Sitecore Namespace

[image]

Sitecore 6.4.1 API
Sitecore Namespace
Send Feedback

Classes

 | Class | Description
Public class | AllowNullAttribute | Implements the AllowNullAttribute class.
Public class | ArchivedItemFieldIDs | Fields of the Tasks/Command template.
Public class | AssertionConditionAttribute |
Public class | AssertionMethodAttribute | Implements the NullableAttribute.
Public class | BaseTypeRequiredAttribute |
Public class | BlockedPage |
Public class | CachePrefix | Implements a static class for holding string prefixes for cache operations.
Public class | CanBeNullAttribute | Implements the CanBeNullAttribute.
Public class | CannotApplyEqualityOperatorAttribute |
Public class | Client |
Public class | CommandFieldIDs | Fields of the Tasks/Command template.
Public class | CommandsCommandFieldIDs | Fields of the Commands/Command template.
Public class | Constants | Implements a static class for holding miscellaneous constantvalues.
Public class | Context | Represents the current state for this request.
Public class | Context..::..ContextData | Represents the context data.
Public class | Context..::..PageDesigner | Represents the Page Designer.
Public class | Context..::..PageMode | Retrieves information about the current page mode.
Public class | Convert | Provides conversion utility functions for a number of types.
Public class | DateUtil | Implements a utility class for manipulating dates.
Public class | DefaultPage | Defines the default page class.
Public class | DeviceFieldIDs | Fields of the Layout/Device template.
Public class | Disposable | Provides a base class for implementing classes that must be disposed.
Public class | EventHandlerInfo | Information about event handler.
Public class | FieldIDs | Implements a static class for holding well-known GUIDs relating to fields.
Public class | Globals | Represents the global data.
Public class | Handle | Represents a handle.
Public class | InvokerParameterNameAttribute |
Public class | ItemIDs | Implements a static class for holding assorted well-known GUID values.
Public class | ItemIDs..::..Analytics | Defines the analytics class.
Public class | ItemIDs..::..Analytics..::..MarketingCenter | Defines the reports class.
Public class | ItemIDs..::..Analytics..::..Reports | Defines the reports class.
Public class | LayoutFieldIDs | Fields of the Layout/Layout template.
Public class | MainUtil | Implements a library of standard utility functions.
Public class | MeansImplicitUseAttribute | Should be used on attributes and causes ReSharper to not mark symbols marked with such attributes as unused (as well as by other usage inspections)
Public class | NotNullAttribute | Implements the NotNullAttribute.
Public class | PackageRegistrationFieldIDs | Fields of the 'Packages/Package registration' template.
Public class | RenderingIDs | Implements a static class for holding assorted well-known GUID values.
Public class | RoleFieldIDs | Fields of the Security/Role template.
Public class | ScheduleFieldIDs | Fields of the Tasks/Schedule template.
Public class | SecurityDatabaseTemplateIDs | Implements a static class for holding well-known GUIDs relating to templates.
Public class | ShellFieldIDs | Implements a static class for holding assorted well-known GUID values.
Public class | StringFormatMethodAttribute |
Public class | StringUtil | Implements a utility class for manipulating strings.
Public class | SystemFieldIDs | Obsolete. Implements a static class for holding well-known GUIDs relating to system fields.
Public class | TemplateFieldIDs | Implements a static class for holding well-known GUIDs relating to template fields.
Public class | TemplateIDs | Implements a static class for holding well-known GUIDs relating to templates.
Public class | TemplateSectionFieldIDs | Implements a static class for holding well-known GUIDs relating to template sections.
Public class | TerminatesProgramAttribute |
Public class | Todo | Obsolete. Todo marker
Public class | UIUtil | Implements helper functions.
Public class | UsedImplicitlyAttribute | Indicates that the marked symbol is used implicitly (ex. reflection, external library), so this symbol will not be marked as unused (as well as by other usage inspections)
Public class | UserFieldIDs | Fields of the Security/User template.
Public class | WebDAVUtil | Web DAV Utils.
Public class | WorkflowFieldIDs | Implements a static class for holding assorted well-known GUID values.

Interfaces

 | Interface | Description
Public interface | IPublishingRequest | Represents a publishing request.
Public interface | IPublishingStatus | Represents a publishing status.

Enumerations

 | Enumeration | Description
Public enumeration | AssertionConditionType |
Public enumeration | DaysOfWeek | Specifies a days of week enumeration.
Public enumeration | FeatureState | Defines possible states of the Sitecore Features
Public enumeration | ImplicitUseFlags |
Public enumeration | Tristate | Represents a tristate.

Send comments on this topic to dv@sitecore.net

(c) Sitecore A/S. All rights reserved.Send comments about this topic to Sitecore.


AllowNullAttribute Class

[image]

Sitecore 6.4.1 API
AllowNullAttribute Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public sealed class AllowNullAttribute : Attribute
Visual Basic
Public NotInheritable Class AllowNullAttribute _
    Inherits Attribute
Visual C++
public ref class AllowNullAttribute sealed : public Attribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Sitecore..::..AllowNullAttribute

See Also

AllowNullAttribute Members
Sitecore Namespace


AllowNullAttribute Members

[image] [image]

Sitecore 6.4.1 API
AllowNullAttribute Members
AllowNullAttribute Class Constructors Methods Properties See Also Send Feedback

The AllowNullAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | AllowNullAttribute | Initializes a new instance of the AllowNullAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | Gets or sets the name.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

AllowNullAttribute Class
Sitecore Namespace


AllowNullAttribute Constructor

[image]

Sitecore 6.4.1 API
AllowNullAttribute Constructor
AllowNullAttribute Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AllowNullAttribute(
    string name
)
Visual Basic
Public Sub New ( _
    name As String _
)
Visual C++
public:
AllowNullAttribute(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

See Also

AllowNullAttribute Class
Sitecore Namespace


AllowNullAttribute Methods

[image] [image]

Sitecore 6.4.1 API
AllowNullAttribute Methods
AllowNullAttribute Class See Also Send Feedback

The AllowNullAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AllowNullAttribute Class
Sitecore Namespace


AllowNullAttribute Properties

[image] [image]

Sitecore 6.4.1 API
AllowNullAttribute Properties
AllowNullAttribute Class See Also Send Feedback

The AllowNullAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets or sets the name.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

AllowNullAttribute Class
Sitecore Namespace


Name Property

[image]

Sitecore 6.4.1 API
AllowNullAttribute..::..Name Property
AllowNullAttribute Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Field Value

The name.

See Also

AllowNullAttribute Class
Sitecore Namespace


ArchivedItemFieldIDs Class

[image]

Sitecore 6.4.1 API
ArchivedItemFieldIDs Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class ArchivedItemFieldIDs
Visual Basic
Public NotInheritable Class ArchivedItemFieldIDs
Visual C++
public ref class ArchivedItemFieldIDs abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore..::..ArchivedItemFieldIDs

See Also

ArchivedItemFieldIDs Members
Sitecore Namespace


ArchivedItemFieldIDs Members

[image] [image]

Sitecore 6.4.1 API
ArchivedItemFieldIDs Members
ArchivedItemFieldIDs Class Fields See Also Send Feedback

The ArchivedItemFieldIDs type exposes the following members.

Fields

Name | Description
ArchiveDate | The ID of the 'Archive date' field.
Completed | The ID of the 'Completed' field.
DatabaseName | The ID of the 'Database name' field.
ItemID | The ID of the 'Item ID' field.
ItemXml | The ID of the 'Item data' field.
ParentID | The ID of the 'Parent ID' field.
UserName | The ID of the 'User' field.

See Also

ArchivedItemFieldIDs Class
Sitecore Namespace


ArchivedItemFieldIDs Fields

[image] [image]

Sitecore 6.4.1 API
ArchivedItemFieldIDs Fields
ArchivedItemFieldIDs Class See Also Send Feedback

The ArchivedItemFieldIDs type exposes the following members.

Fields

Name | Description
ArchiveDate | The ID of the 'Archive date' field.
Completed | The ID of the 'Completed' field.
DatabaseName | The ID of the 'Database name' field.
ItemID | The ID of the 'Item ID' field.
ItemXml | The ID of the 'Item data' field.
ParentID | The ID of the 'Parent ID' field.
UserName | The ID of the 'User' field.

See Also

ArchivedItemFieldIDs Class
Sitecore Namespace


ArchiveDate Field

[image]

Sitecore 6.4.1 API
ArchivedItemFieldIDs..::..ArchiveDate Field
ArchivedItemFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID ArchiveDate
Visual Basic
Public Shared ArchiveDate As ID
Visual C++
public:
static ID^ ArchiveDate

See Also

ArchivedItemFieldIDs Class
Sitecore Namespace


Completed Field

[image]

Sitecore 6.4.1 API
ArchivedItemFieldIDs..::..Completed Field
ArchivedItemFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Completed
Visual Basic
Public Shared Completed As ID
Visual C++
public:
static ID^ Completed

See Also

ArchivedItemFieldIDs Class
Sitecore Namespace


DatabaseName Field

[image]

Sitecore 6.4.1 API
ArchivedItemFieldIDs..::..DatabaseName Field
ArchivedItemFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID DatabaseName
Visual Basic
Public Shared DatabaseName As ID
Visual C++
public:
static ID^ DatabaseName

See Also

ArchivedItemFieldIDs Class
Sitecore Namespace


ItemID Field

[image]

Sitecore 6.4.1 API
ArchivedItemFieldIDs..::..ItemID Field
ArchivedItemFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID ItemID
Visual Basic
Public Shared ItemID As ID
Visual C++
public:
static ID^ ItemID

See Also

ArchivedItemFieldIDs Class
Sitecore Namespace


ItemXml Field

[image]

Sitecore 6.4.1 API
ArchivedItemFieldIDs..::..ItemXml Field
ArchivedItemFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID ItemXml
Visual Basic
Public Shared ItemXml As ID
Visual C++
public:
static ID^ ItemXml

See Also

ArchivedItemFieldIDs Class
Sitecore Namespace


ParentID Field

[image]

Sitecore 6.4.1 API
ArchivedItemFieldIDs..::..ParentID Field
ArchivedItemFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID ParentID
Visual Basic
Public Shared ParentID As ID
Visual C++
public:
static ID^ ParentID

See Also

ArchivedItemFieldIDs Class
Sitecore Namespace


UserName Field

[image]

Sitecore 6.4.1 API
ArchivedItemFieldIDs..::..UserName Field
ArchivedItemFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID UserName
Visual Basic
Public Shared UserName As ID
Visual C++
public:
static ID^ UserName

See Also

ArchivedItemFieldIDs Class
Sitecore Namespace


AssertionConditionAttribute Class

[image]

Sitecore 6.4.1 API
AssertionConditionAttribute Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class AssertionConditionAttribute : Attribute
Visual Basic
Public Class AssertionConditionAttribute _
    Inherits Attribute
Visual C++
public ref class AssertionConditionAttribute : public Attribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Sitecore..::..AssertionConditionAttribute

See Also

AssertionConditionAttribute Members
Sitecore Namespace


AssertionConditionAttribute Members

[image] [image]

Sitecore 6.4.1 API
AssertionConditionAttribute Members
AssertionConditionAttribute Class Constructors Methods Properties See Also Send Feedback

The AssertionConditionAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | AssertionConditionAttribute | Initializes a new instance of the AssertionConditionAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConditionType | Gets the type of the condition.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

AssertionConditionAttribute Class
Sitecore Namespace


AssertionConditionAttribute Constructor

[image]

Sitecore 6.4.1 API
AssertionConditionAttribute Constructor
AssertionConditionAttribute Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AssertionConditionAttribute(
    AssertionConditionType conditionType
)
Visual Basic
Public Sub New ( _
    conditionType As AssertionConditionType _
)
Visual C++
public:
AssertionConditionAttribute(
    AssertionConditionType conditionType
)

Parameters

conditionType
Type: Sitecore..::..AssertionConditionType
Type of the condition.

See Also

AssertionConditionAttribute Class
Sitecore Namespace


AssertionConditionAttribute Methods

[image] [image]

Sitecore 6.4.1 API
AssertionConditionAttribute Methods
AssertionConditionAttribute Class See Also Send Feedback

The AssertionConditionAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssertionConditionAttribute Class
Sitecore Namespace


AssertionConditionAttribute Properties

[image] [image]

Sitecore 6.4.1 API
AssertionConditionAttribute Properties
AssertionConditionAttribute Class See Also Send Feedback

The AssertionConditionAttribute type exposes the following members.

Properties

 | Name | Description
Public property | ConditionType | Gets the type of the condition.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

AssertionConditionAttribute Class
Sitecore Namespace


ConditionType Property

[image]

Sitecore 6.4.1 API
AssertionConditionAttribute..::..ConditionType Property
AssertionConditionAttribute Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AssertionConditionType ConditionType { get; }
Visual Basic
Public ReadOnly Property ConditionType As AssertionConditionType
    Get
Visual C++
public:
property AssertionConditionType ConditionType {
    AssertionConditionType get ();
}

Field Value

The type of the condition.

See Also

AssertionConditionAttribute Class
Sitecore Namespace


AssertionConditionType Enumeration

[image]

Sitecore 6.4.1 API
AssertionConditionType Enumeration
See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum AssertionConditionType
Visual Basic
Public Enumeration AssertionConditionType
Visual C++
public enum class AssertionConditionType

Members

Member name | Value | Description
IS_TRUE | 0 |
IS_FALSE | 1 |
IS_NULL | 2 |
IS_NOT_NULL | 3 |

See Also

Sitecore Namespace


AssertionMethodAttribute Members

[image] [image]

Sitecore 6.4.1 API
AssertionMethodAttribute Members
AssertionMethodAttribute Class Constructors Methods Properties See Also Send Feedback

The AssertionMethodAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | AssertionMethodAttribute | Initializes a new instance of the AssertionMethodAttribute class

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

AssertionMethodAttribute Class
Sitecore Namespace


AssertionMethodAttribute Constructor

[image]

Sitecore 6.4.1 API
AssertionMethodAttribute Constructor
AssertionMethodAttribute Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AssertionMethodAttribute()
Visual Basic
Public Sub New
Visual C++
public:
AssertionMethodAttribute()

See Also

AssertionMethodAttribute Class
Sitecore Namespace


AssertionMethodAttribute Methods

[image] [image]

Sitecore 6.4.1 API
AssertionMethodAttribute Methods
AssertionMethodAttribute Class See Also Send Feedback

The AssertionMethodAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssertionMethodAttribute Class
Sitecore Namespace


AssertionMethodAttribute Properties

[image] [image]

Sitecore 6.4.1 API
AssertionMethodAttribute Properties
AssertionMethodAttribute Class See Also Send Feedback

The AssertionMethodAttribute type exposes the following members.

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

AssertionMethodAttribute Class
Sitecore Namespace


BaseTypeRequiredAttribute Class

[image]

Sitecore 6.4.1 API
BaseTypeRequiredAttribute Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class BaseTypeRequiredAttribute : Attribute
Visual Basic
Public Class BaseTypeRequiredAttribute _
    Inherits Attribute
Visual C++
public ref class BaseTypeRequiredAttribute : public Attribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Sitecore..::..BaseTypeRequiredAttribute

See Also

BaseTypeRequiredAttribute Members
Sitecore Namespace


BaseTypeRequiredAttribute Members

[image] [image]

Sitecore 6.4.1 API
BaseTypeRequiredAttribute Members
BaseTypeRequiredAttribute Class Constructors Methods Properties See Also Send Feedback

The BaseTypeRequiredAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | BaseTypeRequiredAttribute(Type) | Initializes a new instance of the BaseTypeRequiredAttribute class.
Public method | BaseTypeRequiredAttribute(array<Type>[]()[][]) | Initializes a new instance of the BaseTypeRequiredAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BaseTypes | Gets the base types.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

BaseTypeRequiredAttribute Class
Sitecore Namespace


BaseTypeRequiredAttribute Constructor

[image] [image]

Sitecore 6.4.1 API
BaseTypeRequiredAttribute Constructor
BaseTypeRequiredAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BaseTypeRequiredAttribute(Type) | Initializes a new instance of the BaseTypeRequiredAttribute class.
Public method | BaseTypeRequiredAttribute(array<Type>[]()[][]) | Initializes a new instance of the BaseTypeRequiredAttribute class.

See Also

BaseTypeRequiredAttribute Class
BaseTypeRequiredAttribute Members
Sitecore Namespace


BaseTypeRequiredAttribute Constructor (Type)

[image]

Sitecore 6.4.1 API
BaseTypeRequiredAttribute Constructor (Type)
BaseTypeRequiredAttribute Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BaseTypeRequiredAttribute(
    Type baseType
)
Visual Basic
Public Sub New ( _
    baseType As Type _
)
Visual C++
public:
BaseTypeRequiredAttribute(
    Type^ baseType
)

Parameters

baseType
Type: System..::..Type
Type of the base.

See Also

BaseTypeRequiredAttribute Class
BaseTypeRequiredAttribute Overload
Sitecore Namespace


BaseTypeRequiredAttribute Constructor (Type[])

[image]

Sitecore 6.4.1 API
BaseTypeRequiredAttribute Constructor (array<Type>[]()[][])
BaseTypeRequiredAttribute Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BaseTypeRequiredAttribute(
    Type[] baseTypes
)
Visual Basic
Public Sub New ( _
    baseTypes As Type() _
)
Visual C++
public:
BaseTypeRequiredAttribute(
    array<Type^>^ baseTypes
)

Parameters

baseTypes
Type: array< System..::..Type >[]()[][]
The base types.

See Also

BaseTypeRequiredAttribute Class
BaseTypeRequiredAttribute Overload
Sitecore Namespace


BaseTypeRequiredAttribute Methods

[image] [image]

Sitecore 6.4.1 API
BaseTypeRequiredAttribute Methods
BaseTypeRequiredAttribute Class See Also Send Feedback

The BaseTypeRequiredAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BaseTypeRequiredAttribute Class
Sitecore Namespace


BaseTypeRequiredAttribute Properties

[image] [image]

Sitecore 6.4.1 API
BaseTypeRequiredAttribute Properties
BaseTypeRequiredAttribute Class See Also Send Feedback

The BaseTypeRequiredAttribute type exposes the following members.

Properties

 | Name | Description
Public property | BaseTypes | Gets the base types.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

BaseTypeRequiredAttribute Class
Sitecore Namespace


BaseTypes Property

[image]

Sitecore 6.4.1 API
BaseTypeRequiredAttribute..::..BaseTypes Property
BaseTypeRequiredAttribute Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Type[] BaseTypes { get; }
Visual Basic
Public ReadOnly Property BaseTypes As Type()
    Get
Visual C++
public:
property array<Type^>^ BaseTypes {
    array<Type^>^ get ();
}

Field Value

The base types.

See Also

BaseTypeRequiredAttribute Class
Sitecore Namespace


BlockedPage Class

[image]

Sitecore 6.4.1 API
BlockedPage Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class BlockedPage : Page
Visual Basic
Public Class BlockedPage _
    Inherits Page
Visual C++
public ref class BlockedPage : public Page

Inheritance Hierarchy

System..::..Object
System.Web.UI..::..Control
System.Web.UI..::..TemplateControl
System.Web.UI..::..Page
Sitecore..::..BlockedPage

See Also

BlockedPage Members
Sitecore Namespace


BlockedPage Members

[image] [image]

Sitecore 6.4.1 API
BlockedPage Members
BlockedPage Class Constructors Methods Fields Properties Events See Also Send Feedback

The BlockedPage type exposes the following members.

Constructors

 | Name | Description
Public method | BlockedPage | Initializes a new instance of the BlockedPage class

Methods

 | Name | Description
Protected method | AddContentTemplate | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Public method | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
Public method | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Protected method | AddWrappedFileDependencies | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | AspCompatBeginProcessRequest | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
Protected method | AspCompatEndProcessRequest | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
Protected method | AsyncPageBeginProcessRequest | Begins processing an asynchronous page request. (Inherited from Page.)
Protected method | AsyncPageEndProcessRequest | Ends processing an asynchronous page request. (Inherited from Page.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Protected method | Construct | Performs design-time logic. (Inherited from TemplateControl.)
Protected method | CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Protected method | CreateHtmlTextWriter | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
Protected method | CreateResourceBasedLiteralControl | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Public method | DesignerInitialize | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
Protected method | DeterminePostBackMode | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
Protected method | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
Public method | ExecuteRegisteredAsyncTasks | Starts the execution of an asynchronous task. (Inherited from Page.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | FrameworkInitialize | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
Public method | GetDataItem | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Protected method | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
Protected method | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
Protected method | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
Public method | GetPostBackClientEvent | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
Public method | GetPostBackClientHyperlink | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
Public method | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
Public method | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeHashCode | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
Public method | GetValidators | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
Protected method | GetWrappedFileDependencies | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Protected method | InitializeCulture | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
Protected method | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
Protected method | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
Protected method | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
Public method | IsClientScriptBlockRegistered | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Public method | IsStartupScriptRegistered | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
Public method | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
Public method | LoadControl(Type, array<Object>[]()[][]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
Protected method | LoadPageStateFromPersistenceMedium | Loads any saved view-state information to the Page object. (Inherited from Page.)
Public method | LoadTemplate | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
Protected method | LoadViewState | Restores view-state information from a previous page request that was saved by the SaveViewState()()()() method. (Inherited from Control.)
Public method | MapPath | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAbortTransaction | Raises the AbortTransaction event. (Inherited from TemplateControl.)
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnCommitTransaction | Raises the CommitTransaction event. (Inherited from TemplateControl.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnError | Raises the Error event. (Inherited from TemplateControl.)
Protected method | OnInit | Raises the Init event to initialize the page. (Inherited from Page.)
Protected method | OnInitComplete | Raises the InitComplete event after page initialization. (Inherited from Page.)
Protected method | OnLoad | Raises the Load event. (Inherited from Control.)
Protected method | OnLoadComplete | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
Protected method | OnPreInit | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
Protected method | OnPreLoad | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
Protected method | OnPreRender | Raises the PreRender event. (Inherited from Control.)
Protected method | OnPreRenderComplete | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
Protected method | OnSaveStateComplete | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Protected method | Page_Load | Handles the Load event of the Page control.
Public method | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
Public method | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
Public method | ProcessRequest | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Protected method | RaisePostBackEvent | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
Public method | ReadStringResource | Reads a string resource. The ReadStringResource()()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | RegisterArrayDeclaration | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
Public method | RegisterAsyncTask | Registers a new asynchronous task with the page. (Inherited from Page.)
Public method | RegisterClientScriptBlock | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
Public method | RegisterHiddenField | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
Public method | RegisterOnSubmitStatement | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
Public method | RegisterRequiresControlState | Registers a control as one whose control state must be persisted. (Inherited from Page.)
Public method | RegisterRequiresPostBack | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
Public method | RegisterRequiresRaiseEvent | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
Public method | RegisterRequiresViewStateEncryption | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
Public method | RegisterStartupScript | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
Public method | RegisterViewStateHandler | Causes page view state to be persisted, if called. (Inherited from Page.)
Protected method | RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Protected method | Render | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Public method | RequiresControlState | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SavePageStateToPersistenceMedium | Saves any view-state and control-state information for the page. (Inherited from Page.)
Protected method | SaveViewState | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
Public method | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Protected method | SetStringResourcePointer | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | TestDeviceFilter | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TrackViewState | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
Public method | UnregisterRequiresControlState | Stops persistence of control state for the specified control. (Inherited from Page.)
Public method | Validate()()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
Public method | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
Public method | VerifyRenderingInServerForm | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
Protected method | WriteUTF8ResourceString | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
Protected method | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
Protected method | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
Protected method | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
Protected method | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
Protected method | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Protected method | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)

Fields

 | Name | Description
Protected field | form1 | form1 control.

Properties

 | Name | Description
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
Protected property | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
Protected property | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
Public property | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
Protected property | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
Public property | AutoPostBackControl | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
Public property | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Public property | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
Public property | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
Public property | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
Public property | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
Public property | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
Protected property | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
Public property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
Public property | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Public property | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
Public property | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
Public property | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
Public property | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
Public property | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Protected property | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
Public property | Form | Gets the HTML form for the page. (Inherited from Page.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Public property | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
Public property | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
Public property | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
Public property | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
Public property | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Public property | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
Public property | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
Public property | IsPostBackEventControlRegistered | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
Public property | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Public property | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Public property | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
Public property | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Public property | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
Public property | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
Public property | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
Public property | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
Protected property | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
Public property | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
Public property | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
Public property | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
Public property | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
Public property | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
Public property | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
Public property | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
Public property | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
Protected property | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
Public property | Title | Gets or sets the title for the page. (Inherited from Page.)
Public property | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
Public property | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
Public property | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
Protected property | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
Public property | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
Protected property | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
Public property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
Public property | User | Gets information about the user making the page request. (Inherited from Page.)
Public property | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Public property | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
Public property | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)

Events

 | Name | Description
Public event | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
Public event | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
Public event | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
Public event | PreLoad | Occurs before the page Load event. (Inherited from Page.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
Public event | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

See Also

BlockedPage Class
Sitecore Namespace


BlockedPage Constructor

[image]

Sitecore 6.4.1 API
BlockedPage Constructor
BlockedPage Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BlockedPage()
Visual Basic
Public Sub New
Visual C++
public:
BlockedPage()

See Also

BlockedPage Class
Sitecore Namespace


BlockedPage Fields

[image] [image]

Sitecore 6.4.1 API
BlockedPage Fields
BlockedPage Class See Also Send Feedback

The BlockedPage type exposes the following members.

Fields

 | Name | Description
Protected field | form1 | form1 control.

See Also

BlockedPage Class
Sitecore Namespace


form1 Field

[image]

Sitecore 6.4.1 API
BlockedPage..::..form1 Field
BlockedPage Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected HtmlForm form1
Visual Basic
Protected form1 As HtmlForm
Visual C++
protected:
HtmlForm^ form1

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

BlockedPage Class
Sitecore Namespace


BlockedPage Methods

[image] [image]

Sitecore 6.4.1 API
BlockedPage Methods
BlockedPage Class See Also Send Feedback

The BlockedPage type exposes the following members.

Methods

 | Name | Description
Protected method | AddContentTemplate | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Public method | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
Public method | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Protected method | AddWrappedFileDependencies | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | AspCompatBeginProcessRequest | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
Protected method | AspCompatEndProcessRequest | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
Protected method | AsyncPageBeginProcessRequest | Begins processing an asynchronous page request. (Inherited from Page.)
Protected method | AsyncPageEndProcessRequest | Ends processing an asynchronous page request. (Inherited from Page.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Protected method | Construct | Performs design-time logic. (Inherited from TemplateControl.)
Protected method | CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Protected method | CreateHtmlTextWriter | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
Protected method | CreateResourceBasedLiteralControl | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Public method | DesignerInitialize | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
Protected method | DeterminePostBackMode | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
Protected method | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
Public method | ExecuteRegisteredAsyncTasks | Starts the execution of an asynchronous task. (Inherited from Page.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | FrameworkInitialize | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
Public method | GetDataItem | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Protected method | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
Protected method | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
Protected method | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
Public method | GetPostBackClientEvent | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
Public method | GetPostBackClientHyperlink | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
Public method | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
Public method | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeHashCode | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
Public method | GetValidators | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
Protected method | GetWrappedFileDependencies | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Protected method | InitializeCulture | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
Protected method | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
Protected method | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
Protected method | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
Public method | IsClientScriptBlockRegistered | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Public method | IsStartupScriptRegistered | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
Public method | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
Public method | LoadControl(Type, array<Object>[]()[][]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
Protected method | LoadPageStateFromPersistenceMedium | Loads any saved view-state information to the Page object. (Inherited from Page.)
Public method | LoadTemplate | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
Protected method | LoadViewState | Restores view-state information from a previous page request that was saved by the SaveViewState()()()() method. (Inherited from Control.)
Public method | MapPath | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAbortTransaction | Raises the AbortTransaction event. (Inherited from TemplateControl.)
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnCommitTransaction | Raises the CommitTransaction event. (Inherited from TemplateControl.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnError | Raises the Error event. (Inherited from TemplateControl.)
Protected method | OnInit | Raises the Init event to initialize the page. (Inherited from Page.)
Protected method | OnInitComplete | Raises the InitComplete event after page initialization. (Inherited from Page.)
Protected method | OnLoad | Raises the Load event. (Inherited from Control.)
Protected method | OnLoadComplete | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
Protected method | OnPreInit | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
Protected method | OnPreLoad | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
Protected method | OnPreRender | Raises the PreRender event. (Inherited from Control.)
Protected method | OnPreRenderComplete | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
Protected method | OnSaveStateComplete | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Protected method | Page_Load | Handles the Load event of the Page control.
Public method | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
Public method | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
Public method | ProcessRequest | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Protected method | RaisePostBackEvent | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
Public method | ReadStringResource | Reads a string resource. The ReadStringResource()()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | RegisterArrayDeclaration | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
Public method | RegisterAsyncTask | Registers a new asynchronous task with the page. (Inherited from Page.)
Public method | RegisterClientScriptBlock | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
Public method | RegisterHiddenField | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
Public method | RegisterOnSubmitStatement | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
Public method | RegisterRequiresControlState | Registers a control as one whose control state must be persisted. (Inherited from Page.)
Public method | RegisterRequiresPostBack | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
Public method | RegisterRequiresRaiseEvent | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
Public method | RegisterRequiresViewStateEncryption | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
Public method | RegisterStartupScript | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
Public method | RegisterViewStateHandler | Causes page view state to be persisted, if called. (Inherited from Page.)
Protected method | RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Protected method | Render | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Public method | RequiresControlState | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SavePageStateToPersistenceMedium | Saves any view-state and control-state information for the page. (Inherited from Page.)
Protected method | SaveViewState | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
Public method | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Protected method | SetStringResourcePointer | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | TestDeviceFilter | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TrackViewState | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
Public method | UnregisterRequiresControlState | Stops persistence of control state for the specified control. (Inherited from Page.)
Public method | Validate()()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
Public method | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
Public method | VerifyRenderingInServerForm | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
Protected method | WriteUTF8ResourceString | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
Protected method | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
Protected method | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
Protected method | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
Protected method | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
Protected method | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Protected method | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)

See Also

BlockedPage Class
Sitecore Namespace


AddOnPreRenderCompleteAsync Method

[image] [image]

Sitecore 6.4.1 API
BlockedPage..::..AddOnPreRenderCompleteAsync Method
BlockedPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
Public method | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)

See Also

BlockedPage Class
BlockedPage Members
Sitecore Namespace


DataBind Method

[image] [image]

Sitecore 6.4.1 API
BlockedPage..::..DataBind Method
BlockedPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)

See Also

BlockedPage Class
BlockedPage Members
Sitecore Namespace


Eval Method

[image] [image]

Sitecore 6.4.1 API
BlockedPage..::..Eval Method
BlockedPage Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
Protected method | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)

See Also

BlockedPage Class
BlockedPage Members
Sitecore Namespace


FindControl Method

[image] [image]

Sitecore 6.4.1 API
BlockedPage..::..FindControl Method
BlockedPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)

See Also

BlockedPage Class
BlockedPage Members
Sitecore Namespace


GetGlobalResourceObject Method

[image] [image]

Sitecore 6.4.1 API
BlockedPage..::..GetGlobalResourceObject Method
BlockedPage Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
Protected method | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)

See Also

BlockedPage Class
BlockedPage Members
Sitecore Namespace


GetLocalResourceObject Method

[image] [image]

Sitecore 6.4.1 API
BlockedPage..::..GetLocalResourceObject Method
BlockedPage Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
Protected method | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)

See Also

BlockedPage Class
BlockedPage Members
Sitecore Namespace


GetPostBackEventReference Method

[image] [image]

Sitecore 6.4.1 API
BlockedPage..::..GetPostBackEventReference Method
BlockedPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
Public method | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)

See Also

BlockedPage Class
BlockedPage Members
Sitecore Namespace


InitOutputCache Method

[image] [image]

Sitecore 6.4.1 API
BlockedPage..::..InitOutputCache Method
BlockedPage Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
Protected method | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
Protected method | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)

See Also

BlockedPage Class
BlockedPage Members
Sitecore Namespace


LoadControl Method

[image] [image]

Sitecore 6.4.1 API
BlockedPage..::..LoadControl Method
BlockedPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
Public method | LoadControl(Type, array<Object>[]()[][]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)

See Also

BlockedPage Class
BlockedPage Members
Sitecore Namespace


Page_Load Method

[image]

Sitecore 6.4.1 API
BlockedPage..::..Page_Load Method
BlockedPage Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Visual Basic
Protected Sub Page_Load ( _
    sender As Object, _
    e As EventArgs _
)
Visual C++
protected:
void Page_Load(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: System..::..Object
The source of the event.
e
Type: System..::..EventArgs
The EventArgs instance containing the event data.

See Also

BlockedPage Class
Sitecore Namespace


ParseControl Method

[image] [image]

Sitecore 6.4.1 API
BlockedPage..::..ParseControl Method
BlockedPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
Public method | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)

See Also

BlockedPage Class
BlockedPage Members
Sitecore Namespace


RenderControl Method

[image] [image]

Sitecore 6.4.1 API
BlockedPage..::..RenderControl Method
BlockedPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)

See Also

BlockedPage Class
BlockedPage Members
Sitecore Namespace


SetFocus Method

[image] [image]

Sitecore 6.4.1 API
BlockedPage..::..SetFocus Method
BlockedPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
Public method | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)

See Also

BlockedPage Class
BlockedPage Members
Sitecore Namespace


Validate Method

[image] [image]

Sitecore 6.4.1 API
BlockedPage..::..Validate Method
BlockedPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Validate()()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
Public method | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)

See Also

BlockedPage Class
BlockedPage Members
Sitecore Namespace


XPath Method

[image] [image]

Sitecore 6.4.1 API
BlockedPage..::..XPath Method
BlockedPage Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
Protected method | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
Protected method | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
Protected method | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)

See Also

BlockedPage Class
BlockedPage Members
Sitecore Namespace


XPathSelect Method

[image] [image]

Sitecore 6.4.1 API
BlockedPage..::..XPathSelect Method
BlockedPage Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Protected method | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)

See Also

BlockedPage Class
BlockedPage Members
Sitecore Namespace


BlockedPage Properties

[image] [image]

Sitecore 6.4.1 API
BlockedPage Properties
BlockedPage Class See Also Send Feedback

The BlockedPage type exposes the following members.

Properties

 | Name | Description
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
Protected property | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
Protected property | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
Public property | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
Protected property | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
Public property | AutoPostBackControl | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
Public property | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Public property | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
Public property | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
Public property | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
Public property | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
Public property | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
Protected property | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
Public property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
Public property | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Public property | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
Public property | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
Public property | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
Public property | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
Public property | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Protected property | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
Public property | Form | Gets the HTML form for the page. (Inherited from Page.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Public property | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
Public property | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
Public property | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
Public property | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
Public property | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Public property | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
Public property | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
Public property | IsPostBackEventControlRegistered | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
Public property | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Public property | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Public property | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
Public property | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Public property | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
Public property | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
Public property | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
Public property | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
Protected property | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
Public property | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
Public property | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
Public property | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
Public property | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
Public property | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
Public property | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
Public property | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
Public property | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
Protected property | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
Public property | Title | Gets or sets the title for the page. (Inherited from Page.)
Public property | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
Public property | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
Public property | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
Protected property | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
Public property | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
Protected property | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
Public property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
Public property | User | Gets information about the user making the page request. (Inherited from Page.)
Public property | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Public property | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
Public property | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)

See Also

BlockedPage Class
Sitecore Namespace


BlockedPage Events

[image] [image]

Sitecore 6.4.1 API
BlockedPage Events
BlockedPage Class See Also Send Feedback

The BlockedPage type exposes the following members.

Events

 | Name | Description
Public event | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
Public event | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
Public event | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
Public event | PreLoad | Occurs before the page Load event. (Inherited from Page.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
Public event | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

See Also

BlockedPage Class
Sitecore Namespace


CachePrefix Class

[image]

Sitecore 6.4.1 API
CachePrefix Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CachePrefix
Visual Basic
Public Class CachePrefix
Visual C++
public ref class CachePrefix

Remarks

The class does not contain any functionality, but serves as a placeholder for a number of string values.

Inheritance Hierarchy

System..::..Object
Sitecore..::..CachePrefix

See Also

CachePrefix Members
Sitecore Namespace


CachePrefix Constructor

[image]

Sitecore 6.4.1 API
CachePrefix Constructor
CachePrefix Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CachePrefix()
Visual Basic
Public Sub New
Visual C++
public:
CachePrefix()

See Also

CachePrefix Class
Sitecore Namespace


CoreItem Field

[image]

Sitecore 6.4.1 API
CachePrefix..::..CoreItem Field
CachePrefix Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string CoreItem
Visual Basic
Public Const CoreItem As String
Visual C++
public:
literal String^ CoreItem

See Also

CachePrefix Class
Sitecore Namespace


DatabaseCache Field

[image]

Sitecore 6.4.1 API
CachePrefix..::..DatabaseCache Field
CachePrefix Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string DatabaseCache
Visual Basic
Public Const DatabaseCache As String
Visual C++
public:
literal String^ DatabaseCache

See Also

CachePrefix Class
Sitecore Namespace


DomainUser Field

[image]

Sitecore 6.4.1 API
CachePrefix..::..DomainUser Field
CachePrefix Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string DomainUser
Visual Basic
Public Const DomainUser As String
Visual C++
public:
literal String^ DomainUser

See Also

CachePrefix Class
Sitecore Namespace


DomainUserData Field

[image]

Sitecore 6.4.1 API
CachePrefix..::..DomainUserData Field
CachePrefix Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string DomainUserData
Visual Basic
Public Const DomainUserData As String
Visual C++
public:
literal String^ DomainUserData

See Also

CachePrefix Class
Sitecore Namespace


Html Field

[image]

Sitecore 6.4.1 API
CachePrefix..::..Html Field
CachePrefix Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string Html
Visual Basic
Public Const Html As String
Visual C++
public:
literal String^ Html

See Also

CachePrefix Class
Sitecore Namespace


IndexCache Field

[image]

Sitecore 6.4.1 API
CachePrefix..::..IndexCache Field
CachePrefix Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string IndexCache
Visual Basic
Public Const IndexCache As String
Visual C++
public:
literal String^ IndexCache

See Also

CachePrefix Class
Sitecore Namespace


ItemDefinition Field

[image]

Sitecore 6.4.1 API
CachePrefix..::..ItemDefinition Field
CachePrefix Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string ItemDefinition
Visual Basic
Public Const ItemDefinition As String
Visual C++
public:
literal String^ ItemDefinition

See Also

CachePrefix Class
Sitecore Namespace


ItemVersion Field

[image]

Sitecore 6.4.1 API
CachePrefix..::..ItemVersion Field
CachePrefix Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string ItemVersion
Visual Basic
Public Const ItemVersion As String
Visual C++
public:
literal String^ ItemVersion

See Also

CachePrefix Class
Sitecore Namespace


RenderingList Field

[image]

Sitecore 6.4.1 API
CachePrefix..::..RenderingList Field
CachePrefix Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string RenderingList
Visual Basic
Public Const RenderingList As String
Visual C++
public:
literal String^ RenderingList

See Also

CachePrefix Class
Sitecore Namespace


SubDatabases Field

[image]

Sitecore 6.4.1 API
CachePrefix..::..SubDatabases Field
CachePrefix Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string SubDatabases
Visual Basic
Public Const SubDatabases As String
Visual C++
public:
literal String^ SubDatabases

See Also

CachePrefix Class
Sitecore Namespace


Xsl Field

[image]

Sitecore 6.4.1 API
CachePrefix..::..Xsl Field
CachePrefix Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string Xsl
Visual Basic
Public Const Xsl As String
Visual C++
public:
literal String^ Xsl

See Also

CachePrefix Class
Sitecore Namespace


CachePrefix Methods

[image] [image]

Sitecore 6.4.1 API
CachePrefix Methods
CachePrefix Class See Also Send Feedback

The CachePrefix type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CachePrefix Class
Sitecore Namespace


CanBeNullAttribute Members

[image] [image]

Sitecore 6.4.1 API
CanBeNullAttribute Members
CanBeNullAttribute Class Constructors Methods Properties See Also Send Feedback

The CanBeNullAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | CanBeNullAttribute | Initializes a new instance of the CanBeNullAttribute class

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

CanBeNullAttribute Class
Sitecore Namespace


CanBeNullAttribute Constructor

[image]

Sitecore 6.4.1 API
CanBeNullAttribute Constructor
CanBeNullAttribute Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CanBeNullAttribute()
Visual Basic
Public Sub New
Visual C++
public:
CanBeNullAttribute()

See Also

CanBeNullAttribute Class
Sitecore Namespace


CanBeNullAttribute Methods

[image] [image]

Sitecore 6.4.1 API
CanBeNullAttribute Methods
CanBeNullAttribute Class See Also Send Feedback

The CanBeNullAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CanBeNullAttribute Class
Sitecore Namespace


CanBeNullAttribute Properties

[image] [image]

Sitecore 6.4.1 API
CanBeNullAttribute Properties
CanBeNullAttribute Class See Also Send Feedback

The CanBeNullAttribute type exposes the following members.

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

CanBeNullAttribute Class
Sitecore Namespace


CannotApplyEqualityOperatorAttribute Class

[image]

Sitecore 6.4.1 API
CannotApplyEqualityOperatorAttribute Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CannotApplyEqualityOperatorAttribute : Attribute
Visual Basic
Public Class CannotApplyEqualityOperatorAttribute _
    Inherits Attribute
Visual C++
public ref class CannotApplyEqualityOperatorAttribute : public Attribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Sitecore..::..CannotApplyEqualityOperatorAttribute

See Also

CannotApplyEqualityOperatorAttribute Members
Sitecore Namespace


CannotApplyEqualityOperatorAttribute Members

[image] [image]

Sitecore 6.4.1 API
CannotApplyEqualityOperatorAttribute Members
CannotApplyEqualityOperatorAttribute Class Constructors Methods Properties See Also Send Feedback

The CannotApplyEqualityOperatorAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | CannotApplyEqualityOperatorAttribute | Initializes a new instance of the CannotApplyEqualityOperatorAttribute class

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

CannotApplyEqualityOperatorAttribute Class
Sitecore Namespace


CannotApplyEqualityOperatorAttribute Constructor

[image]

Sitecore 6.4.1 API
CannotApplyEqualityOperatorAttribute Constructor
CannotApplyEqualityOperatorAttribute Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CannotApplyEqualityOperatorAttribute()
Visual Basic
Public Sub New
Visual C++
public:
CannotApplyEqualityOperatorAttribute()

See Also

CannotApplyEqualityOperatorAttribute Class
Sitecore Namespace


CannotApplyEqualityOperatorAttribute Methods

[image] [image]

Sitecore 6.4.1 API
CannotApplyEqualityOperatorAttribute Methods
CannotApplyEqualityOperatorAttribute Class See Also Send Feedback

The CannotApplyEqualityOperatorAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CannotApplyEqualityOperatorAttribute Class
Sitecore Namespace


CannotApplyEqualityOperatorAttribute Properties

[image] [image]

Sitecore 6.4.1 API
CannotApplyEqualityOperatorAttribute Properties
CannotApplyEqualityOperatorAttribute Class See Also Send Feedback

The CannotApplyEqualityOperatorAttribute type exposes the following members.

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

CannotApplyEqualityOperatorAttribute Class
Sitecore Namespace


Client Class

[image]

Sitecore 6.4.1 API
Client Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Client
Visual Basic
Public NotInheritable Class Client
Visual C++
public ref class Client abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore..::..Client

See Also

Client Members
Sitecore Namespace


Client Members

[image] [image]

Sitecore 6.4.1 API
Client Members
Client Class Methods Properties See Also Send Feedback

The Client type exposes the following members.

Methods

Name | Description
GetDatabaseNotNull | Gets the database.
GetItemNotNull(String) | Gets the item not null.
GetItemNotNull(ID) | Gets the item ensuring that it is not null.
GetItemNotNull(ItemUri) | Gets the item ensuring that it is not null.
GetItemNotNull(String, Database) | Gets the item not null.
GetItemNotNull(String, Language) | Gets the item not null.
GetItemNotNull(ID, Language) | Gets the item ensuring that it is not null.
GetItemNotNull(String, Language, Version) | Gets the item not null.
GetItemNotNull(ID, Language, Version) | Gets the item not null.
GetItemNotNull(String, Language, Version, Database) | Gets the item not null.
GetItemNotNull(ID, Language, Version, Database) | Gets the item ensuring that it is not null.

Properties

Name | Description
AjaxScriptManager | Gets the current ajax script manager, asserts its presence.
ContentDatabase | Gets the content database.
CoreDatabase | Gets the core database.
Device | Gets the device.
Page | Gets the page.
Site | Gets the site.

See Also

Client Class
Sitecore Namespace


Client Methods

[image] [image]

Sitecore 6.4.1 API
Client Methods
Client Class See Also Send Feedback

The Client type exposes the following members.

Methods

Name | Description
GetDatabaseNotNull | Gets the database.
GetItemNotNull(String) | Gets the item not null.
GetItemNotNull(ID) | Gets the item ensuring that it is not null.
GetItemNotNull(ItemUri) | Gets the item ensuring that it is not null.
GetItemNotNull(String, Database) | Gets the item not null.
GetItemNotNull(String, Language) | Gets the item not null.
GetItemNotNull(ID, Language) | Gets the item ensuring that it is not null.
GetItemNotNull(String, Language, Version) | Gets the item not null.
GetItemNotNull(ID, Language, Version) | Gets the item not null.
GetItemNotNull(String, Language, Version, Database) | Gets the item not null.
GetItemNotNull(ID, Language, Version, Database) | Gets the item ensuring that it is not null.

See Also

Client Class
Sitecore Namespace


GetItemNotNull Method (String)

[image]

Sitecore 6.4.1 API
Client..::..GetItemNotNull Method (String)
Client Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item GetItemNotNull(
    string itemPath
)
Visual Basic
Public Shared Function GetItemNotNull ( _
    itemPath As String _
) As Item
Visual C++
public:
static Item^ GetItemNotNull(
    String^ itemPath
)

Parameters

itemPath
Type: System..::..String
The item path.

Return Value

The item not null.

See Also

Client Class
GetItemNotNull Overload
Sitecore Namespace


GetItemNotNull Method (ID)

[image]

Sitecore 6.4.1 API
Client..::..GetItemNotNull Method (ID)
Client Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item GetItemNotNull(
    ID itemId
)
Visual Basic
Public Shared Function GetItemNotNull ( _
    itemId As ID _
) As Item
Visual C++
public:
static Item^ GetItemNotNull(
    ID^ itemId
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.

Return Value

The item.

See Also

Client Class
GetItemNotNull Overload
Sitecore Namespace


GetItemNotNull Method (ItemUri)

[image]

Sitecore 6.4.1 API
Client..::..GetItemNotNull Method (ItemUri)
Client Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item GetItemNotNull(
    ItemUri uri
)
Visual Basic
Public Shared Function GetItemNotNull ( _
    uri As ItemUri _
) As Item
Visual C++
public:
static Item^ GetItemNotNull(
    ItemUri^ uri
)

Parameters

uri
Type: Sitecore.Data..::..ItemUri
The URI.

Return Value

The item.

Exceptions

Exception | Condition
Sitecore.Exceptions..::..ItemNullException | ItemNullException.

See Also

Client Class
GetItemNotNull Overload
Sitecore Namespace


GetItemNotNull Method (String, Database)

[image]

Sitecore 6.4.1 API
Client..::..GetItemNotNull Method (String, Database)
Client Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item GetItemNotNull(
    string itemPath,
    Database database
)
Visual Basic
Public Shared Function GetItemNotNull ( _
    itemPath As String, _
    database As Database _
) As Item
Visual C++
public:
static Item^ GetItemNotNull(
    String^ itemPath,
    Database^ database
)

Parameters

itemPath
Type: System..::..String
The item path.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

The item not null.

See Also

Client Class
GetItemNotNull Overload
Sitecore Namespace


GetItemNotNull Method (String, Language)

[image]

Sitecore 6.4.1 API
Client..::..GetItemNotNull Method (String, Language)
Client Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item GetItemNotNull(
    string itemPath,
    Language language
)
Visual Basic
Public Shared Function GetItemNotNull ( _
    itemPath As String, _
    language As Language _
) As Item
Visual C++
public:
static Item^ GetItemNotNull(
    String^ itemPath,
    Language^ language
)

Parameters

itemPath
Type: System..::..String
The item path.
language
Type: Sitecore.Globalization..::..Language
The language.

Return Value

The item not null.

See Also

Client Class
GetItemNotNull Overload
Sitecore Namespace


GetItemNotNull Method (ID, Language)

[image]

Sitecore 6.4.1 API
Client..::..GetItemNotNull Method (ID, Language)
Client Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item GetItemNotNull(
    ID itemId,
    Language language
)
Visual Basic
Public Shared Function GetItemNotNull ( _
    itemId As ID, _
    language As Language _
) As Item
Visual C++
public:
static Item^ GetItemNotNull(
    ID^ itemId,
    Language^ language
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
language
Type: Sitecore.Globalization..::..Language
The language.

Return Value

The item.

See Also

Client Class
GetItemNotNull Overload
Sitecore Namespace


GetItemNotNull Method (String, Language, Version)

[image]

Sitecore 6.4.1 API
Client..::..GetItemNotNull Method (String, Language, Version)
Client Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item GetItemNotNull(
    string itemPath,
    Language language,
    Version version
)
Visual Basic
Public Shared Function GetItemNotNull ( _
    itemPath As String, _
    language As Language, _
    version As Version _
) As Item
Visual C++
public:
static Item^ GetItemNotNull(
    String^ itemPath,
    Language^ language,
    Version^ version
)

Parameters

itemPath
Type: System..::..String
The item path.
language
Type: Sitecore.Globalization..::..Language
The language.
version
Type: Sitecore.Data..::..Version
The version.

Return Value

The item not null.

See Also

Client Class
GetItemNotNull Overload
Sitecore Namespace


GetItemNotNull Method (ID, Language, Version)

[image]

Sitecore 6.4.1 API
Client..::..GetItemNotNull Method (ID, Language, Version)
Client Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item GetItemNotNull(
    ID itemId,
    Language language,
    Version version
)
Visual Basic
Public Shared Function GetItemNotNull ( _
    itemId As ID, _
    language As Language, _
    version As Version _
) As Item
Visual C++
public:
static Item^ GetItemNotNull(
    ID^ itemId,
    Language^ language,
    Version^ version
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
language
Type: Sitecore.Globalization..::..Language
The language.
version
Type: Sitecore.Data..::..Version
The version.

Return Value

The item not null.

See Also

Client Class
GetItemNotNull Overload
Sitecore Namespace


GetItemNotNull Method (String, Language, Version, Database)

[image]

Sitecore 6.4.1 API
Client..::..GetItemNotNull Method (String, Language, Version, Database)
Client Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item GetItemNotNull(
    string itemPath,
    Language language,
    Version version,
    Database database
)
Visual Basic
Public Shared Function GetItemNotNull ( _
    itemPath As String, _
    language As Language, _
    version As Version, _
    database As Database _
) As Item
Visual C++
public:
static Item^ GetItemNotNull(
    String^ itemPath,
    Language^ language,
    Version^ version,
    Database^ database
)

Parameters

itemPath
Type: System..::..String
The item path.
language
Type: Sitecore.Globalization..::..Language
The language.
version
Type: Sitecore.Data..::..Version
The version.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

The item not null.

Exceptions

Exception | Condition
Sitecore.Exceptions..::..ItemNullException | Item is null.

See Also

Client Class
GetItemNotNull Overload
Sitecore Namespace


GetItemNotNull Method (ID, Language, Version, Database)

[image]

Sitecore 6.4.1 API
Client..::..GetItemNotNull Method (ID, Language, Version, Database)
Client Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item GetItemNotNull(
    ID itemId,
    Language language,
    Version version,
    Database database
)
Visual Basic
Public Shared Function GetItemNotNull ( _
    itemId As ID, _
    language As Language, _
    version As Version, _
    database As Database _
) As Item
Visual C++
public:
static Item^ GetItemNotNull(
    ID^ itemId,
    Language^ language,
    Version^ version,
    Database^ database
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
language
Type: Sitecore.Globalization..::..Language
The language.
version
Type: Sitecore.Data..::..Version
The version.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

The item.

Exceptions

Exception | Condition
Sitecore.Exceptions..::..ItemNullException | Item not found.

See Also

Client Class
GetItemNotNull Overload
Sitecore Namespace


Client Properties

[image] [image]

Sitecore 6.4.1 API
Client Properties
Client Class See Also Send Feedback

The Client type exposes the following members.

Properties

Name | Description
AjaxScriptManager | Gets the current ajax script manager, asserts its presence.
ContentDatabase | Gets the content database.
CoreDatabase | Gets the core database.
Device | Gets the device.
Page | Gets the page.
Site | Gets the site.

See Also

Client Class
Sitecore Namespace


AjaxScriptManager Property

[image]

Sitecore 6.4.1 API
Client..::..AjaxScriptManager Property
Client Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static AjaxScriptManager AjaxScriptManager { get; }
Visual Basic
Public Shared ReadOnly Property AjaxScriptManager As AjaxScriptManager
    Get
Visual C++
public:
static property AjaxScriptManager^ AjaxScriptManager {
    AjaxScriptManager^ get ();
}

See Also

Client Class
Sitecore Namespace


ContentDatabase Property

[image]

Sitecore 6.4.1 API
Client..::..ContentDatabase Property
Client Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Database ContentDatabase { get; }
Visual Basic
Public Shared ReadOnly Property ContentDatabase As Database
    Get
Visual C++
public:
static property Database^ ContentDatabase {
    Database^ get ();
}

Field Value

The content database.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The Sitecore.Client.ContentDatabase is null.

See Also

Client Class
Sitecore Namespace


CoreDatabase Property

[image]

Sitecore 6.4.1 API
Client..::..CoreDatabase Property
Client Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Database CoreDatabase { get; }
Visual Basic
Public Shared ReadOnly Property CoreDatabase As Database
    Get
Visual C++
public:
static property Database^ CoreDatabase {
    Database^ get ();
}

Field Value

The core database.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The Sitecore.Client.CoreDatabase is null.

See Also

Client Class
Sitecore Namespace


Device Property

[image]

Sitecore 6.4.1 API
Client..::..Device Property
Client Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static DeviceItem Device { get; }
Visual Basic
Public Shared ReadOnly Property Device As DeviceItem
    Get
Visual C++
public:
static property DeviceItem^ Device {
    DeviceItem^ get ();
}

Field Value

The device.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The Sitecore.Client.Device is null.

See Also

Client Class
Sitecore Namespace


Page Property

[image]

Sitecore 6.4.1 API
Client..::..Page Property
Client Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PageContext Page { get; }
Visual Basic
Public Shared ReadOnly Property Page As PageContext
    Get
Visual C++
public:
static property PageContext^ Page {
    PageContext^ get ();
}

Field Value

The page.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The Sitecore.Client.Page is null.

See Also

Client Class
Sitecore Namespace


Site Property

[image]

Sitecore 6.4.1 API
Client..::..Site Property
Client Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static SiteContext Site { get; }
Visual Basic
Public Shared ReadOnly Property Site As SiteContext
    Get
Visual C++
public:
static property SiteContext^ Site {
    SiteContext^ get ();
}

Field Value

The site.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The Sitecore.Client.Site is null.

See Also

Client Class
Sitecore Namespace


CommandFieldIDs Class

[image]

Sitecore 6.4.1 API
CommandFieldIDs Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class CommandFieldIDs
Visual Basic
Public NotInheritable Class CommandFieldIDs
Visual C++
public ref class CommandFieldIDs abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore..::..CommandFieldIDs

See Also

CommandFieldIDs Members
Sitecore Namespace


CommandFieldIDs Members

[image] [image]

Sitecore 6.4.1 API
CommandFieldIDs Members
CommandFieldIDs Class Fields See Also Send Feedback

The CommandFieldIDs type exposes the following members.

Fields

Name | Description
Method | The ID of the 'Method' field.
Type | The ID of the 'Type' field.

See Also

CommandFieldIDs Class
Sitecore Namespace


Method Field

[image]

Sitecore 6.4.1 API
CommandFieldIDs..::..Method Field
CommandFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Method
Visual Basic
Public Shared Method As ID
Visual C++
public:
static ID^ Method

See Also

CommandFieldIDs Class
Sitecore Namespace


Type Field

[image]

Sitecore 6.4.1 API
CommandFieldIDs..::..Type Field
CommandFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Type
Visual Basic
Public Shared Type As ID
Visual C++
public:
static ID^ Type

See Also

CommandFieldIDs Class
Sitecore Namespace


CommandsCommandFieldIDs Class

[image]

Sitecore 6.4.1 API
CommandsCommandFieldIDs Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class CommandsCommandFieldIDs
Visual Basic
Public NotInheritable Class CommandsCommandFieldIDs
Visual C++
public ref class CommandsCommandFieldIDs abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore..::..CommandsCommandFieldIDs

See Also

CommandsCommandFieldIDs Members
Sitecore Namespace


CommandsCommandFieldIDs Members

[image] [image]

Sitecore 6.4.1 API
CommandsCommandFieldIDs Members
CommandsCommandFieldIDs Class Fields See Also Send Feedback

The CommandsCommandFieldIDs type exposes the following members.

Fields

Name | Description
Type | The ID of the 'Type' field.

See Also

CommandsCommandFieldIDs Class
Sitecore Namespace


CommandsCommandFieldIDs Fields

[image] [image]

Sitecore 6.4.1 API
CommandsCommandFieldIDs Fields
CommandsCommandFieldIDs Class See Also Send Feedback

The CommandsCommandFieldIDs type exposes the following members.

Fields

Name | Description
Type | The ID of the 'Type' field.

See Also

CommandsCommandFieldIDs Class
Sitecore Namespace


Type Field

[image]

Sitecore 6.4.1 API
CommandsCommandFieldIDs..::..Type Field
CommandsCommandFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Type
Visual Basic
Public Shared Type As ID
Visual C++
public:
static ID^ Type

See Also

CommandsCommandFieldIDs Class
Sitecore Namespace


Constants Class

[image]

Sitecore 6.4.1 API
Constants Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Constants
Visual Basic
Public Class Constants
Visual C++
public ref class Constants

Inheritance Hierarchy

System..::..Object
Sitecore..::..Constants

See Also

Constants Members
Sitecore Namespace


Constants Members

[image] [image]

Sitecore 6.4.1 API
Constants Members
Constants Class Constructors Methods Fields See Also Send Feedback

The Constants type exposes the following members.

Constructors

 | Name | Description
Public method | Constants | Initializes a new instance of the Constants class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
AnonymousUserName | Name of the 'anonymous' user.
AshxExtension | ASHX extension.
AspxExtension | ASPX extension.
CONTENT_EDITOR_SKIN_NAMESPACE_URI | URI of the Content Editor skin namespace
ContentPath | Path to the content.
CoreDatabaseName | Name of the 'core' database.
CreatorOwnerRoleName | Name of the owner/creator role.
DefaultArchiveName | Name of the default archive for a database.
DefaultAspNetSessionIdCookieName | Default name of the ASP.NET session id cookie.
DefaultCulture | Name of the default culture.
EveryoneRoleName | Name of the 'everyone' role.
FeedRequestPrefix | Prefix of feed request URLs.
GuidLength | Length of a GUID.
HttpRequestAbortedKey | Items key for aborted http requests.
IconRequestPrefix | Prefix of icon request URLs.
IsoDateLength | Length of an iso date.
IsoDateTimeLength | Length of an iso datetime.
IsoTimeLength | Length of an iso time.
LinkPrefix | Prefix of links.
LinkTerminator | Terminator of links
MaxItemLevel | Maximum length of an item name.
MediaLibraryPath | Path to the media library.
MediaRequestPrefix | Prefix of media request URLs.
MinimalPageEditorRoleName | Defines name of the Minimal Page Editor role.
ModulesShellSiteName | Name of the 'modules_shell' site.
NullDate |
PerformanceCounterCategory | Obsolete. General performance counter category name.
PreviewDateCookieName | Name of the Preview Date Cookie.
PreviewShellUserCookieName | Name of the Preview Shell User Cookie.
PublishingSiteName | Name of the site used when publishing.
PublishReplacerName | Name of the 'publish' replacer.
RecycleBinArchiveName | Name of the 'recyclebin' archive for a database.
RequiredDatabaseVersion | The currently required database version.
RestRequestPrefix | Prefix of Rest request URLs.
ShellSiteName | Name of the 'shell' site.
ShortGuidLength | Length of a short GUID.
ShortIdLength | Length of a ShortID.
SitecoreClientUsersRole | Name of the Sitecore Client Users role
SitecorePath | Path to the root of the tree.
SitecorePipelinesOnKey | Key name in Items collection of Context.Items
SitecoreShellPath | Path to the shell.
SpellCheckDictionaryFolder | Spell check dictionary folder
StandardValuesItemName | The name of the standard values item.
XamlRequestPrefix | Prefix of Xaml request URLs.

See Also

Constants Class
Sitecore Namespace


Constants Constructor

[image]

Sitecore 6.4.1 API
Constants Constructor
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Constants()
Visual Basic
Public Sub New
Visual C++
public:
Constants()

See Also

Constants Class
Sitecore Namespace


AnonymousUserName Field

[image]

Sitecore 6.4.1 API
Constants..::..AnonymousUserName Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string AnonymousUserName
Visual Basic
Public Const AnonymousUserName As String
Visual C++
public:
literal String^ AnonymousUserName

See Also

Constants Class
Sitecore Namespace


AshxExtension Field

[image]

Sitecore 6.4.1 API
Constants..::..AshxExtension Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string AshxExtension
Visual Basic
Public Const AshxExtension As String
Visual C++
public:
literal String^ AshxExtension

See Also

Constants Class
Sitecore Namespace


CONTENT_EDITOR_SKIN_NAMESPACE_URI Field

[image]

Sitecore 6.4.1 API
Constants..::..CONTENT_EDITOR_SKIN_NAMESPACE_URI Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string CONTENT_EDITOR_SKIN_NAMESPACE_URI
Visual Basic
Public Const CONTENT_EDITOR_SKIN_NAMESPACE_URI As String
Visual C++
public:
literal String^ CONTENT_EDITOR_SKIN_NAMESPACE_URI

See Also

Constants Class
Sitecore Namespace


ContentPath Field

[image]

Sitecore 6.4.1 API
Constants..::..ContentPath Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string ContentPath
Visual Basic
Public Const ContentPath As String
Visual C++
public:
literal String^ ContentPath

See Also

Constants Class
Sitecore Namespace


CreatorOwnerRoleName Field

[image]

Sitecore 6.4.1 API
Constants..::..CreatorOwnerRoleName Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string CreatorOwnerRoleName
Visual Basic
Public Const CreatorOwnerRoleName As String
Visual C++
public:
literal String^ CreatorOwnerRoleName

See Also

Constants Class
Sitecore Namespace


DefaultArchiveName Field

[image]

Sitecore 6.4.1 API
Constants..::..DefaultArchiveName Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string DefaultArchiveName
Visual Basic
Public Const DefaultArchiveName As String
Visual C++
public:
literal String^ DefaultArchiveName

See Also

Constants Class
Sitecore Namespace


DefaultAspNetSessionIdCookieName Field

[image]

Sitecore 6.4.1 API
Constants..::..DefaultAspNetSessionIdCookieName Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string DefaultAspNetSessionIdCookieName
Visual Basic
Public Const DefaultAspNetSessionIdCookieName As String
Visual C++
public:
literal String^ DefaultAspNetSessionIdCookieName

See Also

Constants Class
Sitecore Namespace


DefaultCulture Field

[image]

Sitecore 6.4.1 API
Constants..::..DefaultCulture Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string DefaultCulture
Visual Basic
Public Const DefaultCulture As String
Visual C++
public:
literal String^ DefaultCulture

See Also

Constants Class
Sitecore Namespace


EveryoneRoleName Field

[image]

Sitecore 6.4.1 API
Constants..::..EveryoneRoleName Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string EveryoneRoleName
Visual Basic
Public Const EveryoneRoleName As String
Visual C++
public:
literal String^ EveryoneRoleName

See Also

Constants Class
Sitecore Namespace


FeedRequestPrefix Field

[image]

Sitecore 6.4.1 API
Constants..::..FeedRequestPrefix Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string FeedRequestPrefix
Visual Basic
Public Const FeedRequestPrefix As String
Visual C++
public:
literal String^ FeedRequestPrefix

See Also

Constants Class
Sitecore Namespace


GuidLength Field

[image]

Sitecore 6.4.1 API
Constants..::..GuidLength Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int GuidLength
Visual Basic
Public Const GuidLength As Integer
Visual C++
public:
literal int GuidLength

See Also

Constants Class
Sitecore Namespace


HttpRequestAbortedKey Field

[image]

Sitecore 6.4.1 API
Constants..::..HttpRequestAbortedKey Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string HttpRequestAbortedKey
Visual Basic
Public Const HttpRequestAbortedKey As String
Visual C++
public:
literal String^ HttpRequestAbortedKey

See Also

Constants Class
Sitecore Namespace


IsoDateLength Field

[image]

Sitecore 6.4.1 API
Constants..::..IsoDateLength Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int IsoDateLength
Visual Basic
Public Const IsoDateLength As Integer
Visual C++
public:
literal int IsoDateLength

See Also

Constants Class
Sitecore Namespace


IsoDateTimeLength Field

[image]

Sitecore 6.4.1 API
Constants..::..IsoDateTimeLength Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int IsoDateTimeLength
Visual Basic
Public Const IsoDateTimeLength As Integer
Visual C++
public:
literal int IsoDateTimeLength

See Also

Constants Class
Sitecore Namespace


IsoTimeLength Field

[image]

Sitecore 6.4.1 API
Constants..::..IsoTimeLength Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int IsoTimeLength
Visual Basic
Public Const IsoTimeLength As Integer
Visual C++
public:
literal int IsoTimeLength

See Also

Constants Class
Sitecore Namespace


LinkPrefix Field

[image]

Sitecore 6.4.1 API
Constants..::..LinkPrefix Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string LinkPrefix
Visual Basic
Public Const LinkPrefix As String
Visual C++
public:
literal String^ LinkPrefix

See Also

Constants Class
Sitecore Namespace


MaxItemLevel Field

[image]

Sitecore 6.4.1 API
Constants..::..MaxItemLevel Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int MaxItemLevel
Visual Basic
Public Const MaxItemLevel As Integer
Visual C++
public:
literal int MaxItemLevel

See Also

Constants Class
Sitecore Namespace


MediaLibraryPath Field

[image]

Sitecore 6.4.1 API
Constants..::..MediaLibraryPath Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string MediaLibraryPath
Visual Basic
Public Const MediaLibraryPath As String
Visual C++
public:
literal String^ MediaLibraryPath

See Also

Constants Class
Sitecore Namespace


MediaRequestPrefix Field

[image]

Sitecore 6.4.1 API
Constants..::..MediaRequestPrefix Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string MediaRequestPrefix
Visual Basic
Public Const MediaRequestPrefix As String
Visual C++
public:
literal String^ MediaRequestPrefix

See Also

Constants Class
Sitecore Namespace


MinimalPageEditorRoleName Field

[image]

Sitecore 6.4.1 API
Constants..::..MinimalPageEditorRoleName Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string MinimalPageEditorRoleName
Visual Basic
Public Const MinimalPageEditorRoleName As String
Visual C++
public:
literal String^ MinimalPageEditorRoleName

See Also

Constants Class
Sitecore Namespace


ModulesShellSiteName Field

[image]

Sitecore 6.4.1 API
Constants..::..ModulesShellSiteName Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string ModulesShellSiteName
Visual Basic
Public Const ModulesShellSiteName As String
Visual C++
public:
literal String^ ModulesShellSiteName

See Also

Constants Class
Sitecore Namespace


NullDate Field

[image]

Sitecore 6.4.1 API
Constants..::..NullDate Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static DateTime NullDate
Visual Basic
Public Shared NullDate As DateTime
Visual C++
public:
static DateTime NullDate

See Also

Constants Class
Sitecore Namespace


PerformanceCounterCategory Field

[image]

Sitecore 6.4.1 API
Constants..::..PerformanceCounterCategory Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated", false)]
public const string PerformanceCounterCategory
Visual Basic
<ObsoleteAttribute("Deprecated", False)> _
Public Const PerformanceCounterCategory As String
Visual C++
[ObsoleteAttribute(L"Deprecated", false)]
public:
literal String^ PerformanceCounterCategory

See Also

Constants Class
Sitecore Namespace


PreviewDateCookieName Field

[image]

Sitecore 6.4.1 API
Constants..::..PreviewDateCookieName Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string PreviewDateCookieName
Visual Basic
Public Const PreviewDateCookieName As String
Visual C++
public:
literal String^ PreviewDateCookieName

See Also

Constants Class
Sitecore Namespace


PreviewShellUserCookieName Field

[image]

Sitecore 6.4.1 API
Constants..::..PreviewShellUserCookieName Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string PreviewShellUserCookieName
Visual Basic
Public Const PreviewShellUserCookieName As String
Visual C++
public:
literal String^ PreviewShellUserCookieName

See Also

Constants Class
Sitecore Namespace


PublishingSiteName Field

[image]

Sitecore 6.4.1 API
Constants..::..PublishingSiteName Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string PublishingSiteName
Visual Basic
Public Const PublishingSiteName As String
Visual C++
public:
literal String^ PublishingSiteName

See Also

Constants Class
Sitecore Namespace


PublishReplacerName Field

[image]

Sitecore 6.4.1 API
Constants..::..PublishReplacerName Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string PublishReplacerName
Visual Basic
Public Const PublishReplacerName As String
Visual C++
public:
literal String^ PublishReplacerName

See Also

Constants Class
Sitecore Namespace


RecycleBinArchiveName Field

[image]

Sitecore 6.4.1 API
Constants..::..RecycleBinArchiveName Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string RecycleBinArchiveName
Visual Basic
Public Const RecycleBinArchiveName As String
Visual C++
public:
literal String^ RecycleBinArchiveName

See Also

Constants Class
Sitecore Namespace


RequiredDatabaseVersion Field

[image]

Sitecore 6.4.1 API
Constants..::..RequiredDatabaseVersion Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int RequiredDatabaseVersion
Visual Basic
Public Const RequiredDatabaseVersion As Integer
Visual C++
public:
literal int RequiredDatabaseVersion

See Also

Constants Class
Sitecore Namespace


RestRequestPrefix Field

[image]

Sitecore 6.4.1 API
Constants..::..RestRequestPrefix Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string RestRequestPrefix
Visual Basic
Public Const RestRequestPrefix As String
Visual C++
public:
literal String^ RestRequestPrefix

See Also

Constants Class
Sitecore Namespace


ShellSiteName Field

[image]

Sitecore 6.4.1 API
Constants..::..ShellSiteName Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string ShellSiteName
Visual Basic
Public Const ShellSiteName As String
Visual C++
public:
literal String^ ShellSiteName

See Also

Constants Class
Sitecore Namespace


ShortGuidLength Field

[image]

Sitecore 6.4.1 API
Constants..::..ShortGuidLength Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int ShortGuidLength
Visual Basic
Public Const ShortGuidLength As Integer
Visual C++
public:
literal int ShortGuidLength

See Also

Constants Class
Sitecore Namespace


ShortIdLength Field

[image]

Sitecore 6.4.1 API
Constants..::..ShortIdLength Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int ShortIdLength
Visual Basic
Public Const ShortIdLength As Integer
Visual C++
public:
literal int ShortIdLength

See Also

Constants Class
Sitecore Namespace


SitecoreClientUsersRole Field

[image]

Sitecore 6.4.1 API
Constants..::..SitecoreClientUsersRole Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string SitecoreClientUsersRole
Visual Basic
Public Shared SitecoreClientUsersRole As String
Visual C++
public:
static String^ SitecoreClientUsersRole

See Also

Constants Class
Sitecore Namespace


SitecorePath Field

[image]

Sitecore 6.4.1 API
Constants..::..SitecorePath Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string SitecorePath
Visual Basic
Public Const SitecorePath As String
Visual C++
public:
literal String^ SitecorePath

See Also

Constants Class
Sitecore Namespace


SitecorePipelinesOnKey Field

[image]

Sitecore 6.4.1 API
Constants..::..SitecorePipelinesOnKey Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string SitecorePipelinesOnKey
Visual Basic
Public Const SitecorePipelinesOnKey As String
Visual C++
public:
literal String^ SitecorePipelinesOnKey

See Also

Constants Class
Sitecore Namespace


SitecoreShellPath Field

[image]

Sitecore 6.4.1 API
Constants..::..SitecoreShellPath Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string SitecoreShellPath
Visual Basic
Public Const SitecoreShellPath As String
Visual C++
public:
literal String^ SitecoreShellPath

See Also

Constants Class
Sitecore Namespace


SpellCheckDictionaryFolder Field

[image]

Sitecore 6.4.1 API
Constants..::..SpellCheckDictionaryFolder Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string SpellCheckDictionaryFolder
Visual Basic
Public Const SpellCheckDictionaryFolder As String
Visual C++
public:
literal String^ SpellCheckDictionaryFolder

See Also

Constants Class
Sitecore Namespace


StandardValuesItemName Field

[image]

Sitecore 6.4.1 API
Constants..::..StandardValuesItemName Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string StandardValuesItemName
Visual Basic
Public Const StandardValuesItemName As String
Visual C++
public:
literal String^ StandardValuesItemName

See Also

Constants Class
Sitecore Namespace


XamlRequestPrefix Field

[image]

Sitecore 6.4.1 API
Constants..::..XamlRequestPrefix Field
Constants Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string XamlRequestPrefix
Visual Basic
Public Const XamlRequestPrefix As String
Visual C++
public:
literal String^ XamlRequestPrefix

See Also

Constants Class
Sitecore Namespace


Constants Methods

[image] [image]

Sitecore 6.4.1 API
Constants Methods
Constants Class See Also Send Feedback

The Constants type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Constants Class
Sitecore Namespace


Context Class

[image]

Sitecore 6.4.1 API
Context Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Context
Visual Basic
Public Class Context
Visual C++
public ref class Context

Remarks

The Context object holds information about the current state such as current database, current language, current domain etc.

Many of these properties are resolved in the HttpRequest pipeline which determines the current site. The site usually specifies the current database, language and domain.

The current item is also resolved in the HttpRequest pipeline.

Remarks

The Context object holds information about the current state such as current database, current language, current domain etc.

Many of these properties are resolved in the HttpRequest pipeline which determines the current site. The site usually specifies the current database, language and domain.

The current item is also resolved in the HttpRequest pipeline.

Remarks

The Context object holds information about the current state such as current database, current language, current domain etc.

Many of these properties are resolved in the HttpRequest pipeline which determines the current site. The site usually specifies the current database, language and domain.

The current item is also resolved in the HttpRequest pipeline.

Inheritance Hierarchy

System..::..Object
Sitecore..::..Context

See Also

Context Members
Sitecore Namespace


Context Members

[image] [image]

Sitecore 6.4.1 API
Context Members
Context Class Constructors Methods Properties See Also Send Feedback

The Context type exposes the following members.

Constructors

 | Name | Description
Public method | Context | Initializes a new instance of the Context class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDeviceName | Gets the name of the current device.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetSiteName | Gets the name of the current site.
 | GetTaskStack | Gets the task stack.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetUserName | Gets the name of the current user.
 | Logout | Logs the current user out.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetActiveSite | Sets the active site.
 | SetLanguage | Sets the current language.
 | SetTraceBuffer | Sets the active trace buffer.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Traces the specified message to the active trace buffer.

Properties

Name | Description
Access | Provides access to the Security/Workflow framework.
ClientData | Gets the client data.
ClientPage | Gets the current Sheer client page object.
ContentDatabase | Gets the current content database.
ContentLanguage | Gets the language used by the client to display content.
Culture | Gets a CultureInfo object that represents the current language.
Data | Gets the data.
Database | Gets the current database.
Device | Gets the current layout device.
Diagnostics | Provides access to the Diagnostics framework.
Domain | Gets the current security domain.
IsAdministrator | Gets a value that indicates if the current user is an administrator.
IsBackgroundThread | Gets a boolean that indicates if the current thread is a background thread.
IsLoggedIn | Gets a value indicating whether this instance is logged in.
IsUnitTesting | Reserved - for internal use
Item | Gets or sets the current item.
Items | Gets the items.
Job | Gets the current job.
Language | Gets the current language.
Notifications | Provides access to the Notification framework.
Page | Provides access to the current ASP.NET Page object.
ProxiesActive | Gets or sets a value indicating whether the proxies are active.
RawUrl | Gets a normalized copy of the raw URL of the current request.
Request | Provides access to the current ASP.NET HttpRequest object.
RequestID | Gets the request ID.
Resources | Provides access to the Resource framework.
Security | Provides access to the Security framework.
Site | Represents the current site.
SkipSecurityInUnitTests | Reserved - for internal use
State | Gets the state.
Task | Gets current task (if any).
User | Gets the current user.
Workflow | Provides access to the current workflow framework.

See Also

Context Class
Sitecore Namespace


Context Constructor

[image]

Sitecore 6.4.1 API
Context Constructor
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Context()
Visual Basic
Public Sub New
Visual C++
public:
Context()

See Also

Context Class
Sitecore Namespace


Context Methods

[image] [image]

Sitecore 6.4.1 API
Context Methods
Context Class See Also Send Feedback

The Context type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDeviceName | Gets the name of the current device.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetSiteName | Gets the name of the current site.
 | GetTaskStack | Gets the task stack.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetUserName | Gets the name of the current user.
 | Logout | Logs the current user out.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetActiveSite | Sets the active site.
 | SetLanguage | Sets the current language.
 | SetTraceBuffer | Sets the active trace buffer.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | Trace | Traces the specified message to the active trace buffer.

See Also

Context Class
Sitecore Namespace


GetDeviceName Method

[image]

Sitecore 6.4.1 API
Context..::..GetDeviceName Method
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetDeviceName()
Visual Basic
Public Shared Function GetDeviceName As String
Visual C++
public:
static String^ GetDeviceName()

Return Value

The String.

See Also

Context Class
Sitecore Namespace


GetSiteName Method

[image]

Sitecore 6.4.1 API
Context..::..GetSiteName Method
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetSiteName()
Visual Basic
Public Shared Function GetSiteName As String
Visual C++
public:
static String^ GetSiteName()

Return Value

[Missing <returns> documentation for "M:Sitecore.Context.GetSiteName"]

See Also

Context Class
Sitecore Namespace


GetTaskStack Method

[image]

Sitecore 6.4.1 API
Context..::..GetTaskStack Method
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Stack<TaskContext> GetTaskStack()
Visual Basic
Public Shared Function GetTaskStack As Stack(Of TaskContext)
Visual C++
public:
static Stack<TaskContext^>^ GetTaskStack()

Return Value

The task stack.

See Also

Context Class
Sitecore Namespace


GetUserName Method

[image]

Sitecore 6.4.1 API
Context..::..GetUserName Method
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetUserName()
Visual Basic
Public Shared Function GetUserName As String
Visual C++
public:
static String^ GetUserName()

Return Value

The String.

See Also

Context Class
Sitecore Namespace


Logout Method

[image]

Sitecore 6.4.1 API
Context..::..Logout Method
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Logout()
Visual Basic
Public Shared Sub Logout
Visual C++
public:
static void Logout()

See Also

Context Class
Sitecore Namespace


SetActiveSite Method

[image]

Sitecore 6.4.1 API
Context..::..SetActiveSite Method
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void SetActiveSite(
    string siteName
)
Visual Basic
Public Shared Sub SetActiveSite ( _
    siteName As String _
)
Visual C++
public:
static void SetActiveSite(
    String^ siteName
)

Parameters

siteName
Type: System..::..String
Name of the site.

Remarks

The current site is normally determined by the HttpRequest module. However if the API is instantiated outside a Http request, it is possible to specify the current site using this methods.

This method is rarely used and should be used with caution.

Situations where this method can be used are: an event from a FileWatcher object or a background thread.

See Also

Context Class
Sitecore Namespace


SetLanguage Method

[image]

Sitecore 6.4.1 API
Context..::..SetLanguage Method
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void SetLanguage(
    Language language,
    bool persistent
)
Visual Basic
Public Shared Sub SetLanguage ( _
    language As Language, _
    persistent As Boolean _
)
Visual C++
public:
static void SetLanguage(
    Language^ language,
    bool persistent
)

Parameters

language
Type: Sitecore.Globalization..::..Language
The language.
persistent
Type: System..::..Boolean
if set to true, the value will be persisted (in a cookie).

See Also

Context Class
Sitecore Namespace


SetTraceBuffer Method

[image]

Sitecore 6.4.1 API
Context..::..SetTraceBuffer Method
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void SetTraceBuffer(
    StringBuilder buffer
)
Visual Basic
Public Shared Sub SetTraceBuffer ( _
    buffer As StringBuilder _
)
Visual C++
public:
static void SetTraceBuffer(
    StringBuilder^ buffer
)

Parameters

buffer
Type: System.Text..::..StringBuilder
The buffer.

See Also

Context Class
Sitecore Namespace


Trace Method

[image]

Sitecore 6.4.1 API
Context..::..Trace Method
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Trace(
    string message,
    params Object[] parameters
)
Visual Basic
Public Shared Sub Trace ( _
    message As String, _
    ParamArray parameters As Object() _
)
Visual C++
public:
static void Trace(
    String^ message,
    ... array<Object^>^ parameters
)

Parameters

message
Type: System..::..String
The message.
parameters
Type: array< System..::..Object >[]()[][]
The parameters (if the message is a format string).

See Also

Context Class
Sitecore Namespace


Context Properties

[image] [image]

Sitecore 6.4.1 API
Context Properties
Context Class See Also Send Feedback

The Context type exposes the following members.

Properties

Name | Description
Access | Provides access to the Security/Workflow framework.
ClientData | Gets the client data.
ClientPage | Gets the current Sheer client page object.
ContentDatabase | Gets the current content database.
ContentLanguage | Gets the language used by the client to display content.
Culture | Gets a CultureInfo object that represents the current language.
Data | Gets the data.
Database | Gets the current database.
Device | Gets the current layout device.
Diagnostics | Provides access to the Diagnostics framework.
Domain | Gets the current security domain.
IsAdministrator | Gets a value that indicates if the current user is an administrator.
IsBackgroundThread | Gets a boolean that indicates if the current thread is a background thread.
IsLoggedIn | Gets a value indicating whether this instance is logged in.
IsUnitTesting | Reserved - for internal use
Item | Gets or sets the current item.
Items | Gets the items.
Job | Gets the current job.
Language | Gets the current language.
Notifications | Provides access to the Notification framework.
Page | Provides access to the current ASP.NET Page object.
ProxiesActive | Gets or sets a value indicating whether the proxies are active.
RawUrl | Gets a normalized copy of the raw URL of the current request.
Request | Provides access to the current ASP.NET HttpRequest object.
RequestID | Gets the request ID.
Resources | Provides access to the Resource framework.
Security | Provides access to the Security framework.
Site | Represents the current site.
SkipSecurityInUnitTests | Reserved - for internal use
State | Gets the state.
Task | Gets current task (if any).
User | Gets the current user.
Workflow | Provides access to the current workflow framework.

See Also

Context Class
Sitecore Namespace


Access Property

[image]

Sitecore 6.4.1 API
Context..::..Access Property
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static AccessContext Access { get; }
Visual Basic
Public Shared ReadOnly Property Access As AccessContext
    Get
Visual C++
public:
static property AccessContext^ Access {
    AccessContext^ get ();
}

Field Value

The access.

See Also

Context Class
Sitecore Namespace


ClientData Property

[image]

Sitecore 6.4.1 API
Context..::..ClientData Property
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ClientDataStore ClientData { get; }
Visual Basic
Public Shared ReadOnly Property ClientData As ClientDataStore
    Get
Visual C++
public:
static property ClientDataStore^ ClientData {
    ClientDataStore^ get ();
}

Field Value

The client data.

See Also

Context Class
Sitecore Namespace


ClientPage Property

[image]

Sitecore 6.4.1 API
Context..::..ClientPage Property
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ClientPage ClientPage { get; set; }
Visual Basic
Public Shared Property ClientPage As ClientPage
    Get
    Set
Visual C++
public:
static property ClientPage^ ClientPage {
    ClientPage^ get ();
    void set (ClientPage^ value);
}

Field Value

The client page.

Remarks

If the current page does not inherit from the Sitecore.Web.UI.Sheer.ClientPage class, this property is null.

The ClientPage property provides access to the Sheer framework.

See Also

Context Class
Sitecore Namespace


ContentDatabase Property

[image]

Sitecore 6.4.1 API
Context..::..ContentDatabase Property
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Database ContentDatabase { get; }
Visual Basic
Public Shared ReadOnly Property ContentDatabase As Database
    Get
Visual C++
public:
static property Database^ ContentDatabase {
    Database^ get ();
}

Field Value

The content database.

Remarks

This property specifies which database is being edited by the client. Usually this is the Master database.

Normally this property is only accessed from within the client.

The value is specified in the Sites section in the web.config.

See Also

Context Class
Sitecore Namespace


ContentLanguage Property

[image]

Sitecore 6.4.1 API
Context..::..ContentLanguage Property
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Language ContentLanguage { get; }
Visual Basic
Public Shared ReadOnly Property ContentLanguage As Language
    Get
Visual C++
public:
static property Language^ ContentLanguage {
    Language^ get ();
}

Field Value

The content language.

Remarks

This property specifies the language which the client displays content in by default.

Normally this property is only accessed from within the client.

The value is specified in the Sites section in the web.config.

See Also

Context Class
Sitecore Namespace


Culture Property

[image]

Sitecore 6.4.1 API
Context..::..Culture Property
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static CultureInfo Culture { get; }
Visual Basic
Public Shared ReadOnly Property Culture As CultureInfo
    Get
Visual C++
public:
static property CultureInfo^ Culture {
    CultureInfo^ get ();
}

Field Value

The culture.

See Also

Context Class
Sitecore Namespace


Data Property

[image]

Sitecore 6.4.1 API
Context..::..Data Property
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Context..::..ContextData Data { get; }
Visual Basic
Public Shared ReadOnly Property Data As Context..::..ContextData
    Get
Visual C++
public:
static property Context..::..ContextData^ Data {
    Context..::..ContextData^ get ();
}

Field Value

The data.

See Also

Context Class
Sitecore Namespace


Database Property

[image]

Sitecore 6.4.1 API
Context..::..Database Property
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Database Database { get; set; }
Visual Basic
Public Shared Property Database As Database
    Get
    Set
Visual C++
public:
static property Database^ Database {
    Database^ get ();
    void set (Database^ value);
}

Field Value

The database.

Remarks

This property returns the current database. For websites this is usually the Web database. In the client, this is the Core database.

The property is resolved in the HttpRequest pipeline and is obtained from the Sites section in the web.config.

See Also

Context Class
Sitecore Namespace


Device Property

[image]

Sitecore 6.4.1 API
Context..::..Device Property
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static DeviceItem Device { get; set; }
Visual Basic
Public Shared Property Device As DeviceItem
    Get
    Set
Visual C++
public:
static property DeviceItem^ Device {
    DeviceItem^ get ();
    void set (DeviceItem^ value);
}

Field Value

The device.

Remarks

The device is resolved in the HttpRequest pipeline by analyzing the incoming request and the items in /sitecore/layout/devices. The best match is selected as the current device.

See Also

Context Class
Sitecore Namespace


Diagnostics Property

[image]

Sitecore 6.4.1 API
Context..::..Diagnostics Property
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static DiagnosticContext Diagnostics { get; }
Visual Basic
Public Shared ReadOnly Property Diagnostics As DiagnosticContext
    Get
Visual C++
public:
static property DiagnosticContext^ Diagnostics {
    DiagnosticContext^ get ();
}

Field Value

The diagnostics.

See Also

Context Class
Sitecore Namespace


Domain Property

[image]

Sitecore 6.4.1 API
Context..::..Domain Property
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Domain Domain { get; }
Visual Basic
Public Shared ReadOnly Property Domain As Domain
    Get
Visual C++
public:
static property Domain^ Domain {
    Domain^ get ();
}

Field Value

The domain.

Remarks

This property is resolved in the HttpRequest pipeline. The value is specified in the Sites section in the web.config.

See Also

Context Class
Sitecore Namespace


IsAdministrator Property

[image]

Sitecore 6.4.1 API
Context..::..IsAdministrator Property
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsAdministrator { get; }
Visual Basic
Public Shared ReadOnly Property IsAdministrator As Boolean
    Get
Visual C++
public:
static property bool IsAdministrator {
    bool get ();
}

Field Value

true if this instance is administrator; otherwise, false.

Remarks

If this property is set, all privileges are granted.

See Also

Context Class
Sitecore Namespace


IsBackgroundThread Property

[image]

Sitecore 6.4.1 API
Context..::..IsBackgroundThread Property
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsBackgroundThread { get; }
Visual Basic
Public Shared ReadOnly Property IsBackgroundThread As Boolean
    Get
Visual C++
public:
static property bool IsBackgroundThread {
    bool get ();
}

Field Value

True, if the current thread is a background thread, otherwise false.

Remarks

Sitecore may handle requests that are not part of a web request. Such requests are considered background or worker threads. An example is the scheduler which uses the API to perform certain tasks. When the scheduler executes, it does not run as a web request.

A developer may use this flag to take certain actions when the current thread is a background thread.

A background thread is defined by the current HttpContext is null:

CopyC#
HttpContext.Current == null

See Also

Context Class
Sitecore Namespace


IsUnitTesting Property

[image]

Sitecore 6.4.1 API
Context..::..IsUnitTesting Property
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsUnitTesting { get; set; }
Visual Basic
Public Shared Property IsUnitTesting As Boolean
    Get
    Set
Visual C++
public:
static property bool IsUnitTesting {
    bool get ();
    void set (bool value);
}

See Also

Context Class
Sitecore Namespace


Item Property

[image]

Sitecore 6.4.1 API
Context..::..Item Property
Context Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item Item { get; set; }
Visual Basic
Public Shared Property Item As Item
    Get
    Set
Visual C++
public:
static property Item^ Item {
    Item^ get ();
    void set (Item^ value);
}

Field Value

The Item identified by the "path" query string parameter, or null if the item was not found.

Remarks

The current item is the context item from which the web page is rendered. For instance if the current item points to the Home item, the web engine will render the layout associated with the Home item.

The current web item is by default obtained by parsing the Path argument on the request query string.

The scope of the value is page and it is stored in the Items variable sc_CurrentItem.

Examples

The following example redirects the page, if the current item has a specific name.
CopyC#
public void Redirect(string name, string url) {
Item item = State.CurrentItem;
if (item.Name == name) {
Response.Redirect(url);
}
}

See Also

Context Class
Sitecore Namespace


Items Property

[image]

Sitecore 6.4.1 API
Context..::..Items Property
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ItemsContext Items { get; }
Visual Basic
Public Shared ReadOnly Property Items As ItemsContext
    Get
Visual C++
public:
static property ItemsContext^ Items {
    ItemsContext^ get ();
}

Field Value

The items.

See Also

Context Class
Sitecore Namespace


Job Property

[image]

Sitecore 6.4.1 API
Context..::..Job Property
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Job Job { get; set; }
Visual Basic
Public Shared Property Job As Job
    Get
    Set
Visual C++
public:
static property Job^ Job {
    Job^ get ();
    void set (Job^ value);
}

Field Value

The job.

Remarks

If a background job is running, this property points to it.

See Also

Context Class
Sitecore Namespace


Language Property

[image]

Sitecore 6.4.1 API
Context..::..Language Property
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Language Language { get; set; }
Visual Basic
Public Shared Property Language As Language
    Get
    Set
Visual C++
public:
static property Language^ Language {
    Language^ get ();
    void set (Language^ value);
}

Field Value

The language.

See Also

Context Class
Sitecore Namespace


Notifications Property

[image]

Sitecore 6.4.1 API
Context..::..Notifications Property
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static NotificationContext Notifications { get; }
Visual Basic
Public Shared ReadOnly Property Notifications As NotificationContext
    Get
Visual C++
public:
static property NotificationContext^ Notifications {
    NotificationContext^ get ();
}

Field Value

The notifications.

See Also

Context Class
Sitecore Namespace


Page Property

[image]

Sitecore 6.4.1 API
Context..::..Page Property
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PageContext Page { get; }
Visual Basic
Public Shared ReadOnly Property Page As PageContext
    Get
Visual C++
public:
static property PageContext^ Page {
    PageContext^ get ();
}

Field Value

The page.

See Also

Context Class
Sitecore Namespace


ProxiesActive Property

[image]

Sitecore 6.4.1 API
Context..::..ProxiesActive Property
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool ProxiesActive { get; set; }
Visual Basic
Public Shared Property ProxiesActive As Boolean
    Get
    Set
Visual C++
public:
static property bool ProxiesActive {
    bool get ();
    void set (bool value);
}

Field Value

true if the proxies are active; otherwise, false.

See Also

Context Class
Sitecore Namespace


RawUrl Property

[image]

Sitecore 6.4.1 API
Context..::..RawUrl Property
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string RawUrl { get; }
Visual Basic
Public Shared ReadOnly Property RawUrl As String
    Get
Visual C++
public:
static property String^ RawUrl {
    String^ get ();
}

Field Value

The raw URL.

See Also

Context Class
Sitecore Namespace
WebUtil..::..NormalizeUrl(String)


Request Property

[image]

Sitecore 6.4.1 API
Context..::..Request Property
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static SiteRequest Request { get; }
Visual Basic
Public Shared ReadOnly Property Request As SiteRequest
    Get
Visual C++
public:
static property SiteRequest^ Request {
    SiteRequest^ get ();
}

Field Value

The request.

See Also

Context Class
Sitecore Namespace


RequestID Property

[image]

Sitecore 6.4.1 API
Context..::..RequestID Property
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string RequestID { get; }
Visual Basic
Public Shared ReadOnly Property RequestID As String
    Get
Visual C++
public:
static property String^ RequestID {
    String^ get ();
}

Field Value

The request ID.

See Also

Context Class
Sitecore Namespace


Resources Property

[image]

Sitecore 6.4.1 API
Context..::..Resources Property
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ResourceContext Resources { get; }
Visual Basic
Public Shared ReadOnly Property Resources As ResourceContext
    Get
Visual C++
public:
static property ResourceContext^ Resources {
    ResourceContext^ get ();
}

Field Value

The resources.

See Also

Context Class
Sitecore Namespace


Security Property

[image]

Sitecore 6.4.1 API
Context..::..Security Property
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static SecurityContext Security { get; }
Visual Basic
Public Shared ReadOnly Property Security As SecurityContext
    Get
Visual C++
public:
static property SecurityContext^ Security {
    SecurityContext^ get ();
}

Field Value

The security.

See Also

Context Class
Sitecore Namespace


SkipSecurityInUnitTests Property

[image]

Sitecore 6.4.1 API
Context..::..SkipSecurityInUnitTests Property
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool SkipSecurityInUnitTests { get; set; }
Visual Basic
Public Shared Property SkipSecurityInUnitTests As Boolean
    Get
    Set
Visual C++
public:
static property bool SkipSecurityInUnitTests {
    bool get ();
    void set (bool value);
}

See Also

Context Class
Sitecore Namespace


State Property

[image]

Sitecore 6.4.1 API
Context..::..State Property
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static StateContext State { get; }
Visual Basic
Public Shared ReadOnly Property State As StateContext
    Get
Visual C++
public:
static property StateContext^ State {
    StateContext^ get ();
}

Field Value

The state.

See Also

Context Class
Sitecore Namespace


Task Property

[image]

Sitecore 6.4.1 API
Context..::..Task Property
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TaskContext Task { get; }
Visual Basic
Public Shared ReadOnly Property Task As TaskContext
    Get
Visual C++
public:
static property TaskContext^ Task {
    TaskContext^ get ();
}

Field Value

The task (or null).

See Also

Context Class
Sitecore Namespace


User Property

[image]

Sitecore 6.4.1 API
Context..::..User Property
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static User User { get; }
Visual Basic
Public Shared ReadOnly Property User As User
    Get
Visual C++
public:
static property User^ User {
    User^ get ();
}

Field Value

The user.

Remarks

The current user is either the logged in user, a user that has been switched to or the Anonymous user, if no other user has been specified.

See Also

Context Class
Sitecore Namespace


Workflow Property

[image]

Sitecore 6.4.1 API
Context..::..Workflow Property
Context Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static WorkflowContext Workflow { get; }
Visual Basic
Public Shared ReadOnly Property Workflow As WorkflowContext
    Get
Visual C++
public:
static property WorkflowContext^ Workflow {
    WorkflowContext^ get ();
}

Field Value

The workflow.

See Also

Context Class
Sitecore Namespace


Context.ContextData Class

[image]

Sitecore 6.4.1 API
Context..::..ContextData Class
Context Class Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ContextData
Visual Basic
Public Class ContextData
Visual C++
public ref class ContextData

Inheritance Hierarchy

System..::..Object
Sitecore..::..Context..::..ContextData

See Also

Context..::..ContextData Members
Sitecore Namespace


Context.ContextData Members

[image] [image]

Sitecore 6.4.1 API
Context..::..ContextData Members
Context..::..ContextData Class Constructors Methods Properties See Also Send Feedback

Represents the current state for this request.
Represents the current state for this request.
Context class
Represents the current state for this request.

The Context..::..ContextData type exposes the following members.

Constructors

 | Name | Description
Public method | Context..::..ContextData | Initializes a new instance of the Context..::..ContextData class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Access | Gets the access.
Public property | Database | Gets or sets the database.
Public property | Device | Gets or sets the device.
Public property | Diagnostics | Gets the diagnostics.
Public property | Domain | Gets the domain.
Public property | FilePathLanguage | Gets or sets the language that was embedded in the file path of the current request.
Public property | IsAdministrator | Gets a value indicating whether if the current user is an administrator.
Public property | RawUrl | Gets or sets the raw URL.
Public property | RequestID | Gets the request ID.
Public property | Security | Gets the security.
Public property | Site | Gets or sets the site.
Public property | User | Gets or sets the user.
Public property | Workflow | Gets the workflow.

See Also

Context..::..ContextData Class
Sitecore Namespace


Context.ContextData Constructor

[image]

Sitecore 6.4.1 API
Context..::..ContextData Constructor
Context..::..ContextData Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ContextData()
Visual Basic
Public Sub New
Visual C++
public:
ContextData()

See Also

Context..::..ContextData Class
Sitecore Namespace


Context.ContextData Methods

[image] [image]

Sitecore 6.4.1 API
Context..::..ContextData Methods
Context..::..ContextData Class See Also Send Feedback

The Context..::..ContextData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Context..::..ContextData Class
Sitecore Namespace


Context.ContextData Properties

[image] [image]

Sitecore 6.4.1 API
Context..::..ContextData Properties
Context..::..ContextData Class See Also Send Feedback

The Context..::..ContextData type exposes the following members.

Properties

 | Name | Description
Public property | Access | Gets the access.
Public property | Database | Gets or sets the database.
Public property | Device | Gets or sets the device.
Public property | Diagnostics | Gets the diagnostics.
Public property | Domain | Gets the domain.
Public property | FilePathLanguage | Gets or sets the language that was embedded in the file path of the current request.
Public property | IsAdministrator | Gets a value indicating whether if the current user is an administrator.
Public property | RawUrl | Gets or sets the raw URL.
Public property | RequestID | Gets the request ID.
Public property | Security | Gets the security.
Public property | Site | Gets or sets the site.
Public property | User | Gets or sets the user.
Public property | Workflow | Gets the workflow.

See Also

Context..::..ContextData Class
Sitecore Namespace


Access Property

[image]

Sitecore 6.4.1 API
Context..::..ContextData..::..Access Property
Context..::..ContextData Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AccessContext Access { get; }
Visual Basic
Public ReadOnly Property Access As AccessContext
    Get
Visual C++
public:
property AccessContext^ Access {
    AccessContext^ get ();
}

Field Value

The access.

See Also

Context..::..ContextData Class
Sitecore Namespace


Database Property

[image]

Sitecore 6.4.1 API
Context..::..ContextData..::..Database Property
Context..::..ContextData Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database Database { get; set; }
Visual Basic
Public Property Database As Database
    Get
    Set
Visual C++
public:
property Database^ Database {
    Database^ get ();
    void set (Database^ value);
}

Field Value

The database.

See Also

Context..::..ContextData Class
Sitecore Namespace


Device Property

[image]

Sitecore 6.4.1 API
Context..::..ContextData..::..Device Property
Context..::..ContextData Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DeviceItem Device { get; set; }
Visual Basic
Public Property Device As DeviceItem
    Get
    Set
Visual C++
public:
property DeviceItem^ Device {
    DeviceItem^ get ();
    void set (DeviceItem^ value);
}

Field Value

The device.

See Also

Context..::..ContextData Class
Sitecore Namespace


Diagnostics Property

[image]

Sitecore 6.4.1 API
Context..::..ContextData..::..Diagnostics Property
Context..::..ContextData Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DiagnosticContext Diagnostics { get; }
Visual Basic
Public ReadOnly Property Diagnostics As DiagnosticContext
    Get
Visual C++
public:
property DiagnosticContext^ Diagnostics {
    DiagnosticContext^ get ();
}

Field Value

The diagnostics.

See Also

Context..::..ContextData Class
Sitecore Namespace


Domain Property

[image]

Sitecore 6.4.1 API
Context..::..ContextData..::..Domain Property
Context..::..ContextData Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Domain Domain { get; }
Visual Basic
Public ReadOnly Property Domain As Domain
    Get
Visual C++
public:
property Domain^ Domain {
    Domain^ get ();
}

Field Value

The domain.

See Also

Context..::..ContextData Class
Sitecore Namespace


FilePathLanguage Property

[image]

Sitecore 6.4.1 API
Context..::..ContextData..::..FilePathLanguage Property
Context..::..ContextData Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Language FilePathLanguage { get; set; }
Visual Basic
Public Property FilePathLanguage As Language
    Get
    Set
Visual C++
public:
property Language^ FilePathLanguage {
    Language^ get ();
    void set (Language^ value);
}

Field Value

The language (might be null, if no language was embedded or the parser has not been run).

Remarks

The language is parsed out by the StripLanguage processor.

See Also

Context..::..ContextData Class
Sitecore Namespace


IsAdministrator Property

[image]

Sitecore 6.4.1 API
Context..::..ContextData..::..IsAdministrator Property
Context..::..ContextData Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsAdministrator { get; }
Visual Basic
Public ReadOnly Property IsAdministrator As Boolean
    Get
Visual C++
public:
property bool IsAdministrator {
    bool get ();
}

Field Value

true if the current user is administrator; otherwise, false.

Remarks

If this property is set, all privileges are granted.

See Also

Context..::..ContextData Class
Sitecore Namespace


RawUrl Property

[image]

Sitecore 6.4.1 API
Context..::..ContextData..::..RawUrl Property
Context..::..ContextData Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string RawUrl { get; set; }
Visual Basic
Public Property RawUrl As String
    Get
    Set
Visual C++
public:
property String^ RawUrl {
    String^ get ();
    void set (String^ value);
}

Field Value

The raw URL.

See Also

Context..::..ContextData Class
Sitecore Namespace


RequestID Property

[image]

Sitecore 6.4.1 API
Context..::..ContextData..::..RequestID Property
Context..::..ContextData Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string RequestID { get; }
Visual Basic
Public ReadOnly Property RequestID As String
    Get
Visual C++
public:
property String^ RequestID {
    String^ get ();
}

Field Value

The request ID.

See Also

Context..::..ContextData Class
Sitecore Namespace


Security Property

[image]

Sitecore 6.4.1 API
Context..::..ContextData..::..Security Property
Context..::..ContextData Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SecurityContext Security { get; }
Visual Basic
Public ReadOnly Property Security As SecurityContext
    Get
Visual C++
public:
property SecurityContext^ Security {
    SecurityContext^ get ();
}

Field Value

The security.

See Also

Context..::..ContextData Class
Sitecore Namespace


Site Property

[image]

Sitecore 6.4.1 API
Context..::..ContextData..::..Site Property
Context..::..ContextData Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SiteContext Site { get; set; }
Visual Basic
Public Property Site As SiteContext
    Get
    Set
Visual C++
public:
property SiteContext^ Site {
    SiteContext^ get ();
    void set (SiteContext^ value);
}

Field Value

The site object.

See Also

Context..::..ContextData Class
Sitecore Namespace


User Property

[image]

Sitecore 6.4.1 API
Context..::..ContextData..::..User Property
Context..::..ContextData Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public User User { get; set; }
Visual Basic
Public Property User As User
    Get
    Set
Visual C++
public:
property User^ User {
    User^ get ();
    void set (User^ value);
}

Field Value

The user object.

See Also

Context..::..ContextData Class
Sitecore Namespace


Workflow Property

[image]

Sitecore 6.4.1 API
Context..::..ContextData..::..Workflow Property
Context..::..ContextData Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WorkflowContext Workflow { get; }
Visual Basic
Public ReadOnly Property Workflow As WorkflowContext
    Get
Visual C++
public:
property WorkflowContext^ Workflow {
    WorkflowContext^ get ();
}

Field Value

The workflow.

See Also

Context..::..ContextData Class
Sitecore Namespace


Context.PageDesigner Class

[image]

Sitecore 6.4.1 API
Context..::..PageDesigner Class
Context Class Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class PageDesigner
Visual Basic
Public NotInheritable Class PageDesigner
Visual C++
public ref class PageDesigner abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore..::..Context..::..PageDesigner

See Also

Context..::..PageDesigner Members
Sitecore Namespace


Context.PageDesigner Members

[image] [image]

Sitecore 6.4.1 API
Context..::..PageDesigner Members
Context..::..PageDesigner Class Properties See Also Send Feedback

Represents the current state for this request.
Represents the current state for this request.
Context class
Represents the current state for this request.

The Context..::..PageDesigner type exposes the following members.

Properties

Name | Description
IsDesigning | Gets a value indicating whether this instance is designing.
IsLayouting | Gets a value indicating whether this instance is layouting.
IsLayoutViewing | Gets a value indicating whether this instance is viewing.
LayoutHandle | Gets the handle.
PageDesignerHandle | Gets the handle.

See Also

Context..::..PageDesigner Class
Sitecore Namespace


IsLayouting Property

[image]

Sitecore 6.4.1 API
Context..::..PageDesigner..::..IsLayouting Property
Context..::..PageDesigner Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsLayouting { get; }
Visual Basic
Public Shared ReadOnly Property IsLayouting As Boolean
    Get
Visual C++
public:
static property bool IsLayouting {
    bool get ();
}

Field Value

true if this instance is layouting; otherwise, false.

See Also

Context..::..PageDesigner Class
Sitecore Namespace


IsLayoutViewing Property

[image]

Sitecore 6.4.1 API
Context..::..PageDesigner..::..IsLayoutViewing Property
Context..::..PageDesigner Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsLayoutViewing { get; }
Visual Basic
Public Shared ReadOnly Property IsLayoutViewing As Boolean
    Get
Visual C++
public:
static property bool IsLayoutViewing {
    bool get ();
}

Field Value

true if this instance is viewing; otherwise, false.

See Also

Context..::..PageDesigner Class
Sitecore Namespace


LayoutHandle Property

[image]

Sitecore 6.4.1 API
Context..::..PageDesigner..::..LayoutHandle Property
Context..::..PageDesigner Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string LayoutHandle { get; }
Visual Basic
Public Shared ReadOnly Property LayoutHandle As String
    Get
Visual C++
public:
static property String^ LayoutHandle {
    String^ get ();
}

Field Value

The handle.

See Also

Context..::..PageDesigner Class
Sitecore Namespace


PageDesignerHandle Property

[image]

Sitecore 6.4.1 API
Context..::..PageDesigner..::..PageDesignerHandle Property
Context..::..PageDesigner Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string PageDesignerHandle { get; }
Visual Basic
Public Shared ReadOnly Property PageDesignerHandle As String
    Get
Visual C++
public:
static property String^ PageDesignerHandle {
    String^ get ();
}

Field Value

The handle.

See Also

Context..::..PageDesigner Class
Sitecore Namespace


Context.PageMode Class

[image]

Sitecore 6.4.1 API
Context..::..PageMode Class
Context Class Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class PageMode
Visual Basic
Public NotInheritable Class PageMode
Visual C++
public ref class PageMode abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore..::..Context..::..PageMode

See Also

Context..::..PageMode Members
Sitecore Namespace


Context.PageMode Members

[image] [image]

Sitecore 6.4.1 API
Context..::..PageMode Members
Context..::..PageMode Class Properties See Also Send Feedback

Represents the current state for this request.
Represents the current state for this request.
Context class
Represents the current state for this request.

The Context..::..PageMode type exposes the following members.

Properties

Name | Description
IsDebugging | Gets a value indicating whether this instance is debugging.
IsNormal | Gets a value indicating whether the page mode is normal.
IsPageEditor | Gets a value indicating whether this instance is page editor.
IsPageEditorClassic | Obsolete. Gets a value indicating whether this instance is page editor classic.
IsPageEditorDesigning | Obsolete. Gets a value indicating whether this instance is page designer.
IsPageEditorEditing | Gets a value indicating whether this instance is page editor editing.
IsPageEditorNavigating | Obsolete. Gets a value indicating whether this instance is page editor navigating.
IsPreview | Gets a value indicating whether this instance is preview.
IsProfiling | Gets a value indicating whether this instance is profiling.

See Also

Context..::..PageMode Class
Sitecore Namespace


Context.PageMode Properties

[image] [image]

Sitecore 6.4.1 API
Context..::..PageMode Properties
Context..::..PageMode Class See Also Send Feedback

The Context..::..PageMode type exposes the following members.

Properties

Name | Description
IsDebugging | Gets a value indicating whether this instance is debugging.
IsNormal | Gets a value indicating whether the page mode is normal.
IsPageEditor | Gets a value indicating whether this instance is page editor.
IsPageEditorClassic | Obsolete. Gets a value indicating whether this instance is page editor classic.
IsPageEditorDesigning | Obsolete. Gets a value indicating whether this instance is page designer.
IsPageEditorEditing | Gets a value indicating whether this instance is page editor editing.
IsPageEditorNavigating | Obsolete. Gets a value indicating whether this instance is page editor navigating.
IsPreview | Gets a value indicating whether this instance is preview.
IsProfiling | Gets a value indicating whether this instance is profiling.

See Also

Context..::..PageMode Class
Sitecore Namespace


IsDebugging Property

[image]

Sitecore 6.4.1 API
Context..::..PageMode..::..IsDebugging Property
Context..::..PageMode Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsDebugging { get; }
Visual Basic
Public Shared ReadOnly Property IsDebugging As Boolean
    Get
Visual C++
public:
static property bool IsDebugging {
    bool get ();
}

Field Value

true if this instance is debugging; otherwise, false.

See Also

Context..::..PageMode Class
Sitecore Namespace


IsNormal Property

[image]

Sitecore 6.4.1 API
Context..::..PageMode..::..IsNormal Property
Context..::..PageMode Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsNormal { get; }
Visual Basic
Public Shared ReadOnly Property IsNormal As Boolean
    Get
Visual C++
public:
static property bool IsNormal {
    bool get ();
}

Field Value

true if the page mode is normal; otherwise, false.

See Also

Context..::..PageMode Class
Sitecore Namespace


IsPageEditor Property

[image]

Sitecore 6.4.1 API
Context..::..PageMode..::..IsPageEditor Property
Context..::..PageMode Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsPageEditor { get; }
Visual Basic
Public Shared ReadOnly Property IsPageEditor As Boolean
    Get
Visual C++
public:
static property bool IsPageEditor {
    bool get ();
}

Field Value

true if this instance is page editor; otherwise, false.

See Also

Context..::..PageMode Class
Sitecore Namespace


IsPageEditorClassic Property

[image]

Sitecore 6.4.1 API
Context..::..PageMode..::..IsPageEditorClassic Property
Context..::..PageMode Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated")]
public static bool IsPageEditorClassic { get; }
Visual Basic
<ObsoleteAttribute("Deprecated")> _
Public Shared ReadOnly Property IsPageEditorClassic As Boolean
    Get
Visual C++
[ObsoleteAttribute(L"Deprecated")]
public:
static property bool IsPageEditorClassic {
    bool get ();
}

Field Value

true if this instance is page editor classic; otherwise, false.

See Also

Context..::..PageMode Class
Sitecore Namespace


IsPageEditorEditing Property

[image]

Sitecore 6.4.1 API
Context..::..PageMode..::..IsPageEditorEditing Property
Context..::..PageMode Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsPageEditorEditing { get; }
Visual Basic
Public Shared ReadOnly Property IsPageEditorEditing As Boolean
    Get
Visual C++
public:
static property bool IsPageEditorEditing {
    bool get ();
}

Field Value

true if this instance is page editor editing; otherwise, false.

See Also

Context..::..PageMode Class
Sitecore Namespace


IsPageEditorNavigating Property

[image]

Sitecore 6.4.1 API
Context..::..PageMode..::..IsPageEditorNavigating Property
Context..::..PageMode Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("The method is deprecated")]
public static bool IsPageEditorNavigating { get; }
Visual Basic
<ObsoleteAttribute("The method is deprecated")> _
Public Shared ReadOnly Property IsPageEditorNavigating As Boolean
    Get
Visual C++
[ObsoleteAttribute(L"The method is deprecated")]
public:
static property bool IsPageEditorNavigating {
    bool get ();
}

Field Value

true if this instance is page editor navigating; otherwise, false.

See Also

Context..::..PageMode Class
Sitecore Namespace


IsPreview Property

[image]

Sitecore 6.4.1 API
Context..::..PageMode..::..IsPreview Property
Context..::..PageMode Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsPreview { get; }
Visual Basic
Public Shared ReadOnly Property IsPreview As Boolean
    Get
Visual C++
public:
static property bool IsPreview {
    bool get ();
}

Field Value

true if this instance is preview; otherwise, false.

See Also

Context..::..PageMode Class
Sitecore Namespace


IsProfiling Property

[image]

Sitecore 6.4.1 API
Context..::..PageMode..::..IsProfiling Property
Context..::..PageMode Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsProfiling { get; }
Visual Basic
Public Shared ReadOnly Property IsProfiling As Boolean
    Get
Visual C++
public:
static property bool IsProfiling {
    bool get ();
}

Field Value

true if this instance is profiling; otherwise, false.

See Also

Context..::..PageMode Class
Sitecore Namespace


Convert Class

[image]

Sitecore 6.4.1 API
Convert Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Convert
Visual Basic
Public NotInheritable Class Convert
Visual C++
public ref class Convert abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore..::..Convert

See Also

Convert Members
Sitecore Namespace


Convert Members

[image] [image]

Sitecore 6.4.1 API
Convert Members
Convert Class Methods See Also Send Feedback

The Convert type exposes the following members.

Methods

Name | Description
Base64ToHashtable | Converts a Base64 encoded string to a Hashtable.
Base64ToObject | Converts a Base64 encoded string to an object.
HashtableToBase64 | Converts a Hashtable to a Base64 encoded string.
ObjectToBase64 | Converters an object to a Base64 encoded string.

See Also

Convert Class
Sitecore Namespace


Base64ToHashtable Method

[image]

Sitecore 6.4.1 API
Convert..::..Base64ToHashtable Method
Convert Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Hashtable Base64ToHashtable(
    string data
)
Visual Basic
Public Shared Function Base64ToHashtable ( _
    data As String _
) As Hashtable
Visual C++
public:
static Hashtable^ Base64ToHashtable(
    String^ data
)

Parameters

data
Type: System..::..String
The data.

Return Value

The to hashtable.

See Also

Convert Class
Sitecore Namespace


Base64ToObject Method

[image]

Sitecore 6.4.1 API
Convert..::..Base64ToObject Method
Convert Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object Base64ToObject(
    string data
)
Visual Basic
Public Shared Function Base64ToObject ( _
    data As String _
) As Object
Visual C++
public:
static Object^ Base64ToObject(
    String^ data
)

Parameters

data
Type: System..::..String
The data.

Return Value

The to object.

See Also

Convert Class
Sitecore Namespace


HashtableToBase64 Method

[image]

Sitecore 6.4.1 API
Convert..::..HashtableToBase64 Method
Convert Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string HashtableToBase64(
    Hashtable data
)
Visual Basic
Public Shared Function HashtableToBase64 ( _
    data As Hashtable _
) As String
Visual C++
public:
static String^ HashtableToBase64(
    Hashtable^ data
)

Parameters

data
Type: System.Collections..::..Hashtable
The data.

Return Value

The to base64.

See Also

Convert Class
Sitecore Namespace


ObjectToBase64 Method

[image]

Sitecore 6.4.1 API
Convert..::..ObjectToBase64 Method
Convert Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ObjectToBase64(
    Object data
)
Visual Basic
Public Shared Function ObjectToBase64 ( _
    data As Object _
) As String
Visual C++
public:
static String^ ObjectToBase64(
    Object^ data
)

Parameters

data
Type: System..::..Object
The data.

Return Value

The to base64.

See Also

Convert Class
Sitecore Namespace


DateUtil Class

[image]

Sitecore 6.4.1 API
DateUtil Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public sealed class DateUtil
Visual Basic
Public NotInheritable Class DateUtil
Visual C++
public ref class DateUtil sealed

Remarks

The DateUtil operates on ISO formatted date/times for the most part. An ISO formatted date/time string is formatted as yyyyMMddTHHmmss.

Inheritance Hierarchy

System..::..Object
Sitecore..::..DateUtil

See Also

DateUtil Members
Sitecore Namespace
Sitecore.IO..::..FileUtil
Sitecore..::..MainUtil
Sitecore.Web..::..HtmlUtil
Sitecore..::..StringUtil
Sitecore.Web..::..WebUtil
Sitecore.Xml..::..XmlUtil


DateUtil Members

[image] [image]

Sitecore 6.4.1 API
DateUtil Members
DateUtil Class Constructors Methods Properties See Also Send Feedback

The DateUtil type exposes the following members.

Constructors

 | Name | Description
Public method | DateUtil | Initializes a new instance of the DateUtil class

Methods

 | Name | Description
 | DateTimeToMilitary | Converts a DateTime class to an military formatted date/time string.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FormatDateTime | Formats the date time.
 | FormatIsoDate(String) | Formats an ISO formatted date/time string to long date/time string.
 | FormatIsoDate(String, String) | Formats an ISO formatted date/time string using a specified format.
 | FormatLongDateTime(DateTime) | Formats a date in a long format.
 | FormatLongDateTime(DateTime, CultureInfo) | Formats a date in a long format.
 | FormatLongTime | Formats a time span to a string showing hours, minutes and seconds.
 | FormatShortDateTime(DateTime) | Formats a date in a short format.
 | FormatShortDateTime(DateTime, CultureInfo) | Formats a date in a short format.
 | FormatShortTime | Formats a time span to a string showing hours and minutes.
 | FormatTime | Formats the time.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetShortIsoDateTime(DateTime) | Gets the short iso date time.
 | GetShortIsoDateTime(String) | Gets the short iso date time.
 | GetTimeSpanFromMilliseconds | Gets a time span from milliseconds.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsIsoDate | Determines if a string is an Iso date.
 | IsoDateToDateTime(String) | Converts an ISO formatted date/time string to a DateTime class.
 | IsoDateToDateTime(String, DateTime) | Converts an ISO formatted date/time string to a DateTime class.
 | Max(array<DateTime>[]()[][]) | Gets the largest of the specified date/times.
 | Max(array<TimeSpan>[]()[][]) | Gets the largest of the specified time spans.
 | Max(DateTime, DateTime) | Gets the largest of the specified date/times.
 | Max(TimeSpan, TimeSpan) | Gets the largest of the specified time spans.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Min(array<DateTime>[]()[][]) | Gets the smallest of the specified date/times.
 | Min(array<TimeSpan>[]()[][]) | Gets the smallest of the specified time spans.
 | Min(DateTime, DateTime) | Gets the smallest of the specified date/times.
 | Min(TimeSpan, TimeSpan) | Gets the smallest of the specified time spans.
 | ParseDateTime(String, DateTime) | Parses a string into a DateTime structure.
 | ParseDateTime(String, DateTime, CultureInfo) | Parses a string into a DateTime structure.
 | ParseTimeSpan(String) | Parses a time string representing a time span.
 | ParseTimeSpan(String, TimeSpan) | Parses a time string representing a time span.
 | ParseTimeSpan(String, TimeSpan, CultureInfo) | Parses a time string representing a time span.
 | TimeSpanToIsoTime | Converts a TimeSpan into a Iso date string.
 | ToIsoDate(DateTime) | Converts a DateTime class to an ISO formatted date/time string.
 | ToIsoDate(DateTime, Boolean) | Converts a DateTime class to an ISO formatted date/time string.
 | ToIsoTime(DateTime) | Converts a DateTime class to an ISO formatted time string.
 | ToIsoTime(DateTime, Boolean) | Converts a DateTime class to an ISO formatted date/time string.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsoNow | Gets the current time formatted as ISO date/time string.
IsoNowDate | Gets the current date formatted as ISO date string.
IsoNowTime | Gets the current time formatted as ISO time string.
IsoNowWithTicks | Gets the current time formatted as ISO date/time string with ticks appended.
TicksPerMillisecond | Gets the number of ticks per millisecond.

See Also

DateUtil Class
Sitecore Namespace


DateUtil Methods

[image] [image]

Sitecore 6.4.1 API
DateUtil Methods
DateUtil Class See Also Send Feedback

The DateUtil type exposes the following members.

Methods

 | Name | Description
 | DateTimeToMilitary | Converts a DateTime class to an military formatted date/time string.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FormatDateTime | Formats the date time.
 | FormatIsoDate(String) | Formats an ISO formatted date/time string to long date/time string.
 | FormatIsoDate(String, String) | Formats an ISO formatted date/time string using a specified format.
 | FormatLongDateTime(DateTime) | Formats a date in a long format.
 | FormatLongDateTime(DateTime, CultureInfo) | Formats a date in a long format.
 | FormatLongTime | Formats a time span to a string showing hours, minutes and seconds.
 | FormatShortDateTime(DateTime) | Formats a date in a short format.
 | FormatShortDateTime(DateTime, CultureInfo) | Formats a date in a short format.
 | FormatShortTime | Formats a time span to a string showing hours and minutes.
 | FormatTime | Formats the time.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetShortIsoDateTime(DateTime) | Gets the short iso date time.
 | GetShortIsoDateTime(String) | Gets the short iso date time.
 | GetTimeSpanFromMilliseconds | Gets a time span from milliseconds.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsIsoDate | Determines if a string is an Iso date.
 | IsoDateToDateTime(String) | Converts an ISO formatted date/time string to a DateTime class.
 | IsoDateToDateTime(String, DateTime) | Converts an ISO formatted date/time string to a DateTime class.
 | Max(array<DateTime>[]()[][]) | Gets the largest of the specified date/times.
 | Max(array<TimeSpan>[]()[][]) | Gets the largest of the specified time spans.
 | Max(DateTime, DateTime) | Gets the largest of the specified date/times.
 | Max(TimeSpan, TimeSpan) | Gets the largest of the specified time spans.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Min(array<DateTime>[]()[][]) | Gets the smallest of the specified date/times.
 | Min(array<TimeSpan>[]()[][]) | Gets the smallest of the specified time spans.
 | Min(DateTime, DateTime) | Gets the smallest of the specified date/times.
 | Min(TimeSpan, TimeSpan) | Gets the smallest of the specified time spans.
 | ParseDateTime(String, DateTime) | Parses a string into a DateTime structure.
 | ParseDateTime(String, DateTime, CultureInfo) | Parses a string into a DateTime structure.
 | ParseTimeSpan(String) | Parses a time string representing a time span.
 | ParseTimeSpan(String, TimeSpan) | Parses a time string representing a time span.
 | ParseTimeSpan(String, TimeSpan, CultureInfo) | Parses a time string representing a time span.
 | TimeSpanToIsoTime | Converts a TimeSpan into a Iso date string.
 | ToIsoDate(DateTime) | Converts a DateTime class to an ISO formatted date/time string.
 | ToIsoDate(DateTime, Boolean) | Converts a DateTime class to an ISO formatted date/time string.
 | ToIsoTime(DateTime) | Converts a DateTime class to an ISO formatted time string.
 | ToIsoTime(DateTime, Boolean) | Converts a DateTime class to an ISO formatted date/time string.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DateUtil Class
Sitecore Namespace


DateTimeToMilitary Method

[image]

Sitecore 6.4.1 API
DateUtil..::..DateTimeToMilitary Method
DateUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string DateTimeToMilitary(
    DateTime datetime
)
Visual Basic
Public Shared Function DateTimeToMilitary ( _
    datetime As DateTime _
) As String
Visual C++
public:
static String^ DateTimeToMilitary(
    DateTime datetime
)

Parameters

datetime
Type: System..::..DateTime
A DateTime class to be formatted.

Return Value

The military formatted date/time equivalent of the DateTime class.

Remarks

The date/time string is formatted as "yyyyMMddTHHmmss".

Examples

The following example returns Now formatted as an military date.
CopyC#
return DateUtil.DateTimeToMilitary(DateTime.Now);

See Also

DateUtil Class
Sitecore Namespace


FormatDateTime Method

[image]

Sitecore 6.4.1 API
DateUtil..::..FormatDateTime Method
DateUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string FormatDateTime(
    DateTime dateTime,
    string format,
    CultureInfo culture
)
Visual Basic
Public Shared Function FormatDateTime ( _
    dateTime As DateTime, _
    format As String, _
    culture As CultureInfo _
) As String
Visual C++
public:
static String^ FormatDateTime(
    DateTime dateTime,
    String^ format,
    CultureInfo^ culture
)

Parameters

dateTime
Type: System..::..DateTime
The date time.
format
Type: System..::..String
The format.
culture
Type: System.Globalization..::..CultureInfo
The culture.

Return Value

The formatted date time string.

See Also

DateUtil Class
Sitecore Namespace


FormatIsoDate Method

[image] [image]

Sitecore 6.4.1 API
DateUtil..::..FormatIsoDate Method
DateUtil Class See Also Send Feedback

Overload List

Name | Description
FormatIsoDate(String) | Formats an ISO formatted date/time string to long date/time string.
FormatIsoDate(String, String) | Formats an ISO formatted date/time string using a specified format.

See Also

DateUtil Class
DateUtil Members
Sitecore Namespace


FormatIsoDate Method (String)

[image]

Sitecore 6.4.1 API
DateUtil..::..FormatIsoDate Method (String)
DateUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string FormatIsoDate(
    string isoDate
)
Visual Basic
Public Shared Function FormatIsoDate ( _
    isoDate As String _
) As String
Visual C++
public:
static String^ FormatIsoDate(
    String^ isoDate
)

Parameters

isoDate
Type: System..::..String
An ISO formatted date/time string.

Return Value

The date/time in equivalent culture dependant long format.

Remarks

If the time part is omitted from the input parameter, only the date part is formatted.

The date/time string is formatted as "yyyyMMddTHHmmss".

Examples

The following example returns Now formatted as a long ISO date.
CopyC#
string isoNow = DateUtil.IsoNow;
return DateUtil.FormatIsoDate(isoNow);

See Also

DateUtil Class
FormatIsoDate Overload
Sitecore Namespace


FormatIsoDate Method (String, String)

[image]

Sitecore 6.4.1 API
DateUtil..::..FormatIsoDate Method (String, String)
DateUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string FormatIsoDate(
    string isoDate,
    string format
)
Visual Basic
Public Shared Function FormatIsoDate ( _
    isoDate As String, _
    format As String _
) As String
Visual C++
public:
static String^ FormatIsoDate(
    String^ isoDate,
    String^ format
)

Parameters

isoDate
Type: System..::..String
A ISO formatted date/time string.
format
Type: System..::..String
The target format.

Return Value

The formatted date/time. If the date/time string is not valied, blank is returned.

Remarks

The format is specified using .NET formatting codes. See here for more information.

The date/time string is formatted as "yyyyMMddTHHmmss".

Examples

The following example returns Now formatted as a short date pattern.
CopyC#
string isoNow = DateUtil.DateTimeToIsoDate(DateTime.Now);
return DateUtil.FormatIsoDate(isoNow, "d");

See Also

DateUtil Class
FormatIsoDate Overload
Sitecore Namespace


FormatLongDateTime Method

[image] [image]

Sitecore 6.4.1 API
DateUtil..::..FormatLongDateTime Method
DateUtil Class See Also Send Feedback

Overload List

Name | Description
FormatLongDateTime(DateTime) | Formats a date in a long format.
FormatLongDateTime(DateTime, CultureInfo) | Formats a date in a long format.

See Also

DateUtil Class
DateUtil Members
Sitecore Namespace


FormatLongDateTime Method (DateTime)

[image]

Sitecore 6.4.1 API
DateUtil..::..FormatLongDateTime Method (DateTime)
DateUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string FormatLongDateTime(
    DateTime dateTime
)
Visual Basic
Public Shared Function FormatLongDateTime ( _
    dateTime As DateTime _
) As String
Visual C++
public:
static String^ FormatLongDateTime(
    DateTime dateTime
)

Parameters

dateTime
Type: System..::..DateTime
The date time.

Return Value

[Missing <returns> documentation for "M:Sitecore.DateUtil.FormatLongDateTime(System.DateTime)"]

See Also

DateUtil Class
FormatLongDateTime Overload
Sitecore Namespace


FormatLongDateTime Method (DateTime, CultureInfo)

[image]

Sitecore 6.4.1 API
DateUtil..::..FormatLongDateTime Method (DateTime, CultureInfo)
DateUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string FormatLongDateTime(
    DateTime dateTime,
    CultureInfo culture
)
Visual Basic
Public Shared Function FormatLongDateTime ( _
    dateTime As DateTime, _
    culture As CultureInfo _
) As String
Visual C++
public:
static String^ FormatLongDateTime(
    DateTime dateTime,
    CultureInfo^ culture
)

Parameters

dateTime
Type: System..::..DateTime
The date time.
culture
Type: System.Globalization..::..CultureInfo
The culture.

Return Value

[Missing <returns> documentation for "M:Sitecore.DateUtil.FormatLongDateTime(System.DateTime,System.Globalization.CultureInfo)"]

See Also

DateUtil Class
FormatLongDateTime Overload
Sitecore Namespace


FormatLongTime Method

[image]

Sitecore 6.4.1 API
DateUtil..::..FormatLongTime Method
DateUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string FormatLongTime(
    TimeSpan time
)
Visual Basic
Public Shared Function FormatLongTime ( _
    time As TimeSpan _
) As String
Visual C++
public:
static String^ FormatLongTime(
    TimeSpan time
)

Parameters

time
Type: System..::..TimeSpan
The time.

Return Value

[Missing <returns> documentation for "M:Sitecore.DateUtil.FormatLongTime(System.TimeSpan)"]

See Also

DateUtil Class
Sitecore Namespace


FormatShortDateTime Method (DateTime, CultureInfo)

[image]

Sitecore 6.4.1 API
DateUtil..::..FormatShortDateTime Method (DateTime, CultureInfo)
DateUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string FormatShortDateTime(
    DateTime dateTime,
    CultureInfo culture
)
Visual Basic
Public Shared Function FormatShortDateTime ( _
    dateTime As DateTime, _
    culture As CultureInfo _
) As String
Visual C++
public:
static String^ FormatShortDateTime(
    DateTime dateTime,
    CultureInfo^ culture
)

Parameters

dateTime
Type: System..::..DateTime
The date time.
culture
Type: System.Globalization..::..CultureInfo
The culture.

Return Value

[Missing <returns> documentation for "M:Sitecore.DateUtil.FormatShortDateTime(System.DateTime,System.Globalization.CultureInfo)"]

See Also

DateUtil Class
FormatShortDateTime Overload
Sitecore Namespace


FormatShortTime Method

[image]

Sitecore 6.4.1 API
DateUtil..::..FormatShortTime Method
DateUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string FormatShortTime(
    TimeSpan time
)
Visual Basic
Public Shared Function FormatShortTime ( _
    time As TimeSpan _
) As String
Visual C++
public:
static String^ FormatShortTime(
    TimeSpan time
)

Parameters

time
Type: System..::..TimeSpan
The time.

Return Value

[Missing <returns> documentation for "M:Sitecore.DateUtil.FormatShortTime(System.TimeSpan)"]

See Also

DateUtil Class
Sitecore Namespace


FormatTime Method

[image]

Sitecore 6.4.1 API
DateUtil..::..FormatTime Method
DateUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string FormatTime(
    TimeSpan time,
    string format,
    CultureInfo culture
)
Visual Basic
Public Shared Function FormatTime ( _
    time As TimeSpan, _
    format As String, _
    culture As CultureInfo _
) As String
Visual C++
public:
static String^ FormatTime(
    TimeSpan time,
    String^ format,
    CultureInfo^ culture
)

Parameters

time
Type: System..::..TimeSpan
The time.
format
Type: System..::..String
The format.
culture
Type: System.Globalization..::..CultureInfo
The culture.

Return Value

The time.

See Also

DateUtil Class
Sitecore Namespace


GetShortIsoDateTime Method

[image] [image]

Sitecore 6.4.1 API
DateUtil..::..GetShortIsoDateTime Method
DateUtil Class See Also Send Feedback

Overload List

Name | Description
GetShortIsoDateTime(DateTime) | Gets the short iso date time.
GetShortIsoDateTime(String) | Gets the short iso date time.

See Also

DateUtil Class
DateUtil Members
Sitecore Namespace


GetShortIsoDateTime Method (DateTime)

[image]

Sitecore 6.4.1 API
DateUtil..::..GetShortIsoDateTime Method (DateTime)
DateUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetShortIsoDateTime(
    DateTime date
)
Visual Basic
Public Shared Function GetShortIsoDateTime ( _
    date As DateTime _
) As String
Visual C++
public:
static String^ GetShortIsoDateTime(
    DateTime date
)

Parameters

date
Type: System..::..DateTime
The date.

Return Value

[Missing <returns> documentation for "M:Sitecore.DateUtil.GetShortIsoDateTime(System.DateTime)"]

See Also

DateUtil Class
GetShortIsoDateTime Overload
Sitecore Namespace


GetShortIsoDateTime Method (String)

[image]

Sitecore 6.4.1 API
DateUtil..::..GetShortIsoDateTime Method (String)
DateUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetShortIsoDateTime(
    string isoDateTime
)
Visual Basic
Public Shared Function GetShortIsoDateTime ( _
    isoDateTime As String _
) As String
Visual C++
public:
static String^ GetShortIsoDateTime(
    String^ isoDateTime
)

Parameters

isoDateTime
Type: System..::..String
The iso date time.

Return Value

[Missing <returns> documentation for "M:Sitecore.DateUtil.GetShortIsoDateTime(System.String)"]

See Also

DateUtil Class
GetShortIsoDateTime Overload
Sitecore Namespace


GetTimeSpanFromMilliseconds Method

[image]

Sitecore 6.4.1 API
DateUtil..::..GetTimeSpanFromMilliseconds Method
DateUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TimeSpan GetTimeSpanFromMilliseconds(
    double milliseconds
)
Visual Basic
Public Shared Function GetTimeSpanFromMilliseconds ( _
    milliseconds As Double _
) As TimeSpan
Visual C++
public:
static TimeSpan GetTimeSpanFromMilliseconds(
    double milliseconds
)

Parameters

milliseconds
Type: System..::..Double
The milliseconds.

Return Value

[Missing <returns> documentation for "M:Sitecore.DateUtil.GetTimeSpanFromMilliseconds(System.Double)"]

See Also

DateUtil Class
Sitecore Namespace


IsIsoDate Method

[image]

Sitecore 6.4.1 API
DateUtil..::..IsIsoDate Method
DateUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsIsoDate(
    string value
)
Visual Basic
Public Shared Function IsIsoDate ( _
    value As String _
) As Boolean
Visual C++
public:
static bool IsIsoDate(
    String^ value
)

Parameters

value
Type: System..::..String
The value.

Return Value

true if [is iso date] [the specified value]; otherwise, false.

See Also

DateUtil Class
Sitecore Namespace


IsoDateToDateTime Method

[image] [image]

Sitecore 6.4.1 API
DateUtil..::..IsoDateToDateTime Method
DateUtil Class See Also Send Feedback

Overload List

Name | Description
IsoDateToDateTime(String) | Converts an ISO formatted date/time string to a DateTime class.
IsoDateToDateTime(String, DateTime) | Converts an ISO formatted date/time string to a DateTime class.

See Also

DateUtil Class
DateUtil Members
Sitecore Namespace


IsoDateToDateTime Method (String)

[image]

Sitecore 6.4.1 API
DateUtil..::..IsoDateToDateTime Method (String)
DateUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static DateTime IsoDateToDateTime(
    string isoDate
)
Visual Basic
Public Shared Function IsoDateToDateTime ( _
    isoDate As String _
) As DateTime
Visual C++
public:
static DateTime IsoDateToDateTime(
    String^ isoDate
)

Parameters

isoDate
Type: System..::..String
An ISO formatted date/time string.

Return Value

The DateTime class equivalent of the date/time string. If the date/time is not valid, DateTime.MinValue is returned.

Remarks

The date/time string is formatted as "yyyyMMddTHHmmss".

Examples

The following example converts an ISO formatted date/time string to a DateTime class.
CopyC#
string isoNow = DateUtil.IsoNow;
DateTime now = DateUtil.IsoDateToDateTime(isoNow);

See Also

DateUtil Class
IsoDateToDateTime Overload
Sitecore Namespace


IsoDateToDateTime Method (String, DateTime)

[image]

Sitecore 6.4.1 API
DateUtil..::..IsoDateToDateTime Method (String, DateTime)
DateUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static DateTime IsoDateToDateTime(
    string isoDate,
    DateTime defaultValue
)
Visual Basic
Public Shared Function IsoDateToDateTime ( _
    isoDate As String, _
    defaultValue As DateTime _
) As DateTime
Visual C++
public:
static DateTime IsoDateToDateTime(
    String^ isoDate,
    DateTime defaultValue
)

Parameters

isoDate
Type: System..::..String
An ISO formatted date/time string.
defaultValue
Type: System..::..DateTime
Default value to use if isoDate can not be converted to a date/time.

Return Value

The DateTime class equivalent of the date/time string. If the date/time is not valid, DateTime.MinValue is returned.

Remarks

The date/time string is formatted as "yyyyMMddTHHmmss".

Examples

The following example converts an ISO formatted date/time string to a DateTime class.
CopyC#
string isoNow = DateUtil.IsoNow;
DateTime now = DateUtil.IsoDateToDateTime(isoNow);

See Also

DateUtil Class
IsoDateToDateTime Overload
Sitecore Namespace


Max Method

[image] [image]

Sitecore 6.4.1 API
DateUtil..::..Max Method
DateUtil Class See Also Send Feedback

Overload List

Name | Description
Max(array<DateTime>[]()[][]) | Gets the largest of the specified date/times.
Max(array<TimeSpan>[]()[][]) | Gets the largest of the specified time spans.
Max(DateTime, DateTime) | Gets the largest of the specified date/times.
Max(TimeSpan, TimeSpan) | Gets the largest of the specified time spans.

See Also

DateUtil Class
DateUtil Members
Sitecore Namespace


Max Method (DateTime[])

[image]

Sitecore 6.4.1 API
DateUtil..::..Max Method (array<DateTime>[]()[][])
DateUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static DateTime Max(
    params DateTime[] dateTimes
)
Visual Basic
Public Shared Function Max ( _
    ParamArray dateTimes As DateTime() _
) As DateTime
Visual C++
public:
static DateTime Max(
    ... array<DateTime>^ dateTimes
)

Parameters

dateTimes
Type: array< System..::..DateTime >[]()[][]
The date times.

Return Value

[Missing <returns> documentation for "M:Sitecore.DateUtil.Max(System.DateTime[])"]

See Also

DateUtil Class
Max Overload
Sitecore Namespace


Max Method (TimeSpan[])

[image]

Sitecore 6.4.1 API
DateUtil..::..Max Method (array<TimeSpan>[]()[][])
DateUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TimeSpan Max(
    params TimeSpan[] times
)
Visual Basic
Public Shared Function Max ( _
    ParamArray times As TimeSpan() _
) As TimeSpan
Visual C++
public:
static TimeSpan Max(
    ... array<TimeSpan>^ times
)

Parameters

times
Type: array< System..::..TimeSpan >[]()[][]
The times.

Return Value

[Missing <returns> documentation for "M:Sitecore.DateUtil.Max(System.TimeSpan[])"]

See Also

DateUtil Class
Max Overload
Sitecore Namespace


Max Method (DateTime, DateTime)

[image]

Sitecore 6.4.1 API
DateUtil..::..Max Method (DateTime, DateTime)
DateUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static DateTime Max(
    DateTime dateTime1,
    DateTime dateTime2
)
Visual Basic
Public Shared Function Max ( _
    dateTime1 As DateTime, _
    dateTime2 As DateTime _
) As DateTime
Visual C++
public:
static DateTime Max(
    DateTime dateTime1,
    DateTime dateTime2
)

Parameters

dateTime1
Type: System..::..DateTime
The date time1.
dateTime2
Type: System..::..DateTime
The date time2.

Return Value

[Missing <returns> documentation for "M:Sitecore.DateUtil.Max(System.DateTime,System.DateTime)"]

See Also

DateUtil Class
Max Overload
Sitecore Namespace


Max Method (TimeSpan, TimeSpan)

[image]

Sitecore 6.4.1 API
DateUtil..::..Max Method (TimeSpan, TimeSpan)
DateUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TimeSpan Max(
    TimeSpan time1,
    TimeSpan time2
)
Visual Basic
Public Shared Function Max ( _
    time1 As TimeSpan, _
    time2 As TimeSpan _
) As TimeSpan
Visual C++
public:
static TimeSpan Max(
    TimeSpan time1,
    TimeSpan time2
)

Parameters

time1
Type: System..::..TimeSpan
The time1.
time2
Type: System..::..TimeSpan
The time2.

Return Value

[Missing <returns> documentation for "M:Sitecore.DateUtil.Max(System.TimeSpan,System.TimeSpan)"]

See Also

DateUtil Class
Max Overload
Sitecore Namespace


Min Method

[image] [image]

Sitecore 6.4.1 API
DateUtil..::..Min Method
DateUtil Class See Also Send Feedback

Overload List

Name | Description
Min(array<DateTime>[]()[][]) | Gets the smallest of the specified date/times.
Min(array<TimeSpan>[]()[][]) | Gets the smallest of the specified time spans.
Min(DateTime, DateTime) | Gets the smallest of the specified date/times.
Min(TimeSpan, TimeSpan) | Gets the smallest of the specified time spans.

See Also

DateUtil Class
DateUtil Members
Sitecore Namespace


Min Method (DateTime[])

[image]

Sitecore 6.4.1 API
DateUtil..::..Min Method (array<DateTime>[]()[][])
DateUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static DateTime Min(
    params DateTime[] dateTimes
)
Visual Basic
Public Shared Function Min ( _
    ParamArray dateTimes As DateTime() _
) As DateTime
Visual C++
public:
static DateTime Min(
    ... array<DateTime>^ dateTimes
)

Parameters

dateTimes
Type: array< System..::..DateTime >[]()[][]
The date times.

Return Value

[Missing <returns> documentation for "M:Sitecore.DateUtil.Min(System.DateTime[])"]

See Also

DateUtil Class
Min Overload
Sitecore Namespace


Min Method (TimeSpan[])

[image]

Sitecore 6.4.1 API
DateUtil..::..Min Method (array<TimeSpan>[]()[][])
DateUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TimeSpan Min(
    params TimeSpan[] times
)
Visual Basic
Public Shared Function Min ( _
    ParamArray times As TimeSpan() _
) As TimeSpan
Visual C++
public:
static TimeSpan Min(
    ... array<TimeSpan>^ times
)

Parameters

times
Type: array< System..::..TimeSpan >[]()[][]
The times.

Return Value

[Missing <returns> documentation for "M:Sitecore.DateUtil.Min(System.TimeSpan[])"]

See Also

DateUtil Class
Min Overload
Sitecore Namespace


Min Method (DateTime, DateTime)

[image]

Sitecore 6.4.1 API
DateUtil..::..Min Method (DateTime, DateTime)
DateUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static DateTime Min(
    DateTime dateTime1,
    DateTime dateTime2
)
Visual Basic
Public Shared Function Min ( _
    dateTime1 As DateTime, _
    dateTime2 As DateTime _
) As DateTime
Visual C++
public:
static DateTime Min(
    DateTime dateTime1,
    DateTime dateTime2
)

Parameters

dateTime1
Type: System..::..DateTime
The date time1.
dateTime2
Type: System..::..DateTime
The date time2.

Return Value

[Missing <returns> documentation for "M:Sitecore.DateUtil.Min(System.DateTime,System.DateTime)"]

See Also

DateUtil Class
Min Overload
Sitecore Namespace


Min Method (TimeSpan, TimeSpan)

[image]

Sitecore 6.4.1 API
DateUtil..::..Min Method (TimeSpan, TimeSpan)
DateUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TimeSpan Min(
    TimeSpan time1,
    TimeSpan time2
)
Visual Basic
Public Shared Function Min ( _
    time1 As TimeSpan, _
    time2 As TimeSpan _
) As TimeSpan
Visual C++
public:
static TimeSpan Min(
    TimeSpan time1,
    TimeSpan time2
)

Parameters

time1
Type: System..::..TimeSpan
The time1.
time2
Type: System..::..TimeSpan
The time2.

Return Value

[Missing <returns> documentation for "M:Sitecore.DateUtil.Min(System.TimeSpan,System.TimeSpan)"]

See Also

DateUtil Class
Min Overload
Sitecore Namespace


ParseDateTime Method

[image] [image]

Sitecore 6.4.1 API
DateUtil..::..ParseDateTime Method
DateUtil Class See Also Send Feedback

Overload List

Name | Description
ParseDateTime(String, DateTime) | Parses a string into a DateTime structure.
ParseDateTime(String, DateTime, CultureInfo) | Parses a string into a DateTime structure.

See Also

DateUtil Class
DateUtil Members
Sitecore Namespace


ParseDateTime Method (String, DateTime)

[image]

Sitecore 6.4.1 API
DateUtil..::..ParseDateTime Method (String, DateTime)
DateUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static DateTime ParseDateTime(
    string value,
    DateTime defaultValue
)
Visual Basic
Public Shared Function ParseDateTime ( _
    value As String, _
    defaultValue As DateTime _
) As DateTime
Visual C++
public:
static DateTime ParseDateTime(
    String^ value,
    DateTime defaultValue
)

Parameters

value
Type: System..::..String
The value.
defaultValue
Type: System..::..DateTime
The default value.

Return Value

[Missing <returns> documentation for "M:Sitecore.DateUtil.ParseDateTime(System.String,System.DateTime)"]

See Also

DateUtil Class
ParseDateTime Overload
Sitecore Namespace


ParseDateTime Method (String, DateTime, CultureInfo)

[image]

Sitecore 6.4.1 API
DateUtil..::..ParseDateTime Method (String, DateTime, CultureInfo)
DateUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static DateTime ParseDateTime(
    string value,
    DateTime defaultValue,
    CultureInfo info
)
Visual Basic
Public Shared Function ParseDateTime ( _
    value As String, _
    defaultValue As DateTime, _
    info As CultureInfo _
) As DateTime
Visual C++
public:
static DateTime ParseDateTime(
    String^ value,
    DateTime defaultValue,
    CultureInfo^ info
)

Parameters

value
Type: System..::..String
The value.
defaultValue
Type: System..::..DateTime
The default value.
info
Type: System.Globalization..::..CultureInfo
The info.

Return Value

[Missing <returns> documentation for "M:Sitecore.DateUtil.ParseDateTime(System.String,System.DateTime,System.Globalization.CultureInfo)"]

See Also

DateUtil Class
ParseDateTime Overload
Sitecore Namespace


ParseTimeSpan Method

[image] [image]

Sitecore 6.4.1 API
DateUtil..::..ParseTimeSpan Method
DateUtil Class See Also Send Feedback

Overload List

Name | Description
ParseTimeSpan(String) | Parses a time string representing a time span.
ParseTimeSpan(String, TimeSpan) | Parses a time string representing a time span.
ParseTimeSpan(String, TimeSpan, CultureInfo) | Parses a time string representing a time span.

See Also

DateUtil Class
DateUtil Members
Sitecore Namespace


ParseTimeSpan Method (String)

[image]

Sitecore 6.4.1 API
DateUtil..::..ParseTimeSpan Method (String)
DateUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TimeSpan ParseTimeSpan(
    string time
)
Visual Basic
Public Shared Function ParseTimeSpan ( _
    time As String _
) As TimeSpan
Visual C++
public:
static TimeSpan ParseTimeSpan(
    String^ time
)

Parameters

time
Type: System..::..String
The time in the format "00:00:00" or "00:00:00:00".

Return Value

A TimeSpan class representing the Itime string.

Remarks

Format must be 00:00:00 representing hours, minutes and seconds. A fourth optional part may be added, representing milliseconds (ie. 00:00:00:00)

Examples

The following example returns the TimeSpan eqivalent of the time string.
CopyC#
string timeString = "13:45:00";
TimeSpan timeSpan = DateUtil.ParseTimeSpan(timeString);

See Also

DateUtil Class
ParseTimeSpan Overload
Sitecore Namespace


ParseTimeSpan Method (String, TimeSpan)

[image]

Sitecore 6.4.1 API
DateUtil..::..ParseTimeSpan Method (String, TimeSpan)
DateUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TimeSpan ParseTimeSpan(
    string time,
    TimeSpan defaultValue
)
Visual Basic
Public Shared Function ParseTimeSpan ( _
    time As String, _
    defaultValue As TimeSpan _
) As TimeSpan
Visual C++
public:
static TimeSpan ParseTimeSpan(
    String^ time,
    TimeSpan defaultValue
)

Parameters

time
Type: System..::..String
The time in the format "00:00:00" or "00:00:00:00".
defaultValue
Type: System..::..TimeSpan
Default value to return if time can not be parsed.

Return Value

A TimeSpan class representing the Itime string.

Remarks

Format must be 00:00:00 representing hours, minutes and seconds. A fourth optional part may be added, representing milliseconds (ie. 00:00:00:00)

Examples

The following example returns the TimeSpan eqivalent of the time string.
CopyC#
string timeString = "13:45:00";
TimeSpan timeSpan = DateUtil.ParseTimeSpan(timeString);

See Also

DateUtil Class
ParseTimeSpan Overload
Sitecore Namespace


ParseTimeSpan Method (String, TimeSpan, CultureInfo)

[image]

Sitecore 6.4.1 API
DateUtil..::..ParseTimeSpan Method (String, TimeSpan, CultureInfo)
DateUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TimeSpan ParseTimeSpan(
    string time,
    TimeSpan defaultValue,
    CultureInfo cultureInfo
)
Visual Basic
Public Shared Function ParseTimeSpan ( _
    time As String, _
    defaultValue As TimeSpan, _
    cultureInfo As CultureInfo _
) As TimeSpan
Visual C++
public:
static TimeSpan ParseTimeSpan(
    String^ time,
    TimeSpan defaultValue,
    CultureInfo^ cultureInfo
)

Parameters

time
Type: System..::..String
The time in the format "00:00:00" or "00:00:00:00".
defaultValue
Type: System..::..TimeSpan
Default value to return if time can not be parsed.
cultureInfo
Type: System.Globalization..::..CultureInfo
The culture info.

Return Value

A TimeSpan class representing the Itime string.

Remarks

Format must be 00:00:00 representing hours, minutes and seconds. A fourth optional part may be added, representing milliseconds (ie. 00:00:00:00)

Examples

The following example returns the TimeSpan eqivalent of the time string.
CopyC#
string timeString = "13:45:00";
TimeSpan timeSpan = DateUtil.ParseTimeSpan(timeString);

See Also

DateUtil Class
ParseTimeSpan Overload
Sitecore Namespace


TimeSpanToIsoTime Method

[image]

Sitecore 6.4.1 API
DateUtil..::..TimeSpanToIsoTime Method
DateUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string TimeSpanToIsoTime(
    TimeSpan interval
)
Visual Basic
Public Shared Function TimeSpanToIsoTime ( _
    interval As TimeSpan _
) As String
Visual C++
public:
static String^ TimeSpanToIsoTime(
    TimeSpan interval
)

Parameters

interval
Type: System..::..TimeSpan
The interval.

Return Value

[Missing <returns> documentation for "M:Sitecore.DateUtil.TimeSpanToIsoTime(System.TimeSpan)"]

See Also

DateUtil Class
Sitecore Namespace


ToIsoDate Method

[image] [image]

Sitecore 6.4.1 API
DateUtil..::..ToIsoDate Method
DateUtil Class See Also Send Feedback

Overload List

Name | Description
ToIsoDate(DateTime) | Converts a DateTime class to an ISO formatted date/time string.
ToIsoDate(DateTime, Boolean) | Converts a DateTime class to an ISO formatted date/time string.

See Also

DateUtil Class
DateUtil Members
Sitecore Namespace


ToIsoDate Method (DateTime, Boolean)

[image]

Sitecore 6.4.1 API
DateUtil..::..ToIsoDate Method (DateTime, Boolean)
DateUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ToIsoDate(
    DateTime datetime,
    bool includeTicks
)
Visual Basic
Public Shared Function ToIsoDate ( _
    datetime As DateTime, _
    includeTicks As Boolean _
) As String
Visual C++
public:
static String^ ToIsoDate(
    DateTime datetime,
    bool includeTicks
)

Parameters

datetime
Type: System..::..DateTime
A DateTime class to be formatted.
includeTicks
Type: System..::..Boolean
if set to true [include ticks].

Return Value

The ISO formatted date/time equivalent of the DateTime class.

Remarks

The date/time string is formatted as "yyyyMMddTHHmmss".

Examples

The following example returns Now formatted as an ISO date.
CopyC#
return DateUtil.DateTimeToIsoDate(DateTime.Now);

See Also

DateUtil Class
ToIsoDate Overload
Sitecore Namespace


ToIsoTime Method

[image] [image]

Sitecore 6.4.1 API
DateUtil..::..ToIsoTime Method
DateUtil Class See Also Send Feedback

Overload List

Name | Description
ToIsoTime(DateTime) | Converts a DateTime class to an ISO formatted time string.
ToIsoTime(DateTime, Boolean) | Converts a DateTime class to an ISO formatted date/time string.

See Also

DateUtil Class
DateUtil Members
Sitecore Namespace


ToIsoTime Method (DateTime)

[image]

Sitecore 6.4.1 API
DateUtil..::..ToIsoTime Method (DateTime)
DateUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ToIsoTime(
    DateTime datetime
)
Visual Basic
Public Shared Function ToIsoTime ( _
    datetime As DateTime _
) As String
Visual C++
public:
static String^ ToIsoTime(
    DateTime datetime
)

Parameters

datetime
Type: System..::..DateTime
A DateTime class to be formatted.

Return Value

The ISO formatted time equivalent of the DateTime class.

Remarks

The time string is formatted as "HHmmss".

Examples

The following example returns Now formatted as an ISO time.
CopyC#
return DateUtil.ToIsoTime(DateTime.Now);

See Also

DateUtil Class
ToIsoTime Overload
Sitecore Namespace


ToIsoTime Method (DateTime, Boolean)

[image]

Sitecore 6.4.1 API
DateUtil..::..ToIsoTime Method (DateTime, Boolean)
DateUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ToIsoTime(
    DateTime datetime,
    bool includeTicks
)
Visual Basic
Public Shared Function ToIsoTime ( _
    datetime As DateTime, _
    includeTicks As Boolean _
) As String
Visual C++
public:
static String^ ToIsoTime(
    DateTime datetime,
    bool includeTicks
)

Parameters

datetime
Type: System..::..DateTime
A DateTime class to be formatted.
includeTicks
Type: System..::..Boolean
if set to true [include ticks].

Return Value

The ISO formatted date/time equivalent of the DateTime class.

Remarks

The date/time string is formatted as "yyyyMMddTHHmmss".

Examples

The following example returns Now formatted as an ISO date.
CopyC#
return DateUtil.DateTimeToIsoDate(DateTime.Now);

See Also

DateUtil Class
ToIsoTime Overload
Sitecore Namespace


DateUtil Properties

[image] [image]

Sitecore 6.4.1 API
DateUtil Properties
DateUtil Class See Also Send Feedback

The DateUtil type exposes the following members.

Properties

Name | Description
IsoNow | Gets the current time formatted as ISO date/time string.
IsoNowDate | Gets the current date formatted as ISO date string.
IsoNowTime | Gets the current time formatted as ISO time string.
IsoNowWithTicks | Gets the current time formatted as ISO date/time string with ticks appended.
TicksPerMillisecond | Gets the number of ticks per millisecond.

See Also

DateUtil Class
Sitecore Namespace


IsoNow Property

[image]

Sitecore 6.4.1 API
DateUtil..::..IsoNow Property
DateUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string IsoNow { get; }
Visual Basic
Public Shared ReadOnly Property IsoNow As String
    Get
Visual C++
public:
static property String^ IsoNow {
    String^ get ();
}

Field Value

Now formatted as a ISO formatted date/time string.

Remarks

The date/time string is formatted as "yyyyMMddTHHmmss".

Examples

The following example sets isoNow to now in ISO format.
CopyC#
string isoNow = DateUtil.IsoNow;

See Also

DateUtil Class
Sitecore Namespace


IsoNowDate Property

[image]

Sitecore 6.4.1 API
DateUtil..::..IsoNowDate Property
DateUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string IsoNowDate { get; }
Visual Basic
Public Shared ReadOnly Property IsoNowDate As String
    Get
Visual C++
public:
static property String^ IsoNowDate {
    String^ get ();
}

Field Value

Now formatted as a ISO formatted date string.

Remarks

The date string is formatted as "yyyyMMdd".

Examples

The following example sets isoNow to the current date in ISO format.
CopyC#
string isoNow = DateUtil.IsoNowDate;

See Also

DateUtil Class
Sitecore Namespace


IsoNowTime Property

[image]

Sitecore 6.4.1 API
DateUtil..::..IsoNowTime Property
DateUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string IsoNowTime { get; }
Visual Basic
Public Shared ReadOnly Property IsoNowTime As String
    Get
Visual C++
public:
static property String^ IsoNowTime {
    String^ get ();
}

Field Value

Now formatted as a ISO formatted time string.

Remarks

The time string is formatted as "HHmmss".

Examples

The following example sets isoNow to the ciurrent time in ISO format.
CopyC#
string isoNow = DateUtil.IsoNowTime;

See Also

DateUtil Class
Sitecore Namespace


IsoNowWithTicks Property

[image]

Sitecore 6.4.1 API
DateUtil..::..IsoNowWithTicks Property
DateUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string IsoNowWithTicks { get; }
Visual Basic
Public Shared ReadOnly Property IsoNowWithTicks As String
    Get
Visual C++
public:
static property String^ IsoNowWithTicks {
    String^ get ();
}

Field Value

Now formatted as a ISO formatted date/time string.

Remarks

The date/time string is formatted as "yyyyMMddTHHmmss" and ":{ticks}" is appended.

Examples

The following example sets isoNow to now in ISO format.
CopyC#
string isoNow = DateUtil.IsoNowWithTicks;  // might return 20012008T102817:2382193728213

See Also

DateUtil Class
Sitecore Namespace


TicksPerMillisecond Property

[image]

Sitecore 6.4.1 API
DateUtil..::..TicksPerMillisecond Property
DateUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long TicksPerMillisecond { get; }
Visual Basic
Public Shared ReadOnly Property TicksPerMillisecond As Long
    Get
Visual C++
public:
static property long long TicksPerMillisecond {
    long long get ();
}

Field Value

The ticks per millisecond.

See Also

DateUtil Class
Sitecore Namespace


DefaultPage Class

[image]

Sitecore 6.4.1 API
DefaultPage Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DefaultPage : Page
Visual Basic
Public Class DefaultPage _
    Inherits Page
Visual C++
public ref class DefaultPage : public Page

Inheritance Hierarchy

System..::..Object
System.Web.UI..::..Control
System.Web.UI..::..TemplateControl
System.Web.UI..::..Page
Sitecore..::..DefaultPage

See Also

DefaultPage Members
Sitecore Namespace


DefaultPage Members

[image] [image]

Sitecore 6.4.1 API
DefaultPage Members
DefaultPage Class Constructors Methods Properties Events See Also Send Feedback

The DefaultPage type exposes the following members.

Constructors

 | Name | Description
Public method | DefaultPage | Initializes a new instance of the DefaultPage class

Methods

 | Name | Description
Protected method | AddContentTemplate | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Public method | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
Public method | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Protected method | AddWrappedFileDependencies | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | AspCompatBeginProcessRequest | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
Protected method | AspCompatEndProcessRequest | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
Protected method | AsyncPageBeginProcessRequest | Begins processing an asynchronous page request. (Inherited from Page.)
Protected method | AsyncPageEndProcessRequest | Ends processing an asynchronous page request. (Inherited from Page.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Protected method | Construct | Performs design-time logic. (Inherited from TemplateControl.)
Protected method | CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Protected method | CreateHtmlTextWriter | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
Protected method | CreateResourceBasedLiteralControl | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Public method | DesignerInitialize | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
Protected method | DeterminePostBackMode | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
Protected method | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
Public method | ExecuteRegisteredAsyncTasks | Starts the execution of an asynchronous task. (Inherited from Page.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | FrameworkInitialize | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
Public method | GetDataItem | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Protected method | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
Protected method | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
Protected method | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
Public method | GetPostBackClientEvent | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
Public method | GetPostBackClientHyperlink | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
Public method | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
Public method | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeHashCode | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
Public method | GetValidators | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
Protected method | GetWrappedFileDependencies | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Protected method | InitializeCulture | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
Protected method | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
Protected method | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
Protected method | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
Public method | IsClientScriptBlockRegistered | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Public method | IsStartupScriptRegistered | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
Public method | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
Public method | LoadControl(Type, array<Object>[]()[][]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
Protected method | LoadPageStateFromPersistenceMedium | Loads any saved view-state information to the Page object. (Inherited from Page.)
Public method | LoadTemplate | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
Protected method | LoadViewState | Restores view-state information from a previous page request that was saved by the SaveViewState()()()() method. (Inherited from Control.)
Public method | MapPath | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAbortTransaction | Raises the AbortTransaction event. (Inherited from TemplateControl.)
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnCommitTransaction | Raises the CommitTransaction event. (Inherited from TemplateControl.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnError | Raises the Error event. (Inherited from TemplateControl.)
Protected method | OnInit | Raises the Init event to initialize the page. (Overrides Page..::..OnInit(EventArgs).)
Protected method | OnInitComplete | Raises the InitComplete event after page initialization. (Inherited from Page.)
Protected method | OnLoad | Raises the Load event. (Inherited from Control.)
Protected method | OnLoadComplete | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
Protected method | OnPreInit | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
Protected method | OnPreLoad | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
Protected method | OnPreRender | Raises the PreRender event. (Inherited from Control.)
Protected method | OnPreRenderComplete | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
Protected method | OnSaveStateComplete | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Protected method | Page_Load | Handles the Load event of the Page control.
Public method | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
Public method | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
Public method | ProcessRequest | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Protected method | RaisePostBackEvent | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
Public method | ReadStringResource | Reads a string resource. The ReadStringResource()()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | RegisterArrayDeclaration | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
Public method | RegisterAsyncTask | Registers a new asynchronous task with the page. (Inherited from Page.)
Public method | RegisterClientScriptBlock | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
Public method | RegisterHiddenField | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
Public method | RegisterOnSubmitStatement | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
Public method | RegisterRequiresControlState | Registers a control as one whose control state must be persisted. (Inherited from Page.)
Public method | RegisterRequiresPostBack | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
Public method | RegisterRequiresRaiseEvent | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
Public method | RegisterRequiresViewStateEncryption | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
Public method | RegisterStartupScript | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
Public method | RegisterViewStateHandler | Causes page view state to be persisted, if called. (Inherited from Page.)
Protected method | RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Protected method | Render | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Public method | RequiresControlState | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SavePageStateToPersistenceMedium | Saves any view-state and control-state information for the page. (Inherited from Page.)
Protected method | SaveViewState | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
Public method | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Protected method | SetStringResourcePointer | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | TestDeviceFilter | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TrackViewState | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
Public method | UnregisterRequiresControlState | Stops persistence of control state for the specified control. (Inherited from Page.)
Public method | Validate()()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
Public method | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
Public method | VerifyRenderingInServerForm | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
Protected method | WriteUTF8ResourceString | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
Protected method | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
Protected method | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
Protected method | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
Protected method | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
Protected method | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Protected method | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)

Properties

 | Name | Description
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
Protected property | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
Protected property | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
Public property | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
Protected property | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
Public property | AutoPostBackControl | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
Public property | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Public property | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
Public property | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
Public property | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
Public property | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
Public property | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
Protected property | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
Public property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
Public property | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Public property | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
Public property | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
Public property | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
Public property | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
Public property | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Protected property | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
Public property | Form | Gets the HTML form for the page. (Inherited from Page.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Public property | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
Public property | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
Public property | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
Public property | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
Public property | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Public property | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
Public property | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
Public property | IsPostBackEventControlRegistered | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
Public property | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Public property | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Public property | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
Public property | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Public property | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
Public property | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
Public property | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
Public property | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
Protected property | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
Public property | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
Public property | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
Public property | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
Public property | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
Public property | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
Public property | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
Public property | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
Public property | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
Protected property | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
Public property | Title | Gets or sets the title for the page. (Inherited from Page.)
Public property | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
Public property | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
Public property | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
Protected property | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
Public property | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
Protected property | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
Public property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
Public property | User | Gets information about the user making the page request. (Inherited from Page.)
Public property | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Public property | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
Public property | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)

Events

 | Name | Description
Public event | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
Public event | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
Public event | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
Public event | PreLoad | Occurs before the page Load event. (Inherited from Page.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
Public event | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

See Also

DefaultPage Class
Sitecore Namespace


DefaultPage Constructor

[image]

Sitecore 6.4.1 API
DefaultPage Constructor
DefaultPage Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DefaultPage()
Visual Basic
Public Sub New
Visual C++
public:
DefaultPage()

See Also

DefaultPage Class
Sitecore Namespace


DefaultPage Methods

[image] [image]

Sitecore 6.4.1 API
DefaultPage Methods
DefaultPage Class See Also Send Feedback

The DefaultPage type exposes the following members.

Methods

 | Name | Description
Protected method | AddContentTemplate | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Public method | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
Public method | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Protected method | AddWrappedFileDependencies | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | AspCompatBeginProcessRequest | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
Protected method | AspCompatEndProcessRequest | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
Protected method | AsyncPageBeginProcessRequest | Begins processing an asynchronous page request. (Inherited from Page.)
Protected method | AsyncPageEndProcessRequest | Ends processing an asynchronous page request. (Inherited from Page.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Protected method | Construct | Performs design-time logic. (Inherited from TemplateControl.)
Protected method | CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Protected method | CreateHtmlTextWriter | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
Protected method | CreateResourceBasedLiteralControl | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Public method | DesignerInitialize | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
Protected method | DeterminePostBackMode | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
Protected method | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
Public method | ExecuteRegisteredAsyncTasks | Starts the execution of an asynchronous task. (Inherited from Page.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | FrameworkInitialize | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
Public method | GetDataItem | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Protected method | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
Protected method | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
Protected method | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
Public method | GetPostBackClientEvent | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
Public method | GetPostBackClientHyperlink | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
Public method | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
Public method | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeHashCode | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
Public method | GetValidators | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
Protected method | GetWrappedFileDependencies | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Protected method | InitializeCulture | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
Protected method | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
Protected method | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
Protected method | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
Public method | IsClientScriptBlockRegistered | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Public method | IsStartupScriptRegistered | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
Public method | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
Public method | LoadControl(Type, array<Object>[]()[][]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
Protected method | LoadPageStateFromPersistenceMedium | Loads any saved view-state information to the Page object. (Inherited from Page.)
Public method | LoadTemplate | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
Protected method | LoadViewState | Restores view-state information from a previous page request that was saved by the SaveViewState()()()() method. (Inherited from Control.)
Public method | MapPath | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAbortTransaction | Raises the AbortTransaction event. (Inherited from TemplateControl.)
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnCommitTransaction | Raises the CommitTransaction event. (Inherited from TemplateControl.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnError | Raises the Error event. (Inherited from TemplateControl.)
Protected method | OnInit | Raises the Init event to initialize the page. (Overrides Page..::..OnInit(EventArgs).)
Protected method | OnInitComplete | Raises the InitComplete event after page initialization. (Inherited from Page.)
Protected method | OnLoad | Raises the Load event. (Inherited from Control.)
Protected method | OnLoadComplete | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
Protected method | OnPreInit | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
Protected method | OnPreLoad | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
Protected method | OnPreRender | Raises the PreRender event. (Inherited from Control.)
Protected method | OnPreRenderComplete | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
Protected method | OnSaveStateComplete | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Protected method | Page_Load | Handles the Load event of the Page control.
Public method | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
Public method | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
Public method | ProcessRequest | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Protected method | RaisePostBackEvent | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
Public method | ReadStringResource | Reads a string resource. The ReadStringResource()()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | RegisterArrayDeclaration | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
Public method | RegisterAsyncTask | Registers a new asynchronous task with the page. (Inherited from Page.)
Public method | RegisterClientScriptBlock | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
Public method | RegisterHiddenField | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
Public method | RegisterOnSubmitStatement | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
Public method | RegisterRequiresControlState | Registers a control as one whose control state must be persisted. (Inherited from Page.)
Public method | RegisterRequiresPostBack | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
Public method | RegisterRequiresRaiseEvent | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
Public method | RegisterRequiresViewStateEncryption | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
Public method | RegisterStartupScript | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
Public method | RegisterViewStateHandler | Causes page view state to be persisted, if called. (Inherited from Page.)
Protected method | RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Protected method | Render | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Public method | RequiresControlState | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SavePageStateToPersistenceMedium | Saves any view-state and control-state information for the page. (Inherited from Page.)
Protected method | SaveViewState | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
Public method | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Protected method | SetStringResourcePointer | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | TestDeviceFilter | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TrackViewState | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
Public method | UnregisterRequiresControlState | Stops persistence of control state for the specified control. (Inherited from Page.)
Public method | Validate()()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
Public method | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
Public method | VerifyRenderingInServerForm | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
Protected method | WriteUTF8ResourceString | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
Protected method | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
Protected method | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
Protected method | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
Protected method | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
Protected method | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Protected method | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)

See Also

DefaultPage Class
Sitecore Namespace


AddOnPreRenderCompleteAsync Method

[image] [image]

Sitecore 6.4.1 API
DefaultPage..::..AddOnPreRenderCompleteAsync Method
DefaultPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
Public method | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)

See Also

DefaultPage Class
DefaultPage Members
Sitecore Namespace


DataBind Method

[image] [image]

Sitecore 6.4.1 API
DefaultPage..::..DataBind Method
DefaultPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)

See Also

DefaultPage Class
DefaultPage Members
Sitecore Namespace


Eval Method

[image] [image]

Sitecore 6.4.1 API
DefaultPage..::..Eval Method
DefaultPage Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
Protected method | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)

See Also

DefaultPage Class
DefaultPage Members
Sitecore Namespace


FindControl Method

[image] [image]

Sitecore 6.4.1 API
DefaultPage..::..FindControl Method
DefaultPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)

See Also

DefaultPage Class
DefaultPage Members
Sitecore Namespace


GetGlobalResourceObject Method

[image] [image]

Sitecore 6.4.1 API
DefaultPage..::..GetGlobalResourceObject Method
DefaultPage Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
Protected method | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)

See Also

DefaultPage Class
DefaultPage Members
Sitecore Namespace


GetLocalResourceObject Method

[image] [image]

Sitecore 6.4.1 API
DefaultPage..::..GetLocalResourceObject Method
DefaultPage Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
Protected method | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)

See Also

DefaultPage Class
DefaultPage Members
Sitecore Namespace


GetPostBackEventReference Method

[image] [image]

Sitecore 6.4.1 API
DefaultPage..::..GetPostBackEventReference Method
DefaultPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
Public method | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)

See Also

DefaultPage Class
DefaultPage Members
Sitecore Namespace


InitOutputCache Method

[image] [image]

Sitecore 6.4.1 API
DefaultPage..::..InitOutputCache Method
DefaultPage Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
Protected method | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
Protected method | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)

See Also

DefaultPage Class
DefaultPage Members
Sitecore Namespace


LoadControl Method

[image] [image]

Sitecore 6.4.1 API
DefaultPage..::..LoadControl Method
DefaultPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
Public method | LoadControl(Type, array<Object>[]()[][]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)

See Also

DefaultPage Class
DefaultPage Members
Sitecore Namespace


OnInit Method

[image]

Sitecore 6.4.1 API
DefaultPage..::..OnInit Method
DefaultPage Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void OnInit(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnInit ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnInit(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
An EventArgs that contains the event data.

See Also

DefaultPage Class
Sitecore Namespace


Page_Load Method

[image]

Sitecore 6.4.1 API
DefaultPage..::..Page_Load Method
DefaultPage Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void Page_Load(
    Object sender,
    EventArgs e
)
Visual Basic
Protected Sub Page_Load ( _
    sender As Object, _
    e As EventArgs _
)
Visual C++
protected:
void Page_Load(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: System..::..Object
The source of the event.
e
Type: System..::..EventArgs
The EventArgs instance containing the event data.

See Also

DefaultPage Class
Sitecore Namespace


RenderControl Method

[image] [image]

Sitecore 6.4.1 API
DefaultPage..::..RenderControl Method
DefaultPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)

See Also

DefaultPage Class
DefaultPage Members
Sitecore Namespace


SetFocus Method

[image] [image]

Sitecore 6.4.1 API
DefaultPage..::..SetFocus Method
DefaultPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
Public method | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)

See Also

DefaultPage Class
DefaultPage Members
Sitecore Namespace


XPath Method

[image] [image]

Sitecore 6.4.1 API
DefaultPage..::..XPath Method
DefaultPage Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
Protected method | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
Protected method | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
Protected method | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)

See Also

DefaultPage Class
DefaultPage Members
Sitecore Namespace


XPathSelect Method

[image] [image]

Sitecore 6.4.1 API
DefaultPage..::..XPathSelect Method
DefaultPage Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Protected method | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)

See Also

DefaultPage Class
DefaultPage Members
Sitecore Namespace


DefaultPage Properties

[image] [image]

Sitecore 6.4.1 API
DefaultPage Properties
DefaultPage Class See Also Send Feedback

The DefaultPage type exposes the following members.

Properties

 | Name | Description
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
Protected property | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
Protected property | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
Public property | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
Protected property | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
Public property | AutoPostBackControl | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
Public property | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Public property | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
Public property | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
Public property | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
Public property | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
Public property | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
Protected property | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
Public property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
Public property | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Public property | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
Public property | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
Public property | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
Public property | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
Public property | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Protected property | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
Public property | Form | Gets the HTML form for the page. (Inherited from Page.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Public property | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
Public property | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
Public property | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
Public property | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
Public property | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Public property | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
Public property | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
Public property | IsPostBackEventControlRegistered | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
Public property | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Public property | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Public property | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
Public property | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Public property | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
Public property | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
Public property | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
Public property | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
Protected property | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
Public property | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
Public property | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
Public property | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
Public property | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
Public property | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
Public property | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
Public property | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
Public property | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
Protected property | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
Public property | Title | Gets or sets the title for the page. (Inherited from Page.)
Public property | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
Public property | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
Public property | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
Protected property | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
Public property | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
Protected property | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
Public property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
Public property | User | Gets information about the user making the page request. (Inherited from Page.)
Public property | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Public property | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
Public property | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)

See Also

DefaultPage Class
Sitecore Namespace


DefaultPage Events

[image] [image]

Sitecore 6.4.1 API
DefaultPage Events
DefaultPage Class See Also Send Feedback

The DefaultPage type exposes the following members.

Events

 | Name | Description
Public event | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
Public event | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
Public event | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
Public event | PreLoad | Occurs before the page Load event. (Inherited from Page.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
Public event | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

See Also

DefaultPage Class
Sitecore Namespace


DeviceFieldIDs Class

[image]

Sitecore 6.4.1 API
DeviceFieldIDs Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class DeviceFieldIDs
Visual Basic
Public NotInheritable Class DeviceFieldIDs
Visual C++
public ref class DeviceFieldIDs abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore..::..DeviceFieldIDs

See Also

DeviceFieldIDs Members
Sitecore Namespace


DeviceFieldIDs Members

[image] [image]

Sitecore 6.4.1 API
DeviceFieldIDs Members
DeviceFieldIDs Class Fields See Also Send Feedback

The DeviceFieldIDs type exposes the following members.

Fields

Name | Description
Agent | The ID of the 'Agent' field.
Default | The ID of the 'Default' field.
FallbackDevice | The ID of the 'Fallback device' field.
QueryString | The ID of the 'Query string' field.

See Also

DeviceFieldIDs Class
Sitecore Namespace


Agent Field

[image]

Sitecore 6.4.1 API
DeviceFieldIDs..::..Agent Field
DeviceFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Agent
Visual Basic
Public Shared Agent As ID
Visual C++
public:
static ID^ Agent

See Also

DeviceFieldIDs Class
Sitecore Namespace


Default Field

[image]

Sitecore 6.4.1 API
DeviceFieldIDs..::..Default Field
DeviceFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Default
Visual Basic
Public Shared Default As ID
Visual C++
public:
static ID^ Default

See Also

DeviceFieldIDs Class
Sitecore Namespace


FallbackDevice Field

[image]

Sitecore 6.4.1 API
DeviceFieldIDs..::..FallbackDevice Field
DeviceFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID FallbackDevice
Visual Basic
Public Shared FallbackDevice As ID
Visual C++
public:
static ID^ FallbackDevice

See Also

DeviceFieldIDs Class
Sitecore Namespace


QueryString Field

[image]

Sitecore 6.4.1 API
DeviceFieldIDs..::..QueryString Field
DeviceFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID QueryString
Visual Basic
Public Shared QueryString As ID
Visual C++
public:
static ID^ QueryString

See Also

DeviceFieldIDs Class
Sitecore Namespace


Disposable Class

[image]

Sitecore 6.4.1 API
Disposable Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class Disposable : IDisposable
Visual Basic
Public MustInherit Class Disposable _
    Implements IDisposable
Visual C++
public ref class Disposable abstract : IDisposable

Inheritance Hierarchy

System..::..Object
Sitecore..::..Disposable

See Also

Disposable Members
Sitecore Namespace


Disposable Members

[image] [image]

Sitecore 6.4.1 API
Disposable Members
Disposable Class Constructors Methods See Also Send Feedback

The Disposable type exposes the following members.

Constructors

 | Name | Description
Protected method | Disposable | Initializes a new instance of the Disposable class

Methods

 | Name | Description
Protected method | Destroy | Destroys this instance.
Protected method | DestroyUnmanagedResources | Destroys the unmanaged resources.
Public method | Dispose | Disposes the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Disposable is reclaimed by garbage collection. (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Disposable Class
Sitecore Namespace


Disposable Methods

[image] [image]

Sitecore 6.4.1 API
Disposable Methods
Disposable Class See Also Send Feedback

The Disposable type exposes the following members.

Methods

 | Name | Description
Protected method | Destroy | Destroys this instance.
Protected method | DestroyUnmanagedResources | Destroys the unmanaged resources.
Public method | Dispose | Disposes the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Disposable is reclaimed by garbage collection. (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Disposable Class
Sitecore Namespace


Destroy Method

[image]

Sitecore 6.4.1 API
Disposable..::..Destroy Method
Disposable Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void Destroy()
Visual Basic
Protected Overridable Sub Destroy
Visual C++
protected:
virtual void Destroy()

See Also

Disposable Class
Sitecore Namespace


DestroyUnmanagedResources Method

[image]

Sitecore 6.4.1 API
Disposable..::..DestroyUnmanagedResources Method
Disposable Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void DestroyUnmanagedResources()
Visual Basic
Protected Overridable Sub DestroyUnmanagedResources
Visual C++
protected:
virtual void DestroyUnmanagedResources()

See Also

Disposable Class
Sitecore Namespace


Finalize Method

[image]

Sitecore 6.4.1 API
Disposable..::..Finalize Method
Disposable Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

Disposable Class
Sitecore Namespace


EventHandlerInfo Class

[image]

Sitecore 6.4.1 API
EventHandlerInfo Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class EventHandlerInfo
Visual Basic
Public Class EventHandlerInfo
Visual C++
public ref class EventHandlerInfo

Inheritance Hierarchy

System..::..Object
Sitecore..::..EventHandlerInfo

See Also

EventHandlerInfo Members
Sitecore Namespace


EventHandlerInfo Constructor

[image]

Sitecore 6.4.1 API
EventHandlerInfo Constructor
EventHandlerInfo Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public EventHandlerInfo(
    Object handler,
    NameValueCollection configSettings
)
Visual Basic
Public Sub New ( _
    handler As Object, _
    configSettings As NameValueCollection _
)
Visual C++
public:
EventHandlerInfo(
    Object^ handler,
    NameValueCollection^ configSettings
)

Parameters

handler
Type: System..::..Object
The handler.
configSettings
Type: System.Collections.Specialized..::..NameValueCollection
The config settings.

See Also

EventHandlerInfo Class
Sitecore Namespace


EventHandlerInfo Methods

[image] [image]

Sitecore 6.4.1 API
EventHandlerInfo Methods
EventHandlerInfo Class See Also Send Feedback

The EventHandlerInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EventHandlerInfo Class
Sitecore Namespace


EventHandlerInfo Properties

[image] [image]

Sitecore 6.4.1 API
EventHandlerInfo Properties
EventHandlerInfo Class See Also Send Feedback

The EventHandlerInfo type exposes the following members.

Properties

 | Name | Description
Public property | ConfigSettings | Gets the config settings for event handler.
Public property | Handler | Gets the handler object.

See Also

EventHandlerInfo Class
Sitecore Namespace


ConfigSettings Property

[image]

Sitecore 6.4.1 API
EventHandlerInfo..::..ConfigSettings Property
EventHandlerInfo Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public NameValueCollection ConfigSettings { get; }
Visual Basic
Public ReadOnly Property ConfigSettings As NameValueCollection
    Get
Visual C++
public:
property NameValueCollection^ ConfigSettings {
    NameValueCollection^ get ();
}

Field Value

The config settings.

See Also

EventHandlerInfo Class
Sitecore Namespace


Handler Property

[image]

Sitecore 6.4.1 API
EventHandlerInfo..::..Handler Property
EventHandlerInfo Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object Handler { get; }
Visual Basic
Public ReadOnly Property Handler As Object
    Get
Visual C++
public:
property Object^ Handler {
    Object^ get ();
}

Field Value

The handler.

See Also

EventHandlerInfo Class
Sitecore Namespace


FeatureState Enumeration

[image]

Sitecore 6.4.1 API
FeatureState Enumeration
See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum FeatureState
Visual Basic
Public Enumeration FeatureState
Visual C++
public enum class FeatureState

Members

Member name | Value | Description
Undefined | 0 | State of the Feature is undefined.
Enabled | 1 | Feature is enabled.
Disabled | 2 | Feature is disabled.

See Also

Sitecore Namespace


FieldIDs Class

[image]

Sitecore 6.4.1 API
FieldIDs Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class FieldIDs
Visual Basic
Public NotInheritable Class FieldIDs
Visual C++
public ref class FieldIDs abstract sealed

Remarks

The class does not contain any functionality, but serves only as a placeholder for a predefined GUIDs.

Inheritance Hierarchy

System..::..Object
Sitecore..::..FieldIDs

See Also

FieldIDs Members
Sitecore Namespace


FieldIDs Members

[image] [image]

Sitecore 6.4.1 API
FieldIDs Members
FieldIDs Class Fields See Also Send Feedback

The FieldIDs type exposes the following members.

Fields

Name | Description
ArchiveDate | The ID of the 'Archive date' field.
BaseTemplate | The ID of the 'Base template' field.
Branches | The ID of the 'Branches' field.
Command | The ID of the 'Command' field.
ContextMenu | The ID of the 'Context Menu' field.
Created | The ID of the 'Created' field.
CreatedBy | The ID of the 'Created by' field.
DefaultDomain | The ID of the 'Default domain' field of the 'Domain folder' template.
DefaultWorkflow | The ID of the 'Initial workflow' field.
DisplayName | The ID of the 'DisplayName' field.
DomainMembershipProvider | The ID of the 'MembershipProvider' field of the 'Domain' template.
DomainRoleNameTemplate | The ID of the 'RoleNameTemplate' field of the 'Domain' template.
DomainUniqueName | The ID of the 'UniqueName' field of the 'Domain' template.
DomainUserNameTemplate | The ID of the 'UserNameTemplate' field of the 'Domain' template.
EditorPath | The ID of the 'Editor path' field.
Hidden | The ID of the '__Hidden' field.
HideVersion | The ID of the 'Hide version' field.
Icon | The GUID of the 'Icon' field.
InheritSecurity | The ID of the 'Inherit security' field.
LanguageIso | The ID of the 'Iso' field of the 'Language' template.
Layout | Obsolete. The ID of the 'Layout' field.
LayoutField | The ID of the 'LayoutField' field.
Lock | The ID of the 'Lock' field.
Masters | Obsolete. The ID of the 'Masters' field.
NeverPublish | The ID of the 'Never publish' field.
Originator | The ID of the '__Originator' field.
Owner | The ID of the 'Owner' field
PageDefinition | The ID of the 'Page definition' field.
Presentation | The ID of the 'Presentation' field.
ProxyInsertionType | The ID of the 'Insertion Type' field of the 'Proxy' template.
ProxySourceDatabase | The ID of the 'Source database' field of the 'Proxy' template.
ProxySourceItem | The ID of the 'Target item' field of the 'Proxy' template.
ProxyTargetItem | The ID of the 'Parent item' field of the 'Proxy' template.
PublishDate | The ID of the 'Publish' field.
PublishingTargetDatabase | The ID of the 'Target database' field in a publishing target.
PublishingTargets | The ID of the 'Publishing targets' field.
ReadOnly | The ID of the 'Read Only' field.
Reference | The ID of the 'Reference' field.
ReminderDate | The ID of the 'Reminder date' field.
ReminderRecipients | The ID of the 'Reminder recipients' field.
ReminderText | The ID of the 'Reminder text' field.
Renderers | The ID of the 'Renderers' field.
Revision | The ID of the 'Revision' field.
Ribbon | The ID of the 'Ribbon' field.
Security | The ID of the 'Security' field.
Skin | The ID of the 'Skin' field.
Sortorder | The ID of the 'Sortorder' field.
Source | The ID of the 'Source' field.
StandardValueHolderId | The ID of the 'StandardValueHolderId' field.
StandardValues | The ID of the 'StandardValues' field.
State | The ID of the State field.
Style | The ID of the Style field.
SubitemsSorting | The ID of the 'Child Sorting' field.
Thumbnail | The ID of the 'Thumbnail' field.
UnpublishDate | The ID of the 'Unpublish' field.
Updated | The ID of the 'Updated' field.
UpdatedBy | The ID of the 'Updated by' field.
UserMembership | The ID of the 'Membership' field of the User template.
ValidFrom | The ID of the 'Valid from' field.
ValidTo | The ID of the 'Valid to' field.
Workflow | The ID of the 'Workflow' field.
WorkflowState | The ID of the 'Workflow state' field.

See Also

FieldIDs Class
Sitecore Namespace


FieldIDs Fields

[image] [image]

Sitecore 6.4.1 API
FieldIDs Fields
FieldIDs Class See Also Send Feedback

The FieldIDs type exposes the following members.

Fields

Name | Description
ArchiveDate | The ID of the 'Archive date' field.
BaseTemplate | The ID of the 'Base template' field.
Branches | The ID of the 'Branches' field.
Command | The ID of the 'Command' field.
ContextMenu | The ID of the 'Context Menu' field.
Created | The ID of the 'Created' field.
CreatedBy | The ID of the 'Created by' field.
DefaultDomain | The ID of the 'Default domain' field of the 'Domain folder' template.
DefaultWorkflow | The ID of the 'Initial workflow' field.
DisplayName | The ID of the 'DisplayName' field.
DomainMembershipProvider | The ID of the 'MembershipProvider' field of the 'Domain' template.
DomainRoleNameTemplate | The ID of the 'RoleNameTemplate' field of the 'Domain' template.
DomainUniqueName | The ID of the 'UniqueName' field of the 'Domain' template.
DomainUserNameTemplate | The ID of the 'UserNameTemplate' field of the 'Domain' template.
EditorPath | The ID of the 'Editor path' field.
Hidden | The ID of the '__Hidden' field.
HideVersion | The ID of the 'Hide version' field.
Icon | The GUID of the 'Icon' field.
InheritSecurity | The ID of the 'Inherit security' field.
LanguageIso | The ID of the 'Iso' field of the 'Language' template.
Layout | Obsolete. The ID of the 'Layout' field.
LayoutField | The ID of the 'LayoutField' field.
Lock | The ID of the 'Lock' field.
Masters | Obsolete. The ID of the 'Masters' field.
NeverPublish | The ID of the 'Never publish' field.
Originator | The ID of the '__Originator' field.
Owner | The ID of the 'Owner' field
PageDefinition | The ID of the 'Page definition' field.
Presentation | The ID of the 'Presentation' field.
ProxyInsertionType | The ID of the 'Insertion Type' field of the 'Proxy' template.
ProxySourceDatabase | The ID of the 'Source database' field of the 'Proxy' template.
ProxySourceItem | The ID of the 'Target item' field of the 'Proxy' template.
ProxyTargetItem | The ID of the 'Parent item' field of the 'Proxy' template.
PublishDate | The ID of the 'Publish' field.
PublishingTargetDatabase | The ID of the 'Target database' field in a publishing target.
PublishingTargets | The ID of the 'Publishing targets' field.
ReadOnly | The ID of the 'Read Only' field.
Reference | The ID of the 'Reference' field.
ReminderDate | The ID of the 'Reminder date' field.
ReminderRecipients | The ID of the 'Reminder recipients' field.
ReminderText | The ID of the 'Reminder text' field.
Renderers | The ID of the 'Renderers' field.
Revision | The ID of the 'Revision' field.
Ribbon | The ID of the 'Ribbon' field.
Security | The ID of the 'Security' field.
Skin | The ID of the 'Skin' field.
Sortorder | The ID of the 'Sortorder' field.
Source | The ID of the 'Source' field.
StandardValueHolderId | The ID of the 'StandardValueHolderId' field.
StandardValues | The ID of the 'StandardValues' field.
State | The ID of the State field.
Style | The ID of the Style field.
SubitemsSorting | The ID of the 'Child Sorting' field.
Thumbnail | The ID of the 'Thumbnail' field.
UnpublishDate | The ID of the 'Unpublish' field.
Updated | The ID of the 'Updated' field.
UpdatedBy | The ID of the 'Updated by' field.
UserMembership | The ID of the 'Membership' field of the User template.
ValidFrom | The ID of the 'Valid from' field.
ValidTo | The ID of the 'Valid to' field.
Workflow | The ID of the 'Workflow' field.
WorkflowState | The ID of the 'Workflow state' field.

See Also

FieldIDs Class
Sitecore Namespace


ArchiveDate Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..ArchiveDate Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID ArchiveDate
Visual Basic
Public Shared ArchiveDate As ID
Visual C++
public:
static ID^ ArchiveDate

See Also

FieldIDs Class
Sitecore Namespace


BaseTemplate Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..BaseTemplate Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID BaseTemplate
Visual Basic
Public Shared BaseTemplate As ID
Visual C++
public:
static ID^ BaseTemplate

See Also

FieldIDs Class
Sitecore Namespace


Branches Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..Branches Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Branches
Visual Basic
Public Shared Branches As ID
Visual C++
public:
static ID^ Branches

See Also

FieldIDs Class
Sitecore Namespace


Command Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..Command Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Command
Visual Basic
Public Shared Command As ID
Visual C++
public:
static ID^ Command

See Also

FieldIDs Class
Sitecore Namespace


ContextMenu Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..ContextMenu Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID ContextMenu
Visual Basic
Public Shared ContextMenu As ID
Visual C++
public:
static ID^ ContextMenu

See Also

FieldIDs Class
Sitecore Namespace


Created Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..Created Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Created
Visual Basic
Public Shared Created As ID
Visual C++
public:
static ID^ Created

See Also

FieldIDs Class
Sitecore Namespace


CreatedBy Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..CreatedBy Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID CreatedBy
Visual Basic
Public Shared CreatedBy As ID
Visual C++
public:
static ID^ CreatedBy

See Also

FieldIDs Class
Sitecore Namespace


DefaultDomain Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..DefaultDomain Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID DefaultDomain
Visual Basic
Public Shared DefaultDomain As ID
Visual C++
public:
static ID^ DefaultDomain

See Also

FieldIDs Class
Sitecore Namespace


DefaultWorkflow Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..DefaultWorkflow Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID DefaultWorkflow
Visual Basic
Public Shared DefaultWorkflow As ID
Visual C++
public:
static ID^ DefaultWorkflow

See Also

FieldIDs Class
Sitecore Namespace


DisplayName Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..DisplayName Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID DisplayName
Visual Basic
Public Shared DisplayName As ID
Visual C++
public:
static ID^ DisplayName

See Also

FieldIDs Class
Sitecore Namespace


DomainMembershipProvider Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..DomainMembershipProvider Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID DomainMembershipProvider
Visual Basic
Public Shared DomainMembershipProvider As ID
Visual C++
public:
static ID^ DomainMembershipProvider

See Also

FieldIDs Class
Sitecore Namespace


DomainRoleNameTemplate Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..DomainRoleNameTemplate Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID DomainRoleNameTemplate
Visual Basic
Public Shared DomainRoleNameTemplate As ID
Visual C++
public:
static ID^ DomainRoleNameTemplate

See Also

FieldIDs Class
Sitecore Namespace


DomainUniqueName Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..DomainUniqueName Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID DomainUniqueName
Visual Basic
Public Shared DomainUniqueName As ID
Visual C++
public:
static ID^ DomainUniqueName

See Also

FieldIDs Class
Sitecore Namespace


DomainUserNameTemplate Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..DomainUserNameTemplate Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID DomainUserNameTemplate
Visual Basic
Public Shared DomainUserNameTemplate As ID
Visual C++
public:
static ID^ DomainUserNameTemplate

See Also

FieldIDs Class
Sitecore Namespace


EditorPath Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..EditorPath Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID EditorPath
Visual Basic
Public Shared EditorPath As ID
Visual C++
public:
static ID^ EditorPath

See Also

FieldIDs Class
Sitecore Namespace


Hidden Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..Hidden Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Hidden
Visual Basic
Public Shared Hidden As ID
Visual C++
public:
static ID^ Hidden

See Also

FieldIDs Class
Sitecore Namespace


HideVersion Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..HideVersion Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID HideVersion
Visual Basic
Public Shared HideVersion As ID
Visual C++
public:
static ID^ HideVersion

See Also

FieldIDs Class
Sitecore Namespace


Icon Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..Icon Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Icon
Visual Basic
Public Shared Icon As ID
Visual C++
public:
static ID^ Icon

See Also

FieldIDs Class
Sitecore Namespace


InheritSecurity Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..InheritSecurity Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID InheritSecurity
Visual Basic
Public Shared InheritSecurity As ID
Visual C++
public:
static ID^ InheritSecurity

See Also

FieldIDs Class
Sitecore Namespace


LanguageIso Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..LanguageIso Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID LanguageIso
Visual Basic
Public Shared LanguageIso As ID
Visual C++
public:
static ID^ LanguageIso

See Also

FieldIDs Class
Sitecore Namespace


Layout Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..Layout Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("This field is no longer used - please use LayoutField instead.")]
public static ID Layout
Visual Basic
<ObsoleteAttribute("This field is no longer used - please use LayoutField instead.")> _
Public Shared Layout As ID
Visual C++
[ObsoleteAttribute(L"This field is no longer used - please use LayoutField instead.")]
public:
static ID^ Layout

See Also

FieldIDs Class
Sitecore Namespace


LayoutField Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..LayoutField Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID LayoutField
Visual Basic
Public Shared LayoutField As ID
Visual C++
public:
static ID^ LayoutField

See Also

FieldIDs Class
Sitecore Namespace


Lock Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..Lock Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Lock
Visual Basic
Public Shared Lock As ID
Visual C++
public:
static ID^ Lock

See Also

FieldIDs Class
Sitecore Namespace


Masters Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..Masters Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use Branches instead.")]
public static ID Masters
Visual Basic
<ObsoleteAttribute("Deprecated - Use Branches instead.")> _
Public Shared Masters As ID
Visual C++
[ObsoleteAttribute(L"Deprecated - Use Branches instead.")]
public:
static ID^ Masters

See Also

FieldIDs Class
Sitecore Namespace


NeverPublish Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..NeverPublish Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID NeverPublish
Visual Basic
Public Shared NeverPublish As ID
Visual C++
public:
static ID^ NeverPublish

See Also

FieldIDs Class
Sitecore Namespace


Originator Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..Originator Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Originator
Visual Basic
Public Shared Originator As ID
Visual C++
public:
static ID^ Originator

See Also

FieldIDs Class
Sitecore Namespace


Owner Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..Owner Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Owner
Visual Basic
Public Shared Owner As ID
Visual C++
public:
static ID^ Owner

See Also

FieldIDs Class
Sitecore Namespace


PageDefinition Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..PageDefinition Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID PageDefinition
Visual Basic
Public Shared PageDefinition As ID
Visual C++
public:
static ID^ PageDefinition

See Also

FieldIDs Class
Sitecore Namespace


Presentation Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..Presentation Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Presentation
Visual Basic
Public Shared Presentation As ID
Visual C++
public:
static ID^ Presentation

See Also

FieldIDs Class
Sitecore Namespace


ProxyInsertionType Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..ProxyInsertionType Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID ProxyInsertionType
Visual Basic
Public Shared ProxyInsertionType As ID
Visual C++
public:
static ID^ ProxyInsertionType

See Also

FieldIDs Class
Sitecore Namespace


ProxySourceItem Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..ProxySourceItem Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID ProxySourceItem
Visual Basic
Public Shared ProxySourceItem As ID
Visual C++
public:
static ID^ ProxySourceItem

See Also

FieldIDs Class
Sitecore Namespace


ProxyTargetItem Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..ProxyTargetItem Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID ProxyTargetItem
Visual Basic
Public Shared ProxyTargetItem As ID
Visual C++
public:
static ID^ ProxyTargetItem

See Also

FieldIDs Class
Sitecore Namespace


PublishDate Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..PublishDate Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID PublishDate
Visual Basic
Public Shared PublishDate As ID
Visual C++
public:
static ID^ PublishDate

See Also

FieldIDs Class
Sitecore Namespace


PublishingTargetDatabase Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..PublishingTargetDatabase Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID PublishingTargetDatabase
Visual Basic
Public Shared PublishingTargetDatabase As ID
Visual C++
public:
static ID^ PublishingTargetDatabase

See Also

FieldIDs Class
Sitecore Namespace


PublishingTargets Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..PublishingTargets Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID PublishingTargets
Visual Basic
Public Shared PublishingTargets As ID
Visual C++
public:
static ID^ PublishingTargets

See Also

FieldIDs Class
Sitecore Namespace


ReadOnly Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..ReadOnly Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID ReadOnly
Visual Basic
Public Shared ReadOnly As ID
Visual C++
public:
static ID^ ReadOnly

See Also

FieldIDs Class
Sitecore Namespace


Reference Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..Reference Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Reference
Visual Basic
Public Shared Reference As ID
Visual C++
public:
static ID^ Reference

See Also

FieldIDs Class
Sitecore Namespace


ReminderText Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..ReminderText Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID ReminderText
Visual Basic
Public Shared ReminderText As ID
Visual C++
public:
static ID^ ReminderText

See Also

FieldIDs Class
Sitecore Namespace


Renderers Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..Renderers Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Renderers
Visual Basic
Public Shared Renderers As ID
Visual C++
public:
static ID^ Renderers

See Also

FieldIDs Class
Sitecore Namespace


Revision Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..Revision Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Revision
Visual Basic
Public Shared Revision As ID
Visual C++
public:
static ID^ Revision

See Also

FieldIDs Class
Sitecore Namespace


Ribbon Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..Ribbon Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Ribbon
Visual Basic
Public Shared Ribbon As ID
Visual C++
public:
static ID^ Ribbon

See Also

FieldIDs Class
Sitecore Namespace


Security Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..Security Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Security
Visual Basic
Public Shared Security As ID
Visual C++
public:
static ID^ Security

See Also

FieldIDs Class
Sitecore Namespace


Skin Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..Skin Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Skin
Visual Basic
Public Shared Skin As ID
Visual C++
public:
static ID^ Skin

See Also

FieldIDs Class
Sitecore Namespace


Sortorder Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..Sortorder Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Sortorder
Visual Basic
Public Shared Sortorder As ID
Visual C++
public:
static ID^ Sortorder

See Also

FieldIDs Class
Sitecore Namespace


Source Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..Source Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Source
Visual Basic
Public Shared Source As ID
Visual C++
public:
static ID^ Source

See Also

FieldIDs Class
Sitecore Namespace


StandardValueHolderId Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..StandardValueHolderId Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID StandardValueHolderId
Visual Basic
Public Shared StandardValueHolderId As ID
Visual C++
public:
static ID^ StandardValueHolderId

See Also

FieldIDs Class
Sitecore Namespace


State Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..State Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID State
Visual Basic
Public Shared State As ID
Visual C++
public:
static ID^ State

See Also

FieldIDs Class
Sitecore Namespace


Style Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..Style Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Style
Visual Basic
Public Shared Style As ID
Visual C++
public:
static ID^ Style

See Also

FieldIDs Class
Sitecore Namespace


SubitemsSorting Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..SubitemsSorting Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID SubitemsSorting
Visual Basic
Public Shared SubitemsSorting As ID
Visual C++
public:
static ID^ SubitemsSorting

See Also

FieldIDs Class
Sitecore Namespace


Thumbnail Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..Thumbnail Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Thumbnail
Visual Basic
Public Shared Thumbnail As ID
Visual C++
public:
static ID^ Thumbnail

See Also

FieldIDs Class
Sitecore Namespace


UnpublishDate Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..UnpublishDate Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID UnpublishDate
Visual Basic
Public Shared UnpublishDate As ID
Visual C++
public:
static ID^ UnpublishDate

See Also

FieldIDs Class
Sitecore Namespace


Updated Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..Updated Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Updated
Visual Basic
Public Shared Updated As ID
Visual C++
public:
static ID^ Updated

See Also

FieldIDs Class
Sitecore Namespace


UpdatedBy Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..UpdatedBy Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID UpdatedBy
Visual Basic
Public Shared UpdatedBy As ID
Visual C++
public:
static ID^ UpdatedBy

See Also

FieldIDs Class
Sitecore Namespace


UserMembership Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..UserMembership Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID UserMembership
Visual Basic
Public Shared UserMembership As ID
Visual C++
public:
static ID^ UserMembership

See Also

FieldIDs Class
Sitecore Namespace


ValidFrom Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..ValidFrom Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID ValidFrom
Visual Basic
Public Shared ValidFrom As ID
Visual C++
public:
static ID^ ValidFrom

See Also

FieldIDs Class
Sitecore Namespace


ValidTo Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..ValidTo Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID ValidTo
Visual Basic
Public Shared ValidTo As ID
Visual C++
public:
static ID^ ValidTo

See Also

FieldIDs Class
Sitecore Namespace


Workflow Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..Workflow Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Workflow
Visual Basic
Public Shared Workflow As ID
Visual C++
public:
static ID^ Workflow

See Also

FieldIDs Class
Sitecore Namespace


WorkflowState Field

[image]

Sitecore 6.4.1 API
FieldIDs..::..WorkflowState Field
FieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID WorkflowState
Visual Basic
Public Shared WorkflowState As ID
Visual C++
public:
static ID^ WorkflowState

See Also

FieldIDs Class
Sitecore Namespace


Globals Class

[image]

Sitecore 6.4.1 API
Globals Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Globals
Visual Basic
Public NotInheritable Class Globals
Visual C++
public ref class Globals abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore..::..Globals

See Also

Globals Members
Sitecore Namespace


Globals Methods

[image] [image]

Sitecore 6.4.1 API
Globals Methods
Globals Class See Also Send Feedback

The Globals type exposes the following members.

Methods

Name | Description
Load | Loads this instance.

See Also

Globals Class
Sitecore Namespace


Load Method

[image]

Sitecore 6.4.1 API
Globals..::..Load Method
Globals Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Load()
Visual Basic
Public Shared Sub Load
Visual C++
public:
static void Load()

See Also

Globals Class
Sitecore Namespace


Globals Properties

[image] [image]

Sitecore 6.4.1 API
Globals Properties
Globals Class See Also Send Feedback

The Globals type exposes the following members.

Properties

Name | Description
DefaultCulture | Gets the default culture.
LinkDatabase | Gets the link database.
Server | Gets the server.
ServerUrl | Gets the server URL.
TaskDatabase | Gets the task database.

See Also

Globals Class
Sitecore Namespace


DefaultCulture Property

[image]

Sitecore 6.4.1 API
Globals..::..DefaultCulture Property
Globals Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static CultureInfo DefaultCulture { get; }
Visual Basic
Public Shared ReadOnly Property DefaultCulture As CultureInfo
    Get
Visual C++
public:
static property CultureInfo^ DefaultCulture {
    CultureInfo^ get ();
}

Field Value

The default culture.

See Also

Globals Class
Sitecore Namespace


LinkDatabase Property

[image]

Sitecore 6.4.1 API
Globals..::..LinkDatabase Property
Globals Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static LinkDatabase LinkDatabase { get; }
Visual Basic
Public Shared ReadOnly Property LinkDatabase As LinkDatabase
    Get
Visual C++
public:
static property LinkDatabase^ LinkDatabase {
    LinkDatabase^ get ();
}

Field Value

The link database.

See Also

Globals Class
Sitecore Namespace


Server Property

[image]

Sitecore 6.4.1 API
Globals..::..Server Property
Globals Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static HttpServerUtility Server { get; }
Visual Basic
Public Shared ReadOnly Property Server As HttpServerUtility
    Get
Visual C++
public:
static property HttpServerUtility^ Server {
    HttpServerUtility^ get ();
}

Field Value

The server.

See Also

Globals Class
Sitecore Namespace


ServerUrl Property

[image]

Sitecore 6.4.1 API
Globals..::..ServerUrl Property
Globals Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ServerUrl { get; }
Visual Basic
Public Shared ReadOnly Property ServerUrl As String
    Get
Visual C++
public:
static property String^ ServerUrl {
    String^ get ();
}

Field Value

The server URL.

See Also

Globals Class
Sitecore Namespace


TaskDatabase Property

[image]

Sitecore 6.4.1 API
Globals..::..TaskDatabase Property
Globals Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TaskDatabase TaskDatabase { get; }
Visual Basic
Public Shared ReadOnly Property TaskDatabase As TaskDatabase
    Get
Visual C++
public:
static property TaskDatabase^ TaskDatabase {
    TaskDatabase^ get ();
}

Field Value

The task database.

See Also

Globals Class
Sitecore Namespace


Handle Class

[image]

Sitecore 6.4.1 API
Handle Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class Handle
Visual Basic
<SerializableAttribute> _
Public Class Handle
Visual C++
[SerializableAttribute]
public ref class Handle

Inheritance Hierarchy

System..::..Object
Sitecore..::..Handle

See Also

Handle Members
Sitecore Namespace


Handle Members

[image] [image]

Sitecore 6.4.1 API
Handle Members
Handle Class Constructors Methods Fields See Also Send Feedback

The Handle type exposes the following members.

Constructors

 | Name | Description
Public method | Handle | Initializes a new instance of the Handle class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Parses the specified value.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Fields

Name | Description
Null | The Null handle.

See Also

Handle Class
Sitecore Namespace


Handle Constructor

[image]

Sitecore 6.4.1 API
Handle Constructor
Handle Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Handle()
Visual Basic
Public Sub New
Visual C++
public:
Handle()

See Also

Handle Class
Sitecore Namespace


Handle Fields

[image] [image]

Sitecore 6.4.1 API
Handle Fields
Handle Class See Also Send Feedback

The Handle type exposes the following members.

Fields

Name | Description
Null | The Null handle.

See Also

Handle Class
Sitecore Namespace


Null Field

[image]

Sitecore 6.4.1 API
Handle..::..Null Field
Handle Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly Handle Null
Visual Basic
Public Shared ReadOnly Null As Handle
Visual C++
public:
static initonly Handle^ Null

See Also

Handle Class
Sitecore Namespace


Handle Methods

[image] [image]

Sitecore 6.4.1 API
Handle Methods
Handle Class See Also Send Feedback

The Handle type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Parses the specified value.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

Handle Class
Sitecore Namespace


Equals Method

[image]

Sitecore 6.4.1 API
Handle..::..Equals Method
Handle Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

See Also

Handle Class
Sitecore Namespace


GetHashCode Method

[image]

Sitecore 6.4.1 API
Handle..::..GetHashCode Method
Handle Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A hash code for the current Object.

See Also

Handle Class
Sitecore Namespace


Parse Method

[image]

Sitecore 6.4.1 API
Handle..::..Parse Method
Handle Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Handle Parse(
    string value
)
Visual Basic
Public Shared Function Parse ( _
    value As String _
) As Handle
Visual C++
public:
static Handle^ Parse(
    String^ value
)

Parameters

value
Type: System..::..String
The value.

Return Value

The parse.

See Also

Handle Class
Sitecore Namespace


ToString Method

[image]

Sitecore 6.4.1 API
Handle..::..ToString Method
Handle Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

Handle Class
Sitecore Namespace


ImplicitUseFlags Enumeration

[image]

Sitecore 6.4.1 API
ImplicitUseFlags Enumeration
See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[FlagsAttribute]
public enum ImplicitUseFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration ImplicitUseFlags
Visual C++
[FlagsAttribute]
public enum class ImplicitUseFlags

Members

Member name | Value | Description
STANDARD | 0 |
ALL_MEMBERS_USED | 1 |

See Also

Sitecore Namespace


InvokerParameterNameAttribute Class

[image]

Sitecore 6.4.1 API
InvokerParameterNameAttribute Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class InvokerParameterNameAttribute : Attribute
Visual Basic
Public Class InvokerParameterNameAttribute _
    Inherits Attribute
Visual C++
public ref class InvokerParameterNameAttribute : public Attribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Sitecore..::..InvokerParameterNameAttribute

See Also

InvokerParameterNameAttribute Members
Sitecore Namespace


InvokerParameterNameAttribute Members

[image] [image]

Sitecore 6.4.1 API
InvokerParameterNameAttribute Members
InvokerParameterNameAttribute Class Constructors Methods Properties See Also Send Feedback

The InvokerParameterNameAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | InvokerParameterNameAttribute | Initializes a new instance of the InvokerParameterNameAttribute class

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

InvokerParameterNameAttribute Class
Sitecore Namespace


InvokerParameterNameAttribute Constructor

[image]

Sitecore 6.4.1 API
InvokerParameterNameAttribute Constructor
InvokerParameterNameAttribute Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public InvokerParameterNameAttribute()
Visual Basic
Public Sub New
Visual C++
public:
InvokerParameterNameAttribute()

See Also

InvokerParameterNameAttribute Class
Sitecore Namespace


InvokerParameterNameAttribute Methods

[image] [image]

Sitecore 6.4.1 API
InvokerParameterNameAttribute Methods
InvokerParameterNameAttribute Class See Also Send Feedback

The InvokerParameterNameAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InvokerParameterNameAttribute Class
Sitecore Namespace


InvokerParameterNameAttribute Properties

[image] [image]

Sitecore 6.4.1 API
InvokerParameterNameAttribute Properties
InvokerParameterNameAttribute Class See Also Send Feedback

The InvokerParameterNameAttribute type exposes the following members.

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

InvokerParameterNameAttribute Class
Sitecore Namespace


IPublishingRequest Interface

[image]

Sitecore 6.4.1 API
IPublishingRequest Interface
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IPublishingRequest
Visual Basic
Public Interface IPublishingRequest
Visual C++
public interface class IPublishingRequest

See Also

IPublishingRequest Members
Sitecore Namespace


IPublishingRequest Members

[image] [image]

Sitecore 6.4.1 API
IPublishingRequest Members
IPublishingRequest Interface Methods Properties See Also Send Feedback

The IPublishingRequest type exposes the following members.

Methods

 | Name | Description
Public method | MarkDone | Marks the request as being done (ie. processed).

Properties

 | Name | Description
Public property | Groups | Gets the groups to publish,
Public property | Handle | Gets the request handle (guid).
Public property | PublishAll | Gets a value indicating whether the IPublishingRequest publishes all.
Public property | PublishDate | Gets the publish date/time.
Public property | PublishIsoDate | Gets the publish date/time in iso format.
Public property | ServerUrl | Gets the Url of server that initiated the request.
Public property | Status | Gets the current status.
Public property | UserName | Gets the name of the user that initiated the publish operation.
Public property | WorkFile | Gets the path to the work file.

See Also

IPublishingRequest Interface
Sitecore Namespace


IPublishingRequest Methods

[image] [image]

Sitecore 6.4.1 API
IPublishingRequest Methods
IPublishingRequest Interface See Also Send Feedback

The IPublishingRequest type exposes the following members.

Methods

 | Name | Description
Public method | MarkDone | Marks the request as being done (ie. processed).

See Also

IPublishingRequest Interface
Sitecore Namespace


MarkDone Method

[image]

Sitecore 6.4.1 API
IPublishingRequest..::..MarkDone Method
IPublishingRequest Interface See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void MarkDone()
Visual Basic
Sub MarkDone
Visual C++
void MarkDone()

See Also

IPublishingRequest Interface
Sitecore Namespace


IPublishingRequest Properties

[image] [image]

Sitecore 6.4.1 API
IPublishingRequest Properties
IPublishingRequest Interface See Also Send Feedback

The IPublishingRequest type exposes the following members.

Properties

 | Name | Description
Public property | Groups | Gets the groups to publish,
Public property | Handle | Gets the request handle (guid).
Public property | PublishAll | Gets a value indicating whether the IPublishingRequest publishes all.
Public property | PublishDate | Gets the publish date/time.
Public property | PublishIsoDate | Gets the publish date/time in iso format.
Public property | ServerUrl | Gets the Url of server that initiated the request.
Public property | Status | Gets the current status.
Public property | UserName | Gets the name of the user that initiated the publish operation.
Public property | WorkFile | Gets the path to the work file.

See Also

IPublishingRequest Interface
Sitecore Namespace


Groups Property

[image]

Sitecore 6.4.1 API
IPublishingRequest..::..Groups Property
IPublishingRequest Interface See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
ArrayList Groups { get; }
Visual Basic
ReadOnly Property Groups As ArrayList
    Get
Visual C++
property ArrayList^ Groups {
    ArrayList^ get ();
}

Field Value

The groups.

See Also

IPublishingRequest Interface
Sitecore Namespace


Handle Property

[image]

Sitecore 6.4.1 API
IPublishingRequest..::..Handle Property
IPublishingRequest Interface See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
string Handle { get; }
Visual Basic
ReadOnly Property Handle As String
    Get
Visual C++
property String^ Handle {
    String^ get ();
}

Field Value

The handle.

See Also

IPublishingRequest Interface
Sitecore Namespace


PublishAll Property

[image]

Sitecore 6.4.1 API
IPublishingRequest..::..PublishAll Property
IPublishingRequest Interface See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
bool PublishAll { get; }
Visual Basic
ReadOnly Property PublishAll As Boolean
    Get
Visual C++
property bool PublishAll {
    bool get ();
}

Field Value

true if the IPublishingRequest publishes all; otherwise, false.

Remarks

If false, only changed items will be published

See Also

IPublishingRequest Interface
Sitecore Namespace


PublishDate Property

[image]

Sitecore 6.4.1 API
IPublishingRequest..::..PublishDate Property
IPublishingRequest Interface See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
DateTime PublishDate { get; }
Visual Basic
ReadOnly Property PublishDate As DateTime
    Get
Visual C++
property DateTime PublishDate {
    DateTime get ();
}

Field Value

The publish date.

See Also

IPublishingRequest Interface
Sitecore Namespace


PublishIsoDate Property

[image]

Sitecore 6.4.1 API
IPublishingRequest..::..PublishIsoDate Property
IPublishingRequest Interface See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
string PublishIsoDate { get; }
Visual Basic
ReadOnly Property PublishIsoDate As String
    Get
Visual C++
property String^ PublishIsoDate {
    String^ get ();
}

Field Value

The publish iso date.

See Also

IPublishingRequest Interface
Sitecore Namespace


ServerUrl Property

[image]

Sitecore 6.4.1 API
IPublishingRequest..::..ServerUrl Property
IPublishingRequest Interface See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
string ServerUrl { get; }
Visual Basic
ReadOnly Property ServerUrl As String
    Get
Visual C++
property String^ ServerUrl {
    String^ get ();
}

Field Value

The server URL.

See Also

IPublishingRequest Interface
Sitecore Namespace


Status Property

[image]

Sitecore 6.4.1 API
IPublishingRequest..::..Status Property
IPublishingRequest Interface See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
IPublishingStatus Status { get; }
Visual Basic
ReadOnly Property Status As IPublishingStatus
    Get
Visual C++
property IPublishingStatus^ Status {
    IPublishingStatus^ get ();
}

Field Value

The status.

See Also

IPublishingRequest Interface
Sitecore Namespace


UserName Property

[image]

Sitecore 6.4.1 API
IPublishingRequest..::..UserName Property
IPublishingRequest Interface See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
string UserName { get; }
Visual Basic
ReadOnly Property UserName As String
    Get
Visual C++
property String^ UserName {
    String^ get ();
}

Field Value

The name of the user.

See Also

IPublishingRequest Interface
Sitecore Namespace


WorkFile Property

[image]

Sitecore 6.4.1 API
IPublishingRequest..::..WorkFile Property
IPublishingRequest Interface See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
string WorkFile { get; }
Visual Basic
ReadOnly Property WorkFile As String
    Get
Visual C++
property String^ WorkFile {
    String^ get ();
}

Field Value

The work file.

See Also

IPublishingRequest Interface
Sitecore Namespace


IPublishingStatus Interface

[image]

Sitecore 6.4.1 API
IPublishingStatus Interface
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IPublishingStatus
Visual Basic
Public Interface IPublishingStatus
Visual C++
public interface class IPublishingStatus

See Also

IPublishingStatus Members
Sitecore Namespace


IPublishingStatus Members

[image] [image]

Sitecore 6.4.1 API
IPublishingStatus Members
IPublishingStatus Interface Properties See Also Send Feedback

The IPublishingStatus type exposes the following members.

Properties

 | Name | Description
Public property | Error | Gets the error.
Public property | EstimatedTimeLeft | Gets the estimated time left (ms).
Public property | ProcessedItems | Gets the number of items processed up until now.
Public property | ProcessingTime | Gets the time spent processing up until now (ms).
Public property | QueueIndex | Gets the index in queue.
Public property | QueueTime | Gets the time spent waiting in queue (ms).
Public property | RemainingItems | Gets the number of items still to be processed.
Public property | Status | Gets the current status description.
Public property | TotalItems | Gets the total number of items to be processed.

See Also

IPublishingStatus Interface
Sitecore Namespace


IPublishingStatus Properties

[image] [image]

Sitecore 6.4.1 API
IPublishingStatus Properties
IPublishingStatus Interface See Also Send Feedback

The IPublishingStatus type exposes the following members.

Properties

 | Name | Description
Public property | Error | Gets the error.
Public property | EstimatedTimeLeft | Gets the estimated time left (ms).
Public property | ProcessedItems | Gets the number of items processed up until now.
Public property | ProcessingTime | Gets the time spent processing up until now (ms).
Public property | QueueIndex | Gets the index in queue.
Public property | QueueTime | Gets the time spent waiting in queue (ms).
Public property | RemainingItems | Gets the number of items still to be processed.
Public property | Status | Gets the current status description.
Public property | TotalItems | Gets the total number of items to be processed.

See Also

IPublishingStatus Interface
Sitecore Namespace


Error Property

[image]

Sitecore 6.4.1 API
IPublishingStatus..::..Error Property
IPublishingStatus Interface See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
string Error { get; }
Visual Basic
ReadOnly Property Error As String
    Get
Visual C++
property String^ Error {
    String^ get ();
}

Field Value

The error.

See Also

IPublishingStatus Interface
Sitecore Namespace


EstimatedTimeLeft Property

[image]

Sitecore 6.4.1 API
IPublishingStatus..::..EstimatedTimeLeft Property
IPublishingStatus Interface See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
double EstimatedTimeLeft { get; }
Visual Basic
ReadOnly Property EstimatedTimeLeft As Double
    Get
Visual C++
property double EstimatedTimeLeft {
    double get ();
}

Field Value

The estimated time left.

See Also

IPublishingStatus Interface
Sitecore Namespace


ProcessedItems Property

[image]

Sitecore 6.4.1 API
IPublishingStatus..::..ProcessedItems Property
IPublishingStatus Interface See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
uint ProcessedItems { get; }
Visual Basic
ReadOnly Property ProcessedItems As UInteger
    Get
Visual C++
property unsigned int ProcessedItems {
    unsigned int get ();
}

Field Value

The processed items.

See Also

IPublishingStatus Interface
Sitecore Namespace


ProcessingTime Property

[image]

Sitecore 6.4.1 API
IPublishingStatus..::..ProcessingTime Property
IPublishingStatus Interface See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
double ProcessingTime { get; }
Visual Basic
ReadOnly Property ProcessingTime As Double
    Get
Visual C++
property double ProcessingTime {
    double get ();
}

Field Value

The processing time.

See Also

IPublishingStatus Interface
Sitecore Namespace


QueueIndex Property

[image]

Sitecore 6.4.1 API
IPublishingStatus..::..QueueIndex Property
IPublishingStatus Interface See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
int QueueIndex { get; }
Visual Basic
ReadOnly Property QueueIndex As Integer
    Get
Visual C++
property int QueueIndex {
    int get ();
}

Field Value

The index of the queue.

Remarks

Returns -1 if not in queue.

See Also

IPublishingStatus Interface
Sitecore Namespace


QueueTime Property

[image]

Sitecore 6.4.1 API
IPublishingStatus..::..QueueTime Property
IPublishingStatus Interface See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
double QueueTime { get; }
Visual Basic
ReadOnly Property QueueTime As Double
    Get
Visual C++
property double QueueTime {
    double get ();
}

Field Value

The queue time.

See Also

IPublishingStatus Interface
Sitecore Namespace


RemainingItems Property

[image]

Sitecore 6.4.1 API
IPublishingStatus..::..RemainingItems Property
IPublishingStatus Interface See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
uint RemainingItems { get; }
Visual Basic
ReadOnly Property RemainingItems As UInteger
    Get
Visual C++
property unsigned int RemainingItems {
    unsigned int get ();
}

Field Value

The remaining items.

See Also

IPublishingStatus Interface
Sitecore Namespace


Status Property

[image]

Sitecore 6.4.1 API
IPublishingStatus..::..Status Property
IPublishingStatus Interface See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
string Status { get; }
Visual Basic
ReadOnly Property Status As String
    Get
Visual C++
property String^ Status {
    String^ get ();
}

Field Value

The status.

See Also

IPublishingStatus Interface
Sitecore Namespace


TotalItems Property

[image]

Sitecore 6.4.1 API
IPublishingStatus..::..TotalItems Property
IPublishingStatus Interface See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
uint TotalItems { get; }
Visual Basic
ReadOnly Property TotalItems As UInteger
    Get
Visual C++
property unsigned int TotalItems {
    unsigned int get ();
}

Field Value

The total items.

See Also

IPublishingStatus Interface
Sitecore Namespace


ItemIDs Class

[image]

Sitecore 6.4.1 API
ItemIDs Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class ItemIDs
Visual Basic
Public NotInheritable Class ItemIDs
Visual C++
public ref class ItemIDs abstract sealed

Remarks

The class does not contain any functionality, but serves as a placeholder for a predefined GUIDs.

Inheritance Hierarchy

System..::..Object
Sitecore..::..ItemIDs

See Also

ItemIDs Members
Sitecore Namespace


ItemIDs Members

[image] [image]

Sitecore 6.4.1 API
ItemIDs Members
ItemIDs Class Fields See Also Send Feedback

The ItemIDs type exposes the following members.

Fields

Name | Description
AnonymousUser | The Anonymous user ID.
BranchesRoot | The ID of "/sitecore/templates/branches"
ConditionalRenderingsGlobalRules | The ID of the /sitecore/system/Settings/Rules/Conditional Renderings/Global Rules.
ContentRoot | The ID of "/sitecore/content"
DefaultRibbon | The ID of "/sitecore/content/Applications/Content Editor/Ribbons/Ribbons/Default"
DevicesRoot | The ID of "/sitecore/layout/Devices"
EveryoneRoleID | The ID of the 'Everyone' role.
LanguageRoot | The ID of the '/sitecore/system/language' item.
LayoutRoot | The ID of "/sitecore/layout"
Layouts | The ID of "/sitecore/layout/layouts"
MastersRoot | Obsolete. The ID of "/sitecore/templates/branches"
MediaLibraryRoot | The ID of "/sitecore/media library"
Null | The Null ID.
PlaceholderSettingsRoot | The ID of "/sitecore/layout/Placeholders"
Policies | The ID of the root item of the system/policies section
RootID | The ID of the Sitecore root item.
Shell | The ID of the /sitecore/content/System/Shell item in the core database
ShellAll | The ID of the /sitecore/content/System/Shell/__All in the core database
ShellDefault | The ID of the /sitecore/content/System/Shell/__Default in the core database
SystemRoot | The ID of "/sitecore/system"
TemplateRoot | The ID of the root item of the templates section
Undefined | ID indicating 'undefined' value.
VirtualStructures | Obsolete. The ID of the "/sitecore/system/Virtual Structures" item
WorkflowRoot | The ID of the root item of the system/workflows section

See Also

ItemIDs Class
Sitecore Namespace


ItemIDs Fields

[image] [image]

Sitecore 6.4.1 API
ItemIDs Fields
ItemIDs Class See Also Send Feedback

The ItemIDs type exposes the following members.

Fields

Name | Description
AnonymousUser | The Anonymous user ID.
BranchesRoot | The ID of "/sitecore/templates/branches"
ConditionalRenderingsGlobalRules | The ID of the /sitecore/system/Settings/Rules/Conditional Renderings/Global Rules.
ContentRoot | The ID of "/sitecore/content"
DefaultRibbon | The ID of "/sitecore/content/Applications/Content Editor/Ribbons/Ribbons/Default"
DevicesRoot | The ID of "/sitecore/layout/Devices"
EveryoneRoleID | The ID of the 'Everyone' role.
LanguageRoot | The ID of the '/sitecore/system/language' item.
LayoutRoot | The ID of "/sitecore/layout"
Layouts | The ID of "/sitecore/layout/layouts"
MastersRoot | Obsolete. The ID of "/sitecore/templates/branches"
MediaLibraryRoot | The ID of "/sitecore/media library"
Null | The Null ID.
PlaceholderSettingsRoot | The ID of "/sitecore/layout/Placeholders"
Policies | The ID of the root item of the system/policies section
RootID | The ID of the Sitecore root item.
Shell | The ID of the /sitecore/content/System/Shell item in the core database
ShellAll | The ID of the /sitecore/content/System/Shell/__All in the core database
ShellDefault | The ID of the /sitecore/content/System/Shell/__Default in the core database
SystemRoot | The ID of "/sitecore/system"
TemplateRoot | The ID of the root item of the templates section
Undefined | ID indicating 'undefined' value.
VirtualStructures | Obsolete. The ID of the "/sitecore/system/Virtual Structures" item
WorkflowRoot | The ID of the root item of the system/workflows section

See Also

ItemIDs Class
Sitecore Namespace


AnonymousUser Field

[image]

Sitecore 6.4.1 API
ItemIDs..::..AnonymousUser Field
ItemIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID AnonymousUser
Visual Basic
Public Shared AnonymousUser As ID
Visual C++
public:
static ID^ AnonymousUser

See Also

ItemIDs Class
Sitecore Namespace


BranchesRoot Field

[image]

Sitecore 6.4.1 API
ItemIDs..::..BranchesRoot Field
ItemIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID BranchesRoot
Visual Basic
Public Shared BranchesRoot As ID
Visual C++
public:
static ID^ BranchesRoot

See Also

ItemIDs Class
Sitecore Namespace


ConditionalRenderingsGlobalRules Field

[image]

Sitecore 6.4.1 API
ItemIDs..::..ConditionalRenderingsGlobalRules Field
ItemIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID ConditionalRenderingsGlobalRules
Visual Basic
Public Shared ConditionalRenderingsGlobalRules As ID
Visual C++
public:
static ID^ ConditionalRenderingsGlobalRules

See Also

ItemIDs Class
Sitecore Namespace


ContentRoot Field

[image]

Sitecore 6.4.1 API
ItemIDs..::..ContentRoot Field
ItemIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID ContentRoot
Visual Basic
Public Shared ContentRoot As ID
Visual C++
public:
static ID^ ContentRoot

See Also

ItemIDs Class
Sitecore Namespace


DefaultRibbon Field

[image]

Sitecore 6.4.1 API
ItemIDs..::..DefaultRibbon Field
ItemIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID DefaultRibbon
Visual Basic
Public Shared DefaultRibbon As ID
Visual C++
public:
static ID^ DefaultRibbon

See Also

ItemIDs Class
Sitecore Namespace


DevicesRoot Field

[image]

Sitecore 6.4.1 API
ItemIDs..::..DevicesRoot Field
ItemIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID DevicesRoot
Visual Basic
Public Shared DevicesRoot As ID
Visual C++
public:
static ID^ DevicesRoot

See Also

ItemIDs Class
Sitecore Namespace


EveryoneRoleID Field

[image]

Sitecore 6.4.1 API
ItemIDs..::..EveryoneRoleID Field
ItemIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID EveryoneRoleID
Visual Basic
Public Shared EveryoneRoleID As ID
Visual C++
public:
static ID^ EveryoneRoleID

See Also

ItemIDs Class
Sitecore Namespace


LanguageRoot Field

[image]

Sitecore 6.4.1 API
ItemIDs..::..LanguageRoot Field
ItemIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID LanguageRoot
Visual Basic
Public Shared LanguageRoot As ID
Visual C++
public:
static ID^ LanguageRoot

See Also

ItemIDs Class
Sitecore Namespace


LayoutRoot Field

[image]

Sitecore 6.4.1 API
ItemIDs..::..LayoutRoot Field
ItemIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID LayoutRoot
Visual Basic
Public Shared LayoutRoot As ID
Visual C++
public:
static ID^ LayoutRoot

See Also

ItemIDs Class
Sitecore Namespace


Layouts Field

[image]

Sitecore 6.4.1 API
ItemIDs..::..Layouts Field
ItemIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Layouts
Visual Basic
Public Shared Layouts As ID
Visual C++
public:
static ID^ Layouts

See Also

ItemIDs Class
Sitecore Namespace


MastersRoot Field

[image]

Sitecore 6.4.1 API
ItemIDs..::..MastersRoot Field
ItemIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use BranchesRoot instead.")]
public static ID MastersRoot
Visual Basic
<ObsoleteAttribute("Deprecated - Use BranchesRoot instead.")> _
Public Shared MastersRoot As ID
Visual C++
[ObsoleteAttribute(L"Deprecated - Use BranchesRoot instead.")]
public:
static ID^ MastersRoot

See Also

ItemIDs Class
Sitecore Namespace


MediaLibraryRoot Field

[image]

Sitecore 6.4.1 API
ItemIDs..::..MediaLibraryRoot Field
ItemIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID MediaLibraryRoot
Visual Basic
Public Shared MediaLibraryRoot As ID
Visual C++
public:
static ID^ MediaLibraryRoot

See Also

ItemIDs Class
Sitecore Namespace


Null Field

[image]

Sitecore 6.4.1 API
ItemIDs..::..Null Field
ItemIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Null
Visual Basic
Public Shared Null As ID
Visual C++
public:
static ID^ Null

See Also

ItemIDs Class
Sitecore Namespace


PlaceholderSettingsRoot Field

[image]

Sitecore 6.4.1 API
ItemIDs..::..PlaceholderSettingsRoot Field
ItemIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID PlaceholderSettingsRoot
Visual Basic
Public Shared PlaceholderSettingsRoot As ID
Visual C++
public:
static ID^ PlaceholderSettingsRoot

See Also

ItemIDs Class
Sitecore Namespace


Policies Field

[image]

Sitecore 6.4.1 API
ItemIDs..::..Policies Field
ItemIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Policies
Visual Basic
Public Shared Policies As ID
Visual C++
public:
static ID^ Policies

See Also

ItemIDs Class
Sitecore Namespace


Shell Field

[image]

Sitecore 6.4.1 API
ItemIDs..::..Shell Field
ItemIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Shell
Visual Basic
Public Shared Shell As ID
Visual C++
public:
static ID^ Shell

See Also

ItemIDs Class
Sitecore Namespace


ShellAll Field

[image]

Sitecore 6.4.1 API
ItemIDs..::..ShellAll Field
ItemIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID ShellAll
Visual Basic
Public Shared ShellAll As ID
Visual C++
public:
static ID^ ShellAll

See Also

ItemIDs Class
Sitecore Namespace


ShellDefault Field

[image]

Sitecore 6.4.1 API
ItemIDs..::..ShellDefault Field
ItemIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID ShellDefault
Visual Basic
Public Shared ShellDefault As ID
Visual C++
public:
static ID^ ShellDefault

See Also

ItemIDs Class
Sitecore Namespace


SystemRoot Field

[image]

Sitecore 6.4.1 API
ItemIDs..::..SystemRoot Field
ItemIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID SystemRoot
Visual Basic
Public Shared SystemRoot As ID
Visual C++
public:
static ID^ SystemRoot

See Also

ItemIDs Class
Sitecore Namespace


TemplateRoot Field

[image]

Sitecore 6.4.1 API
ItemIDs..::..TemplateRoot Field
ItemIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID TemplateRoot
Visual Basic
Public Shared TemplateRoot As ID
Visual C++
public:
static ID^ TemplateRoot

See Also

ItemIDs Class
Sitecore Namespace


Undefined Field

[image]

Sitecore 6.4.1 API
ItemIDs..::..Undefined Field
ItemIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Undefined
Visual Basic
Public Shared Undefined As ID
Visual C++
public:
static ID^ Undefined

See Also

ItemIDs Class
Sitecore Namespace


VirtualStructures Field

[image]

Sitecore 6.4.1 API
ItemIDs..::..VirtualStructures Field
ItemIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("This ID has been deprecated.")]
public static ID VirtualStructures
Visual Basic
<ObsoleteAttribute("This ID has been deprecated.")> _
Public Shared VirtualStructures As ID
Visual C++
[ObsoleteAttribute(L"This ID has been deprecated.")]
public:
static ID^ VirtualStructures

See Also

ItemIDs Class
Sitecore Namespace


WorkflowRoot Field

[image]

Sitecore 6.4.1 API
ItemIDs..::..WorkflowRoot Field
ItemIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID WorkflowRoot
Visual Basic
Public Shared WorkflowRoot As ID
Visual C++
public:
static ID^ WorkflowRoot

See Also

ItemIDs Class
Sitecore Namespace


ItemIDs.Analytics Class

[image]

Sitecore 6.4.1 API
ItemIDs..::..Analytics Class
ItemIDs Class Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Analytics
Visual Basic
Public NotInheritable Class Analytics
Visual C++
public ref class Analytics abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore..::..ItemIDs..::..Analytics

See Also

ItemIDs..::..Analytics Members
Sitecore Namespace


ItemIDs.Analytics Members

[image] [image]

Sitecore 6.4.1 API
ItemIDs..::..Analytics Members
ItemIDs..::..Analytics Class Fields See Also Send Feedback

Implements a static class for holding assorted well-known GUID values.

The ItemIDs..::..Analytics type exposes the following members.

Fields

Name | Description
Criteria | ID indicating '/sitecore/system/Settings/Analytics/Filters/Criteria' value.
GlobalReports | ID indicating '/sitecore/system/Settings/Analytics/Reports/Reports' value.
Macros | ID indicating '/sitecore/system/settings/Analytics/Filters/Macros' value.
MarketingCenterItem | ID indicating '/sitecore/system/Marketing Center' value.
PageEvents | ID indicating '/sitecore/system/settings/Analytics/Page Events' value.
Profiles | ID indicating '/sitecore/system/settings/Analytics/Profiles' value.
VisitorIdentifications | ID indicating '/sitecore/system/settings/Analytics/Visitor Identifications' value.
VisitorIdentificationTypes | ID indicating '/sitecore/system/settings/Analytics/Visitor Identification Types' value.

See Also

ItemIDs..::..Analytics Class
Sitecore Namespace


ItemIDs.Analytics Fields

[image] [image]

Sitecore 6.4.1 API
ItemIDs..::..Analytics Fields
ItemIDs..::..Analytics Class See Also Send Feedback

The ItemIDs..::..Analytics type exposes the following members.

Fields

Name | Description
Criteria | ID indicating '/sitecore/system/Settings/Analytics/Filters/Criteria' value.
GlobalReports | ID indicating '/sitecore/system/Settings/Analytics/Reports/Reports' value.
Macros | ID indicating '/sitecore/system/settings/Analytics/Filters/Macros' value.
MarketingCenterItem | ID indicating '/sitecore/system/Marketing Center' value.
PageEvents | ID indicating '/sitecore/system/settings/Analytics/Page Events' value.
Profiles | ID indicating '/sitecore/system/settings/Analytics/Profiles' value.
VisitorIdentifications | ID indicating '/sitecore/system/settings/Analytics/Visitor Identifications' value.
VisitorIdentificationTypes | ID indicating '/sitecore/system/settings/Analytics/Visitor Identification Types' value.

See Also

ItemIDs..::..Analytics Class
Sitecore Namespace


Criteria Field

[image]

Sitecore 6.4.1 API
ItemIDs..::..Analytics..::..Criteria Field
ItemIDs..::..Analytics Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Criteria
Visual Basic
Public Shared Criteria As ID
Visual C++
public:
static ID^ Criteria

See Also

ItemIDs..::..Analytics Class
Sitecore Namespace


GlobalReports Field

[image]

Sitecore 6.4.1 API
ItemIDs..::..Analytics..::..GlobalReports Field
ItemIDs..::..Analytics Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID GlobalReports
Visual Basic
Public Shared GlobalReports As ID
Visual C++
public:
static ID^ GlobalReports

See Also

ItemIDs..::..Analytics Class
Sitecore Namespace


Macros Field

[image]

Sitecore 6.4.1 API
ItemIDs..::..Analytics..::..Macros Field
ItemIDs..::..Analytics Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Macros
Visual Basic
Public Shared Macros As ID
Visual C++
public:
static ID^ Macros

See Also

ItemIDs..::..Analytics Class
Sitecore Namespace


MarketingCenterItem Field

[image]

Sitecore 6.4.1 API
ItemIDs..::..Analytics..::..MarketingCenterItem Field
ItemIDs..::..Analytics Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID MarketingCenterItem
Visual Basic
Public Shared MarketingCenterItem As ID
Visual C++
public:
static ID^ MarketingCenterItem

See Also

ItemIDs..::..Analytics Class
Sitecore Namespace


PageEvents Field

[image]

Sitecore 6.4.1 API
ItemIDs..::..Analytics..::..PageEvents Field
ItemIDs..::..Analytics Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID PageEvents
Visual Basic
Public Shared PageEvents As ID
Visual C++
public:
static ID^ PageEvents

See Also

ItemIDs..::..Analytics Class
Sitecore Namespace


Profiles Field

[image]

Sitecore 6.4.1 API
ItemIDs..::..Analytics..::..Profiles Field
ItemIDs..::..Analytics Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Profiles
Visual Basic
Public Shared Profiles As ID
Visual C++
public:
static ID^ Profiles

See Also

ItemIDs..::..Analytics Class
Sitecore Namespace


VisitorIdentifications Field

[image]

Sitecore 6.4.1 API
ItemIDs..::..Analytics..::..VisitorIdentifications Field
ItemIDs..::..Analytics Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID VisitorIdentifications
Visual Basic
Public Shared VisitorIdentifications As ID
Visual C++
public:
static ID^ VisitorIdentifications

See Also

ItemIDs..::..Analytics Class
Sitecore Namespace


VisitorIdentificationTypes Field

[image]

Sitecore 6.4.1 API
ItemIDs..::..Analytics..::..VisitorIdentificationTypes Field
ItemIDs..::..Analytics Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID VisitorIdentificationTypes
Visual Basic
Public Shared VisitorIdentificationTypes As ID
Visual C++
public:
static ID^ VisitorIdentificationTypes

See Also

ItemIDs..::..Analytics Class
Sitecore Namespace


ItemIDs.Analytics.MarketingCenter Class

[image]

Sitecore 6.4.1 API
ItemIDs..::..Analytics..::..MarketingCenter Class
ItemIDs..::..Analytics Class Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class MarketingCenter
Visual Basic
Public NotInheritable Class MarketingCenter
Visual C++
public ref class MarketingCenter abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore..::..ItemIDs..::..Analytics..::..MarketingCenter

See Also

ItemIDs..::..Analytics..::..MarketingCenter Members
Sitecore Namespace


ItemIDs.Analytics.MarketingCenter Members

[image] [image]

Sitecore 6.4.1 API
ItemIDs..::..Analytics..::..MarketingCenter Members
ItemIDs..::..Analytics..::..MarketingCenter Class Fields See Also Send Feedback

Defines the analytics class.

The ItemIDs..::..Analytics..::..MarketingCenter type exposes the following members.

Fields

Name | Description
Campaigns | ID indicating '/sitecore/system/Marketing Center/Campaigns' value.
Goals | ID indicating '/sitecore/system/Marketing Center/Goals' value.
Policies | ID indicating '/sitecore/system/Marketing Center/Presentation/Policies' value.
ReportFilters | ID indicating "/sitecore/system/Marketing Center/Reports/Report Filters" value.
TestLaboratory | ID indicating '/sitecore/system/Marketing Center/Test Laboratory' value.

See Also

ItemIDs..::..Analytics..::..MarketingCenter Class
Sitecore Namespace


ItemIDs.Analytics.MarketingCenter Fields

[image] [image]

Sitecore 6.4.1 API
ItemIDs..::..Analytics..::..MarketingCenter Fields
ItemIDs..::..Analytics..::..MarketingCenter Class See Also Send Feedback

The ItemIDs..::..Analytics..::..MarketingCenter type exposes the following members.

Fields

Name | Description
Campaigns | ID indicating '/sitecore/system/Marketing Center/Campaigns' value.
Goals | ID indicating '/sitecore/system/Marketing Center/Goals' value.
Policies | ID indicating '/sitecore/system/Marketing Center/Presentation/Policies' value.
ReportFilters | ID indicating "/sitecore/system/Marketing Center/Reports/Report Filters" value.
TestLaboratory | ID indicating '/sitecore/system/Marketing Center/Test Laboratory' value.

See Also

ItemIDs..::..Analytics..::..MarketingCenter Class
Sitecore Namespace


Campaigns Field

[image]

Sitecore 6.4.1 API
ItemIDs..::..Analytics..::..MarketingCenter..::..Campaigns Field
ItemIDs..::..Analytics..::..MarketingCenter Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Campaigns
Visual Basic
Public Shared Campaigns As ID
Visual C++
public:
static ID^ Campaigns

See Also

ItemIDs..::..Analytics..::..MarketingCenter Class
Sitecore Namespace


Goals Field

[image]

Sitecore 6.4.1 API
ItemIDs..::..Analytics..::..MarketingCenter..::..Goals Field
ItemIDs..::..Analytics..::..MarketingCenter Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Goals
Visual Basic
Public Shared Goals As ID
Visual C++
public:
static ID^ Goals

See Also

ItemIDs..::..Analytics..::..MarketingCenter Class
Sitecore Namespace


Policies Field

[image]

Sitecore 6.4.1 API
ItemIDs..::..Analytics..::..MarketingCenter..::..Policies Field
ItemIDs..::..Analytics..::..MarketingCenter Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Policies
Visual Basic
Public Shared Policies As ID
Visual C++
public:
static ID^ Policies

See Also

ItemIDs..::..Analytics..::..MarketingCenter Class
Sitecore Namespace


ReportFilters Field

[image]

Sitecore 6.4.1 API
ItemIDs..::..Analytics..::..MarketingCenter..::..ReportFilters Field
ItemIDs..::..Analytics..::..MarketingCenter Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID ReportFilters
Visual Basic
Public Shared ReportFilters As ID
Visual C++
public:
static ID^ ReportFilters

See Also

ItemIDs..::..Analytics..::..MarketingCenter Class
Sitecore Namespace


TestLaboratory Field

[image]

Sitecore 6.4.1 API
ItemIDs..::..Analytics..::..MarketingCenter..::..TestLaboratory Field
ItemIDs..::..Analytics..::..MarketingCenter Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID TestLaboratory
Visual Basic
Public Shared TestLaboratory As ID
Visual C++
public:
static ID^ TestLaboratory

See Also

ItemIDs..::..Analytics..::..MarketingCenter Class
Sitecore Namespace


ItemIDs.Analytics.Reports Class

[image]

Sitecore 6.4.1 API
ItemIDs..::..Analytics..::..Reports Class
ItemIDs..::..Analytics Class Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Reports
Visual Basic
Public NotInheritable Class Reports
Visual C++
public ref class Reports abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore..::..ItemIDs..::..Analytics..::..Reports

See Also

ItemIDs..::..Analytics..::..Reports Members
Sitecore Namespace


ItemIDs.Analytics.Reports Members

[image] [image]

Sitecore 6.4.1 API
ItemIDs..::..Analytics..::..Reports Members
ItemIDs..::..Analytics..::..Reports Class Fields See Also Send Feedback

Defines the analytics class.

The ItemIDs..::..Analytics..::..Reports type exposes the following members.

Fields

Name | Description
ItemReports | ID indicating '/sitecore/system/settings/Analytics/Reports/Item reports' value.

See Also

ItemIDs..::..Analytics..::..Reports Class
Sitecore Namespace


ItemIDs.Analytics.Reports Fields

[image] [image]

Sitecore 6.4.1 API
ItemIDs..::..Analytics..::..Reports Fields
ItemIDs..::..Analytics..::..Reports Class See Also Send Feedback

The ItemIDs..::..Analytics..::..Reports type exposes the following members.

Fields

Name | Description
ItemReports | ID indicating '/sitecore/system/settings/Analytics/Reports/Item reports' value.

See Also

ItemIDs..::..Analytics..::..Reports Class
Sitecore Namespace


ItemReports Field

[image]

Sitecore 6.4.1 API
ItemIDs..::..Analytics..::..Reports..::..ItemReports Field
ItemIDs..::..Analytics..::..Reports Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID ItemReports
Visual Basic
Public Shared ItemReports As ID
Visual C++
public:
static ID^ ItemReports

See Also

ItemIDs..::..Analytics..::..Reports Class
Sitecore Namespace


LayoutFieldIDs Class

[image]

Sitecore 6.4.1 API
LayoutFieldIDs Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class LayoutFieldIDs
Visual Basic
Public NotInheritable Class LayoutFieldIDs
Visual C++
public ref class LayoutFieldIDs abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore..::..LayoutFieldIDs

See Also

LayoutFieldIDs Members
Sitecore Namespace


LayoutFieldIDs Members

[image] [image]

Sitecore 6.4.1 API
LayoutFieldIDs Members
LayoutFieldIDs Class Fields See Also Send Feedback

The LayoutFieldIDs type exposes the following members.

Fields

Name | Description
Path | The ID of the 'Path' field.

See Also

LayoutFieldIDs Class
Sitecore Namespace


LayoutFieldIDs Fields

[image] [image]

Sitecore 6.4.1 API
LayoutFieldIDs Fields
LayoutFieldIDs Class See Also Send Feedback

The LayoutFieldIDs type exposes the following members.

Fields

Name | Description
Path | The ID of the 'Path' field.

See Also

LayoutFieldIDs Class
Sitecore Namespace


Path Field

[image]

Sitecore 6.4.1 API
LayoutFieldIDs..::..Path Field
LayoutFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Path
Visual Basic
Public Shared Path As ID
Visual C++
public:
static ID^ Path

See Also

LayoutFieldIDs Class
Sitecore Namespace


MainUtil Class

[image]

Sitecore 6.4.1 API
MainUtil Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public sealed class MainUtil
Visual Basic
Public NotInheritable Class MainUtil
Visual C++
public ref class MainUtil sealed

Remarks

The MainUtil library covers both string and file utility functions. These function at a later point be moved to the StringUtil and FileUtil classes.

Inheritance Hierarchy

System..::..Object
Sitecore..::..MainUtil

See Also

MainUtil Members
Sitecore Namespace
Sitecore..::..DateUtil
Sitecore.IO..::..FileUtil
Sitecore.Web..::..HtmlUtil
Sitecore..::..StringUtil
Sitecore.Web..::..WebUtil
Sitecore.Xml..::..XmlUtil


MainUtil Members

[image] [image]

Sitecore 6.4.1 API
MainUtil Members
MainUtil Class Constructors Methods Properties See Also Send Feedback

The MainUtil type exposes the following members.

Constructors

 | Name | Description
Public method | MainUtil | Initializes a new instance of the MainUtil class

Methods

 | Name | Description
 | AcquireLock | Obsolete. Acquires a named lock.
 | AddArrays | Concatenates two arrays.
 | AppendMissingIDBrace | Appends a mssing closing brace "}" if a path starts with a brace "{".
 | BoolToString | Converts a boolean to "true" or "false".
 | BuildHashtable | Builds the hashtable.
 | Capitalize | Obsolete. Uppercases the first letter of a string and lowercases the remaining letters.
 | ClearBit | Resets a bit in an integer.
 | ColorToString | Converts a color to a string.
 | CombineArrays<(Of <<'(T>)>>)(array<T>[]()[][], T) | Combines an array and a value.
 | CombineArrays<(Of <<'(T>)>>)(array<T>[]()[][], array<T>[]()[][]) | Combines two arrays.
 | CompactArray(array<String>[]()[][]) | Compacts a string array by removing empty strings.
 | CompactArray(array<Object>[]()[][], Type) | Compacts an object array by removing null values.
 | CompareVersionNumbers | Compares two Sitecore version numbers.
 | ContainsUnicodeCharacters | Determines whether the specified string contains unicode characters.
 | ConvertArray | Converts an array to another type.
 | ConvertToHashtable | Converts an array list to a hashtable.
 | ConvertToNameValues(ArrayList) | Converts an array list to a name/value collection.
 | ConvertToNameValues(String, Char) | Converts a string to name/value collection.
 | ConvertToString(ArrayList, Char) | Converts an array list of strings to a single string.
 | ConvertToString(NameValueCollection, Char) | Converts a name/value collection to a single string.
 | ConvertToString(NameValueCollection, String, String) | Converts a name/value collection to a single string.
 | CopyArray | Inserts an array into another array.
 | CreateObject(Type) | Creates an instance of an object.
 | CreateObject(Type, array<Object>[]()[][]) | Creates an instance of an object.
 | CreateObject(String, String, array<Object>[]()[][]) | Creates an instance of an object.
 | DecodeName | Decodes an item name.
 | EncodeName | Encodes an item name.
 | EncodePath | Encodes an item path.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EscapePling | Escapes plings (') or quotes (") in a HTML tag attribute value.
 | ExpandArray(Array, Type) | Expands the array.
 | ExpandArray(Array, Type, Int32) | Expands the array.
 | ExpandSitecorePath | Expands the sitecore path.
 | False | Returns false.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindStartTag | Finds an end tag in a string.
 | FormatDouble | Formats a double.
 | FormatLong | Formats a long.
 | FormatSize | Formats a number into a size string.
 | GarbageCollect | Performs garbage collection to keep memory usage down.
 | GenerateShortID | Generates a short unique ID.
 | GetArrayList | Gets an array list of strings.
 | GetAssemblyName | Gets the name of the assembly containing a type.
 | GetBackupFilename | Gets a filename for a backup file.
 | GetBool(Object, Boolean) | Gets the bool.
 | GetBool(String, Boolean) | Gets the boolean value of a string.
 | GetBool(Tristate, Boolean) | Gets a boolean value from a Tristate.
 | GetCallerMethod | Gets a reference to a method on the call stack.
 | GetCallerName()()()() | Gets name of the calling method.
 | GetCallerName(Int32) | Gets name of the calling method.
 | GetCallerType | Gets the type of the caller.
 | GetCallStack()()()() | Gets the current call stack.
 | GetCallStack(Int32) | Gets the current call stack.
 | GetCurrentProcessThread | Gets the current process thread.
 | GetDotNetFolder | Gets the root folder of the current .NET Framework.
 | GetDotNetVersion | Gets the version of the current .NET Framework.
 | GetEnumerator<(Of <<'(T>)>>)(array<T>[]()[][]) | Combines two enumerators.
 | GetEnumerator<(Of <<'(T>)>>)(IEnumerable<(Of <<'(T>)>>), IEnumerable<(Of <<'(T>)>>)) | Combines two enumerators.
 | GetEnumerator<(Of <<'(T>)>>)(IEnumerable<(Of <<'(T>)>>), T) | Combines two enumerators.
 | GetEnumerator<(Of <<'(T>)>>)(T, IEnumerable<(Of <<'(T>)>>)) | Combines two enumerators.
 | GetExceptionMessage | Gets the message from an exception.
 | GetExtraEntries | Gets the extra entries in one hashtable compared to another.
 | GetFileLock | Obsolete. Gets file specific lock object.
 | GetFileTime | Obsolete. Gets the last modified time of a file.
 | GetFileWriteTime | Obsolete. Gets the last modified time of a file.
 | GetFloat | Gets the float value of a string.
 | GetGuid(Object) | Gets a guid from a string.
 | GetGuid(Object, Guid) | Gets a guid from a string.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHashtable | Gets a Hashtable from a list of objects.
 | GetID(Guid) | Gets the ID.
 | GetID(Object) | Gets the ID.
 | GetID(Object, ID) | Gets the ID.
 | GetID(String, ID) | Gets the ID.
 | GetImage(String) | Gets an image HTML tag.
 | GetImage(String, Boolean) | Gets an image HTML tag.
 | GetImage(String, Int32, Int32) | Gets an image HTML tag.
 | GetImage(String, Int32, Int32, Boolean) | Gets an image HTML tag.
 | GetImage(String, Int32, Int32, Int32, Int32) | Gets an image HTML tag.
 | GetImage(String, Int32, Int32, Int32, Int32, Boolean, Boolean) | Gets an image HTML tag.
 | GetImage(String, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean) | Gets an image HTML tag.
 | GetInt(Int32, Int32) | Gets an int different from zero.
 | GetInt(Object, Int32) | Gets the integer value of a string.
 | GetInt(String, Int32) | Gets the integer value of a string.
 | GetLong | Gets the integer long value of a string.
 | GetMachineName | Gets the name of the machine that this process is executing on.
 | GetMD5Hash | Gets the MD5 hash.
 | GetNameValues(String) | Obsolete. Converts a string to a name/value collection.
 | GetNameValues(array<String>[]()[][]) | Obsolete. Gets a name/value collection from a string array.
 | GetNameValues(String, Char, Char) | Obsolete. Converts a string to a name/value collection.
 | GetNewID | Generates a new GUID.
 | GetNextSequence | Gets next value of the sequencer.
 | GetNextVarNameSequence | Gets next value of the variable name sequencer, optionally resetting it if it has reached a certain maximum.
 | GetObject | Gets an object reference.
 | GetPrivateBytesUsed | Gets the memory used.
 | GetProcessID | Get current process info.
 | GetProcessInfo | Obsolete. Get current process info.
 | GetProcessName | Gets the name of the current process.
 | GetRequestFlag | Gets a boolean flag from the query string.
 | GetRequestInt | Gets an integer from the query string.
 | GetSequencer | Gets the current sequencer value.
 | GetSingleton<(Of <<'(T>)>>) | Gets a singleton.
 | GetSortKey(String) | Generates a unique sort key.
 | GetSortKey(String, String) | Generates a unique sort key.
 | GetSpacer(Int32, Int32) | Obsolete. Gets an image HTML tag with a blank image.
 | GetSpacer(Int32, Int32, Boolean) | Obsolete. Gets an image HTML tag with a blank image.
 | GetString(Object) | Obsolete. Gets the string value of an object.
 | GetString(Object, String) | Obsolete. Gets the string value of an object.
 | GetStringList | Gets an array list of strings.
 | GetThreadID | Gets the current thread ID.
 | GetTickCount | Gets the tick count.
 | GetTicks | Gets the ticks.
 | GetTristate(Boolean) | Gets a tristate from a bool.
 | GetTristate(Object, Tristate) | Gets the tristate.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetUniqueID | Generates a unique ID.
 | GetWebItemSource()()()() | Gets the web item data source from the query string.
 | GetWebItemSource(String) | Gets the web item data source from the query string.
 | GetWord | Gets n'th word from a string.
 | GetWorkFileName | Gets a unique filename.
 | GetWorkingSetSize | Gets size of current working set.
 | GuidToString(Guid) | Converts guid to string.
 | GuidToString(Guid, String) | Converts guid to string.
 | HexToColor | Converts a hex string to a color.
 | HexToInt | Converts a hex string to an integer.
 | Html | Writes a line of HTML to the Response output stream.
 | Ignore | Ignores the specified parameters.
 | IndexOf | Gets the index of an object in an array.
 | IntToHex | Converts an integer to a hex string.
 | IsBitSet | Determines whether the specified bit is set.
 | IsEmpty | Determines whether the specified string is empty.
 | IsFullPath | Determines whether the specified path is a full path.
 | IsID | Checks if string is a valid GUID.
 | IsType(Object, Type) | Checks if an object is of a given type
 | IsType(Type, Type) | Checks if an object is of a given type
 | IsXPath | Checks if a string contains an XPath expression.
 | Join(String, array<String>[]()[][]) | Joins an array of strings excluding any empty string from the result.
 | Join(String, String, String) | Joins two strings excluding any empty string from the result.
 | MakeFilePath(String, String) | Builds a file path from a folder and a file.
 | MakeFilePath(String, String, Boolean) | Builds a file path from a folder and a file.
 | MakePath | Obsolete. Makes a path from two filename parts.
 | MapPath | Maps a virtual file path to a physical file path.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MsgBox(String) | Shows a message box.
 | MsgBox(String, String) | Shows a message box.
 | Nop | No-op
 | NormalizeGuid(Guid) | Normalizes a GUID.
 | NormalizeGuid(String) | Normalizes a GUID.
 | NormalizeItemName | Normalizes an item name.
 | Out(String) | Writes a line of HTML to the Response output stream.
 | Out(String, Boolean) | Writes a line of HTML to the Response output stream.
 | RaiseEvent<(Of <<'(T>)>>) | Fires an event
 | ReadFromFile | Obsolete. Reads a text file.
 | ReleaseLock | Obsolete. Release a named lock
 | RemoveEmptyStrings | Removes the empty strings.
 | RemoveEnd | Removes a number of characters from the end of a string.
 | RemoveFromArray | Removes from array.
 | RemoveStart | Remove the first characters from a string.
 | ReplaceItemIDs | Replaces all item IDs in an XML document with new GUIDs.
 | ReplacePostfix | Replaces the postfix of a string.
 | ReplacePrefix | Replaces the prefix of a string.
 | SendMail(MailMessage) | Sends the mail.
 | SendMail(MailMessage) | Obsolete. Sends the mail.
 | SetBit | Sets the bit.
 | ShortenGuid | Shortens a GUID by removing braces and hyphens.
 | ShrinkArray(Array, Type) | Shrinks the array.
 | ShrinkArray(Array, Type, Int32) | Compacts an object array by removing nulls.
 | SilentCatch | Method to call when doing silent catches. Causes the Resharper warning to disappear.
 | Split(String, Char) | Splits a string into an array of strings.
 | Split(String, String) | Splits a string into an array of strings.
 | Split(String, Char, Boolean) | Splits a string into an array of strings.
 | Split(String, String, Boolean) | Splits a string into an array of strings.
 | SplitPath | Splits a Sitecore path into parts, optionally expanding it to include the root.
 | StringToBool | Converts a string to boolean.
 | StringToColor | Converts a string to a color.
 | Substring(String, Int32, Boolean) | Gets a substring of maximum length of a string.
 | Substring(String, Int32, Int32) | Retrieves a substring from a string. The substring starts at a specified character position and has a specified length.
 | TerminateAspNet()()()() | Terminates the ASP.NET worker process.
 | TerminateAspNet(String) | Terminates the ASP.NET worker process.
 | ThemedImage(String) | Gets a themed image path.
 | ThemedImage(String, ImageDimension) | Gets a themed image path.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | Touch | Touch
 | Trace | Writes a message to the trace.
 | TraceIf | Conditionally writes a message to the trace.
 | TristateToString | Converts a Tristate to a string.
 | True | Returns true.
 | UnmapPath | Maps a physical path to a virtual path.
 | Unquote | Obsolete. Removes enclosing single and double quotes from a string.
 | VerifyCallLevel | Verifies that a call level has not exceeded the maximum specified in the setting 'MaxCallLevel'.
 | Warn | Writes a warning message to the trace.
 | WriteToFile(String, array<Byte>[]()[][]%) | Obsolete. Writes a byte array to a file.
 | WriteToFile(String, String) | Obsolete. Writes a string to a file.
 | WriteToFile(String, String, Boolean) | Obsolete. Write or appends a atring to a file.

Properties

Name | Description
EncodeNameReplacements | Gets item name encodings.

See Also

MainUtil Class
Sitecore Namespace


MainUtil Constructor

[image]

Sitecore 6.4.1 API
MainUtil Constructor
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MainUtil()
Visual Basic
Public Sub New
Visual C++
public:
MainUtil()

See Also

MainUtil Class
Sitecore Namespace


MainUtil Methods

[image] [image]

Sitecore 6.4.1 API
MainUtil Methods
MainUtil Class See Also Send Feedback

The MainUtil type exposes the following members.

Methods

 | Name | Description
 | AcquireLock | Obsolete. Acquires a named lock.
 | AddArrays | Concatenates two arrays.
 | AppendMissingIDBrace | Appends a mssing closing brace "}" if a path starts with a brace "{".
 | BoolToString | Converts a boolean to "true" or "false".
 | BuildHashtable | Builds the hashtable.
 | Capitalize | Obsolete. Uppercases the first letter of a string and lowercases the remaining letters.
 | ClearBit | Resets a bit in an integer.
 | ColorToString | Converts a color to a string.
 | CombineArrays<(Of <<'(T>)>>)(array<T>[]()[][], T) | Combines an array and a value.
 | CombineArrays<(Of <<'(T>)>>)(array<T>[]()[][], array<T>[]()[][]) | Combines two arrays.
 | CompactArray(array<String>[]()[][]) | Compacts a string array by removing empty strings.
 | CompactArray(array<Object>[]()[][], Type) | Compacts an object array by removing null values.
 | CompareVersionNumbers | Compares two Sitecore version numbers.
 | ContainsUnicodeCharacters | Determines whether the specified string contains unicode characters.
 | ConvertArray | Converts an array to another type.
 | ConvertToHashtable | Converts an array list to a hashtable.
 | ConvertToNameValues(ArrayList) | Converts an array list to a name/value collection.
 | ConvertToNameValues(String, Char) | Converts a string to name/value collection.
 | ConvertToString(ArrayList, Char) | Converts an array list of strings to a single string.
 | ConvertToString(NameValueCollection, Char) | Converts a name/value collection to a single string.
 | ConvertToString(NameValueCollection, String, String) | Converts a name/value collection to a single string.
 | CopyArray | Inserts an array into another array.
 | CreateObject(Type) | Creates an instance of an object.
 | CreateObject(Type, array<Object>[]()[][]) | Creates an instance of an object.
 | CreateObject(String, String, array<Object>[]()[][]) | Creates an instance of an object.
 | DecodeName | Decodes an item name.
 | EncodeName | Encodes an item name.
 | EncodePath | Encodes an item path.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EscapePling | Escapes plings (') or quotes (") in a HTML tag attribute value.
 | ExpandArray(Array, Type) | Expands the array.
 | ExpandArray(Array, Type, Int32) | Expands the array.
 | ExpandSitecorePath | Expands the sitecore path.
 | False | Returns false.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindStartTag | Finds an end tag in a string.
 | FormatDouble | Formats a double.
 | FormatLong | Formats a long.
 | FormatSize | Formats a number into a size string.
 | GarbageCollect | Performs garbage collection to keep memory usage down.
 | GenerateShortID | Generates a short unique ID.
 | GetArrayList | Gets an array list of strings.
 | GetAssemblyName | Gets the name of the assembly containing a type.
 | GetBackupFilename | Gets a filename for a backup file.
 | GetBool(Object, Boolean) | Gets the bool.
 | GetBool(String, Boolean) | Gets the boolean value of a string.
 | GetBool(Tristate, Boolean) | Gets a boolean value from a Tristate.
 | GetCallerMethod | Gets a reference to a method on the call stack.
 | GetCallerName()()()() | Gets name of the calling method.
 | GetCallerName(Int32) | Gets name of the calling method.
 | GetCallerType | Gets the type of the caller.
 | GetCallStack()()()() | Gets the current call stack.
 | GetCallStack(Int32) | Gets the current call stack.
 | GetCurrentProcessThread | Gets the current process thread.
 | GetDotNetFolder | Gets the root folder of the current .NET Framework.
 | GetDotNetVersion | Gets the version of the current .NET Framework.
 | GetEnumerator<(Of <<'(T>)>>)(array<T>[]()[][]) | Combines two enumerators.
 | GetEnumerator<(Of <<'(T>)>>)(IEnumerable<(Of <<'(T>)>>), IEnumerable<(Of <<'(T>)>>)) | Combines two enumerators.
 | GetEnumerator<(Of <<'(T>)>>)(IEnumerable<(Of <<'(T>)>>), T) | Combines two enumerators.
 | GetEnumerator<(Of <<'(T>)>>)(T, IEnumerable<(Of <<'(T>)>>)) | Combines two enumerators.
 | GetExceptionMessage | Gets the message from an exception.
 | GetExtraEntries | Gets the extra entries in one hashtable compared to another.
 | GetFileLock | Obsolete. Gets file specific lock object.
 | GetFileTime | Obsolete. Gets the last modified time of a file.
 | GetFileWriteTime | Obsolete. Gets the last modified time of a file.
 | GetFloat | Gets the float value of a string.
 | GetGuid(Object) | Gets a guid from a string.
 | GetGuid(Object, Guid) | Gets a guid from a string.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHashtable | Gets a Hashtable from a list of objects.
 | GetID(Guid) | Gets the ID.
 | GetID(Object) | Gets the ID.
 | GetID(Object, ID) | Gets the ID.
 | GetID(String, ID) | Gets the ID.
 | GetImage(String) | Gets an image HTML tag.
 | GetImage(String, Boolean) | Gets an image HTML tag.
 | GetImage(String, Int32, Int32) | Gets an image HTML tag.
 | GetImage(String, Int32, Int32, Boolean) | Gets an image HTML tag.
 | GetImage(String, Int32, Int32, Int32, Int32) | Gets an image HTML tag.
 | GetImage(String, Int32, Int32, Int32, Int32, Boolean, Boolean) | Gets an image HTML tag.
 | GetImage(String, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean) | Gets an image HTML tag.
 | GetInt(Int32, Int32) | Gets an int different from zero.
 | GetInt(Object, Int32) | Gets the integer value of a string.
 | GetInt(String, Int32) | Gets the integer value of a string.
 | GetLong | Gets the integer long value of a string.
 | GetMachineName | Gets the name of the machine that this process is executing on.
 | GetMD5Hash | Gets the MD5 hash.
 | GetNameValues(String) | Obsolete. Converts a string to a name/value collection.
 | GetNameValues(array<String>[]()[][]) | Obsolete. Gets a name/value collection from a string array.
 | GetNameValues(String, Char, Char) | Obsolete. Converts a string to a name/value collection.
 | GetNewID | Generates a new GUID.
 | GetNextSequence | Gets next value of the sequencer.
 | GetNextVarNameSequence | Gets next value of the variable name sequencer, optionally resetting it if it has reached a certain maximum.
 | GetObject | Gets an object reference.
 | GetPrivateBytesUsed | Gets the memory used.
 | GetProcessID | Get current process info.
 | GetProcessInfo | Obsolete. Get current process info.
 | GetProcessName | Gets the name of the current process.
 | GetRequestFlag | Gets a boolean flag from the query string.
 | GetRequestInt | Gets an integer from the query string.
 | GetSequencer | Gets the current sequencer value.
 | GetSingleton<(Of <<'(T>)>>) | Gets a singleton.
 | GetSortKey(String) | Generates a unique sort key.
 | GetSortKey(String, String) | Generates a unique sort key.
 | GetSpacer(Int32, Int32) | Obsolete. Gets an image HTML tag with a blank image.
 | GetSpacer(Int32, Int32, Boolean) | Obsolete. Gets an image HTML tag with a blank image.
 | GetString(Object) | Obsolete. Gets the string value of an object.
 | GetString(Object, String) | Obsolete. Gets the string value of an object.
 | GetStringList | Gets an array list of strings.
 | GetThreadID | Gets the current thread ID.
 | GetTickCount | Gets the tick count.
 | GetTicks | Gets the ticks.
 | GetTristate(Boolean) | Gets a tristate from a bool.
 | GetTristate(Object, Tristate) | Gets the tristate.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetUniqueID | Generates a unique ID.
 | GetWebItemSource()()()() | Gets the web item data source from the query string.
 | GetWebItemSource(String) | Gets the web item data source from the query string.
 | GetWord | Gets n'th word from a string.
 | GetWorkFileName | Gets a unique filename.
 | GetWorkingSetSize | Gets size of current working set.
 | GuidToString(Guid) | Converts guid to string.
 | GuidToString(Guid, String) | Converts guid to string.
 | HexToColor | Converts a hex string to a color.
 | HexToInt | Converts a hex string to an integer.
 | Html | Writes a line of HTML to the Response output stream.
 | Ignore | Ignores the specified parameters.
 | IndexOf | Gets the index of an object in an array.
 | IntToHex | Converts an integer to a hex string.
 | IsBitSet | Determines whether the specified bit is set.
 | IsEmpty | Determines whether the specified string is empty.
 | IsFullPath | Determines whether the specified path is a full path.
 | IsID | Checks if string is a valid GUID.
 | IsType(Object, Type) | Checks if an object is of a given type
 | IsType(Type, Type) | Checks if an object is of a given type
 | IsXPath | Checks if a string contains an XPath expression.
 | Join(String, array<String>[]()[][]) | Joins an array of strings excluding any empty string from the result.
 | Join(String, String, String) | Joins two strings excluding any empty string from the result.
 | MakeFilePath(String, String) | Builds a file path from a folder and a file.
 | MakeFilePath(String, String, Boolean) | Builds a file path from a folder and a file.
 | MakePath | Obsolete. Makes a path from two filename parts.
 | MapPath | Maps a virtual file path to a physical file path.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MsgBox(String) | Shows a message box.
 | MsgBox(String, String) | Shows a message box.
 | Nop | No-op
 | NormalizeGuid(Guid) | Normalizes a GUID.
 | NormalizeGuid(String) | Normalizes a GUID.
 | NormalizeItemName | Normalizes an item name.
 | Out(String) | Writes a line of HTML to the Response output stream.
 | Out(String, Boolean) | Writes a line of HTML to the Response output stream.
 | RaiseEvent<(Of <<'(T>)>>) | Fires an event
 | ReadFromFile | Obsolete. Reads a text file.
 | ReleaseLock | Obsolete. Release a named lock
 | RemoveEmptyStrings | Removes the empty strings.
 | RemoveEnd | Removes a number of characters from the end of a string.
 | RemoveFromArray | Removes from array.
 | RemoveStart | Remove the first characters from a string.
 | ReplaceItemIDs | Replaces all item IDs in an XML document with new GUIDs.
 | ReplacePostfix | Replaces the postfix of a string.
 | ReplacePrefix | Replaces the prefix of a string.
 | SendMail(MailMessage) | Sends the mail.
 | SendMail(MailMessage) | Obsolete. Sends the mail.
 | SetBit | Sets the bit.
 | ShortenGuid | Shortens a GUID by removing braces and hyphens.
 | ShrinkArray(Array, Type) | Shrinks the array.
 | ShrinkArray(Array, Type, Int32) | Compacts an object array by removing nulls.
 | SilentCatch | Method to call when doing silent catches. Causes the Resharper warning to disappear.
 | Split(String, Char) | Splits a string into an array of strings.
 | Split(String, String) | Splits a string into an array of strings.
 | Split(String, Char, Boolean) | Splits a string into an array of strings.
 | Split(String, String, Boolean) | Splits a string into an array of strings.
 | SplitPath | Splits a Sitecore path into parts, optionally expanding it to include the root.
 | StringToBool | Converts a string to boolean.
 | StringToColor | Converts a string to a color.
 | Substring(String, Int32, Boolean) | Gets a substring of maximum length of a string.
 | Substring(String, Int32, Int32) | Retrieves a substring from a string. The substring starts at a specified character position and has a specified length.
 | TerminateAspNet()()()() | Terminates the ASP.NET worker process.
 | TerminateAspNet(String) | Terminates the ASP.NET worker process.
 | ThemedImage(String) | Gets a themed image path.
 | ThemedImage(String, ImageDimension) | Gets a themed image path.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | Touch | Touch
 | Trace | Writes a message to the trace.
 | TraceIf | Conditionally writes a message to the trace.
 | TristateToString | Converts a Tristate to a string.
 | True | Returns true.
 | UnmapPath | Maps a physical path to a virtual path.
 | Unquote | Obsolete. Removes enclosing single and double quotes from a string.
 | VerifyCallLevel | Verifies that a call level has not exceeded the maximum specified in the setting 'MaxCallLevel'.
 | Warn | Writes a warning message to the trace.
 | WriteToFile(String, array<Byte>[]()[][]%) | Obsolete. Writes a byte array to a file.
 | WriteToFile(String, String) | Obsolete. Writes a string to a file.
 | WriteToFile(String, String, Boolean) | Obsolete. Write or appends a atring to a file.

See Also

MainUtil Class
Sitecore Namespace


AcquireLock Method

[image]

Sitecore 6.4.1 API
MainUtil..::..AcquireLock Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public static CounterLock AcquireLock(
    string name
)
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Shared Function AcquireLock ( _
    name As String _
) As CounterLock
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public:
static CounterLock^ AcquireLock(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.AcquireLock(System.String)"]

See Also

MainUtil Class
Sitecore Namespace


AddArrays Method

[image]

Sitecore 6.4.1 API
MainUtil..::..AddArrays Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Array AddArrays(
    Array array1,
    Array array2,
    Type elementType
)
Visual Basic
Public Shared Function AddArrays ( _
    array1 As Array, _
    array2 As Array, _
    elementType As Type _
) As Array
Visual C++
public:
static Array^ AddArrays(
    Array^ array1,
    Array^ array2,
    Type^ elementType
)

Parameters

array1
Type: System..::..Array
The array1.
array2
Type: System..::..Array
The array2.
elementType
Type: System..::..Type
Type of the element.

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.AddArrays(System.Array,System.Array,System.Type)"]

See Also

MainUtil Class
Sitecore Namespace


AppendMissingIDBrace Method

[image]

Sitecore 6.4.1 API
MainUtil..::..AppendMissingIDBrace Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string AppendMissingIDBrace(
    string sPath
)
Visual Basic
Public Shared Function AppendMissingIDBrace ( _
    sPath As String _
) As String
Visual C++
public:
static String^ AppendMissingIDBrace(
    String^ sPath
)

Parameters

sPath
Type: System..::..String
A path.

Return Value

The path ending with a closing brace "}".

Remarks

This function is usually called to ensure that a GUID ends with a closing brace "}". This can occur if a web page is opened from Outlook by a pasted link as Outlook does not automatically include the ending brace "}".

Examples

CopyC#
string path = StringUtil.GetString(Request.QueryString["path"]);
string id = MainUtil.AppendMissingIDBrace(path);

See Also

MainUtil Class
Sitecore Namespace


BoolToString Method

[image]

Sitecore 6.4.1 API
MainUtil..::..BoolToString Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string BoolToString(
    bool b
)
Visual Basic
Public Shared Function BoolToString ( _
    b As Boolean _
) As String
Visual C++
public:
static String^ BoolToString(
    bool b
)

Parameters

b
Type: System..::..Boolean
A boolean value.

Return Value

If the boolean is true, "true", otherwise "false".

Examples

CopyC#
string trueString = MainUtil.BoolToString(1 = 1); // "true"
string falseString = MainUtil.BoolToString(1 = 0); // "false"

See Also

MainUtil Class
Sitecore Namespace


BuildHashtable Method

[image]

Sitecore 6.4.1 API
MainUtil..::..BuildHashtable Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Hashtable BuildHashtable(
    params Object[] objects
)
Visual Basic
Public Shared Function BuildHashtable ( _
    ParamArray objects As Object() _
) As Hashtable
Visual C++
public:
static Hashtable^ BuildHashtable(
    ... array<Object^>^ objects
)

Parameters

objects
Type: array< System..::..Object >[]()[][]
The objects.

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.BuildHashtable(System.Object[])"]

See Also

MainUtil Class
Sitecore Namespace


Capitalize Method

[image]

Sitecore 6.4.1 API
MainUtil..::..Capitalize Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use StringUtil.Capitalize instead.")]
public static string Capitalize(
    string text
)
Visual Basic
<ObsoleteAttribute("Use StringUtil.Capitalize instead.")> _
Public Shared Function Capitalize ( _
    text As String _
) As String
Visual C++
[ObsoleteAttribute(L"Use StringUtil.Capitalize instead.")]
public:
static String^ Capitalize(
    String^ text
)

Parameters

text
Type: System..::..String
A string.

Return Value

The capitalized string.

Remarks

Sentences are not taken into account.

Examples

CopyC#
string text = MainUtil.Capitalize("HELLO WORLD."); // "Hello world"
string text = MainUtil.Capitalize("HELLO. HOW ARE YOU?"); // "Hello. how are you?"

See Also

MainUtil Class
Sitecore Namespace


ClearBit Method

[image]

Sitecore 6.4.1 API
MainUtil..::..ClearBit Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int ClearBit(
    int bit,
    int bits
)
Visual Basic
Public Shared Function ClearBit ( _
    bit As Integer, _
    bits As Integer _
) As Integer
Visual C++
public:
static int ClearBit(
    int bit,
    int bits
)

Parameters

bit
Type: System..::..Int32
The bit.
bits
Type: System..::..Int32
The bits.

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.ClearBit(System.Int32,System.Int32)"]

See Also

MainUtil Class
Sitecore Namespace


ColorToString Method

[image]

Sitecore 6.4.1 API
MainUtil..::..ColorToString Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ColorToString(
    Color color
)
Visual Basic
Public Shared Function ColorToString ( _
    color As Color _
) As String
Visual C++
public:
static String^ ColorToString(
    Color color
)

Parameters

color
Type: System.Drawing..::..Color
The color.

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.ColorToString(System.Drawing.Color)"]

See Also

MainUtil Class
Sitecore Namespace


CombineArrays Method

[image] [image]

Sitecore 6.4.1 API
MainUtil..::..CombineArrays Method
MainUtil Class See Also Send Feedback

Overload List

Name | Description
CombineArrays<(Of <<'(T>)>>)(array<T>[]()[][], T) | Combines an array and a value.
CombineArrays<(Of <<'(T>)>>)(array<T>[]()[][], array<T>[]()[][]) | Combines two arrays.

See Also

MainUtil Class
MainUtil Members
Sitecore Namespace


CombineArrays(T) Method (T[], T)

[image]

Sitecore 6.4.1 API
MainUtil..::..CombineArrays<(Of <(<'T>)>)> Method (array<T>[]()[][], T)
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static T[] CombineArrays<T>(
    T[] values,
    T value
)
Visual Basic
Public Shared Function CombineArrays(Of T) ( _
    values As T(), _
    value As T _
) As T()
Visual C++
public:
generic<typename T>
static array<T>^ CombineArrays(
    array<T>^ values,
    T value
)

Parameters

values
Type: array<T>[]()[][]
The values.
value
Type: T
The value.

Type Parameters

T
The type of the arrrays.

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.CombineArrays``1(``0[],``0)"]

See Also

MainUtil Class
CombineArrays Overload
Sitecore Namespace


CombineArrays(T) Method (T[], T[])

[image]

Sitecore 6.4.1 API
MainUtil..::..CombineArrays<(Of <(<'T>)>)> Method (array<T>[]()[][], array<T>[]()[][])
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static T[] CombineArrays<T>(
    T[] values1,
    T[] values2
)
Visual Basic
Public Shared Function CombineArrays(Of T) ( _
    values1 As T(), _
    values2 As T() _
) As T()
Visual C++
public:
generic<typename T>
static array<T>^ CombineArrays(
    array<T>^ values1,
    array<T>^ values2
)

Parameters

values1
Type: array<T>[]()[][]
The first array of values.
values2
Type: array<T>[]()[][]
The second array of values.

Type Parameters

T
The type of the arrrays.

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.CombineArrays``1(``0[],``0[])"]

See Also

MainUtil Class
CombineArrays Overload
Sitecore Namespace


CompactArray Method

[image] [image]

Sitecore 6.4.1 API
MainUtil..::..CompactArray Method
MainUtil Class See Also Send Feedback

Overload List

Name | Description
CompactArray(array<String>[]()[][]) | Compacts a string array by removing empty strings.
CompactArray(array<Object>[]()[][], Type) | Compacts an object array by removing null values.

See Also

MainUtil Class
MainUtil Members
Sitecore Namespace


CompactArray Method (String[])

[image]

Sitecore 6.4.1 API
MainUtil..::..CompactArray Method (array<String>[]()[][])
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string[] CompactArray(
    string[] array
)
Visual Basic
Public Shared Function CompactArray ( _
    array As String() _
) As String()
Visual C++
public:
static array<String^>^ CompactArray(
    array<String^>^ array
)

Parameters

array
Type: array< System..::..String >[]()[][]
An array of string.

Return Value

The compacted array of string.

Examples

CopyC#
string[] texts = new string[] {"My", "", "Text, ""};
string[] compact = MainUtil.CompactArray(texts): // { "My", "Text" }

See Also

MainUtil Class
CompactArray Overload
Sitecore Namespace


CompactArray Method (Object[], Type)

[image]

Sitecore 6.4.1 API
MainUtil..::..CompactArray Method (array<Object>[]()[][], Type)
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object CompactArray(
    Object[] array,
    Type elementType
)
Visual Basic
Public Shared Function CompactArray ( _
    array As Object(), _
    elementType As Type _
) As Object
Visual C++
public:
static Object^ CompactArray(
    array<Object^>^ array,
    Type^ elementType
)

Parameters

array
Type: array< System..::..Object >[]()[][]
An array of object.
elementType
Type: System..::..Type
Type of the element.

Return Value

The compacted array of object.

See Also

MainUtil Class
CompactArray Overload
Sitecore Namespace


CompareVersionNumbers Method

[image]

Sitecore 6.4.1 API
MainUtil..::..CompareVersionNumbers Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int CompareVersionNumbers(
    string ver1,
    string ver2
)
Visual Basic
Public Shared Function CompareVersionNumbers ( _
    ver1 As String, _
    ver2 As String _
) As Integer
Visual C++
public:
static int CompareVersionNumbers(
    String^ ver1,
    String^ ver2
)

Parameters

ver1
Type: System..::..String
A version number, e.g. "x.x.x"
ver2
Type: System..::..String
A version number, e.g. "x.x.x"

Return Value

0 if the versions numbers are identical, -1 if ver1 < ver2, 1 if ver1 > ver2.

Examples

CopyC#
int compare0 = MainUtil.CompareVersionNumbers("1.0.1", "1.1.0"); // -1
int compare1 = MainUtil.CompareVersionNumbers("1.0.1", "1.0.0"); // 1

See Also

MainUtil Class
Sitecore Namespace


ContainsUnicodeCharacters Method

[image]

Sitecore 6.4.1 API
MainUtil..::..ContainsUnicodeCharacters Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool ContainsUnicodeCharacters(
    string str
)
Visual Basic
Public Shared Function ContainsUnicodeCharacters ( _
    str As String _
) As Boolean
Visual C++
public:
static bool ContainsUnicodeCharacters(
    String^ str
)

Parameters

str
Type: System..::..String
The string.

Return Value

true if the specified string contains unicode characters; otherwise, false.

See Also

MainUtil Class
Sitecore Namespace


ConvertArray Method

[image]

Sitecore 6.4.1 API
MainUtil..::..ConvertArray Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object ConvertArray(
    Object[] array,
    Type elementType
)
Visual Basic
Public Shared Function ConvertArray ( _
    array As Object(), _
    elementType As Type _
) As Object
Visual C++
public:
static Object^ ConvertArray(
    array<Object^>^ array,
    Type^ elementType
)

Parameters

array
Type: array< System..::..Object >[]()[][]
An array of objects.
elementType
Type: System..::..Type
Type of the element.

Return Value

The converted array of objects.

See Also

MainUtil Class
Sitecore Namespace


ConvertToNameValues Method

[image] [image]

Sitecore 6.4.1 API
MainUtil..::..ConvertToNameValues Method
MainUtil Class See Also Send Feedback

Overload List

Name | Description
ConvertToNameValues(ArrayList) | Converts an array list to a name/value collection.
ConvertToNameValues(String, Char) | Converts a string to name/value collection.

See Also

MainUtil Class
MainUtil Members
Sitecore Namespace


ConvertToNameValues Method (ArrayList)

[image]

Sitecore 6.4.1 API
MainUtil..::..ConvertToNameValues Method (ArrayList)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static NameValueCollection ConvertToNameValues(
    ArrayList list
)
Visual Basic
Public Shared Function ConvertToNameValues ( _
    list As ArrayList _
) As NameValueCollection
Visual C++
public:
static NameValueCollection^ ConvertToNameValues(
    ArrayList^ list
)

Parameters

list
Type: System.Collections..::..ArrayList
An array list of values.

Return Value

A name/value collection.

Remarks

The name/value collection is built by using values from the array list in pairs. An array list consisting of { "Name1", "Value1", "Name2", "Value2" } are converted to ("Name1", "Value1"), ("Name2", "Value2").

Examples

CopyC#
ArrayList list = new ArrayList(new string[] {"Name1", "Value1", "Name2", "Value2"});
NameValueCollection collection = MainUtil.ConvertToNameValues(list);

See Also

MainUtil Class
ConvertToNameValues Overload
Sitecore Namespace


ConvertToNameValues Method (String, Char)

[image]

Sitecore 6.4.1 API
MainUtil..::..ConvertToNameValues Method (String, Char)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static NameValueCollection ConvertToNameValues(
    string values,
    char separator
)
Visual Basic
Public Shared Function ConvertToNameValues ( _
    values As String, _
    separator As Char _
) As NameValueCollection
Visual C++
public:
static NameValueCollection^ ConvertToNameValues(
    String^ values,
    wchar_t separator
)

Parameters

values
Type: System..::..String
A string of seperated values.
separator
Type: System..::..Char
A separator character.

Return Value

A name/value collection.

Remarks

The name/value collection is built by using values from the string in pairs. A string consisting of "Name1|Value1|Name2|Value2" are converted to ("Name1", "Value1"), ("Name2", "Value2").

Examples

CopyC#
NameValueCollection collection = MainUtil.ConvertToNameValues("Name1|Value1|Name2|Value2", '|');

See Also

MainUtil Class
ConvertToNameValues Overload
Sitecore Namespace


ConvertToString Method

[image] [image]

Sitecore 6.4.1 API
MainUtil..::..ConvertToString Method
MainUtil Class See Also Send Feedback

Overload List

Name | Description
ConvertToString(ArrayList, Char) | Converts an array list of strings to a single string.
ConvertToString(NameValueCollection, Char) | Converts a name/value collection to a single string.
ConvertToString(NameValueCollection, String, String) | Converts a name/value collection to a single string.

See Also

MainUtil Class
MainUtil Members
Sitecore Namespace


ConvertToString Method (ArrayList, Char)

[image]

Sitecore 6.4.1 API
MainUtil..::..ConvertToString Method (ArrayList, Char)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ConvertToString(
    ArrayList list,
    char separator
)
Visual Basic
Public Shared Function ConvertToString ( _
    list As ArrayList, _
    separator As Char _
) As String
Visual C++
public:
static String^ ConvertToString(
    ArrayList^ list,
    wchar_t separator
)

Parameters

list
Type: System.Collections..::..ArrayList
An array list.
separator
Type: System..::..Char
A separator character.

Return Value

A string containing the list seperated by the separator character.

Remarks

If the array list is null, blank is returned.

Examples

CopyC#
ArrayList list = new ArrayList(new string[] {"Name1", "Value1", "Name2", "Value2"});
string s = MainUtil.ConvertToString(list, '|'); // "Name1|Value1|Name2|Value2"

See Also

MainUtil Class
ConvertToString Overload
Sitecore Namespace


ConvertToString Method (NameValueCollection, Char)

[image]

Sitecore 6.4.1 API
MainUtil..::..ConvertToString Method (NameValueCollection, Char)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ConvertToString(
    NameValueCollection col,
    char separator
)
Visual Basic
Public Shared Function ConvertToString ( _
    col As NameValueCollection, _
    separator As Char _
) As String
Visual C++
public:
static String^ ConvertToString(
    NameValueCollection^ col,
    wchar_t separator
)

Parameters

col
Type: System.Collections.Specialized..::..NameValueCollection
A name/value collection.
separator
Type: System..::..Char
A separator character.

Return Value

A string containing the name/value collection separated by the separator character.

Remarks

If the collection is null, blank is returned.

Examples

CopyC#
ArrayList list = new ArrayList(new string[] {"Name1", "Value1", "Name2", "Value2"});
NameValueCollection collection = MainUtil.ConvertToNamevalues(list);
string s = MainUtil.ConvertToString(collection, '|'); // "Name1|Value1|Name2|Value2"

See Also

MainUtil Class
ConvertToString Overload
Sitecore Namespace


CopyArray Method

[image]

Sitecore 6.4.1 API
MainUtil..::..CopyArray Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void CopyArray(
    Array source,
    Array destination,
    int startIndex,
    int count
)
Visual Basic
Public Shared Sub CopyArray ( _
    source As Array, _
    destination As Array, _
    startIndex As Integer, _
    count As Integer _
)
Visual C++
public:
static void CopyArray(
    Array^ source,
    Array^ destination,
    int startIndex,
    int count
)

Parameters

source
Type: System..::..Array
The source.
destination
Type: System..::..Array
The destination.
startIndex
Type: System..::..Int32
The start index.
count
Type: System..::..Int32
The count.

See Also

MainUtil Class
Sitecore Namespace


CreateObject Method

[image] [image]

Sitecore 6.4.1 API
MainUtil..::..CreateObject Method
MainUtil Class See Also Send Feedback

Overload List

Name | Description
CreateObject(Type) | Creates an instance of an object.
CreateObject(Type, array<Object>[]()[][]) | Creates an instance of an object.
CreateObject(String, String, array<Object>[]()[][]) | Creates an instance of an object.

See Also

MainUtil Class
MainUtil Members
Sitecore Namespace


CreateObject Method (Type)

[image]

Sitecore 6.4.1 API
MainUtil..::..CreateObject Method (Type)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object CreateObject(
    Type type
)
Visual Basic
Public Shared Function CreateObject ( _
    type As Type _
) As Object
Visual C++
public:
static Object^ CreateObject(
    Type^ type
)

Parameters

type
Type: System..::..Type
Name of both assembly and class of the object.

Return Value

The instantiated object or null if the object could not be instantiated.

Remarks

If the object could not be instantiated, an error message is written to the log file (usually located in the data folder).

Examples

CopyC#
object MyObject = MainUtil.CreateObject(myType);

See Also

MainUtil Class
CreateObject Overload
Sitecore Namespace


CreateObject Method (Type, Object[])

[image]

Sitecore 6.4.1 API
MainUtil..::..CreateObject Method (Type, array<Object>[]()[][])
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object CreateObject(
    Type type,
    Object[] parameters
)
Visual Basic
Public Shared Function CreateObject ( _
    type As Type, _
    parameters As Object() _
) As Object
Visual C++
public:
static Object^ CreateObject(
    Type^ type,
    array<Object^>^ parameters
)

Parameters

type
Type: System..::..Type
Name of both assembly and class of the object.
parameters
Type: array< System..::..Object >[]()[][]
Parameters.

Return Value

The instantiated object or null if the object could not be instantiated.

Remarks

If the object could not be instantiated, an error message is written to the log file (usually located in the data folder).

Examples

CopyC#
object MyObject = MainUtil.CreateObject("MyAssembly.MyObject", parameter1, parameter2);

See Also

MainUtil Class
CreateObject Overload
Sitecore Namespace


CreateObject Method (String, String, Object[])

[image]

Sitecore 6.4.1 API
MainUtil..::..CreateObject Method (String, String, array<Object>[]()[][])
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object CreateObject(
    string assembly,
    string className,
    params Object[] parameters
)
Visual Basic
Public Shared Function CreateObject ( _
    assembly As String, _
    className As String, _
    ParamArray parameters As Object() _
) As Object
Visual C++
public:
static Object^ CreateObject(
    String^ assembly,
    String^ className,
    ... array<Object^>^ parameters
)

Parameters

assembly
Type: System..::..String
An assembly file name.
className
Type: System..::..String
A class name.
parameters
Type: array< System..::..Object >[]()[][]
Parameters.

Return Value

The instantiated object or null if the object could not be instantiated.

Remarks

The assembly name is expanded to a qualified path by:

  • prepending "/bin/", if the filename does not contain any folder information.
  • appending ".dll", if the filename does not end with ".dll".

If the object could not be instantiated, an error message is written to the log file (usually located in the data folder).

Examples

CopyC#
object MyObject = MainUtil.CreateObject("/bin/MyAssembly.dll", "MyNamespace.MyObject");
object MyObject2 = MainUtil.CreateObject("MyAssembly", "MyNamespace.MyObject2", parameter1, parameter2);

See Also

MainUtil Class
CreateObject Overload
Sitecore Namespace


DecodeName Method

[image]

Sitecore 6.4.1 API
MainUtil..::..DecodeName Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string DecodeName(
    string name
)
Visual Basic
Public Shared Function DecodeName ( _
    name As String _
) As String
Visual C++
public:
static String^ DecodeName(
    String^ name
)

Parameters

name
Type: System..::..String
An item name.

Return Value

The decoded name.

Remarks

It can be necessary to encode item names to ensure working friendly URLs. For instance the item name "Bruun & Rasmussen" contains the character "&" which is URL automatically escaped by most browsers.

The encoding is configured in the web.config section <encodeNameReplacements>.

Examples

CopyC#
IMasterItem item = MasterFactory.GetItem("/sitecore/content/Home/Bruun & Rasmussen");
string encodedName = MainUtil.EncodeName(item.Name); // "Bruun --a-- Rasmussen"
string decodedName = MainUtil.DecodeName(encodedName); // "Bruun & Rasmussen"

See Also

MainUtil Class
Sitecore Namespace
MainUtil..::..EncodeName(String)


EncodeName Method

[image]

Sitecore 6.4.1 API
MainUtil..::..EncodeName Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string EncodeName(
    string name
)
Visual Basic
Public Shared Function EncodeName ( _
    name As String _
) As String
Visual C++
public:
static String^ EncodeName(
    String^ name
)

Parameters

name
Type: System..::..String
An item name.

Return Value

The encoded name.

Remarks

It can be necessary to encode item names to ensure working friendly URLs. For instance the item name "Bruun & Rasmussen" contains the character "&" which is URL automatically escaped by most browsers.

The encoding is configured in the web.config section <encodeNameReplacements>.

Examples

CopyC#
IMasterItem item = MasterFactory.GetItem("/sitecore/content/Home/Bruun & Rasmussen");
string encodedName = MainUtil.EncodeName(item.Name); // "Bruun ,-a-, Rasmussen"
string decodedName = MainUtil.DecodeName(encodedName); // "Bruun & Rasmussen"

See Also

MainUtil Class
Sitecore Namespace
MainUtil..::..DecodeName(String)


EncodePath Method

[image]

Sitecore 6.4.1 API
MainUtil..::..EncodePath Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string EncodePath(
    string path,
    char separator
)
Visual Basic
Public Shared Function EncodePath ( _
    path As String, _
    separator As Char _
) As String
Visual C++
public:
static String^ EncodePath(
    String^ path,
    wchar_t separator
)

Parameters

path
Type: System..::..String
An item path.
separator
Type: System..::..Char
The separator used between elements of the path

Return Value

The encoded path.

Remarks

It can be necessary to encode item names to ensure working friendly URLs. For instance the item name "Bruun & Rasmussen" contains the character "&" which is URL automatically escaped by most browsers.

The encoding is configured in the web.config section <encodeNameReplacements>.

Examples

CopyC#
string encodedPath = MainUtil.EncodePath("/home/Bruun & Rasmussen"); // "/home/Bruun ,-a-, Rasmussen"

See Also

MainUtil Class
Sitecore Namespace
MainUtil..::..DecodeName(String)


EscapePling Method

[image]

Sitecore 6.4.1 API
MainUtil..::..EscapePling Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string EscapePling(
    string attribute
)
Visual Basic
Public Shared Function EscapePling ( _
    attribute As String _
) As String
Visual C++
public:
static String^ EscapePling(
    String^ attribute
)

Parameters

attribute
Type: System..::..String
An attribute value.

Return Value

The escaped value.

Remarks

When adding attribute values to an HTML tag, it can be necessaty to escaping single quotes (plings or "'") in the value.

Examples

CopyC#
string attr = MainUtil.EscapePling("Allan's attribute"); // "Allan&#39;s attribute"

See Also

MainUtil Class
Sitecore Namespace


ExpandArray Method (Array, Type)

[image]

Sitecore 6.4.1 API
MainUtil..::..ExpandArray Method (Array, Type)
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Array ExpandArray(
    Array array,
    Type elementType
)
Visual Basic
Public Shared Function ExpandArray ( _
    array As Array, _
    elementType As Type _
) As Array
Visual C++
public:
static Array^ ExpandArray(
    Array^ array,
    Type^ elementType
)

Parameters

array
Type: System..::..Array
The array.
elementType
Type: System..::..Type
Type of the element.

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.ExpandArray(System.Array,System.Type)"]

See Also

MainUtil Class
ExpandArray Overload
Sitecore Namespace


ExpandArray Method (Array, Type, Int32)

[image]

Sitecore 6.4.1 API
MainUtil..::..ExpandArray Method (Array, Type, Int32)
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Array ExpandArray(
    Array array,
    Type elementType,
    int newSize
)
Visual Basic
Public Shared Function ExpandArray ( _
    array As Array, _
    elementType As Type, _
    newSize As Integer _
) As Array
Visual C++
public:
static Array^ ExpandArray(
    Array^ array,
    Type^ elementType,
    int newSize
)

Parameters

array
Type: System..::..Array
The array.
elementType
Type: System..::..Type
Type of the element.
newSize
Type: System..::..Int32
The new size.

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.ExpandArray(System.Array,System.Type,System.Int32)"]

See Also

MainUtil Class
ExpandArray Overload
Sitecore Namespace


ExpandSitecorePath Method

[image]

Sitecore 6.4.1 API
MainUtil..::..ExpandSitecorePath Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ExpandSitecorePath(
    string path
)
Visual Basic
Public Shared Function ExpandSitecorePath ( _
    path As String _
) As String
Visual C++
public:
static String^ ExpandSitecorePath(
    String^ path
)

Parameters

path
Type: System..::..String
The path.

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.ExpandSitecorePath(System.String)"]

See Also

MainUtil Class
Sitecore Namespace


False Method

[image]

Sitecore 6.4.1 API
MainUtil..::..False Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool False()
Visual Basic
Public Shared Function False As Boolean
Visual C++
public:
static bool False()

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.False"]

See Also

MainUtil Class
Sitecore Namespace


FindStartTag Method

[image]

Sitecore 6.4.1 API
MainUtil..::..FindStartTag Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Match FindStartTag(
    string sTagName,
    string sText
)
Visual Basic
Public Shared Function FindStartTag ( _
    sTagName As String, _
    sText As String _
) As Match
Visual C++
public:
static Match^ FindStartTag(
    String^ sTagName,
    String^ sText
)

Parameters

sTagName
Type: System..::..String
A tag name, e.g. "div".
sText
Type: System..::..String
A string.

Return Value

A regular expression Match object.

Examples

CopyC#
Match match = HtmlUtil.FindEndTag("div", "<div>This is my HTML</div>");

See Also

MainUtil Class
Sitecore Namespace


FormatDouble Method

[image]

Sitecore 6.4.1 API
MainUtil..::..FormatDouble Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string FormatDouble(
    double value
)
Visual Basic
Public Shared Function FormatDouble ( _
    value As Double _
) As String
Visual C++
public:
static String^ FormatDouble(
    double value
)

Parameters

value
Type: System..::..Double

[Missing <param name="value"/> documentation for "M:Sitecore.MainUtil.FormatDouble(System.Double)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.FormatDouble(System.Double)"]

See Also

MainUtil Class
Sitecore Namespace


FormatLong Method

[image]

Sitecore 6.4.1 API
MainUtil..::..FormatLong Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string FormatLong(
    long value
)
Visual Basic
Public Shared Function FormatLong ( _
    value As Long _
) As String
Visual C++
public:
static String^ FormatLong(
    long long value
)

Parameters

value
Type: System..::..Int64

[Missing <param name="value"/> documentation for "M:Sitecore.MainUtil.FormatLong(System.Int64)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.FormatLong(System.Int64)"]

See Also

MainUtil Class
Sitecore Namespace


FormatSize Method

[image]

Sitecore 6.4.1 API
MainUtil..::..FormatSize Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string FormatSize(
    long size
)
Visual Basic
Public Shared Function FormatSize ( _
    size As Long _
) As String
Visual C++
public:
static String^ FormatSize(
    long long size
)

Parameters

size
Type: System..::..Int64

[Missing <param name="size"/> documentation for "M:Sitecore.MainUtil.FormatSize(System.Int64)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.FormatSize(System.Int64)"]

Remarks

Size strings are "10 KB" or "2 MB".

See Also

MainUtil Class
Sitecore Namespace


GarbageCollect Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GarbageCollect Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void GarbageCollect()
Visual Basic
Public Shared Sub GarbageCollect
Visual C++
public:
static void GarbageCollect()

See Also

MainUtil Class
Sitecore Namespace


GenerateShortID Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GenerateShortID Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GenerateShortID()
Visual Basic
Public Shared Function GenerateShortID As String
Visual C++
public:
static String^ GenerateShortID()

Return Value

A short unique ID like "scid12".

Remarks

The serial number is generated from a threadsafe counter.

Examples

CopyC#
string myID = MainUtil.GenerateShortID(); // "scid1"

See Also

MainUtil Class
Sitecore Namespace


GetArrayList Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GetArrayList Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ArrayList GetArrayList(
    params string[] strings
)
Visual Basic
Public Shared Function GetArrayList ( _
    ParamArray strings As String() _
) As ArrayList
Visual C++
public:
static ArrayList^ GetArrayList(
    ... array<String^>^ strings
)

Parameters

strings
Type: array< System..::..String >[]()[][]
Strings

Return Value

An array list containing the strings.

Examples

CopyC#
ArrayList list = MainUtil.GetArrayList("Item1", "Item2", "Item3");

See Also

MainUtil Class
Sitecore Namespace


GetAssemblyName Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GetAssemblyName Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetAssemblyName(
    Type type
)
Visual Basic
Public Shared Function GetAssemblyName ( _
    type As Type _
) As String
Visual C++
public:
static String^ GetAssemblyName(
    Type^ type
)

Parameters

type
Type: System..::..Type
A type.

Return Value

The name of the assembly containg the type.

Examples

CopyC#
string assemblyName = MainUtil.GetAssemblyName(Sitecore.MasterFactory.GetType()); // "Sitecore.Kernel"

See Also

MainUtil Class
Sitecore Namespace


GetBackupFilename Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GetBackupFilename Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetBackupFilename(
    string folder,
    string prefix,
    string extension
)
Visual Basic
Public Shared Function GetBackupFilename ( _
    folder As String, _
    prefix As String, _
    extension As String _
) As String
Visual C++
public:
static String^ GetBackupFilename(
    String^ folder,
    String^ prefix,
    String^ extension
)

Parameters

folder
Type: System..::..String
The folder of a file.
prefix
Type: System..::..String
The file prefix of a file (usually the filename itself).
extension
Type: System..::..String
The extension of a file.

Return Value

A unique filename.

Remarks

This function is deprecated - use FileUtil.GetBackupFilename instead.

See Also

MainUtil Class
Sitecore Namespace
FileUtil..::..GetBackupFilename(String)


GetBool Method

[image] [image]

Sitecore 6.4.1 API
MainUtil..::..GetBool Method
MainUtil Class See Also Send Feedback

Overload List

Name | Description
GetBool(Object, Boolean) | Gets the bool.
GetBool(String, Boolean) | Gets the boolean value of a string.
GetBool(Tristate, Boolean) | Gets a boolean value from a Tristate.

See Also

MainUtil Class
MainUtil Members
Sitecore Namespace


GetBool Method (Object, Boolean)

[image]

Sitecore 6.4.1 API
MainUtil..::..GetBool Method (Object, Boolean)
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool GetBool(
    Object obj,
    bool defaultValue
)
Visual Basic
Public Shared Function GetBool ( _
    obj As Object, _
    defaultValue As Boolean _
) As Boolean
Visual C++
public:
static bool GetBool(
    Object^ obj,
    bool defaultValue
)

Parameters

obj
Type: System..::..Object
The object.
defaultValue
Type: System..::..Boolean
if set to true this instance is _default.

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.GetBool(System.Object,System.Boolean)"]

See Also

MainUtil Class
GetBool Overload
Sitecore Namespace


GetBool Method (String, Boolean)

[image]

Sitecore 6.4.1 API
MainUtil..::..GetBool Method (String, Boolean)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool GetBool(
    string value,
    bool defaultValue
)
Visual Basic
Public Shared Function GetBool ( _
    value As String, _
    defaultValue As Boolean _
) As Boolean
Visual C++
public:
static bool GetBool(
    String^ value,
    bool defaultValue
)

Parameters

value
Type: System..::..String
A string.
defaultValue
Type: System..::..Boolean
A default boolean value.

Return Value

The boolean value of the string.

Remarks

The boolean value is true, if the string is one of the following values (case-insensitive):
  • true
  • yes
  • 1

Otherwise the value is false.

The default value is returned if the string is blank or null.

Examples

CopyC#
bool b0 = MainUtil.BoolToString("true", false); // true
bool b1 = MainUtil.BoolToString("True", false); // true
bool b2 = MainUtil.BoolToString("yes", false); // true
bool b3 = MainUtil.BoolToString("1", false); // true
bool b4 = MainUtil.BoolToString("no", false); // false
bool b5 = MainUtil.BoolToString("false", false); // false
bool b6 = MainUtil.BoolToString("", false); // false
bool b6 = MainUtil.BoolToString("", true); // true
bool b6 = MainUtil.BoolToString(null, true); // true

See Also

MainUtil Class
GetBool Overload
Sitecore Namespace


GetBool Method (Tristate, Boolean)

[image]

Sitecore 6.4.1 API
MainUtil..::..GetBool Method (Tristate, Boolean)
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool GetBool(
    Tristate value,
    bool defaultValue
)
Visual Basic
Public Shared Function GetBool ( _
    value As Tristate, _
    defaultValue As Boolean _
) As Boolean
Visual C++
public:
static bool GetBool(
    Tristate value,
    bool defaultValue
)

Parameters

value
Type: Sitecore..::..Tristate
The value.
defaultValue
Type: System..::..Boolean
if set to true [default value].

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.GetBool(Sitecore.Tristate,System.Boolean)"]

See Also

MainUtil Class
GetBool Overload
Sitecore Namespace


GetCallerMethod Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GetCallerMethod Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static MethodBase GetCallerMethod(
    int indexInStack
)
Visual Basic
Public Shared Function GetCallerMethod ( _
    indexInStack As Integer _
) As MethodBase
Visual C++
public:
static MethodBase^ GetCallerMethod(
    int indexInStack
)

Parameters

indexInStack
Type: System..::..Int32
Index of method on the stack.

Return Value

A method.

Remarks

Use 1 to get the name of the function calling GetStackMethod, 2 to get the function calling that etc.

See Also

MainUtil Class
Sitecore Namespace
MainUtil..::..GetCallerName()()()()
MainUtil..::..GetCallerType(Int32)


GetCallerName Method

[image] [image]

Sitecore 6.4.1 API
MainUtil..::..GetCallerName Method
MainUtil Class See Also Send Feedback

Overload List

Name | Description
GetCallerName()()()() | Gets name of the calling method.
GetCallerName(Int32) | Gets name of the calling method.

See Also

MainUtil Class
MainUtil Members
Sitecore Namespace


GetCallerName Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GetCallerName Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetCallerName()
Visual Basic
Public Shared Function GetCallerName As String
Visual C++
public:
static String^ GetCallerName()

Return Value

The name of the calling method.

Examples

CopyC#
void MyFunction() {
string caller = MainUtil.GetCallerName(); // "MyCaller"
}
void MyCaller() {
MyFunction();
}

See Also

MainUtil Class
GetCallerName Overload
Sitecore Namespace
MainUtil..::..GetCallerMethod(Int32)
MainUtil..::..GetCallerType(Int32)


GetCallerName Method (Int32)

[image]

Sitecore 6.4.1 API
MainUtil..::..GetCallerName Method (Int32)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetCallerName(
    int indexInStack
)
Visual Basic
Public Shared Function GetCallerName ( _
    indexInStack As Integer _
) As String
Visual C++
public:
static String^ GetCallerName(
    int indexInStack
)

Parameters

indexInStack
Type: System..::..Int32
The index in stack.

Return Value

The name of the calling method.

Examples

CopyC#
void MyFunction() {
string caller = MainUtil.GetCallerName(); // "MyCaller"
}
void MyCaller() {
MyFunction();
}

See Also

MainUtil Class
GetCallerName Overload
Sitecore Namespace
MainUtil..::..GetCallerMethod(Int32)
MainUtil..::..GetCallerType(Int32)


GetCallStack Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GetCallStack Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetCallStack()
Visual Basic
Public Shared Function GetCallStack As String
Visual C++
public:
static String^ GetCallStack()

Return Value

The call stack.

See Also

MainUtil Class
GetCallStack Overload
Sitecore Namespace


GetCallStack Method (Int32)

[image]

Sitecore 6.4.1 API
MainUtil..::..GetCallStack Method (Int32)
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetCallStack(
    int levels
)
Visual Basic
Public Shared Function GetCallStack ( _
    levels As Integer _
) As String
Visual C++
public:
static String^ GetCallStack(
    int levels
)

Parameters

levels
Type: System..::..Int32

[Missing <param name="levels"/> documentation for "M:Sitecore.MainUtil.GetCallStack(System.Int32)"]

Return Value

The call stack.

See Also

MainUtil Class
GetCallStack Overload
Sitecore Namespace


GetCurrentProcessThread Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GetCurrentProcessThread Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ProcessThread GetCurrentProcessThread()
Visual Basic
Public Shared Function GetCurrentProcessThread As ProcessThread
Visual C++
public:
static ProcessThread^ GetCurrentProcessThread()

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.GetCurrentProcessThread"]

See Also

MainUtil Class
Sitecore Namespace


GetDotNetFolder Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GetDotNetFolder Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetDotNetFolder()
Visual Basic
Public Shared Function GetDotNetFolder As String
Visual C++
public:
static String^ GetDotNetFolder()

Return Value

The path to the root folder of the current .NET Framework.

Examples

CopyC#
string version = MainUtil.GetDotNetFolder();

See Also

MainUtil Class
Sitecore Namespace


GetDotNetVersion Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GetDotNetVersion Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetDotNetVersion()
Visual Basic
Public Shared Function GetDotNetVersion As String
Visual C++
public:
static String^ GetDotNetVersion()

Return Value

The version of the current .NET Framework.

Examples

CopyC#
string version = MainUtil.GetDotNetVersion();

See Also

MainUtil Class
Sitecore Namespace
Environment..::..Version


GetEnumerator(T) Method (T[])

[image]

Sitecore 6.4.1 API
MainUtil..::..GetEnumerator<(Of <(<'T>)>)> Method (array<T>[]()[][])
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static IEnumerable<T> GetEnumerator<T>(
    params T[] items
)
Visual Basic
Public Shared Function GetEnumerator(Of T) ( _
    ParamArray items As T() _
) As IEnumerable(Of T)
Visual C++
public:
generic<typename T>
static IEnumerable<T>^ GetEnumerator(
    ... array<T>^ items
)

Parameters

items
Type: array<T>[]()[][]
The items.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Sitecore.MainUtil.GetEnumerator``1(``0[])"]

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.GetEnumerator``1(``0[])"]

See Also

MainUtil Class
GetEnumerator Overload
Sitecore Namespace


GetEnumerator(T) Method (IEnumerable(T), IEnumerable(T))

[image]

Sitecore 6.4.1 API
MainUtil..::..GetEnumerator<(Of <(<'T>)>)> Method (IEnumerable<(Of <(<'T>)>)>, IEnumerable<(Of <(<'T>)>)>)
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static IEnumerable<T> GetEnumerator<T>(
    IEnumerable<T> list1,
    IEnumerable<T> list2
)
Visual Basic
Public Shared Function GetEnumerator(Of T) ( _
    list1 As IEnumerable(Of T), _
    list2 As IEnumerable(Of T) _
) As IEnumerable(Of T)
Visual C++
public:
generic<typename T>
static IEnumerable<T>^ GetEnumerator(
    IEnumerable<T>^ list1,
    IEnumerable<T>^ list2
)

Parameters

list1
Type: System.Collections.Generic..::..IEnumerable <(Of <(<'T>)>)>
The first list.
list2
Type: System.Collections.Generic..::..IEnumerable <(Of <(<'T>)>)>
The second list.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Sitecore.MainUtil.GetEnumerator``1(System.Collections.Generic.IEnumerable{``0},System.Collections.Generic.IEnumerable{``0})"]

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.GetEnumerator``1(System.Collections.Generic.IEnumerable{``0},System.Collections.Generic.IEnumerable{``0})"]

See Also

MainUtil Class
GetEnumerator Overload
Sitecore Namespace


GetEnumerator(T) Method (IEnumerable(T), T)

[image]

Sitecore 6.4.1 API
MainUtil..::..GetEnumerator<(Of <(<'T>)>)> Method (IEnumerable<(Of <(<'T>)>)>, T)
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static IEnumerable<T> GetEnumerator<T>(
    IEnumerable<T> list1,
    T item
)
Visual Basic
Public Shared Function GetEnumerator(Of T) ( _
    list1 As IEnumerable(Of T), _
    item As T _
) As IEnumerable(Of T)
Visual C++
public:
generic<typename T>
static IEnumerable<T>^ GetEnumerator(
    IEnumerable<T>^ list1,
    T item
)

Parameters

list1
Type: System.Collections.Generic..::..IEnumerable <(Of <(<'T>)>)>
The first list.
item
Type: T
A single item.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Sitecore.MainUtil.GetEnumerator``1(System.Collections.Generic.IEnumerable{``0},``0)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.GetEnumerator``1(System.Collections.Generic.IEnumerable{``0},``0)"]

See Also

MainUtil Class
GetEnumerator Overload
Sitecore Namespace


GetEnumerator(T) Method (T, IEnumerable(T))

[image]

Sitecore 6.4.1 API
MainUtil..::..GetEnumerator<(Of <(<'T>)>)> Method (T, IEnumerable<(Of <(<'T>)>)>)
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static IEnumerable<T> GetEnumerator<T>(
    T item,
    IEnumerable<T> list1
)
Visual Basic
Public Shared Function GetEnumerator(Of T) ( _
    item As T, _
    list1 As IEnumerable(Of T) _
) As IEnumerable(Of T)
Visual C++
public:
generic<typename T>
static IEnumerable<T>^ GetEnumerator(
    T item,
    IEnumerable<T>^ list1
)

Parameters

item
Type: T
A single item.
list1
Type: System.Collections.Generic..::..IEnumerable <(Of <(<'T>)>)>
The first list.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Sitecore.MainUtil.GetEnumerator``1(``0,System.Collections.Generic.IEnumerable{``0})"]

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.GetEnumerator``1(``0,System.Collections.Generic.IEnumerable{``0})"]

See Also

MainUtil Class
GetEnumerator Overload
Sitecore Namespace


GetExceptionMessage Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GetExceptionMessage Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetExceptionMessage(
    Exception ex
)
Visual Basic
Public Shared Function GetExceptionMessage ( _
    ex As Exception _
) As String
Visual C++
public:
static String^ GetExceptionMessage(
    Exception^ ex
)

Parameters

ex
Type: System..::..Exception
An exception.

Return Value

The message part of the exception.

Remarks

The message includes any inner exceptions.

Examples

CopyC#
string message = MainUtil.GetExceptionMessage(exption);

See Also

MainUtil Class
Sitecore Namespace


GetExtraEntries Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GetExtraEntries Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Hashtable GetExtraEntries(
    Hashtable big,
    Hashtable small
)
Visual Basic
Public Shared Function GetExtraEntries ( _
    big As Hashtable, _
    small As Hashtable _
) As Hashtable
Visual C++
public:
static Hashtable^ GetExtraEntries(
    Hashtable^ big,
    Hashtable^ small
)

Parameters

big
Type: System.Collections..::..Hashtable
The big.
small
Type: System.Collections..::..Hashtable
The small.

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.GetExtraEntries(System.Collections.Hashtable,System.Collections.Hashtable)"]

See Also

MainUtil Class
Sitecore Namespace


GetFileLock Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GetFileLock Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use FileUtil.GetFileLock instead.")]
public static Object GetFileLock(
    string path
)
Visual Basic
<ObsoleteAttribute("Use FileUtil.GetFileLock instead.")> _
Public Shared Function GetFileLock ( _
    path As String _
) As Object
Visual C++
[ObsoleteAttribute(L"Use FileUtil.GetFileLock instead.")]
public:
static Object^ GetFileLock(
    String^ path
)

Parameters

path
Type: System..::..String
A filename path.

Return Value

The lock object.

See Also

MainUtil Class
Sitecore Namespace


GetFileTime Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GetFileTime Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use FileUtil.GetFileTime instead", false)]
public static string GetFileTime(
    string filePath
)
Visual Basic
<ObsoleteAttribute("Use FileUtil.GetFileTime instead", False)> _
Public Shared Function GetFileTime ( _
    filePath As String _
) As String
Visual C++
[ObsoleteAttribute(L"Use FileUtil.GetFileTime instead", false)]
public:
static String^ GetFileTime(
    String^ filePath
)

Parameters

filePath
Type: System..::..String
A filename path.

Return Value

The last modified time of the file as a string.

Remarks

If the file does not have a last modified time, blank is returned.

Examples

CopyC#
string lastModified = MainUtil.GetFileTime("/robots.txt");

See Also

MainUtil Class
Sitecore Namespace


GetFileWriteTime Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GetFileWriteTime Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use FileUtil.GetFileWriteTime instead", false)]
public static DateTime GetFileWriteTime(
    string filePath
)
Visual Basic
<ObsoleteAttribute("Use FileUtil.GetFileWriteTime instead", False)> _
Public Shared Function GetFileWriteTime ( _
    filePath As String _
) As DateTime
Visual C++
[ObsoleteAttribute(L"Use FileUtil.GetFileWriteTime instead", false)]
public:
static DateTime GetFileWriteTime(
    String^ filePath
)

Parameters

filePath
Type: System..::..String
A filename path.

Return Value

The last modified time of the file as a date/time.

Remarks

If the file does not have a last modified time, DateTime.MinValue is returned.

Examples

CopyC#
DateTime lastModified = MainUtil.GetFileWriteTime("/robots.txt");

See Also

MainUtil Class
Sitecore Namespace


GetFloat Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GetFloat Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static float GetFloat(
    string value,
    float defaultValue
)
Visual Basic
Public Shared Function GetFloat ( _
    value As String, _
    defaultValue As Single _
) As Single
Visual C++
public:
static float GetFloat(
    String^ value,
    float defaultValue
)

Parameters

value
Type: System..::..String
A string that can be converted to a float.
defaultValue
Type: System..::..Single
A default value.

Return Value

The float value of a string.

Remarks

The default value is returned if the string is blank, null or is not a float. No exception is thrown if the string is not a float.

Note that InvariantCulture is used for the conversion.

Examples

CopyC#
float i0 = MainUtil.GetFloat("1.2", 0); // 1.2
float i1 = MainUtil.GetFloat("", 2.3); // 2.3
float i3 = MainUtil.GetFloat("12.3abc", 0); // 0.0

See Also

MainUtil Class
Sitecore Namespace


GetGuid Method

[image] [image]

Sitecore 6.4.1 API
MainUtil..::..GetGuid Method
MainUtil Class See Also Send Feedback

Overload List

Name | Description
GetGuid(Object) | Gets a guid from a string.
GetGuid(Object, Guid) | Gets a guid from a string.

See Also

MainUtil Class
MainUtil Members
Sitecore Namespace


GetGuid Method (Object)

[image]

Sitecore 6.4.1 API
MainUtil..::..GetGuid Method (Object)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Guid GetGuid(
    Object obj
)
Visual Basic
Public Shared Function GetGuid ( _
    obj As Object _
) As Guid
Visual C++
public:
static Guid GetGuid(
    Object^ obj
)

Parameters

obj
Type: System..::..Object
A string or other object that can be converted to a guid.

Return Value

The guid corresponding to the string. If the string can not be converted to a guid, GuidsOld.Null is returned.

Remarks

GuidsOld.Null is returned if the string is blank, null or is not a guid. No exception is thrown if the string is not a guid.

Examples

CopyC#
Guid g1 = MainUtil.GetGuid(""); // {00000000-0000-0000-0000-000000000000}
Guid g2 = MainUtil.GetGuid("{1930BBEB-7805-471A-A3BE-4858AC7CF696}"); // {1930BBEB-7805-471A-A3BE-4858AC7CF696}

See Also

MainUtil Class
GetGuid Overload
Sitecore Namespace


GetGuid Method (Object, Guid)

[image]

Sitecore 6.4.1 API
MainUtil..::..GetGuid Method (Object, Guid)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Guid GetGuid(
    Object obj,
    Guid defaultValue
)
Visual Basic
Public Shared Function GetGuid ( _
    obj As Object, _
    defaultValue As Guid _
) As Guid
Visual C++
public:
static Guid GetGuid(
    Object^ obj,
    Guid defaultValue
)

Parameters

obj
Type: System..::..Object
A string or other object that can be converted to a guid.
defaultValue
Type: System..::..Guid
A default value.

Return Value

The guid corresponding to the string.

Remarks

The default value is returned if the string is blank, null or is not a guid. No exception is thrown if the string is not a guid.

Examples

CopyC#
Guid g1 = MainUtil.GetGuid("", GuidsOld.Null); // {00000000-0000-0000-0000-000000000000}
Guid g2 = MainUtil.GetGuid("{1930BBEB-7805-471A-A3BE-4858AC7CF696}", GuidsOld.Null); // {1930BBEB-7805-471A-A3BE-4858AC7CF696}

See Also

MainUtil Class
GetGuid Overload
Sitecore Namespace


GetID Method

[image] [image]

Sitecore 6.4.1 API
MainUtil..::..GetID Method
MainUtil Class See Also Send Feedback

Overload List

Name | Description
GetID(Guid) | Gets the ID.
GetID(Object) | Gets the ID.
GetID(Object, ID) | Gets the ID.
GetID(String, ID) | Gets the ID.

See Also

MainUtil Class
MainUtil Members
Sitecore Namespace


GetID Method (Guid)

[image]

Sitecore 6.4.1 API
MainUtil..::..GetID Method (Guid)
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID GetID(
    Guid value
)
Visual Basic
Public Shared Function GetID ( _
    value As Guid _
) As ID
Visual C++
public:
static ID^ GetID(
    Guid value
)

Parameters

value
Type: System..::..Guid
The value.

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.GetID(System.Guid)"]

See Also

MainUtil Class
GetID Overload
Sitecore Namespace


GetID Method (Object)

[image]

Sitecore 6.4.1 API
MainUtil..::..GetID Method (Object)
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID GetID(
    Object value
)
Visual Basic
Public Shared Function GetID ( _
    value As Object _
) As ID
Visual C++
public:
static ID^ GetID(
    Object^ value
)

Parameters

value
Type: System..::..Object
The value.

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.GetID(System.Object)"]

See Also

MainUtil Class
GetID Overload
Sitecore Namespace


GetID Method (Object, ID)

[image]

Sitecore 6.4.1 API
MainUtil..::..GetID Method (Object, ID)
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID GetID(
    Object value,
    ID defaultValue
)
Visual Basic
Public Shared Function GetID ( _
    value As Object, _
    defaultValue As ID _
) As ID
Visual C++
public:
static ID^ GetID(
    Object^ value,
    ID^ defaultValue
)

Parameters

value
Type: System..::..Object
The value.
defaultValue
Type: Sitecore.Data..::..ID
The default value.

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.GetID(System.Object,Sitecore.Data.ID)"]

See Also

MainUtil Class
GetID Overload
Sitecore Namespace


GetID Method (String, ID)

[image]

Sitecore 6.4.1 API
MainUtil..::..GetID Method (String, ID)
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID GetID(
    string value,
    ID defaultValue
)
Visual Basic
Public Shared Function GetID ( _
    value As String, _
    defaultValue As ID _
) As ID
Visual C++
public:
static ID^ GetID(
    String^ value,
    ID^ defaultValue
)

Parameters

value
Type: System..::..String
The value.
defaultValue
Type: Sitecore.Data..::..ID
The default value.

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.GetID(System.String,Sitecore.Data.ID)"]

See Also

MainUtil Class
GetID Overload
Sitecore Namespace


GetImage Method

[image] [image]

Sitecore 6.4.1 API
MainUtil..::..GetImage Method
MainUtil Class See Also Send Feedback

Overload List

Name | Description
GetImage(String) | Gets an image HTML tag.
GetImage(String, Boolean) | Gets an image HTML tag.
GetImage(String, Int32, Int32) | Gets an image HTML tag.
GetImage(String, Int32, Int32, Boolean) | Gets an image HTML tag.
GetImage(String, Int32, Int32, Int32, Int32) | Gets an image HTML tag.
GetImage(String, Int32, Int32, Int32, Int32, Boolean, Boolean) | Gets an image HTML tag.
GetImage(String, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean) | Gets an image HTML tag.

See Also

MainUtil Class
MainUtil Members
Sitecore Namespace


GetImage Method (String)

[image]

Sitecore 6.4.1 API
MainUtil..::..GetImage Method (String)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetImage(
    string sImage
)
Visual Basic
Public Shared Function GetImage ( _
    sImage As String _
) As String
Visual C++
public:
static String^ GetImage(
    String^ sImage
)

Parameters

sImage
Type: System..::..String
The source of the image.

Return Value

The image HTML tag.

Examples

CopyC#
string img = MainUtil.GetImage("/sitecore/images/blank.gif"); // <img src="/sitecore/images/blank.gif" border="0"/>

See Also

MainUtil Class
GetImage Overload
Sitecore Namespace


GetImage Method (String, Boolean)

[image]

Sitecore 6.4.1 API
MainUtil..::..GetImage Method (String, Boolean)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetImage(
    string sImage,
    bool bVerticalCenter
)
Visual Basic
Public Shared Function GetImage ( _
    sImage As String, _
    bVerticalCenter As Boolean _
) As String
Visual C++
public:
static String^ GetImage(
    String^ sImage,
    bool bVerticalCenter
)

Parameters

sImage
Type: System..::..String
The source of the image.
bVerticalCenter
Type: System..::..Boolean
Indicates if the image is vertically centered.

Return Value

The image HTML tag.

Examples

CopyC#
string img = MainUtil.GetImage("/sitecore/images/blank.gif", true); // <img src="/sitecore/images/blank.gif" border="0" style="vertical-align: middle;"/>

See Also

MainUtil Class
GetImage Overload
Sitecore Namespace


GetImage Method (String, Int32, Int32)

[image]

Sitecore 6.4.1 API
MainUtil..::..GetImage Method (String, Int32, Int32)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetImage(
    string sImage,
    int nWidth,
    int nHeight
)
Visual Basic
Public Shared Function GetImage ( _
    sImage As String, _
    nWidth As Integer, _
    nHeight As Integer _
) As String
Visual C++
public:
static String^ GetImage(
    String^ sImage,
    int nWidth,
    int nHeight
)

Parameters

sImage
Type: System..::..String
The source of the image.
nWidth
Type: System..::..Int32
Width of the image.
nHeight
Type: System..::..Int32
Height of the image.

Return Value

The image HTML tag.

Examples

CopyC#
string img = MainUtil.GetImage("/sitecore/images/blank.gif", 20, 20); // <img src="/sitecore/images/blank.gif" border="0" width="20" height="20"/>

See Also

MainUtil Class
GetImage Overload
Sitecore Namespace


GetImage Method (String, Int32, Int32, Boolean)

[image]

Sitecore 6.4.1 API
MainUtil..::..GetImage Method (String, Int32, Int32, Boolean)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetImage(
    string sImage,
    int nWidth,
    int nHeight,
    bool bVerticalCenter
)
Visual Basic
Public Shared Function GetImage ( _
    sImage As String, _
    nWidth As Integer, _
    nHeight As Integer, _
    bVerticalCenter As Boolean _
) As String
Visual C++
public:
static String^ GetImage(
    String^ sImage,
    int nWidth,
    int nHeight,
    bool bVerticalCenter
)

Parameters

sImage
Type: System..::..String
The source of the image.
nWidth
Type: System..::..Int32
Width of the image.
nHeight
Type: System..::..Int32
Height of the image.
bVerticalCenter
Type: System..::..Boolean
Indicates if the image is vertically centered.

Return Value

The image HTML tag.

Examples

CopyC#
string img = MainUtil.GetImage("/sitecore/images/blank.gif", 20, 20, true); // <img src="/sitecore/images/blank.gif" border="0" width="20" height="20" style="vertical-align: middle;"/>

See Also

MainUtil Class
GetImage Overload
Sitecore Namespace


GetImage Method (String, Int32, Int32, Int32, Int32)

[image]

Sitecore 6.4.1 API
MainUtil..::..GetImage Method (String, Int32, Int32, Int32, Int32)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetImage(
    string sImage,
    int nWidth,
    int nHeight,
    int nHSpace,
    int nVSpace
)
Visual Basic
Public Shared Function GetImage ( _
    sImage As String, _
    nWidth As Integer, _
    nHeight As Integer, _
    nHSpace As Integer, _
    nVSpace As Integer _
) As String
Visual C++
public:
static String^ GetImage(
    String^ sImage,
    int nWidth,
    int nHeight,
    int nHSpace,
    int nVSpace
)

Parameters

sImage
Type: System..::..String
The source of the image.
nWidth
Type: System..::..Int32
Width of the image.
nHeight
Type: System..::..Int32
Height of the image.
nHSpace
Type: System..::..Int32
Horizontal space.
nVSpace
Type: System..::..Int32
Vertical space.

Return Value

The image HTML tag.

Examples

CopyC#
string img = MainUtil.GetImage("/sitecore/images/blank.gif", 20, 20, 4, 4); // <img src="/sitecore/images/blank.gif" border="0" width="20" height="20" vspace="4" hspace="4"/>

See Also

MainUtil Class
GetImage Overload
Sitecore Namespace


GetImage Method (String, Int32, Int32, Int32, Int32, Boolean, Boolean)

[image]

Sitecore 6.4.1 API
MainUtil..::..GetImage Method (String, Int32, Int32, Int32, Int32, Boolean, Boolean)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetImage(
    string sImage,
    int nWidth,
    int nHeight,
    int nHSpace,
    int nVSpace,
    bool bVerticalCenter,
    bool bDisabled
)
Visual Basic
Public Shared Function GetImage ( _
    sImage As String, _
    nWidth As Integer, _
    nHeight As Integer, _
    nHSpace As Integer, _
    nVSpace As Integer, _
    bVerticalCenter As Boolean, _
    bDisabled As Boolean _
) As String
Visual C++
public:
static String^ GetImage(
    String^ sImage,
    int nWidth,
    int nHeight,
    int nHSpace,
    int nVSpace,
    bool bVerticalCenter,
    bool bDisabled
)

Parameters

sImage
Type: System..::..String
The source of the image.
nWidth
Type: System..::..Int32
Width of the image.
nHeight
Type: System..::..Int32
Height of the image.
nHSpace
Type: System..::..Int32
Height of the image.
nVSpace
Type: System..::..Int32
Vertical space.
bVerticalCenter
Type: System..::..Boolean
Indicates if the image is vertically centered.
bDisabled
Type: System..::..Boolean
Indicates if the image is grayed out.

Return Value

The image HTML tag.

Examples

CopyC#
string img = MainUtil.GetImage("/sitecore/images/blank.gif", 20, 20, 4, 4, true); // <img src="/sitecore/images/blank.gif" border="0" width="20" height="20" vspace="4" hspace="4" style="vertical-align: middle;"/>

See Also

MainUtil Class
GetImage Overload
Sitecore Namespace


GetImage Method (String, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean)

[image]

Sitecore 6.4.1 API
MainUtil..::..GetImage Method (String, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetImage(
    string sImage,
    int nWidth,
    int nHeight,
    int nHSpace,
    int nVSpace,
    bool bVerticalCenter,
    bool bDisabled,
    bool bDropShadow
)
Visual Basic
Public Shared Function GetImage ( _
    sImage As String, _
    nWidth As Integer, _
    nHeight As Integer, _
    nHSpace As Integer, _
    nVSpace As Integer, _
    bVerticalCenter As Boolean, _
    bDisabled As Boolean, _
    bDropShadow As Boolean _
) As String
Visual C++
public:
static String^ GetImage(
    String^ sImage,
    int nWidth,
    int nHeight,
    int nHSpace,
    int nVSpace,
    bool bVerticalCenter,
    bool bDisabled,
    bool bDropShadow
)

Parameters

sImage
Type: System..::..String
The source of the image.
nWidth
Type: System..::..Int32
Width of the image.
nHeight
Type: System..::..Int32
Height of the image.
nHSpace
Type: System..::..Int32
Height of the image.
nVSpace
Type: System..::..Int32
Vertical space.
bVerticalCenter
Type: System..::..Boolean
Indicates if the image is vertically centered.
bDisabled
Type: System..::..Boolean
Indicates if the image is grayed.
bDropShadow
Type: System..::..Boolean
Indicates if a drop show is drawn.

Return Value

The image HTML tag.

Examples

CopyC#
string img = MainUtil.GetImage("/sitecore/images/blank.gif", 20, 20, 4, 4, true, false, false); // <img src="/sitecore/images/blank.gif" border="0" width="20" height="20" vspace="4" hspace="4" style="vertical-align: middle;"/>

See Also

MainUtil Class
GetImage Overload
Sitecore Namespace


GetInt Method (Int32, Int32)

[image]

Sitecore 6.4.1 API
MainUtil..::..GetInt Method (Int32, Int32)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int GetInt(
    int value,
    int defaultValue
)
Visual Basic
Public Shared Function GetInt ( _
    value As Integer, _
    defaultValue As Integer _
) As Integer
Visual C++
public:
static int GetInt(
    int value,
    int defaultValue
)

Parameters

value
Type: System..::..Int32
The value.
defaultValue
Type: System..::..Int32
The default value that wiil be returned if value is zero.

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.GetInt(System.Int32,System.Int32)"]

Examples

CopyC#
int i0 = MainUtil.GetInt(12, 0); // 12
int i1 = MainUtil.GetInt(12, 13); // 12
int i2 = MainUtil.GetInt(0, 0); // 0
int i3 = MainUtil.GetInt(0, 15); // 15
int i4 = MainUtil.GetInt(-5, 15); // -5

See Also

MainUtil Class
GetInt Overload
Sitecore Namespace


GetInt Method (Object, Int32)

[image]

Sitecore 6.4.1 API
MainUtil..::..GetInt Method (Object, Int32)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int GetInt(
    Object obj,
    int defaultValue
)
Visual Basic
Public Shared Function GetInt ( _
    obj As Object, _
    defaultValue As Integer _
) As Integer
Visual C++
public:
static int GetInt(
    Object^ obj,
    int defaultValue
)

Parameters

obj
Type: System..::..Object
A string or other object that can be converted to an int.
defaultValue
Type: System..::..Int32
A default value.

Return Value

The integer value of a string.

Remarks

The default value is returned if the string is blank, null or is not an integer. No exception is thrown if the string is not an integer.

Examples

CopyC#
int i0 = MainUtil.GetInt("12", 0); // 12
int i1 = MainUtil.GetInt("", 0); // 0
int i2 = MainUtil.GetInt(null, 0); // 0
int i3 = MainUtil.GetInt("123abc", 0); // 0

See Also

MainUtil Class
GetInt Overload
Sitecore Namespace


GetInt Method (String, Int32)

[image]

Sitecore 6.4.1 API
MainUtil..::..GetInt Method (String, Int32)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int GetInt(
    string value,
    int defaultValue
)
Visual Basic
Public Shared Function GetInt ( _
    value As String, _
    defaultValue As Integer _
) As Integer
Visual C++
public:
static int GetInt(
    String^ value,
    int defaultValue
)

Parameters

value
Type: System..::..String
A string that can be converted to an int.
defaultValue
Type: System..::..Int32
A default value.

Return Value

The integer value of a string.

Remarks

The default value is returned if the string is blank, null or is not an integer. No exception is thrown if the string is not an integer.

Examples

CopyC#
int i0 = MainUtil.GetInt("12", 0); // 12
int i1 = MainUtil.GetInt("", 0); // 0
int i2 = MainUtil.GetInt(null, 0); // 0
int i3 = MainUtil.GetInt("123abc", 0); // 0

See Also

MainUtil Class
GetInt Overload
Sitecore Namespace


GetLong Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GetLong Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long GetLong(
    Object obj,
    long defaultValue
)
Visual Basic
Public Shared Function GetLong ( _
    obj As Object, _
    defaultValue As Long _
) As Long
Visual C++
public:
static long long GetLong(
    Object^ obj,
    long long defaultValue
)

Parameters

obj
Type: System..::..Object
A string or other object that can be converted to a long.
defaultValue
Type: System..::..Int64
A default value.

Return Value

The integer long value of a string.

Remarks

The default value is returned if the string is blank, null or is not an integer. No exception is thrown if the string is not an integer.

Examples

CopyC#
int i0 = MainUtil.GetInt("12", 0); // 12
int i1 = MainUtil.GetInt("", 0); // 0
int i2 = MainUtil.GetInt(null, 0); // 0
int i3 = MainUtil.GetInt("123abc", 0); // 0

See Also

MainUtil Class
Sitecore Namespace


GetMachineName Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GetMachineName Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetMachineName()
Visual Basic
Public Shared Function GetMachineName As String
Visual C++
public:
static String^ GetMachineName()

Return Value

The name of the machine that this process is executing on.

See Also

MainUtil Class
Sitecore Namespace


GetMD5Hash Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GetMD5Hash Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID GetMD5Hash(
    string text
)
Visual Basic
Public Shared Function GetMD5Hash ( _
    text As String _
) As ID
Visual C++
public:
static ID^ GetMD5Hash(
    String^ text
)

Parameters

text
Type: System..::..String
The text.

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.GetMD5Hash(System.String)"]

See Also

MainUtil Class
Sitecore Namespace


GetNameValues Method

[image] [image]

Sitecore 6.4.1 API
MainUtil..::..GetNameValues Method
MainUtil Class See Also Send Feedback

Overload List

Name | Description
GetNameValues(String) | Obsolete. Converts a string to a name/value collection.
GetNameValues(array<String>[]()[][]) | Obsolete. Gets a name/value collection from a string array.
GetNameValues(String, Char, Char) | Obsolete. Converts a string to a name/value collection.

See Also

MainUtil Class
MainUtil Members
Sitecore Namespace


GetNameValues Method (String)

[image]

Sitecore 6.4.1 API
MainUtil..::..GetNameValues Method (String)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use StringUtil.GetNameValues instead", false)]
public static NameValueCollection GetNameValues(
    string list
)
Visual Basic
<ObsoleteAttribute("Use StringUtil.GetNameValues instead", False)> _
Public Shared Function GetNameValues ( _
    list As String _
) As NameValueCollection
Visual C++
[ObsoleteAttribute(L"Use StringUtil.GetNameValues instead", false)]
public:
static NameValueCollection^ GetNameValues(
    String^ list
)

Parameters

list
Type: System..::..String
A string of seperated values.

Return Value

A name/value collection.

Remarks

The format of the string must be "name=value|name=value...". The name/value collection is built by using values from the string in pairs. A string consisting of "Name1=Value1|Name2=Value2" are converted to ("Name1", "Value1"), ("Name2", "Value2").

Examples

CopyC#
NameValueCollection collection = MainUtil.GetNameValues("Name1=Value1|Name2=Value2");

See Also

MainUtil Class
GetNameValues Overload
Sitecore Namespace


GetNameValues Method (String[])

[image]

Sitecore 6.4.1 API
MainUtil..::..GetNameValues Method (array<String>[]()[][])
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use StringUtil.GetNameValues instead", false)]
public static NameValueCollection GetNameValues(
    string[] list
)
Visual Basic
<ObsoleteAttribute("Use StringUtil.GetNameValues instead", False)> _
Public Shared Function GetNameValues ( _
    list As String() _
) As NameValueCollection
Visual C++
[ObsoleteAttribute(L"Use StringUtil.GetNameValues instead", false)]
public:
static NameValueCollection^ GetNameValues(
    array<String^>^ list
)

Parameters

list
Type: array< System..::..String >[]()[][]
An array of strings.

Return Value

A name/value collection.

Remarks

The name/value collection is built by using values from the string array in pairs. A string array consisting of { "Name1, "Value1", "Name2", "Value2" } are converted to ("Name1", "Value1"), ("Name2", "Value2").

Examples

CopyC#
NameValueCollection collection = MainUtil.GetNameValues(new string[] {"Name1", "Value1", "Name2", "Value2" });

See Also

MainUtil Class
GetNameValues Overload
Sitecore Namespace


GetNameValues Method (String, Char, Char)

[image]

Sitecore 6.4.1 API
MainUtil..::..GetNameValues Method (String, Char, Char)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use StringUtil.GetNameValues instead", false)]
public static NameValueCollection GetNameValues(
    string list,
    char equal,
    char separator
)
Visual Basic
<ObsoleteAttribute("Use StringUtil.GetNameValues instead", False)> _
Public Shared Function GetNameValues ( _
    list As String, _
    equal As Char, _
    separator As Char _
) As NameValueCollection
Visual C++
[ObsoleteAttribute(L"Use StringUtil.GetNameValues instead", false)]
public:
static NameValueCollection^ GetNameValues(
    String^ list,
    wchar_t equal,
    wchar_t separator
)

Parameters

list
Type: System..::..String
A string of seperated values.
equal
Type: System..::..Char
Name/value pair separator.
separator
Type: System..::..Char
Pair separator.

Return Value

A name/value collection.

Remarks

The name/value collection is built by using values from the string in pairs. A string consisting of "Name1=Value1|Name2=Value2" are converted to ("Name1", "Value1"), ("Name2", "Value2").

Examples

CopyC#
NameValueCollection collection = MainUtil.GetNameValues("Name1=Value1|Name2=Value2", '=', '|');

See Also

MainUtil Class
GetNameValues Overload
Sitecore Namespace


GetNewID Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GetNewID Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetNewID()
Visual Basic
Public Shared Function GetNewID As String
Visual C++
public:
static String^ GetNewID()

Return Value

The GUID as a string.

Examples

CopyC#
string id = MainUtil.GetNewID();

See Also

MainUtil Class
Sitecore Namespace


GetNextSequence Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GetNextSequence Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long GetNextSequence()
Visual Basic
Public Shared Function GetNextSequence As Long
Visual C++
public:
static long long GetNextSequence()

Return Value

The next value of the sequencer.

Remarks

This function is threadsafe and can be used to generate serial numbers. The sequencer is incremented before the value is returned. The value is unique for the duration of the ASP.NET process lifetime.

Examples

CopyC#
string list = "";
for(int n = 0; n < 5; n++) {
list += "id" + MainUtil.GetSequencer().ToString() + ",";
}
// id12,id13,id14,id15,id16

See Also

MainUtil Class
Sitecore Namespace
MainUtil..::..GetSequencer()()()()


GetObject Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GetObject Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object GetObject(
    Object obj,
    Object defaultValue
)
Visual Basic
Public Shared Function GetObject ( _
    obj As Object, _
    defaultValue As Object _
) As Object
Visual C++
public:
static Object^ GetObject(
    Object^ obj,
    Object^ defaultValue
)

Parameters

obj
Type: System..::..Object
An object.
defaultValue
Type: System..::..Object
A default object.

Return Value

An object.

Remarks

If the object is null, the default value is returned.

Examples

CopyC#
object obj0 = MainUtil.GetObject(myObject, null); // myObject
object obj1 = MainUtil.GetObject(null, "123"); // "123"

See Also

MainUtil Class
Sitecore Namespace


GetPrivateBytesUsed Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GetPrivateBytesUsed Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long GetPrivateBytesUsed()
Visual Basic
Public Shared Function GetPrivateBytesUsed As Long
Visual C++
public:
static long long GetPrivateBytesUsed()

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.GetPrivateBytesUsed"]

See Also

MainUtil Class
Sitecore Namespace


GetProcessID Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GetProcessID Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int GetProcessID()
Visual Basic
Public Shared Function GetProcessID As Integer
Visual C++
public:
static int GetProcessID()

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.GetProcessID"]

See Also

MainUtil Class
Sitecore Namespace


GetProcessInfo Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GetProcessInfo Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public static ProcessInfo GetProcessInfo()
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Shared Function GetProcessInfo As ProcessInfo
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public:
static ProcessInfo^ GetProcessInfo()

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.GetProcessInfo"]

See Also

MainUtil Class
Sitecore Namespace


GetProcessName Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GetProcessName Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetProcessName()
Visual Basic
Public Shared Function GetProcessName As String
Visual C++
public:
static String^ GetProcessName()

Return Value

The String.

See Also

MainUtil Class
Sitecore Namespace


GetRequestFlag Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GetRequestFlag Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool GetRequestFlag(
    string sName,
    bool bDefault
)
Visual Basic
Public Shared Function GetRequestFlag ( _
    sName As String, _
    bDefault As Boolean _
) As Boolean
Visual C++
public:
static bool GetRequestFlag(
    String^ sName,
    bool bDefault
)

Parameters

sName
Type: System..::..String
The name of the query string parameter.
bDefault
Type: System..::..Boolean
A default value.

Return Value

The flag as a boolean.

Remarks

A query string flag is a parameter whose value is either "1" or "0", e.g. http://www.mysite.net/?myflag=1. The default value is returned if the flag is not present on the query string.

Examples

CopyC#
bool flag = MainUtil.GetRequestFlag("myflag", false);

See Also

MainUtil Class
Sitecore Namespace


GetRequestInt Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GetRequestInt Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int GetRequestInt(
    string sName,
    int nDefault
)
Visual Basic
Public Shared Function GetRequestInt ( _
    sName As String, _
    nDefault As Integer _
) As Integer
Visual C++
public:
static int GetRequestInt(
    String^ sName,
    int nDefault
)

Parameters

sName
Type: System..::..String
The name of the query string parameter.
nDefault
Type: System..::..Int32
A default value.

Return Value

The flag as an integer.

Remarks

The default value is returned if the flag is not present on the query string.

Examples

CopyC#
int val = MainUtil.GetRequestInt("myparameter", 0);

See Also

MainUtil Class
Sitecore Namespace


GetSequencer Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GetSequencer Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int GetSequencer()
Visual Basic
Public Shared Function GetSequencer As Integer
Visual C++
public:
static int GetSequencer()

Return Value

An integer value.

Remarks

This function is threadsafe and can be used to generate serial numbers. The sequencer is incremented before the value is returned. The value is unique for the duration of the ASP.NET process lifetime.

See Also

MainUtil Class
Sitecore Namespace
MainUtil..::..GetNextSequence()()()()


GetSingleton(T) Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GetSingleton<(Of <(<'T>)>)> Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static T GetSingleton<T>(
    ref T instance,
    Func<T> createInstance
)
where T : class
Visual Basic
Public Shared Function GetSingleton(Of T As Class) ( _
    ByRef instance As T, _
    createInstance As Func(Of T) _
) As T
Visual C++
public:
generic<typename T>
where T : ref class
static T GetSingleton(
    T% instance,
    Func<T>^ createInstance
)

Parameters

instance
Type: T%
The instance.
createInstance
Type: System..::..Func <(Of <(<'T>)>)>
A delegate that can be used to create an instance of the object.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Sitecore.MainUtil.GetSingleton``1(``0@,System.Func{``0})"]

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.GetSingleton``1(``0@,System.Func{``0})"]

See Also

MainUtil Class
Sitecore Namespace


GetSortKey Method

[image] [image]

Sitecore 6.4.1 API
MainUtil..::..GetSortKey Method
MainUtil Class See Also Send Feedback

Overload List

Name | Description
GetSortKey(String) | Generates a unique sort key.
GetSortKey(String, String) | Generates a unique sort key.

See Also

MainUtil Class
MainUtil Members
Sitecore Namespace


GetSortKey Method (String)

[image]

Sitecore 6.4.1 API
MainUtil..::..GetSortKey Method (String)
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetSortKey(
    string name
)
Visual Basic
Public Shared Function GetSortKey ( _
    name As String _
) As String
Visual C++
public:
static String^ GetSortKey(
    String^ name
)

Parameters

name
Type: System..::..String
A sort key.

Return Value

A padded sort key.

Remarks

The sort order key of items needs to be padded in order to be sorted correctly. Furthermore items that start with double underscores "__" should come last. This function creates such a padded sort key.

See Also

MainUtil Class
GetSortKey Overload
Sitecore Namespace


GetSortKey Method (String, String)

[image]

Sitecore 6.4.1 API
MainUtil..::..GetSortKey Method (String, String)
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetSortKey(
    string name,
    string sortorder
)
Visual Basic
Public Shared Function GetSortKey ( _
    name As String, _
    sortorder As String _
) As String
Visual C++
public:
static String^ GetSortKey(
    String^ name,
    String^ sortorder
)

Parameters

name
Type: System..::..String
A sort key.
sortorder
Type: System..::..String
A sort order key.

Return Value

A padded sort key.

Remarks

The sort order key of items needs to be padded in order to be sorted correctly. Furthermore items that start with double underscores "__" should come last. This function creates such a padded sort key.

See Also

MainUtil Class
GetSortKey Overload
Sitecore Namespace


GetSpacer Method

[image] [image]

Sitecore 6.4.1 API
MainUtil..::..GetSpacer Method
MainUtil Class See Also Send Feedback

Overload List

Name | Description
GetSpacer(Int32, Int32) | Obsolete. Gets an image HTML tag with a blank image.
GetSpacer(Int32, Int32, Boolean) | Obsolete. Gets an image HTML tag with a blank image.

See Also

MainUtil Class
MainUtil Members
Sitecore Namespace


GetSpacer Method (Int32, Int32)

[image]

Sitecore 6.4.1 API
MainUtil..::..GetSpacer Method (Int32, Int32)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use Sitecore.Resources.Images.GetSpacer() instead")]
public static string GetSpacer(
    int width,
    int height
)
Visual Basic
<ObsoleteAttribute("Use Sitecore.Resources.Images.GetSpacer() instead")> _
Public Shared Function GetSpacer ( _
    width As Integer, _
    height As Integer _
) As String
Visual C++
[ObsoleteAttribute(L"Use Sitecore.Resources.Images.GetSpacer() instead")]
public:
static String^ GetSpacer(
    int width,
    int height
)

Parameters

width
Type: System..::..Int32
Width of the image.
height
Type: System..::..Int32
Height of the image.

Return Value

The image HTML tag.

Examples

CopyC#
string spacer = Images.GetSpacer(10, 10); // <img src="/sitecore/images/blank.gif" border="0" height="10" width="10">

See Also

MainUtil Class
GetSpacer Overload
Sitecore Namespace


GetSpacer Method (Int32, Int32, Boolean)

[image]

Sitecore 6.4.1 API
MainUtil..::..GetSpacer Method (Int32, Int32, Boolean)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use Sitecore.Resources.Images.GetSpacer() instead")]
public static string GetSpacer(
    int width,
    int height,
    bool verticalCenter
)
Visual Basic
<ObsoleteAttribute("Use Sitecore.Resources.Images.GetSpacer() instead")> _
Public Shared Function GetSpacer ( _
    width As Integer, _
    height As Integer, _
    verticalCenter As Boolean _
) As String
Visual C++
[ObsoleteAttribute(L"Use Sitecore.Resources.Images.GetSpacer() instead")]
public:
static String^ GetSpacer(
    int width,
    int height,
    bool verticalCenter
)

Parameters

width
Type: System..::..Int32
Width of the image.
height
Type: System..::..Int32
Height of the image.
verticalCenter
Type: System..::..Boolean
Indicates if the image is centered vertically.

Return Value

The image HTML tag.

Examples

CopyC#
string spacer = Images.GetSpacer(10, 10, true); // <img src="/sitecore/images/blank.gif" border="0" height="10" width="10" style="vertical-align: middle;">

See Also

MainUtil Class
GetSpacer Overload
Sitecore Namespace


GetString Method (Object)

[image]

Sitecore 6.4.1 API
MainUtil..::..GetString Method (Object)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Please use StringUtil.GetString", false)]
public static string GetString(
    Object value
)
Visual Basic
<ObsoleteAttribute("Please use StringUtil.GetString", False)> _
Public Shared Function GetString ( _
    value As Object _
) As String
Visual C++
[ObsoleteAttribute(L"Please use StringUtil.GetString", false)]
public:
static String^ GetString(
    Object^ value
)

Parameters

value
Type: System..::..Object
An object.

Return Value

The string value of the object or blank if the object is null.

Examples

CopyC#
string s0 = StringUtil.GetString(myObject);
string s1 = StringUtil.GetString(Request.QueryString["id"]);

See Also

MainUtil Class
GetString Overload
Sitecore Namespace


GetString Method (Object, String)

[image]

Sitecore 6.4.1 API
MainUtil..::..GetString Method (Object, String)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Please use StringUtil.GetString", false)]
public static string GetString(
    Object value,
    string defaultValue
)
Visual Basic
<ObsoleteAttribute("Please use StringUtil.GetString", False)> _
Public Shared Function GetString ( _
    value As Object, _
    defaultValue As String _
) As String
Visual C++
[ObsoleteAttribute(L"Please use StringUtil.GetString", false)]
public:
static String^ GetString(
    Object^ value,
    String^ defaultValue
)

Parameters

value
Type: System..::..Object
An object.
defaultValue
Type: System..::..String
A default value

Return Value

The string value of the object or the default value if the object is null.

Examples

CopyC#
string s0 = StringUtil.GetString(myObject, "");
string s1 = StringUtil.GetString(Request.QueryString["id"], "");

See Also

MainUtil Class
GetString Overload
Sitecore Namespace


GetStringList Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GetStringList Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ArrayList GetStringList(
    bool allowEmptyStrings,
    params string[] strings
)
Visual Basic
Public Shared Function GetStringList ( _
    allowEmptyStrings As Boolean, _
    ParamArray strings As String() _
) As ArrayList
Visual C++
public:
static ArrayList^ GetStringList(
    bool allowEmptyStrings,
    ... array<String^>^ strings
)

Parameters

allowEmptyStrings
Type: System..::..Boolean
Indicates if empty strings are added to the array.
strings
Type: array< System..::..String >[]()[][]
Strings

Return Value

An array list of the strings.

Examples

CopyC#
ArrayList list1 = StringUtil.GetStringList(true, new string[] { "Hello", "", "world"}); // "Hello", "", "world"
ArrayList list2 = StringUtil.GetStringList(false, new string[] { "Hello", "", "world"}); // "Hello", "world"

See Also

MainUtil Class
Sitecore Namespace


GetThreadID Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GetThreadID Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int GetThreadID()
Visual Basic
Public Shared Function GetThreadID As Integer
Visual C++
public:
static int GetThreadID()

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.GetThreadID"]

See Also

MainUtil Class
Sitecore Namespace


GetTickCount Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GetTickCount Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long GetTickCount()
Visual Basic
Public Shared Function GetTickCount As Long
Visual C++
public:
static long long GetTickCount()

Return Value

The result.

See Also

MainUtil Class
Sitecore Namespace


GetTicks Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GetTicks Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long GetTicks()
Visual Basic
Public Shared Function GetTicks As Long
Visual C++
public:
static long long GetTicks()

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.GetTicks"]

See Also

MainUtil Class
Sitecore Namespace


GetTristate Method

[image] [image]

Sitecore 6.4.1 API
MainUtil..::..GetTristate Method
MainUtil Class See Also Send Feedback

Overload List

Name | Description
GetTristate(Boolean) | Gets a tristate from a bool.
GetTristate(Object, Tristate) | Gets the tristate.

See Also

MainUtil Class
MainUtil Members
Sitecore Namespace


GetTristate Method (Boolean)

[image]

Sitecore 6.4.1 API
MainUtil..::..GetTristate Method (Boolean)
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Tristate GetTristate(
    bool condition
)
Visual Basic
Public Shared Function GetTristate ( _
    condition As Boolean _
) As Tristate
Visual C++
public:
static Tristate GetTristate(
    bool condition
)

Parameters

condition
Type: System..::..Boolean
if set to true [condition].

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.GetTristate(System.Boolean)"]

See Also

MainUtil Class
GetTristate Overload
Sitecore Namespace


GetTristate Method (Object, Tristate)

[image]

Sitecore 6.4.1 API
MainUtil..::..GetTristate Method (Object, Tristate)
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Tristate GetTristate(
    Object value,
    Tristate defaultValue
)
Visual Basic
Public Shared Function GetTristate ( _
    value As Object, _
    defaultValue As Tristate _
) As Tristate
Visual C++
public:
static Tristate GetTristate(
    Object^ value,
    Tristate defaultValue
)

Parameters

value
Type: System..::..Object
The value.
defaultValue
Type: Sitecore..::..Tristate
The default value.

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.GetTristate(System.Object,Sitecore.Tristate)"]

See Also

MainUtil Class
GetTristate Overload
Sitecore Namespace


GetUniqueID Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GetUniqueID Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetUniqueID()
Visual Basic
Public Shared Function GetUniqueID As String
Visual C++
public:
static String^ GetUniqueID()

Return Value

A unique ID as a string.

Examples

CopyC#
string id = MainUtil.GetUniqueID();

See Also

MainUtil Class
Sitecore Namespace


GetWebItemSource Method

[image] [image]

Sitecore 6.4.1 API
MainUtil..::..GetWebItemSource Method
MainUtil Class See Also Send Feedback

Overload List

Name | Description
GetWebItemSource()()()() | Gets the web item data source from the query string.
GetWebItemSource(String) | Gets the web item data source from the query string.

See Also

MainUtil Class
MainUtil Members
Sitecore Namespace


GetWebItemSource Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GetWebItemSource Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetWebItemSource()
Visual Basic
Public Shared Function GetWebItemSource As String
Visual C++
public:
static String^ GetWebItemSource()

Return Value

The value of the path parameter on the query string.

Remarks

If the query string does not contain a parameter named path, blank is returned.

Examples

CopyC#
string path = MainUtil.GetWebItemSource();
if (path != "") {
IWebItem item = WebFactory.GetItem(path);
}

See Also

MainUtil Class
GetWebItemSource Overload
Sitecore Namespace


GetWebItemSource Method (String)

[image]

Sitecore 6.4.1 API
MainUtil..::..GetWebItemSource Method (String)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetWebItemSource(
    string sDefault
)
Visual Basic
Public Shared Function GetWebItemSource ( _
    sDefault As String _
) As String
Visual C++
public:
static String^ GetWebItemSource(
    String^ sDefault
)

Parameters

sDefault
Type: System..::..String
A default path.

Return Value

The value of the path parameter on the query string.

Remarks

If the query string does not contain a parameter named path, the default value is returned.

Examples

CopyC#
string path = MainUtil.GetWebItemSource("/Home");
IWebItem item = WebFactory.GetItem(path);

See Also

MainUtil Class
GetWebItemSource Overload
Sitecore Namespace


GetWord Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GetWord Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetWord(
    string text,
    int index,
    params char[] separators
)
Visual Basic
Public Shared Function GetWord ( _
    text As String, _
    index As Integer, _
    ParamArray separators As Char() _
) As String
Visual C++
public:
static String^ GetWord(
    String^ text,
    int index,
    ... array<wchar_t>^ separators
)

Parameters

text
Type: System..::..String
A string.
index
Type: System..::..Int32
A index.
separators
Type: array< System..::..Char >[]()[][]
Separators.

Return Value

The word ar the n'th position.

Remarks

The first word has index zero (0).

Examples

CopyC#
string myWord = MainUtil.GetWord("Welcome to my world", 2, ' '); // "my"

See Also

MainUtil Class
Sitecore Namespace


GetWorkFileName Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GetWorkFileName Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetWorkFileName(
    string folder,
    string prefix,
    string extension
)
Visual Basic
Public Shared Function GetWorkFileName ( _
    folder As String, _
    prefix As String, _
    extension As String _
) As String
Visual C++
public:
static String^ GetWorkFileName(
    String^ folder,
    String^ prefix,
    String^ extension
)

Parameters

folder
Type: System..::..String
The folder of a file.
prefix
Type: System..::..String
The file prefix of a file (usually the filename itself).
extension
Type: System..::..String
The extension of a file.

Return Value

The unique filename.

Remarks

This function is deprecated - please use FileUtil.GetWorkFileName instead.

See Also

MainUtil Class
Sitecore Namespace


GetWorkingSetSize Method

[image]

Sitecore 6.4.1 API
MainUtil..::..GetWorkingSetSize Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int GetWorkingSetSize()
Visual Basic
Public Shared Function GetWorkingSetSize As Integer
Visual C++
public:
static int GetWorkingSetSize()

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.GetWorkingSetSize"]

See Also

MainUtil Class
Sitecore Namespace


GuidToString Method

[image] [image]

Sitecore 6.4.1 API
MainUtil..::..GuidToString Method
MainUtil Class See Also Send Feedback

Overload List

Name | Description
GuidToString(Guid) | Converts guid to string.
GuidToString(Guid, String) | Converts guid to string.

See Also

MainUtil Class
MainUtil Members
Sitecore Namespace


GuidToString Method (Guid)

[image]

Sitecore 6.4.1 API
MainUtil..::..GuidToString Method (Guid)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GuidToString(
    Guid guid
)
Visual Basic
Public Shared Function GuidToString ( _
    guid As Guid _
) As String
Visual C++
public:
static String^ GuidToString(
    Guid guid
)

Parameters

guid
Type: System..::..Guid
A guid.

Return Value

The guid as a string with the format "{XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX}".

Examples

CopyC#
string s = MainUtil.GuidToString(Guids.Null); // "{00000000-0000-0000-0000-000000000000}"

See Also

MainUtil Class
GuidToString Overload
Sitecore Namespace


GuidToString Method (Guid, String)

[image]

Sitecore 6.4.1 API
MainUtil..::..GuidToString Method (Guid, String)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GuidToString(
    Guid guid,
    string defaultValue
)
Visual Basic
Public Shared Function GuidToString ( _
    guid As Guid, _
    defaultValue As String _
) As String
Visual C++
public:
static String^ GuidToString(
    Guid guid,
    String^ defaultValue
)

Parameters

guid
Type: System..::..Guid
A guid.
defaultValue
Type: System..::..String
The _default.

Return Value

The guid as a string with the format "{XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX}".

Examples

CopyC#
string s = MainUtil.GuidToString(Guids.Null); // "{00000000-0000-0000-0000-000000000000}"

See Also

MainUtil Class
GuidToString Overload
Sitecore Namespace


HexToColor Method

[image]

Sitecore 6.4.1 API
MainUtil..::..HexToColor Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Color HexToColor(
    string value
)
Visual Basic
Public Shared Function HexToColor ( _
    value As String _
) As Color
Visual C++
public:
static Color HexToColor(
    String^ value
)

Parameters

value
Type: System..::..String
The hex string.

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.HexToColor(System.String)"]

Remarks

Translates a html hexadecimal definition of a color into a .NET Framework Color. The input string must start with a '#' character and be followed by 6 hexadecimal digits. The digits A-F are not case sensitive. If the conversion was not successfull the color white will be returned.

See Also

MainUtil Class
Sitecore Namespace


HexToInt Method

[image]

Sitecore 6.4.1 API
MainUtil..::..HexToInt Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int HexToInt(
    string hex,
    int defaultValue
)
Visual Basic
Public Shared Function HexToInt ( _
    hex As String, _
    defaultValue As Integer _
) As Integer
Visual C++
public:
static int HexToInt(
    String^ hex,
    int defaultValue
)

Parameters

hex
Type: System..::..String
The hex.
defaultValue
Type: System..::..Int32
The default value.

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.HexToInt(System.String,System.Int32)"]

Remarks

This method converts a hexvalues string as 80FF into a integer. Note that you may not put a '#' at the beginning of string! There is not much error checking in this method. If the string does not represent a valid hexadecimal value it returns 0.

See Also

MainUtil Class
Sitecore Namespace


Html Method

[image]

Sitecore 6.4.1 API
MainUtil..::..Html Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Html(
    string text
)
Visual Basic
Public Shared Sub Html ( _
    text As String _
)
Visual C++
public:
static void Html(
    String^ text
)

Parameters

text
Type: System..::..String
An HTML string.

Remarks

The string is outputted to the Response followed by a trailing <br> tag. The stream is flushed afterwards.

Examples

CopyC#
MainUtil.Html("Hello world");

See Also

MainUtil Class
Sitecore Namespace
MainUtil..::..Out(String)


Ignore Method

[image]

Sitecore 6.4.1 API
MainUtil..::..Ignore Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Ignore(
    params Object[] thingsToIgnore
)
Visual Basic
Public Shared Sub Ignore ( _
    ParamArray thingsToIgnore As Object() _
)
Visual C++
public:
static void Ignore(
    ... array<Object^>^ thingsToIgnore
)

Parameters

thingsToIgnore
Type: array< System..::..Object >[]()[][]
The things to ignore.

See Also

MainUtil Class
Sitecore Namespace


IndexOf Method

[image]

Sitecore 6.4.1 API
MainUtil..::..IndexOf Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int IndexOf(
    Object obj,
    Object[] objects
)
Visual Basic
Public Shared Function IndexOf ( _
    obj As Object, _
    objects As Object() _
) As Integer
Visual C++
public:
static int IndexOf(
    Object^ obj,
    array<Object^>^ objects
)

Parameters

obj
Type: System..::..Object
An object to be found.
objects
Type: array< System..::..Object >[]()[][]
An array of objects.

Return Value

The index of the object in the array. If not found, -1 is returned.

Remarks

This function performs a linear scan of the array to find the object.

Examples

CopyC#
object myObject = new object();
object[] objects = new object[] { 0, 1, myObject, 3, 4 };
int index = MainUtil.IndexOf(myObject, objects); // 2

See Also

MainUtil Class
Sitecore Namespace


IntToHex Method

[image]

Sitecore 6.4.1 API
MainUtil..::..IntToHex Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string IntToHex(
    int integer
)
Visual Basic
Public Shared Function IntToHex ( _
    integer As Integer _
) As String
Visual C++
public:
static String^ IntToHex(
    int integer
)

Parameters

integer
Type: System..::..Int32
The integer.

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.IntToHex(System.Int32)"]

See Also

MainUtil Class
Sitecore Namespace


IsBitSet Method

[image]

Sitecore 6.4.1 API
MainUtil..::..IsBitSet Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsBitSet(
    int bit,
    int bits
)
Visual Basic
Public Shared Function IsBitSet ( _
    bit As Integer, _
    bits As Integer _
) As Boolean
Visual C++
public:
static bool IsBitSet(
    int bit,
    int bits
)

Parameters

bit
Type: System..::..Int32
The bit.
bits
Type: System..::..Int32
The bits.

Return Value

true if the specified bit is set; otherwise, false.

See Also

MainUtil Class
Sitecore Namespace


IsEmpty Method

[image]

Sitecore 6.4.1 API
MainUtil..::..IsEmpty Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsEmpty(
    string s
)
Visual Basic
Public Shared Function IsEmpty ( _
    s As String _
) As Boolean
Visual C++
public:
static bool IsEmpty(
    String^ s
)

Parameters

s
Type: System..::..String
The s.

Return Value

true if the specified string is empty; otherwise, false.

See Also

MainUtil Class
Sitecore Namespace


IsFullPath Method

[image]

Sitecore 6.4.1 API
MainUtil..::..IsFullPath Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsFullPath(
    string path
)
Visual Basic
Public Shared Function IsFullPath ( _
    path As String _
) As Boolean
Visual C++
public:
static bool IsFullPath(
    String^ path
)

Parameters

path
Type: System..::..String
The path.

Return Value

true if the specified path is a full path; otherwise, false.

See Also

MainUtil Class
Sitecore Namespace


IsID Method

[image]

Sitecore 6.4.1 API
MainUtil..::..IsID Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsID(
    string id
)
Visual Basic
Public Shared Function IsID ( _
    id As String _
) As Boolean
Visual C++
public:
static bool IsID(
    String^ id
)

Parameters

id
Type: System..::..String
A string.

Return Value

True, if the string is a GUID, otherwise false.

Remarks

The function checks that the length of the string id, starts with a starting brace ({) and ends with closing brace (}).

Examples

CopyC#
string id = StringUtil.GetString(Request.QueryString["id"]);
if (MainUtil.IsID(id)) {
IMasterItem item = MasterFactory.GetItem(id);
}

See Also

MainUtil Class
Sitecore Namespace


IsType Method

[image] [image]

Sitecore 6.4.1 API
MainUtil..::..IsType Method
MainUtil Class See Also Send Feedback

Overload List

Name | Description
IsType(Object, Type) | Checks if an object is of a given type
IsType(Type, Type) | Checks if an object is of a given type

See Also

MainUtil Class
MainUtil Members
Sitecore Namespace


IsType Method (Type, Type)

[image]

Sitecore 6.4.1 API
MainUtil..::..IsType Method (Type, Type)
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsType(
    Type objType,
    Type ancestorType
)
Visual Basic
Public Shared Function IsType ( _
    objType As Type, _
    ancestorType As Type _
) As Boolean
Visual C++
public:
static bool IsType(
    Type^ objType,
    Type^ ancestorType
)

Parameters

objType
Type: System..::..Type
Type of the obj.
ancestorType
Type: System..::..Type
Type of the ancestor.

Return Value

True if the object is of the type, otherwise false.

Remarks

This function is analog to the "is" operator.

The function performs the following checks:

  1. Is the type of object equivalent to the type.
  2. Is the object a subclass of the type.
  3. If the type is an interface, does the object implement it.

See Also

MainUtil Class
IsType Overload
Sitecore Namespace


IsXPath Method

[image]

Sitecore 6.4.1 API
MainUtil..::..IsXPath Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsXPath(
    string path
)
Visual Basic
Public Shared Function IsXPath ( _
    path As String _
) As Boolean
Visual C++
public:
static bool IsXPath(
    String^ path
)

Parameters

path
Type: System..::..String
A string, possiblyh containing an XPath expression.

Return Value

True, if the string contains an XPath expression, otherwise false.

Remarks

This function can be used to differentiate between Sitecore paths and XPath expressions. A path is considered an XPaath expression if it contains "item[" or "::item".

Examples

CopyC#
bool b0 = MainUtil.IsXPath("/item[@key='sitecore']/item[@key='content']"); // true
bool b1 = MainUtil.IsXPath("/sitecore/content"); // false

See Also

MainUtil Class
Sitecore Namespace


Join Method

[image] [image]

Sitecore 6.4.1 API
MainUtil..::..Join Method
MainUtil Class See Also Send Feedback

Overload List

Name | Description
Join(String, array<String>[]()[][]) | Joins an array of strings excluding any empty string from the result.
Join(String, String, String) | Joins two strings excluding any empty string from the result.

See Also

MainUtil Class
MainUtil Members
Sitecore Namespace


Join Method (String, String[])

[image]

Sitecore 6.4.1 API
MainUtil..::..Join Method (String, array<String>[]()[][])
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Join(
    string sSeparator,
    string[] values
)
Visual Basic
Public Shared Function Join ( _
    sSeparator As String, _
    values As String() _
) As String
Visual C++
public:
static String^ Join(
    String^ sSeparator,
    array<String^>^ values
)

Parameters

sSeparator
Type: System..::..String
A separator string.
values
Type: array< System..::..String >[]()[][]
Strings

Return Value

The concatenated strings with the separator in between.

Examples

CopyC#
string s0 = MainUtil.Join(",", "Hello", " ", "world"); // "Hello,world"

See Also

MainUtil Class
Join Overload
Sitecore Namespace


Join Method (String, String, String)

[image]

Sitecore 6.4.1 API
MainUtil..::..Join Method (String, String, String)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Join(
    string sSeparator,
    string s1,
    string s2
)
Visual Basic
Public Shared Function Join ( _
    sSeparator As String, _
    s1 As String, _
    s2 As String _
) As String
Visual C++
public:
static String^ Join(
    String^ sSeparator,
    String^ s1,
    String^ s2
)

Parameters

sSeparator
Type: System..::..String
A separator string.
s1
Type: System..::..String
A string.
s2
Type: System..::..String
A string.

Return Value

The two string with the separator in between.

Examples

CopyC#
string s0 = MainUtil.Join(" ", "Hello", "world"); // "Hello world"
string s1 = MainUtil.Join(",", "Hello", " ", "world"); // "Hello,world"

See Also

MainUtil Class
Join Overload
Sitecore Namespace


MakeFilePath Method

[image] [image]

Sitecore 6.4.1 API
MainUtil..::..MakeFilePath Method
MainUtil Class See Also Send Feedback

Overload List

Name | Description
MakeFilePath(String, String) | Builds a file path from a folder and a file.
MakeFilePath(String, String, Boolean) | Builds a file path from a folder and a file.

See Also

MainUtil Class
MainUtil Members
Sitecore Namespace


MakeFilePath Method (String, String)

[image]

Sitecore 6.4.1 API
MainUtil..::..MakeFilePath Method (String, String)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string MakeFilePath(
    string folder,
    string file
)
Visual Basic
Public Shared Function MakeFilePath ( _
    folder As String, _
    file As String _
) As String
Visual C++
public:
static String^ MakeFilePath(
    String^ folder,
    String^ file
)

Parameters

folder
Type: System..::..String
A folder path.
file
Type: System..::..String
A file name.

Return Value

A file path.

Remarks

If the folder path does not end with a backslash (\), it is appended.

Examples

CopyC#
string filename = FileUtil.MakePath("c:\sitecore\client\images", "images.gif");
// c:\sitecore\client\images\images.gif

See Also

MainUtil Class
MakeFilePath Overload
Sitecore Namespace


MakeFilePath Method (String, String, Boolean)

[image]

Sitecore 6.4.1 API
MainUtil..::..MakeFilePath Method (String, String, Boolean)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string MakeFilePath(
    string folder,
    string file,
    bool unique
)
Visual Basic
Public Shared Function MakeFilePath ( _
    folder As String, _
    file As String, _
    unique As Boolean _
) As String
Visual C++
public:
static String^ MakeFilePath(
    String^ folder,
    String^ file,
    bool unique
)

Parameters

folder
Type: System..::..String
A folder path.
file
Type: System..::..String
A file name.
unique
Type: System..::..Boolean
A flag indicating that the file should be unique in the folder.

Return Value

A file path.

Remarks

If the folder path does not end with a backslash (\), it is appended.

If unique is true, a serial number is appended to the filename. This serial number is incremented until a file with that name does not exist in the folder.

Examples

CopyC#
string filename = FileUtil.MakePath("c:\sitecore\client\images", "images.gif");
// c:\sitecore\client\images\images_001.gif

See Also

MainUtil Class
MakeFilePath Overload
Sitecore Namespace


MakePath Method

[image]

Sitecore 6.4.1 API
MainUtil..::..MakePath Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Please use FileUtil.MakePath", false)]
public static string MakePath(
    string part1,
    string part2,
    char separator
)
Visual Basic
<ObsoleteAttribute("Please use FileUtil.MakePath", False)> _
Public Shared Function MakePath ( _
    part1 As String, _
    part2 As String, _
    separator As Char _
) As String
Visual C++
[ObsoleteAttribute(L"Please use FileUtil.MakePath", false)]
public:
static String^ MakePath(
    String^ part1,
    String^ part2,
    wchar_t separator
)

Parameters

part1
Type: System..::..String
The first part of the filename.
part2
Type: System..::..String
The second part of the filename.
separator
Type: System..::..Char
A separator character.

Return Value

The two parts concatenated with the separator in between.

Remarks

This function is deprecated - please use FileUtil.MakePath instead.

See Also

MainUtil Class
Sitecore Namespace


MapPath Method

[image]

Sitecore 6.4.1 API
MainUtil..::..MapPath Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string MapPath(
    string path
)
Visual Basic
Public Shared Function MapPath ( _
    path As String _
) As String
Visual C++
public:
static String^ MapPath(
    String^ path
)

Parameters

path
Type: System..::..String
A virtual file path.

Return Value

The physical file path.

Remarks

This function is deprecated - please use FileUtil.MapPath instead.

See Also

MainUtil Class
Sitecore Namespace


MsgBox Method (String)

[image]

Sitecore 6.4.1 API
MainUtil..::..MsgBox Method (String)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void MsgBox(
    string message
)
Visual Basic
Public Shared Sub MsgBox ( _
    message As String _
)
Visual C++
public:
static void MsgBox(
    String^ message
)

Parameters

message
Type: System..::..String
A string containing a message.

Examples

CopyC#
MainUtil.MsgBox("Hello world");

See Also

MainUtil Class
MsgBox Overload
Sitecore Namespace
System.Windows.Forms..::..MessageBox


MsgBox Method (String, String)

[image]

Sitecore 6.4.1 API
MainUtil..::..MsgBox Method (String, String)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void MsgBox(
    string message,
    string caption
)
Visual Basic
Public Shared Sub MsgBox ( _
    message As String, _
    caption As String _
)
Visual C++
public:
static void MsgBox(
    String^ message,
    String^ caption
)

Parameters

message
Type: System..::..String
A string containing a message.
caption
Type: System..::..String
A string containing the caption of the box.

Examples

CopyC#
MainUtil.MsgBox("Hello world", "Sitecore");

See Also

MainUtil Class
MsgBox Overload
Sitecore Namespace
System.Windows.Forms..::..MessageBox


Nop Method

[image]

Sitecore 6.4.1 API
MainUtil..::..Nop Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Nop(
    params Object[] obj
)
Visual Basic
Public Shared Sub Nop ( _
    ParamArray obj As Object() _
)
Visual C++
public:
static void Nop(
    ... array<Object^>^ obj
)

Parameters

obj
Type: array< System..::..Object >[]()[][]

[Missing <param name="obj"/> documentation for "M:Sitecore.MainUtil.Nop(System.Object[])"]

See Also

MainUtil Class
Sitecore Namespace


NormalizeGuid Method

[image] [image]

Sitecore 6.4.1 API
MainUtil..::..NormalizeGuid Method
MainUtil Class See Also Send Feedback

Overload List

Name | Description
NormalizeGuid(Guid) | Normalizes a GUID.
NormalizeGuid(String) | Normalizes a GUID.

See Also

MainUtil Class
MainUtil Members
Sitecore Namespace


NormalizeGuid Method (Guid)

[image]

Sitecore 6.4.1 API
MainUtil..::..NormalizeGuid Method (Guid)
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string NormalizeGuid(
    Guid guid
)
Visual Basic
Public Shared Function NormalizeGuid ( _
    guid As Guid _
) As String
Visual C++
public:
static String^ NormalizeGuid(
    Guid guid
)

Parameters

guid
Type: System..::..Guid
A GUID.

Return Value

A GUID string in a normalized format.

Remarks

A normalized GUID is uppercased, starts with a opening brace ({) and ends with a closing brace (}). GUIDs that originate from an SQL server usually have to normalized.

See Also

MainUtil Class
NormalizeGuid Overload
Sitecore Namespace


NormalizeGuid Method (String)

[image]

Sitecore 6.4.1 API
MainUtil..::..NormalizeGuid Method (String)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string NormalizeGuid(
    string guid
)
Visual Basic
Public Shared Function NormalizeGuid ( _
    guid As String _
) As String
Visual C++
public:
static String^ NormalizeGuid(
    String^ guid
)

Parameters

guid
Type: System..::..String
A string contaning a GUID..

Return Value

A GUID string in a normalized format.

Remarks

A normalized GUID is uppercased, starts with a opening brace ({) and ends with a closing brace (}). GUIDs that originate from an SQL server usually have to normalized.

Examples

CopyC#
string id = StringUtil.GetString(Request.QueryString["id"]);
id = MainUtil.NormalizeGuid(id);

See Also

MainUtil Class
NormalizeGuid Overload
Sitecore Namespace


NormalizeItemName Method

[image]

Sitecore 6.4.1 API
MainUtil..::..NormalizeItemName Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string NormalizeItemName(
    string name
)
Visual Basic
Public Shared Function NormalizeItemName ( _
    name As String _
) As String
Visual C++
public:
static String^ NormalizeItemName(
    String^ name
)

Parameters

name
Type: System..::..String
A string contaning an item name.

Return Value

The normalized item name.

Remarks

To work with friendly URLs, an item name must not end with a dot or contain a double quote (").

Examples

CopyC#
string name = MainUtil.NormalizeItemName("MyCorp inc."); // "MyCorp inc"

See Also

MainUtil Class
Sitecore Namespace


Out Method (String)

[image]

Sitecore 6.4.1 API
MainUtil..::..Out Method (String)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Out(
    string text
)
Visual Basic
Public Shared Sub Out ( _
    text As String _
)
Visual C++
public:
static void Out(
    String^ text
)

Parameters

text
Type: System..::..String
A string.

Remarks

The string is outputted to the Response followed by a trailing <br> tag. The stream is flushed afterwards.

Examples

CopyC#
MainUtil.Out("Hello world");

See Also

MainUtil Class
Out Overload
Sitecore Namespace
MainUtil..::..Html(String)


ReadFromFile Method

[image]

Sitecore 6.4.1 API
MainUtil..::..ReadFromFile Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use FileUtil.ReadFromFile instead.")]
public static string ReadFromFile(
    string path
)
Visual Basic
<ObsoleteAttribute("Use FileUtil.ReadFromFile instead.")> _
Public Shared Function ReadFromFile ( _
    path As String _
) As String
Visual C++
[ObsoleteAttribute(L"Use FileUtil.ReadFromFile instead.")]
public:
static String^ ReadFromFile(
    String^ path
)

Parameters

path
Type: System..::..String
A file name.

Return Value

The content of the file.

Remarks

If the file is not found, an exception is written to the trace file and blank is returned.

Examples

CopyC#
string text = MainUtil.ReadFromFile("/robots.txt");

See Also

MainUtil Class
Sitecore Namespace


RemoveEmptyStrings Method

[image]

Sitecore 6.4.1 API
MainUtil..::..RemoveEmptyStrings Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string[] RemoveEmptyStrings(
    string[] values
)
Visual Basic
Public Shared Function RemoveEmptyStrings ( _
    values As String() _
) As String()
Visual C++
public:
static array<String^>^ RemoveEmptyStrings(
    array<String^>^ values
)

Parameters

values
Type: array< System..::..String >[]()[][]
The values.

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.RemoveEmptyStrings(System.String[])"]

See Also

MainUtil Class
Sitecore Namespace


RemoveFromArray Method

[image]

Sitecore 6.4.1 API
MainUtil..::..RemoveFromArray Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void RemoveFromArray(
    Array array,
    int index
)
Visual Basic
Public Shared Sub RemoveFromArray ( _
    array As Array, _
    index As Integer _
)
Visual C++
public:
static void RemoveFromArray(
    Array^ array,
    int index
)

Parameters

array
Type: System..::..Array
The array.
index
Type: System..::..Int32
The index.

See Also

MainUtil Class
Sitecore Namespace


RemoveStart Method

[image]

Sitecore 6.4.1 API
MainUtil..::..RemoveStart Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string RemoveStart(
    string s,
    int count
)
Visual Basic
Public Shared Function RemoveStart ( _
    s As String, _
    count As Integer _
) As String
Visual C++
public:
static String^ RemoveStart(
    String^ s,
    int count
)

Parameters

s
Type: System..::..String
A string.
count
Type: System..::..Int32
The number of characters to remove.

Return Value

The last charcters from the string.

Remarks

If count is greater than the length of the string, blank is returned.

Examples

CopyC#
string text = "Hello world";
string s0 = MainUtil.RemoveStart(text, 6); // "world"

See Also

MainUtil Class
Sitecore Namespace
MainUtil..::..RemoveEnd(String, Int32)


ReplaceItemIDs Method

[image]

Sitecore 6.4.1 API
MainUtil..::..ReplaceItemIDs Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void ReplaceItemIDs(
    XmlDocument doc
)
Visual Basic
Public Shared Sub ReplaceItemIDs ( _
    doc As XmlDocument _
)
Visual C++
public:
static void ReplaceItemIDs(
    XmlDocument^ doc
)

Parameters

doc
Type: System.Xml..::..XmlDocument
An XML document.

Remarks

The function scans the entire document. When it encounters a "item" tag with an "id" attribute, the attribute is replaced with a new GUID.

See Also

MainUtil Class
Sitecore Namespace


ReplacePostfix Method

[image]

Sitecore 6.4.1 API
MainUtil..::..ReplacePostfix Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ReplacePostfix(
    string s,
    string sFind,
    string sReplace
)
Visual Basic
Public Shared Function ReplacePostfix ( _
    s As String, _
    sFind As String, _
    sReplace As String _
) As String
Visual C++
public:
static String^ ReplacePostfix(
    String^ s,
    String^ sFind,
    String^ sReplace
)

Parameters

s
Type: System..::..String
A string.
sFind
Type: System..::..String
The postfix to find.
sReplace
Type: System..::..String
The replacement.

Return Value

A string with the postfix replaced.

Remarks

If the string does not end with the postfix, the string itself is returned.

Examples

CopyC#
string s0 = MainUtil.ReplacePostfix("Hello world", "world", "you"); // "Hello you"
string s1 = MainUtil.ReplacePostfix("Hello world", "you", "me"); // "Hello world"

See Also

MainUtil Class
Sitecore Namespace
MainUtil..::..ReplacePrefix(String, String, String)


ReplacePrefix Method

[image]

Sitecore 6.4.1 API
MainUtil..::..ReplacePrefix Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ReplacePrefix(
    string s,
    string sFind,
    string sReplace
)
Visual Basic
Public Shared Function ReplacePrefix ( _
    s As String, _
    sFind As String, _
    sReplace As String _
) As String
Visual C++
public:
static String^ ReplacePrefix(
    String^ s,
    String^ sFind,
    String^ sReplace
)

Parameters

s
Type: System..::..String
A string.
sFind
Type: System..::..String
The prefix to find.
sReplace
Type: System..::..String
The replacement.

Return Value

A string with the prefix replaced.

Remarks

If the string does not start with the prefix, the string itself is returned.

Examples

CopyC#
string s0 = MainUtil.ReplacePostfix("Hello world", "Hello", "Hi"); // "Hi you"
string s1 = MainUtil.ReplacePostfix("Hello world", "Hi", "Goodday"); // "Hello world"

See Also

MainUtil Class
Sitecore Namespace
MainUtil..::..ReplacePostfix(String, String, String)


SendMail Method

[image] [image]

Sitecore 6.4.1 API
MainUtil..::..SendMail Method
MainUtil Class See Also Send Feedback

Overload List

Name | Description
SendMail(MailMessage) | Sends the mail.
SendMail(MailMessage) | Obsolete. Sends the mail.

See Also

MainUtil Class
MainUtil Members
Sitecore Namespace


SendMail Method (MailMessage)

[image]

Sitecore 6.4.1 API
MainUtil..::..SendMail Method (MailMessage)
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void SendMail(
    MailMessage message
)
Visual Basic
Public Shared Sub SendMail ( _
    message As MailMessage _
)
Visual C++
public:
static void SendMail(
    MailMessage^ message
)

Parameters

message
Type: System.Net.Mail..::..MailMessage
The message.

See Also

MainUtil Class
SendMail Overload
Sitecore Namespace


SendMail Method (MailMessage)

[image]

Sitecore 6.4.1 API
MainUtil..::..SendMail Method (MailMessage)
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use SendMail(System.Net.Mail.MailMessage) instead")]
public static void SendMail(
    MailMessage message
)
Visual Basic
<ObsoleteAttribute("Use SendMail(System.Net.Mail.MailMessage) instead")> _
Public Shared Sub SendMail ( _
    message As MailMessage _
)
Visual C++
[ObsoleteAttribute(L"Use SendMail(System.Net.Mail.MailMessage) instead")]
public:
static void SendMail(
    MailMessage^ message
)

Parameters

message
Type: System.Web.Mail..::..MailMessage
The message.

See Also

MainUtil Class
SendMail Overload
Sitecore Namespace


SetBit Method

[image]

Sitecore 6.4.1 API
MainUtil..::..SetBit Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int SetBit(
    int bit,
    int bits
)
Visual Basic
Public Shared Function SetBit ( _
    bit As Integer, _
    bits As Integer _
) As Integer
Visual C++
public:
static int SetBit(
    int bit,
    int bits
)

Parameters

bit
Type: System..::..Int32
The bit.
bits
Type: System..::..Int32
The bits.

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.SetBit(System.Int32,System.Int32)"]

See Also

MainUtil Class
Sitecore Namespace


ShortenGuid Method

[image]

Sitecore 6.4.1 API
MainUtil..::..ShortenGuid Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ShortenGuid(
    string guid
)
Visual Basic
Public Shared Function ShortenGuid ( _
    guid As String _
) As String
Visual C++
public:
static String^ ShortenGuid(
    String^ guid
)

Parameters

guid
Type: System..::..String
A string containing a GUID.

Return Value

A shortend GUID.

Examples

CopyC#
string shortID = MainUtil.ShortenGuid("{C31EAA4A-0E4B-42C9-B8A9-7AE78EB2A773}");
// "C31EAA4A0E4B42C9B8A97AE78EB2A773"

See Also

MainUtil Class
Sitecore Namespace


ShrinkArray Method

[image] [image]

Sitecore 6.4.1 API
MainUtil..::..ShrinkArray Method
MainUtil Class See Also Send Feedback

Overload List

Name | Description
ShrinkArray(Array, Type) | Shrinks the array.
ShrinkArray(Array, Type, Int32) | Compacts an object array by removing nulls.

See Also

MainUtil Class
MainUtil Members
Sitecore Namespace


ShrinkArray Method (Array, Type)

[image]

Sitecore 6.4.1 API
MainUtil..::..ShrinkArray Method (Array, Type)
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Array ShrinkArray(
    Array array,
    Type elementType
)
Visual Basic
Public Shared Function ShrinkArray ( _
    array As Array, _
    elementType As Type _
) As Array
Visual C++
public:
static Array^ ShrinkArray(
    Array^ array,
    Type^ elementType
)

Parameters

array
Type: System..::..Array
The array.
elementType
Type: System..::..Type
Type of the element.

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.ShrinkArray(System.Array,System.Type)"]

See Also

MainUtil Class
ShrinkArray Overload
Sitecore Namespace


ShrinkArray Method (Array, Type, Int32)

[image]

Sitecore 6.4.1 API
MainUtil..::..ShrinkArray Method (Array, Type, Int32)
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object ShrinkArray(
    Array array,
    Type elementType,
    int newSize
)
Visual Basic
Public Shared Function ShrinkArray ( _
    array As Array, _
    elementType As Type, _
    newSize As Integer _
) As Object
Visual C++
public:
static Object^ ShrinkArray(
    Array^ array,
    Type^ elementType,
    int newSize
)

Parameters

array
Type: System..::..Array
An array of object.
elementType
Type: System..::..Type
Type of the element.
newSize
Type: System..::..Int32
The new size.

Return Value

The compacted array of object.

See Also

MainUtil Class
ShrinkArray Overload
Sitecore Namespace


SilentCatch Method

[image]

Sitecore 6.4.1 API
MainUtil..::..SilentCatch Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void SilentCatch()
Visual Basic
Public Shared Sub SilentCatch
Visual C++
public:
static void SilentCatch()

See Also

MainUtil Class
Sitecore Namespace


Split Method

[image] [image]

Sitecore 6.4.1 API
MainUtil..::..Split Method
MainUtil Class See Also Send Feedback

Overload List

Name | Description
Split(String, Char) | Splits a string into an array of strings.
Split(String, String) | Splits a string into an array of strings.
Split(String, Char, Boolean) | Splits a string into an array of strings.
Split(String, String, Boolean) | Splits a string into an array of strings.

See Also

MainUtil Class
MainUtil Members
Sitecore Namespace


Split Method (String, Char)

[image]

Sitecore 6.4.1 API
MainUtil..::..Split Method (String, Char)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string[] Split(
    string s,
    char separator
)
Visual Basic
Public Shared Function Split ( _
    s As String, _
    separator As Char _
) As String()
Visual C++
public:
static array<String^>^ Split(
    String^ s,
    wchar_t separator
)

Parameters

s
Type: System..::..String
A string.
separator
Type: System..::..Char
A separator.

Return Value

An array of strings.

Remarks

Blank strings are excluded from the array.

Examples

CopyC#
string[] strings = MainUtil.Split("Name1|Value1|Name2||Name3|Value3", '|');
// "Name1", "Value1", "Name2", "Name3", "Value3"
 Please notice that Value2 is missing.

See Also

MainUtil Class
Split Overload
Sitecore Namespace


Split Method (String, String)

[image]

Sitecore 6.4.1 API
MainUtil..::..Split Method (String, String)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string[] Split(
    string s,
    string separator
)
Visual Basic
Public Shared Function Split ( _
    s As String, _
    separator As String _
) As String()
Visual C++
public:
static array<String^>^ Split(
    String^ s,
    String^ separator
)

Parameters

s
Type: System..::..String
A string.
separator
Type: System..::..String
A separator string.

Return Value

An array of strings.

Remarks

Blank strings are excluded from the array.

Examples

CopyC#
string[] strings = MainUtil.Split("Name1|Value1|Name2||Name3|Value3", "|");
// "Name1", "Value1", "Name2", "Name3", "Value3"
 Please notice that Value2 is missing.

See Also

MainUtil Class
Split Overload
Sitecore Namespace


Split Method (String, Char, Boolean)

[image]

Sitecore 6.4.1 API
MainUtil..::..Split Method (String, Char, Boolean)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string[] Split(
    string s,
    char separator,
    bool trim
)
Visual Basic
Public Shared Function Split ( _
    s As String, _
    separator As Char, _
    trim As Boolean _
) As String()
Visual C++
public:
static array<String^>^ Split(
    String^ s,
    wchar_t separator,
    bool trim
)

Parameters

s
Type: System..::..String
A string.
separator
Type: System..::..Char
A separator.
trim
Type: System..::..Boolean
If true, individual parts of the split will be trimmed.

Return Value

An array of strings.

Remarks

Blank strings are excluded from the array.

Examples

CopyC#
string[] strings = MainUtil.Split("Name1|Value1|Name2||Name3|Value3", '|');
// "Name1", "Value1", "Name2", "Name3", "Value3"
 Please notice that Value2 is missing.

See Also

MainUtil Class
Split Overload
Sitecore Namespace


Split Method (String, String, Boolean)

[image]

Sitecore 6.4.1 API
MainUtil..::..Split Method (String, String, Boolean)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string[] Split(
    string s,
    string separator,
    bool trim
)
Visual Basic
Public Shared Function Split ( _
    s As String, _
    separator As String, _
    trim As Boolean _
) As String()
Visual C++
public:
static array<String^>^ Split(
    String^ s,
    String^ separator,
    bool trim
)

Parameters

s
Type: System..::..String
A string.
separator
Type: System..::..String
A separator.
trim
Type: System..::..Boolean
If true, individual parts of the split will be trimmed.

Return Value

An array of strings.

Remarks

Blank strings are excluded from the array.

Examples

CopyC#
string[] strings = MainUtil.Split("Name1|Value1|Name2||Name3|Value3", '|');
// "Name1", "Value1", "Name2", "Name3", "Value3"
 Please notice that Value2 is missing.

See Also

MainUtil Class
Split Overload
Sitecore Namespace


SplitPath Method

[image]

Sitecore 6.4.1 API
MainUtil..::..SplitPath Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string[] SplitPath(
    string path,
    bool expand
)
Visual Basic
Public Shared Function SplitPath ( _
    path As String, _
    expand As Boolean _
) As String()
Visual C++
public:
static array<String^>^ SplitPath(
    String^ path,
    bool expand
)

Parameters

path
Type: System..::..String
A Sitecore path.
expand
Type: System..::..Boolean
Indicates if the path should be expanded into including the root.

Return Value

An array of parts of the path.

Examples

CopyC#
string[] parts = MainUtil.SplitPath("/Home/Menu", false); // "Home", "Menu"
string[] parts = MainUtil.SplitPath("/Home/Menu", true); // "sitecore", "content", "Home", "Menu"

See Also

MainUtil Class
Sitecore Namespace


StringToColor Method

[image]

Sitecore 6.4.1 API
MainUtil..::..StringToColor Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Color StringToColor(
    string color
)
Visual Basic
Public Shared Function StringToColor ( _
    color As String _
) As Color
Visual C++
public:
static Color StringToColor(
    String^ color
)

Parameters

color
Type: System..::..String
The color.

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.StringToColor(System.String)"]

See Also

MainUtil Class
Sitecore Namespace


Substring Method

[image] [image]

Sitecore 6.4.1 API
MainUtil..::..Substring Method
MainUtil Class See Also Send Feedback

Overload List

Name | Description
Substring(String, Int32, Boolean) | Gets a substring of maximum length of a string.
Substring(String, Int32, Int32) | Retrieves a substring from a string. The substring starts at a specified character position and has a specified length.

See Also

MainUtil Class
MainUtil Members
Sitecore Namespace


Substring Method (String, Int32, Boolean)

[image]

Sitecore 6.4.1 API
MainUtil..::..Substring Method (String, Int32, Boolean)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Substring(
    string value,
    int max,
    bool dots
)
Visual Basic
Public Shared Function Substring ( _
    value As String, _
    max As Integer, _
    dots As Boolean _
) As String
Visual C++
public:
static String^ Substring(
    String^ value,
    int max,
    bool dots
)

Parameters

value
Type: System..::..String
A string.
max
Type: System..::..Int32
The number of characters in the substring.
dots
Type: System..::..Boolean
If true, three dots are appended to the substring.

Return Value

A subtring starting at zero and ending a max characters of the string.

Remarks

No exception is thrown if max is greater than the length of the string.

Examples

CopyC#
string text = MainUtil.Substring("Hello world", 6, true); // "Hel..."
string text = MainUtil.Substring("Hello world", 6, false); // "Hello "

See Also

MainUtil Class
Substring Overload
Sitecore Namespace


Substring Method (String, Int32, Int32)

[image]

Sitecore 6.4.1 API
MainUtil..::..Substring Method (String, Int32, Int32)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Substring(
    string value,
    int start,
    int length
)
Visual Basic
Public Shared Function Substring ( _
    value As String, _
    start As Integer, _
    length As Integer _
) As String
Visual C++
public:
static String^ Substring(
    String^ value,
    int start,
    int length
)

Parameters

value
Type: System..::..String
A string.
start
Type: System..::..Int32
The index of the start of the substring.
length
Type: System..::..Int32
The number of characters in the substring.

Return Value

A String equivalent to the substring of length length that begins at start in the string.

Remarks

No exception is thrown if length is greater than the length of the string.

Examples

CopyC#
string text = MainUtil.Substring("Hello world", 6, 100); // "world"
string text = MainUtil.Substring("Hello world", 2, 3); // "llo"

See Also

MainUtil Class
Substring Overload
Sitecore Namespace


TerminateAspNet Method

[image] [image]

Sitecore 6.4.1 API
MainUtil..::..TerminateAspNet Method
MainUtil Class See Also Send Feedback

Overload List

Name | Description
TerminateAspNet()()()() | Terminates the ASP.NET worker process.
TerminateAspNet(String) | Terminates the ASP.NET worker process.

See Also

MainUtil Class
MainUtil Members
Sitecore Namespace


TerminateAspNet Method (String)

[image]

Sitecore 6.4.1 API
MainUtil..::..TerminateAspNet Method (String)
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void TerminateAspNet(
    string message
)
Visual Basic
Public Shared Sub TerminateAspNet ( _
    message As String _
)
Visual C++
public:
static void TerminateAspNet(
    String^ message
)

Parameters

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:Sitecore.MainUtil.TerminateAspNet(System.String)"]

See Also

MainUtil Class
TerminateAspNet Overload
Sitecore Namespace


ThemedImage Method

[image] [image]

Sitecore 6.4.1 API
MainUtil..::..ThemedImage Method
MainUtil Class See Also Send Feedback

Overload List

Name | Description
ThemedImage(String) | Gets a themed image path.
ThemedImage(String, ImageDimension) | Gets a themed image path.

See Also

MainUtil Class
MainUtil Members
Sitecore Namespace


Touch Method

[image]

Sitecore 6.4.1 API
MainUtil..::..Touch Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Touch(
    params Object[] obj
)
Visual Basic
Public Shared Sub Touch ( _
    ParamArray obj As Object() _
)
Visual C++
public:
static void Touch(
    ... array<Object^>^ obj
)

Parameters

obj
Type: array< System..::..Object >[]()[][]

[Missing <param name="obj"/> documentation for "M:Sitecore.MainUtil.Touch(System.Object[])"]

See Also

MainUtil Class
Sitecore Namespace


Trace Method

[image]

Sitecore 6.4.1 API
MainUtil..::..Trace Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Trace(
    string message
)
Visual Basic
Public Shared Sub Trace ( _
    message As String _
)
Visual C++
public:
static void Trace(
    String^ message
)

Parameters

message
Type: System..::..String
A message string.

Remarks

The message is written both to the Sitecore trace and to the current context trace.

Examples

CopyC#
MainUtil.Trace("Point of no return reached.");

See Also

MainUtil Class
Sitecore Namespace
HttpContext..::..Trace


TraceIf Method

[image]

Sitecore 6.4.1 API
MainUtil..::..TraceIf Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void TraceIf(
    bool condition,
    string message
)
Visual Basic
Public Shared Sub TraceIf ( _
    condition As Boolean, _
    message As String _
)
Visual C++
public:
static void TraceIf(
    bool condition,
    String^ message
)

Parameters

condition
Type: System..::..Boolean
A boolean condition.
message
Type: System..::..String
A message string.

Remarks

The message is only written if condition is true.

The message is written both to the Sitecore trace and to the current context trace.

Examples

CopyC#
MainUtil.Trace(true, "Point of no return reached.");

See Also

MainUtil Class
Sitecore Namespace
HttpContext..::..Trace


TristateToString Method

[image]

Sitecore 6.4.1 API
MainUtil..::..TristateToString Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string TristateToString(
    Tristate state
)
Visual Basic
Public Shared Function TristateToString ( _
    state As Tristate _
) As String
Visual C++
public:
static String^ TristateToString(
    Tristate state
)

Parameters

state
Type: Sitecore..::..Tristate
The state.

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.TristateToString(Sitecore.Tristate)"]

See Also

MainUtil Class
Sitecore Namespace


True Method

[image]

Sitecore 6.4.1 API
MainUtil..::..True Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool True()
Visual Basic
Public Shared Function True As Boolean
Visual C++
public:
static bool True()

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.True"]

See Also

MainUtil Class
Sitecore Namespace


UnmapPath Method

[image]

Sitecore 6.4.1 API
MainUtil..::..UnmapPath Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string UnmapPath(
    string path
)
Visual Basic
Public Shared Function UnmapPath ( _
    path As String _
) As String
Visual C++
public:
static String^ UnmapPath(
    String^ path
)

Parameters

path
Type: System..::..String
A path.

Return Value

A virtual path.

Remarks

If the path cannot be made into a virtual path, the physical path is returned.

Examples

CopyC#
string path = MainUtil.UnmapPath(@"c:\inetpub\wwwroot\default side\sitecore\images\blank.gif");
// "/sitecore/images/blank.gif"

See Also

MainUtil Class
Sitecore Namespace
MainUtil..::..MapPath(String)


Unquote Method

[image]

Sitecore 6.4.1 API
MainUtil..::..Unquote Method
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use StringUtil.Unquote instead")]
public static string Unquote(
    string text
)
Visual Basic
<ObsoleteAttribute("Use StringUtil.Unquote instead")> _
Public Shared Function Unquote ( _
    text As String _
) As String
Visual C++
[ObsoleteAttribute(L"Use StringUtil.Unquote instead")]
public:
static String^ Unquote(
    String^ text
)

Parameters

text
Type: System..::..String
A string.

Return Value

The unquoted string.

Examples

CopyC#
string s0 = MainUtil.Unquote("'Hello world'"); // "Hello world"
string s0 = MainUtil.Unquote("'Hello Andy's world'"); // "Hello Andy's world"

See Also

MainUtil Class
Sitecore Namespace


VerifyCallLevel Method

[image]

Sitecore 6.4.1 API
MainUtil..::..VerifyCallLevel Method
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool VerifyCallLevel(
    int callLevel,
    string methodName
)
Visual Basic
Public Shared Function VerifyCallLevel ( _
    callLevel As Integer, _
    methodName As String _
) As Boolean
Visual C++
public:
static bool VerifyCallLevel(
    int callLevel,
    String^ methodName
)

Parameters

callLevel
Type: System..::..Int32
The call level to verify.
methodName
Type: System..::..String
The name of the method being called. This should be a fully qualified name, ie. TypeName.MethodName. An example of this could be: Sitecore.Data.Templates.TemplateParser.GetTemplatePath()

Return Value

[Missing <returns> documentation for "M:Sitecore.MainUtil.VerifyCallLevel(System.Int32,System.String)"]

Remarks

If the call level is exceeded an error message is written to the current log and the method returns false.

See Also

MainUtil Class
Sitecore Namespace


WriteToFile Method

[image] [image]

Sitecore 6.4.1 API
MainUtil..::..WriteToFile Method
MainUtil Class See Also Send Feedback

Overload List

Name | Description
WriteToFile(String, array<Byte>[]()[][]%) | Obsolete. Writes a byte array to a file.
WriteToFile(String, String) | Obsolete. Writes a string to a file.
WriteToFile(String, String, Boolean) | Obsolete. Write or appends a atring to a file.

See Also

MainUtil Class
MainUtil Members
Sitecore Namespace


WriteToFile Method (String, Byte[])

[image]

Sitecore 6.4.1 API
MainUtil..::..WriteToFile Method (String, array<Byte>[]()[][]%)
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use FileUtil.WriteToFile instead.")]
public static void WriteToFile(
    string path,
    ref byte[] data
)
Visual Basic
<ObsoleteAttribute("Use FileUtil.WriteToFile instead.")> _
Public Shared Sub WriteToFile ( _
    path As String, _
    ByRef data As Byte() _
)
Visual C++
[ObsoleteAttribute(L"Use FileUtil.WriteToFile instead.")]
public:
static void WriteToFile(
    String^ path,
    array<unsigned char>^% data
)

Parameters

path
Type: System..::..String
A file name path.
data
Type: array< System..::..Byte >[]()[][]%
A byte array of data.

See Also

MainUtil Class
WriteToFile Overload
Sitecore Namespace


WriteToFile Method (String, String)

[image]

Sitecore 6.4.1 API
MainUtil..::..WriteToFile Method (String, String)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use FileUtil.WriteToFile instead.")]
public static void WriteToFile(
    string path,
    string text
)
Visual Basic
<ObsoleteAttribute("Use FileUtil.WriteToFile instead.")> _
Public Shared Sub WriteToFile ( _
    path As String, _
    text As String _
)
Visual C++
[ObsoleteAttribute(L"Use FileUtil.WriteToFile instead.")]
public:
static void WriteToFile(
    String^ path,
    String^ text
)

Parameters

path
Type: System..::..String
A file name path.
text
Type: System..::..String
A string.

Examples

CopyC#
MainUtil.WriteToString("/my.txt", "Hello world");

See Also

MainUtil Class
WriteToFile Overload
Sitecore Namespace


WriteToFile Method (String, String, Boolean)

[image]

Sitecore 6.4.1 API
MainUtil..::..WriteToFile Method (String, String, Boolean)
MainUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use FileUtil.WriteToFile instead.")]
public static void WriteToFile(
    string path,
    string text,
    bool append
)
Visual Basic
<ObsoleteAttribute("Use FileUtil.WriteToFile instead.")> _
Public Shared Sub WriteToFile ( _
    path As String, _
    text As String, _
    append As Boolean _
)
Visual C++
[ObsoleteAttribute(L"Use FileUtil.WriteToFile instead.")]
public:
static void WriteToFile(
    String^ path,
    String^ text,
    bool append
)

Parameters

path
Type: System..::..String
A file name path.
text
Type: System..::..String
A string.
append
Type: System..::..Boolean
Indicates if the string is appended to the file.

Examples

CopyC#
MainUtil.WriteToString("/my.txt", "Hello world", true);

See Also

MainUtil Class
WriteToFile Overload
Sitecore Namespace


MainUtil Properties

[image] [image]

Sitecore 6.4.1 API
MainUtil Properties
MainUtil Class See Also Send Feedback

The MainUtil type exposes the following members.

Properties

Name | Description
EncodeNameReplacements | Gets item name encodings.

See Also

MainUtil Class
Sitecore Namespace


EncodeNameReplacements Property

[image]

Sitecore 6.4.1 API
MainUtil..::..EncodeNameReplacements Property
MainUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string[] EncodeNameReplacements { get; }
Visual Basic
Public Shared ReadOnly Property EncodeNameReplacements As String()
    Get
Visual C++
public:
static property array<String^>^ EncodeNameReplacements {
    array<String^>^ get ();
}

Field Value

The encode name replacements.

See Also

MainUtil Class
Sitecore Namespace


MeansImplicitUseAttribute Class

[image]

Sitecore 6.4.1 API
MeansImplicitUseAttribute Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class MeansImplicitUseAttribute : Attribute
Visual Basic
Public Class MeansImplicitUseAttribute _
    Inherits Attribute
Visual C++
public ref class MeansImplicitUseAttribute : public Attribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Sitecore..::..MeansImplicitUseAttribute

See Also

MeansImplicitUseAttribute Members
Sitecore Namespace


MeansImplicitUseAttribute Members

[image] [image]

Sitecore 6.4.1 API
MeansImplicitUseAttribute Members
MeansImplicitUseAttribute Class Constructors Methods Properties See Also Send Feedback

The MeansImplicitUseAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | MeansImplicitUseAttribute()()()() | Initializes a new instance of the MeansImplicitUseAttribute class.
Public method | MeansImplicitUseAttribute(ImplicitUseFlags) | Initializes a new instance of the MeansImplicitUseAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Flags | Gets or sets the flags.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

MeansImplicitUseAttribute Class
Sitecore Namespace


MeansImplicitUseAttribute Constructor

[image] [image]

Sitecore 6.4.1 API
MeansImplicitUseAttribute Constructor
MeansImplicitUseAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MeansImplicitUseAttribute()()()() | Initializes a new instance of the MeansImplicitUseAttribute class.
Public method | MeansImplicitUseAttribute(ImplicitUseFlags) | Initializes a new instance of the MeansImplicitUseAttribute class.

See Also

MeansImplicitUseAttribute Class
MeansImplicitUseAttribute Members
Sitecore Namespace


MeansImplicitUseAttribute Constructor

[image]

Sitecore 6.4.1 API
MeansImplicitUseAttribute Constructor
MeansImplicitUseAttribute Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MeansImplicitUseAttribute()
Visual Basic
Public Sub New
Visual C++
public:
MeansImplicitUseAttribute()

See Also

MeansImplicitUseAttribute Class
MeansImplicitUseAttribute Overload
Sitecore Namespace


MeansImplicitUseAttribute Constructor (ImplicitUseFlags)

[image]

Sitecore 6.4.1 API
MeansImplicitUseAttribute Constructor (ImplicitUseFlags)
MeansImplicitUseAttribute Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MeansImplicitUseAttribute(
    ImplicitUseFlags flags
)
Visual Basic
Public Sub New ( _
    flags As ImplicitUseFlags _
)
Visual C++
public:
MeansImplicitUseAttribute(
    ImplicitUseFlags flags
)

Parameters

flags
Type: Sitecore..::..ImplicitUseFlags
The flags.

See Also

MeansImplicitUseAttribute Class
MeansImplicitUseAttribute Overload
Sitecore Namespace


MeansImplicitUseAttribute Methods

[image] [image]

Sitecore 6.4.1 API
MeansImplicitUseAttribute Methods
MeansImplicitUseAttribute Class See Also Send Feedback

The MeansImplicitUseAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MeansImplicitUseAttribute Class
Sitecore Namespace


MeansImplicitUseAttribute Properties

[image] [image]

Sitecore 6.4.1 API
MeansImplicitUseAttribute Properties
MeansImplicitUseAttribute Class See Also Send Feedback

The MeansImplicitUseAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Flags | Gets or sets the flags.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

MeansImplicitUseAttribute Class
Sitecore Namespace


Flags Property

[image]

Sitecore 6.4.1 API
MeansImplicitUseAttribute..::..Flags Property
MeansImplicitUseAttribute Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ImplicitUseFlags Flags { get; private set; }
Visual Basic
Public Property Flags As ImplicitUseFlags
    Get
    Private Set
Visual C++
public:
property ImplicitUseFlags Flags {
    ImplicitUseFlags get ();
    private: void set (ImplicitUseFlags value);
}

Field Value

The flags.

See Also

MeansImplicitUseAttribute Class
Sitecore Namespace


NotNullAttribute Class

[image]

Sitecore 6.4.1 API
NotNullAttribute Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public sealed class NotNullAttribute : Attribute
Visual Basic
Public NotInheritable Class NotNullAttribute _
    Inherits Attribute
Visual C++
public ref class NotNullAttribute sealed : public Attribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Sitecore..::..NotNullAttribute

See Also

NotNullAttribute Members
Sitecore Namespace


NotNullAttribute Members

[image] [image]

Sitecore 6.4.1 API
NotNullAttribute Members
NotNullAttribute Class Constructors Methods Properties See Also Send Feedback

The NotNullAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | NotNullAttribute | Initializes a new instance of the NotNullAttribute class

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

NotNullAttribute Class
Sitecore Namespace


NotNullAttribute Constructor

[image]

Sitecore 6.4.1 API
NotNullAttribute Constructor
NotNullAttribute Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public NotNullAttribute()
Visual Basic
Public Sub New
Visual C++
public:
NotNullAttribute()

See Also

NotNullAttribute Class
Sitecore Namespace


NotNullAttribute Methods

[image] [image]

Sitecore 6.4.1 API
NotNullAttribute Methods
NotNullAttribute Class See Also Send Feedback

The NotNullAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NotNullAttribute Class
Sitecore Namespace


NotNullAttribute Properties

[image] [image]

Sitecore 6.4.1 API
NotNullAttribute Properties
NotNullAttribute Class See Also Send Feedback

The NotNullAttribute type exposes the following members.

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

NotNullAttribute Class
Sitecore Namespace


PackageRegistrationFieldIDs Class

[image]

Sitecore 6.4.1 API
PackageRegistrationFieldIDs Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class PackageRegistrationFieldIDs
Visual Basic
Public NotInheritable Class PackageRegistrationFieldIDs
Visual C++
public ref class PackageRegistrationFieldIDs abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore..::..PackageRegistrationFieldIDs

See Also

PackageRegistrationFieldIDs Members
Sitecore Namespace


PackageRegistrationFieldIDs Members

[image] [image]

Sitecore 6.4.1 API
PackageRegistrationFieldIDs Members
PackageRegistrationFieldIDs Class Fields See Also Send Feedback

The PackageRegistrationFieldIDs type exposes the following members.

Fields

Name | Description
PackageID | The ID of the 'Package id' field.
PackageName | The ID of the 'Package name' field.
PackageVersion | The ID of the 'Package version' field.

See Also

PackageRegistrationFieldIDs Class
Sitecore Namespace


PackageRegistrationFieldIDs Fields

[image] [image]

Sitecore 6.4.1 API
PackageRegistrationFieldIDs Fields
PackageRegistrationFieldIDs Class See Also Send Feedback

The PackageRegistrationFieldIDs type exposes the following members.

Fields

Name | Description
PackageID | The ID of the 'Package id' field.
PackageName | The ID of the 'Package name' field.
PackageVersion | The ID of the 'Package version' field.

See Also

PackageRegistrationFieldIDs Class
Sitecore Namespace


PackageID Field

[image]

Sitecore 6.4.1 API
PackageRegistrationFieldIDs..::..PackageID Field
PackageRegistrationFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID PackageID
Visual Basic
Public Shared PackageID As ID
Visual C++
public:
static ID^ PackageID

See Also

PackageRegistrationFieldIDs Class
Sitecore Namespace


PackageName Field

[image]

Sitecore 6.4.1 API
PackageRegistrationFieldIDs..::..PackageName Field
PackageRegistrationFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID PackageName
Visual Basic
Public Shared PackageName As ID
Visual C++
public:
static ID^ PackageName

See Also

PackageRegistrationFieldIDs Class
Sitecore Namespace


RenderingIDs Class

[image]

Sitecore 6.4.1 API
RenderingIDs Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class RenderingIDs
Visual Basic
Public NotInheritable Class RenderingIDs
Visual C++
public ref class RenderingIDs abstract sealed

Remarks

The class does not contain any functionality, but serves as a placeholder for a predefined GUIDs.

Inheritance Hierarchy

System..::..Object
Sitecore..::..RenderingIDs

See Also

RenderingIDs Members
Sitecore Namespace


RenderingIDs Members

[image] [image]

Sitecore 6.4.1 API
RenderingIDs Members
RenderingIDs Class Fields See Also Send Feedback

The RenderingIDs type exposes the following members.

Fields

Name | Description
FieldRenderer | The System/FieldRenderer rendering.
WebEditContentEditor | The System/WebEdit/WebEdit Content Editor rendering.
WebEditRibbon | The System/WebEdit/WebEdit Ribbon rendering.

See Also

RenderingIDs Class
Sitecore Namespace


RenderingIDs Fields

[image] [image]

Sitecore 6.4.1 API
RenderingIDs Fields
RenderingIDs Class See Also Send Feedback

The RenderingIDs type exposes the following members.

Fields

Name | Description
FieldRenderer | The System/FieldRenderer rendering.
WebEditContentEditor | The System/WebEdit/WebEdit Content Editor rendering.
WebEditRibbon | The System/WebEdit/WebEdit Ribbon rendering.

See Also

RenderingIDs Class
Sitecore Namespace


FieldRenderer Field

[image]

Sitecore 6.4.1 API
RenderingIDs..::..FieldRenderer Field
RenderingIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID FieldRenderer
Visual Basic
Public Shared FieldRenderer As ID
Visual C++
public:
static ID^ FieldRenderer

See Also

RenderingIDs Class
Sitecore Namespace


WebEditContentEditor Field

[image]

Sitecore 6.4.1 API
RenderingIDs..::..WebEditContentEditor Field
RenderingIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID WebEditContentEditor
Visual Basic
Public Shared WebEditContentEditor As ID
Visual C++
public:
static ID^ WebEditContentEditor

See Also

RenderingIDs Class
Sitecore Namespace


WebEditRibbon Field

[image]

Sitecore 6.4.1 API
RenderingIDs..::..WebEditRibbon Field
RenderingIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID WebEditRibbon
Visual Basic
Public Shared WebEditRibbon As ID
Visual C++
public:
static ID^ WebEditRibbon

See Also

RenderingIDs Class
Sitecore Namespace


RoleFieldIDs Class

[image]

Sitecore 6.4.1 API
RoleFieldIDs Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class RoleFieldIDs
Visual Basic
Public NotInheritable Class RoleFieldIDs
Visual C++
public ref class RoleFieldIDs abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore..::..RoleFieldIDs

See Also

RoleFieldIDs Members
Sitecore Namespace


RoleFieldIDs Members

[image] [image]

Sitecore 6.4.1 API
RoleFieldIDs Members
RoleFieldIDs Class Fields See Also Send Feedback

The RoleFieldIDs type exposes the following members.

Fields

Name | Description
Roles | The ID of the 'Roles' field.

See Also

RoleFieldIDs Class
Sitecore Namespace


RoleFieldIDs Fields

[image] [image]

Sitecore 6.4.1 API
RoleFieldIDs Fields
RoleFieldIDs Class See Also Send Feedback

The RoleFieldIDs type exposes the following members.

Fields

Name | Description
Roles | The ID of the 'Roles' field.

See Also

RoleFieldIDs Class
Sitecore Namespace


Roles Field

[image]

Sitecore 6.4.1 API
RoleFieldIDs..::..Roles Field
RoleFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Roles
Visual Basic
Public Shared Roles As ID
Visual C++
public:
static ID^ Roles

See Also

RoleFieldIDs Class
Sitecore Namespace


ScheduleFieldIDs Class

[image]

Sitecore 6.4.1 API
ScheduleFieldIDs Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class ScheduleFieldIDs
Visual Basic
Public NotInheritable Class ScheduleFieldIDs
Visual C++
public ref class ScheduleFieldIDs abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore..::..ScheduleFieldIDs

See Also

ScheduleFieldIDs Members
Sitecore Namespace


ScheduleFieldIDs Members

[image] [image]

Sitecore 6.4.1 API
ScheduleFieldIDs Members
ScheduleFieldIDs Class Fields See Also Send Feedback

The ScheduleFieldIDs type exposes the following members.

Fields

Name | Description
Async | The ID of the 'Async' field.
AutoRemove | The ID of the 'Auto remove' field.
Command | The ID of the 'Command' field.
Items | The ID of the 'Items' field.
LastRun | The ID of the 'Last run' field.
Schedule | The ID of the 'Schedule' field.

See Also

ScheduleFieldIDs Class
Sitecore Namespace


ScheduleFieldIDs Fields

[image] [image]

Sitecore 6.4.1 API
ScheduleFieldIDs Fields
ScheduleFieldIDs Class See Also Send Feedback

The ScheduleFieldIDs type exposes the following members.

Fields

Name | Description
Async | The ID of the 'Async' field.
AutoRemove | The ID of the 'Auto remove' field.
Command | The ID of the 'Command' field.
Items | The ID of the 'Items' field.
LastRun | The ID of the 'Last run' field.
Schedule | The ID of the 'Schedule' field.

See Also

ScheduleFieldIDs Class
Sitecore Namespace


Async Field

[image]

Sitecore 6.4.1 API
ScheduleFieldIDs..::..Async Field
ScheduleFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Async
Visual Basic
Public Shared Async As ID
Visual C++
public:
static ID^ Async

See Also

ScheduleFieldIDs Class
Sitecore Namespace


AutoRemove Field

[image]

Sitecore 6.4.1 API
ScheduleFieldIDs..::..AutoRemove Field
ScheduleFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID AutoRemove
Visual Basic
Public Shared AutoRemove As ID
Visual C++
public:
static ID^ AutoRemove

See Also

ScheduleFieldIDs Class
Sitecore Namespace


Command Field

[image]

Sitecore 6.4.1 API
ScheduleFieldIDs..::..Command Field
ScheduleFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Command
Visual Basic
Public Shared Command As ID
Visual C++
public:
static ID^ Command

See Also

ScheduleFieldIDs Class
Sitecore Namespace


Items Field

[image]

Sitecore 6.4.1 API
ScheduleFieldIDs..::..Items Field
ScheduleFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Items
Visual Basic
Public Shared Items As ID
Visual C++
public:
static ID^ Items

See Also

ScheduleFieldIDs Class
Sitecore Namespace


LastRun Field

[image]

Sitecore 6.4.1 API
ScheduleFieldIDs..::..LastRun Field
ScheduleFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID LastRun
Visual Basic
Public Shared LastRun As ID
Visual C++
public:
static ID^ LastRun

See Also

ScheduleFieldIDs Class
Sitecore Namespace


SecurityDatabaseTemplateIDs Members

[image] [image]

Sitecore 6.4.1 API
SecurityDatabaseTemplateIDs Members
SecurityDatabaseTemplateIDs Class Fields See Also Send Feedback

The SecurityDatabaseTemplateIDs type exposes the following members.

Fields

Name | Description
Folder | The ID of 'Folder' in the security database.

See Also

SecurityDatabaseTemplateIDs Class
Sitecore Namespace


SecurityDatabaseTemplateIDs Fields

[image] [image]

Sitecore 6.4.1 API
SecurityDatabaseTemplateIDs Fields
SecurityDatabaseTemplateIDs Class See Also Send Feedback

The SecurityDatabaseTemplateIDs type exposes the following members.

Fields

Name | Description
Folder | The ID of 'Folder' in the security database.

See Also

SecurityDatabaseTemplateIDs Class
Sitecore Namespace


ShellFieldIDs Class

[image]

Sitecore 6.4.1 API
ShellFieldIDs Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class ShellFieldIDs
Visual Basic
Public NotInheritable Class ShellFieldIDs
Visual C++
public ref class ShellFieldIDs abstract sealed

Remarks

The class does not contain any functionality, but serves as a placeholder for a predefined GUIDs.

Inheritance Hierarchy

System..::..Object
Sitecore..::..ShellFieldIDs

See Also

ShellFieldIDs Members
Sitecore Namespace


ShellFieldIDs Members

[image] [image]

Sitecore 6.4.1 API
ShellFieldIDs Members
ShellFieldIDs Class Fields See Also Send Feedback

The ShellFieldIDs type exposes the following members.

Fields

Name | Description
Branch | The Branch field of the Shell/Shell association template.
Commands | The ID of the 'Commands' field.
Deep | The Deep field of the Shell/Shell association template.
FolderKind | The FolderKind field of the Shell/Shell task group template.
Master | Obsolete. The Master field of the Shell/Shell association template.
Path | The Path field of the Shell/Shell association template.
Template | The Template field of the Shell/Shell association template.
ToolbarIcon | The ToolbarIcon field of the Shell/Shell task group template.
ToolbarStylesheetClass | The ToolbarStylesheetClass field of the Shell/Shell task group template.

See Also

ShellFieldIDs Class
Sitecore Namespace


ShellFieldIDs Fields

[image] [image]

Sitecore 6.4.1 API
ShellFieldIDs Fields
ShellFieldIDs Class See Also Send Feedback

The ShellFieldIDs type exposes the following members.

Fields

Name | Description
Branch | The Branch field of the Shell/Shell association template.
Commands | The ID of the 'Commands' field.
Deep | The Deep field of the Shell/Shell association template.
FolderKind | The FolderKind field of the Shell/Shell task group template.
Master | Obsolete. The Master field of the Shell/Shell association template.
Path | The Path field of the Shell/Shell association template.
Template | The Template field of the Shell/Shell association template.
ToolbarIcon | The ToolbarIcon field of the Shell/Shell task group template.
ToolbarStylesheetClass | The ToolbarStylesheetClass field of the Shell/Shell task group template.

See Also

ShellFieldIDs Class
Sitecore Namespace


Branch Field

[image]

Sitecore 6.4.1 API
ShellFieldIDs..::..Branch Field
ShellFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Branch
Visual Basic
Public Shared Branch As ID
Visual C++
public:
static ID^ Branch

See Also

ShellFieldIDs Class
Sitecore Namespace


Deep Field

[image]

Sitecore 6.4.1 API
ShellFieldIDs..::..Deep Field
ShellFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Deep
Visual Basic
Public Shared Deep As ID
Visual C++
public:
static ID^ Deep

See Also

ShellFieldIDs Class
Sitecore Namespace


Master Field

[image]

Sitecore 6.4.1 API
ShellFieldIDs..::..Master Field
ShellFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use Branch instead.")]
public static ID Master
Visual Basic
<ObsoleteAttribute("Deprecated - Use Branch instead.")> _
Public Shared Master As ID
Visual C++
[ObsoleteAttribute(L"Deprecated - Use Branch instead.")]
public:
static ID^ Master

See Also

ShellFieldIDs Class
Sitecore Namespace


Path Field

[image]

Sitecore 6.4.1 API
ShellFieldIDs..::..Path Field
ShellFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Path
Visual Basic
Public Shared Path As ID
Visual C++
public:
static ID^ Path

See Also

ShellFieldIDs Class
Sitecore Namespace


Template Field

[image]

Sitecore 6.4.1 API
ShellFieldIDs..::..Template Field
ShellFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Template
Visual Basic
Public Shared Template As ID
Visual C++
public:
static ID^ Template

See Also

ShellFieldIDs Class
Sitecore Namespace


ToolbarIcon Field

[image]

Sitecore 6.4.1 API
ShellFieldIDs..::..ToolbarIcon Field
ShellFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID ToolbarIcon
Visual Basic
Public Shared ToolbarIcon As ID
Visual C++
public:
static ID^ ToolbarIcon

See Also

ShellFieldIDs Class
Sitecore Namespace


ToolbarStylesheetClass Field

[image]

Sitecore 6.4.1 API
ShellFieldIDs..::..ToolbarStylesheetClass Field
ShellFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID ToolbarStylesheetClass
Visual Basic
Public Shared ToolbarStylesheetClass As ID
Visual C++
public:
static ID^ ToolbarStylesheetClass

See Also

ShellFieldIDs Class
Sitecore Namespace


StringFormatMethodAttribute Class

[image]

Sitecore 6.4.1 API
StringFormatMethodAttribute Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class StringFormatMethodAttribute : Attribute
Visual Basic
Public Class StringFormatMethodAttribute _
    Inherits Attribute
Visual C++
public ref class StringFormatMethodAttribute : public Attribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Sitecore..::..StringFormatMethodAttribute

See Also

StringFormatMethodAttribute Members
Sitecore Namespace


StringFormatMethodAttribute Members

[image] [image]

Sitecore 6.4.1 API
StringFormatMethodAttribute Members
StringFormatMethodAttribute Class Constructors Methods Properties See Also Send Feedback

The StringFormatMethodAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | StringFormatMethodAttribute | Initializes a new instance of the StringFormatMethodAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FormatParameterName | Gets the name of the format parameter.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

StringFormatMethodAttribute Class
Sitecore Namespace


StringFormatMethodAttribute Constructor

[image]

Sitecore 6.4.1 API
StringFormatMethodAttribute Constructor
StringFormatMethodAttribute Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StringFormatMethodAttribute(
    string formatParameterName
)
Visual Basic
Public Sub New ( _
    formatParameterName As String _
)
Visual C++
public:
StringFormatMethodAttribute(
    String^ formatParameterName
)

Parameters

formatParameterName
Type: System..::..String
Name of the format parameter.

See Also

StringFormatMethodAttribute Class
Sitecore Namespace


StringFormatMethodAttribute Methods

[image] [image]

Sitecore 6.4.1 API
StringFormatMethodAttribute Methods
StringFormatMethodAttribute Class See Also Send Feedback

The StringFormatMethodAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StringFormatMethodAttribute Class
Sitecore Namespace


StringFormatMethodAttribute Properties

[image] [image]

Sitecore 6.4.1 API
StringFormatMethodAttribute Properties
StringFormatMethodAttribute Class See Also Send Feedback

The StringFormatMethodAttribute type exposes the following members.

Properties

 | Name | Description
Public property | FormatParameterName | Gets the name of the format parameter.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

StringFormatMethodAttribute Class
Sitecore Namespace


FormatParameterName Property

[image]

Sitecore 6.4.1 API
StringFormatMethodAttribute..::..FormatParameterName Property
StringFormatMethodAttribute Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string FormatParameterName { get; }
Visual Basic
Public ReadOnly Property FormatParameterName As String
    Get
Visual C++
public:
property String^ FormatParameterName {
    String^ get ();
}

Field Value

The name of the format parameter.

See Also

StringFormatMethodAttribute Class
Sitecore Namespace


StringUtil Class

[image]

Sitecore 6.4.1 API
StringUtil Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public sealed class StringUtil
Visual Basic
Public NotInheritable Class StringUtil
Visual C++
public ref class StringUtil sealed

Remarks

Inheritance Hierarchy

System..::..Object
Sitecore..::..StringUtil

See Also

StringUtil Members
Sitecore Namespace
Sitecore..::..DateUtil
Sitecore..::..MainUtil
Sitecore..::..StringUtil


StringUtil Members

[image] [image]

Sitecore 6.4.1 API
StringUtil Members
StringUtil Class Constructors Methods See Also Send Feedback

The StringUtil type exposes the following members.

Constructors

 | Name | Description
Public method | StringUtil | Initializes a new instance of the StringUtil class

Methods

 | Name | Description
 | ArrayToString | Arrays to string.
 | Capitalize | Uppercases the first letter of a string and lowercases the remaining letters.
 | Clip | Clips a string at a certain length.
 | Combine | Combines the specified parts.
 | Concat | Concats the specified values.
 | Contains | Determines whether [contains] [the specified text].
 | CutUp | Cuts a string into evenly sized parts.
 | Decode | Decodes the specified bytes.
 | DecodeMessageParameter | Decodes the message parameter.
 | DictionaryToNameValues | Dictionaries to name values.
 | Divide | Divides a string using a specified separator character.
 | DivideAtDigit | Divides a string in two at the first digit.
 | Encode | Encodes the specified text.
 | EncodeMessageParameter | Encodes the message parameter.
 | EnsurePostfix | Ensures that a string has a certain postfix.
 | EnsurePrefix | Ensures that a string has a certain prefix.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EscapeBackslash | Escapes the backslash.
 | EscapeJavascriptString(String) | Escapes the javascript string.
 | EscapeJavascriptString(String, Boolean) | Escapes the javascript string.
 | EscapeQuote | Escapes the quote.
 | ExtractParameter | Extracts a parameter string from a query string formatted string.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLastPart | Gets the last part.
 | GetLastPostfix(String, Char) | Gets the last postfix part of a string.
 | GetLastPostfix(String, Char, String) | Gets the postfix part of a string.
 | GetLongestPrefix(String, Char) | Gets the longest prefix.
 | GetLongestPrefix(String, Char, String) | Gets the longest prefix.
 | GetNameValues(String) | Converts a string to a name/value collection.
 | GetNameValues(array<String>[]()[][]) | Gets a name/value collection from a string array.
 | GetNameValues(String, Char, Char) | Converts a string to a name/value collection.
 | GetPostfix(String, Char) | Gets the postfix part of a string.
 | GetPostfix(String, Char, String) | Gets the postfix part of a string.
 | GetPrefix(String, Char) | Gets the prefix part of a string.
 | GetPrefix(String, Char, String) | Gets the prefix part of a string.
 | GetSizeString | Gets the size string.
 | GetString(Object) | Gets the string.
 | GetString(array<String>[]()[][]) | Gets a non-empty string from a list.
 | GetString(Object, String) | Gets the string.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(String, array<String>[]()[][]) | Searches for the text and returns the zero-based index of the first occurrence within the entire string.
 | IndexOf(String, Char, Int32) | Searches for the text and returns the zero-based index of the first occurrence within the entire string.
 | IsWhiteSpace | Determines whether [is white space] [the specified s].
 | Join(IEnumerable, String) | Joins the specified enumerable.
 | Join(IEnumerable, String, String) | Joins the specified enumerable.
 | Left | Gets the leftmost part of a string.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Mid(String, Int32) | Gets the middle part of a string.
 | Mid(String, Int32, Int32) | Gets the middle part of a string.
 | NameValuesToDictionary | Names the values to dictionary.
 | NameValuesToString(NameValueCollection) | Names the values to string.
 | NameValuesToString(NameValueCollection, String) | Names the values to string.
 | ParseArguments | Parses an argument list into a string array.
 | ParseNameValueCollection | Parses the name value.
 | ParseSizeString | Parses a size string (10KB, 20MB, etc.).
 | ReadPhrase | Reads a phrase from a string.
 | RemoveLineFeeds | Remove tags from a string.
 | RemovePostfix(Char, String) | Removes a postfix from a string.
 | RemovePostfix(String, String) | Removes a specific prefix from a string.
 | RemovePrefix(Char, String) | Removes a prefix from a string.
 | RemovePrefix(String, String) | Removes a specific prefix from a string.
 | RemoveTags | Remove tags from a string.
 | Repeat | Repeats a string a number of times.
 | Replace | Replace a character array with strings.
 | Right | Gets the rightmost part of a string.
 | Split(String, Char, Boolean) | Splits a string, optionally trimming parts.
 | Split(String, Char, Char) | Splits a string while protecting phrases.
 | StringArrayToNameValueCollection | Strings the array to name value collection.
 | StringCollectionToString(StringCollection) | Converts a string collection to a string
 | StringCollectionToString(StringCollection, String) | Converts a string collection to a string
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | TrimEnd | Trims the end.
 | TrimStart | Trims the start.
 | Unquote | Removes enclosing single and double quotes from a string.

See Also

StringUtil Class
Sitecore Namespace


StringUtil Constructor

[image]

Sitecore 6.4.1 API
StringUtil Constructor
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StringUtil()
Visual Basic
Public Sub New
Visual C++
public:
StringUtil()

See Also

StringUtil Class
Sitecore Namespace


StringUtil Methods

[image] [image]

Sitecore 6.4.1 API
StringUtil Methods
StringUtil Class See Also Send Feedback

The StringUtil type exposes the following members.

Methods

 | Name | Description
 | ArrayToString | Arrays to string.
 | Capitalize | Uppercases the first letter of a string and lowercases the remaining letters.
 | Clip | Clips a string at a certain length.
 | Combine | Combines the specified parts.
 | Concat | Concats the specified values.
 | Contains | Determines whether [contains] [the specified text].
 | CutUp | Cuts a string into evenly sized parts.
 | Decode | Decodes the specified bytes.
 | DecodeMessageParameter | Decodes the message parameter.
 | DictionaryToNameValues | Dictionaries to name values.
 | Divide | Divides a string using a specified separator character.
 | DivideAtDigit | Divides a string in two at the first digit.
 | Encode | Encodes the specified text.
 | EncodeMessageParameter | Encodes the message parameter.
 | EnsurePostfix | Ensures that a string has a certain postfix.
 | EnsurePrefix | Ensures that a string has a certain prefix.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EscapeBackslash | Escapes the backslash.
 | EscapeJavascriptString(String) | Escapes the javascript string.
 | EscapeJavascriptString(String, Boolean) | Escapes the javascript string.
 | EscapeQuote | Escapes the quote.
 | ExtractParameter | Extracts a parameter string from a query string formatted string.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLastPart | Gets the last part.
 | GetLastPostfix(String, Char) | Gets the last postfix part of a string.
 | GetLastPostfix(String, Char, String) | Gets the postfix part of a string.
 | GetLongestPrefix(String, Char) | Gets the longest prefix.
 | GetLongestPrefix(String, Char, String) | Gets the longest prefix.
 | GetNameValues(String) | Converts a string to a name/value collection.
 | GetNameValues(array<String>[]()[][]) | Gets a name/value collection from a string array.
 | GetNameValues(String, Char, Char) | Converts a string to a name/value collection.
 | GetPostfix(String, Char) | Gets the postfix part of a string.
 | GetPostfix(String, Char, String) | Gets the postfix part of a string.
 | GetPrefix(String, Char) | Gets the prefix part of a string.
 | GetPrefix(String, Char, String) | Gets the prefix part of a string.
 | GetSizeString | Gets the size string.
 | GetString(Object) | Gets the string.
 | GetString(array<String>[]()[][]) | Gets a non-empty string from a list.
 | GetString(Object, String) | Gets the string.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(String, array<String>[]()[][]) | Searches for the text and returns the zero-based index of the first occurrence within the entire string.
 | IndexOf(String, Char, Int32) | Searches for the text and returns the zero-based index of the first occurrence within the entire string.
 | IsWhiteSpace | Determines whether [is white space] [the specified s].
 | Join(IEnumerable, String) | Joins the specified enumerable.
 | Join(IEnumerable, String, String) | Joins the specified enumerable.
 | Left | Gets the leftmost part of a string.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Mid(String, Int32) | Gets the middle part of a string.
 | Mid(String, Int32, Int32) | Gets the middle part of a string.
 | NameValuesToDictionary | Names the values to dictionary.
 | NameValuesToString(NameValueCollection) | Names the values to string.
 | NameValuesToString(NameValueCollection, String) | Names the values to string.
 | ParseArguments | Parses an argument list into a string array.
 | ParseNameValueCollection | Parses the name value.
 | ParseSizeString | Parses a size string (10KB, 20MB, etc.).
 | ReadPhrase | Reads a phrase from a string.
 | RemoveLineFeeds | Remove tags from a string.
 | RemovePostfix(Char, String) | Removes a postfix from a string.
 | RemovePostfix(String, String) | Removes a specific prefix from a string.
 | RemovePrefix(Char, String) | Removes a prefix from a string.
 | RemovePrefix(String, String) | Removes a specific prefix from a string.
 | RemoveTags | Remove tags from a string.
 | Repeat | Repeats a string a number of times.
 | Replace | Replace a character array with strings.
 | Right | Gets the rightmost part of a string.
 | Split(String, Char, Boolean) | Splits a string, optionally trimming parts.
 | Split(String, Char, Char) | Splits a string while protecting phrases.
 | StringArrayToNameValueCollection | Strings the array to name value collection.
 | StringCollectionToString(StringCollection) | Converts a string collection to a string
 | StringCollectionToString(StringCollection, String) | Converts a string collection to a string
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | TrimEnd | Trims the end.
 | TrimStart | Trims the start.
 | Unquote | Removes enclosing single and double quotes from a string.

See Also

StringUtil Class
Sitecore Namespace


ArrayToString Method

[image]

Sitecore 6.4.1 API
StringUtil..::..ArrayToString Method
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ArrayToString(
    Array array,
    char delimiter
)
Visual Basic
Public Shared Function ArrayToString ( _
    array As Array, _
    delimiter As Char _
) As String
Visual C++
public:
static String^ ArrayToString(
    Array^ array,
    wchar_t delimiter
)

Parameters

array
Type: System..::..Array
The array.
delimiter
Type: System..::..Char
The delimiter.

Return Value

[Missing <returns> documentation for "M:Sitecore.StringUtil.ArrayToString(System.Array,System.Char)"]

See Also

StringUtil Class
Sitecore Namespace


Capitalize Method

[image]

Sitecore 6.4.1 API
StringUtil..::..Capitalize Method
StringUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Capitalize(
    string text
)
Visual Basic
Public Shared Function Capitalize ( _
    text As String _
) As String
Visual C++
public:
static String^ Capitalize(
    String^ text
)

Parameters

text
Type: System..::..String
A string.

Return Value

The capitalized string.

Remarks

Sentences are not taken into account.

Examples

CopyC#
string text = MainUtil.Capitalize("HELLO WORLD."); // "Hello world"
string text = MainUtil.Capitalize("HELLO. HOW ARE YOU?"); // "Hello. how are you?"

See Also

StringUtil Class
Sitecore Namespace


Clip Method

[image]

Sitecore 6.4.1 API
StringUtil..::..Clip Method
StringUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Clip(
    string text,
    int length,
    bool ellipsis
)
Visual Basic
Public Shared Function Clip ( _
    text As String, _
    length As Integer, _
    ellipsis As Boolean _
) As String
Visual C++
public:
static String^ Clip(
    String^ text,
    int length,
    bool ellipsis
)

Parameters

text
Type: System..::..String
The text that will be clipped.
length
Type: System..::..Int32
The maximum length of the returned string.
ellipsis
Type: System..::..Boolean
Indicates if the string should have en ellipsis (...) appended

Return Value

The clipped string.

Examples

CopyC#
string s0 = StringUtil.Clip("Hello world", 5, false); // "Hello"
string s1 = StringUtil.Clip("Hello world", 5, true);  // "He..."

See Also

StringUtil Class
Sitecore Namespace


Combine Method

[image]

Sitecore 6.4.1 API
StringUtil..::..Combine Method
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Combine(
    Object part1,
    Object part2,
    string divider
)
Visual Basic
Public Shared Function Combine ( _
    part1 As Object, _
    part2 As Object, _
    divider As String _
) As String
Visual C++
public:
static String^ Combine(
    Object^ part1,
    Object^ part2,
    String^ divider
)

Parameters

part1
Type: System..::..Object
The part1.
part2
Type: System..::..Object
The part2.
divider
Type: System..::..String
The divider.

Return Value

[Missing <returns> documentation for "M:Sitecore.StringUtil.Combine(System.Object,System.Object,System.String)"]

See Also

StringUtil Class
Sitecore Namespace


Concat Method

[image]

Sitecore 6.4.1 API
StringUtil..::..Concat Method
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Concat(
    params Object[] values
)
Visual Basic
Public Shared Function Concat ( _
    ParamArray values As Object() _
) As String
Visual C++
public:
static String^ Concat(
    ... array<Object^>^ values
)

Parameters

values
Type: array< System..::..Object >[]()[][]
The values.

Return Value

[Missing <returns> documentation for "M:Sitecore.StringUtil.Concat(System.Object[])"]

See Also

StringUtil Class
Sitecore Namespace


Contains Method

[image]

Sitecore 6.4.1 API
StringUtil..::..Contains Method
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool Contains(
    string text,
    string[] texts
)
Visual Basic
Public Shared Function Contains ( _
    text As String, _
    texts As String() _
) As Boolean
Visual C++
public:
static bool Contains(
    String^ text,
    array<String^>^ texts
)

Parameters

text
Type: System..::..String
The text.
texts
Type: array< System..::..String >[]()[][]
The texts.

Return Value

true if [contains] [the specified text]; otherwise, false.

See Also

StringUtil Class
Sitecore Namespace


Decode Method

[image]

Sitecore 6.4.1 API
StringUtil..::..Decode Method
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Decode(
    byte[] bytes
)
Visual Basic
Public Shared Function Decode ( _
    bytes As Byte() _
) As String
Visual C++
public:
static String^ Decode(
    array<unsigned char>^ bytes
)

Parameters

bytes
Type: array< System..::..Byte >[]()[][]
The bytes.

Return Value

[Missing <returns> documentation for "M:Sitecore.StringUtil.Decode(System.Byte[])"]

See Also

StringUtil Class
Sitecore Namespace


DecodeMessageParameter Method

[image]

Sitecore 6.4.1 API
StringUtil..::..DecodeMessageParameter Method
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string DecodeMessageParameter(
    string value
)
Visual Basic
Public Shared Function DecodeMessageParameter ( _
    value As String _
) As String
Visual C++
public:
static String^ DecodeMessageParameter(
    String^ value
)

Parameters

value
Type: System..::..String
The value.

Return Value

The message parameter.

See Also

StringUtil Class
Sitecore Namespace


DictionaryToNameValues Method

[image]

Sitecore 6.4.1 API
StringUtil..::..DictionaryToNameValues Method
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static NameValueCollection DictionaryToNameValues(
    SafeDictionary<string> dictionary
)
Visual Basic
Public Shared Function DictionaryToNameValues ( _
    dictionary As SafeDictionary(Of String) _
) As NameValueCollection
Visual C++
public:
static NameValueCollection^ DictionaryToNameValues(
    SafeDictionary<String^>^ dictionary
)

Parameters

dictionary
Type: Sitecore.Collections..::..SafeDictionary <(Of <(<' String >)>)>
The dictionary.

Return Value

The to name values.

See Also

StringUtil Class
Sitecore Namespace


Divide Method

[image]

Sitecore 6.4.1 API
StringUtil..::..Divide Method
StringUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string[] Divide(
    string value,
    char separator,
    bool useLastSeparator
)
Visual Basic
Public Shared Function Divide ( _
    value As String, _
    separator As Char, _
    useLastSeparator As Boolean _
) As String()
Visual C++
public:
static array<String^>^ Divide(
    String^ value,
    wchar_t separator,
    bool useLastSeparator
)

Parameters

value
Type: System..::..String
The value.
separator
Type: System..::..Char
The separator.
useLastSeparator
Type: System..::..Boolean
if set to true this instance is use last separator.

Return Value

[Missing <returns> documentation for "M:Sitecore.StringUtil.Divide(System.String,System.Char,System.Boolean)"]

Examples

StringUtil.Divide("da-DK-kl", '-', false);  // returns {"da", "DK-kl"}
StringUtil.Divide("da-DK-kl", '-', true);  // returns {"da-DK", "kl"}
StringUtil.Divide("da", '-', false);  // returns {"da"}

See Also

StringUtil Class
Sitecore Namespace


DivideAtDigit Method

[image]

Sitecore 6.4.1 API
StringUtil..::..DivideAtDigit Method
StringUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string[] DivideAtDigit(
    string value
)
Visual Basic
Public Shared Function DivideAtDigit ( _
    value As String _
) As String()
Visual C++
public:
static array<String^>^ DivideAtDigit(
    String^ value
)

Parameters

value
Type: System..::..String
The value.

Return Value

[Missing <returns> documentation for "M:Sitecore.StringUtil.DivideAtDigit(System.String)"]

Examples

StringUtil.DivideAtDigit("da-DK12"); // returns {"da-DK", "12"} StringUtil.DivideAtDigit("da-DK"); // returns {"da-DK"}

See Also

StringUtil Class
Sitecore Namespace


Encode Method

[image]

Sitecore 6.4.1 API
StringUtil..::..Encode Method
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static byte[] Encode(
    string text
)
Visual Basic
Public Shared Function Encode ( _
    text As String _
) As Byte()
Visual C++
public:
static array<unsigned char>^ Encode(
    String^ text
)

Parameters

text
Type: System..::..String
The text.

Return Value

[Missing <returns> documentation for "M:Sitecore.StringUtil.Encode(System.String)"]

See Also

StringUtil Class
Sitecore Namespace


EncodeMessageParameter Method

[image]

Sitecore 6.4.1 API
StringUtil..::..EncodeMessageParameter Method
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string EncodeMessageParameter(
    string value
)
Visual Basic
Public Shared Function EncodeMessageParameter ( _
    value As String _
) As String
Visual C++
public:
static String^ EncodeMessageParameter(
    String^ value
)

Parameters

value
Type: System..::..String
The value.

Return Value

The message parameter.

See Also

StringUtil Class
Sitecore Namespace


EnsurePostfix Method

[image]

Sitecore 6.4.1 API
StringUtil..::..EnsurePostfix Method
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string EnsurePostfix(
    char postfix,
    string value
)
Visual Basic
Public Shared Function EnsurePostfix ( _
    postfix As Char, _
    value As String _
) As String
Visual C++
public:
static String^ EnsurePostfix(
    wchar_t postfix,
    String^ value
)

Parameters

postfix
Type: System..::..Char
The postfix.
value
Type: System..::..String
The value.

Return Value

[Missing <returns> documentation for "M:Sitecore.StringUtil.EnsurePostfix(System.Char,System.String)"]

See Also

StringUtil Class
Sitecore Namespace


EnsurePrefix Method

[image]

Sitecore 6.4.1 API
StringUtil..::..EnsurePrefix Method
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string EnsurePrefix(
    char prefix,
    string value
)
Visual Basic
Public Shared Function EnsurePrefix ( _
    prefix As Char, _
    value As String _
) As String
Visual C++
public:
static String^ EnsurePrefix(
    wchar_t prefix,
    String^ value
)

Parameters

prefix
Type: System..::..Char
The prefix.
value
Type: System..::..String
The value.

Return Value

[Missing <returns> documentation for "M:Sitecore.StringUtil.EnsurePrefix(System.Char,System.String)"]

See Also

StringUtil Class
Sitecore Namespace


EscapeBackslash Method

[image]

Sitecore 6.4.1 API
StringUtil..::..EscapeBackslash Method
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string EscapeBackslash(
    string test
)
Visual Basic
Public Shared Function EscapeBackslash ( _
    test As String _
) As String
Visual C++
public:
static String^ EscapeBackslash(
    String^ test
)

Parameters

test
Type: System..::..String
The name.

Return Value

[Missing <returns> documentation for "M:Sitecore.StringUtil.EscapeBackslash(System.String)"]

See Also

StringUtil Class
Sitecore Namespace


EscapeJavascriptString Method

[image] [image]

Sitecore 6.4.1 API
StringUtil..::..EscapeJavascriptString Method
StringUtil Class See Also Send Feedback

Overload List

Name | Description
EscapeJavascriptString(String) | Escapes the javascript string.
EscapeJavascriptString(String, Boolean) | Escapes the javascript string.

See Also

StringUtil Class
StringUtil Members
Sitecore Namespace


EscapeJavascriptString Method (String)

[image]

Sitecore 6.4.1 API
StringUtil..::..EscapeJavascriptString Method (String)
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string EscapeJavascriptString(
    string text
)
Visual Basic
Public Shared Function EscapeJavascriptString ( _
    text As String _
) As String
Visual C++
public:
static String^ EscapeJavascriptString(
    String^ text
)

Parameters

text
Type: System..::..String
The text.

Return Value

[Missing <returns> documentation for "M:Sitecore.StringUtil.EscapeJavascriptString(System.String)"]

See Also

StringUtil Class
EscapeJavascriptString Overload
Sitecore Namespace


EscapeJavascriptString Method (String, Boolean)

[image]

Sitecore 6.4.1 API
StringUtil..::..EscapeJavascriptString Method (String, Boolean)
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string EscapeJavascriptString(
    string text,
    bool surroundWithQuotes
)
Visual Basic
Public Shared Function EscapeJavascriptString ( _
    text As String, _
    surroundWithQuotes As Boolean _
) As String
Visual C++
public:
static String^ EscapeJavascriptString(
    String^ text,
    bool surroundWithQuotes
)

Parameters

text
Type: System..::..String
The text.
surroundWithQuotes
Type: System..::..Boolean
Surround with quotes.

Return Value

[Missing <returns> documentation for "M:Sitecore.StringUtil.EscapeJavascriptString(System.String,System.Boolean)"]

See Also

StringUtil Class
EscapeJavascriptString Overload
Sitecore Namespace


EscapeQuote Method

[image]

Sitecore 6.4.1 API
StringUtil..::..EscapeQuote Method
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string EscapeQuote(
    string text
)
Visual Basic
Public Shared Function EscapeQuote ( _
    text As String _
) As String
Visual C++
public:
static String^ EscapeQuote(
    String^ text
)

Parameters

text
Type: System..::..String
The text.

Return Value

[Missing <returns> documentation for "M:Sitecore.StringUtil.EscapeQuote(System.String)"]

See Also

StringUtil Class
Sitecore Namespace


ExtractParameter Method

[image]

Sitecore 6.4.1 API
StringUtil..::..ExtractParameter Method
StringUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ExtractParameter(
    string name,
    string parameters
)
Visual Basic
Public Shared Function ExtractParameter ( _
    name As String, _
    parameters As String _
) As String
Visual C++
public:
static String^ ExtractParameter(
    String^ name,
    String^ parameters
)

Parameters

name
Type: System..::..String
The name of the parameter to find.
parameters
Type: System..::..String
A query string formatted string, e.g. "a=1&b=2&myparam=3"

Return Value

The value of the named parameter.

Remarks

If the name was not found, blank is returned.

Examples

CopyC#
string parameters = "print=1&target=/sitecore/content/home&test=false";
string print = StringUtil.ExtractParameter("print", parameters); // "1"
string target = StringUtil.ExtractParameter("target", parameters); // "/sitecore/content/home"
string dummy = StringUtil.ExtractParameter("dummy", parameters); // ""

See Also

StringUtil Class
Sitecore Namespace


GetLastPart Method

[image]

Sitecore 6.4.1 API
StringUtil..::..GetLastPart Method
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetLastPart(
    string text,
    char delimiter,
    string defaultValue
)
Visual Basic
Public Shared Function GetLastPart ( _
    text As String, _
    delimiter As Char, _
    defaultValue As String _
) As String
Visual C++
public:
static String^ GetLastPart(
    String^ text,
    wchar_t delimiter,
    String^ defaultValue
)

Parameters

text
Type: System..::..String
The text.
delimiter
Type: System..::..Char
The delimiter.
defaultValue
Type: System..::..String
The default value.

Return Value

[Missing <returns> documentation for "M:Sitecore.StringUtil.GetLastPart(System.String,System.Char,System.String)"]

See Also

StringUtil Class
Sitecore Namespace


GetLastPostfix Method

[image] [image]

Sitecore 6.4.1 API
StringUtil..::..GetLastPostfix Method
StringUtil Class See Also Send Feedback

Overload List

Name | Description
GetLastPostfix(String, Char) | Gets the last postfix part of a string.
GetLastPostfix(String, Char, String) | Gets the postfix part of a string.

See Also

StringUtil Class
StringUtil Members
Sitecore Namespace


GetLastPostfix Method (String, Char)

[image]

Sitecore 6.4.1 API
StringUtil..::..GetLastPostfix Method (String, Char)
StringUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetLastPostfix(
    string text,
    char delimiter
)
Visual Basic
Public Shared Function GetLastPostfix ( _
    text As String, _
    delimiter As Char _
) As String
Visual C++
public:
static String^ GetLastPostfix(
    String^ text,
    wchar_t delimiter
)

Parameters

text
Type: System..::..String
A string
delimiter
Type: System..::..Char
The character delimiting the postfix from the rest of the string.

Return Value

All characters of the string starting from character after the last occurrence of delimiter.

If delimiter is not found in the string, an empty string is returned.

Examples

CopyC#
string postfix = StringUtil.GetPostfix("sc:menu:new", ':');
MainUtil.Out(postfix);
 Outputs: new

See Also

StringUtil Class
GetLastPostfix Overload
Sitecore Namespace
StringUtil..::..GetPostfix(String, Char)


GetLastPostfix Method (String, Char, String)

[image]

Sitecore 6.4.1 API
StringUtil..::..GetLastPostfix Method (String, Char, String)
StringUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetLastPostfix(
    string text,
    char delimiter,
    string defaultValue
)
Visual Basic
Public Shared Function GetLastPostfix ( _
    text As String, _
    delimiter As Char, _
    defaultValue As String _
) As String
Visual C++
public:
static String^ GetLastPostfix(
    String^ text,
    wchar_t delimiter,
    String^ defaultValue
)

Parameters

text
Type: System..::..String
A string
delimiter
Type: System..::..Char
The character delimiting the postfix from the rest of the string.
defaultValue
Type: System..::..String
Value to return if delimiter is not found in text

Return Value

All characters of the string starting from character after the last occurrence of delimiter.

If delimiter is not found in the string, defaultValue is returned.

Examples

CopyC#
string postfix = StringUtil.GetPostfix("sc:menu:new", ':');
MainUtil.Out(postfix);
 Outputs: new

See Also

StringUtil Class
GetLastPostfix Overload
Sitecore Namespace
StringUtil..::..GetPostfix(String, Char, String)


GetLongestPrefix Method

[image] [image]

Sitecore 6.4.1 API
StringUtil..::..GetLongestPrefix Method
StringUtil Class See Also Send Feedback

Overload List

Name | Description
GetLongestPrefix(String, Char) | Gets the longest prefix.
GetLongestPrefix(String, Char, String) | Gets the longest prefix.

See Also

StringUtil Class
StringUtil Members
Sitecore Namespace


GetLongestPrefix Method (String, Char)

[image]

Sitecore 6.4.1 API
StringUtil..::..GetLongestPrefix Method (String, Char)
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetLongestPrefix(
    string text,
    char delimiter
)
Visual Basic
Public Shared Function GetLongestPrefix ( _
    text As String, _
    delimiter As Char _
) As String
Visual C++
public:
static String^ GetLongestPrefix(
    String^ text,
    wchar_t delimiter
)

Parameters

text
Type: System..::..String
The text.
delimiter
Type: System..::..Char
The delimiter.

Return Value

[Missing <returns> documentation for "M:Sitecore.StringUtil.GetLongestPrefix(System.String,System.Char)"]

See Also

StringUtil Class
GetLongestPrefix Overload
Sitecore Namespace


GetNameValues Method

[image] [image]

Sitecore 6.4.1 API
StringUtil..::..GetNameValues Method
StringUtil Class See Also Send Feedback

Overload List

Name | Description
GetNameValues(String) | Converts a string to a name/value collection.
GetNameValues(array<String>[]()[][]) | Gets a name/value collection from a string array.
GetNameValues(String, Char, Char) | Converts a string to a name/value collection.

See Also

StringUtil Class
StringUtil Members
Sitecore Namespace


GetNameValues Method (String)

[image]

Sitecore 6.4.1 API
StringUtil..::..GetNameValues Method (String)
StringUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static NameValueCollection GetNameValues(
    string list
)
Visual Basic
Public Shared Function GetNameValues ( _
    list As String _
) As NameValueCollection
Visual C++
public:
static NameValueCollection^ GetNameValues(
    String^ list
)

Parameters

list
Type: System..::..String
A string of separated values.

Return Value

A name/value collection.

Remarks

The format of the string must be "name=value|name=value...". The name/value collection is built by using values from the string in pairs. A string consisting of "Name1=Value1|Name2=Value2" are converted to ("Name1", "Value1"), ("Name2", "Value2").

Examples

CopyC#
NameValueCollection collection = StringUtil.GetNameValues("Name1=Value1|Name2=Value2");

See Also

StringUtil Class
GetNameValues Overload
Sitecore Namespace


GetNameValues Method (String[])

[image]

Sitecore 6.4.1 API
StringUtil..::..GetNameValues Method (array<String>[]()[][])
StringUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static NameValueCollection GetNameValues(
    string[] list
)
Visual Basic
Public Shared Function GetNameValues ( _
    list As String() _
) As NameValueCollection
Visual C++
public:
static NameValueCollection^ GetNameValues(
    array<String^>^ list
)

Parameters

list
Type: array< System..::..String >[]()[][]
An array of strings.

Return Value

A name/value collection.

Remarks

The name/value collection is built by using values from the string array in pairs. A string array consisting of { "Name1, "Value1", "Name2", "Value2" } are converted to ("Name1", "Value1"), ("Name2", "Value2").

Examples

CopyC#
NameValueCollection collection = StringUtil.GetNameValues(new string[] {"Name1", "Value1", "Name2", "Value2" });

See Also

StringUtil Class
GetNameValues Overload
Sitecore Namespace


GetNameValues Method (String, Char, Char)

[image]

Sitecore 6.4.1 API
StringUtil..::..GetNameValues Method (String, Char, Char)
StringUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static NameValueCollection GetNameValues(
    string list,
    char equal,
    char separator
)
Visual Basic
Public Shared Function GetNameValues ( _
    list As String, _
    equal As Char, _
    separator As Char _
) As NameValueCollection
Visual C++
public:
static NameValueCollection^ GetNameValues(
    String^ list,
    wchar_t equal,
    wchar_t separator
)

Parameters

list
Type: System..::..String
A string of separated values.
equal
Type: System..::..Char
Name/value pair separator.
separator
Type: System..::..Char
Pair separator.

Return Value

A name/value collection.

Remarks

The name/value collection is built by using values from the string in pairs. A string consisting of "Name1=Value1|Name2=Value2" are converted to ("Name1", "Value1"), ("Name2", "Value2").

Examples

CopyC#
NameValueCollection collection = StringUtil.GetNameValues("Name1=Value1|Name2=Value2", '=', '|');

See Also

StringUtil Class
GetNameValues Overload
Sitecore Namespace


GetPostfix Method

[image] [image]

Sitecore 6.4.1 API
StringUtil..::..GetPostfix Method
StringUtil Class See Also Send Feedback

Overload List

Name | Description
GetPostfix(String, Char) | Gets the postfix part of a string.
GetPostfix(String, Char, String) | Gets the postfix part of a string.

See Also

StringUtil Class
StringUtil Members
Sitecore Namespace


GetPostfix Method (String, Char)

[image]

Sitecore 6.4.1 API
StringUtil..::..GetPostfix Method (String, Char)
StringUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetPostfix(
    string text,
    char delimiter
)
Visual Basic
Public Shared Function GetPostfix ( _
    text As String, _
    delimiter As Char _
) As String
Visual C++
public:
static String^ GetPostfix(
    String^ text,
    wchar_t delimiter
)

Parameters

text
Type: System..::..String
A string
delimiter
Type: System..::..Char
The character delimiting the postfix from the rest of the string.

Return Value

All characters of the string starting from character after the first occurrence of delimiter.

If delimiter is not found in the string, an empty string is returned.

Examples

CopyC#
string postfix = StringUtil.GetPostfix("sc:menu", ':');
MainUtil.Out(postfix);
 Outputs: menu

See Also

StringUtil Class
GetPostfix Overload
Sitecore Namespace
StringUtil..::..Right(String, Int32)
StringUtil..::..Mid(String, Int32)


GetPostfix Method (String, Char, String)

[image]

Sitecore 6.4.1 API
StringUtil..::..GetPostfix Method (String, Char, String)
StringUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetPostfix(
    string text,
    char delimiter,
    string defaultValue
)
Visual Basic
Public Shared Function GetPostfix ( _
    text As String, _
    delimiter As Char, _
    defaultValue As String _
) As String
Visual C++
public:
static String^ GetPostfix(
    String^ text,
    wchar_t delimiter,
    String^ defaultValue
)

Parameters

text
Type: System..::..String
A string
delimiter
Type: System..::..Char
The character delimiting the postfix from the rest of the string.
defaultValue
Type: System..::..String
Value to return if delimiter is not found in text

Return Value

All characters of the string starting from character after the first occurrence of delimiter.

If delimiter is not found in the string, defaultValue is returned.

Examples

CopyC#
string postfix = StringUtil.GetPostfix("sc:menu", ':');
MainUtil.Out(postfix);
 Outputs: menu

See Also

StringUtil Class
GetPostfix Overload
Sitecore Namespace
StringUtil..::..Right(String, Int32)
StringUtil..::..Mid(String, Int32)


GetPrefix Method

[image] [image]

Sitecore 6.4.1 API
StringUtil..::..GetPrefix Method
StringUtil Class See Also Send Feedback

Overload List

Name | Description
GetPrefix(String, Char) | Gets the prefix part of a string.
GetPrefix(String, Char, String) | Gets the prefix part of a string.

See Also

StringUtil Class
StringUtil Members
Sitecore Namespace


GetPrefix Method (String, Char)

[image]

Sitecore 6.4.1 API
StringUtil..::..GetPrefix Method (String, Char)
StringUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetPrefix(
    string text,
    char delimiter
)
Visual Basic
Public Shared Function GetPrefix ( _
    text As String, _
    delimiter As Char _
) As String
Visual C++
public:
static String^ GetPrefix(
    String^ text,
    wchar_t delimiter
)

Parameters

text
Type: System..::..String
A string
delimiter
Type: System..::..Char
The character delimiting the prefix from the rest of the string.

Return Value

All characters of the string up to the first occurrence of delimiter.

If delimiter is not found in the string, an empty string is returned.

Examples

CopyC#
string prefix = StringUtil.GetPrefix("sc:menu", ':');
MainUtil.Out(prefix);
 Outputs: sc

See Also

StringUtil Class
GetPrefix Overload
Sitecore Namespace
StringUtil..::..Right(String, Int32)
StringUtil..::..Mid(String, Int32)


GetPrefix Method (String, Char, String)

[image]

Sitecore 6.4.1 API
StringUtil..::..GetPrefix Method (String, Char, String)
StringUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetPrefix(
    string text,
    char delimiter,
    string defaultValue
)
Visual Basic
Public Shared Function GetPrefix ( _
    text As String, _
    delimiter As Char, _
    defaultValue As String _
) As String
Visual C++
public:
static String^ GetPrefix(
    String^ text,
    wchar_t delimiter,
    String^ defaultValue
)

Parameters

text
Type: System..::..String
A string
delimiter
Type: System..::..Char
The character delimiting the prefix from the rest of the string.
defaultValue
Type: System..::..String
Value to return if delimiter is not found in text

Return Value

All characters of the string up to the first occurrence of delimiter.

If delimiter is not found in the string, defaultValue is returned.

Examples

CopyC#
string prefix = StringUtil.GetPrefix("sc:menu", ':');
MainUtil.Out(prefix);
 Outputs: sc

See Also

StringUtil Class
GetPrefix Overload
Sitecore Namespace
StringUtil..::..Right(String, Int32)
StringUtil..::..Mid(String, Int32)


GetSizeString Method

[image]

Sitecore 6.4.1 API
StringUtil..::..GetSizeString Method
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetSizeString(
    long size
)
Visual Basic
Public Shared Function GetSizeString ( _
    size As Long _
) As String
Visual C++
public:
static String^ GetSizeString(
    long long size
)

Parameters

size
Type: System..::..Int64
The size.

Return Value

[Missing <returns> documentation for "M:Sitecore.StringUtil.GetSizeString(System.Int64)"]

See Also

StringUtil Class
Sitecore Namespace


GetString Method

[image] [image]

Sitecore 6.4.1 API
StringUtil..::..GetString Method
StringUtil Class See Also Send Feedback

Overload List

Name | Description
GetString(Object) | Gets the string.
GetString(array<String>[]()[][]) | Gets a non-empty string from a list.
GetString(Object, String) | Gets the string.

See Also

StringUtil Class
StringUtil Members
Sitecore Namespace


GetString Method (Object)

[image]

Sitecore 6.4.1 API
StringUtil..::..GetString Method (Object)
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetString(
    Object value
)
Visual Basic
Public Shared Function GetString ( _
    value As Object _
) As String
Visual C++
public:
static String^ GetString(
    Object^ value
)

Parameters

value
Type: System..::..Object
The value.

Return Value

The string.

See Also

StringUtil Class
GetString Overload
Sitecore Namespace


GetString Method (String[])

[image]

Sitecore 6.4.1 API
StringUtil..::..GetString Method (array<String>[]()[][])
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetString(
    params string[] values
)
Visual Basic
Public Shared Function GetString ( _
    ParamArray values As String() _
) As String
Visual C++
public:
static String^ GetString(
    ... array<String^>^ values
)

Parameters

values
Type: array< System..::..String >[]()[][]
The values.

Return Value

The string.

See Also

StringUtil Class
GetString Overload
Sitecore Namespace


GetString Method (Object, String)

[image]

Sitecore 6.4.1 API
StringUtil..::..GetString Method (Object, String)
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetString(
    Object value,
    string defaultValue
)
Visual Basic
Public Shared Function GetString ( _
    value As Object, _
    defaultValue As String _
) As String
Visual C++
public:
static String^ GetString(
    Object^ value,
    String^ defaultValue
)

Parameters

value
Type: System..::..Object
The value.
defaultValue
Type: System..::..String
The default value.

Return Value

The string.

See Also

StringUtil Class
GetString Overload
Sitecore Namespace


IndexOf Method

[image] [image]

Sitecore 6.4.1 API
StringUtil..::..IndexOf Method
StringUtil Class See Also Send Feedback

Overload List

Name | Description
IndexOf(String, array<String>[]()[][]) | Searches for the text and returns the zero-based index of the first occurrence within the entire string.
IndexOf(String, Char, Int32) | Searches for the text and returns the zero-based index of the first occurrence within the entire string.

See Also

StringUtil Class
StringUtil Members
Sitecore Namespace


IndexOf Method (String, String[])

[image]

Sitecore 6.4.1 API
StringUtil..::..IndexOf Method (String, array<String>[]()[][])
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int IndexOf(
    string text,
    string[] texts
)
Visual Basic
Public Shared Function IndexOf ( _
    text As String, _
    texts As String() _
) As Integer
Visual C++
public:
static int IndexOf(
    String^ text,
    array<String^>^ texts
)

Parameters

text
Type: System..::..String
The text.
texts
Type: array< System..::..String >[]()[][]
The texts.

Return Value

[Missing <returns> documentation for "M:Sitecore.StringUtil.IndexOf(System.String,System.String[])"]

See Also

StringUtil Class
IndexOf Overload
Sitecore Namespace


IndexOf Method (String, Char, Int32)

[image]

Sitecore 6.4.1 API
StringUtil..::..IndexOf Method (String, Char, Int32)
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int IndexOf(
    string text,
    char value,
    int occurrence
)
Visual Basic
Public Shared Function IndexOf ( _
    text As String, _
    value As Char, _
    occurrence As Integer _
) As Integer
Visual C++
public:
static int IndexOf(
    String^ text,
    wchar_t value,
    int occurrence
)

Parameters

text
Type: System..::..String
The text.
value
Type: System..::..Char
The value.
occurrence
Type: System..::..Int32
The occurrence.

Return Value

[Missing <returns> documentation for "M:Sitecore.StringUtil.IndexOf(System.String,System.Char,System.Int32)"]

See Also

StringUtil Class
IndexOf Overload
Sitecore Namespace


IsWhiteSpace Method

[image]

Sitecore 6.4.1 API
StringUtil..::..IsWhiteSpace Method
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsWhiteSpace(
    string s
)
Visual Basic
Public Shared Function IsWhiteSpace ( _
    s As String _
) As Boolean
Visual C++
public:
static bool IsWhiteSpace(
    String^ s
)

Parameters

s
Type: System..::..String
The s.

Return Value

true if [is white space] [the specified s]; otherwise, false.

See Also

StringUtil Class
Sitecore Namespace


Join Method

[image] [image]

Sitecore 6.4.1 API
StringUtil..::..Join Method
StringUtil Class See Also Send Feedback

Overload List

Name | Description
Join(IEnumerable, String) | Joins the specified enumerable.
Join(IEnumerable, String, String) | Joins the specified enumerable.

See Also

StringUtil Class
StringUtil Members
Sitecore Namespace


Join Method (IEnumerable, String)

[image]

Sitecore 6.4.1 API
StringUtil..::..Join Method (IEnumerable, String)
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Join(
    IEnumerable enumerable,
    string separator
)
Visual Basic
Public Shared Function Join ( _
    enumerable As IEnumerable, _
    separator As String _
) As String
Visual C++
public:
static String^ Join(
    IEnumerable^ enumerable,
    String^ separator
)

Parameters

enumerable
Type: System.Collections..::..IEnumerable
The enumerable.
separator
Type: System..::..String
The separator.

Return Value

The join.

See Also

StringUtil Class
Join Overload
Sitecore Namespace


Join Method (IEnumerable, String, String)

[image]

Sitecore 6.4.1 API
StringUtil..::..Join Method (IEnumerable, String, String)
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Join(
    IEnumerable enumerable,
    string separator,
    string propertyName
)
Visual Basic
Public Shared Function Join ( _
    enumerable As IEnumerable, _
    separator As String, _
    propertyName As String _
) As String
Visual C++
public:
static String^ Join(
    IEnumerable^ enumerable,
    String^ separator,
    String^ propertyName
)

Parameters

enumerable
Type: System.Collections..::..IEnumerable
The enumerable.
separator
Type: System..::..String
The separator.
propertyName
Type: System..::..String
Name of the property.

Return Value

The join.

See Also

StringUtil Class
Join Overload
Sitecore Namespace


Left Method

[image]

Sitecore 6.4.1 API
StringUtil..::..Left Method
StringUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Left(
    string text,
    int length
)
Visual Basic
Public Shared Function Left ( _
    text As String, _
    length As Integer _
) As String
Visual C++
public:
static String^ Left(
    String^ text,
    int length
)

Parameters

text
Type: System..::..String
A string
length
Type: System..::..Int32
The number of character to return.

Return Value

The first length characters of the string.

Examples

CopyC#
string left = StringUtil.Left("Hello world", 5); // "Hello"

See Also

StringUtil Class
Sitecore Namespace
StringUtil..::..Right(String, Int32)
StringUtil..::..Mid(String, Int32)


Mid Method

[image] [image]

Sitecore 6.4.1 API
StringUtil..::..Mid Method
StringUtil Class See Also Send Feedback

Overload List

Name | Description
Mid(String, Int32) | Gets the middle part of a string.
Mid(String, Int32, Int32) | Gets the middle part of a string.

See Also

StringUtil Class
StringUtil Members
Sitecore Namespace


Mid Method (String, Int32)

[image]

Sitecore 6.4.1 API
StringUtil..::..Mid Method (String, Int32)
StringUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Mid(
    string text,
    int start
)
Visual Basic
Public Shared Function Mid ( _
    text As String, _
    start As Integer _
) As String
Visual C++
public:
static String^ Mid(
    String^ text,
    int start
)

Parameters

text
Type: System..::..String
A string.
start
Type: System..::..Int32
The starting index into the string.

Return Value

The rightmost part of the string starting at the start position.

Remarks

If start is greater than the length of the string, the blank is returned.

Examples

CopyC#
string result = StringUtil.Mid("Hello world", 6); / "world"

See Also

StringUtil Class
Mid Overload
Sitecore Namespace
StringUtil..::..Left(String, Int32)
StringUtil..::..Right(String, Int32)


Mid Method (String, Int32, Int32)

[image]

Sitecore 6.4.1 API
StringUtil..::..Mid Method (String, Int32, Int32)
StringUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Mid(
    string text,
    int start,
    int length
)
Visual Basic
Public Shared Function Mid ( _
    text As String, _
    start As Integer, _
    length As Integer _
) As String
Visual C++
public:
static String^ Mid(
    String^ text,
    int start,
    int length
)

Parameters

text
Type: System..::..String
A string.
start
Type: System..::..Int32
The starting index into the string.
length
Type: System..::..Int32
The number of returned characters

Return Value

The rightmost part of the string starting at the start position.

Remarks

Examples

CopyC#
string result = StringUtil.Mid("Hello world", 6, 3); / "wor"

See Also

StringUtil Class
Mid Overload
Sitecore Namespace
StringUtil..::..Left(String, Int32)
StringUtil..::..Right(String, Int32)


NameValuesToDictionary Method

[image]

Sitecore 6.4.1 API
StringUtil..::..NameValuesToDictionary Method
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static SafeDictionary<string> NameValuesToDictionary(
    NameValueCollection values
)
Visual Basic
Public Shared Function NameValuesToDictionary ( _
    values As NameValueCollection _
) As SafeDictionary(Of String)
Visual C++
public:
static SafeDictionary<String^>^ NameValuesToDictionary(
    NameValueCollection^ values
)

Parameters

values
Type: System.Collections.Specialized..::..NameValueCollection
The values.

Return Value

The values to dictionary.

See Also

StringUtil Class
Sitecore Namespace


NameValuesToString Method

[image] [image]

Sitecore 6.4.1 API
StringUtil..::..NameValuesToString Method
StringUtil Class See Also Send Feedback

Overload List

Name | Description
NameValuesToString(NameValueCollection) | Names the values to string.
NameValuesToString(NameValueCollection, String) | Names the values to string.

See Also

StringUtil Class
StringUtil Members
Sitecore Namespace


NameValuesToString Method (NameValueCollection, String)

[image]

Sitecore 6.4.1 API
StringUtil..::..NameValuesToString Method (NameValueCollection, String)
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string NameValuesToString(
    NameValueCollection values,
    string divider
)
Visual Basic
Public Shared Function NameValuesToString ( _
    values As NameValueCollection, _
    divider As String _
) As String
Visual C++
public:
static String^ NameValuesToString(
    NameValueCollection^ values,
    String^ divider
)

Parameters

values
Type: System.Collections.Specialized..::..NameValueCollection
The values.
divider
Type: System..::..String
The divider.

Return Value

[Missing <returns> documentation for "M:Sitecore.StringUtil.NameValuesToString(System.Collections.Specialized.NameValueCollection,System.String)"]

See Also

StringUtil Class
NameValuesToString Overload
Sitecore Namespace


ParseArguments Method

[image]

Sitecore 6.4.1 API
StringUtil..::..ParseArguments Method
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string[] ParseArguments(
    string arguments
)
Visual Basic
Public Shared Function ParseArguments ( _
    arguments As String _
) As String()
Visual C++
public:
static array<String^>^ ParseArguments(
    String^ arguments
)

Parameters

arguments
Type: System..::..String
The input string.

Return Value

[Missing <returns> documentation for "M:Sitecore.StringUtil.ParseArguments(System.String)"]

Remarks

The input string has the format: '"String1", "String2"'. This will result in an array with two elements: String1 and String2. To escape the double quote character (") use two consequetive double quotes ("").

See Also

StringUtil Class
Sitecore Namespace


ParseNameValueCollection Method

[image]

Sitecore 6.4.1 API
StringUtil..::..ParseNameValueCollection Method
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static NameValueCollection ParseNameValueCollection(
    string text,
    char nameSeparator,
    char valueSeparator
)
Visual Basic
Public Shared Function ParseNameValueCollection ( _
    text As String, _
    nameSeparator As Char, _
    valueSeparator As Char _
) As NameValueCollection
Visual C++
public:
static NameValueCollection^ ParseNameValueCollection(
    String^ text,
    wchar_t nameSeparator,
    wchar_t valueSeparator
)

Parameters

text
Type: System..::..String
The text.
nameSeparator
Type: System..::..Char
The name separator.
valueSeparator
Type: System..::..Char
The value separator.

Return Value

The name value.

See Also

StringUtil Class
Sitecore Namespace


ParseSizeString Method

[image]

Sitecore 6.4.1 API
StringUtil..::..ParseSizeString Method
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long ParseSizeString(
    string value
)
Visual Basic
Public Shared Function ParseSizeString ( _
    value As String _
) As Long
Visual C++
public:
static long long ParseSizeString(
    String^ value
)

Parameters

value
Type: System..::..String
The value.

Return Value

[Missing <returns> documentation for "M:Sitecore.StringUtil.ParseSizeString(System.String)"]

See Also

StringUtil Class
Sitecore Namespace


ReadPhrase Method

[image]

Sitecore 6.4.1 API
StringUtil..::..ReadPhrase Method
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ReadPhrase(
    string text,
    int start,
    char delimiter,
    char quote,
    out int endPos
)
Visual Basic
Public Shared Function ReadPhrase ( _
    text As String, _
    start As Integer, _
    delimiter As Char, _
    quote As Char, _
    <OutAttribute> ByRef endPos As Integer _
) As String
Visual C++
public:
static String^ ReadPhrase(
    String^ text,
    int start,
    wchar_t delimiter,
    wchar_t quote,
    [OutAttribute] int% endPos
)

Parameters

text
Type: System..::..String
A string.
start
Type: System..::..Int32
Starting position into the string.
delimiter
Type: System..::..Char
A delimiter character.
quote
Type: System..::..Char
A quote character.
endPos
Type: System..::..Int32 %
Returns the ending position.

Return Value

The phrase.

Remarks

A phrase is single word or words within quotes.

See Also

StringUtil Class
Sitecore Namespace


RemoveLineFeeds Method

[image]

Sitecore 6.4.1 API
StringUtil..::..RemoveLineFeeds Method
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string RemoveLineFeeds(
    string text
)
Visual Basic
Public Shared Function RemoveLineFeeds ( _
    text As String _
) As String
Visual C++
public:
static String^ RemoveLineFeeds(
    String^ text
)

Parameters

text
Type: System..::..String
The text.

Return Value

[Missing <returns> documentation for "M:Sitecore.StringUtil.RemoveLineFeeds(System.String)"]

See Also

StringUtil Class
Sitecore Namespace


RemovePostfix Method (Char, String)

[image]

Sitecore 6.4.1 API
StringUtil..::..RemovePostfix Method (Char, String)
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string RemovePostfix(
    char postfix,
    string value
)
Visual Basic
Public Shared Function RemovePostfix ( _
    postfix As Char, _
    value As String _
) As String
Visual C++
public:
static String^ RemovePostfix(
    wchar_t postfix,
    String^ value
)

Parameters

postfix
Type: System..::..Char
The postfix.
value
Type: System..::..String
The string value.

Return Value

[Missing <returns> documentation for "M:Sitecore.StringUtil.RemovePostfix(System.Char,System.String)"]

See Also

StringUtil Class
RemovePostfix Overload
Sitecore Namespace


RemovePrefix Method

[image] [image]

Sitecore 6.4.1 API
StringUtil..::..RemovePrefix Method
StringUtil Class See Also Send Feedback

Overload List

Name | Description
RemovePrefix(Char, String) | Removes a prefix from a string.
RemovePrefix(String, String) | Removes a specific prefix from a string.

See Also

StringUtil Class
StringUtil Members
Sitecore Namespace


RemovePrefix Method (Char, String)

[image]

Sitecore 6.4.1 API
StringUtil..::..RemovePrefix Method (Char, String)
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string RemovePrefix(
    char prefix,
    string value
)
Visual Basic
Public Shared Function RemovePrefix ( _
    prefix As Char, _
    value As String _
) As String
Visual C++
public:
static String^ RemovePrefix(
    wchar_t prefix,
    String^ value
)

Parameters

prefix
Type: System..::..Char
The prefix.
value
Type: System..::..String
The string value.

Return Value

[Missing <returns> documentation for "M:Sitecore.StringUtil.RemovePrefix(System.Char,System.String)"]

See Also

StringUtil Class
RemovePrefix Overload
Sitecore Namespace


RemovePrefix Method (String, String)

[image]

Sitecore 6.4.1 API
StringUtil..::..RemovePrefix Method (String, String)
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string RemovePrefix(
    string prefix,
    string value
)
Visual Basic
Public Shared Function RemovePrefix ( _
    prefix As String, _
    value As String _
) As String
Visual C++
public:
static String^ RemovePrefix(
    String^ prefix,
    String^ value
)

Parameters

prefix
Type: System..::..String
The prefix.
value
Type: System..::..String
The value.

Return Value

[Missing <returns> documentation for "M:Sitecore.StringUtil.RemovePrefix(System.String,System.String)"]

See Also

StringUtil Class
RemovePrefix Overload
Sitecore Namespace


RemoveTags Method

[image]

Sitecore 6.4.1 API
StringUtil..::..RemoveTags Method
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string RemoveTags(
    string text
)
Visual Basic
Public Shared Function RemoveTags ( _
    text As String _
) As String
Visual C++
public:
static String^ RemoveTags(
    String^ text
)

Parameters

text
Type: System..::..String
The text.

Return Value

[Missing <returns> documentation for "M:Sitecore.StringUtil.RemoveTags(System.String)"]

See Also

StringUtil Class
Sitecore Namespace


Repeat Method

[image]

Sitecore 6.4.1 API
StringUtil..::..Repeat Method
StringUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Repeat(
    string s,
    int nCount
)
Visual Basic
Public Shared Function Repeat ( _
    s As String, _
    nCount As Integer _
) As String
Visual C++
public:
static String^ Repeat(
    String^ s,
    int nCount
)

Parameters

s
Type: System..::..String
The string to be repeated.
nCount
Type: System..::..Int32
The number of times the string should be repeated.

Return Value

The string repeated the number of times.

Examples

CopyC#
string text = MainUtil.Repeat("abc", 3); // "abcabcabc"

See Also

StringUtil Class
Sitecore Namespace


Replace Method

[image]

Sitecore 6.4.1 API
StringUtil..::..Replace Method
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Replace(
    string text,
    char[] find,
    string[] replaceWith
)
Visual Basic
Public Shared Function Replace ( _
    text As String, _
    find As Char(), _
    replaceWith As String() _
) As String
Visual C++
public:
static String^ Replace(
    String^ text,
    array<wchar_t>^ find,
    array<String^>^ replaceWith
)

Parameters

text
Type: System..::..String
The text.
find
Type: array< System..::..Char >[]()[][]
The find.
replaceWith
Type: array< System..::..String >[]()[][]
The replace.

Return Value

[Missing <returns> documentation for "M:Sitecore.StringUtil.Replace(System.String,System.Char[],System.String[])"]

See Also

StringUtil Class
Sitecore Namespace


Right Method

[image]

Sitecore 6.4.1 API
StringUtil..::..Right Method
StringUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Right(
    string text,
    int length
)
Visual Basic
Public Shared Function Right ( _
    text As String, _
    length As Integer _
) As String
Visual C++
public:
static String^ Right(
    String^ text,
    int length
)

Parameters

text
Type: System..::..String
A string.
length
Type: System..::..Int32
The number of characters to return.

Return Value

The rightmost length characters.

Examples

CopyC#
string text = StringUtil.Right("Hello world", 5); // "world"

See Also

StringUtil Class
Sitecore Namespace
StringUtil..::..Left(String, Int32)
StringUtil..::..Mid(String, Int32)


Split Method

[image] [image]

Sitecore 6.4.1 API
StringUtil..::..Split Method
StringUtil Class See Also Send Feedback

Overload List

Name | Description
Split(String, Char, Boolean) | Splits a string, optionally trimming parts.
Split(String, Char, Char) | Splits a string while protecting phrases.

See Also

StringUtil Class
StringUtil Members
Sitecore Namespace


Split Method (String, Char, Boolean)

[image]

Sitecore 6.4.1 API
StringUtil..::..Split Method (String, Char, Boolean)
StringUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string[] Split(
    string text,
    char delimiter,
    bool trim
)
Visual Basic
Public Shared Function Split ( _
    text As String, _
    delimiter As Char, _
    trim As Boolean _
) As String()
Visual C++
public:
static array<String^>^ Split(
    String^ text,
    wchar_t delimiter,
    bool trim
)

Parameters

text
Type: System..::..String
A string.
delimiter
Type: System..::..Char
A delimiter character.
trim
Type: System..::..Boolean
A boolean indicating if the parts should be trimmed.

Return Value

An array list of string parts.

Examples

CopyC#
ArrayList list1 = StringUtil.Split("Hello | world", '|', true); /// "Hello", "world"
ArrayList list2 = StringUtil.Split("Hello | world", '|', false); /// "Hello ", " world"

See Also

StringUtil Class
Split Overload
Sitecore Namespace


Split Method (String, Char, Char)

[image]

Sitecore 6.4.1 API
StringUtil..::..Split Method (String, Char, Char)
StringUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ArrayList Split(
    string text,
    char delimiter,
    char quote
)
Visual Basic
Public Shared Function Split ( _
    text As String, _
    delimiter As Char, _
    quote As Char _
) As ArrayList
Visual C++
public:
static ArrayList^ Split(
    String^ text,
    wchar_t delimiter,
    wchar_t quote
)

Parameters

text
Type: System..::..String
A string.
delimiter
Type: System..::..Char
A delimiter character
quote
Type: System..::..Char
A quoute character.

Return Value

An array list of string parts.

Remarks

A phrase is a word within quotes.

Examples

CopyC#
ArrayList list = StringUtil.Split("Welcome 'Andy Parkinson' to Sitecore", ' ', '''');
// "Welcome", "Andy Parkinson", "to", "Sitecore"

See Also

StringUtil Class
Split Overload
Sitecore Namespace


StringCollectionToString Method

[image] [image]

Sitecore 6.4.1 API
StringUtil..::..StringCollectionToString Method
StringUtil Class See Also Send Feedback

Overload List

Name | Description
StringCollectionToString(StringCollection) | Converts a string collection to a string
StringCollectionToString(StringCollection, String) | Converts a string collection to a string

See Also

StringUtil Class
StringUtil Members
Sitecore Namespace


StringCollectionToString Method (StringCollection, String)

[image]

Sitecore 6.4.1 API
StringUtil..::..StringCollectionToString Method (StringCollection, String)
StringUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string StringCollectionToString(
    StringCollection collection,
    string delimiter
)
Visual Basic
Public Shared Function StringCollectionToString ( _
    collection As StringCollection, _
    delimiter As String _
) As String
Visual C++
public:
static String^ StringCollectionToString(
    StringCollection^ collection,
    String^ delimiter
)

Parameters

collection
Type: System.Collections.Specialized..::..StringCollection
A collection of strings.
delimiter
Type: System..::..String
A string to put between each of the strings in the collection.

Return Value

The strings in collection concatenated with the delimiter in between.

Examples

CopyC#
StringCollection list = new StringCollection();
list.Add("1");
list.Add("2");
list.Add("3");
string result = StringUtil.StringCollectionToString(list, "|"); / "1|2|3"

See Also

StringUtil Class
StringCollectionToString Overload
Sitecore Namespace


TrimEnd Method

[image]

Sitecore 6.4.1 API
StringUtil..::..TrimEnd Method
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string TrimEnd(
    string value,
    int count
)
Visual Basic
Public Shared Function TrimEnd ( _
    value As String, _
    count As Integer _
) As String
Visual C++
public:
static String^ TrimEnd(
    String^ value,
    int count
)

Parameters

value
Type: System..::..String
The value.
count
Type: System..::..Int32
The count.

Return Value

[Missing <returns> documentation for "M:Sitecore.StringUtil.TrimEnd(System.String,System.Int32)"]

See Also

StringUtil Class
Sitecore Namespace


TrimStart Method

[image]

Sitecore 6.4.1 API
StringUtil..::..TrimStart Method
StringUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string TrimStart(
    string value,
    int count
)
Visual Basic
Public Shared Function TrimStart ( _
    value As String, _
    count As Integer _
) As String
Visual C++
public:
static String^ TrimStart(
    String^ value,
    int count
)

Parameters

value
Type: System..::..String
The value.
count
Type: System..::..Int32
The count.

Return Value

[Missing <returns> documentation for "M:Sitecore.StringUtil.TrimStart(System.String,System.Int32)"]

See Also

StringUtil Class
Sitecore Namespace


Unquote Method

[image]

Sitecore 6.4.1 API
StringUtil..::..Unquote Method
StringUtil Class Example See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Unquote(
    string text
)
Visual Basic
Public Shared Function Unquote ( _
    text As String _
) As String
Visual C++
public:
static String^ Unquote(
    String^ text
)

Parameters

text
Type: System..::..String
A string.

Return Value

The unquoted string.

Examples

CopyC#
string s0 = StringUtil.Unquote("'Hello world'"); // "Hello world"
string s1 = StringUtil.Unquote("'Hello Andy's world'"); // "Hello Andy's world"

See Also

StringUtil Class
Sitecore Namespace


SystemFieldIDs Class

[image]

Sitecore 6.4.1 API
SystemFieldIDs Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public static class SystemFieldIDs
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public NotInheritable Class SystemFieldIDs
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public ref class SystemFieldIDs abstract sealed

Remarks

The class does not contain any functionality, but serves only as a placeholder for a predefined GUIDs.

Inheritance Hierarchy

System..::..Object
Sitecore..::..SystemFieldIDs

See Also

SystemFieldIDs Members
Sitecore Namespace


SystemFieldIDs Members

[image] [image]

Sitecore 6.4.1 API
SystemFieldIDs Members
SystemFieldIDs Class Fields See Also Send Feedback

The SystemFieldIDs type exposes the following members.

Fields

Name | Description
FieldVersioning | The id of the 'Field versioning' field.
MasterId | The id of the 'Master id' field.
Name | The id of the 'Name' field.
TemplateId | The id of the 'Template id' field.

See Also

SystemFieldIDs Class
Sitecore Namespace


SystemFieldIDs Fields

[image] [image]

Sitecore 6.4.1 API
SystemFieldIDs Fields
SystemFieldIDs Class See Also Send Feedback

The SystemFieldIDs type exposes the following members.

Fields

Name | Description
FieldVersioning | The id of the 'Field versioning' field.
MasterId | The id of the 'Master id' field.
Name | The id of the 'Name' field.
TemplateId | The id of the 'Template id' field.

See Also

SystemFieldIDs Class
Sitecore Namespace


FieldVersioning Field

[image]

Sitecore 6.4.1 API
SystemFieldIDs..::..FieldVersioning Field
SystemFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Guid FieldVersioning
Visual Basic
Public Shared FieldVersioning As Guid
Visual C++
public:
static Guid FieldVersioning

See Also

SystemFieldIDs Class
Sitecore Namespace


MasterId Field

[image]

Sitecore 6.4.1 API
SystemFieldIDs..::..MasterId Field
SystemFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Guid MasterId
Visual Basic
Public Shared MasterId As Guid
Visual C++
public:
static Guid MasterId

See Also

SystemFieldIDs Class
Sitecore Namespace


Name Field

[image]

Sitecore 6.4.1 API
SystemFieldIDs..::..Name Field
SystemFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Guid Name
Visual Basic
Public Shared Name As Guid
Visual C++
public:
static Guid Name

See Also

SystemFieldIDs Class
Sitecore Namespace


TemplateId Field

[image]

Sitecore 6.4.1 API
SystemFieldIDs..::..TemplateId Field
SystemFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Guid TemplateId
Visual Basic
Public Shared TemplateId As Guid
Visual C++
public:
static Guid TemplateId

See Also

SystemFieldIDs Class
Sitecore Namespace


TemplateFieldIDs Class

[image]

Sitecore 6.4.1 API
TemplateFieldIDs Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class TemplateFieldIDs
Visual Basic
Public NotInheritable Class TemplateFieldIDs
Visual C++
public ref class TemplateFieldIDs abstract sealed

Remarks

The class does not contain any functionality, but serves only as a placeholder for a predefined GUIDs.

Inheritance Hierarchy

System..::..Object
Sitecore..::..TemplateFieldIDs

See Also

TemplateFieldIDs Members
Sitecore Namespace


TemplateFieldIDs Fields

[image] [image]

Sitecore 6.4.1 API
TemplateFieldIDs Fields
TemplateFieldIDs Class See Also Send Feedback

The TemplateFieldIDs type exposes the following members.

Fields

Name | Description
Blob | The ID of the 'Blob' field.
DefaultValue | The ID of the 'Default value' field.
Description | The ID of the Description 'Long description' field.
ExcludeFromTextSearch | The ID for ExcludeFromTextSearch field
HelpLink | The ID of the 'Help link' field.
ResetBlank | The ID of the 'Reset blank' field.
Shared | The ID of the Shared field.
Source | The ID of the Source field.
Title | The ID of the Title field.
ToolTip | The ID of the ToolTip ('Short description') field.
Type | The ID of the Type field.
Unversioned | The ID of the Unversioned field.
Validation | The ID of the Validation field.
ValidationText | The ID of the ValidationText field.

See Also

TemplateFieldIDs Class
Sitecore Namespace


Blob Field

[image]

Sitecore 6.4.1 API
TemplateFieldIDs..::..Blob Field
TemplateFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Blob
Visual Basic
Public Shared Blob As ID
Visual C++
public:
static ID^ Blob

See Also

TemplateFieldIDs Class
Sitecore Namespace


DefaultValue Field

[image]

Sitecore 6.4.1 API
TemplateFieldIDs..::..DefaultValue Field
TemplateFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID DefaultValue
Visual Basic
Public Shared DefaultValue As ID
Visual C++
public:
static ID^ DefaultValue

See Also

TemplateFieldIDs Class
Sitecore Namespace


Description Field

[image]

Sitecore 6.4.1 API
TemplateFieldIDs..::..Description Field
TemplateFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Description
Visual Basic
Public Shared Description As ID
Visual C++
public:
static ID^ Description

See Also

TemplateFieldIDs Class
Sitecore Namespace


ExcludeFromTextSearch Field

[image]

Sitecore 6.4.1 API
TemplateFieldIDs..::..ExcludeFromTextSearch Field
TemplateFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID ExcludeFromTextSearch
Visual Basic
Public Shared ExcludeFromTextSearch As ID
Visual C++
public:
static ID^ ExcludeFromTextSearch

See Also

TemplateFieldIDs Class
Sitecore Namespace


HelpLink Field

[image]

Sitecore 6.4.1 API
TemplateFieldIDs..::..HelpLink Field
TemplateFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID HelpLink
Visual Basic
Public Shared HelpLink As ID
Visual C++
public:
static ID^ HelpLink

See Also

TemplateFieldIDs Class
Sitecore Namespace


Shared Field

[image]

Sitecore 6.4.1 API
TemplateFieldIDs..::..Shared Field
TemplateFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Shared
Visual Basic
Public Shared Shared As ID
Visual C++
public:
static ID^ Shared

See Also

TemplateFieldIDs Class
Sitecore Namespace


Source Field

[image]

Sitecore 6.4.1 API
TemplateFieldIDs..::..Source Field
TemplateFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Source
Visual Basic
Public Shared Source As ID
Visual C++
public:
static ID^ Source

See Also

TemplateFieldIDs Class
Sitecore Namespace


Title Field

[image]

Sitecore 6.4.1 API
TemplateFieldIDs..::..Title Field
TemplateFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Title
Visual Basic
Public Shared Title As ID
Visual C++
public:
static ID^ Title

See Also

TemplateFieldIDs Class
Sitecore Namespace


ToolTip Field

[image]

Sitecore 6.4.1 API
TemplateFieldIDs..::..ToolTip Field
TemplateFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID ToolTip
Visual Basic
Public Shared ToolTip As ID
Visual C++
public:
static ID^ ToolTip

See Also

TemplateFieldIDs Class
Sitecore Namespace


Type Field

[image]

Sitecore 6.4.1 API
TemplateFieldIDs..::..Type Field
TemplateFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Type
Visual Basic
Public Shared Type As ID
Visual C++
public:
static ID^ Type

See Also

TemplateFieldIDs Class
Sitecore Namespace


Unversioned Field

[image]

Sitecore 6.4.1 API
TemplateFieldIDs..::..Unversioned Field
TemplateFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Unversioned
Visual Basic
Public Shared Unversioned As ID
Visual C++
public:
static ID^ Unversioned

See Also

TemplateFieldIDs Class
Sitecore Namespace


Validation Field

[image]

Sitecore 6.4.1 API
TemplateFieldIDs..::..Validation Field
TemplateFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Validation
Visual Basic
Public Shared Validation As ID
Visual C++
public:
static ID^ Validation

See Also

TemplateFieldIDs Class
Sitecore Namespace


ValidationText Field

[image]

Sitecore 6.4.1 API
TemplateFieldIDs..::..ValidationText Field
TemplateFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID ValidationText
Visual Basic
Public Shared ValidationText As ID
Visual C++
public:
static ID^ ValidationText

See Also

TemplateFieldIDs Class
Sitecore Namespace


TemplateIDs Class

[image]

Sitecore 6.4.1 API
TemplateIDs Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class TemplateIDs
Visual Basic
Public NotInheritable Class TemplateIDs
Visual C++
public ref class TemplateIDs abstract sealed

Remarks

The class does not contain any functionality, but serves only as a placeholder for a predefined GUIDs.

Inheritance Hierarchy

System..::..Object
Sitecore..::..TemplateIDs

See Also

TemplateIDs Members
Sitecore Namespace


TemplateIDs Members

[image] [image]

Sitecore 6.4.1 API
TemplateIDs Members
TemplateIDs Class Fields See Also Send Feedback

The TemplateIDs type exposes the following members.

Fields

Name | Description
Alias | The ID of 'System/Alias'.
Application | The ID of 'Sitecore Client/Applications/Application'.
ArchivedItem | The ID of 'System/Archiving/Archived item'.
BranchTemplate | The ID of 'System/Branches/Branch'.
BranchTemplateFolder | The ID of 'System/Branches/Branch Folder'.
Command | The ID of 'Commands/Command item'.
CommandGroup | The ID of 'Commands/CommandGroup item'.
CommandMaster | The ID of 'System/Masters/Command Master'.
Device | The ID of 'System/Layout/Device'.
DictionaryEntry | The ID of 'System/Dictionary/DictionaryEntry'.
Domain | The ID of 'System/Security/Domain'.
DynamicMaster | The ID of 'System/Masters/Dynamic Master'.
File | The ID of all MediaItems.
Folder | The ID of 'Folder'.
Image | The ID of 'Versioned/Image'.
Language | The ID of 'System/Language'.
Layout | The ID of 'System/Layout/Layout'.
LayoutGroup | The ID of 'System/Layout/Layout group'.
LinkedDatabase | The ID of 'System/LinkedDatabase'.
MainSection | The ID of 'MainSection'.
MediaFolder | The ID of 'Media folder'.
MenuDivider | The ID of 'System/Menus/Menu Divider'.
MenuItem | The ID of 'System/Menus/Menu Item'.
Node | The ID of 'Node'.
PackageRegistration | The ID of 'Packages/Package registration'.
Property | The ID of 'Property'.
Proxy | The ID of 'System/Proxy'.
Reference | The ID of 'System/Reference'.
RenderingGroup | The ID of 'System/Layout/Rendering group'.
Role | The ID of the 'Security/Role'.
Schedule | The ID of 'System/Tasks/Schedule'.
StandardTemplate | The ID of 'System/Standard template'.
Sublayout | The ID of 'Sublayout'.
Template | The ID of 'System/Template'.
TemplateField | The ID of the 'System/Template field'.
TemplateFieldType | The ID of the 'System/Template field type'.
TemplateFolder | The ID of 'System/Template Folder'.
TemplateSection | The ID of the 'System/Template section'.
UnversionedImage | The ID of 'Unversioned/Image'.
User | The ID of the 'Security/User'.
VersionedImage | The ID of 'Versioned/Image'.
Workflow | The ID of the 'System/Workflow/Workflow'.
WorkflowCommand | The ID of the 'System/Workflow/Command'.
WorkflowState | The ID of the 'System/Workflow/State'.
XMLLayout | The ID of 'System/Layout/XML Layout'.
XSLRendering | The ID of the 'XSL rendering'.

See Also

TemplateIDs Class
Sitecore Namespace


TemplateIDs Fields

[image] [image]

Sitecore 6.4.1 API
TemplateIDs Fields
TemplateIDs Class See Also Send Feedback

The TemplateIDs type exposes the following members.

Fields

Name | Description
Alias | The ID of 'System/Alias'.
Application | The ID of 'Sitecore Client/Applications/Application'.
ArchivedItem | The ID of 'System/Archiving/Archived item'.
BranchTemplate | The ID of 'System/Branches/Branch'.
BranchTemplateFolder | The ID of 'System/Branches/Branch Folder'.
Command | The ID of 'Commands/Command item'.
CommandGroup | The ID of 'Commands/CommandGroup item'.
CommandMaster | The ID of 'System/Masters/Command Master'.
Device | The ID of 'System/Layout/Device'.
DictionaryEntry | The ID of 'System/Dictionary/DictionaryEntry'.
Domain | The ID of 'System/Security/Domain'.
DynamicMaster | The ID of 'System/Masters/Dynamic Master'.
File | The ID of all MediaItems.
Folder | The ID of 'Folder'.
Image | The ID of 'Versioned/Image'.
Language | The ID of 'System/Language'.
Layout | The ID of 'System/Layout/Layout'.
LayoutGroup | The ID of 'System/Layout/Layout group'.
LinkedDatabase | The ID of 'System/LinkedDatabase'.
MainSection | The ID of 'MainSection'.
MediaFolder | The ID of 'Media folder'.
MenuDivider | The ID of 'System/Menus/Menu Divider'.
MenuItem | The ID of 'System/Menus/Menu Item'.
Node | The ID of 'Node'.
PackageRegistration | The ID of 'Packages/Package registration'.
Property | The ID of 'Property'.
Proxy | The ID of 'System/Proxy'.
Reference | The ID of 'System/Reference'.
RenderingGroup | The ID of 'System/Layout/Rendering group'.
Role | The ID of the 'Security/Role'.
Schedule | The ID of 'System/Tasks/Schedule'.
StandardTemplate | The ID of 'System/Standard template'.
Sublayout | The ID of 'Sublayout'.
Template | The ID of 'System/Template'.
TemplateField | The ID of the 'System/Template field'.
TemplateFieldType | The ID of the 'System/Template field type'.
TemplateFolder | The ID of 'System/Template Folder'.
TemplateSection | The ID of the 'System/Template section'.
UnversionedImage | The ID of 'Unversioned/Image'.
User | The ID of the 'Security/User'.
VersionedImage | The ID of 'Versioned/Image'.
Workflow | The ID of the 'System/Workflow/Workflow'.
WorkflowCommand | The ID of the 'System/Workflow/Command'.
WorkflowState | The ID of the 'System/Workflow/State'.
XMLLayout | The ID of 'System/Layout/XML Layout'.
XSLRendering | The ID of the 'XSL rendering'.

See Also

TemplateIDs Class
Sitecore Namespace


Alias Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..Alias Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Alias
Visual Basic
Public Shared Alias As ID
Visual C++
public:
static ID^ Alias

See Also

TemplateIDs Class
Sitecore Namespace


Application Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..Application Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Application
Visual Basic
Public Shared Application As ID
Visual C++
public:
static ID^ Application

See Also

TemplateIDs Class
Sitecore Namespace


ArchivedItem Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..ArchivedItem Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID ArchivedItem
Visual Basic
Public Shared ArchivedItem As ID
Visual C++
public:
static ID^ ArchivedItem

See Also

TemplateIDs Class
Sitecore Namespace


BranchTemplate Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..BranchTemplate Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID BranchTemplate
Visual Basic
Public Shared BranchTemplate As ID
Visual C++
public:
static ID^ BranchTemplate

See Also

TemplateIDs Class
Sitecore Namespace


BranchTemplateFolder Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..BranchTemplateFolder Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID BranchTemplateFolder
Visual Basic
Public Shared BranchTemplateFolder As ID
Visual C++
public:
static ID^ BranchTemplateFolder

See Also

TemplateIDs Class
Sitecore Namespace


Command Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..Command Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Command
Visual Basic
Public Shared Command As ID
Visual C++
public:
static ID^ Command

See Also

TemplateIDs Class
Sitecore Namespace


CommandGroup Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..CommandGroup Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID CommandGroup
Visual Basic
Public Shared CommandGroup As ID
Visual C++
public:
static ID^ CommandGroup

See Also

TemplateIDs Class
Sitecore Namespace


CommandMaster Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..CommandMaster Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID CommandMaster
Visual Basic
Public Shared CommandMaster As ID
Visual C++
public:
static ID^ CommandMaster

See Also

TemplateIDs Class
Sitecore Namespace


Domain Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..Domain Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Domain
Visual Basic
Public Shared Domain As ID
Visual C++
public:
static ID^ Domain

See Also

TemplateIDs Class
Sitecore Namespace


DynamicMaster Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..DynamicMaster Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID DynamicMaster
Visual Basic
Public Shared DynamicMaster As ID
Visual C++
public:
static ID^ DynamicMaster

See Also

TemplateIDs Class
Sitecore Namespace


File Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..File Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly ID File
Visual Basic
Public Shared ReadOnly File As ID
Visual C++
public:
static initonly ID^ File

See Also

TemplateIDs Class
Sitecore Namespace


Folder Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..Folder Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Folder
Visual Basic
Public Shared Folder As ID
Visual C++
public:
static ID^ Folder

See Also

TemplateIDs Class
Sitecore Namespace


Image Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..Image Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Image
Visual Basic
Public Shared Image As ID
Visual C++
public:
static ID^ Image

See Also

TemplateIDs Class
Sitecore Namespace


Language Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..Language Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Language
Visual Basic
Public Shared Language As ID
Visual C++
public:
static ID^ Language

See Also

TemplateIDs Class
Sitecore Namespace


Layout Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..Layout Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Layout
Visual Basic
Public Shared Layout As ID
Visual C++
public:
static ID^ Layout

See Also

TemplateIDs Class
Sitecore Namespace


LayoutGroup Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..LayoutGroup Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID LayoutGroup
Visual Basic
Public Shared LayoutGroup As ID
Visual C++
public:
static ID^ LayoutGroup

See Also

TemplateIDs Class
Sitecore Namespace


LinkedDatabase Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..LinkedDatabase Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID LinkedDatabase
Visual Basic
Public Shared LinkedDatabase As ID
Visual C++
public:
static ID^ LinkedDatabase

See Also

TemplateIDs Class
Sitecore Namespace


MainSection Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..MainSection Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID MainSection
Visual Basic
Public Shared MainSection As ID
Visual C++
public:
static ID^ MainSection

See Also

TemplateIDs Class
Sitecore Namespace


MediaFolder Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..MediaFolder Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID MediaFolder
Visual Basic
Public Shared MediaFolder As ID
Visual C++
public:
static ID^ MediaFolder

See Also

TemplateIDs Class
Sitecore Namespace


MenuDivider Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..MenuDivider Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID MenuDivider
Visual Basic
Public Shared MenuDivider As ID
Visual C++
public:
static ID^ MenuDivider

See Also

TemplateIDs Class
Sitecore Namespace


MenuItem Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..MenuItem Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID MenuItem
Visual Basic
Public Shared MenuItem As ID
Visual C++
public:
static ID^ MenuItem

See Also

TemplateIDs Class
Sitecore Namespace


Node Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..Node Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Node
Visual Basic
Public Shared Node As ID
Visual C++
public:
static ID^ Node

See Also

TemplateIDs Class
Sitecore Namespace


PackageRegistration Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..PackageRegistration Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID PackageRegistration
Visual Basic
Public Shared PackageRegistration As ID
Visual C++
public:
static ID^ PackageRegistration

See Also

TemplateIDs Class
Sitecore Namespace


Property Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..Property Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Property
Visual Basic
Public Shared Property As ID
Visual C++
public:
static ID^ Property

See Also

TemplateIDs Class
Sitecore Namespace


Proxy Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..Proxy Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Proxy
Visual Basic
Public Shared Proxy As ID
Visual C++
public:
static ID^ Proxy

See Also

TemplateIDs Class
Sitecore Namespace


Reference Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..Reference Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Reference
Visual Basic
Public Shared Reference As ID
Visual C++
public:
static ID^ Reference

See Also

TemplateIDs Class
Sitecore Namespace


RenderingGroup Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..RenderingGroup Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID RenderingGroup
Visual Basic
Public Shared RenderingGroup As ID
Visual C++
public:
static ID^ RenderingGroup

See Also

TemplateIDs Class
Sitecore Namespace


Role Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..Role Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Role
Visual Basic
Public Shared Role As ID
Visual C++
public:
static ID^ Role

See Also

TemplateIDs Class
Sitecore Namespace


Schedule Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..Schedule Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Schedule
Visual Basic
Public Shared Schedule As ID
Visual C++
public:
static ID^ Schedule

See Also

TemplateIDs Class
Sitecore Namespace


StandardTemplate Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..StandardTemplate Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID StandardTemplate
Visual Basic
Public Shared StandardTemplate As ID
Visual C++
public:
static ID^ StandardTemplate

See Also

TemplateIDs Class
Sitecore Namespace


Sublayout Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..Sublayout Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Sublayout
Visual Basic
Public Shared Sublayout As ID
Visual C++
public:
static ID^ Sublayout

See Also

TemplateIDs Class
Sitecore Namespace


Template Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..Template Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Template
Visual Basic
Public Shared Template As ID
Visual C++
public:
static ID^ Template

See Also

TemplateIDs Class
Sitecore Namespace


TemplateField Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..TemplateField Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID TemplateField
Visual Basic
Public Shared TemplateField As ID
Visual C++
public:
static ID^ TemplateField

See Also

TemplateIDs Class
Sitecore Namespace


TemplateFieldType Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..TemplateFieldType Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID TemplateFieldType
Visual Basic
Public Shared TemplateFieldType As ID
Visual C++
public:
static ID^ TemplateFieldType

See Also

TemplateIDs Class
Sitecore Namespace


TemplateFolder Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..TemplateFolder Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID TemplateFolder
Visual Basic
Public Shared TemplateFolder As ID
Visual C++
public:
static ID^ TemplateFolder

See Also

TemplateIDs Class
Sitecore Namespace


TemplateSection Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..TemplateSection Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID TemplateSection
Visual Basic
Public Shared TemplateSection As ID
Visual C++
public:
static ID^ TemplateSection

See Also

TemplateIDs Class
Sitecore Namespace


UnversionedImage Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..UnversionedImage Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID UnversionedImage
Visual Basic
Public Shared UnversionedImage As ID
Visual C++
public:
static ID^ UnversionedImage

See Also

TemplateIDs Class
Sitecore Namespace


User Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..User Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID User
Visual Basic
Public Shared User As ID
Visual C++
public:
static ID^ User

See Also

TemplateIDs Class
Sitecore Namespace


VersionedImage Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..VersionedImage Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID VersionedImage
Visual Basic
Public Shared VersionedImage As ID
Visual C++
public:
static ID^ VersionedImage

See Also

TemplateIDs Class
Sitecore Namespace


Workflow Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..Workflow Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Workflow
Visual Basic
Public Shared Workflow As ID
Visual C++
public:
static ID^ Workflow

See Also

TemplateIDs Class
Sitecore Namespace


WorkflowCommand Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..WorkflowCommand Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID WorkflowCommand
Visual Basic
Public Shared WorkflowCommand As ID
Visual C++
public:
static ID^ WorkflowCommand

See Also

TemplateIDs Class
Sitecore Namespace


WorkflowState Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..WorkflowState Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID WorkflowState
Visual Basic
Public Shared WorkflowState As ID
Visual C++
public:
static ID^ WorkflowState

See Also

TemplateIDs Class
Sitecore Namespace


XMLLayout Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..XMLLayout Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID XMLLayout
Visual Basic
Public Shared XMLLayout As ID
Visual C++
public:
static ID^ XMLLayout

See Also

TemplateIDs Class
Sitecore Namespace


XSLRendering Field

[image]

Sitecore 6.4.1 API
TemplateIDs..::..XSLRendering Field
TemplateIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID XSLRendering
Visual Basic
Public Shared XSLRendering As ID
Visual C++
public:
static ID^ XSLRendering

See Also

TemplateIDs Class
Sitecore Namespace


TemplateSectionFieldIDs Class

[image]

Sitecore 6.4.1 API
TemplateSectionFieldIDs Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class TemplateSectionFieldIDs
Visual Basic
Public NotInheritable Class TemplateSectionFieldIDs
Visual C++
public ref class TemplateSectionFieldIDs abstract sealed

Remarks

The class does not contain any functionality, but serves only as a placeholder for a predefined GUIDs.

Inheritance Hierarchy

System..::..Object
Sitecore..::..TemplateSectionFieldIDs

See Also

TemplateSectionFieldIDs Members
Sitecore Namespace


TemplateSectionFieldIDs Members

[image] [image]

Sitecore 6.4.1 API
TemplateSectionFieldIDs Members
TemplateSectionFieldIDs Class Fields See Also Send Feedback

The TemplateSectionFieldIDs type exposes the following members.

Fields

Name | Description
Control | The ID of the 'Control' field.
HiddenByDefault | The ID of the 'HiddenByDefault' field.
HideFields | The ID of the 'HideFields' field.

See Also

TemplateSectionFieldIDs Class
Sitecore Namespace


TemplateSectionFieldIDs Fields

[image] [image]

Sitecore 6.4.1 API
TemplateSectionFieldIDs Fields
TemplateSectionFieldIDs Class See Also Send Feedback

The TemplateSectionFieldIDs type exposes the following members.

Fields

Name | Description
Control | The ID of the 'Control' field.
HiddenByDefault | The ID of the 'HiddenByDefault' field.
HideFields | The ID of the 'HideFields' field.

See Also

TemplateSectionFieldIDs Class
Sitecore Namespace


Control Field

[image]

Sitecore 6.4.1 API
TemplateSectionFieldIDs..::..Control Field
TemplateSectionFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Control
Visual Basic
Public Shared Control As ID
Visual C++
public:
static ID^ Control

See Also

TemplateSectionFieldIDs Class
Sitecore Namespace


HiddenByDefault Field

[image]

Sitecore 6.4.1 API
TemplateSectionFieldIDs..::..HiddenByDefault Field
TemplateSectionFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID HiddenByDefault
Visual Basic
Public Shared HiddenByDefault As ID
Visual C++
public:
static ID^ HiddenByDefault

See Also

TemplateSectionFieldIDs Class
Sitecore Namespace


HideFields Field

[image]

Sitecore 6.4.1 API
TemplateSectionFieldIDs..::..HideFields Field
TemplateSectionFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID HideFields
Visual Basic
Public Shared HideFields As ID
Visual C++
public:
static ID^ HideFields

See Also

TemplateSectionFieldIDs Class
Sitecore Namespace


TerminatesProgramAttribute Members

[image] [image]

Sitecore 6.4.1 API
TerminatesProgramAttribute Members
TerminatesProgramAttribute Class Constructors Methods Properties See Also Send Feedback

The TerminatesProgramAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | TerminatesProgramAttribute | Initializes a new instance of the TerminatesProgramAttribute class

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

TerminatesProgramAttribute Class
Sitecore Namespace


TerminatesProgramAttribute Constructor

[image]

Sitecore 6.4.1 API
TerminatesProgramAttribute Constructor
TerminatesProgramAttribute Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TerminatesProgramAttribute()
Visual Basic
Public Sub New
Visual C++
public:
TerminatesProgramAttribute()

See Also

TerminatesProgramAttribute Class
Sitecore Namespace


TerminatesProgramAttribute Methods

[image] [image]

Sitecore 6.4.1 API
TerminatesProgramAttribute Methods
TerminatesProgramAttribute Class See Also Send Feedback

The TerminatesProgramAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TerminatesProgramAttribute Class
Sitecore Namespace


TerminatesProgramAttribute Properties

[image] [image]

Sitecore 6.4.1 API
TerminatesProgramAttribute Properties
TerminatesProgramAttribute Class See Also Send Feedback

The TerminatesProgramAttribute type exposes the following members.

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

TerminatesProgramAttribute Class
Sitecore Namespace


Todo Class

[image]

Sitecore 6.4.1 API
Todo Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute]
public static class Todo
Visual Basic
<ObsoleteAttribute> _
Public NotInheritable Class Todo
Visual C++
[ObsoleteAttribute]
public ref class Todo abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore..::..Todo

See Also

Todo Members
Sitecore Namespace


Todo Members

[image] [image]

Sitecore 6.4.1 API
Todo Members
Todo Class Methods See Also Send Feedback

The Todo type exposes the following members.

Methods

Name | Description
AR | Just a mark for some work to be done.
DDZ | Just a mark for some work to be done.
EKO | Just a mark for some work to be done.
JC | Just a mark for some work to be done.
MB | Just a mark for some work to be done.
OT | A mark for some work to be done. Throws an exception if the second parameter equals true.
SMAR | Just a mark for some work to be done.

See Also

Todo Class
Sitecore Namespace


Todo Methods

[image] [image]

Sitecore 6.4.1 API
Todo Methods
Todo Class See Also Send Feedback

The Todo type exposes the following members.

Methods

Name | Description
AR | Just a mark for some work to be done.
DDZ | Just a mark for some work to be done.
EKO | Just a mark for some work to be done.
JC | Just a mark for some work to be done.
MB | Just a mark for some work to be done.
OT | A mark for some work to be done. Throws an exception if the second parameter equals true.
SMAR | Just a mark for some work to be done.

See Also

Todo Class
Sitecore Namespace


AR Method

[image]

Sitecore 6.4.1 API
Todo..::..AR Method
Todo Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void AR(
    params Object[] args
)
Visual Basic
Public Shared Sub AR ( _
    ParamArray args As Object() _
)
Visual C++
public:
static void AR(
    ... array<Object^>^ args
)

Parameters

args
Type: array< System..::..Object >[]()[][]
The arguments.

See Also

Todo Class
Sitecore Namespace


DDZ Method

[image]

Sitecore 6.4.1 API
Todo..::..DDZ Method
Todo Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void DDZ(
    params Object[] args
)
Visual Basic
Public Shared Sub DDZ ( _
    ParamArray args As Object() _
)
Visual C++
public:
static void DDZ(
    ... array<Object^>^ args
)

Parameters

args
Type: array< System..::..Object >[]()[][]
The arguments.

See Also

Todo Class
Sitecore Namespace


EKO Method

[image]

Sitecore 6.4.1 API
Todo..::..EKO Method
Todo Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void EKO(
    params Object[] args
)
Visual Basic
Public Shared Sub EKO ( _
    ParamArray args As Object() _
)
Visual C++
public:
static void EKO(
    ... array<Object^>^ args
)

Parameters

args
Type: array< System..::..Object >[]()[][]
The arguments.

See Also

Todo Class
Sitecore Namespace


JC Method

[image]

Sitecore 6.4.1 API
Todo..::..JC Method
Todo Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void JC(
    params Object[] args
)
Visual Basic
Public Shared Sub JC ( _
    ParamArray args As Object() _
)
Visual C++
public:
static void JC(
    ... array<Object^>^ args
)

Parameters

args
Type: array< System..::..Object >[]()[][]
The args.

See Also

Todo Class
Sitecore Namespace


MB Method

[image]

Sitecore 6.4.1 API
Todo..::..MB Method
Todo Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void MB(
    params Object[] args
)
Visual Basic
Public Shared Sub MB ( _
    ParamArray args As Object() _
)
Visual C++
public:
static void MB(
    ... array<Object^>^ args
)

Parameters

args
Type: array< System..::..Object >[]()[][]
The arguments.

See Also

Todo Class
Sitecore Namespace


OT Method

[image]

Sitecore 6.4.1 API
Todo..::..OT Method
Todo Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void OT(
    string description,
    bool throwException
)
Visual Basic
Public Shared Sub OT ( _
    description As String, _
    throwException As Boolean _
)
Visual C++
public:
static void OT(
    String^ description,
    bool throwException
)

Parameters

description
Type: System..::..String
The description.
throwException
Type: System..::..Boolean
if set to true [throw exception].

See Also

Todo Class
Sitecore Namespace


SMAR Method

[image]

Sitecore 6.4.1 API
Todo..::..SMAR Method
Todo Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void SMAR(
    params Object[] args
)
Visual Basic
Public Shared Sub SMAR ( _
    ParamArray args As Object() _
)
Visual C++
public:
static void SMAR(
    ... array<Object^>^ args
)

Parameters

args
Type: array< System..::..Object >[]()[][]
The arguments.

See Also

Todo Class
Sitecore Namespace


UIUtil Class

[image]

Sitecore 6.4.1 API
UIUtil Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class UIUtil
Visual Basic
Public NotInheritable Class UIUtil
Visual C++
public ref class UIUtil abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore..::..UIUtil

See Also

UIUtil Members
Sitecore Namespace


UIUtil Members

[image] [image]

Sitecore 6.4.1 API
UIUtil Members
UIUtil Class Methods See Also Send Feedback

The UIUtil type exposes the following members.

Methods

Name | Description
AddContentDatabaseParameter(String) | Adds the content database parameter.
AddContentDatabaseParameter(UrlBuilder) | Adds the content database parameter.
AddContentDatabaseParameter(UrlString) | Adds the content database parameter.
AddMessageParameter | Add a parameter to a message.
BrowserHeightToDialogHeight | Converts from browser-reported height to internal dialog height saved in registry.
DialogHeightToBrowserHeight | Converts from internal dialog height to browser-specific dialog height value.
ExpandItemMacros | Substitudes macros from an item.
FindControlByType(Type) | Finds a control by the specified type.
FindControlByType(Control, Type) | Finds a control by the specified type.
FindPopupControl | Find a popup control under the parent.
FormatHeader(String, String) | Formats a header.
FormatHeader(String, String, Boolean) | Formats a header.
GetApplicationFromShortcut | Gets an application item from a shortcut.
GetBrowserClassString | Gets the browser class string.
GetBrowserMajorVersion | Gets browser major version
GetHiddenHolder | Gets the hidden holder.
GetHomeItem | Gets the home item.
GetItemFromQueryString | Gets the item from query string.
GetThumbnailSrc | Gets the thumbnail url
GetUri(String) | Gets a uri.
GetUri(String, UrlString) | Gets a uri.
GetUri(String, String) | Gets a uri.
IsControlUri | Detects if a URI is a control: protocol.
IsFirefox | Determines whether this instance is firefox.
IsIE()()()() | Detects if the current browser is IE.
IsIE(Int32) | Detects if the current browser is IE.
IsWebkit | Determines whether this instance is webkit.
LinkToSearch | Links to search.
ParseStyle | Parses a style string.
StripSitecoreShellPath | Strips the sitecore shell path.
SupportsInlineEditing | Supportses the inline editing.
UseFlashUpload | Uses the flash upload.

See Also

UIUtil Class
Sitecore Namespace


UIUtil Methods

[image] [image]

Sitecore 6.4.1 API
UIUtil Methods
UIUtil Class See Also Send Feedback

The UIUtil type exposes the following members.

Methods

Name | Description
AddContentDatabaseParameter(String) | Adds the content database parameter.
AddContentDatabaseParameter(UrlBuilder) | Adds the content database parameter.
AddContentDatabaseParameter(UrlString) | Adds the content database parameter.
AddMessageParameter | Add a parameter to a message.
BrowserHeightToDialogHeight | Converts from browser-reported height to internal dialog height saved in registry.
DialogHeightToBrowserHeight | Converts from internal dialog height to browser-specific dialog height value.
ExpandItemMacros | Substitudes macros from an item.
FindControlByType(Type) | Finds a control by the specified type.
FindControlByType(Control, Type) | Finds a control by the specified type.
FindPopupControl | Find a popup control under the parent.
FormatHeader(String, String) | Formats a header.
FormatHeader(String, String, Boolean) | Formats a header.
GetApplicationFromShortcut | Gets an application item from a shortcut.
GetBrowserClassString | Gets the browser class string.
GetBrowserMajorVersion | Gets browser major version
GetHiddenHolder | Gets the hidden holder.
GetHomeItem | Gets the home item.
GetItemFromQueryString | Gets the item from query string.
GetThumbnailSrc | Gets the thumbnail url
GetUri(String) | Gets a uri.
GetUri(String, UrlString) | Gets a uri.
GetUri(String, String) | Gets a uri.
IsControlUri | Detects if a URI is a control: protocol.
IsFirefox | Determines whether this instance is firefox.
IsIE()()()() | Detects if the current browser is IE.
IsIE(Int32) | Detects if the current browser is IE.
IsWebkit | Determines whether this instance is webkit.
LinkToSearch | Links to search.
ParseStyle | Parses a style string.
StripSitecoreShellPath | Strips the sitecore shell path.
SupportsInlineEditing | Supportses the inline editing.
UseFlashUpload | Uses the flash upload.

See Also

UIUtil Class
Sitecore Namespace


AddContentDatabaseParameter Method

[image] [image]

Sitecore 6.4.1 API
UIUtil..::..AddContentDatabaseParameter Method
UIUtil Class See Also Send Feedback

Overload List

Name | Description
AddContentDatabaseParameter(String) | Adds the content database parameter.
AddContentDatabaseParameter(UrlBuilder) | Adds the content database parameter.
AddContentDatabaseParameter(UrlString) | Adds the content database parameter.

See Also

UIUtil Class
UIUtil Members
Sitecore Namespace


AddContentDatabaseParameter Method (String)

[image]

Sitecore 6.4.1 API
UIUtil..::..AddContentDatabaseParameter Method (String)
UIUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string AddContentDatabaseParameter(
    string url
)
Visual Basic
Public Shared Function AddContentDatabaseParameter ( _
    url As String _
) As String
Visual C++
public:
static String^ AddContentDatabaseParameter(
    String^ url
)

Parameters

url
Type: System..::..String
The URL.

Return Value

[Missing <returns> documentation for "M:Sitecore.UIUtil.AddContentDatabaseParameter(System.String)"]

See Also

UIUtil Class
AddContentDatabaseParameter Overload
Sitecore Namespace


AddContentDatabaseParameter Method (UrlString)

[image]

Sitecore 6.4.1 API
UIUtil..::..AddContentDatabaseParameter Method (UrlString)
UIUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void AddContentDatabaseParameter(
    UrlString url
)
Visual Basic
Public Shared Sub AddContentDatabaseParameter ( _
    url As UrlString _
)
Visual C++
public:
static void AddContentDatabaseParameter(
    UrlString^ url
)

Parameters

url
Type: Sitecore.Text..::..UrlString
The URL.

See Also

UIUtil Class
AddContentDatabaseParameter Overload
Sitecore Namespace


AddMessageParameter Method

[image]

Sitecore 6.4.1 API
UIUtil..::..AddMessageParameter Method
UIUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string AddMessageParameter(
    string message,
    string name,
    string value
)
Visual Basic
Public Shared Function AddMessageParameter ( _
    message As String, _
    name As String, _
    value As String _
) As String
Visual C++
public:
static String^ AddMessageParameter(
    String^ message,
    String^ name,
    String^ value
)

Parameters

message
Type: System..::..String
The message.
name
Type: System..::..String
The name.
value
Type: System..::..String
The value.

Return Value

[Missing <returns> documentation for "M:Sitecore.UIUtil.AddMessageParameter(System.String,System.String,System.String)"]

See Also

UIUtil Class
Sitecore Namespace


BrowserHeightToDialogHeight Method

[image]

Sitecore 6.4.1 API
UIUtil..::..BrowserHeightToDialogHeight Method
UIUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string BrowserHeightToDialogHeight(
    string height
)
Visual Basic
Public Shared Function BrowserHeightToDialogHeight ( _
    height As String _
) As String
Visual C++
public:
static String^ BrowserHeightToDialogHeight(
    String^ height
)

Parameters

height
Type: System..::..String
The height.

Return Value

The height to dialog height.

See Also

UIUtil Class
Sitecore Namespace


DialogHeightToBrowserHeight Method

[image]

Sitecore 6.4.1 API
UIUtil..::..DialogHeightToBrowserHeight Method
UIUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string DialogHeightToBrowserHeight(
    string height
)
Visual Basic
Public Shared Function DialogHeightToBrowserHeight ( _
    height As String _
) As String
Visual C++
public:
static String^ DialogHeightToBrowserHeight(
    String^ height
)

Parameters

height
Type: System..::..String
Height of the pixel.

Return Value

The height.

See Also

UIUtil Class
Sitecore Namespace


ExpandItemMacros Method

[image]

Sitecore 6.4.1 API
UIUtil..::..ExpandItemMacros Method
UIUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ExpandItemMacros(
    string message,
    string id,
    string name,
    string parentID
)
Visual Basic
Public Shared Function ExpandItemMacros ( _
    message As String, _
    id As String, _
    name As String, _
    parentID As String _
) As String
Visual C++
public:
static String^ ExpandItemMacros(
    String^ message,
    String^ id,
    String^ name,
    String^ parentID
)

Parameters

message
Type: System..::..String
The message.
id
Type: System..::..String
The id.
name
Type: System..::..String
The name.
parentID
Type: System..::..String
The parent ID.

Return Value

[Missing <returns> documentation for "M:Sitecore.UIUtil.ExpandItemMacros(System.String,System.String,System.String,System.String)"]

See Also

UIUtil Class
Sitecore Namespace


FindControlByType Method

[image] [image]

Sitecore 6.4.1 API
UIUtil..::..FindControlByType Method
UIUtil Class See Also Send Feedback

Overload List

Name | Description
FindControlByType(Type) | Finds a control by the specified type.
FindControlByType(Control, Type) | Finds a control by the specified type.

See Also

UIUtil Class
UIUtil Members
Sitecore Namespace


FindControlByType Method (Type)

[image]

Sitecore 6.4.1 API
UIUtil..::..FindControlByType Method (Type)
UIUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Control FindControlByType(
    Type type
)
Visual Basic
Public Shared Function FindControlByType ( _
    type As Type _
) As Control
Visual C++
public:
static Control^ FindControlByType(
    Type^ type
)

Parameters

type
Type: System..::..Type
The type.

Return Value

[Missing <returns> documentation for "M:Sitecore.UIUtil.FindControlByType(System.Type)"]

See Also

UIUtil Class
FindControlByType Overload
Sitecore Namespace


FindControlByType Method (Control, Type)

[image]

Sitecore 6.4.1 API
UIUtil..::..FindControlByType Method (Control, Type)
UIUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Control FindControlByType(
    Control parent,
    Type type
)
Visual Basic
Public Shared Function FindControlByType ( _
    parent As Control, _
    type As Type _
) As Control
Visual C++
public:
static Control^ FindControlByType(
    Control^ parent,
    Type^ type
)

Parameters

parent
Type: System.Web.UI..::..Control
The parent.
type
Type: System..::..Type
The type.

Return Value

[Missing <returns> documentation for "M:Sitecore.UIUtil.FindControlByType(System.Web.UI.Control,System.Type)"]

See Also

UIUtil Class
FindControlByType Overload
Sitecore Namespace


FindPopupControl Method

[image]

Sitecore 6.4.1 API
UIUtil..::..FindPopupControl Method
UIUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Control FindPopupControl(
    Control parent
)
Visual Basic
Public Shared Function FindPopupControl ( _
    parent As Control _
) As Control
Visual C++
public:
static Control^ FindPopupControl(
    Control^ parent
)

Parameters

parent
Type: System.Web.UI..::..Control
The parent control to search.

Return Value

A popup control or null, if none were found.

See Also

UIUtil Class
Sitecore Namespace


FormatHeader Method

[image] [image]

Sitecore 6.4.1 API
UIUtil..::..FormatHeader Method
UIUtil Class See Also Send Feedback

Overload List

Name | Description
FormatHeader(String, String) | Formats a header.
FormatHeader(String, String, Boolean) | Formats a header.

See Also

UIUtil Class
UIUtil Members
Sitecore Namespace


FormatHeader Method (String, String)

[image]

Sitecore 6.4.1 API
UIUtil..::..FormatHeader Method (String, String)
UIUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string FormatHeader(
    string header,
    string headerStyle
)
Visual Basic
Public Shared Function FormatHeader ( _
    header As String, _
    headerStyle As String _
) As String
Visual C++
public:
static String^ FormatHeader(
    String^ header,
    String^ headerStyle
)

Parameters

header
Type: System..::..String
The header.
headerStyle
Type: System..::..String
The header style.

Return Value

[Missing <returns> documentation for "M:Sitecore.UIUtil.FormatHeader(System.String,System.String)"]

See Also

UIUtil Class
FormatHeader Overload
Sitecore Namespace


FormatHeader Method (String, String, Boolean)

[image]

Sitecore 6.4.1 API
UIUtil..::..FormatHeader Method (String, String, Boolean)
UIUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string FormatHeader(
    string header,
    string headerStyle,
    bool translate
)
Visual Basic
Public Shared Function FormatHeader ( _
    header As String, _
    headerStyle As String, _
    translate As Boolean _
) As String
Visual C++
public:
static String^ FormatHeader(
    String^ header,
    String^ headerStyle,
    bool translate
)

Parameters

header
Type: System..::..String
The header.
headerStyle
Type: System..::..String
The header style.
translate
Type: System..::..Boolean
if set to true this instance is translate.

Return Value

[Missing <returns> documentation for "M:Sitecore.UIUtil.FormatHeader(System.String,System.String,System.Boolean)"]

See Also

UIUtil Class
FormatHeader Overload
Sitecore Namespace


GetApplicationFromShortcut Method

[image]

Sitecore 6.4.1 API
UIUtil..::..GetApplicationFromShortcut Method
UIUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item GetApplicationFromShortcut(
    Item item
)
Visual Basic
Public Shared Function GetApplicationFromShortcut ( _
    item As Item _
) As Item
Visual C++
public:
static Item^ GetApplicationFromShortcut(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

[Missing <returns> documentation for "M:Sitecore.UIUtil.GetApplicationFromShortcut(Sitecore.Data.Items.Item)"]

See Also

UIUtil Class
Sitecore Namespace


GetBrowserClassString Method

[image]

Sitecore 6.4.1 API
UIUtil..::..GetBrowserClassString Method
UIUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetBrowserClassString()
Visual Basic
Public Shared Function GetBrowserClassString As String
Visual C++
public:
static String^ GetBrowserClassString()

Return Value

The browser class string.

See Also

UIUtil Class
Sitecore Namespace


GetBrowserMajorVersion Method

[image]

Sitecore 6.4.1 API
UIUtil..::..GetBrowserMajorVersion Method
UIUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int GetBrowserMajorVersion()
Visual Basic
Public Shared Function GetBrowserMajorVersion As Integer
Visual C++
public:
static int GetBrowserMajorVersion()

Return Value

Browser's major version or -1, if HttpRequest is not specified

See Also

UIUtil Class
Sitecore Namespace


GetHiddenHolder Method

[image]

Sitecore 6.4.1 API
UIUtil..::..GetHiddenHolder Method
UIUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Control GetHiddenHolder(
    Control parent
)
Visual Basic
Public Shared Function GetHiddenHolder ( _
    parent As Control _
) As Control
Visual C++
public:
static Control^ GetHiddenHolder(
    Control^ parent
)

Parameters

parent
Type: System.Web.UI..::..Control
The parent.

Return Value

[Missing <returns> documentation for "M:Sitecore.UIUtil.GetHiddenHolder(System.Web.UI.Control)"]

See Also

UIUtil Class
Sitecore Namespace


GetHomeItem Method

[image]

Sitecore 6.4.1 API
UIUtil..::..GetHomeItem Method
UIUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item GetHomeItem(
    User user
)
Visual Basic
Public Shared Function GetHomeItem ( _
    user As User _
) As Item
Visual C++
public:
static Item^ GetHomeItem(
    User^ user
)

Parameters

user
Type: Sitecore.Security.Accounts..::..User
The user.

Return Value

[Missing <returns> documentation for "M:Sitecore.UIUtil.GetHomeItem(Sitecore.Security.Accounts.User)"]

See Also

UIUtil Class
Sitecore Namespace


GetItemFromQueryString Method

[image]

Sitecore 6.4.1 API
UIUtil..::..GetItemFromQueryString Method
UIUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item GetItemFromQueryString(
    Database database
)
Visual Basic
Public Shared Function GetItemFromQueryString ( _
    database As Database _
) As Item
Visual C++
public:
static Item^ GetItemFromQueryString(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.UIUtil.GetItemFromQueryString(Sitecore.Data.Database)"]

See Also

UIUtil Class
Sitecore Namespace


GetThumbnailSrc Method

[image]

Sitecore 6.4.1 API
UIUtil..::..GetThumbnailSrc Method
UIUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetThumbnailSrc(
    Item item,
    int height,
    int width
)
Visual Basic
Public Shared Function GetThumbnailSrc ( _
    item As Item, _
    height As Integer, _
    width As Integer _
) As String
Visual C++
public:
static String^ GetThumbnailSrc(
    Item^ item,
    int height,
    int width
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item to get the thumbnail for
height
Type: System..::..Int32
The thumnbail height
width
Type: System..::..Int32
The thumbnail width

Return Value

The thumbnail url

See Also

UIUtil Class
Sitecore Namespace


GetUri Method

[image] [image]

Sitecore 6.4.1 API
UIUtil..::..GetUri Method
UIUtil Class See Also Send Feedback

Overload List

Name | Description
GetUri(String) | Gets a uri.
GetUri(String, UrlString) | Gets a uri.
GetUri(String, String) | Gets a uri.

See Also

UIUtil Class
UIUtil Members
Sitecore Namespace


GetUri Method (String)

[image]

Sitecore 6.4.1 API
UIUtil..::..GetUri Method (String)
UIUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetUri(
    string uri
)
Visual Basic
Public Shared Function GetUri ( _
    uri As String _
) As String
Visual C++
public:
static String^ GetUri(
    String^ uri
)

Parameters

uri
Type: System..::..String
The URI.

Return Value

[Missing <returns> documentation for "M:Sitecore.UIUtil.GetUri(System.String)"]

Remarks

The takes the control: protocol into account.

See Also

UIUtil Class
GetUri Overload
Sitecore Namespace


GetUri Method (String, UrlString)

[image]

Sitecore 6.4.1 API
UIUtil..::..GetUri Method (String, UrlString)
UIUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetUri(
    string uri,
    UrlString parameters
)
Visual Basic
Public Shared Function GetUri ( _
    uri As String, _
    parameters As UrlString _
) As String
Visual C++
public:
static String^ GetUri(
    String^ uri,
    UrlString^ parameters
)

Parameters

uri
Type: System..::..String
The URI.
parameters
Type: Sitecore.Text..::..UrlString
The parameters.

Return Value

[Missing <returns> documentation for "M:Sitecore.UIUtil.GetUri(System.String,Sitecore.Text.UrlString)"]

Remarks

The takes the control: protocol into account.

See Also

UIUtil Class
GetUri Overload
Sitecore Namespace


GetUri Method (String, String)

[image]

Sitecore 6.4.1 API
UIUtil..::..GetUri Method (String, String)
UIUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetUri(
    string uri,
    string parameters
)
Visual Basic
Public Shared Function GetUri ( _
    uri As String, _
    parameters As String _
) As String
Visual C++
public:
static String^ GetUri(
    String^ uri,
    String^ parameters
)

Parameters

uri
Type: System..::..String
The URI.
parameters
Type: System..::..String
The parameters.

Return Value

[Missing <returns> documentation for "M:Sitecore.UIUtil.GetUri(System.String,System.String)"]

Remarks

The takes the control: protocol into account.

See Also

UIUtil Class
GetUri Overload
Sitecore Namespace


IsControlUri Method

[image]

Sitecore 6.4.1 API
UIUtil..::..IsControlUri Method
UIUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsControlUri(
    string uri
)
Visual Basic
Public Shared Function IsControlUri ( _
    uri As String _
) As Boolean
Visual C++
public:
static bool IsControlUri(
    String^ uri
)

Parameters

uri
Type: System..::..String
The URI.

Return Value

true if [is control URI] [the specified URI]; otherwise, false.

See Also

UIUtil Class
Sitecore Namespace


IsFirefox Method

[image]

Sitecore 6.4.1 API
UIUtil..::..IsFirefox Method
UIUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsFirefox()
Visual Basic
Public Shared Function IsFirefox As Boolean
Visual C++
public:
static bool IsFirefox()

Return Value

true if this instance is firefox; otherwise, false.

See Also

UIUtil Class
Sitecore Namespace


IsIE Method

[image]

Sitecore 6.4.1 API
UIUtil..::..IsIE Method
UIUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsIE()
Visual Basic
Public Shared Function IsIE As Boolean
Visual C++
public:
static bool IsIE()

Return Value

true if this instance is IE; otherwise, false.

See Also

UIUtil Class
IsIE Overload
Sitecore Namespace


IsIE Method (Int32)

[image]

Sitecore 6.4.1 API
UIUtil..::..IsIE Method (Int32)
UIUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsIE(
    int majorVersion
)
Visual Basic
Public Shared Function IsIE ( _
    majorVersion As Integer _
) As Boolean
Visual C++
public:
static bool IsIE(
    int majorVersion
)

Parameters

majorVersion
Type: System..::..Int32

[Missing <param name="majorVersion"/> documentation for "M:Sitecore.UIUtil.IsIE(System.Int32)"]

Return Value

true if this instance is IE; otherwise, false.

See Also

UIUtil Class
IsIE Overload
Sitecore Namespace


IsWebkit Method

[image]

Sitecore 6.4.1 API
UIUtil..::..IsWebkit Method
UIUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsWebkit()
Visual Basic
Public Shared Function IsWebkit As Boolean
Visual C++
public:
static bool IsWebkit()

Return Value

true if this instance is webkit; otherwise, false.

See Also

UIUtil Class
Sitecore Namespace


LinkToSearch Method

[image]

Sitecore 6.4.1 API
UIUtil..::..LinkToSearch Method
UIUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string LinkToSearch(
    string text,
    string query
)
Visual Basic
Public Shared Function LinkToSearch ( _
    text As String, _
    query As String _
) As String
Visual C++
public:
static String^ LinkToSearch(
    String^ text,
    String^ query
)

Parameters

text
Type: System..::..String
The text.
query
Type: System..::..String
The query.

Return Value

[Missing <returns> documentation for "M:Sitecore.UIUtil.LinkToSearch(System.String,System.String)"]

See Also

UIUtil Class
Sitecore Namespace


ParseStyle Method

[image]

Sitecore 6.4.1 API
UIUtil..::..ParseStyle Method
UIUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void ParseStyle(
    CssStyleCollection css,
    string style
)
Visual Basic
Public Shared Sub ParseStyle ( _
    css As CssStyleCollection, _
    style As String _
)
Visual C++
public:
static void ParseStyle(
    CssStyleCollection^ css,
    String^ style
)

Parameters

css
Type: System.Web.UI..::..CssStyleCollection
The CSS.
style
Type: System..::..String
The style.

See Also

UIUtil Class
Sitecore Namespace


StripSitecoreShellPath Method

[image]

Sitecore 6.4.1 API
UIUtil..::..StripSitecoreShellPath Method
UIUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string StripSitecoreShellPath(
    string url
)
Visual Basic
Public Shared Function StripSitecoreShellPath ( _
    url As String _
) As String
Visual C++
public:
static String^ StripSitecoreShellPath(
    String^ url
)

Parameters

url
Type: System..::..String
The URL.

Return Value

The sitecore shell path.

See Also

UIUtil Class
Sitecore Namespace


SupportsInlineEditing Method

[image]

Sitecore 6.4.1 API
UIUtil..::..SupportsInlineEditing Method
UIUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool SupportsInlineEditing()
Visual Basic
Public Shared Function SupportsInlineEditing As Boolean
Visual C++
public:
static bool SupportsInlineEditing()

Return Value

The inline editing.

See Also

UIUtil Class
Sitecore Namespace


UseFlashUpload Method

[image]

Sitecore 6.4.1 API
UIUtil..::..UseFlashUpload Method
UIUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool UseFlashUpload()
Visual Basic
Public Shared Function UseFlashUpload As Boolean
Visual C++
public:
static bool UseFlashUpload()

Return Value

The flash upload.

See Also

UIUtil Class
Sitecore Namespace


UsedImplicitlyAttribute Class

[image]

Sitecore 6.4.1 API
UsedImplicitlyAttribute Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class UsedImplicitlyAttribute : Attribute
Visual Basic
Public Class UsedImplicitlyAttribute _
    Inherits Attribute
Visual C++
public ref class UsedImplicitlyAttribute : public Attribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Sitecore..::..UsedImplicitlyAttribute

See Also

UsedImplicitlyAttribute Members
Sitecore Namespace


UsedImplicitlyAttribute Members

[image] [image]

Sitecore 6.4.1 API
UsedImplicitlyAttribute Members
UsedImplicitlyAttribute Class Constructors Methods Properties See Also Send Feedback

The UsedImplicitlyAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | UsedImplicitlyAttribute | Initializes a new instance of the UsedImplicitlyAttribute class

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

UsedImplicitlyAttribute Class
Sitecore Namespace


UsedImplicitlyAttribute Constructor

[image]

Sitecore 6.4.1 API
UsedImplicitlyAttribute Constructor
UsedImplicitlyAttribute Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UsedImplicitlyAttribute()
Visual Basic
Public Sub New
Visual C++
public:
UsedImplicitlyAttribute()

See Also

UsedImplicitlyAttribute Class
Sitecore Namespace


UsedImplicitlyAttribute Methods

[image] [image]

Sitecore 6.4.1 API
UsedImplicitlyAttribute Methods
UsedImplicitlyAttribute Class See Also Send Feedback

The UsedImplicitlyAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UsedImplicitlyAttribute Class
Sitecore Namespace


UsedImplicitlyAttribute Properties

[image] [image]

Sitecore 6.4.1 API
UsedImplicitlyAttribute Properties
UsedImplicitlyAttribute Class See Also Send Feedback

The UsedImplicitlyAttribute type exposes the following members.

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

UsedImplicitlyAttribute Class
Sitecore Namespace


UserFieldIDs Class

[image]

Sitecore 6.4.1 API
UserFieldIDs Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class UserFieldIDs
Visual Basic
Public NotInheritable Class UserFieldIDs
Visual C++
public ref class UserFieldIDs abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore..::..UserFieldIDs

See Also

UserFieldIDs Members
Sitecore Namespace


UserFieldIDs Members

[image] [image]

Sitecore 6.4.1 API
UserFieldIDs Members
UserFieldIDs Class Fields See Also Send Feedback

The UserFieldIDs type exposes the following members.

Fields

Name | Description
Administrator | The ID of the 'Administrator' field.
Password | The ID of the 'Password' field.
Roles | The ID of the 'Roles' field.

See Also

UserFieldIDs Class
Sitecore Namespace


UserFieldIDs Fields

[image] [image]

Sitecore 6.4.1 API
UserFieldIDs Fields
UserFieldIDs Class See Also Send Feedback

The UserFieldIDs type exposes the following members.

Fields

Name | Description
Administrator | The ID of the 'Administrator' field.
Password | The ID of the 'Password' field.
Roles | The ID of the 'Roles' field.

See Also

UserFieldIDs Class
Sitecore Namespace


Administrator Field

[image]

Sitecore 6.4.1 API
UserFieldIDs..::..Administrator Field
UserFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Administrator
Visual Basic
Public Shared Administrator As ID
Visual C++
public:
static ID^ Administrator

See Also

UserFieldIDs Class
Sitecore Namespace


Password Field

[image]

Sitecore 6.4.1 API
UserFieldIDs..::..Password Field
UserFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Password
Visual Basic
Public Shared Password As ID
Visual C++
public:
static ID^ Password

See Also

UserFieldIDs Class
Sitecore Namespace


Roles Field

[image]

Sitecore 6.4.1 API
UserFieldIDs..::..Roles Field
UserFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Roles
Visual Basic
Public Shared Roles As ID
Visual C++
public:
static ID^ Roles

See Also

UserFieldIDs Class
Sitecore Namespace


WebDAVUtil Class

[image]

Sitecore 6.4.1 API
WebDAVUtil Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class WebDAVUtil
Visual Basic
Public Class WebDAVUtil
Visual C++
public ref class WebDAVUtil

Inheritance Hierarchy

System..::..Object
Sitecore..::..WebDAVUtil

See Also

WebDAVUtil Members
Sitecore Namespace


WebDAVUtil Members

[image] [image]

Sitecore 6.4.1 API
WebDAVUtil Members
WebDAVUtil Class Constructors Methods See Also Send Feedback

The WebDAVUtil type exposes the following members.

Constructors

 | Name | Description
Public method | WebDAVUtil | Initializes a new instance of the WebDAVUtil class

Methods

 | Name | Description
 | BasedOnFolderTemplate | Verifies that items is based on folder template.
Public method | CorrectDate | Corrects the date.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBrowseRootItem | Gets the root item for the Drag and Drop dialog.
 | GetEditFileScript | Gets the edit file script.
 | GetEditMediaScript(MediaItem, WebDAVOptions) | Gets the script that opens Media Item for editing via DAV protocol.
 | GetEditMediaScript(MediaItem, ID) | Gets the script that opens Media Item for editing via DAV protocol.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetWebDAVOpenUrl(ID) | Gets the web DAV open URL.
 | GetWebDAVOpenUrl(WebDAVOptions) | Gets the web DAV open URL.
 | GetWebDAVOpenUrl(String, WebDAVOptions) | Gets the web DAV open URL.
 | GetWebDAVOpenUrl(String, ID) | Gets the web DAV open URL.
 | GetWebDAVOptions | Generates the default web DAV options.
 | GetWebDAVViewUrl(ID) | Gets the web DAV View URL.
 | GetWebDAVViewUrl(WebDAVOptions) | Gets the web DAV View URL.
 | GetWebDAVViewUrl(String, WebDAVOptions) | Gets the web DAV View URL.
 | GetWebDAVViewUrl(String, ID) | Gets the web DAV View URL.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WebDAVUtil Class
Sitecore Namespace


WebDAVUtil Constructor

[image]

Sitecore 6.4.1 API
WebDAVUtil Constructor
WebDAVUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WebDAVUtil()
Visual Basic
Public Sub New
Visual C++
public:
WebDAVUtil()

See Also

WebDAVUtil Class
Sitecore Namespace


BasedOnFolderTemplate Method

[image]

Sitecore 6.4.1 API
WebDAVUtil..::..BasedOnFolderTemplate Method
WebDAVUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool BasedOnFolderTemplate(
    Item item
)
Visual Basic
Public Shared Function BasedOnFolderTemplate ( _
    item As Item _
) As Boolean
Visual C++
public:
static bool BasedOnFolderTemplate(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item.

Return Value

true when item is based on folder template.

See Also

WebDAVUtil Class
Sitecore Namespace


CorrectDate Method

[image]

Sitecore 6.4.1 API
WebDAVUtil..::..CorrectDate Method
WebDAVUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime CorrectDate(
    DateTime date,
    DateTime defaultDate
)
Visual Basic
Public Function CorrectDate ( _
    date As DateTime, _
    defaultDate As DateTime _
) As DateTime
Visual C++
public:
DateTime CorrectDate(
    DateTime date,
    DateTime defaultDate
)

Parameters

date
Type: System..::..DateTime
The date to be corrected.
defaultDate
Type: System..::..DateTime
The default date.

Return Value

Corrected Date.

See Also

WebDAVUtil Class
Sitecore Namespace


GetBrowseRootItem Method

[image]

Sitecore 6.4.1 API
WebDAVUtil..::..GetBrowseRootItem Method
WebDAVUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item GetBrowseRootItem(
    Item item
)
Visual Basic
Public Shared Function GetBrowseRootItem ( _
    item As Item _
) As Item
Visual C++
public:
static Item^ GetBrowseRootItem(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The current context item.

Return Value

The root media item to open WebDAV view.

See Also

WebDAVUtil Class
Sitecore Namespace


GetEditFileScript Method

[image]

Sitecore 6.4.1 API
WebDAVUtil..::..GetEditFileScript Method
WebDAVUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetEditFileScript()
Visual Basic
Public Shared Function GetEditFileScript As String
Visual C++
public:
static String^ GetEditFileScript()

Return Value

The Edit file script.

See Also

WebDAVUtil Class
Sitecore Namespace


GetEditMediaScript Method

[image] [image]

Sitecore 6.4.1 API
WebDAVUtil..::..GetEditMediaScript Method
WebDAVUtil Class See Also Send Feedback

Overload List

Name | Description
GetEditMediaScript(MediaItem, WebDAVOptions) | Gets the script that opens Media Item for editing via DAV protocol.
GetEditMediaScript(MediaItem, ID) | Gets the script that opens Media Item for editing via DAV protocol.

See Also

WebDAVUtil Class
WebDAVUtil Members
Sitecore Namespace


GetEditMediaScript Method (MediaItem, WebDAVOptions)

[image]

Sitecore 6.4.1 API
WebDAVUtil..::..GetEditMediaScript Method (MediaItem, WebDAVOptions)
WebDAVUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetEditMediaScript(
    MediaItem item,
    WebDAVOptions options
)
Visual Basic
Public Shared Function GetEditMediaScript ( _
    item As MediaItem, _
    options As WebDAVOptions _
) As String
Visual C++
public:
static String^ GetEditMediaScript(
    MediaItem^ item,
    WebDAVOptions^ options
)

Parameters

item
Type: Sitecore.Data.Items..::..MediaItem
The Media item.
options
Type: Sitecore.Configuration..::..WebDAVOptions
The Web DAV options.

Return Value

The java script.

See Also

WebDAVUtil Class
GetEditMediaScript Overload
Sitecore Namespace


GetWebDAVOpenUrl Method

[image] [image]

Sitecore 6.4.1 API
WebDAVUtil..::..GetWebDAVOpenUrl Method
WebDAVUtil Class See Also Send Feedback

Overload List

Name | Description
GetWebDAVOpenUrl(ID) | Gets the web DAV open URL.
GetWebDAVOpenUrl(WebDAVOptions) | Gets the web DAV open URL.
GetWebDAVOpenUrl(String, WebDAVOptions) | Gets the web DAV open URL.
GetWebDAVOpenUrl(String, ID) | Gets the web DAV open URL.

See Also

WebDAVUtil Class
WebDAVUtil Members
Sitecore Namespace


GetWebDAVOpenUrl Method (WebDAVOptions)

[image]

Sitecore 6.4.1 API
WebDAVUtil..::..GetWebDAVOpenUrl Method (WebDAVOptions)
WebDAVUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetWebDAVOpenUrl(
    WebDAVOptions options
)
Visual Basic
Public Shared Function GetWebDAVOpenUrl ( _
    options As WebDAVOptions _
) As String
Visual C++
public:
static String^ GetWebDAVOpenUrl(
    WebDAVOptions^ options
)

Parameters

options
Type: Sitecore.Configuration..::..WebDAVOptions
The options.

Return Value

Url to opener WebDAV view form.

See Also

WebDAVUtil Class
GetWebDAVOpenUrl Overload
Sitecore Namespace


GetWebDAVOpenUrl Method (String, WebDAVOptions)

[image]

Sitecore 6.4.1 API
WebDAVUtil..::..GetWebDAVOpenUrl Method (String, WebDAVOptions)
WebDAVUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetWebDAVOpenUrl(
    string webDAVOpenerUrl,
    WebDAVOptions options
)
Visual Basic
Public Shared Function GetWebDAVOpenUrl ( _
    webDAVOpenerUrl As String, _
    options As WebDAVOptions _
) As String
Visual C++
public:
static String^ GetWebDAVOpenUrl(
    String^ webDAVOpenerUrl,
    WebDAVOptions^ options
)

Parameters

webDAVOpenerUrl
Type: System..::..String
The web DAV opener URL.
options
Type: Sitecore.Configuration..::..WebDAVOptions
The options.

Return Value

Url to opener WebDAV view form.

See Also

WebDAVUtil Class
GetWebDAVOpenUrl Overload
Sitecore Namespace


GetWebDAVOpenUrl Method (String, ID)

[image]

Sitecore 6.4.1 API
WebDAVUtil..::..GetWebDAVOpenUrl Method (String, ID)
WebDAVUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetWebDAVOpenUrl(
    string webDAVOpenerUrl,
    ID optionID
)
Visual Basic
Public Shared Function GetWebDAVOpenUrl ( _
    webDAVOpenerUrl As String, _
    optionID As ID _
) As String
Visual C++
public:
static String^ GetWebDAVOpenUrl(
    String^ webDAVOpenerUrl,
    ID^ optionID
)

Parameters

webDAVOpenerUrl
Type: System..::..String
The web DAV opener URL.
optionID
Type: Sitecore.Data..::..ID
The option ID.

Return Value

Url to opener WebDAV view form.

See Also

WebDAVUtil Class
GetWebDAVOpenUrl Overload
Sitecore Namespace


GetWebDAVOptions Method

[image]

Sitecore 6.4.1 API
WebDAVUtil..::..GetWebDAVOptions Method
WebDAVUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static WebDAVOptions GetWebDAVOptions(
    Item item
)
Visual Basic
Public Shared Function GetWebDAVOptions ( _
    item As Item _
) As WebDAVOptions
Visual C++
public:
static WebDAVOptions^ GetWebDAVOptions(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The target item.

Return Value

Tshe Web DAV options.

See Also

WebDAVUtil Class
Sitecore Namespace


GetWebDAVViewUrl Method

[image] [image]

Sitecore 6.4.1 API
WebDAVUtil..::..GetWebDAVViewUrl Method
WebDAVUtil Class See Also Send Feedback

Overload List

Name | Description
GetWebDAVViewUrl(ID) | Gets the web DAV View URL.
GetWebDAVViewUrl(WebDAVOptions) | Gets the web DAV View URL.
GetWebDAVViewUrl(String, WebDAVOptions) | Gets the web DAV View URL.
GetWebDAVViewUrl(String, ID) | Gets the web DAV View URL.

See Also

WebDAVUtil Class
WebDAVUtil Members
Sitecore Namespace


GetWebDAVViewUrl Method (ID)

[image]

Sitecore 6.4.1 API
WebDAVUtil..::..GetWebDAVViewUrl Method (ID)
WebDAVUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetWebDAVViewUrl(
    ID optionID
)
Visual Basic
Public Shared Function GetWebDAVViewUrl ( _
    optionID As ID _
) As String
Visual C++
public:
static String^ GetWebDAVViewUrl(
    ID^ optionID
)

Parameters

optionID
Type: Sitecore.Data..::..ID
The option ID.

Return Value

Url to opener WebDAV view form.

See Also

WebDAVUtil Class
GetWebDAVViewUrl Overload
Sitecore Namespace


GetWebDAVViewUrl Method (String, WebDAVOptions)

[image]

Sitecore 6.4.1 API
WebDAVUtil..::..GetWebDAVViewUrl Method (String, WebDAVOptions)
WebDAVUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetWebDAVViewUrl(
    string webDAVViewFormUrl,
    WebDAVOptions options
)
Visual Basic
Public Shared Function GetWebDAVViewUrl ( _
    webDAVViewFormUrl As String, _
    options As WebDAVOptions _
) As String
Visual C++
public:
static String^ GetWebDAVViewUrl(
    String^ webDAVViewFormUrl,
    WebDAVOptions^ options
)

Parameters

webDAVViewFormUrl
Type: System..::..String
The web DAV view form URL.
options
Type: Sitecore.Configuration..::..WebDAVOptions
The options.

Return Value

Url to opener WebDAV view form.

See Also

WebDAVUtil Class
GetWebDAVViewUrl Overload
Sitecore Namespace


GetWebDAVViewUrl Method (String, ID)

[image]

Sitecore 6.4.1 API
WebDAVUtil..::..GetWebDAVViewUrl Method (String, ID)
WebDAVUtil Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetWebDAVViewUrl(
    string webDAVViewFormUrl,
    ID optionID
)
Visual Basic
Public Shared Function GetWebDAVViewUrl ( _
    webDAVViewFormUrl As String, _
    optionID As ID _
) As String
Visual C++
public:
static String^ GetWebDAVViewUrl(
    String^ webDAVViewFormUrl,
    ID^ optionID
)

Parameters

webDAVViewFormUrl
Type: System..::..String
The web DAV view form URL.
optionID
Type: Sitecore.Data..::..ID
The option ID.

Return Value

Url to opener WebDAV view form.

See Also

WebDAVUtil Class
GetWebDAVViewUrl Overload
Sitecore Namespace


WorkflowFieldIDs Class

[image]

Sitecore 6.4.1 API
WorkflowFieldIDs Class
Members See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class WorkflowFieldIDs
Visual Basic
Public NotInheritable Class WorkflowFieldIDs
Visual C++
public ref class WorkflowFieldIDs abstract sealed

Remarks

The class does not contain any functionality, but serves as a placeholder for a predefined GUIDs.

Inheritance Hierarchy

System..::..Object
Sitecore..::..WorkflowFieldIDs

See Also

WorkflowFieldIDs Members
Sitecore Namespace


WorkflowFieldIDs Members

[image] [image]

Sitecore 6.4.1 API
WorkflowFieldIDs Members
WorkflowFieldIDs Class Fields See Also Send Feedback

The WorkflowFieldIDs type exposes the following members.

Fields

Name | Description
FinalState | The Final field of the Workflow/State template.

See Also

WorkflowFieldIDs Class
Sitecore Namespace


WorkflowFieldIDs Fields

[image] [image]

Sitecore 6.4.1 API
WorkflowFieldIDs Fields
WorkflowFieldIDs Class See Also Send Feedback

The WorkflowFieldIDs type exposes the following members.

Fields

Name | Description
FinalState | The Final field of the Workflow/State template.

See Also

WorkflowFieldIDs Class
Sitecore Namespace


FinalState Field

[image]

Sitecore 6.4.1 API
WorkflowFieldIDs..::..FinalState Field
WorkflowFieldIDs Class See Also Send Feedback

Namespace: Sitecore
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID FinalState
Visual Basic
Public Shared FinalState As ID
Visual C++
public:
static ID^ FinalState

See Also

WorkflowFieldIDs Class
Sitecore Namespace


Sitecore.Access Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Access Namespace
Send Feedback

Classes

 | Class | Description
Public class | AccessContext | Represents the current access context.


AccessContext Class

[image]

Sitecore 6.4.1 API
AccessContext Class
Members See Also Send Feedback

Namespace: Sitecore.Access
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class AccessContext
Visual Basic
Public Class AccessContext
Visual C++
public ref class AccessContext

Inheritance Hierarchy

System..::..Object
Sitecore.Access..::..AccessContext

See Also

AccessContext Members
Sitecore.Access Namespace


AccessContext Members

[image] [image]

Sitecore 6.4.1 API
AccessContext Members
AccessContext Class Constructors Methods See Also Send Feedback

The AccessContext type exposes the following members.

Constructors

 | Name | Description
Public method | AccessContext | Initializes a new instance of the AccessContext class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AccessContext Class
Sitecore.Access Namespace


AccessContext Constructor

[image]

Sitecore 6.4.1 API
AccessContext Constructor
AccessContext Class See Also Send Feedback

Namespace: Sitecore.Access
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AccessContext(
    Context..::..ContextData context
)
Visual Basic
Public Sub New ( _
    context As Context..::..ContextData _
)
Visual C++
public:
AccessContext(
    Context..::..ContextData^ context
)

Parameters

context
Type: Sitecore..::..Context..::..ContextData
The context.

See Also

AccessContext Class
Sitecore.Access Namespace


AccessContext Methods

[image] [image]

Sitecore 6.4.1 API
AccessContext Methods
AccessContext Class See Also Send Feedback

The AccessContext type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AccessContext Class
Sitecore.Access Namespace


Sitecore.Analytics Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Analytics Namespace
Send Feedback

Classes

 | Class | Description
Public class | AnalyticsGlobalSession | Defines the analytics global session class.
Public class | AnalyticsHelper | The Analytics helper.
Public class | AnalyticsIds | Defines the analytics ids class.
Public class | AnalyticsManager | Defines the analytics manager class.
Public class | AnalyticsPage | Defines the session page class.
Public class | AnalyticsPageEvent | Defines the analytics page event class.
Public class | AnalyticsSession | Defines the session class.
Public class | AnalyticsTexts | Defines the anatytics texts class.
Public class | AnalyticsTracker | Defines the analytics tracker class.
Public class | AnalyticsTracker..::..Summary | Obsolete. Defines the forms class.
Public class | Browser | Browser
Public class | Campaign | Campaign
Public class | CampaignEvent | Campaign event
Public class | CampaignEventPage | Campaign event page
Public class | GlobalSession | Global session
Public class | IP |
Public class | IPOwner | IP owner
Public class | Keyword | Keyword
Public class | MultiVarianceTestDefinition | Multi variance test definition
Public class | MultiVarianceTestVariable | Multi variance test variable
Public class | MultiVarianceTestVariableCampaignEvent | Multi variance test variable campaign event
Public class | MultiVarianceTestVariablePage | Multi variance test variable page
Public class | OperatingSystem | Operating system
Public class | Page | Page
Public class | PageEvent | Page event
Public class | PageEventDefinition | Page event definition
Public class | Profile | Profile
Public class | ProfileDefinition | Profile definition
Public class | ProfileKey | Profile key
Public class | ProfileKeyDefinition | Profile key definition
Public class | ReferringSite | Referring site
Public class | Screen | Screen
Public class | Session | Session
Public class | Status | Status
Public class | Subscription | Subscription
Public class | Tag | Tag
Public class | TransactionHandle | Defines the transaction handle class.
Public class | VisitorIdentification | Visitor identification


AnalyticsGlobalSession Class

[image]

Sitecore 6.4.1 API
AnalyticsGlobalSession Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class AnalyticsGlobalSession
Visual Basic
Public Class AnalyticsGlobalSession
Visual C++
public ref class AnalyticsGlobalSession

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics..::..AnalyticsGlobalSession

See Also

AnalyticsGlobalSession Members
Sitecore.Analytics Namespace


AnalyticsGlobalSession Members

[image] [image]

Sitecore 6.4.1 API
AnalyticsGlobalSession Members
AnalyticsGlobalSession Class Constructors Methods Properties See Also Send Feedback

The AnalyticsGlobalSession type exposes the following members.

Constructors

 | Name | Description
Public method | AnalyticsGlobalSession | Initializes a new instance of the AnalyticsGlobalSession class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Acquaintance | Gets or sets the acquaintance.
Public property | CookieValue | Gets or sets the cookie value.
Public property | ExternalUser | Gets or sets the external user.
Public property | State | Gets or sets the state.
Public property | Tags | Gets the properties.

See Also

AnalyticsGlobalSession Class
Sitecore.Analytics Namespace


AnalyticsGlobalSession Constructor

[image]

Sitecore 6.4.1 API
AnalyticsGlobalSession Constructor
AnalyticsGlobalSession Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public AnalyticsGlobalSession()
Visual Basic
Public Sub New
Visual C++
public:
AnalyticsGlobalSession()

See Also

AnalyticsGlobalSession Class
Sitecore.Analytics Namespace


AnalyticsGlobalSession Methods

[image] [image]

Sitecore 6.4.1 API
AnalyticsGlobalSession Methods
AnalyticsGlobalSession Class See Also Send Feedback

The AnalyticsGlobalSession type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticsGlobalSession Class
Sitecore.Analytics Namespace


AnalyticsGlobalSession Properties

[image] [image]

Sitecore 6.4.1 API
AnalyticsGlobalSession Properties
AnalyticsGlobalSession Class See Also Send Feedback

The AnalyticsGlobalSession type exposes the following members.

Properties

 | Name | Description
Public property | Acquaintance | Gets or sets the acquaintance.
Public property | CookieValue | Gets or sets the cookie value.
Public property | ExternalUser | Gets or sets the external user.
Public property | State | Gets or sets the state.
Public property | Tags | Gets the properties.

See Also

AnalyticsGlobalSession Class
Sitecore.Analytics Namespace


Acquaintance Property

[image]

Sitecore 6.4.1 API
AnalyticsGlobalSession..::..Acquaintance Property
AnalyticsGlobalSession Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid Acquaintance { get; set; }
Visual Basic
Public Property Acquaintance As Guid
    Get
    Set
Visual C++
public:
property Guid Acquaintance {
    Guid get ();
    void set (Guid value);
}

Field Value

The acquaintance.

See Also

AnalyticsGlobalSession Class
Sitecore.Analytics Namespace


CookieValue Property

[image]

Sitecore 6.4.1 API
AnalyticsGlobalSession..::..CookieValue Property
AnalyticsGlobalSession Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string CookieValue { get; set; }
Visual Basic
Public Property CookieValue As String
    Get
    Set
Visual C++
public:
property String^ CookieValue {
    String^ get ();
    void set (String^ value);
}

Field Value

The cookie value.

See Also

AnalyticsGlobalSession Class
Sitecore.Analytics Namespace


ExternalUser Property

[image]

Sitecore 6.4.1 API
AnalyticsGlobalSession..::..ExternalUser Property
AnalyticsGlobalSession Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string ExternalUser { get; set; }
Visual Basic
Public Property ExternalUser As String
    Get
    Set
Visual C++
public:
property String^ ExternalUser {
    String^ get ();
    void set (String^ value);
}

Field Value

The external user.

See Also

AnalyticsGlobalSession Class
Sitecore.Analytics Namespace


State Property

[image]

Sitecore 6.4.1 API
AnalyticsGlobalSession..::..State Property
AnalyticsGlobalSession Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string State { get; set; }
Visual Basic
Public Property State As String
    Get
    Set
Visual C++
public:
property String^ State {
    String^ get ();
    void set (String^ value);
}

Field Value

The state.

See Also

AnalyticsGlobalSession Class
Sitecore.Analytics Namespace


Tags Property

[image]

Sitecore 6.4.1 API
AnalyticsGlobalSession..::..Tags Property
AnalyticsGlobalSession Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Dictionary<string, string> Tags { get; }
Visual Basic
Public ReadOnly Property Tags As Dictionary(Of String, String)
    Get
Visual C++
public:
property Dictionary<String^, String^>^ Tags {
    Dictionary<String^, String^>^ get ();
}

Field Value

The properties.

See Also

AnalyticsGlobalSession Class
Sitecore.Analytics Namespace


AnalyticsHelper Class

[image]

Sitecore 6.4.1 API
AnalyticsHelper Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static class AnalyticsHelper
Visual Basic
Public NotInheritable Class AnalyticsHelper
Visual C++
public ref class AnalyticsHelper abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics..::..AnalyticsHelper

See Also

AnalyticsHelper Members
Sitecore.Analytics Namespace


AnalyticsHelper Members

[image] [image]

Sitecore 6.4.1 API
AnalyticsHelper Members
AnalyticsHelper Class Methods See Also Send Feedback

The AnalyticsHelper type exposes the following members.

Methods

Name | Description
ExcludeRequest | Checks whether specified HTTP request should be ignored.

See Also

AnalyticsHelper Class
Sitecore.Analytics Namespace


AnalyticsHelper Methods

[image] [image]

Sitecore 6.4.1 API
AnalyticsHelper Methods
AnalyticsHelper Class See Also Send Feedback

The AnalyticsHelper type exposes the following members.

Methods

Name | Description
ExcludeRequest | Checks whether specified HTTP request should be ignored.

See Also

AnalyticsHelper Class
Sitecore.Analytics Namespace


AnalyticsIds Class

[image]

Sitecore 6.4.1 API
AnalyticsIds Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static class AnalyticsIds
Visual Basic
Public NotInheritable Class AnalyticsIds
Visual C++
public ref class AnalyticsIds abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics..::..AnalyticsIds

See Also

AnalyticsIds Members
Sitecore.Analytics Namespace


AnalyticsIds Members

[image] [image]

Sitecore 6.4.1 API
AnalyticsIds Members
AnalyticsIds Class Fields See Also Send Feedback

The AnalyticsIds type exposes the following members.

Fields

Name | Description
Campaign | The ID of the 'Campaign' template.
CampaignEvent | The ID of the 'CampaignEvent' template.
Goal | The ID of the 'Goal' template.
MultiVarianceTest | The ID of the 'MultiVarianceTest' template.
MultiVarianceTestItem | The ID of the 'MultiVarianceTestItem' template.
PageEvent | The ID of the 'Page Event' template.
Pending | The Guid of the '(Pending)' row in the IPOwner table in the database.
Profile | The ID of the 'Profile' template.
ProfileKey | The ID of the 'Profile Key' template.

See Also

AnalyticsIds Class
Sitecore.Analytics Namespace


AnalyticsIds Fields

[image] [image]

Sitecore 6.4.1 API
AnalyticsIds Fields
AnalyticsIds Class See Also Send Feedback

The AnalyticsIds type exposes the following members.

Fields

Name | Description
Campaign | The ID of the 'Campaign' template.
CampaignEvent | The ID of the 'CampaignEvent' template.
Goal | The ID of the 'Goal' template.
MultiVarianceTest | The ID of the 'MultiVarianceTest' template.
MultiVarianceTestItem | The ID of the 'MultiVarianceTestItem' template.
PageEvent | The ID of the 'Page Event' template.
Pending | The Guid of the '(Pending)' row in the IPOwner table in the database.
Profile | The ID of the 'Profile' template.
ProfileKey | The ID of the 'Profile Key' template.

See Also

AnalyticsIds Class
Sitecore.Analytics Namespace


Campaign Field

[image]

Sitecore 6.4.1 API
AnalyticsIds..::..Campaign Field
AnalyticsIds Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static ID Campaign
Visual Basic
Public Shared Campaign As ID
Visual C++
public:
static ID^ Campaign

See Also

AnalyticsIds Class
Sitecore.Analytics Namespace


CampaignEvent Field

[image]

Sitecore 6.4.1 API
AnalyticsIds..::..CampaignEvent Field
AnalyticsIds Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static ID CampaignEvent
Visual Basic
Public Shared CampaignEvent As ID
Visual C++
public:
static ID^ CampaignEvent

See Also

AnalyticsIds Class
Sitecore.Analytics Namespace


Goal Field

[image]

Sitecore 6.4.1 API
AnalyticsIds..::..Goal Field
AnalyticsIds Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static ID Goal
Visual Basic
Public Shared Goal As ID
Visual C++
public:
static ID^ Goal

See Also

AnalyticsIds Class
Sitecore.Analytics Namespace


MultiVarianceTest Field

[image]

Sitecore 6.4.1 API
AnalyticsIds..::..MultiVarianceTest Field
AnalyticsIds Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static ID MultiVarianceTest
Visual Basic
Public Shared MultiVarianceTest As ID
Visual C++
public:
static ID^ MultiVarianceTest

See Also

AnalyticsIds Class
Sitecore.Analytics Namespace


MultiVarianceTestItem Field

[image]

Sitecore 6.4.1 API
AnalyticsIds..::..MultiVarianceTestItem Field
AnalyticsIds Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static ID MultiVarianceTestItem
Visual Basic
Public Shared MultiVarianceTestItem As ID
Visual C++
public:
static ID^ MultiVarianceTestItem

See Also

AnalyticsIds Class
Sitecore.Analytics Namespace


PageEvent Field

[image]

Sitecore 6.4.1 API
AnalyticsIds..::..PageEvent Field
AnalyticsIds Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static ID PageEvent
Visual Basic
Public Shared PageEvent As ID
Visual C++
public:
static ID^ PageEvent

See Also

AnalyticsIds Class
Sitecore.Analytics Namespace


Pending Field

[image]

Sitecore 6.4.1 API
AnalyticsIds..::..Pending Field
AnalyticsIds Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static Guid Pending
Visual Basic
Public Shared Pending As Guid
Visual C++
public:
static Guid Pending

See Also

AnalyticsIds Class
Sitecore.Analytics Namespace


Profile Field

[image]

Sitecore 6.4.1 API
AnalyticsIds..::..Profile Field
AnalyticsIds Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static ID Profile
Visual Basic
Public Shared Profile As ID
Visual C++
public:
static ID^ Profile

See Also

AnalyticsIds Class
Sitecore.Analytics Namespace


ProfileKey Field

[image]

Sitecore 6.4.1 API
AnalyticsIds..::..ProfileKey Field
AnalyticsIds Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static ID ProfileKey
Visual Basic
Public Shared ProfileKey As ID
Visual C++
public:
static ID^ ProfileKey

See Also

AnalyticsIds Class
Sitecore.Analytics Namespace


AnalyticsManager Class

[image]

Sitecore 6.4.1 API
AnalyticsManager Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class AnalyticsManager
Visual Basic
Public Class AnalyticsManager
Visual C++
public ref class AnalyticsManager

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics..::..AnalyticsManager

See Also

AnalyticsManager Members
Sitecore.Analytics Namespace


AnalyticsManager Members

[image] [image]

Sitecore 6.4.1 API
AnalyticsManager Members
AnalyticsManager Class Constructors Methods Fields Properties See Also Send Feedback

The AnalyticsManager type exposes the following members.

Constructors

 | Name | Description
Public method | AnalyticsManager | Initializes a new instance of the AnalyticsManager class

Methods

 | Name | Description
 | DeleteSubscription | Deletes the subscription.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute | Executes the specified command text.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FormatBigString | Convert to char.
 | FormatCommandText | Formats the command text.
 | FormatFunctionName | Formats the functionName of the function.
 | GetAddIpOwnerIdByNameAndCountry | Gets the add ip owner id by name and country.
 | GetBrowserById | Gets the browser by id.
 | GetBrowserIdByUserAgent | Gets the browser by user agent.
 | GetBrowsers | Gets the browsers.
 | GetCampaignById | Gets the campaign by id.
 | GetCampaignEventById | Gets the campaign event by id.
 | GetCampaignEvents | Gets the campaign events.
 | GetCampaignEventsByCampaignId | Gets the campaign events by campaign id.
 | GetCampaigns | Gets the campaigns.
 | GetDateTime | Gets the date time.
 | GetDouble | Gets the double.
 | GetGlobalSessionById | Gets the global session by id.
 | GetGlobalSessionIdByCookieValue | Gets the global session id by cookie value.
 | GetGlobalSessions | Gets the global sessions.
 | GetGuid | Gets the GUID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInt | Gets the int.
 | GetIPById | Gets the IP by id.
 | GetIPBySessionId | Gets the IP by session id.
 | GetIpOwnerById | Gets the ip owner by id.
 | GetIpOwnerBySessionId | Gets the ip owner by session id.
 | GetIpOwnerIdsBySessionId | Gets the ip owner ids by session id.
 | GetIPs | Gets the list of IPs.
 | GetIPsByOwnerId | Gets the IPs by owner id.
 | GetKeywordIdByKeywords | Gets the keyword id by keywords.
 | GetKeywordsBySessionId | Gets the keywords by session id.
 | GetLong | Gets the long.
 | GetLookupData | Gets the lookup data.
 | GetMatchReportQueryPattern | Gets the match report query pattern.
 | GetMultiVarianceTestDefinitionById | Gets the multi variance test definitions by id.
 | GetMultiVarianceTestDefinitions | Gets the multi variance test definitions.
 | GetMultiVarianceTestVariableById | Gets the multi variance test variable by id.
 | GetMultiVarianceTestVariablesByTestDefinitionId | Gets the multi variance test variables by test definition id.
 | GetOperatingSystemById | Gets the operating system by id.
 | GetOperatingSystems | Gets the operating systems.
 | GetOrAddIpIdByAddressFrom | Gets the ip ID by address from.
 | GetPageById | Gets the page by id.
 | GetPageBySessionIdAndPageNo | Gets the page by session id and page no.
 | GetPageEventById | Gets the page event by id.
 | GetPageEventDefinitionById | Gets the page event definition by id.
 | GetPageEventDefinitionFailureNotSystem | Gets the page event definition failure system.
 | GetPageEventDefinitionNotGoalNotFailureNotSystem | Gets the page event definition goal failure not system.
 | GetPageEventDefinitions | Gets the page event definitions.
 | GetPageEventDefinitionsIsGoalNotSystem | Gets the page event definitions is goal not system.
 | GetPageEventsByPageId | Gets the page events by page id.
 | GetPagesBySessionId | Gets the pages by session id.
 | GetProfileById | Gets the profile by id.
 | GetProfileDefinitionById | Gets the profile definition by id.
 | GetProfileDefinitions | Gets the profile definitions.
 | GetProfileKeyDefinitionById | Gets the profile key definition by id.
 | GetProfileKeyDefinitions | Gets the profile key definitions.
 | GetProfileKeyDefinitionsById | Gets the profile key definitions by profile definition id.
 | GetProfileKeysByProfileId | Gets the profile keys by profile id.
 | GetProfilesBySessionId | Gets the profiles by session id.
 | GetReferringSiteByUrl | Gets the referring site by URL.
 | GetReferringSites | Gets the referring sites.
 | GetReportsDatabase | Gets the reports database.
 | GetReportsDataSourceType | Gets the type of the reports data source.
 | GetScreenByScreenId | Gets the screen by screen id.
 | GetScreens | Gets the screens.
 | GetSessionByAspNetSessionId | Gets the session.
 | GetSessionBySessionId | Gets the session by session id.
 | GetSessionIdByAspNetSessionId | Gets the session id by ASP session id.
 | GetSessionsCountByGlobalSessionId | Gets the total by global session id.
 | GetStatusById | Gets the status.
 | GetStatuses | Gets the statuses.
 | GetString | Gets the string.
 | GetSubscriptionByEmailAndIPOwnerId | Gets the subscription.
 | GetSubscriptionById | Gets the subscription by id.
 | GetTagById | Gets the tag by id.
 | GetTagsByGlobalSessionId | Gets the tags by global session id.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetVendorSpecificReportPath | Gets the vendor specific report path.
 | GuidToRawString | Convert GUID to raw string.
 | InsertBrowser | Inserts the browser.
 | InsertCampaign | Inserts the campaign.
 | InsertCampaignEvent | Inserts the campaign event.
 | InsertCampaignEventPage | Inserts the campaign event page.
 | InsertGlobalSession | Inserts the global session.
 | InsertIPOwner | Inserts the IP owner.
 | InsertKeyword | Inserts the keyword.
 | InsertMultiVarianceTestDefinition(Guid, String, String) | Inserts the multi variance test definition.
 | InsertMultiVarianceTestDefinition(String, String, Guid) | Inserts the multi variance test definition.
 | InsertMultiVarianceTestVariable | Inserts the multi variance test variable.
 | InsertMultiVarianceTestVariableCampaignEvent | Inserts the multi variance test variable campaign event.
 | InsertMultiVarianceTestVariablePage | Inserts the multi variance test variable page.
 | InsertOperatingSystem | Inserts the operating system.
 | InsertPage | Inserts the page.
 | InsertPageEvent | Inserts the page event.
 | InsertPageEventDefinition | Inserts the page event definition.
 | InsertProfile | Inserts the profile.
 | InsertProfileDefinition | Inserts the profile definition.
 | InsertProfileKey | Inserts the profile key.
 | InsertProfileKeyDefinition | Inserts the profile key definition.
 | InsertReferringSite | Inserts the referring site.
 | InsertScreen | Inserts the screen.
 | InsertSession | Inserts the session.
 | InsertSubscription | Inserts the subscription.
 | InsertTag | Inserts the tag.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RawStringToGuid | Convert the string to GUID.
 | ReadMany<(Of <<'(T>)>>)(String, Func<(Of <<'(DataProviderReader, T>)>>), array<Object>[]()[][]) | Reads the specified command text.
 | ReadMany<(Of <<'(T>)>>)(String, Func<(Of <<'(DataProviderReader, T>)>>), Int32, array<Object>[]()[][]) | Reads the specified command text.
 | ReadOne<(Of <<'(T>)>>)(String, Func<(Of <<'(DataProviderReader, T>)>>), array<Object>[]()[][]) | Reads the one.
 | ReadOne<(Of <<'(T>)>>)(String, Func<(Of <<'(DataProviderReader, T>)>>), Func<(Of <<'(T>)>>), array<Object>[]()[][]) | Reads the specified command text.
 | SaveCampaignDefinition | Saves the campaign definition.
 | SaveCampaignEvent | Saves the campaign event.
 | SaveMultiVarianceTestDefinition | Saves the multi variance test.
 | SaveMultiVarianceTestVariable | Saves the multi variance test variable.
 | SavePageEventDefinition | Saves the page event definition.
 | SaveProfileDefinition | Saves the profile definition.
 | SaveProfileKeyDefinition | Saves the profile key definition.
 | SetStatusFailed | Sets the status failed.
 | SetStatusSuccessful | Sets the status successful.
 | Submit | Submits the specified tracker.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateBothIdentificationsBySessionId | Updates the both identifications by session id.
 | UpdateBrowser | Updates the browser.
 | UpdateCampaign | Updates the campaign.
 | UpdateCampaignEvent | Updates the campaign event.
 | UpdateCountTotalByProfileId | Updates the profile count total.
 | UpdateCurrentPageBySessionId | Updates the current page by session id.
 | UpdateGlobalSession | Updates the global session.
 | UpdateIP | Updates the IP.
 | UpdateIpInformation(Guid, WhoIsInformation) | Updates the ip information.
 | UpdateIpInformation(Guid, WhoIsInformation, Action<(Of <<'(IP>)>>)) | Updates the ip information.
 | UpdateIPOwner | Updates the IP owner.
 | UpdateMultiVarianceTestDefinition | Updates the multi variance test definition.
 | UpdatePage(Guid, DateTime, Int32, Int32, Guid, String, Int32, Guid, String, String, String, String) | Updates the page.
 | UpdatePage(Guid, Guid, DateTime, Int32, Int32, Guid, String, Int32, Guid, String, String, String, String) | Updates the page.
 | UpdateProfileKey | Updates the profile key.
 | UpdateVisitorIdentificationByIpOwnerId | Updates the visitor identification by ip order id.
 | UpdateVisitorIdentificationBySessionId | Updates the visitor identification by session id.
 | UpdateVisitorIdentifications | Updates the visitor identifications.
 | UpdateVisitorIdentificationsByIPOwnerBrowser | Updates the visitor identifications by IP owner browser.

Fields

Name | Description
STATUS_QUEUE_FULL | Queue full status Guid.
STATUS_REQUEST | Track status Guid.
STATUSLOOKUP | Lookup status Guid.

Properties

Name | Description
ConnectionString | Gets the connection string.
Provider | Gets the providers.
Providers | Gets the providers.

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


AnalyticsManager Constructor

[image]

Sitecore 6.4.1 API
AnalyticsManager Constructor
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public AnalyticsManager()
Visual Basic
Public Sub New
Visual C++
public:
AnalyticsManager()

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


AnalyticsManager Fields

[image] [image]

Sitecore 6.4.1 API
AnalyticsManager Fields
AnalyticsManager Class See Also Send Feedback

The AnalyticsManager type exposes the following members.

Fields

Name | Description
STATUS_QUEUE_FULL | Queue full status Guid.
STATUS_REQUEST | Track status Guid.
STATUSLOOKUP | Lookup status Guid.

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


STATUS_QUEUE_FULL Field

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..STATUS_QUEUE_FULL Field
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static Guid STATUS_QUEUE_FULL
Visual Basic
Public Shared STATUS_QUEUE_FULL As Guid
Visual C++
public:
static Guid STATUS_QUEUE_FULL

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


STATUS_REQUEST Field

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..STATUS_REQUEST Field
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static Guid STATUS_REQUEST
Visual Basic
Public Shared STATUS_REQUEST As Guid
Visual C++
public:
static Guid STATUS_REQUEST

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


STATUSLOOKUP Field

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..STATUSLOOKUP Field
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static Guid STATUSLOOKUP
Visual Basic
Public Shared STATUSLOOKUP As Guid
Visual C++
public:
static Guid STATUSLOOKUP

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


AnalyticsManager Methods

[image] [image]

Sitecore 6.4.1 API
AnalyticsManager Methods
AnalyticsManager Class See Also Send Feedback

The AnalyticsManager type exposes the following members.

Methods

 | Name | Description
 | DeleteSubscription | Deletes the subscription.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute | Executes the specified command text.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FormatBigString | Convert to char.
 | FormatCommandText | Formats the command text.
 | FormatFunctionName | Formats the functionName of the function.
 | GetAddIpOwnerIdByNameAndCountry | Gets the add ip owner id by name and country.
 | GetBrowserById | Gets the browser by id.
 | GetBrowserIdByUserAgent | Gets the browser by user agent.
 | GetBrowsers | Gets the browsers.
 | GetCampaignById | Gets the campaign by id.
 | GetCampaignEventById | Gets the campaign event by id.
 | GetCampaignEvents | Gets the campaign events.
 | GetCampaignEventsByCampaignId | Gets the campaign events by campaign id.
 | GetCampaigns | Gets the campaigns.
 | GetDateTime | Gets the date time.
 | GetDouble | Gets the double.
 | GetGlobalSessionById | Gets the global session by id.
 | GetGlobalSessionIdByCookieValue | Gets the global session id by cookie value.
 | GetGlobalSessions | Gets the global sessions.
 | GetGuid | Gets the GUID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInt | Gets the int.
 | GetIPById | Gets the IP by id.
 | GetIPBySessionId | Gets the IP by session id.
 | GetIpOwnerById | Gets the ip owner by id.
 | GetIpOwnerBySessionId | Gets the ip owner by session id.
 | GetIpOwnerIdsBySessionId | Gets the ip owner ids by session id.
 | GetIPs | Gets the list of IPs.
 | GetIPsByOwnerId | Gets the IPs by owner id.
 | GetKeywordIdByKeywords | Gets the keyword id by keywords.
 | GetKeywordsBySessionId | Gets the keywords by session id.
 | GetLong | Gets the long.
 | GetLookupData | Gets the lookup data.
 | GetMatchReportQueryPattern | Gets the match report query pattern.
 | GetMultiVarianceTestDefinitionById | Gets the multi variance test definitions by id.
 | GetMultiVarianceTestDefinitions | Gets the multi variance test definitions.
 | GetMultiVarianceTestVariableById | Gets the multi variance test variable by id.
 | GetMultiVarianceTestVariablesByTestDefinitionId | Gets the multi variance test variables by test definition id.
 | GetOperatingSystemById | Gets the operating system by id.
 | GetOperatingSystems | Gets the operating systems.
 | GetOrAddIpIdByAddressFrom | Gets the ip ID by address from.
 | GetPageById | Gets the page by id.
 | GetPageBySessionIdAndPageNo | Gets the page by session id and page no.
 | GetPageEventById | Gets the page event by id.
 | GetPageEventDefinitionById | Gets the page event definition by id.
 | GetPageEventDefinitionFailureNotSystem | Gets the page event definition failure system.
 | GetPageEventDefinitionNotGoalNotFailureNotSystem | Gets the page event definition goal failure not system.
 | GetPageEventDefinitions | Gets the page event definitions.
 | GetPageEventDefinitionsIsGoalNotSystem | Gets the page event definitions is goal not system.
 | GetPageEventsByPageId | Gets the page events by page id.
 | GetPagesBySessionId | Gets the pages by session id.
 | GetProfileById | Gets the profile by id.
 | GetProfileDefinitionById | Gets the profile definition by id.
 | GetProfileDefinitions | Gets the profile definitions.
 | GetProfileKeyDefinitionById | Gets the profile key definition by id.
 | GetProfileKeyDefinitions | Gets the profile key definitions.
 | GetProfileKeyDefinitionsById | Gets the profile key definitions by profile definition id.
 | GetProfileKeysByProfileId | Gets the profile keys by profile id.
 | GetProfilesBySessionId | Gets the profiles by session id.
 | GetReferringSiteByUrl | Gets the referring site by URL.
 | GetReferringSites | Gets the referring sites.
 | GetReportsDatabase | Gets the reports database.
 | GetReportsDataSourceType | Gets the type of the reports data source.
 | GetScreenByScreenId | Gets the screen by screen id.
 | GetScreens | Gets the screens.
 | GetSessionByAspNetSessionId | Gets the session.
 | GetSessionBySessionId | Gets the session by session id.
 | GetSessionIdByAspNetSessionId | Gets the session id by ASP session id.
 | GetSessionsCountByGlobalSessionId | Gets the total by global session id.
 | GetStatusById | Gets the status.
 | GetStatuses | Gets the statuses.
 | GetString | Gets the string.
 | GetSubscriptionByEmailAndIPOwnerId | Gets the subscription.
 | GetSubscriptionById | Gets the subscription by id.
 | GetTagById | Gets the tag by id.
 | GetTagsByGlobalSessionId | Gets the tags by global session id.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetVendorSpecificReportPath | Gets the vendor specific report path.
 | GuidToRawString | Convert GUID to raw string.
 | InsertBrowser | Inserts the browser.
 | InsertCampaign | Inserts the campaign.
 | InsertCampaignEvent | Inserts the campaign event.
 | InsertCampaignEventPage | Inserts the campaign event page.
 | InsertGlobalSession | Inserts the global session.
 | InsertIPOwner | Inserts the IP owner.
 | InsertKeyword | Inserts the keyword.
 | InsertMultiVarianceTestDefinition(Guid, String, String) | Inserts the multi variance test definition.
 | InsertMultiVarianceTestDefinition(String, String, Guid) | Inserts the multi variance test definition.
 | InsertMultiVarianceTestVariable | Inserts the multi variance test variable.
 | InsertMultiVarianceTestVariableCampaignEvent | Inserts the multi variance test variable campaign event.
 | InsertMultiVarianceTestVariablePage | Inserts the multi variance test variable page.
 | InsertOperatingSystem | Inserts the operating system.
 | InsertPage | Inserts the page.
 | InsertPageEvent | Inserts the page event.
 | InsertPageEventDefinition | Inserts the page event definition.
 | InsertProfile | Inserts the profile.
 | InsertProfileDefinition | Inserts the profile definition.
 | InsertProfileKey | Inserts the profile key.
 | InsertProfileKeyDefinition | Inserts the profile key definition.
 | InsertReferringSite | Inserts the referring site.
 | InsertScreen | Inserts the screen.
 | InsertSession | Inserts the session.
 | InsertSubscription | Inserts the subscription.
 | InsertTag | Inserts the tag.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RawStringToGuid | Convert the string to GUID.
 | ReadMany<(Of <<'(T>)>>)(String, Func<(Of <<'(DataProviderReader, T>)>>), array<Object>[]()[][]) | Reads the specified command text.
 | ReadMany<(Of <<'(T>)>>)(String, Func<(Of <<'(DataProviderReader, T>)>>), Int32, array<Object>[]()[][]) | Reads the specified command text.
 | ReadOne<(Of <<'(T>)>>)(String, Func<(Of <<'(DataProviderReader, T>)>>), array<Object>[]()[][]) | Reads the one.
 | ReadOne<(Of <<'(T>)>>)(String, Func<(Of <<'(DataProviderReader, T>)>>), Func<(Of <<'(T>)>>), array<Object>[]()[][]) | Reads the specified command text.
 | SaveCampaignDefinition | Saves the campaign definition.
 | SaveCampaignEvent | Saves the campaign event.
 | SaveMultiVarianceTestDefinition | Saves the multi variance test.
 | SaveMultiVarianceTestVariable | Saves the multi variance test variable.
 | SavePageEventDefinition | Saves the page event definition.
 | SaveProfileDefinition | Saves the profile definition.
 | SaveProfileKeyDefinition | Saves the profile key definition.
 | SetStatusFailed | Sets the status failed.
 | SetStatusSuccessful | Sets the status successful.
 | Submit | Submits the specified tracker.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateBothIdentificationsBySessionId | Updates the both identifications by session id.
 | UpdateBrowser | Updates the browser.
 | UpdateCampaign | Updates the campaign.
 | UpdateCampaignEvent | Updates the campaign event.
 | UpdateCountTotalByProfileId | Updates the profile count total.
 | UpdateCurrentPageBySessionId | Updates the current page by session id.
 | UpdateGlobalSession | Updates the global session.
 | UpdateIP | Updates the IP.
 | UpdateIpInformation(Guid, WhoIsInformation) | Updates the ip information.
 | UpdateIpInformation(Guid, WhoIsInformation, Action<(Of <<'(IP>)>>)) | Updates the ip information.
 | UpdateIPOwner | Updates the IP owner.
 | UpdateMultiVarianceTestDefinition | Updates the multi variance test definition.
 | UpdatePage(Guid, DateTime, Int32, Int32, Guid, String, Int32, Guid, String, String, String, String) | Updates the page.
 | UpdatePage(Guid, Guid, DateTime, Int32, Int32, Guid, String, Int32, Guid, String, String, String, String) | Updates the page.
 | UpdateProfileKey | Updates the profile key.
 | UpdateVisitorIdentificationByIpOwnerId | Updates the visitor identification by ip order id.
 | UpdateVisitorIdentificationBySessionId | Updates the visitor identification by session id.
 | UpdateVisitorIdentifications | Updates the visitor identifications.
 | UpdateVisitorIdentificationsByIPOwnerBrowser | Updates the visitor identifications by IP owner browser.

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


DeleteSubscription Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..DeleteSubscription Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int DeleteSubscription(
    Guid subscriptionId
)
Visual Basic
Public Shared Function DeleteSubscription ( _
    subscriptionId As Guid _
) As Integer
Visual C++
public:
static int DeleteSubscription(
    Guid subscriptionId
)

Parameters

subscriptionId
Type: System..::..Guid
The subscription id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.DeleteSubscription(System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


FormatBigString Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..FormatBigString Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static string FormatBigString(
    string columnName
)
Visual Basic
Public Shared Function FormatBigString ( _
    columnName As String _
) As String
Visual C++
public:
static String^ FormatBigString(
    String^ columnName
)

Parameters

columnName
Type: System..::..String
Name of the column.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.FormatBigString(System.String)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


FormatCommandText Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..FormatCommandText Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static string FormatCommandText(
    string commandText
)
Visual Basic
Public Shared Function FormatCommandText ( _
    commandText As String _
) As String
Visual C++
public:
static String^ FormatCommandText(
    String^ commandText
)

Parameters

commandText
Type: System..::..String
The command text.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.FormatCommandText(System.String)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


FormatFunctionName Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..FormatFunctionName Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static string FormatFunctionName(
    string functionName
)
Visual Basic
Public Shared Function FormatFunctionName ( _
    functionName As String _
) As String
Visual C++
public:
static String^ FormatFunctionName(
    String^ functionName
)

Parameters

functionName
Type: System..::..String
The name.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.FormatFunctionName(System.String)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetAddIpOwnerIdByNameAndCountry Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetAddIpOwnerIdByNameAndCountry Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static Guid GetAddIpOwnerIdByNameAndCountry(
    string name,
    string country
)
Visual Basic
Public Shared Function GetAddIpOwnerIdByNameAndCountry ( _
    name As String, _
    country As String _
) As Guid
Visual C++
public:
static Guid GetAddIpOwnerIdByNameAndCountry(
    String^ name,
    String^ country
)

Parameters

name
Type: System..::..String
The name.
country
Type: System..::..String
The country.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetAddIpOwnerIdByNameAndCountry(System.String,System.String)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetBrowserById Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetBrowserById Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static Browser GetBrowserById(
    Guid browserId
)
Visual Basic
Public Shared Function GetBrowserById ( _
    browserId As Guid _
) As Browser
Visual C++
public:
static Browser^ GetBrowserById(
    Guid browserId
)

Parameters

browserId
Type: System..::..Guid
The browser id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetBrowserById(System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetBrowsers Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetBrowsers Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static List<Browser> GetBrowsers()
Visual Basic
Public Shared Function GetBrowsers As List(Of Browser)
Visual C++
public:
static List<Browser^>^ GetBrowsers()

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetBrowsers"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetCampaignById Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetCampaignById Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static Campaign GetCampaignById(
    Guid campaignId
)
Visual Basic
Public Shared Function GetCampaignById ( _
    campaignId As Guid _
) As Campaign
Visual C++
public:
static Campaign^ GetCampaignById(
    Guid campaignId
)

Parameters

campaignId
Type: System..::..Guid
The campaign id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetCampaignById(System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetCampaignEventById Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetCampaignEventById Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static CampaignEvent GetCampaignEventById(
    Guid campaignEventId
)
Visual Basic
Public Shared Function GetCampaignEventById ( _
    campaignEventId As Guid _
) As CampaignEvent
Visual C++
public:
static CampaignEvent^ GetCampaignEventById(
    Guid campaignEventId
)

Parameters

campaignEventId
Type: System..::..Guid
The campaign event id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetCampaignEventById(System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetCampaignEvents Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetCampaignEvents Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static List<CampaignEvent> GetCampaignEvents()
Visual Basic
Public Shared Function GetCampaignEvents As List(Of CampaignEvent)
Visual C++
public:
static List<CampaignEvent^>^ GetCampaignEvents()

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetCampaignEvents"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetCampaignEventsByCampaignId Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetCampaignEventsByCampaignId Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static List<CampaignEvent> GetCampaignEventsByCampaignId(
    Guid campaignId
)
Visual Basic
Public Shared Function GetCampaignEventsByCampaignId ( _
    campaignId As Guid _
) As List(Of CampaignEvent)
Visual C++
public:
static List<CampaignEvent^>^ GetCampaignEventsByCampaignId(
    Guid campaignId
)

Parameters

campaignId
Type: System..::..Guid
The campaign id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetCampaignEventsByCampaignId(System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetCampaigns Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetCampaigns Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static List<Campaign> GetCampaigns()
Visual Basic
Public Shared Function GetCampaigns As List(Of Campaign)
Visual C++
public:
static List<Campaign^>^ GetCampaigns()

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetCampaigns"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetDateTime Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetDateTime Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static DateTime GetDateTime(
    int columnIndex,
    DataProviderReader reader
)
Visual Basic
Public Shared Function GetDateTime ( _
    columnIndex As Integer, _
    reader As DataProviderReader _
) As DateTime
Visual C++
public:
static DateTime GetDateTime(
    int columnIndex,
    DataProviderReader^ reader
)

Parameters

columnIndex
Type: System..::..Int32
Index of the column.
reader
Type: Sitecore.Data.DataProviders.Sql..::..DataProviderReader
The reader.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetDateTime(System.Int32,Sitecore.Data.DataProviders.Sql.DataProviderReader)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetDouble Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetDouble Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static double GetDouble(
    int columnIndex,
    DataProviderReader reader
)
Visual Basic
Public Shared Function GetDouble ( _
    columnIndex As Integer, _
    reader As DataProviderReader _
) As Double
Visual C++
public:
static double GetDouble(
    int columnIndex,
    DataProviderReader^ reader
)

Parameters

columnIndex
Type: System..::..Int32
Index of the column.
reader
Type: Sitecore.Data.DataProviders.Sql..::..DataProviderReader
The reader.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetDouble(System.Int32,Sitecore.Data.DataProviders.Sql.DataProviderReader)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetGlobalSessionById Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetGlobalSessionById Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static GlobalSession GetGlobalSessionById(
    Guid globalSessionId
)
Visual Basic
Public Shared Function GetGlobalSessionById ( _
    globalSessionId As Guid _
) As GlobalSession
Visual C++
public:
static GlobalSession^ GetGlobalSessionById(
    Guid globalSessionId
)

Parameters

globalSessionId
Type: System..::..Guid
The global session id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetGlobalSessionById(System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetGlobalSessionIdByCookieValue Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetGlobalSessionIdByCookieValue Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static GlobalSession GetGlobalSessionIdByCookieValue(
    string cookieValue
)
Visual Basic
Public Shared Function GetGlobalSessionIdByCookieValue ( _
    cookieValue As String _
) As GlobalSession
Visual C++
public:
static GlobalSession^ GetGlobalSessionIdByCookieValue(
    String^ cookieValue
)

Parameters

cookieValue
Type: System..::..String
The cookie value.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetGlobalSessionIdByCookieValue(System.String)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetGlobalSessions Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetGlobalSessions Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static List<GlobalSession> GetGlobalSessions()
Visual Basic
Public Shared Function GetGlobalSessions As List(Of GlobalSession)
Visual C++
public:
static List<GlobalSession^>^ GetGlobalSessions()

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetGlobalSessions"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetGuid Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetGuid Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static Guid GetGuid(
    int columnIndex,
    DataProviderReader reader
)
Visual Basic
Public Shared Function GetGuid ( _
    columnIndex As Integer, _
    reader As DataProviderReader _
) As Guid
Visual C++
public:
static Guid GetGuid(
    int columnIndex,
    DataProviderReader^ reader
)

Parameters

columnIndex
Type: System..::..Int32
Index of the column.
reader
Type: Sitecore.Data.DataProviders.Sql..::..DataProviderReader
The reader.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetGuid(System.Int32,Sitecore.Data.DataProviders.Sql.DataProviderReader)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetInt Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetInt Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int GetInt(
    int columnIndex,
    DataProviderReader reader
)
Visual Basic
Public Shared Function GetInt ( _
    columnIndex As Integer, _
    reader As DataProviderReader _
) As Integer
Visual C++
public:
static int GetInt(
    int columnIndex,
    DataProviderReader^ reader
)

Parameters

columnIndex
Type: System..::..Int32
Index of the column.
reader
Type: Sitecore.Data.DataProviders.Sql..::..DataProviderReader
The reader.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetInt(System.Int32,Sitecore.Data.DataProviders.Sql.DataProviderReader)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetIPById Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetIPById Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static IP GetIPById(
    Guid ipId
)
Visual Basic
Public Shared Function GetIPById ( _
    ipId As Guid _
) As IP
Visual C++
public:
static IP^ GetIPById(
    Guid ipId
)

Parameters

ipId
Type: System..::..Guid
The ip id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetIPById(System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetIPBySessionId Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetIPBySessionId Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static IP GetIPBySessionId(
    Guid sessionId
)
Visual Basic
Public Shared Function GetIPBySessionId ( _
    sessionId As Guid _
) As IP
Visual C++
public:
static IP^ GetIPBySessionId(
    Guid sessionId
)

Parameters

sessionId
Type: System..::..Guid
The session id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetIPBySessionId(System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetIpOwnerById Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetIpOwnerById Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static IPOwner GetIpOwnerById(
    Guid ipOwnerId
)
Visual Basic
Public Shared Function GetIpOwnerById ( _
    ipOwnerId As Guid _
) As IPOwner
Visual C++
public:
static IPOwner^ GetIpOwnerById(
    Guid ipOwnerId
)

Parameters

ipOwnerId
Type: System..::..Guid
The ip owner id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetIpOwnerById(System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetIpOwnerBySessionId Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetIpOwnerBySessionId Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static IPOwner GetIpOwnerBySessionId(
    Guid sessionId
)
Visual Basic
Public Shared Function GetIpOwnerBySessionId ( _
    sessionId As Guid _
) As IPOwner
Visual C++
public:
static IPOwner^ GetIpOwnerBySessionId(
    Guid sessionId
)

Parameters

sessionId
Type: System..::..Guid
The session id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetIpOwnerBySessionId(System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetIpOwnerIdsBySessionId Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetIpOwnerIdsBySessionId Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static List<Guid> GetIpOwnerIdsBySessionId(
    Guid sessionId
)
Visual Basic
Public Shared Function GetIpOwnerIdsBySessionId ( _
    sessionId As Guid _
) As List(Of Guid)
Visual C++
public:
static List<Guid>^ GetIpOwnerIdsBySessionId(
    Guid sessionId
)

Parameters

sessionId
Type: System..::..Guid
The session id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetIpOwnerIdsBySessionId(System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetIPs Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetIPs Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static List<LookupData> GetIPs(
    int maxEntries
)
Visual Basic
Public Shared Function GetIPs ( _
    maxEntries As Integer _
) As List(Of LookupData)
Visual C++
public:
static List<LookupData^>^ GetIPs(
    int maxEntries
)

Parameters

maxEntries
Type: System..::..Int32
The max entries.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetIPs(System.Int32)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetIPsByOwnerId Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetIPsByOwnerId Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static List<LookupData> GetIPsByOwnerId(
    int maxEntries,
    Guid ipOwnerId
)
Visual Basic
Public Shared Function GetIPsByOwnerId ( _
    maxEntries As Integer, _
    ipOwnerId As Guid _
) As List(Of LookupData)
Visual C++
public:
static List<LookupData^>^ GetIPsByOwnerId(
    int maxEntries,
    Guid ipOwnerId
)

Parameters

maxEntries
Type: System..::..Int32
The max entries.
ipOwnerId
Type: System..::..Guid
The ip owner id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetIPsByOwnerId(System.Int32,System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetKeywordIdByKeywords Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetKeywordIdByKeywords Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static Guid GetKeywordIdByKeywords(
    string keywords
)
Visual Basic
Public Shared Function GetKeywordIdByKeywords ( _
    keywords As String _
) As Guid
Visual C++
public:
static Guid GetKeywordIdByKeywords(
    String^ keywords
)

Parameters

keywords
Type: System..::..String
The keywords.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetKeywordIdByKeywords(System.String)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetKeywordsBySessionId Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetKeywordsBySessionId Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static string GetKeywordsBySessionId(
    Guid sessionId
)
Visual Basic
Public Shared Function GetKeywordsBySessionId ( _
    sessionId As Guid _
) As String
Visual C++
public:
static String^ GetKeywordsBySessionId(
    Guid sessionId
)

Parameters

sessionId
Type: System..::..Guid
The session id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetKeywordsBySessionId(System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetLong Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetLong Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static long GetLong(
    int columnIndex,
    DataProviderReader reader
)
Visual Basic
Public Shared Function GetLong ( _
    columnIndex As Integer, _
    reader As DataProviderReader _
) As Long
Visual C++
public:
static long long GetLong(
    int columnIndex,
    DataProviderReader^ reader
)

Parameters

columnIndex
Type: System..::..Int32
Index of the column.
reader
Type: Sitecore.Data.DataProviders.Sql..::..DataProviderReader
The reader.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetLong(System.Int32,Sitecore.Data.DataProviders.Sql.DataProviderReader)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetLookupData Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetLookupData Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static IEnumerable<LookupData> GetLookupData(
    bool onlyBlanks,
    int maxEntries
)
Visual Basic
Public Shared Function GetLookupData ( _
    onlyBlanks As Boolean, _
    maxEntries As Integer _
) As IEnumerable(Of LookupData)
Visual C++
public:
static IEnumerable<LookupData^>^ GetLookupData(
    bool onlyBlanks,
    int maxEntries
)

Parameters

onlyBlanks
Type: System..::..Boolean
if set to true [blanks].
maxEntries
Type: System..::..Int32
The max entries.

Return Value

The lookup data.

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetMatchReportQueryPattern Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetMatchReportQueryPattern Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static string GetMatchReportQueryPattern()
Visual Basic
Public Shared Function GetMatchReportQueryPattern As String
Visual C++
public:
static String^ GetMatchReportQueryPattern()

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetMatchReportQueryPattern"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetMultiVarianceTestDefinitionById Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetMultiVarianceTestDefinitionById Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static MultiVarianceTestDefinition GetMultiVarianceTestDefinitionById(
    Guid multiVarianceTestId
)
Visual Basic
Public Shared Function GetMultiVarianceTestDefinitionById ( _
    multiVarianceTestId As Guid _
) As MultiVarianceTestDefinition
Visual C++
public:
static MultiVarianceTestDefinition^ GetMultiVarianceTestDefinitionById(
    Guid multiVarianceTestId
)

Parameters

multiVarianceTestId
Type: System..::..Guid
The multi variance test id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetMultiVarianceTestDefinitionById(System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetMultiVarianceTestVariableById Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetMultiVarianceTestVariableById Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static MultiVarianceTestVariable GetMultiVarianceTestVariableById(
    Guid multiVarianceTestVariableId
)
Visual Basic
Public Shared Function GetMultiVarianceTestVariableById ( _
    multiVarianceTestVariableId As Guid _
) As MultiVarianceTestVariable
Visual C++
public:
static MultiVarianceTestVariable^ GetMultiVarianceTestVariableById(
    Guid multiVarianceTestVariableId
)

Parameters

multiVarianceTestVariableId
Type: System..::..Guid
The multi variance test variable id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetMultiVarianceTestVariableById(System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetMultiVarianceTestVariablesByTestDefinitionId Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetMultiVarianceTestVariablesByTestDefinitionId Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static List<MultiVarianceTestVariable> GetMultiVarianceTestVariablesByTestDefinitionId(
    Guid multiVarianceTestDefinitionId
)
Visual Basic
Public Shared Function GetMultiVarianceTestVariablesByTestDefinitionId ( _
    multiVarianceTestDefinitionId As Guid _
) As List(Of MultiVarianceTestVariable)
Visual C++
public:
static List<MultiVarianceTestVariable^>^ GetMultiVarianceTestVariablesByTestDefinitionId(
    Guid multiVarianceTestDefinitionId
)

Parameters

multiVarianceTestDefinitionId
Type: System..::..Guid
The multi variance test definition id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetMultiVarianceTestVariablesByTestDefinitionId(System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetOperatingSystemById Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetOperatingSystemById Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static OperatingSystem GetOperatingSystemById(
    Guid operatingSystemId
)
Visual Basic
Public Shared Function GetOperatingSystemById ( _
    operatingSystemId As Guid _
) As OperatingSystem
Visual C++
public:
static OperatingSystem^ GetOperatingSystemById(
    Guid operatingSystemId
)

Parameters

operatingSystemId
Type: System..::..Guid
The operating system id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetOperatingSystemById(System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetOperatingSystems Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetOperatingSystems Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static List<OperatingSystem> GetOperatingSystems()
Visual Basic
Public Shared Function GetOperatingSystems As List(Of OperatingSystem)
Visual C++
public:
static List<OperatingSystem^>^ GetOperatingSystems()

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetOperatingSystems"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetOrAddIpIdByAddressFrom Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetOrAddIpIdByAddressFrom Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static Guid GetOrAddIpIdByAddressFrom(
    string ipAddressFrom
)
Visual Basic
Public Shared Function GetOrAddIpIdByAddressFrom ( _
    ipAddressFrom As String _
) As Guid
Visual C++
public:
static Guid GetOrAddIpIdByAddressFrom(
    String^ ipAddressFrom
)

Parameters

ipAddressFrom
Type: System..::..String
The address from.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetOrAddIpIdByAddressFrom(System.String)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetPageById Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetPageById Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static Page GetPageById(
    Guid pageId
)
Visual Basic
Public Shared Function GetPageById ( _
    pageId As Guid _
) As Page
Visual C++
public:
static Page^ GetPageById(
    Guid pageId
)

Parameters

pageId
Type: System..::..Guid
The page id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetPageById(System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetPageBySessionIdAndPageNo Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetPageBySessionIdAndPageNo Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static Page GetPageBySessionIdAndPageNo(
    Guid sessionId,
    int pageNo
)
Visual Basic
Public Shared Function GetPageBySessionIdAndPageNo ( _
    sessionId As Guid, _
    pageNo As Integer _
) As Page
Visual C++
public:
static Page^ GetPageBySessionIdAndPageNo(
    Guid sessionId,
    int pageNo
)

Parameters

sessionId
Type: System..::..Guid
The session id.
pageNo
Type: System..::..Int32
The page no.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetPageBySessionIdAndPageNo(System.Guid,System.Int32)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetPageEventById Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetPageEventById Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static PageEvent GetPageEventById(
    Guid pageEventId
)
Visual Basic
Public Shared Function GetPageEventById ( _
    pageEventId As Guid _
) As PageEvent
Visual C++
public:
static PageEvent^ GetPageEventById(
    Guid pageEventId
)

Parameters

pageEventId
Type: System..::..Guid
The page event id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetPageEventById(System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetPageEventDefinitionById Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetPageEventDefinitionById Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static PageEventDefinition GetPageEventDefinitionById(
    Guid pageEventDefinitionId
)
Visual Basic
Public Shared Function GetPageEventDefinitionById ( _
    pageEventDefinitionId As Guid _
) As PageEventDefinition
Visual C++
public:
static PageEventDefinition^ GetPageEventDefinitionById(
    Guid pageEventDefinitionId
)

Parameters

pageEventDefinitionId
Type: System..::..Guid
The page event definition id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetPageEventDefinitionById(System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetPageEventDefinitionFailureNotSystem Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetPageEventDefinitionFailureNotSystem Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static List<PageEventDefinition> GetPageEventDefinitionFailureNotSystem()
Visual Basic
Public Shared Function GetPageEventDefinitionFailureNotSystem As List(Of PageEventDefinition)
Visual C++
public:
static List<PageEventDefinition^>^ GetPageEventDefinitionFailureNotSystem()

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetPageEventDefinitionFailureNotSystem"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetPageEventDefinitionNotGoalNotFailureNotSystem Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetPageEventDefinitionNotGoalNotFailureNotSystem Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static List<PageEventDefinition> GetPageEventDefinitionNotGoalNotFailureNotSystem()
Visual Basic
Public Shared Function GetPageEventDefinitionNotGoalNotFailureNotSystem As List(Of PageEventDefinition)
Visual C++
public:
static List<PageEventDefinition^>^ GetPageEventDefinitionNotGoalNotFailureNotSystem()

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetPageEventDefinitionNotGoalNotFailureNotSystem"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetPageEventDefinitions Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetPageEventDefinitions Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static List<PageEventDefinition> GetPageEventDefinitions()
Visual Basic
Public Shared Function GetPageEventDefinitions As List(Of PageEventDefinition)
Visual C++
public:
static List<PageEventDefinition^>^ GetPageEventDefinitions()

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetPageEventDefinitions"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetPageEventDefinitionsIsGoalNotSystem Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetPageEventDefinitionsIsGoalNotSystem Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static List<PageEventDefinition> GetPageEventDefinitionsIsGoalNotSystem()
Visual Basic
Public Shared Function GetPageEventDefinitionsIsGoalNotSystem As List(Of PageEventDefinition)
Visual C++
public:
static List<PageEventDefinition^>^ GetPageEventDefinitionsIsGoalNotSystem()

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetPageEventDefinitionsIsGoalNotSystem"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetPageEventsByPageId Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetPageEventsByPageId Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static List<PageEvent> GetPageEventsByPageId(
    Guid pageId
)
Visual Basic
Public Shared Function GetPageEventsByPageId ( _
    pageId As Guid _
) As List(Of PageEvent)
Visual C++
public:
static List<PageEvent^>^ GetPageEventsByPageId(
    Guid pageId
)

Parameters

pageId
Type: System..::..Guid
The page id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetPageEventsByPageId(System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetPagesBySessionId Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetPagesBySessionId Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static List<Page> GetPagesBySessionId(
    Guid sessionId
)
Visual Basic
Public Shared Function GetPagesBySessionId ( _
    sessionId As Guid _
) As List(Of Page)
Visual C++
public:
static List<Page^>^ GetPagesBySessionId(
    Guid sessionId
)

Parameters

sessionId
Type: System..::..Guid
The session id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetPagesBySessionId(System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetProfileById Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetProfileById Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static Profile GetProfileById(
    Guid profileId
)
Visual Basic
Public Shared Function GetProfileById ( _
    profileId As Guid _
) As Profile
Visual C++
public:
static Profile^ GetProfileById(
    Guid profileId
)

Parameters

profileId
Type: System..::..Guid
The profile id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetProfileById(System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetProfileDefinitionById Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetProfileDefinitionById Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static ProfileDefinition GetProfileDefinitionById(
    Guid profileDefinitionId
)
Visual Basic
Public Shared Function GetProfileDefinitionById ( _
    profileDefinitionId As Guid _
) As ProfileDefinition
Visual C++
public:
static ProfileDefinition^ GetProfileDefinitionById(
    Guid profileDefinitionId
)

Parameters

profileDefinitionId
Type: System..::..Guid
The profile definition id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetProfileDefinitionById(System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetProfileKeyDefinitionById Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetProfileKeyDefinitionById Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static ProfileKeyDefinition GetProfileKeyDefinitionById(
    Guid profileKeyDefinitionById
)
Visual Basic
Public Shared Function GetProfileKeyDefinitionById ( _
    profileKeyDefinitionById As Guid _
) As ProfileKeyDefinition
Visual C++
public:
static ProfileKeyDefinition^ GetProfileKeyDefinitionById(
    Guid profileKeyDefinitionById
)

Parameters

profileKeyDefinitionById
Type: System..::..Guid
The profile key definition by id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetProfileKeyDefinitionById(System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetProfileKeyDefinitions Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetProfileKeyDefinitions Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static List<ProfileKeyDefinition> GetProfileKeyDefinitions()
Visual Basic
Public Shared Function GetProfileKeyDefinitions As List(Of ProfileKeyDefinition)
Visual C++
public:
static List<ProfileKeyDefinition^>^ GetProfileKeyDefinitions()

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetProfileKeyDefinitions"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetProfileKeyDefinitionsById Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetProfileKeyDefinitionsById Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static List<ProfileKeyDefinition> GetProfileKeyDefinitionsById(
    Guid profileDefinitionId
)
Visual Basic
Public Shared Function GetProfileKeyDefinitionsById ( _
    profileDefinitionId As Guid _
) As List(Of ProfileKeyDefinition)
Visual C++
public:
static List<ProfileKeyDefinition^>^ GetProfileKeyDefinitionsById(
    Guid profileDefinitionId
)

Parameters

profileDefinitionId
Type: System..::..Guid
The profile definition id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetProfileKeyDefinitionsById(System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetProfileKeysByProfileId Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetProfileKeysByProfileId Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static List<ProfileKey> GetProfileKeysByProfileId(
    Guid profileId
)
Visual Basic
Public Shared Function GetProfileKeysByProfileId ( _
    profileId As Guid _
) As List(Of ProfileKey)
Visual C++
public:
static List<ProfileKey^>^ GetProfileKeysByProfileId(
    Guid profileId
)

Parameters

profileId
Type: System..::..Guid
The profile id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetProfileKeysByProfileId(System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetProfilesBySessionId Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetProfilesBySessionId Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static List<Profile> GetProfilesBySessionId(
    Guid sessionId
)
Visual Basic
Public Shared Function GetProfilesBySessionId ( _
    sessionId As Guid _
) As List(Of Profile)
Visual C++
public:
static List<Profile^>^ GetProfilesBySessionId(
    Guid sessionId
)

Parameters

sessionId
Type: System..::..Guid
The session id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetProfilesBySessionId(System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetReferringSiteByUrl Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetReferringSiteByUrl Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static ReferringSite GetReferringSiteByUrl(
    string url
)
Visual Basic
Public Shared Function GetReferringSiteByUrl ( _
    url As String _
) As ReferringSite
Visual C++
public:
static ReferringSite^ GetReferringSiteByUrl(
    String^ url
)

Parameters

url
Type: System..::..String
The URL.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetReferringSiteByUrl(System.String)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetReferringSites Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetReferringSites Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static List<ReferringSite> GetReferringSites()
Visual Basic
Public Shared Function GetReferringSites As List(Of ReferringSite)
Visual C++
public:
static List<ReferringSite^>^ GetReferringSites()

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetReferringSites"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetReportsDatabase Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetReportsDatabase Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static StiDatabase GetReportsDatabase()
Visual Basic
Public Shared Function GetReportsDatabase As StiDatabase
Visual C++
public:
static StiDatabase^ GetReportsDatabase()

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetReportsDatabase"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetReportsDataSourceType Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetReportsDataSourceType Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static string GetReportsDataSourceType()
Visual Basic
Public Shared Function GetReportsDataSourceType As String
Visual C++
public:
static String^ GetReportsDataSourceType()

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetReportsDataSourceType"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetScreenByScreenId Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetScreenByScreenId Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static Screen GetScreenByScreenId(
    Guid screenId
)
Visual Basic
Public Shared Function GetScreenByScreenId ( _
    screenId As Guid _
) As Screen
Visual C++
public:
static Screen^ GetScreenByScreenId(
    Guid screenId
)

Parameters

screenId
Type: System..::..Guid
The screen id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetScreenByScreenId(System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetScreens Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetScreens Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static List<Screen> GetScreens()
Visual Basic
Public Shared Function GetScreens As List(Of Screen)
Visual C++
public:
static List<Screen^>^ GetScreens()

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetScreens"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetSessionByAspNetSessionId Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetSessionByAspNetSessionId Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static Session GetSessionByAspNetSessionId(
    string aspNetSessionId
)
Visual Basic
Public Shared Function GetSessionByAspNetSessionId ( _
    aspNetSessionId As String _
) As Session
Visual C++
public:
static Session^ GetSessionByAspNetSessionId(
    String^ aspNetSessionId
)

Parameters

aspNetSessionId
Type: System..::..String
The ASP net session id.

Return Value

Returns the session.

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetSessionBySessionId Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetSessionBySessionId Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static Session GetSessionBySessionId(
    Guid sessionId
)
Visual Basic
Public Shared Function GetSessionBySessionId ( _
    sessionId As Guid _
) As Session
Visual C++
public:
static Session^ GetSessionBySessionId(
    Guid sessionId
)

Parameters

sessionId
Type: System..::..Guid
The session id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetSessionBySessionId(System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetSessionIdByAspNetSessionId Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetSessionIdByAspNetSessionId Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static Guid GetSessionIdByAspNetSessionId(
    string aspNetSessionId
)
Visual Basic
Public Shared Function GetSessionIdByAspNetSessionId ( _
    aspNetSessionId As String _
) As Guid
Visual C++
public:
static Guid GetSessionIdByAspNetSessionId(
    String^ aspNetSessionId
)

Parameters

aspNetSessionId
Type: System..::..String
The ASP net session id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetSessionIdByAspNetSessionId(System.String)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetSessionsCountByGlobalSessionId Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetSessionsCountByGlobalSessionId Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int GetSessionsCountByGlobalSessionId(
    Guid globalSessionId
)
Visual Basic
Public Shared Function GetSessionsCountByGlobalSessionId ( _
    globalSessionId As Guid _
) As Integer
Visual C++
public:
static int GetSessionsCountByGlobalSessionId(
    Guid globalSessionId
)

Parameters

globalSessionId
Type: System..::..Guid
The global session id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetSessionsCountByGlobalSessionId(System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetStatusById Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetStatusById Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static Status GetStatusById(
    Guid statusId
)
Visual Basic
Public Shared Function GetStatusById ( _
    statusId As Guid _
) As Status
Visual C++
public:
static Status^ GetStatusById(
    Guid statusId
)

Parameters

statusId
Type: System..::..Guid
The status id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetStatusById(System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetStatuses Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetStatuses Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static List<Status> GetStatuses()
Visual Basic
Public Shared Function GetStatuses As List(Of Status)
Visual C++
public:
static List<Status^>^ GetStatuses()

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetStatuses"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetString Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetString Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static string GetString(
    int columnIndex,
    DataProviderReader reader
)
Visual Basic
Public Shared Function GetString ( _
    columnIndex As Integer, _
    reader As DataProviderReader _
) As String
Visual C++
public:
static String^ GetString(
    int columnIndex,
    DataProviderReader^ reader
)

Parameters

columnIndex
Type: System..::..Int32
Index of the column.
reader
Type: Sitecore.Data.DataProviders.Sql..::..DataProviderReader
The reader.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetString(System.Int32,Sitecore.Data.DataProviders.Sql.DataProviderReader)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetSubscriptionByEmailAndIPOwnerId Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetSubscriptionByEmailAndIPOwnerId Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static Subscription GetSubscriptionByEmailAndIPOwnerId(
    string email,
    Guid ipownerId
)
Visual Basic
Public Shared Function GetSubscriptionByEmailAndIPOwnerId ( _
    email As String, _
    ipownerId As Guid _
) As Subscription
Visual C++
public:
static Subscription^ GetSubscriptionByEmailAndIPOwnerId(
    String^ email,
    Guid ipownerId
)

Parameters

email
Type: System..::..String
The email.
ipownerId
Type: System..::..Guid
The ipowner id.

Return Value

The subscription.

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetSubscriptionById Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetSubscriptionById Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static Subscription GetSubscriptionById(
    Guid subscriptionId
)
Visual Basic
Public Shared Function GetSubscriptionById ( _
    subscriptionId As Guid _
) As Subscription
Visual C++
public:
static Subscription^ GetSubscriptionById(
    Guid subscriptionId
)

Parameters

subscriptionId
Type: System..::..Guid
The subscription id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetSubscriptionById(System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetTagById Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetTagById Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static Tag GetTagById(
    Guid tagId
)
Visual Basic
Public Shared Function GetTagById ( _
    tagId As Guid _
) As Tag
Visual C++
public:
static Tag^ GetTagById(
    Guid tagId
)

Parameters

tagId
Type: System..::..Guid
The tag id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetTagById(System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetTagsByGlobalSessionId Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetTagsByGlobalSessionId Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static List<Tag> GetTagsByGlobalSessionId(
    Guid globalSessionId
)
Visual Basic
Public Shared Function GetTagsByGlobalSessionId ( _
    globalSessionId As Guid _
) As List(Of Tag)
Visual C++
public:
static List<Tag^>^ GetTagsByGlobalSessionId(
    Guid globalSessionId
)

Parameters

globalSessionId
Type: System..::..Guid
The global session id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetTagsByGlobalSessionId(System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GetVendorSpecificReportPath Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GetVendorSpecificReportPath Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static string GetVendorSpecificReportPath(
    string reportPath
)
Visual Basic
Public Shared Function GetVendorSpecificReportPath ( _
    reportPath As String _
) As String
Visual C++
public:
static String^ GetVendorSpecificReportPath(
    String^ reportPath
)

Parameters

reportPath
Type: System..::..String
The report path.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GetVendorSpecificReportPath(System.String)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


GuidToRawString Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..GuidToRawString Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static string GuidToRawString(
    Guid guid
)
Visual Basic
Public Shared Function GuidToRawString ( _
    guid As Guid _
) As String
Visual C++
public:
static String^ GuidToRawString(
    Guid guid
)

Parameters

guid
Type: System..::..Guid
The GUID.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.GuidToRawString(System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


InsertBrowser Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..InsertBrowser Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int InsertBrowser(
    Guid browserId,
    string userAgent,
    string description,
    string comment,
    string link1,
    string link2,
    int visitorIdentification,
    string majorName,
    string version
)
Visual Basic
Public Shared Function InsertBrowser ( _
    browserId As Guid, _
    userAgent As String, _
    description As String, _
    comment As String, _
    link1 As String, _
    link2 As String, _
    visitorIdentification As Integer, _
    majorName As String, _
    version As String _
) As Integer
Visual C++
public:
static int InsertBrowser(
    Guid browserId,
    String^ userAgent,
    String^ description,
    String^ comment,
    String^ link1,
    String^ link2,
    int visitorIdentification,
    String^ majorName,
    String^ version
)

Parameters

browserId
Type: System..::..Guid
The browser id.
userAgent
Type: System..::..String
The user agent.
description
Type: System..::..String
The description.
comment
Type: System..::..String
The comment.
link1
Type: System..::..String
The link1.
link2
Type: System..::..String
The link2.
visitorIdentification
Type: System..::..Int32
The visitor identification.
majorName
Type: System..::..String
Name of the major.
version
Type: System..::..String
The version.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.InsertBrowser(System.Guid,System.String,System.String,System.String,System.String,System.String,System.Int32,System.String,System.String)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


InsertCampaign Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..InsertCampaign Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int InsertCampaign(
    Guid campaignId,
    string title,
    string type,
    string description,
    double cost,
    DateTime startDate,
    DateTime endDate,
    string data,
    bool isActive
)
Visual Basic
Public Shared Function InsertCampaign ( _
    campaignId As Guid, _
    title As String, _
    type As String, _
    description As String, _
    cost As Double, _
    startDate As DateTime, _
    endDate As DateTime, _
    data As String, _
    isActive As Boolean _
) As Integer
Visual C++
public:
static int InsertCampaign(
    Guid campaignId,
    String^ title,
    String^ type,
    String^ description,
    double cost,
    DateTime startDate,
    DateTime endDate,
    String^ data,
    bool isActive
)

Parameters

campaignId
Type: System..::..Guid
The campaign id.
title
Type: System..::..String
The title.
type
Type: System..::..String
The type.
description
Type: System..::..String
The description.
cost
Type: System..::..Double
The cost.
startDate
Type: System..::..DateTime
The start date.
endDate
Type: System..::..DateTime
The end date.
data
Type: System..::..String
The data.
isActive
Type: System..::..Boolean
if set to true [is active].

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.InsertCampaign(System.Guid,System.String,System.String,System.String,System.Double,System.DateTime,System.DateTime,System.String,System.Boolean)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


InsertCampaignEvent Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..InsertCampaignEvent Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int InsertCampaignEvent(
    Guid campaignEventId,
    Guid campaignId,
    DateTime dateTime,
    string data,
    int state
)
Visual Basic
Public Shared Function InsertCampaignEvent ( _
    campaignEventId As Guid, _
    campaignId As Guid, _
    dateTime As DateTime, _
    data As String, _
    state As Integer _
) As Integer
Visual C++
public:
static int InsertCampaignEvent(
    Guid campaignEventId,
    Guid campaignId,
    DateTime dateTime,
    String^ data,
    int state
)

Parameters

campaignEventId
Type: System..::..Guid
The campaign event id.
campaignId
Type: System..::..Guid
The campaign id.
dateTime
Type: System..::..DateTime
The date time.
data
Type: System..::..String
The data.
state
Type: System..::..Int32
The state.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.InsertCampaignEvent(System.Guid,System.Guid,System.DateTime,System.String,System.Int32)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


InsertCampaignEventPage Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..InsertCampaignEventPage Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int InsertCampaignEventPage(
    Guid campaignSessionPageId,
    Guid pageId,
    Guid campaignEventId
)
Visual Basic
Public Shared Function InsertCampaignEventPage ( _
    campaignSessionPageId As Guid, _
    pageId As Guid, _
    campaignEventId As Guid _
) As Integer
Visual C++
public:
static int InsertCampaignEventPage(
    Guid campaignSessionPageId,
    Guid pageId,
    Guid campaignEventId
)

Parameters

campaignSessionPageId
Type: System..::..Guid
The campaign session page id.
pageId
Type: System..::..Guid
The page id.
campaignEventId
Type: System..::..Guid
The campaign event id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.InsertCampaignEventPage(System.Guid,System.Guid,System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


InsertGlobalSession Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..InsertGlobalSession Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int InsertGlobalSession(
    Guid globalSessionId,
    string cookieValue,
    int visitorIdentification,
    int overriddenVisitorIdentification,
    string externalUser
)
Visual Basic
Public Shared Function InsertGlobalSession ( _
    globalSessionId As Guid, _
    cookieValue As String, _
    visitorIdentification As Integer, _
    overriddenVisitorIdentification As Integer, _
    externalUser As String _
) As Integer
Visual C++
public:
static int InsertGlobalSession(
    Guid globalSessionId,
    String^ cookieValue,
    int visitorIdentification,
    int overriddenVisitorIdentification,
    String^ externalUser
)

Parameters

globalSessionId
Type: System..::..Guid
The global session id.
cookieValue
Type: System..::..String
The cookie value.
visitorIdentification
Type: System..::..Int32
The visitor identification.
overriddenVisitorIdentification
Type: System..::..Int32
The overridden visitor identification.
externalUser
Type: System..::..String
The external user.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.InsertGlobalSession(System.Guid,System.String,System.Int32,System.Int32,System.String)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


InsertIPOwner Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..InsertIPOwner Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int InsertIPOwner(
    Guid ipOwnerId,
    string name,
    string country,
    int visitorIdentification,
    string externalUser
)
Visual Basic
Public Shared Function InsertIPOwner ( _
    ipOwnerId As Guid, _
    name As String, _
    country As String, _
    visitorIdentification As Integer, _
    externalUser As String _
) As Integer
Visual C++
public:
static int InsertIPOwner(
    Guid ipOwnerId,
    String^ name,
    String^ country,
    int visitorIdentification,
    String^ externalUser
)

Parameters

ipOwnerId
Type: System..::..Guid
The ip owner id.
name
Type: System..::..String
The name.
country
Type: System..::..String
The country.
visitorIdentification
Type: System..::..Int32
The visitor identification.
externalUser
Type: System..::..String
The external user.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.InsertIPOwner(System.Guid,System.String,System.String,System.Int32,System.String)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


InsertMultiVarianceTestDefinition Method (Guid, String, String)

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..InsertMultiVarianceTestDefinition Method (Guid, String, String)
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int InsertMultiVarianceTestDefinition(
    Guid multiVarianceTestDefinitionId,
    string title,
    string description
)
Visual Basic
Public Shared Function InsertMultiVarianceTestDefinition ( _
    multiVarianceTestDefinitionId As Guid, _
    title As String, _
    description As String _
) As Integer
Visual C++
public:
static int InsertMultiVarianceTestDefinition(
    Guid multiVarianceTestDefinitionId,
    String^ title,
    String^ description
)

Parameters

multiVarianceTestDefinitionId
Type: System..::..Guid
The multi variance test definition id.
title
Type: System..::..String
The title.
description
Type: System..::..String
The description.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.InsertMultiVarianceTestDefinition(System.Guid,System.String,System.String)"]

See Also

AnalyticsManager Class
InsertMultiVarianceTestDefinition Overload
Sitecore.Analytics Namespace


InsertMultiVarianceTestDefinition Method (String, String, Guid)

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..InsertMultiVarianceTestDefinition Method (String, String, Guid)
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int InsertMultiVarianceTestDefinition(
    string title,
    string description,
    Guid multiVarianceTestId
)
Visual Basic
Public Shared Function InsertMultiVarianceTestDefinition ( _
    title As String, _
    description As String, _
    multiVarianceTestId As Guid _
) As Integer
Visual C++
public:
static int InsertMultiVarianceTestDefinition(
    String^ title,
    String^ description,
    Guid multiVarianceTestId
)

Parameters

title
Type: System..::..String
The title.
description
Type: System..::..String
The description.
multiVarianceTestId
Type: System..::..Guid
The multi variance test id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.InsertMultiVarianceTestDefinition(System.String,System.String,System.Guid)"]

See Also

AnalyticsManager Class
InsertMultiVarianceTestDefinition Overload
Sitecore.Analytics Namespace


InsertMultiVarianceTestVariable Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..InsertMultiVarianceTestVariable Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int InsertMultiVarianceTestVariable(
    Guid multiVarianceTestVariableId,
    Guid multiVarianceTestDefinitionId,
    string name
)
Visual Basic
Public Shared Function InsertMultiVarianceTestVariable ( _
    multiVarianceTestVariableId As Guid, _
    multiVarianceTestDefinitionId As Guid, _
    name As String _
) As Integer
Visual C++
public:
static int InsertMultiVarianceTestVariable(
    Guid multiVarianceTestVariableId,
    Guid multiVarianceTestDefinitionId,
    String^ name
)

Parameters

multiVarianceTestVariableId
Type: System..::..Guid
The multi variance test variable id.
multiVarianceTestDefinitionId
Type: System..::..Guid
The multi variance test definition id.
name
Type: System..::..String
The name.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.InsertMultiVarianceTestVariable(System.Guid,System.Guid,System.String)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


InsertMultiVarianceTestVariableCampaignEvent Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..InsertMultiVarianceTestVariableCampaignEvent Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int InsertMultiVarianceTestVariableCampaignEvent(
    Guid multiVarianceTestVariableCampaignEventId,
    Guid multiVarianceTestVariableId,
    Guid campaignEventId,
    string data
)
Visual Basic
Public Shared Function InsertMultiVarianceTestVariableCampaignEvent ( _
    multiVarianceTestVariableCampaignEventId As Guid, _
    multiVarianceTestVariableId As Guid, _
    campaignEventId As Guid, _
    data As String _
) As Integer
Visual C++
public:
static int InsertMultiVarianceTestVariableCampaignEvent(
    Guid multiVarianceTestVariableCampaignEventId,
    Guid multiVarianceTestVariableId,
    Guid campaignEventId,
    String^ data
)

Parameters

multiVarianceTestVariableCampaignEventId
Type: System..::..Guid
The multi variance test variable campaign event id.
multiVarianceTestVariableId
Type: System..::..Guid
The multi variance test variable id.
campaignEventId
Type: System..::..Guid
The campaign event id.
data
Type: System..::..String
The data.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.InsertMultiVarianceTestVariableCampaignEvent(System.Guid,System.Guid,System.Guid,System.String)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


InsertMultiVarianceTestVariablePage Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..InsertMultiVarianceTestVariablePage Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int InsertMultiVarianceTestVariablePage(
    Guid multiVarianceTestVariablePageId,
    Guid multiVarianceTestVariableId,
    Guid pageId,
    string data
)
Visual Basic
Public Shared Function InsertMultiVarianceTestVariablePage ( _
    multiVarianceTestVariablePageId As Guid, _
    multiVarianceTestVariableId As Guid, _
    pageId As Guid, _
    data As String _
) As Integer
Visual C++
public:
static int InsertMultiVarianceTestVariablePage(
    Guid multiVarianceTestVariablePageId,
    Guid multiVarianceTestVariableId,
    Guid pageId,
    String^ data
)

Parameters

multiVarianceTestVariablePageId
Type: System..::..Guid
The multi variance test variable page id.
multiVarianceTestVariableId
Type: System..::..Guid
The multi variance test variable id.
pageId
Type: System..::..Guid
The page id.
data
Type: System..::..String
The data.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.InsertMultiVarianceTestVariablePage(System.Guid,System.Guid,System.Guid,System.String)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


InsertOperatingSystem Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..InsertOperatingSystem Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int InsertOperatingSystem(
    Guid operatingSystemId,
    string operatingSystem,
    string description,
    string majorName,
    string minorName,
    string version
)
Visual Basic
Public Shared Function InsertOperatingSystem ( _
    operatingSystemId As Guid, _
    operatingSystem As String, _
    description As String, _
    majorName As String, _
    minorName As String, _
    version As String _
) As Integer
Visual C++
public:
static int InsertOperatingSystem(
    Guid operatingSystemId,
    String^ operatingSystem,
    String^ description,
    String^ majorName,
    String^ minorName,
    String^ version
)

Parameters

operatingSystemId
Type: System..::..Guid
The operating system id.
operatingSystem
Type: System..::..String
The operating system.
description
Type: System..::..String
The description.
majorName
Type: System..::..String
Name of the major.
minorName
Type: System..::..String
Name of the minor.
version
Type: System..::..String
The version.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.InsertOperatingSystem(System.Guid,System.String,System.String,System.String,System.String,System.String)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


InsertPage Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..InsertPage Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int InsertPage(
    Guid pageId,
    Guid sessionId,
    DateTime timestamp,
    int duration,
    int pageNo,
    Guid itemId,
    string itemLanguage,
    int itemVersion,
    Guid deviceId,
    string navigation,
    string url,
    string indexableUrl,
    string data
)
Visual Basic
Public Shared Function InsertPage ( _
    pageId As Guid, _
    sessionId As Guid, _
    timestamp As DateTime, _
    duration As Integer, _
    pageNo As Integer, _
    itemId As Guid, _
    itemLanguage As String, _
    itemVersion As Integer, _
    deviceId As Guid, _
    navigation As String, _
    url As String, _
    indexableUrl As String, _
    data As String _
) As Integer
Visual C++
public:
static int InsertPage(
    Guid pageId,
    Guid sessionId,
    DateTime timestamp,
    int duration,
    int pageNo,
    Guid itemId,
    String^ itemLanguage,
    int itemVersion,
    Guid deviceId,
    String^ navigation,
    String^ url,
    String^ indexableUrl,
    String^ data
)

Parameters

pageId
Type: System..::..Guid
The page id.
sessionId
Type: System..::..Guid
The session id.
timestamp
Type: System..::..DateTime
The timestamp.
duration
Type: System..::..Int32
The duration.
pageNo
Type: System..::..Int32
The page no.
itemId
Type: System..::..Guid
The item id.
itemLanguage
Type: System..::..String
The item language.
itemVersion
Type: System..::..Int32
The item version.
deviceId
Type: System..::..Guid
The device id.
navigation
Type: System..::..String
The navigation.
url
Type: System..::..String
The URL.
indexableUrl
Type: System..::..String
The indexable URL.
data
Type: System..::..String
The data.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.InsertPage(System.Guid,System.Guid,System.DateTime,System.Int32,System.Int32,System.Guid,System.String,System.Int32,System.Guid,System.String,System.String,System.String,System.String)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


InsertPageEvent Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..InsertPageEvent Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int InsertPageEvent(
    Guid pageEventId,
    Guid pageId,
    Guid pageEventDefinitionId,
    Guid itemId,
    string itemLanguage,
    int itemVersion,
    string text,
    string dataKey,
    string data,
    int integer,
    long timestamp,
    int customSorting
)
Visual Basic
Public Shared Function InsertPageEvent ( _
    pageEventId As Guid, _
    pageId As Guid, _
    pageEventDefinitionId As Guid, _
    itemId As Guid, _
    itemLanguage As String, _
    itemVersion As Integer, _
    text As String, _
    dataKey As String, _
    data As String, _
    integer As Integer, _
    timestamp As Long, _
    customSorting As Integer _
) As Integer
Visual C++
public:
static int InsertPageEvent(
    Guid pageEventId,
    Guid pageId,
    Guid pageEventDefinitionId,
    Guid itemId,
    String^ itemLanguage,
    int itemVersion,
    String^ text,
    String^ dataKey,
    String^ data,
    int integer,
    long long timestamp,
    int customSorting
)

Parameters

pageEventId
Type: System..::..Guid
The page event id.
pageId
Type: System..::..Guid
The page id.
pageEventDefinitionId
Type: System..::..Guid
The page event definition id.
itemId
Type: System..::..Guid
The item id.
itemLanguage
Type: System..::..String
The item language.
itemVersion
Type: System..::..Int32
The item version.
text
Type: System..::..String
The text.
dataKey
Type: System..::..String
The data key.
data
Type: System..::..String
The data.
integer
Type: System..::..Int32
The integer.
timestamp
Type: System..::..Int64
The timestamp.
customSorting
Type: System..::..Int32
The custom sorting.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.InsertPageEvent(System.Guid,System.Guid,System.Guid,System.Guid,System.String,System.Int32,System.String,System.String,System.String,System.Int32,System.Int64,System.Int32)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


InsertPageEventDefinition Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..InsertPageEventDefinition Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int InsertPageEventDefinition(
    Guid pageEventDefinitionId,
    string name,
    string icon,
    string description,
    bool isSystem,
    bool isAuthorFeedback,
    bool isGoal,
    bool isFailure
)
Visual Basic
Public Shared Function InsertPageEventDefinition ( _
    pageEventDefinitionId As Guid, _
    name As String, _
    icon As String, _
    description As String, _
    isSystem As Boolean, _
    isAuthorFeedback As Boolean, _
    isGoal As Boolean, _
    isFailure As Boolean _
) As Integer
Visual C++
public:
static int InsertPageEventDefinition(
    Guid pageEventDefinitionId,
    String^ name,
    String^ icon,
    String^ description,
    bool isSystem,
    bool isAuthorFeedback,
    bool isGoal,
    bool isFailure
)

Parameters

pageEventDefinitionId
Type: System..::..Guid
The page event definition id.
name
Type: System..::..String
The name.
icon
Type: System..::..String
The icon.
description
Type: System..::..String
The description.
isSystem
Type: System..::..Boolean
if set to true [is system].
isAuthorFeedback
Type: System..::..Boolean
if set to true [is author feedback].
isGoal
Type: System..::..Boolean
if set to true [is goal].
isFailure
Type: System..::..Boolean
if set to true [is failure].

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.InsertPageEventDefinition(System.Guid,System.String,System.String,System.String,System.Boolean,System.Boolean,System.Boolean,System.Boolean)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


InsertProfile Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..InsertProfile Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int InsertProfile(
    Guid profileId,
    Guid profileDefinitionId,
    Guid sessionId,
    int total,
    int count
)
Visual Basic
Public Shared Function InsertProfile ( _
    profileId As Guid, _
    profileDefinitionId As Guid, _
    sessionId As Guid, _
    total As Integer, _
    count As Integer _
) As Integer
Visual C++
public:
static int InsertProfile(
    Guid profileId,
    Guid profileDefinitionId,
    Guid sessionId,
    int total,
    int count
)

Parameters

profileId
Type: System..::..Guid
The profile id.
profileDefinitionId
Type: System..::..Guid
The profile definition id.
sessionId
Type: System..::..Guid
The session id.
total
Type: System..::..Int32
The total.
count
Type: System..::..Int32
The count.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.InsertProfile(System.Guid,System.Guid,System.Guid,System.Int32,System.Int32)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


InsertProfileDefinition Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..InsertProfileDefinition Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int InsertProfileDefinition(
    Guid profileDefinitionId,
    string name,
    string profileType
)
Visual Basic
Public Shared Function InsertProfileDefinition ( _
    profileDefinitionId As Guid, _
    name As String, _
    profileType As String _
) As Integer
Visual C++
public:
static int InsertProfileDefinition(
    Guid profileDefinitionId,
    String^ name,
    String^ profileType
)

Parameters

profileDefinitionId
Type: System..::..Guid
The profile definition id.
name
Type: System..::..String
The name.
profileType
Type: System..::..String
Type of the profile.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.InsertProfileDefinition(System.Guid,System.String,System.String)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


InsertProfileKey Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..InsertProfileKey Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int InsertProfileKey(
    Guid profileKeyId,
    Guid profileId,
    Guid profileKeyDefinitionId,
    int value
)
Visual Basic
Public Shared Function InsertProfileKey ( _
    profileKeyId As Guid, _
    profileId As Guid, _
    profileKeyDefinitionId As Guid, _
    value As Integer _
) As Integer
Visual C++
public:
static int InsertProfileKey(
    Guid profileKeyId,
    Guid profileId,
    Guid profileKeyDefinitionId,
    int value
)

Parameters

profileKeyId
Type: System..::..Guid
The profile key id.
profileId
Type: System..::..Guid
The profile id.
profileKeyDefinitionId
Type: System..::..Guid
The profile key definition id.
value
Type: System..::..Int32
The value.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.InsertProfileKey(System.Guid,System.Guid,System.Guid,System.Int32)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


InsertProfileKeyDefinition Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..InsertProfileKeyDefinition Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int InsertProfileKeyDefinition(
    Guid profileKeyDefinitionId,
    Guid profileDefinitionId,
    string name,
    string control,
    int minValue,
    int maxValue
)
Visual Basic
Public Shared Function InsertProfileKeyDefinition ( _
    profileKeyDefinitionId As Guid, _
    profileDefinitionId As Guid, _
    name As String, _
    control As String, _
    minValue As Integer, _
    maxValue As Integer _
) As Integer
Visual C++
public:
static int InsertProfileKeyDefinition(
    Guid profileKeyDefinitionId,
    Guid profileDefinitionId,
    String^ name,
    String^ control,
    int minValue,
    int maxValue
)

Parameters

profileKeyDefinitionId
Type: System..::..Guid
The profile key definition id.
profileDefinitionId
Type: System..::..Guid
The profile definition id.
name
Type: System..::..String
The name.
control
Type: System..::..String
The control.
minValue
Type: System..::..Int32
The min value.
maxValue
Type: System..::..Int32
The max value.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.InsertProfileKeyDefinition(System.Guid,System.Guid,System.String,System.String,System.Int32,System.Int32)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


InsertReferringSite Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..InsertReferringSite Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int InsertReferringSite(
    Guid referringSiteId,
    string url
)
Visual Basic
Public Shared Function InsertReferringSite ( _
    referringSiteId As Guid, _
    url As String _
) As Integer
Visual C++
public:
static int InsertReferringSite(
    Guid referringSiteId,
    String^ url
)

Parameters

referringSiteId
Type: System..::..Guid
The referring site id.
url
Type: System..::..String
The URL.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.InsertReferringSite(System.Guid,System.String)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


InsertScreen Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..InsertScreen Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int InsertScreen(
    Guid screenId,
    string dimensions,
    string description
)
Visual Basic
Public Shared Function InsertScreen ( _
    screenId As Guid, _
    dimensions As String, _
    description As String _
) As Integer
Visual C++
public:
static int InsertScreen(
    Guid screenId,
    String^ dimensions,
    String^ description
)

Parameters

screenId
Type: System..::..Guid
The screen id.
dimensions
Type: System..::..String
The dimensions.
description
Type: System..::..String
The description.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.InsertScreen(System.Guid,System.String,System.String)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


InsertSession Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..InsertSession Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int InsertSession(
    Guid sessionId,
    string aspNetSessionId,
    DateTime timestamp,
    Guid ipId,
    string ipAddress,
    Guid globalSessionId,
    int globalVisitNo,
    string domain,
    string multiSite,
    Guid screenId,
    Guid operatingSystemId,
    Guid referringSiteId,
    Guid keywordId,
    Guid browserId,
    Guid languageId,
    int currentPage,
    DateTime lastPageTimestamp
)
Visual Basic
Public Shared Function InsertSession ( _
    sessionId As Guid, _
    aspNetSessionId As String, _
    timestamp As DateTime, _
    ipId As Guid, _
    ipAddress As String, _
    globalSessionId As Guid, _
    globalVisitNo As Integer, _
    domain As String, _
    multiSite As String, _
    screenId As Guid, _
    operatingSystemId As Guid, _
    referringSiteId As Guid, _
    keywordId As Guid, _
    browserId As Guid, _
    languageId As Guid, _
    currentPage As Integer, _
    lastPageTimestamp As DateTime _
) As Integer
Visual C++
public:
static int InsertSession(
    Guid sessionId,
    String^ aspNetSessionId,
    DateTime timestamp,
    Guid ipId,
    String^ ipAddress,
    Guid globalSessionId,
    int globalVisitNo,
    String^ domain,
    String^ multiSite,
    Guid screenId,
    Guid operatingSystemId,
    Guid referringSiteId,
    Guid keywordId,
    Guid browserId,
    Guid languageId,
    int currentPage,
    DateTime lastPageTimestamp
)

Parameters

sessionId
Type: System..::..Guid
The session id.
aspNetSessionId
Type: System..::..String
The ASP net session id.
timestamp
Type: System..::..DateTime
The timestamp.
ipId
Type: System..::..Guid
The ip id.
ipAddress
Type: System..::..String
The ip address.
globalSessionId
Type: System..::..Guid
The global session id.
globalVisitNo
Type: System..::..Int32
The global visit no.
domain
Type: System..::..String
The domain.
multiSite
Type: System..::..String
The multi site.
screenId
Type: System..::..Guid
The screen id.
operatingSystemId
Type: System..::..Guid
The operating system id.
referringSiteId
Type: System..::..Guid
The referring site id.
keywordId
Type: System..::..Guid
The keyword id.
browserId
Type: System..::..Guid
The browser id.
languageId
Type: System..::..Guid
The language id.
currentPage
Type: System..::..Int32
The current page.
lastPageTimestamp
Type: System..::..DateTime
The last page timestamp.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.InsertSession(System.Guid,System.String,System.DateTime,System.Guid,System.String,System.Guid,System.Int32,System.String,System.String,System.Guid,System.Guid,System.Guid,System.Guid,System.Guid,System.Guid,System.Int32,System.DateTime)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


InsertSubscription Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..InsertSubscription Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int InsertSubscription(
    Guid subscriptionId,
    Guid ipOwnerId,
    string recipients
)
Visual Basic
Public Shared Function InsertSubscription ( _
    subscriptionId As Guid, _
    ipOwnerId As Guid, _
    recipients As String _
) As Integer
Visual C++
public:
static int InsertSubscription(
    Guid subscriptionId,
    Guid ipOwnerId,
    String^ recipients
)

Parameters

subscriptionId
Type: System..::..Guid
The subscription id.
ipOwnerId
Type: System..::..Guid
The ip owner id.
recipients
Type: System..::..String
The recipients.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.InsertSubscription(System.Guid,System.Guid,System.String)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


InsertTag Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..InsertTag Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int InsertTag(
    Guid tagId,
    Guid globalSessionId,
    string data,
    Guid acquaintance
)
Visual Basic
Public Shared Function InsertTag ( _
    tagId As Guid, _
    globalSessionId As Guid, _
    data As String, _
    acquaintance As Guid _
) As Integer
Visual C++
public:
static int InsertTag(
    Guid tagId,
    Guid globalSessionId,
    String^ data,
    Guid acquaintance
)

Parameters

tagId
Type: System..::..Guid
The tag id.
globalSessionId
Type: System..::..Guid
The global session id.
data
Type: System..::..String
The data.
acquaintance
Type: System..::..Guid
The acquaintance.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.InsertTag(System.Guid,System.Guid,System.String,System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


RawStringToGuid Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..RawStringToGuid Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static Guid RawStringToGuid(
    string rawString
)
Visual Basic
Public Shared Function RawStringToGuid ( _
    rawString As String _
) As Guid
Visual C++
public:
static Guid RawStringToGuid(
    String^ rawString
)

Parameters

rawString
Type: System..::..String
The raw string.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.RawStringToGuid(System.String)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


ReadMany Method

[image] [image]

Sitecore 6.4.1 API
AnalyticsManager..::..ReadMany Method
AnalyticsManager Class See Also Send Feedback

Overload List

Name | Description
ReadMany<(Of <<'(T>)>>)(String, Func<(Of <<'(DataProviderReader, T>)>>), array<Object>[]()[][]) | Reads the specified command text.
ReadMany<(Of <<'(T>)>>)(String, Func<(Of <<'(DataProviderReader, T>)>>), Int32, array<Object>[]()[][]) | Reads the specified command text.

See Also

AnalyticsManager Class
AnalyticsManager Members
Sitecore.Analytics Namespace


ReadMany(T) Method (String, Func(DataProviderReader, T), Object[])

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..ReadMany<(Of <(<'T>)>)> Method (String, Func<(Of <(<'DataProviderReader, T>)>)>, array<Object>[]()[][])
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static List<T> ReadMany<T>(
    string commandText,
    Func<DataProviderReader, T> initializer,
    params Object[] parameters
)
Visual Basic
Public Shared Function ReadMany(Of T) ( _
    commandText As String, _
    initializer As Func(Of DataProviderReader, T), _
    ParamArray parameters As Object() _
) As List(Of T)
Visual C++
public:
generic<typename T>
static List<T>^ ReadMany(
    String^ commandText,
    Func<DataProviderReader^, T>^ initializer,
    ... array<Object^>^ parameters
)

Parameters

commandText
Type: System..::..String
The command text.
initializer
Type: System..::..Func <(Of <(<' DataProviderReader, T>)>)>
The creator.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.

Type Parameters

T
The type of instance.

Return Value

The list of T.

See Also

AnalyticsManager Class
ReadMany Overload
Sitecore.Analytics Namespace


ReadMany(T) Method (String, Func(DataProviderReader, T), Int32, Object[])

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..ReadMany<(Of <(<'T>)>)> Method (String, Func<(Of <(<'DataProviderReader, T>)>)>, Int32, array<Object>[]()[][])
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static List<T> ReadMany<T>(
    string commandText,
    Func<DataProviderReader, T> initializer,
    int maxEntries,
    params Object[] parameters
)
Visual Basic
Public Shared Function ReadMany(Of T) ( _
    commandText As String, _
    initializer As Func(Of DataProviderReader, T), _
    maxEntries As Integer, _
    ParamArray parameters As Object() _
) As List(Of T)
Visual C++
public:
generic<typename T>
static List<T>^ ReadMany(
    String^ commandText,
    Func<DataProviderReader^, T>^ initializer,
    int maxEntries,
    ... array<Object^>^ parameters
)

Parameters

commandText
Type: System..::..String
The command text.
initializer
Type: System..::..Func <(Of <(<' DataProviderReader, T>)>)>
The initializer.
maxEntries
Type: System..::..Int32
The max entries.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.

Type Parameters

T
The type of instance.

Return Value

The list of T.

See Also

AnalyticsManager Class
ReadMany Overload
Sitecore.Analytics Namespace


ReadOne Method

[image] [image]

Sitecore 6.4.1 API
AnalyticsManager..::..ReadOne Method
AnalyticsManager Class See Also Send Feedback

Overload List

Name | Description
ReadOne<(Of <<'(T>)>>)(String, Func<(Of <<'(DataProviderReader, T>)>>), array<Object>[]()[][]) | Reads the one.
ReadOne<(Of <<'(T>)>>)(String, Func<(Of <<'(DataProviderReader, T>)>>), Func<(Of <<'(T>)>>), array<Object>[]()[][]) | Reads the specified command text.

See Also

AnalyticsManager Class
AnalyticsManager Members
Sitecore.Analytics Namespace


ReadOne(T) Method (String, Func(DataProviderReader, T), Object[])

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..ReadOne<(Of <(<'T>)>)> Method (String, Func<(Of <(<'DataProviderReader, T>)>)>, array<Object>[]()[][])
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static T ReadOne<T>(
    string commandText,
    Func<DataProviderReader, T> selector,
    params Object[] parameters
)
Visual Basic
Public Shared Function ReadOne(Of T) ( _
    commandText As String, _
    selector As Func(Of DataProviderReader, T), _
    ParamArray parameters As Object() _
) As T
Visual C++
public:
generic<typename T>
static T ReadOne(
    String^ commandText,
    Func<DataProviderReader^, T>^ selector,
    ... array<Object^>^ parameters
)

Parameters

commandText
Type: System..::..String
The command text.
selector
Type: System..::..Func <(Of <(<' DataProviderReader, T>)>)>
The selector.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.

Type Parameters

T
The type of field.

Return Value

The value of the field selected by selector.

See Also

AnalyticsManager Class
ReadOne Overload
Sitecore.Analytics Namespace


ReadOne(T) Method (String, Func(DataProviderReader, T), Func(T), Object[])

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..ReadOne<(Of <(<'T>)>)> Method (String, Func<(Of <(<'DataProviderReader, T>)>)>, Func<(Of <(<'T>)>)>, array<Object>[]()[][])
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static T ReadOne<T>(
    string commandText,
    Func<DataProviderReader, T> selector,
    Func<T> defaulter,
    params Object[] parameters
)
Visual Basic
Public Shared Function ReadOne(Of T) ( _
    commandText As String, _
    selector As Func(Of DataProviderReader, T), _
    defaulter As Func(Of T), _
    ParamArray parameters As Object() _
) As T
Visual C++
public:
generic<typename T>
static T ReadOne(
    String^ commandText,
    Func<DataProviderReader^, T>^ selector,
    Func<T>^ defaulter,
    ... array<Object^>^ parameters
)

Parameters

commandText
Type: System..::..String
The command text.
selector
Type: System..::..Func <(Of <(<' DataProviderReader, T>)>)>
The selector.
defaulter
Type: System..::..Func <(Of <(<'T>)>)>
The defaulter.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.

Type Parameters

T
The type of field.

Return Value

The value of the field selected by selector.

See Also

AnalyticsManager Class
ReadOne Overload
Sitecore.Analytics Namespace


SaveCampaignDefinition Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..SaveCampaignDefinition Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void SaveCampaignDefinition(
    Guid campaignId,
    string title,
    string type,
    string description,
    double cost,
    DateTime startDate,
    DateTime endDate,
    bool isActive,
    string data
)
Visual Basic
Public Shared Sub SaveCampaignDefinition ( _
    campaignId As Guid, _
    title As String, _
    type As String, _
    description As String, _
    cost As Double, _
    startDate As DateTime, _
    endDate As DateTime, _
    isActive As Boolean, _
    data As String _
)
Visual C++
public:
static void SaveCampaignDefinition(
    Guid campaignId,
    String^ title,
    String^ type,
    String^ description,
    double cost,
    DateTime startDate,
    DateTime endDate,
    bool isActive,
    String^ data
)

Parameters

campaignId
Type: System..::..Guid
The campaign id.
title
Type: System..::..String
The title.
type
Type: System..::..String
The type.
description
Type: System..::..String
The description.
cost
Type: System..::..Double
The cost.
startDate
Type: System..::..DateTime
The start date.
endDate
Type: System..::..DateTime
The end date.
isActive
Type: System..::..Boolean
if set to true [is active].
data
Type: System..::..String
The data.

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


SaveCampaignEvent Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..SaveCampaignEvent Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void SaveCampaignEvent(
    Guid campaignEventId,
    Guid campaignId,
    DateTime dateTime,
    string data
)
Visual Basic
Public Shared Sub SaveCampaignEvent ( _
    campaignEventId As Guid, _
    campaignId As Guid, _
    dateTime As DateTime, _
    data As String _
)
Visual C++
public:
static void SaveCampaignEvent(
    Guid campaignEventId,
    Guid campaignId,
    DateTime dateTime,
    String^ data
)

Parameters

campaignEventId
Type: System..::..Guid
The campaign event id.
campaignId
Type: System..::..Guid
The campaign id.
dateTime
Type: System..::..DateTime
The date time.
data
Type: System..::..String
The campaign data.

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


SaveMultiVarianceTestDefinition Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..SaveMultiVarianceTestDefinition Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void SaveMultiVarianceTestDefinition(
    Guid multiVarianceTestId,
    string title,
    string description
)
Visual Basic
Public Shared Sub SaveMultiVarianceTestDefinition ( _
    multiVarianceTestId As Guid, _
    title As String, _
    description As String _
)
Visual C++
public:
static void SaveMultiVarianceTestDefinition(
    Guid multiVarianceTestId,
    String^ title,
    String^ description
)

Parameters

multiVarianceTestId
Type: System..::..Guid
The multi variance test id.
title
Type: System..::..String
The title.
description
Type: System..::..String
The description.

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


SaveMultiVarianceTestVariable Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..SaveMultiVarianceTestVariable Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void SaveMultiVarianceTestVariable(
    Guid multiVarianceTestVariableId,
    Guid multiVarianceTestDefinitionId,
    string name
)
Visual Basic
Public Shared Sub SaveMultiVarianceTestVariable ( _
    multiVarianceTestVariableId As Guid, _
    multiVarianceTestDefinitionId As Guid, _
    name As String _
)
Visual C++
public:
static void SaveMultiVarianceTestVariable(
    Guid multiVarianceTestVariableId,
    Guid multiVarianceTestDefinitionId,
    String^ name
)

Parameters

multiVarianceTestVariableId
Type: System..::..Guid
The multi variance test variable id.
multiVarianceTestDefinitionId
Type: System..::..Guid
The multi variance test definition id.
name
Type: System..::..String
The test variable name.

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


SavePageEventDefinition Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..SavePageEventDefinition Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void SavePageEventDefinition(
    Guid pageEventDefinitionId,
    string name,
    string icon,
    string description,
    bool isSystem,
    bool isAuthorFeedback,
    bool isGoal,
    bool isFailure
)
Visual Basic
Public Shared Sub SavePageEventDefinition ( _
    pageEventDefinitionId As Guid, _
    name As String, _
    icon As String, _
    description As String, _
    isSystem As Boolean, _
    isAuthorFeedback As Boolean, _
    isGoal As Boolean, _
    isFailure As Boolean _
)
Visual C++
public:
static void SavePageEventDefinition(
    Guid pageEventDefinitionId,
    String^ name,
    String^ icon,
    String^ description,
    bool isSystem,
    bool isAuthorFeedback,
    bool isGoal,
    bool isFailure
)

Parameters

pageEventDefinitionId
Type: System..::..Guid
The page event definition id.
name
Type: System..::..String
The page event name.
icon
Type: System..::..String
The page event icon.
description
Type: System..::..String
The description.
isSystem
Type: System..::..Boolean
if set to true [is system].
isAuthorFeedback
Type: System..::..Boolean
if set to true [is author feedback].
isGoal
Type: System..::..Boolean
if set to true [is goal].
isFailure
Type: System..::..Boolean
if set to true [is failure].

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


SaveProfileDefinition Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..SaveProfileDefinition Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void SaveProfileDefinition(
    Guid profileDefinitionId,
    string name,
    string profileType
)
Visual Basic
Public Shared Sub SaveProfileDefinition ( _
    profileDefinitionId As Guid, _
    name As String, _
    profileType As String _
)
Visual C++
public:
static void SaveProfileDefinition(
    Guid profileDefinitionId,
    String^ name,
    String^ profileType
)

Parameters

profileDefinitionId
Type: System..::..Guid
The profile definition id.
name
Type: System..::..String
The profile name.
profileType
Type: System..::..String
Type of the profile.

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


SaveProfileKeyDefinition Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..SaveProfileKeyDefinition Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void SaveProfileKeyDefinition(
    Guid profileKeyDefinitionId,
    Guid profileDefinitionId,
    string name,
    string control,
    int minValue,
    int maxValue
)
Visual Basic
Public Shared Sub SaveProfileKeyDefinition ( _
    profileKeyDefinitionId As Guid, _
    profileDefinitionId As Guid, _
    name As String, _
    control As String, _
    minValue As Integer, _
    maxValue As Integer _
)
Visual C++
public:
static void SaveProfileKeyDefinition(
    Guid profileKeyDefinitionId,
    Guid profileDefinitionId,
    String^ name,
    String^ control,
    int minValue,
    int maxValue
)

Parameters

profileKeyDefinitionId
Type: System..::..Guid
The profile key definition id.
profileDefinitionId
Type: System..::..Guid
The profile definition id.
name
Type: System..::..String
The profile key name.
control
Type: System..::..String
The control.
minValue
Type: System..::..Int32
The min value.
maxValue
Type: System..::..Int32
The max value.

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


SetStatusSuccessful Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..SetStatusSuccessful Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void SetStatusSuccessful(
    Guid statusId
)
Visual Basic
Public Shared Sub SetStatusSuccessful ( _
    statusId As Guid _
)
Visual C++
public:
static void SetStatusSuccessful(
    Guid statusId
)

Parameters

statusId
Type: System..::..Guid
The status id.

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


Submit Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..Submit Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void Submit(
    AnalyticsTracker tracker,
    bool defer
)
Visual Basic
Public Shared Sub Submit ( _
    tracker As AnalyticsTracker, _
    defer As Boolean _
)
Visual C++
public:
static void Submit(
    AnalyticsTracker^ tracker,
    bool defer
)

Parameters

tracker
Type: Sitecore.Analytics..::..AnalyticsTracker
The tracker.
defer
Type: System..::..Boolean
if set to true [defer].

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


UpdateBothIdentificationsBySessionId Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..UpdateBothIdentificationsBySessionId Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int UpdateBothIdentificationsBySessionId(
    Guid sessionId
)
Visual Basic
Public Shared Function UpdateBothIdentificationsBySessionId ( _
    sessionId As Guid _
) As Integer
Visual C++
public:
static int UpdateBothIdentificationsBySessionId(
    Guid sessionId
)

Parameters

sessionId
Type: System..::..Guid
The session id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.UpdateBothIdentificationsBySessionId(System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


UpdateBrowser Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..UpdateBrowser Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int UpdateBrowser(
    Browser browser
)
Visual Basic
Public Shared Function UpdateBrowser ( _
    browser As Browser _
) As Integer
Visual C++
public:
static int UpdateBrowser(
    Browser^ browser
)

Parameters

browser
Type: Sitecore.Analytics..::..Browser
The browser.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.UpdateBrowser(Sitecore.Analytics.Browser)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


UpdateCampaign Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..UpdateCampaign Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int UpdateCampaign(
    Guid campaignId,
    string title,
    string type,
    string description,
    double cost,
    DateTime startDate,
    DateTime endDate,
    string data,
    bool isActive
)
Visual Basic
Public Shared Function UpdateCampaign ( _
    campaignId As Guid, _
    title As String, _
    type As String, _
    description As String, _
    cost As Double, _
    startDate As DateTime, _
    endDate As DateTime, _
    data As String, _
    isActive As Boolean _
) As Integer
Visual C++
public:
static int UpdateCampaign(
    Guid campaignId,
    String^ title,
    String^ type,
    String^ description,
    double cost,
    DateTime startDate,
    DateTime endDate,
    String^ data,
    bool isActive
)

Parameters

campaignId
Type: System..::..Guid
The campaign id.
title
Type: System..::..String
The title.
type
Type: System..::..String
The type.
description
Type: System..::..String
The description.
cost
Type: System..::..Double
The cost.
startDate
Type: System..::..DateTime
The start date.
endDate
Type: System..::..DateTime
The end date.
data
Type: System..::..String
The data.
isActive
Type: System..::..Boolean
if set to true [is active].

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.UpdateCampaign(System.Guid,System.String,System.String,System.String,System.Double,System.DateTime,System.DateTime,System.String,System.Boolean)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


UpdateCampaignEvent Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..UpdateCampaignEvent Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int UpdateCampaignEvent(
    Guid campaignEventId,
    Guid campaignId,
    string data,
    DateTime dateTime
)
Visual Basic
Public Shared Function UpdateCampaignEvent ( _
    campaignEventId As Guid, _
    campaignId As Guid, _
    data As String, _
    dateTime As DateTime _
) As Integer
Visual C++
public:
static int UpdateCampaignEvent(
    Guid campaignEventId,
    Guid campaignId,
    String^ data,
    DateTime dateTime
)

Parameters

campaignEventId
Type: System..::..Guid
The campaign event id.
campaignId
Type: System..::..Guid
The campaign id.
data
Type: System..::..String
The data.
dateTime
Type: System..::..DateTime
The date time.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.UpdateCampaignEvent(System.Guid,System.Guid,System.String,System.DateTime)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


UpdateCountTotalByProfileId Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..UpdateCountTotalByProfileId Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int UpdateCountTotalByProfileId(
    Guid profileId,
    int count,
    int total
)
Visual Basic
Public Shared Function UpdateCountTotalByProfileId ( _
    profileId As Guid, _
    count As Integer, _
    total As Integer _
) As Integer
Visual C++
public:
static int UpdateCountTotalByProfileId(
    Guid profileId,
    int count,
    int total
)

Parameters

profileId
Type: System..::..Guid
The profile id.
count
Type: System..::..Int32
The count.
total
Type: System..::..Int32
The total.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.UpdateCountTotalByProfileId(System.Guid,System.Int32,System.Int32)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


UpdateCurrentPageBySessionId Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..UpdateCurrentPageBySessionId Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int UpdateCurrentPageBySessionId(
    Guid sessionId,
    int currentPage
)
Visual Basic
Public Shared Function UpdateCurrentPageBySessionId ( _
    sessionId As Guid, _
    currentPage As Integer _
) As Integer
Visual C++
public:
static int UpdateCurrentPageBySessionId(
    Guid sessionId,
    int currentPage
)

Parameters

sessionId
Type: System..::..Guid
The session id.
currentPage
Type: System..::..Int32
The current page.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.UpdateCurrentPageBySessionId(System.Guid,System.Int32)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


UpdateGlobalSession Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..UpdateGlobalSession Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int UpdateGlobalSession(
    GlobalSession globalSession
)
Visual Basic
Public Shared Function UpdateGlobalSession ( _
    globalSession As GlobalSession _
) As Integer
Visual C++
public:
static int UpdateGlobalSession(
    GlobalSession^ globalSession
)

Parameters

globalSession
Type: Sitecore.Analytics..::..GlobalSession
The global session.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.UpdateGlobalSession(Sitecore.Analytics.GlobalSession)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


UpdateIP Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..UpdateIP Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int UpdateIP(
    IP ip
)
Visual Basic
Public Shared Function UpdateIP ( _
    ip As IP _
) As Integer
Visual C++
public:
static int UpdateIP(
    IP^ ip
)

Parameters

ip
Type: Sitecore.Analytics..::..IP
The ip.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.UpdateIP(Sitecore.Analytics.IP)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


UpdateIpInformation Method

[image] [image]

Sitecore 6.4.1 API
AnalyticsManager..::..UpdateIpInformation Method
AnalyticsManager Class See Also Send Feedback

Overload List

Name | Description
UpdateIpInformation(Guid, WhoIsInformation) | Updates the ip information.
UpdateIpInformation(Guid, WhoIsInformation, Action<(Of <<'(IP>)>>)) | Updates the ip information.

See Also

AnalyticsManager Class
AnalyticsManager Members
Sitecore.Analytics Namespace


UpdateIpInformation Method (Guid, WhoIsInformation)

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..UpdateIpInformation Method (Guid, WhoIsInformation)
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void UpdateIpInformation(
    Guid ipId,
    WhoIsInformation whoIsInformation
)
Visual Basic
Public Shared Sub UpdateIpInformation ( _
    ipId As Guid, _
    whoIsInformation As WhoIsInformation _
)
Visual C++
public:
static void UpdateIpInformation(
    Guid ipId,
    WhoIsInformation^ whoIsInformation
)

Parameters

ipId
Type: System..::..Guid
The ip id.
whoIsInformation
Type: Sitecore.Analytics.Lookups..::..WhoIsInformation
The who is information.

See Also

AnalyticsManager Class
UpdateIpInformation Overload
Sitecore.Analytics Namespace


UpdateIpInformation Method (Guid, WhoIsInformation, Action(IP))

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..UpdateIpInformation Method (Guid, WhoIsInformation, Action<(Of <(<'IP>)>)>)
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void UpdateIpInformation(
    Guid ipId,
    WhoIsInformation whoIsInformation,
    Action<IP> postAction
)
Visual Basic
Public Shared Sub UpdateIpInformation ( _
    ipId As Guid, _
    whoIsInformation As WhoIsInformation, _
    postAction As Action(Of IP) _
)
Visual C++
public:
static void UpdateIpInformation(
    Guid ipId,
    WhoIsInformation^ whoIsInformation,
    Action<IP^>^ postAction
)

Parameters

ipId
Type: System..::..Guid
The ip id.
whoIsInformation
Type: Sitecore.Analytics.Lookups..::..WhoIsInformation
The who is information.
postAction
Type: System..::..Action <(Of <(<' IP >)>)>
The post action.

See Also

AnalyticsManager Class
UpdateIpInformation Overload
Sitecore.Analytics Namespace


UpdateIPOwner Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..UpdateIPOwner Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int UpdateIPOwner(
    IPOwner ipOwner
)
Visual Basic
Public Shared Function UpdateIPOwner ( _
    ipOwner As IPOwner _
) As Integer
Visual C++
public:
static int UpdateIPOwner(
    IPOwner^ ipOwner
)

Parameters

ipOwner
Type: Sitecore.Analytics..::..IPOwner
The ip owner.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.UpdateIPOwner(Sitecore.Analytics.IPOwner)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


UpdatePage Method

[image] [image]

Sitecore 6.4.1 API
AnalyticsManager..::..UpdatePage Method
AnalyticsManager Class See Also Send Feedback

Overload List

Name | Description
UpdatePage(Guid, DateTime, Int32, Int32, Guid, String, Int32, Guid, String, String, String, String) | Updates the page.
UpdatePage(Guid, Guid, DateTime, Int32, Int32, Guid, String, Int32, Guid, String, String, String, String) | Updates the page.

See Also

AnalyticsManager Class
AnalyticsManager Members
Sitecore.Analytics Namespace


UpdatePage Method (Guid, DateTime, Int32, Int32, Guid, String, Int32, Guid, String, String, String, String)

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..UpdatePage Method (Guid, DateTime, Int32, Int32, Guid, String, Int32, Guid, String, String, String, String)
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int UpdatePage(
    Guid pageId,
    DateTime timestamp,
    int duration,
    int pageNo,
    Guid itemId,
    string itemLanguage,
    int itemVersion,
    Guid deviceId,
    string navigation,
    string url,
    string indexableUrl,
    string data
)
Visual Basic
Public Shared Function UpdatePage ( _
    pageId As Guid, _
    timestamp As DateTime, _
    duration As Integer, _
    pageNo As Integer, _
    itemId As Guid, _
    itemLanguage As String, _
    itemVersion As Integer, _
    deviceId As Guid, _
    navigation As String, _
    url As String, _
    indexableUrl As String, _
    data As String _
) As Integer
Visual C++
public:
static int UpdatePage(
    Guid pageId,
    DateTime timestamp,
    int duration,
    int pageNo,
    Guid itemId,
    String^ itemLanguage,
    int itemVersion,
    Guid deviceId,
    String^ navigation,
    String^ url,
    String^ indexableUrl,
    String^ data
)

Parameters

pageId
Type: System..::..Guid
The page id.
timestamp
Type: System..::..DateTime
The timestamp.
duration
Type: System..::..Int32
The duration.
pageNo
Type: System..::..Int32
The page no.
itemId
Type: System..::..Guid
The item id.
itemLanguage
Type: System..::..String
The item language.
itemVersion
Type: System..::..Int32
The item version.
deviceId
Type: System..::..Guid
The device id.
navigation
Type: System..::..String
The navigation.
url
Type: System..::..String
The URL.
indexableUrl
Type: System..::..String
The indexable URL.
data
Type: System..::..String
The data.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.UpdatePage(System.Guid,System.DateTime,System.Int32,System.Int32,System.Guid,System.String,System.Int32,System.Guid,System.String,System.String,System.String,System.String)"]

See Also

AnalyticsManager Class
UpdatePage Overload
Sitecore.Analytics Namespace


UpdatePage Method (Guid, Guid, DateTime, Int32, Int32, Guid, String, Int32, Guid, String, String, String, String)

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..UpdatePage Method (Guid, Guid, DateTime, Int32, Int32, Guid, String, Int32, Guid, String, String, String, String)
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int UpdatePage(
    Guid pageId,
    Guid sessionId,
    DateTime timestamp,
    int duration,
    int pageNo,
    Guid itemId,
    string itemLanguage,
    int itemVersion,
    Guid deviceId,
    string navigation,
    string url,
    string indexableUrl,
    string data
)
Visual Basic
Public Shared Function UpdatePage ( _
    pageId As Guid, _
    sessionId As Guid, _
    timestamp As DateTime, _
    duration As Integer, _
    pageNo As Integer, _
    itemId As Guid, _
    itemLanguage As String, _
    itemVersion As Integer, _
    deviceId As Guid, _
    navigation As String, _
    url As String, _
    indexableUrl As String, _
    data As String _
) As Integer
Visual C++
public:
static int UpdatePage(
    Guid pageId,
    Guid sessionId,
    DateTime timestamp,
    int duration,
    int pageNo,
    Guid itemId,
    String^ itemLanguage,
    int itemVersion,
    Guid deviceId,
    String^ navigation,
    String^ url,
    String^ indexableUrl,
    String^ data
)

Parameters

pageId
Type: System..::..Guid
The page id.
sessionId
Type: System..::..Guid
The session id.
timestamp
Type: System..::..DateTime
The timestamp.
duration
Type: System..::..Int32
The duration.
pageNo
Type: System..::..Int32
The page no.
itemId
Type: System..::..Guid
The item id.
itemLanguage
Type: System..::..String
The item language.
itemVersion
Type: System..::..Int32
The item version.
deviceId
Type: System..::..Guid
The device id.
navigation
Type: System..::..String
The navigation.
url
Type: System..::..String
The URL.
indexableUrl
Type: System..::..String
The indexable URL.
data
Type: System..::..String
The data.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.UpdatePage(System.Guid,System.Guid,System.DateTime,System.Int32,System.Int32,System.Guid,System.String,System.Int32,System.Guid,System.String,System.String,System.String,System.String)"]

See Also

AnalyticsManager Class
UpdatePage Overload
Sitecore.Analytics Namespace


UpdateVisitorIdentificationByIpOwnerId Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..UpdateVisitorIdentificationByIpOwnerId Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int UpdateVisitorIdentificationByIpOwnerId(
    Guid ipOwnerId
)
Visual Basic
Public Shared Function UpdateVisitorIdentificationByIpOwnerId ( _
    ipOwnerId As Guid _
) As Integer
Visual C++
public:
static int UpdateVisitorIdentificationByIpOwnerId(
    Guid ipOwnerId
)

Parameters

ipOwnerId
Type: System..::..Guid
The ip owner id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.UpdateVisitorIdentificationByIpOwnerId(System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


UpdateVisitorIdentificationBySessionId Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..UpdateVisitorIdentificationBySessionId Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int UpdateVisitorIdentificationBySessionId(
    Guid sessionId
)
Visual Basic
Public Shared Function UpdateVisitorIdentificationBySessionId ( _
    sessionId As Guid _
) As Integer
Visual C++
public:
static int UpdateVisitorIdentificationBySessionId(
    Guid sessionId
)

Parameters

sessionId
Type: System..::..Guid
The session id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.UpdateVisitorIdentificationBySessionId(System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


UpdateVisitorIdentifications Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..UpdateVisitorIdentifications Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int UpdateVisitorIdentifications()
Visual Basic
Public Shared Function UpdateVisitorIdentifications As Integer
Visual C++
public:
static int UpdateVisitorIdentifications()

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.UpdateVisitorIdentifications"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


UpdateVisitorIdentificationsByIPOwnerBrowser Method

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..UpdateVisitorIdentificationsByIPOwnerBrowser Method
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int UpdateVisitorIdentificationsByIPOwnerBrowser(
    Guid browserId,
    Guid ipId,
    Guid ipOwnerId
)
Visual Basic
Public Shared Function UpdateVisitorIdentificationsByIPOwnerBrowser ( _
    browserId As Guid, _
    ipId As Guid, _
    ipOwnerId As Guid _
) As Integer
Visual C++
public:
static int UpdateVisitorIdentificationsByIPOwnerBrowser(
    Guid browserId,
    Guid ipId,
    Guid ipOwnerId
)

Parameters

browserId
Type: System..::..Guid
The browser id.
ipId
Type: System..::..Guid
The ip id.
ipOwnerId
Type: System..::..Guid
The ip owner id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.AnalyticsManager.UpdateVisitorIdentificationsByIPOwnerBrowser(System.Guid,System.Guid,System.Guid)"]

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


AnalyticsManager Properties

[image] [image]

Sitecore 6.4.1 API
AnalyticsManager Properties
AnalyticsManager Class See Also Send Feedback

The AnalyticsManager type exposes the following members.

Properties

Name | Description
ConnectionString | Gets the connection string.
Provider | Gets the providers.
Providers | Gets the providers.

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


ConnectionString Property

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..ConnectionString Property
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static string ConnectionString { get; }
Visual Basic
Public Shared ReadOnly Property ConnectionString As String
    Get
Visual C++
public:
static property String^ ConnectionString {
    String^ get ();
}

Field Value

The connection string.

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


Provider Property

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..Provider Property
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static AnalyticsProvider Provider { get; }
Visual Basic
Public Shared ReadOnly Property Provider As AnalyticsProvider
    Get
Visual C++
public:
static property AnalyticsProvider^ Provider {
    AnalyticsProvider^ get ();
}

Field Value

The providers.

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


Providers Property

[image]

Sitecore 6.4.1 API
AnalyticsManager..::..Providers Property
AnalyticsManager Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static AnalyticsProviderCollection Providers { get; }
Visual Basic
Public Shared ReadOnly Property Providers As AnalyticsProviderCollection
    Get
Visual C++
public:
static property AnalyticsProviderCollection^ Providers {
    AnalyticsProviderCollection^ get ();
}

Field Value

The providers.

See Also

AnalyticsManager Class
Sitecore.Analytics Namespace


AnalyticsPage Class

[image]

Sitecore 6.4.1 API
AnalyticsPage Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class AnalyticsPage
Visual Basic
Public Class AnalyticsPage
Visual C++
public ref class AnalyticsPage

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics..::..AnalyticsPage

See Also

AnalyticsPage Members
Sitecore.Analytics Namespace


AnalyticsPage Members

[image] [image]

Sitecore 6.4.1 API
AnalyticsPage Members
AnalyticsPage Class Constructors Methods Properties See Also Send Feedback

The AnalyticsPage type exposes the following members.

Constructors

 | Name | Description
Public method | AnalyticsPage | Initializes a new instance of the AnalyticsPage class.

Methods

 | Name | Description
Public method | CreateCampaignEvent | Creates the campaign event.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TriggerCampaignEvent(Guid) | Triggers the campaign.
Public method | TriggerCampaignEvent(Guid, String, String) | Triggers the campaign.
Public method | TriggerCampaignTestVariable | Triggers the campaign test variable.
Public method | TriggerEvent(String) | Triggers the event.
Public method | TriggerEvent(AnalyticsPageEvent) | Adds the event.
Public method | TriggerEvent(String, String) | Triggers the event.
Public method | TriggerEvent(String, String, String, String) | Adds the event.
Public method | TriggerEvent(String, String, String, String, Int32) | Adds the event.
Public method | TriggerEventExpandable | Triggers the event.
Public method | TriggerTestVariable | Triggers the test variable.

Extension Methods

 | Name | Description
Public Extension Method | BeginTransaction | Follows the search hit. (Defined by Transactions.)
Public Extension Method | CancelTransaction | Cancels the specified handle. (Defined by Transactions.)
Public Extension Method | ChangeFormField(String, String) | Overloaded. Fields the changed. (Defined by Forms.)
Public Extension Method | ChangeFormField(String, String, String) | Overloaded. Changes the form field. (Defined by Forms.)
Public Extension Method | EndTransaction | Ends the transaction. (Defined by Transactions.)
Public Extension Method | FollowSearchHit | Follows the search hit. (Defined by Searches.)
Public Extension Method | LoginUser | Fields the changed. (Defined by Membership.)
Public Extension Method | LoginUserFailed | Logins the failed. (Defined by Membership.)
Public Extension Method | LogoutUser | Logouts the specified page. (Defined by Membership.)
Public Extension Method | LongRunningRequest | Puts the in basket. (Defined by Pages.)
Public Extension Method | PageError | Pages the not found. (Defined by Pages.)
Public Extension Method | PageNotFound | Pages the not found. (Defined by Pages.)
Public Extension Method | Print | Tracks a print of this page. (Defined by Prints.)
Public Extension Method | PutInBasket | Puts the in basket. (Defined by Baskets.)
Public Extension Method | Rate | Puts the in basket. (Defined by Ratings.)
Public Extension Method | RegisterUser | Logouts the specified page. (Defined by Membership.)
Public Extension Method | RegisterUserFailed | Registers the user failed. (Defined by Membership.)
Public Extension Method | RemoveFromNewsletter | Removes from newsletter. (Defined by Newsletters.)
Public Extension Method | RequestBrochures | Puts the in basket. (Defined by Brochures.)
Public Extension Method | Search | Puts the in basket. (Defined by Searches.)
Public Extension Method | SelectPollOption | Puts the in basket. (Defined by Polls.)
Public Extension Method | SignUpToNewsletter | Puts the in basket. (Defined by Newsletters.)
Public Extension Method | Submit()()()() | Overloaded. Submits this instance. (Defined by Forms.)
Public Extension Method | Submit(String) | Overloaded. Submits the specified page. (Defined by Forms.)
Public Extension Method | UpdateUser | Updates the user. (Defined by Membership.)
Public Extension Method | VisitPage()()()() | Overloaded. Visits the page. (Defined by Pages.)
Public Extension Method | VisitPage(String) | Overloaded. Removes from newsletter. (Defined by Pages.)

Properties

 | Name | Description
Public property | CampaignEventIds | Gets the campaign event IDs.
Public property | Data | Gets or sets the data.
Public property | DeviceId | Gets or sets the device ID.
Public property | HasCampaignEventPages | Gets a value indicating whether this instance has campaign events.
Public property | HasPageEvents | Gets a value indicating whether this instance has page events.
Public property | Item | Gets or sets the item version.
Public property | Navigation | Gets or sets the navigation.
Public property | PageEvents | Gets the events.
Public property | TestVariableCampaignEventIds | Gets the test variable campaign event IDs.
Public property | TestVariablePageIds | Gets the test variable page IDs.
Public property | Timestamp | Gets or sets the time stamp.
Public property | Url | Gets or sets the URL.

See Also

AnalyticsPage Class
Sitecore.Analytics Namespace


AnalyticsPage Constructor

[image]

Sitecore 6.4.1 API
AnalyticsPage Constructor
AnalyticsPage Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public AnalyticsPage()
Visual Basic
Public Sub New
Visual C++
public:
AnalyticsPage()

See Also

AnalyticsPage Class
Sitecore.Analytics Namespace


AnalyticsPage Methods

[image] [image]

Sitecore 6.4.1 API
AnalyticsPage Methods
AnalyticsPage Class See Also Send Feedback

The AnalyticsPage type exposes the following members.

Methods

 | Name | Description
Public method | CreateCampaignEvent | Creates the campaign event.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TriggerCampaignEvent(Guid) | Triggers the campaign.
Public method | TriggerCampaignEvent(Guid, String, String) | Triggers the campaign.
Public method | TriggerCampaignTestVariable | Triggers the campaign test variable.
Public method | TriggerEvent(String) | Triggers the event.
Public method | TriggerEvent(AnalyticsPageEvent) | Adds the event.
Public method | TriggerEvent(String, String) | Triggers the event.
Public method | TriggerEvent(String, String, String, String) | Adds the event.
Public method | TriggerEvent(String, String, String, String, Int32) | Adds the event.
Public method | TriggerEventExpandable | Triggers the event.
Public method | TriggerTestVariable | Triggers the test variable.

Extension Methods

 | Name | Description
Public Extension Method | BeginTransaction | Follows the search hit. (Defined by Transactions.)
Public Extension Method | CancelTransaction | Cancels the specified handle. (Defined by Transactions.)
Public Extension Method | ChangeFormField(String, String) | Overloaded. Fields the changed. (Defined by Forms.)
Public Extension Method | ChangeFormField(String, String, String) | Overloaded. Changes the form field. (Defined by Forms.)
Public Extension Method | EndTransaction | Ends the transaction. (Defined by Transactions.)
Public Extension Method | FollowSearchHit | Follows the search hit. (Defined by Searches.)
Public Extension Method | LoginUser | Fields the changed. (Defined by Membership.)
Public Extension Method | LoginUserFailed | Logins the failed. (Defined by Membership.)
Public Extension Method | LogoutUser | Logouts the specified page. (Defined by Membership.)
Public Extension Method | LongRunningRequest | Puts the in basket. (Defined by Pages.)
Public Extension Method | PageError | Pages the not found. (Defined by Pages.)
Public Extension Method | PageNotFound | Pages the not found. (Defined by Pages.)
Public Extension Method | Print | Tracks a print of this page. (Defined by Prints.)
Public Extension Method | PutInBasket | Puts the in basket. (Defined by Baskets.)
Public Extension Method | Rate | Puts the in basket. (Defined by Ratings.)
Public Extension Method | RegisterUser | Logouts the specified page. (Defined by Membership.)
Public Extension Method | RegisterUserFailed | Registers the user failed. (Defined by Membership.)
Public Extension Method | RemoveFromNewsletter | Removes from newsletter. (Defined by Newsletters.)
Public Extension Method | RequestBrochures | Puts the in basket. (Defined by Brochures.)
Public Extension Method | Search | Puts the in basket. (Defined by Searches.)
Public Extension Method | SelectPollOption | Puts the in basket. (Defined by Polls.)
Public Extension Method | SignUpToNewsletter | Puts the in basket. (Defined by Newsletters.)
Public Extension Method | Submit()()()() | Overloaded. Submits this instance. (Defined by Forms.)
Public Extension Method | Submit(String) | Overloaded. Submits the specified page. (Defined by Forms.)
Public Extension Method | UpdateUser | Updates the user. (Defined by Membership.)
Public Extension Method | VisitPage()()()() | Overloaded. Visits the page. (Defined by Pages.)
Public Extension Method | VisitPage(String) | Overloaded. Removes from newsletter. (Defined by Pages.)

See Also

AnalyticsPage Class
Sitecore.Analytics Namespace


CreateCampaignEvent Method

[image]

Sitecore 6.4.1 API
AnalyticsPage..::..CreateCampaignEvent Method
AnalyticsPage Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid CreateCampaignEvent(
    Guid campaignId,
    string data,
    int state
)
Visual Basic
Public Function CreateCampaignEvent ( _
    campaignId As Guid, _
    data As String, _
    state As Integer _
) As Guid
Visual C++
public:
Guid CreateCampaignEvent(
    Guid campaignId,
    String^ data,
    int state
)

Parameters

campaignId
Type: System..::..Guid
The campaign ID.
data
Type: System..::..String
The data.
state
Type: System..::..Int32
The state.

Return Value

The campaign event.

See Also

AnalyticsPage Class
Sitecore.Analytics Namespace


TriggerCampaignEvent Method

[image] [image]

Sitecore 6.4.1 API
AnalyticsPage..::..TriggerCampaignEvent Method
AnalyticsPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TriggerCampaignEvent(Guid) | Triggers the campaign.
Public method | TriggerCampaignEvent(Guid, String, String) | Triggers the campaign.

See Also

AnalyticsPage Class
AnalyticsPage Members
Sitecore.Analytics Namespace


TriggerCampaignEvent Method (Guid)

[image]

Sitecore 6.4.1 API
AnalyticsPage..::..TriggerCampaignEvent Method (Guid)
AnalyticsPage Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void TriggerCampaignEvent(
    Guid campaignEventId
)
Visual Basic
Public Sub TriggerCampaignEvent ( _
    campaignEventId As Guid _
)
Visual C++
public:
void TriggerCampaignEvent(
    Guid campaignEventId
)

Parameters

campaignEventId
Type: System..::..Guid
The campaign event.

See Also

AnalyticsPage Class
TriggerCampaignEvent Overload
Sitecore.Analytics Namespace


TriggerCampaignEvent Method (Guid, String, String)

[image]

Sitecore 6.4.1 API
AnalyticsPage..::..TriggerCampaignEvent Method (Guid, String, String)
AnalyticsPage Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void TriggerCampaignEvent(
    Guid campaignEventId,
    string key,
    string data
)
Visual Basic
Public Sub TriggerCampaignEvent ( _
    campaignEventId As Guid, _
    key As String, _
    data As String _
)
Visual C++
public:
void TriggerCampaignEvent(
    Guid campaignEventId,
    String^ key,
    String^ data
)

Parameters

campaignEventId
Type: System..::..Guid
The campaign event.
key
Type: System..::..String
The key.
data
Type: System..::..String
The data.

See Also

AnalyticsPage Class
TriggerCampaignEvent Overload
Sitecore.Analytics Namespace


TriggerCampaignTestVariable Method

[image]

Sitecore 6.4.1 API
AnalyticsPage..::..TriggerCampaignTestVariable Method
AnalyticsPage Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void TriggerCampaignTestVariable(
    Guid campaignEventId,
    Guid testVariable
)
Visual Basic
Public Sub TriggerCampaignTestVariable ( _
    campaignEventId As Guid, _
    testVariable As Guid _
)
Visual C++
public:
void TriggerCampaignTestVariable(
    Guid campaignEventId,
    Guid testVariable
)

Parameters

campaignEventId
Type: System..::..Guid
The campaign event ID.
testVariable
Type: System..::..Guid
The test variable.

See Also

AnalyticsPage Class
Sitecore.Analytics Namespace


TriggerEvent Method

[image] [image]

Sitecore 6.4.1 API
AnalyticsPage..::..TriggerEvent Method
AnalyticsPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TriggerEvent(String) | Triggers the event.
Public method | TriggerEvent(AnalyticsPageEvent) | Adds the event.
Public method | TriggerEvent(String, String) | Triggers the event.
Public method | TriggerEvent(String, String, String, String) | Adds the event.
Public method | TriggerEvent(String, String, String, String, Int32) | Adds the event.

See Also

AnalyticsPage Class
AnalyticsPage Members
Sitecore.Analytics Namespace


TriggerEvent Method (String)

[image]

Sitecore 6.4.1 API
AnalyticsPage..::..TriggerEvent Method (String)
AnalyticsPage Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public AnalyticsPageEvent TriggerEvent(
    string pageEventName
)
Visual Basic
Public Function TriggerEvent ( _
    pageEventName As String _
) As AnalyticsPageEvent
Visual C++
public:
AnalyticsPageEvent^ TriggerEvent(
    String^ pageEventName
)

Parameters

pageEventName
Type: System..::..String
Name of the page event.

Return Value

Returns the event.

See Also

AnalyticsPage Class
TriggerEvent Overload
Sitecore.Analytics Namespace


TriggerEvent Method (AnalyticsPageEvent)

[image]

Sitecore 6.4.1 API
AnalyticsPage..::..TriggerEvent Method (AnalyticsPageEvent)
AnalyticsPage Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public AnalyticsPageEvent TriggerEvent(
    AnalyticsPageEvent pageEvent
)
Visual Basic
Public Function TriggerEvent ( _
    pageEvent As AnalyticsPageEvent _
) As AnalyticsPageEvent
Visual C++
public:
AnalyticsPageEvent^ TriggerEvent(
    AnalyticsPageEvent^ pageEvent
)

Parameters

pageEvent
Type: Sitecore.Analytics..::..AnalyticsPageEvent
The page event.

Return Value

The event.

See Also

AnalyticsPage Class
TriggerEvent Overload
Sitecore.Analytics Namespace


TriggerEvent Method (String, String)

[image]

Sitecore 6.4.1 API
AnalyticsPage..::..TriggerEvent Method (String, String)
AnalyticsPage Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public AnalyticsPageEvent TriggerEvent(
    string pageEventName,
    string text
)
Visual Basic
Public Function TriggerEvent ( _
    pageEventName As String, _
    text As String _
) As AnalyticsPageEvent
Visual C++
public:
AnalyticsPageEvent^ TriggerEvent(
    String^ pageEventName,
    String^ text
)

Parameters

pageEventName
Type: System..::..String
Name of the page event.
text
Type: System..::..String
The event text.

Return Value

Returns the event.

See Also

AnalyticsPage Class
TriggerEvent Overload
Sitecore.Analytics Namespace


TriggerEvent Method (String, String, String, String)

[image]

Sitecore 6.4.1 API
AnalyticsPage..::..TriggerEvent Method (String, String, String, String)
AnalyticsPage Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public AnalyticsPageEvent TriggerEvent(
    string eventName,
    string text,
    string key,
    string data
)
Visual Basic
Public Function TriggerEvent ( _
    eventName As String, _
    text As String, _
    key As String, _
    data As String _
) As AnalyticsPageEvent
Visual C++
public:
AnalyticsPageEvent^ TriggerEvent(
    String^ eventName,
    String^ text,
    String^ key,
    String^ data
)

Parameters

eventName
Type: System..::..String
The name.
text
Type: System..::..String
The text.
key
Type: System..::..String
The key.
data
Type: System..::..String
The data.

Return Value

The event.

See Also

AnalyticsPage Class
TriggerEvent Overload
Sitecore.Analytics Namespace


TriggerEvent Method (String, String, String, String, Int32)

[image]

Sitecore 6.4.1 API
AnalyticsPage..::..TriggerEvent Method (String, String, String, String, Int32)
AnalyticsPage Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public AnalyticsPageEvent TriggerEvent(
    string eventName,
    string text,
    string key,
    string data,
    int integer
)
Visual Basic
Public Function TriggerEvent ( _
    eventName As String, _
    text As String, _
    key As String, _
    data As String, _
    integer As Integer _
) As AnalyticsPageEvent
Visual C++
public:
AnalyticsPageEvent^ TriggerEvent(
    String^ eventName,
    String^ text,
    String^ key,
    String^ data,
    int integer
)

Parameters

eventName
Type: System..::..String
The event name.
text
Type: System..::..String
The event text.
key
Type: System..::..String
The event key.
data
Type: System..::..String
The event data.
integer
Type: System..::..Int32
The integer.

Return Value

The event.

See Also

AnalyticsPage Class
TriggerEvent Overload
Sitecore.Analytics Namespace


TriggerEventExpandable Method

[image]

Sitecore 6.4.1 API
AnalyticsPage..::..TriggerEventExpandable Method
AnalyticsPage Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public AnalyticsPageEvent TriggerEventExpandable(
    string eventName,
    string value
)
Visual Basic
Public Function TriggerEventExpandable ( _
    eventName As String, _
    value As String _
) As AnalyticsPageEvent
Visual C++
public:
AnalyticsPageEvent^ TriggerEventExpandable(
    String^ eventName,
    String^ value
)

Parameters

eventName
Type: System..::..String
The name.
value
Type: System..::..String
The value.

Return Value

The event.

See Also

AnalyticsPage Class
Sitecore.Analytics Namespace


TriggerTestVariable Method

[image]

Sitecore 6.4.1 API
AnalyticsPage..::..TriggerTestVariable Method
AnalyticsPage Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void TriggerTestVariable(
    Guid testVariable
)
Visual Basic
Public Sub TriggerTestVariable ( _
    testVariable As Guid _
)
Visual C++
public:
void TriggerTestVariable(
    Guid testVariable
)

Parameters

testVariable
Type: System..::..Guid
The test variable.

See Also

AnalyticsPage Class
Sitecore.Analytics Namespace


AnalyticsPage Properties

[image] [image]

Sitecore 6.4.1 API
AnalyticsPage Properties
AnalyticsPage Class See Also Send Feedback

The AnalyticsPage type exposes the following members.

Properties

 | Name | Description
Public property | CampaignEventIds | Gets the campaign event IDs.
Public property | Data | Gets or sets the data.
Public property | DeviceId | Gets or sets the device ID.
Public property | HasCampaignEventPages | Gets a value indicating whether this instance has campaign events.
Public property | HasPageEvents | Gets a value indicating whether this instance has page events.
Public property | Item | Gets or sets the item version.
Public property | Navigation | Gets or sets the navigation.
Public property | PageEvents | Gets the events.
Public property | TestVariableCampaignEventIds | Gets the test variable campaign event IDs.
Public property | TestVariablePageIds | Gets the test variable page IDs.
Public property | Timestamp | Gets or sets the time stamp.
Public property | Url | Gets or sets the URL.

See Also

AnalyticsPage Class
Sitecore.Analytics Namespace


CampaignEventIds Property

[image]

Sitecore 6.4.1 API
AnalyticsPage..::..CampaignEventIds Property
AnalyticsPage Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public List<Guid> CampaignEventIds { get; }
Visual Basic
Public ReadOnly Property CampaignEventIds As List(Of Guid)
    Get
Visual C++
public:
property List<Guid>^ CampaignEventIds {
    List<Guid>^ get ();
}

Field Value

The campaign event IDs.

See Also

AnalyticsPage Class
Sitecore.Analytics Namespace


Data Property

[image]

Sitecore 6.4.1 API
AnalyticsPage..::..Data Property
AnalyticsPage Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Data { get; set; }
Visual Basic
Public Property Data As String
    Get
    Set
Visual C++
public:
property String^ Data {
    String^ get ();
    void set (String^ value);
}

Field Value

The session data.

See Also

AnalyticsPage Class
Sitecore.Analytics Namespace


HasCampaignEventPages Property

[image]

Sitecore 6.4.1 API
AnalyticsPage..::..HasCampaignEventPages Property
AnalyticsPage Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public bool HasCampaignEventPages { get; }
Visual Basic
Public ReadOnly Property HasCampaignEventPages As Boolean
    Get
Visual C++
public:
property bool HasCampaignEventPages {
    bool get ();
}

Field Value

true if this instance has campaign events; otherwise, false.

See Also

AnalyticsPage Class
Sitecore.Analytics Namespace


HasPageEvents Property

[image]

Sitecore 6.4.1 API
AnalyticsPage..::..HasPageEvents Property
AnalyticsPage Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public bool HasPageEvents { get; }
Visual Basic
Public ReadOnly Property HasPageEvents As Boolean
    Get
Visual C++
public:
property bool HasPageEvents {
    bool get ();
}

Field Value

true if this instance has page events; otherwise, false.

See Also

AnalyticsPage Class
Sitecore.Analytics Namespace


Item Property

[image]

Sitecore 6.4.1 API
AnalyticsPage..::..Item Property
AnalyticsPage Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Item Item { get; set; }
Visual Basic
Public Property Item As Item
    Get
    Set
Visual C++
public:
property Item^ Item {
    Item^ get ();
    void set (Item^ value);
}

Field Value

The item version.

See Also

AnalyticsPage Class
Sitecore.Analytics Namespace


Navigation Property

[image]

Sitecore 6.4.1 API
AnalyticsPage..::..Navigation Property
AnalyticsPage Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Navigation { get; set; }
Visual Basic
Public Property Navigation As String
    Get
    Set
Visual C++
public:
property String^ Navigation {
    String^ get ();
    void set (String^ value);
}

Field Value

The navigation.

See Also

AnalyticsPage Class
Sitecore.Analytics Namespace


PageEvents Property

[image]

Sitecore 6.4.1 API
AnalyticsPage..::..PageEvents Property
AnalyticsPage Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public IEnumerable<AnalyticsPageEvent> PageEvents { get; }
Visual Basic
Public ReadOnly Property PageEvents As IEnumerable(Of AnalyticsPageEvent)
    Get
Visual C++
public:
property IEnumerable<AnalyticsPageEvent^>^ PageEvents {
    IEnumerable<AnalyticsPageEvent^>^ get ();
}

Field Value

The events.

See Also

AnalyticsPage Class
Sitecore.Analytics Namespace


TestVariableCampaignEventIds Property

[image]

Sitecore 6.4.1 API
AnalyticsPage..::..TestVariableCampaignEventIds Property
AnalyticsPage Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public IEnumerable<KeyValuePair<Guid, Guid>> TestVariableCampaignEventIds { get; }
Visual Basic
Public ReadOnly Property TestVariableCampaignEventIds As IEnumerable(Of KeyValuePair(Of Guid, Guid))
    Get
Visual C++
public:
property IEnumerable<KeyValuePair<Guid, Guid>>^ TestVariableCampaignEventIds {
    IEnumerable<KeyValuePair<Guid, Guid>>^ get ();
}

Field Value

The test variable campaign event IDs.

See Also

AnalyticsPage Class
Sitecore.Analytics Namespace


TestVariablePageIds Property

[image]

Sitecore 6.4.1 API
AnalyticsPage..::..TestVariablePageIds Property
AnalyticsPage Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public IEnumerable<Guid> TestVariablePageIds { get; }
Visual Basic
Public ReadOnly Property TestVariablePageIds As IEnumerable(Of Guid)
    Get
Visual C++
public:
property IEnumerable<Guid>^ TestVariablePageIds {
    IEnumerable<Guid>^ get ();
}

Field Value

The test variable page IDs.

See Also

AnalyticsPage Class
Sitecore.Analytics Namespace


Timestamp Property

[image]

Sitecore 6.4.1 API
AnalyticsPage..::..Timestamp Property
AnalyticsPage Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public DateTime Timestamp { get; set; }
Visual Basic
Public Property Timestamp As DateTime
    Get
    Set
Visual C++
public:
property DateTime Timestamp {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The time stamp.

See Also

AnalyticsPage Class
Sitecore.Analytics Namespace


Url Property

[image]

Sitecore 6.4.1 API
AnalyticsPage..::..Url Property
AnalyticsPage Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Url { get; set; }
Visual Basic
Public Property Url As String
    Get
    Set
Visual C++
public:
property String^ Url {
    String^ get ();
    void set (String^ value);
}

Field Value

The session URL.

See Also

AnalyticsPage Class
Sitecore.Analytics Namespace


AnalyticsPageEvent Class

[image]

Sitecore 6.4.1 API
AnalyticsPageEvent Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class AnalyticsPageEvent
Visual Basic
Public Class AnalyticsPageEvent
Visual C++
public ref class AnalyticsPageEvent

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics..::..AnalyticsPageEvent

See Also

AnalyticsPageEvent Members
Sitecore.Analytics Namespace


AnalyticsPageEvent Members

[image] [image]

Sitecore 6.4.1 API
AnalyticsPageEvent Members
AnalyticsPageEvent Class Constructors Methods Properties See Also Send Feedback

The AnalyticsPageEvent type exposes the following members.

Constructors

 | Name | Description
Public method | AnalyticsPageEvent | Initializes a new instance of the AnalyticsPageEvent class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CustomSorting | Gets or sets the custom sorting.
Public property | Data | Gets or sets the data.
Public property | Integer | Gets or sets the integer.
Public property | Item | Gets or sets the item ID.
Public property | Key | Gets or sets the key.
Public property | Name | Gets or sets the name of the page event.
Public property | Text | Gets or sets the text.
Public property | Timestamp | Gets or sets the timestamp.

See Also

AnalyticsPageEvent Class
Sitecore.Analytics Namespace


AnalyticsPageEvent Constructor

[image]

Sitecore 6.4.1 API
AnalyticsPageEvent Constructor
AnalyticsPageEvent Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public AnalyticsPageEvent()
Visual Basic
Public Sub New
Visual C++
public:
AnalyticsPageEvent()

See Also

AnalyticsPageEvent Class
Sitecore.Analytics Namespace


AnalyticsPageEvent Methods

[image] [image]

Sitecore 6.4.1 API
AnalyticsPageEvent Methods
AnalyticsPageEvent Class See Also Send Feedback

The AnalyticsPageEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticsPageEvent Class
Sitecore.Analytics Namespace


AnalyticsPageEvent Properties

[image] [image]

Sitecore 6.4.1 API
AnalyticsPageEvent Properties
AnalyticsPageEvent Class See Also Send Feedback

The AnalyticsPageEvent type exposes the following members.

Properties

 | Name | Description
Public property | CustomSorting | Gets or sets the custom sorting.
Public property | Data | Gets or sets the data.
Public property | Integer | Gets or sets the integer.
Public property | Item | Gets or sets the item ID.
Public property | Key | Gets or sets the key.
Public property | Name | Gets or sets the name of the page event.
Public property | Text | Gets or sets the text.
Public property | Timestamp | Gets or sets the timestamp.

See Also

AnalyticsPageEvent Class
Sitecore.Analytics Namespace


CustomSorting Property

[image]

Sitecore 6.4.1 API
AnalyticsPageEvent..::..CustomSorting Property
AnalyticsPageEvent Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int CustomSorting { get; set; }
Visual Basic
Public Property CustomSorting As Integer
    Get
    Set
Visual C++
public:
property int CustomSorting {
    int get ();
    void set (int value);
}

Field Value

The custom sorting.

See Also

AnalyticsPageEvent Class
Sitecore.Analytics Namespace


Data Property

[image]

Sitecore 6.4.1 API
AnalyticsPageEvent..::..Data Property
AnalyticsPageEvent Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Data { get; set; }
Visual Basic
Public Property Data As String
    Get
    Set
Visual C++
public:
property String^ Data {
    String^ get ();
    void set (String^ value);
}

Field Value

The generic page event data.

See Also

AnalyticsPageEvent Class
Sitecore.Analytics Namespace


Integer Property

[image]

Sitecore 6.4.1 API
AnalyticsPageEvent..::..Integer Property
AnalyticsPageEvent Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int Integer { get; set; }
Visual Basic
Public Property Integer As Integer
    Get
    Set
Visual C++
public:
property int Integer {
    int get ();
    void set (int value);
}

Field Value

The integer.

See Also

AnalyticsPageEvent Class
Sitecore.Analytics Namespace


Item Property

[image]

Sitecore 6.4.1 API
AnalyticsPageEvent..::..Item Property
AnalyticsPageEvent Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Item Item { get; set; }
Visual Basic
Public Property Item As Item
    Get
    Set
Visual C++
public:
property Item^ Item {
    Item^ get ();
    void set (Item^ value);
}

Field Value

The item ID.

See Also

AnalyticsPageEvent Class
Sitecore.Analytics Namespace


Key Property

[image]

Sitecore 6.4.1 API
AnalyticsPageEvent..::..Key Property
AnalyticsPageEvent Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Key { get; set; }
Visual Basic
Public Property Key As String
    Get
    Set
Visual C++
public:
property String^ Key {
    String^ get ();
    void set (String^ value);
}

Field Value

The key.

See Also

AnalyticsPageEvent Class
Sitecore.Analytics Namespace


Name Property

[image]

Sitecore 6.4.1 API
AnalyticsPageEvent..::..Name Property
AnalyticsPageEvent Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the page event.

See Also

AnalyticsPageEvent Class
Sitecore.Analytics Namespace


Text Property

[image]

Sitecore 6.4.1 API
AnalyticsPageEvent..::..Text Property
AnalyticsPageEvent Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Field Value

The text.

See Also

AnalyticsPageEvent Class
Sitecore.Analytics Namespace


Timestamp Property

[image]

Sitecore 6.4.1 API
AnalyticsPageEvent..::..Timestamp Property
AnalyticsPageEvent Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public long Timestamp { get; protected set; }
Visual Basic
Public Property Timestamp As Long
    Get
    Protected Set
Visual C++
public:
property long long Timestamp {
    long long get ();
    protected: void set (long long value);
}

Field Value

The timestamp.

See Also

AnalyticsPageEvent Class
Sitecore.Analytics Namespace


AnalyticsSession Class

[image]

Sitecore 6.4.1 API
AnalyticsSession Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class AnalyticsSession
Visual Basic
Public Class AnalyticsSession
Visual C++
public ref class AnalyticsSession

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics..::..AnalyticsSession

See Also

AnalyticsSession Members
Sitecore.Analytics Namespace


AnalyticsSession Members

[image] [image]

Sitecore 6.4.1 API
AnalyticsSession Members
AnalyticsSession Class Constructors Methods Properties See Also Send Feedback

The AnalyticsSession type exposes the following members.

Constructors

 | Name | Description
Public method | AnalyticsSession | Initializes a new instance of the AnalyticsSession class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSessionId | Gets the session id.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AspNetSessionId | Gets or sets the ASP net session id.
Public property | Browser | Gets or sets the user agent.
Public property | Domain | Gets or sets the domain.
Public property | Duration | Gets or sets the duration.
Public property | Ip | Gets or sets the IP address.
Public property | IsNewSession | Gets or sets a value indicating whether this instance is new session.
Public property | Keywords | Gets or sets the keywords.
Public property | Language | Gets or sets the language.
Public property | MultiSite | Gets or sets the multi site.
Public property | OperatingSystem | Gets or sets the operating system.
Public property | Profiles | Gets the profiles.
Public property | ReferringSite | Gets or sets the referring site.
Public property | Screen | Gets or sets the screen.
Public property | SessionId | Gets or sets the session id.
Public property | Timestamp | Gets or sets the time stamp.

See Also

AnalyticsSession Class
Sitecore.Analytics Namespace


AnalyticsSession Constructor

[image]

Sitecore 6.4.1 API
AnalyticsSession Constructor
AnalyticsSession Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public AnalyticsSession()
Visual Basic
Public Sub New
Visual C++
public:
AnalyticsSession()

See Also

AnalyticsSession Class
Sitecore.Analytics Namespace


AnalyticsSession Methods

[image] [image]

Sitecore 6.4.1 API
AnalyticsSession Methods
AnalyticsSession Class See Also Send Feedback

The AnalyticsSession type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSessionId | Gets the session id.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticsSession Class
Sitecore.Analytics Namespace


GetSessionId Method

[image]

Sitecore 6.4.1 API
AnalyticsSession..::..GetSessionId Method
AnalyticsSession Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid GetSessionId()
Visual Basic
Public Function GetSessionId As Guid
Visual C++
public:
Guid GetSessionId()

Return Value

Returns the session id.

See Also

AnalyticsSession Class
Sitecore.Analytics Namespace


AnalyticsSession Properties

[image] [image]

Sitecore 6.4.1 API
AnalyticsSession Properties
AnalyticsSession Class See Also Send Feedback

The AnalyticsSession type exposes the following members.

Properties

 | Name | Description
Public property | AspNetSessionId | Gets or sets the ASP net session id.
Public property | Browser | Gets or sets the user agent.
Public property | Domain | Gets or sets the domain.
Public property | Duration | Gets or sets the duration.
Public property | Ip | Gets or sets the IP address.
Public property | IsNewSession | Gets or sets a value indicating whether this instance is new session.
Public property | Keywords | Gets or sets the keywords.
Public property | Language | Gets or sets the language.
Public property | MultiSite | Gets or sets the multi site.
Public property | OperatingSystem | Gets or sets the operating system.
Public property | Profiles | Gets the profiles.
Public property | ReferringSite | Gets or sets the referring site.
Public property | Screen | Gets or sets the screen.
Public property | SessionId | Gets or sets the session id.
Public property | Timestamp | Gets or sets the time stamp.

See Also

AnalyticsSession Class
Sitecore.Analytics Namespace


AspNetSessionId Property

[image]

Sitecore 6.4.1 API
AnalyticsSession..::..AspNetSessionId Property
AnalyticsSession Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string AspNetSessionId { get; set; }
Visual Basic
Public Property AspNetSessionId As String
    Get
    Set
Visual C++
public:
property String^ AspNetSessionId {
    String^ get ();
    void set (String^ value);
}

Field Value

The ASP net session id.

See Also

AnalyticsSession Class
Sitecore.Analytics Namespace


Browser Property

[image]

Sitecore 6.4.1 API
AnalyticsSession..::..Browser Property
AnalyticsSession Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Browser { get; set; }
Visual Basic
Public Property Browser As String
    Get
    Set
Visual C++
public:
property String^ Browser {
    String^ get ();
    void set (String^ value);
}

Field Value

The user agent.

See Also

AnalyticsSession Class
Sitecore.Analytics Namespace


Domain Property

[image]

Sitecore 6.4.1 API
AnalyticsSession..::..Domain Property
AnalyticsSession Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Domain { get; set; }
Visual Basic
Public Property Domain As String
    Get
    Set
Visual C++
public:
property String^ Domain {
    String^ get ();
    void set (String^ value);
}

Field Value

The domain.

See Also

AnalyticsSession Class
Sitecore.Analytics Namespace


Duration Property

[image]

Sitecore 6.4.1 API
AnalyticsSession..::..Duration Property
AnalyticsSession Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public TimeSpan Duration { get; set; }
Visual Basic
Public Property Duration As TimeSpan
    Get
    Set
Visual C++
public:
property TimeSpan Duration {
    TimeSpan get ();
    void set (TimeSpan value);
}

Field Value

The duration.

See Also

AnalyticsSession Class
Sitecore.Analytics Namespace


Ip Property

[image]

Sitecore 6.4.1 API
AnalyticsSession..::..Ip Property
AnalyticsSession Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Ip { get; set; }
Visual Basic
Public Property Ip As String
    Get
    Set
Visual C++
public:
property String^ Ip {
    String^ get ();
    void set (String^ value);
}

Field Value

The IP address.

See Also

AnalyticsSession Class
Sitecore.Analytics Namespace


Keywords Property

[image]

Sitecore 6.4.1 API
AnalyticsSession..::..Keywords Property
AnalyticsSession Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Keywords { get; set; }
Visual Basic
Public Property Keywords As String
    Get
    Set
Visual C++
public:
property String^ Keywords {
    String^ get ();
    void set (String^ value);
}

Field Value

The keywords.

See Also

AnalyticsSession Class
Sitecore.Analytics Namespace


Language Property

[image]

Sitecore 6.4.1 API
AnalyticsSession..::..Language Property
AnalyticsSession Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Language { get; set; }
Visual Basic
Public Property Language As String
    Get
    Set
Visual C++
public:
property String^ Language {
    String^ get ();
    void set (String^ value);
}

Field Value

The language.

See Also

AnalyticsSession Class
Sitecore.Analytics Namespace


MultiSite Property

[image]

Sitecore 6.4.1 API
AnalyticsSession..::..MultiSite Property
AnalyticsSession Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string MultiSite { get; set; }
Visual Basic
Public Property MultiSite As String
    Get
    Set
Visual C++
public:
property String^ MultiSite {
    String^ get ();
    void set (String^ value);
}

Field Value

The multi site.

See Also

AnalyticsSession Class
Sitecore.Analytics Namespace


OperatingSystem Property

[image]

Sitecore 6.4.1 API
AnalyticsSession..::..OperatingSystem Property
AnalyticsSession Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string OperatingSystem { get; set; }
Visual Basic
Public Property OperatingSystem As String
    Get
    Set
Visual C++
public:
property String^ OperatingSystem {
    String^ get ();
    void set (String^ value);
}

Field Value

The operating system.

See Also

AnalyticsSession Class
Sitecore.Analytics Namespace


Profiles Property

[image]

Sitecore 6.4.1 API
AnalyticsSession..::..Profiles Property
AnalyticsSession Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public List<Profile> Profiles { get; }
Visual Basic
Public ReadOnly Property Profiles As List(Of Profile)
    Get
Visual C++
public:
property List<Profile^>^ Profiles {
    List<Profile^>^ get ();
}

Field Value

The profiles.

See Also

AnalyticsSession Class
Sitecore.Analytics Namespace


ReferringSite Property

[image]

Sitecore 6.4.1 API
AnalyticsSession..::..ReferringSite Property
AnalyticsSession Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string ReferringSite { get; set; }
Visual Basic
Public Property ReferringSite As String
    Get
    Set
Visual C++
public:
property String^ ReferringSite {
    String^ get ();
    void set (String^ value);
}

Field Value

The referring site.

See Also

AnalyticsSession Class
Sitecore.Analytics Namespace


Screen Property

[image]

Sitecore 6.4.1 API
AnalyticsSession..::..Screen Property
AnalyticsSession Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Screen { get; set; }
Visual Basic
Public Property Screen As String
    Get
    Set
Visual C++
public:
property String^ Screen {
    String^ get ();
    void set (String^ value);
}

Field Value

The screen.

See Also

AnalyticsSession Class
Sitecore.Analytics Namespace


SessionId Property

[image]

Sitecore 6.4.1 API
AnalyticsSession..::..SessionId Property
AnalyticsSession Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid SessionId { get; set; }
Visual Basic
Public Property SessionId As Guid
    Get
    Set
Visual C++
public:
property Guid SessionId {
    Guid get ();
    void set (Guid value);
}

Field Value

The session id.

See Also

AnalyticsSession Class
Sitecore.Analytics Namespace


Timestamp Property

[image]

Sitecore 6.4.1 API
AnalyticsSession..::..Timestamp Property
AnalyticsSession Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public DateTime Timestamp { get; set; }
Visual Basic
Public Property Timestamp As DateTime
    Get
    Set
Visual C++
public:
property DateTime Timestamp {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The time stamp.

See Also

AnalyticsSession Class
Sitecore.Analytics Namespace


AnalyticsTexts Class

[image]

Sitecore 6.4.1 API
AnalyticsTexts Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static class AnalyticsTexts
Visual Basic
Public NotInheritable Class AnalyticsTexts
Visual C++
public ref class AnalyticsTexts abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics..::..AnalyticsTexts

See Also

AnalyticsTexts Members
Sitecore.Analytics Namespace


AnalyticsTexts Members

[image] [image]

Sitecore 6.4.1 API
AnalyticsTexts Members
AnalyticsTexts Class Fields See Also Send Feedback

The AnalyticsTexts type exposes the following members.

Fields

Name | Description
SelectCampaign | "Select Campaign"
SelectItem | "Select Item"
SelectLanguage | "Select Language"
SelectTheCampaignYouWantToUseForThisRule | "Select the campaign you want to use for this rule."
SelectTheItemYouWantToUseForThisRule | "Select the item you want to use for this rule."
SelectTheLanguageYouWantToUseForThisRule | "Select the language you want to use for this rule."

See Also

AnalyticsTexts Class
Sitecore.Analytics Namespace


AnalyticsTexts Fields

[image] [image]

Sitecore 6.4.1 API
AnalyticsTexts Fields
AnalyticsTexts Class See Also Send Feedback

The AnalyticsTexts type exposes the following members.

Fields

Name | Description
SelectCampaign | "Select Campaign"
SelectItem | "Select Item"
SelectLanguage | "Select Language"
SelectTheCampaignYouWantToUseForThisRule | "Select the campaign you want to use for this rule."
SelectTheItemYouWantToUseForThisRule | "Select the item you want to use for this rule."
SelectTheLanguageYouWantToUseForThisRule | "Select the language you want to use for this rule."

See Also

AnalyticsTexts Class
Sitecore.Analytics Namespace


SelectCampaign Field

[image]

Sitecore 6.4.1 API
AnalyticsTexts..::..SelectCampaign Field
AnalyticsTexts Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public const string SelectCampaign
Visual Basic
Public Const SelectCampaign As String
Visual C++
public:
literal String^ SelectCampaign

See Also

AnalyticsTexts Class
Sitecore.Analytics Namespace


SelectItem Field

[image]

Sitecore 6.4.1 API
AnalyticsTexts..::..SelectItem Field
AnalyticsTexts Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public const string SelectItem
Visual Basic
Public Const SelectItem As String
Visual C++
public:
literal String^ SelectItem

See Also

AnalyticsTexts Class
Sitecore.Analytics Namespace


SelectLanguage Field

[image]

Sitecore 6.4.1 API
AnalyticsTexts..::..SelectLanguage Field
AnalyticsTexts Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public const string SelectLanguage
Visual Basic
Public Const SelectLanguage As String
Visual C++
public:
literal String^ SelectLanguage

See Also

AnalyticsTexts Class
Sitecore.Analytics Namespace


SelectTheCampaignYouWantToUseForThisRule Field

[image]

Sitecore 6.4.1 API
AnalyticsTexts..::..SelectTheCampaignYouWantToUseForThisRule Field
AnalyticsTexts Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public const string SelectTheCampaignYouWantToUseForThisRule
Visual Basic
Public Const SelectTheCampaignYouWantToUseForThisRule As String
Visual C++
public:
literal String^ SelectTheCampaignYouWantToUseForThisRule

See Also

AnalyticsTexts Class
Sitecore.Analytics Namespace


SelectTheItemYouWantToUseForThisRule Field

[image]

Sitecore 6.4.1 API
AnalyticsTexts..::..SelectTheItemYouWantToUseForThisRule Field
AnalyticsTexts Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public const string SelectTheItemYouWantToUseForThisRule
Visual Basic
Public Const SelectTheItemYouWantToUseForThisRule As String
Visual C++
public:
literal String^ SelectTheItemYouWantToUseForThisRule

See Also

AnalyticsTexts Class
Sitecore.Analytics Namespace


SelectTheLanguageYouWantToUseForThisRule Field

[image]

Sitecore 6.4.1 API
AnalyticsTexts..::..SelectTheLanguageYouWantToUseForThisRule Field
AnalyticsTexts Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public const string SelectTheLanguageYouWantToUseForThisRule
Visual Basic
Public Const SelectTheLanguageYouWantToUseForThisRule As String
Visual C++
public:
literal String^ SelectTheLanguageYouWantToUseForThisRule

See Also

AnalyticsTexts Class
Sitecore.Analytics Namespace


AnalyticsTracker Class

[image]

Sitecore 6.4.1 API
AnalyticsTracker Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class AnalyticsTracker
Visual Basic
Public Class AnalyticsTracker
Visual C++
public ref class AnalyticsTracker

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics..::..AnalyticsTracker

See Also

AnalyticsTracker Members
Sitecore.Analytics Namespace


AnalyticsTracker Members

[image] [image]

Sitecore 6.4.1 API
AnalyticsTracker Members
AnalyticsTracker Class Constructors Methods Properties See Also Send Feedback

The AnalyticsTracker type exposes the following members.

Constructors

 | Name | Description
Public method | AnalyticsTracker | Initializes a new instance of the AnalyticsTracker class.

Methods

 | Name | Description
Public method | Cancel | Cancels this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InvalidateCachedData | Invalidates the cached data.
 | IsSampling | Gets the sampling.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetTestCampaignEventId | Sets the test campaign event id.
 | StartTracking | Starts the tracking.
Public method | Submit | Submits this instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | TriggerEvent(String) | Triggers the event.
Public method | TriggerEvent(String, String) | Triggers the event.
Public method | TriggerProfile | Profiles the specified profile name.

Properties

 | Name | Description
Public property | CanBeRobot | Gets or sets a value indicating whether this instance is not a robot.
 | Current | Gets the current.
Public property | CurrentGlobalSession | Gets or sets the global session.
Public property | CurrentPage | Gets or sets the current page.
Public property | CurrentSession | Gets or sets the session.
Public property | Data | Gets the data.
 | IsActive | Gets or sets a value indicating whether this instance is active.
Public property | IsCanceled | Gets or sets a value indicating whether this instance is new page.
Public property | IsTestCampaignEventMode | Gets a value indicating whether this instance is test mode.
Public property | NextPage | Gets or sets the next page.
Public property | PreviousPage | Gets or sets the previous page.
Public property | TestCampaignEventId | Gets the test campaign event.

See Also

AnalyticsTracker Class
Sitecore.Analytics Namespace


AnalyticsTracker Methods

[image] [image]

Sitecore 6.4.1 API
AnalyticsTracker Methods
AnalyticsTracker Class See Also Send Feedback

The AnalyticsTracker type exposes the following members.

Methods

 | Name | Description
Public method | Cancel | Cancels this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InvalidateCachedData | Invalidates the cached data.
 | IsSampling | Gets the sampling.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetTestCampaignEventId | Sets the test campaign event id.
 | StartTracking | Starts the tracking.
Public method | Submit | Submits this instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | TriggerEvent(String) | Triggers the event.
Public method | TriggerEvent(String, String) | Triggers the event.
Public method | TriggerProfile | Profiles the specified profile name.

See Also

AnalyticsTracker Class
Sitecore.Analytics Namespace


Cancel Method

[image]

Sitecore 6.4.1 API
AnalyticsTracker..::..Cancel Method
AnalyticsTracker Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void Cancel()
Visual Basic
Public Sub Cancel
Visual C++
public:
void Cancel()

See Also

AnalyticsTracker Class
Sitecore.Analytics Namespace


InvalidateCachedData Method

[image]

Sitecore 6.4.1 API
AnalyticsTracker..::..InvalidateCachedData Method
AnalyticsTracker Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void InvalidateCachedData()
Visual Basic
Public Sub InvalidateCachedData
Visual C++
public:
void InvalidateCachedData()

See Also

AnalyticsTracker Class
Sitecore.Analytics Namespace


IsSampling Method

[image]

Sitecore 6.4.1 API
AnalyticsTracker..::..IsSampling Method
AnalyticsTracker Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static bool IsSampling(
    HttpSessionState session
)
Visual Basic
Public Shared Function IsSampling ( _
    session As HttpSessionState _
) As Boolean
Visual C++
public:
static bool IsSampling(
    HttpSessionState^ session
)

Parameters

session
Type: System.Web.SessionState..::..HttpSessionState
The session.

Return Value

Returns the sampling.

See Also

AnalyticsTracker Class
Sitecore.Analytics Namespace


SetTestCampaignEventId Method

[image]

Sitecore 6.4.1 API
AnalyticsTracker..::..SetTestCampaignEventId Method
AnalyticsTracker Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void SetTestCampaignEventId(
    Guid campaignEventId
)
Visual Basic
Public Sub SetTestCampaignEventId ( _
    campaignEventId As Guid _
)
Visual C++
public:
void SetTestCampaignEventId(
    Guid campaignEventId
)

Parameters

campaignEventId
Type: System..::..Guid
The test campaign event id.

See Also

AnalyticsTracker Class
Sitecore.Analytics Namespace


StartTracking Method

[image]

Sitecore 6.4.1 API
AnalyticsTracker..::..StartTracking Method
AnalyticsTracker Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void StartTracking()
Visual Basic
Public Shared Sub StartTracking
Visual C++
public:
static void StartTracking()

Exceptions

Exception | Condition
System..::..InvalidOperationException | Cannot start Analytics Tracker when HttpContext.Current == null.

See Also

AnalyticsTracker Class
Sitecore.Analytics Namespace


Submit Method

[image]

Sitecore 6.4.1 API
AnalyticsTracker..::..Submit Method
AnalyticsTracker Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void Submit()
Visual Basic
Public Sub Submit
Visual C++
public:
void Submit()

See Also

AnalyticsTracker Class
Sitecore.Analytics Namespace


TriggerEvent Method

[image] [image]

Sitecore 6.4.1 API
AnalyticsTracker..::..TriggerEvent Method
AnalyticsTracker Class See Also Send Feedback

Overload List

 | Name | Description
 | TriggerEvent(String) | Triggers the event.
Public method | TriggerEvent(String, String) | Triggers the event.

See Also

AnalyticsTracker Class
AnalyticsTracker Members
Sitecore.Analytics Namespace


TriggerEvent Method (String)

[image]

Sitecore 6.4.1 API
AnalyticsTracker..::..TriggerEvent Method (String)
AnalyticsTracker Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void TriggerEvent(
    string pageEventName
)
Visual Basic
Public Shared Sub TriggerEvent ( _
    pageEventName As String _
)
Visual C++
public:
static void TriggerEvent(
    String^ pageEventName
)

Parameters

pageEventName
Type: System..::..String
Name of the page event.

See Also

AnalyticsTracker Class
TriggerEvent Overload
Sitecore.Analytics Namespace


TriggerEvent Method (String, String)

[image]

Sitecore 6.4.1 API
AnalyticsTracker..::..TriggerEvent Method (String, String)
AnalyticsTracker Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void TriggerEvent(
    string pageEventName,
    string text
)
Visual Basic
Public Sub TriggerEvent ( _
    pageEventName As String, _
    text As String _
)
Visual C++
public:
void TriggerEvent(
    String^ pageEventName,
    String^ text
)

Parameters

pageEventName
Type: System..::..String
Name of the page event.
text
Type: System..::..String
The event text.

See Also

AnalyticsTracker Class
TriggerEvent Overload
Sitecore.Analytics Namespace


TriggerProfile Method

[image]

Sitecore 6.4.1 API
AnalyticsTracker..::..TriggerProfile Method
AnalyticsTracker Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void TriggerProfile(
    string profileName,
    string profileKeyName,
    int value
)
Visual Basic
Public Sub TriggerProfile ( _
    profileName As String, _
    profileKeyName As String, _
    value As Integer _
)
Visual C++
public:
void TriggerProfile(
    String^ profileName,
    String^ profileKeyName,
    int value
)

Parameters

profileName
Type: System..::..String
Name of the profile.
profileKeyName
Type: System..::..String
Name of the profile key.
value
Type: System..::..Int32
The value.

See Also

AnalyticsTracker Class
Sitecore.Analytics Namespace


AnalyticsTracker Properties

[image] [image]

Sitecore 6.4.1 API
AnalyticsTracker Properties
AnalyticsTracker Class See Also Send Feedback

The AnalyticsTracker type exposes the following members.

Properties

 | Name | Description
Public property | CanBeRobot | Gets or sets a value indicating whether this instance is not a robot.
 | Current | Gets the current.
Public property | CurrentGlobalSession | Gets or sets the global session.
Public property | CurrentPage | Gets or sets the current page.
Public property | CurrentSession | Gets or sets the session.
Public property | Data | Gets the data.
 | IsActive | Gets or sets a value indicating whether this instance is active.
Public property | IsCanceled | Gets or sets a value indicating whether this instance is new page.
Public property | IsTestCampaignEventMode | Gets a value indicating whether this instance is test mode.
Public property | NextPage | Gets or sets the next page.
Public property | PreviousPage | Gets or sets the previous page.
Public property | TestCampaignEventId | Gets the test campaign event.

See Also

AnalyticsTracker Class
Sitecore.Analytics Namespace


Current Property

[image]

Sitecore 6.4.1 API
AnalyticsTracker..::..Current Property
AnalyticsTracker Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static AnalyticsTracker Current { get; }
Visual Basic
Public Shared ReadOnly Property Current As AnalyticsTracker
    Get
Visual C++
public:
static property AnalyticsTracker^ Current {
    AnalyticsTracker^ get ();
}

Field Value

The current.

Exceptions

Exception | Condition
System..::..Exception | Analytics tracking is only active after the PreInit event of the page has been called.

See Also

AnalyticsTracker Class
Sitecore.Analytics Namespace


CurrentGlobalSession Property

[image]

Sitecore 6.4.1 API
AnalyticsTracker..::..CurrentGlobalSession Property
AnalyticsTracker Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public AnalyticsGlobalSession CurrentGlobalSession { get; set; }
Visual Basic
Public Property CurrentGlobalSession As AnalyticsGlobalSession
    Get
    Set
Visual C++
public:
property AnalyticsGlobalSession^ CurrentGlobalSession {
    AnalyticsGlobalSession^ get ();
    void set (AnalyticsGlobalSession^ value);
}

Field Value

The global session.

See Also

AnalyticsTracker Class
Sitecore.Analytics Namespace


CurrentPage Property

[image]

Sitecore 6.4.1 API
AnalyticsTracker..::..CurrentPage Property
AnalyticsTracker Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public AnalyticsPage CurrentPage { get; set; }
Visual Basic
Public Property CurrentPage As AnalyticsPage
    Get
    Set
Visual C++
public:
property AnalyticsPage^ CurrentPage {
    AnalyticsPage^ get ();
    void set (AnalyticsPage^ value);
}

Field Value

The current page.

See Also

AnalyticsTracker Class
Sitecore.Analytics Namespace


CurrentSession Property

[image]

Sitecore 6.4.1 API
AnalyticsTracker..::..CurrentSession Property
AnalyticsTracker Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public AnalyticsSession CurrentSession { get; set; }
Visual Basic
Public Property CurrentSession As AnalyticsSession
    Get
    Set
Visual C++
public:
property AnalyticsSession^ CurrentSession {
    AnalyticsSession^ get ();
    void set (AnalyticsSession^ value);
}

Field Value

The session.

See Also

AnalyticsTracker Class
Sitecore.Analytics Namespace


Data Property

[image]

Sitecore 6.4.1 API
AnalyticsTracker..::..Data Property
AnalyticsTracker Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public AnalyticsCachedData Data { get; }
Visual Basic
Public ReadOnly Property Data As AnalyticsCachedData
    Get
Visual C++
public:
property AnalyticsCachedData^ Data {
    AnalyticsCachedData^ get ();
}

Field Value

The current data.

See Also

AnalyticsTracker Class
Sitecore.Analytics Namespace


IsActive Property

[image]

Sitecore 6.4.1 API
AnalyticsTracker..::..IsActive Property
AnalyticsTracker Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static bool IsActive { get; set; }
Visual Basic
Public Shared Property IsActive As Boolean
    Get
    Set
Visual C++
public:
static property bool IsActive {
    bool get ();
    void set (bool value);
}

Field Value

true if this instance is tracking; otherwise, false.

See Also

AnalyticsTracker Class
Sitecore.Analytics Namespace


IsCanceled Property

[image]

Sitecore 6.4.1 API
AnalyticsTracker..::..IsCanceled Property
AnalyticsTracker Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public bool IsCanceled { get; set; }
Visual Basic
Public Property IsCanceled As Boolean
    Get
    Set
Visual C++
public:
property bool IsCanceled {
    bool get ();
    void set (bool value);
}

Field Value

true if this instance is new page; otherwise, false.

See Also

AnalyticsTracker Class
Sitecore.Analytics Namespace


IsTestCampaignEventMode Property

[image]

Sitecore 6.4.1 API
AnalyticsTracker..::..IsTestCampaignEventMode Property
AnalyticsTracker Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public bool IsTestCampaignEventMode { get; }
Visual Basic
Public ReadOnly Property IsTestCampaignEventMode As Boolean
    Get
Visual C++
public:
property bool IsTestCampaignEventMode {
    bool get ();
}

Field Value

true if this instance is test mode; otherwise, false.

See Also

AnalyticsTracker Class
Sitecore.Analytics Namespace


NextPage Property

[image]

Sitecore 6.4.1 API
AnalyticsTracker..::..NextPage Property
AnalyticsTracker Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public AnalyticsPage NextPage { get; set; }
Visual Basic
Public Property NextPage As AnalyticsPage
    Get
    Set
Visual C++
public:
property AnalyticsPage^ NextPage {
    AnalyticsPage^ get ();
    void set (AnalyticsPage^ value);
}

Field Value

The next page.

See Also

AnalyticsTracker Class
Sitecore.Analytics Namespace


PreviousPage Property

[image]

Sitecore 6.4.1 API
AnalyticsTracker..::..PreviousPage Property
AnalyticsTracker Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public AnalyticsPage PreviousPage { get; set; }
Visual Basic
Public Property PreviousPage As AnalyticsPage
    Get
    Set
Visual C++
public:
property AnalyticsPage^ PreviousPage {
    AnalyticsPage^ get ();
    void set (AnalyticsPage^ value);
}

Field Value

The previous page.

See Also

AnalyticsTracker Class
Sitecore.Analytics Namespace


TestCampaignEventId Property

[image]

Sitecore 6.4.1 API
AnalyticsTracker..::..TestCampaignEventId Property
AnalyticsTracker Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid TestCampaignEventId { get; }
Visual Basic
Public ReadOnly Property TestCampaignEventId As Guid
    Get
Visual C++
public:
property Guid TestCampaignEventId {
    Guid get ();
}

Field Value

The test campaign event.

See Also

AnalyticsTracker Class
Sitecore.Analytics Namespace


AnalyticsTracker.Summary Class

[image]

Sitecore 6.4.1 API
AnalyticsTracker..::..Summary Class
AnalyticsTracker Class Members See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
[ObsoleteAttribute("Use SummaryHtmlWriter instead.")]
public static class Summary
Visual Basic
<ObsoleteAttribute("Use SummaryHtmlWriter instead.")> _
Public NotInheritable Class Summary
Visual C++
[ObsoleteAttribute(L"Use SummaryHtmlWriter instead.")]
public ref class Summary abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics..::..AnalyticsTracker..::..Summary

See Also

AnalyticsTracker..::..Summary Members
Sitecore.Analytics Namespace


AnalyticsTracker.Summary Members

[image] [image]

Sitecore 6.4.1 API
AnalyticsTracker..::..Summary Members
AnalyticsTracker..::..Summary Class Methods See Also Send Feedback

Defines the analytics tracker class.
Defines the analytics tracker class.

The AnalyticsTracker..::..Summary type exposes the following members.

Methods

Name | Description
Render | Renders this instance.

See Also

AnalyticsTracker..::..Summary Class
Sitecore.Analytics Namespace


AnalyticsTracker.Summary Methods

[image] [image]

Sitecore 6.4.1 API
AnalyticsTracker..::..Summary Methods
AnalyticsTracker..::..Summary Class See Also Send Feedback

The AnalyticsTracker..::..Summary type exposes the following members.

Methods

Name | Description
Render | Renders this instance.

See Also

AnalyticsTracker..::..Summary Class
Sitecore.Analytics Namespace


Render Method

[image]

Sitecore 6.4.1 API
AnalyticsTracker..::..Summary..::..Render Method
AnalyticsTracker..::..Summary Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static string Render()
Visual Basic
Public Shared Function Render As String
Visual C++
public:
static String^ Render()

Return Value

Returns the string.

See Also

AnalyticsTracker..::..Summary Class
Sitecore.Analytics Namespace


Browser Class

[image]

Sitecore 6.4.1 API
Browser Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class Browser
Visual Basic
Public Class Browser
Visual C++
public ref class Browser

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics..::..Browser

See Also

Browser Members
Sitecore.Analytics Namespace


Browser Members

[image] [image]

Sitecore 6.4.1 API
Browser Members
Browser Class Constructors Methods Properties See Also Send Feedback

The Browser type exposes the following members.

Constructors

 | Name | Description
Public method | Browser | Initializes a new instance of the Browser class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BrowserId | Gets or sets the browser id.
Public property | Comment | Gets or sets the comment.
Public property | Description | Gets or sets the description.
Public property | Link1 | Gets or sets the link1.
Public property | Link2 | Gets or sets the link2.
Public property | MajorName | Gets or sets the name of the major.
Public property | UserAgent | Gets or sets the user agent.
Public property | Version | Gets or sets the version.
Public property | VisitorIdentification | Gets or sets the visitor identification.

See Also

Browser Class
Sitecore.Analytics Namespace


Browser Constructor

[image]

Sitecore 6.4.1 API
Browser Constructor
Browser Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Browser()
Visual Basic
Public Sub New
Visual C++
public:
Browser()

See Also

Browser Class
Sitecore.Analytics Namespace


Browser Methods

[image] [image]

Sitecore 6.4.1 API
Browser Methods
Browser Class See Also Send Feedback

The Browser type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Browser Class
Sitecore.Analytics Namespace


Browser Properties

[image] [image]

Sitecore 6.4.1 API
Browser Properties
Browser Class See Also Send Feedback

The Browser type exposes the following members.

Properties

 | Name | Description
Public property | BrowserId | Gets or sets the browser id.
Public property | Comment | Gets or sets the comment.
Public property | Description | Gets or sets the description.
Public property | Link1 | Gets or sets the link1.
Public property | Link2 | Gets or sets the link2.
Public property | MajorName | Gets or sets the name of the major.
Public property | UserAgent | Gets or sets the user agent.
Public property | Version | Gets or sets the version.
Public property | VisitorIdentification | Gets or sets the visitor identification.

See Also

Browser Class
Sitecore.Analytics Namespace


Description Property

[image]

Sitecore 6.4.1 API
Browser..::..Description Property
Browser Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Field Value

The description.

See Also

Browser Class
Sitecore.Analytics Namespace


Link1 Property

[image]

Sitecore 6.4.1 API
Browser..::..Link1 Property
Browser Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Link1 { get; set; }
Visual Basic
Public Property Link1 As String
    Get
    Set
Visual C++
public:
property String^ Link1 {
    String^ get ();
    void set (String^ value);
}

Field Value

The link1.

See Also

Browser Class
Sitecore.Analytics Namespace


Link2 Property

[image]

Sitecore 6.4.1 API
Browser..::..Link2 Property
Browser Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Link2 { get; set; }
Visual Basic
Public Property Link2 As String
    Get
    Set
Visual C++
public:
property String^ Link2 {
    String^ get ();
    void set (String^ value);
}

Field Value

The link2.

See Also

Browser Class
Sitecore.Analytics Namespace


MajorName Property

[image]

Sitecore 6.4.1 API
Browser..::..MajorName Property
Browser Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string MajorName { get; set; }
Visual Basic
Public Property MajorName As String
    Get
    Set
Visual C++
public:
property String^ MajorName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the major.

See Also

Browser Class
Sitecore.Analytics Namespace


UserAgent Property

[image]

Sitecore 6.4.1 API
Browser..::..UserAgent Property
Browser Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string UserAgent { get; set; }
Visual Basic
Public Property UserAgent As String
    Get
    Set
Visual C++
public:
property String^ UserAgent {
    String^ get ();
    void set (String^ value);
}

Field Value

The user agent.

See Also

Browser Class
Sitecore.Analytics Namespace


Version Property

[image]

Sitecore 6.4.1 API
Browser..::..Version Property
Browser Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Version { get; set; }
Visual Basic
Public Property Version As String
    Get
    Set
Visual C++
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}

Field Value

The version.

See Also

Browser Class
Sitecore.Analytics Namespace


VisitorIdentification Property

[image]

Sitecore 6.4.1 API
Browser..::..VisitorIdentification Property
Browser Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int VisitorIdentification { get; set; }
Visual Basic
Public Property VisitorIdentification As Integer
    Get
    Set
Visual C++
public:
property int VisitorIdentification {
    int get ();
    void set (int value);
}

Field Value

The visitor identification.

See Also

Browser Class
Sitecore.Analytics Namespace


Campaign Class

[image]

Sitecore 6.4.1 API
Campaign Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class Campaign
Visual Basic
Public Class Campaign
Visual C++
public ref class Campaign

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics..::..Campaign

See Also

Campaign Members
Sitecore.Analytics Namespace


Campaign Members

[image] [image]

Sitecore 6.4.1 API
Campaign Members
Campaign Class Constructors Methods Properties See Also Send Feedback

The Campaign type exposes the following members.

Constructors

 | Name | Description
Public method | Campaign | Initializes a new instance of the Campaign class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CampaignId | Gets or sets the campaign id.
Public property | Cost | Gets or sets the cost.
Public property | Data | Gets or sets the data.
Public property | Description | Gets or sets the description.
Public property | EndDate | Gets or sets the end date.
Public property | IsActive | Gets or sets the is active.
Public property | StartDate | Gets or sets the start date.
Public property | Title | Gets or sets the title.
Public property | Type | Gets or sets the type.

See Also

Campaign Class
Sitecore.Analytics Namespace


Campaign Constructor

[image]

Sitecore 6.4.1 API
Campaign Constructor
Campaign Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Campaign()
Visual Basic
Public Sub New
Visual C++
public:
Campaign()

See Also

Campaign Class
Sitecore.Analytics Namespace


Campaign Methods

[image] [image]

Sitecore 6.4.1 API
Campaign Methods
Campaign Class See Also Send Feedback

The Campaign type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Campaign Class
Sitecore.Analytics Namespace


Campaign Properties

[image] [image]

Sitecore 6.4.1 API
Campaign Properties
Campaign Class See Also Send Feedback

The Campaign type exposes the following members.

Properties

 | Name | Description
Public property | CampaignId | Gets or sets the campaign id.
Public property | Cost | Gets or sets the cost.
Public property | Data | Gets or sets the data.
Public property | Description | Gets or sets the description.
Public property | EndDate | Gets or sets the end date.
Public property | IsActive | Gets or sets the is active.
Public property | StartDate | Gets or sets the start date.
Public property | Title | Gets or sets the title.
Public property | Type | Gets or sets the type.

See Also

Campaign Class
Sitecore.Analytics Namespace


CampaignId Property

[image]

Sitecore 6.4.1 API
Campaign..::..CampaignId Property
Campaign Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid CampaignId { get; set; }
Visual Basic
Public Property CampaignId As Guid
    Get
    Set
Visual C++
public:
property Guid CampaignId {
    Guid get ();
    void set (Guid value);
}

Field Value

The campaign id.

See Also

Campaign Class
Sitecore.Analytics Namespace


Cost Property

[image]

Sitecore 6.4.1 API
Campaign..::..Cost Property
Campaign Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public double Cost { get; set; }
Visual Basic
Public Property Cost As Double
    Get
    Set
Visual C++
public:
property double Cost {
    double get ();
    void set (double value);
}

Field Value

The cost.

See Also

Campaign Class
Sitecore.Analytics Namespace


Data Property

[image]

Sitecore 6.4.1 API
Campaign..::..Data Property
Campaign Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Data { get; set; }
Visual Basic
Public Property Data As String
    Get
    Set
Visual C++
public:
property String^ Data {
    String^ get ();
    void set (String^ value);
}

Field Value

The data.

See Also

Campaign Class
Sitecore.Analytics Namespace


EndDate Property

[image]

Sitecore 6.4.1 API
Campaign..::..EndDate Property
Campaign Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public DateTime EndDate { get; set; }
Visual Basic
Public Property EndDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime EndDate {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The end date.

See Also

Campaign Class
Sitecore.Analytics Namespace


IsActive Property

[image]

Sitecore 6.4.1 API
Campaign..::..IsActive Property
Campaign Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int IsActive { get; set; }
Visual Basic
Public Property IsActive As Integer
    Get
    Set
Visual C++
public:
property int IsActive {
    int get ();
    void set (int value);
}

Field Value

The is active.

See Also

Campaign Class
Sitecore.Analytics Namespace


StartDate Property

[image]

Sitecore 6.4.1 API
Campaign..::..StartDate Property
Campaign Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public DateTime StartDate { get; set; }
Visual Basic
Public Property StartDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime StartDate {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The start date.

See Also

Campaign Class
Sitecore.Analytics Namespace


Type Property

[image]

Sitecore 6.4.1 API
Campaign..::..Type Property
Campaign Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Type { get; set; }
Visual Basic
Public Property Type As String
    Get
    Set
Visual C++
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}

Field Value

The type.

See Also

Campaign Class
Sitecore.Analytics Namespace


CampaignEvent Class

[image]

Sitecore 6.4.1 API
CampaignEvent Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class CampaignEvent
Visual Basic
Public Class CampaignEvent
Visual C++
public ref class CampaignEvent

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics..::..CampaignEvent

See Also

CampaignEvent Members
Sitecore.Analytics Namespace


CampaignEvent Members

[image] [image]

Sitecore 6.4.1 API
CampaignEvent Members
CampaignEvent Class Constructors Methods Properties See Also Send Feedback

The CampaignEvent type exposes the following members.

Constructors

 | Name | Description
Public method | CampaignEvent | Initializes a new instance of the CampaignEvent class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CampaignEventId | Gets or sets the campaign event id.
Public property | CampaignId | Gets or sets the campaign id.
Public property | Data | Gets or sets the data.
Public property | DateTime | Gets or sets the date time.
Public property | State | Gets or sets the state.

See Also

CampaignEvent Class
Sitecore.Analytics Namespace


CampaignEvent Constructor

[image]

Sitecore 6.4.1 API
CampaignEvent Constructor
CampaignEvent Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public CampaignEvent()
Visual Basic
Public Sub New
Visual C++
public:
CampaignEvent()

See Also

CampaignEvent Class
Sitecore.Analytics Namespace


CampaignEvent Methods

[image] [image]

Sitecore 6.4.1 API
CampaignEvent Methods
CampaignEvent Class See Also Send Feedback

The CampaignEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CampaignEvent Class
Sitecore.Analytics Namespace


CampaignEvent Properties

[image] [image]

Sitecore 6.4.1 API
CampaignEvent Properties
CampaignEvent Class See Also Send Feedback

The CampaignEvent type exposes the following members.

Properties

 | Name | Description
Public property | CampaignEventId | Gets or sets the campaign event id.
Public property | CampaignId | Gets or sets the campaign id.
Public property | Data | Gets or sets the data.
Public property | DateTime | Gets or sets the date time.
Public property | State | Gets or sets the state.

See Also

CampaignEvent Class
Sitecore.Analytics Namespace


CampaignEventId Property

[image]

Sitecore 6.4.1 API
CampaignEvent..::..CampaignEventId Property
CampaignEvent Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid CampaignEventId { get; set; }
Visual Basic
Public Property CampaignEventId As Guid
    Get
    Set
Visual C++
public:
property Guid CampaignEventId {
    Guid get ();
    void set (Guid value);
}

Field Value

The campaign event id.

See Also

CampaignEvent Class
Sitecore.Analytics Namespace


CampaignId Property

[image]

Sitecore 6.4.1 API
CampaignEvent..::..CampaignId Property
CampaignEvent Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid CampaignId { get; set; }
Visual Basic
Public Property CampaignId As Guid
    Get
    Set
Visual C++
public:
property Guid CampaignId {
    Guid get ();
    void set (Guid value);
}

Field Value

The campaign id.

See Also

CampaignEvent Class
Sitecore.Analytics Namespace


Data Property

[image]

Sitecore 6.4.1 API
CampaignEvent..::..Data Property
CampaignEvent Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Data { get; set; }
Visual Basic
Public Property Data As String
    Get
    Set
Visual C++
public:
property String^ Data {
    String^ get ();
    void set (String^ value);
}

Field Value

The data.

See Also

CampaignEvent Class
Sitecore.Analytics Namespace


DateTime Property

[image]

Sitecore 6.4.1 API
CampaignEvent..::..DateTime Property
CampaignEvent Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public DateTime DateTime { get; set; }
Visual Basic
Public Property DateTime As DateTime
    Get
    Set
Visual C++
public:
property DateTime DateTime {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The date time.

See Also

CampaignEvent Class
Sitecore.Analytics Namespace


State Property

[image]

Sitecore 6.4.1 API
CampaignEvent..::..State Property
CampaignEvent Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int State { get; set; }
Visual Basic
Public Property State As Integer
    Get
    Set
Visual C++
public:
property int State {
    int get ();
    void set (int value);
}

Field Value

The state.

See Also

CampaignEvent Class
Sitecore.Analytics Namespace


CampaignEventPage Class

[image]

Sitecore 6.4.1 API
CampaignEventPage Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class CampaignEventPage
Visual Basic
Public Class CampaignEventPage
Visual C++
public ref class CampaignEventPage

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics..::..CampaignEventPage

See Also

CampaignEventPage Members
Sitecore.Analytics Namespace


CampaignEventPage Members

[image] [image]

Sitecore 6.4.1 API
CampaignEventPage Members
CampaignEventPage Class Constructors Methods Properties See Also Send Feedback

The CampaignEventPage type exposes the following members.

Constructors

 | Name | Description
Public method | CampaignEventPage | Initializes a new instance of the CampaignEventPage class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CampaignEventId | Gets or sets the campaign event id.
Public property | CampaignSessionPageId | Gets or sets the campaign session page id.
Public property | PageId | Gets or sets the page id.

See Also

CampaignEventPage Class
Sitecore.Analytics Namespace


CampaignEventPage Constructor

[image]

Sitecore 6.4.1 API
CampaignEventPage Constructor
CampaignEventPage Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public CampaignEventPage()
Visual Basic
Public Sub New
Visual C++
public:
CampaignEventPage()

See Also

CampaignEventPage Class
Sitecore.Analytics Namespace


CampaignEventPage Methods

[image] [image]

Sitecore 6.4.1 API
CampaignEventPage Methods
CampaignEventPage Class See Also Send Feedback

The CampaignEventPage type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CampaignEventPage Class
Sitecore.Analytics Namespace


CampaignEventPage Properties

[image] [image]

Sitecore 6.4.1 API
CampaignEventPage Properties
CampaignEventPage Class See Also Send Feedback

The CampaignEventPage type exposes the following members.

Properties

 | Name | Description
Public property | CampaignEventId | Gets or sets the campaign event id.
Public property | CampaignSessionPageId | Gets or sets the campaign session page id.
Public property | PageId | Gets or sets the page id.

See Also

CampaignEventPage Class
Sitecore.Analytics Namespace


CampaignEventId Property

[image]

Sitecore 6.4.1 API
CampaignEventPage..::..CampaignEventId Property
CampaignEventPage Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid CampaignEventId { get; set; }
Visual Basic
Public Property CampaignEventId As Guid
    Get
    Set
Visual C++
public:
property Guid CampaignEventId {
    Guid get ();
    void set (Guid value);
}

Field Value

The campaign event id.

See Also

CampaignEventPage Class
Sitecore.Analytics Namespace


CampaignSessionPageId Property

[image]

Sitecore 6.4.1 API
CampaignEventPage..::..CampaignSessionPageId Property
CampaignEventPage Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid CampaignSessionPageId { get; set; }
Visual Basic
Public Property CampaignSessionPageId As Guid
    Get
    Set
Visual C++
public:
property Guid CampaignSessionPageId {
    Guid get ();
    void set (Guid value);
}

Field Value

The campaign session page id.

See Also

CampaignEventPage Class
Sitecore.Analytics Namespace


GlobalSession Class

[image]

Sitecore 6.4.1 API
GlobalSession Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class GlobalSession
Visual Basic
Public Class GlobalSession
Visual C++
public ref class GlobalSession

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics..::..GlobalSession

See Also

GlobalSession Members
Sitecore.Analytics Namespace


GlobalSession Members

[image] [image]

Sitecore 6.4.1 API
GlobalSession Members
GlobalSession Class Constructors Methods Properties See Also Send Feedback

The GlobalSession type exposes the following members.

Constructors

 | Name | Description
Public method | GlobalSession | Initializes a new instance of the GlobalSession class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CookieValue | Gets or sets the cookie value.
Public property | ExternalUser | Gets or sets the external user.
Public property | GlobalSessionId | Gets or sets the global session id.
Public property | OverriddenVisitorIdentification | Gets or sets the overridden visitor identification.
Public property | VisitorIdentification | Gets or sets the visitor identification.

See Also

GlobalSession Class
Sitecore.Analytics Namespace


GlobalSession Constructor

[image]

Sitecore 6.4.1 API
GlobalSession Constructor
GlobalSession Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public GlobalSession()
Visual Basic
Public Sub New
Visual C++
public:
GlobalSession()

See Also

GlobalSession Class
Sitecore.Analytics Namespace


GlobalSession Methods

[image] [image]

Sitecore 6.4.1 API
GlobalSession Methods
GlobalSession Class See Also Send Feedback

The GlobalSession type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GlobalSession Class
Sitecore.Analytics Namespace


GlobalSession Properties

[image] [image]

Sitecore 6.4.1 API
GlobalSession Properties
GlobalSession Class See Also Send Feedback

The GlobalSession type exposes the following members.

Properties

 | Name | Description
Public property | CookieValue | Gets or sets the cookie value.
Public property | ExternalUser | Gets or sets the external user.
Public property | GlobalSessionId | Gets or sets the global session id.
Public property | OverriddenVisitorIdentification | Gets or sets the overridden visitor identification.
Public property | VisitorIdentification | Gets or sets the visitor identification.

See Also

GlobalSession Class
Sitecore.Analytics Namespace


CookieValue Property

[image]

Sitecore 6.4.1 API
GlobalSession..::..CookieValue Property
GlobalSession Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string CookieValue { get; set; }
Visual Basic
Public Property CookieValue As String
    Get
    Set
Visual C++
public:
property String^ CookieValue {
    String^ get ();
    void set (String^ value);
}

Field Value

The cookie value.

See Also

GlobalSession Class
Sitecore.Analytics Namespace


ExternalUser Property

[image]

Sitecore 6.4.1 API
GlobalSession..::..ExternalUser Property
GlobalSession Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string ExternalUser { get; set; }
Visual Basic
Public Property ExternalUser As String
    Get
    Set
Visual C++
public:
property String^ ExternalUser {
    String^ get ();
    void set (String^ value);
}

Field Value

The external user.

See Also

GlobalSession Class
Sitecore.Analytics Namespace


GlobalSessionId Property

[image]

Sitecore 6.4.1 API
GlobalSession..::..GlobalSessionId Property
GlobalSession Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid GlobalSessionId { get; set; }
Visual Basic
Public Property GlobalSessionId As Guid
    Get
    Set
Visual C++
public:
property Guid GlobalSessionId {
    Guid get ();
    void set (Guid value);
}

Field Value

The global session id.

See Also

GlobalSession Class
Sitecore.Analytics Namespace


OverriddenVisitorIdentification Property

[image]

Sitecore 6.4.1 API
GlobalSession..::..OverriddenVisitorIdentification Property
GlobalSession Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int OverriddenVisitorIdentification { get; set; }
Visual Basic
Public Property OverriddenVisitorIdentification As Integer
    Get
    Set
Visual C++
public:
property int OverriddenVisitorIdentification {
    int get ();
    void set (int value);
}

Field Value

The overridden visitor identification.

See Also

GlobalSession Class
Sitecore.Analytics Namespace


VisitorIdentification Property

[image]

Sitecore 6.4.1 API
GlobalSession..::..VisitorIdentification Property
GlobalSession Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int VisitorIdentification { get; set; }
Visual Basic
Public Property VisitorIdentification As Integer
    Get
    Set
Visual C++
public:
property int VisitorIdentification {
    int get ();
    void set (int value);
}

Field Value

The visitor identification.

See Also

GlobalSession Class
Sitecore.Analytics Namespace


IP Class

[image]

Sitecore 6.4.1 API
IP Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class IP
Visual Basic
Public Class IP
Visual C++
public ref class IP

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics..::..IP

See Also

IP Members
Sitecore.Analytics Namespace


IP Members

[image] [image]

Sitecore 6.4.1 API
IP Members
IP Class Constructors Methods Properties See Also Send Feedback

The IP type exposes the following members.

Constructors

 | Name | Description
Public method | IP | Initializes a new instance of the IP class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AreaCode | Gets or sets the area code.
Public property | City | Gets or sets the city.
Public property | Dns | Gets or sets the DNS.
Public property | DnsVisitorIdentification | Gets or sets the DNS visitor identification.
Public property | IpAddressFrom | Gets or sets the ip address from.
Public property | IpAddressTo | Gets or sets the ip address to.
Public property | IpId | Gets or sets the ip id.
Public property | IpOwnerId | Gets or sets the ip owner id.
Public property | IspName | Gets or sets the name of the isp.
Public property | Latitude | Gets or sets the latitude.
Public property | Longitude | Gets or sets the longitude.
Public property | MetroCode | Gets or sets the metro code.
Public property | PostalCode | Gets or sets the postal code.
Public property | Region | Gets or sets the region.
Public property | VisitorIdentification | Gets or sets the visitor identification.

See Also

IP Class
Sitecore.Analytics Namespace


IP Constructor

[image]

Sitecore 6.4.1 API
IP Constructor
IP Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public IP()
Visual Basic
Public Sub New
Visual C++
public:
IP()

See Also

IP Class
Sitecore.Analytics Namespace


IP Methods

[image] [image]

Sitecore 6.4.1 API
IP Methods
IP Class See Also Send Feedback

The IP type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IP Class
Sitecore.Analytics Namespace


IP Properties

[image] [image]

Sitecore 6.4.1 API
IP Properties
IP Class See Also Send Feedback

The IP type exposes the following members.

Properties

 | Name | Description
Public property | AreaCode | Gets or sets the area code.
Public property | City | Gets or sets the city.
Public property | Dns | Gets or sets the DNS.
Public property | DnsVisitorIdentification | Gets or sets the DNS visitor identification.
Public property | IpAddressFrom | Gets or sets the ip address from.
Public property | IpAddressTo | Gets or sets the ip address to.
Public property | IpId | Gets or sets the ip id.
Public property | IpOwnerId | Gets or sets the ip owner id.
Public property | IspName | Gets or sets the name of the isp.
Public property | Latitude | Gets or sets the latitude.
Public property | Longitude | Gets or sets the longitude.
Public property | MetroCode | Gets or sets the metro code.
Public property | PostalCode | Gets or sets the postal code.
Public property | Region | Gets or sets the region.
Public property | VisitorIdentification | Gets or sets the visitor identification.

See Also

IP Class
Sitecore.Analytics Namespace


AreaCode Property

[image]

Sitecore 6.4.1 API
IP..::..AreaCode Property
IP Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string AreaCode { get; set; }
Visual Basic
Public Property AreaCode As String
    Get
    Set
Visual C++
public:
property String^ AreaCode {
    String^ get ();
    void set (String^ value);
}

Field Value

The area code.

See Also

IP Class
Sitecore.Analytics Namespace


City Property

[image]

Sitecore 6.4.1 API
IP..::..City Property
IP Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string City { get; set; }
Visual Basic
Public Property City As String
    Get
    Set
Visual C++
public:
property String^ City {
    String^ get ();
    void set (String^ value);
}

Field Value

The city.

See Also

IP Class
Sitecore.Analytics Namespace


Dns Property

[image]

Sitecore 6.4.1 API
IP..::..Dns Property
IP Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Dns { get; set; }
Visual Basic
Public Property Dns As String
    Get
    Set
Visual C++
public:
property String^ Dns {
    String^ get ();
    void set (String^ value);
}

Field Value

The DNS.

See Also

IP Class
Sitecore.Analytics Namespace


DnsVisitorIdentification Property

[image]

Sitecore 6.4.1 API
IP..::..DnsVisitorIdentification Property
IP Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int DnsVisitorIdentification { get; set; }
Visual Basic
Public Property DnsVisitorIdentification As Integer
    Get
    Set
Visual C++
public:
property int DnsVisitorIdentification {
    int get ();
    void set (int value);
}

Field Value

The DNS visitor identification.

See Also

IP Class
Sitecore.Analytics Namespace


IpAddressTo Property

[image]

Sitecore 6.4.1 API
IP..::..IpAddressTo Property
IP Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string IpAddressTo { get; set; }
Visual Basic
Public Property IpAddressTo As String
    Get
    Set
Visual C++
public:
property String^ IpAddressTo {
    String^ get ();
    void set (String^ value);
}

Field Value

The ip address to.

See Also

IP Class
Sitecore.Analytics Namespace


IpId Property

[image]

Sitecore 6.4.1 API
IP..::..IpId Property
IP Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid IpId { get; set; }
Visual Basic
Public Property IpId As Guid
    Get
    Set
Visual C++
public:
property Guid IpId {
    Guid get ();
    void set (Guid value);
}

Field Value

The ip id.

See Also

IP Class
Sitecore.Analytics Namespace


IpOwnerId Property

[image]

Sitecore 6.4.1 API
IP..::..IpOwnerId Property
IP Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid IpOwnerId { get; set; }
Visual Basic
Public Property IpOwnerId As Guid
    Get
    Set
Visual C++
public:
property Guid IpOwnerId {
    Guid get ();
    void set (Guid value);
}

Field Value

The ip owner id.

See Also

IP Class
Sitecore.Analytics Namespace


IspName Property

[image]

Sitecore 6.4.1 API
IP..::..IspName Property
IP Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string IspName { get; set; }
Visual Basic
Public Property IspName As String
    Get
    Set
Visual C++
public:
property String^ IspName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the isp.

See Also

IP Class
Sitecore.Analytics Namespace


Latitude Property

[image]

Sitecore 6.4.1 API
IP..::..Latitude Property
IP Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Latitude { get; set; }
Visual Basic
Public Property Latitude As String
    Get
    Set
Visual C++
public:
property String^ Latitude {
    String^ get ();
    void set (String^ value);
}

Field Value

The latitude.

See Also

IP Class
Sitecore.Analytics Namespace


Longitude Property

[image]

Sitecore 6.4.1 API
IP..::..Longitude Property
IP Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Longitude { get; set; }
Visual Basic
Public Property Longitude As String
    Get
    Set
Visual C++
public:
property String^ Longitude {
    String^ get ();
    void set (String^ value);
}

Field Value

The longitude.

See Also

IP Class
Sitecore.Analytics Namespace


PostalCode Property

[image]

Sitecore 6.4.1 API
IP..::..PostalCode Property
IP Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string PostalCode { get; set; }
Visual Basic
Public Property PostalCode As String
    Get
    Set
Visual C++
public:
property String^ PostalCode {
    String^ get ();
    void set (String^ value);
}

Field Value

The postal code.

See Also

IP Class
Sitecore.Analytics Namespace


Region Property

[image]

Sitecore 6.4.1 API
IP..::..Region Property
IP Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Region { get; set; }
Visual Basic
Public Property Region As String
    Get
    Set
Visual C++
public:
property String^ Region {
    String^ get ();
    void set (String^ value);
}

Field Value

The region.

See Also

IP Class
Sitecore.Analytics Namespace


VisitorIdentification Property

[image]

Sitecore 6.4.1 API
IP..::..VisitorIdentification Property
IP Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int VisitorIdentification { get; set; }
Visual Basic
Public Property VisitorIdentification As Integer
    Get
    Set
Visual C++
public:
property int VisitorIdentification {
    int get ();
    void set (int value);
}

Field Value

The visitor identification.

See Also

IP Class
Sitecore.Analytics Namespace


IPOwner Class

[image]

Sitecore 6.4.1 API
IPOwner Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class IPOwner
Visual Basic
Public Class IPOwner
Visual C++
public ref class IPOwner

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics..::..IPOwner

See Also

IPOwner Members
Sitecore.Analytics Namespace


IPOwner Members

[image] [image]

Sitecore 6.4.1 API
IPOwner Members
IPOwner Class Constructors Methods Properties See Also Send Feedback

The IPOwner type exposes the following members.

Constructors

 | Name | Description
Public method | IPOwner | Initializes a new instance of the IPOwner class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Country | Gets or sets the country.
Public property | ExternalUser | Gets or sets the external user.
Public property | IpOwnerId | Gets or sets the ip owner id.
Public property | Name | Gets or sets the name.
Public property | VisitorIdentification | Gets or sets the visitor identification.

See Also

IPOwner Class
Sitecore.Analytics Namespace


IPOwner Constructor

[image]

Sitecore 6.4.1 API
IPOwner Constructor
IPOwner Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public IPOwner()
Visual Basic
Public Sub New
Visual C++
public:
IPOwner()

See Also

IPOwner Class
Sitecore.Analytics Namespace


IPOwner Methods

[image] [image]

Sitecore 6.4.1 API
IPOwner Methods
IPOwner Class See Also Send Feedback

The IPOwner type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IPOwner Class
Sitecore.Analytics Namespace


IPOwner Properties

[image] [image]

Sitecore 6.4.1 API
IPOwner Properties
IPOwner Class See Also Send Feedback

The IPOwner type exposes the following members.

Properties

 | Name | Description
Public property | Country | Gets or sets the country.
Public property | ExternalUser | Gets or sets the external user.
Public property | IpOwnerId | Gets or sets the ip owner id.
Public property | Name | Gets or sets the name.
Public property | VisitorIdentification | Gets or sets the visitor identification.

See Also

IPOwner Class
Sitecore.Analytics Namespace


Country Property

[image]

Sitecore 6.4.1 API
IPOwner..::..Country Property
IPOwner Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Country { get; set; }
Visual Basic
Public Property Country As String
    Get
    Set
Visual C++
public:
property String^ Country {
    String^ get ();
    void set (String^ value);
}

Field Value

The country.

See Also

IPOwner Class
Sitecore.Analytics Namespace


ExternalUser Property

[image]

Sitecore 6.4.1 API
IPOwner..::..ExternalUser Property
IPOwner Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string ExternalUser { get; set; }
Visual Basic
Public Property ExternalUser As String
    Get
    Set
Visual C++
public:
property String^ ExternalUser {
    String^ get ();
    void set (String^ value);
}

Field Value

The external user.

See Also

IPOwner Class
Sitecore.Analytics Namespace


IpOwnerId Property

[image]

Sitecore 6.4.1 API
IPOwner..::..IpOwnerId Property
IPOwner Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid IpOwnerId { get; set; }
Visual Basic
Public Property IpOwnerId As Guid
    Get
    Set
Visual C++
public:
property Guid IpOwnerId {
    Guid get ();
    void set (Guid value);
}

Field Value

The ip owner id.

See Also

IPOwner Class
Sitecore.Analytics Namespace


Name Property

[image]

Sitecore 6.4.1 API
IPOwner..::..Name Property
IPOwner Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Field Value

The name.

See Also

IPOwner Class
Sitecore.Analytics Namespace


VisitorIdentification Property

[image]

Sitecore 6.4.1 API
IPOwner..::..VisitorIdentification Property
IPOwner Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int VisitorIdentification { get; set; }
Visual Basic
Public Property VisitorIdentification As Integer
    Get
    Set
Visual C++
public:
property int VisitorIdentification {
    int get ();
    void set (int value);
}

Field Value

The visitor identification.

See Also

IPOwner Class
Sitecore.Analytics Namespace


Keyword Class

[image]

Sitecore 6.4.1 API
Keyword Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class Keyword
Visual Basic
Public Class Keyword
Visual C++
public ref class Keyword

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics..::..Keyword

See Also

Keyword Members
Sitecore.Analytics Namespace


Keyword Members

[image] [image]

Sitecore 6.4.1 API
Keyword Members
Keyword Class Constructors Methods Properties See Also Send Feedback

The Keyword type exposes the following members.

Constructors

 | Name | Description
Public method | Keyword | Initializes a new instance of the Keyword class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | KeywordId | Gets or sets the keyword id.
Public property | Keywords | Gets or sets the keywords.

See Also

Keyword Class
Sitecore.Analytics Namespace


Keyword Constructor

[image]

Sitecore 6.4.1 API
Keyword Constructor
Keyword Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Keyword()
Visual Basic
Public Sub New
Visual C++
public:
Keyword()

See Also

Keyword Class
Sitecore.Analytics Namespace


Keyword Methods

[image] [image]

Sitecore 6.4.1 API
Keyword Methods
Keyword Class See Also Send Feedback

The Keyword type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Keyword Class
Sitecore.Analytics Namespace


Keyword Properties

[image] [image]

Sitecore 6.4.1 API
Keyword Properties
Keyword Class See Also Send Feedback

The Keyword type exposes the following members.

Properties

 | Name | Description
Public property | KeywordId | Gets or sets the keyword id.
Public property | Keywords | Gets or sets the keywords.

See Also

Keyword Class
Sitecore.Analytics Namespace


KeywordId Property

[image]

Sitecore 6.4.1 API
Keyword..::..KeywordId Property
Keyword Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid KeywordId { get; set; }
Visual Basic
Public Property KeywordId As Guid
    Get
    Set
Visual C++
public:
property Guid KeywordId {
    Guid get ();
    void set (Guid value);
}

Field Value

The keyword id.

See Also

Keyword Class
Sitecore.Analytics Namespace


Keywords Property

[image]

Sitecore 6.4.1 API
Keyword..::..Keywords Property
Keyword Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Keywords { get; set; }
Visual Basic
Public Property Keywords As String
    Get
    Set
Visual C++
public:
property String^ Keywords {
    String^ get ();
    void set (String^ value);
}

Field Value

The keywords.

See Also

Keyword Class
Sitecore.Analytics Namespace


MultiVarianceTestDefinition Class

[image]

Sitecore 6.4.1 API
MultiVarianceTestDefinition Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class MultiVarianceTestDefinition
Visual Basic
Public Class MultiVarianceTestDefinition
Visual C++
public ref class MultiVarianceTestDefinition

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics..::..MultiVarianceTestDefinition

See Also

MultiVarianceTestDefinition Members
Sitecore.Analytics Namespace


MultiVarianceTestDefinition Members

[image] [image]

Sitecore 6.4.1 API
MultiVarianceTestDefinition Members
MultiVarianceTestDefinition Class Constructors Methods Properties See Also Send Feedback

The MultiVarianceTestDefinition type exposes the following members.

Constructors

 | Name | Description
Public method | MultiVarianceTestDefinition | Initializes a new instance of the MultiVarianceTestDefinition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | Gets or sets the description.
Public property | MultiVarianceTestDefinitionId | Gets or sets the multi variance test definition id.
Public property | Title | Gets or sets the title.

See Also

MultiVarianceTestDefinition Class
Sitecore.Analytics Namespace


MultiVarianceTestDefinition Constructor

[image]

Sitecore 6.4.1 API
MultiVarianceTestDefinition Constructor
MultiVarianceTestDefinition Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public MultiVarianceTestDefinition()
Visual Basic
Public Sub New
Visual C++
public:
MultiVarianceTestDefinition()

See Also

MultiVarianceTestDefinition Class
Sitecore.Analytics Namespace


MultiVarianceTestDefinition Methods

[image] [image]

Sitecore 6.4.1 API
MultiVarianceTestDefinition Methods
MultiVarianceTestDefinition Class See Also Send Feedback

The MultiVarianceTestDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MultiVarianceTestDefinition Class
Sitecore.Analytics Namespace


MultiVarianceTestDefinition Properties

[image] [image]

Sitecore 6.4.1 API
MultiVarianceTestDefinition Properties
MultiVarianceTestDefinition Class See Also Send Feedback

The MultiVarianceTestDefinition type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets or sets the description.
Public property | MultiVarianceTestDefinitionId | Gets or sets the multi variance test definition id.
Public property | Title | Gets or sets the title.

See Also

MultiVarianceTestDefinition Class
Sitecore.Analytics Namespace


Description Property

[image]

Sitecore 6.4.1 API
MultiVarianceTestDefinition..::..Description Property
MultiVarianceTestDefinition Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Field Value

The description.

See Also

MultiVarianceTestDefinition Class
Sitecore.Analytics Namespace


MultiVarianceTestDefinitionId Property

[image]

Sitecore 6.4.1 API
MultiVarianceTestDefinition..::..MultiVarianceTestDefinitionId Property
MultiVarianceTestDefinition Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid MultiVarianceTestDefinitionId { get; set; }
Visual Basic
Public Property MultiVarianceTestDefinitionId As Guid
    Get
    Set
Visual C++
public:
property Guid MultiVarianceTestDefinitionId {
    Guid get ();
    void set (Guid value);
}

Field Value

The multi variance test definition id.

See Also

MultiVarianceTestDefinition Class
Sitecore.Analytics Namespace


MultiVarianceTestVariable Class

[image]

Sitecore 6.4.1 API
MultiVarianceTestVariable Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class MultiVarianceTestVariable
Visual Basic
Public Class MultiVarianceTestVariable
Visual C++
public ref class MultiVarianceTestVariable

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics..::..MultiVarianceTestVariable

See Also

MultiVarianceTestVariable Members
Sitecore.Analytics Namespace


MultiVarianceTestVariable Members

[image] [image]

Sitecore 6.4.1 API
MultiVarianceTestVariable Members
MultiVarianceTestVariable Class Constructors Methods Properties See Also Send Feedback

The MultiVarianceTestVariable type exposes the following members.

Constructors

 | Name | Description
Public method | MultiVarianceTestVariable | Initializes a new instance of the MultiVarianceTestVariable class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | MultiVarianceTestDefinitionId | Gets or sets the multi variance test definition id.
Public property | MultiVarianceTestVariableId | Gets or sets the multi variance test variable id.
Public property | Name | Gets or sets the name.

See Also

MultiVarianceTestVariable Class
Sitecore.Analytics Namespace


MultiVarianceTestVariable Constructor

[image]

Sitecore 6.4.1 API
MultiVarianceTestVariable Constructor
MultiVarianceTestVariable Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public MultiVarianceTestVariable()
Visual Basic
Public Sub New
Visual C++
public:
MultiVarianceTestVariable()

See Also

MultiVarianceTestVariable Class
Sitecore.Analytics Namespace


MultiVarianceTestVariable Methods

[image] [image]

Sitecore 6.4.1 API
MultiVarianceTestVariable Methods
MultiVarianceTestVariable Class See Also Send Feedback

The MultiVarianceTestVariable type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MultiVarianceTestVariable Class
Sitecore.Analytics Namespace


MultiVarianceTestVariable Properties

[image] [image]

Sitecore 6.4.1 API
MultiVarianceTestVariable Properties
MultiVarianceTestVariable Class See Also Send Feedback

The MultiVarianceTestVariable type exposes the following members.

Properties

 | Name | Description
Public property | MultiVarianceTestDefinitionId | Gets or sets the multi variance test definition id.
Public property | MultiVarianceTestVariableId | Gets or sets the multi variance test variable id.
Public property | Name | Gets or sets the name.

See Also

MultiVarianceTestVariable Class
Sitecore.Analytics Namespace


MultiVarianceTestDefinitionId Property

[image]

Sitecore 6.4.1 API
MultiVarianceTestVariable..::..MultiVarianceTestDefinitionId Property
MultiVarianceTestVariable Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid MultiVarianceTestDefinitionId { get; set; }
Visual Basic
Public Property MultiVarianceTestDefinitionId As Guid
    Get
    Set
Visual C++
public:
property Guid MultiVarianceTestDefinitionId {
    Guid get ();
    void set (Guid value);
}

Field Value

The multi variance test definition id.

See Also

MultiVarianceTestVariable Class
Sitecore.Analytics Namespace


MultiVarianceTestVariableId Property

[image]

Sitecore 6.4.1 API
MultiVarianceTestVariable..::..MultiVarianceTestVariableId Property
MultiVarianceTestVariable Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid MultiVarianceTestVariableId { get; set; }
Visual Basic
Public Property MultiVarianceTestVariableId As Guid
    Get
    Set
Visual C++
public:
property Guid MultiVarianceTestVariableId {
    Guid get ();
    void set (Guid value);
}

Field Value

The multi variance test variable id.

See Also

MultiVarianceTestVariable Class
Sitecore.Analytics Namespace


Name Property

[image]

Sitecore 6.4.1 API
MultiVarianceTestVariable..::..Name Property
MultiVarianceTestVariable Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Field Value

The name.

See Also

MultiVarianceTestVariable Class
Sitecore.Analytics Namespace


MultiVarianceTestVariableCampaignEvent Class

[image]

Sitecore 6.4.1 API
MultiVarianceTestVariableCampaignEvent Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class MultiVarianceTestVariableCampaignEvent
Visual Basic
Public Class MultiVarianceTestVariableCampaignEvent
Visual C++
public ref class MultiVarianceTestVariableCampaignEvent

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics..::..MultiVarianceTestVariableCampaignEvent

See Also

MultiVarianceTestVariableCampaignEvent Members
Sitecore.Analytics Namespace


MultiVarianceTestVariableCampaignEvent Members

[image] [image]

Sitecore 6.4.1 API
MultiVarianceTestVariableCampaignEvent Members
MultiVarianceTestVariableCampaignEvent Class Constructors Methods Properties See Also Send Feedback

The MultiVarianceTestVariableCampaignEvent type exposes the following members.

Constructors

 | Name | Description
Public method | MultiVarianceTestVariableCampaignEvent | Initializes a new instance of the MultiVarianceTestVariableCampaignEvent class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CampaignEventId | Gets or sets the campaign event id.
Public property | Data | Gets or sets the data.
Public property | MultiVarianceTestVariableCampaignEventId | Gets or sets the multi variance test variable campaign event id.
Public property | MultiVarianceTestVariableId | Gets or sets the multi variance test variable id.

See Also

MultiVarianceTestVariableCampaignEvent Class
Sitecore.Analytics Namespace


MultiVarianceTestVariableCampaignEvent Constructor

[image]

Sitecore 6.4.1 API
MultiVarianceTestVariableCampaignEvent Constructor
MultiVarianceTestVariableCampaignEvent Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public MultiVarianceTestVariableCampaignEvent()
Visual Basic
Public Sub New
Visual C++
public:
MultiVarianceTestVariableCampaignEvent()

See Also

MultiVarianceTestVariableCampaignEvent Class
Sitecore.Analytics Namespace


MultiVarianceTestVariableCampaignEvent Methods

[image] [image]

Sitecore 6.4.1 API
MultiVarianceTestVariableCampaignEvent Methods
MultiVarianceTestVariableCampaignEvent Class See Also Send Feedback

The MultiVarianceTestVariableCampaignEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MultiVarianceTestVariableCampaignEvent Class
Sitecore.Analytics Namespace


MultiVarianceTestVariableCampaignEvent Properties

[image] [image]

Sitecore 6.4.1 API
MultiVarianceTestVariableCampaignEvent Properties
MultiVarianceTestVariableCampaignEvent Class See Also Send Feedback

The MultiVarianceTestVariableCampaignEvent type exposes the following members.

Properties

 | Name | Description
Public property | CampaignEventId | Gets or sets the campaign event id.
Public property | Data | Gets or sets the data.
Public property | MultiVarianceTestVariableCampaignEventId | Gets or sets the multi variance test variable campaign event id.
Public property | MultiVarianceTestVariableId | Gets or sets the multi variance test variable id.

See Also

MultiVarianceTestVariableCampaignEvent Class
Sitecore.Analytics Namespace


CampaignEventId Property

[image]

Sitecore 6.4.1 API
MultiVarianceTestVariableCampaignEvent..::..CampaignEventId Property
MultiVarianceTestVariableCampaignEvent Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid CampaignEventId { get; set; }
Visual Basic
Public Property CampaignEventId As Guid
    Get
    Set
Visual C++
public:
property Guid CampaignEventId {
    Guid get ();
    void set (Guid value);
}

Field Value

The campaign event id.

See Also

MultiVarianceTestVariableCampaignEvent Class
Sitecore.Analytics Namespace


Data Property

[image]

Sitecore 6.4.1 API
MultiVarianceTestVariableCampaignEvent..::..Data Property
MultiVarianceTestVariableCampaignEvent Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Data { get; set; }
Visual Basic
Public Property Data As String
    Get
    Set
Visual C++
public:
property String^ Data {
    String^ get ();
    void set (String^ value);
}

Field Value

The data.

See Also

MultiVarianceTestVariableCampaignEvent Class
Sitecore.Analytics Namespace


MultiVarianceTestVariableCampaignEventId Property

[image]

Sitecore 6.4.1 API
MultiVarianceTestVariableCampaignEvent..::..MultiVarianceTestVariableCampaignEventId Property
MultiVarianceTestVariableCampaignEvent Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid MultiVarianceTestVariableCampaignEventId { get; set; }
Visual Basic
Public Property MultiVarianceTestVariableCampaignEventId As Guid
    Get
    Set
Visual C++
public:
property Guid MultiVarianceTestVariableCampaignEventId {
    Guid get ();
    void set (Guid value);
}

Field Value

The multi variance test variable campaign event id.

See Also

MultiVarianceTestVariableCampaignEvent Class
Sitecore.Analytics Namespace


MultiVarianceTestVariableId Property

[image]

Sitecore 6.4.1 API
MultiVarianceTestVariableCampaignEvent..::..MultiVarianceTestVariableId Property
MultiVarianceTestVariableCampaignEvent Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid MultiVarianceTestVariableId { get; set; }
Visual Basic
Public Property MultiVarianceTestVariableId As Guid
    Get
    Set
Visual C++
public:
property Guid MultiVarianceTestVariableId {
    Guid get ();
    void set (Guid value);
}

Field Value

The multi variance test variable id.

See Also

MultiVarianceTestVariableCampaignEvent Class
Sitecore.Analytics Namespace


MultiVarianceTestVariablePage Class

[image]

Sitecore 6.4.1 API
MultiVarianceTestVariablePage Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class MultiVarianceTestVariablePage
Visual Basic
Public Class MultiVarianceTestVariablePage
Visual C++
public ref class MultiVarianceTestVariablePage

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics..::..MultiVarianceTestVariablePage

See Also

MultiVarianceTestVariablePage Members
Sitecore.Analytics Namespace


MultiVarianceTestVariablePage Members

[image] [image]

Sitecore 6.4.1 API
MultiVarianceTestVariablePage Members
MultiVarianceTestVariablePage Class Constructors Methods Properties See Also Send Feedback

The MultiVarianceTestVariablePage type exposes the following members.

Constructors

 | Name | Description
Public method | MultiVarianceTestVariablePage | Initializes a new instance of the MultiVarianceTestVariablePage class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Data | Gets or sets the data.
Public property | MultiVarianceTestVariableId | Gets or sets the multi variance test variable id.
Public property | MultiVarianceTestVariablePageId | Gets or sets the multi variance test variable page id.
Public property | PageId | Gets or sets the page id.

See Also

MultiVarianceTestVariablePage Class
Sitecore.Analytics Namespace


MultiVarianceTestVariablePage Constructor

[image]

Sitecore 6.4.1 API
MultiVarianceTestVariablePage Constructor
MultiVarianceTestVariablePage Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public MultiVarianceTestVariablePage()
Visual Basic
Public Sub New
Visual C++
public:
MultiVarianceTestVariablePage()

See Also

MultiVarianceTestVariablePage Class
Sitecore.Analytics Namespace


MultiVarianceTestVariablePage Methods

[image] [image]

Sitecore 6.4.1 API
MultiVarianceTestVariablePage Methods
MultiVarianceTestVariablePage Class See Also Send Feedback

The MultiVarianceTestVariablePage type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MultiVarianceTestVariablePage Class
Sitecore.Analytics Namespace


MultiVarianceTestVariablePage Properties

[image] [image]

Sitecore 6.4.1 API
MultiVarianceTestVariablePage Properties
MultiVarianceTestVariablePage Class See Also Send Feedback

The MultiVarianceTestVariablePage type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets or sets the data.
Public property | MultiVarianceTestVariableId | Gets or sets the multi variance test variable id.
Public property | MultiVarianceTestVariablePageId | Gets or sets the multi variance test variable page id.
Public property | PageId | Gets or sets the page id.

See Also

MultiVarianceTestVariablePage Class
Sitecore.Analytics Namespace


Data Property

[image]

Sitecore 6.4.1 API
MultiVarianceTestVariablePage..::..Data Property
MultiVarianceTestVariablePage Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Data { get; set; }
Visual Basic
Public Property Data As String
    Get
    Set
Visual C++
public:
property String^ Data {
    String^ get ();
    void set (String^ value);
}

Field Value

The data.

See Also

MultiVarianceTestVariablePage Class
Sitecore.Analytics Namespace


MultiVarianceTestVariableId Property

[image]

Sitecore 6.4.1 API
MultiVarianceTestVariablePage..::..MultiVarianceTestVariableId Property
MultiVarianceTestVariablePage Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid MultiVarianceTestVariableId { get; set; }
Visual Basic
Public Property MultiVarianceTestVariableId As Guid
    Get
    Set
Visual C++
public:
property Guid MultiVarianceTestVariableId {
    Guid get ();
    void set (Guid value);
}

Field Value

The multi variance test variable id.

See Also

MultiVarianceTestVariablePage Class
Sitecore.Analytics Namespace


MultiVarianceTestVariablePageId Property

[image]

Sitecore 6.4.1 API
MultiVarianceTestVariablePage..::..MultiVarianceTestVariablePageId Property
MultiVarianceTestVariablePage Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid MultiVarianceTestVariablePageId { get; set; }
Visual Basic
Public Property MultiVarianceTestVariablePageId As Guid
    Get
    Set
Visual C++
public:
property Guid MultiVarianceTestVariablePageId {
    Guid get ();
    void set (Guid value);
}

Field Value

The multi variance test variable page id.

See Also

MultiVarianceTestVariablePage Class
Sitecore.Analytics Namespace


PageId Property

[image]

Sitecore 6.4.1 API
MultiVarianceTestVariablePage..::..PageId Property
MultiVarianceTestVariablePage Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid PageId { get; set; }
Visual Basic
Public Property PageId As Guid
    Get
    Set
Visual C++
public:
property Guid PageId {
    Guid get ();
    void set (Guid value);
}

Field Value

The page id.

See Also

MultiVarianceTestVariablePage Class
Sitecore.Analytics Namespace


OperatingSystem Class

[image]

Sitecore 6.4.1 API
OperatingSystem Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class OperatingSystem
Visual Basic
Public Class OperatingSystem
Visual C++
public ref class OperatingSystem

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics..::..OperatingSystem

See Also

OperatingSystem Members
Sitecore.Analytics Namespace


OperatingSystem Members

[image] [image]

Sitecore 6.4.1 API
OperatingSystem Members
OperatingSystem Class Constructors Methods Properties See Also Send Feedback

The OperatingSystem type exposes the following members.

Constructors

 | Name | Description
Public method | OperatingSystem | Initializes a new instance of the OperatingSystem class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | Gets or sets the description.
Public property | MajorName | Gets or sets the name of the major.
Public property | MinorName | Gets or sets the name of the minor.
Public property | OperatingSystem1 | Gets or sets the operating system1.
Public property | OperatingSystemId | Gets or sets the operating system id.
Public property | Version | Gets or sets the version.

See Also

OperatingSystem Class
Sitecore.Analytics Namespace


OperatingSystem Methods

[image] [image]

Sitecore 6.4.1 API
OperatingSystem Methods
OperatingSystem Class See Also Send Feedback

The OperatingSystem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OperatingSystem Class
Sitecore.Analytics Namespace


OperatingSystem Properties

[image] [image]

Sitecore 6.4.1 API
OperatingSystem Properties
OperatingSystem Class See Also Send Feedback

The OperatingSystem type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets or sets the description.
Public property | MajorName | Gets or sets the name of the major.
Public property | MinorName | Gets or sets the name of the minor.
Public property | OperatingSystem1 | Gets or sets the operating system1.
Public property | OperatingSystemId | Gets or sets the operating system id.
Public property | Version | Gets or sets the version.

See Also

OperatingSystem Class
Sitecore.Analytics Namespace


Description Property

[image]

Sitecore 6.4.1 API
OperatingSystem..::..Description Property
OperatingSystem Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Field Value

The description.

See Also

OperatingSystem Class
Sitecore.Analytics Namespace


MajorName Property

[image]

Sitecore 6.4.1 API
OperatingSystem..::..MajorName Property
OperatingSystem Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string MajorName { get; set; }
Visual Basic
Public Property MajorName As String
    Get
    Set
Visual C++
public:
property String^ MajorName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the major.

See Also

OperatingSystem Class
Sitecore.Analytics Namespace


MinorName Property

[image]

Sitecore 6.4.1 API
OperatingSystem..::..MinorName Property
OperatingSystem Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string MinorName { get; set; }
Visual Basic
Public Property MinorName As String
    Get
    Set
Visual C++
public:
property String^ MinorName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the minor.

See Also

OperatingSystem Class
Sitecore.Analytics Namespace


OperatingSystem1 Property

[image]

Sitecore 6.4.1 API
OperatingSystem..::..OperatingSystem1 Property
OperatingSystem Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string OperatingSystem1 { get; set; }
Visual Basic
Public Property OperatingSystem1 As String
    Get
    Set
Visual C++
public:
property String^ OperatingSystem1 {
    String^ get ();
    void set (String^ value);
}

Field Value

The operating system1.

See Also

OperatingSystem Class
Sitecore.Analytics Namespace


OperatingSystemId Property

[image]

Sitecore 6.4.1 API
OperatingSystem..::..OperatingSystemId Property
OperatingSystem Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid OperatingSystemId { get; set; }
Visual Basic
Public Property OperatingSystemId As Guid
    Get
    Set
Visual C++
public:
property Guid OperatingSystemId {
    Guid get ();
    void set (Guid value);
}

Field Value

The operating system id.

See Also

OperatingSystem Class
Sitecore.Analytics Namespace


Version Property

[image]

Sitecore 6.4.1 API
OperatingSystem..::..Version Property
OperatingSystem Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Version { get; set; }
Visual Basic
Public Property Version As String
    Get
    Set
Visual C++
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}

Field Value

The version.

See Also

OperatingSystem Class
Sitecore.Analytics Namespace


Page Class

[image]

Sitecore 6.4.1 API
Page Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class Page
Visual Basic
Public Class Page
Visual C++
public ref class Page

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics..::..Page

See Also

Page Members
Sitecore.Analytics Namespace


Page Members

[image] [image]

Sitecore 6.4.1 API
Page Members
Page Class Constructors Methods Properties See Also Send Feedback

The Page type exposes the following members.

Constructors

 | Name | Description
Public method | Page | Initializes a new instance of the Page class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Data | Gets or sets the data.
Public property | DeviceId | Gets or sets the device id.
Public property | Duration | Gets or sets the duration.
Public property | IndexableUrl | Gets or sets the indexable URL.
Public property | ItemId | Gets or sets the item id.
Public property | ItemLanguage | Gets or sets the item language.
Public property | ItemVersion | Gets or sets the item version.
Public property | Navigation | Gets or sets the navigation.
Public property | PageId | Gets or sets the page id.
Public property | PageNo | Gets or sets the page no.
Public property | SessionId | Gets or sets the session id.
Public property | Timestamp | Gets or sets the timestamp.
Public property | Url | Gets or sets the URL.

See Also

Page Class
Sitecore.Analytics Namespace


Page Constructor

[image]

Sitecore 6.4.1 API
Page Constructor
Page Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Page()
Visual Basic
Public Sub New
Visual C++
public:
Page()

See Also

Page Class
Sitecore.Analytics Namespace


Page Methods

[image] [image]

Sitecore 6.4.1 API
Page Methods
Page Class See Also Send Feedback

The Page type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Page Class
Sitecore.Analytics Namespace


Page Properties

[image] [image]

Sitecore 6.4.1 API
Page Properties
Page Class See Also Send Feedback

The Page type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets or sets the data.
Public property | DeviceId | Gets or sets the device id.
Public property | Duration | Gets or sets the duration.
Public property | IndexableUrl | Gets or sets the indexable URL.
Public property | ItemId | Gets or sets the item id.
Public property | ItemLanguage | Gets or sets the item language.
Public property | ItemVersion | Gets or sets the item version.
Public property | Navigation | Gets or sets the navigation.
Public property | PageId | Gets or sets the page id.
Public property | PageNo | Gets or sets the page no.
Public property | SessionId | Gets or sets the session id.
Public property | Timestamp | Gets or sets the timestamp.
Public property | Url | Gets or sets the URL.

See Also

Page Class
Sitecore.Analytics Namespace


Data Property

[image]

Sitecore 6.4.1 API
Page..::..Data Property
Page Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Data { get; set; }
Visual Basic
Public Property Data As String
    Get
    Set
Visual C++
public:
property String^ Data {
    String^ get ();
    void set (String^ value);
}

Field Value

The data.

See Also

Page Class
Sitecore.Analytics Namespace


DeviceId Property

[image]

Sitecore 6.4.1 API
Page..::..DeviceId Property
Page Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid DeviceId { get; set; }
Visual Basic
Public Property DeviceId As Guid
    Get
    Set
Visual C++
public:
property Guid DeviceId {
    Guid get ();
    void set (Guid value);
}

Field Value

The device id.

See Also

Page Class
Sitecore.Analytics Namespace


Duration Property

[image]

Sitecore 6.4.1 API
Page..::..Duration Property
Page Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int Duration { get; set; }
Visual Basic
Public Property Duration As Integer
    Get
    Set
Visual C++
public:
property int Duration {
    int get ();
    void set (int value);
}

Field Value

The duration.

See Also

Page Class
Sitecore.Analytics Namespace


IndexableUrl Property

[image]

Sitecore 6.4.1 API
Page..::..IndexableUrl Property
Page Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string IndexableUrl { get; set; }
Visual Basic
Public Property IndexableUrl As String
    Get
    Set
Visual C++
public:
property String^ IndexableUrl {
    String^ get ();
    void set (String^ value);
}

Field Value

The indexable URL.

See Also

Page Class
Sitecore.Analytics Namespace


ItemId Property

[image]

Sitecore 6.4.1 API
Page..::..ItemId Property
Page Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid ItemId { get; set; }
Visual Basic
Public Property ItemId As Guid
    Get
    Set
Visual C++
public:
property Guid ItemId {
    Guid get ();
    void set (Guid value);
}

Field Value

The item id.

See Also

Page Class
Sitecore.Analytics Namespace


ItemLanguage Property

[image]

Sitecore 6.4.1 API
Page..::..ItemLanguage Property
Page Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string ItemLanguage { get; set; }
Visual Basic
Public Property ItemLanguage As String
    Get
    Set
Visual C++
public:
property String^ ItemLanguage {
    String^ get ();
    void set (String^ value);
}

Field Value

The item language.

See Also

Page Class
Sitecore.Analytics Namespace


ItemVersion Property

[image]

Sitecore 6.4.1 API
Page..::..ItemVersion Property
Page Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int ItemVersion { get; set; }
Visual Basic
Public Property ItemVersion As Integer
    Get
    Set
Visual C++
public:
property int ItemVersion {
    int get ();
    void set (int value);
}

Field Value

The item version.

See Also

Page Class
Sitecore.Analytics Namespace


Navigation Property

[image]

Sitecore 6.4.1 API
Page..::..Navigation Property
Page Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Navigation { get; set; }
Visual Basic
Public Property Navigation As String
    Get
    Set
Visual C++
public:
property String^ Navigation {
    String^ get ();
    void set (String^ value);
}

Field Value

The navigation.

See Also

Page Class
Sitecore.Analytics Namespace


PageNo Property

[image]

Sitecore 6.4.1 API
Page..::..PageNo Property
Page Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int PageNo { get; set; }
Visual Basic
Public Property PageNo As Integer
    Get
    Set
Visual C++
public:
property int PageNo {
    int get ();
    void set (int value);
}

Field Value

The page no.

See Also

Page Class
Sitecore.Analytics Namespace


SessionId Property

[image]

Sitecore 6.4.1 API
Page..::..SessionId Property
Page Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid SessionId { get; set; }
Visual Basic
Public Property SessionId As Guid
    Get
    Set
Visual C++
public:
property Guid SessionId {
    Guid get ();
    void set (Guid value);
}

Field Value

The session id.

See Also

Page Class
Sitecore.Analytics Namespace


Timestamp Property

[image]

Sitecore 6.4.1 API
Page..::..Timestamp Property
Page Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public DateTime Timestamp { get; set; }
Visual Basic
Public Property Timestamp As DateTime
    Get
    Set
Visual C++
public:
property DateTime Timestamp {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The timestamp.

See Also

Page Class
Sitecore.Analytics Namespace


Url Property

[image]

Sitecore 6.4.1 API
Page..::..Url Property
Page Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Url { get; set; }
Visual Basic
Public Property Url As String
    Get
    Set
Visual C++
public:
property String^ Url {
    String^ get ();
    void set (String^ value);
}

Field Value

The URL.

See Also

Page Class
Sitecore.Analytics Namespace


PageEvent Class

[image]

Sitecore 6.4.1 API
PageEvent Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class PageEvent
Visual Basic
Public Class PageEvent
Visual C++
public ref class PageEvent

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics..::..PageEvent

See Also

PageEvent Members
Sitecore.Analytics Namespace


PageEvent Members

[image] [image]

Sitecore 6.4.1 API
PageEvent Members
PageEvent Class Constructors Methods Properties See Also Send Feedback

The PageEvent type exposes the following members.

Constructors

 | Name | Description
Public method | PageEvent | Initializes a new instance of the PageEvent class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CustomSorting | Gets or sets the custom sorting.
Public property | Data | Gets or sets the data.
Public property | DataKey | Gets or sets the data key.
Public property | Integer | Gets or sets the integer.
Public property | ItemId | Gets or sets the item id.
Public property | ItemLanguage | Gets or sets the item language.
Public property | ItemVersion | Gets or sets the item version.
Public property | PageEventDefinitionId | Gets or sets the page event definition id.
Public property | PageEventId | Gets or sets the page event id.
Public property | PageId | Gets or sets the page id.
Public property | Text | Gets or sets the text.
Public property | Timestamp | Gets or sets the timestamp.

See Also

PageEvent Class
Sitecore.Analytics Namespace


PageEvent Constructor

[image]

Sitecore 6.4.1 API
PageEvent Constructor
PageEvent Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public PageEvent()
Visual Basic
Public Sub New
Visual C++
public:
PageEvent()

See Also

PageEvent Class
Sitecore.Analytics Namespace


PageEvent Methods

[image] [image]

Sitecore 6.4.1 API
PageEvent Methods
PageEvent Class See Also Send Feedback

The PageEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PageEvent Class
Sitecore.Analytics Namespace


PageEvent Properties

[image] [image]

Sitecore 6.4.1 API
PageEvent Properties
PageEvent Class See Also Send Feedback

The PageEvent type exposes the following members.

Properties

 | Name | Description
Public property | CustomSorting | Gets or sets the custom sorting.
Public property | Data | Gets or sets the data.
Public property | DataKey | Gets or sets the data key.
Public property | Integer | Gets or sets the integer.
Public property | ItemId | Gets or sets the item id.
Public property | ItemLanguage | Gets or sets the item language.
Public property | ItemVersion | Gets or sets the item version.
Public property | PageEventDefinitionId | Gets or sets the page event definition id.
Public property | PageEventId | Gets or sets the page event id.
Public property | PageId | Gets or sets the page id.
Public property | Text | Gets or sets the text.
Public property | Timestamp | Gets or sets the timestamp.

See Also

PageEvent Class
Sitecore.Analytics Namespace


CustomSorting Property

[image]

Sitecore 6.4.1 API
PageEvent..::..CustomSorting Property
PageEvent Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int CustomSorting { get; set; }
Visual Basic
Public Property CustomSorting As Integer
    Get
    Set
Visual C++
public:
property int CustomSorting {
    int get ();
    void set (int value);
}

Field Value

The custom sorting.

See Also

PageEvent Class
Sitecore.Analytics Namespace


Data Property

[image]

Sitecore 6.4.1 API
PageEvent..::..Data Property
PageEvent Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Data { get; set; }
Visual Basic
Public Property Data As String
    Get
    Set
Visual C++
public:
property String^ Data {
    String^ get ();
    void set (String^ value);
}

Field Value

The data.

See Also

PageEvent Class
Sitecore.Analytics Namespace


DataKey Property

[image]

Sitecore 6.4.1 API
PageEvent..::..DataKey Property
PageEvent Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string DataKey { get; set; }
Visual Basic
Public Property DataKey As String
    Get
    Set
Visual C++
public:
property String^ DataKey {
    String^ get ();
    void set (String^ value);
}

Field Value

The data key.

See Also

PageEvent Class
Sitecore.Analytics Namespace


Integer Property

[image]

Sitecore 6.4.1 API
PageEvent..::..Integer Property
PageEvent Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int Integer { get; set; }
Visual Basic
Public Property Integer As Integer
    Get
    Set
Visual C++
public:
property int Integer {
    int get ();
    void set (int value);
}

Field Value

The integer.

See Also

PageEvent Class
Sitecore.Analytics Namespace


ItemId Property

[image]

Sitecore 6.4.1 API
PageEvent..::..ItemId Property
PageEvent Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid ItemId { get; set; }
Visual Basic
Public Property ItemId As Guid
    Get
    Set
Visual C++
public:
property Guid ItemId {
    Guid get ();
    void set (Guid value);
}

Field Value

The item id.

See Also

PageEvent Class
Sitecore.Analytics Namespace


ItemLanguage Property

[image]

Sitecore 6.4.1 API
PageEvent..::..ItemLanguage Property
PageEvent Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string ItemLanguage { get; set; }
Visual Basic
Public Property ItemLanguage As String
    Get
    Set
Visual C++
public:
property String^ ItemLanguage {
    String^ get ();
    void set (String^ value);
}

Field Value

The item language.

See Also

PageEvent Class
Sitecore.Analytics Namespace


ItemVersion Property

[image]

Sitecore 6.4.1 API
PageEvent..::..ItemVersion Property
PageEvent Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int ItemVersion { get; set; }
Visual Basic
Public Property ItemVersion As Integer
    Get
    Set
Visual C++
public:
property int ItemVersion {
    int get ();
    void set (int value);
}

Field Value

The item version.

See Also

PageEvent Class
Sitecore.Analytics Namespace


PageEventDefinitionId Property

[image]

Sitecore 6.4.1 API
PageEvent..::..PageEventDefinitionId Property
PageEvent Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid PageEventDefinitionId { get; set; }
Visual Basic
Public Property PageEventDefinitionId As Guid
    Get
    Set
Visual C++
public:
property Guid PageEventDefinitionId {
    Guid get ();
    void set (Guid value);
}

Field Value

The page event definition id.

See Also

PageEvent Class
Sitecore.Analytics Namespace


PageEventId Property

[image]

Sitecore 6.4.1 API
PageEvent..::..PageEventId Property
PageEvent Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid PageEventId { get; set; }
Visual Basic
Public Property PageEventId As Guid
    Get
    Set
Visual C++
public:
property Guid PageEventId {
    Guid get ();
    void set (Guid value);
}

Field Value

The page event id.

See Also

PageEvent Class
Sitecore.Analytics Namespace


PageId Property

[image]

Sitecore 6.4.1 API
PageEvent..::..PageId Property
PageEvent Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid PageId { get; set; }
Visual Basic
Public Property PageId As Guid
    Get
    Set
Visual C++
public:
property Guid PageId {
    Guid get ();
    void set (Guid value);
}

Field Value

The page id.

See Also

PageEvent Class
Sitecore.Analytics Namespace


Text Property

[image]

Sitecore 6.4.1 API
PageEvent..::..Text Property
PageEvent Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Field Value

The text.

See Also

PageEvent Class
Sitecore.Analytics Namespace


Timestamp Property

[image]

Sitecore 6.4.1 API
PageEvent..::..Timestamp Property
PageEvent Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public long Timestamp { get; set; }
Visual Basic
Public Property Timestamp As Long
    Get
    Set
Visual C++
public:
property long long Timestamp {
    long long get ();
    void set (long long value);
}

Field Value

The timestamp.

See Also

PageEvent Class
Sitecore.Analytics Namespace


PageEventDefinition Class

[image]

Sitecore 6.4.1 API
PageEventDefinition Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class PageEventDefinition
Visual Basic
Public Class PageEventDefinition
Visual C++
public ref class PageEventDefinition

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics..::..PageEventDefinition

See Also

PageEventDefinition Members
Sitecore.Analytics Namespace


PageEventDefinition Members

[image] [image]

Sitecore 6.4.1 API
PageEventDefinition Members
PageEventDefinition Class Constructors Methods Properties See Also Send Feedback

The PageEventDefinition type exposes the following members.

Constructors

 | Name | Description
Public method | PageEventDefinition | Initializes a new instance of the PageEventDefinition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | Gets or sets the description.
Public property | Icon | Gets or sets the icon.
Public property | IsAuthorFeedback | Gets or sets the is author feedback.
Public property | IsFailure | Gets or sets the is failure.
Public property | IsGoal | Gets or sets the is goal.
Public property | IsSystem | Gets or sets the is system.
Public property | Name | Gets or sets the name.
Public property | PageEventDefinitionId | Gets or sets the page event definition id.

See Also

PageEventDefinition Class
Sitecore.Analytics Namespace


PageEventDefinition Constructor

[image]

Sitecore 6.4.1 API
PageEventDefinition Constructor
PageEventDefinition Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public PageEventDefinition()
Visual Basic
Public Sub New
Visual C++
public:
PageEventDefinition()

See Also

PageEventDefinition Class
Sitecore.Analytics Namespace


PageEventDefinition Methods

[image] [image]

Sitecore 6.4.1 API
PageEventDefinition Methods
PageEventDefinition Class See Also Send Feedback

The PageEventDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PageEventDefinition Class
Sitecore.Analytics Namespace


Description Property

[image]

Sitecore 6.4.1 API
PageEventDefinition..::..Description Property
PageEventDefinition Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Field Value

The description.

See Also

PageEventDefinition Class
Sitecore.Analytics Namespace


Icon Property

[image]

Sitecore 6.4.1 API
PageEventDefinition..::..Icon Property
PageEventDefinition Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Icon { get; set; }
Visual Basic
Public Property Icon As String
    Get
    Set
Visual C++
public:
property String^ Icon {
    String^ get ();
    void set (String^ value);
}

Field Value

The icon.

See Also

PageEventDefinition Class
Sitecore.Analytics Namespace


IsAuthorFeedback Property

[image]

Sitecore 6.4.1 API
PageEventDefinition..::..IsAuthorFeedback Property
PageEventDefinition Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int IsAuthorFeedback { get; set; }
Visual Basic
Public Property IsAuthorFeedback As Integer
    Get
    Set
Visual C++
public:
property int IsAuthorFeedback {
    int get ();
    void set (int value);
}

Field Value

The is author feedback.

See Also

PageEventDefinition Class
Sitecore.Analytics Namespace


IsGoal Property

[image]

Sitecore 6.4.1 API
PageEventDefinition..::..IsGoal Property
PageEventDefinition Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int IsGoal { get; set; }
Visual Basic
Public Property IsGoal As Integer
    Get
    Set
Visual C++
public:
property int IsGoal {
    int get ();
    void set (int value);
}

Field Value

The is goal.

See Also

PageEventDefinition Class
Sitecore.Analytics Namespace


IsSystem Property

[image]

Sitecore 6.4.1 API
PageEventDefinition..::..IsSystem Property
PageEventDefinition Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int IsSystem { get; set; }
Visual Basic
Public Property IsSystem As Integer
    Get
    Set
Visual C++
public:
property int IsSystem {
    int get ();
    void set (int value);
}

Field Value

The is system.

See Also

PageEventDefinition Class
Sitecore.Analytics Namespace


PageEventDefinitionId Property

[image]

Sitecore 6.4.1 API
PageEventDefinition..::..PageEventDefinitionId Property
PageEventDefinition Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid PageEventDefinitionId { get; set; }
Visual Basic
Public Property PageEventDefinitionId As Guid
    Get
    Set
Visual C++
public:
property Guid PageEventDefinitionId {
    Guid get ();
    void set (Guid value);
}

Field Value

The page event definition id.

See Also

PageEventDefinition Class
Sitecore.Analytics Namespace


Profile Class

[image]

Sitecore 6.4.1 API
Profile Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class Profile
Visual Basic
Public Class Profile
Visual C++
public ref class Profile

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics..::..Profile

See Also

Profile Members
Sitecore.Analytics Namespace


Profile Constructor

[image]

Sitecore 6.4.1 API
Profile Constructor
Profile Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Profile()
Visual Basic
Public Sub New
Visual C++
public:
Profile()

See Also

Profile Class
Sitecore.Analytics Namespace


Profile Methods

[image] [image]

Sitecore 6.4.1 API
Profile Methods
Profile Class See Also Send Feedback

The Profile type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Profile Class
Sitecore.Analytics Namespace


Profile Properties

[image] [image]

Sitecore 6.4.1 API
Profile Properties
Profile Class See Also Send Feedback

The Profile type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets or sets the count.
Public property | ProfileDefinitionId | Gets or sets the profile definition id.
Public property | ProfileId | Gets or sets the profile id.
Public property | SessionId | Gets or sets the session id.
Public property | Total | Gets or sets the total.

See Also

Profile Class
Sitecore.Analytics Namespace


Count Property

[image]

Sitecore 6.4.1 API
Profile..::..Count Property
Profile Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int Count { get; set; }
Visual Basic
Public Property Count As Integer
    Get
    Set
Visual C++
public:
property int Count {
    int get ();
    void set (int value);
}

Field Value

The count.

See Also

Profile Class
Sitecore.Analytics Namespace


ProfileDefinitionId Property

[image]

Sitecore 6.4.1 API
Profile..::..ProfileDefinitionId Property
Profile Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid ProfileDefinitionId { get; set; }
Visual Basic
Public Property ProfileDefinitionId As Guid
    Get
    Set
Visual C++
public:
property Guid ProfileDefinitionId {
    Guid get ();
    void set (Guid value);
}

Field Value

The profile definition id.

See Also

Profile Class
Sitecore.Analytics Namespace


ProfileId Property

[image]

Sitecore 6.4.1 API
Profile..::..ProfileId Property
Profile Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid ProfileId { get; set; }
Visual Basic
Public Property ProfileId As Guid
    Get
    Set
Visual C++
public:
property Guid ProfileId {
    Guid get ();
    void set (Guid value);
}

Field Value

The profile id.

See Also

Profile Class
Sitecore.Analytics Namespace


SessionId Property

[image]

Sitecore 6.4.1 API
Profile..::..SessionId Property
Profile Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid SessionId { get; set; }
Visual Basic
Public Property SessionId As Guid
    Get
    Set
Visual C++
public:
property Guid SessionId {
    Guid get ();
    void set (Guid value);
}

Field Value

The session id.

See Also

Profile Class
Sitecore.Analytics Namespace


Total Property

[image]

Sitecore 6.4.1 API
Profile..::..Total Property
Profile Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int Total { get; set; }
Visual Basic
Public Property Total As Integer
    Get
    Set
Visual C++
public:
property int Total {
    int get ();
    void set (int value);
}

Field Value

The total.

See Also

Profile Class
Sitecore.Analytics Namespace


ProfileDefinition Class

[image]

Sitecore 6.4.1 API
ProfileDefinition Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class ProfileDefinition
Visual Basic
Public Class ProfileDefinition
Visual C++
public ref class ProfileDefinition

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics..::..ProfileDefinition

See Also

ProfileDefinition Members
Sitecore.Analytics Namespace


ProfileDefinition Constructor

[image]

Sitecore 6.4.1 API
ProfileDefinition Constructor
ProfileDefinition Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public ProfileDefinition()
Visual Basic
Public Sub New
Visual C++
public:
ProfileDefinition()

See Also

ProfileDefinition Class
Sitecore.Analytics Namespace


ProfileDefinition Methods

[image] [image]

Sitecore 6.4.1 API
ProfileDefinition Methods
ProfileDefinition Class See Also Send Feedback

The ProfileDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProfileDefinition Class
Sitecore.Analytics Namespace


ProfileDefinition Properties

[image] [image]

Sitecore 6.4.1 API
ProfileDefinition Properties
ProfileDefinition Class See Also Send Feedback

The ProfileDefinition type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets or sets the name.
Public property | ProfileDefinitionId | Gets or sets the profile definition id.
Public property | ProfileType | Gets or sets the type of the profile.

See Also

ProfileDefinition Class
Sitecore.Analytics Namespace


Name Property

[image]

Sitecore 6.4.1 API
ProfileDefinition..::..Name Property
ProfileDefinition Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Field Value

The name.

See Also

ProfileDefinition Class
Sitecore.Analytics Namespace


ProfileType Property

[image]

Sitecore 6.4.1 API
ProfileDefinition..::..ProfileType Property
ProfileDefinition Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string ProfileType { get; set; }
Visual Basic
Public Property ProfileType As String
    Get
    Set
Visual C++
public:
property String^ ProfileType {
    String^ get ();
    void set (String^ value);
}

Field Value

The type of the profile.

See Also

ProfileDefinition Class
Sitecore.Analytics Namespace


ProfileKey Class

[image]

Sitecore 6.4.1 API
ProfileKey Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class ProfileKey
Visual Basic
Public Class ProfileKey
Visual C++
public ref class ProfileKey

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics..::..ProfileKey

See Also

ProfileKey Members
Sitecore.Analytics Namespace


ProfileKey Members

[image] [image]

Sitecore 6.4.1 API
ProfileKey Members
ProfileKey Class Constructors Methods Properties See Also Send Feedback

The ProfileKey type exposes the following members.

Constructors

 | Name | Description
Public method | ProfileKey | Initializes a new instance of the ProfileKey class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ProfileId | Gets or sets the profile id.
Public property | ProfileKeyDefinitionId | Gets or sets the profile key definition id.
Public property | ProfileKeyId | Gets or sets the profile key id.
Public property | Value | Gets or sets the value.

See Also

ProfileKey Class
Sitecore.Analytics Namespace


ProfileKey Constructor

[image]

Sitecore 6.4.1 API
ProfileKey Constructor
ProfileKey Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public ProfileKey()
Visual Basic
Public Sub New
Visual C++
public:
ProfileKey()

See Also

ProfileKey Class
Sitecore.Analytics Namespace


ProfileKey Methods

[image] [image]

Sitecore 6.4.1 API
ProfileKey Methods
ProfileKey Class See Also Send Feedback

The ProfileKey type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProfileKey Class
Sitecore.Analytics Namespace


ProfileKey Properties

[image] [image]

Sitecore 6.4.1 API
ProfileKey Properties
ProfileKey Class See Also Send Feedback

The ProfileKey type exposes the following members.

Properties

 | Name | Description
Public property | ProfileId | Gets or sets the profile id.
Public property | ProfileKeyDefinitionId | Gets or sets the profile key definition id.
Public property | ProfileKeyId | Gets or sets the profile key id.
Public property | Value | Gets or sets the value.

See Also

ProfileKey Class
Sitecore.Analytics Namespace


ProfileId Property

[image]

Sitecore 6.4.1 API
ProfileKey..::..ProfileId Property
ProfileKey Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid ProfileId { get; set; }
Visual Basic
Public Property ProfileId As Guid
    Get
    Set
Visual C++
public:
property Guid ProfileId {
    Guid get ();
    void set (Guid value);
}

Field Value

The profile id.

See Also

ProfileKey Class
Sitecore.Analytics Namespace


ProfileKeyDefinitionId Property

[image]

Sitecore 6.4.1 API
ProfileKey..::..ProfileKeyDefinitionId Property
ProfileKey Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid ProfileKeyDefinitionId { get; set; }
Visual Basic
Public Property ProfileKeyDefinitionId As Guid
    Get
    Set
Visual C++
public:
property Guid ProfileKeyDefinitionId {
    Guid get ();
    void set (Guid value);
}

Field Value

The profile key definition id.

See Also

ProfileKey Class
Sitecore.Analytics Namespace


ProfileKeyId Property

[image]

Sitecore 6.4.1 API
ProfileKey..::..ProfileKeyId Property
ProfileKey Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid ProfileKeyId { get; set; }
Visual Basic
Public Property ProfileKeyId As Guid
    Get
    Set
Visual C++
public:
property Guid ProfileKeyId {
    Guid get ();
    void set (Guid value);
}

Field Value

The profile key id.

See Also

ProfileKey Class
Sitecore.Analytics Namespace


ProfileKeyDefinition Class

[image]

Sitecore 6.4.1 API
ProfileKeyDefinition Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class ProfileKeyDefinition
Visual Basic
Public Class ProfileKeyDefinition
Visual C++
public ref class ProfileKeyDefinition

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics..::..ProfileKeyDefinition

See Also

ProfileKeyDefinition Members
Sitecore.Analytics Namespace


ProfileKeyDefinition Members

[image] [image]

Sitecore 6.4.1 API
ProfileKeyDefinition Members
ProfileKeyDefinition Class Constructors Methods Properties See Also Send Feedback

The ProfileKeyDefinition type exposes the following members.

Constructors

 | Name | Description
Public method | ProfileKeyDefinition | Initializes a new instance of the ProfileKeyDefinition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Control | Gets or sets the control.
Public property | MaxValue | Gets or sets the max value.
Public property | MinValue | Gets or sets the min value.
Public property | Name | Gets or sets the name.
Public property | ProfileDefinitionId | Gets or sets the profile definition id.
Public property | ProfileKeyDefinitionId | Gets or sets the profile key definition id.

See Also

ProfileKeyDefinition Class
Sitecore.Analytics Namespace


ProfileKeyDefinition Constructor

[image]

Sitecore 6.4.1 API
ProfileKeyDefinition Constructor
ProfileKeyDefinition Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public ProfileKeyDefinition()
Visual Basic
Public Sub New
Visual C++
public:
ProfileKeyDefinition()

See Also

ProfileKeyDefinition Class
Sitecore.Analytics Namespace


ProfileKeyDefinition Methods

[image] [image]

Sitecore 6.4.1 API
ProfileKeyDefinition Methods
ProfileKeyDefinition Class See Also Send Feedback

The ProfileKeyDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProfileKeyDefinition Class
Sitecore.Analytics Namespace


ProfileKeyDefinition Properties

[image] [image]

Sitecore 6.4.1 API
ProfileKeyDefinition Properties
ProfileKeyDefinition Class See Also Send Feedback

The ProfileKeyDefinition type exposes the following members.

Properties

 | Name | Description
Public property | Control | Gets or sets the control.
Public property | MaxValue | Gets or sets the max value.
Public property | MinValue | Gets or sets the min value.
Public property | Name | Gets or sets the name.
Public property | ProfileDefinitionId | Gets or sets the profile definition id.
Public property | ProfileKeyDefinitionId | Gets or sets the profile key definition id.

See Also

ProfileKeyDefinition Class
Sitecore.Analytics Namespace


Control Property

[image]

Sitecore 6.4.1 API
ProfileKeyDefinition..::..Control Property
ProfileKeyDefinition Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Control { get; set; }
Visual Basic
Public Property Control As String
    Get
    Set
Visual C++
public:
property String^ Control {
    String^ get ();
    void set (String^ value);
}

Field Value

The control.

See Also

ProfileKeyDefinition Class
Sitecore.Analytics Namespace


MaxValue Property

[image]

Sitecore 6.4.1 API
ProfileKeyDefinition..::..MaxValue Property
ProfileKeyDefinition Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int MaxValue { get; set; }
Visual Basic
Public Property MaxValue As Integer
    Get
    Set
Visual C++
public:
property int MaxValue {
    int get ();
    void set (int value);
}

Field Value

The max value.

See Also

ProfileKeyDefinition Class
Sitecore.Analytics Namespace


MinValue Property

[image]

Sitecore 6.4.1 API
ProfileKeyDefinition..::..MinValue Property
ProfileKeyDefinition Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int MinValue { get; set; }
Visual Basic
Public Property MinValue As Integer
    Get
    Set
Visual C++
public:
property int MinValue {
    int get ();
    void set (int value);
}

Field Value

The min value.

See Also

ProfileKeyDefinition Class
Sitecore.Analytics Namespace


Name Property

[image]

Sitecore 6.4.1 API
ProfileKeyDefinition..::..Name Property
ProfileKeyDefinition Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Field Value

The name.

See Also

ProfileKeyDefinition Class
Sitecore.Analytics Namespace


ProfileDefinitionId Property

[image]

Sitecore 6.4.1 API
ProfileKeyDefinition..::..ProfileDefinitionId Property
ProfileKeyDefinition Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid ProfileDefinitionId { get; set; }
Visual Basic
Public Property ProfileDefinitionId As Guid
    Get
    Set
Visual C++
public:
property Guid ProfileDefinitionId {
    Guid get ();
    void set (Guid value);
}

Field Value

The profile definition id.

See Also

ProfileKeyDefinition Class
Sitecore.Analytics Namespace


ProfileKeyDefinitionId Property

[image]

Sitecore 6.4.1 API
ProfileKeyDefinition..::..ProfileKeyDefinitionId Property
ProfileKeyDefinition Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid ProfileKeyDefinitionId { get; set; }
Visual Basic
Public Property ProfileKeyDefinitionId As Guid
    Get
    Set
Visual C++
public:
property Guid ProfileKeyDefinitionId {
    Guid get ();
    void set (Guid value);
}

Field Value

The profile key definition id.

See Also

ProfileKeyDefinition Class
Sitecore.Analytics Namespace


ReferringSite Class

[image]

Sitecore 6.4.1 API
ReferringSite Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class ReferringSite
Visual Basic
Public Class ReferringSite
Visual C++
public ref class ReferringSite

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics..::..ReferringSite

See Also

ReferringSite Members
Sitecore.Analytics Namespace


ReferringSite Members

[image] [image]

Sitecore 6.4.1 API
ReferringSite Members
ReferringSite Class Constructors Methods Properties See Also Send Feedback

The ReferringSite type exposes the following members.

Constructors

 | Name | Description
Public method | ReferringSite | Initializes a new instance of the ReferringSite class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ReferringSiteId | Gets or sets the referring site id.
Public property | URL | Gets or sets the URL.

See Also

ReferringSite Class
Sitecore.Analytics Namespace


ReferringSite Constructor

[image]

Sitecore 6.4.1 API
ReferringSite Constructor
ReferringSite Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public ReferringSite()
Visual Basic
Public Sub New
Visual C++
public:
ReferringSite()

See Also

ReferringSite Class
Sitecore.Analytics Namespace


ReferringSite Methods

[image] [image]

Sitecore 6.4.1 API
ReferringSite Methods
ReferringSite Class See Also Send Feedback

The ReferringSite type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReferringSite Class
Sitecore.Analytics Namespace


ReferringSite Properties

[image] [image]

Sitecore 6.4.1 API
ReferringSite Properties
ReferringSite Class See Also Send Feedback

The ReferringSite type exposes the following members.

Properties

 | Name | Description
Public property | ReferringSiteId | Gets or sets the referring site id.
Public property | URL | Gets or sets the URL.

See Also

ReferringSite Class
Sitecore.Analytics Namespace


ReferringSiteId Property

[image]

Sitecore 6.4.1 API
ReferringSite..::..ReferringSiteId Property
ReferringSite Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid ReferringSiteId { get; set; }
Visual Basic
Public Property ReferringSiteId As Guid
    Get
    Set
Visual C++
public:
property Guid ReferringSiteId {
    Guid get ();
    void set (Guid value);
}

Field Value

The referring site id.

See Also

ReferringSite Class
Sitecore.Analytics Namespace


URL Property

[image]

Sitecore 6.4.1 API
ReferringSite..::..URL Property
ReferringSite Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string URL { get; set; }
Visual Basic
Public Property URL As String
    Get
    Set
Visual C++
public:
property String^ URL {
    String^ get ();
    void set (String^ value);
}

Field Value

The URL.

See Also

ReferringSite Class
Sitecore.Analytics Namespace


Screen Class

[image]

Sitecore 6.4.1 API
Screen Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class Screen
Visual Basic
Public Class Screen
Visual C++
public ref class Screen

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics..::..Screen

See Also

Screen Members
Sitecore.Analytics Namespace


Screen Members

[image] [image]

Sitecore 6.4.1 API
Screen Members
Screen Class Constructors Methods Properties See Also Send Feedback

The Screen type exposes the following members.

Constructors

 | Name | Description
Public method | Screen | Initializes a new instance of the Screen class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | Gets or sets the description.
Public property | Dimensions | Gets or sets the dimensions.
Public property | ScreenId | Gets or sets the screen id.

See Also

Screen Class
Sitecore.Analytics Namespace


Screen Constructor

[image]

Sitecore 6.4.1 API
Screen Constructor
Screen Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Screen()
Visual Basic
Public Sub New
Visual C++
public:
Screen()

See Also

Screen Class
Sitecore.Analytics Namespace


Screen Methods

[image] [image]

Sitecore 6.4.1 API
Screen Methods
Screen Class See Also Send Feedback

The Screen type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Screen Class
Sitecore.Analytics Namespace


Screen Properties

[image] [image]

Sitecore 6.4.1 API
Screen Properties
Screen Class See Also Send Feedback

The Screen type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets or sets the description.
Public property | Dimensions | Gets or sets the dimensions.
Public property | ScreenId | Gets or sets the screen id.

See Also

Screen Class
Sitecore.Analytics Namespace


Description Property

[image]

Sitecore 6.4.1 API
Screen..::..Description Property
Screen Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Field Value

The description.

See Also

Screen Class
Sitecore.Analytics Namespace


Dimensions Property

[image]

Sitecore 6.4.1 API
Screen..::..Dimensions Property
Screen Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Dimensions { get; set; }
Visual Basic
Public Property Dimensions As String
    Get
    Set
Visual C++
public:
property String^ Dimensions {
    String^ get ();
    void set (String^ value);
}

Field Value

The dimensions.

See Also

Screen Class
Sitecore.Analytics Namespace


ScreenId Property

[image]

Sitecore 6.4.1 API
Screen..::..ScreenId Property
Screen Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid ScreenId { get; set; }
Visual Basic
Public Property ScreenId As Guid
    Get
    Set
Visual C++
public:
property Guid ScreenId {
    Guid get ();
    void set (Guid value);
}

Field Value

The screen id.

See Also

Screen Class
Sitecore.Analytics Namespace


Session Class

[image]

Sitecore 6.4.1 API
Session Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class Session
Visual Basic
Public Class Session
Visual C++
public ref class Session

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics..::..Session

See Also

Session Members
Sitecore.Analytics Namespace


Session Members

[image] [image]

Sitecore 6.4.1 API
Session Members
Session Class Constructors Methods Properties See Also Send Feedback

The Session type exposes the following members.

Constructors

 | Name | Description
Public method | Session | Initializes a new instance of the Session class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AspNetSessionId | Gets or sets the ASP net session id.
Public property | BrowserId | Gets or sets the browser id.
Public property | CurrentPage | Gets or sets the current page.
Public property | Domain | Gets or sets the domain.
Public property | GlobalSessionId | Gets or sets the global session id.
Public property | GlobalVisitNo | Gets or sets the global visit no.
Public property | IpAddress | Gets or sets the ip address.
Public property | IpId | Gets or sets the ip id.
Public property | KeywordId | Gets or sets the keyword id.
Public property | LanguageId | Gets or sets the language id.
Public property | LastPageTimestamp | Gets or sets the last page timestamp.
Public property | MultiSite | Gets or sets the multi site.
Public property | OperatingSystemId | Gets or sets the operating system id.
Public property | ReferringSiteId | Gets or sets the referring site id.
Public property | ScreenId | Gets or sets the screen id.
Public property | SessionId | Gets or sets the session id.
Public property | Timestamp | Gets or sets the timestamp.

See Also

Session Class
Sitecore.Analytics Namespace


Session Constructor

[image]

Sitecore 6.4.1 API
Session Constructor
Session Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Session()
Visual Basic
Public Sub New
Visual C++
public:
Session()

See Also

Session Class
Sitecore.Analytics Namespace


Session Methods

[image] [image]

Sitecore 6.4.1 API
Session Methods
Session Class See Also Send Feedback

The Session type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Session Class
Sitecore.Analytics Namespace


Session Properties

[image] [image]

Sitecore 6.4.1 API
Session Properties
Session Class See Also Send Feedback

The Session type exposes the following members.

Properties

 | Name | Description
Public property | AspNetSessionId | Gets or sets the ASP net session id.
Public property | BrowserId | Gets or sets the browser id.
Public property | CurrentPage | Gets or sets the current page.
Public property | Domain | Gets or sets the domain.
Public property | GlobalSessionId | Gets or sets the global session id.
Public property | GlobalVisitNo | Gets or sets the global visit no.
Public property | IpAddress | Gets or sets the ip address.
Public property | IpId | Gets or sets the ip id.
Public property | KeywordId | Gets or sets the keyword id.
Public property | LanguageId | Gets or sets the language id.
Public property | LastPageTimestamp | Gets or sets the last page timestamp.
Public property | MultiSite | Gets or sets the multi site.
Public property | OperatingSystemId | Gets or sets the operating system id.
Public property | ReferringSiteId | Gets or sets the referring site id.
Public property | ScreenId | Gets or sets the screen id.
Public property | SessionId | Gets or sets the session id.
Public property | Timestamp | Gets or sets the timestamp.

See Also

Session Class
Sitecore.Analytics Namespace


AspNetSessionId Property

[image]

Sitecore 6.4.1 API
Session..::..AspNetSessionId Property
Session Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string AspNetSessionId { get; set; }
Visual Basic
Public Property AspNetSessionId As String
    Get
    Set
Visual C++
public:
property String^ AspNetSessionId {
    String^ get ();
    void set (String^ value);
}

Field Value

The ASP net session id.

See Also

Session Class
Sitecore.Analytics Namespace


BrowserId Property

[image]

Sitecore 6.4.1 API
Session..::..BrowserId Property
Session Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid BrowserId { get; set; }
Visual Basic
Public Property BrowserId As Guid
    Get
    Set
Visual C++
public:
property Guid BrowserId {
    Guid get ();
    void set (Guid value);
}

Field Value

The browser id.

See Also

Session Class
Sitecore.Analytics Namespace


CurrentPage Property

[image]

Sitecore 6.4.1 API
Session..::..CurrentPage Property
Session Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int CurrentPage { get; set; }
Visual Basic
Public Property CurrentPage As Integer
    Get
    Set
Visual C++
public:
property int CurrentPage {
    int get ();
    void set (int value);
}

Field Value

The current page.

See Also

Session Class
Sitecore.Analytics Namespace


Domain Property

[image]

Sitecore 6.4.1 API
Session..::..Domain Property
Session Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Domain { get; set; }
Visual Basic
Public Property Domain As String
    Get
    Set
Visual C++
public:
property String^ Domain {
    String^ get ();
    void set (String^ value);
}

Field Value

The domain.

See Also

Session Class
Sitecore.Analytics Namespace


GlobalVisitNo Property

[image]

Sitecore 6.4.1 API
Session..::..GlobalVisitNo Property
Session Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int GlobalVisitNo { get; set; }
Visual Basic
Public Property GlobalVisitNo As Integer
    Get
    Set
Visual C++
public:
property int GlobalVisitNo {
    int get ();
    void set (int value);
}

Field Value

The global visit no.

See Also

Session Class
Sitecore.Analytics Namespace


IpAddress Property

[image]

Sitecore 6.4.1 API
Session..::..IpAddress Property
Session Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string IpAddress { get; set; }
Visual Basic
Public Property IpAddress As String
    Get
    Set
Visual C++
public:
property String^ IpAddress {
    String^ get ();
    void set (String^ value);
}

Field Value

The ip address.

See Also

Session Class
Sitecore.Analytics Namespace


IpId Property

[image]

Sitecore 6.4.1 API
Session..::..IpId Property
Session Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid IpId { get; set; }
Visual Basic
Public Property IpId As Guid
    Get
    Set
Visual C++
public:
property Guid IpId {
    Guid get ();
    void set (Guid value);
}

Field Value

The ip id.

See Also

Session Class
Sitecore.Analytics Namespace


KeywordId Property

[image]

Sitecore 6.4.1 API
Session..::..KeywordId Property
Session Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid KeywordId { get; set; }
Visual Basic
Public Property KeywordId As Guid
    Get
    Set
Visual C++
public:
property Guid KeywordId {
    Guid get ();
    void set (Guid value);
}

Field Value

The keyword id.

See Also

Session Class
Sitecore.Analytics Namespace


LanguageId Property

[image]

Sitecore 6.4.1 API
Session..::..LanguageId Property
Session Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid LanguageId { get; set; }
Visual Basic
Public Property LanguageId As Guid
    Get
    Set
Visual C++
public:
property Guid LanguageId {
    Guid get ();
    void set (Guid value);
}

Field Value

The language id.

See Also

Session Class
Sitecore.Analytics Namespace


LastPageTimestamp Property

[image]

Sitecore 6.4.1 API
Session..::..LastPageTimestamp Property
Session Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public DateTime LastPageTimestamp { get; set; }
Visual Basic
Public Property LastPageTimestamp As DateTime
    Get
    Set
Visual C++
public:
property DateTime LastPageTimestamp {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The last page timestamp.

See Also

Session Class
Sitecore.Analytics Namespace


MultiSite Property

[image]

Sitecore 6.4.1 API
Session..::..MultiSite Property
Session Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string MultiSite { get; set; }
Visual Basic
Public Property MultiSite As String
    Get
    Set
Visual C++
public:
property String^ MultiSite {
    String^ get ();
    void set (String^ value);
}

Field Value

The multi site.

See Also

Session Class
Sitecore.Analytics Namespace


OperatingSystemId Property

[image]

Sitecore 6.4.1 API
Session..::..OperatingSystemId Property
Session Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid OperatingSystemId { get; set; }
Visual Basic
Public Property OperatingSystemId As Guid
    Get
    Set
Visual C++
public:
property Guid OperatingSystemId {
    Guid get ();
    void set (Guid value);
}

Field Value

The operating system id.

See Also

Session Class
Sitecore.Analytics Namespace


ReferringSiteId Property

[image]

Sitecore 6.4.1 API
Session..::..ReferringSiteId Property
Session Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid ReferringSiteId { get; set; }
Visual Basic
Public Property ReferringSiteId As Guid
    Get
    Set
Visual C++
public:
property Guid ReferringSiteId {
    Guid get ();
    void set (Guid value);
}

Field Value

The referring site id.

See Also

Session Class
Sitecore.Analytics Namespace


ScreenId Property

[image]

Sitecore 6.4.1 API
Session..::..ScreenId Property
Session Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid ScreenId { get; set; }
Visual Basic
Public Property ScreenId As Guid
    Get
    Set
Visual C++
public:
property Guid ScreenId {
    Guid get ();
    void set (Guid value);
}

Field Value

The screen id.

See Also

Session Class
Sitecore.Analytics Namespace


SessionId Property

[image]

Sitecore 6.4.1 API
Session..::..SessionId Property
Session Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid SessionId { get; set; }
Visual Basic
Public Property SessionId As Guid
    Get
    Set
Visual C++
public:
property Guid SessionId {
    Guid get ();
    void set (Guid value);
}

Field Value

The session id.

See Also

Session Class
Sitecore.Analytics Namespace


Timestamp Property

[image]

Sitecore 6.4.1 API
Session..::..Timestamp Property
Session Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public DateTime Timestamp { get; set; }
Visual Basic
Public Property Timestamp As DateTime
    Get
    Set
Visual C++
public:
property DateTime Timestamp {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The timestamp.

See Also

Session Class
Sitecore.Analytics Namespace


Status Class

[image]

Sitecore 6.4.1 API
Status Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class Status
Visual Basic
Public Class Status
Visual C++
public ref class Status

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics..::..Status

See Also

Status Members
Sitecore.Analytics Namespace


Status Members

[image] [image]

Sitecore 6.4.1 API
Status Members
Status Class Constructors Methods Properties See Also Send Feedback

The Status type exposes the following members.

Constructors

 | Name | Description
Public method | Status | Initializes a new instance of the Status class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Id | Gets or sets the id.
Public property | LastFailed | Gets or sets the last failed.
Public property | LastSuccessful | Gets or sets the last successful.
Public property | Name | Gets or sets the name.

See Also

Status Class
Sitecore.Analytics Namespace


Status Constructor

[image]

Sitecore 6.4.1 API
Status Constructor
Status Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Status()
Visual Basic
Public Sub New
Visual C++
public:
Status()

See Also

Status Class
Sitecore.Analytics Namespace


Status Methods

[image] [image]

Sitecore 6.4.1 API
Status Methods
Status Class See Also Send Feedback

The Status type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Status Class
Sitecore.Analytics Namespace


Status Properties

[image] [image]

Sitecore 6.4.1 API
Status Properties
Status Class See Also Send Feedback

The Status type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets or sets the id.
Public property | LastFailed | Gets or sets the last failed.
Public property | LastSuccessful | Gets or sets the last successful.
Public property | Name | Gets or sets the name.

See Also

Status Class
Sitecore.Analytics Namespace


Id Property

[image]

Sitecore 6.4.1 API
Status..::..Id Property
Status Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid Id { get; set; }
Visual Basic
Public Property Id As Guid
    Get
    Set
Visual C++
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}

Field Value

The id.

See Also

Status Class
Sitecore.Analytics Namespace


LastSuccessful Property

[image]

Sitecore 6.4.1 API
Status..::..LastSuccessful Property
Status Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Nullable<DateTime> LastSuccessful { get; set; }
Visual Basic
Public Property LastSuccessful As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> LastSuccessful {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Field Value

The last successful.

See Also

Status Class
Sitecore.Analytics Namespace


Name Property

[image]

Sitecore 6.4.1 API
Status..::..Name Property
Status Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Field Value

The name.

See Also

Status Class
Sitecore.Analytics Namespace


Subscription Class

[image]

Sitecore 6.4.1 API
Subscription Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class Subscription
Visual Basic
Public Class Subscription
Visual C++
public ref class Subscription

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics..::..Subscription

See Also

Subscription Members
Sitecore.Analytics Namespace


Subscription Members

[image] [image]

Sitecore 6.4.1 API
Subscription Members
Subscription Class Constructors Methods Properties See Also Send Feedback

The Subscription type exposes the following members.

Constructors

 | Name | Description
Public method | Subscription | Initializes a new instance of the Subscription class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IpOwnerId | Gets or sets the ip owner id.
Public property | Recipients | Gets or sets the recipients.
Public property | SubscriptionId | Gets or sets the subscription id.

See Also

Subscription Class
Sitecore.Analytics Namespace


Subscription Constructor

[image]

Sitecore 6.4.1 API
Subscription Constructor
Subscription Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Subscription()
Visual Basic
Public Sub New
Visual C++
public:
Subscription()

See Also

Subscription Class
Sitecore.Analytics Namespace


Subscription Methods

[image] [image]

Sitecore 6.4.1 API
Subscription Methods
Subscription Class See Also Send Feedback

The Subscription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Subscription Class
Sitecore.Analytics Namespace


Subscription Properties

[image] [image]

Sitecore 6.4.1 API
Subscription Properties
Subscription Class See Also Send Feedback

The Subscription type exposes the following members.

Properties

 | Name | Description
Public property | IpOwnerId | Gets or sets the ip owner id.
Public property | Recipients | Gets or sets the recipients.
Public property | SubscriptionId | Gets or sets the subscription id.

See Also

Subscription Class
Sitecore.Analytics Namespace


Recipients Property

[image]

Sitecore 6.4.1 API
Subscription..::..Recipients Property
Subscription Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Recipients { get; set; }
Visual Basic
Public Property Recipients As String
    Get
    Set
Visual C++
public:
property String^ Recipients {
    String^ get ();
    void set (String^ value);
}

Field Value

The recipients.

See Also

Subscription Class
Sitecore.Analytics Namespace


SubscriptionId Property

[image]

Sitecore 6.4.1 API
Subscription..::..SubscriptionId Property
Subscription Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid SubscriptionId { get; set; }
Visual Basic
Public Property SubscriptionId As Guid
    Get
    Set
Visual C++
public:
property Guid SubscriptionId {
    Guid get ();
    void set (Guid value);
}

Field Value

The subscription id.

See Also

Subscription Class
Sitecore.Analytics Namespace


Tag Class

[image]

Sitecore 6.4.1 API
Tag Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class Tag
Visual Basic
Public Class Tag
Visual C++
public ref class Tag

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics..::..Tag

See Also

Tag Members
Sitecore.Analytics Namespace


Tag Members

[image] [image]

Sitecore 6.4.1 API
Tag Members
Tag Class Constructors Methods Properties See Also Send Feedback

The Tag type exposes the following members.

Constructors

 | Name | Description
Public method | Tag | Initializes a new instance of the Tag class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Acquaintance | Gets or sets the acquaintance.
Public property | Data | Gets or sets the data.
Public property | GlobalSessionId | Gets or sets the global session id.
Public property | TagId | Gets or sets the tag id.

See Also

Tag Class
Sitecore.Analytics Namespace


Tag Constructor

[image]

Sitecore 6.4.1 API
Tag Constructor
Tag Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Tag()
Visual Basic
Public Sub New
Visual C++
public:
Tag()

See Also

Tag Class
Sitecore.Analytics Namespace


Tag Methods

[image] [image]

Sitecore 6.4.1 API
Tag Methods
Tag Class See Also Send Feedback

The Tag type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Tag Class
Sitecore.Analytics Namespace


Tag Properties

[image] [image]

Sitecore 6.4.1 API
Tag Properties
Tag Class See Also Send Feedback

The Tag type exposes the following members.

Properties

 | Name | Description
Public property | Acquaintance | Gets or sets the acquaintance.
Public property | Data | Gets or sets the data.
Public property | GlobalSessionId | Gets or sets the global session id.
Public property | TagId | Gets or sets the tag id.

See Also

Tag Class
Sitecore.Analytics Namespace


Acquaintance Property

[image]

Sitecore 6.4.1 API
Tag..::..Acquaintance Property
Tag Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid Acquaintance { get; set; }
Visual Basic
Public Property Acquaintance As Guid
    Get
    Set
Visual C++
public:
property Guid Acquaintance {
    Guid get ();
    void set (Guid value);
}

Field Value

The acquaintance.

See Also

Tag Class
Sitecore.Analytics Namespace


Data Property

[image]

Sitecore 6.4.1 API
Tag..::..Data Property
Tag Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Data { get; set; }
Visual Basic
Public Property Data As String
    Get
    Set
Visual C++
public:
property String^ Data {
    String^ get ();
    void set (String^ value);
}

Field Value

The data.

See Also

Tag Class
Sitecore.Analytics Namespace


GlobalSessionId Property

[image]

Sitecore 6.4.1 API
Tag..::..GlobalSessionId Property
Tag Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid GlobalSessionId { get; set; }
Visual Basic
Public Property GlobalSessionId As Guid
    Get
    Set
Visual C++
public:
property Guid GlobalSessionId {
    Guid get ();
    void set (Guid value);
}

Field Value

The global session id.

See Also

Tag Class
Sitecore.Analytics Namespace


TagId Property

[image]

Sitecore 6.4.1 API
Tag..::..TagId Property
Tag Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid TagId { get; set; }
Visual Basic
Public Property TagId As Guid
    Get
    Set
Visual C++
public:
property Guid TagId {
    Guid get ();
    void set (Guid value);
}

Field Value

The tag id.

See Also

Tag Class
Sitecore.Analytics Namespace


TransactionHandle Class

[image]

Sitecore 6.4.1 API
TransactionHandle Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class TransactionHandle
Visual Basic
Public Class TransactionHandle
Visual C++
public ref class TransactionHandle

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics..::..TransactionHandle

See Also

TransactionHandle Members
Sitecore.Analytics Namespace


TransactionHandle Members

[image] [image]

Sitecore 6.4.1 API
TransactionHandle Members
TransactionHandle Class Constructors Methods See Also Send Feedback

The TransactionHandle type exposes the following members.

Constructors

 | Name | Description
Public method | TransactionHandle | Initializes a new instance of the TransactionHandle class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TransactionHandle Class
Sitecore.Analytics Namespace


TransactionHandle Constructor

[image]

Sitecore 6.4.1 API
TransactionHandle Constructor
TransactionHandle Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public TransactionHandle()
Visual Basic
Public Sub New
Visual C++
public:
TransactionHandle()

See Also

TransactionHandle Class
Sitecore.Analytics Namespace


TransactionHandle Methods

[image] [image]

Sitecore 6.4.1 API
TransactionHandle Methods
TransactionHandle Class See Also Send Feedback

The TransactionHandle type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TransactionHandle Class
Sitecore.Analytics Namespace


VisitorIdentification Class

[image]

Sitecore 6.4.1 API
VisitorIdentification Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class VisitorIdentification
Visual Basic
Public Class VisitorIdentification
Visual C++
public ref class VisitorIdentification

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics..::..VisitorIdentification

See Also

VisitorIdentification Members
Sitecore.Analytics Namespace


VisitorIdentification Members

[image] [image]

Sitecore 6.4.1 API
VisitorIdentification Members
VisitorIdentification Class Constructors Methods Properties See Also Send Feedback

The VisitorIdentification type exposes the following members.

Constructors

 | Name | Description
Public method | VisitorIdentification | Initializes a new instance of the VisitorIdentification class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | Gets or sets the description.
Public property | VisitorIdentification1 | Gets or sets the visitor identification1.

See Also

VisitorIdentification Class
Sitecore.Analytics Namespace


VisitorIdentification Constructor

[image]

Sitecore 6.4.1 API
VisitorIdentification Constructor
VisitorIdentification Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public VisitorIdentification()
Visual Basic
Public Sub New
Visual C++
public:
VisitorIdentification()

See Also

VisitorIdentification Class
Sitecore.Analytics Namespace


VisitorIdentification Methods

[image] [image]

Sitecore 6.4.1 API
VisitorIdentification Methods
VisitorIdentification Class See Also Send Feedback

The VisitorIdentification type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VisitorIdentification Class
Sitecore.Analytics Namespace


Description Property

[image]

Sitecore 6.4.1 API
VisitorIdentification..::..Description Property
VisitorIdentification Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Field Value

The description.

See Also

VisitorIdentification Class
Sitecore.Analytics Namespace


VisitorIdentification1 Property

[image]

Sitecore 6.4.1 API
VisitorIdentification..::..VisitorIdentification1 Property
VisitorIdentification Class See Also Send Feedback

Namespace: Sitecore.Analytics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int VisitorIdentification1 { get; set; }
Visual Basic
Public Property VisitorIdentification1 As Integer
    Get
    Set
Visual C++
public:
property int VisitorIdentification1 {
    int get ();
    void set (int value);
}

Field Value

The visitor identification1.

See Also

VisitorIdentification Class
Sitecore.Analytics Namespace


Sitecore.Analytics.Configuration Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Analytics.Configuration Namespace
Send Feedback

Classes

 | Class | Description
Public class | AnalyticsSettings | Defines the analytics settings class.
Public class | AnalyticsSettings..::..PerformLookup | Defines the perform lookup class.
Public class | AnalyticsSettings..::..Reports | Defines the reports settings class
Public class | AnalyticsSettings..::..Sampling | Defines the sampling class.
Public class | ExcludeList | The exclude list.


AnalyticsSettings Class

[image]

Sitecore 6.4.1 API
AnalyticsSettings Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Configuration
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static class AnalyticsSettings
Visual Basic
Public NotInheritable Class AnalyticsSettings
Visual C++
public ref class AnalyticsSettings abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Configuration..::..AnalyticsSettings

See Also

AnalyticsSettings Members
Sitecore.Analytics.Configuration Namespace


AnalyticsSettings Members

[image] [image]

Sitecore 6.4.1 API
AnalyticsSettings Members
AnalyticsSettings Class Properties See Also Send Feedback

The AnalyticsSettings type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating whether this AnalyticsSettings is enabled.
ExcludeList | Gets exclude list. Requests with user agent or IP address from the list will be ignored.

See Also

AnalyticsSettings Class
Sitecore.Analytics.Configuration Namespace


AnalyticsSettings Properties

[image] [image]

Sitecore 6.4.1 API
AnalyticsSettings Properties
AnalyticsSettings Class See Also Send Feedback

The AnalyticsSettings type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating whether this AnalyticsSettings is enabled.
ExcludeList | Gets exclude list. Requests with user agent or IP address from the list will be ignored.

See Also

AnalyticsSettings Class
Sitecore.Analytics.Configuration Namespace


Enabled Property

[image]

Sitecore 6.4.1 API
AnalyticsSettings..::..Enabled Property
AnalyticsSettings Class See Also Send Feedback

Namespace: Sitecore.Analytics.Configuration
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static bool Enabled { get; }
Visual Basic
Public Shared ReadOnly Property Enabled As Boolean
    Get
Visual C++
public:
static property bool Enabled {
    bool get ();
}

Field Value

true if enabled; otherwise, false.

See Also

AnalyticsSettings Class
Sitecore.Analytics.Configuration Namespace


ExcludeList Property

[image]

Sitecore 6.4.1 API
AnalyticsSettings..::..ExcludeList Property
AnalyticsSettings Class See Also Send Feedback

Namespace: Sitecore.Analytics.Configuration
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static ExcludeList ExcludeList { get; }
Visual Basic
Public Shared ReadOnly Property ExcludeList As ExcludeList
    Get
Visual C++
public:
static property ExcludeList^ ExcludeList {
    ExcludeList^ get ();
}

See Also

AnalyticsSettings Class
Sitecore.Analytics.Configuration Namespace


AnalyticsSettings.PerformLookup Class

[image]

Sitecore 6.4.1 API
AnalyticsSettings..::..PerformLookup Class
AnalyticsSettings Class Members See Also Send Feedback

Namespace: Sitecore.Analytics.Configuration
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static class PerformLookup
Visual Basic
Public NotInheritable Class PerformLookup
Visual C++
public ref class PerformLookup abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Configuration..::..AnalyticsSettings..::..PerformLookup

See Also

AnalyticsSettings..::..PerformLookup Members
Sitecore.Analytics.Configuration Namespace


AnalyticsSettings.PerformLookup Members

[image] [image]

Sitecore 6.4.1 API
AnalyticsSettings..::..PerformLookup Members
AnalyticsSettings..::..PerformLookup Class Properties See Also Send Feedback

Defines the analytics settings class.

The AnalyticsSettings..::..PerformLookup type exposes the following members.

Properties

Name | Description
Interval | Gets the DNS lookup interval in milliseconds.

See Also

AnalyticsSettings..::..PerformLookup Class
Sitecore.Analytics.Configuration Namespace


AnalyticsSettings.Reports Class

[image]

Sitecore 6.4.1 API
AnalyticsSettings..::..Reports Class
AnalyticsSettings Class Members See Also Send Feedback

Namespace: Sitecore.Analytics.Configuration
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static class Reports
Visual Basic
Public NotInheritable Class Reports
Visual C++
public ref class Reports abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Configuration..::..AnalyticsSettings..::..Reports

See Also

AnalyticsSettings..::..Reports Members
Sitecore.Analytics.Configuration Namespace


AnalyticsSettings.Reports Members

[image] [image]

Sitecore 6.4.1 API
AnalyticsSettings..::..Reports Members
AnalyticsSettings..::..Reports Class Properties See Also Send Feedback

Defines the analytics settings class.

The AnalyticsSettings..::..Reports type exposes the following members.

Properties

Name | Description
Timeout | Gets the timeout value for analytics reports.

See Also

AnalyticsSettings..::..Reports Class
Sitecore.Analytics.Configuration Namespace


AnalyticsSettings.Reports Properties

[image] [image]

Sitecore 6.4.1 API
AnalyticsSettings..::..Reports Properties
AnalyticsSettings..::..Reports Class See Also Send Feedback

The AnalyticsSettings..::..Reports type exposes the following members.

Properties

Name | Description
Timeout | Gets the timeout value for analytics reports.

See Also

AnalyticsSettings..::..Reports Class
Sitecore.Analytics.Configuration Namespace


Timeout Property

[image]

Sitecore 6.4.1 API
AnalyticsSettings..::..Reports..::..Timeout Property
AnalyticsSettings..::..Reports Class See Also Send Feedback

Namespace: Sitecore.Analytics.Configuration
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static TimeSpan Timeout { get; }
Visual Basic
Public Shared ReadOnly Property Timeout As TimeSpan
    Get
Visual C++
public:
static property TimeSpan Timeout {
    TimeSpan get ();
}

Field Value

Default value: 5 minutes

See Also

AnalyticsSettings..::..Reports Class
Sitecore.Analytics.Configuration Namespace


AnalyticsSettings.Sampling Class

[image]

Sitecore 6.4.1 API
AnalyticsSettings..::..Sampling Class
AnalyticsSettings Class Members See Also Send Feedback

Namespace: Sitecore.Analytics.Configuration
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static class Sampling
Visual Basic
Public NotInheritable Class Sampling
Visual C++
public ref class Sampling abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Configuration..::..AnalyticsSettings..::..Sampling

See Also

AnalyticsSettings..::..Sampling Members
Sitecore.Analytics.Configuration Namespace


AnalyticsSettings.Sampling Members

[image] [image]

Sitecore 6.4.1 API
AnalyticsSettings..::..Sampling Members
AnalyticsSettings..::..Sampling Class Properties See Also Send Feedback

Defines the analytics settings class.

The AnalyticsSettings..::..Sampling type exposes the following members.

Properties

Name | Description
Percentage | Gets the percentage.

See Also

AnalyticsSettings..::..Sampling Class
Sitecore.Analytics.Configuration Namespace


AnalyticsSettings.Sampling Properties

[image] [image]

Sitecore 6.4.1 API
AnalyticsSettings..::..Sampling Properties
AnalyticsSettings..::..Sampling Class See Also Send Feedback

The AnalyticsSettings..::..Sampling type exposes the following members.

Properties

Name | Description
Percentage | Gets the percentage.

See Also

AnalyticsSettings..::..Sampling Class
Sitecore.Analytics.Configuration Namespace


Percentage Property

[image]

Sitecore 6.4.1 API
AnalyticsSettings..::..Sampling..::..Percentage Property
AnalyticsSettings..::..Sampling Class See Also Send Feedback

Namespace: Sitecore.Analytics.Configuration
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static int Percentage { get; }
Visual Basic
Public Shared ReadOnly Property Percentage As Integer
    Get
Visual C++
public:
static property int Percentage {
    int get ();
}

Field Value

The percentage.

See Also

AnalyticsSettings..::..Sampling Class
Sitecore.Analytics.Configuration Namespace


ExcludeList Class

[image]

Sitecore 6.4.1 API
ExcludeList Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Configuration
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class ExcludeList
Visual Basic
Public Class ExcludeList
Visual C++
public ref class ExcludeList

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Configuration..::..ExcludeList

See Also

ExcludeList Members
Sitecore.Analytics.Configuration Namespace


ExcludeList Members

[image] [image]

Sitecore 6.4.1 API
ExcludeList Members
ExcludeList Class Constructors Methods See Also Send Feedback

The ExcludeList type exposes the following members.

Constructors

 | Name | Description
Public method | ExcludeList | Initializes a new instance of the ExcludeList class.

Methods

 | Name | Description
Public method | ContainsIpAddress | Determines whether list contains specified IP address or user agent string.
Public method | ContainsUserAgent | Determines whether list contains the specified user agent.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GeExcludeList | Gets exclude list.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExcludeList Class
Sitecore.Analytics.Configuration Namespace


ExcludeList Methods

[image] [image]

Sitecore 6.4.1 API
ExcludeList Methods
ExcludeList Class See Also Send Feedback

The ExcludeList type exposes the following members.

Methods

 | Name | Description
Public method | ContainsIpAddress | Determines whether list contains specified IP address or user agent string.
Public method | ContainsUserAgent | Determines whether list contains the specified user agent.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GeExcludeList | Gets exclude list.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExcludeList Class
Sitecore.Analytics.Configuration Namespace


ContainsIpAddress Method

[image]

Sitecore 6.4.1 API
ExcludeList..::..ContainsIpAddress Method
ExcludeList Class See Also Send Feedback

Namespace: Sitecore.Analytics.Configuration
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public bool ContainsIpAddress(
    string addressString
)
Visual Basic
Public Function ContainsIpAddress ( _
    addressString As String _
) As Boolean
Visual C++
public:
bool ContainsIpAddress(
    String^ addressString
)

Parameters

addressString
Type: System..::..String
The IP address.

Return Value

true if list contains specified IP address or user agent string, false.

See Also

ExcludeList Class
Sitecore.Analytics.Configuration Namespace


ContainsUserAgent Method

[image]

Sitecore 6.4.1 API
ExcludeList..::..ContainsUserAgent Method
ExcludeList Class See Also Send Feedback

Namespace: Sitecore.Analytics.Configuration
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public bool ContainsUserAgent(
    string userAgent
)
Visual Basic
Public Function ContainsUserAgent ( _
    userAgent As String _
) As Boolean
Visual C++
public:
bool ContainsUserAgent(
    String^ userAgent
)

Parameters

userAgent
Type: System..::..String
The user agent.

Return Value

true if list contains the specified user agent; otherwise, false.

See Also

ExcludeList Class
Sitecore.Analytics.Configuration Namespace


GeExcludeList Method

[image]

Sitecore 6.4.1 API
ExcludeList..::..GeExcludeList Method
ExcludeList Class See Also Send Feedback

Namespace: Sitecore.Analytics.Configuration
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static ExcludeList GeExcludeList()
Visual Basic
Public Shared Function GeExcludeList As ExcludeList
Visual C++
public:
static ExcludeList^ GeExcludeList()

Return Value

The exclude list.

See Also

ExcludeList Class
Sitecore.Analytics.Configuration Namespace


Sitecore.Analytics.Data Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Analytics.Data Namespace
Send Feedback

Classes

 | Class | Description
Public class | AnalyticsCachedData | Defines the analytics data class.
Public class | AnalyticsTrackerSubmitter | Defines the analytics tracker submitter class.
Public class | CampaignEventSubmitter | Defines the update visitor identification submitter class.
Public class | DatabaseSubmitter | Defines the submitter class.
Public class | ProfileData | Defines the profile data class.
Public class | ProfileKeyData | Defines the profile key data class.
Public class | ProfilesDataCollection | Defines the profiles data class.
Public class | TrackingFieldProcessor | Defines the tracking field processor class.
Public class | UpdateVisitorIdentificationSubmitter | Defines the update visitor identification submitter class.
Public class | VisitorIdentification | Defines the visitor identification class.

Interfaces

 | Interface | Description
Public interface | IDatabaseSubmittable | Defines the database submittable interface.


AnalyticsCachedData Class

[image]

Sitecore 6.4.1 API
AnalyticsCachedData Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
[SerializableAttribute]
public class AnalyticsCachedData
Visual Basic
<SerializableAttribute> _
Public Class AnalyticsCachedData
Visual C++
[SerializableAttribute]
public ref class AnalyticsCachedData

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data..::..AnalyticsCachedData

See Also

AnalyticsCachedData Members
Sitecore.Analytics.Data Namespace


AnalyticsCachedData Members

[image] [image]

Sitecore 6.4.1 API
AnalyticsCachedData Members
AnalyticsCachedData Class Constructors Methods Properties See Also Send Feedback

The AnalyticsCachedData type exposes the following members.

Constructors

 | Name | Description
Public method | AnalyticsCachedData | Initializes a new instance of the AnalyticsCachedData class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reload | Reloads this instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Profiles | Gets the profiles.

See Also

AnalyticsCachedData Class
Sitecore.Analytics.Data Namespace


AnalyticsCachedData Constructor

[image]

Sitecore 6.4.1 API
AnalyticsCachedData Constructor
AnalyticsCachedData Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public AnalyticsCachedData()
Visual Basic
Public Sub New
Visual C++
public:
AnalyticsCachedData()

See Also

AnalyticsCachedData Class
Sitecore.Analytics.Data Namespace


AnalyticsCachedData Methods

[image] [image]

Sitecore 6.4.1 API
AnalyticsCachedData Methods
AnalyticsCachedData Class See Also Send Feedback

The AnalyticsCachedData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reload | Reloads this instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticsCachedData Class
Sitecore.Analytics.Data Namespace


Reload Method

[image]

Sitecore 6.4.1 API
AnalyticsCachedData..::..Reload Method
AnalyticsCachedData Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void Reload(
    Guid sessionId
)
Visual Basic
Public Sub Reload ( _
    sessionId As Guid _
)
Visual C++
public:
void Reload(
    Guid sessionId
)

Parameters

sessionId
Type: System..::..Guid
The session id.

Remarks

This is called when the session is lost.

See Also

AnalyticsCachedData Class
Sitecore.Analytics.Data Namespace


AnalyticsCachedData Properties

[image] [image]

Sitecore 6.4.1 API
AnalyticsCachedData Properties
AnalyticsCachedData Class See Also Send Feedback

The AnalyticsCachedData type exposes the following members.

Properties

 | Name | Description
Public property | Profiles | Gets the profiles.

See Also

AnalyticsCachedData Class
Sitecore.Analytics.Data Namespace


Profiles Property

[image]

Sitecore 6.4.1 API
AnalyticsCachedData..::..Profiles Property
AnalyticsCachedData Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public ProfilesDataCollection Profiles { get; }
Visual Basic
Public ReadOnly Property Profiles As ProfilesDataCollection
    Get
Visual C++
public:
property ProfilesDataCollection^ Profiles {
    ProfilesDataCollection^ get ();
}

Field Value

The profiles.

See Also

AnalyticsCachedData Class
Sitecore.Analytics.Data Namespace


AnalyticsTrackerSubmitter Members

[image] [image]

Sitecore 6.4.1 API
AnalyticsTrackerSubmitter Members
AnalyticsTrackerSubmitter Class Constructors Methods See Also Send Feedback

The AnalyticsTrackerSubmitter type exposes the following members.

Constructors

 | Name | Description
Public method | AnalyticsTrackerSubmitter | Initializes a new instance of the AnalyticsTrackerSubmitter class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Submit | Submits this instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticsTrackerSubmitter Class
Sitecore.Analytics.Data Namespace


AnalyticsTrackerSubmitter Constructor

[image]

Sitecore 6.4.1 API
AnalyticsTrackerSubmitter Constructor
AnalyticsTrackerSubmitter Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public AnalyticsTrackerSubmitter(
    AnalyticsTracker analyticsTracker
)
Visual Basic
Public Sub New ( _
    analyticsTracker As AnalyticsTracker _
)
Visual C++
public:
AnalyticsTrackerSubmitter(
    AnalyticsTracker^ analyticsTracker
)

Parameters

analyticsTracker
Type: Sitecore.Analytics..::..AnalyticsTracker
The analytics tracker.

See Also

AnalyticsTrackerSubmitter Class
Sitecore.Analytics.Data Namespace


AnalyticsTrackerSubmitter Methods

[image] [image]

Sitecore 6.4.1 API
AnalyticsTrackerSubmitter Methods
AnalyticsTrackerSubmitter Class See Also Send Feedback

The AnalyticsTrackerSubmitter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Submit | Submits this instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticsTrackerSubmitter Class
Sitecore.Analytics.Data Namespace


Submit Method

[image]

Sitecore 6.4.1 API
AnalyticsTrackerSubmitter..::..Submit Method
AnalyticsTrackerSubmitter Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void Submit()
Visual Basic
Public Sub Submit
Visual C++
public:
virtual void Submit() sealed

Implements

IDatabaseSubmittable..::..Submit()()()()

See Also

AnalyticsTrackerSubmitter Class
Sitecore.Analytics.Data Namespace


CampaignEventSubmitter Class

[image]

Sitecore 6.4.1 API
CampaignEventSubmitter Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class CampaignEventSubmitter : IDatabaseSubmittable
Visual Basic
Public Class CampaignEventSubmitter _
    Implements IDatabaseSubmittable
Visual C++
public ref class CampaignEventSubmitter : IDatabaseSubmittable

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data..::..CampaignEventSubmitter

See Also

CampaignEventSubmitter Members
Sitecore.Analytics.Data Namespace


CampaignEventSubmitter Methods

[image] [image]

Sitecore 6.4.1 API
CampaignEventSubmitter Methods
CampaignEventSubmitter Class See Also Send Feedback

The CampaignEventSubmitter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Submit | Submits this instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CampaignEventSubmitter Class
Sitecore.Analytics.Data Namespace


Submit Method

[image]

Sitecore 6.4.1 API
CampaignEventSubmitter..::..Submit Method
CampaignEventSubmitter Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void Submit()
Visual Basic
Public Sub Submit
Visual C++
public:
virtual void Submit() sealed

Implements

IDatabaseSubmittable..::..Submit()()()()

See Also

CampaignEventSubmitter Class
Sitecore.Analytics.Data Namespace


DatabaseSubmitter Class

[image]

Sitecore 6.4.1 API
DatabaseSubmitter Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static class DatabaseSubmitter
Visual Basic
Public NotInheritable Class DatabaseSubmitter
Visual C++
public ref class DatabaseSubmitter abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data..::..DatabaseSubmitter

See Also

DatabaseSubmitter Members
Sitecore.Analytics.Data Namespace


DatabaseSubmitter Members

[image] [image]

Sitecore 6.4.1 API
DatabaseSubmitter Members
DatabaseSubmitter Class Methods See Also Send Feedback

The DatabaseSubmitter type exposes the following members.

Methods

Name | Description
Dequeue | Dequeues this instance.
Enqueue | Enqueues the specified analytics tracker.
GetSubmitters<(Of <<'(T>)>>) | Gets the items.

See Also

DatabaseSubmitter Class
Sitecore.Analytics.Data Namespace


DatabaseSubmitter Methods

[image] [image]

Sitecore 6.4.1 API
DatabaseSubmitter Methods
DatabaseSubmitter Class See Also Send Feedback

The DatabaseSubmitter type exposes the following members.

Methods

Name | Description
Dequeue | Dequeues this instance.
Enqueue | Enqueues the specified analytics tracker.
GetSubmitters<(Of <<'(T>)>>) | Gets the items.

See Also

DatabaseSubmitter Class
Sitecore.Analytics.Data Namespace


Dequeue Method

[image]

Sitecore 6.4.1 API
DatabaseSubmitter..::..Dequeue Method
DatabaseSubmitter Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static IDatabaseSubmittable Dequeue()
Visual Basic
Public Shared Function Dequeue As IDatabaseSubmittable
Visual C++
public:
static IDatabaseSubmittable^ Dequeue()

Return Value

The analytics tracker.

See Also

DatabaseSubmitter Class
Sitecore.Analytics.Data Namespace


Enqueue Method

[image]

Sitecore 6.4.1 API
DatabaseSubmitter..::..Enqueue Method
DatabaseSubmitter Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void Enqueue(
    IDatabaseSubmittable databaseSubmittable
)
Visual Basic
Public Shared Sub Enqueue ( _
    databaseSubmittable As IDatabaseSubmittable _
)
Visual C++
public:
static void Enqueue(
    IDatabaseSubmittable^ databaseSubmittable
)

Parameters

databaseSubmittable
Type: Sitecore.Analytics.Data..::..IDatabaseSubmittable
The database submittable object.

See Also

DatabaseSubmitter Class
Sitecore.Analytics.Data Namespace


IDatabaseSubmittable Interface

[image]

Sitecore 6.4.1 API
IDatabaseSubmittable Interface
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public interface IDatabaseSubmittable
Visual Basic
Public Interface IDatabaseSubmittable
Visual C++
public interface class IDatabaseSubmittable

See Also

IDatabaseSubmittable Members
Sitecore.Analytics.Data Namespace


IDatabaseSubmittable Members

[image] [image]

Sitecore 6.4.1 API
IDatabaseSubmittable Members
IDatabaseSubmittable Interface Methods See Also Send Feedback

The IDatabaseSubmittable type exposes the following members.

Methods

 | Name | Description
Public method | Submit | Submits this instance.

See Also

IDatabaseSubmittable Interface
Sitecore.Analytics.Data Namespace


IDatabaseSubmittable Methods

[image] [image]

Sitecore 6.4.1 API
IDatabaseSubmittable Methods
IDatabaseSubmittable Interface See Also Send Feedback

The IDatabaseSubmittable type exposes the following members.

Methods

 | Name | Description
Public method | Submit | Submits this instance.

See Also

IDatabaseSubmittable Interface
Sitecore.Analytics.Data Namespace


Submit Method

[image]

Sitecore 6.4.1 API
IDatabaseSubmittable..::..Submit Method
IDatabaseSubmittable Interface See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
void Submit()
Visual Basic
Sub Submit
Visual C++
void Submit()

See Also

IDatabaseSubmittable Interface
Sitecore.Analytics.Data Namespace


ProfileData Class

[image]

Sitecore 6.4.1 API
ProfileData Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
[SerializableAttribute]
public class ProfileData : ISerializable,
    IEnumerable<ProfileKeyData>, IEnumerable
Visual Basic
<SerializableAttribute> _
Public Class ProfileData _
    Implements ISerializable, IEnumerable(Of ProfileKeyData),  _
    IEnumerable
Visual C++
[SerializableAttribute]
public ref class ProfileData : ISerializable,
    IEnumerable<ProfileKeyData^>, IEnumerable

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data..::..ProfileData

See Also

ProfileData Members
Sitecore.Analytics.Data Namespace


ProfileData Members

[image] [image]

Sitecore 6.4.1 API
ProfileData Members
ProfileData Class Constructors Methods Properties See Also Send Feedback

The ProfileData type exposes the following members.

Constructors

 | Name | Description
Public method | ProfileData()()()() | Initializes a new instance of the ProfileData class.
Protected method | ProfileData(SerializationInfo, StreamingContext) | Initializes a new instance of the ProfileData class.

Methods

 | Name | Description
Public method | Add | Adds the specified profile key data.
Public method | AddProfileKeyValue | Adds the profile key value.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetProfileKey | Gets the profile key.
Public method | GetProfileKeyValue | Gets the profile key value.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | Convert<(Of <<'(ProfileKeyData, TTo>)>>) | Converts this instance. (Defined by EnumerableExtensions.)
Public Extension Method | StringConcatenate<(Of <<'(ProfileKeyData>)>>) | Concatenate strings (Defined by IEnumerableExtensions.)

Properties

 | Name | Description
Public property | Changed | Gets or sets a value indicating whether this ProfileData is changed.
Public property | Count | Gets or sets the count.
Public property | ProfileId | Gets or sets the profile id.
Public property | ProfileName | Gets or sets the name.
Public property | Total | Gets or sets the total.

See Also

ProfileData Class
Sitecore.Analytics.Data Namespace


ProfileData Constructor

[image] [image]

Sitecore 6.4.1 API
ProfileData Constructor
ProfileData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ProfileData()()()() | Initializes a new instance of the ProfileData class.
Protected method | ProfileData(SerializationInfo, StreamingContext) | Initializes a new instance of the ProfileData class.

See Also

ProfileData Class
ProfileData Members
Sitecore.Analytics.Data Namespace


ProfileData Constructor

[image]

Sitecore 6.4.1 API
ProfileData Constructor
ProfileData Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public ProfileData()
Visual Basic
Public Sub New
Visual C++
public:
ProfileData()

See Also

ProfileData Class
ProfileData Overload
Sitecore.Analytics.Data Namespace


ProfileData Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
ProfileData Constructor (SerializationInfo, StreamingContext)
ProfileData Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected ProfileData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
ProfileData(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

ProfileData Class
ProfileData Overload
Sitecore.Analytics.Data Namespace


Add Method

[image]

Sitecore 6.4.1 API
ProfileData..::..Add Method
ProfileData Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void Add(
    ProfileKeyData profileKeyData
)
Visual Basic
Public Sub Add ( _
    profileKeyData As ProfileKeyData _
)
Visual C++
public:
void Add(
    ProfileKeyData^ profileKeyData
)

Parameters

profileKeyData
Type: Sitecore.Analytics.Data..::..ProfileKeyData
The profile key data.

See Also

ProfileData Class
Sitecore.Analytics.Data Namespace


AddProfileKeyValue Method

[image]

Sitecore 6.4.1 API
ProfileData..::..AddProfileKeyValue Method
ProfileData Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int AddProfileKeyValue(
    string name,
    int value
)
Visual Basic
Public Function AddProfileKeyValue ( _
    name As String, _
    value As Integer _
) As Integer
Visual C++
public:
int AddProfileKeyValue(
    String^ name,
    int value
)

Parameters

name
Type: System..::..String
The name of the profile key.
value
Type: System..::..Int32
The value.

Return Value

Returns the int32.

See Also

ProfileData Class
Sitecore.Analytics.Data Namespace


GetEnumerator Method

[image]

Sitecore 6.4.1 API
ProfileData..::..GetEnumerator Method
ProfileData Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public IEnumerator<ProfileKeyData> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of ProfileKeyData)
Visual C++
public:
virtual IEnumerator<ProfileKeyData^>^ GetEnumerator() sealed

Return Value

A IEnumerator<(Of <(<'T>)>)> that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

ProfileData Class
Sitecore.Analytics.Data Namespace


GetObjectData Method

[image]

Sitecore 6.4.1 API
ProfileData..::..GetObjectData Method
ProfileData Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System.Security..::..SecurityException | The caller does not have the required permission.

See Also

ProfileData Class
Sitecore.Analytics.Data Namespace


GetProfileKey Method

[image]

Sitecore 6.4.1 API
ProfileData..::..GetProfileKey Method
ProfileData Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public ProfileKeyData GetProfileKey(
    string name
)
Visual Basic
Public Function GetProfileKey ( _
    name As String _
) As ProfileKeyData
Visual C++
public:
ProfileKeyData^ GetProfileKey(
    String^ name
)

Parameters

name
Type: System..::..String
The name of the profile key.

Return Value

Returns the profile key data.

See Also

ProfileData Class
Sitecore.Analytics.Data Namespace


GetProfileKeyValue Method

[image]

Sitecore 6.4.1 API
ProfileData..::..GetProfileKeyValue Method
ProfileData Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int GetProfileKeyValue(
    string name
)
Visual Basic
Public Function GetProfileKeyValue ( _
    name As String _
) As Integer
Visual C++
public:
int GetProfileKeyValue(
    String^ name
)

Parameters

name
Type: System..::..String
The name of profile key.

Return Value

Returns the value.

See Also

ProfileData Class
Sitecore.Analytics.Data Namespace


ProfileData Properties

[image] [image]

Sitecore 6.4.1 API
ProfileData Properties
ProfileData Class See Also Send Feedback

The ProfileData type exposes the following members.

Properties

 | Name | Description
Public property | Changed | Gets or sets a value indicating whether this ProfileData is changed.
Public property | Count | Gets or sets the count.
Public property | ProfileId | Gets or sets the profile id.
Public property | ProfileName | Gets or sets the name.
Public property | Total | Gets or sets the total.

See Also

ProfileData Class
Sitecore.Analytics.Data Namespace


Changed Property

[image]

Sitecore 6.4.1 API
ProfileData..::..Changed Property
ProfileData Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public bool Changed { get; set; }
Visual Basic
Public Property Changed As Boolean
    Get
    Set
Visual C++
public:
property bool Changed {
    bool get ();
    void set (bool value);
}

Field Value

true if changed; otherwise, false.

See Also

ProfileData Class
Sitecore.Analytics.Data Namespace


Count Property

[image]

Sitecore 6.4.1 API
ProfileData..::..Count Property
ProfileData Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int Count { get; set; }
Visual Basic
Public Property Count As Integer
    Get
    Set
Visual C++
public:
property int Count {
    int get ();
    void set (int value);
}

Field Value

The count.

See Also

ProfileData Class
Sitecore.Analytics.Data Namespace


ProfileId Property

[image]

Sitecore 6.4.1 API
ProfileData..::..ProfileId Property
ProfileData Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid ProfileId { get; set; }
Visual Basic
Public Property ProfileId As Guid
    Get
    Set
Visual C++
public:
property Guid ProfileId {
    Guid get ();
    void set (Guid value);
}

Field Value

The profile id.

See Also

ProfileData Class
Sitecore.Analytics.Data Namespace


ProfileName Property

[image]

Sitecore 6.4.1 API
ProfileData..::..ProfileName Property
ProfileData Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string ProfileName { get; set; }
Visual Basic
Public Property ProfileName As String
    Get
    Set
Visual C++
public:
property String^ ProfileName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the profile.

See Also

ProfileData Class
Sitecore.Analytics.Data Namespace


Total Property

[image]

Sitecore 6.4.1 API
ProfileData..::..Total Property
ProfileData Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int Total { get; set; }
Visual Basic
Public Property Total As Integer
    Get
    Set
Visual C++
public:
property int Total {
    int get ();
    void set (int value);
}

Field Value

The total.

See Also

ProfileData Class
Sitecore.Analytics.Data Namespace


ProfileKeyData Class

[image]

Sitecore 6.4.1 API
ProfileKeyData Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
[SerializableAttribute]
public class ProfileKeyData : ISerializable
Visual Basic
<SerializableAttribute> _
Public Class ProfileKeyData _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class ProfileKeyData : ISerializable

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data..::..ProfileKeyData

See Also

ProfileKeyData Members
Sitecore.Analytics.Data Namespace


ProfileKeyData Constructor

[image] [image]

Sitecore 6.4.1 API
ProfileKeyData Constructor
ProfileKeyData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ProfileKeyData()()()() | Initializes a new instance of the ProfileKeyData class.
Protected method | ProfileKeyData(SerializationInfo, StreamingContext) | Initializes a new instance of the ProfileKeyData class.

See Also

ProfileKeyData Class
ProfileKeyData Members
Sitecore.Analytics.Data Namespace


ProfileKeyData Constructor

[image]

Sitecore 6.4.1 API
ProfileKeyData Constructor
ProfileKeyData Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public ProfileKeyData()
Visual Basic
Public Sub New
Visual C++
public:
ProfileKeyData()

See Also

ProfileKeyData Class
ProfileKeyData Overload
Sitecore.Analytics.Data Namespace


ProfileKeyData Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
ProfileKeyData Constructor (SerializationInfo, StreamingContext)
ProfileKeyData Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected ProfileKeyData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
ProfileKeyData(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

ProfileKeyData Class
ProfileKeyData Overload
Sitecore.Analytics.Data Namespace


ProfileKeyData Methods

[image] [image]

Sitecore 6.4.1 API
ProfileKeyData Methods
ProfileKeyData Class See Also Send Feedback

The ProfileKeyData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProfileKeyData Class
Sitecore.Analytics.Data Namespace


ProfileKeyData Properties

[image] [image]

Sitecore 6.4.1 API
ProfileKeyData Properties
ProfileKeyData Class See Also Send Feedback

The ProfileKeyData type exposes the following members.

Properties

 | Name | Description
Public property | Changed | Gets or sets a value indicating whether this ProfileKeyData is changed.
Public property | ProfileKeyId | Gets or sets the profile key id.
Public property | ProfileKeyName | Gets or sets the name.
Public property | Value | Gets or sets the value.

See Also

ProfileKeyData Class
Sitecore.Analytics.Data Namespace


Changed Property

[image]

Sitecore 6.4.1 API
ProfileKeyData..::..Changed Property
ProfileKeyData Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public bool Changed { get; set; }
Visual Basic
Public Property Changed As Boolean
    Get
    Set
Visual C++
public:
property bool Changed {
    bool get ();
    void set (bool value);
}

Field Value

true if changed; otherwise, false.

See Also

ProfileKeyData Class
Sitecore.Analytics.Data Namespace


ProfileKeyId Property

[image]

Sitecore 6.4.1 API
ProfileKeyData..::..ProfileKeyId Property
ProfileKeyData Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid ProfileKeyId { get; set; }
Visual Basic
Public Property ProfileKeyId As Guid
    Get
    Set
Visual C++
public:
property Guid ProfileKeyId {
    Guid get ();
    void set (Guid value);
}

Field Value

The profile key id.

See Also

ProfileKeyData Class
Sitecore.Analytics.Data Namespace


ProfileKeyName Property

[image]

Sitecore 6.4.1 API
ProfileKeyData..::..ProfileKeyName Property
ProfileKeyData Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string ProfileKeyName { get; set; }
Visual Basic
Public Property ProfileKeyName As String
    Get
    Set
Visual C++
public:
property String^ ProfileKeyName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the profile key.

See Also

ProfileKeyData Class
Sitecore.Analytics.Data Namespace


Value Property

[image]

Sitecore 6.4.1 API
ProfileKeyData..::..Value Property
ProfileKeyData Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int Value { get; set; }
Visual Basic
Public Property Value As Integer
    Get
    Set
Visual C++
public:
property int Value {
    int get ();
    void set (int value);
}

Field Value

The value.

See Also

ProfileKeyData Class
Sitecore.Analytics.Data Namespace


ProfilesDataCollection Class

[image]

Sitecore 6.4.1 API
ProfilesDataCollection Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
[SerializableAttribute]
public class ProfilesDataCollection : ISerializable,
    IEnumerable<ProfileData>, IEnumerable
Visual Basic
<SerializableAttribute> _
Public Class ProfilesDataCollection _
    Implements ISerializable, IEnumerable(Of ProfileData),  _
    IEnumerable
Visual C++
[SerializableAttribute]
public ref class ProfilesDataCollection : ISerializable,
    IEnumerable<ProfileData^>, IEnumerable

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data..::..ProfilesDataCollection

See Also

ProfilesDataCollection Members
Sitecore.Analytics.Data Namespace


ProfilesDataCollection Members

[image] [image]

Sitecore 6.4.1 API
ProfilesDataCollection Members
ProfilesDataCollection Class Constructors Methods See Also Send Feedback

The ProfilesDataCollection type exposes the following members.

Constructors

 | Name | Description
Public method | ProfilesDataCollection()()()() | Initializes a new instance of the ProfilesDataCollection class.
Protected method | ProfilesDataCollection(SerializationInfo, StreamingContext) | Initializes a new instance of the ProfilesDataCollection class.

Methods

 | Name | Description
Public method | Add | Adds the specified profile data.
Public method | AddProfile | Adds the profile.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetProfile | Gets the profile.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | Convert<(Of <<'(ProfileData, TTo>)>>) | Converts this instance. (Defined by EnumerableExtensions.)
Public Extension Method | StringConcatenate<(Of <<'(ProfileData>)>>) | Concatenate strings (Defined by IEnumerableExtensions.)

See Also

ProfilesDataCollection Class
Sitecore.Analytics.Data Namespace


ProfilesDataCollection Constructor

[image] [image]

Sitecore 6.4.1 API
ProfilesDataCollection Constructor
ProfilesDataCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ProfilesDataCollection()()()() | Initializes a new instance of the ProfilesDataCollection class.
Protected method | ProfilesDataCollection(SerializationInfo, StreamingContext) | Initializes a new instance of the ProfilesDataCollection class.

See Also

ProfilesDataCollection Class
ProfilesDataCollection Members
Sitecore.Analytics.Data Namespace


ProfilesDataCollection Constructor

[image]

Sitecore 6.4.1 API
ProfilesDataCollection Constructor
ProfilesDataCollection Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public ProfilesDataCollection()
Visual Basic
Public Sub New
Visual C++
public:
ProfilesDataCollection()

See Also

ProfilesDataCollection Class
ProfilesDataCollection Overload
Sitecore.Analytics.Data Namespace


ProfilesDataCollection Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
ProfilesDataCollection Constructor (SerializationInfo, StreamingContext)
ProfilesDataCollection Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected ProfilesDataCollection(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
ProfilesDataCollection(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

ProfilesDataCollection Class
ProfilesDataCollection Overload
Sitecore.Analytics.Data Namespace


ProfilesDataCollection Methods

[image] [image]

Sitecore 6.4.1 API
ProfilesDataCollection Methods
ProfilesDataCollection Class See Also Send Feedback

The ProfilesDataCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified profile data.
Public method | AddProfile | Adds the profile.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetProfile | Gets the profile.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | Convert<(Of <<'(ProfileData, TTo>)>>) | Converts this instance. (Defined by EnumerableExtensions.)
Public Extension Method | StringConcatenate<(Of <<'(ProfileData>)>>) | Concatenate strings (Defined by IEnumerableExtensions.)

See Also

ProfilesDataCollection Class
Sitecore.Analytics.Data Namespace


Add Method

[image]

Sitecore 6.4.1 API
ProfilesDataCollection..::..Add Method
ProfilesDataCollection Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void Add(
    ProfileData profileData
)
Visual Basic
Public Sub Add ( _
    profileData As ProfileData _
)
Visual C++
public:
void Add(
    ProfileData^ profileData
)

Parameters

profileData
Type: Sitecore.Analytics.Data..::..ProfileData
The profile data.

See Also

ProfilesDataCollection Class
Sitecore.Analytics.Data Namespace


AddProfile Method

[image]

Sitecore 6.4.1 API
ProfilesDataCollection..::..AddProfile Method
ProfilesDataCollection Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public ProfileData AddProfile(
    string name
)
Visual Basic
Public Function AddProfile ( _
    name As String _
) As ProfileData
Visual C++
public:
ProfileData^ AddProfile(
    String^ name
)

Parameters

name
Type: System..::..String
The name of the profile.

Return Value

Returns the profile data.

See Also

ProfilesDataCollection Class
Sitecore.Analytics.Data Namespace


GetEnumerator Method

[image]

Sitecore 6.4.1 API
ProfilesDataCollection..::..GetEnumerator Method
ProfilesDataCollection Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public IEnumerator<ProfileData> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of ProfileData)
Visual C++
public:
virtual IEnumerator<ProfileData^>^ GetEnumerator() sealed

Return Value

A IEnumerator<(Of <(<'T>)>)> that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

ProfilesDataCollection Class
Sitecore.Analytics.Data Namespace


GetObjectData Method

[image]

Sitecore 6.4.1 API
ProfilesDataCollection..::..GetObjectData Method
ProfilesDataCollection Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System.Security..::..SecurityException | The caller does not have the required permission.

See Also

ProfilesDataCollection Class
Sitecore.Analytics.Data Namespace


GetProfile Method

[image]

Sitecore 6.4.1 API
ProfilesDataCollection..::..GetProfile Method
ProfilesDataCollection Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public ProfileData GetProfile(
    string name
)
Visual Basic
Public Function GetProfile ( _
    name As String _
) As ProfileData
Visual C++
public:
ProfileData^ GetProfile(
    String^ name
)

Parameters

name
Type: System..::..String
The name of the profile.

Return Value

Returns the profile data.

See Also

ProfilesDataCollection Class
Sitecore.Analytics.Data Namespace


TrackingFieldProcessor Class

[image]

Sitecore 6.4.1 API
TrackingFieldProcessor Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class TrackingFieldProcessor
Visual Basic
Public Class TrackingFieldProcessor
Visual C++
public ref class TrackingFieldProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data..::..TrackingFieldProcessor

See Also

TrackingFieldProcessor Members
Sitecore.Analytics.Data Namespace


TrackingFieldProcessor Members

[image] [image]

Sitecore 6.4.1 API
TrackingFieldProcessor Members
TrackingFieldProcessor Class Constructors Methods See Also Send Feedback

The TrackingFieldProcessor type exposes the following members.

Constructors

 | Name | Description
Public method | TrackingFieldProcessor | Initializes a new instance of the TrackingFieldProcessor class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the item.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TrackingFieldProcessor Class
Sitecore.Analytics.Data Namespace


TrackingFieldProcessor Constructor

[image]

Sitecore 6.4.1 API
TrackingFieldProcessor Constructor
TrackingFieldProcessor Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public TrackingFieldProcessor()
Visual Basic
Public Sub New
Visual C++
public:
TrackingFieldProcessor()

See Also

TrackingFieldProcessor Class
Sitecore.Analytics.Data Namespace


TrackingFieldProcessor Methods

[image] [image]

Sitecore 6.4.1 API
TrackingFieldProcessor Methods
TrackingFieldProcessor Class See Also Send Feedback

The TrackingFieldProcessor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the item.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TrackingFieldProcessor Class
Sitecore.Analytics.Data Namespace


Process Method

[image]

Sitecore 6.4.1 API
TrackingFieldProcessor..::..Process Method
TrackingFieldProcessor Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void Process(
    Item item
)
Visual Basic
Public Sub Process ( _
    item As Item _
)
Visual C++
public:
void Process(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item to process.

See Also

TrackingFieldProcessor Class
Sitecore.Analytics.Data Namespace


UpdateVisitorIdentificationSubmitter Class

[image]

Sitecore 6.4.1 API
UpdateVisitorIdentificationSubmitter Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class UpdateVisitorIdentificationSubmitter : IDatabaseSubmittable
Visual Basic
Public Class UpdateVisitorIdentificationSubmitter _
    Implements IDatabaseSubmittable
Visual C++
public ref class UpdateVisitorIdentificationSubmitter : IDatabaseSubmittable

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data..::..UpdateVisitorIdentificationSubmitter

See Also

UpdateVisitorIdentificationSubmitter Members
Sitecore.Analytics.Data Namespace


UpdateVisitorIdentificationSubmitter Members

[image] [image]

Sitecore 6.4.1 API
UpdateVisitorIdentificationSubmitter Members
UpdateVisitorIdentificationSubmitter Class Constructors Methods Properties See Also Send Feedback

The UpdateVisitorIdentificationSubmitter type exposes the following members.

Constructors

 | Name | Description
Public method | UpdateVisitorIdentificationSubmitter | Initializes a new instance of the UpdateVisitorIdentificationSubmitter class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Submit | Submits this instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | SessionId | Gets the session id.

See Also

UpdateVisitorIdentificationSubmitter Class
Sitecore.Analytics.Data Namespace


UpdateVisitorIdentificationSubmitter Constructor

[image]

Sitecore 6.4.1 API
UpdateVisitorIdentificationSubmitter Constructor
UpdateVisitorIdentificationSubmitter Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public UpdateVisitorIdentificationSubmitter(
    Guid sessionId
)
Visual Basic
Public Sub New ( _
    sessionId As Guid _
)
Visual C++
public:
UpdateVisitorIdentificationSubmitter(
    Guid sessionId
)

Parameters

sessionId
Type: System..::..Guid
The session id.

See Also

UpdateVisitorIdentificationSubmitter Class
Sitecore.Analytics.Data Namespace


UpdateVisitorIdentificationSubmitter Methods

[image] [image]

Sitecore 6.4.1 API
UpdateVisitorIdentificationSubmitter Methods
UpdateVisitorIdentificationSubmitter Class See Also Send Feedback

The UpdateVisitorIdentificationSubmitter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Submit | Submits this instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UpdateVisitorIdentificationSubmitter Class
Sitecore.Analytics.Data Namespace


UpdateVisitorIdentificationSubmitter Properties

[image] [image]

Sitecore 6.4.1 API
UpdateVisitorIdentificationSubmitter Properties
UpdateVisitorIdentificationSubmitter Class See Also Send Feedback

The UpdateVisitorIdentificationSubmitter type exposes the following members.

Properties

 | Name | Description
Public property | SessionId | Gets the session id.

See Also

UpdateVisitorIdentificationSubmitter Class
Sitecore.Analytics.Data Namespace


SessionId Property

[image]

Sitecore 6.4.1 API
UpdateVisitorIdentificationSubmitter..::..SessionId Property
UpdateVisitorIdentificationSubmitter Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid SessionId { get; }
Visual Basic
Public ReadOnly Property SessionId As Guid
    Get
Visual C++
public:
property Guid SessionId {
    Guid get ();
}

Field Value

The session id.

See Also

UpdateVisitorIdentificationSubmitter Class
Sitecore.Analytics.Data Namespace


VisitorIdentification Class

[image]

Sitecore 6.4.1 API
VisitorIdentification Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static class VisitorIdentification
Visual Basic
Public NotInheritable Class VisitorIdentification
Visual C++
public ref class VisitorIdentification abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data..::..VisitorIdentification

See Also

VisitorIdentification Members
Sitecore.Analytics.Data Namespace


VisitorIdentification Members

[image] [image]

Sitecore 6.4.1 API
VisitorIdentification Members
VisitorIdentification Class Methods See Also Send Feedback

The VisitorIdentification type exposes the following members.

Methods

Name | Description
DoNotAutoDetectVisitorAsRobot | Executes the not auto detect visitor as robot event.
UpdateVisitorIdentification | Updates the visitor identification.
UpdateVisitorIdentifications | Updates the visitor identifications.

See Also

VisitorIdentification Class
Sitecore.Analytics.Data Namespace


VisitorIdentification Methods

[image] [image]

Sitecore 6.4.1 API
VisitorIdentification Methods
VisitorIdentification Class See Also Send Feedback

The VisitorIdentification type exposes the following members.

Methods

Name | Description
DoNotAutoDetectVisitorAsRobot | Executes the not auto detect visitor as robot event.
UpdateVisitorIdentification | Updates the visitor identification.
UpdateVisitorIdentifications | Updates the visitor identifications.

See Also

VisitorIdentification Class
Sitecore.Analytics.Data Namespace


DoNotAutoDetectVisitorAsRobot Method

[image]

Sitecore 6.4.1 API
VisitorIdentification..::..DoNotAutoDetectVisitorAsRobot Method
VisitorIdentification Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void DoNotAutoDetectVisitorAsRobot()
Visual Basic
Public Shared Sub DoNotAutoDetectVisitorAsRobot
Visual C++
public:
static void DoNotAutoDetectVisitorAsRobot()

See Also

VisitorIdentification Class
Sitecore.Analytics.Data Namespace


UpdateVisitorIdentification Method

[image]

Sitecore 6.4.1 API
VisitorIdentification..::..UpdateVisitorIdentification Method
VisitorIdentification Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void UpdateVisitorIdentification(
    Guid ipOwnerId
)
Visual Basic
Public Shared Sub UpdateVisitorIdentification ( _
    ipOwnerId As Guid _
)
Visual C++
public:
static void UpdateVisitorIdentification(
    Guid ipOwnerId
)

Parameters

ipOwnerId
Type: System..::..Guid
The ip owner id.

See Also

VisitorIdentification Class
Sitecore.Analytics.Data Namespace


UpdateVisitorIdentifications Method

[image]

Sitecore 6.4.1 API
VisitorIdentification..::..UpdateVisitorIdentifications Method
VisitorIdentification Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void UpdateVisitorIdentifications()
Visual Basic
Public Shared Sub UpdateVisitorIdentifications
Visual C++
public:
static void UpdateVisitorIdentifications()

See Also

VisitorIdentification Class
Sitecore.Analytics.Data Namespace


Sitecore.Analytics.Data.DataProviders Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Analytics.Data.DataProviders Namespace
Send Feedback

Classes

 | Class | Description
Public class | AnalyticsProvider | Defines the analytics provider class.
Public class | AnalyticsProviderCollection | AnalyticsProviderCollection class
Public class | AnalyticsProviderSqlServer | Analytics provider for Microsoft SQL Server


AnalyticsProvider Class

[image]

Sitecore 6.4.1 API
AnalyticsProvider Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract class AnalyticsProvider : ProviderBase
Visual Basic
Public MustInherit Class AnalyticsProvider _
    Inherits ProviderBase
Visual C++
public ref class AnalyticsProvider abstract : public ProviderBase

Inheritance Hierarchy

System..::..Object
System.Configuration.Provider..::..ProviderBase
Sitecore.Analytics.Data.DataProviders..::..AnalyticsProvider
Sitecore.Analytics.Data.DataProviders..::..AnalyticsProviderSqlServer

See Also

AnalyticsProvider Members
Sitecore.Analytics.Data.DataProviders Namespace


AnalyticsProvider Members

[image] [image]

Sitecore 6.4.1 API
AnalyticsProvider Members
AnalyticsProvider Class Constructors Methods Fields Properties See Also Send Feedback

The AnalyticsProvider type exposes the following members.

Constructors

 | Name | Description
Protected method | AnalyticsProvider | Initializes a new instance of the AnalyticsProvider class.

Methods

 | Name | Description
Protected method | CreateReader | Creates the reader.
Public method | DeleteSubscription | Deletes the subscription.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the specified command text.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FormatBigString | Toes the char.
Public method | FormatCommandText | Formats the command text.
Public method | FormatFunctionName | Formats the name of the function.
Public method | GetAddIpIdByAddressFrom | Gets the ip ID by address from.
Public method | GetAddIpOwnerIdByNameAndCountry | Gets the IP owner id.
Public method | GetBrowserById | Gets the browser by id.
Public method | GetBrowserIdByUserAgent | Gets the browser by user agent.
Public method | GetBrowsers | Gets the browsers.
Public method | GetCampaignById | Gets the campaign by id.
Public method | GetCampaignEventById | Gets the campaign event by id.
Public method | GetCampaignEvents | Gets the campaign events.
Public method | GetCampaignEventsByCampaignId | Gets the campaign events by campaign id.
Public method | GetCampaigns | Gets the campaigns.
Public method | GetConnectionString | Gets the connection string.
Public method | GetDateTime | Gets the date time.
Public method | GetDouble | Gets the double.
Public method | GetGlobalSessionById | Gets the global session by id.
Public method | GetGlobalSessionIdByCookieValue | Gets the global session id by cookie value.
Public method | GetGlobalSessions | Gets the global sessions.
Public method | GetGuid | Gets the GUID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInt | Gets the int.
Public method | GetIPById | Gets the IP by id.
Public method | GetIPBySessionId | Gets the IP by session id.
Public method | GetIpOwnerById | Gets the ip owner by id.
Public method | GetIpOwnerBySessionId | Gets the ip owner by session id.
Public method | GetIpOwnerIdsBySessionId | Gets the ip owner ids by session id.
Public method | GetIPs | Gets the I ps.
Public method | GetIPsByOwnerId | Gets the IPs by owner id.
Public method | GetKeywordIdByKeywords | Gets the keyword id by keywords.
Public method | GetKeywordsBySessionId | Gets the keywords by session id.
Public method | GetLong | Gets the big int.
Public method | GetLookupData | Gets the lookup data.
Public method | GetMatchReportQueryPattern | Gets the match report query pattern.
Public method | GetMultiVarianceTestDefinitionById | Gets the multi variance test definition by id.
Public method | GetMultiVarianceTestDefinitions | Gets the multi variance test definitions.
Public method | GetMultiVarianceTestVariableById | Gets the multi variance test variable by id.
Public method | GetMultiVarianceTestVariablesByTestDefinitionId | Gets the multi variance test variables by test definition id.
Public method | GetOperatingSystemById | Gets the operating system by id.
Public method | GetOperatingSystems | Gets the operating systems.
Public method | GetPageById | Gets the page by id.
Public method | GetPageBySessionIdAndPageNo | Gets the page by session id and page no.
Public method | GetPageEventById | Gets the page event by id.
Public method | GetPageEventDefinitionById | Gets the page event definition by id.
Public method | GetPageEventDefinitionFailureNotSystem | Gets the page event definition failure system.
Public method | GetPageEventDefinitionNotGoalNotFailureNotSystem | Gets the page event definition goal failure not system.
Public method | GetPageEventDefinitions | Gets the page event definitions.
Public method | GetPageEventDefinitionsIsGoalNotSystem | Gets the page event definitions is goal not system.
Public method | GetPageEventsByPageId | Gets the page events by page id.
Public method | GetPagesBySessionId | Gets the pages by session id.
Public method | GetProfileById | Gets the profile by id.
Public method | GetProfileDefinitionById | Gets the profile definition by id.
Public method | GetProfileDefinitions | Gets the profile definitions.
Public method | GetProfileKeyDefinitionById | Gets the profile key definition by id.
Public method | GetProfileKeyDefinitions | Gets the profile key definitions.
Public method | GetProfileKeyDefinitionsById | Gets the profile key definitions by profile definition id.
Public method | GetProfileKeysByProfileId | Gets the profile keys by profile id.
Public method | GetProfilesBySessionId | Gets the profiles by session id.
Public method | GetReferringSiteByUrl | Gets the referring site by URL.
Public method | GetReferringSites | Gets the referring sites.
Public method | GetReportsDatabase | Gets the reports database.
Public method | GetReportsDataSourceType | Gets the type of the reports data source.
Public method | GetScreenByScreenId | Gets the screen by screen id.
Public method | GetScreens | Gets the screens.
Public method | GetSessionByAspNetSessionId | Gets the session by ASP net session id.
Public method | GetSessionBySessionId | Gets the session by session id.
Public method | GetSessionIdByAspNetSessionId | Gets the session id by ASP net session id.
Public method | GetStatusById | Gets the status.
Public method | GetStatuses | Gets the statuses.
Public method | GetString | Gets the string.
Public method | GetSubscription | Gets the subscription.
Public method | GetSubscriptionById | Gets the subscription by id.
Public method | GetTagById | Gets the tag by id.
Public method | GetTagsByGlobalSessionId | Gets the tags by global session id.
Public method | GetTotalByGlobalSessionId | Gets the total by global session id.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVendorSpecificReportPath | Gets the vendor specific report path.
Public method | GuidToRawString | GUIDs to raw string.
Public method | Initialize | Initializes the provider. (Inherited from ProviderBase.)
Public method | InsertBrowser | Inserts the browser.
Public method | InsertCampaign | Inserts the campaign.
Public method | InsertCampaignEvent | Inserts the campaign event.
Public method | InsertCampaignEventPage | Inserts the campaign event page.
Public method | InsertGlobalSession | Inserts the global session.
Public method | InsertIPOwner | Inserts the IP owner.
Public method | InsertKeyword | Inserts the keyword.
Public method | InsertMultiVarianceTestDefinition(Guid, String, String) | Inserts the multi variance test definition.
Public method | InsertMultiVarianceTestDefinition(String, String, Guid) | Inserts the multi variance test definition.
Public method | InsertMultiVarianceTestVariable | Inserts the multi variance test variable.
Public method | InsertMultiVarianceTestVariableCampaignEvent | Inserts the multi variance test variable campaign event.
Public method | InsertMultiVarianceTestVariablePage | Inserts the multi variance test variable page.
Public method | InsertOperatingSystem | Inserts the operating system.
Public method | InsertPage | Inserts the page.
Public method | InsertPageEvent | Inserts the page event.
Public method | InsertPageEventDefinition | Inserts the page event definition.
Public method | InsertProfile | Inserts the profile.
Public method | InsertProfileDefinition | Inserts the profile definition.
Public method | InsertProfileKey | Inserts the profile key.
Public method | InsertProfileKeyDefinition | Inserts the profile key definition.
Public method | InsertReferringSite | Inserts the referring site.
Public method | InsertScreen | Inserts the screen.
Public method | InsertSession | Inserts the session.
Public method | InsertSubscription | Inserts the subscription.
Public method | InsertTag | Inserts the tag.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RawStringToGuid | Raws the string to GUID.
Protected method | ReadIP | Reads the IP.
Protected method | ReadIPOwner | Reads the IP owner.
Public method | ReadMany<(Of <<'(T>)>>)(String, Func<(Of <<'(DataProviderReader, T>)>>), array<Object>[]()[][]) | Reads the specified command text.
Public method | ReadMany<(Of <<'(T>)>>)(String, Func<(Of <<'(DataProviderReader, T>)>>), Int32, array<Object>[]()[][]) | Reads the specified command text.
Public method | ReadOne<(Of <<'(T>)>>)(String, Func<(Of <<'(DataProviderReader, T>)>>), array<Object>[]()[][]) | Reads the one.
Public method | ReadOne<(Of <<'(T>)>>)(String, Func<(Of <<'(DataProviderReader, T>)>>), Func<(Of <<'(T>)>>), array<Object>[]()[][]) | Reads the specified command text.
Protected method | ReadProfile | Reads the profile.
Public method | SaveCampaignDefinition | Saves the campaign.
Public method | SaveCampaignEvent | Saves the campaign event.
Public method | SaveMultiVarianceTestDefinition | Saves the multi variance test.
Public method | SaveMultiVarianceTestVariable | Saves the multi variance test variable.
Public method | SavePageEventDefinition | Saves the page event definition.
Public method | SaveProfileDefinition | Saves the profile definition.
Public method | SaveProfileKeyDefinition | Saves the profile key definition.
Public method | SetStatusFailed | Sets the status failed.
Public method | SetStatusSuccessful | Sets the status successful.
Public method | Submit | Commits this instance.
Public method | SubmitTracker | Submits the tracker.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateBothIdentificationsBySessionId | Updates the both identifications by session id.
Public method | UpdateBrowser | Updates the browser.
Public method | UpdateCampaign | Updates the campaign.
Public method | UpdateCampaignEvent | Updates the campaign event.
Public method | UpdateCountTotalByProfileId | Updates the count total by profile id.
Public method | UpdateCurrentPageBySessionId | Updates the current page by session id.
Public method | UpdateGlobalSession | Updates the global session.
Public method | UpdateIP | Updates the IP.
Public method | UpdateIpInformation(Guid, WhoIsInformation) | Updates the ip information with default post step action.
Public method | UpdateIpInformation(Guid, WhoIsInformation, Action<(Of <<'(IP>)>>)) | Updates the ip information.
Public method | UpdateIPOwner | Updates the IP owner.
Public method | UpdateMultiVarianceTestDefinition | Updates the multi variance test definition.
Public method | UpdatePage(Guid, DateTime, Int32, Int32, Guid, String, Int32, Guid, String, String, String, String) | Updates the page.
Public method | UpdatePage(Guid, Guid, DateTime, Int32, Int32, Guid, String, Int32, Guid, String, String, String, String) | Updates the page.
Public method | UpdateProfileKey | Updates the profile key.
Public method | UpdateVisitorIdentificationByIpOwnerId | Updates the visitor identification by ip order id.
Public method | UpdateVisitorIdentificationBySessionId | Updates the visitor identification by session id.
Public method | UpdateVisitorIdentifications | Updates the visitor identifications.
Public method | UpdateVisitorIdentificationsByIPOwnerBrowser | Updates the visitor identifications by IP owner browser.

Fields

 | Name | Description
Protected field | DataApi | Data access API using pseudo SQL

Properties

 | Name | Description
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


AnalyticsProvider Constructor

[image]

Sitecore 6.4.1 API
AnalyticsProvider Constructor
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected AnalyticsProvider(
    SqlDataApi sqlDataApi
)
Visual Basic
Protected Sub New ( _
    sqlDataApi As SqlDataApi _
)
Visual C++
protected:
AnalyticsProvider(
    SqlDataApi^ sqlDataApi
)

Parameters

sqlDataApi
Type: Sitecore.Data.DataProviders.Sql..::..SqlDataApi
The SQL data API.

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


AnalyticsProvider Fields

[image] [image]

Sitecore 6.4.1 API
AnalyticsProvider Fields
AnalyticsProvider Class See Also Send Feedback

The AnalyticsProvider type exposes the following members.

Fields

 | Name | Description
Protected field | DataApi | Data access API using pseudo SQL

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


DataApi Field

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..DataApi Field
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected readonly SqlDataApi DataApi
Visual Basic
Protected ReadOnly DataApi As SqlDataApi
Visual C++
protected:
initonly SqlDataApi^ DataApi

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


AnalyticsProvider Methods

[image] [image]

Sitecore 6.4.1 API
AnalyticsProvider Methods
AnalyticsProvider Class See Also Send Feedback

The AnalyticsProvider type exposes the following members.

Methods

 | Name | Description
Protected method | CreateReader | Creates the reader.
Public method | DeleteSubscription | Deletes the subscription.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the specified command text.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FormatBigString | Toes the char.
Public method | FormatCommandText | Formats the command text.
Public method | FormatFunctionName | Formats the name of the function.
Public method | GetAddIpIdByAddressFrom | Gets the ip ID by address from.
Public method | GetAddIpOwnerIdByNameAndCountry | Gets the IP owner id.
Public method | GetBrowserById | Gets the browser by id.
Public method | GetBrowserIdByUserAgent | Gets the browser by user agent.
Public method | GetBrowsers | Gets the browsers.
Public method | GetCampaignById | Gets the campaign by id.
Public method | GetCampaignEventById | Gets the campaign event by id.
Public method | GetCampaignEvents | Gets the campaign events.
Public method | GetCampaignEventsByCampaignId | Gets the campaign events by campaign id.
Public method | GetCampaigns | Gets the campaigns.
Public method | GetConnectionString | Gets the connection string.
Public method | GetDateTime | Gets the date time.
Public method | GetDouble | Gets the double.
Public method | GetGlobalSessionById | Gets the global session by id.
Public method | GetGlobalSessionIdByCookieValue | Gets the global session id by cookie value.
Public method | GetGlobalSessions | Gets the global sessions.
Public method | GetGuid | Gets the GUID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInt | Gets the int.
Public method | GetIPById | Gets the IP by id.
Public method | GetIPBySessionId | Gets the IP by session id.
Public method | GetIpOwnerById | Gets the ip owner by id.
Public method | GetIpOwnerBySessionId | Gets the ip owner by session id.
Public method | GetIpOwnerIdsBySessionId | Gets the ip owner ids by session id.
Public method | GetIPs | Gets the I ps.
Public method | GetIPsByOwnerId | Gets the IPs by owner id.
Public method | GetKeywordIdByKeywords | Gets the keyword id by keywords.
Public method | GetKeywordsBySessionId | Gets the keywords by session id.
Public method | GetLong | Gets the big int.
Public method | GetLookupData | Gets the lookup data.
Public method | GetMatchReportQueryPattern | Gets the match report query pattern.
Public method | GetMultiVarianceTestDefinitionById | Gets the multi variance test definition by id.
Public method | GetMultiVarianceTestDefinitions | Gets the multi variance test definitions.
Public method | GetMultiVarianceTestVariableById | Gets the multi variance test variable by id.
Public method | GetMultiVarianceTestVariablesByTestDefinitionId | Gets the multi variance test variables by test definition id.
Public method | GetOperatingSystemById | Gets the operating system by id.
Public method | GetOperatingSystems | Gets the operating systems.
Public method | GetPageById | Gets the page by id.
Public method | GetPageBySessionIdAndPageNo | Gets the page by session id and page no.
Public method | GetPageEventById | Gets the page event by id.
Public method | GetPageEventDefinitionById | Gets the page event definition by id.
Public method | GetPageEventDefinitionFailureNotSystem | Gets the page event definition failure system.
Public method | GetPageEventDefinitionNotGoalNotFailureNotSystem | Gets the page event definition goal failure not system.
Public method | GetPageEventDefinitions | Gets the page event definitions.
Public method | GetPageEventDefinitionsIsGoalNotSystem | Gets the page event definitions is goal not system.
Public method | GetPageEventsByPageId | Gets the page events by page id.
Public method | GetPagesBySessionId | Gets the pages by session id.
Public method | GetProfileById | Gets the profile by id.
Public method | GetProfileDefinitionById | Gets the profile definition by id.
Public method | GetProfileDefinitions | Gets the profile definitions.
Public method | GetProfileKeyDefinitionById | Gets the profile key definition by id.
Public method | GetProfileKeyDefinitions | Gets the profile key definitions.
Public method | GetProfileKeyDefinitionsById | Gets the profile key definitions by profile definition id.
Public method | GetProfileKeysByProfileId | Gets the profile keys by profile id.
Public method | GetProfilesBySessionId | Gets the profiles by session id.
Public method | GetReferringSiteByUrl | Gets the referring site by URL.
Public method | GetReferringSites | Gets the referring sites.
Public method | GetReportsDatabase | Gets the reports database.
Public method | GetReportsDataSourceType | Gets the type of the reports data source.
Public method | GetScreenByScreenId | Gets the screen by screen id.
Public method | GetScreens | Gets the screens.
Public method | GetSessionByAspNetSessionId | Gets the session by ASP net session id.
Public method | GetSessionBySessionId | Gets the session by session id.
Public method | GetSessionIdByAspNetSessionId | Gets the session id by ASP net session id.
Public method | GetStatusById | Gets the status.
Public method | GetStatuses | Gets the statuses.
Public method | GetString | Gets the string.
Public method | GetSubscription | Gets the subscription.
Public method | GetSubscriptionById | Gets the subscription by id.
Public method | GetTagById | Gets the tag by id.
Public method | GetTagsByGlobalSessionId | Gets the tags by global session id.
Public method | GetTotalByGlobalSessionId | Gets the total by global session id.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVendorSpecificReportPath | Gets the vendor specific report path.
Public method | GuidToRawString | GUIDs to raw string.
Public method | Initialize | Initializes the provider. (Inherited from ProviderBase.)
Public method | InsertBrowser | Inserts the browser.
Public method | InsertCampaign | Inserts the campaign.
Public method | InsertCampaignEvent | Inserts the campaign event.
Public method | InsertCampaignEventPage | Inserts the campaign event page.
Public method | InsertGlobalSession | Inserts the global session.
Public method | InsertIPOwner | Inserts the IP owner.
Public method | InsertKeyword | Inserts the keyword.
Public method | InsertMultiVarianceTestDefinition(Guid, String, String) | Inserts the multi variance test definition.
Public method | InsertMultiVarianceTestDefinition(String, String, Guid) | Inserts the multi variance test definition.
Public method | InsertMultiVarianceTestVariable | Inserts the multi variance test variable.
Public method | InsertMultiVarianceTestVariableCampaignEvent | Inserts the multi variance test variable campaign event.
Public method | InsertMultiVarianceTestVariablePage | Inserts the multi variance test variable page.
Public method | InsertOperatingSystem | Inserts the operating system.
Public method | InsertPage | Inserts the page.
Public method | InsertPageEvent | Inserts the page event.
Public method | InsertPageEventDefinition | Inserts the page event definition.
Public method | InsertProfile | Inserts the profile.
Public method | InsertProfileDefinition | Inserts the profile definition.
Public method | InsertProfileKey | Inserts the profile key.
Public method | InsertProfileKeyDefinition | Inserts the profile key definition.
Public method | InsertReferringSite | Inserts the referring site.
Public method | InsertScreen | Inserts the screen.
Public method | InsertSession | Inserts the session.
Public method | InsertSubscription | Inserts the subscription.
Public method | InsertTag | Inserts the tag.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RawStringToGuid | Raws the string to GUID.
Protected method | ReadIP | Reads the IP.
Protected method | ReadIPOwner | Reads the IP owner.
Public method | ReadMany<(Of <<'(T>)>>)(String, Func<(Of <<'(DataProviderReader, T>)>>), array<Object>[]()[][]) | Reads the specified command text.
Public method | ReadMany<(Of <<'(T>)>>)(String, Func<(Of <<'(DataProviderReader, T>)>>), Int32, array<Object>[]()[][]) | Reads the specified command text.
Public method | ReadOne<(Of <<'(T>)>>)(String, Func<(Of <<'(DataProviderReader, T>)>>), array<Object>[]()[][]) | Reads the one.
Public method | ReadOne<(Of <<'(T>)>>)(String, Func<(Of <<'(DataProviderReader, T>)>>), Func<(Of <<'(T>)>>), array<Object>[]()[][]) | Reads the specified command text.
Protected method | ReadProfile | Reads the profile.
Public method | SaveCampaignDefinition | Saves the campaign.
Public method | SaveCampaignEvent | Saves the campaign event.
Public method | SaveMultiVarianceTestDefinition | Saves the multi variance test.
Public method | SaveMultiVarianceTestVariable | Saves the multi variance test variable.
Public method | SavePageEventDefinition | Saves the page event definition.
Public method | SaveProfileDefinition | Saves the profile definition.
Public method | SaveProfileKeyDefinition | Saves the profile key definition.
Public method | SetStatusFailed | Sets the status failed.
Public method | SetStatusSuccessful | Sets the status successful.
Public method | Submit | Commits this instance.
Public method | SubmitTracker | Submits the tracker.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateBothIdentificationsBySessionId | Updates the both identifications by session id.
Public method | UpdateBrowser | Updates the browser.
Public method | UpdateCampaign | Updates the campaign.
Public method | UpdateCampaignEvent | Updates the campaign event.
Public method | UpdateCountTotalByProfileId | Updates the count total by profile id.
Public method | UpdateCurrentPageBySessionId | Updates the current page by session id.
Public method | UpdateGlobalSession | Updates the global session.
Public method | UpdateIP | Updates the IP.
Public method | UpdateIpInformation(Guid, WhoIsInformation) | Updates the ip information with default post step action.
Public method | UpdateIpInformation(Guid, WhoIsInformation, Action<(Of <<'(IP>)>>)) | Updates the ip information.
Public method | UpdateIPOwner | Updates the IP owner.
Public method | UpdateMultiVarianceTestDefinition | Updates the multi variance test definition.
Public method | UpdatePage(Guid, DateTime, Int32, Int32, Guid, String, Int32, Guid, String, String, String, String) | Updates the page.
Public method | UpdatePage(Guid, Guid, DateTime, Int32, Int32, Guid, String, Int32, Guid, String, String, String, String) | Updates the page.
Public method | UpdateProfileKey | Updates the profile key.
Public method | UpdateVisitorIdentificationByIpOwnerId | Updates the visitor identification by ip order id.
Public method | UpdateVisitorIdentificationBySessionId | Updates the visitor identification by session id.
Public method | UpdateVisitorIdentifications | Updates the visitor identifications.
Public method | UpdateVisitorIdentificationsByIPOwnerBrowser | Updates the visitor identifications by IP owner browser.

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


CreateReader Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..CreateReader Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected virtual DataProviderReader CreateReader(
    string sql,
    params Object[] parameters
)
Visual Basic
Protected Overridable Function CreateReader ( _
    sql As String, _
    ParamArray parameters As Object() _
) As DataProviderReader
Visual C++
protected:
virtual DataProviderReader^ CreateReader(
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

sql
Type: System..::..String
The SQL.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.CreateReader(System.String,System.Object[])"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


DeleteSubscription Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..DeleteSubscription Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int DeleteSubscription(
    Guid subscriptionId
)
Visual Basic
Public Function DeleteSubscription ( _
    subscriptionId As Guid _
) As Integer
Visual C++
public:
int DeleteSubscription(
    Guid subscriptionId
)

Parameters

subscriptionId
Type: System..::..Guid
The subscription id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.DeleteSubscription(System.Guid)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


Execute Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..Execute Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual int Execute(
    string commandText,
    params Object[] parameters
)
Visual Basic
Public Overridable Function Execute ( _
    commandText As String, _
    ParamArray parameters As Object() _
) As Integer
Visual C++
public:
virtual int Execute(
    String^ commandText,
    ... array<Object^>^ parameters
)

Parameters

commandText
Type: System..::..String
The command text.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.Execute(System.String,System.Object[])"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


FormatBigString Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..FormatBigString Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract string FormatBigString(
    string columnName
)
Visual Basic
Public MustOverride Function FormatBigString ( _
    columnName As String _
) As String
Visual C++
public:
virtual String^ FormatBigString(
    String^ columnName
) abstract

Parameters

columnName
Type: System..::..String
Name of the column.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.FormatBigString(System.String)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


FormatCommandText Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..FormatCommandText Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual string FormatCommandText(
    string commandText
)
Visual Basic
Public Overridable Function FormatCommandText ( _
    commandText As String _
) As String
Visual C++
public:
virtual String^ FormatCommandText(
    String^ commandText
)

Parameters

commandText
Type: System..::..String
The command text.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.FormatCommandText(System.String)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


FormatFunctionName Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..FormatFunctionName Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract string FormatFunctionName(
    string functionName
)
Visual Basic
Public MustOverride Function FormatFunctionName ( _
    functionName As String _
) As String
Visual C++
public:
virtual String^ FormatFunctionName(
    String^ functionName
) abstract

Parameters

functionName
Type: System..::..String
Name of the function.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.FormatFunctionName(System.String)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetAddIpIdByAddressFrom Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetAddIpIdByAddressFrom Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual Guid GetAddIpIdByAddressFrom(
    string ipAddressFrom
)
Visual Basic
Public Overridable Function GetAddIpIdByAddressFrom ( _
    ipAddressFrom As String _
) As Guid
Visual C++
public:
virtual Guid GetAddIpIdByAddressFrom(
    String^ ipAddressFrom
)

Parameters

ipAddressFrom
Type: System..::..String
The address from.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetAddIpIdByAddressFrom(System.String)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetAddIpOwnerIdByNameAndCountry Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetAddIpOwnerIdByNameAndCountry Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual Guid GetAddIpOwnerIdByNameAndCountry(
    string name,
    string country
)
Visual Basic
Public Overridable Function GetAddIpOwnerIdByNameAndCountry ( _
    name As String, _
    country As String _
) As Guid
Visual C++
public:
virtual Guid GetAddIpOwnerIdByNameAndCountry(
    String^ name,
    String^ country
)

Parameters

name
Type: System..::..String
The business name.
country
Type: System..::..String
The country.

Return Value

The IP owner id.

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetBrowserById Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetBrowserById Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual Browser GetBrowserById(
    Guid browserId
)
Visual Basic
Public Overridable Function GetBrowserById ( _
    browserId As Guid _
) As Browser
Visual C++
public:
virtual Browser^ GetBrowserById(
    Guid browserId
)

Parameters

browserId
Type: System..::..Guid
The browser id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetBrowserById(System.Guid)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetBrowserIdByUserAgent Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetBrowserIdByUserAgent Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual Guid GetBrowserIdByUserAgent(
    string userAgent
)
Visual Basic
Public Overridable Function GetBrowserIdByUserAgent ( _
    userAgent As String _
) As Guid
Visual C++
public:
virtual Guid GetBrowserIdByUserAgent(
    String^ userAgent
)

Parameters

userAgent
Type: System..::..String
The user agent.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetBrowserIdByUserAgent(System.String)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetBrowsers Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetBrowsers Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual List<Browser> GetBrowsers()
Visual Basic
Public Overridable Function GetBrowsers As List(Of Browser)
Visual C++
public:
virtual List<Browser^>^ GetBrowsers()

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetBrowsers"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetCampaignById Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetCampaignById Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual Campaign GetCampaignById(
    Guid campaignId
)
Visual Basic
Public Overridable Function GetCampaignById ( _
    campaignId As Guid _
) As Campaign
Visual C++
public:
virtual Campaign^ GetCampaignById(
    Guid campaignId
)

Parameters

campaignId
Type: System..::..Guid
The campaign id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetCampaignById(System.Guid)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetCampaignEventById Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetCampaignEventById Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual CampaignEvent GetCampaignEventById(
    Guid campaignEventId
)
Visual Basic
Public Overridable Function GetCampaignEventById ( _
    campaignEventId As Guid _
) As CampaignEvent
Visual C++
public:
virtual CampaignEvent^ GetCampaignEventById(
    Guid campaignEventId
)

Parameters

campaignEventId
Type: System..::..Guid
The campaign event id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetCampaignEventById(System.Guid)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetCampaignEvents Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetCampaignEvents Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual List<CampaignEvent> GetCampaignEvents()
Visual Basic
Public Overridable Function GetCampaignEvents As List(Of CampaignEvent)
Visual C++
public:
virtual List<CampaignEvent^>^ GetCampaignEvents()

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetCampaignEvents"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetCampaignEventsByCampaignId Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetCampaignEventsByCampaignId Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual List<CampaignEvent> GetCampaignEventsByCampaignId(
    Guid campaignId
)
Visual Basic
Public Overridable Function GetCampaignEventsByCampaignId ( _
    campaignId As Guid _
) As List(Of CampaignEvent)
Visual C++
public:
virtual List<CampaignEvent^>^ GetCampaignEventsByCampaignId(
    Guid campaignId
)

Parameters

campaignId
Type: System..::..Guid
The campaign id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetCampaignEventsByCampaignId(System.Guid)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetCampaigns Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetCampaigns Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual List<Campaign> GetCampaigns()
Visual Basic
Public Overridable Function GetCampaigns As List(Of Campaign)
Visual C++
public:
virtual List<Campaign^>^ GetCampaigns()

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetCampaigns"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetConnectionString Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetConnectionString Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual string GetConnectionString()
Visual Basic
Public Overridable Function GetConnectionString As String
Visual C++
public:
virtual String^ GetConnectionString()

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetConnectionString"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetDateTime Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetDateTime Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual DateTime GetDateTime(
    int columnIndex,
    DataProviderReader reader
)
Visual Basic
Public Overridable Function GetDateTime ( _
    columnIndex As Integer, _
    reader As DataProviderReader _
) As DateTime
Visual C++
public:
virtual DateTime GetDateTime(
    int columnIndex,
    DataProviderReader^ reader
)

Parameters

columnIndex
Type: System..::..Int32
Index of the column.
reader
Type: Sitecore.Data.DataProviders.Sql..::..DataProviderReader
The reader.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetDateTime(System.Int32,Sitecore.Data.DataProviders.Sql.DataProviderReader)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetDouble Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetDouble Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract double GetDouble(
    int columnIndex,
    DataProviderReader reader
)
Visual Basic
Public MustOverride Function GetDouble ( _
    columnIndex As Integer, _
    reader As DataProviderReader _
) As Double
Visual C++
public:
virtual double GetDouble(
    int columnIndex,
    DataProviderReader^ reader
) abstract

Parameters

columnIndex
Type: System..::..Int32
Index of the column.
reader
Type: Sitecore.Data.DataProviders.Sql..::..DataProviderReader
The reader.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetDouble(System.Int32,Sitecore.Data.DataProviders.Sql.DataProviderReader)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetGlobalSessionById Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetGlobalSessionById Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public GlobalSession GetGlobalSessionById(
    Guid globalSessionId
)
Visual Basic
Public Function GetGlobalSessionById ( _
    globalSessionId As Guid _
) As GlobalSession
Visual C++
public:
GlobalSession^ GetGlobalSessionById(
    Guid globalSessionId
)

Parameters

globalSessionId
Type: System..::..Guid
The global session id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetGlobalSessionById(System.Guid)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetGlobalSessionIdByCookieValue Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetGlobalSessionIdByCookieValue Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public GlobalSession GetGlobalSessionIdByCookieValue(
    string cookieValue
)
Visual Basic
Public Function GetGlobalSessionIdByCookieValue ( _
    cookieValue As String _
) As GlobalSession
Visual C++
public:
GlobalSession^ GetGlobalSessionIdByCookieValue(
    String^ cookieValue
)

Parameters

cookieValue
Type: System..::..String
The cookie value.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetGlobalSessionIdByCookieValue(System.String)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetGlobalSessions Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetGlobalSessions Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public List<GlobalSession> GetGlobalSessions()
Visual Basic
Public Function GetGlobalSessions As List(Of GlobalSession)
Visual C++
public:
List<GlobalSession^>^ GetGlobalSessions()

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetGlobalSessions"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetGuid Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetGuid Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid GetGuid(
    int columnIndex,
    DataProviderReader reader
)
Visual Basic
Public Function GetGuid ( _
    columnIndex As Integer, _
    reader As DataProviderReader _
) As Guid
Visual C++
public:
Guid GetGuid(
    int columnIndex,
    DataProviderReader^ reader
)

Parameters

columnIndex
Type: System..::..Int32
Index of the column.
reader
Type: Sitecore.Data.DataProviders.Sql..::..DataProviderReader
The reader.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetGuid(System.Int32,Sitecore.Data.DataProviders.Sql.DataProviderReader)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetInt Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetInt Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual int GetInt(
    int columnIndex,
    DataProviderReader reader
)
Visual Basic
Public Overridable Function GetInt ( _
    columnIndex As Integer, _
    reader As DataProviderReader _
) As Integer
Visual C++
public:
virtual int GetInt(
    int columnIndex,
    DataProviderReader^ reader
)

Parameters

columnIndex
Type: System..::..Int32
Index of the column.
reader
Type: Sitecore.Data.DataProviders.Sql..::..DataProviderReader
The reader.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetInt(System.Int32,Sitecore.Data.DataProviders.Sql.DataProviderReader)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetIPById Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetIPById Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual IP GetIPById(
    Guid ipId
)
Visual Basic
Public Overridable Function GetIPById ( _
    ipId As Guid _
) As IP
Visual C++
public:
virtual IP^ GetIPById(
    Guid ipId
)

Parameters

ipId
Type: System..::..Guid
The ip id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetIPById(System.Guid)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetIPBySessionId Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetIPBySessionId Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual IP GetIPBySessionId(
    Guid sessionId
)
Visual Basic
Public Overridable Function GetIPBySessionId ( _
    sessionId As Guid _
) As IP
Visual C++
public:
virtual IP^ GetIPBySessionId(
    Guid sessionId
)

Parameters

sessionId
Type: System..::..Guid
The session id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetIPBySessionId(System.Guid)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetIpOwnerById Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetIpOwnerById Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual IPOwner GetIpOwnerById(
    Guid ipOwnerId
)
Visual Basic
Public Overridable Function GetIpOwnerById ( _
    ipOwnerId As Guid _
) As IPOwner
Visual C++
public:
virtual IPOwner^ GetIpOwnerById(
    Guid ipOwnerId
)

Parameters

ipOwnerId
Type: System..::..Guid
The ip owner id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetIpOwnerById(System.Guid)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetIpOwnerBySessionId Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetIpOwnerBySessionId Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual IPOwner GetIpOwnerBySessionId(
    Guid sessionId
)
Visual Basic
Public Overridable Function GetIpOwnerBySessionId ( _
    sessionId As Guid _
) As IPOwner
Visual C++
public:
virtual IPOwner^ GetIpOwnerBySessionId(
    Guid sessionId
)

Parameters

sessionId
Type: System..::..Guid
The session id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetIpOwnerBySessionId(System.Guid)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetIpOwnerIdsBySessionId Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetIpOwnerIdsBySessionId Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual List<Guid> GetIpOwnerIdsBySessionId(
    Guid sessionId
)
Visual Basic
Public Overridable Function GetIpOwnerIdsBySessionId ( _
    sessionId As Guid _
) As List(Of Guid)
Visual C++
public:
virtual List<Guid>^ GetIpOwnerIdsBySessionId(
    Guid sessionId
)

Parameters

sessionId
Type: System..::..Guid
The session id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetIpOwnerIdsBySessionId(System.Guid)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetIPs Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetIPs Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual List<LookupData> GetIPs(
    int maxEntries
)
Visual Basic
Public Overridable Function GetIPs ( _
    maxEntries As Integer _
) As List(Of LookupData)
Visual C++
public:
virtual List<LookupData^>^ GetIPs(
    int maxEntries
)

Parameters

maxEntries
Type: System..::..Int32
The max entries.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetIPs(System.Int32)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetIPsByOwnerId Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetIPsByOwnerId Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual List<LookupData> GetIPsByOwnerId(
    int maxEntries,
    Guid ipOwnerId
)
Visual Basic
Public Overridable Function GetIPsByOwnerId ( _
    maxEntries As Integer, _
    ipOwnerId As Guid _
) As List(Of LookupData)
Visual C++
public:
virtual List<LookupData^>^ GetIPsByOwnerId(
    int maxEntries,
    Guid ipOwnerId
)

Parameters

maxEntries
Type: System..::..Int32
The max entries.
ipOwnerId
Type: System..::..Guid
The ip owner id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetIPsByOwnerId(System.Int32,System.Guid)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetKeywordIdByKeywords Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetKeywordIdByKeywords Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual Guid GetKeywordIdByKeywords(
    string keywords
)
Visual Basic
Public Overridable Function GetKeywordIdByKeywords ( _
    keywords As String _
) As Guid
Visual C++
public:
virtual Guid GetKeywordIdByKeywords(
    String^ keywords
)

Parameters

keywords
Type: System..::..String
The keywords.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetKeywordIdByKeywords(System.String)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetKeywordsBySessionId Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetKeywordsBySessionId Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual string GetKeywordsBySessionId(
    Guid sessionId
)
Visual Basic
Public Overridable Function GetKeywordsBySessionId ( _
    sessionId As Guid _
) As String
Visual C++
public:
virtual String^ GetKeywordsBySessionId(
    Guid sessionId
)

Parameters

sessionId
Type: System..::..Guid
The session id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetKeywordsBySessionId(System.Guid)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetLong Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetLong Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual long GetLong(
    int columnIndex,
    DataProviderReader reader
)
Visual Basic
Public Overridable Function GetLong ( _
    columnIndex As Integer, _
    reader As DataProviderReader _
) As Long
Visual C++
public:
virtual long long GetLong(
    int columnIndex,
    DataProviderReader^ reader
)

Parameters

columnIndex
Type: System..::..Int32
Index of the column.
reader
Type: Sitecore.Data.DataProviders.Sql..::..DataProviderReader
The reader.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetLong(System.Int32,Sitecore.Data.DataProviders.Sql.DataProviderReader)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetLookupData Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetLookupData Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual IEnumerable<LookupData> GetLookupData(
    bool onlyBlanks,
    int maxEntries
)
Visual Basic
Public Overridable Function GetLookupData ( _
    onlyBlanks As Boolean, _
    maxEntries As Integer _
) As IEnumerable(Of LookupData)
Visual C++
public:
virtual IEnumerable<LookupData^>^ GetLookupData(
    bool onlyBlanks,
    int maxEntries
)

Parameters

onlyBlanks
Type: System..::..Boolean
if set to true [blanks].
maxEntries
Type: System..::..Int32
The max entries.

Return Value

The lookup data.

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetMatchReportQueryPattern Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetMatchReportQueryPattern Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract string GetMatchReportQueryPattern()
Visual Basic
Public MustOverride Function GetMatchReportQueryPattern As String
Visual C++
public:
virtual String^ GetMatchReportQueryPattern() abstract

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetMatchReportQueryPattern"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetMultiVarianceTestDefinitionById Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetMultiVarianceTestDefinitionById Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual MultiVarianceTestDefinition GetMultiVarianceTestDefinitionById(
    Guid multiVarianceTestDefinitionId
)
Visual Basic
Public Overridable Function GetMultiVarianceTestDefinitionById ( _
    multiVarianceTestDefinitionId As Guid _
) As MultiVarianceTestDefinition
Visual C++
public:
virtual MultiVarianceTestDefinition^ GetMultiVarianceTestDefinitionById(
    Guid multiVarianceTestDefinitionId
)

Parameters

multiVarianceTestDefinitionId
Type: System..::..Guid
The multi variance test definition id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetMultiVarianceTestDefinitionById(System.Guid)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetMultiVarianceTestDefinitions Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetMultiVarianceTestDefinitions Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual List<MultiVarianceTestDefinition> GetMultiVarianceTestDefinitions()
Visual Basic
Public Overridable Function GetMultiVarianceTestDefinitions As List(Of MultiVarianceTestDefinition)
Visual C++
public:
virtual List<MultiVarianceTestDefinition^>^ GetMultiVarianceTestDefinitions()

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetMultiVarianceTestDefinitions"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetMultiVarianceTestVariableById Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetMultiVarianceTestVariableById Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual MultiVarianceTestVariable GetMultiVarianceTestVariableById(
    Guid multiVarianceTestVariableId
)
Visual Basic
Public Overridable Function GetMultiVarianceTestVariableById ( _
    multiVarianceTestVariableId As Guid _
) As MultiVarianceTestVariable
Visual C++
public:
virtual MultiVarianceTestVariable^ GetMultiVarianceTestVariableById(
    Guid multiVarianceTestVariableId
)

Parameters

multiVarianceTestVariableId
Type: System..::..Guid
The multi variance test variable id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetMultiVarianceTestVariableById(System.Guid)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetOperatingSystemById Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetOperatingSystemById Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual OperatingSystem GetOperatingSystemById(
    Guid operatingSystemId
)
Visual Basic
Public Overridable Function GetOperatingSystemById ( _
    operatingSystemId As Guid _
) As OperatingSystem
Visual C++
public:
virtual OperatingSystem^ GetOperatingSystemById(
    Guid operatingSystemId
)

Parameters

operatingSystemId
Type: System..::..Guid
The operating system id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetOperatingSystemById(System.Guid)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetOperatingSystems Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetOperatingSystems Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual List<OperatingSystem> GetOperatingSystems()
Visual Basic
Public Overridable Function GetOperatingSystems As List(Of OperatingSystem)
Visual C++
public:
virtual List<OperatingSystem^>^ GetOperatingSystems()

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetOperatingSystems"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetPageById Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetPageById Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual Page GetPageById(
    Guid pageId
)
Visual Basic
Public Overridable Function GetPageById ( _
    pageId As Guid _
) As Page
Visual C++
public:
virtual Page^ GetPageById(
    Guid pageId
)

Parameters

pageId
Type: System..::..Guid
The page id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetPageById(System.Guid)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetPageBySessionIdAndPageNo Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetPageBySessionIdAndPageNo Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Page GetPageBySessionIdAndPageNo(
    Guid sessionId,
    int pageNo
)
Visual Basic
Public Function GetPageBySessionIdAndPageNo ( _
    sessionId As Guid, _
    pageNo As Integer _
) As Page
Visual C++
public:
Page^ GetPageBySessionIdAndPageNo(
    Guid sessionId,
    int pageNo
)

Parameters

sessionId
Type: System..::..Guid
The session id.
pageNo
Type: System..::..Int32
The page no.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetPageBySessionIdAndPageNo(System.Guid,System.Int32)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetPageEventById Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetPageEventById Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual PageEvent GetPageEventById(
    Guid pageEventId
)
Visual Basic
Public Overridable Function GetPageEventById ( _
    pageEventId As Guid _
) As PageEvent
Visual C++
public:
virtual PageEvent^ GetPageEventById(
    Guid pageEventId
)

Parameters

pageEventId
Type: System..::..Guid
The page event id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetPageEventById(System.Guid)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetPageEventDefinitionById Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetPageEventDefinitionById Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual PageEventDefinition GetPageEventDefinitionById(
    Guid pageEventDefinitionId
)
Visual Basic
Public Overridable Function GetPageEventDefinitionById ( _
    pageEventDefinitionId As Guid _
) As PageEventDefinition
Visual C++
public:
virtual PageEventDefinition^ GetPageEventDefinitionById(
    Guid pageEventDefinitionId
)

Parameters

pageEventDefinitionId
Type: System..::..Guid
The page event definition id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetPageEventDefinitionById(System.Guid)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetPageEventDefinitionFailureNotSystem Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetPageEventDefinitionFailureNotSystem Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual List<PageEventDefinition> GetPageEventDefinitionFailureNotSystem()
Visual Basic
Public Overridable Function GetPageEventDefinitionFailureNotSystem As List(Of PageEventDefinition)
Visual C++
public:
virtual List<PageEventDefinition^>^ GetPageEventDefinitionFailureNotSystem()

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetPageEventDefinitionFailureNotSystem"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetPageEventDefinitionNotGoalNotFailureNotSystem Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetPageEventDefinitionNotGoalNotFailureNotSystem Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual List<PageEventDefinition> GetPageEventDefinitionNotGoalNotFailureNotSystem()
Visual Basic
Public Overridable Function GetPageEventDefinitionNotGoalNotFailureNotSystem As List(Of PageEventDefinition)
Visual C++
public:
virtual List<PageEventDefinition^>^ GetPageEventDefinitionNotGoalNotFailureNotSystem()

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetPageEventDefinitionNotGoalNotFailureNotSystem"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetPageEventDefinitionsIsGoalNotSystem Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetPageEventDefinitionsIsGoalNotSystem Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual List<PageEventDefinition> GetPageEventDefinitionsIsGoalNotSystem()
Visual Basic
Public Overridable Function GetPageEventDefinitionsIsGoalNotSystem As List(Of PageEventDefinition)
Visual C++
public:
virtual List<PageEventDefinition^>^ GetPageEventDefinitionsIsGoalNotSystem()

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetPageEventDefinitionsIsGoalNotSystem"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetPagesBySessionId Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetPagesBySessionId Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public List<Page> GetPagesBySessionId(
    Guid sessionId
)
Visual Basic
Public Function GetPagesBySessionId ( _
    sessionId As Guid _
) As List(Of Page)
Visual C++
public:
List<Page^>^ GetPagesBySessionId(
    Guid sessionId
)

Parameters

sessionId
Type: System..::..Guid
The session id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetPagesBySessionId(System.Guid)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetProfileDefinitionById Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetProfileDefinitionById Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual ProfileDefinition GetProfileDefinitionById(
    Guid profileDefinitionId
)
Visual Basic
Public Overridable Function GetProfileDefinitionById ( _
    profileDefinitionId As Guid _
) As ProfileDefinition
Visual C++
public:
virtual ProfileDefinition^ GetProfileDefinitionById(
    Guid profileDefinitionId
)

Parameters

profileDefinitionId
Type: System..::..Guid
The profile definition id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetProfileDefinitionById(System.Guid)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetProfileDefinitions Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetProfileDefinitions Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual List<ProfileDefinition> GetProfileDefinitions()
Visual Basic
Public Overridable Function GetProfileDefinitions As List(Of ProfileDefinition)
Visual C++
public:
virtual List<ProfileDefinition^>^ GetProfileDefinitions()

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetProfileDefinitions"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetProfileKeyDefinitionById Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetProfileKeyDefinitionById Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual ProfileKeyDefinition GetProfileKeyDefinitionById(
    Guid profileKeyDefinition
)
Visual Basic
Public Overridable Function GetProfileKeyDefinitionById ( _
    profileKeyDefinition As Guid _
) As ProfileKeyDefinition
Visual C++
public:
virtual ProfileKeyDefinition^ GetProfileKeyDefinitionById(
    Guid profileKeyDefinition
)

Parameters

profileKeyDefinition
Type: System..::..Guid
The profile key definition.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetProfileKeyDefinitionById(System.Guid)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetProfileKeyDefinitions Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetProfileKeyDefinitions Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual List<ProfileKeyDefinition> GetProfileKeyDefinitions()
Visual Basic
Public Overridable Function GetProfileKeyDefinitions As List(Of ProfileKeyDefinition)
Visual C++
public:
virtual List<ProfileKeyDefinition^>^ GetProfileKeyDefinitions()

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetProfileKeyDefinitions"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetProfileKeysByProfileId Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetProfileKeysByProfileId Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual List<ProfileKey> GetProfileKeysByProfileId(
    Guid profileId
)
Visual Basic
Public Overridable Function GetProfileKeysByProfileId ( _
    profileId As Guid _
) As List(Of ProfileKey)
Visual C++
public:
virtual List<ProfileKey^>^ GetProfileKeysByProfileId(
    Guid profileId
)

Parameters

profileId
Type: System..::..Guid
The profile id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetProfileKeysByProfileId(System.Guid)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetProfilesBySessionId Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetProfilesBySessionId Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual List<Profile> GetProfilesBySessionId(
    Guid sessionId
)
Visual Basic
Public Overridable Function GetProfilesBySessionId ( _
    sessionId As Guid _
) As List(Of Profile)
Visual C++
public:
virtual List<Profile^>^ GetProfilesBySessionId(
    Guid sessionId
)

Parameters

sessionId
Type: System..::..Guid
The session id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetProfilesBySessionId(System.Guid)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetReferringSiteByUrl Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetReferringSiteByUrl Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public ReferringSite GetReferringSiteByUrl(
    string url
)
Visual Basic
Public Function GetReferringSiteByUrl ( _
    url As String _
) As ReferringSite
Visual C++
public:
ReferringSite^ GetReferringSiteByUrl(
    String^ url
)

Parameters

url
Type: System..::..String
The URL.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetReferringSiteByUrl(System.String)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetReportsDatabase Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetReportsDatabase Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract StiDatabase GetReportsDatabase()
Visual Basic
Public MustOverride Function GetReportsDatabase As StiDatabase
Visual C++
public:
virtual StiDatabase^ GetReportsDatabase() abstract

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetReportsDatabase"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetReportsDataSourceType Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetReportsDataSourceType Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract string GetReportsDataSourceType()
Visual Basic
Public MustOverride Function GetReportsDataSourceType As String
Visual C++
public:
virtual String^ GetReportsDataSourceType() abstract

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetReportsDataSourceType"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetScreenByScreenId Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetScreenByScreenId Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Screen GetScreenByScreenId(
    Guid screenId
)
Visual Basic
Public Function GetScreenByScreenId ( _
    screenId As Guid _
) As Screen
Visual C++
public:
Screen^ GetScreenByScreenId(
    Guid screenId
)

Parameters

screenId
Type: System..::..Guid
The screen id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetScreenByScreenId(System.Guid)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetScreens Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetScreens Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public List<Screen> GetScreens()
Visual Basic
Public Function GetScreens As List(Of Screen)
Visual C++
public:
List<Screen^>^ GetScreens()

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetScreens"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetSessionByAspNetSessionId Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetSessionByAspNetSessionId Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Session GetSessionByAspNetSessionId(
    string aspNetSessionId
)
Visual Basic
Public Function GetSessionByAspNetSessionId ( _
    aspNetSessionId As String _
) As Session
Visual C++
public:
Session^ GetSessionByAspNetSessionId(
    String^ aspNetSessionId
)

Parameters

aspNetSessionId
Type: System..::..String
The ASP net session id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetSessionByAspNetSessionId(System.String)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetSessionBySessionId Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetSessionBySessionId Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Session GetSessionBySessionId(
    Guid sessionId
)
Visual Basic
Public Function GetSessionBySessionId ( _
    sessionId As Guid _
) As Session
Visual C++
public:
Session^ GetSessionBySessionId(
    Guid sessionId
)

Parameters

sessionId
Type: System..::..Guid
The session id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetSessionBySessionId(System.Guid)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetSessionIdByAspNetSessionId Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetSessionIdByAspNetSessionId Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid GetSessionIdByAspNetSessionId(
    string aspNetSessionId
)
Visual Basic
Public Function GetSessionIdByAspNetSessionId ( _
    aspNetSessionId As String _
) As Guid
Visual C++
public:
Guid GetSessionIdByAspNetSessionId(
    String^ aspNetSessionId
)

Parameters

aspNetSessionId
Type: System..::..String
The ASP net session id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetSessionIdByAspNetSessionId(System.String)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetStatuses Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetStatuses Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual List<Status> GetStatuses()
Visual Basic
Public Overridable Function GetStatuses As List(Of Status)
Visual C++
public:
virtual List<Status^>^ GetStatuses()

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetStatuses"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetSubscription Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetSubscription Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual Subscription GetSubscription(
    string email,
    Guid ipownerId
)
Visual Basic
Public Overridable Function GetSubscription ( _
    email As String, _
    ipownerId As Guid _
) As Subscription
Visual C++
public:
virtual Subscription^ GetSubscription(
    String^ email,
    Guid ipownerId
)

Parameters

email
Type: System..::..String
The email.
ipownerId
Type: System..::..Guid
The ipowner id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetSubscription(System.String,System.Guid)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetSubscriptionById Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetSubscriptionById Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Subscription GetSubscriptionById(
    Guid subscriptionId
)
Visual Basic
Public Function GetSubscriptionById ( _
    subscriptionId As Guid _
) As Subscription
Visual C++
public:
Subscription^ GetSubscriptionById(
    Guid subscriptionId
)

Parameters

subscriptionId
Type: System..::..Guid
The subscription id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetSubscriptionById(System.Guid)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetTagById Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetTagById Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual Tag GetTagById(
    Guid tagId
)
Visual Basic
Public Overridable Function GetTagById ( _
    tagId As Guid _
) As Tag
Visual C++
public:
virtual Tag^ GetTagById(
    Guid tagId
)

Parameters

tagId
Type: System..::..Guid
The tag id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetTagById(System.Guid)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetTagsByGlobalSessionId Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetTagsByGlobalSessionId Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual List<Tag> GetTagsByGlobalSessionId(
    Guid globalSessionId
)
Visual Basic
Public Overridable Function GetTagsByGlobalSessionId ( _
    globalSessionId As Guid _
) As List(Of Tag)
Visual C++
public:
virtual List<Tag^>^ GetTagsByGlobalSessionId(
    Guid globalSessionId
)

Parameters

globalSessionId
Type: System..::..Guid
The global session id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetTagsByGlobalSessionId(System.Guid)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetTotalByGlobalSessionId Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetTotalByGlobalSessionId Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int GetTotalByGlobalSessionId(
    Guid globalSessionId
)
Visual Basic
Public Function GetTotalByGlobalSessionId ( _
    globalSessionId As Guid _
) As Integer
Visual C++
public:
int GetTotalByGlobalSessionId(
    Guid globalSessionId
)

Parameters

globalSessionId
Type: System..::..Guid
The global session id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetTotalByGlobalSessionId(System.Guid)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GetVendorSpecificReportPath Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GetVendorSpecificReportPath Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual string GetVendorSpecificReportPath(
    string reportPath
)
Visual Basic
Public Overridable Function GetVendorSpecificReportPath ( _
    reportPath As String _
) As String
Visual C++
public:
virtual String^ GetVendorSpecificReportPath(
    String^ reportPath
)

Parameters

reportPath
Type: System..::..String
The report path.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GetVendorSpecificReportPath(System.String)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


GuidToRawString Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..GuidToRawString Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract string GuidToRawString(
    Guid guid
)
Visual Basic
Public MustOverride Function GuidToRawString ( _
    guid As Guid _
) As String
Visual C++
public:
virtual String^ GuidToRawString(
    Guid guid
) abstract

Parameters

guid
Type: System..::..Guid
The GUID.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.GuidToRawString(System.Guid)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


InsertBrowser Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..InsertBrowser Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual int InsertBrowser(
    Guid browserId,
    string userAgent,
    string description,
    string comment,
    string link1,
    string link2,
    int visitorIdentification,
    string majorName,
    string version
)
Visual Basic
Public Overridable Function InsertBrowser ( _
    browserId As Guid, _
    userAgent As String, _
    description As String, _
    comment As String, _
    link1 As String, _
    link2 As String, _
    visitorIdentification As Integer, _
    majorName As String, _
    version As String _
) As Integer
Visual C++
public:
virtual int InsertBrowser(
    Guid browserId,
    String^ userAgent,
    String^ description,
    String^ comment,
    String^ link1,
    String^ link2,
    int visitorIdentification,
    String^ majorName,
    String^ version
)

Parameters

browserId
Type: System..::..Guid
The browser id.
userAgent
Type: System..::..String
The user agent.
description
Type: System..::..String
The description.
comment
Type: System..::..String
The comment.
link1
Type: System..::..String
The link1.
link2
Type: System..::..String
The link2.
visitorIdentification
Type: System..::..Int32
The visitor identification.
majorName
Type: System..::..String
Name of the major.
version
Type: System..::..String
The version.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.InsertBrowser(System.Guid,System.String,System.String,System.String,System.String,System.String,System.Int32,System.String,System.String)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


InsertCampaign Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..InsertCampaign Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual int InsertCampaign(
    Guid campaignId,
    string title,
    string type,
    string description,
    double cost,
    DateTime startDate,
    DateTime endDate,
    string data,
    bool isActive
)
Visual Basic
Public Overridable Function InsertCampaign ( _
    campaignId As Guid, _
    title As String, _
    type As String, _
    description As String, _
    cost As Double, _
    startDate As DateTime, _
    endDate As DateTime, _
    data As String, _
    isActive As Boolean _
) As Integer
Visual C++
public:
virtual int InsertCampaign(
    Guid campaignId,
    String^ title,
    String^ type,
    String^ description,
    double cost,
    DateTime startDate,
    DateTime endDate,
    String^ data,
    bool isActive
)

Parameters

campaignId
Type: System..::..Guid
The campaign id.
title
Type: System..::..String
The title.
type
Type: System..::..String
The type.
description
Type: System..::..String
The description.
cost
Type: System..::..Double
The cost.
startDate
Type: System..::..DateTime
The start date.
endDate
Type: System..::..DateTime
The end date.
data
Type: System..::..String
The data.
isActive
Type: System..::..Boolean
if set to true [is active].

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.InsertCampaign(System.Guid,System.String,System.String,System.String,System.Double,System.DateTime,System.DateTime,System.String,System.Boolean)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


InsertCampaignEvent Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..InsertCampaignEvent Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual int InsertCampaignEvent(
    Guid campaignEventId,
    Guid campaignId,
    DateTime dateTime,
    string data,
    int state
)
Visual Basic
Public Overridable Function InsertCampaignEvent ( _
    campaignEventId As Guid, _
    campaignId As Guid, _
    dateTime As DateTime, _
    data As String, _
    state As Integer _
) As Integer
Visual C++
public:
virtual int InsertCampaignEvent(
    Guid campaignEventId,
    Guid campaignId,
    DateTime dateTime,
    String^ data,
    int state
)

Parameters

campaignEventId
Type: System..::..Guid
The campaign event id.
campaignId
Type: System..::..Guid
The campaign id.
dateTime
Type: System..::..DateTime
The date time.
data
Type: System..::..String
The data.
state
Type: System..::..Int32
The state.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.InsertCampaignEvent(System.Guid,System.Guid,System.DateTime,System.String,System.Int32)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


InsertCampaignEventPage Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..InsertCampaignEventPage Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int InsertCampaignEventPage(
    Guid campaignSessionPageId,
    Guid pageId,
    Guid campaignEventId
)
Visual Basic
Public Function InsertCampaignEventPage ( _
    campaignSessionPageId As Guid, _
    pageId As Guid, _
    campaignEventId As Guid _
) As Integer
Visual C++
public:
int InsertCampaignEventPage(
    Guid campaignSessionPageId,
    Guid pageId,
    Guid campaignEventId
)

Parameters

campaignSessionPageId
Type: System..::..Guid
The campaign session page id.
pageId
Type: System..::..Guid
The page id.
campaignEventId
Type: System..::..Guid
The campaign event id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.InsertCampaignEventPage(System.Guid,System.Guid,System.Guid)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


InsertGlobalSession Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..InsertGlobalSession Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int InsertGlobalSession(
    Guid globalSessionId,
    string cookieValue,
    int visitorIdentification,
    int overriddenVisitorIdentification,
    string externalUser
)
Visual Basic
Public Function InsertGlobalSession ( _
    globalSessionId As Guid, _
    cookieValue As String, _
    visitorIdentification As Integer, _
    overriddenVisitorIdentification As Integer, _
    externalUser As String _
) As Integer
Visual C++
public:
int InsertGlobalSession(
    Guid globalSessionId,
    String^ cookieValue,
    int visitorIdentification,
    int overriddenVisitorIdentification,
    String^ externalUser
)

Parameters

globalSessionId
Type: System..::..Guid
The global session id.
cookieValue
Type: System..::..String
The cookie value.
visitorIdentification
Type: System..::..Int32
The visitor identification.
overriddenVisitorIdentification
Type: System..::..Int32
The overridden visitor identification.
externalUser
Type: System..::..String
The external user.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.InsertGlobalSession(System.Guid,System.String,System.Int32,System.Int32,System.String)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


InsertIPOwner Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..InsertIPOwner Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual int InsertIPOwner(
    Guid ipOwnerId,
    string name,
    string country,
    int visitorIdentification,
    string externalUser
)
Visual Basic
Public Overridable Function InsertIPOwner ( _
    ipOwnerId As Guid, _
    name As String, _
    country As String, _
    visitorIdentification As Integer, _
    externalUser As String _
) As Integer
Visual C++
public:
virtual int InsertIPOwner(
    Guid ipOwnerId,
    String^ name,
    String^ country,
    int visitorIdentification,
    String^ externalUser
)

Parameters

ipOwnerId
Type: System..::..Guid
The ip owner id.
name
Type: System..::..String
The name.
country
Type: System..::..String
The country.
visitorIdentification
Type: System..::..Int32
The visitor identification.
externalUser
Type: System..::..String
The external user.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.InsertIPOwner(System.Guid,System.String,System.String,System.Int32,System.String)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


InsertKeyword Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..InsertKeyword Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual int InsertKeyword(
    Guid keywordId,
    string keywords
)
Visual Basic
Public Overridable Function InsertKeyword ( _
    keywordId As Guid, _
    keywords As String _
) As Integer
Visual C++
public:
virtual int InsertKeyword(
    Guid keywordId,
    String^ keywords
)

Parameters

keywordId
Type: System..::..Guid
The keyword id.
keywords
Type: System..::..String
The keywords.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.InsertKeyword(System.Guid,System.String)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


InsertMultiVarianceTestDefinition Method

[image] [image]

Sitecore 6.4.1 API
AnalyticsProvider..::..InsertMultiVarianceTestDefinition Method
AnalyticsProvider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertMultiVarianceTestDefinition(Guid, String, String) | Inserts the multi variance test definition.
Public method | InsertMultiVarianceTestDefinition(String, String, Guid) | Inserts the multi variance test definition.

See Also

AnalyticsProvider Class
AnalyticsProvider Members
Sitecore.Analytics.Data.DataProviders Namespace


InsertMultiVarianceTestDefinition Method (String, String, Guid)

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..InsertMultiVarianceTestDefinition Method (String, String, Guid)
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual int InsertMultiVarianceTestDefinition(
    string title,
    string description,
    Guid multiVarianceTestId
)
Visual Basic
Public Overridable Function InsertMultiVarianceTestDefinition ( _
    title As String, _
    description As String, _
    multiVarianceTestId As Guid _
) As Integer
Visual C++
public:
virtual int InsertMultiVarianceTestDefinition(
    String^ title,
    String^ description,
    Guid multiVarianceTestId
)

Parameters

title
Type: System..::..String
The title.
description
Type: System..::..String
The description.
multiVarianceTestId
Type: System..::..Guid
The multi variance test id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.InsertMultiVarianceTestDefinition(System.String,System.String,System.Guid)"]

See Also

AnalyticsProvider Class
InsertMultiVarianceTestDefinition Overload
Sitecore.Analytics.Data.DataProviders Namespace


InsertMultiVarianceTestVariable Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..InsertMultiVarianceTestVariable Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int InsertMultiVarianceTestVariable(
    Guid multiVarianceTestVariableId,
    Guid multiVarianceTestDefinitionId,
    string name
)
Visual Basic
Public Function InsertMultiVarianceTestVariable ( _
    multiVarianceTestVariableId As Guid, _
    multiVarianceTestDefinitionId As Guid, _
    name As String _
) As Integer
Visual C++
public:
int InsertMultiVarianceTestVariable(
    Guid multiVarianceTestVariableId,
    Guid multiVarianceTestDefinitionId,
    String^ name
)

Parameters

multiVarianceTestVariableId
Type: System..::..Guid
The multi variance test variable id.
multiVarianceTestDefinitionId
Type: System..::..Guid
The multi variance test definition id.
name
Type: System..::..String
The name.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.InsertMultiVarianceTestVariable(System.Guid,System.Guid,System.String)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


InsertMultiVarianceTestVariableCampaignEvent Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..InsertMultiVarianceTestVariableCampaignEvent Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual int InsertMultiVarianceTestVariableCampaignEvent(
    Guid multiVarianceTestVariableCampaignEventId,
    Guid multiVarianceTestVariableId,
    Guid campaignEventId,
    string data
)
Visual Basic
Public Overridable Function InsertMultiVarianceTestVariableCampaignEvent ( _
    multiVarianceTestVariableCampaignEventId As Guid, _
    multiVarianceTestVariableId As Guid, _
    campaignEventId As Guid, _
    data As String _
) As Integer
Visual C++
public:
virtual int InsertMultiVarianceTestVariableCampaignEvent(
    Guid multiVarianceTestVariableCampaignEventId,
    Guid multiVarianceTestVariableId,
    Guid campaignEventId,
    String^ data
)

Parameters

multiVarianceTestVariableCampaignEventId
Type: System..::..Guid
The multi variance test variable campaign event id.
multiVarianceTestVariableId
Type: System..::..Guid
The multi variance test variable id.
campaignEventId
Type: System..::..Guid
The campaign event id.
data
Type: System..::..String
The data.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.InsertMultiVarianceTestVariableCampaignEvent(System.Guid,System.Guid,System.Guid,System.String)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


InsertMultiVarianceTestVariablePage Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..InsertMultiVarianceTestVariablePage Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int InsertMultiVarianceTestVariablePage(
    Guid multiVarianceTestVariablePageId,
    Guid multiVarianceTestVariableId,
    Guid pageId,
    string data
)
Visual Basic
Public Function InsertMultiVarianceTestVariablePage ( _
    multiVarianceTestVariablePageId As Guid, _
    multiVarianceTestVariableId As Guid, _
    pageId As Guid, _
    data As String _
) As Integer
Visual C++
public:
int InsertMultiVarianceTestVariablePage(
    Guid multiVarianceTestVariablePageId,
    Guid multiVarianceTestVariableId,
    Guid pageId,
    String^ data
)

Parameters

multiVarianceTestVariablePageId
Type: System..::..Guid
The multi variance test variable page id.
multiVarianceTestVariableId
Type: System..::..Guid
The multi variance test variable id.
pageId
Type: System..::..Guid
The page id.
data
Type: System..::..String
The data.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.InsertMultiVarianceTestVariablePage(System.Guid,System.Guid,System.Guid,System.String)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


InsertOperatingSystem Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..InsertOperatingSystem Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual int InsertOperatingSystem(
    Guid operatingSystemId,
    string operatingSystem,
    string description,
    string majorName,
    string minorName,
    string version
)
Visual Basic
Public Overridable Function InsertOperatingSystem ( _
    operatingSystemId As Guid, _
    operatingSystem As String, _
    description As String, _
    majorName As String, _
    minorName As String, _
    version As String _
) As Integer
Visual C++
public:
virtual int InsertOperatingSystem(
    Guid operatingSystemId,
    String^ operatingSystem,
    String^ description,
    String^ majorName,
    String^ minorName,
    String^ version
)

Parameters

operatingSystemId
Type: System..::..Guid
The operating system id.
operatingSystem
Type: System..::..String
The operating system.
description
Type: System..::..String
The description.
majorName
Type: System..::..String
Name of the major.
minorName
Type: System..::..String
Name of the minor.
version
Type: System..::..String
The version.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.InsertOperatingSystem(System.Guid,System.String,System.String,System.String,System.String,System.String)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


InsertPage Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..InsertPage Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual int InsertPage(
    Guid pageId,
    Guid sessionId,
    DateTime timestamp,
    int duration,
    int pageNo,
    Guid itemId,
    string itemLanguage,
    int itemVersion,
    Guid deviceId,
    string navigation,
    string url,
    string indexableUrl,
    string data
)
Visual Basic
Public Overridable Function InsertPage ( _
    pageId As Guid, _
    sessionId As Guid, _
    timestamp As DateTime, _
    duration As Integer, _
    pageNo As Integer, _
    itemId As Guid, _
    itemLanguage As String, _
    itemVersion As Integer, _
    deviceId As Guid, _
    navigation As String, _
    url As String, _
    indexableUrl As String, _
    data As String _
) As Integer
Visual C++
public:
virtual int InsertPage(
    Guid pageId,
    Guid sessionId,
    DateTime timestamp,
    int duration,
    int pageNo,
    Guid itemId,
    String^ itemLanguage,
    int itemVersion,
    Guid deviceId,
    String^ navigation,
    String^ url,
    String^ indexableUrl,
    String^ data
)

Parameters

pageId
Type: System..::..Guid
The page id.
sessionId
Type: System..::..Guid
The session id.
timestamp
Type: System..::..DateTime
The timestamp.
duration
Type: System..::..Int32
The duration.
pageNo
Type: System..::..Int32
The page no.
itemId
Type: System..::..Guid
The item id.
itemLanguage
Type: System..::..String
The item language.
itemVersion
Type: System..::..Int32
The item version.
deviceId
Type: System..::..Guid
The device id.
navigation
Type: System..::..String
The navigation.
url
Type: System..::..String
The URL.
indexableUrl
Type: System..::..String
The indexable URL.
data
Type: System..::..String
The data.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.InsertPage(System.Guid,System.Guid,System.DateTime,System.Int32,System.Int32,System.Guid,System.String,System.Int32,System.Guid,System.String,System.String,System.String,System.String)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


InsertPageEvent Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..InsertPageEvent Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual int InsertPageEvent(
    Guid pageEventId,
    Guid pageId,
    Guid pageEventDefinitionId,
    Guid itemId,
    string itemLanguage,
    int itemVersion,
    string text,
    string dataKey,
    string data,
    int integer,
    long timestamp,
    int customSorting
)
Visual Basic
Public Overridable Function InsertPageEvent ( _
    pageEventId As Guid, _
    pageId As Guid, _
    pageEventDefinitionId As Guid, _
    itemId As Guid, _
    itemLanguage As String, _
    itemVersion As Integer, _
    text As String, _
    dataKey As String, _
    data As String, _
    integer As Integer, _
    timestamp As Long, _
    customSorting As Integer _
) As Integer
Visual C++
public:
virtual int InsertPageEvent(
    Guid pageEventId,
    Guid pageId,
    Guid pageEventDefinitionId,
    Guid itemId,
    String^ itemLanguage,
    int itemVersion,
    String^ text,
    String^ dataKey,
    String^ data,
    int integer,
    long long timestamp,
    int customSorting
)

Parameters

pageEventId
Type: System..::..Guid
The page event id.
pageId
Type: System..::..Guid
The page id.
pageEventDefinitionId
Type: System..::..Guid
The page event definition id.
itemId
Type: System..::..Guid
The item id.
itemLanguage
Type: System..::..String
The item language.
itemVersion
Type: System..::..Int32
The item version.
text
Type: System..::..String
The text.
dataKey
Type: System..::..String
The data key.
data
Type: System..::..String
The data.
integer
Type: System..::..Int32
The integer.
timestamp
Type: System..::..Int64
The timestamp.
customSorting
Type: System..::..Int32
The custom sorting.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.InsertPageEvent(System.Guid,System.Guid,System.Guid,System.Guid,System.String,System.Int32,System.String,System.String,System.String,System.Int32,System.Int64,System.Int32)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


InsertProfile Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..InsertProfile Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual int InsertProfile(
    Guid profileId,
    Guid profileDefinitionId,
    Guid sessionId,
    int total,
    int count
)
Visual Basic
Public Overridable Function InsertProfile ( _
    profileId As Guid, _
    profileDefinitionId As Guid, _
    sessionId As Guid, _
    total As Integer, _
    count As Integer _
) As Integer
Visual C++
public:
virtual int InsertProfile(
    Guid profileId,
    Guid profileDefinitionId,
    Guid sessionId,
    int total,
    int count
)

Parameters

profileId
Type: System..::..Guid
The profile id.
profileDefinitionId
Type: System..::..Guid
The profile definition id.
sessionId
Type: System..::..Guid
The session id.
total
Type: System..::..Int32
The total.
count
Type: System..::..Int32
The count.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.InsertProfile(System.Guid,System.Guid,System.Guid,System.Int32,System.Int32)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


InsertProfileDefinition Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..InsertProfileDefinition Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual int InsertProfileDefinition(
    Guid profileDefinitionId,
    string name,
    string profileType
)
Visual Basic
Public Overridable Function InsertProfileDefinition ( _
    profileDefinitionId As Guid, _
    name As String, _
    profileType As String _
) As Integer
Visual C++
public:
virtual int InsertProfileDefinition(
    Guid profileDefinitionId,
    String^ name,
    String^ profileType
)

Parameters

profileDefinitionId
Type: System..::..Guid
The profile definition id.
name
Type: System..::..String
The name.
profileType
Type: System..::..String
Type of the profile.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.InsertProfileDefinition(System.Guid,System.String,System.String)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


InsertProfileKey Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..InsertProfileKey Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual int InsertProfileKey(
    Guid profileKeyId,
    Guid profileId,
    Guid profileKeyDefinitionId,
    int value
)
Visual Basic
Public Overridable Function InsertProfileKey ( _
    profileKeyId As Guid, _
    profileId As Guid, _
    profileKeyDefinitionId As Guid, _
    value As Integer _
) As Integer
Visual C++
public:
virtual int InsertProfileKey(
    Guid profileKeyId,
    Guid profileId,
    Guid profileKeyDefinitionId,
    int value
)

Parameters

profileKeyId
Type: System..::..Guid
The profile key id.
profileId
Type: System..::..Guid
The profile id.
profileKeyDefinitionId
Type: System..::..Guid
The profile key definition id.
value
Type: System..::..Int32
The value.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.InsertProfileKey(System.Guid,System.Guid,System.Guid,System.Int32)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


InsertProfileKeyDefinition Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..InsertProfileKeyDefinition Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual int InsertProfileKeyDefinition(
    Guid profileKeyDefinitionId,
    Guid profileDefinitionId,
    string name,
    string control,
    int minValue,
    int maxValue
)
Visual Basic
Public Overridable Function InsertProfileKeyDefinition ( _
    profileKeyDefinitionId As Guid, _
    profileDefinitionId As Guid, _
    name As String, _
    control As String, _
    minValue As Integer, _
    maxValue As Integer _
) As Integer
Visual C++
public:
virtual int InsertProfileKeyDefinition(
    Guid profileKeyDefinitionId,
    Guid profileDefinitionId,
    String^ name,
    String^ control,
    int minValue,
    int maxValue
)

Parameters

profileKeyDefinitionId
Type: System..::..Guid
The profile key definition id.
profileDefinitionId
Type: System..::..Guid
The profile definition id.
name
Type: System..::..String
The name.
control
Type: System..::..String
The control.
minValue
Type: System..::..Int32
The min value.
maxValue
Type: System..::..Int32
The max value.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.InsertProfileKeyDefinition(System.Guid,System.Guid,System.String,System.String,System.Int32,System.Int32)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


InsertReferringSite Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..InsertReferringSite Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int InsertReferringSite(
    Guid referringSiteId,
    string url
)
Visual Basic
Public Function InsertReferringSite ( _
    referringSiteId As Guid, _
    url As String _
) As Integer
Visual C++
public:
int InsertReferringSite(
    Guid referringSiteId,
    String^ url
)

Parameters

referringSiteId
Type: System..::..Guid
The referring site id.
url
Type: System..::..String
The URL.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.InsertReferringSite(System.Guid,System.String)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


InsertScreen Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..InsertScreen Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int InsertScreen(
    Guid screenId,
    string dimensions,
    string description
)
Visual Basic
Public Function InsertScreen ( _
    screenId As Guid, _
    dimensions As String, _
    description As String _
) As Integer
Visual C++
public:
int InsertScreen(
    Guid screenId,
    String^ dimensions,
    String^ description
)

Parameters

screenId
Type: System..::..Guid
The screen id.
dimensions
Type: System..::..String
The dimensions.
description
Type: System..::..String
The description.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.InsertScreen(System.Guid,System.String,System.String)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


InsertSession Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..InsertSession Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual int InsertSession(
    Guid sessionId,
    string aspNetSessionId,
    DateTime timestamp,
    Guid ipId,
    string ipAddress,
    Guid globalSessionId,
    int globalVisitNo,
    string domain,
    string multiSite,
    Guid screenId,
    Guid operatingSystemId,
    Guid referringSiteId,
    Guid keywordId,
    Guid browserId,
    Guid languageId,
    int currentPage,
    DateTime lastPageTimestamp
)
Visual Basic
Public Overridable Function InsertSession ( _
    sessionId As Guid, _
    aspNetSessionId As String, _
    timestamp As DateTime, _
    ipId As Guid, _
    ipAddress As String, _
    globalSessionId As Guid, _
    globalVisitNo As Integer, _
    domain As String, _
    multiSite As String, _
    screenId As Guid, _
    operatingSystemId As Guid, _
    referringSiteId As Guid, _
    keywordId As Guid, _
    browserId As Guid, _
    languageId As Guid, _
    currentPage As Integer, _
    lastPageTimestamp As DateTime _
) As Integer
Visual C++
public:
virtual int InsertSession(
    Guid sessionId,
    String^ aspNetSessionId,
    DateTime timestamp,
    Guid ipId,
    String^ ipAddress,
    Guid globalSessionId,
    int globalVisitNo,
    String^ domain,
    String^ multiSite,
    Guid screenId,
    Guid operatingSystemId,
    Guid referringSiteId,
    Guid keywordId,
    Guid browserId,
    Guid languageId,
    int currentPage,
    DateTime lastPageTimestamp
)

Parameters

sessionId
Type: System..::..Guid
The session id.
aspNetSessionId
Type: System..::..String
The ASP net session id.
timestamp
Type: System..::..DateTime
The timestamp.
ipId
Type: System..::..Guid
The ip id.
ipAddress
Type: System..::..String
The ip address.
globalSessionId
Type: System..::..Guid
The global session id.
globalVisitNo
Type: System..::..Int32
The global visit no.
domain
Type: System..::..String
The domain.
multiSite
Type: System..::..String
The multi site.
screenId
Type: System..::..Guid
The screen id.
operatingSystemId
Type: System..::..Guid
The operating system id.
referringSiteId
Type: System..::..Guid
The referring site id.
keywordId
Type: System..::..Guid
The keyword id.
browserId
Type: System..::..Guid
The browser id.
languageId
Type: System..::..Guid
The language id.
currentPage
Type: System..::..Int32
The current page.
lastPageTimestamp
Type: System..::..DateTime
The last page timestamp.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.InsertSession(System.Guid,System.String,System.DateTime,System.Guid,System.String,System.Guid,System.Int32,System.String,System.String,System.Guid,System.Guid,System.Guid,System.Guid,System.Guid,System.Guid,System.Int32,System.DateTime)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


InsertSubscription Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..InsertSubscription Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual int InsertSubscription(
    Guid subscriptionId,
    Guid ipOwnerId,
    string recipients
)
Visual Basic
Public Overridable Function InsertSubscription ( _
    subscriptionId As Guid, _
    ipOwnerId As Guid, _
    recipients As String _
) As Integer
Visual C++
public:
virtual int InsertSubscription(
    Guid subscriptionId,
    Guid ipOwnerId,
    String^ recipients
)

Parameters

subscriptionId
Type: System..::..Guid
The subscription id.
ipOwnerId
Type: System..::..Guid
The ip owner id.
recipients
Type: System..::..String
The recipients.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.InsertSubscription(System.Guid,System.Guid,System.String)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


InsertTag Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..InsertTag Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual int InsertTag(
    Guid tagId,
    Guid globalSessionId,
    string data,
    Guid acquaintance
)
Visual Basic
Public Overridable Function InsertTag ( _
    tagId As Guid, _
    globalSessionId As Guid, _
    data As String, _
    acquaintance As Guid _
) As Integer
Visual C++
public:
virtual int InsertTag(
    Guid tagId,
    Guid globalSessionId,
    String^ data,
    Guid acquaintance
)

Parameters

tagId
Type: System..::..Guid
The tag id.
globalSessionId
Type: System..::..Guid
The global session id.
data
Type: System..::..String
The data.
acquaintance
Type: System..::..Guid
The acquaintance.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.InsertTag(System.Guid,System.Guid,System.String,System.Guid)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


RawStringToGuid Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..RawStringToGuid Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract Guid RawStringToGuid(
    string rawString
)
Visual Basic
Public MustOverride Function RawStringToGuid ( _
    rawString As String _
) As Guid
Visual C++
public:
virtual Guid RawStringToGuid(
    String^ rawString
) abstract

Parameters

rawString
Type: System..::..String
The raw string.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.RawStringToGuid(System.String)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


ReadIP Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..ReadIP Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected virtual IP ReadIP(
    DataProviderReader reader
)
Visual Basic
Protected Overridable Function ReadIP ( _
    reader As DataProviderReader _
) As IP
Visual C++
protected:
virtual IP^ ReadIP(
    DataProviderReader^ reader
)

Parameters

reader
Type: Sitecore.Data.DataProviders.Sql..::..DataProviderReader
The reader.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.ReadIP(Sitecore.Data.DataProviders.Sql.DataProviderReader)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


ReadIPOwner Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..ReadIPOwner Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected virtual IPOwner ReadIPOwner(
    DataProviderReader reader
)
Visual Basic
Protected Overridable Function ReadIPOwner ( _
    reader As DataProviderReader _
) As IPOwner
Visual C++
protected:
virtual IPOwner^ ReadIPOwner(
    DataProviderReader^ reader
)

Parameters

reader
Type: Sitecore.Data.DataProviders.Sql..::..DataProviderReader
The reader.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.ReadIPOwner(Sitecore.Data.DataProviders.Sql.DataProviderReader)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


ReadMany Method

[image] [image]

Sitecore 6.4.1 API
AnalyticsProvider..::..ReadMany Method
AnalyticsProvider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadMany<(Of <<'(T>)>>)(String, Func<(Of <<'(DataProviderReader, T>)>>), array<Object>[]()[][]) | Reads the specified command text.
Public method | ReadMany<(Of <<'(T>)>>)(String, Func<(Of <<'(DataProviderReader, T>)>>), Int32, array<Object>[]()[][]) | Reads the specified command text.

See Also

AnalyticsProvider Class
AnalyticsProvider Members
Sitecore.Analytics.Data.DataProviders Namespace


ReadOne Method

[image] [image]

Sitecore 6.4.1 API
AnalyticsProvider..::..ReadOne Method
AnalyticsProvider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadOne<(Of <<'(T>)>>)(String, Func<(Of <<'(DataProviderReader, T>)>>), array<Object>[]()[][]) | Reads the one.
Public method | ReadOne<(Of <<'(T>)>>)(String, Func<(Of <<'(DataProviderReader, T>)>>), Func<(Of <<'(T>)>>), array<Object>[]()[][]) | Reads the specified command text.

See Also

AnalyticsProvider Class
AnalyticsProvider Members
Sitecore.Analytics.Data.DataProviders Namespace


ReadOne(T) Method (String, Func(DataProviderReader, T), Object[])

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..ReadOne<(Of <(<'T>)>)> Method (String, Func<(Of <(<'DataProviderReader, T>)>)>, array<Object>[]()[][])
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual T ReadOne<T>(
    string commandText,
    Func<DataProviderReader, T> selector,
    params Object[] parameters
)
Visual Basic
Public Overridable Function ReadOne(Of T) ( _
    commandText As String, _
    selector As Func(Of DataProviderReader, T), _
    ParamArray parameters As Object() _
) As T
Visual C++
public:
generic<typename T>
virtual T ReadOne(
    String^ commandText,
    Func<DataProviderReader^, T>^ selector,
    ... array<Object^>^ parameters
)

Parameters

commandText
Type: System..::..String
The command text.
selector
Type: System..::..Func <(Of <(<' DataProviderReader, T>)>)>
The selector.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.

Type Parameters

T
The type of instance.

Return Value

The instance of type T.

See Also

AnalyticsProvider Class
ReadOne Overload
Sitecore.Analytics.Data.DataProviders Namespace


ReadOne(T) Method (String, Func(DataProviderReader, T), Func(T), Object[])

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..ReadOne<(Of <(<'T>)>)> Method (String, Func<(Of <(<'DataProviderReader, T>)>)>, Func<(Of <(<'T>)>)>, array<Object>[]()[][])
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual T ReadOne<T>(
    string commandText,
    Func<DataProviderReader, T> selector,
    Func<T> defaulter,
    params Object[] parameters
)
Visual Basic
Public Overridable Function ReadOne(Of T) ( _
    commandText As String, _
    selector As Func(Of DataProviderReader, T), _
    defaulter As Func(Of T), _
    ParamArray parameters As Object() _
) As T
Visual C++
public:
generic<typename T>
virtual T ReadOne(
    String^ commandText,
    Func<DataProviderReader^, T>^ selector,
    Func<T>^ defaulter,
    ... array<Object^>^ parameters
)

Parameters

commandText
Type: System..::..String
The command text.
selector
Type: System..::..Func <(Of <(<' DataProviderReader, T>)>)>
The selector.
defaulter
Type: System..::..Func <(Of <(<'T>)>)>
The defaulter.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.

Type Parameters

T
The type of field.

Return Value

The value of the field.

See Also

AnalyticsProvider Class
ReadOne Overload
Sitecore.Analytics.Data.DataProviders Namespace


ReadProfile Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..ReadProfile Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected virtual Profile ReadProfile(
    DataProviderReader reader
)
Visual Basic
Protected Overridable Function ReadProfile ( _
    reader As DataProviderReader _
) As Profile
Visual C++
protected:
virtual Profile^ ReadProfile(
    DataProviderReader^ reader
)

Parameters

reader
Type: Sitecore.Data.DataProviders.Sql..::..DataProviderReader
The reader.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.ReadProfile(Sitecore.Data.DataProviders.Sql.DataProviderReader)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


SaveCampaignDefinition Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..SaveCampaignDefinition Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual void SaveCampaignDefinition(
    Guid campaignId,
    string title,
    string type,
    string description,
    double cost,
    DateTime startDate,
    DateTime endDate,
    bool isActive,
    string data
)
Visual Basic
Public Overridable Sub SaveCampaignDefinition ( _
    campaignId As Guid, _
    title As String, _
    type As String, _
    description As String, _
    cost As Double, _
    startDate As DateTime, _
    endDate As DateTime, _
    isActive As Boolean, _
    data As String _
)
Visual C++
public:
virtual void SaveCampaignDefinition(
    Guid campaignId,
    String^ title,
    String^ type,
    String^ description,
    double cost,
    DateTime startDate,
    DateTime endDate,
    bool isActive,
    String^ data
)

Parameters

campaignId
Type: System..::..Guid
The campaign id.
title
Type: System..::..String
The title.
type
Type: System..::..String
The type of campaign.
description
Type: System..::..String
The description.
cost
Type: System..::..Double
The cost of the campaign.
startDate
Type: System..::..DateTime
The start date.
endDate
Type: System..::..DateTime
The end date.
isActive
Type: System..::..Boolean
if set to true [is active].
data
Type: System..::..String
The data.

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


SaveCampaignEvent Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..SaveCampaignEvent Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual void SaveCampaignEvent(
    Guid campaignEventId,
    Guid campaignId,
    DateTime dateTime,
    string data
)
Visual Basic
Public Overridable Sub SaveCampaignEvent ( _
    campaignEventId As Guid, _
    campaignId As Guid, _
    dateTime As DateTime, _
    data As String _
)
Visual C++
public:
virtual void SaveCampaignEvent(
    Guid campaignEventId,
    Guid campaignId,
    DateTime dateTime,
    String^ data
)

Parameters

campaignEventId
Type: System..::..Guid
The campaign event id.
campaignId
Type: System..::..Guid
The campaign id.
dateTime
Type: System..::..DateTime
The date time.
data
Type: System..::..String
The campaign data.

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


SaveMultiVarianceTestDefinition Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..SaveMultiVarianceTestDefinition Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual void SaveMultiVarianceTestDefinition(
    Guid multiVarianceTestId,
    string title,
    string description
)
Visual Basic
Public Overridable Sub SaveMultiVarianceTestDefinition ( _
    multiVarianceTestId As Guid, _
    title As String, _
    description As String _
)
Visual C++
public:
virtual void SaveMultiVarianceTestDefinition(
    Guid multiVarianceTestId,
    String^ title,
    String^ description
)

Parameters

multiVarianceTestId
Type: System..::..Guid
The multi variance test id.
title
Type: System..::..String
The title.
description
Type: System..::..String
The description.

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


SavePageEventDefinition Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..SavePageEventDefinition Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual void SavePageEventDefinition(
    Guid pageEventDefinitionId,
    string name,
    string icon,
    string description,
    bool isSystem,
    bool isAuthorFeedback,
    bool isGoal,
    bool isFailure
)
Visual Basic
Public Overridable Sub SavePageEventDefinition ( _
    pageEventDefinitionId As Guid, _
    name As String, _
    icon As String, _
    description As String, _
    isSystem As Boolean, _
    isAuthorFeedback As Boolean, _
    isGoal As Boolean, _
    isFailure As Boolean _
)
Visual C++
public:
virtual void SavePageEventDefinition(
    Guid pageEventDefinitionId,
    String^ name,
    String^ icon,
    String^ description,
    bool isSystem,
    bool isAuthorFeedback,
    bool isGoal,
    bool isFailure
)

Parameters

pageEventDefinitionId
Type: System..::..Guid
The page event definition id.
name
Type: System..::..String
The name of the page event.
icon
Type: System..::..String
The icon of the page event.
description
Type: System..::..String
The description.
isSystem
Type: System..::..Boolean
if set to true [is system].
isAuthorFeedback
Type: System..::..Boolean
if set to true [is author feedback].
isGoal
Type: System..::..Boolean
if set to true [is goal].
isFailure
Type: System..::..Boolean
if set to true [is failure].

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


SaveProfileDefinition Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..SaveProfileDefinition Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual void SaveProfileDefinition(
    Guid profileDefinitionId,
    string name,
    string profileType
)
Visual Basic
Public Overridable Sub SaveProfileDefinition ( _
    profileDefinitionId As Guid, _
    name As String, _
    profileType As String _
)
Visual C++
public:
virtual void SaveProfileDefinition(
    Guid profileDefinitionId,
    String^ name,
    String^ profileType
)

Parameters

profileDefinitionId
Type: System..::..Guid
The profile definition id.
name
Type: System..::..String
The name of the profile.
profileType
Type: System..::..String
The type of the profile.

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


SetStatusFailed Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..SetStatusFailed Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void SetStatusFailed(
    Guid id
)
Visual Basic
Public Sub SetStatusFailed ( _
    id As Guid _
)
Visual C++
public:
void SetStatusFailed(
    Guid id
)

Parameters

id
Type: System..::..Guid
The failed id.

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


SetStatusSuccessful Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..SetStatusSuccessful Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void SetStatusSuccessful(
    Guid id
)
Visual Basic
Public Sub SetStatusSuccessful ( _
    id As Guid _
)
Visual C++
public:
void SetStatusSuccessful(
    Guid id
)

Parameters

id
Type: System..::..Guid
The successful id.

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


Submit Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..Submit Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual void Submit(
    AnalyticsTracker analyticsTracker,
    bool defer
)
Visual Basic
Public Overridable Sub Submit ( _
    analyticsTracker As AnalyticsTracker, _
    defer As Boolean _
)
Visual C++
public:
virtual void Submit(
    AnalyticsTracker^ analyticsTracker,
    bool defer
)

Parameters

analyticsTracker
Type: Sitecore.Analytics..::..AnalyticsTracker
The experience tracker.
defer
Type: System..::..Boolean
if set to true [defer].

Exceptions

Exception | Condition
System..::..Exception | Exception.

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


SubmitTracker Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..SubmitTracker Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual void SubmitTracker(
    AnalyticsTracker analyticsTracker
)
Visual Basic
Public Overridable Sub SubmitTracker ( _
    analyticsTracker As AnalyticsTracker _
)
Visual C++
public:
virtual void SubmitTracker(
    AnalyticsTracker^ analyticsTracker
)

Parameters

analyticsTracker
Type: Sitecore.Analytics..::..AnalyticsTracker
The analytics tracker.

Exceptions

Exception | Condition
System..::..Exception | Failed to insert Analytics data.

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


UpdateBothIdentificationsBySessionId Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..UpdateBothIdentificationsBySessionId Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract int UpdateBothIdentificationsBySessionId(
    Guid sessionId
)
Visual Basic
Public MustOverride Function UpdateBothIdentificationsBySessionId ( _
    sessionId As Guid _
) As Integer
Visual C++
public:
virtual int UpdateBothIdentificationsBySessionId(
    Guid sessionId
) abstract

Parameters

sessionId
Type: System..::..Guid
The session id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.UpdateBothIdentificationsBySessionId(System.Guid)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


UpdateCampaign Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..UpdateCampaign Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual int UpdateCampaign(
    Guid campaignId,
    string title,
    string type,
    string description,
    double cost,
    DateTime startDate,
    DateTime endDate,
    string data,
    bool isActive
)
Visual Basic
Public Overridable Function UpdateCampaign ( _
    campaignId As Guid, _
    title As String, _
    type As String, _
    description As String, _
    cost As Double, _
    startDate As DateTime, _
    endDate As DateTime, _
    data As String, _
    isActive As Boolean _
) As Integer
Visual C++
public:
virtual int UpdateCampaign(
    Guid campaignId,
    String^ title,
    String^ type,
    String^ description,
    double cost,
    DateTime startDate,
    DateTime endDate,
    String^ data,
    bool isActive
)

Parameters

campaignId
Type: System..::..Guid
The campaign id.
title
Type: System..::..String
The title.
type
Type: System..::..String
The type.
description
Type: System..::..String
The description.
cost
Type: System..::..Double
The cost.
startDate
Type: System..::..DateTime
The start date.
endDate
Type: System..::..DateTime
The end date.
data
Type: System..::..String
The data.
isActive
Type: System..::..Boolean
if set to true [is active].

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.UpdateCampaign(System.Guid,System.String,System.String,System.String,System.Double,System.DateTime,System.DateTime,System.String,System.Boolean)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


UpdateCampaignEvent Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..UpdateCampaignEvent Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual int UpdateCampaignEvent(
    Guid campaignEventId,
    Guid campaignId,
    string data,
    DateTime dateTime
)
Visual Basic
Public Overridable Function UpdateCampaignEvent ( _
    campaignEventId As Guid, _
    campaignId As Guid, _
    data As String, _
    dateTime As DateTime _
) As Integer
Visual C++
public:
virtual int UpdateCampaignEvent(
    Guid campaignEventId,
    Guid campaignId,
    String^ data,
    DateTime dateTime
)

Parameters

campaignEventId
Type: System..::..Guid
The campaign event id.
campaignId
Type: System..::..Guid
The campaign id.
data
Type: System..::..String
The data.
dateTime
Type: System..::..DateTime
The date time.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.UpdateCampaignEvent(System.Guid,System.Guid,System.String,System.DateTime)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


UpdateCountTotalByProfileId Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..UpdateCountTotalByProfileId Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual int UpdateCountTotalByProfileId(
    Guid profileId,
    int count,
    int total
)
Visual Basic
Public Overridable Function UpdateCountTotalByProfileId ( _
    profileId As Guid, _
    count As Integer, _
    total As Integer _
) As Integer
Visual C++
public:
virtual int UpdateCountTotalByProfileId(
    Guid profileId,
    int count,
    int total
)

Parameters

profileId
Type: System..::..Guid
The profile id.
count
Type: System..::..Int32
The count.
total
Type: System..::..Int32
The total.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.UpdateCountTotalByProfileId(System.Guid,System.Int32,System.Int32)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


UpdateCurrentPageBySessionId Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..UpdateCurrentPageBySessionId Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int UpdateCurrentPageBySessionId(
    Guid sessionId,
    int currentPage
)
Visual Basic
Public Function UpdateCurrentPageBySessionId ( _
    sessionId As Guid, _
    currentPage As Integer _
) As Integer
Visual C++
public:
int UpdateCurrentPageBySessionId(
    Guid sessionId,
    int currentPage
)

Parameters

sessionId
Type: System..::..Guid
The session id.
currentPage
Type: System..::..Int32
The current page.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.UpdateCurrentPageBySessionId(System.Guid,System.Int32)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


UpdateIP Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..UpdateIP Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual int UpdateIP(
    IP ip
)
Visual Basic
Public Overridable Function UpdateIP ( _
    ip As IP _
) As Integer
Visual C++
public:
virtual int UpdateIP(
    IP^ ip
)

Parameters

ip
Type: Sitecore.Analytics..::..IP
The ip.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.UpdateIP(Sitecore.Analytics.IP)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


UpdateIpInformation Method

[image] [image]

Sitecore 6.4.1 API
AnalyticsProvider..::..UpdateIpInformation Method
AnalyticsProvider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UpdateIpInformation(Guid, WhoIsInformation) | Updates the ip information with default post step action.
Public method | UpdateIpInformation(Guid, WhoIsInformation, Action<(Of <<'(IP>)>>)) | Updates the ip information.

See Also

AnalyticsProvider Class
AnalyticsProvider Members
Sitecore.Analytics.Data.DataProviders Namespace


UpdateIpInformation Method (Guid, WhoIsInformation)

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..UpdateIpInformation Method (Guid, WhoIsInformation)
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual void UpdateIpInformation(
    Guid ipId,
    WhoIsInformation information
)
Visual Basic
Public Overridable Sub UpdateIpInformation ( _
    ipId As Guid, _
    information As WhoIsInformation _
)
Visual C++
public:
virtual void UpdateIpInformation(
    Guid ipId,
    WhoIsInformation^ information
)

Parameters

ipId
Type: System..::..Guid
The ip id.
information
Type: Sitecore.Analytics.Lookups..::..WhoIsInformation
The information.

See Also

AnalyticsProvider Class
UpdateIpInformation Overload
Sitecore.Analytics.Data.DataProviders Namespace


UpdateIpInformation Method (Guid, WhoIsInformation, Action(IP))

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..UpdateIpInformation Method (Guid, WhoIsInformation, Action<(Of <(<'IP>)>)>)
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual void UpdateIpInformation(
    Guid ipId,
    WhoIsInformation information,
    Action<IP> postUpdateAction
)
Visual Basic
Public Overridable Sub UpdateIpInformation ( _
    ipId As Guid, _
    information As WhoIsInformation, _
    postUpdateAction As Action(Of IP) _
)
Visual C++
public:
virtual void UpdateIpInformation(
    Guid ipId,
    WhoIsInformation^ information,
    Action<IP^>^ postUpdateAction
)

Parameters

ipId
Type: System..::..Guid
The ip id.
information
Type: Sitecore.Analytics.Lookups..::..WhoIsInformation
The information.
postUpdateAction
Type: System..::..Action <(Of <(<' IP >)>)>
The post update.

See Also

AnalyticsProvider Class
UpdateIpInformation Overload
Sitecore.Analytics.Data.DataProviders Namespace


UpdateIPOwner Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..UpdateIPOwner Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual int UpdateIPOwner(
    IPOwner ipOwner
)
Visual Basic
Public Overridable Function UpdateIPOwner ( _
    ipOwner As IPOwner _
) As Integer
Visual C++
public:
virtual int UpdateIPOwner(
    IPOwner^ ipOwner
)

Parameters

ipOwner
Type: Sitecore.Analytics..::..IPOwner
The ip owner.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.UpdateIPOwner(Sitecore.Analytics.IPOwner)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


UpdateMultiVarianceTestDefinition Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..UpdateMultiVarianceTestDefinition Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual int UpdateMultiVarianceTestDefinition(
    Guid multiVarianceTestId,
    string title,
    string description
)
Visual Basic
Public Overridable Function UpdateMultiVarianceTestDefinition ( _
    multiVarianceTestId As Guid, _
    title As String, _
    description As String _
) As Integer
Visual C++
public:
virtual int UpdateMultiVarianceTestDefinition(
    Guid multiVarianceTestId,
    String^ title,
    String^ description
)

Parameters

multiVarianceTestId
Type: System..::..Guid
The multi variance test id.
title
Type: System..::..String
The title.
description
Type: System..::..String
The description.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.UpdateMultiVarianceTestDefinition(System.Guid,System.String,System.String)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


UpdatePage Method

[image] [image]

Sitecore 6.4.1 API
AnalyticsProvider..::..UpdatePage Method
AnalyticsProvider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UpdatePage(Guid, DateTime, Int32, Int32, Guid, String, Int32, Guid, String, String, String, String) | Updates the page.
Public method | UpdatePage(Guid, Guid, DateTime, Int32, Int32, Guid, String, Int32, Guid, String, String, String, String) | Updates the page.

See Also

AnalyticsProvider Class
AnalyticsProvider Members
Sitecore.Analytics.Data.DataProviders Namespace


UpdatePage Method (Guid, DateTime, Int32, Int32, Guid, String, Int32, Guid, String, String, String, String)

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..UpdatePage Method (Guid, DateTime, Int32, Int32, Guid, String, Int32, Guid, String, String, String, String)
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual int UpdatePage(
    Guid pageId,
    DateTime timestamp,
    int duration,
    int pageNo,
    Guid itemId,
    string itemLanguage,
    int itemVersion,
    Guid deviceId,
    string navigation,
    string url,
    string indexableUrl,
    string data
)
Visual Basic
Public Overridable Function UpdatePage ( _
    pageId As Guid, _
    timestamp As DateTime, _
    duration As Integer, _
    pageNo As Integer, _
    itemId As Guid, _
    itemLanguage As String, _
    itemVersion As Integer, _
    deviceId As Guid, _
    navigation As String, _
    url As String, _
    indexableUrl As String, _
    data As String _
) As Integer
Visual C++
public:
virtual int UpdatePage(
    Guid pageId,
    DateTime timestamp,
    int duration,
    int pageNo,
    Guid itemId,
    String^ itemLanguage,
    int itemVersion,
    Guid deviceId,
    String^ navigation,
    String^ url,
    String^ indexableUrl,
    String^ data
)

Parameters

pageId
Type: System..::..Guid
The page id.
timestamp
Type: System..::..DateTime
The timestamp.
duration
Type: System..::..Int32
The duration.
pageNo
Type: System..::..Int32
The page no.
itemId
Type: System..::..Guid
The item id.
itemLanguage
Type: System..::..String
The item language.
itemVersion
Type: System..::..Int32
The item version.
deviceId
Type: System..::..Guid
The device id.
navigation
Type: System..::..String
The navigation.
url
Type: System..::..String
The URL.
indexableUrl
Type: System..::..String
The indexable URL.
data
Type: System..::..String
The data.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.UpdatePage(System.Guid,System.DateTime,System.Int32,System.Int32,System.Guid,System.String,System.Int32,System.Guid,System.String,System.String,System.String,System.String)"]

See Also

AnalyticsProvider Class
UpdatePage Overload
Sitecore.Analytics.Data.DataProviders Namespace


UpdateVisitorIdentificationByIpOwnerId Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..UpdateVisitorIdentificationByIpOwnerId Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract int UpdateVisitorIdentificationByIpOwnerId(
    Guid ipOwnerId
)
Visual Basic
Public MustOverride Function UpdateVisitorIdentificationByIpOwnerId ( _
    ipOwnerId As Guid _
) As Integer
Visual C++
public:
virtual int UpdateVisitorIdentificationByIpOwnerId(
    Guid ipOwnerId
) abstract

Parameters

ipOwnerId
Type: System..::..Guid
The ip owner id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.UpdateVisitorIdentificationByIpOwnerId(System.Guid)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


UpdateVisitorIdentificationBySessionId Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..UpdateVisitorIdentificationBySessionId Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract int UpdateVisitorIdentificationBySessionId(
    Guid sessionId
)
Visual Basic
Public MustOverride Function UpdateVisitorIdentificationBySessionId ( _
    sessionId As Guid _
) As Integer
Visual C++
public:
virtual int UpdateVisitorIdentificationBySessionId(
    Guid sessionId
) abstract

Parameters

sessionId
Type: System..::..Guid
The session id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.UpdateVisitorIdentificationBySessionId(System.Guid)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


UpdateVisitorIdentifications Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..UpdateVisitorIdentifications Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract int UpdateVisitorIdentifications()
Visual Basic
Public MustOverride Function UpdateVisitorIdentifications As Integer
Visual C++
public:
virtual int UpdateVisitorIdentifications() abstract

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.UpdateVisitorIdentifications"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


UpdateVisitorIdentificationsByIPOwnerBrowser Method

[image]

Sitecore 6.4.1 API
AnalyticsProvider..::..UpdateVisitorIdentificationsByIPOwnerBrowser Method
AnalyticsProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract int UpdateVisitorIdentificationsByIPOwnerBrowser(
    Guid browserId,
    Guid ipId,
    Guid ipOwnerId
)
Visual Basic
Public MustOverride Function UpdateVisitorIdentificationsByIPOwnerBrowser ( _
    browserId As Guid, _
    ipId As Guid, _
    ipOwnerId As Guid _
) As Integer
Visual C++
public:
virtual int UpdateVisitorIdentificationsByIPOwnerBrowser(
    Guid browserId,
    Guid ipId,
    Guid ipOwnerId
) abstract

Parameters

browserId
Type: System..::..Guid
The browser id.
ipId
Type: System..::..Guid
The ip id.
ipOwnerId
Type: System..::..Guid
The ip owner id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProvider.UpdateVisitorIdentificationsByIPOwnerBrowser(System.Guid,System.Guid,System.Guid)"]

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


AnalyticsProvider Properties

[image] [image]

Sitecore 6.4.1 API
AnalyticsProvider Properties
AnalyticsProvider Class See Also Send Feedback

The AnalyticsProvider type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

AnalyticsProvider Class
Sitecore.Analytics.Data.DataProviders Namespace


AnalyticsProviderCollection Class

[image]

Sitecore 6.4.1 API
AnalyticsProviderCollection Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class AnalyticsProviderCollection : ProviderCollection
Visual Basic
Public Class AnalyticsProviderCollection _
    Inherits ProviderCollection
Visual C++
public ref class AnalyticsProviderCollection : public ProviderCollection

Inheritance Hierarchy

System..::..Object
System.Configuration.Provider..::..ProviderCollection
Sitecore.Analytics.Data.DataProviders..::..AnalyticsProviderCollection

See Also

AnalyticsProviderCollection Members
Sitecore.Analytics.Data.DataProviders Namespace


AnalyticsProviderCollection Members

[image] [image]

Sitecore 6.4.1 API
AnalyticsProviderCollection Members
AnalyticsProviderCollection Class Constructors Methods Properties See Also Send Feedback

The AnalyticsProviderCollection type exposes the following members.

Constructors

 | Name | Description
Public method | AnalyticsProviderCollection | Initializes a new instance of the AnalyticsProviderCollection class

Methods

 | Name | Description
Public method | Add(ProviderBase) | Adds a provider to the collection. (Overrides ProviderCollection..::..Add(ProviderBase).)
Public method | Add(AnalyticsProvider) | Adds the specified provider.
Public method | Clear | Removes all items from the collection. (Inherited from ProviderCollection.)
Public method | CopyTo | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a provider from the collection. (Inherited from ProviderCollection.)
Public method | SetReadOnly | Sets the collection to be read-only. (Inherited from ProviderCollection.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
Public property | Item | Gets the AnalyticsProvider with the specified name.
Public property | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)

See Also

AnalyticsProviderCollection Class
Sitecore.Analytics.Data.DataProviders Namespace


AnalyticsProviderCollection Constructor

[image]

Sitecore 6.4.1 API
AnalyticsProviderCollection Constructor
AnalyticsProviderCollection Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public AnalyticsProviderCollection()
Visual Basic
Public Sub New
Visual C++
public:
AnalyticsProviderCollection()

See Also

AnalyticsProviderCollection Class
Sitecore.Analytics.Data.DataProviders Namespace


AnalyticsProviderCollection Methods

[image] [image]

Sitecore 6.4.1 API
AnalyticsProviderCollection Methods
AnalyticsProviderCollection Class See Also Send Feedback

The AnalyticsProviderCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add(ProviderBase) | Adds a provider to the collection. (Overrides ProviderCollection..::..Add(ProviderBase).)
Public method | Add(AnalyticsProvider) | Adds the specified provider.
Public method | Clear | Removes all items from the collection. (Inherited from ProviderCollection.)
Public method | CopyTo | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a provider from the collection. (Inherited from ProviderCollection.)
Public method | SetReadOnly | Sets the collection to be read-only. (Inherited from ProviderCollection.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticsProviderCollection Class
Sitecore.Analytics.Data.DataProviders Namespace


Add Method

[image] [image]

Sitecore 6.4.1 API
AnalyticsProviderCollection..::..Add Method
AnalyticsProviderCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(ProviderBase) | Adds a provider to the collection. (Overrides ProviderCollection..::..Add(ProviderBase).)
Public method | Add(AnalyticsProvider) | Adds the specified provider.

See Also

AnalyticsProviderCollection Class
AnalyticsProviderCollection Members
Sitecore.Analytics.Data.DataProviders Namespace


Add Method (ProviderBase)

[image]

Sitecore 6.4.1 API
AnalyticsProviderCollection..::..Add Method (ProviderBase)
AnalyticsProviderCollection Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void Add(
    ProviderBase provider
)
Visual Basic
Public Overrides Sub Add ( _
    provider As ProviderBase _
)
Visual C++
public:
virtual void Add(
    ProviderBase^ provider
) override

Parameters

provider
Type: System.Configuration.Provider..::..ProviderBase
The provider to be added.

Exceptions

Exception | Condition
System..::..NotSupportedException | The collection is read-only.
System..::..ArgumentNullException | provider is null.
System..::..ArgumentException | The Name of provider is null.- or -The length of the Name of provider is less than 1.

See Also

AnalyticsProviderCollection Class
Add Overload
Sitecore.Analytics.Data.DataProviders Namespace


AnalyticsProviderCollection Properties

[image] [image]

Sitecore 6.4.1 API
AnalyticsProviderCollection Properties
AnalyticsProviderCollection Class See Also Send Feedback

The AnalyticsProviderCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
Public property | Item | Gets the AnalyticsProvider with the specified name.
Public property | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)

See Also

AnalyticsProviderCollection Class
Sitecore.Analytics.Data.DataProviders Namespace


Item Property

[image]

Sitecore 6.4.1 API
AnalyticsProviderCollection..::..Item Property
AnalyticsProviderCollection Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual AnalyticsProvider this[
    string name
] { get; }
Visual Basic
Public Overridable ReadOnly Default Property Item ( _
    name As String _
) As AnalyticsProvider
    Get
Visual C++
public:
virtual property AnalyticsProvider^ default[String^ name] {
    AnalyticsProvider^ get (String^ name);
}

Parameters

name
Type: System..::..String
The name of the Analytics Provider.

Field Value

The AnalyticsProvider with the specified name.

See Also

AnalyticsProviderCollection Class
Sitecore.Analytics.Data.DataProviders Namespace


AnalyticsProviderSqlServer Class

[image]

Sitecore 6.4.1 API
AnalyticsProviderSqlServer Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class AnalyticsProviderSqlServer : AnalyticsProvider
Visual Basic
Public Class AnalyticsProviderSqlServer _
    Inherits AnalyticsProvider
Visual C++
public ref class AnalyticsProviderSqlServer : public AnalyticsProvider

Inheritance Hierarchy

System..::..Object
System.Configuration.Provider..::..ProviderBase
Sitecore.Analytics.Data.DataProviders..::..AnalyticsProvider
Sitecore.Analytics.Data.DataProviders..::..AnalyticsProviderSqlServer

See Also

AnalyticsProviderSqlServer Members
Sitecore.Analytics.Data.DataProviders Namespace


AnalyticsProviderSqlServer Members

[image] [image]

Sitecore 6.4.1 API
AnalyticsProviderSqlServer Members
AnalyticsProviderSqlServer Class Constructors Methods Fields Properties See Also Send Feedback

The AnalyticsProviderSqlServer type exposes the following members.

Constructors

 | Name | Description
Public method | AnalyticsProviderSqlServer | Initializes a new instance of the AnalyticsProviderSqlServer class.

Methods

 | Name | Description
Protected method | CreateReader | Creates the reader. (Inherited from AnalyticsProvider.)
Public method | DeleteSubscription | Deletes the subscription. (Inherited from AnalyticsProvider.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the specified command text. (Inherited from AnalyticsProvider.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FormatBigString | Convert to the char. (Overrides AnalyticsProvider..::..FormatBigString(String).)
Public method | FormatCommandText | Formats the command text. (Inherited from AnalyticsProvider.)
Public method | FormatFunctionName | Formats the name of the function. (Overrides AnalyticsProvider..::..FormatFunctionName(String).)
Public method | GetAddIpIdByAddressFrom | Gets the ip ID by address from. (Inherited from AnalyticsProvider.)
Public method | GetAddIpOwnerIdByNameAndCountry | Gets the IP owner id. (Inherited from AnalyticsProvider.)
Public method | GetBrowserById | Gets the browser by id. (Inherited from AnalyticsProvider.)
Public method | GetBrowserIdByUserAgent | Gets the browser by user agent. (Inherited from AnalyticsProvider.)
Public method | GetBrowsers | Gets the browsers. (Inherited from AnalyticsProvider.)
Public method | GetCampaignById | Gets the campaign by id. (Inherited from AnalyticsProvider.)
Public method | GetCampaignEventById | Gets the campaign event by id. (Inherited from AnalyticsProvider.)
Public method | GetCampaignEvents | Gets the campaign events. (Inherited from AnalyticsProvider.)
Public method | GetCampaignEventsByCampaignId | Gets the campaign events by campaign id. (Inherited from AnalyticsProvider.)
Public method | GetCampaigns | Gets the campaigns. (Inherited from AnalyticsProvider.)
Public method | GetConnectionString | Gets the connection string. (Inherited from AnalyticsProvider.)
Public method | GetDateTime | Gets the date time. (Inherited from AnalyticsProvider.)
Public method | GetDouble | Gets the double. (Overrides AnalyticsProvider..::..GetDouble(Int32, DataProviderReader).)
Public method | GetGlobalSessionById | Gets the global session by id. (Inherited from AnalyticsProvider.)
Public method | GetGlobalSessionIdByCookieValue | Gets the global session id by cookie value. (Inherited from AnalyticsProvider.)
Public method | GetGlobalSessions | Gets the global sessions. (Inherited from AnalyticsProvider.)
Public method | GetGuid | Gets the GUID. (Inherited from AnalyticsProvider.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInt | Gets the int. (Inherited from AnalyticsProvider.)
Public method | GetIPById | Gets the IP by id. (Inherited from AnalyticsProvider.)
Public method | GetIPBySessionId | Gets the IP by session id. (Inherited from AnalyticsProvider.)
Public method | GetIpOwnerById | Gets the ip owner by id. (Inherited from AnalyticsProvider.)
Public method | GetIpOwnerBySessionId | Gets the ip owner by session id. (Inherited from AnalyticsProvider.)
Public method | GetIpOwnerIdsBySessionId | Gets the ip owner ids by session id. (Inherited from AnalyticsProvider.)
Public method | GetIPs | Gets the I ps. (Inherited from AnalyticsProvider.)
Public method | GetIPsByOwnerId | Gets the IPs by owner id. (Inherited from AnalyticsProvider.)
Public method | GetKeywordIdByKeywords | Gets the keyword id by keywords. (Inherited from AnalyticsProvider.)
Public method | GetKeywordsBySessionId | Gets the keywords by session id. (Inherited from AnalyticsProvider.)
Public method | GetLong | Gets the big int. (Inherited from AnalyticsProvider.)
Public method | GetLookupData | Gets the lookup data. (Inherited from AnalyticsProvider.)
Public method | GetMatchReportQueryPattern | Gets the match report query pattern. (Overrides AnalyticsProvider..::..GetMatchReportQueryPattern()()()().)
Public method | GetMultiVarianceTestDefinitionById | Gets the multi variance test definition by id. (Inherited from AnalyticsProvider.)
Public method | GetMultiVarianceTestDefinitions | Gets the multi variance test definitions. (Inherited from AnalyticsProvider.)
Public method | GetMultiVarianceTestVariableById | Gets the multi variance test variable by id. (Inherited from AnalyticsProvider.)
Public method | GetMultiVarianceTestVariablesByTestDefinitionId | Gets the multi variance test variables by test definition id. (Inherited from AnalyticsProvider.)
Public method | GetOperatingSystemById | Gets the operating system by id. (Inherited from AnalyticsProvider.)
Public method | GetOperatingSystems | Gets the operating systems. (Inherited from AnalyticsProvider.)
Public method | GetPageById | Gets the page by id. (Inherited from AnalyticsProvider.)
Public method | GetPageBySessionIdAndPageNo | Gets the page by session id and page no. (Inherited from AnalyticsProvider.)
Public method | GetPageEventById | Gets the page event by id. (Inherited from AnalyticsProvider.)
Public method | GetPageEventDefinitionById | Gets the page event definition by id. (Inherited from AnalyticsProvider.)
Public method | GetPageEventDefinitionFailureNotSystem | Gets the page event definition failure system. (Inherited from AnalyticsProvider.)
Public method | GetPageEventDefinitionNotGoalNotFailureNotSystem | Gets the page event definition goal failure not system. (Inherited from AnalyticsProvider.)
Public method | GetPageEventDefinitions | Gets the page event definitions. (Inherited from AnalyticsProvider.)
Public method | GetPageEventDefinitionsIsGoalNotSystem | Gets the page event definitions is goal not system. (Inherited from AnalyticsProvider.)
Public method | GetPageEventsByPageId | Gets the page events by page id. (Inherited from AnalyticsProvider.)
Public method | GetPagesBySessionId | Gets the pages by session id. (Inherited from AnalyticsProvider.)
Public method | GetProfileById | Gets the profile by id. (Inherited from AnalyticsProvider.)
Public method | GetProfileDefinitionById | Gets the profile definition by id. (Inherited from AnalyticsProvider.)
Public method | GetProfileDefinitions | Gets the profile definitions. (Inherited from AnalyticsProvider.)
Public method | GetProfileKeyDefinitionById | Gets the profile key definition by id. (Inherited from AnalyticsProvider.)
Public method | GetProfileKeyDefinitions | Gets the profile key definitions. (Inherited from AnalyticsProvider.)
Public method | GetProfileKeyDefinitionsById | Gets the profile key definitions by profile definition id. (Inherited from AnalyticsProvider.)
Public method | GetProfileKeysByProfileId | Gets the profile keys by profile id. (Inherited from AnalyticsProvider.)
Public method | GetProfilesBySessionId | Gets the profiles by session id. (Inherited from AnalyticsProvider.)
Public method | GetReferringSiteByUrl | Gets the referring site by URL. (Inherited from AnalyticsProvider.)
Public method | GetReferringSites | Gets the referring sites. (Inherited from AnalyticsProvider.)
Public method | GetReportsDatabase | Gets the reports database. (Overrides AnalyticsProvider..::..GetReportsDatabase()()()().)
Public method | GetReportsDataSourceType | Gets the type of the reports data source. (Overrides AnalyticsProvider..::..GetReportsDataSourceType()()()().)
Public method | GetScreenByScreenId | Gets the screen by screen id. (Inherited from AnalyticsProvider.)
Public method | GetScreens | Gets the screens. (Inherited from AnalyticsProvider.)
Public method | GetSessionByAspNetSessionId | Gets the session by ASP net session id. (Inherited from AnalyticsProvider.)
Public method | GetSessionBySessionId | Gets the session by session id. (Inherited from AnalyticsProvider.)
Public method | GetSessionIdByAspNetSessionId | Gets the session id by ASP net session id. (Inherited from AnalyticsProvider.)
Public method | GetStatusById | Gets the status. (Inherited from AnalyticsProvider.)
Public method | GetStatuses | Gets the statuses. (Inherited from AnalyticsProvider.)
Public method | GetString | Gets the string. (Inherited from AnalyticsProvider.)
Public method | GetSubscription | Gets the subscription. (Inherited from AnalyticsProvider.)
Public method | GetSubscriptionById | Gets the subscription by id. (Inherited from AnalyticsProvider.)
Public method | GetTagById | Gets the tag by id. (Inherited from AnalyticsProvider.)
Public method | GetTagsByGlobalSessionId | Gets the tags by global session id. (Inherited from AnalyticsProvider.)
Public method | GetTotalByGlobalSessionId | Gets the total by global session id. (Inherited from AnalyticsProvider.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVendorSpecificReportPath | Gets the vendor specific report path. (Inherited from AnalyticsProvider.)
Public method | GuidToRawString | GUIDs to raw string. (Overrides AnalyticsProvider..::..GuidToRawString(Guid).)
Public method | Initialize | Initializes the provider. (Inherited from ProviderBase.)
Public method | InsertBrowser | Inserts the browser. (Inherited from AnalyticsProvider.)
Public method | InsertCampaign | Inserts the campaign. (Inherited from AnalyticsProvider.)
Public method | InsertCampaignEvent | Inserts the campaign event. (Inherited from AnalyticsProvider.)
Public method | InsertCampaignEventPage | Inserts the campaign event page. (Inherited from AnalyticsProvider.)
Public method | InsertGlobalSession | Inserts the global session. (Inherited from AnalyticsProvider.)
Public method | InsertIPOwner | Inserts the IP owner. (Inherited from AnalyticsProvider.)
Public method | InsertKeyword | Inserts the keyword. (Inherited from AnalyticsProvider.)
Public method | InsertMultiVarianceTestDefinition(Guid, String, String) | Inserts the multi variance test definition. (Inherited from AnalyticsProvider.)
Public method | InsertMultiVarianceTestDefinition(String, String, Guid) | Inserts the multi variance test definition. (Inherited from AnalyticsProvider.)
Public method | InsertMultiVarianceTestVariable | Inserts the multi variance test variable. (Inherited from AnalyticsProvider.)
Public method | InsertMultiVarianceTestVariableCampaignEvent | Inserts the multi variance test variable campaign event. (Inherited from AnalyticsProvider.)
Public method | InsertMultiVarianceTestVariablePage | Inserts the multi variance test variable page. (Inherited from AnalyticsProvider.)
Public method | InsertOperatingSystem | Inserts the operating system. (Inherited from AnalyticsProvider.)
Public method | InsertPage | Inserts the page. (Inherited from AnalyticsProvider.)
Public method | InsertPageEvent | Inserts the page event. (Inherited from AnalyticsProvider.)
Public method | InsertPageEventDefinition | Inserts the page event definition. (Inherited from AnalyticsProvider.)
Public method | InsertProfile | Inserts the profile. (Inherited from AnalyticsProvider.)
Public method | InsertProfileDefinition | Inserts the profile definition. (Inherited from AnalyticsProvider.)
Public method | InsertProfileKey | Inserts the profile key. (Inherited from AnalyticsProvider.)
Public method | InsertProfileKeyDefinition | Inserts the profile key definition. (Inherited from AnalyticsProvider.)
Public method | InsertReferringSite | Inserts the referring site. (Inherited from AnalyticsProvider.)
Public method | InsertScreen | Inserts the screen. (Inherited from AnalyticsProvider.)
Public method | InsertSession | Inserts the session. (Inherited from AnalyticsProvider.)
Public method | InsertSubscription | Inserts the subscription. (Inherited from AnalyticsProvider.)
Public method | InsertTag | Inserts the tag. (Inherited from AnalyticsProvider.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RawStringToGuid | Raws the string to GUID. (Overrides AnalyticsProvider..::..RawStringToGuid(String).)
Protected method | ReadIP | Reads the IP. (Inherited from AnalyticsProvider.)
Protected method | ReadIPOwner | Reads the IP owner. (Inherited from AnalyticsProvider.)
Public method | ReadMany<(Of <<'(T>)>>)(String, Func<(Of <<'(DataProviderReader, T>)>>), array<Object>[]()[][]) | Reads the specified command text. (Inherited from AnalyticsProvider.)
Public method | ReadMany<(Of <<'(T>)>>)(String, Func<(Of <<'(DataProviderReader, T>)>>), Int32, array<Object>[]()[][]) | Reads the specified command text. (Inherited from AnalyticsProvider.)
Public method | ReadOne<(Of <<'(T>)>>)(String, Func<(Of <<'(DataProviderReader, T>)>>), array<Object>[]()[][]) | Reads the one. (Inherited from AnalyticsProvider.)
Public method | ReadOne<(Of <<'(T>)>>)(String, Func<(Of <<'(DataProviderReader, T>)>>), Func<(Of <<'(T>)>>), array<Object>[]()[][]) | Reads the specified command text. (Inherited from AnalyticsProvider.)
Protected method | ReadProfile | Reads the profile. (Inherited from AnalyticsProvider.)
Public method | SaveCampaignDefinition | Saves the campaign. (Inherited from AnalyticsProvider.)
Public method | SaveCampaignEvent | Saves the campaign event. (Inherited from AnalyticsProvider.)
Public method | SaveMultiVarianceTestDefinition | Saves the multi variance test. (Inherited from AnalyticsProvider.)
Public method | SaveMultiVarianceTestVariable | Saves the multi variance test variable. (Inherited from AnalyticsProvider.)
Public method | SavePageEventDefinition | Saves the page event definition. (Inherited from AnalyticsProvider.)
Public method | SaveProfileDefinition | Saves the profile definition. (Inherited from AnalyticsProvider.)
Public method | SaveProfileKeyDefinition | Saves the profile key definition. (Inherited from AnalyticsProvider.)
Public method | SetStatusFailed | Sets the status failed. (Inherited from AnalyticsProvider.)
Public method | SetStatusSuccessful | Sets the status successful. (Inherited from AnalyticsProvider.)
Public method | Submit | Commits this instance. (Inherited from AnalyticsProvider.)
Public method | SubmitTracker | Submits the tracker. (Inherited from AnalyticsProvider.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateBothIdentificationsBySessionId | Updates the visitor identification by session id. (Overrides AnalyticsProvider..::..UpdateBothIdentificationsBySessionId(Guid).)
Public method | UpdateBrowser | Updates the browser. (Inherited from AnalyticsProvider.)
Public method | UpdateCampaign | Updates the campaign. (Inherited from AnalyticsProvider.)
Public method | UpdateCampaignEvent | Updates the campaign event. (Inherited from AnalyticsProvider.)
Public method | UpdateCountTotalByProfileId | Updates the count total by profile id. (Inherited from AnalyticsProvider.)
Public method | UpdateCurrentPageBySessionId | Updates the current page by session id. (Inherited from AnalyticsProvider.)
Public method | UpdateGlobalSession | Updates the global session. (Inherited from AnalyticsProvider.)
Public method | UpdateIP | Updates the IP. (Inherited from AnalyticsProvider.)
Public method | UpdateIpInformation(Guid, WhoIsInformation) | Updates the ip information with default post step action. (Inherited from AnalyticsProvider.)
Public method | UpdateIpInformation(Guid, WhoIsInformation, Action<(Of <<'(IP>)>>)) | Updates the ip information. (Inherited from AnalyticsProvider.)
Public method | UpdateIPOwner | Updates the IP owner. (Inherited from AnalyticsProvider.)
Public method | UpdateMultiVarianceTestDefinition | Updates the multi variance test definition. (Inherited from AnalyticsProvider.)
Public method | UpdatePage(Guid, DateTime, Int32, Int32, Guid, String, Int32, Guid, String, String, String, String) | Updates the page. (Inherited from AnalyticsProvider.)
Public method | UpdatePage(Guid, Guid, DateTime, Int32, Int32, Guid, String, Int32, Guid, String, String, String, String) | Updates the page. (Inherited from AnalyticsProvider.)
Public method | UpdateProfileKey | Updates the profile key. (Inherited from AnalyticsProvider.)
Public method | UpdateVisitorIdentificationByIpOwnerId | Updates the visitor identification by ip order id. (Overrides AnalyticsProvider..::..UpdateVisitorIdentificationByIpOwnerId(Guid).)
Public method | UpdateVisitorIdentificationBySessionId | Updates the visitor identification by session id. (Overrides AnalyticsProvider..::..UpdateVisitorIdentificationBySessionId(Guid).)
Public method | UpdateVisitorIdentifications | Updates the visitor identifications. (Overrides AnalyticsProvider..::..UpdateVisitorIdentifications()()()().)
Public method | UpdateVisitorIdentificationsByIPOwnerBrowser | Updates the visitor identifications by IP owner browser. (Overrides AnalyticsProvider..::..UpdateVisitorIdentificationsByIPOwnerBrowser(Guid, Guid, Guid).)

Fields

 | Name | Description
Protected field | DataApi | Data access API using pseudo SQL (Inherited from AnalyticsProvider.)

Properties

 | Name | Description
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

AnalyticsProviderSqlServer Class
Sitecore.Analytics.Data.DataProviders Namespace


AnalyticsProviderSqlServer Constructor

[image]

Sitecore 6.4.1 API
AnalyticsProviderSqlServer Constructor
AnalyticsProviderSqlServer Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public AnalyticsProviderSqlServer()
Visual Basic
Public Sub New
Visual C++
public:
AnalyticsProviderSqlServer()

See Also

AnalyticsProviderSqlServer Class
Sitecore.Analytics.Data.DataProviders Namespace


AnalyticsProviderSqlServer Methods

[image] [image]

Sitecore 6.4.1 API
AnalyticsProviderSqlServer Methods
AnalyticsProviderSqlServer Class See Also Send Feedback

The AnalyticsProviderSqlServer type exposes the following members.

Methods

 | Name | Description
Protected method | CreateReader | Creates the reader. (Inherited from AnalyticsProvider.)
Public method | DeleteSubscription | Deletes the subscription. (Inherited from AnalyticsProvider.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the specified command text. (Inherited from AnalyticsProvider.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FormatBigString | Convert to the char. (Overrides AnalyticsProvider..::..FormatBigString(String).)
Public method | FormatCommandText | Formats the command text. (Inherited from AnalyticsProvider.)
Public method | FormatFunctionName | Formats the name of the function. (Overrides AnalyticsProvider..::..FormatFunctionName(String).)
Public method | GetAddIpIdByAddressFrom | Gets the ip ID by address from. (Inherited from AnalyticsProvider.)
Public method | GetAddIpOwnerIdByNameAndCountry | Gets the IP owner id. (Inherited from AnalyticsProvider.)
Public method | GetBrowserById | Gets the browser by id. (Inherited from AnalyticsProvider.)
Public method | GetBrowserIdByUserAgent | Gets the browser by user agent. (Inherited from AnalyticsProvider.)
Public method | GetBrowsers | Gets the browsers. (Inherited from AnalyticsProvider.)
Public method | GetCampaignById | Gets the campaign by id. (Inherited from AnalyticsProvider.)
Public method | GetCampaignEventById | Gets the campaign event by id. (Inherited from AnalyticsProvider.)
Public method | GetCampaignEvents | Gets the campaign events. (Inherited from AnalyticsProvider.)
Public method | GetCampaignEventsByCampaignId | Gets the campaign events by campaign id. (Inherited from AnalyticsProvider.)
Public method | GetCampaigns | Gets the campaigns. (Inherited from AnalyticsProvider.)
Public method | GetConnectionString | Gets the connection string. (Inherited from AnalyticsProvider.)
Public method | GetDateTime | Gets the date time. (Inherited from AnalyticsProvider.)
Public method | GetDouble | Gets the double. (Overrides AnalyticsProvider..::..GetDouble(Int32, DataProviderReader).)
Public method | GetGlobalSessionById | Gets the global session by id. (Inherited from AnalyticsProvider.)
Public method | GetGlobalSessionIdByCookieValue | Gets the global session id by cookie value. (Inherited from AnalyticsProvider.)
Public method | GetGlobalSessions | Gets the global sessions. (Inherited from AnalyticsProvider.)
Public method | GetGuid | Gets the GUID. (Inherited from AnalyticsProvider.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInt | Gets the int. (Inherited from AnalyticsProvider.)
Public method | GetIPById | Gets the IP by id. (Inherited from AnalyticsProvider.)
Public method | GetIPBySessionId | Gets the IP by session id. (Inherited from AnalyticsProvider.)
Public method | GetIpOwnerById | Gets the ip owner by id. (Inherited from AnalyticsProvider.)
Public method | GetIpOwnerBySessionId | Gets the ip owner by session id. (Inherited from AnalyticsProvider.)
Public method | GetIpOwnerIdsBySessionId | Gets the ip owner ids by session id. (Inherited from AnalyticsProvider.)
Public method | GetIPs | Gets the I ps. (Inherited from AnalyticsProvider.)
Public method | GetIPsByOwnerId | Gets the IPs by owner id. (Inherited from AnalyticsProvider.)
Public method | GetKeywordIdByKeywords | Gets the keyword id by keywords. (Inherited from AnalyticsProvider.)
Public method | GetKeywordsBySessionId | Gets the keywords by session id. (Inherited from AnalyticsProvider.)
Public method | GetLong | Gets the big int. (Inherited from AnalyticsProvider.)
Public method | GetLookupData | Gets the lookup data. (Inherited from AnalyticsProvider.)
Public method | GetMatchReportQueryPattern | Gets the match report query pattern. (Overrides AnalyticsProvider..::..GetMatchReportQueryPattern()()()().)
Public method | GetMultiVarianceTestDefinitionById | Gets the multi variance test definition by id. (Inherited from AnalyticsProvider.)
Public method | GetMultiVarianceTestDefinitions | Gets the multi variance test definitions. (Inherited from AnalyticsProvider.)
Public method | GetMultiVarianceTestVariableById | Gets the multi variance test variable by id. (Inherited from AnalyticsProvider.)
Public method | GetMultiVarianceTestVariablesByTestDefinitionId | Gets the multi variance test variables by test definition id. (Inherited from AnalyticsProvider.)
Public method | GetOperatingSystemById | Gets the operating system by id. (Inherited from AnalyticsProvider.)
Public method | GetOperatingSystems | Gets the operating systems. (Inherited from AnalyticsProvider.)
Public method | GetPageById | Gets the page by id. (Inherited from AnalyticsProvider.)
Public method | GetPageBySessionIdAndPageNo | Gets the page by session id and page no. (Inherited from AnalyticsProvider.)
Public method | GetPageEventById | Gets the page event by id. (Inherited from AnalyticsProvider.)
Public method | GetPageEventDefinitionById | Gets the page event definition by id. (Inherited from AnalyticsProvider.)
Public method | GetPageEventDefinitionFailureNotSystem | Gets the page event definition failure system. (Inherited from AnalyticsProvider.)
Public method | GetPageEventDefinitionNotGoalNotFailureNotSystem | Gets the page event definition goal failure not system. (Inherited from AnalyticsProvider.)
Public method | GetPageEventDefinitions | Gets the page event definitions. (Inherited from AnalyticsProvider.)
Public method | GetPageEventDefinitionsIsGoalNotSystem | Gets the page event definitions is goal not system. (Inherited from AnalyticsProvider.)
Public method | GetPageEventsByPageId | Gets the page events by page id. (Inherited from AnalyticsProvider.)
Public method | GetPagesBySessionId | Gets the pages by session id. (Inherited from AnalyticsProvider.)
Public method | GetProfileById | Gets the profile by id. (Inherited from AnalyticsProvider.)
Public method | GetProfileDefinitionById | Gets the profile definition by id. (Inherited from AnalyticsProvider.)
Public method | GetProfileDefinitions | Gets the profile definitions. (Inherited from AnalyticsProvider.)
Public method | GetProfileKeyDefinitionById | Gets the profile key definition by id. (Inherited from AnalyticsProvider.)
Public method | GetProfileKeyDefinitions | Gets the profile key definitions. (Inherited from AnalyticsProvider.)
Public method | GetProfileKeyDefinitionsById | Gets the profile key definitions by profile definition id. (Inherited from AnalyticsProvider.)
Public method | GetProfileKeysByProfileId | Gets the profile keys by profile id. (Inherited from AnalyticsProvider.)
Public method | GetProfilesBySessionId | Gets the profiles by session id. (Inherited from AnalyticsProvider.)
Public method | GetReferringSiteByUrl | Gets the referring site by URL. (Inherited from AnalyticsProvider.)
Public method | GetReferringSites | Gets the referring sites. (Inherited from AnalyticsProvider.)
Public method | GetReportsDatabase | Gets the reports database. (Overrides AnalyticsProvider..::..GetReportsDatabase()()()().)
Public method | GetReportsDataSourceType | Gets the type of the reports data source. (Overrides AnalyticsProvider..::..GetReportsDataSourceType()()()().)
Public method | GetScreenByScreenId | Gets the screen by screen id. (Inherited from AnalyticsProvider.)
Public method | GetScreens | Gets the screens. (Inherited from AnalyticsProvider.)
Public method | GetSessionByAspNetSessionId | Gets the session by ASP net session id. (Inherited from AnalyticsProvider.)
Public method | GetSessionBySessionId | Gets the session by session id. (Inherited from AnalyticsProvider.)
Public method | GetSessionIdByAspNetSessionId | Gets the session id by ASP net session id. (Inherited from AnalyticsProvider.)
Public method | GetStatusById | Gets the status. (Inherited from AnalyticsProvider.)
Public method | GetStatuses | Gets the statuses. (Inherited from AnalyticsProvider.)
Public method | GetString | Gets the string. (Inherited from AnalyticsProvider.)
Public method | GetSubscription | Gets the subscription. (Inherited from AnalyticsProvider.)
Public method | GetSubscriptionById | Gets the subscription by id. (Inherited from AnalyticsProvider.)
Public method | GetTagById | Gets the tag by id. (Inherited from AnalyticsProvider.)
Public method | GetTagsByGlobalSessionId | Gets the tags by global session id. (Inherited from AnalyticsProvider.)
Public method | GetTotalByGlobalSessionId | Gets the total by global session id. (Inherited from AnalyticsProvider.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVendorSpecificReportPath | Gets the vendor specific report path. (Inherited from AnalyticsProvider.)
Public method | GuidToRawString | GUIDs to raw string. (Overrides AnalyticsProvider..::..GuidToRawString(Guid).)
Public method | Initialize | Initializes the provider. (Inherited from ProviderBase.)
Public method | InsertBrowser | Inserts the browser. (Inherited from AnalyticsProvider.)
Public method | InsertCampaign | Inserts the campaign. (Inherited from AnalyticsProvider.)
Public method | InsertCampaignEvent | Inserts the campaign event. (Inherited from AnalyticsProvider.)
Public method | InsertCampaignEventPage | Inserts the campaign event page. (Inherited from AnalyticsProvider.)
Public method | InsertGlobalSession | Inserts the global session. (Inherited from AnalyticsProvider.)
Public method | InsertIPOwner | Inserts the IP owner. (Inherited from AnalyticsProvider.)
Public method | InsertKeyword | Inserts the keyword. (Inherited from AnalyticsProvider.)
Public method | InsertMultiVarianceTestDefinition(Guid, String, String) | Inserts the multi variance test definition. (Inherited from AnalyticsProvider.)
Public method | InsertMultiVarianceTestDefinition(String, String, Guid) | Inserts the multi variance test definition. (Inherited from AnalyticsProvider.)
Public method | InsertMultiVarianceTestVariable | Inserts the multi variance test variable. (Inherited from AnalyticsProvider.)
Public method | InsertMultiVarianceTestVariableCampaignEvent | Inserts the multi variance test variable campaign event. (Inherited from AnalyticsProvider.)
Public method | InsertMultiVarianceTestVariablePage | Inserts the multi variance test variable page. (Inherited from AnalyticsProvider.)
Public method | InsertOperatingSystem | Inserts the operating system. (Inherited from AnalyticsProvider.)
Public method | InsertPage | Inserts the page. (Inherited from AnalyticsProvider.)
Public method | InsertPageEvent | Inserts the page event. (Inherited from AnalyticsProvider.)
Public method | InsertPageEventDefinition | Inserts the page event definition. (Inherited from AnalyticsProvider.)
Public method | InsertProfile | Inserts the profile. (Inherited from AnalyticsProvider.)
Public method | InsertProfileDefinition | Inserts the profile definition. (Inherited from AnalyticsProvider.)
Public method | InsertProfileKey | Inserts the profile key. (Inherited from AnalyticsProvider.)
Public method | InsertProfileKeyDefinition | Inserts the profile key definition. (Inherited from AnalyticsProvider.)
Public method | InsertReferringSite | Inserts the referring site. (Inherited from AnalyticsProvider.)
Public method | InsertScreen | Inserts the screen. (Inherited from AnalyticsProvider.)
Public method | InsertSession | Inserts the session. (Inherited from AnalyticsProvider.)
Public method | InsertSubscription | Inserts the subscription. (Inherited from AnalyticsProvider.)
Public method | InsertTag | Inserts the tag. (Inherited from AnalyticsProvider.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RawStringToGuid | Raws the string to GUID. (Overrides AnalyticsProvider..::..RawStringToGuid(String).)
Protected method | ReadIP | Reads the IP. (Inherited from AnalyticsProvider.)
Protected method | ReadIPOwner | Reads the IP owner. (Inherited from AnalyticsProvider.)
Public method | ReadMany<(Of <<'(T>)>>)(String, Func<(Of <<'(DataProviderReader, T>)>>), array<Object>[]()[][]) | Reads the specified command text. (Inherited from AnalyticsProvider.)
Public method | ReadMany<(Of <<'(T>)>>)(String, Func<(Of <<'(DataProviderReader, T>)>>), Int32, array<Object>[]()[][]) | Reads the specified command text. (Inherited from AnalyticsProvider.)
Public method | ReadOne<(Of <<'(T>)>>)(String, Func<(Of <<'(DataProviderReader, T>)>>), array<Object>[]()[][]) | Reads the one. (Inherited from AnalyticsProvider.)
Public method | ReadOne<(Of <<'(T>)>>)(String, Func<(Of <<'(DataProviderReader, T>)>>), Func<(Of <<'(T>)>>), array<Object>[]()[][]) | Reads the specified command text. (Inherited from AnalyticsProvider.)
Protected method | ReadProfile | Reads the profile. (Inherited from AnalyticsProvider.)
Public method | SaveCampaignDefinition | Saves the campaign. (Inherited from AnalyticsProvider.)
Public method | SaveCampaignEvent | Saves the campaign event. (Inherited from AnalyticsProvider.)
Public method | SaveMultiVarianceTestDefinition | Saves the multi variance test. (Inherited from AnalyticsProvider.)
Public method | SaveMultiVarianceTestVariable | Saves the multi variance test variable. (Inherited from AnalyticsProvider.)
Public method | SavePageEventDefinition | Saves the page event definition. (Inherited from AnalyticsProvider.)
Public method | SaveProfileDefinition | Saves the profile definition. (Inherited from AnalyticsProvider.)
Public method | SaveProfileKeyDefinition | Saves the profile key definition. (Inherited from AnalyticsProvider.)
Public method | SetStatusFailed | Sets the status failed. (Inherited from AnalyticsProvider.)
Public method | SetStatusSuccessful | Sets the status successful. (Inherited from AnalyticsProvider.)
Public method | Submit | Commits this instance. (Inherited from AnalyticsProvider.)
Public method | SubmitTracker | Submits the tracker. (Inherited from AnalyticsProvider.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateBothIdentificationsBySessionId | Updates the visitor identification by session id. (Overrides AnalyticsProvider..::..UpdateBothIdentificationsBySessionId(Guid).)
Public method | UpdateBrowser | Updates the browser. (Inherited from AnalyticsProvider.)
Public method | UpdateCampaign | Updates the campaign. (Inherited from AnalyticsProvider.)
Public method | UpdateCampaignEvent | Updates the campaign event. (Inherited from AnalyticsProvider.)
Public method | UpdateCountTotalByProfileId | Updates the count total by profile id. (Inherited from AnalyticsProvider.)
Public method | UpdateCurrentPageBySessionId | Updates the current page by session id. (Inherited from AnalyticsProvider.)
Public method | UpdateGlobalSession | Updates the global session. (Inherited from AnalyticsProvider.)
Public method | UpdateIP | Updates the IP. (Inherited from AnalyticsProvider.)
Public method | UpdateIpInformation(Guid, WhoIsInformation) | Updates the ip information with default post step action. (Inherited from AnalyticsProvider.)
Public method | UpdateIpInformation(Guid, WhoIsInformation, Action<(Of <<'(IP>)>>)) | Updates the ip information. (Inherited from AnalyticsProvider.)
Public method | UpdateIPOwner | Updates the IP owner. (Inherited from AnalyticsProvider.)
Public method | UpdateMultiVarianceTestDefinition | Updates the multi variance test definition. (Inherited from AnalyticsProvider.)
Public method | UpdatePage(Guid, DateTime, Int32, Int32, Guid, String, Int32, Guid, String, String, String, String) | Updates the page. (Inherited from AnalyticsProvider.)
Public method | UpdatePage(Guid, Guid, DateTime, Int32, Int32, Guid, String, Int32, Guid, String, String, String, String) | Updates the page. (Inherited from AnalyticsProvider.)
Public method | UpdateProfileKey | Updates the profile key. (Inherited from AnalyticsProvider.)
Public method | UpdateVisitorIdentificationByIpOwnerId | Updates the visitor identification by ip order id. (Overrides AnalyticsProvider..::..UpdateVisitorIdentificationByIpOwnerId(Guid).)
Public method | UpdateVisitorIdentificationBySessionId | Updates the visitor identification by session id. (Overrides AnalyticsProvider..::..UpdateVisitorIdentificationBySessionId(Guid).)
Public method | UpdateVisitorIdentifications | Updates the visitor identifications. (Overrides AnalyticsProvider..::..UpdateVisitorIdentifications()()()().)
Public method | UpdateVisitorIdentificationsByIPOwnerBrowser | Updates the visitor identifications by IP owner browser. (Overrides AnalyticsProvider..::..UpdateVisitorIdentificationsByIPOwnerBrowser(Guid, Guid, Guid).)

See Also

AnalyticsProviderSqlServer Class
Sitecore.Analytics.Data.DataProviders Namespace


FormatBigString Method

[image]

Sitecore 6.4.1 API
AnalyticsProviderSqlServer..::..FormatBigString Method
AnalyticsProviderSqlServer Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override string FormatBigString(
    string columnName
)
Visual Basic
Public Overrides Function FormatBigString ( _
    columnName As String _
) As String
Visual C++
public:
virtual String^ FormatBigString(
    String^ columnName
) override

Parameters

columnName
Type: System..::..String
Name of the column.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProviderSqlServer.FormatBigString(System.String)"]

See Also

AnalyticsProviderSqlServer Class
Sitecore.Analytics.Data.DataProviders Namespace


FormatFunctionName Method

[image]

Sitecore 6.4.1 API
AnalyticsProviderSqlServer..::..FormatFunctionName Method
AnalyticsProviderSqlServer Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override string FormatFunctionName(
    string functionName
)
Visual Basic
Public Overrides Function FormatFunctionName ( _
    functionName As String _
) As String
Visual C++
public:
virtual String^ FormatFunctionName(
    String^ functionName
) override

Parameters

functionName
Type: System..::..String
Name of the function.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProviderSqlServer.FormatFunctionName(System.String)"]

See Also

AnalyticsProviderSqlServer Class
Sitecore.Analytics.Data.DataProviders Namespace


GetMatchReportQueryPattern Method

[image]

Sitecore 6.4.1 API
AnalyticsProviderSqlServer..::..GetMatchReportQueryPattern Method
AnalyticsProviderSqlServer Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override string GetMatchReportQueryPattern()
Visual Basic
Public Overrides Function GetMatchReportQueryPattern As String
Visual C++
public:
virtual String^ GetMatchReportQueryPattern() override

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProviderSqlServer.GetMatchReportQueryPattern"]

See Also

AnalyticsProviderSqlServer Class
Sitecore.Analytics.Data.DataProviders Namespace


GetReportsDataSourceType Method

[image]

Sitecore 6.4.1 API
AnalyticsProviderSqlServer..::..GetReportsDataSourceType Method
AnalyticsProviderSqlServer Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override string GetReportsDataSourceType()
Visual Basic
Public Overrides Function GetReportsDataSourceType As String
Visual C++
public:
virtual String^ GetReportsDataSourceType() override

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProviderSqlServer.GetReportsDataSourceType"]

See Also

AnalyticsProviderSqlServer Class
Sitecore.Analytics.Data.DataProviders Namespace


GuidToRawString Method

[image]

Sitecore 6.4.1 API
AnalyticsProviderSqlServer..::..GuidToRawString Method
AnalyticsProviderSqlServer Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override string GuidToRawString(
    Guid guid
)
Visual Basic
Public Overrides Function GuidToRawString ( _
    guid As Guid _
) As String
Visual C++
public:
virtual String^ GuidToRawString(
    Guid guid
) override

Parameters

guid
Type: System..::..Guid
The GUID.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProviderSqlServer.GuidToRawString(System.Guid)"]

See Also

AnalyticsProviderSqlServer Class
Sitecore.Analytics.Data.DataProviders Namespace


InsertMultiVarianceTestDefinition Method

[image] [image]

Sitecore 6.4.1 API
AnalyticsProviderSqlServer..::..InsertMultiVarianceTestDefinition Method
AnalyticsProviderSqlServer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertMultiVarianceTestDefinition(Guid, String, String) | Inserts the multi variance test definition. (Inherited from AnalyticsProvider.)
Public method | InsertMultiVarianceTestDefinition(String, String, Guid) | Inserts the multi variance test definition. (Inherited from AnalyticsProvider.)

See Also

AnalyticsProviderSqlServer Class
AnalyticsProviderSqlServer Members
Sitecore.Analytics.Data.DataProviders Namespace


RawStringToGuid Method

[image]

Sitecore 6.4.1 API
AnalyticsProviderSqlServer..::..RawStringToGuid Method
AnalyticsProviderSqlServer Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override Guid RawStringToGuid(
    string rawString
)
Visual Basic
Public Overrides Function RawStringToGuid ( _
    rawString As String _
) As Guid
Visual C++
public:
virtual Guid RawStringToGuid(
    String^ rawString
) override

Parameters

rawString
Type: System..::..String
The raw string.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProviderSqlServer.RawStringToGuid(System.String)"]

See Also

AnalyticsProviderSqlServer Class
Sitecore.Analytics.Data.DataProviders Namespace


ReadMany Method

[image] [image]

Sitecore 6.4.1 API
AnalyticsProviderSqlServer..::..ReadMany Method
AnalyticsProviderSqlServer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadMany<(Of <<'(T>)>>)(String, Func<(Of <<'(DataProviderReader, T>)>>), array<Object>[]()[][]) | Reads the specified command text. (Inherited from AnalyticsProvider.)
Public method | ReadMany<(Of <<'(T>)>>)(String, Func<(Of <<'(DataProviderReader, T>)>>), Int32, array<Object>[]()[][]) | Reads the specified command text. (Inherited from AnalyticsProvider.)

See Also

AnalyticsProviderSqlServer Class
AnalyticsProviderSqlServer Members
Sitecore.Analytics.Data.DataProviders Namespace


ReadOne Method

[image] [image]

Sitecore 6.4.1 API
AnalyticsProviderSqlServer..::..ReadOne Method
AnalyticsProviderSqlServer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadOne<(Of <<'(T>)>>)(String, Func<(Of <<'(DataProviderReader, T>)>>), array<Object>[]()[][]) | Reads the one. (Inherited from AnalyticsProvider.)
Public method | ReadOne<(Of <<'(T>)>>)(String, Func<(Of <<'(DataProviderReader, T>)>>), Func<(Of <<'(T>)>>), array<Object>[]()[][]) | Reads the specified command text. (Inherited from AnalyticsProvider.)

See Also

AnalyticsProviderSqlServer Class
AnalyticsProviderSqlServer Members
Sitecore.Analytics.Data.DataProviders Namespace


UpdateBothIdentificationsBySessionId Method

[image]

Sitecore 6.4.1 API
AnalyticsProviderSqlServer..::..UpdateBothIdentificationsBySessionId Method
AnalyticsProviderSqlServer Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override int UpdateBothIdentificationsBySessionId(
    Guid sessionId
)
Visual Basic
Public Overrides Function UpdateBothIdentificationsBySessionId ( _
    sessionId As Guid _
) As Integer
Visual C++
public:
virtual int UpdateBothIdentificationsBySessionId(
    Guid sessionId
) override

Parameters

sessionId
Type: System..::..Guid
The session id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProviderSqlServer.UpdateBothIdentificationsBySessionId(System.Guid)"]

See Also

AnalyticsProviderSqlServer Class
Sitecore.Analytics.Data.DataProviders Namespace


UpdateIpInformation Method

[image] [image]

Sitecore 6.4.1 API
AnalyticsProviderSqlServer..::..UpdateIpInformation Method
AnalyticsProviderSqlServer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UpdateIpInformation(Guid, WhoIsInformation) | Updates the ip information with default post step action. (Inherited from AnalyticsProvider.)
Public method | UpdateIpInformation(Guid, WhoIsInformation, Action<(Of <<'(IP>)>>)) | Updates the ip information. (Inherited from AnalyticsProvider.)

See Also

AnalyticsProviderSqlServer Class
AnalyticsProviderSqlServer Members
Sitecore.Analytics.Data.DataProviders Namespace


UpdatePage Method

[image] [image]

Sitecore 6.4.1 API
AnalyticsProviderSqlServer..::..UpdatePage Method
AnalyticsProviderSqlServer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UpdatePage(Guid, DateTime, Int32, Int32, Guid, String, Int32, Guid, String, String, String, String) | Updates the page. (Inherited from AnalyticsProvider.)
Public method | UpdatePage(Guid, Guid, DateTime, Int32, Int32, Guid, String, Int32, Guid, String, String, String, String) | Updates the page. (Inherited from AnalyticsProvider.)

See Also

AnalyticsProviderSqlServer Class
AnalyticsProviderSqlServer Members
Sitecore.Analytics.Data.DataProviders Namespace


UpdateVisitorIdentificationByIpOwnerId Method

[image]

Sitecore 6.4.1 API
AnalyticsProviderSqlServer..::..UpdateVisitorIdentificationByIpOwnerId Method
AnalyticsProviderSqlServer Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override int UpdateVisitorIdentificationByIpOwnerId(
    Guid ipOwnerId
)
Visual Basic
Public Overrides Function UpdateVisitorIdentificationByIpOwnerId ( _
    ipOwnerId As Guid _
) As Integer
Visual C++
public:
virtual int UpdateVisitorIdentificationByIpOwnerId(
    Guid ipOwnerId
) override

Parameters

ipOwnerId
Type: System..::..Guid
The ip owner id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProviderSqlServer.UpdateVisitorIdentificationByIpOwnerId(System.Guid)"]

See Also

AnalyticsProviderSqlServer Class
Sitecore.Analytics.Data.DataProviders Namespace


UpdateVisitorIdentificationBySessionId Method

[image]

Sitecore 6.4.1 API
AnalyticsProviderSqlServer..::..UpdateVisitorIdentificationBySessionId Method
AnalyticsProviderSqlServer Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override int UpdateVisitorIdentificationBySessionId(
    Guid sessionId
)
Visual Basic
Public Overrides Function UpdateVisitorIdentificationBySessionId ( _
    sessionId As Guid _
) As Integer
Visual C++
public:
virtual int UpdateVisitorIdentificationBySessionId(
    Guid sessionId
) override

Parameters

sessionId
Type: System..::..Guid
The session id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProviderSqlServer.UpdateVisitorIdentificationBySessionId(System.Guid)"]

See Also

AnalyticsProviderSqlServer Class
Sitecore.Analytics.Data.DataProviders Namespace


UpdateVisitorIdentifications Method

[image]

Sitecore 6.4.1 API
AnalyticsProviderSqlServer..::..UpdateVisitorIdentifications Method
AnalyticsProviderSqlServer Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override int UpdateVisitorIdentifications()
Visual Basic
Public Overrides Function UpdateVisitorIdentifications As Integer
Visual C++
public:
virtual int UpdateVisitorIdentifications() override

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProviderSqlServer.UpdateVisitorIdentifications"]

See Also

AnalyticsProviderSqlServer Class
Sitecore.Analytics.Data.DataProviders Namespace


UpdateVisitorIdentificationsByIPOwnerBrowser Method

[image]

Sitecore 6.4.1 API
AnalyticsProviderSqlServer..::..UpdateVisitorIdentificationsByIPOwnerBrowser Method
AnalyticsProviderSqlServer Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.DataProviders
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override int UpdateVisitorIdentificationsByIPOwnerBrowser(
    Guid browserId,
    Guid ipId,
    Guid ipOwnerId
)
Visual Basic
Public Overrides Function UpdateVisitorIdentificationsByIPOwnerBrowser ( _
    browserId As Guid, _
    ipId As Guid, _
    ipOwnerId As Guid _
) As Integer
Visual C++
public:
virtual int UpdateVisitorIdentificationsByIPOwnerBrowser(
    Guid browserId,
    Guid ipId,
    Guid ipOwnerId
) override

Parameters

browserId
Type: System..::..Guid
The browser id.
ipId
Type: System..::..Guid
The ip id.
ipOwnerId
Type: System..::..Guid
The ip owner id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.DataProviders.AnalyticsProviderSqlServer.UpdateVisitorIdentificationsByIPOwnerBrowser(System.Guid,System.Guid,System.Guid)"]

See Also

AnalyticsProviderSqlServer Class
Sitecore.Analytics.Data.DataProviders Namespace


AnalyticsProviderSqlServer Properties

[image] [image]

Sitecore 6.4.1 API
AnalyticsProviderSqlServer Properties
AnalyticsProviderSqlServer Class See Also Send Feedback

The AnalyticsProviderSqlServer type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

AnalyticsProviderSqlServer Class
Sitecore.Analytics.Data.DataProviders Namespace


Sitecore.Analytics.Data.Filters Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Analytics.Data.Filters Namespace
Send Feedback

Classes

 | Class | Description
Public class | ReportFilters | Defines the filtering class.
Public class | SqlCommand | Defines the filter base class.


ReportFilters Class

[image]

Sitecore 6.4.1 API
ReportFilters Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static class ReportFilters
Visual Basic
Public NotInheritable Class ReportFilters
Visual C++
public ref class ReportFilters abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters..::..ReportFilters

See Also

ReportFilters Members
Sitecore.Analytics.Data.Filters Namespace


ReportFilters Members

[image] [image]

Sitecore 6.4.1 API
ReportFilters Members
ReportFilters Class Methods See Also Send Feedback

The ReportFilters type exposes the following members.

Methods

Name | Description
ApplyFilter | Applies the filter.
IsApplicable | Determines whether the specified SQL command is applicable.

See Also

ReportFilters Class
Sitecore.Analytics.Data.Filters Namespace


ReportFilters Methods

[image] [image]

Sitecore 6.4.1 API
ReportFilters Methods
ReportFilters Class See Also Send Feedback

The ReportFilters type exposes the following members.

Methods

Name | Description
ApplyFilter | Applies the filter.
IsApplicable | Determines whether the specified SQL command is applicable.

See Also

ReportFilters Class
Sitecore.Analytics.Data.Filters Namespace


ApplyFilter Method

[image]

Sitecore 6.4.1 API
ReportFilters..::..ApplyFilter Method
ReportFilters Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void ApplyFilter(
    Database database,
    SqlCommand sqlCommand,
    XDocument filters
)
Visual Basic
Public Shared Sub ApplyFilter ( _
    database As Database, _
    sqlCommand As SqlCommand, _
    filters As XDocument _
)
Visual C++
public:
static void ApplyFilter(
    Database^ database,
    SqlCommand^ sqlCommand,
    XDocument^ filters
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.
sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.
filters
Type: System.Xml.Linq..::..XDocument
The filters.

See Also

ReportFilters Class
Sitecore.Analytics.Data.Filters Namespace


IsApplicable Method

[image]

Sitecore 6.4.1 API
ReportFilters..::..IsApplicable Method
ReportFilters Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static bool IsApplicable(
    Database database,
    SqlCommand sqlCommand,
    XDocument filters
)
Visual Basic
Public Shared Function IsApplicable ( _
    database As Database, _
    sqlCommand As SqlCommand, _
    filters As XDocument _
) As Boolean
Visual C++
public:
static bool IsApplicable(
    Database^ database,
    SqlCommand^ sqlCommand,
    XDocument^ filters
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.
sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.
filters
Type: System.Xml.Linq..::..XDocument
The filters.

Return Value

true if the specified SQL command is applicable; otherwise, false.

See Also

ReportFilters Class
Sitecore.Analytics.Data.Filters Namespace


SqlCommand Class

[image]

Sitecore 6.4.1 API
SqlCommand Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class SqlCommand
Visual Basic
Public Class SqlCommand
Visual C++
public ref class SqlCommand

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters..::..SqlCommand

See Also

SqlCommand Members
Sitecore.Analytics.Data.Filters Namespace


SqlCommand Members

[image] [image]

Sitecore 6.4.1 API
SqlCommand Members
SqlCommand Class Constructors Methods Properties See Also Send Feedback

The SqlCommand type exposes the following members.

Constructors

 | Name | Description
Public method | SqlCommand | Initializes a new instance of the SqlCommand class.

Methods

 | Name | Description
Public method | AddWhereClause | Adds the variable value.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasPlaceholder | Determines whether the specified variable name has variable.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Placeholders | Gets the variables.
Public property | Sql | Gets the SQL.

See Also

SqlCommand Class
Sitecore.Analytics.Data.Filters Namespace


SqlCommand Constructor

[image]

Sitecore 6.4.1 API
SqlCommand Constructor
SqlCommand Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public SqlCommand(
    string sql,
    List<string> placeholders
)
Visual Basic
Public Sub New ( _
    sql As String, _
    placeholders As List(Of String) _
)
Visual C++
public:
SqlCommand(
    String^ sql,
    List<String^>^ placeholders
)

Parameters

sql
Type: System..::..String
The SQL command.
placeholders
Type: System.Collections.Generic..::..List <(Of <(<' String >)>)>
The placeholders.

See Also

SqlCommand Class
Sitecore.Analytics.Data.Filters Namespace


SqlCommand Methods

[image] [image]

Sitecore 6.4.1 API
SqlCommand Methods
SqlCommand Class See Also Send Feedback

The SqlCommand type exposes the following members.

Methods

 | Name | Description
Public method | AddWhereClause | Adds the variable value.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasPlaceholder | Determines whether the specified variable name has variable.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SqlCommand Class
Sitecore.Analytics.Data.Filters Namespace


HasPlaceholder Method

[image]

Sitecore 6.4.1 API
SqlCommand..::..HasPlaceholder Method
SqlCommand Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public bool HasPlaceholder(
    string variableName
)
Visual Basic
Public Function HasPlaceholder ( _
    variableName As String _
) As Boolean
Visual C++
public:
bool HasPlaceholder(
    String^ variableName
)

Parameters

variableName
Type: System..::..String
Name of the variable.

Return Value

true if the specified variable name has variable; otherwise, false.

See Also

SqlCommand Class
Sitecore.Analytics.Data.Filters Namespace


SqlCommand Properties

[image] [image]

Sitecore 6.4.1 API
SqlCommand Properties
SqlCommand Class See Also Send Feedback

The SqlCommand type exposes the following members.

Properties

 | Name | Description
Public property | Placeholders | Gets the variables.
Public property | Sql | Gets the SQL.

See Also

SqlCommand Class
Sitecore.Analytics.Data.Filters Namespace


Placeholders Property

[image]

Sitecore 6.4.1 API
SqlCommand..::..Placeholders Property
SqlCommand Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Dictionary<string, string> Placeholders { get; }
Visual Basic
Public ReadOnly Property Placeholders As Dictionary(Of String, String)
    Get
Visual C++
public:
property Dictionary<String^, String^>^ Placeholders {
    Dictionary<String^, String^>^ get ();
}

Field Value

The variables.

See Also

SqlCommand Class
Sitecore.Analytics.Data.Filters Namespace


Sitecore.Analytics.Data.Filters.Filters Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Analytics.Data.Filters.Filters Namespace
Send Feedback

Classes

 | Class | Description
Public class | FilterBase | Defines the filter base class.
Public class | IfExitPage | Defines the when template is class.
Public class | IfIsNotBounce | Defines the when template is class.
Public class | OperatorFilterBase | Defines the when template is class.
Public class | WhereAreaCode | Defines the where country class.
Public class | WhereBrowser | Defines the when template is class.
Public class | WhereCampaign | Defines the when template is class.
Public class | WhereCity | Defines the where country class.
Public class | WhereCountry | Defines the where country class.
Public class | WhereGlobalVisitNo | Defines the when template is class.
Public class | WhereIpBase | Defines the base class for filtering on the IpOwner table.
Public class | WhereIpOwnerBase | Defines the base class for filtering on the IpOwner table.
Public class | WhereIsp | Defines the where country class.
Public class | WhereItem | Defines the when template is class.
Public class | WhereKeywords | Defines the when template is class.
Public class | WhereLanguage | Defines the when template is class.
Public class | WhereLatitude | Defines the where country class.
Public class | WhereLongitude | Defines the where country class.
Public class | WhereMetroCode | Defines the where country class.
Public class | WhereName | Defines the where country class.
Public class | WhereOperatingSystem | Defines the when template is class.
Public class | WherePageCount | Defines the when template is class.
Public class | WherePageNo | Defines the when template is class.
Public class | WherePersona | Defines the when template is class.
Public class | WherePostalCode | Defines the where country class.
Public class | WhereProfileKey | Defines the when template is class.
Public class | WhereReferringSite | Defines the when template is class.
Public class | WhereRegion | Defines the where country class.
Public class | WhereScreen | Defines the when template is class.
Public class | WhereSite | Defines the when template is class.
Public class | WhereVisitorIdentification | Defines the when template is class.

Interfaces

 | Interface | Description
Public interface | IFilter | The filter interface.


FilterBase Class

[image]

Sitecore 6.4.1 API
FilterBase Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract class FilterBase : IFilter
Visual Basic
Public MustInherit Class FilterBase _
    Implements IFilter
Visual C++
public ref class FilterBase abstract : IFilter

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Filters..::..FilterBase
Sitecore.Analytics.Data.Filters.Filters..::..OperatorFilterBase
Sitecore.Analytics.Data.Filters.Filters..::..WhereBrowser
Sitecore.Analytics.Data.Filters.Filters..::..WhereCampaign
Sitecore.Analytics.Data.Filters.Filters..::..WhereItem
Sitecore.Analytics.Data.Filters.Filters..::..WhereKeywords
Sitecore.Analytics.Data.Filters.Filters..::..WhereLanguage
Sitecore.Analytics.Data.Filters.Filters..::..WhereOperatingSystem
Sitecore.Analytics.Data.Filters.Filters..::..WherePersona
Sitecore.Analytics.Data.Filters.Filters..::..WhereReferringSite
Sitecore.Analytics.Data.Filters.Filters..::..WhereScreen
Sitecore.Analytics.Data.Filters.Filters..::..WhereSite

See Also

FilterBase Members
Sitecore.Analytics.Data.Filters.Filters Namespace


FilterBase Members

[image] [image]

Sitecore 6.4.1 API
FilterBase Members
FilterBase Class Constructors Methods Properties See Also Send Feedback

The FilterBase type exposes the following members.

Constructors

 | Name | Description
Protected method | FilterBase | Initializes a new instance of the FilterBase class

Methods

 | Name | Description
Public method | ApplyFilter | Applies this instance.
 | BuildCriteria(String, ListString) | Builds the criteria.
 | BuildCriteria(String, IEnumerable<(Of <<'(Guid>)>>)) | Builds the criteria.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EscapeLike | Escapes the specified text.
 | EscapeQuote | Escapes the specified text.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition.

See Also

FilterBase Class
Sitecore.Analytics.Data.Filters.Filters Namespace


FilterBase Constructor

[image]

Sitecore 6.4.1 API
FilterBase Constructor
FilterBase Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected FilterBase()
Visual Basic
Protected Sub New
Visual C++
protected:
FilterBase()

See Also

FilterBase Class
Sitecore.Analytics.Data.Filters.Filters Namespace


FilterBase Methods

[image] [image]

Sitecore 6.4.1 API
FilterBase Methods
FilterBase Class See Also Send Feedback

The FilterBase type exposes the following members.

Methods

 | Name | Description
Public method | ApplyFilter | Applies this instance.
 | BuildCriteria(String, ListString) | Builds the criteria.
 | BuildCriteria(String, IEnumerable<(Of <<'(Guid>)>>)) | Builds the criteria.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EscapeLike | Escapes the specified text.
 | EscapeQuote | Escapes the specified text.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterBase Class
Sitecore.Analytics.Data.Filters.Filters Namespace


ApplyFilter Method

[image]

Sitecore 6.4.1 API
FilterBase..::..ApplyFilter Method
FilterBase Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract void ApplyFilter(
    SqlCommand sqlCommand
)
Visual Basic
Public MustOverride Sub ApplyFilter ( _
    sqlCommand As SqlCommand _
)
Visual C++
public:
virtual void ApplyFilter(
    SqlCommand^ sqlCommand
) abstract

Parameters

sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.

Implements

IFilter..::..ApplyFilter(SqlCommand)

See Also

FilterBase Class
Sitecore.Analytics.Data.Filters.Filters Namespace


BuildCriteria Method

[image] [image]

Sitecore 6.4.1 API
FilterBase..::..BuildCriteria Method
FilterBase Class See Also Send Feedback

Overload List

Name | Description
BuildCriteria(String, ListString) | Builds the criteria.
BuildCriteria(String, IEnumerable<(Of <<'(Guid>)>>)) | Builds the criteria.

See Also

FilterBase Class
FilterBase Members
Sitecore.Analytics.Data.Filters.Filters Namespace


BuildCriteria Method (String, ListString)

[image]

Sitecore 6.4.1 API
FilterBase..::..BuildCriteria Method (String, ListString)
FilterBase Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected static string BuildCriteria(
    string format,
    ListString listString
)
Visual Basic
Protected Shared Function BuildCriteria ( _
    format As String, _
    listString As ListString _
) As String
Visual C++
protected:
static String^ BuildCriteria(
    String^ format,
    ListString^ listString
)

Parameters

format
Type: System..::..String
The format.
listString
Type: Sitecore.Text..::..ListString
The list string.

Return Value

The criteria.

See Also

FilterBase Class
BuildCriteria Overload
Sitecore.Analytics.Data.Filters.Filters Namespace


BuildCriteria Method (String, IEnumerable(Guid))

[image]

Sitecore 6.4.1 API
FilterBase..::..BuildCriteria Method (String, IEnumerable<(Of <(<'Guid>)>)>)
FilterBase Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected static string BuildCriteria(
    string format,
    IEnumerable<Guid> items
)
Visual Basic
Protected Shared Function BuildCriteria ( _
    format As String, _
    items As IEnumerable(Of Guid) _
) As String
Visual C++
protected:
static String^ BuildCriteria(
    String^ format,
    IEnumerable<Guid>^ items
)

Parameters

format
Type: System..::..String
The format.
items
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Guid >)>)>
The list guids.

Return Value

[Missing <returns> documentation for "M:Sitecore.Analytics.Data.Filters.Filters.FilterBase.BuildCriteria(System.String,System.Collections.Generic.IEnumerable{System.Guid})"]

See Also

FilterBase Class
BuildCriteria Overload
Sitecore.Analytics.Data.Filters.Filters Namespace


EscapeLike Method

[image]

Sitecore 6.4.1 API
FilterBase..::..EscapeLike Method
FilterBase Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected static string EscapeLike(
    string text
)
Visual Basic
Protected Shared Function EscapeLike ( _
    text As String _
) As String
Visual C++
protected:
static String^ EscapeLike(
    String^ text
)

Parameters

text
Type: System..::..String
The text to escape.

Return Value

Returns the string.

See Also

FilterBase Class
Sitecore.Analytics.Data.Filters.Filters Namespace


EscapeQuote Method

[image]

Sitecore 6.4.1 API
FilterBase..::..EscapeQuote Method
FilterBase Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected static string EscapeQuote(
    string text
)
Visual Basic
Protected Shared Function EscapeQuote ( _
    text As String _
) As String
Visual C++
protected:
static String^ EscapeQuote(
    String^ text
)

Parameters

text
Type: System..::..String
The text to escape.

Return Value

Returns the string.

See Also

FilterBase Class
Sitecore.Analytics.Data.Filters.Filters Namespace


FilterBase Properties

[image] [image]

Sitecore 6.4.1 API
FilterBase Properties
FilterBase Class See Also Send Feedback

The FilterBase type exposes the following members.

Properties

 | Name | Description
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition.

See Also

FilterBase Class
Sitecore.Analytics.Data.Filters.Filters Namespace


Except Property

[image]

Sitecore 6.4.1 API
FilterBase..::..Except Property
FilterBase Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public bool Except { get; set; }
Visual Basic
Public Property Except As Boolean
    Get
    Set
Visual C++
public:
property bool Except {
    bool get ();
    void set (bool value);
}

Field Value

true if filter is a "not" condition; otherwise, false.

See Also

FilterBase Class
Sitecore.Analytics.Data.Filters.Filters Namespace


IfExitPage Class

[image]

Sitecore 6.4.1 API
IfExitPage Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class IfExitPage : OperatorFilterBase
Visual Basic
Public Class IfExitPage _
    Inherits OperatorFilterBase
Visual C++
public ref class IfExitPage : public OperatorFilterBase

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Filters..::..FilterBase
Sitecore.Analytics.Data.Filters.Filters..::..OperatorFilterBase
Sitecore.Analytics.Data.Filters.Filters..::..IfExitPage

See Also

IfExitPage Members
Sitecore.Analytics.Data.Filters.Filters Namespace


IfExitPage Members

[image] [image]

Sitecore 6.4.1 API
IfExitPage Members
IfExitPage Class Constructors Methods Properties See Also Send Feedback

The IfExitPage type exposes the following members.

Constructors

 | Name | Description
Public method | IfExitPage | Initializes a new instance of the IfExitPage class

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Overrides FilterBase..::..ApplyFilter(SqlCommand).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorFilterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Overrides FilterBase..::..IsApplicable(SqlCommand).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorFilterBase.)

See Also

IfExitPage Class
Sitecore.Analytics.Data.Filters.Filters Namespace


IfExitPage Constructor

[image]

Sitecore 6.4.1 API
IfExitPage Constructor
IfExitPage Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public IfExitPage()
Visual Basic
Public Sub New
Visual C++
public:
IfExitPage()

See Also

IfExitPage Class
Sitecore.Analytics.Data.Filters.Filters Namespace


IfExitPage Methods

[image] [image]

Sitecore 6.4.1 API
IfExitPage Methods
IfExitPage Class See Also Send Feedback

The IfExitPage type exposes the following members.

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Overrides FilterBase..::..ApplyFilter(SqlCommand).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorFilterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Overrides FilterBase..::..IsApplicable(SqlCommand).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IfExitPage Class
Sitecore.Analytics.Data.Filters.Filters Namespace


ApplyFilter Method

[image]

Sitecore 6.4.1 API
IfExitPage..::..ApplyFilter Method
IfExitPage Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void ApplyFilter(
    SqlCommand sqlCommand
)
Visual Basic
Public Overrides Sub ApplyFilter ( _
    sqlCommand As SqlCommand _
)
Visual C++
public:
virtual void ApplyFilter(
    SqlCommand^ sqlCommand
) override

Parameters

sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.

Implements

IFilter..::..ApplyFilter(SqlCommand)

See Also

IfExitPage Class
Sitecore.Analytics.Data.Filters.Filters Namespace


IsApplicable Method

[image]

Sitecore 6.4.1 API
IfExitPage..::..IsApplicable Method
IfExitPage Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override bool IsApplicable(
    SqlCommand sqlCommand
)
Visual Basic
Public Overrides Function IsApplicable ( _
    sqlCommand As SqlCommand _
) As Boolean
Visual C++
public:
virtual bool IsApplicable(
    SqlCommand^ sqlCommand
) override

Parameters

sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.

Return Value

true if the filter is applicable to the specified SQL Command; otherwise, false.

Implements

IFilter..::..IsApplicable(SqlCommand)

See Also

IfExitPage Class
Sitecore.Analytics.Data.Filters.Filters Namespace


IFilter Interface

[image]

Sitecore 6.4.1 API
IFilter Interface
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public interface IFilter
Visual Basic
Public Interface IFilter
Visual C++
public interface class IFilter

See Also

IFilter Members
Sitecore.Analytics.Data.Filters.Filters Namespace


IFilter Members

[image] [image]

Sitecore 6.4.1 API
IFilter Members
IFilter Interface Methods See Also Send Feedback

The IFilter type exposes the following members.

Methods

 | Name | Description
Public method | ApplyFilter | Applies this instance.
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command.

See Also

IFilter Interface
Sitecore.Analytics.Data.Filters.Filters Namespace


IFilter Methods

[image] [image]

Sitecore 6.4.1 API
IFilter Methods
IFilter Interface See Also Send Feedback

The IFilter type exposes the following members.

Methods

 | Name | Description
Public method | ApplyFilter | Applies this instance.
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command.

See Also

IFilter Interface
Sitecore.Analytics.Data.Filters.Filters Namespace


ApplyFilter Method

[image]

Sitecore 6.4.1 API
IFilter..::..ApplyFilter Method
IFilter Interface See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
void ApplyFilter(
    SqlCommand sqlCommand
)
Visual Basic
Sub ApplyFilter ( _
    sqlCommand As SqlCommand _
)
Visual C++
void ApplyFilter(
    SqlCommand^ sqlCommand
)

Parameters

sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.

See Also

IFilter Interface
Sitecore.Analytics.Data.Filters.Filters Namespace


IsApplicable Method

[image]

Sitecore 6.4.1 API
IFilter..::..IsApplicable Method
IFilter Interface See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
bool IsApplicable(
    SqlCommand sqlCommand
)
Visual Basic
Function IsApplicable ( _
    sqlCommand As SqlCommand _
) As Boolean
Visual C++
bool IsApplicable(
    SqlCommand^ sqlCommand
)

Parameters

sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.

Return Value

true if the filter is applicable to the specified SQL Command; otherwise, false.

See Also

IFilter Interface
Sitecore.Analytics.Data.Filters.Filters Namespace


IfIsNotBounce Class

[image]

Sitecore 6.4.1 API
IfIsNotBounce Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class IfIsNotBounce : OperatorFilterBase
Visual Basic
Public Class IfIsNotBounce _
    Inherits OperatorFilterBase
Visual C++
public ref class IfIsNotBounce : public OperatorFilterBase

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Filters..::..FilterBase
Sitecore.Analytics.Data.Filters.Filters..::..OperatorFilterBase
Sitecore.Analytics.Data.Filters.Filters..::..IfIsNotBounce

See Also

IfIsNotBounce Members
Sitecore.Analytics.Data.Filters.Filters Namespace


IfIsNotBounce Members

[image] [image]

Sitecore 6.4.1 API
IfIsNotBounce Members
IfIsNotBounce Class Constructors Methods Properties See Also Send Feedback

The IfIsNotBounce type exposes the following members.

Constructors

 | Name | Description
Public method | IfIsNotBounce | Initializes a new instance of the IfIsNotBounce class

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Overrides FilterBase..::..ApplyFilter(SqlCommand).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorFilterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Overrides FilterBase..::..IsApplicable(SqlCommand).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorFilterBase.)

See Also

IfIsNotBounce Class
Sitecore.Analytics.Data.Filters.Filters Namespace


IfIsNotBounce Constructor

[image]

Sitecore 6.4.1 API
IfIsNotBounce Constructor
IfIsNotBounce Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public IfIsNotBounce()
Visual Basic
Public Sub New
Visual C++
public:
IfIsNotBounce()

See Also

IfIsNotBounce Class
Sitecore.Analytics.Data.Filters.Filters Namespace


IfIsNotBounce Methods

[image] [image]

Sitecore 6.4.1 API
IfIsNotBounce Methods
IfIsNotBounce Class See Also Send Feedback

The IfIsNotBounce type exposes the following members.

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Overrides FilterBase..::..ApplyFilter(SqlCommand).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorFilterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Overrides FilterBase..::..IsApplicable(SqlCommand).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IfIsNotBounce Class
Sitecore.Analytics.Data.Filters.Filters Namespace


ApplyFilter Method

[image]

Sitecore 6.4.1 API
IfIsNotBounce..::..ApplyFilter Method
IfIsNotBounce Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void ApplyFilter(
    SqlCommand sqlCommand
)
Visual Basic
Public Overrides Sub ApplyFilter ( _
    sqlCommand As SqlCommand _
)
Visual C++
public:
virtual void ApplyFilter(
    SqlCommand^ sqlCommand
) override

Parameters

sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.

Implements

IFilter..::..ApplyFilter(SqlCommand)

See Also

IfIsNotBounce Class
Sitecore.Analytics.Data.Filters.Filters Namespace


IsApplicable Method

[image]

Sitecore 6.4.1 API
IfIsNotBounce..::..IsApplicable Method
IfIsNotBounce Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override bool IsApplicable(
    SqlCommand sqlCommand
)
Visual Basic
Public Overrides Function IsApplicable ( _
    sqlCommand As SqlCommand _
) As Boolean
Visual C++
public:
virtual bool IsApplicable(
    SqlCommand^ sqlCommand
) override

Parameters

sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.

Return Value

true if the filter is applicable to the specified SQL Command; otherwise, false.

Implements

IFilter..::..IsApplicable(SqlCommand)

See Also

IfIsNotBounce Class
Sitecore.Analytics.Data.Filters.Filters Namespace


IfIsNotBounce Properties

[image] [image]

Sitecore 6.4.1 API
IfIsNotBounce Properties
IfIsNotBounce Class See Also Send Feedback

The IfIsNotBounce type exposes the following members.

Properties

 | Name | Description
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorFilterBase.)

See Also

IfIsNotBounce Class
Sitecore.Analytics.Data.Filters.Filters Namespace


OperatorFilterBase Class

[image]

Sitecore 6.4.1 API
OperatorFilterBase Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract class OperatorFilterBase : FilterBase
Visual Basic
Public MustInherit Class OperatorFilterBase _
    Inherits FilterBase
Visual C++
public ref class OperatorFilterBase abstract : public FilterBase

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Filters..::..FilterBase
Sitecore.Analytics.Data.Filters.Filters..::..OperatorFilterBase
Sitecore.Analytics.Data.Filters.Filters..::..IfExitPage
Sitecore.Analytics.Data.Filters.Filters..::..IfIsNotBounce
Sitecore.Analytics.Data.Filters.Filters..::..WhereGlobalVisitNo
Sitecore.Analytics.Data.Filters.Filters..::..WhereIpBase
Sitecore.Analytics.Data.Filters.Filters..::..WhereIpOwnerBase
Sitecore.Analytics.Data.Filters.Filters..::..WherePageCount
Sitecore.Analytics.Data.Filters.Filters..::..WherePageNo
Sitecore.Analytics.Data.Filters.Filters..::..WhereProfileKey
Sitecore.Analytics.Data.Filters.Filters..::..WhereVisitorIdentification

See Also

OperatorFilterBase Members
Sitecore.Analytics.Data.Filters.Filters Namespace


OperatorFilterBase Members

[image] [image]

Sitecore 6.4.1 API
OperatorFilterBase Members
OperatorFilterBase Class Constructors Methods Properties See Also Send Feedback

The OperatorFilterBase type exposes the following members.

Constructors

 | Name | Description
Protected method | OperatorFilterBase | Initializes a new instance of the OperatorFilterBase class

Methods

 | Name | Description
Public method | ApplyFilter | Applies this instance. (Inherited from FilterBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Inherited from FilterBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | OperatorId | Gets or sets the operator id.

See Also

OperatorFilterBase Class
Sitecore.Analytics.Data.Filters.Filters Namespace


OperatorFilterBase Constructor

[image]

Sitecore 6.4.1 API
OperatorFilterBase Constructor
OperatorFilterBase Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected OperatorFilterBase()
Visual Basic
Protected Sub New
Visual C++
protected:
OperatorFilterBase()

See Also

OperatorFilterBase Class
Sitecore.Analytics.Data.Filters.Filters Namespace


OperatorFilterBase Methods

[image] [image]

Sitecore 6.4.1 API
OperatorFilterBase Methods
OperatorFilterBase Class See Also Send Feedback

The OperatorFilterBase type exposes the following members.

Methods

 | Name | Description
Public method | ApplyFilter | Applies this instance. (Inherited from FilterBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Inherited from FilterBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OperatorFilterBase Class
Sitecore.Analytics.Data.Filters.Filters Namespace


GetOperator Method

[image]

Sitecore 6.4.1 API
OperatorFilterBase..::..GetOperator Method
OperatorFilterBase Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected string GetOperator()
Visual Basic
Protected Function GetOperator As String
Visual C++
protected:
String^ GetOperator()

Return Value

Returns the string.

See Also

OperatorFilterBase Class
Sitecore.Analytics.Data.Filters.Filters Namespace


OperatorFilterBase Properties

[image] [image]

Sitecore 6.4.1 API
OperatorFilterBase Properties
OperatorFilterBase Class See Also Send Feedback

The OperatorFilterBase type exposes the following members.

Properties

 | Name | Description
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | OperatorId | Gets or sets the operator id.

See Also

OperatorFilterBase Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereAreaCode Class

[image]

Sitecore 6.4.1 API
WhereAreaCode Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class WhereAreaCode : WhereIpBase
Visual Basic
Public Class WhereAreaCode _
    Inherits WhereIpBase
Visual C++
public ref class WhereAreaCode : public WhereIpBase

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Filters..::..FilterBase
Sitecore.Analytics.Data.Filters.Filters..::..OperatorFilterBase
Sitecore.Analytics.Data.Filters.Filters..::..WhereIpBase
Sitecore.Analytics.Data.Filters.Filters..::..WhereAreaCode

See Also

WhereAreaCode Members
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereAreaCode Members

[image] [image]

Sitecore 6.4.1 API
WhereAreaCode Members
WhereAreaCode Class Constructors Methods Properties See Also Send Feedback

The WhereAreaCode type exposes the following members.

Constructors

 | Name | Description
Public method | WhereAreaCode | Initializes a new instance of the WhereAreaCode class.

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Inherited from WhereIpBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorFilterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Inherited from WhereIpBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Protected property | ColumnName | Gets or sets the name of the column. (Inherited from WhereIpBase.)
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorFilterBase.)
Public property | Value | Gets or sets the value. (Inherited from WhereIpBase.)

See Also

WhereAreaCode Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereAreaCode Constructor

[image]

Sitecore 6.4.1 API
WhereAreaCode Constructor
WhereAreaCode Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public WhereAreaCode()
Visual Basic
Public Sub New
Visual C++
public:
WhereAreaCode()

See Also

WhereAreaCode Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereAreaCode Methods

[image] [image]

Sitecore 6.4.1 API
WhereAreaCode Methods
WhereAreaCode Class See Also Send Feedback

The WhereAreaCode type exposes the following members.

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Inherited from WhereIpBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorFilterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Inherited from WhereIpBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WhereAreaCode Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereAreaCode Properties

[image] [image]

Sitecore 6.4.1 API
WhereAreaCode Properties
WhereAreaCode Class See Also Send Feedback

The WhereAreaCode type exposes the following members.

Properties

 | Name | Description
Protected property | ColumnName | Gets or sets the name of the column. (Inherited from WhereIpBase.)
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorFilterBase.)
Public property | Value | Gets or sets the value. (Inherited from WhereIpBase.)

See Also

WhereAreaCode Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereBrowser Class

[image]

Sitecore 6.4.1 API
WhereBrowser Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class WhereBrowser : FilterBase
Visual Basic
Public Class WhereBrowser _
    Inherits FilterBase
Visual C++
public ref class WhereBrowser : public FilterBase

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Filters..::..FilterBase
Sitecore.Analytics.Data.Filters.Filters..::..WhereBrowser

See Also

WhereBrowser Members
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereBrowser Members

[image] [image]

Sitecore 6.4.1 API
WhereBrowser Members
WhereBrowser Class Constructors Methods Properties See Also Send Feedback

The WhereBrowser type exposes the following members.

Constructors

 | Name | Description
Public method | WhereBrowser | Initializes a new instance of the WhereBrowser class

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Overrides FilterBase..::..ApplyFilter(SqlCommand).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Overrides FilterBase..::..IsApplicable(SqlCommand).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BrowserId | Gets or sets the browser user agent.
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)

See Also

WhereBrowser Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereBrowser Constructor

[image]

Sitecore 6.4.1 API
WhereBrowser Constructor
WhereBrowser Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public WhereBrowser()
Visual Basic
Public Sub New
Visual C++
public:
WhereBrowser()

See Also

WhereBrowser Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereBrowser Methods

[image] [image]

Sitecore 6.4.1 API
WhereBrowser Methods
WhereBrowser Class See Also Send Feedback

The WhereBrowser type exposes the following members.

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Overrides FilterBase..::..ApplyFilter(SqlCommand).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Overrides FilterBase..::..IsApplicable(SqlCommand).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WhereBrowser Class
Sitecore.Analytics.Data.Filters.Filters Namespace


ApplyFilter Method

[image]

Sitecore 6.4.1 API
WhereBrowser..::..ApplyFilter Method
WhereBrowser Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void ApplyFilter(
    SqlCommand sqlCommand
)
Visual Basic
Public Overrides Sub ApplyFilter ( _
    sqlCommand As SqlCommand _
)
Visual C++
public:
virtual void ApplyFilter(
    SqlCommand^ sqlCommand
) override

Parameters

sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.

Implements

IFilter..::..ApplyFilter(SqlCommand)

See Also

WhereBrowser Class
Sitecore.Analytics.Data.Filters.Filters Namespace


IsApplicable Method

[image]

Sitecore 6.4.1 API
WhereBrowser..::..IsApplicable Method
WhereBrowser Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override bool IsApplicable(
    SqlCommand sqlCommand
)
Visual Basic
Public Overrides Function IsApplicable ( _
    sqlCommand As SqlCommand _
) As Boolean
Visual C++
public:
virtual bool IsApplicable(
    SqlCommand^ sqlCommand
) override

Parameters

sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.

Return Value

true if the filter is applicable to the specified SQL Command; otherwise, false.

Implements

IFilter..::..IsApplicable(SqlCommand)

See Also

WhereBrowser Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereBrowser Properties

[image] [image]

Sitecore 6.4.1 API
WhereBrowser Properties
WhereBrowser Class See Also Send Feedback

The WhereBrowser type exposes the following members.

Properties

 | Name | Description
Public property | BrowserId | Gets or sets the browser user agent.
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)

See Also

WhereBrowser Class
Sitecore.Analytics.Data.Filters.Filters Namespace


BrowserId Property

[image]

Sitecore 6.4.1 API
WhereBrowser..::..BrowserId Property
WhereBrowser Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string BrowserId { get; set; }
Visual Basic
Public Property BrowserId As String
    Get
    Set
Visual C++
public:
property String^ BrowserId {
    String^ get ();
    void set (String^ value);
}

Field Value

The user agent.

See Also

WhereBrowser Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereCampaign Class

[image]

Sitecore 6.4.1 API
WhereCampaign Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class WhereCampaign : FilterBase
Visual Basic
Public Class WhereCampaign _
    Inherits FilterBase
Visual C++
public ref class WhereCampaign : public FilterBase

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Filters..::..FilterBase
Sitecore.Analytics.Data.Filters.Filters..::..WhereCampaign

See Also

WhereCampaign Members
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereCampaign Members

[image] [image]

Sitecore 6.4.1 API
WhereCampaign Members
WhereCampaign Class Constructors Methods Properties See Also Send Feedback

The WhereCampaign type exposes the following members.

Constructors

 | Name | Description
Public method | WhereCampaign | Initializes a new instance of the WhereCampaign class

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Overrides FilterBase..::..ApplyFilter(SqlCommand).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Overrides FilterBase..::..IsApplicable(SqlCommand).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Campaign | Gets or sets the campaign.
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)

See Also

WhereCampaign Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereCampaign Constructor

[image]

Sitecore 6.4.1 API
WhereCampaign Constructor
WhereCampaign Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public WhereCampaign()
Visual Basic
Public Sub New
Visual C++
public:
WhereCampaign()

See Also

WhereCampaign Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereCampaign Methods

[image] [image]

Sitecore 6.4.1 API
WhereCampaign Methods
WhereCampaign Class See Also Send Feedback

The WhereCampaign type exposes the following members.

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Overrides FilterBase..::..ApplyFilter(SqlCommand).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Overrides FilterBase..::..IsApplicable(SqlCommand).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WhereCampaign Class
Sitecore.Analytics.Data.Filters.Filters Namespace


ApplyFilter Method

[image]

Sitecore 6.4.1 API
WhereCampaign..::..ApplyFilter Method
WhereCampaign Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void ApplyFilter(
    SqlCommand sqlCommand
)
Visual Basic
Public Overrides Sub ApplyFilter ( _
    sqlCommand As SqlCommand _
)
Visual C++
public:
virtual void ApplyFilter(
    SqlCommand^ sqlCommand
) override

Parameters

sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.

Implements

IFilter..::..ApplyFilter(SqlCommand)

See Also

WhereCampaign Class
Sitecore.Analytics.Data.Filters.Filters Namespace


IsApplicable Method

[image]

Sitecore 6.4.1 API
WhereCampaign..::..IsApplicable Method
WhereCampaign Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override bool IsApplicable(
    SqlCommand sqlCommand
)
Visual Basic
Public Overrides Function IsApplicable ( _
    sqlCommand As SqlCommand _
) As Boolean
Visual C++
public:
virtual bool IsApplicable(
    SqlCommand^ sqlCommand
) override

Parameters

sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.

Return Value

true if the filter is applicable to the specified SQL Command; otherwise, false.

Implements

IFilter..::..IsApplicable(SqlCommand)

See Also

WhereCampaign Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereCampaign Properties

[image] [image]

Sitecore 6.4.1 API
WhereCampaign Properties
WhereCampaign Class See Also Send Feedback

The WhereCampaign type exposes the following members.

Properties

 | Name | Description
Public property | Campaign | Gets or sets the campaign.
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)

See Also

WhereCampaign Class
Sitecore.Analytics.Data.Filters.Filters Namespace


Campaign Property

[image]

Sitecore 6.4.1 API
WhereCampaign..::..Campaign Property
WhereCampaign Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Campaign { get; set; }
Visual Basic
Public Property Campaign As String
    Get
    Set
Visual C++
public:
property String^ Campaign {
    String^ get ();
    void set (String^ value);
}

Field Value

The campaign.

See Also

WhereCampaign Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereCity Class

[image]

Sitecore 6.4.1 API
WhereCity Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class WhereCity : WhereIpBase
Visual Basic
Public Class WhereCity _
    Inherits WhereIpBase
Visual C++
public ref class WhereCity : public WhereIpBase

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Filters..::..FilterBase
Sitecore.Analytics.Data.Filters.Filters..::..OperatorFilterBase
Sitecore.Analytics.Data.Filters.Filters..::..WhereIpBase
Sitecore.Analytics.Data.Filters.Filters..::..WhereCity

See Also

WhereCity Members
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereCity Members

[image] [image]

Sitecore 6.4.1 API
WhereCity Members
WhereCity Class Constructors Methods Properties See Also Send Feedback

The WhereCity type exposes the following members.

Constructors

 | Name | Description
Public method | WhereCity | Initializes a new instance of the WhereCity class.

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Inherited from WhereIpBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorFilterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Inherited from WhereIpBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Protected property | ColumnName | Gets or sets the name of the column. (Inherited from WhereIpBase.)
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorFilterBase.)
Public property | Value | Gets or sets the value. (Inherited from WhereIpBase.)

See Also

WhereCity Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereCity Constructor

[image]

Sitecore 6.4.1 API
WhereCity Constructor
WhereCity Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public WhereCity()
Visual Basic
Public Sub New
Visual C++
public:
WhereCity()

See Also

WhereCity Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereCity Methods

[image] [image]

Sitecore 6.4.1 API
WhereCity Methods
WhereCity Class See Also Send Feedback

The WhereCity type exposes the following members.

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Inherited from WhereIpBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorFilterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Inherited from WhereIpBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WhereCity Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereCity Properties

[image] [image]

Sitecore 6.4.1 API
WhereCity Properties
WhereCity Class See Also Send Feedback

The WhereCity type exposes the following members.

Properties

 | Name | Description
Protected property | ColumnName | Gets or sets the name of the column. (Inherited from WhereIpBase.)
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorFilterBase.)
Public property | Value | Gets or sets the value. (Inherited from WhereIpBase.)

See Also

WhereCity Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereCountry Class

[image]

Sitecore 6.4.1 API
WhereCountry Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class WhereCountry : WhereIpOwnerBase
Visual Basic
Public Class WhereCountry _
    Inherits WhereIpOwnerBase
Visual C++
public ref class WhereCountry : public WhereIpOwnerBase

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Filters..::..FilterBase
Sitecore.Analytics.Data.Filters.Filters..::..OperatorFilterBase
Sitecore.Analytics.Data.Filters.Filters..::..WhereIpOwnerBase
Sitecore.Analytics.Data.Filters.Filters..::..WhereCountry

See Also

WhereCountry Members
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereCountry Members

[image] [image]

Sitecore 6.4.1 API
WhereCountry Members
WhereCountry Class Constructors Methods Properties See Also Send Feedback

The WhereCountry type exposes the following members.

Constructors

 | Name | Description
Public method | WhereCountry | Initializes a new instance of the WhereCountry class.

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Inherited from WhereIpOwnerBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorFilterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Inherited from WhereIpOwnerBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Protected property | ColumnName | Gets or sets the name of the column. (Inherited from WhereIpOwnerBase.)
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorFilterBase.)
Public property | Value | Gets or sets the value. (Inherited from WhereIpOwnerBase.)

See Also

WhereCountry Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereCountry Constructor

[image]

Sitecore 6.4.1 API
WhereCountry Constructor
WhereCountry Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public WhereCountry()
Visual Basic
Public Sub New
Visual C++
public:
WhereCountry()

See Also

WhereCountry Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereCountry Methods

[image] [image]

Sitecore 6.4.1 API
WhereCountry Methods
WhereCountry Class See Also Send Feedback

The WhereCountry type exposes the following members.

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Inherited from WhereIpOwnerBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorFilterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Inherited from WhereIpOwnerBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WhereCountry Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereCountry Properties

[image] [image]

Sitecore 6.4.1 API
WhereCountry Properties
WhereCountry Class See Also Send Feedback

The WhereCountry type exposes the following members.

Properties

 | Name | Description
Protected property | ColumnName | Gets or sets the name of the column. (Inherited from WhereIpOwnerBase.)
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorFilterBase.)
Public property | Value | Gets or sets the value. (Inherited from WhereIpOwnerBase.)

See Also

WhereCountry Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereGlobalVisitNo Class

[image]

Sitecore 6.4.1 API
WhereGlobalVisitNo Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class WhereGlobalVisitNo : OperatorFilterBase
Visual Basic
Public Class WhereGlobalVisitNo _
    Inherits OperatorFilterBase
Visual C++
public ref class WhereGlobalVisitNo : public OperatorFilterBase

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Filters..::..FilterBase
Sitecore.Analytics.Data.Filters.Filters..::..OperatorFilterBase
Sitecore.Analytics.Data.Filters.Filters..::..WhereGlobalVisitNo

See Also

WhereGlobalVisitNo Members
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereGlobalVisitNo Members

[image] [image]

Sitecore 6.4.1 API
WhereGlobalVisitNo Members
WhereGlobalVisitNo Class Constructors Methods Properties See Also Send Feedback

The WhereGlobalVisitNo type exposes the following members.

Constructors

 | Name | Description
Public method | WhereGlobalVisitNo | Initializes a new instance of the WhereGlobalVisitNo class

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Overrides FilterBase..::..ApplyFilter(SqlCommand).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorFilterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Overrides FilterBase..::..IsApplicable(SqlCommand).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | GlobalVisitNo | Gets or sets the visit no.
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorFilterBase.)

See Also

WhereGlobalVisitNo Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereGlobalVisitNo Constructor

[image]

Sitecore 6.4.1 API
WhereGlobalVisitNo Constructor
WhereGlobalVisitNo Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public WhereGlobalVisitNo()
Visual Basic
Public Sub New
Visual C++
public:
WhereGlobalVisitNo()

See Also

WhereGlobalVisitNo Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereGlobalVisitNo Methods

[image] [image]

Sitecore 6.4.1 API
WhereGlobalVisitNo Methods
WhereGlobalVisitNo Class See Also Send Feedback

The WhereGlobalVisitNo type exposes the following members.

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Overrides FilterBase..::..ApplyFilter(SqlCommand).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorFilterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Overrides FilterBase..::..IsApplicable(SqlCommand).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WhereGlobalVisitNo Class
Sitecore.Analytics.Data.Filters.Filters Namespace


ApplyFilter Method

[image]

Sitecore 6.4.1 API
WhereGlobalVisitNo..::..ApplyFilter Method
WhereGlobalVisitNo Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void ApplyFilter(
    SqlCommand sqlCommand
)
Visual Basic
Public Overrides Sub ApplyFilter ( _
    sqlCommand As SqlCommand _
)
Visual C++
public:
virtual void ApplyFilter(
    SqlCommand^ sqlCommand
) override

Parameters

sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.

Implements

IFilter..::..ApplyFilter(SqlCommand)

See Also

WhereGlobalVisitNo Class
Sitecore.Analytics.Data.Filters.Filters Namespace


IsApplicable Method

[image]

Sitecore 6.4.1 API
WhereGlobalVisitNo..::..IsApplicable Method
WhereGlobalVisitNo Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override bool IsApplicable(
    SqlCommand sqlCommand
)
Visual Basic
Public Overrides Function IsApplicable ( _
    sqlCommand As SqlCommand _
) As Boolean
Visual C++
public:
virtual bool IsApplicable(
    SqlCommand^ sqlCommand
) override

Parameters

sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.

Return Value

true if the filter is applicable to the specified SQL Command; otherwise, false.

Implements

IFilter..::..IsApplicable(SqlCommand)

See Also

WhereGlobalVisitNo Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereGlobalVisitNo Properties

[image] [image]

Sitecore 6.4.1 API
WhereGlobalVisitNo Properties
WhereGlobalVisitNo Class See Also Send Feedback

The WhereGlobalVisitNo type exposes the following members.

Properties

 | Name | Description
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | GlobalVisitNo | Gets or sets the visit no.
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorFilterBase.)

See Also

WhereGlobalVisitNo Class
Sitecore.Analytics.Data.Filters.Filters Namespace


GlobalVisitNo Property

[image]

Sitecore 6.4.1 API
WhereGlobalVisitNo..::..GlobalVisitNo Property
WhereGlobalVisitNo Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int GlobalVisitNo { get; set; }
Visual Basic
Public Property GlobalVisitNo As Integer
    Get
    Set
Visual C++
public:
property int GlobalVisitNo {
    int get ();
    void set (int value);
}

Field Value

The visit no.

See Also

WhereGlobalVisitNo Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereIpBase Class

[image]

Sitecore 6.4.1 API
WhereIpBase Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class WhereIpBase : OperatorFilterBase
Visual Basic
Public Class WhereIpBase _
    Inherits OperatorFilterBase
Visual C++
public ref class WhereIpBase : public OperatorFilterBase

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Filters..::..FilterBase
Sitecore.Analytics.Data.Filters.Filters..::..OperatorFilterBase
Sitecore.Analytics.Data.Filters.Filters..::..WhereIpBase
Sitecore.Analytics.Data.Filters.Filters..::..WhereAreaCode
Sitecore.Analytics.Data.Filters.Filters..::..WhereCity
Sitecore.Analytics.Data.Filters.Filters..::..WhereIsp
Sitecore.Analytics.Data.Filters.Filters..::..WhereLatitude
Sitecore.Analytics.Data.Filters.Filters..::..WhereLongitude
Sitecore.Analytics.Data.Filters.Filters..::..WhereMetroCode
Sitecore.Analytics.Data.Filters.Filters..::..WherePostalCode
Sitecore.Analytics.Data.Filters.Filters..::..WhereRegion

See Also

WhereIpBase Members
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereIpBase Members

[image] [image]

Sitecore 6.4.1 API
WhereIpBase Members
WhereIpBase Class Constructors Methods Properties See Also Send Feedback

The WhereIpBase type exposes the following members.

Constructors

 | Name | Description
Public method | WhereIpBase | Initializes a new instance of the WhereIpBase class

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Overrides FilterBase..::..ApplyFilter(SqlCommand).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorFilterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Overrides FilterBase..::..IsApplicable(SqlCommand).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Protected property | ColumnName | Gets or sets the name of the column.
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorFilterBase.)
Public property | Value | Gets or sets the value.

See Also

WhereIpBase Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereIpBase Constructor

[image]

Sitecore 6.4.1 API
WhereIpBase Constructor
WhereIpBase Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public WhereIpBase()
Visual Basic
Public Sub New
Visual C++
public:
WhereIpBase()

See Also

WhereIpBase Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereIpBase Methods

[image] [image]

Sitecore 6.4.1 API
WhereIpBase Methods
WhereIpBase Class See Also Send Feedback

The WhereIpBase type exposes the following members.

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Overrides FilterBase..::..ApplyFilter(SqlCommand).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorFilterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Overrides FilterBase..::..IsApplicable(SqlCommand).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WhereIpBase Class
Sitecore.Analytics.Data.Filters.Filters Namespace


ApplyFilter Method

[image]

Sitecore 6.4.1 API
WhereIpBase..::..ApplyFilter Method
WhereIpBase Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void ApplyFilter(
    SqlCommand sqlCommand
)
Visual Basic
Public Overrides Sub ApplyFilter ( _
    sqlCommand As SqlCommand _
)
Visual C++
public:
virtual void ApplyFilter(
    SqlCommand^ sqlCommand
) override

Parameters

sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.

Implements

IFilter..::..ApplyFilter(SqlCommand)

See Also

WhereIpBase Class
Sitecore.Analytics.Data.Filters.Filters Namespace


IsApplicable Method

[image]

Sitecore 6.4.1 API
WhereIpBase..::..IsApplicable Method
WhereIpBase Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override bool IsApplicable(
    SqlCommand sqlCommand
)
Visual Basic
Public Overrides Function IsApplicable ( _
    sqlCommand As SqlCommand _
) As Boolean
Visual C++
public:
virtual bool IsApplicable(
    SqlCommand^ sqlCommand
) override

Parameters

sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.

Return Value

true if the filter is applicable to the specified SQL Command; otherwise, false.

Implements

IFilter..::..IsApplicable(SqlCommand)

See Also

WhereIpBase Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereIpBase Properties

[image] [image]

Sitecore 6.4.1 API
WhereIpBase Properties
WhereIpBase Class See Also Send Feedback

The WhereIpBase type exposes the following members.

Properties

 | Name | Description
Protected property | ColumnName | Gets or sets the name of the column.
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorFilterBase.)
Public property | Value | Gets or sets the value.

See Also

WhereIpBase Class
Sitecore.Analytics.Data.Filters.Filters Namespace


ColumnName Property

[image]

Sitecore 6.4.1 API
WhereIpBase..::..ColumnName Property
WhereIpBase Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected string ColumnName { get; set; }
Visual Basic
Protected Property ColumnName As String
    Get
    Set
Visual C++
protected:
property String^ ColumnName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the column.

See Also

WhereIpBase Class
Sitecore.Analytics.Data.Filters.Filters Namespace


Value Property

[image]

Sitecore 6.4.1 API
WhereIpBase..::..Value Property
WhereIpBase Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Field Value

The value.

See Also

WhereIpBase Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereIpOwnerBase Class

[image]

Sitecore 6.4.1 API
WhereIpOwnerBase Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class WhereIpOwnerBase : OperatorFilterBase
Visual Basic
Public Class WhereIpOwnerBase _
    Inherits OperatorFilterBase
Visual C++
public ref class WhereIpOwnerBase : public OperatorFilterBase

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Filters..::..FilterBase
Sitecore.Analytics.Data.Filters.Filters..::..OperatorFilterBase
Sitecore.Analytics.Data.Filters.Filters..::..WhereIpOwnerBase
Sitecore.Analytics.Data.Filters.Filters..::..WhereCountry
Sitecore.Analytics.Data.Filters.Filters..::..WhereName

See Also

WhereIpOwnerBase Members
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereIpOwnerBase Members

[image] [image]

Sitecore 6.4.1 API
WhereIpOwnerBase Members
WhereIpOwnerBase Class Constructors Methods Properties See Also Send Feedback

The WhereIpOwnerBase type exposes the following members.

Constructors

 | Name | Description
Public method | WhereIpOwnerBase | Initializes a new instance of the WhereIpOwnerBase class

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Overrides FilterBase..::..ApplyFilter(SqlCommand).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorFilterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Overrides FilterBase..::..IsApplicable(SqlCommand).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Protected property | ColumnName | Gets or sets the name of the column.
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorFilterBase.)
Public property | Value | Gets or sets the value.

See Also

WhereIpOwnerBase Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereIpOwnerBase Constructor

[image]

Sitecore 6.4.1 API
WhereIpOwnerBase Constructor
WhereIpOwnerBase Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public WhereIpOwnerBase()
Visual Basic
Public Sub New
Visual C++
public:
WhereIpOwnerBase()

See Also

WhereIpOwnerBase Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereIpOwnerBase Methods

[image] [image]

Sitecore 6.4.1 API
WhereIpOwnerBase Methods
WhereIpOwnerBase Class See Also Send Feedback

The WhereIpOwnerBase type exposes the following members.

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Overrides FilterBase..::..ApplyFilter(SqlCommand).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorFilterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Overrides FilterBase..::..IsApplicable(SqlCommand).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WhereIpOwnerBase Class
Sitecore.Analytics.Data.Filters.Filters Namespace


ApplyFilter Method

[image]

Sitecore 6.4.1 API
WhereIpOwnerBase..::..ApplyFilter Method
WhereIpOwnerBase Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void ApplyFilter(
    SqlCommand sqlCommand
)
Visual Basic
Public Overrides Sub ApplyFilter ( _
    sqlCommand As SqlCommand _
)
Visual C++
public:
virtual void ApplyFilter(
    SqlCommand^ sqlCommand
) override

Parameters

sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.

Implements

IFilter..::..ApplyFilter(SqlCommand)

See Also

WhereIpOwnerBase Class
Sitecore.Analytics.Data.Filters.Filters Namespace


IsApplicable Method

[image]

Sitecore 6.4.1 API
WhereIpOwnerBase..::..IsApplicable Method
WhereIpOwnerBase Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override bool IsApplicable(
    SqlCommand sqlCommand
)
Visual Basic
Public Overrides Function IsApplicable ( _
    sqlCommand As SqlCommand _
) As Boolean
Visual C++
public:
virtual bool IsApplicable(
    SqlCommand^ sqlCommand
) override

Parameters

sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.

Return Value

true if the filter is applicable to the specified SQL Command; otherwise, false.

Implements

IFilter..::..IsApplicable(SqlCommand)

See Also

WhereIpOwnerBase Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereIpOwnerBase Properties

[image] [image]

Sitecore 6.4.1 API
WhereIpOwnerBase Properties
WhereIpOwnerBase Class See Also Send Feedback

The WhereIpOwnerBase type exposes the following members.

Properties

 | Name | Description
Protected property | ColumnName | Gets or sets the name of the column.
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorFilterBase.)
Public property | Value | Gets or sets the value.

See Also

WhereIpOwnerBase Class
Sitecore.Analytics.Data.Filters.Filters Namespace


ColumnName Property

[image]

Sitecore 6.4.1 API
WhereIpOwnerBase..::..ColumnName Property
WhereIpOwnerBase Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected string ColumnName { get; set; }
Visual Basic
Protected Property ColumnName As String
    Get
    Set
Visual C++
protected:
property String^ ColumnName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the column.

See Also

WhereIpOwnerBase Class
Sitecore.Analytics.Data.Filters.Filters Namespace


Value Property

[image]

Sitecore 6.4.1 API
WhereIpOwnerBase..::..Value Property
WhereIpOwnerBase Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Field Value

The value.

See Also

WhereIpOwnerBase Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereIsp Class

[image]

Sitecore 6.4.1 API
WhereIsp Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class WhereIsp : WhereIpBase
Visual Basic
Public Class WhereIsp _
    Inherits WhereIpBase
Visual C++
public ref class WhereIsp : public WhereIpBase

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Filters..::..FilterBase
Sitecore.Analytics.Data.Filters.Filters..::..OperatorFilterBase
Sitecore.Analytics.Data.Filters.Filters..::..WhereIpBase
Sitecore.Analytics.Data.Filters.Filters..::..WhereIsp

See Also

WhereIsp Members
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereIsp Members

[image] [image]

Sitecore 6.4.1 API
WhereIsp Members
WhereIsp Class Constructors Methods Properties See Also Send Feedback

The WhereIsp type exposes the following members.

Constructors

 | Name | Description
Public method | WhereIsp | Initializes a new instance of the WhereIsp class.

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Inherited from WhereIpBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorFilterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Inherited from WhereIpBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Protected property | ColumnName | Gets or sets the name of the column. (Inherited from WhereIpBase.)
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorFilterBase.)
Public property | Value | Gets or sets the value. (Inherited from WhereIpBase.)

See Also

WhereIsp Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereIsp Constructor

[image]

Sitecore 6.4.1 API
WhereIsp Constructor
WhereIsp Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public WhereIsp()
Visual Basic
Public Sub New
Visual C++
public:
WhereIsp()

See Also

WhereIsp Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereIsp Properties

[image] [image]

Sitecore 6.4.1 API
WhereIsp Properties
WhereIsp Class See Also Send Feedback

The WhereIsp type exposes the following members.

Properties

 | Name | Description
Protected property | ColumnName | Gets or sets the name of the column. (Inherited from WhereIpBase.)
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorFilterBase.)
Public property | Value | Gets or sets the value. (Inherited from WhereIpBase.)

See Also

WhereIsp Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereItem Class

[image]

Sitecore 6.4.1 API
WhereItem Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class WhereItem : FilterBase
Visual Basic
Public Class WhereItem _
    Inherits FilterBase
Visual C++
public ref class WhereItem : public FilterBase

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Filters..::..FilterBase
Sitecore.Analytics.Data.Filters.Filters..::..WhereItem

See Also

WhereItem Members
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereItem Members

[image] [image]

Sitecore 6.4.1 API
WhereItem Members
WhereItem Class Constructors Methods Properties See Also Send Feedback

The WhereItem type exposes the following members.

Constructors

 | Name | Description
Public method | WhereItem | Initializes a new instance of the WhereItem class

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Overrides FilterBase..::..ApplyFilter(SqlCommand).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Overrides FilterBase..::..IsApplicable(SqlCommand).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | ItemId | Gets or sets the visit no.

See Also

WhereItem Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereItem Constructor

[image]

Sitecore 6.4.1 API
WhereItem Constructor
WhereItem Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public WhereItem()
Visual Basic
Public Sub New
Visual C++
public:
WhereItem()

See Also

WhereItem Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereItem Methods

[image] [image]

Sitecore 6.4.1 API
WhereItem Methods
WhereItem Class See Also Send Feedback

The WhereItem type exposes the following members.

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Overrides FilterBase..::..ApplyFilter(SqlCommand).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Overrides FilterBase..::..IsApplicable(SqlCommand).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WhereItem Class
Sitecore.Analytics.Data.Filters.Filters Namespace


ApplyFilter Method

[image]

Sitecore 6.4.1 API
WhereItem..::..ApplyFilter Method
WhereItem Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void ApplyFilter(
    SqlCommand sqlCommand
)
Visual Basic
Public Overrides Sub ApplyFilter ( _
    sqlCommand As SqlCommand _
)
Visual C++
public:
virtual void ApplyFilter(
    SqlCommand^ sqlCommand
) override

Parameters

sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.

Implements

IFilter..::..ApplyFilter(SqlCommand)

See Also

WhereItem Class
Sitecore.Analytics.Data.Filters.Filters Namespace


IsApplicable Method

[image]

Sitecore 6.4.1 API
WhereItem..::..IsApplicable Method
WhereItem Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override bool IsApplicable(
    SqlCommand sqlCommand
)
Visual Basic
Public Overrides Function IsApplicable ( _
    sqlCommand As SqlCommand _
) As Boolean
Visual C++
public:
virtual bool IsApplicable(
    SqlCommand^ sqlCommand
) override

Parameters

sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.

Return Value

true if the filter is applicable to the specified SQL Command; otherwise, false.

Implements

IFilter..::..IsApplicable(SqlCommand)

See Also

WhereItem Class
Sitecore.Analytics.Data.Filters.Filters Namespace


ItemId Property

[image]

Sitecore 6.4.1 API
WhereItem..::..ItemId Property
WhereItem Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string ItemId { get; set; }
Visual Basic
Public Property ItemId As String
    Get
    Set
Visual C++
public:
property String^ ItemId {
    String^ get ();
    void set (String^ value);
}

Field Value

The visit no.

See Also

WhereItem Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereKeywords Class

[image]

Sitecore 6.4.1 API
WhereKeywords Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class WhereKeywords : FilterBase
Visual Basic
Public Class WhereKeywords _
    Inherits FilterBase
Visual C++
public ref class WhereKeywords : public FilterBase

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Filters..::..FilterBase
Sitecore.Analytics.Data.Filters.Filters..::..WhereKeywords

See Also

WhereKeywords Members
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereKeywords Members

[image] [image]

Sitecore 6.4.1 API
WhereKeywords Members
WhereKeywords Class Constructors Methods Properties See Also Send Feedback

The WhereKeywords type exposes the following members.

Constructors

 | Name | Description
Public method | WhereKeywords | Initializes a new instance of the WhereKeywords class

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Overrides FilterBase..::..ApplyFilter(SqlCommand).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Overrides FilterBase..::..IsApplicable(SqlCommand).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | Keywords | Gets or sets the visit no.

See Also

WhereKeywords Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereKeywords Constructor

[image]

Sitecore 6.4.1 API
WhereKeywords Constructor
WhereKeywords Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public WhereKeywords()
Visual Basic
Public Sub New
Visual C++
public:
WhereKeywords()

See Also

WhereKeywords Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereKeywords Methods

[image] [image]

Sitecore 6.4.1 API
WhereKeywords Methods
WhereKeywords Class See Also Send Feedback

The WhereKeywords type exposes the following members.

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Overrides FilterBase..::..ApplyFilter(SqlCommand).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Overrides FilterBase..::..IsApplicable(SqlCommand).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WhereKeywords Class
Sitecore.Analytics.Data.Filters.Filters Namespace


ApplyFilter Method

[image]

Sitecore 6.4.1 API
WhereKeywords..::..ApplyFilter Method
WhereKeywords Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void ApplyFilter(
    SqlCommand sqlCommand
)
Visual Basic
Public Overrides Sub ApplyFilter ( _
    sqlCommand As SqlCommand _
)
Visual C++
public:
virtual void ApplyFilter(
    SqlCommand^ sqlCommand
) override

Parameters

sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.

Implements

IFilter..::..ApplyFilter(SqlCommand)

See Also

WhereKeywords Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereKeywords Properties

[image] [image]

Sitecore 6.4.1 API
WhereKeywords Properties
WhereKeywords Class See Also Send Feedback

The WhereKeywords type exposes the following members.

Properties

 | Name | Description
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | Keywords | Gets or sets the visit no.

See Also

WhereKeywords Class
Sitecore.Analytics.Data.Filters.Filters Namespace


Keywords Property

[image]

Sitecore 6.4.1 API
WhereKeywords..::..Keywords Property
WhereKeywords Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Keywords { get; set; }
Visual Basic
Public Property Keywords As String
    Get
    Set
Visual C++
public:
property String^ Keywords {
    String^ get ();
    void set (String^ value);
}

Field Value

The visit no.

See Also

WhereKeywords Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereLanguage Class

[image]

Sitecore 6.4.1 API
WhereLanguage Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class WhereLanguage : FilterBase
Visual Basic
Public Class WhereLanguage _
    Inherits FilterBase
Visual C++
public ref class WhereLanguage : public FilterBase

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Filters..::..FilterBase
Sitecore.Analytics.Data.Filters.Filters..::..WhereLanguage

See Also

WhereLanguage Members
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereLanguage Members

[image] [image]

Sitecore 6.4.1 API
WhereLanguage Members
WhereLanguage Class Constructors Methods Properties See Also Send Feedback

The WhereLanguage type exposes the following members.

Constructors

 | Name | Description
Public method | WhereLanguage | Initializes a new instance of the WhereLanguage class

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Overrides FilterBase..::..ApplyFilter(SqlCommand).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Overrides FilterBase..::..IsApplicable(SqlCommand).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | Language | Gets or sets the visit no.

See Also

WhereLanguage Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereLanguage Constructor

[image]

Sitecore 6.4.1 API
WhereLanguage Constructor
WhereLanguage Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public WhereLanguage()
Visual Basic
Public Sub New
Visual C++
public:
WhereLanguage()

See Also

WhereLanguage Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereLanguage Methods

[image] [image]

Sitecore 6.4.1 API
WhereLanguage Methods
WhereLanguage Class See Also Send Feedback

The WhereLanguage type exposes the following members.

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Overrides FilterBase..::..ApplyFilter(SqlCommand).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Overrides FilterBase..::..IsApplicable(SqlCommand).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WhereLanguage Class
Sitecore.Analytics.Data.Filters.Filters Namespace


ApplyFilter Method

[image]

Sitecore 6.4.1 API
WhereLanguage..::..ApplyFilter Method
WhereLanguage Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void ApplyFilter(
    SqlCommand sqlCommand
)
Visual Basic
Public Overrides Sub ApplyFilter ( _
    sqlCommand As SqlCommand _
)
Visual C++
public:
virtual void ApplyFilter(
    SqlCommand^ sqlCommand
) override

Parameters

sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.

Implements

IFilter..::..ApplyFilter(SqlCommand)

See Also

WhereLanguage Class
Sitecore.Analytics.Data.Filters.Filters Namespace


IsApplicable Method

[image]

Sitecore 6.4.1 API
WhereLanguage..::..IsApplicable Method
WhereLanguage Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override bool IsApplicable(
    SqlCommand sqlCommand
)
Visual Basic
Public Overrides Function IsApplicable ( _
    sqlCommand As SqlCommand _
) As Boolean
Visual C++
public:
virtual bool IsApplicable(
    SqlCommand^ sqlCommand
) override

Parameters

sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.

Return Value

true if the filter is applicable to the specified SQL Command; otherwise, false.

Implements

IFilter..::..IsApplicable(SqlCommand)

See Also

WhereLanguage Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereLanguage Properties

[image] [image]

Sitecore 6.4.1 API
WhereLanguage Properties
WhereLanguage Class See Also Send Feedback

The WhereLanguage type exposes the following members.

Properties

 | Name | Description
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | Language | Gets or sets the visit no.

See Also

WhereLanguage Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereLatitude Class

[image]

Sitecore 6.4.1 API
WhereLatitude Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class WhereLatitude : WhereIpBase
Visual Basic
Public Class WhereLatitude _
    Inherits WhereIpBase
Visual C++
public ref class WhereLatitude : public WhereIpBase

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Filters..::..FilterBase
Sitecore.Analytics.Data.Filters.Filters..::..OperatorFilterBase
Sitecore.Analytics.Data.Filters.Filters..::..WhereIpBase
Sitecore.Analytics.Data.Filters.Filters..::..WhereLatitude

See Also

WhereLatitude Members
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereLatitude Members

[image] [image]

Sitecore 6.4.1 API
WhereLatitude Members
WhereLatitude Class Constructors Methods Properties See Also Send Feedback

The WhereLatitude type exposes the following members.

Constructors

 | Name | Description
Public method | WhereLatitude | Initializes a new instance of the WhereLatitude class.

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Inherited from WhereIpBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorFilterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Inherited from WhereIpBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Protected property | ColumnName | Gets or sets the name of the column. (Inherited from WhereIpBase.)
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorFilterBase.)
Public property | Value | Gets or sets the value. (Inherited from WhereIpBase.)

See Also

WhereLatitude Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereLatitude Constructor

[image]

Sitecore 6.4.1 API
WhereLatitude Constructor
WhereLatitude Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public WhereLatitude()
Visual Basic
Public Sub New
Visual C++
public:
WhereLatitude()

See Also

WhereLatitude Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereLatitude Properties

[image] [image]

Sitecore 6.4.1 API
WhereLatitude Properties
WhereLatitude Class See Also Send Feedback

The WhereLatitude type exposes the following members.

Properties

 | Name | Description
Protected property | ColumnName | Gets or sets the name of the column. (Inherited from WhereIpBase.)
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorFilterBase.)
Public property | Value | Gets or sets the value. (Inherited from WhereIpBase.)

See Also

WhereLatitude Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereLongitude Class

[image]

Sitecore 6.4.1 API
WhereLongitude Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class WhereLongitude : WhereIpBase
Visual Basic
Public Class WhereLongitude _
    Inherits WhereIpBase
Visual C++
public ref class WhereLongitude : public WhereIpBase

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Filters..::..FilterBase
Sitecore.Analytics.Data.Filters.Filters..::..OperatorFilterBase
Sitecore.Analytics.Data.Filters.Filters..::..WhereIpBase
Sitecore.Analytics.Data.Filters.Filters..::..WhereLongitude

See Also

WhereLongitude Members
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereLongitude Members

[image] [image]

Sitecore 6.4.1 API
WhereLongitude Members
WhereLongitude Class Constructors Methods Properties See Also Send Feedback

The WhereLongitude type exposes the following members.

Constructors

 | Name | Description
Public method | WhereLongitude | Initializes a new instance of the WhereLongitude class.

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Inherited from WhereIpBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorFilterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Inherited from WhereIpBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Protected property | ColumnName | Gets or sets the name of the column. (Inherited from WhereIpBase.)
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorFilterBase.)
Public property | Value | Gets or sets the value. (Inherited from WhereIpBase.)

See Also

WhereLongitude Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereLongitude Constructor

[image]

Sitecore 6.4.1 API
WhereLongitude Constructor
WhereLongitude Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public WhereLongitude()
Visual Basic
Public Sub New
Visual C++
public:
WhereLongitude()

See Also

WhereLongitude Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereLongitude Methods

[image] [image]

Sitecore 6.4.1 API
WhereLongitude Methods
WhereLongitude Class See Also Send Feedback

The WhereLongitude type exposes the following members.

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Inherited from WhereIpBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorFilterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Inherited from WhereIpBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WhereLongitude Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereLongitude Properties

[image] [image]

Sitecore 6.4.1 API
WhereLongitude Properties
WhereLongitude Class See Also Send Feedback

The WhereLongitude type exposes the following members.

Properties

 | Name | Description
Protected property | ColumnName | Gets or sets the name of the column. (Inherited from WhereIpBase.)
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorFilterBase.)
Public property | Value | Gets or sets the value. (Inherited from WhereIpBase.)

See Also

WhereLongitude Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereMetroCode Class

[image]

Sitecore 6.4.1 API
WhereMetroCode Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class WhereMetroCode : WhereIpBase
Visual Basic
Public Class WhereMetroCode _
    Inherits WhereIpBase
Visual C++
public ref class WhereMetroCode : public WhereIpBase

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Filters..::..FilterBase
Sitecore.Analytics.Data.Filters.Filters..::..OperatorFilterBase
Sitecore.Analytics.Data.Filters.Filters..::..WhereIpBase
Sitecore.Analytics.Data.Filters.Filters..::..WhereMetroCode

See Also

WhereMetroCode Members
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereMetroCode Members

[image] [image]

Sitecore 6.4.1 API
WhereMetroCode Members
WhereMetroCode Class Constructors Methods Properties See Also Send Feedback

The WhereMetroCode type exposes the following members.

Constructors

 | Name | Description
Public method | WhereMetroCode | Initializes a new instance of the WhereMetroCode class.

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Inherited from WhereIpBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorFilterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Inherited from WhereIpBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Protected property | ColumnName | Gets or sets the name of the column. (Inherited from WhereIpBase.)
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorFilterBase.)
Public property | Value | Gets or sets the value. (Inherited from WhereIpBase.)

See Also

WhereMetroCode Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereMetroCode Constructor

[image]

Sitecore 6.4.1 API
WhereMetroCode Constructor
WhereMetroCode Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public WhereMetroCode()
Visual Basic
Public Sub New
Visual C++
public:
WhereMetroCode()

See Also

WhereMetroCode Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereMetroCode Methods

[image] [image]

Sitecore 6.4.1 API
WhereMetroCode Methods
WhereMetroCode Class See Also Send Feedback

The WhereMetroCode type exposes the following members.

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Inherited from WhereIpBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorFilterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Inherited from WhereIpBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WhereMetroCode Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereMetroCode Properties

[image] [image]

Sitecore 6.4.1 API
WhereMetroCode Properties
WhereMetroCode Class See Also Send Feedback

The WhereMetroCode type exposes the following members.

Properties

 | Name | Description
Protected property | ColumnName | Gets or sets the name of the column. (Inherited from WhereIpBase.)
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorFilterBase.)
Public property | Value | Gets or sets the value. (Inherited from WhereIpBase.)

See Also

WhereMetroCode Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereName Class

[image]

Sitecore 6.4.1 API
WhereName Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class WhereName : WhereIpOwnerBase
Visual Basic
Public Class WhereName _
    Inherits WhereIpOwnerBase
Visual C++
public ref class WhereName : public WhereIpOwnerBase

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Filters..::..FilterBase
Sitecore.Analytics.Data.Filters.Filters..::..OperatorFilterBase
Sitecore.Analytics.Data.Filters.Filters..::..WhereIpOwnerBase
Sitecore.Analytics.Data.Filters.Filters..::..WhereName

See Also

WhereName Members
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereName Members

[image] [image]

Sitecore 6.4.1 API
WhereName Members
WhereName Class Constructors Methods Properties See Also Send Feedback

The WhereName type exposes the following members.

Constructors

 | Name | Description
Public method | WhereName | Initializes a new instance of the WhereName class.

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Inherited from WhereIpOwnerBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorFilterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Inherited from WhereIpOwnerBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Protected property | ColumnName | Gets or sets the name of the column. (Inherited from WhereIpOwnerBase.)
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorFilterBase.)
Public property | Value | Gets or sets the value. (Inherited from WhereIpOwnerBase.)

See Also

WhereName Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereName Constructor

[image]

Sitecore 6.4.1 API
WhereName Constructor
WhereName Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public WhereName()
Visual Basic
Public Sub New
Visual C++
public:
WhereName()

See Also

WhereName Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereName Methods

[image] [image]

Sitecore 6.4.1 API
WhereName Methods
WhereName Class See Also Send Feedback

The WhereName type exposes the following members.

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Inherited from WhereIpOwnerBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorFilterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Inherited from WhereIpOwnerBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WhereName Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereName Properties

[image] [image]

Sitecore 6.4.1 API
WhereName Properties
WhereName Class See Also Send Feedback

The WhereName type exposes the following members.

Properties

 | Name | Description
Protected property | ColumnName | Gets or sets the name of the column. (Inherited from WhereIpOwnerBase.)
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorFilterBase.)
Public property | Value | Gets or sets the value. (Inherited from WhereIpOwnerBase.)

See Also

WhereName Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereOperatingSystem Class

[image]

Sitecore 6.4.1 API
WhereOperatingSystem Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class WhereOperatingSystem : FilterBase
Visual Basic
Public Class WhereOperatingSystem _
    Inherits FilterBase
Visual C++
public ref class WhereOperatingSystem : public FilterBase

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Filters..::..FilterBase
Sitecore.Analytics.Data.Filters.Filters..::..WhereOperatingSystem

See Also

WhereOperatingSystem Members
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereOperatingSystem Members

[image] [image]

Sitecore 6.4.1 API
WhereOperatingSystem Members
WhereOperatingSystem Class Constructors Methods Properties See Also Send Feedback

The WhereOperatingSystem type exposes the following members.

Constructors

 | Name | Description
Public method | WhereOperatingSystem | Initializes a new instance of the WhereOperatingSystem class

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Overrides FilterBase..::..ApplyFilter(SqlCommand).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Overrides FilterBase..::..IsApplicable(SqlCommand).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | OperatingSystemId | Gets or sets the operating system.

See Also

WhereOperatingSystem Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereOperatingSystem Constructor

[image]

Sitecore 6.4.1 API
WhereOperatingSystem Constructor
WhereOperatingSystem Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public WhereOperatingSystem()
Visual Basic
Public Sub New
Visual C++
public:
WhereOperatingSystem()

See Also

WhereOperatingSystem Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereOperatingSystem Methods

[image] [image]

Sitecore 6.4.1 API
WhereOperatingSystem Methods
WhereOperatingSystem Class See Also Send Feedback

The WhereOperatingSystem type exposes the following members.

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Overrides FilterBase..::..ApplyFilter(SqlCommand).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Overrides FilterBase..::..IsApplicable(SqlCommand).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WhereOperatingSystem Class
Sitecore.Analytics.Data.Filters.Filters Namespace


ApplyFilter Method

[image]

Sitecore 6.4.1 API
WhereOperatingSystem..::..ApplyFilter Method
WhereOperatingSystem Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void ApplyFilter(
    SqlCommand sqlCommand
)
Visual Basic
Public Overrides Sub ApplyFilter ( _
    sqlCommand As SqlCommand _
)
Visual C++
public:
virtual void ApplyFilter(
    SqlCommand^ sqlCommand
) override

Parameters

sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.

Implements

IFilter..::..ApplyFilter(SqlCommand)

See Also

WhereOperatingSystem Class
Sitecore.Analytics.Data.Filters.Filters Namespace


IsApplicable Method

[image]

Sitecore 6.4.1 API
WhereOperatingSystem..::..IsApplicable Method
WhereOperatingSystem Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override bool IsApplicable(
    SqlCommand sqlCommand
)
Visual Basic
Public Overrides Function IsApplicable ( _
    sqlCommand As SqlCommand _
) As Boolean
Visual C++
public:
virtual bool IsApplicable(
    SqlCommand^ sqlCommand
) override

Parameters

sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.

Return Value

true if the filter is applicable to the specified SQL Command; otherwise, false.

Implements

IFilter..::..IsApplicable(SqlCommand)

See Also

WhereOperatingSystem Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereOperatingSystem Properties

[image] [image]

Sitecore 6.4.1 API
WhereOperatingSystem Properties
WhereOperatingSystem Class See Also Send Feedback

The WhereOperatingSystem type exposes the following members.

Properties

 | Name | Description
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | OperatingSystemId | Gets or sets the operating system.

See Also

WhereOperatingSystem Class
Sitecore.Analytics.Data.Filters.Filters Namespace


OperatingSystemId Property

[image]

Sitecore 6.4.1 API
WhereOperatingSystem..::..OperatingSystemId Property
WhereOperatingSystem Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string OperatingSystemId { get; set; }
Visual Basic
Public Property OperatingSystemId As String
    Get
    Set
Visual C++
public:
property String^ OperatingSystemId {
    String^ get ();
    void set (String^ value);
}

Field Value

The operating system.

See Also

WhereOperatingSystem Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WherePageCount Class

[image]

Sitecore 6.4.1 API
WherePageCount Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class WherePageCount : OperatorFilterBase
Visual Basic
Public Class WherePageCount _
    Inherits OperatorFilterBase
Visual C++
public ref class WherePageCount : public OperatorFilterBase

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Filters..::..FilterBase
Sitecore.Analytics.Data.Filters.Filters..::..OperatorFilterBase
Sitecore.Analytics.Data.Filters.Filters..::..WherePageCount

See Also

WherePageCount Members
Sitecore.Analytics.Data.Filters.Filters Namespace


WherePageCount Members

[image] [image]

Sitecore 6.4.1 API
WherePageCount Members
WherePageCount Class Constructors Methods Properties See Also Send Feedback

The WherePageCount type exposes the following members.

Constructors

 | Name | Description
Public method | WherePageCount | Initializes a new instance of the WherePageCount class

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Overrides FilterBase..::..ApplyFilter(SqlCommand).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorFilterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Overrides FilterBase..::..IsApplicable(SqlCommand).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets or sets the visit no.
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorFilterBase.)

See Also

WherePageCount Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WherePageCount Methods

[image] [image]

Sitecore 6.4.1 API
WherePageCount Methods
WherePageCount Class See Also Send Feedback

The WherePageCount type exposes the following members.

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Overrides FilterBase..::..ApplyFilter(SqlCommand).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorFilterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Overrides FilterBase..::..IsApplicable(SqlCommand).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WherePageCount Class
Sitecore.Analytics.Data.Filters.Filters Namespace


ApplyFilter Method

[image]

Sitecore 6.4.1 API
WherePageCount..::..ApplyFilter Method
WherePageCount Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void ApplyFilter(
    SqlCommand sqlCommand
)
Visual Basic
Public Overrides Sub ApplyFilter ( _
    sqlCommand As SqlCommand _
)
Visual C++
public:
virtual void ApplyFilter(
    SqlCommand^ sqlCommand
) override

Parameters

sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.

Implements

IFilter..::..ApplyFilter(SqlCommand)

See Also

WherePageCount Class
Sitecore.Analytics.Data.Filters.Filters Namespace


IsApplicable Method

[image]

Sitecore 6.4.1 API
WherePageCount..::..IsApplicable Method
WherePageCount Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override bool IsApplicable(
    SqlCommand sqlCommand
)
Visual Basic
Public Overrides Function IsApplicable ( _
    sqlCommand As SqlCommand _
) As Boolean
Visual C++
public:
virtual bool IsApplicable(
    SqlCommand^ sqlCommand
) override

Parameters

sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.

Return Value

true if the filter is applicable to the specified SQL Command; otherwise, false.

Implements

IFilter..::..IsApplicable(SqlCommand)

See Also

WherePageCount Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WherePageCount Properties

[image] [image]

Sitecore 6.4.1 API
WherePageCount Properties
WherePageCount Class See Also Send Feedback

The WherePageCount type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets or sets the visit no.
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorFilterBase.)

See Also

WherePageCount Class
Sitecore.Analytics.Data.Filters.Filters Namespace


Count Property

[image]

Sitecore 6.4.1 API
WherePageCount..::..Count Property
WherePageCount Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int Count { get; set; }
Visual Basic
Public Property Count As Integer
    Get
    Set
Visual C++
public:
property int Count {
    int get ();
    void set (int value);
}

Field Value

The visit no.

See Also

WherePageCount Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WherePageNo Class

[image]

Sitecore 6.4.1 API
WherePageNo Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class WherePageNo : OperatorFilterBase
Visual Basic
Public Class WherePageNo _
    Inherits OperatorFilterBase
Visual C++
public ref class WherePageNo : public OperatorFilterBase

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Filters..::..FilterBase
Sitecore.Analytics.Data.Filters.Filters..::..OperatorFilterBase
Sitecore.Analytics.Data.Filters.Filters..::..WherePageNo

See Also

WherePageNo Members
Sitecore.Analytics.Data.Filters.Filters Namespace


WherePageNo Members

[image] [image]

Sitecore 6.4.1 API
WherePageNo Members
WherePageNo Class Constructors Methods Properties See Also Send Feedback

The WherePageNo type exposes the following members.

Constructors

 | Name | Description
Public method | WherePageNo | Initializes a new instance of the WherePageNo class

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Overrides FilterBase..::..ApplyFilter(SqlCommand).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorFilterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Overrides FilterBase..::..IsApplicable(SqlCommand).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorFilterBase.)
Public property | PageNo | Gets or sets the visit no.

See Also

WherePageNo Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WherePageNo Methods

[image] [image]

Sitecore 6.4.1 API
WherePageNo Methods
WherePageNo Class See Also Send Feedback

The WherePageNo type exposes the following members.

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Overrides FilterBase..::..ApplyFilter(SqlCommand).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorFilterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Overrides FilterBase..::..IsApplicable(SqlCommand).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WherePageNo Class
Sitecore.Analytics.Data.Filters.Filters Namespace


ApplyFilter Method

[image]

Sitecore 6.4.1 API
WherePageNo..::..ApplyFilter Method
WherePageNo Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void ApplyFilter(
    SqlCommand sqlCommand
)
Visual Basic
Public Overrides Sub ApplyFilter ( _
    sqlCommand As SqlCommand _
)
Visual C++
public:
virtual void ApplyFilter(
    SqlCommand^ sqlCommand
) override

Parameters

sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.

Implements

IFilter..::..ApplyFilter(SqlCommand)

See Also

WherePageNo Class
Sitecore.Analytics.Data.Filters.Filters Namespace


IsApplicable Method

[image]

Sitecore 6.4.1 API
WherePageNo..::..IsApplicable Method
WherePageNo Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override bool IsApplicable(
    SqlCommand sqlCommand
)
Visual Basic
Public Overrides Function IsApplicable ( _
    sqlCommand As SqlCommand _
) As Boolean
Visual C++
public:
virtual bool IsApplicable(
    SqlCommand^ sqlCommand
) override

Parameters

sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.

Return Value

true if the filter is applicable to the specified SQL Command; otherwise, false.

Implements

IFilter..::..IsApplicable(SqlCommand)

See Also

WherePageNo Class
Sitecore.Analytics.Data.Filters.Filters Namespace


PageNo Property

[image]

Sitecore 6.4.1 API
WherePageNo..::..PageNo Property
WherePageNo Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int PageNo { get; set; }
Visual Basic
Public Property PageNo As Integer
    Get
    Set
Visual C++
public:
property int PageNo {
    int get ();
    void set (int value);
}

Field Value

The visit no.

See Also

WherePageNo Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WherePersona Class

[image]

Sitecore 6.4.1 API
WherePersona Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class WherePersona : FilterBase
Visual Basic
Public Class WherePersona _
    Inherits FilterBase
Visual C++
public ref class WherePersona : public FilterBase

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Filters..::..FilterBase
Sitecore.Analytics.Data.Filters.Filters..::..WherePersona

See Also

WherePersona Members
Sitecore.Analytics.Data.Filters.Filters Namespace


WherePersona Members

[image] [image]

Sitecore 6.4.1 API
WherePersona Members
WherePersona Class Constructors Methods Properties See Also Send Feedback

The WherePersona type exposes the following members.

Constructors

 | Name | Description
Public method | WherePersona | Initializes a new instance of the WherePersona class.

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Overrides FilterBase..::..ApplyFilter(SqlCommand).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Overrides FilterBase..::..IsApplicable(SqlCommand).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | Item | Gets the item.

See Also

WherePersona Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WherePersona Constructor

[image]

Sitecore 6.4.1 API
WherePersona Constructor
WherePersona Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public WherePersona(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
WherePersona(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The persona item.

See Also

WherePersona Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WherePersona Methods

[image] [image]

Sitecore 6.4.1 API
WherePersona Methods
WherePersona Class See Also Send Feedback

The WherePersona type exposes the following members.

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Overrides FilterBase..::..ApplyFilter(SqlCommand).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Overrides FilterBase..::..IsApplicable(SqlCommand).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WherePersona Class
Sitecore.Analytics.Data.Filters.Filters Namespace


ApplyFilter Method

[image]

Sitecore 6.4.1 API
WherePersona..::..ApplyFilter Method
WherePersona Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void ApplyFilter(
    SqlCommand sqlCommand
)
Visual Basic
Public Overrides Sub ApplyFilter ( _
    sqlCommand As SqlCommand _
)
Visual C++
public:
virtual void ApplyFilter(
    SqlCommand^ sqlCommand
) override

Parameters

sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.

Implements

IFilter..::..ApplyFilter(SqlCommand)

See Also

WherePersona Class
Sitecore.Analytics.Data.Filters.Filters Namespace


IsApplicable Method

[image]

Sitecore 6.4.1 API
WherePersona..::..IsApplicable Method
WherePersona Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override bool IsApplicable(
    SqlCommand sqlCommand
)
Visual Basic
Public Overrides Function IsApplicable ( _
    sqlCommand As SqlCommand _
) As Boolean
Visual C++
public:
virtual bool IsApplicable(
    SqlCommand^ sqlCommand
) override

Parameters

sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.

Return Value

true if the filter is applicable to the specified SQL Command; otherwise, false.

Implements

IFilter..::..IsApplicable(SqlCommand)

See Also

WherePersona Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WherePersona Properties

[image] [image]

Sitecore 6.4.1 API
WherePersona Properties
WherePersona Class See Also Send Feedback

The WherePersona type exposes the following members.

Properties

 | Name | Description
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | Item | Gets the item.

See Also

WherePersona Class
Sitecore.Analytics.Data.Filters.Filters Namespace


Item Property

[image]

Sitecore 6.4.1 API
WherePersona..::..Item Property
WherePersona Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Item Item { get; }
Visual Basic
Public ReadOnly Property Item As Item
    Get
Visual C++
public:
property Item^ Item {
    Item^ get ();
}

Field Value

The persona item.

See Also

WherePersona Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WherePostalCode Class

[image]

Sitecore 6.4.1 API
WherePostalCode Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class WherePostalCode : WhereIpBase
Visual Basic
Public Class WherePostalCode _
    Inherits WhereIpBase
Visual C++
public ref class WherePostalCode : public WhereIpBase

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Filters..::..FilterBase
Sitecore.Analytics.Data.Filters.Filters..::..OperatorFilterBase
Sitecore.Analytics.Data.Filters.Filters..::..WhereIpBase
Sitecore.Analytics.Data.Filters.Filters..::..WherePostalCode

See Also

WherePostalCode Members
Sitecore.Analytics.Data.Filters.Filters Namespace


WherePostalCode Members

[image] [image]

Sitecore 6.4.1 API
WherePostalCode Members
WherePostalCode Class Constructors Methods Properties See Also Send Feedback

The WherePostalCode type exposes the following members.

Constructors

 | Name | Description
Public method | WherePostalCode | Initializes a new instance of the WherePostalCode class.

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Inherited from WhereIpBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorFilterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Inherited from WhereIpBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Protected property | ColumnName | Gets or sets the name of the column. (Inherited from WhereIpBase.)
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorFilterBase.)
Public property | Value | Gets or sets the value. (Inherited from WhereIpBase.)

See Also

WherePostalCode Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WherePostalCode Constructor

[image]

Sitecore 6.4.1 API
WherePostalCode Constructor
WherePostalCode Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public WherePostalCode()
Visual Basic
Public Sub New
Visual C++
public:
WherePostalCode()

See Also

WherePostalCode Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WherePostalCode Methods

[image] [image]

Sitecore 6.4.1 API
WherePostalCode Methods
WherePostalCode Class See Also Send Feedback

The WherePostalCode type exposes the following members.

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Inherited from WhereIpBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorFilterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Inherited from WhereIpBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WherePostalCode Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WherePostalCode Properties

[image] [image]

Sitecore 6.4.1 API
WherePostalCode Properties
WherePostalCode Class See Also Send Feedback

The WherePostalCode type exposes the following members.

Properties

 | Name | Description
Protected property | ColumnName | Gets or sets the name of the column. (Inherited from WhereIpBase.)
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorFilterBase.)
Public property | Value | Gets or sets the value. (Inherited from WhereIpBase.)

See Also

WherePostalCode Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereProfileKey Class

[image]

Sitecore 6.4.1 API
WhereProfileKey Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class WhereProfileKey : OperatorFilterBase
Visual Basic
Public Class WhereProfileKey _
    Inherits OperatorFilterBase
Visual C++
public ref class WhereProfileKey : public OperatorFilterBase

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Filters..::..FilterBase
Sitecore.Analytics.Data.Filters.Filters..::..OperatorFilterBase
Sitecore.Analytics.Data.Filters.Filters..::..WhereProfileKey

See Also

WhereProfileKey Members
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereProfileKey Members

[image] [image]

Sitecore 6.4.1 API
WhereProfileKey Members
WhereProfileKey Class Constructors Methods Properties See Also Send Feedback

The WhereProfileKey type exposes the following members.

Constructors

 | Name | Description
Public method | WhereProfileKey | Initializes a new instance of the WhereProfileKey class

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Overrides FilterBase..::..ApplyFilter(SqlCommand).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorFilterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Overrides FilterBase..::..IsApplicable(SqlCommand).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorFilterBase.)
Public property | ProfileKeyId | Gets or sets the profile key id.
Public property | Value | Gets or sets the value.

See Also

WhereProfileKey Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereProfileKey Constructor

[image]

Sitecore 6.4.1 API
WhereProfileKey Constructor
WhereProfileKey Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public WhereProfileKey()
Visual Basic
Public Sub New
Visual C++
public:
WhereProfileKey()

See Also

WhereProfileKey Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereProfileKey Methods

[image] [image]

Sitecore 6.4.1 API
WhereProfileKey Methods
WhereProfileKey Class See Also Send Feedback

The WhereProfileKey type exposes the following members.

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Overrides FilterBase..::..ApplyFilter(SqlCommand).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorFilterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Overrides FilterBase..::..IsApplicable(SqlCommand).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WhereProfileKey Class
Sitecore.Analytics.Data.Filters.Filters Namespace


ApplyFilter Method

[image]

Sitecore 6.4.1 API
WhereProfileKey..::..ApplyFilter Method
WhereProfileKey Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void ApplyFilter(
    SqlCommand sqlCommand
)
Visual Basic
Public Overrides Sub ApplyFilter ( _
    sqlCommand As SqlCommand _
)
Visual C++
public:
virtual void ApplyFilter(
    SqlCommand^ sqlCommand
) override

Parameters

sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.

Implements

IFilter..::..ApplyFilter(SqlCommand)

See Also

WhereProfileKey Class
Sitecore.Analytics.Data.Filters.Filters Namespace


IsApplicable Method

[image]

Sitecore 6.4.1 API
WhereProfileKey..::..IsApplicable Method
WhereProfileKey Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override bool IsApplicable(
    SqlCommand sqlCommand
)
Visual Basic
Public Overrides Function IsApplicable ( _
    sqlCommand As SqlCommand _
) As Boolean
Visual C++
public:
virtual bool IsApplicable(
    SqlCommand^ sqlCommand
) override

Parameters

sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.

Return Value

true if the filter is applicable to the specified SQL Command; otherwise, false.

Implements

IFilter..::..IsApplicable(SqlCommand)

See Also

WhereProfileKey Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereProfileKey Properties

[image] [image]

Sitecore 6.4.1 API
WhereProfileKey Properties
WhereProfileKey Class See Also Send Feedback

The WhereProfileKey type exposes the following members.

Properties

 | Name | Description
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorFilterBase.)
Public property | ProfileKeyId | Gets or sets the profile key id.
Public property | Value | Gets or sets the value.

See Also

WhereProfileKey Class
Sitecore.Analytics.Data.Filters.Filters Namespace


ProfileKeyId Property

[image]

Sitecore 6.4.1 API
WhereProfileKey..::..ProfileKeyId Property
WhereProfileKey Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string ProfileKeyId { get; set; }
Visual Basic
Public Property ProfileKeyId As String
    Get
    Set
Visual C++
public:
property String^ ProfileKeyId {
    String^ get ();
    void set (String^ value);
}

Field Value

The profile key id.

See Also

WhereProfileKey Class
Sitecore.Analytics.Data.Filters.Filters Namespace


Value Property

[image]

Sitecore 6.4.1 API
WhereProfileKey..::..Value Property
WhereProfileKey Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Field Value

The value.

See Also

WhereProfileKey Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereReferringSite Class

[image]

Sitecore 6.4.1 API
WhereReferringSite Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class WhereReferringSite : FilterBase
Visual Basic
Public Class WhereReferringSite _
    Inherits FilterBase
Visual C++
public ref class WhereReferringSite : public FilterBase

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Filters..::..FilterBase
Sitecore.Analytics.Data.Filters.Filters..::..WhereReferringSite

See Also

WhereReferringSite Members
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereReferringSite Members

[image] [image]

Sitecore 6.4.1 API
WhereReferringSite Members
WhereReferringSite Class Constructors Methods Properties See Also Send Feedback

The WhereReferringSite type exposes the following members.

Constructors

 | Name | Description
Public method | WhereReferringSite | Initializes a new instance of the WhereReferringSite class

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Overrides FilterBase..::..ApplyFilter(SqlCommand).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Overrides FilterBase..::..IsApplicable(SqlCommand).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | ReferringSiteId | Gets or sets the referring site url

See Also

WhereReferringSite Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereReferringSite Constructor

[image]

Sitecore 6.4.1 API
WhereReferringSite Constructor
WhereReferringSite Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public WhereReferringSite()
Visual Basic
Public Sub New
Visual C++
public:
WhereReferringSite()

See Also

WhereReferringSite Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereReferringSite Methods

[image] [image]

Sitecore 6.4.1 API
WhereReferringSite Methods
WhereReferringSite Class See Also Send Feedback

The WhereReferringSite type exposes the following members.

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Overrides FilterBase..::..ApplyFilter(SqlCommand).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Overrides FilterBase..::..IsApplicable(SqlCommand).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WhereReferringSite Class
Sitecore.Analytics.Data.Filters.Filters Namespace


ApplyFilter Method

[image]

Sitecore 6.4.1 API
WhereReferringSite..::..ApplyFilter Method
WhereReferringSite Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void ApplyFilter(
    SqlCommand sqlCommand
)
Visual Basic
Public Overrides Sub ApplyFilter ( _
    sqlCommand As SqlCommand _
)
Visual C++
public:
virtual void ApplyFilter(
    SqlCommand^ sqlCommand
) override

Parameters

sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.

Implements

IFilter..::..ApplyFilter(SqlCommand)

See Also

WhereReferringSite Class
Sitecore.Analytics.Data.Filters.Filters Namespace


IsApplicable Method

[image]

Sitecore 6.4.1 API
WhereReferringSite..::..IsApplicable Method
WhereReferringSite Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override bool IsApplicable(
    SqlCommand sqlCommand
)
Visual Basic
Public Overrides Function IsApplicable ( _
    sqlCommand As SqlCommand _
) As Boolean
Visual C++
public:
virtual bool IsApplicable(
    SqlCommand^ sqlCommand
) override

Parameters

sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.

Return Value

true if the filter is applicable to the specified SQL Command; otherwise, false.

Implements

IFilter..::..IsApplicable(SqlCommand)

See Also

WhereReferringSite Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereReferringSite Properties

[image] [image]

Sitecore 6.4.1 API
WhereReferringSite Properties
WhereReferringSite Class See Also Send Feedback

The WhereReferringSite type exposes the following members.

Properties

 | Name | Description
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | ReferringSiteId | Gets or sets the referring site url

See Also

WhereReferringSite Class
Sitecore.Analytics.Data.Filters.Filters Namespace


ReferringSiteId Property

[image]

Sitecore 6.4.1 API
WhereReferringSite..::..ReferringSiteId Property
WhereReferringSite Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string ReferringSiteId { get; set; }
Visual Basic
Public Property ReferringSiteId As String
    Get
    Set
Visual C++
public:
property String^ ReferringSiteId {
    String^ get ();
    void set (String^ value);
}

Field Value

Referring site url

See Also

WhereReferringSite Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereRegion Class

[image]

Sitecore 6.4.1 API
WhereRegion Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class WhereRegion : WhereIpBase
Visual Basic
Public Class WhereRegion _
    Inherits WhereIpBase
Visual C++
public ref class WhereRegion : public WhereIpBase

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Filters..::..FilterBase
Sitecore.Analytics.Data.Filters.Filters..::..OperatorFilterBase
Sitecore.Analytics.Data.Filters.Filters..::..WhereIpBase
Sitecore.Analytics.Data.Filters.Filters..::..WhereRegion

See Also

WhereRegion Members
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereRegion Members

[image] [image]

Sitecore 6.4.1 API
WhereRegion Members
WhereRegion Class Constructors Methods Properties See Also Send Feedback

The WhereRegion type exposes the following members.

Constructors

 | Name | Description
Public method | WhereRegion | Initializes a new instance of the WhereRegion class.

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Inherited from WhereIpBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorFilterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Inherited from WhereIpBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Protected property | ColumnName | Gets or sets the name of the column. (Inherited from WhereIpBase.)
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorFilterBase.)
Public property | Value | Gets or sets the value. (Inherited from WhereIpBase.)

See Also

WhereRegion Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereRegion Constructor

[image]

Sitecore 6.4.1 API
WhereRegion Constructor
WhereRegion Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public WhereRegion()
Visual Basic
Public Sub New
Visual C++
public:
WhereRegion()

See Also

WhereRegion Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereRegion Methods

[image] [image]

Sitecore 6.4.1 API
WhereRegion Methods
WhereRegion Class See Also Send Feedback

The WhereRegion type exposes the following members.

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Inherited from WhereIpBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorFilterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Inherited from WhereIpBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WhereRegion Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereRegion Properties

[image] [image]

Sitecore 6.4.1 API
WhereRegion Properties
WhereRegion Class See Also Send Feedback

The WhereRegion type exposes the following members.

Properties

 | Name | Description
Protected property | ColumnName | Gets or sets the name of the column. (Inherited from WhereIpBase.)
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorFilterBase.)
Public property | Value | Gets or sets the value. (Inherited from WhereIpBase.)

See Also

WhereRegion Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereScreen Class

[image]

Sitecore 6.4.1 API
WhereScreen Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class WhereScreen : FilterBase
Visual Basic
Public Class WhereScreen _
    Inherits FilterBase
Visual C++
public ref class WhereScreen : public FilterBase

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Filters..::..FilterBase
Sitecore.Analytics.Data.Filters.Filters..::..WhereScreen

See Also

WhereScreen Members
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereScreen Members

[image] [image]

Sitecore 6.4.1 API
WhereScreen Members
WhereScreen Class Constructors Methods Properties See Also Send Feedback

The WhereScreen type exposes the following members.

Constructors

 | Name | Description
Public method | WhereScreen | Initializes a new instance of the WhereScreen class

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Overrides FilterBase..::..ApplyFilter(SqlCommand).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Overrides FilterBase..::..IsApplicable(SqlCommand).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | ScreenId | Gets or sets the screen id.

See Also

WhereScreen Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereScreen Constructor

[image]

Sitecore 6.4.1 API
WhereScreen Constructor
WhereScreen Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public WhereScreen()
Visual Basic
Public Sub New
Visual C++
public:
WhereScreen()

See Also

WhereScreen Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereScreen Methods

[image] [image]

Sitecore 6.4.1 API
WhereScreen Methods
WhereScreen Class See Also Send Feedback

The WhereScreen type exposes the following members.

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Overrides FilterBase..::..ApplyFilter(SqlCommand).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Overrides FilterBase..::..IsApplicable(SqlCommand).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WhereScreen Class
Sitecore.Analytics.Data.Filters.Filters Namespace


ApplyFilter Method

[image]

Sitecore 6.4.1 API
WhereScreen..::..ApplyFilter Method
WhereScreen Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void ApplyFilter(
    SqlCommand sqlCommand
)
Visual Basic
Public Overrides Sub ApplyFilter ( _
    sqlCommand As SqlCommand _
)
Visual C++
public:
virtual void ApplyFilter(
    SqlCommand^ sqlCommand
) override

Parameters

sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.

Implements

IFilter..::..ApplyFilter(SqlCommand)

See Also

WhereScreen Class
Sitecore.Analytics.Data.Filters.Filters Namespace


IsApplicable Method

[image]

Sitecore 6.4.1 API
WhereScreen..::..IsApplicable Method
WhereScreen Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override bool IsApplicable(
    SqlCommand sqlCommand
)
Visual Basic
Public Overrides Function IsApplicable ( _
    sqlCommand As SqlCommand _
) As Boolean
Visual C++
public:
virtual bool IsApplicable(
    SqlCommand^ sqlCommand
) override

Parameters

sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.

Return Value

true if the filter is applicable to the specified SQL Command; otherwise, false.

Implements

IFilter..::..IsApplicable(SqlCommand)

See Also

WhereScreen Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereScreen Properties

[image] [image]

Sitecore 6.4.1 API
WhereScreen Properties
WhereScreen Class See Also Send Feedback

The WhereScreen type exposes the following members.

Properties

 | Name | Description
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | ScreenId | Gets or sets the screen id.

See Also

WhereScreen Class
Sitecore.Analytics.Data.Filters.Filters Namespace


ScreenId Property

[image]

Sitecore 6.4.1 API
WhereScreen..::..ScreenId Property
WhereScreen Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string ScreenId { get; set; }
Visual Basic
Public Property ScreenId As String
    Get
    Set
Visual C++
public:
property String^ ScreenId {
    String^ get ();
    void set (String^ value);
}

Field Value

The screen id.

See Also

WhereScreen Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereSite Class

[image]

Sitecore 6.4.1 API
WhereSite Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class WhereSite : FilterBase
Visual Basic
Public Class WhereSite _
    Inherits FilterBase
Visual C++
public ref class WhereSite : public FilterBase

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Filters..::..FilterBase
Sitecore.Analytics.Data.Filters.Filters..::..WhereSite

See Also

WhereSite Members
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereSite Members

[image] [image]

Sitecore 6.4.1 API
WhereSite Members
WhereSite Class Constructors Methods Properties See Also Send Feedback

The WhereSite type exposes the following members.

Constructors

 | Name | Description
Public method | WhereSite | Initializes a new instance of the WhereSite class

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Overrides FilterBase..::..ApplyFilter(SqlCommand).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Overrides FilterBase..::..IsApplicable(SqlCommand).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | Site | Gets or sets the site.

See Also

WhereSite Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereSite Constructor

[image]

Sitecore 6.4.1 API
WhereSite Constructor
WhereSite Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public WhereSite()
Visual Basic
Public Sub New
Visual C++
public:
WhereSite()

See Also

WhereSite Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereSite Methods

[image] [image]

Sitecore 6.4.1 API
WhereSite Methods
WhereSite Class See Also Send Feedback

The WhereSite type exposes the following members.

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Overrides FilterBase..::..ApplyFilter(SqlCommand).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Overrides FilterBase..::..IsApplicable(SqlCommand).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WhereSite Class
Sitecore.Analytics.Data.Filters.Filters Namespace


ApplyFilter Method

[image]

Sitecore 6.4.1 API
WhereSite..::..ApplyFilter Method
WhereSite Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void ApplyFilter(
    SqlCommand sqlCommand
)
Visual Basic
Public Overrides Sub ApplyFilter ( _
    sqlCommand As SqlCommand _
)
Visual C++
public:
virtual void ApplyFilter(
    SqlCommand^ sqlCommand
) override

Parameters

sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.

Implements

IFilter..::..ApplyFilter(SqlCommand)

See Also

WhereSite Class
Sitecore.Analytics.Data.Filters.Filters Namespace


IsApplicable Method

[image]

Sitecore 6.4.1 API
WhereSite..::..IsApplicable Method
WhereSite Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override bool IsApplicable(
    SqlCommand sqlCommand
)
Visual Basic
Public Overrides Function IsApplicable ( _
    sqlCommand As SqlCommand _
) As Boolean
Visual C++
public:
virtual bool IsApplicable(
    SqlCommand^ sqlCommand
) override

Parameters

sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.

Return Value

true if the filter is applicable to the specified SQL Command; otherwise, false.

Implements

IFilter..::..IsApplicable(SqlCommand)

See Also

WhereSite Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereSite Properties

[image] [image]

Sitecore 6.4.1 API
WhereSite Properties
WhereSite Class See Also Send Feedback

The WhereSite type exposes the following members.

Properties

 | Name | Description
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | Site | Gets or sets the site.

See Also

WhereSite Class
Sitecore.Analytics.Data.Filters.Filters Namespace


Site Property

[image]

Sitecore 6.4.1 API
WhereSite..::..Site Property
WhereSite Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Site { get; set; }
Visual Basic
Public Property Site As String
    Get
    Set
Visual C++
public:
property String^ Site {
    String^ get ();
    void set (String^ value);
}

Field Value

The site.

See Also

WhereSite Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereVisitorIdentification Class

[image]

Sitecore 6.4.1 API
WhereVisitorIdentification Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class WhereVisitorIdentification : OperatorFilterBase
Visual Basic
Public Class WhereVisitorIdentification _
    Inherits OperatorFilterBase
Visual C++
public ref class WhereVisitorIdentification : public OperatorFilterBase

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Filters..::..FilterBase
Sitecore.Analytics.Data.Filters.Filters..::..OperatorFilterBase
Sitecore.Analytics.Data.Filters.Filters..::..WhereVisitorIdentification

See Also

WhereVisitorIdentification Members
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereVisitorIdentification Members

[image] [image]

Sitecore 6.4.1 API
WhereVisitorIdentification Members
WhereVisitorIdentification Class Constructors Methods Properties See Also Send Feedback

The WhereVisitorIdentification type exposes the following members.

Constructors

 | Name | Description
Public method | WhereVisitorIdentification | Initializes a new instance of the WhereVisitorIdentification class

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Overrides FilterBase..::..ApplyFilter(SqlCommand).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorFilterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Overrides FilterBase..::..IsApplicable(SqlCommand).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | Identification | Gets or sets the identification.
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorFilterBase.)

See Also

WhereVisitorIdentification Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereVisitorIdentification Constructor

[image]

Sitecore 6.4.1 API
WhereVisitorIdentification Constructor
WhereVisitorIdentification Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public WhereVisitorIdentification()
Visual Basic
Public Sub New
Visual C++
public:
WhereVisitorIdentification()

See Also

WhereVisitorIdentification Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereVisitorIdentification Methods

[image] [image]

Sitecore 6.4.1 API
WhereVisitorIdentification Methods
WhereVisitorIdentification Class See Also Send Feedback

The WhereVisitorIdentification type exposes the following members.

Methods

 | Name | Description
Public method | ApplyFilter | Executes the specified rule context. (Overrides FilterBase..::..ApplyFilter(SqlCommand).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorFilterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicable | Determines whether the filter is applicable to the specified SQL Command. (Overrides FilterBase..::..IsApplicable(SqlCommand).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WhereVisitorIdentification Class
Sitecore.Analytics.Data.Filters.Filters Namespace


ApplyFilter Method

[image]

Sitecore 6.4.1 API
WhereVisitorIdentification..::..ApplyFilter Method
WhereVisitorIdentification Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void ApplyFilter(
    SqlCommand sqlCommand
)
Visual Basic
Public Overrides Sub ApplyFilter ( _
    sqlCommand As SqlCommand _
)
Visual C++
public:
virtual void ApplyFilter(
    SqlCommand^ sqlCommand
) override

Parameters

sqlCommand
Type: Sitecore.Analytics.Data.Filters..::..SqlCommand
The SQL command.

Implements

IFilter..::..ApplyFilter(SqlCommand)

See Also

WhereVisitorIdentification Class
Sitecore.Analytics.Data.Filters.Filters Namespace


WhereVisitorIdentification Properties

[image] [image]

Sitecore 6.4.1 API
WhereVisitorIdentification Properties
WhereVisitorIdentification Class See Also Send Feedback

The WhereVisitorIdentification type exposes the following members.

Properties

 | Name | Description
Public property | Except | Gets or sets a value indicating whether this FilterBase is a "not" condition. (Inherited from FilterBase.)
Public property | Identification | Gets or sets the identification.
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorFilterBase.)

See Also

WhereVisitorIdentification Class
Sitecore.Analytics.Data.Filters.Filters Namespace


Identification Property

[image]

Sitecore 6.4.1 API
WhereVisitorIdentification..::..Identification Property
WhereVisitorIdentification Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Filters
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int Identification { get; set; }
Visual Basic
Public Property Identification As Integer
    Get
    Set
Visual C++
public:
property int Identification {
    int get ();
    void set (int value);
}

Field Value

The identification.

See Also

WhereVisitorIdentification Class
Sitecore.Analytics.Data.Filters.Filters Namespace


Sitecore.Analytics.Data.Filters.Macros Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Analytics.Data.Filters.Macros Namespace
Send Feedback

Classes

 | Class | Description
Public class | BrowserMacro | Defines the when browser class.
Public class | CampaignMacro | Defines the tree macro class.
Public class | FilterMacro | Defines the when browser class.
Public class | ItemMacro | Defines the tree macro class.
Public class | LanguageMacro | Defines the tree macro class.
Public class | OperatingSystemMacro | Defines the when browser class.
Public class | OperatorMacro | Defines the tree macro class.
Public class | ProfileKeyMacro | Defines the tree macro class.
Public class | ReferringSiteMacro | Defines the screen macro class.
Public class | ScreenMacro | Defines the screen macro class.

Interfaces

 | Interface | Description
Public interface | IFilterMacro | The filter macro.


BrowserMacro Class

[image]

Sitecore 6.4.1 API
BrowserMacro Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class BrowserMacro : FilterMacro
Visual Basic
Public Class BrowserMacro _
    Inherits FilterMacro
Visual C++
public ref class BrowserMacro : public FilterMacro

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Macros..::..FilterMacro
Sitecore.Analytics.Data.Filters.Macros..::..BrowserMacro

See Also

BrowserMacro Members
Sitecore.Analytics.Data.Filters.Macros Namespace


BrowserMacro Members

[image] [image]

Sitecore 6.4.1 API
BrowserMacro Members
BrowserMacro Class Constructors Methods See Also Send Feedback

The BrowserMacro type exposes the following members.

Constructors

 | Name | Description
Public method | BrowserMacro | Initializes a new instance of the BrowserMacro class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the specified element. (Overrides FilterMacro..::..Execute(XElement, String, UrlString, String).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDisplayValue | Gets the display value. (Overrides FilterMacro..::..GetDisplayValue(String).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BrowserMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


BrowserMacro Constructor

[image]

Sitecore 6.4.1 API
BrowserMacro Constructor
BrowserMacro Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public BrowserMacro()
Visual Basic
Public Sub New
Visual C++
public:
BrowserMacro()

See Also

BrowserMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


BrowserMacro Methods

[image] [image]

Sitecore 6.4.1 API
BrowserMacro Methods
BrowserMacro Class See Also Send Feedback

The BrowserMacro type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the specified element. (Overrides FilterMacro..::..Execute(XElement, String, UrlString, String).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDisplayValue | Gets the display value. (Overrides FilterMacro..::..GetDisplayValue(String).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BrowserMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


Execute Method

[image]

Sitecore 6.4.1 API
BrowserMacro..::..Execute Method
BrowserMacro Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void Execute(
    XElement element,
    string name,
    UrlString parameters,
    string value
)
Visual Basic
Public Overrides Sub Execute ( _
    element As XElement, _
    name As String, _
    parameters As UrlString, _
    value As String _
)
Visual C++
public:
virtual void Execute(
    XElement^ element,
    String^ name,
    UrlString^ parameters,
    String^ value
) override

Parameters

element
Type: System.Xml.Linq..::..XElement
The element.
name
Type: System..::..String
The name of the macro.
parameters
Type: Sitecore.Text..::..UrlString
The parameters.
value
Type: System..::..String
The value.

Implements

IFilterMacro..::..Execute(XElement, String, UrlString, String)

See Also

BrowserMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


GetDisplayValue Method

[image]

Sitecore 6.4.1 API
BrowserMacro..::..GetDisplayValue Method
BrowserMacro Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override string GetDisplayValue(
    string value
)
Visual Basic
Public Overrides Function GetDisplayValue ( _
    value As String _
) As String
Visual C++
public:
virtual String^ GetDisplayValue(
    String^ value
) override

Parameters

value
Type: System..::..String
The value.

Return Value

Returns the string.

Implements

IFilterMacro..::..GetDisplayValue(String)

See Also

BrowserMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


CampaignMacro Class

[image]

Sitecore 6.4.1 API
CampaignMacro Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class CampaignMacro : FilterMacro
Visual Basic
Public Class CampaignMacro _
    Inherits FilterMacro
Visual C++
public ref class CampaignMacro : public FilterMacro

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Macros..::..FilterMacro
Sitecore.Analytics.Data.Filters.Macros..::..CampaignMacro

See Also

CampaignMacro Members
Sitecore.Analytics.Data.Filters.Macros Namespace


CampaignMacro Members

[image] [image]

Sitecore 6.4.1 API
CampaignMacro Members
CampaignMacro Class Constructors Methods See Also Send Feedback

The CampaignMacro type exposes the following members.

Constructors

 | Name | Description
Public method | CampaignMacro | Initializes a new instance of the CampaignMacro class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the specified macro. (Overrides FilterMacro..::..Execute(XElement, String, UrlString, String).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDisplayValue | Gets the display value. (Inherited from FilterMacro.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CampaignMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


CampaignMacro Constructor

[image]

Sitecore 6.4.1 API
CampaignMacro Constructor
CampaignMacro Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public CampaignMacro()
Visual Basic
Public Sub New
Visual C++
public:
CampaignMacro()

See Also

CampaignMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


CampaignMacro Methods

[image] [image]

Sitecore 6.4.1 API
CampaignMacro Methods
CampaignMacro Class See Also Send Feedback

The CampaignMacro type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the specified macro. (Overrides FilterMacro..::..Execute(XElement, String, UrlString, String).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDisplayValue | Gets the display value. (Inherited from FilterMacro.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CampaignMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


Execute Method

[image]

Sitecore 6.4.1 API
CampaignMacro..::..Execute Method
CampaignMacro Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void Execute(
    XElement element,
    string name,
    UrlString parameters,
    string value
)
Visual Basic
Public Overrides Sub Execute ( _
    element As XElement, _
    name As String, _
    parameters As UrlString, _
    value As String _
)
Visual C++
public:
virtual void Execute(
    XElement^ element,
    String^ name,
    UrlString^ parameters,
    String^ value
) override

Parameters

element
Type: System.Xml.Linq..::..XElement
The element.
name
Type: System..::..String
The name of the field.
parameters
Type: Sitecore.Text..::..UrlString
The parameters.
value
Type: System..::..String
The value.

Implements

IFilterMacro..::..Execute(XElement, String, UrlString, String)

See Also

CampaignMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


FilterMacro Class

[image]

Sitecore 6.4.1 API
FilterMacro Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract class FilterMacro : IFilterMacro
Visual Basic
Public MustInherit Class FilterMacro _
    Implements IFilterMacro
Visual C++
public ref class FilterMacro abstract : IFilterMacro

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Macros..::..FilterMacro
Sitecore.Analytics.Data.Filters.Macros..::..BrowserMacro
Sitecore.Analytics.Data.Filters.Macros..::..CampaignMacro
Sitecore.Analytics.Data.Filters.Macros..::..ItemMacro
Sitecore.Analytics.Data.Filters.Macros..::..LanguageMacro
Sitecore.Analytics.Data.Filters.Macros..::..OperatingSystemMacro
Sitecore.Analytics.Data.Filters.Macros..::..OperatorMacro
Sitecore.Analytics.Data.Filters.Macros..::..ProfileKeyMacro
Sitecore.Analytics.Data.Filters.Macros..::..ReferringSiteMacro
Sitecore.Analytics.Data.Filters.Macros..::..ScreenMacro

See Also

FilterMacro Members
Sitecore.Analytics.Data.Filters.Macros Namespace


FilterMacro Members

[image] [image]

Sitecore 6.4.1 API
FilterMacro Members
FilterMacro Class Constructors Methods See Also Send Feedback

The FilterMacro type exposes the following members.

Constructors

 | Name | Description
Protected method | FilterMacro | Initializes a new instance of the FilterMacro class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the specified element.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetConnectionString | Gets the connection string.
Public method | GetDisplayValue | Gets the display value.
 | GetFilterMacro | Gets the filter macro.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SelectDatabaseRows | Selects the database rows.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


FilterMacro Constructor

[image]

Sitecore 6.4.1 API
FilterMacro Constructor
FilterMacro Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected FilterMacro()
Visual Basic
Protected Sub New
Visual C++
protected:
FilterMacro()

See Also

FilterMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


Execute Method

[image]

Sitecore 6.4.1 API
FilterMacro..::..Execute Method
FilterMacro Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract void Execute(
    XElement element,
    string name,
    UrlString parameters,
    string value
)
Visual Basic
Public MustOverride Sub Execute ( _
    element As XElement, _
    name As String, _
    parameters As UrlString, _
    value As String _
)
Visual C++
public:
virtual void Execute(
    XElement^ element,
    String^ name,
    UrlString^ parameters,
    String^ value
) abstract

Parameters

element
Type: System.Xml.Linq..::..XElement
The element.
name
Type: System..::..String
The name of the macro.
parameters
Type: Sitecore.Text..::..UrlString
The parameters.
value
Type: System..::..String
The value.

Implements

IFilterMacro..::..Execute(XElement, String, UrlString, String)

See Also

FilterMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


GetConnectionString Method

[image]

Sitecore 6.4.1 API
FilterMacro..::..GetConnectionString Method
FilterMacro Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected static string GetConnectionString()
Visual Basic
Protected Shared Function GetConnectionString As String
Visual C++
protected:
static String^ GetConnectionString()

Return Value

Returns the string.

See Also

FilterMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


GetDisplayValue Method

[image]

Sitecore 6.4.1 API
FilterMacro..::..GetDisplayValue Method
FilterMacro Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual string GetDisplayValue(
    string value
)
Visual Basic
Public Overridable Function GetDisplayValue ( _
    value As String _
) As String
Visual C++
public:
virtual String^ GetDisplayValue(
    String^ value
)

Parameters

value
Type: System..::..String
The value.

Return Value

Returns the string.

Implements

IFilterMacro..::..GetDisplayValue(String)

See Also

FilterMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


GetFilterMacro Method

[image]

Sitecore 6.4.1 API
FilterMacro..::..GetFilterMacro Method
FilterMacro Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static IFilterMacro GetFilterMacro(
    string control
)
Visual Basic
Public Shared Function GetFilterMacro ( _
    control As String _
) As IFilterMacro
Visual C++
public:
static IFilterMacro^ GetFilterMacro(
    String^ control
)

Parameters

control
Type: System..::..String
The control.

Return Value

Returns the I filter macro.

See Also

FilterMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


SelectDatabaseRows Method

[image]

Sitecore 6.4.1 API
FilterMacro..::..SelectDatabaseRows Method
FilterMacro Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected static void SelectDatabaseRows(
    string sql,
    string value
)
Visual Basic
Protected Shared Sub SelectDatabaseRows ( _
    sql As String, _
    value As String _
)
Visual C++
protected:
static void SelectDatabaseRows(
    String^ sql,
    String^ value
)

Parameters

sql
Type: System..::..String
The SQL statement.
value
Type: System..::..String
The value.

See Also

FilterMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


IFilterMacro Interface

[image]

Sitecore 6.4.1 API
IFilterMacro Interface
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public interface IFilterMacro
Visual Basic
Public Interface IFilterMacro
Visual C++
public interface class IFilterMacro

See Also

IFilterMacro Members
Sitecore.Analytics.Data.Filters.Macros Namespace


IFilterMacro Members

[image] [image]

Sitecore 6.4.1 API
IFilterMacro Members
IFilterMacro Interface Methods See Also Send Feedback

The IFilterMacro type exposes the following members.

Methods

 | Name | Description
Public method | Execute | Executes the specified element.
Public method | GetDisplayValue | Gets the display value.

See Also

IFilterMacro Interface
Sitecore.Analytics.Data.Filters.Macros Namespace


Execute Method

[image]

Sitecore 6.4.1 API
IFilterMacro..::..Execute Method
IFilterMacro Interface See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
void Execute(
    XElement element,
    string name,
    UrlString parameters,
    string value
)
Visual Basic
Sub Execute ( _
    element As XElement, _
    name As String, _
    parameters As UrlString, _
    value As String _
)
Visual C++
void Execute(
    XElement^ element,
    String^ name,
    UrlString^ parameters,
    String^ value
)

Parameters

element
Type: System.Xml.Linq..::..XElement
The element.
name
Type: System..::..String
The name of the macro.
parameters
Type: Sitecore.Text..::..UrlString
The parameters.
value
Type: System..::..String
The value.

See Also

IFilterMacro Interface
Sitecore.Analytics.Data.Filters.Macros Namespace


GetDisplayValue Method

[image]

Sitecore 6.4.1 API
IFilterMacro..::..GetDisplayValue Method
IFilterMacro Interface See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
string GetDisplayValue(
    string value
)
Visual Basic
Function GetDisplayValue ( _
    value As String _
) As String
Visual C++
String^ GetDisplayValue(
    String^ value
)

Parameters

value
Type: System..::..String
The value.

Return Value

Returns the string.

See Also

IFilterMacro Interface
Sitecore.Analytics.Data.Filters.Macros Namespace


ItemMacro Class

[image]

Sitecore 6.4.1 API
ItemMacro Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class ItemMacro : FilterMacro
Visual Basic
Public Class ItemMacro _
    Inherits FilterMacro
Visual C++
public ref class ItemMacro : public FilterMacro

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Macros..::..FilterMacro
Sitecore.Analytics.Data.Filters.Macros..::..ItemMacro

See Also

ItemMacro Members
Sitecore.Analytics.Data.Filters.Macros Namespace


ItemMacro Members

[image] [image]

Sitecore 6.4.1 API
ItemMacro Members
ItemMacro Class Constructors Methods See Also Send Feedback

The ItemMacro type exposes the following members.

Constructors

 | Name | Description
Public method | ItemMacro | Initializes a new instance of the ItemMacro class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the specified macro. (Overrides FilterMacro..::..Execute(XElement, String, UrlString, String).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDisplayValue | Gets the display value. (Inherited from FilterMacro.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


ItemMacro Constructor

[image]

Sitecore 6.4.1 API
ItemMacro Constructor
ItemMacro Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public ItemMacro()
Visual Basic
Public Sub New
Visual C++
public:
ItemMacro()

See Also

ItemMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


ItemMacro Methods

[image] [image]

Sitecore 6.4.1 API
ItemMacro Methods
ItemMacro Class See Also Send Feedback

The ItemMacro type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the specified macro. (Overrides FilterMacro..::..Execute(XElement, String, UrlString, String).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDisplayValue | Gets the display value. (Inherited from FilterMacro.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


Execute Method

[image]

Sitecore 6.4.1 API
ItemMacro..::..Execute Method
ItemMacro Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void Execute(
    XElement element,
    string name,
    UrlString parameters,
    string value
)
Visual Basic
Public Overrides Sub Execute ( _
    element As XElement, _
    name As String, _
    parameters As UrlString, _
    value As String _
)
Visual C++
public:
virtual void Execute(
    XElement^ element,
    String^ name,
    UrlString^ parameters,
    String^ value
) override

Parameters

element
Type: System.Xml.Linq..::..XElement
The element.
name
Type: System..::..String
The name of the field.
parameters
Type: Sitecore.Text..::..UrlString
The parameters.
value
Type: System..::..String
The value.

Implements

IFilterMacro..::..Execute(XElement, String, UrlString, String)

See Also

ItemMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


LanguageMacro Class

[image]

Sitecore 6.4.1 API
LanguageMacro Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class LanguageMacro : FilterMacro
Visual Basic
Public Class LanguageMacro _
    Inherits FilterMacro
Visual C++
public ref class LanguageMacro : public FilterMacro

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Macros..::..FilterMacro
Sitecore.Analytics.Data.Filters.Macros..::..LanguageMacro

See Also

LanguageMacro Members
Sitecore.Analytics.Data.Filters.Macros Namespace


LanguageMacro Members

[image] [image]

Sitecore 6.4.1 API
LanguageMacro Members
LanguageMacro Class Constructors Methods See Also Send Feedback

The LanguageMacro type exposes the following members.

Constructors

 | Name | Description
Public method | LanguageMacro | Initializes a new instance of the LanguageMacro class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the specified macro. (Overrides FilterMacro..::..Execute(XElement, String, UrlString, String).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDisplayValue | Gets the display value. (Inherited from FilterMacro.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LanguageMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


LanguageMacro Constructor

[image]

Sitecore 6.4.1 API
LanguageMacro Constructor
LanguageMacro Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public LanguageMacro()
Visual Basic
Public Sub New
Visual C++
public:
LanguageMacro()

See Also

LanguageMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


LanguageMacro Methods

[image] [image]

Sitecore 6.4.1 API
LanguageMacro Methods
LanguageMacro Class See Also Send Feedback

The LanguageMacro type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the specified macro. (Overrides FilterMacro..::..Execute(XElement, String, UrlString, String).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDisplayValue | Gets the display value. (Inherited from FilterMacro.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LanguageMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


Execute Method

[image]

Sitecore 6.4.1 API
LanguageMacro..::..Execute Method
LanguageMacro Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void Execute(
    XElement element,
    string name,
    UrlString parameters,
    string value
)
Visual Basic
Public Overrides Sub Execute ( _
    element As XElement, _
    name As String, _
    parameters As UrlString, _
    value As String _
)
Visual C++
public:
virtual void Execute(
    XElement^ element,
    String^ name,
    UrlString^ parameters,
    String^ value
) override

Parameters

element
Type: System.Xml.Linq..::..XElement
The element.
name
Type: System..::..String
The name of the field.
parameters
Type: Sitecore.Text..::..UrlString
The parameters.
value
Type: System..::..String
The value.

Implements

IFilterMacro..::..Execute(XElement, String, UrlString, String)

See Also

LanguageMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


OperatingSystemMacro Class

[image]

Sitecore 6.4.1 API
OperatingSystemMacro Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class OperatingSystemMacro : FilterMacro
Visual Basic
Public Class OperatingSystemMacro _
    Inherits FilterMacro
Visual C++
public ref class OperatingSystemMacro : public FilterMacro

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Macros..::..FilterMacro
Sitecore.Analytics.Data.Filters.Macros..::..OperatingSystemMacro

See Also

OperatingSystemMacro Members
Sitecore.Analytics.Data.Filters.Macros Namespace


OperatingSystemMacro Constructor

[image]

Sitecore 6.4.1 API
OperatingSystemMacro Constructor
OperatingSystemMacro Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public OperatingSystemMacro()
Visual Basic
Public Sub New
Visual C++
public:
OperatingSystemMacro()

See Also

OperatingSystemMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


OperatingSystemMacro Methods

[image] [image]

Sitecore 6.4.1 API
OperatingSystemMacro Methods
OperatingSystemMacro Class See Also Send Feedback

The OperatingSystemMacro type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the specified element. (Overrides FilterMacro..::..Execute(XElement, String, UrlString, String).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDisplayValue | Gets the display value. (Overrides FilterMacro..::..GetDisplayValue(String).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OperatingSystemMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


Execute Method

[image]

Sitecore 6.4.1 API
OperatingSystemMacro..::..Execute Method
OperatingSystemMacro Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void Execute(
    XElement element,
    string name,
    UrlString parameters,
    string value
)
Visual Basic
Public Overrides Sub Execute ( _
    element As XElement, _
    name As String, _
    parameters As UrlString, _
    value As String _
)
Visual C++
public:
virtual void Execute(
    XElement^ element,
    String^ name,
    UrlString^ parameters,
    String^ value
) override

Parameters

element
Type: System.Xml.Linq..::..XElement
The element.
name
Type: System..::..String
The name of the macro.
parameters
Type: Sitecore.Text..::..UrlString
The parameters.
value
Type: System..::..String
The value.

Implements

IFilterMacro..::..Execute(XElement, String, UrlString, String)

See Also

OperatingSystemMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


GetDisplayValue Method

[image]

Sitecore 6.4.1 API
OperatingSystemMacro..::..GetDisplayValue Method
OperatingSystemMacro Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override string GetDisplayValue(
    string value
)
Visual Basic
Public Overrides Function GetDisplayValue ( _
    value As String _
) As String
Visual C++
public:
virtual String^ GetDisplayValue(
    String^ value
) override

Parameters

value
Type: System..::..String
The value.

Return Value

Returns the string.

Implements

IFilterMacro..::..GetDisplayValue(String)

See Also

OperatingSystemMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


OperatorMacro Members

[image] [image]

Sitecore 6.4.1 API
OperatorMacro Members
OperatorMacro Class Constructors Methods See Also Send Feedback

The OperatorMacro type exposes the following members.

Constructors

 | Name | Description
Public method | OperatorMacro | Initializes a new instance of the OperatorMacro class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the specified macro. (Overrides FilterMacro..::..Execute(XElement, String, UrlString, String).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDisplayValue | Gets the display value. (Inherited from FilterMacro.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OperatorMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


OperatorMacro Constructor

[image]

Sitecore 6.4.1 API
OperatorMacro Constructor
OperatorMacro Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public OperatorMacro()
Visual Basic
Public Sub New
Visual C++
public:
OperatorMacro()

See Also

OperatorMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


OperatorMacro Methods

[image] [image]

Sitecore 6.4.1 API
OperatorMacro Methods
OperatorMacro Class See Also Send Feedback

The OperatorMacro type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the specified macro. (Overrides FilterMacro..::..Execute(XElement, String, UrlString, String).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDisplayValue | Gets the display value. (Inherited from FilterMacro.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OperatorMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


Execute Method

[image]

Sitecore 6.4.1 API
OperatorMacro..::..Execute Method
OperatorMacro Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void Execute(
    XElement element,
    string name,
    UrlString parameters,
    string value
)
Visual Basic
Public Overrides Sub Execute ( _
    element As XElement, _
    name As String, _
    parameters As UrlString, _
    value As String _
)
Visual C++
public:
virtual void Execute(
    XElement^ element,
    String^ name,
    UrlString^ parameters,
    String^ value
) override

Parameters

element
Type: System.Xml.Linq..::..XElement
The element.
name
Type: System..::..String
The name of the field.
parameters
Type: Sitecore.Text..::..UrlString
The parameters.
value
Type: System..::..String
The value.

Implements

IFilterMacro..::..Execute(XElement, String, UrlString, String)

See Also

OperatorMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


ProfileKeyMacro Class

[image]

Sitecore 6.4.1 API
ProfileKeyMacro Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class ProfileKeyMacro : FilterMacro
Visual Basic
Public Class ProfileKeyMacro _
    Inherits FilterMacro
Visual C++
public ref class ProfileKeyMacro : public FilterMacro

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Macros..::..FilterMacro
Sitecore.Analytics.Data.Filters.Macros..::..ProfileKeyMacro

See Also

ProfileKeyMacro Members
Sitecore.Analytics.Data.Filters.Macros Namespace


ProfileKeyMacro Members

[image] [image]

Sitecore 6.4.1 API
ProfileKeyMacro Members
ProfileKeyMacro Class Constructors Methods See Also Send Feedback

The ProfileKeyMacro type exposes the following members.

Constructors

 | Name | Description
Public method | ProfileKeyMacro | Initializes a new instance of the ProfileKeyMacro class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the specified macro. (Overrides FilterMacro..::..Execute(XElement, String, UrlString, String).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDisplayValue | Gets the display value. (Inherited from FilterMacro.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProfileKeyMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


ProfileKeyMacro Constructor

[image]

Sitecore 6.4.1 API
ProfileKeyMacro Constructor
ProfileKeyMacro Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public ProfileKeyMacro()
Visual Basic
Public Sub New
Visual C++
public:
ProfileKeyMacro()

See Also

ProfileKeyMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


ProfileKeyMacro Methods

[image] [image]

Sitecore 6.4.1 API
ProfileKeyMacro Methods
ProfileKeyMacro Class See Also Send Feedback

The ProfileKeyMacro type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the specified macro. (Overrides FilterMacro..::..Execute(XElement, String, UrlString, String).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDisplayValue | Gets the display value. (Inherited from FilterMacro.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProfileKeyMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


Execute Method

[image]

Sitecore 6.4.1 API
ProfileKeyMacro..::..Execute Method
ProfileKeyMacro Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void Execute(
    XElement element,
    string name,
    UrlString parameters,
    string value
)
Visual Basic
Public Overrides Sub Execute ( _
    element As XElement, _
    name As String, _
    parameters As UrlString, _
    value As String _
)
Visual C++
public:
virtual void Execute(
    XElement^ element,
    String^ name,
    UrlString^ parameters,
    String^ value
) override

Parameters

element
Type: System.Xml.Linq..::..XElement
The element.
name
Type: System..::..String
The name of the field.
parameters
Type: Sitecore.Text..::..UrlString
The parameters.
value
Type: System..::..String
The value.

Implements

IFilterMacro..::..Execute(XElement, String, UrlString, String)

See Also

ProfileKeyMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


ReferringSiteMacro Class

[image]

Sitecore 6.4.1 API
ReferringSiteMacro Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class ReferringSiteMacro : FilterMacro
Visual Basic
Public Class ReferringSiteMacro _
    Inherits FilterMacro
Visual C++
public ref class ReferringSiteMacro : public FilterMacro

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Macros..::..FilterMacro
Sitecore.Analytics.Data.Filters.Macros..::..ReferringSiteMacro

See Also

ReferringSiteMacro Members
Sitecore.Analytics.Data.Filters.Macros Namespace


ReferringSiteMacro Members

[image] [image]

Sitecore 6.4.1 API
ReferringSiteMacro Members
ReferringSiteMacro Class Constructors Methods See Also Send Feedback

The ReferringSiteMacro type exposes the following members.

Constructors

 | Name | Description
Public method | ReferringSiteMacro | Initializes a new instance of the ReferringSiteMacro class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the specified element. (Overrides FilterMacro..::..Execute(XElement, String, UrlString, String).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDisplayValue | Gets the display value. (Overrides FilterMacro..::..GetDisplayValue(String).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReferringSiteMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


ReferringSiteMacro Constructor

[image]

Sitecore 6.4.1 API
ReferringSiteMacro Constructor
ReferringSiteMacro Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public ReferringSiteMacro()
Visual Basic
Public Sub New
Visual C++
public:
ReferringSiteMacro()

See Also

ReferringSiteMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


ReferringSiteMacro Methods

[image] [image]

Sitecore 6.4.1 API
ReferringSiteMacro Methods
ReferringSiteMacro Class See Also Send Feedback

The ReferringSiteMacro type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the specified element. (Overrides FilterMacro..::..Execute(XElement, String, UrlString, String).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDisplayValue | Gets the display value. (Overrides FilterMacro..::..GetDisplayValue(String).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReferringSiteMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


Execute Method

[image]

Sitecore 6.4.1 API
ReferringSiteMacro..::..Execute Method
ReferringSiteMacro Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void Execute(
    XElement element,
    string name,
    UrlString parameters,
    string value
)
Visual Basic
Public Overrides Sub Execute ( _
    element As XElement, _
    name As String, _
    parameters As UrlString, _
    value As String _
)
Visual C++
public:
virtual void Execute(
    XElement^ element,
    String^ name,
    UrlString^ parameters,
    String^ value
) override

Parameters

element
Type: System.Xml.Linq..::..XElement
The element.
name
Type: System..::..String
The name of the macro.
parameters
Type: Sitecore.Text..::..UrlString
The parameters.
value
Type: System..::..String
The value.

Implements

IFilterMacro..::..Execute(XElement, String, UrlString, String)

See Also

ReferringSiteMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


GetDisplayValue Method

[image]

Sitecore 6.4.1 API
ReferringSiteMacro..::..GetDisplayValue Method
ReferringSiteMacro Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override string GetDisplayValue(
    string value
)
Visual Basic
Public Overrides Function GetDisplayValue ( _
    value As String _
) As String
Visual C++
public:
virtual String^ GetDisplayValue(
    String^ value
) override

Parameters

value
Type: System..::..String
The value.

Return Value

Returns the string.

Implements

IFilterMacro..::..GetDisplayValue(String)

See Also

ReferringSiteMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


ScreenMacro Class

[image]

Sitecore 6.4.1 API
ScreenMacro Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class ScreenMacro : FilterMacro
Visual Basic
Public Class ScreenMacro _
    Inherits FilterMacro
Visual C++
public ref class ScreenMacro : public FilterMacro

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Filters.Macros..::..FilterMacro
Sitecore.Analytics.Data.Filters.Macros..::..ScreenMacro

See Also

ScreenMacro Members
Sitecore.Analytics.Data.Filters.Macros Namespace


ScreenMacro Members

[image] [image]

Sitecore 6.4.1 API
ScreenMacro Members
ScreenMacro Class Constructors Methods See Also Send Feedback

The ScreenMacro type exposes the following members.

Constructors

 | Name | Description
Public method | ScreenMacro | Initializes a new instance of the ScreenMacro class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the specified element. (Overrides FilterMacro..::..Execute(XElement, String, UrlString, String).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDisplayValue | Gets the display value. (Overrides FilterMacro..::..GetDisplayValue(String).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScreenMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


ScreenMacro Constructor

[image]

Sitecore 6.4.1 API
ScreenMacro Constructor
ScreenMacro Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public ScreenMacro()
Visual Basic
Public Sub New
Visual C++
public:
ScreenMacro()

See Also

ScreenMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


ScreenMacro Methods

[image] [image]

Sitecore 6.4.1 API
ScreenMacro Methods
ScreenMacro Class See Also Send Feedback

The ScreenMacro type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the specified element. (Overrides FilterMacro..::..Execute(XElement, String, UrlString, String).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDisplayValue | Gets the display value. (Overrides FilterMacro..::..GetDisplayValue(String).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScreenMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


Execute Method

[image]

Sitecore 6.4.1 API
ScreenMacro..::..Execute Method
ScreenMacro Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void Execute(
    XElement element,
    string name,
    UrlString parameters,
    string value
)
Visual Basic
Public Overrides Sub Execute ( _
    element As XElement, _
    name As String, _
    parameters As UrlString, _
    value As String _
)
Visual C++
public:
virtual void Execute(
    XElement^ element,
    String^ name,
    UrlString^ parameters,
    String^ value
) override

Parameters

element
Type: System.Xml.Linq..::..XElement
The element.
name
Type: System..::..String
The name of the macro.
parameters
Type: Sitecore.Text..::..UrlString
The parameters.
value
Type: System..::..String
The value.

Implements

IFilterMacro..::..Execute(XElement, String, UrlString, String)

See Also

ScreenMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


GetDisplayValue Method

[image]

Sitecore 6.4.1 API
ScreenMacro..::..GetDisplayValue Method
ScreenMacro Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Filters.Macros
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override string GetDisplayValue(
    string value
)
Visual Basic
Public Overrides Function GetDisplayValue ( _
    value As String _
) As String
Visual C++
public:
virtual String^ GetDisplayValue(
    String^ value
) override

Parameters

value
Type: System..::..String
The value.

Return Value

Returns the string.

Implements

IFilterMacro..::..GetDisplayValue(String)

See Also

ScreenMacro Class
Sitecore.Analytics.Data.Filters.Macros Namespace


Sitecore.Analytics.Data.Items Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Analytics.Data.Items Namespace
Send Feedback

Classes

 | Class | Description
Public class | ItemEventHandler | Represents an item event handler.


ItemEventHandler Class

[image]

Sitecore 6.4.1 API
ItemEventHandler Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Items
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class ItemEventHandler
Visual Basic
Public Class ItemEventHandler
Visual C++
public ref class ItemEventHandler

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Data.Items..::..ItemEventHandler

See Also

ItemEventHandler Members
Sitecore.Analytics.Data.Items Namespace


ItemEventHandler Constructor

[image]

Sitecore 6.4.1 API
ItemEventHandler Constructor
ItemEventHandler Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Items
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public ItemEventHandler()
Visual Basic
Public Sub New
Visual C++
public:
ItemEventHandler()

See Also

ItemEventHandler Class
Sitecore.Analytics.Data.Items Namespace


ItemEventHandler Methods

[image] [image]

Sitecore 6.4.1 API
ItemEventHandler Methods
ItemEventHandler Class See Also Send Feedback

The ItemEventHandler type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnItemCopied | Called when the item has copied.
Protected method | OnItemDeleted | Called when the item has deleted.
Protected method | OnItemSaved | Called when the item has saved.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemEventHandler Class
Sitecore.Analytics.Data.Items Namespace


OnItemCopied Method

[image]

Sitecore 6.4.1 API
ItemEventHandler..::..OnItemCopied Method
ItemEventHandler Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Items
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected void OnItemCopied(
    Object sender,
    EventArgs args
)
Visual Basic
Protected Sub OnItemCopied ( _
    sender As Object, _
    args As EventArgs _
)
Visual C++
protected:
void OnItemCopied(
    Object^ sender,
    EventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: System..::..EventArgs
The arguments.

See Also

ItemEventHandler Class
Sitecore.Analytics.Data.Items Namespace


OnItemDeleted Method

[image]

Sitecore 6.4.1 API
ItemEventHandler..::..OnItemDeleted Method
ItemEventHandler Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Items
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected void OnItemDeleted(
    Object sender,
    EventArgs args
)
Visual Basic
Protected Sub OnItemDeleted ( _
    sender As Object, _
    args As EventArgs _
)
Visual C++
protected:
void OnItemDeleted(
    Object^ sender,
    EventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: System..::..EventArgs
The arguments.

See Also

ItemEventHandler Class
Sitecore.Analytics.Data.Items Namespace


OnItemSaved Method

[image]

Sitecore 6.4.1 API
ItemEventHandler..::..OnItemSaved Method
ItemEventHandler Class See Also Send Feedback

Namespace: Sitecore.Analytics.Data.Items
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected void OnItemSaved(
    Object sender,
    EventArgs args
)
Visual Basic
Protected Sub OnItemSaved ( _
    sender As Object, _
    args As EventArgs _
)
Visual C++
protected:
void OnItemSaved(
    Object^ sender,
    EventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: System..::..EventArgs
The arguments.

See Also

ItemEventHandler Class
Sitecore.Analytics.Data.Items Namespace


Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace
Send Feedback

Classes

 | Class | Description
Public class | Baskets | Defines the baskets class.
Public class | Brochures | Defines the baskets class.
Public class | Forms | Defines the baskets class.
Public class | Membership | Defines the baskets class.
Public class | Newsletters | Defines the baskets class.
Public class | Pages | Defines the pages class.
Public class | Polls | Defines the polls class.
Public class | Prints | Defines the prints class.
Public class | Ratings | Defines the ratings class.
Public class | Searches | Defines the searches class.
Public class | Transactions | Defines the transactions class.


Baskets Class

[image]

Sitecore 6.4.1 API
Baskets Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Extensions.AnalyticsPageExtensions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static class Baskets
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class Baskets
Visual C++
[ExtensionAttribute]
public ref class Baskets abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Extensions.AnalyticsPageExtensions..::..Baskets

See Also

Baskets Members
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


Baskets Members

[image] [image]

Sitecore 6.4.1 API
Baskets Members
Baskets Class Methods See Also Send Feedback

The Baskets type exposes the following members.

Methods

Name | Description
PutInBasket | Puts the in basket.

See Also

Baskets Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


Baskets Methods

[image] [image]

Sitecore 6.4.1 API
Baskets Methods
Baskets Class See Also Send Feedback

The Baskets type exposes the following members.

Methods

Name | Description
PutInBasket | Puts the in basket.

See Also

Baskets Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


PutInBasket Method

[image]

Sitecore 6.4.1 API
Baskets..::..PutInBasket Method
Baskets Class See Also Send Feedback

Namespace: Sitecore.Analytics.Extensions.AnalyticsPageExtensions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void PutInBasket(
    this AnalyticsPage page,
    string product,
    int amount,
    double cost
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub PutInBasket ( _
    page As AnalyticsPage, _
    product As String, _
    amount As Integer, _
    cost As Double _
)
Visual C++
[ExtensionAttribute]
public:
static void PutInBasket(
    AnalyticsPage^ page,
    String^ product,
    int amount,
    double cost
)

Parameters

page
Type: Sitecore.Analytics..::..AnalyticsPage
The page.
product
Type: System..::..String
The product.
amount
Type: System..::..Int32
The amount.
cost
Type: System..::..Double
The cost.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type AnalyticsPage. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Baskets Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


Brochures Class

[image]

Sitecore 6.4.1 API
Brochures Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Extensions.AnalyticsPageExtensions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static class Brochures
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class Brochures
Visual C++
[ExtensionAttribute]
public ref class Brochures abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Extensions.AnalyticsPageExtensions..::..Brochures

See Also

Brochures Members
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


Brochures Members

[image] [image]

Sitecore 6.4.1 API
Brochures Members
Brochures Class Methods See Also Send Feedback

The Brochures type exposes the following members.

Methods

Name | Description
RequestBrochures | Puts the in basket.

See Also

Brochures Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


Brochures Methods

[image] [image]

Sitecore 6.4.1 API
Brochures Methods
Brochures Class See Also Send Feedback

The Brochures type exposes the following members.

Methods

Name | Description
RequestBrochures | Puts the in basket.

See Also

Brochures Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


RequestBrochures Method

[image]

Sitecore 6.4.1 API
Brochures..::..RequestBrochures Method
Brochures Class See Also Send Feedback

Namespace: Sitecore.Analytics.Extensions.AnalyticsPageExtensions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void RequestBrochures(
    this AnalyticsPage page,
    IEnumerable<string> brochureNames
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub RequestBrochures ( _
    page As AnalyticsPage, _
    brochureNames As IEnumerable(Of String) _
)
Visual C++
[ExtensionAttribute]
public:
static void RequestBrochures(
    AnalyticsPage^ page,
    IEnumerable<String^>^ brochureNames
)

Parameters

page
Type: Sitecore.Analytics..::..AnalyticsPage
The page.
brochureNames
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' String >)>)>
The brochure names.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type AnalyticsPage. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Brochures Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


Forms Class

[image]

Sitecore 6.4.1 API
Forms Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Extensions.AnalyticsPageExtensions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static class Forms
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class Forms
Visual C++
[ExtensionAttribute]
public ref class Forms abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Extensions.AnalyticsPageExtensions..::..Forms

See Also

Forms Members
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


Forms Members

[image] [image]

Sitecore 6.4.1 API
Forms Members
Forms Class Methods See Also Send Feedback

Methods

Name | Description
ChangeFormField(AnalyticsPage, String, String) | Fields the changed.
ChangeFormField(AnalyticsPage, String, String, String) | Changes the form field.
Submit(AnalyticsPage) | Submits this instance.
Submit(AnalyticsPage, String) | Submits the specified page.

See Also

Forms Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


Forms Methods

[image] [image]

Sitecore 6.4.1 API
Forms Methods
Forms Class See Also Send Feedback

Methods

Name | Description
ChangeFormField(AnalyticsPage, String, String) | Fields the changed.
ChangeFormField(AnalyticsPage, String, String, String) | Changes the form field.
Submit(AnalyticsPage) | Submits this instance.
Submit(AnalyticsPage, String) | Submits the specified page.

See Also

Forms Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


ChangeFormField Method

[image] [image]

Sitecore 6.4.1 API
Forms..::..ChangeFormField Method
Forms Class See Also Send Feedback

Overload List

Name | Description
ChangeFormField(AnalyticsPage, String, String) | Fields the changed.
ChangeFormField(AnalyticsPage, String, String, String) | Changes the form field.

See Also

Forms Class
Forms Members
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


ChangeFormField Method (AnalyticsPage, String, String, String)

[image]

Sitecore 6.4.1 API
Forms..::..ChangeFormField Method (AnalyticsPage, String, String, String)
Forms Class See Also Send Feedback

Namespace: Sitecore.Analytics.Extensions.AnalyticsPageExtensions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void ChangeFormField(
    this AnalyticsPage page,
    string formName,
    string fieldName,
    string fieldValue
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub ChangeFormField ( _
    page As AnalyticsPage, _
    formName As String, _
    fieldName As String, _
    fieldValue As String _
)
Visual C++
[ExtensionAttribute]
public:
static void ChangeFormField(
    AnalyticsPage^ page,
    String^ formName,
    String^ fieldName,
    String^ fieldValue
)

Parameters

page
Type: Sitecore.Analytics..::..AnalyticsPage
The analytics page.
formName
Type: System..::..String
Name of the form.
fieldName
Type: System..::..String
Name of the field.
fieldValue
Type: System..::..String
The field value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type AnalyticsPage. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Forms Class
ChangeFormField Overload
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


Submit Method

[image] [image]

Sitecore 6.4.1 API
Forms..::..Submit Method
Forms Class See Also Send Feedback

Overload List

Name | Description
Submit(AnalyticsPage) | Submits this instance.
Submit(AnalyticsPage, String) | Submits the specified page.

See Also

Forms Class
Forms Members
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


Submit Method (AnalyticsPage)

[image]

Sitecore 6.4.1 API
Forms..::..Submit Method (AnalyticsPage)
Forms Class See Also Send Feedback

Namespace: Sitecore.Analytics.Extensions.AnalyticsPageExtensions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void Submit(
    this AnalyticsPage page
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub Submit ( _
    page As AnalyticsPage _
)
Visual C++
[ExtensionAttribute]
public:
static void Submit(
    AnalyticsPage^ page
)

Parameters

page
Type: Sitecore.Analytics..::..AnalyticsPage
The analytics page.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type AnalyticsPage. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Forms Class
Submit Overload
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


Submit Method (AnalyticsPage, String)

[image]

Sitecore 6.4.1 API
Forms..::..Submit Method (AnalyticsPage, String)
Forms Class See Also Send Feedback

Namespace: Sitecore.Analytics.Extensions.AnalyticsPageExtensions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void Submit(
    this AnalyticsPage page,
    string formName
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub Submit ( _
    page As AnalyticsPage, _
    formName As String _
)
Visual C++
[ExtensionAttribute]
public:
static void Submit(
    AnalyticsPage^ page,
    String^ formName
)

Parameters

page
Type: Sitecore.Analytics..::..AnalyticsPage
The analytics page.
formName
Type: System..::..String
Name of the form.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type AnalyticsPage. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Forms Class
Submit Overload
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


Membership Class

[image]

Sitecore 6.4.1 API
Membership Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Extensions.AnalyticsPageExtensions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static class Membership
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class Membership
Visual C++
[ExtensionAttribute]
public ref class Membership abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Extensions.AnalyticsPageExtensions..::..Membership

See Also

Membership Members
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


Membership Members

[image] [image]

Sitecore 6.4.1 API
Membership Members
Membership Class Methods See Also Send Feedback

The Membership type exposes the following members.

Methods

Name | Description
LoginUser | Fields the changed.
LoginUserFailed | Logins the failed.
LogoutUser | Logouts the specified page.
RegisterUser | Logouts the specified page.
RegisterUserFailed | Registers the user failed.
UpdateUser | Updates the user.

See Also

Membership Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


Membership Methods

[image] [image]

Sitecore 6.4.1 API
Membership Methods
Membership Class See Also Send Feedback

The Membership type exposes the following members.

Methods

Name | Description
LoginUser | Fields the changed.
LoginUserFailed | Logins the failed.
LogoutUser | Logouts the specified page.
RegisterUser | Logouts the specified page.
RegisterUserFailed | Registers the user failed.
UpdateUser | Updates the user.

See Also

Membership Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


LoginUser Method

[image]

Sitecore 6.4.1 API
Membership..::..LoginUser Method
Membership Class See Also Send Feedback

Namespace: Sitecore.Analytics.Extensions.AnalyticsPageExtensions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void LoginUser(
    this AnalyticsPage page,
    string userName
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub LoginUser ( _
    page As AnalyticsPage, _
    userName As String _
)
Visual C++
[ExtensionAttribute]
public:
static void LoginUser(
    AnalyticsPage^ page,
    String^ userName
)

Parameters

page
Type: Sitecore.Analytics..::..AnalyticsPage
The page.
userName
Type: System..::..String
Name of the user.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type AnalyticsPage. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Remarks

The current page is canceled as this method is expected to be called in an Ajax request.

See Also

Membership Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


LoginUserFailed Method

[image]

Sitecore 6.4.1 API
Membership..::..LoginUserFailed Method
Membership Class See Also Send Feedback

Namespace: Sitecore.Analytics.Extensions.AnalyticsPageExtensions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void LoginUserFailed(
    this AnalyticsPage page,
    string userName,
    string reason
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub LoginUserFailed ( _
    page As AnalyticsPage, _
    userName As String, _
    reason As String _
)
Visual C++
[ExtensionAttribute]
public:
static void LoginUserFailed(
    AnalyticsPage^ page,
    String^ userName,
    String^ reason
)

Parameters

page
Type: Sitecore.Analytics..::..AnalyticsPage
The page.
userName
Type: System..::..String
Name of the user.
reason
Type: System..::..String
The reason.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type AnalyticsPage. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Membership Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


LogoutUser Method

[image]

Sitecore 6.4.1 API
Membership..::..LogoutUser Method
Membership Class See Also Send Feedback

Namespace: Sitecore.Analytics.Extensions.AnalyticsPageExtensions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void LogoutUser(
    this AnalyticsPage page
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub LogoutUser ( _
    page As AnalyticsPage _
)
Visual C++
[ExtensionAttribute]
public:
static void LogoutUser(
    AnalyticsPage^ page
)

Parameters

page
Type: Sitecore.Analytics..::..AnalyticsPage
The page.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type AnalyticsPage. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Membership Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


RegisterUser Method

[image]

Sitecore 6.4.1 API
Membership..::..RegisterUser Method
Membership Class See Also Send Feedback

Namespace: Sitecore.Analytics.Extensions.AnalyticsPageExtensions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void RegisterUser(
    this AnalyticsPage page,
    string fullName,
    string email,
    string address,
    string city,
    string state,
    string country,
    string phone,
    params string[] additional
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub RegisterUser ( _
    page As AnalyticsPage, _
    fullName As String, _
    email As String, _
    address As String, _
    city As String, _
    state As String, _
    country As String, _
    phone As String, _
    ParamArray additional As String() _
)
Visual C++
[ExtensionAttribute]
public:
static void RegisterUser(
    AnalyticsPage^ page,
    String^ fullName,
    String^ email,
    String^ address,
    String^ city,
    String^ state,
    String^ country,
    String^ phone,
    ... array<String^>^ additional
)

Parameters

page
Type: Sitecore.Analytics..::..AnalyticsPage
The page.
fullName
Type: System..::..String
The full name.
email
Type: System..::..String
The email.
address
Type: System..::..String
The address.
city
Type: System..::..String
The city.
state
Type: System..::..String
The state.
country
Type: System..::..String
The country.
phone
Type: System..::..String
The phone.
additional
Type: array< System..::..String >[]()[][]
The additional.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type AnalyticsPage. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Membership Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


RegisterUserFailed Method

[image]

Sitecore 6.4.1 API
Membership..::..RegisterUserFailed Method
Membership Class See Also Send Feedback

Namespace: Sitecore.Analytics.Extensions.AnalyticsPageExtensions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void RegisterUserFailed(
    this AnalyticsPage page,
    string fullName,
    string email,
    string address,
    string city,
    string state,
    string country,
    string phone,
    string reason,
    params string[] additional
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub RegisterUserFailed ( _
    page As AnalyticsPage, _
    fullName As String, _
    email As String, _
    address As String, _
    city As String, _
    state As String, _
    country As String, _
    phone As String, _
    reason As String, _
    ParamArray additional As String() _
)
Visual C++
[ExtensionAttribute]
public:
static void RegisterUserFailed(
    AnalyticsPage^ page,
    String^ fullName,
    String^ email,
    String^ address,
    String^ city,
    String^ state,
    String^ country,
    String^ phone,
    String^ reason,
    ... array<String^>^ additional
)

Parameters

page
Type: Sitecore.Analytics..::..AnalyticsPage
The page.
fullName
Type: System..::..String
The full name.
email
Type: System..::..String
The email.
address
Type: System..::..String
The address.
city
Type: System..::..String
The city.
state
Type: System..::..String
The state.
country
Type: System..::..String
The country.
phone
Type: System..::..String
The phone.
reason
Type: System..::..String
The reason.
additional
Type: array< System..::..String >[]()[][]
The additional.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type AnalyticsPage. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Membership Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


UpdateUser Method

[image]

Sitecore 6.4.1 API
Membership..::..UpdateUser Method
Membership Class See Also Send Feedback

Namespace: Sitecore.Analytics.Extensions.AnalyticsPageExtensions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void UpdateUser(
    this AnalyticsPage page,
    string fullName,
    string email,
    string address,
    string city,
    string state,
    string country,
    string phone,
    params string[] additional
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub UpdateUser ( _
    page As AnalyticsPage, _
    fullName As String, _
    email As String, _
    address As String, _
    city As String, _
    state As String, _
    country As String, _
    phone As String, _
    ParamArray additional As String() _
)
Visual C++
[ExtensionAttribute]
public:
static void UpdateUser(
    AnalyticsPage^ page,
    String^ fullName,
    String^ email,
    String^ address,
    String^ city,
    String^ state,
    String^ country,
    String^ phone,
    ... array<String^>^ additional
)

Parameters

page
Type: Sitecore.Analytics..::..AnalyticsPage
The page.
fullName
Type: System..::..String
The full name.
email
Type: System..::..String
The email.
address
Type: System..::..String
The address.
city
Type: System..::..String
The city.
state
Type: System..::..String
The state.
country
Type: System..::..String
The country.
phone
Type: System..::..String
The phone.
additional
Type: array< System..::..String >[]()[][]
The additional.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type AnalyticsPage. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Membership Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


Newsletters Class

[image]

Sitecore 6.4.1 API
Newsletters Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Extensions.AnalyticsPageExtensions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static class Newsletters
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class Newsletters
Visual C++
[ExtensionAttribute]
public ref class Newsletters abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Extensions.AnalyticsPageExtensions..::..Newsletters

See Also

Newsletters Members
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


Newsletters Members

[image] [image]

Sitecore 6.4.1 API
Newsletters Members
Newsletters Class Methods See Also Send Feedback

The Newsletters type exposes the following members.

Methods

Name | Description
RemoveFromNewsletter | Removes from newsletter.
SignUpToNewsletter | Puts the in basket.

See Also

Newsletters Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


Newsletters Methods

[image] [image]

Sitecore 6.4.1 API
Newsletters Methods
Newsletters Class See Also Send Feedback

The Newsletters type exposes the following members.

Methods

Name | Description
RemoveFromNewsletter | Removes from newsletter.
SignUpToNewsletter | Puts the in basket.

See Also

Newsletters Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


RemoveFromNewsletter Method

[image]

Sitecore 6.4.1 API
Newsletters..::..RemoveFromNewsletter Method
Newsletters Class See Also Send Feedback

Namespace: Sitecore.Analytics.Extensions.AnalyticsPageExtensions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void RemoveFromNewsletter(
    this AnalyticsPage page,
    string newsletter
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub RemoveFromNewsletter ( _
    page As AnalyticsPage, _
    newsletter As String _
)
Visual C++
[ExtensionAttribute]
public:
static void RemoveFromNewsletter(
    AnalyticsPage^ page,
    String^ newsletter
)

Parameters

page
Type: Sitecore.Analytics..::..AnalyticsPage
The page.
newsletter
Type: System..::..String
The newsletter.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type AnalyticsPage. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Newsletters Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


SignUpToNewsletter Method

[image]

Sitecore 6.4.1 API
Newsletters..::..SignUpToNewsletter Method
Newsletters Class See Also Send Feedback

Namespace: Sitecore.Analytics.Extensions.AnalyticsPageExtensions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void SignUpToNewsletter(
    this AnalyticsPage page,
    string newsletter,
    string email
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub SignUpToNewsletter ( _
    page As AnalyticsPage, _
    newsletter As String, _
    email As String _
)
Visual C++
[ExtensionAttribute]
public:
static void SignUpToNewsletter(
    AnalyticsPage^ page,
    String^ newsletter,
    String^ email
)

Parameters

page
Type: Sitecore.Analytics..::..AnalyticsPage
The page.
newsletter
Type: System..::..String
The newsletter.
email
Type: System..::..String
The email.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type AnalyticsPage. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Newsletters Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


Pages Class

[image]

Sitecore 6.4.1 API
Pages Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Extensions.AnalyticsPageExtensions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static class Pages
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class Pages
Visual C++
[ExtensionAttribute]
public ref class Pages abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Extensions.AnalyticsPageExtensions..::..Pages

See Also

Pages Members
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


Pages Members

[image] [image]

Sitecore 6.4.1 API
Pages Members
Pages Class Methods See Also Send Feedback

The Pages type exposes the following members.

Methods

Name | Description
LongRunningRequest | Puts the in basket.
PageError | Pages the not found.
PageNotFound | Pages the not found.
VisitPage(AnalyticsPage) | Visits the page.
VisitPage(AnalyticsPage, String) | Removes from newsletter.

See Also

Pages Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


Pages Methods

[image] [image]

Sitecore 6.4.1 API
Pages Methods
Pages Class See Also Send Feedback

The Pages type exposes the following members.

Methods

Name | Description
LongRunningRequest | Puts the in basket.
PageError | Pages the not found.
PageNotFound | Pages the not found.
VisitPage(AnalyticsPage) | Visits the page.
VisitPage(AnalyticsPage, String) | Removes from newsletter.

See Also

Pages Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


LongRunningRequest Method

[image]

Sitecore 6.4.1 API
Pages..::..LongRunningRequest Method
Pages Class See Also Send Feedback

Namespace: Sitecore.Analytics.Extensions.AnalyticsPageExtensions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void LongRunningRequest(
    this AnalyticsPage page,
    double milliseconds
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub LongRunningRequest ( _
    page As AnalyticsPage, _
    milliseconds As Double _
)
Visual C++
[ExtensionAttribute]
public:
static void LongRunningRequest(
    AnalyticsPage^ page,
    double milliseconds
)

Parameters

page
Type: Sitecore.Analytics..::..AnalyticsPage
The page.
milliseconds
Type: System..::..Double
The milliseconds.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type AnalyticsPage. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Pages Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


PageError Method

[image]

Sitecore 6.4.1 API
Pages..::..PageError Method
Pages Class See Also Send Feedback

Namespace: Sitecore.Analytics.Extensions.AnalyticsPageExtensions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void PageError(
    this AnalyticsPage page,
    string url,
    string message
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub PageError ( _
    page As AnalyticsPage, _
    url As String, _
    message As String _
)
Visual C++
[ExtensionAttribute]
public:
static void PageError(
    AnalyticsPage^ page,
    String^ url,
    String^ message
)

Parameters

page
Type: Sitecore.Analytics..::..AnalyticsPage
The page.
url
Type: System..::..String
The URL.
message
Type: System..::..String
The message.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type AnalyticsPage. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Pages Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


PageNotFound Method

[image]

Sitecore 6.4.1 API
Pages..::..PageNotFound Method
Pages Class See Also Send Feedback

Namespace: Sitecore.Analytics.Extensions.AnalyticsPageExtensions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void PageNotFound(
    this AnalyticsPage page,
    string url
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub PageNotFound ( _
    page As AnalyticsPage, _
    url As String _
)
Visual C++
[ExtensionAttribute]
public:
static void PageNotFound(
    AnalyticsPage^ page,
    String^ url
)

Parameters

page
Type: Sitecore.Analytics..::..AnalyticsPage
The page.
url
Type: System..::..String
The URL.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type AnalyticsPage. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Pages Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


VisitPage Method

[image] [image]

Sitecore 6.4.1 API
Pages..::..VisitPage Method
Pages Class See Also Send Feedback

Overload List

Name | Description
VisitPage(AnalyticsPage) | Visits the page.
VisitPage(AnalyticsPage, String) | Removes from newsletter.

See Also

Pages Class
Pages Members
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


VisitPage Method (AnalyticsPage)

[image]

Sitecore 6.4.1 API
Pages..::..VisitPage Method (AnalyticsPage)
Pages Class See Also Send Feedback

Namespace: Sitecore.Analytics.Extensions.AnalyticsPageExtensions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void VisitPage(
    this AnalyticsPage page
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub VisitPage ( _
    page As AnalyticsPage _
)
Visual C++
[ExtensionAttribute]
public:
static void VisitPage(
    AnalyticsPage^ page
)

Parameters

page
Type: Sitecore.Analytics..::..AnalyticsPage
The page.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type AnalyticsPage. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Pages Class
VisitPage Overload
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


VisitPage Method (AnalyticsPage, String)

[image]

Sitecore 6.4.1 API
Pages..::..VisitPage Method (AnalyticsPage, String)
Pages Class See Also Send Feedback

Namespace: Sitecore.Analytics.Extensions.AnalyticsPageExtensions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void VisitPage(
    this AnalyticsPage page,
    string url
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub VisitPage ( _
    page As AnalyticsPage, _
    url As String _
)
Visual C++
[ExtensionAttribute]
public:
static void VisitPage(
    AnalyticsPage^ page,
    String^ url
)

Parameters

page
Type: Sitecore.Analytics..::..AnalyticsPage
The page.
url
Type: System..::..String
The URL.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type AnalyticsPage. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Pages Class
VisitPage Overload
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


Polls Class

[image]

Sitecore 6.4.1 API
Polls Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Extensions.AnalyticsPageExtensions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static class Polls
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class Polls
Visual C++
[ExtensionAttribute]
public ref class Polls abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Extensions.AnalyticsPageExtensions..::..Polls

See Also

Polls Members
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


Polls Members

[image] [image]

Sitecore 6.4.1 API
Polls Members
Polls Class Methods See Also Send Feedback

The Polls type exposes the following members.

Methods

Name | Description
SelectPollOption | Puts the in basket.

See Also

Polls Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


Polls Methods

[image] [image]

Sitecore 6.4.1 API
Polls Methods
Polls Class See Also Send Feedback

The Polls type exposes the following members.

Methods

Name | Description
SelectPollOption | Puts the in basket.

See Also

Polls Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


SelectPollOption Method

[image]

Sitecore 6.4.1 API
Polls..::..SelectPollOption Method
Polls Class See Also Send Feedback

Namespace: Sitecore.Analytics.Extensions.AnalyticsPageExtensions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void SelectPollOption(
    this AnalyticsPage page,
    string pollName,
    string option,
    int optionIndex
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub SelectPollOption ( _
    page As AnalyticsPage, _
    pollName As String, _
    option As String, _
    optionIndex As Integer _
)
Visual C++
[ExtensionAttribute]
public:
static void SelectPollOption(
    AnalyticsPage^ page,
    String^ pollName,
    String^ option,
    int optionIndex
)

Parameters

page
Type: Sitecore.Analytics..::..AnalyticsPage
The page.
pollName
Type: System..::..String
Name of the poll.
option
Type: System..::..String
The option.
optionIndex
Type: System..::..Int32
Index of the option.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type AnalyticsPage. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Polls Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


Prints Class

[image]

Sitecore 6.4.1 API
Prints Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Extensions.AnalyticsPageExtensions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static class Prints
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class Prints
Visual C++
[ExtensionAttribute]
public ref class Prints abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Extensions.AnalyticsPageExtensions..::..Prints

See Also

Prints Members
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


Prints Members

[image] [image]

Sitecore 6.4.1 API
Prints Members
Prints Class Methods See Also Send Feedback

The Prints type exposes the following members.

Methods

Name | Description
Print | Tracks a print of this page.

See Also

Prints Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


Prints Methods

[image] [image]

Sitecore 6.4.1 API
Prints Methods
Prints Class See Also Send Feedback

The Prints type exposes the following members.

Methods

Name | Description
Print | Tracks a print of this page.

See Also

Prints Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


Print Method

[image]

Sitecore 6.4.1 API
Prints..::..Print Method
Prints Class See Also Send Feedback

Namespace: Sitecore.Analytics.Extensions.AnalyticsPageExtensions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void Print(
    this AnalyticsPage page
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub Print ( _
    page As AnalyticsPage _
)
Visual C++
[ExtensionAttribute]
public:
static void Print(
    AnalyticsPage^ page
)

Parameters

page
Type: Sitecore.Analytics..::..AnalyticsPage
The page.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type AnalyticsPage. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Prints Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


Ratings Class

[image]

Sitecore 6.4.1 API
Ratings Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Extensions.AnalyticsPageExtensions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static class Ratings
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class Ratings
Visual C++
[ExtensionAttribute]
public ref class Ratings abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Extensions.AnalyticsPageExtensions..::..Ratings

See Also

Ratings Members
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


Ratings Members

[image] [image]

Sitecore 6.4.1 API
Ratings Members
Ratings Class Methods See Also Send Feedback

The Ratings type exposes the following members.

Methods

Name | Description
Rate | Puts the in basket.

See Also

Ratings Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


Ratings Methods

[image] [image]

Sitecore 6.4.1 API
Ratings Methods
Ratings Class See Also Send Feedback

The Ratings type exposes the following members.

Methods

Name | Description
Rate | Puts the in basket.

See Also

Ratings Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


Rate Method

[image]

Sitecore 6.4.1 API
Ratings..::..Rate Method
Ratings Class See Also Send Feedback

Namespace: Sitecore.Analytics.Extensions.AnalyticsPageExtensions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void Rate(
    this AnalyticsPage page,
    string ratingName,
    string ratingOption,
    int ratingValue
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub Rate ( _
    page As AnalyticsPage, _
    ratingName As String, _
    ratingOption As String, _
    ratingValue As Integer _
)
Visual C++
[ExtensionAttribute]
public:
static void Rate(
    AnalyticsPage^ page,
    String^ ratingName,
    String^ ratingOption,
    int ratingValue
)

Parameters

page
Type: Sitecore.Analytics..::..AnalyticsPage
The page.
ratingName
Type: System..::..String
Name of the rating.
ratingOption
Type: System..::..String
The rating option.
ratingValue
Type: System..::..Int32
The rating value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type AnalyticsPage. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Ratings Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


Searches Class

[image]

Sitecore 6.4.1 API
Searches Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Extensions.AnalyticsPageExtensions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static class Searches
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class Searches
Visual C++
[ExtensionAttribute]
public ref class Searches abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Extensions.AnalyticsPageExtensions..::..Searches

See Also

Searches Members
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


Searches Members

[image] [image]

Sitecore 6.4.1 API
Searches Members
Searches Class Methods See Also Send Feedback

The Searches type exposes the following members.

Methods

Name | Description
AddFollowHitToQueryString | Adds the follow hit to query string.
FollowSearchHit | Follows the search hit.
Search | Puts the in basket.

See Also

Searches Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


Searches Methods

[image] [image]

Sitecore 6.4.1 API
Searches Methods
Searches Class See Also Send Feedback

The Searches type exposes the following members.

Methods

Name | Description
AddFollowHitToQueryString | Adds the follow hit to query string.
FollowSearchHit | Follows the search hit.
Search | Puts the in basket.

See Also

Searches Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


FollowSearchHit Method

[image]

Sitecore 6.4.1 API
Searches..::..FollowSearchHit Method
Searches Class See Also Send Feedback

Namespace: Sitecore.Analytics.Extensions.AnalyticsPageExtensions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void FollowSearchHit(
    this AnalyticsPage page
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub FollowSearchHit ( _
    page As AnalyticsPage _
)
Visual C++
[ExtensionAttribute]
public:
static void FollowSearchHit(
    AnalyticsPage^ page
)

Parameters

page
Type: Sitecore.Analytics..::..AnalyticsPage
The page.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type AnalyticsPage. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Searches Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


Search Method

[image]

Sitecore 6.4.1 API
Searches..::..Search Method
Searches Class See Also Send Feedback

Namespace: Sitecore.Analytics.Extensions.AnalyticsPageExtensions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void Search(
    this AnalyticsPage page,
    string query,
    int hits
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub Search ( _
    page As AnalyticsPage, _
    query As String, _
    hits As Integer _
)
Visual C++
[ExtensionAttribute]
public:
static void Search(
    AnalyticsPage^ page,
    String^ query,
    int hits
)

Parameters

page
Type: Sitecore.Analytics..::..AnalyticsPage
The page.
query
Type: System..::..String
The query.
hits
Type: System..::..Int32
The hits.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type AnalyticsPage. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Searches Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


Transactions Class

[image]

Sitecore 6.4.1 API
Transactions Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Extensions.AnalyticsPageExtensions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static class Transactions
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class Transactions
Visual C++
[ExtensionAttribute]
public ref class Transactions abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Extensions.AnalyticsPageExtensions..::..Transactions

See Also

Transactions Members
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


Transactions Methods

[image] [image]

Sitecore 6.4.1 API
Transactions Methods
Transactions Class See Also Send Feedback

The Transactions type exposes the following members.

Methods

Name | Description
BeginTransaction | Follows the search hit.
CancelTransaction | Cancels the specified handle.
EndTransaction | Ends the transaction.

See Also

Transactions Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


BeginTransaction Method

[image]

Sitecore 6.4.1 API
Transactions..::..BeginTransaction Method
Transactions Class See Also Send Feedback

Namespace: Sitecore.Analytics.Extensions.AnalyticsPageExtensions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static TransactionHandle BeginTransaction(
    this AnalyticsPage page
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function BeginTransaction ( _
    page As AnalyticsPage _
) As TransactionHandle
Visual C++
[ExtensionAttribute]
public:
static TransactionHandle^ BeginTransaction(
    AnalyticsPage^ page
)

Parameters

page
Type: Sitecore.Analytics..::..AnalyticsPage
The page.

Return Value

The transaction handle.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type AnalyticsPage. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Transactions Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


CancelTransaction Method

[image]

Sitecore 6.4.1 API
Transactions..::..CancelTransaction Method
Transactions Class See Also Send Feedback

Namespace: Sitecore.Analytics.Extensions.AnalyticsPageExtensions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void CancelTransaction(
    this AnalyticsPage page,
    TransactionHandle transactionHandle
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub CancelTransaction ( _
    page As AnalyticsPage, _
    transactionHandle As TransactionHandle _
)
Visual C++
[ExtensionAttribute]
public:
static void CancelTransaction(
    AnalyticsPage^ page,
    TransactionHandle^ transactionHandle
)

Parameters

page
Type: Sitecore.Analytics..::..AnalyticsPage
The page.
transactionHandle
Type: Sitecore.Analytics..::..TransactionHandle
The handle.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type AnalyticsPage. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Transactions Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


EndTransaction Method

[image]

Sitecore 6.4.1 API
Transactions..::..EndTransaction Method
Transactions Class See Also Send Feedback

Namespace: Sitecore.Analytics.Extensions.AnalyticsPageExtensions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void EndTransaction(
    this AnalyticsPage page,
    TransactionHandle transactionHandle
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub EndTransaction ( _
    page As AnalyticsPage, _
    transactionHandle As TransactionHandle _
)
Visual C++
[ExtensionAttribute]
public:
static void EndTransaction(
    AnalyticsPage^ page,
    TransactionHandle^ transactionHandle
)

Parameters

page
Type: Sitecore.Analytics..::..AnalyticsPage
The page.
transactionHandle
Type: Sitecore.Analytics..::..TransactionHandle
The handle.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type AnalyticsPage. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Transactions Class
Sitecore.Analytics.Extensions.AnalyticsPageExtensions Namespace


Sitecore.Analytics.Lookups Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Analytics.Lookups Namespace
Send Feedback

Classes

 | Class | Description
Public class | Hexillion | Defines the hexillion class.
Public class | HexillionProvider | Defines the hexillion provider class.
Public class | LookupData | Defines the lookup data class.
Public class | LookupManager | Defines the lookup manager class.
Public class | LookupProviderBase | Defines the lookup provider base class.
Public class | LookupProviderCollection | LookupProviderCollection class
Public class | LookupUpdater | Defines the lookup updater class.
Public class | LookupWorker | Defines the submitter class.
Public class | MaxMindProvider | Defines the MaxMind provider class.
Public class | WhoIsInformation | Defines the who is information class.

Enumerations

 | Enumeration | Description
Public enumeration | UpdateOperation | UpdateOperation enumeration.


Hexillion Class

[image]

Sitecore 6.4.1 API
Hexillion Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class Hexillion
Visual Basic
Public Class Hexillion
Visual C++
public ref class Hexillion

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Lookups..::..Hexillion

See Also

Hexillion Members
Sitecore.Analytics.Lookups Namespace


Hexillion Members

[image] [image]

Sitecore 6.4.1 API
Hexillion Members
Hexillion Class Constructors Methods See Also Send Feedback

The Hexillion type exposes the following members.

Constructors

 | Name | Description
Public method | Hexillion | Initializes a new instance of the Hexillion class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInformationByIp | Gets the information by IP.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAuthenticated | Determines whether this instance is authenticated.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Hexillion Class
Sitecore.Analytics.Lookups Namespace


Hexillion Constructor

[image]

Sitecore 6.4.1 API
Hexillion Constructor
Hexillion Class See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Hexillion()
Visual Basic
Public Sub New
Visual C++
public:
Hexillion()

See Also

Hexillion Class
Sitecore.Analytics.Lookups Namespace


Hexillion Methods

[image] [image]

Sitecore 6.4.1 API
Hexillion Methods
Hexillion Class See Also Send Feedback

The Hexillion type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInformationByIp | Gets the information by IP.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAuthenticated | Determines whether this instance is authenticated.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Hexillion Class
Sitecore.Analytics.Lookups Namespace


GetInformationByIp Method

[image]

Sitecore 6.4.1 API
Hexillion..::..GetInformationByIp Method
Hexillion Class See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public WhoIsInformation GetInformationByIp(
    string ip
)
Visual Basic
Public Function GetInformationByIp ( _
    ip As String _
) As WhoIsInformation
Visual C++
public:
WhoIsInformation^ GetInformationByIp(
    String^ ip
)

Parameters

ip
Type: System..::..String
The IP address.

Return Value

The information by IP.

See Also

Hexillion Class
Sitecore.Analytics.Lookups Namespace


IsAuthenticated Method

[image]

Sitecore 6.4.1 API
Hexillion..::..IsAuthenticated Method
Hexillion Class See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public bool IsAuthenticated()
Visual Basic
Public Function IsAuthenticated As Boolean
Visual C++
public:
bool IsAuthenticated()

Return Value

true if this instance is authenticated; otherwise, false.

See Also

Hexillion Class
Sitecore.Analytics.Lookups Namespace


HexillionProvider Class

[image]

Sitecore 6.4.1 API
HexillionProvider Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class HexillionProvider : LookupProviderBase
Visual Basic
Public Class HexillionProvider _
    Inherits LookupProviderBase
Visual C++
public ref class HexillionProvider : public LookupProviderBase

Inheritance Hierarchy

System..::..Object
System.Configuration.Provider..::..ProviderBase
Sitecore.Analytics.Lookups..::..LookupProviderBase
Sitecore.Analytics.Lookups..::..HexillionProvider

See Also

HexillionProvider Members
Sitecore.Analytics.Lookups Namespace


HexillionProvider Members

[image] [image]

Sitecore 6.4.1 API
HexillionProvider Members
HexillionProvider Class Constructors Methods Properties See Also Send Feedback

The HexillionProvider type exposes the following members.

Constructors

 | Name | Description
Public method | HexillionProvider | Initializes a new instance of the HexillionProvider class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInformationByIp | Gets the information by IP. (Overrides LookupProviderBase..::..GetInformationByIp(String, String).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the provider. (Inherited from ProviderBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReverseDnsLookup | Reverses the DNS lookup. (Inherited from LookupProviderBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

HexillionProvider Class
Sitecore.Analytics.Lookups Namespace


HexillionProvider Constructor

[image]

Sitecore 6.4.1 API
HexillionProvider Constructor
HexillionProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public HexillionProvider()
Visual Basic
Public Sub New
Visual C++
public:
HexillionProvider()

See Also

HexillionProvider Class
Sitecore.Analytics.Lookups Namespace


HexillionProvider Methods

[image] [image]

Sitecore 6.4.1 API
HexillionProvider Methods
HexillionProvider Class See Also Send Feedback

The HexillionProvider type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInformationByIp | Gets the information by IP. (Overrides LookupProviderBase..::..GetInformationByIp(String, String).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the provider. (Inherited from ProviderBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReverseDnsLookup | Reverses the DNS lookup. (Inherited from LookupProviderBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HexillionProvider Class
Sitecore.Analytics.Lookups Namespace


GetInformationByIp Method

[image]

Sitecore 6.4.1 API
HexillionProvider..::..GetInformationByIp Method
HexillionProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override WhoIsInformation GetInformationByIp(
    string ipfrom,
    string ipto
)
Visual Basic
Public Overrides Function GetInformationByIp ( _
    ipfrom As String, _
    ipto As String _
) As WhoIsInformation
Visual C++
public:
virtual WhoIsInformation^ GetInformationByIp(
    String^ ipfrom,
    String^ ipto
) override

Parameters

ipfrom
Type: System..::..String
The ip from.
ipto
Type: System..::..String
The ip to.

Return Value

The information by IP.

See Also

HexillionProvider Class
Sitecore.Analytics.Lookups Namespace


HexillionProvider Properties

[image] [image]

Sitecore 6.4.1 API
HexillionProvider Properties
HexillionProvider Class See Also Send Feedback

The HexillionProvider type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

HexillionProvider Class
Sitecore.Analytics.Lookups Namespace


LookupData Class

[image]

Sitecore 6.4.1 API
LookupData Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class LookupData
Visual Basic
Public Class LookupData
Visual C++
public ref class LookupData

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Lookups..::..LookupData

See Also

LookupData Members
Sitecore.Analytics.Lookups Namespace


LookupData Members

[image] [image]

Sitecore 6.4.1 API
LookupData Members
LookupData Class Constructors Methods Properties See Also Send Feedback

The LookupData type exposes the following members.

Constructors

 | Name | Description
Public method | LookupData | Initializes a new instance of the LookupData class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IpFrom | Gets or sets the IP address.
Public property | IpId | Gets or sets the IP owner id.
Public property | IpTo | Gets or sets the ip to.

See Also

LookupData Class
Sitecore.Analytics.Lookups Namespace


LookupData Constructor

[image]

Sitecore 6.4.1 API
LookupData Constructor
LookupData Class See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public LookupData()
Visual Basic
Public Sub New
Visual C++
public:
LookupData()

See Also

LookupData Class
Sitecore.Analytics.Lookups Namespace


LookupData Methods

[image] [image]

Sitecore 6.4.1 API
LookupData Methods
LookupData Class See Also Send Feedback

The LookupData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LookupData Class
Sitecore.Analytics.Lookups Namespace


LookupData Properties

[image] [image]

Sitecore 6.4.1 API
LookupData Properties
LookupData Class See Also Send Feedback

The LookupData type exposes the following members.

Properties

 | Name | Description
Public property | IpFrom | Gets or sets the IP address.
Public property | IpId | Gets or sets the IP owner id.
Public property | IpTo | Gets or sets the ip to.

See Also

LookupData Class
Sitecore.Analytics.Lookups Namespace


IpFrom Property

[image]

Sitecore 6.4.1 API
LookupData..::..IpFrom Property
LookupData Class See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string IpFrom { get; set; }
Visual Basic
Public Property IpFrom As String
    Get
    Set
Visual C++
public:
property String^ IpFrom {
    String^ get ();
    void set (String^ value);
}

Field Value

The IP address.

See Also

LookupData Class
Sitecore.Analytics.Lookups Namespace


IpId Property

[image]

Sitecore 6.4.1 API
LookupData..::..IpId Property
LookupData Class See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid IpId { get; set; }
Visual Basic
Public Property IpId As Guid
    Get
    Set
Visual C++
public:
property Guid IpId {
    Guid get ();
    void set (Guid value);
}

Field Value

The IP owner id.

See Also

LookupData Class
Sitecore.Analytics.Lookups Namespace


IpTo Property

[image]

Sitecore 6.4.1 API
LookupData..::..IpTo Property
LookupData Class See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string IpTo { get; set; }
Visual Basic
Public Property IpTo As String
    Get
    Set
Visual C++
public:
property String^ IpTo {
    String^ get ();
    void set (String^ value);
}

Field Value

The ip to.

See Also

LookupData Class
Sitecore.Analytics.Lookups Namespace


LookupManager Class

[image]

Sitecore 6.4.1 API
LookupManager Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class LookupManager
Visual Basic
Public Class LookupManager
Visual C++
public ref class LookupManager

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Lookups..::..LookupManager

See Also

LookupManager Members
Sitecore.Analytics.Lookups Namespace


LookupManager Members

[image] [image]

Sitecore 6.4.1 API
LookupManager Members
LookupManager Class Constructors Methods Properties See Also Send Feedback

The LookupManager type exposes the following members.

Constructors

 | Name | Description
Public method | LookupManager | Initializes a new instance of the LookupManager class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInformationByIp | Gets the information by IP.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReverseDnsLookup | Reverses the DNS lookup.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Provider | Gets the providers.
Providers | Gets the providers.

See Also

LookupManager Class
Sitecore.Analytics.Lookups Namespace


LookupManager Constructor

[image]

Sitecore 6.4.1 API
LookupManager Constructor
LookupManager Class See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public LookupManager()
Visual Basic
Public Sub New
Visual C++
public:
LookupManager()

See Also

LookupManager Class
Sitecore.Analytics.Lookups Namespace


GetInformationByIp Method

[image]

Sitecore 6.4.1 API
LookupManager..::..GetInformationByIp Method
LookupManager Class See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static WhoIsInformation GetInformationByIp(
    string ipFrom,
    string ipTo
)
Visual Basic
Public Shared Function GetInformationByIp ( _
    ipFrom As String, _
    ipTo As String _
) As WhoIsInformation
Visual C++
public:
static WhoIsInformation^ GetInformationByIp(
    String^ ipFrom,
    String^ ipTo
)

Parameters

ipFrom
Type: System..::..String
The ip from.
ipTo
Type: System..::..String
The ip to.

Return Value

The information by IP.

See Also

LookupManager Class
Sitecore.Analytics.Lookups Namespace


ReverseDnsLookup Method

[image]

Sitecore 6.4.1 API
LookupManager..::..ReverseDnsLookup Method
LookupManager Class See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static string ReverseDnsLookup(
    string ip
)
Visual Basic
Public Shared Function ReverseDnsLookup ( _
    ip As String _
) As String
Visual C++
public:
static String^ ReverseDnsLookup(
    String^ ip
)

Parameters

ip
Type: System..::..String
The ip.

Return Value

The DNS lookup.

See Also

LookupManager Class
Sitecore.Analytics.Lookups Namespace


LookupManager Properties

[image] [image]

Sitecore 6.4.1 API
LookupManager Properties
LookupManager Class See Also Send Feedback

The LookupManager type exposes the following members.

Properties

Name | Description
Provider | Gets the providers.
Providers | Gets the providers.

See Also

LookupManager Class
Sitecore.Analytics.Lookups Namespace


Provider Property

[image]

Sitecore 6.4.1 API
LookupManager..::..Provider Property
LookupManager Class See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static LookupProviderBase Provider { get; }
Visual Basic
Public Shared ReadOnly Property Provider As LookupProviderBase
    Get
Visual C++
public:
static property LookupProviderBase^ Provider {
    LookupProviderBase^ get ();
}

Field Value

The providers.

See Also

LookupManager Class
Sitecore.Analytics.Lookups Namespace


Providers Property

[image]

Sitecore 6.4.1 API
LookupManager..::..Providers Property
LookupManager Class See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static LookupProviderCollection Providers { get; }
Visual Basic
Public Shared ReadOnly Property Providers As LookupProviderCollection
    Get
Visual C++
public:
static property LookupProviderCollection^ Providers {
    LookupProviderCollection^ get ();
}

Field Value

The providers.

See Also

LookupManager Class
Sitecore.Analytics.Lookups Namespace


LookupProviderBase Class

[image]

Sitecore 6.4.1 API
LookupProviderBase Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract class LookupProviderBase : ProviderBase
Visual Basic
Public MustInherit Class LookupProviderBase _
    Inherits ProviderBase
Visual C++
public ref class LookupProviderBase abstract : public ProviderBase

Inheritance Hierarchy

System..::..Object
System.Configuration.Provider..::..ProviderBase
Sitecore.Analytics.Lookups..::..LookupProviderBase
Sitecore.Analytics.Lookups..::..HexillionProvider
Sitecore.Analytics.Lookups..::..MaxMindProvider

See Also

LookupProviderBase Members
Sitecore.Analytics.Lookups Namespace


LookupProviderBase Members

[image] [image]

Sitecore 6.4.1 API
LookupProviderBase Members
LookupProviderBase Class Constructors Methods Properties See Also Send Feedback

The LookupProviderBase type exposes the following members.

Constructors

 | Name | Description
Protected method | LookupProviderBase | Initializes a new instance of the LookupProviderBase class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInformationByIp | Gets the information by IP.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the provider. (Inherited from ProviderBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReverseDnsLookup | Reverses the DNS lookup.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

LookupProviderBase Class
Sitecore.Analytics.Lookups Namespace


LookupProviderBase Constructor

[image]

Sitecore 6.4.1 API
LookupProviderBase Constructor
LookupProviderBase Class See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected LookupProviderBase()
Visual Basic
Protected Sub New
Visual C++
protected:
LookupProviderBase()

See Also

LookupProviderBase Class
Sitecore.Analytics.Lookups Namespace


LookupProviderBase Methods

[image] [image]

Sitecore 6.4.1 API
LookupProviderBase Methods
LookupProviderBase Class See Also Send Feedback

The LookupProviderBase type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInformationByIp | Gets the information by IP.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the provider. (Inherited from ProviderBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReverseDnsLookup | Reverses the DNS lookup.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LookupProviderBase Class
Sitecore.Analytics.Lookups Namespace


GetInformationByIp Method

[image]

Sitecore 6.4.1 API
LookupProviderBase..::..GetInformationByIp Method
LookupProviderBase Class See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract WhoIsInformation GetInformationByIp(
    string ipfrom,
    string ipto
)
Visual Basic
Public MustOverride Function GetInformationByIp ( _
    ipfrom As String, _
    ipto As String _
) As WhoIsInformation
Visual C++
public:
virtual WhoIsInformation^ GetInformationByIp(
    String^ ipfrom,
    String^ ipto
) abstract

Parameters

ipfrom
Type: System..::..String
The ip from.
ipto
Type: System..::..String
The ip to.

Return Value

The information by IP.

See Also

LookupProviderBase Class
Sitecore.Analytics.Lookups Namespace


ReverseDnsLookup Method

[image]

Sitecore 6.4.1 API
LookupProviderBase..::..ReverseDnsLookup Method
LookupProviderBase Class See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual string ReverseDnsLookup(
    string ip
)
Visual Basic
Public Overridable Function ReverseDnsLookup ( _
    ip As String _
) As String
Visual C++
public:
virtual String^ ReverseDnsLookup(
    String^ ip
)

Parameters

ip
Type: System..::..String
The ip.

Return Value

The DNS lookup.

See Also

LookupProviderBase Class
Sitecore.Analytics.Lookups Namespace


LookupProviderBase Properties

[image] [image]

Sitecore 6.4.1 API
LookupProviderBase Properties
LookupProviderBase Class See Also Send Feedback

The LookupProviderBase type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

LookupProviderBase Class
Sitecore.Analytics.Lookups Namespace


LookupProviderCollection Class

[image]

Sitecore 6.4.1 API
LookupProviderCollection Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class LookupProviderCollection : ProviderCollection
Visual Basic
Public Class LookupProviderCollection _
    Inherits ProviderCollection
Visual C++
public ref class LookupProviderCollection : public ProviderCollection

Inheritance Hierarchy

System..::..Object
System.Configuration.Provider..::..ProviderCollection
Sitecore.Analytics.Lookups..::..LookupProviderCollection

See Also

LookupProviderCollection Members
Sitecore.Analytics.Lookups Namespace


LookupProviderCollection Members

[image] [image]

Sitecore 6.4.1 API
LookupProviderCollection Members
LookupProviderCollection Class Constructors Methods Properties See Also Send Feedback

The LookupProviderCollection type exposes the following members.

Constructors

 | Name | Description
Public method | LookupProviderCollection | Initializes a new instance of the LookupProviderCollection class

Methods

 | Name | Description
Public method | Add(ProviderBase) | Adds a provider to the collection. (Overrides ProviderCollection..::..Add(ProviderBase).)
Public method | Add(LookupProviderBase) | Adds the specified provider.
Public method | Clear | Removes all items from the collection. (Inherited from ProviderCollection.)
Public method | CopyTo | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a provider from the collection. (Inherited from ProviderCollection.)
Public method | SetReadOnly | Sets the collection to be read-only. (Inherited from ProviderCollection.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
Public property | Item | Gets the LookupProviderBase with the specified name.
Public property | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)

See Also

LookupProviderCollection Class
Sitecore.Analytics.Lookups Namespace


LookupProviderCollection Constructor

[image]

Sitecore 6.4.1 API
LookupProviderCollection Constructor
LookupProviderCollection Class See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public LookupProviderCollection()
Visual Basic
Public Sub New
Visual C++
public:
LookupProviderCollection()

See Also

LookupProviderCollection Class
Sitecore.Analytics.Lookups Namespace


LookupProviderCollection Methods

[image] [image]

Sitecore 6.4.1 API
LookupProviderCollection Methods
LookupProviderCollection Class See Also Send Feedback

The LookupProviderCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add(ProviderBase) | Adds a provider to the collection. (Overrides ProviderCollection..::..Add(ProviderBase).)
Public method | Add(LookupProviderBase) | Adds the specified provider.
Public method | Clear | Removes all items from the collection. (Inherited from ProviderCollection.)
Public method | CopyTo | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a provider from the collection. (Inherited from ProviderCollection.)
Public method | SetReadOnly | Sets the collection to be read-only. (Inherited from ProviderCollection.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LookupProviderCollection Class
Sitecore.Analytics.Lookups Namespace


Add Method

[image] [image]

Sitecore 6.4.1 API
LookupProviderCollection..::..Add Method
LookupProviderCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(ProviderBase) | Adds a provider to the collection. (Overrides ProviderCollection..::..Add(ProviderBase).)
Public method | Add(LookupProviderBase) | Adds the specified provider.

See Also

LookupProviderCollection Class
LookupProviderCollection Members
Sitecore.Analytics.Lookups Namespace


Add Method (LookupProviderBase)

[image]

Sitecore 6.4.1 API
LookupProviderCollection..::..Add Method (LookupProviderBase)
LookupProviderCollection Class See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual void Add(
    LookupProviderBase provider
)
Visual Basic
Public Overridable Sub Add ( _
    provider As LookupProviderBase _
)
Visual C++
public:
virtual void Add(
    LookupProviderBase^ provider
)

Parameters

provider
Type: Sitecore.Analytics.Lookups..::..LookupProviderBase
The provider.

See Also

LookupProviderCollection Class
Add Overload
Sitecore.Analytics.Lookups Namespace


LookupProviderCollection Properties

[image] [image]

Sitecore 6.4.1 API
LookupProviderCollection Properties
LookupProviderCollection Class See Also Send Feedback

The LookupProviderCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
Public property | Item | Gets the LookupProviderBase with the specified name.
Public property | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)

See Also

LookupProviderCollection Class
Sitecore.Analytics.Lookups Namespace


Item Property

[image]

Sitecore 6.4.1 API
LookupProviderCollection..::..Item Property
LookupProviderCollection Class See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual LookupProviderBase this[
    string name
] { get; }
Visual Basic
Public Overridable ReadOnly Default Property Item ( _
    name As String _
) As LookupProviderBase
    Get
Visual C++
public:
virtual property LookupProviderBase^ default[String^ name] {
    LookupProviderBase^ get (String^ name);
}

Parameters

name
Type: System..::..String
The name of the provider.

Field Value

The selected provider.

See Also

LookupProviderCollection Class
Sitecore.Analytics.Lookups Namespace


LookupUpdater Class

[image]

Sitecore 6.4.1 API
LookupUpdater Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static class LookupUpdater
Visual Basic
Public NotInheritable Class LookupUpdater
Visual C++
public ref class LookupUpdater abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Lookups..::..LookupUpdater

See Also

LookupUpdater Members
Sitecore.Analytics.Lookups Namespace


LookupUpdater Members

[image] [image]

Sitecore 6.4.1 API
LookupUpdater Members
LookupUpdater Class Methods See Also Send Feedback

The LookupUpdater type exposes the following members.

Methods

Name | Description
Process | update lookup.

See Also

LookupUpdater Class
Sitecore.Analytics.Lookups Namespace


LookupUpdater Methods

[image] [image]

Sitecore 6.4.1 API
LookupUpdater Methods
LookupUpdater Class See Also Send Feedback

The LookupUpdater type exposes the following members.

Methods

Name | Description
Process | update lookup.

See Also

LookupUpdater Class
Sitecore.Analytics.Lookups Namespace


Process Method

[image]

Sitecore 6.4.1 API
LookupUpdater..::..Process Method
LookupUpdater Class See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void Process(
    LookupData item
)
Visual Basic
Public Shared Sub Process ( _
    item As LookupData _
)
Visual C++
public:
static void Process(
    LookupData^ item
)

Parameters

item
Type: Sitecore.Analytics.Lookups..::..LookupData
The item.

See Also

LookupUpdater Class
Sitecore.Analytics.Lookups Namespace


LookupWorker Class

[image]

Sitecore 6.4.1 API
LookupWorker Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static class LookupWorker
Visual Basic
Public NotInheritable Class LookupWorker
Visual C++
public ref class LookupWorker abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Lookups..::..LookupWorker

See Also

LookupWorker Members
Sitecore.Analytics.Lookups Namespace


LookupWorker Members

[image] [image]

Sitecore 6.4.1 API
LookupWorker Members
LookupWorker Class Methods See Also Send Feedback

The LookupWorker type exposes the following members.

Methods

Name | Description
Start | Starts this instance.

See Also

LookupWorker Class
Sitecore.Analytics.Lookups Namespace


LookupWorker Methods

[image] [image]

Sitecore 6.4.1 API
LookupWorker Methods
LookupWorker Class See Also Send Feedback

The LookupWorker type exposes the following members.

Methods

Name | Description
Start | Starts this instance.

See Also

LookupWorker Class
Sitecore.Analytics.Lookups Namespace


Start Method

[image]

Sitecore 6.4.1 API
LookupWorker..::..Start Method
LookupWorker Class See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void Start()
Visual Basic
Public Shared Sub Start
Visual C++
public:
static void Start()

See Also

LookupWorker Class
Sitecore.Analytics.Lookups Namespace


MaxMindProvider Class

[image]

Sitecore 6.4.1 API
MaxMindProvider Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class MaxMindProvider : LookupProviderBase
Visual Basic
Public Class MaxMindProvider _
    Inherits LookupProviderBase
Visual C++
public ref class MaxMindProvider : public LookupProviderBase

Inheritance Hierarchy

System..::..Object
System.Configuration.Provider..::..ProviderBase
Sitecore.Analytics.Lookups..::..LookupProviderBase
Sitecore.Analytics.Lookups..::..MaxMindProvider

See Also

MaxMindProvider Members
Sitecore.Analytics.Lookups Namespace


MaxMindProvider Members

[image] [image]

Sitecore 6.4.1 API
MaxMindProvider Members
MaxMindProvider Class Constructors Methods Properties See Also Send Feedback

The MaxMindProvider type exposes the following members.

Constructors

 | Name | Description
Public method | MaxMindProvider | Initializes a new instance of the MaxMindProvider class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInformationByIp | Gets the information by IP. (Overrides LookupProviderBase..::..GetInformationByIp(String, String).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the provider. (Inherited from ProviderBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReverseDnsLookup | Reverses the DNS lookup. (Inherited from LookupProviderBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

MaxMindProvider Class
Sitecore.Analytics.Lookups Namespace


MaxMindProvider Constructor

[image]

Sitecore 6.4.1 API
MaxMindProvider Constructor
MaxMindProvider Class See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public MaxMindProvider()
Visual Basic
Public Sub New
Visual C++
public:
MaxMindProvider()

See Also

MaxMindProvider Class
Sitecore.Analytics.Lookups Namespace


MaxMindProvider Methods

[image] [image]

Sitecore 6.4.1 API
MaxMindProvider Methods
MaxMindProvider Class See Also Send Feedback

The MaxMindProvider type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInformationByIp | Gets the information by IP. (Overrides LookupProviderBase..::..GetInformationByIp(String, String).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the provider. (Inherited from ProviderBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReverseDnsLookup | Reverses the DNS lookup. (Inherited from LookupProviderBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MaxMindProvider Class
Sitecore.Analytics.Lookups Namespace


MaxMindProvider Properties

[image] [image]

Sitecore 6.4.1 API
MaxMindProvider Properties
MaxMindProvider Class See Also Send Feedback

The MaxMindProvider type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

MaxMindProvider Class
Sitecore.Analytics.Lookups Namespace


UpdateOperation Enumeration

[image]

Sitecore 6.4.1 API
UpdateOperation Enumeration
See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public enum UpdateOperation
Visual Basic
Public Enumeration UpdateOperation
Visual C++
public enum class UpdateOperation

Members

Member name | Value | Description
All | 0 | "All".
Blanks | 1 | "Blanks".

See Also

Sitecore.Analytics.Lookups Namespace


WhoIsInformation Members

[image] [image]

Sitecore 6.4.1 API
WhoIsInformation Members
WhoIsInformation Class Constructors Methods Properties See Also Send Feedback

The WhoIsInformation type exposes the following members.

Constructors

 | Name | Description
Public method | WhoIsInformation | Initializes a new instance of the WhoIsInformation class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AreaCode | Gets or sets the area code.
Public property | City | Gets or sets the city.
Public property | Country | Gets or sets the country.
Public property | Dns | Gets or sets the reverse DNS.
Public property | Ip | Gets or sets the IP.
Public property | Isp | Gets or sets the ISP name.
Public property | Latitude | Gets or sets the latitude.
Public property | Longitude | Gets or sets the longitude.
Public property | MetroCode | Gets or sets the metro code.
Public property | Name | Gets or sets the owner.
Public property | PostalCode | Gets or sets the postal code.
Public property | Region | Gets or sets the region.
Public property | Url | Gets or sets the URL.

See Also

WhoIsInformation Class
Sitecore.Analytics.Lookups Namespace


WhoIsInformation Constructor

[image]

Sitecore 6.4.1 API
WhoIsInformation Constructor
WhoIsInformation Class See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public WhoIsInformation()
Visual Basic
Public Sub New
Visual C++
public:
WhoIsInformation()

See Also

WhoIsInformation Class
Sitecore.Analytics.Lookups Namespace


WhoIsInformation Methods

[image] [image]

Sitecore 6.4.1 API
WhoIsInformation Methods
WhoIsInformation Class See Also Send Feedback

The WhoIsInformation type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WhoIsInformation Class
Sitecore.Analytics.Lookups Namespace


WhoIsInformation Properties

[image] [image]

Sitecore 6.4.1 API
WhoIsInformation Properties
WhoIsInformation Class See Also Send Feedback

The WhoIsInformation type exposes the following members.

Properties

 | Name | Description
Public property | AreaCode | Gets or sets the area code.
Public property | City | Gets or sets the city.
Public property | Country | Gets or sets the country.
Public property | Dns | Gets or sets the reverse DNS.
Public property | Ip | Gets or sets the IP.
Public property | Isp | Gets or sets the ISP name.
Public property | Latitude | Gets or sets the latitude.
Public property | Longitude | Gets or sets the longitude.
Public property | MetroCode | Gets or sets the metro code.
Public property | Name | Gets or sets the owner.
Public property | PostalCode | Gets or sets the postal code.
Public property | Region | Gets or sets the region.
Public property | Url | Gets or sets the URL.

See Also

WhoIsInformation Class
Sitecore.Analytics.Lookups Namespace


AreaCode Property

[image]

Sitecore 6.4.1 API
WhoIsInformation..::..AreaCode Property
WhoIsInformation Class See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string AreaCode { get; set; }
Visual Basic
Public Property AreaCode As String
    Get
    Set
Visual C++
public:
property String^ AreaCode {
    String^ get ();
    void set (String^ value);
}

Field Value

The area code.

See Also

WhoIsInformation Class
Sitecore.Analytics.Lookups Namespace


City Property

[image]

Sitecore 6.4.1 API
WhoIsInformation..::..City Property
WhoIsInformation Class See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string City { get; set; }
Visual Basic
Public Property City As String
    Get
    Set
Visual C++
public:
property String^ City {
    String^ get ();
    void set (String^ value);
}

Field Value

The city name.

See Also

WhoIsInformation Class
Sitecore.Analytics.Lookups Namespace


Country Property

[image]

Sitecore 6.4.1 API
WhoIsInformation..::..Country Property
WhoIsInformation Class See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Country { get; set; }
Visual Basic
Public Property Country As String
    Get
    Set
Visual C++
public:
property String^ Country {
    String^ get ();
    void set (String^ value);
}

Field Value

The country.

See Also

WhoIsInformation Class
Sitecore.Analytics.Lookups Namespace


Dns Property

[image]

Sitecore 6.4.1 API
WhoIsInformation..::..Dns Property
WhoIsInformation Class See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Dns { get; set; }
Visual Basic
Public Property Dns As String
    Get
    Set
Visual C++
public:
property String^ Dns {
    String^ get ();
    void set (String^ value);
}

Field Value

The reverse DNS.

See Also

WhoIsInformation Class
Sitecore.Analytics.Lookups Namespace


Ip Property

[image]

Sitecore 6.4.1 API
WhoIsInformation..::..Ip Property
WhoIsInformation Class See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Ip { get; set; }
Visual Basic
Public Property Ip As String
    Get
    Set
Visual C++
public:
property String^ Ip {
    String^ get ();
    void set (String^ value);
}

Field Value

The IP address.

See Also

WhoIsInformation Class
Sitecore.Analytics.Lookups Namespace


Isp Property

[image]

Sitecore 6.4.1 API
WhoIsInformation..::..Isp Property
WhoIsInformation Class See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Isp { get; set; }
Visual Basic
Public Property Isp As String
    Get
    Set
Visual C++
public:
property String^ Isp {
    String^ get ();
    void set (String^ value);
}

Field Value

The ISP name.

See Also

WhoIsInformation Class
Sitecore.Analytics.Lookups Namespace


Latitude Property

[image]

Sitecore 6.4.1 API
WhoIsInformation..::..Latitude Property
WhoIsInformation Class See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Latitude { get; set; }
Visual Basic
Public Property Latitude As String
    Get
    Set
Visual C++
public:
property String^ Latitude {
    String^ get ();
    void set (String^ value);
}

Field Value

The latitude.

See Also

WhoIsInformation Class
Sitecore.Analytics.Lookups Namespace


Longitude Property

[image]

Sitecore 6.4.1 API
WhoIsInformation..::..Longitude Property
WhoIsInformation Class See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Longitude { get; set; }
Visual Basic
Public Property Longitude As String
    Get
    Set
Visual C++
public:
property String^ Longitude {
    String^ get ();
    void set (String^ value);
}

Field Value

The longitude.

See Also

WhoIsInformation Class
Sitecore.Analytics.Lookups Namespace


MetroCode Property

[image]

Sitecore 6.4.1 API
WhoIsInformation..::..MetroCode Property
WhoIsInformation Class See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string MetroCode { get; set; }
Visual Basic
Public Property MetroCode As String
    Get
    Set
Visual C++
public:
property String^ MetroCode {
    String^ get ();
    void set (String^ value);
}

Field Value

The metro code.

See Also

WhoIsInformation Class
Sitecore.Analytics.Lookups Namespace


Name Property

[image]

Sitecore 6.4.1 API
WhoIsInformation..::..Name Property
WhoIsInformation Class See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Field Value

The owner.

See Also

WhoIsInformation Class
Sitecore.Analytics.Lookups Namespace


PostalCode Property

[image]

Sitecore 6.4.1 API
WhoIsInformation..::..PostalCode Property
WhoIsInformation Class See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string PostalCode { get; set; }
Visual Basic
Public Property PostalCode As String
    Get
    Set
Visual C++
public:
property String^ PostalCode {
    String^ get ();
    void set (String^ value);
}

Field Value

The postal code.

See Also

WhoIsInformation Class
Sitecore.Analytics.Lookups Namespace


Region Property

[image]

Sitecore 6.4.1 API
WhoIsInformation..::..Region Property
WhoIsInformation Class See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Region { get; set; }
Visual Basic
Public Property Region As String
    Get
    Set
Visual C++
public:
property String^ Region {
    String^ get ();
    void set (String^ value);
}

Field Value

The region.

See Also

WhoIsInformation Class
Sitecore.Analytics.Lookups Namespace


Url Property

[image]

Sitecore 6.4.1 API
WhoIsInformation..::..Url Property
WhoIsInformation Class See Also Send Feedback

Namespace: Sitecore.Analytics.Lookups
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Url { get; set; }
Visual Basic
Public Property Url As String
    Get
    Set
Visual C++
public:
property String^ Url {
    String^ get ();
    void set (String^ value);
}

Field Value

The URL address.

See Also

WhoIsInformation Class
Sitecore.Analytics.Lookups Namespace


Sitecore.Analytics.Media Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Analytics.Media Namespace
Send Feedback

Classes

 | Class | Description
Public class | MediaRequestEventHandler | Defines the media request event handler class.


MediaRequestEventHandler Members

[image] [image]

Sitecore 6.4.1 API
MediaRequestEventHandler Members
MediaRequestEventHandler Class Constructors Methods See Also Send Feedback

The MediaRequestEventHandler type exposes the following members.

Constructors

 | Name | Description
Public method | MediaRequestEventHandler | Initializes a new instance of the MediaRequestEventHandler class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnMediaRequest | Called when the media has request.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MediaRequestEventHandler Class
Sitecore.Analytics.Media Namespace


MediaRequestEventHandler Constructor

[image]

Sitecore 6.4.1 API
MediaRequestEventHandler Constructor
MediaRequestEventHandler Class See Also Send Feedback

Namespace: Sitecore.Analytics.Media
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public MediaRequestEventHandler()
Visual Basic
Public Sub New
Visual C++
public:
MediaRequestEventHandler()

See Also

MediaRequestEventHandler Class
Sitecore.Analytics.Media Namespace


OnMediaRequest Method

[image]

Sitecore 6.4.1 API
MediaRequestEventHandler..::..OnMediaRequest Method
MediaRequestEventHandler Class See Also Send Feedback

Namespace: Sitecore.Analytics.Media
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void OnMediaRequest(
    Object sender,
    EventArgs args
)
Visual Basic
Public Sub OnMediaRequest ( _
    sender As Object, _
    args As EventArgs _
)
Visual C++
public:
void OnMediaRequest(
    Object^ sender,
    EventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: System..::..EventArgs
The arguments.

See Also

MediaRequestEventHandler Class
Sitecore.Analytics.Media Namespace


SqlProcessorBase Class

[image]

Sitecore 6.4.1 API
SqlProcessorBase Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract class SqlProcessorBase
Visual Basic
Public MustInherit Class SqlProcessorBase
Visual C++
public ref class SqlProcessorBase abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines..::..SqlProcessorBase
Sitecore.Analytics.Pipelines.CreateSession..::..CreateSessionProcessor
Sitecore.Analytics.Pipelines.Submit..::..SubmitProcessor
Sitecore.Analytics.Pipelines.SubmitPage..::..SubmitPageProcessor
Sitecore.Analytics.Pipelines.SubmitTests..::..SubmitTestsProcessor

See Also

SqlProcessorBase Members
Sitecore.Analytics.Pipelines Namespace


SqlProcessorBase Members

[image] [image]

Sitecore 6.4.1 API
SqlProcessorBase Members
SqlProcessorBase Class Constructors Methods See Also Send Feedback

The SqlProcessorBase type exposes the following members.

Constructors

 | Name | Description
Protected method | SqlProcessorBase | Initializes a new instance of the SqlProcessorBase class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SqlProcessorBase Class
Sitecore.Analytics.Pipelines Namespace


SqlProcessorBase Constructor

[image]

Sitecore 6.4.1 API
SqlProcessorBase Constructor
SqlProcessorBase Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected SqlProcessorBase()
Visual Basic
Protected Sub New
Visual C++
protected:
SqlProcessorBase()

See Also

SqlProcessorBase Class
Sitecore.Analytics.Pipelines Namespace


SqlProcessorBase Methods

[image] [image]

Sitecore 6.4.1 API
SqlProcessorBase Methods
SqlProcessorBase Class See Also Send Feedback

The SqlProcessorBase type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SqlProcessorBase Class
Sitecore.Analytics.Pipelines Namespace


Sitecore.Analytics.Pipelines.CreateSession Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Analytics.Pipelines.CreateSession Namespace
Send Feedback

Classes

 | Class | Description
Public class | CreateSessionArgs | Defines the start tracking args class.
Public class | CreateSessionPipeline | Defines the submit pipeline class.
Public class | CreateSessionProcessor | Defines the start tracking processor class.
Public class | GetBrowser | Defines the get keywords class.
Public class | GetGlobalSession | Defines the get keywords class.
Public class | GetIpAddress | Defines the process query string class.
Public class | GetKeywords | Defines the get keywords class.
Public class | GetOperatingSystem | Defines the get operating system class.
Public class | GetReferringSite | Defines the get referring site class.
Public class | GetScreen | Defines the get screen class.
Public class | InitializeSession | Defines the process query string class.


CreateSessionArgs Constructor

[image] [image]

Sitecore 6.4.1 API
CreateSessionArgs Constructor
CreateSessionArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateSessionArgs()()()() | Initializes a new instance of the CreateSessionArgs class.
Protected method | CreateSessionArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the CreateSessionArgs class. Initializes a new instance of the StartTrackingArgs class.

See Also

CreateSessionArgs Class
CreateSessionArgs Members
Sitecore.Analytics.Pipelines.CreateSession Namespace


CreateSessionArgs Constructor

[image]

Sitecore 6.4.1 API
CreateSessionArgs Constructor
CreateSessionArgs Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.CreateSession
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public CreateSessionArgs()
Visual Basic
Public Sub New
Visual C++
public:
CreateSessionArgs()

See Also

CreateSessionArgs Class
CreateSessionArgs Overload
Sitecore.Analytics.Pipelines.CreateSession Namespace


CreateSessionArgs Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
CreateSessionArgs Constructor (SerializationInfo, StreamingContext)
CreateSessionArgs Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.CreateSession
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected CreateSessionArgs(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
CreateSessionArgs(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

CreateSessionArgs Class
CreateSessionArgs Overload
Sitecore.Analytics.Pipelines.CreateSession Namespace


CreateSessionArgs Methods

[image] [image]

Sitecore 6.4.1 API
CreateSessionArgs Methods
CreateSessionArgs Class See Also Send Feedback

The CreateSessionArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CreateSessionArgs Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
CreateSessionArgs..::..AddMessage Method
CreateSessionArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

CreateSessionArgs Class
CreateSessionArgs Members
Sitecore.Analytics.Pipelines.CreateSession Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
CreateSessionArgs..::..GetMessages Method
CreateSessionArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

CreateSessionArgs Class
CreateSessionArgs Members
Sitecore.Analytics.Pipelines.CreateSession Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
CreateSessionArgs..::..Suspend Method
CreateSessionArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

CreateSessionArgs Class
CreateSessionArgs Members
Sitecore.Analytics.Pipelines.CreateSession Namespace


CreateSessionArgs Properties

[image] [image]

Sitecore 6.4.1 API
CreateSessionArgs Properties
CreateSessionArgs Class See Also Send Feedback

The CreateSessionArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | AnalyticsTracker | Gets or sets the analytics tracker.
Public property | CanBeRobot | Gets or sets a value indicating whether this instance is not robot.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Session | Gets or sets the session.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

CreateSessionArgs Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


AnalyticsTracker Property

[image]

Sitecore 6.4.1 API
CreateSessionArgs..::..AnalyticsTracker Property
CreateSessionArgs Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.CreateSession
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public AnalyticsTracker AnalyticsTracker { get; set; }
Visual Basic
Public Property AnalyticsTracker As AnalyticsTracker
    Get
    Set
Visual C++
public:
property AnalyticsTracker^ AnalyticsTracker {
    AnalyticsTracker^ get ();
    void set (AnalyticsTracker^ value);
}

Field Value

The analytics tracker.

See Also

CreateSessionArgs Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


CanBeRobot Property

[image]

Sitecore 6.4.1 API
CreateSessionArgs..::..CanBeRobot Property
CreateSessionArgs Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.CreateSession
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public bool CanBeRobot { get; set; }
Visual Basic
Public Property CanBeRobot As Boolean
    Get
    Set
Visual C++
public:
property bool CanBeRobot {
    bool get ();
    void set (bool value);
}

Field Value

true if this instance is not robot; otherwise, false.

See Also

CreateSessionArgs Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


Session Property

[image]

Sitecore 6.4.1 API
CreateSessionArgs..::..Session Property
CreateSessionArgs Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.CreateSession
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Session Session { get; set; }
Visual Basic
Public Property Session As Session
    Get
    Set
Visual C++
public:
property Session^ Session {
    Session^ get ();
    void set (Session^ value);
}

Field Value

The session.

See Also

CreateSessionArgs Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


CreateSessionPipeline Class

[image]

Sitecore 6.4.1 API
CreateSessionPipeline Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.CreateSession
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class CreateSessionPipeline
Visual Basic
Public Class CreateSessionPipeline
Visual C++
public ref class CreateSessionPipeline

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines.CreateSession..::..CreateSessionPipeline

See Also

CreateSessionPipeline Members
Sitecore.Analytics.Pipelines.CreateSession Namespace


CreateSessionPipeline Members

[image] [image]

Sitecore 6.4.1 API
CreateSessionPipeline Members
CreateSessionPipeline Class Constructors Methods See Also Send Feedback

The CreateSessionPipeline type exposes the following members.

Constructors

 | Name | Description
Public method | CreateSessionPipeline | Initializes a new instance of the CreateSessionPipeline class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run | Runs the 'publish' pipeline with specified arguments.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CreateSessionPipeline Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


CreateSessionPipeline Constructor

[image]

Sitecore 6.4.1 API
CreateSessionPipeline Constructor
CreateSessionPipeline Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.CreateSession
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public CreateSessionPipeline()
Visual Basic
Public Sub New
Visual C++
public:
CreateSessionPipeline()

See Also

CreateSessionPipeline Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


CreateSessionPipeline Methods

[image] [image]

Sitecore 6.4.1 API
CreateSessionPipeline Methods
CreateSessionPipeline Class See Also Send Feedback

The CreateSessionPipeline type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run | Runs the 'publish' pipeline with specified arguments.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CreateSessionPipeline Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


Run Method

[image]

Sitecore 6.4.1 API
CreateSessionPipeline..::..Run Method
CreateSessionPipeline Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.CreateSession
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void Run(
    CreateSessionArgs args
)
Visual Basic
Public Shared Sub Run ( _
    args As CreateSessionArgs _
)
Visual C++
public:
static void Run(
    CreateSessionArgs^ args
)

Parameters

args
Type: Sitecore.Analytics.Pipelines.CreateSession..::..CreateSessionArgs
The arguments.

See Also

CreateSessionPipeline Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


CreateSessionProcessor Class

[image]

Sitecore 6.4.1 API
CreateSessionProcessor Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.CreateSession
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract class CreateSessionProcessor : SqlProcessorBase
Visual Basic
Public MustInherit Class CreateSessionProcessor _
    Inherits SqlProcessorBase
Visual C++
public ref class CreateSessionProcessor abstract : public SqlProcessorBase

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines..::..SqlProcessorBase
Sitecore.Analytics.Pipelines.CreateSession..::..CreateSessionProcessor
Sitecore.Analytics.Pipelines.CreateSession..::..GetBrowser
Sitecore.Analytics.Pipelines.CreateSession..::..GetGlobalSession
Sitecore.Analytics.Pipelines.CreateSession..::..GetIpAddress
Sitecore.Analytics.Pipelines.CreateSession..::..GetKeywords
Sitecore.Analytics.Pipelines.CreateSession..::..GetOperatingSystem
Sitecore.Analytics.Pipelines.CreateSession..::..GetReferringSite
Sitecore.Analytics.Pipelines.CreateSession..::..GetScreen
Sitecore.Analytics.Pipelines.CreateSession..::..InitializeSession

See Also

CreateSessionProcessor Members
Sitecore.Analytics.Pipelines.CreateSession Namespace


CreateSessionProcessor Members

[image] [image]

Sitecore 6.4.1 API
CreateSessionProcessor Members
CreateSessionProcessor Class Constructors Methods See Also Send Feedback

The CreateSessionProcessor type exposes the following members.

Constructors

 | Name | Description
Protected method | CreateSessionProcessor | Initializes a new instance of the CreateSessionProcessor class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CreateSessionProcessor Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


CreateSessionProcessor Constructor

[image]

Sitecore 6.4.1 API
CreateSessionProcessor Constructor
CreateSessionProcessor Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.CreateSession
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected CreateSessionProcessor()
Visual Basic
Protected Sub New
Visual C++
protected:
CreateSessionProcessor()

See Also

CreateSessionProcessor Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


CreateSessionProcessor Methods

[image] [image]

Sitecore 6.4.1 API
CreateSessionProcessor Methods
CreateSessionProcessor Class See Also Send Feedback

The CreateSessionProcessor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CreateSessionProcessor Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


Process Method

[image]

Sitecore 6.4.1 API
CreateSessionProcessor..::..Process Method
CreateSessionProcessor Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.CreateSession
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract void Process(
    CreateSessionArgs args
)
Visual Basic
Public MustOverride Sub Process ( _
    args As CreateSessionArgs _
)
Visual C++
public:
virtual void Process(
    CreateSessionArgs^ args
) abstract

Parameters

args
Type: Sitecore.Analytics.Pipelines.CreateSession..::..CreateSessionArgs
The arguments.

See Also

CreateSessionProcessor Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


GetBrowser Class

[image]

Sitecore 6.4.1 API
GetBrowser Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.CreateSession
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class GetBrowser : CreateSessionProcessor
Visual Basic
Public Class GetBrowser _
    Inherits CreateSessionProcessor
Visual C++
public ref class GetBrowser : public CreateSessionProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines..::..SqlProcessorBase
Sitecore.Analytics.Pipelines.CreateSession..::..CreateSessionProcessor
Sitecore.Analytics.Pipelines.CreateSession..::..GetBrowser

See Also

GetBrowser Members
Sitecore.Analytics.Pipelines.CreateSession Namespace


GetBrowser Members

[image] [image]

Sitecore 6.4.1 API
GetBrowser Members
GetBrowser Class Constructors Methods See Also Send Feedback

The GetBrowser type exposes the following members.

Constructors

 | Name | Description
Public method | GetBrowser | Initializes a new instance of the GetBrowser class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides CreateSessionProcessor..::..Process(CreateSessionArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetBrowser Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


GetBrowser Constructor

[image]

Sitecore 6.4.1 API
GetBrowser Constructor
GetBrowser Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.CreateSession
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public GetBrowser()
Visual Basic
Public Sub New
Visual C++
public:
GetBrowser()

See Also

GetBrowser Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


GetBrowser Methods

[image] [image]

Sitecore 6.4.1 API
GetBrowser Methods
GetBrowser Class See Also Send Feedback

The GetBrowser type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides CreateSessionProcessor..::..Process(CreateSessionArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetBrowser Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


Process Method

[image]

Sitecore 6.4.1 API
GetBrowser..::..Process Method
GetBrowser Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.CreateSession
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void Process(
    CreateSessionArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As CreateSessionArgs _
)
Visual C++
public:
virtual void Process(
    CreateSessionArgs^ args
) override

Parameters

args
Type: Sitecore.Analytics.Pipelines.CreateSession..::..CreateSessionArgs
The arguments.

See Also

GetBrowser Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


GetGlobalSession Members

[image] [image]

Sitecore 6.4.1 API
GetGlobalSession Members
GetGlobalSession Class Constructors Methods See Also Send Feedback

The GetGlobalSession type exposes the following members.

Constructors

 | Name | Description
Public method | GetGlobalSession | Initializes a new instance of the GetGlobalSession class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides CreateSessionProcessor..::..Process(CreateSessionArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetGlobalSession Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


GetGlobalSession Constructor

[image]

Sitecore 6.4.1 API
GetGlobalSession Constructor
GetGlobalSession Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.CreateSession
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public GetGlobalSession()
Visual Basic
Public Sub New
Visual C++
public:
GetGlobalSession()

See Also

GetGlobalSession Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


GetGlobalSession Methods

[image] [image]

Sitecore 6.4.1 API
GetGlobalSession Methods
GetGlobalSession Class See Also Send Feedback

The GetGlobalSession type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides CreateSessionProcessor..::..Process(CreateSessionArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetGlobalSession Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


Process Method

[image]

Sitecore 6.4.1 API
GetGlobalSession..::..Process Method
GetGlobalSession Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.CreateSession
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void Process(
    CreateSessionArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As CreateSessionArgs _
)
Visual C++
public:
virtual void Process(
    CreateSessionArgs^ args
) override

Parameters

args
Type: Sitecore.Analytics.Pipelines.CreateSession..::..CreateSessionArgs
The arguments.

See Also

GetGlobalSession Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


GetIpAddress Members

[image] [image]

Sitecore 6.4.1 API
GetIpAddress Members
GetIpAddress Class Constructors Methods See Also Send Feedback

The GetIpAddress type exposes the following members.

Constructors

 | Name | Description
Public method | GetIpAddress | Initializes a new instance of the GetIpAddress class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides CreateSessionProcessor..::..Process(CreateSessionArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetIpAddress Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


GetIpAddress Constructor

[image]

Sitecore 6.4.1 API
GetIpAddress Constructor
GetIpAddress Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.CreateSession
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public GetIpAddress()
Visual Basic
Public Sub New
Visual C++
public:
GetIpAddress()

See Also

GetIpAddress Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


GetIpAddress Methods

[image] [image]

Sitecore 6.4.1 API
GetIpAddress Methods
GetIpAddress Class See Also Send Feedback

The GetIpAddress type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides CreateSessionProcessor..::..Process(CreateSessionArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetIpAddress Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


Process Method

[image]

Sitecore 6.4.1 API
GetIpAddress..::..Process Method
GetIpAddress Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.CreateSession
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void Process(
    CreateSessionArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As CreateSessionArgs _
)
Visual C++
public:
virtual void Process(
    CreateSessionArgs^ args
) override

Parameters

args
Type: Sitecore.Analytics.Pipelines.CreateSession..::..CreateSessionArgs
The arguments.

See Also

GetIpAddress Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


GetKeywords Class

[image]

Sitecore 6.4.1 API
GetKeywords Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.CreateSession
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class GetKeywords : CreateSessionProcessor
Visual Basic
Public Class GetKeywords _
    Inherits CreateSessionProcessor
Visual C++
public ref class GetKeywords : public CreateSessionProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines..::..SqlProcessorBase
Sitecore.Analytics.Pipelines.CreateSession..::..CreateSessionProcessor
Sitecore.Analytics.Pipelines.CreateSession..::..GetKeywords

See Also

GetKeywords Members
Sitecore.Analytics.Pipelines.CreateSession Namespace


GetKeywords Members

[image] [image]

Sitecore 6.4.1 API
GetKeywords Members
GetKeywords Class Constructors Methods See Also Send Feedback

The GetKeywords type exposes the following members.

Constructors

 | Name | Description
Public method | GetKeywords | Initializes a new instance of the GetKeywords class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides CreateSessionProcessor..::..Process(CreateSessionArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetKeywords Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


GetKeywords Constructor

[image]

Sitecore 6.4.1 API
GetKeywords Constructor
GetKeywords Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.CreateSession
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public GetKeywords()
Visual Basic
Public Sub New
Visual C++
public:
GetKeywords()

See Also

GetKeywords Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


Process Method

[image]

Sitecore 6.4.1 API
GetKeywords..::..Process Method
GetKeywords Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.CreateSession
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void Process(
    CreateSessionArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As CreateSessionArgs _
)
Visual C++
public:
virtual void Process(
    CreateSessionArgs^ args
) override

Parameters

args
Type: Sitecore.Analytics.Pipelines.CreateSession..::..CreateSessionArgs
The arguments.

See Also

GetKeywords Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


GetOperatingSystem Class

[image]

Sitecore 6.4.1 API
GetOperatingSystem Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.CreateSession
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class GetOperatingSystem : CreateSessionProcessor
Visual Basic
Public Class GetOperatingSystem _
    Inherits CreateSessionProcessor
Visual C++
public ref class GetOperatingSystem : public CreateSessionProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines..::..SqlProcessorBase
Sitecore.Analytics.Pipelines.CreateSession..::..CreateSessionProcessor
Sitecore.Analytics.Pipelines.CreateSession..::..GetOperatingSystem

See Also

GetOperatingSystem Members
Sitecore.Analytics.Pipelines.CreateSession Namespace


GetOperatingSystem Members

[image] [image]

Sitecore 6.4.1 API
GetOperatingSystem Members
GetOperatingSystem Class Constructors Methods See Also Send Feedback

The GetOperatingSystem type exposes the following members.

Constructors

 | Name | Description
Public method | GetOperatingSystem | Initializes a new instance of the GetOperatingSystem class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides CreateSessionProcessor..::..Process(CreateSessionArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetOperatingSystem Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


Process Method

[image]

Sitecore 6.4.1 API
GetOperatingSystem..::..Process Method
GetOperatingSystem Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.CreateSession
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void Process(
    CreateSessionArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As CreateSessionArgs _
)
Visual C++
public:
virtual void Process(
    CreateSessionArgs^ args
) override

Parameters

args
Type: Sitecore.Analytics.Pipelines.CreateSession..::..CreateSessionArgs
The arguments.

See Also

GetOperatingSystem Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


GetReferringSite Class

[image]

Sitecore 6.4.1 API
GetReferringSite Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.CreateSession
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class GetReferringSite : CreateSessionProcessor
Visual Basic
Public Class GetReferringSite _
    Inherits CreateSessionProcessor
Visual C++
public ref class GetReferringSite : public CreateSessionProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines..::..SqlProcessorBase
Sitecore.Analytics.Pipelines.CreateSession..::..CreateSessionProcessor
Sitecore.Analytics.Pipelines.CreateSession..::..GetReferringSite

See Also

GetReferringSite Members
Sitecore.Analytics.Pipelines.CreateSession Namespace


GetReferringSite Members

[image] [image]

Sitecore 6.4.1 API
GetReferringSite Members
GetReferringSite Class Constructors Methods See Also Send Feedback

The GetReferringSite type exposes the following members.

Constructors

 | Name | Description
Public method | GetReferringSite | Initializes a new instance of the GetReferringSite class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides CreateSessionProcessor..::..Process(CreateSessionArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetReferringSite Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


GetReferringSite Constructor

[image]

Sitecore 6.4.1 API
GetReferringSite Constructor
GetReferringSite Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.CreateSession
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public GetReferringSite()
Visual Basic
Public Sub New
Visual C++
public:
GetReferringSite()

See Also

GetReferringSite Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


GetReferringSite Methods

[image] [image]

Sitecore 6.4.1 API
GetReferringSite Methods
GetReferringSite Class See Also Send Feedback

The GetReferringSite type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides CreateSessionProcessor..::..Process(CreateSessionArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetReferringSite Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


Process Method

[image]

Sitecore 6.4.1 API
GetReferringSite..::..Process Method
GetReferringSite Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.CreateSession
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void Process(
    CreateSessionArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As CreateSessionArgs _
)
Visual C++
public:
virtual void Process(
    CreateSessionArgs^ args
) override

Parameters

args
Type: Sitecore.Analytics.Pipelines.CreateSession..::..CreateSessionArgs
The arguments.

See Also

GetReferringSite Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


GetScreen Class

[image]

Sitecore 6.4.1 API
GetScreen Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.CreateSession
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class GetScreen : CreateSessionProcessor
Visual Basic
Public Class GetScreen _
    Inherits CreateSessionProcessor
Visual C++
public ref class GetScreen : public CreateSessionProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines..::..SqlProcessorBase
Sitecore.Analytics.Pipelines.CreateSession..::..CreateSessionProcessor
Sitecore.Analytics.Pipelines.CreateSession..::..GetScreen

See Also

GetScreen Members
Sitecore.Analytics.Pipelines.CreateSession Namespace


GetScreen Members

[image] [image]

Sitecore 6.4.1 API
GetScreen Members
GetScreen Class Constructors Methods See Also Send Feedback

The GetScreen type exposes the following members.

Constructors

 | Name | Description
Public method | GetScreen | Initializes a new instance of the GetScreen class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides CreateSessionProcessor..::..Process(CreateSessionArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetScreen Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


GetScreen Constructor

[image]

Sitecore 6.4.1 API
GetScreen Constructor
GetScreen Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.CreateSession
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public GetScreen()
Visual Basic
Public Sub New
Visual C++
public:
GetScreen()

See Also

GetScreen Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


GetScreen Methods

[image] [image]

Sitecore 6.4.1 API
GetScreen Methods
GetScreen Class See Also Send Feedback

The GetScreen type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides CreateSessionProcessor..::..Process(CreateSessionArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetScreen Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


Process Method

[image]

Sitecore 6.4.1 API
GetScreen..::..Process Method
GetScreen Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.CreateSession
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void Process(
    CreateSessionArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As CreateSessionArgs _
)
Visual C++
public:
virtual void Process(
    CreateSessionArgs^ args
) override

Parameters

args
Type: Sitecore.Analytics.Pipelines.CreateSession..::..CreateSessionArgs
The arguments.

See Also

GetScreen Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


InitializeSession Class

[image]

Sitecore 6.4.1 API
InitializeSession Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.CreateSession
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class InitializeSession : CreateSessionProcessor
Visual Basic
Public Class InitializeSession _
    Inherits CreateSessionProcessor
Visual C++
public ref class InitializeSession : public CreateSessionProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines..::..SqlProcessorBase
Sitecore.Analytics.Pipelines.CreateSession..::..CreateSessionProcessor
Sitecore.Analytics.Pipelines.CreateSession..::..InitializeSession

See Also

InitializeSession Members
Sitecore.Analytics.Pipelines.CreateSession Namespace


InitializeSession Members

[image] [image]

Sitecore 6.4.1 API
InitializeSession Members
InitializeSession Class Constructors Methods See Also Send Feedback

The InitializeSession type exposes the following members.

Constructors

 | Name | Description
Public method | InitializeSession | Initializes a new instance of the InitializeSession class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides CreateSessionProcessor..::..Process(CreateSessionArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InitializeSession Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


InitializeSession Constructor

[image]

Sitecore 6.4.1 API
InitializeSession Constructor
InitializeSession Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.CreateSession
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public InitializeSession()
Visual Basic
Public Sub New
Visual C++
public:
InitializeSession()

See Also

InitializeSession Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


Process Method

[image]

Sitecore 6.4.1 API
InitializeSession..::..Process Method
InitializeSession Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.CreateSession
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void Process(
    CreateSessionArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As CreateSessionArgs _
)
Visual C++
public:
virtual void Process(
    CreateSessionArgs^ args
) override

Parameters

args
Type: Sitecore.Analytics.Pipelines.CreateSession..::..CreateSessionArgs
The arguments.

See Also

InitializeSession Class
Sitecore.Analytics.Pipelines.CreateSession Namespace


Sitecore.Analytics.Pipelines.EvaluateConditionals Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Analytics.Pipelines.EvaluateConditionals Namespace
Send Feedback

Classes

 | Class | Description
Public class | EvaluateConditionalsArgs | Defines the evaluate conditionals args class.
Public class | EvaluateConditionalsPipeline | Defines the evaluate conditionals pipeline class.
Public class | EvaluateConditionalsProcessor | Defines the evaluate conditionals processor class.
Public class | EvaluateContains | IIS404Handler
Public class | EvaluateEquals | Defines the evaluate equals class.


EvaluateConditionalsArgs Class

[image]

Sitecore 6.4.1 API
EvaluateConditionalsArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.EvaluateConditionals
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
[SerializableAttribute]
public class EvaluateConditionalsArgs : PipelineArgs
Visual Basic
<SerializableAttribute> _
Public Class EvaluateConditionalsArgs _
    Inherits PipelineArgs
Visual C++
[SerializableAttribute]
public ref class EvaluateConditionalsArgs : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Analytics.Pipelines.EvaluateConditionals..::..EvaluateConditionalsArgs

See Also

EvaluateConditionalsArgs Members
Sitecore.Analytics.Pipelines.EvaluateConditionals Namespace


EvaluateConditionalsArgs Members

[image] [image]

Sitecore 6.4.1 API
EvaluateConditionalsArgs Members
EvaluateConditionalsArgs Class Constructors Methods Properties See Also Send Feedback

The EvaluateConditionalsArgs type exposes the following members.

Constructors

 | Name | Description
Protected method | EvaluateConditionalsArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the EvaluateConditionalsArgs class.
Public method | EvaluateConditionalsArgs(Item, XElement, String) | Initializes a new instance of the EvaluateConditionalsArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Element | Gets the element.
Public property | FieldName | Gets the name of the field.
Public property | Item | Gets the item.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Result | Gets or sets a value indicating whether this EvaluateConditionalsArgs is result.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
Public property | Value | Gets the value.

See Also

EvaluateConditionalsArgs Class
Sitecore.Analytics.Pipelines.EvaluateConditionals Namespace


EvaluateConditionalsArgs Constructor

[image] [image]

Sitecore 6.4.1 API
EvaluateConditionalsArgs Constructor
EvaluateConditionalsArgs Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | EvaluateConditionalsArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the EvaluateConditionalsArgs class.
Public method | EvaluateConditionalsArgs(Item, XElement, String) | Initializes a new instance of the EvaluateConditionalsArgs class.

See Also

EvaluateConditionalsArgs Class
EvaluateConditionalsArgs Members
Sitecore.Analytics.Pipelines.EvaluateConditionals Namespace


EvaluateConditionalsArgs Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
EvaluateConditionalsArgs Constructor (SerializationInfo, StreamingContext)
EvaluateConditionalsArgs Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.EvaluateConditionals
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected EvaluateConditionalsArgs(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
EvaluateConditionalsArgs(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

EvaluateConditionalsArgs Class
EvaluateConditionalsArgs Overload
Sitecore.Analytics.Pipelines.EvaluateConditionals Namespace


EvaluateConditionalsArgs Constructor (Item, XElement, String)

[image]

Sitecore 6.4.1 API
EvaluateConditionalsArgs Constructor (Item, XElement, String)
EvaluateConditionalsArgs Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.EvaluateConditionals
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public EvaluateConditionalsArgs(
    Item item,
    XElement element,
    string fieldName
)
Visual Basic
Public Sub New ( _
    item As Item, _
    element As XElement, _
    fieldName As String _
)
Visual C++
public:
EvaluateConditionalsArgs(
    Item^ item,
    XElement^ element,
    String^ fieldName
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
element
Type: System.Xml.Linq..::..XElement
The element.
fieldName
Type: System..::..String
Name of the field.

See Also

EvaluateConditionalsArgs Class
EvaluateConditionalsArgs Overload
Sitecore.Analytics.Pipelines.EvaluateConditionals Namespace


EvaluateConditionalsArgs Methods

[image] [image]

Sitecore 6.4.1 API
EvaluateConditionalsArgs Methods
EvaluateConditionalsArgs Class See Also Send Feedback

The EvaluateConditionalsArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EvaluateConditionalsArgs Class
Sitecore.Analytics.Pipelines.EvaluateConditionals Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
EvaluateConditionalsArgs..::..AddMessage Method
EvaluateConditionalsArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

EvaluateConditionalsArgs Class
EvaluateConditionalsArgs Members
Sitecore.Analytics.Pipelines.EvaluateConditionals Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
EvaluateConditionalsArgs..::..GetMessages Method
EvaluateConditionalsArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

EvaluateConditionalsArgs Class
EvaluateConditionalsArgs Members
Sitecore.Analytics.Pipelines.EvaluateConditionals Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
EvaluateConditionalsArgs..::..Suspend Method
EvaluateConditionalsArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

EvaluateConditionalsArgs Class
EvaluateConditionalsArgs Members
Sitecore.Analytics.Pipelines.EvaluateConditionals Namespace


EvaluateConditionalsArgs Properties

[image] [image]

Sitecore 6.4.1 API
EvaluateConditionalsArgs Properties
EvaluateConditionalsArgs Class See Also Send Feedback

The EvaluateConditionalsArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Element | Gets the element.
Public property | FieldName | Gets the name of the field.
Public property | Item | Gets the item.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Result | Gets or sets a value indicating whether this EvaluateConditionalsArgs is result.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
Public property | Value | Gets the value.

See Also

EvaluateConditionalsArgs Class
Sitecore.Analytics.Pipelines.EvaluateConditionals Namespace


Element Property

[image]

Sitecore 6.4.1 API
EvaluateConditionalsArgs..::..Element Property
EvaluateConditionalsArgs Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.EvaluateConditionals
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public XElement Element { get; }
Visual Basic
Public ReadOnly Property Element As XElement
    Get
Visual C++
public:
property XElement^ Element {
    XElement^ get ();
}

Field Value

The element.

See Also

EvaluateConditionalsArgs Class
Sitecore.Analytics.Pipelines.EvaluateConditionals Namespace


FieldName Property

[image]

Sitecore 6.4.1 API
EvaluateConditionalsArgs..::..FieldName Property
EvaluateConditionalsArgs Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.EvaluateConditionals
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string FieldName { get; }
Visual Basic
Public ReadOnly Property FieldName As String
    Get
Visual C++
public:
property String^ FieldName {
    String^ get ();
}

Field Value

The name of the field.

See Also

EvaluateConditionalsArgs Class
Sitecore.Analytics.Pipelines.EvaluateConditionals Namespace


Item Property

[image]

Sitecore 6.4.1 API
EvaluateConditionalsArgs..::..Item Property
EvaluateConditionalsArgs Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.EvaluateConditionals
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Item Item { get; }
Visual Basic
Public ReadOnly Property Item As Item
    Get
Visual C++
public:
property Item^ Item {
    Item^ get ();
}

Field Value

The item.

See Also

EvaluateConditionalsArgs Class
Sitecore.Analytics.Pipelines.EvaluateConditionals Namespace


Result Property

[image]

Sitecore 6.4.1 API
EvaluateConditionalsArgs..::..Result Property
EvaluateConditionalsArgs Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.EvaluateConditionals
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public bool Result { get; set; }
Visual Basic
Public Property Result As Boolean
    Get
    Set
Visual C++
public:
property bool Result {
    bool get ();
    void set (bool value);
}

Field Value

true if result; otherwise, false.

See Also

EvaluateConditionalsArgs Class
Sitecore.Analytics.Pipelines.EvaluateConditionals Namespace


Value Property

[image]

Sitecore 6.4.1 API
EvaluateConditionalsArgs..::..Value Property
EvaluateConditionalsArgs Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.EvaluateConditionals
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Value { get; }
Visual Basic
Public ReadOnly Property Value As String
    Get
Visual C++
public:
property String^ Value {
    String^ get ();
}

Field Value

The value.

See Also

EvaluateConditionalsArgs Class
Sitecore.Analytics.Pipelines.EvaluateConditionals Namespace


EvaluateConditionalsPipeline Class

[image]

Sitecore 6.4.1 API
EvaluateConditionalsPipeline Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.EvaluateConditionals
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class EvaluateConditionalsPipeline
Visual Basic
Public Class EvaluateConditionalsPipeline
Visual C++
public ref class EvaluateConditionalsPipeline

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines.EvaluateConditionals..::..EvaluateConditionalsPipeline

See Also

EvaluateConditionalsPipeline Members
Sitecore.Analytics.Pipelines.EvaluateConditionals Namespace


EvaluateConditionalsPipeline Members

[image] [image]

Sitecore 6.4.1 API
EvaluateConditionalsPipeline Members
EvaluateConditionalsPipeline Class Constructors Methods See Also Send Feedback

The EvaluateConditionalsPipeline type exposes the following members.

Constructors

 | Name | Description
Public method | EvaluateConditionalsPipeline | Initializes a new instance of the EvaluateConditionalsPipeline class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run | Runs the 'publish' pipeline with specified arguments.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EvaluateConditionalsPipeline Class
Sitecore.Analytics.Pipelines.EvaluateConditionals Namespace


EvaluateConditionalsPipeline Constructor

[image]

Sitecore 6.4.1 API
EvaluateConditionalsPipeline Constructor
EvaluateConditionalsPipeline Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.EvaluateConditionals
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public EvaluateConditionalsPipeline()
Visual Basic
Public Sub New
Visual C++
public:
EvaluateConditionalsPipeline()

See Also

EvaluateConditionalsPipeline Class
Sitecore.Analytics.Pipelines.EvaluateConditionals Namespace


EvaluateConditionalsPipeline Methods

[image] [image]

Sitecore 6.4.1 API
EvaluateConditionalsPipeline Methods
EvaluateConditionalsPipeline Class See Also Send Feedback

The EvaluateConditionalsPipeline type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run | Runs the 'publish' pipeline with specified arguments.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EvaluateConditionalsPipeline Class
Sitecore.Analytics.Pipelines.EvaluateConditionals Namespace


Run Method

[image]

Sitecore 6.4.1 API
EvaluateConditionalsPipeline..::..Run Method
EvaluateConditionalsPipeline Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.EvaluateConditionals
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void Run(
    EvaluateConditionalsArgs args
)
Visual Basic
Public Shared Sub Run ( _
    args As EvaluateConditionalsArgs _
)
Visual C++
public:
static void Run(
    EvaluateConditionalsArgs^ args
)

Parameters

args
Type: Sitecore.Analytics.Pipelines.EvaluateConditionals..::..EvaluateConditionalsArgs
The arguments.

See Also

EvaluateConditionalsPipeline Class
Sitecore.Analytics.Pipelines.EvaluateConditionals Namespace


EvaluateConditionalsProcessor Class

[image]

Sitecore 6.4.1 API
EvaluateConditionalsProcessor Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.EvaluateConditionals
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract class EvaluateConditionalsProcessor
Visual Basic
Public MustInherit Class EvaluateConditionalsProcessor
Visual C++
public ref class EvaluateConditionalsProcessor abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines.EvaluateConditionals..::..EvaluateConditionalsProcessor
Sitecore.Analytics.Pipelines.EvaluateConditionals..::..EvaluateContains
Sitecore.Analytics.Pipelines.EvaluateConditionals..::..EvaluateEquals

See Also

EvaluateConditionalsProcessor Members
Sitecore.Analytics.Pipelines.EvaluateConditionals Namespace


EvaluateConditionalsProcessor Members

[image] [image]

Sitecore 6.4.1 API
EvaluateConditionalsProcessor Members
EvaluateConditionalsProcessor Class Constructors Methods See Also Send Feedback

The EvaluateConditionalsProcessor type exposes the following members.

Constructors

 | Name | Description
Protected method | EvaluateConditionalsProcessor | Initializes a new instance of the EvaluateConditionalsProcessor class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EvaluateConditionalsProcessor Class
Sitecore.Analytics.Pipelines.EvaluateConditionals Namespace


EvaluateConditionalsProcessor Constructor

[image]

Sitecore 6.4.1 API
EvaluateConditionalsProcessor Constructor
EvaluateConditionalsProcessor Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.EvaluateConditionals
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected EvaluateConditionalsProcessor()
Visual Basic
Protected Sub New
Visual C++
protected:
EvaluateConditionalsProcessor()

See Also

EvaluateConditionalsProcessor Class
Sitecore.Analytics.Pipelines.EvaluateConditionals Namespace


EvaluateConditionalsProcessor Methods

[image] [image]

Sitecore 6.4.1 API
EvaluateConditionalsProcessor Methods
EvaluateConditionalsProcessor Class See Also Send Feedback

The EvaluateConditionalsProcessor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EvaluateConditionalsProcessor Class
Sitecore.Analytics.Pipelines.EvaluateConditionals Namespace


Process Method

[image]

Sitecore 6.4.1 API
EvaluateConditionalsProcessor..::..Process Method
EvaluateConditionalsProcessor Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.EvaluateConditionals
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract void Process(
    EvaluateConditionalsArgs args
)
Visual Basic
Public MustOverride Sub Process ( _
    args As EvaluateConditionalsArgs _
)
Visual C++
public:
virtual void Process(
    EvaluateConditionalsArgs^ args
) abstract

Parameters

args
Type: Sitecore.Analytics.Pipelines.EvaluateConditionals..::..EvaluateConditionalsArgs
The arguments.

See Also

EvaluateConditionalsProcessor Class
Sitecore.Analytics.Pipelines.EvaluateConditionals Namespace


EvaluateContains Class

[image]

Sitecore 6.4.1 API
EvaluateContains Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.EvaluateConditionals
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class EvaluateContains : EvaluateConditionalsProcessor
Visual Basic
Public Class EvaluateContains _
    Inherits EvaluateConditionalsProcessor
Visual C++
public ref class EvaluateContains : public EvaluateConditionalsProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines.EvaluateConditionals..::..EvaluateConditionalsProcessor
Sitecore.Analytics.Pipelines.EvaluateConditionals..::..EvaluateContains

See Also

EvaluateContains Members
Sitecore.Analytics.Pipelines.EvaluateConditionals Namespace


EvaluateContains Members

[image] [image]

Sitecore 6.4.1 API
EvaluateContains Members
EvaluateContains Class Constructors Methods See Also Send Feedback

The EvaluateContains type exposes the following members.

Constructors

 | Name | Description
Public method | EvaluateContains | Initializes a new instance of the EvaluateContains class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides EvaluateConditionalsProcessor..::..Process(EvaluateConditionalsArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EvaluateContains Class
Sitecore.Analytics.Pipelines.EvaluateConditionals Namespace


EvaluateContains Constructor

[image]

Sitecore 6.4.1 API
EvaluateContains Constructor
EvaluateContains Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.EvaluateConditionals
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public EvaluateContains()
Visual Basic
Public Sub New
Visual C++
public:
EvaluateContains()

See Also

EvaluateContains Class
Sitecore.Analytics.Pipelines.EvaluateConditionals Namespace


EvaluateContains Methods

[image] [image]

Sitecore 6.4.1 API
EvaluateContains Methods
EvaluateContains Class See Also Send Feedback

The EvaluateContains type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides EvaluateConditionalsProcessor..::..Process(EvaluateConditionalsArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EvaluateContains Class
Sitecore.Analytics.Pipelines.EvaluateConditionals Namespace


Process Method

[image]

Sitecore 6.4.1 API
EvaluateContains..::..Process Method
EvaluateContains Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.EvaluateConditionals
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void Process(
    EvaluateConditionalsArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As EvaluateConditionalsArgs _
)
Visual C++
public:
virtual void Process(
    EvaluateConditionalsArgs^ args
) override

Parameters

args
Type: Sitecore.Analytics.Pipelines.EvaluateConditionals..::..EvaluateConditionalsArgs
The args.

See Also

EvaluateContains Class
Sitecore.Analytics.Pipelines.EvaluateConditionals Namespace


EvaluateEquals Class

[image]

Sitecore 6.4.1 API
EvaluateEquals Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.EvaluateConditionals
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class EvaluateEquals : EvaluateConditionalsProcessor
Visual Basic
Public Class EvaluateEquals _
    Inherits EvaluateConditionalsProcessor
Visual C++
public ref class EvaluateEquals : public EvaluateConditionalsProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines.EvaluateConditionals..::..EvaluateConditionalsProcessor
Sitecore.Analytics.Pipelines.EvaluateConditionals..::..EvaluateEquals

See Also

EvaluateEquals Members
Sitecore.Analytics.Pipelines.EvaluateConditionals Namespace


EvaluateEquals Members

[image] [image]

Sitecore 6.4.1 API
EvaluateEquals Members
EvaluateEquals Class Constructors Methods See Also Send Feedback

The EvaluateEquals type exposes the following members.

Constructors

 | Name | Description
Public method | EvaluateEquals | Initializes a new instance of the EvaluateEquals class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides EvaluateConditionalsProcessor..::..Process(EvaluateConditionalsArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EvaluateEquals Class
Sitecore.Analytics.Pipelines.EvaluateConditionals Namespace


EvaluateEquals Methods

[image] [image]

Sitecore 6.4.1 API
EvaluateEquals Methods
EvaluateEquals Class See Also Send Feedback

The EvaluateEquals type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides EvaluateConditionalsProcessor..::..Process(EvaluateConditionalsArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EvaluateEquals Class
Sitecore.Analytics.Pipelines.EvaluateConditionals Namespace


Process Method

[image]

Sitecore 6.4.1 API
EvaluateEquals..::..Process Method
EvaluateEquals Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.EvaluateConditionals
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void Process(
    EvaluateConditionalsArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As EvaluateConditionalsArgs _
)
Visual C++
public:
virtual void Process(
    EvaluateConditionalsArgs^ args
) override

Parameters

args
Type: Sitecore.Analytics.Pipelines.EvaluateConditionals..::..EvaluateConditionalsArgs
The args.

See Also

EvaluateEquals Class
Sitecore.Analytics.Pipelines.EvaluateConditionals Namespace


Sitecore.Analytics.Pipelines.ExcludeRobots Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Analytics.Pipelines.ExcludeRobots Namespace
Send Feedback

Classes

 | Class | Description
Public class | CheckIpAddress | Processor that excludes HTTP request checking IP address.
Public class | CheckUserAgent | Processor that excludes HTTP request checking user agent.
Public class | ExcludeRobotsArgs | Arguments of the ExcludeRobots pipeline processor.
Public class | ExcludeRobotsPipeline | ExcludeRobots pipeline.
Public class | ExcludeRobotsProcessor | ExcludeRobots processor base.


CheckIpAddress Class

[image]

Sitecore 6.4.1 API
CheckIpAddress Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.ExcludeRobots
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class CheckIpAddress : ExcludeRobotsProcessor
Visual Basic
Public Class CheckIpAddress _
    Inherits ExcludeRobotsProcessor
Visual C++
public ref class CheckIpAddress : public ExcludeRobotsProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines.ExcludeRobots..::..ExcludeRobotsProcessor
Sitecore.Analytics.Pipelines.ExcludeRobots..::..CheckIpAddress

See Also

CheckIpAddress Members
Sitecore.Analytics.Pipelines.ExcludeRobots Namespace


CheckIpAddress Members

[image] [image]

Sitecore 6.4.1 API
CheckIpAddress Members
CheckIpAddress Class Constructors Methods See Also Send Feedback

The CheckIpAddress type exposes the following members.

Constructors

 | Name | Description
Public method | CheckIpAddress | Initializes a new instance of the CheckIpAddress class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides ExcludeRobotsProcessor..::..Process(ExcludeRobotsArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckIpAddress Class
Sitecore.Analytics.Pipelines.ExcludeRobots Namespace


CheckIpAddress Constructor

[image]

Sitecore 6.4.1 API
CheckIpAddress Constructor
CheckIpAddress Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.ExcludeRobots
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public CheckIpAddress()
Visual Basic
Public Sub New
Visual C++
public:
CheckIpAddress()

See Also

CheckIpAddress Class
Sitecore.Analytics.Pipelines.ExcludeRobots Namespace


CheckIpAddress Methods

[image] [image]

Sitecore 6.4.1 API
CheckIpAddress Methods
CheckIpAddress Class See Also Send Feedback

The CheckIpAddress type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides ExcludeRobotsProcessor..::..Process(ExcludeRobotsArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckIpAddress Class
Sitecore.Analytics.Pipelines.ExcludeRobots Namespace


Process Method

[image]

Sitecore 6.4.1 API
CheckIpAddress..::..Process Method
CheckIpAddress Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.ExcludeRobots
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void Process(
    ExcludeRobotsArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As ExcludeRobotsArgs _
)
Visual C++
public:
virtual void Process(
    ExcludeRobotsArgs^ args
) override

Parameters

args
Type: Sitecore.Analytics.Pipelines.ExcludeRobots..::..ExcludeRobotsArgs
The arguments.

See Also

CheckIpAddress Class
Sitecore.Analytics.Pipelines.ExcludeRobots Namespace


CheckUserAgent Class

[image]

Sitecore 6.4.1 API
CheckUserAgent Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.ExcludeRobots
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class CheckUserAgent : ExcludeRobotsProcessor
Visual Basic
Public Class CheckUserAgent _
    Inherits ExcludeRobotsProcessor
Visual C++
public ref class CheckUserAgent : public ExcludeRobotsProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines.ExcludeRobots..::..ExcludeRobotsProcessor
Sitecore.Analytics.Pipelines.ExcludeRobots..::..CheckUserAgent

See Also

CheckUserAgent Members
Sitecore.Analytics.Pipelines.ExcludeRobots Namespace


CheckUserAgent Members

[image] [image]

Sitecore 6.4.1 API
CheckUserAgent Members
CheckUserAgent Class Constructors Methods See Also Send Feedback

The CheckUserAgent type exposes the following members.

Constructors

 | Name | Description
Public method | CheckUserAgent | Initializes a new instance of the CheckUserAgent class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides ExcludeRobotsProcessor..::..Process(ExcludeRobotsArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckUserAgent Class
Sitecore.Analytics.Pipelines.ExcludeRobots Namespace


CheckUserAgent Constructor

[image]

Sitecore 6.4.1 API
CheckUserAgent Constructor
CheckUserAgent Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.ExcludeRobots
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public CheckUserAgent()
Visual Basic
Public Sub New
Visual C++
public:
CheckUserAgent()

See Also

CheckUserAgent Class
Sitecore.Analytics.Pipelines.ExcludeRobots Namespace


CheckUserAgent Methods

[image] [image]

Sitecore 6.4.1 API
CheckUserAgent Methods
CheckUserAgent Class See Also Send Feedback

The CheckUserAgent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides ExcludeRobotsProcessor..::..Process(ExcludeRobotsArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckUserAgent Class
Sitecore.Analytics.Pipelines.ExcludeRobots Namespace


Process Method

[image]

Sitecore 6.4.1 API
CheckUserAgent..::..Process Method
CheckUserAgent Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.ExcludeRobots
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void Process(
    ExcludeRobotsArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As ExcludeRobotsArgs _
)
Visual C++
public:
virtual void Process(
    ExcludeRobotsArgs^ args
) override

Parameters

args
Type: Sitecore.Analytics.Pipelines.ExcludeRobots..::..ExcludeRobotsArgs
The arguments.

See Also

CheckUserAgent Class
Sitecore.Analytics.Pipelines.ExcludeRobots Namespace


ExcludeRobotsArgs Class

[image]

Sitecore 6.4.1 API
ExcludeRobotsArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.ExcludeRobots
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class ExcludeRobotsArgs : PipelineArgs
Visual Basic
Public Class ExcludeRobotsArgs _
    Inherits PipelineArgs
Visual C++
public ref class ExcludeRobotsArgs : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Analytics.Pipelines.ExcludeRobots..::..ExcludeRobotsArgs

See Also

ExcludeRobotsArgs Members
Sitecore.Analytics.Pipelines.ExcludeRobots Namespace


ExcludeRobotsArgs Members

[image] [image]

Sitecore 6.4.1 API
ExcludeRobotsArgs Members
ExcludeRobotsArgs Class Constructors Methods Properties See Also Send Feedback

The ExcludeRobotsArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ExcludeRobotsArgs | Initializes a new instance of the ExcludeRobotsArgs class

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | IsRequestExcluded | Gets or sets a value indicating whether this instance is HTTP request excluded.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Request | Gets or sets the HTTP request.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

ExcludeRobotsArgs Class
Sitecore.Analytics.Pipelines.ExcludeRobots Namespace


ExcludeRobotsArgs Constructor

[image]

Sitecore 6.4.1 API
ExcludeRobotsArgs Constructor
ExcludeRobotsArgs Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.ExcludeRobots
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public ExcludeRobotsArgs()
Visual Basic
Public Sub New
Visual C++
public:
ExcludeRobotsArgs()

See Also

ExcludeRobotsArgs Class
Sitecore.Analytics.Pipelines.ExcludeRobots Namespace


ExcludeRobotsArgs Methods

[image] [image]

Sitecore 6.4.1 API
ExcludeRobotsArgs Methods
ExcludeRobotsArgs Class See Also Send Feedback

The ExcludeRobotsArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExcludeRobotsArgs Class
Sitecore.Analytics.Pipelines.ExcludeRobots Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
ExcludeRobotsArgs..::..GetMessages Method
ExcludeRobotsArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

ExcludeRobotsArgs Class
ExcludeRobotsArgs Members
Sitecore.Analytics.Pipelines.ExcludeRobots Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
ExcludeRobotsArgs..::..Suspend Method
ExcludeRobotsArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

ExcludeRobotsArgs Class
ExcludeRobotsArgs Members
Sitecore.Analytics.Pipelines.ExcludeRobots Namespace


ExcludeRobotsArgs Properties

[image] [image]

Sitecore 6.4.1 API
ExcludeRobotsArgs Properties
ExcludeRobotsArgs Class See Also Send Feedback

The ExcludeRobotsArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | IsRequestExcluded | Gets or sets a value indicating whether this instance is HTTP request excluded.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Request | Gets or sets the HTTP request.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

ExcludeRobotsArgs Class
Sitecore.Analytics.Pipelines.ExcludeRobots Namespace


Request Property

[image]

Sitecore 6.4.1 API
ExcludeRobotsArgs..::..Request Property
ExcludeRobotsArgs Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.ExcludeRobots
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public HttpRequest Request { get; set; }
Visual Basic
Public Property Request As HttpRequest
    Get
    Set
Visual C++
public:
property HttpRequest^ Request {
    HttpRequest^ get ();
    void set (HttpRequest^ value);
}

Field Value

The HTTP request.

See Also

ExcludeRobotsArgs Class
Sitecore.Analytics.Pipelines.ExcludeRobots Namespace


ExcludeRobotsPipeline Members

[image] [image]

Sitecore 6.4.1 API
ExcludeRobotsPipeline Members
ExcludeRobotsPipeline Class Methods See Also Send Feedback

The ExcludeRobotsPipeline type exposes the following members.

Methods

Name | Description
Run | Runs the ExcludeRobots pipeline.

See Also

ExcludeRobotsPipeline Class
Sitecore.Analytics.Pipelines.ExcludeRobots Namespace


ExcludeRobotsPipeline Methods

[image] [image]

Sitecore 6.4.1 API
ExcludeRobotsPipeline Methods
ExcludeRobotsPipeline Class See Also Send Feedback

The ExcludeRobotsPipeline type exposes the following members.

Methods

Name | Description
Run | Runs the ExcludeRobots pipeline.

See Also

ExcludeRobotsPipeline Class
Sitecore.Analytics.Pipelines.ExcludeRobots Namespace


Run Method

[image]

Sitecore 6.4.1 API
ExcludeRobotsPipeline..::..Run Method
ExcludeRobotsPipeline Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.ExcludeRobots
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void Run(
    ExcludeRobotsArgs args
)
Visual Basic
Public Shared Sub Run ( _
    args As ExcludeRobotsArgs _
)
Visual C++
public:
static void Run(
    ExcludeRobotsArgs^ args
)

Parameters

args
Type: Sitecore.Analytics.Pipelines.ExcludeRobots..::..ExcludeRobotsArgs
The arguments.

See Also

ExcludeRobotsPipeline Class
Sitecore.Analytics.Pipelines.ExcludeRobots Namespace


ExcludeRobotsProcessor Members

[image] [image]

Sitecore 6.4.1 API
ExcludeRobotsProcessor Members
ExcludeRobotsProcessor Class Constructors Methods See Also Send Feedback

The ExcludeRobotsProcessor type exposes the following members.

Constructors

 | Name | Description
Protected method | ExcludeRobotsProcessor | Initializes a new instance of the ExcludeRobotsProcessor class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExcludeRobotsProcessor Class
Sitecore.Analytics.Pipelines.ExcludeRobots Namespace


ExcludeRobotsProcessor Methods

[image] [image]

Sitecore 6.4.1 API
ExcludeRobotsProcessor Methods
ExcludeRobotsProcessor Class See Also Send Feedback

The ExcludeRobotsProcessor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExcludeRobotsProcessor Class
Sitecore.Analytics.Pipelines.ExcludeRobots Namespace


Process Method

[image]

Sitecore 6.4.1 API
ExcludeRobotsProcessor..::..Process Method
ExcludeRobotsProcessor Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.ExcludeRobots
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract void Process(
    ExcludeRobotsArgs args
)
Visual Basic
Public MustOverride Sub Process ( _
    args As ExcludeRobotsArgs _
)
Visual C++
public:
virtual void Process(
    ExcludeRobotsArgs^ args
) abstract

Parameters

args
Type: Sitecore.Analytics.Pipelines.ExcludeRobots..::..ExcludeRobotsArgs
The arguments.

See Also

ExcludeRobotsProcessor Class
Sitecore.Analytics.Pipelines.ExcludeRobots Namespace


Sitecore.Analytics.Pipelines.HttpRequest Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Analytics.Pipelines.HttpRequest Namespace
Send Feedback

Classes

 | Class | Description
Public class | EndAnalytics | Defines the end analytics class.
Public class | StartAnalytics | Defines the start analytics class.
Public class | StartDiagnostics | Defines the start diagnostics class.


EndAnalytics Class

[image]

Sitecore 6.4.1 API
EndAnalytics Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.HttpRequest
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class EndAnalytics : HttpRequestProcessor
Visual Basic
Public Class EndAnalytics _
    Inherits HttpRequestProcessor
Visual C++
public ref class EndAnalytics : public HttpRequestProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.HttpRequest..::..HttpRequestProcessor
Sitecore.Analytics.Pipelines.HttpRequest..::..EndAnalytics

See Also

EndAnalytics Members
Sitecore.Analytics.Pipelines.HttpRequest Namespace


EndAnalytics Members

[image] [image]

Sitecore 6.4.1 API
EndAnalytics Members
EndAnalytics Class Constructors Methods See Also Send Feedback

The EndAnalytics type exposes the following members.

Constructors

 | Name | Description
Public method | EndAnalytics | Initializes a new instance of the EndAnalytics class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EndAnalytics Class
Sitecore.Analytics.Pipelines.HttpRequest Namespace


EndAnalytics Constructor

[image]

Sitecore 6.4.1 API
EndAnalytics Constructor
EndAnalytics Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.HttpRequest
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public EndAnalytics()
Visual Basic
Public Sub New
Visual C++
public:
EndAnalytics()

See Also

EndAnalytics Class
Sitecore.Analytics.Pipelines.HttpRequest Namespace


Process Method

[image]

Sitecore 6.4.1 API
EndAnalytics..::..Process Method
EndAnalytics Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.HttpRequest
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void Process(
    HttpRequestArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As HttpRequestArgs _
)
Visual C++
public:
virtual void Process(
    HttpRequestArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.HttpRequest..::..HttpRequestArgs
The arguments.

See Also

EndAnalytics Class
Sitecore.Analytics.Pipelines.HttpRequest Namespace


StartAnalytics Class

[image]

Sitecore 6.4.1 API
StartAnalytics Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.HttpRequest
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class StartAnalytics
Visual Basic
Public Class StartAnalytics
Visual C++
public ref class StartAnalytics

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines.HttpRequest..::..StartAnalytics

See Also

StartAnalytics Members
Sitecore.Analytics.Pipelines.HttpRequest Namespace


StartAnalytics Constructor

[image]

Sitecore 6.4.1 API
StartAnalytics Constructor
StartAnalytics Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.HttpRequest
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public StartAnalytics()
Visual Basic
Public Sub New
Visual C++
public:
StartAnalytics()

See Also

StartAnalytics Class
Sitecore.Analytics.Pipelines.HttpRequest Namespace


StartAnalytics Methods

[image] [image]

Sitecore 6.4.1 API
StartAnalytics Methods
StartAnalytics Class See Also Send Feedback

The StartAnalytics type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StartAnalytics Class
Sitecore.Analytics.Pipelines.HttpRequest Namespace


Process Method

[image]

Sitecore 6.4.1 API
StartAnalytics..::..Process Method
StartAnalytics Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.HttpRequest
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void Process(
    RenderLayoutArgs args
)
Visual Basic
Public Sub Process ( _
    args As RenderLayoutArgs _
)
Visual C++
public:
void Process(
    RenderLayoutArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.RenderLayout..::..RenderLayoutArgs
The arguments.

See Also

StartAnalytics Class
Sitecore.Analytics.Pipelines.HttpRequest Namespace


StartDiagnostics Class

[image]

Sitecore 6.4.1 API
StartDiagnostics Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.HttpRequest
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class StartDiagnostics : HttpRequestProcessor
Visual Basic
Public Class StartDiagnostics _
    Inherits HttpRequestProcessor
Visual C++
public ref class StartDiagnostics : public HttpRequestProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.HttpRequest..::..HttpRequestProcessor
Sitecore.Analytics.Pipelines.HttpRequest..::..StartDiagnostics

See Also

StartDiagnostics Members
Sitecore.Analytics.Pipelines.HttpRequest Namespace


StartDiagnostics Members

[image] [image]

Sitecore 6.4.1 API
StartDiagnostics Members
StartDiagnostics Class Constructors Methods See Also Send Feedback

The StartDiagnostics type exposes the following members.

Constructors

 | Name | Description
Public method | StartDiagnostics | Initializes a new instance of the StartDiagnostics class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StartDiagnostics Class
Sitecore.Analytics.Pipelines.HttpRequest Namespace


StartDiagnostics Constructor

[image]

Sitecore 6.4.1 API
StartDiagnostics Constructor
StartDiagnostics Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.HttpRequest
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public StartDiagnostics()
Visual Basic
Public Sub New
Visual C++
public:
StartDiagnostics()

See Also

StartDiagnostics Class
Sitecore.Analytics.Pipelines.HttpRequest Namespace


StartDiagnostics Methods

[image] [image]

Sitecore 6.4.1 API
StartDiagnostics Methods
StartDiagnostics Class See Also Send Feedback

The StartDiagnostics type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StartDiagnostics Class
Sitecore.Analytics.Pipelines.HttpRequest Namespace


Process Method

[image]

Sitecore 6.4.1 API
StartDiagnostics..::..Process Method
StartDiagnostics Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.HttpRequest
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void Process(
    HttpRequestArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As HttpRequestArgs _
)
Visual C++
public:
virtual void Process(
    HttpRequestArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.HttpRequest..::..HttpRequestArgs
The arguments.

See Also

StartDiagnostics Class
Sitecore.Analytics.Pipelines.HttpRequest Namespace


Sitecore.Analytics.Pipelines.ParseReferrer Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Analytics.Pipelines.ParseReferrer Namespace
Send Feedback

Classes

 | Class | Description
Public class | ParseGoogle | Defines the parse google class.
Public class | ParseLiveSearch | Defines the parse google class.
Public class | ParseReferrerArgs | Defines the parse referrer args class.
Public class | ParseReferrerPipeline | Defines the parse referrer pipeline class.
Public class | ParseReferrerProcessor | Defines the parse referrer processor class.
Public class | ParseYahoo | Defines the parse yahoo class.


ParseGoogle Class

[image]

Sitecore 6.4.1 API
ParseGoogle Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.ParseReferrer
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class ParseGoogle : ParseReferrerProcessor
Visual Basic
Public Class ParseGoogle _
    Inherits ParseReferrerProcessor
Visual C++
public ref class ParseGoogle : public ParseReferrerProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines.ParseReferrer..::..ParseReferrerProcessor
Sitecore.Analytics.Pipelines.ParseReferrer..::..ParseGoogle

See Also

ParseGoogle Members
Sitecore.Analytics.Pipelines.ParseReferrer Namespace


ParseGoogle Members

[image] [image]

Sitecore 6.4.1 API
ParseGoogle Members
ParseGoogle Class Constructors Methods See Also Send Feedback

The ParseGoogle type exposes the following members.

Constructors

 | Name | Description
Public method | ParseGoogle | Initializes a new instance of the ParseGoogle class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides ParseReferrerProcessor..::..Process(ParseReferrerArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParseGoogle Class
Sitecore.Analytics.Pipelines.ParseReferrer Namespace


ParseGoogle Constructor

[image]

Sitecore 6.4.1 API
ParseGoogle Constructor
ParseGoogle Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.ParseReferrer
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public ParseGoogle()
Visual Basic
Public Sub New
Visual C++
public:
ParseGoogle()

See Also

ParseGoogle Class
Sitecore.Analytics.Pipelines.ParseReferrer Namespace


ParseGoogle Methods

[image] [image]

Sitecore 6.4.1 API
ParseGoogle Methods
ParseGoogle Class See Also Send Feedback

The ParseGoogle type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides ParseReferrerProcessor..::..Process(ParseReferrerArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParseGoogle Class
Sitecore.Analytics.Pipelines.ParseReferrer Namespace


Process Method

[image]

Sitecore 6.4.1 API
ParseGoogle..::..Process Method
ParseGoogle Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.ParseReferrer
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void Process(
    ParseReferrerArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As ParseReferrerArgs _
)
Visual C++
public:
virtual void Process(
    ParseReferrerArgs^ args
) override

Parameters

args
Type: Sitecore.Analytics.Pipelines.ParseReferrer..::..ParseReferrerArgs
The arguments.

See Also

ParseGoogle Class
Sitecore.Analytics.Pipelines.ParseReferrer Namespace


ParseLiveSearch Class

[image]

Sitecore 6.4.1 API
ParseLiveSearch Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.ParseReferrer
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class ParseLiveSearch : ParseReferrerProcessor
Visual Basic
Public Class ParseLiveSearch _
    Inherits ParseReferrerProcessor
Visual C++
public ref class ParseLiveSearch : public ParseReferrerProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines.ParseReferrer..::..ParseReferrerProcessor
Sitecore.Analytics.Pipelines.ParseReferrer..::..ParseLiveSearch

See Also

ParseLiveSearch Members
Sitecore.Analytics.Pipelines.ParseReferrer Namespace


ParseLiveSearch Members

[image] [image]

Sitecore 6.4.1 API
ParseLiveSearch Members
ParseLiveSearch Class Constructors Methods See Also Send Feedback

The ParseLiveSearch type exposes the following members.

Constructors

 | Name | Description
Public method | ParseLiveSearch | Initializes a new instance of the ParseLiveSearch class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides ParseReferrerProcessor..::..Process(ParseReferrerArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParseLiveSearch Class
Sitecore.Analytics.Pipelines.ParseReferrer Namespace


ParseLiveSearch Constructor

[image]

Sitecore 6.4.1 API
ParseLiveSearch Constructor
ParseLiveSearch Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.ParseReferrer
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public ParseLiveSearch()
Visual Basic
Public Sub New
Visual C++
public:
ParseLiveSearch()

See Also

ParseLiveSearch Class
Sitecore.Analytics.Pipelines.ParseReferrer Namespace


ParseLiveSearch Methods

[image] [image]

Sitecore 6.4.1 API
ParseLiveSearch Methods
ParseLiveSearch Class See Also Send Feedback

The ParseLiveSearch type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides ParseReferrerProcessor..::..Process(ParseReferrerArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParseLiveSearch Class
Sitecore.Analytics.Pipelines.ParseReferrer Namespace


Process Method

[image]

Sitecore 6.4.1 API
ParseLiveSearch..::..Process Method
ParseLiveSearch Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.ParseReferrer
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void Process(
    ParseReferrerArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As ParseReferrerArgs _
)
Visual C++
public:
virtual void Process(
    ParseReferrerArgs^ args
) override

Parameters

args
Type: Sitecore.Analytics.Pipelines.ParseReferrer..::..ParseReferrerArgs
The arguments.

See Also

ParseLiveSearch Class
Sitecore.Analytics.Pipelines.ParseReferrer Namespace


ParseReferrerArgs Class

[image]

Sitecore 6.4.1 API
ParseReferrerArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.ParseReferrer
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
[SerializableAttribute]
public class ParseReferrerArgs : PipelineArgs
Visual Basic
<SerializableAttribute> _
Public Class ParseReferrerArgs _
    Inherits PipelineArgs
Visual C++
[SerializableAttribute]
public ref class ParseReferrerArgs : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Analytics.Pipelines.ParseReferrer..::..ParseReferrerArgs

See Also

ParseReferrerArgs Members
Sitecore.Analytics.Pipelines.ParseReferrer Namespace


ParseReferrerArgs Members

[image] [image]

Sitecore 6.4.1 API
ParseReferrerArgs Members
ParseReferrerArgs Class Constructors Methods Properties See Also Send Feedback

The ParseReferrerArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ParseReferrerArgs()()()() | Initializes a new instance of the ParseReferrerArgs class.
Protected method | ParseReferrerArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the ParseReferrerArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | AnalyticsSession | Gets or sets the session.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
Public property | UrlReferrer | Gets or sets the URL referrer.

See Also

ParseReferrerArgs Class
Sitecore.Analytics.Pipelines.ParseReferrer Namespace


ParseReferrerArgs Constructor

[image] [image]

Sitecore 6.4.1 API
ParseReferrerArgs Constructor
ParseReferrerArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ParseReferrerArgs()()()() | Initializes a new instance of the ParseReferrerArgs class.
Protected method | ParseReferrerArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the ParseReferrerArgs class.

See Also

ParseReferrerArgs Class
ParseReferrerArgs Members
Sitecore.Analytics.Pipelines.ParseReferrer Namespace


ParseReferrerArgs Constructor

[image]

Sitecore 6.4.1 API
ParseReferrerArgs Constructor
ParseReferrerArgs Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.ParseReferrer
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public ParseReferrerArgs()
Visual Basic
Public Sub New
Visual C++
public:
ParseReferrerArgs()

See Also

ParseReferrerArgs Class
ParseReferrerArgs Overload
Sitecore.Analytics.Pipelines.ParseReferrer Namespace


ParseReferrerArgs Methods

[image] [image]

Sitecore 6.4.1 API
ParseReferrerArgs Methods
ParseReferrerArgs Class See Also Send Feedback

The ParseReferrerArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParseReferrerArgs Class
Sitecore.Analytics.Pipelines.ParseReferrer Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
ParseReferrerArgs..::..AddMessage Method
ParseReferrerArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

ParseReferrerArgs Class
ParseReferrerArgs Members
Sitecore.Analytics.Pipelines.ParseReferrer Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
ParseReferrerArgs..::..Suspend Method
ParseReferrerArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

ParseReferrerArgs Class
ParseReferrerArgs Members
Sitecore.Analytics.Pipelines.ParseReferrer Namespace


ParseReferrerArgs Properties

[image] [image]

Sitecore 6.4.1 API
ParseReferrerArgs Properties
ParseReferrerArgs Class See Also Send Feedback

The ParseReferrerArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | AnalyticsSession | Gets or sets the session.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
Public property | UrlReferrer | Gets or sets the URL referrer.

See Also

ParseReferrerArgs Class
Sitecore.Analytics.Pipelines.ParseReferrer Namespace


AnalyticsSession Property

[image]

Sitecore 6.4.1 API
ParseReferrerArgs..::..AnalyticsSession Property
ParseReferrerArgs Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.ParseReferrer
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public AnalyticsSession AnalyticsSession { get; set; }
Visual Basic
Public Property AnalyticsSession As AnalyticsSession
    Get
    Set
Visual C++
public:
property AnalyticsSession^ AnalyticsSession {
    AnalyticsSession^ get ();
    void set (AnalyticsSession^ value);
}

Field Value

The session.

See Also

ParseReferrerArgs Class
Sitecore.Analytics.Pipelines.ParseReferrer Namespace


UrlReferrer Property

[image]

Sitecore 6.4.1 API
ParseReferrerArgs..::..UrlReferrer Property
ParseReferrerArgs Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.ParseReferrer
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Uri UrlReferrer { get; set; }
Visual Basic
Public Property UrlReferrer As Uri
    Get
    Set
Visual C++
public:
property Uri^ UrlReferrer {
    Uri^ get ();
    void set (Uri^ value);
}

Field Value

The URL referrer.

See Also

ParseReferrerArgs Class
Sitecore.Analytics.Pipelines.ParseReferrer Namespace


ParseReferrerPipeline Class

[image]

Sitecore 6.4.1 API
ParseReferrerPipeline Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.ParseReferrer
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class ParseReferrerPipeline
Visual Basic
Public Class ParseReferrerPipeline
Visual C++
public ref class ParseReferrerPipeline

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines.ParseReferrer..::..ParseReferrerPipeline

See Also

ParseReferrerPipeline Members
Sitecore.Analytics.Pipelines.ParseReferrer Namespace


ParseReferrerPipeline Members

[image] [image]

Sitecore 6.4.1 API
ParseReferrerPipeline Members
ParseReferrerPipeline Class Constructors Methods See Also Send Feedback

The ParseReferrerPipeline type exposes the following members.

Constructors

 | Name | Description
Public method | ParseReferrerPipeline | Initializes a new instance of the ParseReferrerPipeline class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run | Runs the 'publish' pipeline with specified arguments.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParseReferrerPipeline Class
Sitecore.Analytics.Pipelines.ParseReferrer Namespace


ParseReferrerPipeline Constructor

[image]

Sitecore 6.4.1 API
ParseReferrerPipeline Constructor
ParseReferrerPipeline Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.ParseReferrer
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public ParseReferrerPipeline()
Visual Basic
Public Sub New
Visual C++
public:
ParseReferrerPipeline()

See Also

ParseReferrerPipeline Class
Sitecore.Analytics.Pipelines.ParseReferrer Namespace


ParseReferrerPipeline Methods

[image] [image]

Sitecore 6.4.1 API
ParseReferrerPipeline Methods
ParseReferrerPipeline Class See Also Send Feedback

The ParseReferrerPipeline type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run | Runs the 'publish' pipeline with specified arguments.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParseReferrerPipeline Class
Sitecore.Analytics.Pipelines.ParseReferrer Namespace


Run Method

[image]

Sitecore 6.4.1 API
ParseReferrerPipeline..::..Run Method
ParseReferrerPipeline Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.ParseReferrer
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void Run(
    ParseReferrerArgs args
)
Visual Basic
Public Shared Sub Run ( _
    args As ParseReferrerArgs _
)
Visual C++
public:
static void Run(
    ParseReferrerArgs^ args
)

Parameters

args
Type: Sitecore.Analytics.Pipelines.ParseReferrer..::..ParseReferrerArgs
The arguments.

See Also

ParseReferrerPipeline Class
Sitecore.Analytics.Pipelines.ParseReferrer Namespace


ParseReferrerProcessor Class

[image]

Sitecore 6.4.1 API
ParseReferrerProcessor Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.ParseReferrer
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract class ParseReferrerProcessor
Visual Basic
Public MustInherit Class ParseReferrerProcessor
Visual C++
public ref class ParseReferrerProcessor abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines.ParseReferrer..::..ParseReferrerProcessor
Sitecore.Analytics.Pipelines.ParseReferrer..::..ParseGoogle
Sitecore.Analytics.Pipelines.ParseReferrer..::..ParseLiveSearch
Sitecore.Analytics.Pipelines.ParseReferrer..::..ParseYahoo

See Also

ParseReferrerProcessor Members
Sitecore.Analytics.Pipelines.ParseReferrer Namespace


ParseReferrerProcessor Members

[image] [image]

Sitecore 6.4.1 API
ParseReferrerProcessor Members
ParseReferrerProcessor Class Constructors Methods See Also Send Feedback

The ParseReferrerProcessor type exposes the following members.

Constructors

 | Name | Description
Protected method | ParseReferrerProcessor | Initializes a new instance of the ParseReferrerProcessor class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParseReferrerProcessor Class
Sitecore.Analytics.Pipelines.ParseReferrer Namespace


ParseReferrerProcessor Constructor

[image]

Sitecore 6.4.1 API
ParseReferrerProcessor Constructor
ParseReferrerProcessor Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.ParseReferrer
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected ParseReferrerProcessor()
Visual Basic
Protected Sub New
Visual C++
protected:
ParseReferrerProcessor()

See Also

ParseReferrerProcessor Class
Sitecore.Analytics.Pipelines.ParseReferrer Namespace


ParseReferrerProcessor Methods

[image] [image]

Sitecore 6.4.1 API
ParseReferrerProcessor Methods
ParseReferrerProcessor Class See Also Send Feedback

The ParseReferrerProcessor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParseReferrerProcessor Class
Sitecore.Analytics.Pipelines.ParseReferrer Namespace


Process Method

[image]

Sitecore 6.4.1 API
ParseReferrerProcessor..::..Process Method
ParseReferrerProcessor Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.ParseReferrer
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract void Process(
    ParseReferrerArgs args
)
Visual Basic
Public MustOverride Sub Process ( _
    args As ParseReferrerArgs _
)
Visual C++
public:
virtual void Process(
    ParseReferrerArgs^ args
) abstract

Parameters

args
Type: Sitecore.Analytics.Pipelines.ParseReferrer..::..ParseReferrerArgs
The arguments.

See Also

ParseReferrerProcessor Class
Sitecore.Analytics.Pipelines.ParseReferrer Namespace


ParseYahoo Class

[image]

Sitecore 6.4.1 API
ParseYahoo Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.ParseReferrer
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class ParseYahoo : ParseReferrerProcessor
Visual Basic
Public Class ParseYahoo _
    Inherits ParseReferrerProcessor
Visual C++
public ref class ParseYahoo : public ParseReferrerProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines.ParseReferrer..::..ParseReferrerProcessor
Sitecore.Analytics.Pipelines.ParseReferrer..::..ParseYahoo

See Also

ParseYahoo Members
Sitecore.Analytics.Pipelines.ParseReferrer Namespace


ParseYahoo Members

[image] [image]

Sitecore 6.4.1 API
ParseYahoo Members
ParseYahoo Class Constructors Methods See Also Send Feedback

The ParseYahoo type exposes the following members.

Constructors

 | Name | Description
Public method | ParseYahoo | Initializes a new instance of the ParseYahoo class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides ParseReferrerProcessor..::..Process(ParseReferrerArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParseYahoo Class
Sitecore.Analytics.Pipelines.ParseReferrer Namespace


ParseYahoo Constructor

[image]

Sitecore 6.4.1 API
ParseYahoo Constructor
ParseYahoo Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.ParseReferrer
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public ParseYahoo()
Visual Basic
Public Sub New
Visual C++
public:
ParseYahoo()

See Also

ParseYahoo Class
Sitecore.Analytics.Pipelines.ParseReferrer Namespace


ParseYahoo Methods

[image] [image]

Sitecore 6.4.1 API
ParseYahoo Methods
ParseYahoo Class See Also Send Feedback

The ParseYahoo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides ParseReferrerProcessor..::..Process(ParseReferrerArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParseYahoo Class
Sitecore.Analytics.Pipelines.ParseReferrer Namespace


Process Method

[image]

Sitecore 6.4.1 API
ParseYahoo..::..Process Method
ParseYahoo Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.ParseReferrer
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void Process(
    ParseReferrerArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As ParseReferrerArgs _
)
Visual C++
public:
virtual void Process(
    ParseReferrerArgs^ args
) override

Parameters

args
Type: Sitecore.Analytics.Pipelines.ParseReferrer..::..ParseReferrerArgs
The arguments.

See Also

ParseYahoo Class
Sitecore.Analytics.Pipelines.ParseReferrer Namespace


Sitecore.Analytics.Pipelines.RenderingConditions Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Analytics.Pipelines.RenderingConditions Namespace
Send Feedback

Classes

 | Class | Description
Public class | EvaluateProfileKeys | Defines the evaluate profile keys class.
Public class | RenderingConditionArgs | Defines the rendering condition args class.
Public class | RenderingConditionPipeline | Defines the rendering condition pipeline class.
Public class | RenderingConditionProcessor | Defines the rendering condition processor class.


EvaluateProfileKeys Class

[image]

Sitecore 6.4.1 API
EvaluateProfileKeys Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.RenderingConditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class EvaluateProfileKeys : RenderingConditionProcessor
Visual Basic
Public Class EvaluateProfileKeys _
    Inherits RenderingConditionProcessor
Visual C++
public ref class EvaluateProfileKeys : public RenderingConditionProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines.RenderingConditions..::..RenderingConditionProcessor
Sitecore.Analytics.Pipelines.RenderingConditions..::..EvaluateProfileKeys

See Also

EvaluateProfileKeys Members
Sitecore.Analytics.Pipelines.RenderingConditions Namespace


EvaluateProfileKeys Members

[image] [image]

Sitecore 6.4.1 API
EvaluateProfileKeys Members
EvaluateProfileKeys Class Constructors Methods See Also Send Feedback

The EvaluateProfileKeys type exposes the following members.

Constructors

 | Name | Description
Public method | EvaluateProfileKeys | Initializes a new instance of the EvaluateProfileKeys class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides RenderingConditionProcessor..::..Process(RenderingConditionArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EvaluateProfileKeys Class
Sitecore.Analytics.Pipelines.RenderingConditions Namespace


EvaluateProfileKeys Constructor

[image]

Sitecore 6.4.1 API
EvaluateProfileKeys Constructor
EvaluateProfileKeys Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.RenderingConditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public EvaluateProfileKeys()
Visual Basic
Public Sub New
Visual C++
public:
EvaluateProfileKeys()

See Also

EvaluateProfileKeys Class
Sitecore.Analytics.Pipelines.RenderingConditions Namespace


EvaluateProfileKeys Methods

[image] [image]

Sitecore 6.4.1 API
EvaluateProfileKeys Methods
EvaluateProfileKeys Class See Also Send Feedback

The EvaluateProfileKeys type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides RenderingConditionProcessor..::..Process(RenderingConditionArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EvaluateProfileKeys Class
Sitecore.Analytics.Pipelines.RenderingConditions Namespace


Process Method

[image]

Sitecore 6.4.1 API
EvaluateProfileKeys..::..Process Method
EvaluateProfileKeys Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.RenderingConditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void Process(
    RenderingConditionArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As RenderingConditionArgs _
)
Visual C++
public:
virtual void Process(
    RenderingConditionArgs^ args
) override

Parameters

args
Type: Sitecore.Analytics.Pipelines.RenderingConditions..::..RenderingConditionArgs
The arguments.

See Also

EvaluateProfileKeys Class
Sitecore.Analytics.Pipelines.RenderingConditions Namespace


RenderingConditionArgs Class

[image]

Sitecore 6.4.1 API
RenderingConditionArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.RenderingConditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
[SerializableAttribute]
public class RenderingConditionArgs : PipelineArgs
Visual Basic
<SerializableAttribute> _
Public Class RenderingConditionArgs _
    Inherits PipelineArgs
Visual C++
[SerializableAttribute]
public ref class RenderingConditionArgs : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Analytics.Pipelines.RenderingConditions..::..RenderingConditionArgs

See Also

RenderingConditionArgs Members
Sitecore.Analytics.Pipelines.RenderingConditions Namespace


RenderingConditionArgs Constructor

[image] [image]

Sitecore 6.4.1 API
RenderingConditionArgs Constructor
RenderingConditionArgs Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RenderingConditionArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the RenderingConditionArgs class.
Public method | RenderingConditionArgs(XElement, RenderingReference) | Initializes a new instance of the RenderingConditionArgs class.

See Also

RenderingConditionArgs Class
RenderingConditionArgs Members
Sitecore.Analytics.Pipelines.RenderingConditions Namespace


RenderingConditionArgs Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
RenderingConditionArgs Constructor (SerializationInfo, StreamingContext)
RenderingConditionArgs Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.RenderingConditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected RenderingConditionArgs(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
RenderingConditionArgs(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

RenderingConditionArgs Class
RenderingConditionArgs Overload
Sitecore.Analytics.Pipelines.RenderingConditions Namespace


RenderingConditionArgs Constructor (XElement, RenderingReference)

[image]

Sitecore 6.4.1 API
RenderingConditionArgs Constructor (XElement, RenderingReference)
RenderingConditionArgs Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.RenderingConditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public RenderingConditionArgs(
    XElement element,
    RenderingReference renderingReference
)
Visual Basic
Public Sub New ( _
    element As XElement, _
    renderingReference As RenderingReference _
)
Visual C++
public:
RenderingConditionArgs(
    XElement^ element,
    RenderingReference^ renderingReference
)

Parameters

element
Type: System.Xml.Linq..::..XElement
The element.
renderingReference
Type: Sitecore.Layouts..::..RenderingReference
The rendering reference.

See Also

RenderingConditionArgs Class
RenderingConditionArgs Overload
Sitecore.Analytics.Pipelines.RenderingConditions Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
RenderingConditionArgs..::..AddMessage Method
RenderingConditionArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

RenderingConditionArgs Class
RenderingConditionArgs Members
Sitecore.Analytics.Pipelines.RenderingConditions Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
RenderingConditionArgs..::..GetMessages Method
RenderingConditionArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

RenderingConditionArgs Class
RenderingConditionArgs Members
Sitecore.Analytics.Pipelines.RenderingConditions Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
RenderingConditionArgs..::..Suspend Method
RenderingConditionArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

RenderingConditionArgs Class
RenderingConditionArgs Members
Sitecore.Analytics.Pipelines.RenderingConditions Namespace


RenderingConditionArgs Properties

[image] [image]

Sitecore 6.4.1 API
RenderingConditionArgs Properties
RenderingConditionArgs Class See Also Send Feedback

The RenderingConditionArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CanRender | Gets or sets a value indicating whether this instance can render.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Element | Gets the element.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | RenderingReference | Gets the rendering reference.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

RenderingConditionArgs Class
Sitecore.Analytics.Pipelines.RenderingConditions Namespace


CanRender Property

[image]

Sitecore 6.4.1 API
RenderingConditionArgs..::..CanRender Property
RenderingConditionArgs Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.RenderingConditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public bool CanRender { get; set; }
Visual Basic
Public Property CanRender As Boolean
    Get
    Set
Visual C++
public:
property bool CanRender {
    bool get ();
    void set (bool value);
}

Field Value

true if this instance can render; otherwise, false.

See Also

RenderingConditionArgs Class
Sitecore.Analytics.Pipelines.RenderingConditions Namespace


Element Property

[image]

Sitecore 6.4.1 API
RenderingConditionArgs..::..Element Property
RenderingConditionArgs Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.RenderingConditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public XElement Element { get; }
Visual Basic
Public ReadOnly Property Element As XElement
    Get
Visual C++
public:
property XElement^ Element {
    XElement^ get ();
}

Field Value

The element.

See Also

RenderingConditionArgs Class
Sitecore.Analytics.Pipelines.RenderingConditions Namespace


RenderingConditionPipeline Class

[image]

Sitecore 6.4.1 API
RenderingConditionPipeline Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.RenderingConditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class RenderingConditionPipeline
Visual Basic
Public Class RenderingConditionPipeline
Visual C++
public ref class RenderingConditionPipeline

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines.RenderingConditions..::..RenderingConditionPipeline

See Also

RenderingConditionPipeline Members
Sitecore.Analytics.Pipelines.RenderingConditions Namespace


RenderingConditionPipeline Members

[image] [image]

Sitecore 6.4.1 API
RenderingConditionPipeline Members
RenderingConditionPipeline Class Constructors Methods See Also Send Feedback

The RenderingConditionPipeline type exposes the following members.

Constructors

 | Name | Description
Public method | RenderingConditionPipeline | Initializes a new instance of the RenderingConditionPipeline class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run | Runs the 'publish' pipeline with specified arguments.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenderingConditionPipeline Class
Sitecore.Analytics.Pipelines.RenderingConditions Namespace


RenderingConditionPipeline Constructor

[image]

Sitecore 6.4.1 API
RenderingConditionPipeline Constructor
RenderingConditionPipeline Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.RenderingConditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public RenderingConditionPipeline()
Visual Basic
Public Sub New
Visual C++
public:
RenderingConditionPipeline()

See Also

RenderingConditionPipeline Class
Sitecore.Analytics.Pipelines.RenderingConditions Namespace


RenderingConditionPipeline Methods

[image] [image]

Sitecore 6.4.1 API
RenderingConditionPipeline Methods
RenderingConditionPipeline Class See Also Send Feedback

The RenderingConditionPipeline type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run | Runs the 'publish' pipeline with specified arguments.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenderingConditionPipeline Class
Sitecore.Analytics.Pipelines.RenderingConditions Namespace


Run Method

[image]

Sitecore 6.4.1 API
RenderingConditionPipeline..::..Run Method
RenderingConditionPipeline Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.RenderingConditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void Run(
    RenderingConditionArgs args
)
Visual Basic
Public Shared Sub Run ( _
    args As RenderingConditionArgs _
)
Visual C++
public:
static void Run(
    RenderingConditionArgs^ args
)

Parameters

args
Type: Sitecore.Analytics.Pipelines.RenderingConditions..::..RenderingConditionArgs
The arguments.

See Also

RenderingConditionPipeline Class
Sitecore.Analytics.Pipelines.RenderingConditions Namespace


RenderingConditionProcessor Class

[image]

Sitecore 6.4.1 API
RenderingConditionProcessor Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.RenderingConditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract class RenderingConditionProcessor
Visual Basic
Public MustInherit Class RenderingConditionProcessor
Visual C++
public ref class RenderingConditionProcessor abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines.RenderingConditions..::..RenderingConditionProcessor
Sitecore.Analytics.Pipelines.RenderingConditions..::..EvaluateProfileKeys

See Also

RenderingConditionProcessor Members
Sitecore.Analytics.Pipelines.RenderingConditions Namespace


RenderingConditionProcessor Members

[image] [image]

Sitecore 6.4.1 API
RenderingConditionProcessor Members
RenderingConditionProcessor Class Constructors Methods See Also Send Feedback

The RenderingConditionProcessor type exposes the following members.

Constructors

 | Name | Description
Protected method | RenderingConditionProcessor | Initializes a new instance of the RenderingConditionProcessor class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenderingConditionProcessor Class
Sitecore.Analytics.Pipelines.RenderingConditions Namespace


RenderingConditionProcessor Constructor

[image]

Sitecore 6.4.1 API
RenderingConditionProcessor Constructor
RenderingConditionProcessor Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.RenderingConditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected RenderingConditionProcessor()
Visual Basic
Protected Sub New
Visual C++
protected:
RenderingConditionProcessor()

See Also

RenderingConditionProcessor Class
Sitecore.Analytics.Pipelines.RenderingConditions Namespace


RenderingConditionProcessor Methods

[image] [image]

Sitecore 6.4.1 API
RenderingConditionProcessor Methods
RenderingConditionProcessor Class See Also Send Feedback

The RenderingConditionProcessor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenderingConditionProcessor Class
Sitecore.Analytics.Pipelines.RenderingConditions Namespace


Process Method

[image]

Sitecore 6.4.1 API
RenderingConditionProcessor..::..Process Method
RenderingConditionProcessor Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.RenderingConditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract void Process(
    RenderingConditionArgs args
)
Visual Basic
Public MustOverride Sub Process ( _
    args As RenderingConditionArgs _
)
Visual C++
public:
virtual void Process(
    RenderingConditionArgs^ args
) abstract

Parameters

args
Type: Sitecore.Analytics.Pipelines.RenderingConditions..::..RenderingConditionArgs
The arguments.

See Also

RenderingConditionProcessor Class
Sitecore.Analytics.Pipelines.RenderingConditions Namespace


Sitecore.Analytics.Pipelines.StartTracking Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Analytics.Pipelines.StartTracking Namespace
Send Feedback

Classes

 | Class | Description
Public class | ProcessItem | Defines the process item class.
Public class | ProcessQueryString | Defines the process query string class.
Public class | StartTrackingArgs | Defines the start tracking args class.
Public class | StartTrackingPipeline | Defines the start tracking pipeline class.
Public class | StartTrackingProcessor | Defines the start tracking processor class.


ProcessItem Class

[image]

Sitecore 6.4.1 API
ProcessItem Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.StartTracking
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class ProcessItem : StartTrackingProcessor
Visual Basic
Public Class ProcessItem _
    Inherits StartTrackingProcessor
Visual C++
public ref class ProcessItem : public StartTrackingProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines.StartTracking..::..StartTrackingProcessor
Sitecore.Analytics.Pipelines.StartTracking..::..ProcessItem

See Also

ProcessItem Members
Sitecore.Analytics.Pipelines.StartTracking Namespace


ProcessItem Members

[image] [image]

Sitecore 6.4.1 API
ProcessItem Members
ProcessItem Class Constructors Methods See Also Send Feedback

The ProcessItem type exposes the following members.

Constructors

 | Name | Description
Public method | ProcessItem | Initializes a new instance of the ProcessItem class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides StartTrackingProcessor..::..Process(StartTrackingArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProcessItem Class
Sitecore.Analytics.Pipelines.StartTracking Namespace


ProcessItem Constructor

[image]

Sitecore 6.4.1 API
ProcessItem Constructor
ProcessItem Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.StartTracking
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public ProcessItem()
Visual Basic
Public Sub New
Visual C++
public:
ProcessItem()

See Also

ProcessItem Class
Sitecore.Analytics.Pipelines.StartTracking Namespace


ProcessItem Methods

[image] [image]

Sitecore 6.4.1 API
ProcessItem Methods
ProcessItem Class See Also Send Feedback

The ProcessItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides StartTrackingProcessor..::..Process(StartTrackingArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProcessItem Class
Sitecore.Analytics.Pipelines.StartTracking Namespace


Process Method

[image]

Sitecore 6.4.1 API
ProcessItem..::..Process Method
ProcessItem Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.StartTracking
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void Process(
    StartTrackingArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As StartTrackingArgs _
)
Visual C++
public:
virtual void Process(
    StartTrackingArgs^ args
) override

Parameters

args
Type: Sitecore.Analytics.Pipelines.StartTracking..::..StartTrackingArgs
The arguments.

See Also

ProcessItem Class
Sitecore.Analytics.Pipelines.StartTracking Namespace


ProcessQueryString Class

[image]

Sitecore 6.4.1 API
ProcessQueryString Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.StartTracking
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class ProcessQueryString : StartTrackingProcessor
Visual Basic
Public Class ProcessQueryString _
    Inherits StartTrackingProcessor
Visual C++
public ref class ProcessQueryString : public StartTrackingProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines.StartTracking..::..StartTrackingProcessor
Sitecore.Analytics.Pipelines.StartTracking..::..ProcessQueryString

See Also

ProcessQueryString Members
Sitecore.Analytics.Pipelines.StartTracking Namespace


ProcessQueryString Members

[image] [image]

Sitecore 6.4.1 API
ProcessQueryString Members
ProcessQueryString Class Constructors Methods See Also Send Feedback

The ProcessQueryString type exposes the following members.

Constructors

 | Name | Description
Public method | ProcessQueryString | Initializes a new instance of the ProcessQueryString class

Methods

 | Name | Description
Public method | AddTrigger | Adds the counter.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides StartTrackingProcessor..::..Process(StartTrackingArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProcessQueryString Class
Sitecore.Analytics.Pipelines.StartTracking Namespace


ProcessQueryString Constructor

[image]

Sitecore 6.4.1 API
ProcessQueryString Constructor
ProcessQueryString Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.StartTracking
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public ProcessQueryString()
Visual Basic
Public Sub New
Visual C++
public:
ProcessQueryString()

See Also

ProcessQueryString Class
Sitecore.Analytics.Pipelines.StartTracking Namespace


ProcessQueryString Methods

[image] [image]

Sitecore 6.4.1 API
ProcessQueryString Methods
ProcessQueryString Class See Also Send Feedback

The ProcessQueryString type exposes the following members.

Methods

 | Name | Description
Public method | AddTrigger | Adds the counter.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides StartTrackingProcessor..::..Process(StartTrackingArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProcessQueryString Class
Sitecore.Analytics.Pipelines.StartTracking Namespace


AddTrigger Method

[image]

Sitecore 6.4.1 API
ProcessQueryString..::..AddTrigger Method
ProcessQueryString Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.StartTracking
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public virtual void AddTrigger(
    XmlNode configNode
)
Visual Basic
Public Overridable Sub AddTrigger ( _
    configNode As XmlNode _
)
Visual C++
public:
virtual void AddTrigger(
    XmlNode^ configNode
)

Parameters

configNode
Type: System.Xml..::..XmlNode
The config node.

See Also

ProcessQueryString Class
Sitecore.Analytics.Pipelines.StartTracking Namespace


Process Method

[image]

Sitecore 6.4.1 API
ProcessQueryString..::..Process Method
ProcessQueryString Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.StartTracking
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void Process(
    StartTrackingArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As StartTrackingArgs _
)
Visual C++
public:
virtual void Process(
    StartTrackingArgs^ args
) override

Parameters

args
Type: Sitecore.Analytics.Pipelines.StartTracking..::..StartTrackingArgs
The arguments.

See Also

ProcessQueryString Class
Sitecore.Analytics.Pipelines.StartTracking Namespace


StartTrackingArgs Class

[image]

Sitecore 6.4.1 API
StartTrackingArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.StartTracking
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
[SerializableAttribute]
public class StartTrackingArgs : PipelineArgs
Visual Basic
<SerializableAttribute> _
Public Class StartTrackingArgs _
    Inherits PipelineArgs
Visual C++
[SerializableAttribute]
public ref class StartTrackingArgs : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Analytics.Pipelines.StartTracking..::..StartTrackingArgs

See Also

StartTrackingArgs Members
Sitecore.Analytics.Pipelines.StartTracking Namespace


StartTrackingArgs Members

[image] [image]

Sitecore 6.4.1 API
StartTrackingArgs Members
StartTrackingArgs Class Constructors Methods Properties See Also Send Feedback

The StartTrackingArgs type exposes the following members.

Constructors

 | Name | Description
Public method | StartTrackingArgs()()()() | Initializes a new instance of the StartTrackingArgs class.
Protected method | StartTrackingArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the StartTrackingArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

StartTrackingArgs Class
Sitecore.Analytics.Pipelines.StartTracking Namespace


StartTrackingArgs Constructor

[image] [image]

Sitecore 6.4.1 API
StartTrackingArgs Constructor
StartTrackingArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StartTrackingArgs()()()() | Initializes a new instance of the StartTrackingArgs class.
Protected method | StartTrackingArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the StartTrackingArgs class.

See Also

StartTrackingArgs Class
StartTrackingArgs Members
Sitecore.Analytics.Pipelines.StartTracking Namespace


StartTrackingArgs Constructor

[image]

Sitecore 6.4.1 API
StartTrackingArgs Constructor
StartTrackingArgs Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.StartTracking
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public StartTrackingArgs()
Visual Basic
Public Sub New
Visual C++
public:
StartTrackingArgs()

See Also

StartTrackingArgs Class
StartTrackingArgs Overload
Sitecore.Analytics.Pipelines.StartTracking Namespace


StartTrackingArgs Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
StartTrackingArgs Constructor (SerializationInfo, StreamingContext)
StartTrackingArgs Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.StartTracking
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected StartTrackingArgs(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
StartTrackingArgs(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

StartTrackingArgs Class
StartTrackingArgs Overload
Sitecore.Analytics.Pipelines.StartTracking Namespace


StartTrackingArgs Methods

[image] [image]

Sitecore 6.4.1 API
StartTrackingArgs Methods
StartTrackingArgs Class See Also Send Feedback

The StartTrackingArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StartTrackingArgs Class
Sitecore.Analytics.Pipelines.StartTracking Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
StartTrackingArgs..::..AddMessage Method
StartTrackingArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

StartTrackingArgs Class
StartTrackingArgs Members
Sitecore.Analytics.Pipelines.StartTracking Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
StartTrackingArgs..::..Suspend Method
StartTrackingArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

StartTrackingArgs Class
StartTrackingArgs Members
Sitecore.Analytics.Pipelines.StartTracking Namespace


StartTrackingArgs Properties

[image] [image]

Sitecore 6.4.1 API
StartTrackingArgs Properties
StartTrackingArgs Class See Also Send Feedback

The StartTrackingArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

StartTrackingArgs Class
Sitecore.Analytics.Pipelines.StartTracking Namespace


StartTrackingPipeline Class

[image]

Sitecore 6.4.1 API
StartTrackingPipeline Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.StartTracking
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class StartTrackingPipeline
Visual Basic
Public Class StartTrackingPipeline
Visual C++
public ref class StartTrackingPipeline

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines.StartTracking..::..StartTrackingPipeline

See Also

StartTrackingPipeline Members
Sitecore.Analytics.Pipelines.StartTracking Namespace


StartTrackingPipeline Members

[image] [image]

Sitecore 6.4.1 API
StartTrackingPipeline Members
StartTrackingPipeline Class Constructors Methods See Also Send Feedback

The StartTrackingPipeline type exposes the following members.

Constructors

 | Name | Description
Public method | StartTrackingPipeline | Initializes a new instance of the StartTrackingPipeline class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run | Runs the 'publish' pipeline with specified arguments.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StartTrackingPipeline Class
Sitecore.Analytics.Pipelines.StartTracking Namespace


StartTrackingPipeline Constructor

[image]

Sitecore 6.4.1 API
StartTrackingPipeline Constructor
StartTrackingPipeline Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.StartTracking
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public StartTrackingPipeline()
Visual Basic
Public Sub New
Visual C++
public:
StartTrackingPipeline()

See Also

StartTrackingPipeline Class
Sitecore.Analytics.Pipelines.StartTracking Namespace


Run Method

[image]

Sitecore 6.4.1 API
StartTrackingPipeline..::..Run Method
StartTrackingPipeline Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.StartTracking
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void Run(
    StartTrackingArgs args
)
Visual Basic
Public Shared Sub Run ( _
    args As StartTrackingArgs _
)
Visual C++
public:
static void Run(
    StartTrackingArgs^ args
)

Parameters

args
Type: Sitecore.Analytics.Pipelines.StartTracking..::..StartTrackingArgs
The arguments.

See Also

StartTrackingPipeline Class
Sitecore.Analytics.Pipelines.StartTracking Namespace


StartTrackingProcessor Class

[image]

Sitecore 6.4.1 API
StartTrackingProcessor Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.StartTracking
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract class StartTrackingProcessor
Visual Basic
Public MustInherit Class StartTrackingProcessor
Visual C++
public ref class StartTrackingProcessor abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines.StartTracking..::..StartTrackingProcessor
Sitecore.Analytics.Pipelines.StartTracking..::..ProcessItem
Sitecore.Analytics.Pipelines.StartTracking..::..ProcessQueryString

See Also

StartTrackingProcessor Members
Sitecore.Analytics.Pipelines.StartTracking Namespace


StartTrackingProcessor Members

[image] [image]

Sitecore 6.4.1 API
StartTrackingProcessor Members
StartTrackingProcessor Class Constructors Methods See Also Send Feedback

The StartTrackingProcessor type exposes the following members.

Constructors

 | Name | Description
Protected method | StartTrackingProcessor | Initializes a new instance of the StartTrackingProcessor class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StartTrackingProcessor Class
Sitecore.Analytics.Pipelines.StartTracking Namespace


StartTrackingProcessor Constructor

[image]

Sitecore 6.4.1 API
StartTrackingProcessor Constructor
StartTrackingProcessor Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.StartTracking
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected StartTrackingProcessor()
Visual Basic
Protected Sub New
Visual C++
protected:
StartTrackingProcessor()

See Also

StartTrackingProcessor Class
Sitecore.Analytics.Pipelines.StartTracking Namespace


StartTrackingProcessor Methods

[image] [image]

Sitecore 6.4.1 API
StartTrackingProcessor Methods
StartTrackingProcessor Class See Also Send Feedback

The StartTrackingProcessor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StartTrackingProcessor Class
Sitecore.Analytics.Pipelines.StartTracking Namespace


Process Method

[image]

Sitecore 6.4.1 API
StartTrackingProcessor..::..Process Method
StartTrackingProcessor Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.StartTracking
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract void Process(
    StartTrackingArgs args
)
Visual Basic
Public MustOverride Sub Process ( _
    args As StartTrackingArgs _
)
Visual C++
public:
virtual void Process(
    StartTrackingArgs^ args
) abstract

Parameters

args
Type: Sitecore.Analytics.Pipelines.StartTracking..::..StartTrackingArgs
The arguments.

See Also

StartTrackingProcessor Class
Sitecore.Analytics.Pipelines.StartTracking Namespace


Sitecore.Analytics.Pipelines.Submit Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Analytics.Pipelines.Submit Namespace
Send Feedback

Classes

 | Class | Description
Public class | SubmitArgs | Defines the start tracking args class.
Public class | SubmitGlobalSessionTags | Defines the process query string class.
Public class | SubmitPages | Defines the process query string class.
Public class | SubmitPipeline | Defines the submit pipeline class.
Public class | SubmitProcessor | Defines the submit processor class.
Public class | SubmitProfiles | Defines the submit profiles class.
Public class | SubmitSession | Defines the process query string class.


SubmitArgs Class

[image]

Sitecore 6.4.1 API
SubmitArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.Submit
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
[SerializableAttribute]
public class SubmitArgs : PipelineArgs
Visual Basic
<SerializableAttribute> _
Public Class SubmitArgs _
    Inherits PipelineArgs
Visual C++
[SerializableAttribute]
public ref class SubmitArgs : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Analytics.Pipelines.Submit..::..SubmitArgs

See Also

SubmitArgs Members
Sitecore.Analytics.Pipelines.Submit Namespace


SubmitArgs Constructor

[image] [image]

Sitecore 6.4.1 API
SubmitArgs Constructor
SubmitArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SubmitArgs()()()() | Initializes a new instance of the SubmitArgs class.
Protected method | SubmitArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the SubmitArgs class. Initializes a new instance of the StartTrackingArgs class.

See Also

SubmitArgs Class
SubmitArgs Members
Sitecore.Analytics.Pipelines.Submit Namespace


SubmitArgs Constructor

[image]

Sitecore 6.4.1 API
SubmitArgs Constructor
SubmitArgs Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.Submit
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public SubmitArgs()
Visual Basic
Public Sub New
Visual C++
public:
SubmitArgs()

See Also

SubmitArgs Class
SubmitArgs Overload
Sitecore.Analytics.Pipelines.Submit Namespace


SubmitArgs Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
SubmitArgs Constructor (SerializationInfo, StreamingContext)
SubmitArgs Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.Submit
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected SubmitArgs(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
SubmitArgs(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

SubmitArgs Class
SubmitArgs Overload
Sitecore.Analytics.Pipelines.Submit Namespace


SubmitArgs Methods

[image] [image]

Sitecore 6.4.1 API
SubmitArgs Methods
SubmitArgs Class See Also Send Feedback

The SubmitArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubmitArgs Class
Sitecore.Analytics.Pipelines.Submit Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
SubmitArgs..::..GetMessages Method
SubmitArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

SubmitArgs Class
SubmitArgs Members
Sitecore.Analytics.Pipelines.Submit Namespace


SubmitArgs Properties

[image] [image]

Sitecore 6.4.1 API
SubmitArgs Properties
SubmitArgs Class See Also Send Feedback

The SubmitArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | AnalyticsTracker | Gets or sets the analytics tracker.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Session | Gets or sets the session.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

SubmitArgs Class
Sitecore.Analytics.Pipelines.Submit Namespace


AnalyticsTracker Property

[image]

Sitecore 6.4.1 API
SubmitArgs..::..AnalyticsTracker Property
SubmitArgs Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.Submit
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public AnalyticsTracker AnalyticsTracker { get; set; }
Visual Basic
Public Property AnalyticsTracker As AnalyticsTracker
    Get
    Set
Visual C++
public:
property AnalyticsTracker^ AnalyticsTracker {
    AnalyticsTracker^ get ();
    void set (AnalyticsTracker^ value);
}

Field Value

The analytics tracker.

See Also

SubmitArgs Class
Sitecore.Analytics.Pipelines.Submit Namespace


Session Property

[image]

Sitecore 6.4.1 API
SubmitArgs..::..Session Property
SubmitArgs Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.Submit
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Session Session { get; set; }
Visual Basic
Public Property Session As Session
    Get
    Set
Visual C++
public:
property Session^ Session {
    Session^ get ();
    void set (Session^ value);
}

Field Value

The session.

See Also

SubmitArgs Class
Sitecore.Analytics.Pipelines.Submit Namespace


SubmitGlobalSessionTags Class

[image]

Sitecore 6.4.1 API
SubmitGlobalSessionTags Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.Submit
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class SubmitGlobalSessionTags : SubmitProcessor
Visual Basic
Public Class SubmitGlobalSessionTags _
    Inherits SubmitProcessor
Visual C++
public ref class SubmitGlobalSessionTags : public SubmitProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines..::..SqlProcessorBase
Sitecore.Analytics.Pipelines.Submit..::..SubmitProcessor
Sitecore.Analytics.Pipelines.Submit..::..SubmitGlobalSessionTags

See Also

SubmitGlobalSessionTags Members
Sitecore.Analytics.Pipelines.Submit Namespace


SubmitGlobalSessionTags Members

[image] [image]

Sitecore 6.4.1 API
SubmitGlobalSessionTags Members
SubmitGlobalSessionTags Class Constructors Methods See Also Send Feedback

The SubmitGlobalSessionTags type exposes the following members.

Constructors

 | Name | Description
Public method | SubmitGlobalSessionTags | Initializes a new instance of the SubmitGlobalSessionTags class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides SubmitProcessor..::..Process(SubmitArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubmitGlobalSessionTags Class
Sitecore.Analytics.Pipelines.Submit Namespace


SubmitGlobalSessionTags Constructor

[image]

Sitecore 6.4.1 API
SubmitGlobalSessionTags Constructor
SubmitGlobalSessionTags Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.Submit
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public SubmitGlobalSessionTags()
Visual Basic
Public Sub New
Visual C++
public:
SubmitGlobalSessionTags()

See Also

SubmitGlobalSessionTags Class
Sitecore.Analytics.Pipelines.Submit Namespace


SubmitGlobalSessionTags Methods

[image] [image]

Sitecore 6.4.1 API
SubmitGlobalSessionTags Methods
SubmitGlobalSessionTags Class See Also Send Feedback

The SubmitGlobalSessionTags type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides SubmitProcessor..::..Process(SubmitArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubmitGlobalSessionTags Class
Sitecore.Analytics.Pipelines.Submit Namespace


Process Method

[image]

Sitecore 6.4.1 API
SubmitGlobalSessionTags..::..Process Method
SubmitGlobalSessionTags Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.Submit
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void Process(
    SubmitArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As SubmitArgs _
)
Visual C++
public:
virtual void Process(
    SubmitArgs^ args
) override

Parameters

args
Type: Sitecore.Analytics.Pipelines.Submit..::..SubmitArgs
The arguments.

See Also

SubmitGlobalSessionTags Class
Sitecore.Analytics.Pipelines.Submit Namespace


SubmitPages Class

[image]

Sitecore 6.4.1 API
SubmitPages Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.Submit
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class SubmitPages : SubmitProcessor
Visual Basic
Public Class SubmitPages _
    Inherits SubmitProcessor
Visual C++
public ref class SubmitPages : public SubmitProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines..::..SqlProcessorBase
Sitecore.Analytics.Pipelines.Submit..::..SubmitProcessor
Sitecore.Analytics.Pipelines.Submit..::..SubmitPages

See Also

SubmitPages Members
Sitecore.Analytics.Pipelines.Submit Namespace


SubmitPages Members

[image] [image]

Sitecore 6.4.1 API
SubmitPages Members
SubmitPages Class Constructors Methods See Also Send Feedback

The SubmitPages type exposes the following members.

Constructors

 | Name | Description
Public method | SubmitPages | Initializes a new instance of the SubmitPages class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides SubmitProcessor..::..Process(SubmitArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubmitPages Class
Sitecore.Analytics.Pipelines.Submit Namespace


SubmitPages Constructor

[image]

Sitecore 6.4.1 API
SubmitPages Constructor
SubmitPages Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.Submit
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public SubmitPages()
Visual Basic
Public Sub New
Visual C++
public:
SubmitPages()

See Also

SubmitPages Class
Sitecore.Analytics.Pipelines.Submit Namespace


SubmitPages Methods

[image] [image]

Sitecore 6.4.1 API
SubmitPages Methods
SubmitPages Class See Also Send Feedback

The SubmitPages type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides SubmitProcessor..::..Process(SubmitArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubmitPages Class
Sitecore.Analytics.Pipelines.Submit Namespace


Process Method

[image]

Sitecore 6.4.1 API
SubmitPages..::..Process Method
SubmitPages Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.Submit
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void Process(
    SubmitArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As SubmitArgs _
)
Visual C++
public:
virtual void Process(
    SubmitArgs^ args
) override

Parameters

args
Type: Sitecore.Analytics.Pipelines.Submit..::..SubmitArgs
The arguments.

See Also

SubmitPages Class
Sitecore.Analytics.Pipelines.Submit Namespace


SubmitPipeline Members

[image] [image]

Sitecore 6.4.1 API
SubmitPipeline Members
SubmitPipeline Class Constructors Methods See Also Send Feedback

The SubmitPipeline type exposes the following members.

Constructors

 | Name | Description
Public method | SubmitPipeline | Initializes a new instance of the SubmitPipeline class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run | Runs the 'publish' pipeline with specified arguments.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubmitPipeline Class
Sitecore.Analytics.Pipelines.Submit Namespace


SubmitPipeline Constructor

[image]

Sitecore 6.4.1 API
SubmitPipeline Constructor
SubmitPipeline Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.Submit
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public SubmitPipeline()
Visual Basic
Public Sub New
Visual C++
public:
SubmitPipeline()

See Also

SubmitPipeline Class
Sitecore.Analytics.Pipelines.Submit Namespace


SubmitPipeline Methods

[image] [image]

Sitecore 6.4.1 API
SubmitPipeline Methods
SubmitPipeline Class See Also Send Feedback

The SubmitPipeline type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run | Runs the 'publish' pipeline with specified arguments.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubmitPipeline Class
Sitecore.Analytics.Pipelines.Submit Namespace


Run Method

[image]

Sitecore 6.4.1 API
SubmitPipeline..::..Run Method
SubmitPipeline Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.Submit
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void Run(
    SubmitArgs args
)
Visual Basic
Public Shared Sub Run ( _
    args As SubmitArgs _
)
Visual C++
public:
static void Run(
    SubmitArgs^ args
)

Parameters

args
Type: Sitecore.Analytics.Pipelines.Submit..::..SubmitArgs
The arguments.

See Also

SubmitPipeline Class
Sitecore.Analytics.Pipelines.Submit Namespace


SubmitProcessor Class

[image]

Sitecore 6.4.1 API
SubmitProcessor Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.Submit
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract class SubmitProcessor : SqlProcessorBase
Visual Basic
Public MustInherit Class SubmitProcessor _
    Inherits SqlProcessorBase
Visual C++
public ref class SubmitProcessor abstract : public SqlProcessorBase

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines..::..SqlProcessorBase
Sitecore.Analytics.Pipelines.Submit..::..SubmitProcessor
Sitecore.Analytics.Pipelines.Submit..::..SubmitGlobalSessionTags
Sitecore.Analytics.Pipelines.Submit..::..SubmitPages
Sitecore.Analytics.Pipelines.Submit..::..SubmitProfiles
Sitecore.Analytics.Pipelines.Submit..::..SubmitSession

See Also

SubmitProcessor Members
Sitecore.Analytics.Pipelines.Submit Namespace


SubmitProcessor Members

[image] [image]

Sitecore 6.4.1 API
SubmitProcessor Members
SubmitProcessor Class Constructors Methods See Also Send Feedback

The SubmitProcessor type exposes the following members.

Constructors

 | Name | Description
Protected method | SubmitProcessor | Initializes a new instance of the SubmitProcessor class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubmitProcessor Class
Sitecore.Analytics.Pipelines.Submit Namespace


SubmitProcessor Constructor

[image]

Sitecore 6.4.1 API
SubmitProcessor Constructor
SubmitProcessor Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.Submit
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected SubmitProcessor()
Visual Basic
Protected Sub New
Visual C++
protected:
SubmitProcessor()

See Also

SubmitProcessor Class
Sitecore.Analytics.Pipelines.Submit Namespace


SubmitProcessor Methods

[image] [image]

Sitecore 6.4.1 API
SubmitProcessor Methods
SubmitProcessor Class See Also Send Feedback

The SubmitProcessor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubmitProcessor Class
Sitecore.Analytics.Pipelines.Submit Namespace


Process Method

[image]

Sitecore 6.4.1 API
SubmitProcessor..::..Process Method
SubmitProcessor Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.Submit
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract void Process(
    SubmitArgs args
)
Visual Basic
Public MustOverride Sub Process ( _
    args As SubmitArgs _
)
Visual C++
public:
virtual void Process(
    SubmitArgs^ args
) abstract

Parameters

args
Type: Sitecore.Analytics.Pipelines.Submit..::..SubmitArgs
The arguments.

See Also

SubmitProcessor Class
Sitecore.Analytics.Pipelines.Submit Namespace


SubmitProfiles Class

[image]

Sitecore 6.4.1 API
SubmitProfiles Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.Submit
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class SubmitProfiles : SubmitProcessor
Visual Basic
Public Class SubmitProfiles _
    Inherits SubmitProcessor
Visual C++
public ref class SubmitProfiles : public SubmitProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines..::..SqlProcessorBase
Sitecore.Analytics.Pipelines.Submit..::..SubmitProcessor
Sitecore.Analytics.Pipelines.Submit..::..SubmitProfiles

See Also

SubmitProfiles Members
Sitecore.Analytics.Pipelines.Submit Namespace


SubmitProfiles Members

[image] [image]

Sitecore 6.4.1 API
SubmitProfiles Members
SubmitProfiles Class Constructors Methods See Also Send Feedback

The SubmitProfiles type exposes the following members.

Constructors

 | Name | Description
Public method | SubmitProfiles | Initializes a new instance of the SubmitProfiles class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides SubmitProcessor..::..Process(SubmitArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubmitProfiles Class
Sitecore.Analytics.Pipelines.Submit Namespace


Process Method

[image]

Sitecore 6.4.1 API
SubmitProfiles..::..Process Method
SubmitProfiles Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.Submit
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void Process(
    SubmitArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As SubmitArgs _
)
Visual C++
public:
virtual void Process(
    SubmitArgs^ args
) override

Parameters

args
Type: Sitecore.Analytics.Pipelines.Submit..::..SubmitArgs
The arguments.

See Also

SubmitProfiles Class
Sitecore.Analytics.Pipelines.Submit Namespace


SubmitSession Members

[image] [image]

Sitecore 6.4.1 API
SubmitSession Members
SubmitSession Class Constructors Methods See Also Send Feedback

The SubmitSession type exposes the following members.

Constructors

 | Name | Description
Public method | SubmitSession | Initializes a new instance of the SubmitSession class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides SubmitProcessor..::..Process(SubmitArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubmitSession Class
Sitecore.Analytics.Pipelines.Submit Namespace


SubmitSession Methods

[image] [image]

Sitecore 6.4.1 API
SubmitSession Methods
SubmitSession Class See Also Send Feedback

The SubmitSession type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides SubmitProcessor..::..Process(SubmitArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubmitSession Class
Sitecore.Analytics.Pipelines.Submit Namespace


Process Method

[image]

Sitecore 6.4.1 API
SubmitSession..::..Process Method
SubmitSession Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.Submit
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void Process(
    SubmitArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As SubmitArgs _
)
Visual C++
public:
virtual void Process(
    SubmitArgs^ args
) override

Parameters

args
Type: Sitecore.Analytics.Pipelines.Submit..::..SubmitArgs
The arguments.

See Also

SubmitSession Class
Sitecore.Analytics.Pipelines.Submit Namespace


Sitecore.Analytics.Pipelines.SubmitPage Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Analytics.Pipelines.SubmitPage Namespace
Send Feedback

Classes

 | Class | Description
Public class | SubmitCampaignEvents | Defines the process query string class.
Public class | SubmitCampaignTestVariables | Defines the submit campaign test variables class.
Public class | SubmitPageArgs | Defines the start tracking args class.
Public class | SubmitPageEvents | Defines the process query string class.
Public class | SubmitPagePipeline | Defines the submit pipeline class.
Public class | SubmitPageProcessor | Defines the submit processor class.
Public class | SubmitTestVariables | Defines the submit test variables class.


SubmitCampaignEvents Class

[image]

Sitecore 6.4.1 API
SubmitCampaignEvents Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.SubmitPage
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class SubmitCampaignEvents : SubmitPageProcessor
Visual Basic
Public Class SubmitCampaignEvents _
    Inherits SubmitPageProcessor
Visual C++
public ref class SubmitCampaignEvents : public SubmitPageProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines..::..SqlProcessorBase
Sitecore.Analytics.Pipelines.SubmitPage..::..SubmitPageProcessor
Sitecore.Analytics.Pipelines.SubmitPage..::..SubmitCampaignEvents

See Also

SubmitCampaignEvents Members
Sitecore.Analytics.Pipelines.SubmitPage Namespace


SubmitCampaignEvents Members

[image] [image]

Sitecore 6.4.1 API
SubmitCampaignEvents Members
SubmitCampaignEvents Class Constructors Methods See Also Send Feedback

The SubmitCampaignEvents type exposes the following members.

Constructors

 | Name | Description
Public method | SubmitCampaignEvents | Initializes a new instance of the SubmitCampaignEvents class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides SubmitPageProcessor..::..Process(SubmitPageArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubmitCampaignEvents Class
Sitecore.Analytics.Pipelines.SubmitPage Namespace


SubmitCampaignEvents Constructor

[image]

Sitecore 6.4.1 API
SubmitCampaignEvents Constructor
SubmitCampaignEvents Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.SubmitPage
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public SubmitCampaignEvents()
Visual Basic
Public Sub New
Visual C++
public:
SubmitCampaignEvents()

See Also

SubmitCampaignEvents Class
Sitecore.Analytics.Pipelines.SubmitPage Namespace


SubmitCampaignEvents Methods

[image] [image]

Sitecore 6.4.1 API
SubmitCampaignEvents Methods
SubmitCampaignEvents Class See Also Send Feedback

The SubmitCampaignEvents type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides SubmitPageProcessor..::..Process(SubmitPageArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubmitCampaignEvents Class
Sitecore.Analytics.Pipelines.SubmitPage Namespace


Process Method

[image]

Sitecore 6.4.1 API
SubmitCampaignEvents..::..Process Method
SubmitCampaignEvents Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.SubmitPage
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void Process(
    SubmitPageArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As SubmitPageArgs _
)
Visual C++
public:
virtual void Process(
    SubmitPageArgs^ args
) override

Parameters

args
Type: Sitecore.Analytics.Pipelines.SubmitPage..::..SubmitPageArgs
The arguments.

See Also

SubmitCampaignEvents Class
Sitecore.Analytics.Pipelines.SubmitPage Namespace


SubmitCampaignTestVariables Class

[image]

Sitecore 6.4.1 API
SubmitCampaignTestVariables Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.SubmitPage
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class SubmitCampaignTestVariables : SubmitPageProcessor
Visual Basic
Public Class SubmitCampaignTestVariables _
    Inherits SubmitPageProcessor
Visual C++
public ref class SubmitCampaignTestVariables : public SubmitPageProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines..::..SqlProcessorBase
Sitecore.Analytics.Pipelines.SubmitPage..::..SubmitPageProcessor
Sitecore.Analytics.Pipelines.SubmitPage..::..SubmitCampaignTestVariables

See Also

SubmitCampaignTestVariables Members
Sitecore.Analytics.Pipelines.SubmitPage Namespace


SubmitCampaignTestVariables Members

[image] [image]

Sitecore 6.4.1 API
SubmitCampaignTestVariables Members
SubmitCampaignTestVariables Class Constructors Methods See Also Send Feedback

The SubmitCampaignTestVariables type exposes the following members.

Constructors

 | Name | Description
Public method | SubmitCampaignTestVariables | Initializes a new instance of the SubmitCampaignTestVariables class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides SubmitPageProcessor..::..Process(SubmitPageArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubmitCampaignTestVariables Class
Sitecore.Analytics.Pipelines.SubmitPage Namespace


SubmitCampaignTestVariables Constructor

[image]

Sitecore 6.4.1 API
SubmitCampaignTestVariables Constructor
SubmitCampaignTestVariables Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.SubmitPage
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public SubmitCampaignTestVariables()
Visual Basic
Public Sub New
Visual C++
public:
SubmitCampaignTestVariables()

See Also

SubmitCampaignTestVariables Class
Sitecore.Analytics.Pipelines.SubmitPage Namespace


SubmitCampaignTestVariables Methods

[image] [image]

Sitecore 6.4.1 API
SubmitCampaignTestVariables Methods
SubmitCampaignTestVariables Class See Also Send Feedback

The SubmitCampaignTestVariables type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides SubmitPageProcessor..::..Process(SubmitPageArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubmitCampaignTestVariables Class
Sitecore.Analytics.Pipelines.SubmitPage Namespace


Process Method

[image]

Sitecore 6.4.1 API
SubmitCampaignTestVariables..::..Process Method
SubmitCampaignTestVariables Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.SubmitPage
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void Process(
    SubmitPageArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As SubmitPageArgs _
)
Visual C++
public:
virtual void Process(
    SubmitPageArgs^ args
) override

Parameters

args
Type: Sitecore.Analytics.Pipelines.SubmitPage..::..SubmitPageArgs
The arguments.

See Also

SubmitCampaignTestVariables Class
Sitecore.Analytics.Pipelines.SubmitPage Namespace


SubmitPageArgs Class

[image]

Sitecore 6.4.1 API
SubmitPageArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.SubmitPage
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
[SerializableAttribute]
public class SubmitPageArgs : PipelineArgs
Visual Basic
<SerializableAttribute> _
Public Class SubmitPageArgs _
    Inherits PipelineArgs
Visual C++
[SerializableAttribute]
public ref class SubmitPageArgs : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Analytics.Pipelines.SubmitPage..::..SubmitPageArgs

See Also

SubmitPageArgs Members
Sitecore.Analytics.Pipelines.SubmitPage Namespace


SubmitPageArgs Members

[image] [image]

Sitecore 6.4.1 API
SubmitPageArgs Members
SubmitPageArgs Class Constructors Methods Properties See Also Send Feedback

The SubmitPageArgs type exposes the following members.

Constructors

 | Name | Description
Public method | SubmitPageArgs()()()() | Initializes a new instance of the SubmitPageArgs class.
Protected method | SubmitPageArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the SubmitPageArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | AnalyticsPage | Gets or sets the page.
Public property | AnalyticsTracker | Gets or sets the analytics tracker.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Page | Gets or sets the page.
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

SubmitPageArgs Class
Sitecore.Analytics.Pipelines.SubmitPage Namespace


SubmitPageArgs Constructor

[image]

Sitecore 6.4.1 API
SubmitPageArgs Constructor
SubmitPageArgs Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.SubmitPage
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public SubmitPageArgs()
Visual Basic
Public Sub New
Visual C++
public:
SubmitPageArgs()

See Also

SubmitPageArgs Class
SubmitPageArgs Overload
Sitecore.Analytics.Pipelines.SubmitPage Namespace


SubmitPageArgs Methods

[image] [image]

Sitecore 6.4.1 API
SubmitPageArgs Methods
SubmitPageArgs Class See Also Send Feedback

The SubmitPageArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubmitPageArgs Class
Sitecore.Analytics.Pipelines.SubmitPage Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
SubmitPageArgs..::..AddMessage Method
SubmitPageArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

SubmitPageArgs Class
SubmitPageArgs Members
Sitecore.Analytics.Pipelines.SubmitPage Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
SubmitPageArgs..::..GetMessages Method
SubmitPageArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

SubmitPageArgs Class
SubmitPageArgs Members
Sitecore.Analytics.Pipelines.SubmitPage Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
SubmitPageArgs..::..Suspend Method
SubmitPageArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

SubmitPageArgs Class
SubmitPageArgs Members
Sitecore.Analytics.Pipelines.SubmitPage Namespace


SubmitPageArgs Properties

[image] [image]

Sitecore 6.4.1 API
SubmitPageArgs Properties
SubmitPageArgs Class See Also Send Feedback

The SubmitPageArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | AnalyticsPage | Gets or sets the page.
Public property | AnalyticsTracker | Gets or sets the analytics tracker.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Page | Gets or sets the page.
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

SubmitPageArgs Class
Sitecore.Analytics.Pipelines.SubmitPage Namespace


AnalyticsPage Property

[image]

Sitecore 6.4.1 API
SubmitPageArgs..::..AnalyticsPage Property
SubmitPageArgs Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.SubmitPage
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public AnalyticsPage AnalyticsPage { get; set; }
Visual Basic
Public Property AnalyticsPage As AnalyticsPage
    Get
    Set
Visual C++
public:
property AnalyticsPage^ AnalyticsPage {
    AnalyticsPage^ get ();
    void set (AnalyticsPage^ value);
}

Field Value

The page.

See Also

SubmitPageArgs Class
Sitecore.Analytics.Pipelines.SubmitPage Namespace


AnalyticsTracker Property

[image]

Sitecore 6.4.1 API
SubmitPageArgs..::..AnalyticsTracker Property
SubmitPageArgs Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.SubmitPage
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public AnalyticsTracker AnalyticsTracker { get; set; }
Visual Basic
Public Property AnalyticsTracker As AnalyticsTracker
    Get
    Set
Visual C++
public:
property AnalyticsTracker^ AnalyticsTracker {
    AnalyticsTracker^ get ();
    void set (AnalyticsTracker^ value);
}

Field Value

The analytics tracker.

See Also

SubmitPageArgs Class
Sitecore.Analytics.Pipelines.SubmitPage Namespace


Page Property

[image]

Sitecore 6.4.1 API
SubmitPageArgs..::..Page Property
SubmitPageArgs Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.SubmitPage
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Page Page { get; set; }
Visual Basic
Public Property Page As Page
    Get
    Set
Visual C++
public:
property Page^ Page {
    Page^ get ();
    void set (Page^ value);
}

Field Value

The page.

See Also

SubmitPageArgs Class
Sitecore.Analytics.Pipelines.SubmitPage Namespace


SubmitPageEvents Class

[image]

Sitecore 6.4.1 API
SubmitPageEvents Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.SubmitPage
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class SubmitPageEvents : SubmitPageProcessor
Visual Basic
Public Class SubmitPageEvents _
    Inherits SubmitPageProcessor
Visual C++
public ref class SubmitPageEvents : public SubmitPageProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines..::..SqlProcessorBase
Sitecore.Analytics.Pipelines.SubmitPage..::..SubmitPageProcessor
Sitecore.Analytics.Pipelines.SubmitPage..::..SubmitPageEvents

See Also

SubmitPageEvents Members
Sitecore.Analytics.Pipelines.SubmitPage Namespace


SubmitPageEvents Members

[image] [image]

Sitecore 6.4.1 API
SubmitPageEvents Members
SubmitPageEvents Class Constructors Methods See Also Send Feedback

The SubmitPageEvents type exposes the following members.

Constructors

 | Name | Description
Public method | SubmitPageEvents | Initializes a new instance of the SubmitPageEvents class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides SubmitPageProcessor..::..Process(SubmitPageArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubmitPageEvents Class
Sitecore.Analytics.Pipelines.SubmitPage Namespace


SubmitPageEvents Constructor

[image]

Sitecore 6.4.1 API
SubmitPageEvents Constructor
SubmitPageEvents Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.SubmitPage
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public SubmitPageEvents()
Visual Basic
Public Sub New
Visual C++
public:
SubmitPageEvents()

See Also

SubmitPageEvents Class
Sitecore.Analytics.Pipelines.SubmitPage Namespace


SubmitPageEvents Methods

[image] [image]

Sitecore 6.4.1 API
SubmitPageEvents Methods
SubmitPageEvents Class See Also Send Feedback

The SubmitPageEvents type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides SubmitPageProcessor..::..Process(SubmitPageArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubmitPageEvents Class
Sitecore.Analytics.Pipelines.SubmitPage Namespace


Process Method

[image]

Sitecore 6.4.1 API
SubmitPageEvents..::..Process Method
SubmitPageEvents Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.SubmitPage
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void Process(
    SubmitPageArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As SubmitPageArgs _
)
Visual C++
public:
virtual void Process(
    SubmitPageArgs^ args
) override

Parameters

args
Type: Sitecore.Analytics.Pipelines.SubmitPage..::..SubmitPageArgs
The arguments.

See Also

SubmitPageEvents Class
Sitecore.Analytics.Pipelines.SubmitPage Namespace


SubmitPagePipeline Class

[image]

Sitecore 6.4.1 API
SubmitPagePipeline Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.SubmitPage
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class SubmitPagePipeline
Visual Basic
Public Class SubmitPagePipeline
Visual C++
public ref class SubmitPagePipeline

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines.SubmitPage..::..SubmitPagePipeline

See Also

SubmitPagePipeline Members
Sitecore.Analytics.Pipelines.SubmitPage Namespace


SubmitPagePipeline Members

[image] [image]

Sitecore 6.4.1 API
SubmitPagePipeline Members
SubmitPagePipeline Class Constructors Methods See Also Send Feedback

The SubmitPagePipeline type exposes the following members.

Constructors

 | Name | Description
Public method | SubmitPagePipeline | Initializes a new instance of the SubmitPagePipeline class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run | Runs the 'publish' pipeline with specified arguments.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubmitPagePipeline Class
Sitecore.Analytics.Pipelines.SubmitPage Namespace


SubmitPagePipeline Constructor

[image]

Sitecore 6.4.1 API
SubmitPagePipeline Constructor
SubmitPagePipeline Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.SubmitPage
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public SubmitPagePipeline()
Visual Basic
Public Sub New
Visual C++
public:
SubmitPagePipeline()

See Also

SubmitPagePipeline Class
Sitecore.Analytics.Pipelines.SubmitPage Namespace


SubmitPagePipeline Methods

[image] [image]

Sitecore 6.4.1 API
SubmitPagePipeline Methods
SubmitPagePipeline Class See Also Send Feedback

The SubmitPagePipeline type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run | Runs the 'publish' pipeline with specified arguments.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubmitPagePipeline Class
Sitecore.Analytics.Pipelines.SubmitPage Namespace


Run Method

[image]

Sitecore 6.4.1 API
SubmitPagePipeline..::..Run Method
SubmitPagePipeline Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.SubmitPage
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void Run(
    SubmitPageArgs args
)
Visual Basic
Public Shared Sub Run ( _
    args As SubmitPageArgs _
)
Visual C++
public:
static void Run(
    SubmitPageArgs^ args
)

Parameters

args
Type: Sitecore.Analytics.Pipelines.SubmitPage..::..SubmitPageArgs
The arguments.

See Also

SubmitPagePipeline Class
Sitecore.Analytics.Pipelines.SubmitPage Namespace


SubmitPageProcessor Class

[image]

Sitecore 6.4.1 API
SubmitPageProcessor Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.SubmitPage
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract class SubmitPageProcessor : SqlProcessorBase
Visual Basic
Public MustInherit Class SubmitPageProcessor _
    Inherits SqlProcessorBase
Visual C++
public ref class SubmitPageProcessor abstract : public SqlProcessorBase

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines..::..SqlProcessorBase
Sitecore.Analytics.Pipelines.SubmitPage..::..SubmitPageProcessor
Sitecore.Analytics.Pipelines.SubmitPage..::..SubmitCampaignEvents
Sitecore.Analytics.Pipelines.SubmitPage..::..SubmitCampaignTestVariables
Sitecore.Analytics.Pipelines.SubmitPage..::..SubmitPageEvents
Sitecore.Analytics.Pipelines.SubmitPage..::..SubmitTestVariables

See Also

SubmitPageProcessor Members
Sitecore.Analytics.Pipelines.SubmitPage Namespace


SubmitPageProcessor Members

[image] [image]

Sitecore 6.4.1 API
SubmitPageProcessor Members
SubmitPageProcessor Class Constructors Methods See Also Send Feedback

The SubmitPageProcessor type exposes the following members.

Constructors

 | Name | Description
Protected method | SubmitPageProcessor | Initializes a new instance of the SubmitPageProcessor class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubmitPageProcessor Class
Sitecore.Analytics.Pipelines.SubmitPage Namespace


SubmitPageProcessor Constructor

[image]

Sitecore 6.4.1 API
SubmitPageProcessor Constructor
SubmitPageProcessor Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.SubmitPage
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected SubmitPageProcessor()
Visual Basic
Protected Sub New
Visual C++
protected:
SubmitPageProcessor()

See Also

SubmitPageProcessor Class
Sitecore.Analytics.Pipelines.SubmitPage Namespace


SubmitPageProcessor Methods

[image] [image]

Sitecore 6.4.1 API
SubmitPageProcessor Methods
SubmitPageProcessor Class See Also Send Feedback

The SubmitPageProcessor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubmitPageProcessor Class
Sitecore.Analytics.Pipelines.SubmitPage Namespace


Process Method

[image]

Sitecore 6.4.1 API
SubmitPageProcessor..::..Process Method
SubmitPageProcessor Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.SubmitPage
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract void Process(
    SubmitPageArgs args
)
Visual Basic
Public MustOverride Sub Process ( _
    args As SubmitPageArgs _
)
Visual C++
public:
virtual void Process(
    SubmitPageArgs^ args
) abstract

Parameters

args
Type: Sitecore.Analytics.Pipelines.SubmitPage..::..SubmitPageArgs
The arguments.

See Also

SubmitPageProcessor Class
Sitecore.Analytics.Pipelines.SubmitPage Namespace


SubmitTestVariables Class

[image]

Sitecore 6.4.1 API
SubmitTestVariables Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.SubmitPage
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class SubmitTestVariables : SubmitPageProcessor
Visual Basic
Public Class SubmitTestVariables _
    Inherits SubmitPageProcessor
Visual C++
public ref class SubmitTestVariables : public SubmitPageProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines..::..SqlProcessorBase
Sitecore.Analytics.Pipelines.SubmitPage..::..SubmitPageProcessor
Sitecore.Analytics.Pipelines.SubmitPage..::..SubmitTestVariables

See Also

SubmitTestVariables Members
Sitecore.Analytics.Pipelines.SubmitPage Namespace


SubmitTestVariables Members

[image] [image]

Sitecore 6.4.1 API
SubmitTestVariables Members
SubmitTestVariables Class Constructors Methods See Also Send Feedback

The SubmitTestVariables type exposes the following members.

Constructors

 | Name | Description
Public method | SubmitTestVariables | Initializes a new instance of the SubmitTestVariables class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides SubmitPageProcessor..::..Process(SubmitPageArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubmitTestVariables Class
Sitecore.Analytics.Pipelines.SubmitPage Namespace


SubmitTestVariables Constructor

[image]

Sitecore 6.4.1 API
SubmitTestVariables Constructor
SubmitTestVariables Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.SubmitPage
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public SubmitTestVariables()
Visual Basic
Public Sub New
Visual C++
public:
SubmitTestVariables()

See Also

SubmitTestVariables Class
Sitecore.Analytics.Pipelines.SubmitPage Namespace


SubmitTestVariables Methods

[image] [image]

Sitecore 6.4.1 API
SubmitTestVariables Methods
SubmitTestVariables Class See Also Send Feedback

The SubmitTestVariables type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides SubmitPageProcessor..::..Process(SubmitPageArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubmitTestVariables Class
Sitecore.Analytics.Pipelines.SubmitPage Namespace


Process Method

[image]

Sitecore 6.4.1 API
SubmitTestVariables..::..Process Method
SubmitTestVariables Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.SubmitPage
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void Process(
    SubmitPageArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As SubmitPageArgs _
)
Visual C++
public:
virtual void Process(
    SubmitPageArgs^ args
) override

Parameters

args
Type: Sitecore.Analytics.Pipelines.SubmitPage..::..SubmitPageArgs
The arguments.

See Also

SubmitTestVariables Class
Sitecore.Analytics.Pipelines.SubmitPage Namespace


Sitecore.Analytics.Pipelines.SubmitTests Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Analytics.Pipelines.SubmitTests Namespace
Send Feedback

Classes

 | Class | Description
Public class | SubmitTestsArgs | Defines the start tracking args class.
Public class | SubmitTestsPipeline | Defines the submit pipeline class.
Public class | SubmitTestsProcessor | Defines the submit processor class.
Public class | SubmitTestVariables | Defines the submit test variables class.


SubmitTestsArgs Class

[image]

Sitecore 6.4.1 API
SubmitTestsArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.SubmitTests
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
[SerializableAttribute]
public class SubmitTestsArgs : PipelineArgs
Visual Basic
<SerializableAttribute> _
Public Class SubmitTestsArgs _
    Inherits PipelineArgs
Visual C++
[SerializableAttribute]
public ref class SubmitTestsArgs : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Analytics.Pipelines.SubmitTests..::..SubmitTestsArgs

See Also

SubmitTestsArgs Members
Sitecore.Analytics.Pipelines.SubmitTests Namespace


SubmitTestsArgs Members

[image] [image]

Sitecore 6.4.1 API
SubmitTestsArgs Members
SubmitTestsArgs Class Constructors Methods Properties See Also Send Feedback

The SubmitTestsArgs type exposes the following members.

Constructors

 | Name | Description
Public method | SubmitTestsArgs()()()() | Initializes a new instance of the SubmitArgs class.
Protected method | SubmitTestsArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the StartTrackingArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | AnalyticsTracker | Gets or sets the analytics tracker.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

SubmitTestsArgs Class
Sitecore.Analytics.Pipelines.SubmitTests Namespace


SubmitTestsArgs Constructor

[image] [image]

Sitecore 6.4.1 API
SubmitTestsArgs Constructor
SubmitTestsArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SubmitTestsArgs()()()() | Initializes a new instance of the SubmitArgs class.
Protected method | SubmitTestsArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the StartTrackingArgs class.

See Also

SubmitTestsArgs Class
SubmitTestsArgs Members
Sitecore.Analytics.Pipelines.SubmitTests Namespace


SubmitTestsArgs Constructor

[image]

Sitecore 6.4.1 API
SubmitTestsArgs Constructor
SubmitTestsArgs Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.SubmitTests
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public SubmitTestsArgs()
Visual Basic
Public Sub New
Visual C++
public:
SubmitTestsArgs()

See Also

SubmitTestsArgs Class
SubmitTestsArgs Overload
Sitecore.Analytics.Pipelines.SubmitTests Namespace


SubmitTestsArgs Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
SubmitTestsArgs Constructor (SerializationInfo, StreamingContext)
SubmitTestsArgs Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.SubmitTests
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected SubmitTestsArgs(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
SubmitTestsArgs(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

SubmitTestsArgs Class
SubmitTestsArgs Overload
Sitecore.Analytics.Pipelines.SubmitTests Namespace


SubmitTestsArgs Methods

[image] [image]

Sitecore 6.4.1 API
SubmitTestsArgs Methods
SubmitTestsArgs Class See Also Send Feedback

The SubmitTestsArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubmitTestsArgs Class
Sitecore.Analytics.Pipelines.SubmitTests Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
SubmitTestsArgs..::..AddMessage Method
SubmitTestsArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

SubmitTestsArgs Class
SubmitTestsArgs Members
Sitecore.Analytics.Pipelines.SubmitTests Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
SubmitTestsArgs..::..GetMessages Method
SubmitTestsArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

SubmitTestsArgs Class
SubmitTestsArgs Members
Sitecore.Analytics.Pipelines.SubmitTests Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
SubmitTestsArgs..::..Suspend Method
SubmitTestsArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

SubmitTestsArgs Class
SubmitTestsArgs Members
Sitecore.Analytics.Pipelines.SubmitTests Namespace


SubmitTestsArgs Properties

[image] [image]

Sitecore 6.4.1 API
SubmitTestsArgs Properties
SubmitTestsArgs Class See Also Send Feedback

The SubmitTestsArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | AnalyticsTracker | Gets or sets the analytics tracker.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

SubmitTestsArgs Class
Sitecore.Analytics.Pipelines.SubmitTests Namespace


AnalyticsTracker Property

[image]

Sitecore 6.4.1 API
SubmitTestsArgs..::..AnalyticsTracker Property
SubmitTestsArgs Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.SubmitTests
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public AnalyticsTracker AnalyticsTracker { get; set; }
Visual Basic
Public Property AnalyticsTracker As AnalyticsTracker
    Get
    Set
Visual C++
public:
property AnalyticsTracker^ AnalyticsTracker {
    AnalyticsTracker^ get ();
    void set (AnalyticsTracker^ value);
}

Field Value

The analytics tracker.

See Also

SubmitTestsArgs Class
Sitecore.Analytics.Pipelines.SubmitTests Namespace


SubmitTestsPipeline Class

[image]

Sitecore 6.4.1 API
SubmitTestsPipeline Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.SubmitTests
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class SubmitTestsPipeline
Visual Basic
Public Class SubmitTestsPipeline
Visual C++
public ref class SubmitTestsPipeline

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines.SubmitTests..::..SubmitTestsPipeline

See Also

SubmitTestsPipeline Members
Sitecore.Analytics.Pipelines.SubmitTests Namespace


SubmitTestsPipeline Members

[image] [image]

Sitecore 6.4.1 API
SubmitTestsPipeline Members
SubmitTestsPipeline Class Constructors Methods See Also Send Feedback

The SubmitTestsPipeline type exposes the following members.

Constructors

 | Name | Description
Public method | SubmitTestsPipeline | Initializes a new instance of the SubmitTestsPipeline class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run | Runs the 'publish' pipeline with specified arguments.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubmitTestsPipeline Class
Sitecore.Analytics.Pipelines.SubmitTests Namespace


SubmitTestsPipeline Constructor

[image]

Sitecore 6.4.1 API
SubmitTestsPipeline Constructor
SubmitTestsPipeline Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.SubmitTests
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public SubmitTestsPipeline()
Visual Basic
Public Sub New
Visual C++
public:
SubmitTestsPipeline()

See Also

SubmitTestsPipeline Class
Sitecore.Analytics.Pipelines.SubmitTests Namespace


SubmitTestsPipeline Methods

[image] [image]

Sitecore 6.4.1 API
SubmitTestsPipeline Methods
SubmitTestsPipeline Class See Also Send Feedback

The SubmitTestsPipeline type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run | Runs the 'publish' pipeline with specified arguments.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubmitTestsPipeline Class
Sitecore.Analytics.Pipelines.SubmitTests Namespace


Run Method

[image]

Sitecore 6.4.1 API
SubmitTestsPipeline..::..Run Method
SubmitTestsPipeline Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.SubmitTests
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void Run(
    SubmitTestsArgs args
)
Visual Basic
Public Shared Sub Run ( _
    args As SubmitTestsArgs _
)
Visual C++
public:
static void Run(
    SubmitTestsArgs^ args
)

Parameters

args
Type: Sitecore.Analytics.Pipelines.SubmitTests..::..SubmitTestsArgs
The arguments.

See Also

SubmitTestsPipeline Class
Sitecore.Analytics.Pipelines.SubmitTests Namespace


SubmitTestsProcessor Class

[image]

Sitecore 6.4.1 API
SubmitTestsProcessor Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.SubmitTests
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract class SubmitTestsProcessor : SqlProcessorBase
Visual Basic
Public MustInherit Class SubmitTestsProcessor _
    Inherits SqlProcessorBase
Visual C++
public ref class SubmitTestsProcessor abstract : public SqlProcessorBase

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines..::..SqlProcessorBase
Sitecore.Analytics.Pipelines.SubmitTests..::..SubmitTestsProcessor
Sitecore.Analytics.Pipelines.SubmitTests..::..SubmitTestVariables

See Also

SubmitTestsProcessor Members
Sitecore.Analytics.Pipelines.SubmitTests Namespace


SubmitTestsProcessor Members

[image] [image]

Sitecore 6.4.1 API
SubmitTestsProcessor Members
SubmitTestsProcessor Class Constructors Methods See Also Send Feedback

The SubmitTestsProcessor type exposes the following members.

Constructors

 | Name | Description
Protected method | SubmitTestsProcessor | Initializes a new instance of the SubmitTestsProcessor class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubmitTestsProcessor Class
Sitecore.Analytics.Pipelines.SubmitTests Namespace


SubmitTestsProcessor Constructor

[image]

Sitecore 6.4.1 API
SubmitTestsProcessor Constructor
SubmitTestsProcessor Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.SubmitTests
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected SubmitTestsProcessor()
Visual Basic
Protected Sub New
Visual C++
protected:
SubmitTestsProcessor()

See Also

SubmitTestsProcessor Class
Sitecore.Analytics.Pipelines.SubmitTests Namespace


SubmitTestsProcessor Methods

[image] [image]

Sitecore 6.4.1 API
SubmitTestsProcessor Methods
SubmitTestsProcessor Class See Also Send Feedback

The SubmitTestsProcessor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubmitTestsProcessor Class
Sitecore.Analytics.Pipelines.SubmitTests Namespace


Process Method

[image]

Sitecore 6.4.1 API
SubmitTestsProcessor..::..Process Method
SubmitTestsProcessor Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.SubmitTests
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract void Process(
    SubmitTestsArgs args
)
Visual Basic
Public MustOverride Sub Process ( _
    args As SubmitTestsArgs _
)
Visual C++
public:
virtual void Process(
    SubmitTestsArgs^ args
) abstract

Parameters

args
Type: Sitecore.Analytics.Pipelines.SubmitTests..::..SubmitTestsArgs
The arguments.

See Also

SubmitTestsProcessor Class
Sitecore.Analytics.Pipelines.SubmitTests Namespace


SubmitTestVariables Class

[image]

Sitecore 6.4.1 API
SubmitTestVariables Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.SubmitTests
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class SubmitTestVariables : SubmitTestsProcessor
Visual Basic
Public Class SubmitTestVariables _
    Inherits SubmitTestsProcessor
Visual C++
public ref class SubmitTestVariables : public SubmitTestsProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Pipelines..::..SqlProcessorBase
Sitecore.Analytics.Pipelines.SubmitTests..::..SubmitTestsProcessor
Sitecore.Analytics.Pipelines.SubmitTests..::..SubmitTestVariables

See Also

SubmitTestVariables Members
Sitecore.Analytics.Pipelines.SubmitTests Namespace


SubmitTestVariables Members

[image] [image]

Sitecore 6.4.1 API
SubmitTestVariables Members
SubmitTestVariables Class Constructors Methods See Also Send Feedback

The SubmitTestVariables type exposes the following members.

Constructors

 | Name | Description
Public method | SubmitTestVariables | Initializes a new instance of the SubmitTestVariables class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides SubmitTestsProcessor..::..Process(SubmitTestsArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubmitTestVariables Class
Sitecore.Analytics.Pipelines.SubmitTests Namespace


SubmitTestVariables Constructor

[image]

Sitecore 6.4.1 API
SubmitTestVariables Constructor
SubmitTestVariables Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.SubmitTests
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public SubmitTestVariables()
Visual Basic
Public Sub New
Visual C++
public:
SubmitTestVariables()

See Also

SubmitTestVariables Class
Sitecore.Analytics.Pipelines.SubmitTests Namespace


SubmitTestVariables Methods

[image] [image]

Sitecore 6.4.1 API
SubmitTestVariables Methods
SubmitTestVariables Class See Also Send Feedback

The SubmitTestVariables type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides SubmitTestsProcessor..::..Process(SubmitTestsArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubmitTestVariables Class
Sitecore.Analytics.Pipelines.SubmitTests Namespace


Process Method

[image]

Sitecore 6.4.1 API
SubmitTestVariables..::..Process Method
SubmitTestVariables Class See Also Send Feedback

Namespace: Sitecore.Analytics.Pipelines.SubmitTests
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override void Process(
    SubmitTestsArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As SubmitTestsArgs _
)
Visual C++
public:
virtual void Process(
    SubmitTestsArgs^ args
) override

Parameters

args
Type: Sitecore.Analytics.Pipelines.SubmitTests..::..SubmitTestsArgs
The arguments.

See Also

SubmitTestVariables Class
Sitecore.Analytics.Pipelines.SubmitTests Namespace


Sitecore.Analytics.Reports Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Analytics.Reports Namespace
Send Feedback

Classes

 | Class | Description
Public class | ReportExporter | Defines the report exporter class.
Public class | ReportFactory | Defines the report builder class.
Public class | ReportMailer | Defines the report mailer class.


ReportExporter Class

[image]

Sitecore 6.4.1 API
ReportExporter Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Reports
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static class ReportExporter
Visual Basic
Public NotInheritable Class ReportExporter
Visual C++
public ref class ReportExporter abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Reports..::..ReportExporter

See Also

ReportExporter Members
Sitecore.Analytics.Reports Namespace


ReportExporter Members

[image] [image]

Sitecore 6.4.1 API
ReportExporter Members
ReportExporter Class Methods See Also Send Feedback

The ReportExporter type exposes the following members.

Methods

Name | Description
Export | Exports the specified report file name.

See Also

ReportExporter Class
Sitecore.Analytics.Reports Namespace


ReportExporter Methods

[image] [image]

Sitecore 6.4.1 API
ReportExporter Methods
ReportExporter Class See Also Send Feedback

The ReportExporter type exposes the following members.

Methods

Name | Description
Export | Exports the specified report file name.

See Also

ReportExporter Class
Sitecore.Analytics.Reports Namespace


Export Method

[image]

Sitecore 6.4.1 API
ReportExporter..::..Export Method
ReportExporter Class See Also Send Feedback

Namespace: Sitecore.Analytics.Reports
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static string Export(
    StiReport report,
    StiExportFormat exportFormat,
    string reportTitle,
    params Object[] parameters
)
Visual Basic
Public Shared Function Export ( _
    report As StiReport, _
    exportFormat As StiExportFormat, _
    reportTitle As String, _
    ParamArray parameters As Object() _
) As String
Visual C++
public:
static String^ Export(
    StiReport^ report,
    StiExportFormat exportFormat,
    String^ reportTitle,
    ... array<Object^>^ parameters
)

Parameters

report
Type: StiReport
The report.
exportFormat
Type: StiExportFormat
The export format.
reportTitle
Type: System..::..String
The report title.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.

Return Value

The file name of the report.

See Also

ReportExporter Class
Sitecore.Analytics.Reports Namespace


ReportFactory Members

[image] [image]

Sitecore 6.4.1 API
ReportFactory Members
ReportFactory Class Methods See Also Send Feedback

The ReportFactory type exposes the following members.

Methods

Name | Description
CompileReport | Compiles the report into separate assembly.
GetReport(String) | Gets the report.
GetReport(Database, String, ID, String, DateTime, DateTime, XDocument) | Gets the report.

See Also

ReportFactory Class
Sitecore.Analytics.Reports Namespace


ReportFactory Methods

[image] [image]

Sitecore 6.4.1 API
ReportFactory Methods
ReportFactory Class See Also Send Feedback

The ReportFactory type exposes the following members.

Methods

Name | Description
CompileReport | Compiles the report into separate assembly.
GetReport(String) | Gets the report.
GetReport(Database, String, ID, String, DateTime, DateTime, XDocument) | Gets the report.

See Also

ReportFactory Class
Sitecore.Analytics.Reports Namespace


GetReport Method

[image] [image]

Sitecore 6.4.1 API
ReportFactory..::..GetReport Method
ReportFactory Class See Also Send Feedback

Overload List

Name | Description
GetReport(String) | Gets the report.
GetReport(Database, String, ID, String, DateTime, DateTime, XDocument) | Gets the report.

See Also

ReportFactory Class
ReportFactory Members
Sitecore.Analytics.Reports Namespace


GetReport Method (String)

[image]

Sitecore 6.4.1 API
ReportFactory..::..GetReport Method (String)
ReportFactory Class See Also Send Feedback

Namespace: Sitecore.Analytics.Reports
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static StiReport GetReport(
    string reportFileName
)
Visual Basic
Public Shared Function GetReport ( _
    reportFileName As String _
) As StiReport
Visual C++
public:
static StiReport^ GetReport(
    String^ reportFileName
)

Parameters

reportFileName
Type: System..::..String
Name of the report file.

Return Value

The report.

See Also

ReportFactory Class
GetReport Overload
Sitecore.Analytics.Reports Namespace


GetReport Method (Database, String, ID, String, DateTime, DateTime, XDocument)

[image]

Sitecore 6.4.1 API
ReportFactory..::..GetReport Method (Database, String, ID, String, DateTime, DateTime, XDocument)
ReportFactory Class See Also Send Feedback

Namespace: Sitecore.Analytics.Reports
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static StiReport GetReport(
    Database database,
    string reportFileName,
    ID reportItemId,
    string email,
    DateTime startDate,
    DateTime endDate,
    XDocument filters
)
Visual Basic
Public Shared Function GetReport ( _
    database As Database, _
    reportFileName As String, _
    reportItemId As ID, _
    email As String, _
    startDate As DateTime, _
    endDate As DateTime, _
    filters As XDocument _
) As StiReport
Visual C++
public:
static StiReport^ GetReport(
    Database^ database,
    String^ reportFileName,
    ID^ reportItemId,
    String^ email,
    DateTime startDate,
    DateTime endDate,
    XDocument^ filters
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.
reportFileName
Type: System..::..String
Name of the report file.
reportItemId
Type: Sitecore.Data..::..ID
The report item id.
email
Type: System..::..String
The email.
startDate
Type: System..::..DateTime
The start date.
endDate
Type: System..::..DateTime
The end date.
filters
Type: System.Xml.Linq..::..XDocument
The filters.

Return Value

The report.

See Also

ReportFactory Class
GetReport Overload
Sitecore.Analytics.Reports Namespace


ReportMailer Class

[image]

Sitecore 6.4.1 API
ReportMailer Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Reports
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class ReportMailer
Visual Basic
Public Class ReportMailer
Visual C++
public ref class ReportMailer

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Reports..::..ReportMailer

See Also

ReportMailer Members
Sitecore.Analytics.Reports Namespace


ReportMailer Members

[image] [image]

Sitecore 6.4.1 API
ReportMailer Members
ReportMailer Class Constructors Methods See Also Send Feedback

The ReportMailer type exposes the following members.

Constructors

 | Name | Description
Public method | ReportMailer | Initializes a new instance of the ReportMailer class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Mail | Mails the specified report file name.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportMailer Class
Sitecore.Analytics.Reports Namespace


ReportMailer Constructor

[image]

Sitecore 6.4.1 API
ReportMailer Constructor
ReportMailer Class See Also Send Feedback

Namespace: Sitecore.Analytics.Reports
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public ReportMailer()
Visual Basic
Public Sub New
Visual C++
public:
ReportMailer()

See Also

ReportMailer Class
Sitecore.Analytics.Reports Namespace


ReportMailer Methods

[image] [image]

Sitecore 6.4.1 API
ReportMailer Methods
ReportMailer Class See Also Send Feedback

The ReportMailer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Mail | Mails the specified report file name.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportMailer Class
Sitecore.Analytics.Reports Namespace


Mail Method

[image]

Sitecore 6.4.1 API
ReportMailer..::..Mail Method
ReportMailer Class See Also Send Feedback

Namespace: Sitecore.Analytics.Reports
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static bool Mail(
    string exportedReportFileName,
    IEnumerable<string> recipients,
    string reportTitle,
    bool embedFile,
    bool deleteFile
)
Visual Basic
Public Shared Function Mail ( _
    exportedReportFileName As String, _
    recipients As IEnumerable(Of String), _
    reportTitle As String, _
    embedFile As Boolean, _
    deleteFile As Boolean _
) As Boolean
Visual C++
public:
static bool Mail(
    String^ exportedReportFileName,
    IEnumerable<String^>^ recipients,
    String^ reportTitle,
    bool embedFile,
    bool deleteFile
)

Parameters

exportedReportFileName
Type: System..::..String
Name of the report file.
recipients
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' String >)>)>
The recipients.
reportTitle
Type: System..::..String
The report title.
embedFile
Type: System..::..Boolean
if set to true [embed file].
deleteFile
Type: System..::..Boolean
if set to true [delete file].

Return Value

A boolean that indicates if the mail was sent.

See Also

ReportMailer Class
Sitecore.Analytics.Reports Namespace


Sitecore.Analytics.Rules.Conditions Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Analytics.Rules.Conditions Namespace
Send Feedback

Classes

 | Class | Description
Public class | AreaCodeCondition<(Of <(<'T>)>)> | Defines the area code condition class.
Public class | CityCondition<(Of <(<'T>)>)> | Defines the area code condition class.
Public class | CountryCondition<(Of <(<'T>)>)> | Defines the area code condition class.
Public class | DnsCondition<(Of <(<'T>)>)> | Defines the area code condition class.
Public class | GlobalVisitNoCondition<(Of <(<'T>)>)> | Defines the when template is class.
Public class | IfMultiVariateTestEnabled<(Of <(<'T>)>)> | Defines the when template is class.
Public class | IpAddressCondition<(Of <(<'T>)>)> | Defines the ip address condition class.
Public class | IpBaseCondition<(Of <(<'T>)>)> | Defines the operator condition class.
Public class | IpOwnerBaseCondition<(Of <(<'T>)>)> | Defines the operator condition class.
Public class | IspNameCondition<(Of <(<'T>)>)> | Defines the area code condition class.
Public class | KeywordsCondition<(Of <(<'T>)>)> | Defines the area code condition class.
Public class | LatitudeCondition<(Of <(<'T>)>)> | Defines the area code condition class.
Public class | LongitudeCondition<(Of <(<'T>)>)> | Defines the area code condition class.
Public class | MetroCodeCondition<(Of <(<'T>)>)> | Defines the area code condition class.
Public class | NameCondition<(Of <(<'T>)>)> | Defines the area code condition class.
Public class | PageIndexCondition<(Of <(<'T>)>)> | Defines the when template is class.
Public class | PostalCodeCondition<(Of <(<'T>)>)> | Defines the area code condition class.
Public class | ProcessMultiVariateTestAction<(Of <(<'T>)>)> | Defines the set data source action class.
Public class | ProfileCondition<(Of <(<'T>)>)> | Defines the when subitem of class.
Public class | RegionCondition<(Of <(<'T>)>)> | Defines the area code condition class.
Public class | StickyMultiVariateTestStrategy | Defines the sticky multi variate test strategy class.
Public class | VisitorIdentificationCondition<(Of <(<'T>)>)> | Defines the when subitem of class.

Interfaces

 | Interface | Description
Public interface | IMultiVariateTestStrategy | Defines the interface for getting the test variable item.


AreaCodeCondition(T) Class

[image]

Sitecore 6.4.1 API
AreaCodeCondition<(Of <(<'T>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class AreaCodeCondition<T> : IpBaseCondition<T>
where T : RuleContext
Visual Basic
Public Class AreaCodeCondition(Of T As RuleContext) _
    Inherits IpBaseCondition(Of T)
Visual C++
generic<typename T>
where T : RuleContext
public ref class AreaCodeCondition : public IpBaseCondition<T>

Type Parameters

T
The Rule Context type.

Inheritance Hierarchy

System..::..Object
Sitecore.Rules.Conditions..::..RuleCondition <(Of <(<' T >)>)>
Sitecore.Rules.Conditions..::..WhenCondition <(Of <(<' T >)>)>
Sitecore.Rules.Conditions..::..StringOperatorCondition <(Of <(<' T >)>)>
Sitecore.Analytics.Rules.Conditions..::..IpBaseCondition <(Of <(<' T >)>)>
Sitecore.Analytics.Rules.Conditions..::..AreaCodeCondition<(Of <(<'T>)>)>

See Also

AreaCodeCondition<(Of <(<'T>)>)> Members
Sitecore.Analytics.Rules.Conditions Namespace


AreaCodeCondition(T) Members

[image] [image]

Sitecore 6.4.1 API
AreaCodeCondition<(Of <(<'T>)>)> Members
AreaCodeCondition<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The AreaCodeCondition<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | AreaCodeCondition<(Of <(<'T>)>)> | Initializes a new instance of the AreaCodeCondition<(Of <(<'T>)>)> class

Methods

 | Name | Description
Protected method | Compare | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Execute | Executes the specified rule context. (Inherited from IpBaseCondition<(Of <(<'T>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetColumnValue | Gets the column value. (Overrides IpBaseCondition<(Of <(<'T>)>)>..::..GetColumnValue(IP).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public property | Value | Gets or sets the value. (Inherited from IpBaseCondition<(Of <(<'T>)>)>.)

See Also

AreaCodeCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


AreaCodeCondition(T) Constructor

[image]

Sitecore 6.4.1 API
AreaCodeCondition<(Of <(<'T>)>)> Constructor
AreaCodeCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public AreaCodeCondition()
Visual Basic
Public Sub New
Visual C++
public:
AreaCodeCondition()

See Also

AreaCodeCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


AreaCodeCondition(T) Methods

[image] [image]

Sitecore 6.4.1 API
AreaCodeCondition<(Of <(<'T>)>)> Methods
AreaCodeCondition<(Of <(<'T>)>)> Class See Also Send Feedback

The AreaCodeCondition<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Protected method | Compare | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Execute | Executes the specified rule context. (Inherited from IpBaseCondition<(Of <(<'T>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetColumnValue | Gets the column value. (Overrides IpBaseCondition<(Of <(<'T>)>)>..::..GetColumnValue(IP).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaCodeCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


GetColumnValue Method

[image]

Sitecore 6.4.1 API
AreaCodeCondition<(Of <(<'T>)>)>..::..GetColumnValue Method
AreaCodeCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected override string GetColumnValue(
    IP ip
)
Visual Basic
Protected Overrides Function GetColumnValue ( _
    ip As IP _
) As String
Visual C++
protected:
virtual String^ GetColumnValue(
    IP^ ip
) override

Parameters

ip
Type: Sitecore.Analytics..::..IP
The ip.

Return Value

The column value.

See Also

AreaCodeCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


AreaCodeCondition(T) Properties

[image] [image]

Sitecore 6.4.1 API
AreaCodeCondition<(Of <(<'T>)>)> Properties
AreaCodeCondition<(Of <(<'T>)>)> Class See Also Send Feedback

The AreaCodeCondition<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public property | Value | Gets or sets the value. (Inherited from IpBaseCondition<(Of <(<'T>)>)>.)

See Also

AreaCodeCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


CityCondition(T) Class

[image]

Sitecore 6.4.1 API
CityCondition<(Of <(<'T>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class CityCondition<T> : IpBaseCondition<T>
where T : RuleContext
Visual Basic
Public Class CityCondition(Of T As RuleContext) _
    Inherits IpBaseCondition(Of T)
Visual C++
generic<typename T>
where T : RuleContext
public ref class CityCondition : public IpBaseCondition<T>

Type Parameters

T
The Rule Context type.

Inheritance Hierarchy

System..::..Object
Sitecore.Rules.Conditions..::..RuleCondition <(Of <(<' T >)>)>
Sitecore.Rules.Conditions..::..WhenCondition <(Of <(<' T >)>)>
Sitecore.Rules.Conditions..::..StringOperatorCondition <(Of <(<' T >)>)>
Sitecore.Analytics.Rules.Conditions..::..IpBaseCondition <(Of <(<' T >)>)>
Sitecore.Analytics.Rules.Conditions..::..CityCondition<(Of <(<'T>)>)>

See Also

CityCondition<(Of <(<'T>)>)> Members
Sitecore.Analytics.Rules.Conditions Namespace


CityCondition(T) Members

[image] [image]

Sitecore 6.4.1 API
CityCondition<(Of <(<'T>)>)> Members
CityCondition<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The CityCondition<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | CityCondition<(Of <(<'T>)>)> | Initializes a new instance of the CityCondition<(Of <(<'T>)>)> class

Methods

 | Name | Description
Protected method | Compare | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Execute | Executes the specified rule context. (Inherited from IpBaseCondition<(Of <(<'T>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetColumnValue | Gets the column value. (Overrides IpBaseCondition<(Of <(<'T>)>)>..::..GetColumnValue(IP).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public property | Value | Gets or sets the value. (Inherited from IpBaseCondition<(Of <(<'T>)>)>.)

See Also

CityCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


CityCondition(T) Constructor

[image]

Sitecore 6.4.1 API
CityCondition<(Of <(<'T>)>)> Constructor
CityCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public CityCondition()
Visual Basic
Public Sub New
Visual C++
public:
CityCondition()

See Also

CityCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


CityCondition(T) Methods

[image] [image]

Sitecore 6.4.1 API
CityCondition<(Of <(<'T>)>)> Methods
CityCondition<(Of <(<'T>)>)> Class See Also Send Feedback

The CityCondition<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Protected method | Compare | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Execute | Executes the specified rule context. (Inherited from IpBaseCondition<(Of <(<'T>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetColumnValue | Gets the column value. (Overrides IpBaseCondition<(Of <(<'T>)>)>..::..GetColumnValue(IP).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CityCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


GetColumnValue Method

[image]

Sitecore 6.4.1 API
CityCondition<(Of <(<'T>)>)>..::..GetColumnValue Method
CityCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected override string GetColumnValue(
    IP ip
)
Visual Basic
Protected Overrides Function GetColumnValue ( _
    ip As IP _
) As String
Visual C++
protected:
virtual String^ GetColumnValue(
    IP^ ip
) override

Parameters

ip
Type: Sitecore.Analytics..::..IP
The ip.

Return Value

The column value.

See Also

CityCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


CityCondition(T) Properties

[image] [image]

Sitecore 6.4.1 API
CityCondition<(Of <(<'T>)>)> Properties
CityCondition<(Of <(<'T>)>)> Class See Also Send Feedback

The CityCondition<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public property | Value | Gets or sets the value. (Inherited from IpBaseCondition<(Of <(<'T>)>)>.)

See Also

CityCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


CountryCondition(T) Class

[image]

Sitecore 6.4.1 API
CountryCondition<(Of <(<'T>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class CountryCondition<T> : IpOwnerBaseCondition<T>
where T : RuleContext
Visual Basic
Public Class CountryCondition(Of T As RuleContext) _
    Inherits IpOwnerBaseCondition(Of T)
Visual C++
generic<typename T>
where T : RuleContext
public ref class CountryCondition : public IpOwnerBaseCondition<T>

Type Parameters

T
The Rule Context type.

Inheritance Hierarchy

System..::..Object
Sitecore.Rules.Conditions..::..RuleCondition <(Of <(<' T >)>)>
Sitecore.Rules.Conditions..::..WhenCondition <(Of <(<' T >)>)>
Sitecore.Rules.Conditions..::..StringOperatorCondition <(Of <(<' T >)>)>
Sitecore.Analytics.Rules.Conditions..::..IpOwnerBaseCondition <(Of <(<'T>)>)>
Sitecore.Analytics.Rules.Conditions..::..CountryCondition<(Of <(<'T>)>)>

See Also

CountryCondition<(Of <(<'T>)>)> Members
Sitecore.Analytics.Rules.Conditions Namespace


CountryCondition(T) Members

[image] [image]

Sitecore 6.4.1 API
CountryCondition<(Of <(<'T>)>)> Members
CountryCondition<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The CountryCondition<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | CountryCondition<(Of <(<'T>)>)> | Initializes a new instance of the CountryCondition<(Of <(<'T>)>)> class

Methods

 | Name | Description
Protected method | Compare | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Execute(T) | Executes the specified rule context. (Inherited from IpOwnerBaseCondition<(Of <(<'T>)>)>.)
Protected method | Execute(T) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetColumnValue | Gets the column value. (Overrides IpOwnerBaseCondition<(Of <(<'T>)>)>..::..GetColumnValue(IPOwner).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public property | Value | Gets or sets the value. (Inherited from IpOwnerBaseCondition<(Of <(<'T>)>)>.)

See Also

CountryCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


CountryCondition(T) Constructor

[image]

Sitecore 6.4.1 API
CountryCondition<(Of <(<'T>)>)> Constructor
CountryCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public CountryCondition()
Visual Basic
Public Sub New
Visual C++
public:
CountryCondition()

See Also

CountryCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


CountryCondition(T) Methods

[image] [image]

Sitecore 6.4.1 API
CountryCondition<(Of <(<'T>)>)> Methods
CountryCondition<(Of <(<'T>)>)> Class See Also Send Feedback

The CountryCondition<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Protected method | Compare | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Execute(T) | Executes the specified rule context. (Inherited from IpOwnerBaseCondition<(Of <(<'T>)>)>.)
Protected method | Execute(T) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetColumnValue | Gets the column value. (Overrides IpOwnerBaseCondition<(Of <(<'T>)>)>..::..GetColumnValue(IPOwner).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CountryCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


Execute Method

[image] [image]

Sitecore 6.4.1 API
CountryCondition<(Of <(<'T>)>)>..::..Execute Method
CountryCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Execute(T) | Executes the specified rule context. (Inherited from IpOwnerBaseCondition<(Of <(<'T>)>)>.)
Protected method | Execute(T) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)

See Also

CountryCondition<(Of <(<'T>)>)> Class
CountryCondition<(Of <(<'T>)>)> Members
Sitecore.Analytics.Rules.Conditions Namespace


GetColumnValue Method

[image]

Sitecore 6.4.1 API
CountryCondition<(Of <(<'T>)>)>..::..GetColumnValue Method
CountryCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected override string GetColumnValue(
    IPOwner ip
)
Visual Basic
Protected Overrides Function GetColumnValue ( _
    ip As IPOwner _
) As String
Visual C++
protected:
virtual String^ GetColumnValue(
    IPOwner^ ip
) override

Parameters

ip
Type: Sitecore.Analytics..::..IPOwner
The ip.

Return Value

The column value.

See Also

CountryCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


CountryCondition(T) Properties

[image] [image]

Sitecore 6.4.1 API
CountryCondition<(Of <(<'T>)>)> Properties
CountryCondition<(Of <(<'T>)>)> Class See Also Send Feedback

The CountryCondition<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public property | Value | Gets or sets the value. (Inherited from IpOwnerBaseCondition<(Of <(<'T>)>)>.)

See Also

CountryCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


DnsCondition(T) Class

[image]

Sitecore 6.4.1 API
DnsCondition<(Of <(<'T>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class DnsCondition<T> : IpBaseCondition<T>
where T : RuleContext
Visual Basic
Public Class DnsCondition(Of T As RuleContext) _
    Inherits IpBaseCondition(Of T)
Visual C++
generic<typename T>
where T : RuleContext
public ref class DnsCondition : public IpBaseCondition<T>

Type Parameters

T
The Rule Context type.

Inheritance Hierarchy

System..::..Object
Sitecore.Rules.Conditions..::..RuleCondition <(Of <(<' T >)>)>
Sitecore.Rules.Conditions..::..WhenCondition <(Of <(<' T >)>)>
Sitecore.Rules.Conditions..::..StringOperatorCondition <(Of <(<' T >)>)>
Sitecore.Analytics.Rules.Conditions..::..IpBaseCondition <(Of <(<' T >)>)>
Sitecore.Analytics.Rules.Conditions..::..DnsCondition<(Of <(<'T>)>)>

See Also

DnsCondition<(Of <(<'T>)>)> Members
Sitecore.Analytics.Rules.Conditions Namespace


DnsCondition(T) Members

[image] [image]

Sitecore 6.4.1 API
DnsCondition<(Of <(<'T>)>)> Members
DnsCondition<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The DnsCondition<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | DnsCondition<(Of <(<'T>)>)> | Initializes a new instance of the DnsCondition<(Of <(<'T>)>)> class

Methods

 | Name | Description
Protected method | Compare | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Execute | Executes the specified rule context. (Inherited from IpBaseCondition<(Of <(<'T>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetColumnValue | Gets the column value. (Overrides IpBaseCondition<(Of <(<'T>)>)>..::..GetColumnValue(IP).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public property | Value | Gets or sets the value. (Inherited from IpBaseCondition<(Of <(<'T>)>)>.)

See Also

DnsCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


DnsCondition(T) Constructor

[image]

Sitecore 6.4.1 API
DnsCondition<(Of <(<'T>)>)> Constructor
DnsCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public DnsCondition()
Visual Basic
Public Sub New
Visual C++
public:
DnsCondition()

See Also

DnsCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


GetColumnValue Method

[image]

Sitecore 6.4.1 API
DnsCondition<(Of <(<'T>)>)>..::..GetColumnValue Method
DnsCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected override string GetColumnValue(
    IP ip
)
Visual Basic
Protected Overrides Function GetColumnValue ( _
    ip As IP _
) As String
Visual C++
protected:
virtual String^ GetColumnValue(
    IP^ ip
) override

Parameters

ip
Type: Sitecore.Analytics..::..IP
The ip.

Return Value

The column value.

See Also

DnsCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


DnsCondition(T) Properties

[image] [image]

Sitecore 6.4.1 API
DnsCondition<(Of <(<'T>)>)> Properties
DnsCondition<(Of <(<'T>)>)> Class See Also Send Feedback

The DnsCondition<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public property | Value | Gets or sets the value. (Inherited from IpBaseCondition<(Of <(<'T>)>)>.)

See Also

DnsCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


GlobalVisitNoCondition(T) Class

[image]

Sitecore 6.4.1 API
GlobalVisitNoCondition<(Of <(<'T>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class GlobalVisitNoCondition<T> : OperatorCondition<T>
where T : RuleContext
Visual Basic
Public Class GlobalVisitNoCondition(Of T As RuleContext) _
    Inherits OperatorCondition(Of T)
Visual C++
generic<typename T>
where T : RuleContext
public ref class GlobalVisitNoCondition : public OperatorCondition<T>

Type Parameters

T
The rule context.

Inheritance Hierarchy

System..::..Object
Sitecore.Rules.Conditions..::..RuleCondition <(Of <(<' T >)>)>
Sitecore.Rules.Conditions..::..WhenCondition <(Of <(<' T >)>)>
Sitecore.Rules.Conditions..::..OperatorCondition <(Of <(<' T >)>)>
Sitecore.Analytics.Rules.Conditions..::..GlobalVisitNoCondition<(Of <(<'T>)>)>

See Also

GlobalVisitNoCondition<(Of <(<'T>)>)> Members
Sitecore.Analytics.Rules.Conditions Namespace


GlobalVisitNoCondition(T) Members

[image] [image]

Sitecore 6.4.1 API
GlobalVisitNoCondition<(Of <(<'T>)>)> Members
GlobalVisitNoCondition<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The GlobalVisitNoCondition<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | GlobalVisitNoCondition<(Of <(<'T>)>)> | Initializes a new instance of the GlobalVisitNoCondition<(Of <(<'T>)>)> class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Execute(T) | Executes the specified rule context.
Protected method | Execute(T) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorCondition<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | No | Gets or sets the template id.
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorCondition<(Of <(<'T>)>)>.)

See Also

GlobalVisitNoCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


GlobalVisitNoCondition(T) Constructor

[image]

Sitecore 6.4.1 API
GlobalVisitNoCondition<(Of <(<'T>)>)> Constructor
GlobalVisitNoCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public GlobalVisitNoCondition()
Visual Basic
Public Sub New
Visual C++
public:
GlobalVisitNoCondition()

See Also

GlobalVisitNoCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


GlobalVisitNoCondition(T) Methods

[image] [image]

Sitecore 6.4.1 API
GlobalVisitNoCondition<(Of <(<'T>)>)> Methods
GlobalVisitNoCondition<(Of <(<'T>)>)> Class See Also Send Feedback

The GlobalVisitNoCondition<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Execute(T) | Executes the specified rule context.
Protected method | Execute(T) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorCondition<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GlobalVisitNoCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


Execute Method

[image] [image]

Sitecore 6.4.1 API
GlobalVisitNoCondition<(Of <(<'T>)>)>..::..Execute Method
GlobalVisitNoCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Execute(T) | Executes the specified rule context.
Protected method | Execute(T) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)

See Also

GlobalVisitNoCondition<(Of <(<'T>)>)> Class
GlobalVisitNoCondition<(Of <(<'T>)>)> Members
Sitecore.Analytics.Rules.Conditions Namespace


Execute Method (T)

[image]

Sitecore 6.4.1 API
GlobalVisitNoCondition<(Of <(<'T>)>)>..::..Execute Method (T)
GlobalVisitNoCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected virtual bool Execute(
    T ruleContext
)
Visual Basic
Protected Overridable Function Execute ( _
    ruleContext As T _
) As Boolean
Visual C++
protected:
virtual bool Execute(
    T ruleContext
)

Parameters

ruleContext
Type: T
The rule context.

Return Value

True, if the condition succeeds, otherwise false.

See Also

GlobalVisitNoCondition<(Of <(<'T>)>)> Class
Execute Overload
Sitecore.Analytics.Rules.Conditions Namespace


GlobalVisitNoCondition(T) Properties

[image] [image]

Sitecore 6.4.1 API
GlobalVisitNoCondition<(Of <(<'T>)>)> Properties
GlobalVisitNoCondition<(Of <(<'T>)>)> Class See Also Send Feedback

The GlobalVisitNoCondition<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | No | Gets or sets the template id.
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorCondition<(Of <(<'T>)>)>.)

See Also

GlobalVisitNoCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


No Property

[image]

Sitecore 6.4.1 API
GlobalVisitNoCondition<(Of <(<'T>)>)>..::..No Property
GlobalVisitNoCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int No { get; set; }
Visual Basic
Public Property No As Integer
    Get
    Set
Visual C++
public:
property int No {
    int get ();
    void set (int value);
}

Field Value

The template id.

See Also

GlobalVisitNoCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


IfMultiVariateTestEnabled(T) Class

[image]

Sitecore 6.4.1 API
IfMultiVariateTestEnabled<(Of <(<'T>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class IfMultiVariateTestEnabled<T> : WhenCondition<T>
where T : ConditionalRenderingsRuleContext
Visual Basic
Public Class IfMultiVariateTestEnabled(Of T As ConditionalRenderingsRuleContext) _
    Inherits WhenCondition(Of T)
Visual C++
generic<typename T>
where T : ConditionalRenderingsRuleContext
public ref class IfMultiVariateTestEnabled : public WhenCondition<T>

Type Parameters

T
The rule context.

Inheritance Hierarchy

System..::..Object
Sitecore.Rules.Conditions..::..RuleCondition <(Of <(<'T>)>)>
Sitecore.Rules.Conditions..::..WhenCondition <(Of <(<'T>)>)>
Sitecore.Analytics.Rules.Conditions..::..IfMultiVariateTestEnabled<(Of <(<'T>)>)>

See Also

IfMultiVariateTestEnabled<(Of <(<'T>)>)> Members
Sitecore.Analytics.Rules.Conditions Namespace


IfMultiVariateTestEnabled(T) Members

[image] [image]

Sitecore 6.4.1 API
IfMultiVariateTestEnabled<(Of <(<'T>)>)> Members
IfMultiVariateTestEnabled<(Of <(<'T>)>)> Class Constructors Methods See Also Send Feedback

The IfMultiVariateTestEnabled<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | IfMultiVariateTestEnabled<(Of <(<'T>)>)> | Initializes a new instance of the IfMultiVariateTestEnabled<(Of <(<'T>)>)> class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Execute | Executes the specified rule context. (Overrides WhenCondition<(Of <(<'T>)>)>..::..Execute(T).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IfMultiVariateTestEnabled<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


IfMultiVariateTestEnabled(T) Constructor

[image]

Sitecore 6.4.1 API
IfMultiVariateTestEnabled<(Of <(<'T>)>)> Constructor
IfMultiVariateTestEnabled<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public IfMultiVariateTestEnabled()
Visual Basic
Public Sub New
Visual C++
public:
IfMultiVariateTestEnabled()

See Also

IfMultiVariateTestEnabled<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


IfMultiVariateTestEnabled(T) Methods

[image] [image]

Sitecore 6.4.1 API
IfMultiVariateTestEnabled<(Of <(<'T>)>)> Methods
IfMultiVariateTestEnabled<(Of <(<'T>)>)> Class See Also Send Feedback

The IfMultiVariateTestEnabled<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Execute | Executes the specified rule context. (Overrides WhenCondition<(Of <(<'T>)>)>..::..Execute(T).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IfMultiVariateTestEnabled<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


IMultiVariateTestStrategy Members

[image] [image]

Sitecore 6.4.1 API
IMultiVariateTestStrategy Members
IMultiVariateTestStrategy Interface Methods See Also Send Feedback

The IMultiVariateTestStrategy type exposes the following members.

Methods

 | Name | Description
Public method | GetTestVariableItem | Gets the test variable item.

See Also

IMultiVariateTestStrategy Interface
Sitecore.Analytics.Rules.Conditions Namespace


IMultiVariateTestStrategy Methods

[image] [image]

Sitecore 6.4.1 API
IMultiVariateTestStrategy Methods
IMultiVariateTestStrategy Interface See Also Send Feedback

The IMultiVariateTestStrategy type exposes the following members.

Methods

 | Name | Description
Public method | GetTestVariableItem | Gets the test variable item.

See Also

IMultiVariateTestStrategy Interface
Sitecore.Analytics.Rules.Conditions Namespace


GetTestVariableItem Method

[image]

Sitecore 6.4.1 API
IMultiVariateTestStrategy..::..GetTestVariableItem Method
IMultiVariateTestStrategy Interface See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
Item GetTestVariableItem(
    Item item,
    Item multiVariateTest
)
Visual Basic
Function GetTestVariableItem ( _
    item As Item, _
    multiVariateTest As Item _
) As Item
Visual C++
Item^ GetTestVariableItem(
    Item^ item,
    Item^ multiVariateTest
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
multiVariateTest
Type: Sitecore.Data.Items..::..Item
The multi variate test.

Return Value

Returns the item.

See Also

IMultiVariateTestStrategy Interface
Sitecore.Analytics.Rules.Conditions Namespace


IpAddressCondition(T) Members

[image] [image]

Sitecore 6.4.1 API
IpAddressCondition<(Of <(<'T>)>)> Members
IpAddressCondition<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The IpAddressCondition<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | IpAddressCondition<(Of <(<'T>)>)> | Initializes a new instance of the IpAddressCondition<(Of <(<'T>)>)> class

Methods

 | Name | Description
Protected method | Compare | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Execute | Executes the specified rule context. (Inherited from IpBaseCondition<(Of <(<'T>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetColumnValue | Gets the column value. (Overrides IpBaseCondition<(Of <(<'T>)>)>..::..GetColumnValue(IP).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public property | Value | Gets or sets the value. (Inherited from IpBaseCondition<(Of <(<'T>)>)>.)

See Also

IpAddressCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


IpAddressCondition(T) Constructor

[image]

Sitecore 6.4.1 API
IpAddressCondition<(Of <(<'T>)>)> Constructor
IpAddressCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public IpAddressCondition()
Visual Basic
Public Sub New
Visual C++
public:
IpAddressCondition()

See Also

IpAddressCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


IpAddressCondition(T) Methods

[image] [image]

Sitecore 6.4.1 API
IpAddressCondition<(Of <(<'T>)>)> Methods
IpAddressCondition<(Of <(<'T>)>)> Class See Also Send Feedback

The IpAddressCondition<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Protected method | Compare | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Execute | Executes the specified rule context. (Inherited from IpBaseCondition<(Of <(<'T>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetColumnValue | Gets the column value. (Overrides IpBaseCondition<(Of <(<'T>)>)>..::..GetColumnValue(IP).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IpAddressCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


GetColumnValue Method

[image]

Sitecore 6.4.1 API
IpAddressCondition<(Of <(<'T>)>)>..::..GetColumnValue Method
IpAddressCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected override string GetColumnValue(
    IP ip
)
Visual Basic
Protected Overrides Function GetColumnValue ( _
    ip As IP _
) As String
Visual C++
protected:
virtual String^ GetColumnValue(
    IP^ ip
) override

Parameters

ip
Type: Sitecore.Analytics..::..IP
The ip.

Return Value

The column value.

See Also

IpAddressCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


IpBaseCondition(T) Constructor

[image]

Sitecore 6.4.1 API
IpBaseCondition<(Of <(<'T>)>)> Constructor
IpBaseCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected IpBaseCondition()
Visual Basic
Protected Sub New
Visual C++
protected:
IpBaseCondition()

See Also

IpBaseCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


IpBaseCondition(T) Methods

[image] [image]

Sitecore 6.4.1 API
IpBaseCondition<(Of <(<'T>)>)> Methods
IpBaseCondition<(Of <(<'T>)>)> Class See Also Send Feedback

The IpBaseCondition<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Protected method | Compare | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Execute | Executes the specified rule context. (Overrides WhenCondition<(Of <(<'T>)>)>..::..Execute(T).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetColumnValue | Gets the column value.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IpBaseCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


GetColumnValue Method

[image]

Sitecore 6.4.1 API
IpBaseCondition<(Of <(<'T>)>)>..::..GetColumnValue Method
IpBaseCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected abstract string GetColumnValue(
    IP ip
)
Visual Basic
Protected MustOverride Function GetColumnValue ( _
    ip As IP _
) As String
Visual C++
protected:
virtual String^ GetColumnValue(
    IP^ ip
) abstract

Parameters

ip
Type: Sitecore.Analytics..::..IP
The ip.

Return Value

The column value.

See Also

IpBaseCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


IpBaseCondition(T) Properties

[image] [image]

Sitecore 6.4.1 API
IpBaseCondition<(Of <(<'T>)>)> Properties
IpBaseCondition<(Of <(<'T>)>)> Class See Also Send Feedback

The IpBaseCondition<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public property | Value | Gets or sets the value.

See Also

IpBaseCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


Value Property

[image]

Sitecore 6.4.1 API
IpBaseCondition<(Of <(<'T>)>)>..::..Value Property
IpBaseCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Field Value

The value.

See Also

IpBaseCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


IpOwnerBaseCondition(T) Class

[image]

Sitecore 6.4.1 API
IpOwnerBaseCondition<(Of <(<'T>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract class IpOwnerBaseCondition<T> : StringOperatorCondition<T>
where T : RuleContext
Visual Basic
Public MustInherit Class IpOwnerBaseCondition(Of T As RuleContext) _
    Inherits StringOperatorCondition(Of T)
Visual C++
generic<typename T>
where T : RuleContext
public ref class IpOwnerBaseCondition abstract : public StringOperatorCondition<T>

Type Parameters

T
The rule context.

Inheritance Hierarchy

System..::..Object
Sitecore.Rules.Conditions..::..RuleCondition <(Of <(<' T >)>)>
Sitecore.Rules.Conditions..::..WhenCondition <(Of <(<' T >)>)>
Sitecore.Rules.Conditions..::..StringOperatorCondition <(Of <(<' T >)>)>
Sitecore.Analytics.Rules.Conditions..::..IpOwnerBaseCondition<(Of <(<'T>)>)>
Sitecore.Analytics.Rules.Conditions..::..CountryCondition<(Of <(<'T>)>)>
Sitecore.Analytics.Rules.Conditions..::..NameCondition<(Of <(<'T>)>)>

See Also

IpOwnerBaseCondition<(Of <(<'T>)>)> Members
Sitecore.Analytics.Rules.Conditions Namespace


IpOwnerBaseCondition(T) Members

[image] [image]

Sitecore 6.4.1 API
IpOwnerBaseCondition<(Of <(<'T>)>)> Members
IpOwnerBaseCondition<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The IpOwnerBaseCondition<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Protected method | IpOwnerBaseCondition<(Of <(<'T>)>)> | Initializes a new instance of the IpOwnerBaseCondition<(Of <(<'T>)>)> class

Methods

 | Name | Description
Protected method | Compare | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Execute(T) | Executes the specified rule context.
Protected method | Execute(T) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetColumnValue | Gets the column value.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public property | Value | Gets or sets the value.

See Also

IpOwnerBaseCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


IpOwnerBaseCondition(T) Constructor

[image]

Sitecore 6.4.1 API
IpOwnerBaseCondition<(Of <(<'T>)>)> Constructor
IpOwnerBaseCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected IpOwnerBaseCondition()
Visual Basic
Protected Sub New
Visual C++
protected:
IpOwnerBaseCondition()

See Also

IpOwnerBaseCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


IpOwnerBaseCondition(T) Methods

[image] [image]

Sitecore 6.4.1 API
IpOwnerBaseCondition<(Of <(<'T>)>)> Methods
IpOwnerBaseCondition<(Of <(<'T>)>)> Class See Also Send Feedback

The IpOwnerBaseCondition<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Protected method | Compare | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Execute(T) | Executes the specified rule context.
Protected method | Execute(T) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetColumnValue | Gets the column value.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IpOwnerBaseCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


Execute Method

[image] [image]

Sitecore 6.4.1 API
IpOwnerBaseCondition<(Of <(<'T>)>)>..::..Execute Method
IpOwnerBaseCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Execute(T) | Executes the specified rule context.
Protected method | Execute(T) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)

See Also

IpOwnerBaseCondition<(Of <(<'T>)>)> Class
IpOwnerBaseCondition<(Of <(<'T>)>)> Members
Sitecore.Analytics.Rules.Conditions Namespace


Execute Method (T)

[image]

Sitecore 6.4.1 API
IpOwnerBaseCondition<(Of <(<'T>)>)>..::..Execute Method (T)
IpOwnerBaseCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected virtual bool Execute(
    T ruleContext
)
Visual Basic
Protected Overridable Function Execute ( _
    ruleContext As T _
) As Boolean
Visual C++
protected:
virtual bool Execute(
    T ruleContext
)

Parameters

ruleContext
Type: T
The rule context.

Return Value

True, if the condition succeeds, otherwise false.

See Also

IpOwnerBaseCondition<(Of <(<'T>)>)> Class
Execute Overload
Sitecore.Analytics.Rules.Conditions Namespace


GetColumnValue Method

[image]

Sitecore 6.4.1 API
IpOwnerBaseCondition<(Of <(<'T>)>)>..::..GetColumnValue Method
IpOwnerBaseCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected abstract string GetColumnValue(
    IPOwner ip
)
Visual Basic
Protected MustOverride Function GetColumnValue ( _
    ip As IPOwner _
) As String
Visual C++
protected:
virtual String^ GetColumnValue(
    IPOwner^ ip
) abstract

Parameters

ip
Type: Sitecore.Analytics..::..IPOwner
The ip.

Return Value

The column value.

See Also

IpOwnerBaseCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


IpOwnerBaseCondition(T) Properties

[image] [image]

Sitecore 6.4.1 API
IpOwnerBaseCondition<(Of <(<'T>)>)> Properties
IpOwnerBaseCondition<(Of <(<'T>)>)> Class See Also Send Feedback

The IpOwnerBaseCondition<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public property | Value | Gets or sets the value.

See Also

IpOwnerBaseCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


Value Property

[image]

Sitecore 6.4.1 API
IpOwnerBaseCondition<(Of <(<'T>)>)>..::..Value Property
IpOwnerBaseCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Field Value

The value.

See Also

IpOwnerBaseCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


IspNameCondition(T) Class

[image]

Sitecore 6.4.1 API
IspNameCondition<(Of <(<'T>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class IspNameCondition<T> : IpBaseCondition<T>
where T : RuleContext
Visual Basic
Public Class IspNameCondition(Of T As RuleContext) _
    Inherits IpBaseCondition(Of T)
Visual C++
generic<typename T>
where T : RuleContext
public ref class IspNameCondition : public IpBaseCondition<T>

Type Parameters

T
The Rule Context type.

Inheritance Hierarchy

System..::..Object
Sitecore.Rules.Conditions..::..RuleCondition <(Of <(<' T >)>)>
Sitecore.Rules.Conditions..::..WhenCondition <(Of <(<' T >)>)>
Sitecore.Rules.Conditions..::..StringOperatorCondition <(Of <(<' T >)>)>
Sitecore.Analytics.Rules.Conditions..::..IpBaseCondition <(Of <(<' T >)>)>
Sitecore.Analytics.Rules.Conditions..::..IspNameCondition<(Of <(<'T>)>)>

See Also

IspNameCondition<(Of <(<'T>)>)> Members
Sitecore.Analytics.Rules.Conditions Namespace


IspNameCondition(T) Members

[image] [image]

Sitecore 6.4.1 API
IspNameCondition<(Of <(<'T>)>)> Members
IspNameCondition<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The IspNameCondition<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | IspNameCondition<(Of <(<'T>)>)> | Initializes a new instance of the IspNameCondition<(Of <(<'T>)>)> class

Methods

 | Name | Description
Protected method | Compare | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Execute | Executes the specified rule context. (Inherited from IpBaseCondition<(Of <(<'T>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetColumnValue | Gets the column value. (Overrides IpBaseCondition<(Of <(<'T>)>)>..::..GetColumnValue(IP).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public property | Value | Gets or sets the value. (Inherited from IpBaseCondition<(Of <(<'T>)>)>.)

See Also

IspNameCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


IspNameCondition(T) Constructor

[image]

Sitecore 6.4.1 API
IspNameCondition<(Of <(<'T>)>)> Constructor
IspNameCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public IspNameCondition()
Visual Basic
Public Sub New
Visual C++
public:
IspNameCondition()

See Also

IspNameCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


GetColumnValue Method

[image]

Sitecore 6.4.1 API
IspNameCondition<(Of <(<'T>)>)>..::..GetColumnValue Method
IspNameCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected override string GetColumnValue(
    IP ip
)
Visual Basic
Protected Overrides Function GetColumnValue ( _
    ip As IP _
) As String
Visual C++
protected:
virtual String^ GetColumnValue(
    IP^ ip
) override

Parameters

ip
Type: Sitecore.Analytics..::..IP
The ip.

Return Value

The column value.

See Also

IspNameCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


IspNameCondition(T) Properties

[image] [image]

Sitecore 6.4.1 API
IspNameCondition<(Of <(<'T>)>)> Properties
IspNameCondition<(Of <(<'T>)>)> Class See Also Send Feedback

The IspNameCondition<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public property | Value | Gets or sets the value. (Inherited from IpBaseCondition<(Of <(<'T>)>)>.)

See Also

IspNameCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


KeywordsCondition(T) Class

[image]

Sitecore 6.4.1 API
KeywordsCondition<(Of <(<'T>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class KeywordsCondition<T> : StringOperatorCondition<T>
where T : RuleContext
Visual Basic
Public Class KeywordsCondition(Of T As RuleContext) _
    Inherits StringOperatorCondition(Of T)
Visual C++
generic<typename T>
where T : RuleContext
public ref class KeywordsCondition : public StringOperatorCondition<T>

Type Parameters

T
The Rule Context type.

Inheritance Hierarchy

System..::..Object
Sitecore.Rules.Conditions..::..RuleCondition <(Of <(<' T >)>)>
Sitecore.Rules.Conditions..::..WhenCondition <(Of <(<' T >)>)>
Sitecore.Rules.Conditions..::..StringOperatorCondition <(Of <(<' T >)>)>
Sitecore.Analytics.Rules.Conditions..::..KeywordsCondition<(Of <(<'T>)>)>

See Also

KeywordsCondition<(Of <(<'T>)>)> Members
Sitecore.Analytics.Rules.Conditions Namespace


KeywordsCondition(T) Members

[image] [image]

Sitecore 6.4.1 API
KeywordsCondition<(Of <(<'T>)>)> Members
KeywordsCondition<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The KeywordsCondition<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | KeywordsCondition<(Of <(<'T>)>)> | Initializes a new instance of the KeywordsCondition<(Of <(<'T>)>)> class

Methods

 | Name | Description
Protected method | Compare | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Execute(T) | Executes the specified rule context.
Protected method | Execute(T) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public property | Value | Gets or sets the value.

See Also

KeywordsCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


KeywordsCondition(T) Constructor

[image]

Sitecore 6.4.1 API
KeywordsCondition<(Of <(<'T>)>)> Constructor
KeywordsCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public KeywordsCondition()
Visual Basic
Public Sub New
Visual C++
public:
KeywordsCondition()

See Also

KeywordsCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


KeywordsCondition(T) Methods

[image] [image]

Sitecore 6.4.1 API
KeywordsCondition<(Of <(<'T>)>)> Methods
KeywordsCondition<(Of <(<'T>)>)> Class See Also Send Feedback

The KeywordsCondition<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Protected method | Compare | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Execute(T) | Executes the specified rule context.
Protected method | Execute(T) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

KeywordsCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


Execute Method

[image] [image]

Sitecore 6.4.1 API
KeywordsCondition<(Of <(<'T>)>)>..::..Execute Method
KeywordsCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Execute(T) | Executes the specified rule context.
Protected method | Execute(T) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)

See Also

KeywordsCondition<(Of <(<'T>)>)> Class
KeywordsCondition<(Of <(<'T>)>)> Members
Sitecore.Analytics.Rules.Conditions Namespace


Execute Method (T)

[image]

Sitecore 6.4.1 API
KeywordsCondition<(Of <(<'T>)>)>..::..Execute Method (T)
KeywordsCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected virtual bool Execute(
    T ruleContext
)
Visual Basic
Protected Overridable Function Execute ( _
    ruleContext As T _
) As Boolean
Visual C++
protected:
virtual bool Execute(
    T ruleContext
)

Parameters

ruleContext
Type: T
The rule context.

Return Value

True, if the condition succeeds, otherwise false.

See Also

KeywordsCondition<(Of <(<'T>)>)> Class
Execute Overload
Sitecore.Analytics.Rules.Conditions Namespace


KeywordsCondition(T) Properties

[image] [image]

Sitecore 6.4.1 API
KeywordsCondition<(Of <(<'T>)>)> Properties
KeywordsCondition<(Of <(<'T>)>)> Class See Also Send Feedback

The KeywordsCondition<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public property | Value | Gets or sets the value.

See Also

KeywordsCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


Value Property

[image]

Sitecore 6.4.1 API
KeywordsCondition<(Of <(<'T>)>)>..::..Value Property
KeywordsCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Field Value

The value.

See Also

KeywordsCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


LatitudeCondition(T) Class

[image]

Sitecore 6.4.1 API
LatitudeCondition<(Of <(<'T>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class LatitudeCondition<T> : IpBaseCondition<T>
where T : RuleContext
Visual Basic
Public Class LatitudeCondition(Of T As RuleContext) _
    Inherits IpBaseCondition(Of T)
Visual C++
generic<typename T>
where T : RuleContext
public ref class LatitudeCondition : public IpBaseCondition<T>

Type Parameters

T
The Rule Context type.

Inheritance Hierarchy

System..::..Object
Sitecore.Rules.Conditions..::..RuleCondition <(Of <(<'T>)>)>
Sitecore.Rules.Conditions..::..WhenCondition <(Of <(<'T>)>)>
Sitecore.Rules.Conditions..::..StringOperatorCondition <(Of <(<'T>)>)>
Sitecore.Analytics.Rules.Conditions..::..IpBaseCondition <(Of <(<'T>)>)>
Sitecore.Analytics.Rules.Conditions..::..LatitudeCondition<(Of <(<'T>)>)>

See Also

LatitudeCondition<(Of <(<'T>)>)> Members
Sitecore.Analytics.Rules.Conditions Namespace


LatitudeCondition(T) Members

[image] [image]

Sitecore 6.4.1 API
LatitudeCondition<(Of <(<'T>)>)> Members
LatitudeCondition<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The LatitudeCondition<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | LatitudeCondition<(Of <(<'T>)>)> | Initializes a new instance of the LatitudeCondition<(Of <(<'T>)>)> class

Methods

 | Name | Description
Protected method | Compare | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Execute | Executes the specified rule context. (Inherited from IpBaseCondition<(Of <(<'T>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetColumnValue | Gets the column value. (Overrides IpBaseCondition<(Of <(<'T>)>)>..::..GetColumnValue(IP).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public property | Value | Gets or sets the value. (Inherited from IpBaseCondition<(Of <(<'T>)>)>.)

See Also

LatitudeCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


LatitudeCondition(T) Constructor

[image]

Sitecore 6.4.1 API
LatitudeCondition<(Of <(<'T>)>)> Constructor
LatitudeCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public LatitudeCondition()
Visual Basic
Public Sub New
Visual C++
public:
LatitudeCondition()

See Also

LatitudeCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


LatitudeCondition(T) Methods

[image] [image]

Sitecore 6.4.1 API
LatitudeCondition<(Of <(<'T>)>)> Methods
LatitudeCondition<(Of <(<'T>)>)> Class See Also Send Feedback

The LatitudeCondition<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Protected method | Compare | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Execute | Executes the specified rule context. (Inherited from IpBaseCondition<(Of <(<'T>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetColumnValue | Gets the column value. (Overrides IpBaseCondition<(Of <(<'T>)>)>..::..GetColumnValue(IP).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LatitudeCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


GetColumnValue Method

[image]

Sitecore 6.4.1 API
LatitudeCondition<(Of <(<'T>)>)>..::..GetColumnValue Method
LatitudeCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected override string GetColumnValue(
    IP ip
)
Visual Basic
Protected Overrides Function GetColumnValue ( _
    ip As IP _
) As String
Visual C++
protected:
virtual String^ GetColumnValue(
    IP^ ip
) override

Parameters

ip
Type: Sitecore.Analytics..::..IP
The ip.

Return Value

The column value.

See Also

LatitudeCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


LongitudeCondition(T) Class

[image]

Sitecore 6.4.1 API
LongitudeCondition<(Of <(<'T>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class LongitudeCondition<T> : IpBaseCondition<T>
where T : RuleContext
Visual Basic
Public Class LongitudeCondition(Of T As RuleContext) _
    Inherits IpBaseCondition(Of T)
Visual C++
generic<typename T>
where T : RuleContext
public ref class LongitudeCondition : public IpBaseCondition<T>

Type Parameters

T
The Rule Context type.

Inheritance Hierarchy

System..::..Object
Sitecore.Rules.Conditions..::..RuleCondition <(Of <(<' T >)>)>
Sitecore.Rules.Conditions..::..WhenCondition <(Of <(<' T >)>)>
Sitecore.Rules.Conditions..::..StringOperatorCondition <(Of <(<' T >)>)>
Sitecore.Analytics.Rules.Conditions..::..IpBaseCondition <(Of <(<' T >)>)>
Sitecore.Analytics.Rules.Conditions..::..LongitudeCondition<(Of <(<'T>)>)>

See Also

LongitudeCondition<(Of <(<'T>)>)> Members
Sitecore.Analytics.Rules.Conditions Namespace


LongitudeCondition(T) Members

[image] [image]

Sitecore 6.4.1 API
LongitudeCondition<(Of <(<'T>)>)> Members
LongitudeCondition<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The LongitudeCondition<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | LongitudeCondition<(Of <(<'T>)>)> | Initializes a new instance of the LongitudeCondition<(Of <(<'T>)>)> class

Methods

 | Name | Description
Protected method | Compare | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Execute | Executes the specified rule context. (Inherited from IpBaseCondition<(Of <(<'T>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetColumnValue | Gets the column value. (Overrides IpBaseCondition<(Of <(<'T>)>)>..::..GetColumnValue(IP).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public property | Value | Gets or sets the value. (Inherited from IpBaseCondition<(Of <(<'T>)>)>.)

See Also

LongitudeCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


LongitudeCondition(T) Constructor

[image]

Sitecore 6.4.1 API
LongitudeCondition<(Of <(<'T>)>)> Constructor
LongitudeCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public LongitudeCondition()
Visual Basic
Public Sub New
Visual C++
public:
LongitudeCondition()

See Also

LongitudeCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


GetColumnValue Method

[image]

Sitecore 6.4.1 API
LongitudeCondition<(Of <(<'T>)>)>..::..GetColumnValue Method
LongitudeCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected override string GetColumnValue(
    IP ip
)
Visual Basic
Protected Overrides Function GetColumnValue ( _
    ip As IP _
) As String
Visual C++
protected:
virtual String^ GetColumnValue(
    IP^ ip
) override

Parameters

ip
Type: Sitecore.Analytics..::..IP
The ip.

Return Value

The column value.

See Also

LongitudeCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


LongitudeCondition(T) Properties

[image] [image]

Sitecore 6.4.1 API
LongitudeCondition<(Of <(<'T>)>)> Properties
LongitudeCondition<(Of <(<'T>)>)> Class See Also Send Feedback

The LongitudeCondition<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public property | Value | Gets or sets the value. (Inherited from IpBaseCondition<(Of <(<'T>)>)>.)

See Also

LongitudeCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


MetroCodeCondition(T) Class

[image]

Sitecore 6.4.1 API
MetroCodeCondition<(Of <(<'T>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class MetroCodeCondition<T> : IpBaseCondition<T>
where T : RuleContext
Visual Basic
Public Class MetroCodeCondition(Of T As RuleContext) _
    Inherits IpBaseCondition(Of T)
Visual C++
generic<typename T>
where T : RuleContext
public ref class MetroCodeCondition : public IpBaseCondition<T>

Type Parameters

T
The Rule Context type.

Inheritance Hierarchy

System..::..Object
Sitecore.Rules.Conditions..::..RuleCondition <(Of <(<' T >)>)>
Sitecore.Rules.Conditions..::..WhenCondition <(Of <(<' T >)>)>
Sitecore.Rules.Conditions..::..StringOperatorCondition <(Of <(<' T >)>)>
Sitecore.Analytics.Rules.Conditions..::..IpBaseCondition <(Of <(<' T >)>)>
Sitecore.Analytics.Rules.Conditions..::..MetroCodeCondition<(Of <(<'T>)>)>

See Also

MetroCodeCondition<(Of <(<'T>)>)> Members
Sitecore.Analytics.Rules.Conditions Namespace


MetroCodeCondition(T) Members

[image] [image]

Sitecore 6.4.1 API
MetroCodeCondition<(Of <(<'T>)>)> Members
MetroCodeCondition<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The MetroCodeCondition<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | MetroCodeCondition<(Of <(<'T>)>)> | Initializes a new instance of the MetroCodeCondition<(Of <(<'T>)>)> class

Methods

 | Name | Description
Protected method | Compare | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Execute | Executes the specified rule context. (Inherited from IpBaseCondition<(Of <(<'T>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetColumnValue | Gets the column value. (Overrides IpBaseCondition<(Of <(<'T>)>)>..::..GetColumnValue(IP).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public property | Value | Gets or sets the value. (Inherited from IpBaseCondition<(Of <(<'T>)>)>.)

See Also

MetroCodeCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


MetroCodeCondition(T) Constructor

[image]

Sitecore 6.4.1 API
MetroCodeCondition<(Of <(<'T>)>)> Constructor
MetroCodeCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public MetroCodeCondition()
Visual Basic
Public Sub New
Visual C++
public:
MetroCodeCondition()

See Also

MetroCodeCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


MetroCodeCondition(T) Methods

[image] [image]

Sitecore 6.4.1 API
MetroCodeCondition<(Of <(<'T>)>)> Methods
MetroCodeCondition<(Of <(<'T>)>)> Class See Also Send Feedback

The MetroCodeCondition<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Protected method | Compare | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Execute | Executes the specified rule context. (Inherited from IpBaseCondition<(Of <(<'T>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetColumnValue | Gets the column value. (Overrides IpBaseCondition<(Of <(<'T>)>)>..::..GetColumnValue(IP).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MetroCodeCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


GetColumnValue Method

[image]

Sitecore 6.4.1 API
MetroCodeCondition<(Of <(<'T>)>)>..::..GetColumnValue Method
MetroCodeCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected override string GetColumnValue(
    IP ip
)
Visual Basic
Protected Overrides Function GetColumnValue ( _
    ip As IP _
) As String
Visual C++
protected:
virtual String^ GetColumnValue(
    IP^ ip
) override

Parameters

ip
Type: Sitecore.Analytics..::..IP
The ip.

Return Value

The column value.

See Also

MetroCodeCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


MetroCodeCondition(T) Properties

[image] [image]

Sitecore 6.4.1 API
MetroCodeCondition<(Of <(<'T>)>)> Properties
MetroCodeCondition<(Of <(<'T>)>)> Class See Also Send Feedback

The MetroCodeCondition<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public property | Value | Gets or sets the value. (Inherited from IpBaseCondition<(Of <(<'T>)>)>.)

See Also

MetroCodeCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


NameCondition(T) Class

[image]

Sitecore 6.4.1 API
NameCondition<(Of <(<'T>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class NameCondition<T> : IpOwnerBaseCondition<T>
where T : RuleContext
Visual Basic
Public Class NameCondition(Of T As RuleContext) _
    Inherits IpOwnerBaseCondition(Of T)
Visual C++
generic<typename T>
where T : RuleContext
public ref class NameCondition : public IpOwnerBaseCondition<T>

Type Parameters

T
The Rule Context type.

Inheritance Hierarchy

System..::..Object
Sitecore.Rules.Conditions..::..RuleCondition <(Of <(<' T >)>)>
Sitecore.Rules.Conditions..::..WhenCondition <(Of <(<' T >)>)>
Sitecore.Rules.Conditions..::..StringOperatorCondition <(Of <(<' T >)>)>
Sitecore.Analytics.Rules.Conditions..::..IpOwnerBaseCondition <(Of <(<' T >)>)>
Sitecore.Analytics.Rules.Conditions..::..NameCondition<(Of <(<'T>)>)>

See Also

NameCondition<(Of <(<'T>)>)> Members
Sitecore.Analytics.Rules.Conditions Namespace


NameCondition(T) Members

[image] [image]

Sitecore 6.4.1 API
NameCondition<(Of <(<'T>)>)> Members
NameCondition<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The NameCondition<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | NameCondition<(Of <(<'T>)>)> | Initializes a new instance of the NameCondition<(Of <(<'T>)>)> class

Methods

 | Name | Description
Protected method | Compare | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Execute(T) | Executes the specified rule context. (Inherited from IpOwnerBaseCondition<(Of <(<'T>)>)>.)
Protected method | Execute(T) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetColumnValue | Gets the column value. (Overrides IpOwnerBaseCondition<(Of <(<'T>)>)>..::..GetColumnValue(IPOwner).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public property | Value | Gets or sets the value. (Inherited from IpOwnerBaseCondition<(Of <(<'T>)>)>.)

See Also

NameCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


NameCondition(T) Constructor

[image]

Sitecore 6.4.1 API
NameCondition<(Of <(<'T>)>)> Constructor
NameCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public NameCondition()
Visual Basic
Public Sub New
Visual C++
public:
NameCondition()

See Also

NameCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


NameCondition(T) Methods

[image] [image]

Sitecore 6.4.1 API
NameCondition<(Of <(<'T>)>)> Methods
NameCondition<(Of <(<'T>)>)> Class See Also Send Feedback

The NameCondition<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Protected method | Compare | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Execute(T) | Executes the specified rule context. (Inherited from IpOwnerBaseCondition<(Of <(<'T>)>)>.)
Protected method | Execute(T) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetColumnValue | Gets the column value. (Overrides IpOwnerBaseCondition<(Of <(<'T>)>)>..::..GetColumnValue(IPOwner).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NameCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


Execute Method

[image] [image]

Sitecore 6.4.1 API
NameCondition<(Of <(<'T>)>)>..::..Execute Method
NameCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Execute(T) | Executes the specified rule context. (Inherited from IpOwnerBaseCondition<(Of <(<'T>)>)>.)
Protected method | Execute(T) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)

See Also

NameCondition<(Of <(<'T>)>)> Class
NameCondition<(Of <(<'T>)>)> Members
Sitecore.Analytics.Rules.Conditions Namespace


GetColumnValue Method

[image]

Sitecore 6.4.1 API
NameCondition<(Of <(<'T>)>)>..::..GetColumnValue Method
NameCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected override string GetColumnValue(
    IPOwner ip
)
Visual Basic
Protected Overrides Function GetColumnValue ( _
    ip As IPOwner _
) As String
Visual C++
protected:
virtual String^ GetColumnValue(
    IPOwner^ ip
) override

Parameters

ip
Type: Sitecore.Analytics..::..IPOwner
The ip.

Return Value

The column value.

See Also

NameCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


NameCondition(T) Properties

[image] [image]

Sitecore 6.4.1 API
NameCondition<(Of <(<'T>)>)> Properties
NameCondition<(Of <(<'T>)>)> Class See Also Send Feedback

The NameCondition<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public property | Value | Gets or sets the value. (Inherited from IpOwnerBaseCondition<(Of <(<'T>)>)>.)

See Also

NameCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


PageIndexCondition(T) Class

[image]

Sitecore 6.4.1 API
PageIndexCondition<(Of <(<'T>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class PageIndexCondition<T> : OperatorCondition<T>
where T : RuleContext
Visual Basic
Public Class PageIndexCondition(Of T As RuleContext) _
    Inherits OperatorCondition(Of T)
Visual C++
generic<typename T>
where T : RuleContext
public ref class PageIndexCondition : public OperatorCondition<T>

Type Parameters

T
The rule context.

Inheritance Hierarchy

System..::..Object
Sitecore.Rules.Conditions..::..RuleCondition <(Of <(<' T >)>)>
Sitecore.Rules.Conditions..::..WhenCondition <(Of <(<' T >)>)>
Sitecore.Rules.Conditions..::..OperatorCondition <(Of <(<'T>)>)>
Sitecore.Analytics.Rules.Conditions..::..PageIndexCondition<(Of <(<'T>)>)>

See Also

PageIndexCondition<(Of <(<'T>)>)> Members
Sitecore.Analytics.Rules.Conditions Namespace


PageIndexCondition(T) Members

[image] [image]

Sitecore 6.4.1 API
PageIndexCondition<(Of <(<'T>)>)> Members
PageIndexCondition<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The PageIndexCondition<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | PageIndexCondition<(Of <(<'T>)>)> | Initializes a new instance of the PageIndexCondition<(Of <(<'T>)>)> class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Execute(T) | Executes the specified rule context.
Protected method | Execute(T) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorCondition<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Index | Gets or sets the template id.
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorCondition<(Of <(<'T>)>)>.)

See Also

PageIndexCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


PageIndexCondition(T) Constructor

[image]

Sitecore 6.4.1 API
PageIndexCondition<(Of <(<'T>)>)> Constructor
PageIndexCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public PageIndexCondition()
Visual Basic
Public Sub New
Visual C++
public:
PageIndexCondition()

See Also

PageIndexCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


PageIndexCondition(T) Methods

[image] [image]

Sitecore 6.4.1 API
PageIndexCondition<(Of <(<'T>)>)> Methods
PageIndexCondition<(Of <(<'T>)>)> Class See Also Send Feedback

The PageIndexCondition<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Execute(T) | Executes the specified rule context.
Protected method | Execute(T) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorCondition<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PageIndexCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


Execute Method

[image] [image]

Sitecore 6.4.1 API
PageIndexCondition<(Of <(<'T>)>)>..::..Execute Method
PageIndexCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Execute(T) | Executes the specified rule context.
Protected method | Execute(T) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)

See Also

PageIndexCondition<(Of <(<'T>)>)> Class
PageIndexCondition<(Of <(<'T>)>)> Members
Sitecore.Analytics.Rules.Conditions Namespace


PageIndexCondition(T) Properties

[image] [image]

Sitecore 6.4.1 API
PageIndexCondition<(Of <(<'T>)>)> Properties
PageIndexCondition<(Of <(<'T>)>)> Class See Also Send Feedback

The PageIndexCondition<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Index | Gets or sets the template id.
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorCondition<(Of <(<'T>)>)>.)

See Also

PageIndexCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


PostalCodeCondition(T) Class

[image]

Sitecore 6.4.1 API
PostalCodeCondition<(Of <(<'T>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class PostalCodeCondition<T> : IpBaseCondition<T>
where T : RuleContext
Visual Basic
Public Class PostalCodeCondition(Of T As RuleContext) _
    Inherits IpBaseCondition(Of T)
Visual C++
generic<typename T>
where T : RuleContext
public ref class PostalCodeCondition : public IpBaseCondition<T>

Type Parameters

T
The Rule Context type.

Inheritance Hierarchy

System..::..Object
Sitecore.Rules.Conditions..::..RuleCondition <(Of <(<' T >)>)>
Sitecore.Rules.Conditions..::..WhenCondition <(Of <(<' T >)>)>
Sitecore.Rules.Conditions..::..StringOperatorCondition <(Of <(<' T >)>)>
Sitecore.Analytics.Rules.Conditions..::..IpBaseCondition <(Of <(<' T >)>)>
Sitecore.Analytics.Rules.Conditions..::..PostalCodeCondition<(Of <(<'T>)>)>

See Also

PostalCodeCondition<(Of <(<'T>)>)> Members
Sitecore.Analytics.Rules.Conditions Namespace


PostalCodeCondition(T) Members

[image] [image]

Sitecore 6.4.1 API
PostalCodeCondition<(Of <(<'T>)>)> Members
PostalCodeCondition<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The PostalCodeCondition<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | PostalCodeCondition<(Of <(<'T>)>)> | Initializes a new instance of the PostalCodeCondition<(Of <(<'T>)>)> class

Methods

 | Name | Description
Protected method | Compare | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Execute | Executes the specified rule context. (Inherited from IpBaseCondition<(Of <(<'T>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetColumnValue | Gets the column value. (Overrides IpBaseCondition<(Of <(<'T>)>)>..::..GetColumnValue(IP).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public property | Value | Gets or sets the value. (Inherited from IpBaseCondition<(Of <(<'T>)>)>.)

See Also

PostalCodeCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


PostalCodeCondition(T) Methods

[image] [image]

Sitecore 6.4.1 API
PostalCodeCondition<(Of <(<'T>)>)> Methods
PostalCodeCondition<(Of <(<'T>)>)> Class See Also Send Feedback

The PostalCodeCondition<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Protected method | Compare | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Execute | Executes the specified rule context. (Inherited from IpBaseCondition<(Of <(<'T>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetColumnValue | Gets the column value. (Overrides IpBaseCondition<(Of <(<'T>)>)>..::..GetColumnValue(IP).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PostalCodeCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


GetColumnValue Method

[image]

Sitecore 6.4.1 API
PostalCodeCondition<(Of <(<'T>)>)>..::..GetColumnValue Method
PostalCodeCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected override string GetColumnValue(
    IP ip
)
Visual Basic
Protected Overrides Function GetColumnValue ( _
    ip As IP _
) As String
Visual C++
protected:
virtual String^ GetColumnValue(
    IP^ ip
) override

Parameters

ip
Type: Sitecore.Analytics..::..IP
The ip.

Return Value

The column value.

See Also

PostalCodeCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


PostalCodeCondition(T) Properties

[image] [image]

Sitecore 6.4.1 API
PostalCodeCondition<(Of <(<'T>)>)> Properties
PostalCodeCondition<(Of <(<'T>)>)> Class See Also Send Feedback

The PostalCodeCondition<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public property | Value | Gets or sets the value. (Inherited from IpBaseCondition<(Of <(<'T>)>)>.)

See Also

PostalCodeCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


ProcessMultiVariateTestAction(T) Class

[image]

Sitecore 6.4.1 API
ProcessMultiVariateTestAction<(Of <(<'T>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class ProcessMultiVariateTestAction<T> : SetDataSource<T>,
    IMultiVariateTestStrategy
where T : ConditionalRenderingsRuleContext
Visual Basic
Public Class ProcessMultiVariateTestAction(Of T As ConditionalRenderingsRuleContext) _
    Inherits SetDataSource(Of T) _
    Implements IMultiVariateTestStrategy
Visual C++
generic<typename T>
where T : ConditionalRenderingsRuleContext
public ref class ProcessMultiVariateTestAction : public SetDataSource<T>,
    IMultiVariateTestStrategy

Type Parameters

T
The rule context.

Inheritance Hierarchy

System..::..Object
Sitecore.Rules.Actions..::..RuleAction <(Of <(<'T>)>)>
Sitecore.Rules.ConditionalRenderings..::..SetDataSource <(Of <(<'T>)>)>
Sitecore.Analytics.Rules.Conditions..::..ProcessMultiVariateTestAction<(Of <(<'T>)>)>

See Also

ProcessMultiVariateTestAction<(Of <(<'T>)>)> Members
Sitecore.Analytics.Rules.Conditions Namespace


ProcessMultiVariateTestAction(T) Members

[image] [image]

Sitecore 6.4.1 API
ProcessMultiVariateTestAction<(Of <(<'T>)>)> Members
ProcessMultiVariateTestAction<(Of <(<'T>)>)> Class Constructors Methods See Also Send Feedback

The ProcessMultiVariateTestAction<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | ProcessMultiVariateTestAction<(Of <(<'T>)>)> | Initializes a new instance of the ProcessMultiVariateTestAction<(Of <(<'T>)>)> class

Methods

 | Name | Description
Public method | Apply(T) | Executes the specified rule context. (Overrides RuleAction<(Of <(<'T>)>)>..::..Apply(T).)
Protected method | Apply(T, String) | Executes the specified rule context. (Inherited from SetDataSource<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTestVariableItem | Gets the test variable item.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProcessMultiVariateTestAction<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


ProcessMultiVariateTestAction(T) Constructor

[image]

Sitecore 6.4.1 API
ProcessMultiVariateTestAction<(Of <(<'T>)>)> Constructor
ProcessMultiVariateTestAction<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public ProcessMultiVariateTestAction()
Visual Basic
Public Sub New
Visual C++
public:
ProcessMultiVariateTestAction()

See Also

ProcessMultiVariateTestAction<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


ProcessMultiVariateTestAction(T) Methods

[image] [image]

Sitecore 6.4.1 API
ProcessMultiVariateTestAction<(Of <(<'T>)>)> Methods
ProcessMultiVariateTestAction<(Of <(<'T>)>)> Class See Also Send Feedback

The ProcessMultiVariateTestAction<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Apply(T) | Executes the specified rule context. (Overrides RuleAction<(Of <(<'T>)>)>..::..Apply(T).)
Protected method | Apply(T, String) | Executes the specified rule context. (Inherited from SetDataSource<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTestVariableItem | Gets the test variable item.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProcessMultiVariateTestAction<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


Apply Method

[image] [image]

Sitecore 6.4.1 API
ProcessMultiVariateTestAction<(Of <(<'T>)>)>..::..Apply Method
ProcessMultiVariateTestAction<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Apply(T) | Executes the specified rule context. (Overrides RuleAction<(Of <(<'T>)>)>..::..Apply(T).)
Protected method | Apply(T, String) | Executes the specified rule context. (Inherited from SetDataSource<(Of <(<'T>)>)>.)

See Also

ProcessMultiVariateTestAction<(Of <(<'T>)>)> Class
ProcessMultiVariateTestAction<(Of <(<'T>)>)> Members
Sitecore.Analytics.Rules.Conditions Namespace


GetTestVariableItem Method

[image]

Sitecore 6.4.1 API
ProcessMultiVariateTestAction<(Of <(<'T>)>)>..::..GetTestVariableItem Method
ProcessMultiVariateTestAction<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Item GetTestVariableItem(
    Item item,
    Item multiVariateTest
)
Visual Basic
Public Function GetTestVariableItem ( _
    item As Item, _
    multiVariateTest As Item _
) As Item
Visual C++
public:
virtual Item^ GetTestVariableItem(
    Item^ item,
    Item^ multiVariateTest
) sealed

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
multiVariateTest
Type: Sitecore.Data.Items..::..Item
The multi variate test.

Return Value

Returns the item.

Implements

IMultiVariateTestStrategy..::..GetTestVariableItem(Item, Item)

See Also

ProcessMultiVariateTestAction<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


ProfileCondition(T) Members

[image] [image]

Sitecore 6.4.1 API
ProfileCondition<(Of <(<'T>)>)> Members
ProfileCondition<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The ProfileCondition<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | ProfileCondition<(Of <(<'T>)>)> | Initializes a new instance of the ProfileCondition class. Initializes a new instance of the ProfileCondition class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Execute(T) | Executes the specified rule context.
Protected method | Execute(T) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorCondition<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorCondition<(Of <(<'T>)>)>.)
Public property | ProfileKeyId | Gets or sets the profile key id.
Public property | Value | Gets or sets the value.

See Also

ProfileCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


ProfileCondition(T) Constructor

[image]

Sitecore 6.4.1 API
ProfileCondition<(Of <(<'T>)>)> Constructor
ProfileCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public ProfileCondition()
Visual Basic
Public Sub New
Visual C++
public:
ProfileCondition()

See Also

ProfileCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


ProfileCondition(T) Methods

[image] [image]

Sitecore 6.4.1 API
ProfileCondition<(Of <(<'T>)>)> Methods
ProfileCondition<(Of <(<'T>)>)> Class See Also Send Feedback

The ProfileCondition<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Execute(T) | Executes the specified rule context.
Protected method | Execute(T) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorCondition<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProfileCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


Execute Method

[image] [image]

Sitecore 6.4.1 API
ProfileCondition<(Of <(<'T>)>)>..::..Execute Method
ProfileCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Execute(T) | Executes the specified rule context.
Protected method | Execute(T) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)

See Also

ProfileCondition<(Of <(<'T>)>)> Class
ProfileCondition<(Of <(<'T>)>)> Members
Sitecore.Analytics.Rules.Conditions Namespace


Execute Method (T)

[image]

Sitecore 6.4.1 API
ProfileCondition<(Of <(<'T>)>)>..::..Execute Method (T)
ProfileCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected virtual bool Execute(
    T ruleContext
)
Visual Basic
Protected Overridable Function Execute ( _
    ruleContext As T _
) As Boolean
Visual C++
protected:
virtual bool Execute(
    T ruleContext
)

Parameters

ruleContext
Type: T
The rule context.

Return Value

True, if the condition succeeds, otherwise false.

See Also

ProfileCondition<(Of <(<'T>)>)> Class
Execute Overload
Sitecore.Analytics.Rules.Conditions Namespace


ProfileCondition(T) Properties

[image] [image]

Sitecore 6.4.1 API
ProfileCondition<(Of <(<'T>)>)> Properties
ProfileCondition<(Of <(<'T>)>)> Class See Also Send Feedback

The ProfileCondition<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorCondition<(Of <(<'T>)>)>.)
Public property | ProfileKeyId | Gets or sets the profile key id.
Public property | Value | Gets or sets the value.

See Also

ProfileCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


Value Property

[image]

Sitecore 6.4.1 API
ProfileCondition<(Of <(<'T>)>)>..::..Value Property
ProfileCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Field Value

The value.

See Also

ProfileCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


RegionCondition(T) Class

[image]

Sitecore 6.4.1 API
RegionCondition<(Of <(<'T>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class RegionCondition<T> : IpBaseCondition<T>
where T : RuleContext
Visual Basic
Public Class RegionCondition(Of T As RuleContext) _
    Inherits IpBaseCondition(Of T)
Visual C++
generic<typename T>
where T : RuleContext
public ref class RegionCondition : public IpBaseCondition<T>

Type Parameters

T
The Rule Context type.

Inheritance Hierarchy

System..::..Object
Sitecore.Rules.Conditions..::..RuleCondition <(Of <(<' T >)>)>
Sitecore.Rules.Conditions..::..WhenCondition <(Of <(<' T >)>)>
Sitecore.Rules.Conditions..::..StringOperatorCondition <(Of <(<' T >)>)>
Sitecore.Analytics.Rules.Conditions..::..IpBaseCondition <(Of <(<' T >)>)>
Sitecore.Analytics.Rules.Conditions..::..RegionCondition<(Of <(<'T>)>)>

See Also

RegionCondition<(Of <(<'T>)>)> Members
Sitecore.Analytics.Rules.Conditions Namespace


RegionCondition(T) Members

[image] [image]

Sitecore 6.4.1 API
RegionCondition<(Of <(<'T>)>)> Members
RegionCondition<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The RegionCondition<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | RegionCondition<(Of <(<'T>)>)> | Initializes a new instance of the RegionCondition<(Of <(<'T>)>)> class

Methods

 | Name | Description
Protected method | Compare | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Execute | Executes the specified rule context. (Inherited from IpBaseCondition<(Of <(<'T>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetColumnValue | Gets the column value. (Overrides IpBaseCondition<(Of <(<'T>)>)>..::..GetColumnValue(IP).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | OperatorId | Gets or sets the operator id. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public property | Value | Gets or sets the value. (Inherited from IpBaseCondition<(Of <(<'T>)>)>.)

See Also

RegionCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


RegionCondition(T) Constructor

[image]

Sitecore 6.4.1 API
RegionCondition<(Of <(<'T>)>)> Constructor
RegionCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public RegionCondition()
Visual Basic
Public Sub New
Visual C++
public:
RegionCondition()

See Also

RegionCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


RegionCondition(T) Methods

[image] [image]

Sitecore 6.4.1 API
RegionCondition<(Of <(<'T>)>)> Methods
RegionCondition<(Of <(<'T>)>)> Class See Also Send Feedback

The RegionCondition<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Protected method | Compare | Compares the specified value0. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Execute | Executes the specified rule context. (Inherited from IpBaseCondition<(Of <(<'T>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetColumnValue | Gets the column value. (Overrides IpBaseCondition<(Of <(<'T>)>)>..::..GetColumnValue(IP).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from StringOperatorCondition<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RegionCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


GetColumnValue Method

[image]

Sitecore 6.4.1 API
RegionCondition<(Of <(<'T>)>)>..::..GetColumnValue Method
RegionCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected override string GetColumnValue(
    IP ip
)
Visual Basic
Protected Overrides Function GetColumnValue ( _
    ip As IP _
) As String
Visual C++
protected:
virtual String^ GetColumnValue(
    IP^ ip
) override

Parameters

ip
Type: Sitecore.Analytics..::..IP
The ip.

Return Value

The column value.

See Also

RegionCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


StickyMultiVariateTestStrategy Class

[image]

Sitecore 6.4.1 API
StickyMultiVariateTestStrategy Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class StickyMultiVariateTestStrategy : IMultiVariateTestStrategy
Visual Basic
Public Class StickyMultiVariateTestStrategy _
    Implements IMultiVariateTestStrategy
Visual C++
public ref class StickyMultiVariateTestStrategy : IMultiVariateTestStrategy

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Rules.Conditions..::..StickyMultiVariateTestStrategy

See Also

StickyMultiVariateTestStrategy Members
Sitecore.Analytics.Rules.Conditions Namespace


StickyMultiVariateTestStrategy Members

[image] [image]

Sitecore 6.4.1 API
StickyMultiVariateTestStrategy Members
StickyMultiVariateTestStrategy Class Constructors Methods See Also Send Feedback

The StickyMultiVariateTestStrategy type exposes the following members.

Constructors

 | Name | Description
Public method | StickyMultiVariateTestStrategy | Initializes a new instance of the StickyMultiVariateTestStrategy class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTestVariableItem | Gets the test variable item.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StickyMultiVariateTestStrategy Class
Sitecore.Analytics.Rules.Conditions Namespace


StickyMultiVariateTestStrategy Constructor

[image]

Sitecore 6.4.1 API
StickyMultiVariateTestStrategy Constructor
StickyMultiVariateTestStrategy Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public StickyMultiVariateTestStrategy()
Visual Basic
Public Sub New
Visual C++
public:
StickyMultiVariateTestStrategy()

See Also

StickyMultiVariateTestStrategy Class
Sitecore.Analytics.Rules.Conditions Namespace


StickyMultiVariateTestStrategy Methods

[image] [image]

Sitecore 6.4.1 API
StickyMultiVariateTestStrategy Methods
StickyMultiVariateTestStrategy Class See Also Send Feedback

The StickyMultiVariateTestStrategy type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTestVariableItem | Gets the test variable item.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StickyMultiVariateTestStrategy Class
Sitecore.Analytics.Rules.Conditions Namespace


GetTestVariableItem Method

[image]

Sitecore 6.4.1 API
StickyMultiVariateTestStrategy..::..GetTestVariableItem Method
StickyMultiVariateTestStrategy Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Item GetTestVariableItem(
    Item item,
    Item multiVariateTest
)
Visual Basic
Public Function GetTestVariableItem ( _
    item As Item, _
    multiVariateTest As Item _
) As Item
Visual C++
public:
virtual Item^ GetTestVariableItem(
    Item^ item,
    Item^ multiVariateTest
) sealed

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
multiVariateTest
Type: Sitecore.Data.Items..::..Item
The multi variate test.

Return Value

Returns the item.

Implements

IMultiVariateTestStrategy..::..GetTestVariableItem(Item, Item)

See Also

StickyMultiVariateTestStrategy Class
Sitecore.Analytics.Rules.Conditions Namespace


VisitorIdentificationCondition(T) Class

[image]

Sitecore 6.4.1 API
VisitorIdentificationCondition<(Of <(<'T>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class VisitorIdentificationCondition<T> : OperatorCondition<T>
where T : RuleContext
Visual Basic
Public Class VisitorIdentificationCondition(Of T As RuleContext) _
    Inherits OperatorCondition(Of T)
Visual C++
generic<typename T>
where T : RuleContext
public ref class VisitorIdentificationCondition : public OperatorCondition<T>

Type Parameters

T
The rule context.

Inheritance Hierarchy

System..::..Object
Sitecore.Rules.Conditions..::..RuleCondition <(Of <(<' T >)>)>
Sitecore.Rules.Conditions..::..WhenCondition <(Of <(<' T >)>)>
Sitecore.Rules.Conditions..::..OperatorCondition <(Of <(<' T >)>)>
Sitecore.Analytics.Rules.Conditions..::..VisitorIdentificationCondition<(Of <(<'T>)>)>

See Also

VisitorIdentificationCondition<(Of <(<'T>)>)> Members
Sitecore.Analytics.Rules.Conditions Namespace


VisitorIdentificationCondition(T) Members

[image] [image]

Sitecore 6.4.1 API
VisitorIdentificationCondition<(Of <(<'T>)>)> Members
VisitorIdentificationCondition<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The VisitorIdentificationCondition<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | VisitorIdentificationCondition<(Of <(<'T>)>)> | Initializes a new instance of the VisitorIdentificationCondition<(Of <(<'T>)>)> class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Execute(T) | Executes the specified rule context.
Protected method | Execute(T) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorCondition<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorCondition<(Of <(<'T>)>)>.)
Public property | VisitorIdentification | Gets or sets the value.

See Also

VisitorIdentificationCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


VisitorIdentificationCondition(T) Constructor

[image]

Sitecore 6.4.1 API
VisitorIdentificationCondition<(Of <(<'T>)>)> Constructor
VisitorIdentificationCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public VisitorIdentificationCondition()
Visual Basic
Public Sub New
Visual C++
public:
VisitorIdentificationCondition()

See Also

VisitorIdentificationCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


VisitorIdentificationCondition(T) Methods

[image] [image]

Sitecore 6.4.1 API
VisitorIdentificationCondition<(Of <(<'T>)>)> Methods
VisitorIdentificationCondition<(Of <(<'T>)>)> Class See Also Send Feedback

The VisitorIdentificationCondition<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Execute(T) | Executes the specified rule context.
Protected method | Execute(T) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetOperator | Gets the operator. (Inherited from OperatorCondition<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VisitorIdentificationCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


Execute Method

[image] [image]

Sitecore 6.4.1 API
VisitorIdentificationCondition<(Of <(<'T>)>)>..::..Execute Method
VisitorIdentificationCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Execute(T) | Executes the specified rule context.
Protected method | Execute(T) | Executes the specified rule context. (Inherited from WhenCondition<(Of <(<'T>)>)>.)

See Also

VisitorIdentificationCondition<(Of <(<'T>)>)> Class
VisitorIdentificationCondition<(Of <(<'T>)>)> Members
Sitecore.Analytics.Rules.Conditions Namespace


Execute Method (T)

[image]

Sitecore 6.4.1 API
VisitorIdentificationCondition<(Of <(<'T>)>)>..::..Execute Method (T)
VisitorIdentificationCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected virtual bool Execute(
    T ruleContext
)
Visual Basic
Protected Overridable Function Execute ( _
    ruleContext As T _
) As Boolean
Visual C++
protected:
virtual bool Execute(
    T ruleContext
)

Parameters

ruleContext
Type: T
The rule context.

Return Value

True, if the condition succeeds, otherwise false.

See Also

VisitorIdentificationCondition<(Of <(<'T>)>)> Class
Execute Overload
Sitecore.Analytics.Rules.Conditions Namespace


VisitorIdentificationCondition(T) Properties

[image] [image]

Sitecore 6.4.1 API
VisitorIdentificationCondition<(Of <(<'T>)>)> Properties
VisitorIdentificationCondition<(Of <(<'T>)>)> Class See Also Send Feedback

The VisitorIdentificationCondition<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | OperatorId | Gets or sets the operator id. (Inherited from OperatorCondition<(Of <(<'T>)>)>.)
Public property | VisitorIdentification | Gets or sets the value.

See Also

VisitorIdentificationCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


VisitorIdentification Property

[image]

Sitecore 6.4.1 API
VisitorIdentificationCondition<(Of <(<'T>)>)>..::..VisitorIdentification Property
VisitorIdentificationCondition<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Analytics.Rules.Conditions
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int VisitorIdentification { get; set; }
Visual Basic
Public Property VisitorIdentification As Integer
    Get
    Set
Visual C++
public:
property int VisitorIdentification {
    int get ();
    void set (int value);
}

Field Value

The value.

See Also

VisitorIdentificationCondition<(Of <(<'T>)>)> Class
Sitecore.Analytics.Rules.Conditions Namespace


Sitecore.Analytics.Tasks Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Analytics.Tasks Namespace
Send Feedback

Classes

 | Class | Description
Public class | EmailReportsTask | Defines the email task class.
Public class | SubscriptionTask | Defines the email task class.


EmailReportsTask Class

[image]

Sitecore 6.4.1 API
EmailReportsTask Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Tasks
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class EmailReportsTask
Visual Basic
Public Class EmailReportsTask
Visual C++
public ref class EmailReportsTask

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Tasks..::..EmailReportsTask

See Also

EmailReportsTask Members
Sitecore.Analytics.Tasks Namespace


EmailReportsTask Constructor

[image]

Sitecore 6.4.1 API
EmailReportsTask Constructor
EmailReportsTask Class See Also Send Feedback

Namespace: Sitecore.Analytics.Tasks
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public EmailReportsTask()
Visual Basic
Public Sub New
Visual C++
public:
EmailReportsTask()

See Also

EmailReportsTask Class
Sitecore.Analytics.Tasks Namespace


EmailReportsTask Methods

[image] [image]

Sitecore 6.4.1 API
EmailReportsTask Methods
EmailReportsTask Class See Also Send Feedback

The EmailReportsTask type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Run | Executes this task.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EmailReportsTask Class
Sitecore.Analytics.Tasks Namespace


EmailReportsTask Properties

[image] [image]

Sitecore 6.4.1 API
EmailReportsTask Properties
EmailReportsTask Class See Also Send Feedback

The EmailReportsTask type exposes the following members.

Properties

 | Name | Description
Public property | DatabaseName | Gets or sets the name of the database.

See Also

EmailReportsTask Class
Sitecore.Analytics.Tasks Namespace


DatabaseName Property

[image]

Sitecore 6.4.1 API
EmailReportsTask..::..DatabaseName Property
EmailReportsTask Class See Also Send Feedback

Namespace: Sitecore.Analytics.Tasks
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string DatabaseName { get; set; }
Visual Basic
Public Property DatabaseName As String
    Get
    Set
Visual C++
public:
property String^ DatabaseName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the database.

See Also

EmailReportsTask Class
Sitecore.Analytics.Tasks Namespace


SubscriptionTask Class

[image]

Sitecore 6.4.1 API
SubscriptionTask Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Tasks
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class SubscriptionTask
Visual Basic
Public Class SubscriptionTask
Visual C++
public ref class SubscriptionTask

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Tasks..::..SubscriptionTask

See Also

SubscriptionTask Members
Sitecore.Analytics.Tasks Namespace


SubscriptionTask Members

[image] [image]

Sitecore 6.4.1 API
SubscriptionTask Members
SubscriptionTask Class Constructors Methods Properties See Also Send Feedback

The SubscriptionTask type exposes the following members.

Constructors

 | Name | Description
Public method | SubscriptionTask | Initializes a new instance of the SubscriptionTask class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Run | Executes this task.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Minutes | Gets or sets the name of the database.

See Also

SubscriptionTask Class
Sitecore.Analytics.Tasks Namespace


SubscriptionTask Constructor

[image]

Sitecore 6.4.1 API
SubscriptionTask Constructor
SubscriptionTask Class See Also Send Feedback

Namespace: Sitecore.Analytics.Tasks
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public SubscriptionTask()
Visual Basic
Public Sub New
Visual C++
public:
SubscriptionTask()

See Also

SubscriptionTask Class
Sitecore.Analytics.Tasks Namespace


SubscriptionTask Methods

[image] [image]

Sitecore 6.4.1 API
SubscriptionTask Methods
SubscriptionTask Class See Also Send Feedback

The SubscriptionTask type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Run | Executes this task.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubscriptionTask Class
Sitecore.Analytics.Tasks Namespace


Run Method

[image]

Sitecore 6.4.1 API
SubscriptionTask..::..Run Method
SubscriptionTask Class See Also Send Feedback

Namespace: Sitecore.Analytics.Tasks
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void Run()
Visual Basic
Public Sub Run
Visual C++
public:
void Run()

See Also

SubscriptionTask Class
Sitecore.Analytics.Tasks Namespace


SubscriptionTask Properties

[image] [image]

Sitecore 6.4.1 API
SubscriptionTask Properties
SubscriptionTask Class See Also Send Feedback

The SubscriptionTask type exposes the following members.

Properties

 | Name | Description
Public property | Minutes | Gets or sets the name of the database.

See Also

SubscriptionTask Class
Sitecore.Analytics.Tasks Namespace


Sitecore.Analytics.Texts Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Analytics.Texts Namespace
Send Feedback

Classes

 | Class | Description
Public class | SummaryHtmlWriter | Defines the summary html writer class.
Public class | SummaryTextWriter | Defines the summary text writer class.


SummaryHtmlWriter Class

[image]

Sitecore 6.4.1 API
SummaryHtmlWriter Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Texts
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class SummaryHtmlWriter
Visual Basic
Public Class SummaryHtmlWriter
Visual C++
public ref class SummaryHtmlWriter

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Texts..::..SummaryHtmlWriter

See Also

SummaryHtmlWriter Members
Sitecore.Analytics.Texts Namespace


SummaryHtmlWriter Members

[image] [image]

Sitecore 6.4.1 API
SummaryHtmlWriter Members
SummaryHtmlWriter Class Constructors Methods See Also Send Feedback

The SummaryHtmlWriter type exposes the following members.

Constructors

 | Name | Description
Public method | SummaryHtmlWriter | Initializes a new instance of the SummaryHtmlWriter class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Render()()()() | Renders this instance.
Public method | Render(HtmlTextWriter) | Renders the specified output.
Public method | Render(HtmlTextWriter, Session) | Renders the specified output.
Public method | Render(HtmlTextWriter, String) | Renders the session.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SummaryHtmlWriter Class
Sitecore.Analytics.Texts Namespace


SummaryHtmlWriter Constructor

[image]

Sitecore 6.4.1 API
SummaryHtmlWriter Constructor
SummaryHtmlWriter Class See Also Send Feedback

Namespace: Sitecore.Analytics.Texts
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public SummaryHtmlWriter()
Visual Basic
Public Sub New
Visual C++
public:
SummaryHtmlWriter()

See Also

SummaryHtmlWriter Class
Sitecore.Analytics.Texts Namespace


Render Method

[image]

Sitecore 6.4.1 API
SummaryHtmlWriter..::..Render Method
SummaryHtmlWriter Class See Also Send Feedback

Namespace: Sitecore.Analytics.Texts
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Render()
Visual Basic
Public Function Render As String
Visual C++
public:
String^ Render()

Return Value

Returns the string.

See Also

SummaryHtmlWriter Class
Render Overload
Sitecore.Analytics.Texts Namespace


Render Method (HtmlTextWriter)

[image]

Sitecore 6.4.1 API
SummaryHtmlWriter..::..Render Method (HtmlTextWriter)
SummaryHtmlWriter Class See Also Send Feedback

Namespace: Sitecore.Analytics.Texts
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void Render(
    HtmlTextWriter output
)
Visual Basic
Public Sub Render ( _
    output As HtmlTextWriter _
)
Visual C++
public:
void Render(
    HtmlTextWriter^ output
)

Parameters

output
Type: System.Web.UI..::..HtmlTextWriter
The output.

See Also

SummaryHtmlWriter Class
Render Overload
Sitecore.Analytics.Texts Namespace


Render Method (HtmlTextWriter, Session)

[image]

Sitecore 6.4.1 API
SummaryHtmlWriter..::..Render Method (HtmlTextWriter, Session)
SummaryHtmlWriter Class See Also Send Feedback

Namespace: Sitecore.Analytics.Texts
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void Render(
    HtmlTextWriter output,
    Session session
)
Visual Basic
Public Sub Render ( _
    output As HtmlTextWriter, _
    session As Session _
)
Visual C++
public:
void Render(
    HtmlTextWriter^ output,
    Session^ session
)

Parameters

output
Type: System.Web.UI..::..HtmlTextWriter
The output.
session
Type: Sitecore.Analytics..::..Session
The session.

See Also

SummaryHtmlWriter Class
Render Overload
Sitecore.Analytics.Texts Namespace


Render Method (HtmlTextWriter, String)

[image]

Sitecore 6.4.1 API
SummaryHtmlWriter..::..Render Method (HtmlTextWriter, String)
SummaryHtmlWriter Class See Also Send Feedback

Namespace: Sitecore.Analytics.Texts
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void Render(
    HtmlTextWriter output,
    string aspNetSessionId
)
Visual Basic
Public Sub Render ( _
    output As HtmlTextWriter, _
    aspNetSessionId As String _
)
Visual C++
public:
void Render(
    HtmlTextWriter^ output,
    String^ aspNetSessionId
)

Parameters

output
Type: System.Web.UI..::..HtmlTextWriter
The output.
aspNetSessionId
Type: System..::..String
The ASP net session id.

See Also

SummaryHtmlWriter Class
Render Overload
Sitecore.Analytics.Texts Namespace


SummaryTextWriter Class

[image]

Sitecore 6.4.1 API
SummaryTextWriter Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Texts
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class SummaryTextWriter
Visual Basic
Public Class SummaryTextWriter
Visual C++
public ref class SummaryTextWriter

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Texts..::..SummaryTextWriter

See Also

SummaryTextWriter Members
Sitecore.Analytics.Texts Namespace


SummaryTextWriter Members

[image] [image]

Sitecore 6.4.1 API
SummaryTextWriter Members
SummaryTextWriter Class Constructors Methods See Also Send Feedback

The SummaryTextWriter type exposes the following members.

Constructors

 | Name | Description
Public method | SummaryTextWriter | Initializes a new instance of the SummaryTextWriter class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Render()()()() | Renders this instance.
Public method | Render(TextWriter) | Renders the specified output.
Public method | Render(TextWriter, Session) | Renders the specified output.
Public method | Render(TextWriter, String) | Renders the session.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SummaryTextWriter Class
Sitecore.Analytics.Texts Namespace


SummaryTextWriter Constructor

[image]

Sitecore 6.4.1 API
SummaryTextWriter Constructor
SummaryTextWriter Class See Also Send Feedback

Namespace: Sitecore.Analytics.Texts
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public SummaryTextWriter()
Visual Basic
Public Sub New
Visual C++
public:
SummaryTextWriter()

See Also

SummaryTextWriter Class
Sitecore.Analytics.Texts Namespace


Render Method

[image] [image]

Sitecore 6.4.1 API
SummaryTextWriter..::..Render Method
SummaryTextWriter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Render()()()() | Renders this instance.
Public method | Render(TextWriter) | Renders the specified output.
Public method | Render(TextWriter, Session) | Renders the specified output.
Public method | Render(TextWriter, String) | Renders the session.

See Also

SummaryTextWriter Class
SummaryTextWriter Members
Sitecore.Analytics.Texts Namespace


Render Method

[image]

Sitecore 6.4.1 API
SummaryTextWriter..::..Render Method
SummaryTextWriter Class See Also Send Feedback

Namespace: Sitecore.Analytics.Texts
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Render()
Visual Basic
Public Function Render As String
Visual C++
public:
String^ Render()

Return Value

Returns the string.

See Also

SummaryTextWriter Class
Render Overload
Sitecore.Analytics.Texts Namespace


Render Method (TextWriter)

[image]

Sitecore 6.4.1 API
SummaryTextWriter..::..Render Method (TextWriter)
SummaryTextWriter Class See Also Send Feedback

Namespace: Sitecore.Analytics.Texts
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void Render(
    TextWriter output
)
Visual Basic
Public Sub Render ( _
    output As TextWriter _
)
Visual C++
public:
void Render(
    TextWriter^ output
)

Parameters

output
Type: System.IO..::..TextWriter
The output.

See Also

SummaryTextWriter Class
Render Overload
Sitecore.Analytics.Texts Namespace


Render Method (TextWriter, Session)

[image]

Sitecore 6.4.1 API
SummaryTextWriter..::..Render Method (TextWriter, Session)
SummaryTextWriter Class See Also Send Feedback

Namespace: Sitecore.Analytics.Texts
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void Render(
    TextWriter output,
    Session session
)
Visual Basic
Public Sub Render ( _
    output As TextWriter, _
    session As Session _
)
Visual C++
public:
void Render(
    TextWriter^ output,
    Session^ session
)

Parameters

output
Type: System.IO..::..TextWriter
The output.
session
Type: Sitecore.Analytics..::..Session
The session.

See Also

SummaryTextWriter Class
Render Overload
Sitecore.Analytics.Texts Namespace


Render Method (TextWriter, String)

[image]

Sitecore 6.4.1 API
SummaryTextWriter..::..Render Method (TextWriter, String)
SummaryTextWriter Class See Also Send Feedback

Namespace: Sitecore.Analytics.Texts
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void Render(
    TextWriter output,
    string aspNetSessionId
)
Visual Basic
Public Sub Render ( _
    output As TextWriter, _
    aspNetSessionId As String _
)
Visual C++
public:
void Render(
    TextWriter^ output,
    String^ aspNetSessionId
)

Parameters

output
Type: System.IO..::..TextWriter
The output.
aspNetSessionId
Type: System..::..String
The ASP net session id.

See Also

SummaryTextWriter Class
Render Overload
Sitecore.Analytics.Texts Namespace


AnalyticsSessionCookie Class

[image]

Sitecore 6.4.1 API
AnalyticsSessionCookie Class
Members See Also Send Feedback

Namespace: Sitecore.Analytics.Web
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class AnalyticsSessionCookie
Visual Basic
Public Class AnalyticsSessionCookie
Visual C++
public ref class AnalyticsSessionCookie

Inheritance Hierarchy

System..::..Object
Sitecore.Analytics.Web..::..AnalyticsSessionCookie

See Also

AnalyticsSessionCookie Members
Sitecore.Analytics.Web Namespace


AnalyticsSessionCookie Members

[image] [image]

Sitecore 6.4.1 API
AnalyticsSessionCookie Members
AnalyticsSessionCookie Class Constructors Methods Fields Properties See Also Send Feedback

The AnalyticsSessionCookie type exposes the following members.

Constructors

 | Name | Description
Public method | AnalyticsSessionCookie | Initializes a new instance of the AnalyticsSessionCookie class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Loads this instance.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Saves this instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
SC_ANALYTICS_SESSION_COOKIE | Name of the sitecore analytics session cookie.

Properties

 | Name | Description
Public property | SessionId | Gets or sets the session id.
Public property | UpdateVisitorIdentification | Gets or sets a value indicating whether [check bots].

See Also

AnalyticsSessionCookie Class
Sitecore.Analytics.Web Namespace


AnalyticsSessionCookie Constructor

[image]

Sitecore 6.4.1 API
AnalyticsSessionCookie Constructor
AnalyticsSessionCookie Class See Also Send Feedback

Namespace: Sitecore.Analytics.Web
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public AnalyticsSessionCookie()
Visual Basic
Public Sub New
Visual C++
public:
AnalyticsSessionCookie()

See Also

AnalyticsSessionCookie Class
Sitecore.Analytics.Web Namespace


SC_ANALYTICS_SESSION_COOKIE Field

[image]

Sitecore 6.4.1 API
AnalyticsSessionCookie..::..SC_ANALYTICS_SESSION_COOKIE Field
AnalyticsSessionCookie Class See Also Send Feedback

Namespace: Sitecore.Analytics.Web
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public const string SC_ANALYTICS_SESSION_COOKIE
Visual Basic
Public Const SC_ANALYTICS_SESSION_COOKIE As String
Visual C++
public:
literal String^ SC_ANALYTICS_SESSION_COOKIE

See Also

AnalyticsSessionCookie Class
Sitecore.Analytics.Web Namespace


Load Method

[image]

Sitecore 6.4.1 API
AnalyticsSessionCookie..::..Load Method
AnalyticsSessionCookie Class See Also Send Feedback

Namespace: Sitecore.Analytics.Web
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void Load()
Visual Basic
Public Sub Load
Visual C++
public:
void Load()

See Also

AnalyticsSessionCookie Class
Sitecore.Analytics.Web Namespace


Save Method

[image]

Sitecore 6.4.1 API
AnalyticsSessionCookie..::..Save Method
AnalyticsSessionCookie Class See Also Send Feedback

Namespace: Sitecore.Analytics.Web
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void Save()
Visual Basic
Public Sub Save
Visual C++
public:
void Save()

See Also

AnalyticsSessionCookie Class
Sitecore.Analytics.Web Namespace


AnalyticsSessionCookie Properties

[image] [image]

Sitecore 6.4.1 API
AnalyticsSessionCookie Properties
AnalyticsSessionCookie Class See Also Send Feedback

The AnalyticsSessionCookie type exposes the following members.

Properties

 | Name | Description
Public property | SessionId | Gets or sets the session id.
Public property | UpdateVisitorIdentification | Gets or sets a value indicating whether [check bots].

See Also

AnalyticsSessionCookie Class
Sitecore.Analytics.Web Namespace


SessionId Property

[image]

Sitecore 6.4.1 API
AnalyticsSessionCookie..::..SessionId Property
AnalyticsSessionCookie Class See Also Send Feedback

Namespace: Sitecore.Analytics.Web
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Guid SessionId { get; set; }
Visual Basic
Public Property SessionId As Guid
    Get
    Set
Visual C++
public:
property Guid SessionId {
    Guid get ();
    void set (Guid value);
}

Field Value

The session id.

See Also

AnalyticsSessionCookie Class
Sitecore.Analytics.Web Namespace


UpdateVisitorIdentification Property

[image]

Sitecore 6.4.1 API
AnalyticsSessionCookie..::..UpdateVisitorIdentification Property
AnalyticsSessionCookie Class See Also Send Feedback

Namespace: Sitecore.Analytics.Web
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public bool UpdateVisitorIdentification { get; set; }
Visual Basic
Public Property UpdateVisitorIdentification As Boolean
    Get
    Set
Visual C++
public:
property bool UpdateVisitorIdentification {
    bool get ();
    void set (bool value);
}

Field Value

true if [check bots]; otherwise, false.

See Also

AnalyticsSessionCookie Class
Sitecore.Analytics.Web Namespace


Sitecore.Applications.WebEdit.Dialogs.DateSelector Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Applications.WebEdit.Dialogs.DateSelector Namespace
Send Feedback

Classes

 | Class | Description
Public class | SelectDateOptions | Options for select date dialog.


SelectDateOptions Class

[image]

Sitecore 6.4.1 API
SelectDateOptions Class
Members See Also Send Feedback

Namespace: Sitecore.Applications.WebEdit.Dialogs.DateSelector
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SelectDateOptions
Visual Basic
Public Class SelectDateOptions
Visual C++
public ref class SelectDateOptions

Inheritance Hierarchy

System..::..Object
Sitecore.Applications.WebEdit.Dialogs.DateSelector..::..SelectDateOptions

See Also

SelectDateOptions Members
Sitecore.Applications.WebEdit.Dialogs.DateSelector Namespace


SelectDateOptions Members

[image] [image]

Sitecore 6.4.1 API
SelectDateOptions Members
SelectDateOptions Class Constructors Methods Properties See Also Send Feedback

The SelectDateOptions type exposes the following members.

Constructors

 | Name | Description
Public method | SelectDateOptions | Creates a new blank instance of select date options.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Parses the query string.
Public method | ToString | ToString. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Header | The Title.
Public property | SelectedDate | The selected date.
Public property | SelectedIsoDate | The selected iso date.
Public property | Text | The Text.

See Also

SelectDateOptions Class
Sitecore.Applications.WebEdit.Dialogs.DateSelector Namespace


SelectDateOptions Constructor

[image]

Sitecore 6.4.1 API
SelectDateOptions Constructor
SelectDateOptions Class See Also Send Feedback

Namespace: Sitecore.Applications.WebEdit.Dialogs.DateSelector
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SelectDateOptions()
Visual Basic
Public Sub New
Visual C++
public:
SelectDateOptions()

See Also

SelectDateOptions Class
Sitecore.Applications.WebEdit.Dialogs.DateSelector Namespace


SelectDateOptions Methods

[image] [image]

Sitecore 6.4.1 API
SelectDateOptions Methods
SelectDateOptions Class See Also Send Feedback

The SelectDateOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Parses the query string.
Public method | ToString | ToString. (Overrides Object..::..ToString()()()().)

See Also

SelectDateOptions Class
Sitecore.Applications.WebEdit.Dialogs.DateSelector Namespace


Parse Method

[image]

Sitecore 6.4.1 API
SelectDateOptions..::..Parse Method
SelectDateOptions Class See Also Send Feedback

Namespace: Sitecore.Applications.WebEdit.Dialogs.DateSelector
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static SelectDateOptions Parse()
Visual Basic
Public Shared Function Parse As SelectDateOptions
Visual C++
public:
static SelectDateOptions^ Parse()

Return Value

Select date options

See Also

SelectDateOptions Class
Sitecore.Applications.WebEdit.Dialogs.DateSelector Namespace


SelectDateOptions Properties

[image] [image]

Sitecore 6.4.1 API
SelectDateOptions Properties
SelectDateOptions Class See Also Send Feedback

The SelectDateOptions type exposes the following members.

Properties

 | Name | Description
Public property | Header | The Title.
Public property | SelectedDate | The selected date.
Public property | SelectedIsoDate | The selected iso date.
Public property | Text | The Text.

See Also

SelectDateOptions Class
Sitecore.Applications.WebEdit.Dialogs.DateSelector Namespace


Header Property

[image]

Sitecore 6.4.1 API
SelectDateOptions..::..Header Property
SelectDateOptions Class See Also Send Feedback

Namespace: Sitecore.Applications.WebEdit.Dialogs.DateSelector
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Header { get; set; }
Visual Basic
Public Property Header As String
    Get
    Set
Visual C++
public:
property String^ Header {
    String^ get ();
    void set (String^ value);
}

See Also

SelectDateOptions Class
Sitecore.Applications.WebEdit.Dialogs.DateSelector Namespace


SelectedIsoDate Property

[image]

Sitecore 6.4.1 API
SelectDateOptions..::..SelectedIsoDate Property
SelectDateOptions Class See Also Send Feedback

Namespace: Sitecore.Applications.WebEdit.Dialogs.DateSelector
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string SelectedIsoDate { get; set; }
Visual Basic
Public Property SelectedIsoDate As String
    Get
    Set
Visual C++
public:
property String^ SelectedIsoDate {
    String^ get ();
    void set (String^ value);
}

See Also

SelectDateOptions Class
Sitecore.Applications.WebEdit.Dialogs.DateSelector Namespace


Sitecore.Caching Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Caching Namespace
Send Feedback

Classes

 | Class | Description
Public class | AccessResultCache | AccessResultCache class.
Public class | Cache | Cache
Public class | Cache..::..CacheEntry | Class representing a cache entry.
Public class | CacheComparer | Implements the IComparer interface to compare two cache objects.
Public class | CacheItem | Represents a cache item.
Public class | CacheManager | Represents a cache manager.
Public class | CacheStatistics | Represents cache statistics.
Public class | CustomCache | CustomCache
Public class | DataCache | Represents a data cache.
Public class | EntryRemovedEventArgs | Argument for the EntryRemoved event.
Public class | FilteredItemsCache | FilteredItemsCache class
Public class | HtmlCache | Represents a html cache.
Public class | ItemCache | ItemCache
Public class | ItemRelation | Represents an item relation.
Public class | ItemsContext |
Public class | PathCache | Represents a path cache.
Public class | RegistryCache | Represents a registry cache.
Public class | RuleCache | RuleCache class represents cache for rules
Public class | StandardValuesCache | StandardValuesCache class
Public class | ViewStateCache | Represents a view state cache.
Public class | XslCache | Represents a Xsl cache.

Interfaces

 | Interface | Description
Public interface | ICacheable | Defines the basic properties and functionality of an object that is cacheable.

Delegates

 | Delegate | Description
Public delegate | DataLengthChangedDelegate |

Enumerations

 | Enumeration | Description
Public enumeration | CachePriority | Represents a cache priority.


AccessResultCache Class

[image]

Sitecore 6.4.1 API
AccessResultCache Class
Members See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class AccessResultCache : CustomCache
Visual Basic
Public Class AccessResultCache _
    Inherits CustomCache
Visual C++
public ref class AccessResultCache : public CustomCache

Inheritance Hierarchy

System..::..Object
Sitecore.Caching..::..CustomCache
Sitecore.Caching..::..AccessResultCache

See Also

AccessResultCache Members
Sitecore.Caching Namespace


AccessResultCache Members

[image] [image]

Sitecore 6.4.1 API
AccessResultCache Members
AccessResultCache Class Constructors Methods Properties See Also Send Feedback

The AccessResultCache type exposes the following members.

Constructors

 | Name | Description
Public method | AccessResultCache | Initializes a new instance of the AccessResultCache class.

Methods

 | Name | Description
Public method | AddRecord(ISecurable, AccessResultCacheRecord) | Obsolete. Adds an access result record.
Public method | AddRecord(ISecurable, Account, AccessRight, PropagationType, AccessResult) | Adds an access result.
Public method | Clear | Clears this instance. (Inherited from CustomCache.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetID | Gets the ID. (Inherited from CustomCache.)
Protected method | GetObject | Gets the object. (Inherited from CustomCache.)
Public method | GetRecord(ISecurable) | Obsolete. Gets an access result record.
Public method | GetRecord(ISecurable, Account, AccessRight, PropagationType) | Gets an access result record.
Protected method | GetString | Gets the string. (Inherited from CustomCache.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Remove | Removes the specified key. (Inherited from CustomCache.)
Public method | RemoveKeysContaining | Removes the keys containing. (Inherited from CustomCache.)
Public method | RemovePrefix | Removes entries with keys starting with the specified prefix. (Inherited from CustomCache.)
Protected method | SetID | Sets the ID. (Inherited from CustomCache.)
Protected method | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Sets the object. (Inherited from CustomCache.)
Protected method | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
Protected method | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether this CustomCache is enabled. (Inherited from CustomCache.)
Public property | InnerCache | Gets the inner cache. (Inherited from CustomCache.)
Public property | Name | Gets the name. (Inherited from CustomCache.)

See Also

AccessResultCache Class
Sitecore.Caching Namespace


AccessResultCache Constructor

[image]

Sitecore 6.4.1 API
AccessResultCache Constructor
AccessResultCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AccessResultCache(
    long maxSize
)
Visual Basic
Public Sub New ( _
    maxSize As Long _
)
Visual C++
public:
AccessResultCache(
    long long maxSize
)

Parameters

maxSize
Type: System..::..Int64
Size of the max.

See Also

AccessResultCache Class
Sitecore.Caching Namespace


AccessResultCache Methods

[image] [image]

Sitecore 6.4.1 API
AccessResultCache Methods
AccessResultCache Class See Also Send Feedback

The AccessResultCache type exposes the following members.

Methods

 | Name | Description
Public method | AddRecord(ISecurable, AccessResultCacheRecord) | Obsolete. Adds an access result record.
Public method | AddRecord(ISecurable, Account, AccessRight, PropagationType, AccessResult) | Adds an access result.
Public method | Clear | Clears this instance. (Inherited from CustomCache.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetID | Gets the ID. (Inherited from CustomCache.)
Protected method | GetObject | Gets the object. (Inherited from CustomCache.)
Public method | GetRecord(ISecurable) | Obsolete. Gets an access result record.
Public method | GetRecord(ISecurable, Account, AccessRight, PropagationType) | Gets an access result record.
Protected method | GetString | Gets the string. (Inherited from CustomCache.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Remove | Removes the specified key. (Inherited from CustomCache.)
Public method | RemoveKeysContaining | Removes the keys containing. (Inherited from CustomCache.)
Public method | RemovePrefix | Removes entries with keys starting with the specified prefix. (Inherited from CustomCache.)
Protected method | SetID | Sets the ID. (Inherited from CustomCache.)
Protected method | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Sets the object. (Inherited from CustomCache.)
Protected method | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
Protected method | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AccessResultCache Class
Sitecore.Caching Namespace


AddRecord Method

[image] [image]

Sitecore 6.4.1 API
AccessResultCache..::..AddRecord Method
AccessResultCache Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddRecord(ISecurable, AccessResultCacheRecord) | Obsolete. Adds an access result record.
Public method | AddRecord(ISecurable, Account, AccessRight, PropagationType, AccessResult) | Adds an access result.

See Also

AccessResultCache Class
AccessResultCache Members
Sitecore.Caching Namespace


AddRecord Method (ISecurable, AccessResultCacheRecord)

[image]

Sitecore 6.4.1 API
AccessResultCache..::..AddRecord Method (ISecurable, AccessResultCacheRecord)
AccessResultCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use overloaded method instead with all parameters specified")]
public void AddRecord(
    ISecurable entity,
    AccessResultCacheRecord record
)
Visual Basic
<ObsoleteAttribute("Use overloaded method instead with all parameters specified")> _
Public Sub AddRecord ( _
    entity As ISecurable, _
    record As AccessResultCacheRecord _
)
Visual C++
[ObsoleteAttribute(L"Use overloaded method instead with all parameters specified")]
public:
void AddRecord(
    ISecurable^ entity,
    AccessResultCacheRecord^ record
)

Parameters

entity
Type: Sitecore.Security.AccessControl..::..ISecurable
The entity.
record
Type: Sitecore.Security.AccessControl..::..AccessResultCacheRecord
The record.

See Also

AccessResultCache Class
AddRecord Overload
Sitecore.Caching Namespace


AddRecord Method (ISecurable, Account, AccessRight, PropagationType, AccessResult)

[image]

Sitecore 6.4.1 API
AccessResultCache..::..AddRecord Method (ISecurable, Account, AccessRight, PropagationType, AccessResult)
AccessResultCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddRecord(
    ISecurable entity,
    Account account,
    AccessRight accessRight,
    PropagationType propagationType,
    AccessResult accessResult
)
Visual Basic
Public Sub AddRecord ( _
    entity As ISecurable, _
    account As Account, _
    accessRight As AccessRight, _
    propagationType As PropagationType, _
    accessResult As AccessResult _
)
Visual C++
public:
void AddRecord(
    ISecurable^ entity,
    Account^ account,
    AccessRight^ accessRight,
    PropagationType propagationType,
    AccessResult^ accessResult
)

Parameters

entity
Type: Sitecore.Security.AccessControl..::..ISecurable
The entity.
account
Type: Sitecore.Security.Accounts..::..Account
The account.
accessRight
Type: Sitecore.Security.AccessControl..::..AccessRight
The access right
propagationType
Type: Sitecore.Security.AccessControl..::..PropagationType
The propagation type
accessResult
Type: Sitecore.Security.AccessControl..::..AccessResult
The access result

See Also

AccessResultCache Class
AddRecord Overload
Sitecore.Caching Namespace


GetRecord Method

[image] [image]

Sitecore 6.4.1 API
AccessResultCache..::..GetRecord Method
AccessResultCache Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRecord(ISecurable) | Obsolete. Gets an access result record.
Public method | GetRecord(ISecurable, Account, AccessRight, PropagationType) | Gets an access result record.

See Also

AccessResultCache Class
AccessResultCache Members
Sitecore.Caching Namespace


GetRecord Method (ISecurable)

[image]

Sitecore 6.4.1 API
AccessResultCache..::..GetRecord Method (ISecurable)
AccessResultCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use overloaded method instead with all parameters specified")]
public AccessResultCacheRecord GetRecord(
    ISecurable entity
)
Visual Basic
<ObsoleteAttribute("Use overloaded method instead with all parameters specified")> _
Public Function GetRecord ( _
    entity As ISecurable _
) As AccessResultCacheRecord
Visual C++
[ObsoleteAttribute(L"Use overloaded method instead with all parameters specified")]
public:
AccessResultCacheRecord^ GetRecord(
    ISecurable^ entity
)

Parameters

entity
Type: Sitecore.Security.AccessControl..::..ISecurable
The entity.

Return Value

AccessResultCacheRecord object.

See Also

AccessResultCache Class
GetRecord Overload
Sitecore.Caching Namespace


GetRecord Method (ISecurable, Account, AccessRight, PropagationType)

[image]

Sitecore 6.4.1 API
AccessResultCache..::..GetRecord Method (ISecurable, Account, AccessRight, PropagationType)
AccessResultCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AccessResultCacheRecord GetRecord(
    ISecurable entity,
    Account account,
    AccessRight accessRight,
    PropagationType propagationType
)
Visual Basic
Public Function GetRecord ( _
    entity As ISecurable, _
    account As Account, _
    accessRight As AccessRight, _
    propagationType As PropagationType _
) As AccessResultCacheRecord
Visual C++
public:
AccessResultCacheRecord^ GetRecord(
    ISecurable^ entity,
    Account^ account,
    AccessRight^ accessRight,
    PropagationType propagationType
)

Parameters

entity
Type: Sitecore.Security.AccessControl..::..ISecurable
The entity.
account
Type: Sitecore.Security.Accounts..::..Account
The account.
accessRight
Type: Sitecore.Security.AccessControl..::..AccessRight
The access right
propagationType
Type: Sitecore.Security.AccessControl..::..PropagationType
The propagation type.

Return Value

AccessResultCacheRecord object.

See Also

AccessResultCache Class
GetRecord Overload
Sitecore.Caching Namespace


SetObject Method

[image] [image]

Sitecore 6.4.1 API
AccessResultCache..::..SetObject Method
AccessResultCache Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Sets the object. (Inherited from CustomCache.)

See Also

AccessResultCache Class
AccessResultCache Members
Sitecore.Caching Namespace


SetString Method

[image] [image]

Sitecore 6.4.1 API
AccessResultCache..::..SetString Method
AccessResultCache Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
Protected method | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)

See Also

AccessResultCache Class
AccessResultCache Members
Sitecore.Caching Namespace


AccessResultCache Properties

[image] [image]

Sitecore 6.4.1 API
AccessResultCache Properties
AccessResultCache Class See Also Send Feedback

The AccessResultCache type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether this CustomCache is enabled. (Inherited from CustomCache.)
Public property | InnerCache | Gets the inner cache. (Inherited from CustomCache.)
Public property | Name | Gets the name. (Inherited from CustomCache.)

See Also

AccessResultCache Class
Sitecore.Caching Namespace


Cache Class

[image]

Sitecore 6.4.1 API
Cache Class
Members See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Cache
Visual Basic
Public Class Cache
Visual C++
public ref class Cache

Inheritance Hierarchy

System..::..Object
Sitecore.Caching..::..Cache

See Also

Cache Members
Sitecore.Caching Namespace


Cache Members

[image] [image]

Sitecore 6.4.1 API
Cache Members
Cache Class Constructors Methods Properties See Also Send Feedback

The Cache type exposes the following members.

Constructors

 | Name | Description
Public method | Cache(Int64) | Initializes a new instance of the Cache class.
Public method | Cache(String, Int64) | Initializes a new instance of the Cache class.
Public method | Cache(String, String) | Initializes a new instance of the Cache class.

Methods

 | Name | Description
Public method | Add(String, ICacheable) | Adds the specified key.
Public method | Add(String, ID) | Adds the specified key.
Public method | Add(String, String) | Adds the specified key.
Public method | Add(ID, ICacheable) | Adds the specified key.
Public method | Add(ID, String) | Adds the specified key.
Public method | Add(Object, Object, Int64) | Adds the specified data to the cache.
Public method | Add(String, Object, Int64) | Adds the specified key.
Public method | Add(ID, Object, Int64) | Adds the specified key.
Public method | Add(Object, Object, Int64, DateTime) | Adds the specified key.
Public method | Add(Object, Object, Int64, TimeSpan) | Adds the specified data to the cache.
Public method | Add(String, Object, Int64, DateTime) | Adds the specified object.
Public method | Add(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Adds the specified key.
Public method | Add(String, Object, Int64, TimeSpan) | Adds the specified object.
Public method | Add(Object, Object, Int64, TimeSpan, DateTime) | Adds the specified data to the cache.
Public method | Clear | Clears this instance.
Public method | ContainsKey(Object) | Determines whether the specified key is currently contained in the cache.
Public method | ContainsKey(ID) | Determines whether the specified key is currently contained in the cache.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCacheKeys()()()() | Gets a list of all the current cache keys.
Public method | GetCacheKeys(String) | Gets the cache keys.
Public method | GetEntry | Gets the entry represented by key.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetNamedInstance | Get the instance of cache by name
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the value.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(Object) | Removes the specified key.
Public method | Remove<(Of <<'(TKey>)>>)(Predicate<(Of <<'(TKey>)>>)) | Remove keys by predicate
Public method | RemoveKeysContaining | Removes the keys containing the value.
Public method | RemovePrefix | Removes the prefix.
Public method | Scavenge | Scavenges this cache.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the count.
Public property | DefaultPriority | Gets or sets the default priority.
Public property | Enabled | Gets or sets a value indicating whether this Cache is enabled.
Public property | Id | Gets the id.
Public property | Item | Gets the Object with the specified key.
Public property | MaxSize | Gets or sets the max size.
Public property | Name | Gets the name.
Public property | RemainingSpace | Gets the remaining space (in bytes).
Public property | Scavengable | Gets or sets a value indicating whether this Cache is scavengable.
Public property | Size | Gets the size.
Public property | SyncRoot | Gets the sync root.

See Also

Cache Class
Sitecore.Caching Namespace


Cache Constructor (Int64)

[image]

Sitecore 6.4.1 API
Cache Constructor (Int64)
Cache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Cache(
    long maxSize
)
Visual Basic
Public Sub New ( _
    maxSize As Long _
)
Visual C++
public:
Cache(
    long long maxSize
)

Parameters

maxSize
Type: System..::..Int64
Size of the max.

See Also

Cache Class
Cache Overload
Sitecore.Caching Namespace


Cache Constructor (String, Int64)

[image]

Sitecore 6.4.1 API
Cache Constructor (String, Int64)
Cache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Cache(
    string name,
    long maxSize
)
Visual Basic
Public Sub New ( _
    name As String, _
    maxSize As Long _
)
Visual C++
public:
Cache(
    String^ name,
    long long maxSize
)

Parameters

name
Type: System..::..String
The name.
maxSize
Type: System..::..Int64
Size of the max.

See Also

Cache Class
Cache Overload
Sitecore.Caching Namespace


Cache Constructor (String, String)

[image]

Sitecore 6.4.1 API
Cache Constructor (String, String)
Cache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Cache(
    string name,
    string maxSize
)
Visual Basic
Public Sub New ( _
    name As String, _
    maxSize As String _
)
Visual C++
public:
Cache(
    String^ name,
    String^ maxSize
)

Parameters

name
Type: System..::..String
The name.
maxSize
Type: System..::..String
Size of the max.

See Also

Cache Class
Cache Overload
Sitecore.Caching Namespace


Cache Methods

[image] [image]

Sitecore 6.4.1 API
Cache Methods
Cache Class See Also Send Feedback

The Cache type exposes the following members.

Methods

 | Name | Description
Public method | Add(String, ICacheable) | Adds the specified key.
Public method | Add(String, ID) | Adds the specified key.
Public method | Add(String, String) | Adds the specified key.
Public method | Add(ID, ICacheable) | Adds the specified key.
Public method | Add(ID, String) | Adds the specified key.
Public method | Add(Object, Object, Int64) | Adds the specified data to the cache.
Public method | Add(String, Object, Int64) | Adds the specified key.
Public method | Add(ID, Object, Int64) | Adds the specified key.
Public method | Add(Object, Object, Int64, DateTime) | Adds the specified key.
Public method | Add(Object, Object, Int64, TimeSpan) | Adds the specified data to the cache.
Public method | Add(String, Object, Int64, DateTime) | Adds the specified object.
Public method | Add(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Adds the specified key.
Public method | Add(String, Object, Int64, TimeSpan) | Adds the specified object.
Public method | Add(Object, Object, Int64, TimeSpan, DateTime) | Adds the specified data to the cache.
Public method | Clear | Clears this instance.
Public method | ContainsKey(Object) | Determines whether the specified key is currently contained in the cache.
Public method | ContainsKey(ID) | Determines whether the specified key is currently contained in the cache.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCacheKeys()()()() | Gets a list of all the current cache keys.
Public method | GetCacheKeys(String) | Gets the cache keys.
Public method | GetEntry | Gets the entry represented by key.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetNamedInstance | Get the instance of cache by name
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the value.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(Object) | Removes the specified key.
Public method | Remove<(Of <<'(TKey>)>>)(Predicate<(Of <<'(TKey>)>>)) | Remove keys by predicate
Public method | RemoveKeysContaining | Removes the keys containing the value.
Public method | RemovePrefix | Removes the prefix.
Public method | Scavenge | Scavenges this cache.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Cache Class
Sitecore.Caching Namespace


Add Method

[image] [image]

Sitecore 6.4.1 API
Cache..::..Add Method
Cache Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(String, ICacheable) | Adds the specified key.
Public method | Add(String, ID) | Adds the specified key.
Public method | Add(String, String) | Adds the specified key.
Public method | Add(ID, ICacheable) | Adds the specified key.
Public method | Add(ID, String) | Adds the specified key.
Public method | Add(Object, Object, Int64) | Adds the specified data to the cache.
Public method | Add(String, Object, Int64) | Adds the specified key.
Public method | Add(ID, Object, Int64) | Adds the specified key.
Public method | Add(Object, Object, Int64, DateTime) | Adds the specified key.
Public method | Add(Object, Object, Int64, TimeSpan) | Adds the specified data to the cache.
Public method | Add(String, Object, Int64, DateTime) | Adds the specified object.
Public method | Add(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Adds the specified key.
Public method | Add(String, Object, Int64, TimeSpan) | Adds the specified object.
Public method | Add(Object, Object, Int64, TimeSpan, DateTime) | Adds the specified data to the cache.

See Also

Cache Class
Cache Members
Sitecore.Caching Namespace


Add Method (String, ICacheable)

[image]

Sitecore 6.4.1 API
Cache..::..Add Method (String, ICacheable)
Cache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Add(
    string key,
    ICacheable data
)
Visual Basic
Public Sub Add ( _
    key As String, _
    data As ICacheable _
)
Visual C++
public:
void Add(
    String^ key,
    ICacheable^ data
)

Parameters

key
Type: System..::..String
The key.
data
Type: Sitecore.Caching..::..ICacheable
The data.

See Also

Cache Class
Add Overload
Sitecore.Caching Namespace


Add Method (String, ID)

[image]

Sitecore 6.4.1 API
Cache..::..Add Method (String, ID)
Cache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Add(
    string key,
    ID value
)
Visual Basic
Public Sub Add ( _
    key As String, _
    value As ID _
)
Visual C++
public:
void Add(
    String^ key,
    ID^ value
)

Parameters

key
Type: System..::..String
The key.
value
Type: Sitecore.Data..::..ID
The value.

See Also

Cache Class
Add Overload
Sitecore.Caching Namespace


Add Method (String, String)

[image]

Sitecore 6.4.1 API
Cache..::..Add Method (String, String)
Cache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Cache..::..CacheEntry Add(
    string key,
    string data
)
Visual Basic
Public Function Add ( _
    key As String, _
    data As String _
) As Cache..::..CacheEntry
Visual C++
public:
Cache..::..CacheEntry^ Add(
    String^ key,
    String^ data
)

Parameters

key
Type: System..::..String
The key.
data
Type: System..::..String
The data.

Return Value

[Missing <returns> documentation for "M:Sitecore.Caching.Cache.Add(System.String,System.String)"]

See Also

Cache Class
Add Overload
Sitecore.Caching Namespace


Add Method (ID, ICacheable)

[image]

Sitecore 6.4.1 API
Cache..::..Add Method (ID, ICacheable)
Cache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Add(
    ID key,
    ICacheable data
)
Visual Basic
Public Sub Add ( _
    key As ID, _
    data As ICacheable _
)
Visual C++
public:
void Add(
    ID^ key,
    ICacheable^ data
)

Parameters

key
Type: Sitecore.Data..::..ID
The key.
data
Type: Sitecore.Caching..::..ICacheable
The data.

See Also

Cache Class
Add Overload
Sitecore.Caching Namespace


Add Method (ID, String)

[image]

Sitecore 6.4.1 API
Cache..::..Add Method (ID, String)
Cache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Add(
    ID key,
    string value
)
Visual Basic
Public Sub Add ( _
    key As ID, _
    value As String _
)
Visual C++
public:
void Add(
    ID^ key,
    String^ value
)

Parameters

key
Type: Sitecore.Data..::..ID
The key.
value
Type: System..::..String
The value.

See Also

Cache Class
Add Overload
Sitecore.Caching Namespace


Add Method (Object, Object, Int64)

[image]

Sitecore 6.4.1 API
Cache..::..Add Method (Object, Object, Int64)
Cache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Add(
    Object key,
    Object data,
    long dataLength
)
Visual Basic
Public Sub Add ( _
    key As Object, _
    data As Object, _
    dataLength As Long _
)
Visual C++
public:
void Add(
    Object^ key,
    Object^ data,
    long long dataLength
)

Parameters

key
Type: System..::..Object
The key.
data
Type: System..::..Object
The data.
dataLength
Type: System..::..Int64
Length of the data.

See Also

Cache Class
Add Overload
Sitecore.Caching Namespace


Add Method (String, Object, Int64)

[image]

Sitecore 6.4.1 API
Cache..::..Add Method (String, Object, Int64)
Cache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Add(
    string key,
    Object data,
    long dataLength
)
Visual Basic
Public Sub Add ( _
    key As String, _
    data As Object, _
    dataLength As Long _
)
Visual C++
public:
void Add(
    String^ key,
    Object^ data,
    long long dataLength
)

Parameters

key
Type: System..::..String
The key.
data
Type: System..::..Object
The data.
dataLength
Type: System..::..Int64
Length of the data.

See Also

Cache Class
Add Overload
Sitecore.Caching Namespace


Add Method (ID, Object, Int64)

[image]

Sitecore 6.4.1 API
Cache..::..Add Method (ID, Object, Int64)
Cache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Add(
    ID key,
    Object data,
    long dataLength
)
Visual Basic
Public Sub Add ( _
    key As ID, _
    data As Object, _
    dataLength As Long _
)
Visual C++
public:
void Add(
    ID^ key,
    Object^ data,
    long long dataLength
)

Parameters

key
Type: Sitecore.Data..::..ID
The key.
data
Type: System..::..Object
The data.
dataLength
Type: System..::..Int64
Length of the data.

See Also

Cache Class
Add Overload
Sitecore.Caching Namespace


Add Method (Object, Object, Int64, DateTime)

[image]

Sitecore 6.4.1 API
Cache..::..Add Method (Object, Object, Int64, DateTime)
Cache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Add(
    Object key,
    Object data,
    long dataLength,
    DateTime absoluteExpiration
)
Visual Basic
Public Sub Add ( _
    key As Object, _
    data As Object, _
    dataLength As Long, _
    absoluteExpiration As DateTime _
)
Visual C++
public:
void Add(
    Object^ key,
    Object^ data,
    long long dataLength,
    DateTime absoluteExpiration
)

Parameters

key
Type: System..::..Object
The key.
data
Type: System..::..Object
The data.
dataLength
Type: System..::..Int64
Length of the data.
absoluteExpiration
Type: System..::..DateTime
The absolute expiration.

See Also

Cache Class
Add Overload
Sitecore.Caching Namespace


Add Method (Object, Object, Int64, TimeSpan)

[image]

Sitecore 6.4.1 API
Cache..::..Add Method (Object, Object, Int64, TimeSpan)
Cache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Add(
    Object key,
    Object data,
    long dataLength,
    TimeSpan slidingExpiration
)
Visual Basic
Public Sub Add ( _
    key As Object, _
    data As Object, _
    dataLength As Long, _
    slidingExpiration As TimeSpan _
)
Visual C++
public:
void Add(
    Object^ key,
    Object^ data,
    long long dataLength,
    TimeSpan slidingExpiration
)

Parameters

key
Type: System..::..Object
The key.
data
Type: System..::..Object
The data.
dataLength
Type: System..::..Int64
Length of the data.
slidingExpiration
Type: System..::..TimeSpan
The sliding expiration.

See Also

Cache Class
Add Overload
Sitecore.Caching Namespace


Add Method (String, Object, Int64, DateTime)

[image]

Sitecore 6.4.1 API
Cache..::..Add Method (String, Object, Int64, DateTime)
Cache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Cache..::..CacheEntry Add(
    string key,
    Object data,
    long dataLength,
    DateTime absoluteExpiration
)
Visual Basic
Public Function Add ( _
    key As String, _
    data As Object, _
    dataLength As Long, _
    absoluteExpiration As DateTime _
) As Cache..::..CacheEntry
Visual C++
public:
Cache..::..CacheEntry^ Add(
    String^ key,
    Object^ data,
    long long dataLength,
    DateTime absoluteExpiration
)

Parameters

key
Type: System..::..String
The key.
data
Type: System..::..Object
The data.
dataLength
Type: System..::..Int64
Length of the data.
absoluteExpiration
Type: System..::..DateTime
The absolute expiration.

Return Value

[Missing <returns> documentation for "M:Sitecore.Caching.Cache.Add(System.String,System.Object,System.Int64,System.DateTime)"]

See Also

Cache Class
Add Overload
Sitecore.Caching Namespace


Add Method (String, Object, Int64, EventHandler(EntryRemovedEventArgs))

[image]

Sitecore 6.4.1 API
Cache..::..Add Method (String, Object, Int64, EventHandler<(Of <(<'EntryRemovedEventArgs>)>)>)
Cache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Add(
    string key,
    Object data,
    long dataLength,
    EventHandler<EntryRemovedEventArgs> removedHandler
)
Visual Basic
Public Sub Add ( _
    key As String, _
    data As Object, _
    dataLength As Long, _
    removedHandler As EventHandler(Of EntryRemovedEventArgs) _
)
Visual C++
public:
void Add(
    String^ key,
    Object^ data,
    long long dataLength,
    EventHandler<EntryRemovedEventArgs^>^ removedHandler
)

Parameters

key
Type: System..::..String
The key.
data
Type: System..::..Object
The data.
dataLength
Type: System..::..Int64
Length of the data.
removedHandler
Type: System..::..EventHandler <(Of <(<' EntryRemovedEventArgs >)>)>
The removed handler.

See Also

Cache Class
Add Overload
Sitecore.Caching Namespace


Add Method (String, Object, Int64, TimeSpan)

[image]

Sitecore 6.4.1 API
Cache..::..Add Method (String, Object, Int64, TimeSpan)
Cache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Cache..::..CacheEntry Add(
    string key,
    Object data,
    long dataLength,
    TimeSpan slidingExpiration
)
Visual Basic
Public Function Add ( _
    key As String, _
    data As Object, _
    dataLength As Long, _
    slidingExpiration As TimeSpan _
) As Cache..::..CacheEntry
Visual C++
public:
Cache..::..CacheEntry^ Add(
    String^ key,
    Object^ data,
    long long dataLength,
    TimeSpan slidingExpiration
)

Parameters

key
Type: System..::..String
The key.
data
Type: System..::..Object
The data.
dataLength
Type: System..::..Int64
Length of the data.
slidingExpiration
Type: System..::..TimeSpan
The sliding expiration.

Return Value

[Missing <returns> documentation for "M:Sitecore.Caching.Cache.Add(System.String,System.Object,System.Int64,System.TimeSpan)"]

See Also

Cache Class
Add Overload
Sitecore.Caching Namespace


Add Method (Object, Object, Int64, TimeSpan, DateTime)

[image]

Sitecore 6.4.1 API
Cache..::..Add Method (Object, Object, Int64, TimeSpan, DateTime)
Cache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Add(
    Object key,
    Object data,
    long dataLength,
    TimeSpan slidingExpiration,
    DateTime absoluteExpiration
)
Visual Basic
Public Sub Add ( _
    key As Object, _
    data As Object, _
    dataLength As Long, _
    slidingExpiration As TimeSpan, _
    absoluteExpiration As DateTime _
)
Visual C++
public:
void Add(
    Object^ key,
    Object^ data,
    long long dataLength,
    TimeSpan slidingExpiration,
    DateTime absoluteExpiration
)

Parameters

key
Type: System..::..Object
The key.
data
Type: System..::..Object
The data.
dataLength
Type: System..::..Int64
Length of the data.
slidingExpiration
Type: System..::..TimeSpan
The sliding expiration.
absoluteExpiration
Type: System..::..DateTime
The absolute expiration of the cache entry

See Also

Cache Class
Add Overload
Sitecore.Caching Namespace


Clear Method

[image]

Sitecore 6.4.1 API
Cache..::..Clear Method
Cache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

Cache Class
Sitecore.Caching Namespace


ContainsKey Method

[image] [image]

Sitecore 6.4.1 API
Cache..::..ContainsKey Method
Cache Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ContainsKey(Object) | Determines whether the specified key is currently contained in the cache.
Public method | ContainsKey(ID) | Determines whether the specified key is currently contained in the cache.

See Also

Cache Class
Cache Members
Sitecore.Caching Namespace


ContainsKey Method (Object)

[image]

Sitecore 6.4.1 API
Cache..::..ContainsKey Method (Object)
Cache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ContainsKey(
    Object key
)
Visual Basic
Public Function ContainsKey ( _
    key As Object _
) As Boolean
Visual C++
public:
bool ContainsKey(
    Object^ key
)

Parameters

key
Type: System..::..Object
The key.

Return Value

true if the specified key is contained; otherwise, false.

See Also

Cache Class
ContainsKey Overload
Sitecore.Caching Namespace


ContainsKey Method (ID)

[image]

Sitecore 6.4.1 API
Cache..::..ContainsKey Method (ID)
Cache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ContainsKey(
    ID key
)
Visual Basic
Public Function ContainsKey ( _
    key As ID _
) As Boolean
Visual C++
public:
bool ContainsKey(
    ID^ key
)

Parameters

key
Type: Sitecore.Data..::..ID
The key.

Return Value

true if the specified key is contained; otherwise, false.

See Also

Cache Class
ContainsKey Overload
Sitecore.Caching Namespace


GetCacheKeys Method

[image] [image]

Sitecore 6.4.1 API
Cache..::..GetCacheKeys Method
Cache Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetCacheKeys()()()() | Gets a list of all the current cache keys.
Public method | GetCacheKeys(String) | Gets the cache keys.

See Also

Cache Class
Cache Members
Sitecore.Caching Namespace


GetCacheKeys Method

[image]

Sitecore 6.4.1 API
Cache..::..GetCacheKeys Method
Cache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ArrayList GetCacheKeys()
Visual Basic
Public Function GetCacheKeys As ArrayList
Visual C++
public:
ArrayList^ GetCacheKeys()

Return Value

[Missing <returns> documentation for "M:Sitecore.Caching.Cache.GetCacheKeys"]

See Also

Cache Class
GetCacheKeys Overload
Sitecore.Caching Namespace


GetCacheKeys Method (String)

[image]

Sitecore 6.4.1 API
Cache..::..GetCacheKeys Method (String)
Cache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ArrayList GetCacheKeys(
    string keyPrefix
)
Visual Basic
Public Function GetCacheKeys ( _
    keyPrefix As String _
) As ArrayList
Visual C++
public:
ArrayList^ GetCacheKeys(
    String^ keyPrefix
)

Parameters

keyPrefix
Type: System..::..String
The key prefix.

Return Value

[Missing <returns> documentation for "M:Sitecore.Caching.Cache.GetCacheKeys(System.String)"]

See Also

Cache Class
GetCacheKeys Overload
Sitecore.Caching Namespace


GetEntry Method

[image]

Sitecore 6.4.1 API
Cache..::..GetEntry Method
Cache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Cache..::..CacheEntry GetEntry(
    Object key,
    bool updateAccessed
)
Visual Basic
Public Function GetEntry ( _
    key As Object, _
    updateAccessed As Boolean _
) As Cache..::..CacheEntry
Visual C++
public:
Cache..::..CacheEntry^ GetEntry(
    Object^ key,
    bool updateAccessed
)

Parameters

key
Type: System..::..Object
The key.
updateAccessed
Type: System..::..Boolean
if set to true the update accessed counter is updated.

Return Value

The entry (or null).

See Also

Cache Class
Sitecore.Caching Namespace


GetNamedInstance Method

[image]

Sitecore 6.4.1 API
Cache..::..GetNamedInstance Method
Cache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Cache GetNamedInstance(
    string name,
    long defaultMaxSize
)
Visual Basic
Public Shared Function GetNamedInstance ( _
    name As String, _
    defaultMaxSize As Long _
) As Cache
Visual C++
public:
static Cache^ GetNamedInstance(
    String^ name,
    long long defaultMaxSize
)

Parameters

name
Type: System..::..String
The name of the cache
defaultMaxSize
Type: System..::..Int64

[Missing <param name="defaultMaxSize"/> documentation for "M:Sitecore.Caching.Cache.GetNamedInstance(System.String,System.Int64)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Caching.Cache.GetNamedInstance(System.String,System.Int64)"]

See Also

Cache Class
Sitecore.Caching Namespace


Remove Method

[image] [image]

Sitecore 6.4.1 API
Cache..::..Remove Method
Cache Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Remove(Object) | Removes the specified key.
Public method | Remove<(Of <<'(TKey>)>>)(Predicate<(Of <<'(TKey>)>>)) | Remove keys by predicate

See Also

Cache Class
Cache Members
Sitecore.Caching Namespace


Remove Method (Object)

[image]

Sitecore 6.4.1 API
Cache..::..Remove Method (Object)
Cache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Remove(
    Object key
)
Visual Basic
Public Sub Remove ( _
    key As Object _
)
Visual C++
public:
void Remove(
    Object^ key
)

Parameters

key
Type: System..::..Object
The key.

See Also

Cache Class
Remove Overload
Sitecore.Caching Namespace


Remove(TKey) Method (Predicate(TKey))

[image]

Sitecore 6.4.1 API
Cache..::..Remove<(Of <(<'TKey>)>)> Method (Predicate<(Of <(<'TKey>)>)>)
Cache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Remove<TKey>(
    Predicate<TKey> predicate
)
Visual Basic
Public Sub Remove(Of TKey) ( _
    predicate As Predicate(Of TKey) _
)
Visual C++
public:
generic<typename TKey>
void Remove(
    Predicate<TKey>^ predicate
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<'TKey>)>)>

[Missing <param name="predicate"/> documentation for "M:Sitecore.Caching.Cache.Remove``1(System.Predicate{``0})"]

Type Parameters

TKey

[Missing <typeparam name="TKey"/> documentation for "M:Sitecore.Caching.Cache.Remove``1(System.Predicate{``0})"]

See Also

Cache Class
Remove Overload
Sitecore.Caching Namespace


RemoveKeysContaining Method

[image]

Sitecore 6.4.1 API
Cache..::..RemoveKeysContaining Method
Cache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RemoveKeysContaining(
    string value
)
Visual Basic
Public Sub RemoveKeysContaining ( _
    value As String _
)
Visual C++
public:
void RemoveKeysContaining(
    String^ value
)

Parameters

value
Type: System..::..String
The value.

See Also

Cache Class
Sitecore.Caching Namespace


RemovePrefix Method

[image]

Sitecore 6.4.1 API
Cache..::..RemovePrefix Method
Cache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RemovePrefix(
    string keyPrefix
)
Visual Basic
Public Sub RemovePrefix ( _
    keyPrefix As String _
)
Visual C++
public:
void RemovePrefix(
    String^ keyPrefix
)

Parameters

keyPrefix
Type: System..::..String
The key prefix.

See Also

Cache Class
Sitecore.Caching Namespace


Cache Properties

[image] [image]

Sitecore 6.4.1 API
Cache Properties
Cache Class See Also Send Feedback

The Cache type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the count.
Public property | DefaultPriority | Gets or sets the default priority.
Public property | Enabled | Gets or sets a value indicating whether this Cache is enabled.
Public property | Id | Gets the id.
Public property | Item | Gets the Object with the specified key.
Public property | MaxSize | Gets or sets the max size.
Public property | Name | Gets the name.
Public property | RemainingSpace | Gets the remaining space (in bytes).
Public property | Scavengable | Gets or sets a value indicating whether this Cache is scavengable.
Public property | Size | Gets the size.
Public property | SyncRoot | Gets the sync root.

See Also

Cache Class
Sitecore.Caching Namespace


Count Property

[image]

Sitecore 6.4.1 API
Cache..::..Count Property
Cache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
property int Count {
    int get ();
}

Field Value

The count.

See Also

Cache Class
Sitecore.Caching Namespace


Enabled Property

[image]

Sitecore 6.4.1 API
Cache..::..Enabled Property
Cache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Enabled { get; set; }
Visual Basic
Public Property Enabled As Boolean
    Get
    Set
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

Field Value

true if enabled; otherwise, false.

See Also

Cache Class
Sitecore.Caching Namespace


Id Property

[image]

Sitecore 6.4.1 API
Cache..::..Id Property
Cache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID Id { get; }
Visual Basic
Public ReadOnly Property Id As ID
    Get
Visual C++
public:
property ID^ Id {
    ID^ get ();
}

Field Value

The id.

See Also

Cache Class
Sitecore.Caching Namespace


Item Property

[image]

Sitecore 6.4.1 API
Cache..::..Item Property
Cache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object this[
    Object key
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    key As Object _
) As Object
    Get
Visual C++
public:
property Object^ default[Object^ key] {
    Object^ get (Object^ key);
}

Parameters

key
Type: System..::..Object

Field Value

See Also

Cache Class
Sitecore.Caching Namespace


MaxSize Property

[image]

Sitecore 6.4.1 API
Cache..::..MaxSize Property
Cache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long MaxSize { get; set; }
Visual Basic
Public Property MaxSize As Long
    Get
    Set
Visual C++
public:
property long long MaxSize {
    long long get ();
    void set (long long value);
}

Field Value

The max size.

See Also

Cache Class
Sitecore.Caching Namespace


Name Property

[image]

Sitecore 6.4.1 API
Cache..::..Name Property
Cache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

Cache Class
Sitecore.Caching Namespace


RemainingSpace Property

[image]

Sitecore 6.4.1 API
Cache..::..RemainingSpace Property
Cache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long RemainingSpace { get; }
Visual Basic
Public ReadOnly Property RemainingSpace As Long
    Get
Visual C++
public:
property long long RemainingSpace {
    long long get ();
}

Field Value

The remaining space.

See Also

Cache Class
Sitecore.Caching Namespace


Scavengable Property

[image]

Sitecore 6.4.1 API
Cache..::..Scavengable Property
Cache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Scavengable { get; set; }
Visual Basic
Public Property Scavengable As Boolean
    Get
    Set
Visual C++
public:
property bool Scavengable {
    bool get ();
    void set (bool value);
}

Field Value

true if scavengable; otherwise, false.

See Also

Cache Class
Sitecore.Caching Namespace


Size Property

[image]

Sitecore 6.4.1 API
Cache..::..Size Property
Cache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long Size { get; }
Visual Basic
Public ReadOnly Property Size As Long
    Get
Visual C++
public:
property long long Size {
    long long get ();
}

Field Value

The size.

See Also

Cache Class
Sitecore.Caching Namespace


SyncRoot Property

[image]

Sitecore 6.4.1 API
Cache..::..SyncRoot Property
Cache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object SyncRoot { get; }
Visual Basic
Public ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
property Object^ SyncRoot {
    Object^ get ();
}

Field Value

The sync root.

See Also

Cache Class
Sitecore.Caching Namespace


Cache.CacheEntry Class

[image]

Sitecore 6.4.1 API
Cache..::..CacheEntry Class
Cache Class Members See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CacheEntry
Visual Basic
Public Class CacheEntry
Visual C++
public ref class CacheEntry

Inheritance Hierarchy

System..::..Object
Sitecore.Caching..::..Cache..::..CacheEntry

See Also

Cache..::..CacheEntry Members
Sitecore.Caching Namespace


Cache.CacheEntry Members

[image] [image]

Sitecore 6.4.1 API
Cache..::..CacheEntry Members
Cache..::..CacheEntry Class Constructors Methods Properties Events See Also Send Feedback

Cache
Class representing a cache.

The Cache..::..CacheEntry type exposes the following members.

Constructors

 | Name | Description
Public method | Cache..::..CacheEntry(String, ICacheable, CachePriority, Cache) | Initializes a new instance of the Cache..::..CacheEntry class.
Public method | Cache..::..CacheEntry(String, String, CachePriority, Cache) | Initializes a new instance of the Cache..::..CacheEntry class.
Public method | Cache..::..CacheEntry(ID, ICacheable, CachePriority, Cache) | Initializes a new instance of the Cache..::..CacheEntry class.
Public method | Cache..::..CacheEntry(ID, String, CachePriority, Cache) | Initializes a new instance of the Cache..::..CacheEntry class.
Public method | Cache..::..CacheEntry(Object, Object, Int64, CachePriority, Cache) | Initializes a new instance of the Cache..::..CacheEntry class.
Public method | Cache..::..CacheEntry(String, Object, Int64, CachePriority, Cache) | Initializes a new instance of the Cache..::..CacheEntry class.
Public method | Cache..::..CacheEntry(ID, Object, Int64, CachePriority, Cache) | Initializes a new instance of the Cache..::..CacheEntry class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RaiseEntryRemoved | Raises the EntryRemoved event.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateAccessed | Updates the accessed time.

Properties

 | Name | Description
Public property | AbsoluteExpiration | Gets or sets the sliding expiration.
Public property | Accessed | Gets the date/time where the entry was last accessed.
Public property | Data | Gets the data.
Public property | DataLength | Gets the length of the data.
Public property | Expired | Gets a value indicating whether this Cache..::..CacheEntry is expired.
Public property | Key | Gets the key.
Public property | Priority | Gets the priority.
Public property | SlidingExpiration | Gets or sets the sliding expiration.

Events

 | Name | Description
Public event | EntryRemoved |

See Also

Cache..::..CacheEntry Class
Sitecore.Caching Namespace


Cache.CacheEntry Constructor (String, ICacheable, CachePriority, Cache)

[image]

Sitecore 6.4.1 API
Cache..::..CacheEntry Constructor (String, ICacheable, CachePriority, Cache)
Cache..::..CacheEntry Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CacheEntry(
    string key,
    ICacheable data,
    CachePriority priority,
    Cache cache
)
Visual Basic
Public Sub New ( _
    key As String, _
    data As ICacheable, _
    priority As CachePriority, _
    cache As Cache _
)
Visual C++
public:
CacheEntry(
    String^ key,
    ICacheable^ data,
    CachePriority priority,
    Cache^ cache
)

Parameters

key
Type: System..::..String
The key.
data
Type: Sitecore.Caching..::..ICacheable
The data.
priority
Type: Sitecore.Caching..::..CachePriority
The priority.
cache
Type: Sitecore.Caching..::..Cache
The cache.

See Also

Cache..::..CacheEntry Class
Cache..::..CacheEntry Overload
Sitecore.Caching Namespace


Cache.CacheEntry Constructor (String, String, CachePriority, Cache)

[image]

Sitecore 6.4.1 API
Cache..::..CacheEntry Constructor (String, String, CachePriority, Cache)
Cache..::..CacheEntry Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CacheEntry(
    string key,
    string value,
    CachePriority priority,
    Cache cache
)
Visual Basic
Public Sub New ( _
    key As String, _
    value As String, _
    priority As CachePriority, _
    cache As Cache _
)
Visual C++
public:
CacheEntry(
    String^ key,
    String^ value,
    CachePriority priority,
    Cache^ cache
)

Parameters

key
Type: System..::..String
The key.
value
Type: System..::..String
The value.
priority
Type: Sitecore.Caching..::..CachePriority
The priority.
cache
Type: Sitecore.Caching..::..Cache
The cache.

See Also

Cache..::..CacheEntry Class
Cache..::..CacheEntry Overload
Sitecore.Caching Namespace


Cache.CacheEntry Constructor (ID, ICacheable, CachePriority, Cache)

[image]

Sitecore 6.4.1 API
Cache..::..CacheEntry Constructor (ID, ICacheable, CachePriority, Cache)
Cache..::..CacheEntry Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CacheEntry(
    ID key,
    ICacheable data,
    CachePriority priority,
    Cache cache
)
Visual Basic
Public Sub New ( _
    key As ID, _
    data As ICacheable, _
    priority As CachePriority, _
    cache As Cache _
)
Visual C++
public:
CacheEntry(
    ID^ key,
    ICacheable^ data,
    CachePriority priority,
    Cache^ cache
)

Parameters

key
Type: Sitecore.Data..::..ID
The key.
data
Type: Sitecore.Caching..::..ICacheable
The data.
priority
Type: Sitecore.Caching..::..CachePriority
The priority.
cache
Type: Sitecore.Caching..::..Cache
The cache.

See Also

Cache..::..CacheEntry Class
Cache..::..CacheEntry Overload
Sitecore.Caching Namespace


Cache.CacheEntry Constructor (ID, String, CachePriority, Cache)

[image]

Sitecore 6.4.1 API
Cache..::..CacheEntry Constructor (ID, String, CachePriority, Cache)
Cache..::..CacheEntry Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CacheEntry(
    ID key,
    string value,
    CachePriority priority,
    Cache cache
)
Visual Basic
Public Sub New ( _
    key As ID, _
    value As String, _
    priority As CachePriority, _
    cache As Cache _
)
Visual C++
public:
CacheEntry(
    ID^ key,
    String^ value,
    CachePriority priority,
    Cache^ cache
)

Parameters

key
Type: Sitecore.Data..::..ID
The key.
value
Type: System..::..String
The value.
priority
Type: Sitecore.Caching..::..CachePriority
The priority.
cache
Type: Sitecore.Caching..::..Cache
The cache.

See Also

Cache..::..CacheEntry Class
Cache..::..CacheEntry Overload
Sitecore.Caching Namespace


Cache.CacheEntry Constructor (Object, Object, Int64, CachePriority, Cache)

[image]

Sitecore 6.4.1 API
Cache..::..CacheEntry Constructor (Object, Object, Int64, CachePriority, Cache)
Cache..::..CacheEntry Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CacheEntry(
    Object key,
    Object data,
    long dataLength,
    CachePriority priority,
    Cache cache
)
Visual Basic
Public Sub New ( _
    key As Object, _
    data As Object, _
    dataLength As Long, _
    priority As CachePriority, _
    cache As Cache _
)
Visual C++
public:
CacheEntry(
    Object^ key,
    Object^ data,
    long long dataLength,
    CachePriority priority,
    Cache^ cache
)

Parameters

key
Type: System..::..Object
The key.
data
Type: System..::..Object
The data.
dataLength
Type: System..::..Int64
Length of the data.
priority
Type: Sitecore.Caching..::..CachePriority
The priority.
cache
Type: Sitecore.Caching..::..Cache
The cache.

See Also

Cache..::..CacheEntry Class
Cache..::..CacheEntry Overload
Sitecore.Caching Namespace


Cache.CacheEntry Constructor (String, Object, Int64, CachePriority, Cache)

[image]

Sitecore 6.4.1 API
Cache..::..CacheEntry Constructor (String, Object, Int64, CachePriority, Cache)
Cache..::..CacheEntry Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CacheEntry(
    string key,
    Object data,
    long dataLength,
    CachePriority priority,
    Cache cache
)
Visual Basic
Public Sub New ( _
    key As String, _
    data As Object, _
    dataLength As Long, _
    priority As CachePriority, _
    cache As Cache _
)
Visual C++
public:
CacheEntry(
    String^ key,
    Object^ data,
    long long dataLength,
    CachePriority priority,
    Cache^ cache
)

Parameters

key
Type: System..::..String
The key.
data
Type: System..::..Object
The data.
dataLength
Type: System..::..Int64
Length of the data.
priority
Type: Sitecore.Caching..::..CachePriority
The priority.
cache
Type: Sitecore.Caching..::..Cache
The cache.

See Also

Cache..::..CacheEntry Class
Cache..::..CacheEntry Overload
Sitecore.Caching Namespace


Cache.CacheEntry Constructor (ID, Object, Int64, CachePriority, Cache)

[image]

Sitecore 6.4.1 API
Cache..::..CacheEntry Constructor (ID, Object, Int64, CachePriority, Cache)
Cache..::..CacheEntry Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CacheEntry(
    ID key,
    Object data,
    long dataLength,
    CachePriority priority,
    Cache cache
)
Visual Basic
Public Sub New ( _
    key As ID, _
    data As Object, _
    dataLength As Long, _
    priority As CachePriority, _
    cache As Cache _
)
Visual C++
public:
CacheEntry(
    ID^ key,
    Object^ data,
    long long dataLength,
    CachePriority priority,
    Cache^ cache
)

Parameters

key
Type: Sitecore.Data..::..ID
The key.
data
Type: System..::..Object
The data.
dataLength
Type: System..::..Int64
Length of the data.
priority
Type: Sitecore.Caching..::..CachePriority
The priority.
cache
Type: Sitecore.Caching..::..Cache
The cache.

See Also

Cache..::..CacheEntry Class
Cache..::..CacheEntry Overload
Sitecore.Caching Namespace


Cache.CacheEntry Methods

[image] [image]

Sitecore 6.4.1 API
Cache..::..CacheEntry Methods
Cache..::..CacheEntry Class See Also Send Feedback

The Cache..::..CacheEntry type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RaiseEntryRemoved | Raises the EntryRemoved event.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateAccessed | Updates the accessed time.

See Also

Cache..::..CacheEntry Class
Sitecore.Caching Namespace


RaiseEntryRemoved Method

[image]

Sitecore 6.4.1 API
Cache..::..CacheEntry..::..RaiseEntryRemoved Method
Cache..::..CacheEntry Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RaiseEntryRemoved()
Visual Basic
Public Sub RaiseEntryRemoved
Visual C++
public:
void RaiseEntryRemoved()

See Also

Cache..::..CacheEntry Class
Sitecore.Caching Namespace


UpdateAccessed Method

[image]

Sitecore 6.4.1 API
Cache..::..CacheEntry..::..UpdateAccessed Method
Cache..::..CacheEntry Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void UpdateAccessed()
Visual Basic
Public Sub UpdateAccessed
Visual C++
public:
void UpdateAccessed()

See Also

Cache..::..CacheEntry Class
Sitecore.Caching Namespace


Cache.CacheEntry Properties

[image] [image]

Sitecore 6.4.1 API
Cache..::..CacheEntry Properties
Cache..::..CacheEntry Class See Also Send Feedback

The Cache..::..CacheEntry type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteExpiration | Gets or sets the sliding expiration.
Public property | Accessed | Gets the date/time where the entry was last accessed.
Public property | Data | Gets the data.
Public property | DataLength | Gets the length of the data.
Public property | Expired | Gets a value indicating whether this Cache..::..CacheEntry is expired.
Public property | Key | Gets the key.
Public property | Priority | Gets the priority.
Public property | SlidingExpiration | Gets or sets the sliding expiration.

See Also

Cache..::..CacheEntry Class
Sitecore.Caching Namespace


AbsoluteExpiration Property

[image]

Sitecore 6.4.1 API
Cache..::..CacheEntry..::..AbsoluteExpiration Property
Cache..::..CacheEntry Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime AbsoluteExpiration { get; set; }
Visual Basic
Public Property AbsoluteExpiration As DateTime
    Get
    Set
Visual C++
public:
property DateTime AbsoluteExpiration {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The sliding expiration.

See Also

Cache..::..CacheEntry Class
Sitecore.Caching Namespace


Accessed Property

[image]

Sitecore 6.4.1 API
Cache..::..CacheEntry..::..Accessed Property
Cache..::..CacheEntry Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime Accessed { get; set; }
Visual Basic
Public Property Accessed As DateTime
    Get
    Set
Visual C++
public:
property DateTime Accessed {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The date/time of access.

See Also

Cache..::..CacheEntry Class
Sitecore.Caching Namespace


Data Property

[image]

Sitecore 6.4.1 API
Cache..::..CacheEntry..::..Data Property
Cache..::..CacheEntry Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object Data { get; }
Visual Basic
Public ReadOnly Property Data As Object
    Get
Visual C++
public:
property Object^ Data {
    Object^ get ();
}

Field Value

The data.

See Also

Cache..::..CacheEntry Class
Sitecore.Caching Namespace


DataLength Property

[image]

Sitecore 6.4.1 API
Cache..::..CacheEntry..::..DataLength Property
Cache..::..CacheEntry Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long DataLength { get; }
Visual Basic
Public ReadOnly Property DataLength As Long
    Get
Visual C++
public:
property long long DataLength {
    long long get ();
}

Field Value

The length of the data.

See Also

Cache..::..CacheEntry Class
Sitecore.Caching Namespace


Expired Property

[image]

Sitecore 6.4.1 API
Cache..::..CacheEntry..::..Expired Property
Cache..::..CacheEntry Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Expired { get; }
Visual Basic
Public ReadOnly Property Expired As Boolean
    Get
Visual C++
public:
property bool Expired {
    bool get ();
}

Field Value

true if expired; otherwise, false.

See Also

Cache..::..CacheEntry Class
Sitecore.Caching Namespace


Key Property

[image]

Sitecore 6.4.1 API
Cache..::..CacheEntry..::..Key Property
Cache..::..CacheEntry Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object Key { get; }
Visual Basic
Public ReadOnly Property Key As Object
    Get
Visual C++
public:
property Object^ Key {
    Object^ get ();
}

Field Value

The key.

See Also

Cache..::..CacheEntry Class
Sitecore.Caching Namespace


Priority Property

[image]

Sitecore 6.4.1 API
Cache..::..CacheEntry..::..Priority Property
Cache..::..CacheEntry Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CachePriority Priority { get; }
Visual Basic
Public ReadOnly Property Priority As CachePriority
    Get
Visual C++
public:
property CachePriority Priority {
    CachePriority get ();
}

Field Value

The priority.

See Also

Cache..::..CacheEntry Class
Sitecore.Caching Namespace


SlidingExpiration Property

[image]

Sitecore 6.4.1 API
Cache..::..CacheEntry..::..SlidingExpiration Property
Cache..::..CacheEntry Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TimeSpan SlidingExpiration { get; set; }
Visual Basic
Public Property SlidingExpiration As TimeSpan
    Get
    Set
Visual C++
public:
property TimeSpan SlidingExpiration {
    TimeSpan get ();
    void set (TimeSpan value);
}

Field Value

The sliding expiration.

See Also

Cache..::..CacheEntry Class
Sitecore.Caching Namespace


Cache.CacheEntry Events

[image] [image]

Sitecore 6.4.1 API
Cache..::..CacheEntry Events
Cache..::..CacheEntry Class See Also Send Feedback

The Cache..::..CacheEntry type exposes the following members.

Events

 | Name | Description
Public event | EntryRemoved |

See Also

Cache..::..CacheEntry Class
Sitecore.Caching Namespace


EntryRemoved Event

[image]

Sitecore 6.4.1 API
Cache..::..CacheEntry..::..EntryRemoved Event
Cache..::..CacheEntry Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler<EntryRemovedEventArgs> EntryRemoved
Visual Basic
Public Event EntryRemoved As EventHandler(Of EntryRemovedEventArgs)
Visual C++
public:
 event EventHandler<EntryRemovedEventArgs^>^ EntryRemoved {
    void add (EventHandler<EntryRemovedEventArgs^>^ value);
    void remove (EventHandler<EntryRemovedEventArgs^>^ value);
}

See Also

Cache..::..CacheEntry Class
Sitecore.Caching Namespace


CacheComparer Class

[image]

Sitecore 6.4.1 API
CacheComparer Class
Members See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CacheComparer : IComparer
Visual Basic
Public Class CacheComparer _
    Implements IComparer
Visual C++
public ref class CacheComparer : IComparer

Inheritance Hierarchy

System..::..Object
Sitecore.Caching..::..CacheComparer

See Also

CacheComparer Members
Sitecore.Caching Namespace


CacheComparer Constructor

[image]

Sitecore 6.4.1 API
CacheComparer Constructor
CacheComparer Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CacheComparer()
Visual Basic
Public Sub New
Visual C++
public:
CacheComparer()

See Also

CacheComparer Class
Sitecore.Caching Namespace


CacheComparer Methods

[image] [image]

Sitecore 6.4.1 API
CacheComparer Methods
CacheComparer Class See Also Send Feedback

The CacheComparer type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CacheComparer Class
Sitecore.Caching Namespace


Compare Method

[image]

Sitecore 6.4.1 API
CacheComparer..::..Compare Method
CacheComparer Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Compare(
    Object x,
    Object y
)
Visual Basic
Public Function Compare ( _
    x As Object, _
    y As Object _
) As Integer
Visual C++
public:
virtual int Compare(
    Object^ x,
    Object^ y
) sealed

Parameters

x
Type: System..::..Object
The first object to compare.
y
Type: System..::..Object
The second object to compare.

Return Value

Value Condition Less than zero x is less than y. Zero x equals y. Greater than zero x is greater than y.

Implements

IComparer..::..Compare(Object, Object)

Exceptions

Exception | Condition
System..::..ArgumentException | Neither x nor y implements the IComparable interface.-or- x and y are of different types and neither one can handle comparisons with the other.

See Also

CacheComparer Class
Sitecore.Caching Namespace


CacheItem Class

[image]

Sitecore 6.4.1 API
CacheItem Class
Members See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CacheItem
Visual Basic
Public Class CacheItem
Visual C++
public ref class CacheItem

Inheritance Hierarchy

System..::..Object
Sitecore.Caching..::..CacheItem

See Also

CacheItem Members
Sitecore.Caching Namespace


CacheItem Members

[image] [image]

Sitecore 6.4.1 API
CacheItem Members
CacheItem Class Constructors Methods Properties See Also Send Feedback

The CacheItem type exposes the following members.

Constructors

 | Name | Description
Public method | CacheItem | Initializes a new instance of the CacheItem class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Accessed | Gets the accessed.
Public property | Created | Gets the created.
Public property | Object | Gets the object.
Public property | Priority | Gets the priority.

See Also

CacheItem Class
Sitecore.Caching Namespace


CacheItem Constructor

[image]

Sitecore 6.4.1 API
CacheItem Constructor
CacheItem Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CacheItem(
    Object obj,
    CachePriority priority
)
Visual Basic
Public Sub New ( _
    obj As Object, _
    priority As CachePriority _
)
Visual C++
public:
CacheItem(
    Object^ obj,
    CachePriority priority
)

Parameters

obj
Type: System..::..Object
The object.
priority
Type: Sitecore.Caching..::..CachePriority
The priority.

See Also

CacheItem Class
Sitecore.Caching Namespace


CacheItem Methods

[image] [image]

Sitecore 6.4.1 API
CacheItem Methods
CacheItem Class See Also Send Feedback

The CacheItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CacheItem Class
Sitecore.Caching Namespace


CacheItem Properties

[image] [image]

Sitecore 6.4.1 API
CacheItem Properties
CacheItem Class See Also Send Feedback

The CacheItem type exposes the following members.

Properties

 | Name | Description
Public property | Accessed | Gets the accessed.
Public property | Created | Gets the created.
Public property | Object | Gets the object.
Public property | Priority | Gets the priority.

See Also

CacheItem Class
Sitecore.Caching Namespace


Created Property

[image]

Sitecore 6.4.1 API
CacheItem..::..Created Property
CacheItem Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime Created { get; }
Visual Basic
Public ReadOnly Property Created As DateTime
    Get
Visual C++
public:
property DateTime Created {
    DateTime get ();
}

Field Value

The created.

See Also

CacheItem Class
Sitecore.Caching Namespace


Object Property

[image]

Sitecore 6.4.1 API
CacheItem..::..Object Property
CacheItem Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object Object { get; }
Visual Basic
Public ReadOnly Property Object As Object
    Get
Visual C++
public:
property Object^ Object {
    Object^ get ();
}

Field Value

The object.

See Also

CacheItem Class
Sitecore.Caching Namespace


Priority Property

[image]

Sitecore 6.4.1 API
CacheItem..::..Priority Property
CacheItem Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CachePriority Priority { get; }
Visual Basic
Public ReadOnly Property Priority As CachePriority
    Get
Visual C++
public:
property CachePriority Priority {
    CachePriority get ();
}

Field Value

The priority.

See Also

CacheItem Class
Sitecore.Caching Namespace


CacheManager Class

[image]

Sitecore 6.4.1 API
CacheManager Class
Members See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CacheManager
Visual Basic
Public Class CacheManager
Visual C++
public ref class CacheManager

Inheritance Hierarchy

System..::..Object
Sitecore.Caching..::..CacheManager

See Also

CacheManager Members
Sitecore.Caching Namespace


CacheManager Members

[image] [image]

Sitecore 6.4.1 API
CacheManager Members
CacheManager Class Constructors Methods Properties See Also Send Feedback

The CacheManager type exposes the following members.

Constructors

 | Name | Description
Public method | CacheManager | Initializes a new instance of the CacheManager class

Methods

 | Name | Description
 | ClearAccessResultCache | Clears the access result cache.
Public method | ClearAll | Obsolete. Clears all.
 | ClearAllCaches | Clears all caches.
 | ClearIsInRoleCache | Clear cache with information about is user in role
 | ClearSecurityCache | Clear security cache
 | ClearUserProfileCache | Clear cache with user profiles
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindCacheByName | Finds the cache by its name
 | GetAccessResultCache | Gets the access result cache.
 | GetAllCaches | Gets all caches.
 | GetDataCache | Gets the data cache.
 | GetFilteredItemsCache | Gets the filtered items cache for the specified site.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHtmlCache | Gets the HTML cache.
 | GetIsInRoleCache | Gets the is in role cache.
 | GetItemCache | Gets the item cache of a database.
 | GetPathCache | Gets the path cache.
 | GetRegistryCache | Gets the registry cache.
 | GetStatistics | Gets the statistics.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetUserProfileCache | Gets the user profile cache.
 | GetViewStateCache | Gets the view state cache.
 | GetXslCache | Gets the XSL cache.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets or sets a value indicating whether this CacheManager is enabled.
LoadFactor | Gets or sets the load factor.

See Also

CacheManager Class
Sitecore.Caching Namespace


CacheManager Constructor

[image]

Sitecore 6.4.1 API
CacheManager Constructor
CacheManager Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CacheManager()
Visual Basic
Public Sub New
Visual C++
public:
CacheManager()

See Also

CacheManager Class
Sitecore.Caching Namespace


CacheManager Methods

[image] [image]

Sitecore 6.4.1 API
CacheManager Methods
CacheManager Class See Also Send Feedback

The CacheManager type exposes the following members.

Methods

 | Name | Description
 | ClearAccessResultCache | Clears the access result cache.
Public method | ClearAll | Obsolete. Clears all.
 | ClearAllCaches | Clears all caches.
 | ClearIsInRoleCache | Clear cache with information about is user in role
 | ClearSecurityCache | Clear security cache
 | ClearUserProfileCache | Clear cache with user profiles
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindCacheByName | Finds the cache by its name
 | GetAccessResultCache | Gets the access result cache.
 | GetAllCaches | Gets all caches.
 | GetDataCache | Gets the data cache.
 | GetFilteredItemsCache | Gets the filtered items cache for the specified site.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHtmlCache | Gets the HTML cache.
 | GetIsInRoleCache | Gets the is in role cache.
 | GetItemCache | Gets the item cache of a database.
 | GetPathCache | Gets the path cache.
 | GetRegistryCache | Gets the registry cache.
 | GetStatistics | Gets the statistics.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetUserProfileCache | Gets the user profile cache.
 | GetViewStateCache | Gets the view state cache.
 | GetXslCache | Gets the XSL cache.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CacheManager Class
Sitecore.Caching Namespace


ClearAccessResultCache Method

[image]

Sitecore 6.4.1 API
CacheManager..::..ClearAccessResultCache Method
CacheManager Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void ClearAccessResultCache()
Visual Basic
Public Shared Sub ClearAccessResultCache
Visual C++
public:
static void ClearAccessResultCache()

Return Value

See Also

CacheManager Class
Sitecore.Caching Namespace


ClearAll Method

[image]

Sitecore 6.4.1 API
CacheManager..::..ClearAll Method
CacheManager Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use Sitecore.Caching.CacheManager.ClearAllCaches instead.")]
public void ClearAll()
Visual Basic
<ObsoleteAttribute("Use Sitecore.Caching.CacheManager.ClearAllCaches instead.")> _
Public Sub ClearAll
Visual C++
[ObsoleteAttribute(L"Use Sitecore.Caching.CacheManager.ClearAllCaches instead.")]
public:
void ClearAll()

See Also

CacheManager Class
Sitecore.Caching Namespace


ClearAllCaches Method

[image]

Sitecore 6.4.1 API
CacheManager..::..ClearAllCaches Method
CacheManager Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void ClearAllCaches()
Visual Basic
Public Shared Sub ClearAllCaches
Visual C++
public:
static void ClearAllCaches()

See Also

CacheManager Class
Sitecore.Caching Namespace


ClearIsInRoleCache Method

[image]

Sitecore 6.4.1 API
CacheManager..::..ClearIsInRoleCache Method
CacheManager Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void ClearIsInRoleCache(
    string userName
)
Visual Basic
Public Shared Sub ClearIsInRoleCache ( _
    userName As String _
)
Visual C++
public:
static void ClearIsInRoleCache(
    String^ userName
)

Parameters

userName
Type: System..::..String

[Missing <param name="userName"/> documentation for "M:Sitecore.Caching.CacheManager.ClearIsInRoleCache(System.String)"]

See Also

CacheManager Class
Sitecore.Caching Namespace


ClearSecurityCache Method

[image]

Sitecore 6.4.1 API
CacheManager..::..ClearSecurityCache Method
CacheManager Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void ClearSecurityCache(
    string userName
)
Visual Basic
Public Shared Sub ClearSecurityCache ( _
    userName As String _
)
Visual C++
public:
static void ClearSecurityCache(
    String^ userName
)

Parameters

userName
Type: System..::..String

[Missing <param name="userName"/> documentation for "M:Sitecore.Caching.CacheManager.ClearSecurityCache(System.String)"]

See Also

CacheManager Class
Sitecore.Caching Namespace


ClearUserProfileCache Method

[image]

Sitecore 6.4.1 API
CacheManager..::..ClearUserProfileCache Method
CacheManager Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void ClearUserProfileCache(
    string userName
)
Visual Basic
Public Shared Sub ClearUserProfileCache ( _
    userName As String _
)
Visual C++
public:
static void ClearUserProfileCache(
    String^ userName
)

Parameters

userName
Type: System..::..String

[Missing <param name="userName"/> documentation for "M:Sitecore.Caching.CacheManager.ClearUserProfileCache(System.String)"]

See Also

CacheManager Class
Sitecore.Caching Namespace


FindCacheByName Method

[image]

Sitecore 6.4.1 API
CacheManager..::..FindCacheByName Method
CacheManager Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Cache FindCacheByName(
    string name
)
Visual Basic
Public Shared Function FindCacheByName ( _
    name As String _
) As Cache
Visual C++
public:
static Cache^ FindCacheByName(
    String^ name
)

Parameters

name
Type: System..::..String
The name of the cache

Return Value

The cache

See Also

CacheManager Class
Sitecore.Caching Namespace


GetAccessResultCache Method

[image]

Sitecore 6.4.1 API
CacheManager..::..GetAccessResultCache Method
CacheManager Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static AccessResultCache GetAccessResultCache()
Visual Basic
Public Shared Function GetAccessResultCache As AccessResultCache
Visual C++
public:
static AccessResultCache^ GetAccessResultCache()

Return Value

[Missing <returns> documentation for "M:Sitecore.Caching.CacheManager.GetAccessResultCache"]

See Also

CacheManager Class
Sitecore.Caching Namespace


GetAllCaches Method

[image]

Sitecore 6.4.1 API
CacheManager..::..GetAllCaches Method
CacheManager Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Cache[] GetAllCaches()
Visual Basic
Public Shared Function GetAllCaches As Cache()
Visual C++
public:
static array<Cache^>^ GetAllCaches()

Return Value

The all caches.

See Also

CacheManager Class
Sitecore.Caching Namespace


GetDataCache Method

[image]

Sitecore 6.4.1 API
CacheManager..::..GetDataCache Method
CacheManager Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static DataCache GetDataCache(
    Database database
)
Visual Basic
Public Shared Function GetDataCache ( _
    database As Database _
) As DataCache
Visual C++
public:
static DataCache^ GetDataCache(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

Return Value

The data cache.

See Also

CacheManager Class
Sitecore.Caching Namespace


GetFilteredItemsCache Method

[image]

Sitecore 6.4.1 API
CacheManager..::..GetFilteredItemsCache Method
CacheManager Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static FilteredItemsCache GetFilteredItemsCache(
    SiteContext site
)
Visual Basic
Public Shared Function GetFilteredItemsCache ( _
    site As SiteContext _
) As FilteredItemsCache
Visual C++
public:
static FilteredItemsCache^ GetFilteredItemsCache(
    SiteContext^ site
)

Parameters

site
Type: Sitecore.Sites..::..SiteContext
The site.

Return Value

[Missing <returns> documentation for "M:Sitecore.Caching.CacheManager.GetFilteredItemsCache(Sitecore.Sites.SiteContext)"]

See Also

CacheManager Class
Sitecore.Caching Namespace


GetHtmlCache Method

[image]

Sitecore 6.4.1 API
CacheManager..::..GetHtmlCache Method
CacheManager Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static HtmlCache GetHtmlCache(
    SiteContext site
)
Visual Basic
Public Shared Function GetHtmlCache ( _
    site As SiteContext _
) As HtmlCache
Visual C++
public:
static HtmlCache^ GetHtmlCache(
    SiteContext^ site
)

Parameters

site
Type: Sitecore.Sites..::..SiteContext
The site.

Return Value

The HTML cache.

See Also

CacheManager Class
Sitecore.Caching Namespace


GetIsInRoleCache Method

[image]

Sitecore 6.4.1 API
CacheManager..::..GetIsInRoleCache Method
CacheManager Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static IsUserInRoleCache GetIsInRoleCache()
Visual Basic
Public Shared Function GetIsInRoleCache As IsUserInRoleCache
Visual C++
public:
static IsUserInRoleCache^ GetIsInRoleCache()

Return Value

The is in role cache.

See Also

CacheManager Class
Sitecore.Caching Namespace


GetItemCache Method

[image]

Sitecore 6.4.1 API
CacheManager..::..GetItemCache Method
CacheManager Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ItemCache GetItemCache(
    Database database
)
Visual Basic
Public Shared Function GetItemCache ( _
    database As Database _
) As ItemCache
Visual C++
public:
static ItemCache^ GetItemCache(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Caching.CacheManager.GetItemCache(Sitecore.Data.Database)"]

See Also

CacheManager Class
Sitecore.Caching Namespace


GetPathCache Method

[image]

Sitecore 6.4.1 API
CacheManager..::..GetPathCache Method
CacheManager Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PathCache GetPathCache(
    Database database
)
Visual Basic
Public Shared Function GetPathCache ( _
    database As Database _
) As PathCache
Visual C++
public:
static PathCache^ GetPathCache(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

Return Value

The path cache.

See Also

CacheManager Class
Sitecore.Caching Namespace


GetRegistryCache Method

[image]

Sitecore 6.4.1 API
CacheManager..::..GetRegistryCache Method
CacheManager Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static RegistryCache GetRegistryCache(
    SiteContext site
)
Visual Basic
Public Shared Function GetRegistryCache ( _
    site As SiteContext _
) As RegistryCache
Visual C++
public:
static RegistryCache^ GetRegistryCache(
    SiteContext^ site
)

Parameters

site
Type: Sitecore.Sites..::..SiteContext
The site.

Return Value

The registry cache.

See Also

CacheManager Class
Sitecore.Caching Namespace


GetStatistics Method

[image]

Sitecore 6.4.1 API
CacheManager..::..GetStatistics Method
CacheManager Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static CacheStatistics GetStatistics()
Visual Basic
Public Shared Function GetStatistics As CacheStatistics
Visual C++
public:
static CacheStatistics^ GetStatistics()

Return Value

The statistics.

See Also

CacheManager Class
Sitecore.Caching Namespace


GetUserProfileCache Method

[image]

Sitecore 6.4.1 API
CacheManager..::..GetUserProfileCache Method
CacheManager Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static UserProfileCache GetUserProfileCache()
Visual Basic
Public Shared Function GetUserProfileCache As UserProfileCache
Visual C++
public:
static UserProfileCache^ GetUserProfileCache()

Return Value

The user profile cache.

See Also

CacheManager Class
Sitecore.Caching Namespace


GetViewStateCache Method

[image]

Sitecore 6.4.1 API
CacheManager..::..GetViewStateCache Method
CacheManager Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ViewStateCache GetViewStateCache(
    SiteContext site
)
Visual Basic
Public Shared Function GetViewStateCache ( _
    site As SiteContext _
) As ViewStateCache
Visual C++
public:
static ViewStateCache^ GetViewStateCache(
    SiteContext^ site
)

Parameters

site
Type: Sitecore.Sites..::..SiteContext
The site.

Return Value

The view state cache.

See Also

CacheManager Class
Sitecore.Caching Namespace


GetXslCache Method

[image]

Sitecore 6.4.1 API
CacheManager..::..GetXslCache Method
CacheManager Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static XslCache GetXslCache(
    SiteContext site
)
Visual Basic
Public Shared Function GetXslCache ( _
    site As SiteContext _
) As XslCache
Visual C++
public:
static XslCache^ GetXslCache(
    SiteContext^ site
)

Parameters

site
Type: Sitecore.Sites..::..SiteContext
The site.

Return Value

The XSL cache.

See Also

CacheManager Class
Sitecore.Caching Namespace


CacheManager Properties

[image] [image]

Sitecore 6.4.1 API
CacheManager Properties
CacheManager Class See Also Send Feedback

The CacheManager type exposes the following members.

Properties

Name | Description
Enabled | Gets or sets a value indicating whether this CacheManager is enabled.
LoadFactor | Gets or sets the load factor.

See Also

CacheManager Class
Sitecore.Caching Namespace


Enabled Property

[image]

Sitecore 6.4.1 API
CacheManager..::..Enabled Property
CacheManager Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool Enabled { get; set; }
Visual Basic
Public Shared Property Enabled As Boolean
    Get
    Set
Visual C++
public:
static property bool Enabled {
    bool get ();
    void set (bool value);
}

Field Value

true if enabled; otherwise, false.

See Also

CacheManager Class
Sitecore.Caching Namespace


LoadFactor Property

[image]

Sitecore 6.4.1 API
CacheManager..::..LoadFactor Property
CacheManager Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static double LoadFactor { get; set; }
Visual Basic
Public Shared Property LoadFactor As Double
    Get
    Set
Visual C++
public:
static property double LoadFactor {
    double get ();
    void set (double value);
}

Field Value

The load factor.

See Also

CacheManager Class
Sitecore.Caching Namespace


CachePriority Enumeration

[image]

Sitecore 6.4.1 API
CachePriority Enumeration
See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum CachePriority
Visual Basic
Public Enumeration CachePriority
Visual C++
public enum class CachePriority

Members

Member name | Value | Description
Lowest | 0 | Lowest.
Low | 1 | Low.
BelowNormal | 2 | Below normal.
Normal | 3 | Normal.
AboveNormal | 4 | Above normal.
High | 5 | High.
Highest | 6 | Highest.
NeverRemove | 7 | Never remove.

See Also

Sitecore.Caching Namespace


CacheStatistics Class

[image]

Sitecore 6.4.1 API
CacheStatistics Class
Members See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CacheStatistics
Visual Basic
Public Class CacheStatistics
Visual C++
public ref class CacheStatistics

Inheritance Hierarchy

System..::..Object
Sitecore.Caching..::..CacheStatistics

See Also

CacheStatistics Members
Sitecore.Caching Namespace


CacheStatistics Constructor

[image]

Sitecore 6.4.1 API
CacheStatistics Constructor
CacheStatistics Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CacheStatistics(
    long totalCount,
    long totalSize
)
Visual Basic
Public Sub New ( _
    totalCount As Long, _
    totalSize As Long _
)
Visual C++
public:
CacheStatistics(
    long long totalCount,
    long long totalSize
)

Parameters

totalCount
Type: System..::..Int64
The total count.
totalSize
Type: System..::..Int64
The total size.

See Also

CacheStatistics Class
Sitecore.Caching Namespace


CacheStatistics Methods

[image] [image]

Sitecore 6.4.1 API
CacheStatistics Methods
CacheStatistics Class See Also Send Feedback

The CacheStatistics type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CacheStatistics Class
Sitecore.Caching Namespace


CacheStatistics Properties

[image] [image]

Sitecore 6.4.1 API
CacheStatistics Properties
CacheStatistics Class See Also Send Feedback

The CacheStatistics type exposes the following members.

Properties

 | Name | Description
Public property | TotalCount | Gets the total count.
Public property | TotalSize | Gets the total size.

See Also

CacheStatistics Class
Sitecore.Caching Namespace


TotalCount Property

[image]

Sitecore 6.4.1 API
CacheStatistics..::..TotalCount Property
CacheStatistics Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long TotalCount { get; }
Visual Basic
Public ReadOnly Property TotalCount As Long
    Get
Visual C++
public:
property long long TotalCount {
    long long get ();
}

Field Value

The total count.

See Also

CacheStatistics Class
Sitecore.Caching Namespace


CustomCache Class

[image]

Sitecore 6.4.1 API
CustomCache Class
Members See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class CustomCache
Visual Basic
Public MustInherit Class CustomCache
Visual C++
public ref class CustomCache abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Caching..::..CustomCache
Sitecore.Caching..::..AccessResultCache
Sitecore.Caching..::..DataCache
Sitecore.Caching..::..FilteredItemsCache
Sitecore.Caching..::..HtmlCache
Sitecore.Caching.IsUserInRole..::..IsUserInRoleCache
Sitecore.Caching..::..PathCache
Sitecore.Caching..::..RegistryCache
Sitecore.Caching..::..RuleCache
Sitecore.Caching..::..StandardValuesCache
Sitecore.Caching.UserProfile..::..UserProfileCache
Sitecore.Caching..::..ViewStateCache
Sitecore.Caching..::..XslCache

See Also

CustomCache Members
Sitecore.Caching Namespace


CustomCache Members

[image] [image]

Sitecore 6.4.1 API
CustomCache Members
CustomCache Class Constructors Methods Properties See Also Send Feedback

The CustomCache type exposes the following members.

Constructors

 | Name | Description
Protected method | CustomCache | Initializes a new instance of the CustomCache class.

Methods

 | Name | Description
Public method | Clear | Clears this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetID | Gets the ID.
Protected method | GetObject | Gets the object.
Protected method | GetString | Gets the string.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Remove | Removes the specified key.
Public method | RemoveKeysContaining | Removes the keys containing.
Public method | RemovePrefix | Removes entries with keys starting with the specified prefix.
Protected method | SetID | Sets the ID.
Protected method | SetObject(String, ICacheable) | Sets the object.
Protected method | SetObject(ID, ICacheable) | Sets the object.
Protected method | SetObject(Object, Object, Int64) | Sets the object.
Protected method | SetObject(String, Object, Int64) | Sets the object.
Protected method | SetObject(ID, Object, Int64) | Sets the object.
Protected method | SetObject(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Sets the object.
Protected method | SetString(String, String) | Sets the string.
Protected method | SetString(String, String, DateTime) | Sets the string.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether this CustomCache is enabled.
Public property | InnerCache | Gets the inner cache.
Public property | Name | Gets the name.

See Also

CustomCache Class
Sitecore.Caching Namespace


CustomCache Constructor

[image]

Sitecore 6.4.1 API
CustomCache Constructor
CustomCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected CustomCache(
    string name,
    long maxSize
)
Visual Basic
Protected Sub New ( _
    name As String, _
    maxSize As Long _
)
Visual C++
protected:
CustomCache(
    String^ name,
    long long maxSize
)

Parameters

name
Type: System..::..String
The name.
maxSize
Type: System..::..Int64
Size of the max.

See Also

CustomCache Class
Sitecore.Caching Namespace


Clear Method

[image]

Sitecore 6.4.1 API
CustomCache..::..Clear Method
CustomCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CustomCache Class
Sitecore.Caching Namespace


GetID Method

[image]

Sitecore 6.4.1 API
CustomCache..::..GetID Method
CustomCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected ID GetID(
    string key
)
Visual Basic
Protected Function GetID ( _
    key As String _
) As ID
Visual C++
protected:
ID^ GetID(
    String^ key
)

Parameters

key
Type: System..::..String
The key.

Return Value

[Missing <returns> documentation for "M:Sitecore.Caching.CustomCache.GetID(System.String)"]

See Also

CustomCache Class
Sitecore.Caching Namespace


GetObject Method

[image]

Sitecore 6.4.1 API
CustomCache..::..GetObject Method
CustomCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Object GetObject(
    Object key
)
Visual Basic
Protected Function GetObject ( _
    key As Object _
) As Object
Visual C++
protected:
Object^ GetObject(
    Object^ key
)

Parameters

key
Type: System..::..Object
The key.

Return Value

[Missing <returns> documentation for "M:Sitecore.Caching.CustomCache.GetObject(System.Object)"]

See Also

CustomCache Class
Sitecore.Caching Namespace


GetString Method

[image]

Sitecore 6.4.1 API
CustomCache..::..GetString Method
CustomCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected string GetString(
    string key
)
Visual Basic
Protected Function GetString ( _
    key As String _
) As String
Visual C++
protected:
String^ GetString(
    String^ key
)

Parameters

key
Type: System..::..String
The key.

Return Value

[Missing <returns> documentation for "M:Sitecore.Caching.CustomCache.GetString(System.String)"]

See Also

CustomCache Class
Sitecore.Caching Namespace


Remove Method

[image]

Sitecore 6.4.1 API
CustomCache..::..Remove Method
CustomCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void Remove(
    Object key
)
Visual Basic
Protected Sub Remove ( _
    key As Object _
)
Visual C++
protected:
void Remove(
    Object^ key
)

Parameters

key
Type: System..::..Object
The key.

See Also

CustomCache Class
Sitecore.Caching Namespace


RemoveKeysContaining Method

[image]

Sitecore 6.4.1 API
CustomCache..::..RemoveKeysContaining Method
CustomCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void RemoveKeysContaining(
    string value
)
Visual Basic
Public Overridable Sub RemoveKeysContaining ( _
    value As String _
)
Visual C++
public:
virtual void RemoveKeysContaining(
    String^ value
)

Parameters

value
Type: System..::..String
The value.

See Also

CustomCache Class
Sitecore.Caching Namespace


RemovePrefix Method

[image]

Sitecore 6.4.1 API
CustomCache..::..RemovePrefix Method
CustomCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void RemovePrefix(
    string prefix
)
Visual Basic
Public Overridable Sub RemovePrefix ( _
    prefix As String _
)
Visual C++
public:
virtual void RemovePrefix(
    String^ prefix
)

Parameters

prefix
Type: System..::..String
The prefix.

See Also

CustomCache Class
Sitecore.Caching Namespace


SetID Method

[image]

Sitecore 6.4.1 API
CustomCache..::..SetID Method
CustomCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void SetID(
    string key,
    ID value
)
Visual Basic
Protected Sub SetID ( _
    key As String, _
    value As ID _
)
Visual C++
protected:
void SetID(
    String^ key,
    ID^ value
)

Parameters

key
Type: System..::..String
The key.
value
Type: Sitecore.Data..::..ID
The value.

See Also

CustomCache Class
Sitecore.Caching Namespace


SetObject Method

[image] [image]

Sitecore 6.4.1 API
CustomCache..::..SetObject Method
CustomCache Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SetObject(String, ICacheable) | Sets the object.
Protected method | SetObject(ID, ICacheable) | Sets the object.
Protected method | SetObject(Object, Object, Int64) | Sets the object.
Protected method | SetObject(String, Object, Int64) | Sets the object.
Protected method | SetObject(ID, Object, Int64) | Sets the object.
Protected method | SetObject(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Sets the object.

See Also

CustomCache Class
CustomCache Members
Sitecore.Caching Namespace


SetObject Method (String, ICacheable)

[image]

Sitecore 6.4.1 API
CustomCache..::..SetObject Method (String, ICacheable)
CustomCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void SetObject(
    string key,
    ICacheable value
)
Visual Basic
Protected Sub SetObject ( _
    key As String, _
    value As ICacheable _
)
Visual C++
protected:
void SetObject(
    String^ key,
    ICacheable^ value
)

Parameters

key
Type: System..::..String
The key.
value
Type: Sitecore.Caching..::..ICacheable
The value.

See Also

CustomCache Class
SetObject Overload
Sitecore.Caching Namespace


SetObject Method (ID, ICacheable)

[image]

Sitecore 6.4.1 API
CustomCache..::..SetObject Method (ID, ICacheable)
CustomCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void SetObject(
    ID key,
    ICacheable value
)
Visual Basic
Protected Sub SetObject ( _
    key As ID, _
    value As ICacheable _
)
Visual C++
protected:
void SetObject(
    ID^ key,
    ICacheable^ value
)

Parameters

key
Type: Sitecore.Data..::..ID
The key.
value
Type: Sitecore.Caching..::..ICacheable
The value.

See Also

CustomCache Class
SetObject Overload
Sitecore.Caching Namespace


SetObject Method (Object, Object, Int64)

[image]

Sitecore 6.4.1 API
CustomCache..::..SetObject Method (Object, Object, Int64)
CustomCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void SetObject(
    Object key,
    Object value,
    long size
)
Visual Basic
Protected Sub SetObject ( _
    key As Object, _
    value As Object, _
    size As Long _
)
Visual C++
protected:
void SetObject(
    Object^ key,
    Object^ value,
    long long size
)

Parameters

key
Type: System..::..Object
The key.
value
Type: System..::..Object
The value.
size
Type: System..::..Int64
The size.

See Also

CustomCache Class
SetObject Overload
Sitecore.Caching Namespace


SetObject Method (String, Object, Int64)

[image]

Sitecore 6.4.1 API
CustomCache..::..SetObject Method (String, Object, Int64)
CustomCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void SetObject(
    string key,
    Object value,
    long size
)
Visual Basic
Protected Sub SetObject ( _
    key As String, _
    value As Object, _
    size As Long _
)
Visual C++
protected:
void SetObject(
    String^ key,
    Object^ value,
    long long size
)

Parameters

key
Type: System..::..String
The key.
value
Type: System..::..Object
The value.
size
Type: System..::..Int64
The size.

See Also

CustomCache Class
SetObject Overload
Sitecore.Caching Namespace


SetObject Method (ID, Object, Int64)

[image]

Sitecore 6.4.1 API
CustomCache..::..SetObject Method (ID, Object, Int64)
CustomCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void SetObject(
    ID key,
    Object value,
    long size
)
Visual Basic
Protected Sub SetObject ( _
    key As ID, _
    value As Object, _
    size As Long _
)
Visual C++
protected:
void SetObject(
    ID^ key,
    Object^ value,
    long long size
)

Parameters

key
Type: Sitecore.Data..::..ID
The key.
value
Type: System..::..Object
The value.
size
Type: System..::..Int64
The size.

See Also

CustomCache Class
SetObject Overload
Sitecore.Caching Namespace


SetObject Method (String, Object, Int64, EventHandler(EntryRemovedEventArgs))

[image]

Sitecore 6.4.1 API
CustomCache..::..SetObject Method (String, Object, Int64, EventHandler<(Of <(<'EntryRemovedEventArgs>)>)>)
CustomCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void SetObject(
    string key,
    Object value,
    long size,
    EventHandler<EntryRemovedEventArgs> removedHandler
)
Visual Basic
Protected Sub SetObject ( _
    key As String, _
    value As Object, _
    size As Long, _
    removedHandler As EventHandler(Of EntryRemovedEventArgs) _
)
Visual C++
protected:
void SetObject(
    String^ key,
    Object^ value,
    long long size,
    EventHandler<EntryRemovedEventArgs^>^ removedHandler
)

Parameters

key
Type: System..::..String
The key.
value
Type: System..::..Object
The value.
size
Type: System..::..Int64
The size.
removedHandler
Type: System..::..EventHandler <(Of <(<' EntryRemovedEventArgs >)>)>
The removed handler.

See Also

CustomCache Class
SetObject Overload
Sitecore.Caching Namespace


SetString Method

[image] [image]

Sitecore 6.4.1 API
CustomCache..::..SetString Method
CustomCache Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SetString(String, String) | Sets the string.
Protected method | SetString(String, String, DateTime) | Sets the string.

See Also

CustomCache Class
CustomCache Members
Sitecore.Caching Namespace


SetString Method (String, String)

[image]

Sitecore 6.4.1 API
CustomCache..::..SetString Method (String, String)
CustomCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void SetString(
    string key,
    string value
)
Visual Basic
Protected Sub SetString ( _
    key As String, _
    value As String _
)
Visual C++
protected:
void SetString(
    String^ key,
    String^ value
)

Parameters

key
Type: System..::..String
The key.
value
Type: System..::..String
The value.

See Also

CustomCache Class
SetString Overload
Sitecore.Caching Namespace


SetString Method (String, String, DateTime)

[image]

Sitecore 6.4.1 API
CustomCache..::..SetString Method (String, String, DateTime)
CustomCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void SetString(
    string key,
    string value,
    DateTime expiry
)
Visual Basic
Protected Sub SetString ( _
    key As String, _
    value As String, _
    expiry As DateTime _
)
Visual C++
protected:
void SetString(
    String^ key,
    String^ value,
    DateTime expiry
)

Parameters

key
Type: System..::..String
The key.
value
Type: System..::..String
The value.
expiry
Type: System..::..DateTime
The expiry.

See Also

CustomCache Class
SetString Overload
Sitecore.Caching Namespace


CustomCache Properties

[image] [image]

Sitecore 6.4.1 API
CustomCache Properties
CustomCache Class See Also Send Feedback

The CustomCache type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether this CustomCache is enabled.
Public property | InnerCache | Gets the inner cache.
Public property | Name | Gets the name.

See Also

CustomCache Class
Sitecore.Caching Namespace


Enabled Property

[image]

Sitecore 6.4.1 API
CustomCache..::..Enabled Property
CustomCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool Enabled { get; set; }
Visual Basic
Public Overridable Property Enabled As Boolean
    Get
    Set
Visual C++
public:
virtual property bool Enabled {
    bool get ();
    void set (bool value);
}

Field Value

true if enabled; otherwise, false.

See Also

CustomCache Class
Sitecore.Caching Namespace


InnerCache Property

[image]

Sitecore 6.4.1 API
CustomCache..::..InnerCache Property
CustomCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Cache InnerCache { get; }
Visual Basic
Public ReadOnly Property InnerCache As Cache
    Get
Visual C++
public:
property Cache^ InnerCache {
    Cache^ get ();
}

Field Value

The inner cache.

See Also

CustomCache Class
Sitecore.Caching Namespace


Name Property

[image]

Sitecore 6.4.1 API
CustomCache..::..Name Property
CustomCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string Name { get; }
Visual Basic
Public Overridable ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

CustomCache Class
Sitecore.Caching Namespace


DataCache Class

[image]

Sitecore 6.4.1 API
DataCache Class
Members See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DataCache : CustomCache
Visual Basic
Public Class DataCache _
    Inherits CustomCache
Visual C++
public ref class DataCache : public CustomCache

Inheritance Hierarchy

System..::..Object
Sitecore.Caching..::..CustomCache
Sitecore.Caching..::..DataCache

See Also

DataCache Members
Sitecore.Caching Namespace


DataCache Members

[image] [image]

Sitecore 6.4.1 API
DataCache Members
DataCache Class Constructors Methods Properties See Also Send Feedback

The DataCache type exposes the following members.

Constructors

 | Name | Description
Public method | DataCache | Initializes a new instance of the DataCache class.

Methods

 | Name | Description
Public method | AddItemInformation | Adds the item information.
Public method | Clear()()()() | Clears this instance. (Inherited from CustomCache.)
 | Clear(Database) | Clears the specified database.
Public method | ContainsNullItem | Determines whether [contains null item] [the specified item id].
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetID | Gets the ID. (Inherited from CustomCache.)
Public method | GetItemInformation | Gets the item information.
Protected method | GetObject | Gets the object. (Inherited from CustomCache.)
Protected method | GetString | Gets the string. (Inherited from CustomCache.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RegisterNullItem | Registers the null item.
Protected method | Remove | Removes the specified key. (Inherited from CustomCache.)
Public method | RemoveItemInformation | Removes the item information.
Public method | RemoveKeysContaining | Removes the keys containing. (Inherited from CustomCache.)
Public method | RemovePrefix | Removes entries with keys starting with the specified prefix. (Inherited from CustomCache.)
Protected method | SetID | Sets the ID. (Inherited from CustomCache.)
Protected method | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Sets the object. (Inherited from CustomCache.)
Protected method | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
Protected method | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UnregisterNullItem | Unregisters the null item.

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether this CustomCache is enabled. (Overrides CustomCache..::..Enabled.)
Public property | InnerCache | Gets the inner cache. (Inherited from CustomCache.)
Public property | Name | Gets the name. (Inherited from CustomCache.)

See Also

DataCache Class
Sitecore.Caching Namespace


DataCache Constructor

[image]

Sitecore 6.4.1 API
DataCache Constructor
DataCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataCache(
    Database database,
    long maxSize
)
Visual Basic
Public Sub New ( _
    database As Database, _
    maxSize As Long _
)
Visual C++
public:
DataCache(
    Database^ database,
    long long maxSize
)

Parameters

database
Type: Sitecore.Data..::..Database
The database owning the cache.
maxSize
Type: System..::..Int64
The maximum size of the cache (in bytes).

See Also

DataCache Class
Sitecore.Caching Namespace


DataCache Methods

[image] [image]

Sitecore 6.4.1 API
DataCache Methods
DataCache Class See Also Send Feedback

The DataCache type exposes the following members.

Methods

 | Name | Description
Public method | AddItemInformation | Adds the item information.
Public method | Clear()()()() | Clears this instance. (Inherited from CustomCache.)
 | Clear(Database) | Clears the specified database.
Public method | ContainsNullItem | Determines whether [contains null item] [the specified item id].
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetID | Gets the ID. (Inherited from CustomCache.)
Public method | GetItemInformation | Gets the item information.
Protected method | GetObject | Gets the object. (Inherited from CustomCache.)
Protected method | GetString | Gets the string. (Inherited from CustomCache.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RegisterNullItem | Registers the null item.
Protected method | Remove | Removes the specified key. (Inherited from CustomCache.)
Public method | RemoveItemInformation | Removes the item information.
Public method | RemoveKeysContaining | Removes the keys containing. (Inherited from CustomCache.)
Public method | RemovePrefix | Removes entries with keys starting with the specified prefix. (Inherited from CustomCache.)
Protected method | SetID | Sets the ID. (Inherited from CustomCache.)
Protected method | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Sets the object. (Inherited from CustomCache.)
Protected method | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
Protected method | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UnregisterNullItem | Unregisters the null item.

See Also

DataCache Class
Sitecore.Caching Namespace


AddItemInformation Method

[image]

Sitecore 6.4.1 API
DataCache..::..AddItemInformation Method
DataCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddItemInformation(
    ID itemID,
    ItemInformation itemInformation
)
Visual Basic
Public Sub AddItemInformation ( _
    itemID As ID, _
    itemInformation As ItemInformation _
)
Visual C++
public:
void AddItemInformation(
    ID^ itemID,
    ItemInformation^ itemInformation
)

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.
itemInformation
Type: Sitecore.Data..::..ItemInformation
The item information.

See Also

DataCache Class
Sitecore.Caching Namespace


Clear Method

[image] [image]

Sitecore 6.4.1 API
DataCache..::..Clear Method
DataCache Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clear()()()() | Clears this instance. (Inherited from CustomCache.)
 | Clear(Database) | Clears the specified database.

See Also

DataCache Class
DataCache Members
Sitecore.Caching Namespace


Clear Method (Database)

[image]

Sitecore 6.4.1 API
DataCache..::..Clear Method (Database)
DataCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Clear(
    Database database
)
Visual Basic
Public Shared Sub Clear ( _
    database As Database _
)
Visual C++
public:
static void Clear(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

See Also

DataCache Class
Clear Overload
Sitecore.Caching Namespace


ContainsNullItem Method

[image]

Sitecore 6.4.1 API
DataCache..::..ContainsNullItem Method
DataCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ContainsNullItem(
    ID itemId
)
Visual Basic
Public Function ContainsNullItem ( _
    itemId As ID _
) As Boolean
Visual C++
public:
bool ContainsNullItem(
    ID^ itemId
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.

Return Value

true if [contains null item] [the specified item id]; otherwise, false.

See Also

DataCache Class
Sitecore.Caching Namespace


GetItemInformation Method

[image]

Sitecore 6.4.1 API
DataCache..::..GetItemInformation Method
DataCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemInformation GetItemInformation(
    ID itemID
)
Visual Basic
Public Function GetItemInformation ( _
    itemID As ID _
) As ItemInformation
Visual C++
public:
ItemInformation^ GetItemInformation(
    ID^ itemID
)

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.

Return Value

The item information.

See Also

DataCache Class
Sitecore.Caching Namespace


RegisterNullItem Method

[image]

Sitecore 6.4.1 API
DataCache..::..RegisterNullItem Method
DataCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RegisterNullItem(
    ID itemId
)
Visual Basic
Public Sub RegisterNullItem ( _
    itemId As ID _
)
Visual C++
public:
void RegisterNullItem(
    ID^ itemId
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.

See Also

DataCache Class
Sitecore.Caching Namespace


RemoveItemInformation Method

[image]

Sitecore 6.4.1 API
DataCache..::..RemoveItemInformation Method
DataCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RemoveItemInformation(
    ID itemID
)
Visual Basic
Public Sub RemoveItemInformation ( _
    itemID As ID _
)
Visual C++
public:
void RemoveItemInformation(
    ID^ itemID
)

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.

See Also

DataCache Class
Sitecore.Caching Namespace


SetObject Method

[image] [image]

Sitecore 6.4.1 API
DataCache..::..SetObject Method
DataCache Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Sets the object. (Inherited from CustomCache.)

See Also

DataCache Class
DataCache Members
Sitecore.Caching Namespace


SetString Method

[image] [image]

Sitecore 6.4.1 API
DataCache..::..SetString Method
DataCache Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
Protected method | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)

See Also

DataCache Class
DataCache Members
Sitecore.Caching Namespace


UnregisterNullItem Method

[image]

Sitecore 6.4.1 API
DataCache..::..UnregisterNullItem Method
DataCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void UnregisterNullItem(
    ID itemId
)
Visual Basic
Public Sub UnregisterNullItem ( _
    itemId As ID _
)
Visual C++
public:
void UnregisterNullItem(
    ID^ itemId
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.

See Also

DataCache Class
Sitecore.Caching Namespace


DataCache Properties

[image] [image]

Sitecore 6.4.1 API
DataCache Properties
DataCache Class See Also Send Feedback

The DataCache type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether this CustomCache is enabled. (Overrides CustomCache..::..Enabled.)
Public property | InnerCache | Gets the inner cache. (Inherited from CustomCache.)
Public property | Name | Gets the name. (Inherited from CustomCache.)

See Also

DataCache Class
Sitecore.Caching Namespace


Enabled Property

[image]

Sitecore 6.4.1 API
DataCache..::..Enabled Property
DataCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool Enabled { get; }
Visual Basic
Public Overrides ReadOnly Property Enabled As Boolean
    Get
Visual C++
public:
virtual property bool Enabled {
    bool get () override;
}

Field Value

true if enabled; otherwise, false.

See Also

DataCache Class
Sitecore.Caching Namespace


DataLengthChangedDelegate Delegate

[image]

Sitecore 6.4.1 API
DataLengthChangedDelegate Delegate
See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public delegate void DataLengthChangedDelegate(
    ICacheable obj
)
Visual Basic
Public Delegate Sub DataLengthChangedDelegate ( _
    obj As ICacheable _
)
Visual C++
public delegate void DataLengthChangedDelegate(
    ICacheable^ obj
)

Parameters

obj
Type: Sitecore.Caching..::..ICacheable

See Also

Sitecore.Caching Namespace


EntryRemovedEventArgs Class

[image]

Sitecore 6.4.1 API
EntryRemovedEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class EntryRemovedEventArgs : EventArgs
Visual Basic
Public Class EntryRemovedEventArgs _
    Inherits EventArgs
Visual C++
public ref class EntryRemovedEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Caching..::..EntryRemovedEventArgs

See Also

EntryRemovedEventArgs Members
Sitecore.Caching Namespace


EntryRemovedEventArgs Members

[image] [image]

Sitecore 6.4.1 API
EntryRemovedEventArgs Members
EntryRemovedEventArgs Class Constructors Methods Properties See Also Send Feedback

The EntryRemovedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | EntryRemovedEventArgs | Initializes a new instance of the EntryRemovedEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Entry | Gets the entry that triggered the evtn.

See Also

EntryRemovedEventArgs Class
Sitecore.Caching Namespace


EntryRemovedEventArgs Constructor

[image]

Sitecore 6.4.1 API
EntryRemovedEventArgs Constructor
EntryRemovedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public EntryRemovedEventArgs(
    Cache..::..CacheEntry entry
)
Visual Basic
Public Sub New ( _
    entry As Cache..::..CacheEntry _
)
Visual C++
public:
EntryRemovedEventArgs(
    Cache..::..CacheEntry^ entry
)

Parameters

entry
Type: Sitecore.Caching..::..Cache..::..CacheEntry

[Missing <param name="entry"/> documentation for "M:Sitecore.Caching.EntryRemovedEventArgs.#ctor(Sitecore.Caching.Cache.CacheEntry)"]

See Also

EntryRemovedEventArgs Class
Sitecore.Caching Namespace


EntryRemovedEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
EntryRemovedEventArgs Methods
EntryRemovedEventArgs Class See Also Send Feedback

The EntryRemovedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EntryRemovedEventArgs Class
Sitecore.Caching Namespace


EntryRemovedEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
EntryRemovedEventArgs Properties
EntryRemovedEventArgs Class See Also Send Feedback

The EntryRemovedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Entry | Gets the entry that triggered the evtn.

See Also

EntryRemovedEventArgs Class
Sitecore.Caching Namespace


Entry Property

[image]

Sitecore 6.4.1 API
EntryRemovedEventArgs..::..Entry Property
EntryRemovedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Cache..::..CacheEntry Entry { get; }
Visual Basic
Public ReadOnly Property Entry As Cache..::..CacheEntry
    Get
Visual C++
public:
property Cache..::..CacheEntry^ Entry {
    Cache..::..CacheEntry^ get ();
}

Field Value

The entry.

See Also

EntryRemovedEventArgs Class
Sitecore.Caching Namespace


FilteredItemsCache Class

[image]

Sitecore 6.4.1 API
FilteredItemsCache Class
Members See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FilteredItemsCache : CustomCache
Visual Basic
Public Class FilteredItemsCache _
    Inherits CustomCache
Visual C++
public ref class FilteredItemsCache : public CustomCache

Inheritance Hierarchy

System..::..Object
Sitecore.Caching..::..CustomCache
Sitecore.Caching..::..FilteredItemsCache

See Also

FilteredItemsCache Members
Sitecore.Caching Namespace


FilteredItemsCache Members

[image] [image]

Sitecore 6.4.1 API
FilteredItemsCache Members
FilteredItemsCache Class Constructors Methods Properties See Also Send Feedback

The FilteredItemsCache type exposes the following members.

Constructors

 | Name | Description
Public method | FilteredItemsCache | Initializes a new instance of the FilteredItemsCache class.

Methods

 | Name | Description
Public method | Clear | Clears this instance. (Inherited from CustomCache.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetID | Gets the ID. (Inherited from CustomCache.)
Protected method | GetObject | Gets the object. (Inherited from CustomCache.)
Protected method | GetString | Gets the string. (Inherited from CustomCache.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Remove | Removes the specified key. (Inherited from CustomCache.)
Public method | RemoveKeysContaining | Removes the keys containing. (Inherited from CustomCache.)
Public method | RemovePrefix | Removes entries with keys starting with the specified prefix. (Inherited from CustomCache.)
Protected method | SetID | Sets the ID. (Inherited from CustomCache.)
Protected method | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Sets the object. (Inherited from CustomCache.)
Protected method | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
Protected method | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether this CustomCache is enabled. (Inherited from CustomCache.)
Public property | InnerCache | Gets the inner cache. (Inherited from CustomCache.)
Public property | Name | Gets the name. (Inherited from CustomCache.)

See Also

FilteredItemsCache Class
Sitecore.Caching Namespace


FilteredItemsCache Constructor

[image]

Sitecore 6.4.1 API
FilteredItemsCache Constructor
FilteredItemsCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FilteredItemsCache(
    SiteInfo siteInfo,
    long maxSize
)
Visual Basic
Public Sub New ( _
    siteInfo As SiteInfo, _
    maxSize As Long _
)
Visual C++
public:
FilteredItemsCache(
    SiteInfo^ siteInfo,
    long long maxSize
)

Parameters

siteInfo
Type: Sitecore.Web..::..SiteInfo
The site info.
maxSize
Type: System..::..Int64
Size of the max.

See Also

FilteredItemsCache Class
Sitecore.Caching Namespace


FilteredItemsCache Methods

[image] [image]

Sitecore 6.4.1 API
FilteredItemsCache Methods
FilteredItemsCache Class See Also Send Feedback

The FilteredItemsCache type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Clears this instance. (Inherited from CustomCache.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetID | Gets the ID. (Inherited from CustomCache.)
Protected method | GetObject | Gets the object. (Inherited from CustomCache.)
Protected method | GetString | Gets the string. (Inherited from CustomCache.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Remove | Removes the specified key. (Inherited from CustomCache.)
Public method | RemoveKeysContaining | Removes the keys containing. (Inherited from CustomCache.)
Public method | RemovePrefix | Removes entries with keys starting with the specified prefix. (Inherited from CustomCache.)
Protected method | SetID | Sets the ID. (Inherited from CustomCache.)
Protected method | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Sets the object. (Inherited from CustomCache.)
Protected method | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
Protected method | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilteredItemsCache Class
Sitecore.Caching Namespace


SetObject Method

[image] [image]

Sitecore 6.4.1 API
FilteredItemsCache..::..SetObject Method
FilteredItemsCache Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Sets the object. (Inherited from CustomCache.)

See Also

FilteredItemsCache Class
FilteredItemsCache Members
Sitecore.Caching Namespace


SetString Method

[image] [image]

Sitecore 6.4.1 API
FilteredItemsCache..::..SetString Method
FilteredItemsCache Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
Protected method | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)

See Also

FilteredItemsCache Class
FilteredItemsCache Members
Sitecore.Caching Namespace


FilteredItemsCache Properties

[image] [image]

Sitecore 6.4.1 API
FilteredItemsCache Properties
FilteredItemsCache Class See Also Send Feedback

The FilteredItemsCache type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether this CustomCache is enabled. (Inherited from CustomCache.)
Public property | InnerCache | Gets the inner cache. (Inherited from CustomCache.)
Public property | Name | Gets the name. (Inherited from CustomCache.)

See Also

FilteredItemsCache Class
Sitecore.Caching Namespace


HtmlCache Class

[image]

Sitecore 6.4.1 API
HtmlCache Class
Members See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class HtmlCache : CustomCache
Visual Basic
Public Class HtmlCache _
    Inherits CustomCache
Visual C++
public ref class HtmlCache : public CustomCache

Inheritance Hierarchy

System..::..Object
Sitecore.Caching..::..CustomCache
Sitecore.Caching..::..HtmlCache

See Also

HtmlCache Members
Sitecore.Caching Namespace


HtmlCache Members

[image] [image]

Sitecore 6.4.1 API
HtmlCache Members
HtmlCache Class Constructors Methods Properties See Also Send Feedback

The HtmlCache type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlCache | Initializes a new instance of the HtmlCache class.

Methods

 | Name | Description
Public method | Clear()()()() | Clears this instance. (Overrides CustomCache..::..Clear()()()().)
Public method | Clear(Boolean) | Clears this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHtml | Gets the HTML.
Protected method | GetID | Gets the ID. (Inherited from CustomCache.)
Protected method | GetObject | Gets the object. (Inherited from CustomCache.)
Protected method | GetString | Gets the string. (Inherited from CustomCache.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Remove | Removes the specified key. (Inherited from CustomCache.)
Public method | RemoveKeysContaining | Removes the keys containing. (Inherited from CustomCache.)
Public method | RemovePrefix | Removes entries with keys starting with the specified prefix. (Inherited from CustomCache.)
Public method | SetHtml(String, String) | Sets the HTML.
Public method | SetHtml(String, String, DateTime) | Sets the HTML.
Public method | SetHtml(String, String, TimeSpan) | Sets the HTML.
Protected method | SetID | Sets the ID. (Inherited from CustomCache.)
Protected method | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Sets the object. (Inherited from CustomCache.)
Protected method | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
Protected method | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ClearLatency | Gets the clear latency.
Public property | Enabled | Gets or sets a value indicating whether this CustomCache is enabled. (Inherited from CustomCache.)
Public property | InnerCache | Gets the inner cache. (Inherited from CustomCache.)
Public property | Name | Gets the name. (Inherited from CustomCache.)

See Also

HtmlCache Class
Sitecore.Caching Namespace


HtmlCache Constructor

[image]

Sitecore 6.4.1 API
HtmlCache Constructor
HtmlCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HtmlCache(
    SiteInfo site,
    long maxSize
)
Visual Basic
Public Sub New ( _
    site As SiteInfo, _
    maxSize As Long _
)
Visual C++
public:
HtmlCache(
    SiteInfo^ site,
    long long maxSize
)

Parameters

site
Type: Sitecore.Web..::..SiteInfo
The site.
maxSize
Type: System..::..Int64
Size of the max.

See Also

HtmlCache Class
Sitecore.Caching Namespace


HtmlCache Methods

[image] [image]

Sitecore 6.4.1 API
HtmlCache Methods
HtmlCache Class See Also Send Feedback

The HtmlCache type exposes the following members.

Methods

 | Name | Description
Public method | Clear()()()() | Clears this instance. (Overrides CustomCache..::..Clear()()()().)
Public method | Clear(Boolean) | Clears this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHtml | Gets the HTML.
Protected method | GetID | Gets the ID. (Inherited from CustomCache.)
Protected method | GetObject | Gets the object. (Inherited from CustomCache.)
Protected method | GetString | Gets the string. (Inherited from CustomCache.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Remove | Removes the specified key. (Inherited from CustomCache.)
Public method | RemoveKeysContaining | Removes the keys containing. (Inherited from CustomCache.)
Public method | RemovePrefix | Removes entries with keys starting with the specified prefix. (Inherited from CustomCache.)
Public method | SetHtml(String, String) | Sets the HTML.
Public method | SetHtml(String, String, DateTime) | Sets the HTML.
Public method | SetHtml(String, String, TimeSpan) | Sets the HTML.
Protected method | SetID | Sets the ID. (Inherited from CustomCache.)
Protected method | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Sets the object. (Inherited from CustomCache.)
Protected method | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
Protected method | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HtmlCache Class
Sitecore.Caching Namespace


Clear Method

[image] [image]

Sitecore 6.4.1 API
HtmlCache..::..Clear Method
HtmlCache Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clear()()()() | Clears this instance. (Overrides CustomCache..::..Clear()()()().)
Public method | Clear(Boolean) | Clears this instance.

See Also

HtmlCache Class
HtmlCache Members
Sitecore.Caching Namespace


Clear Method

[image]

Sitecore 6.4.1 API
HtmlCache..::..Clear Method
HtmlCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Clear()
Visual Basic
Public Overrides Sub Clear
Visual C++
public:
virtual void Clear() override

See Also

HtmlCache Class
Clear Overload
Sitecore.Caching Namespace


Clear Method (Boolean)

[image]

Sitecore 6.4.1 API
HtmlCache..::..Clear Method (Boolean)
HtmlCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Clear(
    bool force
)
Visual Basic
Public Overridable Sub Clear ( _
    force As Boolean _
)
Visual C++
public:
virtual void Clear(
    bool force
)

Parameters

force
Type: System..::..Boolean
if set to true, the cache will be cleared immediately. Otherwise, the cache will be cleared according to the ClearLatency property.

See Also

HtmlCache Class
Clear Overload
Sitecore.Caching Namespace


GetHtml Method

[image]

Sitecore 6.4.1 API
HtmlCache..::..GetHtml Method
HtmlCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetHtml(
    string key
)
Visual Basic
Public Function GetHtml ( _
    key As String _
) As String
Visual C++
public:
String^ GetHtml(
    String^ key
)

Parameters

key
Type: System..::..String
The key.

Return Value

The HTML.

See Also

HtmlCache Class
Sitecore.Caching Namespace


SetHtml Method

[image] [image]

Sitecore 6.4.1 API
HtmlCache..::..SetHtml Method
HtmlCache Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetHtml(String, String) | Sets the HTML.
Public method | SetHtml(String, String, DateTime) | Sets the HTML.
Public method | SetHtml(String, String, TimeSpan) | Sets the HTML.

See Also

HtmlCache Class
HtmlCache Members
Sitecore.Caching Namespace


SetHtml Method (String, String)

[image]

Sitecore 6.4.1 API
HtmlCache..::..SetHtml Method (String, String)
HtmlCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetHtml(
    string key,
    string html
)
Visual Basic
Public Sub SetHtml ( _
    key As String, _
    html As String _
)
Visual C++
public:
void SetHtml(
    String^ key,
    String^ html
)

Parameters

key
Type: System..::..String
The key.
html
Type: System..::..String
The HTML.

See Also

HtmlCache Class
SetHtml Overload
Sitecore.Caching Namespace


SetHtml Method (String, String, DateTime)

[image]

Sitecore 6.4.1 API
HtmlCache..::..SetHtml Method (String, String, DateTime)
HtmlCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetHtml(
    string key,
    string html,
    DateTime expiryUtcDate
)
Visual Basic
Public Sub SetHtml ( _
    key As String, _
    html As String, _
    expiryUtcDate As DateTime _
)
Visual C++
public:
void SetHtml(
    String^ key,
    String^ html,
    DateTime expiryUtcDate
)

Parameters

key
Type: System..::..String
The key.
html
Type: System..::..String
The HTML.
expiryUtcDate
Type: System..::..DateTime
The UTC date at which the cache entry will expire.

See Also

HtmlCache Class
SetHtml Overload
Sitecore.Caching Namespace


SetHtml Method (String, String, TimeSpan)

[image]

Sitecore 6.4.1 API
HtmlCache..::..SetHtml Method (String, String, TimeSpan)
HtmlCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetHtml(
    string key,
    string html,
    TimeSpan timeout
)
Visual Basic
Public Sub SetHtml ( _
    key As String, _
    html As String, _
    timeout As TimeSpan _
)
Visual C++
public:
void SetHtml(
    String^ key,
    String^ html,
    TimeSpan timeout
)

Parameters

key
Type: System..::..String
The key.
html
Type: System..::..String
The HTML.
timeout
Type: System..::..TimeSpan
The timeout.

See Also

HtmlCache Class
SetHtml Overload
Sitecore.Caching Namespace


SetObject Method

[image] [image]

Sitecore 6.4.1 API
HtmlCache..::..SetObject Method
HtmlCache Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Sets the object. (Inherited from CustomCache.)

See Also

HtmlCache Class
HtmlCache Members
Sitecore.Caching Namespace


SetString Method

[image] [image]

Sitecore 6.4.1 API
HtmlCache..::..SetString Method
HtmlCache Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
Protected method | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)

See Also

HtmlCache Class
HtmlCache Members
Sitecore.Caching Namespace


HtmlCache Properties

[image] [image]

Sitecore 6.4.1 API
HtmlCache Properties
HtmlCache Class See Also Send Feedback

The HtmlCache type exposes the following members.

Properties

 | Name | Description
Public property | ClearLatency | Gets the clear latency.
Public property | Enabled | Gets or sets a value indicating whether this CustomCache is enabled. (Inherited from CustomCache.)
Public property | InnerCache | Gets the inner cache. (Inherited from CustomCache.)
Public property | Name | Gets the name. (Inherited from CustomCache.)

See Also

HtmlCache Class
Sitecore.Caching Namespace


ClearLatency Property

[image]

Sitecore 6.4.1 API
HtmlCache..::..ClearLatency Property
HtmlCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual TimeSpan ClearLatency { get; set; }
Visual Basic
Public Overridable Property ClearLatency As TimeSpan
    Get
    Set
Visual C++
public:
virtual property TimeSpan ClearLatency {
    TimeSpan get ();
    void set (TimeSpan value);
}

Field Value

The clear latency.

See Also

HtmlCache Class
Sitecore.Caching Namespace


ICacheable Interface

[image]

Sitecore 6.4.1 API
ICacheable Interface
Members See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface ICacheable
Visual Basic
Public Interface ICacheable
Visual C++
public interface class ICacheable

See Also

ICacheable Members
Sitecore.Caching Namespace


ICacheable Members

[image] [image]

Sitecore 6.4.1 API
ICacheable Members
ICacheable Interface Methods Properties Events See Also Send Feedback

The ICacheable type exposes the following members.

Methods

 | Name | Description
Public method | GetDataLength | Gets the size of the data to use when caching.

Properties

 | Name | Description
Public property | Cacheable | Gets or sets a value indicating whether this ICacheable is cacheable.
Public property | Immutable | Gets a value indicating whether this ICacheable is immutable.

Events

 | Name | Description
Public event | DataLengthChanged |

See Also

ICacheable Interface
Sitecore.Caching Namespace


GetDataLength Method

[image]

Sitecore 6.4.1 API
ICacheable..::..GetDataLength Method
ICacheable Interface See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
long GetDataLength()
Visual Basic
Function GetDataLength As Long
Visual C++
long long GetDataLength()

Return Value

[Missing <returns> documentation for "M:Sitecore.Caching.ICacheable.GetDataLength"]

See Also

ICacheable Interface
Sitecore.Caching Namespace


ICacheable Properties

[image] [image]

Sitecore 6.4.1 API
ICacheable Properties
ICacheable Interface See Also Send Feedback

The ICacheable type exposes the following members.

Properties

 | Name | Description
Public property | Cacheable | Gets or sets a value indicating whether this ICacheable is cacheable.
Public property | Immutable | Gets a value indicating whether this ICacheable is immutable.

See Also

ICacheable Interface
Sitecore.Caching Namespace


Cacheable Property

[image]

Sitecore 6.4.1 API
ICacheable..::..Cacheable Property
ICacheable Interface See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
bool Cacheable { get; set; }
Visual Basic
Property Cacheable As Boolean
    Get
    Set
Visual C++
property bool Cacheable {
    bool get ();
    void set (bool value);
}

Field Value

true if cacheable; otherwise, false.

See Also

ICacheable Interface
Sitecore.Caching Namespace


Immutable Property

[image]

Sitecore 6.4.1 API
ICacheable..::..Immutable Property
ICacheable Interface See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
bool Immutable { get; }
Visual Basic
ReadOnly Property Immutable As Boolean
    Get
Visual C++
property bool Immutable {
    bool get ();
}

Field Value

true if immutable; otherwise, false.

See Also

ICacheable Interface
Sitecore.Caching Namespace


ICacheable Events

[image] [image]

Sitecore 6.4.1 API
ICacheable Events
ICacheable Interface See Also Send Feedback

The ICacheable type exposes the following members.

Events

 | Name | Description
Public event | DataLengthChanged |

See Also

ICacheable Interface
Sitecore.Caching Namespace


DataLengthChanged Event

[image]

Sitecore 6.4.1 API
ICacheable..::..DataLengthChanged Event
ICacheable Interface See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
event DataLengthChangedDelegate DataLengthChanged
Visual Basic
Event DataLengthChanged As DataLengthChangedDelegate
Visual C++
 event DataLengthChangedDelegate^ DataLengthChanged {
    void add (DataLengthChangedDelegate^ value);
    void remove (DataLengthChangedDelegate^ value);
}

See Also

ICacheable Interface
Sitecore.Caching Namespace


ItemCache Class

[image]

Sitecore 6.4.1 API
ItemCache Class
Members See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemCache
Visual Basic
Public Class ItemCache
Visual C++
public ref class ItemCache

Inheritance Hierarchy

System..::..Object
Sitecore.Caching..::..ItemCache

See Also

ItemCache Members
Sitecore.Caching Namespace


ItemCache Members

[image] [image]

Sitecore 6.4.1 API
ItemCache Members
ItemCache Class Constructors Methods Properties See Also Send Feedback

The ItemCache type exposes the following members.

Constructors

 | Name | Description
Public method | ItemCache | Initializes a new instance of the DataCache class.

Methods

 | Name | Description
Public method | AddItem | Adds an item to the cache.
Public method | Clear | Clears the cache.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItem | Gets an item from the cache.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveItem | Removes all versions of an item.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether this ItemCache is enabled.

See Also

ItemCache Class
Sitecore.Caching Namespace


ItemCache Constructor

[image]

Sitecore 6.4.1 API
ItemCache Constructor
ItemCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemCache(
    Database database,
    long maxSize
)
Visual Basic
Public Sub New ( _
    database As Database, _
    maxSize As Long _
)
Visual C++
public:
ItemCache(
    Database^ database,
    long long maxSize
)

Parameters

database
Type: Sitecore.Data..::..Database
The database owning the cache.
maxSize
Type: System..::..Int64
The maximum size of the cache (in bytes).

See Also

ItemCache Class
Sitecore.Caching Namespace


ItemCache Methods

[image] [image]

Sitecore 6.4.1 API
ItemCache Methods
ItemCache Class See Also Send Feedback

The ItemCache type exposes the following members.

Methods

 | Name | Description
Public method | AddItem | Adds an item to the cache.
Public method | Clear | Clears the cache.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItem | Gets an item from the cache.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveItem | Removes all versions of an item.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemCache Class
Sitecore.Caching Namespace


AddItem Method

[image]

Sitecore 6.4.1 API
ItemCache..::..AddItem Method
ItemCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddItem(
    ID itemId,
    Language language,
    Version version,
    Item item
)
Visual Basic
Public Sub AddItem ( _
    itemId As ID, _
    language As Language, _
    version As Version, _
    item As Item _
)
Visual C++
public:
void AddItem(
    ID^ itemId,
    Language^ language,
    Version^ version,
    Item^ item
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
language
Type: Sitecore.Globalization..::..Language
The language.
version
Type: Sitecore.Data..::..Version
The version.
item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

ItemCache Class
Sitecore.Caching Namespace


Clear Method

[image]

Sitecore 6.4.1 API
ItemCache..::..Clear Method
ItemCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ItemCache Class
Sitecore.Caching Namespace


GetItem Method

[image]

Sitecore 6.4.1 API
ItemCache..::..GetItem Method
ItemCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetItem(
    ID itemId,
    Language language,
    Version version
)
Visual Basic
Public Function GetItem ( _
    itemId As ID, _
    language As Language, _
    version As Version _
) As Item
Visual C++
public:
Item^ GetItem(
    ID^ itemId,
    Language^ language,
    Version^ version
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
language
Type: Sitecore.Globalization..::..Language
The language.
version
Type: Sitecore.Data..::..Version
The version.

Return Value

[Missing <returns> documentation for "M:Sitecore.Caching.ItemCache.GetItem(Sitecore.Data.ID,Sitecore.Globalization.Language,Sitecore.Data.Version)"]

See Also

ItemCache Class
Sitecore.Caching Namespace


RemoveItem Method

[image]

Sitecore 6.4.1 API
ItemCache..::..RemoveItem Method
ItemCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void RemoveItem(
    ID itemId
)
Visual Basic
Public Overridable Sub RemoveItem ( _
    itemId As ID _
)
Visual C++
public:
virtual void RemoveItem(
    ID^ itemId
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.

See Also

ItemCache Class
Sitecore.Caching Namespace


ItemCache Properties

[image] [image]

Sitecore 6.4.1 API
ItemCache Properties
ItemCache Class See Also Send Feedback

The ItemCache type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether this ItemCache is enabled.

See Also

ItemCache Class
Sitecore.Caching Namespace


Enabled Property

[image]

Sitecore 6.4.1 API
ItemCache..::..Enabled Property
ItemCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool Enabled { get; set; }
Visual Basic
Public Overridable Property Enabled As Boolean
    Get
    Set
Visual C++
public:
virtual property bool Enabled {
    bool get ();
    void set (bool value);
}

Field Value

true if enabled; otherwise, false.

See Also

ItemCache Class
Sitecore.Caching Namespace


ItemRelation Class

[image]

Sitecore 6.4.1 API
ItemRelation Class
Members See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemRelation : ICacheable
Visual Basic
Public Class ItemRelation _
    Implements ICacheable
Visual C++
public ref class ItemRelation : ICacheable

Inheritance Hierarchy

System..::..Object
Sitecore.Caching..::..ItemRelation

See Also

ItemRelation Members
Sitecore.Caching Namespace


ItemRelation Members

[image] [image]

Sitecore 6.4.1 API
ItemRelation Members
ItemRelation Class Constructors Methods Properties See Also Send Feedback

The ItemRelation type exposes the following members.

Constructors

 | Name | Description
Public method | ItemRelation | Initializes a new instance of the ItemRelation class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ChildIDs | Gets the child I ds.
Public property | ParentID | Gets the parent ID.

See Also

ItemRelation Class
Sitecore.Caching Namespace


ItemRelation Methods

[image] [image]

Sitecore 6.4.1 API
ItemRelation Methods
ItemRelation Class See Also Send Feedback

The ItemRelation type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemRelation Class
Sitecore.Caching Namespace


ItemRelation Properties

[image] [image]

Sitecore 6.4.1 API
ItemRelation Properties
ItemRelation Class See Also Send Feedback

The ItemRelation type exposes the following members.

Properties

 | Name | Description
Public property | ChildIDs | Gets the child I ds.
Public property | ParentID | Gets the parent ID.

See Also

ItemRelation Class
Sitecore.Caching Namespace


ChildIDs Property

[image]

Sitecore 6.4.1 API
ItemRelation..::..ChildIDs Property
ItemRelation Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID[] ChildIDs { get; }
Visual Basic
Public ReadOnly Property ChildIDs As ID()
    Get
Visual C++
public:
property array<ID^>^ ChildIDs {
    array<ID^>^ get ();
}

Field Value

The child I ds.

See Also

ItemRelation Class
Sitecore.Caching Namespace


ParentID Property

[image]

Sitecore 6.4.1 API
ItemRelation..::..ParentID Property
ItemRelation Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ParentID { get; }
Visual Basic
Public ReadOnly Property ParentID As ID
    Get
Visual C++
public:
property ID^ ParentID {
    ID^ get ();
}

Field Value

The parent ID.

See Also

ItemRelation Class
Sitecore.Caching Namespace


ItemsContext Class

[image]

Sitecore 6.4.1 API
ItemsContext Class
Members See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemsContext
Visual Basic
Public Class ItemsContext
Visual C++
public ref class ItemsContext

Inheritance Hierarchy

System..::..Object
Sitecore.Caching..::..ItemsContext

See Also

ItemsContext Members
Sitecore.Caching Namespace


ItemsContext Members

[image] [image]

Sitecore 6.4.1 API
ItemsContext Members
ItemsContext Class Constructors Methods Properties See Also Send Feedback

The ItemsContext type exposes the following members.

Constructors

 | Name | Description
Public method | ItemsContext | Initializes a new instance of the ItemsContext class

Methods

 | Name | Description
Public method | Add | Adds the specified value to the dictionary.
Public method | Clear | Clears this instance.
Public method | Contains | Determines whether the dictionary contains the the specified key.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the specified key.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the count.
Public property | Item | Gets or sets the Object with the specified key.

See Also

ItemsContext Class
Sitecore.Caching Namespace


ItemsContext Constructor

[image]

Sitecore 6.4.1 API
ItemsContext Constructor
ItemsContext Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemsContext()
Visual Basic
Public Sub New
Visual C++
public:
ItemsContext()

See Also

ItemsContext Class
Sitecore.Caching Namespace


ItemsContext Methods

[image] [image]

Sitecore 6.4.1 API
ItemsContext Methods
ItemsContext Class See Also Send Feedback

The ItemsContext type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified value to the dictionary.
Public method | Clear | Clears this instance.
Public method | Contains | Determines whether the dictionary contains the the specified key.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the specified key.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemsContext Class
Sitecore.Caching Namespace


Add Method

[image]

Sitecore 6.4.1 API
ItemsContext..::..Add Method
ItemsContext Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Add(
    Object key,
    Object value
)
Visual Basic
Public Sub Add ( _
    key As Object, _
    value As Object _
)
Visual C++
public:
void Add(
    Object^ key,
    Object^ value
)

Parameters

key
Type: System..::..Object
The key.
value
Type: System..::..Object
The value.

See Also

ItemsContext Class
Sitecore.Caching Namespace


Clear Method

[image]

Sitecore 6.4.1 API
ItemsContext..::..Clear Method
ItemsContext Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

ItemsContext Class
Sitecore.Caching Namespace


Contains Method

[image]

Sitecore 6.4.1 API
ItemsContext..::..Contains Method
ItemsContext Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Contains(
    Object key
)
Visual Basic
Public Function Contains ( _
    key As Object _
) As Boolean
Visual C++
public:
bool Contains(
    Object^ key
)

Parameters

key
Type: System..::..Object
The key.

Return Value

true if the dictionary contains the the specified key; otherwise, false.

See Also

ItemsContext Class
Sitecore.Caching Namespace


Remove Method

[image]

Sitecore 6.4.1 API
ItemsContext..::..Remove Method
ItemsContext Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Remove(
    string key
)
Visual Basic
Public Sub Remove ( _
    key As String _
)
Visual C++
public:
void Remove(
    String^ key
)

Parameters

key
Type: System..::..String
The key.

See Also

ItemsContext Class
Sitecore.Caching Namespace


ItemsContext Properties

[image] [image]

Sitecore 6.4.1 API
ItemsContext Properties
ItemsContext Class See Also Send Feedback

The ItemsContext type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the count.
Public property | Item | Gets or sets the Object with the specified key.

See Also

ItemsContext Class
Sitecore.Caching Namespace


Count Property

[image]

Sitecore 6.4.1 API
ItemsContext..::..Count Property
ItemsContext Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
property int Count {
    int get ();
}

Field Value

The count.

See Also

ItemsContext Class
Sitecore.Caching Namespace


Item Property

[image]

Sitecore 6.4.1 API
ItemsContext..::..Item Property
ItemsContext Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object this[
    string key
] { get; set; }
Visual Basic
Public Default Property Item ( _
    key As String _
) As Object
    Get
    Set
Visual C++
public:
property Object^ default[String^ key] {
    Object^ get (String^ key);
    void set (String^ key, Object^ value);
}

Parameters

key
Type: System..::..String

Field Value

See Also

ItemsContext Class
Sitecore.Caching Namespace


PathCache Class

[image]

Sitecore 6.4.1 API
PathCache Class
Members See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PathCache : CustomCache
Visual Basic
Public Class PathCache _
    Inherits CustomCache
Visual C++
public ref class PathCache : public CustomCache

Inheritance Hierarchy

System..::..Object
Sitecore.Caching..::..CustomCache
Sitecore.Caching..::..PathCache

See Also

PathCache Members
Sitecore.Caching Namespace


PathCache Constructor

[image]

Sitecore 6.4.1 API
PathCache Constructor
PathCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PathCache(
    Database database,
    long maxSize
)
Visual Basic
Public Sub New ( _
    database As Database, _
    maxSize As Long _
)
Visual C++
public:
PathCache(
    Database^ database,
    long long maxSize
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.
maxSize
Type: System..::..Int64
Size of the max.

See Also

PathCache Class
Sitecore.Caching Namespace


PathCache Methods

[image] [image]

Sitecore 6.4.1 API
PathCache Methods
PathCache Class See Also Send Feedback

The PathCache type exposes the following members.

Methods

 | Name | Description
Public method | AddMapping(String, ID) | Adds the mapping.
 | AddMapping(String, ID, Database) | Adds the mapping.
Public method | Clear | Clears this instance. (Overrides CustomCache..::..Clear()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetID | Gets the ID. (Inherited from CustomCache.)
Public method | GetMapping(String) | Gets the mapping.
 | GetMapping(String, Database) | Gets the mapping.
Protected method | GetObject | Gets the object. (Inherited from CustomCache.)
Protected method | GetString | Gets the string. (Inherited from CustomCache.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Remove | Removes the specified key. (Inherited from CustomCache.)
Public method | RemoveKeysContaining | Removes the keys containing. (Inherited from CustomCache.)
Public method | RemoveMappingsContaining(String) | Removes the mappings containing.
Public method | RemoveMappingsContaining(ID) | Removes the mappings containing.
 | RemoveMappingsContaining(String, Database) | Removes the mappings containing.
 | RemoveMappingsContaining(ID, Database) | Removes the mappings containing.
Public method | RemovePrefix | Removes entries with keys starting with the specified prefix. (Inherited from CustomCache.)
Protected method | SetID | Sets the ID. (Inherited from CustomCache.)
Protected method | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Sets the object. (Inherited from CustomCache.)
Protected method | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
Protected method | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PathCache Class
Sitecore.Caching Namespace


AddMapping Method

[image] [image]

Sitecore 6.4.1 API
PathCache..::..AddMapping Method
PathCache Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMapping(String, ID) | Adds the mapping.
 | AddMapping(String, ID, Database) | Adds the mapping.

See Also

PathCache Class
PathCache Members
Sitecore.Caching Namespace


AddMapping Method (String, ID)

[image]

Sitecore 6.4.1 API
PathCache..::..AddMapping Method (String, ID)
PathCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddMapping(
    string itemPath,
    ID itemID
)
Visual Basic
Public Sub AddMapping ( _
    itemPath As String, _
    itemID As ID _
)
Visual C++
public:
void AddMapping(
    String^ itemPath,
    ID^ itemID
)

Parameters

itemPath
Type: System..::..String
The item path.
itemID
Type: Sitecore.Data..::..ID
The item ID.

See Also

PathCache Class
AddMapping Overload
Sitecore.Caching Namespace


AddMapping Method (String, ID, Database)

[image]

Sitecore 6.4.1 API
PathCache..::..AddMapping Method (String, ID, Database)
PathCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void AddMapping(
    string itemPath,
    ID itemID,
    Database database
)
Visual Basic
Public Shared Sub AddMapping ( _
    itemPath As String, _
    itemID As ID, _
    database As Database _
)
Visual C++
public:
static void AddMapping(
    String^ itemPath,
    ID^ itemID,
    Database^ database
)

Parameters

itemPath
Type: System..::..String
The item path.
itemID
Type: Sitecore.Data..::..ID
The item ID.
database
Type: Sitecore.Data..::..Database
The database.

See Also

PathCache Class
AddMapping Overload
Sitecore.Caching Namespace


Clear Method

[image]

Sitecore 6.4.1 API
PathCache..::..Clear Method
PathCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Clear()
Visual Basic
Public Overrides Sub Clear
Visual C++
public:
virtual void Clear() override

See Also

PathCache Class
Sitecore.Caching Namespace


GetMapping Method

[image] [image]

Sitecore 6.4.1 API
PathCache..::..GetMapping Method
PathCache Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMapping(String) | Gets the mapping.
 | GetMapping(String, Database) | Gets the mapping.

See Also

PathCache Class
PathCache Members
Sitecore.Caching Namespace


GetMapping Method (String)

[image]

Sitecore 6.4.1 API
PathCache..::..GetMapping Method (String)
PathCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID GetMapping(
    string itemPath
)
Visual Basic
Public Function GetMapping ( _
    itemPath As String _
) As ID
Visual C++
public:
ID^ GetMapping(
    String^ itemPath
)

Parameters

itemPath
Type: System..::..String
The item path.

Return Value

The mapping.

See Also

PathCache Class
GetMapping Overload
Sitecore.Caching Namespace


GetMapping Method (String, Database)

[image]

Sitecore 6.4.1 API
PathCache..::..GetMapping Method (String, Database)
PathCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID GetMapping(
    string itemPath,
    Database database
)
Visual Basic
Public Shared Function GetMapping ( _
    itemPath As String, _
    database As Database _
) As ID
Visual C++
public:
static ID^ GetMapping(
    String^ itemPath,
    Database^ database
)

Parameters

itemPath
Type: System..::..String
The item path.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

The mapping.

See Also

PathCache Class
GetMapping Overload
Sitecore.Caching Namespace


RemoveMappingsContaining Method

[image] [image]

Sitecore 6.4.1 API
PathCache..::..RemoveMappingsContaining Method
PathCache Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveMappingsContaining(String) | Removes the mappings containing.
Public method | RemoveMappingsContaining(ID) | Removes the mappings containing.
 | RemoveMappingsContaining(String, Database) | Removes the mappings containing.
 | RemoveMappingsContaining(ID, Database) | Removes the mappings containing.

See Also

PathCache Class
PathCache Members
Sitecore.Caching Namespace


RemoveMappingsContaining Method (String)

[image]

Sitecore 6.4.1 API
PathCache..::..RemoveMappingsContaining Method (String)
PathCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RemoveMappingsContaining(
    string value
)
Visual Basic
Public Sub RemoveMappingsContaining ( _
    value As String _
)
Visual C++
public:
void RemoveMappingsContaining(
    String^ value
)

Parameters

value
Type: System..::..String
The value.

See Also

PathCache Class
RemoveMappingsContaining Overload
Sitecore.Caching Namespace


RemoveMappingsContaining Method (ID)

[image]

Sitecore 6.4.1 API
PathCache..::..RemoveMappingsContaining Method (ID)
PathCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RemoveMappingsContaining(
    ID itemID
)
Visual Basic
Public Sub RemoveMappingsContaining ( _
    itemID As ID _
)
Visual C++
public:
void RemoveMappingsContaining(
    ID^ itemID
)

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.

See Also

PathCache Class
RemoveMappingsContaining Overload
Sitecore.Caching Namespace


RemoveMappingsContaining Method (String, Database)

[image]

Sitecore 6.4.1 API
PathCache..::..RemoveMappingsContaining Method (String, Database)
PathCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void RemoveMappingsContaining(
    string value,
    Database database
)
Visual Basic
Public Shared Sub RemoveMappingsContaining ( _
    value As String, _
    database As Database _
)
Visual C++
public:
static void RemoveMappingsContaining(
    String^ value,
    Database^ database
)

Parameters

value
Type: System..::..String
The value.
database
Type: Sitecore.Data..::..Database
The database.

See Also

PathCache Class
RemoveMappingsContaining Overload
Sitecore.Caching Namespace


RemoveMappingsContaining Method (ID, Database)

[image]

Sitecore 6.4.1 API
PathCache..::..RemoveMappingsContaining Method (ID, Database)
PathCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void RemoveMappingsContaining(
    ID itemID,
    Database database
)
Visual Basic
Public Shared Sub RemoveMappingsContaining ( _
    itemID As ID, _
    database As Database _
)
Visual C++
public:
static void RemoveMappingsContaining(
    ID^ itemID,
    Database^ database
)

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.
database
Type: Sitecore.Data..::..Database
The database.

See Also

PathCache Class
RemoveMappingsContaining Overload
Sitecore.Caching Namespace


SetObject Method

[image] [image]

Sitecore 6.4.1 API
PathCache..::..SetObject Method
PathCache Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Sets the object. (Inherited from CustomCache.)

See Also

PathCache Class
PathCache Members
Sitecore.Caching Namespace


PathCache Properties

[image] [image]

Sitecore 6.4.1 API
PathCache Properties
PathCache Class See Also Send Feedback

The PathCache type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether this CustomCache is enabled. (Overrides CustomCache..::..Enabled.)
Public property | InnerCache | Gets the inner cache. (Inherited from CustomCache.)
Public property | Name | Gets the name. (Inherited from CustomCache.)

See Also

PathCache Class
Sitecore.Caching Namespace


Enabled Property

[image]

Sitecore 6.4.1 API
PathCache..::..Enabled Property
PathCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool Enabled { get; }
Visual Basic
Public Overrides ReadOnly Property Enabled As Boolean
    Get
Visual C++
public:
virtual property bool Enabled {
    bool get () override;
}

Field Value

true if enabled; otherwise, false.

See Also

PathCache Class
Sitecore.Caching Namespace


RegistryCache Class

[image]

Sitecore 6.4.1 API
RegistryCache Class
Members See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RegistryCache : CustomCache
Visual Basic
Public Class RegistryCache _
    Inherits CustomCache
Visual C++
public ref class RegistryCache : public CustomCache

Inheritance Hierarchy

System..::..Object
Sitecore.Caching..::..CustomCache
Sitecore.Caching..::..RegistryCache

See Also

RegistryCache Members
Sitecore.Caching Namespace


RegistryCache Members

[image] [image]

Sitecore 6.4.1 API
RegistryCache Members
RegistryCache Class Constructors Methods Properties See Also Send Feedback

The RegistryCache type exposes the following members.

Constructors

 | Name | Description
Public method | RegistryCache | Initializes a new instance of the RegistryCache class.

Methods

 | Name | Description
Public method | Clear | Clears this instance. (Overrides CustomCache..::..Clear()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetID | Gets the ID. (Inherited from CustomCache.)
Protected method | GetObject | Gets the object. (Inherited from CustomCache.)
Protected method | GetString | Gets the string. (Inherited from CustomCache.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the value.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Remove | Removes the specified key. (Inherited from CustomCache.)
Public method | RemoveKeysContaining | Removes the keys containing. (Inherited from CustomCache.)
Public method | RemovePrefix | Removes entries with keys starting with the specified prefix. (Inherited from CustomCache.)
Protected method | SetID | Sets the ID. (Inherited from CustomCache.)
Protected method | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Sets the object. (Inherited from CustomCache.)
Protected method | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
Protected method | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)
Public method | SetValue | Sets the value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether this CustomCache is enabled. (Inherited from CustomCache.)
Public property | InnerCache | Gets the inner cache. (Inherited from CustomCache.)
Public property | Name | Gets the name. (Inherited from CustomCache.)

See Also

RegistryCache Class
Sitecore.Caching Namespace


RegistryCache Constructor

[image]

Sitecore 6.4.1 API
RegistryCache Constructor
RegistryCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RegistryCache(
    SiteInfo site,
    long maxSize
)
Visual Basic
Public Sub New ( _
    site As SiteInfo, _
    maxSize As Long _
)
Visual C++
public:
RegistryCache(
    SiteInfo^ site,
    long long maxSize
)

Parameters

site
Type: Sitecore.Web..::..SiteInfo
The site.
maxSize
Type: System..::..Int64
Size of the max.

See Also

RegistryCache Class
Sitecore.Caching Namespace


RegistryCache Methods

[image] [image]

Sitecore 6.4.1 API
RegistryCache Methods
RegistryCache Class See Also Send Feedback

The RegistryCache type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Clears this instance. (Overrides CustomCache..::..Clear()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetID | Gets the ID. (Inherited from CustomCache.)
Protected method | GetObject | Gets the object. (Inherited from CustomCache.)
Protected method | GetString | Gets the string. (Inherited from CustomCache.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the value.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Remove | Removes the specified key. (Inherited from CustomCache.)
Public method | RemoveKeysContaining | Removes the keys containing. (Inherited from CustomCache.)
Public method | RemovePrefix | Removes entries with keys starting with the specified prefix. (Inherited from CustomCache.)
Protected method | SetID | Sets the ID. (Inherited from CustomCache.)
Protected method | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Sets the object. (Inherited from CustomCache.)
Protected method | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
Protected method | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)
Public method | SetValue | Sets the value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RegistryCache Class
Sitecore.Caching Namespace


Clear Method

[image]

Sitecore 6.4.1 API
RegistryCache..::..Clear Method
RegistryCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Clear()
Visual Basic
Public Overrides Sub Clear
Visual C++
public:
virtual void Clear() override

See Also

RegistryCache Class
Sitecore.Caching Namespace


GetValue Method

[image]

Sitecore 6.4.1 API
RegistryCache..::..GetValue Method
RegistryCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetValue(
    string key
)
Visual Basic
Public Function GetValue ( _
    key As String _
) As String
Visual C++
public:
String^ GetValue(
    String^ key
)

Parameters

key
Type: System..::..String
The key.

Return Value

The value.

See Also

RegistryCache Class
Sitecore.Caching Namespace


SetObject Method

[image] [image]

Sitecore 6.4.1 API
RegistryCache..::..SetObject Method
RegistryCache Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Sets the object. (Inherited from CustomCache.)

See Also

RegistryCache Class
RegistryCache Members
Sitecore.Caching Namespace


SetString Method

[image] [image]

Sitecore 6.4.1 API
RegistryCache..::..SetString Method
RegistryCache Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
Protected method | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)

See Also

RegistryCache Class
RegistryCache Members
Sitecore.Caching Namespace


RegistryCache Properties

[image] [image]

Sitecore 6.4.1 API
RegistryCache Properties
RegistryCache Class See Also Send Feedback

The RegistryCache type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether this CustomCache is enabled. (Inherited from CustomCache.)
Public property | InnerCache | Gets the inner cache. (Inherited from CustomCache.)
Public property | Name | Gets the name. (Inherited from CustomCache.)

See Also

RegistryCache Class
Sitecore.Caching Namespace


RuleCache Class

[image]

Sitecore 6.4.1 API
RuleCache Class
Members See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RuleCache : CustomCache
Visual Basic
Public Class RuleCache _
    Inherits CustomCache
Visual C++
public ref class RuleCache : public CustomCache

Inheritance Hierarchy

System..::..Object
Sitecore.Caching..::..CustomCache
Sitecore.Caching..::..RuleCache

See Also

RuleCache Members
Sitecore.Caching Namespace


RuleCache Members

[image] [image]

Sitecore 6.4.1 API
RuleCache Members
RuleCache Class Constructors Methods Properties See Also Send Feedback

The RuleCache type exposes the following members.

Constructors

 | Name | Description
Public method | RuleCache | Initializes a new instance of the RuleCache class.

Methods

 | Name | Description
Public method | AddRules<(Of <<'(T>)>>) | Adds the rules.
Public method | Clear | Clears this instance. (Inherited from CustomCache.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetID | Gets the ID. (Inherited from CustomCache.)
Protected method | GetObject | Gets the object. (Inherited from CustomCache.)
Public method | GetRules<(Of <<'(T>)>>) | Gets the rules.
Protected method | GetString | Gets the string. (Inherited from CustomCache.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Remove | Removes the specified key. (Inherited from CustomCache.)
Public method | RemoveKeysContaining | Removes the keys containing. (Inherited from CustomCache.)
Public method | RemovePrefix | Removes entries with keys starting with the specified prefix. (Inherited from CustomCache.)
Protected method | SetID | Sets the ID. (Inherited from CustomCache.)
Protected method | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Sets the object. (Inherited from CustomCache.)
Protected method | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
Protected method | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether this CustomCache is enabled. (Inherited from CustomCache.)
Public property | InnerCache | Gets the inner cache. (Inherited from CustomCache.)
Public property | Name | Gets the name. (Inherited from CustomCache.)

See Also

RuleCache Class
Sitecore.Caching Namespace


RuleCache Constructor

[image]

Sitecore 6.4.1 API
RuleCache Constructor
RuleCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RuleCache(
    long maxSize
)
Visual Basic
Public Sub New ( _
    maxSize As Long _
)
Visual C++
public:
RuleCache(
    long long maxSize
)

Parameters

maxSize
Type: System..::..Int64
Size of the max.

See Also

RuleCache Class
Sitecore.Caching Namespace


RuleCache Methods

[image] [image]

Sitecore 6.4.1 API
RuleCache Methods
RuleCache Class See Also Send Feedback

The RuleCache type exposes the following members.

Methods

 | Name | Description
Public method | AddRules<(Of <<'(T>)>>) | Adds the rules.
Public method | Clear | Clears this instance. (Inherited from CustomCache.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetID | Gets the ID. (Inherited from CustomCache.)
Protected method | GetObject | Gets the object. (Inherited from CustomCache.)
Public method | GetRules<(Of <<'(T>)>>) | Gets the rules.
Protected method | GetString | Gets the string. (Inherited from CustomCache.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Remove | Removes the specified key. (Inherited from CustomCache.)
Public method | RemoveKeysContaining | Removes the keys containing. (Inherited from CustomCache.)
Public method | RemovePrefix | Removes entries with keys starting with the specified prefix. (Inherited from CustomCache.)
Protected method | SetID | Sets the ID. (Inherited from CustomCache.)
Protected method | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Sets the object. (Inherited from CustomCache.)
Protected method | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
Protected method | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RuleCache Class
Sitecore.Caching Namespace


AddRules(T) Method

[image]

Sitecore 6.4.1 API
RuleCache..::..AddRules<(Of <(<'T>)>)> Method
RuleCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddRules<T>(
    Item parentItem,
    string fieldName,
    RuleList<T> result
)
where T : RuleContext
Visual Basic
Public Sub AddRules(Of T As RuleContext) ( _
    parentItem As Item, _
    fieldName As String, _
    result As RuleList(Of T) _
)
Visual C++
public:
generic<typename T>
where T : RuleContext
void AddRules(
    Item^ parentItem,
    String^ fieldName,
    RuleList<T>^ result
)

Parameters

parentItem
Type: Sitecore.Data.Items..::..Item
The parent item.
fieldName
Type: System..::..String
Name of the field.
result
Type: Sitecore.Rules..::..RuleList <(Of <(<'T>)>)>
The result.

Type Parameters

T
RuleContext type

See Also

RuleCache Class
Sitecore.Caching Namespace


GetRules(T) Method

[image]

Sitecore 6.4.1 API
RuleCache..::..GetRules<(Of <(<'T>)>)> Method
RuleCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RuleList<T> GetRules<T>(
    Item parentItem,
    string fieldName
)
where T : RuleContext
Visual Basic
Public Function GetRules(Of T As RuleContext) ( _
    parentItem As Item, _
    fieldName As String _
) As RuleList(Of T)
Visual C++
public:
generic<typename T>
where T : RuleContext
RuleList<T>^ GetRules(
    Item^ parentItem,
    String^ fieldName
)

Parameters

parentItem
Type: Sitecore.Data.Items..::..Item
The parent item.
fieldName
Type: System..::..String
Name of the field.

Type Parameters

T
RuleContext type

Return Value

List of rule

See Also

RuleCache Class
Sitecore.Caching Namespace


SetObject Method

[image] [image]

Sitecore 6.4.1 API
RuleCache..::..SetObject Method
RuleCache Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Sets the object. (Inherited from CustomCache.)

See Also

RuleCache Class
RuleCache Members
Sitecore.Caching Namespace


SetString Method

[image] [image]

Sitecore 6.4.1 API
RuleCache..::..SetString Method
RuleCache Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
Protected method | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)

See Also

RuleCache Class
RuleCache Members
Sitecore.Caching Namespace


RuleCache Properties

[image] [image]

Sitecore 6.4.1 API
RuleCache Properties
RuleCache Class See Also Send Feedback

The RuleCache type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether this CustomCache is enabled. (Inherited from CustomCache.)
Public property | InnerCache | Gets the inner cache. (Inherited from CustomCache.)
Public property | Name | Gets the name. (Inherited from CustomCache.)

See Also

RuleCache Class
Sitecore.Caching Namespace


StandardValuesCache Class

[image]

Sitecore 6.4.1 API
StandardValuesCache Class
Members See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class StandardValuesCache : CustomCache
Visual Basic
Public Class StandardValuesCache _
    Inherits CustomCache
Visual C++
public ref class StandardValuesCache : public CustomCache

Inheritance Hierarchy

System..::..Object
Sitecore.Caching..::..CustomCache
Sitecore.Caching..::..StandardValuesCache

See Also

StandardValuesCache Members
Sitecore.Caching Namespace


StandardValuesCache Members

[image] [image]

Sitecore 6.4.1 API
StandardValuesCache Members
StandardValuesCache Class Constructors Methods Properties See Also Send Feedback

The StandardValuesCache type exposes the following members.

Constructors

 | Name | Description
Public method | StandardValuesCache | Initializes a new instance of the StandardValuesCache class.

Methods

 | Name | Description
Public method | AddStandardValues | Adds standard values for an item.
Public method | Clear | Clears this instance. (Inherited from CustomCache.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetID | Gets the ID. (Inherited from CustomCache.)
Protected method | GetObject | Gets the object. (Inherited from CustomCache.)
Public method | GetStandardValues | Gets the standard values for an item.
Protected method | GetString | Gets the string. (Inherited from CustomCache.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Remove | Removes the specified key. (Inherited from CustomCache.)
Public method | RemoveKeysContaining | Removes the keys containing. (Inherited from CustomCache.)
Public method | RemovePrefix | Removes entries with keys starting with the specified prefix. (Inherited from CustomCache.)
Protected method | SetID | Sets the ID. (Inherited from CustomCache.)
Protected method | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Sets the object. (Inherited from CustomCache.)
Protected method | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
Protected method | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether this CustomCache is enabled. (Inherited from CustomCache.)
Public property | InnerCache | Gets the inner cache. (Inherited from CustomCache.)
Public property | Name | Gets the name. (Inherited from CustomCache.)

See Also

StandardValuesCache Class
Sitecore.Caching Namespace


StandardValuesCache Constructor

[image]

Sitecore 6.4.1 API
StandardValuesCache Constructor
StandardValuesCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StandardValuesCache(
    Database database,
    long maxSize
)
Visual Basic
Public Sub New ( _
    database As Database, _
    maxSize As Long _
)
Visual C++
public:
StandardValuesCache(
    Database^ database,
    long long maxSize
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.
maxSize
Type: System..::..Int64
Size of the max.

See Also

StandardValuesCache Class
Sitecore.Caching Namespace


StandardValuesCache Methods

[image] [image]

Sitecore 6.4.1 API
StandardValuesCache Methods
StandardValuesCache Class See Also Send Feedback

The StandardValuesCache type exposes the following members.

Methods

 | Name | Description
Public method | AddStandardValues | Adds standard values for an item.
Public method | Clear | Clears this instance. (Inherited from CustomCache.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetID | Gets the ID. (Inherited from CustomCache.)
Protected method | GetObject | Gets the object. (Inherited from CustomCache.)
Public method | GetStandardValues | Gets the standard values for an item.
Protected method | GetString | Gets the string. (Inherited from CustomCache.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Remove | Removes the specified key. (Inherited from CustomCache.)
Public method | RemoveKeysContaining | Removes the keys containing. (Inherited from CustomCache.)
Public method | RemovePrefix | Removes entries with keys starting with the specified prefix. (Inherited from CustomCache.)
Protected method | SetID | Sets the ID. (Inherited from CustomCache.)
Protected method | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Sets the object. (Inherited from CustomCache.)
Protected method | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
Protected method | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StandardValuesCache Class
Sitecore.Caching Namespace


AddStandardValues Method

[image]

Sitecore 6.4.1 API
StandardValuesCache..::..AddStandardValues Method
StandardValuesCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddStandardValues(
    Item item,
    SafeDictionary<ID, string> values
)
Visual Basic
Public Sub AddStandardValues ( _
    item As Item, _
    values As SafeDictionary(Of ID, String) _
)
Visual C++
public:
void AddStandardValues(
    Item^ item,
    SafeDictionary<ID^, String^>^ values
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
values
Type: Sitecore.Collections..::..SafeDictionary <(Of <(<' ID, String >)>)>
The values.

See Also

StandardValuesCache Class
Sitecore.Caching Namespace


GetStandardValues Method

[image]

Sitecore 6.4.1 API
StandardValuesCache..::..GetStandardValues Method
StandardValuesCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SafeDictionary<ID, string> GetStandardValues(
    Item item
)
Visual Basic
Public Function GetStandardValues ( _
    item As Item _
) As SafeDictionary(Of ID, String)
Visual C++
public:
SafeDictionary<ID^, String^>^ GetStandardValues(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Caching.StandardValuesCache.GetStandardValues(Sitecore.Data.Items.Item)"]

See Also

StandardValuesCache Class
Sitecore.Caching Namespace


SetObject Method

[image] [image]

Sitecore 6.4.1 API
StandardValuesCache..::..SetObject Method
StandardValuesCache Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Sets the object. (Inherited from CustomCache.)

See Also

StandardValuesCache Class
StandardValuesCache Members
Sitecore.Caching Namespace


SetString Method

[image] [image]

Sitecore 6.4.1 API
StandardValuesCache..::..SetString Method
StandardValuesCache Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
Protected method | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)

See Also

StandardValuesCache Class
StandardValuesCache Members
Sitecore.Caching Namespace


StandardValuesCache Properties

[image] [image]

Sitecore 6.4.1 API
StandardValuesCache Properties
StandardValuesCache Class See Also Send Feedback

The StandardValuesCache type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether this CustomCache is enabled. (Inherited from CustomCache.)
Public property | InnerCache | Gets the inner cache. (Inherited from CustomCache.)
Public property | Name | Gets the name. (Inherited from CustomCache.)

See Also

StandardValuesCache Class
Sitecore.Caching Namespace


ViewStateCache Class

[image]

Sitecore 6.4.1 API
ViewStateCache Class
Members See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ViewStateCache : CustomCache
Visual Basic
Public Class ViewStateCache _
    Inherits CustomCache
Visual C++
public ref class ViewStateCache : public CustomCache

Inheritance Hierarchy

System..::..Object
Sitecore.Caching..::..CustomCache
Sitecore.Caching..::..ViewStateCache

See Also

ViewStateCache Members
Sitecore.Caching Namespace


ViewStateCache Members

[image] [image]

Sitecore 6.4.1 API
ViewStateCache Members
ViewStateCache Class Constructors Methods Properties See Also Send Feedback

The ViewStateCache type exposes the following members.

Constructors

 | Name | Description
Public method | ViewStateCache | Initializes a new instance of the ViewStateCache class.

Methods

 | Name | Description
Public method | Clear | Clears this instance. (Overrides CustomCache..::..Clear()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetID | Gets the ID. (Inherited from CustomCache.)
Protected method | GetObject | Gets the object. (Inherited from CustomCache.)
Protected method | GetString | Gets the string. (Inherited from CustomCache.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetViewState | Gets the state of the view.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Remove | Removes the specified key. (Inherited from CustomCache.)
Public method | RemoveKeysContaining | Removes the keys containing. (Inherited from CustomCache.)
Public method | RemovePrefix | Removes entries with keys starting with the specified prefix. (Inherited from CustomCache.)
Protected method | SetID | Sets the ID. (Inherited from CustomCache.)
Protected method | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Sets the object. (Inherited from CustomCache.)
Protected method | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
Protected method | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)
Public method | SetViewState | Sets the state of the view.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether this CustomCache is enabled. (Inherited from CustomCache.)
Public property | InnerCache | Gets the inner cache. (Inherited from CustomCache.)
Public property | Name | Gets the name. (Inherited from CustomCache.)

See Also

ViewStateCache Class
Sitecore.Caching Namespace


ViewStateCache Constructor

[image]

Sitecore 6.4.1 API
ViewStateCache Constructor
ViewStateCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ViewStateCache(
    SiteInfo site,
    long maxSize
)
Visual Basic
Public Sub New ( _
    site As SiteInfo, _
    maxSize As Long _
)
Visual C++
public:
ViewStateCache(
    SiteInfo^ site,
    long long maxSize
)

Parameters

site
Type: Sitecore.Web..::..SiteInfo
The site.
maxSize
Type: System..::..Int64
Size of the max.

See Also

ViewStateCache Class
Sitecore.Caching Namespace


ViewStateCache Methods

[image] [image]

Sitecore 6.4.1 API
ViewStateCache Methods
ViewStateCache Class See Also Send Feedback

The ViewStateCache type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Clears this instance. (Overrides CustomCache..::..Clear()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetID | Gets the ID. (Inherited from CustomCache.)
Protected method | GetObject | Gets the object. (Inherited from CustomCache.)
Protected method | GetString | Gets the string. (Inherited from CustomCache.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetViewState | Gets the state of the view.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Remove | Removes the specified key. (Inherited from CustomCache.)
Public method | RemoveKeysContaining | Removes the keys containing. (Inherited from CustomCache.)
Public method | RemovePrefix | Removes entries with keys starting with the specified prefix. (Inherited from CustomCache.)
Protected method | SetID | Sets the ID. (Inherited from CustomCache.)
Protected method | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Sets the object. (Inherited from CustomCache.)
Protected method | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
Protected method | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)
Public method | SetViewState | Sets the state of the view.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewStateCache Class
Sitecore.Caching Namespace


Clear Method

[image]

Sitecore 6.4.1 API
ViewStateCache..::..Clear Method
ViewStateCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Clear()
Visual Basic
Public Overrides Sub Clear
Visual C++
public:
virtual void Clear() override

See Also

ViewStateCache Class
Sitecore.Caching Namespace


GetViewState Method

[image]

Sitecore 6.4.1 API
ViewStateCache..::..GetViewState Method
ViewStateCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetViewState(
    string key
)
Visual Basic
Public Function GetViewState ( _
    key As String _
) As String
Visual C++
public:
String^ GetViewState(
    String^ key
)

Parameters

key
Type: System..::..String
The key.

Return Value

The String.

See Also

ViewStateCache Class
Sitecore.Caching Namespace


SetObject Method

[image] [image]

Sitecore 6.4.1 API
ViewStateCache..::..SetObject Method
ViewStateCache Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Sets the object. (Inherited from CustomCache.)

See Also

ViewStateCache Class
ViewStateCache Members
Sitecore.Caching Namespace


SetString Method

[image] [image]

Sitecore 6.4.1 API
ViewStateCache..::..SetString Method
ViewStateCache Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
Protected method | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)

See Also

ViewStateCache Class
ViewStateCache Members
Sitecore.Caching Namespace


SetViewState Method

[image]

Sitecore 6.4.1 API
ViewStateCache..::..SetViewState Method
ViewStateCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetViewState(
    string key,
    string value
)
Visual Basic
Public Sub SetViewState ( _
    key As String, _
    value As String _
)
Visual C++
public:
void SetViewState(
    String^ key,
    String^ value
)

Parameters

key
Type: System..::..String
The key.
value
Type: System..::..String
The value.

See Also

ViewStateCache Class
Sitecore.Caching Namespace


ViewStateCache Properties

[image] [image]

Sitecore 6.4.1 API
ViewStateCache Properties
ViewStateCache Class See Also Send Feedback

The ViewStateCache type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether this CustomCache is enabled. (Inherited from CustomCache.)
Public property | InnerCache | Gets the inner cache. (Inherited from CustomCache.)
Public property | Name | Gets the name. (Inherited from CustomCache.)

See Also

ViewStateCache Class
Sitecore.Caching Namespace


XslCache Class

[image]

Sitecore 6.4.1 API
XslCache Class
Members See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class XslCache : CustomCache
Visual Basic
Public Class XslCache _
    Inherits CustomCache
Visual C++
public ref class XslCache : public CustomCache

Inheritance Hierarchy

System..::..Object
Sitecore.Caching..::..CustomCache
Sitecore.Caching..::..XslCache

See Also

XslCache Members
Sitecore.Caching Namespace


XslCache Members

[image] [image]

Sitecore 6.4.1 API
XslCache Members
XslCache Class Constructors Methods Properties See Also Send Feedback

The XslCache type exposes the following members.

Constructors

 | Name | Description
Public method | XslCache | Initializes a new instance of the XslCache class.

Methods

 | Name | Description
Public method | Clear | Clears this instance. (Overrides CustomCache..::..Clear()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetID | Gets the ID. (Inherited from CustomCache.)
Protected method | GetObject | Gets the object. (Inherited from CustomCache.)
Protected method | GetString | Gets the string. (Inherited from CustomCache.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXsl | Obsolete. Gets the XSL.
Public method | GetXslTransform | Gets the XSL transform.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Remove | Removes the specified key. (Inherited from CustomCache.)
Public method | RemoveKeysContaining | Removes the keys containing. (Inherited from CustomCache.)
Public method | RemovePrefix | Removes entries with keys starting with the specified prefix. (Inherited from CustomCache.)
Protected method | SetID | Sets the ID. (Inherited from CustomCache.)
Protected method | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Sets the object. (Inherited from CustomCache.)
Protected method | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
Protected method | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)
Public method | SetXsl | Obsolete. Sets the XSL.
Public method | SetXslTransform | Sets the XSL transform.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether this CustomCache is enabled. (Inherited from CustomCache.)
Public property | InnerCache | Gets the inner cache. (Inherited from CustomCache.)
Public property | Name | Gets the name. (Inherited from CustomCache.)

See Also

XslCache Class
Sitecore.Caching Namespace


XslCache Constructor

[image]

Sitecore 6.4.1 API
XslCache Constructor
XslCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public XslCache(
    SiteInfo site,
    long maxSize
)
Visual Basic
Public Sub New ( _
    site As SiteInfo, _
    maxSize As Long _
)
Visual C++
public:
XslCache(
    SiteInfo^ site,
    long long maxSize
)

Parameters

site
Type: Sitecore.Web..::..SiteInfo
The site.
maxSize
Type: System..::..Int64
Size of the max.

See Also

XslCache Class
Sitecore.Caching Namespace


XslCache Methods

[image] [image]

Sitecore 6.4.1 API
XslCache Methods
XslCache Class See Also Send Feedback

The XslCache type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Clears this instance. (Overrides CustomCache..::..Clear()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetID | Gets the ID. (Inherited from CustomCache.)
Protected method | GetObject | Gets the object. (Inherited from CustomCache.)
Protected method | GetString | Gets the string. (Inherited from CustomCache.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXsl | Obsolete. Gets the XSL.
Public method | GetXslTransform | Gets the XSL transform.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Remove | Removes the specified key. (Inherited from CustomCache.)
Public method | RemoveKeysContaining | Removes the keys containing. (Inherited from CustomCache.)
Public method | RemovePrefix | Removes entries with keys starting with the specified prefix. (Inherited from CustomCache.)
Protected method | SetID | Sets the ID. (Inherited from CustomCache.)
Protected method | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Sets the object. (Inherited from CustomCache.)
Protected method | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
Protected method | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)
Public method | SetXsl | Obsolete. Sets the XSL.
Public method | SetXslTransform | Sets the XSL transform.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

XslCache Class
Sitecore.Caching Namespace


Clear Method

[image]

Sitecore 6.4.1 API
XslCache..::..Clear Method
XslCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Clear()
Visual Basic
Public Overrides Sub Clear
Visual C++
public:
virtual void Clear() override

See Also

XslCache Class
Sitecore.Caching Namespace


GetXsl Method

[image]

Sitecore 6.4.1 API
XslCache..::..GetXsl Method
XslCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use GetXslTransform instead.", false)]
public XslTransform GetXsl(
    string filePath
)
Visual Basic
<ObsoleteAttribute("Use GetXslTransform instead.", False)> _
Public Function GetXsl ( _
    filePath As String _
) As XslTransform
Visual C++
[ObsoleteAttribute(L"Use GetXslTransform instead.", false)]
public:
XslTransform^ GetXsl(
    String^ filePath
)

Parameters

filePath
Type: System..::..String
The file path.

Return Value

The XSL.

See Also

XslCache Class
Sitecore.Caching Namespace


GetXslTransform Method

[image]

Sitecore 6.4.1 API
XslCache..::..GetXslTransform Method
XslCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MvpXslTransform GetXslTransform(
    string filePath
)
Visual Basic
Public Function GetXslTransform ( _
    filePath As String _
) As MvpXslTransform
Visual C++
public:
MvpXslTransform^ GetXslTransform(
    String^ filePath
)

Parameters

filePath
Type: System..::..String
The file path.

Return Value

The XSL transform.

See Also

XslCache Class
Sitecore.Caching Namespace


SetObject Method

[image] [image]

Sitecore 6.4.1 API
XslCache..::..SetObject Method
XslCache Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Sets the object. (Inherited from CustomCache.)

See Also

XslCache Class
XslCache Members
Sitecore.Caching Namespace


SetString Method

[image] [image]

Sitecore 6.4.1 API
XslCache..::..SetString Method
XslCache Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
Protected method | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)

See Also

XslCache Class
XslCache Members
Sitecore.Caching Namespace


SetXsl Method

[image]

Sitecore 6.4.1 API
XslCache..::..SetXsl Method
XslCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use SetXslTransform instead.", false)]
public void SetXsl(
    string filePath,
    XslTransform xsl
)
Visual Basic
<ObsoleteAttribute("Use SetXslTransform instead.", False)> _
Public Sub SetXsl ( _
    filePath As String, _
    xsl As XslTransform _
)
Visual C++
[ObsoleteAttribute(L"Use SetXslTransform instead.", false)]
public:
void SetXsl(
    String^ filePath,
    XslTransform^ xsl
)

Parameters

filePath
Type: System..::..String
The file path.
xsl
Type: System.Xml.Xsl..::..XslTransform
The XSL.

See Also

XslCache Class
Sitecore.Caching Namespace


SetXslTransform Method

[image]

Sitecore 6.4.1 API
XslCache..::..SetXslTransform Method
XslCache Class See Also Send Feedback

Namespace: Sitecore.Caching
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetXslTransform(
    string filePath,
    MvpXslTransform xsl
)
Visual Basic
Public Sub SetXslTransform ( _
    filePath As String, _
    xsl As MvpXslTransform _
)
Visual C++
public:
void SetXslTransform(
    String^ filePath,
    MvpXslTransform^ xsl
)

Parameters

filePath
Type: System..::..String
The file path.
xsl
Type: MvpXslTransform
The XSL.

See Also

XslCache Class
Sitecore.Caching Namespace


XslCache Properties

[image] [image]

Sitecore 6.4.1 API
XslCache Properties
XslCache Class See Also Send Feedback

The XslCache type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether this CustomCache is enabled. (Inherited from CustomCache.)
Public property | InnerCache | Gets the inner cache. (Inherited from CustomCache.)
Public property | Name | Gets the name. (Inherited from CustomCache.)

See Also

XslCache Class
Sitecore.Caching Namespace


Cache(TKey, TData) Class

[image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Cache<TKey, TData>
where TData : ICacheable
Visual Basic
Public Class Cache(Of TKey, TData As ICacheable)
Visual C++
generic<typename TKey, typename TData>
where TData : ICacheable
public ref class Cache

Type Parameters

TKey

[Missing <typeparam name="TKey"/> documentation for "T:Sitecore.Caching.Generics.Cache`2"]

TData

[Missing <typeparam name="TData"/> documentation for "T:Sitecore.Caching.Generics.Cache`2"]

Inheritance Hierarchy

System..::..Object
Sitecore.Caching.Generics..::..Cache<(Of <(<'TKey, TData>)>)>

See Also

Cache<(Of <(<'TKey, TData>)>)> Members
Sitecore.Caching.Generics Namespace


Cache(TKey, TData) Members

[image] [image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)> Members
Cache<(Of <(<'TKey, TData>)>)> Class Constructors Methods Properties See Also Send Feedback

The Cache<(Of <(<'TKey, TData>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | Cache<(Of <(<'TKey, TData>)>)>(Int64) | Initializes a new instance of the Cache class.
Public method | Cache<(Of <(<'TKey, TData>)>)>(String, Int64) | Initializes a new instance of the Cache class.
Public method | Cache<(Of <(<'TKey, TData>)>)>(String, String) | Initializes a new instance of the Cache class.

Methods

 | Name | Description
Public method | Add | Adds the specified key.
Public method | Clear | Clears this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCacheKeys()()()() | Gets the cache keys.
Public method | GetCacheKeys(String) | Gets the cache keys.
Public method | GetEntry | Gets the entry represented by key.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the value.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseSizeString | Parses the size string.
Public method | Remove | Removes the specified key.
Public method | RemoveKeysContaining | Removes the keys containing the value.
Public method | RemovePrefix | Removes the prefix.
Public method | Scavenge | Scavenges this cache.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the count.
Public property | DefaultPriority | Gets or sets the default priority.
Public property | Enabled | Gets or sets a value indicating whether this Cache is enabled.
Public property | Id | Gets the id.
Public property | Item | Gets the data with the specified key.
Public property | MaxSize | Gets or sets the max size.
Public property | Name | Gets the name.
Public property | RemainingSpace | Gets the remaining space (in bytes).
Public property | Scavengable | Gets or sets a value indicating whether this Cache is scavengable.
Public property | Size | Gets the size.
Public property | SyncRoot | Gets the sync root.

See Also

Cache<(Of <(<'TKey, TData>)>)> Class
Sitecore.Caching.Generics Namespace


Cache(TKey, TData) Constructor

[image] [image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)> Constructor
Cache<(Of <(<'TKey, TData>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Cache<(Of <(<'TKey, TData>)>)>(Int64) | Initializes a new instance of the Cache class.
Public method | Cache<(Of <(<'TKey, TData>)>)>(String, Int64) | Initializes a new instance of the Cache class.
Public method | Cache<(Of <(<'TKey, TData>)>)>(String, String) | Initializes a new instance of the Cache class.

See Also

Cache<(Of <(<'TKey, TData>)>)> Class
Cache<(Of <(<'TKey, TData>)>)> Members
Sitecore.Caching.Generics Namespace


Cache(TKey, TData) Constructor (Int64)

[image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)> Constructor (Int64)
Cache<(Of <(<'TKey, TData>)>)> Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Cache(
    long maxSize
)
Visual Basic
Public Sub New ( _
    maxSize As Long _
)
Visual C++
public:
Cache(
    long long maxSize
)

Parameters

maxSize
Type: System..::..Int64
Size of the max.

See Also

Cache<(Of <(<'TKey, TData>)>)> Class
Cache<(Of <(<'TKey, TData>)>)> Overload
Sitecore.Caching.Generics Namespace


Cache(TKey, TData) Constructor (String, String)

[image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)> Constructor (String, String)
Cache<(Of <(<'TKey, TData>)>)> Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Cache(
    string name,
    string maxSize
)
Visual Basic
Public Sub New ( _
    name As String, _
    maxSize As String _
)
Visual C++
public:
Cache(
    String^ name,
    String^ maxSize
)

Parameters

name
Type: System..::..String
The name.
maxSize
Type: System..::..String
Size of the max.

See Also

Cache<(Of <(<'TKey, TData>)>)> Class
Cache<(Of <(<'TKey, TData>)>)> Overload
Sitecore.Caching.Generics Namespace


Cache(TKey, TData) Methods

[image] [image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)> Methods
Cache<(Of <(<'TKey, TData>)>)> Class See Also Send Feedback

The Cache<(Of <(<'TKey, TData>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key.
Public method | Clear | Clears this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCacheKeys()()()() | Gets the cache keys.
Public method | GetCacheKeys(String) | Gets the cache keys.
Public method | GetEntry | Gets the entry represented by key.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the value.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseSizeString | Parses the size string.
Public method | Remove | Removes the specified key.
Public method | RemoveKeysContaining | Removes the keys containing the value.
Public method | RemovePrefix | Removes the prefix.
Public method | Scavenge | Scavenges this cache.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Cache<(Of <(<'TKey, TData>)>)> Class
Sitecore.Caching.Generics Namespace


Add Method

[image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)>..::..Add Method
Cache<(Of <(<'TKey, TData>)>)> Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Add(
    TKey key,
    TData data
)
Visual Basic
Public Sub Add ( _
    key As TKey, _
    data As TData _
)
Visual C++
public:
void Add(
    TKey key,
    TData data
)

Parameters

key
Type: TKey
The key.
data
Type: TData
The data.

See Also

Cache<(Of <(<'TKey, TData>)>)> Class
Sitecore.Caching.Generics Namespace


Clear Method

[image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)>..::..Clear Method
Cache<(Of <(<'TKey, TData>)>)> Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

Cache<(Of <(<'TKey, TData>)>)> Class
Sitecore.Caching.Generics Namespace


GetCacheKeys Method

[image] [image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)>..::..GetCacheKeys Method
Cache<(Of <(<'TKey, TData>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetCacheKeys()()()() | Gets the cache keys.
Public method | GetCacheKeys(String) | Gets the cache keys.

See Also

Cache<(Of <(<'TKey, TData>)>)> Class
Cache<(Of <(<'TKey, TData>)>)> Members
Sitecore.Caching.Generics Namespace


GetCacheKeys Method

[image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)>..::..GetCacheKeys Method
Cache<(Of <(<'TKey, TData>)>)> Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Collection<TKey> GetCacheKeys()
Visual Basic
Public Function GetCacheKeys As Collection(Of TKey)
Visual C++
public:
Collection<TKey>^ GetCacheKeys()

Return Value

[Missing <returns> documentation for "M:Sitecore.Caching.Generics.Cache`2.GetCacheKeys"]

See Also

Cache<(Of <(<'TKey, TData>)>)> Class
GetCacheKeys Overload
Sitecore.Caching.Generics Namespace


GetCacheKeys Method (String)

[image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)>..::..GetCacheKeys Method (String)
Cache<(Of <(<'TKey, TData>)>)> Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Collection<TKey> GetCacheKeys(
    string keyPrefix
)
Visual Basic
Public Function GetCacheKeys ( _
    keyPrefix As String _
) As Collection(Of TKey)
Visual C++
public:
Collection<TKey>^ GetCacheKeys(
    String^ keyPrefix
)

Parameters

keyPrefix
Type: System..::..String
The key prefix.

Return Value

[Missing <returns> documentation for "M:Sitecore.Caching.Generics.Cache`2.GetCacheKeys(System.String)"]

See Also

Cache<(Of <(<'TKey, TData>)>)> Class
GetCacheKeys Overload
Sitecore.Caching.Generics Namespace


GetEntry Method

[image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)>..::..GetEntry Method
Cache<(Of <(<'TKey, TData>)>)> Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry GetEntry(
    TKey key,
    bool updateAccessed
)
Visual Basic
Public Function GetEntry ( _
    key As TKey, _
    updateAccessed As Boolean _
) As Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry
Visual C++
public:
Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry^ GetEntry(
    TKey key,
    bool updateAccessed
)

Parameters

key
Type: TKey
The key.
updateAccessed
Type: System..::..Boolean
if set to true the accessed counter is updated.

Return Value

The entry (or null).

See Also

Cache<(Of <(<'TKey, TData>)>)> Class
Sitecore.Caching.Generics Namespace


GetValue Method

[image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)>..::..GetValue Method
Cache<(Of <(<'TKey, TData>)>)> Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TData GetValue(
    TKey key
)
Visual Basic
Public Function GetValue ( _
    key As TKey _
) As TData
Visual C++
public:
TData GetValue(
    TKey key
)

Parameters

key
Type: TKey
The key.

Return Value

[Missing <returns> documentation for "M:Sitecore.Caching.Generics.Cache`2.GetValue(`0)"]

See Also

Cache<(Of <(<'TKey, TData>)>)> Class
Sitecore.Caching.Generics Namespace


ParseSizeString Method

[image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)>..::..ParseSizeString Method
Cache<(Of <(<'TKey, TData>)>)> Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long ParseSizeString(
    string value
)
Visual Basic
Public Shared Function ParseSizeString ( _
    value As String _
) As Long
Visual C++
public:
static long long ParseSizeString(
    String^ value
)

Parameters

value
Type: System..::..String
The value.

Return Value

[Missing <returns> documentation for "M:Sitecore.Caching.Generics.Cache`2.ParseSizeString(System.String)"]

See Also

Cache<(Of <(<'TKey, TData>)>)> Class
Sitecore.Caching.Generics Namespace


Remove Method

[image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)>..::..Remove Method
Cache<(Of <(<'TKey, TData>)>)> Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Remove(
    TKey key
)
Visual Basic
Public Sub Remove ( _
    key As TKey _
)
Visual C++
public:
void Remove(
    TKey key
)

Parameters

key
Type: TKey
The key.

See Also

Cache<(Of <(<'TKey, TData>)>)> Class
Sitecore.Caching.Generics Namespace


RemoveKeysContaining Method

[image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)>..::..RemoveKeysContaining Method
Cache<(Of <(<'TKey, TData>)>)> Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RemoveKeysContaining(
    string value
)
Visual Basic
Public Sub RemoveKeysContaining ( _
    value As String _
)
Visual C++
public:
void RemoveKeysContaining(
    String^ value
)

Parameters

value
Type: System..::..String
The value.

See Also

Cache<(Of <(<'TKey, TData>)>)> Class
Sitecore.Caching.Generics Namespace


RemovePrefix Method

[image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)>..::..RemovePrefix Method
Cache<(Of <(<'TKey, TData>)>)> Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RemovePrefix(
    string keyPrefix
)
Visual Basic
Public Sub RemovePrefix ( _
    keyPrefix As String _
)
Visual C++
public:
void RemovePrefix(
    String^ keyPrefix
)

Parameters

keyPrefix
Type: System..::..String
The key prefix.

See Also

Cache<(Of <(<'TKey, TData>)>)> Class
Sitecore.Caching.Generics Namespace


Scavenge Method

[image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)>..::..Scavenge Method
Cache<(Of <(<'TKey, TData>)>)> Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Scavenge()
Visual Basic
Public Sub Scavenge
Visual C++
public:
void Scavenge()

See Also

Cache<(Of <(<'TKey, TData>)>)> Class
Sitecore.Caching.Generics Namespace


Cache(TKey, TData) Properties

[image] [image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)> Properties
Cache<(Of <(<'TKey, TData>)>)> Class See Also Send Feedback

The Cache<(Of <(<'TKey, TData>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the count.
Public property | DefaultPriority | Gets or sets the default priority.
Public property | Enabled | Gets or sets a value indicating whether this Cache is enabled.
Public property | Id | Gets the id.
Public property | Item | Gets the data with the specified key.
Public property | MaxSize | Gets or sets the max size.
Public property | Name | Gets the name.
Public property | RemainingSpace | Gets the remaining space (in bytes).
Public property | Scavengable | Gets or sets a value indicating whether this Cache is scavengable.
Public property | Size | Gets the size.
Public property | SyncRoot | Gets the sync root.

See Also

Cache<(Of <(<'TKey, TData>)>)> Class
Sitecore.Caching.Generics Namespace


Count Property

[image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)>..::..Count Property
Cache<(Of <(<'TKey, TData>)>)> Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
property int Count {
    int get ();
}

Field Value

The count.

See Also

Cache<(Of <(<'TKey, TData>)>)> Class
Sitecore.Caching.Generics Namespace


DefaultPriority Property

[image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)>..::..DefaultPriority Property
Cache<(Of <(<'TKey, TData>)>)> Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CachePriority DefaultPriority { get; set; }
Visual Basic
Public Property DefaultPriority As CachePriority
    Get
    Set
Visual C++
public:
property CachePriority DefaultPriority {
    CachePriority get ();
    void set (CachePriority value);
}

Field Value

The default priority.

See Also

Cache<(Of <(<'TKey, TData>)>)> Class
Sitecore.Caching.Generics Namespace


Enabled Property

[image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)>..::..Enabled Property
Cache<(Of <(<'TKey, TData>)>)> Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Enabled { get; set; }
Visual Basic
Public Property Enabled As Boolean
    Get
    Set
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

Field Value

true if enabled; otherwise, false.

See Also

Cache<(Of <(<'TKey, TData>)>)> Class
Sitecore.Caching.Generics Namespace


Id Property

[image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)>..::..Id Property
Cache<(Of <(<'TKey, TData>)>)> Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID Id { get; }
Visual Basic
Public ReadOnly Property Id As ID
    Get
Visual C++
public:
property ID^ Id {
    ID^ get ();
}

Field Value

The id.

See Also

Cache<(Of <(<'TKey, TData>)>)> Class
Sitecore.Caching.Generics Namespace


Item Property

[image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)>..::..Item Property
Cache<(Of <(<'TKey, TData>)>)> Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TData this[
    TKey key
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    key As TKey _
) As TData
    Get
Visual C++
public:
property TData default[TKey key] {
    TData get (TKey key);
}

Parameters

key
Type: TKey

Field Value

See Also

Cache<(Of <(<'TKey, TData>)>)> Class
Sitecore.Caching.Generics Namespace


MaxSize Property

[image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)>..::..MaxSize Property
Cache<(Of <(<'TKey, TData>)>)> Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long MaxSize { get; set; }
Visual Basic
Public Property MaxSize As Long
    Get
    Set
Visual C++
public:
property long long MaxSize {
    long long get ();
    void set (long long value);
}

Field Value

The max size.

See Also

Cache<(Of <(<'TKey, TData>)>)> Class
Sitecore.Caching.Generics Namespace


Name Property

[image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)>..::..Name Property
Cache<(Of <(<'TKey, TData>)>)> Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

Cache<(Of <(<'TKey, TData>)>)> Class
Sitecore.Caching.Generics Namespace


RemainingSpace Property

[image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)>..::..RemainingSpace Property
Cache<(Of <(<'TKey, TData>)>)> Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long RemainingSpace { get; }
Visual Basic
Public ReadOnly Property RemainingSpace As Long
    Get
Visual C++
public:
property long long RemainingSpace {
    long long get ();
}

Field Value

The remaining space.

See Also

Cache<(Of <(<'TKey, TData>)>)> Class
Sitecore.Caching.Generics Namespace


Scavengable Property

[image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)>..::..Scavengable Property
Cache<(Of <(<'TKey, TData>)>)> Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Scavengable { get; set; }
Visual Basic
Public Property Scavengable As Boolean
    Get
    Set
Visual C++
public:
property bool Scavengable {
    bool get ();
    void set (bool value);
}

Field Value

true if scavengable; otherwise, false.

See Also

Cache<(Of <(<'TKey, TData>)>)> Class
Sitecore.Caching.Generics Namespace


Size Property

[image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)>..::..Size Property
Cache<(Of <(<'TKey, TData>)>)> Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long Size { get; }
Visual Basic
Public ReadOnly Property Size As Long
    Get
Visual C++
public:
property long long Size {
    long long get ();
}

Field Value

The size.

See Also

Cache<(Of <(<'TKey, TData>)>)> Class
Sitecore.Caching.Generics Namespace


SyncRoot Property

[image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)>..::..SyncRoot Property
Cache<(Of <(<'TKey, TData>)>)> Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object SyncRoot { get; }
Visual Basic
Public ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
property Object^ SyncRoot {
    Object^ get ();
}

Field Value

The sync root.

See Also

Cache<(Of <(<'TKey, TData>)>)> Class
Sitecore.Caching.Generics Namespace


Cache(TKey, TData).CacheEntry Class

[image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry Class
Cache<(Of <(<'TKey, TData>)>)> Class Members See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CacheEntry
Visual Basic
Public Class CacheEntry
Visual C++
public ref class CacheEntry

Inheritance Hierarchy

System..::..Object
Sitecore.Caching.Generics..::..Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry

See Also

Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry Members
Sitecore.Caching.Generics Namespace


Cache(TKey, TData).CacheEntry Constructor

[image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry Constructor
Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CacheEntry(
    TKey key,
    TData data,
    CachePriority priority,
    Cache<TKey, TData> cache
)
Visual Basic
Public Sub New ( _
    key As TKey, _
    data As TData, _
    priority As CachePriority, _
    cache As Cache(Of TKey, TData) _
)
Visual C++
public:
CacheEntry(
    TKey key,
    TData data,
    CachePriority priority,
    Cache<TKey, TData>^ cache
)

Parameters

key
Type: TKey
The key.
data
Type: TData
The data.
priority
Type: Sitecore.Caching..::..CachePriority
The priority.
cache
Type: Sitecore.Caching.Generics..::..Cache <(Of <(<' TKey, TData >)>)>
The cache.

See Also

Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry Class
Sitecore.Caching.Generics Namespace


Cache(TKey, TData).CacheEntry Methods

[image] [image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry Methods
Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry Class See Also Send Feedback

The Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry generic type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RaiseEntryRemoved | Raises the EntryRemoved event.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateAccessed | Updates the accessed time.

See Also

Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry Class
Sitecore.Caching.Generics Namespace


UpdateAccessed Method

[image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry..::..UpdateAccessed Method
Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void UpdateAccessed()
Visual Basic
Public Sub UpdateAccessed
Visual C++
public:
void UpdateAccessed()

See Also

Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry Class
Sitecore.Caching.Generics Namespace


Cache(TKey, TData).CacheEntry Properties

[image] [image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry Properties
Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry Class See Also Send Feedback

The Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry generic type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteExpiration | Gets or sets the sliding expiration.
Public property | Accessed | Gets the date/time where the entry was last accessed.
Public property | Data | Gets the data.
Public property | DataLength | Gets the length of the data.
Public property | Expired | Gets a value indicating whether this Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry is expired.
Public property | Key | Gets the key.
Public property | Priority | Gets the priority.
Public property | SlidingExpiration | Gets or sets the sliding expiration.

See Also

Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry Class
Sitecore.Caching.Generics Namespace


AbsoluteExpiration Property

[image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry..::..AbsoluteExpiration Property
Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime AbsoluteExpiration { get; set; }
Visual Basic
Public Property AbsoluteExpiration As DateTime
    Get
    Set
Visual C++
public:
property DateTime AbsoluteExpiration {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The sliding expiration.

See Also

Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry Class
Sitecore.Caching.Generics Namespace


Accessed Property

[image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry..::..Accessed Property
Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime Accessed { get; set; }
Visual Basic
Public Property Accessed As DateTime
    Get
    Set
Visual C++
public:
property DateTime Accessed {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The date/time of access.

See Also

Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry Class
Sitecore.Caching.Generics Namespace


Data Property

[image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry..::..Data Property
Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TData Data { get; }
Visual Basic
Public ReadOnly Property Data As TData
    Get
Visual C++
public:
property TData Data {
    TData get ();
}

Field Value

The data.

See Also

Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry Class
Sitecore.Caching.Generics Namespace


DataLength Property

[image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry..::..DataLength Property
Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long DataLength { get; }
Visual Basic
Public ReadOnly Property DataLength As Long
    Get
Visual C++
public:
property long long DataLength {
    long long get ();
}

Field Value

The length of the data.

See Also

Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry Class
Sitecore.Caching.Generics Namespace


Expired Property

[image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry..::..Expired Property
Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Expired { get; }
Visual Basic
Public ReadOnly Property Expired As Boolean
    Get
Visual C++
public:
property bool Expired {
    bool get ();
}

Field Value

true if expired; otherwise, false.

See Also

Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry Class
Sitecore.Caching.Generics Namespace


Key Property

[image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry..::..Key Property
Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TKey Key { get; }
Visual Basic
Public ReadOnly Property Key As TKey
    Get
Visual C++
public:
property TKey Key {
    TKey get ();
}

Field Value

The key.

See Also

Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry Class
Sitecore.Caching.Generics Namespace


Priority Property

[image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry..::..Priority Property
Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CachePriority Priority { get; }
Visual Basic
Public ReadOnly Property Priority As CachePriority
    Get
Visual C++
public:
property CachePriority Priority {
    CachePriority get ();
}

Field Value

The priority.

See Also

Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry Class
Sitecore.Caching.Generics Namespace


SlidingExpiration Property

[image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry..::..SlidingExpiration Property
Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TimeSpan SlidingExpiration { get; set; }
Visual Basic
Public Property SlidingExpiration As TimeSpan
    Get
    Set
Visual C++
public:
property TimeSpan SlidingExpiration {
    TimeSpan get ();
    void set (TimeSpan value);
}

Field Value

The sliding expiration.

See Also

Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry Class
Sitecore.Caching.Generics Namespace


Cache(TKey, TData).CacheEntry Events

[image] [image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry Events
Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry Class See Also Send Feedback

The Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry generic type exposes the following members.

Events

 | Name | Description
Public event | EntryRemoved |

See Also

Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry Class
Sitecore.Caching.Generics Namespace


EntryRemoved Event

[image]

Sitecore 6.4.1 API
Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry..::..EntryRemoved Event
Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler<EntryRemovedEventArgs<TKey, TData>> EntryRemoved
Visual Basic
Public Event EntryRemoved As EventHandler(Of EntryRemovedEventArgs(Of TKey, TData))
Visual C++
public:
 event EventHandler<EntryRemovedEventArgs<TKey, TData>^>^ EntryRemoved {
    void add (EventHandler<EntryRemovedEventArgs<TKey, TData>^>^ value);
    void remove (EventHandler<EntryRemovedEventArgs<TKey, TData>^>^ value);
}

See Also

Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry Class
Sitecore.Caching.Generics Namespace


CacheableRecordBase(T) Class

[image]

Sitecore 6.4.1 API
CacheableRecordBase<(Of <(<'T>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class CacheableRecordBase<T> : ICacheable
Visual Basic
Public MustInherit Class CacheableRecordBase(Of T) _
    Implements ICacheable
Visual C++
generic<typename T>
public ref class CacheableRecordBase abstract : ICacheable

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Sitecore.Caching.Generics.CacheableRecordBase`1"]

Inheritance Hierarchy

System..::..Object
Sitecore.Caching.Generics..::..CacheableRecordBase<(Of <(<'T>)>)>
Sitecore.Caching.IsUserInRole..::..IsUserInRoleCacheRecord
Sitecore.Caching.UserProfile..::..UserProfileCacheRecord
Sitecore.Security.AccessControl..::..AccessResultCacheRecord

See Also

CacheableRecordBase<(Of <(<'T>)>)> Members
Sitecore.Caching.Generics Namespace


CacheableRecordBase(T) Members

[image] [image]

Sitecore 6.4.1 API
CacheableRecordBase<(Of <(<'T>)>)> Members
CacheableRecordBase<(Of <(<'T>)>)> Class Constructors Methods Properties Events See Also Send Feedback

The CacheableRecordBase<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Protected method | CacheableRecordBase<(Of <(<'T>)>)> | Initializes a new instance of the CacheableRecordBase<(Of <(<'T>)>)> class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDataLength | Gets the size of the data to use when caching.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDataLengthChanged | Length of the data changed
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cacheable | Gets or sets a value indicating whether this ICacheable is cacheable.
Public property | Immutable | Gets a value indicating whether this ICacheable is immutable.
Public property | Value | Cached value

Events

 | Name | Description
Public event | DataLengthChanged | Length of the data changed

See Also

CacheableRecordBase<(Of <(<'T>)>)> Class
Sitecore.Caching.Generics Namespace


CacheableRecordBase(T) Constructor

[image]

Sitecore 6.4.1 API
CacheableRecordBase<(Of <(<'T>)>)> Constructor
CacheableRecordBase<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected CacheableRecordBase()
Visual Basic
Protected Sub New
Visual C++
protected:
CacheableRecordBase()

See Also

CacheableRecordBase<(Of <(<'T>)>)> Class
Sitecore.Caching.Generics Namespace


CacheableRecordBase(T) Methods

[image] [image]

Sitecore 6.4.1 API
CacheableRecordBase<(Of <(<'T>)>)> Methods
CacheableRecordBase<(Of <(<'T>)>)> Class See Also Send Feedback

The CacheableRecordBase<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDataLength | Gets the size of the data to use when caching.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDataLengthChanged | Length of the data changed
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CacheableRecordBase<(Of <(<'T>)>)> Class
Sitecore.Caching.Generics Namespace


GetDataLength Method

[image]

Sitecore 6.4.1 API
CacheableRecordBase<(Of <(<'T>)>)>..::..GetDataLength Method
CacheableRecordBase<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract long GetDataLength()
Visual Basic
Public MustOverride Function GetDataLength As Long
Visual C++
public:
virtual long long GetDataLength() abstract

Return Value

[Missing <returns> documentation for "M:Sitecore.Caching.Generics.CacheableRecordBase`1.GetDataLength"]

Implements

ICacheable..::..GetDataLength()()()()

See Also

CacheableRecordBase<(Of <(<'T>)>)> Class
Sitecore.Caching.Generics Namespace


OnDataLengthChanged Method

[image]

Sitecore 6.4.1 API
CacheableRecordBase<(Of <(<'T>)>)>..::..OnDataLengthChanged Method
CacheableRecordBase<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void OnDataLengthChanged()
Visual Basic
Protected Sub OnDataLengthChanged
Visual C++
protected:
void OnDataLengthChanged()

See Also

CacheableRecordBase<(Of <(<'T>)>)> Class
Sitecore.Caching.Generics Namespace


Cacheable Property

[image]

Sitecore 6.4.1 API
CacheableRecordBase<(Of <(<'T>)>)>..::..Cacheable Property
CacheableRecordBase<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool Cacheable { get; set; }
Visual Basic
Public Overridable Property Cacheable As Boolean
    Get
    Set
Visual C++
public:
virtual property bool Cacheable {
    bool get ();
    void set (bool value);
}

Field Value

true if cacheable; otherwise, false.

Implements

ICacheable..::..Cacheable

See Also

CacheableRecordBase<(Of <(<'T>)>)> Class
Sitecore.Caching.Generics Namespace


Value Property

[image]

Sitecore 6.4.1 API
CacheableRecordBase<(Of <(<'T>)>)>..::..Value Property
CacheableRecordBase<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public T Value { get; set; }
Visual Basic
Public Property Value As T
    Get
    Set
Visual C++
public:
property T Value {
    T get ();
    void set (T value);
}

See Also

CacheableRecordBase<(Of <(<'T>)>)> Class
Sitecore.Caching.Generics Namespace


CacheableRecordBase(T) Events

[image] [image]

Sitecore 6.4.1 API
CacheableRecordBase<(Of <(<'T>)>)> Events
CacheableRecordBase<(Of <(<'T>)>)> Class See Also Send Feedback

The CacheableRecordBase<(Of <(<'T>)>)> type exposes the following members.

Events

 | Name | Description
Public event | DataLengthChanged | Length of the data changed

See Also

CacheableRecordBase<(Of <(<'T>)>)> Class
Sitecore.Caching.Generics Namespace


DataLengthChanged Event

[image]

Sitecore 6.4.1 API
CacheableRecordBase<(Of <(<'T>)>)>..::..DataLengthChanged Event
CacheableRecordBase<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event DataLengthChangedDelegate DataLengthChanged
Visual Basic
Public Event DataLengthChanged As DataLengthChangedDelegate
Visual C++
public:
virtual  event DataLengthChangedDelegate^ DataLengthChanged {
    void add (DataLengthChangedDelegate^ value);
    void remove (DataLengthChangedDelegate^ value);
}

Implements

ICacheable..::..DataLengthChanged

See Also

CacheableRecordBase<(Of <(<'T>)>)> Class
Sitecore.Caching.Generics Namespace


EntryRemovedEventArgs(TKey, TData) Members

[image] [image]

Sitecore 6.4.1 API
EntryRemovedEventArgs<(Of <(<'TKey, TData>)>)> Members
EntryRemovedEventArgs<(Of <(<'TKey, TData>)>)> Class Constructors Methods Properties See Also Send Feedback

The EntryRemovedEventArgs<(Of <(<'TKey, TData>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | EntryRemovedEventArgs<(Of <(<'TKey, TData>)>)> | Initializes a new instance of the EntryRemovedEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Entry | Gets the entry that triggered the evtn.

See Also

EntryRemovedEventArgs<(Of <(<'TKey, TData>)>)> Class
Sitecore.Caching.Generics Namespace


EntryRemovedEventArgs(TKey, TData) Constructor

[image]

Sitecore 6.4.1 API
EntryRemovedEventArgs<(Of <(<'TKey, TData>)>)> Constructor
EntryRemovedEventArgs<(Of <(<'TKey, TData>)>)> Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public EntryRemovedEventArgs(
    Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry entry
)
Visual Basic
Public Sub New ( _
    entry As Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry _
)
Visual C++
public:
EntryRemovedEventArgs(
    Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry^ entry
)

Parameters

entry
Type: Sitecore.Caching.Generics..::..Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry

[Missing <param name="entry"/> documentation for "M:Sitecore.Caching.Generics.EntryRemovedEventArgs`2.#ctor(Sitecore.Caching.Generics.Cache{`0,`1}.CacheEntry)"]

See Also

EntryRemovedEventArgs<(Of <(<'TKey, TData>)>)> Class
Sitecore.Caching.Generics Namespace


EntryRemovedEventArgs(TKey, TData) Methods

[image] [image]

Sitecore 6.4.1 API
EntryRemovedEventArgs<(Of <(<'TKey, TData>)>)> Methods
EntryRemovedEventArgs<(Of <(<'TKey, TData>)>)> Class See Also Send Feedback

The EntryRemovedEventArgs<(Of <(<'TKey, TData>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EntryRemovedEventArgs<(Of <(<'TKey, TData>)>)> Class
Sitecore.Caching.Generics Namespace


EntryRemovedEventArgs(TKey, TData) Properties

[image] [image]

Sitecore 6.4.1 API
EntryRemovedEventArgs<(Of <(<'TKey, TData>)>)> Properties
EntryRemovedEventArgs<(Of <(<'TKey, TData>)>)> Class See Also Send Feedback

The EntryRemovedEventArgs<(Of <(<'TKey, TData>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Entry | Gets the entry that triggered the evtn.

See Also

EntryRemovedEventArgs<(Of <(<'TKey, TData>)>)> Class
Sitecore.Caching.Generics Namespace


Entry Property

[image]

Sitecore 6.4.1 API
EntryRemovedEventArgs<(Of <(<'TKey, TData>)>)>..::..Entry Property
EntryRemovedEventArgs<(Of <(<'TKey, TData>)>)> Class See Also Send Feedback

Namespace: Sitecore.Caching.Generics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry Entry { get; }
Visual Basic
Public ReadOnly Property Entry As Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry
    Get
Visual C++
public:
property Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry^ Entry {
    Cache<(Of <(<'TKey, TData>)>)>..::..CacheEntry^ get ();
}

Field Value

The entry.

See Also

EntryRemovedEventArgs<(Of <(<'TKey, TData>)>)> Class
Sitecore.Caching.Generics Namespace


Sitecore.Caching.IsUserInRole Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Caching.IsUserInRole Namespace
Send Feedback

Classes

 | Class | Description
Public class | IsUserInRoleCache | Represents IsUserInRoleCache
Public class | IsUserInRoleCacheRecord | Is user is role value


IsUserInRoleCache Class

[image]

Sitecore 6.4.1 API
IsUserInRoleCache Class
Members See Also Send Feedback

Namespace: Sitecore.Caching.IsUserInRole
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class IsUserInRoleCache : CustomCache
Visual Basic
Public Class IsUserInRoleCache _
    Inherits CustomCache
Visual C++
public ref class IsUserInRoleCache : public CustomCache

Inheritance Hierarchy

System..::..Object
Sitecore.Caching..::..CustomCache
Sitecore.Caching.IsUserInRole..::..IsUserInRoleCache

See Also

IsUserInRoleCache Members
Sitecore.Caching.IsUserInRole Namespace


IsUserInRoleCache Members

[image] [image]

Sitecore 6.4.1 API
IsUserInRoleCache Members
IsUserInRoleCache Class Constructors Methods Properties See Also Send Feedback

The IsUserInRoleCache type exposes the following members.

Constructors

 | Name | Description
Public method | IsUserInRoleCache | Initializes a new instance of the IsUserInRoleCache class.

Methods

 | Name | Description
Public method | AddRecord(String, String, Boolean) | Obsolete. Add combination to cache.
Public method | AddRecord(String, String, Boolean, Boolean) | Adds the record.
Public method | Clear | Clears this instance. (Inherited from CustomCache.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetID | Gets the ID. (Inherited from CustomCache.)
Protected method | GetObject | Gets the object. (Inherited from CustomCache.)
Public method | GetRecord(String, String) | Obsolete. Gets the is in role.
Public method | GetRecord(String, String, Boolean) | Gets the record.
Protected method | GetString | Gets the string. (Inherited from CustomCache.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Remove | Removes the specified key. (Inherited from CustomCache.)
Public method | RemoveKeysContaining | Removes the keys containing. (Inherited from CustomCache.)
Public method | RemovePrefix | Removes entries with keys starting with the specified prefix. (Inherited from CustomCache.)
Public method | RemoveUser | Clears the cache for specified user name.
Protected method | SetID | Sets the ID. (Inherited from CustomCache.)
Protected method | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Sets the object. (Inherited from CustomCache.)
Protected method | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
Protected method | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether this CustomCache is enabled. (Inherited from CustomCache.)
Public property | InnerCache | Gets the inner cache. (Inherited from CustomCache.)
Public property | Name | Gets the name. (Inherited from CustomCache.)

See Also

IsUserInRoleCache Class
Sitecore.Caching.IsUserInRole Namespace


IsUserInRoleCache Constructor

[image]

Sitecore 6.4.1 API
IsUserInRoleCache Constructor
IsUserInRoleCache Class See Also Send Feedback

Namespace: Sitecore.Caching.IsUserInRole
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IsUserInRoleCache(
    long maxSize
)
Visual Basic
Public Sub New ( _
    maxSize As Long _
)
Visual C++
public:
IsUserInRoleCache(
    long long maxSize
)

Parameters

maxSize
Type: System..::..Int64
Size of the max.

See Also

IsUserInRoleCache Class
Sitecore.Caching.IsUserInRole Namespace


IsUserInRoleCache Methods

[image] [image]

Sitecore 6.4.1 API
IsUserInRoleCache Methods
IsUserInRoleCache Class See Also Send Feedback

The IsUserInRoleCache type exposes the following members.

Methods

 | Name | Description
Public method | AddRecord(String, String, Boolean) | Obsolete. Add combination to cache.
Public method | AddRecord(String, String, Boolean, Boolean) | Adds the record.
Public method | Clear | Clears this instance. (Inherited from CustomCache.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetID | Gets the ID. (Inherited from CustomCache.)
Protected method | GetObject | Gets the object. (Inherited from CustomCache.)
Public method | GetRecord(String, String) | Obsolete. Gets the is in role.
Public method | GetRecord(String, String, Boolean) | Gets the record.
Protected method | GetString | Gets the string. (Inherited from CustomCache.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Remove | Removes the specified key. (Inherited from CustomCache.)
Public method | RemoveKeysContaining | Removes the keys containing. (Inherited from CustomCache.)
Public method | RemovePrefix | Removes entries with keys starting with the specified prefix. (Inherited from CustomCache.)
Public method | RemoveUser | Clears the cache for specified user name.
Protected method | SetID | Sets the ID. (Inherited from CustomCache.)
Protected method | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Sets the object. (Inherited from CustomCache.)
Protected method | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
Protected method | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IsUserInRoleCache Class
Sitecore.Caching.IsUserInRole Namespace


AddRecord Method

[image] [image]

Sitecore 6.4.1 API
IsUserInRoleCache..::..AddRecord Method
IsUserInRoleCache Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddRecord(String, String, Boolean) | Obsolete. Add combination to cache.
Public method | AddRecord(String, String, Boolean, Boolean) | Adds the record.

See Also

IsUserInRoleCache Class
IsUserInRoleCache Members
Sitecore.Caching.IsUserInRole Namespace


AddRecord Method (String, String, Boolean)

[image]

Sitecore 6.4.1 API
IsUserInRoleCache..::..AddRecord Method (String, String, Boolean)
IsUserInRoleCache Class See Also Send Feedback

Namespace: Sitecore.Caching.IsUserInRole
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use AddRecord(string roleName, string accountName, bool isInRole, bool includeIndirectMemberships) instead")]
public void AddRecord(
    string roleName,
    string accountName,
    bool isInRole
)
Visual Basic
<ObsoleteAttribute("Use AddRecord(string roleName, string accountName, bool isInRole, bool includeIndirectMemberships) instead")> _
Public Sub AddRecord ( _
    roleName As String, _
    accountName As String, _
    isInRole As Boolean _
)
Visual C++
[ObsoleteAttribute(L"Use AddRecord(string roleName, string accountName, bool isInRole, bool includeIndirectMemberships) instead")]
public:
void AddRecord(
    String^ roleName,
    String^ accountName,
    bool isInRole
)

Parameters

roleName
Type: System..::..String
Name of the role.
accountName
Type: System..::..String
Name of the account.
isInRole
Type: System..::..Boolean
if set to true this instance is is in role.

See Also

IsUserInRoleCache Class
AddRecord Overload
Sitecore.Caching.IsUserInRole Namespace


AddRecord Method (String, String, Boolean, Boolean)

[image]

Sitecore 6.4.1 API
IsUserInRoleCache..::..AddRecord Method (String, String, Boolean, Boolean)
IsUserInRoleCache Class See Also Send Feedback

Namespace: Sitecore.Caching.IsUserInRole
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddRecord(
    string roleName,
    string accountName,
    bool isInRole,
    bool includeIndirectMemberships
)
Visual Basic
Public Sub AddRecord ( _
    roleName As String, _
    accountName As String, _
    isInRole As Boolean, _
    includeIndirectMemberships As Boolean _
)
Visual C++
public:
void AddRecord(
    String^ roleName,
    String^ accountName,
    bool isInRole,
    bool includeIndirectMemberships
)

Parameters

roleName
Type: System..::..String
Name of the role.
accountName
Type: System..::..String
Name of the account.
isInRole
Type: System..::..Boolean
if set to true then account is in role.
includeIndirectMemberships
Type: System..::..Boolean
if set to true include indirect memberships.

See Also

IsUserInRoleCache Class
AddRecord Overload
Sitecore.Caching.IsUserInRole Namespace


GetRecord Method

[image] [image]

Sitecore 6.4.1 API
IsUserInRoleCache..::..GetRecord Method
IsUserInRoleCache Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRecord(String, String) | Obsolete. Gets the is in role.
Public method | GetRecord(String, String, Boolean) | Gets the record.

See Also

IsUserInRoleCache Class
IsUserInRoleCache Members
Sitecore.Caching.IsUserInRole Namespace


GetRecord Method (String, String)

[image]

Sitecore 6.4.1 API
IsUserInRoleCache..::..GetRecord Method (String, String)
IsUserInRoleCache Class See Also Send Feedback

Namespace: Sitecore.Caching.IsUserInRole
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use GetRecord(string roleName, string accountName, bool includeIndirectMemberships) instead")]
public IsUserInRoleCacheRecord GetRecord(
    string roleName,
    string accountName
)
Visual Basic
<ObsoleteAttribute("Use GetRecord(string roleName, string accountName, bool includeIndirectMemberships) instead")> _
Public Function GetRecord ( _
    roleName As String, _
    accountName As String _
) As IsUserInRoleCacheRecord
Visual C++
[ObsoleteAttribute(L"Use GetRecord(string roleName, string accountName, bool includeIndirectMemberships) instead")]
public:
IsUserInRoleCacheRecord^ GetRecord(
    String^ roleName,
    String^ accountName
)

Parameters

roleName
Type: System..::..String
Name of the role.
accountName
Type: System..::..String
Name of the account. Could be Role or User

Return Value

The is in role.

See Also

IsUserInRoleCache Class
GetRecord Overload
Sitecore.Caching.IsUserInRole Namespace


GetRecord Method (String, String, Boolean)

[image]

Sitecore 6.4.1 API
IsUserInRoleCache..::..GetRecord Method (String, String, Boolean)
IsUserInRoleCache Class See Also Send Feedback

Namespace: Sitecore.Caching.IsUserInRole
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IsUserInRoleCacheRecord GetRecord(
    string roleName,
    string accountName,
    bool includeIndirectMemberships
)
Visual Basic
Public Function GetRecord ( _
    roleName As String, _
    accountName As String, _
    includeIndirectMemberships As Boolean _
) As IsUserInRoleCacheRecord
Visual C++
public:
IsUserInRoleCacheRecord^ GetRecord(
    String^ roleName,
    String^ accountName,
    bool includeIndirectMemberships
)

Parameters

roleName
Type: System..::..String
Name of the role.
accountName
Type: System..::..String
Name of the account.
includeIndirectMemberships
Type: System..::..Boolean
if set to true [include indirect memberships].

Return Value

The record.

See Also

IsUserInRoleCache Class
GetRecord Overload
Sitecore.Caching.IsUserInRole Namespace


SetObject Method

[image] [image]

Sitecore 6.4.1 API
IsUserInRoleCache..::..SetObject Method
IsUserInRoleCache Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Sets the object. (Inherited from CustomCache.)

See Also

IsUserInRoleCache Class
IsUserInRoleCache Members
Sitecore.Caching.IsUserInRole Namespace


SetString Method

[image] [image]

Sitecore 6.4.1 API
IsUserInRoleCache..::..SetString Method
IsUserInRoleCache Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
Protected method | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)

See Also

IsUserInRoleCache Class
IsUserInRoleCache Members
Sitecore.Caching.IsUserInRole Namespace


IsUserInRoleCache Properties

[image] [image]

Sitecore 6.4.1 API
IsUserInRoleCache Properties
IsUserInRoleCache Class See Also Send Feedback

The IsUserInRoleCache type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether this CustomCache is enabled. (Inherited from CustomCache.)
Public property | InnerCache | Gets the inner cache. (Inherited from CustomCache.)
Public property | Name | Gets the name. (Inherited from CustomCache.)

See Also

IsUserInRoleCache Class
Sitecore.Caching.IsUserInRole Namespace


IsUserInRoleCacheRecord Class

[image]

Sitecore 6.4.1 API
IsUserInRoleCacheRecord Class
Members See Also Send Feedback

Namespace: Sitecore.Caching.IsUserInRole
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class IsUserInRoleCacheRecord : CacheableRecordBase<bool>
Visual Basic
Public Class IsUserInRoleCacheRecord _
    Inherits CacheableRecordBase(Of Boolean)
Visual C++
public ref class IsUserInRoleCacheRecord : public CacheableRecordBase<bool>

Inheritance Hierarchy

System..::..Object
Sitecore.Caching.Generics..::..CacheableRecordBase <(Of <(<' Boolean >)>)>
Sitecore.Caching.IsUserInRole..::..IsUserInRoleCacheRecord

See Also

IsUserInRoleCacheRecord Members
Sitecore.Caching.IsUserInRole Namespace


IsUserInRoleCacheRecord Members

[image] [image]

Sitecore 6.4.1 API
IsUserInRoleCacheRecord Members
IsUserInRoleCacheRecord Class Constructors Methods Properties Events See Also Send Feedback

The IsUserInRoleCacheRecord type exposes the following members.

Constructors

 | Name | Description
Public method | IsUserInRoleCacheRecord | Initializes a new instance of the IsUserInRoleCacheRecord class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDataLength | Gets the size of the data to use when caching. (Overrides CacheableRecordBase<(Of <(<'T>)>)>..::..GetDataLength()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDataLengthChanged | Length of the data changed (Inherited from CacheableRecordBase<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cacheable | Gets or sets a value indicating whether this ICacheable is cacheable. (Inherited from CacheableRecordBase<(Of <(<'T>)>)>.)
Public property | Immutable | Gets a value indicating whether this ICacheable is immutable. (Inherited from CacheableRecordBase<(Of <(<'T>)>)>.)
Public property | Value | Cached value (Inherited from CacheableRecordBase<(Of <(<'T>)>)>.)

Events

 | Name | Description
Public event | DataLengthChanged | Length of the data changed (Inherited from CacheableRecordBase<(Of <(<'T>)>)>.)

See Also

IsUserInRoleCacheRecord Class
Sitecore.Caching.IsUserInRole Namespace


IsUserInRoleCacheRecord Constructor

[image]

Sitecore 6.4.1 API
IsUserInRoleCacheRecord Constructor
IsUserInRoleCacheRecord Class See Also Send Feedback

Namespace: Sitecore.Caching.IsUserInRole
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IsUserInRoleCacheRecord()
Visual Basic
Public Sub New
Visual C++
public:
IsUserInRoleCacheRecord()

See Also

IsUserInRoleCacheRecord Class
Sitecore.Caching.IsUserInRole Namespace


IsUserInRoleCacheRecord Methods

[image] [image]

Sitecore 6.4.1 API
IsUserInRoleCacheRecord Methods
IsUserInRoleCacheRecord Class See Also Send Feedback

The IsUserInRoleCacheRecord type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDataLength | Gets the size of the data to use when caching. (Overrides CacheableRecordBase<(Of <(<'T>)>)>..::..GetDataLength()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDataLengthChanged | Length of the data changed (Inherited from CacheableRecordBase<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IsUserInRoleCacheRecord Class
Sitecore.Caching.IsUserInRole Namespace


GetDataLength Method

[image]

Sitecore 6.4.1 API
IsUserInRoleCacheRecord..::..GetDataLength Method
IsUserInRoleCacheRecord Class See Also Send Feedback

Namespace: Sitecore.Caching.IsUserInRole
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override long GetDataLength()
Visual Basic
Public Overrides Function GetDataLength As Long
Visual C++
public:
virtual long long GetDataLength() override

Return Value

[Missing <returns> documentation for "M:Sitecore.Caching.IsUserInRole.IsUserInRoleCacheRecord.GetDataLength"]

Implements

ICacheable..::..GetDataLength()()()()

See Also

IsUserInRoleCacheRecord Class
Sitecore.Caching.IsUserInRole Namespace


IsUserInRoleCacheRecord Properties

[image] [image]

Sitecore 6.4.1 API
IsUserInRoleCacheRecord Properties
IsUserInRoleCacheRecord Class See Also Send Feedback

The IsUserInRoleCacheRecord type exposes the following members.

Properties

 | Name | Description
Public property | Cacheable | Gets or sets a value indicating whether this ICacheable is cacheable. (Inherited from CacheableRecordBase<(Of <(<'T>)>)>.)
Public property | Immutable | Gets a value indicating whether this ICacheable is immutable. (Inherited from CacheableRecordBase<(Of <(<'T>)>)>.)
Public property | Value | Cached value (Inherited from CacheableRecordBase<(Of <(<'T>)>)>.)

See Also

IsUserInRoleCacheRecord Class
Sitecore.Caching.IsUserInRole Namespace


IsUserInRoleCacheRecord Events

[image] [image]

Sitecore 6.4.1 API
IsUserInRoleCacheRecord Events
IsUserInRoleCacheRecord Class See Also Send Feedback

The IsUserInRoleCacheRecord type exposes the following members.

Events

 | Name | Description
Public event | DataLengthChanged | Length of the data changed (Inherited from CacheableRecordBase<(Of <(<'T>)>)>.)

See Also

IsUserInRoleCacheRecord Class
Sitecore.Caching.IsUserInRole Namespace


Sitecore.Caching.UserProfile Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Caching.UserProfile Namespace
Send Feedback

Classes

 | Class | Description
Public class | UserProfileCache | Represents UserProfileCache
Public class | UserProfileCacheRecord | User profile cache record


UserProfileCache Class

[image]

Sitecore 6.4.1 API
UserProfileCache Class
Members See Also Send Feedback

Namespace: Sitecore.Caching.UserProfile
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class UserProfileCache : CustomCache
Visual Basic
Public Class UserProfileCache _
    Inherits CustomCache
Visual C++
public ref class UserProfileCache : public CustomCache

Inheritance Hierarchy

System..::..Object
Sitecore.Caching..::..CustomCache
Sitecore.Caching.UserProfile..::..UserProfileCache

See Also

UserProfileCache Members
Sitecore.Caching.UserProfile Namespace


UserProfileCache Members

[image] [image]

Sitecore 6.4.1 API
UserProfileCache Members
UserProfileCache Class Constructors Methods Properties See Also Send Feedback

The UserProfileCache type exposes the following members.

Constructors

 | Name | Description
Public method | UserProfileCache | Initializes a new instance of the UserProfileCache class.

Methods

 | Name | Description
Public method | AddRecord | Adds the specified user profile to cache.
Public method | Clear | Clears this instance. (Inherited from CustomCache.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetID | Gets the ID. (Inherited from CustomCache.)
Protected method | GetObject | Gets the object. (Inherited from CustomCache.)
Public method | GetRecord | Gets the property value.
Protected method | GetString | Gets the string. (Inherited from CustomCache.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Remove | Removes the specified key. (Inherited from CustomCache.)
Public method | RemoveKeysContaining | Removes the keys containing. (Inherited from CustomCache.)
Public method | RemovePrefix | Removes entries with keys starting with the specified prefix. (Inherited from CustomCache.)
Public method | RemoveUser | Removes the user from cache.
Protected method | SetID | Sets the ID. (Inherited from CustomCache.)
Protected method | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Sets the object. (Inherited from CustomCache.)
Protected method | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
Protected method | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether this CustomCache is enabled. (Inherited from CustomCache.)
Public property | InnerCache | Gets the inner cache. (Inherited from CustomCache.)
Public property | Name | Gets the name. (Inherited from CustomCache.)

See Also

UserProfileCache Class
Sitecore.Caching.UserProfile Namespace


UserProfileCache Constructor

[image]

Sitecore 6.4.1 API
UserProfileCache Constructor
UserProfileCache Class See Also Send Feedback

Namespace: Sitecore.Caching.UserProfile
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UserProfileCache(
    long maxSize
)
Visual Basic
Public Sub New ( _
    maxSize As Long _
)
Visual C++
public:
UserProfileCache(
    long long maxSize
)

Parameters

maxSize
Type: System..::..Int64
Size of the max.

See Also

UserProfileCache Class
Sitecore.Caching.UserProfile Namespace


UserProfileCache Methods

[image] [image]

Sitecore 6.4.1 API
UserProfileCache Methods
UserProfileCache Class See Also Send Feedback

The UserProfileCache type exposes the following members.

Methods

 | Name | Description
Public method | AddRecord | Adds the specified user profile to cache.
Public method | Clear | Clears this instance. (Inherited from CustomCache.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetID | Gets the ID. (Inherited from CustomCache.)
Protected method | GetObject | Gets the object. (Inherited from CustomCache.)
Public method | GetRecord | Gets the property value.
Protected method | GetString | Gets the string. (Inherited from CustomCache.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Remove | Removes the specified key. (Inherited from CustomCache.)
Public method | RemoveKeysContaining | Removes the keys containing. (Inherited from CustomCache.)
Public method | RemovePrefix | Removes entries with keys starting with the specified prefix. (Inherited from CustomCache.)
Public method | RemoveUser | Removes the user from cache.
Protected method | SetID | Sets the ID. (Inherited from CustomCache.)
Protected method | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Sets the object. (Inherited from CustomCache.)
Protected method | SetString(String, String) | Sets the string. (Inherited from CustomCache.)
Protected method | SetString(String, String, DateTime) | Sets the string. (Inherited from CustomCache.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UserProfileCache Class
Sitecore.Caching.UserProfile Namespace


AddRecord Method

[image]

Sitecore 6.4.1 API
UserProfileCache..::..AddRecord Method
UserProfileCache Class See Also Send Feedback

Namespace: Sitecore.Caching.UserProfile
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddRecord(
    string userName,
    string propertyName,
    Object propertyValue
)
Visual Basic
Public Sub AddRecord ( _
    userName As String, _
    propertyName As String, _
    propertyValue As Object _
)
Visual C++
public:
void AddRecord(
    String^ userName,
    String^ propertyName,
    Object^ propertyValue
)

Parameters

userName
Type: System..::..String
Name of the user.
propertyName
Type: System..::..String
Name of the property.
propertyValue
Type: System..::..Object
The property value.

See Also

UserProfileCache Class
Sitecore.Caching.UserProfile Namespace


GetRecord Method

[image]

Sitecore 6.4.1 API
UserProfileCache..::..GetRecord Method
UserProfileCache Class See Also Send Feedback

Namespace: Sitecore.Caching.UserProfile
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UserProfileCacheRecord GetRecord(
    string userName,
    string propertyName
)
Visual Basic
Public Function GetRecord ( _
    userName As String, _
    propertyName As String _
) As UserProfileCacheRecord
Visual C++
public:
UserProfileCacheRecord^ GetRecord(
    String^ userName,
    String^ propertyName
)

Parameters

userName
Type: System..::..String
Name of the user.
propertyName
Type: System..::..String
Name of the property.

Return Value

The property value.

See Also

UserProfileCache Class
Sitecore.Caching.UserProfile Namespace


RemoveUser Method

[image]

Sitecore 6.4.1 API
UserProfileCache..::..RemoveUser Method
UserProfileCache Class See Also Send Feedback

Namespace: Sitecore.Caching.UserProfile
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RemoveUser(
    string userName
)
Visual Basic
Public Sub RemoveUser ( _
    userName As String _
)
Visual C++
public:
void RemoveUser(
    String^ userName
)

Parameters

userName
Type: System..::..String
Name of the user.

See Also

UserProfileCache Class
Sitecore.Caching.UserProfile Namespace


SetObject Method

[image] [image]

Sitecore 6.4.1 API
UserProfileCache..::..SetObject Method
UserProfileCache Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SetObject(String, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, ICacheable) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(Object, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(ID, Object, Int64) | Sets the object. (Inherited from CustomCache.)
Protected method | SetObject(String, Object, Int64, EventHandler<(Of <<'(EntryRemovedEventArgs>)>>)) | Sets the object. (Inherited from CustomCache.)

See Also

UserProfileCache Class
UserProfileCache Members
Sitecore.Caching.UserProfile Namespace


UserProfileCache Properties

[image] [image]

Sitecore 6.4.1 API
UserProfileCache Properties
UserProfileCache Class See Also Send Feedback

The UserProfileCache type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether this CustomCache is enabled. (Inherited from CustomCache.)
Public property | InnerCache | Gets the inner cache. (Inherited from CustomCache.)
Public property | Name | Gets the name. (Inherited from CustomCache.)

See Also

UserProfileCache Class
Sitecore.Caching.UserProfile Namespace


UserProfileCacheRecord Class

[image]

Sitecore 6.4.1 API
UserProfileCacheRecord Class
Members See Also Send Feedback

Namespace: Sitecore.Caching.UserProfile
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class UserProfileCacheRecord : CacheableRecordBase<Object>
Visual Basic
Public Class UserProfileCacheRecord _
    Inherits CacheableRecordBase(Of Object)
Visual C++
public ref class UserProfileCacheRecord : public CacheableRecordBase<Object^>

Inheritance Hierarchy

System..::..Object
Sitecore.Caching.Generics..::..CacheableRecordBase <(Of <(<' Object >)>)>
Sitecore.Caching.UserProfile..::..UserProfileCacheRecord

See Also

UserProfileCacheRecord Members
Sitecore.Caching.UserProfile Namespace


UserProfileCacheRecord Members

[image] [image]

Sitecore 6.4.1 API
UserProfileCacheRecord Members
UserProfileCacheRecord Class Constructors Methods Properties Events See Also Send Feedback

The UserProfileCacheRecord type exposes the following members.

Constructors

 | Name | Description
Public method | UserProfileCacheRecord | Initializes a new instance of the UserProfileCacheRecord class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDataLength | Gets the size of the data to use when caching. (Overrides CacheableRecordBase<(Of <(<'T>)>)>..::..GetDataLength()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDataLengthChanged | Length of the data changed (Inherited from CacheableRecordBase<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cacheable | Gets or sets a value indicating whether this ICacheable is cacheable. (Inherited from CacheableRecordBase<(Of <(<'T>)>)>.)
Public property | Immutable | Gets a value indicating whether this ICacheable is immutable. (Inherited from CacheableRecordBase<(Of <(<'T>)>)>.)
Public property | Value | Cached value (Inherited from CacheableRecordBase<(Of <(<'T>)>)>.)

Events

 | Name | Description
Public event | DataLengthChanged | Length of the data changed (Inherited from CacheableRecordBase<(Of <(<'T>)>)>.)

See Also

UserProfileCacheRecord Class
Sitecore.Caching.UserProfile Namespace


UserProfileCacheRecord Constructor

[image]

Sitecore 6.4.1 API
UserProfileCacheRecord Constructor
UserProfileCacheRecord Class See Also Send Feedback

Namespace: Sitecore.Caching.UserProfile
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UserProfileCacheRecord()
Visual Basic
Public Sub New
Visual C++
public:
UserProfileCacheRecord()

See Also

UserProfileCacheRecord Class
Sitecore.Caching.UserProfile Namespace


UserProfileCacheRecord Methods

[image] [image]

Sitecore 6.4.1 API
UserProfileCacheRecord Methods
UserProfileCacheRecord Class See Also Send Feedback

The UserProfileCacheRecord type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDataLength | Gets the size of the data to use when caching. (Overrides CacheableRecordBase<(Of <(<'T>)>)>..::..GetDataLength()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDataLengthChanged | Length of the data changed (Inherited from CacheableRecordBase<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UserProfileCacheRecord Class
Sitecore.Caching.UserProfile Namespace


GetDataLength Method

[image]

Sitecore 6.4.1 API
UserProfileCacheRecord..::..GetDataLength Method
UserProfileCacheRecord Class See Also Send Feedback

Namespace: Sitecore.Caching.UserProfile
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override long GetDataLength()
Visual Basic
Public Overrides Function GetDataLength As Long
Visual C++
public:
virtual long long GetDataLength() override

Return Value

[Missing <returns> documentation for "M:Sitecore.Caching.UserProfile.UserProfileCacheRecord.GetDataLength"]

Implements

ICacheable..::..GetDataLength()()()()

See Also

UserProfileCacheRecord Class
Sitecore.Caching.UserProfile Namespace


UserProfileCacheRecord Properties

[image] [image]

Sitecore 6.4.1 API
UserProfileCacheRecord Properties
UserProfileCacheRecord Class See Also Send Feedback

The UserProfileCacheRecord type exposes the following members.

Properties

 | Name | Description
Public property | Cacheable | Gets or sets a value indicating whether this ICacheable is cacheable. (Inherited from CacheableRecordBase<(Of <(<'T>)>)>.)
Public property | Immutable | Gets a value indicating whether this ICacheable is immutable. (Inherited from CacheableRecordBase<(Of <(<'T>)>)>.)
Public property | Value | Cached value (Inherited from CacheableRecordBase<(Of <(<'T>)>)>.)

See Also

UserProfileCacheRecord Class
Sitecore.Caching.UserProfile Namespace


UserProfileCacheRecord Events

[image] [image]

Sitecore 6.4.1 API
UserProfileCacheRecord Events
UserProfileCacheRecord Class See Also Send Feedback

The UserProfileCacheRecord type exposes the following members.

Events

 | Name | Description
Public event | DataLengthChanged | Length of the data changed (Inherited from CacheableRecordBase<(Of <(<'T>)>)>.)

See Also

UserProfileCacheRecord Class
Sitecore.Caching.UserProfile Namespace


Sitecore.CodeDom Namespace

[image]

Sitecore 6.4.1 API
Sitecore.CodeDom Namespace
Send Feedback

Classes

 | Class | Description
Public class | CodeBuilder | Represents a CodeBuilder.
Public class | CodeParser | Represents a CodeParser.


CodeBuilder Class

[image]

Sitecore 6.4.1 API
CodeBuilder Class
Members See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CodeBuilder
Visual Basic
Public Class CodeBuilder
Visual C++
public ref class CodeBuilder

Inheritance Hierarchy

System..::..Object
Sitecore.CodeDom..::..CodeBuilder

See Also

CodeBuilder Members
Sitecore.CodeDom Namespace


CodeBuilder Members

[image] [image]

Sitecore 6.4.1 API
CodeBuilder Members
CodeBuilder Class Constructors Methods See Also Send Feedback

The CodeBuilder type exposes the following members.

Constructors

 | Name | Description
Public method | CodeBuilder | Initializes a new instance of the CodeBuilder class.

Methods

 | Name | Description
Public method | AddBlank | Adds the blank.
Public method | AddComment(String) | Adds the comment.
Public method | AddComment(String, Boolean) | Adds the comment.
Public method | AddRaw | Adds the raw.
Public method | AddString(String, Boolean) | Adds the string.
Public method | AddString(String, Boolean, Boolean) | Adds the string.
Public method | AddUsing | Adds the using.
Public method | AddVariable(String, String) | Adds the variable.
Public method | AddVariable(String, Type) | Adds the variable.
Public method | AddVarRef | Adds the var ref.
Public method | AssertContext | Asserts the context.
Public method | EndAssign | Ends the assign.
Public method | EndClass | Ends the class.
Public method | EndEqual | Ends the equal.
Public method | EndGet | Ends the get.
Public method | EndIf | Ends if.
Public method | EndIfTrue | Ends if true.
Public method | EndMethod | Ends the method.
Public method | EndMethodCall | Ends the method call.
Public method | EndNamespace | Ends the namespace.
Public method | EndProperty | Ends the property.
Public method | EndReturn | Ends the return.
Public method | EndSet | Ends the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCodeXml | Gets the code XML.
Public method | GetCSharpCode | Gets the C sharp code.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartAssign | Starts the assign.
Public method | StartClass(String, String) | Starts the class.
Public method | StartClass(String, Type) | Starts the class.
Public method | StartClass(String, String, String, String) | Starts the class.
Public method | StartClass(String, Type, String, String) | Starts the class.
Public method | StartEqual | Starts the equal.
Public method | StartGet | Starts the get.
Public method | StartIf | Starts if.
Public method | StartIfTrue | Starts if true.
Public method | StartMethod(String, String) | Starts the method.
Public method | StartMethod(String, Type) | Starts the method.
Public method | StartMethod(String, String, String) | Starts the method.
Public method | StartMethod(String, Type, String) | Starts the method.
Public method | StartMethodCall(String) | Starts the method call.
Public method | StartMethodCall(String, String) | Starts the method call.
Public method | StartNamespace | Starts the namespace.
Public method | StartProperty(String, String, String) | Starts the property.
Public method | StartProperty(String, Type, String) | Starts the property.
Public method | StartReturn | Starts the return.
Public method | StartSet | Starts the set.
Public method | Test | Tests this instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CodeBuilder Class
Sitecore.CodeDom Namespace


CodeBuilder Constructor

[image]

Sitecore 6.4.1 API
CodeBuilder Constructor
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CodeBuilder()
Visual Basic
Public Sub New
Visual C++
public:
CodeBuilder()

See Also

CodeBuilder Class
Sitecore.CodeDom Namespace


CodeBuilder Methods

[image] [image]

Sitecore 6.4.1 API
CodeBuilder Methods
CodeBuilder Class See Also Send Feedback

The CodeBuilder type exposes the following members.

Methods

 | Name | Description
Public method | AddBlank | Adds the blank.
Public method | AddComment(String) | Adds the comment.
Public method | AddComment(String, Boolean) | Adds the comment.
Public method | AddRaw | Adds the raw.
Public method | AddString(String, Boolean) | Adds the string.
Public method | AddString(String, Boolean, Boolean) | Adds the string.
Public method | AddUsing | Adds the using.
Public method | AddVariable(String, String) | Adds the variable.
Public method | AddVariable(String, Type) | Adds the variable.
Public method | AddVarRef | Adds the var ref.
Public method | AssertContext | Asserts the context.
Public method | EndAssign | Ends the assign.
Public method | EndClass | Ends the class.
Public method | EndEqual | Ends the equal.
Public method | EndGet | Ends the get.
Public method | EndIf | Ends if.
Public method | EndIfTrue | Ends if true.
Public method | EndMethod | Ends the method.
Public method | EndMethodCall | Ends the method call.
Public method | EndNamespace | Ends the namespace.
Public method | EndProperty | Ends the property.
Public method | EndReturn | Ends the return.
Public method | EndSet | Ends the set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCodeXml | Gets the code XML.
Public method | GetCSharpCode | Gets the C sharp code.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartAssign | Starts the assign.
Public method | StartClass(String, String) | Starts the class.
Public method | StartClass(String, Type) | Starts the class.
Public method | StartClass(String, String, String, String) | Starts the class.
Public method | StartClass(String, Type, String, String) | Starts the class.
Public method | StartEqual | Starts the equal.
Public method | StartGet | Starts the get.
Public method | StartIf | Starts if.
Public method | StartIfTrue | Starts if true.
Public method | StartMethod(String, String) | Starts the method.
Public method | StartMethod(String, Type) | Starts the method.
Public method | StartMethod(String, String, String) | Starts the method.
Public method | StartMethod(String, Type, String) | Starts the method.
Public method | StartMethodCall(String) | Starts the method call.
Public method | StartMethodCall(String, String) | Starts the method call.
Public method | StartNamespace | Starts the namespace.
Public method | StartProperty(String, String, String) | Starts the property.
Public method | StartProperty(String, Type, String) | Starts the property.
Public method | StartReturn | Starts the return.
Public method | StartSet | Starts the set.
Public method | Test | Tests this instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CodeBuilder Class
Sitecore.CodeDom Namespace


AddBlank Method

[image]

Sitecore 6.4.1 API
CodeBuilder..::..AddBlank Method
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddBlank()
Visual Basic
Public Sub AddBlank
Visual C++
public:
void AddBlank()

See Also

CodeBuilder Class
Sitecore.CodeDom Namespace


AddComment Method (String)

[image]

Sitecore 6.4.1 API
CodeBuilder..::..AddComment Method (String)
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddComment(
    string text
)
Visual Basic
Public Sub AddComment ( _
    text As String _
)
Visual C++
public:
void AddComment(
    String^ text
)

Parameters

text
Type: System..::..String
The text.

See Also

CodeBuilder Class
AddComment Overload
Sitecore.CodeDom Namespace


AddComment Method (String, Boolean)

[image]

Sitecore 6.4.1 API
CodeBuilder..::..AddComment Method (String, Boolean)
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddComment(
    string text,
    bool emptyLineBefore
)
Visual Basic
Public Sub AddComment ( _
    text As String, _
    emptyLineBefore As Boolean _
)
Visual C++
public:
void AddComment(
    String^ text,
    bool emptyLineBefore
)

Parameters

text
Type: System..::..String
The text.
emptyLineBefore
Type: System..::..Boolean
if set to true this instance is empty line before.

See Also

CodeBuilder Class
AddComment Overload
Sitecore.CodeDom Namespace


AddString Method (String, Boolean)

[image]

Sitecore 6.4.1 API
CodeBuilder..::..AddString Method (String, Boolean)
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddString(
    string value,
    bool escape
)
Visual Basic
Public Sub AddString ( _
    value As String, _
    escape As Boolean _
)
Visual C++
public:
void AddString(
    String^ value,
    bool escape
)

Parameters

value
Type: System..::..String
The value.
escape
Type: System..::..Boolean
if set to true this instance is escape.

See Also

CodeBuilder Class
AddString Overload
Sitecore.CodeDom Namespace


AddString Method (String, Boolean, Boolean)

[image]

Sitecore 6.4.1 API
CodeBuilder..::..AddString Method (String, Boolean, Boolean)
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddString(
    string value,
    bool escape,
    bool quotes
)
Visual Basic
Public Sub AddString ( _
    value As String, _
    escape As Boolean, _
    quotes As Boolean _
)
Visual C++
public:
void AddString(
    String^ value,
    bool escape,
    bool quotes
)

Parameters

value
Type: System..::..String
The _value.
escape
Type: System..::..Boolean
if set to true this instance is escape.
quotes
Type: System..::..Boolean
if set to true this instance is quotes.

See Also

CodeBuilder Class
AddString Overload
Sitecore.CodeDom Namespace


AddUsing Method

[image]

Sitecore 6.4.1 API
CodeBuilder..::..AddUsing Method
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddUsing(
    string namespace
)
Visual Basic
Public Sub AddUsing ( _
    namespace As String _
)
Visual C++
public:
void AddUsing(
    String^ namespace
)

Parameters

namespace
Type: System..::..String
The _namespace.

See Also

CodeBuilder Class
Sitecore.CodeDom Namespace


AddVariable Method

[image] [image]

Sitecore 6.4.1 API
CodeBuilder..::..AddVariable Method
CodeBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddVariable(String, String) | Adds the variable.
Public method | AddVariable(String, Type) | Adds the variable.

See Also

CodeBuilder Class
CodeBuilder Members
Sitecore.CodeDom Namespace


AddVariable Method (String, String)

[image]

Sitecore 6.4.1 API
CodeBuilder..::..AddVariable Method (String, String)
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddVariable(
    string name,
    string type
)
Visual Basic
Public Sub AddVariable ( _
    name As String, _
    type As String _
)
Visual C++
public:
void AddVariable(
    String^ name,
    String^ type
)

Parameters

name
Type: System..::..String
The name.
type
Type: System..::..String
The type.

See Also

CodeBuilder Class
AddVariable Overload
Sitecore.CodeDom Namespace


AddVariable Method (String, Type)

[image]

Sitecore 6.4.1 API
CodeBuilder..::..AddVariable Method (String, Type)
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddVariable(
    string name,
    Type type
)
Visual Basic
Public Sub AddVariable ( _
    name As String, _
    type As Type _
)
Visual C++
public:
void AddVariable(
    String^ name,
    Type^ type
)

Parameters

name
Type: System..::..String
The name.
type
Type: System..::..Type
The type.

See Also

CodeBuilder Class
AddVariable Overload
Sitecore.CodeDom Namespace


AddVarRef Method

[image]

Sitecore 6.4.1 API
CodeBuilder..::..AddVarRef Method
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddVarRef(
    string name
)
Visual Basic
Public Sub AddVarRef ( _
    name As String _
)
Visual C++
public:
void AddVarRef(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

See Also

CodeBuilder Class
Sitecore.CodeDom Namespace


AssertContext Method

[image]

Sitecore 6.4.1 API
CodeBuilder..::..AssertContext Method
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AssertContext(
    string context
)
Visual Basic
Public Sub AssertContext ( _
    context As String _
)
Visual C++
public:
void AssertContext(
    String^ context
)

Parameters

context
Type: System..::..String
The context.

See Also

CodeBuilder Class
Sitecore.CodeDom Namespace


EndAssign Method

[image]

Sitecore 6.4.1 API
CodeBuilder..::..EndAssign Method
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void EndAssign()
Visual Basic
Public Sub EndAssign
Visual C++
public:
void EndAssign()

See Also

CodeBuilder Class
Sitecore.CodeDom Namespace


EndClass Method

[image]

Sitecore 6.4.1 API
CodeBuilder..::..EndClass Method
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void EndClass()
Visual Basic
Public Sub EndClass
Visual C++
public:
void EndClass()

See Also

CodeBuilder Class
Sitecore.CodeDom Namespace


EndGet Method

[image]

Sitecore 6.4.1 API
CodeBuilder..::..EndGet Method
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void EndGet()
Visual Basic
Public Sub EndGet
Visual C++
public:
void EndGet()

See Also

CodeBuilder Class
Sitecore.CodeDom Namespace


EndIf Method

[image]

Sitecore 6.4.1 API
CodeBuilder..::..EndIf Method
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void EndIf()
Visual Basic
Public Sub EndIf
Visual C++
public:
void EndIf()

See Also

CodeBuilder Class
Sitecore.CodeDom Namespace


EndIfTrue Method

[image]

Sitecore 6.4.1 API
CodeBuilder..::..EndIfTrue Method
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void EndIfTrue()
Visual Basic
Public Sub EndIfTrue
Visual C++
public:
void EndIfTrue()

See Also

CodeBuilder Class
Sitecore.CodeDom Namespace


EndMethod Method

[image]

Sitecore 6.4.1 API
CodeBuilder..::..EndMethod Method
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void EndMethod()
Visual Basic
Public Sub EndMethod
Visual C++
public:
void EndMethod()

See Also

CodeBuilder Class
Sitecore.CodeDom Namespace


EndMethodCall Method

[image]

Sitecore 6.4.1 API
CodeBuilder..::..EndMethodCall Method
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void EndMethodCall()
Visual Basic
Public Sub EndMethodCall
Visual C++
public:
void EndMethodCall()

See Also

CodeBuilder Class
Sitecore.CodeDom Namespace


EndNamespace Method

[image]

Sitecore 6.4.1 API
CodeBuilder..::..EndNamespace Method
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void EndNamespace()
Visual Basic
Public Sub EndNamespace
Visual C++
public:
void EndNamespace()

See Also

CodeBuilder Class
Sitecore.CodeDom Namespace


EndProperty Method

[image]

Sitecore 6.4.1 API
CodeBuilder..::..EndProperty Method
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void EndProperty()
Visual Basic
Public Sub EndProperty
Visual C++
public:
void EndProperty()

See Also

CodeBuilder Class
Sitecore.CodeDom Namespace


EndReturn Method

[image]

Sitecore 6.4.1 API
CodeBuilder..::..EndReturn Method
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void EndReturn()
Visual Basic
Public Sub EndReturn
Visual C++
public:
void EndReturn()

See Also

CodeBuilder Class
Sitecore.CodeDom Namespace


EndSet Method

[image]

Sitecore 6.4.1 API
CodeBuilder..::..EndSet Method
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void EndSet()
Visual Basic
Public Sub EndSet
Visual C++
public:
void EndSet()

See Also

CodeBuilder Class
Sitecore.CodeDom Namespace


GetCodeXml Method

[image]

Sitecore 6.4.1 API
CodeBuilder..::..GetCodeXml Method
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetCodeXml()
Visual Basic
Public Function GetCodeXml As String
Visual C++
public:
String^ GetCodeXml()

Return Value

[Missing <returns> documentation for "M:Sitecore.CodeDom.CodeBuilder.GetCodeXml"]

See Also

CodeBuilder Class
Sitecore.CodeDom Namespace


GetCSharpCode Method

[image]

Sitecore 6.4.1 API
CodeBuilder..::..GetCSharpCode Method
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetCSharpCode()
Visual Basic
Public Function GetCSharpCode As String
Visual C++
public:
String^ GetCSharpCode()

Return Value

[Missing <returns> documentation for "M:Sitecore.CodeDom.CodeBuilder.GetCSharpCode"]

See Also

CodeBuilder Class
Sitecore.CodeDom Namespace


StartAssign Method

[image]

Sitecore 6.4.1 API
CodeBuilder..::..StartAssign Method
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void StartAssign()
Visual Basic
Public Sub StartAssign
Visual C++
public:
void StartAssign()

See Also

CodeBuilder Class
Sitecore.CodeDom Namespace


StartClass Method (String, String)

[image]

Sitecore 6.4.1 API
CodeBuilder..::..StartClass Method (String, String)
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void StartClass(
    string name,
    string inherits
)
Visual Basic
Public Sub StartClass ( _
    name As String, _
    inherits As String _
)
Visual C++
public:
void StartClass(
    String^ name,
    String^ inherits
)

Parameters

name
Type: System..::..String
The name.
inherits
Type: System..::..String
The inherits.

See Also

CodeBuilder Class
StartClass Overload
Sitecore.CodeDom Namespace


StartClass Method (String, Type)

[image]

Sitecore 6.4.1 API
CodeBuilder..::..StartClass Method (String, Type)
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void StartClass(
    string name,
    Type inherits
)
Visual Basic
Public Sub StartClass ( _
    name As String, _
    inherits As Type _
)
Visual C++
public:
void StartClass(
    String^ name,
    Type^ inherits
)

Parameters

name
Type: System..::..String
The name.
inherits
Type: System..::..Type
The inherits.

See Also

CodeBuilder Class
StartClass Overload
Sitecore.CodeDom Namespace


StartClass Method (String, String, String, String)

[image]

Sitecore 6.4.1 API
CodeBuilder..::..StartClass Method (String, String, String, String)
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void StartClass(
    string name,
    string inherits,
    string scope,
    string renderAs
)
Visual Basic
Public Sub StartClass ( _
    name As String, _
    inherits As String, _
    scope As String, _
    renderAs As String _
)
Visual C++
public:
void StartClass(
    String^ name,
    String^ inherits,
    String^ scope,
    String^ renderAs
)

Parameters

name
Type: System..::..String
The name.
inherits
Type: System..::..String
The inherits.
scope
Type: System..::..String
The scope.
renderAs
Type: System..::..String
The render as.

See Also

CodeBuilder Class
StartClass Overload
Sitecore.CodeDom Namespace


StartClass Method (String, Type, String, String)

[image]

Sitecore 6.4.1 API
CodeBuilder..::..StartClass Method (String, Type, String, String)
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void StartClass(
    string name,
    Type inherits,
    string scope,
    string renderAs
)
Visual Basic
Public Sub StartClass ( _
    name As String, _
    inherits As Type, _
    scope As String, _
    renderAs As String _
)
Visual C++
public:
void StartClass(
    String^ name,
    Type^ inherits,
    String^ scope,
    String^ renderAs
)

Parameters

name
Type: System..::..String
The name.
inherits
Type: System..::..Type
The inherits.
scope
Type: System..::..String
The scope.
renderAs
Type: System..::..String
The render as.

See Also

CodeBuilder Class
StartClass Overload
Sitecore.CodeDom Namespace


StartEqual Method

[image]

Sitecore 6.4.1 API
CodeBuilder..::..StartEqual Method
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void StartEqual()
Visual Basic
Public Sub StartEqual
Visual C++
public:
void StartEqual()

See Also

CodeBuilder Class
Sitecore.CodeDom Namespace


StartGet Method

[image]

Sitecore 6.4.1 API
CodeBuilder..::..StartGet Method
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void StartGet()
Visual Basic
Public Sub StartGet
Visual C++
public:
void StartGet()

See Also

CodeBuilder Class
Sitecore.CodeDom Namespace


StartIf Method

[image]

Sitecore 6.4.1 API
CodeBuilder..::..StartIf Method
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void StartIf()
Visual Basic
Public Sub StartIf
Visual C++
public:
void StartIf()

See Also

CodeBuilder Class
Sitecore.CodeDom Namespace


StartIfTrue Method

[image]

Sitecore 6.4.1 API
CodeBuilder..::..StartIfTrue Method
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void StartIfTrue()
Visual Basic
Public Sub StartIfTrue
Visual C++
public:
void StartIfTrue()

See Also

CodeBuilder Class
Sitecore.CodeDom Namespace


StartMethod Method

[image] [image]

Sitecore 6.4.1 API
CodeBuilder..::..StartMethod Method
CodeBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StartMethod(String, String) | Starts the method.
Public method | StartMethod(String, Type) | Starts the method.
Public method | StartMethod(String, String, String) | Starts the method.
Public method | StartMethod(String, Type, String) | Starts the method.

See Also

CodeBuilder Class
CodeBuilder Members
Sitecore.CodeDom Namespace


StartMethod Method (String, String)

[image]

Sitecore 6.4.1 API
CodeBuilder..::..StartMethod Method (String, String)
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void StartMethod(
    string name,
    string returnType
)
Visual Basic
Public Sub StartMethod ( _
    name As String, _
    returnType As String _
)
Visual C++
public:
void StartMethod(
    String^ name,
    String^ returnType
)

Parameters

name
Type: System..::..String
The name.
returnType
Type: System..::..String
Type of the return.

See Also

CodeBuilder Class
StartMethod Overload
Sitecore.CodeDom Namespace


StartMethod Method (String, Type)

[image]

Sitecore 6.4.1 API
CodeBuilder..::..StartMethod Method (String, Type)
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void StartMethod(
    string name,
    Type returnType
)
Visual Basic
Public Sub StartMethod ( _
    name As String, _
    returnType As Type _
)
Visual C++
public:
void StartMethod(
    String^ name,
    Type^ returnType
)

Parameters

name
Type: System..::..String
The name.
returnType
Type: System..::..Type
Type of the return.

See Also

CodeBuilder Class
StartMethod Overload
Sitecore.CodeDom Namespace


StartMethod Method (String, Type, String)

[image]

Sitecore 6.4.1 API
CodeBuilder..::..StartMethod Method (String, Type, String)
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void StartMethod(
    string name,
    Type returnType,
    string modifiers
)
Visual Basic
Public Sub StartMethod ( _
    name As String, _
    returnType As Type, _
    modifiers As String _
)
Visual C++
public:
void StartMethod(
    String^ name,
    Type^ returnType,
    String^ modifiers
)

Parameters

name
Type: System..::..String
The name.
returnType
Type: System..::..Type
Type of the return.
modifiers
Type: System..::..String
The modifiers.

See Also

CodeBuilder Class
StartMethod Overload
Sitecore.CodeDom Namespace


StartMethodCall Method

[image] [image]

Sitecore 6.4.1 API
CodeBuilder..::..StartMethodCall Method
CodeBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StartMethodCall(String) | Starts the method call.
Public method | StartMethodCall(String, String) | Starts the method call.

See Also

CodeBuilder Class
CodeBuilder Members
Sitecore.CodeDom Namespace


StartMethodCall Method (String)

[image]

Sitecore 6.4.1 API
CodeBuilder..::..StartMethodCall Method (String)
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void StartMethodCall(
    string name
)
Visual Basic
Public Sub StartMethodCall ( _
    name As String _
)
Visual C++
public:
void StartMethodCall(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

See Also

CodeBuilder Class
StartMethodCall Overload
Sitecore.CodeDom Namespace


StartNamespace Method

[image]

Sitecore 6.4.1 API
CodeBuilder..::..StartNamespace Method
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void StartNamespace(
    string name
)
Visual Basic
Public Sub StartNamespace ( _
    name As String _
)
Visual C++
public:
void StartNamespace(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

See Also

CodeBuilder Class
Sitecore.CodeDom Namespace


StartProperty Method

[image] [image]

Sitecore 6.4.1 API
CodeBuilder..::..StartProperty Method
CodeBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StartProperty(String, String, String) | Starts the property.
Public method | StartProperty(String, Type, String) | Starts the property.

See Also

CodeBuilder Class
CodeBuilder Members
Sitecore.CodeDom Namespace


StartProperty Method (String, String, String)

[image]

Sitecore 6.4.1 API
CodeBuilder..::..StartProperty Method (String, String, String)
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void StartProperty(
    string name,
    string type,
    string modifier
)
Visual Basic
Public Sub StartProperty ( _
    name As String, _
    type As String, _
    modifier As String _
)
Visual C++
public:
void StartProperty(
    String^ name,
    String^ type,
    String^ modifier
)

Parameters

name
Type: System..::..String
The name.
type
Type: System..::..String
The type.
modifier
Type: System..::..String
The modifier.

See Also

CodeBuilder Class
StartProperty Overload
Sitecore.CodeDom Namespace


StartProperty Method (String, Type, String)

[image]

Sitecore 6.4.1 API
CodeBuilder..::..StartProperty Method (String, Type, String)
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void StartProperty(
    string name,
    Type type,
    string modifier
)
Visual Basic
Public Sub StartProperty ( _
    name As String, _
    type As Type, _
    modifier As String _
)
Visual C++
public:
void StartProperty(
    String^ name,
    Type^ type,
    String^ modifier
)

Parameters

name
Type: System..::..String
The name.
type
Type: System..::..Type
The type.
modifier
Type: System..::..String
The modifier.

See Also

CodeBuilder Class
StartProperty Overload
Sitecore.CodeDom Namespace


StartReturn Method

[image]

Sitecore 6.4.1 API
CodeBuilder..::..StartReturn Method
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void StartReturn()
Visual Basic
Public Sub StartReturn
Visual C++
public:
void StartReturn()

See Also

CodeBuilder Class
Sitecore.CodeDom Namespace


StartSet Method

[image]

Sitecore 6.4.1 API
CodeBuilder..::..StartSet Method
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void StartSet()
Visual Basic
Public Sub StartSet
Visual C++
public:
void StartSet()

See Also

CodeBuilder Class
Sitecore.CodeDom Namespace


Test Method

[image]

Sitecore 6.4.1 API
CodeBuilder..::..Test Method
CodeBuilder Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Test()
Visual Basic
Public Sub Test
Visual C++
public:
void Test()

See Also

CodeBuilder Class
Sitecore.CodeDom Namespace


CodeParser Class

[image]

Sitecore 6.4.1 API
CodeParser Class
Members See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CodeParser
Visual Basic
Public Class CodeParser
Visual C++
public ref class CodeParser

Inheritance Hierarchy

System..::..Object
Sitecore.CodeDom..::..CodeParser

See Also

CodeParser Members
Sitecore.CodeDom Namespace


CodeParser Members

[image] [image]

Sitecore 6.4.1 API
CodeParser Members
CodeParser Class Constructors Methods See Also Send Feedback

The CodeParser type exposes the following members.

Constructors

 | Name | Description
Public method | CodeParser | Initializes a new instance of the CodeParser class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Parse | Parses the specified code.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CodeParser Class
Sitecore.CodeDom Namespace


CodeParser Constructor

[image]

Sitecore 6.4.1 API
CodeParser Constructor
CodeParser Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CodeParser()
Visual Basic
Public Sub New
Visual C++
public:
CodeParser()

See Also

CodeParser Class
Sitecore.CodeDom Namespace


CodeParser Methods

[image] [image]

Sitecore 6.4.1 API
CodeParser Methods
CodeParser Class See Also Send Feedback

The CodeParser type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Parse | Parses the specified code.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CodeParser Class
Sitecore.CodeDom Namespace


Parse Method

[image]

Sitecore 6.4.1 API
CodeParser..::..Parse Method
CodeParser Class See Also Send Feedback

Namespace: Sitecore.CodeDom
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Parse(
    XmlDocument code
)
Visual Basic
Public Function Parse ( _
    code As XmlDocument _
) As String
Visual C++
public:
String^ Parse(
    XmlDocument^ code
)

Parameters

code
Type: System.Xml..::..XmlDocument
The code.

Return Value

[Missing <returns> documentation for "M:Sitecore.CodeDom.CodeParser.Parse(System.Xml.XmlDocument)"]

See Also

CodeParser Class
Sitecore.CodeDom Namespace


Sitecore.CodeDom.Compiler Namespace

[image]

Sitecore 6.4.1 API
Sitecore.CodeDom.Compiler Namespace
Send Feedback

Classes

 | Class | Description
Public class | CompilerException | Represents a compiler exception.
Public class | CSharpCompiler | C# compiler.


CompilerException Class

[image]

Sitecore 6.4.1 API
CompilerException Class
Members See Also Send Feedback

Namespace: Sitecore.CodeDom.Compiler
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public sealed class CompilerException : ApplicationException
Visual Basic
<SerializableAttribute> _
Public NotInheritable Class CompilerException _
    Inherits ApplicationException
Visual C++
[SerializableAttribute]
public ref class CompilerException sealed : public ApplicationException

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Sitecore.CodeDom.Compiler..::..CompilerException

See Also

CompilerException Members
Sitecore.CodeDom.Compiler Namespace


CompilerException Members

[image] [image]

Sitecore 6.4.1 API
CompilerException Members
CompilerException Class Constructors Methods Properties See Also Send Feedback

The CompilerException type exposes the following members.

Constructors

 | Name | Description
Public method | CompilerException(CompilerErrorCollection) | Constructor.
Public method | CompilerException(CompilerErrorCollection, String) | Constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CompilerException Class
Sitecore.CodeDom.Compiler Namespace


CompilerException Constructor

[image] [image]

Sitecore 6.4.1 API
CompilerException Constructor
CompilerException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CompilerException(CompilerErrorCollection) | Constructor.
Public method | CompilerException(CompilerErrorCollection, String) | Constructor.

See Also

CompilerException Class
CompilerException Members
Sitecore.CodeDom.Compiler Namespace


CompilerException Constructor (CompilerErrorCollection)

[image]

Sitecore 6.4.1 API
CompilerException Constructor (CompilerErrorCollection)
CompilerException Class See Also Send Feedback

Namespace: Sitecore.CodeDom.Compiler
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CompilerException(
    CompilerErrorCollection errors
)
Visual Basic
Public Sub New ( _
    errors As CompilerErrorCollection _
)
Visual C++
public:
CompilerException(
    CompilerErrorCollection^ errors
)

Parameters

errors
Type: System.CodeDom.Compiler..::..CompilerErrorCollection
The errors.

See Also

CompilerException Class
CompilerException Overload
Sitecore.CodeDom.Compiler Namespace


CompilerException Constructor (CompilerErrorCollection, String)

[image]

Sitecore 6.4.1 API
CompilerException Constructor (CompilerErrorCollection, String)
CompilerException Class See Also Send Feedback

Namespace: Sitecore.CodeDom.Compiler
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CompilerException(
    CompilerErrorCollection errors,
    string sourceFile
)
Visual Basic
Public Sub New ( _
    errors As CompilerErrorCollection, _
    sourceFile As String _
)
Visual C++
public:
CompilerException(
    CompilerErrorCollection^ errors,
    String^ sourceFile
)

Parameters

errors
Type: System.CodeDom.Compiler..::..CompilerErrorCollection
The errors.
sourceFile
Type: System..::..String
The source file.

See Also

CompilerException Class
CompilerException Overload
Sitecore.CodeDom.Compiler Namespace


CompilerException Methods

[image] [image]

Sitecore 6.4.1 API
CompilerException Methods
CompilerException Class See Also Send Feedback

The CompilerException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

CompilerException Class
Sitecore.CodeDom.Compiler Namespace


CompilerException Properties

[image] [image]

Sitecore 6.4.1 API
CompilerException Properties
CompilerException Class See Also Send Feedback

The CompilerException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CompilerException Class
Sitecore.CodeDom.Compiler Namespace


CSharpCompiler Class

[image]

Sitecore 6.4.1 API
CSharpCompiler Class
Members See Also Send Feedback

Namespace: Sitecore.CodeDom.Compiler
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CSharpCompiler
Visual Basic
Public Class CSharpCompiler
Visual C++
public ref class CSharpCompiler

Inheritance Hierarchy

System..::..Object
Sitecore.CodeDom.Compiler..::..CSharpCompiler

See Also

CSharpCompiler Members
Sitecore.CodeDom.Compiler Namespace


CSharpCompiler Members

[image] [image]

Sitecore 6.4.1 API
CSharpCompiler Members
CSharpCompiler Class Constructors Methods See Also Send Feedback

The CSharpCompiler type exposes the following members.

Constructors

 | Name | Description
Public method | CSharpCompiler | Initializes a new instance of the CSharpCompiler class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FileToFile | Compile C# code to assembly.
Public method | FileToMemory | Compile C# code to assembly.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SourceToFile | Compile C# code to assembly.
Public method | SourceToMemory | Compile C# code to assembly.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CSharpCompiler Class
Sitecore.CodeDom.Compiler Namespace


CSharpCompiler Constructor

[image]

Sitecore 6.4.1 API
CSharpCompiler Constructor
CSharpCompiler Class See Also Send Feedback

Namespace: Sitecore.CodeDom.Compiler
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CSharpCompiler()
Visual Basic
Public Sub New
Visual C++
public:
CSharpCompiler()

See Also

CSharpCompiler Class
Sitecore.CodeDom.Compiler Namespace


CSharpCompiler Methods

[image] [image]

Sitecore 6.4.1 API
CSharpCompiler Methods
CSharpCompiler Class See Also Send Feedback

The CSharpCompiler type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FileToFile | Compile C# code to assembly.
Public method | FileToMemory | Compile C# code to assembly.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SourceToFile | Compile C# code to assembly.
Public method | SourceToMemory | Compile C# code to assembly.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CSharpCompiler Class
Sitecore.CodeDom.Compiler Namespace


FileToFile Method

[image]

Sitecore 6.4.1 API
CSharpCompiler..::..FileToFile Method
CSharpCompiler Class See Also Send Feedback

Namespace: Sitecore.CodeDom.Compiler
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void FileToFile(
    string sourceFile,
    string assemblyFile,
    StringCollection referencedAssemblies
)
Visual Basic
Public Sub FileToFile ( _
    sourceFile As String, _
    assemblyFile As String, _
    referencedAssemblies As StringCollection _
)
Visual C++
public:
void FileToFile(
    String^ sourceFile,
    String^ assemblyFile,
    StringCollection^ referencedAssemblies
)

Parameters

sourceFile
Type: System..::..String
The source file.
assemblyFile
Type: System..::..String
The assembly file.
referencedAssemblies
Type: System.Collections.Specialized..::..StringCollection
The referenced assemblies.

See Also

CSharpCompiler Class
Sitecore.CodeDom.Compiler Namespace


FileToMemory Method

[image]

Sitecore 6.4.1 API
CSharpCompiler..::..FileToMemory Method
CSharpCompiler Class See Also Send Feedback

Namespace: Sitecore.CodeDom.Compiler
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Assembly FileToMemory(
    string sourceFile,
    StringCollection referencedAssemblies
)
Visual Basic
Public Function FileToMemory ( _
    sourceFile As String, _
    referencedAssemblies As StringCollection _
) As Assembly
Visual C++
public:
Assembly^ FileToMemory(
    String^ sourceFile,
    StringCollection^ referencedAssemblies
)

Parameters

sourceFile
Type: System..::..String
The source file.
referencedAssemblies
Type: System.Collections.Specialized..::..StringCollection
The referenced assemblies.

Return Value

[Missing <returns> documentation for "M:Sitecore.CodeDom.Compiler.CSharpCompiler.FileToMemory(System.String,System.Collections.Specialized.StringCollection)"]

See Also

CSharpCompiler Class
Sitecore.CodeDom.Compiler Namespace


SourceToFile Method

[image]

Sitecore 6.4.1 API
CSharpCompiler..::..SourceToFile Method
CSharpCompiler Class See Also Send Feedback

Namespace: Sitecore.CodeDom.Compiler
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SourceToFile(
    string sourceFile,
    string code,
    string assemblyFile,
    StringCollection referencedAssemblies
)
Visual Basic
Public Sub SourceToFile ( _
    sourceFile As String, _
    code As String, _
    assemblyFile As String, _
    referencedAssemblies As StringCollection _
)
Visual C++
public:
void SourceToFile(
    String^ sourceFile,
    String^ code,
    String^ assemblyFile,
    StringCollection^ referencedAssemblies
)

Parameters

sourceFile
Type: System..::..String
The source file.
code
Type: System..::..String
The code.
assemblyFile
Type: System..::..String
The assembly file.
referencedAssemblies
Type: System.Collections.Specialized..::..StringCollection
The referenced assemblies.

See Also

CSharpCompiler Class
Sitecore.CodeDom.Compiler Namespace


SourceToMemory Method

[image]

Sitecore 6.4.1 API
CSharpCompiler..::..SourceToMemory Method
CSharpCompiler Class See Also Send Feedback

Namespace: Sitecore.CodeDom.Compiler
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Assembly SourceToMemory(
    string code,
    StringCollection referencedAssemblies
)
Visual Basic
Public Function SourceToMemory ( _
    code As String, _
    referencedAssemblies As StringCollection _
) As Assembly
Visual C++
public:
Assembly^ SourceToMemory(
    String^ code,
    StringCollection^ referencedAssemblies
)

Parameters

code
Type: System..::..String
The code.
referencedAssemblies
Type: System.Collections.Specialized..::..StringCollection
The referenced assemblies.

Return Value

[Missing <returns> documentation for "M:Sitecore.CodeDom.Compiler.CSharpCompiler.SourceToMemory(System.String,System.Collections.Specialized.StringCollection)"]

See Also

CSharpCompiler Class
Sitecore.CodeDom.Compiler Namespace


Sitecore.CodeDom.Scripts Namespace

[image]

Sitecore 6.4.1 API
Sitecore.CodeDom.Scripts Namespace
Send Feedback

Classes

 | Class | Description
Public class | ItemScripts | Extensions methods for string.
Public class | Script | Defines the script class.
Public class | ScriptFactory | Defines the script factory class.


ItemScripts Class

[image]

Sitecore 6.4.1 API
ItemScripts Class
Members See Also Send Feedback

Namespace: Sitecore.CodeDom.Scripts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class ItemScripts
Visual Basic
Public NotInheritable Class ItemScripts
Visual C++
public ref class ItemScripts abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.CodeDom.Scripts..::..ItemScripts

See Also

ItemScripts Members
Sitecore.CodeDom.Scripts Namespace


ItemScripts Members

[image] [image]

Sitecore 6.4.1 API
ItemScripts Members
ItemScripts Class Methods See Also Send Feedback

The ItemScripts type exposes the following members.

Methods

Name | Description
Compile | Gets the attribute value.
CreateObject | Creates the object.
GetGenericType<(Of <<'(T>)>>) | Gets the generic type.
HasScript | Determines whether the specified item has script.
InvokeDefaultMethod<(Of <<'(T>)>>) | Invokes this instance.

See Also

ItemScripts Class
Sitecore.CodeDom.Scripts Namespace


ItemScripts Methods

[image] [image]

Sitecore 6.4.1 API
ItemScripts Methods
ItemScripts Class See Also Send Feedback

The ItemScripts type exposes the following members.

Methods

Name | Description
Compile | Gets the attribute value.
CreateObject | Creates the object.
GetGenericType<(Of <<'(T>)>>) | Gets the generic type.
HasScript | Determines whether the specified item has script.
InvokeDefaultMethod<(Of <<'(T>)>>) | Invokes this instance.

See Also

ItemScripts Class
Sitecore.CodeDom.Scripts Namespace


Compile Method

[image]

Sitecore 6.4.1 API
ItemScripts..::..Compile Method
ItemScripts Class See Also Send Feedback

Namespace: Sitecore.CodeDom.Scripts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Script Compile(
    Item item
)
Visual Basic
Public Shared Function Compile ( _
    item As Item _
) As Script
Visual C++
public:
static Script^ Compile(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The source item.

Return Value

The script.

See Also

ItemScripts Class
Sitecore.CodeDom.Scripts Namespace


CreateObject Method

[image]

Sitecore 6.4.1 API
ItemScripts..::..CreateObject Method
ItemScripts Class See Also Send Feedback

Namespace: Sitecore.CodeDom.Scripts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object CreateObject(
    Item item
)
Visual Basic
Public Shared Function CreateObject ( _
    item As Item _
) As Object
Visual C++
public:
static Object^ CreateObject(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The script item.

Return Value

Returns the created object.

See Also

ItemScripts Class
Sitecore.CodeDom.Scripts Namespace


GetGenericType(T) Method

[image]

Sitecore 6.4.1 API
ItemScripts..::..GetGenericType<(Of <(<'T>)>)> Method
ItemScripts Class See Also Send Feedback

Namespace: Sitecore.CodeDom.Scripts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Type GetGenericType<T>(
    Item item
)
Visual Basic
Public Shared Function GetGenericType(Of T) ( _
    item As Item _
) As Type
Visual C++
public:
generic<typename T>
static Type^ GetGenericType(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The script item.

Type Parameters

T
The generic type.

Return Value

Returns the type.

See Also

ItemScripts Class
Sitecore.CodeDom.Scripts Namespace


HasScript Method

[image]

Sitecore 6.4.1 API
ItemScripts..::..HasScript Method
ItemScripts Class See Also Send Feedback

Namespace: Sitecore.CodeDom.Scripts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool HasScript(
    Item item
)
Visual Basic
Public Shared Function HasScript ( _
    item As Item _
) As Boolean
Visual C++
public:
static bool HasScript(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The source item.

Return Value

true if the specified item has script; otherwise, false.

See Also

ItemScripts Class
Sitecore.CodeDom.Scripts Namespace


InvokeDefaultMethod(T) Method

[image]

Sitecore 6.4.1 API
ItemScripts..::..InvokeDefaultMethod<(Of <(<'T>)>)> Method
ItemScripts Class See Also Send Feedback

Namespace: Sitecore.CodeDom.Scripts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static T InvokeDefaultMethod<T>(
    Item item,
    params Object[] parameters
)
Visual Basic
Public Shared Function InvokeDefaultMethod(Of T) ( _
    item As Item, _
    ParamArray parameters As Object() _
) As T
Visual C++
public:
generic<typename T>
static T InvokeDefaultMethod(
    Item^ item,
    ... array<Object^>^ parameters
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The source item.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.

Type Parameters

T
The return type

Return Value

Returns the invoked value.

See Also

ItemScripts Class
Sitecore.CodeDom.Scripts Namespace


Script Class

[image]

Sitecore 6.4.1 API
Script Class
Members See Also Send Feedback

Namespace: Sitecore.CodeDom.Scripts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Script : ICacheable
Visual Basic
Public Class Script _
    Implements ICacheable
Visual C++
public ref class Script : ICacheable

Inheritance Hierarchy

System..::..Object
Sitecore.CodeDom.Scripts..::..Script

See Also

Script Members
Sitecore.CodeDom.Scripts Namespace


Script Members

[image] [image]

Sitecore 6.4.1 API
Script Members
Script Class Constructors Methods Properties See Also Send Feedback

The Script type exposes the following members.

Constructors

 | Name | Description
Public method | Script | Initializes a new instance of the Script class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDefaultType | Gets the type of the default.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasDefaultMethod | Determines whether the script has a default method.
Public method | InvokeDefaultMethod<(Of <<'(T>)>>) | Invokes the default.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Assembly | Gets or sets the assembly.
 | Empty | Gets the empty.
Public property | Errors | Gets or sets the errors.
Public property | IsValid | Gets a value indicating whether this instance is valid.

See Also

Script Class
Sitecore.CodeDom.Scripts Namespace


Script Constructor

[image]

Sitecore 6.4.1 API
Script Constructor
Script Class See Also Send Feedback

Namespace: Sitecore.CodeDom.Scripts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Script()
Visual Basic
Public Sub New
Visual C++
public:
Script()

See Also

Script Class
Sitecore.CodeDom.Scripts Namespace


Script Methods

[image] [image]

Sitecore 6.4.1 API
Script Methods
Script Class See Also Send Feedback

The Script type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDefaultType | Gets the type of the default.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasDefaultMethod | Determines whether the script has a default method.
Public method | InvokeDefaultMethod<(Of <<'(T>)>>) | Invokes the default.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Script Class
Sitecore.CodeDom.Scripts Namespace


GetDefaultType Method

[image]

Sitecore 6.4.1 API
Script..::..GetDefaultType Method
Script Class See Also Send Feedback

Namespace: Sitecore.CodeDom.Scripts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Type GetDefaultType()
Visual Basic
Public Function GetDefaultType As Type
Visual C++
public:
Type^ GetDefaultType()

Return Value

Returns the type.

See Also

Script Class
Sitecore.CodeDom.Scripts Namespace


HasDefaultMethod Method

[image]

Sitecore 6.4.1 API
Script..::..HasDefaultMethod Method
Script Class See Also Send Feedback

Namespace: Sitecore.CodeDom.Scripts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool HasDefaultMethod()
Visual Basic
Public Function HasDefaultMethod As Boolean
Visual C++
public:
bool HasDefaultMethod()

Return Value

true if the script has a default method; otherwise, false.

See Also

Script Class
Sitecore.CodeDom.Scripts Namespace


Script Properties

[image] [image]

Sitecore 6.4.1 API
Script Properties
Script Class See Also Send Feedback

The Script type exposes the following members.

Properties

 | Name | Description
Public property | Assembly | Gets or sets the assembly.
 | Empty | Gets the empty.
Public property | Errors | Gets or sets the errors.
Public property | IsValid | Gets a value indicating whether this instance is valid.

See Also

Script Class
Sitecore.CodeDom.Scripts Namespace


Assembly Property

[image]

Sitecore 6.4.1 API
Script..::..Assembly Property
Script Class See Also Send Feedback

Namespace: Sitecore.CodeDom.Scripts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Assembly Assembly { get; set; }
Visual Basic
Public Property Assembly As Assembly
    Get
    Set
Visual C++
public:
property Assembly^ Assembly {
    Assembly^ get ();
    void set (Assembly^ value);
}

Field Value

The assembly.

See Also

Script Class
Sitecore.CodeDom.Scripts Namespace


Empty Property

[image]

Sitecore 6.4.1 API
Script..::..Empty Property
Script Class See Also Send Feedback

Namespace: Sitecore.CodeDom.Scripts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Script Empty { get; }
Visual Basic
Public Shared ReadOnly Property Empty As Script
    Get
Visual C++
public:
static property Script^ Empty {
    Script^ get ();
}

Field Value

The empty.

See Also

Script Class
Sitecore.CodeDom.Scripts Namespace


Errors Property

[image]

Sitecore 6.4.1 API
Script..::..Errors Property
Script Class See Also Send Feedback

Namespace: Sitecore.CodeDom.Scripts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CompilerErrorCollection Errors { get; set; }
Visual Basic
Public Property Errors As CompilerErrorCollection
    Get
    Set
Visual C++
public:
property CompilerErrorCollection^ Errors {
    CompilerErrorCollection^ get ();
    void set (CompilerErrorCollection^ value);
}

Field Value

The errors.

See Also

Script Class
Sitecore.CodeDom.Scripts Namespace


IsValid Property

[image]

Sitecore 6.4.1 API
Script..::..IsValid Property
Script Class See Also Send Feedback

Namespace: Sitecore.CodeDom.Scripts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsValid { get; }
Visual Basic
Public ReadOnly Property IsValid As Boolean
    Get
Visual C++
public:
property bool IsValid {
    bool get ();
}

Field Value

true if this instance is valid; otherwise, false.

See Also

Script Class
Sitecore.CodeDom.Scripts Namespace


ScriptFactory Class

[image]

Sitecore 6.4.1 API
ScriptFactory Class
Members See Also Send Feedback

Namespace: Sitecore.CodeDom.Scripts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class ScriptFactory
Visual Basic
Public NotInheritable Class ScriptFactory
Visual C++
public ref class ScriptFactory abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.CodeDom.Scripts..::..ScriptFactory

See Also

ScriptFactory Members
Sitecore.CodeDom.Scripts Namespace


ScriptFactory Members

[image] [image]

Sitecore 6.4.1 API
ScriptFactory Members
ScriptFactory Class Methods See Also Send Feedback

The ScriptFactory type exposes the following members.

Methods

Name | Description
Compile | Gets the script.
InvalidateCache | Invalidates the cache.
SyntaxCheck | Syntaxes the check.

See Also

ScriptFactory Class
Sitecore.CodeDom.Scripts Namespace


ScriptFactory Methods

[image] [image]

Sitecore 6.4.1 API
ScriptFactory Methods
ScriptFactory Class See Also Send Feedback

The ScriptFactory type exposes the following members.

Methods

Name | Description
Compile | Gets the script.
InvalidateCache | Invalidates the cache.
SyntaxCheck | Syntaxes the check.

See Also

ScriptFactory Class
Sitecore.CodeDom.Scripts Namespace


Compile Method

[image]

Sitecore 6.4.1 API
ScriptFactory..::..Compile Method
ScriptFactory Class See Also Send Feedback

Namespace: Sitecore.CodeDom.Scripts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Script Compile(
    string cacheKey,
    IEnumerable<string> references,
    string code,
    string language
)
Visual Basic
Public Shared Function Compile ( _
    cacheKey As String, _
    references As IEnumerable(Of String), _
    code As String, _
    language As String _
) As Script
Visual C++
public:
static Script^ Compile(
    String^ cacheKey,
    IEnumerable<String^>^ references,
    String^ code,
    String^ language
)

Parameters

cacheKey
Type: System..::..String
The key for the cache.
references
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' String >)>)>
The references.
code
Type: System..::..String
The script code.
language
Type: System..::..String
The language.

Return Value

Returns the script.

See Also

ScriptFactory Class
Sitecore.CodeDom.Scripts Namespace


InvalidateCache Method

[image]

Sitecore 6.4.1 API
ScriptFactory..::..InvalidateCache Method
ScriptFactory Class See Also Send Feedback

Namespace: Sitecore.CodeDom.Scripts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void InvalidateCache()
Visual Basic
Public Shared Sub InvalidateCache
Visual C++
public:
static void InvalidateCache()

See Also

ScriptFactory Class
Sitecore.CodeDom.Scripts Namespace


SyntaxCheck Method

[image]

Sitecore 6.4.1 API
ScriptFactory..::..SyntaxCheck Method
ScriptFactory Class See Also Send Feedback

Namespace: Sitecore.CodeDom.Scripts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static CompilerErrorCollection SyntaxCheck(
    IEnumerable<string> references,
    string code,
    string language
)
Visual Basic
Public Shared Function SyntaxCheck ( _
    references As IEnumerable(Of String), _
    code As String, _
    language As String _
) As CompilerErrorCollection
Visual C++
public:
static CompilerErrorCollection^ SyntaxCheck(
    IEnumerable<String^>^ references,
    String^ code,
    String^ language
)

Parameters

references
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' String >)>)>
The references.
code
Type: System..::..String
The source code.
language
Type: System..::..String
The language.

Return Value

The list of errors.

See Also

ScriptFactory Class
Sitecore.CodeDom.Scripts Namespace


Sitecore.Collections Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Collections Namespace
Send Feedback

Classes

 | Class | Description
Public class | Attribute | Attribute class
Public class | AttributeList | AttributeList class
Public class | ChildList | Represents a list of children.
Public class | DataProviderCollection | Represents a data provider collection.
Public class | FieldCollection | Represents a collection of fields.
Public class | FieldValueDictionary | Dictionary holding a list of templates indexed by template id.
Public class | HashDictionary<(Of <(<'TKey, TValue>)>)> | HashDictionary class
Public class | HashList<(Of <(<'TKey, TValue>)>)> | Maintains a hash table of objects with the ability to retrieve the objects in the same order as they were put in.
Public class | HistoryEntryCollection | Represents a HistoryEntryCollection.
Public class | IdCollection | Collection holding a list of id's.
Public class | IdList | Holds a list of Ids.
Public class | IDList | Represents a list of Ids.
Public class | IndexedDictionary | Maintains a dictionary of objects with the ability to retrieve the objects in the same order as they were put in.
Public class | ItemCollection | Represents a collection of Item objects.
Public class | ItemList | Represents a list of Item objects.
Public class | JobCollection | Collection class for holding jobs.
Public class | LanguageCollection | Holds a collection of languages.
Public class | LanguageDictionary | Dictionary of Languages
Public class | LanguageList | Represents a list of languages.
Public class | LockSet | LockSet class
Public class | MinMax<(Of <(<'T>)>)> | MinMax class
Public class | Pair<(Of <(<'T1, T2>)>)> | Represents a pair.
Public class | PerformanceCounterCollection | Represents a performance counter collection.
Public class | ReadOnlyList<(Of <(<'TElement>)>)> | ReadOnlyList class
Public class | ReadOnlyStringList | ReadOnlyStringList
Public class | SafeDictionary<(Of <(<'TKeyAndValue>)>)> | Dictionary using the same type for keys and values (and allowing dictionary[key] without exceptions).
Public class | SafeDictionary<(Of <(<'TKey, TValue>)>)> | Dictionary allowing dictionary[key] without exceptions.
Public class | Set<(Of <(<'T>)>)> | Set
Public class | StringDictionary | StringDictionary class
Public class | StringHashtable | Maintains a Hashtable of strings.
Public class | StringList | StringList class
Public class | TemplateDictionary | Dictionary holding a list of templates indexed by template id.
Public class | VersionCollection | Collection class for holding Version.
Public class | VersionList | Represents a list of versions.
Public class | VersionUriList | VersionList

Enumerations

 | Enumeration | Description
Public enumeration | ChildListOptions | Specifies security options for the ChildList class.


Attribute Class

[image]

Sitecore 6.4.1 API
Attribute Class
Members See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Attribute
Visual Basic
Public Class Attribute
Visual C++
public ref class Attribute

Inheritance Hierarchy

System..::..Object
Sitecore.Collections..::..Attribute

See Also

Attribute Members
Sitecore.Collections Namespace


Attribute Members

[image] [image]

Sitecore 6.4.1 API
Attribute Members
Attribute Class Constructors Methods Properties See Also Send Feedback

The Attribute type exposes the following members.

Constructors

 | Name | Description
Public method | Attribute | Initializes a new instance of the Attribute class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | Gets the name.
Public property | Value | Gets the value.

See Also

Attribute Class
Sitecore.Collections Namespace


Attribute Constructor

[image]

Sitecore 6.4.1 API
Attribute Constructor
Attribute Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Attribute(
    string name,
    string value
)
Visual Basic
Public Sub New ( _
    name As String, _
    value As String _
)
Visual C++
public:
Attribute(
    String^ name,
    String^ value
)

Parameters

name
Type: System..::..String
The name.
value
Type: System..::..String
The value.

See Also

Attribute Class
Sitecore.Collections Namespace


Attribute Methods

[image] [image]

Sitecore 6.4.1 API
Attribute Methods
Attribute Class See Also Send Feedback

The Attribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Attribute Class
Sitecore.Collections Namespace


Attribute Properties

[image] [image]

Sitecore 6.4.1 API
Attribute Properties
Attribute Class See Also Send Feedback

The Attribute type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the name.
Public property | Value | Gets the value.

See Also

Attribute Class
Sitecore.Collections Namespace


Name Property

[image]

Sitecore 6.4.1 API
Attribute..::..Name Property
Attribute Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

Attribute Class
Sitecore.Collections Namespace


AttributeList Class

[image]

Sitecore 6.4.1 API
AttributeList Class
Members See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class AttributeList : ReadOnlyList<Attribute>
Visual Basic
Public Class AttributeList _
    Inherits ReadOnlyList(Of Attribute)
Visual C++
public ref class AttributeList : public ReadOnlyList<Attribute^>

Inheritance Hierarchy

System..::..Object
Sitecore.Collections..::..ReadOnlyList <(Of <(<' Attribute >)>)>
Sitecore.Collections..::..AttributeList

See Also

AttributeList Members
Sitecore.Collections Namespace


AttributeList Members

[image] [image]

Sitecore 6.4.1 API
AttributeList Members
AttributeList Class Constructors Methods Properties See Also Send Feedback

The AttributeList type exposes the following members.

Constructors

 | Name | Description
Public method | AttributeList()()()() | Initializes a new instance of the AttributeList class.
Public method | AttributeList(array<String>[]()[][]) | Initializes a new instance of the AttributeList class.
Public method | AttributeList(array<Attribute>[]()[][]) | Initializes a new instance of the AttributeList class.
Public method | AttributeList(IEnumerable<(Of <<'(Attribute>)>>)) | Initializes a new instance of the AttributeList class.

Methods

 | Name | Description
Public method | Contains | Determines whether the list contains the specified element. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToArray | Converts the list to an array. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of entries in the list. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public property | Item[([( String])]) | Gets the String with the specified attribute name.
Public property | Item[([( Int32])]) | Gets the element at the specified index. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)

See Also

AttributeList Class
Sitecore.Collections Namespace


AttributeList Constructor

[image] [image]

Sitecore 6.4.1 API
AttributeList Constructor
AttributeList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AttributeList()()()() | Initializes a new instance of the AttributeList class.
Public method | AttributeList(array<String>[]()[][]) | Initializes a new instance of the AttributeList class.
Public method | AttributeList(array<Attribute>[]()[][]) | Initializes a new instance of the AttributeList class.
Public method | AttributeList(IEnumerable<(Of <<'(Attribute>)>>)) | Initializes a new instance of the AttributeList class.

See Also

AttributeList Class
AttributeList Members
Sitecore.Collections Namespace


AttributeList Constructor

[image]

Sitecore 6.4.1 API
AttributeList Constructor
AttributeList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AttributeList()
Visual Basic
Public Sub New
Visual C++
public:
AttributeList()

See Also

AttributeList Class
AttributeList Overload
Sitecore.Collections Namespace


AttributeList Constructor (String[])

[image]

Sitecore 6.4.1 API
AttributeList Constructor (array<String>[]()[][])
AttributeList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AttributeList(
    params string[] entries
)
Visual Basic
Public Sub New ( _
    ParamArray entries As String() _
)
Visual C++
public:
AttributeList(
    ... array<String^>^ entries
)

Parameters

entries
Type: array< System..::..String >[]()[][]
The entries.

See Also

AttributeList Class
AttributeList Overload
Sitecore.Collections Namespace


AttributeList Constructor (Attribute[])

[image]

Sitecore 6.4.1 API
AttributeList Constructor (array<Attribute>[]()[][])
AttributeList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AttributeList(
    params Attribute[] entries
)
Visual Basic
Public Sub New ( _
    ParamArray entries As Attribute() _
)
Visual C++
public:
AttributeList(
    ... array<Attribute^>^ entries
)

Parameters

entries
Type: array< Sitecore.Collections..::..Attribute >[]()[][]
The entries.

See Also

AttributeList Class
AttributeList Overload
Sitecore.Collections Namespace


AttributeList Constructor (IEnumerable(Attribute))

[image]

Sitecore 6.4.1 API
AttributeList Constructor (IEnumerable<(Of <(<'Attribute>)>)>)
AttributeList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AttributeList(
    IEnumerable<Attribute> entries
)
Visual Basic
Public Sub New ( _
    entries As IEnumerable(Of Attribute) _
)
Visual C++
public:
AttributeList(
    IEnumerable<Attribute^>^ entries
)

Parameters

entries
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Attribute >)>)>
The entries.

See Also

AttributeList Class
AttributeList Overload
Sitecore.Collections Namespace


AttributeList Methods

[image] [image]

Sitecore 6.4.1 API
AttributeList Methods
AttributeList Class See Also Send Feedback

The AttributeList type exposes the following members.

Methods

 | Name | Description
Public method | Contains | Determines whether the list contains the specified element. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToArray | Converts the list to an array. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AttributeList Class
Sitecore.Collections Namespace


Item Property

[image] [image]

Sitecore 6.4.1 API
AttributeList..::..Item Property
AttributeList Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( String])]) | Gets the String with the specified attribute name.
Public property | Item[([( Int32])]) | Gets the element at the specified index. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)

See Also

AttributeList Class
AttributeList Members
Sitecore.Collections Namespace


Item Property (String)

[image]

Sitecore 6.4.1 API
AttributeList..::..Item Property (String)
AttributeList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string this[
    string attributeName
] { get; }
Visual Basic
Public Overridable ReadOnly Default Property Item ( _
    attributeName As String _
) As String
    Get
Visual C++
public:
virtual property String^ default[String^ attributeName] {
    String^ get (String^ attributeName);
}

Parameters

attributeName
Type: System..::..String

Field Value

See Also

AttributeList Class
Item Overload
Sitecore.Collections Namespace


ChildList Class

[image]

Sitecore 6.4.1 API
ChildList Class
Members See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ChildList : IEnumerable<Item>,
    ICollection, IEnumerable
Visual Basic
Public Class ChildList _
    Implements IEnumerable(Of Item), ICollection,  _
    IEnumerable
Visual C++
public ref class ChildList : IEnumerable<Item^>,
    ICollection, IEnumerable

Inheritance Hierarchy

System..::..Object
Sitecore.Collections..::..ChildList

See Also

ChildList Members
Sitecore.Collections Namespace


ChildList Members

[image] [image]

Sitecore 6.4.1 API
ChildList Members
ChildList Class Constructors Methods Properties See Also Send Feedback

The ChildList type exposes the following members.

Constructors

 | Name | Description
Public method | ChildList(Item) | Initializes a new instance of the ChildList class.
Public method | ChildList(Item, ChildListOptions) | Initializes a new instance of the ChildList class.
Public method | ChildList(Item, ItemList) | Initializes a new instance of the ChildList class.
Public method | ChildList(Item, ICollection) | Initializes a new instance of the ChildList class.

Methods

 | Name | Description
Public method | CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(ID) | Searches for the item and returns the zero-based index of the first occurrence within the entire ChildList.
Public method | IndexOf(Item) | Searches for the item and returns the zero-based index of the first occurrence within the entire ChildList.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Populate | Populates the childlist.
Public method | Reset()()()() | Resets the child collection.
Public method | Reset(ChildListOptions) | Resets the child collection.
Public method | Sort()()()() | Sorts the child list.
Public method | Sort(IComparer) | Obsolete. Sorts the child list using the specified comparer.
Public method | Sort(IComparer<(Of <<'(Item>)>>)) | Sorts the child list using the specified comparer.
Public method | ToArray | Converts the child list to an array of items.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | Convert<(Of <<'(Item, TTo>)>>) | Converts this instance. (Defined by EnumerableExtensions.)
Public Extension Method | StringConcatenate<(Of <<'(Item>)>>) | Concatenate strings (Defined by IEnumerableExtensions.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection.
Public property | InnerChildren | Gets the inner children.
Public property | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe).
Public property | Item[([( Int32])]) | Gets the Item at the specified index.
Public property | Item[([( String])]) | Gets the Item with the specified child name.
Public property | Item[([( ID])]) | Gets the Item with the specified child ID.
Public property | OwnerItem | Gets the owner item.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the ICollection.

See Also

ChildList Class
Sitecore.Collections Namespace


ChildList Constructor

[image] [image]

Sitecore 6.4.1 API
ChildList Constructor
ChildList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ChildList(Item) | Initializes a new instance of the ChildList class.
Public method | ChildList(Item, ChildListOptions) | Initializes a new instance of the ChildList class.
Public method | ChildList(Item, ItemList) | Initializes a new instance of the ChildList class.
Public method | ChildList(Item, ICollection) | Initializes a new instance of the ChildList class.

See Also

ChildList Class
ChildList Members
Sitecore.Collections Namespace


ChildList Constructor (Item)

[image]

Sitecore 6.4.1 API
ChildList Constructor (Item)
ChildList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ChildList(
    Item ownerItem
)
Visual Basic
Public Sub New ( _
    ownerItem As Item _
)
Visual C++
public:
ChildList(
    Item^ ownerItem
)

Parameters

ownerItem
Type: Sitecore.Data.Items..::..Item
The owner item.

See Also

ChildList Class
ChildList Overload
Sitecore.Collections Namespace


ChildList Constructor (Item, ChildListOptions)

[image]

Sitecore 6.4.1 API
ChildList Constructor (Item, ChildListOptions)
ChildList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ChildList(
    Item ownerItem,
    ChildListOptions options
)
Visual Basic
Public Sub New ( _
    ownerItem As Item, _
    options As ChildListOptions _
)
Visual C++
public:
ChildList(
    Item^ ownerItem,
    ChildListOptions options
)

Parameters

ownerItem
Type: Sitecore.Data.Items..::..Item
The owner item.
options
Type: Sitecore.Collections..::..ChildListOptions
The options.

See Also

ChildList Class
ChildList Overload
Sitecore.Collections Namespace


ChildList Constructor (Item, ICollection)

[image]

Sitecore 6.4.1 API
ChildList Constructor (Item, ICollection)
ChildList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ChildList(
    Item ownerItem,
    ICollection children
)
Visual Basic
Public Sub New ( _
    ownerItem As Item, _
    children As ICollection _
)
Visual C++
public:
ChildList(
    Item^ ownerItem,
    ICollection^ children
)

Parameters

ownerItem
Type: Sitecore.Data.Items..::..Item
The owner item.
children
Type: System.Collections..::..ICollection
The children.

See Also

ChildList Class
ChildList Overload
Sitecore.Collections Namespace


ChildList Methods

[image] [image]

Sitecore 6.4.1 API
ChildList Methods
ChildList Class See Also Send Feedback

The ChildList type exposes the following members.

Methods

 | Name | Description
Public method | CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(ID) | Searches for the item and returns the zero-based index of the first occurrence within the entire ChildList.
Public method | IndexOf(Item) | Searches for the item and returns the zero-based index of the first occurrence within the entire ChildList.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Populate | Populates the childlist.
Public method | Reset()()()() | Resets the child collection.
Public method | Reset(ChildListOptions) | Resets the child collection.
Public method | Sort()()()() | Sorts the child list.
Public method | Sort(IComparer) | Obsolete. Sorts the child list using the specified comparer.
Public method | Sort(IComparer<(Of <<'(Item>)>>)) | Sorts the child list using the specified comparer.
Public method | ToArray | Converts the child list to an array of items.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | Convert<(Of <<'(Item, TTo>)>>) | Converts this instance. (Defined by EnumerableExtensions.)
Public Extension Method | StringConcatenate<(Of <<'(Item>)>>) | Concatenate strings (Defined by IEnumerableExtensions.)

See Also

ChildList Class
Sitecore.Collections Namespace


CopyTo Method

[image]

Sitecore 6.4.1 API
ChildList..::..CopyTo Method
ChildList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void CopyTo(
    Array array,
    int index
)
Visual Basic
Public Sub CopyTo ( _
    array As Array, _
    index As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int index
) sealed

Parameters

array
Type: System..::..Array
The one-dimensional Array that is the destination of the elements copied from ICollection. The Array must have zero-based indexing.
index
Type: System..::..Int32
The zero-based index in array at which copying begins.

Implements

ICollection..::..CopyTo(Array, Int32)

Exceptions

Exception | Condition
System..::..ArgumentNullException | array is null.
System..::..ArgumentOutOfRangeException | index is less than zero.
System..::..ArgumentException | array is multidimensional.-or- index is equal to or greater than the length of array.-or- The number of elements in the source ICollection is greater than the available space from index to the end of the destination array.
System..::..InvalidCastException | The type of the source ICollection cannot be cast automatically to the type of the destination array.

See Also

ChildList Class
Sitecore.Collections Namespace


GetEnumerator Method

[image]

Sitecore 6.4.1 API
ChildList..::..GetEnumerator Method
ChildList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator() sealed

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

ChildList Class
Sitecore.Collections Namespace


IndexOf Method

[image] [image]

Sitecore 6.4.1 API
ChildList..::..IndexOf Method
ChildList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(ID) | Searches for the item and returns the zero-based index of the first occurrence within the entire ChildList.
Public method | IndexOf(Item) | Searches for the item and returns the zero-based index of the first occurrence within the entire ChildList.

See Also

ChildList Class
ChildList Members
Sitecore.Collections Namespace


IndexOf Method (ID)

[image]

Sitecore 6.4.1 API
ChildList..::..IndexOf Method (ID)
ChildList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int IndexOf(
    ID itemId
)
Visual Basic
Public Function IndexOf ( _
    itemId As ID _
) As Integer
Visual C++
public:
int IndexOf(
    ID^ itemId
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item ID.

Return Value

[Missing <returns> documentation for "M:Sitecore.Collections.ChildList.IndexOf(Sitecore.Data.ID)"]

See Also

ChildList Class
IndexOf Overload
Sitecore.Collections Namespace


IndexOf Method (Item)

[image]

Sitecore 6.4.1 API
ChildList..::..IndexOf Method (Item)
ChildList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int IndexOf(
    Item item
)
Visual Basic
Public Function IndexOf ( _
    item As Item _
) As Integer
Visual C++
public:
int IndexOf(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Collections.ChildList.IndexOf(Sitecore.Data.Items.Item)"]

See Also

ChildList Class
IndexOf Overload
Sitecore.Collections Namespace


Populate Method

[image]

Sitecore 6.4.1 API
ChildList..::..Populate Method
ChildList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual ItemList Populate(
    ChildListOptions options
)
Visual Basic
Protected Overridable Function Populate ( _
    options As ChildListOptions _
) As ItemList
Visual C++
protected:
virtual ItemList^ Populate(
    ChildListOptions options
)

Parameters

options
Type: Sitecore.Collections..::..ChildListOptions

[Missing <param name="options"/> documentation for "M:Sitecore.Collections.ChildList.Populate(Sitecore.Collections.ChildListOptions)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Collections.ChildList.Populate(Sitecore.Collections.ChildListOptions)"]

See Also

ChildList Class
Sitecore.Collections Namespace


Reset Method

[image] [image]

Sitecore 6.4.1 API
ChildList..::..Reset Method
ChildList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reset()()()() | Resets the child collection.
Public method | Reset(ChildListOptions) | Resets the child collection.

See Also

ChildList Class
ChildList Members
Sitecore.Collections Namespace


Reset Method

[image]

Sitecore 6.4.1 API
ChildList..::..Reset Method
ChildList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset
Visual C++
public:
void Reset()

See Also

ChildList Class
Reset Overload
Sitecore.Collections Namespace


Sort Method

[image] [image]

Sitecore 6.4.1 API
ChildList..::..Sort Method
ChildList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort()()()() | Sorts the child list.
Public method | Sort(IComparer) | Obsolete. Sorts the child list using the specified comparer.
Public method | Sort(IComparer<(Of <<'(Item>)>>)) | Sorts the child list using the specified comparer.

See Also

ChildList Class
ChildList Members
Sitecore.Collections Namespace


Sort Method

[image]

Sitecore 6.4.1 API
ChildList..::..Sort Method
ChildList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Sort()
Visual Basic
Public Sub Sort
Visual C++
public:
void Sort()

See Also

ChildList Class
Sort Overload
Sitecore.Collections Namespace


Sort Method (IComparer)

[image]

Sitecore 6.4.1 API
ChildList..::..Sort Method (IComparer)
ChildList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated. Use Sort(IComparer<Item> comparer) instead.")]
public void Sort(
    IComparer comparer
)
Visual Basic
<ObsoleteAttribute("Deprecated. Use Sort(IComparer<Item> comparer) instead.")> _
Public Sub Sort ( _
    comparer As IComparer _
)
Visual C++
[ObsoleteAttribute(L"Deprecated. Use Sort(IComparer<Item> comparer) instead.")]
public:
void Sort(
    IComparer^ comparer
)

Parameters

comparer
Type: System.Collections..::..IComparer
The comparer.

See Also

ChildList Class
Sort Overload
Sitecore.Collections Namespace


Sort Method (IComparer(Item))

[image]

Sitecore 6.4.1 API
ChildList..::..Sort Method (IComparer<(Of <(<'Item>)>)>)
ChildList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Sort(
    IComparer<Item> comparer
)
Visual Basic
Public Sub Sort ( _
    comparer As IComparer(Of Item) _
)
Visual C++
public:
void Sort(
    IComparer<Item^>^ comparer
)

Parameters

comparer
Type: System.Collections.Generic..::..IComparer <(Of <(<' Item >)>)>
The comparer.

See Also

ChildList Class
Sort Overload
Sitecore.Collections Namespace


ToArray Method

[image]

Sitecore 6.4.1 API
ChildList..::..ToArray Method
ChildList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item[] ToArray()
Visual Basic
Public Function ToArray As Item()
Visual C++
public:
array<Item^>^ ToArray()

Return Value

[Missing <returns> documentation for "M:Sitecore.Collections.ChildList.ToArray"]

See Also

ChildList Class
Sitecore.Collections Namespace


ChildList Properties

[image] [image]

Sitecore 6.4.1 API
ChildList Properties
ChildList Class See Also Send Feedback

The ChildList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection.
Public property | InnerChildren | Gets the inner children.
Public property | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe).
Public property | Item[([( Int32])]) | Gets the Item at the specified index.
Public property | Item[([( String])]) | Gets the Item with the specified child name.
Public property | Item[([( ID])]) | Gets the Item with the specified child ID.
Public property | OwnerItem | Gets the owner item.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the ICollection.

See Also

ChildList Class
Sitecore.Collections Namespace


Count Property

[image]

Sitecore 6.4.1 API
ChildList..::..Count Property
ChildList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Field Value

Return Value

The number of elements contained in the ICollection.

Implements

ICollection..::..Count

See Also

ChildList Class
Sitecore.Collections Namespace


InnerChildren Property

[image]

Sitecore 6.4.1 API
ChildList..::..InnerChildren Property
ChildList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemList InnerChildren { get; }
Visual Basic
Public ReadOnly Property InnerChildren As ItemList
    Get
Visual C++
public:
property ItemList^ InnerChildren {
    ItemList^ get ();
}

Field Value

The inner children.

See Also

ChildList Class
Sitecore.Collections Namespace


IsSynchronized Property

[image]

Sitecore 6.4.1 API
ChildList..::..IsSynchronized Property
ChildList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsSynchronized { get; }
Visual Basic
Public ReadOnly Property IsSynchronized As Boolean
    Get
Visual C++
public:
virtual property bool IsSynchronized {
    bool get () sealed;
}

Field Value

Return Value

true if access to the ICollection is synchronized (thread safe); otherwise, false.

Implements

ICollection..::..IsSynchronized

See Also

ChildList Class
Sitecore.Collections Namespace


Item Property

[image] [image]

Sitecore 6.4.1 API
ChildList..::..Item Property
ChildList Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gets the Item at the specified index.
Public property | Item[([( String])]) | Gets the Item with the specified child name.
Public property | Item[([( ID])]) | Gets the Item with the specified child ID.

See Also

ChildList Class
ChildList Members
Sitecore.Collections Namespace


Item Property (Int32)

[image]

Sitecore 6.4.1 API
ChildList..::..Item Property (Int32)
ChildList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    index As Integer _
) As Item
    Get
Visual C++
public:
property Item^ default[int index] {
    Item^ get (int index);
}

Parameters

index
Type: System..::..Int32

Field Value

See Also

ChildList Class
Item Overload
Sitecore.Collections Namespace


Item Property (String)

[image]

Sitecore 6.4.1 API
ChildList..::..Item Property (String)
ChildList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item this[
    string childName
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    childName As String _
) As Item
    Get
Visual C++
public:
property Item^ default[String^ childName] {
    Item^ get (String^ childName);
}

Parameters

childName
Type: System..::..String

Field Value

See Also

ChildList Class
Item Overload
Sitecore.Collections Namespace


Item Property (ID)

[image]

Sitecore 6.4.1 API
ChildList..::..Item Property (ID)
ChildList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item this[
    ID childId
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    childId As ID _
) As Item
    Get
Visual C++
public:
property Item^ default[ID^ childId] {
    Item^ get (ID^ childId);
}

Parameters

childId
Type: Sitecore.Data..::..ID

Field Value

See Also

ChildList Class
Item Overload
Sitecore.Collections Namespace


OwnerItem Property

[image]

Sitecore 6.4.1 API
ChildList..::..OwnerItem Property
ChildList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item OwnerItem { get; }
Visual Basic
Public ReadOnly Property OwnerItem As Item
    Get
Visual C++
public:
property Item^ OwnerItem {
    Item^ get ();
}

Field Value

The owner item.

See Also

ChildList Class
Sitecore.Collections Namespace


SyncRoot Property

[image]

Sitecore 6.4.1 API
ChildList..::..SyncRoot Property
ChildList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object SyncRoot { get; }
Visual Basic
Public ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get () sealed;
}

Field Value

Return Value

An object that can be used to synchronize access to the ICollection.

Implements

ICollection..::..SyncRoot

See Also

ChildList Class
Sitecore.Collections Namespace


ChildListOptions Enumeration

[image]

Sitecore 6.4.1 API
ChildListOptions Enumeration
See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[FlagsAttribute]
public enum ChildListOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration ChildListOptions
Visual C++
[FlagsAttribute]
public enum class ChildListOptions

Members

Member name | Value | Description
None | 0 |
IgnoreSecurity | 1 |
AllowReuse | 2 |

See Also

Sitecore.Collections Namespace


DataProviderCollection Class

[image]

Sitecore 6.4.1 API
DataProviderCollection Class
Members See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DataProviderCollection : Collection<DataProvider>
Visual Basic
Public Class DataProviderCollection _
    Inherits Collection(Of DataProvider)
Visual C++
public ref class DataProviderCollection : public Collection<DataProvider^>

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<' DataProvider >)>)>
Sitecore.Collections..::..DataProviderCollection

See Also

DataProviderCollection Members
Sitecore.Collections Namespace


DataProviderCollection Members

[image] [image]

Sitecore 6.4.1 API
DataProviderCollection Members
DataProviderCollection Class Constructors Methods Properties See Also Send Feedback

The DataProviderCollection type exposes the following members.

Constructors

 | Name | Description
Public method | DataProviderCollection | Initializes a new instance of the DataProviderCollection class

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataProvider >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataProvider >)>)>.)
Protected method | ClearItems | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataProvider >)>)>.)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataProvider >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' DataProvider >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataProvider >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataProvider >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' DataProvider >)>)>.)
Protected method | InsertItem | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' DataProvider >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataProvider >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataProvider >)>)>.)
Protected method | RemoveItem | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataProvider >)>)>.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from Collection <(Of <(<' DataProvider >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataProvider >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' DataProvider >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataProvider >)>)>.)

See Also

DataProviderCollection Class
Sitecore.Collections Namespace


DataProviderCollection Methods

[image] [image]

Sitecore 6.4.1 API
DataProviderCollection Methods
DataProviderCollection Class See Also Send Feedback

The DataProviderCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataProvider >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataProvider >)>)>.)
Protected method | ClearItems | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataProvider >)>)>.)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataProvider >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' DataProvider >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataProvider >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataProvider >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' DataProvider >)>)>.)
Protected method | InsertItem | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' DataProvider >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataProvider >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataProvider >)>)>.)
Protected method | RemoveItem | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataProvider >)>)>.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from Collection <(Of <(<' DataProvider >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataProviderCollection Class
Sitecore.Collections Namespace


DataProviderCollection Properties

[image] [image]

Sitecore 6.4.1 API
DataProviderCollection Properties
DataProviderCollection Class See Also Send Feedback

The DataProviderCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataProvider >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' DataProvider >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataProvider >)>)>.)

See Also

DataProviderCollection Class
Sitecore.Collections Namespace


FieldCollection Class

[image]

Sitecore 6.4.1 API
FieldCollection Class
Members See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FieldCollection : ICollection,
    IEnumerable<Field>, IEnumerable
Visual Basic
Public Class FieldCollection _
    Implements ICollection, IEnumerable(Of Field),  _
    IEnumerable
Visual C++
public ref class FieldCollection : ICollection,
    IEnumerable<Field^>, IEnumerable

Inheritance Hierarchy

System..::..Object
Sitecore.Collections..::..FieldCollection

See Also

FieldCollection Members
Sitecore.Collections Namespace


FieldCollection Constructor

[image]

Sitecore 6.4.1 API
FieldCollection Constructor
FieldCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FieldCollection(
    Item ownerItem
)
Visual Basic
Public Sub New ( _
    ownerItem As Item _
)
Visual C++
public:
FieldCollection(
    Item^ ownerItem
)

Parameters

ownerItem
Type: Sitecore.Data.Items..::..Item
The owner item.

See Also

FieldCollection Class
Sitecore.Collections Namespace


FieldCollection Methods

[image] [image]

Sitecore 6.4.1 API
FieldCollection Methods
FieldCollection Class See Also Send Feedback

The FieldCollection type exposes the following members.

Methods

 | Name | Description
Public method | Contains | Determines whether the collection contains a field with the specified id.
Public method | CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index.
Public method | EnsureField(Field) | Ensures that the field is included in the internal field collection.
Public method | EnsureField(ID) | Ensures that the field is included in the internal field collection.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadAll | Reads all.
Public method | Reset | Resets this instance.
Public method | Sort | Sorts the list of fields.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | Convert<(Of <<'(Field, TTo>)>>) | Converts this instance. (Defined by EnumerableExtensions.)
Public Extension Method | StringConcatenate<(Of <<'(Field>)>>) | Concatenate strings (Defined by IEnumerableExtensions.)

See Also

FieldCollection Class
Sitecore.Collections Namespace


Contains Method

[image]

Sitecore 6.4.1 API
FieldCollection..::..Contains Method
FieldCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Contains(
    ID fieldId
)
Visual Basic
Public Function Contains ( _
    fieldId As ID _
) As Boolean
Visual C++
public:
bool Contains(
    ID^ fieldId
)

Parameters

fieldId
Type: Sitecore.Data..::..ID
The field id.

Return Value

true if the specified field id has field; otherwise, false.

See Also

FieldCollection Class
Sitecore.Collections Namespace


CopyTo Method

[image]

Sitecore 6.4.1 API
FieldCollection..::..CopyTo Method
FieldCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void CopyTo(
    Array array,
    int index
)
Visual Basic
Public Sub CopyTo ( _
    array As Array, _
    index As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int index
) sealed

Parameters

array
Type: System..::..Array
The one-dimensional Array that is the destination of the elements copied from ICollection. The Array must have zero-based indexing.
index
Type: System..::..Int32
The zero-based index in array at which copying begins.

Implements

ICollection..::..CopyTo(Array, Int32)

Exceptions

Exception | Condition
System..::..ArgumentNullException | array is null.
System..::..ArgumentOutOfRangeException | index is less than zero.
System..::..ArgumentException | array is multidimensional.-or- index is equal to or greater than the length of array.-or- The number of elements in the source ICollection is greater than the available space from index to the end of the destination array.
System..::..InvalidCastException | The type of the source ICollection cannot be cast automatically to the type of the destination array.

See Also

FieldCollection Class
Sitecore.Collections Namespace


EnsureField Method

[image] [image]

Sitecore 6.4.1 API
FieldCollection..::..EnsureField Method
FieldCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EnsureField(Field) | Ensures that the field is included in the internal field collection.
Public method | EnsureField(ID) | Ensures that the field is included in the internal field collection.

See Also

FieldCollection Class
FieldCollection Members
Sitecore.Collections Namespace


EnsureField Method (Field)

[image]

Sitecore 6.4.1 API
FieldCollection..::..EnsureField Method (Field)
FieldCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void EnsureField(
    Field field
)
Visual Basic
Public Sub EnsureField ( _
    field As Field _
)
Visual C++
public:
void EnsureField(
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.

See Also

FieldCollection Class
EnsureField Overload
Sitecore.Collections Namespace


EnsureField Method (ID)

[image]

Sitecore 6.4.1 API
FieldCollection..::..EnsureField Method (ID)
FieldCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void EnsureField(
    ID fieldId
)
Visual Basic
Public Sub EnsureField ( _
    fieldId As ID _
)
Visual C++
public:
void EnsureField(
    ID^ fieldId
)

Parameters

fieldId
Type: Sitecore.Data..::..ID
The field id.

See Also

FieldCollection Class
EnsureField Overload
Sitecore.Collections Namespace


GetEnumerator Method

[image]

Sitecore 6.4.1 API
FieldCollection..::..GetEnumerator Method
FieldCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator() sealed

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

FieldCollection Class
Sitecore.Collections Namespace


ReadAll Method

[image]

Sitecore 6.4.1 API
FieldCollection..::..ReadAll Method
FieldCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void ReadAll()
Visual Basic
Public Sub ReadAll
Visual C++
public:
void ReadAll()

See Also

FieldCollection Class
Sitecore.Collections Namespace


Reset Method

[image]

Sitecore 6.4.1 API
FieldCollection..::..Reset Method
FieldCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset
Visual C++
public:
void Reset()

See Also

FieldCollection Class
Sitecore.Collections Namespace


Sort Method

[image]

Sitecore 6.4.1 API
FieldCollection..::..Sort Method
FieldCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Sort()
Visual Basic
Public Sub Sort
Visual C++
public:
void Sort()

See Also

FieldCollection Class
Sitecore.Collections Namespace


FieldCollection Properties

[image] [image]

Sitecore 6.4.1 API
FieldCollection Properties
FieldCollection Class See Also Send Feedback

The FieldCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection.
Public property | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe).
Public property | Item[([( Int32])]) | Gets the Field at the specified index.
Public property | Item[([( String])]) | Gets the Field with the specified field name.
Public property | Item[([( ID])]) | Gets the Field with the specified field ID.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the ICollection.

See Also

FieldCollection Class
Sitecore.Collections Namespace


IsSynchronized Property

[image]

Sitecore 6.4.1 API
FieldCollection..::..IsSynchronized Property
FieldCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsSynchronized { get; }
Visual Basic
Public ReadOnly Property IsSynchronized As Boolean
    Get
Visual C++
public:
virtual property bool IsSynchronized {
    bool get () sealed;
}

Field Value

Implements

ICollection..::..IsSynchronized

See Also

FieldCollection Class
Sitecore.Collections Namespace


Item Property (Int32)

[image]

Sitecore 6.4.1 API
FieldCollection..::..Item Property (Int32)
FieldCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Field this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    index As Integer _
) As Field
    Get
Visual C++
public:
property Field^ default[int index] {
    Field^ get (int index);
}

Parameters

index
Type: System..::..Int32

Field Value

The Field.

See Also

FieldCollection Class
Item Overload
Sitecore.Collections Namespace


Item Property (String)

[image]

Sitecore 6.4.1 API
FieldCollection..::..Item Property (String)
FieldCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Field this[
    string fieldName
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    fieldName As String _
) As Field
    Get
Visual C++
public:
property Field^ default[String^ fieldName] {
    Field^ get (String^ fieldName);
}

Parameters

fieldName
Type: System..::..String

Field Value

The Field.

See Also

FieldCollection Class
Item Overload
Sitecore.Collections Namespace


Item Property (ID)

[image]

Sitecore 6.4.1 API
FieldCollection..::..Item Property (ID)
FieldCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Field this[
    ID fieldID
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    fieldID As ID _
) As Field
    Get
Visual C++
public:
property Field^ default[ID^ fieldID] {
    Field^ get (ID^ fieldID);
}

Parameters

fieldID
Type: Sitecore.Data..::..ID

Field Value

The Field.

See Also

FieldCollection Class
Item Overload
Sitecore.Collections Namespace


SyncRoot Property

[image]

Sitecore 6.4.1 API
FieldCollection..::..SyncRoot Property
FieldCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object SyncRoot { get; }
Visual Basic
Public ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get () sealed;
}

Field Value

Implements

ICollection..::..SyncRoot

See Also

FieldCollection Class
Sitecore.Collections Namespace


FieldValueDictionary Class

[image]

Sitecore 6.4.1 API
FieldValueDictionary Class
Members See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class FieldValueDictionary : SafeDictionary<ID, string>
Visual Basic
<SerializableAttribute> _
Public Class FieldValueDictionary _
    Inherits SafeDictionary(Of ID, String)
Visual C++
[SerializableAttribute]
public ref class FieldValueDictionary : public SafeDictionary<ID^, String^>

Inheritance Hierarchy

System..::..Object
Sitecore.Collections..::..SafeDictionary <(Of <(<' ID, String >)>)>
Sitecore.Collections..::..FieldValueDictionary

See Also

FieldValueDictionary Members
Sitecore.Collections Namespace


FieldValueDictionary Members

[image] [image]

Sitecore 6.4.1 API
FieldValueDictionary Members
FieldValueDictionary Class Constructors Methods Properties See Also Send Feedback

The FieldValueDictionary type exposes the following members.

Constructors

 | Name | Description
Protected method | FieldValueDictionary | Initializes a new instance of the FieldValueDictionary class.

Methods

 | Name | Description
Public method | Add | Adds the specified key/value pair to the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | AddRange | Adds a range of key/values. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | Clear | Removes all entries from the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | Clone | Clones this instance. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | ContainsKey | Determines whether the dictionary contains the specified key. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the entry with the specified key from the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | ToKeyArray | Returns an array containing all keys. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToValueArray | Returns an array containing all values. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | TryGetValue | Attempts to get a specific value. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)

Properties

 | Name | Description
Public property | Count | Gets the number of entries in the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Protected property | Hashtable | Gets the internal hashtable. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | Item | Gets or sets the value with the specified key. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | Keys | Gets the keys of the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | ReadOnly | Gets or sets a value indicating whether [read only]. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | SyncRoot | Gets the object to use for locking in multi-thread scenarios. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | Values | Gets the values of the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)

See Also

FieldValueDictionary Class
Sitecore.Collections Namespace


FieldValueDictionary Constructor

[image]

Sitecore 6.4.1 API
FieldValueDictionary Constructor
FieldValueDictionary Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected FieldValueDictionary(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
FieldValueDictionary(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

FieldValueDictionary Class
Sitecore.Collections Namespace


FieldValueDictionary Methods

[image] [image]

Sitecore 6.4.1 API
FieldValueDictionary Methods
FieldValueDictionary Class See Also Send Feedback

The FieldValueDictionary type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key/value pair to the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | AddRange | Adds a range of key/values. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | Clear | Removes all entries from the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | Clone | Clones this instance. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | ContainsKey | Determines whether the dictionary contains the specified key. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the entry with the specified key from the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | ToKeyArray | Returns an array containing all keys. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToValueArray | Returns an array containing all values. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | TryGetValue | Attempts to get a specific value. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)

See Also

FieldValueDictionary Class
Sitecore.Collections Namespace


FieldValueDictionary Properties

[image] [image]

Sitecore 6.4.1 API
FieldValueDictionary Properties
FieldValueDictionary Class See Also Send Feedback

The FieldValueDictionary type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of entries in the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Protected property | Hashtable | Gets the internal hashtable. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | Item | Gets or sets the value with the specified key. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | Keys | Gets the keys of the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | ReadOnly | Gets or sets a value indicating whether [read only]. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | SyncRoot | Gets the object to use for locking in multi-thread scenarios. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | Values | Gets the values of the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)

See Also

FieldValueDictionary Class
Sitecore.Collections Namespace


HashDictionary(TKey, TValue) Class

[image]

Sitecore 6.4.1 API
HashDictionary<(Of <(<'TKey, TValue>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class HashDictionary<TKey, TValue> : Dictionary<TKey, TValue>
where TValue : class
Visual Basic
Public Class HashDictionary(Of TKey, TValue As Class) _
    Inherits Dictionary(Of TKey, TValue)
Visual C++
generic<typename TKey, typename TValue>
where TValue : ref class
public ref class HashDictionary : public Dictionary<TKey, TValue>

Type Parameters

TKey

[Missing <typeparam name="TKey"/> documentation for "T:Sitecore.Collections.HashDictionary`2"]

TValue

[Missing <typeparam name="TValue"/> documentation for "T:Sitecore.Collections.HashDictionary`2"]

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<'TKey, TValue>)>)>
Sitecore.Collections..::..HashDictionary<(Of <(<'TKey, TValue>)>)>

See Also

HashDictionary<(Of <(<'TKey, TValue>)>)> Members
Sitecore.Collections Namespace


HashDictionary(TKey, TValue) Members

[image] [image]

Sitecore 6.4.1 API
HashDictionary<(Of <(<'TKey, TValue>)>)> Members
HashDictionary<(Of <(<'TKey, TValue>)>)> Class Constructors Methods Properties See Also Send Feedback

The HashDictionary<(Of <(<'TKey, TValue>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | HashDictionary<(Of <(<'TKey, TValue>)>)>()()()() | Initializes a new instance of the HashDictionary<(Of <(<'TKey, TValue>)>)> class.
Public method | HashDictionary<(Of <(<'TKey, TValue>)>)>(IEqualityComparer<(Of <<'(TKey>)>>)) | Initializes a new instance of the HashDictionary<(Of <(<'TKey, TValue>)>)> class.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' TKey, TValue >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' TKey, TValue >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' TKey, TValue >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' TKey, TValue >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' TKey, TValue >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' TKey, TValue >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' TKey, TValue >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' TKey, TValue >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' TKey, TValue >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' TKey, TValue >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' TKey, TValue >)>)>.)
Public property | Item | Gets or sets the entry with the specified key.
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' TKey, TValue >)>)>.)
Public property | RemoveNullValues | Gets or sets a value indicating whether [remove null values].
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' TKey, TValue >)>)>.)

See Also

HashDictionary<(Of <(<'TKey, TValue>)>)> Class
Sitecore.Collections Namespace


HashDictionary(TKey, TValue) Constructor

[image] [image]

Sitecore 6.4.1 API
HashDictionary<(Of <(<'TKey, TValue>)>)> Constructor
HashDictionary<(Of <(<'TKey, TValue>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HashDictionary<(Of <(<'TKey, TValue>)>)>()()()() | Initializes a new instance of the HashDictionary<(Of <(<'TKey, TValue>)>)> class.
Public method | HashDictionary<(Of <(<'TKey, TValue>)>)>(IEqualityComparer<(Of <<'(TKey>)>>)) | Initializes a new instance of the HashDictionary<(Of <(<'TKey, TValue>)>)> class.

See Also

HashDictionary<(Of <(<'TKey, TValue>)>)> Class
HashDictionary<(Of <(<'TKey, TValue>)>)> Members
Sitecore.Collections Namespace


HashDictionary(TKey, TValue) Constructor

[image]

Sitecore 6.4.1 API
HashDictionary<(Of <(<'TKey, TValue>)>)> Constructor
HashDictionary<(Of <(<'TKey, TValue>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HashDictionary()
Visual Basic
Public Sub New
Visual C++
public:
HashDictionary()

See Also

HashDictionary<(Of <(<'TKey, TValue>)>)> Class
HashDictionary<(Of <(<'TKey, TValue>)>)> Overload
Sitecore.Collections Namespace


HashDictionary(TKey, TValue) Constructor (IEqualityComparer(TKey))

[image]

Sitecore 6.4.1 API
HashDictionary<(Of <(<'TKey, TValue>)>)> Constructor (IEqualityComparer<(Of <(<'TKey>)>)>)
HashDictionary<(Of <(<'TKey, TValue>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HashDictionary(
    IEqualityComparer<TKey> comparer
)
Visual Basic
Public Sub New ( _
    comparer As IEqualityComparer(Of TKey) _
)
Visual C++
public:
HashDictionary(
    IEqualityComparer<TKey>^ comparer
)

Parameters

comparer
Type: System.Collections.Generic..::..IEqualityComparer <(Of <(<' TKey >)>)>
The comparer.

See Also

HashDictionary<(Of <(<'TKey, TValue>)>)> Class
HashDictionary<(Of <(<'TKey, TValue>)>)> Overload
Sitecore.Collections Namespace


HashDictionary(TKey, TValue) Methods

[image] [image]

Sitecore 6.4.1 API
HashDictionary<(Of <(<'TKey, TValue>)>)> Methods
HashDictionary<(Of <(<'TKey, TValue>)>)> Class See Also Send Feedback

The HashDictionary<(Of <(<'TKey, TValue>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' TKey, TValue >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' TKey, TValue >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' TKey, TValue >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' TKey, TValue >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' TKey, TValue >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' TKey, TValue >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' TKey, TValue >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' TKey, TValue >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' TKey, TValue >)>)>.)

See Also

HashDictionary<(Of <(<'TKey, TValue>)>)> Class
Sitecore.Collections Namespace


HashDictionary(TKey, TValue) Properties

[image] [image]

Sitecore 6.4.1 API
HashDictionary<(Of <(<'TKey, TValue>)>)> Properties
HashDictionary<(Of <(<'TKey, TValue>)>)> Class See Also Send Feedback

The HashDictionary<(Of <(<'TKey, TValue>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' TKey, TValue >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' TKey, TValue >)>)>.)
Public property | Item | Gets or sets the entry with the specified key.
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' TKey, TValue >)>)>.)
Public property | RemoveNullValues | Gets or sets a value indicating whether [remove null values].
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' TKey, TValue >)>)>.)

See Also

HashDictionary<(Of <(<'TKey, TValue>)>)> Class
Sitecore.Collections Namespace


Item Property

[image]

Sitecore 6.4.1 API
HashDictionary<(Of <(<'TKey, TValue>)>)>..::..Item Property
HashDictionary<(Of <(<'TKey, TValue>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual TValue this[
    TKey key
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    key As TKey _
) As TValue
    Get
    Set
Visual C++
public:
virtual property TValue default[TKey key] {
    TValue get (TKey key);
    void set (TKey key, TValue value);
}

Parameters

key
Type: TKey

Field Value

See Also

HashDictionary<(Of <(<'TKey, TValue>)>)> Class
Sitecore.Collections Namespace


RemoveNullValues Property

[image]

Sitecore 6.4.1 API
HashDictionary<(Of <(<'TKey, TValue>)>)>..::..RemoveNullValues Property
HashDictionary<(Of <(<'TKey, TValue>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool RemoveNullValues { get; set; }
Visual Basic
Public Overridable Property RemoveNullValues As Boolean
    Get
    Set
Visual C++
public:
virtual property bool RemoveNullValues {
    bool get ();
    void set (bool value);
}

Field Value

true if [remove null values]; otherwise, false.

See Also

HashDictionary<(Of <(<'TKey, TValue>)>)> Class
Sitecore.Collections Namespace


HashList(TKey, TValue) Class

[image]

Sitecore 6.4.1 API
HashList<(Of <(<'TKey, TValue>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class HashList<TKey, TValue> : ISerializable
where TKey : class
where TValue : class
Visual Basic
<SerializableAttribute> _
Public Class HashList(Of TKey As Class, TValue As Class) _
    Implements ISerializable
Visual C++
[SerializableAttribute]
generic<typename TKey, typename TValue>
where TKey : ref class
where TValue : ref class
public ref class HashList : ISerializable

Type Parameters

TKey

[Missing <typeparam name="TKey"/> documentation for "T:Sitecore.Collections.HashList`2"]

TValue

[Missing <typeparam name="TValue"/> documentation for "T:Sitecore.Collections.HashList`2"]

Inheritance Hierarchy

System..::..Object
Sitecore.Collections..::..HashList<(Of <(<'TKey, TValue>)>)>

See Also

HashList<(Of <(<'TKey, TValue>)>)> Members
Sitecore.Collections Namespace


HashList(TKey, TValue) Members

[image] [image]

Sitecore 6.4.1 API
HashList<(Of <(<'TKey, TValue>)>)> Members
HashList<(Of <(<'TKey, TValue>)>)> Class Constructors Methods Properties See Also Send Feedback

The HashList<(Of <(<'TKey, TValue>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | HashList<(Of <(<'TKey, TValue>)>)>()()()() | Initializes a new instance of the HashList<(Of <(<'TKey, TValue>)>)> class.
Protected method | HashList<(Of <(<'TKey, TValue>)>)>(SerializationInfo, StreamingContext) | Initializes a new instance of the HashList<(Of <(<'TKey, TValue>)>)> class.

Methods

 | Name | Description
Public method | Add | Adds an object to the hash table.
Public method | AddAt | Adds or replaces an object at a specific index.
Public method | Clear | Clears the list.
Public method | Contains | Checks if the hash table contains a key.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKey | Gets a key by an index.
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Gets the index of a key.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes an object from the hash table.
Public method | RemoveRange | Removes a range of objects from the hash table.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of objects in the hash table.
Public property | Item[([( Int32])]) | Gets an object by its index.
Public property | Item[([( TKey])]) | Gets or sets an object by its key.
Public property | Keys | Gets a collection of keys.
Public property | SyncRoot | Gets the sync root.

See Also

HashList<(Of <(<'TKey, TValue>)>)> Class
Sitecore.Collections Namespace


HashList(TKey, TValue) Constructor

[image] [image]

Sitecore 6.4.1 API
HashList<(Of <(<'TKey, TValue>)>)> Constructor
HashList<(Of <(<'TKey, TValue>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HashList<(Of <(<'TKey, TValue>)>)>()()()() | Initializes a new instance of the HashList<(Of <(<'TKey, TValue>)>)> class.
Protected method | HashList<(Of <(<'TKey, TValue>)>)>(SerializationInfo, StreamingContext) | Initializes a new instance of the HashList<(Of <(<'TKey, TValue>)>)> class.

See Also

HashList<(Of <(<'TKey, TValue>)>)> Class
HashList<(Of <(<'TKey, TValue>)>)> Members
Sitecore.Collections Namespace


HashList(TKey, TValue) Constructor

[image]

Sitecore 6.4.1 API
HashList<(Of <(<'TKey, TValue>)>)> Constructor
HashList<(Of <(<'TKey, TValue>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HashList()
Visual Basic
Public Sub New
Visual C++
public:
HashList()

See Also

HashList<(Of <(<'TKey, TValue>)>)> Class
HashList<(Of <(<'TKey, TValue>)>)> Overload
Sitecore.Collections Namespace


HashList(TKey, TValue) Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
HashList<(Of <(<'TKey, TValue>)>)> Constructor (SerializationInfo, StreamingContext)
HashList<(Of <(<'TKey, TValue>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected HashList(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
HashList(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

HashList<(Of <(<'TKey, TValue>)>)> Class
HashList<(Of <(<'TKey, TValue>)>)> Overload
Sitecore.Collections Namespace


HashList(TKey, TValue) Methods

[image] [image]

Sitecore 6.4.1 API
HashList<(Of <(<'TKey, TValue>)>)> Methods
HashList<(Of <(<'TKey, TValue>)>)> Class See Also Send Feedback

The HashList<(Of <(<'TKey, TValue>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the hash table.
Public method | AddAt | Adds or replaces an object at a specific index.
Public method | Clear | Clears the list.
Public method | Contains | Checks if the hash table contains a key.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKey | Gets a key by an index.
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Gets the index of a key.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes an object from the hash table.
Public method | RemoveRange | Removes a range of objects from the hash table.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HashList<(Of <(<'TKey, TValue>)>)> Class
Sitecore.Collections Namespace


AddAt Method

[image]

Sitecore 6.4.1 API
HashList<(Of <(<'TKey, TValue>)>)>..::..AddAt Method
HashList<(Of <(<'TKey, TValue>)>)> Class Example See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddAt(
    int index,
    TKey key,
    TValue value
)
Visual Basic
Public Sub AddAt ( _
    index As Integer, _
    key As TKey, _
    value As TValue _
)
Visual C++
public:
void AddAt(
    int index,
    TKey key,
    TValue value
)

Parameters

index
Type: System..::..Int32
An index into the hash table.
key
Type: TKey
A key uniquely describing the object.
value
Type: TValue
The value.

Remarks

If the key does not exist in the hash table, the key and object is added.

Examples

CopyC#
Hashtable hashTable = new Hashtable();
hashTable.Add("0", "apples");
hashTable.Add("1", "bananas");
hashTable.Add(0, "2", "pears");

See Also

HashList<(Of <(<'TKey, TValue>)>)> Class
Sitecore.Collections Namespace


Clear Method

[image]

Sitecore 6.4.1 API
HashList<(Of <(<'TKey, TValue>)>)>..::..Clear Method
HashList<(Of <(<'TKey, TValue>)>)> Class Example See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

Examples

CopyC#
Hashtable hashTable = new Hashtable();
hashTable.Add("1", "bananas");
hashTable.Add(0, "2", "pears");
hashTable.Clear();

See Also

HashList<(Of <(<'TKey, TValue>)>)> Class
Sitecore.Collections Namespace


Contains Method

[image]

Sitecore 6.4.1 API
HashList<(Of <(<'TKey, TValue>)>)>..::..Contains Method
HashList<(Of <(<'TKey, TValue>)>)> Class Example See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Contains(
    TKey key
)
Visual Basic
Public Function Contains ( _
    key As TKey _
) As Boolean
Visual C++
public:
bool Contains(
    TKey key
)

Parameters

key
Type: TKey
A key.

Return Value

True, if the key exists in the hash table, otherwise false.

Examples

CopyC#
Hashtable hashTable = new Hashtable();
hashTable.Add("0", "apples");
hashTable.Add("1", "bananas");
hashTable.Add("2", "pears");
if (hashTable.Contains("1")) {
hashTable.Add("3", "pineapple");
}

See Also

HashList<(Of <(<'TKey, TValue>)>)> Class
Sitecore.Collections Namespace


GetObjectData Method

[image]

Sitecore 6.4.1 API
HashList<(Of <(<'TKey, TValue>)>)>..::..GetObjectData Method
HashList<(Of <(<'TKey, TValue>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System.Security..::..SecurityException | The caller does not have the required permission.

See Also

HashList<(Of <(<'TKey, TValue>)>)> Class
Sitecore.Collections Namespace


IndexOf Method

[image]

Sitecore 6.4.1 API
HashList<(Of <(<'TKey, TValue>)>)>..::..IndexOf Method
HashList<(Of <(<'TKey, TValue>)>)> Class Example See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int IndexOf(
    TKey key
)
Visual Basic
Public Function IndexOf ( _
    key As TKey _
) As Integer
Visual C++
public:
int IndexOf(
    TKey key
)

Parameters

key
Type: TKey
A key.

Return Value

The index of the key. If the key is not found, -1 is returned.

Examples

CopyC#
Hashtable hashTable = new Hashtable();
hashTable.Add("0", "apples");
hashTable.Add("1", "bananas");
hashTable.Add("2", "pears");
int bananaKey = hashTable.IndexOf("1");

See Also

HashList<(Of <(<'TKey, TValue>)>)> Class
Sitecore.Collections Namespace


Remove Method

[image]

Sitecore 6.4.1 API
HashList<(Of <(<'TKey, TValue>)>)>..::..Remove Method
HashList<(Of <(<'TKey, TValue>)>)> Class Example See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Remove(
    TKey key
)
Visual Basic
Public Sub Remove ( _
    key As TKey _
)
Visual C++
public:
void Remove(
    TKey key
)

Parameters

key
Type: TKey
A key.

Remarks

No exception is thrown if the key does not exist.

Examples

CopyC#
Hashtable hashTable = new Hashtable();
hashTable.Add("0", "apples");
hashTable.Add("1", "bananas");
hashTable.Add("2", "pears");
hashTable.Remove("1");

See Also

HashList<(Of <(<'TKey, TValue>)>)> Class
Sitecore.Collections Namespace


RemoveRange Method

[image]

Sitecore 6.4.1 API
HashList<(Of <(<'TKey, TValue>)>)>..::..RemoveRange Method
HashList<(Of <(<'TKey, TValue>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RemoveRange(
    int index,
    int count
)
Visual Basic
Public Sub RemoveRange ( _
    index As Integer, _
    count As Integer _
)
Visual C++
public:
void RemoveRange(
    int index,
    int count
)

Parameters

index
Type: System..::..Int32
The index.
count
Type: System..::..Int32
The count.

See Also

HashList<(Of <(<'TKey, TValue>)>)> Class
Sitecore.Collections Namespace


HashList(TKey, TValue) Properties

[image] [image]

Sitecore 6.4.1 API
HashList<(Of <(<'TKey, TValue>)>)> Properties
HashList<(Of <(<'TKey, TValue>)>)> Class See Also Send Feedback

The HashList<(Of <(<'TKey, TValue>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of objects in the hash table.
Public property | Item[([( Int32])]) | Gets an object by its index.
Public property | Item[([( TKey])]) | Gets or sets an object by its key.
Public property | Keys | Gets a collection of keys.
Public property | SyncRoot | Gets the sync root.

See Also

HashList<(Of <(<'TKey, TValue>)>)> Class
Sitecore.Collections Namespace


Count Property

[image]

Sitecore 6.4.1 API
HashList<(Of <(<'TKey, TValue>)>)>..::..Count Property
HashList<(Of <(<'TKey, TValue>)>)> Class Example See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
property int Count {
    int get ();
}

Field Value

Gets the number of objects.

Examples

CopyC#
Hashtable hashTable = new Hashtable();
hashTable.Add("0", "apples");
hashTable.Add("1", "bananas");

See Also

HashList<(Of <(<'TKey, TValue>)>)> Class
Sitecore.Collections Namespace


Item Property (Int32)

[image]

Sitecore 6.4.1 API
HashList<(Of <(<'TKey, TValue>)>)>..::..Item Property (Int32)
HashList<(Of <(<'TKey, TValue>)>)> Class Example See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TValue this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    index As Integer _
) As TValue
    Get
Visual C++
public:
property TValue default[int index] {
    TValue get (int index);
}

Parameters

index
Type: System..::..Int32
An index into the hash table.

Field Value

Gets the object at index position.

Remarks

If index if less than zero or greater than the number of objects in the list, null is returned.

Examples

CopyC#
Hashtable hashTable = new Hashtable();
hashTable.Add("0", "apples");
hashTable.Add("1", "bananas");
hashTable.Add("2", "pears");

string bananas = hashTable[1]; // returns "bananas"
string apples = hashTable["0"]; // returns "apples"

See Also

HashList<(Of <(<'TKey, TValue>)>)> Class
Item Overload
Sitecore.Collections Namespace


Keys Property

[image]

Sitecore 6.4.1 API
HashList<(Of <(<'TKey, TValue>)>)>..::..Keys Property
HashList<(Of <(<'TKey, TValue>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ICollection Keys { get; }
Visual Basic
Public ReadOnly Property Keys As ICollection
    Get
Visual C++
public:
property ICollection^ Keys {
    ICollection^ get ();
}

Field Value

A collection of keys.

See Also

HashList<(Of <(<'TKey, TValue>)>)> Class
Sitecore.Collections Namespace


SyncRoot Property

[image]

Sitecore 6.4.1 API
HashList<(Of <(<'TKey, TValue>)>)>..::..SyncRoot Property
HashList<(Of <(<'TKey, TValue>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object SyncRoot { get; }
Visual Basic
Public ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
property Object^ SyncRoot {
    Object^ get ();
}

Field Value

The sync root.

See Also

HashList<(Of <(<'TKey, TValue>)>)> Class
Sitecore.Collections Namespace


HistoryEntryCollection Class

[image]

Sitecore 6.4.1 API
HistoryEntryCollection Class
Members See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class HistoryEntryCollection : Collection<HistoryEntry>
Visual Basic
Public Class HistoryEntryCollection _
    Inherits Collection(Of HistoryEntry)
Visual C++
public ref class HistoryEntryCollection : public Collection<HistoryEntry^>

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<' HistoryEntry >)>)>
Sitecore.Collections..::..HistoryEntryCollection

See Also

HistoryEntryCollection Members
Sitecore.Collections Namespace


HistoryEntryCollection Members

[image] [image]

Sitecore 6.4.1 API
HistoryEntryCollection Members
HistoryEntryCollection Class Constructors Methods Properties See Also Send Feedback

The HistoryEntryCollection type exposes the following members.

Constructors

 | Name | Description
Public method | HistoryEntryCollection | Initializes a new instance of the HistoryEntryCollection class

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' HistoryEntry >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' HistoryEntry >)>)>.)
Protected method | ClearItems | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' HistoryEntry >)>)>.)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' HistoryEntry >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' HistoryEntry >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' HistoryEntry >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' HistoryEntry >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' HistoryEntry >)>)>.)
Protected method | InsertItem | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' HistoryEntry >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' HistoryEntry >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' HistoryEntry >)>)>.)
Protected method | RemoveItem | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' HistoryEntry >)>)>.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from Collection <(Of <(<' HistoryEntry >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' HistoryEntry >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' HistoryEntry >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' HistoryEntry >)>)>.)

See Also

HistoryEntryCollection Class
Sitecore.Collections Namespace


HistoryEntryCollection Constructor

[image]

Sitecore 6.4.1 API
HistoryEntryCollection Constructor
HistoryEntryCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HistoryEntryCollection()
Visual Basic
Public Sub New
Visual C++
public:
HistoryEntryCollection()

See Also

HistoryEntryCollection Class
Sitecore.Collections Namespace


HistoryEntryCollection Methods

[image] [image]

Sitecore 6.4.1 API
HistoryEntryCollection Methods
HistoryEntryCollection Class See Also Send Feedback

The HistoryEntryCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' HistoryEntry >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' HistoryEntry >)>)>.)
Protected method | ClearItems | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' HistoryEntry >)>)>.)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' HistoryEntry >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' HistoryEntry >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' HistoryEntry >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' HistoryEntry >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' HistoryEntry >)>)>.)
Protected method | InsertItem | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' HistoryEntry >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' HistoryEntry >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' HistoryEntry >)>)>.)
Protected method | RemoveItem | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' HistoryEntry >)>)>.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from Collection <(Of <(<' HistoryEntry >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HistoryEntryCollection Class
Sitecore.Collections Namespace


HistoryEntryCollection Properties

[image] [image]

Sitecore 6.4.1 API
HistoryEntryCollection Properties
HistoryEntryCollection Class See Also Send Feedback

The HistoryEntryCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' HistoryEntry >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' HistoryEntry >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' HistoryEntry >)>)>.)

See Also

HistoryEntryCollection Class
Sitecore.Collections Namespace


IdCollection Class

[image]

Sitecore 6.4.1 API
IdCollection Class
Members See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class IdCollection : Collection<ID>
Visual Basic
Public Class IdCollection _
    Inherits Collection(Of ID)
Visual C++
public ref class IdCollection : public Collection<ID^>

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<' ID >)>)>
Sitecore.Collections..::..IdCollection

See Also

IdCollection Members
Sitecore.Collections Namespace


IdCollection Members

[image] [image]

Sitecore 6.4.1 API
IdCollection Members
IdCollection Class Constructors Methods Properties See Also Send Feedback

The IdCollection type exposes the following members.

Constructors

 | Name | Description
Public method | IdCollection | Initializes a new instance of the IdCollection class

Methods

 | Name | Description
Public method | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' ID >)>)>.)
Public method | Add(array<ID>[]()[][]) | Adds the specified values.
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' ID >)>)>.)
Protected method | ClearItems | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' ID >)>)>.)
 | Combine | Gets a collection containing the combined items of two other collections.
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' ID >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' ID >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' ID >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' ID >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' ID >)>)>.)
Protected method | InsertItem | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' ID >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' ID >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' ID >)>)>.)
Protected method | RemoveItem | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' ID >)>)>.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from Collection <(Of <(<' ID >)>)>.)
Public method | ToArray | Copies the collection to an array.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' ID >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' ID >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' ID >)>)>.)

See Also

IdCollection Class
Sitecore.Collections Namespace


IdCollection Constructor

[image]

Sitecore 6.4.1 API
IdCollection Constructor
IdCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IdCollection()
Visual Basic
Public Sub New
Visual C++
public:
IdCollection()

See Also

IdCollection Class
Sitecore.Collections Namespace


Add Method

[image] [image]

Sitecore 6.4.1 API
IdCollection..::..Add Method
IdCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' ID >)>)>.)
Public method | Add(array<ID>[]()[][]) | Adds the specified values.

See Also

IdCollection Class
IdCollection Members
Sitecore.Collections Namespace


Add Method (ID[])

[image]

Sitecore 6.4.1 API
IdCollection..::..Add Method (array<ID>[]()[][])
IdCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Add(
    ID[] values
)
Visual Basic
Public Sub Add ( _
    values As ID() _
)
Visual C++
public:
void Add(
    array<ID^>^ values
)

Parameters

values
Type: array< Sitecore.Data..::..ID >[]()[][]
The values.

See Also

IdCollection Class
Add Overload
Sitecore.Collections Namespace


Combine Method

[image]

Sitecore 6.4.1 API
IdCollection..::..Combine Method
IdCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static IdCollection Combine(
    IdCollection collection1,
    IdCollection collection2
)
Visual Basic
Public Shared Function Combine ( _
    collection1 As IdCollection, _
    collection2 As IdCollection _
) As IdCollection
Visual C++
public:
static IdCollection^ Combine(
    IdCollection^ collection1,
    IdCollection^ collection2
)

Parameters

collection1
Type: Sitecore.Collections..::..IdCollection
The collection1.
collection2
Type: Sitecore.Collections..::..IdCollection
The collection2.

Return Value

[Missing <returns> documentation for "M:Sitecore.Collections.IdCollection.Combine(Sitecore.Collections.IdCollection,Sitecore.Collections.IdCollection)"]

See Also

IdCollection Class
Sitecore.Collections Namespace


ToString Method

[image]

Sitecore 6.4.1 API
IdCollection..::..ToString Method
IdCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

IdCollection Class
Sitecore.Collections Namespace


IdCollection Properties

[image] [image]

Sitecore 6.4.1 API
IdCollection Properties
IdCollection Class See Also Send Feedback

The IdCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' ID >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' ID >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' ID >)>)>.)

See Also

IdCollection Class
Sitecore.Collections Namespace


IdList Class

[image]

Sitecore 6.4.1 API
IdList Class
Members See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class IdList : List<ID>
Visual Basic
Public Class IdList _
    Inherits List(Of ID)
Visual C++
public ref class IdList : public List<ID^>

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' ID >)>)>
Sitecore.Collections..::..IdList

See Also

IdList Members
Sitecore.Collections Namespace


IdList Members

[image] [image]

Sitecore 6.4.1 API
IdList Members
IdList Class Constructors Methods Properties See Also Send Feedback

The IdList type exposes the following members.

Constructors

 | Name | Description
Public method | IdList | Initializes a new instance of the IdList class

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | AddRange | Adds the elements of the specified collection to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | AsReadOnly | Returns a read-only IList<(Of <(<'T>)>)> wrapper for the current collection. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | Clear | Removes all elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | Contains | Determines whether an element is in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | Converts the elements in the current List<(Of <(<'T>)>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the List<(Of <(<'T>)>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' ID >)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | ForEach | Performs the specified action on each element of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | GetEnumerator | Returns an enumerator that iterates through the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | Insert | Inserts an element into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | InsertRange | Inserts the elements of a collection into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' ID >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | RemoveRange | Removes a range of elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | ToArray | Copies the elements of the List<(Of <(<'T>)>)> to a new array. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(<'T>)>)>, if that number is less than a threshold value. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | TrueForAll | Determines whether every element in the List<(Of <(<'T>)>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of <(<' ID >)>)>.)

Properties

 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <(<' ID >)>)>.)
Public property | Count | Gets the number of elements actually contained in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ID >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List <(Of <(<' ID >)>)>.)

See Also

IdList Class
Sitecore.Collections Namespace


IdList Constructor

[image]

Sitecore 6.4.1 API
IdList Constructor
IdList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IdList()
Visual Basic
Public Sub New
Visual C++
public:
IdList()

See Also

IdList Class
Sitecore.Collections Namespace


BinarySearch Method

[image] [image]

Sitecore 6.4.1 API
IdList..::..BinarySearch Method
IdList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' ID >)>)>.)

See Also

IdList Class
IdList Members
Sitecore.Collections Namespace


CopyTo Method

[image] [image]

Sitecore 6.4.1 API
IdList..::..CopyTo Method
IdList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' ID >)>)>.)

See Also

IdList Class
IdList Members
Sitecore.Collections Namespace


FindIndex Method

[image] [image]

Sitecore 6.4.1 API
IdList..::..FindIndex Method
IdList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' ID >)>)>.)

See Also

IdList Class
IdList Members
Sitecore.Collections Namespace


FindLastIndex Method

[image] [image]

Sitecore 6.4.1 API
IdList..::..FindLastIndex Method
IdList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' ID >)>)>.)

See Also

IdList Class
IdList Members
Sitecore.Collections Namespace


IndexOf Method

[image] [image]

Sitecore 6.4.1 API
IdList..::..IndexOf Method
IdList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' ID >)>)>.)

See Also

IdList Class
IdList Members
Sitecore.Collections Namespace


LastIndexOf Method

[image] [image]

Sitecore 6.4.1 API
IdList..::..LastIndexOf Method
IdList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' ID >)>)>.)

See Also

IdList Class
IdList Members
Sitecore.Collections Namespace


Reverse Method

[image] [image]

Sitecore 6.4.1 API
IdList..::..Reverse Method
IdList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ID >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' ID >)>)>.)

See Also

IdList Class
IdList Members
Sitecore.Collections Namespace


IdList Properties

[image] [image]

Sitecore 6.4.1 API
IdList Properties
IdList Class See Also Send Feedback

The IdList type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <(<' ID >)>)>.)
Public property | Count | Gets the number of elements actually contained in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ID >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List <(Of <(<' ID >)>)>.)

See Also

IdList Class
Sitecore.Collections Namespace


IDList Class

[image]

Sitecore 6.4.1 API
IDList Class
Members See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class IDList : IEnumerable
Visual Basic
Public Class IDList _
    Implements IEnumerable
Visual C++
public ref class IDList : IEnumerable

Inheritance Hierarchy

System..::..Object
Sitecore.Collections..::..IDList

See Also

IDList Members
Sitecore.Collections Namespace


IDList Members

[image] [image]

Sitecore 6.4.1 API
IDList Members
IDList Class Constructors Methods Properties See Also Send Feedback

The IDList type exposes the following members.

Constructors

 | Name | Description
Public method | IDList | Initializes a new instance of the IDList class

Methods

 | Name | Description
Public method | Add(ID) | Adds the specified id.
 | Add(IDList, IDList) | Adds the specified list1.
 | Build | Builds the specified ids.
Public method | Clone | Clones this instance (shallowly).
Public method | Contains | Returns true if id is IDList already contains provided id.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDataLength | Gets the size of the data to use when caching.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the specified id.
Public method | ToArray | Converts the IDList to an array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the count.
Public property | Item | Gets the ID at the specified index.

See Also

IDList Class
Sitecore.Collections Namespace


IDList Constructor

[image]

Sitecore 6.4.1 API
IDList Constructor
IDList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IDList()
Visual Basic
Public Sub New
Visual C++
public:
IDList()

See Also

IDList Class
Sitecore.Collections Namespace


IDList Methods

[image] [image]

Sitecore 6.4.1 API
IDList Methods
IDList Class See Also Send Feedback

The IDList type exposes the following members.

Methods

 | Name | Description
Public method | Add(ID) | Adds the specified id.
 | Add(IDList, IDList) | Adds the specified list1.
 | Build | Builds the specified ids.
Public method | Clone | Clones this instance (shallowly).
Public method | Contains | Returns true if id is IDList already contains provided id.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDataLength | Gets the size of the data to use when caching.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the specified id.
Public method | ToArray | Converts the IDList to an array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IDList Class
Sitecore.Collections Namespace


Add Method

[image] [image]

Sitecore 6.4.1 API
IDList..::..Add Method
IDList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(ID) | Adds the specified id.
 | Add(IDList, IDList) | Adds the specified list1.

See Also

IDList Class
IDList Members
Sitecore.Collections Namespace


Add Method (IDList, IDList)

[image]

Sitecore 6.4.1 API
IDList..::..Add Method (IDList, IDList)
IDList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static IDList Add(
    IDList list1,
    IDList list2
)
Visual Basic
Public Shared Function Add ( _
    list1 As IDList, _
    list2 As IDList _
) As IDList
Visual C++
public:
static IDList^ Add(
    IDList^ list1,
    IDList^ list2
)

Parameters

list1
Type: Sitecore.Collections..::..IDList
The list1.
list2
Type: Sitecore.Collections..::..IDList
The list2.

Return Value

The add.

See Also

IDList Class
Add Overload
Sitecore.Collections Namespace


Build Method

[image]

Sitecore 6.4.1 API
IDList..::..Build Method
IDList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static IDList Build(
    params ID[] ids
)
Visual Basic
Public Shared Function Build ( _
    ParamArray ids As ID() _
) As IDList
Visual C++
public:
static IDList^ Build(
    ... array<ID^>^ ids
)

Parameters

ids
Type: array< Sitecore.Data..::..ID >[]()[][]
The ids.

Return Value

The build.

See Also

IDList Class
Sitecore.Collections Namespace


Contains Method

[image]

Sitecore 6.4.1 API
IDList..::..Contains Method
IDList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Contains(
    ID id
)
Visual Basic
Public Function Contains ( _
    id As ID _
) As Boolean
Visual C++
public:
bool Contains(
    ID^ id
)

Parameters

id
Type: Sitecore.Data..::..ID
id to test

Return Value

true if id is IDList already contains provided id. Otherwise false.

See Also

IDList Class
Sitecore.Collections Namespace


GetDataLength Method

[image]

Sitecore 6.4.1 API
IDList..::..GetDataLength Method
IDList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long GetDataLength()
Visual Basic
Public Function GetDataLength As Long
Visual C++
public:
long long GetDataLength()

Return Value

[Missing <returns> documentation for "M:Sitecore.Collections.IDList.GetDataLength"]

See Also

IDList Class
Sitecore.Collections Namespace


GetEnumerator Method

[image]

Sitecore 6.4.1 API
IDList..::..GetEnumerator Method
IDList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator() sealed

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

IDList Class
Sitecore.Collections Namespace


Remove Method

[image]

Sitecore 6.4.1 API
IDList..::..Remove Method
IDList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Remove(
    ID id
)
Visual Basic
Public Sub Remove ( _
    id As ID _
)
Visual C++
public:
void Remove(
    ID^ id
)

Parameters

id
Type: Sitecore.Data..::..ID
The id.

See Also

IDList Class
Sitecore.Collections Namespace


ToArray Method

[image]

Sitecore 6.4.1 API
IDList..::..ToArray Method
IDList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Array ToArray()
Visual Basic
Public Function ToArray As Array
Visual C++
public:
Array^ ToArray()

Return Value

The IDList as an array.

See Also

IDList Class
Sitecore.Collections Namespace


IDList Properties

[image] [image]

Sitecore 6.4.1 API
IDList Properties
IDList Class See Also Send Feedback

The IDList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the count.
Public property | Item | Gets the ID at the specified index.

See Also

IDList Class
Sitecore.Collections Namespace


Count Property

[image]

Sitecore 6.4.1 API
IDList..::..Count Property
IDList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
property int Count {
    int get ();
}

Field Value

The count.

See Also

IDList Class
Sitecore.Collections Namespace


Item Property

[image]

Sitecore 6.4.1 API
IDList..::..Item Property
IDList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    index As Integer _
) As ID
    Get
Visual C++
public:
property ID^ default[int index] {
    ID^ get (int index);
}

Parameters

index
Type: System..::..Int32

Field Value

The ID.

See Also

IDList Class
Sitecore.Collections Namespace


IndexedDictionary Class

[image]

Sitecore 6.4.1 API
IndexedDictionary Class
Members See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class IndexedDictionary : ICollection,
    IEnumerable
Visual Basic
Public Class IndexedDictionary _
    Implements ICollection, IEnumerable
Visual C++
public ref class IndexedDictionary : ICollection,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Sitecore.Collections..::..IndexedDictionary

See Also

IndexedDictionary Members
Sitecore.Collections Namespace


IndexedDictionary Members

[image] [image]

Sitecore 6.4.1 API
IndexedDictionary Members
IndexedDictionary Class Constructors Methods Properties See Also Send Feedback

The IndexedDictionary type exposes the following members.

Constructors

 | Name | Description
Public method | IndexedDictionary | Initializes a new instance of the IndexedDictionary class

Methods

 | Name | Description
Public method | CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKey | Gets the key.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the specified index.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection.
Public property | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe).
Public property | Item[([( Int32])]) | Gets the Object at the specified index.
Public property | Item[([( Object])]) | Gets or sets the Object with the specified key.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the ICollection.

See Also

IndexedDictionary Class
Sitecore.Collections Namespace


IndexedDictionary Constructor

[image]

Sitecore 6.4.1 API
IndexedDictionary Constructor
IndexedDictionary Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IndexedDictionary()
Visual Basic
Public Sub New
Visual C++
public:
IndexedDictionary()

See Also

IndexedDictionary Class
Sitecore.Collections Namespace


IndexedDictionary Methods

[image] [image]

Sitecore 6.4.1 API
IndexedDictionary Methods
IndexedDictionary Class See Also Send Feedback

The IndexedDictionary type exposes the following members.

Methods

 | Name | Description
Public method | CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKey | Gets the key.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the specified index.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IndexedDictionary Class
Sitecore.Collections Namespace


CopyTo Method

[image]

Sitecore 6.4.1 API
IndexedDictionary..::..CopyTo Method
IndexedDictionary Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void CopyTo(
    Array array,
    int index
)
Visual Basic
Public Sub CopyTo ( _
    array As Array, _
    index As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int index
) sealed

Parameters

array
Type: System..::..Array
The one-dimensional Array that is the destination of the elements copied from ICollection. The Array must have zero-based indexing.
index
Type: System..::..Int32
The zero-based index in array at which copying begins.

Implements

ICollection..::..CopyTo(Array, Int32)

Exceptions

Exception | Condition
System..::..ArgumentNullException | array is null.
System..::..ArgumentOutOfRangeException | index is less than zero.
System..::..ArgumentException | array is multidimensional.-or- index is equal to or greater than the length of array.-or- The number of elements in the source ICollection is greater than the available space from index to the end of the destination array.
System..::..InvalidCastException | The type of the source ICollection cannot be cast automatically to the type of the destination array.

See Also

IndexedDictionary Class
Sitecore.Collections Namespace


GetEnumerator Method

[image]

Sitecore 6.4.1 API
IndexedDictionary..::..GetEnumerator Method
IndexedDictionary Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator() sealed

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

IndexedDictionary Class
Sitecore.Collections Namespace


GetKey Method

[image]

Sitecore 6.4.1 API
IndexedDictionary..::..GetKey Method
IndexedDictionary Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object GetKey(
    int index
)
Visual Basic
Public Function GetKey ( _
    index As Integer _
) As Object
Visual C++
public:
Object^ GetKey(
    int index
)

Parameters

index
Type: System..::..Int32
The index.

Return Value

[Missing <returns> documentation for "M:Sitecore.Collections.IndexedDictionary.GetKey(System.Int32)"]

See Also

IndexedDictionary Class
Sitecore.Collections Namespace


Remove Method

[image]

Sitecore 6.4.1 API
IndexedDictionary..::..Remove Method
IndexedDictionary Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Remove(
    int index
)
Visual Basic
Public Sub Remove ( _
    index As Integer _
)
Visual C++
public:
void Remove(
    int index
)

Parameters

index
Type: System..::..Int32
The index.

See Also

IndexedDictionary Class
Sitecore.Collections Namespace


IndexedDictionary Properties

[image] [image]

Sitecore 6.4.1 API
IndexedDictionary Properties
IndexedDictionary Class See Also Send Feedback

The IndexedDictionary type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection.
Public property | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe).
Public property | Item[([( Int32])]) | Gets the Object at the specified index.
Public property | Item[([( Object])]) | Gets or sets the Object with the specified key.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the ICollection.

See Also

IndexedDictionary Class
Sitecore.Collections Namespace


Count Property

[image]

Sitecore 6.4.1 API
IndexedDictionary..::..Count Property
IndexedDictionary Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Field Value

Return Value

The number of elements contained in the ICollection.

Implements

ICollection..::..Count

See Also

IndexedDictionary Class
Sitecore.Collections Namespace


IsSynchronized Property

[image]

Sitecore 6.4.1 API
IndexedDictionary..::..IsSynchronized Property
IndexedDictionary Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsSynchronized { get; }
Visual Basic
Public ReadOnly Property IsSynchronized As Boolean
    Get
Visual C++
public:
virtual property bool IsSynchronized {
    bool get () sealed;
}

Field Value

Return Value

true if access to the ICollection is synchronized (thread safe); otherwise, false.

Implements

ICollection..::..IsSynchronized

See Also

IndexedDictionary Class
Sitecore.Collections Namespace


Item Property

[image] [image]

Sitecore 6.4.1 API
IndexedDictionary..::..Item Property
IndexedDictionary Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gets the Object at the specified index.
Public property | Item[([( Object])]) | Gets or sets the Object with the specified key.

See Also

IndexedDictionary Class
IndexedDictionary Members
Sitecore.Collections Namespace


Item Property (Int32)

[image]

Sitecore 6.4.1 API
IndexedDictionary..::..Item Property (Int32)
IndexedDictionary Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    index As Integer _
) As Object
    Get
Visual C++
public:
property Object^ default[int index] {
    Object^ get (int index);
}

Parameters

index
Type: System..::..Int32

Field Value

See Also

IndexedDictionary Class
Item Overload
Sitecore.Collections Namespace


Item Property (Object)

[image]

Sitecore 6.4.1 API
IndexedDictionary..::..Item Property (Object)
IndexedDictionary Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object this[
    Object key
] { get; set; }
Visual Basic
Public Default Property Item ( _
    key As Object _
) As Object
    Get
    Set
Visual C++
public:
property Object^ default[Object^ key] {
    Object^ get (Object^ key);
    void set (Object^ key, Object^ value);
}

Parameters

key
Type: System..::..Object

Field Value

See Also

IndexedDictionary Class
Item Overload
Sitecore.Collections Namespace


ItemCollection Class

[image]

Sitecore 6.4.1 API
ItemCollection Class
Members See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemCollection : CollectionBase
Visual Basic
Public Class ItemCollection _
    Inherits CollectionBase
Visual C++
public ref class ItemCollection : public CollectionBase

Inheritance Hierarchy

System..::..Object
System.Collections..::..CollectionBase
Sitecore.Collections..::..ItemCollection

See Also

ItemCollection Members
Sitecore.Collections Namespace


ItemCollection Members

[image] [image]

Sitecore 6.4.1 API
ItemCollection Members
ItemCollection Class Constructors Methods Properties See Also Send Feedback

The ItemCollection type exposes the following members.

Constructors

 | Name | Description
Public method | ItemCollection | Initializes a new instance of the ItemCollection class

Methods

 | Name | Description
Public method | Add | Adds the specified item.
Public method | AddRange(array<Item>[]()[][]) | Adds the range.
Public method | AddRange(ItemCollection) | Adds the range.
 | Build | Builds the collection from the specified items.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Determines whether the collection contains the specified item.
Public method | ContainsID | Determines whether the collection contains an item with the specified ID.
Public method | CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the item and returns the zero-based index of the first occurrence within the entire ItemCollection.
Public method | Insert | Inserts the item at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove(Int32) | Removes the item at the specified index.
Public method | Remove(Item) | Removes the specified item.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | Sort | Sorts the collection.
Public method | ToArray | Converts the list to an array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe).
Public property | Item[([( Int32])]) | Gets the Item at the specified index.
Public property | Item[([( String])]) | Gets the Item with the specified name.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the ICollection.

See Also

ItemCollection Class
Sitecore.Collections Namespace


ItemCollection Constructor

[image]

Sitecore 6.4.1 API
ItemCollection Constructor
ItemCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemCollection()
Visual Basic
Public Sub New
Visual C++
public:
ItemCollection()

See Also

ItemCollection Class
Sitecore.Collections Namespace


ItemCollection Methods

[image] [image]

Sitecore 6.4.1 API
ItemCollection Methods
ItemCollection Class See Also Send Feedback

The ItemCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified item.
Public method | AddRange(array<Item>[]()[][]) | Adds the range.
Public method | AddRange(ItemCollection) | Adds the range.
 | Build | Builds the collection from the specified items.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Determines whether the collection contains the specified item.
Public method | ContainsID | Determines whether the collection contains an item with the specified ID.
Public method | CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the item and returns the zero-based index of the first occurrence within the entire ItemCollection.
Public method | Insert | Inserts the item at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove(Int32) | Removes the item at the specified index.
Public method | Remove(Item) | Removes the specified item.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | Sort | Sorts the collection.
Public method | ToArray | Converts the list to an array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemCollection Class
Sitecore.Collections Namespace


Add Method

[image]

Sitecore 6.4.1 API
ItemCollection..::..Add Method
ItemCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Add(
    Item item
)
Visual Basic
Public Function Add ( _
    item As Item _
) As Integer
Visual C++
public:
int Add(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Collections.ItemCollection.Add(Sitecore.Data.Items.Item)"]

See Also

ItemCollection Class
Sitecore.Collections Namespace


AddRange Method (Item[])

[image]

Sitecore 6.4.1 API
ItemCollection..::..AddRange Method (array<Item>[]()[][])
ItemCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddRange(
    Item[] items
)
Visual Basic
Public Sub AddRange ( _
    items As Item() _
)
Visual C++
public:
void AddRange(
    array<Item^>^ items
)

Parameters

items
Type: array< Sitecore.Data.Items..::..Item >[]()[][]
The items.

See Also

ItemCollection Class
AddRange Overload
Sitecore.Collections Namespace


AddRange Method (ItemCollection)

[image]

Sitecore 6.4.1 API
ItemCollection..::..AddRange Method (ItemCollection)
ItemCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddRange(
    ItemCollection collection
)
Visual Basic
Public Sub AddRange ( _
    collection As ItemCollection _
)
Visual C++
public:
void AddRange(
    ItemCollection^ collection
)

Parameters

collection
Type: Sitecore.Collections..::..ItemCollection
The collection.

See Also

ItemCollection Class
AddRange Overload
Sitecore.Collections Namespace


Contains Method

[image]

Sitecore 6.4.1 API
ItemCollection..::..Contains Method
ItemCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Contains(
    Item item
)
Visual Basic
Public Function Contains ( _
    item As Item _
) As Boolean
Visual C++
public:
bool Contains(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

true if the collection contains the specified item; otherwise, false.

See Also

ItemCollection Class
Sitecore.Collections Namespace


ContainsID Method

[image]

Sitecore 6.4.1 API
ItemCollection..::..ContainsID Method
ItemCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ContainsID(
    ID itemID
)
Visual Basic
Public Function ContainsID ( _
    itemID As ID _
) As Boolean
Visual C++
public:
bool ContainsID(
    ID^ itemID
)

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.

Return Value

true if the collection contains an item with the specified ID; otherwise, false.

See Also

ItemCollection Class
Sitecore.Collections Namespace


CopyTo Method

[image]

Sitecore 6.4.1 API
ItemCollection..::..CopyTo Method
ItemCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void CopyTo(
    Array array,
    int index
)
Visual Basic
Public Sub CopyTo ( _
    array As Array, _
    index As Integer _
)
Visual C++
public:
void CopyTo(
    Array^ array,
    int index
)

Parameters

array
Type: System..::..Array
The one-dimensional Array that is the destination of the elements copied from ICollection. The Array must have zero-based indexing.
index
Type: System..::..Int32
The zero-based index in array at which copying begins.

Exceptions

Exception | Condition
System..::..ArgumentNullException | array is null.
System..::..ArgumentOutOfRangeException | index is less than zero.
System..::..ArgumentException | array is multidimensional.-or- index is equal to or greater than the length of array.-or- The number of elements in the source ICollection is greater than the available space from index to the end of the destination array.
System..::..InvalidCastException | The type of the source ICollection cannot be cast automatically to the type of the destination array.

See Also

ItemCollection Class
Sitecore.Collections Namespace


IndexOf Method

[image]

Sitecore 6.4.1 API
ItemCollection..::..IndexOf Method
ItemCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int IndexOf(
    Item item
)
Visual Basic
Public Function IndexOf ( _
    item As Item _
) As Integer
Visual C++
public:
int IndexOf(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

The index position of the item if that Item is found, or -1 if it is not.

See Also

ItemCollection Class
Sitecore.Collections Namespace


Insert Method

[image]

Sitecore 6.4.1 API
ItemCollection..::..Insert Method
ItemCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Insert(
    int index,
    Item item
)
Visual Basic
Public Sub Insert ( _
    index As Integer, _
    item As Item _
)
Visual C++
public:
void Insert(
    int index,
    Item^ item
)

Parameters

index
Type: System..::..Int32
The index.
item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

ItemCollection Class
Sitecore.Collections Namespace


Remove Method

[image] [image]

Sitecore 6.4.1 API
ItemCollection..::..Remove Method
ItemCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Remove(Int32) | Removes the item at the specified index.
Public method | Remove(Item) | Removes the specified item.

See Also

ItemCollection Class
ItemCollection Members
Sitecore.Collections Namespace


Remove Method (Int32)

[image]

Sitecore 6.4.1 API
ItemCollection..::..Remove Method (Int32)
ItemCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Remove(
    int index
)
Visual Basic
Public Sub Remove ( _
    index As Integer _
)
Visual C++
public:
void Remove(
    int index
)

Parameters

index
Type: System..::..Int32
The index.

See Also

ItemCollection Class
Remove Overload
Sitecore.Collections Namespace


Remove Method (Item)

[image]

Sitecore 6.4.1 API
ItemCollection..::..Remove Method (Item)
ItemCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Remove(
    Item item
)
Visual Basic
Public Sub Remove ( _
    item As Item _
)
Visual C++
public:
void Remove(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

ItemCollection Class
Remove Overload
Sitecore.Collections Namespace


Sort Method

[image]

Sitecore 6.4.1 API
ItemCollection..::..Sort Method
ItemCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Sort(
    IComparer comparer
)
Visual Basic
Public Sub Sort ( _
    comparer As IComparer _
)
Visual C++
public:
void Sort(
    IComparer^ comparer
)

Parameters

comparer
Type: System.Collections..::..IComparer
The comparer.

See Also

ItemCollection Class
Sitecore.Collections Namespace


ItemCollection Properties

[image] [image]

Sitecore 6.4.1 API
ItemCollection Properties
ItemCollection Class See Also Send Feedback

The ItemCollection type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe).
Public property | Item[([( Int32])]) | Gets the Item at the specified index.
Public property | Item[([( String])]) | Gets the Item with the specified name.
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the ICollection.

See Also

ItemCollection Class
Sitecore.Collections Namespace


IsSynchronized Property

[image]

Sitecore 6.4.1 API
ItemCollection..::..IsSynchronized Property
ItemCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsSynchronized { get; }
Visual Basic
Public ReadOnly Property IsSynchronized As Boolean
    Get
Visual C++
public:
property bool IsSynchronized {
    bool get ();
}

Field Value

Return Value

true if access to the ICollection is synchronized (thread safe); otherwise, false.

See Also

ItemCollection Class
Sitecore.Collections Namespace


Item Property

[image] [image]

Sitecore 6.4.1 API
ItemCollection..::..Item Property
ItemCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gets the Item at the specified index.
Public property | Item[([( String])]) | Gets the Item with the specified name.

See Also

ItemCollection Class
ItemCollection Members
Sitecore.Collections Namespace


Item Property (Int32)

[image]

Sitecore 6.4.1 API
ItemCollection..::..Item Property (Int32)
ItemCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    index As Integer _
) As Item
    Get
Visual C++
public:
property Item^ default[int index] {
    Item^ get (int index);
}

Parameters

index
Type: System..::..Int32

Field Value

See Also

ItemCollection Class
Item Overload
Sitecore.Collections Namespace


Item Property (String)

[image]

Sitecore 6.4.1 API
ItemCollection..::..Item Property (String)
ItemCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item this[
    string name
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    name As String _
) As Item
    Get
Visual C++
public:
property Item^ default[String^ name] {
    Item^ get (String^ name);
}

Parameters

name
Type: System..::..String

Field Value

See Also

ItemCollection Class
Item Overload
Sitecore.Collections Namespace


SyncRoot Property

[image]

Sitecore 6.4.1 API
ItemCollection..::..SyncRoot Property
ItemCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object SyncRoot { get; }
Visual Basic
Public ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
property Object^ SyncRoot {
    Object^ get ();
}

Field Value

Return Value

An object that can be used to synchronize access to the ICollection.

See Also

ItemCollection Class
Sitecore.Collections Namespace


ItemList Class

[image]

Sitecore 6.4.1 API
ItemList Class
Members See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemList : List<Item>
Visual Basic
Public Class ItemList _
    Inherits List(Of Item)
Visual C++
public ref class ItemList : public List<Item^>

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' Item >)>)>
Sitecore.Collections..::..ItemList

See Also

ItemList Members
Sitecore.Collections Namespace


ItemList Members

[image] [image]

Sitecore 6.4.1 API
ItemList Members
ItemList Class Constructors Methods Properties See Also Send Feedback

The ItemList type exposes the following members.

Constructors

 | Name | Description
Public method | ItemList | Initializes a new instance of the ItemList class

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | AddRange | Adds the elements of the specified collection to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | AsReadOnly | Returns a read-only IList<(Of <(<'T>)>)> wrapper for the current collection. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | Clear | Removes all elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | Contains | Determines whether an element is in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | Converts the elements in the current List<(Of <(<'T>)>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the List<(Of <(<'T>)>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' Item >)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | ForEach | Performs the specified action on each element of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | GetEnumerator | Returns an enumerator that iterates through the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | Insert | Inserts an element into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | InsertRange | Inserts the elements of a collection into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' Item >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | RemoveRange | Removes a range of elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | ToArray | Copies the elements of the List<(Of <(<'T>)>)> to a new array. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(<'T>)>)>, if that number is less than a threshold value. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | TrueForAll | Determines whether every element in the List<(Of <(<'T>)>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of <(<' Item >)>)>.)

Properties

 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <(<' Item >)>)>.)
Public property | Count | Gets the number of elements actually contained in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List <(Of <(<' Item >)>)>.)

See Also

ItemList Class
Sitecore.Collections Namespace


ItemList Methods

[image] [image]

Sitecore 6.4.1 API
ItemList Methods
ItemList Class See Also Send Feedback

The ItemList type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | AddRange | Adds the elements of the specified collection to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | AsReadOnly | Returns a read-only IList<(Of <(<'T>)>)> wrapper for the current collection. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | Clear | Removes all elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | Contains | Determines whether an element is in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | Converts the elements in the current List<(Of <(<'T>)>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the List<(Of <(<'T>)>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' Item >)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | ForEach | Performs the specified action on each element of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | GetEnumerator | Returns an enumerator that iterates through the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | Insert | Inserts an element into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | InsertRange | Inserts the elements of a collection into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' Item >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | RemoveRange | Removes a range of elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | ToArray | Copies the elements of the List<(Of <(<'T>)>)> to a new array. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(<'T>)>)>, if that number is less than a threshold value. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | TrueForAll | Determines whether every element in the List<(Of <(<'T>)>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of <(<' Item >)>)>.)

See Also

ItemList Class
Sitecore.Collections Namespace


BinarySearch Method

[image] [image]

Sitecore 6.4.1 API
ItemList..::..BinarySearch Method
ItemList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' Item >)>)>.)

See Also

ItemList Class
ItemList Members
Sitecore.Collections Namespace


CopyTo Method

[image] [image]

Sitecore 6.4.1 API
ItemList..::..CopyTo Method
ItemList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' Item >)>)>.)

See Also

ItemList Class
ItemList Members
Sitecore.Collections Namespace


FindIndex Method

[image] [image]

Sitecore 6.4.1 API
ItemList..::..FindIndex Method
ItemList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' Item >)>)>.)

See Also

ItemList Class
ItemList Members
Sitecore.Collections Namespace


FindLastIndex Method

[image] [image]

Sitecore 6.4.1 API
ItemList..::..FindLastIndex Method
ItemList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' Item >)>)>.)

See Also

ItemList Class
ItemList Members
Sitecore.Collections Namespace


IndexOf Method

[image] [image]

Sitecore 6.4.1 API
ItemList..::..IndexOf Method
ItemList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' Item >)>)>.)

See Also

ItemList Class
ItemList Members
Sitecore.Collections Namespace


LastIndexOf Method

[image] [image]

Sitecore 6.4.1 API
ItemList..::..LastIndexOf Method
ItemList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' Item >)>)>.)

See Also

ItemList Class
ItemList Members
Sitecore.Collections Namespace


Reverse Method

[image] [image]

Sitecore 6.4.1 API
ItemList..::..Reverse Method
ItemList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' Item >)>)>.)

See Also

ItemList Class
ItemList Members
Sitecore.Collections Namespace


ItemList Properties

[image] [image]

Sitecore 6.4.1 API
ItemList Properties
ItemList Class See Also Send Feedback

The ItemList type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <(<' Item >)>)>.)
Public property | Count | Gets the number of elements actually contained in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Item >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List <(Of <(<' Item >)>)>.)

See Also

ItemList Class
Sitecore.Collections Namespace


JobCollection Class

[image]

Sitecore 6.4.1 API
JobCollection Class
Members See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class JobCollection : Collection<Job>
Visual Basic
Public Class JobCollection _
    Inherits Collection(Of Job)
Visual C++
public ref class JobCollection : public Collection<Job^>

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<' Job >)>)>
Sitecore.Collections..::..JobCollection

See Also

JobCollection Members
Sitecore.Collections Namespace


JobCollection Members

[image] [image]

Sitecore 6.4.1 API
JobCollection Members
JobCollection Class Constructors Methods Properties See Also Send Feedback

The JobCollection type exposes the following members.

Constructors

 | Name | Description
Public method | JobCollection | Initializes a new instance of the JobCollection class

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Job >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Job >)>)>.)
Protected method | ClearItems | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Job >)>)>.)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Job >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' Job >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Job >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Job >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Job >)>)>.)
Protected method | InsertItem | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Job >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Job >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Job >)>)>.)
Protected method | RemoveItem | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Job >)>)>.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from Collection <(Of <(<' Job >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Job >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Job >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Job >)>)>.)

See Also

JobCollection Class
Sitecore.Collections Namespace


JobCollection Constructor

[image]

Sitecore 6.4.1 API
JobCollection Constructor
JobCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public JobCollection()
Visual Basic
Public Sub New
Visual C++
public:
JobCollection()

See Also

JobCollection Class
Sitecore.Collections Namespace


JobCollection Methods

[image] [image]

Sitecore 6.4.1 API
JobCollection Methods
JobCollection Class See Also Send Feedback

The JobCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Job >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Job >)>)>.)
Protected method | ClearItems | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Job >)>)>.)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Job >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' Job >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Job >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Job >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Job >)>)>.)
Protected method | InsertItem | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Job >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Job >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Job >)>)>.)
Protected method | RemoveItem | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Job >)>)>.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from Collection <(Of <(<' Job >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

JobCollection Class
Sitecore.Collections Namespace


JobCollection Properties

[image] [image]

Sitecore 6.4.1 API
JobCollection Properties
JobCollection Class See Also Send Feedback

The JobCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Job >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Job >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Job >)>)>.)

See Also

JobCollection Class
Sitecore.Collections Namespace


LanguageCollection Class

[image]

Sitecore 6.4.1 API
LanguageCollection Class
Members See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class LanguageCollection : Collection<Language>,
    ICacheable
Visual Basic
Public Class LanguageCollection _
    Inherits Collection(Of Language) _
    Implements ICacheable
Visual C++
public ref class LanguageCollection : public Collection<Language^>,
    ICacheable

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<' Language >)>)>
Sitecore.Collections..::..LanguageCollection

See Also

LanguageCollection Members
Sitecore.Collections Namespace


LanguageCollection Members

[image] [image]

Sitecore 6.4.1 API
LanguageCollection Members
LanguageCollection Class Constructors Methods Properties See Also Send Feedback

The LanguageCollection type exposes the following members.

Constructors

 | Name | Description
Public method | LanguageCollection()()()() | Initializes a new instance of the LanguageCollection class.
Public method | LanguageCollection(IEnumerable<(Of <<'(Language>)>>)) | Initializes a new instance of the LanguageCollection class.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Language >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Language >)>)>.)
Protected method | ClearItems | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Language >)>)>.)
Public method | Contains(String) | Checks if the collection contains a language with a specific name.
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Language >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' Language >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDataLength | Gets the current (estimated) size of the object (in bytes).
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Language >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Language >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Language >)>)>.)
Protected method | InsertItem | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Language >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Language >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Language >)>)>.)
Protected method | RemoveItem | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Language >)>)>.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from Collection <(Of <(<' Language >)>)>.)
Public method | ToArray | Converts the collection to an array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cacheable | Gets a value indicating if the object is cacheable.
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Language >)>)>.)
Public property | Immutable | Gets a value indicating whether this ICacheable is immutable.
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Language >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Language >)>)>.)

See Also

LanguageCollection Class
Sitecore.Collections Namespace


LanguageCollection Constructor

[image] [image]

Sitecore 6.4.1 API
LanguageCollection Constructor
LanguageCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LanguageCollection()()()() | Initializes a new instance of the LanguageCollection class.
Public method | LanguageCollection(IEnumerable<(Of <<'(Language>)>>)) | Initializes a new instance of the LanguageCollection class.

See Also

LanguageCollection Class
LanguageCollection Members
Sitecore.Collections Namespace


LanguageCollection Constructor (IEnumerable(Language))

[image]

Sitecore 6.4.1 API
LanguageCollection Constructor (IEnumerable<(Of <(<'Language>)>)>)
LanguageCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LanguageCollection(
    IEnumerable<Language> initialData
)
Visual Basic
Public Sub New ( _
    initialData As IEnumerable(Of Language) _
)
Visual C++
public:
LanguageCollection(
    IEnumerable<Language^>^ initialData
)

Parameters

initialData
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Language >)>)>
The initial data.

See Also

LanguageCollection Class
LanguageCollection Overload
Sitecore.Collections Namespace


LanguageCollection Methods

[image] [image]

Sitecore 6.4.1 API
LanguageCollection Methods
LanguageCollection Class See Also Send Feedback

The LanguageCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Language >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Language >)>)>.)
Protected method | ClearItems | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Language >)>)>.)
Public method | Contains(String) | Checks if the collection contains a language with a specific name.
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Language >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' Language >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDataLength | Gets the current (estimated) size of the object (in bytes).
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Language >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Language >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Language >)>)>.)
Protected method | InsertItem | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Language >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Language >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Language >)>)>.)
Protected method | RemoveItem | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Language >)>)>.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from Collection <(Of <(<' Language >)>)>.)
Public method | ToArray | Converts the collection to an array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LanguageCollection Class
Sitecore.Collections Namespace


Contains Method

[image] [image]

Sitecore 6.4.1 API
LanguageCollection..::..Contains Method
LanguageCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Contains(String) | Checks if the collection contains a language with a specific name.
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Language >)>)>.)

See Also

LanguageCollection Class
LanguageCollection Members
Sitecore.Collections Namespace


Contains Method (String)

[image]

Sitecore 6.4.1 API
LanguageCollection..::..Contains Method (String)
LanguageCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Contains(
    string languageName
)
Visual Basic
Public Function Contains ( _
    languageName As String _
) As Boolean
Visual C++
public:
bool Contains(
    String^ languageName
)

Parameters

languageName
Type: System..::..String

[Missing <param name="languageName"/> documentation for "M:Sitecore.Collections.LanguageCollection.Contains(System.String)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Collections.LanguageCollection.Contains(System.String)"]

See Also

LanguageCollection Class
Contains Overload
Sitecore.Collections Namespace


GetDataLength Method

[image]

Sitecore 6.4.1 API
LanguageCollection..::..GetDataLength Method
LanguageCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long GetDataLength()
Visual Basic
Public Function GetDataLength As Long
Visual C++
public:
virtual long long GetDataLength() sealed

Return Value

[Missing <returns> documentation for "M:Sitecore.Collections.LanguageCollection.GetDataLength"]

Implements

ICacheable..::..GetDataLength()()()()

See Also

LanguageCollection Class
Sitecore.Collections Namespace


ToArray Method

[image]

Sitecore 6.4.1 API
LanguageCollection..::..ToArray Method
LanguageCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Language[] ToArray()
Visual Basic
Public Function ToArray As Language()
Visual C++
public:
array<Language^>^ ToArray()

Return Value

[Missing <returns> documentation for "M:Sitecore.Collections.LanguageCollection.ToArray"]

See Also

LanguageCollection Class
Sitecore.Collections Namespace


LanguageCollection Properties

[image] [image]

Sitecore 6.4.1 API
LanguageCollection Properties
LanguageCollection Class See Also Send Feedback

The LanguageCollection type exposes the following members.

Properties

 | Name | Description
Public property | Cacheable | Gets a value indicating if the object is cacheable.
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Language >)>)>.)
Public property | Immutable | Gets a value indicating whether this ICacheable is immutable.
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Language >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Language >)>)>.)

See Also

LanguageCollection Class
Sitecore.Collections Namespace


Cacheable Property

[image]

Sitecore 6.4.1 API
LanguageCollection..::..Cacheable Property
LanguageCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Cacheable { get; set; }
Visual Basic
Public Property Cacheable As Boolean
    Get
    Set
Visual C++
public:
virtual property bool Cacheable {
    bool get () sealed;
    void set (bool value) sealed;
}

Field Value

Implements

ICacheable..::..Cacheable

See Also

LanguageCollection Class
Sitecore.Collections Namespace


Immutable Property

[image]

Sitecore 6.4.1 API
LanguageCollection..::..Immutable Property
LanguageCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Immutable { get; }
Visual Basic
Public ReadOnly Property Immutable As Boolean
    Get
Visual C++
public:
virtual property bool Immutable {
    bool get () sealed;
}

Field Value

true if immutable; otherwise, false.

Implements

ICacheable..::..Immutable

See Also

LanguageCollection Class
Sitecore.Collections Namespace


LanguageDictionary Class

[image]

Sitecore 6.4.1 API
LanguageDictionary Class
Members See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class LanguageDictionary : SafeDictionary<string, Language>,
    ICacheable
Visual Basic
<SerializableAttribute> _
Public Class LanguageDictionary _
    Inherits SafeDictionary(Of String, Language) _
    Implements ICacheable
Visual C++
[SerializableAttribute]
public ref class LanguageDictionary : public SafeDictionary<String^, Language^>,
    ICacheable

Inheritance Hierarchy

System..::..Object
Sitecore.Collections..::..SafeDictionary <(Of <(<' String, Language >)>)>
Sitecore.Collections..::..LanguageDictionary

See Also

LanguageDictionary Members
Sitecore.Collections Namespace


LanguageDictionary Members

[image] [image]

Sitecore 6.4.1 API
LanguageDictionary Members
LanguageDictionary Class Constructors Methods Properties See Also Send Feedback

The LanguageDictionary type exposes the following members.

Constructors

 | Name | Description
Protected method | LanguageDictionary | Initializes a new instance of the LanguageDictionary class.

Methods

 | Name | Description
Public method | Add | Adds the specified key/value pair to the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | AddRange | Adds a range of key/values. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | Clear | Removes all entries from the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | Clone | Clones this instance. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | ContainsKey | Determines whether the dictionary contains the specified key. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDataLength | Gets the current (estimated) size of the object (in bytes).
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides SafeDictionary<(Of <(<'TKey, TValue>)>)>..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the entry with the specified key from the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | ToKeyArray | Returns an array containing all keys. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToValueArray | Returns an array containing all values. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | TryGetValue | Attempts to get a specific value. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)

Properties

 | Name | Description
Public property | Cacheable | Gets a value indicating if the object is cacheable.
Public property | Count | Gets the number of entries in the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Protected property | Hashtable | Gets the internal hashtable. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | Immutable | Gets a value indicating whether this ICacheable is immutable.
Public property | Item | Gets or sets the value with the specified key. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | Keys | Gets the keys of the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | ReadOnly | Gets or sets a value indicating whether [read only]. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | SyncRoot | Gets the object to use for locking in multi-thread scenarios. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | Values | Gets the values of the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)

See Also

LanguageDictionary Class
Sitecore.Collections Namespace


LanguageDictionary Constructor

[image]

Sitecore 6.4.1 API
LanguageDictionary Constructor
LanguageDictionary Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected LanguageDictionary(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
LanguageDictionary(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

LanguageDictionary Class
Sitecore.Collections Namespace


LanguageDictionary Methods

[image] [image]

Sitecore 6.4.1 API
LanguageDictionary Methods
LanguageDictionary Class See Also Send Feedback

The LanguageDictionary type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key/value pair to the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | AddRange | Adds a range of key/values. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | Clear | Removes all entries from the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | Clone | Clones this instance. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | ContainsKey | Determines whether the dictionary contains the specified key. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDataLength | Gets the current (estimated) size of the object (in bytes).
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides SafeDictionary<(Of <(<'TKey, TValue>)>)>..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the entry with the specified key from the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | ToKeyArray | Returns an array containing all keys. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToValueArray | Returns an array containing all values. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | TryGetValue | Attempts to get a specific value. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)

See Also

LanguageDictionary Class
Sitecore.Collections Namespace


GetDataLength Method

[image]

Sitecore 6.4.1 API
LanguageDictionary..::..GetDataLength Method
LanguageDictionary Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long GetDataLength()
Visual Basic
Public Function GetDataLength As Long
Visual C++
public:
virtual long long GetDataLength() sealed

Return Value

[Missing <returns> documentation for "M:Sitecore.Collections.LanguageDictionary.GetDataLength"]

Implements

ICacheable..::..GetDataLength()()()()

See Also

LanguageDictionary Class
Sitecore.Collections Namespace


GetObjectData Method

[image]

Sitecore 6.4.1 API
LanguageDictionary..::..GetObjectData Method
LanguageDictionary Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System.Security..::..SecurityException | The caller does not have the required permission.

See Also

LanguageDictionary Class
Sitecore.Collections Namespace


Cacheable Property

[image]

Sitecore 6.4.1 API
LanguageDictionary..::..Cacheable Property
LanguageDictionary Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Cacheable { get; set; }
Visual Basic
Public Property Cacheable As Boolean
    Get
    Set
Visual C++
public:
virtual property bool Cacheable {
    bool get () sealed;
    void set (bool value) sealed;
}

Field Value

Implements

ICacheable..::..Cacheable

See Also

LanguageDictionary Class
Sitecore.Collections Namespace


Immutable Property

[image]

Sitecore 6.4.1 API
LanguageDictionary..::..Immutable Property
LanguageDictionary Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Immutable { get; }
Visual Basic
Public ReadOnly Property Immutable As Boolean
    Get
Visual C++
public:
virtual property bool Immutable {
    bool get () sealed;
}

Field Value

true if immutable; otherwise, false.

Implements

ICacheable..::..Immutable

See Also

LanguageDictionary Class
Sitecore.Collections Namespace


LanguageList Class

[image]

Sitecore 6.4.1 API
LanguageList Class
Members See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class LanguageList : IEnumerable
Visual Basic
Public Class LanguageList _
    Implements IEnumerable
Visual C++
public ref class LanguageList : IEnumerable

Inheritance Hierarchy

System..::..Object
Sitecore.Collections..::..LanguageList

See Also

LanguageList Members
Sitecore.Collections Namespace


LanguageList Members

[image] [image]

Sitecore 6.4.1 API
LanguageList Members
LanguageList Class Constructors Methods Properties See Also Send Feedback

The LanguageList type exposes the following members.

Constructors

 | Name | Description
Public method | LanguageList | Initializes a new instance of the LanguageList class

Methods

 | Name | Description
Public method | Add(Language) | Adds the specified language.
 | Add(LanguageList, LanguageList) | Adds the specified list.
 | Build | Builds the specified languages.
Public method | Contains | Determines whether the list contains the specified language.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToArray | Converts the LanguageList to an array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the count.
Public property | Item | Gets the Language at the specified index.

See Also

LanguageList Class
Sitecore.Collections Namespace


LanguageList Constructor

[image]

Sitecore 6.4.1 API
LanguageList Constructor
LanguageList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LanguageList()
Visual Basic
Public Sub New
Visual C++
public:
LanguageList()

See Also

LanguageList Class
Sitecore.Collections Namespace


LanguageList Methods

[image] [image]

Sitecore 6.4.1 API
LanguageList Methods
LanguageList Class See Also Send Feedback

The LanguageList type exposes the following members.

Methods

 | Name | Description
Public method | Add(Language) | Adds the specified language.
 | Add(LanguageList, LanguageList) | Adds the specified list.
 | Build | Builds the specified languages.
Public method | Contains | Determines whether the list contains the specified language.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToArray | Converts the LanguageList to an array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LanguageList Class
Sitecore.Collections Namespace


Add Method

[image] [image]

Sitecore 6.4.1 API
LanguageList..::..Add Method
LanguageList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(Language) | Adds the specified language.
 | Add(LanguageList, LanguageList) | Adds the specified list.

See Also

LanguageList Class
LanguageList Members
Sitecore.Collections Namespace


Add Method (Language)

[image]

Sitecore 6.4.1 API
LanguageList..::..Add Method (Language)
LanguageList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Add(
    Language language
)
Visual Basic
Public Sub Add ( _
    language As Language _
)
Visual C++
public:
void Add(
    Language^ language
)

Parameters

language
Type: Sitecore.Globalization..::..Language
The language.

See Also

LanguageList Class
Add Overload
Sitecore.Collections Namespace


Add Method (LanguageList, LanguageList)

[image]

Sitecore 6.4.1 API
LanguageList..::..Add Method (LanguageList, LanguageList)
LanguageList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static LanguageList Add(
    LanguageList list1,
    LanguageList list2
)
Visual Basic
Public Shared Function Add ( _
    list1 As LanguageList, _
    list2 As LanguageList _
) As LanguageList
Visual C++
public:
static LanguageList^ Add(
    LanguageList^ list1,
    LanguageList^ list2
)

Parameters

list1
Type: Sitecore.Collections..::..LanguageList
The list1.
list2
Type: Sitecore.Collections..::..LanguageList
The list2.

Return Value

[Missing <returns> documentation for "M:Sitecore.Collections.LanguageList.Add(Sitecore.Collections.LanguageList,Sitecore.Collections.LanguageList)"]

See Also

LanguageList Class
Add Overload
Sitecore.Collections Namespace


Build Method

[image]

Sitecore 6.4.1 API
LanguageList..::..Build Method
LanguageList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static LanguageList Build(
    params Language[] languages
)
Visual Basic
Public Shared Function Build ( _
    ParamArray languages As Language() _
) As LanguageList
Visual C++
public:
static LanguageList^ Build(
    ... array<Language^>^ languages
)

Parameters

languages
Type: array< Sitecore.Globalization..::..Language >[]()[][]
The languages.

Return Value

[Missing <returns> documentation for "M:Sitecore.Collections.LanguageList.Build(Sitecore.Globalization.Language[])"]

See Also

LanguageList Class
Sitecore.Collections Namespace


Contains Method

[image]

Sitecore 6.4.1 API
LanguageList..::..Contains Method
LanguageList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Contains(
    Language language
)
Visual Basic
Public Function Contains ( _
    language As Language _
) As Boolean
Visual C++
public:
bool Contains(
    Language^ language
)

Parameters

language
Type: Sitecore.Globalization..::..Language
The language.

Return Value

true if the list contains the specified language; otherwise, false.

See Also

LanguageList Class
Sitecore.Collections Namespace


GetEnumerator Method

[image]

Sitecore 6.4.1 API
LanguageList..::..GetEnumerator Method
LanguageList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator() sealed

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

LanguageList Class
Sitecore.Collections Namespace


ToArray Method

[image]

Sitecore 6.4.1 API
LanguageList..::..ToArray Method
LanguageList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Array ToArray()
Visual Basic
Public Function ToArray As Array
Visual C++
public:
Array^ ToArray()

Return Value

The LanguageList as an array.

See Also

LanguageList Class
Sitecore.Collections Namespace


Count Property

[image]

Sitecore 6.4.1 API
LanguageList..::..Count Property
LanguageList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
property int Count {
    int get ();
}

Field Value

The count.

See Also

LanguageList Class
Sitecore.Collections Namespace


Item Property

[image]

Sitecore 6.4.1 API
LanguageList..::..Item Property
LanguageList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Language this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    index As Integer _
) As Language
    Get
Visual C++
public:
property Language^ default[int index] {
    Language^ get (int index);
}

Parameters

index
Type: System..::..Int32

Field Value

See Also

LanguageList Class
Sitecore.Collections Namespace


LockSet Class

[image]

Sitecore 6.4.1 API
LockSet Class
Members See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class LockSet
Visual Basic
Public Class LockSet
Visual C++
public ref class LockSet

Inheritance Hierarchy

System..::..Object
Sitecore.Collections..::..LockSet

See Also

LockSet Members
Sitecore.Collections Namespace


LockSet Members

[image] [image]

Sitecore 6.4.1 API
LockSet Members
LockSet Class Constructors Methods See Also Send Feedback

The LockSet type exposes the following members.

Constructors

 | Name | Description
Public method | LockSet | Initializes a new instance of the LockSet class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLock | Gets a lock object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LockSet Class
Sitecore.Collections Namespace


LockSet Constructor

[image]

Sitecore 6.4.1 API
LockSet Constructor
LockSet Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LockSet()
Visual Basic
Public Sub New
Visual C++
public:
LockSet()

See Also

LockSet Class
Sitecore.Collections Namespace


LockSet Methods

[image] [image]

Sitecore 6.4.1 API
LockSet Methods
LockSet Class See Also Send Feedback

The LockSet type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLock | Gets a lock object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LockSet Class
Sitecore.Collections Namespace


GetLock Method

[image]

Sitecore 6.4.1 API
LockSet..::..GetLock Method
LockSet Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object GetLock(
    Object value
)
Visual Basic
Public Function GetLock ( _
    value As Object _
) As Object
Visual C++
public:
Object^ GetLock(
    Object^ value
)

Parameters

value
Type: System..::..Object
The value.

Return Value

The lock object.

See Also

LockSet Class
Sitecore.Collections Namespace


MinMax(T) Members

[image] [image]

Sitecore 6.4.1 API
MinMax<(Of <(<'T>)>)> Members
MinMax<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The MinMax<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | MinMax<(Of <(<'T>)>)> | Initializes a new instance of the Pair<(Of <(<'T1, T2>)>)> class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Max | Gets the max.
Public property | Min | Gets the min.

See Also

MinMax<(Of <(<'T>)>)> Class
Sitecore.Collections Namespace


MinMax(T) Constructor

[image]

Sitecore 6.4.1 API
MinMax<(Of <(<'T>)>)> Constructor
MinMax<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MinMax(
    T min,
    T max
)
Visual Basic
Public Sub New ( _
    min As T, _
    max As T _
)
Visual C++
public:
MinMax(
    T min,
    T max
)

Parameters

min
Type: T
The min.
max
Type: T
The max.

See Also

MinMax<(Of <(<'T>)>)> Class
Sitecore.Collections Namespace


MinMax(T) Methods

[image] [image]

Sitecore 6.4.1 API
MinMax<(Of <(<'T>)>)> Methods
MinMax<(Of <(<'T>)>)> Class See Also Send Feedback

The MinMax<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MinMax<(Of <(<'T>)>)> Class
Sitecore.Collections Namespace


MinMax(T) Properties

[image] [image]

Sitecore 6.4.1 API
MinMax<(Of <(<'T>)>)> Properties
MinMax<(Of <(<'T>)>)> Class See Also Send Feedback

The MinMax<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Max | Gets the max.
Public property | Min | Gets the min.

See Also

MinMax<(Of <(<'T>)>)> Class
Sitecore.Collections Namespace


Min Property

[image]

Sitecore 6.4.1 API
MinMax<(Of <(<'T>)>)>..::..Min Property
MinMax<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public T Min { get; }
Visual Basic
Public ReadOnly Property Min As T
    Get
Visual C++
public:
property T Min {
    T get ();
}

Field Value

The min.

See Also

MinMax<(Of <(<'T>)>)> Class
Sitecore.Collections Namespace


Pair(T1, T2) Class

[image]

Sitecore 6.4.1 API
Pair<(Of <(<'T1, T2>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Pair<T1, T2>
Visual Basic
Public Class Pair(Of T1, T2)
Visual C++
generic<typename T1, typename T2>
public ref class Pair

Type Parameters

T1

[Missing <typeparam name="T1"/> documentation for "T:Sitecore.Collections.Pair`2"]

T2

[Missing <typeparam name="T2"/> documentation for "T:Sitecore.Collections.Pair`2"]

Inheritance Hierarchy

System..::..Object
Sitecore.Collections..::..Pair<(Of <(<'T1, T2>)>)>

See Also

Pair<(Of <(<'T1, T2>)>)> Members
Sitecore.Collections Namespace


Pair(T1, T2) Members

[image] [image]

Sitecore 6.4.1 API
Pair<(Of <(<'T1, T2>)>)> Members
Pair<(Of <(<'T1, T2>)>)> Class Constructors Methods Properties See Also Send Feedback

The Pair<(Of <(<'T1, T2>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | Pair<(Of <(<'T1, T2>)>)> | Initializes a new instance of the Pair<(Of <(<'T1, T2>)>)> class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Part1 | Gets part1.
Public property | Part2 | Gets part2.

See Also

Pair<(Of <(<'T1, T2>)>)> Class
Sitecore.Collections Namespace


Pair(T1, T2) Constructor

[image]

Sitecore 6.4.1 API
Pair<(Of <(<'T1, T2>)>)> Constructor
Pair<(Of <(<'T1, T2>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Pair(
    T1 part1,
    T2 part2
)
Visual Basic
Public Sub New ( _
    part1 As T1, _
    part2 As T2 _
)
Visual C++
public:
Pair(
    T1 part1,
    T2 part2
)

Parameters

part1
Type: T1
The part1.
part2
Type: T2
The part2.

See Also

Pair<(Of <(<'T1, T2>)>)> Class
Sitecore.Collections Namespace


Pair(T1, T2) Methods

[image] [image]

Sitecore 6.4.1 API
Pair<(Of <(<'T1, T2>)>)> Methods
Pair<(Of <(<'T1, T2>)>)> Class See Also Send Feedback

The Pair<(Of <(<'T1, T2>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Pair<(Of <(<'T1, T2>)>)> Class
Sitecore.Collections Namespace


Pair(T1, T2) Properties

[image] [image]

Sitecore 6.4.1 API
Pair<(Of <(<'T1, T2>)>)> Properties
Pair<(Of <(<'T1, T2>)>)> Class See Also Send Feedback

The Pair<(Of <(<'T1, T2>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Part1 | Gets part1.
Public property | Part2 | Gets part2.

See Also

Pair<(Of <(<'T1, T2>)>)> Class
Sitecore.Collections Namespace


Part2 Property

[image]

Sitecore 6.4.1 API
Pair<(Of <(<'T1, T2>)>)>..::..Part2 Property
Pair<(Of <(<'T1, T2>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public T2 Part2 { get; }
Visual Basic
Public ReadOnly Property Part2 As T2
    Get
Visual C++
public:
property T2 Part2 {
    T2 get ();
}

Field Value

The part1.

See Also

Pair<(Of <(<'T1, T2>)>)> Class
Sitecore.Collections Namespace


PerformanceCounterCollection Class

[image]

Sitecore 6.4.1 API
PerformanceCounterCollection Class
Members See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PerformanceCounterCollection : Collection<PerformanceCounter>
Visual Basic
Public Class PerformanceCounterCollection _
    Inherits Collection(Of PerformanceCounter)
Visual C++
public ref class PerformanceCounterCollection : public Collection<PerformanceCounter^>

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<' PerformanceCounter >)>)>
Sitecore.Collections..::..PerformanceCounterCollection

See Also

PerformanceCounterCollection Members
Sitecore.Collections Namespace


PerformanceCounterCollection Members

[image] [image]

Sitecore 6.4.1 API
PerformanceCounterCollection Members
PerformanceCounterCollection Class Constructors Methods Properties See Also Send Feedback

The PerformanceCounterCollection type exposes the following members.

Constructors

 | Name | Description
Public method | PerformanceCounterCollection | Initializes a new instance of the PerformanceCounterCollection class

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' PerformanceCounter >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' PerformanceCounter >)>)>.)
Protected method | ClearItems | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' PerformanceCounter >)>)>.)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' PerformanceCounter >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' PerformanceCounter >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' PerformanceCounter >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' PerformanceCounter >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' PerformanceCounter >)>)>.)
Protected method | InsertItem | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' PerformanceCounter >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' PerformanceCounter >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' PerformanceCounter >)>)>.)
Protected method | RemoveItem | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' PerformanceCounter >)>)>.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from Collection <(Of <(<' PerformanceCounter >)>)>.)
Public method | ToArray | Converts the collection to an array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' PerformanceCounter >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' PerformanceCounter >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' PerformanceCounter >)>)>.)

See Also

PerformanceCounterCollection Class
Sitecore.Collections Namespace


PerformanceCounterCollection Constructor

[image]

Sitecore 6.4.1 API
PerformanceCounterCollection Constructor
PerformanceCounterCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PerformanceCounterCollection()
Visual Basic
Public Sub New
Visual C++
public:
PerformanceCounterCollection()

See Also

PerformanceCounterCollection Class
Sitecore.Collections Namespace


PerformanceCounterCollection Methods

[image] [image]

Sitecore 6.4.1 API
PerformanceCounterCollection Methods
PerformanceCounterCollection Class See Also Send Feedback

The PerformanceCounterCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' PerformanceCounter >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' PerformanceCounter >)>)>.)
Protected method | ClearItems | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' PerformanceCounter >)>)>.)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' PerformanceCounter >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' PerformanceCounter >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' PerformanceCounter >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' PerformanceCounter >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' PerformanceCounter >)>)>.)
Protected method | InsertItem | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' PerformanceCounter >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' PerformanceCounter >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' PerformanceCounter >)>)>.)
Protected method | RemoveItem | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' PerformanceCounter >)>)>.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from Collection <(Of <(<' PerformanceCounter >)>)>.)
Public method | ToArray | Converts the collection to an array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PerformanceCounterCollection Class
Sitecore.Collections Namespace


ToArray Method

[image]

Sitecore 6.4.1 API
PerformanceCounterCollection..::..ToArray Method
PerformanceCounterCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PerformanceCounter[] ToArray()
Visual Basic
Public Function ToArray As PerformanceCounter()
Visual C++
public:
array<PerformanceCounter^>^ ToArray()

Return Value

The PerformanceCounterCollection as an array.

See Also

PerformanceCounterCollection Class
Sitecore.Collections Namespace


PerformanceCounterCollection Properties

[image] [image]

Sitecore 6.4.1 API
PerformanceCounterCollection Properties
PerformanceCounterCollection Class See Also Send Feedback

The PerformanceCounterCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' PerformanceCounter >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' PerformanceCounter >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' PerformanceCounter >)>)>.)

See Also

PerformanceCounterCollection Class
Sitecore.Collections Namespace


ReadOnlyList(TElement) Class

[image]

Sitecore 6.4.1 API
ReadOnlyList<(Of <(<'TElement>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ReadOnlyList<TElement> : IEnumerable<T>,
    IEnumerable
Visual Basic
Public Class ReadOnlyList(Of TElement) _
    Implements IEnumerable(Of T), IEnumerable
Visual C++
generic<typename TElement>
public ref class ReadOnlyList : IEnumerable<T>,
    IEnumerable

Type Parameters

TElement

[Missing <typeparam name="TElement"/> documentation for "T:Sitecore.Collections.ReadOnlyList`1"]

Inheritance Hierarchy

System..::..Object
Sitecore.Collections..::..ReadOnlyList<(Of <(<'TElement>)>)>
Sitecore.Collections..::..AttributeList
Sitecore.Collections..::..ReadOnlyStringList
Sitecore.Data.Archiving..::..ArchiveEntryList
Sitecore.Data.Items..::..ReadOnlyItemList
Sitecore.Data.Templates..::..TemplateList
Sitecore.Layouts..::..RenderingReferenceList
Sitecore.Security.Accounts..::..AccountList
Sitecore.Security.Accounts..::..RoleList
Sitecore.Security.Accounts..::..UserList
Sitecore.Security.Domains..::..DomainList
Sitecore.Web.UI.WebControls..::..PlaceholderList

See Also

ReadOnlyList<(Of <(<'TElement>)>)> Members
Sitecore.Collections Namespace


ReadOnlyList(TElement) Members

[image] [image]

Sitecore 6.4.1 API
ReadOnlyList<(Of <(<'TElement>)>)> Members
ReadOnlyList<(Of <(<'TElement>)>)> Class Constructors Methods Properties See Also Send Feedback

The ReadOnlyList<(Of <(<'TElement>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | ReadOnlyList<(Of <(<'TElement>)>)>()()()() | Initializes a new instance of the ReadOnlyList<(Of <(<'TElement>)>)> class.
Public method | ReadOnlyList<(Of <(<'TElement>)>)>(IEnumerable<(Of <<'(TElement>)>>)) | Initializes a new instance of the ReadOnlyList<(Of <(<'TElement>)>)> class.

Methods

 | Name | Description
 | Combine | Combines two lists
Public method | Contains | Determines whether the list contains the specified element.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToArray | Converts the list to an array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | Convert<(Of <<'(T, TTo>)>>) | Converts this instance. (Defined by EnumerableExtensions.)
Public Extension Method | StringConcatenate<(Of <<'(T>)>>) | Concatenate strings (Defined by IEnumerableExtensions.)

Properties

 | Name | Description
Public property | Count | Gets the number of entries in the list.
 | Empty | Gets the empty collection.
Public property | Item | Gets the element at the specified index.

See Also

ReadOnlyList<(Of <(<'TElement>)>)> Class
Sitecore.Collections Namespace


ReadOnlyList(TElement) Constructor

[image] [image]

Sitecore 6.4.1 API
ReadOnlyList<(Of <(<'TElement>)>)> Constructor
ReadOnlyList<(Of <(<'TElement>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadOnlyList<(Of <(<'TElement>)>)>()()()() | Initializes a new instance of the ReadOnlyList<(Of <(<'TElement>)>)> class.
Public method | ReadOnlyList<(Of <(<'TElement>)>)>(IEnumerable<(Of <<'(TElement>)>>)) | Initializes a new instance of the ReadOnlyList<(Of <(<'TElement>)>)> class.

See Also

ReadOnlyList<(Of <(<'TElement>)>)> Class
ReadOnlyList<(Of <(<'TElement>)>)> Members
Sitecore.Collections Namespace


ReadOnlyList(TElement) Constructor

[image]

Sitecore 6.4.1 API
ReadOnlyList<(Of <(<'TElement>)>)> Constructor
ReadOnlyList<(Of <(<'TElement>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ReadOnlyList()
Visual Basic
Public Sub New
Visual C++
public:
ReadOnlyList()

See Also

ReadOnlyList<(Of <(<'TElement>)>)> Class
ReadOnlyList<(Of <(<'TElement>)>)> Overload
Sitecore.Collections Namespace


ReadOnlyList(TElement) Constructor (IEnumerable(TElement))

[image]

Sitecore 6.4.1 API
ReadOnlyList<(Of <(<'TElement>)>)> Constructor (IEnumerable<(Of <(<'TElement>)>)>)
ReadOnlyList<(Of <(<'TElement>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ReadOnlyList(
    IEnumerable<TElement> entries
)
Visual Basic
Public Sub New ( _
    entries As IEnumerable(Of TElement) _
)
Visual C++
public:
ReadOnlyList(
    IEnumerable<TElement>^ entries
)

Parameters

entries
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' TElement >)>)>
The entries.

See Also

ReadOnlyList<(Of <(<'TElement>)>)> Class
ReadOnlyList<(Of <(<'TElement>)>)> Overload
Sitecore.Collections Namespace


ReadOnlyList(TElement) Methods

[image] [image]

Sitecore 6.4.1 API
ReadOnlyList<(Of <(<'TElement>)>)> Methods
ReadOnlyList<(Of <(<'TElement>)>)> Class See Also Send Feedback

The ReadOnlyList<(Of <(<'TElement>)>)> type exposes the following members.

Methods

 | Name | Description
 | Combine | Combines two lists
Public method | Contains | Determines whether the list contains the specified element.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToArray | Converts the list to an array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | Convert<(Of <<'(T, TTo>)>>) | Converts this instance. (Defined by EnumerableExtensions.)
Public Extension Method | StringConcatenate<(Of <<'(T>)>>) | Concatenate strings (Defined by IEnumerableExtensions.)

See Also

ReadOnlyList<(Of <(<'TElement>)>)> Class
Sitecore.Collections Namespace


Combine Method

[image]

Sitecore 6.4.1 API
ReadOnlyList<(Of <(<'TElement>)>)>..::..Combine Method
ReadOnlyList<(Of <(<'TElement>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static IEnumerable<TElement> Combine(
    IEnumerable<TElement> list1,
    IEnumerable<TElement> list2
)
Visual Basic
Public Shared Function Combine ( _
    list1 As IEnumerable(Of TElement), _
    list2 As IEnumerable(Of TElement) _
) As IEnumerable(Of TElement)
Visual C++
public:
static IEnumerable<TElement>^ Combine(
    IEnumerable<TElement>^ list1,
    IEnumerable<TElement>^ list2
)

Parameters

list1
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' TElement >)>)>

[Missing <param name="list1"/> documentation for "M:Sitecore.Collections.ReadOnlyList`1.Combine(System.Collections.Generic.IEnumerable{`0},System.Collections.Generic.IEnumerable{`0})"]

list2
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' TElement >)>)>

[Missing <param name="list2"/> documentation for "M:Sitecore.Collections.ReadOnlyList`1.Combine(System.Collections.Generic.IEnumerable{`0},System.Collections.Generic.IEnumerable{`0})"]

Field Value

Return Value

[Missing <returns> documentation for "M:Sitecore.Collections.ReadOnlyList`1.Combine(System.Collections.Generic.IEnumerable{`0},System.Collections.Generic.IEnumerable{`0})"]

See Also

ReadOnlyList<(Of <(<'TElement>)>)> Class
Sitecore.Collections Namespace


Contains Method

[image]

Sitecore 6.4.1 API
ReadOnlyList<(Of <(<'TElement>)>)>..::..Contains Method
ReadOnlyList<(Of <(<'TElement>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool Contains(
    TElement element
)
Visual Basic
Public Overridable Function Contains ( _
    element As TElement _
) As Boolean
Visual C++
public:
virtual bool Contains(
    TElement element
)

Parameters

element
Type: TElement
The element.

Return Value

true if the list contains the specified element; otherwise, false.

See Also

ReadOnlyList<(Of <(<'TElement>)>)> Class
Sitecore.Collections Namespace


GetEnumerator Method

[image]

Sitecore 6.4.1 API
ReadOnlyList<(Of <(<'TElement>)>)>..::..GetEnumerator Method
ReadOnlyList<(Of <(<'TElement>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator() sealed

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

ReadOnlyList<(Of <(<'TElement>)>)> Class
Sitecore.Collections Namespace


ToArray Method

[image]

Sitecore 6.4.1 API
ReadOnlyList<(Of <(<'TElement>)>)>..::..ToArray Method
ReadOnlyList<(Of <(<'TElement>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TElement[] ToArray()
Visual Basic
Public Function ToArray As TElement()
Visual C++
public:
array<TElement>^ ToArray()

Return Value

[Missing <returns> documentation for "M:Sitecore.Collections.ReadOnlyList`1.ToArray"]

See Also

ReadOnlyList<(Of <(<'TElement>)>)> Class
Sitecore.Collections Namespace


ReadOnlyList(TElement) Properties

[image] [image]

Sitecore 6.4.1 API
ReadOnlyList<(Of <(<'TElement>)>)> Properties
ReadOnlyList<(Of <(<'TElement>)>)> Class See Also Send Feedback

The ReadOnlyList<(Of <(<'TElement>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of entries in the list.
 | Empty | Gets the empty collection.
Public property | Item | Gets the element at the specified index.

See Also

ReadOnlyList<(Of <(<'TElement>)>)> Class
Sitecore.Collections Namespace


Count Property

[image]

Sitecore 6.4.1 API
ReadOnlyList<(Of <(<'TElement>)>)>..::..Count Property
ReadOnlyList<(Of <(<'TElement>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
property int Count {
    int get ();
}

Field Value

The count.

See Also

ReadOnlyList<(Of <(<'TElement>)>)> Class
Sitecore.Collections Namespace


Empty Property

[image]

Sitecore 6.4.1 API
ReadOnlyList<(Of <(<'TElement>)>)>..::..Empty Property
ReadOnlyList<(Of <(<'TElement>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static IEnumerable<TElement> Empty { get; }
Visual Basic
Public Shared ReadOnly Property Empty As IEnumerable(Of TElement)
    Get
Visual C++
public:
static property IEnumerable<TElement>^ Empty {
    IEnumerable<TElement>^ get ();
}

Field Value

The empty.

See Also

ReadOnlyList<(Of <(<'TElement>)>)> Class
Sitecore.Collections Namespace


Item Property

[image]

Sitecore 6.4.1 API
ReadOnlyList<(Of <(<'TElement>)>)>..::..Item Property
ReadOnlyList<(Of <(<'TElement>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TElement this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    index As Integer _
) As TElement
    Get
Visual C++
public:
property TElement default[int index] {
    TElement get (int index);
}

Parameters

index
Type: System..::..Int32

Field Value

See Also

ReadOnlyList<(Of <(<'TElement>)>)> Class
Sitecore.Collections Namespace


ReadOnlyStringList Class

[image]

Sitecore 6.4.1 API
ReadOnlyStringList Class
Members See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ReadOnlyStringList : ReadOnlyList<string>
Visual Basic
Public Class ReadOnlyStringList _
    Inherits ReadOnlyList(Of String)
Visual C++
public ref class ReadOnlyStringList : public ReadOnlyList<String^>

Inheritance Hierarchy

System..::..Object
Sitecore.Collections..::..ReadOnlyList <(Of <(<' String >)>)>
Sitecore.Collections..::..ReadOnlyStringList

See Also

ReadOnlyStringList Members
Sitecore.Collections Namespace


ReadOnlyStringList Members

[image] [image]

Sitecore 6.4.1 API
ReadOnlyStringList Members
ReadOnlyStringList Class Constructors Methods Properties See Also Send Feedback

The ReadOnlyStringList type exposes the following members.

Constructors

 | Name | Description
Public method | ReadOnlyStringList()()()() | Initializes a new instance of the ReadOnlyStringList class.
Public method | ReadOnlyStringList(IEnumerable<(Of <<'(String>)>>)) | Initializes a new instance of the ReadOnlyStringList class.

Methods

 | Name | Description
Public method | Contains | Determines whether the list contains the specified element. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToArray | Converts the list to an array. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of entries in the list. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public property | Item | Gets the element at the specified index. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)

See Also

ReadOnlyStringList Class
Sitecore.Collections Namespace


ReadOnlyStringList Constructor

[image] [image]

Sitecore 6.4.1 API
ReadOnlyStringList Constructor
ReadOnlyStringList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadOnlyStringList()()()() | Initializes a new instance of the ReadOnlyStringList class.
Public method | ReadOnlyStringList(IEnumerable<(Of <<'(String>)>>)) | Initializes a new instance of the ReadOnlyStringList class.

See Also

ReadOnlyStringList Class
ReadOnlyStringList Members
Sitecore.Collections Namespace


ReadOnlyStringList Constructor (IEnumerable(String))

[image]

Sitecore 6.4.1 API
ReadOnlyStringList Constructor (IEnumerable<(Of <(<'String>)>)>)
ReadOnlyStringList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ReadOnlyStringList(
    IEnumerable<string> entries
)
Visual Basic
Public Sub New ( _
    entries As IEnumerable(Of String) _
)
Visual C++
public:
ReadOnlyStringList(
    IEnumerable<String^>^ entries
)

Parameters

entries
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' String >)>)>
The entries.

See Also

ReadOnlyStringList Class
ReadOnlyStringList Overload
Sitecore.Collections Namespace


ReadOnlyStringList Methods

[image] [image]

Sitecore 6.4.1 API
ReadOnlyStringList Methods
ReadOnlyStringList Class See Also Send Feedback

The ReadOnlyStringList type exposes the following members.

Methods

 | Name | Description
Public method | Contains | Determines whether the list contains the specified element. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToArray | Converts the list to an array. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReadOnlyStringList Class
Sitecore.Collections Namespace


ReadOnlyStringList Properties

[image] [image]

Sitecore 6.4.1 API
ReadOnlyStringList Properties
ReadOnlyStringList Class See Also Send Feedback

The ReadOnlyStringList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of entries in the list. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public property | Item | Gets the element at the specified index. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)

See Also

ReadOnlyStringList Class
Sitecore.Collections Namespace


SafeDictionary(TKeyAndValue) Class

[image]

Sitecore 6.4.1 API
SafeDictionary<(Of <(<'TKeyAndValue>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class SafeDictionary<TKeyAndValue> : SafeDictionary<TKeyAndValue, TKeyAndValue>
Visual Basic
<SerializableAttribute> _
Public Class SafeDictionary(Of TKeyAndValue) _
    Inherits SafeDictionary(Of TKeyAndValue, TKeyAndValue)
Visual C++
[SerializableAttribute]
generic<typename TKeyAndValue>
public ref class SafeDictionary : public SafeDictionary<TKeyAndValue, TKeyAndValue>

Type Parameters

TKeyAndValue

[Missing <typeparam name="TKeyAndValue"/> documentation for "T:Sitecore.Collections.SafeDictionary`1"]

Inheritance Hierarchy

System..::..Object
Sitecore.Collections..::..SafeDictionary <(Of <(<'TKeyAndValue, TKeyAndValue>)>)>
Sitecore.Collections..::..SafeDictionary<(Of <(<'TKeyAndValue>)>)>

See Also

SafeDictionary<(Of <(<'TKeyAndValue>)>)> Members
Sitecore.Collections Namespace


SafeDictionary(TKeyAndValue) Members

[image] [image]

Sitecore 6.4.1 API
SafeDictionary<(Of <(<'TKeyAndValue>)>)> Members
SafeDictionary<(Of <(<'TKeyAndValue>)>)> Class Constructors Methods Properties See Also Send Feedback

The SafeDictionary<(Of <(<'TKeyAndValue>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | SafeDictionary<(Of <(<'TKeyAndValue>)>)>()()()() | Initializes a new instance of the SafeDictionary<(Of <(<'TKeyAndValue>)>)> class.
Public method | SafeDictionary<(Of <(<'TKeyAndValue>)>)>(IEqualityComparer) | Initializes a new instance of the SafeDictionary<(Of <(<'TKeyAndValue>)>)> class.
Protected method | SafeDictionary<(Of <(<'TKeyAndValue>)>)>(SerializationInfo, StreamingContext) | Initializes a new instance of the SafeDictionary<(Of <(<'TKeyAndValue>)>)> class.

Methods

 | Name | Description
Public method | Add | Adds the specified key/value pair to the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | AddArray | Adds an array of values.
Public method | AddRange | Adds a range of key/values. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | Clear | Removes all entries from the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | Clone | Clones this instance.
Public method | ContainsKey | Determines whether the dictionary contains the specified key. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the entry with the specified key from the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | ToArray | Converts the collection to an array.
Public method | ToKeyArray | Returns an array containing all keys. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToValueArray | Returns an array containing all values. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | TryGetValue | Attempts to get a specific value. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)

Properties

 | Name | Description
Public property | Count | Gets the number of entries in the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Protected property | Hashtable | Gets the internal hashtable. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | Item | Gets or sets the value with the specified key. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | Keys | Gets the keys of the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | ReadOnly | Gets or sets a value indicating whether [read only]. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | SyncRoot | Gets the object to use for locking in multi-thread scenarios. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | Values | Gets the values of the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)

See Also

SafeDictionary<(Of <(<'TKeyAndValue>)>)> Class
Sitecore.Collections Namespace


SafeDictionary(TKeyAndValue) Constructor

[image] [image]

Sitecore 6.4.1 API
SafeDictionary<(Of <(<'TKeyAndValue>)>)> Constructor
SafeDictionary<(Of <(<'TKeyAndValue>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SafeDictionary<(Of <(<'TKeyAndValue>)>)>()()()() | Initializes a new instance of the SafeDictionary<(Of <(<'TKeyAndValue>)>)> class.
Public method | SafeDictionary<(Of <(<'TKeyAndValue>)>)>(IEqualityComparer) | Initializes a new instance of the SafeDictionary<(Of <(<'TKeyAndValue>)>)> class.
Protected method | SafeDictionary<(Of <(<'TKeyAndValue>)>)>(SerializationInfo, StreamingContext) | Initializes a new instance of the SafeDictionary<(Of <(<'TKeyAndValue>)>)> class.

See Also

SafeDictionary<(Of <(<'TKeyAndValue>)>)> Class
SafeDictionary<(Of <(<'TKeyAndValue>)>)> Members
Sitecore.Collections Namespace


SafeDictionary(TKeyAndValue) Constructor

[image]

Sitecore 6.4.1 API
SafeDictionary<(Of <(<'TKeyAndValue>)>)> Constructor
SafeDictionary<(Of <(<'TKeyAndValue>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SafeDictionary()
Visual Basic
Public Sub New
Visual C++
public:
SafeDictionary()

See Also

SafeDictionary<(Of <(<'TKeyAndValue>)>)> Class
SafeDictionary<(Of <(<'TKeyAndValue>)>)> Overload
Sitecore.Collections Namespace


SafeDictionary(TKeyAndValue) Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
SafeDictionary<(Of <(<'TKeyAndValue>)>)> Constructor (SerializationInfo, StreamingContext)
SafeDictionary<(Of <(<'TKeyAndValue>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected SafeDictionary(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
SafeDictionary(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

SafeDictionary<(Of <(<'TKeyAndValue>)>)> Class
SafeDictionary<(Of <(<'TKeyAndValue>)>)> Overload
Sitecore.Collections Namespace


SafeDictionary(TKeyAndValue) Methods

[image] [image]

Sitecore 6.4.1 API
SafeDictionary<(Of <(<'TKeyAndValue>)>)> Methods
SafeDictionary<(Of <(<'TKeyAndValue>)>)> Class See Also Send Feedback

The SafeDictionary<(Of <(<'TKeyAndValue>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key/value pair to the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | AddArray | Adds an array of values.
Public method | AddRange | Adds a range of key/values. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | Clear | Removes all entries from the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | Clone | Clones this instance.
Public method | ContainsKey | Determines whether the dictionary contains the specified key. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the entry with the specified key from the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | ToArray | Converts the collection to an array.
Public method | ToKeyArray | Returns an array containing all keys. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToValueArray | Returns an array containing all values. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | TryGetValue | Attempts to get a specific value. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)

See Also

SafeDictionary<(Of <(<'TKeyAndValue>)>)> Class
Sitecore.Collections Namespace


AddArray Method

[image]

Sitecore 6.4.1 API
SafeDictionary<(Of <(<'TKeyAndValue>)>)>..::..AddArray Method
SafeDictionary<(Of <(<'TKeyAndValue>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddArray(
    TKeyAndValue[] values
)
Visual Basic
Public Sub AddArray ( _
    values As TKeyAndValue() _
)
Visual C++
public:
void AddArray(
    array<TKeyAndValue>^ values
)

Parameters

values
Type: array< TKeyAndValue >[]()[][]
The values.

See Also

SafeDictionary<(Of <(<'TKeyAndValue>)>)> Class
Sitecore.Collections Namespace


Clone Method

[image]

Sitecore 6.4.1 API
SafeDictionary<(Of <(<'TKeyAndValue>)>)>..::..Clone Method
SafeDictionary<(Of <(<'TKeyAndValue>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SafeDictionary<TKeyAndValue> Clone()
Visual Basic
Public Function Clone As SafeDictionary(Of TKeyAndValue)
Visual C++
public:
SafeDictionary<TKeyAndValue>^ Clone()

Return Value

[Missing <returns> documentation for "M:Sitecore.Collections.SafeDictionary`1.Clone"]

See Also

SafeDictionary<(Of <(<'TKeyAndValue>)>)> Class
Sitecore.Collections Namespace


ToArray Method

[image]

Sitecore 6.4.1 API
SafeDictionary<(Of <(<'TKeyAndValue>)>)>..::..ToArray Method
SafeDictionary<(Of <(<'TKeyAndValue>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TKeyAndValue[] ToArray()
Visual Basic
Public Function ToArray As TKeyAndValue()
Visual C++
public:
array<TKeyAndValue>^ ToArray()

Return Value

[Missing <returns> documentation for "M:Sitecore.Collections.SafeDictionary`1.ToArray"]

See Also

SafeDictionary<(Of <(<'TKeyAndValue>)>)> Class
Sitecore.Collections Namespace


SafeDictionary(TKeyAndValue) Properties

[image] [image]

Sitecore 6.4.1 API
SafeDictionary<(Of <(<'TKeyAndValue>)>)> Properties
SafeDictionary<(Of <(<'TKeyAndValue>)>)> Class See Also Send Feedback

The SafeDictionary<(Of <(<'TKeyAndValue>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of entries in the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Protected property | Hashtable | Gets the internal hashtable. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | Item | Gets or sets the value with the specified key. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | Keys | Gets the keys of the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | ReadOnly | Gets or sets a value indicating whether [read only]. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | SyncRoot | Gets the object to use for locking in multi-thread scenarios. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | Values | Gets the values of the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)

See Also

SafeDictionary<(Of <(<'TKeyAndValue>)>)> Class
Sitecore.Collections Namespace


SafeDictionary(TKey, TValue) Class

[image]

Sitecore 6.4.1 API
SafeDictionary<(Of <(<'TKey, TValue>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class SafeDictionary<TKey, TValue> : ISerializable,
    IEnumerable<KeyValuePair<TKey, TValue>>, IEnumerable
Visual Basic
<SerializableAttribute> _
Public Class SafeDictionary(Of TKey, TValue) _
    Implements ISerializable, IEnumerable(Of KeyValuePair(Of TKey, TValue)),  _
    IEnumerable
Visual C++
[SerializableAttribute]
generic<typename TKey, typename TValue>
public ref class SafeDictionary : ISerializable,
    IEnumerable<KeyValuePair<TKey, TValue>>, IEnumerable

Type Parameters

TKey

[Missing <typeparam name="TKey"/> documentation for "T:Sitecore.Collections.SafeDictionary`2"]

TValue

[Missing <typeparam name="TValue"/> documentation for "T:Sitecore.Collections.SafeDictionary`2"]

Inheritance Hierarchy

System..::..Object
Sitecore.Collections..::..SafeDictionary<(Of <(<'TKey, TValue>)>)>
Sitecore.Collections..::..FieldValueDictionary
Sitecore.Collections..::..LanguageDictionary
Sitecore.Collections..::..SafeDictionary<(Of <(<'TKeyAndValue>)>)>
Sitecore.Collections..::..StringDictionary
Sitecore.Collections..::..TemplateDictionary

See Also

SafeDictionary<(Of <(<'TKey, TValue>)>)> Members
Sitecore.Collections Namespace


SafeDictionary(TKey, TValue) Members

[image] [image]

Sitecore 6.4.1 API
SafeDictionary<(Of <(<'TKey, TValue>)>)> Members
SafeDictionary<(Of <(<'TKey, TValue>)>)> Class Constructors Methods Properties See Also Send Feedback

The SafeDictionary<(Of <(<'TKey, TValue>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | SafeDictionary<(Of <(<'TKey, TValue>)>)>()()()() | Initializes a new instance of the SafeDictionary<(Of <(<'TKey, TValue>)>)> class.
Public method | SafeDictionary<(Of <(<'TKey, TValue>)>)>(IEqualityComparer) | Initializes a new instance of the SafeDictionary<(Of <(<'TKey, TValue>)>)> class.
Protected method | SafeDictionary<(Of <(<'TKey, TValue>)>)>(SerializationInfo, StreamingContext) | Initializes a new instance of the SafeDictionary<(Of <(<'TKey, TValue>)>)> class.

Methods

 | Name | Description
Public method | Add | Adds the specified key/value pair to the dictionary.
Public method | AddRange | Adds a range of key/values.
Public method | Clear | Removes all entries from the dictionary.
Public method | Clone | Clones this instance.
Public method | ContainsKey | Determines whether the dictionary contains the specified key.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the entry with the specified key from the dictionary.
Public method | ToKeyArray | Returns an array containing all keys.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToValueArray | Returns an array containing all values.
Public method | TryGetValue | Attempts to get a specific value.

Extension Methods

 | Name | Description
Public Extension Method | Convert<(Of <<'(KeyValuePair<(Of <<'(TKey, TValue>)>>), TTo>)>>) | Converts this instance. (Defined by EnumerableExtensions.)
Public Extension Method | StringConcatenate<(Of <<'(KeyValuePair<(Of <<'(TKey, TValue>)>>)>)>>) | Concatenate strings (Defined by IEnumerableExtensions.)

Properties

 | Name | Description
Public property | Count | Gets the number of entries in the dictionary.
Protected property | Hashtable | Gets the internal hashtable.
Public property | Item | Gets or sets the value with the specified key.
Public property | Keys | Gets the keys of the dictionary.
Public property | ReadOnly | Gets or sets a value indicating whether [read only].
Public property | SyncRoot | Gets the object to use for locking in multi-thread scenarios.
Public property | Values | Gets the values of the dictionary.

See Also

SafeDictionary<(Of <(<'TKey, TValue>)>)> Class
Sitecore.Collections Namespace


SafeDictionary(TKey, TValue) Constructor

[image] [image]

Sitecore 6.4.1 API
SafeDictionary<(Of <(<'TKey, TValue>)>)> Constructor
SafeDictionary<(Of <(<'TKey, TValue>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SafeDictionary<(Of <(<'TKey, TValue>)>)>()()()() | Initializes a new instance of the SafeDictionary<(Of <(<'TKey, TValue>)>)> class.
Public method | SafeDictionary<(Of <(<'TKey, TValue>)>)>(IEqualityComparer) | Initializes a new instance of the SafeDictionary<(Of <(<'TKey, TValue>)>)> class.
Protected method | SafeDictionary<(Of <(<'TKey, TValue>)>)>(SerializationInfo, StreamingContext) | Initializes a new instance of the SafeDictionary<(Of <(<'TKey, TValue>)>)> class.

See Also

SafeDictionary<(Of <(<'TKey, TValue>)>)> Class
SafeDictionary<(Of <(<'TKey, TValue>)>)> Members
Sitecore.Collections Namespace


SafeDictionary(TKey, TValue) Constructor

[image]

Sitecore 6.4.1 API
SafeDictionary<(Of <(<'TKey, TValue>)>)> Constructor
SafeDictionary<(Of <(<'TKey, TValue>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SafeDictionary()
Visual Basic
Public Sub New
Visual C++
public:
SafeDictionary()

See Also

SafeDictionary<(Of <(<'TKey, TValue>)>)> Class
SafeDictionary<(Of <(<'TKey, TValue>)>)> Overload
Sitecore.Collections Namespace


SafeDictionary(TKey, TValue) Constructor (IEqualityComparer)

[image]

Sitecore 6.4.1 API
SafeDictionary<(Of <(<'TKey, TValue>)>)> Constructor (IEqualityComparer)
SafeDictionary<(Of <(<'TKey, TValue>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SafeDictionary(
    IEqualityComparer comparer
)
Visual Basic
Public Sub New ( _
    comparer As IEqualityComparer _
)
Visual C++
public:
SafeDictionary(
    IEqualityComparer^ comparer
)

Parameters

comparer
Type: System.Collections..::..IEqualityComparer
The comparer.

See Also

SafeDictionary<(Of <(<'TKey, TValue>)>)> Class
SafeDictionary<(Of <(<'TKey, TValue>)>)> Overload
Sitecore.Collections Namespace


SafeDictionary(TKey, TValue) Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
SafeDictionary<(Of <(<'TKey, TValue>)>)> Constructor (SerializationInfo, StreamingContext)
SafeDictionary<(Of <(<'TKey, TValue>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected SafeDictionary(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
SafeDictionary(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

SafeDictionary<(Of <(<'TKey, TValue>)>)> Class
SafeDictionary<(Of <(<'TKey, TValue>)>)> Overload
Sitecore.Collections Namespace


SafeDictionary(TKey, TValue) Methods

[image] [image]

Sitecore 6.4.1 API
SafeDictionary<(Of <(<'TKey, TValue>)>)> Methods
SafeDictionary<(Of <(<'TKey, TValue>)>)> Class See Also Send Feedback

The SafeDictionary<(Of <(<'TKey, TValue>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key/value pair to the dictionary.
Public method | AddRange | Adds a range of key/values.
Public method | Clear | Removes all entries from the dictionary.
Public method | Clone | Clones this instance.
Public method | ContainsKey | Determines whether the dictionary contains the specified key.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the entry with the specified key from the dictionary.
Public method | ToKeyArray | Returns an array containing all keys.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToValueArray | Returns an array containing all values.
Public method | TryGetValue | Attempts to get a specific value.

Extension Methods

 | Name | Description
Public Extension Method | Convert<(Of <<'(KeyValuePair<(Of <<'(TKey, TValue>)>>), TTo>)>>) | Converts this instance. (Defined by EnumerableExtensions.)
Public Extension Method | StringConcatenate<(Of <<'(KeyValuePair<(Of <<'(TKey, TValue>)>>)>)>>) | Concatenate strings (Defined by IEnumerableExtensions.)

See Also

SafeDictionary<(Of <(<'TKey, TValue>)>)> Class
Sitecore.Collections Namespace


Add Method

[image]

Sitecore 6.4.1 API
SafeDictionary<(Of <(<'TKey, TValue>)>)>..::..Add Method
SafeDictionary<(Of <(<'TKey, TValue>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Add(
    TKey key,
    TValue value
)
Visual Basic
Public Sub Add ( _
    key As TKey, _
    value As TValue _
)
Visual C++
public:
void Add(
    TKey key,
    TValue value
)

Parameters

key
Type: TKey
The key.
value
Type: TValue
The value.

See Also

SafeDictionary<(Of <(<'TKey, TValue>)>)> Class
Sitecore.Collections Namespace


AddRange Method

[image]

Sitecore 6.4.1 API
SafeDictionary<(Of <(<'TKey, TValue>)>)>..::..AddRange Method
SafeDictionary<(Of <(<'TKey, TValue>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddRange(
    SafeDictionary<TKey, TValue> dictionary
)
Visual Basic
Public Sub AddRange ( _
    dictionary As SafeDictionary(Of TKey, TValue) _
)
Visual C++
public:
void AddRange(
    SafeDictionary<TKey, TValue>^ dictionary
)

Parameters

dictionary
Type: Sitecore.Collections..::..SafeDictionary <(Of <(<' TKey, TValue >)>)>
The dictionary.

See Also

SafeDictionary<(Of <(<'TKey, TValue>)>)> Class
Sitecore.Collections Namespace


Clear Method

[image]

Sitecore 6.4.1 API
SafeDictionary<(Of <(<'TKey, TValue>)>)>..::..Clear Method
SafeDictionary<(Of <(<'TKey, TValue>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

SafeDictionary<(Of <(<'TKey, TValue>)>)> Class
Sitecore.Collections Namespace


Clone Method

[image]

Sitecore 6.4.1 API
SafeDictionary<(Of <(<'TKey, TValue>)>)>..::..Clone Method
SafeDictionary<(Of <(<'TKey, TValue>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual SafeDictionary<TKey, TValue> Clone()
Visual Basic
Public Overridable Function Clone As SafeDictionary(Of TKey, TValue)
Visual C++
public:
virtual SafeDictionary<TKey, TValue>^ Clone()

Return Value

[Missing <returns> documentation for "M:Sitecore.Collections.SafeDictionary`2.Clone"]

See Also

SafeDictionary<(Of <(<'TKey, TValue>)>)> Class
Sitecore.Collections Namespace


ContainsKey Method

[image]

Sitecore 6.4.1 API
SafeDictionary<(Of <(<'TKey, TValue>)>)>..::..ContainsKey Method
SafeDictionary<(Of <(<'TKey, TValue>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ContainsKey(
    TKey key
)
Visual Basic
Public Function ContainsKey ( _
    key As TKey _
) As Boolean
Visual C++
public:
bool ContainsKey(
    TKey key
)

Parameters

key
Type: TKey
The key.

Return Value

true if the dictionary contains the specified key; otherwise, false.

See Also

SafeDictionary<(Of <(<'TKey, TValue>)>)> Class
Sitecore.Collections Namespace


GetEnumerator Method

[image]

Sitecore 6.4.1 API
SafeDictionary<(Of <(<'TKey, TValue>)>)>..::..GetEnumerator Method
SafeDictionary<(Of <(<'TKey, TValue>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IEnumerator<KeyValuePair<TKey, TValue>> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of TKey, TValue))
Visual C++
public:
virtual IEnumerator<KeyValuePair<TKey, TValue>>^ GetEnumerator() sealed

Return Value

A IEnumerator<(Of <(<'T>)>)> that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

SafeDictionary<(Of <(<'TKey, TValue>)>)> Class
Sitecore.Collections Namespace


GetObjectData Method

[image]

Sitecore 6.4.1 API
SafeDictionary<(Of <(<'TKey, TValue>)>)>..::..GetObjectData Method
SafeDictionary<(Of <(<'TKey, TValue>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System.Security..::..SecurityException | The caller does not have the required permission.

See Also

SafeDictionary<(Of <(<'TKey, TValue>)>)> Class
Sitecore.Collections Namespace


ToValueArray Method

[image]

Sitecore 6.4.1 API
SafeDictionary<(Of <(<'TKey, TValue>)>)>..::..ToValueArray Method
SafeDictionary<(Of <(<'TKey, TValue>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TValue[] ToValueArray()
Visual Basic
Public Function ToValueArray As TValue()
Visual C++
public:
array<TValue>^ ToValueArray()

Return Value

[Missing <returns> documentation for "M:Sitecore.Collections.SafeDictionary`2.ToValueArray"]

See Also

SafeDictionary<(Of <(<'TKey, TValue>)>)> Class
Sitecore.Collections Namespace


SafeDictionary(TKey, TValue) Properties

[image] [image]

Sitecore 6.4.1 API
SafeDictionary<(Of <(<'TKey, TValue>)>)> Properties
SafeDictionary<(Of <(<'TKey, TValue>)>)> Class See Also Send Feedback

The SafeDictionary<(Of <(<'TKey, TValue>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of entries in the dictionary.
Protected property | Hashtable | Gets the internal hashtable.
Public property | Item | Gets or sets the value with the specified key.
Public property | Keys | Gets the keys of the dictionary.
Public property | ReadOnly | Gets or sets a value indicating whether [read only].
Public property | SyncRoot | Gets the object to use for locking in multi-thread scenarios.
Public property | Values | Gets the values of the dictionary.

See Also

SafeDictionary<(Of <(<'TKey, TValue>)>)> Class
Sitecore.Collections Namespace


Hashtable Property

[image]

Sitecore 6.4.1 API
SafeDictionary<(Of <(<'TKey, TValue>)>)>..::..Hashtable Property
SafeDictionary<(Of <(<'TKey, TValue>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Hashtable Hashtable { get; }
Visual Basic
Protected ReadOnly Property Hashtable As Hashtable
    Get
Visual C++
protected:
property Hashtable^ Hashtable {
    Hashtable^ get ();
}

Field Value

The hashtable.

See Also

SafeDictionary<(Of <(<'TKey, TValue>)>)> Class
Sitecore.Collections Namespace


Item Property

[image]

Sitecore 6.4.1 API
SafeDictionary<(Of <(<'TKey, TValue>)>)>..::..Item Property
SafeDictionary<(Of <(<'TKey, TValue>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual TValue this[
    TKey key
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    key As TKey _
) As TValue
    Get
    Set
Visual C++
public:
virtual property TValue default[TKey key] {
    TValue get (TKey key);
    void set (TKey key, TValue value);
}

Parameters

key
Type: TKey

Field Value

See Also

SafeDictionary<(Of <(<'TKey, TValue>)>)> Class
Sitecore.Collections Namespace


Keys Property

[image]

Sitecore 6.4.1 API
SafeDictionary<(Of <(<'TKey, TValue>)>)>..::..Keys Property
SafeDictionary<(Of <(<'TKey, TValue>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IEnumerable<TKey> Keys { get; }
Visual Basic
Public ReadOnly Property Keys As IEnumerable(Of TKey)
    Get
Visual C++
public:
property IEnumerable<TKey>^ Keys {
    IEnumerable<TKey>^ get ();
}

Field Value

The keys.

See Also

SafeDictionary<(Of <(<'TKey, TValue>)>)> Class
Sitecore.Collections Namespace


ReadOnly Property

[image]

Sitecore 6.4.1 API
SafeDictionary<(Of <(<'TKey, TValue>)>)>..::..ReadOnly Property
SafeDictionary<(Of <(<'TKey, TValue>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool ReadOnly { get; set; }
Visual Basic
Public Overridable Property ReadOnly As Boolean
    Get
    Set
Visual C++
public:
virtual property bool ReadOnly {
    bool get ();
    void set (bool value);
}

Field Value

true if [read only]; otherwise, false.

See Also

SafeDictionary<(Of <(<'TKey, TValue>)>)> Class
Sitecore.Collections Namespace


SyncRoot Property

[image]

Sitecore 6.4.1 API
SafeDictionary<(Of <(<'TKey, TValue>)>)>..::..SyncRoot Property
SafeDictionary<(Of <(<'TKey, TValue>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object SyncRoot { get; }
Visual Basic
Public ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
property Object^ SyncRoot {
    Object^ get ();
}

Field Value

The sync root.

See Also

SafeDictionary<(Of <(<'TKey, TValue>)>)> Class
Sitecore.Collections Namespace


Values Property

[image]

Sitecore 6.4.1 API
SafeDictionary<(Of <(<'TKey, TValue>)>)>..::..Values Property
SafeDictionary<(Of <(<'TKey, TValue>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IEnumerable<TValue> Values { get; }
Visual Basic
Public ReadOnly Property Values As IEnumerable(Of TValue)
    Get
Visual C++
public:
property IEnumerable<TValue>^ Values {
    IEnumerable<TValue>^ get ();
}

Field Value

The values.

See Also

SafeDictionary<(Of <(<'TKey, TValue>)>)> Class
Sitecore.Collections Namespace


Set(T) Class

[image]

Sitecore 6.4.1 API
Set<(Of <(<'T>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Set<T> : IEnumerable<T>, IEnumerable
Visual Basic
Public Class Set(Of T) _
    Implements IEnumerable(Of T), IEnumerable
Visual C++
generic<typename T>
public ref class Set : IEnumerable<T>, IEnumerable

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Sitecore.Collections.Set`1"]

Inheritance Hierarchy

System..::..Object
Sitecore.Collections..::..Set<(Of <(<'T>)>)>

See Also

Set<(Of <(<'T>)>)> Members
Sitecore.Collections Namespace


Set(T) Members

[image] [image]

Sitecore 6.4.1 API
Set<(Of <(<'T>)>)> Members
Set<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The Set<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | Set<(Of <(<'T>)>)>()()()() | Initializes a new instance of the Set<(Of <(<'T>)>)> class.
Public method | Set<(Of <(<'T>)>)>(IEnumerable<(Of <<'(T>)>>)) | Initializes a new instance of the Set<(Of <(<'T>)>)> class.
Public method | Set<(Of <(<'T>)>)>(IEqualityComparer) | Initializes a new instance of the Set<(Of <(<'T>)>)> class.

Methods

 | Name | Description
Public method | Add | Adds the specified value to the set.
Public method | AddRange(IEnumerable<(Of <<'(T>)>>)) | Adds a range of values to the set.
Public method | AddRange(array<T>[]()[][]) | Initializes a new instance of the Set<(Of <(<'T>)>)> class.
Public method | AddRange(IEnumerable<(Of <<'(T>)>>), Func<(Of <<'(T, T>)>>)) | Adds a range of values, converting each value before adding it.
Public method | Clear | Removes all members of the set.
Public method | Contains | Checks if the specified value is contained in the set.
 | Create | Creates a set containing the specified values.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Gets the enumerator.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the specified value.
Public method | ToArray | Converts the members to an array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | Convert<(Of <<'(T, TTo>)>>) | Converts this instance. (Defined by EnumerableExtensions.)
Public Extension Method | StringConcatenate<(Of <<'(T>)>>) | Concatenate strings (Defined by IEnumerableExtensions.)

Properties

 | Name | Description
Public property | Count | Gets the count.
Public property | SyncRoot | Gets the sync root.

See Also

Set<(Of <(<'T>)>)> Class
Sitecore.Collections Namespace


Set(T) Constructor

[image] [image]

Sitecore 6.4.1 API
Set<(Of <(<'T>)>)> Constructor
Set<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Set<(Of <(<'T>)>)>()()()() | Initializes a new instance of the Set<(Of <(<'T>)>)> class.
Public method | Set<(Of <(<'T>)>)>(IEnumerable<(Of <<'(T>)>>)) | Initializes a new instance of the Set<(Of <(<'T>)>)> class.
Public method | Set<(Of <(<'T>)>)>(IEqualityComparer) | Initializes a new instance of the Set<(Of <(<'T>)>)> class.

See Also

Set<(Of <(<'T>)>)> Class
Set<(Of <(<'T>)>)> Members
Sitecore.Collections Namespace


Set(T) Constructor

[image]

Sitecore 6.4.1 API
Set<(Of <(<'T>)>)> Constructor
Set<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Set()
Visual Basic
Public Sub New
Visual C++
public:
Set()

See Also

Set<(Of <(<'T>)>)> Class
Set<(Of <(<'T>)>)> Overload
Sitecore.Collections Namespace


Set(T) Constructor (IEnumerable(T))

[image]

Sitecore 6.4.1 API
Set<(Of <(<'T>)>)> Constructor (IEnumerable<(Of <(<'T>)>)>)
Set<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Set(
    IEnumerable<T> enumerable
)
Visual Basic
Public Sub New ( _
    enumerable As IEnumerable(Of T) _
)
Visual C++
public:
Set(
    IEnumerable<T>^ enumerable
)

Parameters

enumerable
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' T >)>)>

[Missing <param name="enumerable"/> documentation for "M:Sitecore.Collections.Set`1.#ctor(System.Collections.Generic.IEnumerable{`0})"]

See Also

Set<(Of <(<'T>)>)> Class
Set<(Of <(<'T>)>)> Overload
Sitecore.Collections Namespace


Set(T) Constructor (IEqualityComparer)

[image]

Sitecore 6.4.1 API
Set<(Of <(<'T>)>)> Constructor (IEqualityComparer)
Set<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Set(
    IEqualityComparer comparer
)
Visual Basic
Public Sub New ( _
    comparer As IEqualityComparer _
)
Visual C++
public:
Set(
    IEqualityComparer^ comparer
)

Parameters

comparer
Type: System.Collections..::..IEqualityComparer

[Missing <param name="comparer"/> documentation for "M:Sitecore.Collections.Set`1.#ctor(System.Collections.IEqualityComparer)"]

See Also

Set<(Of <(<'T>)>)> Class
Set<(Of <(<'T>)>)> Overload
Sitecore.Collections Namespace


Set(T) Methods

[image] [image]

Sitecore 6.4.1 API
Set<(Of <(<'T>)>)> Methods
Set<(Of <(<'T>)>)> Class See Also Send Feedback

The Set<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified value to the set.
Public method | AddRange(IEnumerable<(Of <<'(T>)>>)) | Adds a range of values to the set.
Public method | AddRange(array<T>[]()[][]) | Initializes a new instance of the Set<(Of <(<'T>)>)> class.
Public method | AddRange(IEnumerable<(Of <<'(T>)>>), Func<(Of <<'(T, T>)>>)) | Adds a range of values, converting each value before adding it.
Public method | Clear | Removes all members of the set.
Public method | Contains | Checks if the specified value is contained in the set.
 | Create | Creates a set containing the specified values.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Gets the enumerator.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the specified value.
Public method | ToArray | Converts the members to an array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | Convert<(Of <<'(T, TTo>)>>) | Converts this instance. (Defined by EnumerableExtensions.)
Public Extension Method | StringConcatenate<(Of <<'(T>)>>) | Concatenate strings (Defined by IEnumerableExtensions.)

See Also

Set<(Of <(<'T>)>)> Class
Sitecore.Collections Namespace


Add Method

[image]

Sitecore 6.4.1 API
Set<(Of <(<'T>)>)>..::..Add Method
Set<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Add(
    T value
)
Visual Basic
Public Sub Add ( _
    value As T _
)
Visual C++
public:
void Add(
    T value
)

Parameters

value
Type: T
The value.

See Also

Set<(Of <(<'T>)>)> Class
Sitecore.Collections Namespace


AddRange Method

[image] [image]

Sitecore 6.4.1 API
Set<(Of <(<'T>)>)>..::..AddRange Method
Set<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddRange(IEnumerable<(Of <<'(T>)>>)) | Adds a range of values to the set.
Public method | AddRange(array<T>[]()[][]) | Initializes a new instance of the Set<(Of <(<'T>)>)> class.
Public method | AddRange(IEnumerable<(Of <<'(T>)>>), Func<(Of <<'(T, T>)>>)) | Adds a range of values, converting each value before adding it.

See Also

Set<(Of <(<'T>)>)> Class
Set<(Of <(<'T>)>)> Members
Sitecore.Collections Namespace


AddRange Method (IEnumerable(T))

[image]

Sitecore 6.4.1 API
Set<(Of <(<'T>)>)>..::..AddRange Method (IEnumerable<(Of <(<'T>)>)>)
Set<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddRange(
    IEnumerable<T> values
)
Visual Basic
Public Sub AddRange ( _
    values As IEnumerable(Of T) _
)
Visual C++
public:
void AddRange(
    IEnumerable<T>^ values
)

Parameters

values
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' T >)>)>
The values.

See Also

Set<(Of <(<'T>)>)> Class
AddRange Overload
Sitecore.Collections Namespace


AddRange Method (T[])

[image]

Sitecore 6.4.1 API
Set<(Of <(<'T>)>)>..::..AddRange Method (array<T>[]()[][])
Set<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddRange(
    params T[] members
)
Visual Basic
Public Sub AddRange ( _
    ParamArray members As T() _
)
Visual C++
public:
void AddRange(
    ... array<T>^ members
)

Parameters

members
Type: array< T >[]()[][]

[Missing <param name="members"/> documentation for "M:Sitecore.Collections.Set`1.AddRange(`0[])"]

See Also

Set<(Of <(<'T>)>)> Class
AddRange Overload
Sitecore.Collections Namespace


AddRange Method (IEnumerable(T), Func(T, T))

[image]

Sitecore 6.4.1 API
Set<(Of <(<'T>)>)>..::..AddRange Method (IEnumerable<(Of <(<'T>)>)>, Func<(Of <(<'T, T>)>)>)
Set<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddRange(
    IEnumerable<T> values,
    Func<T, T> convert
)
Visual Basic
Public Sub AddRange ( _
    values As IEnumerable(Of T), _
    convert As Func(Of T, T) _
)
Visual C++
public:
void AddRange(
    IEnumerable<T>^ values,
    Func<T, T>^ convert
)

Parameters

values
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' T >)>)>
The values.
convert
Type: System..::..Func <(Of <(<' T, T >)>)>
The converter method.

See Also

Set<(Of <(<'T>)>)> Class
AddRange Overload
Sitecore.Collections Namespace


Clear Method

[image]

Sitecore 6.4.1 API
Set<(Of <(<'T>)>)>..::..Clear Method
Set<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

Set<(Of <(<'T>)>)> Class
Sitecore.Collections Namespace


Contains Method

[image]

Sitecore 6.4.1 API
Set<(Of <(<'T>)>)>..::..Contains Method
Set<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Contains(
    T value
)
Visual Basic
Public Function Contains ( _
    value As T _
) As Boolean
Visual C++
public:
bool Contains(
    T value
)

Parameters

value
Type: T
The value.

Return Value

[Missing <returns> documentation for "M:Sitecore.Collections.Set`1.Contains(`0)"]

See Also

Set<(Of <(<'T>)>)> Class
Sitecore.Collections Namespace


Create Method

[image]

Sitecore 6.4.1 API
Set<(Of <(<'T>)>)>..::..Create Method
Set<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Set<T> Create(
    params T[] values
)
Visual Basic
Public Shared Function Create ( _
    ParamArray values As T() _
) As Set(Of T)
Visual C++
public:
static Set<T>^ Create(
    ... array<T>^ values
)

Parameters

values
Type: array< T >[]()[][]
The values.

Return Value

[Missing <returns> documentation for "M:Sitecore.Collections.Set`1.Create(`0[])"]

See Also

Set<(Of <(<'T>)>)> Class
Sitecore.Collections Namespace


GetEnumerator Method

[image]

Sitecore 6.4.1 API
Set<(Of <(<'T>)>)>..::..GetEnumerator Method
Set<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IEnumerator<T> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of T)
Visual C++
public:
virtual IEnumerator<T>^ GetEnumerator() sealed

Return Value

The enumerator.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

Set<(Of <(<'T>)>)> Class
Sitecore.Collections Namespace


ToArray Method

[image]

Sitecore 6.4.1 API
Set<(Of <(<'T>)>)>..::..ToArray Method
Set<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public T[] ToArray()
Visual Basic
Public Function ToArray As T()
Visual C++
public:
array<T>^ ToArray()

Return Value

[Missing <returns> documentation for "M:Sitecore.Collections.Set`1.ToArray"]

See Also

Set<(Of <(<'T>)>)> Class
Sitecore.Collections Namespace


Set(T) Properties

[image] [image]

Sitecore 6.4.1 API
Set<(Of <(<'T>)>)> Properties
Set<(Of <(<'T>)>)> Class See Also Send Feedback

The Set<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the count.
Public property | SyncRoot | Gets the sync root.

See Also

Set<(Of <(<'T>)>)> Class
Sitecore.Collections Namespace


Count Property

[image]

Sitecore 6.4.1 API
Set<(Of <(<'T>)>)>..::..Count Property
Set<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
property int Count {
    int get ();
}

Field Value

The count.

See Also

Set<(Of <(<'T>)>)> Class
Sitecore.Collections Namespace


SyncRoot Property

[image]

Sitecore 6.4.1 API
Set<(Of <(<'T>)>)>..::..SyncRoot Property
Set<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object SyncRoot { get; }
Visual Basic
Public ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
property Object^ SyncRoot {
    Object^ get ();
}

Field Value

The sync root.

See Also

Set<(Of <(<'T>)>)> Class
Sitecore.Collections Namespace


StringDictionary Class

[image]

Sitecore 6.4.1 API
StringDictionary Class
Members See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class StringDictionary : SafeDictionary<string, string>
Visual Basic
<SerializableAttribute> _
Public Class StringDictionary _
    Inherits SafeDictionary(Of String, String)
Visual C++
[SerializableAttribute]
public ref class StringDictionary : public SafeDictionary<String^, String^>

Inheritance Hierarchy

System..::..Object
Sitecore.Collections..::..SafeDictionary <(Of <(<' String, String >)>)>
Sitecore.Collections..::..StringDictionary
Sitecore.Web.UI.WebControls..::..AjaxScriptManager..::..StateBag
Sitecore.Web.UI.XamlSharp.Xaml..::..ChildCreator..::..SymbolStackFrame

See Also

StringDictionary Members
Sitecore.Collections Namespace


StringDictionary Members

[image] [image]

Sitecore 6.4.1 API
StringDictionary Members
StringDictionary Class Constructors Methods Properties See Also Send Feedback

The StringDictionary type exposes the following members.

Constructors

 | Name | Description
Public method | StringDictionary()()()() | Initializes a new instance of the StringDictionary class.
Public method | StringDictionary(IEnumerable<(Of <<'(KeyValuePair<(Of <<'(String, String>)>>)>)>>)) | Initializes a new instance of the StringDictionary class.
Public method | StringDictionary(IEqualityComparer) | Initializes a new instance of the StringDictionary class.
Protected method | StringDictionary(SerializationInfo, StreamingContext) | Initializes a new instance of the SafeDictionary class.

Methods

 | Name | Description
Public method | Add | Adds the specified key/value pair to the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | AddRange | Adds a range of key/values. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | Clear | Removes all entries from the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | Clone | Clones this instance. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | ContainsKey | Determines whether the dictionary contains the specified key. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the entry with the specified key from the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | ToKeyArray | Returns an array containing all keys. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | ToNameValueCollection | Converts the dictionary to a NameValueCollection.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToValueArray | Returns an array containing all values. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | TryGetValue | Attempts to get a specific value. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)

Properties

 | Name | Description
Public property | Count | Gets the number of entries in the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Protected property | Hashtable | Gets the internal hashtable. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | Item | Gets or sets the value with the specified key. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | Keys | Gets the keys of the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | ReadOnly | Gets or sets a value indicating whether [read only]. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | SyncRoot | Gets the object to use for locking in multi-thread scenarios. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | Values | Gets the values of the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)

See Also

StringDictionary Class
Sitecore.Collections Namespace


StringDictionary Constructor

[image]

Sitecore 6.4.1 API
StringDictionary Constructor
StringDictionary Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StringDictionary()
Visual Basic
Public Sub New
Visual C++
public:
StringDictionary()

See Also

StringDictionary Class
StringDictionary Overload
Sitecore.Collections Namespace


StringDictionary Constructor (IEnumerable(KeyValuePair(String, String)))

[image]

Sitecore 6.4.1 API
StringDictionary Constructor (IEnumerable<(Of <(<'KeyValuePair<(Of <(<'String, String>)>)>>)>)>)
StringDictionary Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StringDictionary(
    IEnumerable<KeyValuePair<string, string>> values
)
Visual Basic
Public Sub New ( _
    values As IEnumerable(Of KeyValuePair(Of String, String)) _
)
Visual C++
public:
StringDictionary(
    IEnumerable<KeyValuePair<String^, String^>>^ values
)

Parameters

values
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' KeyValuePair <(Of <(<' String, String >)>)>>)>)>

[Missing <param name="values"/> documentation for "M:Sitecore.Collections.StringDictionary.#ctor(System.Collections.Generic.IEnumerable{System.Collections.Generic.KeyValuePair{System.String,System.String}})"]

See Also

StringDictionary Class
StringDictionary Overload
Sitecore.Collections Namespace


StringDictionary Constructor (IEqualityComparer)

[image]

Sitecore 6.4.1 API
StringDictionary Constructor (IEqualityComparer)
StringDictionary Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StringDictionary(
    IEqualityComparer comparer
)
Visual Basic
Public Sub New ( _
    comparer As IEqualityComparer _
)
Visual C++
public:
StringDictionary(
    IEqualityComparer^ comparer
)

Parameters

comparer
Type: System.Collections..::..IEqualityComparer

[Missing <param name="comparer"/> documentation for "M:Sitecore.Collections.StringDictionary.#ctor(System.Collections.IEqualityComparer)"]

See Also

StringDictionary Class
StringDictionary Overload
Sitecore.Collections Namespace


StringDictionary Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
StringDictionary Constructor (SerializationInfo, StreamingContext)
StringDictionary Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected StringDictionary(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
StringDictionary(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
A SerializationInfo object containing the information required to serialize the Dictionary<(Of <(<'TKey, TValue>)>)>.
context
Type: System.Runtime.Serialization..::..StreamingContext
A StreamingContext structure containing the source and destination of the serialized stream associated with the Dictionary<(Of <(<'TKey, TValue>)>)>.

See Also

StringDictionary Class
StringDictionary Overload
Sitecore.Collections Namespace


StringDictionary Methods

[image] [image]

Sitecore 6.4.1 API
StringDictionary Methods
StringDictionary Class See Also Send Feedback

The StringDictionary type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key/value pair to the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | AddRange | Adds a range of key/values. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | Clear | Removes all entries from the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | Clone | Clones this instance. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | ContainsKey | Determines whether the dictionary contains the specified key. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the entry with the specified key from the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | ToKeyArray | Returns an array containing all keys. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | ToNameValueCollection | Converts the dictionary to a NameValueCollection.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToValueArray | Returns an array containing all values. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | TryGetValue | Attempts to get a specific value. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)

See Also

StringDictionary Class
Sitecore.Collections Namespace


ToNameValueCollection Method

[image]

Sitecore 6.4.1 API
StringDictionary..::..ToNameValueCollection Method
StringDictionary Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public NameValueCollection ToNameValueCollection()
Visual Basic
Public Function ToNameValueCollection As NameValueCollection
Visual C++
public:
NameValueCollection^ ToNameValueCollection()

Return Value

[Missing <returns> documentation for "M:Sitecore.Collections.StringDictionary.ToNameValueCollection"]

See Also

StringDictionary Class
Sitecore.Collections Namespace


StringDictionary Properties

[image] [image]

Sitecore 6.4.1 API
StringDictionary Properties
StringDictionary Class See Also Send Feedback

The StringDictionary type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of entries in the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Protected property | Hashtable | Gets the internal hashtable. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | Item | Gets or sets the value with the specified key. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | Keys | Gets the keys of the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | ReadOnly | Gets or sets a value indicating whether [read only]. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | SyncRoot | Gets the object to use for locking in multi-thread scenarios. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | Values | Gets the values of the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)

See Also

StringDictionary Class
Sitecore.Collections Namespace


StringHashtable Class

[image]

Sitecore 6.4.1 API
StringHashtable Class
Members Example See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class StringHashtable
Visual Basic
Public Class StringHashtable
Visual C++
public ref class StringHashtable

Examples

CopyC#
StringHashtable table = new StringHashtable();
table["myKey"] = "Hello world";
int count = table.Count; // 1
string myValue = table["myKey"]; // "Hello world"

Inheritance Hierarchy

System..::..Object
Sitecore.Collections..::..StringHashtable

See Also

StringHashtable Members
Sitecore.Collections Namespace


StringHashtable Members

[image] [image]

Sitecore 6.4.1 API
StringHashtable Members
StringHashtable Class Constructors Methods Properties See Also Send Feedback

The StringHashtable type exposes the following members.

Constructors

 | Name | Description
Public method | StringHashtable | Initializes a new instance of the StringHashtable class

Methods

 | Name | Description
Public method | Add(StringHashtable) | Adds a StringHashtable to the table.
Public method | Add(String, String) | Adds a string to the table.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of strings in the table.
Public property | Item | Gets or sets a string by its key.

See Also

StringHashtable Class
Sitecore.Collections Namespace


StringHashtable Constructor

[image]

Sitecore 6.4.1 API
StringHashtable Constructor
StringHashtable Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StringHashtable()
Visual Basic
Public Sub New
Visual C++
public:
StringHashtable()

See Also

StringHashtable Class
Sitecore.Collections Namespace


StringHashtable Methods

[image] [image]

Sitecore 6.4.1 API
StringHashtable Methods
StringHashtable Class See Also Send Feedback

The StringHashtable type exposes the following members.

Methods

 | Name | Description
Public method | Add(StringHashtable) | Adds a StringHashtable to the table.
Public method | Add(String, String) | Adds a string to the table.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StringHashtable Class
Sitecore.Collections Namespace


Add Method

[image] [image]

Sitecore 6.4.1 API
StringHashtable..::..Add Method
StringHashtable Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(StringHashtable) | Adds a StringHashtable to the table.
Public method | Add(String, String) | Adds a string to the table.

See Also

StringHashtable Class
StringHashtable Members
Sitecore.Collections Namespace


Add Method (StringHashtable)

[image]

Sitecore 6.4.1 API
StringHashtable..::..Add Method (StringHashtable)
StringHashtable Class Example See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Add(
    StringHashtable hash
)
Visual Basic
Public Sub Add ( _
    hash As StringHashtable _
)
Visual C++
public:
void Add(
    StringHashtable^ hash
)

Parameters

hash
Type: Sitecore.Collections..::..StringHashtable
A StringHashtable.

Remarks

Each key/value pair is added to the table. If the tables contain values with the same key, an exception is thrown.

Examples

CopyC#
StringHashtable table1 = new StringHashtable();
table1.Add("myKey", "Hello world");
StringHashtable table2 = new StringHashtable();
table2.Add(table1);

See Also

StringHashtable Class
Add Overload
Sitecore.Collections Namespace


StringHashtable Properties

[image] [image]

Sitecore 6.4.1 API
StringHashtable Properties
StringHashtable Class See Also Send Feedback

The StringHashtable type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of strings in the table.
Public property | Item | Gets or sets a string by its key.

See Also

StringHashtable Class
Sitecore.Collections Namespace


Count Property

[image]

Sitecore 6.4.1 API
StringHashtable..::..Count Property
StringHashtable Class Example See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
property int Count {
    int get ();
}

Field Value

The number of strings in the table.

Examples

CopyC#
StringHashtable table = new StringHashtable();
table["myKey"] = "Hello world";
int count = table.Count; // 1

See Also

StringHashtable Class
Sitecore.Collections Namespace


Item Property

[image]

Sitecore 6.4.1 API
StringHashtable..::..Item Property
StringHashtable Class Example See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string this[
    string sKey
] { get; set; }
Visual Basic
Public Default Property Item ( _
    sKey As String _
) As String
    Get
    Set
Visual C++
public:
property String^ default[String^ sKey] {
    String^ get (String^ sKey);
    void set (String^ sKey, String^ value);
}

Parameters

sKey
Type: System..::..String

Field Value

The string identified by the key.

Remarks

Any null values are converted to blanks.

Examples

CopyC#
StringHashtable table = new StringHashtable();
table["myKey"] = "Hello world";

See Also

StringHashtable Class
Sitecore.Collections Namespace


StringList Class

[image]

Sitecore 6.4.1 API
StringList Class
Members See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class StringList : List<string>
Visual Basic
Public Class StringList _
    Inherits List(Of String)
Visual C++
public ref class StringList : public List<String^>

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' String >)>)>
Sitecore.Collections..::..StringList

See Also

StringList Members
Sitecore.Collections Namespace


StringList Constructor

[image] [image]

Sitecore 6.4.1 API
StringList Constructor
StringList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StringList()()()() | Initializes a new instance of the StringList class.
Public method | StringList(IEnumerable<(Of <<'(String>)>>)) | Initializes a new instance of the StringList class.
Public method | StringList(String) | Initializes a new instance of the StringList class.

See Also

StringList Class
StringList Members
Sitecore.Collections Namespace


StringList Constructor (IEnumerable(String))

[image]

Sitecore 6.4.1 API
StringList Constructor (IEnumerable<(Of <(<'String>)>)>)
StringList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StringList(
    IEnumerable<string> values
)
Visual Basic
Public Sub New ( _
    values As IEnumerable(Of String) _
)
Visual C++
public:
StringList(
    IEnumerable<String^>^ values
)

Parameters

values
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' String >)>)>
The values.

See Also

StringList Class
StringList Overload
Sitecore.Collections Namespace


StringList Constructor (String)

[image]

Sitecore 6.4.1 API
StringList Constructor (String)
StringList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StringList(
    string value
)
Visual Basic
Public Sub New ( _
    value As String _
)
Visual C++
public:
StringList(
    String^ value
)

Parameters

value
Type: System..::..String
A value to add.

See Also

StringList Class
StringList Overload
Sitecore.Collections Namespace


StringList Methods

[image] [image]

Sitecore 6.4.1 API
StringList Methods
StringList Class See Also Send Feedback

The StringList type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | AddRange | Adds the elements of the specified collection to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | AppendToFile | Appends the list to a file.
Public method | AsReadOnly | Returns a read-only IList<(Of <(<'T>)>)> wrapper for the current collection. (Inherited from List <(Of <(<' String >)>)>.)
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' String >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' String >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Clear | Removes all elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Contains | Determines whether an element is in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | Converts the elements in the current List<(Of <(<'T>)>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of <(<' String >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' String >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' String >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the List<(Of <(<'T>)>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' String >)>)>.)
Public method | ExtractDictionary | Extracts a dictionary.
Public method | ExtractRecord | Extracts a single record.
Public method | ExtractSection | Extracts a section from a record.
Public method | ExtractSingleValue | Extracts a single value from a record.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' String >)>)>.)
Public method | ForEach | Performs the specified action on each element of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
 | FromFile | Instantiate a list from a file.
Public method | GetEnumerator | Returns an enumerator that iterates through the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' String >)>)>.)
Public method | IndexOf(String, StringComparison) | Get the index of a specific value.
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Insert | Inserts an element into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' String >)>)>.)
Public method | InsertRange | Inserts the elements of a collection into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' String >)>)>.)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' String >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' String >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadFromFile | Reads the list from a file.
Public method | Remove | Removes the first occurrence of a specific object from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' String >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | RemoveRange | Removes a range of elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' String >)>)>.)
Public method | ToArray | Copies the elements of the List<(Of <(<'T>)>)> to a new array. (Inherited from List <(Of <(<' String >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(<'T>)>)>, if that number is less than a threshold value. (Inherited from List <(Of <(<' String >)>)>.)
Public method | TrueForAll | Determines whether every element in the List<(Of <(<'T>)>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of <(<' String >)>)>.)
Public method | WriteToFile | Writes the list to a file.

See Also

StringList Class
Sitecore.Collections Namespace


AppendToFile Method

[image]

Sitecore 6.4.1 API
StringList..::..AppendToFile Method
StringList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AppendToFile(
    string filePath
)
Visual Basic
Public Sub AppendToFile ( _
    filePath As String _
)
Visual C++
public:
void AppendToFile(
    String^ filePath
)

Parameters

filePath
Type: System..::..String
The file path.

See Also

StringList Class
Sitecore.Collections Namespace


BinarySearch Method

[image] [image]

Sitecore 6.4.1 API
StringList..::..BinarySearch Method
StringList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' String >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' String >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' String >)>)>.)

See Also

StringList Class
StringList Members
Sitecore.Collections Namespace


CopyTo Method

[image] [image]

Sitecore 6.4.1 API
StringList..::..CopyTo Method
StringList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' String >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' String >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' String >)>)>.)

See Also

StringList Class
StringList Members
Sitecore.Collections Namespace


ExtractDictionary Method

[image]

Sitecore 6.4.1 API
StringList..::..ExtractDictionary Method
StringList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StringDictionary ExtractDictionary(
    string sectionName,
    string separator
)
Visual Basic
Public Function ExtractDictionary ( _
    sectionName As String, _
    separator As String _
) As StringDictionary
Visual C++
public:
StringDictionary^ ExtractDictionary(
    String^ sectionName,
    String^ separator
)

Parameters

sectionName
Type: System..::..String
Name of the section.
separator
Type: System..::..String
The key/value separator.

Return Value

[Missing <returns> documentation for "M:Sitecore.Collections.StringList.ExtractDictionary(System.String,System.String)"]

See Also

StringList Class
Sitecore.Collections Namespace


ExtractRecord Method

[image]

Sitecore 6.4.1 API
StringList..::..ExtractRecord Method
StringList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StringList ExtractRecord(
    string key
)
Visual Basic
Public Function ExtractRecord ( _
    key As String _
) As StringList
Visual C++
public:
StringList^ ExtractRecord(
    String^ key
)

Parameters

key
Type: System..::..String
The key.

Return Value

[Missing <returns> documentation for "M:Sitecore.Collections.StringList.ExtractRecord(System.String)"]

See Also

StringList Class
Sitecore.Collections Namespace


ExtractSection Method

[image]

Sitecore 6.4.1 API
StringList..::..ExtractSection Method
StringList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StringList ExtractSection(
    string name
)
Visual Basic
Public Function ExtractSection ( _
    name As String _
) As StringList
Visual C++
public:
StringList^ ExtractSection(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

Return Value

[Missing <returns> documentation for "M:Sitecore.Collections.StringList.ExtractSection(System.String)"]

See Also

StringList Class
Sitecore.Collections Namespace


ExtractSingleValue Method

[image]

Sitecore 6.4.1 API
StringList..::..ExtractSingleValue Method
StringList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ExtractSingleValue(
    string sectionName
)
Visual Basic
Public Function ExtractSingleValue ( _
    sectionName As String _
) As String
Visual C++
public:
String^ ExtractSingleValue(
    String^ sectionName
)

Parameters

sectionName
Type: System..::..String
Name of the section.

Return Value

[Missing <returns> documentation for "M:Sitecore.Collections.StringList.ExtractSingleValue(System.String)"]

See Also

StringList Class
Sitecore.Collections Namespace


FindLastIndex Method

[image] [image]

Sitecore 6.4.1 API
StringList..::..FindLastIndex Method
StringList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' String >)>)>.)

See Also

StringList Class
StringList Members
Sitecore.Collections Namespace


FromFile Method

[image]

Sitecore 6.4.1 API
StringList..::..FromFile Method
StringList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static StringList FromFile(
    string fileName
)
Visual Basic
Public Shared Function FromFile ( _
    fileName As String _
) As StringList
Visual C++
public:
static StringList^ FromFile(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
Name of the file.

Return Value

[Missing <returns> documentation for "M:Sitecore.Collections.StringList.FromFile(System.String)"]

See Also

StringList Class
Sitecore.Collections Namespace


IndexOf Method

[image] [image]

Sitecore 6.4.1 API
StringList..::..IndexOf Method
StringList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' String >)>)>.)
Public method | IndexOf(String, StringComparison) | Get the index of a specific value.
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' String >)>)>.)

See Also

StringList Class
StringList Members
Sitecore.Collections Namespace


IndexOf Method (String, StringComparison)

[image]

Sitecore 6.4.1 API
StringList..::..IndexOf Method (String, StringComparison)
StringList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int IndexOf(
    string value,
    StringComparison comparison
)
Visual Basic
Public Function IndexOf ( _
    value As String, _
    comparison As StringComparison _
) As Integer
Visual C++
public:
int IndexOf(
    String^ value,
    StringComparison comparison
)

Parameters

value
Type: System..::..String
The value.
comparison
Type: System..::..StringComparison
The comparison.

Return Value

[Missing <returns> documentation for "M:Sitecore.Collections.StringList.IndexOf(System.String,System.StringComparison)"]

See Also

StringList Class
IndexOf Overload
Sitecore.Collections Namespace


LastIndexOf Method

[image] [image]

Sitecore 6.4.1 API
StringList..::..LastIndexOf Method
StringList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' String >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' String >)>)>.)

See Also

StringList Class
StringList Members
Sitecore.Collections Namespace


ReadFromFile Method

[image]

Sitecore 6.4.1 API
StringList..::..ReadFromFile Method
StringList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void ReadFromFile(
    string filePath
)
Visual Basic
Public Sub ReadFromFile ( _
    filePath As String _
)
Visual C++
public:
void ReadFromFile(
    String^ filePath
)

Parameters

filePath
Type: System..::..String
The file path.

See Also

StringList Class
Sitecore.Collections Namespace


Reverse Method

[image] [image]

Sitecore 6.4.1 API
StringList..::..Reverse Method
StringList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' String >)>)>.)

See Also

StringList Class
StringList Members
Sitecore.Collections Namespace


Sort Method

[image] [image]

Sitecore 6.4.1 API
StringList..::..Sort Method
StringList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' String >)>)>.)

See Also

StringList Class
StringList Members
Sitecore.Collections Namespace


ToString Method

[image]

Sitecore 6.4.1 API
StringList..::..ToString Method
StringList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

StringList Class
Sitecore.Collections Namespace


WriteToFile Method

[image]

Sitecore 6.4.1 API
StringList..::..WriteToFile Method
StringList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void WriteToFile(
    string filePath
)
Visual Basic
Public Sub WriteToFile ( _
    filePath As String _
)
Visual C++
public:
void WriteToFile(
    String^ filePath
)

Parameters

filePath
Type: System..::..String
The file path.

See Also

StringList Class
Sitecore.Collections Namespace


StringList Properties

[image] [image]

Sitecore 6.4.1 API
StringList Properties
StringList Class See Also Send Feedback

The StringList type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <(<' String >)>)>.)
Public property | Count | Gets the number of elements actually contained in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
 | Empty | Gets the empty.
Public property | Item | Gets or sets the element at the specified index. (Inherited from List <(Of <(<' String >)>)>.)

See Also

StringList Class
Sitecore.Collections Namespace


Empty Property

[image]

Sitecore 6.4.1 API
StringList..::..Empty Property
StringList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static StringList Empty { get; }
Visual Basic
Public Shared ReadOnly Property Empty As StringList
    Get
Visual C++
public:
static property StringList^ Empty {
    StringList^ get ();
}

Field Value

The empty.

See Also

StringList Class
Sitecore.Collections Namespace


TemplateDictionary Class

[image]

Sitecore 6.4.1 API
TemplateDictionary Class
Members See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class TemplateDictionary : SafeDictionary<ID, Template>
Visual Basic
<SerializableAttribute> _
Public Class TemplateDictionary _
    Inherits SafeDictionary(Of ID, Template)
Visual C++
[SerializableAttribute]
public ref class TemplateDictionary : public SafeDictionary<ID^, Template^>

Inheritance Hierarchy

System..::..Object
Sitecore.Collections..::..SafeDictionary <(Of <(<' ID, Template >)>)>
Sitecore.Collections..::..TemplateDictionary

See Also

TemplateDictionary Members
Sitecore.Collections Namespace


TemplateDictionary Members

[image] [image]

Sitecore 6.4.1 API
TemplateDictionary Members
TemplateDictionary Class Constructors Methods Properties See Also Send Feedback

The TemplateDictionary type exposes the following members.

Constructors

 | Name | Description
Public method | TemplateDictionary()()()() | Initializes a new instance of the TemplateDictionary class.
Public method | TemplateDictionary(IEqualityComparer) | Initializes a new instance of the TemplateDictionary class.
Protected method | TemplateDictionary(SerializationInfo, StreamingContext) | Initializes a new instance of the TemplateDictionary class.

Methods

 | Name | Description
Public method | Add | Adds the specified key/value pair to the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | AddRange | Adds a range of key/values. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | Clear | Removes all entries from the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | Clone | Creates a shallow copy of the collection.
Public method | ContainsKey | Determines whether the dictionary contains the specified key. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | CopyTo | Copies the templates to an array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the entry with the specified key from the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | ToKeyArray | Returns an array containing all keys. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToValueArray | Returns an array containing all values. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | TryGetValue | Attempts to get a specific value. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)

Properties

 | Name | Description
Public property | Count | Gets the number of entries in the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Protected property | Hashtable | Gets the internal hashtable. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | Item[([( TKey])]) | Gets or sets the value with the specified key. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | Item[([( String])]) | Gets the Template with the specified full name.
Public property | Keys | Gets the keys of the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | ReadOnly | Gets or sets a value indicating whether [read only]. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | SyncRoot | Gets the object to use for locking in multi-thread scenarios. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | Values | Gets the values of the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)

See Also

TemplateDictionary Class
Sitecore.Collections Namespace


TemplateDictionary Constructor

[image] [image]

Sitecore 6.4.1 API
TemplateDictionary Constructor
TemplateDictionary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TemplateDictionary()()()() | Initializes a new instance of the TemplateDictionary class.
Public method | TemplateDictionary(IEqualityComparer) | Initializes a new instance of the TemplateDictionary class.
Protected method | TemplateDictionary(SerializationInfo, StreamingContext) | Initializes a new instance of the TemplateDictionary class.

See Also

TemplateDictionary Class
TemplateDictionary Members
Sitecore.Collections Namespace


TemplateDictionary Constructor

[image]

Sitecore 6.4.1 API
TemplateDictionary Constructor
TemplateDictionary Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateDictionary()
Visual Basic
Public Sub New
Visual C++
public:
TemplateDictionary()

See Also

TemplateDictionary Class
TemplateDictionary Overload
Sitecore.Collections Namespace


TemplateDictionary Constructor (IEqualityComparer)

[image]

Sitecore 6.4.1 API
TemplateDictionary Constructor (IEqualityComparer)
TemplateDictionary Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateDictionary(
    IEqualityComparer comparer
)
Visual Basic
Public Sub New ( _
    comparer As IEqualityComparer _
)
Visual C++
public:
TemplateDictionary(
    IEqualityComparer^ comparer
)

Parameters

comparer
Type: System.Collections..::..IEqualityComparer
The comparer.

See Also

TemplateDictionary Class
TemplateDictionary Overload
Sitecore.Collections Namespace


TemplateDictionary Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
TemplateDictionary Constructor (SerializationInfo, StreamingContext)
TemplateDictionary Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected TemplateDictionary(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
TemplateDictionary(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

TemplateDictionary Class
TemplateDictionary Overload
Sitecore.Collections Namespace


TemplateDictionary Methods

[image] [image]

Sitecore 6.4.1 API
TemplateDictionary Methods
TemplateDictionary Class See Also Send Feedback

The TemplateDictionary type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key/value pair to the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | AddRange | Adds a range of key/values. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | Clear | Removes all entries from the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | Clone | Creates a shallow copy of the collection.
Public method | ContainsKey | Determines whether the dictionary contains the specified key. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | CopyTo | Copies the templates to an array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the entry with the specified key from the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | ToKeyArray | Returns an array containing all keys. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToValueArray | Returns an array containing all values. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public method | TryGetValue | Attempts to get a specific value. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)

See Also

TemplateDictionary Class
Sitecore.Collections Namespace


Clone Method

[image]

Sitecore 6.4.1 API
TemplateDictionary..::..Clone Method
TemplateDictionary Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateDictionary Clone()
Visual Basic
Public Function Clone As TemplateDictionary
Visual C++
public:
TemplateDictionary^ Clone()

Return Value

[Missing <returns> documentation for "M:Sitecore.Collections.TemplateDictionary.Clone"]

See Also

TemplateDictionary Class
Sitecore.Collections Namespace


CopyTo Method

[image]

Sitecore 6.4.1 API
TemplateDictionary..::..CopyTo Method
TemplateDictionary Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void CopyTo(
    Template[] array,
    int index
)
Visual Basic
Public Sub CopyTo ( _
    array As Template(), _
    index As Integer _
)
Visual C++
public:
void CopyTo(
    array<Template^>^ array,
    int index
)

Parameters

array
Type: array< Sitecore.Data.Templates..::..Template >[]()[][]
The array.
index
Type: System..::..Int32
The target index.

See Also

TemplateDictionary Class
Sitecore.Collections Namespace


TemplateDictionary Properties

[image] [image]

Sitecore 6.4.1 API
TemplateDictionary Properties
TemplateDictionary Class See Also Send Feedback

The TemplateDictionary type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of entries in the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Protected property | Hashtable | Gets the internal hashtable. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | Item[([( TKey])]) | Gets or sets the value with the specified key. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | Item[([( String])]) | Gets the Template with the specified full name.
Public property | Keys | Gets the keys of the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | ReadOnly | Gets or sets a value indicating whether [read only]. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | SyncRoot | Gets the object to use for locking in multi-thread scenarios. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | Values | Gets the values of the dictionary. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)

See Also

TemplateDictionary Class
Sitecore.Collections Namespace


Item Property

[image] [image]

Sitecore 6.4.1 API
TemplateDictionary..::..Item Property
TemplateDictionary Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( TKey])]) | Gets or sets the value with the specified key. (Inherited from SafeDictionary<(Of <(<'TKey, TValue>)>)>.)
Public property | Item[([( String])]) | Gets the Template with the specified full name.

See Also

TemplateDictionary Class
TemplateDictionary Members
Sitecore.Collections Namespace


Item Property (String)

[image]

Sitecore 6.4.1 API
TemplateDictionary..::..Item Property (String)
TemplateDictionary Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Template this[
    string fullName
] { get; }
Visual Basic
Public Overridable ReadOnly Default Property Item ( _
    fullName As String _
) As Template
    Get
Visual C++
public:
virtual property Template^ default[String^ fullName] {
    Template^ get (String^ fullName);
}

Parameters

fullName
Type: System..::..String

Field Value

See Also

TemplateDictionary Class
Item Overload
Sitecore.Collections Namespace


VersionCollection Class

[image]

Sitecore 6.4.1 API
VersionCollection Class
Members See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class VersionCollection : List<Version>
Visual Basic
Public Class VersionCollection _
    Inherits List(Of Version)
Visual C++
public ref class VersionCollection : public List<Version^>

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' Version >)>)>
Sitecore.Collections..::..VersionCollection

See Also

VersionCollection Members
Sitecore.Collections Namespace


VersionCollection Members

[image] [image]

Sitecore 6.4.1 API
VersionCollection Members
VersionCollection Class Constructors Methods Properties See Also Send Feedback

The VersionCollection type exposes the following members.

Constructors

 | Name | Description
Public method | VersionCollection | Initializes a new instance of the VersionCollection class

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | AddRange | Adds the elements of the specified collection to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | AsReadOnly | Returns a read-only IList<(Of <(<'T>)>)> wrapper for the current collection. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | Clear | Removes all elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | Contains | Determines whether an element is in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | Converts the elements in the current List<(Of <(<'T>)>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the List<(Of <(<'T>)>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' Version >)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | ForEach | Performs the specified action on each element of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | GetEnumerator | Returns an enumerator that iterates through the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | Insert | Inserts an element into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | InsertRange | Inserts the elements of a collection into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' Version >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | RemoveRange | Removes a range of elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | ToArray | Copies the elements of the List<(Of <(<'T>)>)> to a new array. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(<'T>)>)>, if that number is less than a threshold value. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | TrueForAll | Determines whether every element in the List<(Of <(<'T>)>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of <(<' Version >)>)>.)

Properties

 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <(<' Version >)>)>.)
Public property | Count | Gets the number of elements actually contained in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List <(Of <(<' Version >)>)>.)

See Also

VersionCollection Class
Sitecore.Collections Namespace


VersionCollection Constructor

[image]

Sitecore 6.4.1 API
VersionCollection Constructor
VersionCollection Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public VersionCollection()
Visual Basic
Public Sub New
Visual C++
public:
VersionCollection()

See Also

VersionCollection Class
Sitecore.Collections Namespace


VersionCollection Methods

[image] [image]

Sitecore 6.4.1 API
VersionCollection Methods
VersionCollection Class See Also Send Feedback

The VersionCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | AddRange | Adds the elements of the specified collection to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | AsReadOnly | Returns a read-only IList<(Of <(<'T>)>)> wrapper for the current collection. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | Clear | Removes all elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | Contains | Determines whether an element is in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | Converts the elements in the current List<(Of <(<'T>)>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the List<(Of <(<'T>)>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' Version >)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | ForEach | Performs the specified action on each element of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | GetEnumerator | Returns an enumerator that iterates through the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | Insert | Inserts an element into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | InsertRange | Inserts the elements of a collection into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' Version >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | RemoveRange | Removes a range of elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | ToArray | Copies the elements of the List<(Of <(<'T>)>)> to a new array. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(<'T>)>)>, if that number is less than a threshold value. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | TrueForAll | Determines whether every element in the List<(Of <(<'T>)>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of <(<' Version >)>)>.)

See Also

VersionCollection Class
Sitecore.Collections Namespace


BinarySearch Method

[image] [image]

Sitecore 6.4.1 API
VersionCollection..::..BinarySearch Method
VersionCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' Version >)>)>.)

See Also

VersionCollection Class
VersionCollection Members
Sitecore.Collections Namespace


CopyTo Method

[image] [image]

Sitecore 6.4.1 API
VersionCollection..::..CopyTo Method
VersionCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' Version >)>)>.)

See Also

VersionCollection Class
VersionCollection Members
Sitecore.Collections Namespace


FindIndex Method

[image] [image]

Sitecore 6.4.1 API
VersionCollection..::..FindIndex Method
VersionCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' Version >)>)>.)

See Also

VersionCollection Class
VersionCollection Members
Sitecore.Collections Namespace


FindLastIndex Method

[image] [image]

Sitecore 6.4.1 API
VersionCollection..::..FindLastIndex Method
VersionCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' Version >)>)>.)

See Also

VersionCollection Class
VersionCollection Members
Sitecore.Collections Namespace


IndexOf Method

[image] [image]

Sitecore 6.4.1 API
VersionCollection..::..IndexOf Method
VersionCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' Version >)>)>.)

See Also

VersionCollection Class
VersionCollection Members
Sitecore.Collections Namespace


LastIndexOf Method

[image] [image]

Sitecore 6.4.1 API
VersionCollection..::..LastIndexOf Method
VersionCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' Version >)>)>.)

See Also

VersionCollection Class
VersionCollection Members
Sitecore.Collections Namespace


Reverse Method

[image] [image]

Sitecore 6.4.1 API
VersionCollection..::..Reverse Method
VersionCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' Version >)>)>.)

See Also

VersionCollection Class
VersionCollection Members
Sitecore.Collections Namespace


Sort Method

[image] [image]

Sitecore 6.4.1 API
VersionCollection..::..Sort Method
VersionCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' Version >)>)>.)

See Also

VersionCollection Class
VersionCollection Members
Sitecore.Collections Namespace


VersionCollection Properties

[image] [image]

Sitecore 6.4.1 API
VersionCollection Properties
VersionCollection Class See Also Send Feedback

The VersionCollection type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <(<' Version >)>)>.)
Public property | Count | Gets the number of elements actually contained in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Version >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List <(Of <(<' Version >)>)>.)

See Also

VersionCollection Class
Sitecore.Collections Namespace


VersionList Class

[image]

Sitecore 6.4.1 API
VersionList Class
Members See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class VersionList : IEnumerable
Visual Basic
Public Class VersionList _
    Implements IEnumerable
Visual C++
public ref class VersionList : IEnumerable

Inheritance Hierarchy

System..::..Object
Sitecore.Collections..::..VersionList

See Also

VersionList Members
Sitecore.Collections Namespace


VersionList Members

[image] [image]

Sitecore 6.4.1 API
VersionList Members
VersionList Class Constructors Methods Properties See Also Send Feedback

The VersionList type exposes the following members.

Constructors

 | Name | Description
Public method | VersionList | Initializes a new instance of the VersionList class

Methods

 | Name | Description
Public method | Add(Version) | Adds the specified version.
 | Add(VersionList, VersionList) | Adds the specified list1.
 | Build | Builds the specified versions.
Public method | Contains | Determines whether [contains] [the specified version].
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the specified version.
Public method | Sort | Sorts this instance.
Public method | ToArray | Converts the VersionList to an array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the count.
Public property | Item | Gets the Version at the specified index.
Public property | SyncRoot | Gets the sync root.

See Also

VersionList Class
Sitecore.Collections Namespace


VersionList Constructor

[image]

Sitecore 6.4.1 API
VersionList Constructor
VersionList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public VersionList()
Visual Basic
Public Sub New
Visual C++
public:
VersionList()

See Also

VersionList Class
Sitecore.Collections Namespace


VersionList Methods

[image] [image]

Sitecore 6.4.1 API
VersionList Methods
VersionList Class See Also Send Feedback

The VersionList type exposes the following members.

Methods

 | Name | Description
Public method | Add(Version) | Adds the specified version.
 | Add(VersionList, VersionList) | Adds the specified list1.
 | Build | Builds the specified versions.
Public method | Contains | Determines whether [contains] [the specified version].
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the specified version.
Public method | Sort | Sorts this instance.
Public method | ToArray | Converts the VersionList to an array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VersionList Class
Sitecore.Collections Namespace


Add Method

[image] [image]

Sitecore 6.4.1 API
VersionList..::..Add Method
VersionList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(Version) | Adds the specified version.
 | Add(VersionList, VersionList) | Adds the specified list1.

See Also

VersionList Class
VersionList Members
Sitecore.Collections Namespace


Add Method (Version)

[image]

Sitecore 6.4.1 API
VersionList..::..Add Method (Version)
VersionList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Add(
    Version version
)
Visual Basic
Public Sub Add ( _
    version As Version _
)
Visual C++
public:
void Add(
    Version^ version
)

Parameters

version
Type: Sitecore.Data..::..Version
The version.

See Also

VersionList Class
Add Overload
Sitecore.Collections Namespace


Add Method (VersionList, VersionList)

[image]

Sitecore 6.4.1 API
VersionList..::..Add Method (VersionList, VersionList)
VersionList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static VersionList Add(
    VersionList list1,
    VersionList list2
)
Visual Basic
Public Shared Function Add ( _
    list1 As VersionList, _
    list2 As VersionList _
) As VersionList
Visual C++
public:
static VersionList^ Add(
    VersionList^ list1,
    VersionList^ list2
)

Parameters

list1
Type: Sitecore.Collections..::..VersionList
The list1.
list2
Type: Sitecore.Collections..::..VersionList
The list2.

Return Value

The VersionList.

See Also

VersionList Class
Add Overload
Sitecore.Collections Namespace


Build Method

[image]

Sitecore 6.4.1 API
VersionList..::..Build Method
VersionList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static VersionList Build(
    params Version[] versions
)
Visual Basic
Public Shared Function Build ( _
    ParamArray versions As Version() _
) As VersionList
Visual C++
public:
static VersionList^ Build(
    ... array<Version^>^ versions
)

Parameters

versions
Type: array< Sitecore.Data..::..Version >[]()[][]
The versions.

Return Value

The VersionList.

See Also

VersionList Class
Sitecore.Collections Namespace


Contains Method

[image]

Sitecore 6.4.1 API
VersionList..::..Contains Method
VersionList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Contains(
    Version version
)
Visual Basic
Public Function Contains ( _
    version As Version _
) As Boolean
Visual C++
public:
bool Contains(
    Version^ version
)

Parameters

version
Type: Sitecore.Data..::..Version
The version.

Return Value

true if [contains] [the specified version]; otherwise, false.

See Also

VersionList Class
Sitecore.Collections Namespace


GetEnumerator Method

[image]

Sitecore 6.4.1 API
VersionList..::..GetEnumerator Method
VersionList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator() sealed

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

VersionList Class
Sitecore.Collections Namespace


Remove Method

[image]

Sitecore 6.4.1 API
VersionList..::..Remove Method
VersionList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Remove(
    Version version
)
Visual Basic
Public Sub Remove ( _
    version As Version _
)
Visual C++
public:
void Remove(
    Version^ version
)

Parameters

version
Type: Sitecore.Data..::..Version
The version.

See Also

VersionList Class
Sitecore.Collections Namespace


Sort Method

[image]

Sitecore 6.4.1 API
VersionList..::..Sort Method
VersionList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Sort()
Visual Basic
Public Sub Sort
Visual C++
public:
void Sort()

See Also

VersionList Class
Sitecore.Collections Namespace


ToArray Method

[image]

Sitecore 6.4.1 API
VersionList..::..ToArray Method
VersionList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Array ToArray()
Visual Basic
Public Function ToArray As Array
Visual C++
public:
Array^ ToArray()

Return Value

The VersionList as an array.

See Also

VersionList Class
Sitecore.Collections Namespace


VersionList Properties

[image] [image]

Sitecore 6.4.1 API
VersionList Properties
VersionList Class See Also Send Feedback

The VersionList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the count.
Public property | Item | Gets the Version at the specified index.
Public property | SyncRoot | Gets the sync root.

See Also

VersionList Class
Sitecore.Collections Namespace


Count Property

[image]

Sitecore 6.4.1 API
VersionList..::..Count Property
VersionList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
property int Count {
    int get ();
}

Field Value

The count.

See Also

VersionList Class
Sitecore.Collections Namespace


Item Property

[image]

Sitecore 6.4.1 API
VersionList..::..Item Property
VersionList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Version this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    index As Integer _
) As Version
    Get
Visual C++
public:
property Version^ default[int index] {
    Version^ get (int index);
}

Parameters

index
Type: System..::..Int32

Field Value

The Version.

See Also

VersionList Class
Sitecore.Collections Namespace


SyncRoot Property

[image]

Sitecore 6.4.1 API
VersionList..::..SyncRoot Property
VersionList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object SyncRoot { get; }
Visual Basic
Public ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
property Object^ SyncRoot {
    Object^ get ();
}

Field Value

The sync root object.

See Also

VersionList Class
Sitecore.Collections Namespace


VersionUriList Class

[image]

Sitecore 6.4.1 API
VersionUriList Class
Members See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class VersionUriList : IEnumerable
Visual Basic
Public Class VersionUriList _
    Implements IEnumerable
Visual C++
public ref class VersionUriList : IEnumerable

Inheritance Hierarchy

System..::..Object
Sitecore.Collections..::..VersionUriList

See Also

VersionUriList Members
Sitecore.Collections Namespace


VersionUriList Members

[image] [image]

Sitecore 6.4.1 API
VersionUriList Members
VersionUriList Class Constructors Methods Properties See Also Send Feedback

The VersionUriList type exposes the following members.

Constructors

 | Name | Description
Public method | VersionUriList | Initializes a new instance of the VersionUriList class

Methods

 | Name | Description
Public method | Add(VersionUri) | Adds the specified URI.
Public method | Add(Language, VersionList) | Adds the specified language.
Public method | Add(Language, Version) | Adds the specified language.
 | Add(VersionUriList, VersionUriList) | Adds the specified list1.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDataLength | Gets the size of the data to use when caching.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the count.
Public property | Item | Gets the VersionUri at the specified index.

See Also

VersionUriList Class
Sitecore.Collections Namespace


VersionUriList Constructor

[image]

Sitecore 6.4.1 API
VersionUriList Constructor
VersionUriList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public VersionUriList()
Visual Basic
Public Sub New
Visual C++
public:
VersionUriList()

See Also

VersionUriList Class
Sitecore.Collections Namespace


VersionUriList Methods

[image] [image]

Sitecore 6.4.1 API
VersionUriList Methods
VersionUriList Class See Also Send Feedback

The VersionUriList type exposes the following members.

Methods

 | Name | Description
Public method | Add(VersionUri) | Adds the specified URI.
Public method | Add(Language, VersionList) | Adds the specified language.
Public method | Add(Language, Version) | Adds the specified language.
 | Add(VersionUriList, VersionUriList) | Adds the specified list1.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDataLength | Gets the size of the data to use when caching.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VersionUriList Class
Sitecore.Collections Namespace


Add Method

[image] [image]

Sitecore 6.4.1 API
VersionUriList..::..Add Method
VersionUriList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(VersionUri) | Adds the specified URI.
Public method | Add(Language, VersionList) | Adds the specified language.
Public method | Add(Language, Version) | Adds the specified language.
 | Add(VersionUriList, VersionUriList) | Adds the specified list1.

See Also

VersionUriList Class
VersionUriList Members
Sitecore.Collections Namespace


Add Method (VersionUri)

[image]

Sitecore 6.4.1 API
VersionUriList..::..Add Method (VersionUri)
VersionUriList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Add(
    VersionUri uri
)
Visual Basic
Public Sub Add ( _
    uri As VersionUri _
)
Visual C++
public:
void Add(
    VersionUri^ uri
)

Parameters

uri
Type: Sitecore.Data..::..VersionUri
The URI.

See Also

VersionUriList Class
Add Overload
Sitecore.Collections Namespace


Add Method (Language, VersionList)

[image]

Sitecore 6.4.1 API
VersionUriList..::..Add Method (Language, VersionList)
VersionUriList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Add(
    Language language,
    VersionList versions
)
Visual Basic
Public Sub Add ( _
    language As Language, _
    versions As VersionList _
)
Visual C++
public:
void Add(
    Language^ language,
    VersionList^ versions
)

Parameters

language
Type: Sitecore.Globalization..::..Language
The language.
versions
Type: Sitecore.Collections..::..VersionList
The versions.

See Also

VersionUriList Class
Add Overload
Sitecore.Collections Namespace


Add Method (Language, Version)

[image]

Sitecore 6.4.1 API
VersionUriList..::..Add Method (Language, Version)
VersionUriList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Add(
    Language language,
    Version version
)
Visual Basic
Public Sub Add ( _
    language As Language, _
    version As Version _
)
Visual C++
public:
void Add(
    Language^ language,
    Version^ version
)

Parameters

language
Type: Sitecore.Globalization..::..Language
The language.
version
Type: Sitecore.Data..::..Version
The version.

See Also

VersionUriList Class
Add Overload
Sitecore.Collections Namespace


Add Method (VersionUriList, VersionUriList)

[image]

Sitecore 6.4.1 API
VersionUriList..::..Add Method (VersionUriList, VersionUriList)
VersionUriList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static VersionUriList Add(
    VersionUriList list1,
    VersionUriList list2
)
Visual Basic
Public Shared Function Add ( _
    list1 As VersionUriList, _
    list2 As VersionUriList _
) As VersionUriList
Visual C++
public:
static VersionUriList^ Add(
    VersionUriList^ list1,
    VersionUriList^ list2
)

Parameters

list1
Type: Sitecore.Collections..::..VersionUriList
The list1.
list2
Type: Sitecore.Collections..::..VersionUriList
The list2.

Return Value

The VersionUriList.

See Also

VersionUriList Class
Add Overload
Sitecore.Collections Namespace


GetEnumerator Method

[image]

Sitecore 6.4.1 API
VersionUriList..::..GetEnumerator Method
VersionUriList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator() sealed

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

VersionUriList Class
Sitecore.Collections Namespace


VersionUriList Properties

[image] [image]

Sitecore 6.4.1 API
VersionUriList Properties
VersionUriList Class See Also Send Feedback

The VersionUriList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the count.
Public property | Item | Gets the VersionUri at the specified index.

See Also

VersionUriList Class
Sitecore.Collections Namespace


Count Property

[image]

Sitecore 6.4.1 API
VersionUriList..::..Count Property
VersionUriList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
property int Count {
    int get ();
}

Field Value

The count.

See Also

VersionUriList Class
Sitecore.Collections Namespace


Item Property

[image]

Sitecore 6.4.1 API
VersionUriList..::..Item Property
VersionUriList Class See Also Send Feedback

Namespace: Sitecore.Collections
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public VersionUri this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    index As Integer _
) As VersionUri
    Get
Visual C++
public:
property VersionUri^ default[int index] {
    VersionUri^ get (int index);
}

Parameters

index
Type: System..::..Int32

Field Value

The VersionUri.

See Also

VersionUriList Class
Sitecore.Collections Namespace


Sitecore.Common Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Common Namespace
Send Feedback

Classes

 | Class | Description
Public class | CallContext | AuthorizationCallContext class
Public class | CallContextSwitcher | AuthorizationCallContextSwitcher class
Public class | DateTimeExtensions | Extension methods for the DateTime class.
Public class | DateTimeRange | Class representing a range between to dates and times.
Public class | ElementCounter | ElementCounter
Public class | Enumerable<(Of <(<'TElement>)>)> | UserEnumerable
Public class | EnumerableExtensions | The enumerable extensions.
Public class | Enumerator<(Of <(<'TElement>)>)> | Enumerator class
Public class | Filterable<(Of <(<'TElement>)>)> | Filterable class
Public class | Pageable<(Of <(<'TElement>)>)> | Pageable class
Public class | PageableList<(Of <(<'TElement>)>)> | ListPageableData class
Public class | PagingHelper<(Of <(<'TInput, TOutput>)>)> | PagingHelper class
Public class | PagingIterator<(Of <(<'T>)>)> |
Public class | Reference<(Of <(<'T>)>)> | Defines the reference class.
Public class | Serializer | Serializer class.
Public class | SettingsPropertyCollectionExtensions | Extension methods for the SettingsPropertyCollection class.
Public class | Switcher<(Of <(<'T>)>)> | Swither class
Public class | Switcher<(Of <(<'TValue, TSwitchType>)>)> | Switcher class
Public class | Timeline | Timeline class
Public class | TypeExtensions | The type extensions.

Interfaces

 | Interface | Description
Public interface | ICommand<(Of <(<'TReturnType>)>)> | Interface for a command object.
Public interface | IFilterable<(Of <(<'TElement>)>)> | IFilterable interface
Public interface | IPageable<(Of <(<'TElement>)>)> | IPageableData interface
Public interface | IPrototype<(Of <(<'TObjectType>)>)> | Interface for a prototype object.

Delegates

 | Delegate | Description
Public delegate | PagingHelper<(Of <(<'TInput, TOutput>)>)>..::..GetElements | GetElements delegate
Public delegate | PagingIterator<(Of <(<'T>)>)>..::..GetPage |


CallContext Class

[image]

Sitecore 6.4.1 API
CallContext Class
Members See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CallContext
Visual Basic
Public Class CallContext
Visual C++
public ref class CallContext

Inheritance Hierarchy

System..::..Object
Sitecore.Common..::..CallContext

See Also

CallContext Members
Sitecore.Common Namespace


CallContext Constructor

[image]

Sitecore 6.4.1 API
CallContext Constructor
CallContext Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CallContext()
Visual Basic
Public Sub New
Visual C++
public:
CallContext()

See Also

CallContext Class
Sitecore.Common Namespace


CallContext Methods

[image] [image]

Sitecore 6.4.1 API
CallContext Methods
CallContext Class See Also Send Feedback

The CallContext type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Resets this instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CallContext Class
Sitecore.Common Namespace


Reset Method

[image]

Sitecore 6.4.1 API
CallContext..::..Reset Method
CallContext Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset
Visual C++
public:
void Reset()

See Also

CallContext Class
Sitecore.Common Namespace


CallContext Properties

[image] [image]

Sitecore 6.4.1 API
CallContext Properties
CallContext Class See Also Send Feedback

The CallContext type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets or sets a value indicating whether the call chain has been aborted.
 | Current | Gets the current call context.
Public property | NotSupported | Gets or sets a value indicating whether the operation is supported by the called method.

See Also

CallContext Class
Sitecore.Common Namespace


Aborted Property

[image]

Sitecore 6.4.1 API
CallContext..::..Aborted Property
CallContext Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Aborted { get; set; }
Visual Basic
Public Property Aborted As Boolean
    Get
    Set
Visual C++
public:
property bool Aborted {
    bool get ();
    void set (bool value);
}

Field Value

true if aborted; otherwise, false.

See Also

CallContext Class
Sitecore.Common Namespace


Current Property

[image]

Sitecore 6.4.1 API
CallContext..::..Current Property
CallContext Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static CallContext Current { get; }
Visual Basic
Public Shared ReadOnly Property Current As CallContext
    Get
Visual C++
public:
static property CallContext^ Current {
    CallContext^ get ();
}

Field Value

The current.

See Also

CallContext Class
Sitecore.Common Namespace


NotSupported Property

[image]

Sitecore 6.4.1 API
CallContext..::..NotSupported Property
CallContext Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool NotSupported { get; set; }
Visual Basic
Public Property NotSupported As Boolean
    Get
    Set
Visual C++
public:
property bool NotSupported {
    bool get ();
    void set (bool value);
}

Field Value

true if the called method is not supported by the implementation; otherwise, false.

See Also

CallContext Class
Sitecore.Common Namespace


CallContextSwitcher Class

[image]

Sitecore 6.4.1 API
CallContextSwitcher Class
Members See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CallContextSwitcher : Switcher<CallContext, CallContextSwitcher>
Visual Basic
Public Class CallContextSwitcher _
    Inherits Switcher(Of CallContext, CallContextSwitcher)
Visual C++
public ref class CallContextSwitcher : public Switcher<CallContext^, CallContextSwitcher^>

Inheritance Hierarchy

System..::..Object
Sitecore.Common..::..Switcher <(Of <(<' CallContext, CallContextSwitcher>)>)>
Sitecore.Common..::..CallContextSwitcher

See Also

CallContextSwitcher Members
Sitecore.Common Namespace


CallContextSwitcher Members

[image] [image]

Sitecore 6.4.1 API
CallContextSwitcher Members
CallContextSwitcher Class Constructors Methods Events See Also Send Feedback

The CallContextSwitcher type exposes the following members.

Constructors

 | Name | Description
Public method | CallContextSwitcher()()()() | Initializes a new instance of the CallContextSwitcher class.
Public method | CallContextSwitcher(CallContext) | Initializes a new instance of the CallContextSwitcher class.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Switcher<(Of <(<'TValue, TSwitchType>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

 | Name | Description
Protected event | Disposed | Occurs when the object has been disposed. (Inherited from Switcher<(Of <(<'TValue, TSwitchType>)>)>.)

See Also

CallContextSwitcher Class
Sitecore.Common Namespace


CallContextSwitcher Constructor

[image] [image]

Sitecore 6.4.1 API
CallContextSwitcher Constructor
CallContextSwitcher Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallContextSwitcher()()()() | Initializes a new instance of the CallContextSwitcher class.
Public method | CallContextSwitcher(CallContext) | Initializes a new instance of the CallContextSwitcher class.

See Also

CallContextSwitcher Class
CallContextSwitcher Members
Sitecore.Common Namespace


CallContextSwitcher Constructor

[image]

Sitecore 6.4.1 API
CallContextSwitcher Constructor
CallContextSwitcher Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CallContextSwitcher()
Visual Basic
Public Sub New
Visual C++
public:
CallContextSwitcher()

See Also

CallContextSwitcher Class
CallContextSwitcher Overload
Sitecore.Common Namespace


CallContextSwitcher Constructor (CallContext)

[image]

Sitecore 6.4.1 API
CallContextSwitcher Constructor (CallContext)
CallContextSwitcher Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CallContextSwitcher(
    CallContext context
)
Visual Basic
Public Sub New ( _
    context As CallContext _
)
Visual C++
public:
CallContextSwitcher(
    CallContext^ context
)

Parameters

context
Type: Sitecore.Common..::..CallContext

[Missing <param name="context"/> documentation for "M:Sitecore.Common.CallContextSwitcher.#ctor(Sitecore.Common.CallContext)"]

See Also

CallContextSwitcher Class
CallContextSwitcher Overload
Sitecore.Common Namespace


CallContextSwitcher Methods

[image] [image]

Sitecore 6.4.1 API
CallContextSwitcher Methods
CallContextSwitcher Class See Also Send Feedback

The CallContextSwitcher type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Switcher<(Of <(<'TValue, TSwitchType>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CallContextSwitcher Class
Sitecore.Common Namespace


CallContextSwitcher Events

[image] [image]

Sitecore 6.4.1 API
CallContextSwitcher Events
CallContextSwitcher Class See Also Send Feedback

The CallContextSwitcher type exposes the following members.

Events

 | Name | Description
Protected event | Disposed | Occurs when the object has been disposed. (Inherited from Switcher<(Of <(<'TValue, TSwitchType>)>)>.)

See Also

CallContextSwitcher Class
Sitecore.Common Namespace


DateTimeExtensions Class

[image]

Sitecore 6.4.1 API
DateTimeExtensions Class
Members See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class DateTimeExtensions
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class DateTimeExtensions
Visual C++
[ExtensionAttribute]
public ref class DateTimeExtensions abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Common..::..DateTimeExtensions

See Also

DateTimeExtensions Members
Sitecore.Common Namespace


DateTimeExtensions Members

[image] [image]

Sitecore 6.4.1 API
DateTimeExtensions Members
DateTimeExtensions Class Methods See Also Send Feedback

Methods

Name | Description
InRange(DateTime, Pair<(Of <<'(DateTime, DateTime>)>>)) | Determines if a DateTime is within the specified range (inclusive).
InRange(DateTime, DateTime, DateTime) | Determines if a DateTime is within the specified range (inclusive).

See Also

DateTimeExtensions Class
Sitecore.Common Namespace


DateTimeExtensions Methods

[image] [image]

Sitecore 6.4.1 API
DateTimeExtensions Methods
DateTimeExtensions Class See Also Send Feedback

Methods

Name | Description
InRange(DateTime, Pair<(Of <<'(DateTime, DateTime>)>>)) | Determines if a DateTime is within the specified range (inclusive).
InRange(DateTime, DateTime, DateTime) | Determines if a DateTime is within the specified range (inclusive).

See Also

DateTimeExtensions Class
Sitecore.Common Namespace


InRange Method

[image] [image]

Sitecore 6.4.1 API
DateTimeExtensions..::..InRange Method
DateTimeExtensions Class See Also Send Feedback

Overload List

Name | Description
InRange(DateTime, Pair<(Of <<'(DateTime, DateTime>)>>)) | Determines if a DateTime is within the specified range (inclusive).
InRange(DateTime, DateTime, DateTime) | Determines if a DateTime is within the specified range (inclusive).

See Also

DateTimeExtensions Class
DateTimeExtensions Members
Sitecore.Common Namespace


InRange Method (DateTime, Pair(DateTime, DateTime))

[image]

Sitecore 6.4.1 API
DateTimeExtensions..::..InRange Method (DateTime, Pair<(Of <(<'DateTime, DateTime>)>)>)
DateTimeExtensions Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool InRange(
    this DateTime date,
    Pair<DateTime, DateTime> range
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function InRange ( _
    date As DateTime, _
    range As Pair(Of DateTime, DateTime) _
) As Boolean
Visual C++
[ExtensionAttribute]
public:
static bool InRange(
    DateTime date,
    Pair<DateTime, DateTime>^ range
)

Parameters

date
Type: System..::..DateTime

[Missing <param name="date"/> documentation for "M:Sitecore.Common.DateTimeExtensions.InRange(System.DateTime,Sitecore.Collections.Pair{System.DateTime,System.DateTime})"]

range
Type: Sitecore.Collections..::..Pair <(Of <(<' DateTime, DateTime >)>)>

[Missing <param name="range"/> documentation for "M:Sitecore.Common.DateTimeExtensions.InRange(System.DateTime,Sitecore.Collections.Pair{System.DateTime,System.DateTime})"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Common.DateTimeExtensions.InRange(System.DateTime,Sitecore.Collections.Pair{System.DateTime,System.DateTime})"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DateTime. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

DateTimeExtensions Class
InRange Overload
Sitecore.Common Namespace


InRange Method (DateTime, DateTime, DateTime)

[image]

Sitecore 6.4.1 API
DateTimeExtensions..::..InRange Method (DateTime, DateTime, DateTime)
DateTimeExtensions Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool InRange(
    this DateTime date,
    DateTime from,
    DateTime to
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function InRange ( _
    date As DateTime, _
    from As DateTime, _
    to As DateTime _
) As Boolean
Visual C++
[ExtensionAttribute]
public:
static bool InRange(
    DateTime date,
    DateTime from,
    DateTime to
)

Parameters

date
Type: System..::..DateTime

[Missing <param name="date"/> documentation for "M:Sitecore.Common.DateTimeExtensions.InRange(System.DateTime,System.DateTime,System.DateTime)"]

from
Type: System..::..DateTime

[Missing <param name="from"/> documentation for "M:Sitecore.Common.DateTimeExtensions.InRange(System.DateTime,System.DateTime,System.DateTime)"]

to
Type: System..::..DateTime

[Missing <param name="to"/> documentation for "M:Sitecore.Common.DateTimeExtensions.InRange(System.DateTime,System.DateTime,System.DateTime)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Common.DateTimeExtensions.InRange(System.DateTime,System.DateTime,System.DateTime)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DateTime. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

DateTimeExtensions Class
InRange Overload
Sitecore.Common Namespace


DateTimeRange Class

[image]

Sitecore 6.4.1 API
DateTimeRange Class
Members See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DateTimeRange
Visual Basic
Public Class DateTimeRange
Visual C++
public ref class DateTimeRange

Inheritance Hierarchy

System..::..Object
Sitecore.Common..::..DateTimeRange

See Also

DateTimeRange Members
Sitecore.Common Namespace


DateTimeRange Members

[image] [image]

Sitecore 6.4.1 API
DateTimeRange Members
DateTimeRange Class Constructors Methods Properties See Also Send Feedback

The DateTimeRange type exposes the following members.

Constructors

 | Name | Description
Public method | DateTimeRange | Initializes a new instance of the DateTimeRange class.

Methods

 | Name | Description
Public method | Contains | Determines whether the range contains the specified date time.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
 | Empty | Gets the empty range.
Public property | From | Gets the 'from' date.
Public property | To | Gets the 'to' date.

See Also

DateTimeRange Class
Sitecore.Common Namespace


DateTimeRange Constructor

[image]

Sitecore 6.4.1 API
DateTimeRange Constructor
DateTimeRange Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTimeRange(
    DateTime from,
    DateTime to
)
Visual Basic
Public Sub New ( _
    from As DateTime, _
    to As DateTime _
)
Visual C++
public:
DateTimeRange(
    DateTime from,
    DateTime to
)

Parameters

from
Type: System..::..DateTime
From.
to
Type: System..::..DateTime
To.

See Also

DateTimeRange Class
Sitecore.Common Namespace


DateTimeRange Methods

[image] [image]

Sitecore 6.4.1 API
DateTimeRange Methods
DateTimeRange Class See Also Send Feedback

The DateTimeRange type exposes the following members.

Methods

 | Name | Description
Public method | Contains | Determines whether the range contains the specified date time.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DateTimeRange Class
Sitecore.Common Namespace


Contains Method

[image]

Sitecore 6.4.1 API
DateTimeRange..::..Contains Method
DateTimeRange Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Contains(
    DateTime dateTime
)
Visual Basic
Public Function Contains ( _
    dateTime As DateTime _
) As Boolean
Visual C++
public:
bool Contains(
    DateTime dateTime
)

Parameters

dateTime
Type: System..::..DateTime
The date time.

Return Value

true if it contains the specified date time; otherwise, false.

See Also

DateTimeRange Class
Sitecore.Common Namespace


DateTimeRange Properties

[image] [image]

Sitecore 6.4.1 API
DateTimeRange Properties
DateTimeRange Class See Also Send Feedback

The DateTimeRange type exposes the following members.

Properties

 | Name | Description
 | Empty | Gets the empty range.
Public property | From | Gets the 'from' date.
Public property | To | Gets the 'to' date.

See Also

DateTimeRange Class
Sitecore.Common Namespace


Empty Property

[image]

Sitecore 6.4.1 API
DateTimeRange..::..Empty Property
DateTimeRange Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static DateTimeRange Empty { get; }
Visual Basic
Public Shared ReadOnly Property Empty As DateTimeRange
    Get
Visual C++
public:
static property DateTimeRange^ Empty {
    DateTimeRange^ get ();
}

Field Value

The empty range.

See Also

DateTimeRange Class
Sitecore.Common Namespace


From Property

[image]

Sitecore 6.4.1 API
DateTimeRange..::..From Property
DateTimeRange Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime From { get; }
Visual Basic
Public ReadOnly Property From As DateTime
    Get
Visual C++
public:
property DateTime From {
    DateTime get ();
}

Field Value

From.

See Also

DateTimeRange Class
Sitecore.Common Namespace


To Property

[image]

Sitecore 6.4.1 API
DateTimeRange..::..To Property
DateTimeRange Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime To { get; }
Visual Basic
Public ReadOnly Property To As DateTime
    Get
Visual C++
public:
property DateTime To {
    DateTime get ();
}

Field Value

To.

See Also

DateTimeRange Class
Sitecore.Common Namespace


ElementCounter Class

[image]

Sitecore 6.4.1 API
ElementCounter Class
Members See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ElementCounter
Visual Basic
Public Class ElementCounter
Visual C++
public ref class ElementCounter

Inheritance Hierarchy

System..::..Object
Sitecore.Common..::..ElementCounter

See Also

ElementCounter Members
Sitecore.Common Namespace


ElementCounter Members

[image] [image]

Sitecore 6.4.1 API
ElementCounter Members
ElementCounter Class Constructors Methods Properties See Also Send Feedback

The ElementCounter type exposes the following members.

Constructors

 | Name | Description
Public method | ElementCounter | Initializes a new instance of the ElementCounter class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Value | Gets or sets the value.

See Also

ElementCounter Class
Sitecore.Common Namespace


ElementCounter Constructor

[image]

Sitecore 6.4.1 API
ElementCounter Constructor
ElementCounter Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ElementCounter()
Visual Basic
Public Sub New
Visual C++
public:
ElementCounter()

See Also

ElementCounter Class
Sitecore.Common Namespace


ElementCounter Methods

[image] [image]

Sitecore 6.4.1 API
ElementCounter Methods
ElementCounter Class See Also Send Feedback

The ElementCounter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementCounter Class
Sitecore.Common Namespace


ElementCounter Properties

[image] [image]

Sitecore 6.4.1 API
ElementCounter Properties
ElementCounter Class See Also Send Feedback

The ElementCounter type exposes the following members.

Properties

 | Name | Description
Public property | Value | Gets or sets the value.

See Also

ElementCounter Class
Sitecore.Common Namespace


Value Property

[image]

Sitecore 6.4.1 API
ElementCounter..::..Value Property
ElementCounter Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Value { get; set; }
Visual Basic
Public Property Value As Integer
    Get
    Set
Visual C++
public:
property int Value {
    int get ();
    void set (int value);
}

Field Value

The value.

See Also

ElementCounter Class
Sitecore.Common Namespace


Enumerable(TElement) Class

[image]

Sitecore 6.4.1 API
Enumerable<(Of <(<'TElement>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Enumerable<TElement> : IEnumerable<T>,
    IEnumerable
Visual Basic
Public Class Enumerable(Of TElement) _
    Implements IEnumerable(Of T), IEnumerable
Visual C++
generic<typename TElement>
public ref class Enumerable : IEnumerable<T>,
    IEnumerable

Type Parameters

TElement

[Missing <typeparam name="TElement"/> documentation for "T:Sitecore.Common.Enumerable`1"]

Inheritance Hierarchy

System..::..Object
Sitecore.Common..::..Enumerable<(Of <(<'TElement>)>)>

See Also

Enumerable<(Of <(<'TElement>)>)> Members
Sitecore.Common Namespace


Enumerable(TElement) Members

[image] [image]

Sitecore 6.4.1 API
Enumerable<(Of <(<'TElement>)>)> Members
Enumerable<(Of <(<'TElement>)>)> Class Constructors Methods See Also Send Feedback

The Enumerable<(Of <(<'TElement>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | Enumerable<(Of <(<'TElement>)>)>(Func<(Of <<'(IEnumerable>)>>), Func<(Of <<'(Object, TElement>)>>)) | Initializes a new instance of the Enumerable<(Of <(<'TElement>)>)> class.
Public method | Enumerable<(Of <(<'TElement>)>)>(Func<(Of <<'(IEnumerator>)>>), Func<(Of <<'(Object, TElement>)>>)) | Initializes a new instance of the Enumerable<(Of <(<'TElement>)>)> class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | Convert<(Of <<'(T, TTo>)>>) | Converts this instance. (Defined by EnumerableExtensions.)
Public Extension Method | StringConcatenate<(Of <<'(T>)>>) | Concatenate strings (Defined by IEnumerableExtensions.)

See Also

Enumerable<(Of <(<'TElement>)>)> Class
Sitecore.Common Namespace


Enumerable(TElement) Constructor (Func(IEnumerable), Func(Object, TElement))

[image]

Sitecore 6.4.1 API
Enumerable<(Of <(<'TElement>)>)> Constructor (Func<(Of <(<'IEnumerable>)>)>, Func<(Of <(<'Object, TElement>)>)>)
Enumerable<(Of <(<'TElement>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Enumerable(
    Func<IEnumerable> getEnumerable,
    Func<Object, TElement> mapElement
)
Visual Basic
Public Sub New ( _
    getEnumerable As Func(Of IEnumerable), _
    mapElement As Func(Of Object, TElement) _
)
Visual C++
public:
Enumerable(
    Func<IEnumerable^>^ getEnumerable,
    Func<Object^, TElement>^ mapElement
)

Parameters

getEnumerable
Type: System..::..Func <(Of <(<' IEnumerable >)>)>
The get enumerable function.
mapElement
Type: System..::..Func <(Of <(<' Object, TElement >)>)>
The map element function.

See Also

Enumerable<(Of <(<'TElement>)>)> Class
Enumerable<(Of <(<'TElement>)>)> Overload
Sitecore.Common Namespace


Enumerable(TElement) Constructor (Func(IEnumerator), Func(Object, TElement))

[image]

Sitecore 6.4.1 API
Enumerable<(Of <(<'TElement>)>)> Constructor (Func<(Of <(<'IEnumerator>)>)>, Func<(Of <(<'Object, TElement>)>)>)
Enumerable<(Of <(<'TElement>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Enumerable(
    Func<IEnumerator> getEnumerator,
    Func<Object, TElement> mapElement
)
Visual Basic
Public Sub New ( _
    getEnumerator As Func(Of IEnumerator), _
    mapElement As Func(Of Object, TElement) _
)
Visual C++
public:
Enumerable(
    Func<IEnumerator^>^ getEnumerator,
    Func<Object^, TElement>^ mapElement
)

Parameters

getEnumerator
Type: System..::..Func <(Of <(<' IEnumerator >)>)>
The get enumerator.
mapElement
Type: System..::..Func <(Of <(<' Object, TElement >)>)>
The map element.

See Also

Enumerable<(Of <(<'TElement>)>)> Class
Enumerable<(Of <(<'TElement>)>)> Overload
Sitecore.Common Namespace


Enumerable(TElement) Methods

[image] [image]

Sitecore 6.4.1 API
Enumerable<(Of <(<'TElement>)>)> Methods
Enumerable<(Of <(<'TElement>)>)> Class See Also Send Feedback

The Enumerable<(Of <(<'TElement>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | Convert<(Of <<'(T, TTo>)>>) | Converts this instance. (Defined by EnumerableExtensions.)
Public Extension Method | StringConcatenate<(Of <<'(T>)>>) | Concatenate strings (Defined by IEnumerableExtensions.)

See Also

Enumerable<(Of <(<'TElement>)>)> Class
Sitecore.Common Namespace


GetEnumerator Method

[image]

Sitecore 6.4.1 API
Enumerable<(Of <(<'TElement>)>)>..::..GetEnumerator Method
Enumerable<(Of <(<'TElement>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IEnumerator<TElement> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of TElement)
Visual C++
public:
virtual IEnumerator<TElement>^ GetEnumerator() sealed

Return Value

A IEnumerator<(Of <(<'T>)>)> that can be used to iterate through the collection.

See Also

Enumerable<(Of <(<'TElement>)>)> Class
Sitecore.Common Namespace


EnumerableExtensions Class

[image]

Sitecore 6.4.1 API
EnumerableExtensions Class
Members See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class EnumerableExtensions
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class EnumerableExtensions
Visual C++
[ExtensionAttribute]
public ref class EnumerableExtensions abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Common..::..EnumerableExtensions

See Also

EnumerableExtensions Members
Sitecore.Common Namespace


EnumerableExtensions Members

[image] [image]

Sitecore 6.4.1 API
EnumerableExtensions Members
EnumerableExtensions Class Methods See Also Send Feedback

The EnumerableExtensions type exposes the following members.

Methods

Name | Description
Convert<(Of <<'(TFrom, TTo>)>>) | Converts this instance.

See Also

EnumerableExtensions Class
Sitecore.Common Namespace


EnumerableExtensions Methods

[image] [image]

Sitecore 6.4.1 API
EnumerableExtensions Methods
EnumerableExtensions Class See Also Send Feedback

The EnumerableExtensions type exposes the following members.

Methods

Name | Description
Convert<(Of <<'(TFrom, TTo>)>>) | Converts this instance.

See Also

EnumerableExtensions Class
Sitecore.Common Namespace


Convert(TFrom, TTo) Method

[image]

Sitecore 6.4.1 API
EnumerableExtensions..::..Convert<(Of <(<'TFrom, TTo>)>)> Method
EnumerableExtensions Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static IEnumerable<TTo> Convert<TFrom, TTo>(
    this IEnumerable<TFrom> values,
    Func<TFrom, TTo> converter
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function Convert(Of TFrom, TTo) ( _
    values As IEnumerable(Of TFrom), _
    converter As Func(Of TFrom, TTo) _
) As IEnumerable(Of TTo)
Visual C++
[ExtensionAttribute]
public:
generic<typename TFrom, typename TTo>
static IEnumerable<TTo>^ Convert(
    IEnumerable<TFrom>^ values,
    Func<TFrom, TTo>^ converter
)

Parameters

values
Type: System.Collections.Generic..::..IEnumerable <(Of <(<'TFrom>)>)>

[Missing <param name="values"/> documentation for "M:Sitecore.Common.EnumerableExtensions.Convert``2(System.Collections.Generic.IEnumerable{``0},System.Func{``0,``1})"]

converter
Type: System..::..Func <(Of <(<'TFrom, TTo>)>)>

[Missing <param name="converter"/> documentation for "M:Sitecore.Common.EnumerableExtensions.Convert``2(System.Collections.Generic.IEnumerable{``0},System.Func{``0,``1})"]

Type Parameters

TFrom
The type of from.
TTo
The type of to.

Return Value

The result.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable <(Of <(<'TFrom>)>)>. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

EnumerableExtensions Class
Sitecore.Common Namespace


Enumerator(TElement) Class

[image]

Sitecore 6.4.1 API
Enumerator<(Of <(<'TElement>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Enumerator<TElement> : IEnumerator<TElement>,
    IDisposable, IEnumerator
Visual Basic
Public Class Enumerator(Of TElement) _
    Implements IEnumerator(Of TElement), IDisposable,  _
    IEnumerator
Visual C++
generic<typename TElement>
public ref class Enumerator : IEnumerator<TElement>,
    IDisposable, IEnumerator

Type Parameters

TElement

[Missing <typeparam name="TElement"/> documentation for "T:Sitecore.Common.Enumerator`1"]

Inheritance Hierarchy

System..::..Object
Sitecore.Common..::..Enumerator<(Of <(<'TElement>)>)>

See Also

Enumerator<(Of <(<'TElement>)>)> Members
Sitecore.Common Namespace


Enumerator(TElement) Members

[image] [image]

Sitecore 6.4.1 API
Enumerator<(Of <(<'TElement>)>)> Members
Enumerator<(Of <(<'TElement>)>)> Class Constructors Methods Properties See Also Send Feedback

The Enumerator<(Of <(<'TElement>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | Enumerator<(Of <(<'TElement>)>)> | Initializes a new instance of the Enumerator<(Of <(<'TElement>)>)> class.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext | Advances the enumerator to the next element of the collection.
Public method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Gets the element in the collection at the current position of the enumerator.
Protected property | InnerEnumerator | Gets the enumerator.

See Also

Enumerator<(Of <(<'TElement>)>)> Class
Sitecore.Common Namespace


Enumerator(TElement) Constructor

[image]

Sitecore 6.4.1 API
Enumerator<(Of <(<'TElement>)>)> Constructor
Enumerator<(Of <(<'TElement>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Enumerator(
    Func<IEnumerator> getEnumerator,
    Func<Object, TElement> mapElement
)
Visual Basic
Public Sub New ( _
    getEnumerator As Func(Of IEnumerator), _
    mapElement As Func(Of Object, TElement) _
)
Visual C++
public:
Enumerator(
    Func<IEnumerator^>^ getEnumerator,
    Func<Object^, TElement>^ mapElement
)

Parameters

getEnumerator
Type: System..::..Func <(Of <(<' IEnumerator >)>)>
The get enumerator function.
mapElement
Type: System..::..Func <(Of <(<' Object, TElement >)>)>
The map element function.

See Also

Enumerator<(Of <(<'TElement>)>)> Class
Sitecore.Common Namespace


Enumerator(TElement) Methods

[image] [image]

Sitecore 6.4.1 API
Enumerator<(Of <(<'TElement>)>)> Methods
Enumerator<(Of <(<'TElement>)>)> Class See Also Send Feedback

The Enumerator<(Of <(<'TElement>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext | Advances the enumerator to the next element of the collection.
Public method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Enumerator<(Of <(<'TElement>)>)> Class
Sitecore.Common Namespace


Dispose Method

[image]

Sitecore 6.4.1 API
Enumerator<(Of <(<'TElement>)>)>..::..Dispose Method
Enumerator<(Of <(<'TElement>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

Enumerator<(Of <(<'TElement>)>)> Class
Sitecore.Common Namespace


MoveNext Method

[image]

Sitecore 6.4.1 API
Enumerator<(Of <(<'TElement>)>)>..::..MoveNext Method
Enumerator<(Of <(<'TElement>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool MoveNext()
Visual Basic
Public Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext() sealed

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Implements

IEnumerator..::..MoveNext()()()()

Exceptions

Exception | Condition
System..::..InvalidOperationException | The collection was modified after the enumerator was created.

See Also

Enumerator<(Of <(<'TElement>)>)> Class
Sitecore.Common Namespace


Enumerator(TElement) Properties

[image] [image]

Sitecore 6.4.1 API
Enumerator<(Of <(<'TElement>)>)> Properties
Enumerator<(Of <(<'TElement>)>)> Class See Also Send Feedback

The Enumerator<(Of <(<'TElement>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Current | Gets the element in the collection at the current position of the enumerator.
Protected property | InnerEnumerator | Gets the enumerator.

See Also

Enumerator<(Of <(<'TElement>)>)> Class
Sitecore.Common Namespace


Current Property

[image]

Sitecore 6.4.1 API
Enumerator<(Of <(<'TElement>)>)>..::..Current Property
Enumerator<(Of <(<'TElement>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TElement Current { get; }
Visual Basic
Public ReadOnly Property Current As TElement
    Get
Visual C++
public:
virtual property TElement Current {
    TElement get () sealed;
}

Return Value

The element in the collection at the current position of the enumerator.

Implements

IEnumerator<(Of <(<'T>)>)>..::..Current

See Also

Enumerator<(Of <(<'TElement>)>)> Class
Sitecore.Common Namespace


InnerEnumerator Property

[image]

Sitecore 6.4.1 API
Enumerator<(Of <(<'TElement>)>)>..::..InnerEnumerator Property
Enumerator<(Of <(<'TElement>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected IEnumerator InnerEnumerator { get; }
Visual Basic
Protected ReadOnly Property InnerEnumerator As IEnumerator
    Get
Visual C++
protected:
property IEnumerator^ InnerEnumerator {
    IEnumerator^ get ();
}

Field Value

The enumerator.

See Also

Enumerator<(Of <(<'TElement>)>)> Class
Sitecore.Common Namespace


Filterable(TElement) Class

[image]

Sitecore 6.4.1 API
Filterable<(Of <(<'TElement>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Filterable<TElement> : Pageable<TElement>,
    IFilterable<TElement>, IPageable<TElement>, IEnumerable<T>, IEnumerable
Visual Basic
Public Class Filterable(Of TElement) _
    Inherits Pageable(Of TElement) _
    Implements IFilterable(Of TElement), IPageable(Of TElement),  _
    IEnumerable(Of T), IEnumerable
Visual C++
generic<typename TElement>
public ref class Filterable : public Pageable<TElement>,
    IFilterable<TElement>, IPageable<TElement>, IEnumerable<T>, IEnumerable

Type Parameters

TElement
The type of the element.

Inheritance Hierarchy

System..::..Object
Sitecore.Common..::..Pageable <(Of <(<'TElement>)>)>
Sitecore.Common..::..Filterable<(Of <(<'TElement>)>)>

See Also

Filterable<(Of <(<'TElement>)>)> Members
Sitecore.Common Namespace


Filterable(TElement) Members

[image] [image]

Sitecore 6.4.1 API
Filterable<(Of <(<'TElement>)>)> Members
Filterable<(Of <(<'TElement>)>)> Class Constructors Methods See Also Send Feedback

The Filterable<(Of <(<'TElement>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | Filterable<(Of <(<'TElement>)>)> | Initializes a new instance of the Filterable<(Of <(<'TElement>)>)> class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAll | Gets all elements. (Inherited from Pageable<(Of <(<'TElement>)>)>.)
Public method | GetCount()()()() | Gets the number of elements. (Inherited from Pageable<(Of <(<'TElement>)>)>.)
Public method | GetCount(String) | Gets the number of elements matching the specified filter.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from Pageable<(Of <(<'TElement>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPage(Int32, Int32) | Gets a page of elements. (Inherited from Pageable<(Of <(<'TElement>)>)>.)
Public method | GetPage(Int32, Int32, String) | Gets a page of filtered elements.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | Convert<(Of <<'(T, TTo>)>>) | Converts this instance. (Defined by EnumerableExtensions.)
Public Extension Method | StringConcatenate<(Of <<'(T>)>>) | Concatenate strings (Defined by IEnumerableExtensions.)

See Also

Filterable<(Of <(<'TElement>)>)> Class
Sitecore.Common Namespace


Filterable(TElement) Constructor

[image]

Sitecore 6.4.1 API
Filterable<(Of <(<'TElement>)>)> Constructor
Filterable<(Of <(<'TElement>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Filterable(
    Func<int, int, IEnumerable<TElement>> getPage,
    Func<IEnumerable<TElement>> getAll,
    Func<int> getCount,
    Func<int, int, string, IEnumerable<TElement>> getFiltered,
    Func<string, int> getFilteredCount
)
Visual Basic
Public Sub New ( _
    getPage As Func(Of Integer, Integer, IEnumerable(Of TElement)), _
    getAll As Func(Of IEnumerable(Of TElement)), _
    getCount As Func(Of Integer), _
    getFiltered As Func(Of Integer, Integer, String, IEnumerable(Of TElement)), _
    getFilteredCount As Func(Of String, Integer) _
)
Visual C++
public:
Filterable(
    Func<int, int, IEnumerable<TElement>^>^ getPage,
    Func<IEnumerable<TElement>^>^ getAll,
    Func<int>^ getCount,
    Func<int, int, String^, IEnumerable<TElement>^>^ getFiltered,
    Func<String^, int>^ getFilteredCount
)

Parameters

getPage
Type: System..::..Func <(Of <(<' Int32, Int32, IEnumerable <(Of <(<' TElement >)>)>>)>)>
The 'get single page of elements' delegate.
getAll
Type: System..::..Func <(Of <(<' IEnumerable <(Of <(<' TElement >)>)>>)>)>
The 'get all elements' delegate.
getCount
Type: System..::..Func <(Of <(<' Int32 >)>)>
The 'get number of elements' delegate.
getFiltered
Type: System..::..Func <(Of <(<' Int32, Int32, String, IEnumerable <(Of <(<' TElement >)>)>>)>)>
The 'get filtered elements' delegate.
getFilteredCount
Type: System..::..Func <(Of <(<' String, Int32 >)>)>
The get filtered count.

See Also

Filterable<(Of <(<'TElement>)>)> Class
Sitecore.Common Namespace


Filterable(TElement) Methods

[image] [image]

Sitecore 6.4.1 API
Filterable<(Of <(<'TElement>)>)> Methods
Filterable<(Of <(<'TElement>)>)> Class See Also Send Feedback

The Filterable<(Of <(<'TElement>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAll | Gets all elements. (Inherited from Pageable<(Of <(<'TElement>)>)>.)
Public method | GetCount()()()() | Gets the number of elements. (Inherited from Pageable<(Of <(<'TElement>)>)>.)
Public method | GetCount(String) | Gets the number of elements matching the specified filter.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from Pageable<(Of <(<'TElement>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPage(Int32, Int32) | Gets a page of elements. (Inherited from Pageable<(Of <(<'TElement>)>)>.)
Public method | GetPage(Int32, Int32, String) | Gets a page of filtered elements.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | Convert<(Of <<'(T, TTo>)>>) | Converts this instance. (Defined by EnumerableExtensions.)
Public Extension Method | StringConcatenate<(Of <<'(T>)>>) | Concatenate strings (Defined by IEnumerableExtensions.)

See Also

Filterable<(Of <(<'TElement>)>)> Class
Sitecore.Common Namespace


GetCount Method

[image] [image]

Sitecore 6.4.1 API
Filterable<(Of <(<'TElement>)>)>..::..GetCount Method
Filterable<(Of <(<'TElement>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetCount()()()() | Gets the number of elements. (Inherited from Pageable<(Of <(<'TElement>)>)>.)
Public method | GetCount(String) | Gets the number of elements matching the specified filter.

See Also

Filterable<(Of <(<'TElement>)>)> Class
Filterable<(Of <(<'TElement>)>)> Members
Sitecore.Common Namespace


GetCount Method (String)

[image]

Sitecore 6.4.1 API
Filterable<(Of <(<'TElement>)>)>..::..GetCount Method (String)
Filterable<(Of <(<'TElement>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int GetCount(
    string filter
)
Visual Basic
Public Function GetCount ( _
    filter As String _
) As Integer
Visual C++
public:
virtual int GetCount(
    String^ filter
) sealed

Parameters

filter
Type: System..::..String

[Missing <param name="filter"/> documentation for "M:Sitecore.Common.Filterable`1.GetCount(System.String)"]

Field Value

The number of elements.

Return Value

[Missing <returns> documentation for "M:Sitecore.Common.Filterable`1.GetCount(System.String)"]

Implements

IFilterable<(Of <(<'TElement>)>)>..::..GetCount(String)

See Also

Filterable<(Of <(<'TElement>)>)> Class
GetCount Overload
Sitecore.Common Namespace


GetPage Method

[image] [image]

Sitecore 6.4.1 API
Filterable<(Of <(<'TElement>)>)>..::..GetPage Method
Filterable<(Of <(<'TElement>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPage(Int32, Int32) | Gets a page of elements. (Inherited from Pageable<(Of <(<'TElement>)>)>.)
Public method | GetPage(Int32, Int32, String) | Gets a page of filtered elements.

See Also

Filterable<(Of <(<'TElement>)>)> Class
Filterable<(Of <(<'TElement>)>)> Members
Sitecore.Common Namespace


ICommand(TReturnType) Interface

[image]

Sitecore 6.4.1 API
ICommand<(Of <(<'TReturnType>)>)> Interface
Members See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface ICommand<TReturnType>
Visual Basic
Public Interface ICommand(Of TReturnType)
Visual C++
generic<typename TReturnType>
public interface class ICommand

Type Parameters

TReturnType

[Missing <typeparam name="TReturnType"/> documentation for "T:Sitecore.Common.ICommand`1"]

See Also

ICommand<(Of <(<'TReturnType>)>)> Members
Sitecore.Common Namespace


ICommand(TReturnType) Members

[image] [image]

Sitecore 6.4.1 API
ICommand<(Of <(<'TReturnType>)>)> Members
ICommand<(Of <(<'TReturnType>)>)> Interface Methods See Also Send Feedback

The ICommand<(Of <(<'TReturnType>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Execute | Executes the command.

See Also

ICommand<(Of <(<'TReturnType>)>)> Interface
Sitecore.Common Namespace


ICommand(TReturnType) Methods

[image] [image]

Sitecore 6.4.1 API
ICommand<(Of <(<'TReturnType>)>)> Methods
ICommand<(Of <(<'TReturnType>)>)> Interface See Also Send Feedback

The ICommand<(Of <(<'TReturnType>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Execute | Executes the command.

See Also

ICommand<(Of <(<'TReturnType>)>)> Interface
Sitecore.Common Namespace


Execute Method

[image]

Sitecore 6.4.1 API
ICommand<(Of <(<'TReturnType>)>)>..::..Execute Method
ICommand<(Of <(<'TReturnType>)>)> Interface See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
TReturnType Execute()
Visual Basic
Function Execute As TReturnType
Visual C++
TReturnType Execute()

Return Value

[Missing <returns> documentation for "M:Sitecore.Common.ICommand`1.Execute"]

See Also

ICommand<(Of <(<'TReturnType>)>)> Interface
Sitecore.Common Namespace


IFilterable(TElement) Interface

[image]

Sitecore 6.4.1 API
IFilterable<(Of <(<'TElement>)>)> Interface
Members See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IFilterable<TElement> : IPageable<TElement>,
    IEnumerable<T>, IEnumerable
Visual Basic
Public Interface IFilterable(Of TElement) _
    Inherits IPageable(Of TElement), IEnumerable(Of T),  _
    IEnumerable
Visual C++
generic<typename TElement>
public interface class IFilterable : IPageable<TElement>,
    IEnumerable<T>, IEnumerable

Type Parameters

TElement
The type of the element.

See Also

IFilterable<(Of <(<'TElement>)>)> Members
Sitecore.Common Namespace


IFilterable(TElement) Members

[image] [image]

Sitecore 6.4.1 API
IFilterable<(Of <(<'TElement>)>)> Members
IFilterable<(Of <(<'TElement>)>)> Interface Methods See Also Send Feedback

The IFilterable<(Of <(<'TElement>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | GetAll | Gets all elements. (Inherited from IPageable<(Of <(<'TElement>)>)>.)
Public method | GetCount()()()() | Gets the number of elements. (Inherited from IPageable<(Of <(<'TElement>)>)>.)
Public method | GetCount(String) | Gets the number of elements matching the specified filter.
Public method | GetEnumerator()()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable <(Of <(<' T >)>)>.)
Public method | GetEnumerator()()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | GetPage(Int32, Int32) | Gets a page of elements. (Inherited from IPageable<(Of <(<'TElement>)>)>.)
Public method | GetPage(Int32, Int32, String) | Gets a page of filtered elements.

Extension Methods

 | Name | Description
Public Extension Method | Convert<(Of <<'(T, TTo>)>>) | Converts this instance. (Defined by EnumerableExtensions.)
Public Extension Method | StringConcatenate<(Of <<'(T>)>>) | Concatenate strings (Defined by IEnumerableExtensions.)

See Also

IFilterable<(Of <(<'TElement>)>)> Interface
Sitecore.Common Namespace


IFilterable(TElement) Methods

[image] [image]

Sitecore 6.4.1 API
IFilterable<(Of <(<'TElement>)>)> Methods
IFilterable<(Of <(<'TElement>)>)> Interface See Also Send Feedback

The IFilterable<(Of <(<'TElement>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | GetAll | Gets all elements. (Inherited from IPageable<(Of <(<'TElement>)>)>.)
Public method | GetCount()()()() | Gets the number of elements. (Inherited from IPageable<(Of <(<'TElement>)>)>.)
Public method | GetCount(String) | Gets the number of elements matching the specified filter.
Public method | GetEnumerator()()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable <(Of <(<' T >)>)>.)
Public method | GetEnumerator()()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | GetPage(Int32, Int32) | Gets a page of elements. (Inherited from IPageable<(Of <(<'TElement>)>)>.)
Public method | GetPage(Int32, Int32, String) | Gets a page of filtered elements.

Extension Methods

 | Name | Description
Public Extension Method | Convert<(Of <<'(T, TTo>)>>) | Converts this instance. (Defined by EnumerableExtensions.)
Public Extension Method | StringConcatenate<(Of <<'(T>)>>) | Concatenate strings (Defined by IEnumerableExtensions.)

See Also

IFilterable<(Of <(<'TElement>)>)> Interface
Sitecore.Common Namespace


GetCount Method

[image] [image]

Sitecore 6.4.1 API
IFilterable<(Of <(<'TElement>)>)>..::..GetCount Method
IFilterable<(Of <(<'TElement>)>)> Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetCount()()()() | Gets the number of elements. (Inherited from IPageable<(Of <(<'TElement>)>)>.)
Public method | GetCount(String) | Gets the number of elements matching the specified filter.

See Also

IFilterable<(Of <(<'TElement>)>)> Interface
IFilterable<(Of <(<'TElement>)>)> Members
Sitecore.Common Namespace


GetCount Method (String)

[image]

Sitecore 6.4.1 API
IFilterable<(Of <(<'TElement>)>)>..::..GetCount Method (String)
IFilterable<(Of <(<'TElement>)>)> Interface See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
int GetCount(
    string filter
)
Visual Basic
Function GetCount ( _
    filter As String _
) As Integer
Visual C++
int GetCount(
    String^ filter
)

Parameters

filter
Type: System..::..String

[Missing <param name="filter"/> documentation for "M:Sitecore.Common.IFilterable`1.GetCount(System.String)"]

Field Value

The number of elements.

Return Value

[Missing <returns> documentation for "M:Sitecore.Common.IFilterable`1.GetCount(System.String)"]

See Also

IFilterable<(Of <(<'TElement>)>)> Interface
GetCount Overload
Sitecore.Common Namespace


GetEnumerator Method

[image] [image]

Sitecore 6.4.1 API
IFilterable<(Of <(<'TElement>)>)>..::..GetEnumerator Method
IFilterable<(Of <(<'TElement>)>)> Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetEnumerator()()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable <(Of <(<' T >)>)>.)
Public method | GetEnumerator()()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

IFilterable<(Of <(<'TElement>)>)> Interface
IFilterable<(Of <(<'TElement>)>)> Members
Sitecore.Common Namespace


GetPage Method

[image] [image]

Sitecore 6.4.1 API
IFilterable<(Of <(<'TElement>)>)>..::..GetPage Method
IFilterable<(Of <(<'TElement>)>)> Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPage(Int32, Int32) | Gets a page of elements. (Inherited from IPageable<(Of <(<'TElement>)>)>.)
Public method | GetPage(Int32, Int32, String) | Gets a page of filtered elements.

See Also

IFilterable<(Of <(<'TElement>)>)> Interface
IFilterable<(Of <(<'TElement>)>)> Members
Sitecore.Common Namespace


GetPage Method (Int32, Int32, String)

[image]

Sitecore 6.4.1 API
IFilterable<(Of <(<'TElement>)>)>..::..GetPage Method (Int32, Int32, String)
IFilterable<(Of <(<'TElement>)>)> Interface See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
IEnumerable<TElement> GetPage(
    int pageIndex,
    int pageSize,
    string filter
)
Visual Basic
Function GetPage ( _
    pageIndex As Integer, _
    pageSize As Integer, _
    filter As String _
) As IEnumerable(Of TElement)
Visual C++
IEnumerable<TElement>^ GetPage(
    int pageIndex,
    int pageSize,
    String^ filter
)

Parameters

pageIndex
Type: System..::..Int32
Index of the page.
pageSize
Type: System..::..Int32
Size of the page.
filter
Type: System..::..String
The filter. This will be a simple string to match. It is up to the implementation to decide how to use this (search single/multiple column(s), use LIKE or exact matches, etc.).

Return Value

[Missing <returns> documentation for "M:Sitecore.Common.IFilterable`1.GetPage(System.Int32,System.Int32,System.String)"]

See Also

IFilterable<(Of <(<'TElement>)>)> Interface
GetPage Overload
Sitecore.Common Namespace


IPageable(TElement) Interface

[image]

Sitecore 6.4.1 API
IPageable<(Of <(<'TElement>)>)> Interface
Members See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IPageable<TElement> : IEnumerable<T>,
    IEnumerable
Visual Basic
Public Interface IPageable(Of TElement) _
    Inherits IEnumerable(Of T), IEnumerable
Visual C++
generic<typename TElement>
public interface class IPageable : IEnumerable<T>,
    IEnumerable

Type Parameters

TElement
The type of the element.

See Also

IPageable<(Of <(<'TElement>)>)> Members
Sitecore.Common Namespace


IPageable(TElement) Members

[image] [image]

Sitecore 6.4.1 API
IPageable<(Of <(<'TElement>)>)> Members
IPageable<(Of <(<'TElement>)>)> Interface Methods See Also Send Feedback

The IPageable<(Of <(<'TElement>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | GetAll | Gets all elements.
Public method | GetCount | Gets the number of elements.
Public method | GetEnumerator()()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable <(Of <(<' T >)>)>.)
Public method | GetEnumerator()()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | GetPage | Gets a page of elements.

Extension Methods

 | Name | Description
Public Extension Method | Convert<(Of <<'(T, TTo>)>>) | Converts this instance. (Defined by EnumerableExtensions.)
Public Extension Method | StringConcatenate<(Of <<'(T>)>>) | Concatenate strings (Defined by IEnumerableExtensions.)

See Also

IPageable<(Of <(<'TElement>)>)> Interface
Sitecore.Common Namespace


IPageable(TElement) Methods

[image] [image]

Sitecore 6.4.1 API
IPageable<(Of <(<'TElement>)>)> Methods
IPageable<(Of <(<'TElement>)>)> Interface See Also Send Feedback

The IPageable<(Of <(<'TElement>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | GetAll | Gets all elements.
Public method | GetCount | Gets the number of elements.
Public method | GetEnumerator()()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable <(Of <(<' T >)>)>.)
Public method | GetEnumerator()()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | GetPage | Gets a page of elements.

Extension Methods

 | Name | Description
Public Extension Method | Convert<(Of <<'(T, TTo>)>>) | Converts this instance. (Defined by EnumerableExtensions.)
Public Extension Method | StringConcatenate<(Of <<'(T>)>>) | Concatenate strings (Defined by IEnumerableExtensions.)

See Also

IPageable<(Of <(<'TElement>)>)> Interface
Sitecore.Common Namespace


GetAll Method

[image]

Sitecore 6.4.1 API
IPageable<(Of <(<'TElement>)>)>..::..GetAll Method
IPageable<(Of <(<'TElement>)>)> Interface See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
IEnumerable<TElement> GetAll()
Visual Basic
Function GetAll As IEnumerable(Of TElement)
Visual C++
IEnumerable<TElement>^ GetAll()

Return Value

[Missing <returns> documentation for "M:Sitecore.Common.IPageable`1.GetAll"]

See Also

IPageable<(Of <(<'TElement>)>)> Interface
Sitecore.Common Namespace


GetCount Method

[image]

Sitecore 6.4.1 API
IPageable<(Of <(<'TElement>)>)>..::..GetCount Method
IPageable<(Of <(<'TElement>)>)> Interface See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
int GetCount()
Visual Basic
Function GetCount As Integer
Visual C++
int GetCount()

Field Value

The number of elements.

Return Value

[Missing <returns> documentation for "M:Sitecore.Common.IPageable`1.GetCount"]

See Also

IPageable<(Of <(<'TElement>)>)> Interface
Sitecore.Common Namespace


GetEnumerator Method

[image] [image]

Sitecore 6.4.1 API
IPageable<(Of <(<'TElement>)>)>..::..GetEnumerator Method
IPageable<(Of <(<'TElement>)>)> Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetEnumerator()()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable <(Of <(<' T >)>)>.)
Public method | GetEnumerator()()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

IPageable<(Of <(<'TElement>)>)> Interface
IPageable<(Of <(<'TElement>)>)> Members
Sitecore.Common Namespace


GetPage Method

[image]

Sitecore 6.4.1 API
IPageable<(Of <(<'TElement>)>)>..::..GetPage Method
IPageable<(Of <(<'TElement>)>)> Interface See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
IEnumerable<TElement> GetPage(
    int pageIndex,
    int pageSize
)
Visual Basic
Function GetPage ( _
    pageIndex As Integer, _
    pageSize As Integer _
) As IEnumerable(Of TElement)
Visual C++
IEnumerable<TElement>^ GetPage(
    int pageIndex,
    int pageSize
)

Parameters

pageIndex
Type: System..::..Int32
Index of the page.
pageSize
Type: System..::..Int32
Size of the page.

Return Value

[Missing <returns> documentation for "M:Sitecore.Common.IPageable`1.GetPage(System.Int32,System.Int32)"]

See Also

IPageable<(Of <(<'TElement>)>)> Interface
Sitecore.Common Namespace


IPrototype(TObjectType) Interface

[image]

Sitecore 6.4.1 API
IPrototype<(Of <(<'TObjectType>)>)> Interface
Members See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IPrototype<TObjectType>
Visual Basic
Public Interface IPrototype(Of TObjectType)
Visual C++
generic<typename TObjectType>
public interface class IPrototype

Type Parameters

TObjectType

[Missing <typeparam name="TObjectType"/> documentation for "T:Sitecore.Common.IPrototype`1"]

See Also

IPrototype<(Of <(<'TObjectType>)>)> Members
Sitecore.Common Namespace


IPrototype(TObjectType) Members

[image] [image]

Sitecore 6.4.1 API
IPrototype<(Of <(<'TObjectType>)>)> Members
IPrototype<(Of <(<'TObjectType>)>)> Interface Methods See Also Send Feedback

The IPrototype<(Of <(<'TObjectType>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones the source object. Has the same effect as creating a new instance of the type.

See Also

IPrototype<(Of <(<'TObjectType>)>)> Interface
Sitecore.Common Namespace


IPrototype(TObjectType) Methods

[image] [image]

Sitecore 6.4.1 API
IPrototype<(Of <(<'TObjectType>)>)> Methods
IPrototype<(Of <(<'TObjectType>)>)> Interface See Also Send Feedback

The IPrototype<(Of <(<'TObjectType>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones the source object. Has the same effect as creating a new instance of the type.

See Also

IPrototype<(Of <(<'TObjectType>)>)> Interface
Sitecore.Common Namespace


Pageable(TElement) Class

[image]

Sitecore 6.4.1 API
Pageable<(Of <(<'TElement>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Pageable<TElement> : IPageable<TElement>,
    IEnumerable<T>, IEnumerable
Visual Basic
Public Class Pageable(Of TElement) _
    Implements IPageable(Of TElement), IEnumerable(Of T),  _
    IEnumerable
Visual C++
generic<typename TElement>
public ref class Pageable : IPageable<TElement>,
    IEnumerable<T>, IEnumerable

Type Parameters

TElement
The type of the element.

Inheritance Hierarchy

System..::..Object
Sitecore.Common..::..Pageable<(Of <(<'TElement>)>)>
Sitecore.Common..::..Filterable<(Of <(<'TElement>)>)>

See Also

Pageable<(Of <(<'TElement>)>)> Members
Sitecore.Common Namespace


Pageable(TElement) Members

[image] [image]

Sitecore 6.4.1 API
Pageable<(Of <(<'TElement>)>)> Members
Pageable<(Of <(<'TElement>)>)> Class Constructors Methods Properties See Also Send Feedback

The Pageable<(Of <(<'TElement>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | Pageable<(Of <(<'TElement>)>)> | Initializes a new instance of the Pageable<(Of <(<'TElement>)>)> class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAll | Gets all elements.
Public method | GetCount | Gets the number of elements.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPage | Gets a page of elements.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | Convert<(Of <<'(T, TTo>)>>) | Converts this instance. (Defined by EnumerableExtensions.)
Public Extension Method | StringConcatenate<(Of <<'(T>)>>) | Concatenate strings (Defined by IEnumerableExtensions.)

Properties

Name | Description
Empty | Gets the 'empty' Pageable.

See Also

Pageable<(Of <(<'TElement>)>)> Class
Sitecore.Common Namespace


Pageable(TElement) Constructor

[image]

Sitecore 6.4.1 API
Pageable<(Of <(<'TElement>)>)> Constructor
Pageable<(Of <(<'TElement>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Pageable(
    Func<int, int, IEnumerable<TElement>> getPage,
    Func<IEnumerable<TElement>> getAll,
    Func<int> getCount
)
Visual Basic
Public Sub New ( _
    getPage As Func(Of Integer, Integer, IEnumerable(Of TElement)), _
    getAll As Func(Of IEnumerable(Of TElement)), _
    getCount As Func(Of Integer) _
)
Visual C++
public:
Pageable(
    Func<int, int, IEnumerable<TElement>^>^ getPage,
    Func<IEnumerable<TElement>^>^ getAll,
    Func<int>^ getCount
)

Parameters

getPage
Type: System..::..Func <(Of <(<' Int32, Int32, IEnumerable <(Of <(<' TElement >)>)>>)>)>
The 'get single page of elements' delegate.
getAll
Type: System..::..Func <(Of <(<' IEnumerable <(Of <(<' TElement >)>)>>)>)>
The 'get all elements' delegate.
getCount
Type: System..::..Func <(Of <(<' Int32 >)>)>
The 'get number of elements' delegate.

See Also

Pageable<(Of <(<'TElement>)>)> Class
Sitecore.Common Namespace


Pageable(TElement) Methods

[image] [image]

Sitecore 6.4.1 API
Pageable<(Of <(<'TElement>)>)> Methods
Pageable<(Of <(<'TElement>)>)> Class See Also Send Feedback

The Pageable<(Of <(<'TElement>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAll | Gets all elements.
Public method | GetCount | Gets the number of elements.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPage | Gets a page of elements.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | Convert<(Of <<'(T, TTo>)>>) | Converts this instance. (Defined by EnumerableExtensions.)
Public Extension Method | StringConcatenate<(Of <<'(T>)>>) | Concatenate strings (Defined by IEnumerableExtensions.)

See Also

Pageable<(Of <(<'TElement>)>)> Class
Sitecore.Common Namespace


GetCount Method

[image]

Sitecore 6.4.1 API
Pageable<(Of <(<'TElement>)>)>..::..GetCount Method
Pageable<(Of <(<'TElement>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int GetCount()
Visual Basic
Public Function GetCount As Integer
Visual C++
public:
virtual int GetCount() sealed

Field Value

The number of elements.

Return Value

[Missing <returns> documentation for "M:Sitecore.Common.Pageable`1.GetCount"]

Implements

IPageable<(Of <(<'TElement>)>)>..::..GetCount()()()()

See Also

Pageable<(Of <(<'TElement>)>)> Class
Sitecore.Common Namespace


GetEnumerator Method

[image]

Sitecore 6.4.1 API
Pageable<(Of <(<'TElement>)>)>..::..GetEnumerator Method
Pageable<(Of <(<'TElement>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IEnumerator<TElement> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of TElement)
Visual C++
public:
virtual IEnumerator<TElement>^ GetEnumerator() sealed

Return Value

A IEnumerator<(Of <(<'T>)>)> that can be used to iterate through the collection.

See Also

Pageable<(Of <(<'TElement>)>)> Class
Sitecore.Common Namespace


GetPage Method

[image]

Sitecore 6.4.1 API
Pageable<(Of <(<'TElement>)>)>..::..GetPage Method
Pageable<(Of <(<'TElement>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IEnumerable<TElement> GetPage(
    int pageIndex,
    int pageSize
)
Visual Basic
Public Function GetPage ( _
    pageIndex As Integer, _
    pageSize As Integer _
) As IEnumerable(Of TElement)
Visual C++
public:
virtual IEnumerable<TElement>^ GetPage(
    int pageIndex,
    int pageSize
) sealed

Parameters

pageIndex
Type: System..::..Int32
Index of the page.
pageSize
Type: System..::..Int32
Size of the page.

Return Value

[Missing <returns> documentation for "M:Sitecore.Common.Pageable`1.GetPage(System.Int32,System.Int32)"]

Implements

IPageable<(Of <(<'TElement>)>)>..::..GetPage(Int32, Int32)

See Also

Pageable<(Of <(<'TElement>)>)> Class
Sitecore.Common Namespace


Pageable(TElement) Properties

[image] [image]

Sitecore 6.4.1 API
Pageable<(Of <(<'TElement>)>)> Properties
Pageable<(Of <(<'TElement>)>)> Class See Also Send Feedback

The Pageable<(Of <(<'TElement>)>)> type exposes the following members.

Properties

Name | Description
Empty | Gets the 'empty' Pageable.

See Also

Pageable<(Of <(<'TElement>)>)> Class
Sitecore.Common Namespace


Empty Property

[image]

Sitecore 6.4.1 API
Pageable<(Of <(<'TElement>)>)>..::..Empty Property
Pageable<(Of <(<'TElement>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Pageable<TElement> Empty { get; }
Visual Basic
Public Shared ReadOnly Property Empty As Pageable(Of TElement)
    Get
Visual C++
public:
static property Pageable<TElement>^ Empty {
    Pageable<TElement>^ get ();
}

Field Value

The empty.

See Also

Pageable<(Of <(<'TElement>)>)> Class
Sitecore.Common Namespace


PageableList(TElement) Constructor

[image] [image]

Sitecore 6.4.1 API
PageableList<(Of <(<'TElement>)>)> Constructor
PageableList<(Of <(<'TElement>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PageableList<(Of <(<'TElement>)>)>(IEnumerable<(Of <<'(TElement>)>>)) | Initializes a new instance of the PageableList<(Of <(<'TElement>)>)> class.
Public method | PageableList<(Of <(<'TElement>)>)>(List<(Of <<'(TElement>)>>)) | Initializes a new instance of the PageableList<(Of <(<'TElement>)>)> class.

See Also

PageableList<(Of <(<'TElement>)>)> Class
PageableList<(Of <(<'TElement>)>)> Members
Sitecore.Common Namespace


PageableList(TElement) Constructor (IEnumerable(TElement))

[image]

Sitecore 6.4.1 API
PageableList<(Of <(<'TElement>)>)> Constructor (IEnumerable<(Of <(<'TElement>)>)>)
PageableList<(Of <(<'TElement>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PageableList(
    IEnumerable<TElement> elements
)
Visual Basic
Public Sub New ( _
    elements As IEnumerable(Of TElement) _
)
Visual C++
public:
PageableList(
    IEnumerable<TElement>^ elements
)

Parameters

elements
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' TElement >)>)>
The elements.

See Also

PageableList<(Of <(<'TElement>)>)> Class
PageableList<(Of <(<'TElement>)>)> Overload
Sitecore.Common Namespace


GetAll Method

[image]

Sitecore 6.4.1 API
PageableList<(Of <(<'TElement>)>)>..::..GetAll Method
PageableList<(Of <(<'TElement>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IEnumerable<TElement> GetAll()
Visual Basic
Public Function GetAll As IEnumerable(Of TElement)
Visual C++
public:
virtual IEnumerable<TElement>^ GetAll() sealed

Return Value

[Missing <returns> documentation for "M:Sitecore.Common.PageableList`1.GetAll"]

See Also

PageableList<(Of <(<'TElement>)>)> Class
Sitecore.Common Namespace


GetCount Method

[image]

Sitecore 6.4.1 API
PageableList<(Of <(<'TElement>)>)>..::..GetCount Method
PageableList<(Of <(<'TElement>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int GetCount()
Visual Basic
Public Function GetCount As Integer
Visual C++
public:
virtual int GetCount() sealed

Field Value

The number of elements.

Return Value

[Missing <returns> documentation for "M:Sitecore.Common.PageableList`1.GetCount"]

Implements

IPageable<(Of <(<'TElement>)>)>..::..GetCount()()()()

See Also

PageableList<(Of <(<'TElement>)>)> Class
Sitecore.Common Namespace


GetEnumerator Method

[image]

Sitecore 6.4.1 API
PageableList<(Of <(<'TElement>)>)>..::..GetEnumerator Method
PageableList<(Of <(<'TElement>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IEnumerator<TElement> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of TElement)
Visual C++
public:
virtual IEnumerator<TElement>^ GetEnumerator() sealed

Return Value

A IEnumerator<(Of <(<'T>)>)> that can be used to iterate through the collection.

See Also

PageableList<(Of <(<'TElement>)>)> Class
Sitecore.Common Namespace


GetPage Method

[image]

Sitecore 6.4.1 API
PageableList<(Of <(<'TElement>)>)>..::..GetPage Method
PageableList<(Of <(<'TElement>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IEnumerable<TElement> GetPage(
    int pageIndex,
    int pageSize
)
Visual Basic
Public Function GetPage ( _
    pageIndex As Integer, _
    pageSize As Integer _
) As IEnumerable(Of TElement)
Visual C++
public:
virtual IEnumerable<TElement>^ GetPage(
    int pageIndex,
    int pageSize
) sealed

Parameters

pageIndex
Type: System..::..Int32
Index of the page.
pageSize
Type: System..::..Int32
Size of the page.

Return Value

[Missing <returns> documentation for "M:Sitecore.Common.PageableList`1.GetPage(System.Int32,System.Int32)"]

See Also

PageableList<(Of <(<'TElement>)>)> Class
Sitecore.Common Namespace


PagingHelper(TInput, TOutput) Class

[image]

Sitecore 6.4.1 API
PagingHelper<(Of <(<'TInput, TOutput>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PagingHelper<TInput, TOutput>
where TOutput : class
Visual Basic
Public Class PagingHelper(Of TInput, TOutput As Class)
Visual C++
generic<typename TInput, typename TOutput>
where TOutput : ref class
public ref class PagingHelper

Type Parameters

TInput

[Missing <typeparam name="TInput"/> documentation for "T:Sitecore.Common.PagingHelper`2"]

TOutput

[Missing <typeparam name="TOutput"/> documentation for "T:Sitecore.Common.PagingHelper`2"]

Inheritance Hierarchy

System..::..Object
Sitecore.Common..::..PagingHelper<(Of <(<'TInput, TOutput>)>)>

See Also

PagingHelper<(Of <(<'TInput, TOutput>)>)> Members
Sitecore.Common Namespace


PagingHelper(TInput, TOutput) Members

[image] [image]

Sitecore 6.4.1 API
PagingHelper<(Of <(<'TInput, TOutput>)>)> Members
PagingHelper<(Of <(<'TInput, TOutput>)>)> Class Constructors Methods See Also Send Feedback

The PagingHelper<(Of <(<'TInput, TOutput>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | PagingHelper<(Of <(<'TInput, TOutput>)>)> | Initializes a new instance of the PagingHelper<(Of <(<'TInput, TOutput>)>)> class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRecords | Gets the records.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PagingHelper<(Of <(<'TInput, TOutput>)>)> Class
Sitecore.Common Namespace


PagingHelper(TInput, TOutput) Constructor

[image]

Sitecore 6.4.1 API
PagingHelper<(Of <(<'TInput, TOutput>)>)> Constructor
PagingHelper<(Of <(<'TInput, TOutput>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PagingHelper()
Visual Basic
Public Sub New
Visual C++
public:
PagingHelper()

See Also

PagingHelper<(Of <(<'TInput, TOutput>)>)> Class
Sitecore.Common Namespace


PagingHelper(TInput, TOutput) Methods

[image] [image]

Sitecore 6.4.1 API
PagingHelper<(Of <(<'TInput, TOutput>)>)> Methods
PagingHelper<(Of <(<'TInput, TOutput>)>)> Class See Also Send Feedback

The PagingHelper<(Of <(<'TInput, TOutput>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRecords | Gets the records.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PagingHelper<(Of <(<'TInput, TOutput>)>)> Class
Sitecore.Common Namespace


GetRecords Method

[image]

Sitecore 6.4.1 API
PagingHelper<(Of <(<'TInput, TOutput>)>)>..::..GetRecords Method
PagingHelper<(Of <(<'TInput, TOutput>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public List<TOutput> GetRecords(
    int pageIndex,
    int pageSize,
    IEnumerable<TInput> inputList,
    PagingHelper<(Of <(<'TInput, TOutput>)>)>..::..GetElements getElements,
    out int totalRecords
)
Visual Basic
Public Function GetRecords ( _
    pageIndex As Integer, _
    pageSize As Integer, _
    inputList As IEnumerable(Of TInput), _
    getElements As PagingHelper<(Of <(<'TInput, TOutput>)>)>..::..GetElements, _
    <OutAttribute> ByRef totalRecords As Integer _
) As List(Of TOutput)
Visual C++
public:
List<TOutput>^ GetRecords(
    int pageIndex,
    int pageSize,
    IEnumerable<TInput>^ inputList,
    PagingHelper<(Of <(<'TInput, TOutput>)>)>..::..GetElements^ getElements,
    [OutAttribute] int% totalRecords
)

Parameters

pageIndex
Type: System..::..Int32
Index of the page.
pageSize
Type: System..::..Int32
Size of the page.
inputList
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' TInput >)>)>
The list of elements to process.
getElements
Type: Sitecore.Common..::..PagingHelper<(Of <(<'TInput, TOutput>)>)>..::..GetElements
The function to call for each input element.
totalRecords
Type: System..::..Int32 %
The total number of records in all elements combined.

Return Value

[Missing <returns> documentation for "M:Sitecore.Common.PagingHelper`2.GetRecords(System.Int32,System.Int32,System.Collections.Generic.IEnumerable{`0},Sitecore.Common.PagingHelper{`0,`1}.GetElements,System.Int32@)"]

See Also

PagingHelper<(Of <(<'TInput, TOutput>)>)> Class
Sitecore.Common Namespace


PagingHelper(TInput, TOutput).GetElements Delegate

[image]

Sitecore 6.4.1 API
PagingHelper<(Of <(<'TInput, TOutput>)>)>..::..GetElements Delegate
PagingHelper<(Of <(<'TInput, TOutput>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public delegate Object GetElements(
    TInput source,
    int pageIndex,
    int pageSize,
    out int totalRecords
)
Visual Basic
Public Delegate Function GetElements ( _
    source As TInput, _
    pageIndex As Integer, _
    pageSize As Integer, _
    <OutAttribute> ByRef totalRecords As Integer _
) As Object
Visual C++
public delegate Object^ GetElements(
    TInput source,
    int pageIndex,
    int pageSize,
    [OutAttribute] int% totalRecords
)

Parameters

source
Type: TInput
The source to retrieve records from.
pageIndex
Type: System..::..Int32
The index of the page of results to return.
pageSize
Type: System..::..Int32
The size of each page.
totalRecords
Type: System..::..Int32 %
When this method returns, contains the total number of elements in the source.

Return Value

An object that is either IEnumerable or has a GetEnumerator method.

See Also

Sitecore.Common Namespace


PagingIterator(T) Class

[image]

Sitecore 6.4.1 API
PagingIterator<(Of <(<'T>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PagingIterator<T> : IEnumerable<T>,
    IEnumerable
Visual Basic
Public Class PagingIterator(Of T) _
    Implements IEnumerable(Of T), IEnumerable
Visual C++
generic<typename T>
public ref class PagingIterator : IEnumerable<T>,
    IEnumerable

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Sitecore.Common.PagingIterator`1"]

Inheritance Hierarchy

System..::..Object
Sitecore.Common..::..PagingIterator<(Of <(<'T>)>)>

See Also

PagingIterator<(Of <(<'T>)>)> Members
Sitecore.Common Namespace


PagingIterator(T) Members

[image] [image]

Sitecore 6.4.1 API
PagingIterator<(Of <(<'T>)>)> Members
PagingIterator<(Of <(<'T>)>)> Class Constructors Methods See Also Send Feedback

The PagingIterator<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | PagingIterator<(Of <(<'T>)>)> | Initializes a new instance of the PagingIterator<(Of <(<'T>)>)> class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | Convert<(Of <<'(T, TTo>)>>) | Converts this instance. (Defined by EnumerableExtensions.)
Public Extension Method | StringConcatenate<(Of <<'(T>)>>) | Concatenate strings (Defined by IEnumerableExtensions.)

See Also

PagingIterator<(Of <(<'T>)>)> Class
Sitecore.Common Namespace


PagingIterator(T) Constructor

[image]

Sitecore 6.4.1 API
PagingIterator<(Of <(<'T>)>)> Constructor
PagingIterator<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PagingIterator(
    PagingIterator<(Of <(<'T>)>)>..::..GetPage getPage
)
Visual Basic
Public Sub New ( _
    getPage As PagingIterator<(Of <(<'T>)>)>..::..GetPage _
)
Visual C++
public:
PagingIterator(
    PagingIterator<(Of <(<'T>)>)>..::..GetPage^ getPage
)

Parameters

getPage
Type: Sitecore.Common..::..PagingIterator<(Of <(<'T>)>)>..::..GetPage
The get page delegate.

See Also

PagingIterator<(Of <(<'T>)>)> Class
Sitecore.Common Namespace


PagingIterator(T) Methods

[image] [image]

Sitecore 6.4.1 API
PagingIterator<(Of <(<'T>)>)> Methods
PagingIterator<(Of <(<'T>)>)> Class See Also Send Feedback

The PagingIterator<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | Convert<(Of <<'(T, TTo>)>>) | Converts this instance. (Defined by EnumerableExtensions.)
Public Extension Method | StringConcatenate<(Of <<'(T>)>>) | Concatenate strings (Defined by IEnumerableExtensions.)

See Also

PagingIterator<(Of <(<'T>)>)> Class
Sitecore.Common Namespace


GetEnumerator Method

[image]

Sitecore 6.4.1 API
PagingIterator<(Of <(<'T>)>)>..::..GetEnumerator Method
PagingIterator<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IEnumerator<T> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of T)
Visual C++
public:
virtual IEnumerator<T>^ GetEnumerator() sealed

Return Value

A IEnumerator<(Of <(<'T>)>)> that can be used to iterate through the collection.

See Also

PagingIterator<(Of <(<'T>)>)> Class
Sitecore.Common Namespace


PagingIterator(T).GetPage Delegate

[image]

Sitecore 6.4.1 API
PagingIterator<(Of <(<'T>)>)>..::..GetPage Delegate
PagingIterator<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public delegate IEnumerable GetPage(
    int pageIndex
)
Visual Basic
Public Delegate Function GetPage ( _
    pageIndex As Integer _
) As IEnumerable
Visual C++
public delegate IEnumerable^ GetPage(
    int pageIndex
)

Parameters

pageIndex
Type: System..::..Int32

See Also

Sitecore.Common Namespace


Reference(T) Class

[image]

Sitecore 6.4.1 API
Reference<(Of <(<'T>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Reference<T>
where T : class
Visual Basic
Public Class Reference(Of T As Class)
Visual C++
generic<typename T>
where T : ref class
public ref class Reference

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Sitecore.Common.Reference`1"]

Inheritance Hierarchy

System..::..Object
Sitecore.Common..::..Reference<(Of <(<'T>)>)>

See Also

Reference<(Of <(<'T>)>)> Members
Sitecore.Common Namespace


Reference(T) Members

[image] [image]

Sitecore 6.4.1 API
Reference<(Of <(<'T>)>)> Members
Reference<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The Reference<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | Reference<(Of <(<'T>)>)> | Initializes a new instance of the Reference<(Of <(<'T>)>)> class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | HasValue | Gets a value indicating whether this instance has value.
Public property | Value | Gets the value.

See Also

Reference<(Of <(<'T>)>)> Class
Sitecore.Common Namespace


Reference(T) Constructor

[image]

Sitecore 6.4.1 API
Reference<(Of <(<'T>)>)> Constructor
Reference<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Reference(
    T pointer
)
Visual Basic
Public Sub New ( _
    pointer As T _
)
Visual C++
public:
Reference(
    T pointer
)

Parameters

pointer
Type: T
The pointer.

See Also

Reference<(Of <(<'T>)>)> Class
Sitecore.Common Namespace


Reference(T) Methods

[image] [image]

Sitecore 6.4.1 API
Reference<(Of <(<'T>)>)> Methods
Reference<(Of <(<'T>)>)> Class See Also Send Feedback

The Reference<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reference<(Of <(<'T>)>)> Class
Sitecore.Common Namespace


Reference(T) Properties

[image] [image]

Sitecore 6.4.1 API
Reference<(Of <(<'T>)>)> Properties
Reference<(Of <(<'T>)>)> Class See Also Send Feedback

The Reference<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | HasValue | Gets a value indicating whether this instance has value.
Public property | Value | Gets the value.

See Also

Reference<(Of <(<'T>)>)> Class
Sitecore.Common Namespace


HasValue Property

[image]

Sitecore 6.4.1 API
Reference<(Of <(<'T>)>)>..::..HasValue Property
Reference<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool HasValue { get; }
Visual Basic
Public ReadOnly Property HasValue As Boolean
    Get
Visual C++
public:
property bool HasValue {
    bool get ();
}

Field Value

true if this instance has value; otherwise, false.

See Also

Reference<(Of <(<'T>)>)> Class
Sitecore.Common Namespace


Value Property

[image]

Sitecore 6.4.1 API
Reference<(Of <(<'T>)>)>..::..Value Property
Reference<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public T Value { get; }
Visual Basic
Public ReadOnly Property Value As T
    Get
Visual C++
public:
property T Value {
    T get ();
}

Field Value

The value.

See Also

Reference<(Of <(<'T>)>)> Class
Sitecore.Common Namespace


Serializer Class

[image]

Sitecore 6.4.1 API
Serializer Class
Members See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Serializer
Visual Basic
Public Class Serializer
Visual C++
public ref class Serializer

Inheritance Hierarchy

System..::..Object
Sitecore.Common..::..Serializer

See Also

Serializer Members
Sitecore.Common Namespace


Serializer Members

[image] [image]

Sitecore 6.4.1 API
Serializer Members
Serializer Class Constructors Methods See Also Send Feedback

The Serializer type exposes the following members.

Constructors

 | Name | Description
Public method | Serializer | Initializes a new instance of the Serializer class

Methods

 | Name | Description
Public method | Deserialize(String, Type) | Deserializes the specified data.
Public method | Deserialize<(Of <<'(T>)>>)(String) | Deserializes the specified data.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize(Object) | Serializes the specified data.
Public method | Serialize<(Of <<'(T>)>>)(T) | Serializes the specified data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Serializer Class
Sitecore.Common Namespace


Serializer Constructor

[image]

Sitecore 6.4.1 API
Serializer Constructor
Serializer Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Serializer()
Visual Basic
Public Sub New
Visual C++
public:
Serializer()

See Also

Serializer Class
Sitecore.Common Namespace


Serializer Methods

[image] [image]

Sitecore 6.4.1 API
Serializer Methods
Serializer Class See Also Send Feedback

The Serializer type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize(String, Type) | Deserializes the specified data.
Public method | Deserialize<(Of <<'(T>)>>)(String) | Deserializes the specified data.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize(Object) | Serializes the specified data.
Public method | Serialize<(Of <<'(T>)>>)(T) | Serializes the specified data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Serializer Class
Sitecore.Common Namespace


Deserialize Method

[image] [image]

Sitecore 6.4.1 API
Serializer..::..Deserialize Method
Serializer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Deserialize<(Of <<'(T>)>>)(String) | Deserializes the specified data.
Public method | Deserialize(String, Type) | Deserializes the specified data.

See Also

Serializer Class
Serializer Members
Sitecore.Common Namespace


Deserialize(T) Method (String)

[image]

Sitecore 6.4.1 API
Serializer..::..Deserialize<(Of <(<'T>)>)> Method (String)
Serializer Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public T Deserialize<T>(
    string data
)
Visual Basic
Public Function Deserialize(Of T) ( _
    data As String _
) As T
Visual C++
public:
generic<typename T>
T Deserialize(
    String^ data
)

Parameters

data
Type: System..::..String
The data.

Type Parameters

T
The type.

Return Value

The result.

See Also

Serializer Class
Deserialize Overload
Sitecore.Common Namespace


Deserialize Method (String, Type)

[image]

Sitecore 6.4.1 API
Serializer..::..Deserialize Method (String, Type)
Serializer Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Object Deserialize(
    string data,
    Type resultType
)
Visual Basic
Public Overridable Function Deserialize ( _
    data As String, _
    resultType As Type _
) As Object
Visual C++
public:
virtual Object^ Deserialize(
    String^ data,
    Type^ resultType
)

Parameters

data
Type: System..::..String
The data.
resultType
Type: System..::..Type
Type of the result.

Return Value

The result.

Remarks

There is bug in the Microsoft JSON deserialization. When data contract contains more than 648 non-ANSI characters then an exception occurs. More info: http://social.msdn.microsoft.com/Forums/en-US/wcf/thread/938156c7-ccb5-4436-833d-d560b9901750.

Exceptions

Exception | Condition
System..::..Exception | Exception.

See Also

Serializer Class
Deserialize Overload
Sitecore.Common Namespace


Serialize Method

[image] [image]

Sitecore 6.4.1 API
Serializer..::..Serialize Method
Serializer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Serialize(Object) | Serializes the specified data.
Public method | Serialize<(Of <<'(T>)>>)(T) | Serializes the specified data.

See Also

Serializer Class
Serializer Members
Sitecore.Common Namespace


Serialize Method (Object)

[image]

Sitecore 6.4.1 API
Serializer..::..Serialize Method (Object)
Serializer Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string Serialize(
    Object data
)
Visual Basic
Public Overridable Function Serialize ( _
    data As Object _
) As String
Visual C++
public:
virtual String^ Serialize(
    Object^ data
)

Parameters

data
Type: System..::..Object
The data.

Return Value

The result.

See Also

Serializer Class
Serialize Overload
Sitecore.Common Namespace


Serialize(T) Method (T)

[image]

Sitecore 6.4.1 API
Serializer..::..Serialize<(Of <(<'T>)>)> Method (T)
Serializer Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Serialize<T>(
    T data
)
Visual Basic
Public Function Serialize(Of T) ( _
    data As T _
) As String
Visual C++
public:
generic<typename T>
String^ Serialize(
    T data
)

Parameters

data
Type: T
The data.

Type Parameters

T
The type.

Return Value

The result.

See Also

Serializer Class
Serialize Overload
Sitecore.Common Namespace


SettingsPropertyCollectionExtensions Class

[image]

Sitecore 6.4.1 API
SettingsPropertyCollectionExtensions Class
Members See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class SettingsPropertyCollectionExtensions
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class SettingsPropertyCollectionExtensions
Visual C++
[ExtensionAttribute]
public ref class SettingsPropertyCollectionExtensions abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Common..::..SettingsPropertyCollectionExtensions

See Also

SettingsPropertyCollectionExtensions Members
Sitecore.Common Namespace


SettingsPropertyCollectionExtensions Members

[image] [image]

Sitecore 6.4.1 API
SettingsPropertyCollectionExtensions Members
SettingsPropertyCollectionExtensions Class Methods See Also Send Feedback

The SettingsPropertyCollectionExtensions type exposes the following members.

Methods

Name | Description
Contains | Determines whether SettingsPropertyCollection contains the specified property.

See Also

SettingsPropertyCollectionExtensions Class
Sitecore.Common Namespace


SettingsPropertyCollectionExtensions Methods

[image] [image]

Sitecore 6.4.1 API
SettingsPropertyCollectionExtensions Methods
SettingsPropertyCollectionExtensions Class See Also Send Feedback

The SettingsPropertyCollectionExtensions type exposes the following members.

Methods

Name | Description
Contains | Determines whether SettingsPropertyCollection contains the specified property.

See Also

SettingsPropertyCollectionExtensions Class
Sitecore.Common Namespace


Contains Method

[image]

Sitecore 6.4.1 API
SettingsPropertyCollectionExtensions..::..Contains Method
SettingsPropertyCollectionExtensions Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool Contains(
    this SettingsPropertyCollection propertyCollection,
    string propertyName
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function Contains ( _
    propertyCollection As SettingsPropertyCollection, _
    propertyName As String _
) As Boolean
Visual C++
[ExtensionAttribute]
public:
static bool Contains(
    SettingsPropertyCollection^ propertyCollection,
    String^ propertyName
)

Parameters

propertyCollection
Type: System.Configuration..::..SettingsPropertyCollection
The property collection.
propertyName
Type: System..::..String
Name of the property.

Return Value

true if contains; otherwise, false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SettingsPropertyCollection. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

SettingsPropertyCollectionExtensions Class
Sitecore.Common Namespace


Switcher(T) Class

[image]

Sitecore 6.4.1 API
Switcher<(Of <(<'T>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Switcher<T> : Switcher<T, T>
Visual Basic
Public Class Switcher(Of T) _
    Inherits Switcher(Of T, T)
Visual C++
generic<typename T>
public ref class Switcher : public Switcher<T, T>

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Sitecore.Common.Switcher`1"]

Inheritance Hierarchy

System..::..Object
Sitecore.Common..::..Switcher <(Of <(<'T, T>)>)>
Sitecore.Common..::..Switcher<(Of <(<'T>)>)>
Sitecore.Data.Proxies..::..DomainSwitcher
Sitecore.Security.AccessControl..::..AuthorizationSwitcher
Sitecore.Security.Accounts..::..UserSwitcher
Sitecore.Security.Authentication..::..AuthenticationSwitcher
Sitecore.Security..::..ProfileSwitcher
Sitecore.SecurityModel..::..SecurityStateSwitcher

See Also

Switcher<(Of <(<'T>)>)> Members
Sitecore.Common Namespace


Switcher(T) Members

[image] [image]

Sitecore 6.4.1 API
Switcher<(Of <(<'T>)>)> Members
Switcher<(Of <(<'T>)>)> Class Constructors Methods Events See Also Send Feedback

The Switcher<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Protected method | Switcher<(Of <(<'T>)>)>()()()() | Initializes a new instance of the Switcher<(Of <(<'T>)>)> class.
Public method | Switcher<(Of <(<'T>)>)>(T) | Initializes a new instance of the Switcher<(Of <(<'T>)>)> class.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Switcher<(Of <(<'TValue, TSwitchType>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

 | Name | Description
Protected event | Disposed | Occurs when the object has been disposed. (Inherited from Switcher<(Of <(<'TValue, TSwitchType>)>)>.)

See Also

Switcher<(Of <(<'T>)>)> Class
Sitecore.Common Namespace


Switcher(T) Constructor

[image] [image]

Sitecore 6.4.1 API
Switcher<(Of <(<'T>)>)> Constructor
Switcher<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Switcher<(Of <(<'T>)>)>()()()() | Initializes a new instance of the Switcher<(Of <(<'T>)>)> class.
Public method | Switcher<(Of <(<'T>)>)>(T) | Initializes a new instance of the Switcher<(Of <(<'T>)>)> class.

See Also

Switcher<(Of <(<'T>)>)> Class
Switcher<(Of <(<'T>)>)> Members
Sitecore.Common Namespace


Switcher(T) Constructor

[image]

Sitecore 6.4.1 API
Switcher<(Of <(<'T>)>)> Constructor
Switcher<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Switcher()
Visual Basic
Protected Sub New
Visual C++
protected:
Switcher()

See Also

Switcher<(Of <(<'T>)>)> Class
Switcher<(Of <(<'T>)>)> Overload
Sitecore.Common Namespace


Switcher(T) Constructor (T)

[image]

Sitecore 6.4.1 API
Switcher<(Of <(<'T>)>)> Constructor (T)
Switcher<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Switcher(
    T objectToSwitchTo
)
Visual Basic
Public Sub New ( _
    objectToSwitchTo As T _
)
Visual C++
public:
Switcher(
    T objectToSwitchTo
)

Parameters

objectToSwitchTo
Type: T
The object to switch to.

See Also

Switcher<(Of <(<'T>)>)> Class
Switcher<(Of <(<'T>)>)> Overload
Sitecore.Common Namespace


Switcher(T) Methods

[image] [image]

Sitecore 6.4.1 API
Switcher<(Of <(<'T>)>)> Methods
Switcher<(Of <(<'T>)>)> Class See Also Send Feedback

The Switcher<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Switcher<(Of <(<'TValue, TSwitchType>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Switcher<(Of <(<'T>)>)> Class
Sitecore.Common Namespace


Switcher(T) Events

[image] [image]

Sitecore 6.4.1 API
Switcher<(Of <(<'T>)>)> Events
Switcher<(Of <(<'T>)>)> Class See Also Send Feedback

The Switcher<(Of <(<'T>)>)> type exposes the following members.

Events

 | Name | Description
Protected event | Disposed | Occurs when the object has been disposed. (Inherited from Switcher<(Of <(<'TValue, TSwitchType>)>)>.)

See Also

Switcher<(Of <(<'T>)>)> Class
Sitecore.Common Namespace


Switcher(TValue, TSwitchType) Class

[image]

Sitecore 6.4.1 API
Switcher<(Of <(<'TValue, TSwitchType>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Switcher<TValue, TSwitchType> : IDisposable
Visual Basic
Public Class Switcher(Of TValue, TSwitchType) _
    Implements IDisposable
Visual C++
generic<typename TValue, typename TSwitchType>
public ref class Switcher : IDisposable

Type Parameters

TValue

[Missing <typeparam name="TValue"/> documentation for "T:Sitecore.Common.Switcher`2"]

TSwitchType

[Missing <typeparam name="TSwitchType"/> documentation for "T:Sitecore.Common.Switcher`2"]

Inheritance Hierarchy

System..::..Object
Sitecore.Common..::..Switcher<(Of <(<'TValue, TSwitchType>)>)>
Sitecore.Common..::..CallContextSwitcher
Sitecore.Common..::..Switcher<(Of <(<'T>)>)>
Sitecore.Data..::..DatabaseCacheDisabler
Sitecore.Data.Engines..::..SyncOperationContext
Sitecore.Data.Events..::..EventDisabler
Sitecore.Data.Items..::..ContextItemSwitcher
Sitecore.Links..::..LinkDisabler
Sitecore.Sites..::..SiteContextSwitcher
Sitecore.Text..::..ReplacerContextSwitcher
Sitecore.Web.UI..::..ViewStateDisabler
Sitecore.Web.UI.WebControls..::..PlaceholderSwitcher

See Also

Switcher<(Of <(<'TValue, TSwitchType>)>)> Members
Sitecore.Common Namespace


Switcher(TValue, TSwitchType) Members

[image] [image]

Sitecore 6.4.1 API
Switcher<(Of <(<'TValue, TSwitchType>)>)> Members
Switcher<(Of <(<'TValue, TSwitchType>)>)> Class Constructors Methods Properties Events See Also Send Feedback

The Switcher<(Of <(<'TValue, TSwitchType>)>)> type exposes the following members.

Constructors

 | Name | Description
Protected method | Switcher<(Of <(<'TValue, TSwitchType>)>)>()()()() | Initializes a new instance of the Switcher<(Of <(<'TValue, TSwitchType>)>)> class.
Public method | Switcher<(Of <(<'TValue, TSwitchType>)>)>(TValue) | Initializes a new instance of the Switcher<(Of <(<'TValue, TSwitchType>)>)> class.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
 | Enter | Enters an object instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exit | Exits the current object.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetStack | Gets the stack.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CurrentValue | Gets the current object instance (or default(T) if no switch is active).
ItemsKey | Key used for storing state in Items

Events

 | Name | Description
Protected event | Disposed | Occurs when the object has been disposed.

See Also

Switcher<(Of <(<'TValue, TSwitchType>)>)> Class
Sitecore.Common Namespace


Switcher(TValue, TSwitchType) Constructor

[image] [image]

Sitecore 6.4.1 API
Switcher<(Of <(<'TValue, TSwitchType>)>)> Constructor
Switcher<(Of <(<'TValue, TSwitchType>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Switcher<(Of <(<'TValue, TSwitchType>)>)>()()()() | Initializes a new instance of the Switcher<(Of <(<'TValue, TSwitchType>)>)> class.
Public method | Switcher<(Of <(<'TValue, TSwitchType>)>)>(TValue) | Initializes a new instance of the Switcher<(Of <(<'TValue, TSwitchType>)>)> class.

See Also

Switcher<(Of <(<'TValue, TSwitchType>)>)> Class
Switcher<(Of <(<'TValue, TSwitchType>)>)> Members
Sitecore.Common Namespace


Switcher(TValue, TSwitchType) Constructor

[image]

Sitecore 6.4.1 API
Switcher<(Of <(<'TValue, TSwitchType>)>)> Constructor
Switcher<(Of <(<'TValue, TSwitchType>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Switcher()
Visual Basic
Protected Sub New
Visual C++
protected:
Switcher()

See Also

Switcher<(Of <(<'TValue, TSwitchType>)>)> Class
Switcher<(Of <(<'TValue, TSwitchType>)>)> Overload
Sitecore.Common Namespace


Switcher(TValue, TSwitchType) Constructor (TValue)

[image]

Sitecore 6.4.1 API
Switcher<(Of <(<'TValue, TSwitchType>)>)> Constructor (TValue)
Switcher<(Of <(<'TValue, TSwitchType>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Switcher(
    TValue objectToSwitchTo
)
Visual Basic
Public Sub New ( _
    objectToSwitchTo As TValue _
)
Visual C++
public:
Switcher(
    TValue objectToSwitchTo
)

Parameters

objectToSwitchTo
Type: TValue
The object to switch to.

See Also

Switcher<(Of <(<'TValue, TSwitchType>)>)> Class
Switcher<(Of <(<'TValue, TSwitchType>)>)> Overload
Sitecore.Common Namespace


Switcher(TValue, TSwitchType) Methods

[image] [image]

Sitecore 6.4.1 API
Switcher<(Of <(<'TValue, TSwitchType>)>)> Methods
Switcher<(Of <(<'TValue, TSwitchType>)>)> Class See Also Send Feedback

The Switcher<(Of <(<'TValue, TSwitchType>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
 | Enter | Enters an object instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exit | Exits the current object.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetStack | Gets the stack.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Switcher<(Of <(<'TValue, TSwitchType>)>)> Class
Sitecore.Common Namespace


Dispose Method

[image]

Sitecore 6.4.1 API
Switcher<(Of <(<'TValue, TSwitchType>)>)>..::..Dispose Method
Switcher<(Of <(<'TValue, TSwitchType>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Dispose()
Visual Basic
Public Overridable Sub Dispose
Visual C++
public:
virtual void Dispose()

Implements

IDisposable..::..Dispose()()()()

See Also

Switcher<(Of <(<'TValue, TSwitchType>)>)> Class
Sitecore.Common Namespace


Enter Method

[image]

Sitecore 6.4.1 API
Switcher<(Of <(<'TValue, TSwitchType>)>)>..::..Enter Method
Switcher<(Of <(<'TValue, TSwitchType>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Enter(
    TValue objectToSwitchTo
)
Visual Basic
Public Shared Sub Enter ( _
    objectToSwitchTo As TValue _
)
Visual C++
public:
static void Enter(
    TValue objectToSwitchTo
)

Parameters

objectToSwitchTo
Type: TValue
The object to switch to.

See Also

Switcher<(Of <(<'TValue, TSwitchType>)>)> Class
Sitecore.Common Namespace


Exit Method

[image]

Sitecore 6.4.1 API
Switcher<(Of <(<'TValue, TSwitchType>)>)>..::..Exit Method
Switcher<(Of <(<'TValue, TSwitchType>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Exit()
Visual Basic
Public Shared Sub Exit
Visual C++
public:
static void Exit()

See Also

Switcher<(Of <(<'TValue, TSwitchType>)>)> Class
Sitecore.Common Namespace


GetStack Method

[image]

Sitecore 6.4.1 API
Switcher<(Of <(<'TValue, TSwitchType>)>)>..::..GetStack Method
Switcher<(Of <(<'TValue, TSwitchType>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Stack<TValue> GetStack(
    bool createIfEmpty
)
Visual Basic
Public Shared Function GetStack ( _
    createIfEmpty As Boolean _
) As Stack(Of TValue)
Visual C++
public:
static Stack<TValue>^ GetStack(
    bool createIfEmpty
)

Parameters

createIfEmpty
Type: System..::..Boolean
if set to true null value will never be returned.

Return Value

[Missing <returns> documentation for "M:Sitecore.Common.Switcher`2.GetStack(System.Boolean)"]

See Also

Switcher<(Of <(<'TValue, TSwitchType>)>)> Class
Sitecore.Common Namespace


Switcher(TValue, TSwitchType) Properties

[image] [image]

Sitecore 6.4.1 API
Switcher<(Of <(<'TValue, TSwitchType>)>)> Properties
Switcher<(Of <(<'TValue, TSwitchType>)>)> Class See Also Send Feedback

The Switcher<(Of <(<'TValue, TSwitchType>)>)> type exposes the following members.

Properties

Name | Description
CurrentValue | Gets the current object instance (or default(T) if no switch is active).
ItemsKey | Key used for storing state in Items

See Also

Switcher<(Of <(<'TValue, TSwitchType>)>)> Class
Sitecore.Common Namespace


CurrentValue Property

[image]

Sitecore 6.4.1 API
Switcher<(Of <(<'TValue, TSwitchType>)>)>..::..CurrentValue Property
Switcher<(Of <(<'TValue, TSwitchType>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TValue CurrentValue { get; }
Visual Basic
Public Shared ReadOnly Property CurrentValue As TValue
    Get
Visual C++
public:
static property TValue CurrentValue {
    TValue get ();
}

Field Value

The current group.

See Also

Switcher<(Of <(<'TValue, TSwitchType>)>)> Class
Sitecore.Common Namespace


ItemsKey Property

[image]

Sitecore 6.4.1 API
Switcher<(Of <(<'TValue, TSwitchType>)>)>..::..ItemsKey Property
Switcher<(Of <(<'TValue, TSwitchType>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ItemsKey { get; }
Visual Basic
Public Shared ReadOnly Property ItemsKey As String
    Get
Visual C++
public:
static property String^ ItemsKey {
    String^ get ();
}

See Also

Switcher<(Of <(<'TValue, TSwitchType>)>)> Class
Sitecore.Common Namespace


Switcher(TValue, TSwitchType) Events

[image] [image]

Sitecore 6.4.1 API
Switcher<(Of <(<'TValue, TSwitchType>)>)> Events
Switcher<(Of <(<'TValue, TSwitchType>)>)> Class See Also Send Feedback

The Switcher<(Of <(<'TValue, TSwitchType>)>)> type exposes the following members.

Events

 | Name | Description
Protected event | Disposed | Occurs when the object has been disposed.

See Also

Switcher<(Of <(<'TValue, TSwitchType>)>)> Class
Sitecore.Common Namespace


Disposed Event

[image]

Sitecore 6.4.1 API
Switcher<(Of <(<'TValue, TSwitchType>)>)>..::..Disposed Event
Switcher<(Of <(<'TValue, TSwitchType>)>)> Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected event EventHandler<EventArgs> Disposed
Visual Basic
Protected Event Disposed As EventHandler(Of EventArgs)
Visual C++
protected:
 event EventHandler<EventArgs^>^ Disposed {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

See Also

Switcher<(Of <(<'TValue, TSwitchType>)>)> Class
Sitecore.Common Namespace


Timeline Class

[image]

Sitecore 6.4.1 API
Timeline Class
Members See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Timeline
Visual Basic
Public Class Timeline
Visual C++
public ref class Timeline

Inheritance Hierarchy

System..::..Object
Sitecore.Common..::..Timeline

See Also

Timeline Members
Sitecore.Common Namespace


Timeline Members

[image] [image]

Sitecore 6.4.1 API
Timeline Members
Timeline Class Constructors Methods See Also Send Feedback

The Timeline type exposes the following members.

Constructors

 | Name | Description
Public method | Timeline | Initializes a new instance of the Timeline class.

Methods

 | Name | Description
Public method | Contains | Determines whether the timeline contains the specified date time.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRangeContaining | Gets the range containing the specified date time.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveAfter | Removes everything after the specified date time from the timeline.
Public method | RemoveBefore | Removes everything before the specified date time from the timeline.
Public method | Subtract | Subtracts the specified range.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Timeline Class
Sitecore.Common Namespace


Timeline Constructor

[image]

Sitecore 6.4.1 API
Timeline Constructor
Timeline Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Timeline(
    DateTimeRange range
)
Visual Basic
Public Sub New ( _
    range As DateTimeRange _
)
Visual C++
public:
Timeline(
    DateTimeRange^ range
)

Parameters

range
Type: Sitecore.Common..::..DateTimeRange
The initial range.

See Also

Timeline Class
Sitecore.Common Namespace


Timeline Methods

[image] [image]

Sitecore 6.4.1 API
Timeline Methods
Timeline Class See Also Send Feedback

The Timeline type exposes the following members.

Methods

 | Name | Description
Public method | Contains | Determines whether the timeline contains the specified date time.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRangeContaining | Gets the range containing the specified date time.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveAfter | Removes everything after the specified date time from the timeline.
Public method | RemoveBefore | Removes everything before the specified date time from the timeline.
Public method | Subtract | Subtracts the specified range.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Timeline Class
Sitecore.Common Namespace


Contains Method

[image]

Sitecore 6.4.1 API
Timeline..::..Contains Method
Timeline Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Contains(
    DateTime dateTime
)
Visual Basic
Public Function Contains ( _
    dateTime As DateTime _
) As Boolean
Visual C++
public:
bool Contains(
    DateTime dateTime
)

Parameters

dateTime
Type: System..::..DateTime
The date time.

Return Value

true if the specified date time is contained; otherwise, false.

See Also

Timeline Class
Sitecore.Common Namespace


GetRangeContaining Method

[image]

Sitecore 6.4.1 API
Timeline..::..GetRangeContaining Method
Timeline Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTimeRange GetRangeContaining(
    DateTime dateTime
)
Visual Basic
Public Function GetRangeContaining ( _
    dateTime As DateTime _
) As DateTimeRange
Visual C++
public:
DateTimeRange^ GetRangeContaining(
    DateTime dateTime
)

Parameters

dateTime
Type: System..::..DateTime
The date time.

Return Value

The range. If no range is found, Empty is returned.

See Also

Timeline Class
Sitecore.Common Namespace


RemoveAfter Method

[image]

Sitecore 6.4.1 API
Timeline..::..RemoveAfter Method
Timeline Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RemoveAfter(
    DateTime dateTime
)
Visual Basic
Public Sub RemoveAfter ( _
    dateTime As DateTime _
)
Visual C++
public:
void RemoveAfter(
    DateTime dateTime
)

Parameters

dateTime
Type: System..::..DateTime
The date time.

See Also

Timeline Class
Sitecore.Common Namespace


Subtract Method

[image]

Sitecore 6.4.1 API
Timeline..::..Subtract Method
Timeline Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Subtract(
    DateTimeRange range
)
Visual Basic
Public Sub Subtract ( _
    range As DateTimeRange _
)
Visual C++
public:
void Subtract(
    DateTimeRange^ range
)

Parameters

range
Type: Sitecore.Common..::..DateTimeRange
The range.

See Also

Timeline Class
Sitecore.Common Namespace


TypeExtensions Class

[image]

Sitecore 6.4.1 API
TypeExtensions Class
Members See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class TypeExtensions
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class TypeExtensions
Visual C++
[ExtensionAttribute]
public ref class TypeExtensions abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Common..::..TypeExtensions

See Also

TypeExtensions Members
Sitecore.Common Namespace


TypeExtensions Members

[image] [image]

Sitecore 6.4.1 API
TypeExtensions Members
TypeExtensions Class Methods See Also Send Feedback

The TypeExtensions type exposes the following members.

Methods

Name | Description
ToID | Toes the ID.

See Also

TypeExtensions Class
Sitecore.Common Namespace


TypeExtensions Methods

[image] [image]

Sitecore 6.4.1 API
TypeExtensions Methods
TypeExtensions Class See Also Send Feedback

The TypeExtensions type exposes the following members.

Methods

Name | Description
ToID | Toes the ID.

See Also

TypeExtensions Class
Sitecore.Common Namespace


ToID Method

[image]

Sitecore 6.4.1 API
TypeExtensions..::..ToID Method
TypeExtensions Class See Also Send Feedback

Namespace: Sitecore.Common
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID ToID(
    this Guid value
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function ToID ( _
    value As Guid _
) As ID
Visual C++
[ExtensionAttribute]
public:
static ID^ ToID(
    Guid value
)

Parameters

value
Type: System..::..Guid
The value.

Return Value

The result.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Guid. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

TypeExtensions Class
Sitecore.Common Namespace


Sitecore.Configuration Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Configuration Namespace
Send Feedback

Classes

 | Class | Description
Public class | About | About Sitecore.
Public class | ClientContext | Represents the current client context.
Public class | ClientDataStore | Represents a Client Data Store.
Public class | ConfigChangedEventArgs | ConfigChangedEventArgs class
Public class | ConfigReader | Class to read custom configuration sections.
Public class | ConfigRecord | ConfigRecord class
Public class | ConfigStore | ConfigStore class
Public class | ConfigWatcher | Monitors the /App_Config folder for changes.
Public class | Factory | The Factory.
Public class | FileDataStore | Represents a FileDataStore.
Public class | IDTableWebDAVOptionStore | Stores Web DAV options in Sitecore ID table.
Public class | ObjectList | Represents an object list.
Public class | ProviderHelper<(Of <(<'TProvider, TCollection>)>)> | ManagerData class
Public class | Settings | The Settings class encapsulates the web.config file and provides easy access to the values therein.
Public class | Settings..::..Authentication | The authentication.
Public class | Settings..::..Authorization | The authorization.
Public class | Settings..::..Caching | The caching.
Public class | Settings..::..Caching..::..StandardValues | StandardValues class
Public class | Settings..::..ClientFeeds |
Public class | Settings..::..ContentEditor | Defines Content Editor options.
Public class | Settings..::..Counters | The counters.
Public class | Settings..::..EventQueue | The settings for event queues.
Public class | Settings..::..Feeds | The feeds.
Public class | Settings..::..HtmlEditor | The html editor.
Public class | Settings..::..Icons | Defines the icons class.
Public class | Settings..::..Indexing | The indexing.
Public class | Settings..::..Install | Settings for Install namespace
Public class | Settings..::..Jobs | The jobs.
Public class | Settings..::..Languages | The languages.
Public class | Settings..::..Links | The links.
Public class | Settings..::..Login | The login.
Public class | Settings..::..Media | The media.
Public class | Settings..::..MediaResponse | The media response.
Public class | Settings..::..Performance | The performance.
Public class | Settings..::..Preview | The preview.
Public class | Settings..::..Profiling | Defines profile options.
Public class | Settings..::..Publishing | The publishing.
Public class | Settings..::..Query | The query.
Public class | Settings..::..Rendering | The rendering.
Public class | Settings..::..RequestErrors | Settings controlling behaviour when a request error condition occurs.
Public class | Settings..::..Roles | The roles.
Public class | Settings..::..Rules | Defines the rule sets class.
Public class | Settings..::..Runtime | The runtime.
Public class | Settings..::..Scripts | Defines the scripts class.
Public class | Settings..::..Statistics | The statistics.
Public class | Settings..::..Tasks |
Public class | Settings..::..Templates | The templates.
Public class | Settings..::..Trace | The trace.
Public class | Settings..::..UI | The ui.
Public class | Settings..::..UnitTests | The unit tests.
Public class | Settings..::..Upload | The upload.
Public class | Settings..::..Validators | The validators.
Public class | Settings..::..WebConfig | WebConfig class
Public class | Settings..::..WebDAV | Web DAV settings.
Public class | Settings..::..WebEdit | The web edit.
Public class | Settings..::..WordOCX | Settings for WordOCX
Public class | Settings..::..WorldLingo | The world lingo.
Public class | Settings..::..XmlControls | The xml controls.
Public class | State | Sitecore maintains a state about the current webpage (in the Items collection) and about the current session (in the Session collection). Typical information include the current user, the current web item, the current master item, the current layout etc. The State class encapsulates both the Items and Session collections.
Public class | State..::..Client |
Public class | State..::..HttpRuntime |
Public class | State..::..PageDesigner | PageDesigner state
Public class | State..::..Request |
Public class | State..::..Sites |
Public class | StateContext | Represents the state context.
Public class | WebDAVConfiguration | Web DAV configuration.
Public class | WebDAVConfiguration..::..Authentication | Web DAV Authentication.
Public class | WebDAVConfiguration..::..Authentication..::..UserAgent | The User Agent.
Public class | WebDAVConfiguration..::..WebDAVUrl | Represents the WebDAV Url.
Public class | WebDAVOptions | Web DAV options object.
Public class | WebDAVOptionStore | web DAV Options Store.
Public class | XmlConfigFile | XmlConfigFile
Public class | XmlConfigRecord | XmlConfigRecord class
Public class | XmlConfigStore | XmlConfigStore class

Interfaces

 | Interface | Description
Public interface | IConstructable | Interface used by the Factory to notify objects that construction has completed.
Public interface | IFactoryHelper | IFactoryHelper class

Enumerations

 | Enumeration | Description
Public enumeration | ConfigurationAction | ConfigurationAction class
Public enumeration | Factory..::..HashKeyType | Represents a HashKeyType.
Public enumeration | Factory..::..HashValueFormat | Represents a HashValueFormat.
Public enumeration | Factory..::..HashValueType | Represents a HashValueType.
Public enumeration | WebDAVConfiguration..::..WebDAVMode | Web DAV Mode.


About Members

[image] [image]

Sitecore 6.4.1 API
About Members
About Class Constructors Methods Properties See Also Send Feedback

The About type exposes the following members.

Constructors

 | Name | Description
Public method | About | Initializes a new instance of the About class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetVersionNumber | Gets the version number (on the form Major.Minor.Build[.Revision]).
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToHtml | Gets about information of the current installation as html.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | VersionInformation | Gets version information of the current installation.

Properties

Name | Description
Version | Gets version information of the current installation.

See Also

About Class
Sitecore.Configuration Namespace


About Constructor

[image]

Sitecore 6.4.1 API
About Constructor
About Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public About()
Visual Basic
Public Sub New
Visual C++
public:
About()

See Also

About Class
Sitecore.Configuration Namespace


About Methods

[image] [image]

Sitecore 6.4.1 API
About Methods
About Class See Also Send Feedback

The About type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetVersionNumber | Gets the version number (on the form Major.Minor.Build[.Revision]).
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToHtml | Gets about information of the current installation as html.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | VersionInformation | Gets version information of the current installation.

See Also

About Class
Sitecore.Configuration Namespace


GetVersionNumber Method

[image]

Sitecore 6.4.1 API
About..::..GetVersionNumber Method
About Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetVersionNumber(
    bool includeRevision
)
Visual Basic
Public Shared Function GetVersionNumber ( _
    includeRevision As Boolean _
) As String
Visual C++
public:
static String^ GetVersionNumber(
    bool includeRevision
)

Parameters

includeRevision
Type: System..::..Boolean
if set to true revision number is included in the value.

Return Value

[Missing <returns> documentation for "M:Sitecore.Configuration.About.GetVersionNumber(System.Boolean)"]

See Also

About Class
Sitecore.Configuration Namespace


ToHtml Method

[image]

Sitecore 6.4.1 API
About..::..ToHtml Method
About Class Example See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ToHtml()
Visual Basic
Public Shared Function ToHtml As String
Visual C++
public:
static String^ ToHtml()

Return Value

[Missing <returns> documentation for "M:Sitecore.Configuration.About.ToHtml"]

Remarks

The returned html is a fragment made up of more div tags having class='sc_about_font'.

Examples

CopyC#
string aboutInfo = "<td>" + About.ToHtml() + "</td>"; // returns ready-to-use html.

See Also

About Class
Sitecore.Configuration Namespace


VersionInformation Method

[image]

Sitecore 6.4.1 API
About..::..VersionInformation Method
About Class Example See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string VersionInformation()
Visual Basic
Public Shared Function VersionInformation As String
Visual C++
public:
static String^ VersionInformation()

Return Value

[Missing <returns> documentation for "M:Sitecore.Configuration.About.VersionInformation"]

Remarks

The information is on the format Sitecore Major.Minor.Revision.Build.

Examples

CopyC#
string versionInfo = About.VersionInformation(); // "Sitecore 4.3.2"

See Also

About Class
Sitecore.Configuration Namespace


About Properties

[image] [image]

Sitecore 6.4.1 API
About Properties
About Class See Also Send Feedback

The About type exposes the following members.

Properties

Name | Description
Version | Gets version information of the current installation.

See Also

About Class
Sitecore.Configuration Namespace


Version Property

[image]

Sitecore 6.4.1 API
About..::..Version Property
About Class Example See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Version { get; }
Visual Basic
Public Shared ReadOnly Property Version As String
    Get
Visual C++
public:
static property String^ Version {
    String^ get ();
}

Field Value

The version.

Remarks

The information is on the format Major.Minor.Revision.Build.

Examples

CopyC#
string versionInfo = About.Version(); // "5.3.0"

See Also

About Class
Sitecore.Configuration Namespace


ClientContext Class

[image]

Sitecore 6.4.1 API
ClientContext Class
Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class ClientContext
Visual Basic
Public NotInheritable Class ClientContext
Visual C++
public ref class ClientContext abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..ClientContext

See Also

ClientContext Members
Sitecore.Configuration Namespace


ClientContext Members

[image] [image]

Sitecore 6.4.1 API
ClientContext Members
ClientContext Class Methods Properties See Also Send Feedback

The ClientContext type exposes the following members.

Methods

Name | Description
GetValue | Gets the value.
GetValueNames | Gets the value names.
RemoveValue | Removes the value.
SetValue(String, String) | Sets the value.
SetValue(String, Object, String) | Sets the value.

Properties

Name | Description
DataStore | Gets the data store.

See Also

ClientContext Class
Sitecore.Configuration Namespace


ClientContext Methods

[image] [image]

Sitecore 6.4.1 API
ClientContext Methods
ClientContext Class See Also Send Feedback

The ClientContext type exposes the following members.

Methods

Name | Description
GetValue | Gets the value.
GetValueNames | Gets the value names.
RemoveValue | Removes the value.
SetValue(String, String) | Sets the value.
SetValue(String, Object, String) | Sets the value.

See Also

ClientContext Class
Sitecore.Configuration Namespace


GetValue Method

[image]

Sitecore 6.4.1 API
ClientContext..::..GetValue Method
ClientContext Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object GetValue(
    string name
)
Visual Basic
Public Shared Function GetValue ( _
    name As String _
) As Object
Visual C++
public:
static Object^ GetValue(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

Return Value

The value.

See Also

ClientContext Class
Sitecore.Configuration Namespace


GetValueNames Method

[image]

Sitecore 6.4.1 API
ClientContext..::..GetValueNames Method
ClientContext Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string[] GetValueNames()
Visual Basic
Public Shared Function GetValueNames As String()
Visual C++
public:
static array<String^>^ GetValueNames()

Return Value

The value names.

See Also

ClientContext Class
Sitecore.Configuration Namespace


RemoveValue Method

[image]

Sitecore 6.4.1 API
ClientContext..::..RemoveValue Method
ClientContext Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void RemoveValue(
    string name
)
Visual Basic
Public Shared Sub RemoveValue ( _
    name As String _
)
Visual C++
public:
static void RemoveValue(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

See Also

ClientContext Class
Sitecore.Configuration Namespace


SetValue Method

[image] [image]

Sitecore 6.4.1 API
ClientContext..::..SetValue Method
ClientContext Class See Also Send Feedback

Overload List

Name | Description
SetValue(String, String) | Sets the value.
SetValue(String, Object, String) | Sets the value.

See Also

ClientContext Class
ClientContext Members
Sitecore.Configuration Namespace


SetValue Method (String, String)

[image]

Sitecore 6.4.1 API
ClientContext..::..SetValue Method (String, String)
ClientContext Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void SetValue(
    string name,
    string value
)
Visual Basic
Public Shared Sub SetValue ( _
    name As String, _
    value As String _
)
Visual C++
public:
static void SetValue(
    String^ name,
    String^ value
)

Parameters

name
Type: System..::..String
The name.
value
Type: System..::..String
The value.

See Also

ClientContext Class
SetValue Overload
Sitecore.Configuration Namespace


SetValue Method (String, Object, String)

[image]

Sitecore 6.4.1 API
ClientContext..::..SetValue Method (String, Object, String)
ClientContext Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void SetValue(
    string name,
    Object value,
    string persistableValue
)
Visual Basic
Public Shared Sub SetValue ( _
    name As String, _
    value As Object, _
    persistableValue As String _
)
Visual C++
public:
static void SetValue(
    String^ name,
    Object^ value,
    String^ persistableValue
)

Parameters

name
Type: System..::..String
The name.
value
Type: System..::..Object
The value.
persistableValue
Type: System..::..String
The persistable value.

See Also

ClientContext Class
SetValue Overload
Sitecore.Configuration Namespace


ClientContext Properties

[image] [image]

Sitecore 6.4.1 API
ClientContext Properties
ClientContext Class See Also Send Feedback

The ClientContext type exposes the following members.

Properties

Name | Description
DataStore | Gets the data store.

See Also

ClientContext Class
Sitecore.Configuration Namespace


DataStore Property

[image]

Sitecore 6.4.1 API
ClientContext..::..DataStore Property
ClientContext Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ClientDataStore DataStore { get; }
Visual Basic
Public Shared ReadOnly Property DataStore As ClientDataStore
    Get
Visual C++
public:
static property ClientDataStore^ DataStore {
    ClientDataStore^ get ();
}

Field Value

The data store.

See Also

ClientContext Class
Sitecore.Configuration Namespace


ClientDataStore Class

[image]

Sitecore 6.4.1 API
ClientDataStore Class
Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class ClientDataStore
Visual Basic
Public MustInherit Class ClientDataStore
Visual C++
public ref class ClientDataStore abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..ClientDataStore
Sitecore.Configuration..::..FileDataStore
Sitecore.Data.SqlServer..::..SqlServerClientDataStore

See Also

ClientDataStore Members
Sitecore.Configuration Namespace


ClientDataStore Members

[image] [image]

Sitecore 6.4.1 API
ClientDataStore Members
ClientDataStore Class Constructors Methods Properties See Also Send Feedback

The ClientDataStore type exposes the following members.

Constructors

 | Name | Description
Protected method | ClientDataStore(TimeSpan) | Initializes a new instance of the ClientDataStore class.
Protected method | ClientDataStore(TimeSpan, Boolean) | Initializes a new instance of the ClientDataStore class.

Methods

 | Name | Description
Protected method | AddDataToCache | Adds data to the cache.
Public method | Compact | Compacts this instance.
Protected method | CompactData | Compacts the data.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetDataFromCache | Gets data from the cache.
Protected method | GetDataKey | Gets the data key.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSize | Gets the size of newly returned data.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the value.
Public method | GetValueNames | Gets the value names.
Protected method | LoadData()()()() | Loads the data.
Protected method | LoadData(String) | Loads the data.
Public method | LoadViewstate | Loads the viewstate.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveAll | Removes the values.
Protected method | RemoveAllData | Removes all data.
Protected method | RemoveData()()()() | Removes the data.
Protected method | RemoveData(String) | Removes the data.
Protected method | RemoveDataFromCache | Removes data from the cache.
Public method | RemoveValue | Removes the value.
Public method | RemoveValues | Removes the values.
Public method | RemoveViewstate | Removes the viewstate.
Protected method | SaveData(Hashtable) | Saves the data.
Protected method | SaveData(String, String) | Saves the data.
Public method | SaveViewstate | Saves the viewstate.
Public method | SetValue(String, String) | Sets the value.
Public method | SetValue(String, Object, String) | Sets the value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TouchActiveData | Touches all active data.
Protected method | TouchData | Touches the data represented by key.

Properties

 | Name | Description
Public property | ObjectLifetime | Gets the object lifetime.

See Also

ClientDataStore Class
Sitecore.Configuration Namespace


ClientDataStore Constructor

[image] [image]

Sitecore 6.4.1 API
ClientDataStore Constructor
ClientDataStore Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | ClientDataStore(TimeSpan) | Initializes a new instance of the ClientDataStore class.
Protected method | ClientDataStore(TimeSpan, Boolean) | Initializes a new instance of the ClientDataStore class.

See Also

ClientDataStore Class
ClientDataStore Members
Sitecore.Configuration Namespace


ClientDataStore Constructor (TimeSpan)

[image]

Sitecore 6.4.1 API
ClientDataStore Constructor (TimeSpan)
ClientDataStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected ClientDataStore(
    TimeSpan objectLifetime
)
Visual Basic
Protected Sub New ( _
    objectLifetime As TimeSpan _
)
Visual C++
protected:
ClientDataStore(
    TimeSpan objectLifetime
)

Parameters

objectLifetime
Type: System..::..TimeSpan
The object lifetime.

See Also

ClientDataStore Class
ClientDataStore Overload
Sitecore.Configuration Namespace


ClientDataStore Constructor (TimeSpan, Boolean)

[image]

Sitecore 6.4.1 API
ClientDataStore Constructor (TimeSpan, Boolean)
ClientDataStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected ClientDataStore(
    TimeSpan objectLifetime,
    bool enableCaching
)
Visual Basic
Protected Sub New ( _
    objectLifetime As TimeSpan, _
    enableCaching As Boolean _
)
Visual C++
protected:
ClientDataStore(
    TimeSpan objectLifetime,
    bool enableCaching
)

Parameters

objectLifetime
Type: System..::..TimeSpan
The object lifetime.
enableCaching
Type: System..::..Boolean
If set to true this instance enables caching.

See Also

ClientDataStore Class
ClientDataStore Overload
Sitecore.Configuration Namespace


AddDataToCache Method

[image]

Sitecore 6.4.1 API
ClientDataStore..::..AddDataToCache Method
ClientDataStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void AddDataToCache(
    string key,
    Hashtable data,
    long size
)
Visual Basic
Protected Overridable Sub AddDataToCache ( _
    key As String, _
    data As Hashtable, _
    size As Long _
)
Visual C++
protected:
virtual void AddDataToCache(
    String^ key,
    Hashtable^ data,
    long long size
)

Parameters

key
Type: System..::..String
The key.
data
Type: System.Collections..::..Hashtable
The data.
size
Type: System..::..Int64
The size.

See Also

ClientDataStore Class
Sitecore.Configuration Namespace


CompactData Method

[image]

Sitecore 6.4.1 API
ClientDataStore..::..CompactData Method
ClientDataStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected abstract void CompactData()
Visual Basic
Protected MustOverride Sub CompactData
Visual C++
protected:
virtual void CompactData() abstract

See Also

ClientDataStore Class
Sitecore.Configuration Namespace


GetDataFromCache Method

[image]

Sitecore 6.4.1 API
ClientDataStore..::..GetDataFromCache Method
ClientDataStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual Hashtable GetDataFromCache(
    string key
)
Visual Basic
Protected Overridable Function GetDataFromCache ( _
    key As String _
) As Hashtable
Visual C++
protected:
virtual Hashtable^ GetDataFromCache(
    String^ key
)

Parameters

key
Type: System..::..String
The key.

Return Value

The data (or null).

See Also

ClientDataStore Class
Sitecore.Configuration Namespace


GetDataKey Method

[image]

Sitecore 6.4.1 API
ClientDataStore..::..GetDataKey Method
ClientDataStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string GetDataKey()
Visual Basic
Protected Overridable Function GetDataKey As String
Visual C++
protected:
virtual String^ GetDataKey()

Return Value

The data key.

See Also

ClientDataStore Class
Sitecore.Configuration Namespace


GetSize Method

[image]

Sitecore 6.4.1 API
ClientDataStore..::..GetSize Method
ClientDataStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual long GetSize(
    Hashtable data
)
Visual Basic
Protected Overridable Function GetSize ( _
    data As Hashtable _
) As Long
Visual C++
protected:
virtual long long GetSize(
    Hashtable^ data
)

Parameters

data
Type: System.Collections..::..Hashtable
The data.

Return Value

The size.

See Also

ClientDataStore Class
Sitecore.Configuration Namespace


GetValue Method

[image]

Sitecore 6.4.1 API
ClientDataStore..::..GetValue Method
ClientDataStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Object GetValue(
    string name
)
Visual Basic
Public Overridable Function GetValue ( _
    name As String _
) As Object
Visual C++
public:
virtual Object^ GetValue(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

Return Value

The value.

See Also

ClientDataStore Class
Sitecore.Configuration Namespace


GetValueNames Method

[image]

Sitecore 6.4.1 API
ClientDataStore..::..GetValueNames Method
ClientDataStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string[] GetValueNames()
Visual Basic
Public Overridable Function GetValueNames As String()
Visual C++
public:
virtual array<String^>^ GetValueNames()

Return Value

The value names.

See Also

ClientDataStore Class
Sitecore.Configuration Namespace


LoadData Method

[image] [image]

Sitecore 6.4.1 API
ClientDataStore..::..LoadData Method
ClientDataStore Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | LoadData()()()() | Loads the data.
Protected method | LoadData(String) | Loads the data.

See Also

ClientDataStore Class
ClientDataStore Members
Sitecore.Configuration Namespace


LoadData Method

[image]

Sitecore 6.4.1 API
ClientDataStore..::..LoadData Method
ClientDataStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual Hashtable LoadData()
Visual Basic
Protected Overridable Function LoadData As Hashtable
Visual C++
protected:
virtual Hashtable^ LoadData()

Return Value

The data.

See Also

ClientDataStore Class
LoadData Overload
Sitecore.Configuration Namespace


LoadViewstate Method

[image]

Sitecore 6.4.1 API
ClientDataStore..::..LoadViewstate Method
ClientDataStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string LoadViewstate(
    string key
)
Visual Basic
Public Overridable Function LoadViewstate ( _
    key As String _
) As String
Visual C++
public:
virtual String^ LoadViewstate(
    String^ key
)

Parameters

key
Type: System..::..String
The key.

Return Value

[Missing <returns> documentation for "M:Sitecore.Configuration.ClientDataStore.LoadViewstate(System.String)"]

See Also

ClientDataStore Class
Sitecore.Configuration Namespace


RemoveAll Method

[image]

Sitecore 6.4.1 API
ClientDataStore..::..RemoveAll Method
ClientDataStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void RemoveAll()
Visual Basic
Public Overridable Sub RemoveAll
Visual C++
public:
virtual void RemoveAll()

See Also

ClientDataStore Class
Sitecore.Configuration Namespace


RemoveAllData Method

[image]

Sitecore 6.4.1 API
ClientDataStore..::..RemoveAllData Method
ClientDataStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void RemoveAllData()
Visual Basic
Protected Overridable Sub RemoveAllData
Visual C++
protected:
virtual void RemoveAllData()

See Also

ClientDataStore Class
Sitecore.Configuration Namespace


RemoveData Method

[image]

Sitecore 6.4.1 API
ClientDataStore..::..RemoveData Method
ClientDataStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void RemoveData()
Visual Basic
Protected Overridable Sub RemoveData
Visual C++
protected:
virtual void RemoveData()

See Also

ClientDataStore Class
RemoveData Overload
Sitecore.Configuration Namespace


RemoveData Method (String)

[image]

Sitecore 6.4.1 API
ClientDataStore..::..RemoveData Method (String)
ClientDataStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected abstract void RemoveData(
    string key
)
Visual Basic
Protected MustOverride Sub RemoveData ( _
    key As String _
)
Visual C++
protected:
virtual void RemoveData(
    String^ key
) abstract

Parameters

key
Type: System..::..String
The key.

See Also

ClientDataStore Class
RemoveData Overload
Sitecore.Configuration Namespace


RemoveDataFromCache Method

[image]

Sitecore 6.4.1 API
ClientDataStore..::..RemoveDataFromCache Method
ClientDataStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void RemoveDataFromCache(
    string key
)
Visual Basic
Protected Overridable Sub RemoveDataFromCache ( _
    key As String _
)
Visual C++
protected:
virtual void RemoveDataFromCache(
    String^ key
)

Parameters

key
Type: System..::..String
The key.

See Also

ClientDataStore Class
Sitecore.Configuration Namespace


RemoveValue Method

[image]

Sitecore 6.4.1 API
ClientDataStore..::..RemoveValue Method
ClientDataStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void RemoveValue(
    string name
)
Visual Basic
Public Overridable Sub RemoveValue ( _
    name As String _
)
Visual C++
public:
virtual void RemoveValue(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

See Also

ClientDataStore Class
Sitecore.Configuration Namespace


RemoveValues Method

[image]

Sitecore 6.4.1 API
ClientDataStore..::..RemoveValues Method
ClientDataStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void RemoveValues()
Visual Basic
Public Overridable Sub RemoveValues
Visual C++
public:
virtual void RemoveValues()

See Also

ClientDataStore Class
Sitecore.Configuration Namespace


RemoveViewstate Method

[image]

Sitecore 6.4.1 API
ClientDataStore..::..RemoveViewstate Method
ClientDataStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void RemoveViewstate(
    string key
)
Visual Basic
Public Overridable Sub RemoveViewstate ( _
    key As String _
)
Visual C++
public:
virtual void RemoveViewstate(
    String^ key
)

Parameters

key
Type: System..::..String
The key.

See Also

ClientDataStore Class
Sitecore.Configuration Namespace


SaveData Method

[image] [image]

Sitecore 6.4.1 API
ClientDataStore..::..SaveData Method
ClientDataStore Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SaveData(Hashtable) | Saves the data.
Protected method | SaveData(String, String) | Saves the data.

See Also

ClientDataStore Class
ClientDataStore Members
Sitecore.Configuration Namespace


SaveData Method (Hashtable)

[image]

Sitecore 6.4.1 API
ClientDataStore..::..SaveData Method (Hashtable)
ClientDataStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void SaveData(
    Hashtable data
)
Visual Basic
Protected Overridable Sub SaveData ( _
    data As Hashtable _
)
Visual C++
protected:
virtual void SaveData(
    Hashtable^ data
)

Parameters

data
Type: System.Collections..::..Hashtable
The data.

See Also

ClientDataStore Class
SaveData Overload
Sitecore.Configuration Namespace


SaveData Method (String, String)

[image]

Sitecore 6.4.1 API
ClientDataStore..::..SaveData Method (String, String)
ClientDataStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected abstract void SaveData(
    string key,
    string data
)
Visual Basic
Protected MustOverride Sub SaveData ( _
    key As String, _
    data As String _
)
Visual C++
protected:
virtual void SaveData(
    String^ key,
    String^ data
) abstract

Parameters

key
Type: System..::..String
The key.
data
Type: System..::..String
The data.

See Also

ClientDataStore Class
SaveData Overload
Sitecore.Configuration Namespace


SaveViewstate Method

[image]

Sitecore 6.4.1 API
ClientDataStore..::..SaveViewstate Method
ClientDataStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void SaveViewstate(
    string key,
    string value
)
Visual Basic
Public Overridable Sub SaveViewstate ( _
    key As String, _
    value As String _
)
Visual C++
public:
virtual void SaveViewstate(
    String^ key,
    String^ value
)

Parameters

key
Type: System..::..String
The key.
value
Type: System..::..String
The value.

See Also

ClientDataStore Class
Sitecore.Configuration Namespace


SetValue Method (String, String)

[image]

Sitecore 6.4.1 API
ClientDataStore..::..SetValue Method (String, String)
ClientDataStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void SetValue(
    string name,
    string value
)
Visual Basic
Public Overridable Sub SetValue ( _
    name As String, _
    value As String _
)
Visual C++
public:
virtual void SetValue(
    String^ name,
    String^ value
)

Parameters

name
Type: System..::..String
The name.
value
Type: System..::..String
The value.

See Also

ClientDataStore Class
SetValue Overload
Sitecore.Configuration Namespace


SetValue Method (String, Object, String)

[image]

Sitecore 6.4.1 API
ClientDataStore..::..SetValue Method (String, Object, String)
ClientDataStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void SetValue(
    string name,
    Object value,
    string persistableValue
)
Visual Basic
Public Overridable Sub SetValue ( _
    name As String, _
    value As Object, _
    persistableValue As String _
)
Visual C++
public:
virtual void SetValue(
    String^ name,
    Object^ value,
    String^ persistableValue
)

Parameters

name
Type: System..::..String
The name.
value
Type: System..::..Object
The value.
persistableValue
Type: System..::..String
The persistable value.

See Also

ClientDataStore Class
SetValue Overload
Sitecore.Configuration Namespace


TouchActiveData Method

[image]

Sitecore 6.4.1 API
ClientDataStore..::..TouchActiveData Method
ClientDataStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void TouchActiveData()
Visual Basic
Protected Overridable Sub TouchActiveData
Visual C++
protected:
virtual void TouchActiveData()

See Also

ClientDataStore Class
Sitecore.Configuration Namespace


TouchData Method

[image]

Sitecore 6.4.1 API
ClientDataStore..::..TouchData Method
ClientDataStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void TouchData(
    string key
)
Visual Basic
Protected Overridable Sub TouchData ( _
    key As String _
)
Visual C++
protected:
virtual void TouchData(
    String^ key
)

Parameters

key
Type: System..::..String
The key.

See Also

ClientDataStore Class
Sitecore.Configuration Namespace


ClientDataStore Properties

[image] [image]

Sitecore 6.4.1 API
ClientDataStore Properties
ClientDataStore Class See Also Send Feedback

The ClientDataStore type exposes the following members.

Properties

 | Name | Description
Public property | ObjectLifetime | Gets the object lifetime.

See Also

ClientDataStore Class
Sitecore.Configuration Namespace


ObjectLifetime Property

[image]

Sitecore 6.4.1 API
ClientDataStore..::..ObjectLifetime Property
ClientDataStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TimeSpan ObjectLifetime { get; }
Visual Basic
Public ReadOnly Property ObjectLifetime As TimeSpan
    Get
Visual C++
public:
property TimeSpan ObjectLifetime {
    TimeSpan get ();
}

Field Value

The object lifetime.

See Also

ClientDataStore Class
Sitecore.Configuration Namespace


ConfigChangedEventArgs Class

[image]

Sitecore 6.4.1 API
ConfigChangedEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ConfigChangedEventArgs : EventArgs
Visual Basic
Public Class ConfigChangedEventArgs _
    Inherits EventArgs
Visual C++
public ref class ConfigChangedEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Configuration..::..ConfigChangedEventArgs

See Also

ConfigChangedEventArgs Members
Sitecore.Configuration Namespace


ConfigChangedEventArgs Members

[image] [image]

Sitecore 6.4.1 API
ConfigChangedEventArgs Members
ConfigChangedEventArgs Class Constructors Methods Properties See Also Send Feedback

The ConfigChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ConfigChangedEventArgs | Initializes a new instance of the ConfigChangedEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigFilePath | Gets the config file path.

See Also

ConfigChangedEventArgs Class
Sitecore.Configuration Namespace


ConfigChangedEventArgs Constructor

[image]

Sitecore 6.4.1 API
ConfigChangedEventArgs Constructor
ConfigChangedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ConfigChangedEventArgs(
    string configFilePath
)
Visual Basic
Public Sub New ( _
    configFilePath As String _
)
Visual C++
public:
ConfigChangedEventArgs(
    String^ configFilePath
)

Parameters

configFilePath
Type: System..::..String

[Missing <param name="configFilePath"/> documentation for "M:Sitecore.Configuration.ConfigChangedEventArgs.#ctor(System.String)"]

See Also

ConfigChangedEventArgs Class
Sitecore.Configuration Namespace


ConfigChangedEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
ConfigChangedEventArgs Methods
ConfigChangedEventArgs Class See Also Send Feedback

The ConfigChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConfigChangedEventArgs Class
Sitecore.Configuration Namespace


ConfigChangedEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
ConfigChangedEventArgs Properties
ConfigChangedEventArgs Class See Also Send Feedback

The ConfigChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ConfigFilePath | Gets the config file path.

See Also

ConfigChangedEventArgs Class
Sitecore.Configuration Namespace


ConfigFilePath Property

[image]

Sitecore 6.4.1 API
ConfigChangedEventArgs..::..ConfigFilePath Property
ConfigChangedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ConfigFilePath { get; }
Visual Basic
Public ReadOnly Property ConfigFilePath As String
    Get
Visual C++
public:
property String^ ConfigFilePath {
    String^ get ();
}

Field Value

The config file path.

See Also

ConfigChangedEventArgs Class
Sitecore.Configuration Namespace


ConfigReader Class

[image]

Sitecore 6.4.1 API
ConfigReader Class
Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ConfigReader : IConfigurationSectionHandler
Visual Basic
Public Class ConfigReader _
    Implements IConfigurationSectionHandler
Visual C++
public ref class ConfigReader : IConfigurationSectionHandler

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..ConfigReader

See Also

ConfigReader Members
Sitecore.Configuration Namespace


ConfigReader Members

[image] [image]

Sitecore 6.4.1 API
ConfigReader Members
ConfigReader Class Constructors Methods Properties See Also Send Feedback

The ConfigReader type exposes the following members.

Constructors

 | Name | Description
Public method | ConfigReader | Initializes a new instance of the ConfigReader class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAttribute | Obsolete. Gets the attribute.
 | GetConfigNode()()()() | Gets the root config node (ie. sitecore)
 | GetConfigNode(String) | Gets a specific config node.
 | GetConfigNodes | Gets a list of config nodes matching an xpath.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetImplementationNode | Gets a specific implementation node.
Protected method | GetNode | Get an xml node.
Protected method | GetNodes | Get a list of xml nodes.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ConfigutationIsSet | Gets a value indicating whether configutation is set.

See Also

ConfigReader Class
Sitecore.Configuration Namespace


ConfigReader Constructor

[image]

Sitecore 6.4.1 API
ConfigReader Constructor
ConfigReader Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ConfigReader()
Visual Basic
Public Sub New
Visual C++
public:
ConfigReader()

See Also

ConfigReader Class
Sitecore.Configuration Namespace


ConfigReader Methods

[image] [image]

Sitecore 6.4.1 API
ConfigReader Methods
ConfigReader Class See Also Send Feedback

The ConfigReader type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAttribute | Obsolete. Gets the attribute.
 | GetConfigNode()()()() | Gets the root config node (ie. sitecore)
 | GetConfigNode(String) | Gets a specific config node.
 | GetConfigNodes | Gets a list of config nodes matching an xpath.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetImplementationNode | Gets a specific implementation node.
Protected method | GetNode | Get an xml node.
Protected method | GetNodes | Get a list of xml nodes.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConfigReader Class
Sitecore.Configuration Namespace


GetAttribute Method

[image]

Sitecore 6.4.1 API
ConfigReader..::..GetAttribute Method
ConfigReader Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public static string GetAttribute(
    string nodePath,
    string attributeName
)
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Shared Function GetAttribute ( _
    nodePath As String, _
    attributeName As String _
) As String
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public:
static String^ GetAttribute(
    String^ nodePath,
    String^ attributeName
)

Parameters

nodePath
Type: System..::..String
The node path.
attributeName
Type: System..::..String
Name of the attribute.

Return Value

[Missing <returns> documentation for "M:Sitecore.Configuration.ConfigReader.GetAttribute(System.String,System.String)"]

See Also

ConfigReader Class
Sitecore.Configuration Namespace


GetConfigNode Method

[image] [image]

Sitecore 6.4.1 API
ConfigReader..::..GetConfigNode Method
ConfigReader Class See Also Send Feedback

Overload List

Name | Description
GetConfigNode()()()() | Gets the root config node (ie. sitecore)
GetConfigNode(String) | Gets a specific config node.

See Also

ConfigReader Class
ConfigReader Members
Sitecore.Configuration Namespace


GetConfigNode Method

[image]

Sitecore 6.4.1 API
ConfigReader..::..GetConfigNode Method
ConfigReader Class Example See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static XmlNode GetConfigNode()
Visual Basic
Public Shared Function GetConfigNode As XmlNode
Visual C++
public:
static XmlNode^ GetConfigNode()

Return Value

Root configuration node. If no node is found, null is returned.

Examples

Get the number of nodes below the <sitecore> node in web.config:
CopyC#
XmlNode node = ConfigReader.GetConfigNode();
Mainutil.Out("Config nodes: " + node.ChildNodes.Count);
 Outputs: Config nodes: 43

See Also

ConfigReader Class
GetConfigNode Overload
Sitecore.Configuration Namespace


GetConfigNodes Method

[image]

Sitecore 6.4.1 API
ConfigReader..::..GetConfigNodes Method
ConfigReader Class Example See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static XmlNodeList GetConfigNodes(
    string xpath
)
Visual Basic
Public Shared Function GetConfigNodes ( _
    xpath As String _
) As XmlNodeList
Visual C++
public:
static XmlNodeList^ GetConfigNodes(
    String^ xpath
)

Parameters

xpath
Type: System..::..String
XPath of node to find (relative to the sitecore node).

Return Value

Requested configuration nodes. If no nodes are found, null is returned.

Remarks

The xpath must be relative to the sitecore node. It must never start with /

Examples

Get the list of item event handlers:
CopyC#
XmlNodeList nodes = ConfigReader.GetConfigNodes("eventHandlers/items");
foreach(XmlNode node in nodes) {
MainUtil.Out("Type: " + XmlUtil.GetAttribute("type", node));
}
 Outputs:
CopyC#
Type: Sitecore.Logging
Type: Sitecore.WebEdit.ItemEventHandler
Type: Sitecore.Preview.ItemEventHandler

See Also

ConfigReader Class
Sitecore.Configuration Namespace


GetNode Method

[image]

Sitecore 6.4.1 API
ConfigReader..::..GetNode Method
ConfigReader Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected XmlNode GetNode(
    string xpath
)
Visual Basic
Protected Function GetNode ( _
    xpath As String _
) As XmlNode
Visual C++
protected:
XmlNode^ GetNode(
    String^ xpath
)

Parameters

xpath
Type: System..::..String
The xpath.

Return Value

The node.

See Also

ConfigReader Class
Sitecore.Configuration Namespace


GetNodes Method

[image]

Sitecore 6.4.1 API
ConfigReader..::..GetNodes Method
ConfigReader Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected XmlNodeList GetNodes(
    string xpath
)
Visual Basic
Protected Function GetNodes ( _
    xpath As String _
) As XmlNodeList
Visual C++
protected:
XmlNodeList^ GetNodes(
    String^ xpath
)

Parameters

xpath
Type: System..::..String
The xpath.

Return Value

The nodes.

See Also

ConfigReader Class
Sitecore.Configuration Namespace


ConfigReader Properties

[image] [image]

Sitecore 6.4.1 API
ConfigReader Properties
ConfigReader Class See Also Send Feedback

The ConfigReader type exposes the following members.

Properties

Name | Description
ConfigutationIsSet | Gets a value indicating whether configutation is set.

See Also

ConfigReader Class
Sitecore.Configuration Namespace


ConfigRecord Class

[image]

Sitecore 6.4.1 API
ConfigRecord Class
Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class ConfigRecord
Visual Basic
Public MustInherit Class ConfigRecord
Visual C++
public ref class ConfigRecord abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..ConfigRecord
Sitecore.Configuration..::..XmlConfigRecord

See Also

ConfigRecord Members
Sitecore.Configuration Namespace


ConfigRecord Members

[image] [image]

Sitecore 6.4.1 API
ConfigRecord Members
ConfigRecord Class Constructors Methods Properties See Also Send Feedback

The ConfigRecord type exposes the following members.

Constructors

 | Name | Description
Protected method | ConfigRecord | Initializes a new instance of the ConfigRecord class.

Methods

 | Name | Description
Public method | AddRecord(String) | Adds the record.
Public method | AddRecord(String, String, array<String>[]()[][]) | Adds a new child record to the record.
Public method | CreateObject<(Of <<'(T>)>>) | Creates the object represented by the record.
Public method | CreateObjects<(Of <<'(T>)>>) | Creates objects from all child record with the name specified in recordName.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChildRecord | Gets a child record with the specified name.
Public method | GetChildRecords()()()() | Gets all child records.
Public method | GetChildRecords(String) | Gets all child records with the specified name.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNamedChildRecord | Gets a named child record.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the textual value of the record.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the record from the config store.
Public method | SetAttribute | Sets the attribute.
Public method | SetValue | Sets the textual value of the record.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Attributes | Gets the attributes.
Public property | ConfigStore | Gets the store.
Public property | Name | Gets the name.

See Also

ConfigRecord Class
Sitecore.Configuration Namespace


ConfigRecord Constructor

[image]

Sitecore 6.4.1 API
ConfigRecord Constructor
ConfigRecord Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected ConfigRecord(
    string name,
    ConfigStore store
)
Visual Basic
Protected Sub New ( _
    name As String, _
    store As ConfigStore _
)
Visual C++
protected:
ConfigRecord(
    String^ name,
    ConfigStore^ store
)

Parameters

name
Type: System..::..String
The name.
store
Type: Sitecore.Configuration..::..ConfigStore
The store.

See Also

ConfigRecord Class
Sitecore.Configuration Namespace


ConfigRecord Methods

[image] [image]

Sitecore 6.4.1 API
ConfigRecord Methods
ConfigRecord Class See Also Send Feedback

The ConfigRecord type exposes the following members.

Methods

 | Name | Description
Public method | AddRecord(String) | Adds the record.
Public method | AddRecord(String, String, array<String>[]()[][]) | Adds a new child record to the record.
Public method | CreateObject<(Of <<'(T>)>>) | Creates the object represented by the record.
Public method | CreateObjects<(Of <<'(T>)>>) | Creates objects from all child record with the name specified in recordName.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChildRecord | Gets a child record with the specified name.
Public method | GetChildRecords()()()() | Gets all child records.
Public method | GetChildRecords(String) | Gets all child records with the specified name.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNamedChildRecord | Gets a named child record.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the textual value of the record.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the record from the config store.
Public method | SetAttribute | Sets the attribute.
Public method | SetValue | Sets the textual value of the record.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConfigRecord Class
Sitecore.Configuration Namespace


AddRecord Method

[image] [image]

Sitecore 6.4.1 API
ConfigRecord..::..AddRecord Method
ConfigRecord Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddRecord(String) | Adds the record.
Public method | AddRecord(String, String, array<String>[]()[][]) | Adds a new child record to the record.

See Also

ConfigRecord Class
ConfigRecord Members
Sitecore.Configuration Namespace


AddRecord Method (String)

[image]

Sitecore 6.4.1 API
ConfigRecord..::..AddRecord Method (String)
ConfigRecord Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract ConfigRecord AddRecord(
    string recordName
)
Visual Basic
Public MustOverride Function AddRecord ( _
    recordName As String _
) As ConfigRecord
Visual C++
public:
virtual ConfigRecord^ AddRecord(
    String^ recordName
) abstract

Parameters

recordName
Type: System..::..String
Name of the record.

Return Value

[Missing <returns> documentation for "M:Sitecore.Configuration.ConfigRecord.AddRecord(System.String)"]

See Also

ConfigRecord Class
AddRecord Overload
Sitecore.Configuration Namespace


CreateObject(T) Method

[image]

Sitecore 6.4.1 API
ConfigRecord..::..CreateObject<(Of <(<'T>)>)> Method
ConfigRecord Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract T CreateObject<T>()
where T : class
Visual Basic
Public MustOverride Function CreateObject(Of T As Class) As T
Visual C++
public:
generic<typename T>
where T : ref class
virtual T CreateObject() abstract

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Sitecore.Configuration.ConfigRecord.CreateObject``1"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Configuration.ConfigRecord.CreateObject``1"]

See Also

ConfigRecord Class
Sitecore.Configuration Namespace


CreateObjects(T) Method

[image]

Sitecore 6.4.1 API
ConfigRecord..::..CreateObjects<(Of <(<'T>)>)> Method
ConfigRecord Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public List<T> CreateObjects<T>(
    string recordName
)
where T : class
Visual Basic
Public Function CreateObjects(Of T As Class) ( _
    recordName As String _
) As List(Of T)
Visual C++
public:
generic<typename T>
where T : ref class
List<T>^ CreateObjects(
    String^ recordName
)

Parameters

recordName
Type: System..::..String
Name of the child records.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Sitecore.Configuration.ConfigRecord.CreateObjects``1(System.String)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Configuration.ConfigRecord.CreateObjects``1(System.String)"]

See Also

ConfigRecord Class
Sitecore.Configuration Namespace


GetChildRecord Method

[image]

Sitecore 6.4.1 API
ConfigRecord..::..GetChildRecord Method
ConfigRecord Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract ConfigRecord GetChildRecord(
    string recordName
)
Visual Basic
Public MustOverride Function GetChildRecord ( _
    recordName As String _
) As ConfigRecord
Visual C++
public:
virtual ConfigRecord^ GetChildRecord(
    String^ recordName
) abstract

Parameters

recordName
Type: System..::..String
Name of the record.

Return Value

[Missing <returns> documentation for "M:Sitecore.Configuration.ConfigRecord.GetChildRecord(System.String)"]

See Also

ConfigRecord Class
Sitecore.Configuration Namespace


GetChildRecords Method

[image] [image]

Sitecore 6.4.1 API
ConfigRecord..::..GetChildRecords Method
ConfigRecord Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildRecords()()()() | Gets all child records.
Public method | GetChildRecords(String) | Gets all child records with the specified name.

See Also

ConfigRecord Class
ConfigRecord Members
Sitecore.Configuration Namespace


GetChildRecords Method

[image]

Sitecore 6.4.1 API
ConfigRecord..::..GetChildRecords Method
ConfigRecord Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract List<ConfigRecord> GetChildRecords()
Visual Basic
Public MustOverride Function GetChildRecords As List(Of ConfigRecord)
Visual C++
public:
virtual List<ConfigRecord^>^ GetChildRecords() abstract

Return Value

[Missing <returns> documentation for "M:Sitecore.Configuration.ConfigRecord.GetChildRecords"]

See Also

ConfigRecord Class
GetChildRecords Overload
Sitecore.Configuration Namespace


GetChildRecords Method (String)

[image]

Sitecore 6.4.1 API
ConfigRecord..::..GetChildRecords Method (String)
ConfigRecord Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract List<ConfigRecord> GetChildRecords(
    string recordName
)
Visual Basic
Public MustOverride Function GetChildRecords ( _
    recordName As String _
) As List(Of ConfigRecord)
Visual C++
public:
virtual List<ConfigRecord^>^ GetChildRecords(
    String^ recordName
) abstract

Parameters

recordName
Type: System..::..String
Name of the record.

Return Value

[Missing <returns> documentation for "M:Sitecore.Configuration.ConfigRecord.GetChildRecords(System.String)"]

See Also

ConfigRecord Class
GetChildRecords Overload
Sitecore.Configuration Namespace


GetNamedChildRecord Method

[image]

Sitecore 6.4.1 API
ConfigRecord..::..GetNamedChildRecord Method
ConfigRecord Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract ConfigRecord GetNamedChildRecord(
    string recordName,
    string name
)
Visual Basic
Public MustOverride Function GetNamedChildRecord ( _
    recordName As String, _
    name As String _
) As ConfigRecord
Visual C++
public:
virtual ConfigRecord^ GetNamedChildRecord(
    String^ recordName,
    String^ name
) abstract

Parameters

recordName
Type: System..::..String
Name of the record.
name
Type: System..::..String
The name.

Return Value

[Missing <returns> documentation for "M:Sitecore.Configuration.ConfigRecord.GetNamedChildRecord(System.String,System.String)"]

See Also

ConfigRecord Class
Sitecore.Configuration Namespace


GetValue Method

[image]

Sitecore 6.4.1 API
ConfigRecord..::..GetValue Method
ConfigRecord Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract string GetValue()
Visual Basic
Public MustOverride Function GetValue As String
Visual C++
public:
virtual String^ GetValue() abstract

Return Value

[Missing <returns> documentation for "M:Sitecore.Configuration.ConfigRecord.GetValue"]

See Also

ConfigRecord Class
Sitecore.Configuration Namespace


Remove Method

[image]

Sitecore 6.4.1 API
ConfigRecord..::..Remove Method
ConfigRecord Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract void Remove()
Visual Basic
Public MustOverride Sub Remove
Visual C++
public:
virtual void Remove() abstract

See Also

ConfigRecord Class
Sitecore.Configuration Namespace


SetValue Method

[image]

Sitecore 6.4.1 API
ConfigRecord..::..SetValue Method
ConfigRecord Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract void SetValue(
    string value
)
Visual Basic
Public MustOverride Sub SetValue ( _
    value As String _
)
Visual C++
public:
virtual void SetValue(
    String^ value
) abstract

Parameters

value
Type: System..::..String
The value.

See Also

ConfigRecord Class
Sitecore.Configuration Namespace


Attributes Property

[image]

Sitecore 6.4.1 API
ConfigRecord..::..Attributes Property
ConfigRecord Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract AttributeList Attributes { get; }
Visual Basic
Public MustOverride ReadOnly Property Attributes As AttributeList
    Get
Visual C++
public:
virtual property AttributeList^ Attributes {
    AttributeList^ get () abstract;
}

Field Value

The attributes.

See Also

ConfigRecord Class
Sitecore.Configuration Namespace


ConfigStore Property

[image]

Sitecore 6.4.1 API
ConfigRecord..::..ConfigStore Property
ConfigRecord Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ConfigStore ConfigStore { get; }
Visual Basic
Public ReadOnly Property ConfigStore As ConfigStore
    Get
Visual C++
public:
property ConfigStore^ ConfigStore {
    ConfigStore^ get ();
}

Field Value

The store.

See Also

ConfigRecord Class
Sitecore.Configuration Namespace


Name Property

[image]

Sitecore 6.4.1 API
ConfigRecord..::..Name Property
ConfigRecord Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

ConfigRecord Class
Sitecore.Configuration Namespace


ConfigStore Class

[image]

Sitecore 6.4.1 API
ConfigStore Class
Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class ConfigStore
Visual Basic
Public MustInherit Class ConfigStore
Visual C++
public ref class ConfigStore abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..ConfigStore
Sitecore.Configuration..::..XmlConfigStore

See Also

ConfigStore Members
Sitecore.Configuration Namespace


ConfigStore Members

[image] [image]

Sitecore 6.4.1 API
ConfigStore Members
ConfigStore Class Constructors Methods Properties Events See Also Send Feedback

The ConfigStore type exposes the following members.

Constructors

 | Name | Description
Protected method | ConfigStore | Initializes a new instance of the ConfigStore class

Methods

 | Name | Description
Public method | CommitChanges | Commits the changes.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTemplateRecord | Gets the template record.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Load | Loads the specified config store name.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotifyConfigChanged | Notify subscribers that the configuration has changed.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | RootRecord | Gets the root record.

Events

 | Name | Description
Public event | ConfigChanged | Occurs when configuration has been changed (externally).

See Also

ConfigStore Class
Sitecore.Configuration Namespace


ConfigStore Constructor

[image]

Sitecore 6.4.1 API
ConfigStore Constructor
ConfigStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected ConfigStore()
Visual Basic
Protected Sub New
Visual C++
protected:
ConfigStore()

See Also

ConfigStore Class
Sitecore.Configuration Namespace


ConfigStore Methods

[image] [image]

Sitecore 6.4.1 API
ConfigStore Methods
ConfigStore Class See Also Send Feedback

The ConfigStore type exposes the following members.

Methods

 | Name | Description
Public method | CommitChanges | Commits the changes.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTemplateRecord | Gets the template record.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Load | Loads the specified config store name.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotifyConfigChanged | Notify subscribers that the configuration has changed.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConfigStore Class
Sitecore.Configuration Namespace


CommitChanges Method

[image]

Sitecore 6.4.1 API
ConfigStore..::..CommitChanges Method
ConfigStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract void CommitChanges()
Visual Basic
Public MustOverride Sub CommitChanges
Visual C++
public:
virtual void CommitChanges() abstract

See Also

ConfigStore Class
Sitecore.Configuration Namespace


GetTemplateRecord Method

[image]

Sitecore 6.4.1 API
ConfigStore..::..GetTemplateRecord Method
ConfigStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ConfigRecord GetTemplateRecord(
    string recordName,
    string templateName
)
Visual Basic
Public Overridable Function GetTemplateRecord ( _
    recordName As String, _
    templateName As String _
) As ConfigRecord
Visual C++
public:
virtual ConfigRecord^ GetTemplateRecord(
    String^ recordName,
    String^ templateName
)

Parameters

recordName
Type: System..::..String
Name of the record.
templateName
Type: System..::..String
Name of the template.

Return Value

[Missing <returns> documentation for "M:Sitecore.Configuration.ConfigStore.GetTemplateRecord(System.String,System.String)"]

See Also

ConfigStore Class
Sitecore.Configuration Namespace


Load Method

[image]

Sitecore 6.4.1 API
ConfigStore..::..Load Method
ConfigStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ConfigStore Load(
    string configStoreName
)
Visual Basic
Public Shared Function Load ( _
    configStoreName As String _
) As ConfigStore
Visual C++
public:
static ConfigStore^ Load(
    String^ configStoreName
)

Parameters

configStoreName
Type: System..::..String
Name of the config store.

Return Value

[Missing <returns> documentation for "M:Sitecore.Configuration.ConfigStore.Load(System.String)"]

See Also

ConfigStore Class
Sitecore.Configuration Namespace


NotifyConfigChanged Method

[image]

Sitecore 6.4.1 API
ConfigStore..::..NotifyConfigChanged Method
ConfigStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void NotifyConfigChanged()
Visual Basic
Protected Overridable Sub NotifyConfigChanged
Visual C++
protected:
virtual void NotifyConfigChanged()

See Also

ConfigStore Class
Sitecore.Configuration Namespace


ConfigStore Properties

[image] [image]

Sitecore 6.4.1 API
ConfigStore Properties
ConfigStore Class See Also Send Feedback

The ConfigStore type exposes the following members.

Properties

 | Name | Description
Public property | RootRecord | Gets the root record.

See Also

ConfigStore Class
Sitecore.Configuration Namespace


RootRecord Property

[image]

Sitecore 6.4.1 API
ConfigStore..::..RootRecord Property
ConfigStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract ConfigRecord RootRecord { get; }
Visual Basic
Public MustOverride ReadOnly Property RootRecord As ConfigRecord
    Get
Visual C++
public:
virtual property ConfigRecord^ RootRecord {
    ConfigRecord^ get () abstract;
}

Field Value

The root record.

See Also

ConfigStore Class
Sitecore.Configuration Namespace


ConfigStore Events

[image] [image]

Sitecore 6.4.1 API
ConfigStore Events
ConfigStore Class See Also Send Feedback

The ConfigStore type exposes the following members.

Events

 | Name | Description
Public event | ConfigChanged | Occurs when configuration has been changed (externally).

See Also

ConfigStore Class
Sitecore.Configuration Namespace


ConfigChanged Event

[image]

Sitecore 6.4.1 API
ConfigStore..::..ConfigChanged Event
ConfigStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler ConfigChanged
Visual Basic
Public Event ConfigChanged As EventHandler
Visual C++
public:
 event EventHandler^ ConfigChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

ConfigStore Class
Sitecore.Configuration Namespace


ConfigWatcher Class

[image]

Sitecore 6.4.1 API
ConfigWatcher Class
Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ConfigWatcher : FileWatcher
Visual Basic
Public Class ConfigWatcher _
    Inherits FileWatcher
Visual C++
public ref class ConfigWatcher : public FileWatcher

Inheritance Hierarchy

System..::..Object
Sitecore.IO..::..FileWatcher
Sitecore.Configuration..::..ConfigWatcher

See Also

ConfigWatcher Members
Sitecore.Configuration Namespace


ConfigWatcher Members

[image] [image]

Sitecore 6.4.1 API
ConfigWatcher Members
ConfigWatcher Class Constructors Methods Properties Events See Also Send Feedback

The ConfigWatcher type exposes the following members.

Constructors

 | Name | Description
Public method | ConfigWatcher | Initializes a new instance of the ConfigWatcher class.

Methods

 | Name | Description
Protected method | Created | Called when a file has been created. (Overrides FileWatcher..::..Created(String).)
Protected method | Deleted | Called when a file has been deleted. (Overrides FileWatcher..::..Deleted(String).)
Public method | Dispose | Application shutdown handler (Inherited from FileWatcher.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Application startup handler (Inherited from FileWatcher.)
Protected method | InitializeWatcher | Initializes a file watcher. (Inherited from FileWatcher.)
Protected method | InitializeWorker | Initializes the worker. (Inherited from FileWatcher.)
Protected method | MapPathToSiteCore | Maps the path to a Sitecore path. (Inherited from FileWatcher.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnFileCreated | File has been created. (Inherited from FileWatcher.)
Protected method | OnFileDeleted | File has been deleted. (Inherited from FileWatcher.)
Protected method | OnFileRenamed | File has been renamed. (Inherited from FileWatcher.)
Protected method | PathShouldBeIngnored | Checks whether the pathes the should be ingnored. (Inherited from FileWatcher.)
 | PostponeEvents | Postpones the execution.
 | RegisterKnownConfigFile | Regsiters the known config file.
Protected method | Renamed | Called when a file has been renamed. (Overrides FileWatcher..::..Renamed(String, String).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Protected property | Folder | Gets the path to the monitored folder. (Inherited from FileWatcher.)

Events

Name | Description
ConfigChanged | Obsolete.

See Also

ConfigWatcher Class
Sitecore.Configuration Namespace


ConfigWatcher Constructor

[image]

Sitecore 6.4.1 API
ConfigWatcher Constructor
ConfigWatcher Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ConfigWatcher()
Visual Basic
Public Sub New
Visual C++
public:
ConfigWatcher()

See Also

ConfigWatcher Class
Sitecore.Configuration Namespace


ConfigWatcher Methods

[image] [image]

Sitecore 6.4.1 API
ConfigWatcher Methods
ConfigWatcher Class See Also Send Feedback

The ConfigWatcher type exposes the following members.

Methods

 | Name | Description
Protected method | Created | Called when a file has been created. (Overrides FileWatcher..::..Created(String).)
Protected method | Deleted | Called when a file has been deleted. (Overrides FileWatcher..::..Deleted(String).)
Public method | Dispose | Application shutdown handler (Inherited from FileWatcher.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Application startup handler (Inherited from FileWatcher.)
Protected method | InitializeWatcher | Initializes a file watcher. (Inherited from FileWatcher.)
Protected method | InitializeWorker | Initializes the worker. (Inherited from FileWatcher.)
Protected method | MapPathToSiteCore | Maps the path to a Sitecore path. (Inherited from FileWatcher.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnFileCreated | File has been created. (Inherited from FileWatcher.)
Protected method | OnFileDeleted | File has been deleted. (Inherited from FileWatcher.)
Protected method | OnFileRenamed | File has been renamed. (Inherited from FileWatcher.)
Protected method | PathShouldBeIngnored | Checks whether the pathes the should be ingnored. (Inherited from FileWatcher.)
 | PostponeEvents | Postpones the execution.
 | RegisterKnownConfigFile | Regsiters the known config file.
Protected method | Renamed | Called when a file has been renamed. (Overrides FileWatcher..::..Renamed(String, String).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConfigWatcher Class
Sitecore.Configuration Namespace


Created Method

[image]

Sitecore 6.4.1 API
ConfigWatcher..::..Created Method
ConfigWatcher Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void Created(
    string filePath
)
Visual Basic
Protected Overrides Sub Created ( _
    filePath As String _
)
Visual C++
protected:
virtual void Created(
    String^ filePath
) override

Parameters

filePath
Type: System..::..String
The file path.

See Also

ConfigWatcher Class
Sitecore.Configuration Namespace


PostponeEvents Method

[image]

Sitecore 6.4.1 API
ConfigWatcher..::..PostponeEvents Method
ConfigWatcher Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static IDisposable PostponeEvents()
Visual Basic
Public Shared Function PostponeEvents As IDisposable
Visual C++
public:
static IDisposable^ PostponeEvents()

Return Value

[Missing <returns> documentation for "M:Sitecore.Configuration.ConfigWatcher.PostponeEvents"]

See Also

ConfigWatcher Class
Sitecore.Configuration Namespace


RegisterKnownConfigFile Method

[image]

Sitecore 6.4.1 API
ConfigWatcher..::..RegisterKnownConfigFile Method
ConfigWatcher Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void RegisterKnownConfigFile(
    string configFilePath
)
Visual Basic
Public Shared Sub RegisterKnownConfigFile ( _
    configFilePath As String _
)
Visual C++
public:
static void RegisterKnownConfigFile(
    String^ configFilePath
)

Parameters

configFilePath
Type: System..::..String
The config file path.

See Also

ConfigWatcher Class
Sitecore.Configuration Namespace


Renamed Method

[image]

Sitecore 6.4.1 API
ConfigWatcher..::..Renamed Method
ConfigWatcher Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void Renamed(
    string filePath,
    string oldFilePath
)
Visual Basic
Protected Overrides Sub Renamed ( _
    filePath As String, _
    oldFilePath As String _
)
Visual C++
protected:
virtual void Renamed(
    String^ filePath,
    String^ oldFilePath
) override

Parameters

filePath
Type: System..::..String
The full path.
oldFilePath
Type: System..::..String
The old full path.

See Also

ConfigWatcher Class
Sitecore.Configuration Namespace


ConfigWatcher Properties

[image] [image]

Sitecore 6.4.1 API
ConfigWatcher Properties
ConfigWatcher Class See Also Send Feedback

The ConfigWatcher type exposes the following members.

Properties

 | Name | Description
Protected property | Folder | Gets the path to the monitored folder. (Inherited from FileWatcher.)

See Also

ConfigWatcher Class
Sitecore.Configuration Namespace


ConfigWatcher Events

[image] [image]

Sitecore 6.4.1 API
ConfigWatcher Events
ConfigWatcher Class See Also Send Feedback

The ConfigWatcher type exposes the following members.

Events

Name | Description
ConfigChanged | Obsolete.

See Also

ConfigWatcher Class
Sitecore.Configuration Namespace


ConfigChanged Event

[image]

Sitecore 6.4.1 API
ConfigWatcher..::..ConfigChanged Event
ConfigWatcher Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated. Config watcher will restart ASP.NET process when configuration files are changed.")]
public static event EventHandler<ConfigChangedEventArgs> ConfigChanged
Visual Basic
<ObsoleteAttribute("Deprecated. Config watcher will restart ASP.NET process when configuration files are changed.")> _
Public Shared Event ConfigChanged As EventHandler(Of ConfigChangedEventArgs)
Visual C++
[ObsoleteAttribute(L"Deprecated. Config watcher will restart ASP.NET process when configuration files are changed.")]
public:
static  event EventHandler<ConfigChangedEventArgs^>^ ConfigChanged {
    void add (EventHandler<ConfigChangedEventArgs^>^ value);
    void remove (EventHandler<ConfigChangedEventArgs^>^ value);
}

See Also

ConfigWatcher Class
Sitecore.Configuration Namespace


Factory Class

[image]

Sitecore 6.4.1 API
Factory Class
Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Factory
Visual Basic
Public NotInheritable Class Factory
Visual C++
public ref class Factory abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Factory

See Also

Factory Members
Sitecore.Configuration Namespace


Factory Methods

[image] [image]

Sitecore 6.4.1 API
Factory Methods
Factory Class See Also Send Feedback

The Factory type exposes the following members.

Methods

Name | Description
CreateErrorControl | Creates an error control.
CreateItemNavigator | Creates an item navigator.
CreateObject(String, Boolean) | Creates the object.
CreateObject(XmlNode, Boolean) | Creates the object.
CreateObject(String, array<String>[]()[][], Boolean) | Creates the object.
CreateObject(XmlNode, array<String>[]()[][], Boolean) | Creates the object.
CreateObject(XmlNode, array<String>[]()[][], Boolean, IFactoryHelper) | Creates the object.
CreateObject<(Of <<'(T>)>>)(XmlNode) | Creates an object from a configuration node.
CreateType(XmlNode, Boolean) | Creates the type.
CreateType(XmlNode, array<String>[]()[][], Boolean) | Creates the type.
FindType | Finds the type.
GetAttribute | Gets the attribute.
GetConfigNode(String) | Gets a config node.
GetConfigNode(String, Boolean) | Gets a config node.
GetConfigNodes | Gets a set of config nodes.
GetConfigStore | Gets the config store.
GetConfiguration | Gets the configuration.
GetCustomHandlers | Gets the request handlers.
GetDatabase(String) | Gets the database.
GetDatabase(String, Boolean) | Gets the database.
GetDatabaseNames | Gets the database names.
GetDatabases | Gets all databases.
GetDomain | Gets the domain.
GetDomainMap | Gets the domain map.
GetDomainNames | Gets the domain names.
GetHashtable | Gets the hash table.
GetIDTable | Gets the ID table.
GetIndex | Gets the index.
GetItemComparer | Gets an item comparer.
GetLinkDatabase | Gets the link database.
GetMasterVariablesReplacer | Gets the object used for replacing variables when creating a master.
GetPerformanceCounters | Gets the performance counters.
GetProviders<(Of <<'(TProvider, TCollection>)>>) | Gets a list of providers.
GetReplacer | Gets the replacer.
GetSite | Gets the site.
GetSiteInfo | Gets the site info.
GetSiteInfoList | Gets a list of all site info instances.
GetSiteNames | Gets the site names.
GetSites | Obsolete. Gets all sites.
GetSitesInfo | Obsolete. Gets a list of all site info instances.
GetString | Gets the string.
GetStringSet | Gets a string set from config.
GetTaskDatabase | Gets the task database.
Reset | Resets all cached information.

See Also

Factory Class
Sitecore.Configuration Namespace


CreateErrorControl Method

[image]

Sitecore 6.4.1 API
Factory..::..CreateErrorControl Method
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ErrorControl CreateErrorControl(
    string message,
    string details
)
Visual Basic
Public Shared Function CreateErrorControl ( _
    message As String, _
    details As String _
) As ErrorControl
Visual C++
public:
static ErrorControl^ CreateErrorControl(
    String^ message,
    String^ details
)

Parameters

message
Type: System..::..String
The message.
details
Type: System..::..String
The details.

Return Value

The Error Control object.

See Also

Factory Class
Sitecore.Configuration Namespace


CreateItemNavigator Method

[image]

Sitecore 6.4.1 API
Factory..::..CreateItemNavigator Method
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ItemNavigator CreateItemNavigator(
    Item item
)
Visual Basic
Public Shared Function CreateItemNavigator ( _
    item As Item _
) As ItemNavigator
Visual C++
public:
static ItemNavigator^ CreateItemNavigator(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item.

Return Value

The Item Navigator.

See Also

Factory Class
Sitecore.Configuration Namespace


CreateObject Method

[image] [image]

Sitecore 6.4.1 API
Factory..::..CreateObject Method
Factory Class See Also Send Feedback

Overload List

Name | Description
CreateObject<(Of <<'(T>)>>)(XmlNode) | Creates an object from a configuration node.
CreateObject(String, Boolean) | Creates the object.
CreateObject(XmlNode, Boolean) | Creates the object.
CreateObject(String, array<String>[]()[][], Boolean) | Creates the object.
CreateObject(XmlNode, array<String>[]()[][], Boolean) | Creates the object.
CreateObject(XmlNode, array<String>[]()[][], Boolean, IFactoryHelper) | Creates the object.

See Also

Factory Class
Factory Members
Sitecore.Configuration Namespace


CreateObject(T) Method (XmlNode)

[image]

Sitecore 6.4.1 API
Factory..::..CreateObject<(Of <(<'T>)>)> Method (XmlNode)
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static T CreateObject<T>(
    XmlNode configNode
)
where T : class
Visual Basic
Public Shared Function CreateObject(Of T As Class) ( _
    configNode As XmlNode _
) As T
Visual C++
public:
generic<typename T>
where T : ref class
static T CreateObject(
    XmlNode^ configNode
)

Parameters

configNode
Type: System.Xml..::..XmlNode
The config node.

Type Parameters

T
The type of object to create.

Return Value

The object of type T

Exceptions

Exception | Condition
Sitecore.Exceptions..::..ConfigurationException | ConfigurationException.

See Also

Factory Class
CreateObject Overload
Sitecore.Configuration Namespace


CreateObject Method (String, Boolean)

[image]

Sitecore 6.4.1 API
Factory..::..CreateObject Method (String, Boolean)
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object CreateObject(
    string configPath,
    bool assert
)
Visual Basic
Public Shared Function CreateObject ( _
    configPath As String, _
    assert As Boolean _
) As Object
Visual C++
public:
static Object^ CreateObject(
    String^ configPath,
    bool assert
)

Parameters

configPath
Type: System..::..String
The config path.
assert
Type: System..::..Boolean
if set to true this instance is assert.

Return Value

The create object.

See Also

Factory Class
CreateObject Overload
Sitecore.Configuration Namespace


CreateObject Method (XmlNode, Boolean)

[image]

Sitecore 6.4.1 API
Factory..::..CreateObject Method (XmlNode, Boolean)
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object CreateObject(
    XmlNode configNode,
    bool assert
)
Visual Basic
Public Shared Function CreateObject ( _
    configNode As XmlNode, _
    assert As Boolean _
) As Object
Visual C++
public:
static Object^ CreateObject(
    XmlNode^ configNode,
    bool assert
)

Parameters

configNode
Type: System.Xml..::..XmlNode
The config node.
assert
Type: System..::..Boolean
if set to true this instance is assert.

Return Value

The create object.

See Also

Factory Class
CreateObject Overload
Sitecore.Configuration Namespace


CreateObject Method (String, String[], Boolean)

[image]

Sitecore 6.4.1 API
Factory..::..CreateObject Method (String, array<String>[]()[][], Boolean)
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object CreateObject(
    string configPath,
    string[] parameters,
    bool assert
)
Visual Basic
Public Shared Function CreateObject ( _
    configPath As String, _
    parameters As String(), _
    assert As Boolean _
) As Object
Visual C++
public:
static Object^ CreateObject(
    String^ configPath,
    array<String^>^ parameters,
    bool assert
)

Parameters

configPath
Type: System..::..String
The config path.
parameters
Type: array< System..::..String >[]()[][]
The parameters.
assert
Type: System..::..Boolean
if set to true this instance is assert.

Return Value

The create object.

See Also

Factory Class
CreateObject Overload
Sitecore.Configuration Namespace


CreateObject Method (XmlNode, String[], Boolean)

[image]

Sitecore 6.4.1 API
Factory..::..CreateObject Method (XmlNode, array<String>[]()[][], Boolean)
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object CreateObject(
    XmlNode configNode,
    string[] parameters,
    bool assert
)
Visual Basic
Public Shared Function CreateObject ( _
    configNode As XmlNode, _
    parameters As String(), _
    assert As Boolean _
) As Object
Visual C++
public:
static Object^ CreateObject(
    XmlNode^ configNode,
    array<String^>^ parameters,
    bool assert
)

Parameters

configNode
Type: System.Xml..::..XmlNode
The config node.
parameters
Type: array< System..::..String >[]()[][]
The parameters.
assert
Type: System..::..Boolean
if set to true this instance is assert.

Return Value

The create object.

See Also

Factory Class
CreateObject Overload
Sitecore.Configuration Namespace


CreateObject Method (XmlNode, String[], Boolean, IFactoryHelper)

[image]

Sitecore 6.4.1 API
Factory..::..CreateObject Method (XmlNode, array<String>[]()[][], Boolean, IFactoryHelper)
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object CreateObject(
    XmlNode configNode,
    string[] parameters,
    bool assert,
    IFactoryHelper helper
)
Visual Basic
Public Shared Function CreateObject ( _
    configNode As XmlNode, _
    parameters As String(), _
    assert As Boolean, _
    helper As IFactoryHelper _
) As Object
Visual C++
public:
static Object^ CreateObject(
    XmlNode^ configNode,
    array<String^>^ parameters,
    bool assert,
    IFactoryHelper^ helper
)

Parameters

configNode
Type: System.Xml..::..XmlNode
The config node.
parameters
Type: array< System..::..String >[]()[][]
The parameters.
assert
Type: System..::..Boolean
If set to true throw an exception if the object could not be created.
helper
Type: Sitecore.Configuration..::..IFactoryHelper
The helper.

Return Value

The object.

See Also

Factory Class
CreateObject Overload
Sitecore.Configuration Namespace


CreateType Method

[image] [image]

Sitecore 6.4.1 API
Factory..::..CreateType Method
Factory Class See Also Send Feedback

Overload List

Name | Description
CreateType(XmlNode, Boolean) | Creates the type.
CreateType(XmlNode, array<String>[]()[][], Boolean) | Creates the type.

See Also

Factory Class
Factory Members
Sitecore.Configuration Namespace


CreateType Method (XmlNode, Boolean)

[image]

Sitecore 6.4.1 API
Factory..::..CreateType Method (XmlNode, Boolean)
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Type CreateType(
    XmlNode configNode,
    bool assert
)
Visual Basic
Public Shared Function CreateType ( _
    configNode As XmlNode, _
    assert As Boolean _
) As Type
Visual C++
public:
static Type^ CreateType(
    XmlNode^ configNode,
    bool assert
)

Parameters

configNode
Type: System.Xml..::..XmlNode
The config node.
assert
Type: System..::..Boolean
if set to true this instance is assert.

Return Value

The Type object.

See Also

Factory Class
CreateType Overload
Sitecore.Configuration Namespace


CreateType Method (XmlNode, String[], Boolean)

[image]

Sitecore 6.4.1 API
Factory..::..CreateType Method (XmlNode, array<String>[]()[][], Boolean)
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Type CreateType(
    XmlNode configNode,
    string[] parameters,
    bool assert
)
Visual Basic
Public Shared Function CreateType ( _
    configNode As XmlNode, _
    parameters As String(), _
    assert As Boolean _
) As Type
Visual C++
public:
static Type^ CreateType(
    XmlNode^ configNode,
    array<String^>^ parameters,
    bool assert
)

Parameters

configNode
Type: System.Xml..::..XmlNode
The config node.
parameters
Type: array< System..::..String >[]()[][]
The parameters.
assert
Type: System..::..Boolean
if set to true this instance is assert.

Return Value

The Type object.

See Also

Factory Class
CreateType Overload
Sitecore.Configuration Namespace


FindType Method

[image]

Sitecore 6.4.1 API
Factory..::..FindType Method
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Type FindType(
    string className,
    Assembly assembly
)
Visual Basic
Public Shared Function FindType ( _
    className As String, _
    assembly As Assembly _
) As Type
Visual C++
public:
static Type^ FindType(
    String^ className,
    Assembly^ assembly
)

Parameters

className
Type: System..::..String
Name of the class.
assembly
Type: System.Reflection..::..Assembly
The assembly.

Return Value

The Type object.

See Also

Factory Class
Sitecore.Configuration Namespace


GetAttribute Method

[image]

Sitecore 6.4.1 API
Factory..::..GetAttribute Method
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetAttribute(
    string name,
    XmlNode node,
    string[] parameters
)
Visual Basic
Public Shared Function GetAttribute ( _
    name As String, _
    node As XmlNode, _
    parameters As String() _
) As String
Visual C++
public:
static String^ GetAttribute(
    String^ name,
    XmlNode^ node,
    array<String^>^ parameters
)

Parameters

name
Type: System..::..String
The attribute name.
node
Type: System.Xml..::..XmlNode
The Xml node.
parameters
Type: array< System..::..String >[]()[][]
The parameters.

Return Value

The attribute.

See Also

Factory Class
Sitecore.Configuration Namespace


GetConfigNode Method

[image] [image]

Sitecore 6.4.1 API
Factory..::..GetConfigNode Method
Factory Class See Also Send Feedback

Overload List

Name | Description
GetConfigNode(String) | Gets a config node.
GetConfigNode(String, Boolean) | Gets a config node.

See Also

Factory Class
Factory Members
Sitecore.Configuration Namespace


GetConfigNode Method (String)

[image]

Sitecore 6.4.1 API
Factory..::..GetConfigNode Method (String)
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static XmlNode GetConfigNode(
    string xpath
)
Visual Basic
Public Shared Function GetConfigNode ( _
    xpath As String _
) As XmlNode
Visual C++
public:
static XmlNode^ GetConfigNode(
    String^ xpath
)

Parameters

xpath
Type: System..::..String
The Xpath.

Return Value

The config node.

See Also

Factory Class
GetConfigNode Overload
Sitecore.Configuration Namespace


GetConfigNode Method (String, Boolean)

[image]

Sitecore 6.4.1 API
Factory..::..GetConfigNode Method (String, Boolean)
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static XmlNode GetConfigNode(
    string xpath,
    bool assert
)
Visual Basic
Public Shared Function GetConfigNode ( _
    xpath As String, _
    assert As Boolean _
) As XmlNode
Visual C++
public:
static XmlNode^ GetConfigNode(
    String^ xpath,
    bool assert
)

Parameters

xpath
Type: System..::..String
The Xpath.
assert
Type: System..::..Boolean
if set to true assert that the node is not null.

Return Value

The config node.

See Also

Factory Class
GetConfigNode Overload
Sitecore.Configuration Namespace


GetConfigNodes Method

[image]

Sitecore 6.4.1 API
Factory..::..GetConfigNodes Method
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static XmlNodeList GetConfigNodes(
    string xpath
)
Visual Basic
Public Shared Function GetConfigNodes ( _
    xpath As String _
) As XmlNodeList
Visual C++
public:
static XmlNodeList^ GetConfigNodes(
    String^ xpath
)

Parameters

xpath
Type: System..::..String
The Xpath.

Return Value

The Configuration nodes.

See Also

Factory Class
Sitecore.Configuration Namespace


GetConfigStore Method

[image]

Sitecore 6.4.1 API
Factory..::..GetConfigStore Method
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ConfigStore GetConfigStore(
    string configStoreName
)
Visual Basic
Public Shared Function GetConfigStore ( _
    configStoreName As String _
) As ConfigStore
Visual C++
public:
static ConfigStore^ GetConfigStore(
    String^ configStoreName
)

Parameters

configStoreName
Type: System..::..String
Name of the config store.

Return Value

The ConfigStore object.

Exceptions

Exception | Condition
Sitecore.Exceptions..::..ConfigurationException | ConfigurationException.

See Also

Factory Class
Sitecore.Configuration Namespace


GetConfiguration Method

[image]

Sitecore 6.4.1 API
Factory..::..GetConfiguration Method
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static XmlDocument GetConfiguration()
Visual Basic
Public Shared Function GetConfiguration As XmlDocument
Visual C++
public:
static XmlDocument^ GetConfiguration()

Return Value

Xml document containing the entire Sitecore configuration.

See Also

Factory Class
Sitecore.Configuration Namespace


GetCustomHandlers Method

[image]

Sitecore 6.4.1 API
Factory..::..GetCustomHandlers Method
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static List<CustomHandler> GetCustomHandlers()
Visual Basic
Public Shared Function GetCustomHandlers As List(Of CustomHandler)
Visual C++
public:
static List<CustomHandler^>^ GetCustomHandlers()

Return Value

The request handlers.

Exceptions

Exception | Condition
System..::..InvalidOperationException | InvalidOperationException.

See Also

Factory Class
Sitecore.Configuration Namespace


GetDatabase Method

[image] [image]

Sitecore 6.4.1 API
Factory..::..GetDatabase Method
Factory Class See Also Send Feedback

Overload List

Name | Description
GetDatabase(String) | Gets the database.
GetDatabase(String, Boolean) | Gets the database.

See Also

Factory Class
Factory Members
Sitecore.Configuration Namespace


GetDatabase Method (String)

[image]

Sitecore 6.4.1 API
Factory..::..GetDatabase Method (String)
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Database GetDatabase(
    string name
)
Visual Basic
Public Shared Function GetDatabase ( _
    name As String _
) As Database
Visual C++
public:
static Database^ GetDatabase(
    String^ name
)

Parameters

name
Type: System..::..String
The database name.

Return Value

The Database object.

See Also

Factory Class
GetDatabase Overload
Sitecore.Configuration Namespace


GetDatabase Method (String, Boolean)

[image]

Sitecore 6.4.1 API
Factory..::..GetDatabase Method (String, Boolean)
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Database GetDatabase(
    string name,
    bool assert
)
Visual Basic
Public Shared Function GetDatabase ( _
    name As String, _
    assert As Boolean _
) As Database
Visual C++
public:
static Database^ GetDatabase(
    String^ name,
    bool assert
)

Parameters

name
Type: System..::..String
The database name.
assert
Type: System..::..Boolean
if set to true exception will be thrown if database does not exist.

Return Value

The Database object.

See Also

Factory Class
GetDatabase Overload
Sitecore.Configuration Namespace


GetDatabaseNames Method

[image]

Sitecore 6.4.1 API
Factory..::..GetDatabaseNames Method
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string[] GetDatabaseNames()
Visual Basic
Public Shared Function GetDatabaseNames As String()
Visual C++
public:
static array<String^>^ GetDatabaseNames()

Return Value

The list of registered in configuration file database names.

See Also

Factory Class
Sitecore.Configuration Namespace


GetDatabases Method

[image]

Sitecore 6.4.1 API
Factory..::..GetDatabases Method
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static List<Database> GetDatabases()
Visual Basic
Public Shared Function GetDatabases As List(Of Database)
Visual C++
public:
static List<Database^>^ GetDatabases()

Return Value

The list of registered in configuration file databases.

See Also

Factory Class
Sitecore.Configuration Namespace


GetDomain Method

[image]

Sitecore 6.4.1 API
Factory..::..GetDomain Method
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Domain GetDomain(
    string name
)
Visual Basic
Public Shared Function GetDomain ( _
    name As String _
) As Domain
Visual C++
public:
static Domain^ GetDomain(
    String^ name
)

Parameters

name
Type: System..::..String
The domain name.

Return Value

The list of registered in configuration file database objects.

See Also

Factory Class
Sitecore.Configuration Namespace


GetDomainMap Method

[image]

Sitecore 6.4.1 API
Factory..::..GetDomainMap Method
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static StringDictionary GetDomainMap(
    string path
)
Visual Basic
Public Shared Function GetDomainMap ( _
    path As String _
) As StringDictionary
Visual C++
public:
static StringDictionary^ GetDomainMap(
    String^ path
)

Parameters

path
Type: System..::..String
The domain map Xml path.

Return Value

The domain map.

See Also

Factory Class
Sitecore.Configuration Namespace


GetDomainNames Method

[image]

Sitecore 6.4.1 API
Factory..::..GetDomainNames Method
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string[] GetDomainNames()
Visual Basic
Public Shared Function GetDomainNames As String()
Visual C++
public:
static array<String^>^ GetDomainNames()

Return Value

The array of damain names.

See Also

Factory Class
Sitecore.Configuration Namespace


GetHashtable Method

[image]

Sitecore 6.4.1 API
Factory..::..GetHashtable Method
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Hashtable GetHashtable(
    string path,
    Factory..::..HashKeyType keyType,
    Factory..::..HashValueType valueType,
    Factory..::..HashValueFormat format,
    Type dataType
)
Visual Basic
Public Shared Function GetHashtable ( _
    path As String, _
    keyType As Factory..::..HashKeyType, _
    valueType As Factory..::..HashValueType, _
    format As Factory..::..HashValueFormat, _
    dataType As Type _
) As Hashtable
Visual C++
public:
static Hashtable^ GetHashtable(
    String^ path,
    Factory..::..HashKeyType keyType,
    Factory..::..HashValueType valueType,
    Factory..::..HashValueFormat format,
    Type^ dataType
)

Parameters

path
Type: System..::..String
The Xml path.
keyType
Type: Sitecore.Configuration..::..Factory..::..HashKeyType
Type of the key.
valueType
Type: Sitecore.Configuration..::..Factory..::..HashValueType
Type of the value.
format
Type: Sitecore.Configuration..::..Factory..::..HashValueFormat
The format.
dataType
Type: System..::..Type
Type of the data.

Return Value

The Hashtable.

See Also

Factory Class
Sitecore.Configuration Namespace


GetIDTable Method

[image]

Sitecore 6.4.1 API
Factory..::..GetIDTable Method
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static IDTableProvider GetIDTable()
Visual Basic
Public Shared Function GetIDTable As IDTableProvider
Visual C++
public:
static IDTableProvider^ GetIDTable()

Return Value

The IDTable provider.

See Also

Factory Class
Sitecore.Configuration Namespace


GetItemComparer Method

[image]

Sitecore 6.4.1 API
Factory..::..GetItemComparer Method
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static IComparer<Item> GetItemComparer(
    Item item
)
Visual Basic
Public Shared Function GetItemComparer ( _
    item As Item _
) As IComparer(Of Item)
Visual C++
public:
static IComparer<Item^>^ GetItemComparer(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item.

Return Value

The Item comparer.

See Also

Factory Class
Sitecore.Configuration Namespace


GetLinkDatabase Method

[image]

Sitecore 6.4.1 API
Factory..::..GetLinkDatabase Method
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static LinkDatabase GetLinkDatabase()
Visual Basic
Public Shared Function GetLinkDatabase As LinkDatabase
Visual C++
public:
static LinkDatabase^ GetLinkDatabase()

Return Value

The LinkDatabase.

Exceptions

Exception | Condition
Sitecore.Exceptions..::..InvalidTypeException | LinkDatabase object is of wrong type

See Also

Factory Class
Sitecore.Configuration Namespace


GetMasterVariablesReplacer Method

[image]

Sitecore 6.4.1 API
Factory..::..GetMasterVariablesReplacer Method
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static MasterVariablesReplacer GetMasterVariablesReplacer()
Visual Basic
Public Shared Function GetMasterVariablesReplacer As MasterVariablesReplacer
Visual C++
public:
static MasterVariablesReplacer^ GetMasterVariablesReplacer()

Return Value

The MasterVariables replacer.

See Also

Factory Class
Sitecore.Configuration Namespace


GetPerformanceCounters Method

[image]

Sitecore 6.4.1 API
Factory..::..GetPerformanceCounters Method
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounterCollection GetPerformanceCounters()
Visual Basic
Public Shared Function GetPerformanceCounters As PerformanceCounterCollection
Visual C++
public:
static PerformanceCounterCollection^ GetPerformanceCounters()

Return Value

The performance counters.

See Also

Factory Class
Sitecore.Configuration Namespace


GetReplacer Method

[image]

Sitecore 6.4.1 API
Factory..::..GetReplacer Method
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Replacer GetReplacer(
    string name
)
Visual Basic
Public Shared Function GetReplacer ( _
    name As String _
) As Replacer
Visual C++
public:
static Replacer^ GetReplacer(
    String^ name
)

Parameters

name
Type: System..::..String
The replacer name.

Return Value

The replacer.

See Also

Factory Class
Sitecore.Configuration Namespace


GetSite Method

[image]

Sitecore 6.4.1 API
Factory..::..GetSite Method
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static SiteContext GetSite(
    string siteName
)
Visual Basic
Public Shared Function GetSite ( _
    siteName As String _
) As SiteContext
Visual C++
public:
static SiteContext^ GetSite(
    String^ siteName
)

Parameters

siteName
Type: System..::..String
Name of the site.

Return Value

The site by name.

See Also

Factory Class
Sitecore.Configuration Namespace


GetSiteInfo Method

[image]

Sitecore 6.4.1 API
Factory..::..GetSiteInfo Method
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static SiteInfo GetSiteInfo(
    string siteName
)
Visual Basic
Public Shared Function GetSiteInfo ( _
    siteName As String _
) As SiteInfo
Visual C++
public:
static SiteInfo^ GetSiteInfo(
    String^ siteName
)

Parameters

siteName
Type: System..::..String
Name of the site.

Return Value

The site info.

See Also

Factory Class
Sitecore.Configuration Namespace


GetSiteInfoList Method

[image]

Sitecore 6.4.1 API
Factory..::..GetSiteInfoList Method
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static List<SiteInfo> GetSiteInfoList()
Visual Basic
Public Shared Function GetSiteInfoList As List(Of SiteInfo)
Visual C++
public:
static List<SiteInfo^>^ GetSiteInfoList()

Return Value

Gets all sites.

See Also

Factory Class
Sitecore.Configuration Namespace


GetSiteNames Method

[image]

Sitecore 6.4.1 API
Factory..::..GetSiteNames Method
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string[] GetSiteNames()
Visual Basic
Public Shared Function GetSiteNames As String()
Visual C++
public:
static array<String^>^ GetSiteNames()

Return Value

The site names.

See Also

Factory Class
Sitecore.Configuration Namespace


GetSites Method

[image]

Sitecore 6.4.1 API
Factory..::..GetSites Method
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use GetSitesInfo() method instead")]
public static List<SiteContext> GetSites()
Visual Basic
<ObsoleteAttribute("Use GetSitesInfo() method instead")> _
Public Shared Function GetSites As List(Of SiteContext)
Visual C++
[ObsoleteAttribute(L"Use GetSitesInfo() method instead")]
public:
static List<SiteContext^>^ GetSites()

Return Value

The sites.

See Also

Factory Class
Sitecore.Configuration Namespace


GetSitesInfo Method

[image]

Sitecore 6.4.1 API
Factory..::..GetSitesInfo Method
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use GetSiteInfoList instead.")]
public static List<SiteInfo> GetSitesInfo()
Visual Basic
<ObsoleteAttribute("Deprecated - Use GetSiteInfoList instead.")> _
Public Shared Function GetSitesInfo As List(Of SiteInfo)
Visual C++
[ObsoleteAttribute(L"Deprecated - Use GetSiteInfoList instead.")]
public:
static List<SiteInfo^>^ GetSitesInfo()

Return Value

Gets all sites.

See Also

Factory Class
Sitecore.Configuration Namespace


GetString Method

[image]

Sitecore 6.4.1 API
Factory..::..GetString Method
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetString(
    string configPath,
    bool assert
)
Visual Basic
Public Shared Function GetString ( _
    configPath As String, _
    assert As Boolean _
) As String
Visual C++
public:
static String^ GetString(
    String^ configPath,
    bool assert
)

Parameters

configPath
Type: System..::..String
The config path.
assert
Type: System..::..Boolean
if set to true this instance is assert.

Return Value

The string.

See Also

Factory Class
Sitecore.Configuration Namespace


GetStringSet Method

[image]

Sitecore 6.4.1 API
Factory..::..GetStringSet Method
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Set<string> GetStringSet(
    string configPath
)
Visual Basic
Public Shared Function GetStringSet ( _
    configPath As String _
) As Set(Of String)
Visual C++
public:
static Set<String^>^ GetStringSet(
    String^ configPath
)

Parameters

configPath
Type: System..::..String
The config path.

Return Value

The set of inner texts of Xml nodes with specified path.

See Also

Factory Class
Sitecore.Configuration Namespace


GetTaskDatabase Method

[image]

Sitecore 6.4.1 API
Factory..::..GetTaskDatabase Method
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TaskDatabase GetTaskDatabase()
Visual Basic
Public Shared Function GetTaskDatabase As TaskDatabase
Visual C++
public:
static TaskDatabase^ GetTaskDatabase()

Return Value

The task database.

Exceptions

Exception | Condition
Sitecore.Exceptions..::..InvalidTypeException | TaskDatabase object is of wrong type

See Also

Factory Class
Sitecore.Configuration Namespace


Reset Method

[image]

Sitecore 6.4.1 API
Factory..::..Reset Method
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Reset()
Visual Basic
Public Shared Sub Reset
Visual C++
public:
static void Reset()

Remarks

This will cause all configuration data to be reloaded.

See Also

Factory Class
Sitecore.Configuration Namespace


Factory.HashKeyType Enumeration

[image]

Sitecore 6.4.1 API
Factory..::..HashKeyType Enumeration
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum HashKeyType
Visual Basic
Public Enumeration HashKeyType
Visual C++
public enum class HashKeyType

Members

Member name | Value | Description
NodeName | 0 | Node name.

See Also

Sitecore.Configuration Namespace


Factory.HashValueFormat Enumeration

[image]

Sitecore 6.4.1 API
Factory..::..HashValueFormat Enumeration
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum HashValueFormat
Visual Basic
Public Enumeration HashValueFormat
Visual C++
public enum class HashValueFormat

Members

Member name | Value | Description
SingleObject | 0 | Single object.
Array | 1 | Array object.

See Also

Sitecore.Configuration Namespace


Factory.HashValueType Enumeration

[image]

Sitecore 6.4.1 API
Factory..::..HashValueType Enumeration
Factory Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum HashValueType
Visual Basic
Public Enumeration HashValueType
Visual C++
public enum class HashValueType

Members

Member name | Value | Description
NodeName | 0 | Node name.
Object | 1 | Object type.

See Also

Sitecore.Configuration Namespace


FileDataStore Class

[image]

Sitecore 6.4.1 API
FileDataStore Class
Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FileDataStore : ClientDataStore
Visual Basic
Public Class FileDataStore _
    Inherits ClientDataStore
Visual C++
public ref class FileDataStore : public ClientDataStore

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..ClientDataStore
Sitecore.Configuration..::..FileDataStore

See Also

FileDataStore Members
Sitecore.Configuration Namespace


FileDataStore Members

[image] [image]

Sitecore 6.4.1 API
FileDataStore Members
FileDataStore Class Constructors Methods Properties See Also Send Feedback

The FileDataStore type exposes the following members.

Constructors

 | Name | Description
Public method | FileDataStore | Initializes a new instance of the FileDataStore class.

Methods

 | Name | Description
Protected method | AddDataToCache | Adds data to the cache. (Inherited from ClientDataStore.)
Public method | Compact | Compacts this instance. (Inherited from ClientDataStore.)
Protected method | CompactData | Compacts the data. (Overrides ClientDataStore..::..CompactData()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetDataFromCache | Gets data from the cache. (Inherited from ClientDataStore.)
Protected method | GetDataKey | Gets the data key. (Inherited from ClientDataStore.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSize | Gets the size of newly returned data. (Inherited from ClientDataStore.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the value. (Inherited from ClientDataStore.)
Public method | GetValueNames | Gets the value names. (Inherited from ClientDataStore.)
Protected method | LoadData()()()() | Loads the data. (Inherited from ClientDataStore.)
Protected method | LoadData(String) | Loads the data. (Overrides ClientDataStore..::..LoadData(String).)
Public method | LoadViewstate | Loads the viewstate. (Inherited from ClientDataStore.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveAll | Removes the values. (Inherited from ClientDataStore.)
Protected method | RemoveAllData | Removes all data. (Inherited from ClientDataStore.)
Protected method | RemoveData()()()() | Removes the data. (Inherited from ClientDataStore.)
Protected method | RemoveData(String) | Removes the data. (Overrides ClientDataStore..::..RemoveData(String).)
Protected method | RemoveDataFromCache | Removes data from the cache. (Inherited from ClientDataStore.)
Public method | RemoveValue | Removes the value. (Inherited from ClientDataStore.)
Public method | RemoveValues | Removes the values. (Inherited from ClientDataStore.)
Public method | RemoveViewstate | Removes the viewstate. (Inherited from ClientDataStore.)
Protected method | SaveData(Hashtable) | Saves the data. (Overrides ClientDataStore..::..SaveData(Hashtable).)
Protected method | SaveData(String, String) | Saves the data. (Overrides ClientDataStore..::..SaveData(String, String).)
Public method | SaveViewstate | Saves the viewstate. (Inherited from ClientDataStore.)
Public method | SetValue(String, String) | Sets the value. (Inherited from ClientDataStore.)
Public method | SetValue(String, Object, String) | Sets the value. (Inherited from ClientDataStore.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TouchActiveData | Touches all active data. (Inherited from ClientDataStore.)
Protected method | TouchData | Touches the data represented by key. (Inherited from ClientDataStore.)

Properties

 | Name | Description
Public property | ObjectLifetime | Gets the object lifetime. (Inherited from ClientDataStore.)

See Also

FileDataStore Class
Sitecore.Configuration Namespace


FileDataStore Constructor

[image]

Sitecore 6.4.1 API
FileDataStore Constructor
FileDataStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FileDataStore(
    string baseFolder,
    string objectLifetime
)
Visual Basic
Public Sub New ( _
    baseFolder As String, _
    objectLifetime As String _
)
Visual C++
public:
FileDataStore(
    String^ baseFolder,
    String^ objectLifetime
)

Parameters

baseFolder
Type: System..::..String
The base folder.
objectLifetime
Type: System..::..String
The object lifetime.

See Also

FileDataStore Class
Sitecore.Configuration Namespace


FileDataStore Methods

[image] [image]

Sitecore 6.4.1 API
FileDataStore Methods
FileDataStore Class See Also Send Feedback

The FileDataStore type exposes the following members.

Methods

 | Name | Description
Protected method | AddDataToCache | Adds data to the cache. (Inherited from ClientDataStore.)
Public method | Compact | Compacts this instance. (Inherited from ClientDataStore.)
Protected method | CompactData | Compacts the data. (Overrides ClientDataStore..::..CompactData()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetDataFromCache | Gets data from the cache. (Inherited from ClientDataStore.)
Protected method | GetDataKey | Gets the data key. (Inherited from ClientDataStore.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSize | Gets the size of newly returned data. (Inherited from ClientDataStore.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the value. (Inherited from ClientDataStore.)
Public method | GetValueNames | Gets the value names. (Inherited from ClientDataStore.)
Protected method | LoadData()()()() | Loads the data. (Inherited from ClientDataStore.)
Protected method | LoadData(String) | Loads the data. (Overrides ClientDataStore..::..LoadData(String).)
Public method | LoadViewstate | Loads the viewstate. (Inherited from ClientDataStore.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveAll | Removes the values. (Inherited from ClientDataStore.)
Protected method | RemoveAllData | Removes all data. (Inherited from ClientDataStore.)
Protected method | RemoveData()()()() | Removes the data. (Inherited from ClientDataStore.)
Protected method | RemoveData(String) | Removes the data. (Overrides ClientDataStore..::..RemoveData(String).)
Protected method | RemoveDataFromCache | Removes data from the cache. (Inherited from ClientDataStore.)
Public method | RemoveValue | Removes the value. (Inherited from ClientDataStore.)
Public method | RemoveValues | Removes the values. (Inherited from ClientDataStore.)
Public method | RemoveViewstate | Removes the viewstate. (Inherited from ClientDataStore.)
Protected method | SaveData(Hashtable) | Saves the data. (Overrides ClientDataStore..::..SaveData(Hashtable).)
Protected method | SaveData(String, String) | Saves the data. (Overrides ClientDataStore..::..SaveData(String, String).)
Public method | SaveViewstate | Saves the viewstate. (Inherited from ClientDataStore.)
Public method | SetValue(String, String) | Sets the value. (Inherited from ClientDataStore.)
Public method | SetValue(String, Object, String) | Sets the value. (Inherited from ClientDataStore.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TouchActiveData | Touches all active data. (Inherited from ClientDataStore.)
Protected method | TouchData | Touches the data represented by key. (Inherited from ClientDataStore.)

See Also

FileDataStore Class
Sitecore.Configuration Namespace


CompactData Method

[image]

Sitecore 6.4.1 API
FileDataStore..::..CompactData Method
FileDataStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void CompactData()
Visual Basic
Protected Overrides Sub CompactData
Visual C++
protected:
virtual void CompactData() override

See Also

FileDataStore Class
Sitecore.Configuration Namespace


LoadData Method (String)

[image]

Sitecore 6.4.1 API
FileDataStore..::..LoadData Method (String)
FileDataStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override string LoadData(
    string key
)
Visual Basic
Protected Overrides Function LoadData ( _
    key As String _
) As String
Visual C++
protected:
virtual String^ LoadData(
    String^ key
) override

Parameters

key
Type: System..::..String

[Missing <param name="key"/> documentation for "M:Sitecore.Configuration.FileDataStore.LoadData(System.String)"]

Return Value

The data.

See Also

FileDataStore Class
LoadData Overload
Sitecore.Configuration Namespace


RemoveData Method

[image] [image]

Sitecore 6.4.1 API
FileDataStore..::..RemoveData Method
FileDataStore Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RemoveData()()()() | Removes the data. (Inherited from ClientDataStore.)
Protected method | RemoveData(String) | Removes the data. (Overrides ClientDataStore..::..RemoveData(String).)

See Also

FileDataStore Class
FileDataStore Members
Sitecore.Configuration Namespace


RemoveData Method (String)

[image]

Sitecore 6.4.1 API
FileDataStore..::..RemoveData Method (String)
FileDataStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void RemoveData(
    string key
)
Visual Basic
Protected Overrides Sub RemoveData ( _
    key As String _
)
Visual C++
protected:
virtual void RemoveData(
    String^ key
) override

Parameters

key
Type: System..::..String

[Missing <param name="key"/> documentation for "M:Sitecore.Configuration.FileDataStore.RemoveData(System.String)"]

See Also

FileDataStore Class
RemoveData Overload
Sitecore.Configuration Namespace


SaveData Method

[image] [image]

Sitecore 6.4.1 API
FileDataStore..::..SaveData Method
FileDataStore Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SaveData(Hashtable) | Saves the data. (Overrides ClientDataStore..::..SaveData(Hashtable).)
Protected method | SaveData(String, String) | Saves the data. (Overrides ClientDataStore..::..SaveData(String, String).)

See Also

FileDataStore Class
FileDataStore Members
Sitecore.Configuration Namespace


SaveData Method (Hashtable)

[image]

Sitecore 6.4.1 API
FileDataStore..::..SaveData Method (Hashtable)
FileDataStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void SaveData(
    Hashtable data
)
Visual Basic
Protected Overrides Sub SaveData ( _
    data As Hashtable _
)
Visual C++
protected:
virtual void SaveData(
    Hashtable^ data
) override

Parameters

data
Type: System.Collections..::..Hashtable
The data.

See Also

FileDataStore Class
SaveData Overload
Sitecore.Configuration Namespace


SaveData Method (String, String)

[image]

Sitecore 6.4.1 API
FileDataStore..::..SaveData Method (String, String)
FileDataStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void SaveData(
    string key,
    string data
)
Visual Basic
Protected Overrides Sub SaveData ( _
    key As String, _
    data As String _
)
Visual C++
protected:
virtual void SaveData(
    String^ key,
    String^ data
) override

Parameters

key
Type: System..::..String
The key.
data
Type: System..::..String
The data.

See Also

FileDataStore Class
SaveData Overload
Sitecore.Configuration Namespace


SetValue Method

[image] [image]

Sitecore 6.4.1 API
FileDataStore..::..SetValue Method
FileDataStore Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue(String, String) | Sets the value. (Inherited from ClientDataStore.)
Public method | SetValue(String, Object, String) | Sets the value. (Inherited from ClientDataStore.)

See Also

FileDataStore Class
FileDataStore Members
Sitecore.Configuration Namespace


IConstructable Interface

[image]

Sitecore 6.4.1 API
IConstructable Interface
Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IConstructable
Visual Basic
Public Interface IConstructable
Visual C++
public interface class IConstructable

See Also

IConstructable Members
Sitecore.Configuration Namespace


IConstructable Members

[image] [image]

Sitecore 6.4.1 API
IConstructable Members
IConstructable Interface Methods See Also Send Feedback

The IConstructable type exposes the following members.

Methods

 | Name | Description
Public method | Constructed | Called after object construction by the Factory has been finished.

See Also

IConstructable Interface
Sitecore.Configuration Namespace


IConstructable Methods

[image] [image]

Sitecore 6.4.1 API
IConstructable Methods
IConstructable Interface See Also Send Feedback

The IConstructable type exposes the following members.

Methods

 | Name | Description
Public method | Constructed | Called after object construction by the Factory has been finished.

See Also

IConstructable Interface
Sitecore.Configuration Namespace


Constructed Method

[image]

Sitecore 6.4.1 API
IConstructable..::..Constructed Method
IConstructable Interface See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void Constructed(
    XmlNode configuration
)
Visual Basic
Sub Constructed ( _
    configuration As XmlNode _
)
Visual C++
void Constructed(
    XmlNode^ configuration
)

Parameters

configuration
Type: System.Xml..::..XmlNode
The configuration.

See Also

IConstructable Interface
Sitecore.Configuration Namespace


IDTableWebDAVOptionStore Class

[image]

Sitecore 6.4.1 API
IDTableWebDAVOptionStore Class
Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class IDTableWebDAVOptionStore : WebDAVOptionStore
Visual Basic
Public Class IDTableWebDAVOptionStore _
    Inherits WebDAVOptionStore
Visual C++
public ref class IDTableWebDAVOptionStore : public WebDAVOptionStore

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..WebDAVOptionStore
Sitecore.Configuration..::..IDTableWebDAVOptionStore

See Also

IDTableWebDAVOptionStore Members
Sitecore.Configuration Namespace


IDTableWebDAVOptionStore Members

[image] [image]

Sitecore 6.4.1 API
IDTableWebDAVOptionStore Members
IDTableWebDAVOptionStore Class Constructors Methods Properties See Also Send Feedback

The IDTableWebDAVOptionStore type exposes the following members.

Constructors

 | Name | Description
Public method | IDTableWebDAVOptionStore | Initializes a new instance of the IDTableWebDAVOptionStore class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCacheKey | Gets the cache key.
Public method | GetExpiredOptions | Gets the expired options. (Overrides WebDAVOptionStore..::..GetExpiredOptions(TimeSpan).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetIDTableCacheKeys | Gets the ID table cache keys.
Public method | GetOption | Gets the option by Option ID. (Overrides WebDAVOptionStore..::..GetOption(ID).)
Public method | GetOptionIDs | Gets the list of option IDs. (Overrides WebDAVOptionStore..::..GetOptionIDs()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InitializeOptions | Initializes the options.
Protected method | IsObsolete | Determines whether the specified option ID is obsolete.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveOption | Removes the option. (Overrides WebDAVOptionStore..::..RemoveOption(ID).)
Public method | SaveOption | Saves the option. (Overrides WebDAVOptionStore..::..SaveOption(WebDAVOptions).)
Protected method | SerializeData | Serializes the options data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DefaultOption | Gets the default options. (Inherited from WebDAVOptionStore.)
 | Prefix | Gets the record prefix.

See Also

IDTableWebDAVOptionStore Class
Sitecore.Configuration Namespace


IDTableWebDAVOptionStore Constructor

[image]

Sitecore 6.4.1 API
IDTableWebDAVOptionStore Constructor
IDTableWebDAVOptionStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IDTableWebDAVOptionStore()
Visual Basic
Public Sub New
Visual C++
public:
IDTableWebDAVOptionStore()

See Also

IDTableWebDAVOptionStore Class
Sitecore.Configuration Namespace


IDTableWebDAVOptionStore Methods

[image] [image]

Sitecore 6.4.1 API
IDTableWebDAVOptionStore Methods
IDTableWebDAVOptionStore Class See Also Send Feedback

The IDTableWebDAVOptionStore type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCacheKey | Gets the cache key.
Public method | GetExpiredOptions | Gets the expired options. (Overrides WebDAVOptionStore..::..GetExpiredOptions(TimeSpan).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetIDTableCacheKeys | Gets the ID table cache keys.
Public method | GetOption | Gets the option by Option ID. (Overrides WebDAVOptionStore..::..GetOption(ID).)
Public method | GetOptionIDs | Gets the list of option IDs. (Overrides WebDAVOptionStore..::..GetOptionIDs()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InitializeOptions | Initializes the options.
Protected method | IsObsolete | Determines whether the specified option ID is obsolete.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveOption | Removes the option. (Overrides WebDAVOptionStore..::..RemoveOption(ID).)
Public method | SaveOption | Saves the option. (Overrides WebDAVOptionStore..::..SaveOption(WebDAVOptions).)
Protected method | SerializeData | Serializes the options data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IDTableWebDAVOptionStore Class
Sitecore.Configuration Namespace


GetCacheKey Method

[image]

Sitecore 6.4.1 API
IDTableWebDAVOptionStore..::..GetCacheKey Method
IDTableWebDAVOptionStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected string GetCacheKey(
    IDTableEntry entry
)
Visual Basic
Protected Function GetCacheKey ( _
    entry As IDTableEntry _
) As String
Visual C++
protected:
String^ GetCacheKey(
    IDTableEntry^ entry
)

Parameters

entry
Type: Sitecore.Data.IDTables..::..IDTableEntry
The entry.

Return Value

The entry cache key.

See Also

IDTableWebDAVOptionStore Class
Sitecore.Configuration Namespace


GetExpiredOptions Method

[image]

Sitecore 6.4.1 API
IDTableWebDAVOptionStore..::..GetExpiredOptions Method
IDTableWebDAVOptionStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Dictionary<ID, WebDAVOptions> GetExpiredOptions(
    TimeSpan expirationSpan
)
Visual Basic
Public Overrides Function GetExpiredOptions ( _
    expirationSpan As TimeSpan _
) As Dictionary(Of ID, WebDAVOptions)
Visual C++
public:
virtual Dictionary<ID^, WebDAVOptions^>^ GetExpiredOptions(
    TimeSpan expirationSpan
) override

Parameters

expirationSpan
Type: System..::..TimeSpan
The expiration period.

Return Value

The expired options.

See Also

IDTableWebDAVOptionStore Class
Sitecore.Configuration Namespace


GetIDTableCacheKeys Method

[image]

Sitecore 6.4.1 API
IDTableWebDAVOptionStore..::..GetIDTableCacheKeys Method
IDTableWebDAVOptionStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual Dictionary<string, DateTime> GetIDTableCacheKeys()
Visual Basic
Protected Overridable Function GetIDTableCacheKeys As Dictionary(Of String, DateTime)
Visual C++
protected:
virtual Dictionary<String^, DateTime>^ GetIDTableCacheKeys()

Return Value

The list of keys of IDTable cache.

See Also

IDTableWebDAVOptionStore Class
Sitecore.Configuration Namespace


GetOption Method

[image]

Sitecore 6.4.1 API
IDTableWebDAVOptionStore..::..GetOption Method
IDTableWebDAVOptionStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override WebDAVOptions GetOption(
    ID optionID
)
Visual Basic
Public Overrides Function GetOption ( _
    optionID As ID _
) As WebDAVOptions
Visual C++
public:
virtual WebDAVOptions^ GetOption(
    ID^ optionID
) override

Parameters

optionID
Type: Sitecore.Data..::..ID
The option ID.

Return Value

The Web DAV Option.

See Also

IDTableWebDAVOptionStore Class
Sitecore.Configuration Namespace


GetOptionIDs Method

[image]

Sitecore 6.4.1 API
IDTableWebDAVOptionStore..::..GetOptionIDs Method
IDTableWebDAVOptionStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override List<ID> GetOptionIDs()
Visual Basic
Public Overrides Function GetOptionIDs As List(Of ID)
Visual C++
public:
virtual List<ID^>^ GetOptionIDs() override

Return Value

The list of IDs.

See Also

IDTableWebDAVOptionStore Class
Sitecore.Configuration Namespace


InitializeOptions Method

[image]

Sitecore 6.4.1 API
IDTableWebDAVOptionStore..::..InitializeOptions Method
IDTableWebDAVOptionStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void InitializeOptions(
    WebDAVOptions options,
    string data
)
Visual Basic
Protected Overridable Sub InitializeOptions ( _
    options As WebDAVOptions, _
    data As String _
)
Visual C++
protected:
virtual void InitializeOptions(
    WebDAVOptions^ options,
    String^ data
)

Parameters

options
Type: Sitecore.Configuration..::..WebDAVOptions
The options.
data
Type: System..::..String
The options data.

See Also

IDTableWebDAVOptionStore Class
Sitecore.Configuration Namespace


IsObsolete Method

[image]

Sitecore 6.4.1 API
IDTableWebDAVOptionStore..::..IsObsolete Method
IDTableWebDAVOptionStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected bool IsObsolete(
    ID optionID,
    WebDAVOptions options,
    Dictionary<string, DateTime> keys,
    TimeSpan expirationSpan
)
Visual Basic
Protected Function IsObsolete ( _
    optionID As ID, _
    options As WebDAVOptions, _
    keys As Dictionary(Of String, DateTime), _
    expirationSpan As TimeSpan _
) As Boolean
Visual C++
protected:
bool IsObsolete(
    ID^ optionID,
    WebDAVOptions^ options,
    Dictionary<String^, DateTime>^ keys,
    TimeSpan expirationSpan
)

Parameters

optionID
Type: Sitecore.Data..::..ID
The option ID.
options
Type: Sitecore.Configuration..::..WebDAVOptions
The options.
keys
Type: System.Collections.Generic..::..Dictionary <(Of <(<' String, DateTime >)>)>
The IDTable keys.
expirationSpan
Type: System..::..TimeSpan
The expiration span.

Return Value

true if the specified option ID is obsolete; otherwise, false.

See Also

IDTableWebDAVOptionStore Class
Sitecore.Configuration Namespace


RemoveOption Method

[image]

Sitecore 6.4.1 API
IDTableWebDAVOptionStore..::..RemoveOption Method
IDTableWebDAVOptionStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void RemoveOption(
    ID optionID
)
Visual Basic
Public Overrides Sub RemoveOption ( _
    optionID As ID _
)
Visual C++
public:
virtual void RemoveOption(
    ID^ optionID
) override

Parameters

optionID
Type: Sitecore.Data..::..ID
The option ID.

See Also

IDTableWebDAVOptionStore Class
Sitecore.Configuration Namespace


SaveOption Method

[image]

Sitecore 6.4.1 API
IDTableWebDAVOptionStore..::..SaveOption Method
IDTableWebDAVOptionStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override ID SaveOption(
    WebDAVOptions option
)
Visual Basic
Public Overrides Function SaveOption ( _
    option As WebDAVOptions _
) As ID
Visual C++
public:
virtual ID^ SaveOption(
    WebDAVOptions^ option
) override

Parameters

option
Type: Sitecore.Configuration..::..WebDAVOptions
The option.

Return Value

The Option ID. Note: ID can be diferent from Option ID.

See Also

IDTableWebDAVOptionStore Class
Sitecore.Configuration Namespace


SerializeData Method

[image]

Sitecore 6.4.1 API
IDTableWebDAVOptionStore..::..SerializeData Method
IDTableWebDAVOptionStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string SerializeData(
    WebDAVOptions options
)
Visual Basic
Protected Overridable Function SerializeData ( _
    options As WebDAVOptions _
) As String
Visual C++
protected:
virtual String^ SerializeData(
    WebDAVOptions^ options
)

Parameters

options
Type: Sitecore.Configuration..::..WebDAVOptions
The Web DAV options.

Return Value

Serialized Options data.

See Also

IDTableWebDAVOptionStore Class
Sitecore.Configuration Namespace


IDTableWebDAVOptionStore Properties

[image] [image]

Sitecore 6.4.1 API
IDTableWebDAVOptionStore Properties
IDTableWebDAVOptionStore Class See Also Send Feedback

The IDTableWebDAVOptionStore type exposes the following members.

Properties

 | Name | Description
Public property | DefaultOption | Gets the default options. (Inherited from WebDAVOptionStore.)
 | Prefix | Gets the record prefix.

See Also

IDTableWebDAVOptionStore Class
Sitecore.Configuration Namespace


Prefix Property

[image]

Sitecore 6.4.1 API
IDTableWebDAVOptionStore..::..Prefix Property
IDTableWebDAVOptionStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Prefix { get; }
Visual Basic
Public Shared ReadOnly Property Prefix As String
    Get
Visual C++
public:
static property String^ Prefix {
    String^ get ();
}

Field Value

The record prefix.

See Also

IDTableWebDAVOptionStore Class
Sitecore.Configuration Namespace


IFactoryHelper Interface

[image]

Sitecore 6.4.1 API
IFactoryHelper Interface
Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IFactoryHelper
Visual Basic
Public Interface IFactoryHelper
Visual C++
public interface class IFactoryHelper

See Also

IFactoryHelper Members
Sitecore.Configuration Namespace


IFactoryHelper Members

[image] [image]

Sitecore 6.4.1 API
IFactoryHelper Members
IFactoryHelper Interface Methods See Also Send Feedback

The IFactoryHelper type exposes the following members.

Methods

 | Name | Description
Public method | SetProperty | Sets a property on the object being created.

See Also

IFactoryHelper Interface
Sitecore.Configuration Namespace


IFactoryHelper Methods

[image] [image]

Sitecore 6.4.1 API
IFactoryHelper Methods
IFactoryHelper Interface See Also Send Feedback

The IFactoryHelper type exposes the following members.

Methods

 | Name | Description
Public method | SetProperty | Sets a property on the object being created.

See Also

IFactoryHelper Interface
Sitecore.Configuration Namespace


SetProperty Method

[image]

Sitecore 6.4.1 API
IFactoryHelper..::..SetProperty Method
IFactoryHelper Interface See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
bool SetProperty(
    XmlNode propertyNode,
    Object objectBeingCreated
)
Visual Basic
Function SetProperty ( _
    propertyNode As XmlNode, _
    objectBeingCreated As Object _
) As Boolean
Visual C++
bool SetProperty(
    XmlNode^ propertyNode,
    Object^ objectBeingCreated
)

Parameters

propertyNode
Type: System.Xml..::..XmlNode
The property node.
objectBeingCreated
Type: System..::..Object
The object being created.

Return Value

true if the helper set the property, false if the factory should set the property itself.

See Also

IFactoryHelper Interface
Sitecore.Configuration Namespace


ObjectList Class

[image]

Sitecore 6.4.1 API
ObjectList Class
Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ObjectList
Visual Basic
Public Class ObjectList
Visual C++
public ref class ObjectList

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..ObjectList

See Also

ObjectList Members
Sitecore.Configuration Namespace


ObjectList Members

[image] [image]

Sitecore 6.4.1 API
ObjectList Members
ObjectList Class Constructors Methods Properties See Also Send Feedback

The ObjectList type exposes the following members.

Constructors

 | Name | Description
Public method | ObjectList | Initializes a new instance of the ObjectList class.

Methods

 | Name | Description
Public method | Add | Adds the specified key.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AddMethod | Gets the add method.
Public property | List | Gets the list.

See Also

ObjectList Class
Sitecore.Configuration Namespace


ObjectList Constructor

[image]

Sitecore 6.4.1 API
ObjectList Constructor
ObjectList Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ObjectList(
    string addMethod
)
Visual Basic
Public Sub New ( _
    addMethod As String _
)
Visual C++
public:
ObjectList(
    String^ addMethod
)

Parameters

addMethod
Type: System..::..String
The add method.

See Also

ObjectList Class
Sitecore.Configuration Namespace


ObjectList Methods

[image] [image]

Sitecore 6.4.1 API
ObjectList Methods
ObjectList Class See Also Send Feedback

The ObjectList type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ObjectList Class
Sitecore.Configuration Namespace


Add Method

[image]

Sitecore 6.4.1 API
ObjectList..::..Add Method
ObjectList Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Add(
    string key,
    Object value
)
Visual Basic
Public Sub Add ( _
    key As String, _
    value As Object _
)
Visual C++
public:
void Add(
    String^ key,
    Object^ value
)

Parameters

key
Type: System..::..String
The key.
value
Type: System..::..Object
The value.

See Also

ObjectList Class
Sitecore.Configuration Namespace


ObjectList Properties

[image] [image]

Sitecore 6.4.1 API
ObjectList Properties
ObjectList Class See Also Send Feedback

The ObjectList type exposes the following members.

Properties

 | Name | Description
Public property | AddMethod | Gets the add method.
Public property | List | Gets the list.

See Also

ObjectList Class
Sitecore.Configuration Namespace


AddMethod Property

[image]

Sitecore 6.4.1 API
ObjectList..::..AddMethod Property
ObjectList Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string AddMethod { get; }
Visual Basic
Public ReadOnly Property AddMethod As String
    Get
Visual C++
public:
property String^ AddMethod {
    String^ get ();
}

Field Value

The add method.

See Also

ObjectList Class
Sitecore.Configuration Namespace


ProviderHelper(TProvider, TCollection) Class

[image]

Sitecore 6.4.1 API
ProviderHelper<(Of <(<'TProvider, TCollection>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ProviderHelper<TProvider, TCollection>
where TProvider : ProviderBase
where TCollection : new(), ProviderCollection
Visual Basic
Public Class ProviderHelper(Of TProvider As ProviderBase, TCollection As {New, ProviderCollection})
Visual C++
generic<typename TProvider, typename TCollection>
where TProvider : ProviderBase
where TCollection : gcnew(), ProviderCollection
public ref class ProviderHelper

Type Parameters

TProvider

[Missing <typeparam name="TProvider"/> documentation for "T:Sitecore.Configuration.ProviderHelper`2"]

TCollection

[Missing <typeparam name="TCollection"/> documentation for "T:Sitecore.Configuration.ProviderHelper`2"]

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..ProviderHelper<(Of <(<'TProvider, TCollection>)>)>

See Also

ProviderHelper<(Of <(<'TProvider, TCollection>)>)> Members
Sitecore.Configuration Namespace


ProviderHelper(TProvider, TCollection) Members

[image] [image]

Sitecore 6.4.1 API
ProviderHelper<(Of <(<'TProvider, TCollection>)>)> Members
ProviderHelper<(Of <(<'TProvider, TCollection>)>)> Class Constructors Methods Properties See Also Send Feedback

The ProviderHelper<(Of <(<'TProvider, TCollection>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | ProviderHelper<(Of <(<'TProvider, TCollection>)>)> | Initializes a new instance of the ProviderHelper<(Of <(<'TProvider, TCollection>)>)> class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRootAttribute | Gets the root attribute.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReadProviders | Reads the providers from configuration.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
 | DefaultProvider | Sets the default provider.
Public property | Provider | Gets the provider.
Public property | Providers | Gets all provider.

See Also

ProviderHelper<(Of <(<'TProvider, TCollection>)>)> Class
Sitecore.Configuration Namespace


ProviderHelper(TProvider, TCollection) Constructor

[image]

Sitecore 6.4.1 API
ProviderHelper<(Of <(<'TProvider, TCollection>)>)> Constructor
ProviderHelper<(Of <(<'TProvider, TCollection>)>)> Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ProviderHelper(
    string configPath
)
Visual Basic
Public Sub New ( _
    configPath As String _
)
Visual C++
public:
ProviderHelper(
    String^ configPath
)

Parameters

configPath
Type: System..::..String
The config path.

See Also

ProviderHelper<(Of <(<'TProvider, TCollection>)>)> Class
Sitecore.Configuration Namespace


ProviderHelper(TProvider, TCollection) Methods

[image] [image]

Sitecore 6.4.1 API
ProviderHelper<(Of <(<'TProvider, TCollection>)>)> Methods
ProviderHelper<(Of <(<'TProvider, TCollection>)>)> Class See Also Send Feedback

The ProviderHelper<(Of <(<'TProvider, TCollection>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRootAttribute | Gets the root attribute.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReadProviders | Reads the providers from configuration.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProviderHelper<(Of <(<'TProvider, TCollection>)>)> Class
Sitecore.Configuration Namespace


GetRootAttribute Method

[image]

Sitecore 6.4.1 API
ProviderHelper<(Of <(<'TProvider, TCollection>)>)>..::..GetRootAttribute Method
ProviderHelper<(Of <(<'TProvider, TCollection>)>)> Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetRootAttribute(
    string attributeName
)
Visual Basic
Public Function GetRootAttribute ( _
    attributeName As String _
) As String
Visual C++
public:
String^ GetRootAttribute(
    String^ attributeName
)

Parameters

attributeName
Type: System..::..String
Name of the attribute.

Return Value

[Missing <returns> documentation for "M:Sitecore.Configuration.ProviderHelper`2.GetRootAttribute(System.String)"]

See Also

ProviderHelper<(Of <(<'TProvider, TCollection>)>)> Class
Sitecore.Configuration Namespace


ReadProviders Method

[image]

Sitecore 6.4.1 API
ProviderHelper<(Of <(<'TProvider, TCollection>)>)>..::..ReadProviders Method
ProviderHelper<(Of <(<'TProvider, TCollection>)>)> Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void ReadProviders()
Visual Basic
Protected Sub ReadProviders
Visual C++
protected:
void ReadProviders()

See Also

ProviderHelper<(Of <(<'TProvider, TCollection>)>)> Class
Sitecore.Configuration Namespace


ProviderHelper(TProvider, TCollection) Properties

[image] [image]

Sitecore 6.4.1 API
ProviderHelper<(Of <(<'TProvider, TCollection>)>)> Properties
ProviderHelper<(Of <(<'TProvider, TCollection>)>)> Class See Also Send Feedback

The ProviderHelper<(Of <(<'TProvider, TCollection>)>)> type exposes the following members.

Properties

 | Name | Description
 | DefaultProvider | Sets the default provider.
Public property | Provider | Gets the provider.
Public property | Providers | Gets all provider.

See Also

ProviderHelper<(Of <(<'TProvider, TCollection>)>)> Class
Sitecore.Configuration Namespace


DefaultProvider Property

[image]

Sitecore 6.4.1 API
ProviderHelper<(Of <(<'TProvider, TCollection>)>)>..::..DefaultProvider Property
ProviderHelper<(Of <(<'TProvider, TCollection>)>)> Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TProvider DefaultProvider { set; }
Visual Basic
Public Shared WriteOnly Property DefaultProvider As TProvider
    Set
Visual C++
public:
static property TProvider DefaultProvider {
    void set (TProvider value);
}

Field Value

The default provider.

See Also

ProviderHelper<(Of <(<'TProvider, TCollection>)>)> Class
Sitecore.Configuration Namespace


Provider Property

[image]

Sitecore 6.4.1 API
ProviderHelper<(Of <(<'TProvider, TCollection>)>)>..::..Provider Property
ProviderHelper<(Of <(<'TProvider, TCollection>)>)> Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TProvider Provider { get; }
Visual Basic
Public ReadOnly Property Provider As TProvider
    Get
Visual C++
public:
property TProvider Provider {
    TProvider get ();
}

Field Value

The provider.

See Also

ProviderHelper<(Of <(<'TProvider, TCollection>)>)> Class
Sitecore.Configuration Namespace


Providers Property

[image]

Sitecore 6.4.1 API
ProviderHelper<(Of <(<'TProvider, TCollection>)>)>..::..Providers Property
ProviderHelper<(Of <(<'TProvider, TCollection>)>)> Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TCollection Providers { get; }
Visual Basic
Public ReadOnly Property Providers As TCollection
    Get
Visual C++
public:
property TCollection Providers {
    TCollection get ();
}

Field Value

The providers.

See Also

ProviderHelper<(Of <(<'TProvider, TCollection>)>)> Class
Sitecore.Configuration Namespace


Settings Class

[image]

Sitecore 6.4.1 API
Settings Class
Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public sealed class Settings
Visual Basic
Public NotInheritable Class Settings
Visual C++
public ref class Settings sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings

See Also

Settings Members
Sitecore.Configuration Namespace


Settings Members

[image] [image]

Sitecore 6.4.1 API
Settings Members
Settings Class Constructors Methods Properties See Also Send Feedback

The Settings type exposes the following members.

Constructors

 | Name | Description
Public method | Settings | Initializes a new instance of the Settings class

Methods

 | Name | Description
 | ConnectionStringExists | Determines if the specified connection string exists.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAppSetting(String) | Get named application setting.
 | GetAppSetting(String, String) | Get named application setting.
 | GetBoolSetting | Get boolean setting.
 | GetConnectionString | Gets a named connection string.
 | GetDoubleSetting | Get double setting.
 | GetFileSetting(String) | Get named setting containg a file path.
 | GetFileSetting(String, String) | Get named setting containg a file path.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIntSetting | Get int setting.
 | GetLongSetting | Get long setting.
 | GetNumberOfSettings | Get number of settings.
 | GetProviderObject(String, Type) | Gets the provider object.
 | GetProviderObject(String, String, Type) | Gets the provider object.
 | GetProviderObjects | Gets the provider objects.
 | GetSetting(String) | Get named setting.
 | GetSetting(String, String) | Get named setting with default.
 | GetSystemSection<(Of <<'(T>)>>) | Gets a system section from web.config (i.e. a section located beneath system.web).
 | GetTimeSpanSetting(String, String) | Get setting containg a time span (hh:mm:ss)
 | GetTimeSpanSetting(String, TimeSpan) | Get setting containg a time span (hh:mm:ss)
 | GetTimeSpanSetting(String, TimeSpan, CultureInfo) | Gets the time span setting.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Reset | Resets this instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | WriteSetting(String, String, Boolean) | Write a setting to web.config.
 | WriteSetting(String, String, String, Boolean) | Write a setting to web.config.

Properties

Name | Description
AccountNameValidation | Gets the default account name validation.
AliasesActive | Indicates if aliases are active.
AllowLogoutOfAllUsers | Indicates if the logout screen presents all users or just users with the same name.
AppendQSToUrlRendering | Indicates if main query strings are appended to URL renderings?
AutoMaintainProxyDefinitions | Gets a value indicating whether proxy definitions (items with template Proxy) are maintained by the system automatically. This affects copy, duplicate, archive, recycle and delete operations.
AutomaticDataBind | Indicates if the DataBind function is called by the web engine.
AutomaticLockOnSave | Gets a value indicating whether the item is automatically locked on save.
AutomaticUnlockOnSaved | Gets a value indicating whether the item is automatically unlocked on saved.
CheckSecurityOnLanguages | Indicates if security on languages should be checked.
ClientLanguage | Gets the default client language.
ConfigurationIsSet | Gets a value indicating whether configuration is set.
CustomErrorsMode | Gets the custom errors mode.
DataFolder | Gets the path to the data folder.
DataProviderTimeout | Gets the default timeout for data provider commands.
DebugBorderColor | Gets the color of debug borders.
DebugBorderTag | Gets the html tag to use for debug borders (usually span or div).
DebugEnabled | Gets a value indicating whether ASP.NET debuggin is enabled.
DebugFolder | Gets the path to the debug folder.
DefaultBaseTemplate | The guid of the default base templates.
DefaultDesktop | Gets the default desktop.
DefaultIcon | Gets the path to the default icon for items in the Sitecore client.
DefaultItem | Gets the default item for the Sitecore client.
DefaultLanguage | Gets the default language for the web site.
DefaultLayoutFile | Gets the path to the layout file to use for items that do not specify a layout file themselves.
DefaultPageName | Gets the name of the default ASPX page.
DefaultPublishingTargets | Gets a pipe separated list of publishing group names.
DefaultRegionalIsoCode | Gets the default regional ISO code.
DefaultShellControl | Gets the default shell control.
DefaultSortOrder | Gets the default value of the sort order attribute.
DefaultSQLTimeout | Gets the default timeout for SQL commands.
DefaultTheme | Gets the default Sitecore client theme.
DefaultThumbnail | Gets the path to the default thumbnail for items in the Sitecore client.
DisableBrowserCaching | Indicates if browser caching of pages should be disabled.
EnableEventQueues | Gets a value that indicates whether Sitecore sends local events to the event queue, and whether the local instance handles events in the queue from remote instances.
EnableXslDocumentFunction | Gets a value indicating whether XSLT document() support should be enabled.
EnableXslScripts | Gets a value indicating whether XSLT script support should be enabled.
ErrorPage | Gets the page to redirect to, if a generic error occurs.
FastPublishing | Use fast publishing?
FastQueryDescendantsDisabled | Setting this to 'true' will improve performance of item creation/moving/deletion, but will make fast query return incorrect results when selecting items using the Ancestors/Descendants axes.
GenerateThumbnails | Indicates if thumbnails of uploaded image files should be generated.
GridPageSize | Gets the number of rows in a UI grid.
HashEncryptionProvider | Gets the hash encryption provider.
HealthMonitorInterval | Gets the health monitor interval.
HeartbeatInterval | Gets the interval between heartbeats.
IgnoreUrlPrefixes | Gets a pipe separated list of url prefixes to ignore when mapping friendly urls.
ImageTypes | Gets a pipe separated list of image file types (extensions).
IncludeProxiesInLinkDatabase | Gets a value indicating whether to include proxy definitions in the link database.
IndexFolder | Gets the index folder.
InstanceName | Gets the name of the Sitecore server instance.
InvalidItemNameChars | Gets the invalid item name chars.
ItemNameValidation | Gets the item name validation.
ItemNotFoundUrl | Gets the url to redirect to, if an item being linked to is not found.
KeepLockAfterSaveForAdminUsers | Gets a value indicating whether the item is keeped locked after save in Page Editor for Administator users.
LayoutFolder | Gets the path to the layout file root folder.
LayoutNotFoundUrl | Gets the url to redirect to, if an items layout is not found.
LayoutPageEvent | Gets the name of page event where the layout pipeline will be run.
LicenseFile | Gets the path to the license file.
LinkItemNotFoundUrl | Gets the url to redirect to, if an item is not found.
LogFolder | Gets the path to the log folder.
LoginLayout | Gets the name of the layout to use for logging in (to extranet)
LoginPage | Gets the path to the page to use for logging in (to extranet)
MailServer | Gets the mail server.
MailServerPassword | Gets the mail server password.
MailServerPort | Gets the mail server port.
MailServerUserName | Gets the name of the mail server user.
MasterVariablesReplacer | Gets the type of a class used for replacing variables when creating a master.
MaxCallLevel | Specifies the maximum allowed depth of a recursive method call.
MaxItemNameLength | Specifies the maximum length of an item name.
MaxSqlBatchStatements | Gets the maximum number of statements to put in a SqlBatch.
MaxTreeDepth | Specifies the maximum allowed depth of an item tree.
MaxWorkerThreads | Gets the maximum number of worker threads to use.
MediaFolder | Gets the path to the media library root folder.
NoAccessUrl | Gets the url to redirect to, if access to an item is denied.
NoLicenseUrl | Gets the url to redirect to, if a license is missing.
PackagePath | Specifies the path where package files are located.
PortalPrincipalResolver | Gets the portal principal resolver.
PortalStorage | Gets the portal storage.
ProcessHistoryCount | Gets the number of process histories to show at startup.
ProfileItemDatabase | Gets the database where user profile items are stored.
ProtectedSite | Indicates if the entire site is protected (require login).
RecycleBinActive | Indicates if recycle bin is active.
RedirectUrlPrefixes | Gets a list of paths for which the RewritePath method should not be used for security reasons. For more details see the RedirectURLPrefixes setting in the web.config file.
RequireLockBeforeEditing | Gets a value indicating whether a lock is required before editing.
SerializationFolder | Gets the serialization folder.
SerializationPassword | Gets the password used for deserializing users.
Sites | Gets the list of sites.
SystemBlockedUrl | Gets the url to redirect to, if the system has been blocked.
TempFolderPath | Gets the temp folder path.
ThumbnailHeight | Gets the max height of auto-generated image thumbnails.
ThumbnailsBackgroundColor | Gets the color of the thumbnails background.
ThumbnailWidth | Gets the maximum width of auto-generated image thumbnails.
UnlockAfterCopy | Gets a value indicating whether to unlock items after copying.
VersionFilePath | Gets the path to the version file.
ViewStateStore | Indicates if ViewState is cached in the GlobalCache in SheerUI.
Wallpaper | Gets the wallpaper.
WallpapersPath | Gets the wallpapers path.
WebStylesheet | Gets the path to the default web site stylesheet.
WelcomeTitle | Gets the welcome title to show on the login page.
XHtmlSchemaFile | Gets the XHTML schema file.
XmlControlAspxFile | Gets the extension used for xml control files.
XmlControlExtension | Gets the extension used for xml control files.

See Also

Settings Class
Sitecore.Configuration Namespace


Settings Methods

[image] [image]

Sitecore 6.4.1 API
Settings Methods
Settings Class See Also Send Feedback

The Settings type exposes the following members.

Methods

 | Name | Description
 | ConnectionStringExists | Determines if the specified connection string exists.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAppSetting(String) | Get named application setting.
 | GetAppSetting(String, String) | Get named application setting.
 | GetBoolSetting | Get boolean setting.
 | GetConnectionString | Gets a named connection string.
 | GetDoubleSetting | Get double setting.
 | GetFileSetting(String) | Get named setting containg a file path.
 | GetFileSetting(String, String) | Get named setting containg a file path.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIntSetting | Get int setting.
 | GetLongSetting | Get long setting.
 | GetNumberOfSettings | Get number of settings.
 | GetProviderObject(String, Type) | Gets the provider object.
 | GetProviderObject(String, String, Type) | Gets the provider object.
 | GetProviderObjects | Gets the provider objects.
 | GetSetting(String) | Get named setting.
 | GetSetting(String, String) | Get named setting with default.
 | GetSystemSection<(Of <<'(T>)>>) | Gets a system section from web.config (i.e. a section located beneath system.web).
 | GetTimeSpanSetting(String, String) | Get setting containg a time span (hh:mm:ss)
 | GetTimeSpanSetting(String, TimeSpan) | Get setting containg a time span (hh:mm:ss)
 | GetTimeSpanSetting(String, TimeSpan, CultureInfo) | Gets the time span setting.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Reset | Resets this instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | WriteSetting(String, String, Boolean) | Write a setting to web.config.
 | WriteSetting(String, String, String, Boolean) | Write a setting to web.config.

See Also

Settings Class
Sitecore.Configuration Namespace


ConnectionStringExists Method

[image]

Sitecore 6.4.1 API
Settings..::..ConnectionStringExists Method
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool ConnectionStringExists(
    string connectionStringName
)
Visual Basic
Public Shared Function ConnectionStringExists ( _
    connectionStringName As String _
) As Boolean
Visual C++
public:
static bool ConnectionStringExists(
    String^ connectionStringName
)

Parameters

connectionStringName
Type: System..::..String
Name of the connection string.

Return Value

The connection string exists.

See Also

Settings Class
Sitecore.Configuration Namespace


GetAppSetting Method

[image] [image]

Sitecore 6.4.1 API
Settings..::..GetAppSetting Method
Settings Class See Also Send Feedback

Overload List

Name | Description
GetAppSetting(String) | Get named application setting.
GetAppSetting(String, String) | Get named application setting.

See Also

Settings Class
Settings Members
Sitecore.Configuration Namespace


GetAppSetting Method (String)

[image]

Sitecore 6.4.1 API
Settings..::..GetAppSetting Method (String)
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetAppSetting(
    string name
)
Visual Basic
Public Shared Function GetAppSetting ( _
    name As String _
) As String
Visual C++
public:
static String^ GetAppSetting(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

Return Value

The app setting.

See Also

Settings Class
GetAppSetting Overload
Sitecore.Configuration Namespace


GetAppSetting Method (String, String)

[image]

Sitecore 6.4.1 API
Settings..::..GetAppSetting Method (String, String)
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetAppSetting(
    string name,
    string defaultValue
)
Visual Basic
Public Shared Function GetAppSetting ( _
    name As String, _
    defaultValue As String _
) As String
Visual C++
public:
static String^ GetAppSetting(
    String^ name,
    String^ defaultValue
)

Parameters

name
Type: System..::..String
The name.
defaultValue
Type: System..::..String
The _default.

Return Value

The app setting.

See Also

Settings Class
GetAppSetting Overload
Sitecore.Configuration Namespace


GetConnectionString Method

[image]

Sitecore 6.4.1 API
Settings..::..GetConnectionString Method
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetConnectionString(
    string connectionStringName
)
Visual Basic
Public Shared Function GetConnectionString ( _
    connectionStringName As String _
) As String
Visual C++
public:
static String^ GetConnectionString(
    String^ connectionStringName
)

Parameters

connectionStringName
Type: System..::..String
Name of the connection string.

Return Value

The connection string.

See Also

Settings Class
Sitecore.Configuration Namespace


GetDoubleSetting Method

[image]

Sitecore 6.4.1 API
Settings..::..GetDoubleSetting Method
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static double GetDoubleSetting(
    string name,
    double defaultValue
)
Visual Basic
Public Shared Function GetDoubleSetting ( _
    name As String, _
    defaultValue As Double _
) As Double
Visual C++
public:
static double GetDoubleSetting(
    String^ name,
    double defaultValue
)

Parameters

name
Type: System..::..String
The name.
defaultValue
Type: System..::..Double
The default value.

Return Value

The long setting.

See Also

Settings Class
Sitecore.Configuration Namespace


GetFileSetting Method

[image] [image]

Sitecore 6.4.1 API
Settings..::..GetFileSetting Method
Settings Class See Also Send Feedback

Overload List

Name | Description
GetFileSetting(String) | Get named setting containg a file path.
GetFileSetting(String, String) | Get named setting containg a file path.

See Also

Settings Class
Settings Members
Sitecore.Configuration Namespace


GetFileSetting Method (String)

[image]

Sitecore 6.4.1 API
Settings..::..GetFileSetting Method (String)
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetFileSetting(
    string sName
)
Visual Basic
Public Shared Function GetFileSetting ( _
    sName As String _
) As String
Visual C++
public:
static String^ GetFileSetting(
    String^ sName
)

Parameters

sName
Type: System..::..String
Name of the s.

Return Value

The file setting.

See Also

Settings Class
GetFileSetting Overload
Sitecore.Configuration Namespace


GetFileSetting Method (String, String)

[image]

Sitecore 6.4.1 API
Settings..::..GetFileSetting Method (String, String)
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetFileSetting(
    string name,
    string defaultValue
)
Visual Basic
Public Shared Function GetFileSetting ( _
    name As String, _
    defaultValue As String _
) As String
Visual C++
public:
static String^ GetFileSetting(
    String^ name,
    String^ defaultValue
)

Parameters

name
Type: System..::..String
The name.
defaultValue
Type: System..::..String
The _default.

Return Value

The file setting.

See Also

Settings Class
GetFileSetting Overload
Sitecore.Configuration Namespace


GetIntSetting Method

[image]

Sitecore 6.4.1 API
Settings..::..GetIntSetting Method
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int GetIntSetting(
    string name,
    int defaultValue
)
Visual Basic
Public Shared Function GetIntSetting ( _
    name As String, _
    defaultValue As Integer _
) As Integer
Visual C++
public:
static int GetIntSetting(
    String^ name,
    int defaultValue
)

Parameters

name
Type: System..::..String
The name.
defaultValue
Type: System..::..Int32
The default value.

Return Value

The int setting.

See Also

Settings Class
Sitecore.Configuration Namespace


GetLongSetting Method

[image]

Sitecore 6.4.1 API
Settings..::..GetLongSetting Method
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long GetLongSetting(
    string name,
    long defaultValue
)
Visual Basic
Public Shared Function GetLongSetting ( _
    name As String, _
    defaultValue As Long _
) As Long
Visual C++
public:
static long long GetLongSetting(
    String^ name,
    long long defaultValue
)

Parameters

name
Type: System..::..String
The name.
defaultValue
Type: System..::..Int64
The default value.

Return Value

The long setting.

See Also

Settings Class
Sitecore.Configuration Namespace


GetNumberOfSettings Method

[image]

Sitecore 6.4.1 API
Settings..::..GetNumberOfSettings Method
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int GetNumberOfSettings()
Visual Basic
Public Shared Function GetNumberOfSettings As Integer
Visual C++
public:
static int GetNumberOfSettings()

Return Value

The number of settings.

See Also

Settings Class
Sitecore.Configuration Namespace


GetProviderObject Method

[image] [image]

Sitecore 6.4.1 API
Settings..::..GetProviderObject Method
Settings Class See Also Send Feedback

Overload List

Name | Description
GetProviderObject(String, Type) | Gets the provider object.
GetProviderObject(String, String, Type) | Gets the provider object.

See Also

Settings Class
Settings Members
Sitecore.Configuration Namespace


GetProviderObject Method (String, Type)

[image]

Sitecore 6.4.1 API
Settings..::..GetProviderObject Method (String, Type)
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object GetProviderObject(
    string implementationPath,
    Type expectedType
)
Visual Basic
Public Shared Function GetProviderObject ( _
    implementationPath As String, _
    expectedType As Type _
) As Object
Visual C++
public:
static Object^ GetProviderObject(
    String^ implementationPath,
    Type^ expectedType
)

Parameters

implementationPath
Type: System..::..String
The implementation path.
expectedType
Type: System..::..Type
The expected type.

Return Value

The provider object.

See Also

Settings Class
GetProviderObject Overload
Sitecore.Configuration Namespace


GetProviderObject Method (String, String, Type)

[image]

Sitecore 6.4.1 API
Settings..::..GetProviderObject Method (String, String, Type)
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object GetProviderObject(
    string referencePath,
    string implementationPath,
    Type expectedType
)
Visual Basic
Public Shared Function GetProviderObject ( _
    referencePath As String, _
    implementationPath As String, _
    expectedType As Type _
) As Object
Visual C++
public:
static Object^ GetProviderObject(
    String^ referencePath,
    String^ implementationPath,
    Type^ expectedType
)

Parameters

referencePath
Type: System..::..String
The reference path.
implementationPath
Type: System..::..String
The implementation path.
expectedType
Type: System..::..Type
The expected type.

Return Value

The provider object.

See Also

Settings Class
GetProviderObject Overload
Sitecore.Configuration Namespace


GetProviderObjects Method

[image]

Sitecore 6.4.1 API
Settings..::..GetProviderObjects Method
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object[] GetProviderObjects(
    string referencePath,
    string implementationPath,
    Type expectedType
)
Visual Basic
Public Shared Function GetProviderObjects ( _
    referencePath As String, _
    implementationPath As String, _
    expectedType As Type _
) As Object()
Visual C++
public:
static array<Object^>^ GetProviderObjects(
    String^ referencePath,
    String^ implementationPath,
    Type^ expectedType
)

Parameters

referencePath
Type: System..::..String
The reference path.
implementationPath
Type: System..::..String
The implementation path.
expectedType
Type: System..::..Type
The expected type.

Return Value

The provider objects.

See Also

Settings Class
Sitecore.Configuration Namespace


GetSetting Method

[image] [image]

Sitecore 6.4.1 API
Settings..::..GetSetting Method
Settings Class See Also Send Feedback

Overload List

Name | Description
GetSetting(String) | Get named setting.
GetSetting(String, String) | Get named setting with default.

See Also

Settings Class
Settings Members
Sitecore.Configuration Namespace


GetSetting Method (String)

[image]

Sitecore 6.4.1 API
Settings..::..GetSetting Method (String)
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetSetting(
    string name
)
Visual Basic
Public Shared Function GetSetting ( _
    name As String _
) As String
Visual C++
public:
static String^ GetSetting(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

Return Value

The setting.

See Also

Settings Class
GetSetting Overload
Sitecore.Configuration Namespace


GetSetting Method (String, String)

[image]

Sitecore 6.4.1 API
Settings..::..GetSetting Method (String, String)
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetSetting(
    string name,
    string defaultValue
)
Visual Basic
Public Shared Function GetSetting ( _
    name As String, _
    defaultValue As String _
) As String
Visual C++
public:
static String^ GetSetting(
    String^ name,
    String^ defaultValue
)

Parameters

name
Type: System..::..String
The name.
defaultValue
Type: System..::..String
The _default.

Return Value

The setting.

See Also

Settings Class
GetSetting Overload
Sitecore.Configuration Namespace


GetSystemSection(T) Method

[image]

Sitecore 6.4.1 API
Settings..::..GetSystemSection<(Of <(<'T>)>)> Method
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static T GetSystemSection<T>(
    string sectionName
)
where T : class
Visual Basic
Public Shared Function GetSystemSection(Of T As Class) ( _
    sectionName As String _
) As T
Visual C++
public:
generic<typename T>
where T : ref class
static T GetSystemSection(
    String^ sectionName
)

Parameters

sectionName
Type: System..::..String
Name of the section.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Sitecore.Configuration.Settings.GetSystemSection``1(System.String)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Configuration.Settings.GetSystemSection``1(System.String)"]

See Also

Settings Class
Sitecore.Configuration Namespace


GetTimeSpanSetting Method

[image] [image]

Sitecore 6.4.1 API
Settings..::..GetTimeSpanSetting Method
Settings Class See Also Send Feedback

Overload List

Name | Description
GetTimeSpanSetting(String, String) | Get setting containg a time span (hh:mm:ss)
GetTimeSpanSetting(String, TimeSpan) | Get setting containg a time span (hh:mm:ss)
GetTimeSpanSetting(String, TimeSpan, CultureInfo) | Gets the time span setting.

See Also

Settings Class
Settings Members
Sitecore.Configuration Namespace


GetTimeSpanSetting Method (String, String)

[image]

Sitecore 6.4.1 API
Settings..::..GetTimeSpanSetting Method (String, String)
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TimeSpan GetTimeSpanSetting(
    string name,
    string defaultValue
)
Visual Basic
Public Shared Function GetTimeSpanSetting ( _
    name As String, _
    defaultValue As String _
) As TimeSpan
Visual C++
public:
static TimeSpan GetTimeSpanSetting(
    String^ name,
    String^ defaultValue
)

Parameters

name
Type: System..::..String
The name.
defaultValue
Type: System..::..String
The _default.

Return Value

The time span setting.

See Also

Settings Class
GetTimeSpanSetting Overload
Sitecore.Configuration Namespace


GetTimeSpanSetting Method (String, TimeSpan)

[image]

Sitecore 6.4.1 API
Settings..::..GetTimeSpanSetting Method (String, TimeSpan)
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TimeSpan GetTimeSpanSetting(
    string name,
    TimeSpan defaultValue
)
Visual Basic
Public Shared Function GetTimeSpanSetting ( _
    name As String, _
    defaultValue As TimeSpan _
) As TimeSpan
Visual C++
public:
static TimeSpan GetTimeSpanSetting(
    String^ name,
    TimeSpan defaultValue
)

Parameters

name
Type: System..::..String
The name.
defaultValue
Type: System..::..TimeSpan
The _default.

Return Value

The time span setting.

See Also

Settings Class
GetTimeSpanSetting Overload
Sitecore.Configuration Namespace


GetTimeSpanSetting Method (String, TimeSpan, CultureInfo)

[image]

Sitecore 6.4.1 API
Settings..::..GetTimeSpanSetting Method (String, TimeSpan, CultureInfo)
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TimeSpan GetTimeSpanSetting(
    string name,
    TimeSpan defaultValue,
    CultureInfo cultureInfo
)
Visual Basic
Public Shared Function GetTimeSpanSetting ( _
    name As String, _
    defaultValue As TimeSpan, _
    cultureInfo As CultureInfo _
) As TimeSpan
Visual C++
public:
static TimeSpan GetTimeSpanSetting(
    String^ name,
    TimeSpan defaultValue,
    CultureInfo^ cultureInfo
)

Parameters

name
Type: System..::..String
The name.
defaultValue
Type: System..::..TimeSpan
The default value.
cultureInfo
Type: System.Globalization..::..CultureInfo
The culture info.

Return Value

[Missing <returns> documentation for "M:Sitecore.Configuration.Settings.GetTimeSpanSetting(System.String,System.TimeSpan,System.Globalization.CultureInfo)"]

See Also

Settings Class
GetTimeSpanSetting Overload
Sitecore.Configuration Namespace


Reset Method

[image]

Sitecore 6.4.1 API
Settings..::..Reset Method
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Reset()
Visual Basic
Public Shared Sub Reset
Visual C++
public:
static void Reset()

Remarks

This will cause all configuration data to be reloaded.

See Also

Settings Class
Sitecore.Configuration Namespace


WriteSetting Method

[image] [image]

Sitecore 6.4.1 API
Settings..::..WriteSetting Method
Settings Class See Also Send Feedback

Overload List

Name | Description
WriteSetting(String, String, Boolean) | Write a setting to web.config.
WriteSetting(String, String, String, Boolean) | Write a setting to web.config.

See Also

Settings Class
Settings Members
Sitecore.Configuration Namespace


WriteSetting Method (String, String, Boolean)

[image]

Sitecore 6.4.1 API
Settings..::..WriteSetting Method (String, String, Boolean)
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool WriteSetting(
    string key,
    string value,
    bool overwrite
)
Visual Basic
Public Shared Function WriteSetting ( _
    key As String, _
    value As String, _
    overwrite As Boolean _
) As Boolean
Visual C++
public:
static bool WriteSetting(
    String^ key,
    String^ value,
    bool overwrite
)

Parameters

key
Type: System..::..String
The key.
value
Type: System..::..String
The value.
overwrite
Type: System..::..Boolean
if set to true this instance is overwrite.

Return Value

The setting.

See Also

Settings Class
WriteSetting Overload
Sitecore.Configuration Namespace


WriteSetting Method (String, String, String, Boolean)

[image]

Sitecore 6.4.1 API
Settings..::..WriteSetting Method (String, String, String, Boolean)
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool WriteSetting(
    string path,
    string match,
    string content,
    bool overwrite
)
Visual Basic
Public Shared Function WriteSetting ( _
    path As String, _
    match As String, _
    content As String, _
    overwrite As Boolean _
) As Boolean
Visual C++
public:
static bool WriteSetting(
    String^ path,
    String^ match,
    String^ content,
    bool overwrite
)

Parameters

path
Type: System..::..String
The path.
match
Type: System..::..String
The match.
content
Type: System..::..String
The content.
overwrite
Type: System..::..Boolean
if set to true this instance is overwrite.

Return Value

The setting.

See Also

Settings Class
WriteSetting Overload
Sitecore.Configuration Namespace


Settings Properties

[image] [image]

Sitecore 6.4.1 API
Settings Properties
Settings Class See Also Send Feedback

The Settings type exposes the following members.

Properties

Name | Description
AccountNameValidation | Gets the default account name validation.
AliasesActive | Indicates if aliases are active.
AllowLogoutOfAllUsers | Indicates if the logout screen presents all users or just users with the same name.
AppendQSToUrlRendering | Indicates if main query strings are appended to URL renderings?
AutoMaintainProxyDefinitions | Gets a value indicating whether proxy definitions (items with template Proxy) are maintained by the system automatically. This affects copy, duplicate, archive, recycle and delete operations.
AutomaticDataBind | Indicates if the DataBind function is called by the web engine.
AutomaticLockOnSave | Gets a value indicating whether the item is automatically locked on save.
AutomaticUnlockOnSaved | Gets a value indicating whether the item is automatically unlocked on saved.
CheckSecurityOnLanguages | Indicates if security on languages should be checked.
ClientLanguage | Gets the default client language.
ConfigurationIsSet | Gets a value indicating whether configuration is set.
CustomErrorsMode | Gets the custom errors mode.
DataFolder | Gets the path to the data folder.
DataProviderTimeout | Gets the default timeout for data provider commands.
DebugBorderColor | Gets the color of debug borders.
DebugBorderTag | Gets the html tag to use for debug borders (usually span or div).
DebugEnabled | Gets a value indicating whether ASP.NET debuggin is enabled.
DebugFolder | Gets the path to the debug folder.
DefaultBaseTemplate | The guid of the default base templates.
DefaultDesktop | Gets the default desktop.
DefaultIcon | Gets the path to the default icon for items in the Sitecore client.
DefaultItem | Gets the default item for the Sitecore client.
DefaultLanguage | Gets the default language for the web site.
DefaultLayoutFile | Gets the path to the layout file to use for items that do not specify a layout file themselves.
DefaultPageName | Gets the name of the default ASPX page.
DefaultPublishingTargets | Gets a pipe separated list of publishing group names.
DefaultRegionalIsoCode | Gets the default regional ISO code.
DefaultShellControl | Gets the default shell control.
DefaultSortOrder | Gets the default value of the sort order attribute.
DefaultSQLTimeout | Gets the default timeout for SQL commands.
DefaultTheme | Gets the default Sitecore client theme.
DefaultThumbnail | Gets the path to the default thumbnail for items in the Sitecore client.
DisableBrowserCaching | Indicates if browser caching of pages should be disabled.
EnableEventQueues | Gets a value that indicates whether Sitecore sends local events to the event queue, and whether the local instance handles events in the queue from remote instances.
EnableXslDocumentFunction | Gets a value indicating whether XSLT document() support should be enabled.
EnableXslScripts | Gets a value indicating whether XSLT script support should be enabled.
ErrorPage | Gets the page to redirect to, if a generic error occurs.
FastPublishing | Use fast publishing?
FastQueryDescendantsDisabled | Setting this to 'true' will improve performance of item creation/moving/deletion, but will make fast query return incorrect results when selecting items using the Ancestors/Descendants axes.
GenerateThumbnails | Indicates if thumbnails of uploaded image files should be generated.
GridPageSize | Gets the number of rows in a UI grid.
HashEncryptionProvider | Gets the hash encryption provider.
HealthMonitorInterval | Gets the health monitor interval.
HeartbeatInterval | Gets the interval between heartbeats.
IgnoreUrlPrefixes | Gets a pipe separated list of url prefixes to ignore when mapping friendly urls.
ImageTypes | Gets a pipe separated list of image file types (extensions).
IncludeProxiesInLinkDatabase | Gets a value indicating whether to include proxy definitions in the link database.
IndexFolder | Gets the index folder.
InstanceName | Gets the name of the Sitecore server instance.
InvalidItemNameChars | Gets the invalid item name chars.
ItemNameValidation | Gets the item name validation.
ItemNotFoundUrl | Gets the url to redirect to, if an item being linked to is not found.
KeepLockAfterSaveForAdminUsers | Gets a value indicating whether the item is keeped locked after save in Page Editor for Administator users.
LayoutFolder | Gets the path to the layout file root folder.
LayoutNotFoundUrl | Gets the url to redirect to, if an items layout is not found.
LayoutPageEvent | Gets the name of page event where the layout pipeline will be run.
LicenseFile | Gets the path to the license file.
LinkItemNotFoundUrl | Gets the url to redirect to, if an item is not found.
LogFolder | Gets the path to the log folder.
LoginLayout | Gets the name of the layout to use for logging in (to extranet)
LoginPage | Gets the path to the page to use for logging in (to extranet)
MailServer | Gets the mail server.
MailServerPassword | Gets the mail server password.
MailServerPort | Gets the mail server port.
MailServerUserName | Gets the name of the mail server user.
MasterVariablesReplacer | Gets the type of a class used for replacing variables when creating a master.
MaxCallLevel | Specifies the maximum allowed depth of a recursive method call.
MaxItemNameLength | Specifies the maximum length of an item name.
MaxSqlBatchStatements | Gets the maximum number of statements to put in a SqlBatch.
MaxTreeDepth | Specifies the maximum allowed depth of an item tree.
MaxWorkerThreads | Gets the maximum number of worker threads to use.
MediaFolder | Gets the path to the media library root folder.
NoAccessUrl | Gets the url to redirect to, if access to an item is denied.
NoLicenseUrl | Gets the url to redirect to, if a license is missing.
PackagePath | Specifies the path where package files are located.
PortalPrincipalResolver | Gets the portal principal resolver.
PortalStorage | Gets the portal storage.
ProcessHistoryCount | Gets the number of process histories to show at startup.
ProfileItemDatabase | Gets the database where user profile items are stored.
ProtectedSite | Indicates if the entire site is protected (require login).
RecycleBinActive | Indicates if recycle bin is active.
RedirectUrlPrefixes | Gets a list of paths for which the RewritePath method should not be used for security reasons. For more details see the RedirectURLPrefixes setting in the web.config file.
RequireLockBeforeEditing | Gets a value indicating whether a lock is required before editing.
SerializationFolder | Gets the serialization folder.
SerializationPassword | Gets the password used for deserializing users.
Sites | Gets the list of sites.
SystemBlockedUrl | Gets the url to redirect to, if the system has been blocked.
TempFolderPath | Gets the temp folder path.
ThumbnailHeight | Gets the max height of auto-generated image thumbnails.
ThumbnailsBackgroundColor | Gets the color of the thumbnails background.
ThumbnailWidth | Gets the maximum width of auto-generated image thumbnails.
UnlockAfterCopy | Gets a value indicating whether to unlock items after copying.
VersionFilePath | Gets the path to the version file.
ViewStateStore | Indicates if ViewState is cached in the GlobalCache in SheerUI.
Wallpaper | Gets the wallpaper.
WallpapersPath | Gets the wallpapers path.
WebStylesheet | Gets the path to the default web site stylesheet.
WelcomeTitle | Gets the welcome title to show on the login page.
XHtmlSchemaFile | Gets the XHTML schema file.
XmlControlAspxFile | Gets the extension used for xml control files.
XmlControlExtension | Gets the extension used for xml control files.

See Also

Settings Class
Sitecore.Configuration Namespace


AccountNameValidation Property

[image]

Sitecore 6.4.1 API
Settings..::..AccountNameValidation Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string AccountNameValidation { get; }
Visual Basic
Public Shared ReadOnly Property AccountNameValidation As String
    Get
Visual C++
public:
static property String^ AccountNameValidation {
    String^ get ();
}

Field Value

The default account name validation.

See Also

Settings Class
Sitecore.Configuration Namespace


AliasesActive Property

[image]

Sitecore 6.4.1 API
Settings..::..AliasesActive Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool AliasesActive { get; }
Visual Basic
Public Shared ReadOnly Property AliasesActive As Boolean
    Get
Visual C++
public:
static property bool AliasesActive {
    bool get ();
}

Field Value

True, if aliases are active, otherwise false. Default value: true.

Remarks

When Sitecore renders a page, it first tries to determine the current item from the path on the query string. If the path does not match an item, it search the alias list for matching pages. An alias is a simple pointer to an item in Sitecore. If a match is found, that page is rendered.

Aliases are configured in /sitecore/system/aliases.

Aliases cause a small performance loss as the alias list has to be searched, if the page was not found.

This setting controls if the alias lias search or not.

The name of the web.config setting is "AliasesActive".

See Also

Settings Class
Sitecore.Configuration Namespace


AllowLogoutOfAllUsers Property

[image]

Sitecore 6.4.1 API
Settings..::..AllowLogoutOfAllUsers Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool AllowLogoutOfAllUsers { get; }
Visual Basic
Public Shared ReadOnly Property AllowLogoutOfAllUsers As Boolean
    Get
Visual C++
public:
static property bool AllowLogoutOfAllUsers {
    bool get ();
}

Field Value

True, if all users are shown, otherwise false. Default value: false.

Remarks

>When a user logs in, Sitecore checks if the maximum number of users has been reached (as specified in the license). If so, the logout user web page is shown allowing the user to logout a existing session.

This flags is the user is allowed to logout only sessions with the same name as the user, or all other sessions. For instance if the flag is false, the user "Andy" may only logout other sessions created by the user "Andy". If the flag is true, "Andy" can also logout sessions created by "Bob".

The name of the web.config setting is "AllowLogoutOfAllUsers".

See Also

Settings Class
Sitecore.Configuration Namespace


AppendQSToUrlRendering Property

[image]

Sitecore 6.4.1 API
Settings..::..AppendQSToUrlRendering Property
Settings Class Example See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool AppendQSToUrlRendering { get; }
Visual Basic
Public Shared ReadOnly Property AppendQSToUrlRendering As Boolean
    Get
Visual C++
public:
static property bool AppendQSToUrlRendering {
    bool get ();
}

Field Value

Default value: true.

Remarks

If true, query strings of the main page will be passed on the all URL renderings on the page.

Examples

If a layout contains a URL rendering with the url http://www.google.com/search., and the layout is triggered by the url http://localhost/home.aspx?q=sitecore., the url rendering will request the url http://www.google.com/search?q=sitecore.

See Also

Settings Class
Sitecore.Configuration Namespace


AutoMaintainProxyDefinitions Property

[image]

Sitecore 6.4.1 API
Settings..::..AutoMaintainProxyDefinitions Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool AutoMaintainProxyDefinitions { get; }
Visual Basic
Public Shared ReadOnly Property AutoMaintainProxyDefinitions As Boolean
    Get
Visual C++
public:
static property bool AutoMaintainProxyDefinitions {
    bool get ();
}

Field Value

true if the Sitecore shall copy/delete proxy definitions automatically; otherwise, false.

See Also

Settings Class
Sitecore.Configuration Namespace


AutomaticDataBind Property

[image]

Sitecore 6.4.1 API
Settings..::..AutomaticDataBind Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool AutomaticDataBind { get; }
Visual Basic
Public Shared ReadOnly Property AutomaticDataBind As Boolean
    Get
Visual C++
public:
static property bool AutomaticDataBind {
    bool get ();
}

Field Value

True, if DataBind()()()() is called, otherwise false. Default value: false.

Remarks

This settings holds the default value for the DataBind State variable.

See Also

Settings Class
Sitecore.Configuration Namespace


AutomaticLockOnSave Property

[image]

Sitecore 6.4.1 API
Settings..::..AutomaticLockOnSave Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool AutomaticLockOnSave { get; }
Visual Basic
Public Shared ReadOnly Property AutomaticLockOnSave As Boolean
    Get
Visual C++
public:
static property bool AutomaticLockOnSave {
    bool get ();
}

Field Value

true if the item is automatically locked on save; otherwise, false.

See Also

Settings Class
Sitecore.Configuration Namespace


AutomaticUnlockOnSaved Property

[image]

Sitecore 6.4.1 API
Settings..::..AutomaticUnlockOnSaved Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool AutomaticUnlockOnSaved { get; }
Visual Basic
Public Shared ReadOnly Property AutomaticUnlockOnSaved As Boolean
    Get
Visual C++
public:
static property bool AutomaticUnlockOnSaved {
    bool get ();
}

Field Value

true if the item is automatically unlocked on saved; otherwise, false.

See Also

Settings Class
Sitecore.Configuration Namespace


CheckSecurityOnLanguages Property

[image]

Sitecore 6.4.1 API
Settings..::..CheckSecurityOnLanguages Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool CheckSecurityOnLanguages { get; }
Visual Basic
Public Shared ReadOnly Property CheckSecurityOnLanguages As Boolean
    Get
Visual C++
public:
static property bool CheckSecurityOnLanguages {
    bool get ();
}

Field Value

Default value: false.

Remarks

If true, the security settings on individual languages will be checked.

This allows the administrator to hide languages from individual users. For instance, security may be set that allows a user to read English and write German.

See Also

Settings Class
Sitecore.Configuration Namespace


ClientLanguage Property

[image]

Sitecore 6.4.1 API
Settings..::..ClientLanguage Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ClientLanguage { get; }
Visual Basic
Public Shared ReadOnly Property ClientLanguage As String
    Get
Visual C++
public:
static property String^ ClientLanguage {
    String^ get ();
}

Field Value

Default value: "en"

Remarks

Determines the language of the user interface in the Sitecore client.

This setting will be ignored if a specific client language has been specified for the user (in the user settings).

See Also

Settings Class
Sitecore.Configuration Namespace


ConfigurationIsSet Property

[image]

Sitecore 6.4.1 API
Settings..::..ConfigurationIsSet Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool ConfigurationIsSet { get; }
Visual Basic
Public Shared ReadOnly Property ConfigurationIsSet As Boolean
    Get
Visual C++
public:
static property bool ConfigurationIsSet {
    bool get ();
}

Field Value

true if configuration is set; otherwise, false.

See Also

Settings Class
Sitecore.Configuration Namespace


CustomErrorsMode Property

[image]

Sitecore 6.4.1 API
Settings..::..CustomErrorsMode Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static CustomErrorsMode CustomErrorsMode { get; }
Visual Basic
Public Shared ReadOnly Property CustomErrorsMode As CustomErrorsMode
    Get
Visual C++
public:
static property CustomErrorsMode CustomErrorsMode {
    CustomErrorsMode get ();
}

Field Value

The custom errors mode.

See Also

Settings Class
Sitecore.Configuration Namespace


DataFolder Property

[image]

Sitecore 6.4.1 API
Settings..::..DataFolder Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string DataFolder { get; }
Visual Basic
Public Shared ReadOnly Property DataFolder As String
    Get
Visual C++
public:
static property String^ DataFolder {
    String^ get ();
}

Field Value

Default value: "/data"

Remarks

The data folder is the place where data, index, audit and log files are stored.

The value can be a virtual or physical path.

See Also

Settings Class
Sitecore.Configuration Namespace


DataProviderTimeout Property

[image]

Sitecore 6.4.1 API
Settings..::..DataProviderTimeout Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TimeSpan DataProviderTimeout { get; }
Visual Basic
Public Shared ReadOnly Property DataProviderTimeout As TimeSpan
    Get
Visual C++
public:
static property TimeSpan DataProviderTimeout {
    TimeSpan get ();
}

Field Value

Default value: 3 minutes

See Also

Settings Class
Sitecore.Configuration Namespace


DebugBorderColor Property

[image]

Sitecore 6.4.1 API
Settings..::..DebugBorderColor Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string DebugBorderColor { get; }
Visual Basic
Public Shared ReadOnly Property DebugBorderColor As String
    Get
Visual C++
public:
static property String^ DebugBorderColor {
    String^ get ();
}

Field Value

Default value: "red"

Remarks

This is the CSS color value to use when drawing borders around elements on the Sitecore debug page (/sitecore/debug).

See Also

Settings Class
Sitecore.Configuration Namespace


DebugBorderTag Property

[image]

Sitecore 6.4.1 API
Settings..::..DebugBorderTag Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string DebugBorderTag { get; }
Visual Basic
Public Shared ReadOnly Property DebugBorderTag As String
    Get
Visual C++
public:
static property String^ DebugBorderTag {
    String^ get ();
}

Field Value

Default value: "span"

Remarks

This is the html tag to use when drawing borders around elements on the Sitecore debug page (/sitecore/debug).

See Also

Settings Class
Sitecore.Configuration Namespace


DebugEnabled Property

[image]

Sitecore 6.4.1 API
Settings..::..DebugEnabled Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool DebugEnabled { get; }
Visual Basic
Public Shared ReadOnly Property DebugEnabled As Boolean
    Get
Visual C++
public:
static property bool DebugEnabled {
    bool get ();
}

Field Value

true if debug is enabled; otherwise, false.

See Also

Settings Class
Sitecore.Configuration Namespace


DebugFolder Property

[image]

Sitecore 6.4.1 API
Settings..::..DebugFolder Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string DebugFolder { get; }
Visual Basic
Public Shared ReadOnly Property DebugFolder As String
    Get
Visual C++
public:
static property String^ DebugFolder {
    String^ get ();
}

Field Value

Default value: DataFolder

Remarks

The debug folder is the place where debug files are stored.

The value can be a virtual or physical path.

See Also

Settings Class
Sitecore.Configuration Namespace


DefaultBaseTemplate Property

[image]

Sitecore 6.4.1 API
Settings..::..DefaultBaseTemplate Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string DefaultBaseTemplate { get; }
Visual Basic
Public Shared ReadOnly Property DefaultBaseTemplate As String
    Get
Visual C++
public:
static property String^ DefaultBaseTemplate {
    String^ get ();
}

Field Value

The default base template.

See Also

Settings Class
Sitecore.Configuration Namespace


DefaultDesktop Property

[image]

Sitecore 6.4.1 API
Settings..::..DefaultDesktop Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string DefaultDesktop { get; }
Visual Basic
Public Shared ReadOnly Property DefaultDesktop As String
    Get
Visual C++
public:
static property String^ DefaultDesktop {
    String^ get ();
}

Field Value

Default value: "/sitecore/client/desktops/standard/default.aspx"

Remarks

Gets the path of the aspx page that defines the default layout (frameset) of the Sitecore client.

See Also

Settings Class
Sitecore.Configuration Namespace


DefaultIcon Property

[image]

Sitecore 6.4.1 API
Settings..::..DefaultIcon Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string DefaultIcon { get; }
Visual Basic
Public Shared ReadOnly Property DefaultIcon As String
    Get
Visual C++
public:
static property String^ DefaultIcon {
    String^ get ();
}

Field Value

Default value: "/sitecore/client/images/document.gif"

Remarks

Gets the path of the default image file to show next to items in the tree view of the Sitecore client.

The image shown can be overriden by filling out the Icon field on an item or its template.

See Also

Settings Class
Sitecore.Configuration Namespace


DefaultLanguage Property

[image]

Sitecore 6.4.1 API
Settings..::..DefaultLanguage Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string DefaultLanguage { get; }
Visual Basic
Public Shared ReadOnly Property DefaultLanguage As String
    Get
Visual C++
public:
static property String^ DefaultLanguage {
    String^ get ();
}

Field Value

Default value: "en"

Remarks

This is the default language of all content on the web site.

If multiple sites are specified using the <sites> section of web.config, the current url will be matched against the sites specified in that section.

If a match is found, the language of that site definition is used. Otherwise, the value of the 'DefaultLanguage' setting is used.

See Also

Settings Class
Sitecore.Configuration Namespace


DefaultLayoutFile Property

[image]

Sitecore 6.4.1 API
Settings..::..DefaultLayoutFile Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string DefaultLayoutFile { get; }
Visual Basic
Public Shared ReadOnly Property DefaultLayoutFile As String
    Get
Visual C++
public:
static property String^ DefaultLayoutFile {
    String^ get ();
}

Field Value

Default value: "/default.aspx"

See Also

Settings Class
Sitecore.Configuration Namespace


DefaultPageName Property

[image]

Sitecore 6.4.1 API
Settings..::..DefaultPageName Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string DefaultPageName { get; }
Visual Basic
Public Shared ReadOnly Property DefaultPageName As String
    Get
Visual C++
public:
static property String^ DefaultPageName {
    String^ get ();
}

Field Value

The name of the default page.

Remarks

Default value: default.aspx

See Also

Settings Class
Sitecore.Configuration Namespace


DefaultPublishingTargets Property

[image]

Sitecore 6.4.1 API
Settings..::..DefaultPublishingTargets Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string DefaultPublishingTargets { get; }
Visual Basic
Public Shared ReadOnly Property DefaultPublishingTargets As String
    Get
Visual C++
public:
static property String^ DefaultPublishingTargets {
    String^ get ();
}

Field Value

Default value: "||"

Remarks

Groups in this list will be preselected in the Publish and Preview dialogs.

See Also

Settings Class
Sitecore.Configuration Namespace


DefaultRegionalIsoCode Property

[image]

Sitecore 6.4.1 API
Settings..::..DefaultRegionalIsoCode Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string DefaultRegionalIsoCode { get; }
Visual Basic
Public Shared ReadOnly Property DefaultRegionalIsoCode As String
    Get
Visual C++
public:
static property String^ DefaultRegionalIsoCode {
    String^ get ();
}

Field Value

The default regional ISO code.

See Also

Settings Class
Sitecore.Configuration Namespace


DefaultShellControl Property

[image]

Sitecore 6.4.1 API
Settings..::..DefaultShellControl Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string DefaultShellControl { get; }
Visual Basic
Public Shared ReadOnly Property DefaultShellControl As String
    Get
Visual C++
public:
static property String^ DefaultShellControl {
    String^ get ();
}

Field Value

Default value: "Cyclops"

Remarks

This specifies the default XML control to use in /sitecore/shell/default.aspx, if none is specified.

See Also

Settings Class
Sitecore.Configuration Namespace


DefaultSortOrder Property

[image]

Sitecore 6.4.1 API
Settings..::..DefaultSortOrder Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int DefaultSortOrder { get; }
Visual Basic
Public Shared ReadOnly Property DefaultSortOrder As Integer
    Get
Visual C++
public:
static property int DefaultSortOrder {
    int get ();
}

Field Value

Default value: 0

Remarks

Sort order is used for displaying items in the Sitecore client and for API functions that returns sorted sets.

See Also

Settings Class
Sitecore.Configuration Namespace


DefaultSQLTimeout Property

[image]

Sitecore 6.4.1 API
Settings..::..DefaultSQLTimeout Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TimeSpan DefaultSQLTimeout { get; }
Visual Basic
Public Shared ReadOnly Property DefaultSQLTimeout As TimeSpan
    Get
Visual C++
public:
static property TimeSpan DefaultSQLTimeout {
    TimeSpan get ();
}

Field Value

Default value: 3 minutes

See Also

Settings Class
Sitecore.Configuration Namespace


DefaultTheme Property

[image]

Sitecore 6.4.1 API
Settings..::..DefaultTheme Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string DefaultTheme { get; }
Visual Basic
Public Shared ReadOnly Property DefaultTheme As String
    Get
Visual C++
public:
static property String^ DefaultTheme {
    String^ get ();
}

Field Value

Default value: "standard"

Remarks

A theme is a set of colors and fonts used in the Sitecore client (ie. a 'skin').

See Also

Settings Class
Sitecore.Configuration Namespace


DefaultThumbnail Property

[image]

Sitecore 6.4.1 API
Settings..::..DefaultThumbnail Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string DefaultThumbnail { get; }
Visual Basic
Public Shared ReadOnly Property DefaultThumbnail As String
    Get
Visual C++
public:
static property String^ DefaultThumbnail {
    String^ get ();
}

Field Value

Default value: "/sitecore/client/images/document.gif"

See Also

Settings Class
Sitecore.Configuration Namespace


DisableBrowserCaching Property

[image]

Sitecore 6.4.1 API
Settings..::..DisableBrowserCaching Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool DisableBrowserCaching { get; }
Visual Basic
Public Shared ReadOnly Property DisableBrowserCaching As Boolean
    Get
Visual C++
public:
static property bool DisableBrowserCaching {
    bool get ();
}

Field Value

Default value: true.

Remarks

If true, a HTTP header value disabling browser caching will be written to all outgoing pages.

See Also

Settings Class
Sitecore.Configuration Namespace


EnableEventQueues Property

[image]

Sitecore 6.4.1 API
Settings..::..EnableEventQueues Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool EnableEventQueues { get; }
Visual Basic
Public Shared ReadOnly Property EnableEventQueues As Boolean
    Get
Visual C++
public:
static property bool EnableEventQueues {
    bool get ();
}

Field Value

true if Sitecore writes local events to the event queue and handles events in the queue from remote instances; otherwise, false.

See Also

Settings Class
Sitecore.Configuration Namespace


EnableXslDocumentFunction Property

[image]

Sitecore 6.4.1 API
Settings..::..EnableXslDocumentFunction Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool EnableXslDocumentFunction { get; }
Visual Basic
Public Shared ReadOnly Property EnableXslDocumentFunction As Boolean
    Get
Visual C++
public:
static property bool EnableXslDocumentFunction {
    bool get ();
}

Field Value

true if document() support is enabled; otherwise, false.

Remarks

If this is not enabled, it will be an error if the XSLT file contains 'document()' references.

Document support can be set for individual XSLT files by using the EnableDocument property.

Default value: true.

See Also

Settings Class
Sitecore.Configuration Namespace


EnableXslScripts Property

[image]

Sitecore 6.4.1 API
Settings..::..EnableXslScripts Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool EnableXslScripts { get; }
Visual Basic
Public Shared ReadOnly Property EnableXslScripts As Boolean
    Get
Visual C++
public:
static property bool EnableXslScripts {
    bool get ();
}

Field Value

true if script support is enabled; otherwise, false.

Remarks

If script support is not enabled, it will be an error if the XSLT file contains script blocks.

Script support can be set for individual XSLT files by using the EnableScript property.

Default value: false.

See Also

Settings Class
Sitecore.Configuration Namespace


ErrorPage Property

[image]

Sitecore 6.4.1 API
Settings..::..ErrorPage Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ErrorPage { get; }
Visual Basic
Public Shared ReadOnly Property ErrorPage As String
    Get
Visual C++
public:
static property String^ ErrorPage {
    String^ get ();
}

Field Value

Default value: "/sitecore/service/error.aspx"

Remarks

If an error occurs during processing of an incoming request, an error message wil be shown using the page pointed to

See Also

Settings Class
Sitecore.Configuration Namespace


FastPublishing Property

[image]

Sitecore 6.4.1 API
Settings..::..FastPublishing Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool FastPublishing { get; }
Visual Basic
Public Shared ReadOnly Property FastPublishing As Boolean
    Get
Visual C++
public:
static property bool FastPublishing {
    bool get ();
}

Field Value

true if the fast publishing is used; otherwise, false.

See Also

Settings Class
Sitecore.Configuration Namespace


FastQueryDescendantsDisabled Property

[image]

Sitecore 6.4.1 API
Settings..::..FastQueryDescendantsDisabled Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool FastQueryDescendantsDisabled { get; }
Visual Basic
Public Shared ReadOnly Property FastQueryDescendantsDisabled As Boolean
    Get
Visual C++
public:
static property bool FastQueryDescendantsDisabled {
    bool get ();
}

Field Value

true if axes info are refreshed; otherwise, false.

See Also

Settings Class
Sitecore.Configuration Namespace


GenerateThumbnails Property

[image]

Sitecore 6.4.1 API
Settings..::..GenerateThumbnails Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool GenerateThumbnails { get; }
Visual Basic
Public Shared ReadOnly Property GenerateThumbnails As Boolean
    Get
Visual C++
public:
static property bool GenerateThumbnails {
    bool get ();
}

Field Value

Default value: true.

Remarks

If true, a thumbnail will be generated each time an image file is uploaded.

The thumbnail will be stored in the MediaFolder.

See Also

Settings Class
Sitecore.Configuration Namespace
Settings..::..ThumbnailWidth
Settings..::..ThumbnailHeight


GridPageSize Property

[image]

Sitecore 6.4.1 API
Settings..::..GridPageSize Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int GridPageSize { get; }
Visual Basic
Public Shared ReadOnly Property GridPageSize As Integer
    Get
Visual C++
public:
static property int GridPageSize {
    int get ();
}

Field Value

The number of rows in a UI grid.

See Also

Settings Class
Sitecore.Configuration Namespace


HashEncryptionProvider Property

[image]

Sitecore 6.4.1 API
Settings..::..HashEncryptionProvider Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static HashEncryption..::..EncryptionProvider HashEncryptionProvider { get; }
Visual Basic
Public Shared ReadOnly Property HashEncryptionProvider As HashEncryption..::..EncryptionProvider
    Get
Visual C++
public:
static property HashEncryption..::..EncryptionProvider HashEncryptionProvider {
    HashEncryption..::..EncryptionProvider get ();
}

Field Value

The hash encryption provider.

See Also

Settings Class
Sitecore.Configuration Namespace


HealthMonitorInterval Property

[image]

Sitecore 6.4.1 API
Settings..::..HealthMonitorInterval Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TimeSpan HealthMonitorInterval { get; }
Visual Basic
Public Shared ReadOnly Property HealthMonitorInterval As TimeSpan
    Get
Visual C++
public:
static property TimeSpan HealthMonitorInterval {
    TimeSpan get ();
}

Field Value

The health monitor interval (default: 10 minutes).

See Also

Settings Class
Sitecore.Configuration Namespace


HeartbeatInterval Property

[image]

Sitecore 6.4.1 API
Settings..::..HeartbeatInterval Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TimeSpan HeartbeatInterval { get; }
Visual Basic
Public Shared ReadOnly Property HeartbeatInterval As TimeSpan
    Get
Visual C++
public:
static property TimeSpan HeartbeatInterval {
    TimeSpan get ();
}

Field Value

Default value: 00:00:05 (5 seconds)

See Also

Settings Class
Sitecore.Configuration Namespace


IgnoreUrlPrefixes Property

[image]

Sitecore 6.4.1 API
Settings..::..IgnoreUrlPrefixes Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string[] IgnoreUrlPrefixes { get; }
Visual Basic
Public Shared ReadOnly Property IgnoreUrlPrefixes As String()
    Get
Visual C++
public:
static property array<String^>^ IgnoreUrlPrefixes {
    array<String^>^ get ();
}

Field Value

Default value: "/sitecore|/layouts/|/images/|/trace.axd"

Remarks

Normally, url requests coming in are mapped to an item and the request is redirected to the items layout page.

For example, if the item /home/news. has the layout /layouts/newslist.aspx., the url http://localhost/home/news.aspx. will be redirected to http://localhost/layouts/newslist.aspx?path=[id of the News item].

To prevent this redirection to take place for physical aspx pages, their prefixes can be added to IgnoreUrlPrefixes.

For example, if an aspx page called /forms/registration.aspx. existed, the prefix /forms/ could be added to web.config to prevent requests for this page to be redirected.

Elements must be lowercase and non-empty.

See Also

Settings Class
Sitecore.Configuration Namespace


ImageTypes Property

[image]

Sitecore 6.4.1 API
Settings..::..ImageTypes Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ImageTypes { get; }
Visual Basic
Public Shared ReadOnly Property ImageTypes As String
    Get
Visual C++
public:
static property String^ ImageTypes {
    String^ get ();
}

Field Value

Default value: "|gif|jpg|png|"

Remarks

List of file extension that are to be considered images by the Sitecore system.

Used for determining if thumbnails should be generated when uploading files.

See Also

Settings Class
Sitecore.Configuration Namespace


IncludeProxiesInLinkDatabase Property

[image]

Sitecore 6.4.1 API
Settings..::..IncludeProxiesInLinkDatabase Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IncludeProxiesInLinkDatabase { get; }
Visual Basic
Public Shared ReadOnly Property IncludeProxiesInLinkDatabase As Boolean
    Get
Visual C++
public:
static property bool IncludeProxiesInLinkDatabase {
    bool get ();
}

Field Value

true if proxy definitions should be included in the link database; otherwise, false.

See Also

Settings Class
Sitecore.Configuration Namespace


IndexFolder Property

[image]

Sitecore 6.4.1 API
Settings..::..IndexFolder Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string IndexFolder { get; }
Visual Basic
Public Shared ReadOnly Property IndexFolder As String
    Get
Visual C++
public:
static property String^ IndexFolder {
    String^ get ();
}

Field Value

The index folder.

See Also

Settings Class
Sitecore.Configuration Namespace


InstanceName Property

[image]

Sitecore 6.4.1 API
Settings..::..InstanceName Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string InstanceName { get; }
Visual Basic
Public Shared ReadOnly Property InstanceName As String
    Get
Visual C++
public:
static property String^ InstanceName {
    String^ get ();
}

Field Value

The name of the Sitecore server instance.

Remarks

Default value: GetMachineName()()()().

See Also

Settings Class
Sitecore.Configuration Namespace


InvalidItemNameChars Property

[image]

Sitecore 6.4.1 API
Settings..::..InvalidItemNameChars Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static char[] InvalidItemNameChars { get; }
Visual Basic
Public Shared ReadOnly Property InvalidItemNameChars As Char()
    Get
Visual C++
public:
static property array<wchar_t>^ InvalidItemNameChars {
    array<wchar_t>^ get ();
}

Field Value

The invalid item name chars.

See Also

Settings Class
Sitecore.Configuration Namespace


ItemNameValidation Property

[image]

Sitecore 6.4.1 API
Settings..::..ItemNameValidation Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ItemNameValidation { get; }
Visual Basic
Public Shared ReadOnly Property ItemNameValidation As String
    Get
Visual C++
public:
static property String^ ItemNameValidation {
    String^ get ();
}

Field Value

The item name validation.

See Also

Settings Class
Sitecore.Configuration Namespace


ItemNotFoundUrl Property

[image]

Sitecore 6.4.1 API
Settings..::..ItemNotFoundUrl Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ItemNotFoundUrl { get; }
Visual Basic
Public Shared ReadOnly Property ItemNotFoundUrl As String
    Get
Visual C++
public:
static property String^ ItemNotFoundUrl {
    String^ get ();
}

Field Value

Default value: "/sitecore/service/notfound.aspx"

Remarks

If a dynamic link is made for a non-existing item on the web site, the request is redirected to the url pointed to by this setting.

See Also

Settings Class
Sitecore.Configuration Namespace


KeepLockAfterSaveForAdminUsers Property

[image]

Sitecore 6.4.1 API
Settings..::..KeepLockAfterSaveForAdminUsers Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool KeepLockAfterSaveForAdminUsers { get; }
Visual Basic
Public Shared ReadOnly Property KeepLockAfterSaveForAdminUsers As Boolean
    Get
Visual C++
public:
static property bool KeepLockAfterSaveForAdminUsers {
    bool get ();
}

Field Value

true if the item is keeped locked on saved; otherwise, false.

See Also

Settings Class
Sitecore.Configuration Namespace


LayoutFolder Property

[image]

Sitecore 6.4.1 API
Settings..::..LayoutFolder Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string LayoutFolder { get; }
Visual Basic
Public Shared ReadOnly Property LayoutFolder As String
    Get
Visual C++
public:
static property String^ LayoutFolder {
    String^ get ();
}

Field Value

Default value: "/layouts"

Remarks

The layout folder is the place where layout files are stored.

The value can be a virtual or physical path.

See Also

Settings Class
Sitecore.Configuration Namespace


LayoutNotFoundUrl Property

[image]

Sitecore 6.4.1 API
Settings..::..LayoutNotFoundUrl Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string LayoutNotFoundUrl { get; }
Visual Basic
Public Shared ReadOnly Property LayoutNotFoundUrl As String
    Get
Visual C++
public:
static property String^ LayoutNotFoundUrl {
    String^ get ();
}

Field Value

Default value: "/sitecore/service/nolayout.aspx"

Remarks

If a request for an item with an empty or a non-existing layout comes in, the request is redirected to the url pointed to by this setting.

See Also

Settings Class
Sitecore.Configuration Namespace


LayoutPageEvent Property

[image]

Sitecore 6.4.1 API
Settings..::..LayoutPageEvent Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string LayoutPageEvent { get; }
Visual Basic
Public Shared ReadOnly Property LayoutPageEvent As String
    Get
Visual C++
public:
static property String^ LayoutPageEvent {
    String^ get ();
}

Field Value

The layout page event.

Remarks

Presently, there are three valid values: 'preInit', 'init' or 'load'.

Default value is: 'preInit'.

See Also

Settings Class
Sitecore.Configuration Namespace


LicenseFile Property

[image]

Sitecore 6.4.1 API
Settings..::..LicenseFile Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string LicenseFile { get; }
Visual Basic
Public Shared ReadOnly Property LicenseFile As String
    Get
Visual C++
public:
static property String^ LicenseFile {
    String^ get ();
}

Field Value

Default value: MakePath(String, String)(DataFolder, "license.xml")

See Also

Settings Class
Sitecore.Configuration Namespace


LinkItemNotFoundUrl Property

[image]

Sitecore 6.4.1 API
Settings..::..LinkItemNotFoundUrl Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string LinkItemNotFoundUrl { get; }
Visual Basic
Public Shared ReadOnly Property LinkItemNotFoundUrl As String
    Get
Visual C++
public:
static property String^ LinkItemNotFoundUrl {
    String^ get ();
}

Field Value

Default value: "/sitecore/service/notfound.aspx"

Remarks

If a request for a non-existing item comes in on the web site, the request is redirected to the url pointed to by this setting.

See Also

Settings Class
Sitecore.Configuration Namespace


LogFolder Property

[image]

Sitecore 6.4.1 API
Settings..::..LogFolder Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string LogFolder { get; }
Visual Basic
Public Shared ReadOnly Property LogFolder As String
    Get
Visual C++
public:
static property String^ LogFolder {
    String^ get ();
}

Field Value

Default value: DataFolder

Remarks

The log folder is the place where log files are stored.

The value can be a virtual or physical path.

See Also

Settings Class
Sitecore.Configuration Namespace


LoginLayout Property

[image]

Sitecore 6.4.1 API
Settings..::..LoginLayout Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string LoginLayout { get; }
Visual Basic
Public Shared ReadOnly Property LoginLayout As String
    Get
Visual C++
public:
static property String^ LoginLayout {
    String^ get ();
}

Field Value

Default value: [an empty string]

Remarks

If the web site is protected (see ProtectedSite), the layout specified by this setting will be shown, when an unauthorised person tries to view the site.

If no LoginLayout is specified, the ProtectedSite setting will have no effect.

See Also

Settings Class
Sitecore.Configuration Namespace


LoginPage Property

[image]

Sitecore 6.4.1 API
Settings..::..LoginPage Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string LoginPage { get; }
Visual Basic
Public Shared ReadOnly Property LoginPage As String
    Get
Visual C++
public:
static property String^ LoginPage {
    String^ get ();
}

Field Value

Default value: [an empty string]

Remarks

If the web site is protected (see ProtectedSite), the layout specified by this setting will be shown, when an unauthorised person tries to view the site.

If no LoginPage is specified, the user will be redirected to an error page.

See Also

Settings Class
Sitecore.Configuration Namespace


MailServer Property

[image]

Sitecore 6.4.1 API
Settings..::..MailServer Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string MailServer { get; }
Visual Basic
Public Shared ReadOnly Property MailServer As String
    Get
Visual C++
public:
static property String^ MailServer {
    String^ get ();
}

Field Value

The mail server.

See Also

Settings Class
Sitecore.Configuration Namespace


MailServerPassword Property

[image]

Sitecore 6.4.1 API
Settings..::..MailServerPassword Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string MailServerPassword { get; }
Visual Basic
Public Shared ReadOnly Property MailServerPassword As String
    Get
Visual C++
public:
static property String^ MailServerPassword {
    String^ get ();
}

Field Value

The mail server password.

See Also

Settings Class
Sitecore.Configuration Namespace


MailServerPort Property

[image]

Sitecore 6.4.1 API
Settings..::..MailServerPort Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int MailServerPort { get; }
Visual Basic
Public Shared ReadOnly Property MailServerPort As Integer
    Get
Visual C++
public:
static property int MailServerPort {
    int get ();
}

Field Value

The mail server port.

See Also

Settings Class
Sitecore.Configuration Namespace


MailServerUserName Property

[image]

Sitecore 6.4.1 API
Settings..::..MailServerUserName Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string MailServerUserName { get; }
Visual Basic
Public Shared ReadOnly Property MailServerUserName As String
    Get
Visual C++
public:
static property String^ MailServerUserName {
    String^ get ();
}

Field Value

The name of the mail server user.

See Also

Settings Class
Sitecore.Configuration Namespace


MasterVariablesReplacer Property

[image]

Sitecore 6.4.1 API
Settings..::..MasterVariablesReplacer Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string MasterVariablesReplacer { get; }
Visual Basic
Public Shared ReadOnly Property MasterVariablesReplacer As String
    Get
Visual C++
public:
static property String^ MasterVariablesReplacer {
    String^ get ();
}

Field Value

The master variables replacer.

See Also

Settings Class
Sitecore.Configuration Namespace


MaxCallLevel Property

[image]

Sitecore 6.4.1 API
Settings..::..MaxCallLevel Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int MaxCallLevel { get; }
Visual Basic
Public Shared ReadOnly Property MaxCallLevel As Integer
    Get
Visual C++
public:
static property int MaxCallLevel {
    int get ();
}

Field Value

Default value: The current value of MaxTreeDepth

See Also

Settings Class
Sitecore.Configuration Namespace


MaxItemNameLength Property

[image]

Sitecore 6.4.1 API
Settings..::..MaxItemNameLength Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int MaxItemNameLength { get; }
Visual Basic
Public Shared ReadOnly Property MaxItemNameLength As Integer
    Get
Visual C++
public:
static property int MaxItemNameLength {
    int get ();
}

Field Value

Default value: 100

See Also

Settings Class
Sitecore.Configuration Namespace


MaxSqlBatchStatements Property

[image]

Sitecore 6.4.1 API
Settings..::..MaxSqlBatchStatements Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int MaxSqlBatchStatements { get; }
Visual Basic
Public Shared ReadOnly Property MaxSqlBatchStatements As Integer
    Get
Visual C++
public:
static property int MaxSqlBatchStatements {
    int get ();
}

Field Value

The maximum number. Default value: 150

See Also

Settings Class
Sitecore.Configuration Namespace


MaxTreeDepth Property

[image]

Sitecore 6.4.1 API
Settings..::..MaxTreeDepth Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int MaxTreeDepth { get; }
Visual Basic
Public Shared ReadOnly Property MaxTreeDepth As Integer
    Get
Visual C++
public:
static property int MaxTreeDepth {
    int get ();
}

Field Value

Default value: 20

See Also

Settings Class
Sitecore.Configuration Namespace


MaxWorkerThreads Property

[image]

Sitecore 6.4.1 API
Settings..::..MaxWorkerThreads Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int MaxWorkerThreads { get; }
Visual Basic
Public Shared ReadOnly Property MaxWorkerThreads As Integer
    Get
Visual C++
public:
static property int MaxWorkerThreads {
    int get ();
}

Field Value

Default value: 20

Remarks

Used by the ManagedThreadPool.

See Also

Settings Class
Sitecore.Configuration Namespace


MediaFolder Property

[image]

Sitecore 6.4.1 API
Settings..::..MediaFolder Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string MediaFolder { get; }
Visual Basic
Public Shared ReadOnly Property MediaFolder As String
    Get
Visual C++
public:
static property String^ MediaFolder {
    String^ get ();
}

Field Value

Default value: "/upload"

Remarks

The media folder is the place where images, pdf's, and other media files are stored.

The value can be a virtual or physical path.

See Also

Settings Class
Sitecore.Configuration Namespace


NoAccessUrl Property

[image]

Sitecore 6.4.1 API
Settings..::..NoAccessUrl Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string NoAccessUrl { get; }
Visual Basic
Public Shared ReadOnly Property NoAccessUrl As String
    Get
Visual C++
public:
static property String^ NoAccessUrl {
    String^ get ();
}

Field Value

Default value: "/sitecore/service/noaccess.aspx"

Remarks

If a request for an item for which the current user does not have read rights is detected, the request is redirected to the url pointed to by this setting.

See Also

Settings Class
Sitecore.Configuration Namespace


NoLicenseUrl Property

[image]

Sitecore 6.4.1 API
Settings..::..NoLicenseUrl Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string NoLicenseUrl { get; }
Visual Basic
Public Shared ReadOnly Property NoLicenseUrl As String
    Get
Visual C++
public:
static property String^ NoLicenseUrl {
    String^ get ();
}

Field Value

Default value: "/sitecore/service/nolicense.aspx"

Remarks

If a required license is missing, page requests will be redirected to the url pointed to by this setting.

See Also

Settings Class
Sitecore.Configuration Namespace


PackagePath Property

[image]

Sitecore 6.4.1 API
Settings..::..PackagePath Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string PackagePath { get; }
Visual Basic
Public Shared ReadOnly Property PackagePath As String
    Get
Visual C++
public:
static property String^ PackagePath {
    String^ get ();
}

Field Value

Default value: MakePath(String, String)(DataFolder, "packages")

Remarks

When installing packages, the package files must be located in this folder.

Also, when generating new packages, the files will be saved in this folder.

See Also

Settings Class
Sitecore.Configuration Namespace


PortalPrincipalResolver Property

[image]

Sitecore 6.4.1 API
Settings..::..PortalPrincipalResolver Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string PortalPrincipalResolver { get; }
Visual Basic
Public Shared ReadOnly Property PortalPrincipalResolver As String
    Get
Visual C++
public:
static property String^ PortalPrincipalResolver {
    String^ get ();
}

Field Value

The portal principal resolver.

See Also

Settings Class
Sitecore.Configuration Namespace


ProcessHistoryCount Property

[image]

Sitecore 6.4.1 API
Settings..::..ProcessHistoryCount Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int ProcessHistoryCount { get; }
Visual Basic
Public Shared ReadOnly Property ProcessHistoryCount As Integer
    Get
Visual C++
public:
static property int ProcessHistoryCount {
    int get ();
}

Field Value

Default value: 2

Remarks

For diagnostic purposes, the shutdown reason for previous ASP.NET worker processes are shown in the Sitecore log file.

This setting determinies how many proceses to look back (max. 100).

See Also

Settings Class
Sitecore.Configuration Namespace


ProfileItemDatabase Property

[image]

Sitecore 6.4.1 API
Settings..::..ProfileItemDatabase Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ProfileItemDatabase { get; }
Visual Basic
Public Shared ReadOnly Property ProfileItemDatabase As String
    Get
Visual C++
public:
static property String^ ProfileItemDatabase {
    String^ get ();
}

Field Value

The profile item database.

See Also

Settings Class
Sitecore.Configuration Namespace


ProtectedSite Property

[image]

Sitecore 6.4.1 API
Settings..::..ProtectedSite Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool ProtectedSite { get; }
Visual Basic
Public Shared ReadOnly Property ProtectedSite As Boolean
    Get
Visual C++
public:
static property bool ProtectedSite {
    bool get ();
}

Field Value

Default value: false.

Remarks

If true, no page on the site can be accessed without logging in to the extranet security subsystem.

For this to work, the setting LoginLayout must. also be set.

See Also

Settings Class
Sitecore.Configuration Namespace


RecycleBinActive Property

[image]

Sitecore 6.4.1 API
Settings..::..RecycleBinActive Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool RecycleBinActive { get; }
Visual Basic
Public Shared ReadOnly Property RecycleBinActive As Boolean
    Get
Visual C++
public:
static property bool RecycleBinActive {
    bool get ();
}

Field Value

Default value: true.

Remarks

If true, deleted items are moved to the recycle bin rather than being physically deleted.

If false, items are always physically deleted.

See Also

Settings Class
Sitecore.Configuration Namespace


RedirectUrlPrefixes Property

[image]

Sitecore 6.4.1 API
Settings..::..RedirectUrlPrefixes Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static IEnumerable<string> RedirectUrlPrefixes { get; }
Visual Basic
Public Shared ReadOnly Property RedirectUrlPrefixes As IEnumerable(Of String)
    Get
Visual C++
public:
static property IEnumerable<String^>^ RedirectUrlPrefixes {
    IEnumerable<String^>^ get ();
}

Field Value

List of paths.

See Also

Settings Class
Sitecore.Configuration Namespace


RequireLockBeforeEditing Property

[image]

Sitecore 6.4.1 API
Settings..::..RequireLockBeforeEditing Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool RequireLockBeforeEditing { get; }
Visual Basic
Public Shared ReadOnly Property RequireLockBeforeEditing As Boolean
    Get
Visual C++
public:
static property bool RequireLockBeforeEditing {
    bool get ();
}

Field Value

true if a lock is required before editing; otherwise, false.

See Also

Settings Class
Sitecore.Configuration Namespace


SerializationFolder Property

[image]

Sitecore 6.4.1 API
Settings..::..SerializationFolder Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string SerializationFolder { get; }
Visual Basic
Public Shared ReadOnly Property SerializationFolder As String
    Get
Visual C++
public:
static property String^ SerializationFolder {
    String^ get ();
}

Field Value

The serialization folder.

See Also

Settings Class
Sitecore.Configuration Namespace


SerializationPassword Property

[image]

Sitecore 6.4.1 API
Settings..::..SerializationPassword Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string SerializationPassword { get; }
Visual Basic
Public Shared ReadOnly Property SerializationPassword As String
    Get
Visual C++
public:
static property String^ SerializationPassword {
    String^ get ();
}

Field Value

The serialization password.

See Also

Settings Class
Sitecore.Configuration Namespace


Sites Property

[image]

Sitecore 6.4.1 API
Settings..::..Sites Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static List<SiteInfo> Sites { get; }
Visual Basic
Public Shared ReadOnly Property Sites As List(Of SiteInfo)
    Get
Visual C++
public:
static property List<SiteInfo^>^ Sites {
    List<SiteInfo^>^ get ();
}

Field Value

Default value: [empty list]

Remarks

A single Sitecore database can contain multiple sites with different root paths and languages.

This setting returns a list of SiteInfo objects describing the individual sites in a multi-site installation.

The site data is collected from the <sites> section in web.config.

See Also

Settings Class
Sitecore.Configuration Namespace


SystemBlockedUrl Property

[image]

Sitecore 6.4.1 API
Settings..::..SystemBlockedUrl Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string SystemBlockedUrl { get; }
Visual Basic
Public Shared ReadOnly Property SystemBlockedUrl As String
    Get
Visual C++
public:
static property String^ SystemBlockedUrl {
    String^ get ();
}

Field Value

Default value: "/sitecore/blocked.aspx"

Remarks

If the system has been blocked, page requests will be redirected to the url pointed to by this setting.

See Also

Settings Class
Sitecore.Configuration Namespace


TempFolderPath Property

[image]

Sitecore 6.4.1 API
Settings..::..TempFolderPath Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string TempFolderPath { get; }
Visual Basic
Public Shared ReadOnly Property TempFolderPath As String
    Get
Visual C++
public:
static property String^ TempFolderPath {
    String^ get ();
}

Field Value

The temp folder path.

See Also

Settings Class
Sitecore.Configuration Namespace


ThumbnailHeight Property

[image]

Sitecore 6.4.1 API
Settings..::..ThumbnailHeight Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int ThumbnailHeight { get; }
Visual Basic
Public Shared ReadOnly Property ThumbnailHeight As Integer
    Get
Visual C++
public:
static property int ThumbnailHeight {
    int get ();
}

Field Value

Default value: 50

Remarks

When images are uploaded to the media library, a thumbnail is generated (see GenerateThumbnails).

If zero, the ThumbnailWidth property decides the size (scaling is done proportionally).

See Also

Settings Class
Sitecore.Configuration Namespace


ThumbnailsBackgroundColor Property

[image]

Sitecore 6.4.1 API
Settings..::..ThumbnailsBackgroundColor Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ThumbnailsBackgroundColor { get; }
Visual Basic
Public Shared ReadOnly Property ThumbnailsBackgroundColor As String
    Get
Visual C++
public:
static property String^ ThumbnailsBackgroundColor {
    String^ get ();
}

Field Value

The color of the thumbnails background.

See Also

Settings Class
Sitecore.Configuration Namespace


ThumbnailWidth Property

[image]

Sitecore 6.4.1 API
Settings..::..ThumbnailWidth Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int ThumbnailWidth { get; }
Visual Basic
Public Shared ReadOnly Property ThumbnailWidth As Integer
    Get
Visual C++
public:
static property int ThumbnailWidth {
    int get ();
}

Field Value

Default value: 0

Remarks

When images are uploaded to the media library, a thumbnail is generated (see GenerateThumbnails).

If zero, the ThumbnailHeight property decides the size (scaling is done proportionally).

See Also

Settings Class
Sitecore.Configuration Namespace


UnlockAfterCopy Property

[image]

Sitecore 6.4.1 API
Settings..::..UnlockAfterCopy Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool UnlockAfterCopy { get; }
Visual Basic
Public Shared ReadOnly Property UnlockAfterCopy As Boolean
    Get
Visual C++
public:
static property bool UnlockAfterCopy {
    bool get ();
}

Field Value

true if items should be unlocked after copying; otherwise, false.

Remarks

Only the copies are unlocked. The original items stay locked.

See Also

Settings Class
Sitecore.Configuration Namespace


VersionFilePath Property

[image]

Sitecore 6.4.1 API
Settings..::..VersionFilePath Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string VersionFilePath { get; }
Visual Basic
Public Shared ReadOnly Property VersionFilePath As String
    Get
Visual C++
public:
static property String^ VersionFilePath {
    String^ get ();
}

Field Value

The version file path.

See Also

Settings Class
Sitecore.Configuration Namespace


ViewStateStore Property

[image]

Sitecore 6.4.1 API
Settings..::..ViewStateStore Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ViewStateStore { get; }
Visual Basic
Public Shared ReadOnly Property ViewStateStore As String
    Get
Visual C++
public:
static property String^ ViewStateStore {
    String^ get ();
}

Field Value

The view state store.

See Also

Settings Class
Sitecore.Configuration Namespace


Wallpaper Property

[image]

Sitecore 6.4.1 API
Settings..::..Wallpaper Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Wallpaper { get; }
Visual Basic
Public Shared ReadOnly Property Wallpaper As String
    Get
Visual C++
public:
static property String^ Wallpaper {
    String^ get ();
}

Field Value

The wallpaper.

See Also

Settings Class
Sitecore.Configuration Namespace


WallpapersPath Property

[image]

Sitecore 6.4.1 API
Settings..::..WallpapersPath Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string WallpapersPath { get; }
Visual Basic
Public Shared ReadOnly Property WallpapersPath As String
    Get
Visual C++
public:
static property String^ WallpapersPath {
    String^ get ();
}

Field Value

The wallpapers path.

See Also

Settings Class
Sitecore.Configuration Namespace


WebStylesheet Property

[image]

Sitecore 6.4.1 API
Settings..::..WebStylesheet Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string WebStylesheet { get; }
Visual Basic
Public Shared ReadOnly Property WebStylesheet As String
    Get
Visual C++
public:
static property String^ WebStylesheet {
    String^ get ();
}

Field Value

Default value: /default.css.

Remarks

The stylesheet pointed to by this setting is automatically added to all pages descending from Sitecore.BasePage".

See Also

Settings Class
Sitecore.Configuration Namespace


WelcomeTitle Property

[image]

Sitecore 6.4.1 API
Settings..::..WelcomeTitle Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string WelcomeTitle { get; }
Visual Basic
Public Shared ReadOnly Property WelcomeTitle As String
    Get
Visual C++
public:
static property String^ WelcomeTitle {
    String^ get ();
}

Field Value

Default value: "" (empty string)

Remarks

The title to show on the Sitecore client login page.

See Also

Settings Class
Sitecore.Configuration Namespace


XHtmlSchemaFile Property

[image]

Sitecore 6.4.1 API
Settings..::..XHtmlSchemaFile Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string XHtmlSchemaFile { get; }
Visual Basic
Public Shared ReadOnly Property XHtmlSchemaFile As String
    Get
Visual C++
public:
static property String^ XHtmlSchemaFile {
    String^ get ();
}

Field Value

The XHTML schema file.

See Also

Settings Class
Sitecore.Configuration Namespace


XmlControlAspxFile Property

[image]

Sitecore 6.4.1 API
Settings..::..XmlControlAspxFile Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string XmlControlAspxFile { get; }
Visual Basic
Public Shared ReadOnly Property XmlControlAspxFile As String
    Get
Visual C++
public:
static property String^ XmlControlAspxFile {
    String^ get ();
}

Field Value

Default value: "xml"

See Also

Settings Class
Sitecore.Configuration Namespace


XmlControlExtension Property

[image]

Sitecore 6.4.1 API
Settings..::..XmlControlExtension Property
Settings Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string XmlControlExtension { get; }
Visual Basic
Public Shared ReadOnly Property XmlControlExtension As String
    Get
Visual C++
public:
static property String^ XmlControlExtension {
    String^ get ();
}

Field Value

Default value: "xml"

See Also

Settings Class
Sitecore.Configuration Namespace


Settings.Authentication Class

[image]

Sitecore 6.4.1 API
Settings..::..Authentication Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Authentication
Visual Basic
Public NotInheritable Class Authentication
Visual C++
public ref class Authentication abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..Authentication

See Also

Settings..::..Authentication Members
Sitecore.Configuration Namespace


Settings.Authentication Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..Authentication Members
Settings..::..Authentication Class Properties See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..Authentication type exposes the following members.

Properties

Name | Description
ClientPersistentLoginDuration | Specifies the timeout in days for the client "remember me" feature.
DefaultDomainName | Gets the name of the default domain.
DefaultMembershipProviderWildcard | Gets the default membership wildcard used by the providers.
SaveRawUrl | Specifies whether the original request URL is passed to the login page (saved in 'url' query string parameter).
TicketTimeout | Obsolete. Specifies the timeout in minutes of an authentication ticket.
VirtualMembershipWildcard | Gets the membership wildcard to use in high level code.

See Also

Settings..::..Authentication Class
Sitecore.Configuration Namespace


Settings.Authentication Properties

[image] [image]

Sitecore 6.4.1 API
Settings..::..Authentication Properties
Settings..::..Authentication Class See Also Send Feedback

The Settings..::..Authentication type exposes the following members.

Properties

Name | Description
ClientPersistentLoginDuration | Specifies the timeout in days for the client "remember me" feature.
DefaultDomainName | Gets the name of the default domain.
DefaultMembershipProviderWildcard | Gets the default membership wildcard used by the providers.
SaveRawUrl | Specifies whether the original request URL is passed to the login page (saved in 'url' query string parameter).
TicketTimeout | Obsolete. Specifies the timeout in minutes of an authentication ticket.
VirtualMembershipWildcard | Gets the membership wildcard to use in high level code.

See Also

Settings..::..Authentication Class
Sitecore.Configuration Namespace


ClientPersistentLoginDuration Property

[image]

Sitecore 6.4.1 API
Settings..::..Authentication..::..ClientPersistentLoginDuration Property
Settings..::..Authentication Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TimeSpan ClientPersistentLoginDuration { get; }
Visual Basic
Public Shared ReadOnly Property ClientPersistentLoginDuration As TimeSpan
    Get
Visual C++
public:
static property TimeSpan ClientPersistentLoginDuration {
    TimeSpan get ();
}

See Also

Settings..::..Authentication Class
Sitecore.Configuration Namespace


DefaultDomainName Property

[image]

Sitecore 6.4.1 API
Settings..::..Authentication..::..DefaultDomainName Property
Settings..::..Authentication Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string DefaultDomainName { get; }
Visual Basic
Public Shared ReadOnly Property DefaultDomainName As String
    Get
Visual C++
public:
static property String^ DefaultDomainName {
    String^ get ();
}

Field Value

The name of the default domain.

Remarks

Default value: default

See Also

Settings..::..Authentication Class
Sitecore.Configuration Namespace


DefaultMembershipProviderWildcard Property

[image]

Sitecore 6.4.1 API
Settings..::..Authentication..::..DefaultMembershipProviderWildcard Property
Settings..::..Authentication Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string DefaultMembershipProviderWildcard { get; }
Visual Basic
Public Shared ReadOnly Property DefaultMembershipProviderWildcard As String
    Get
Visual C++
public:
static property String^ DefaultMembershipProviderWildcard {
    String^ get ();
}

Field Value

The membership wildcard. Default value: %

See Also

Settings..::..Authentication Class
Sitecore.Configuration Namespace


SaveRawUrl Property

[image]

Sitecore 6.4.1 API
Settings..::..Authentication..::..SaveRawUrl Property
Settings..::..Authentication Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool SaveRawUrl { get; }
Visual Basic
Public Shared ReadOnly Property SaveRawUrl As Boolean
    Get
Visual C++
public:
static property bool SaveRawUrl {
    bool get ();
}

Field Value

true if raw URL of original request should be passed to the login page otherwise, false.

See Also

Settings..::..Authentication Class
Sitecore.Configuration Namespace


TicketTimeout Property

[image]

Sitecore 6.4.1 API
Settings..::..Authentication..::..TicketTimeout Property
Settings..::..Authentication Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Authentication.ClientPersistentLoginDuration is used for remember me duration, ticket timeouts are obsolete")]
public static TimeSpan TicketTimeout { get; }
Visual Basic
<ObsoleteAttribute("Authentication.ClientPersistentLoginDuration is used for remember me duration, ticket timeouts are obsolete")> _
Public Shared ReadOnly Property TicketTimeout As TimeSpan
    Get
Visual C++
[ObsoleteAttribute(L"Authentication.ClientPersistentLoginDuration is used for remember me duration, ticket timeouts are obsolete")]
public:
static property TimeSpan TicketTimeout {
    TimeSpan get ();
}

See Also

Settings..::..Authentication Class
Sitecore.Configuration Namespace


VirtualMembershipWildcard Property

[image]

Sitecore 6.4.1 API
Settings..::..Authentication..::..VirtualMembershipWildcard Property
Settings..::..Authentication Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string VirtualMembershipWildcard { get; }
Visual Basic
Public Shared ReadOnly Property VirtualMembershipWildcard As String
    Get
Visual C++
public:
static property String^ VirtualMembershipWildcard {
    String^ get ();
}

Field Value

The membership wildcard. Default value: *

See Also

Settings..::..Authentication Class
Sitecore.Configuration Namespace


Settings.Authorization Class

[image]

Sitecore 6.4.1 API
Settings..::..Authorization Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Authorization
Visual Basic
Public NotInheritable Class Authorization
Visual C++
public ref class Authorization abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..Authorization

See Also

Settings..::..Authorization Members
Sitecore.Configuration Namespace


Settings.Authorization Properties

[image] [image]

Sitecore 6.4.1 API
Settings..::..Authorization Properties
Settings..::..Authorization Class See Also Send Feedback

The Settings..::..Authorization type exposes the following members.

Properties

Name | Description
InheritSecurityByDefault | Gets a value indicating whether to inherit security by default.

See Also

Settings..::..Authorization Class
Sitecore.Configuration Namespace


InheritSecurityByDefault Property

[image]

Sitecore 6.4.1 API
Settings..::..Authorization..::..InheritSecurityByDefault Property
Settings..::..Authorization Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool InheritSecurityByDefault { get; }
Visual Basic
Public Shared ReadOnly Property InheritSecurityByDefault As Boolean
    Get
Visual C++
public:
static property bool InheritSecurityByDefault {
    bool get ();
}

Field Value

true if security is inherited by default; otherwise, false.

See Also

Settings..::..Authorization Class
Sitecore.Configuration Namespace


Settings.Caching Class

[image]

Sitecore 6.4.1 API
Settings..::..Caching Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Caching
Visual Basic
Public NotInheritable Class Caching
Visual C++
public ref class Caching abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..Caching

See Also

Settings..::..Caching Members
Sitecore.Configuration Namespace


Settings.Caching Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..Caching Members
Settings..::..Caching Class Methods Properties See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..Caching type exposes the following members.

Methods

Name | Description
GetAbsoluteSecurityCacheExpiration | Items that are older than the speficied time interval (in days) will not be included in the feed.

Properties

Name | Description
AccessResultCacheSize | Gets the size of the access result cache.
AverageItemSize | Gets the average size of an item.
BlobIDCacheSize | Gets the size of the cache that stores blob IDs.
CacheViewState | Indicates if ViewState is cached in the GlobalCache in SheerUI.
DefaultClientDataCacheSize | Gets the size of the default client data cache.
DefaultDataCacheSize | Gets the size of the default data cache.
DefaultFilteredItemsCacheSize | Gets the default size of the filtered items cache.
DefaultHtmlCacheSize | Gets the size of the default HTML cache.
DefaultItemCacheSize | Gets the size of the default item cache.
DefaultPathCacheSize | Gets the size of the default path cache.
DefaultPriority | Gets the default priority.
DefaultPropertyCacheSize | Gets the size of the default property cache.
DefaultProxyCacheSize | Gets the size of the default proxy cache.
DefaultRegistryCacheSize | Gets the size of the default registry cache.
DefaultTemplateCacheSize | Gets the size of the default template cache.
DefaultViewStateCacheSize | Gets the size of the default view state cache.
DefaultXslCacheSize | Gets the size of the default XSL cache.
Enabled | Gets a value indicating whether caching is enabled.
FastMediaCacheMapSize | Obsolete. Gets the size of the fast media cache map cache.
HtmlLifetime | Gets the HTML timeout.
HugeCacheSize | Gets the size of a huge cache.
IsUserInRoleCacheSize | Gets the size of the is in role cache.
ItemCachingEnabled | Gets a value indicating whether item caching is enabled.
LargeCacheSize | Gets the size of a large cache.
LoadFactor | Gets a value indicating the default load factor to use for cached values.
MaxLoadFactor | Gets a value indicating the maximum load factor to use for cached values.
MediumCacheSize | Gets the size of a medium cache.
ScavengeInterval | Gets the scavenge interval.
SecurityCacheExpiration | Gets the security cache sliding expiration.
SmallCacheSize | Gets the size of a small cache.
TinyCacheSize | Gets the size of a tiny cache.
UserProfileCacheSize | Gets the size of the user profile cache.

See Also

Settings..::..Caching Class
Sitecore.Configuration Namespace


GetAbsoluteSecurityCacheExpiration Method

[image]

Sitecore 6.4.1 API
Settings..::..Caching..::..GetAbsoluteSecurityCacheExpiration Method
Settings..::..Caching Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static DateTime GetAbsoluteSecurityCacheExpiration()
Visual Basic
Public Shared Function GetAbsoluteSecurityCacheExpiration As DateTime
Visual C++
public:
static DateTime GetAbsoluteSecurityCacheExpiration()

Return Value

The absolute value of security cache expiration.

See Also

Settings..::..Caching Class
Sitecore.Configuration Namespace


Settings.Caching Properties

[image] [image]

Sitecore 6.4.1 API
Settings..::..Caching Properties
Settings..::..Caching Class See Also Send Feedback

The Settings..::..Caching type exposes the following members.

Properties

Name | Description
AccessResultCacheSize | Gets the size of the access result cache.
AverageItemSize | Gets the average size of an item.
BlobIDCacheSize | Gets the size of the cache that stores blob IDs.
CacheViewState | Indicates if ViewState is cached in the GlobalCache in SheerUI.
DefaultClientDataCacheSize | Gets the size of the default client data cache.
DefaultDataCacheSize | Gets the size of the default data cache.
DefaultFilteredItemsCacheSize | Gets the default size of the filtered items cache.
DefaultHtmlCacheSize | Gets the size of the default HTML cache.
DefaultItemCacheSize | Gets the size of the default item cache.
DefaultPathCacheSize | Gets the size of the default path cache.
DefaultPriority | Gets the default priority.
DefaultPropertyCacheSize | Gets the size of the default property cache.
DefaultProxyCacheSize | Gets the size of the default proxy cache.
DefaultRegistryCacheSize | Gets the size of the default registry cache.
DefaultTemplateCacheSize | Gets the size of the default template cache.
DefaultViewStateCacheSize | Gets the size of the default view state cache.
DefaultXslCacheSize | Gets the size of the default XSL cache.
Enabled | Gets a value indicating whether caching is enabled.
FastMediaCacheMapSize | Obsolete. Gets the size of the fast media cache map cache.
HtmlLifetime | Gets the HTML timeout.
HugeCacheSize | Gets the size of a huge cache.
IsUserInRoleCacheSize | Gets the size of the is in role cache.
ItemCachingEnabled | Gets a value indicating whether item caching is enabled.
LargeCacheSize | Gets the size of a large cache.
LoadFactor | Gets a value indicating the default load factor to use for cached values.
MaxLoadFactor | Gets a value indicating the maximum load factor to use for cached values.
MediumCacheSize | Gets the size of a medium cache.
ScavengeInterval | Gets the scavenge interval.
SecurityCacheExpiration | Gets the security cache sliding expiration.
SmallCacheSize | Gets the size of a small cache.
TinyCacheSize | Gets the size of a tiny cache.
UserProfileCacheSize | Gets the size of the user profile cache.

See Also

Settings..::..Caching Class
Sitecore.Configuration Namespace


AverageItemSize Property

[image]

Sitecore 6.4.1 API
Settings..::..Caching..::..AverageItemSize Property
Settings..::..Caching Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int AverageItemSize { get; }
Visual Basic
Public Shared ReadOnly Property AverageItemSize As Integer
    Get
Visual C++
public:
static property int AverageItemSize {
    int get ();
}

Field Value

The average size of the item.

See Also

Settings..::..Caching Class
Sitecore.Configuration Namespace


BlobIDCacheSize Property

[image]

Sitecore 6.4.1 API
Settings..::..Caching..::..BlobIDCacheSize Property
Settings..::..Caching Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long BlobIDCacheSize { get; }
Visual Basic
Public Shared ReadOnly Property BlobIDCacheSize As Long
    Get
Visual C++
public:
static property long long BlobIDCacheSize {
    long long get ();
}

Field Value

The size of the cache that stores blob IDs.

See Also

Settings..::..Caching Class
Sitecore.Configuration Namespace


CacheViewState Property

[image]

Sitecore 6.4.1 API
Settings..::..Caching..::..CacheViewState Property
Settings..::..Caching Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool CacheViewState { get; }
Visual Basic
Public Shared ReadOnly Property CacheViewState As Boolean
    Get
Visual C++
public:
static property bool CacheViewState {
    bool get ();
}

Field Value

true if ViewState is cached in the GlobalCache in SheerUI; otherwise, false.

See Also

Settings..::..Caching Class
Sitecore.Configuration Namespace


DefaultDataCacheSize Property

[image]

Sitecore 6.4.1 API
Settings..::..Caching..::..DefaultDataCacheSize Property
Settings..::..Caching Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long DefaultDataCacheSize { get; }
Visual Basic
Public Shared ReadOnly Property DefaultDataCacheSize As Long
    Get
Visual C++
public:
static property long long DefaultDataCacheSize {
    long long get ();
}

Field Value

The size of the default data cache.

See Also

Settings..::..Caching Class
Sitecore.Configuration Namespace


DefaultFilteredItemsCacheSize Property

[image]

Sitecore 6.4.1 API
Settings..::..Caching..::..DefaultFilteredItemsCacheSize Property
Settings..::..Caching Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long DefaultFilteredItemsCacheSize { get; }
Visual Basic
Public Shared ReadOnly Property DefaultFilteredItemsCacheSize As Long
    Get
Visual C++
public:
static property long long DefaultFilteredItemsCacheSize {
    long long get ();
}

Field Value

The size of the filtered items cache. Default value: 0 (cache disabled)

See Also

Settings..::..Caching Class
Sitecore.Configuration Namespace


DefaultHtmlCacheSize Property

[image]

Sitecore 6.4.1 API
Settings..::..Caching..::..DefaultHtmlCacheSize Property
Settings..::..Caching Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long DefaultHtmlCacheSize { get; }
Visual Basic
Public Shared ReadOnly Property DefaultHtmlCacheSize As Long
    Get
Visual C++
public:
static property long long DefaultHtmlCacheSize {
    long long get ();
}

Field Value

The size of the default HTML cache.

See Also

Settings..::..Caching Class
Sitecore.Configuration Namespace


DefaultItemCacheSize Property

[image]

Sitecore 6.4.1 API
Settings..::..Caching..::..DefaultItemCacheSize Property
Settings..::..Caching Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long DefaultItemCacheSize { get; }
Visual Basic
Public Shared ReadOnly Property DefaultItemCacheSize As Long
    Get
Visual C++
public:
static property long long DefaultItemCacheSize {
    long long get ();
}

Field Value

The size of the default item cache.

See Also

Settings..::..Caching Class
Sitecore.Configuration Namespace


DefaultPathCacheSize Property

[image]

Sitecore 6.4.1 API
Settings..::..Caching..::..DefaultPathCacheSize Property
Settings..::..Caching Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long DefaultPathCacheSize { get; }
Visual Basic
Public Shared ReadOnly Property DefaultPathCacheSize As Long
    Get
Visual C++
public:
static property long long DefaultPathCacheSize {
    long long get ();
}

Field Value

The size of the default path cache.

See Also

Settings..::..Caching Class
Sitecore.Configuration Namespace


DefaultPriority Property

[image]

Sitecore 6.4.1 API
Settings..::..Caching..::..DefaultPriority Property
Settings..::..Caching Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static CachePriority DefaultPriority { get; }
Visual Basic
Public Shared ReadOnly Property DefaultPriority As CachePriority
    Get
Visual C++
public:
static property CachePriority DefaultPriority {
    CachePriority get ();
}

Field Value

The default priority.

See Also

Settings..::..Caching Class
Sitecore.Configuration Namespace


DefaultPropertyCacheSize Property

[image]

Sitecore 6.4.1 API
Settings..::..Caching..::..DefaultPropertyCacheSize Property
Settings..::..Caching Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long DefaultPropertyCacheSize { get; }
Visual Basic
Public Shared ReadOnly Property DefaultPropertyCacheSize As Long
    Get
Visual C++
public:
static property long long DefaultPropertyCacheSize {
    long long get ();
}

Field Value

The size of the default property cache.

See Also

Settings..::..Caching Class
Sitecore.Configuration Namespace


DefaultProxyCacheSize Property

[image]

Sitecore 6.4.1 API
Settings..::..Caching..::..DefaultProxyCacheSize Property
Settings..::..Caching Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long DefaultProxyCacheSize { get; }
Visual Basic
Public Shared ReadOnly Property DefaultProxyCacheSize As Long
    Get
Visual C++
public:
static property long long DefaultProxyCacheSize {
    long long get ();
}

Field Value

The size of the default proxy cache.

See Also

Settings..::..Caching Class
Sitecore.Configuration Namespace


DefaultRegistryCacheSize Property

[image]

Sitecore 6.4.1 API
Settings..::..Caching..::..DefaultRegistryCacheSize Property
Settings..::..Caching Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long DefaultRegistryCacheSize { get; }
Visual Basic
Public Shared ReadOnly Property DefaultRegistryCacheSize As Long
    Get
Visual C++
public:
static property long long DefaultRegistryCacheSize {
    long long get ();
}

Field Value

The size of the default registry cache.

See Also

Settings..::..Caching Class
Sitecore.Configuration Namespace


DefaultTemplateCacheSize Property

[image]

Sitecore 6.4.1 API
Settings..::..Caching..::..DefaultTemplateCacheSize Property
Settings..::..Caching Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long DefaultTemplateCacheSize { get; }
Visual Basic
Public Shared ReadOnly Property DefaultTemplateCacheSize As Long
    Get
Visual C++
public:
static property long long DefaultTemplateCacheSize {
    long long get ();
}

Field Value

The size of the default template cache.

See Also

Settings..::..Caching Class
Sitecore.Configuration Namespace


DefaultViewStateCacheSize Property

[image]

Sitecore 6.4.1 API
Settings..::..Caching..::..DefaultViewStateCacheSize Property
Settings..::..Caching Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long DefaultViewStateCacheSize { get; }
Visual Basic
Public Shared ReadOnly Property DefaultViewStateCacheSize As Long
    Get
Visual C++
public:
static property long long DefaultViewStateCacheSize {
    long long get ();
}

Field Value

The size of the default view state cache.

See Also

Settings..::..Caching Class
Sitecore.Configuration Namespace


DefaultXslCacheSize Property

[image]

Sitecore 6.4.1 API
Settings..::..Caching..::..DefaultXslCacheSize Property
Settings..::..Caching Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long DefaultXslCacheSize { get; }
Visual Basic
Public Shared ReadOnly Property DefaultXslCacheSize As Long
    Get
Visual C++
public:
static property long long DefaultXslCacheSize {
    long long get ();
}

Field Value

The size of the default XSL cache.

See Also

Settings..::..Caching Class
Sitecore.Configuration Namespace


Enabled Property

[image]

Sitecore 6.4.1 API
Settings..::..Caching..::..Enabled Property
Settings..::..Caching Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool Enabled { get; }
Visual Basic
Public Shared ReadOnly Property Enabled As Boolean
    Get
Visual C++
public:
static property bool Enabled {
    bool get ();
}

Field Value

true if enabled; otherwise, false.

See Also

Settings..::..Caching Class
Sitecore.Configuration Namespace


FastMediaCacheMapSize Property

[image]

Sitecore 6.4.1 API
Settings..::..Caching..::..FastMediaCacheMapSize Property
Settings..::..Caching Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public static long FastMediaCacheMapSize { get; }
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Shared ReadOnly Property FastMediaCacheMapSize As Long
    Get
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public:
static property long long FastMediaCacheMapSize {
    long long get ();
}

Field Value

The size of the fast media cache map cache.

See Also

Settings..::..Caching Class
Sitecore.Configuration Namespace


HtmlLifetime Property

[image]

Sitecore 6.4.1 API
Settings..::..Caching..::..HtmlLifetime Property
Settings..::..Caching Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TimeSpan HtmlLifetime { get; }
Visual Basic
Public Shared ReadOnly Property HtmlLifetime As TimeSpan
    Get
Visual C++
public:
static property TimeSpan HtmlLifetime {
    TimeSpan get ();
}

Field Value

The HTML timeout.

See Also

Settings..::..Caching Class
Sitecore.Configuration Namespace


HugeCacheSize Property

[image]

Sitecore 6.4.1 API
Settings..::..Caching..::..HugeCacheSize Property
Settings..::..Caching Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long HugeCacheSize { get; }
Visual Basic
Public Shared ReadOnly Property HugeCacheSize As Long
    Get
Visual C++
public:
static property long long HugeCacheSize {
    long long get ();
}

Field Value

The size of a huge cache.

See Also

Settings..::..Caching Class
Sitecore.Configuration Namespace


IsUserInRoleCacheSize Property

[image]

Sitecore 6.4.1 API
Settings..::..Caching..::..IsUserInRoleCacheSize Property
Settings..::..Caching Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long IsUserInRoleCacheSize { get; }
Visual Basic
Public Shared ReadOnly Property IsUserInRoleCacheSize As Long
    Get
Visual C++
public:
static property long long IsUserInRoleCacheSize {
    long long get ();
}

Field Value

The size of the is in role cache.

See Also

Settings..::..Caching Class
Sitecore.Configuration Namespace


ItemCachingEnabled Property

[image]

Sitecore 6.4.1 API
Settings..::..Caching..::..ItemCachingEnabled Property
Settings..::..Caching Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool ItemCachingEnabled { get; }
Visual Basic
Public Shared ReadOnly Property ItemCachingEnabled As Boolean
    Get
Visual C++
public:
static property bool ItemCachingEnabled {
    bool get ();
}

Field Value

true if enabled; otherwise, false.

See Also

Settings..::..Caching Class
Sitecore.Configuration Namespace


LargeCacheSize Property

[image]

Sitecore 6.4.1 API
Settings..::..Caching..::..LargeCacheSize Property
Settings..::..Caching Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long LargeCacheSize { get; }
Visual Basic
Public Shared ReadOnly Property LargeCacheSize As Long
    Get
Visual C++
public:
static property long long LargeCacheSize {
    long long get ();
}

Field Value

The size of a large cache.

See Also

Settings..::..Caching Class
Sitecore.Configuration Namespace


LoadFactor Property

[image]

Sitecore 6.4.1 API
Settings..::..Caching..::..LoadFactor Property
Settings..::..Caching Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static double LoadFactor { get; }
Visual Basic
Public Shared ReadOnly Property LoadFactor As Double
    Get
Visual C++
public:
static property double LoadFactor {
    double get ();
}

Field Value

The meximum load factor.

Remarks

The size of all cached values are multiplied with this value before being added to the cache.

Default value: 1.0.

See Also

Settings..::..Caching Class
Sitecore.Configuration Namespace


MaxLoadFactor Property

[image]

Sitecore 6.4.1 API
Settings..::..Caching..::..MaxLoadFactor Property
Settings..::..Caching Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static double MaxLoadFactor { get; }
Visual Basic
Public Shared ReadOnly Property MaxLoadFactor As Double
    Get
Visual C++
public:
static property double MaxLoadFactor {
    double get ();
}

Field Value

The meximum load factor.

Remarks

The load factor might be increased up to this value during heavy memory load.

Default value: 3.0.

See Also

Settings..::..Caching Class
Sitecore.Configuration Namespace


MediumCacheSize Property

[image]

Sitecore 6.4.1 API
Settings..::..Caching..::..MediumCacheSize Property
Settings..::..Caching Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long MediumCacheSize { get; }
Visual Basic
Public Shared ReadOnly Property MediumCacheSize As Long
    Get
Visual C++
public:
static property long long MediumCacheSize {
    long long get ();
}

Field Value

The size of a medium cache.

See Also

Settings..::..Caching Class
Sitecore.Configuration Namespace


ScavengeInterval Property

[image]

Sitecore 6.4.1 API
Settings..::..Caching..::..ScavengeInterval Property
Settings..::..Caching Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TimeSpan ScavengeInterval { get; }
Visual Basic
Public Shared ReadOnly Property ScavengeInterval As TimeSpan
    Get
Visual C++
public:
static property TimeSpan ScavengeInterval {
    TimeSpan get ();
}

Field Value

The scavenge interval (default: 2 minutes).

See Also

Settings..::..Caching Class
Sitecore.Configuration Namespace


SecurityCacheExpiration Property

[image]

Sitecore 6.4.1 API
Settings..::..Caching..::..SecurityCacheExpiration Property
Settings..::..Caching Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TimeSpan SecurityCacheExpiration { get; }
Visual Basic
Public Shared ReadOnly Property SecurityCacheExpiration As TimeSpan
    Get
Visual C++
public:
static property TimeSpan SecurityCacheExpiration {
    TimeSpan get ();
}

Field Value

The security cache sliding expiration.

See Also

Settings..::..Caching Class
Sitecore.Configuration Namespace


SmallCacheSize Property

[image]

Sitecore 6.4.1 API
Settings..::..Caching..::..SmallCacheSize Property
Settings..::..Caching Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long SmallCacheSize { get; }
Visual Basic
Public Shared ReadOnly Property SmallCacheSize As Long
    Get
Visual C++
public:
static property long long SmallCacheSize {
    long long get ();
}

Field Value

The size of a small cache.

See Also

Settings..::..Caching Class
Sitecore.Configuration Namespace


TinyCacheSize Property

[image]

Sitecore 6.4.1 API
Settings..::..Caching..::..TinyCacheSize Property
Settings..::..Caching Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long TinyCacheSize { get; }
Visual Basic
Public Shared ReadOnly Property TinyCacheSize As Long
    Get
Visual C++
public:
static property long long TinyCacheSize {
    long long get ();
}

Field Value

The size of a tiny cache.

See Also

Settings..::..Caching Class
Sitecore.Configuration Namespace


UserProfileCacheSize Property

[image]

Sitecore 6.4.1 API
Settings..::..Caching..::..UserProfileCacheSize Property
Settings..::..Caching Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long UserProfileCacheSize { get; }
Visual Basic
Public Shared ReadOnly Property UserProfileCacheSize As Long
    Get
Visual C++
public:
static property long long UserProfileCacheSize {
    long long get ();
}

Field Value

The size of the user profile cache.

See Also

Settings..::..Caching Class
Sitecore.Configuration Namespace


Settings.Caching.StandardValues Class

[image]

Sitecore 6.4.1 API
Settings..::..Caching..::..StandardValues Class
Settings..::..Caching Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class StandardValues
Visual Basic
Public Class StandardValues
Visual C++
public ref class StandardValues

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..Caching..::..StandardValues

See Also

Settings..::..Caching..::..StandardValues Members
Sitecore.Configuration Namespace


Settings.Caching.StandardValues Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..Caching..::..StandardValues Members
Settings..::..Caching..::..StandardValues Class Constructors Methods Properties See Also Send Feedback

The caching.

The Settings..::..Caching..::..StandardValues type exposes the following members.

Constructors

 | Name | Description
Public method | Settings..::..Caching..::..StandardValues | Initializes a new instance of the Settings..::..Caching..::..StandardValues class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AverageValueSize | Gets the average size of a standard values.
DefaultCacheSize | Gets the default size of the standard value cache.

See Also

Settings..::..Caching..::..StandardValues Class
Sitecore.Configuration Namespace


Settings.Caching.StandardValues Constructor

[image]

Sitecore 6.4.1 API
Settings..::..Caching..::..StandardValues Constructor
Settings..::..Caching..::..StandardValues Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StandardValues()
Visual Basic
Public Sub New
Visual C++
public:
StandardValues()

See Also

Settings..::..Caching..::..StandardValues Class
Sitecore.Configuration Namespace


Settings.Caching.StandardValues Methods

[image] [image]

Sitecore 6.4.1 API
Settings..::..Caching..::..StandardValues Methods
Settings..::..Caching..::..StandardValues Class See Also Send Feedback

The Settings..::..Caching..::..StandardValues type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Settings..::..Caching..::..StandardValues Class
Sitecore.Configuration Namespace


Settings.Caching.StandardValues Properties

[image] [image]

Sitecore 6.4.1 API
Settings..::..Caching..::..StandardValues Properties
Settings..::..Caching..::..StandardValues Class See Also Send Feedback

The Settings..::..Caching..::..StandardValues type exposes the following members.

Properties

Name | Description
AverageValueSize | Gets the average size of a standard values.
DefaultCacheSize | Gets the default size of the standard value cache.

See Also

Settings..::..Caching..::..StandardValues Class
Sitecore.Configuration Namespace


AverageValueSize Property

[image]

Sitecore 6.4.1 API
Settings..::..Caching..::..StandardValues..::..AverageValueSize Property
Settings..::..Caching..::..StandardValues Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long AverageValueSize { get; }
Visual Basic
Public Shared ReadOnly Property AverageValueSize As Long
    Get
Visual C++
public:
static property long long AverageValueSize {
    long long get ();
}

Field Value

The average size of standard values entries.

Remarks

Default value: 100

See Also

Settings..::..Caching..::..StandardValues Class
Sitecore.Configuration Namespace


DefaultCacheSize Property

[image]

Sitecore 6.4.1 API
Settings..::..Caching..::..StandardValues..::..DefaultCacheSize Property
Settings..::..Caching..::..StandardValues Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long DefaultCacheSize { get; }
Visual Basic
Public Shared ReadOnly Property DefaultCacheSize As Long
    Get
Visual C++
public:
static property long long DefaultCacheSize {
    long long get ();
}

Field Value

The default size of the standard value cache.

Remarks

Default value: 1MB

See Also

Settings..::..Caching..::..StandardValues Class
Sitecore.Configuration Namespace


Settings.ClientFeeds Class

[image]

Sitecore 6.4.1 API
Settings..::..ClientFeeds Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class ClientFeeds
Visual Basic
Public NotInheritable Class ClientFeeds
Visual C++
public ref class ClientFeeds abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..ClientFeeds

See Also

Settings..::..ClientFeeds Members
Sitecore.Configuration Namespace


Settings.ClientFeeds Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..ClientFeeds Members
Settings..::..ClientFeeds Class Properties See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..ClientFeeds type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating whether Client Feeds are enabled.
ItemExpiration | Items that are older than the speficied time interval (in days) will not be included in the feed.
MaximumItemsInFeed | Gets the maximum number of items to include in the feed.

See Also

Settings..::..ClientFeeds Class
Sitecore.Configuration Namespace


Settings.ClientFeeds Properties

[image] [image]

Sitecore 6.4.1 API
Settings..::..ClientFeeds Properties
Settings..::..ClientFeeds Class See Also Send Feedback

The Settings..::..ClientFeeds type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating whether Client Feeds are enabled.
ItemExpiration | Items that are older than the speficied time interval (in days) will not be included in the feed.
MaximumItemsInFeed | Gets the maximum number of items to include in the feed.

See Also

Settings..::..ClientFeeds Class
Sitecore.Configuration Namespace


Enabled Property

[image]

Sitecore 6.4.1 API
Settings..::..ClientFeeds..::..Enabled Property
Settings..::..ClientFeeds Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool Enabled { get; }
Visual Basic
Public Shared ReadOnly Property Enabled As Boolean
    Get
Visual C++
public:
static property bool Enabled {
    bool get ();
}

Field Value

true if enabled; otherwise, false.

See Also

Settings..::..ClientFeeds Class
Sitecore.Configuration Namespace


ItemExpiration Property

[image]

Sitecore 6.4.1 API
Settings..::..ClientFeeds..::..ItemExpiration Property
Settings..::..ClientFeeds Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Nullable<TimeSpan> ItemExpiration { get; }
Visual Basic
Public Shared ReadOnly Property ItemExpiration As Nullable(Of TimeSpan)
    Get
Visual C++
public:
static property Nullable<TimeSpan> ItemExpiration {
    Nullable<TimeSpan> get ();
}

Field Value

The item expiration.

See Also

Settings..::..ClientFeeds Class
Sitecore.Configuration Namespace


MaximumItemsInFeed Property

[image]

Sitecore 6.4.1 API
Settings..::..ClientFeeds..::..MaximumItemsInFeed Property
Settings..::..ClientFeeds Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int MaximumItemsInFeed { get; }
Visual Basic
Public Shared ReadOnly Property MaximumItemsInFeed As Integer
    Get
Visual C++
public:
static property int MaximumItemsInFeed {
    int get ();
}

Field Value

The maximum items in feed.

See Also

Settings..::..ClientFeeds Class
Sitecore.Configuration Namespace


Settings.ContentEditor Class

[image]

Sitecore 6.4.1 API
Settings..::..ContentEditor Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class ContentEditor
Visual Basic
Public NotInheritable Class ContentEditor
Visual C++
public ref class ContentEditor abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..ContentEditor

See Also

Settings..::..ContentEditor Members
Sitecore.Configuration Namespace


Settings.ContentEditor Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..ContentEditor Members
Settings..::..ContentEditor Class Properties See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..ContentEditor type exposes the following members.

Properties

Name | Description
CheckHasChildrenOnTreeNodes | Gets a value indicating whether the Settings..::..ContentEditor uses HasChildren when drawing tree nodes.
CheckSecurityOnTreeNodes | Gets a value indicating whether the Settings..::..ContentEditor checks the security on tree nodes.
ClassicFrameEventPropagation | Gets a value indicating whether the Content Editor uses classic frame event propagation.
DefaultSkin | Gets the default skin.
RenderCollapsedSections | Gets a value indicating whether the content editor renders collapsed sections.
ShowGutter | Gets a value indicating whether the Settings..::..ContentEditor shows the gutter.
ShowSearchPanel | Gets a value indicating whether the Settings..::..ContentEditor shows the search panel.
ShowValidatorBar | Gets a value indicating whether the Settings..::..ContentEditor shows the validator bar.
UseSmartTags | Gets a value indicating whether the Settings..::..ContentEditor uses the smart tags.

See Also

Settings..::..ContentEditor Class
Sitecore.Configuration Namespace


Settings.ContentEditor Properties

[image] [image]

Sitecore 6.4.1 API
Settings..::..ContentEditor Properties
Settings..::..ContentEditor Class See Also Send Feedback

The Settings..::..ContentEditor type exposes the following members.

Properties

Name | Description
CheckHasChildrenOnTreeNodes | Gets a value indicating whether the Settings..::..ContentEditor uses HasChildren when drawing tree nodes.
CheckSecurityOnTreeNodes | Gets a value indicating whether the Settings..::..ContentEditor checks the security on tree nodes.
ClassicFrameEventPropagation | Gets a value indicating whether the Content Editor uses classic frame event propagation.
DefaultSkin | Gets the default skin.
RenderCollapsedSections | Gets a value indicating whether the content editor renders collapsed sections.
ShowGutter | Gets a value indicating whether the Settings..::..ContentEditor shows the gutter.
ShowSearchPanel | Gets a value indicating whether the Settings..::..ContentEditor shows the search panel.
ShowValidatorBar | Gets a value indicating whether the Settings..::..ContentEditor shows the validator bar.
UseSmartTags | Gets a value indicating whether the Settings..::..ContentEditor uses the smart tags.

See Also

Settings..::..ContentEditor Class
Sitecore.Configuration Namespace


CheckHasChildrenOnTreeNodes Property

[image]

Sitecore 6.4.1 API
Settings..::..ContentEditor..::..CheckHasChildrenOnTreeNodes Property
Settings..::..ContentEditor Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool CheckHasChildrenOnTreeNodes { get; }
Visual Basic
Public Shared ReadOnly Property CheckHasChildrenOnTreeNodes As Boolean
    Get
Visual C++
public:
static property bool CheckHasChildrenOnTreeNodes {
    bool get ();
}

Field Value

true if the Settings..::..ContentEditor uses HasChildren when drawing tree nodes; otherwise, false.

See Also

Settings..::..ContentEditor Class
Sitecore.Configuration Namespace


CheckSecurityOnTreeNodes Property

[image]

Sitecore 6.4.1 API
Settings..::..ContentEditor..::..CheckSecurityOnTreeNodes Property
Settings..::..ContentEditor Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool CheckSecurityOnTreeNodes { get; }
Visual Basic
Public Shared ReadOnly Property CheckSecurityOnTreeNodes As Boolean
    Get
Visual C++
public:
static property bool CheckSecurityOnTreeNodes {
    bool get ();
}

Field Value

true if the Settings..::..ContentEditor checks the security on tree nodes; otherwise, false.

See Also

Settings..::..ContentEditor Class
Sitecore.Configuration Namespace


ClassicFrameEventPropagation Property

[image]

Sitecore 6.4.1 API
Settings..::..ContentEditor..::..ClassicFrameEventPropagation Property
Settings..::..ContentEditor Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool ClassicFrameEventPropagation { get; }
Visual Basic
Public Shared ReadOnly Property ClassicFrameEventPropagation As Boolean
    Get
Visual C++
public:
static property bool ClassicFrameEventPropagation {
    bool get ();
}

Field Value

true if the Content Editor uses classic frame event propagation; otherwise, false.

Remarks

In classic propagation all item events are sent to all frames in the content editor. This may hurt server and client performance. If classic mode is not used, only events relating to items that are either selected in the content editor or subitms thereof, are propagated.

See Also

Settings..::..ContentEditor Class
Sitecore.Configuration Namespace


DefaultSkin Property

[image]

Sitecore 6.4.1 API
Settings..::..ContentEditor..::..DefaultSkin Property
Settings..::..ContentEditor Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string DefaultSkin { get; }
Visual Basic
Public Shared ReadOnly Property DefaultSkin As String
    Get
Visual C++
public:
static property String^ DefaultSkin {
    String^ get ();
}

Field Value

The default skin.

See Also

Settings..::..ContentEditor Class
Sitecore.Configuration Namespace


RenderCollapsedSections Property

[image]

Sitecore 6.4.1 API
Settings..::..ContentEditor..::..RenderCollapsedSections Property
Settings..::..ContentEditor Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool RenderCollapsedSections { get; }
Visual Basic
Public Shared ReadOnly Property RenderCollapsedSections As Boolean
    Get
Visual C++
public:
static property bool RenderCollapsedSections {
    bool get ();
}

Field Value

true if the content editor renders collapsed sections; otherwise, false.

See Also

Settings..::..ContentEditor Class
Sitecore.Configuration Namespace


ShowGutter Property

[image]

Sitecore 6.4.1 API
Settings..::..ContentEditor..::..ShowGutter Property
Settings..::..ContentEditor Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool ShowGutter { get; }
Visual Basic
Public Shared ReadOnly Property ShowGutter As Boolean
    Get
Visual C++
public:
static property bool ShowGutter {
    bool get ();
}

Field Value

true if the Settings..::..ContentEditor shows the gutter; otherwise, false.

See Also

Settings..::..ContentEditor Class
Sitecore.Configuration Namespace


ShowSearchPanel Property

[image]

Sitecore 6.4.1 API
Settings..::..ContentEditor..::..ShowSearchPanel Property
Settings..::..ContentEditor Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool ShowSearchPanel { get; }
Visual Basic
Public Shared ReadOnly Property ShowSearchPanel As Boolean
    Get
Visual C++
public:
static property bool ShowSearchPanel {
    bool get ();
}

Field Value

true if the Settings..::..ContentEditor shows the search panel; otherwise, false.

See Also

Settings..::..ContentEditor Class
Sitecore.Configuration Namespace


ShowValidatorBar Property

[image]

Sitecore 6.4.1 API
Settings..::..ContentEditor..::..ShowValidatorBar Property
Settings..::..ContentEditor Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool ShowValidatorBar { get; }
Visual Basic
Public Shared ReadOnly Property ShowValidatorBar As Boolean
    Get
Visual C++
public:
static property bool ShowValidatorBar {
    bool get ();
}

Field Value

true if the Settings..::..ContentEditor shows the validator bar; otherwise, false.

See Also

Settings..::..ContentEditor Class
Sitecore.Configuration Namespace


UseSmartTags Property

[image]

Sitecore 6.4.1 API
Settings..::..ContentEditor..::..UseSmartTags Property
Settings..::..ContentEditor Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool UseSmartTags { get; }
Visual Basic
Public Shared ReadOnly Property UseSmartTags As Boolean
    Get
Visual C++
public:
static property bool UseSmartTags {
    bool get ();
}

Field Value

true if the Settings..::..ContentEditor uses the smart tags; otherwise, false.

See Also

Settings..::..ContentEditor Class
Sitecore.Configuration Namespace


Settings.Counters Class

[image]

Sitecore 6.4.1 API
Settings..::..Counters Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Counters
Visual Basic
Public NotInheritable Class Counters
Visual C++
public ref class Counters abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..Counters

See Also

Settings..::..Counters Members
Sitecore.Configuration Namespace


Settings.Counters Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..Counters Members
Settings..::..Counters Class Properties See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..Counters type exposes the following members.

Properties

Name | Description
Enabled | Indicates if performance counters are enabled.
InstanceName | Indicates if performance counters are enabled.
ResetOnStartup | Indicates if performance counters will be reset on Sitecore startup.

See Also

Settings..::..Counters Class
Sitecore.Configuration Namespace


Enabled Property

[image]

Sitecore 6.4.1 API
Settings..::..Counters..::..Enabled Property
Settings..::..Counters Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool Enabled { get; }
Visual Basic
Public Shared ReadOnly Property Enabled As Boolean
    Get
Visual C++
public:
static property bool Enabled {
    bool get ();
}

Field Value

true if enabled; otherwise, false.

See Also

Settings..::..Counters Class
Sitecore.Configuration Namespace


InstanceName Property

[image]

Sitecore 6.4.1 API
Settings..::..Counters..::..InstanceName Property
Settings..::..Counters Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string InstanceName { get; }
Visual Basic
Public Shared ReadOnly Property InstanceName As String
    Get
Visual C++
public:
static property String^ InstanceName {
    String^ get ();
}

Field Value

The name of the instance.

See Also

Settings..::..Counters Class
Sitecore.Configuration Namespace


ResetOnStartup Property

[image]

Sitecore 6.4.1 API
Settings..::..Counters..::..ResetOnStartup Property
Settings..::..Counters Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool ResetOnStartup { get; }
Visual Basic
Public Shared ReadOnly Property ResetOnStartup As Boolean
    Get
Visual C++
public:
static property bool ResetOnStartup {
    bool get ();
}

Field Value

true if performance counters will be reset on Sitecore startup; otherwise, false.

See Also

Settings..::..Counters Class
Sitecore.Configuration Namespace


Settings.EventQueue Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..EventQueue Members
Settings..::..EventQueue Class Properties See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..EventQueue type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating whether this Settings..::..EventQueue is enabled.
PersistStampInterval | Maximum interval between saving the event queue's last processed event stamp.
PersistStampMaxAge | Max age of the events fetched

See Also

Settings..::..EventQueue Class
Sitecore.Configuration Namespace


Settings.EventQueue Properties

[image] [image]

Sitecore 6.4.1 API
Settings..::..EventQueue Properties
Settings..::..EventQueue Class See Also Send Feedback

The Settings..::..EventQueue type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating whether this Settings..::..EventQueue is enabled.
PersistStampInterval | Maximum interval between saving the event queue's last processed event stamp.
PersistStampMaxAge | Max age of the events fetched

See Also

Settings..::..EventQueue Class
Sitecore.Configuration Namespace


PersistStampInterval Property

[image]

Sitecore 6.4.1 API
Settings..::..EventQueue..::..PersistStampInterval Property
Settings..::..EventQueue Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TimeSpan PersistStampInterval { get; }
Visual Basic
Public Shared ReadOnly Property PersistStampInterval As TimeSpan
    Get
Visual C++
public:
static property TimeSpan PersistStampInterval {
    TimeSpan get ();
}

Field Value

The persist stamp interval.

See Also

Settings..::..EventQueue Class
Sitecore.Configuration Namespace


PersistStampMaxAge Property

[image]

Sitecore 6.4.1 API
Settings..::..EventQueue..::..PersistStampMaxAge Property
Settings..::..EventQueue Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TimeSpan PersistStampMaxAge { get; }
Visual Basic
Public Shared ReadOnly Property PersistStampMaxAge As TimeSpan
    Get
Visual C++
public:
static property TimeSpan PersistStampMaxAge {
    TimeSpan get ();
}

Field Value

The persist stamp max age.

See Also

Settings..::..EventQueue Class
Sitecore.Configuration Namespace


Settings.Feeds Class

[image]

Sitecore 6.4.1 API
Settings..::..Feeds Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Feeds
Visual Basic
Public NotInheritable Class Feeds
Visual C++
public ref class Feeds abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..Feeds

See Also

Settings..::..Feeds Members
Sitecore.Configuration Namespace


Settings.Feeds Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..Feeds Members
Settings..::..Feeds Class Properties See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..Feeds type exposes the following members.

Properties

Name | Description
ItemExpiration | Items that are older than the speficied time interval (in days) will not be included in the feed.
MaximumItemsInFeed | Gets the maximum number of items to include in the feed.

See Also

Settings..::..Feeds Class
Sitecore.Configuration Namespace


Settings.Feeds Properties

[image] [image]

Sitecore 6.4.1 API
Settings..::..Feeds Properties
Settings..::..Feeds Class See Also Send Feedback

The Settings..::..Feeds type exposes the following members.

Properties

Name | Description
ItemExpiration | Items that are older than the speficied time interval (in days) will not be included in the feed.
MaximumItemsInFeed | Gets the maximum number of items to include in the feed.

See Also

Settings..::..Feeds Class
Sitecore.Configuration Namespace


ItemExpiration Property

[image]

Sitecore 6.4.1 API
Settings..::..Feeds..::..ItemExpiration Property
Settings..::..Feeds Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Nullable<TimeSpan> ItemExpiration { get; }
Visual Basic
Public Shared ReadOnly Property ItemExpiration As Nullable(Of TimeSpan)
    Get
Visual C++
public:
static property Nullable<TimeSpan> ItemExpiration {
    Nullable<TimeSpan> get ();
}

Field Value

The item expiration.

See Also

Settings..::..Feeds Class
Sitecore.Configuration Namespace


MaximumItemsInFeed Property

[image]

Sitecore 6.4.1 API
Settings..::..Feeds..::..MaximumItemsInFeed Property
Settings..::..Feeds Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int MaximumItemsInFeed { get; }
Visual Basic
Public Shared ReadOnly Property MaximumItemsInFeed As Integer
    Get
Visual C++
public:
static property int MaximumItemsInFeed {
    int get ();
}

Field Value

The maximum items in feed.

See Also

Settings..::..Feeds Class
Sitecore.Configuration Namespace


Settings.HtmlEditor Class

[image]

Sitecore 6.4.1 API
Settings..::..HtmlEditor Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class HtmlEditor
Visual Basic
Public NotInheritable Class HtmlEditor
Visual C++
public ref class HtmlEditor abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..HtmlEditor

See Also

Settings..::..HtmlEditor Members
Sitecore.Configuration Namespace


Settings.HtmlEditor Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..HtmlEditor Members
Settings..::..HtmlEditor Class Properties See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..HtmlEditor type exposes the following members.

Properties

Name | Description
DefaultConfigurationType | Specifies the type responsible for setting up the rich text editor. Can be overriden at profile level. Must inherit from Sitecore.Shell.Controls.RichTextEditor.EditorConfiguration,Sitecore.Client.
DefaultProfile | Gets the default profile.
LineBreak | Gets the line break.
SupportWebControls | Gets a value indicating whether the Settings..::..HtmlEditor supports the web controls.
ValidatorServiceUrl | Gets the validator service URL.

See Also

Settings..::..HtmlEditor Class
Sitecore.Configuration Namespace


Settings.HtmlEditor Properties

[image] [image]

Sitecore 6.4.1 API
Settings..::..HtmlEditor Properties
Settings..::..HtmlEditor Class See Also Send Feedback

The Settings..::..HtmlEditor type exposes the following members.

Properties

Name | Description
DefaultConfigurationType | Specifies the type responsible for setting up the rich text editor. Can be overriden at profile level. Must inherit from Sitecore.Shell.Controls.RichTextEditor.EditorConfiguration,Sitecore.Client.
DefaultProfile | Gets the default profile.
LineBreak | Gets the line break.
SupportWebControls | Gets a value indicating whether the Settings..::..HtmlEditor supports the web controls.
ValidatorServiceUrl | Gets the validator service URL.

See Also

Settings..::..HtmlEditor Class
Sitecore.Configuration Namespace


DefaultConfigurationType Property

[image]

Sitecore 6.4.1 API
Settings..::..HtmlEditor..::..DefaultConfigurationType Property
Settings..::..HtmlEditor Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string DefaultConfigurationType { get; }
Visual Basic
Public Shared ReadOnly Property DefaultConfigurationType As String
    Get
Visual C++
public:
static property String^ DefaultConfigurationType {
    String^ get ();
}

Field Value

The default type of the configuration.

See Also

Settings..::..HtmlEditor Class
Sitecore.Configuration Namespace


DefaultProfile Property

[image]

Sitecore 6.4.1 API
Settings..::..HtmlEditor..::..DefaultProfile Property
Settings..::..HtmlEditor Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string DefaultProfile { get; }
Visual Basic
Public Shared ReadOnly Property DefaultProfile As String
    Get
Visual C++
public:
static property String^ DefaultProfile {
    String^ get ();
}

Field Value

The default profile.

See Also

Settings..::..HtmlEditor Class
Sitecore.Configuration Namespace


LineBreak Property

[image]

Sitecore 6.4.1 API
Settings..::..HtmlEditor..::..LineBreak Property
Settings..::..HtmlEditor Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string LineBreak { get; }
Visual Basic
Public Shared ReadOnly Property LineBreak As String
    Get
Visual C++
public:
static property String^ LineBreak {
    String^ get ();
}

Field Value

The line break.

See Also

Settings..::..HtmlEditor Class
Sitecore.Configuration Namespace


SupportWebControls Property

[image]

Sitecore 6.4.1 API
Settings..::..HtmlEditor..::..SupportWebControls Property
Settings..::..HtmlEditor Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool SupportWebControls { get; }
Visual Basic
Public Shared ReadOnly Property SupportWebControls As Boolean
    Get
Visual C++
public:
static property bool SupportWebControls {
    bool get ();
}

Field Value

true if the Settings..::..HtmlEditor supports the web controls; otherwise, false.

See Also

Settings..::..HtmlEditor Class
Sitecore.Configuration Namespace


ValidatorServiceUrl Property

[image]

Sitecore 6.4.1 API
Settings..::..HtmlEditor..::..ValidatorServiceUrl Property
Settings..::..HtmlEditor Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ValidatorServiceUrl { get; }
Visual Basic
Public Shared ReadOnly Property ValidatorServiceUrl As String
    Get
Visual C++
public:
static property String^ ValidatorServiceUrl {
    String^ get ();
}

Field Value

The validator service URL.

See Also

Settings..::..HtmlEditor Class
Sitecore.Configuration Namespace


Settings.Icons Class

[image]

Sitecore 6.4.1 API
Settings..::..Icons Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Icons
Visual Basic
Public NotInheritable Class Icons
Visual C++
public ref class Icons abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..Icons

See Also

Settings..::..Icons Members
Sitecore.Configuration Namespace


Settings.Icons Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..Icons Members
Settings..::..Icons Class Properties See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..Icons type exposes the following members.

Properties

Name | Description
CacheFolder | Gets the cache folder.
UseZippedIcons | Gets a value indicating whether [use zipped icons].

See Also

Settings..::..Icons Class
Sitecore.Configuration Namespace


Settings.Icons Properties

[image] [image]

Sitecore 6.4.1 API
Settings..::..Icons Properties
Settings..::..Icons Class See Also Send Feedback

The Settings..::..Icons type exposes the following members.

Properties

Name | Description
CacheFolder | Gets the cache folder.
UseZippedIcons | Gets a value indicating whether [use zipped icons].

See Also

Settings..::..Icons Class
Sitecore.Configuration Namespace


CacheFolder Property

[image]

Sitecore 6.4.1 API
Settings..::..Icons..::..CacheFolder Property
Settings..::..Icons Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string CacheFolder { get; }
Visual Basic
Public Shared ReadOnly Property CacheFolder As String
    Get
Visual C++
public:
static property String^ CacheFolder {
    String^ get ();
}

Field Value

The cache folder.

See Also

Settings..::..Icons Class
Sitecore.Configuration Namespace


UseZippedIcons Property

[image]

Sitecore 6.4.1 API
Settings..::..Icons..::..UseZippedIcons Property
Settings..::..Icons Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool UseZippedIcons { get; }
Visual Basic
Public Shared ReadOnly Property UseZippedIcons As Boolean
    Get
Visual C++
public:
static property bool UseZippedIcons {
    bool get ();
}

Field Value

true if [use zipped icons]; otherwise, false.

See Also

Settings..::..Icons Class
Sitecore.Configuration Namespace


Settings.Indexing Class

[image]

Sitecore 6.4.1 API
Settings..::..Indexing Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Indexing
Visual Basic
Public NotInheritable Class Indexing
Visual C++
public ref class Indexing abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..Indexing

See Also

Settings..::..Indexing Members
Sitecore.Configuration Namespace


Settings.Indexing Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..Indexing Members
Settings..::..Indexing Class Properties See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..Indexing type exposes the following members.

Properties

Name | Description
Enabled | This property can be used to disable/enable indexing during the run time.
ServerSpecificProperties | Gets a value indicating whether to store properties specific to each server name.
UpdateInterval | Gets the interval between the IndexingManager checking its queue for pending actions.
UpdateJobThrottle | Gets the minimum time to wait between individual index update jobs.

See Also

Settings..::..Indexing Class
Sitecore.Configuration Namespace


Settings.Indexing Properties

[image] [image]

Sitecore 6.4.1 API
Settings..::..Indexing Properties
Settings..::..Indexing Class See Also Send Feedback

The Settings..::..Indexing type exposes the following members.

Properties

Name | Description
Enabled | This property can be used to disable/enable indexing during the run time.
ServerSpecificProperties | Gets a value indicating whether to store properties specific to each server name.
UpdateInterval | Gets the interval between the IndexingManager checking its queue for pending actions.
UpdateJobThrottle | Gets the minimum time to wait between individual index update jobs.

See Also

Settings..::..Indexing Class
Sitecore.Configuration Namespace


Enabled Property

[image]

Sitecore 6.4.1 API
Settings..::..Indexing..::..Enabled Property
Settings..::..Indexing Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool Enabled { get; set; }
Visual Basic
Public Shared Property Enabled As Boolean
    Get
    Set
Visual C++
public:
static property bool Enabled {
    bool get ();
    void set (bool value);
}

Field Value

true if enabled; otherwise, false.

See Also

Settings..::..Indexing Class
Sitecore.Configuration Namespace


ServerSpecificProperties Property

[image]

Sitecore 6.4.1 API
Settings..::..Indexing..::..ServerSpecificProperties Property
Settings..::..Indexing Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool ServerSpecificProperties { get; }
Visual Basic
Public Shared ReadOnly Property ServerSpecificProperties As Boolean
    Get
Visual C++
public:
static property bool ServerSpecificProperties {
    bool get ();
}

Field Value

true if server specific properties; otherwise, false.

See Also

Settings..::..Indexing Class
Sitecore.Configuration Namespace


UpdateInterval Property

[image]

Sitecore 6.4.1 API
Settings..::..Indexing..::..UpdateInterval Property
Settings..::..Indexing Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TimeSpan UpdateInterval { get; }
Visual Basic
Public Shared ReadOnly Property UpdateInterval As TimeSpan
    Get
Visual C++
public:
static property TimeSpan UpdateInterval {
    TimeSpan get ();
}

Field Value

Default value: "00:05:00" (5 minutes)

See Also

Settings..::..Indexing Class
Sitecore.Configuration Namespace


UpdateJobThrottle Property

[image]

Sitecore 6.4.1 API
Settings..::..Indexing..::..UpdateJobThrottle Property
Settings..::..Indexing Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TimeSpan UpdateJobThrottle { get; }
Visual Basic
Public Shared ReadOnly Property UpdateJobThrottle As TimeSpan
    Get
Visual C++
public:
static property TimeSpan UpdateJobThrottle {
    TimeSpan get ();
}

Field Value

Default value: "00:00:01" (1 second)

See Also

Settings..::..Indexing Class
Sitecore.Configuration Namespace


Settings.Install Class

[image]

Sitecore 6.4.1 API
Settings..::..Install Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Install
Visual Basic
Public NotInheritable Class Install
Visual C++
public ref class Install abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..Install

See Also

Settings..::..Install Members
Sitecore.Configuration Namespace


Settings.Install Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..Install Members
Settings..::..Install Class Properties See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..Install type exposes the following members.

Properties

Name | Description
HistoryFolder | Gets the history folder.
RemoveTransactionFolder | Gets a value indicating whether the Settings..::..Install removes the transaction folder.
TransactionsRoot | Gets the transactions root.

See Also

Settings..::..Install Class
Sitecore.Configuration Namespace


Settings.Install Properties

[image] [image]

Sitecore 6.4.1 API
Settings..::..Install Properties
Settings..::..Install Class See Also Send Feedback

The Settings..::..Install type exposes the following members.

Properties

Name | Description
HistoryFolder | Gets the history folder.
RemoveTransactionFolder | Gets a value indicating whether the Settings..::..Install removes the transaction folder.
TransactionsRoot | Gets the transactions root.

See Also

Settings..::..Install Class
Sitecore.Configuration Namespace


HistoryFolder Property

[image]

Sitecore 6.4.1 API
Settings..::..Install..::..HistoryFolder Property
Settings..::..Install Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string HistoryFolder { get; }
Visual Basic
Public Shared ReadOnly Property HistoryFolder As String
    Get
Visual C++
public:
static property String^ HistoryFolder {
    String^ get ();
}

Field Value

The history folder.

See Also

Settings..::..Install Class
Sitecore.Configuration Namespace


RemoveTransactionFolder Property

[image]

Sitecore 6.4.1 API
Settings..::..Install..::..RemoveTransactionFolder Property
Settings..::..Install Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool RemoveTransactionFolder { get; }
Visual Basic
Public Shared ReadOnly Property RemoveTransactionFolder As Boolean
    Get
Visual C++
public:
static property bool RemoveTransactionFolder {
    bool get ();
}

Field Value

true if the Settings..::..Install removes the transaction folder; otherwise, false.

See Also

Settings..::..Install Class
Sitecore.Configuration Namespace


TransactionsRoot Property

[image]

Sitecore 6.4.1 API
Settings..::..Install..::..TransactionsRoot Property
Settings..::..Install Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string TransactionsRoot { get; }
Visual Basic
Public Shared ReadOnly Property TransactionsRoot As String
    Get
Visual C++
public:
static property String^ TransactionsRoot {
    String^ get ();
}

Field Value

The transactions root.

See Also

Settings..::..Install Class
Sitecore.Configuration Namespace


Settings.Jobs Class

[image]

Sitecore 6.4.1 API
Settings..::..Jobs Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Jobs
Visual Basic
Public NotInheritable Class Jobs
Visual C++
public ref class Jobs abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..Jobs

See Also

Settings..::..Jobs Members
Sitecore.Configuration Namespace


Settings.Jobs Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..Jobs Members
Settings..::..Jobs Class Properties See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..Jobs type exposes the following members.

Properties

Name | Description
QueueProcessingInterval | Gets the interval between the JobManager checking its queue for pending actions.

See Also

Settings..::..Jobs Class
Sitecore.Configuration Namespace


Settings.Jobs Properties

[image] [image]

Sitecore 6.4.1 API
Settings..::..Jobs Properties
Settings..::..Jobs Class See Also Send Feedback

The Settings..::..Jobs type exposes the following members.

Properties

Name | Description
QueueProcessingInterval | Gets the interval between the JobManager checking its queue for pending actions.

See Also

Settings..::..Jobs Class
Sitecore.Configuration Namespace


QueueProcessingInterval Property

[image]

Sitecore 6.4.1 API
Settings..::..Jobs..::..QueueProcessingInterval Property
Settings..::..Jobs Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TimeSpan QueueProcessingInterval { get; }
Visual Basic
Public Shared ReadOnly Property QueueProcessingInterval As TimeSpan
    Get
Visual C++
public:
static property TimeSpan QueueProcessingInterval {
    TimeSpan get ();
}

Field Value

Default value: "00:00:02" (2 seconds)

See Also

Settings..::..Jobs Class
Sitecore.Configuration Namespace


Settings.Languages Class

[image]

Sitecore 6.4.1 API
Settings..::..Languages Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Languages
Visual Basic
Public NotInheritable Class Languages
Visual C++
public ref class Languages abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..Languages

See Also

Settings..::..Languages Members
Sitecore.Configuration Namespace


Settings.Languages Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..Languages Members
Settings..::..Languages Class Properties See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..Languages type exposes the following members.

Properties

Name | Description
AutoRemoveItemData | Indicates if item data is automatically removed from a database when a language item is deleted.
AutoRenameItemData | Indicates if the language of item data is automatically renamed when a language item is renamed.

See Also

Settings..::..Languages Class
Sitecore.Configuration Namespace


Settings.Languages Properties

[image] [image]

Sitecore 6.4.1 API
Settings..::..Languages Properties
Settings..::..Languages Class See Also Send Feedback

The Settings..::..Languages type exposes the following members.

Properties

Name | Description
AutoRemoveItemData | Indicates if item data is automatically removed from a database when a language item is deleted.
AutoRenameItemData | Indicates if the language of item data is automatically renamed when a language item is renamed.

See Also

Settings..::..Languages Class
Sitecore.Configuration Namespace


AutoRemoveItemData Property

[image]

Sitecore 6.4.1 API
Settings..::..Languages..::..AutoRemoveItemData Property
Settings..::..Languages Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool AutoRemoveItemData { get; }
Visual Basic
Public Shared ReadOnly Property AutoRemoveItemData As Boolean
    Get
Visual C++
public:
static property bool AutoRemoveItemData {
    bool get ();
}

Field Value

true if data should be removed; otherwise, false.

See Also

Settings..::..Languages Class
Sitecore.Configuration Namespace


AutoRenameItemData Property

[image]

Sitecore 6.4.1 API
Settings..::..Languages..::..AutoRenameItemData Property
Settings..::..Languages Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool AutoRenameItemData { get; }
Visual Basic
Public Shared ReadOnly Property AutoRenameItemData As Boolean
    Get
Visual C++
public:
static property bool AutoRenameItemData {
    bool get ();
}

Field Value

true if data language should be renamed; otherwise, false.

See Also

Settings..::..Languages Class
Sitecore.Configuration Namespace


Settings.Links Class

[image]

Sitecore 6.4.1 API
Settings..::..Links Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Links
Visual Basic
Public NotInheritable Class Links
Visual C++
public ref class Links abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..Links

See Also

Settings..::..Links Members
Sitecore.Configuration Namespace


Settings.Links Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..Links Members
Settings..::..Links Class Properties See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..Links type exposes the following members.

Properties

Name | Description
QueryStringSeparator | Gets the string used to separate entries in generated query strings.

See Also

Settings..::..Links Class
Sitecore.Configuration Namespace


Settings.Links Properties

[image] [image]

Sitecore 6.4.1 API
Settings..::..Links Properties
Settings..::..Links Class See Also Send Feedback

The Settings..::..Links type exposes the following members.

Properties

Name | Description
QueryStringSeparator | Gets the string used to separate entries in generated query strings.

See Also

Settings..::..Links Class
Sitecore.Configuration Namespace


QueryStringSeparator Property

[image]

Sitecore 6.4.1 API
Settings..::..Links..::..QueryStringSeparator Property
Settings..::..Links Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string QueryStringSeparator { get; }
Visual Basic
Public Shared ReadOnly Property QueryStringSeparator As String
    Get
Visual C++
public:
static property String^ QueryStringSeparator {
    String^ get ();
}

Field Value

The separator.

Remarks

Default value: &

See Also

Settings..::..Links Class
Sitecore.Configuration Namespace


Settings.Login Class

[image]

Sitecore 6.4.1 API
Settings..::..Login Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Login
Visual Basic
Public NotInheritable Class Login
Visual C++
public ref class Login abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..Login

See Also

Settings..::..Login Members
Sitecore.Configuration Namespace


Settings.Login Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..Login Members
Settings..::..Login Class Properties See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..Login type exposes the following members.

Properties

Name | Description
DisableChangePassword | Gets a value that indicates whether users are allowed to change their passwords on the /sitecore/login/changepassword.aspx page. If true, Sitecore disables change password functionality and hides the “Change Password” link no the login page.
DisablePasswordRecovery | Gets a value that indicates if users are allowed to reset their passwords on the /sitecore/login/passwordrecovery.aspx page. If true, Sitecore disables password recovery functionality and hides the “Forgot Your Password?” link on the login page.
RememberLastLoggedInUserName | Gets a value indicating whether Sitecore will remember the last logged in user name on the login page (stored encrypted in a cookie). If you set this to false, the user name field on the login page and change password page will always be blank. Default: true.
SitecoreUrl | Gets the max items.

See Also

Settings..::..Login Class
Sitecore.Configuration Namespace


DisablePasswordRecovery Property

[image]

Sitecore 6.4.1 API
Settings..::..Login..::..DisablePasswordRecovery Property
Settings..::..Login Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool DisablePasswordRecovery { get; }
Visual Basic
Public Shared ReadOnly Property DisablePasswordRecovery As Boolean
    Get
Visual C++
public:
static property bool DisablePasswordRecovery {
    bool get ();
}

See Also

Settings..::..Login Class
Sitecore.Configuration Namespace


RememberLastLoggedInUserName Property

[image]

Sitecore 6.4.1 API
Settings..::..Login..::..RememberLastLoggedInUserName Property
Settings..::..Login Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool RememberLastLoggedInUserName { get; }
Visual Basic
Public Shared ReadOnly Property RememberLastLoggedInUserName As Boolean
    Get
Visual C++
public:
static property bool RememberLastLoggedInUserName {
    bool get ();
}

Field Value

If true Sitecore will remember the last logged in user name on the login page (stored encrypted in a cookie).

See Also

Settings..::..Login Class
Sitecore.Configuration Namespace


SitecoreUrl Property

[image]

Sitecore 6.4.1 API
Settings..::..Login..::..SitecoreUrl Property
Settings..::..Login Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string SitecoreUrl { get; }
Visual Basic
Public Shared ReadOnly Property SitecoreUrl As String
    Get
Visual C++
public:
static property String^ SitecoreUrl {
    String^ get ();
}

Field Value

The max items.

See Also

Settings..::..Login Class
Sitecore.Configuration Namespace


Settings.Media Class

[image]

Sitecore 6.4.1 API
Settings..::..Media Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Media
Visual Basic
Public NotInheritable Class Media
Visual C++
public ref class Media abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..Media

See Also

Settings..::..Media Members
Sitecore.Configuration Namespace


Settings.Media Properties

[image] [image]

Sitecore 6.4.1 API
Settings..::..Media Properties
Settings..::..Media Class See Also Send Feedback

The Settings..::..Media type exposes the following members.

Properties

Name | Description
AutoSetAlt | Indicates if the Alt field on the Image template is set autmatically to the file path when the image is uploaded. If false, the Alt field is blank.
BaseFolder | Obsolete. Gets the base folder used when storing media files.
CacheFolder | Gets the folder under which media files are cached by the system.
CachingEnabled | Indicates if caching of media files is enabled.
DefaultImageFormat | Gets the default ImageFormat to use when it's not possible to deduce this from an extension.
DefaultMediaPrefix | Gets the default media prefix.
DisableFileMedia | Gets a value indicating whether file media is enabled or disabled.
FileFolder | Gets the folder under which media files are stored by the system.
IncludeExtensionsInItemNames | Gets a value indicating whether to include a file extension when generating an item name from a file name.
InterpolationMode | Gets the interpolation mode to use when resizing images.
MaxImageWidth | Gets the max width of the image in a Rich Text field.
MaxSizeInDatabase | Gets the maximum allowed size of media intended to be stored in a database (binary blob).
MaxSizeInMemory | Gets the maximum size of media to load into memory for processing (rezising etc.).
MediaLinkPrefix | Gets the media link prefix. The prefix to use when Sitecore generates media links. The setting is used in the front-end as well as the back-end. Notice: If you specify a custom media link prefix, you must also add a corresponding entry to the section. If the value is not set, the default media request prefix will be used (which by default is "~/media/")
OpenContentEditorAfterUpload | Gets a value indicating whether the content editor must be opened after a file has been uploaded.
RequestExtension | Gets the extension to use in media request URLs.
StreamBufferSize | Gets the size of the buffer to use when streaming media to files or other targets.
StreamPartiallyCachedFiles | Gets a value indicating whether to start streaming files before they have been fully written to the cache.
UploadAsFiles | Determines if media should be uploaded as files or as database blobs.
UploadAsVersionableByDefault | Gets a value indicating whether media items is uploaded as versionable by default.
UseItemPaths | Gets a value indicating whether to use item paths for media URLs.
UseLegacyResizing | Gets a value indicating whether to use legacy resizing (ie. bypass the Sitecore.ImageLib library).
WhitespaceReplacement | Gets the character to use when replacing whitespace in the names of uploaded media.

See Also

Settings..::..Media Class
Sitecore.Configuration Namespace


AutoSetAlt Property

[image]

Sitecore 6.4.1 API
Settings..::..Media..::..AutoSetAlt Property
Settings..::..Media Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool AutoSetAlt { get; }
Visual Basic
Public Shared ReadOnly Property AutoSetAlt As Boolean
    Get
Visual C++
public:
static property bool AutoSetAlt {
    bool get ();
}

See Also

Settings..::..Media Class
Sitecore.Configuration Namespace


BaseFolder Property

[image]

Sitecore 6.4.1 API
Settings..::..Media..::..BaseFolder Property
Settings..::..Media Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public static string BaseFolder { get; }
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Shared ReadOnly Property BaseFolder As String
    Get
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public:
static property String^ BaseFolder {
    String^ get ();
}

Field Value

The base folder.

Remarks

Default value: /App_Data/MediaFiles

See Also

Settings..::..Media Class
Sitecore.Configuration Namespace


CacheFolder Property

[image]

Sitecore 6.4.1 API
Settings..::..Media..::..CacheFolder Property
Settings..::..Media Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string CacheFolder { get; }
Visual Basic
Public Shared ReadOnly Property CacheFolder As String
    Get
Visual C++
public:
static property String^ CacheFolder {
    String^ get ();
}

Field Value

The cache folder.

Remarks

Default value: /App_Data/MediaCache

See Also

Settings..::..Media Class
Sitecore.Configuration Namespace


CachingEnabled Property

[image]

Sitecore 6.4.1 API
Settings..::..Media..::..CachingEnabled Property
Settings..::..Media Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool CachingEnabled { get; }
Visual Basic
Public Shared ReadOnly Property CachingEnabled As Boolean
    Get
Visual C++
public:
static property bool CachingEnabled {
    bool get ();
}

Remarks

Default value: true

See Also

Settings..::..Media Class
Sitecore.Configuration Namespace


DefaultImageFormat Property

[image]

Sitecore 6.4.1 API
Settings..::..Media..::..DefaultImageFormat Property
Settings..::..Media Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string DefaultImageFormat { get; }
Visual Basic
Public Shared ReadOnly Property DefaultImageFormat As String
    Get
Visual C++
public:
static property String^ DefaultImageFormat {
    String^ get ();
}

Field Value

The image format. Default value: "" (empty string).

Remarks

The value must be parsable to a valid ImageFormat value.

If the value is not set, the GetImageFormat(String) may return null causing image functions to fail.

See Also

Settings..::..Media Class
Sitecore.Configuration Namespace


DefaultMediaPrefix Property

[image]

Sitecore 6.4.1 API
Settings..::..Media..::..DefaultMediaPrefix Property
Settings..::..Media Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string DefaultMediaPrefix { get; }
Visual Basic
Public Shared ReadOnly Property DefaultMediaPrefix As String
    Get
Visual C++
public:
static property String^ DefaultMediaPrefix {
    String^ get ();
}

Field Value

The default media prefix.

See Also

Settings..::..Media Class
Sitecore.Configuration Namespace


DisableFileMedia Property

[image]

Sitecore 6.4.1 API
Settings..::..Media..::..DisableFileMedia Property
Settings..::..Media Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool DisableFileMedia { get; }
Visual Basic
Public Shared ReadOnly Property DisableFileMedia As Boolean
    Get
Visual C++
public:
static property bool DisableFileMedia {
    bool get ();
}

Field Value

true if file media is disabled, otherwise, false.

See Also

Settings..::..Media Class
Sitecore.Configuration Namespace


FileFolder Property

[image]

Sitecore 6.4.1 API
Settings..::..Media..::..FileFolder Property
Settings..::..Media Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string FileFolder { get; }
Visual Basic
Public Shared ReadOnly Property FileFolder As String
    Get
Visual C++
public:
static property String^ FileFolder {
    String^ get ();
}

Field Value

The folder.

Remarks

Default value: /App_Data/MediaFiles

See Also

Settings..::..Media Class
Sitecore.Configuration Namespace


IncludeExtensionsInItemNames Property

[image]

Sitecore 6.4.1 API
Settings..::..Media..::..IncludeExtensionsInItemNames Property
Settings..::..Media Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IncludeExtensionsInItemNames { get; }
Visual Basic
Public Shared ReadOnly Property IncludeExtensionsInItemNames As Boolean
    Get
Visual C++
public:
static property bool IncludeExtensionsInItemNames {
    bool get ();
}

Field Value

true if extansion should be included; otherwise, false.

See Also

Settings..::..Media Class
Sitecore.Configuration Namespace


InterpolationMode Property

[image]

Sitecore 6.4.1 API
Settings..::..Media..::..InterpolationMode Property
Settings..::..Media Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static InterpolationMode InterpolationMode { get; }
Visual Basic
Public Shared ReadOnly Property InterpolationMode As InterpolationMode
    Get
Visual C++
public:
static property InterpolationMode InterpolationMode {
    InterpolationMode get ();
}

Field Value

The interpolation mode.

Remarks

Default value: High

See Also

Settings..::..Media Class
Sitecore.Configuration Namespace


MaxImageWidth Property

[image]

Sitecore 6.4.1 API
Settings..::..Media..::..MaxImageWidth Property
Settings..::..Media Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int MaxImageWidth { get; }
Visual Basic
Public Shared ReadOnly Property MaxImageWidth As Integer
    Get
Visual C++
public:
static property int MaxImageWidth {
    int get ();
}

Field Value

The max width of an image in a Rich Text field.

See Also

Settings..::..Media Class
Sitecore.Configuration Namespace


MaxSizeInDatabase Property

[image]

Sitecore 6.4.1 API
Settings..::..Media..::..MaxSizeInDatabase Property
Settings..::..Media Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long MaxSizeInDatabase { get; }
Visual Basic
Public Shared ReadOnly Property MaxSizeInDatabase As Long
    Get
Visual C++
public:
static property long long MaxSizeInDatabase {
    long long get ();
}

Field Value

The maximum size.

Remarks

Default value: 500MB

See Also

Settings..::..Media Class
Sitecore.Configuration Namespace


MaxSizeInMemory Property

[image]

Sitecore 6.4.1 API
Settings..::..Media..::..MaxSizeInMemory Property
Settings..::..Media Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long MaxSizeInMemory { get; }
Visual Basic
Public Shared ReadOnly Property MaxSizeInMemory As Long
    Get
Visual C++
public:
static property long long MaxSizeInMemory {
    long long get ();
}

Field Value

The maximum size.

Remarks

Default value: 40MB

See Also

Settings..::..Media Class
Sitecore.Configuration Namespace


MediaLinkPrefix Property

[image]

Sitecore 6.4.1 API
Settings..::..Media..::..MediaLinkPrefix Property
Settings..::..Media Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string MediaLinkPrefix { get; }
Visual Basic
Public Shared ReadOnly Property MediaLinkPrefix As String
    Get
Visual C++
public:
static property String^ MediaLinkPrefix {
    String^ get ();
}

Field Value

The media link prefix.

Remarks

Default value: ""

See Also

Settings..::..Media Class
Sitecore.Configuration Namespace


OpenContentEditorAfterUpload Property

[image]

Sitecore 6.4.1 API
Settings..::..Media..::..OpenContentEditorAfterUpload Property
Settings..::..Media Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool OpenContentEditorAfterUpload { get; }
Visual Basic
Public Shared ReadOnly Property OpenContentEditorAfterUpload As Boolean
    Get
Visual C++
public:
static property bool OpenContentEditorAfterUpload {
    bool get ();
}

Field Value

true if the content editor must be opened after a file has been uploaded; otherwise, false.

See Also

Settings..::..Media Class
Sitecore.Configuration Namespace


RequestExtension Property

[image]

Sitecore 6.4.1 API
Settings..::..Media..::..RequestExtension Property
Settings..::..Media Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string RequestExtension { get; }
Visual Basic
Public Shared ReadOnly Property RequestExtension As String
    Get
Visual C++
public:
static property String^ RequestExtension {
    String^ get ();
}

Field Value

The request extension. Default value: "" (an empty string)

Remarks

If the value is not set, the Extension field of the individual media items will be used (ie. JPG, GIF, etc.)

See Also

Settings..::..Media Class
Sitecore.Configuration Namespace


StreamBufferSize Property

[image]

Sitecore 6.4.1 API
Settings..::..Media..::..StreamBufferSize Property
Settings..::..Media Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int StreamBufferSize { get; }
Visual Basic
Public Shared ReadOnly Property StreamBufferSize As Integer
    Get
Visual C++
public:
static property int StreamBufferSize {
    int get ();
}

Field Value

The size of the stream buffer.

Remarks

Default value: 100000

See Also

Settings..::..Media Class
Sitecore.Configuration Namespace


StreamPartiallyCachedFiles Property

[image]

Sitecore 6.4.1 API
Settings..::..Media..::..StreamPartiallyCachedFiles Property
Settings..::..Media Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool StreamPartiallyCachedFiles { get; }
Visual Basic
Public Shared ReadOnly Property StreamPartiallyCachedFiles As Boolean
    Get
Visual C++
public:
static property bool StreamPartiallyCachedFiles {
    bool get ();
}

Field Value

true if the feature should be enabled; otherwise, false.

Remarks

Default value: true

See Also

Settings..::..Media Class
Sitecore.Configuration Namespace


UploadAsFiles Property

[image]

Sitecore 6.4.1 API
Settings..::..Media..::..UploadAsFiles Property
Settings..::..Media Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool UploadAsFiles { get; }
Visual Basic
Public Shared ReadOnly Property UploadAsFiles As Boolean
    Get
Visual C++
public:
static property bool UploadAsFiles {
    bool get ();
}

Field Value

true if upload as files; otherwise, false.

See Also

Settings..::..Media Class
Sitecore.Configuration Namespace


UploadAsVersionableByDefault Property

[image]

Sitecore 6.4.1 API
Settings..::..Media..::..UploadAsVersionableByDefault Property
Settings..::..Media Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool UploadAsVersionableByDefault { get; }
Visual Basic
Public Shared ReadOnly Property UploadAsVersionableByDefault As Boolean
    Get
Visual C++
public:
static property bool UploadAsVersionableByDefault {
    bool get ();
}

Field Value

true if media items is uploaded as versionable by default; otherwise, false.

See Also

Settings..::..Media Class
Sitecore.Configuration Namespace


UseItemPaths Property

[image]

Sitecore 6.4.1 API
Settings..::..Media..::..UseItemPaths Property
Settings..::..Media Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool UseItemPaths { get; }
Visual Basic
Public Shared ReadOnly Property UseItemPaths As Boolean
    Get
Visual C++
public:
static property bool UseItemPaths {
    bool get ();
}

Field Value

true if item paths should be used; otherwise, false.

Remarks

Default value: false

See Also

Settings..::..Media Class
Sitecore.Configuration Namespace


UseLegacyResizing Property

[image]

Sitecore 6.4.1 API
Settings..::..Media..::..UseLegacyResizing Property
Settings..::..Media Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool UseLegacyResizing { get; }
Visual Basic
Public Shared ReadOnly Property UseLegacyResizing As Boolean
    Get
Visual C++
public:
static property bool UseLegacyResizing {
    bool get ();
}

Field Value

true if legacy resizing should be used; otherwise, false.

Remarks

Default value: false.

See Also

Settings..::..Media Class
Sitecore.Configuration Namespace


WhitespaceReplacement Property

[image]

Sitecore 6.4.1 API
Settings..::..Media..::..WhitespaceReplacement Property
Settings..::..Media Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string WhitespaceReplacement { get; }
Visual Basic
Public Shared ReadOnly Property WhitespaceReplacement As String
    Get
Visual C++
public:
static property String^ WhitespaceReplacement {
    String^ get ();
}

Field Value

The extension divider.

Remarks

Default: A single space character.

See Also

Settings..::..Media Class
Sitecore.Configuration Namespace


Settings.MediaResponse Class

[image]

Sitecore 6.4.1 API
Settings..::..MediaResponse Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class MediaResponse
Visual Basic
Public NotInheritable Class MediaResponse
Visual C++
public ref class MediaResponse abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..MediaResponse

See Also

Settings..::..MediaResponse Members
Sitecore.Configuration Namespace


Settings.MediaResponse Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..MediaResponse Members
Settings..::..MediaResponse Class Properties See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..MediaResponse type exposes the following members.

Properties

Name | Description
Cacheability | Gets the HttpCacheability cacheability to use in media response headers.
CacheExtensions | Gets the cache extension to use in media response headers.
MaxAge | Gets the max age to use in media response headers.
SlidingExpiration | Gets the sliding expiration to use in media response headers.

See Also

Settings..::..MediaResponse Class
Sitecore.Configuration Namespace


Settings.MediaResponse Properties

[image] [image]

Sitecore 6.4.1 API
Settings..::..MediaResponse Properties
Settings..::..MediaResponse Class See Also Send Feedback

The Settings..::..MediaResponse type exposes the following members.

Properties

Name | Description
Cacheability | Gets the HttpCacheability cacheability to use in media response headers.
CacheExtensions | Gets the cache extension to use in media response headers.
MaxAge | Gets the max age to use in media response headers.
SlidingExpiration | Gets the sliding expiration to use in media response headers.

See Also

Settings..::..MediaResponse Class
Sitecore.Configuration Namespace


Cacheability Property

[image]

Sitecore 6.4.1 API
Settings..::..MediaResponse..::..Cacheability Property
Settings..::..MediaResponse Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static HttpCacheability Cacheability { get; }
Visual Basic
Public Shared ReadOnly Property Cacheability As HttpCacheability
    Get
Visual C++
public:
static property HttpCacheability Cacheability {
    HttpCacheability get ();
}

Field Value

The HTTP cacheability.

See Also

Settings..::..MediaResponse Class
Sitecore.Configuration Namespace


MaxAge Property

[image]

Sitecore 6.4.1 API
Settings..::..MediaResponse..::..MaxAge Property
Settings..::..MediaResponse Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TimeSpan MaxAge { get; }
Visual Basic
Public Shared ReadOnly Property MaxAge As TimeSpan
    Get
Visual C++
public:
static property TimeSpan MaxAge {
    TimeSpan get ();
}

Field Value

The max age. Set it to "00:00:00" to omit this header.

Remarks

Default value: "00:00:00" (Zero).

See Also

Settings..::..MediaResponse Class
Sitecore.Configuration Namespace


SlidingExpiration Property

[image]

Sitecore 6.4.1 API
Settings..::..MediaResponse..::..SlidingExpiration Property
Settings..::..MediaResponse Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Tristate SlidingExpiration { get; }
Visual Basic
Public Shared ReadOnly Property SlidingExpiration As Tristate
    Get
Visual C++
public:
static property Tristate SlidingExpiration {
    Tristate get ();
}

Field Value

The sliding expiration ("true"/"false"). Set it to "" to omit this header.

Remarks

Default value: "".

See Also

Settings..::..MediaResponse Class
Sitecore.Configuration Namespace


Settings.Performance Class

[image]

Sitecore 6.4.1 API
Settings..::..Performance Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Performance
Visual Basic
Public NotInheritable Class Performance
Visual C++
public ref class Performance abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..Performance

See Also

Settings..::..Performance Members
Sitecore.Configuration Namespace


Settings.Performance Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..Performance Members
Settings..::..Performance Class Properties See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..Performance type exposes the following members.

Properties

Name | Description
PagingIteratorPageSize | Gets the default page size to use with the PagingIterator<(Of <(<'T>)>)>.

See Also

Settings..::..Performance Class
Sitecore.Configuration Namespace


Settings.Performance Properties

[image] [image]

Sitecore 6.4.1 API
Settings..::..Performance Properties
Settings..::..Performance Class See Also Send Feedback

The Settings..::..Performance type exposes the following members.

Properties

Name | Description
PagingIteratorPageSize | Gets the default page size to use with the PagingIterator<(Of <(<'T>)>)>.

See Also

Settings..::..Performance Class
Sitecore.Configuration Namespace


PagingIteratorPageSize Property

[image]

Sitecore 6.4.1 API
Settings..::..Performance..::..PagingIteratorPageSize Property
Settings..::..Performance Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int PagingIteratorPageSize { get; }
Visual Basic
Public Shared ReadOnly Property PagingIteratorPageSize As Integer
    Get
Visual C++
public:
static property int PagingIteratorPageSize {
    int get ();
}

Field Value

The size of the paging iterator page.

Remarks

Default value: 100

See Also

Settings..::..Performance Class
Sitecore.Configuration Namespace


Settings.Preview Class

[image]

Sitecore 6.4.1 API
Settings..::..Preview Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Preview
Visual Basic
Public NotInheritable Class Preview
Visual C++
public ref class Preview abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..Preview

See Also

Settings..::..Preview Members
Sitecore.Configuration Namespace


Settings.Preview Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..Preview Members
Settings..::..Preview Class Properties See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..Preview type exposes the following members.

Properties

Name | Description
DefaultSite | Gets the default site.

See Also

Settings..::..Preview Class
Sitecore.Configuration Namespace


Settings.Preview Properties

[image] [image]

Sitecore 6.4.1 API
Settings..::..Preview Properties
Settings..::..Preview Class See Also Send Feedback

The Settings..::..Preview type exposes the following members.

Properties

Name | Description
DefaultSite | Gets the default site.

See Also

Settings..::..Preview Class
Sitecore.Configuration Namespace


DefaultSite Property

[image]

Sitecore 6.4.1 API
Settings..::..Preview..::..DefaultSite Property
Settings..::..Preview Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string DefaultSite { get; }
Visual Basic
Public Shared ReadOnly Property DefaultSite As String
    Get
Visual C++
public:
static property String^ DefaultSite {
    String^ get ();
}

Field Value

The default site.

See Also

Settings..::..Preview Class
Sitecore.Configuration Namespace


Settings.Profiling Class

[image]

Sitecore 6.4.1 API
Settings..::..Profiling Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Profiling
Visual Basic
Public NotInheritable Class Profiling
Visual C++
public ref class Profiling abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..Profiling

See Also

Settings..::..Profiling Members
Sitecore.Configuration Namespace


Settings.Profiling Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..Profiling Members
Settings..::..Profiling Class Properties See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..Profiling type exposes the following members.

Properties

Name | Description
FormattingXslFile | Gets the formatting XSL file.
RenderFieldThreshold | Defines the threshold value for logging long field render operations.
SheerUI | Determines if SheerUI is profiled.
SheerUIWarningThreshold | Defines the threshold value for logging long requests.

See Also

Settings..::..Profiling Class
Sitecore.Configuration Namespace


Settings.Profiling Properties

[image] [image]

Sitecore 6.4.1 API
Settings..::..Profiling Properties
Settings..::..Profiling Class See Also Send Feedback

The Settings..::..Profiling type exposes the following members.

Properties

Name | Description
FormattingXslFile | Gets the formatting XSL file.
RenderFieldThreshold | Defines the threshold value for logging long field render operations.
SheerUI | Determines if SheerUI is profiled.
SheerUIWarningThreshold | Defines the threshold value for logging long requests.

See Also

Settings..::..Profiling Class
Sitecore.Configuration Namespace


FormattingXslFile Property

[image]

Sitecore 6.4.1 API
Settings..::..Profiling..::..FormattingXslFile Property
Settings..::..Profiling Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string FormattingXslFile { get; }
Visual Basic
Public Shared ReadOnly Property FormattingXslFile As String
    Get
Visual C++
public:
static property String^ FormattingXslFile {
    String^ get ();
}

Field Value

The formatting XSL file.

See Also

Settings..::..Profiling Class
Sitecore.Configuration Namespace


RenderFieldThreshold Property

[image]

Sitecore 6.4.1 API
Settings..::..Profiling..::..RenderFieldThreshold Property
Settings..::..Profiling Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int RenderFieldThreshold { get; }
Visual Basic
Public Shared ReadOnly Property RenderFieldThreshold As Integer
    Get
Visual C++
public:
static property int RenderFieldThreshold {
    int get ();
}

Field Value

The threshold value for logging long field render operations.

See Also

Settings..::..Profiling Class
Sitecore.Configuration Namespace


SheerUI Property

[image]

Sitecore 6.4.1 API
Settings..::..Profiling..::..SheerUI Property
Settings..::..Profiling Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool SheerUI { get; }
Visual Basic
Public Shared ReadOnly Property SheerUI As Boolean
    Get
Visual C++
public:
static property bool SheerUI {
    bool get ();
}

Field Value

true if SheerUI is profiled; otherwise, false.

See Also

Settings..::..Profiling Class
Sitecore.Configuration Namespace


SheerUIWarningThreshold Property

[image]

Sitecore 6.4.1 API
Settings..::..Profiling..::..SheerUIWarningThreshold Property
Settings..::..Profiling Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int SheerUIWarningThreshold { get; }
Visual Basic
Public Shared ReadOnly Property SheerUIWarningThreshold As Integer
    Get
Visual C++
public:
static property int SheerUIWarningThreshold {
    int get ();
}

Field Value

The sheer UI warning threshold.

See Also

Settings..::..Profiling Class
Sitecore.Configuration Namespace


Settings.Publishing Class

[image]

Sitecore 6.4.1 API
Settings..::..Publishing Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Publishing
Visual Basic
Public NotInheritable Class Publishing
Visual C++
public ref class Publishing abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..Publishing

See Also

Settings..::..Publishing Members
Sitecore.Configuration Namespace


Settings.Publishing Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..Publishing Members
Settings..::..Publishing Class Properties See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..Publishing type exposes the following members.

Properties

Name | Description
AutoScheduleSmartPublish | Gets a value indicating whether to automatically schedule a smart publish when proxy definitions etc. change?
CheckSecurity | Determines whether to check security rights when publishing.
CompareRevisions | Gets a value indicating whether publishing compares the revisions.
LogInterval | Gets the log interval.
PublishDialogPollingInterval | Gets the publish dialog polling interval.
PublishEmptyItems | Determines if empty items (i.e. items without publishable versions) shold be published.
PublishingInstance | Gets the publish server instance name.
RequireTargetDeleteRightWhenCheckingSecurity | Determines whether to check for delete rights on target items when publishing.
StatusUpdateInterval | Gets the time between updating the status cache for running publishing jobs.
ThreadPriority | Gets the thread priority of publishing jobs.
TimeBeforeStatusExpires | Gets the time before a cached status registration expires.

See Also

Settings..::..Publishing Class
Sitecore.Configuration Namespace


Settings.Publishing Properties

[image] [image]

Sitecore 6.4.1 API
Settings..::..Publishing Properties
Settings..::..Publishing Class See Also Send Feedback

The Settings..::..Publishing type exposes the following members.

Properties

Name | Description
AutoScheduleSmartPublish | Gets a value indicating whether to automatically schedule a smart publish when proxy definitions etc. change?
CheckSecurity | Determines whether to check security rights when publishing.
CompareRevisions | Gets a value indicating whether publishing compares the revisions.
LogInterval | Gets the log interval.
PublishDialogPollingInterval | Gets the publish dialog polling interval.
PublishEmptyItems | Determines if empty items (i.e. items without publishable versions) shold be published.
PublishingInstance | Gets the publish server instance name.
RequireTargetDeleteRightWhenCheckingSecurity | Determines whether to check for delete rights on target items when publishing.
StatusUpdateInterval | Gets the time between updating the status cache for running publishing jobs.
ThreadPriority | Gets the thread priority of publishing jobs.
TimeBeforeStatusExpires | Gets the time before a cached status registration expires.

See Also

Settings..::..Publishing Class
Sitecore.Configuration Namespace


CheckSecurity Property

[image]

Sitecore 6.4.1 API
Settings..::..Publishing..::..CheckSecurity Property
Settings..::..Publishing Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool CheckSecurity { get; }
Visual Basic
Public Shared ReadOnly Property CheckSecurity As Boolean
    Get
Visual C++
public:
static property bool CheckSecurity {
    bool get ();
}

Field Value

true if security should be checked; otherwise, false.

Remarks

Only read and write rights are used.

Default value: false.

See Also

Settings..::..Publishing Class
Sitecore.Configuration Namespace


CompareRevisions Property

[image]

Sitecore 6.4.1 API
Settings..::..Publishing..::..CompareRevisions Property
Settings..::..Publishing Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool CompareRevisions { get; }
Visual Basic
Public Shared ReadOnly Property CompareRevisions As Boolean
    Get
Visual C++
public:
static property bool CompareRevisions {
    bool get ();
}

Field Value

true if publishing compares the revisions; otherwise, false.

See Also

Settings..::..Publishing Class
Sitecore.Configuration Namespace


LogInterval Property

[image]

Sitecore 6.4.1 API
Settings..::..Publishing..::..LogInterval Property
Settings..::..Publishing Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int LogInterval { get; }
Visual Basic
Public Shared ReadOnly Property LogInterval As Integer
    Get
Visual C++
public:
static property int LogInterval {
    int get ();
}

Field Value

The log interval.

See Also

Settings..::..Publishing Class
Sitecore.Configuration Namespace


PublishDialogPollingInterval Property

[image]

Sitecore 6.4.1 API
Settings..::..Publishing..::..PublishDialogPollingInterval Property
Settings..::..Publishing Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int PublishDialogPollingInterval { get; }
Visual Basic
Public Shared ReadOnly Property PublishDialogPollingInterval As Integer
    Get
Visual C++
public:
static property int PublishDialogPollingInterval {
    int get ();
}

Field Value

The publish dialog polling interval.

See Also

Settings..::..Publishing Class
Sitecore.Configuration Namespace


PublishEmptyItems Property

[image]

Sitecore 6.4.1 API
Settings..::..Publishing..::..PublishEmptyItems Property
Settings..::..Publishing Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool PublishEmptyItems { get; }
Visual Basic
Public Shared ReadOnly Property PublishEmptyItems As Boolean
    Get
Visual C++
public:
static property bool PublishEmptyItems {
    bool get ();
}

Field Value

true if empty items should be published; otherwise, false.

See Also

Settings..::..Publishing Class
Sitecore.Configuration Namespace


PublishingInstance Property

[image]

Sitecore 6.4.1 API
Settings..::..Publishing..::..PublishingInstance Property
Settings..::..Publishing Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string PublishingInstance { get; }
Visual Basic
Public Shared ReadOnly Property PublishingInstance As String
    Get
Visual C++
public:
static property String^ PublishingInstance {
    String^ get ();
}

Field Value

The publish server.

See Also

Settings..::..Publishing Class
Sitecore.Configuration Namespace


RequireTargetDeleteRightWhenCheckingSecurity Property

[image]

Sitecore 6.4.1 API
Settings..::..Publishing..::..RequireTargetDeleteRightWhenCheckingSecurity Property
Settings..::..Publishing Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool RequireTargetDeleteRightWhenCheckingSecurity { get; }
Visual Basic
Public Shared ReadOnly Property RequireTargetDeleteRightWhenCheckingSecurity As Boolean
    Get
Visual C++
public:
static property bool RequireTargetDeleteRightWhenCheckingSecurity {
    bool get ();
}

Field Value

true if delete right should be checked; otherwise, false.

Remarks

Only used when CheckSecurity is true.

If set to false all publishing users will be able to publish deletions.

Default value: true.

See Also

Settings..::..Publishing Class
Sitecore.Configuration Namespace


StatusUpdateInterval Property

[image]

Sitecore 6.4.1 API
Settings..::..Publishing..::..StatusUpdateInterval Property
Settings..::..Publishing Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TimeSpan StatusUpdateInterval { get; }
Visual Basic
Public Shared ReadOnly Property StatusUpdateInterval As TimeSpan
    Get
Visual C++
public:
static property TimeSpan StatusUpdateInterval {
    TimeSpan get ();
}

Field Value

The update interval.

Remarks

Default value: 2 seconds.

See Also

Settings..::..Publishing Class
Sitecore.Configuration Namespace


ThreadPriority Property

[image]

Sitecore 6.4.1 API
Settings..::..Publishing..::..ThreadPriority Property
Settings..::..Publishing Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ThreadPriority ThreadPriority { get; }
Visual Basic
Public Shared ReadOnly Property ThreadPriority As ThreadPriority
    Get
Visual C++
public:
static property ThreadPriority ThreadPriority {
    ThreadPriority get ();
}

Field Value

The priority. Default value is ThreadPriority.BelowNormal/>

See Also

Settings..::..Publishing Class
Sitecore.Configuration Namespace


TimeBeforeStatusExpires Property

[image]

Sitecore 6.4.1 API
Settings..::..Publishing..::..TimeBeforeStatusExpires Property
Settings..::..Publishing Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TimeSpan TimeBeforeStatusExpires { get; }
Visual Basic
Public Shared ReadOnly Property TimeBeforeStatusExpires As TimeSpan
    Get
Visual C++
public:
static property TimeSpan TimeBeforeStatusExpires {
    TimeSpan get ();
}

Field Value

The time.

Remarks

Default value: 2 hours.

See Also

Settings..::..Publishing Class
Sitecore.Configuration Namespace


Settings.Query Class

[image]

Sitecore 6.4.1 API
Settings..::..Query Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Query
Visual Basic
Public NotInheritable Class Query
Visual C++
public ref class Query abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..Query

See Also

Settings..::..Query Members
Sitecore.Configuration Namespace


Settings.Query Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..Query Members
Settings..::..Query Class Properties See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..Query type exposes the following members.

Properties

Name | Description
MaxItems | Gets the max items.

See Also

Settings..::..Query Class
Sitecore.Configuration Namespace


Settings.Query Properties

[image] [image]

Sitecore 6.4.1 API
Settings..::..Query Properties
Settings..::..Query Class See Also Send Feedback

The Settings..::..Query type exposes the following members.

Properties

Name | Description
MaxItems | Gets the max items.

See Also

Settings..::..Query Class
Sitecore.Configuration Namespace


MaxItems Property

[image]

Sitecore 6.4.1 API
Settings..::..Query..::..MaxItems Property
Settings..::..Query Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int MaxItems { get; }
Visual Basic
Public Shared ReadOnly Property MaxItems As Integer
    Get
Visual C++
public:
static property int MaxItems {
    int get ();
}

Field Value

The max items.

See Also

Settings..::..Query Class
Sitecore.Configuration Namespace


Settings.Rendering Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..Rendering Members
Settings..::..Rendering Class Properties See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..Rendering type exposes the following members.

Properties

Name | Description
ImagesAsXhtml | Gets a value indicating whether to render images as XHTML.
ProcessDuplicatePlaceholders | Gets a value indicating whether to process duplicate placeholders.
SiteResolving | Setting it to true, will cause resolving site information while rendering item links.
TypesThatShouldNotBeExpanded | Gets a Set<(Of <(<'T>)>)> of the types that should not be expanded during page building.

See Also

Settings..::..Rendering Class
Sitecore.Configuration Namespace


Settings.Rendering Properties

[image] [image]

Sitecore 6.4.1 API
Settings..::..Rendering Properties
Settings..::..Rendering Class See Also Send Feedback

The Settings..::..Rendering type exposes the following members.

Properties

Name | Description
ImagesAsXhtml | Gets a value indicating whether to render images as XHTML.
ProcessDuplicatePlaceholders | Gets a value indicating whether to process duplicate placeholders.
SiteResolving | Setting it to true, will cause resolving site information while rendering item links.
TypesThatShouldNotBeExpanded | Gets a Set<(Of <(<'T>)>)> of the types that should not be expanded during page building.

See Also

Settings..::..Rendering Class
Sitecore.Configuration Namespace


ImagesAsXhtml Property

[image]

Sitecore 6.4.1 API
Settings..::..Rendering..::..ImagesAsXhtml Property
Settings..::..Rendering Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool ImagesAsXhtml { get; }
Visual Basic
Public Shared ReadOnly Property ImagesAsXhtml As Boolean
    Get
Visual C++
public:
static property bool ImagesAsXhtml {
    bool get ();
}

Field Value

true if images should be rendered as XHTML; otherwise, false.

Remarks

Default value: true

See Also

Settings..::..Rendering Class
Sitecore.Configuration Namespace


ProcessDuplicatePlaceholders Property

[image]

Sitecore 6.4.1 API
Settings..::..Rendering..::..ProcessDuplicatePlaceholders Property
Settings..::..Rendering Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool ProcessDuplicatePlaceholders { get; }
Visual Basic
Public Shared ReadOnly Property ProcessDuplicatePlaceholders As Boolean
    Get
Visual C++
public:
static property bool ProcessDuplicatePlaceholders {
    bool get ();
}

Field Value

true if [process duplicate placeholders]; otherwise, false.

See Also

Settings..::..Rendering Class
Sitecore.Configuration Namespace


SiteResolving Property

[image]

Sitecore 6.4.1 API
Settings..::..Rendering..::..SiteResolving Property
Settings..::..Rendering Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool SiteResolving { get; }
Visual Basic
Public Shared ReadOnly Property SiteResolving As Boolean
    Get
Visual C++
public:
static property bool SiteResolving {
    bool get ();
}

Field Value

true if site resolving is enabled; otherwise, false.

See Also

Settings..::..Rendering Class
Sitecore.Configuration Namespace


TypesThatShouldNotBeExpanded Property

[image]

Sitecore 6.4.1 API
Settings..::..Rendering..::..TypesThatShouldNotBeExpanded Property
Settings..::..Rendering Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Set<string> TypesThatShouldNotBeExpanded { get; }
Visual Basic
Public Shared ReadOnly Property TypesThatShouldNotBeExpanded As Set(Of String)
    Get
Visual C++
public:
static property Set<String^>^ TypesThatShouldNotBeExpanded {
    Set<String^>^ get ();
}

Field Value

The types that should not be expanded.

See Also

Settings..::..Rendering Class
Sitecore.Configuration Namespace


Settings.RequestErrors Class

[image]

Sitecore 6.4.1 API
Settings..::..RequestErrors Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class RequestErrors
Visual Basic
Public NotInheritable Class RequestErrors
Visual C++
public ref class RequestErrors abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..RequestErrors

See Also

Settings..::..RequestErrors Members
Sitecore.Configuration Namespace


Settings.RequestErrors Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..RequestErrors Members
Settings..::..RequestErrors Class Properties See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..RequestErrors type exposes the following members.

Properties

Name | Description
UseServerSideRedirect | Gets a value indicating whether the Sitecore uses Server.Transfer instead of Response.Redirect to move to a service page.

See Also

Settings..::..RequestErrors Class
Sitecore.Configuration Namespace


UseServerSideRedirect Property

[image]

Sitecore 6.4.1 API
Settings..::..RequestErrors..::..UseServerSideRedirect Property
Settings..::..RequestErrors Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool UseServerSideRedirect { get; }
Visual Basic
Public Shared ReadOnly Property UseServerSideRedirect As Boolean
    Get
Visual C++
public:
static property bool UseServerSideRedirect {
    bool get ();
}

Field Value

true if Sitecore should use Server.Transfer; otherwise, false.

See Also

Settings..::..RequestErrors Class
Sitecore.Configuration Namespace


Settings.Roles Class

[image]

Sitecore 6.4.1 API
Settings..::..Roles Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Roles
Visual Basic
Public NotInheritable Class Roles
Visual C++
public ref class Roles abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..Roles

See Also

Settings..::..Roles Members
Sitecore.Configuration Namespace


Settings.Roles Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..Roles Members
Settings..::..Roles Class Properties See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..Roles type exposes the following members.

Properties

Name | Description
MaxNameLength | Gets the length of the max name.

See Also

Settings..::..Roles Class
Sitecore.Configuration Namespace


Settings.Roles Properties

[image] [image]

Sitecore 6.4.1 API
Settings..::..Roles Properties
Settings..::..Roles Class See Also Send Feedback

The Settings..::..Roles type exposes the following members.

Properties

Name | Description
MaxNameLength | Gets the length of the max name.

See Also

Settings..::..Roles Class
Sitecore.Configuration Namespace


MaxNameLength Property

[image]

Sitecore 6.4.1 API
Settings..::..Roles..::..MaxNameLength Property
Settings..::..Roles Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int MaxNameLength { get; }
Visual Basic
Public Shared ReadOnly Property MaxNameLength As Integer
    Get
Visual C++
public:
static property int MaxNameLength {
    int get ();
}

Field Value

The length of the max name.

See Also

Settings..::..Roles Class
Sitecore.Configuration Namespace


Settings.Rules Class

[image]

Sitecore 6.4.1 API
Settings..::..Rules Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Rules
Visual Basic
Public NotInheritable Class Rules
Visual C++
public ref class Rules abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..Rules

See Also

Settings..::..Rules Members
Sitecore.Configuration Namespace


Settings.Rules Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..Rules Members
Settings..::..Rules Class Properties See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..Rules type exposes the following members.

Properties

Name | Description
MaxCachedRules | Gets the number of maxed cached rule sets.

See Also

Settings..::..Rules Class
Sitecore.Configuration Namespace


Settings.Rules Properties

[image] [image]

Sitecore 6.4.1 API
Settings..::..Rules Properties
Settings..::..Rules Class See Also Send Feedback

The Settings..::..Rules type exposes the following members.

Properties

Name | Description
MaxCachedRules | Gets the number of maxed cached rule sets.

See Also

Settings..::..Rules Class
Sitecore.Configuration Namespace


MaxCachedRules Property

[image]

Sitecore 6.4.1 API
Settings..::..Rules..::..MaxCachedRules Property
Settings..::..Rules Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int MaxCachedRules { get; }
Visual Basic
Public Shared ReadOnly Property MaxCachedRules As Integer
    Get
Visual C++
public:
static property int MaxCachedRules {
    int get ();
}

Field Value

The number of maxed cached rule sets.

See Also

Settings..::..Rules Class
Sitecore.Configuration Namespace


Settings.Runtime Class

[image]

Sitecore 6.4.1 API
Settings..::..Runtime Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Runtime
Visual Basic
Public NotInheritable Class Runtime
Visual C++
public ref class Runtime abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..Runtime

See Also

Settings..::..Runtime Members
Sitecore.Configuration Namespace


Settings.Runtime Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..Runtime Members
Settings..::..Runtime Class Properties See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..Runtime type exposes the following members.

Properties

Name | Description
EffectiveMaxRequestLengthBytes | Gets the maximum request length in bytes, adjusted to account for system data being transmitted. Defined as maxRequestLength attribute of httpRuntime.
MaxRequestLength | Gets the maximum request length. Defined as maxRequestLength attribute of httpRuntime.

See Also

Settings..::..Runtime Class
Sitecore.Configuration Namespace


EffectiveMaxRequestLengthBytes Property

[image]

Sitecore 6.4.1 API
Settings..::..Runtime..::..EffectiveMaxRequestLengthBytes Property
Settings..::..Runtime Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long EffectiveMaxRequestLengthBytes { get; }
Visual Basic
Public Shared ReadOnly Property EffectiveMaxRequestLengthBytes As Long
    Get
Visual C++
public:
static property long long EffectiveMaxRequestLengthBytes {
    long long get ();
}

Field Value

The max request length bytes.

See Also

Settings..::..Runtime Class
Sitecore.Configuration Namespace


MaxRequestLength Property

[image]

Sitecore 6.4.1 API
Settings..::..Runtime..::..MaxRequestLength Property
Settings..::..Runtime Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int MaxRequestLength { get; }
Visual Basic
Public Shared ReadOnly Property MaxRequestLength As Integer
    Get
Visual C++
public:
static property int MaxRequestLength {
    int get ();
}

Field Value

The length of the max request.

See Also

Settings..::..Runtime Class
Sitecore.Configuration Namespace


Settings.Scripts Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..Scripts Members
Settings..::..Scripts Class Properties See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..Scripts type exposes the following members.

Properties

Name | Description
MaxCachedScripts | Gets the max cached scripts.

See Also

Settings..::..Scripts Class
Sitecore.Configuration Namespace


Settings.Scripts Properties

[image] [image]

Sitecore 6.4.1 API
Settings..::..Scripts Properties
Settings..::..Scripts Class See Also Send Feedback

The Settings..::..Scripts type exposes the following members.

Properties

Name | Description
MaxCachedScripts | Gets the max cached scripts.

See Also

Settings..::..Scripts Class
Sitecore.Configuration Namespace


Settings.Statistics Class

[image]

Sitecore 6.4.1 API
Settings..::..Statistics Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Statistics
Visual Basic
Public NotInheritable Class Statistics
Visual C++
public ref class Statistics abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..Statistics

See Also

Settings..::..Statistics Members
Sitecore.Configuration Namespace


Settings.Statistics Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..Statistics Members
Settings..::..Statistics Class Properties See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..Statistics type exposes the following members.

Properties

Name | Description
CollectRenderingData | Indicates if renderings statistics should be collected.

See Also

Settings..::..Statistics Class
Sitecore.Configuration Namespace


Settings.Statistics Properties

[image] [image]

Sitecore 6.4.1 API
Settings..::..Statistics Properties
Settings..::..Statistics Class See Also Send Feedback

The Settings..::..Statistics type exposes the following members.

Properties

Name | Description
CollectRenderingData | Indicates if renderings statistics should be collected.

See Also

Settings..::..Statistics Class
Sitecore.Configuration Namespace


CollectRenderingData Property

[image]

Sitecore 6.4.1 API
Settings..::..Statistics..::..CollectRenderingData Property
Settings..::..Statistics Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool CollectRenderingData { get; }
Visual Basic
Public Shared ReadOnly Property CollectRenderingData As Boolean
    Get
Visual C++
public:
static property bool CollectRenderingData {
    bool get ();
}

Field Value

true if renderings statistics should be collected; false otherwise.

See Also

Settings..::..Statistics Class
Sitecore.Configuration Namespace


Settings.Tasks Class

[image]

Sitecore 6.4.1 API
Settings..::..Tasks Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Tasks
Visual Basic
Public NotInheritable Class Tasks
Visual C++
public ref class Tasks abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..Tasks

See Also

Settings..::..Tasks Members
Sitecore.Configuration Namespace


Settings.Tasks Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..Tasks Members
Settings..::..Tasks Class Properties See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..Tasks type exposes the following members.

Properties

Name | Description
EmailReminderSubject | Gets the subject to use for email reminders.
EmailReminderText | Gets the leading text to use for email reminders. Custom text will be appended.

See Also

Settings..::..Tasks Class
Sitecore.Configuration Namespace


Settings.Tasks Properties

[image] [image]

Sitecore 6.4.1 API
Settings..::..Tasks Properties
Settings..::..Tasks Class See Also Send Feedback

The Settings..::..Tasks type exposes the following members.

Properties

Name | Description
EmailReminderSubject | Gets the subject to use for email reminders.
EmailReminderText | Gets the leading text to use for email reminders. Custom text will be appended.

See Also

Settings..::..Tasks Class
Sitecore.Configuration Namespace


EmailReminderSubject Property

[image]

Sitecore 6.4.1 API
Settings..::..Tasks..::..EmailReminderSubject Property
Settings..::..Tasks Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string EmailReminderSubject { get; }
Visual Basic
Public Shared ReadOnly Property EmailReminderSubject As String
    Get
Visual C++
public:
static property String^ EmailReminderSubject {
    String^ get ();
}

Field Value

The subject text.

See Also

Settings..::..Tasks Class
Sitecore.Configuration Namespace


EmailReminderText Property

[image]

Sitecore 6.4.1 API
Settings..::..Tasks..::..EmailReminderText Property
Settings..::..Tasks Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string EmailReminderText { get; }
Visual Basic
Public Shared ReadOnly Property EmailReminderText As String
    Get
Visual C++
public:
static property String^ EmailReminderText {
    String^ get ();
}

Field Value

The reminder text.

See Also

Settings..::..Tasks Class
Sitecore.Configuration Namespace


Settings.Templates Class

[image]

Sitecore 6.4.1 API
Settings..::..Templates Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Templates
Visual Basic
Public NotInheritable Class Templates
Visual C++
public ref class Templates abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..Templates

See Also

Settings..::..Templates Members
Sitecore.Configuration Namespace


Settings.Templates Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..Templates Members
Settings..::..Templates Class Properties See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..Templates type exposes the following members.

Properties

Name | Description
MaxInheritanceDepth | Gets the max inheritance depth.

See Also

Settings..::..Templates Class
Sitecore.Configuration Namespace


Settings.Templates Properties

[image] [image]

Sitecore 6.4.1 API
Settings..::..Templates Properties
Settings..::..Templates Class See Also Send Feedback

The Settings..::..Templates type exposes the following members.

Properties

Name | Description
MaxInheritanceDepth | Gets the max inheritance depth.

See Also

Settings..::..Templates Class
Sitecore.Configuration Namespace


MaxInheritanceDepth Property

[image]

Sitecore 6.4.1 API
Settings..::..Templates..::..MaxInheritanceDepth Property
Settings..::..Templates Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int MaxInheritanceDepth { get; }
Visual Basic
Public Shared ReadOnly Property MaxInheritanceDepth As Integer
    Get
Visual C++
public:
static property int MaxInheritanceDepth {
    int get ();
}

Field Value

The max inheritance depth.

See Also

Settings..::..Templates Class
Sitecore.Configuration Namespace


Settings.Trace Class

[image]

Sitecore 6.4.1 API
Settings..::..Trace Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Trace
Visual Basic
Public NotInheritable Class Trace
Visual C++
public ref class Trace abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..Trace

See Also

Settings..::..Trace Members
Sitecore.Configuration Namespace


Settings.Trace Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..Trace Members
Settings..::..Trace Class Properties See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..Trace type exposes the following members.

Properties

Name | Description
FormattingXslFile | Gets the formatting XSL file.

See Also

Settings..::..Trace Class
Sitecore.Configuration Namespace


Settings.Trace Properties

[image] [image]

Sitecore 6.4.1 API
Settings..::..Trace Properties
Settings..::..Trace Class See Also Send Feedback

The Settings..::..Trace type exposes the following members.

Properties

Name | Description
FormattingXslFile | Gets the formatting XSL file.

See Also

Settings..::..Trace Class
Sitecore.Configuration Namespace


FormattingXslFile Property

[image]

Sitecore 6.4.1 API
Settings..::..Trace..::..FormattingXslFile Property
Settings..::..Trace Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string FormattingXslFile { get; }
Visual Basic
Public Shared ReadOnly Property FormattingXslFile As String
    Get
Visual C++
public:
static property String^ FormattingXslFile {
    String^ get ();
}

Field Value

The formatting XSL file.

See Also

Settings..::..Trace Class
Sitecore.Configuration Namespace


Settings.UI Class

[image]

Sitecore 6.4.1 API
Settings..::..UI Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class UI
Visual Basic
Public NotInheritable Class UI
Visual C++
public ref class UI abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..UI

See Also

Settings..::..UI Members
Sitecore.Configuration Namespace


Settings.UI Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..UI Members
Settings..::..UI Class Properties See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..UI type exposes the following members.

Properties

Name | Description
CalendarTimeOfDay | Defines the default time of day.

See Also

Settings..::..UI Class
Sitecore.Configuration Namespace


Settings.UI Properties

[image] [image]

Sitecore 6.4.1 API
Settings..::..UI Properties
Settings..::..UI Class See Also Send Feedback

The Settings..::..UI type exposes the following members.

Properties

Name | Description
CalendarTimeOfDay | Defines the default time of day.

See Also

Settings..::..UI Class
Sitecore.Configuration Namespace


CalendarTimeOfDay Property

[image]

Sitecore 6.4.1 API
Settings..::..UI..::..CalendarTimeOfDay Property
Settings..::..UI Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TimeSpan CalendarTimeOfDay { get; }
Visual Basic
Public Shared ReadOnly Property CalendarTimeOfDay As TimeSpan
    Get
Visual C++
public:
static property TimeSpan CalendarTimeOfDay {
    TimeSpan get ();
}

Field Value

The default time of day.

Remarks

Defines the default time of day when the user user the calendar drop down to select a day. The drop down does not allow the user to set the time of day.

See Also

Settings..::..UI Class
Sitecore.Configuration Namespace


Settings.UnitTests Class

[image]

Sitecore 6.4.1 API
Settings..::..UnitTests Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class UnitTests
Visual Basic
Public NotInheritable Class UnitTests
Visual C++
public ref class UnitTests abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..UnitTests

See Also

Settings..::..UnitTests Members
Sitecore.Configuration Namespace


Settings.UnitTests Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..UnitTests Members
Settings..::..UnitTests Class Properties See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..UnitTests type exposes the following members.

Properties

Name | Description
Host | Gets the host.
Password | Gets the password.
UserName | Gets the name of the user.

See Also

Settings..::..UnitTests Class
Sitecore.Configuration Namespace


Settings.UnitTests Properties

[image] [image]

Sitecore 6.4.1 API
Settings..::..UnitTests Properties
Settings..::..UnitTests Class See Also Send Feedback

The Settings..::..UnitTests type exposes the following members.

Properties

Name | Description
Host | Gets the host.
Password | Gets the password.
UserName | Gets the name of the user.

See Also

Settings..::..UnitTests Class
Sitecore.Configuration Namespace


Host Property

[image]

Sitecore 6.4.1 API
Settings..::..UnitTests..::..Host Property
Settings..::..UnitTests Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Host { get; }
Visual Basic
Public Shared ReadOnly Property Host As String
    Get
Visual C++
public:
static property String^ Host {
    String^ get ();
}

Field Value

The host.

See Also

Settings..::..UnitTests Class
Sitecore.Configuration Namespace


Password Property

[image]

Sitecore 6.4.1 API
Settings..::..UnitTests..::..Password Property
Settings..::..UnitTests Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Password { get; }
Visual Basic
Public Shared ReadOnly Property Password As String
    Get
Visual C++
public:
static property String^ Password {
    String^ get ();
}

Field Value

The password.

See Also

Settings..::..UnitTests Class
Sitecore.Configuration Namespace


UserName Property

[image]

Sitecore 6.4.1 API
Settings..::..UnitTests..::..UserName Property
Settings..::..UnitTests Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string UserName { get; }
Visual Basic
Public Shared ReadOnly Property UserName As String
    Get
Visual C++
public:
static property String^ UserName {
    String^ get ();
}

Field Value

The name of the user.

See Also

Settings..::..UnitTests Class
Sitecore.Configuration Namespace


Settings.Upload Class

[image]

Sitecore 6.4.1 API
Settings..::..Upload Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Upload
Visual Basic
Public NotInheritable Class Upload
Visual C++
public ref class Upload abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..Upload

See Also

Settings..::..Upload Members
Sitecore.Configuration Namespace


Settings.Upload Properties

[image] [image]

Sitecore 6.4.1 API
Settings..::..Upload Properties
Settings..::..Upload Class See Also Send Feedback

The Settings..::..Upload type exposes the following members.

Properties

Name | Description
Classic | Indicates if uploading runs in classic (no flash) mode
MaximumDatabaseUploadSize | Gets the maximum file size that can be uploaded to database.
SimpleUploadOverwriting | Gets a value indicating whether the simple Upload dialog has overwriting on.
UserSelectableDestination | Defines if the user can select the destination database or file.

See Also

Settings..::..Upload Class
Sitecore.Configuration Namespace


Classic Property

[image]

Sitecore 6.4.1 API
Settings..::..Upload..::..Classic Property
Settings..::..Upload Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool Classic { get; }
Visual Basic
Public Shared ReadOnly Property Classic As Boolean
    Get
Visual C++
public:
static property bool Classic {
    bool get ();
}

Field Value

true Indicates if uploading runs in classic (no flash) mode; otherwise, false.

See Also

Settings..::..Upload Class
Sitecore.Configuration Namespace


MaximumDatabaseUploadSize Property

[image]

Sitecore 6.4.1 API
Settings..::..Upload..::..MaximumDatabaseUploadSize Property
Settings..::..Upload Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long MaximumDatabaseUploadSize { get; }
Visual Basic
Public Shared ReadOnly Property MaximumDatabaseUploadSize As Long
    Get
Visual C++
public:
static property long long MaximumDatabaseUploadSize {
    long long get ();
}

Field Value

The size of the max file.

See Also

Settings..::..Upload Class
Sitecore.Configuration Namespace


SimpleUploadOverwriting Property

[image]

Sitecore 6.4.1 API
Settings..::..Upload..::..SimpleUploadOverwriting Property
Settings..::..Upload Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool SimpleUploadOverwriting { get; }
Visual Basic
Public Shared ReadOnly Property SimpleUploadOverwriting As Boolean
    Get
Visual C++
public:
static property bool SimpleUploadOverwriting {
    bool get ();
}

Field Value

true if the simple Upload dialog has overwriting on; otherwise, false.

See Also

Settings..::..Upload Class
Sitecore.Configuration Namespace


UserSelectableDestination Property

[image]

Sitecore 6.4.1 API
Settings..::..Upload..::..UserSelectableDestination Property
Settings..::..Upload Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool UserSelectableDestination { get; }
Visual Basic
Public Shared ReadOnly Property UserSelectableDestination As Boolean
    Get
Visual C++
public:
static property bool UserSelectableDestination {
    bool get ();
}

Field Value

true if the user can select the destination; otherwise, false.

See Also

Settings..::..Upload Class
Sitecore.Configuration Namespace


Settings.Validators Class

[image]

Sitecore 6.4.1 API
Settings..::..Validators Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Validators
Visual Basic
Public NotInheritable Class Validators
Visual C++
public ref class Validators abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..Validators

See Also

Settings..::..Validators Members
Sitecore.Configuration Namespace


Settings.Validators Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..Validators Members
Settings..::..Validators Class Properties See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..Validators type exposes the following members.

Properties

Name | Description
AutomaticUpdate | Gets a value indicating whether validators are automatically run in the content editor.
BlockingExpiry | Gets the blocking expiry.
BlockingSleep | Gets the blocking sleep.
Expiry | Gets the expiry.
UpdateDelay | Gets the update delay.
UpdateFrequency | Gets the update frequency.

See Also

Settings..::..Validators Class
Sitecore.Configuration Namespace


Settings.Validators Properties

[image] [image]

Sitecore 6.4.1 API
Settings..::..Validators Properties
Settings..::..Validators Class See Also Send Feedback

The Settings..::..Validators type exposes the following members.

Properties

Name | Description
AutomaticUpdate | Gets a value indicating whether validators are automatically run in the content editor.
BlockingExpiry | Gets the blocking expiry.
BlockingSleep | Gets the blocking sleep.
Expiry | Gets the expiry.
UpdateDelay | Gets the update delay.
UpdateFrequency | Gets the update frequency.

See Also

Settings..::..Validators Class
Sitecore.Configuration Namespace


AutomaticUpdate Property

[image]

Sitecore 6.4.1 API
Settings..::..Validators..::..AutomaticUpdate Property
Settings..::..Validators Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool AutomaticUpdate { get; }
Visual Basic
Public Shared ReadOnly Property AutomaticUpdate As Boolean
    Get
Visual C++
public:
static property bool AutomaticUpdate {
    bool get ();
}

Field Value

true if validators are automatically run in the content editor; otherwise, false.

Remarks

Setting this to 0 disables automatic updates.

See Also

Settings..::..Validators Class
Sitecore.Configuration Namespace


BlockingExpiry Property

[image]

Sitecore 6.4.1 API
Settings..::..Validators..::..BlockingExpiry Property
Settings..::..Validators Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TimeSpan BlockingExpiry { get; }
Visual Basic
Public Shared ReadOnly Property BlockingExpiry As TimeSpan
    Get
Visual C++
public:
static property TimeSpan BlockingExpiry {
    TimeSpan get ();
}

Field Value

The blocking expiry.

See Also

Settings..::..Validators Class
Sitecore.Configuration Namespace


BlockingSleep Property

[image]

Sitecore 6.4.1 API
Settings..::..Validators..::..BlockingSleep Property
Settings..::..Validators Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TimeSpan BlockingSleep { get; }
Visual Basic
Public Shared ReadOnly Property BlockingSleep As TimeSpan
    Get
Visual C++
public:
static property TimeSpan BlockingSleep {
    TimeSpan get ();
}

Field Value

The blocking sleep.

See Also

Settings..::..Validators Class
Sitecore.Configuration Namespace


Expiry Property

[image]

Sitecore 6.4.1 API
Settings..::..Validators..::..Expiry Property
Settings..::..Validators Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TimeSpan Expiry { get; }
Visual Basic
Public Shared ReadOnly Property Expiry As TimeSpan
    Get
Visual C++
public:
static property TimeSpan Expiry {
    TimeSpan get ();
}

Field Value

The expiry.

See Also

Settings..::..Validators Class
Sitecore.Configuration Namespace


UpdateDelay Property

[image]

Sitecore 6.4.1 API
Settings..::..Validators..::..UpdateDelay Property
Settings..::..Validators Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int UpdateDelay { get; }
Visual Basic
Public Shared ReadOnly Property UpdateDelay As Integer
    Get
Visual C++
public:
static property int UpdateDelay {
    int get ();
}

Field Value

The update delay.

See Also

Settings..::..Validators Class
Sitecore.Configuration Namespace


UpdateFrequency Property

[image]

Sitecore 6.4.1 API
Settings..::..Validators..::..UpdateFrequency Property
Settings..::..Validators Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int UpdateFrequency { get; }
Visual Basic
Public Shared ReadOnly Property UpdateFrequency As Integer
    Get
Visual C++
public:
static property int UpdateFrequency {
    int get ();
}

Field Value

The update frequency.

See Also

Settings..::..Validators Class
Sitecore.Configuration Namespace


Settings.WebConfig Class

[image]

Sitecore 6.4.1 API
Settings..::..WebConfig Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class WebConfig
Visual Basic
Public NotInheritable Class WebConfig
Visual C++
public ref class WebConfig abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..WebConfig

See Also

Settings..::..WebConfig Members
Sitecore.Configuration Namespace


Settings.WebConfig Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..WebConfig Members
Settings..::..WebConfig Class Methods See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..WebConfig type exposes the following members.

Methods

Name | Description
GetNodeAttribute | Gets the value of an attribute of the node specified by xpath.
GetNodeValue | Gets the value of the node specified by xpath.
GetWebConfig | Gets web.config as an XmlDocument.
NodeExists | Determines if a node satisfying the specified xpath exists in web.config.

See Also

Settings..::..WebConfig Class
Sitecore.Configuration Namespace


Settings.WebConfig Methods

[image] [image]

Sitecore 6.4.1 API
Settings..::..WebConfig Methods
Settings..::..WebConfig Class See Also Send Feedback

The Settings..::..WebConfig type exposes the following members.

Methods

Name | Description
GetNodeAttribute | Gets the value of an attribute of the node specified by xpath.
GetNodeValue | Gets the value of the node specified by xpath.
GetWebConfig | Gets web.config as an XmlDocument.
NodeExists | Determines if a node satisfying the specified xpath exists in web.config.

See Also

Settings..::..WebConfig Class
Sitecore.Configuration Namespace


GetNodeAttribute Method

[image]

Sitecore 6.4.1 API
Settings..::..WebConfig..::..GetNodeAttribute Method
Settings..::..WebConfig Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetNodeAttribute(
    string xpath,
    string attributeName
)
Visual Basic
Public Shared Function GetNodeAttribute ( _
    xpath As String, _
    attributeName As String _
) As String
Visual C++
public:
static String^ GetNodeAttribute(
    String^ xpath,
    String^ attributeName
)

Parameters

xpath
Type: System..::..String
The xpath.
attributeName
Type: System..::..String
Name of the attribute.

Return Value

The get node attribute.

See Also

Settings..::..WebConfig Class
Sitecore.Configuration Namespace


GetNodeValue Method

[image]

Sitecore 6.4.1 API
Settings..::..WebConfig..::..GetNodeValue Method
Settings..::..WebConfig Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetNodeValue(
    string xpath
)
Visual Basic
Public Shared Function GetNodeValue ( _
    xpath As String _
) As String
Visual C++
public:
static String^ GetNodeValue(
    String^ xpath
)

Parameters

xpath
Type: System..::..String
The xpath.

Return Value

The get node value.

See Also

Settings..::..WebConfig Class
Sitecore.Configuration Namespace


GetWebConfig Method

[image]

Sitecore 6.4.1 API
Settings..::..WebConfig..::..GetWebConfig Method
Settings..::..WebConfig Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static XmlDocument GetWebConfig()
Visual Basic
Public Shared Function GetWebConfig As XmlDocument
Visual C++
public:
static XmlDocument^ GetWebConfig()

Return Value

[Missing <returns> documentation for "M:Sitecore.Configuration.Settings.WebConfig.GetWebConfig"]

See Also

Settings..::..WebConfig Class
Sitecore.Configuration Namespace


NodeExists Method

[image]

Sitecore 6.4.1 API
Settings..::..WebConfig..::..NodeExists Method
Settings..::..WebConfig Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool NodeExists(
    string xpath
)
Visual Basic
Public Shared Function NodeExists ( _
    xpath As String _
) As Boolean
Visual C++
public:
static bool NodeExists(
    String^ xpath
)

Parameters

xpath
Type: System..::..String
The xpath.

Return Value

The node exists.

See Also

Settings..::..WebConfig Class
Sitecore.Configuration Namespace


Settings.WebDAV Class

[image]

Sitecore 6.4.1 API
Settings..::..WebDAV Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class WebDAV
Visual Basic
Public NotInheritable Class WebDAV
Visual C++
public ref class WebDAV abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..WebDAV

See Also

Settings..::..WebDAV Members
Sitecore.Configuration Namespace


Settings.WebDAV Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..WebDAV Members
Settings..::..WebDAV Class Properties See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..WebDAV type exposes the following members.

Properties

Name | Description
AssociateUsernameWithLink | If "true" Sitecore associates the username of the current Sitecore user with a WebDAV link via a server side object which stores additional information as well, such as the current database and language. Sitecore will not prompt for a username and password when serving WebDAV requests, as long as the server side object still exists at the time of the request. This approach could potentially allow unauthorized access on unsecure networks. Default value: false
Enabled | Gets a value indicating whether the WebDAV feature is enabled.
EngineLogLevel | Gets the ITHit engine log level. Default value is Off. Supported values: All, Debug, Info, Warn, Error, Fatal, Off
FileDropAreaMediaLocation | Gets the path to the location of media items related to a File Drop Area media items.
Folder | Gets the path to WebDAV folder.
LicenseFile | Gets the path to the ITHit Web DAV license file.
MediaHandlerPrefix | Gets the name of the media handler.
PromptWhenUsernameUnknown | If "true" Sitecore will prompt for a username and password if the username is not available. If "false" Sitecore will not prompt for a username and password if the username even if it is not available. Sitecore will only provide access to files, in this case, if they are available to the Anonymous user. Default value: true
URLDisplayName | Gets the WebDAV URL Display Name.
UseShortURL | Uses a shorter URL format to define the path to the WebDAV folder, based on the unique ID of the folder. Setting this to false, allows you to define a static path for a WebDAV folder, but may impact performance. Default value: true

See Also

Settings..::..WebDAV Class
Sitecore.Configuration Namespace


Settings.WebDAV Properties

[image] [image]

Sitecore 6.4.1 API
Settings..::..WebDAV Properties
Settings..::..WebDAV Class See Also Send Feedback

The Settings..::..WebDAV type exposes the following members.

Properties

Name | Description
AssociateUsernameWithLink | If "true" Sitecore associates the username of the current Sitecore user with a WebDAV link via a server side object which stores additional information as well, such as the current database and language. Sitecore will not prompt for a username and password when serving WebDAV requests, as long as the server side object still exists at the time of the request. This approach could potentially allow unauthorized access on unsecure networks. Default value: false
Enabled | Gets a value indicating whether the WebDAV feature is enabled.
EngineLogLevel | Gets the ITHit engine log level. Default value is Off. Supported values: All, Debug, Info, Warn, Error, Fatal, Off
FileDropAreaMediaLocation | Gets the path to the location of media items related to a File Drop Area media items.
Folder | Gets the path to WebDAV folder.
LicenseFile | Gets the path to the ITHit Web DAV license file.
MediaHandlerPrefix | Gets the name of the media handler.
PromptWhenUsernameUnknown | If "true" Sitecore will prompt for a username and password if the username is not available. If "false" Sitecore will not prompt for a username and password if the username even if it is not available. Sitecore will only provide access to files, in this case, if they are available to the Anonymous user. Default value: true
URLDisplayName | Gets the WebDAV URL Display Name.
UseShortURL | Uses a shorter URL format to define the path to the WebDAV folder, based on the unique ID of the folder. Setting this to false, allows you to define a static path for a WebDAV folder, but may impact performance. Default value: true

See Also

Settings..::..WebDAV Class
Sitecore.Configuration Namespace


AssociateUsernameWithLink Property

[image]

Sitecore 6.4.1 API
Settings..::..WebDAV..::..AssociateUsernameWithLink Property
Settings..::..WebDAV Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Tristate AssociateUsernameWithLink { get; }
Visual Basic
Public Shared ReadOnly Property AssociateUsernameWithLink As Tristate
    Get
Visual C++
public:
static property Tristate AssociateUsernameWithLink {
    Tristate get ();
}

Field Value

true if Sitecore should associate the username of the current Sitecore user with a WebDAV link via a server side object; otherwise, false.

See Also

Settings..::..WebDAV Class
Sitecore.Configuration Namespace


Enabled Property

[image]

Sitecore 6.4.1 API
Settings..::..WebDAV..::..Enabled Property
Settings..::..WebDAV Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool Enabled { get; }
Visual Basic
Public Shared ReadOnly Property Enabled As Boolean
    Get
Visual C++
public:
static property bool Enabled {
    bool get ();
}

Field Value

true if WebDAV feature should be enabled; otherwise, false.

See Also

Settings..::..WebDAV Class
Sitecore.Configuration Namespace


EngineLogLevel Property

[image]

Sitecore 6.4.1 API
Settings..::..WebDAV..::..EngineLogLevel Property
Settings..::..WebDAV Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string EngineLogLevel { get; }
Visual Basic
Public Shared ReadOnly Property EngineLogLevel As String
    Get
Visual C++
public:
static property String^ EngineLogLevel {
    String^ get ();
}

Field Value

The engine log level.

See Also

Settings..::..WebDAV Class
Sitecore.Configuration Namespace


FileDropAreaMediaLocation Property

[image]

Sitecore 6.4.1 API
Settings..::..WebDAV..::..FileDropAreaMediaLocation Property
Settings..::..WebDAV Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string FileDropAreaMediaLocation { get; }
Visual Basic
Public Shared ReadOnly Property FileDropAreaMediaLocation As String
    Get
Visual C++
public:
static property String^ FileDropAreaMediaLocation {
    String^ get ();
}

Field Value

The location of media items related to a File Drop Area media items.

See Also

Settings..::..WebDAV Class
Sitecore.Configuration Namespace


Folder Property

[image]

Sitecore 6.4.1 API
Settings..::..WebDAV..::..Folder Property
Settings..::..WebDAV Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Folder { get; }
Visual Basic
Public Shared ReadOnly Property Folder As String
    Get
Visual C++
public:
static property String^ Folder {
    String^ get ();
}

Field Value

The WebDAV folder.

See Also

Settings..::..WebDAV Class
Sitecore.Configuration Namespace


LicenseFile Property

[image]

Sitecore 6.4.1 API
Settings..::..WebDAV..::..LicenseFile Property
Settings..::..WebDAV Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string LicenseFile { get; }
Visual Basic
Public Shared ReadOnly Property LicenseFile As String
    Get
Visual C++
public:
static property String^ LicenseFile {
    String^ get ();
}

Field Value

Default value: MakePath(String, String)(DataFolder, "license.lic")

See Also

Settings..::..WebDAV Class
Sitecore.Configuration Namespace


MediaHandlerPrefix Property

[image]

Sitecore 6.4.1 API
Settings..::..WebDAV..::..MediaHandlerPrefix Property
Settings..::..WebDAV Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string MediaHandlerPrefix { get; }
Visual Basic
Public Shared ReadOnly Property MediaHandlerPrefix As String
    Get
Visual C++
public:
static property String^ MediaHandlerPrefix {
    String^ get ();
}

Field Value

The name of the media handler.

See Also

Settings..::..WebDAV Class
Sitecore.Configuration Namespace


PromptWhenUsernameUnknown Property

[image]

Sitecore 6.4.1 API
Settings..::..WebDAV..::..PromptWhenUsernameUnknown Property
Settings..::..WebDAV Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool PromptWhenUsernameUnknown { get; }
Visual Basic
Public Shared ReadOnly Property PromptWhenUsernameUnknown As Boolean
    Get
Visual C++
public:
static property bool PromptWhenUsernameUnknown {
    bool get ();
}

Field Value

true if Web DAV requests require authentication; otherwise, false.

See Also

Settings..::..WebDAV Class
Sitecore.Configuration Namespace


URLDisplayName Property

[image]

Sitecore 6.4.1 API
Settings..::..WebDAV..::..URLDisplayName Property
Settings..::..WebDAV Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string URLDisplayName { get; }
Visual Basic
Public Shared ReadOnly Property URLDisplayName As String
    Get
Visual C++
public:
static property String^ URLDisplayName {
    String^ get ();
}

Field Value

The WebDAV URL Display Name.

See Also

Settings..::..WebDAV Class
Sitecore.Configuration Namespace


UseShortURL Property

[image]

Sitecore 6.4.1 API
Settings..::..WebDAV..::..UseShortURL Property
Settings..::..WebDAV Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool UseShortURL { get; }
Visual Basic
Public Shared ReadOnly Property UseShortURL As Boolean
    Get
Visual C++
public:
static property bool UseShortURL {
    bool get ();
}

Field Value

true if WebDAV engine should generate and parse URLs in a short form; otherwise, false.

See Also

Settings..::..WebDAV Class
Sitecore.Configuration Namespace


Settings.WebEdit Class

[image]

Sitecore 6.4.1 API
Settings..::..WebEdit Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class WebEdit
Visual Basic
Public NotInheritable Class WebEdit
Visual C++
public ref class WebEdit abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..WebEdit

See Also

Settings..::..WebEdit Members
Sitecore.Configuration Namespace


Settings.WebEdit Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..WebEdit Members
Settings..::..WebEdit Class Properties See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..WebEdit type exposes the following members.

Properties

Name | Description
Classic | Obsolete. Gets a value indicating whether this Settings..::..WebEdit is classic.
ContentEditorStyle | Gets the content editor Iframe CSS style.
ContentEditorStylesheet | Gets the content editor stylesheet.
CssClass | Obsolete. Gets the CSS class.
DefaultButtonPath | Gets the default button path.
DisabledCssClass | Obsolete. Gets the disabled CSS class.
DisabledDot | Obsolete. Gets the disabled dot.
DrawContentDotsByDefault | Obsolete. Gets a value indicating whether WebEdit draws the content dots by default.
EnabledDot | Obsolete. Gets the enabled dot.
HSpace | Obsolete. Gets the horizontal space.
ShowNumberOfLockedItemsOnButton | Gets a value indicating whether [show number of locked items on button].
SpaceCssClass | Obsolete. Gets the spacer CSS class.
UsePopupContentEditor | Gets a value indicating whether WebEdit uses the popup content editor.
VSpace | Obsolete. Gets the vertical space.

See Also

Settings..::..WebEdit Class
Sitecore.Configuration Namespace


Settings.WebEdit Properties

[image] [image]

Sitecore 6.4.1 API
Settings..::..WebEdit Properties
Settings..::..WebEdit Class See Also Send Feedback

The Settings..::..WebEdit type exposes the following members.

Properties

Name | Description
Classic | Obsolete. Gets a value indicating whether this Settings..::..WebEdit is classic.
ContentEditorStyle | Gets the content editor Iframe CSS style.
ContentEditorStylesheet | Gets the content editor stylesheet.
CssClass | Obsolete. Gets the CSS class.
DefaultButtonPath | Gets the default button path.
DisabledCssClass | Obsolete. Gets the disabled CSS class.
DisabledDot | Obsolete. Gets the disabled dot.
DrawContentDotsByDefault | Obsolete. Gets a value indicating whether WebEdit draws the content dots by default.
EnabledDot | Obsolete. Gets the enabled dot.
HSpace | Obsolete. Gets the horizontal space.
ShowNumberOfLockedItemsOnButton | Gets a value indicating whether [show number of locked items on button].
SpaceCssClass | Obsolete. Gets the spacer CSS class.
UsePopupContentEditor | Gets a value indicating whether WebEdit uses the popup content editor.
VSpace | Obsolete. Gets the vertical space.

See Also

Settings..::..WebEdit Class
Sitecore.Configuration Namespace


Classic Property

[image]

Sitecore 6.4.1 API
Settings..::..WebEdit..::..Classic Property
Settings..::..WebEdit Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public static bool Classic { get; }
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Shared ReadOnly Property Classic As Boolean
    Get
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public:
static property bool Classic {
    bool get ();
}

Field Value

true if classic; otherwise, false.

See Also

Settings..::..WebEdit Class
Sitecore.Configuration Namespace


ContentEditorStyle Property

[image]

Sitecore 6.4.1 API
Settings..::..WebEdit..::..ContentEditorStyle Property
Settings..::..WebEdit Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ContentEditorStyle { get; }
Visual Basic
Public Shared ReadOnly Property ContentEditorStyle As String
    Get
Visual C++
public:
static property String^ ContentEditorStyle {
    String^ get ();
}

Field Value

The content editor Iframe CSS style.

See Also

Settings..::..WebEdit Class
Sitecore.Configuration Namespace


ContentEditorStylesheet Property

[image]

Sitecore 6.4.1 API
Settings..::..WebEdit..::..ContentEditorStylesheet Property
Settings..::..WebEdit Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ContentEditorStylesheet { get; }
Visual Basic
Public Shared ReadOnly Property ContentEditorStylesheet As String
    Get
Visual C++
public:
static property String^ ContentEditorStylesheet {
    String^ get ();
}

Field Value

The content editor stylesheet.

See Also

Settings..::..WebEdit Class
Sitecore.Configuration Namespace


CssClass Property

[image]

Sitecore 6.4.1 API
Settings..::..WebEdit..::..CssClass Property
Settings..::..WebEdit Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public static string CssClass { get; }
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Shared ReadOnly Property CssClass As String
    Get
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public:
static property String^ CssClass {
    String^ get ();
}

Field Value

The CSS class.

See Also

Settings..::..WebEdit Class
Sitecore.Configuration Namespace


DefaultButtonPath Property

[image]

Sitecore 6.4.1 API
Settings..::..WebEdit..::..DefaultButtonPath Property
Settings..::..WebEdit Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string DefaultButtonPath { get; }
Visual Basic
Public Shared ReadOnly Property DefaultButtonPath As String
    Get
Visual C++
public:
static property String^ DefaultButtonPath {
    String^ get ();
}

Field Value

The default button path.

See Also

Settings..::..WebEdit Class
Sitecore.Configuration Namespace


DisabledCssClass Property

[image]

Sitecore 6.4.1 API
Settings..::..WebEdit..::..DisabledCssClass Property
Settings..::..WebEdit Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public static string DisabledCssClass { get; }
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Shared ReadOnly Property DisabledCssClass As String
    Get
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public:
static property String^ DisabledCssClass {
    String^ get ();
}

Field Value

The disabled CSS class.

See Also

Settings..::..WebEdit Class
Sitecore.Configuration Namespace


DisabledDot Property

[image]

Sitecore 6.4.1 API
Settings..::..WebEdit..::..DisabledDot Property
Settings..::..WebEdit Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public static string DisabledDot { get; }
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Shared ReadOnly Property DisabledDot As String
    Get
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public:
static property String^ DisabledDot {
    String^ get ();
}

Field Value

The disabled dot.

See Also

Settings..::..WebEdit Class
Sitecore.Configuration Namespace


DrawContentDotsByDefault Property

[image]

Sitecore 6.4.1 API
Settings..::..WebEdit..::..DrawContentDotsByDefault Property
Settings..::..WebEdit Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public static bool DrawContentDotsByDefault { get; }
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Shared ReadOnly Property DrawContentDotsByDefault As Boolean
    Get
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public:
static property bool DrawContentDotsByDefault {
    bool get ();
}

Field Value

true if the WebEdit draws the content dots by default; otherwise, false.

See Also

Settings..::..WebEdit Class
Sitecore.Configuration Namespace


EnabledDot Property

[image]

Sitecore 6.4.1 API
Settings..::..WebEdit..::..EnabledDot Property
Settings..::..WebEdit Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public static string EnabledDot { get; }
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Shared ReadOnly Property EnabledDot As String
    Get
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public:
static property String^ EnabledDot {
    String^ get ();
}

Field Value

The enabled dot.

See Also

Settings..::..WebEdit Class
Sitecore.Configuration Namespace


HSpace Property

[image]

Sitecore 6.4.1 API
Settings..::..WebEdit..::..HSpace Property
Settings..::..WebEdit Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public static int HSpace { get; }
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Shared ReadOnly Property HSpace As Integer
    Get
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public:
static property int HSpace {
    int get ();
}

Field Value

The horizontal space.

See Also

Settings..::..WebEdit Class
Sitecore.Configuration Namespace


ShowNumberOfLockedItemsOnButton Property

[image]

Sitecore 6.4.1 API
Settings..::..WebEdit..::..ShowNumberOfLockedItemsOnButton Property
Settings..::..WebEdit Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool ShowNumberOfLockedItemsOnButton { get; }
Visual Basic
Public Shared ReadOnly Property ShowNumberOfLockedItemsOnButton As Boolean
    Get
Visual C++
public:
static property bool ShowNumberOfLockedItemsOnButton {
    bool get ();
}

Field Value

true if [show number of locked items on button]; otherwise, false.

See Also

Settings..::..WebEdit Class
Sitecore.Configuration Namespace


SpaceCssClass Property

[image]

Sitecore 6.4.1 API
Settings..::..WebEdit..::..SpaceCssClass Property
Settings..::..WebEdit Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public static string SpaceCssClass { get; }
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Shared ReadOnly Property SpaceCssClass As String
    Get
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public:
static property String^ SpaceCssClass {
    String^ get ();
}

Field Value

The spacer CSS class.

See Also

Settings..::..WebEdit Class
Sitecore.Configuration Namespace


UsePopupContentEditor Property

[image]

Sitecore 6.4.1 API
Settings..::..WebEdit..::..UsePopupContentEditor Property
Settings..::..WebEdit Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool UsePopupContentEditor { get; }
Visual Basic
Public Shared ReadOnly Property UsePopupContentEditor As Boolean
    Get
Visual C++
public:
static property bool UsePopupContentEditor {
    bool get ();
}

Field Value

true if the WebEdit uses the popup content editor; otherwise, false.

See Also

Settings..::..WebEdit Class
Sitecore.Configuration Namespace


VSpace Property

[image]

Sitecore 6.4.1 API
Settings..::..WebEdit..::..VSpace Property
Settings..::..WebEdit Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public static int VSpace { get; }
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Shared ReadOnly Property VSpace As Integer
    Get
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public:
static property int VSpace {
    int get ();
}

Field Value

The vertical space.

See Also

Settings..::..WebEdit Class
Sitecore.Configuration Namespace


Settings.WordOCX Class

[image]

Sitecore 6.4.1 API
Settings..::..WordOCX Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class WordOCX
Visual Basic
Public NotInheritable Class WordOCX
Visual C++
public ref class WordOCX abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..WordOCX

See Also

Settings..::..WordOCX Members
Sitecore.Configuration Namespace


Settings.WordOCX Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..WordOCX Members
Settings..::..WordOCX Class Properties See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..WordOCX type exposes the following members.

Properties

Name | Description
Height | Gets the height.
Padding | Gets the padding.
Width | Gets the width.

See Also

Settings..::..WordOCX Class
Sitecore.Configuration Namespace


Settings.WordOCX Properties

[image] [image]

Sitecore 6.4.1 API
Settings..::..WordOCX Properties
Settings..::..WordOCX Class See Also Send Feedback

The Settings..::..WordOCX type exposes the following members.

Properties

Name | Description
Height | Gets the height.
Padding | Gets the padding.
Width | Gets the width.

See Also

Settings..::..WordOCX Class
Sitecore.Configuration Namespace


Height Property

[image]

Sitecore 6.4.1 API
Settings..::..WordOCX..::..Height Property
Settings..::..WordOCX Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Height { get; }
Visual Basic
Public Shared ReadOnly Property Height As String
    Get
Visual C++
public:
static property String^ Height {
    String^ get ();
}

Field Value

The height.

See Also

Settings..::..WordOCX Class
Sitecore.Configuration Namespace


Padding Property

[image]

Sitecore 6.4.1 API
Settings..::..WordOCX..::..Padding Property
Settings..::..WordOCX Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Padding { get; }
Visual Basic
Public Shared ReadOnly Property Padding As String
    Get
Visual C++
public:
static property String^ Padding {
    String^ get ();
}

Field Value

The padding.

See Also

Settings..::..WordOCX Class
Sitecore.Configuration Namespace


Width Property

[image]

Sitecore 6.4.1 API
Settings..::..WordOCX..::..Width Property
Settings..::..WordOCX Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Width { get; }
Visual Basic
Public Shared ReadOnly Property Width As String
    Get
Visual C++
public:
static property String^ Width {
    String^ get ();
}

Field Value

The width.

See Also

Settings..::..WordOCX Class
Sitecore.Configuration Namespace


Settings.WorldLingo Class

[image]

Sitecore 6.4.1 API
Settings..::..WorldLingo Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class WorldLingo
Visual Basic
Public NotInheritable Class WorldLingo
Visual C++
public ref class WorldLingo abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..WorldLingo

See Also

Settings..::..WorldLingo Members
Sitecore.Configuration Namespace


Settings.WorldLingo Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..WorldLingo Members
Settings..::..WorldLingo Class Properties See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..WorldLingo type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating whether WorldLingo is enabled.
Password | Gets the password.
Url | Gets the URL.

See Also

Settings..::..WorldLingo Class
Sitecore.Configuration Namespace


Settings.WorldLingo Properties

[image] [image]

Sitecore 6.4.1 API
Settings..::..WorldLingo Properties
Settings..::..WorldLingo Class See Also Send Feedback

The Settings..::..WorldLingo type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating whether WorldLingo is enabled.
Password | Gets the password.
Url | Gets the URL.

See Also

Settings..::..WorldLingo Class
Sitecore.Configuration Namespace


Enabled Property

[image]

Sitecore 6.4.1 API
Settings..::..WorldLingo..::..Enabled Property
Settings..::..WorldLingo Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool Enabled { get; }
Visual Basic
Public Shared ReadOnly Property Enabled As Boolean
    Get
Visual C++
public:
static property bool Enabled {
    bool get ();
}

Field Value

true if enabled; otherwise, false.

See Also

Settings..::..WorldLingo Class
Sitecore.Configuration Namespace


Password Property

[image]

Sitecore 6.4.1 API
Settings..::..WorldLingo..::..Password Property
Settings..::..WorldLingo Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Password { get; }
Visual Basic
Public Shared ReadOnly Property Password As String
    Get
Visual C++
public:
static property String^ Password {
    String^ get ();
}

Field Value

The password.

See Also

Settings..::..WorldLingo Class
Sitecore.Configuration Namespace


Url Property

[image]

Sitecore 6.4.1 API
Settings..::..WorldLingo..::..Url Property
Settings..::..WorldLingo Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Url { get; }
Visual Basic
Public Shared ReadOnly Property Url As String
    Get
Visual C++
public:
static property String^ Url {
    String^ get ();
}

Field Value

The URL.

See Also

Settings..::..WorldLingo Class
Sitecore.Configuration Namespace


Settings.XmlControls Class

[image]

Sitecore 6.4.1 API
Settings..::..XmlControls Class
Settings Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class XmlControls
Visual Basic
Public NotInheritable Class XmlControls
Visual C++
public ref class XmlControls abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..Settings..::..XmlControls

See Also

Settings..::..XmlControls Members
Sitecore.Configuration Namespace


Settings.XmlControls Members

[image] [image]

Sitecore 6.4.1 API
Settings..::..XmlControls Members
Settings..::..XmlControls Class Properties See Also Send Feedback

The Settings class encapsulates the web.config file and provides easy access to the values therein.

The Settings..::..XmlControls type exposes the following members.

Properties

Name | Description
OutputDebugFiles | Gets a value indicating whether the code for compiled XmlControls will be saved as *.cs files in to debug folders.
ThrowException | Gets a value indicating whether parsing XmlControls can throw an exception.

See Also

Settings..::..XmlControls Class
Sitecore.Configuration Namespace


Settings.XmlControls Properties

[image] [image]

Sitecore 6.4.1 API
Settings..::..XmlControls Properties
Settings..::..XmlControls Class See Also Send Feedback

The Settings..::..XmlControls type exposes the following members.

Properties

Name | Description
OutputDebugFiles | Gets a value indicating whether the code for compiled XmlControls will be saved as *.cs files in to debug folders.
ThrowException | Gets a value indicating whether parsing XmlControls can throw an exception.

See Also

Settings..::..XmlControls Class
Sitecore.Configuration Namespace


OutputDebugFiles Property

[image]

Sitecore 6.4.1 API
Settings..::..XmlControls..::..OutputDebugFiles Property
Settings..::..XmlControls Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool OutputDebugFiles { get; }
Visual Basic
Public Shared ReadOnly Property OutputDebugFiles As Boolean
    Get
Visual C++
public:
static property bool OutputDebugFiles {
    bool get ();
}

Field Value

true if the code for compiled XMLControls should be saved; otherwise, false.

See Also

Settings..::..XmlControls Class
Sitecore.Configuration Namespace


ThrowException Property

[image]

Sitecore 6.4.1 API
Settings..::..XmlControls..::..ThrowException Property
Settings..::..XmlControls Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool ThrowException { get; }
Visual Basic
Public Shared ReadOnly Property ThrowException As Boolean
    Get
Visual C++
public:
static property bool ThrowException {
    bool get ();
}

Field Value

true if parsing XmlControls can throw an exception; otherwise, false.

See Also

Settings..::..XmlControls Class
Sitecore.Configuration Namespace


State Class

[image]

Sitecore 6.4.1 API
State Class
Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public sealed class State
Visual Basic
Public NotInheritable Class State
Visual C++
public ref class State sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..State

See Also

State Members
Sitecore.Configuration Namespace


State Members

[image] [image]

Sitecore 6.4.1 API
State Members
State Class Constructors Methods Properties See Also Send Feedback

The State type exposes the following members.

Constructors

 | Name | Description
Public method | State | Initializes a new instance of the State class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCustom | Gets a custom State variable.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RemoveCustom | Removes a custom State variable.
 | SetActivePublish | Set active publishing info.
 | SetCustom | Sets a custom State variable.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ActivePublishDate | Gets the active publish date.
ActivePublishGroups | Gets the active publish groups.
AddRenderings | Gets an array list of renderings to add to the default list of renderings.
ClientLanguage | Gets or sets the ISO language code the the current client language.
ClientUsesOSWindows | Obsolete. Gets or sets a value indicating whether the client uses OS windows.
CommitDisabled | Option to disable commits on items.
ContentDatabase | Gets or sets the content database.
CurrentLayout | Obsolete. Gets or sets the ID or name of the current layout.
CurrentLayoutChanged | Obsolete. Gets or sets a boolean that indicates if current layout was changed.
CustomLayout | Gets or sets the ID or name of a custom layout to use for the current page request.
DebugMode | Gets or sets a boolean that indicates if Sitecore is in debug mode.
Desktop | Gets or sets the path of the client desktop webpage.
DisableDefaultRenderings | Gets or sets a boolean that indicates if the default renderings are disabled or not.
DisableItemChangeRegistering | Gets or sets a boolean that indicates of item changes are registered.
DispatchEvents | Gets or sets a boolean that indicates if events are dispatched.
DrawRenderingBorders | Get or sets a boolean that indicates if borders are drawn around renderings.
ExtensionObjects | Gets the hash list of XSL extention objects.
Form | Gets or sets the current form collection from web page.
Language | Get or sets the current language code.
LastError | Gets a hash list of sections containing the last errors.
LayoutGroup | Obsolete. Gets or sets the current layout group.
MasterItem | Gets or sets the current master item.
PreviewDate | Gets or sets the current date/time of a preview.
PreviewGroups | Gets or sets the current publishing groups of a preview.
Previewing | Gets a value indicating whether the system is previewing.
Profiling | Gets or sets a boolean that indicates if profiling data are generated.
RemoveRenderings | Gets a has array list of renderings that should be removed from the list of default renderings.
ResetAfterWebView | Gets or sets a boolean that indicates if the web editing state should be reset after web view.
ShowEditDots | Gets or sets a boolean that indicates if dots (and panel) are shown in preview and web edit mode.
ShowRenderingInfo | Gets or sets a boolean that indicates if rendering info is available.
Theme | Gets or sets the current theme.
Tracing | Gets or sets a boolean that indicates if tracing data is collected.
Translating | Gets or sets a value indicating whether this State is translating.
WebEditing | Gets a value indicating whether the system is web editing.

See Also

State Class
Sitecore.Configuration Namespace


State Constructor

[image]

Sitecore 6.4.1 API
State Constructor
State Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public State()
Visual Basic
Public Sub New
Visual C++
public:
State()

See Also

State Class
Sitecore.Configuration Namespace


State Methods

[image] [image]

Sitecore 6.4.1 API
State Methods
State Class See Also Send Feedback

The State type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCustom | Gets a custom State variable.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RemoveCustom | Removes a custom State variable.
 | SetActivePublish | Set active publishing info.
 | SetCustom | Sets a custom State variable.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

State Class
Sitecore.Configuration Namespace


GetCustom Method

[image]

Sitecore 6.4.1 API
State..::..GetCustom Method
State Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object GetCustom(
    string name
)
Visual Basic
Public Shared Function GetCustom ( _
    name As String _
) As Object
Visual C++
public:
static Object^ GetCustom(
    String^ name
)

Parameters

name
Type: System..::..String
The name of the State variable.

Return Value

The value of the State variable.

Remarks

A custom state variable is stored in the Session object under the name "SC_CUSTOM_" + name.

See Also

State Class
Sitecore.Configuration Namespace
State..::..SetCustom(String, Object)


RemoveCustom Method

[image]

Sitecore 6.4.1 API
State..::..RemoveCustom Method
State Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void RemoveCustom(
    string name
)
Visual Basic
Public Shared Sub RemoveCustom ( _
    name As String _
)
Visual C++
public:
static void RemoveCustom(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

See Also

State Class
Sitecore.Configuration Namespace


SetActivePublish Method

[image]

Sitecore 6.4.1 API
State..::..SetActivePublish Method
State Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void SetActivePublish(
    DateTime publishDate,
    string groups
)
Visual Basic
Public Shared Sub SetActivePublish ( _
    publishDate As DateTime, _
    groups As String _
)
Visual C++
public:
static void SetActivePublish(
    DateTime publishDate,
    String^ groups
)

Parameters

publishDate
Type: System..::..DateTime
The publish date.
groups
Type: System..::..String
The groups.

See Also

State Class
Sitecore.Configuration Namespace


SetCustom Method

[image]

Sitecore 6.4.1 API
State..::..SetCustom Method
State Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void SetCustom(
    string name,
    Object value
)
Visual Basic
Public Shared Sub SetCustom ( _
    name As String, _
    value As Object _
)
Visual C++
public:
static void SetCustom(
    String^ name,
    Object^ value
)

Parameters

name
Type: System..::..String
The name of the State variable.
value
Type: System..::..Object
The value of the State variable.

Remarks

A custom state variable is stored in the Session object under the name "SC_CUSTOM_" + name.

See Also

State Class
Sitecore.Configuration Namespace
State..::..GetCustom(String)


State Properties

[image] [image]

Sitecore 6.4.1 API
State Properties
State Class See Also Send Feedback

The State type exposes the following members.

Properties

Name | Description
ActivePublishDate | Gets the active publish date.
ActivePublishGroups | Gets the active publish groups.
AddRenderings | Gets an array list of renderings to add to the default list of renderings.
ClientLanguage | Gets or sets the ISO language code the the current client language.
ClientUsesOSWindows | Obsolete. Gets or sets a value indicating whether the client uses OS windows.
CommitDisabled | Option to disable commits on items.
ContentDatabase | Gets or sets the content database.
CurrentLayout | Obsolete. Gets or sets the ID or name of the current layout.
CurrentLayoutChanged | Obsolete. Gets or sets a boolean that indicates if current layout was changed.
CustomLayout | Gets or sets the ID or name of a custom layout to use for the current page request.
DebugMode | Gets or sets a boolean that indicates if Sitecore is in debug mode.
Desktop | Gets or sets the path of the client desktop webpage.
DisableDefaultRenderings | Gets or sets a boolean that indicates if the default renderings are disabled or not.
DisableItemChangeRegistering | Gets or sets a boolean that indicates of item changes are registered.
DispatchEvents | Gets or sets a boolean that indicates if events are dispatched.
DrawRenderingBorders | Get or sets a boolean that indicates if borders are drawn around renderings.
ExtensionObjects | Gets the hash list of XSL extention objects.
Form | Gets or sets the current form collection from web page.
Language | Get or sets the current language code.
LastError | Gets a hash list of sections containing the last errors.
LayoutGroup | Obsolete. Gets or sets the current layout group.
MasterItem | Gets or sets the current master item.
PreviewDate | Gets or sets the current date/time of a preview.
PreviewGroups | Gets or sets the current publishing groups of a preview.
Previewing | Gets a value indicating whether the system is previewing.
Profiling | Gets or sets a boolean that indicates if profiling data are generated.
RemoveRenderings | Gets a has array list of renderings that should be removed from the list of default renderings.
ResetAfterWebView | Gets or sets a boolean that indicates if the web editing state should be reset after web view.
ShowEditDots | Gets or sets a boolean that indicates if dots (and panel) are shown in preview and web edit mode.
ShowRenderingInfo | Gets or sets a boolean that indicates if rendering info is available.
Theme | Gets or sets the current theme.
Tracing | Gets or sets a boolean that indicates if tracing data is collected.
Translating | Gets or sets a value indicating whether this State is translating.
WebEditing | Gets a value indicating whether the system is web editing.

See Also

State Class
Sitecore.Configuration Namespace


ActivePublishDate Property

[image]

Sitecore 6.4.1 API
State..::..ActivePublishDate Property
State Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static DateTime ActivePublishDate { get; }
Visual Basic
Public Shared ReadOnly Property ActivePublishDate As DateTime
    Get
Visual C++
public:
static property DateTime ActivePublishDate {
    DateTime get ();
}

Field Value

The active publish date.

See Also

State Class
Sitecore.Configuration Namespace


ActivePublishGroups Property

[image]

Sitecore 6.4.1 API
State..::..ActivePublishGroups Property
State Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ActivePublishGroups { get; }
Visual Basic
Public Shared ReadOnly Property ActivePublishGroups As String
    Get
Visual C++
public:
static property String^ ActivePublishGroups {
    String^ get ();
}

Field Value

The active publish groups.

See Also

State Class
Sitecore.Configuration Namespace


AddRenderings Property

[image]

Sitecore 6.4.1 API
State..::..AddRenderings Property
State Class Example See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ArrayList AddRenderings { get; }
Visual Basic
Public Shared ReadOnly Property AddRenderings As ArrayList
    Get
Visual C++
public:
static property ArrayList^ AddRenderings {
    ArrayList^ get ();
}

Field Value

An array list of renderingings.

Remarks

As the web engine renders a page, it builds a list of renderings to add to the page. Normally the renderings are fetched from the current item, but the AddRenderings State variable allows additional renderings to be rendered on the page.

Usually this is used in global.aspx to programatically add new renderings to a page based on certain conditions.

The list consists of either IDs or names of renderings.

The scope of the value is page and it is stored in the Items variable "SC_ADD_RENDERINGS".

Examples

The following code add the SpotBox rendering to the page, and removes the Document rendering, id the user is logged into the extranet.
CopyC#
public PersonalizePage() {
if (ExtranetSecurity.IsLoggedIn) {
State.AddRenderings.Add("SpotBox");
State.RemoveRenderings.Add("Document");
}
}

See Also

State Class
Sitecore.Configuration Namespace
State..::..RemoveRenderings
State..::..DisableDefaultRenderings


ClientLanguage Property

[image]

Sitecore 6.4.1 API
State..::..ClientLanguage Property
State Class Example See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ClientLanguage { get; set; }
Visual Basic
Public Shared Property ClientLanguage As String
    Get
    Set
Visual C++
public:
static property String^ ClientLanguage {
    String^ get ();
    void set (String^ value);
}

Field Value

The current client language ISO code.

Remarks

The client language is the language that the Sitecore client is presented in. For instance if the client language is "da" the client will present all menus, toolbars etc. in the Danish language.

The client language code is usually set when the user logs in. The language code for a user is specified in the Client Language field on the __User template.

If the language code is changed, the Sitecore client must be reloaded in order to retrieve the new language from the server.

The scope of the value is session and it is stored in the Session variable "SC_CLIENT_LANGUAGE".

Examples

The following example checks the client language to provide the correct text.
CopyC#
public string GetWelcomeText() {
if (State.ClientLanguage == "da") {
return "Velkommen";
}
return "Welcome";
}

See Also

State Class
Sitecore.Configuration Namespace
State..::..Language


ClientUsesOSWindows Property

[image]

Sitecore 6.4.1 API
State..::..ClientUsesOSWindows Property
State Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - use State.Client.UsesBrowserWindows")]
public static bool ClientUsesOSWindows { get; set; }
Visual Basic
<ObsoleteAttribute("Deprecated - use State.Client.UsesBrowserWindows")> _
Public Shared Property ClientUsesOSWindows As Boolean
    Get
    Set
Visual C++
[ObsoleteAttribute(L"Deprecated - use State.Client.UsesBrowserWindows")]
public:
static property bool ClientUsesOSWindows {
    bool get ();
    void set (bool value);
}

Field Value

true if the client uses OS windows; otherwise, false.

See Also

State Class
Sitecore.Configuration Namespace


CommitDisabled Property

[image]

Sitecore 6.4.1 API
State..::..CommitDisabled Property
State Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool CommitDisabled { get; set; }
Visual Basic
Public Shared Property CommitDisabled As Boolean
    Get
    Set
Visual C++
public:
static property bool CommitDisabled {
    bool get ();
    void set (bool value);
}

Field Value

true if commits are disabled; otherwise, false.

Remarks

The scope of the value is thread and it is stored in the thread variable "SC_COMMIT_DISABLED".

See Also

State Class
Sitecore.Configuration Namespace


ContentDatabase Property

[image]

Sitecore 6.4.1 API
State..::..ContentDatabase Property
State Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ContentDatabase { get; set; }
Visual Basic
Public Shared Property ContentDatabase As String
    Get
    Set
Visual C++
public:
static property String^ ContentDatabase {
    String^ get ();
    void set (String^ value);
}

Field Value

The content database.

See Also

State Class
Sitecore.Configuration Namespace


CurrentLayout Property

[image]

Sitecore 6.4.1 API
State..::..CurrentLayout Property
State Class Example See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use State.CustomLayout instead")]
public static string CurrentLayout { get; set; }
Visual Basic
<ObsoleteAttribute("Use State.CustomLayout instead")> _
Public Shared Property CurrentLayout As String
    Get
    Set
Visual C++
[ObsoleteAttribute(L"Use State.CustomLayout instead")]
public:
static property String^ CurrentLayout {
    String^ get ();
    void set (String^ value);
}

Field Value

The ID or name of the current layout.

Remarks

The current layout is the layout that will be rendered by the web engine. This is by default the layout of the current item.

The default layout can be overridden by setting the current layout before the web engine starts. This can be used to build the layout programatically in conjunction with AddRenderings and RemoveRenderings. Normally programatic layouts are built in global.aspx which executes before the web engine.

When programatically setting the current layout, the State property CurrentLayoutChanged is set to true.

By default the current layout is set from then request query string argument "layout". This is argument is set to the layout of the current item by the Sitecore Http Request handler (HttpModule).

The scope of the value is page and it is stored in the Items variable "SC_CURRENT_LAYOUT".

Examples

The following example builds a special layout if the user is a special user.
CopyC#
public void BuildVIPLayout(string user) {
if (user == "VIP") {
State.CurrentLayout = "VIP layout";
State.AddRenderings.Add("VIPRendering");
}
}

See Also

State Class
Sitecore.Configuration Namespace
State..::..CurrentLayoutChanged


CurrentLayoutChanged Property

[image]

Sitecore 6.4.1 API
State..::..CurrentLayoutChanged Property
State Class Example See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use State.CustomLayout instead")]
public static bool CurrentLayoutChanged { get; set; }
Visual Basic
<ObsoleteAttribute("Use State.CustomLayout instead")> _
Public Shared Property CurrentLayoutChanged As Boolean
    Get
    Set
Visual C++
[ObsoleteAttribute(L"Use State.CustomLayout instead")]
public:
static property bool CurrentLayoutChanged {
    bool get ();
    void set (bool value);
}

Field Value

True, if the layout has been changed, otherwise false.

Remarks

This boolean is used with with the State variable CurrentLayout. When CurrentLayout is programatically set, CurrentLayoutChanged is set to true.

The scope of the value is page and it is stored in the Items variable "SC_CURRENT_LAYOUT_CHANGED".

Examples

The following example builds a special layout if the user is a special user.
CopyC#
public void BuildVIPLayout(string user) {
if (user == "VIP") {
State.CurrentLayout = "VIP layout";
State.AddRenderings.Add("VIPRendering");
}
}
public void Build() {
bool changed = State.CurrentLayoutChanged; // false
BuildVIPLayout("Employee");
changed = State.CurrentLayoutChanged; // false
BuildVIPLayout("VIP");
changed = State.CurrentLayoutChanged; // true
}

See Also

State Class
Sitecore.Configuration Namespace
State..::..CurrentLayout


CustomLayout Property

[image]

Sitecore 6.4.1 API
State..::..CustomLayout Property
State Class Example See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string CustomLayout { get; set; }
Visual Basic
Public Shared Property CustomLayout As String
    Get
    Set
Visual C++
public:
static property String^ CustomLayout {
    String^ get ();
    void set (String^ value);
}

Field Value

The ID or name of the custom layout.

Remarks

The default layout can be overridden by setting the custom layout before the web engine starts (typically in Page_Init or a page handler). This can be used to build the layout programatically in conjunction with AddRenderings and RemoveRenderings.

The scope of the value is page and it is stored in the Items variable "SC_CUSTOM_LAYOUT".

Examples

The following example builds a special layout if the user is a special user.
CopyC#
public void BuildVIPLayout(string user) {
if (user == "VIP") {
State.CustomLayout = "VIP layout";
State.AddRenderings.Add("VIPRendering");
}
void Page_Init() {
BuildVIPLayout(myUser);
}
}

See Also

State Class
Sitecore.Configuration Namespace


DebugMode Property

[image]

Sitecore 6.4.1 API
State..::..DebugMode Property
State Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool DebugMode { get; set; }
Visual Basic
Public Shared Property DebugMode As Boolean
    Get
    Set
Visual C++
public:
static property bool DebugMode {
    bool get ();
    void set (bool value);
}

Field Value

True, if Sitecore is in debug mode, otherwise false.

Remarks

DebugMode is the global controller of all debug activities. It controls such tools as Profiling, Trace, Rendering Borders and Rendering Info. Only if DebugMode is true will these tools be available.

The DebugMode flag also adds further information on the Debug tab in the content area.

The DebugMode flag can be enabled by specifying the "sc_debug=1" argument on the query string. To disable it, specify "sc_debug=0".

The scope of the value is sesion and it is stored in the Session variable "SC_DEBUGMODE".

See Also

State Class
Sitecore.Configuration Namespace
State..::..DrawRenderingBorders
State..::..Profiling
State..::..ShowRenderingInfo
State..::..Tracing


Desktop Property

[image]

Sitecore 6.4.1 API
State..::..Desktop Property
State Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Desktop { get; set; }
Visual Basic
Public Shared Property Desktop As String
    Get
    Set
Visual C++
public:
static property String^ Desktop {
    String^ get ();
    void set (String^ value);
}

Field Value

The path to the webpage that specifies the Sitecore client.

Remarks

A desktop is the basic webpage that contains a Sitecore client. Sitecore only provides one desktop, but customers or partners may implement other desktops.

The desktop is initialized during user login. When the login procedure has completed, the browser is redirected to the desktop webpage.

The desktop for a specific user is specified in the Desktop field on the __User template. This is a lookup field pointing to "/sitecore/system/Desktops and Themes/Desktops".

If the user item does not specify a desktop, the value from DefaultDesktop is used.

The scope of the value is session and it is stored in the Session variable "SC_DESKTOP".

See Also

State Class
Sitecore.Configuration Namespace
State..::..Theme


DisableDefaultRenderings Property

[image]

Sitecore 6.4.1 API
State..::..DisableDefaultRenderings Property
State Class Example See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool DisableDefaultRenderings { get; set; }
Visual Basic
Public Shared Property DisableDefaultRenderings As Boolean
    Get
    Set
Visual C++
public:
static property bool DisableDefaultRenderings {
    bool get ();
    void set (bool value);
}

Field Value

True, if default renderings are disabled, otherwise false.

Remarks

Default renderings are the renderings, specified as part of the current layout. For instance the Home layout may have a Document rendering.

When builing a programatic layout using AddRenderings and RemoveRenderings, it is possible to disable any renderings that the layout specifies.

The scope of the value is page and it stored in the Items variable "SC_DISABLE_DEFAULT_RENDERINGS".

Examples

The following example builds a special layout if the user is a VIP.
CopyC#
public void BuildVIPLayout(string user) {
if (user == "VIP") {
State.DisableDefaultRenderings = true;
State.AddRenderings.Add("VIPRendering");
}
}

See Also

State Class
Sitecore.Configuration Namespace
State..::..AddRenderings
State..::..RemoveRenderings


DisableItemChangeRegistering Property

[image]

Sitecore 6.4.1 API
State..::..DisableItemChangeRegistering Property
State Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool DisableItemChangeRegistering { get; set; }
Visual Basic
Public Shared Property DisableItemChangeRegistering As Boolean
    Get
    Set
Visual C++
public:
static property bool DisableItemChangeRegistering {
    bool get ();
    void set (bool value);
}

Field Value

true if the State disables the item change registering; otherwise, false.

Remarks

The scope of the value is thread and it is stored in the thread variable "SC_COMMIT_DISABLED".

See Also

State Class
Sitecore.Configuration Namespace


DispatchEvents Property

[image]

Sitecore 6.4.1 API
State..::..DispatchEvents Property
State Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool DispatchEvents { get; set; }
Visual Basic
Public Shared Property DispatchEvents As Boolean
    Get
    Set
Visual C++
public:
static property bool DispatchEvents {
    bool get ();
    void set (bool value);
}

Field Value

True, if events are dispatched, otherwise false.

Remarks

The event dispatcher is the event handling mechanism in Sitecore. Certain actions raise events, for instance saving an item, publishing, tracing and exception handling.

This flag can be used to disable event handling on the current web page.

The scope of the value is page and it is stored in the Items variable "SC_DISPATCH_EVENTS".

See Also

State Class
Sitecore.Configuration Namespace


DrawRenderingBorders Property

[image]

Sitecore 6.4.1 API
State..::..DrawRenderingBorders Property
State Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool DrawRenderingBorders { get; set; }
Visual Basic
Public Shared Property DrawRenderingBorders As Boolean
    Get
    Set
Visual C++
public:
static property bool DrawRenderingBorders {
    bool get ();
    void set (bool value);
}

Field Value

True, if DebugMode is true and borders are drawn, otherwise false.

Remarks

When the web engine is running in debug mode, it can drawn borders around each rendering. This makes it easy for the developer to identify individual renderings.

This flag requires that DebugMode is true.

The scope of the value is session and it stored in the Session variable "SC_DRAW_RENDERING_BORDERS".

See Also

State Class
Sitecore.Configuration Namespace


ExtensionObjects Property

[image]

Sitecore 6.4.1 API
State..::..ExtensionObjects Property
State Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Hashtable ExtensionObjects { get; }
Visual Basic
Public Shared ReadOnly Property ExtensionObjects As Hashtable
    Get
Visual C++
public:
static property Hashtable^ ExtensionObjects {
    Hashtable^ get ();
}

Field Value

A hash list of extention objects.

Remarks

An XSL extention is an object that is accessible from within XSL transformations. For instance the XslHelper object, which implements the "sc:fld" function.

The developer may make more extention objects available on a per page basis. It such case the new extention object can be added to this list.

The scope of this list is page only. To add extention objects globally, use the xslExtentions section ion the web.config.

The ExtensionObjects is usually used in global.aspx.

The scope of the value is page and it is stored in the Items variable "SC_EXPAND_LINKED_DATABASES".

See Also

State Class
Sitecore.Configuration Namespace


Form Property

[image]

Sitecore 6.4.1 API
State..::..Form Property
State Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static NameValueCollection Form { get; set; }
Visual Basic
Public Shared Property Form As NameValueCollection
    Get
    Set
Visual C++
public:
static property NameValueCollection^ Form {
    NameValueCollection^ get ();
    void set (NameValueCollection^ value);
}

Field Value

The form collection from the current web page.

Remarks

The Sitecore request handler (HttpModule) overrides the current form collection in order to find the correct layout for the page. The normal form collection (Form) is therefore not valid. However Sitecore stores the original form collection in this variable before overwriting it.

See Also

State Class
Sitecore.Configuration Namespace


Language Property

[image]

Sitecore 6.4.1 API
State..::..Language Property
State Class Example See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Language { get; set; }
Visual Basic
Public Shared Property Language As String
    Get
    Set
Visual C++
public:
static property String^ Language {
    String^ get ();
    void set (String^ value);
}

Field Value

The current language code.

Remarks

The current language specifies which pieces of content, Sitecore fetches by default. For instance if the language code is "da" (Danish), Sitecore will by default fetch contents that have the code "da".

The code is just an identifier, but usually it is an ISO language code, e.g. "en", "en-us", "da", "ge" etc.

This State variable does not change the language of the Sitecore client.

Examples

The following example changes the language to german.
CopyC#
string english = version.GetFieldValue("Text"); // english text
State.Language = "ge";
string german = version.GetFieldValue("Text"); // german text

See Also

State Class
Sitecore.Configuration Namespace
State..::..ClientLanguage


LastError Property

[image]

Sitecore 6.4.1 API
State..::..LastError Property
State Class Example See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Hashtable LastError { get; }
Visual Basic
Public Shared ReadOnly Property LastError As Hashtable
    Get
Visual C++
public:
static property Hashtable^ LastError {
    Hashtable^ get ();
}

Field Value

A hash list of of errors.

Remarks

It is possible to log errors using this State variable. The key of the error identifies the type of error, e.g. "Extranet".

Examples

The following example adds an error and retrieves it again.
CopyC#
State.LastError.Add("Extranet", "Unknown user or password");
string error = State.LastError["Extranet"];

See Also

State Class
Sitecore.Configuration Namespace


LayoutGroup Property

[image]

Sitecore 6.4.1 API
State..::..LayoutGroup Property
State Class Example See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute]
public static string LayoutGroup { get; set; }
Visual Basic
<ObsoleteAttribute> _
Public Shared Property LayoutGroup As String
    Get
    Set
Visual C++
[ObsoleteAttribute]
public:
static property String^ LayoutGroup {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the current layout group.

Remarks

A layout groups holds a number of different layouts. When the web engine renders a web page at looks at the current layout. If the current layout is a layout group it selects the layout that matches the current value of this State variable.

For instance the State layout group variable may be set to "Print". If the web engine encounters a layout group, it will select the layout matches "Print".

Layout groups can be specified the request query string by specifying "lg=<value>". In this case the scope of the layout group is page only. The "lg" key name can be specified in the Settings.LayoutGroupQSName web.config setting.

When setting the Layout group variable, the request has usually already started and it is too late to change the Layout group as the layout has already be identified. The solution is the redirect to a web page that sets the layout group and then redirect to the original web page. That way the layout group will be set when the request starts.

The scope of the value is session and it is stored in a cookied named "SC_LAYOUTGROUP".

Examples

The following example sets the layout group to "Netscape".
CopyC#
State.LayoutGroup = "Netscape";

See Also

State Class
Sitecore.Configuration Namespace


MasterItem Property

[image]

Sitecore 6.4.1 API
State..::..MasterItem Property
State Class Example See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item MasterItem { get; set; }
Visual Basic
Public Shared Property MasterItem As Item
    Get
    Set
Visual C++
public:
static property Item^ MasterItem {
    Item^ get ();
    void set (Item^ value);
}

Field Value

The current Item object.

Remarks

The current master item is used in the Sitecore client. It points to the current loaded item in the content area and is set when the content area page loads.

The scope of the value is page and it is stored the Items variable "SC_CURRENT_MASTER_ITEM".

Examples

The following example processes the children of the current master item.
CopyC#
public void IterateChildren() {
if (State.MasterItem != null) {
SortedList list = State.MasterItem.GetChildrenSorted();
for(int n = 0; n < list.count; n++) {
IMasterItem2 child = list.GetByIndex(n) as IMasterItem2;
ProcessChild(child);
}
}
}

See Also

State Class
Sitecore.Configuration Namespace


PreviewDate Property

[image]

Sitecore 6.4.1 API
State..::..PreviewDate Property
State Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static DateTime PreviewDate { get; }
Visual Basic
Public Shared ReadOnly Property PreviewDate As DateTime
    Get
Visual C++
public:
static property DateTime PreviewDate {
    DateTime get ();
}

Field Value

The date/time of the preview.

Remarks

When a preview is generated, it reflects the web site at a certain date and time. This date and time is specified in this State variable.

See Also

State Class
Sitecore.Configuration Namespace
State..::..PreviewGroups


PreviewGroups Property

[image]

Sitecore 6.4.1 API
State..::..PreviewGroups Property
State Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string PreviewGroups { get; }
Visual Basic
Public Shared ReadOnly Property PreviewGroups As String
    Get
Visual C++
public:
static property String^ PreviewGroups {
    String^ get ();
}

Field Value

The publishing groups of the preview.

Remarks

When a preview is generated, it publishes certain publishing groups. These groups are specified in this State variable.

See Also

State Class
Sitecore.Configuration Namespace


Previewing Property

[image]

Sitecore 6.4.1 API
State..::..Previewing Property
State Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool Previewing { get; }
Visual Basic
Public Shared ReadOnly Property Previewing As Boolean
    Get
Visual C++
public:
static property bool Previewing {
    bool get ();
}

Field Value

true if the system is previewing; otherwise, false.

See Also

State Class
Sitecore.Configuration Namespace


Profiling Property

[image]

Sitecore 6.4.1 API
State..::..Profiling Property
State Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool Profiling { get; set; }
Visual Basic
Public Shared Property Profiling As Boolean
    Get
    Set
Visual C++
public:
static property bool Profiling {
    bool get ();
    void set (bool value);
}

Field Value

True, if DebugMode is true and profiling is enabled, otherwise false.

Remarks

When profiling the web engine times each rendering. This information is available on the Sitecore debug pages "http://www.mysite.net/sitecore/debug".

Profiling can only be enabled if DebugMode is true.

The scope of the value is session and it is stored in the Session variable "SC_PROFILING".

See Also

State Class
Sitecore.Configuration Namespace
State..::..Tracing


RemoveRenderings Property

[image]

Sitecore 6.4.1 API
State..::..RemoveRenderings Property
State Class Example See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ArrayList RemoveRenderings { get; }
Visual Basic
Public Shared ReadOnly Property RemoveRenderings As ArrayList
    Get
Visual C++
public:
static property ArrayList^ RemoveRenderings {
    ArrayList^ get ();
}

Field Value

An array list of rendering names or IDs.

Remarks

Default renderings are the renderings specified as part of the current layout. For instance the Home layout may have a Document rendering.

When builing a programatic layout using AddRenderings and DisableDefaultRenderings, it is possible to remove default renderings.

Examples

The following code adds the SpotBox rendering to the page, and removes the Document rendering, if the user is logged into the extranet.
CopyC#
public PersonalizePage() {
if (ExtranetSecurity.IsLoggedIn) {
State.AddRenderings.Add("SpotBox");
State.RemoveRenderings.Add("Document");
}
}

See Also

State Class
Sitecore.Configuration Namespace


ResetAfterWebView Property

[image]

Sitecore 6.4.1 API
State..::..ResetAfterWebView Property
State Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool ResetAfterWebView { get; set; }
Visual Basic
Public Shared Property ResetAfterWebView As Boolean
    Get
    Set
Visual C++
public:
static property bool ResetAfterWebView {
    bool get ();
    void set (bool value);
}

Field Value

True, if it should be reset, otherwise false.

Remarks

This is for internal use only.

See Also

State Class
Sitecore.Configuration Namespace


ShowEditDots Property

[image]

Sitecore 6.4.1 API
State..::..ShowEditDots Property
State Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool ShowEditDots { get; }
Visual Basic
Public Shared ReadOnly Property ShowEditDots As Boolean
    Get
Visual C++
public:
static property bool ShowEditDots {
    bool get ();
}

Field Value

True, if dots are shown, otherwise false.

Remarks

Dots are the small markers that an editor clicks on in preview or web edit mode to edit the content.

The dots can be turned off. For example this is done in the Web view pane in the Sitecore client.

See Also

State Class
Sitecore.Configuration Namespace


ShowRenderingInfo Property

[image]

Sitecore 6.4.1 API
State..::..ShowRenderingInfo Property
State Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool ShowRenderingInfo { get; set; }
Visual Basic
Public Shared Property ShowRenderingInfo As Boolean
    Get
    Set
Visual C++
public:
static property bool ShowRenderingInfo {
    bool get ();
    void set (bool value);
}

Field Value

True, if DebugMode is true and rendering info should be available, otherwise false.

Remarks

The web engine can render information about each rendering on the web page. That makes it easy for a developer to identify the individual renderings and their parameters.

Rendering information can only be enabled if DebugMode is true.

The scope of the value is session and it is stored in the Session variable "SC_SHOW_RENDERING_INFO".

See Also

State Class
Sitecore.Configuration Namespace


Theme Property

[image]

Sitecore 6.4.1 API
State..::..Theme Property
State Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Theme { get; set; }
Visual Basic
Public Shared Property Theme As String
    Get
    Set
Visual C++
public:
static property String^ Theme {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the current theme.

Remarks

A theme is the appearance of the Sitecore client. Themes control the stylesheet and images used in the client.

The theme is initialized during user login.

The desktop for a specific user is specified in the Theme field on the __User template. This is a lookup field pointing to "/sitecore/system/Desktops and Themes/Themes".

If the user item does not specify a theme, the value from DefaultTheme is used.

The scope of the value is session and it is stored in the Session variable "SC_THEME".

See Also

State Class
Sitecore.Configuration Namespace
State..::..Desktop


Tracing Property

[image]

Sitecore 6.4.1 API
State..::..Tracing Property
State Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool Tracing { get; set; }
Visual Basic
Public Shared Property Tracing As Boolean
    Get
    Set
Visual C++
public:
static property bool Tracing {
    bool get ();
    void set (bool value);
}

Field Value

True, if DebugMode is true and tracing is enabled, otherwise false.

Remarks

When tracing the web engine collects information about the rendering process. This information is available on the Sitecore debug pages "http://www.mysite.net/sitecore/debug".

Tracing can only be enabled if DebugMode is true.

The scope of the value is session and it is stored in the Session variable "SC_TRACING".

See Also

State Class
Sitecore.Configuration Namespace
State..::..Profiling


Translating Property

[image]

Sitecore 6.4.1 API
State..::..Translating Property
State Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool Translating { get; set; }
Visual Basic
Public Shared Property Translating As Boolean
    Get
    Set
Visual C++
public:
static property bool Translating {
    bool get ();
    void set (bool value);
}

Field Value

true if translating; otherwise, false.

See Also

State Class
Sitecore.Configuration Namespace


WebEditing Property

[image]

Sitecore 6.4.1 API
State..::..WebEditing Property
State Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool WebEditing { get; }
Visual Basic
Public Shared ReadOnly Property WebEditing As Boolean
    Get
Visual C++
public:
static property bool WebEditing {
    bool get ();
}

Field Value

true if the system is web editing; otherwise, false.

See Also

State Class
Sitecore.Configuration Namespace


State.Client Class

[image]

Sitecore 6.4.1 API
State..::..Client Class
State Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Client
Visual Basic
Public NotInheritable Class Client
Visual C++
public ref class Client abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..State..::..Client

See Also

State..::..Client Members
Sitecore.Configuration Namespace


State.Client Members

[image] [image]

Sitecore 6.4.1 API
State..::..Client Members
State..::..Client Class Properties See Also Send Feedback

Sitecore maintains a state about the current webpage (in the Items collection) and about the current session (in the Session collection).

Typical information include the current user, the current web item, the current master item, the current layout etc.

The State class encapsulates both the Items and Session collections.

The State..::..Client type exposes the following members.

Properties

Name | Description
IsFullscreen | Gets or sets a value indicating whether this session is fullscreen.
NoDesktop | Gets or sets a value indicating whether the browser shows the the desktop.
UsesBrowserWindows | Gets or sets a value indicating whether the session uses browser windows.

See Also

State..::..Client Class
Sitecore.Configuration Namespace


State.Client Properties

[image] [image]

Sitecore 6.4.1 API
State..::..Client Properties
State..::..Client Class See Also Send Feedback

The State..::..Client type exposes the following members.

Properties

Name | Description
IsFullscreen | Gets or sets a value indicating whether this session is fullscreen.
NoDesktop | Gets or sets a value indicating whether the browser shows the the desktop.
UsesBrowserWindows | Gets or sets a value indicating whether the session uses browser windows.

See Also

State..::..Client Class
Sitecore.Configuration Namespace


IsFullscreen Property

[image]

Sitecore 6.4.1 API
State..::..Client..::..IsFullscreen Property
State..::..Client Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsFullscreen { get; set; }
Visual Basic
Public Shared Property IsFullscreen As Boolean
    Get
    Set
Visual C++
public:
static property bool IsFullscreen {
    bool get ();
    void set (bool value);
}

Field Value

true if this session is fullscreen; otherwise, false.

See Also

State..::..Client Class
Sitecore.Configuration Namespace


NoDesktop Property

[image]

Sitecore 6.4.1 API
State..::..Client..::..NoDesktop Property
State..::..Client Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool NoDesktop { get; set; }
Visual Basic
Public Shared Property NoDesktop As Boolean
    Get
    Set
Visual C++
public:
static property bool NoDesktop {
    bool get ();
    void set (bool value);
}

Field Value

true if the browser shows the the desktop; otherwise, false.

See Also

State..::..Client Class
Sitecore.Configuration Namespace


UsesBrowserWindows Property

[image]

Sitecore 6.4.1 API
State..::..Client..::..UsesBrowserWindows Property
State..::..Client Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool UsesBrowserWindows { get; set; }
Visual Basic
Public Shared Property UsesBrowserWindows As Boolean
    Get
    Set
Visual C++
public:
static property bool UsesBrowserWindows {
    bool get ();
    void set (bool value);
}

Field Value

true if the session uses browser windows; otherwise, false.

See Also

State..::..Client Class
Sitecore.Configuration Namespace


State.HttpRuntime Class

[image]

Sitecore 6.4.1 API
State..::..HttpRuntime Class
State Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class HttpRuntime
Visual Basic
Public NotInheritable Class HttpRuntime
Visual C++
public ref class HttpRuntime abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..State..::..HttpRuntime

See Also

State..::..HttpRuntime Members
Sitecore.Configuration Namespace


State.HttpRuntime Members

[image] [image]

Sitecore 6.4.1 API
State..::..HttpRuntime Members
State..::..HttpRuntime Class Properties See Also Send Feedback

Sitecore maintains a state about the current webpage (in the Items collection) and about the current session (in the Session collection).

Typical information include the current user, the current web item, the current master item, the current layout etc.

The State class encapsulates both the Items and Session collections.

The State..::..HttpRuntime type exposes the following members.

Properties

Name | Description
AppDomainAppPath | Gets or sets the application domain application path.

See Also

State..::..HttpRuntime Class
Sitecore.Configuration Namespace


State.HttpRuntime Properties

[image] [image]

Sitecore 6.4.1 API
State..::..HttpRuntime Properties
State..::..HttpRuntime Class See Also Send Feedback

The State..::..HttpRuntime type exposes the following members.

Properties

Name | Description
AppDomainAppPath | Gets or sets the application domain application path.

See Also

State..::..HttpRuntime Class
Sitecore.Configuration Namespace


AppDomainAppPath Property

[image]

Sitecore 6.4.1 API
State..::..HttpRuntime..::..AppDomainAppPath Property
State..::..HttpRuntime Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string AppDomainAppPath { get; set; }
Visual Basic
Public Shared Property AppDomainAppPath As String
    Get
    Set
Visual C++
public:
static property String^ AppDomainAppPath {
    String^ get ();
    void set (String^ value);
}

Field Value

The application domain application path.

See Also

State..::..HttpRuntime Class
Sitecore.Configuration Namespace


State.PageDesigner Members

[image] [image]

Sitecore 6.4.1 API
State..::..PageDesigner Members
State..::..PageDesigner Class Properties See Also Send Feedback

Sitecore maintains a state about the current webpage (in the Items collection) and about the current session (in the Session collection).

Typical information include the current user, the current web item, the current master item, the current layout etc.

The State class encapsulates both the Items and Session collections.

The State..::..PageDesigner type exposes the following members.

Properties

Name | Description
CurrentDevice | Gets or sets the current device.

See Also

State..::..PageDesigner Class
Sitecore.Configuration Namespace


State.PageDesigner Properties

[image] [image]

Sitecore 6.4.1 API
State..::..PageDesigner Properties
State..::..PageDesigner Class See Also Send Feedback

The State..::..PageDesigner type exposes the following members.

Properties

Name | Description
CurrentDevice | Gets or sets the current device.

See Also

State..::..PageDesigner Class
Sitecore.Configuration Namespace


CurrentDevice Property

[image]

Sitecore 6.4.1 API
State..::..PageDesigner..::..CurrentDevice Property
State..::..PageDesigner Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string CurrentDevice { get; set; }
Visual Basic
Public Shared Property CurrentDevice As String
    Get
    Set
Visual C++
public:
static property String^ CurrentDevice {
    String^ get ();
    void set (String^ value);
}

Field Value

The current device.

See Also

State..::..PageDesigner Class
Sitecore.Configuration Namespace


State.Request Class

[image]

Sitecore 6.4.1 API
State..::..Request Class
State Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Request
Visual Basic
Public NotInheritable Class Request
Visual C++
public ref class Request abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..State..::..Request

See Also

State..::..Request Members
Sitecore.Configuration Namespace


State.Request Members

[image] [image]

Sitecore 6.4.1 API
State..::..Request Members
State..::..Request Class Properties See Also Send Feedback

Sitecore maintains a state about the current webpage (in the Items collection) and about the current session (in the Session collection).

Typical information include the current user, the current web item, the current master item, the current layout etc.

The State class encapsulates both the Items and Session collections.

The State..::..Request type exposes the following members.

Properties

Name | Description
ContentType | Gets or sets a value indicating whether this session is fullscreen.

See Also

State..::..Request Class
Sitecore.Configuration Namespace


State.Request Properties

[image] [image]

Sitecore 6.4.1 API
State..::..Request Properties
State..::..Request Class See Also Send Feedback

The State..::..Request type exposes the following members.

Properties

Name | Description
ContentType | Gets or sets a value indicating whether this session is fullscreen.

See Also

State..::..Request Class
Sitecore.Configuration Namespace


ContentType Property

[image]

Sitecore 6.4.1 API
State..::..Request..::..ContentType Property
State..::..Request Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ContentType { get; set; }
Visual Basic
Public Shared Property ContentType As String
    Get
    Set
Visual C++
public:
static property String^ ContentType {
    String^ get ();
    void set (String^ value);
}

Field Value

true if this session is fullscreen; otherwise, false.

See Also

State..::..Request Class
Sitecore.Configuration Namespace


State.Sites Class

[image]

Sitecore 6.4.1 API
State..::..Sites Class
State Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Sites
Visual Basic
Public NotInheritable Class Sites
Visual C++
public ref class Sites abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..State..::..Sites

See Also

State..::..Sites Members
Sitecore.Configuration Namespace


State.Sites Members

[image] [image]

Sitecore 6.4.1 API
State..::..Sites Members
State..::..Sites Class Properties See Also Send Feedback

Sitecore maintains a state about the current webpage (in the Items collection) and about the current session (in the Session collection).

Typical information include the current user, the current web item, the current master item, the current layout etc.

The State class encapsulates both the Items and Session collections.

The State..::..Sites type exposes the following members.

Properties

Name | Description
IsSiteResolved | Gets or sets a value indicating whether the current site has been resolved.

See Also

State..::..Sites Class
Sitecore.Configuration Namespace


State.Sites Properties

[image] [image]

Sitecore 6.4.1 API
State..::..Sites Properties
State..::..Sites Class See Also Send Feedback

The State..::..Sites type exposes the following members.

Properties

Name | Description
IsSiteResolved | Gets or sets a value indicating whether the current site has been resolved.

See Also

State..::..Sites Class
Sitecore.Configuration Namespace


IsSiteResolved Property

[image]

Sitecore 6.4.1 API
State..::..Sites..::..IsSiteResolved Property
State..::..Sites Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsSiteResolved { get; set; }
Visual Basic
Public Shared Property IsSiteResolved As Boolean
    Get
    Set
Visual C++
public:
static property bool IsSiteResolved {
    bool get ();
    void set (bool value);
}

Field Value

true if the current site has been resolved; otherwise, false.

See Also

State..::..Sites Class
Sitecore.Configuration Namespace


StateContext Class

[image]

Sitecore 6.4.1 API
StateContext Class
Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class StateContext
Visual Basic
Public Class StateContext
Visual C++
public ref class StateContext

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..StateContext

See Also

StateContext Members
Sitecore.Configuration Namespace


StateContext Members

[image] [image]

Sitecore 6.4.1 API
StateContext Members
StateContext Class Constructors Methods Properties See Also Send Feedback

The StateContext type exposes the following members.

Constructors

 | Name | Description
Public method | StateContext | Initializes a new instance of the StateContext class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DataBind | Gets or sets a boolean that indicates if the DataBind()()()() method should be called for current page.

See Also

StateContext Class
Sitecore.Configuration Namespace


StateContext Constructor

[image]

Sitecore 6.4.1 API
StateContext Constructor
StateContext Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StateContext()
Visual Basic
Public Sub New
Visual C++
public:
StateContext()

See Also

StateContext Class
Sitecore.Configuration Namespace


StateContext Methods

[image] [image]

Sitecore 6.4.1 API
StateContext Methods
StateContext Class See Also Send Feedback

The StateContext type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StateContext Class
Sitecore.Configuration Namespace


StateContext Properties

[image] [image]

Sitecore 6.4.1 API
StateContext Properties
StateContext Class See Also Send Feedback

The StateContext type exposes the following members.

Properties

 | Name | Description
Public property | DataBind | Gets or sets a boolean that indicates if the DataBind()()()() method should be called for current page.

See Also

StateContext Class
Sitecore.Configuration Namespace


DataBind Property

[image]

Sitecore 6.4.1 API
StateContext..::..DataBind Property
StateContext Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool DataBind { get; set; }
Visual Basic
Public Property DataBind As Boolean
    Get
    Set
Visual C++
public:
property bool DataBind {
    bool get ();
    void set (bool value);
}

Field Value

True, if DataBind()()()() should be called, otherwise false.

Remarks

This flag indicates if the DataBind()()()() method should be called by the web engine.

The default value is controlled by AutomaticDataBind.

The scope of the value is page and it is stored in the Items variable "SC_DATA_BIND".

See Also

StateContext Class
Sitecore.Configuration Namespace


WebDAVConfiguration Members

[image] [image]

Sitecore 6.4.1 API
WebDAVConfiguration Members
WebDAVConfiguration Class Methods Properties See Also Send Feedback

The WebDAVConfiguration type exposes the following members.

Methods

Name | Description
AssociateUsernameWithLink | Defines whether username should be associated with WebDAV URL.
AuthenticationRequired | Authenrications the required.
GetAuthenticationProvider()()()() | Gets the authentication ptrovider.
GetAuthenticationProvider(HttpRequest) | Gets the authentication ptrovider.
GetDatabase | Gets the DAV database.
GetDAVUrl(String) | Gets the DAV URL.
GetDAVUrl(HttpContext, ID) | Gets the DAV URL.
GetDAVUrl(HttpContext, ID, Boolean) | Gets the DAV URL.
GetDAVUrl(HttpContext, MediaItem, ID) | Gets the DAV URL.
GetDAVUrl(HttpContext, MediaItem, ID, Boolean) | Gets the DAV URL.
GetDAVUrl(HttpContext, String, ID, Boolean) | Gets the DAV URL.
GetDAVUser | Gets the Web DAV user.
GetLanguage | Gets the language.
GetOptions(HttpContext) | Gets the Web DAV options.
GetOptions(ID) | Gets the options.
GetRootItem | Gets the Web DAV root item.
GetSiteName | Gets the name of the site.
GetView(String) | Gets the Web DAV view.
GetView(HttpContext) | Gets the view.
GetViewNames | Gets the view names.
GetViews | Gets the supported WebDAV views.
IsOpenLinkBehaviorSupported | Determines whether Web DAV modal dialog is supported.
IsReadOnlyMode | Resolves the DAV mode.
IsWebDAVEnabled | Determines whether Web DAV is enabled for current request.
SaveOptions | Saves the Web DAV options.

Properties

Name | Description
DefaultView | Gets the default view.
Locking | Gets the locking.
LockNull | Gets the lock null provider.
Options | Gets the WebDAV options provider.

See Also

WebDAVConfiguration Class
Sitecore.Configuration Namespace


WebDAVConfiguration Methods

[image] [image]

Sitecore 6.4.1 API
WebDAVConfiguration Methods
WebDAVConfiguration Class See Also Send Feedback

The WebDAVConfiguration type exposes the following members.

Methods

Name | Description
AssociateUsernameWithLink | Defines whether username should be associated with WebDAV URL.
AuthenticationRequired | Authenrications the required.
GetAuthenticationProvider()()()() | Gets the authentication ptrovider.
GetAuthenticationProvider(HttpRequest) | Gets the authentication ptrovider.
GetDatabase | Gets the DAV database.
GetDAVUrl(String) | Gets the DAV URL.
GetDAVUrl(HttpContext, ID) | Gets the DAV URL.
GetDAVUrl(HttpContext, ID, Boolean) | Gets the DAV URL.
GetDAVUrl(HttpContext, MediaItem, ID) | Gets the DAV URL.
GetDAVUrl(HttpContext, MediaItem, ID, Boolean) | Gets the DAV URL.
GetDAVUrl(HttpContext, String, ID, Boolean) | Gets the DAV URL.
GetDAVUser | Gets the Web DAV user.
GetLanguage | Gets the language.
GetOptions(HttpContext) | Gets the Web DAV options.
GetOptions(ID) | Gets the options.
GetRootItem | Gets the Web DAV root item.
GetSiteName | Gets the name of the site.
GetView(String) | Gets the Web DAV view.
GetView(HttpContext) | Gets the view.
GetViewNames | Gets the view names.
GetViews | Gets the supported WebDAV views.
IsOpenLinkBehaviorSupported | Determines whether Web DAV modal dialog is supported.
IsReadOnlyMode | Resolves the DAV mode.
IsWebDAVEnabled | Determines whether Web DAV is enabled for current request.
SaveOptions | Saves the Web DAV options.

See Also

WebDAVConfiguration Class
Sitecore.Configuration Namespace


AssociateUsernameWithLink Method

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..AssociateUsernameWithLink Method
WebDAVConfiguration Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool AssociateUsernameWithLink(
    HttpContext context
)
Visual Basic
Public Shared Function AssociateUsernameWithLink ( _
    context As HttpContext _
) As Boolean
Visual C++
public:
static bool AssociateUsernameWithLink(
    HttpContext^ context
)

Parameters

context
Type: System.Web..::..HttpContext
The context.

Return Value

true if user name should be associated with WebDAV link.

See Also

WebDAVConfiguration Class
Sitecore.Configuration Namespace


AuthenticationRequired Method

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..AuthenticationRequired Method
WebDAVConfiguration Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool AuthenticationRequired(
    HttpContext context
)
Visual Basic
Public Shared Function AuthenticationRequired ( _
    context As HttpContext _
) As Boolean
Visual C++
public:
static bool AuthenticationRequired(
    HttpContext^ context
)

Parameters

context
Type: System.Web..::..HttpContext
The context.

Return Value

true if current Request requires authentication.

See Also

WebDAVConfiguration Class
Sitecore.Configuration Namespace


GetAuthenticationProvider Method

[image] [image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..GetAuthenticationProvider Method
WebDAVConfiguration Class See Also Send Feedback

Overload List

Name | Description
GetAuthenticationProvider()()()() | Gets the authentication ptrovider.
GetAuthenticationProvider(HttpRequest) | Gets the authentication ptrovider.

See Also

WebDAVConfiguration Class
WebDAVConfiguration Members
Sitecore.Configuration Namespace


GetAuthenticationProvider Method

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..GetAuthenticationProvider Method
WebDAVConfiguration Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static HttpAuthenticationProvider GetAuthenticationProvider()
Visual Basic
Public Shared Function GetAuthenticationProvider As HttpAuthenticationProvider
Visual C++
public:
static HttpAuthenticationProvider^ GetAuthenticationProvider()

Return Value

The HttpAuthentication provider.

See Also

WebDAVConfiguration Class
GetAuthenticationProvider Overload
Sitecore.Configuration Namespace


GetAuthenticationProvider Method (HttpRequest)

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..GetAuthenticationProvider Method (HttpRequest)
WebDAVConfiguration Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static HttpAuthenticationProvider GetAuthenticationProvider(
    HttpRequest request
)
Visual Basic
Public Shared Function GetAuthenticationProvider ( _
    request As HttpRequest _
) As HttpAuthenticationProvider
Visual C++
public:
static HttpAuthenticationProvider^ GetAuthenticationProvider(
    HttpRequest^ request
)

Parameters

request
Type: System.Web..::..HttpRequest
The request.

Return Value

The HttpAuthentication provider.

See Also

WebDAVConfiguration Class
GetAuthenticationProvider Overload
Sitecore.Configuration Namespace


GetDatabase Method

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..GetDatabase Method
WebDAVConfiguration Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Database GetDatabase(
    HttpContext context
)
Visual Basic
Public Shared Function GetDatabase ( _
    context As HttpContext _
) As Database
Visual C++
public:
static Database^ GetDatabase(
    HttpContext^ context
)

Parameters

context
Type: System.Web..::..HttpContext
The context.

Return Value

The Database to work with.

See Also

WebDAVConfiguration Class
Sitecore.Configuration Namespace


GetDAVUrl Method

[image] [image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..GetDAVUrl Method
WebDAVConfiguration Class See Also Send Feedback

Overload List

Name | Description
GetDAVUrl(String) | Gets the DAV URL.
GetDAVUrl(HttpContext, ID) | Gets the DAV URL.
GetDAVUrl(HttpContext, ID, Boolean) | Gets the DAV URL.
GetDAVUrl(HttpContext, MediaItem, ID) | Gets the DAV URL.
GetDAVUrl(HttpContext, MediaItem, ID, Boolean) | Gets the DAV URL.
GetDAVUrl(HttpContext, String, ID, Boolean) | Gets the DAV URL.

See Also

WebDAVConfiguration Class
WebDAVConfiguration Members
Sitecore.Configuration Namespace


GetDAVUrl Method (String)

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..GetDAVUrl Method (String)
WebDAVConfiguration Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetDAVUrl(
    string mediaPath
)
Visual Basic
Public Shared Function GetDAVUrl ( _
    mediaPath As String _
) As String
Visual C++
public:
static String^ GetDAVUrl(
    String^ mediaPath
)

Parameters

mediaPath
Type: System..::..String
The media path.

Return Value

The Web DAV Url.

See Also

WebDAVConfiguration Class
GetDAVUrl Overload
Sitecore.Configuration Namespace


GetDAVUrl Method (HttpContext, ID)

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..GetDAVUrl Method (HttpContext, ID)
WebDAVConfiguration Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetDAVUrl(
    HttpContext context,
    ID optionsID
)
Visual Basic
Public Shared Function GetDAVUrl ( _
    context As HttpContext, _
    optionsID As ID _
) As String
Visual C++
public:
static String^ GetDAVUrl(
    HttpContext^ context,
    ID^ optionsID
)

Parameters

context
Type: System.Web..::..HttpContext
The context.
optionsID
Type: Sitecore.Data..::..ID
The options ID.

Return Value

The Web DAV Url.

See Also

WebDAVConfiguration Class
GetDAVUrl Overload
Sitecore.Configuration Namespace


GetDAVUrl Method (HttpContext, MediaItem, ID)

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..GetDAVUrl Method (HttpContext, MediaItem, ID)
WebDAVConfiguration Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetDAVUrl(
    HttpContext context,
    MediaItem item,
    ID optionID
)
Visual Basic
Public Shared Function GetDAVUrl ( _
    context As HttpContext, _
    item As MediaItem, _
    optionID As ID _
) As String
Visual C++
public:
static String^ GetDAVUrl(
    HttpContext^ context,
    MediaItem^ item,
    ID^ optionID
)

Parameters

context
Type: System.Web..::..HttpContext
The context.
item
Type: Sitecore.Data.Items..::..MediaItem
The Sitecore item.
optionID
Type: Sitecore.Data..::..ID
The option ID.

Return Value

The WebDAV Url.

See Also

WebDAVConfiguration Class
GetDAVUrl Overload
Sitecore.Configuration Namespace


GetDAVUrl Method (HttpContext, MediaItem, ID, Boolean)

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..GetDAVUrl Method (HttpContext, MediaItem, ID, Boolean)
WebDAVConfiguration Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetDAVUrl(
    HttpContext context,
    MediaItem item,
    ID optionID,
    bool fullUrl
)
Visual Basic
Public Shared Function GetDAVUrl ( _
    context As HttpContext, _
    item As MediaItem, _
    optionID As ID, _
    fullUrl As Boolean _
) As String
Visual C++
public:
static String^ GetDAVUrl(
    HttpContext^ context,
    MediaItem^ item,
    ID^ optionID,
    bool fullUrl
)

Parameters

context
Type: System.Web..::..HttpContext
The context.
item
Type: Sitecore.Data.Items..::..MediaItem
The Sitecore item.
optionID
Type: Sitecore.Data..::..ID
The option ID.
fullUrl
Type: System..::..Boolean
if set to true schema and hostname will be included into a URL.

Return Value

The WebDAV Url.

See Also

WebDAVConfiguration Class
GetDAVUrl Overload
Sitecore.Configuration Namespace


GetDAVUser Method

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..GetDAVUser Method
WebDAVConfiguration Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static User GetDAVUser(
    HttpContext context
)
Visual Basic
Public Shared Function GetDAVUser ( _
    context As HttpContext _
) As User
Visual C++
public:
static User^ GetDAVUser(
    HttpContext^ context
)

Parameters

context
Type: System.Web..::..HttpContext
The Http context.

Return Value

The Web DAV user.

See Also

WebDAVConfiguration Class
Sitecore.Configuration Namespace


GetOptions Method

[image] [image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..GetOptions Method
WebDAVConfiguration Class See Also Send Feedback

Overload List

Name | Description
GetOptions(HttpContext) | Gets the Web DAV options.
GetOptions(ID) | Gets the options.

See Also

WebDAVConfiguration Class
WebDAVConfiguration Members
Sitecore.Configuration Namespace


GetOptions Method (HttpContext)

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..GetOptions Method (HttpContext)
WebDAVConfiguration Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static WebDAVOptions GetOptions(
    HttpContext context
)
Visual Basic
Public Shared Function GetOptions ( _
    context As HttpContext _
) As WebDAVOptions
Visual C++
public:
static WebDAVOptions^ GetOptions(
    HttpContext^ context
)

Parameters

context
Type: System.Web..::..HttpContext
The HttpContext.

Return Value

Web DAV options object.

See Also

WebDAVConfiguration Class
GetOptions Overload
Sitecore.Configuration Namespace


GetOptions Method (ID)

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..GetOptions Method (ID)
WebDAVConfiguration Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static WebDAVOptions GetOptions(
    ID optionsID
)
Visual Basic
Public Shared Function GetOptions ( _
    optionsID As ID _
) As WebDAVOptions
Visual C++
public:
static WebDAVOptions^ GetOptions(
    ID^ optionsID
)

Parameters

optionsID
Type: Sitecore.Data..::..ID
The options ID.

Return Value

Web DAV Options.

See Also

WebDAVConfiguration Class
GetOptions Overload
Sitecore.Configuration Namespace


GetRootItem Method

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..GetRootItem Method
WebDAVConfiguration Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item GetRootItem(
    HttpContext context
)
Visual Basic
Public Shared Function GetRootItem ( _
    context As HttpContext _
) As Item
Visual C++
public:
static Item^ GetRootItem(
    HttpContext^ context
)

Parameters

context
Type: System.Web..::..HttpContext
The Http context.

Return Value

Web DAV root item.

See Also

WebDAVConfiguration Class
Sitecore.Configuration Namespace


GetSiteName Method

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..GetSiteName Method
WebDAVConfiguration Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetSiteName(
    HttpContext context
)
Visual Basic
Public Shared Function GetSiteName ( _
    context As HttpContext _
) As String
Visual C++
public:
static String^ GetSiteName(
    HttpContext^ context
)

Parameters

context
Type: System.Web..::..HttpContext
The context.

Return Value

The Site name.

See Also

WebDAVConfiguration Class
Sitecore.Configuration Namespace


GetView Method

[image] [image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..GetView Method
WebDAVConfiguration Class See Also Send Feedback

Overload List

Name | Description
GetView(String) | Gets the Web DAV view.
GetView(HttpContext) | Gets the view.

See Also

WebDAVConfiguration Class
WebDAVConfiguration Members
Sitecore.Configuration Namespace


GetView Method (String)

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..GetView Method (String)
WebDAVConfiguration Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static WebDAVView GetView(
    string viewName
)
Visual Basic
Public Shared Function GetView ( _
    viewName As String _
) As WebDAVView
Visual C++
public:
static WebDAVView^ GetView(
    String^ viewName
)

Parameters

viewName
Type: System..::..String
Name of the view.

Return Value

The Web DAV View.

See Also

WebDAVConfiguration Class
GetView Overload
Sitecore.Configuration Namespace


GetView Method (HttpContext)

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..GetView Method (HttpContext)
WebDAVConfiguration Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static WebDAVView GetView(
    HttpContext context
)
Visual Basic
Public Shared Function GetView ( _
    context As HttpContext _
) As WebDAVView
Visual C++
public:
static WebDAVView^ GetView(
    HttpContext^ context
)

Parameters

context
Type: System.Web..::..HttpContext
The context.

Return Value

Web DAV View.

See Also

WebDAVConfiguration Class
GetView Overload
Sitecore.Configuration Namespace


GetViewNames Method

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..GetViewNames Method
WebDAVConfiguration Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static List<string> GetViewNames()
Visual Basic
Public Shared Function GetViewNames As List(Of String)
Visual C++
public:
static List<String^>^ GetViewNames()

Return Value

List of Web DAV view names.

See Also

WebDAVConfiguration Class
Sitecore.Configuration Namespace


GetViews Method

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..GetViews Method
WebDAVConfiguration Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static List<WebDAVView> GetViews()
Visual Basic
Public Shared Function GetViews As List(Of WebDAVView)
Visual C++
public:
static List<WebDAVView^>^ GetViews()

Return Value

Collection of supported WebDAV views.

See Also

WebDAVConfiguration Class
Sitecore.Configuration Namespace


IsOpenLinkBehaviorSupported Method

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..IsOpenLinkBehaviorSupported Method
WebDAVConfiguration Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsOpenLinkBehaviorSupported()
Visual Basic
Public Shared Function IsOpenLinkBehaviorSupported As Boolean
Visual C++
public:
static bool IsOpenLinkBehaviorSupported()

Return Value

true if Web DAV modal dialog is supported; otherwise, false.

See Also

WebDAVConfiguration Class
Sitecore.Configuration Namespace


IsReadOnlyMode Method

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..IsReadOnlyMode Method
WebDAVConfiguration Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsReadOnlyMode(
    HttpContext context
)
Visual Basic
Public Shared Function IsReadOnlyMode ( _
    context As HttpContext _
) As Boolean
Visual C++
public:
static bool IsReadOnlyMode(
    HttpContext^ context
)

Parameters

context
Type: System.Web..::..HttpContext
The context.

Return Value

true if Web DAV is in Read-only mode; otherwise, false.

See Also

WebDAVConfiguration Class
Sitecore.Configuration Namespace


IsWebDAVEnabled Method

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..IsWebDAVEnabled Method
WebDAVConfiguration Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsWebDAVEnabled(
    bool checkBrowserAgent
)
Visual Basic
Public Shared Function IsWebDAVEnabled ( _
    checkBrowserAgent As Boolean _
) As Boolean
Visual C++
public:
static bool IsWebDAVEnabled(
    bool checkBrowserAgent
)

Parameters

checkBrowserAgent
Type: System..::..Boolean
if set to true the check is performed from Sheer UI.

Return Value

true if we can process WebDAV requests; otherwise, false.

See Also

WebDAVConfiguration Class
Sitecore.Configuration Namespace


SaveOptions Method

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..SaveOptions Method
WebDAVConfiguration Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID SaveOptions(
    WebDAVOptions options
)
Visual Basic
Public Shared Function SaveOptions ( _
    options As WebDAVOptions _
) As ID
Visual C++
public:
static ID^ SaveOptions(
    WebDAVOptions^ options
)

Parameters

options
Type: Sitecore.Configuration..::..WebDAVOptions
The Web DAV options.

Return Value

Options identifier. Note: may differs from Options.ID

See Also

WebDAVConfiguration Class
Sitecore.Configuration Namespace


WebDAVConfiguration Properties

[image] [image]

Sitecore 6.4.1 API
WebDAVConfiguration Properties
WebDAVConfiguration Class See Also Send Feedback

The WebDAVConfiguration type exposes the following members.

Properties

Name | Description
DefaultView | Gets the default view.
Locking | Gets the locking.
LockNull | Gets the lock null provider.
Options | Gets the WebDAV options provider.

See Also

WebDAVConfiguration Class
Sitecore.Configuration Namespace


DefaultView Property

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..DefaultView Property
WebDAVConfiguration Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static WebDAVView DefaultView { get; }
Visual Basic
Public Shared ReadOnly Property DefaultView As WebDAVView
    Get
Visual C++
public:
static property WebDAVView^ DefaultView {
    WebDAVView^ get ();
}

Field Value

The default view.

See Also

WebDAVConfiguration Class
Sitecore.Configuration Namespace


Locking Property

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..Locking Property
WebDAVConfiguration Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static WebDAVLockingProvider Locking { get; }
Visual Basic
Public Shared ReadOnly Property Locking As WebDAVLockingProvider
    Get
Visual C++
public:
static property WebDAVLockingProvider^ Locking {
    WebDAVLockingProvider^ get ();
}

Field Value

The locking provider.

See Also

WebDAVConfiguration Class
Sitecore.Configuration Namespace


LockNull Property

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..LockNull Property
WebDAVConfiguration Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static WebDAVLockNullProvider LockNull { get; }
Visual Basic
Public Shared ReadOnly Property LockNull As WebDAVLockNullProvider
    Get
Visual C++
public:
static property WebDAVLockNullProvider^ LockNull {
    WebDAVLockNullProvider^ get ();
}

Field Value

The lock null provider.

See Also

WebDAVConfiguration Class
Sitecore.Configuration Namespace


Options Property

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..Options Property
WebDAVConfiguration Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static WebDAVOptionStore Options { get; }
Visual Basic
Public Shared ReadOnly Property Options As WebDAVOptionStore
    Get
Visual C++
public:
static property WebDAVOptionStore^ Options {
    WebDAVOptionStore^ get ();
}

Field Value

The WebDAV options provider.

See Also

WebDAVConfiguration Class
Sitecore.Configuration Namespace


WebDAVConfiguration.Authentication Class

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..Authentication Class
WebDAVConfiguration Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Authentication
Visual Basic
Public Class Authentication
Visual C++
public ref class Authentication

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..WebDAVConfiguration..::..Authentication

See Also

WebDAVConfiguration..::..Authentication Members
Sitecore.Configuration Namespace


WebDAVConfiguration.Authentication Members

[image] [image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..Authentication Members
WebDAVConfiguration..::..Authentication Class Constructors Methods Properties See Also Send Feedback

Web DAV configuration.

The WebDAVConfiguration..::..Authentication type exposes the following members.

Constructors

 | Name | Description
Public method | WebDAVConfiguration..::..Authentication | Initializes a new instance of the WebDAVConfiguration..::..Authentication class

Methods

 | Name | Description
Public method | AddAuthenticationMapping | Adds the authentication mapping.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProvider | Gets the provider.
Protected method | GetProviderName | Gets the name of the provider.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PreferredAuthentication | Gets or sets the preferred authentication provider.

See Also

WebDAVConfiguration..::..Authentication Class
Sitecore.Configuration Namespace


WebDAVConfiguration.Authentication Constructor

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..Authentication Constructor
WebDAVConfiguration..::..Authentication Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Authentication()
Visual Basic
Public Sub New
Visual C++
public:
Authentication()

See Also

WebDAVConfiguration..::..Authentication Class
Sitecore.Configuration Namespace


WebDAVConfiguration.Authentication Methods

[image] [image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..Authentication Methods
WebDAVConfiguration..::..Authentication Class See Also Send Feedback

The WebDAVConfiguration..::..Authentication type exposes the following members.

Methods

 | Name | Description
Public method | AddAuthenticationMapping | Adds the authentication mapping.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProvider | Gets the provider.
Protected method | GetProviderName | Gets the name of the provider.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WebDAVConfiguration..::..Authentication Class
Sitecore.Configuration Namespace


AddAuthenticationMapping Method

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..Authentication..::..AddAuthenticationMapping Method
WebDAVConfiguration..::..Authentication Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddAuthenticationMapping(
    XmlNode configNode
)
Visual Basic
Public Sub AddAuthenticationMapping ( _
    configNode As XmlNode _
)
Visual C++
public:
void AddAuthenticationMapping(
    XmlNode^ configNode
)

Parameters

configNode
Type: System.Xml..::..XmlNode
The config node.

See Also

WebDAVConfiguration..::..Authentication Class
Sitecore.Configuration Namespace


GetProvider Method

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..Authentication..::..GetProvider Method
WebDAVConfiguration..::..Authentication Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HttpAuthenticationProvider GetProvider(
    HttpRequest request
)
Visual Basic
Public Function GetProvider ( _
    request As HttpRequest _
) As HttpAuthenticationProvider
Visual C++
public:
HttpAuthenticationProvider^ GetProvider(
    HttpRequest^ request
)

Parameters

request
Type: System.Web..::..HttpRequest
The request.

Return Value

The Authentication provider.

See Also

WebDAVConfiguration..::..Authentication Class
Sitecore.Configuration Namespace


WebDAVConfiguration.Authentication Properties

[image] [image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..Authentication Properties
WebDAVConfiguration..::..Authentication Class See Also Send Feedback

The WebDAVConfiguration..::..Authentication type exposes the following members.

Properties

 | Name | Description
Public property | PreferredAuthentication | Gets or sets the preferred authentication provider.

See Also

WebDAVConfiguration..::..Authentication Class
Sitecore.Configuration Namespace


PreferredAuthentication Property

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..Authentication..::..PreferredAuthentication Property
WebDAVConfiguration..::..Authentication Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string PreferredAuthentication { get; set; }
Visual Basic
Public Property PreferredAuthentication As String
    Get
    Set
Visual C++
public:
property String^ PreferredAuthentication {
    String^ get ();
    void set (String^ value);
}

Field Value

The preferred authentication provider.

See Also

WebDAVConfiguration..::..Authentication Class
Sitecore.Configuration Namespace


WebDAVConfiguration.Authentication.UserAgent Class

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..Authentication..::..UserAgent Class
WebDAVConfiguration..::..Authentication Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class UserAgent
Visual Basic
Public Class UserAgent
Visual C++
public ref class UserAgent

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..WebDAVConfiguration..::..Authentication..::..UserAgent

See Also

WebDAVConfiguration..::..Authentication..::..UserAgent Members
Sitecore.Configuration Namespace


WebDAVConfiguration.Authentication.UserAgent Members

[image] [image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..Authentication..::..UserAgent Members
WebDAVConfiguration..::..Authentication..::..UserAgent Class Constructors Methods See Also Send Feedback

Web DAV Authentication.

The WebDAVConfiguration..::..Authentication..::..UserAgent type exposes the following members.

Constructors

 | Name | Description
Public method | WebDAVConfiguration..::..Authentication..::..UserAgent | Initializes a new instance of the WebDAVConfiguration..::..Authentication..::..UserAgent class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsMatch | Determines whether the specified request is using current User Agent.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WebDAVConfiguration..::..Authentication..::..UserAgent Class
Sitecore.Configuration Namespace


WebDAVConfiguration.Authentication.UserAgent Constructor

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..Authentication..::..UserAgent Constructor
WebDAVConfiguration..::..Authentication..::..UserAgent Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UserAgent(
    string pattern
)
Visual Basic
Public Sub New ( _
    pattern As String _
)
Visual C++
public:
UserAgent(
    String^ pattern
)

Parameters

pattern
Type: System..::..String
The pattern.

See Also

WebDAVConfiguration..::..Authentication..::..UserAgent Class
Sitecore.Configuration Namespace


WebDAVConfiguration.Authentication.UserAgent Methods

[image] [image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..Authentication..::..UserAgent Methods
WebDAVConfiguration..::..Authentication..::..UserAgent Class See Also Send Feedback

The WebDAVConfiguration..::..Authentication..::..UserAgent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsMatch | Determines whether the specified request is using current User Agent.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WebDAVConfiguration..::..Authentication..::..UserAgent Class
Sitecore.Configuration Namespace


IsMatch Method

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..Authentication..::..UserAgent..::..IsMatch Method
WebDAVConfiguration..::..Authentication..::..UserAgent Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsMatch(
    HttpRequest request
)
Visual Basic
Public Function IsMatch ( _
    request As HttpRequest _
) As Boolean
Visual C++
public:
bool IsMatch(
    HttpRequest^ request
)

Parameters

request
Type: System.Web..::..HttpRequest
The request.

Return Value

true if the specified request is using current User Agent; otherwise, false.

See Also

WebDAVConfiguration..::..Authentication..::..UserAgent Class
Sitecore.Configuration Namespace


WebDAVConfiguration.WebDAVMode Enumeration

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..WebDAVMode Enumeration
WebDAVConfiguration Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum WebDAVMode
Visual Basic
Public Enumeration WebDAVMode
Visual C++
public enum class WebDAVMode

Members

Member name | Value | Description
Default | 0 | Default mode
ReadOnly | 1 | Read-only mode.

See Also

Sitecore.Configuration Namespace


WebDAVConfiguration.WebDAVUrl Class

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..WebDAVUrl Class
WebDAVConfiguration Class Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class WebDAVUrl
Visual Basic
Public Class WebDAVUrl
Visual C++
public ref class WebDAVUrl

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..WebDAVConfiguration..::..WebDAVUrl

See Also

WebDAVConfiguration..::..WebDAVUrl Members
Sitecore.Configuration Namespace


WebDAVConfiguration.WebDAVUrl Members

[image] [image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..WebDAVUrl Members
WebDAVConfiguration..::..WebDAVUrl Class Constructors Methods Properties See Also Send Feedback

Web DAV configuration.

The WebDAVConfiguration..::..WebDAVUrl type exposes the following members.

Constructors

 | Name | Description
Public method | WebDAVConfiguration..::..WebDAVUrl | Initializes a new instance of the WebDAVConfiguration..::..WebDAVUrl class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse(String) | Parses the specified URL.
 | Parse(HttpRequest) | Parses the specified request.
Public method | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToString(HttpRequest, Boolean) | Gets the DAV URL.

Properties

 | Name | Description
Public property | MediaPath | Gets the media path.
Public property | OptionsID | Gets the WebDAV options ID.

See Also

WebDAVConfiguration..::..WebDAVUrl Class
Sitecore.Configuration Namespace


WebDAVConfiguration.WebDAVUrl Constructor

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..WebDAVUrl Constructor
WebDAVConfiguration..::..WebDAVUrl Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WebDAVUrl(
    ID optionsID,
    string mediaPath
)
Visual Basic
Public Sub New ( _
    optionsID As ID, _
    mediaPath As String _
)
Visual C++
public:
WebDAVUrl(
    ID^ optionsID,
    String^ mediaPath
)

Parameters

optionsID
Type: Sitecore.Data..::..ID
The WebDAV options ID.
mediaPath
Type: System..::..String
The requested media path.

See Also

WebDAVConfiguration..::..WebDAVUrl Class
Sitecore.Configuration Namespace


WebDAVConfiguration.WebDAVUrl Methods

[image] [image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..WebDAVUrl Methods
WebDAVConfiguration..::..WebDAVUrl Class See Also Send Feedback

The WebDAVConfiguration..::..WebDAVUrl type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse(String) | Parses the specified URL.
 | Parse(HttpRequest) | Parses the specified request.
Public method | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToString(HttpRequest, Boolean) | Gets the DAV URL.

See Also

WebDAVConfiguration..::..WebDAVUrl Class
Sitecore.Configuration Namespace


Parse Method

[image] [image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..WebDAVUrl..::..Parse Method
WebDAVConfiguration..::..WebDAVUrl Class See Also Send Feedback

Overload List

Name | Description
Parse(String) | Parses the specified URL.
Parse(HttpRequest) | Parses the specified request.

See Also

WebDAVConfiguration..::..WebDAVUrl Class
WebDAVConfiguration..::..WebDAVUrl Members
Sitecore.Configuration Namespace


Parse Method (String)

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..WebDAVUrl..::..Parse Method (String)
WebDAVConfiguration..::..WebDAVUrl Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static WebDAVConfiguration..::..WebDAVUrl Parse(
    string url
)
Visual Basic
Public Shared Function Parse ( _
    url As String _
) As WebDAVConfiguration..::..WebDAVUrl
Visual C++
public:
static WebDAVConfiguration..::..WebDAVUrl^ Parse(
    String^ url
)

Parameters

url
Type: System..::..String
The raw URL.

Return Value

WebDAV Url object.

See Also

WebDAVConfiguration..::..WebDAVUrl Class
Parse Overload
Sitecore.Configuration Namespace


Parse Method (HttpRequest)

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..WebDAVUrl..::..Parse Method (HttpRequest)
WebDAVConfiguration..::..WebDAVUrl Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static WebDAVConfiguration..::..WebDAVUrl Parse(
    HttpRequest request
)
Visual Basic
Public Shared Function Parse ( _
    request As HttpRequest _
) As WebDAVConfiguration..::..WebDAVUrl
Visual C++
public:
static WebDAVConfiguration..::..WebDAVUrl^ Parse(
    HttpRequest^ request
)

Parameters

request
Type: System.Web..::..HttpRequest
The request.

Return Value

The WebDAV Url.

See Also

WebDAVConfiguration..::..WebDAVUrl Class
Parse Overload
Sitecore.Configuration Namespace


ToString Method

[image] [image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..WebDAVUrl..::..ToString Method
WebDAVConfiguration..::..WebDAVUrl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToString(HttpRequest, Boolean) | Gets the DAV URL.

See Also

WebDAVConfiguration..::..WebDAVUrl Class
WebDAVConfiguration..::..WebDAVUrl Members
Sitecore.Configuration Namespace


ToString Method (HttpRequest, Boolean)

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..WebDAVUrl..::..ToString Method (HttpRequest, Boolean)
WebDAVConfiguration..::..WebDAVUrl Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ToString(
    HttpRequest request,
    bool fullUrl
)
Visual Basic
Public Function ToString ( _
    request As HttpRequest, _
    fullUrl As Boolean _
) As String
Visual C++
public:
String^ ToString(
    HttpRequest^ request,
    bool fullUrl
)

Parameters

request
Type: System.Web..::..HttpRequest
The request.
fullUrl
Type: System..::..Boolean
if set to true schema and hostname will be included into a URL.

Return Value

The WebDAV Url.

See Also

WebDAVConfiguration..::..WebDAVUrl Class
ToString Overload
Sitecore.Configuration Namespace


WebDAVConfiguration.WebDAVUrl Properties

[image] [image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..WebDAVUrl Properties
WebDAVConfiguration..::..WebDAVUrl Class See Also Send Feedback

The WebDAVConfiguration..::..WebDAVUrl type exposes the following members.

Properties

 | Name | Description
Public property | MediaPath | Gets the media path.
Public property | OptionsID | Gets the WebDAV options ID.

See Also

WebDAVConfiguration..::..WebDAVUrl Class
Sitecore.Configuration Namespace


MediaPath Property

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..WebDAVUrl..::..MediaPath Property
WebDAVConfiguration..::..WebDAVUrl Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string MediaPath { get; }
Visual Basic
Public ReadOnly Property MediaPath As String
    Get
Visual C++
public:
property String^ MediaPath {
    String^ get ();
}

Field Value

The media path.

See Also

WebDAVConfiguration..::..WebDAVUrl Class
Sitecore.Configuration Namespace


OptionsID Property

[image]

Sitecore 6.4.1 API
WebDAVConfiguration..::..WebDAVUrl..::..OptionsID Property
WebDAVConfiguration..::..WebDAVUrl Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID OptionsID { get; }
Visual Basic
Public ReadOnly Property OptionsID As ID
    Get
Visual C++
public:
property ID^ OptionsID {
    ID^ get ();
}

Field Value

The WebDAV options ID.

See Also

WebDAVConfiguration..::..WebDAVUrl Class
Sitecore.Configuration Namespace


WebDAVOptions Class

[image]

Sitecore 6.4.1 API
WebDAVOptions Class
Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class WebDAVOptions
Visual Basic
Public Class WebDAVOptions
Visual C++
public ref class WebDAVOptions

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..WebDAVOptions

See Also

WebDAVOptions Members
Sitecore.Configuration Namespace


WebDAVOptions Members

[image] [image]

Sitecore 6.4.1 API
WebDAVOptions Members
WebDAVOptions Class Constructors Methods Properties See Also Send Feedback

The WebDAVOptions type exposes the following members.

Constructors

 | Name | Description
Public method | WebDAVOptions | Initializes a new instance of the WebDAVOptions class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTristateProperty | Gets the bool property.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetTristateProperty | Sets the tristate property.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreationDate | Gets the creation date.
Public property | DavUserName | Gets or sets the DAV context user name.
Public property | Options | Gets the options.
Public property | ReadOnlyMode | Gets or sets the read only mode.
Public property | RequiresAuthentication | Gets or sets the whether WebDAV requires authentication or not.
Public property | RootUri | Gets or sets the root ID.
Public property | SiteName | Gets or sets the name of the site.
Public property | ViewName | Gets or sets the name of the view.

See Also

WebDAVOptions Class
Sitecore.Configuration Namespace


WebDAVOptions Constructor

[image]

Sitecore 6.4.1 API
WebDAVOptions Constructor
WebDAVOptions Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WebDAVOptions()
Visual Basic
Public Sub New
Visual C++
public:
WebDAVOptions()

See Also

WebDAVOptions Class
Sitecore.Configuration Namespace


WebDAVOptions Methods

[image] [image]

Sitecore 6.4.1 API
WebDAVOptions Methods
WebDAVOptions Class See Also Send Feedback

The WebDAVOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTristateProperty | Gets the bool property.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetTristateProperty | Sets the tristate property.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WebDAVOptions Class
Sitecore.Configuration Namespace


GetTristateProperty Method

[image]

Sitecore 6.4.1 API
WebDAVOptions..::..GetTristateProperty Method
WebDAVOptions Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual Tristate GetTristateProperty(
    string name
)
Visual Basic
Protected Overridable Function GetTristateProperty ( _
    name As String _
) As Tristate
Visual C++
protected:
virtual Tristate GetTristateProperty(
    String^ name
)

Parameters

name
Type: System..::..String
The property name.

Return Value

Value of the property

See Also

WebDAVOptions Class
Sitecore.Configuration Namespace


WebDAVOptions Properties

[image] [image]

Sitecore 6.4.1 API
WebDAVOptions Properties
WebDAVOptions Class See Also Send Feedback

The WebDAVOptions type exposes the following members.

Properties

 | Name | Description
Public property | CreationDate | Gets the creation date.
Public property | DavUserName | Gets or sets the DAV context user name.
Public property | Options | Gets the options.
Public property | ReadOnlyMode | Gets or sets the read only mode.
Public property | RequiresAuthentication | Gets or sets the whether WebDAV requires authentication or not.
Public property | RootUri | Gets or sets the root ID.
Public property | SiteName | Gets or sets the name of the site.
Public property | ViewName | Gets or sets the name of the view.

See Also

WebDAVOptions Class
Sitecore.Configuration Namespace


CreationDate Property

[image]

Sitecore 6.4.1 API
WebDAVOptions..::..CreationDate Property
WebDAVOptions Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime CreationDate { get; }
Visual Basic
Public ReadOnly Property CreationDate As DateTime
    Get
Visual C++
public:
property DateTime CreationDate {
    DateTime get ();
}

Field Value

The creation date.

See Also

WebDAVOptions Class
Sitecore.Configuration Namespace


DavUserName Property

[image]

Sitecore 6.4.1 API
WebDAVOptions..::..DavUserName Property
WebDAVOptions Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string DavUserName { get; set; }
Visual Basic
Public Overridable Property DavUserName As String
    Get
    Set
Visual C++
public:
virtual property String^ DavUserName {
    String^ get ();
    void set (String^ value);
}

Field Value

The DAB user name.

See Also

WebDAVOptions Class
Sitecore.Configuration Namespace


Options Property

[image]

Sitecore 6.4.1 API
WebDAVOptions..::..Options Property
WebDAVOptions Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual SortedDictionary<string, string> Options { get; }
Visual Basic
Public Overridable ReadOnly Property Options As SortedDictionary(Of String, String)
    Get
Visual C++
public:
virtual property SortedDictionary<String^, String^>^ Options {
    SortedDictionary<String^, String^>^ get ();
}

Field Value

The options.

See Also

WebDAVOptions Class
Sitecore.Configuration Namespace


ReadOnlyMode Property

[image]

Sitecore 6.4.1 API
WebDAVOptions..::..ReadOnlyMode Property
WebDAVOptions Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Tristate ReadOnlyMode { get; set; }
Visual Basic
Public Overridable Property ReadOnlyMode As Tristate
    Get
    Set
Visual C++
public:
virtual property Tristate ReadOnlyMode {
    Tristate get ();
    void set (Tristate value);
}

Field Value

The read only mode.

See Also

WebDAVOptions Class
Sitecore.Configuration Namespace


RequiresAuthentication Property

[image]

Sitecore 6.4.1 API
WebDAVOptions..::..RequiresAuthentication Property
WebDAVOptions Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Tristate RequiresAuthentication { get; set; }
Visual Basic
Public Overridable Property RequiresAuthentication As Tristate
    Get
    Set
Visual C++
public:
virtual property Tristate RequiresAuthentication {
    Tristate get ();
    void set (Tristate value);
}

Field Value

Tristate value.

See Also

WebDAVOptions Class
Sitecore.Configuration Namespace


RootUri Property

[image]

Sitecore 6.4.1 API
WebDAVOptions..::..RootUri Property
WebDAVOptions Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ItemUri RootUri { get; set; }
Visual Basic
Public Overridable Property RootUri As ItemUri
    Get
    Set
Visual C++
public:
virtual property ItemUri^ RootUri {
    ItemUri^ get ();
    void set (ItemUri^ value);
}

Field Value

The root ID.

See Also

WebDAVOptions Class
Sitecore.Configuration Namespace


SiteName Property

[image]

Sitecore 6.4.1 API
WebDAVOptions..::..SiteName Property
WebDAVOptions Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string SiteName { get; set; }
Visual Basic
Public Overridable Property SiteName As String
    Get
    Set
Visual C++
public:
virtual property String^ SiteName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the site.

See Also

WebDAVOptions Class
Sitecore.Configuration Namespace


WebDAVOptionStore Class

[image]

Sitecore 6.4.1 API
WebDAVOptionStore Class
Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class WebDAVOptionStore
Visual Basic
Public MustInherit Class WebDAVOptionStore
Visual C++
public ref class WebDAVOptionStore abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..WebDAVOptionStore
Sitecore.Configuration..::..IDTableWebDAVOptionStore

See Also

WebDAVOptionStore Members
Sitecore.Configuration Namespace


WebDAVOptionStore Members

[image] [image]

Sitecore 6.4.1 API
WebDAVOptionStore Members
WebDAVOptionStore Class Constructors Methods Properties See Also Send Feedback

The WebDAVOptionStore type exposes the following members.

Constructors

 | Name | Description
Protected method | WebDAVOptionStore | Initializes a new instance of the WebDAVOptionStore class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetExpiredOptions | Gets the expired options.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOption | Gets the option by Option ID.
Public method | GetOptionIDs | Gets the list of option IDs.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveOption | Removes the WebDAV option with specified ID.
Public method | SaveOption | Saves the option.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DefaultOption | Gets the default options.

See Also

WebDAVOptionStore Class
Sitecore.Configuration Namespace


WebDAVOptionStore Constructor

[image]

Sitecore 6.4.1 API
WebDAVOptionStore Constructor
WebDAVOptionStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected WebDAVOptionStore()
Visual Basic
Protected Sub New
Visual C++
protected:
WebDAVOptionStore()

See Also

WebDAVOptionStore Class
Sitecore.Configuration Namespace


WebDAVOptionStore Methods

[image] [image]

Sitecore 6.4.1 API
WebDAVOptionStore Methods
WebDAVOptionStore Class See Also Send Feedback

The WebDAVOptionStore type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetExpiredOptions | Gets the expired options.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOption | Gets the option by Option ID.
Public method | GetOptionIDs | Gets the list of option IDs.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveOption | Removes the WebDAV option with specified ID.
Public method | SaveOption | Saves the option.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WebDAVOptionStore Class
Sitecore.Configuration Namespace


GetExpiredOptions Method

[image]

Sitecore 6.4.1 API
WebDAVOptionStore..::..GetExpiredOptions Method
WebDAVOptionStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract Dictionary<ID, WebDAVOptions> GetExpiredOptions(
    TimeSpan expirationSpan
)
Visual Basic
Public MustOverride Function GetExpiredOptions ( _
    expirationSpan As TimeSpan _
) As Dictionary(Of ID, WebDAVOptions)
Visual C++
public:
virtual Dictionary<ID^, WebDAVOptions^>^ GetExpiredOptions(
    TimeSpan expirationSpan
) abstract

Parameters

expirationSpan
Type: System..::..TimeSpan
The expiration span.

Return Value

The expired options.

See Also

WebDAVOptionStore Class
Sitecore.Configuration Namespace


GetOption Method

[image]

Sitecore 6.4.1 API
WebDAVOptionStore..::..GetOption Method
WebDAVOptionStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract WebDAVOptions GetOption(
    ID optionID
)
Visual Basic
Public MustOverride Function GetOption ( _
    optionID As ID _
) As WebDAVOptions
Visual C++
public:
virtual WebDAVOptions^ GetOption(
    ID^ optionID
) abstract

Parameters

optionID
Type: Sitecore.Data..::..ID
The option ID.

Return Value

The Web DAV Option.

See Also

WebDAVOptionStore Class
Sitecore.Configuration Namespace


GetOptionIDs Method

[image]

Sitecore 6.4.1 API
WebDAVOptionStore..::..GetOptionIDs Method
WebDAVOptionStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract List<ID> GetOptionIDs()
Visual Basic
Public MustOverride Function GetOptionIDs As List(Of ID)
Visual C++
public:
virtual List<ID^>^ GetOptionIDs() abstract

Return Value

The list of IDs.

See Also

WebDAVOptionStore Class
Sitecore.Configuration Namespace


RemoveOption Method

[image]

Sitecore 6.4.1 API
WebDAVOptionStore..::..RemoveOption Method
WebDAVOptionStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract void RemoveOption(
    ID optionID
)
Visual Basic
Public MustOverride Sub RemoveOption ( _
    optionID As ID _
)
Visual C++
public:
virtual void RemoveOption(
    ID^ optionID
) abstract

Parameters

optionID
Type: Sitecore.Data..::..ID
The option ID.

See Also

WebDAVOptionStore Class
Sitecore.Configuration Namespace


SaveOption Method

[image]

Sitecore 6.4.1 API
WebDAVOptionStore..::..SaveOption Method
WebDAVOptionStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract ID SaveOption(
    WebDAVOptions option
)
Visual Basic
Public MustOverride Function SaveOption ( _
    option As WebDAVOptions _
) As ID
Visual C++
public:
virtual ID^ SaveOption(
    WebDAVOptions^ option
) abstract

Parameters

option
Type: Sitecore.Configuration..::..WebDAVOptions
The option.

Return Value

The Option ID. Note: ID can be diferent from Option ID.

See Also

WebDAVOptionStore Class
Sitecore.Configuration Namespace


WebDAVOptionStore Properties

[image] [image]

Sitecore 6.4.1 API
WebDAVOptionStore Properties
WebDAVOptionStore Class See Also Send Feedback

The WebDAVOptionStore type exposes the following members.

Properties

 | Name | Description
Public property | DefaultOption | Gets the default options.

See Also

WebDAVOptionStore Class
Sitecore.Configuration Namespace


DefaultOption Property

[image]

Sitecore 6.4.1 API
WebDAVOptionStore..::..DefaultOption Property
WebDAVOptionStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual WebDAVOptions DefaultOption { get; }
Visual Basic
Public Overridable ReadOnly Property DefaultOption As WebDAVOptions
    Get
Visual C++
public:
virtual property WebDAVOptions^ DefaultOption {
    WebDAVOptions^ get ();
}

Field Value

The default options.

See Also

WebDAVOptionStore Class
Sitecore.Configuration Namespace


XmlConfigFile Class

[image]

Sitecore 6.4.1 API
XmlConfigFile Class
Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class XmlConfigFile
Visual Basic
Public Class XmlConfigFile
Visual C++
public ref class XmlConfigFile

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..XmlConfigFile

See Also

XmlConfigFile Members
Sitecore.Configuration Namespace


XmlConfigFile Members

[image] [image]

Sitecore 6.4.1 API
XmlConfigFile Members
XmlConfigFile Class Constructors Methods See Also Send Feedback

The XmlConfigFile type exposes the following members.

Constructors

 | Name | Description
Public method | XmlConfigFile | Initializes a new instance of the XmlConfigFile class

Methods

 | Name | Description
Public method | CreateObjects | Creates all objects matching xpath.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LoadFromFile | Loads a configuration file from a file.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

XmlConfigFile Class
Sitecore.Configuration Namespace


XmlConfigFile Constructor

[image]

Sitecore 6.4.1 API
XmlConfigFile Constructor
XmlConfigFile Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public XmlConfigFile()
Visual Basic
Public Sub New
Visual C++
public:
XmlConfigFile()

See Also

XmlConfigFile Class
Sitecore.Configuration Namespace


XmlConfigFile Methods

[image] [image]

Sitecore 6.4.1 API
XmlConfigFile Methods
XmlConfigFile Class See Also Send Feedback

The XmlConfigFile type exposes the following members.

Methods

 | Name | Description
Public method | CreateObjects | Creates all objects matching xpath.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LoadFromFile | Loads a configuration file from a file.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

XmlConfigFile Class
Sitecore.Configuration Namespace


CreateObjects Method

[image]

Sitecore 6.4.1 API
XmlConfigFile..::..CreateObjects Method
XmlConfigFile Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public List<Domain> CreateObjects(
    string xpath
)
Visual Basic
Public Function CreateObjects ( _
    xpath As String _
) As List(Of Domain)
Visual C++
public:
List<Domain^>^ CreateObjects(
    String^ xpath
)

Parameters

xpath
Type: System..::..String
The xpath.

Return Value

[Missing <returns> documentation for "M:Sitecore.Configuration.XmlConfigFile.CreateObjects(System.String)"]

Exceptions

Exception | Condition
System..::..NotImplementedException | NotImplementedException.

See Also

XmlConfigFile Class
Sitecore.Configuration Namespace


LoadFromFile Method

[image]

Sitecore 6.4.1 API
XmlConfigFile..::..LoadFromFile Method
XmlConfigFile Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static XmlConfigFile LoadFromFile(
    string filePath
)
Visual Basic
Public Shared Function LoadFromFile ( _
    filePath As String _
) As XmlConfigFile
Visual C++
public:
static XmlConfigFile^ LoadFromFile(
    String^ filePath
)

Parameters

filePath
Type: System..::..String
The file path.

Return Value

[Missing <returns> documentation for "M:Sitecore.Configuration.XmlConfigFile.LoadFromFile(System.String)"]

Exceptions

Exception | Condition
System..::..NotImplementedException | NotImplementedException.

See Also

XmlConfigFile Class
Sitecore.Configuration Namespace


XmlConfigRecord Class

[image]

Sitecore 6.4.1 API
XmlConfigRecord Class
Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class XmlConfigRecord : ConfigRecord
Visual Basic
Public Class XmlConfigRecord _
    Inherits ConfigRecord
Visual C++
public ref class XmlConfigRecord : public ConfigRecord

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..ConfigRecord
Sitecore.Configuration..::..XmlConfigRecord

See Also

XmlConfigRecord Members
Sitecore.Configuration Namespace


XmlConfigRecord Members

[image] [image]

Sitecore 6.4.1 API
XmlConfigRecord Members
XmlConfigRecord Class Constructors Methods Properties See Also Send Feedback

The XmlConfigRecord type exposes the following members.

Constructors

 | Name | Description
Public method | XmlConfigRecord | Initializes a new instance of the XmlConfigRecord class.

Methods

 | Name | Description
Public method | AddRecord(String) | Adds the record. (Overrides ConfigRecord..::..AddRecord(String).)
Public method | AddRecord(String, String, array<String>[]()[][]) | Adds a new child record to the record. (Inherited from ConfigRecord.)
Public method | CreateObject<(Of <<'(T>)>>) | Creates the object represented by the record. (Overrides ConfigRecord..::..CreateObject<(Of <<'(T>)>>)()()()().)
Public method | CreateObjects<(Of <<'(T>)>>) | Creates objects from all child record with the name specified in recordName. (Inherited from ConfigRecord.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChildRecord | Gets a child record with the specified name. (Overrides ConfigRecord..::..GetChildRecord(String).)
Public method | GetChildRecords()()()() | Gets all child records. (Overrides ConfigRecord..::..GetChildRecords()()()().)
Public method | GetChildRecords(String) | Gets all child records with the specified name. (Overrides ConfigRecord..::..GetChildRecords(String).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNamedChildRecord | Gets a named child record. (Overrides ConfigRecord..::..GetNamedChildRecord(String, String).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the textual value of the record. (Overrides ConfigRecord..::..GetValue()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the record from the config store. (Overrides ConfigRecord..::..Remove()()()().)
Public method | SetAttribute | Sets the attribute. (Overrides ConfigRecord..::..SetAttribute(String, String).)
Public method | SetValue | Sets the value. (Overrides ConfigRecord..::..SetValue(String).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Attributes | Gets the attributes. (Overrides ConfigRecord..::..Attributes.)
Public property | ConfigStore | Gets the store. (Inherited from ConfigRecord.)
Public property | Name | Gets the name. (Inherited from ConfigRecord.)

See Also

XmlConfigRecord Class
Sitecore.Configuration Namespace


XmlConfigRecord Constructor

[image]

Sitecore 6.4.1 API
XmlConfigRecord Constructor
XmlConfigRecord Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public XmlConfigRecord(
    XmlNode node,
    ConfigStore store
)
Visual Basic
Public Sub New ( _
    node As XmlNode, _
    store As ConfigStore _
)
Visual C++
public:
XmlConfigRecord(
    XmlNode^ node,
    ConfigStore^ store
)

Parameters

node
Type: System.Xml..::..XmlNode
The node.
store
Type: Sitecore.Configuration..::..ConfigStore
The store.

See Also

XmlConfigRecord Class
Sitecore.Configuration Namespace


XmlConfigRecord Methods

[image] [image]

Sitecore 6.4.1 API
XmlConfigRecord Methods
XmlConfigRecord Class See Also Send Feedback

The XmlConfigRecord type exposes the following members.

Methods

 | Name | Description
Public method | AddRecord(String) | Adds the record. (Overrides ConfigRecord..::..AddRecord(String).)
Public method | AddRecord(String, String, array<String>[]()[][]) | Adds a new child record to the record. (Inherited from ConfigRecord.)
Public method | CreateObject<(Of <<'(T>)>>) | Creates the object represented by the record. (Overrides ConfigRecord..::..CreateObject<(Of <<'(T>)>>)()()()().)
Public method | CreateObjects<(Of <<'(T>)>>) | Creates objects from all child record with the name specified in recordName. (Inherited from ConfigRecord.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChildRecord | Gets a child record with the specified name. (Overrides ConfigRecord..::..GetChildRecord(String).)
Public method | GetChildRecords()()()() | Gets all child records. (Overrides ConfigRecord..::..GetChildRecords()()()().)
Public method | GetChildRecords(String) | Gets all child records with the specified name. (Overrides ConfigRecord..::..GetChildRecords(String).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNamedChildRecord | Gets a named child record. (Overrides ConfigRecord..::..GetNamedChildRecord(String, String).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the textual value of the record. (Overrides ConfigRecord..::..GetValue()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the record from the config store. (Overrides ConfigRecord..::..Remove()()()().)
Public method | SetAttribute | Sets the attribute. (Overrides ConfigRecord..::..SetAttribute(String, String).)
Public method | SetValue | Sets the value. (Overrides ConfigRecord..::..SetValue(String).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

XmlConfigRecord Class
Sitecore.Configuration Namespace


AddRecord Method

[image] [image]

Sitecore 6.4.1 API
XmlConfigRecord..::..AddRecord Method
XmlConfigRecord Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddRecord(String) | Adds the record. (Overrides ConfigRecord..::..AddRecord(String).)
Public method | AddRecord(String, String, array<String>[]()[][]) | Adds a new child record to the record. (Inherited from ConfigRecord.)

See Also

XmlConfigRecord Class
XmlConfigRecord Members
Sitecore.Configuration Namespace


AddRecord Method (String)

[image]

Sitecore 6.4.1 API
XmlConfigRecord..::..AddRecord Method (String)
XmlConfigRecord Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override ConfigRecord AddRecord(
    string recordName
)
Visual Basic
Public Overrides Function AddRecord ( _
    recordName As String _
) As ConfigRecord
Visual C++
public:
virtual ConfigRecord^ AddRecord(
    String^ recordName
) override

Parameters

recordName
Type: System..::..String
Name of the record.

Return Value

[Missing <returns> documentation for "M:Sitecore.Configuration.XmlConfigRecord.AddRecord(System.String)"]

See Also

XmlConfigRecord Class
AddRecord Overload
Sitecore.Configuration Namespace


CreateObject(T) Method

[image]

Sitecore 6.4.1 API
XmlConfigRecord..::..CreateObject<(Of <(<'T>)>)> Method
XmlConfigRecord Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override T CreateObject<T>()
where T : class
Visual Basic
Public Overrides Function CreateObject(Of T As Class) As T
Visual C++
public:
generic<typename T>
where T : ref class
virtual T CreateObject() override

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Sitecore.Configuration.XmlConfigRecord.CreateObject``1"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Configuration.XmlConfigRecord.CreateObject``1"]

Exceptions

Exception | Condition
Sitecore.Exceptions..::..ConfigurationException |

See Also

XmlConfigRecord Class
Sitecore.Configuration Namespace


GetChildRecord Method

[image]

Sitecore 6.4.1 API
XmlConfigRecord..::..GetChildRecord Method
XmlConfigRecord Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override ConfigRecord GetChildRecord(
    string recordName
)
Visual Basic
Public Overrides Function GetChildRecord ( _
    recordName As String _
) As ConfigRecord
Visual C++
public:
virtual ConfigRecord^ GetChildRecord(
    String^ recordName
) override

Parameters

recordName
Type: System..::..String
Name of the record.

Return Value

[Missing <returns> documentation for "M:Sitecore.Configuration.XmlConfigRecord.GetChildRecord(System.String)"]

See Also

XmlConfigRecord Class
Sitecore.Configuration Namespace


GetChildRecords Method

[image] [image]

Sitecore 6.4.1 API
XmlConfigRecord..::..GetChildRecords Method
XmlConfigRecord Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildRecords()()()() | Gets all child records. (Overrides ConfigRecord..::..GetChildRecords()()()().)
Public method | GetChildRecords(String) | Gets all child records with the specified name. (Overrides ConfigRecord..::..GetChildRecords(String).)

See Also

XmlConfigRecord Class
XmlConfigRecord Members
Sitecore.Configuration Namespace


GetChildRecords Method

[image]

Sitecore 6.4.1 API
XmlConfigRecord..::..GetChildRecords Method
XmlConfigRecord Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override List<ConfigRecord> GetChildRecords()
Visual Basic
Public Overrides Function GetChildRecords As List(Of ConfigRecord)
Visual C++
public:
virtual List<ConfigRecord^>^ GetChildRecords() override

Return Value

[Missing <returns> documentation for "M:Sitecore.Configuration.XmlConfigRecord.GetChildRecords"]

See Also

XmlConfigRecord Class
GetChildRecords Overload
Sitecore.Configuration Namespace


GetChildRecords Method (String)

[image]

Sitecore 6.4.1 API
XmlConfigRecord..::..GetChildRecords Method (String)
XmlConfigRecord Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override List<ConfigRecord> GetChildRecords(
    string recordName
)
Visual Basic
Public Overrides Function GetChildRecords ( _
    recordName As String _
) As List(Of ConfigRecord)
Visual C++
public:
virtual List<ConfigRecord^>^ GetChildRecords(
    String^ recordName
) override

Parameters

recordName
Type: System..::..String
Name of the record.

Return Value

[Missing <returns> documentation for "M:Sitecore.Configuration.XmlConfigRecord.GetChildRecords(System.String)"]

See Also

XmlConfigRecord Class
GetChildRecords Overload
Sitecore.Configuration Namespace


GetNamedChildRecord Method

[image]

Sitecore 6.4.1 API
XmlConfigRecord..::..GetNamedChildRecord Method
XmlConfigRecord Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override ConfigRecord GetNamedChildRecord(
    string recordName,
    string name
)
Visual Basic
Public Overrides Function GetNamedChildRecord ( _
    recordName As String, _
    name As String _
) As ConfigRecord
Visual C++
public:
virtual ConfigRecord^ GetNamedChildRecord(
    String^ recordName,
    String^ name
) override

Parameters

recordName
Type: System..::..String
Name of the record.
name
Type: System..::..String
The name.

Return Value

[Missing <returns> documentation for "M:Sitecore.Configuration.XmlConfigRecord.GetNamedChildRecord(System.String,System.String)"]

See Also

XmlConfigRecord Class
Sitecore.Configuration Namespace


GetValue Method

[image]

Sitecore 6.4.1 API
XmlConfigRecord..::..GetValue Method
XmlConfigRecord Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string GetValue()
Visual Basic
Public Overrides Function GetValue As String
Visual C++
public:
virtual String^ GetValue() override

Return Value

[Missing <returns> documentation for "M:Sitecore.Configuration.XmlConfigRecord.GetValue"]

See Also

XmlConfigRecord Class
Sitecore.Configuration Namespace


Remove Method

[image]

Sitecore 6.4.1 API
XmlConfigRecord..::..Remove Method
XmlConfigRecord Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Remove()
Visual Basic
Public Overrides Sub Remove
Visual C++
public:
virtual void Remove() override

See Also

XmlConfigRecord Class
Sitecore.Configuration Namespace


SetValue Method

[image]

Sitecore 6.4.1 API
XmlConfigRecord..::..SetValue Method
XmlConfigRecord Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void SetValue(
    string value
)
Visual Basic
Public Overrides Sub SetValue ( _
    value As String _
)
Visual C++
public:
virtual void SetValue(
    String^ value
) override

Parameters

value
Type: System..::..String
The value.

See Also

XmlConfigRecord Class
Sitecore.Configuration Namespace


XmlConfigRecord Properties

[image] [image]

Sitecore 6.4.1 API
XmlConfigRecord Properties
XmlConfigRecord Class See Also Send Feedback

The XmlConfigRecord type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets the attributes. (Overrides ConfigRecord..::..Attributes.)
Public property | ConfigStore | Gets the store. (Inherited from ConfigRecord.)
Public property | Name | Gets the name. (Inherited from ConfigRecord.)

See Also

XmlConfigRecord Class
Sitecore.Configuration Namespace


Attributes Property

[image]

Sitecore 6.4.1 API
XmlConfigRecord..::..Attributes Property
XmlConfigRecord Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override AttributeList Attributes { get; }
Visual Basic
Public Overrides ReadOnly Property Attributes As AttributeList
    Get
Visual C++
public:
virtual property AttributeList^ Attributes {
    AttributeList^ get () override;
}

Field Value

The attributes.

See Also

XmlConfigRecord Class
Sitecore.Configuration Namespace


XmlConfigStore Class

[image]

Sitecore 6.4.1 API
XmlConfigStore Class
Members See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class XmlConfigStore : ConfigStore
Visual Basic
Public Class XmlConfigStore _
    Inherits ConfigStore
Visual C++
public ref class XmlConfigStore : public ConfigStore

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..ConfigStore
Sitecore.Configuration..::..XmlConfigStore

See Also

XmlConfigStore Members
Sitecore.Configuration Namespace


XmlConfigStore Members

[image] [image]

Sitecore 6.4.1 API
XmlConfigStore Members
XmlConfigStore Class Constructors Methods Properties Events See Also Send Feedback

The XmlConfigStore type exposes the following members.

Constructors

 | Name | Description
Public method | XmlConfigStore | Initializes a new instance of the XmlConfigStore class.

Methods

 | Name | Description
Public method | CommitChanges | Commits the changes. (Overrides ConfigStore..::..CommitChanges()()()().)
Protected method | EnqueueReload | Queues the reloading of configuration.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTemplateRecord | Gets the template record. (Inherited from ConfigStore.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HandleConfigChanged | Notifies that the configuration file has been changed.
Protected method | HandleConfigDeleted | Notifies that the configuration file has been changed.
Protected method | InternalLoad | Performs the actual loading of the configuration file.
 | LoadFromFile | Loads from file.
 | LoadFromXml | Loads the config store from an XML document.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotifyConfigChanged | Notify subscribers that the configuration has changed. (Inherited from ConfigStore.)
Protected method | Reload | Reloads this instance.
Public method | SaveToFile | Saves to file.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FilePath | Gets the file path.
Public property | RootRecord | Gets the root record. (Overrides ConfigStore..::..RootRecord.)

Events

 | Name | Description
Public event | ConfigChanged | Occurs when configuration has been changed (externally). (Inherited from ConfigStore.)

See Also

XmlConfigStore Class
Sitecore.Configuration Namespace


XmlConfigStore Constructor

[image]

Sitecore 6.4.1 API
XmlConfigStore Constructor
XmlConfigStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public XmlConfigStore(
    string rootElementName
)
Visual Basic
Public Sub New ( _
    rootElementName As String _
)
Visual C++
public:
XmlConfigStore(
    String^ rootElementName
)

Parameters

rootElementName
Type: System..::..String
The root Element Name.

See Also

XmlConfigStore Class
Sitecore.Configuration Namespace


XmlConfigStore Methods

[image] [image]

Sitecore 6.4.1 API
XmlConfigStore Methods
XmlConfigStore Class See Also Send Feedback

The XmlConfigStore type exposes the following members.

Methods

 | Name | Description
Public method | CommitChanges | Commits the changes. (Overrides ConfigStore..::..CommitChanges()()()().)
Protected method | EnqueueReload | Queues the reloading of configuration.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTemplateRecord | Gets the template record. (Inherited from ConfigStore.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HandleConfigChanged | Notifies that the configuration file has been changed.
Protected method | HandleConfigDeleted | Notifies that the configuration file has been changed.
Protected method | InternalLoad | Performs the actual loading of the configuration file.
 | LoadFromFile | Loads from file.
 | LoadFromXml | Loads the config store from an XML document.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotifyConfigChanged | Notify subscribers that the configuration has changed. (Inherited from ConfigStore.)
Protected method | Reload | Reloads this instance.
Public method | SaveToFile | Saves to file.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

XmlConfigStore Class
Sitecore.Configuration Namespace


CommitChanges Method

[image]

Sitecore 6.4.1 API
XmlConfigStore..::..CommitChanges Method
XmlConfigStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void CommitChanges()
Visual Basic
Public Overrides Sub CommitChanges
Visual C++
public:
virtual void CommitChanges() override

Exceptions

Exception | Condition
Sitecore.Exceptions..::..ConfigurationException | No FilePath have been specified in XmlConfigStore.

See Also

XmlConfigStore Class
Sitecore.Configuration Namespace


HandleConfigChanged Method

[image]

Sitecore 6.4.1 API
XmlConfigStore..::..HandleConfigChanged Method
XmlConfigStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void HandleConfigChanged()
Visual Basic
Protected Overridable Sub HandleConfigChanged
Visual C++
protected:
virtual void HandleConfigChanged()

See Also

XmlConfigStore Class
Sitecore.Configuration Namespace


HandleConfigDeleted Method

[image]

Sitecore 6.4.1 API
XmlConfigStore..::..HandleConfigDeleted Method
XmlConfigStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void HandleConfigDeleted()
Visual Basic
Protected Overridable Sub HandleConfigDeleted
Visual C++
protected:
virtual void HandleConfigDeleted()

See Also

XmlConfigStore Class
Sitecore.Configuration Namespace


InternalLoad Method

[image]

Sitecore 6.4.1 API
XmlConfigStore..::..InternalLoad Method
XmlConfigStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void InternalLoad()
Visual Basic
Protected Overridable Sub InternalLoad
Visual C++
protected:
virtual void InternalLoad()

Exceptions

Exception | Condition
Sitecore.Exceptions..::..ConfigurationException | ConfigurationException.

See Also

XmlConfigStore Class
Sitecore.Configuration Namespace


LoadFromFile Method

[image]

Sitecore 6.4.1 API
XmlConfigStore..::..LoadFromFile Method
XmlConfigStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static XmlConfigStore LoadFromFile(
    string filePath
)
Visual Basic
Public Shared Function LoadFromFile ( _
    filePath As String _
) As XmlConfigStore
Visual C++
public:
static XmlConfigStore^ LoadFromFile(
    String^ filePath
)

Parameters

filePath
Type: System..::..String
The file path.

Return Value

XmlConfigStore object.

See Also

XmlConfigStore Class
Sitecore.Configuration Namespace


LoadFromXml Method

[image]

Sitecore 6.4.1 API
XmlConfigStore..::..LoadFromXml Method
XmlConfigStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static XmlConfigStore LoadFromXml(
    XmlDocument document
)
Visual Basic
Public Shared Function LoadFromXml ( _
    document As XmlDocument _
) As XmlConfigStore
Visual C++
public:
static XmlConfigStore^ LoadFromXml(
    XmlDocument^ document
)

Parameters

document
Type: System.Xml..::..XmlDocument
The document.

Return Value

XmlConfigStore object.

Exceptions

Exception | Condition
Sitecore.Exceptions..::..ConfigurationException | Configuration document is missing a root element.

See Also

XmlConfigStore Class
Sitecore.Configuration Namespace


Reload Method

[image]

Sitecore 6.4.1 API
XmlConfigStore..::..Reload Method
XmlConfigStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void Reload()
Visual Basic
Protected Overridable Sub Reload
Visual C++
protected:
virtual void Reload()

Exceptions

Exception | Condition
Sitecore.Exceptions..::..ConfigurationException | ConfigurationException.

See Also

XmlConfigStore Class
Sitecore.Configuration Namespace


SaveToFile Method

[image]

Sitecore 6.4.1 API
XmlConfigStore..::..SaveToFile Method
XmlConfigStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void SaveToFile(
    string fileToSave
)
Visual Basic
Public Overridable Sub SaveToFile ( _
    fileToSave As String _
)
Visual C++
public:
virtual void SaveToFile(
    String^ fileToSave
)

Parameters

fileToSave
Type: System..::..String
The file path.

See Also

XmlConfigStore Class
Sitecore.Configuration Namespace


XmlConfigStore Properties

[image] [image]

Sitecore 6.4.1 API
XmlConfigStore Properties
XmlConfigStore Class See Also Send Feedback

The XmlConfigStore type exposes the following members.

Properties

 | Name | Description
Public property | FilePath | Gets the file path.
Public property | RootRecord | Gets the root record. (Overrides ConfigStore..::..RootRecord.)

See Also

XmlConfigStore Class
Sitecore.Configuration Namespace


FilePath Property

[image]

Sitecore 6.4.1 API
XmlConfigStore..::..FilePath Property
XmlConfigStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string FilePath { get; }
Visual Basic
Public Overridable ReadOnly Property FilePath As String
    Get
Visual C++
public:
virtual property String^ FilePath {
    String^ get ();
}

Field Value

The file path.

See Also

XmlConfigStore Class
Sitecore.Configuration Namespace


RootRecord Property

[image]

Sitecore 6.4.1 API
XmlConfigStore..::..RootRecord Property
XmlConfigStore Class See Also Send Feedback

Namespace: Sitecore.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override ConfigRecord RootRecord { get; }
Visual Basic
Public Overrides ReadOnly Property RootRecord As ConfigRecord
    Get
Visual C++
public:
virtual property ConfigRecord^ RootRecord {
    ConfigRecord^ get () override;
}

Field Value

The root record.

See Also

XmlConfigStore Class
Sitecore.Configuration Namespace


XmlConfigStore Events

[image] [image]

Sitecore 6.4.1 API
XmlConfigStore Events
XmlConfigStore Class See Also Send Feedback

The XmlConfigStore type exposes the following members.

Events

 | Name | Description
Public event | ConfigChanged | Occurs when configuration has been changed (externally). (Inherited from ConfigStore.)

See Also

XmlConfigStore Class
Sitecore.Configuration Namespace


Sitecore.Configuration.Providers Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Configuration.Providers Namespace
Send Feedback

Classes

 | Class | Description
Public class | ProviderCollectionBase<(Of <(<'TProvider>)>)> | ProviderCollectionBase class


ProviderCollectionBase(TProvider) Class

[image]

Sitecore 6.4.1 API
ProviderCollectionBase<(Of <(<'TProvider>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Configuration.Providers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ProviderCollectionBase<TProvider> : ProviderCollection,
    IEnumerable<T>, IEnumerable
where TProvider : class
Visual Basic
Public Class ProviderCollectionBase(Of TProvider As Class) _
    Inherits ProviderCollection _
    Implements IEnumerable(Of T), IEnumerable
Visual C++
generic<typename TProvider>
where TProvider : ref class
public ref class ProviderCollectionBase : public ProviderCollection,
    IEnumerable<T>, IEnumerable

Type Parameters

TProvider
Provider type.

Inheritance Hierarchy

System..::..Object
System.Configuration.Provider..::..ProviderCollection
Sitecore.Configuration.Providers..::..ProviderCollectionBase<(Of <(<'TProvider>)>)>

See Also

ProviderCollectionBase<(Of <(<'TProvider>)>)> Members
Sitecore.Configuration.Providers Namespace


ProviderCollectionBase(TProvider) Members

[image] [image]

Sitecore 6.4.1 API
ProviderCollectionBase<(Of <(<'TProvider>)>)> Members
ProviderCollectionBase<(Of <(<'TProvider>)>)> Class Constructors Methods Properties See Also Send Feedback

The ProviderCollectionBase<(Of <(<'TProvider>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | ProviderCollectionBase<(Of <(<'TProvider>)>)> | Initializes a new instance of the ProviderCollectionBase<(Of <(<'TProvider>)>)> class

Methods

 | Name | Description
Public method | Add | Adds a provider to the collection. (Inherited from ProviderCollection.)
Public method | Clear | Removes all items from the collection. (Inherited from ProviderCollection.)
Public method | CopyTo | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a provider from the collection. (Inherited from ProviderCollection.)
Public method | SetReadOnly | Sets the collection to be read-only. (Inherited from ProviderCollection.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | Convert<(Of <<'(T, TTo>)>>) | Converts this instance. (Defined by EnumerableExtensions.)
Public Extension Method | StringConcatenate<(Of <<'(T>)>>) | Concatenate strings (Defined by IEnumerableExtensions.)

Properties

 | Name | Description
Public property | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
Public property | Item | Gets the provider with the specified provider name.
Public property | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)

See Also

ProviderCollectionBase<(Of <(<'TProvider>)>)> Class
Sitecore.Configuration.Providers Namespace


ProviderCollectionBase(TProvider) Constructor

[image]

Sitecore 6.4.1 API
ProviderCollectionBase<(Of <(<'TProvider>)>)> Constructor
ProviderCollectionBase<(Of <(<'TProvider>)>)> Class See Also Send Feedback

Namespace: Sitecore.Configuration.Providers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ProviderCollectionBase()
Visual Basic
Public Sub New
Visual C++
public:
ProviderCollectionBase()

See Also

ProviderCollectionBase<(Of <(<'TProvider>)>)> Class
Sitecore.Configuration.Providers Namespace


ProviderCollectionBase(TProvider) Methods

[image] [image]

Sitecore 6.4.1 API
ProviderCollectionBase<(Of <(<'TProvider>)>)> Methods
ProviderCollectionBase<(Of <(<'TProvider>)>)> Class See Also Send Feedback

The ProviderCollectionBase<(Of <(<'TProvider>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds a provider to the collection. (Inherited from ProviderCollection.)
Public method | Clear | Removes all items from the collection. (Inherited from ProviderCollection.)
Public method | CopyTo | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a provider from the collection. (Inherited from ProviderCollection.)
Public method | SetReadOnly | Sets the collection to be read-only. (Inherited from ProviderCollection.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | Convert<(Of <<'(T, TTo>)>>) | Converts this instance. (Defined by EnumerableExtensions.)
Public Extension Method | StringConcatenate<(Of <<'(T>)>>) | Concatenate strings (Defined by IEnumerableExtensions.)

See Also

ProviderCollectionBase<(Of <(<'TProvider>)>)> Class
Sitecore.Configuration.Providers Namespace


Item Property

[image]

Sitecore 6.4.1 API
ProviderCollectionBase<(Of <(<'TProvider>)>)>..::..Item Property
ProviderCollectionBase<(Of <(<'TProvider>)>)> Class See Also Send Feedback

Namespace: Sitecore.Configuration.Providers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TProvider this[
    string providerName
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    providerName As String _
) As TProvider
    Get
Visual C++
public:
property TProvider default[String^ providerName] {
    TProvider get (String^ providerName);
}

Parameters

providerName
Type: System..::..String
The provider name.

Field Value

The provider.

See Also

ProviderCollectionBase<(Of <(<'TProvider>)>)> Class
Sitecore.Configuration.Providers Namespace


Sitecore.Controls Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Controls Namespace
Send Feedback

Classes

 | Class | Description
Public class | DialogPage | Represents the Device Editor form.
Public class | HtmlBody | Defines the HTML body class.
Public class | ModalDialogPage | Represents the Device Editor form.
Public class | Wizard | Provides a class that handles wizard dialog forms.
Public class | WizardPage | WizardPage class


DialogPage Class

[image]

Sitecore 6.4.1 API
DialogPage Class
Members See Also Send Feedback

Namespace: Sitecore.Controls
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DialogPage : XamlMainControl
Visual Basic
Public Class DialogPage _
    Inherits XamlMainControl
Visual C++
public ref class DialogPage : public XamlMainControl

Inheritance Hierarchy

System..::..Object
System.Web.UI..::..Control
System.Web.UI.WebControls..::..WebControl
Sitecore.Web.UI.XamlSharp.Xaml..::..XamlControl
Sitecore.Web.UI.XamlSharp.Xaml..::..XamlMainControl
Sitecore.Controls..::..DialogPage

See Also

DialogPage Members
Sitecore.Controls Namespace


DialogPage Members

[image] [image]

Sitecore 6.4.1 API
DialogPage Members
DialogPage Class Constructors Methods Properties Events See Also Send Feedback

The DialogPage type exposes the following members.

Constructors

 | Name | Description
Public method | DialogPage | Initializes a new instance of the DialogPage class

Methods

 | Name | Description
Protected method | AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Public method | ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | Cancel_Click | Handles a click on the OK button.
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Public method | CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from XamlControl.)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Protected method | CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteAjaxCommand | Executes the ajax command. (Inherited from XamlControl.)
Protected method | ExecuteAjaxMethod | Executes the ajax method. (Inherited from XamlControl.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
Protected method | FindDescendantControl(String) | Find descendant control. (Inherited from XamlControl.)
Protected method | FindDescendantControl(Control, String) | Find descendant control. (Inherited from XamlControl.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
Protected method | LoadViewState | Restores view-state information from a previous request that was saved with the SaveViewState()()()() method. (Inherited from WebControl.)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | OK_Click | Handles a click on the OK button.
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnInit | Raises the Init event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from XamlMainControl.)
Protected method | OnPreRender | Raises the PreRender event. (Inherited from Control.)
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Protected method | PreviewAjaxCommand | Previews the Ajax command. (Inherited from XamlControl.)
Protected method | PreviewAjaxMethod | Previews the Ajax method. (Inherited from XamlControl.)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Protected method | RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Protected method | Render | Renders the control to the specified HTML writer. (Inherited from XamlControl.)
Public method | RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Protected method | RenderContents | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Public method | RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SaveViewState | Saves any state that was modified after the TrackViewState()()()() method was invoked. (Inherited from WebControl.)
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)

Properties

 | Name | Description
Public property | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | Application | Gets or sets the application. (Inherited from XamlMainControl.)
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
Public property | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
Public property | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
Public property | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Protected property | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Public property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from XamlControl.)
Public property | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
Public property | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
Protected property | Definition | Gets the definition. (Inherited from XamlControl.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
Public property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
Public property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Public property | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
Public property | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
Public property | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Protected property | Header | Gets or sets the header.
Public property | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
Public property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
Protected property | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Protected property | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
Public property | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
Public property | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
Protected property | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Protected property | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Protected property | Text | Gets or sets the text.
Public property | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
Public property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
Public property | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)

Events

 | Name | Description
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

See Also

DialogPage Class
Sitecore.Controls Namespace


DialogPage Constructor

[image]

Sitecore 6.4.1 API
DialogPage Constructor
DialogPage Class See Also Send Feedback

Namespace: Sitecore.Controls
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DialogPage()
Visual Basic
Public Sub New
Visual C++
public:
DialogPage()

See Also

DialogPage Class
Sitecore.Controls Namespace


DialogPage Methods

[image] [image]

Sitecore 6.4.1 API
DialogPage Methods
DialogPage Class See Also Send Feedback

The DialogPage type exposes the following members.

Methods

 | Name | Description
Protected method | AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Public method | ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | Cancel_Click | Handles a click on the OK button.
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Public method | CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from XamlControl.)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Protected method | CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteAjaxCommand | Executes the ajax command. (Inherited from XamlControl.)
Protected method | ExecuteAjaxMethod | Executes the ajax method. (Inherited from XamlControl.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
Protected method | FindDescendantControl(String) | Find descendant control. (Inherited from XamlControl.)
Protected method | FindDescendantControl(Control, String) | Find descendant control. (Inherited from XamlControl.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
Protected method | LoadViewState | Restores view-state information from a previous request that was saved with the SaveViewState()()()() method. (Inherited from WebControl.)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | OK_Click | Handles a click on the OK button.
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnInit | Raises the Init event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from XamlMainControl.)
Protected method | OnPreRender | Raises the PreRender event. (Inherited from Control.)
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Protected method | PreviewAjaxCommand | Previews the Ajax command. (Inherited from XamlControl.)
Protected method | PreviewAjaxMethod | Previews the Ajax method. (Inherited from XamlControl.)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Protected method | RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Protected method | Render | Renders the control to the specified HTML writer. (Inherited from XamlControl.)
Public method | RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Protected method | RenderContents | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Public method | RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SaveViewState | Saves any state that was modified after the TrackViewState()()()() method was invoked. (Inherited from WebControl.)
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)

See Also

DialogPage Class
Sitecore.Controls Namespace


Cancel_Click Method

[image]

Sitecore 6.4.1 API
DialogPage..::..Cancel_Click Method
DialogPage Class See Also Send Feedback

Namespace: Sitecore.Controls
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void Cancel_Click()
Visual Basic
Protected Overridable Sub Cancel_Click
Visual C++
protected:
virtual void Cancel_Click()

Remarks

When the user clicks OK, the dialog is closed by calling the CloseWindow method.

See Also

DialogPage Class
Sitecore.Controls Namespace


DataBind Method

[image] [image]

Sitecore 6.4.1 API
DialogPage..::..DataBind Method
DialogPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)

See Also

DialogPage Class
DialogPage Members
Sitecore.Controls Namespace


FindControl Method

[image] [image]

Sitecore 6.4.1 API
DialogPage..::..FindControl Method
DialogPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)

See Also

DialogPage Class
DialogPage Members
Sitecore.Controls Namespace


FindDescendantControl Method

[image] [image]

Sitecore 6.4.1 API
DialogPage..::..FindDescendantControl Method
DialogPage Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | FindDescendantControl(String) | Find descendant control. (Inherited from XamlControl.)
Protected method | FindDescendantControl(Control, String) | Find descendant control. (Inherited from XamlControl.)

See Also

DialogPage Class
DialogPage Members
Sitecore.Controls Namespace


OK_Click Method

[image]

Sitecore 6.4.1 API
DialogPage..::..OK_Click Method
DialogPage Class See Also Send Feedback

Namespace: Sitecore.Controls
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void OK_Click()
Visual Basic
Protected Overridable Sub OK_Click
Visual C++
protected:
virtual void OK_Click()

Remarks

When the user clicks OK, the dialog is closed by calling the CloseWindow method.

See Also

DialogPage Class
Sitecore.Controls Namespace


RenderControl Method

[image] [image]

Sitecore 6.4.1 API
DialogPage..::..RenderControl Method
DialogPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)

See Also

DialogPage Class
DialogPage Members
Sitecore.Controls Namespace


DialogPage Properties

[image] [image]

Sitecore 6.4.1 API
DialogPage Properties
DialogPage Class See Also Send Feedback

The DialogPage type exposes the following members.

Properties

 | Name | Description
Public property | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | Application | Gets or sets the application. (Inherited from XamlMainControl.)
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
Public property | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
Public property | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
Public property | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Protected property | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Public property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from XamlControl.)
Public property | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
Public property | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
Protected property | Definition | Gets the definition. (Inherited from XamlControl.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
Public property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
Public property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Public property | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
Public property | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
Public property | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Protected property | Header | Gets or sets the header.
Public property | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
Public property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
Protected property | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Protected property | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
Public property | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
Public property | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
Protected property | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Protected property | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Protected property | Text | Gets or sets the text.
Public property | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
Public property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
Public property | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)

See Also

DialogPage Class
Sitecore.Controls Namespace


Header Property

[image]

Sitecore 6.4.1 API
DialogPage..::..Header Property
DialogPage Class See Also Send Feedback

Namespace: Sitecore.Controls
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected string Header { get; set; }
Visual Basic
Protected Property Header As String
    Get
    Set
Visual C++
protected:
property String^ Header {
    String^ get ();
    void set (String^ value);
}

See Also

DialogPage Class
Sitecore.Controls Namespace


Text Property

[image]

Sitecore 6.4.1 API
DialogPage..::..Text Property
DialogPage Class See Also Send Feedback

Namespace: Sitecore.Controls
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected string Text { get; set; }
Visual Basic
Protected Property Text As String
    Get
    Set
Visual C++
protected:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

DialogPage Class
Sitecore.Controls Namespace


DialogPage Events

[image] [image]

Sitecore 6.4.1 API
DialogPage Events
DialogPage Class See Also Send Feedback

The DialogPage type exposes the following members.

Events

 | Name | Description
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

See Also

DialogPage Class
Sitecore.Controls Namespace


HtmlBody Members

[image] [image]

Sitecore 6.4.1 API
HtmlBody Members
HtmlBody Class Constructors Methods Properties Events See Also Send Feedback

The HtmlBody type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlBody | Initializes a new instance of the HtmlBody class

Methods

 | Name | Description
Protected method | AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Public method | ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Public method | CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from XamlControl.)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Protected method | CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteAjaxCommand | Executes the ajax command. (Inherited from XamlControl.)
Protected method | ExecuteAjaxMethod | Executes the ajax method. (Inherited from XamlControl.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
Protected method | FindDescendantControl(String) | Find descendant control. (Inherited from XamlControl.)
Protected method | FindDescendantControl(Control, String) | Find descendant control. (Inherited from XamlControl.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
Protected method | LoadViewState | Restores view-state information from a previous request that was saved with the SaveViewState()()()() method. (Inherited from WebControl.)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnInit | Raises the Init event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from XamlControl.)
Protected method | OnPreRender | Raises the PreRender event. (Overrides Control..::..OnPreRender(EventArgs).)
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Protected method | PreviewAjaxCommand | Previews the Ajax command. (Inherited from XamlControl.)
Protected method | PreviewAjaxMethod | Previews the Ajax method. (Inherited from XamlControl.)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Protected method | RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Protected method | Render | Renders the control to the specified HTML writer. (Inherited from XamlControl.)
Public method | RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Protected method | RenderContents | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Public method | RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SaveViewState | Saves any state that was modified after the TrackViewState()()()() method was invoked. (Inherited from WebControl.)
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)

Properties

 | Name | Description
Public property | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
Public property | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
Public property | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
Public property | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Protected property | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Public property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from XamlControl.)
Public property | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
Public property | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
Protected property | Definition | Gets the definition. (Inherited from XamlControl.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
Public property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
Public property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Public property | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
Public property | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
Public property | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Public property | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
Public property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
Protected property | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Protected property | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Protected property | PageBody | Gets or sets the page body.
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
Public property | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
Public property | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
Protected property | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Protected property | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
Public property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
Public property | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)

Events

 | Name | Description
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

See Also

HtmlBody Class
Sitecore.Controls Namespace


HtmlBody Constructor

[image]

Sitecore 6.4.1 API
HtmlBody Constructor
HtmlBody Class See Also Send Feedback

Namespace: Sitecore.Controls
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HtmlBody()
Visual Basic
Public Sub New
Visual C++
public:
HtmlBody()

See Also

HtmlBody Class
Sitecore.Controls Namespace


HtmlBody Methods

[image] [image]

Sitecore 6.4.1 API
HtmlBody Methods
HtmlBody Class See Also Send Feedback

The HtmlBody type exposes the following members.

Methods

 | Name | Description
Protected method | AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Public method | ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Public method | CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from XamlControl.)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Protected method | CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteAjaxCommand | Executes the ajax command. (Inherited from XamlControl.)
Protected method | ExecuteAjaxMethod | Executes the ajax method. (Inherited from XamlControl.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
Protected method | FindDescendantControl(String) | Find descendant control. (Inherited from XamlControl.)
Protected method | FindDescendantControl(Control, String) | Find descendant control. (Inherited from XamlControl.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
Protected method | LoadViewState | Restores view-state information from a previous request that was saved with the SaveViewState()()()() method. (Inherited from WebControl.)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnInit | Raises the Init event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from XamlControl.)
Protected method | OnPreRender | Raises the PreRender event. (Overrides Control..::..OnPreRender(EventArgs).)
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Protected method | PreviewAjaxCommand | Previews the Ajax command. (Inherited from XamlControl.)
Protected method | PreviewAjaxMethod | Previews the Ajax method. (Inherited from XamlControl.)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Protected method | RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Protected method | Render | Renders the control to the specified HTML writer. (Inherited from XamlControl.)
Public method | RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Protected method | RenderContents | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Public method | RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SaveViewState | Saves any state that was modified after the TrackViewState()()()() method was invoked. (Inherited from WebControl.)
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)

See Also

HtmlBody Class
Sitecore.Controls Namespace


DataBind Method

[image] [image]

Sitecore 6.4.1 API
HtmlBody..::..DataBind Method
HtmlBody Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)

See Also

HtmlBody Class
HtmlBody Members
Sitecore.Controls Namespace


FindControl Method

[image] [image]

Sitecore 6.4.1 API
HtmlBody..::..FindControl Method
HtmlBody Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)

See Also

HtmlBody Class
HtmlBody Members
Sitecore.Controls Namespace


FindDescendantControl Method

[image] [image]

Sitecore 6.4.1 API
HtmlBody..::..FindDescendantControl Method
HtmlBody Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | FindDescendantControl(String) | Find descendant control. (Inherited from XamlControl.)
Protected method | FindDescendantControl(Control, String) | Find descendant control. (Inherited from XamlControl.)

See Also

HtmlBody Class
HtmlBody Members
Sitecore.Controls Namespace


RenderControl Method

[image] [image]

Sitecore 6.4.1 API
HtmlBody..::..RenderControl Method
HtmlBody Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)

See Also

HtmlBody Class
HtmlBody Members
Sitecore.Controls Namespace


HtmlBody Properties

[image] [image]

Sitecore 6.4.1 API
HtmlBody Properties
HtmlBody Class See Also Send Feedback

The HtmlBody type exposes the following members.

Properties

 | Name | Description
Public property | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
Public property | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
Public property | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
Public property | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Protected property | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Public property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from XamlControl.)
Public property | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
Public property | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
Protected property | Definition | Gets the definition. (Inherited from XamlControl.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
Public property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
Public property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Public property | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
Public property | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
Public property | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Public property | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
Public property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
Protected property | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Protected property | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Protected property | PageBody | Gets or sets the page body.
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
Public property | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
Public property | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
Protected property | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Protected property | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
Public property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
Public property | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)

See Also

HtmlBody Class
Sitecore.Controls Namespace


PageBody Property

[image]

Sitecore 6.4.1 API
HtmlBody..::..PageBody Property
HtmlBody Class See Also Send Feedback

Namespace: Sitecore.Controls
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected HtmlGenericControl PageBody { get; set; }
Visual Basic
Protected Property PageBody As HtmlGenericControl
    Get
    Set
Visual C++
protected:
property HtmlGenericControl^ PageBody {
    HtmlGenericControl^ get ();
    void set (HtmlGenericControl^ value);
}

Field Value

The page body.

See Also

HtmlBody Class
Sitecore.Controls Namespace


HtmlBody Events

[image] [image]

Sitecore 6.4.1 API
HtmlBody Events
HtmlBody Class See Also Send Feedback

The HtmlBody type exposes the following members.

Events

 | Name | Description
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

See Also

HtmlBody Class
Sitecore.Controls Namespace


ModalDialogPage Class

[image]

Sitecore 6.4.1 API
ModalDialogPage Class
Members See Also Send Feedback

Namespace: Sitecore.Controls
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ModalDialogPage : XamlMainControl
Visual Basic
Public Class ModalDialogPage _
    Inherits XamlMainControl
Visual C++
public ref class ModalDialogPage : public XamlMainControl

Inheritance Hierarchy

System..::..Object
System.Web.UI..::..Control
System.Web.UI.WebControls..::..WebControl
Sitecore.Web.UI.XamlSharp.Xaml..::..XamlControl
Sitecore.Web.UI.XamlSharp.Xaml..::..XamlMainControl
Sitecore.Controls..::..ModalDialogPage

See Also

ModalDialogPage Members
Sitecore.Controls Namespace


ModalDialogPage Members

[image] [image]

Sitecore 6.4.1 API
ModalDialogPage Members
ModalDialogPage Class Constructors Methods Properties Events See Also Send Feedback

The ModalDialogPage type exposes the following members.

Constructors

 | Name | Description
Public method | ModalDialogPage | Initializes a new instance of the ModalDialogPage class

Methods

 | Name | Description
Protected method | AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Public method | ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Protected method | Close_Click | Handles a click on the OK button.
Public method | CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from XamlControl.)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Protected method | CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteAjaxCommand | Executes the ajax command. (Inherited from XamlControl.)
Protected method | ExecuteAjaxMethod | Executes the ajax method. (Inherited from XamlControl.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
Protected method | FindDescendantControl(String) | Find descendant control. (Inherited from XamlControl.)
Protected method | FindDescendantControl(Control, String) | Find descendant control. (Inherited from XamlControl.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
Protected method | LoadViewState | Restores view-state information from a previous request that was saved with the SaveViewState()()()() method. (Inherited from WebControl.)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnInit | Raises the Init event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from XamlMainControl.)
Protected method | OnPreRender | Raises the PreRender event. (Inherited from Control.)
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Protected method | PreviewAjaxCommand | Previews the Ajax command. (Inherited from XamlControl.)
Protected method | PreviewAjaxMethod | Previews the Ajax method. (Inherited from XamlControl.)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Protected method | RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Protected method | Render | Renders the control to the specified HTML writer. (Inherited from XamlControl.)
Public method | RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Protected method | RenderContents | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Public method | RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SaveViewState | Saves any state that was modified after the TrackViewState()()()() method was invoked. (Inherited from WebControl.)
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)

Properties

 | Name | Description
Public property | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | Application | Gets or sets the application. (Inherited from XamlMainControl.)
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
Public property | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
Public property | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
Public property | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Protected property | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Public property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from XamlControl.)
Public property | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
Public property | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
Protected property | Definition | Gets the definition. (Inherited from XamlControl.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
Public property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
Public property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Public property | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
Public property | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
Public property | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Public property | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
Public property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
Protected property | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Protected property | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
Public property | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
Public property | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
Protected property | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Protected property | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
Public property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
Public property | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)

Events

 | Name | Description
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

See Also

ModalDialogPage Class
Sitecore.Controls Namespace


ModalDialogPage Constructor

[image]

Sitecore 6.4.1 API
ModalDialogPage Constructor
ModalDialogPage Class See Also Send Feedback

Namespace: Sitecore.Controls
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ModalDialogPage()
Visual Basic
Public Sub New
Visual C++
public:
ModalDialogPage()

See Also

ModalDialogPage Class
Sitecore.Controls Namespace


ModalDialogPage Methods

[image] [image]

Sitecore 6.4.1 API
ModalDialogPage Methods
ModalDialogPage Class See Also Send Feedback

The ModalDialogPage type exposes the following members.

Methods

 | Name | Description
Protected method | AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Public method | ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Protected method | Close_Click | Handles a click on the OK button.
Public method | CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from XamlControl.)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Protected method | CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteAjaxCommand | Executes the ajax command. (Inherited from XamlControl.)
Protected method | ExecuteAjaxMethod | Executes the ajax method. (Inherited from XamlControl.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
Protected method | FindDescendantControl(String) | Find descendant control. (Inherited from XamlControl.)
Protected method | FindDescendantControl(Control, String) | Find descendant control. (Inherited from XamlControl.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
Protected method | LoadViewState | Restores view-state information from a previous request that was saved with the SaveViewState()()()() method. (Inherited from WebControl.)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnInit | Raises the Init event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from XamlMainControl.)
Protected method | OnPreRender | Raises the PreRender event. (Inherited from Control.)
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Protected method | PreviewAjaxCommand | Previews the Ajax command. (Inherited from XamlControl.)
Protected method | PreviewAjaxMethod | Previews the Ajax method. (Inherited from XamlControl.)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Protected method | RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Protected method | Render | Renders the control to the specified HTML writer. (Inherited from XamlControl.)
Public method | RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Protected method | RenderContents | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Public method | RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SaveViewState | Saves any state that was modified after the TrackViewState()()()() method was invoked. (Inherited from WebControl.)
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)

See Also

ModalDialogPage Class
Sitecore.Controls Namespace


Close_Click Method

[image]

Sitecore 6.4.1 API
ModalDialogPage..::..Close_Click Method
ModalDialogPage Class See Also Send Feedback

Namespace: Sitecore.Controls
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void Close_Click()
Visual Basic
Protected Overridable Sub Close_Click
Visual C++
protected:
virtual void Close_Click()

Remarks

When the user clicks OK, the dialog is closed by calling the CloseWindow method.

See Also

ModalDialogPage Class
Sitecore.Controls Namespace


DataBind Method

[image] [image]

Sitecore 6.4.1 API
ModalDialogPage..::..DataBind Method
ModalDialogPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)

See Also

ModalDialogPage Class
ModalDialogPage Members
Sitecore.Controls Namespace


FindControl Method

[image] [image]

Sitecore 6.4.1 API
ModalDialogPage..::..FindControl Method
ModalDialogPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)

See Also

ModalDialogPage Class
ModalDialogPage Members
Sitecore.Controls Namespace


FindDescendantControl Method

[image] [image]

Sitecore 6.4.1 API
ModalDialogPage..::..FindDescendantControl Method
ModalDialogPage Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | FindDescendantControl(String) | Find descendant control. (Inherited from XamlControl.)
Protected method | FindDescendantControl(Control, String) | Find descendant control. (Inherited from XamlControl.)

See Also

ModalDialogPage Class
ModalDialogPage Members
Sitecore.Controls Namespace


RenderControl Method

[image] [image]

Sitecore 6.4.1 API
ModalDialogPage..::..RenderControl Method
ModalDialogPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)

See Also

ModalDialogPage Class
ModalDialogPage Members
Sitecore.Controls Namespace


ModalDialogPage Properties

[image] [image]

Sitecore 6.4.1 API
ModalDialogPage Properties
ModalDialogPage Class See Also Send Feedback

The ModalDialogPage type exposes the following members.

Properties

 | Name | Description
Public property | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | Application | Gets or sets the application. (Inherited from XamlMainControl.)
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
Public property | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
Public property | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
Public property | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Protected property | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Public property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from XamlControl.)
Public property | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
Public property | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
Protected property | Definition | Gets the definition. (Inherited from XamlControl.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
Public property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
Public property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Public property | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
Public property | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
Public property | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Public property | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
Public property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
Protected property | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Protected property | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
Public property | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
Public property | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
Protected property | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Protected property | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
Public property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
Public property | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)

See Also

ModalDialogPage Class
Sitecore.Controls Namespace


ModalDialogPage Events

[image] [image]

Sitecore 6.4.1 API
ModalDialogPage Events
ModalDialogPage Class See Also Send Feedback

The ModalDialogPage type exposes the following members.

Events

 | Name | Description
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

See Also

ModalDialogPage Class
Sitecore.Controls Namespace


Wizard Class

[image]

Sitecore 6.4.1 API
Wizard Class
Members See Also Send Feedback

Namespace: Sitecore.Controls
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Wizard : XamlControl
Visual Basic
Public Class Wizard _
    Inherits XamlControl
Visual C++
public ref class Wizard : public XamlControl

Remarks

The class has methods to handles Next, Back and Cancel button clicks. These methods can be overridden to provide other functionality.

Further more the path through the wizard pages can be controlled by overridding the ActivePageChanging and ActivePageChanged methods.

Inheritance Hierarchy

System..::..Object
System.Web.UI..::..Control
System.Web.UI.WebControls..::..WebControl
Sitecore.Web.UI.XamlSharp.Xaml..::..XamlControl
Sitecore.Controls..::..Wizard

See Also

Wizard Members
Sitecore.Controls Namespace


Wizard Members

[image] [image]

Sitecore 6.4.1 API
Wizard Members
Wizard Class Constructors Methods Properties Events See Also Send Feedback

The Wizard type exposes the following members.

Constructors

 | Name | Description
Public method | Wizard | Initializes a new instance of the Wizard class

Methods

 | Name | Description
Protected method | ActivePageChanged | Called when the active page has been changed.
Protected method | ActivePageChanging | Called when the active page is changing.
Protected method | AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Public method | ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Public method | Back | Back.
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Public method | Cancel | Cancel.
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Protected method | CloseWizard | Shows a confirmation window.
Public method | CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from XamlControl.)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Protected method | CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
Protected method | EndWizard | Ends the wizard.
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteAjaxCommand | Executes the ajax command. (Inherited from XamlControl.)
Protected method | ExecuteAjaxMethod | Executes the ajax method. (Inherited from XamlControl.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
Protected method | FindDescendantControl(String) | Find descendant control. (Inherited from XamlControl.)
Protected method | FindDescendantControl(Control, String) | Find descendant control. (Inherited from XamlControl.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
Protected method | LoadViewState | Restores view-state information from a previous request that was saved with the SaveViewState()()()() method. (Inherited from WebControl.)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | Next | Moves the wizard to the next page.
Protected method | OnBack | Called when the user clicks the Back button.
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnCancel | Called when the user clicks the Cancel button.
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnInit | Raises the Init event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Overrides XamlControl..::..OnLoad(EventArgs).)
Protected method | OnNext | Called when the user clicks the Next button.
Protected method | OnPreRender | Raises the PreRender event. (Inherited from Control.)
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Protected method | PreviewAjaxCommand | Previews the Ajax command. (Inherited from XamlControl.)
Protected method | PreviewAjaxMethod | Previews the Ajax method. (Inherited from XamlControl.)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Protected method | RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Protected method | Render | Renders the control to the specified HTML writer. (Inherited from XamlControl.)
Public method | RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Protected method | RenderContents | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Public method | RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SaveViewState | Saves any state that was modified after the TrackViewState()()()() method was invoked. (Inherited from WebControl.)
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)

Properties

 | Name | Description
Public property | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Public property | Active | Gets or sets the active page name.
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
Protected property | BackButton |
Public property | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
Public property | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
Public property | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
Protected property | CancelButton |
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Protected property | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Public property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from XamlControl.)
Public property | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
Public property | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
Protected property | Definition | Gets the definition. (Inherited from XamlControl.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
Public property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
Public property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Public property | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
Public property | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
Public property | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Public property | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
Public property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
Protected property | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Protected property | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Protected property | NextButton |
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | Pages | Gets the pages.
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
Public property | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
Public property | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
Protected property | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Protected property | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
Public property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
Public property | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)

Events

 | Name | Description
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

See Also

Wizard Class
Sitecore.Controls Namespace


Wizard Constructor

[image]

Sitecore 6.4.1 API
Wizard Constructor
Wizard Class See Also Send Feedback

Namespace: Sitecore.Controls
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Wizard()
Visual Basic
Public Sub New
Visual C++
public:
Wizard()

See Also

Wizard Class
Sitecore.Controls Namespace


Wizard Methods

[image] [image]

Sitecore 6.4.1 API
Wizard Methods
Wizard Class See Also Send Feedback

The Wizard type exposes the following members.

Methods

 | Name | Description
Protected method | ActivePageChanged | Called when the active page has been changed.
Protected method | ActivePageChanging | Called when the active page is changing.
Protected method | AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Public method | ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Public method | Back | Back.
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Public method | Cancel | Cancel.
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Protected method | CloseWizard | Shows a confirmation window.
Public method | CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from XamlControl.)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Protected method | CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
Protected method | EndWizard | Ends the wizard.
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteAjaxCommand | Executes the ajax command. (Inherited from XamlControl.)
Protected method | ExecuteAjaxMethod | Executes the ajax method. (Inherited from XamlControl.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
Protected method | FindDescendantControl(String) | Find descendant control. (Inherited from XamlControl.)
Protected method | FindDescendantControl(Control, String) | Find descendant control. (Inherited from XamlControl.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
Protected method | LoadViewState | Restores view-state information from a previous request that was saved with the SaveViewState()()()() method. (Inherited from WebControl.)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | Next | Moves the wizard to the next page.
Protected method | OnBack | Called when the user clicks the Back button.
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnCancel | Called when the user clicks the Cancel button.
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnInit | Raises the Init event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Overrides XamlControl..::..OnLoad(EventArgs).)
Protected method | OnNext | Called when the user clicks the Next button.
Protected method | OnPreRender | Raises the PreRender event. (Inherited from Control.)
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Protected method | PreviewAjaxCommand | Previews the Ajax command. (Inherited from XamlControl.)
Protected method | PreviewAjaxMethod | Previews the Ajax method. (Inherited from XamlControl.)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Protected method | RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Protected method | Render | Renders the control to the specified HTML writer. (Inherited from XamlControl.)
Public method | RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Protected method | RenderContents | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Public method | RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SaveViewState | Saves any state that was modified after the TrackViewState()()()() method was invoked. (Inherited from WebControl.)
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)

See Also

Wizard Class
Sitecore.Controls Namespace


ActivePageChanged Method

[image]

Sitecore 6.4.1 API
Wizard..::..ActivePageChanged Method
Wizard Class See Also Send Feedback

Namespace: Sitecore.Controls
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void ActivePageChanged(
    string page,
    string oldPage
)
Visual Basic
Protected Overridable Sub ActivePageChanged ( _
    page As String, _
    oldPage As String _
)
Visual C++
protected:
virtual void ActivePageChanged(
    String^ page,
    String^ oldPage
)

Parameters

page
Type: System..::..String
The page that has been entered.
oldPage
Type: System..::..String
The page that was left.

See Also

Wizard Class
Sitecore.Controls Namespace


Back Method

[image]

Sitecore 6.4.1 API
Wizard..::..Back Method
Wizard Class See Also Send Feedback

Namespace: Sitecore.Controls
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Back()
Visual Basic
Public Sub Back
Visual C++
public:
void Back()

See Also

Wizard Class
Sitecore.Controls Namespace


Cancel Method

[image]

Sitecore 6.4.1 API
Wizard..::..Cancel Method
Wizard Class See Also Send Feedback

Namespace: Sitecore.Controls
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Cancel()
Visual Basic
Public Sub Cancel
Visual C++
public:
void Cancel()

See Also

Wizard Class
Sitecore.Controls Namespace


CloseWizard Method

[image]

Sitecore 6.4.1 API
Wizard..::..CloseWizard Method
Wizard Class See Also Send Feedback

Namespace: Sitecore.Controls
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void CloseWizard(
    ClientPipelineArgs args
)
Visual Basic
Protected Sub CloseWizard ( _
    args As ClientPipelineArgs _
)
Visual C++
protected:
void CloseWizard(
    ClientPipelineArgs^ args
)

Parameters

args
Type: Sitecore.Web.UI.Sheer..::..ClientPipelineArgs
The args.

See Also

Wizard Class
Sitecore.Controls Namespace


DataBind Method

[image] [image]

Sitecore 6.4.1 API
Wizard..::..DataBind Method
Wizard Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)

See Also

Wizard Class
Wizard Members
Sitecore.Controls Namespace


EndWizard Method

[image]

Sitecore 6.4.1 API
Wizard..::..EndWizard Method
Wizard Class See Also Send Feedback

Namespace: Sitecore.Controls
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void EndWizard()
Visual Basic
Protected Overridable Sub EndWizard
Visual C++
protected:
virtual void EndWizard()

See Also

Wizard Class
Sitecore.Controls Namespace


FindControl Method

[image] [image]

Sitecore 6.4.1 API
Wizard..::..FindControl Method
Wizard Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)

See Also

Wizard Class
Wizard Members
Sitecore.Controls Namespace


FindDescendantControl Method

[image] [image]

Sitecore 6.4.1 API
Wizard..::..FindDescendantControl Method
Wizard Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | FindDescendantControl(String) | Find descendant control. (Inherited from XamlControl.)
Protected method | FindDescendantControl(Control, String) | Find descendant control. (Inherited from XamlControl.)

See Also

Wizard Class
Wizard Members
Sitecore.Controls Namespace


Next Method

[image]

Sitecore 6.4.1 API
Wizard..::..Next Method
Wizard Class See Also Send Feedback

Namespace: Sitecore.Controls
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Next()
Visual Basic
Public Sub Next
Visual C++
public:
void Next()

See Also

Wizard Class
Sitecore.Controls Namespace


OnBack Method

[image]

Sitecore 6.4.1 API
Wizard..::..OnBack Method
Wizard Class See Also Send Feedback

Namespace: Sitecore.Controls
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void OnBack(
    Object sender,
    EventArgs formEventArgs
)
Visual Basic
Protected Overridable Sub OnBack ( _
    sender As Object, _
    formEventArgs As EventArgs _
)
Visual C++
protected:
virtual void OnBack(
    Object^ sender,
    EventArgs^ formEventArgs
)

Parameters

sender
Type: System..::..Object
The sender.
formEventArgs
Type: System..::..EventArgs
The EventArgs instance containing the event data.

See Also

Wizard Class
Sitecore.Controls Namespace


OnLoad Method

[image]

Sitecore 6.4.1 API
Wizard..::..OnLoad Method
Wizard Class See Also Send Feedback

Namespace: Sitecore.Controls
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void OnLoad(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnLoad ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLoad(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
The EventArgs object that contains the event data.

See Also

Wizard Class
Sitecore.Controls Namespace


OnNext Method

[image]

Sitecore 6.4.1 API
Wizard..::..OnNext Method
Wizard Class See Also Send Feedback

Namespace: Sitecore.Controls
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void OnNext(
    Object sender,
    EventArgs formEventArgs
)
Visual Basic
Protected Overridable Sub OnNext ( _
    sender As Object, _
    formEventArgs As EventArgs _
)
Visual C++
protected:
virtual void OnNext(
    Object^ sender,
    EventArgs^ formEventArgs
)

Parameters

sender
Type: System..::..Object
The sender.
formEventArgs
Type: System..::..EventArgs
The EventArgs instance containing the event data.

See Also

Wizard Class
Sitecore.Controls Namespace


RenderControl Method

[image] [image]

Sitecore 6.4.1 API
Wizard..::..RenderControl Method
Wizard Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)

See Also

Wizard Class
Wizard Members
Sitecore.Controls Namespace


Wizard Properties

[image] [image]

Sitecore 6.4.1 API
Wizard Properties
Wizard Class See Also Send Feedback

The Wizard type exposes the following members.

Properties

 | Name | Description
Public property | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Public property | Active | Gets or sets the active page name.
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
Protected property | BackButton |
Public property | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
Public property | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
Public property | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
Protected property | CancelButton |
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Protected property | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Public property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from XamlControl.)
Public property | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
Public property | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
Protected property | Definition | Gets the definition. (Inherited from XamlControl.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
Public property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
Public property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Public property | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
Public property | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
Public property | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Public property | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
Public property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
Protected property | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Protected property | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Protected property | NextButton |
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | Pages | Gets the pages.
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
Public property | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
Public property | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
Protected property | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Protected property | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
Public property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
Public property | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)

See Also

Wizard Class
Sitecore.Controls Namespace


BackButton Property

[image]

Sitecore 6.4.1 API
Wizard..::..BackButton Property
Wizard Class See Also Send Feedback

Namespace: Sitecore.Controls
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Button BackButton { get; set; }
Visual Basic
Protected Property BackButton As Button
    Get
    Set
Visual C++
protected:
property Button^ BackButton {
    Button^ get ();
    void set (Button^ value);
}

See Also

Wizard Class
Sitecore.Controls Namespace


CancelButton Property

[image]

Sitecore 6.4.1 API
Wizard..::..CancelButton Property
Wizard Class See Also Send Feedback

Namespace: Sitecore.Controls
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Button CancelButton { get; set; }
Visual Basic
Protected Property CancelButton As Button
    Get
    Set
Visual C++
protected:
property Button^ CancelButton {
    Button^ get ();
    void set (Button^ value);
}

See Also

Wizard Class
Sitecore.Controls Namespace


NextButton Property

[image]

Sitecore 6.4.1 API
Wizard..::..NextButton Property
Wizard Class See Also Send Feedback

Namespace: Sitecore.Controls
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Button NextButton { get; set; }
Visual Basic
Protected Property NextButton As Button
    Get
    Set
Visual C++
protected:
property Button^ NextButton {
    Button^ get ();
    void set (Button^ value);
}

See Also

Wizard Class
Sitecore.Controls Namespace


Pages Property

[image]

Sitecore 6.4.1 API
Wizard..::..Pages Property
Wizard Class See Also Send Feedback

Namespace: Sitecore.Controls
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StringCollection Pages { get; set; }
Visual Basic
Public Property Pages As StringCollection
    Get
    Set
Visual C++
public:
property StringCollection^ Pages {
    StringCollection^ get ();
    void set (StringCollection^ value);
}

Field Value

The pages.

See Also

Wizard Class
Sitecore.Controls Namespace


Wizard Events

[image] [image]

Sitecore 6.4.1 API
Wizard Events
Wizard Class See Also Send Feedback

The Wizard type exposes the following members.

Events

 | Name | Description
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

See Also

Wizard Class
Sitecore.Controls Namespace


WizardPage Constructor

[image]

Sitecore 6.4.1 API
WizardPage Constructor
WizardPage Class See Also Send Feedback

Namespace: Sitecore.Controls
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WizardPage()
Visual Basic
Public Sub New
Visual C++
public:
WizardPage()

See Also

WizardPage Class
Sitecore.Controls Namespace


WizardPage Methods

[image] [image]

Sitecore 6.4.1 API
WizardPage Methods
WizardPage Class See Also Send Feedback

The WizardPage type exposes the following members.

Methods

 | Name | Description
Protected method | AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Public method | ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Public method | CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from XamlControl.)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Protected method | CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteAjaxCommand | Executes the ajax command. (Inherited from XamlControl.)
Protected method | ExecuteAjaxMethod | Executes the ajax method. (Inherited from XamlControl.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
Protected method | FindDescendantControl(String) | Find descendant control. (Inherited from XamlControl.)
Protected method | FindDescendantControl(Control, String) | Find descendant control. (Inherited from XamlControl.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
Protected method | LoadViewState | Restores view-state information from a previous request that was saved with the SaveViewState()()()() method. (Inherited from WebControl.)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnInit | Raises the Init event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from XamlControl.)
Protected method | OnPreRender | Raises the PreRender event. (Inherited from Control.)
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Protected method | PreviewAjaxCommand | Previews the Ajax command. (Inherited from XamlControl.)
Protected method | PreviewAjaxMethod | Previews the Ajax method. (Inherited from XamlControl.)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Protected method | RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Protected method | Render | Renders the control to the specified HTML writer. (Inherited from XamlControl.)
Public method | RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Protected method | RenderContents | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Public method | RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SaveViewState | Saves any state that was modified after the TrackViewState()()()() method was invoked. (Inherited from WebControl.)
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)

See Also

WizardPage Class
Sitecore.Controls Namespace


FindControl Method

[image] [image]

Sitecore 6.4.1 API
WizardPage..::..FindControl Method
WizardPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)

See Also

WizardPage Class
WizardPage Members
Sitecore.Controls Namespace


FindDescendantControl Method

[image] [image]

Sitecore 6.4.1 API
WizardPage..::..FindDescendantControl Method
WizardPage Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | FindDescendantControl(String) | Find descendant control. (Inherited from XamlControl.)
Protected method | FindDescendantControl(Control, String) | Find descendant control. (Inherited from XamlControl.)

See Also

WizardPage Class
WizardPage Members
Sitecore.Controls Namespace


RenderControl Method

[image] [image]

Sitecore 6.4.1 API
WizardPage..::..RenderControl Method
WizardPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)

See Also

WizardPage Class
WizardPage Members
Sitecore.Controls Namespace


WizardPage Properties

[image] [image]

Sitecore 6.4.1 API
WizardPage Properties
WizardPage Class See Also Send Feedback

The WizardPage type exposes the following members.

Properties

 | Name | Description
Public property | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
Public property | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
Public property | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
Public property | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Protected property | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Public property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from XamlControl.)
Public property | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
Public property | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
Protected property | Definition | Gets the definition. (Inherited from XamlControl.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
Public property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
Public property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Public property | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
Public property | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
Public property | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Public property | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
Public property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
Protected property | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Protected property | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
Public property | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
Public property | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
Protected property | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Protected property | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
Public property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
Public property | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)

See Also

WizardPage Class
Sitecore.Controls Namespace


WizardPage Events

[image] [image]

Sitecore 6.4.1 API
WizardPage Events
WizardPage Class See Also Send Feedback

The WizardPage type exposes the following members.

Events

 | Name | Description
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

See Also

WizardPage Class
Sitecore.Controls Namespace


Sitecore.Data Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Data Namespace
Send Feedback

Classes

 | Class | Description
Public class | AliasResolver | Resolves an alias.
Public class | Appearance | Defines the appearance properties.
Public class | BranchRecords | Represents the masters that are defined in a specified database.
Public class | BulkUpdateContext | BatchUpdateContext class
Public class | Database | Represents a database.
Public class | Database..::..DataRecords | Items records
Public class | DatabaseCacheDisabler | Disables database caches for given thread.
Public class | DatabaseCaches | Stores caches for a database.
Public class | DatabaseEngines | DatabaseEngines
Public class | DatabaseProperties | Stores custom properties for a database.
Public class | DatabaseSwitcher | Switches to another database temporarily.
Public class | DataManager | Represents the data manager.
Public class | DataSource | Represents a data source.
Public class | DataUri | Represents a moniker to an item in a specified database.
Public class | DeviceRecords | Represents the layout devices that are defined in a specified database.
Public class | FieldDescriptor | Defines the field URI class.
Public class | FieldList | Represents a list of fields.
Public class | ID | An ID represents a unique identifier.
Public class | ItemData | Represents item data.
Public class | ItemDefinition | Represents an item definition.
Public class | ItemInformation | ItemInformation
Public class | ItemPath | Contains utility properties and function that describe the path of an item.
Public class | ItemPointer | Points to an item.
Public class | ItemRecords | Provides access to the items in a database.
Public class | ItemUri | Provides a moniker to an item in a database.
Public class | ItemUriBuilder | Builds an ItemUri.
Public class | LayoutRecords | Represents the layout that are defined in a specified database.
Public class | MasterVariablesReplacer | Represents a master variables replacer.
Public class | PropertiesBase | Defines a meta data store for a database.
Public class | RenderingRecords | Represents the renderings that are defined in a specified database.
Public class | ShortID | Represents an ID in a compressed form.
Public class | SortCriteria | GridSort
Public class | StandardValuesManager | StandardValueManager class
Public class | StandardValuesProvider | StandardValuesProvider
Public class | StandardValuesProviderCollection | StandardValuesProviderCollection class
Public class | SublayoutRecords | Represents the sublayouts in a database.
Public class | TemplateRecords | Represents the templates that are defined in a specified database.
Public class | TreeNavigator | Obsolete. Represents a tree navigator.
Public class | TreeNavigator..::..State | Represents the state of a tree navigator.
Public class | Version | Represents a version number of an item.
Public class | VersionComparer | Represents a version comparer.
Public class | VersionUri | Represents an Uri to a Version.

Structures

 | Structure | Description
Public structure | BranchId | Represents a master ID.
Public structure | LongID | A LongID is a fully qualified ID path.
Public structure | TemplateID | Represents a template ID.

Enumerations

 | Enumeration | Description
Public enumeration | ItemUriFormat | Defines how the string representation of an ItemURI is formatted.
Public enumeration | VersioningType | Defines the type of versioning for a field.


AliasResolver Class

[image]

Sitecore 6.4.1 API
AliasResolver Class
Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class AliasResolver
Visual Basic
Public Class AliasResolver
Visual C++
public ref class AliasResolver

Remarks

An alias is a URL that points to another location in the content tree. For instance the URL "/campaign" can be setup to point to "/sitecore/content/Home/Campaigns/2005/Super Offers".

Aliases are configures in /sitecore/system/Aliases

An alias resolver is attach to a database and is access through the Sitecore.Data.Database.Aliases property.

Inheritance Hierarchy

System..::..Object
Sitecore.Data..::..AliasResolver

See Also

AliasResolver Members
Sitecore.Data Namespace


AliasResolver Members

[image] [image]

Sitecore 6.4.1 API
AliasResolver Members
AliasResolver Class Constructors Methods Properties See Also Send Feedback

The AliasResolver type exposes the following members.

Constructors

 | Name | Description
Public method | AliasResolver | Creates a new AliasResolver instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines if an alias point to a valid item.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTargetID | Gets the target ID.
Public method | GetTargetUrl | Gets the target URL.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | Gets a LinkField form a specified alias.

See Also

AliasResolver Class
Sitecore.Data Namespace


AliasResolver Constructor

[image]

Sitecore 6.4.1 API
AliasResolver Constructor
AliasResolver Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AliasResolver(
    Database database
)
Visual Basic
Public Sub New ( _
    database As Database _
)
Visual C++
public:
AliasResolver(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
Database.

See Also

AliasResolver Class
Sitecore.Data Namespace


AliasResolver Methods

[image] [image]

Sitecore 6.4.1 API
AliasResolver Methods
AliasResolver Class See Also Send Feedback

The AliasResolver type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines if an alias point to a valid item.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTargetID | Gets the target ID.
Public method | GetTargetUrl | Gets the target URL.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AliasResolver Class
Sitecore.Data Namespace


Exists Method

[image]

Sitecore 6.4.1 API
AliasResolver..::..Exists Method
AliasResolver Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Exists(
    string alias
)
Visual Basic
Public Function Exists ( _
    alias As String _
) As Boolean
Visual C++
public:
bool Exists(
    String^ alias
)

Parameters

alias
Type: System..::..String
Alias.

Return Value

The exists.

See Also

AliasResolver Class
Sitecore.Data Namespace


GetTargetID Method

[image]

Sitecore 6.4.1 API
AliasResolver..::..GetTargetID Method
AliasResolver Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID GetTargetID(
    string alias
)
Visual Basic
Public Function GetTargetID ( _
    alias As String _
) As ID
Visual C++
public:
ID^ GetTargetID(
    String^ alias
)

Parameters

alias
Type: System..::..String
Alias.

Return Value

The target ID.

See Also

AliasResolver Class
Sitecore.Data Namespace


GetTargetUrl Method

[image]

Sitecore 6.4.1 API
AliasResolver..::..GetTargetUrl Method
AliasResolver Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetTargetUrl(
    string alias
)
Visual Basic
Public Function GetTargetUrl ( _
    alias As String _
) As String
Visual C++
public:
String^ GetTargetUrl(
    String^ alias
)

Parameters

alias
Type: System..::..String
Alias.

Return Value

The target URL.

See Also

AliasResolver Class
Sitecore.Data Namespace


AliasResolver Properties

[image] [image]

Sitecore 6.4.1 API
AliasResolver Properties
AliasResolver Class See Also Send Feedback

The AliasResolver type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets a LinkField form a specified alias.

See Also

AliasResolver Class
Sitecore.Data Namespace


Item Property

[image]

Sitecore 6.4.1 API
AliasResolver..::..Item Property
AliasResolver Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LinkField this[
    string alias
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    alias As String _
) As LinkField
    Get
Visual C++
public:
property LinkField^ default[String^ alias] {
    LinkField^ get (String^ alias);
}

Parameters

alias
Type: System..::..String

See Also

AliasResolver Class
Sitecore.Data Namespace


Appearance Class

[image]

Sitecore 6.4.1 API
Appearance Class
Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Appearance
Visual Basic
Public Class Appearance
Visual C++
public ref class Appearance

Inheritance Hierarchy

System..::..Object
Sitecore.Data..::..Appearance
Sitecore.Data.Items..::..ItemAppearance

See Also

Appearance Members
Sitecore.Data Namespace


Appearance Members

[image] [image]

Sitecore 6.4.1 API
Appearance Members
Appearance Class Constructors Methods Properties See Also Send Feedback

The Appearance type exposes the following members.

Constructors

 | Name | Description
Public method | Appearance()()()() | Creates a new Appearance instance.
Public method | Appearance(String) | Creates a new Appearance instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DisplayName | Gets or sets the display name.
Public property | HelpLink | Gets or sets the help link.
Public property | Icon | Gets or sets the icon.
Public property | LongDescription | Gets or sets the long description.
Public property | ShortDescription | Gets or sets the short description.
Public property | Style | Gets or sets the CSS style.

See Also

Appearance Class
Sitecore.Data Namespace


Appearance Constructor

[image] [image]

Sitecore 6.4.1 API
Appearance Constructor
Appearance Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Appearance()()()() | Creates a new Appearance instance.
Public method | Appearance(String) | Creates a new Appearance instance.

See Also

Appearance Class
Appearance Members
Sitecore.Data Namespace


Appearance Constructor

[image]

Sitecore 6.4.1 API
Appearance Constructor
Appearance Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Appearance()
Visual Basic
Public Sub New
Visual C++
public:
Appearance()

See Also

Appearance Class
Appearance Overload
Sitecore.Data Namespace


Appearance Constructor (String)

[image]

Sitecore 6.4.1 API
Appearance Constructor (String)
Appearance Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Appearance(
    string displayName
)
Visual Basic
Public Sub New ( _
    displayName As String _
)
Visual C++
public:
Appearance(
    String^ displayName
)

Parameters

displayName
Type: System..::..String
The display name.

See Also

Appearance Class
Appearance Overload
Sitecore.Data Namespace


Appearance Methods

[image] [image]

Sitecore 6.4.1 API
Appearance Methods
Appearance Class See Also Send Feedback

The Appearance type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Appearance Class
Sitecore.Data Namespace


Appearance Properties

[image] [image]

Sitecore 6.4.1 API
Appearance Properties
Appearance Class See Also Send Feedback

The Appearance type exposes the following members.

Properties

 | Name | Description
Public property | DisplayName | Gets or sets the display name.
Public property | HelpLink | Gets or sets the help link.
Public property | Icon | Gets or sets the icon.
Public property | LongDescription | Gets or sets the long description.
Public property | ShortDescription | Gets or sets the short description.
Public property | Style | Gets or sets the CSS style.

See Also

Appearance Class
Sitecore.Data Namespace


DisplayName Property

[image]

Sitecore 6.4.1 API
Appearance..::..DisplayName Property
Appearance Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string DisplayName { get; set; }
Visual Basic
Public Overridable Property DisplayName As String
    Get
    Set
Visual C++
public:
virtual property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the display.

Remarks

If the display name field is blank, the item name is used.

See Also

Appearance Class
Sitecore.Data Namespace


HelpLink Property

[image]

Sitecore 6.4.1 API
Appearance..::..HelpLink Property
Appearance Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string HelpLink { get; set; }
Visual Basic
Public Overridable Property HelpLink As String
    Get
    Set
Visual C++
public:
virtual property String^ HelpLink {
    String^ get ();
    void set (String^ value);
}

Field Value

The help link.

See Also

Appearance Class
Sitecore.Data Namespace


Icon Property

[image]

Sitecore 6.4.1 API
Appearance..::..Icon Property
Appearance Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string Icon { get; set; }
Visual Basic
Public Overridable Property Icon As String
    Get
    Set
Visual C++
public:
virtual property String^ Icon {
    String^ get ();
    void set (String^ value);
}

Field Value

The icon.

See Also

Appearance Class
Sitecore.Data Namespace


LongDescription Property

[image]

Sitecore 6.4.1 API
Appearance..::..LongDescription Property
Appearance Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string LongDescription { get; set; }
Visual Basic
Public Overridable Property LongDescription As String
    Get
    Set
Visual C++
public:
virtual property String^ LongDescription {
    String^ get ();
    void set (String^ value);
}

Field Value

The long description.

See Also

Appearance Class
Sitecore.Data Namespace


ShortDescription Property

[image]

Sitecore 6.4.1 API
Appearance..::..ShortDescription Property
Appearance Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string ShortDescription { get; set; }
Visual Basic
Public Overridable Property ShortDescription As String
    Get
    Set
Visual C++
public:
virtual property String^ ShortDescription {
    String^ get ();
    void set (String^ value);
}

Field Value

The short description.

See Also

Appearance Class
Sitecore.Data Namespace


Style Property

[image]

Sitecore 6.4.1 API
Appearance..::..Style Property
Appearance Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string Style { get; set; }
Visual Basic
Public Overridable Property Style As String
    Get
    Set
Visual C++
public:
virtual property String^ Style {
    String^ get ();
    void set (String^ value);
}

Field Value

The CSS style.

Remarks

The CSS style is primarly used in the Content Tree where the style is applied to tree node. For instance all top sections (content, media library, templates etc.) have the style "color:green" which makes the nodes appear green.

See Also

Appearance Class
Sitecore.Data Namespace


BranchId Structure

[image]

Sitecore 6.4.1 API
BranchId Structure
Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public struct BranchId
Visual Basic
Public Structure BranchId
Visual C++
public value class BranchId

See Also

BranchId Members
Sitecore.Data Namespace


BranchId Members

[image] [image]

Sitecore 6.4.1 API
BranchId Members
BranchId Structure Constructors Methods Properties See Also Send Feedback

The BranchId type exposes the following members.

Constructors

 | Name | Description
Public method | BranchId | Initializes a new instance of the BranchId class.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the ID as a string. (Overrides ValueType..::..ToString()()()().)

Properties

 | Name | Description
Public property | ID | Gets the ID.

See Also

BranchId Structure
Sitecore.Data Namespace


BranchId Constructor

[image]

Sitecore 6.4.1 API
BranchId Constructor
BranchId Structure See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BranchId(
    ID id
)
Visual Basic
Public Sub New ( _
    id As ID _
)
Visual C++
public:
BranchId(
    ID^ id
)

Parameters

id
Type: Sitecore.Data..::..ID
The id.

See Also

BranchId Structure
Sitecore.Data Namespace


BranchId Methods

[image] [image]

Sitecore 6.4.1 API
BranchId Methods
BranchId Structure See Also Send Feedback

The BranchId type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the ID as a string. (Overrides ValueType..::..ToString()()()().)

See Also

BranchId Structure
Sitecore.Data Namespace


ToString Method

[image]

Sitecore 6.4.1 API
BranchId..::..ToString Method
BranchId Structure See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String containing the ID.

See Also

BranchId Structure
Sitecore.Data Namespace


BranchId Properties

[image] [image]

Sitecore 6.4.1 API
BranchId Properties
BranchId Structure See Also Send Feedback

The BranchId type exposes the following members.

Properties

 | Name | Description
Public property | ID | Gets the ID.

See Also

BranchId Structure
Sitecore.Data Namespace


ID Property

[image]

Sitecore 6.4.1 API
BranchId..::..ID Property
BranchId Structure See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ID { get; }
Visual Basic
Public ReadOnly Property ID As ID
    Get
Visual C++
public:
property ID^ ID {
    ID^ get ();
}

Field Value

The ID.

See Also

BranchId Structure
Sitecore.Data Namespace


BranchRecords Class

[image]

Sitecore 6.4.1 API
BranchRecords Class
Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class BranchRecords : Database..::..DataRecords
Visual Basic
Public Class BranchRecords _
    Inherits Database..::..DataRecords
Visual C++
public ref class BranchRecords : public Database..::..DataRecords

Remarks

Masters are configured in /sitecore/masters.

The masters are normally access through the Branches property.

Inheritance Hierarchy

System..::..Object
Sitecore.Data..::..Database..::..DataRecords
Sitecore.Data..::..BranchRecords

See Also

BranchRecords Members
Sitecore.Data Namespace


BranchRecords Members

[image] [image]

Sitecore 6.4.1 API
BranchRecords Members
BranchRecords Class Constructors Methods Properties See Also Send Feedback

The BranchRecords type exposes the following members.

Constructors

 | Name | Description
Public method | BranchRecords | Creates a new BranchRecords instance.

Methods

 | Name | Description
Public method | CreateMaster | Creates a new master.
Protected method | DoGetItem(String) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(DataUri) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(String, Language) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID, Language) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(String, Language, Version) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID, Language, Version) | Gets the item. (Inherited from Database..::..DataRecords.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists(DataUri) | Gets a value that indicates if the data URI exists in the database. (Inherited from Database..::..DataRecords.)
Public method | Exists(ID) | Gets a value that indicates if the item ID exists in the database. (Inherited from Database..::..DataRecords.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaster(String) | Gets a master.
Public method | GetMaster(ID) | Gets a master.
Public method | GetMaster(String, Language) | Gets a master.
Public method | GetMaster(ID, Language) | Gets a master.
Public method | GetMaster(String, Language, Version) | Gets a master.
Public method | GetMaster(ID, Language, Version) | Gets a master.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniquePath | Gets a unique path of an item in the database. (Inherited from Database..::..DataRecords.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BasePath | Gets the base path. (Inherited from Database..::..DataRecords.)
Public property | Database | Gets the database. (Inherited from Database..::..DataRecords.)
Public property | Item[([( String])]) | Gets the BranchItem with the specified name.
Public property | Item[([( ID])]) | Gets the BranchItem with the specified id.
Public property | Item[([( String, Language])]) | Gets the BranchItem with the specified name.
Public property | Item[([( ID, Language])]) | Gets the BranchItem with the specified id.
Public property | Item[([( String, Language, Version])]) | Gets the BranchItem with the specified name.
Public property | Item[([( ID, Language, Version])]) | Gets the BranchItem with the specified id.

See Also

BranchRecords Class
Sitecore.Data Namespace


BranchRecords Constructor

[image]

Sitecore 6.4.1 API
BranchRecords Constructor
BranchRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BranchRecords(
    Database database
)
Visual Basic
Public Sub New ( _
    database As Database _
)
Visual C++
public:
BranchRecords(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
Database.

See Also

BranchRecords Class
Sitecore.Data Namespace


CreateMaster Method

[image]

Sitecore 6.4.1 API
BranchRecords..::..CreateMaster Method
BranchRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BranchItem CreateMaster(
    string name,
    TemplateItem template
)
Visual Basic
Public Function CreateMaster ( _
    name As String, _
    template As TemplateItem _
) As BranchItem
Visual C++
public:
BranchItem^ CreateMaster(
    String^ name,
    TemplateItem^ template
)

Parameters

name
Type: System..::..String
Name.
template
Type: Sitecore.Data.Items..::..TemplateItem
Template.

Return Value

The master.

See Also

BranchRecords Class
Sitecore.Data Namespace


DoGetItem Method

[image] [image]

Sitecore 6.4.1 API
BranchRecords..::..DoGetItem Method
BranchRecords Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | DoGetItem(String) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(DataUri) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(String, Language) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID, Language) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(String, Language, Version) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID, Language, Version) | Gets the item. (Inherited from Database..::..DataRecords.)

See Also

BranchRecords Class
BranchRecords Members
Sitecore.Data Namespace


Exists Method

[image] [image]

Sitecore 6.4.1 API
BranchRecords..::..Exists Method
BranchRecords Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Exists(DataUri) | Gets a value that indicates if the data URI exists in the database. (Inherited from Database..::..DataRecords.)
Public method | Exists(ID) | Gets a value that indicates if the item ID exists in the database. (Inherited from Database..::..DataRecords.)

See Also

BranchRecords Class
BranchRecords Members
Sitecore.Data Namespace


GetMaster Method

[image] [image]

Sitecore 6.4.1 API
BranchRecords..::..GetMaster Method
BranchRecords Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMaster(String) | Gets a master.
Public method | GetMaster(ID) | Gets a master.
Public method | GetMaster(String, Language) | Gets a master.
Public method | GetMaster(ID, Language) | Gets a master.
Public method | GetMaster(String, Language, Version) | Gets a master.
Public method | GetMaster(ID, Language, Version) | Gets a master.

See Also

BranchRecords Class
BranchRecords Members
Sitecore.Data Namespace


GetMaster Method (String)

[image]

Sitecore 6.4.1 API
BranchRecords..::..GetMaster Method (String)
BranchRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BranchItem GetMaster(
    string itemPath
)
Visual Basic
Public Function GetMaster ( _
    itemPath As String _
) As BranchItem
Visual C++
public:
BranchItem^ GetMaster(
    String^ itemPath
)

Parameters

itemPath
Type: System..::..String
Item path.

Return Value

The master.

See Also

BranchRecords Class
GetMaster Overload
Sitecore.Data Namespace


GetMaster Method (ID)

[image]

Sitecore 6.4.1 API
BranchRecords..::..GetMaster Method (ID)
BranchRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BranchItem GetMaster(
    ID itemID
)
Visual Basic
Public Function GetMaster ( _
    itemID As ID _
) As BranchItem
Visual C++
public:
BranchItem^ GetMaster(
    ID^ itemID
)

Parameters

itemID
Type: Sitecore.Data..::..ID
Item ID.

Return Value

The master.

See Also

BranchRecords Class
GetMaster Overload
Sitecore.Data Namespace


GetMaster Method (String, Language)

[image]

Sitecore 6.4.1 API
BranchRecords..::..GetMaster Method (String, Language)
BranchRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BranchItem GetMaster(
    string itemPath,
    Language language
)
Visual Basic
Public Function GetMaster ( _
    itemPath As String, _
    language As Language _
) As BranchItem
Visual C++
public:
BranchItem^ GetMaster(
    String^ itemPath,
    Language^ language
)

Parameters

itemPath
Type: System..::..String
Item path.
language
Type: Sitecore.Globalization..::..Language
Language.

Return Value

The master.

See Also

BranchRecords Class
GetMaster Overload
Sitecore.Data Namespace


GetMaster Method (ID, Language)

[image]

Sitecore 6.4.1 API
BranchRecords..::..GetMaster Method (ID, Language)
BranchRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BranchItem GetMaster(
    ID itemID,
    Language language
)
Visual Basic
Public Function GetMaster ( _
    itemID As ID, _
    language As Language _
) As BranchItem
Visual C++
public:
BranchItem^ GetMaster(
    ID^ itemID,
    Language^ language
)

Parameters

itemID
Type: Sitecore.Data..::..ID
Item ID.
language
Type: Sitecore.Globalization..::..Language
Language.

Return Value

The master.

See Also

BranchRecords Class
GetMaster Overload
Sitecore.Data Namespace


GetMaster Method (String, Language, Version)

[image]

Sitecore 6.4.1 API
BranchRecords..::..GetMaster Method (String, Language, Version)
BranchRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BranchItem GetMaster(
    string masterName,
    Language language,
    Version version
)
Visual Basic
Public Function GetMaster ( _
    masterName As String, _
    language As Language, _
    version As Version _
) As BranchItem
Visual C++
public:
BranchItem^ GetMaster(
    String^ masterName,
    Language^ language,
    Version^ version
)

Parameters

masterName
Type: System..::..String
Item path.
language
Type: Sitecore.Globalization..::..Language
Language.
version
Type: Sitecore.Data..::..Version
Version.

Return Value

The master.

See Also

BranchRecords Class
GetMaster Overload
Sitecore.Data Namespace


GetMaster Method (ID, Language, Version)

[image]

Sitecore 6.4.1 API
BranchRecords..::..GetMaster Method (ID, Language, Version)
BranchRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BranchItem GetMaster(
    ID itemID,
    Language language,
    Version version
)
Visual Basic
Public Function GetMaster ( _
    itemID As ID, _
    language As Language, _
    version As Version _
) As BranchItem
Visual C++
public:
BranchItem^ GetMaster(
    ID^ itemID,
    Language^ language,
    Version^ version
)

Parameters

itemID
Type: Sitecore.Data..::..ID
Item ID.
language
Type: Sitecore.Globalization..::..Language
Language.
version
Type: Sitecore.Data..::..Version
Version.

Return Value

The master.

See Also

BranchRecords Class
GetMaster Overload
Sitecore.Data Namespace


BranchRecords Properties

[image] [image]

Sitecore 6.4.1 API
BranchRecords Properties
BranchRecords Class See Also Send Feedback

The BranchRecords type exposes the following members.

Properties

 | Name | Description
Public property | BasePath | Gets the base path. (Inherited from Database..::..DataRecords.)
Public property | Database | Gets the database. (Inherited from Database..::..DataRecords.)
Public property | Item[([( String])]) | Gets the BranchItem with the specified name.
Public property | Item[([( ID])]) | Gets the BranchItem with the specified id.
Public property | Item[([( String, Language])]) | Gets the BranchItem with the specified name.
Public property | Item[([( ID, Language])]) | Gets the BranchItem with the specified id.
Public property | Item[([( String, Language, Version])]) | Gets the BranchItem with the specified name.
Public property | Item[([( ID, Language, Version])]) | Gets the BranchItem with the specified id.

See Also

BranchRecords Class
Sitecore.Data Namespace


Item Property

[image] [image]

Sitecore 6.4.1 API
BranchRecords..::..Item Property
BranchRecords Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( String])]) | Gets the BranchItem with the specified name.
Public property | Item[([( ID])]) | Gets the BranchItem with the specified id.
Public property | Item[([( String, Language])]) | Gets the BranchItem with the specified name.
Public property | Item[([( ID, Language])]) | Gets the BranchItem with the specified id.
Public property | Item[([( String, Language, Version])]) | Gets the BranchItem with the specified name.
Public property | Item[([( ID, Language, Version])]) | Gets the BranchItem with the specified id.

See Also

BranchRecords Class
BranchRecords Members
Sitecore.Data Namespace


Item Property (String)

[image]

Sitecore 6.4.1 API
BranchRecords..::..Item Property (String)
BranchRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BranchItem this[
    string masterName
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    masterName As String _
) As BranchItem
    Get
Visual C++
public:
property BranchItem^ default[String^ masterName] {
    BranchItem^ get (String^ masterName);
}

Parameters

masterName
Type: System..::..String

See Also

BranchRecords Class
Item Overload
Sitecore.Data Namespace


Item Property (ID)

[image]

Sitecore 6.4.1 API
BranchRecords..::..Item Property (ID)
BranchRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BranchItem this[
    ID itemID
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    itemID As ID _
) As BranchItem
    Get
Visual C++
public:
property BranchItem^ default[ID^ itemID] {
    BranchItem^ get (ID^ itemID);
}

Parameters

itemID
Type: Sitecore.Data..::..ID

See Also

BranchRecords Class
Item Overload
Sitecore.Data Namespace


Item Property (String, Language)

[image]

Sitecore 6.4.1 API
BranchRecords..::..Item Property (String, Language)
BranchRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BranchItem this[
    string masterName,
    Language language
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    masterName As String, _
    language As Language _
) As BranchItem
    Get
Visual C++
public:
property BranchItem^ default[String^ masterName, Language^ language] {
    BranchItem^ get (String^ masterName, Language^ language);
}

Parameters

masterName
Type: System..::..String
language
Type: Sitecore.Globalization..::..Language

Field Value

See Also

BranchRecords Class
Item Overload
Sitecore.Data Namespace


Item Property (ID, Language)

[image]

Sitecore 6.4.1 API
BranchRecords..::..Item Property (ID, Language)
BranchRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BranchItem this[
    ID itemID,
    Language language
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    itemID As ID, _
    language As Language _
) As BranchItem
    Get
Visual C++
public:
property BranchItem^ default[ID^ itemID, Language^ language] {
    BranchItem^ get (ID^ itemID, Language^ language);
}

Parameters

itemID
Type: Sitecore.Data..::..ID
language
Type: Sitecore.Globalization..::..Language

See Also

BranchRecords Class
Item Overload
Sitecore.Data Namespace


Item Property (String, Language, Version)

[image]

Sitecore 6.4.1 API
BranchRecords..::..Item Property (String, Language, Version)
BranchRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BranchItem this[
    string masterName,
    Language language,
    Version version
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    masterName As String, _
    language As Language, _
    version As Version _
) As BranchItem
    Get
Visual C++
public:
property BranchItem^ default[String^ masterName, Language^ language, Version^ version] {
    BranchItem^ get (String^ masterName, Language^ language, Version^ version);
}

Parameters

masterName
Type: System..::..String
language
Type: Sitecore.Globalization..::..Language
version
Type: Sitecore.Data..::..Version

See Also

BranchRecords Class
Item Overload
Sitecore.Data Namespace


Item Property (ID, Language, Version)

[image]

Sitecore 6.4.1 API
BranchRecords..::..Item Property (ID, Language, Version)
BranchRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BranchItem this[
    ID itemID,
    Language language,
    Version version
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    itemID As ID, _
    language As Language, _
    version As Version _
) As BranchItem
    Get
Visual C++
public:
property BranchItem^ default[ID^ itemID, Language^ language, Version^ version] {
    BranchItem^ get (ID^ itemID, Language^ language, Version^ version);
}

Parameters

itemID
Type: Sitecore.Data..::..ID
language
Type: Sitecore.Globalization..::..Language
version
Type: Sitecore.Data..::..Version

See Also

BranchRecords Class
Item Overload
Sitecore.Data Namespace


BulkUpdateContext Class

[image]

Sitecore 6.4.1 API
BulkUpdateContext Class
Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class BulkUpdateContext : IDisposable
Visual Basic
Public Class BulkUpdateContext _
    Implements IDisposable
Visual C++
public ref class BulkUpdateContext : IDisposable

Inheritance Hierarchy

System..::..Object
Sitecore.Data..::..BulkUpdateContext

See Also

BulkUpdateContext Members
Sitecore.Data Namespace


BulkUpdateContext Members

[image] [image]

Sitecore 6.4.1 API
BulkUpdateContext Members
BulkUpdateContext Class Constructors Methods Fields Properties Events See Also Send Feedback

The BulkUpdateContext type exposes the following members.

Constructors

 | Name | Description
Public method | BulkUpdateContext | Initializes a new instance of the BulkUpdateContext class

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the BulkUpdateContext
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
_onLeave | Actions to be done while leaving context

Properties

Name | Description
IsActive | Gets a value indicating whether a batch update is in progress.

Events

Name | Description
OnLeave | Occurs when leaving context.

See Also

BulkUpdateContext Class
Sitecore.Data Namespace


BulkUpdateContext Constructor

[image]

Sitecore 6.4.1 API
BulkUpdateContext Constructor
BulkUpdateContext Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BulkUpdateContext()
Visual Basic
Public Sub New
Visual C++
public:
BulkUpdateContext()

See Also

BulkUpdateContext Class
Sitecore.Data Namespace


BulkUpdateContext Fields

[image] [image]

Sitecore 6.4.1 API
BulkUpdateContext Fields
BulkUpdateContext Class See Also Send Feedback

The BulkUpdateContext type exposes the following members.

Fields

Name | Description
_onLeave | Actions to be done while leaving context

See Also

BulkUpdateContext Class
Sitecore.Data Namespace


BulkUpdateContext Methods

[image] [image]

Sitecore 6.4.1 API
BulkUpdateContext Methods
BulkUpdateContext Class See Also Send Feedback

The BulkUpdateContext type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BulkUpdateContext Class
Sitecore.Data Namespace


Dispose Method

[image]

Sitecore 6.4.1 API
BulkUpdateContext..::..Dispose Method
BulkUpdateContext Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

BulkUpdateContext Class
Sitecore.Data Namespace


IsActive Property

[image]

Sitecore 6.4.1 API
BulkUpdateContext..::..IsActive Property
BulkUpdateContext Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsActive { get; }
Visual Basic
Public Shared ReadOnly Property IsActive As Boolean
    Get
Visual C++
public:
static property bool IsActive {
    bool get ();
}

Field Value

true if this instance is active; otherwise, false.

See Also

BulkUpdateContext Class
Sitecore.Data Namespace


BulkUpdateContext Events

[image] [image]

Sitecore 6.4.1 API
BulkUpdateContext Events
BulkUpdateContext Class See Also Send Feedback

The BulkUpdateContext type exposes the following members.

Events

Name | Description
OnLeave | Occurs when leaving context.

See Also

BulkUpdateContext Class
Sitecore.Data Namespace


OnLeave Event

[image]

Sitecore 6.4.1 API
BulkUpdateContext..::..OnLeave Event
BulkUpdateContext Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static event ThreadStart OnLeave
Visual Basic
Public Shared Event OnLeave As ThreadStart
Visual C++
public:
static  event ThreadStart^ OnLeave {
    void add (ThreadStart^ value);
    void remove (ThreadStart^ value);
}

See Also

BulkUpdateContext Class
Sitecore.Data Namespace


Database Class

[image]

Sitecore 6.4.1 API
Database Class
Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Database : IConstructable
Visual Basic
Public Class Database _
    Implements IConstructable
Visual C++
public ref class Database : IConstructable

Remarks

To create a database object use the Factory.GetDatabase method.

The database object provides access to items, aliases, templates etc.

Databases are configured in the web.config.

Remarks

To create a database object use the Factory.GetDatabase method.

The database object provides access to items, aliases, templates etc.

Databases are configured in the web.config.

Inheritance Hierarchy

System..::..Object
Sitecore.Data..::..Database

See Also

Database Members
Sitecore.Data Namespace


Database Members

[image] [image]

Sitecore 6.4.1 API
Database Members
Database Class Constructors Methods Properties Events See Also Send Feedback

The Database type exposes the following members.

Constructors

 | Name | Description
Public method | Database | Initializes a new database.

Methods

 | Name | Description
Public method | CleanupDatabase | Cleans up the database. Note: Make sure that the database has been backed up before calling this method. It may delete a lot of data.
Public method | CreateItemPath(String) | Creates a path of items.
Public method | CreateItemPath(String, TemplateItem) | Creates a path of items.
Public method | CreateItemPath(String, TemplateItem, TemplateItem) | Creates a path of items.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDatabase | Connects to the specified database.
Public method | GetDataProviders | Gets the data providers.
Public method | GetDataSize | Gets the size of the data contained in the database.
 | GetDataSizes | Gets the data sizes of all databases.
Public method | GetDictionaryEntryCount | Gets the number of dictionary entries stored in the database.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItem(String) | Gets an item from a path.
Public method | GetItem(DataUri) | Gets the item.
Public method | GetItem(ID) | Gets an item from a path.
 | GetItem(ItemUri) | Gets an item from an Item URI.
Public method | GetItem(String, Language) | Gets an item from a path.
Public method | GetItem(ID, Language) | Gets an item from a path.
Public method | GetItem(String, Language, Version) | Gets an item from a path.
Public method | GetItem(ID, Language, Version) | Gets an item from a path.
Public method | GetLanguages | Gets the languages defined in the database.
Public method | GetRootItem()()()() | Gets the root item of the database.
Public method | GetRootItem(Language) | Gets the root item of a database.
Public method | GetSearcher | Gets an Index searcher for the database.
Public method | GetTemplate(String) | Gets the template.
Public method | GetTemplate(ID) | Gets the template.
 | GetTotalDataSize | Gets the total size of the data.
 | GetTotalDictionaryEntryCount | Gets the total number of dictionary entries in all databases.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnConstructed | Called when database object has been constructed by the factory.
Public method | SelectItems | Performs a Sitecore Xpath query in the database.
Public method | SelectItemsUsingXPath | Selects the items using Xpath.
Public method | SelectSingleItem | Performs a Sitecore Xpath query in the database.
Public method | SelectSingleItemUsingXPath | Selects the single item using Xpath.
Public method | ToString | Gets the name of the database. (Overrides Object..::..ToString()()()().)

Extension Methods

 | Name | Description
Public Extension Method | GetKnownItem | Gets the known item. (Defined by DatabaseExtensions.)
Public Extension Method | GetKnownItemId | Gets the leftmost part of a string. (Defined by DatabaseExtensions.)

Properties

 | Name | Description
Public property | Aliases | Gets the alias resolver object.
Public property | ArchiveNames | Provides access to the names of the Archives associated with the database.
Public property | Archives | Provides access to the Archives associated with the database.
Public property | Branches | Provides access to the branches in the database.
Public property | Caches | Gets the caches.
Public property | ConnectionStringName | Gets or sets the name of the connection string used by archives etc..
Public property | DataManager | Gets the database manager object that provides low-level access to a DataSource.
Protected property | DataProviders | Gets the data providers.
Public property | Engines | Gets the engines.
Public property | HasContentItem | Gets a value that indicates is the /sitecore/content item is present.
Public property | Icon | Gets or sets the icon.
Public property | Indexes | Provides access to the Indexes associated with the database.
Public property | Items | Provides access to the items in the database.
Public property | Languages | Provides access to the languages in the database.
Public property | Masters | Obsolete. Provides access to the masters in the database.
Public property | Name | Gets the name of the database.
Public property | NotificationProvider | Gets or sets the notification provider.
Public property | Properties | Provides access to the database properties.
Public property | Protected | Gets or sets a value indicating whether this database should be protected.
Public property | ProxiesEnabled | Gets or sets a value that indicates if proxy items are enabled.
Public property | ProxyDataProvider | Gets or sets the proxy data provider.
Public property | PublishVirtualItems | Gets or sets a value that indicates whether virtual items will be published.
Public property | ReadOnly | Gets or sets a value that indicates if the database is read-only.
Public property | RemoteEvents | Gets or sets the remote events.
Public property | Resources | Gets the resources.
Public property | SecurityEnabled | Gets a value that indicates if security is enforced when accessing items.
Public property | SitecoreItem | Gets the sitecore item.
Public property | Templates | Provides access to the Templates in the database.
Public property | WorkflowProvider | Gets the workflow associated with the database.

Events

 | Name | Description
Public event | Constructed |
 | InstanceCreated |

See Also

Database Class
Sitecore.Data Namespace


Database Constructor

[image]

Sitecore 6.4.1 API
Database Constructor
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database(
    string name
)
Visual Basic
Public Sub New ( _
    name As String _
)
Visual C++
public:
Database(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

Remarks

Normally database objects are created using Factory.GetDatabase.

See Also

Database Class
Sitecore.Data Namespace


Database Methods

[image] [image]

Sitecore 6.4.1 API
Database Methods
Database Class See Also Send Feedback

The Database type exposes the following members.

Methods

 | Name | Description
Public method | CleanupDatabase | Cleans up the database. Note: Make sure that the database has been backed up before calling this method. It may delete a lot of data.
Public method | CreateItemPath(String) | Creates a path of items.
Public method | CreateItemPath(String, TemplateItem) | Creates a path of items.
Public method | CreateItemPath(String, TemplateItem, TemplateItem) | Creates a path of items.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDatabase | Connects to the specified database.
Public method | GetDataProviders | Gets the data providers.
Public method | GetDataSize | Gets the size of the data contained in the database.
 | GetDataSizes | Gets the data sizes of all databases.
Public method | GetDictionaryEntryCount | Gets the number of dictionary entries stored in the database.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItem(String) | Gets an item from a path.
Public method | GetItem(DataUri) | Gets the item.
Public method | GetItem(ID) | Gets an item from a path.
 | GetItem(ItemUri) | Gets an item from an Item URI.
Public method | GetItem(String, Language) | Gets an item from a path.
Public method | GetItem(ID, Language) | Gets an item from a path.
Public method | GetItem(String, Language, Version) | Gets an item from a path.
Public method | GetItem(ID, Language, Version) | Gets an item from a path.
Public method | GetLanguages | Gets the languages defined in the database.
Public method | GetRootItem()()()() | Gets the root item of the database.
Public method | GetRootItem(Language) | Gets the root item of a database.
Public method | GetSearcher | Gets an Index searcher for the database.
Public method | GetTemplate(String) | Gets the template.
Public method | GetTemplate(ID) | Gets the template.
 | GetTotalDataSize | Gets the total size of the data.
 | GetTotalDictionaryEntryCount | Gets the total number of dictionary entries in all databases.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnConstructed | Called when database object has been constructed by the factory.
Public method | SelectItems | Performs a Sitecore Xpath query in the database.
Public method | SelectItemsUsingXPath | Selects the items using Xpath.
Public method | SelectSingleItem | Performs a Sitecore Xpath query in the database.
Public method | SelectSingleItemUsingXPath | Selects the single item using Xpath.
Public method | ToString | Gets the name of the database. (Overrides Object..::..ToString()()()().)

Extension Methods

 | Name | Description
Public Extension Method | GetKnownItem | Gets the known item. (Defined by DatabaseExtensions.)
Public Extension Method | GetKnownItemId | Gets the leftmost part of a string. (Defined by DatabaseExtensions.)

See Also

Database Class
Sitecore.Data Namespace


CleanupDatabase Method

[image]

Sitecore 6.4.1 API
Database..::..CleanupDatabase Method
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool CleanupDatabase()
Visual Basic
Public Function CleanupDatabase As Boolean
Visual C++
public:
bool CleanupDatabase()

Return Value

true if cleanup was performed; false otherwise.

Remarks

Typically, a cleanup operation will remove data in invalid languages and items in orphaned trees.

Specific operations depends on the actual data provider implementation.

See Also

Database Class
Sitecore.Data Namespace


CreateItemPath Method

[image] [image]

Sitecore 6.4.1 API
Database..::..CreateItemPath Method
Database Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateItemPath(String) | Creates a path of items.
Public method | CreateItemPath(String, TemplateItem) | Creates a path of items.
Public method | CreateItemPath(String, TemplateItem, TemplateItem) | Creates a path of items.

See Also

Database Class
Database Members
Sitecore.Data Namespace


CreateItemPath Method (String, TemplateItem)

[image]

Sitecore 6.4.1 API
Database..::..CreateItemPath Method (String, TemplateItem)
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item CreateItemPath(
    string path,
    TemplateItem template
)
Visual Basic
Public Function CreateItemPath ( _
    path As String, _
    template As TemplateItem _
) As Item
Visual C++
public:
Item^ CreateItemPath(
    String^ path,
    TemplateItem^ template
)

Parameters

path
Type: System..::..String
Path that must exist in the database.
template
Type: Sitecore.Data.Items..::..TemplateItem
Name or ID of template to use when creating new items.

Return Value

The item corresponding to the last element in the path. E.g. the "deepest" item.

Remarks

Use this method to ensure that a specific path of items exist in the database.

For each element in the path it is checked if an item matching the element exists. If it does not, a new item is created with the proper name.

The new items are created from the template specified in template

See Also

Database Class
CreateItemPath Overload
Sitecore.Data Namespace


CreateItemPath Method (String, TemplateItem, TemplateItem)

[image]

Sitecore 6.4.1 API
Database..::..CreateItemPath Method (String, TemplateItem, TemplateItem)
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item CreateItemPath(
    string path,
    TemplateItem folderTemplate,
    TemplateItem itemTemplate
)
Visual Basic
Public Function CreateItemPath ( _
    path As String, _
    folderTemplate As TemplateItem, _
    itemTemplate As TemplateItem _
) As Item
Visual C++
public:
Item^ CreateItemPath(
    String^ path,
    TemplateItem^ folderTemplate,
    TemplateItem^ itemTemplate
)

Parameters

path
Type: System..::..String
Path that must exist in the database
folderTemplate
Type: Sitecore.Data.Items..::..TemplateItem
Name or ID of template to use when creating folder items (all items except last).
itemTemplate
Type: Sitecore.Data.Items..::..TemplateItem
Name or ID of template to use when creating final item in path.

Return Value

The item corresponding to the last element in the path. I.e. the "deepest" item.

Remarks

Use this method to ensure that a specific path of items exist in the database.

For each element in the path it is checked if an item matching the element exists. If it does not, a new item is created with the proper name.

The new items are created from the template specified in itemTemplate

See Also

Database Class
CreateItemPath Overload
Sitecore.Data Namespace


GetDataProviders Method

[image]

Sitecore 6.4.1 API
Database..::..GetDataProviders Method
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataProvider[] GetDataProviders()
Visual Basic
Public Function GetDataProviders As DataProvider()
Visual C++
public:
array<DataProvider^>^ GetDataProviders()

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Database.GetDataProviders"]

See Also

Database Class
Sitecore.Data Namespace


GetDataSize Method

[image]

Sitecore 6.4.1 API
Database..::..GetDataSize Method
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long GetDataSize(
    int minEntitySize,
    int maxEntitySize
)
Visual Basic
Public Function GetDataSize ( _
    minEntitySize As Integer, _
    maxEntitySize As Integer _
) As Long
Visual C++
public:
long long GetDataSize(
    int minEntitySize,
    int maxEntitySize
)

Parameters

minEntitySize
Type: System..::..Int32
Minimum size of an entity.
maxEntitySize
Type: System..::..Int32
Maximum size of an entity.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Database.GetDataSize(System.Int32,System.Int32)"]

See Also

Database Class
Sitecore.Data Namespace


GetDataSizes Method

[image]

Sitecore 6.4.1 API
Database..::..GetDataSizes Method
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static SafeDictionary<Database, long> GetDataSizes(
    int minEntitySize,
    int maxEntitySize
)
Visual Basic
Public Shared Function GetDataSizes ( _
    minEntitySize As Integer, _
    maxEntitySize As Integer _
) As SafeDictionary(Of Database, Long)
Visual C++
public:
static SafeDictionary<Database^, long long>^ GetDataSizes(
    int minEntitySize,
    int maxEntitySize
)

Parameters

minEntitySize
Type: System..::..Int32
Minimum size of an entity.
maxEntitySize
Type: System..::..Int32
Maximum size of an entity.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Database.GetDataSizes(System.Int32,System.Int32)"]

See Also

Database Class
Sitecore.Data Namespace


GetDictionaryEntryCount Method

[image]

Sitecore 6.4.1 API
Database..::..GetDictionaryEntryCount Method
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long GetDictionaryEntryCount()
Visual Basic
Public Function GetDictionaryEntryCount As Long
Visual C++
public:
long long GetDictionaryEntryCount()

Return Value

The number of dictionary entries stored in the database.

See Also

Database Class
Sitecore.Data Namespace


GetItem Method

[image] [image]

Sitecore 6.4.1 API
Database..::..GetItem Method
Database Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetItem(String) | Gets an item from a path.
Public method | GetItem(DataUri) | Gets the item.
Public method | GetItem(ID) | Gets an item from a path.
 | GetItem(ItemUri) | Gets an item from an Item URI.
Public method | GetItem(String, Language) | Gets an item from a path.
Public method | GetItem(ID, Language) | Gets an item from a path.
Public method | GetItem(String, Language, Version) | Gets an item from a path.
Public method | GetItem(ID, Language, Version) | Gets an item from a path.

See Also

Database Class
Database Members
Sitecore.Data Namespace


GetItem Method (String)

[image]

Sitecore 6.4.1 API
Database..::..GetItem Method (String)
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetItem(
    string path
)
Visual Basic
Public Function GetItem ( _
    path As String _
) As Item
Visual C++
public:
Item^ GetItem(
    String^ path
)

Parameters

path
Type: System..::..String
The path.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Database.GetItem(System.String)"]

See Also

Database Class
GetItem Overload
Sitecore.Data Namespace


GetItem Method (DataUri)

[image]

Sitecore 6.4.1 API
Database..::..GetItem Method (DataUri)
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetItem(
    DataUri uri
)
Visual Basic
Public Function GetItem ( _
    uri As DataUri _
) As Item
Visual C++
public:
Item^ GetItem(
    DataUri^ uri
)

Parameters

uri
Type: Sitecore.Data..::..DataUri
The URI.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Database.GetItem(Sitecore.Data.DataUri)"]

See Also

Database Class
GetItem Overload
Sitecore.Data Namespace


GetItem Method (ID)

[image]

Sitecore 6.4.1 API
Database..::..GetItem Method (ID)
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetItem(
    ID itemId
)
Visual Basic
Public Function GetItem ( _
    itemId As ID _
) As Item
Visual C++
public:
Item^ GetItem(
    ID^ itemId
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Database.GetItem(Sitecore.Data.ID)"]

See Also

Database Class
GetItem Overload
Sitecore.Data Namespace


GetItem Method (ItemUri)

[image]

Sitecore 6.4.1 API
Database..::..GetItem Method (ItemUri)
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item GetItem(
    ItemUri uri
)
Visual Basic
Public Shared Function GetItem ( _
    uri As ItemUri _
) As Item
Visual C++
public:
static Item^ GetItem(
    ItemUri^ uri
)

Parameters

uri
Type: Sitecore.Data..::..ItemUri
The URI.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Database.GetItem(Sitecore.Data.ItemUri)"]

See Also

Database Class
GetItem Overload
Sitecore.Data Namespace


GetItem Method (String, Language)

[image]

Sitecore 6.4.1 API
Database..::..GetItem Method (String, Language)
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetItem(
    string path,
    Language language
)
Visual Basic
Public Function GetItem ( _
    path As String, _
    language As Language _
) As Item
Visual C++
public:
Item^ GetItem(
    String^ path,
    Language^ language
)

Parameters

path
Type: System..::..String
The path.
language
Type: Sitecore.Globalization..::..Language
The language.

Return Value

The item.

See Also

Database Class
GetItem Overload
Sitecore.Data Namespace


GetItem Method (ID, Language)

[image]

Sitecore 6.4.1 API
Database..::..GetItem Method (ID, Language)
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetItem(
    ID itemId,
    Language language
)
Visual Basic
Public Function GetItem ( _
    itemId As ID, _
    language As Language _
) As Item
Visual C++
public:
Item^ GetItem(
    ID^ itemId,
    Language^ language
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
language
Type: Sitecore.Globalization..::..Language
The language.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Database.GetItem(Sitecore.Data.ID,Sitecore.Globalization.Language)"]

See Also

Database Class
GetItem Overload
Sitecore.Data Namespace


GetItem Method (String, Language, Version)

[image]

Sitecore 6.4.1 API
Database..::..GetItem Method (String, Language, Version)
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetItem(
    string path,
    Language language,
    Version version
)
Visual Basic
Public Function GetItem ( _
    path As String, _
    language As Language, _
    version As Version _
) As Item
Visual C++
public:
Item^ GetItem(
    String^ path,
    Language^ language,
    Version^ version
)

Parameters

path
Type: System..::..String
The path.
language
Type: Sitecore.Globalization..::..Language
The language.
version
Type: Sitecore.Data..::..Version
The version.

Return Value

The item.

See Also

Database Class
GetItem Overload
Sitecore.Data Namespace


GetItem Method (ID, Language, Version)

[image]

Sitecore 6.4.1 API
Database..::..GetItem Method (ID, Language, Version)
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetItem(
    ID itemId,
    Language language,
    Version version
)
Visual Basic
Public Function GetItem ( _
    itemId As ID, _
    language As Language, _
    version As Version _
) As Item
Visual C++
public:
Item^ GetItem(
    ID^ itemId,
    Language^ language,
    Version^ version
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
language
Type: Sitecore.Globalization..::..Language
The language.
version
Type: Sitecore.Data..::..Version
The version.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Database.GetItem(Sitecore.Data.ID,Sitecore.Globalization.Language,Sitecore.Data.Version)"]

See Also

Database Class
GetItem Overload
Sitecore.Data Namespace


GetLanguages Method

[image]

Sitecore 6.4.1 API
Database..::..GetLanguages Method
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LanguageCollection GetLanguages()
Visual Basic
Public Function GetLanguages As LanguageCollection
Visual C++
public:
LanguageCollection^ GetLanguages()

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Database.GetLanguages"]

See Also

Database Class
Sitecore.Data Namespace


GetRootItem Method

[image] [image]

Sitecore 6.4.1 API
Database..::..GetRootItem Method
Database Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRootItem()()()() | Gets the root item of the database.
Public method | GetRootItem(Language) | Gets the root item of a database.

See Also

Database Class
Database Members
Sitecore.Data Namespace


GetRootItem Method

[image]

Sitecore 6.4.1 API
Database..::..GetRootItem Method
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetRootItem()
Visual Basic
Public Function GetRootItem As Item
Visual C++
public:
Item^ GetRootItem()

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Database.GetRootItem"]

See Also

Database Class
GetRootItem Overload
Sitecore.Data Namespace


GetRootItem Method (Language)

[image]

Sitecore 6.4.1 API
Database..::..GetRootItem Method (Language)
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetRootItem(
    Language language
)
Visual Basic
Public Function GetRootItem ( _
    language As Language _
) As Item
Visual C++
public:
Item^ GetRootItem(
    Language^ language
)

Parameters

language
Type: Sitecore.Globalization..::..Language
The language.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Database.GetRootItem(Sitecore.Globalization.Language)"]

See Also

Database Class
GetRootItem Overload
Sitecore.Data Namespace


GetSearcher Method

[image]

Sitecore 6.4.1 API
Database..::..GetSearcher Method
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IndexSearcher GetSearcher(
    string name
)
Visual Basic
Public Function GetSearcher ( _
    name As String _
) As IndexSearcher
Visual C++
public:
IndexSearcher^ GetSearcher(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Database.GetSearcher(System.String)"]

See Also

Database Class
Sitecore.Data Namespace


GetTemplate Method

[image] [image]

Sitecore 6.4.1 API
Database..::..GetTemplate Method
Database Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTemplate(String) | Gets the template.
Public method | GetTemplate(ID) | Gets the template.

See Also

Database Class
Database Members
Sitecore.Data Namespace


GetTemplate Method (String)

[image]

Sitecore 6.4.1 API
Database..::..GetTemplate Method (String)
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateItem GetTemplate(
    string fullName
)
Visual Basic
Public Function GetTemplate ( _
    fullName As String _
) As TemplateItem
Visual C++
public:
TemplateItem^ GetTemplate(
    String^ fullName
)

Parameters

fullName
Type: System..::..String
The full name.

Return Value

The template.

See Also

Database Class
GetTemplate Overload
Sitecore.Data Namespace


GetTemplate Method (ID)

[image]

Sitecore 6.4.1 API
Database..::..GetTemplate Method (ID)
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateItem GetTemplate(
    ID templateId
)
Visual Basic
Public Function GetTemplate ( _
    templateId As ID _
) As TemplateItem
Visual C++
public:
TemplateItem^ GetTemplate(
    ID^ templateId
)

Parameters

templateId
Type: Sitecore.Data..::..ID
The template id.

Return Value

The template.

See Also

Database Class
GetTemplate Overload
Sitecore.Data Namespace


GetTotalDataSize Method

[image]

Sitecore 6.4.1 API
Database..::..GetTotalDataSize Method
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long GetTotalDataSize(
    int minEntitySize,
    int maxEntitySize
)
Visual Basic
Public Shared Function GetTotalDataSize ( _
    minEntitySize As Integer, _
    maxEntitySize As Integer _
) As Long
Visual C++
public:
static long long GetTotalDataSize(
    int minEntitySize,
    int maxEntitySize
)

Parameters

minEntitySize
Type: System..::..Int32
Minimum size of an entity.
maxEntitySize
Type: System..::..Int32
Maximum size of an entity.

Return Value

The total data size.

See Also

Database Class
Sitecore.Data Namespace


OnConstructed Method

[image]

Sitecore 6.4.1 API
Database..::..OnConstructed Method
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void OnConstructed(
    XmlNode configuration
)
Visual Basic
Protected Overridable Sub OnConstructed ( _
    configuration As XmlNode _
)
Visual C++
protected:
virtual void OnConstructed(
    XmlNode^ configuration
)

Parameters

configuration
Type: System.Xml..::..XmlNode
The configuration.

See Also

Database Class
Sitecore.Data Namespace


SelectItems Method

[image]

Sitecore 6.4.1 API
Database..::..SelectItems Method
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item[] SelectItems(
    string query
)
Visual Basic
Public Function SelectItems ( _
    query As String _
) As Item()
Visual C++
public:
array<Item^>^ SelectItems(
    String^ query
)

Parameters

query
Type: System..::..String
The query.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Database.SelectItems(System.String)"]

See Also

Database Class
Sitecore.Data Namespace


SelectItemsUsingXPath Method

[image]

Sitecore 6.4.1 API
Database..::..SelectItemsUsingXPath Method
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemList SelectItemsUsingXPath(
    string query
)
Visual Basic
Public Function SelectItemsUsingXPath ( _
    query As String _
) As ItemList
Visual C++
public:
ItemList^ SelectItemsUsingXPath(
    String^ query
)

Parameters

query
Type: System..::..String
The query.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Database.SelectItemsUsingXPath(System.String)"]

See Also

Database Class
Sitecore.Data Namespace


SelectSingleItem Method

[image]

Sitecore 6.4.1 API
Database..::..SelectSingleItem Method
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item SelectSingleItem(
    string query
)
Visual Basic
Public Function SelectSingleItem ( _
    query As String _
) As Item
Visual C++
public:
Item^ SelectSingleItem(
    String^ query
)

Parameters

query
Type: System..::..String
The query.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Database.SelectSingleItem(System.String)"]

See Also

Database Class
Sitecore.Data Namespace


SelectSingleItemUsingXPath Method

[image]

Sitecore 6.4.1 API
Database..::..SelectSingleItemUsingXPath Method
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item SelectSingleItemUsingXPath(
    string query
)
Visual Basic
Public Function SelectSingleItemUsingXPath ( _
    query As String _
) As Item
Visual C++
public:
Item^ SelectSingleItemUsingXPath(
    String^ query
)

Parameters

query
Type: System..::..String
The query.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Database.SelectSingleItemUsingXPath(System.String)"]

See Also

Database Class
Sitecore.Data Namespace


ToString Method

[image]

Sitecore 6.4.1 API
Database..::..ToString Method
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

Database Class
Sitecore.Data Namespace


Database Properties

[image] [image]

Sitecore 6.4.1 API
Database Properties
Database Class See Also Send Feedback

The Database type exposes the following members.

Properties

 | Name | Description
Public property | Aliases | Gets the alias resolver object.
Public property | ArchiveNames | Provides access to the names of the Archives associated with the database.
Public property | Archives | Provides access to the Archives associated with the database.
Public property | Branches | Provides access to the branches in the database.
Public property | Caches | Gets the caches.
Public property | ConnectionStringName | Gets or sets the name of the connection string used by archives etc..
Public property | DataManager | Gets the database manager object that provides low-level access to a DataSource.
Protected property | DataProviders | Gets the data providers.
Public property | Engines | Gets the engines.
Public property | HasContentItem | Gets a value that indicates is the /sitecore/content item is present.
Public property | Icon | Gets or sets the icon.
Public property | Indexes | Provides access to the Indexes associated with the database.
Public property | Items | Provides access to the items in the database.
Public property | Languages | Provides access to the languages in the database.
Public property | Masters | Obsolete. Provides access to the masters in the database.
Public property | Name | Gets the name of the database.
Public property | NotificationProvider | Gets or sets the notification provider.
Public property | Properties | Provides access to the database properties.
Public property | Protected | Gets or sets a value indicating whether this database should be protected.
Public property | ProxiesEnabled | Gets or sets a value that indicates if proxy items are enabled.
Public property | ProxyDataProvider | Gets or sets the proxy data provider.
Public property | PublishVirtualItems | Gets or sets a value that indicates whether virtual items will be published.
Public property | ReadOnly | Gets or sets a value that indicates if the database is read-only.
Public property | RemoteEvents | Gets or sets the remote events.
Public property | Resources | Gets the resources.
Public property | SecurityEnabled | Gets a value that indicates if security is enforced when accessing items.
Public property | SitecoreItem | Gets the sitecore item.
Public property | Templates | Provides access to the Templates in the database.
Public property | WorkflowProvider | Gets the workflow associated with the database.

See Also

Database Class
Sitecore.Data Namespace


Aliases Property

[image]

Sitecore 6.4.1 API
Database..::..Aliases Property
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AliasResolver Aliases { get; }
Visual Basic
Public ReadOnly Property Aliases As AliasResolver
    Get
Visual C++
public:
property AliasResolver^ Aliases {
    AliasResolver^ get ();
}

Field Value

The aliases.

See Also

Database Class
Sitecore.Data Namespace


ArchiveNames Property

[image]

Sitecore 6.4.1 API
Database..::..ArchiveNames Property
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public List<string> ArchiveNames { get; }
Visual Basic
Public ReadOnly Property ArchiveNames As List(Of String)
    Get
Visual C++
public:
property List<String^>^ ArchiveNames {
    List<String^>^ get ();
}

Field Value

The archives.

See Also

Database Class
Sitecore.Data Namespace


Archives Property

[image]

Sitecore 6.4.1 API
Database..::..Archives Property
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataArchives Archives { get; }
Visual Basic
Public ReadOnly Property Archives As DataArchives
    Get
Visual C++
public:
property DataArchives^ Archives {
    DataArchives^ get ();
}

Field Value

The archives.

See Also

Database Class
Sitecore.Data Namespace


Branches Property

[image]

Sitecore 6.4.1 API
Database..::..Branches Property
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BranchRecords Branches { get; }
Visual Basic
Public ReadOnly Property Branches As BranchRecords
    Get
Visual C++
public:
property BranchRecords^ Branches {
    BranchRecords^ get ();
}

Field Value

The branches.

See Also

Database Class
Sitecore.Data Namespace


Caches Property

[image]

Sitecore 6.4.1 API
Database..::..Caches Property
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DatabaseCaches Caches { get; }
Visual Basic
Public ReadOnly Property Caches As DatabaseCaches
    Get
Visual C++
public:
property DatabaseCaches^ Caches {
    DatabaseCaches^ get ();
}

Field Value

The caches.

See Also

Database Class
Sitecore.Data Namespace


ConnectionStringName Property

[image]

Sitecore 6.4.1 API
Database..::..ConnectionStringName Property
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ConnectionStringName { get; set; }
Visual Basic
Public Property ConnectionStringName As String
    Get
    Set
Visual C++
public:
property String^ ConnectionStringName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the connection string.

See Also

Database Class
Sitecore.Data Namespace


DataManager Property

[image]

Sitecore 6.4.1 API
Database..::..DataManager Property
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataManager DataManager { get; }
Visual Basic
Public ReadOnly Property DataManager As DataManager
    Get
Visual C++
public:
property DataManager^ DataManager {
    DataManager^ get ();
}

Field Value

The data manager.

Remarks

The DataManager object provides a low-level access to a DataSource.

See Also

Database Class
Sitecore.Data Namespace


DataProviders Property

[image]

Sitecore 6.4.1 API
Database..::..DataProviders Property
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected internal DataProviderCollection DataProviders { get; }
Visual Basic
Protected Friend ReadOnly Property DataProviders As DataProviderCollection
    Get
Visual C++
protected public:
property DataProviderCollection^ DataProviders {
    DataProviderCollection^ get ();
}

Field Value

The data providers.

See Also

Database Class
Sitecore.Data Namespace


Engines Property

[image]

Sitecore 6.4.1 API
Database..::..Engines Property
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DatabaseEngines Engines { get; }
Visual Basic
Public ReadOnly Property Engines As DatabaseEngines
    Get
Visual C++
public:
property DatabaseEngines^ Engines {
    DatabaseEngines^ get ();
}

Field Value

The engines.

See Also

Database Class
Sitecore.Data Namespace


HasContentItem Property

[image]

Sitecore 6.4.1 API
Database..::..HasContentItem Property
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool HasContentItem { get; }
Visual Basic
Public ReadOnly Property HasContentItem As Boolean
    Get
Visual C++
public:
property bool HasContentItem {
    bool get ();
}

Field Value

true if this instance has content item; otherwise, false.

Remarks

Some database does not contain the /sitecore/content item which indicates that this is a special database. The Security and Extranet databases are examples of this.

See Also

Database Class
Sitecore.Data Namespace


Icon Property

[image]

Sitecore 6.4.1 API
Database..::..Icon Property
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Icon { get; set; }
Visual Basic
Public Property Icon As String
    Get
    Set
Visual C++
public:
property String^ Icon {
    String^ get ();
    void set (String^ value);
}

Field Value

The icon.

See Also

Database Class
Sitecore.Data Namespace


Indexes Property

[image]

Sitecore 6.4.1 API
Database..::..Indexes Property
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataIndexes Indexes { get; }
Visual Basic
Public ReadOnly Property Indexes As DataIndexes
    Get
Visual C++
public:
property DataIndexes^ Indexes {
    DataIndexes^ get ();
}

Field Value

The indexes.

See Also

Database Class
Sitecore.Data Namespace


Items Property

[image]

Sitecore 6.4.1 API
Database..::..Items Property
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemRecords Items { get; }
Visual Basic
Public ReadOnly Property Items As ItemRecords
    Get
Visual C++
public:
property ItemRecords^ Items {
    ItemRecords^ get ();
}

Field Value

The items.

See Also

Database Class
Sitecore.Data Namespace


Languages Property

[image]

Sitecore 6.4.1 API
Database..::..Languages Property
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Language[] Languages { get; }
Visual Basic
Public ReadOnly Property Languages As Language()
    Get
Visual C++
public:
property array<Language^>^ Languages {
    array<Language^>^ get ();
}

Field Value

The languages.

See Also

Database Class
Sitecore.Data Namespace


Masters Property

[image]

Sitecore 6.4.1 API
Database..::..Masters Property
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use Branches instead.")]
public BranchRecords Masters { get; }
Visual Basic
<ObsoleteAttribute("Deprecated - Use Branches instead.")> _
Public ReadOnly Property Masters As BranchRecords
    Get
Visual C++
[ObsoleteAttribute(L"Deprecated - Use Branches instead.")]
public:
property BranchRecords^ Masters {
    BranchRecords^ get ();
}

Field Value

The masters.

See Also

Database Class
Sitecore.Data Namespace


Name Property

[image]

Sitecore 6.4.1 API
Database..::..Name Property
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

Database Class
Sitecore.Data Namespace


NotificationProvider Property

[image]

Sitecore 6.4.1 API
Database..::..NotificationProvider Property
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public NotificationProvider NotificationProvider { get; set; }
Visual Basic
Public Property NotificationProvider As NotificationProvider
    Get
    Set
Visual C++
public:
property NotificationProvider^ NotificationProvider {
    NotificationProvider^ get ();
    void set (NotificationProvider^ value);
}

Field Value

The notification provider.

See Also

Database Class
Sitecore.Data Namespace


Properties Property

[image]

Sitecore 6.4.1 API
Database..::..Properties Property
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DatabaseProperties Properties { get; }
Visual Basic
Public ReadOnly Property Properties As DatabaseProperties
    Get
Visual C++
public:
property DatabaseProperties^ Properties {
    DatabaseProperties^ get ();
}

Field Value

The properties.

Remarks

Database properties are meta data that describe the database, e.g. the version number of the database.

Properties can freely be added to the database.

See Also

Database Class
Sitecore.Data Namespace


Protected Property

[image]

Sitecore 6.4.1 API
Database..::..Protected Property
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Protected { get; set; }
Visual Basic
Public Property Protected As Boolean
    Get
    Set
Visual C++
public:
property bool Protected {
    bool get ();
    void set (bool value);
}

Field Value

true if this database should be protected; otherwise, false.

Remarks

This property might be used by client applications to limit access to certain databases.

For instance, a protected database can not be used as a content database unless the current user is an administrator.

See Also

Database Class
Sitecore.Data Namespace


ProxiesEnabled Property

[image]

Sitecore 6.4.1 API
Database..::..ProxiesEnabled Property
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ProxiesEnabled { get; set; }
Visual Basic
Public Property ProxiesEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool ProxiesEnabled {
    bool get ();
    void set (bool value);
}

Field Value

true if the Database has proxies enabled; otherwise, false.

See Also

Database Class
Sitecore.Data Namespace


ProxyDataProvider Property

[image]

Sitecore 6.4.1 API
Database..::..ProxyDataProvider Property
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ProxyDataProvider ProxyDataProvider { get; set; }
Visual Basic
Public Property ProxyDataProvider As ProxyDataProvider
    Get
    Set
Visual C++
public:
property ProxyDataProvider^ ProxyDataProvider {
    ProxyDataProvider^ get ();
    void set (ProxyDataProvider^ value);
}

Field Value

The proxy data provider.

See Also

Database Class
Sitecore.Data Namespace


PublishVirtualItems Property

[image]

Sitecore 6.4.1 API
Database..::..PublishVirtualItems Property
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool PublishVirtualItems { get; set; }
Visual Basic
Public Property PublishVirtualItems As Boolean
    Get
    Set
Visual C++
public:
property bool PublishVirtualItems {
    bool get ();
    void set (bool value);
}

Remarks

When this setting is false, only the proxy definitions will be published. Therefore proxy support must be enabled on the web database.

When true, virtual items will be published as if they were real items. Therefore, proxy support should not be enabled on the web site.

The default value is false, meaning that only proxy definitions are published.

See Also

Database Class
Sitecore.Data Namespace


ReadOnly Property

[image]

Sitecore 6.4.1 API
Database..::..ReadOnly Property
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ReadOnly { get; set; }
Visual Basic
Public Property ReadOnly As Boolean
    Get
    Set
Visual C++
public:
property bool ReadOnly {
    bool get ();
    void set (bool value);
}

Field Value

true if the Database is read-only; otherwise, false.

See Also

Database Class
Sitecore.Data Namespace


RemoteEvents Property

[image]

Sitecore 6.4.1 API
Database..::..RemoteEvents Property
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DatabaseRemoteEvents RemoteEvents { get; }
Visual Basic
Public ReadOnly Property RemoteEvents As DatabaseRemoteEvents
    Get
Visual C++
public:
property DatabaseRemoteEvents^ RemoteEvents {
    DatabaseRemoteEvents^ get ();
}

Field Value

The remote events.

See Also

Database Class
Sitecore.Data Namespace


Resources Property

[image]

Sitecore 6.4.1 API
Database..::..Resources Property
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ResourceItems Resources { get; }
Visual Basic
Public ReadOnly Property Resources As ResourceItems
    Get
Visual C++
public:
property ResourceItems^ Resources {
    ResourceItems^ get ();
}

Field Value

The resources.

See Also

Database Class
Sitecore.Data Namespace


SecurityEnabled Property

[image]

Sitecore 6.4.1 API
Database..::..SecurityEnabled Property
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool SecurityEnabled { get; set; }
Visual Basic
Public Property SecurityEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool SecurityEnabled {
    bool get ();
    void set (bool value);
}

Field Value

true if the Database has security enabled; otherwise, false.

See Also

Database Class
Sitecore.Data Namespace


SitecoreItem Property

[image]

Sitecore 6.4.1 API
Database..::..SitecoreItem Property
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item SitecoreItem { get; }
Visual Basic
Public ReadOnly Property SitecoreItem As Item
    Get
Visual C++
public:
property Item^ SitecoreItem {
    Item^ get ();
}

Field Value

The sitecore item.

See Also

Database Class
Sitecore.Data Namespace


WorkflowProvider Property

[image]

Sitecore 6.4.1 API
Database..::..WorkflowProvider Property
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IWorkflowProvider WorkflowProvider { get; set; }
Visual Basic
Public Property WorkflowProvider As IWorkflowProvider
    Get
    Set
Visual C++
public:
property IWorkflowProvider^ WorkflowProvider {
    IWorkflowProvider^ get ();
    void set (IWorkflowProvider^ value);
}

Field Value

The workflow provider.

See Also

Database Class
Sitecore.Data Namespace


Database Events

[image] [image]

Sitecore 6.4.1 API
Database Events
Database Class See Also Send Feedback

The Database type exposes the following members.

Events

 | Name | Description
Public event | Constructed |
 | InstanceCreated |

See Also

Database Class
Sitecore.Data Namespace


Constructed Event

[image]

Sitecore 6.4.1 API
Database..::..Constructed Event
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler<ConstructedEventArgs> Constructed
Visual Basic
Public Event Constructed As EventHandler(Of ConstructedEventArgs)
Visual C++
public:
 event EventHandler<ConstructedEventArgs^>^ Constructed {
    void add (EventHandler<ConstructedEventArgs^>^ value);
    void remove (EventHandler<ConstructedEventArgs^>^ value);
}

See Also

Database Class
Sitecore.Data Namespace


InstanceCreated Event

[image]

Sitecore 6.4.1 API
Database..::..InstanceCreated Event
Database Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static event EventHandler<InstanceCreatedEventArgs> InstanceCreated
Visual Basic
Public Shared Event InstanceCreated As EventHandler(Of InstanceCreatedEventArgs)
Visual C++
public:
static  event EventHandler<InstanceCreatedEventArgs^>^ InstanceCreated {
    void add (EventHandler<InstanceCreatedEventArgs^>^ value);
    void remove (EventHandler<InstanceCreatedEventArgs^>^ value);
}

See Also

Database Class
Sitecore.Data Namespace


Database.DataRecords Class

[image]

Sitecore 6.4.1 API
Database..::..DataRecords Class
Database Class Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DataRecords
Visual Basic
Public Class DataRecords
Visual C++
public ref class DataRecords

Inheritance Hierarchy

System..::..Object
Sitecore.Data..::..Database..::..DataRecords
Sitecore.Data..::..BranchRecords
Sitecore.Data..::..DeviceRecords
Sitecore.Data..::..ItemRecords
Sitecore.Data..::..LayoutRecords
Sitecore.Data..::..RenderingRecords
Sitecore.Data..::..SublayoutRecords

See Also

Database..::..DataRecords Members
Sitecore.Data Namespace


Database.DataRecords Members

[image] [image]

Sitecore 6.4.1 API
Database..::..DataRecords Members
Database..::..DataRecords Class Constructors Methods Properties See Also Send Feedback

Represents a database.
Represents a database.

The Database..::..DataRecords type exposes the following members.

Constructors

 | Name | Description
Public method | Database..::..DataRecords(Database) | Initializes a new instance of the Database..::..DataRecords class.
Public method | Database..::..DataRecords(Database, String) | Initializes a new instance of the Database..::..DataRecords class.

Methods

 | Name | Description
Protected method | DoGetItem(String) | Gets the item.
Protected method | DoGetItem(DataUri) | Gets the item.
Protected method | DoGetItem(ID) | Gets the item.
Protected method | DoGetItem(String, Language) | Gets the item.
Protected method | DoGetItem(ID, Language) | Gets the item.
Protected method | DoGetItem(String, Language, Version) | Gets the item.
Protected method | DoGetItem(ID, Language, Version) | Gets the item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists(DataUri) | Gets a value that indicates if the data URI exists in the database.
Public method | Exists(ID) | Gets a value that indicates if the item ID exists in the database.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniquePath | Gets a unique path of an item in the database.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BasePath | Gets the base path.
Public property | Database | Gets the database.

See Also

Database..::..DataRecords Class
Sitecore.Data Namespace


Database.DataRecords Constructor

[image] [image]

Sitecore 6.4.1 API
Database..::..DataRecords Constructor
Database..::..DataRecords Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Database..::..DataRecords(Database) | Initializes a new instance of the Database..::..DataRecords class.
Public method | Database..::..DataRecords(Database, String) | Initializes a new instance of the Database..::..DataRecords class.

See Also

Database..::..DataRecords Class
Database..::..DataRecords Members
Sitecore.Data Namespace


Database.DataRecords Constructor (Database)

[image]

Sitecore 6.4.1 API
Database..::..DataRecords Constructor (Database)
Database..::..DataRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataRecords(
    Database database
)
Visual Basic
Public Sub New ( _
    database As Database _
)
Visual C++
public:
DataRecords(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

See Also

Database..::..DataRecords Class
Database..::..DataRecords Overload
Sitecore.Data Namespace


Database.DataRecords Constructor (Database, String)

[image]

Sitecore 6.4.1 API
Database..::..DataRecords Constructor (Database, String)
Database..::..DataRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataRecords(
    Database database,
    string basePath
)
Visual Basic
Public Sub New ( _
    database As Database, _
    basePath As String _
)
Visual C++
public:
DataRecords(
    Database^ database,
    String^ basePath
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.
basePath
Type: System..::..String
The base path.

See Also

Database..::..DataRecords Class
Database..::..DataRecords Overload
Sitecore.Data Namespace


Database.DataRecords Methods

[image] [image]

Sitecore 6.4.1 API
Database..::..DataRecords Methods
Database..::..DataRecords Class See Also Send Feedback

The Database..::..DataRecords type exposes the following members.

Methods

 | Name | Description
Protected method | DoGetItem(String) | Gets the item.
Protected method | DoGetItem(DataUri) | Gets the item.
Protected method | DoGetItem(ID) | Gets the item.
Protected method | DoGetItem(String, Language) | Gets the item.
Protected method | DoGetItem(ID, Language) | Gets the item.
Protected method | DoGetItem(String, Language, Version) | Gets the item.
Protected method | DoGetItem(ID, Language, Version) | Gets the item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists(DataUri) | Gets a value that indicates if the data URI exists in the database.
Public method | Exists(ID) | Gets a value that indicates if the item ID exists in the database.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniquePath | Gets a unique path of an item in the database.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Database..::..DataRecords Class
Sitecore.Data Namespace


DoGetItem Method

[image] [image]

Sitecore 6.4.1 API
Database..::..DataRecords..::..DoGetItem Method
Database..::..DataRecords Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | DoGetItem(String) | Gets the item.
Protected method | DoGetItem(DataUri) | Gets the item.
Protected method | DoGetItem(ID) | Gets the item.
Protected method | DoGetItem(String, Language) | Gets the item.
Protected method | DoGetItem(ID, Language) | Gets the item.
Protected method | DoGetItem(String, Language, Version) | Gets the item.
Protected method | DoGetItem(ID, Language, Version) | Gets the item.

See Also

Database..::..DataRecords Class
Database..::..DataRecords Members
Sitecore.Data Namespace


DoGetItem Method (String)

[image]

Sitecore 6.4.1 API
Database..::..DataRecords..::..DoGetItem Method (String)
Database..::..DataRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual Item DoGetItem(
    string itemPath
)
Visual Basic
Protected Overridable Function DoGetItem ( _
    itemPath As String _
) As Item
Visual C++
protected:
virtual Item^ DoGetItem(
    String^ itemPath
)

Parameters

itemPath
Type: System..::..String
The item path.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Database.DataRecords.DoGetItem(System.String)"]

See Also

Database..::..DataRecords Class
DoGetItem Overload
Sitecore.Data Namespace


DoGetItem Method (DataUri)

[image]

Sitecore 6.4.1 API
Database..::..DataRecords..::..DoGetItem Method (DataUri)
Database..::..DataRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual Item DoGetItem(
    DataUri uri
)
Visual Basic
Protected Overridable Function DoGetItem ( _
    uri As DataUri _
) As Item
Visual C++
protected:
virtual Item^ DoGetItem(
    DataUri^ uri
)

Parameters

uri
Type: Sitecore.Data..::..DataUri
The URI.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Database.DataRecords.DoGetItem(Sitecore.Data.DataUri)"]

See Also

Database..::..DataRecords Class
DoGetItem Overload
Sitecore.Data Namespace


DoGetItem Method (ID)

[image]

Sitecore 6.4.1 API
Database..::..DataRecords..::..DoGetItem Method (ID)
Database..::..DataRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual Item DoGetItem(
    ID itemID
)
Visual Basic
Protected Overridable Function DoGetItem ( _
    itemID As ID _
) As Item
Visual C++
protected:
virtual Item^ DoGetItem(
    ID^ itemID
)

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Database.DataRecords.DoGetItem(Sitecore.Data.ID)"]

See Also

Database..::..DataRecords Class
DoGetItem Overload
Sitecore.Data Namespace


DoGetItem Method (String, Language)

[image]

Sitecore 6.4.1 API
Database..::..DataRecords..::..DoGetItem Method (String, Language)
Database..::..DataRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual Item DoGetItem(
    string itemPath,
    Language language
)
Visual Basic
Protected Overridable Function DoGetItem ( _
    itemPath As String, _
    language As Language _
) As Item
Visual C++
protected:
virtual Item^ DoGetItem(
    String^ itemPath,
    Language^ language
)

Parameters

itemPath
Type: System..::..String
The item path.
language
Type: Sitecore.Globalization..::..Language
The language.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Database.DataRecords.DoGetItem(System.String,Sitecore.Globalization.Language)"]

See Also

Database..::..DataRecords Class
DoGetItem Overload
Sitecore.Data Namespace


DoGetItem Method (ID, Language)

[image]

Sitecore 6.4.1 API
Database..::..DataRecords..::..DoGetItem Method (ID, Language)
Database..::..DataRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual Item DoGetItem(
    ID itemID,
    Language language
)
Visual Basic
Protected Overridable Function DoGetItem ( _
    itemID As ID, _
    language As Language _
) As Item
Visual C++
protected:
virtual Item^ DoGetItem(
    ID^ itemID,
    Language^ language
)

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.
language
Type: Sitecore.Globalization..::..Language
The language.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Database.DataRecords.DoGetItem(Sitecore.Data.ID,Sitecore.Globalization.Language)"]

See Also

Database..::..DataRecords Class
DoGetItem Overload
Sitecore.Data Namespace


DoGetItem Method (String, Language, Version)

[image]

Sitecore 6.4.1 API
Database..::..DataRecords..::..DoGetItem Method (String, Language, Version)
Database..::..DataRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual Item DoGetItem(
    string itemPath,
    Language language,
    Version version
)
Visual Basic
Protected Overridable Function DoGetItem ( _
    itemPath As String, _
    language As Language, _
    version As Version _
) As Item
Visual C++
protected:
virtual Item^ DoGetItem(
    String^ itemPath,
    Language^ language,
    Version^ version
)

Parameters

itemPath
Type: System..::..String
The item path.
language
Type: Sitecore.Globalization..::..Language
The language.
version
Type: Sitecore.Data..::..Version
The version.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Database.DataRecords.DoGetItem(System.String,Sitecore.Globalization.Language,Sitecore.Data.Version)"]

See Also

Database..::..DataRecords Class
DoGetItem Overload
Sitecore.Data Namespace


DoGetItem Method (ID, Language, Version)

[image]

Sitecore 6.4.1 API
Database..::..DataRecords..::..DoGetItem Method (ID, Language, Version)
Database..::..DataRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual Item DoGetItem(
    ID itemID,
    Language language,
    Version version
)
Visual Basic
Protected Overridable Function DoGetItem ( _
    itemID As ID, _
    language As Language, _
    version As Version _
) As Item
Visual C++
protected:
virtual Item^ DoGetItem(
    ID^ itemID,
    Language^ language,
    Version^ version
)

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.
language
Type: Sitecore.Globalization..::..Language
The language.
version
Type: Sitecore.Data..::..Version
The version.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Database.DataRecords.DoGetItem(Sitecore.Data.ID,Sitecore.Globalization.Language,Sitecore.Data.Version)"]

See Also

Database..::..DataRecords Class
DoGetItem Overload
Sitecore.Data Namespace


Exists Method

[image] [image]

Sitecore 6.4.1 API
Database..::..DataRecords..::..Exists Method
Database..::..DataRecords Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Exists(DataUri) | Gets a value that indicates if the data URI exists in the database.
Public method | Exists(ID) | Gets a value that indicates if the item ID exists in the database.

See Also

Database..::..DataRecords Class
Database..::..DataRecords Members
Sitecore.Data Namespace


Exists Method (ID)

[image]

Sitecore 6.4.1 API
Database..::..DataRecords..::..Exists Method (ID)
Database..::..DataRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Exists(
    ID itemID
)
Visual Basic
Public Function Exists ( _
    itemID As ID _
) As Boolean
Visual C++
public:
bool Exists(
    ID^ itemID
)

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Database.DataRecords.Exists(Sitecore.Data.ID)"]

See Also

Database..::..DataRecords Class
Exists Overload
Sitecore.Data Namespace


GetUniquePath Method

[image]

Sitecore 6.4.1 API
Database..::..DataRecords..::..GetUniquePath Method
Database..::..DataRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetUniquePath(
    string id
)
Visual Basic
Public Function GetUniquePath ( _
    id As String _
) As String
Visual C++
public:
String^ GetUniquePath(
    String^ id
)

Parameters

id
Type: System..::..String
The id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Database.DataRecords.GetUniquePath(System.String)"]

Remarks

A unique path is a path consisting of item IDs.

See Also

Database..::..DataRecords Class
Sitecore.Data Namespace


Database.DataRecords Properties

[image] [image]

Sitecore 6.4.1 API
Database..::..DataRecords Properties
Database..::..DataRecords Class See Also Send Feedback

The Database..::..DataRecords type exposes the following members.

Properties

 | Name | Description
Public property | BasePath | Gets the base path.
Public property | Database | Gets the database.

See Also

Database..::..DataRecords Class
Sitecore.Data Namespace


BasePath Property

[image]

Sitecore 6.4.1 API
Database..::..DataRecords..::..BasePath Property
Database..::..DataRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string BasePath { get; }
Visual Basic
Public ReadOnly Property BasePath As String
    Get
Visual C++
public:
property String^ BasePath {
    String^ get ();
}

Field Value

The base path.

See Also

Database..::..DataRecords Class
Sitecore.Data Namespace


Database Property

[image]

Sitecore 6.4.1 API
Database..::..DataRecords..::..Database Property
Database..::..DataRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database Database { get; }
Visual Basic
Public ReadOnly Property Database As Database
    Get
Visual C++
public:
property Database^ Database {
    Database^ get ();
}

Field Value

The database.

See Also

Database..::..DataRecords Class
Sitecore.Data Namespace


DatabaseCacheDisabler Class

[image]

Sitecore 6.4.1 API
DatabaseCacheDisabler Class
Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DatabaseCacheDisabler : Switcher<bool, DatabaseCacheDisabler>
Visual Basic
Public Class DatabaseCacheDisabler _
    Inherits Switcher(Of Boolean, DatabaseCacheDisabler)
Visual C++
public ref class DatabaseCacheDisabler : public Switcher<bool, DatabaseCacheDisabler^>

Inheritance Hierarchy

System..::..Object
Sitecore.Common..::..Switcher <(Of <(<' Boolean, DatabaseCacheDisabler>)>)>
Sitecore.Data..::..DatabaseCacheDisabler

See Also

DatabaseCacheDisabler Members
Sitecore.Data Namespace


DatabaseCacheDisabler Members

[image] [image]

Sitecore 6.4.1 API
DatabaseCacheDisabler Members
DatabaseCacheDisabler Class Constructors Methods Events See Also Send Feedback

The DatabaseCacheDisabler type exposes the following members.

Constructors

 | Name | Description
Public method | DatabaseCacheDisabler | Initializes a new instance of the DatabaseCacheDisabler class.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Switcher<(Of <(<'TValue, TSwitchType>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

 | Name | Description
Protected event | Disposed | Occurs when the object has been disposed. (Inherited from Switcher<(Of <(<'TValue, TSwitchType>)>)>.)

See Also

DatabaseCacheDisabler Class
Sitecore.Data Namespace


DatabaseCacheDisabler Constructor

[image]

Sitecore 6.4.1 API
DatabaseCacheDisabler Constructor
DatabaseCacheDisabler Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DatabaseCacheDisabler()
Visual Basic
Public Sub New
Visual C++
public:
DatabaseCacheDisabler()

See Also

DatabaseCacheDisabler Class
Sitecore.Data Namespace


DatabaseCacheDisabler Methods

[image] [image]

Sitecore 6.4.1 API
DatabaseCacheDisabler Methods
DatabaseCacheDisabler Class See Also Send Feedback

The DatabaseCacheDisabler type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Switcher<(Of <(<'TValue, TSwitchType>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DatabaseCacheDisabler Class
Sitecore.Data Namespace


DatabaseCacheDisabler Events

[image] [image]

Sitecore 6.4.1 API
DatabaseCacheDisabler Events
DatabaseCacheDisabler Class See Also Send Feedback

The DatabaseCacheDisabler type exposes the following members.

Events

 | Name | Description
Protected event | Disposed | Occurs when the object has been disposed. (Inherited from Switcher<(Of <(<'TValue, TSwitchType>)>)>.)

See Also

DatabaseCacheDisabler Class
Sitecore.Data Namespace


DatabaseCaches Class

[image]

Sitecore 6.4.1 API
DatabaseCaches Class
Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DatabaseCaches
Visual Basic
Public Class DatabaseCaches
Visual C++
public ref class DatabaseCaches

Inheritance Hierarchy

System..::..Object
Sitecore.Data..::..DatabaseCaches

See Also

DatabaseCaches Members
Sitecore.Data Namespace


DatabaseCaches Members

[image] [image]

Sitecore 6.4.1 API
DatabaseCaches Members
DatabaseCaches Class Constructors Methods Properties See Also Send Feedback

The DatabaseCaches type exposes the following members.

Constructors

 | Name | Description
Public method | DatabaseCaches | Creates a new DatabaseProperties instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DataCache | Gets the data cache.
Public property | ItemCache | Gets the item cache.
Public property | PathCache | Gets the path cache.
Public property | StandardValuesCache | Gets the standard values cache.

See Also

DatabaseCaches Class
Sitecore.Data Namespace


DatabaseCaches Constructor

[image]

Sitecore 6.4.1 API
DatabaseCaches Constructor
DatabaseCaches Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DatabaseCaches(
    Database database
)
Visual Basic
Public Sub New ( _
    database As Database _
)
Visual C++
public:
DatabaseCaches(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
Database.

See Also

DatabaseCaches Class
Sitecore.Data Namespace


DatabaseCaches Methods

[image] [image]

Sitecore 6.4.1 API
DatabaseCaches Methods
DatabaseCaches Class See Also Send Feedback

The DatabaseCaches type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DatabaseCaches Class
Sitecore.Data Namespace


DatabaseCaches Properties

[image] [image]

Sitecore 6.4.1 API
DatabaseCaches Properties
DatabaseCaches Class See Also Send Feedback

The DatabaseCaches type exposes the following members.

Properties

 | Name | Description
Public property | DataCache | Gets the data cache.
Public property | ItemCache | Gets the item cache.
Public property | PathCache | Gets the path cache.
Public property | StandardValuesCache | Gets the standard values cache.

See Also

DatabaseCaches Class
Sitecore.Data Namespace


DataCache Property

[image]

Sitecore 6.4.1 API
DatabaseCaches..::..DataCache Property
DatabaseCaches Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual DataCache DataCache { get; }
Visual Basic
Public Overridable ReadOnly Property DataCache As DataCache
    Get
Visual C++
public:
virtual property DataCache^ DataCache {
    DataCache^ get ();
}

Field Value

The data cache.

See Also

DatabaseCaches Class
Sitecore.Data Namespace


ItemCache Property

[image]

Sitecore 6.4.1 API
DatabaseCaches..::..ItemCache Property
DatabaseCaches Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ItemCache ItemCache { get; }
Visual Basic
Public Overridable ReadOnly Property ItemCache As ItemCache
    Get
Visual C++
public:
virtual property ItemCache^ ItemCache {
    ItemCache^ get ();
}

Field Value

The item cache.

See Also

DatabaseCaches Class
Sitecore.Data Namespace


StandardValuesCache Property

[image]

Sitecore 6.4.1 API
DatabaseCaches..::..StandardValuesCache Property
DatabaseCaches Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StandardValuesCache StandardValuesCache { get; }
Visual Basic
Public ReadOnly Property StandardValuesCache As StandardValuesCache
    Get
Visual C++
public:
property StandardValuesCache^ StandardValuesCache {
    StandardValuesCache^ get ();
}

Field Value

The standard values cache.

See Also

DatabaseCaches Class
Sitecore.Data Namespace


DatabaseEngines Class

[image]

Sitecore 6.4.1 API
DatabaseEngines Class
Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DatabaseEngines
Visual Basic
Public Class DatabaseEngines
Visual C++
public ref class DatabaseEngines

Inheritance Hierarchy

System..::..Object
Sitecore.Data..::..DatabaseEngines

See Also

DatabaseEngines Members
Sitecore.Data Namespace


DatabaseEngines Members

[image] [image]

Sitecore 6.4.1 API
DatabaseEngines Members
DatabaseEngines Class Constructors Methods Properties See Also Send Feedback

The DatabaseEngines type exposes the following members.

Constructors

 | Name | Description
Public method | DatabaseEngines | Initializes a new instance of the DatabaseEngines class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DataEngine | Gets the data engine.
Public property | HistoryEngine | Gets the history engine.
Public property | TemplateEngine | Gets the template engine.
Public property | WorkflowEngine | Gets the workflow engine.

See Also

DatabaseEngines Class
Sitecore.Data Namespace


DatabaseEngines Constructor

[image]

Sitecore 6.4.1 API
DatabaseEngines Constructor
DatabaseEngines Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DatabaseEngines(
    Database database
)
Visual Basic
Public Sub New ( _
    database As Database _
)
Visual C++
public:
DatabaseEngines(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

See Also

DatabaseEngines Class
Sitecore.Data Namespace


DatabaseEngines Methods

[image] [image]

Sitecore 6.4.1 API
DatabaseEngines Methods
DatabaseEngines Class See Also Send Feedback

The DatabaseEngines type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DatabaseEngines Class
Sitecore.Data Namespace


DatabaseEngines Properties

[image] [image]

Sitecore 6.4.1 API
DatabaseEngines Properties
DatabaseEngines Class See Also Send Feedback

The DatabaseEngines type exposes the following members.

Properties

 | Name | Description
Public property | DataEngine | Gets the data engine.
Public property | HistoryEngine | Gets the history engine.
Public property | TemplateEngine | Gets the template engine.
Public property | WorkflowEngine | Gets the workflow engine.

See Also

DatabaseEngines Class
Sitecore.Data Namespace


DataEngine Property

[image]

Sitecore 6.4.1 API
DatabaseEngines..::..DataEngine Property
DatabaseEngines Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataEngine DataEngine { get; }
Visual Basic
Public ReadOnly Property DataEngine As DataEngine
    Get
Visual C++
public:
property DataEngine^ DataEngine {
    DataEngine^ get ();
}

Field Value

The data engine.

See Also

DatabaseEngines Class
Sitecore.Data Namespace


HistoryEngine Property

[image]

Sitecore 6.4.1 API
DatabaseEngines..::..HistoryEngine Property
DatabaseEngines Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HistoryEngine HistoryEngine { get; }
Visual Basic
Public ReadOnly Property HistoryEngine As HistoryEngine
    Get
Visual C++
public:
property HistoryEngine^ HistoryEngine {
    HistoryEngine^ get ();
}

Field Value

The history engine.

See Also

DatabaseEngines Class
Sitecore.Data Namespace


TemplateEngine Property

[image]

Sitecore 6.4.1 API
DatabaseEngines..::..TemplateEngine Property
DatabaseEngines Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateEngine TemplateEngine { get; }
Visual Basic
Public ReadOnly Property TemplateEngine As TemplateEngine
    Get
Visual C++
public:
property TemplateEngine^ TemplateEngine {
    TemplateEngine^ get ();
}

Field Value

The template engine.

See Also

DatabaseEngines Class
Sitecore.Data Namespace


WorkflowEngine Property

[image]

Sitecore 6.4.1 API
DatabaseEngines..::..WorkflowEngine Property
DatabaseEngines Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WorkflowEngine WorkflowEngine { get; }
Visual Basic
Public ReadOnly Property WorkflowEngine As WorkflowEngine
    Get
Visual C++
public:
property WorkflowEngine^ WorkflowEngine {
    WorkflowEngine^ get ();
}

Field Value

The workflow engine.

See Also

DatabaseEngines Class
Sitecore.Data Namespace


DatabaseProperties Class

[image]

Sitecore 6.4.1 API
DatabaseProperties Class
Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DatabaseProperties : PropertiesBase
Visual Basic
Public Class DatabaseProperties _
    Inherits PropertiesBase
Visual C++
public ref class DatabaseProperties : public PropertiesBase

Remarks

The database properties allows the developer to attach meta data to a database. For instance the database version is a database property.

Inheritance Hierarchy

System..::..Object
Sitecore.Data..::..PropertiesBase
Sitecore.Data..::..DatabaseProperties

See Also

DatabaseProperties Members
Sitecore.Data Namespace


DatabaseProperties Members

[image] [image]

Sitecore 6.4.1 API
DatabaseProperties Members
DatabaseProperties Class Constructors Methods Properties See Also Send Feedback

The DatabaseProperties type exposes the following members.

Constructors

 | Name | Description
Public method | DatabaseProperties | Creates a new DatabaseProperties instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBoolValue | Gets a bool value. (Inherited from PropertiesBase.)
Public method | GetDateValue | Gets a date value. (Inherited from PropertiesBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntValue | Gets an integer value. (Inherited from PropertiesBase.)
Public method | GetLastPublishDate | Gets the last publish date.
Public method | GetLongValue | Gets a long value. (Inherited from PropertiesBase.)
Public method | GetSmartPublishRequired | Gets a value indicating if smart publish is required.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a value with the specified name. (Inherited from PropertiesBase.)
Public method | RemovePrefix | Removes all values which names have the specified prefix. (Inherited from PropertiesBase.)
Public method | SetBoolValue | Sets a bool value. (Inherited from PropertiesBase.)
Public method | SetDateValue | Sets a date value. (Inherited from PropertiesBase.)
Public method | SetIntValue | Sets an integer value. (Inherited from PropertiesBase.)
Public method | SetLastPublishDate | Sets the last publish date.
Public method | SetLongValue | Sets a long value. (Inherited from PropertiesBase.)
Public method | SetSmartPublishRequired | Sets a value indicating if smart publish is required.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Database | Gets the database. (Inherited from PropertiesBase.)
Public property | Item | Gets or sets the value with the specified name. (Inherited from PropertiesBase.)
Public property | Version | Gets the version of the database.

See Also

DatabaseProperties Class
Sitecore.Data Namespace


DatabaseProperties Constructor

[image]

Sitecore 6.4.1 API
DatabaseProperties Constructor
DatabaseProperties Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DatabaseProperties(
    Database database
)
Visual Basic
Public Sub New ( _
    database As Database _
)
Visual C++
public:
DatabaseProperties(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
Database.

See Also

DatabaseProperties Class
Sitecore.Data Namespace


DatabaseProperties Methods

[image] [image]

Sitecore 6.4.1 API
DatabaseProperties Methods
DatabaseProperties Class See Also Send Feedback

The DatabaseProperties type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBoolValue | Gets a bool value. (Inherited from PropertiesBase.)
Public method | GetDateValue | Gets a date value. (Inherited from PropertiesBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntValue | Gets an integer value. (Inherited from PropertiesBase.)
Public method | GetLastPublishDate | Gets the last publish date.
Public method | GetLongValue | Gets a long value. (Inherited from PropertiesBase.)
Public method | GetSmartPublishRequired | Gets a value indicating if smart publish is required.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a value with the specified name. (Inherited from PropertiesBase.)
Public method | RemovePrefix | Removes all values which names have the specified prefix. (Inherited from PropertiesBase.)
Public method | SetBoolValue | Sets a bool value. (Inherited from PropertiesBase.)
Public method | SetDateValue | Sets a date value. (Inherited from PropertiesBase.)
Public method | SetIntValue | Sets an integer value. (Inherited from PropertiesBase.)
Public method | SetLastPublishDate | Sets the last publish date.
Public method | SetLongValue | Sets a long value. (Inherited from PropertiesBase.)
Public method | SetSmartPublishRequired | Sets a value indicating if smart publish is required.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DatabaseProperties Class
Sitecore.Data Namespace


GetLastPublishDate Method

[image]

Sitecore 6.4.1 API
DatabaseProperties..::..GetLastPublishDate Method
DatabaseProperties Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime GetLastPublishDate(
    Database target,
    Language language
)
Visual Basic
Public Function GetLastPublishDate ( _
    target As Database, _
    language As Language _
) As DateTime
Visual C++
public:
DateTime GetLastPublishDate(
    Database^ target,
    Language^ language
)

Parameters

target
Type: Sitecore.Data..::..Database
Target.
language
Type: Sitecore.Globalization..::..Language
Language.

Return Value

The last publish date.

See Also

DatabaseProperties Class
Sitecore.Data Namespace


GetSmartPublishRequired Method

[image]

Sitecore 6.4.1 API
DatabaseProperties..::..GetSmartPublishRequired Method
DatabaseProperties Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool GetSmartPublishRequired(
    string targetName,
    Language language
)
Visual Basic
Public Function GetSmartPublishRequired ( _
    targetName As String, _
    language As Language _
) As Boolean
Visual C++
public:
bool GetSmartPublishRequired(
    String^ targetName,
    Language^ language
)

Parameters

targetName
Type: System..::..String
Name of the target database.
language
Type: Sitecore.Globalization..::..Language
Language.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DatabaseProperties.GetSmartPublishRequired(System.String,Sitecore.Globalization.Language)"]

See Also

DatabaseProperties Class
Sitecore.Data Namespace


SetLastPublishDate Method

[image]

Sitecore 6.4.1 API
DatabaseProperties..::..SetLastPublishDate Method
DatabaseProperties Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetLastPublishDate(
    Database target,
    Language language,
    DateTime date
)
Visual Basic
Public Sub SetLastPublishDate ( _
    target As Database, _
    language As Language, _
    date As DateTime _
)
Visual C++
public:
void SetLastPublishDate(
    Database^ target,
    Language^ language,
    DateTime date
)

Parameters

target
Type: Sitecore.Data..::..Database
Target.
language
Type: Sitecore.Globalization..::..Language
Language.
date
Type: System..::..DateTime
Date.

Remarks

This property is automatically updated for each publish.

See Also

DatabaseProperties Class
Sitecore.Data Namespace


SetSmartPublishRequired Method

[image]

Sitecore 6.4.1 API
DatabaseProperties..::..SetSmartPublishRequired Method
DatabaseProperties Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetSmartPublishRequired(
    string targetName,
    Language language,
    bool required
)
Visual Basic
Public Sub SetSmartPublishRequired ( _
    targetName As String, _
    language As Language, _
    required As Boolean _
)
Visual C++
public:
void SetSmartPublishRequired(
    String^ targetName,
    Language^ language,
    bool required
)

Parameters

targetName
Type: System..::..String
Name of the target database.
language
Type: Sitecore.Globalization..::..Language
Language.
required
Type: System..::..Boolean
if set to true smart publish is required.

See Also

DatabaseProperties Class
Sitecore.Data Namespace


DatabaseProperties Properties

[image] [image]

Sitecore 6.4.1 API
DatabaseProperties Properties
DatabaseProperties Class See Also Send Feedback

The DatabaseProperties type exposes the following members.

Properties

 | Name | Description
Public property | Database | Gets the database. (Inherited from PropertiesBase.)
Public property | Item | Gets or sets the value with the specified name. (Inherited from PropertiesBase.)
Public property | Version | Gets the version of the database.

See Also

DatabaseProperties Class
Sitecore.Data Namespace


Version Property

[image]

Sitecore 6.4.1 API
DatabaseProperties..::..Version Property
DatabaseProperties Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Version { get; }
Visual Basic
Public ReadOnly Property Version As Integer
    Get
Visual C++
public:
property int Version {
    int get ();
}

Field Value

The version.

See Also

DatabaseProperties Class
Sitecore.Data Namespace


DatabaseSwitcher Class

[image]

Sitecore 6.4.1 API
DatabaseSwitcher Class
Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DatabaseSwitcher : IDisposable
Visual Basic
Public Class DatabaseSwitcher _
    Implements IDisposable
Visual C++
public ref class DatabaseSwitcher : IDisposable

Inheritance Hierarchy

System..::..Object
Sitecore.Data..::..DatabaseSwitcher

See Also

DatabaseSwitcher Members
Sitecore.Data Namespace


DatabaseSwitcher Members

[image] [image]

Sitecore 6.4.1 API
DatabaseSwitcher Members
DatabaseSwitcher Class Constructors Methods See Also Send Feedback

The DatabaseSwitcher type exposes the following members.

Constructors

 | Name | Description
Public method | DatabaseSwitcher | Initializes a new instance of the DatabaseSwitcher class.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DatabaseSwitcher Class
Sitecore.Data Namespace


DatabaseSwitcher Constructor

[image]

Sitecore 6.4.1 API
DatabaseSwitcher Constructor
DatabaseSwitcher Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DatabaseSwitcher(
    Database database
)
Visual Basic
Public Sub New ( _
    database As Database _
)
Visual C++
public:
DatabaseSwitcher(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database to switch to.

See Also

DatabaseSwitcher Class
Sitecore.Data Namespace


DatabaseSwitcher Methods

[image] [image]

Sitecore 6.4.1 API
DatabaseSwitcher Methods
DatabaseSwitcher Class See Also Send Feedback

The DatabaseSwitcher type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DatabaseSwitcher Class
Sitecore.Data Namespace


Dispose Method

[image]

Sitecore 6.4.1 API
DatabaseSwitcher..::..Dispose Method
DatabaseSwitcher Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

DatabaseSwitcher Class
Sitecore.Data Namespace


DataManager Class

[image]

Sitecore 6.4.1 API
DataManager Class
Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DataManager : IQueryable
Visual Basic
Public Class DataManager _
    Implements IQueryable
Visual C++
public ref class DataManager : IQueryable

Inheritance Hierarchy

System..::..Object
Sitecore.Data..::..DataManager

See Also

DataManager Members
Sitecore.Data Namespace


DataManager Members

[image] [image]

Sitecore 6.4.1 API
DataManager Members
DataManager Class Constructors Methods Properties See Also Send Feedback

The DataManager type exposes the following members.

Constructors

 | Name | Description
Public method | DataManager | Initializes a new instance of the DataManager class.

Methods

 | Name | Description
Public method | CleanupPublishQueue | Cleanups the publish queue.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemsInWorkflowState | Gets the state of the items in workflow.
Public method | GetProperty | Gets the property.
Public method | GetPropertyKeys | Gets the property.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWorkflowInfo | Gets the workflow info.
Public method | HasShadows | Determines whether the specified item has shadows.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveProperty | Removes the property.
Public method | SelectItems(String) | Selects the items.
Public method | SelectItems(String, Boolean%) | Selects the items.
Public method | SelectSingleItem | Selects the single item.
Public method | SetProperty | Sets the property.
Public method | SetWorkflowInfo | Sets the workflow info.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Database | Gets the database.
Public property | DataEngine | Gets the data engine.
Public property | DataSource | Gets the DataSource associated with this DataManager instance.

See Also

DataManager Class
Sitecore.Data Namespace


DataManager Constructor

[image]

Sitecore 6.4.1 API
DataManager Constructor
DataManager Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataManager(
    Database database
)
Visual Basic
Public Sub New ( _
    database As Database _
)
Visual C++
public:
DataManager(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

See Also

DataManager Class
Sitecore.Data Namespace


DataManager Methods

[image] [image]

Sitecore 6.4.1 API
DataManager Methods
DataManager Class See Also Send Feedback

The DataManager type exposes the following members.

Methods

 | Name | Description
Public method | CleanupPublishQueue | Cleanups the publish queue.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemsInWorkflowState | Gets the state of the items in workflow.
Public method | GetProperty | Gets the property.
Public method | GetPropertyKeys | Gets the property.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWorkflowInfo | Gets the workflow info.
Public method | HasShadows | Determines whether the specified item has shadows.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveProperty | Removes the property.
Public method | SelectItems(String) | Selects the items.
Public method | SelectItems(String, Boolean%) | Selects the items.
Public method | SelectSingleItem | Selects the single item.
Public method | SetProperty | Sets the property.
Public method | SetWorkflowInfo | Sets the workflow info.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataManager Class
Sitecore.Data Namespace


GetProperty Method

[image]

Sitecore 6.4.1 API
DataManager..::..GetProperty Method
DataManager Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetProperty(
    string name
)
Visual Basic
Public Function GetProperty ( _
    name As String _
) As String
Visual C++
public:
String^ GetProperty(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

Return Value

The property.

See Also

DataManager Class
Sitecore.Data Namespace


GetPropertyKeys Method

[image]

Sitecore 6.4.1 API
DataManager..::..GetPropertyKeys Method
DataManager Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public List<string> GetPropertyKeys(
    string prefix
)
Visual Basic
Public Function GetPropertyKeys ( _
    prefix As String _
) As List(Of String)
Visual C++
public:
List<String^>^ GetPropertyKeys(
    String^ prefix
)

Parameters

prefix
Type: System..::..String
The prefix.

Return Value

The property.

See Also

DataManager Class
Sitecore.Data Namespace


GetWorkflowInfo Method

[image]

Sitecore 6.4.1 API
DataManager..::..GetWorkflowInfo Method
DataManager Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WorkflowInfo GetWorkflowInfo(
    Item item
)
Visual Basic
Public Function GetWorkflowInfo ( _
    item As Item _
) As WorkflowInfo
Visual C++
public:
WorkflowInfo^ GetWorkflowInfo(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

The workflow info.

See Also

DataManager Class
Sitecore.Data Namespace


HasShadows Method

[image]

Sitecore 6.4.1 API
DataManager..::..HasShadows Method
DataManager Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool HasShadows(
    Item item
)
Visual Basic
Public Function HasShadows ( _
    item As Item _
) As Boolean
Visual C++
public:
bool HasShadows(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

true if the specified item has shadows; otherwise, false.

See Also

DataManager Class
Sitecore.Data Namespace


RemoveProperty Method

[image]

Sitecore 6.4.1 API
DataManager..::..RemoveProperty Method
DataManager Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool RemoveProperty(
    string name,
    bool isPrefix
)
Visual Basic
Public Function RemoveProperty ( _
    name As String, _
    isPrefix As Boolean _
) As Boolean
Visual C++
public:
bool RemoveProperty(
    String^ name,
    bool isPrefix
)

Parameters

name
Type: System..::..String
The name.
isPrefix
Type: System..::..Boolean
if set to true this instance is is prefix.

Return Value

The property.

See Also

DataManager Class
Sitecore.Data Namespace


SelectItems Method

[image] [image]

Sitecore 6.4.1 API
DataManager..::..SelectItems Method
DataManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SelectItems(String) | Selects the items.
Public method | SelectItems(String, Boolean%) | Selects the items.

See Also

DataManager Class
DataManager Members
Sitecore.Data Namespace


SelectItems Method (String)

[image]

Sitecore 6.4.1 API
DataManager..::..SelectItems Method (String)
DataManager Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item[] SelectItems(
    string query
)
Visual Basic
Public Function SelectItems ( _
    query As String _
) As Item()
Visual C++
public:
array<Item^>^ SelectItems(
    String^ query
)

Parameters

query
Type: System..::..String
The query.

Return Value

The items.

See Also

DataManager Class
SelectItems Overload
Sitecore.Data Namespace


SelectItems Method (String, Boolean)

[image]

Sitecore 6.4.1 API
DataManager..::..SelectItems Method (String, Boolean%)
DataManager Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item[] SelectItems(
    string query,
    out bool processed
)
Visual Basic
Public Function SelectItems ( _
    query As String, _
    <OutAttribute> ByRef processed As Boolean _
) As Item()
Visual C++
public:
array<Item^>^ SelectItems(
    String^ query,
    [OutAttribute] bool% processed
)

Parameters

query
Type: System..::..String
The query.
processed
Type: System..::..Boolean %
If set to true the query was processed.

Return Value

The items.

See Also

DataManager Class
SelectItems Overload
Sitecore.Data Namespace


SelectSingleItem Method

[image]

Sitecore 6.4.1 API
DataManager..::..SelectSingleItem Method
DataManager Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item SelectSingleItem(
    string query,
    out bool processed
)
Visual Basic
Public Function SelectSingleItem ( _
    query As String, _
    <OutAttribute> ByRef processed As Boolean _
) As Item
Visual C++
public:
Item^ SelectSingleItem(
    String^ query,
    [OutAttribute] bool% processed
)

Parameters

query
Type: System..::..String
The query.
processed
Type: System..::..Boolean %
If set to true the query was processed.

Return Value

The single item.

See Also

DataManager Class
Sitecore.Data Namespace


SetProperty Method

[image]

Sitecore 6.4.1 API
DataManager..::..SetProperty Method
DataManager Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool SetProperty(
    string name,
    string value
)
Visual Basic
Public Function SetProperty ( _
    name As String, _
    value As String _
) As Boolean
Visual C++
public:
bool SetProperty(
    String^ name,
    String^ value
)

Parameters

name
Type: System..::..String
The name.
value
Type: System..::..String
The value.

Return Value

The property.

See Also

DataManager Class
Sitecore.Data Namespace


SetWorkflowInfo Method

[image]

Sitecore 6.4.1 API
DataManager..::..SetWorkflowInfo Method
DataManager Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool SetWorkflowInfo(
    Item item,
    WorkflowInfo info
)
Visual Basic
Public Function SetWorkflowInfo ( _
    item As Item, _
    info As WorkflowInfo _
) As Boolean
Visual C++
public:
bool SetWorkflowInfo(
    Item^ item,
    WorkflowInfo^ info
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
info
Type: Sitecore.Workflows..::..WorkflowInfo
The info.

Return Value

The workflow info.

See Also

DataManager Class
Sitecore.Data Namespace


DataManager Properties

[image] [image]

Sitecore 6.4.1 API
DataManager Properties
DataManager Class See Also Send Feedback

The DataManager type exposes the following members.

Properties

 | Name | Description
Public property | Database | Gets the database.
Public property | DataEngine | Gets the data engine.
Public property | DataSource | Gets the DataSource associated with this DataManager instance.

See Also

DataManager Class
Sitecore.Data Namespace


DataEngine Property

[image]

Sitecore 6.4.1 API
DataManager..::..DataEngine Property
DataManager Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataEngine DataEngine { get; }
Visual Basic
Public ReadOnly Property DataEngine As DataEngine
    Get
Visual C++
public:
property DataEngine^ DataEngine {
    DataEngine^ get ();
}

Field Value

The data engine.

See Also

DataManager Class
Sitecore.Data Namespace


DataSource Property

[image]

Sitecore 6.4.1 API
DataManager..::..DataSource Property
DataManager Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataSource DataSource { get; }
Visual Basic
Public ReadOnly Property DataSource As DataSource
    Get
Visual C++
public:
property DataSource^ DataSource {
    DataSource^ get ();
}

Field Value

The data source.

See Also

DataManager Class
Sitecore.Data Namespace


DataSource Class

[image]

Sitecore 6.4.1 API
DataSource Class
Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DataSource
Visual Basic
Public Class DataSource
Visual C++
public ref class DataSource

Inheritance Hierarchy

System..::..Object
Sitecore.Data..::..DataSource

See Also

DataSource Members
Sitecore.Data Namespace


DataSource Members

[image] [image]

Sitecore 6.4.1 API
DataSource Members
DataSource Class Constructors Methods Properties See Also Send Feedback

The DataSource type exposes the following members.

Constructors

 | Name | Description
Public method | DataSource | Initializes a new instance of the DataSource class.

Methods

 | Name | Description
Public method | AddToPublishQueue | Adds to publish queue.
Public method | AddVersion | Adds the version.
Public method | BlobStreamExists | Determines whether the specified field contains a BLOB value.
Protected method | CacheBlobID | Caches the blob ID.
Public method | ChangeFieldSharing | Changes the type of field sharing for a single field.
Public method | ChangeTemplate | Changes the template.
Public method | CleanupDatabase | Cleans up the database.
Public method | CleanupPublishQueue | Cleanups the publish queue.
Public method | CopyItem | Copies the item.
Public method | CreateItem | Creates the item.
Public method | DeleteItem | Deletes the item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBlobCacheKey | Gets the BLOB cache key.
Public method | GetBlobStream | Gets the BLOB stream associated with a field.
Public method | GetChildIDs | Gets the child I ds.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemData | Gets the item data.
Public method | GetItemDefinition(String) | Gets the item definition.
Public method | GetItemDefinition(ID) | Gets the item definition.
Public method | GetItemInformation | Gets the item information.
Public method | GetItemsInWorkflowState | Gets the state of the items in workflow.
Public method | GetLanguages()()()() | Removes all data using a specific language from the database.
Public method | GetLanguages(ID) | Gets the languages containing data for a specific item.
Public method | GetLatestVersion | Gets the latest version.
Public method | GetParentID | Gets the parent ID.
Public method | GetProperty | Gets the property.
Public method | GetPropertyKeys | Gets a list of property keys matching a specific prefix.
Public method | GetPublishQueue | Gets the publish queue.
Public method | GetRootID | Gets the root ID.
Public method | GetTemplate(String) | Gets the template.
Public method | GetTemplate(ID) | Gets the template.
Public method | GetTemplateIds | Get a list of all template ids stored in the data providers.
Public method | GetTemplates | Gets the templates.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersions(ID, Language) | Gets the versions.
Public method | GetVersions(ItemInformation, Language) | Gets the versions.
Public method | GetVersionUris | Gets all version URIs for an item.
Public method | GetWorkflowInfo | Gets the workflow info.
Public method | HasChildren | Determines whether the specified item has children.
Public method | ItemExists | Items the exists.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveItem | Moves the item.
Public method | RemoveLanguageData | Removes the language data specified by language.
Public method | RemoveProperty | Removes the property.
Public method | RemoveVersion | Removes the version.
Public method | RemoveVersions | Removes the versions.
Public method | RenameLanguageData | Renames a language binding.
Public method | ResolvePath | Resolves the path.
Public method | SaveItem | Saves the item.
Public method | SelectIDs | Selects the I ds.
Public method | SelectSingleID | Selects the single ID.
Public method | SetBlobStream | Sets the BLOB stream associated with a field.
Public method | SetProperty | Sets the property.
Public method | SetWorkflowInfo(ItemDefinition, VersionUri, WorkflowInfo) | Sets the workflow info.
Public method | SetWorkflowInfo(ID, Language, Version, WorkflowInfo) | Sets the workflow info.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DataManager | Gets the data manager.

See Also

DataSource Class
Sitecore.Data Namespace


DataSource Constructor

[image]

Sitecore 6.4.1 API
DataSource Constructor
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataSource(
    DataManager dataManager
)
Visual Basic
Public Sub New ( _
    dataManager As DataManager _
)
Visual C++
public:
DataSource(
    DataManager^ dataManager
)

Parameters

dataManager
Type: Sitecore.Data..::..DataManager
The data manager.

See Also

DataSource Class
Sitecore.Data Namespace


DataSource Methods

[image] [image]

Sitecore 6.4.1 API
DataSource Methods
DataSource Class See Also Send Feedback

The DataSource type exposes the following members.

Methods

 | Name | Description
Public method | AddToPublishQueue | Adds to publish queue.
Public method | AddVersion | Adds the version.
Public method | BlobStreamExists | Determines whether the specified field contains a BLOB value.
Protected method | CacheBlobID | Caches the blob ID.
Public method | ChangeFieldSharing | Changes the type of field sharing for a single field.
Public method | ChangeTemplate | Changes the template.
Public method | CleanupDatabase | Cleans up the database.
Public method | CleanupPublishQueue | Cleanups the publish queue.
Public method | CopyItem | Copies the item.
Public method | CreateItem | Creates the item.
Public method | DeleteItem | Deletes the item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBlobCacheKey | Gets the BLOB cache key.
Public method | GetBlobStream | Gets the BLOB stream associated with a field.
Public method | GetChildIDs | Gets the child I ds.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemData | Gets the item data.
Public method | GetItemDefinition(String) | Gets the item definition.
Public method | GetItemDefinition(ID) | Gets the item definition.
Public method | GetItemInformation | Gets the item information.
Public method | GetItemsInWorkflowState | Gets the state of the items in workflow.
Public method | GetLanguages()()()() | Removes all data using a specific language from the database.
Public method | GetLanguages(ID) | Gets the languages containing data for a specific item.
Public method | GetLatestVersion | Gets the latest version.
Public method | GetParentID | Gets the parent ID.
Public method | GetProperty | Gets the property.
Public method | GetPropertyKeys | Gets a list of property keys matching a specific prefix.
Public method | GetPublishQueue | Gets the publish queue.
Public method | GetRootID | Gets the root ID.
Public method | GetTemplate(String) | Gets the template.
Public method | GetTemplate(ID) | Gets the template.
Public method | GetTemplateIds | Get a list of all template ids stored in the data providers.
Public method | GetTemplates | Gets the templates.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersions(ID, Language) | Gets the versions.
Public method | GetVersions(ItemInformation, Language) | Gets the versions.
Public method | GetVersionUris | Gets all version URIs for an item.
Public method | GetWorkflowInfo | Gets the workflow info.
Public method | HasChildren | Determines whether the specified item has children.
Public method | ItemExists | Items the exists.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveItem | Moves the item.
Public method | RemoveLanguageData | Removes the language data specified by language.
Public method | RemoveProperty | Removes the property.
Public method | RemoveVersion | Removes the version.
Public method | RemoveVersions | Removes the versions.
Public method | RenameLanguageData | Renames a language binding.
Public method | ResolvePath | Resolves the path.
Public method | SaveItem | Saves the item.
Public method | SelectIDs | Selects the I ds.
Public method | SelectSingleID | Selects the single ID.
Public method | SetBlobStream | Sets the BLOB stream associated with a field.
Public method | SetProperty | Sets the property.
Public method | SetWorkflowInfo(ItemDefinition, VersionUri, WorkflowInfo) | Sets the workflow info.
Public method | SetWorkflowInfo(ID, Language, Version, WorkflowInfo) | Sets the workflow info.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataSource Class
Sitecore.Data Namespace


AddToPublishQueue Method

[image]

Sitecore 6.4.1 API
DataSource..::..AddToPublishQueue Method
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool AddToPublishQueue(
    ID itemID,
    string action,
    DateTime date
)
Visual Basic
Public Function AddToPublishQueue ( _
    itemID As ID, _
    action As String, _
    date As DateTime _
) As Boolean
Visual C++
public:
bool AddToPublishQueue(
    ID^ itemID,
    String^ action,
    DateTime date
)

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.
action
Type: System..::..String
The action.
date
Type: System..::..DateTime
The date.

Return Value

The to publish queue.

See Also

DataSource Class
Sitecore.Data Namespace


AddVersion Method

[image]

Sitecore 6.4.1 API
DataSource..::..AddVersion Method
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int AddVersion(
    ID itemID,
    VersionUri baseVersion
)
Visual Basic
Public Function AddVersion ( _
    itemID As ID, _
    baseVersion As VersionUri _
) As Integer
Visual C++
public:
int AddVersion(
    ID^ itemID,
    VersionUri^ baseVersion
)

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.
baseVersion
Type: Sitecore.Data..::..VersionUri
The base version.

Return Value

The version.

See Also

DataSource Class
Sitecore.Data Namespace


BlobStreamExists Method

[image]

Sitecore 6.4.1 API
DataSource..::..BlobStreamExists Method
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool BlobStreamExists(
    Guid blobId
)
Visual Basic
Public Function BlobStreamExists ( _
    blobId As Guid _
) As Boolean
Visual C++
public:
bool BlobStreamExists(
    Guid blobId
)

Parameters

blobId
Type: System..::..Guid
The BLOB id.

Return Value

true if [has BLOB value] [the specified BLOB id]; otherwise, false.

See Also

DataSource Class
Sitecore.Data Namespace


ChangeFieldSharing Method

[image]

Sitecore 6.4.1 API
DataSource..::..ChangeFieldSharing Method
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ChangeFieldSharing(
    TemplateField fieldDefinition,
    TemplateFieldSharing sharing
)
Visual Basic
Public Function ChangeFieldSharing ( _
    fieldDefinition As TemplateField, _
    sharing As TemplateFieldSharing _
) As Boolean
Visual C++
public:
bool ChangeFieldSharing(
    TemplateField^ fieldDefinition,
    TemplateFieldSharing sharing
)

Parameters

fieldDefinition
Type: Sitecore.Data.Templates..::..TemplateField
The field definition.
sharing
Type: Sitecore.Data.Templates..::..TemplateFieldSharing
The new sharing type.

Return Value

The change field sharing.

See Also

DataSource Class
Sitecore.Data Namespace


ChangeTemplate Method

[image]

Sitecore 6.4.1 API
DataSource..::..ChangeTemplate Method
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ChangeTemplate(
    ID itemID,
    TemplateChangeList changes
)
Visual Basic
Public Function ChangeTemplate ( _
    itemID As ID, _
    changes As TemplateChangeList _
) As Boolean
Visual C++
public:
bool ChangeTemplate(
    ID^ itemID,
    TemplateChangeList^ changes
)

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.
changes
Type: Sitecore.Data.Templates..::..TemplateChangeList
The changes.

Return Value

The template.

See Also

DataSource Class
Sitecore.Data Namespace


CleanupPublishQueue Method

[image]

Sitecore 6.4.1 API
DataSource..::..CleanupPublishQueue Method
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool CleanupPublishQueue(
    DateTime to
)
Visual Basic
Public Function CleanupPublishQueue ( _
    to As DateTime _
) As Boolean
Visual C++
public:
bool CleanupPublishQueue(
    DateTime to
)

Parameters

to
Type: System..::..DateTime
To.

Return Value

The publish queue.

See Also

DataSource Class
Sitecore.Data Namespace


CopyItem Method

[image]

Sitecore 6.4.1 API
DataSource..::..CopyItem Method
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool CopyItem(
    ID sourceID,
    ID destinationID,
    string copyName,
    ID copyID
)
Visual Basic
Public Function CopyItem ( _
    sourceID As ID, _
    destinationID As ID, _
    copyName As String, _
    copyID As ID _
) As Boolean
Visual C++
public:
bool CopyItem(
    ID^ sourceID,
    ID^ destinationID,
    String^ copyName,
    ID^ copyID
)

Parameters

sourceID
Type: Sitecore.Data..::..ID
The source ID.
destinationID
Type: Sitecore.Data..::..ID
The destination ID.
copyName
Type: System..::..String
Name of the copy.
copyID
Type: Sitecore.Data..::..ID
The copy ID.

Return Value

The item.

See Also

DataSource Class
Sitecore.Data Namespace


CreateItem Method

[image]

Sitecore 6.4.1 API
DataSource..::..CreateItem Method
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool CreateItem(
    ID itemID,
    string itemName,
    ID templateID,
    ID parentID
)
Visual Basic
Public Function CreateItem ( _
    itemID As ID, _
    itemName As String, _
    templateID As ID, _
    parentID As ID _
) As Boolean
Visual C++
public:
bool CreateItem(
    ID^ itemID,
    String^ itemName,
    ID^ templateID,
    ID^ parentID
)

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.
itemName
Type: System..::..String
Name of the item.
templateID
Type: Sitecore.Data..::..ID
The template ID.
parentID
Type: Sitecore.Data..::..ID
The parent ID.

Return Value

The item.

See Also

DataSource Class
Sitecore.Data Namespace


DeleteItem Method

[image]

Sitecore 6.4.1 API
DataSource..::..DeleteItem Method
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool DeleteItem(
    ID itemID
)
Visual Basic
Public Function DeleteItem ( _
    itemID As ID _
) As Boolean
Visual C++
public:
bool DeleteItem(
    ID^ itemID
)

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.

Return Value

The item.

See Also

DataSource Class
Sitecore.Data Namespace


GetBlobStream Method

[image]

Sitecore 6.4.1 API
DataSource..::..GetBlobStream Method
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Stream GetBlobStream(
    Guid blobId
)
Visual Basic
Public Function GetBlobStream ( _
    blobId As Guid _
) As Stream
Visual C++
public:
Stream^ GetBlobStream(
    Guid blobId
)

Parameters

blobId
Type: System..::..Guid
The BLOB id.

Return Value

The stream.

See Also

DataSource Class
Sitecore.Data Namespace


GetItemData Method

[image]

Sitecore 6.4.1 API
DataSource..::..GetItemData Method
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ItemData GetItemData(
    ID itemID,
    Language language,
    Version version
)
Visual Basic
Public Overridable Function GetItemData ( _
    itemID As ID, _
    language As Language, _
    version As Version _
) As ItemData
Visual C++
public:
virtual ItemData^ GetItemData(
    ID^ itemID,
    Language^ language,
    Version^ version
)

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.
language
Type: Sitecore.Globalization..::..Language
The language.
version
Type: Sitecore.Data..::..Version
The version.

Return Value

The item data.

See Also

DataSource Class
Sitecore.Data Namespace


GetItemDefinition Method

[image] [image]

Sitecore 6.4.1 API
DataSource..::..GetItemDefinition Method
DataSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetItemDefinition(String) | Gets the item definition.
Public method | GetItemDefinition(ID) | Gets the item definition.

See Also

DataSource Class
DataSource Members
Sitecore.Data Namespace


GetItemDefinition Method (String)

[image]

Sitecore 6.4.1 API
DataSource..::..GetItemDefinition Method (String)
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ItemDefinition GetItemDefinition(
    string path
)
Visual Basic
Public Overridable Function GetItemDefinition ( _
    path As String _
) As ItemDefinition
Visual C++
public:
virtual ItemDefinition^ GetItemDefinition(
    String^ path
)

Parameters

path
Type: System..::..String
The path.

Return Value

The item definition.

See Also

DataSource Class
GetItemDefinition Overload
Sitecore.Data Namespace


GetItemDefinition Method (ID)

[image]

Sitecore 6.4.1 API
DataSource..::..GetItemDefinition Method (ID)
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ItemDefinition GetItemDefinition(
    ID itemID
)
Visual Basic
Public Overridable Function GetItemDefinition ( _
    itemID As ID _
) As ItemDefinition
Visual C++
public:
virtual ItemDefinition^ GetItemDefinition(
    ID^ itemID
)

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.

Return Value

The item definition.

See Also

DataSource Class
GetItemDefinition Overload
Sitecore.Data Namespace


GetItemInformation Method

[image]

Sitecore 6.4.1 API
DataSource..::..GetItemInformation Method
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ItemInformation GetItemInformation(
    ID itemID
)
Visual Basic
Public Overridable Function GetItemInformation ( _
    itemID As ID _
) As ItemInformation
Visual C++
public:
virtual ItemInformation^ GetItemInformation(
    ID^ itemID
)

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.

Return Value

The item information.

See Also

DataSource Class
Sitecore.Data Namespace


GetItemsInWorkflowState Method

[image]

Sitecore 6.4.1 API
DataSource..::..GetItemsInWorkflowState Method
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataUri[] GetItemsInWorkflowState(
    WorkflowInfo info
)
Visual Basic
Public Function GetItemsInWorkflowState ( _
    info As WorkflowInfo _
) As DataUri()
Visual C++
public:
array<DataUri^>^ GetItemsInWorkflowState(
    WorkflowInfo^ info
)

Parameters

info
Type: Sitecore.Workflows..::..WorkflowInfo
The info.

Return Value

The DataUri array.

See Also

DataSource Class
Sitecore.Data Namespace


GetLanguages Method

[image] [image]

Sitecore 6.4.1 API
DataSource..::..GetLanguages Method
DataSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetLanguages()()()() | Removes all data using a specific language from the database.
Public method | GetLanguages(ID) | Gets the languages containing data for a specific item.

See Also

DataSource Class
DataSource Members
Sitecore.Data Namespace


GetLanguages Method

[image]

Sitecore 6.4.1 API
DataSource..::..GetLanguages Method
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LanguageCollection GetLanguages()
Visual Basic
Public Function GetLanguages As LanguageCollection
Visual C++
public:
LanguageCollection^ GetLanguages()

Return Value

The languages.

See Also

DataSource Class
GetLanguages Overload
Sitecore.Data Namespace


GetLanguages Method (ID)

[image]

Sitecore 6.4.1 API
DataSource..::..GetLanguages Method (ID)
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LanguageCollection GetLanguages(
    ID itemId
)
Visual Basic
Public Function GetLanguages ( _
    itemId As ID _
) As LanguageCollection
Visual C++
public:
LanguageCollection^ GetLanguages(
    ID^ itemId
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.

Return Value

The languages.

See Also

DataSource Class
GetLanguages Overload
Sitecore.Data Namespace


GetLatestVersion Method

[image]

Sitecore 6.4.1 API
DataSource..::..GetLatestVersion Method
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Version GetLatestVersion(
    ID itemID,
    Language language
)
Visual Basic
Public Function GetLatestVersion ( _
    itemID As ID, _
    language As Language _
) As Version
Visual C++
public:
Version^ GetLatestVersion(
    ID^ itemID,
    Language^ language
)

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.
language
Type: Sitecore.Globalization..::..Language
The language.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataSource.GetLatestVersion(Sitecore.Data.ID,Sitecore.Globalization.Language)"]

See Also

DataSource Class
Sitecore.Data Namespace


GetParentID Method

[image]

Sitecore 6.4.1 API
DataSource..::..GetParentID Method
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ID GetParentID(
    ID itemID
)
Visual Basic
Public Overridable Function GetParentID ( _
    itemID As ID _
) As ID
Visual C++
public:
virtual ID^ GetParentID(
    ID^ itemID
)

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataSource.GetParentID(Sitecore.Data.ID)"]

See Also

DataSource Class
Sitecore.Data Namespace


GetProperty Method

[image]

Sitecore 6.4.1 API
DataSource..::..GetProperty Method
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetProperty(
    string name
)
Visual Basic
Public Function GetProperty ( _
    name As String _
) As String
Visual C++
public:
String^ GetProperty(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

Return Value

The property.

See Also

DataSource Class
Sitecore.Data Namespace


GetPropertyKeys Method

[image]

Sitecore 6.4.1 API
DataSource..::..GetPropertyKeys Method
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public List<string> GetPropertyKeys(
    string prefix
)
Visual Basic
Public Function GetPropertyKeys ( _
    prefix As String _
) As List(Of String)
Visual C++
public:
List<String^>^ GetPropertyKeys(
    String^ prefix
)

Parameters

prefix
Type: System..::..String
The prefix.

Return Value

The property.

See Also

DataSource Class
Sitecore.Data Namespace


GetPublishQueue Method

[image]

Sitecore 6.4.1 API
DataSource..::..GetPublishQueue Method
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IDList GetPublishQueue(
    DateTime from,
    DateTime to
)
Visual Basic
Public Function GetPublishQueue ( _
    from As DateTime, _
    to As DateTime _
) As IDList
Visual C++
public:
IDList^ GetPublishQueue(
    DateTime from,
    DateTime to
)

Parameters

from
Type: System..::..DateTime
From.
to
Type: System..::..DateTime
To.

Return Value

The publish queue.

See Also

DataSource Class
Sitecore.Data Namespace


GetRootID Method

[image]

Sitecore 6.4.1 API
DataSource..::..GetRootID Method
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID GetRootID()
Visual Basic
Public Function GetRootID As ID
Visual C++
public:
ID^ GetRootID()

Return Value

The root ID.

See Also

DataSource Class
Sitecore.Data Namespace


GetTemplate Method

[image] [image]

Sitecore 6.4.1 API
DataSource..::..GetTemplate Method
DataSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTemplate(String) | Gets the template.
Public method | GetTemplate(ID) | Gets the template.

See Also

DataSource Class
DataSource Members
Sitecore.Data Namespace


GetTemplate Method (String)

[image]

Sitecore 6.4.1 API
DataSource..::..GetTemplate Method (String)
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Template GetTemplate(
    string fullName
)
Visual Basic
Public Function GetTemplate ( _
    fullName As String _
) As Template
Visual C++
public:
Template^ GetTemplate(
    String^ fullName
)

Parameters

fullName
Type: System..::..String
The full name.

Return Value

The template.

See Also

DataSource Class
GetTemplate Overload
Sitecore.Data Namespace


GetTemplate Method (ID)

[image]

Sitecore 6.4.1 API
DataSource..::..GetTemplate Method (ID)
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Template GetTemplate(
    ID templateId
)
Visual Basic
Public Function GetTemplate ( _
    templateId As ID _
) As Template
Visual C++
public:
Template^ GetTemplate(
    ID^ templateId
)

Parameters

templateId
Type: Sitecore.Data..::..ID
The template id.

Return Value

The template.

See Also

DataSource Class
GetTemplate Overload
Sitecore.Data Namespace


GetTemplateIds Method

[image]

Sitecore 6.4.1 API
DataSource..::..GetTemplateIds Method
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IdCollection GetTemplateIds()
Visual Basic
Public Function GetTemplateIds As IdCollection
Visual C++
public:
IdCollection^ GetTemplateIds()

Return Value

The template ids.

See Also

DataSource Class
Sitecore.Data Namespace


GetTemplates Method

[image]

Sitecore 6.4.1 API
DataSource..::..GetTemplates Method
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateCollection GetTemplates()
Visual Basic
Public Function GetTemplates As TemplateCollection
Visual C++
public:
TemplateCollection^ GetTemplates()

Return Value

The templates.

See Also

DataSource Class
Sitecore.Data Namespace


GetVersions Method

[image] [image]

Sitecore 6.4.1 API
DataSource..::..GetVersions Method
DataSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetVersions(ID, Language) | Gets the versions.
Public method | GetVersions(ItemInformation, Language) | Gets the versions.

See Also

DataSource Class
DataSource Members
Sitecore.Data Namespace


GetVersions Method (ID, Language)

[image]

Sitecore 6.4.1 API
DataSource..::..GetVersions Method (ID, Language)
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public VersionList GetVersions(
    ID itemID,
    Language language
)
Visual Basic
Public Function GetVersions ( _
    itemID As ID, _
    language As Language _
) As VersionList
Visual C++
public:
VersionList^ GetVersions(
    ID^ itemID,
    Language^ language
)

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.
language
Type: Sitecore.Globalization..::..Language
The language.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataSource.GetVersions(Sitecore.Data.ID,Sitecore.Globalization.Language)"]

See Also

DataSource Class
GetVersions Overload
Sitecore.Data Namespace


GetVersions Method (ItemInformation, Language)

[image]

Sitecore 6.4.1 API
DataSource..::..GetVersions Method (ItemInformation, Language)
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public VersionCollection GetVersions(
    ItemInformation itemInformation,
    Language language
)
Visual Basic
Public Function GetVersions ( _
    itemInformation As ItemInformation, _
    language As Language _
) As VersionCollection
Visual C++
public:
VersionCollection^ GetVersions(
    ItemInformation^ itemInformation,
    Language^ language
)

Parameters

itemInformation
Type: Sitecore.Data..::..ItemInformation
The item information.
language
Type: Sitecore.Globalization..::..Language
The language.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataSource.GetVersions(Sitecore.Data.ItemInformation,Sitecore.Globalization.Language)"]

See Also

DataSource Class
GetVersions Overload
Sitecore.Data Namespace


GetVersionUris Method

[image]

Sitecore 6.4.1 API
DataSource..::..GetVersionUris Method
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public VersionUriList GetVersionUris(
    ID itemID
)
Visual Basic
Public Function GetVersionUris ( _
    itemID As ID _
) As VersionUriList
Visual C++
public:
VersionUriList^ GetVersionUris(
    ID^ itemID
)

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataSource.GetVersionUris(Sitecore.Data.ID)"]

See Also

DataSource Class
Sitecore.Data Namespace


GetWorkflowInfo Method

[image]

Sitecore 6.4.1 API
DataSource..::..GetWorkflowInfo Method
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WorkflowInfo GetWorkflowInfo(
    ID itemID,
    Language language,
    Version version
)
Visual Basic
Public Function GetWorkflowInfo ( _
    itemID As ID, _
    language As Language, _
    version As Version _
) As WorkflowInfo
Visual C++
public:
WorkflowInfo^ GetWorkflowInfo(
    ID^ itemID,
    Language^ language,
    Version^ version
)

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.
language
Type: Sitecore.Globalization..::..Language
The language.
version
Type: Sitecore.Data..::..Version
The version.

Return Value

The workflow info.

See Also

DataSource Class
Sitecore.Data Namespace


HasChildren Method

[image]

Sitecore 6.4.1 API
DataSource..::..HasChildren Method
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool HasChildren(
    ID itemId
)
Visual Basic
Public Function HasChildren ( _
    itemId As ID _
) As Boolean
Visual C++
public:
bool HasChildren(
    ID^ itemId
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.

Return Value

The has children.

See Also

DataSource Class
Sitecore.Data Namespace


ItemExists Method

[image]

Sitecore 6.4.1 API
DataSource..::..ItemExists Method
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ItemExists(
    ID itemID
)
Visual Basic
Public Function ItemExists ( _
    itemID As ID _
) As Boolean
Visual C++
public:
bool ItemExists(
    ID^ itemID
)

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.

Return Value

The exists.

See Also

DataSource Class
Sitecore.Data Namespace


RemoveLanguageData Method

[image]

Sitecore 6.4.1 API
DataSource..::..RemoveLanguageData Method
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RemoveLanguageData(
    Language language
)
Visual Basic
Public Sub RemoveLanguageData ( _
    language As Language _
)
Visual C++
public:
void RemoveLanguageData(
    Language^ language
)

Parameters

language
Type: Sitecore.Globalization..::..Language
The language.

See Also

DataSource Class
Sitecore.Data Namespace


RemoveProperty Method

[image]

Sitecore 6.4.1 API
DataSource..::..RemoveProperty Method
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool RemoveProperty(
    string name,
    bool isPrefix
)
Visual Basic
Public Function RemoveProperty ( _
    name As String, _
    isPrefix As Boolean _
) As Boolean
Visual C++
public:
bool RemoveProperty(
    String^ name,
    bool isPrefix
)

Parameters

name
Type: System..::..String
The name.
isPrefix
Type: System..::..Boolean
if set to true this instance is is prefix.

Return Value

The property.

See Also

DataSource Class
Sitecore.Data Namespace


RemoveVersion Method

[image]

Sitecore 6.4.1 API
DataSource..::..RemoveVersion Method
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool RemoveVersion(
    ID itemID,
    VersionUri uri
)
Visual Basic
Public Function RemoveVersion ( _
    itemID As ID, _
    uri As VersionUri _
) As Boolean
Visual C++
public:
bool RemoveVersion(
    ID^ itemID,
    VersionUri^ uri
)

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.
uri
Type: Sitecore.Data..::..VersionUri
The URI.

Return Value

The version.

See Also

DataSource Class
Sitecore.Data Namespace


RemoveVersions Method

[image]

Sitecore 6.4.1 API
DataSource..::..RemoveVersions Method
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool RemoveVersions(
    ID itemID,
    Language language,
    bool removeSharedData
)
Visual Basic
Public Function RemoveVersions ( _
    itemID As ID, _
    language As Language, _
    removeSharedData As Boolean _
) As Boolean
Visual C++
public:
bool RemoveVersions(
    ID^ itemID,
    Language^ language,
    bool removeSharedData
)

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.
language
Type: Sitecore.Globalization..::..Language
The language.
removeSharedData
Type: System..::..Boolean
If set to true shared data is removed.

Return Value

The versions.

See Also

DataSource Class
Sitecore.Data Namespace


RenameLanguageData Method

[image]

Sitecore 6.4.1 API
DataSource..::..RenameLanguageData Method
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RenameLanguageData(
    string fromLanguage,
    string toLanguage
)
Visual Basic
Public Sub RenameLanguageData ( _
    fromLanguage As String, _
    toLanguage As String _
)
Visual C++
public:
void RenameLanguageData(
    String^ fromLanguage,
    String^ toLanguage
)

Parameters

fromLanguage
Type: System..::..String
Rename from this language name.
toLanguage
Type: System..::..String
Rename to this language name.

See Also

DataSource Class
Sitecore.Data Namespace


ResolvePath Method

[image]

Sitecore 6.4.1 API
DataSource..::..ResolvePath Method
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ResolvePath(
    string path
)
Visual Basic
Public Function ResolvePath ( _
    path As String _
) As ID
Visual C++
public:
ID^ ResolvePath(
    String^ path
)

Parameters

path
Type: System..::..String
The path.

Return Value

The path.

See Also

DataSource Class
Sitecore.Data Namespace


SaveItem Method

[image]

Sitecore 6.4.1 API
DataSource..::..SaveItem Method
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool SaveItem(
    ID itemID,
    ItemChanges changes
)
Visual Basic
Public Function SaveItem ( _
    itemID As ID, _
    changes As ItemChanges _
) As Boolean
Visual C++
public:
bool SaveItem(
    ID^ itemID,
    ItemChanges^ changes
)

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.
changes
Type: Sitecore.Data.Items..::..ItemChanges
The changes.

Return Value

The item.

See Also

DataSource Class
Sitecore.Data Namespace


SelectIDs Method

[image]

Sitecore 6.4.1 API
DataSource..::..SelectIDs Method
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IDList SelectIDs(
    string query
)
Visual Basic
Public Function SelectIDs ( _
    query As String _
) As IDList
Visual C++
public:
IDList^ SelectIDs(
    String^ query
)

Parameters

query
Type: System..::..String
The query.

Return Value

The I ds.

See Also

DataSource Class
Sitecore.Data Namespace


SetBlobStream Method

[image]

Sitecore 6.4.1 API
DataSource..::..SetBlobStream Method
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool SetBlobStream(
    Stream stream,
    Guid blobId
)
Visual Basic
Public Function SetBlobStream ( _
    stream As Stream, _
    blobId As Guid _
) As Boolean
Visual C++
public:
bool SetBlobStream(
    Stream^ stream,
    Guid blobId
)

Parameters

stream
Type: System.IO..::..Stream
The stream.
blobId
Type: System..::..Guid
The BLOB id.

Return Value

The set blob stream.

See Also

DataSource Class
Sitecore.Data Namespace


SetProperty Method

[image]

Sitecore 6.4.1 API
DataSource..::..SetProperty Method
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool SetProperty(
    string name,
    string value
)
Visual Basic
Public Function SetProperty ( _
    name As String, _
    value As String _
) As Boolean
Visual C++
public:
bool SetProperty(
    String^ name,
    String^ value
)

Parameters

name
Type: System..::..String
The name.
value
Type: System..::..String
The value.

Return Value

The property.

See Also

DataSource Class
Sitecore.Data Namespace


SetWorkflowInfo Method

[image] [image]

Sitecore 6.4.1 API
DataSource..::..SetWorkflowInfo Method
DataSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetWorkflowInfo(ItemDefinition, VersionUri, WorkflowInfo) | Sets the workflow info.
Public method | SetWorkflowInfo(ID, Language, Version, WorkflowInfo) | Sets the workflow info.

See Also

DataSource Class
DataSource Members
Sitecore.Data Namespace


SetWorkflowInfo Method (ItemDefinition, VersionUri, WorkflowInfo)

[image]

Sitecore 6.4.1 API
DataSource..::..SetWorkflowInfo Method (ItemDefinition, VersionUri, WorkflowInfo)
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool SetWorkflowInfo(
    ItemDefinition item,
    VersionUri versionUri,
    WorkflowInfo info
)
Visual Basic
Public Function SetWorkflowInfo ( _
    item As ItemDefinition, _
    versionUri As VersionUri, _
    info As WorkflowInfo _
) As Boolean
Visual C++
public:
bool SetWorkflowInfo(
    ItemDefinition^ item,
    VersionUri^ versionUri,
    WorkflowInfo^ info
)

Parameters

item
Type: Sitecore.Data..::..ItemDefinition
The item.
versionUri
Type: Sitecore.Data..::..VersionUri
The version URI.
info
Type: Sitecore.Workflows..::..WorkflowInfo
The info.

Return Value

The workflow info.

See Also

DataSource Class
SetWorkflowInfo Overload
Sitecore.Data Namespace


SetWorkflowInfo Method (ID, Language, Version, WorkflowInfo)

[image]

Sitecore 6.4.1 API
DataSource..::..SetWorkflowInfo Method (ID, Language, Version, WorkflowInfo)
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool SetWorkflowInfo(
    ID itemID,
    Language language,
    Version version,
    WorkflowInfo info
)
Visual Basic
Public Function SetWorkflowInfo ( _
    itemID As ID, _
    language As Language, _
    version As Version, _
    info As WorkflowInfo _
) As Boolean
Visual C++
public:
bool SetWorkflowInfo(
    ID^ itemID,
    Language^ language,
    Version^ version,
    WorkflowInfo^ info
)

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.
language
Type: Sitecore.Globalization..::..Language
The language.
version
Type: Sitecore.Data..::..Version
The version.
info
Type: Sitecore.Workflows..::..WorkflowInfo
The info.

Return Value

The workflow info.

See Also

DataSource Class
SetWorkflowInfo Overload
Sitecore.Data Namespace


DataSource Properties

[image] [image]

Sitecore 6.4.1 API
DataSource Properties
DataSource Class See Also Send Feedback

The DataSource type exposes the following members.

Properties

 | Name | Description
Public property | DataManager | Gets the data manager.

See Also

DataSource Class
Sitecore.Data Namespace


DataManager Property

[image]

Sitecore 6.4.1 API
DataSource..::..DataManager Property
DataSource Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataManager DataManager { get; }
Visual Basic
Public ReadOnly Property DataManager As DataManager
    Get
Visual C++
public:
property DataManager^ DataManager {
    DataManager^ get ();
}

Field Value

The data manager.

See Also

DataSource Class
Sitecore.Data Namespace


DataUri Members

[image] [image]

Sitecore 6.4.1 API
DataUri Members
DataUri Class Constructors Methods Properties See Also Send Feedback

The DataUri type exposes the following members.

Constructors

 | Name | Description
Public method | DataUri(String) | Creates a new DataUri instance.
Public method | DataUri(DataUri) | Creates a new DataUri instance.
Public method | DataUri(ID) | Creates a new DataUri instance.
Public method | DataUri(ItemUri) | Creates a new DataUri instance.
Protected method | DataUri(SerializationInfo, StreamingContext) | Creates a new DataUri instance.
Public method | DataUri(String, Language) | Creates a new DataUri instance.
Public method | DataUri(ID, Language) | Creates a new DataUri instance.
Public method | DataUri(String, Language, Version) | Creates a new DataUri instance.
Public method | DataUri(ID, Language, Version) | Creates a new DataUri instance.

Methods

 | Name | Description
Public method | Clone | Clones this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Converts a string into a DataUri.
Public method | ToString()()()() | Returns the string presentation of a DataUri. (Overrides Object..::..ToString()()()().)
Public method | ToString(Boolean) | Returns the string presentation of a DataUri.

Properties

 | Name | Description
Public property | ItemID | Gets the item ID.
Public property | Language | Gets the language.
Public property | Path | Gets or sets the path.
Public property | Version | Gets the version.

See Also

DataUri Class
Sitecore.Data Namespace


DataUri Constructor

[image] [image]

Sitecore 6.4.1 API
DataUri Constructor
DataUri Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DataUri(String) | Creates a new DataUri instance.
Public method | DataUri(DataUri) | Creates a new DataUri instance.
Public method | DataUri(ID) | Creates a new DataUri instance.
Public method | DataUri(ItemUri) | Creates a new DataUri instance.
Protected method | DataUri(SerializationInfo, StreamingContext) | Creates a new DataUri instance.
Public method | DataUri(String, Language) | Creates a new DataUri instance.
Public method | DataUri(ID, Language) | Creates a new DataUri instance.
Public method | DataUri(String, Language, Version) | Creates a new DataUri instance.
Public method | DataUri(ID, Language, Version) | Creates a new DataUri instance.

See Also

DataUri Class
DataUri Members
Sitecore.Data Namespace


DataUri Constructor (String)

[image]

Sitecore 6.4.1 API
DataUri Constructor (String)
DataUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataUri(
    string dataUri
)
Visual Basic
Public Sub New ( _
    dataUri As String _
)
Visual C++
public:
DataUri(
    String^ dataUri
)

Parameters

dataUri
Type: System..::..String
Data URI.

See Also

DataUri Class
DataUri Overload
Sitecore.Data Namespace


DataUri Constructor (DataUri)

[image]

Sitecore 6.4.1 API
DataUri Constructor (DataUri)
DataUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataUri(
    DataUri uri
)
Visual Basic
Public Sub New ( _
    uri As DataUri _
)
Visual C++
public:
DataUri(
    DataUri^ uri
)

Parameters

uri
Type: Sitecore.Data..::..DataUri
URI.

See Also

DataUri Class
DataUri Overload
Sitecore.Data Namespace


DataUri Constructor (ID)

[image]

Sitecore 6.4.1 API
DataUri Constructor (ID)
DataUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataUri(
    ID itemID
)
Visual Basic
Public Sub New ( _
    itemID As ID _
)
Visual C++
public:
DataUri(
    ID^ itemID
)

Parameters

itemID
Type: Sitecore.Data..::..ID
Item ID.

See Also

DataUri Class
DataUri Overload
Sitecore.Data Namespace


DataUri Constructor (ItemUri)

[image]

Sitecore 6.4.1 API
DataUri Constructor (ItemUri)
DataUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataUri(
    ItemUri uri
)
Visual Basic
Public Sub New ( _
    uri As ItemUri _
)
Visual C++
public:
DataUri(
    ItemUri^ uri
)

Parameters

uri
Type: Sitecore.Data..::..ItemUri
URI.

See Also

DataUri Class
DataUri Overload
Sitecore.Data Namespace


DataUri Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
DataUri Constructor (SerializationInfo, StreamingContext)
DataUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected DataUri(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
DataUri(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Info.
context
Type: System.Runtime.Serialization..::..StreamingContext
Context.

See Also

DataUri Class
DataUri Overload
Sitecore.Data Namespace


DataUri Constructor (String, Language)

[image]

Sitecore 6.4.1 API
DataUri Constructor (String, Language)
DataUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataUri(
    string path,
    Language language
)
Visual Basic
Public Sub New ( _
    path As String, _
    language As Language _
)
Visual C++
public:
DataUri(
    String^ path,
    Language^ language
)

Parameters

path
Type: System..::..String
Path.
language
Type: Sitecore.Globalization..::..Language
Language.

See Also

DataUri Class
DataUri Overload
Sitecore.Data Namespace


DataUri Constructor (String, Language, Version)

[image]

Sitecore 6.4.1 API
DataUri Constructor (String, Language, Version)
DataUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataUri(
    string path,
    Language language,
    Version version
)
Visual Basic
Public Sub New ( _
    path As String, _
    language As Language, _
    version As Version _
)
Visual C++
public:
DataUri(
    String^ path,
    Language^ language,
    Version^ version
)

Parameters

path
Type: System..::..String
Path.
language
Type: Sitecore.Globalization..::..Language
Language.
version
Type: Sitecore.Data..::..Version
Version.

See Also

DataUri Class
DataUri Overload
Sitecore.Data Namespace


DataUri Constructor (ID, Language, Version)

[image]

Sitecore 6.4.1 API
DataUri Constructor (ID, Language, Version)
DataUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataUri(
    ID itemID,
    Language language,
    Version version
)
Visual Basic
Public Sub New ( _
    itemID As ID, _
    language As Language, _
    version As Version _
)
Visual C++
public:
DataUri(
    ID^ itemID,
    Language^ language,
    Version^ version
)

Parameters

itemID
Type: Sitecore.Data..::..ID
Item ID.
language
Type: Sitecore.Globalization..::..Language
Language.
version
Type: Sitecore.Data..::..Version
Version.

See Also

DataUri Class
DataUri Overload
Sitecore.Data Namespace


DataUri Methods

[image] [image]

Sitecore 6.4.1 API
DataUri Methods
DataUri Class See Also Send Feedback

The DataUri type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Converts a string into a DataUri.
Public method | ToString()()()() | Returns the string presentation of a DataUri. (Overrides Object..::..ToString()()()().)
Public method | ToString(Boolean) | Returns the string presentation of a DataUri.

See Also

DataUri Class
Sitecore.Data Namespace


Clone Method

[image]

Sitecore 6.4.1 API
DataUri..::..Clone Method
DataUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object
Visual C++
public:
virtual Object^ Clone() sealed

Return Value

A new object that is a copy of this instance.

Implements

ICloneable..::..Clone()()()()

See Also

DataUri Class
Sitecore.Data Namespace


Parse Method

[image]

Sitecore 6.4.1 API
DataUri..::..Parse Method
DataUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static DataUri Parse(
    string dataUri
)
Visual Basic
Public Shared Function Parse ( _
    dataUri As String _
) As DataUri
Visual C++
public:
static DataUri^ Parse(
    String^ dataUri
)

Parameters

dataUri
Type: System..::..String
Data URI.

Return Value

The parse.

See Also

DataUri Class
Sitecore.Data Namespace


ToString Method

[image] [image]

Sitecore 6.4.1 API
DataUri..::..ToString Method
DataUri Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Returns the string presentation of a DataUri. (Overrides Object..::..ToString()()()().)
Public method | ToString(Boolean) | Returns the string presentation of a DataUri.

See Also

DataUri Class
DataUri Members
Sitecore.Data Namespace


ToString Method

[image]

Sitecore 6.4.1 API
DataUri..::..ToString Method
DataUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

DataUri Class
ToString Overload
Sitecore.Data Namespace


ToString Method (Boolean)

[image]

Sitecore 6.4.1 API
DataUri..::..ToString Method (Boolean)
DataUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ToString(
    bool shortFormat
)
Visual Basic
Public Function ToString ( _
    shortFormat As Boolean _
) As String
Visual C++
public:
String^ ToString(
    bool shortFormat
)

Parameters

shortFormat
Type: System..::..Boolean
if set to true this instance is short format.

Return Value

The string.

See Also

DataUri Class
ToString Overload
Sitecore.Data Namespace


DataUri Properties

[image] [image]

Sitecore 6.4.1 API
DataUri Properties
DataUri Class See Also Send Feedback

The DataUri type exposes the following members.

Properties

 | Name | Description
Public property | ItemID | Gets the item ID.
Public property | Language | Gets the language.
Public property | Path | Gets or sets the path.
Public property | Version | Gets the version.

See Also

DataUri Class
Sitecore.Data Namespace


ItemID Property

[image]

Sitecore 6.4.1 API
DataUri..::..ItemID Property
DataUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ItemID { get; }
Visual Basic
Public ReadOnly Property ItemID As ID
    Get
Visual C++
public:
property ID^ ItemID {
    ID^ get ();
}

Field Value

The item ID.

See Also

DataUri Class
Sitecore.Data Namespace


Language Property

[image]

Sitecore 6.4.1 API
DataUri..::..Language Property
DataUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Language Language { get; }
Visual Basic
Public ReadOnly Property Language As Language
    Get
Visual C++
public:
property Language^ Language {
    Language^ get ();
}

Field Value

The language.

See Also

DataUri Class
Sitecore.Data Namespace


Path Property

[image]

Sitecore 6.4.1 API
DataUri..::..Path Property
DataUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Path { get; set; }
Visual Basic
Public Property Path As String
    Get
    Set
Visual C++
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}

Field Value

The path.

See Also

DataUri Class
Sitecore.Data Namespace


Version Property

[image]

Sitecore 6.4.1 API
DataUri..::..Version Property
DataUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Version Version { get; }
Visual Basic
Public ReadOnly Property Version As Version
    Get
Visual C++
public:
property Version^ Version {
    Version^ get ();
}

Field Value

The version.

See Also

DataUri Class
Sitecore.Data Namespace


DeviceRecords Class

[image]

Sitecore 6.4.1 API
DeviceRecords Class
Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DeviceRecords : Database..::..DataRecords
Visual Basic
Public Class DeviceRecords _
    Inherits Database..::..DataRecords
Visual C++
public ref class DeviceRecords : public Database..::..DataRecords

Remarks

Devices are configured in /sitecore/layouts/Layout/Devices.

The devices are normally access through the Devices property.

Inheritance Hierarchy

System..::..Object
Sitecore.Data..::..Database..::..DataRecords
Sitecore.Data..::..DeviceRecords

See Also

DeviceRecords Members
Sitecore.Data Namespace


DeviceRecords Members

[image] [image]

Sitecore 6.4.1 API
DeviceRecords Members
DeviceRecords Class Constructors Methods Properties See Also Send Feedback

The DeviceRecords type exposes the following members.

Constructors

 | Name | Description
Public method | DeviceRecords | Creates a new DeviceRecords instance.

Methods

 | Name | Description
Protected method | DoGetItem(String) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(DataUri) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(String, Language) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID, Language) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(String, Language, Version) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID, Language, Version) | Gets the item. (Inherited from Database..::..DataRecords.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists(DataUri) | Gets a value that indicates if the data URI exists in the database. (Inherited from Database..::..DataRecords.)
Public method | Exists(ID) | Gets a value that indicates if the item ID exists in the database. (Inherited from Database..::..DataRecords.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAll | Gets all the devices defined by the database.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniquePath | Gets a unique path of an item in the database. (Inherited from Database..::..DataRecords.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BasePath | Gets the base path. (Inherited from Database..::..DataRecords.)
Public property | Database | Gets the database. (Inherited from Database..::..DataRecords.)
Public property | Item[([( String])]) | Gets the DeviceItem with the specified item path.
Public property | Item[([( DataUri])]) | Gets the DeviceItem with the specified URI.
Public property | Item[([( ID])]) | Gets the DeviceItem with the specified item ID.

See Also

DeviceRecords Class
Sitecore.Data Namespace


DeviceRecords Constructor

[image]

Sitecore 6.4.1 API
DeviceRecords Constructor
DeviceRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DeviceRecords(
    Database database
)
Visual Basic
Public Sub New ( _
    database As Database _
)
Visual C++
public:
DeviceRecords(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
Database.

See Also

DeviceRecords Class
Sitecore.Data Namespace


DeviceRecords Methods

[image] [image]

Sitecore 6.4.1 API
DeviceRecords Methods
DeviceRecords Class See Also Send Feedback

The DeviceRecords type exposes the following members.

Methods

 | Name | Description
Protected method | DoGetItem(String) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(DataUri) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(String, Language) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID, Language) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(String, Language, Version) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID, Language, Version) | Gets the item. (Inherited from Database..::..DataRecords.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists(DataUri) | Gets a value that indicates if the data URI exists in the database. (Inherited from Database..::..DataRecords.)
Public method | Exists(ID) | Gets a value that indicates if the item ID exists in the database. (Inherited from Database..::..DataRecords.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAll | Gets all the devices defined by the database.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniquePath | Gets a unique path of an item in the database. (Inherited from Database..::..DataRecords.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DeviceRecords Class
Sitecore.Data Namespace


DoGetItem Method

[image] [image]

Sitecore 6.4.1 API
DeviceRecords..::..DoGetItem Method
DeviceRecords Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | DoGetItem(String) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(DataUri) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(String, Language) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID, Language) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(String, Language, Version) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID, Language, Version) | Gets the item. (Inherited from Database..::..DataRecords.)

See Also

DeviceRecords Class
DeviceRecords Members
Sitecore.Data Namespace


Exists Method

[image] [image]

Sitecore 6.4.1 API
DeviceRecords..::..Exists Method
DeviceRecords Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Exists(DataUri) | Gets a value that indicates if the data URI exists in the database. (Inherited from Database..::..DataRecords.)
Public method | Exists(ID) | Gets a value that indicates if the item ID exists in the database. (Inherited from Database..::..DataRecords.)

See Also

DeviceRecords Class
DeviceRecords Members
Sitecore.Data Namespace


GetAll Method

[image]

Sitecore 6.4.1 API
DeviceRecords..::..GetAll Method
DeviceRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DeviceItem[] GetAll()
Visual Basic
Public Function GetAll As DeviceItem()
Visual C++
public:
array<DeviceItem^>^ GetAll()

Return Value

The all.

See Also

DeviceRecords Class
Sitecore.Data Namespace


Item Property

[image] [image]

Sitecore 6.4.1 API
DeviceRecords..::..Item Property
DeviceRecords Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( String])]) | Gets the DeviceItem with the specified item path.
Public property | Item[([( DataUri])]) | Gets the DeviceItem with the specified URI.
Public property | Item[([( ID])]) | Gets the DeviceItem with the specified item ID.

See Also

DeviceRecords Class
DeviceRecords Members
Sitecore.Data Namespace


Item Property (String)

[image]

Sitecore 6.4.1 API
DeviceRecords..::..Item Property (String)
DeviceRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DeviceItem this[
    string itemPath
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    itemPath As String _
) As DeviceItem
    Get
Visual C++
public:
property DeviceItem^ default[String^ itemPath] {
    DeviceItem^ get (String^ itemPath);
}

Parameters

itemPath
Type: System..::..String

See Also

DeviceRecords Class
Item Overload
Sitecore.Data Namespace


Item Property (DataUri)

[image]

Sitecore 6.4.1 API
DeviceRecords..::..Item Property (DataUri)
DeviceRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DeviceItem this[
    DataUri uri
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    uri As DataUri _
) As DeviceItem
    Get
Visual C++
public:
property DeviceItem^ default[DataUri^ uri] {
    DeviceItem^ get (DataUri^ uri);
}

Parameters

uri
Type: Sitecore.Data..::..DataUri

See Also

DeviceRecords Class
Item Overload
Sitecore.Data Namespace


Item Property (ID)

[image]

Sitecore 6.4.1 API
DeviceRecords..::..Item Property (ID)
DeviceRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DeviceItem this[
    ID itemID
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    itemID As ID _
) As DeviceItem
    Get
Visual C++
public:
property DeviceItem^ default[ID^ itemID] {
    DeviceItem^ get (ID^ itemID);
}

Parameters

itemID
Type: Sitecore.Data..::..ID

See Also

DeviceRecords Class
Item Overload
Sitecore.Data Namespace


FieldDescriptor Class

[image]

Sitecore 6.4.1 API
FieldDescriptor Class
Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FieldDescriptor
Visual Basic
Public Class FieldDescriptor
Visual C++
public ref class FieldDescriptor

Inheritance Hierarchy

System..::..Object
Sitecore.Data..::..FieldDescriptor

See Also

FieldDescriptor Members
Sitecore.Data Namespace


FieldDescriptor Members

[image] [image]

Sitecore 6.4.1 API
FieldDescriptor Members
FieldDescriptor Class Constructors Methods Properties See Also Send Feedback

The FieldDescriptor type exposes the following members.

Constructors

 | Name | Description
Public method | FieldDescriptor(Item, String) | Initializes a new instance of the FieldDescriptor class.
Public method | FieldDescriptor(ItemUri, ID, String, Boolean) | Initializes a new instance of the FieldDescriptor class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Parses the specified field URI.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | ContainsStandardValue | Gets or sets a value indicating whether [contains standard value].
Public property | FieldID | Gets the field ID.
Public property | ItemUri | Gets the item URI.
Public property | Value | Gets or sets the value.

See Also

FieldDescriptor Class
Sitecore.Data Namespace


FieldDescriptor Constructor

[image] [image]

Sitecore 6.4.1 API
FieldDescriptor Constructor
FieldDescriptor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FieldDescriptor(Item, String) | Initializes a new instance of the FieldDescriptor class.
Public method | FieldDescriptor(ItemUri, ID, String, Boolean) | Initializes a new instance of the FieldDescriptor class.

See Also

FieldDescriptor Class
FieldDescriptor Members
Sitecore.Data Namespace


FieldDescriptor Constructor (Item, String)

[image]

Sitecore 6.4.1 API
FieldDescriptor Constructor (Item, String)
FieldDescriptor Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FieldDescriptor(
    Item item,
    string fieldName
)
Visual Basic
Public Sub New ( _
    item As Item, _
    fieldName As String _
)
Visual C++
public:
FieldDescriptor(
    Item^ item,
    String^ fieldName
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
fieldName
Type: System..::..String
The field name

See Also

FieldDescriptor Class
FieldDescriptor Overload
Sitecore.Data Namespace


FieldDescriptor Constructor (ItemUri, ID, String, Boolean)

[image]

Sitecore 6.4.1 API
FieldDescriptor Constructor (ItemUri, ID, String, Boolean)
FieldDescriptor Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FieldDescriptor(
    ItemUri itemUri,
    ID fieldID,
    string value,
    bool containsStandardValue
)
Visual Basic
Public Sub New ( _
    itemUri As ItemUri, _
    fieldID As ID, _
    value As String, _
    containsStandardValue As Boolean _
)
Visual C++
public:
FieldDescriptor(
    ItemUri^ itemUri,
    ID^ fieldID,
    String^ value,
    bool containsStandardValue
)

Parameters

itemUri
Type: Sitecore.Data..::..ItemUri
The item URI.
fieldID
Type: Sitecore.Data..::..ID
The field ID.
value
Type: System..::..String
The value.
containsStandardValue
Type: System..::..Boolean
if set to true [contains standard value].

See Also

FieldDescriptor Class
FieldDescriptor Overload
Sitecore.Data Namespace


FieldDescriptor Methods

[image] [image]

Sitecore 6.4.1 API
FieldDescriptor Methods
FieldDescriptor Class See Also Send Feedback

The FieldDescriptor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Parses the specified field URI.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

FieldDescriptor Class
Sitecore.Data Namespace


Equals Method

[image]

Sitecore 6.4.1 API
FieldDescriptor..::..Equals Method
FieldDescriptor Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Exceptions

Exception | Condition
System..::..NullReferenceException | The obj parameter is null.

See Also

FieldDescriptor Class
Sitecore.Data Namespace


Parse Method

[image]

Sitecore 6.4.1 API
FieldDescriptor..::..Parse Method
FieldDescriptor Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static FieldDescriptor Parse(
    string fieldUri
)
Visual Basic
Public Shared Function Parse ( _
    fieldUri As String _
) As FieldDescriptor
Visual C++
public:
static FieldDescriptor^ Parse(
    String^ fieldUri
)

Parameters

fieldUri
Type: System..::..String
The field URI.

Return Value

The field URI.

See Also

FieldDescriptor Class
Sitecore.Data Namespace


ToString Method

[image]

Sitecore 6.4.1 API
FieldDescriptor..::..ToString Method
FieldDescriptor Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

FieldDescriptor Class
Sitecore.Data Namespace


FieldDescriptor Properties

[image] [image]

Sitecore 6.4.1 API
FieldDescriptor Properties
FieldDescriptor Class See Also Send Feedback

The FieldDescriptor type exposes the following members.

Properties

 | Name | Description
Public property | ContainsStandardValue | Gets or sets a value indicating whether [contains standard value].
Public property | FieldID | Gets the field ID.
Public property | ItemUri | Gets the item URI.
Public property | Value | Gets or sets the value.

See Also

FieldDescriptor Class
Sitecore.Data Namespace


ContainsStandardValue Property

[image]

Sitecore 6.4.1 API
FieldDescriptor..::..ContainsStandardValue Property
FieldDescriptor Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ContainsStandardValue { get; set; }
Visual Basic
Public Property ContainsStandardValue As Boolean
    Get
    Set
Visual C++
public:
property bool ContainsStandardValue {
    bool get ();
    void set (bool value);
}

Field Value

true if [contains standard value]; otherwise, false.

See Also

FieldDescriptor Class
Sitecore.Data Namespace


FieldID Property

[image]

Sitecore 6.4.1 API
FieldDescriptor..::..FieldID Property
FieldDescriptor Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID FieldID { get; }
Visual Basic
Public ReadOnly Property FieldID As ID
    Get
Visual C++
public:
property ID^ FieldID {
    ID^ get ();
}

Field Value

The field ID.

See Also

FieldDescriptor Class
Sitecore.Data Namespace


ItemUri Property

[image]

Sitecore 6.4.1 API
FieldDescriptor..::..ItemUri Property
FieldDescriptor Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemUri ItemUri { get; }
Visual Basic
Public ReadOnly Property ItemUri As ItemUri
    Get
Visual C++
public:
property ItemUri^ ItemUri {
    ItemUri^ get ();
}

Field Value

The item URI.

See Also

FieldDescriptor Class
Sitecore.Data Namespace


Value Property

[image]

Sitecore 6.4.1 API
FieldDescriptor..::..Value Property
FieldDescriptor Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Field Value

The value.

See Also

FieldDescriptor Class
Sitecore.Data Namespace


FieldList Class

[image]

Sitecore 6.4.1 API
FieldList Class
Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FieldList : IEnumerable
Visual Basic
Public Class FieldList _
    Implements IEnumerable
Visual C++
public ref class FieldList : IEnumerable

Inheritance Hierarchy

System..::..Object
Sitecore.Data..::..FieldList

See Also

FieldList Members
Sitecore.Data Namespace


FieldList Members

[image] [image]

Sitecore 6.4.1 API
FieldList Members
FieldList Class Constructors Methods Properties See Also Send Feedback

The FieldList type exposes the following members.

Constructors

 | Name | Description
Public method | FieldList | Initializes a new instance of the FieldList class

Methods

 | Name | Description
 | Add(FieldList, FieldList) | Joins the specified lists of fields.
Public method | Add(ID, String) | Adds the specified field ID.
Public method | Clear | Clears this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDataLength | Gets the size of the data to use when caching.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection (yielding KeyValuePair{ID, string}).
Public method | GetFieldIDs | Gets the field Ids.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the count.
Public property | FieldValues | Gets the fields.
Public property | Item | Gets the String with the specified field ID.
Public property | SyncRoot | Gets the sync root.

See Also

FieldList Class
Sitecore.Data Namespace


FieldList Constructor

[image]

Sitecore 6.4.1 API
FieldList Constructor
FieldList Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FieldList()
Visual Basic
Public Sub New
Visual C++
public:
FieldList()

See Also

FieldList Class
Sitecore.Data Namespace


FieldList Methods

[image] [image]

Sitecore 6.4.1 API
FieldList Methods
FieldList Class See Also Send Feedback

The FieldList type exposes the following members.

Methods

 | Name | Description
 | Add(FieldList, FieldList) | Joins the specified lists of fields.
Public method | Add(ID, String) | Adds the specified field ID.
Public method | Clear | Clears this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDataLength | Gets the size of the data to use when caching.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection (yielding KeyValuePair{ID, string}).
Public method | GetFieldIDs | Gets the field Ids.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldList Class
Sitecore.Data Namespace


Add Method

[image] [image]

Sitecore 6.4.1 API
FieldList..::..Add Method
FieldList Class See Also Send Feedback

Overload List

 | Name | Description
 | Add(FieldList, FieldList) | Joins the specified lists of fields.
Public method | Add(ID, String) | Adds the specified field ID.

See Also

FieldList Class
FieldList Members
Sitecore.Data Namespace


Add Method (FieldList, FieldList)

[image]

Sitecore 6.4.1 API
FieldList..::..Add Method (FieldList, FieldList)
FieldList Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static FieldList Add(
    FieldList list1,
    FieldList list2
)
Visual Basic
Public Shared Function Add ( _
    list1 As FieldList, _
    list2 As FieldList _
) As FieldList
Visual C++
public:
static FieldList^ Add(
    FieldList^ list1,
    FieldList^ list2
)

Parameters

list1
Type: Sitecore.Data..::..FieldList
The first list.
list2
Type: Sitecore.Data..::..FieldList
The second list.

Return Value

The joined lists.

See Also

FieldList Class
Add Overload
Sitecore.Data Namespace


Add Method (ID, String)

[image]

Sitecore 6.4.1 API
FieldList..::..Add Method (ID, String)
FieldList Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Add(
    ID fieldId,
    string value
)
Visual Basic
Public Sub Add ( _
    fieldId As ID, _
    value As String _
)
Visual C++
public:
void Add(
    ID^ fieldId,
    String^ value
)

Parameters

fieldId
Type: Sitecore.Data..::..ID
The field ID.
value
Type: System..::..String
The value.

See Also

FieldList Class
Add Overload
Sitecore.Data Namespace


Clear Method

[image]

Sitecore 6.4.1 API
FieldList..::..Clear Method
FieldList Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

FieldList Class
Sitecore.Data Namespace


GetDataLength Method

[image]

Sitecore 6.4.1 API
FieldList..::..GetDataLength Method
FieldList Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long GetDataLength()
Visual Basic
Public Function GetDataLength As Long
Visual C++
public:
long long GetDataLength()

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.FieldList.GetDataLength"]

See Also

FieldList Class
Sitecore.Data Namespace


GetEnumerator Method

[image]

Sitecore 6.4.1 API
FieldList..::..GetEnumerator Method
FieldList Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator() sealed

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

FieldList Class
Sitecore.Data Namespace


GetFieldIDs Method

[image]

Sitecore 6.4.1 API
FieldList..::..GetFieldIDs Method
FieldList Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID[] GetFieldIDs()
Visual Basic
Public Function GetFieldIDs As ID()
Visual C++
public:
array<ID^>^ GetFieldIDs()

Return Value

The field Ids.

See Also

FieldList Class
Sitecore.Data Namespace


FieldList Properties

[image] [image]

Sitecore 6.4.1 API
FieldList Properties
FieldList Class See Also Send Feedback

The FieldList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the count.
Public property | FieldValues | Gets the fields.
Public property | Item | Gets the String with the specified field ID.
Public property | SyncRoot | Gets the sync root.

See Also

FieldList Class
Sitecore.Data Namespace


Count Property

[image]

Sitecore 6.4.1 API
FieldList..::..Count Property
FieldList Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
property int Count {
    int get ();
}

Field Value

The count.

See Also

FieldList Class
Sitecore.Data Namespace


FieldValues Property

[image]

Sitecore 6.4.1 API
FieldList..::..FieldValues Property
FieldList Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HashList<ID, string> FieldValues { get; }
Visual Basic
Public ReadOnly Property FieldValues As HashList(Of ID, String)
    Get
Visual C++
public:
property HashList<ID^, String^>^ FieldValues {
    HashList<ID^, String^>^ get ();
}

Field Value

The fields.

See Also

FieldList Class
Sitecore.Data Namespace


Item Property

[image]

Sitecore 6.4.1 API
FieldList..::..Item Property
FieldList Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string this[
    ID fieldID
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    fieldID As ID _
) As String
    Get
Visual C++
public:
property String^ default[ID^ fieldID] {
    String^ get (ID^ fieldID);
}

Parameters

fieldID
Type: Sitecore.Data..::..ID

Field Value

The String.

See Also

FieldList Class
Sitecore.Data Namespace


SyncRoot Property

[image]

Sitecore 6.4.1 API
FieldList..::..SyncRoot Property
FieldList Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object SyncRoot { get; }
Visual Basic
Public ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
property Object^ SyncRoot {
    Object^ get ();
}

Field Value

The sync root.

See Also

FieldList Class
Sitecore.Data Namespace


ID Class

[image]

Sitecore 6.4.1 API
ID Class
Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class ID : ISerializable
Visual Basic
<SerializableAttribute> _
Public Class ID _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class ID : ISerializable

Remarks

In Sitecore an ID is a GUID.

The ID can be converted to a ShortID or a LongID.

Inheritance Hierarchy

System..::..Object
Sitecore.Data..::..ID

See Also

ID Members
Sitecore.Data Namespace


ID Members

[image] [image]

Sitecore 6.4.1 API
ID Members
ID Class Constructors Methods Operators Properties See Also Send Feedback

The ID type exposes the following members.

Constructors

 | Name | Description
Public method | ID(Guid) | Initializes an ID from a GUID.
Public method | ID(String) | Initializes an ID from a string.
Protected method | ID(SerializationInfo, StreamingContext) | Initializes a new instance of the ID class.

Methods

 | Name | Description
 | ArrayToString(array<ID>[]()[][]) | Arrays to string.
 | ArrayToString(array<ID>[]()[][], Char) | Arrays to string.
 | Decode | Converts a ShortID into a an ID.
 | Encode | Converts an ID to a ShortID.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDataLength | Gets the length of the data.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Overrides Object..::..GetHashCode()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsID | Tests if the string is a valid ID.
 | IsNullOrEmpty | Determines whether the specified id is null or empty.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse(Guid) | Converts a GUID to an ID.
 | Parse(Object) | Converts an object to an ID.
 | Parse(String) | Converts a string to an ID.
 | Parse(String, ID) | Converts a string to an ID.
 | ParseArray(String) | Converts a string of pipe separated IDs to an array of IDs.
 | ParseArray(String, Boolean) | Converts a string of pipe separated IDs to an array of IDs.
Public method | ToGuid | Gets the GUID represented by the ID.
Public method | ToShortID | Converts the ID to a ShortID.
Public method | ToString | Converts the ID to a string. (Overrides Object..::..ToString()()()().)
 | TryParse(Object, ID%) | Tries to parse a value.
 | TryParse(String, ID%) | Tries to parse a string value.

Operators

Name | Description
Equality(ID, ID) | Operator ==s the specified id1.
Equality(ID, ShortID) | Operator ==s the specified id1.
Equality(ShortID, ID) | Operator ==s the specified id1.
ImplicitWideningImplicitImplicitImplicit(BranchId to ID) | Implicit operators the specified master ID.
ImplicitWideningImplicitImplicitImplicit(TemplateID to ID) | Implicit operators the specified template ID.
Inequality(ID, ID) | Operator !=s the specified id1.
Inequality(ID, ShortID) | Operator !=s the specified id1.
Inequality(ShortID, ID) | Operator !=s the specified id1.

Properties

 | Name | Description
Public property | Guid | Gets the GUID represented by the ID.
Public property | IsGlobalNullId | Gets or sets a value indicating whether this instance is the global null id.
Public property | IsNull | Gets or sets a value indicating whether this instance is null.
 | NewID | Gets a new unique ID.
 | Null | Gets the Null ID.
 | Undefined | Gets the Undefined ID.

See Also

ID Class
Sitecore.Data Namespace


ID Constructor

[image] [image]

Sitecore 6.4.1 API
ID Constructor
ID Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ID(Guid) | Initializes an ID from a GUID.
Public method | ID(String) | Initializes an ID from a string.
Protected method | ID(SerializationInfo, StreamingContext) | Initializes a new instance of the ID class.

See Also

ID Class
ID Members
Sitecore.Data Namespace


ID Constructor (Guid)

[image]

Sitecore 6.4.1 API
ID Constructor (Guid)
ID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID(
    Guid id
)
Visual Basic
Public Sub New ( _
    id As Guid _
)
Visual C++
public:
ID(
    Guid id
)

Parameters

id
Type: System..::..Guid
The id.

See Also

ID Class
ID Overload
Sitecore.Data Namespace


ID Constructor (String)

[image]

Sitecore 6.4.1 API
ID Constructor (String)
ID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID(
    string id
)
Visual Basic
Public Sub New ( _
    id As String _
)
Visual C++
public:
ID(
    String^ id
)

Parameters

id
Type: System..::..String
The id.

Remarks

The string must be 38 characters long, start with a curly brace "{" and end with a curly brace "}".

See Also

ID Class
ID Overload
Sitecore.Data Namespace


ID Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
ID Constructor (SerializationInfo, StreamingContext)
ID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected ID(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
ID(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

ID Class
ID Overload
Sitecore.Data Namespace


ID Methods

[image] [image]

Sitecore 6.4.1 API
ID Methods
ID Class See Also Send Feedback

The ID type exposes the following members.

Methods

 | Name | Description
 | ArrayToString(array<ID>[]()[][]) | Arrays to string.
 | ArrayToString(array<ID>[]()[][], Char) | Arrays to string.
 | Decode | Converts a ShortID into a an ID.
 | Encode | Converts an ID to a ShortID.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDataLength | Gets the length of the data.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Overrides Object..::..GetHashCode()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsID | Tests if the string is a valid ID.
 | IsNullOrEmpty | Determines whether the specified id is null or empty.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse(Guid) | Converts a GUID to an ID.
 | Parse(Object) | Converts an object to an ID.
 | Parse(String) | Converts a string to an ID.
 | Parse(String, ID) | Converts a string to an ID.
 | ParseArray(String) | Converts a string of pipe separated IDs to an array of IDs.
 | ParseArray(String, Boolean) | Converts a string of pipe separated IDs to an array of IDs.
Public method | ToGuid | Gets the GUID represented by the ID.
Public method | ToShortID | Converts the ID to a ShortID.
Public method | ToString | Converts the ID to a string. (Overrides Object..::..ToString()()()().)
 | TryParse(Object, ID%) | Tries to parse a value.
 | TryParse(String, ID%) | Tries to parse a string value.

See Also

ID Class
Sitecore.Data Namespace


ArrayToString Method

[image] [image]

Sitecore 6.4.1 API
ID..::..ArrayToString Method
ID Class See Also Send Feedback

Overload List

Name | Description
ArrayToString(array<ID>[]()[][]) | Arrays to string.
ArrayToString(array<ID>[]()[][], Char) | Arrays to string.

See Also

ID Class
ID Members
Sitecore.Data Namespace


ArrayToString Method (ID[])

[image]

Sitecore 6.4.1 API
ID..::..ArrayToString Method (array<ID>[]()[][])
ID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ArrayToString(
    ID[] ids
)
Visual Basic
Public Shared Function ArrayToString ( _
    ids As ID() _
) As String
Visual C++
public:
static String^ ArrayToString(
    array<ID^>^ ids
)

Parameters

ids
Type: array< Sitecore.Data..::..ID >[]()[][]
The ids.

Return Value

The to string.

See Also

ID Class
ArrayToString Overload
Sitecore.Data Namespace


ArrayToString Method (ID[], Char)

[image]

Sitecore 6.4.1 API
ID..::..ArrayToString Method (array<ID>[]()[][], Char)
ID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ArrayToString(
    ID[] ids,
    char separator
)
Visual Basic
Public Shared Function ArrayToString ( _
    ids As ID(), _
    separator As Char _
) As String
Visual C++
public:
static String^ ArrayToString(
    array<ID^>^ ids,
    wchar_t separator
)

Parameters

ids
Type: array< Sitecore.Data..::..ID >[]()[][]
The ids.
separator
Type: System..::..Char
The separator.

Return Value

The to string.

See Also

ID Class
ArrayToString Overload
Sitecore.Data Namespace


Decode Method

[image]

Sitecore 6.4.1 API
ID..::..Decode Method
ID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Decode(
    string id
)
Visual Basic
Public Shared Function Decode ( _
    id As String _
) As ID
Visual C++
public:
static ID^ Decode(
    String^ id
)

Parameters

id
Type: System..::..String
The id.

Return Value

The decode.

See Also

ID Class
Sitecore.Data Namespace


Encode Method

[image]

Sitecore 6.4.1 API
ID..::..Encode Method
ID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Encode(
    ID id
)
Visual Basic
Public Shared Function Encode ( _
    id As ID _
) As String
Visual C++
public:
static String^ Encode(
    ID^ id
)

Parameters

id
Type: Sitecore.Data..::..ID
The id.

Return Value

The encode.

See Also

ID Class
Sitecore.Data Namespace


Equals Method

[image]

Sitecore 6.4.1 API
ID..::..Equals Method
ID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

See Also

ID Class
Sitecore.Data Namespace


GetDataLength Method

[image]

Sitecore 6.4.1 API
ID..::..GetDataLength Method
ID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long GetDataLength()
Visual Basic
Public Function GetDataLength As Long
Visual C++
public:
long long GetDataLength()

Return Value

The data length.

See Also

ID Class
Sitecore.Data Namespace


GetObjectData Method

[image]

Sitecore 6.4.1 API
ID..::..GetObjectData Method
ID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System.Security..::..SecurityException | The caller does not have the required permission.

See Also

ID Class
Sitecore.Data Namespace


IsID Method

[image]

Sitecore 6.4.1 API
ID..::..IsID Method
ID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsID(
    string id
)
Visual Basic
Public Shared Function IsID ( _
    id As String _
) As Boolean
Visual C++
public:
static bool IsID(
    String^ id
)

Parameters

id
Type: System..::..String
The id.

Return Value

true if the specified id is ID; otherwise, false.

Remarks

The string must be 38 characters long, start with a curly brace "{" and end with a curly brace "}".

See Also

ID Class
Sitecore.Data Namespace


IsNullOrEmpty Method

[image]

Sitecore 6.4.1 API
ID..::..IsNullOrEmpty Method
ID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsNullOrEmpty(
    ID id
)
Visual Basic
Public Shared Function IsNullOrEmpty ( _
    id As ID _
) As Boolean
Visual C++
public:
static bool IsNullOrEmpty(
    ID^ id
)

Parameters

id
Type: Sitecore.Data..::..ID
The id.

Return Value

true if the specified id is null or empty; otherwise, false.

See Also

ID Class
Sitecore.Data Namespace


Parse Method

[image] [image]

Sitecore 6.4.1 API
ID..::..Parse Method
ID Class See Also Send Feedback

Overload List

Name | Description
Parse(Guid) | Converts a GUID to an ID.
Parse(Object) | Converts an object to an ID.
Parse(String) | Converts a string to an ID.
Parse(String, ID) | Converts a string to an ID.

See Also

ID Class
ID Members
Sitecore.Data Namespace


Parse Method (Guid)

[image]

Sitecore 6.4.1 API
ID..::..Parse Method (Guid)
ID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Parse(
    Guid value
)
Visual Basic
Public Shared Function Parse ( _
    value As Guid _
) As ID
Visual C++
public:
static ID^ Parse(
    Guid value
)

Parameters

value
Type: System..::..Guid
The value.

Return Value

The parse.

See Also

ID Class
Parse Overload
Sitecore.Data Namespace


Parse Method (Object)

[image]

Sitecore 6.4.1 API
ID..::..Parse Method (Object)
ID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Parse(
    Object value
)
Visual Basic
Public Shared Function Parse ( _
    value As Object _
) As ID
Visual C++
public:
static ID^ Parse(
    Object^ value
)

Parameters

value
Type: System..::..Object
The value.

Return Value

The parse.

See Also

ID Class
Parse Overload
Sitecore.Data Namespace


Parse Method (String)

[image]

Sitecore 6.4.1 API
ID..::..Parse Method (String)
ID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Parse(
    string value
)
Visual Basic
Public Shared Function Parse ( _
    value As String _
) As ID
Visual C++
public:
static ID^ Parse(
    String^ value
)

Parameters

value
Type: System..::..String
The value.

Return Value

The parse.

See Also

ID Class
Parse Overload
Sitecore.Data Namespace


Parse Method (String, ID)

[image]

Sitecore 6.4.1 API
ID..::..Parse Method (String, ID)
ID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Parse(
    string value,
    ID defaultValue
)
Visual Basic
Public Shared Function Parse ( _
    value As String, _
    defaultValue As ID _
) As ID
Visual C++
public:
static ID^ Parse(
    String^ value,
    ID^ defaultValue
)

Parameters

value
Type: System..::..String
The value.
defaultValue
Type: Sitecore.Data..::..ID
The default value.

Return Value

The parse.

See Also

ID Class
Parse Overload
Sitecore.Data Namespace


ParseArray Method

[image] [image]

Sitecore 6.4.1 API
ID..::..ParseArray Method
ID Class See Also Send Feedback

Overload List

Name | Description
ParseArray(String) | Converts a string of pipe separated IDs to an array of IDs.
ParseArray(String, Boolean) | Converts a string of pipe separated IDs to an array of IDs.

See Also

ID Class
ID Members
Sitecore.Data Namespace


ParseArray Method (String)

[image]

Sitecore 6.4.1 API
ID..::..ParseArray Method (String)
ID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID[] ParseArray(
    string values
)
Visual Basic
Public Shared Function ParseArray ( _
    values As String _
) As ID()
Visual C++
public:
static array<ID^>^ ParseArray(
    String^ values
)

Parameters

values
Type: System..::..String
The values.

Return Value

The array.

Remarks

The list of IDs is separated by a pipe "|".

See Also

ID Class
ParseArray Overload
Sitecore.Data Namespace


ToGuid Method

[image]

Sitecore 6.4.1 API
ID..::..ToGuid Method
ID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Guid ToGuid()
Visual Basic
Public Function ToGuid As Guid
Visual C++
public:
Guid ToGuid()

Return Value

The GUID.

See Also

ID Class
Sitecore.Data Namespace


ToShortID Method

[image]

Sitecore 6.4.1 API
ID..::..ToShortID Method
ID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ShortID ToShortID()
Visual Basic
Public Function ToShortID As ShortID
Visual C++
public:
ShortID^ ToShortID()

Return Value

The short ID.

See Also

ID Class
Sitecore.Data Namespace


ToString Method

[image]

Sitecore 6.4.1 API
ID..::..ToString Method
ID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

ID Class
Sitecore.Data Namespace


TryParse Method

[image] [image]

Sitecore 6.4.1 API
ID..::..TryParse Method
ID Class See Also Send Feedback

Overload List

Name | Description
TryParse(Object, ID%) | Tries to parse a value.
TryParse(String, ID%) | Tries to parse a string value.

See Also

ID Class
ID Members
Sitecore.Data Namespace


TryParse Method (Object, ID)

[image]

Sitecore 6.4.1 API
ID..::..TryParse Method (Object, ID%)
ID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool TryParse(
    Object value,
    out ID result
)
Visual Basic
Public Shared Function TryParse ( _
    value As Object, _
    <OutAttribute> ByRef result As ID _
) As Boolean
Visual C++
public:
static bool TryParse(
    Object^ value,
    [OutAttribute] ID^% result
)

Parameters

value
Type: System..::..Object
The value.
result
Type: Sitecore.Data..::..ID %
The result.

Return Value

true, if the pasing was successful, otherwise false.

See Also

ID Class
TryParse Overload
Sitecore.Data Namespace


TryParse Method (String, ID)

[image]

Sitecore 6.4.1 API
ID..::..TryParse Method (String, ID%)
ID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool TryParse(
    string value,
    out ID result
)
Visual Basic
Public Shared Function TryParse ( _
    value As String, _
    <OutAttribute> ByRef result As ID _
) As Boolean
Visual C++
public:
static bool TryParse(
    String^ value,
    [OutAttribute] ID^% result
)

Parameters

value
Type: System..::..String
The value.
result
Type: Sitecore.Data..::..ID %
The result.

Return Value

true, if the parsing was successful, otherwise false.

See Also

ID Class
TryParse Overload
Sitecore.Data Namespace


ID Operators and Type Conversions

[image] [image]

Sitecore 6.4.1 API
ID Operators and Type Conversions
ID Class See Also Send Feedback

Operators

Name | Description
Equality(ID, ID) | Operator ==s the specified id1.
Equality(ID, ShortID) | Operator ==s the specified id1.
Equality(ShortID, ID) | Operator ==s the specified id1.
ImplicitWideningImplicitImplicitImplicit(BranchId to ID) | Implicit operators the specified master ID.
ImplicitWideningImplicitImplicitImplicit(TemplateID to ID) | Implicit operators the specified template ID.
Inequality(ID, ID) | Operator !=s the specified id1.
Inequality(ID, ShortID) | Operator !=s the specified id1.
Inequality(ShortID, ID) | Operator !=s the specified id1.

See Also

ID Class
Sitecore.Data Namespace


Equality Operator

[image] [image]

Sitecore 6.4.1 API
ID..::..Equality Operator
ID Class See Also Send Feedback

Overload List

Name | Description
Equality(ID, ID) | Operator ==s the specified id1.
Equality(ID, ShortID) | Operator ==s the specified id1.
Equality(ShortID, ID) | Operator ==s the specified id1.

See Also

ID Class
ID Members
Sitecore.Data Namespace


Equality Operator (ID, ID)

[image]

Sitecore 6.4.1 API
ID..::..Equality Operator (ID, ID)
ID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool operator ==(
    ID id1,
    ID id2
)
Visual Basic
Public Shared Operator = ( _
    id1 As ID, _
    id2 As ID _
) As Boolean
Visual C++
public:
static bool operator ==(
    ID^ id1,
    ID^ id2
)

Parameters

id1
Type: Sitecore.Data..::..ID
The id1.
id2
Type: Sitecore.Data..::..ID
The id2.

Return Value

The operator ==.

See Also

ID Class
Equality Overload
Sitecore.Data Namespace


Equality Operator (ShortID, ID)

[image]

Sitecore 6.4.1 API
ID..::..Equality Operator (ShortID, ID)
ID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool operator ==(
    ShortID id1,
    ID id2
)
Visual Basic
Public Shared Operator = ( _
    id1 As ShortID, _
    id2 As ID _
) As Boolean
Visual C++
public:
static bool operator ==(
    ShortID^ id1,
    ID^ id2
)

Parameters

id1
Type: Sitecore.Data..::..ShortID
The id1.
id2
Type: Sitecore.Data..::..ID
The id2.

Return Value

The operator ==.

See Also

ID Class
Equality Overload
Sitecore.Data Namespace


Implicit Conversion (BranchId to ID)

[image]

Sitecore 6.4.1 API
ID ImplicitWideningImplicitImplicitImplicit Conversion (BranchId to ID)
ID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator ID (
    BranchId branchId
)
Visual Basic
Public Shared Widening Operator CType ( _
    branchId As BranchId _
) As ID
Visual C++
static implicit operator ID^ (
    BranchId branchId
)

Parameters

branchId
Type: Sitecore.Data..::..BranchId
The master ID.

Return Value

The implicit operator.

See Also

ID Class
ImplicitWideningImplicitImplicitImplicit Overload
Sitecore.Data Namespace


Inequality Operator

[image] [image]

Sitecore 6.4.1 API
ID..::..Inequality Operator
ID Class See Also Send Feedback

Overload List

Name | Description
Inequality(ID, ID) | Operator !=s the specified id1.
Inequality(ID, ShortID) | Operator !=s the specified id1.
Inequality(ShortID, ID) | Operator !=s the specified id1.

See Also

ID Class
ID Members
Sitecore.Data Namespace


Inequality Operator (ID, ID)

[image]

Sitecore 6.4.1 API
ID..::..Inequality Operator (ID, ID)
ID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool operator !=(
    ID id1,
    ID id2
)
Visual Basic
Public Shared Operator <> ( _
    id1 As ID, _
    id2 As ID _
) As Boolean
Visual C++
public:
static bool operator !=(
    ID^ id1,
    ID^ id2
)

Parameters

id1
Type: Sitecore.Data..::..ID
The id1.
id2
Type: Sitecore.Data..::..ID
The id2.

Return Value

The operator !=.

See Also

ID Class
Inequality Overload
Sitecore.Data Namespace


Inequality Operator (ID, ShortID)

[image]

Sitecore 6.4.1 API
ID..::..Inequality Operator (ID, ShortID)
ID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool operator !=(
    ID id1,
    ShortID id2
)
Visual Basic
Public Shared Operator <> ( _
    id1 As ID, _
    id2 As ShortID _
) As Boolean
Visual C++
public:
static bool operator !=(
    ID^ id1,
    ShortID^ id2
)

Parameters

id1
Type: Sitecore.Data..::..ID
The id1.
id2
Type: Sitecore.Data..::..ShortID
The id2.

Return Value

The operator !=.

See Also

ID Class
Inequality Overload
Sitecore.Data Namespace


Inequality Operator (ShortID, ID)

[image]

Sitecore 6.4.1 API
ID..::..Inequality Operator (ShortID, ID)
ID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool operator !=(
    ShortID id1,
    ID id2
)
Visual Basic
Public Shared Operator <> ( _
    id1 As ShortID, _
    id2 As ID _
) As Boolean
Visual C++
public:
static bool operator !=(
    ShortID^ id1,
    ID^ id2
)

Parameters

id1
Type: Sitecore.Data..::..ShortID
The id1.
id2
Type: Sitecore.Data..::..ID
The id2.

Return Value

The operator !=.

See Also

ID Class
Inequality Overload
Sitecore.Data Namespace


ID Properties

[image] [image]

Sitecore 6.4.1 API
ID Properties
ID Class See Also Send Feedback

The ID type exposes the following members.

Properties

 | Name | Description
Public property | Guid | Gets the GUID represented by the ID.
Public property | IsGlobalNullId | Gets or sets a value indicating whether this instance is the global null id.
Public property | IsNull | Gets or sets a value indicating whether this instance is null.
 | NewID | Gets a new unique ID.
 | Null | Gets the Null ID.
 | Undefined | Gets the Undefined ID.

See Also

ID Class
Sitecore.Data Namespace


Guid Property

[image]

Sitecore 6.4.1 API
ID..::..Guid Property
ID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Guid Guid { get; }
Visual Basic
Public ReadOnly Property Guid As Guid
    Get
Visual C++
public:
property Guid Guid {
    Guid get ();
}

Field Value

The GUID.

See Also

ID Class
Sitecore.Data Namespace


IsGlobalNullId Property

[image]

Sitecore 6.4.1 API
ID..::..IsGlobalNullId Property
ID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsGlobalNullId { get; internal set; }
Visual Basic
Public Property IsGlobalNullId As Boolean
    Get
    Friend Set
Visual C++
public:
property bool IsGlobalNullId {
    bool get ();
    internal: void set (bool value);
}

Field Value

true if this instance is the global null id; otherwise, false.

See Also

ID Class
Sitecore.Data Namespace


IsNull Property

[image]

Sitecore 6.4.1 API
ID..::..IsNull Property
ID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsNull { get; }
Visual Basic
Public ReadOnly Property IsNull As Boolean
    Get
Visual C++
public:
property bool IsNull {
    bool get ();
}

Field Value

true if this instance is null; otherwise, false.

See Also

ID Class
Sitecore.Data Namespace


NewID Property

[image]

Sitecore 6.4.1 API
ID..::..NewID Property
ID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID NewID { get; }
Visual Basic
Public Shared ReadOnly Property NewID As ID
    Get
Visual C++
public:
static property ID^ NewID {
    ID^ get ();
}

Field Value

The new ID.

See Also

ID Class
Sitecore.Data Namespace


Null Property

[image]

Sitecore 6.4.1 API
ID..::..Null Property
ID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Null { get; }
Visual Basic
Public Shared ReadOnly Property Null As ID
    Get
Visual C++
public:
static property ID^ Null {
    ID^ get ();
}

Field Value

The null.

Remarks

The Null ID is a special wellknown ID.

See Also

ID Class
Sitecore.Data Namespace


Undefined Property

[image]

Sitecore 6.4.1 API
ID..::..Undefined Property
ID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID Undefined { get; }
Visual Basic
Public Shared ReadOnly Property Undefined As ID
    Get
Visual C++
public:
static property ID^ Undefined {
    ID^ get ();
}

Field Value

The undefined.

Remarks

The Undefined ID is a special wellknown ID.

See Also

ID Class
Sitecore.Data Namespace


ItemData Class

[image]

Sitecore 6.4.1 API
ItemData Class
Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemData
Visual Basic
Public Class ItemData
Visual C++
public ref class ItemData

Inheritance Hierarchy

System..::..Object
Sitecore.Data..::..ItemData

See Also

ItemData Members
Sitecore.Data Namespace


ItemData Members

[image] [image]

Sitecore 6.4.1 API
ItemData Members
ItemData Class Constructors Methods Properties See Also Send Feedback

The ItemData type exposes the following members.

Constructors

 | Name | Description
Public method | ItemData | Initializes a new instance of the ItemData class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DataID | Obsolete. Gets the data ID.
Public property | Definition | Gets the definition.
Public property | Fields | Gets the fields.
Public property | Language | Gets the language of the item.
Public property | Version | Gets the version of the item.

See Also

ItemData Class
Sitecore.Data Namespace


ItemData Constructor

[image]

Sitecore 6.4.1 API
ItemData Constructor
ItemData Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemData(
    ItemDefinition definition,
    Language language,
    Version version,
    FieldList fields
)
Visual Basic
Public Sub New ( _
    definition As ItemDefinition, _
    language As Language, _
    version As Version, _
    fields As FieldList _
)
Visual C++
public:
ItemData(
    ItemDefinition^ definition,
    Language^ language,
    Version^ version,
    FieldList^ fields
)

Parameters

definition
Type: Sitecore.Data..::..ItemDefinition
The definition.
language
Type: Sitecore.Globalization..::..Language
The language.
version
Type: Sitecore.Data..::..Version
The version.
fields
Type: Sitecore.Data..::..FieldList
The fields.

See Also

ItemData Class
Sitecore.Data Namespace


ItemData Methods

[image] [image]

Sitecore 6.4.1 API
ItemData Methods
ItemData Class See Also Send Feedback

The ItemData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemData Class
Sitecore.Data Namespace


ItemData Properties

[image] [image]

Sitecore 6.4.1 API
ItemData Properties
ItemData Class See Also Send Feedback

The ItemData type exposes the following members.

Properties

 | Name | Description
Public property | DataID | Obsolete. Gets the data ID.
Public property | Definition | Gets the definition.
Public property | Fields | Gets the fields.
Public property | Language | Gets the language of the item.
Public property | Version | Gets the version of the item.

See Also

ItemData Class
Sitecore.Data Namespace


DataID Property

[image]

Sitecore 6.4.1 API
ItemData..::..DataID Property
ItemData Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use Defintion instead.")]
public ID DataID { get; }
Visual Basic
<ObsoleteAttribute("Deprecated - Use Defintion instead.")> _
Public ReadOnly Property DataID As ID
    Get
Visual C++
[ObsoleteAttribute(L"Deprecated - Use Defintion instead.")]
public:
property ID^ DataID {
    ID^ get ();
}

Field Value

The data ID.

See Also

ItemData Class
Sitecore.Data Namespace


Definition Property

[image]

Sitecore 6.4.1 API
ItemData..::..Definition Property
ItemData Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemDefinition Definition { get; }
Visual Basic
Public ReadOnly Property Definition As ItemDefinition
    Get
Visual C++
public:
property ItemDefinition^ Definition {
    ItemDefinition^ get ();
}

Field Value

The definition.

See Also

ItemData Class
Sitecore.Data Namespace


Fields Property

[image]

Sitecore 6.4.1 API
ItemData..::..Fields Property
ItemData Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FieldList Fields { get; }
Visual Basic
Public ReadOnly Property Fields As FieldList
    Get
Visual C++
public:
property FieldList^ Fields {
    FieldList^ get ();
}

Field Value

The fields.

See Also

ItemData Class
Sitecore.Data Namespace


Language Property

[image]

Sitecore 6.4.1 API
ItemData..::..Language Property
ItemData Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Language Language { get; }
Visual Basic
Public ReadOnly Property Language As Language
    Get
Visual C++
public:
property Language^ Language {
    Language^ get ();
}

Field Value

The language.

See Also

ItemData Class
Sitecore.Data Namespace


Version Property

[image]

Sitecore 6.4.1 API
ItemData..::..Version Property
ItemData Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Version Version { get; }
Visual Basic
Public ReadOnly Property Version As Version
    Get
Visual C++
public:
property Version^ Version {
    Version^ get ();
}

Field Value

The version.

See Also

ItemData Class
Sitecore.Data Namespace


ItemDefinition Class

[image]

Sitecore 6.4.1 API
ItemDefinition Class
Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemDefinition : ICacheable
Visual Basic
Public Class ItemDefinition _
    Implements ICacheable
Visual C++
public ref class ItemDefinition : ICacheable

Inheritance Hierarchy

System..::..Object
Sitecore.Data..::..ItemDefinition

See Also

ItemDefinition Members
Sitecore.Data Namespace


ItemDefinition Constructor

[image]

Sitecore 6.4.1 API
ItemDefinition Constructor
ItemDefinition Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemDefinition(
    ID itemID,
    string itemName,
    ID templateID,
    ID branchId
)
Visual Basic
Public Sub New ( _
    itemID As ID, _
    itemName As String, _
    templateID As ID, _
    branchId As ID _
)
Visual C++
public:
ItemDefinition(
    ID^ itemID,
    String^ itemName,
    ID^ templateID,
    ID^ branchId
)

Parameters

itemID
Type: Sitecore.Data..::..ID
Item ID.
itemName
Type: System..::..String
Name.
templateID
Type: Sitecore.Data..::..ID
Template ID.
branchId
Type: Sitecore.Data..::..ID
Branch id.

See Also

ItemDefinition Class
Sitecore.Data Namespace


ItemDefinition Methods

[image] [image]

Sitecore 6.4.1 API
ItemDefinition Methods
ItemDefinition Class See Also Send Feedback

The ItemDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDataLength | Gets the size of the data to use when caching.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemDefinition Class
Sitecore.Data Namespace


GetDataLength Method

[image]

Sitecore 6.4.1 API
ItemDefinition..::..GetDataLength Method
ItemDefinition Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long GetDataLength()
Visual Basic
Public Function GetDataLength As Long
Visual C++
public:
virtual long long GetDataLength() sealed

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.ItemDefinition.GetDataLength"]

Implements

ICacheable..::..GetDataLength()()()()

See Also

ItemDefinition Class
Sitecore.Data Namespace


ItemDefinition Properties

[image] [image]

Sitecore 6.4.1 API
ItemDefinition Properties
ItemDefinition Class See Also Send Feedback

The ItemDefinition type exposes the following members.

Properties

 | Name | Description
Public property | BranchId | Gets the ID of master used for creating the item.
 | Empty | Gets the empty ItemInformation.
Public property | ID | Gets the ID of the item.
Public property | IsEmpty | Gets a value indicating whether this instance is empty (ie. the null instance).
Public property | Key | Gets the key of the item.
Public property | MasterID | Obsolete. Gets the ID of master used for creating the item.
Public property | Name | Gets the name of the item.
Public property | TemplateID | Gets the ID of the template.

See Also

ItemDefinition Class
Sitecore.Data Namespace


Empty Property

[image]

Sitecore 6.4.1 API
ItemDefinition..::..Empty Property
ItemDefinition Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ItemDefinition Empty { get; }
Visual Basic
Public Shared ReadOnly Property Empty As ItemDefinition
    Get
Visual C++
public:
static property ItemDefinition^ Empty {
    ItemDefinition^ get ();
}

Field Value

The empty ItemInformation.

See Also

ItemDefinition Class
Sitecore.Data Namespace


ID Property

[image]

Sitecore 6.4.1 API
ItemDefinition..::..ID Property
ItemDefinition Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ID { get; }
Visual Basic
Public ReadOnly Property ID As ID
    Get
Visual C++
public:
property ID^ ID {
    ID^ get ();
}

Field Value

The ID.

See Also

ItemDefinition Class
Sitecore.Data Namespace


IsEmpty Property

[image]

Sitecore 6.4.1 API
ItemDefinition..::..IsEmpty Property
ItemDefinition Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
property bool IsEmpty {
    bool get ();
}

Field Value

true if this instance is empty; otherwise, false.

See Also

ItemDefinition Class
Sitecore.Data Namespace


Key Property

[image]

Sitecore 6.4.1 API
ItemDefinition..::..Key Property
ItemDefinition Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Key { get; }
Visual Basic
Public ReadOnly Property Key As String
    Get
Visual C++
public:
property String^ Key {
    String^ get ();
}

Remarks

Same as Name in lowercase.

See Also

ItemDefinition Class
Sitecore.Data Namespace


MasterID Property

[image]

Sitecore 6.4.1 API
ItemDefinition..::..MasterID Property
ItemDefinition Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use BranchId instead.")]
public ID MasterID { get; }
Visual Basic
<ObsoleteAttribute("Deprecated - Use BranchId instead.")> _
Public ReadOnly Property MasterID As ID
    Get
Visual C++
[ObsoleteAttribute(L"Deprecated - Use BranchId instead.")]
public:
property ID^ MasterID {
    ID^ get ();
}

Field Value

The master ID.

See Also

ItemDefinition Class
Sitecore.Data Namespace


Name Property

[image]

Sitecore 6.4.1 API
ItemDefinition..::..Name Property
ItemDefinition Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Field Value

See Also

ItemDefinition Class
Sitecore.Data Namespace


TemplateID Property

[image]

Sitecore 6.4.1 API
ItemDefinition..::..TemplateID Property
ItemDefinition Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID TemplateID { get; }
Visual Basic
Public ReadOnly Property TemplateID As ID
    Get
Visual C++
public:
property ID^ TemplateID {
    ID^ get ();
}

Field Value

The template ID.

See Also

ItemDefinition Class
Sitecore.Data Namespace


ItemInformation Members

[image] [image]

Sitecore 6.4.1 API
ItemInformation Members
ItemInformation Class Constructors Methods Properties See Also Send Feedback

The ItemInformation type exposes the following members.

Constructors

 | Name | Description
Public method | ItemInformation | Initializes a new instance of the ItemInformation class.

Methods

 | Name | Description
Public method | AddItemData | Adds the item data.
Public method | AddLanguages | Adds the languages.
Public method | AddVersions(VersionUriList) | Adds the versions.
Public method | AddVersions(VersionCollection, Language) | Adds the versions.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemData | Gets the item data.
Public method | GetLanguages | Gets the languages.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersions()()()() | Gets the versions.
Public method | GetVersions(Language) | Gets the versions.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyChildAdded | Notifies the child added.
Public method | NotifyChildRemoved | Notifies the child removed.
Public method | NotifySaved | Notifies the saved.
Public method | NotifyVersionAdded | Notifies the version added.
Public method | NotifyVersionRemoved | Notifies the version removed.
Public method | NotifyVersionsRemoved | Notifies the versions removed.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ChildIDs | Gets or sets the child I ds.
Public property | ItemDefinition | Gets the item definition.
Public property | ParentID | Gets or sets the parent ID.

See Also

ItemInformation Class
Sitecore.Data Namespace


ItemInformation Constructor

[image]

Sitecore 6.4.1 API
ItemInformation Constructor
ItemInformation Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemInformation(
    ItemDefinition itemDefinition
)
Visual Basic
Public Sub New ( _
    itemDefinition As ItemDefinition _
)
Visual C++
public:
ItemInformation(
    ItemDefinition^ itemDefinition
)

Parameters

itemDefinition
Type: Sitecore.Data..::..ItemDefinition
The item definition.

See Also

ItemInformation Class
Sitecore.Data Namespace


ItemInformation Methods

[image] [image]

Sitecore 6.4.1 API
ItemInformation Methods
ItemInformation Class See Also Send Feedback

The ItemInformation type exposes the following members.

Methods

 | Name | Description
Public method | AddItemData | Adds the item data.
Public method | AddLanguages | Adds the languages.
Public method | AddVersions(VersionUriList) | Adds the versions.
Public method | AddVersions(VersionCollection, Language) | Adds the versions.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemData | Gets the item data.
Public method | GetLanguages | Gets the languages.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersions()()()() | Gets the versions.
Public method | GetVersions(Language) | Gets the versions.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyChildAdded | Notifies the child added.
Public method | NotifyChildRemoved | Notifies the child removed.
Public method | NotifySaved | Notifies the saved.
Public method | NotifyVersionAdded | Notifies the version added.
Public method | NotifyVersionRemoved | Notifies the version removed.
Public method | NotifyVersionsRemoved | Notifies the versions removed.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemInformation Class
Sitecore.Data Namespace


AddLanguages Method

[image]

Sitecore 6.4.1 API
ItemInformation..::..AddLanguages Method
ItemInformation Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddLanguages(
    LanguageCollection languages
)
Visual Basic
Public Sub AddLanguages ( _
    languages As LanguageCollection _
)
Visual C++
public:
void AddLanguages(
    LanguageCollection^ languages
)

Parameters

languages
Type: Sitecore.Collections..::..LanguageCollection
The languages.

See Also

ItemInformation Class
Sitecore.Data Namespace


AddVersions Method

[image] [image]

Sitecore 6.4.1 API
ItemInformation..::..AddVersions Method
ItemInformation Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddVersions(VersionUriList) | Adds the versions.
Public method | AddVersions(VersionCollection, Language) | Adds the versions.

See Also

ItemInformation Class
ItemInformation Members
Sitecore.Data Namespace


AddVersions Method (VersionUriList)

[image]

Sitecore 6.4.1 API
ItemInformation..::..AddVersions Method (VersionUriList)
ItemInformation Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddVersions(
    VersionUriList versionUris
)
Visual Basic
Public Sub AddVersions ( _
    versionUris As VersionUriList _
)
Visual C++
public:
void AddVersions(
    VersionUriList^ versionUris
)

Parameters

versionUris
Type: Sitecore.Collections..::..VersionUriList
The version uris.

See Also

ItemInformation Class
AddVersions Overload
Sitecore.Data Namespace


AddVersions Method (VersionCollection, Language)

[image]

Sitecore 6.4.1 API
ItemInformation..::..AddVersions Method (VersionCollection, Language)
ItemInformation Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddVersions(
    VersionCollection versions,
    Language language
)
Visual Basic
Public Sub AddVersions ( _
    versions As VersionCollection, _
    language As Language _
)
Visual C++
public:
void AddVersions(
    VersionCollection^ versions,
    Language^ language
)

Parameters

versions
Type: Sitecore.Collections..::..VersionCollection
The versions.
language
Type: Sitecore.Globalization..::..Language
The language.

See Also

ItemInformation Class
AddVersions Overload
Sitecore.Data Namespace


GetItemData Method

[image]

Sitecore 6.4.1 API
ItemInformation..::..GetItemData Method
ItemInformation Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemData GetItemData(
    Language language,
    Version version
)
Visual Basic
Public Function GetItemData ( _
    language As Language, _
    version As Version _
) As ItemData
Visual C++
public:
ItemData^ GetItemData(
    Language^ language,
    Version^ version
)

Parameters

language
Type: Sitecore.Globalization..::..Language
The language.
version
Type: Sitecore.Data..::..Version
The version.

Return Value

The item data.

See Also

ItemInformation Class
Sitecore.Data Namespace


GetLanguages Method

[image]

Sitecore 6.4.1 API
ItemInformation..::..GetLanguages Method
ItemInformation Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LanguageCollection GetLanguages()
Visual Basic
Public Function GetLanguages As LanguageCollection
Visual C++
public:
LanguageCollection^ GetLanguages()

Return Value

The languages.

See Also

ItemInformation Class
Sitecore.Data Namespace


GetVersions Method

[image] [image]

Sitecore 6.4.1 API
ItemInformation..::..GetVersions Method
ItemInformation Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetVersions()()()() | Gets the versions.
Public method | GetVersions(Language) | Gets the versions.

See Also

ItemInformation Class
ItemInformation Members
Sitecore.Data Namespace


GetVersions Method

[image]

Sitecore 6.4.1 API
ItemInformation..::..GetVersions Method
ItemInformation Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public VersionUriList GetVersions()
Visual Basic
Public Function GetVersions As VersionUriList
Visual C++
public:
VersionUriList^ GetVersions()

Return Value

The versions.

See Also

ItemInformation Class
GetVersions Overload
Sitecore.Data Namespace


GetVersions Method (Language)

[image]

Sitecore 6.4.1 API
ItemInformation..::..GetVersions Method (Language)
ItemInformation Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public VersionCollection GetVersions(
    Language language
)
Visual Basic
Public Function GetVersions ( _
    language As Language _
) As VersionCollection
Visual C++
public:
VersionCollection^ GetVersions(
    Language^ language
)

Parameters

language
Type: Sitecore.Globalization..::..Language
The language.

Return Value

The versions.

See Also

ItemInformation Class
GetVersions Overload
Sitecore.Data Namespace


NotifyChildAdded Method

[image]

Sitecore 6.4.1 API
ItemInformation..::..NotifyChildAdded Method
ItemInformation Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void NotifyChildAdded(
    ID childID
)
Visual Basic
Public Sub NotifyChildAdded ( _
    childID As ID _
)
Visual C++
public:
void NotifyChildAdded(
    ID^ childID
)

Parameters

childID
Type: Sitecore.Data..::..ID
The child ID.

See Also

ItemInformation Class
Sitecore.Data Namespace


NotifyChildRemoved Method

[image]

Sitecore 6.4.1 API
ItemInformation..::..NotifyChildRemoved Method
ItemInformation Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void NotifyChildRemoved(
    ID childID
)
Visual Basic
Public Sub NotifyChildRemoved ( _
    childID As ID _
)
Visual C++
public:
void NotifyChildRemoved(
    ID^ childID
)

Parameters

childID
Type: Sitecore.Data..::..ID
The child ID.

See Also

ItemInformation Class
Sitecore.Data Namespace


NotifySaved Method

[image]

Sitecore 6.4.1 API
ItemInformation..::..NotifySaved Method
ItemInformation Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void NotifySaved(
    ItemInformation item,
    ItemChanges changes
)
Visual Basic
Public Sub NotifySaved ( _
    item As ItemInformation, _
    changes As ItemChanges _
)
Visual C++
public:
void NotifySaved(
    ItemInformation^ item,
    ItemChanges^ changes
)

Parameters

item
Type: Sitecore.Data..::..ItemInformation
The item.
changes
Type: Sitecore.Data.Items..::..ItemChanges
The changes.

See Also

ItemInformation Class
Sitecore.Data Namespace


NotifyVersionRemoved Method

[image]

Sitecore 6.4.1 API
ItemInformation..::..NotifyVersionRemoved Method
ItemInformation Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void NotifyVersionRemoved(
    Language language,
    Version version
)
Visual Basic
Public Sub NotifyVersionRemoved ( _
    language As Language, _
    version As Version _
)
Visual C++
public:
void NotifyVersionRemoved(
    Language^ language,
    Version^ version
)

Parameters

language
Type: Sitecore.Globalization..::..Language
The language.
version
Type: Sitecore.Data..::..Version
The version.

See Also

ItemInformation Class
Sitecore.Data Namespace


NotifyVersionsRemoved Method

[image]

Sitecore 6.4.1 API
ItemInformation..::..NotifyVersionsRemoved Method
ItemInformation Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void NotifyVersionsRemoved(
    Language language
)
Visual Basic
Public Sub NotifyVersionsRemoved ( _
    language As Language _
)
Visual C++
public:
void NotifyVersionsRemoved(
    Language^ language
)

Parameters

language
Type: Sitecore.Globalization..::..Language
The language.

See Also

ItemInformation Class
Sitecore.Data Namespace


ChildIDs Property

[image]

Sitecore 6.4.1 API
ItemInformation..::..ChildIDs Property
ItemInformation Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IDList ChildIDs { get; set; }
Visual Basic
Public Property ChildIDs As IDList
    Get
    Set
Visual C++
public:
property IDList^ ChildIDs {
    IDList^ get ();
    void set (IDList^ value);
}

Field Value

The child I ds.

See Also

ItemInformation Class
Sitecore.Data Namespace


ItemDefinition Property

[image]

Sitecore 6.4.1 API
ItemInformation..::..ItemDefinition Property
ItemInformation Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemDefinition ItemDefinition { get; }
Visual Basic
Public ReadOnly Property ItemDefinition As ItemDefinition
    Get
Visual C++
public:
property ItemDefinition^ ItemDefinition {
    ItemDefinition^ get ();
}

Field Value

The item definition.

See Also

ItemInformation Class
Sitecore.Data Namespace


ParentID Property

[image]

Sitecore 6.4.1 API
ItemInformation..::..ParentID Property
ItemInformation Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ParentID { get; set; }
Visual Basic
Public Property ParentID As ID
    Get
    Set
Visual C++
public:
property ID^ ParentID {
    ID^ get ();
    void set (ID^ value);
}

Field Value

The parent ID.

See Also

ItemInformation Class
Sitecore.Data Namespace


ItemPath Class

[image]

Sitecore 6.4.1 API
ItemPath Class
Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemPath
Visual Basic
Public Class ItemPath
Visual C++
public ref class ItemPath

Inheritance Hierarchy

System..::..Object
Sitecore.Data..::..ItemPath

See Also

ItemPath Members
Sitecore.Data Namespace


ItemPath Constructor

[image]

Sitecore 6.4.1 API
ItemPath Constructor
ItemPath Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemPath(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
ItemPath(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
Item.

See Also

ItemPath Class
Sitecore.Data Namespace


GetFriendlyUrl Method

[image] [image]

Sitecore 6.4.1 API
ItemPath..::..GetFriendlyUrl Method
ItemPath Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetFriendlyUrl()()()() | Obsolete. Gets the friendly URL.
Public method | GetFriendlyUrl(Boolean) | Obsolete. Gets the friendly URL.
Public method | GetFriendlyUrl(String) | Obsolete. Gets the friendly URL.
Public method | GetFriendlyUrl(SiteContext) | Obsolete. Gets the friendly URL.
Public method | GetFriendlyUrl(String, String) | Obsolete. Gets the friendly URL.
Public method | GetFriendlyUrl(SiteContext, Boolean) | Obsolete. Gets the friendly URL.
Public method | GetFriendlyUrl(String, String, Boolean) | Obsolete. Gets the friendly URL.

See Also

ItemPath Class
ItemPath Members
Sitecore.Data Namespace


GetFriendlyUrl Method

[image]

Sitecore 6.4.1 API
ItemPath..::..GetFriendlyUrl Method
ItemPath Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated. Use Sitecore.Links.LinkManager.GetItemUrl() instead.")]
public string GetFriendlyUrl()
Visual Basic
<ObsoleteAttribute("Deprecated. Use Sitecore.Links.LinkManager.GetItemUrl() instead.")> _
Public Function GetFriendlyUrl As String
Visual C++
[ObsoleteAttribute(L"Deprecated. Use Sitecore.Links.LinkManager.GetItemUrl() instead.")]
public:
String^ GetFriendlyUrl()

Return Value

The friendly URL.

See Also

ItemPath Class
GetFriendlyUrl Overload
Sitecore.Data Namespace


GetFriendlyUrl Method (Boolean)

[image]

Sitecore 6.4.1 API
ItemPath..::..GetFriendlyUrl Method (Boolean)
ItemPath Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated. Use Sitecore.Links.LinkManager.GetItemUrl() instead.")]
public string GetFriendlyUrl(
    bool shorten
)
Visual Basic
<ObsoleteAttribute("Deprecated. Use Sitecore.Links.LinkManager.GetItemUrl() instead.")> _
Public Function GetFriendlyUrl ( _
    shorten As Boolean _
) As String
Visual C++
[ObsoleteAttribute(L"Deprecated. Use Sitecore.Links.LinkManager.GetItemUrl() instead.")]
public:
String^ GetFriendlyUrl(
    bool shorten
)

Parameters

shorten
Type: System..::..Boolean
Shorten path.

Return Value

The friendly URL.

See Also

ItemPath Class
GetFriendlyUrl Overload
Sitecore.Data Namespace


GetFriendlyUrl Method (String)

[image]

Sitecore 6.4.1 API
ItemPath..::..GetFriendlyUrl Method (String)
ItemPath Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated. Use Sitecore.Links.LinkManager.GetItemUrl() instead.")]
public string GetFriendlyUrl(
    string siteName
)
Visual Basic
<ObsoleteAttribute("Deprecated. Use Sitecore.Links.LinkManager.GetItemUrl() instead.")> _
Public Function GetFriendlyUrl ( _
    siteName As String _
) As String
Visual C++
[ObsoleteAttribute(L"Deprecated. Use Sitecore.Links.LinkManager.GetItemUrl() instead.")]
public:
String^ GetFriendlyUrl(
    String^ siteName
)

Parameters

siteName
Type: System..::..String
Name of the site.

Return Value

The friendly URL.

See Also

ItemPath Class
GetFriendlyUrl Overload
Sitecore.Data Namespace


GetFriendlyUrl Method (SiteContext)

[image]

Sitecore 6.4.1 API
ItemPath..::..GetFriendlyUrl Method (SiteContext)
ItemPath Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated. Use Sitecore.Links.LinkManager.GetItemUrl() instead.")]
public string GetFriendlyUrl(
    SiteContext site
)
Visual Basic
<ObsoleteAttribute("Deprecated. Use Sitecore.Links.LinkManager.GetItemUrl() instead.")> _
Public Function GetFriendlyUrl ( _
    site As SiteContext _
) As String
Visual C++
[ObsoleteAttribute(L"Deprecated. Use Sitecore.Links.LinkManager.GetItemUrl() instead.")]
public:
String^ GetFriendlyUrl(
    SiteContext^ site
)

Parameters

site
Type: Sitecore.Sites..::..SiteContext
The site.

Return Value

The friendly URL.

See Also

ItemPath Class
GetFriendlyUrl Overload
Sitecore.Data Namespace


GetFriendlyUrl Method (String, String)

[image]

Sitecore 6.4.1 API
ItemPath..::..GetFriendlyUrl Method (String, String)
ItemPath Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated. Use Sitecore.Links.LinkManager.GetItemUrl() instead.")]
public string GetFriendlyUrl(
    string startPath,
    string virtualFolder
)
Visual Basic
<ObsoleteAttribute("Deprecated. Use Sitecore.Links.LinkManager.GetItemUrl() instead.")> _
Public Function GetFriendlyUrl ( _
    startPath As String, _
    virtualFolder As String _
) As String
Visual C++
[ObsoleteAttribute(L"Deprecated. Use Sitecore.Links.LinkManager.GetItemUrl() instead.")]
public:
String^ GetFriendlyUrl(
    String^ startPath,
    String^ virtualFolder
)

Parameters

startPath
Type: System..::..String
The start path.
virtualFolder
Type: System..::..String
The virtual folder.

Return Value

The friendly URL.

See Also

ItemPath Class
GetFriendlyUrl Overload
Sitecore.Data Namespace


GetFriendlyUrl Method (SiteContext, Boolean)

[image]

Sitecore 6.4.1 API
ItemPath..::..GetFriendlyUrl Method (SiteContext, Boolean)
ItemPath Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated. Use Sitecore.Links.LinkManager.GetItemUrl() instead.")]
public string GetFriendlyUrl(
    SiteContext site,
    bool useDisplayName
)
Visual Basic
<ObsoleteAttribute("Deprecated. Use Sitecore.Links.LinkManager.GetItemUrl() instead.")> _
Public Function GetFriendlyUrl ( _
    site As SiteContext, _
    useDisplayName As Boolean _
) As String
Visual C++
[ObsoleteAttribute(L"Deprecated. Use Sitecore.Links.LinkManager.GetItemUrl() instead.")]
public:
String^ GetFriendlyUrl(
    SiteContext^ site,
    bool useDisplayName
)

Parameters

site
Type: Sitecore.Sites..::..SiteContext
The site.
useDisplayName
Type: System..::..Boolean
if set to true [use display name].

Return Value

The friendly URL.

See Also

ItemPath Class
GetFriendlyUrl Overload
Sitecore.Data Namespace


GetFriendlyUrl Method (String, String, Boolean)

[image]

Sitecore 6.4.1 API
ItemPath..::..GetFriendlyUrl Method (String, String, Boolean)
ItemPath Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated. Use Sitecore.Links.LinkManager.GetItemUrl() instead.")]
public string GetFriendlyUrl(
    string startPath,
    string virtualFolder,
    bool useDisplayName
)
Visual Basic
<ObsoleteAttribute("Deprecated. Use Sitecore.Links.LinkManager.GetItemUrl() instead.")> _
Public Function GetFriendlyUrl ( _
    startPath As String, _
    virtualFolder As String, _
    useDisplayName As Boolean _
) As String
Visual C++
[ObsoleteAttribute(L"Deprecated. Use Sitecore.Links.LinkManager.GetItemUrl() instead.")]
public:
String^ GetFriendlyUrl(
    String^ startPath,
    String^ virtualFolder,
    bool useDisplayName
)

Parameters

startPath
Type: System..::..String
The start path.
virtualFolder
Type: System..::..String
The virtual folder.
useDisplayName
Type: System..::..Boolean
if set to true [use display name].

Return Value

The friendly URL.

See Also

ItemPath Class
GetFriendlyUrl Overload
Sitecore.Data Namespace


GetItem Method

[image]

Sitecore 6.4.1 API
ItemPath..::..GetItem Method
ItemPath Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetItem()
Visual Basic
Public Function GetItem As Item
Visual C++
public:
Item^ GetItem()

Return Value

The item.

See Also

ItemPath Class
GetItem Overload
Sitecore.Data Namespace


GetItem Method (Database)

[image]

Sitecore 6.4.1 API
ItemPath..::..GetItem Method (Database)
ItemPath Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetItem(
    Database database
)
Visual Basic
Public Function GetItem ( _
    database As Database _
) As Item
Visual C++
public:
Item^ GetItem(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
Database for item.

Return Value

The item.

See Also

ItemPath Class
GetItem Overload
Sitecore.Data Namespace


GetPath Method

[image] [image]

Sitecore 6.4.1 API
ItemPath..::..GetPath Method
ItemPath Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPath(ItemPathType) | Gets the path of the item.
Public method | GetPath(String, String, ItemPathType) | Get item path

See Also

ItemPath Class
ItemPath Members
Sitecore.Data Namespace


GetPath Method (String, String, ItemPathType)

[image]

Sitecore 6.4.1 API
ItemPath..::..GetPath Method (String, String, ItemPathType)
ItemPath Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetPath(
    string from,
    string separator,
    ItemPathType type
)
Visual Basic
Public Function GetPath ( _
    from As String, _
    separator As String, _
    type As ItemPathType _
) As String
Visual C++
public:
String^ GetPath(
    String^ from,
    String^ separator,
    ItemPathType type
)

Parameters

from
Type: System..::..String
Base path that will not be included in the result
separator
Type: System..::..String
Path separator
type
Type: Sitecore.Data.Items..::..ItemPathType
Type of the elements in the path. Can be: id, key or name

Return Value

Sitecore path of item (excluding from)

See Also

ItemPath Class
GetPath Overload
Sitecore.Data Namespace


GetSubItem Method

[image]

Sitecore 6.4.1 API
ItemPath..::..GetSubItem Method
ItemPath Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetSubItem(
    string path
)
Visual Basic
Public Function GetSubItem ( _
    path As String _
) As Item
Visual C++
public:
Item^ GetSubItem(
    String^ path
)

Parameters

path
Type: System..::..String
Path.

Return Value

The sub item.

See Also

ItemPath Class
Sitecore.Data Namespace


IsAncestorOf Method

[image]

Sitecore 6.4.1 API
ItemPath..::..IsAncestorOf Method
ItemPath Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsAncestorOf(
    Item ancestorItem
)
Visual Basic
Public Function IsAncestorOf ( _
    ancestorItem As Item _
) As Boolean
Visual C++
public:
bool IsAncestorOf(
    Item^ ancestorItem
)

Parameters

ancestorItem
Type: Sitecore.Data.Items..::..Item
Item to check.

Return Value

true if an item is an ancestor of the current item; otherwise, false.

See Also

ItemPath Class
Sitecore.Data Namespace


IsDescendantOf Method

[image]

Sitecore 6.4.1 API
ItemPath..::..IsDescendantOf Method
ItemPath Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsDescendantOf(
    Item descendantItem
)
Visual Basic
Public Function IsDescendantOf ( _
    descendantItem As Item _
) As Boolean
Visual C++
public:
bool IsDescendantOf(
    Item^ descendantItem
)

Parameters

descendantItem
Type: Sitecore.Data.Items..::..Item
Item.

Return Value

true if the current item is a descendant of the other item; otherwise, false.

See Also

ItemPath Class
Sitecore.Data Namespace


Map Method

[image]

Sitecore 6.4.1 API
ItemPath..::..Map Method
ItemPath Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Map(
    string from,
    string to
)
Visual Basic
Public Function Map ( _
    from As String, _
    to As String _
) As String
Visual C++
public:
String^ Map(
    String^ from,
    String^ to
)

Parameters

from
Type: System..::..String
From.
to
Type: System..::..String
To.

Return Value

The map.

See Also

ItemPath Class
Sitecore.Data Namespace


ItemPath Properties

[image] [image]

Sitecore 6.4.1 API
ItemPath Properties
ItemPath Class See Also Send Feedback

The ItemPath type exposes the following members.

Properties

 | Name | Description
Public property | ContentPath | Gets the content path.
Public property | FullPath | Gets the full path of the item.
Public property | IsContentItem | Gets a value indicating whether this item is a descendant of the /sitecore/content item.
Public property | IsFullyQualified | Gets a value indicating whether this item has a root that is either "/{11111111-1111-1111-1111-111111111111}" or "/sitecore".
Public property | IsMasterPart | Gets a value indicating whether this instance is a master.
Public property | IsMediaItem | Gets a value indicating whether this item is a descendant of the /sitecore/media library item.
Public property | Item | Gets the item.
Public property | LongID | Gets the long ID.
Public property | MediaPath | Gets the media path.
Public property | ParentPath | Gets the path of the parent item.
Public property | Path | Gets the path.

See Also

ItemPath Class
Sitecore.Data Namespace


ContentPath Property

[image]

Sitecore 6.4.1 API
ItemPath..::..ContentPath Property
ItemPath Class Example See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ContentPath { get; }
Visual Basic
Public ReadOnly Property ContentPath As String
    Get
Visual C++
public:
property String^ ContentPath {
    String^ get ();
}

Field Value

The content path.

Remarks

If the item is a descendant of /sitecore/content the path relative to /sitecore/content is returned with a slash '/' prepended. If not, the absolute path is returned.

Examples

Item item = Sitecore.Context.Database.Items["/sitecore/content/Home/News"]; string s = item.Paths.Path; // /Home/News

See Also

ItemPath Class
Sitecore.Data Namespace


FullPath Property

[image]

Sitecore 6.4.1 API
ItemPath..::..FullPath Property
ItemPath Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string FullPath { get; }
Visual Basic
Public ReadOnly Property FullPath As String
    Get
Visual C++
public:
property String^ FullPath {
    String^ get ();
}

Field Value

The full path.

See Also

ItemPath Class
Sitecore.Data Namespace


IsContentItem Property

[image]

Sitecore 6.4.1 API
ItemPath..::..IsContentItem Property
ItemPath Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsContentItem { get; }
Visual Basic
Public ReadOnly Property IsContentItem As Boolean
    Get
Visual C++
public:
property bool IsContentItem {
    bool get ();
}

Field Value

true if this item is a descendant of the /sitecore/content item; otherwise, false.

See Also

ItemPath Class
Sitecore.Data Namespace


IsFullyQualified Property

[image]

Sitecore 6.4.1 API
ItemPath..::..IsFullyQualified Property
ItemPath Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsFullyQualified { get; }
Visual Basic
Public ReadOnly Property IsFullyQualified As Boolean
    Get
Visual C++
public:
property bool IsFullyQualified {
    bool get ();
}

Field Value

true if this item has a root that is either "/{11111111-1111-1111-1111-111111111111}" or "/sitecore"; otherwise, false.

See Also

ItemPath Class
Sitecore.Data Namespace


IsMasterPart Property

[image]

Sitecore 6.4.1 API
ItemPath..::..IsMasterPart Property
ItemPath Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsMasterPart { get; }
Visual Basic
Public ReadOnly Property IsMasterPart As Boolean
    Get
Visual C++
public:
property bool IsMasterPart {
    bool get ();
}

Field Value

true if this instance is a master; otherwise, false.

See Also

ItemPath Class
Sitecore.Data Namespace


IsMediaItem Property

[image]

Sitecore 6.4.1 API
ItemPath..::..IsMediaItem Property
ItemPath Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsMediaItem { get; }
Visual Basic
Public ReadOnly Property IsMediaItem As Boolean
    Get
Visual C++
public:
property bool IsMediaItem {
    bool get ();
}

Field Value

true if this item is a descendant of the /sitecore/media library; otherwise, false.

See Also

ItemPath Class
Sitecore.Data Namespace


LongID Property

[image]

Sitecore 6.4.1 API
ItemPath..::..LongID Property
ItemPath Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string LongID { get; }
Visual Basic
Public ReadOnly Property LongID As String
    Get
Visual C++
public:
property String^ LongID {
    String^ get ();
}

Field Value

The long ID.

See Also

ItemPath Class
Sitecore.Data Namespace


MediaPath Property

[image]

Sitecore 6.4.1 API
ItemPath..::..MediaPath Property
ItemPath Class Example See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string MediaPath { get; }
Visual Basic
Public ReadOnly Property MediaPath As String
    Get
Visual C++
public:
property String^ MediaPath {
    String^ get ();
}

Field Value

The media path.

Remarks

If the item is a descendant of /sitecore/media library the path relative to /sitecore/media library is returned with a slash '/' prepended. If not, the absolute path is returned.

Examples

Item item = Sitecore.Context.Database.Items["/sitecore/media library/Buildings/House"]; string s = item.Paths.Path; // /Buildings/House

See Also

ItemPath Class
Sitecore.Data Namespace


ParentPath Property

[image]

Sitecore 6.4.1 API
ItemPath..::..ParentPath Property
ItemPath Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ParentPath { get; }
Visual Basic
Public ReadOnly Property ParentPath As String
    Get
Visual C++
public:
property String^ ParentPath {
    String^ get ();
}

Field Value

The parent path.

See Also

ItemPath Class
Sitecore.Data Namespace


Path Property

[image]

Sitecore 6.4.1 API
ItemPath..::..Path Property
ItemPath Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Path { get; }
Visual Basic
Public ReadOnly Property Path As String
    Get
Visual C++
public:
property String^ Path {
    String^ get ();
}

Field Value

The path.

See Also

ItemPath Class
Sitecore.Data Namespace


ItemPointer Class

[image]

Sitecore 6.4.1 API
ItemPointer Class
Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemPointer
Visual Basic
Public Class ItemPointer
Visual C++
public ref class ItemPointer

Remarks

Points to an item without the ambiguities of ItemUri.

Inheritance Hierarchy

System..::..Object
Sitecore.Data..::..ItemPointer

See Also

ItemPointer Members
Sitecore.Data Namespace


ItemPointer Members

[image] [image]

Sitecore 6.4.1 API
ItemPointer Members
ItemPointer Class Constructors Methods Properties See Also Send Feedback

The ItemPointer type exposes the following members.

Constructors

 | Name | Description
Public method | ItemPointer(Item) | Creates a new ItemPointer instance.
Public method | ItemPointer(ID, Language, Version) | Creates a new ItemPointer instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Parses the specified value.
Public method | ToString | Converts the point to a string representation. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | ItemID | Gets the item ID.
Public property | Language | Gets the language.
Public property | Version | Gets the version.

See Also

ItemPointer Class
Sitecore.Data Namespace


ItemPointer Constructor

[image] [image]

Sitecore 6.4.1 API
ItemPointer Constructor
ItemPointer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ItemPointer(Item) | Creates a new ItemPointer instance.
Public method | ItemPointer(ID, Language, Version) | Creates a new ItemPointer instance.

See Also

ItemPointer Class
ItemPointer Members
Sitecore.Data Namespace


ItemPointer Constructor (Item)

[image]

Sitecore 6.4.1 API
ItemPointer Constructor (Item)
ItemPointer Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemPointer(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
ItemPointer(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
Item.

See Also

ItemPointer Class
ItemPointer Overload
Sitecore.Data Namespace


ItemPointer Constructor (ID, Language, Version)

[image]

Sitecore 6.4.1 API
ItemPointer Constructor (ID, Language, Version)
ItemPointer Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemPointer(
    ID itemID,
    Language language,
    Version version
)
Visual Basic
Public Sub New ( _
    itemID As ID, _
    language As Language, _
    version As Version _
)
Visual C++
public:
ItemPointer(
    ID^ itemID,
    Language^ language,
    Version^ version
)

Parameters

itemID
Type: Sitecore.Data..::..ID
Item ID.
language
Type: Sitecore.Globalization..::..Language
Language.
version
Type: Sitecore.Data..::..Version
Version.

See Also

ItemPointer Class
ItemPointer Overload
Sitecore.Data Namespace


ItemPointer Methods

[image] [image]

Sitecore 6.4.1 API
ItemPointer Methods
ItemPointer Class See Also Send Feedback

The ItemPointer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Parses the specified value.
Public method | ToString | Converts the point to a string representation. (Overrides Object..::..ToString()()()().)

See Also

ItemPointer Class
Sitecore.Data Namespace


Parse Method

[image]

Sitecore 6.4.1 API
ItemPointer..::..Parse Method
ItemPointer Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ItemPointer Parse(
    string value
)
Visual Basic
Public Shared Function Parse ( _
    value As String _
) As ItemPointer
Visual C++
public:
static ItemPointer^ Parse(
    String^ value
)

Parameters

value
Type: System..::..String
Value.

Return Value

The parse.

See Also

ItemPointer Class
Sitecore.Data Namespace


ToString Method

[image]

Sitecore 6.4.1 API
ItemPointer..::..ToString Method
ItemPointer Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

ItemPointer Class
Sitecore.Data Namespace


ItemPointer Properties

[image] [image]

Sitecore 6.4.1 API
ItemPointer Properties
ItemPointer Class See Also Send Feedback

The ItemPointer type exposes the following members.

Properties

 | Name | Description
Public property | ItemID | Gets the item ID.
Public property | Language | Gets the language.
Public property | Version | Gets the version.

See Also

ItemPointer Class
Sitecore.Data Namespace


ItemID Property

[image]

Sitecore 6.4.1 API
ItemPointer..::..ItemID Property
ItemPointer Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ItemID { get; }
Visual Basic
Public ReadOnly Property ItemID As ID
    Get
Visual C++
public:
property ID^ ItemID {
    ID^ get ();
}

Field Value

The item ID.

See Also

ItemPointer Class
Sitecore.Data Namespace


Language Property

[image]

Sitecore 6.4.1 API
ItemPointer..::..Language Property
ItemPointer Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Language Language { get; }
Visual Basic
Public ReadOnly Property Language As Language
    Get
Visual C++
public:
property Language^ Language {
    Language^ get ();
}

Field Value

The language.

See Also

ItemPointer Class
Sitecore.Data Namespace


Version Property

[image]

Sitecore 6.4.1 API
ItemPointer..::..Version Property
ItemPointer Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Version Version { get; }
Visual Basic
Public ReadOnly Property Version As Version
    Get
Visual C++
public:
property Version^ Version {
    Version^ get ();
}

Field Value

The version.

See Also

ItemPointer Class
Sitecore.Data Namespace


ItemRecords Class

[image]

Sitecore 6.4.1 API
ItemRecords Class
Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemRecords : Database..::..DataRecords
Visual Basic
Public Class ItemRecords _
    Inherits Database..::..DataRecords
Visual C++
public ref class ItemRecords : public Database..::..DataRecords

Remarks

Normally items are accessed through the GetItem(ID) property.

Inheritance Hierarchy

System..::..Object
Sitecore.Data..::..Database..::..DataRecords
Sitecore.Data..::..ItemRecords

See Also

ItemRecords Members
Sitecore.Data Namespace


ItemRecords Members

[image] [image]

Sitecore 6.4.1 API
ItemRecords Members
ItemRecords Class Constructors Methods Properties See Also Send Feedback

The ItemRecords type exposes the following members.

Constructors

 | Name | Description
Public method | ItemRecords | Creates a new ItemRecords instance.

Methods

 | Name | Description
Protected method | DoGetItem(String) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(DataUri) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(String, Language) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID, Language) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(String, Language, Version) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID, Language, Version) | Gets the item. (Inherited from Database..::..DataRecords.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists(DataUri) | Gets a value that indicates if the data URI exists in the database. (Inherited from Database..::..DataRecords.)
Public method | Exists(ID) | Gets a value that indicates if the item ID exists in the database. (Inherited from Database..::..DataRecords.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItem(String) | Gets an item.
Public method | GetItem(DataUri) | Gets an item.
Public method | GetItem(ID) | Gets an item.
Public method | GetItem(String, Language) | Gets an item.
Public method | GetItem(ID, Language) | Gets an item.
Public method | GetItem(String, Language, Version) | Gets an item.
Public method | GetItem(ID, Language, Version) | Gets an item.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniquePath | Gets a unique path of an item in the database. (Inherited from Database..::..DataRecords.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BasePath | Gets the base path. (Inherited from Database..::..DataRecords.)
Public property | Database | Gets the database. (Inherited from Database..::..DataRecords.)
Public property | Item[([( String])]) | Gets the Item with the specified item path.
Public property | Item[([( DataUri])]) | Gets the Item with the specified URI.
Public property | Item[([( ID])]) | Gets the Item with the specified item ID.
Public property | Item[([( ItemPointer])]) | Gets the Item with the specified pointer.
Public property | Item[([( String, Language])]) | Gets the Item with the specified item path.
Public property | Item[([( ID, Language])]) | Gets the Item with the specified item ID.
Public property | Item[([( String, Language, Version])]) | Gets the Item with the specified item path.
Public property | Item[([( ID, Language, Version])]) | Gets the Item with the specified item ID.

See Also

ItemRecords Class
Sitecore.Data Namespace


ItemRecords Methods

[image] [image]

Sitecore 6.4.1 API
ItemRecords Methods
ItemRecords Class See Also Send Feedback

The ItemRecords type exposes the following members.

Methods

 | Name | Description
Protected method | DoGetItem(String) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(DataUri) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(String, Language) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID, Language) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(String, Language, Version) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID, Language, Version) | Gets the item. (Inherited from Database..::..DataRecords.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists(DataUri) | Gets a value that indicates if the data URI exists in the database. (Inherited from Database..::..DataRecords.)
Public method | Exists(ID) | Gets a value that indicates if the item ID exists in the database. (Inherited from Database..::..DataRecords.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItem(String) | Gets an item.
Public method | GetItem(DataUri) | Gets an item.
Public method | GetItem(ID) | Gets an item.
Public method | GetItem(String, Language) | Gets an item.
Public method | GetItem(ID, Language) | Gets an item.
Public method | GetItem(String, Language, Version) | Gets an item.
Public method | GetItem(ID, Language, Version) | Gets an item.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniquePath | Gets a unique path of an item in the database. (Inherited from Database..::..DataRecords.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemRecords Class
Sitecore.Data Namespace


DoGetItem Method

[image] [image]

Sitecore 6.4.1 API
ItemRecords..::..DoGetItem Method
ItemRecords Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | DoGetItem(String) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(DataUri) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(String, Language) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID, Language) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(String, Language, Version) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID, Language, Version) | Gets the item. (Inherited from Database..::..DataRecords.)

See Also

ItemRecords Class
ItemRecords Members
Sitecore.Data Namespace


Exists Method

[image] [image]

Sitecore 6.4.1 API
ItemRecords..::..Exists Method
ItemRecords Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Exists(DataUri) | Gets a value that indicates if the data URI exists in the database. (Inherited from Database..::..DataRecords.)
Public method | Exists(ID) | Gets a value that indicates if the item ID exists in the database. (Inherited from Database..::..DataRecords.)

See Also

ItemRecords Class
ItemRecords Members
Sitecore.Data Namespace


GetItem Method

[image] [image]

Sitecore 6.4.1 API
ItemRecords..::..GetItem Method
ItemRecords Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetItem(String) | Gets an item.
Public method | GetItem(DataUri) | Gets an item.
Public method | GetItem(ID) | Gets an item.
Public method | GetItem(String, Language) | Gets an item.
Public method | GetItem(ID, Language) | Gets an item.
Public method | GetItem(String, Language, Version) | Gets an item.
Public method | GetItem(ID, Language, Version) | Gets an item.

See Also

ItemRecords Class
ItemRecords Members
Sitecore.Data Namespace


GetItem Method (String)

[image]

Sitecore 6.4.1 API
ItemRecords..::..GetItem Method (String)
ItemRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetItem(
    string itemPath
)
Visual Basic
Public Function GetItem ( _
    itemPath As String _
) As Item
Visual C++
public:
Item^ GetItem(
    String^ itemPath
)

Parameters

itemPath
Type: System..::..String
Item path.

Return Value

The item.

See Also

ItemRecords Class
GetItem Overload
Sitecore.Data Namespace


GetItem Method (DataUri)

[image]

Sitecore 6.4.1 API
ItemRecords..::..GetItem Method (DataUri)
ItemRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetItem(
    DataUri uri
)
Visual Basic
Public Function GetItem ( _
    uri As DataUri _
) As Item
Visual C++
public:
Item^ GetItem(
    DataUri^ uri
)

Parameters

uri
Type: Sitecore.Data..::..DataUri
URI.

Return Value

The item.

See Also

ItemRecords Class
GetItem Overload
Sitecore.Data Namespace


GetItem Method (ID)

[image]

Sitecore 6.4.1 API
ItemRecords..::..GetItem Method (ID)
ItemRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetItem(
    ID itemID
)
Visual Basic
Public Function GetItem ( _
    itemID As ID _
) As Item
Visual C++
public:
Item^ GetItem(
    ID^ itemID
)

Parameters

itemID
Type: Sitecore.Data..::..ID
Item ID.

Return Value

The item.

See Also

ItemRecords Class
GetItem Overload
Sitecore.Data Namespace


GetItem Method (String, Language)

[image]

Sitecore 6.4.1 API
ItemRecords..::..GetItem Method (String, Language)
ItemRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetItem(
    string itemPath,
    Language language
)
Visual Basic
Public Function GetItem ( _
    itemPath As String, _
    language As Language _
) As Item
Visual C++
public:
Item^ GetItem(
    String^ itemPath,
    Language^ language
)

Parameters

itemPath
Type: System..::..String
Item path.
language
Type: Sitecore.Globalization..::..Language
Language.

Return Value

The item.

See Also

ItemRecords Class
GetItem Overload
Sitecore.Data Namespace


GetItem Method (ID, Language)

[image]

Sitecore 6.4.1 API
ItemRecords..::..GetItem Method (ID, Language)
ItemRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetItem(
    ID itemID,
    Language language
)
Visual Basic
Public Function GetItem ( _
    itemID As ID, _
    language As Language _
) As Item
Visual C++
public:
Item^ GetItem(
    ID^ itemID,
    Language^ language
)

Parameters

itemID
Type: Sitecore.Data..::..ID
Item ID.
language
Type: Sitecore.Globalization..::..Language
Language.

Return Value

The item.

See Also

ItemRecords Class
GetItem Overload
Sitecore.Data Namespace


GetItem Method (String, Language, Version)

[image]

Sitecore 6.4.1 API
ItemRecords..::..GetItem Method (String, Language, Version)
ItemRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetItem(
    string itemPath,
    Language language,
    Version version
)
Visual Basic
Public Function GetItem ( _
    itemPath As String, _
    language As Language, _
    version As Version _
) As Item
Visual C++
public:
Item^ GetItem(
    String^ itemPath,
    Language^ language,
    Version^ version
)

Parameters

itemPath
Type: System..::..String
Item path.
language
Type: Sitecore.Globalization..::..Language
Language.
version
Type: Sitecore.Data..::..Version
Version.

Return Value

The item.

See Also

ItemRecords Class
GetItem Overload
Sitecore.Data Namespace


GetItem Method (ID, Language, Version)

[image]

Sitecore 6.4.1 API
ItemRecords..::..GetItem Method (ID, Language, Version)
ItemRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetItem(
    ID itemID,
    Language language,
    Version version
)
Visual Basic
Public Function GetItem ( _
    itemID As ID, _
    language As Language, _
    version As Version _
) As Item
Visual C++
public:
Item^ GetItem(
    ID^ itemID,
    Language^ language,
    Version^ version
)

Parameters

itemID
Type: Sitecore.Data..::..ID
Item ID.
language
Type: Sitecore.Globalization..::..Language
Language.
version
Type: Sitecore.Data..::..Version
Version.

Return Value

The item.

See Also

ItemRecords Class
GetItem Overload
Sitecore.Data Namespace


ItemRecords Properties

[image] [image]

Sitecore 6.4.1 API
ItemRecords Properties
ItemRecords Class See Also Send Feedback

The ItemRecords type exposes the following members.

Properties

 | Name | Description
Public property | BasePath | Gets the base path. (Inherited from Database..::..DataRecords.)
Public property | Database | Gets the database. (Inherited from Database..::..DataRecords.)
Public property | Item[([( String])]) | Gets the Item with the specified item path.
Public property | Item[([( DataUri])]) | Gets the Item with the specified URI.
Public property | Item[([( ID])]) | Gets the Item with the specified item ID.
Public property | Item[([( ItemPointer])]) | Gets the Item with the specified pointer.
Public property | Item[([( String, Language])]) | Gets the Item with the specified item path.
Public property | Item[([( ID, Language])]) | Gets the Item with the specified item ID.
Public property | Item[([( String, Language, Version])]) | Gets the Item with the specified item path.
Public property | Item[([( ID, Language, Version])]) | Gets the Item with the specified item ID.

See Also

ItemRecords Class
Sitecore.Data Namespace


Item Property

[image] [image]

Sitecore 6.4.1 API
ItemRecords..::..Item Property
ItemRecords Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( String])]) | Gets the Item with the specified item path.
Public property | Item[([( DataUri])]) | Gets the Item with the specified URI.
Public property | Item[([( ID])]) | Gets the Item with the specified item ID.
Public property | Item[([( ItemPointer])]) | Gets the Item with the specified pointer.
Public property | Item[([( String, Language])]) | Gets the Item with the specified item path.
Public property | Item[([( ID, Language])]) | Gets the Item with the specified item ID.
Public property | Item[([( String, Language, Version])]) | Gets the Item with the specified item path.
Public property | Item[([( ID, Language, Version])]) | Gets the Item with the specified item ID.

See Also

ItemRecords Class
ItemRecords Members
Sitecore.Data Namespace


Item Property (String)

[image]

Sitecore 6.4.1 API
ItemRecords..::..Item Property (String)
ItemRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item this[
    string itemPath
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    itemPath As String _
) As Item
    Get
Visual C++
public:
property Item^ default[String^ itemPath] {
    Item^ get (String^ itemPath);
}

Parameters

itemPath
Type: System..::..String

See Also

ItemRecords Class
Item Overload
Sitecore.Data Namespace


Item Property (DataUri)

[image]

Sitecore 6.4.1 API
ItemRecords..::..Item Property (DataUri)
ItemRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item this[
    DataUri uri
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    uri As DataUri _
) As Item
    Get
Visual C++
public:
property Item^ default[DataUri^ uri] {
    Item^ get (DataUri^ uri);
}

Parameters

uri
Type: Sitecore.Data..::..DataUri

See Also

ItemRecords Class
Item Overload
Sitecore.Data Namespace


Item Property (ID)

[image]

Sitecore 6.4.1 API
ItemRecords..::..Item Property (ID)
ItemRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item this[
    ID itemID
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    itemID As ID _
) As Item
    Get
Visual C++
public:
property Item^ default[ID^ itemID] {
    Item^ get (ID^ itemID);
}

Parameters

itemID
Type: Sitecore.Data..::..ID

See Also

ItemRecords Class
Item Overload
Sitecore.Data Namespace


Item Property (ItemPointer)

[image]

Sitecore 6.4.1 API
ItemRecords..::..Item Property (ItemPointer)
ItemRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item this[
    ItemPointer pointer
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    pointer As ItemPointer _
) As Item
    Get
Visual C++
public:
property Item^ default[ItemPointer^ pointer] {
    Item^ get (ItemPointer^ pointer);
}

Parameters

pointer
Type: Sitecore.Data..::..ItemPointer

See Also

ItemRecords Class
Item Overload
Sitecore.Data Namespace


Item Property (String, Language)

[image]

Sitecore 6.4.1 API
ItemRecords..::..Item Property (String, Language)
ItemRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item this[
    string itemPath,
    Language language
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    itemPath As String, _
    language As Language _
) As Item
    Get
Visual C++
public:
property Item^ default[String^ itemPath, Language^ language] {
    Item^ get (String^ itemPath, Language^ language);
}

Parameters

itemPath
Type: System..::..String
language
Type: Sitecore.Globalization..::..Language

See Also

ItemRecords Class
Item Overload
Sitecore.Data Namespace


Item Property (ID, Language)

[image]

Sitecore 6.4.1 API
ItemRecords..::..Item Property (ID, Language)
ItemRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item this[
    ID itemID,
    Language language
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    itemID As ID, _
    language As Language _
) As Item
    Get
Visual C++
public:
property Item^ default[ID^ itemID, Language^ language] {
    Item^ get (ID^ itemID, Language^ language);
}

Parameters

itemID
Type: Sitecore.Data..::..ID
language
Type: Sitecore.Globalization..::..Language

See Also

ItemRecords Class
Item Overload
Sitecore.Data Namespace


Item Property (String, Language, Version)

[image]

Sitecore 6.4.1 API
ItemRecords..::..Item Property (String, Language, Version)
ItemRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item this[
    string itemPath,
    Language language,
    Version version
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    itemPath As String, _
    language As Language, _
    version As Version _
) As Item
    Get
Visual C++
public:
property Item^ default[String^ itemPath, Language^ language, Version^ version] {
    Item^ get (String^ itemPath, Language^ language, Version^ version);
}

Parameters

itemPath
Type: System..::..String
language
Type: Sitecore.Globalization..::..Language
version
Type: Sitecore.Data..::..Version

See Also

ItemRecords Class
Item Overload
Sitecore.Data Namespace


Item Property (ID, Language, Version)

[image]

Sitecore 6.4.1 API
ItemRecords..::..Item Property (ID, Language, Version)
ItemRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item this[
    ID itemID,
    Language language,
    Version version
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    itemID As ID, _
    language As Language, _
    version As Version _
) As Item
    Get
Visual C++
public:
property Item^ default[ID^ itemID, Language^ language, Version^ version] {
    Item^ get (ID^ itemID, Language^ language, Version^ version);
}

Parameters

itemID
Type: Sitecore.Data..::..ID
language
Type: Sitecore.Globalization..::..Language
version
Type: Sitecore.Data..::..Version

See Also

ItemRecords Class
Item Overload
Sitecore.Data Namespace


ItemUri Class

[image]

Sitecore 6.4.1 API
ItemUri Class
Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class ItemUri : ICloneable, ISerializable
Visual Basic
<SerializableAttribute> _
Public Class ItemUri _
    Implements ICloneable, ISerializable
Visual C++
[SerializableAttribute]
public ref class ItemUri : ICloneable,
    ISerializable

Remarks

An ItemUri is immutable and cannot be changed once created. To build an ItemUri dynamically use ItemUriBuilder.

Inheritance Hierarchy

System..::..Object
Sitecore.Data..::..ItemUri

See Also

ItemUri Members
Sitecore.Data Namespace


ItemUri Members

[image] [image]

Sitecore 6.4.1 API
ItemUri Members
ItemUri Class Constructors Methods Operators Properties See Also Send Feedback

The ItemUri type exposes the following members.

Constructors

 | Name | Description
Public method | ItemUri(String) | Creates a new ItemUri instance.
Public method | ItemUri(Item) | Creates a new ItemUri instance.
Public method | ItemUri(ItemUri) | Creates a new ItemUri instance.
Protected method | ItemUri(SerializationInfo, StreamingContext) | Initializes a new instance of the ItemUri class.
Public method | ItemUri(String, Database) | Creates a new ItemUri instance.
Public method | ItemUri(DataUri, Database) | Creates a new ItemUri instance.
Public method | ItemUri(ID, Database) | Creates a new ItemUri instance.
Public method | ItemUri(String, Language, Database) | Creates a new ItemUri instance.
Public method | ItemUri(ID, Language, Database) | Creates a new ItemUri instance.
Public method | ItemUri(String, Language, Version, Database) | Creates a new ItemUri instance.
Public method | ItemUri(String, Language, Version, String) | Creates a new ItemUri instance.
Public method | ItemUri(ID, Language, Version, Database) | Creates a new ItemUri instance.
Public method | ItemUri(ID, Language, Version, String) | Creates a new ItemUri instance.
Public method | ItemUri(ID, String, Language, Version, String) | Creates a new ItemUri instance.

Methods

 | Name | Description
Public method | AddToUrlString | Adds the Uri to the specified Url string.
Public method | Clone | Clones this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Overrides Object..::..GetHashCode()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetPathOrId | Gets the item path.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsItemUri | Checks if a path is an item URI.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Converts the string into an ItemUri.
 | ParseQueryString()()()() | Parses the query string.
 | ParseQueryString(Database) | Parses the query string.
Public method | ToDataUri | Converts the ItemUri to a DataUri.
Public method | ToString()()()() | Returns a string representing the URI. (Overrides Object..::..ToString()()()().)
Public method | ToString(ItemUriFormat) | Returns a string representing the URI.
Public method | ToUrlString | Converts the Uri to an Url.

Operators

Name | Description
Equality | Determines if two Uris are equal.
Inequality | Determines if two Uris are unequal.

Properties

 | Name | Description
Public property | DatabaseName | Gets the name of the database.
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | ItemID | Gets the item ID.
Public property | Language | Gets the language.
Public property | Path | Gets the path.
Public property | Version | Gets the version.

See Also

ItemUri Class
Sitecore.Data Namespace


ItemUri Constructor

[image] [image]

Sitecore 6.4.1 API
ItemUri Constructor
ItemUri Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ItemUri(String) | Creates a new ItemUri instance.
Public method | ItemUri(Item) | Creates a new ItemUri instance.
Public method | ItemUri(ItemUri) | Creates a new ItemUri instance.
Protected method | ItemUri(SerializationInfo, StreamingContext) | Initializes a new instance of the ItemUri class.
Public method | ItemUri(String, Database) | Creates a new ItemUri instance.
Public method | ItemUri(DataUri, Database) | Creates a new ItemUri instance.
Public method | ItemUri(ID, Database) | Creates a new ItemUri instance.
Public method | ItemUri(String, Language, Database) | Creates a new ItemUri instance.
Public method | ItemUri(ID, Language, Database) | Creates a new ItemUri instance.
Public method | ItemUri(String, Language, Version, Database) | Creates a new ItemUri instance.
Public method | ItemUri(String, Language, Version, String) | Creates a new ItemUri instance.
Public method | ItemUri(ID, Language, Version, Database) | Creates a new ItemUri instance.
Public method | ItemUri(ID, Language, Version, String) | Creates a new ItemUri instance.
Public method | ItemUri(ID, String, Language, Version, String) | Creates a new ItemUri instance.

See Also

ItemUri Class
ItemUri Members
Sitecore.Data Namespace


ItemUri Constructor (String)

[image]

Sitecore 6.4.1 API
ItemUri Constructor (String)
ItemUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemUri(
    string itemUri
)
Visual Basic
Public Sub New ( _
    itemUri As String _
)
Visual C++
public:
ItemUri(
    String^ itemUri
)

Parameters

itemUri
Type: System..::..String
Item URI.

See Also

ItemUri Class
ItemUri Overload
Sitecore.Data Namespace


ItemUri Constructor (Item)

[image]

Sitecore 6.4.1 API
ItemUri Constructor (Item)
ItemUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemUri(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
ItemUri(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

ItemUri Class
ItemUri Overload
Sitecore.Data Namespace


ItemUri Constructor (ItemUri)

[image]

Sitecore 6.4.1 API
ItemUri Constructor (ItemUri)
ItemUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemUri(
    ItemUri uri
)
Visual Basic
Public Sub New ( _
    uri As ItemUri _
)
Visual C++
public:
ItemUri(
    ItemUri^ uri
)

Parameters

uri
Type: Sitecore.Data..::..ItemUri
URI.

See Also

ItemUri Class
ItemUri Overload
Sitecore.Data Namespace


ItemUri Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
ItemUri Constructor (SerializationInfo, StreamingContext)
ItemUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected ItemUri(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
ItemUri(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

ItemUri Class
ItemUri Overload
Sitecore.Data Namespace


ItemUri Constructor (String, Database)

[image]

Sitecore 6.4.1 API
ItemUri Constructor (String, Database)
ItemUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemUri(
    string path,
    Database database
)
Visual Basic
Public Sub New ( _
    path As String, _
    database As Database _
)
Visual C++
public:
ItemUri(
    String^ path,
    Database^ database
)

Parameters

path
Type: System..::..String
Path.
database
Type: Sitecore.Data..::..Database
Database.

See Also

ItemUri Class
ItemUri Overload
Sitecore.Data Namespace


ItemUri Constructor (DataUri, Database)

[image]

Sitecore 6.4.1 API
ItemUri Constructor (DataUri, Database)
ItemUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemUri(
    DataUri dataUri,
    Database database
)
Visual Basic
Public Sub New ( _
    dataUri As DataUri, _
    database As Database _
)
Visual C++
public:
ItemUri(
    DataUri^ dataUri,
    Database^ database
)

Parameters

dataUri
Type: Sitecore.Data..::..DataUri
Data URI.
database
Type: Sitecore.Data..::..Database
Database.

See Also

ItemUri Class
ItemUri Overload
Sitecore.Data Namespace


ItemUri Constructor (ID, Database)

[image]

Sitecore 6.4.1 API
ItemUri Constructor (ID, Database)
ItemUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemUri(
    ID itemID,
    Database database
)
Visual Basic
Public Sub New ( _
    itemID As ID, _
    database As Database _
)
Visual C++
public:
ItemUri(
    ID^ itemID,
    Database^ database
)

Parameters

itemID
Type: Sitecore.Data..::..ID
Item ID.
database
Type: Sitecore.Data..::..Database
Database.

See Also

ItemUri Class
ItemUri Overload
Sitecore.Data Namespace


ItemUri Constructor (String, Language, Database)

[image]

Sitecore 6.4.1 API
ItemUri Constructor (String, Language, Database)
ItemUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemUri(
    string path,
    Language language,
    Database database
)
Visual Basic
Public Sub New ( _
    path As String, _
    language As Language, _
    database As Database _
)
Visual C++
public:
ItemUri(
    String^ path,
    Language^ language,
    Database^ database
)

Parameters

path
Type: System..::..String
Path.
language
Type: Sitecore.Globalization..::..Language
Language.
database
Type: Sitecore.Data..::..Database
Database.

See Also

ItemUri Class
ItemUri Overload
Sitecore.Data Namespace


ItemUri Constructor (ID, Language, Database)

[image]

Sitecore 6.4.1 API
ItemUri Constructor (ID, Language, Database)
ItemUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemUri(
    ID itemID,
    Language language,
    Database database
)
Visual Basic
Public Sub New ( _
    itemID As ID, _
    language As Language, _
    database As Database _
)
Visual C++
public:
ItemUri(
    ID^ itemID,
    Language^ language,
    Database^ database
)

Parameters

itemID
Type: Sitecore.Data..::..ID
Item ID.
language
Type: Sitecore.Globalization..::..Language
Language.
database
Type: Sitecore.Data..::..Database
Database.

See Also

ItemUri Class
ItemUri Overload
Sitecore.Data Namespace


ItemUri Constructor (String, Language, Version, Database)

[image]

Sitecore 6.4.1 API
ItemUri Constructor (String, Language, Version, Database)
ItemUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemUri(
    string path,
    Language language,
    Version version,
    Database database
)
Visual Basic
Public Sub New ( _
    path As String, _
    language As Language, _
    version As Version, _
    database As Database _
)
Visual C++
public:
ItemUri(
    String^ path,
    Language^ language,
    Version^ version,
    Database^ database
)

Parameters

path
Type: System..::..String
Path.
language
Type: Sitecore.Globalization..::..Language
Language.
version
Type: Sitecore.Data..::..Version
Version.
database
Type: Sitecore.Data..::..Database
Database.

See Also

ItemUri Class
ItemUri Overload
Sitecore.Data Namespace


ItemUri Constructor (String, Language, Version, String)

[image]

Sitecore 6.4.1 API
ItemUri Constructor (String, Language, Version, String)
ItemUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemUri(
    string path,
    Language language,
    Version version,
    string databaseName
)
Visual Basic
Public Sub New ( _
    path As String, _
    language As Language, _
    version As Version, _
    databaseName As String _
)
Visual C++
public:
ItemUri(
    String^ path,
    Language^ language,
    Version^ version,
    String^ databaseName
)

Parameters

path
Type: System..::..String
Path.
language
Type: Sitecore.Globalization..::..Language
Language.
version
Type: Sitecore.Data..::..Version
Version.
databaseName
Type: System..::..String
Name of the database.

See Also

ItemUri Class
ItemUri Overload
Sitecore.Data Namespace


ItemUri Constructor (ID, Language, Version, Database)

[image]

Sitecore 6.4.1 API
ItemUri Constructor (ID, Language, Version, Database)
ItemUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemUri(
    ID itemID,
    Language language,
    Version version,
    Database database
)
Visual Basic
Public Sub New ( _
    itemID As ID, _
    language As Language, _
    version As Version, _
    database As Database _
)
Visual C++
public:
ItemUri(
    ID^ itemID,
    Language^ language,
    Version^ version,
    Database^ database
)

Parameters

itemID
Type: Sitecore.Data..::..ID
Item ID.
language
Type: Sitecore.Globalization..::..Language
Language.
version
Type: Sitecore.Data..::..Version
Version.
database
Type: Sitecore.Data..::..Database
Database.

See Also

ItemUri Class
ItemUri Overload
Sitecore.Data Namespace


ItemUri Constructor (ID, Language, Version, String)

[image]

Sitecore 6.4.1 API
ItemUri Constructor (ID, Language, Version, String)
ItemUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemUri(
    ID itemID,
    Language language,
    Version version,
    string databaseName
)
Visual Basic
Public Sub New ( _
    itemID As ID, _
    language As Language, _
    version As Version, _
    databaseName As String _
)
Visual C++
public:
ItemUri(
    ID^ itemID,
    Language^ language,
    Version^ version,
    String^ databaseName
)

Parameters

itemID
Type: Sitecore.Data..::..ID
Item ID.
language
Type: Sitecore.Globalization..::..Language
Language.
version
Type: Sitecore.Data..::..Version
Version.
databaseName
Type: System..::..String
Name of the database.

See Also

ItemUri Class
ItemUri Overload
Sitecore.Data Namespace


ItemUri Constructor (ID, String, Language, Version, String)

[image]

Sitecore 6.4.1 API
ItemUri Constructor (ID, String, Language, Version, String)
ItemUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemUri(
    ID itemID,
    string path,
    Language language,
    Version version,
    string databaseName
)
Visual Basic
Public Sub New ( _
    itemID As ID, _
    path As String, _
    language As Language, _
    version As Version, _
    databaseName As String _
)
Visual C++
public:
ItemUri(
    ID^ itemID,
    String^ path,
    Language^ language,
    Version^ version,
    String^ databaseName
)

Parameters

itemID
Type: Sitecore.Data..::..ID
Item ID.
path
Type: System..::..String
Path.
language
Type: Sitecore.Globalization..::..Language
Language.
version
Type: Sitecore.Data..::..Version
Version.
databaseName
Type: System..::..String
Name of the database.

See Also

ItemUri Class
ItemUri Overload
Sitecore.Data Namespace


ItemUri Methods

[image] [image]

Sitecore 6.4.1 API
ItemUri Methods
ItemUri Class See Also Send Feedback

The ItemUri type exposes the following members.

Methods

 | Name | Description
Public method | AddToUrlString | Adds the Uri to the specified Url string.
Public method | Clone | Clones this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Overrides Object..::..GetHashCode()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetPathOrId | Gets the item path.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsItemUri | Checks if a path is an item URI.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Converts the string into an ItemUri.
 | ParseQueryString()()()() | Parses the query string.
 | ParseQueryString(Database) | Parses the query string.
Public method | ToDataUri | Converts the ItemUri to a DataUri.
Public method | ToString()()()() | Returns a string representing the URI. (Overrides Object..::..ToString()()()().)
Public method | ToString(ItemUriFormat) | Returns a string representing the URI.
Public method | ToUrlString | Converts the Uri to an Url.

See Also

ItemUri Class
Sitecore.Data Namespace


AddToUrlString Method

[image]

Sitecore 6.4.1 API
ItemUri..::..AddToUrlString Method
ItemUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddToUrlString(
    UrlString urlString
)
Visual Basic
Public Sub AddToUrlString ( _
    urlString As UrlString _
)
Visual C++
public:
void AddToUrlString(
    UrlString^ urlString
)

Parameters

urlString
Type: Sitecore.Text..::..UrlString
The Url string.

See Also

ItemUri Class
Sitecore.Data Namespace


Clone Method

[image]

Sitecore 6.4.1 API
ItemUri..::..Clone Method
ItemUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object
Visual C++
public:
virtual Object^ Clone() sealed

Return Value

A new object that is a copy of this instance.

Implements

ICloneable..::..Clone()()()()

See Also

ItemUri Class
Sitecore.Data Namespace


Equals Method

[image]

Sitecore 6.4.1 API
ItemUri..::..Equals Method
ItemUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

See Also

ItemUri Class
Sitecore.Data Namespace


GetHashCode Method

[image]

Sitecore 6.4.1 API
ItemUri..::..GetHashCode Method
ItemUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A hash code for the current Object.

See Also

ItemUri Class
Sitecore.Data Namespace


GetObjectData Method

[image]

Sitecore 6.4.1 API
ItemUri..::..GetObjectData Method
ItemUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System.Security..::..SecurityException | The caller does not have the required permission.

See Also

ItemUri Class
Sitecore.Data Namespace


GetPathOrId Method

[image]

Sitecore 6.4.1 API
ItemUri..::..GetPathOrId Method
ItemUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetPathOrId()
Visual Basic
Public Function GetPathOrId As String
Visual C++
public:
String^ GetPathOrId()

Return Value

The item path.

See Also

ItemUri Class
Sitecore.Data Namespace


IsItemUri Method

[image]

Sitecore 6.4.1 API
ItemUri..::..IsItemUri Method
ItemUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsItemUri(
    string path
)
Visual Basic
Public Shared Function IsItemUri ( _
    path As String _
) As Boolean
Visual C++
public:
static bool IsItemUri(
    String^ path
)

Parameters

path
Type: System..::..String
The path.

Return Value

true if the path is an item URI; false otherwise.

See Also

ItemUri Class
Sitecore.Data Namespace


Parse Method

[image]

Sitecore 6.4.1 API
ItemUri..::..Parse Method
ItemUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ItemUri Parse(
    string itemUri
)
Visual Basic
Public Shared Function Parse ( _
    itemUri As String _
) As ItemUri
Visual C++
public:
static ItemUri^ Parse(
    String^ itemUri
)

Parameters

itemUri
Type: System..::..String
Item URI.

Return Value

The parse.

See Also

ItemUri Class
Sitecore.Data Namespace


ParseQueryString Method

[image] [image]

Sitecore 6.4.1 API
ItemUri..::..ParseQueryString Method
ItemUri Class See Also Send Feedback

Overload List

Name | Description
ParseQueryString()()()() | Parses the query string.
ParseQueryString(Database) | Parses the query string.

See Also

ItemUri Class
ItemUri Members
Sitecore.Data Namespace


ParseQueryString Method

[image]

Sitecore 6.4.1 API
ItemUri..::..ParseQueryString Method
ItemUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ItemUri ParseQueryString()
Visual Basic
Public Shared Function ParseQueryString As ItemUri
Visual C++
public:
static ItemUri^ ParseQueryString()

Return Value

The query string.

See Also

ItemUri Class
ParseQueryString Overload
Sitecore.Data Namespace


ParseQueryString Method (Database)

[image]

Sitecore 6.4.1 API
ItemUri..::..ParseQueryString Method (Database)
ItemUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ItemUri ParseQueryString(
    Database database
)
Visual Basic
Public Shared Function ParseQueryString ( _
    database As Database _
) As ItemUri
Visual C++
public:
static ItemUri^ ParseQueryString(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

Return Value

The query string.

See Also

ItemUri Class
ParseQueryString Overload
Sitecore.Data Namespace


ToDataUri Method

[image]

Sitecore 6.4.1 API
ItemUri..::..ToDataUri Method
ItemUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataUri ToDataUri()
Visual Basic
Public Function ToDataUri As DataUri
Visual C++
public:
DataUri^ ToDataUri()

Return Value

The data URI.

See Also

ItemUri Class
Sitecore.Data Namespace


ToString Method

[image] [image]

Sitecore 6.4.1 API
ItemUri..::..ToString Method
ItemUri Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Returns a string representing the URI. (Overrides Object..::..ToString()()()().)
Public method | ToString(ItemUriFormat) | Returns a string representing the URI.

See Also

ItemUri Class
ItemUri Members
Sitecore.Data Namespace


ToString Method

[image]

Sitecore 6.4.1 API
ItemUri..::..ToString Method
ItemUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

ItemUri Class
ToString Overload
Sitecore.Data Namespace


ToString Method (ItemUriFormat)

[image]

Sitecore 6.4.1 API
ItemUri..::..ToString Method (ItemUriFormat)
ItemUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ToString(
    ItemUriFormat format
)
Visual Basic
Public Function ToString ( _
    format As ItemUriFormat _
) As String
Visual C++
public:
String^ ToString(
    ItemUriFormat format
)

Parameters

format
Type: Sitecore.Data..::..ItemUriFormat
The format.

Return Value

A String that represents the current Object.

See Also

ItemUri Class
ToString Overload
Sitecore.Data Namespace


ItemUri Operators

[image] [image]

Sitecore 6.4.1 API
ItemUri Operators
ItemUri Class See Also Send Feedback

The ItemUri type exposes the following members.

Operators

Name | Description
Equality | Determines if two Uris are equal.
Inequality | Determines if two Uris are unequal.

See Also

ItemUri Class
Sitecore.Data Namespace


Equality Operator

[image]

Sitecore 6.4.1 API
ItemUri..::..Equality Operator
ItemUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool operator ==(
    ItemUri uri1,
    ItemUri uri2
)
Visual Basic
Public Shared Operator = ( _
    uri1 As ItemUri, _
    uri2 As ItemUri _
) As Boolean
Visual C++
public:
static bool operator ==(
    ItemUri^ uri1,
    ItemUri^ uri2
)

Parameters

uri1
Type: Sitecore.Data..::..ItemUri
The uri1.
uri2
Type: Sitecore.Data..::..ItemUri
The uri2.

Return Value

The operator ==.

See Also

ItemUri Class
Sitecore.Data Namespace


Inequality Operator

[image]

Sitecore 6.4.1 API
ItemUri..::..Inequality Operator
ItemUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool operator !=(
    ItemUri uri1,
    ItemUri uri2
)
Visual Basic
Public Shared Operator <> ( _
    uri1 As ItemUri, _
    uri2 As ItemUri _
) As Boolean
Visual C++
public:
static bool operator !=(
    ItemUri^ uri1,
    ItemUri^ uri2
)

Parameters

uri1
Type: Sitecore.Data..::..ItemUri
The uri1.
uri2
Type: Sitecore.Data..::..ItemUri
The uri2.

Return Value

The operator !=.

See Also

ItemUri Class
Sitecore.Data Namespace


ItemUri Properties

[image] [image]

Sitecore 6.4.1 API
ItemUri Properties
ItemUri Class See Also Send Feedback

The ItemUri type exposes the following members.

Properties

 | Name | Description
Public property | DatabaseName | Gets the name of the database.
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | ItemID | Gets the item ID.
Public property | Language | Gets the language.
Public property | Path | Gets the path.
Public property | Version | Gets the version.

See Also

ItemUri Class
Sitecore.Data Namespace


DatabaseName Property

[image]

Sitecore 6.4.1 API
ItemUri..::..DatabaseName Property
ItemUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string DatabaseName { get; }
Visual Basic
Public ReadOnly Property DatabaseName As String
    Get
Visual C++
public:
property String^ DatabaseName {
    String^ get ();
}

Field Value

The name of the database.

See Also

ItemUri Class
Sitecore.Data Namespace


IsEmpty Property

[image]

Sitecore 6.4.1 API
ItemUri..::..IsEmpty Property
ItemUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
property bool IsEmpty {
    bool get ();
}

Field Value

true if this instance is empty; otherwise, false.

See Also

ItemUri Class
Sitecore.Data Namespace


ItemID Property

[image]

Sitecore 6.4.1 API
ItemUri..::..ItemID Property
ItemUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ItemID { get; }
Visual Basic
Public ReadOnly Property ItemID As ID
    Get
Visual C++
public:
property ID^ ItemID {
    ID^ get ();
}

Field Value

The item ID.

See Also

ItemUri Class
Sitecore.Data Namespace


Language Property

[image]

Sitecore 6.4.1 API
ItemUri..::..Language Property
ItemUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Language Language { get; }
Visual Basic
Public ReadOnly Property Language As Language
    Get
Visual C++
public:
property Language^ Language {
    Language^ get ();
}

Field Value

The language.

See Also

ItemUri Class
Sitecore.Data Namespace


Path Property

[image]

Sitecore 6.4.1 API
ItemUri..::..Path Property
ItemUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Path { get; }
Visual Basic
Public ReadOnly Property Path As String
    Get
Visual C++
public:
property String^ Path {
    String^ get ();
}

Field Value

The path.

See Also

ItemUri Class
Sitecore.Data Namespace


Version Property

[image]

Sitecore 6.4.1 API
ItemUri..::..Version Property
ItemUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Version Version { get; }
Visual Basic
Public ReadOnly Property Version As Version
    Get
Visual C++
public:
property Version^ Version {
    Version^ get ();
}

Field Value

The version.

See Also

ItemUri Class
Sitecore.Data Namespace


ItemUriBuilder Members

[image] [image]

Sitecore 6.4.1 API
ItemUriBuilder Members
ItemUriBuilder Class Constructors Methods Properties See Also Send Feedback

The ItemUriBuilder type exposes the following members.

Constructors

 | Name | Description
Public method | ItemUriBuilder(String) | Creates a new ItemUriBuilder instance.
Public method | ItemUriBuilder(ID) | Creates a new ItemUriBuilder instance.
Public method | ItemUriBuilder(ItemUri) | Creates a new ItemUriBuilder instance.
Public method | ItemUriBuilder(String, Database) | Creates a new ItemUriBuilder instance.
Public method | ItemUriBuilder(String, Language) | Creates a new ItemUriBuilder instance.
Public method | ItemUriBuilder(ID, Language) | Creates a new ItemUriBuilder instance.
Public method | ItemUriBuilder(String, Language, Version) | Creates a new ItemUriBuilder instance.
Public method | ItemUriBuilder(ID, Language, Version) | Creates a new ItemUriBuilder instance.
Public method | ItemUriBuilder(String, Language, Version, String) | Creates a new ItemUriBuilder instance.
Public method | ItemUriBuilder(ID, Language, Version, Database) | Creates a new ItemUriBuilder instance.
Public method | ItemUriBuilder(ID, Language, Version, String) | Creates a new ItemUriBuilder instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DatabaseName | Gets or sets the name of the database.
Public property | ItemID | Gets or sets the item ID.
Public property | ItemUri | Gets the item URI.
Public property | Language | Gets or sets the language.
Public property | Path | Gets or sets the path.
Public property | Version | Gets or sets the version.

See Also

ItemUriBuilder Class
Sitecore.Data Namespace


ItemUriBuilder Constructor

[image] [image]

Sitecore 6.4.1 API
ItemUriBuilder Constructor
ItemUriBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ItemUriBuilder(String) | Creates a new ItemUriBuilder instance.
Public method | ItemUriBuilder(ID) | Creates a new ItemUriBuilder instance.
Public method | ItemUriBuilder(ItemUri) | Creates a new ItemUriBuilder instance.
Public method | ItemUriBuilder(String, Database) | Creates a new ItemUriBuilder instance.
Public method | ItemUriBuilder(String, Language) | Creates a new ItemUriBuilder instance.
Public method | ItemUriBuilder(ID, Language) | Creates a new ItemUriBuilder instance.
Public method | ItemUriBuilder(String, Language, Version) | Creates a new ItemUriBuilder instance.
Public method | ItemUriBuilder(ID, Language, Version) | Creates a new ItemUriBuilder instance.
Public method | ItemUriBuilder(String, Language, Version, String) | Creates a new ItemUriBuilder instance.
Public method | ItemUriBuilder(ID, Language, Version, Database) | Creates a new ItemUriBuilder instance.
Public method | ItemUriBuilder(ID, Language, Version, String) | Creates a new ItemUriBuilder instance.

See Also

ItemUriBuilder Class
ItemUriBuilder Members
Sitecore.Data Namespace


ItemUriBuilder Constructor (String)

[image]

Sitecore 6.4.1 API
ItemUriBuilder Constructor (String)
ItemUriBuilder Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemUriBuilder(
    string path
)
Visual Basic
Public Sub New ( _
    path As String _
)
Visual C++
public:
ItemUriBuilder(
    String^ path
)

Parameters

path
Type: System..::..String
Path.

See Also

ItemUriBuilder Class
ItemUriBuilder Overload
Sitecore.Data Namespace


ItemUriBuilder Constructor (ID)

[image]

Sitecore 6.4.1 API
ItemUriBuilder Constructor (ID)
ItemUriBuilder Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemUriBuilder(
    ID itemID
)
Visual Basic
Public Sub New ( _
    itemID As ID _
)
Visual C++
public:
ItemUriBuilder(
    ID^ itemID
)

Parameters

itemID
Type: Sitecore.Data..::..ID
Item ID.

See Also

ItemUriBuilder Class
ItemUriBuilder Overload
Sitecore.Data Namespace


ItemUriBuilder Constructor (ItemUri)

[image]

Sitecore 6.4.1 API
ItemUriBuilder Constructor (ItemUri)
ItemUriBuilder Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemUriBuilder(
    ItemUri uri
)
Visual Basic
Public Sub New ( _
    uri As ItemUri _
)
Visual C++
public:
ItemUriBuilder(
    ItemUri^ uri
)

Parameters

uri
Type: Sitecore.Data..::..ItemUri
URI.

See Also

ItemUriBuilder Class
ItemUriBuilder Overload
Sitecore.Data Namespace


ItemUriBuilder Constructor (String, Database)

[image]

Sitecore 6.4.1 API
ItemUriBuilder Constructor (String, Database)
ItemUriBuilder Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemUriBuilder(
    string path,
    Database database
)
Visual Basic
Public Sub New ( _
    path As String, _
    database As Database _
)
Visual C++
public:
ItemUriBuilder(
    String^ path,
    Database^ database
)

Parameters

path
Type: System..::..String
Path.
database
Type: Sitecore.Data..::..Database
Database.

See Also

ItemUriBuilder Class
ItemUriBuilder Overload
Sitecore.Data Namespace


ItemUriBuilder Constructor (String, Language)

[image]

Sitecore 6.4.1 API
ItemUriBuilder Constructor (String, Language)
ItemUriBuilder Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemUriBuilder(
    string path,
    Language language
)
Visual Basic
Public Sub New ( _
    path As String, _
    language As Language _
)
Visual C++
public:
ItemUriBuilder(
    String^ path,
    Language^ language
)

Parameters

path
Type: System..::..String
Path.
language
Type: Sitecore.Globalization..::..Language
Language.

See Also

ItemUriBuilder Class
ItemUriBuilder Overload
Sitecore.Data Namespace


ItemUriBuilder Constructor (ID, Language)

[image]

Sitecore 6.4.1 API
ItemUriBuilder Constructor (ID, Language)
ItemUriBuilder Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemUriBuilder(
    ID itemID,
    Language language
)
Visual Basic
Public Sub New ( _
    itemID As ID, _
    language As Language _
)
Visual C++
public:
ItemUriBuilder(
    ID^ itemID,
    Language^ language
)

Parameters

itemID
Type: Sitecore.Data..::..ID
Item ID.
language
Type: Sitecore.Globalization..::..Language
Language.

See Also

ItemUriBuilder Class
ItemUriBuilder Overload
Sitecore.Data Namespace


ItemUriBuilder Constructor (String, Language, Version)

[image]

Sitecore 6.4.1 API
ItemUriBuilder Constructor (String, Language, Version)
ItemUriBuilder Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemUriBuilder(
    string path,
    Language language,
    Version version
)
Visual Basic
Public Sub New ( _
    path As String, _
    language As Language, _
    version As Version _
)
Visual C++
public:
ItemUriBuilder(
    String^ path,
    Language^ language,
    Version^ version
)

Parameters

path
Type: System..::..String
Path.
language
Type: Sitecore.Globalization..::..Language
Language.
version
Type: Sitecore.Data..::..Version
Version.

See Also

ItemUriBuilder Class
ItemUriBuilder Overload
Sitecore.Data Namespace


ItemUriBuilder Constructor (ID, Language, Version)

[image]

Sitecore 6.4.1 API
ItemUriBuilder Constructor (ID, Language, Version)
ItemUriBuilder Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemUriBuilder(
    ID itemID,
    Language language,
    Version version
)
Visual Basic
Public Sub New ( _
    itemID As ID, _
    language As Language, _
    version As Version _
)
Visual C++
public:
ItemUriBuilder(
    ID^ itemID,
    Language^ language,
    Version^ version
)

Parameters

itemID
Type: Sitecore.Data..::..ID
Item ID.
language
Type: Sitecore.Globalization..::..Language
Language.
version
Type: Sitecore.Data..::..Version
Version.

See Also

ItemUriBuilder Class
ItemUriBuilder Overload
Sitecore.Data Namespace


ItemUriBuilder Constructor (String, Language, Version, String)

[image]

Sitecore 6.4.1 API
ItemUriBuilder Constructor (String, Language, Version, String)
ItemUriBuilder Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemUriBuilder(
    string path,
    Language language,
    Version version,
    string databaseName
)
Visual Basic
Public Sub New ( _
    path As String, _
    language As Language, _
    version As Version, _
    databaseName As String _
)
Visual C++
public:
ItemUriBuilder(
    String^ path,
    Language^ language,
    Version^ version,
    String^ databaseName
)

Parameters

path
Type: System..::..String
Path.
language
Type: Sitecore.Globalization..::..Language
Language.
version
Type: Sitecore.Data..::..Version
Version.
databaseName
Type: System..::..String
Name of the database.

See Also

ItemUriBuilder Class
ItemUriBuilder Overload
Sitecore.Data Namespace


ItemUriBuilder Constructor (ID, Language, Version, Database)

[image]

Sitecore 6.4.1 API
ItemUriBuilder Constructor (ID, Language, Version, Database)
ItemUriBuilder Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemUriBuilder(
    ID itemID,
    Language language,
    Version version,
    Database database
)
Visual Basic
Public Sub New ( _
    itemID As ID, _
    language As Language, _
    version As Version, _
    database As Database _
)
Visual C++
public:
ItemUriBuilder(
    ID^ itemID,
    Language^ language,
    Version^ version,
    Database^ database
)

Parameters

itemID
Type: Sitecore.Data..::..ID
Item ID.
language
Type: Sitecore.Globalization..::..Language
Language.
version
Type: Sitecore.Data..::..Version
Version.
database
Type: Sitecore.Data..::..Database
Database.

See Also

ItemUriBuilder Class
ItemUriBuilder Overload
Sitecore.Data Namespace


ItemUriBuilder Constructor (ID, Language, Version, String)

[image]

Sitecore 6.4.1 API
ItemUriBuilder Constructor (ID, Language, Version, String)
ItemUriBuilder Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemUriBuilder(
    ID itemID,
    Language language,
    Version version,
    string databaseName
)
Visual Basic
Public Sub New ( _
    itemID As ID, _
    language As Language, _
    version As Version, _
    databaseName As String _
)
Visual C++
public:
ItemUriBuilder(
    ID^ itemID,
    Language^ language,
    Version^ version,
    String^ databaseName
)

Parameters

itemID
Type: Sitecore.Data..::..ID
Item ID.
language
Type: Sitecore.Globalization..::..Language
Language.
version
Type: Sitecore.Data..::..Version
Version.
databaseName
Type: System..::..String
Name of the database.

See Also

ItemUriBuilder Class
ItemUriBuilder Overload
Sitecore.Data Namespace


ItemUriBuilder Methods

[image] [image]

Sitecore 6.4.1 API
ItemUriBuilder Methods
ItemUriBuilder Class See Also Send Feedback

The ItemUriBuilder type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemUriBuilder Class
Sitecore.Data Namespace


ItemUriBuilder Properties

[image] [image]

Sitecore 6.4.1 API
ItemUriBuilder Properties
ItemUriBuilder Class See Also Send Feedback

The ItemUriBuilder type exposes the following members.

Properties

 | Name | Description
Public property | DatabaseName | Gets or sets the name of the database.
Public property | ItemID | Gets or sets the item ID.
Public property | ItemUri | Gets the item URI.
Public property | Language | Gets or sets the language.
Public property | Path | Gets or sets the path.
Public property | Version | Gets or sets the version.

See Also

ItemUriBuilder Class
Sitecore.Data Namespace


DatabaseName Property

[image]

Sitecore 6.4.1 API
ItemUriBuilder..::..DatabaseName Property
ItemUriBuilder Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string DatabaseName { get; set; }
Visual Basic
Public Property DatabaseName As String
    Get
    Set
Visual C++
public:
property String^ DatabaseName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the database.

See Also

ItemUriBuilder Class
Sitecore.Data Namespace


ItemID Property

[image]

Sitecore 6.4.1 API
ItemUriBuilder..::..ItemID Property
ItemUriBuilder Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ItemID { get; set; }
Visual Basic
Public Property ItemID As ID
    Get
    Set
Visual C++
public:
property ID^ ItemID {
    ID^ get ();
    void set (ID^ value);
}

Field Value

The item ID.

See Also

ItemUriBuilder Class
Sitecore.Data Namespace


ItemUri Property

[image]

Sitecore 6.4.1 API
ItemUriBuilder..::..ItemUri Property
ItemUriBuilder Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemUri ItemUri { get; }
Visual Basic
Public ReadOnly Property ItemUri As ItemUri
    Get
Visual C++
public:
property ItemUri^ ItemUri {
    ItemUri^ get ();
}

Field Value

The item URI.

See Also

ItemUriBuilder Class
Sitecore.Data Namespace


Language Property

[image]

Sitecore 6.4.1 API
ItemUriBuilder..::..Language Property
ItemUriBuilder Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Language Language { get; set; }
Visual Basic
Public Property Language As Language
    Get
    Set
Visual C++
public:
property Language^ Language {
    Language^ get ();
    void set (Language^ value);
}

Field Value

The language.

See Also

ItemUriBuilder Class
Sitecore.Data Namespace


Path Property

[image]

Sitecore 6.4.1 API
ItemUriBuilder..::..Path Property
ItemUriBuilder Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Path { get; set; }
Visual Basic
Public Property Path As String
    Get
    Set
Visual C++
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}

Field Value

The path.

See Also

ItemUriBuilder Class
Sitecore.Data Namespace


Version Property

[image]

Sitecore 6.4.1 API
ItemUriBuilder..::..Version Property
ItemUriBuilder Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Version Version { get; set; }
Visual Basic
Public Property Version As Version
    Get
    Set
Visual C++
public:
property Version^ Version {
    Version^ get ();
    void set (Version^ value);
}

Field Value

The version.

See Also

ItemUriBuilder Class
Sitecore.Data Namespace


ItemUriFormat Enumeration

[image]

Sitecore 6.4.1 API
ItemUriFormat Enumeration
See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum ItemUriFormat
Visual Basic
Public Enumeration ItemUriFormat
Visual C++
public enum class ItemUriFormat

Members

Member name | Value | Description
Uri | 0 | Uri.
QueryString | 1 | QueryString.
Message | 2 | Message.

See Also

Sitecore.Data Namespace


LayoutRecords Class

[image]

Sitecore 6.4.1 API
LayoutRecords Class
Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class LayoutRecords : Database..::..DataRecords
Visual Basic
Public Class LayoutRecords _
    Inherits Database..::..DataRecords
Visual C++
public ref class LayoutRecords : public Database..::..DataRecords

Remarks

Layouts are configured in /sitecore/layouts/Layout/Layouts.

The devices are normally access through the Layouts property.

Inheritance Hierarchy

System..::..Object
Sitecore.Data..::..Database..::..DataRecords
Sitecore.Data..::..LayoutRecords

See Also

LayoutRecords Members
Sitecore.Data Namespace


LayoutRecords Constructor

[image]

Sitecore 6.4.1 API
LayoutRecords Constructor
LayoutRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LayoutRecords(
    Database database
)
Visual Basic
Public Sub New ( _
    database As Database _
)
Visual C++
public:
LayoutRecords(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
Database.

See Also

LayoutRecords Class
Sitecore.Data Namespace


LayoutRecords Methods

[image] [image]

Sitecore 6.4.1 API
LayoutRecords Methods
LayoutRecords Class See Also Send Feedback

The LayoutRecords type exposes the following members.

Methods

 | Name | Description
Protected method | DoGetItem(String) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(DataUri) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(String, Language) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID, Language) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(String, Language, Version) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID, Language, Version) | Gets the item. (Inherited from Database..::..DataRecords.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists(DataUri) | Gets a value that indicates if the data URI exists in the database. (Inherited from Database..::..DataRecords.)
Public method | Exists(ID) | Gets a value that indicates if the item ID exists in the database. (Inherited from Database..::..DataRecords.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniquePath | Gets a unique path of an item in the database. (Inherited from Database..::..DataRecords.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LayoutRecords Class
Sitecore.Data Namespace


DoGetItem Method

[image] [image]

Sitecore 6.4.1 API
LayoutRecords..::..DoGetItem Method
LayoutRecords Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | DoGetItem(String) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(DataUri) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(String, Language) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID, Language) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(String, Language, Version) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID, Language, Version) | Gets the item. (Inherited from Database..::..DataRecords.)

See Also

LayoutRecords Class
LayoutRecords Members
Sitecore.Data Namespace


Exists Method

[image] [image]

Sitecore 6.4.1 API
LayoutRecords..::..Exists Method
LayoutRecords Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Exists(DataUri) | Gets a value that indicates if the data URI exists in the database. (Inherited from Database..::..DataRecords.)
Public method | Exists(ID) | Gets a value that indicates if the item ID exists in the database. (Inherited from Database..::..DataRecords.)

See Also

LayoutRecords Class
LayoutRecords Members
Sitecore.Data Namespace


Item Property

[image] [image]

Sitecore 6.4.1 API
LayoutRecords..::..Item Property
LayoutRecords Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( String])]) | Gets the LayoutItem with the specified item path.
Public property | Item[([( DataUri])]) | Gets the LayoutItem with the specified URI.
Public property | Item[([( ID])]) | Gets the LayoutItem with the specified item ID.
Public property | Item[([( String, Language])]) | Gets the LayoutItem with the specified item path.
Public property | Item[([( ID, Language])]) | Gets the LayoutItem with the specified item ID.
Public property | Item[([( String, Language, Version])]) | Gets the LayoutItem with the specified item path.
Public property | Item[([( ID, Language, Version])]) | Gets the LayoutItem with the specified item ID.

See Also

LayoutRecords Class
LayoutRecords Members
Sitecore.Data Namespace


Item Property (String)

[image]

Sitecore 6.4.1 API
LayoutRecords..::..Item Property (String)
LayoutRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LayoutItem this[
    string itemPath
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    itemPath As String _
) As LayoutItem
    Get
Visual C++
public:
property LayoutItem^ default[String^ itemPath] {
    LayoutItem^ get (String^ itemPath);
}

Parameters

itemPath
Type: System..::..String

See Also

LayoutRecords Class
Item Overload
Sitecore.Data Namespace


Item Property (DataUri)

[image]

Sitecore 6.4.1 API
LayoutRecords..::..Item Property (DataUri)
LayoutRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LayoutItem this[
    DataUri uri
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    uri As DataUri _
) As LayoutItem
    Get
Visual C++
public:
property LayoutItem^ default[DataUri^ uri] {
    LayoutItem^ get (DataUri^ uri);
}

Parameters

uri
Type: Sitecore.Data..::..DataUri

See Also

LayoutRecords Class
Item Overload
Sitecore.Data Namespace


Item Property (String, Language)

[image]

Sitecore 6.4.1 API
LayoutRecords..::..Item Property (String, Language)
LayoutRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LayoutItem this[
    string itemPath,
    Language language
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    itemPath As String, _
    language As Language _
) As LayoutItem
    Get
Visual C++
public:
property LayoutItem^ default[String^ itemPath, Language^ language] {
    LayoutItem^ get (String^ itemPath, Language^ language);
}

Parameters

itemPath
Type: System..::..String
language
Type: Sitecore.Globalization..::..Language

See Also

LayoutRecords Class
Item Overload
Sitecore.Data Namespace


Item Property (ID, Language)

[image]

Sitecore 6.4.1 API
LayoutRecords..::..Item Property (ID, Language)
LayoutRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LayoutItem this[
    ID itemID,
    Language language
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    itemID As ID, _
    language As Language _
) As LayoutItem
    Get
Visual C++
public:
property LayoutItem^ default[ID^ itemID, Language^ language] {
    LayoutItem^ get (ID^ itemID, Language^ language);
}

Parameters

itemID
Type: Sitecore.Data..::..ID
language
Type: Sitecore.Globalization..::..Language

See Also

LayoutRecords Class
Item Overload
Sitecore.Data Namespace


Item Property (String, Language, Version)

[image]

Sitecore 6.4.1 API
LayoutRecords..::..Item Property (String, Language, Version)
LayoutRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LayoutItem this[
    string itemPath,
    Language language,
    Version version
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    itemPath As String, _
    language As Language, _
    version As Version _
) As LayoutItem
    Get
Visual C++
public:
property LayoutItem^ default[String^ itemPath, Language^ language, Version^ version] {
    LayoutItem^ get (String^ itemPath, Language^ language, Version^ version);
}

Parameters

itemPath
Type: System..::..String
language
Type: Sitecore.Globalization..::..Language
version
Type: Sitecore.Data..::..Version

See Also

LayoutRecords Class
Item Overload
Sitecore.Data Namespace


Item Property (ID, Language, Version)

[image]

Sitecore 6.4.1 API
LayoutRecords..::..Item Property (ID, Language, Version)
LayoutRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LayoutItem this[
    ID itemID,
    Language language,
    Version version
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    itemID As ID, _
    language As Language, _
    version As Version _
) As LayoutItem
    Get
Visual C++
public:
property LayoutItem^ default[ID^ itemID, Language^ language, Version^ version] {
    LayoutItem^ get (ID^ itemID, Language^ language, Version^ version);
}

Parameters

itemID
Type: Sitecore.Data..::..ID
language
Type: Sitecore.Globalization..::..Language
version
Type: Sitecore.Data..::..Version

See Also

LayoutRecords Class
Item Overload
Sitecore.Data Namespace


LongID Structure

[image]

Sitecore 6.4.1 API
LongID Structure
Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public struct LongID
Visual Basic
Public Structure LongID
Visual C++
public value class LongID

Remarks

A LongID contains a path of IDs, e.g. "/{678E49BA-7D1F-48E2-BE86-35824C641556}/{61624451-6216-4C5D-AF67-46FF91442DF7}".

This will uniquely identify an item within a database that supports virtual links.

See Also

LongID Members
Sitecore.Data Namespace


LongID Members

[image] [image]

Sitecore 6.4.1 API
LongID Members
LongID Structure Methods See Also Send Feedback

The LongID type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsLongID | Tests if a string is a valid LongID.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToID | Converts a LongID to an ID.
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

LongID Structure
Sitecore.Data Namespace


LongID Methods

[image] [image]

Sitecore 6.4.1 API
LongID Methods
LongID Structure See Also Send Feedback

The LongID type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsLongID | Tests if a string is a valid LongID.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToID | Converts a LongID to an ID.
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

LongID Structure
Sitecore.Data Namespace


IsLongID Method

[image]

Sitecore 6.4.1 API
LongID..::..IsLongID Method
LongID Structure See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsLongID(
    string id
)
Visual Basic
Public Shared Function IsLongID ( _
    id As String _
) As Boolean
Visual C++
public:
static bool IsLongID(
    String^ id
)

Parameters

id
Type: System..::..String
The id.

Return Value

true if [is long ID] [the specified id]; otherwise, false.

See Also

LongID Structure
Sitecore.Data Namespace


ToID Method

[image]

Sitecore 6.4.1 API
LongID..::..ToID Method
LongID Structure See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ToID(
    string longID
)
Visual Basic
Public Shared Function ToID ( _
    longID As String _
) As String
Visual C++
public:
static String^ ToID(
    String^ longID
)

Parameters

longID
Type: System..::..String
The long ID.

Return Value

The ID.

See Also

LongID Structure
Sitecore.Data Namespace


MasterVariablesReplacer Members

[image] [image]

Sitecore 6.4.1 API
MasterVariablesReplacer Members
MasterVariablesReplacer Class Constructors Methods See Also Send Feedback

The MasterVariablesReplacer type exposes the following members.

Constructors

 | Name | Description
Public method | MasterVariablesReplacer | Initializes a new instance of the MasterVariablesReplacer class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExpandBranchItemName | Expands the name of the branch item.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetContext | Gets the current context.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Replace | Replaces the specified text.
Public method | ReplaceField | Replaces the field.
Public method | ReplaceItem | Replaces the item.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MasterVariablesReplacer Class
Sitecore.Data Namespace


MasterVariablesReplacer Constructor

[image]

Sitecore 6.4.1 API
MasterVariablesReplacer Constructor
MasterVariablesReplacer Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MasterVariablesReplacer()
Visual Basic
Public Sub New
Visual C++
public:
MasterVariablesReplacer()

See Also

MasterVariablesReplacer Class
Sitecore.Data Namespace


MasterVariablesReplacer Methods

[image] [image]

Sitecore 6.4.1 API
MasterVariablesReplacer Methods
MasterVariablesReplacer Class See Also Send Feedback

The MasterVariablesReplacer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExpandBranchItemName | Expands the name of the branch item.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetContext | Gets the current context.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Replace | Replaces the specified text.
Public method | ReplaceField | Replaces the field.
Public method | ReplaceItem | Replaces the item.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MasterVariablesReplacer Class
Sitecore.Data Namespace


ExpandBranchItemName Method

[image]

Sitecore 6.4.1 API
MasterVariablesReplacer..::..ExpandBranchItemName Method
MasterVariablesReplacer Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ExpandBranchItemName(
    Item branchTemplateItem,
    string rootItemName
)
Visual Basic
Public Function ExpandBranchItemName ( _
    branchTemplateItem As Item, _
    rootItemName As String _
) As String
Visual C++
public:
String^ ExpandBranchItemName(
    Item^ branchTemplateItem,
    String^ rootItemName
)

Parameters

branchTemplateItem
Type: Sitecore.Data.Items..::..Item
The branch template item.
rootItemName
Type: System..::..String
Name of the root item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.MasterVariablesReplacer.ExpandBranchItemName(Sitecore.Data.Items.Item,System.String)"]

See Also

MasterVariablesReplacer Class
Sitecore.Data Namespace


GetContext Method

[image]

Sitecore 6.4.1 API
MasterVariablesReplacer..::..GetContext Method
MasterVariablesReplacer Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual ReplacerContext GetContext()
Visual Basic
Protected Overridable Function GetContext As ReplacerContext
Visual C++
protected:
virtual ReplacerContext^ GetContext()

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.MasterVariablesReplacer.GetContext"]

See Also

MasterVariablesReplacer Class
Sitecore.Data Namespace


Replace Method

[image]

Sitecore 6.4.1 API
MasterVariablesReplacer..::..Replace Method
MasterVariablesReplacer Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string Replace(
    string text,
    Item targetItem
)
Visual Basic
Public Overridable Function Replace ( _
    text As String, _
    targetItem As Item _
) As String
Visual C++
public:
virtual String^ Replace(
    String^ text,
    Item^ targetItem
)

Parameters

text
Type: System..::..String
The text.
targetItem
Type: Sitecore.Data.Items..::..Item
The target item for the field data.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.MasterVariablesReplacer.Replace(System.String,Sitecore.Data.Items.Item)"]

See Also

MasterVariablesReplacer Class
Sitecore.Data Namespace


ReplaceField Method

[image]

Sitecore 6.4.1 API
MasterVariablesReplacer..::..ReplaceField Method
MasterVariablesReplacer Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void ReplaceField(
    Item item,
    Field field
)
Visual Basic
Public Overridable Sub ReplaceField ( _
    item As Item, _
    field As Field _
)
Visual C++
public:
virtual void ReplaceField(
    Item^ item,
    Field^ field
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
field
Type: Sitecore.Data.Fields..::..Field
The field.

See Also

MasterVariablesReplacer Class
Sitecore.Data Namespace


ReplaceItem Method

[image]

Sitecore 6.4.1 API
MasterVariablesReplacer..::..ReplaceItem Method
MasterVariablesReplacer Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void ReplaceItem(
    Item item
)
Visual Basic
Public Overridable Sub ReplaceItem ( _
    item As Item _
)
Visual C++
public:
virtual void ReplaceItem(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

MasterVariablesReplacer Class
Sitecore.Data Namespace


PropertiesBase Class

[image]

Sitecore 6.4.1 API
PropertiesBase Class
Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PropertiesBase
Visual Basic
Public Class PropertiesBase
Visual C++
public ref class PropertiesBase

Remarks

Inheritance Hierarchy

System..::..Object
Sitecore.Data..::..PropertiesBase
Sitecore.Data..::..DatabaseProperties

See Also

PropertiesBase Members
Sitecore.Data Namespace
Sitecore.Data..::..DatabaseProperties


PropertiesBase Members

[image] [image]

Sitecore 6.4.1 API
PropertiesBase Members
PropertiesBase Class Constructors Methods Properties See Also Send Feedback

The PropertiesBase type exposes the following members.

Constructors

 | Name | Description
Public method | PropertiesBase | Creates a new PropertiesBase instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBoolValue | Gets a bool value.
Public method | GetDateValue | Gets a date value.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntValue | Gets an integer value.
Public method | GetLongValue | Gets a long value.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a value with the specified name.
Public method | RemovePrefix | Removes all values which names have the specified prefix.
Public method | SetBoolValue | Sets a bool value.
Public method | SetDateValue | Sets a date value.
Public method | SetIntValue | Sets an integer value.
Public method | SetLongValue | Sets a long value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Database | Gets the database.
Public property | Item | Gets or sets the value with the specified name.

See Also

PropertiesBase Class
Sitecore.Data Namespace


PropertiesBase Constructor

[image]

Sitecore 6.4.1 API
PropertiesBase Constructor
PropertiesBase Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PropertiesBase(
    Database database
)
Visual Basic
Public Sub New ( _
    database As Database _
)
Visual C++
public:
PropertiesBase(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
Database.

See Also

PropertiesBase Class
Sitecore.Data Namespace


PropertiesBase Methods

[image] [image]

Sitecore 6.4.1 API
PropertiesBase Methods
PropertiesBase Class See Also Send Feedback

The PropertiesBase type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBoolValue | Gets a bool value.
Public method | GetDateValue | Gets a date value.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntValue | Gets an integer value.
Public method | GetLongValue | Gets a long value.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a value with the specified name.
Public method | RemovePrefix | Removes all values which names have the specified prefix.
Public method | SetBoolValue | Sets a bool value.
Public method | SetDateValue | Sets a date value.
Public method | SetIntValue | Sets an integer value.
Public method | SetLongValue | Sets a long value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PropertiesBase Class
Sitecore.Data Namespace


GetBoolValue Method

[image]

Sitecore 6.4.1 API
PropertiesBase..::..GetBoolValue Method
PropertiesBase Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool GetBoolValue(
    string name,
    bool defaultValue
)
Visual Basic
Public Function GetBoolValue ( _
    name As String, _
    defaultValue As Boolean _
) As Boolean
Visual C++
public:
bool GetBoolValue(
    String^ name,
    bool defaultValue
)

Parameters

name
Type: System..::..String
Name.
defaultValue
Type: System..::..Boolean
Default value.

Return Value

The value.

See Also

PropertiesBase Class
Sitecore.Data Namespace


GetDateValue Method

[image]

Sitecore 6.4.1 API
PropertiesBase..::..GetDateValue Method
PropertiesBase Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime GetDateValue(
    string name,
    DateTime defaultValue
)
Visual Basic
Public Function GetDateValue ( _
    name As String, _
    defaultValue As DateTime _
) As DateTime
Visual C++
public:
DateTime GetDateValue(
    String^ name,
    DateTime defaultValue
)

Parameters

name
Type: System..::..String
Name.
defaultValue
Type: System..::..DateTime
Default value.

Return Value

The date value.

See Also

PropertiesBase Class
Sitecore.Data Namespace


GetIntValue Method

[image]

Sitecore 6.4.1 API
PropertiesBase..::..GetIntValue Method
PropertiesBase Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int GetIntValue(
    string name,
    int defaultValue
)
Visual Basic
Public Function GetIntValue ( _
    name As String, _
    defaultValue As Integer _
) As Integer
Visual C++
public:
int GetIntValue(
    String^ name,
    int defaultValue
)

Parameters

name
Type: System..::..String
Name.
defaultValue
Type: System..::..Int32
Default value.

Return Value

The int value.

See Also

PropertiesBase Class
Sitecore.Data Namespace


GetLongValue Method

[image]

Sitecore 6.4.1 API
PropertiesBase..::..GetLongValue Method
PropertiesBase Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long GetLongValue(
    string name,
    long defaultValue
)
Visual Basic
Public Function GetLongValue ( _
    name As String, _
    defaultValue As Long _
) As Long
Visual C++
public:
long long GetLongValue(
    String^ name,
    long long defaultValue
)

Parameters

name
Type: System..::..String
Name.
defaultValue
Type: System..::..Int64
Default value.

Return Value

The long value.

See Also

PropertiesBase Class
Sitecore.Data Namespace


Remove Method

[image]

Sitecore 6.4.1 API
PropertiesBase..::..Remove Method
PropertiesBase Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Remove(
    string name
)
Visual Basic
Public Overridable Sub Remove ( _
    name As String _
)
Visual C++
public:
virtual void Remove(
    String^ name
)

Parameters

name
Type: System..::..String
Name.

See Also

PropertiesBase Class
Sitecore.Data Namespace


RemovePrefix Method

[image]

Sitecore 6.4.1 API
PropertiesBase..::..RemovePrefix Method
PropertiesBase Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void RemovePrefix(
    string prefix
)
Visual Basic
Public Overridable Sub RemovePrefix ( _
    prefix As String _
)
Visual C++
public:
virtual void RemovePrefix(
    String^ prefix
)

Parameters

prefix
Type: System..::..String
Prefix.

See Also

PropertiesBase Class
Sitecore.Data Namespace


SetBoolValue Method

[image]

Sitecore 6.4.1 API
PropertiesBase..::..SetBoolValue Method
PropertiesBase Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetBoolValue(
    string name,
    bool value
)
Visual Basic
Public Sub SetBoolValue ( _
    name As String, _
    value As Boolean _
)
Visual C++
public:
void SetBoolValue(
    String^ name,
    bool value
)

Parameters

name
Type: System..::..String
Name.
value
Type: System..::..Boolean
Value.

See Also

PropertiesBase Class
Sitecore.Data Namespace


SetDateValue Method

[image]

Sitecore 6.4.1 API
PropertiesBase..::..SetDateValue Method
PropertiesBase Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetDateValue(
    string name,
    DateTime date
)
Visual Basic
Public Sub SetDateValue ( _
    name As String, _
    date As DateTime _
)
Visual C++
public:
void SetDateValue(
    String^ name,
    DateTime date
)

Parameters

name
Type: System..::..String
Name.
date
Type: System..::..DateTime
Date.

See Also

PropertiesBase Class
Sitecore.Data Namespace


SetIntValue Method

[image]

Sitecore 6.4.1 API
PropertiesBase..::..SetIntValue Method
PropertiesBase Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetIntValue(
    string name,
    int value
)
Visual Basic
Public Sub SetIntValue ( _
    name As String, _
    value As Integer _
)
Visual C++
public:
void SetIntValue(
    String^ name,
    int value
)

Parameters

name
Type: System..::..String
Name.
value
Type: System..::..Int32
Value.

See Also

PropertiesBase Class
Sitecore.Data Namespace


SetLongValue Method

[image]

Sitecore 6.4.1 API
PropertiesBase..::..SetLongValue Method
PropertiesBase Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetLongValue(
    string name,
    long value
)
Visual Basic
Public Sub SetLongValue ( _
    name As String, _
    value As Long _
)
Visual C++
public:
void SetLongValue(
    String^ name,
    long long value
)

Parameters

name
Type: System..::..String
Name.
value
Type: System..::..Int64
Value.

See Also

PropertiesBase Class
Sitecore.Data Namespace


PropertiesBase Properties

[image] [image]

Sitecore 6.4.1 API
PropertiesBase Properties
PropertiesBase Class See Also Send Feedback

The PropertiesBase type exposes the following members.

Properties

 | Name | Description
Public property | Database | Gets the database.
Public property | Item | Gets or sets the value with the specified name.

See Also

PropertiesBase Class
Sitecore.Data Namespace


Database Property

[image]

Sitecore 6.4.1 API
PropertiesBase..::..Database Property
PropertiesBase Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Database Database { get; }
Visual Basic
Public Overridable ReadOnly Property Database As Database
    Get
Visual C++
public:
virtual property Database^ Database {
    Database^ get ();
}

Field Value

The database.

See Also

PropertiesBase Class
Sitecore.Data Namespace


Item Property

[image]

Sitecore 6.4.1 API
PropertiesBase..::..Item Property
PropertiesBase Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string this[
    string name
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    name As String _
) As String
    Get
    Set
Visual C++
public:
virtual property String^ default[String^ name] {
    String^ get (String^ name);
    void set (String^ name, String^ value);
}

Parameters

name
Type: System..::..String

See Also

PropertiesBase Class
Sitecore.Data Namespace


RenderingRecords Class

[image]

Sitecore 6.4.1 API
RenderingRecords Class
Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RenderingRecords : Database..::..DataRecords
Visual Basic
Public Class RenderingRecords _
    Inherits Database..::..DataRecords
Visual C++
public ref class RenderingRecords : public Database..::..DataRecords

Remarks

Renderings are configured in /sitecore/layouts/Layout/Renderings.

The renderings are normally access through the Renderings property.

Inheritance Hierarchy

System..::..Object
Sitecore.Data..::..Database..::..DataRecords
Sitecore.Data..::..RenderingRecords

See Also

RenderingRecords Members
Sitecore.Data Namespace


RenderingRecords Members

[image] [image]

Sitecore 6.4.1 API
RenderingRecords Members
RenderingRecords Class Constructors Methods Properties See Also Send Feedback

The RenderingRecords type exposes the following members.

Constructors

 | Name | Description
Public method | RenderingRecords | Creates a new RenderingRecords instance.

Methods

 | Name | Description
Protected method | DoGetItem(String) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(DataUri) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(String, Language) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID, Language) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(String, Language, Version) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID, Language, Version) | Gets the item. (Inherited from Database..::..DataRecords.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists(DataUri) | Gets a value that indicates if the data URI exists in the database. (Inherited from Database..::..DataRecords.)
Public method | Exists(ID) | Gets a value that indicates if the item ID exists in the database. (Inherited from Database..::..DataRecords.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAll | Gets all the renderings defined by the database.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniquePath | Gets a unique path of an item in the database. (Inherited from Database..::..DataRecords.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BasePath | Gets the base path. (Inherited from Database..::..DataRecords.)
Public property | Database | Gets the database. (Inherited from Database..::..DataRecords.)
Public property | Item[([( String])]) | Gets the RenderingItem with the specified item path.
Public property | Item[([( DataUri])]) | Gets the RenderingItem with the specified URI.
Public property | Item[([( ID])]) | Gets the RenderingItem with the specified item ID.
Public property | Item[([( String, Language])]) | Gets the RenderingItem with the specified item path.
Public property | Item[([( ID, Language])]) | Gets the RenderingItem with the specified item ID.
Public property | Item[([( String, Language, Version])]) | Gets the RenderingItem with the specified item path.
Public property | Item[([( ID, Language, Version])]) | Gets the RenderingItem with the specified item ID.

See Also

RenderingRecords Class
Sitecore.Data Namespace


RenderingRecords Constructor

[image]

Sitecore 6.4.1 API
RenderingRecords Constructor
RenderingRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderingRecords(
    Database database
)
Visual Basic
Public Sub New ( _
    database As Database _
)
Visual C++
public:
RenderingRecords(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
Database.

See Also

RenderingRecords Class
Sitecore.Data Namespace


RenderingRecords Methods

[image] [image]

Sitecore 6.4.1 API
RenderingRecords Methods
RenderingRecords Class See Also Send Feedback

The RenderingRecords type exposes the following members.

Methods

 | Name | Description
Protected method | DoGetItem(String) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(DataUri) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(String, Language) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID, Language) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(String, Language, Version) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID, Language, Version) | Gets the item. (Inherited from Database..::..DataRecords.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists(DataUri) | Gets a value that indicates if the data URI exists in the database. (Inherited from Database..::..DataRecords.)
Public method | Exists(ID) | Gets a value that indicates if the item ID exists in the database. (Inherited from Database..::..DataRecords.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAll | Gets all the renderings defined by the database.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniquePath | Gets a unique path of an item in the database. (Inherited from Database..::..DataRecords.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenderingRecords Class
Sitecore.Data Namespace


DoGetItem Method

[image] [image]

Sitecore 6.4.1 API
RenderingRecords..::..DoGetItem Method
RenderingRecords Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | DoGetItem(String) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(DataUri) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(String, Language) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID, Language) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(String, Language, Version) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID, Language, Version) | Gets the item. (Inherited from Database..::..DataRecords.)

See Also

RenderingRecords Class
RenderingRecords Members
Sitecore.Data Namespace


Exists Method

[image] [image]

Sitecore 6.4.1 API
RenderingRecords..::..Exists Method
RenderingRecords Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Exists(DataUri) | Gets a value that indicates if the data URI exists in the database. (Inherited from Database..::..DataRecords.)
Public method | Exists(ID) | Gets a value that indicates if the item ID exists in the database. (Inherited from Database..::..DataRecords.)

See Also

RenderingRecords Class
RenderingRecords Members
Sitecore.Data Namespace


GetAll Method

[image]

Sitecore 6.4.1 API
RenderingRecords..::..GetAll Method
RenderingRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderingItem[] GetAll()
Visual Basic
Public Function GetAll As RenderingItem()
Visual C++
public:
array<RenderingItem^>^ GetAll()

Return Value

The all.

See Also

RenderingRecords Class
Sitecore.Data Namespace


RenderingRecords Properties

[image] [image]

Sitecore 6.4.1 API
RenderingRecords Properties
RenderingRecords Class See Also Send Feedback

The RenderingRecords type exposes the following members.

Properties

 | Name | Description
Public property | BasePath | Gets the base path. (Inherited from Database..::..DataRecords.)
Public property | Database | Gets the database. (Inherited from Database..::..DataRecords.)
Public property | Item[([( String])]) | Gets the RenderingItem with the specified item path.
Public property | Item[([( DataUri])]) | Gets the RenderingItem with the specified URI.
Public property | Item[([( ID])]) | Gets the RenderingItem with the specified item ID.
Public property | Item[([( String, Language])]) | Gets the RenderingItem with the specified item path.
Public property | Item[([( ID, Language])]) | Gets the RenderingItem with the specified item ID.
Public property | Item[([( String, Language, Version])]) | Gets the RenderingItem with the specified item path.
Public property | Item[([( ID, Language, Version])]) | Gets the RenderingItem with the specified item ID.

See Also

RenderingRecords Class
Sitecore.Data Namespace


Item Property

[image] [image]

Sitecore 6.4.1 API
RenderingRecords..::..Item Property
RenderingRecords Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( String])]) | Gets the RenderingItem with the specified item path.
Public property | Item[([( DataUri])]) | Gets the RenderingItem with the specified URI.
Public property | Item[([( ID])]) | Gets the RenderingItem with the specified item ID.
Public property | Item[([( String, Language])]) | Gets the RenderingItem with the specified item path.
Public property | Item[([( ID, Language])]) | Gets the RenderingItem with the specified item ID.
Public property | Item[([( String, Language, Version])]) | Gets the RenderingItem with the specified item path.
Public property | Item[([( ID, Language, Version])]) | Gets the RenderingItem with the specified item ID.

See Also

RenderingRecords Class
RenderingRecords Members
Sitecore.Data Namespace


Item Property (DataUri)

[image]

Sitecore 6.4.1 API
RenderingRecords..::..Item Property (DataUri)
RenderingRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderingItem this[
    DataUri uri
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    uri As DataUri _
) As RenderingItem
    Get
Visual C++
public:
property RenderingItem^ default[DataUri^ uri] {
    RenderingItem^ get (DataUri^ uri);
}

Parameters

uri
Type: Sitecore.Data..::..DataUri

See Also

RenderingRecords Class
Item Overload
Sitecore.Data Namespace


Item Property (ID)

[image]

Sitecore 6.4.1 API
RenderingRecords..::..Item Property (ID)
RenderingRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderingItem this[
    ID itemID
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    itemID As ID _
) As RenderingItem
    Get
Visual C++
public:
property RenderingItem^ default[ID^ itemID] {
    RenderingItem^ get (ID^ itemID);
}

Parameters

itemID
Type: Sitecore.Data..::..ID

See Also

RenderingRecords Class
Item Overload
Sitecore.Data Namespace


Item Property (String, Language)

[image]

Sitecore 6.4.1 API
RenderingRecords..::..Item Property (String, Language)
RenderingRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderingItem this[
    string itemPath,
    Language language
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    itemPath As String, _
    language As Language _
) As RenderingItem
    Get
Visual C++
public:
property RenderingItem^ default[String^ itemPath, Language^ language] {
    RenderingItem^ get (String^ itemPath, Language^ language);
}

Parameters

itemPath
Type: System..::..String
language
Type: Sitecore.Globalization..::..Language

See Also

RenderingRecords Class
Item Overload
Sitecore.Data Namespace


Item Property (ID, Language)

[image]

Sitecore 6.4.1 API
RenderingRecords..::..Item Property (ID, Language)
RenderingRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderingItem this[
    ID itemID,
    Language language
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    itemID As ID, _
    language As Language _
) As RenderingItem
    Get
Visual C++
public:
property RenderingItem^ default[ID^ itemID, Language^ language] {
    RenderingItem^ get (ID^ itemID, Language^ language);
}

Parameters

itemID
Type: Sitecore.Data..::..ID
language
Type: Sitecore.Globalization..::..Language

See Also

RenderingRecords Class
Item Overload
Sitecore.Data Namespace


Item Property (String, Language, Version)

[image]

Sitecore 6.4.1 API
RenderingRecords..::..Item Property (String, Language, Version)
RenderingRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderingItem this[
    string itemPath,
    Language language,
    Version version
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    itemPath As String, _
    language As Language, _
    version As Version _
) As RenderingItem
    Get
Visual C++
public:
property RenderingItem^ default[String^ itemPath, Language^ language, Version^ version] {
    RenderingItem^ get (String^ itemPath, Language^ language, Version^ version);
}

Parameters

itemPath
Type: System..::..String
language
Type: Sitecore.Globalization..::..Language
version
Type: Sitecore.Data..::..Version

See Also

RenderingRecords Class
Item Overload
Sitecore.Data Namespace


Item Property (ID, Language, Version)

[image]

Sitecore 6.4.1 API
RenderingRecords..::..Item Property (ID, Language, Version)
RenderingRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderingItem this[
    ID itemID,
    Language language,
    Version version
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    itemID As ID, _
    language As Language, _
    version As Version _
) As RenderingItem
    Get
Visual C++
public:
property RenderingItem^ default[ID^ itemID, Language^ language, Version^ version] {
    RenderingItem^ get (ID^ itemID, Language^ language, Version^ version);
}

Parameters

itemID
Type: Sitecore.Data..::..ID
language
Type: Sitecore.Globalization..::..Language
version
Type: Sitecore.Data..::..Version

See Also

RenderingRecords Class
Item Overload
Sitecore.Data Namespace


ShortID Class

[image]

Sitecore 6.4.1 API
ShortID Class
Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class ShortID : ISerializable
Visual Basic
<SerializableAttribute> _
Public Class ShortID _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class ShortID : ISerializable

Remarks

A string representation of an ID is usually 38 characters long. Some of these characters are omittable and can be excluded to save space.

The ShortID equivalent of the ID "{678E49BA-7D1F-48E2-BE86-35824C641556}" is "678E49BA7D1F48E2BE8635824C641556".

A ShortID is 32 characters long.

Inheritance Hierarchy

System..::..Object
Sitecore.Data..::..ShortID

See Also

ShortID Members
Sitecore.Data Namespace


ShortID Members

[image] [image]

Sitecore 6.4.1 API
ShortID Members
ShortID Class Constructors Methods Operators Fields Properties See Also Send Feedback

The ShortID type exposes the following members.

Constructors

 | Name | Description
Public method | ShortID()()()() | Initializes a new instance of the ShortID class.
Public method | ShortID(Guid) | Initializes a ShortID from a GUID.
Public method | ShortID(String) | Initializes a ShortID from a string.
Public method | ShortID(ID) | Initializes a ShortID from an ID.
Protected method | ShortID(SerializationInfo, StreamingContext) | Initializes a new instance of the ShortID class.

Methods

 | Name | Description
 | Decode | Converts a string containing a ShortID to a string
 | DecodeID | Converts a string containing a ShortID to a ID.
 | DecodeItem | Gets an ID path that represents an item from an encoded string.
 | Encode(Guid) | Converts a GUID to a ShortID.
 | Encode(String) | Converts a string to a ShortID.
 | Encode(ID) | Converts an ID to a ShortID.
 | EncodeItem | Gets a an encoded path of ShortIDs that represents an item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Overrides Object..::..GetHashCode()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsShortID | Tests if a string is a ShortID.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewId | Gets a new id.
 | Parse | Parses the specified value.
Public method | ToID | Converts the ShortID to an ID.
Public method | ToString | Converts the ShortID to a string. (Overrides Object..::..ToString()()()().)
 | TryParse | Tries to parse a value.

Operators

Name | Description
Equality | Determines whether two short IDs instances are equal.
Inequality | Determines whether two short IDs instances are unequal.

Fields

Name | Description
Length | Gets the constant length of 32 character.

Properties

 | Name | Description
Public property | Guid | Gets the GUID represented by the ShortID.

See Also

ShortID Class
Sitecore.Data Namespace


ShortID Constructor

[image] [image]

Sitecore 6.4.1 API
ShortID Constructor
ShortID Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ShortID()()()() | Initializes a new instance of the ShortID class.
Public method | ShortID(Guid) | Initializes a ShortID from a GUID.
Public method | ShortID(String) | Initializes a ShortID from a string.
Public method | ShortID(ID) | Initializes a ShortID from an ID.
Protected method | ShortID(SerializationInfo, StreamingContext) | Initializes a new instance of the ShortID class.

See Also

ShortID Class
ShortID Members
Sitecore.Data Namespace


ShortID Constructor

[image]

Sitecore 6.4.1 API
ShortID Constructor
ShortID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ShortID()
Visual Basic
Public Sub New
Visual C++
public:
ShortID()

See Also

ShortID Class
ShortID Overload
Sitecore.Data Namespace


ShortID Constructor (Guid)

[image]

Sitecore 6.4.1 API
ShortID Constructor (Guid)
ShortID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ShortID(
    Guid id
)
Visual Basic
Public Sub New ( _
    id As Guid _
)
Visual C++
public:
ShortID(
    Guid id
)

Parameters

id
Type: System..::..Guid
The id.

See Also

ShortID Class
ShortID Overload
Sitecore.Data Namespace


ShortID Constructor (String)

[image]

Sitecore 6.4.1 API
ShortID Constructor (String)
ShortID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ShortID(
    string id
)
Visual Basic
Public Sub New ( _
    id As String _
)
Visual C++
public:
ShortID(
    String^ id
)

Parameters

id
Type: System..::..String
The id.

See Also

ShortID Class
ShortID Overload
Sitecore.Data Namespace


ShortID Constructor (ID)

[image]

Sitecore 6.4.1 API
ShortID Constructor (ID)
ShortID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ShortID(
    ID id
)
Visual Basic
Public Sub New ( _
    id As ID _
)
Visual C++
public:
ShortID(
    ID^ id
)

Parameters

id
Type: Sitecore.Data..::..ID
The id.

See Also

ShortID Class
ShortID Overload
Sitecore.Data Namespace


ShortID Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
ShortID Constructor (SerializationInfo, StreamingContext)
ShortID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected ShortID(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
ShortID(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

ShortID Class
ShortID Overload
Sitecore.Data Namespace


ShortID Fields

[image] [image]

Sitecore 6.4.1 API
ShortID Fields
ShortID Class See Also Send Feedback

The ShortID type exposes the following members.

Fields

Name | Description
Length | Gets the constant length of 32 character.

See Also

ShortID Class
Sitecore.Data Namespace


Length Field

[image]

Sitecore 6.4.1 API
ShortID..::..Length Field
ShortID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int Length
Visual Basic
Public Const Length As Integer
Visual C++
public:
literal int Length

See Also

ShortID Class
Sitecore.Data Namespace


ShortID Methods

[image] [image]

Sitecore 6.4.1 API
ShortID Methods
ShortID Class See Also Send Feedback

The ShortID type exposes the following members.

Methods

 | Name | Description
 | Decode | Converts a string containing a ShortID to a string
 | DecodeID | Converts a string containing a ShortID to a ID.
 | DecodeItem | Gets an ID path that represents an item from an encoded string.
 | Encode(Guid) | Converts a GUID to a ShortID.
 | Encode(String) | Converts a string to a ShortID.
 | Encode(ID) | Converts an ID to a ShortID.
 | EncodeItem | Gets a an encoded path of ShortIDs that represents an item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Overrides Object..::..GetHashCode()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsShortID | Tests if a string is a ShortID.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewId | Gets a new id.
 | Parse | Parses the specified value.
Public method | ToID | Converts the ShortID to an ID.
Public method | ToString | Converts the ShortID to a string. (Overrides Object..::..ToString()()()().)
 | TryParse | Tries to parse a value.

See Also

ShortID Class
Sitecore.Data Namespace


DecodeID Method

[image]

Sitecore 6.4.1 API
ShortID..::..DecodeID Method
ShortID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID DecodeID(
    string id
)
Visual Basic
Public Shared Function DecodeID ( _
    id As String _
) As ID
Visual C++
public:
static ID^ DecodeID(
    String^ id
)

Parameters

id
Type: System..::..String
The id.

Return Value

The ID.

See Also

ShortID Class
Sitecore.Data Namespace


DecodeItem Method

[image]

Sitecore 6.4.1 API
ShortID..::..DecodeItem Method
ShortID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string DecodeItem(
    string id
)
Visual Basic
Public Shared Function DecodeItem ( _
    id As String _
) As String
Visual C++
public:
static String^ DecodeItem(
    String^ id
)

Parameters

id
Type: System..::..String
The id.

Return Value

The item.

See Also

ShortID Class
Sitecore.Data Namespace


Encode Method

[image] [image]

Sitecore 6.4.1 API
ShortID..::..Encode Method
ShortID Class See Also Send Feedback

Overload List

Name | Description
Encode(Guid) | Converts a GUID to a ShortID.
Encode(String) | Converts a string to a ShortID.
Encode(ID) | Converts an ID to a ShortID.

See Also

ShortID Class
ShortID Members
Sitecore.Data Namespace


Encode Method (Guid)

[image]

Sitecore 6.4.1 API
ShortID..::..Encode Method (Guid)
ShortID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Encode(
    Guid id
)
Visual Basic
Public Shared Function Encode ( _
    id As Guid _
) As String
Visual C++
public:
static String^ Encode(
    Guid id
)

Parameters

id
Type: System..::..Guid
The id.

Return Value

The encode.

See Also

ShortID Class
Encode Overload
Sitecore.Data Namespace


Encode Method (String)

[image]

Sitecore 6.4.1 API
ShortID..::..Encode Method (String)
ShortID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Encode(
    string guid
)
Visual Basic
Public Shared Function Encode ( _
    guid As String _
) As String
Visual C++
public:
static String^ Encode(
    String^ guid
)

Parameters

guid
Type: System..::..String
The GUID.

Return Value

The encode.

See Also

ShortID Class
Encode Overload
Sitecore.Data Namespace


Encode Method (ID)

[image]

Sitecore 6.4.1 API
ShortID..::..Encode Method (ID)
ShortID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Encode(
    ID id
)
Visual Basic
Public Shared Function Encode ( _
    id As ID _
) As String
Visual C++
public:
static String^ Encode(
    ID^ id
)

Parameters

id
Type: Sitecore.Data..::..ID
The id.

Return Value

The encode.

See Also

ShortID Class
Encode Overload
Sitecore.Data Namespace


EncodeItem Method

[image]

Sitecore 6.4.1 API
ShortID..::..EncodeItem Method
ShortID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string EncodeItem(
    Item item
)
Visual Basic
Public Shared Function EncodeItem ( _
    item As Item _
) As String
Visual C++
public:
static String^ EncodeItem(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

The item.

See Also

ShortID Class
Sitecore.Data Namespace


Equals Method

[image]

Sitecore 6.4.1 API
ShortID..::..Equals Method
ShortID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

See Also

ShortID Class
Sitecore.Data Namespace


GetHashCode Method

[image]

Sitecore 6.4.1 API
ShortID..::..GetHashCode Method
ShortID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A hash code for the current Object.

See Also

ShortID Class
Sitecore.Data Namespace


GetObjectData Method

[image]

Sitecore 6.4.1 API
ShortID..::..GetObjectData Method
ShortID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System.Security..::..SecurityException | The caller does not have the required permission.

See Also

ShortID Class
Sitecore.Data Namespace


IsShortID Method

[image]

Sitecore 6.4.1 API
ShortID..::..IsShortID Method
ShortID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsShortID(
    string id
)
Visual Basic
Public Shared Function IsShortID ( _
    id As String _
) As Boolean
Visual C++
public:
static bool IsShortID(
    String^ id
)

Parameters

id
Type: System..::..String
The id.

Return Value

true if [is short ID] [the specified id]; otherwise, false.

See Also

ShortID Class
Sitecore.Data Namespace


NewId Method

[image]

Sitecore 6.4.1 API
ShortID..::..NewId Method
ShortID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ShortID NewId()
Visual Basic
Public Shared Function NewId As ShortID
Visual C++
public:
static ShortID^ NewId()

Return Value

The id

See Also

ShortID Class
Sitecore.Data Namespace


Parse Method

[image]

Sitecore 6.4.1 API
ShortID..::..Parse Method
ShortID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ShortID Parse(
    string value
)
Visual Basic
Public Shared Function Parse ( _
    value As String _
) As ShortID
Visual C++
public:
static ShortID^ Parse(
    String^ value
)

Parameters

value
Type: System..::..String
The value.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.ShortID.Parse(System.String)"]

See Also

ShortID Class
Sitecore.Data Namespace


ToID Method

[image]

Sitecore 6.4.1 API
ShortID..::..ToID Method
ShortID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ToID()
Visual Basic
Public Function ToID As ID
Visual C++
public:
ID^ ToID()

Return Value

The ID.

See Also

ShortID Class
Sitecore.Data Namespace


TryParse Method

[image]

Sitecore 6.4.1 API
ShortID..::..TryParse Method
ShortID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool TryParse(
    string value,
    out ShortID result
)
Visual Basic
Public Shared Function TryParse ( _
    value As String, _
    <OutAttribute> ByRef result As ShortID _
) As Boolean
Visual C++
public:
static bool TryParse(
    String^ value,
    [OutAttribute] ShortID^% result
)

Parameters

value
Type: System..::..String
The value.
result
Type: Sitecore.Data..::..ShortID %
The result.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.ShortID.TryParse(System.String,Sitecore.Data.ShortID@)"]

See Also

ShortID Class
Sitecore.Data Namespace


ShortID Operators

[image] [image]

Sitecore 6.4.1 API
ShortID Operators
ShortID Class See Also Send Feedback

The ShortID type exposes the following members.

Operators

Name | Description
Equality | Determines whether two short IDs instances are equal.
Inequality | Determines whether two short IDs instances are unequal.

See Also

ShortID Class
Sitecore.Data Namespace


Equality Operator

[image]

Sitecore 6.4.1 API
ShortID..::..Equality Operator
ShortID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool operator ==(
    ShortID id1,
    ShortID id2
)
Visual Basic
Public Shared Operator = ( _
    id1 As ShortID, _
    id2 As ShortID _
) As Boolean
Visual C++
public:
static bool operator ==(
    ShortID^ id1,
    ShortID^ id2
)

Parameters

id1
Type: Sitecore.Data..::..ShortID
The first ShortID to compare.
id2
Type: Sitecore.Data..::..ShortID
The second ShortID to compare.

Return Value

true if id1 is the same instance as id2 or if both are null references or if id1.Equals(id2) returns true; otherwise, false.

See Also

ShortID Class
Sitecore.Data Namespace


Inequality Operator

[image]

Sitecore 6.4.1 API
ShortID..::..Inequality Operator
ShortID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool operator !=(
    ShortID id1,
    ShortID id2
)
Visual Basic
Public Shared Operator <> ( _
    id1 As ShortID, _
    id2 As ShortID _
) As Boolean
Visual C++
public:
static bool operator !=(
    ShortID^ id1,
    ShortID^ id2
)

Parameters

id1
Type: Sitecore.Data..::..ShortID
The first ShortID to compare.
id2
Type: Sitecore.Data..::..ShortID
The second ShortID to compare.

Return Value

true if id1 is not the same instance as id2 or if id1.Equals(id2) returns false; otherwise, false.

See Also

ShortID Class
Sitecore.Data Namespace


ShortID Properties

[image] [image]

Sitecore 6.4.1 API
ShortID Properties
ShortID Class See Also Send Feedback

The ShortID type exposes the following members.

Properties

 | Name | Description
Public property | Guid | Gets the GUID represented by the ShortID.

See Also

ShortID Class
Sitecore.Data Namespace


Guid Property

[image]

Sitecore 6.4.1 API
ShortID..::..Guid Property
ShortID Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Guid Guid { get; set; }
Visual Basic
Public Property Guid As Guid
    Get
    Set
Visual C++
public:
property Guid Guid {
    Guid get ();
    void set (Guid value);
}

Field Value

The GUID.

See Also

ShortID Class
Sitecore.Data Namespace


SortCriteria Class

[image]

Sitecore 6.4.1 API
SortCriteria Class
Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SortCriteria
Visual Basic
Public Class SortCriteria
Visual C++
public ref class SortCriteria

Inheritance Hierarchy

System..::..Object
Sitecore.Data..::..SortCriteria

See Also

SortCriteria Members
Sitecore.Data Namespace


SortCriteria Members

[image] [image]

Sitecore 6.4.1 API
SortCriteria Members
SortCriteria Class Constructors Methods Properties See Also Send Feedback

The SortCriteria type exposes the following members.

Constructors

 | Name | Description
Public method | SortCriteria | Initializes a new instance of the SortCriteria class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Direction | Gets the direction.
Public property | FieldName | Gets the name of the field.

See Also

SortCriteria Class
Sitecore.Data Namespace


SortCriteria Constructor

[image]

Sitecore 6.4.1 API
SortCriteria Constructor
SortCriteria Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SortCriteria(
    string fieldName,
    SortDirection direction
)
Visual Basic
Public Sub New ( _
    fieldName As String, _
    direction As SortDirection _
)
Visual C++
public:
SortCriteria(
    String^ fieldName,
    SortDirection direction
)

Parameters

fieldName
Type: System..::..String
Name of the field.
direction
Type: System.Web.UI.WebControls..::..SortDirection
The direction.

See Also

SortCriteria Class
Sitecore.Data Namespace


SortCriteria Methods

[image] [image]

Sitecore 6.4.1 API
SortCriteria Methods
SortCriteria Class See Also Send Feedback

The SortCriteria type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SortCriteria Class
Sitecore.Data Namespace


SortCriteria Properties

[image] [image]

Sitecore 6.4.1 API
SortCriteria Properties
SortCriteria Class See Also Send Feedback

The SortCriteria type exposes the following members.

Properties

 | Name | Description
Public property | Direction | Gets the direction.
Public property | FieldName | Gets the name of the field.

See Also

SortCriteria Class
Sitecore.Data Namespace


Direction Property

[image]

Sitecore 6.4.1 API
SortCriteria..::..Direction Property
SortCriteria Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SortDirection Direction { get; }
Visual Basic
Public ReadOnly Property Direction As SortDirection
    Get
Visual C++
public:
property SortDirection Direction {
    SortDirection get ();
}

Field Value

The direction.

See Also

SortCriteria Class
Sitecore.Data Namespace


FieldName Property

[image]

Sitecore 6.4.1 API
SortCriteria..::..FieldName Property
SortCriteria Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string FieldName { get; }
Visual Basic
Public ReadOnly Property FieldName As String
    Get
Visual C++
public:
property String^ FieldName {
    String^ get ();
}

Field Value

The name of the field.

See Also

SortCriteria Class
Sitecore.Data Namespace


StandardValuesManager Class

[image]

Sitecore 6.4.1 API
StandardValuesManager Class
Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class StandardValuesManager
Visual Basic
Public NotInheritable Class StandardValuesManager
Visual C++
public ref class StandardValuesManager abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Data..::..StandardValuesManager

See Also

StandardValuesManager Members
Sitecore.Data Namespace


StandardValuesManager Members

[image] [image]

Sitecore 6.4.1 API
StandardValuesManager Members
StandardValuesManager Class Methods Properties See Also Send Feedback

The StandardValuesManager type exposes the following members.

Methods

Name | Description
GetStandardValue | Gets the standard value of a field.
IsStandardValuesHolder | Determines whether the specified item is a is standard values holder.

Properties

Name | Description
Provider | Gets the provider.
Providers | Gets the providers.

See Also

StandardValuesManager Class
Sitecore.Data Namespace


StandardValuesManager Methods

[image] [image]

Sitecore 6.4.1 API
StandardValuesManager Methods
StandardValuesManager Class See Also Send Feedback

The StandardValuesManager type exposes the following members.

Methods

Name | Description
GetStandardValue | Gets the standard value of a field.
IsStandardValuesHolder | Determines whether the specified item is a is standard values holder.

See Also

StandardValuesManager Class
Sitecore.Data Namespace


GetStandardValue Method

[image]

Sitecore 6.4.1 API
StandardValuesManager..::..GetStandardValue Method
StandardValuesManager Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetStandardValue(
    Field field
)
Visual Basic
Public Shared Function GetStandardValue ( _
    field As Field _
) As String
Visual C++
public:
static String^ GetStandardValue(
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.StandardValuesManager.GetStandardValue(Sitecore.Data.Fields.Field)"]

See Also

StandardValuesManager Class
Sitecore.Data Namespace


StandardValuesManager Properties

[image] [image]

Sitecore 6.4.1 API
StandardValuesManager Properties
StandardValuesManager Class See Also Send Feedback

The StandardValuesManager type exposes the following members.

Properties

Name | Description
Provider | Gets the provider.
Providers | Gets the providers.

See Also

StandardValuesManager Class
Sitecore.Data Namespace


Provider Property

[image]

Sitecore 6.4.1 API
StandardValuesManager..::..Provider Property
StandardValuesManager Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static StandardValuesProvider Provider { get; }
Visual Basic
Public Shared ReadOnly Property Provider As StandardValuesProvider
    Get
Visual C++
public:
static property StandardValuesProvider^ Provider {
    StandardValuesProvider^ get ();
}

Field Value

The provider.

See Also

StandardValuesManager Class
Sitecore.Data Namespace


Providers Property

[image]

Sitecore 6.4.1 API
StandardValuesManager..::..Providers Property
StandardValuesManager Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static StandardValuesProviderCollection Providers { get; }
Visual Basic
Public Shared ReadOnly Property Providers As StandardValuesProviderCollection
    Get
Visual C++
public:
static property StandardValuesProviderCollection^ Providers {
    StandardValuesProviderCollection^ get ();
}

Field Value

The provider.

See Also

StandardValuesManager Class
Sitecore.Data Namespace


StandardValuesProvider Class

[image]

Sitecore 6.4.1 API
StandardValuesProvider Class
Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class StandardValuesProvider : ProviderBase
Visual Basic
Public Class StandardValuesProvider _
    Inherits ProviderBase
Visual C++
public ref class StandardValuesProvider : public ProviderBase

Inheritance Hierarchy

System..::..Object
System.Configuration.Provider..::..ProviderBase
Sitecore.Data..::..StandardValuesProvider

See Also

StandardValuesProvider Members
Sitecore.Data Namespace


StandardValuesProvider Constructor

[image]

Sitecore 6.4.1 API
StandardValuesProvider Constructor
StandardValuesProvider Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StandardValuesProvider()
Visual Basic
Public Sub New
Visual C++
public:
StandardValuesProvider()

See Also

StandardValuesProvider Class
Sitecore.Data Namespace


StandardValuesProvider Methods

[image] [image]

Sitecore 6.4.1 API
StandardValuesProvider Methods
StandardValuesProvider Class See Also Send Feedback

The StandardValuesProvider type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStandardValue | Gets the standard value of a field.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the provider. (Overrides ProviderBase..::..Initialize(String, NameValueCollection).)
Public method | IsStandardValuesHolder | Determines whether the specified item is a is standard values holder.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StandardValuesProvider Class
Sitecore.Data Namespace


GetStandardValue Method

[image]

Sitecore 6.4.1 API
StandardValuesProvider..::..GetStandardValue Method
StandardValuesProvider Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string GetStandardValue(
    Field field
)
Visual Basic
Public Overridable Function GetStandardValue ( _
    field As Field _
) As String
Visual C++
public:
virtual String^ GetStandardValue(
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.StandardValuesProvider.GetStandardValue(Sitecore.Data.Fields.Field)"]

See Also

StandardValuesProvider Class
Sitecore.Data Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
StandardValuesProvider..::..Initialize Method
StandardValuesProvider Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Initialize(
    string name,
    NameValueCollection config
)
Visual Basic
Public Overrides Sub Initialize ( _
    name As String, _
    config As NameValueCollection _
)
Visual C++
public:
virtual void Initialize(
    String^ name,
    NameValueCollection^ config
) override

Parameters

name
Type: System..::..String
The friendly name of the provider.
config
Type: System.Collections.Specialized..::..NameValueCollection
A collection of the name/value pairs representing the provider-specific attributes specified in the configuration for this provider.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The name of the provider is null.
System..::..ArgumentException | The name of the provider has a length of zero.
System..::..InvalidOperationException | An attempt is made to call Initialize(String, NameValueCollection) on a provider after the provider has already been initialized.

See Also

StandardValuesProvider Class
Sitecore.Data Namespace


IsStandardValuesHolder Method

[image]

Sitecore 6.4.1 API
StandardValuesProvider..::..IsStandardValuesHolder Method
StandardValuesProvider Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool IsStandardValuesHolder(
    Item item
)
Visual Basic
Public Overridable Function IsStandardValuesHolder ( _
    item As Item _
) As Boolean
Visual C++
public:
virtual bool IsStandardValuesHolder(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

true if the specified item is a standard values holder; otherwise, false.

See Also

StandardValuesProvider Class
Sitecore.Data Namespace


StandardValuesProvider Properties

[image] [image]

Sitecore 6.4.1 API
StandardValuesProvider Properties
StandardValuesProvider Class See Also Send Feedback

The StandardValuesProvider type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

StandardValuesProvider Class
Sitecore.Data Namespace


StandardValuesProviderCollection Class

[image]

Sitecore 6.4.1 API
StandardValuesProviderCollection Class
Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class StandardValuesProviderCollection : ProviderCollection
Visual Basic
Public Class StandardValuesProviderCollection _
    Inherits ProviderCollection
Visual C++
public ref class StandardValuesProviderCollection : public ProviderCollection

Inheritance Hierarchy

System..::..Object
System.Configuration.Provider..::..ProviderCollection
Sitecore.Data..::..StandardValuesProviderCollection

See Also

StandardValuesProviderCollection Members
Sitecore.Data Namespace


StandardValuesProviderCollection Members

[image] [image]

Sitecore 6.4.1 API
StandardValuesProviderCollection Members
StandardValuesProviderCollection Class Constructors Methods Properties See Also Send Feedback

The StandardValuesProviderCollection type exposes the following members.

Constructors

 | Name | Description
Public method | StandardValuesProviderCollection | Initializes a new instance of the StandardValuesProviderCollection class

Methods

 | Name | Description
Public method | Add | Adds a provider to the collection. (Inherited from ProviderCollection.)
Public method | Clear | Removes all items from the collection. (Inherited from ProviderCollection.)
Public method | CopyTo | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a provider from the collection. (Inherited from ProviderCollection.)
Public method | SetReadOnly | Sets the collection to be read-only. (Inherited from ProviderCollection.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
Public property | Item | Gets the StandardValuesProvider with the specified name.
Public property | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)

See Also

StandardValuesProviderCollection Class
Sitecore.Data Namespace


StandardValuesProviderCollection Methods

[image] [image]

Sitecore 6.4.1 API
StandardValuesProviderCollection Methods
StandardValuesProviderCollection Class See Also Send Feedback

The StandardValuesProviderCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds a provider to the collection. (Inherited from ProviderCollection.)
Public method | Clear | Removes all items from the collection. (Inherited from ProviderCollection.)
Public method | CopyTo | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a provider from the collection. (Inherited from ProviderCollection.)
Public method | SetReadOnly | Sets the collection to be read-only. (Inherited from ProviderCollection.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StandardValuesProviderCollection Class
Sitecore.Data Namespace


StandardValuesProviderCollection Properties

[image] [image]

Sitecore 6.4.1 API
StandardValuesProviderCollection Properties
StandardValuesProviderCollection Class See Also Send Feedback

The StandardValuesProviderCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
Public property | Item | Gets the StandardValuesProvider with the specified name.
Public property | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)

See Also

StandardValuesProviderCollection Class
Sitecore.Data Namespace


Item Property

[image]

Sitecore 6.4.1 API
StandardValuesProviderCollection..::..Item Property
StandardValuesProviderCollection Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StandardValuesProvider this[
    string name
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    name As String _
) As StandardValuesProvider
    Get
Visual C++
public:
property StandardValuesProvider^ default[String^ name] {
    StandardValuesProvider^ get (String^ name);
}

Parameters

name
Type: System..::..String

Field Value

See Also

StandardValuesProviderCollection Class
Sitecore.Data Namespace


SublayoutRecords Class

[image]

Sitecore 6.4.1 API
SublayoutRecords Class
Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SublayoutRecords : Database..::..DataRecords
Visual Basic
Public Class SublayoutRecords _
    Inherits Database..::..DataRecords
Visual C++
public ref class SublayoutRecords : public Database..::..DataRecords

Inheritance Hierarchy

System..::..Object
Sitecore.Data..::..Database..::..DataRecords
Sitecore.Data..::..SublayoutRecords

See Also

SublayoutRecords Members
Sitecore.Data Namespace


SublayoutRecords Members

[image] [image]

Sitecore 6.4.1 API
SublayoutRecords Members
SublayoutRecords Class Constructors Methods Properties See Also Send Feedback

The SublayoutRecords type exposes the following members.

Constructors

 | Name | Description
Public method | SublayoutRecords | Represents the sublayouts that are defined in a specified database.

Methods

 | Name | Description
Protected method | DoGetItem(String) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(DataUri) | Gets a sublayout. (Overrides Database..::..DataRecords..::..DoGetItem(DataUri).)
Protected method | DoGetItem(ID) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(String, Language) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID, Language) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(String, Language, Version) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID, Language, Version) | Gets the item. (Inherited from Database..::..DataRecords.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists(DataUri) | Gets a value that indicates if the data URI exists in the database. (Inherited from Database..::..DataRecords.)
Public method | Exists(ID) | Gets a value that indicates if the item ID exists in the database. (Inherited from Database..::..DataRecords.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSublayout(String) | Gets a sublayout.
Public method | GetSublayout(DataUri) | Gets a sublayout.
Public method | GetSublayout(ID) | Gets a sublayout.
Public method | GetSublayout(String, Language) | Gets a sublayout.
Public method | GetSublayout(ID, Language) | Gets a sublayout.
Public method | GetSublayout(String, Language, Version) | Gets a sublayout.
Public method | GetSublayout(ID, Language, Version) | Gets a sublayout.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniquePath | Gets a unique path of an item in the database. (Inherited from Database..::..DataRecords.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BasePath | Gets the base path. (Inherited from Database..::..DataRecords.)
Public property | Database | Gets the database. (Inherited from Database..::..DataRecords.)
Public property | Item[([( String])]) | Gets the SublayoutItem with the specified item path.
Public property | Item[([( DataUri])]) | Gets the SublayoutItem with the specified URI.
Public property | Item[([( ID])]) | Gets the SublayoutItem with the specified item ID.
Public property | Item[([( String, Language])]) | Gets the SublayoutItem with the specified item path.
Public property | Item[([( ID, Language])]) | Gets the SublayoutItem with the specified item ID.
Public property | Item[([( String, Language, Version])]) | Gets the SublayoutItem with the specified item path.
Public property | Item[([( ID, Language, Version])]) | Gets the SublayoutItem with the specified item ID.

See Also

SublayoutRecords Class
Sitecore.Data Namespace


SublayoutRecords Constructor

[image]

Sitecore 6.4.1 API
SublayoutRecords Constructor
SublayoutRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SublayoutRecords(
    Database database
)
Visual Basic
Public Sub New ( _
    database As Database _
)
Visual C++
public:
SublayoutRecords(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database

[Missing <param name="database"/> documentation for "M:Sitecore.Data.SublayoutRecords.#ctor(Sitecore.Data.Database)"]

Remarks

Sublayouts are configured in /sitecore/layouts/Layout/Sublayouts.

The renderingsare normally access through the Sublayouts property.

See Also

SublayoutRecords Class
Sitecore.Data Namespace


DoGetItem Method

[image] [image]

Sitecore 6.4.1 API
SublayoutRecords..::..DoGetItem Method
SublayoutRecords Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | DoGetItem(String) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(DataUri) | Gets a sublayout. (Overrides Database..::..DataRecords..::..DoGetItem(DataUri).)
Protected method | DoGetItem(ID) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(String, Language) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID, Language) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(String, Language, Version) | Gets the item. (Inherited from Database..::..DataRecords.)
Protected method | DoGetItem(ID, Language, Version) | Gets the item. (Inherited from Database..::..DataRecords.)

See Also

SublayoutRecords Class
SublayoutRecords Members
Sitecore.Data Namespace


DoGetItem Method (DataUri)

[image]

Sitecore 6.4.1 API
SublayoutRecords..::..DoGetItem Method (DataUri)
SublayoutRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override Item DoGetItem(
    DataUri uri
)
Visual Basic
Protected Overrides Function DoGetItem ( _
    uri As DataUri _
) As Item
Visual C++
protected:
virtual Item^ DoGetItem(
    DataUri^ uri
) override

Parameters

uri
Type: Sitecore.Data..::..DataUri
URI.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.SublayoutRecords.DoGetItem(Sitecore.Data.DataUri)"]

See Also

SublayoutRecords Class
DoGetItem Overload
Sitecore.Data Namespace


Exists Method

[image] [image]

Sitecore 6.4.1 API
SublayoutRecords..::..Exists Method
SublayoutRecords Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Exists(DataUri) | Gets a value that indicates if the data URI exists in the database. (Inherited from Database..::..DataRecords.)
Public method | Exists(ID) | Gets a value that indicates if the item ID exists in the database. (Inherited from Database..::..DataRecords.)

See Also

SublayoutRecords Class
SublayoutRecords Members
Sitecore.Data Namespace


GetSublayout Method

[image] [image]

Sitecore 6.4.1 API
SublayoutRecords..::..GetSublayout Method
SublayoutRecords Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetSublayout(String) | Gets a sublayout.
Public method | GetSublayout(DataUri) | Gets a sublayout.
Public method | GetSublayout(ID) | Gets a sublayout.
Public method | GetSublayout(String, Language) | Gets a sublayout.
Public method | GetSublayout(ID, Language) | Gets a sublayout.
Public method | GetSublayout(String, Language, Version) | Gets a sublayout.
Public method | GetSublayout(ID, Language, Version) | Gets a sublayout.

See Also

SublayoutRecords Class
SublayoutRecords Members
Sitecore.Data Namespace


GetSublayout Method (String)

[image]

Sitecore 6.4.1 API
SublayoutRecords..::..GetSublayout Method (String)
SublayoutRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SublayoutItem GetSublayout(
    string itemPath
)
Visual Basic
Public Function GetSublayout ( _
    itemPath As String _
) As SublayoutItem
Visual C++
public:
SublayoutItem^ GetSublayout(
    String^ itemPath
)

Parameters

itemPath
Type: System..::..String
Item path.

Return Value

The sublayout.

See Also

SublayoutRecords Class
GetSublayout Overload
Sitecore.Data Namespace


GetSublayout Method (DataUri)

[image]

Sitecore 6.4.1 API
SublayoutRecords..::..GetSublayout Method (DataUri)
SublayoutRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SublayoutItem GetSublayout(
    DataUri uri
)
Visual Basic
Public Function GetSublayout ( _
    uri As DataUri _
) As SublayoutItem
Visual C++
public:
SublayoutItem^ GetSublayout(
    DataUri^ uri
)

Parameters

uri
Type: Sitecore.Data..::..DataUri
URI.

Return Value

The sublayout.

See Also

SublayoutRecords Class
GetSublayout Overload
Sitecore.Data Namespace


GetSublayout Method (ID)

[image]

Sitecore 6.4.1 API
SublayoutRecords..::..GetSublayout Method (ID)
SublayoutRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SublayoutItem GetSublayout(
    ID itemID
)
Visual Basic
Public Function GetSublayout ( _
    itemID As ID _
) As SublayoutItem
Visual C++
public:
SublayoutItem^ GetSublayout(
    ID^ itemID
)

Parameters

itemID
Type: Sitecore.Data..::..ID
Item ID.

Return Value

The sublayout.

See Also

SublayoutRecords Class
GetSublayout Overload
Sitecore.Data Namespace


GetSublayout Method (String, Language)

[image]

Sitecore 6.4.1 API
SublayoutRecords..::..GetSublayout Method (String, Language)
SublayoutRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SublayoutItem GetSublayout(
    string itemPath,
    Language language
)
Visual Basic
Public Function GetSublayout ( _
    itemPath As String, _
    language As Language _
) As SublayoutItem
Visual C++
public:
SublayoutItem^ GetSublayout(
    String^ itemPath,
    Language^ language
)

Parameters

itemPath
Type: System..::..String
Item path.
language
Type: Sitecore.Globalization..::..Language
Language.

Return Value

The sublayout.

See Also

SublayoutRecords Class
GetSublayout Overload
Sitecore.Data Namespace


GetSublayout Method (ID, Language)

[image]

Sitecore 6.4.1 API
SublayoutRecords..::..GetSublayout Method (ID, Language)
SublayoutRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SublayoutItem GetSublayout(
    ID itemID,
    Language language
)
Visual Basic
Public Function GetSublayout ( _
    itemID As ID, _
    language As Language _
) As SublayoutItem
Visual C++
public:
SublayoutItem^ GetSublayout(
    ID^ itemID,
    Language^ language
)

Parameters

itemID
Type: Sitecore.Data..::..ID
Item ID.
language
Type: Sitecore.Globalization..::..Language
Language.

Return Value

The sublayout.

See Also

SublayoutRecords Class
GetSublayout Overload
Sitecore.Data Namespace


GetSublayout Method (String, Language, Version)

[image]

Sitecore 6.4.1 API
SublayoutRecords..::..GetSublayout Method (String, Language, Version)
SublayoutRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SublayoutItem GetSublayout(
    string itemPath,
    Language language,
    Version version
)
Visual Basic
Public Function GetSublayout ( _
    itemPath As String, _
    language As Language, _
    version As Version _
) As SublayoutItem
Visual C++
public:
SublayoutItem^ GetSublayout(
    String^ itemPath,
    Language^ language,
    Version^ version
)

Parameters

itemPath
Type: System..::..String
Item path.
language
Type: Sitecore.Globalization..::..Language
Language.
version
Type: Sitecore.Data..::..Version
Version.

Return Value

The sublayout.

See Also

SublayoutRecords Class
GetSublayout Overload
Sitecore.Data Namespace


GetSublayout Method (ID, Language, Version)

[image]

Sitecore 6.4.1 API
SublayoutRecords..::..GetSublayout Method (ID, Language, Version)
SublayoutRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SublayoutItem GetSublayout(
    ID itemID,
    Language language,
    Version version
)
Visual Basic
Public Function GetSublayout ( _
    itemID As ID, _
    language As Language, _
    version As Version _
) As SublayoutItem
Visual C++
public:
SublayoutItem^ GetSublayout(
    ID^ itemID,
    Language^ language,
    Version^ version
)

Parameters

itemID
Type: Sitecore.Data..::..ID
Item ID.
language
Type: Sitecore.Globalization..::..Language
Language.
version
Type: Sitecore.Data..::..Version
Version.

Return Value

The sublayout.

See Also

SublayoutRecords Class
GetSublayout Overload
Sitecore.Data Namespace


SublayoutRecords Properties

[image] [image]

Sitecore 6.4.1 API
SublayoutRecords Properties
SublayoutRecords Class See Also Send Feedback

The SublayoutRecords type exposes the following members.

Properties

 | Name | Description
Public property | BasePath | Gets the base path. (Inherited from Database..::..DataRecords.)
Public property | Database | Gets the database. (Inherited from Database..::..DataRecords.)
Public property | Item[([( String])]) | Gets the SublayoutItem with the specified item path.
Public property | Item[([( DataUri])]) | Gets the SublayoutItem with the specified URI.
Public property | Item[([( ID])]) | Gets the SublayoutItem with the specified item ID.
Public property | Item[([( String, Language])]) | Gets the SublayoutItem with the specified item path.
Public property | Item[([( ID, Language])]) | Gets the SublayoutItem with the specified item ID.
Public property | Item[([( String, Language, Version])]) | Gets the SublayoutItem with the specified item path.
Public property | Item[([( ID, Language, Version])]) | Gets the SublayoutItem with the specified item ID.

See Also

SublayoutRecords Class
Sitecore.Data Namespace


Item Property (String)

[image]

Sitecore 6.4.1 API
SublayoutRecords..::..Item Property (String)
SublayoutRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SublayoutItem this[
    string itemPath
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    itemPath As String _
) As SublayoutItem
    Get
Visual C++
public:
property SublayoutItem^ default[String^ itemPath] {
    SublayoutItem^ get (String^ itemPath);
}

Parameters

itemPath
Type: System..::..String

See Also

SublayoutRecords Class
Item Overload
Sitecore.Data Namespace


Item Property (DataUri)

[image]

Sitecore 6.4.1 API
SublayoutRecords..::..Item Property (DataUri)
SublayoutRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SublayoutItem this[
    DataUri uri
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    uri As DataUri _
) As SublayoutItem
    Get
Visual C++
public:
property SublayoutItem^ default[DataUri^ uri] {
    SublayoutItem^ get (DataUri^ uri);
}

Parameters

uri
Type: Sitecore.Data..::..DataUri

See Also

SublayoutRecords Class
Item Overload
Sitecore.Data Namespace


Item Property (ID)

[image]

Sitecore 6.4.1 API
SublayoutRecords..::..Item Property (ID)
SublayoutRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SublayoutItem this[
    ID itemID
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    itemID As ID _
) As SublayoutItem
    Get
Visual C++
public:
property SublayoutItem^ default[ID^ itemID] {
    SublayoutItem^ get (ID^ itemID);
}

Parameters

itemID
Type: Sitecore.Data..::..ID

See Also

SublayoutRecords Class
Item Overload
Sitecore.Data Namespace


Item Property (String, Language)

[image]

Sitecore 6.4.1 API
SublayoutRecords..::..Item Property (String, Language)
SublayoutRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SublayoutItem this[
    string itemPath,
    Language language
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    itemPath As String, _
    language As Language _
) As SublayoutItem
    Get
Visual C++
public:
property SublayoutItem^ default[String^ itemPath, Language^ language] {
    SublayoutItem^ get (String^ itemPath, Language^ language);
}

Parameters

itemPath
Type: System..::..String
language
Type: Sitecore.Globalization..::..Language

See Also

SublayoutRecords Class
Item Overload
Sitecore.Data Namespace


Item Property (ID, Language)

[image]

Sitecore 6.4.1 API
SublayoutRecords..::..Item Property (ID, Language)
SublayoutRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SublayoutItem this[
    ID itemID,
    Language language
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    itemID As ID, _
    language As Language _
) As SublayoutItem
    Get
Visual C++
public:
property SublayoutItem^ default[ID^ itemID, Language^ language] {
    SublayoutItem^ get (ID^ itemID, Language^ language);
}

Parameters

itemID
Type: Sitecore.Data..::..ID
language
Type: Sitecore.Globalization..::..Language

See Also

SublayoutRecords Class
Item Overload
Sitecore.Data Namespace


Item Property (String, Language, Version)

[image]

Sitecore 6.4.1 API
SublayoutRecords..::..Item Property (String, Language, Version)
SublayoutRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SublayoutItem this[
    string itemPath,
    Language language,
    Version version
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    itemPath As String, _
    language As Language, _
    version As Version _
) As SublayoutItem
    Get
Visual C++
public:
property SublayoutItem^ default[String^ itemPath, Language^ language, Version^ version] {
    SublayoutItem^ get (String^ itemPath, Language^ language, Version^ version);
}

Parameters

itemPath
Type: System..::..String
language
Type: Sitecore.Globalization..::..Language
version
Type: Sitecore.Data..::..Version

See Also

SublayoutRecords Class
Item Overload
Sitecore.Data Namespace


Item Property (ID, Language, Version)

[image]

Sitecore 6.4.1 API
SublayoutRecords..::..Item Property (ID, Language, Version)
SublayoutRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SublayoutItem this[
    ID itemID,
    Language language,
    Version version
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    itemID As ID, _
    language As Language, _
    version As Version _
) As SublayoutItem
    Get
Visual C++
public:
property SublayoutItem^ default[ID^ itemID, Language^ language, Version^ version] {
    SublayoutItem^ get (ID^ itemID, Language^ language, Version^ version);
}

Parameters

itemID
Type: Sitecore.Data..::..ID
language
Type: Sitecore.Globalization..::..Language
version
Type: Sitecore.Data..::..Version

See Also

SublayoutRecords Class
Item Overload
Sitecore.Data Namespace


TemplateID Structure

[image]

Sitecore 6.4.1 API
TemplateID Structure
Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public struct TemplateID
Visual Basic
Public Structure TemplateID
Visual C++
public value class TemplateID

See Also

TemplateID Members
Sitecore.Data Namespace


TemplateID Members

[image] [image]

Sitecore 6.4.1 API
TemplateID Members
TemplateID Structure Constructors Methods Properties See Also Send Feedback

The TemplateID type exposes the following members.

Constructors

 | Name | Description
Public method | TemplateID | Initializes a new instance of the TemplateID class.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Overrides ValueType..::..ToString()()()().)

Properties

 | Name | Description
Public property | ID | Gets the ID.

See Also

TemplateID Structure
Sitecore.Data Namespace


TemplateID Constructor

[image]

Sitecore 6.4.1 API
TemplateID Constructor
TemplateID Structure See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateID(
    ID id
)
Visual Basic
Public Sub New ( _
    id As ID _
)
Visual C++
public:
TemplateID(
    ID^ id
)

Parameters

id
Type: Sitecore.Data..::..ID
The id.

See Also

TemplateID Structure
Sitecore.Data Namespace


TemplateID Methods

[image] [image]

Sitecore 6.4.1 API
TemplateID Methods
TemplateID Structure See Also Send Feedback

The TemplateID type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Overrides ValueType..::..ToString()()()().)

See Also

TemplateID Structure
Sitecore.Data Namespace


ToString Method

[image]

Sitecore 6.4.1 API
TemplateID..::..ToString Method
TemplateID Structure See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String containing a fully qualified type name.

See Also

TemplateID Structure
Sitecore.Data Namespace


ID Property

[image]

Sitecore 6.4.1 API
TemplateID..::..ID Property
TemplateID Structure See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ID { get; }
Visual Basic
Public ReadOnly Property ID As ID
    Get
Visual C++
public:
property ID^ ID {
    ID^ get ();
}

Field Value

The ID.

See Also

TemplateID Structure
Sitecore.Data Namespace


TemplateRecords Class

[image]

Sitecore 6.4.1 API
TemplateRecords Class
Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class TemplateRecords
Visual Basic
Public Class TemplateRecords
Visual C++
public ref class TemplateRecords

Remarks

Templates are configured in /sitecore/templates.

The templates are normally access through the Templates property.

Inheritance Hierarchy

System..::..Object
Sitecore.Data..::..TemplateRecords

See Also

TemplateRecords Members
Sitecore.Data Namespace


TemplateRecords Members

[image] [image]

Sitecore 6.4.1 API
TemplateRecords Members
TemplateRecords Class Constructors Methods Properties See Also Send Feedback

The TemplateRecords type exposes the following members.

Constructors

 | Name | Description
Public method | TemplateRecords | Creates a new TemplateRecords instance.

Methods

 | Name | Description
Public method | CreateTemplate | Creates a new template.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTemplates | Gets all the templates in a specified language.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item[([( String])]) | Gets the TemplateItem with the specified full name.
Public property | Item[([( ID])]) | Gets the TemplateItem with the specified template ID.
Public property | Item[([( String, Language])]) | Gets the TemplateItem with the specified full name.
Public property | Item[([( ID, Language])]) | Gets the TemplateItem with the specified template ID.

See Also

TemplateRecords Class
Sitecore.Data Namespace


TemplateRecords Constructor

[image]

Sitecore 6.4.1 API
TemplateRecords Constructor
TemplateRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateRecords(
    Database database
)
Visual Basic
Public Sub New ( _
    database As Database _
)
Visual C++
public:
TemplateRecords(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
Database.

See Also

TemplateRecords Class
Sitecore.Data Namespace


TemplateRecords Methods

[image] [image]

Sitecore 6.4.1 API
TemplateRecords Methods
TemplateRecords Class See Also Send Feedback

The TemplateRecords type exposes the following members.

Methods

 | Name | Description
Public method | CreateTemplate | Creates a new template.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTemplates | Gets all the templates in a specified language.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TemplateRecords Class
Sitecore.Data Namespace


GetTemplates Method

[image]

Sitecore 6.4.1 API
TemplateRecords..::..GetTemplates Method
TemplateRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateItem[] GetTemplates(
    Language language
)
Visual Basic
Public Function GetTemplates ( _
    language As Language _
) As TemplateItem()
Visual C++
public:
array<TemplateItem^>^ GetTemplates(
    Language^ language
)

Parameters

language
Type: Sitecore.Globalization..::..Language
Language.

Return Value

The templates.

See Also

TemplateRecords Class
Sitecore.Data Namespace


TemplateRecords Properties

[image] [image]

Sitecore 6.4.1 API
TemplateRecords Properties
TemplateRecords Class See Also Send Feedback

Properties

 | Name | Description
Public property | Item[([( String])]) | Gets the TemplateItem with the specified full name.
Public property | Item[([( ID])]) | Gets the TemplateItem with the specified template ID.
Public property | Item[([( String, Language])]) | Gets the TemplateItem with the specified full name.
Public property | Item[([( ID, Language])]) | Gets the TemplateItem with the specified template ID.

See Also

TemplateRecords Class
Sitecore.Data Namespace


Item Property

[image] [image]

Sitecore 6.4.1 API
TemplateRecords..::..Item Property
TemplateRecords Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( String])]) | Gets the TemplateItem with the specified full name.
Public property | Item[([( ID])]) | Gets the TemplateItem with the specified template ID.
Public property | Item[([( String, Language])]) | Gets the TemplateItem with the specified full name.
Public property | Item[([( ID, Language])]) | Gets the TemplateItem with the specified template ID.

See Also

TemplateRecords Class
TemplateRecords Members
Sitecore.Data Namespace


Item Property (String)

[image]

Sitecore 6.4.1 API
TemplateRecords..::..Item Property (String)
TemplateRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateItem this[
    string fullName
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    fullName As String _
) As TemplateItem
    Get
Visual C++
public:
property TemplateItem^ default[String^ fullName] {
    TemplateItem^ get (String^ fullName);
}

Parameters

fullName
Type: System..::..String

See Also

TemplateRecords Class
Item Overload
Sitecore.Data Namespace


Item Property (ID)

[image]

Sitecore 6.4.1 API
TemplateRecords..::..Item Property (ID)
TemplateRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateItem this[
    ID templateID
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    templateID As ID _
) As TemplateItem
    Get
Visual C++
public:
property TemplateItem^ default[ID^ templateID] {
    TemplateItem^ get (ID^ templateID);
}

Parameters

templateID
Type: Sitecore.Data..::..ID

See Also

TemplateRecords Class
Item Overload
Sitecore.Data Namespace


Item Property (String, Language)

[image]

Sitecore 6.4.1 API
TemplateRecords..::..Item Property (String, Language)
TemplateRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateItem this[
    string fullName,
    Language language
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    fullName As String, _
    language As Language _
) As TemplateItem
    Get
Visual C++
public:
property TemplateItem^ default[String^ fullName, Language^ language] {
    TemplateItem^ get (String^ fullName, Language^ language);
}

Parameters

fullName
Type: System..::..String
language
Type: Sitecore.Globalization..::..Language

See Also

TemplateRecords Class
Item Overload
Sitecore.Data Namespace


Item Property (ID, Language)

[image]

Sitecore 6.4.1 API
TemplateRecords..::..Item Property (ID, Language)
TemplateRecords Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateItem this[
    ID templateID,
    Language language
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    templateID As ID, _
    language As Language _
) As TemplateItem
    Get
Visual C++
public:
property TemplateItem^ default[ID^ templateID, Language^ language] {
    TemplateItem^ get (ID^ templateID, Language^ language);
}

Parameters

templateID
Type: Sitecore.Data..::..ID
language
Type: Sitecore.Globalization..::..Language

See Also

TemplateRecords Class
Item Overload
Sitecore.Data Namespace


TreeNavigator Class

[image]

Sitecore 6.4.1 API
TreeNavigator Class
Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public class TreeNavigator
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Class TreeNavigator
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public ref class TreeNavigator

Inheritance Hierarchy

System..::..Object
Sitecore.Data..::..TreeNavigator

See Also

TreeNavigator Members
Sitecore.Data Namespace


TreeNavigator Members

[image] [image]

Sitecore 6.4.1 API
TreeNavigator Members
TreeNavigator Class Constructors Methods Properties See Also Send Feedback

The TreeNavigator type exposes the following members.

Constructors

 | Name | Description
Public method | TreeNavigator | Initializes a new instance of the TreeNavigator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveToNext | Moves to next.
Public method | MoveToRoot | Moves to root.
Public method | SkipBranch | Skips the branch.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Gets the current.
Public property | Root | Gets the root.

See Also

TreeNavigator Class
Sitecore.Data Namespace


TreeNavigator Constructor

[image]

Sitecore 6.4.1 API
TreeNavigator Constructor
TreeNavigator Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TreeNavigator(
    Item rootItem
)
Visual Basic
Public Sub New ( _
    rootItem As Item _
)
Visual C++
public:
TreeNavigator(
    Item^ rootItem
)

Parameters

rootItem
Type: Sitecore.Data.Items..::..Item
The root item.

See Also

TreeNavigator Class
Sitecore.Data Namespace


TreeNavigator Methods

[image] [image]

Sitecore 6.4.1 API
TreeNavigator Methods
TreeNavigator Class See Also Send Feedback

The TreeNavigator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveToNext | Moves to next.
Public method | MoveToRoot | Moves to root.
Public method | SkipBranch | Skips the branch.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TreeNavigator Class
Sitecore.Data Namespace


MoveToNext Method

[image]

Sitecore 6.4.1 API
TreeNavigator..::..MoveToNext Method
TreeNavigator Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool MoveToNext()
Visual Basic
Public Function MoveToNext As Boolean
Visual C++
public:
bool MoveToNext()

Return Value

The next.

See Also

TreeNavigator Class
Sitecore.Data Namespace


MoveToRoot Method

[image]

Sitecore 6.4.1 API
TreeNavigator..::..MoveToRoot Method
TreeNavigator Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool MoveToRoot()
Visual Basic
Public Function MoveToRoot As Boolean
Visual C++
public:
bool MoveToRoot()

Return Value

The root.

See Also

TreeNavigator Class
Sitecore.Data Namespace


SkipBranch Method

[image]

Sitecore 6.4.1 API
TreeNavigator..::..SkipBranch Method
TreeNavigator Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SkipBranch()
Visual Basic
Public Sub SkipBranch
Visual C++
public:
void SkipBranch()

See Also

TreeNavigator Class
Sitecore.Data Namespace


Current Property

[image]

Sitecore 6.4.1 API
TreeNavigator..::..Current Property
TreeNavigator Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Current { get; }
Visual Basic
Public ReadOnly Property Current As Item
    Get
Visual C++
public:
property Item^ Current {
    Item^ get ();
}

Field Value

The current.

See Also

TreeNavigator Class
Sitecore.Data Namespace


Root Property

[image]

Sitecore 6.4.1 API
TreeNavigator..::..Root Property
TreeNavigator Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Root { get; }
Visual Basic
Public ReadOnly Property Root As Item
    Get
Visual C++
public:
property Item^ Root {
    Item^ get ();
}

Field Value

The root.

See Also

TreeNavigator Class
Sitecore.Data Namespace


TreeNavigator.State Class

[image]

Sitecore 6.4.1 API
TreeNavigator..::..State Class
TreeNavigator Class Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class State
Visual Basic
Public Class State
Visual C++
public ref class State

Inheritance Hierarchy

System..::..Object
Sitecore.Data..::..TreeNavigator..::..State

See Also

TreeNavigator..::..State Members
Sitecore.Data Namespace


TreeNavigator.State Members

[image] [image]

Sitecore 6.4.1 API
TreeNavigator..::..State Members
TreeNavigator..::..State Class Constructors Methods Properties See Also Send Feedback

Represents a tree navigator.

The TreeNavigator..::..State type exposes the following members.

Constructors

 | Name | Description
Public method | TreeNavigator..::..State | Initializes a new instance of the TreeNavigator..::..State class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext | Moves the next.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Gets the current.
Public property | Index | Gets the index.
Public property | Items | Gets the items.

See Also

TreeNavigator..::..State Class
Sitecore.Data Namespace


TreeNavigator.State Constructor

[image]

Sitecore 6.4.1 API
TreeNavigator..::..State Constructor
TreeNavigator..::..State Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public State(
    ArrayList items
)
Visual Basic
Public Sub New ( _
    items As ArrayList _
)
Visual C++
public:
State(
    ArrayList^ items
)

Parameters

items
Type: System.Collections..::..ArrayList
The items.

See Also

TreeNavigator..::..State Class
Sitecore.Data Namespace


TreeNavigator.State Methods

[image] [image]

Sitecore 6.4.1 API
TreeNavigator..::..State Methods
TreeNavigator..::..State Class See Also Send Feedback

The TreeNavigator..::..State type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext | Moves the next.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TreeNavigator..::..State Class
Sitecore.Data Namespace


MoveNext Method

[image]

Sitecore 6.4.1 API
TreeNavigator..::..State..::..MoveNext Method
TreeNavigator..::..State Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool MoveNext()
Visual Basic
Public Function MoveNext As Boolean
Visual C++
public:
bool MoveNext()

Return Value

The next.

See Also

TreeNavigator..::..State Class
Sitecore.Data Namespace


TreeNavigator.State Properties

[image] [image]

Sitecore 6.4.1 API
TreeNavigator..::..State Properties
TreeNavigator..::..State Class See Also Send Feedback

The TreeNavigator..::..State type exposes the following members.

Properties

 | Name | Description
Public property | Current | Gets the current.
Public property | Index | Gets the index.
Public property | Items | Gets the items.

See Also

TreeNavigator..::..State Class
Sitecore.Data Namespace


Current Property

[image]

Sitecore 6.4.1 API
TreeNavigator..::..State..::..Current Property
TreeNavigator..::..State Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Current { get; }
Visual Basic
Public ReadOnly Property Current As Item
    Get
Visual C++
public:
property Item^ Current {
    Item^ get ();
}

Field Value

The current.

See Also

TreeNavigator..::..State Class
Sitecore.Data Namespace


Index Property

[image]

Sitecore 6.4.1 API
TreeNavigator..::..State..::..Index Property
TreeNavigator..::..State Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Index { get; }
Visual Basic
Public ReadOnly Property Index As Integer
    Get
Visual C++
public:
property int Index {
    int get ();
}

Field Value

The index.

See Also

TreeNavigator..::..State Class
Sitecore.Data Namespace


Items Property

[image]

Sitecore 6.4.1 API
TreeNavigator..::..State..::..Items Property
TreeNavigator..::..State Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ArrayList Items { get; }
Visual Basic
Public ReadOnly Property Items As ArrayList
    Get
Visual C++
public:
property ArrayList^ Items {
    ArrayList^ get ();
}

Field Value

The items.

See Also

TreeNavigator..::..State Class
Sitecore.Data Namespace


Version Class

[image]

Sitecore 6.4.1 API
Version Class
Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class Version : ISerializable, ICacheable
Visual Basic
<SerializableAttribute> _
Public Class Version _
    Implements ISerializable, ICacheable
Visual C++
[SerializableAttribute]
public ref class Version : ISerializable,
    ICacheable

Inheritance Hierarchy

System..::..Object
Sitecore.Data..::..Version

See Also

Version Members
Sitecore.Data Namespace


Version Members

[image] [image]

Sitecore 6.4.1 API
Version Members
Version Class Constructors Methods Operators Properties See Also Send Feedback

The Version type exposes the following members.

Constructors

 | Name | Description
Public method | Version(Int32) | Creates a new Version instance.
Public method | Version(String) | Creates a new Version instance.
Public method | Version(Int32, Int32) | Creates a new Version instance.
Protected method | Version(SerializationInfo, StreamingContext) | Creates a new Version instance.
Public method | Version(String, Int32) | Creates a new Version instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Overrides Object..::..GetHashCode()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse(Int32) | Converts a string into a version number.
 | Parse(Object) | Converts a string into a version number.
 | Parse(String) | Converts a string into a version number.
Public method | ToInt32 | Converts the version number into an integer.
Public method | ToString | Converts the version number to a string. (Overrides Object..::..ToString()()()().)
 | TryParse | Tries to parse a string.

Operators

Name | Description
Equality | Determines whether two version instances are equal.
Inequality | Determines whether two version instances are unequal.

Properties

 | Name | Description
 | First | Gets the first version number.
 | Invalid | Gets the invalid version number.
 | Latest | Gets the latest number.
Public property | Number | Gets or sets the number.

See Also

Version Class
Sitecore.Data Namespace


Version Constructor

[image] [image]

Sitecore 6.4.1 API
Version Constructor
Version Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Version(Int32) | Creates a new Version instance.
Public method | Version(String) | Creates a new Version instance.
Public method | Version(Int32, Int32) | Creates a new Version instance.
Protected method | Version(SerializationInfo, StreamingContext) | Creates a new Version instance.
Public method | Version(String, Int32) | Creates a new Version instance.

See Also

Version Class
Version Members
Sitecore.Data Namespace


Version Constructor (Int32)

[image]

Sitecore 6.4.1 API
Version Constructor (Int32)
Version Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Version(
    int version
)
Visual Basic
Public Sub New ( _
    version As Integer _
)
Visual C++
public:
Version(
    int version
)

Parameters

version
Type: System..::..Int32
Version.

See Also

Version Class
Version Overload
Sitecore.Data Namespace


Version Constructor (String)

[image]

Sitecore 6.4.1 API
Version Constructor (String)
Version Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Version(
    string version
)
Visual Basic
Public Sub New ( _
    version As String _
)
Visual C++
public:
Version(
    String^ version
)

Parameters

version
Type: System..::..String
Version.

See Also

Version Class
Version Overload
Sitecore.Data Namespace


Version Constructor (Int32, Int32)

[image]

Sitecore 6.4.1 API
Version Constructor (Int32, Int32)
Version Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Version(
    int version,
    int defaultValue
)
Visual Basic
Public Sub New ( _
    version As Integer, _
    defaultValue As Integer _
)
Visual C++
public:
Version(
    int version,
    int defaultValue
)

Parameters

version
Type: System..::..Int32
Version.
defaultValue
Type: System..::..Int32
Default value.

See Also

Version Class
Version Overload
Sitecore.Data Namespace


Version Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
Version Constructor (SerializationInfo, StreamingContext)
Version Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Version(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
Version(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Info.
context
Type: System.Runtime.Serialization..::..StreamingContext
Context.

See Also

Version Class
Version Overload
Sitecore.Data Namespace


Version Constructor (String, Int32)

[image]

Sitecore 6.4.1 API
Version Constructor (String, Int32)
Version Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Version(
    string version,
    int defaultValue
)
Visual Basic
Public Sub New ( _
    version As String, _
    defaultValue As Integer _
)
Visual C++
public:
Version(
    String^ version,
    int defaultValue
)

Parameters

version
Type: System..::..String
Version.
defaultValue
Type: System..::..Int32
Default value.

See Also

Version Class
Version Overload
Sitecore.Data Namespace


Version Methods

[image] [image]

Sitecore 6.4.1 API
Version Methods
Version Class See Also Send Feedback

The Version type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Overrides Object..::..GetHashCode()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse(Int32) | Converts a string into a version number.
 | Parse(Object) | Converts a string into a version number.
 | Parse(String) | Converts a string into a version number.
Public method | ToInt32 | Converts the version number into an integer.
Public method | ToString | Converts the version number to a string. (Overrides Object..::..ToString()()()().)
 | TryParse | Tries to parse a string.

See Also

Version Class
Sitecore.Data Namespace


Equals Method

[image]

Sitecore 6.4.1 API
Version..::..Equals Method
Version Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

See Also

Version Class
Sitecore.Data Namespace


GetHashCode Method

[image]

Sitecore 6.4.1 API
Version..::..GetHashCode Method
Version Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A hash code for the current Object.

See Also

Version Class
Sitecore.Data Namespace


GetObjectData Method

[image]

Sitecore 6.4.1 API
Version..::..GetObjectData Method
Version Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System.Security..::..SecurityException | The caller does not have the required permission.

See Also

Version Class
Sitecore.Data Namespace


Parse Method

[image] [image]

Sitecore 6.4.1 API
Version..::..Parse Method
Version Class See Also Send Feedback

Overload List

Name | Description
Parse(Int32) | Converts a string into a version number.
Parse(Object) | Converts a string into a version number.
Parse(String) | Converts a string into a version number.

See Also

Version Class
Version Members
Sitecore.Data Namespace


Parse Method (Int32)

[image]

Sitecore 6.4.1 API
Version..::..Parse Method (Int32)
Version Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Version Parse(
    int value
)
Visual Basic
Public Shared Function Parse ( _
    value As Integer _
) As Version
Visual C++
public:
static Version^ Parse(
    int value
)

Parameters

value
Type: System..::..Int32
Value.

Return Value

The parse.

See Also

Version Class
Parse Overload
Sitecore.Data Namespace


Parse Method (Object)

[image]

Sitecore 6.4.1 API
Version..::..Parse Method (Object)
Version Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Version Parse(
    Object value
)
Visual Basic
Public Shared Function Parse ( _
    value As Object _
) As Version
Visual C++
public:
static Version^ Parse(
    Object^ value
)

Parameters

value
Type: System..::..Object
Value.

Return Value

The parse.

See Also

Version Class
Parse Overload
Sitecore.Data Namespace


Parse Method (String)

[image]

Sitecore 6.4.1 API
Version..::..Parse Method (String)
Version Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Version Parse(
    string value
)
Visual Basic
Public Shared Function Parse ( _
    value As String _
) As Version
Visual C++
public:
static Version^ Parse(
    String^ value
)

Parameters

value
Type: System..::..String
Value.

Return Value

The parse.

See Also

Version Class
Parse Overload
Sitecore.Data Namespace


ToInt32 Method

[image]

Sitecore 6.4.1 API
Version..::..ToInt32 Method
Version Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int ToInt32()
Visual Basic
Public Function ToInt32 As Integer
Visual C++
public:
int ToInt32()

Return Value

The int32.

See Also

Version Class
Sitecore.Data Namespace


ToString Method

[image]

Sitecore 6.4.1 API
Version..::..ToString Method
Version Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

Version Class
Sitecore.Data Namespace


TryParse Method

[image]

Sitecore 6.4.1 API
Version..::..TryParse Method
Version Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool TryParse(
    string value,
    out Version result
)
Visual Basic
Public Shared Function TryParse ( _
    value As String, _
    <OutAttribute> ByRef result As Version _
) As Boolean
Visual C++
public:
static bool TryParse(
    String^ value,
    [OutAttribute] Version^% result
)

Parameters

value
Type: System..::..String
The value.
result
Type: Sitecore.Data..::..Version %
The result.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Version.TryParse(System.String,Sitecore.Data.Version@)"]

See Also

Version Class
Sitecore.Data Namespace


Version Operators

[image] [image]

Sitecore 6.4.1 API
Version Operators
Version Class See Also Send Feedback

The Version type exposes the following members.

Operators

Name | Description
Equality | Determines whether two version instances are equal.
Inequality | Determines whether two version instances are unequal.

See Also

Version Class
Sitecore.Data Namespace


Equality Operator

[image]

Sitecore 6.4.1 API
Version..::..Equality Operator
Version Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool operator ==(
    Version version1,
    Version version2
)
Visual Basic
Public Shared Operator = ( _
    version1 As Version, _
    version2 As Version _
) As Boolean
Visual C++
public:
static bool operator ==(
    Version^ version1,
    Version^ version2
)

Parameters

version1
Type: Sitecore.Data..::..Version
The first version to compare.
version2
Type: Sitecore.Data..::..Version
The second version to compare.

Return Value

true if version1 is the same instance as version2 or if both are null references or if version1.Equals(version2) returns true; otherwise, false.

See Also

Version Class
Sitecore.Data Namespace


Inequality Operator

[image]

Sitecore 6.4.1 API
Version..::..Inequality Operator
Version Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool operator !=(
    Version version1,
    Version version2
)
Visual Basic
Public Shared Operator <> ( _
    version1 As Version, _
    version2 As Version _
) As Boolean
Visual C++
public:
static bool operator !=(
    Version^ version1,
    Version^ version2
)

Parameters

version1
Type: Sitecore.Data..::..Version
The first version to compare.
version2
Type: Sitecore.Data..::..Version
The second version to compare.

Return Value

true if version1 is not the same instance as version2 or if version1.Equals(version2) returns false; otherwise, false.

See Also

Version Class
Sitecore.Data Namespace


Version Properties

[image] [image]

Sitecore 6.4.1 API
Version Properties
Version Class See Also Send Feedback

The Version type exposes the following members.

Properties

 | Name | Description
 | First | Gets the first version number.
 | Invalid | Gets the invalid version number.
 | Latest | Gets the latest number.
Public property | Number | Gets or sets the number.

See Also

Version Class
Sitecore.Data Namespace


First Property

[image]

Sitecore 6.4.1 API
Version..::..First Property
Version Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Version First { get; }
Visual Basic
Public Shared ReadOnly Property First As Version
    Get
Visual C++
public:
static property Version^ First {
    Version^ get ();
}

Field Value

The first.

Remarks

The version number of the first version is 1.

See Also

Version Class
Sitecore.Data Namespace


Invalid Property

[image]

Sitecore 6.4.1 API
Version..::..Invalid Property
Version Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Version Invalid { get; }
Visual Basic
Public Shared ReadOnly Property Invalid As Version
    Get
Visual C++
public:
static property Version^ Invalid {
    Version^ get ();
}

Field Value

The invalid.

Remarks

The version number of the first version is -1.

See Also

Version Class
Sitecore.Data Namespace


Latest Property

[image]

Sitecore 6.4.1 API
Version..::..Latest Property
Version Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Version Latest { get; }
Visual Basic
Public Shared ReadOnly Property Latest As Version
    Get
Visual C++
public:
static property Version^ Latest {
    Version^ get ();
}

Field Value

The latest.

Remarks

The version number of the first version is 0.

See Also

Version Class
Sitecore.Data Namespace


Number Property

[image]

Sitecore 6.4.1 API
Version..::..Number Property
Version Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Number { get; }
Visual Basic
Public ReadOnly Property Number As Integer
    Get
Visual C++
public:
property int Number {
    int get ();
}

Field Value

The number.

See Also

Version Class
Sitecore.Data Namespace


VersionComparer Class

[image]

Sitecore 6.4.1 API
VersionComparer Class
Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class VersionComparer : IComparer,
    IComparer<Version>
Visual Basic
Public Class VersionComparer _
    Implements IComparer, IComparer(Of Version)
Visual C++
public ref class VersionComparer : IComparer,
    IComparer<Version^>

Inheritance Hierarchy

System..::..Object
Sitecore.Data..::..VersionComparer

See Also

VersionComparer Members
Sitecore.Data Namespace


VersionComparer Members

[image] [image]

Sitecore 6.4.1 API
VersionComparer Members
VersionComparer Class Constructors Methods See Also Send Feedback

The VersionComparer type exposes the following members.

Constructors

 | Name | Description
Public method | VersionComparer | Initializes a new instance of the VersionComparer class

Methods

 | Name | Description
Public method | Compare(Object, Object) | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Public method | Compare(Version, Version) | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VersionComparer Class
Sitecore.Data Namespace


VersionComparer Constructor

[image]

Sitecore 6.4.1 API
VersionComparer Constructor
VersionComparer Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public VersionComparer()
Visual Basic
Public Sub New
Visual C++
public:
VersionComparer()

See Also

VersionComparer Class
Sitecore.Data Namespace


VersionComparer Methods

[image] [image]

Sitecore 6.4.1 API
VersionComparer Methods
VersionComparer Class See Also Send Feedback

The VersionComparer type exposes the following members.

Methods

 | Name | Description
Public method | Compare(Object, Object) | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Public method | Compare(Version, Version) | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VersionComparer Class
Sitecore.Data Namespace


Compare Method

[image] [image]

Sitecore 6.4.1 API
VersionComparer..::..Compare Method
VersionComparer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Compare(Object, Object) | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Public method | Compare(Version, Version) | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.

See Also

VersionComparer Class
VersionComparer Members
Sitecore.Data Namespace


Compare Method (Object, Object)

[image]

Sitecore 6.4.1 API
VersionComparer..::..Compare Method (Object, Object)
VersionComparer Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Compare(
    Object x,
    Object y
)
Visual Basic
Public Function Compare ( _
    x As Object, _
    y As Object _
) As Integer
Visual C++
public:
virtual int Compare(
    Object^ x,
    Object^ y
) sealed

Parameters

x
Type: System..::..Object
The first object to compare.
y
Type: System..::..Object
The second object to compare.

Return Value

Value Condition Less than zero x is less than y. Zero x equals y. Greater than zero x is greater than y.

Implements

IComparer..::..Compare(Object, Object)

Exceptions

Exception | Condition
System..::..ArgumentException | Neither x nor y implements the IComparable interface.-or- x and y are of different types and neither one can handle comparisons with the other.

See Also

VersionComparer Class
Compare Overload
Sitecore.Data Namespace


Compare Method (Version, Version)

[image]

Sitecore 6.4.1 API
VersionComparer..::..Compare Method (Version, Version)
VersionComparer Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Compare(
    Version version1,
    Version version2
)
Visual Basic
Public Function Compare ( _
    version1 As Version, _
    version2 As Version _
) As Integer
Visual C++
public:
virtual int Compare(
    Version^ version1,
    Version^ version2
) sealed

Parameters

version1
Type: Sitecore.Data..::..Version
The version1.
version2
Type: Sitecore.Data..::..Version
The version2.

Return Value

Value Condition Less than zerox is less than y.Zerox equals y.Greater than zerox is greater than y.

Implements

IComparer<(Of <(<'T>)>)>..::..Compare(T, T)

See Also

VersionComparer Class
Compare Overload
Sitecore.Data Namespace


VersioningType Enumeration

[image]

Sitecore 6.4.1 API
VersioningType Enumeration
See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum VersioningType
Visual Basic
Public Enumeration VersioningType
Visual C++
public enum class VersioningType

Members

Member name | Value | Description
None | 0 | Field is shared by all languages and versions.
Language | 1 | Field is shared by languages.
Full | 2 | Field is not shared.

See Also

Sitecore.Data Namespace


VersionUri Class

[image]

Sitecore 6.4.1 API
VersionUri Class
Members See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class VersionUri
Visual Basic
Public Class VersionUri
Visual C++
public ref class VersionUri

Inheritance Hierarchy

System..::..Object
Sitecore.Data..::..VersionUri

See Also

VersionUri Members
Sitecore.Data Namespace


VersionUri Members

[image] [image]

Sitecore 6.4.1 API
VersionUri Members
VersionUri Class Constructors Methods Properties See Also Send Feedback

The VersionUri type exposes the following members.

Constructors

 | Name | Description
Public method | VersionUri | Initializes a new instance of the VersionUri class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Language | Gets the language.
Public property | Version | Gets the version.

See Also

VersionUri Class
Sitecore.Data Namespace


VersionUri Constructor

[image]

Sitecore 6.4.1 API
VersionUri Constructor
VersionUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public VersionUri(
    Language language,
    Version version
)
Visual Basic
Public Sub New ( _
    language As Language, _
    version As Version _
)
Visual C++
public:
VersionUri(
    Language^ language,
    Version^ version
)

Parameters

language
Type: Sitecore.Globalization..::..Language
The language.
version
Type: Sitecore.Data..::..Version
The version.

See Also

VersionUri Class
Sitecore.Data Namespace


VersionUri Methods

[image] [image]

Sitecore 6.4.1 API
VersionUri Methods
VersionUri Class See Also Send Feedback

The VersionUri type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

VersionUri Class
Sitecore.Data Namespace


ToString Method

[image]

Sitecore 6.4.1 API
VersionUri..::..ToString Method
VersionUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

VersionUri Class
Sitecore.Data Namespace


VersionUri Properties

[image] [image]

Sitecore 6.4.1 API
VersionUri Properties
VersionUri Class See Also Send Feedback

The VersionUri type exposes the following members.

Properties

 | Name | Description
Public property | Language | Gets the language.
Public property | Version | Gets the version.

See Also

VersionUri Class
Sitecore.Data Namespace


Language Property

[image]

Sitecore 6.4.1 API
VersionUri..::..Language Property
VersionUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Language Language { get; }
Visual Basic
Public ReadOnly Property Language As Language
    Get
Visual C++
public:
property Language^ Language {
    Language^ get ();
}

Field Value

The language.

See Also

VersionUri Class
Sitecore.Data Namespace


Version Property

[image]

Sitecore 6.4.1 API
VersionUri..::..Version Property
VersionUri Class See Also Send Feedback

Namespace: Sitecore.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Version Version { get; }
Visual Basic
Public ReadOnly Property Version As Version
    Get
Visual C++
public:
property Version^ Version {
    Version^ get ();
}

Field Value

The version.

See Also

VersionUri Class
Sitecore.Data Namespace


Sitecore.Data.Archiving Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Data.Archiving Namespace
Send Feedback

Classes

 | Class | Description
Public class | Archive | Provides functionality to archive an item.
Public class | ArchiveEntry | ArchiveEntry
Public class | ArchiveEntryList | ArchiveEntry list.
Public class | ArchiveItemCompletedEvent | Defines the archive item completed event class.
Public class | ArchiveManager | ArchiveManager
Public class | ArchiveProvider | ArchiveProvider
Public class | ArchiveProviderCollection | ArchiveProviderCollection
Public class | ArchiveQuery | ArchiveQuery
Public class | ArchiveQuery..::..Ordering | Ordering
Public class | DataArchives | Represents the archives that are attached to a database.
Public class | SqlArchive | Sql Archive class.
Public class | SqlArchiveProvider | SqlArchiveProvider
Public class | SwitchingArchiveProvider | SwitchingArchiveProvider class

Enumerations

 | Enumeration | Description
Public enumeration | ArchiveQuery..::..ArchiveField | ArchiveField
Public enumeration | ArchiveQuery..::..OrderDirection | OrderDirection


Archive Class

[image]

Sitecore 6.4.1 API
Archive Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class Archive
Visual Basic
Public MustInherit Class Archive
Visual C++
public ref class Archive abstract

Remarks

When archiving an item, the item is moved to the Archive database.

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Archiving..::..Archive
Sitecore.Data.Archiving..::..SqlArchive

See Also

Archive Members
Sitecore.Data.Archiving Namespace


Archive Members

[image] [image]

Sitecore 6.4.1 API
Archive Members
Archive Class Constructors Methods Properties See Also Send Feedback

The Archive type exposes the following members.

Constructors

 | Name | Description
Protected method | Archive | Creates a new Archive instance.

Methods

 | Name | Description
Public method | ArchiveItem | Archives an item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetArchivalId | Gets the archival id associated with an item.
Public method | GetEntries(Int32, Int32) | Gets a list of entries.
Public method | GetEntries(ArchiveQuery, Int32, Int32) | Gets a list of entries.
Public method | GetEntriesForUser | Gets a list of entries owned by the specified user.
Public method | GetEntryCount()()()() | Gets the number of entries currently in the archive.
Public method | GetEntryCount(ArchiveQuery) | Gets the number of entries currently in the archive.
Public method | GetEntryCountForUser | Gets the entry count for current user.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotifyItemDeleted | Notifies the item deleted.
Protected method | NotifyItemDeleting | Notifies the item deleting.
Public method | RemoveEntries()()()() | Removes all entries from the archive.
Public method | RemoveEntries(ArchiveQuery) | Removes all entries from the archive.
Public method | RestoreItem | Restores an item.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | Gets the name of the archive.

See Also

Archive Class
Sitecore.Data.Archiving Namespace


Archive Constructor

[image]

Sitecore 6.4.1 API
Archive Constructor
Archive Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Archive(
    string name
)
Visual Basic
Protected Sub New ( _
    name As String _
)
Visual C++
protected:
Archive(
    String^ name
)

Parameters

name
Type: System..::..String
Name.

See Also

Archive Class
Sitecore.Data.Archiving Namespace


Archive Methods

[image] [image]

Sitecore 6.4.1 API
Archive Methods
Archive Class See Also Send Feedback

The Archive type exposes the following members.

Methods

 | Name | Description
Public method | ArchiveItem | Archives an item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetArchivalId | Gets the archival id associated with an item.
Public method | GetEntries(Int32, Int32) | Gets a list of entries.
Public method | GetEntries(ArchiveQuery, Int32, Int32) | Gets a list of entries.
Public method | GetEntriesForUser | Gets a list of entries owned by the specified user.
Public method | GetEntryCount()()()() | Gets the number of entries currently in the archive.
Public method | GetEntryCount(ArchiveQuery) | Gets the number of entries currently in the archive.
Public method | GetEntryCountForUser | Gets the entry count for current user.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotifyItemDeleted | Notifies the item deleted.
Protected method | NotifyItemDeleting | Notifies the item deleting.
Public method | RemoveEntries()()()() | Removes all entries from the archive.
Public method | RemoveEntries(ArchiveQuery) | Removes all entries from the archive.
Public method | RestoreItem | Restores an item.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Archive Class
Sitecore.Data.Archiving Namespace


ArchiveItem Method

[image]

Sitecore 6.4.1 API
Archive..::..ArchiveItem Method
Archive Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract Guid ArchiveItem(
    Item item
)
Visual Basic
Public MustOverride Function ArchiveItem ( _
    item As Item _
) As Guid
Visual C++
public:
virtual Guid ArchiveItem(
    Item^ item
) abstract

Parameters

item
Type: Sitecore.Data.Items..::..Item
Item.

Return Value

The archival id.

See Also

Archive Class
Sitecore.Data.Archiving Namespace


GetArchivalId Method

[image]

Sitecore 6.4.1 API
Archive..::..GetArchivalId Method
Archive Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract Guid GetArchivalId(
    ID itemId
)
Visual Basic
Public MustOverride Function GetArchivalId ( _
    itemId As ID _
) As Guid
Visual C++
public:
virtual Guid GetArchivalId(
    ID^ itemId
) abstract

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Archiving.Archive.GetArchivalId(Sitecore.Data.ID)"]

See Also

Archive Class
Sitecore.Data.Archiving Namespace


GetEntries Method

[image] [image]

Sitecore 6.4.1 API
Archive..::..GetEntries Method
Archive Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetEntries(Int32, Int32) | Gets a list of entries.
Public method | GetEntries(ArchiveQuery, Int32, Int32) | Gets a list of entries.

See Also

Archive Class
Archive Members
Sitecore.Data.Archiving Namespace


GetEntries Method (Int32, Int32)

[image]

Sitecore 6.4.1 API
Archive..::..GetEntries Method (Int32, Int32)
Archive Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual IEnumerable<ArchiveEntry> GetEntries(
    int pageIndex,
    int pageSize
)
Visual Basic
Public Overridable Function GetEntries ( _
    pageIndex As Integer, _
    pageSize As Integer _
) As IEnumerable(Of ArchiveEntry)
Visual C++
public:
virtual IEnumerable<ArchiveEntry^>^ GetEntries(
    int pageIndex,
    int pageSize
)

Parameters

pageIndex
Type: System..::..Int32
Index of the page.
pageSize
Type: System..::..Int32
Size of the page.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Archiving.Archive.GetEntries(System.Int32,System.Int32)"]

See Also

Archive Class
GetEntries Overload
Sitecore.Data.Archiving Namespace


GetEntries Method (ArchiveQuery, Int32, Int32)

[image]

Sitecore 6.4.1 API
Archive..::..GetEntries Method (ArchiveQuery, Int32, Int32)
Archive Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract IEnumerable<ArchiveEntry> GetEntries(
    ArchiveQuery query,
    int pageIndex,
    int pageSize
)
Visual Basic
Public MustOverride Function GetEntries ( _
    query As ArchiveQuery, _
    pageIndex As Integer, _
    pageSize As Integer _
) As IEnumerable(Of ArchiveEntry)
Visual C++
public:
virtual IEnumerable<ArchiveEntry^>^ GetEntries(
    ArchiveQuery^ query,
    int pageIndex,
    int pageSize
) abstract

Parameters

query
Type: Sitecore.Data.Archiving..::..ArchiveQuery
The query.
pageIndex
Type: System..::..Int32
Index of the page.
pageSize
Type: System..::..Int32
Size of the page.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Archiving.Archive.GetEntries(Sitecore.Data.Archiving.ArchiveQuery,System.Int32,System.Int32)"]

See Also

Archive Class
GetEntries Overload
Sitecore.Data.Archiving Namespace


GetEntriesForUser Method

[image]

Sitecore 6.4.1 API
Archive..::..GetEntriesForUser Method
Archive Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual IEnumerable<ArchiveEntry> GetEntriesForUser(
    User user,
    int pageIndex,
    int pageSize
)
Visual Basic
Public Overridable Function GetEntriesForUser ( _
    user As User, _
    pageIndex As Integer, _
    pageSize As Integer _
) As IEnumerable(Of ArchiveEntry)
Visual C++
public:
virtual IEnumerable<ArchiveEntry^>^ GetEntriesForUser(
    User^ user,
    int pageIndex,
    int pageSize
)

Parameters

user
Type: Sitecore.Security.Accounts..::..User
The user.
pageIndex
Type: System..::..Int32
Index of the page.
pageSize
Type: System..::..Int32
Size of the page.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Archiving.Archive.GetEntriesForUser(Sitecore.Security.Accounts.User,System.Int32,System.Int32)"]

Remarks

If the current user is an administrator, all entries are returned.

See Also

Archive Class
Sitecore.Data.Archiving Namespace


GetEntryCount Method

[image] [image]

Sitecore 6.4.1 API
Archive..::..GetEntryCount Method
Archive Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetEntryCount()()()() | Gets the number of entries currently in the archive.
Public method | GetEntryCount(ArchiveQuery) | Gets the number of entries currently in the archive.

See Also

Archive Class
Archive Members
Sitecore.Data.Archiving Namespace


GetEntryCount Method

[image]

Sitecore 6.4.1 API
Archive..::..GetEntryCount Method
Archive Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual int GetEntryCount()
Visual Basic
Public Overridable Function GetEntryCount As Integer
Visual C++
public:
virtual int GetEntryCount()

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Archiving.Archive.GetEntryCount"]

See Also

Archive Class
GetEntryCount Overload
Sitecore.Data.Archiving Namespace


GetEntryCount Method (ArchiveQuery)

[image]

Sitecore 6.4.1 API
Archive..::..GetEntryCount Method (ArchiveQuery)
Archive Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract int GetEntryCount(
    ArchiveQuery query
)
Visual Basic
Public MustOverride Function GetEntryCount ( _
    query As ArchiveQuery _
) As Integer
Visual C++
public:
virtual int GetEntryCount(
    ArchiveQuery^ query
) abstract

Parameters

query
Type: Sitecore.Data.Archiving..::..ArchiveQuery

[Missing <param name="query"/> documentation for "M:Sitecore.Data.Archiving.Archive.GetEntryCount(Sitecore.Data.Archiving.ArchiveQuery)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Archiving.Archive.GetEntryCount(Sitecore.Data.Archiving.ArchiveQuery)"]

See Also

Archive Class
GetEntryCount Overload
Sitecore.Data.Archiving Namespace


GetEntryCountForUser Method

[image]

Sitecore 6.4.1 API
Archive..::..GetEntryCountForUser Method
Archive Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int GetEntryCountForUser(
    User user
)
Visual Basic
Public Function GetEntryCountForUser ( _
    user As User _
) As Integer
Visual C++
public:
int GetEntryCountForUser(
    User^ user
)

Parameters

user
Type: Sitecore.Security.Accounts..::..User

[Missing <param name="user"/> documentation for "M:Sitecore.Data.Archiving.Archive.GetEntryCountForUser(Sitecore.Security.Accounts.User)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Archiving.Archive.GetEntryCountForUser(Sitecore.Security.Accounts.User)"]

See Also

Archive Class
Sitecore.Data.Archiving Namespace


NotifyItemDeleted Method

[image]

Sitecore 6.4.1 API
Archive..::..NotifyItemDeleted Method
Archive Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void NotifyItemDeleted(
    Item item,
    ID parentId
)
Visual Basic
Protected Overridable Sub NotifyItemDeleted ( _
    item As Item, _
    parentId As ID _
)
Visual C++
protected:
virtual void NotifyItemDeleted(
    Item^ item,
    ID^ parentId
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
parentId
Type: Sitecore.Data..::..ID
The parent id.

See Also

Archive Class
Sitecore.Data.Archiving Namespace


NotifyItemDeleting Method

[image]

Sitecore 6.4.1 API
Archive..::..NotifyItemDeleting Method
Archive Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void NotifyItemDeleting(
    Item item,
    out bool canceled
)
Visual Basic
Protected Overridable Sub NotifyItemDeleting ( _
    item As Item, _
    <OutAttribute> ByRef canceled As Boolean _
)
Visual C++
protected:
virtual void NotifyItemDeleting(
    Item^ item,
    [OutAttribute] bool% canceled
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
canceled
Type: System..::..Boolean %
if set to true this event is canceled.

See Also

Archive Class
Sitecore.Data.Archiving Namespace


RemoveEntries Method

[image] [image]

Sitecore 6.4.1 API
Archive..::..RemoveEntries Method
Archive Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveEntries()()()() | Removes all entries from the archive.
Public method | RemoveEntries(ArchiveQuery) | Removes all entries from the archive.

See Also

Archive Class
Archive Members
Sitecore.Data.Archiving Namespace


RemoveEntries Method

[image]

Sitecore 6.4.1 API
Archive..::..RemoveEntries Method
Archive Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void RemoveEntries()
Visual Basic
Public Overridable Sub RemoveEntries
Visual C++
public:
virtual void RemoveEntries()

See Also

Archive Class
RemoveEntries Overload
Sitecore.Data.Archiving Namespace


RemoveEntries Method (ArchiveQuery)

[image]

Sitecore 6.4.1 API
Archive..::..RemoveEntries Method (ArchiveQuery)
Archive Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract void RemoveEntries(
    ArchiveQuery query
)
Visual Basic
Public MustOverride Sub RemoveEntries ( _
    query As ArchiveQuery _
)
Visual C++
public:
virtual void RemoveEntries(
    ArchiveQuery^ query
) abstract

Parameters

query
Type: Sitecore.Data.Archiving..::..ArchiveQuery

[Missing <param name="query"/> documentation for "M:Sitecore.Data.Archiving.Archive.RemoveEntries(Sitecore.Data.Archiving.ArchiveQuery)"]

See Also

Archive Class
RemoveEntries Overload
Sitecore.Data.Archiving Namespace


RestoreItem Method

[image]

Sitecore 6.4.1 API
Archive..::..RestoreItem Method
Archive Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract bool RestoreItem(
    Guid archivalId
)
Visual Basic
Public MustOverride Function RestoreItem ( _
    archivalId As Guid _
) As Boolean
Visual C++
public:
virtual bool RestoreItem(
    Guid archivalId
) abstract

Parameters

archivalId
Type: System..::..Guid
The archival id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Archiving.Archive.RestoreItem(System.Guid)"]

See Also

Archive Class
Sitecore.Data.Archiving Namespace


Archive Properties

[image] [image]

Sitecore 6.4.1 API
Archive Properties
Archive Class See Also Send Feedback

The Archive type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the name of the archive.

See Also

Archive Class
Sitecore.Data.Archiving Namespace


Name Property

[image]

Sitecore 6.4.1 API
Archive..::..Name Property
Archive Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

Archive Class
Sitecore.Data.Archiving Namespace


ArchiveEntry Class

[image]

Sitecore 6.4.1 API
ArchiveEntry Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ArchiveEntry
Visual Basic
Public Class ArchiveEntry
Visual C++
public ref class ArchiveEntry

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Archiving..::..ArchiveEntry

See Also

ArchiveEntry Members
Sitecore.Data.Archiving Namespace


ArchiveEntry Members

[image] [image]

Sitecore 6.4.1 API
ArchiveEntry Members
ArchiveEntry Class Constructors Methods Properties See Also Send Feedback

The ArchiveEntry type exposes the following members.

Constructors

 | Name | Description
Public method | ArchiveEntry | Initializes a new instance of the ArchiveEntry class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ArchivalId | Gets the archival id.
Public property | ArchiveDate | Gets the archive date in UTC time.
Public property | ArchivedBy | Gets the archived by.
Public property | ArchiveLocalDate | Gets the archive local date in local time.
Public property | ArchiveName | Gets the name of the archive.
Public property | Database | Gets the database.
Public property | ItemId | Gets the item id.
Public property | Name | Gets the name.
Public property | OriginalLocation | Gets the original location.
Public property | ParentId | Gets the parent id.

See Also

ArchiveEntry Class
Sitecore.Data.Archiving Namespace


ArchiveEntry Constructor

[image]

Sitecore 6.4.1 API
ArchiveEntry Constructor
ArchiveEntry Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ArchiveEntry(
    Guid archivalId,
    ID itemId,
    ID parentId,
    string name,
    string originalLocation,
    DateTime archiveDate,
    string archivedBy,
    string archiveName,
    Database database
)
Visual Basic
Public Sub New ( _
    archivalId As Guid, _
    itemId As ID, _
    parentId As ID, _
    name As String, _
    originalLocation As String, _
    archiveDate As DateTime, _
    archivedBy As String, _
    archiveName As String, _
    database As Database _
)
Visual C++
public:
ArchiveEntry(
    Guid archivalId,
    ID^ itemId,
    ID^ parentId,
    String^ name,
    String^ originalLocation,
    DateTime archiveDate,
    String^ archivedBy,
    String^ archiveName,
    Database^ database
)

Parameters

archivalId
Type: System..::..Guid
The archival id.
itemId
Type: Sitecore.Data..::..ID
The item id.
parentId
Type: Sitecore.Data..::..ID
The parent id.
name
Type: System..::..String
The name.
originalLocation
Type: System..::..String
The original location.
archiveDate
Type: System..::..DateTime
The archive date.
archivedBy
Type: System..::..String
The archived by.
archiveName
Type: System..::..String
Name of the archive.
database
Type: Sitecore.Data..::..Database
The database.

See Also

ArchiveEntry Class
Sitecore.Data.Archiving Namespace


ArchiveEntry Methods

[image] [image]

Sitecore 6.4.1 API
ArchiveEntry Methods
ArchiveEntry Class See Also Send Feedback

The ArchiveEntry type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ArchiveEntry Class
Sitecore.Data.Archiving Namespace


ArchivalId Property

[image]

Sitecore 6.4.1 API
ArchiveEntry..::..ArchivalId Property
ArchiveEntry Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Guid ArchivalId { get; }
Visual Basic
Public ReadOnly Property ArchivalId As Guid
    Get
Visual C++
public:
property Guid ArchivalId {
    Guid get ();
}

Field Value

The archival id.

See Also

ArchiveEntry Class
Sitecore.Data.Archiving Namespace


ArchiveDate Property

[image]

Sitecore 6.4.1 API
ArchiveEntry..::..ArchiveDate Property
ArchiveEntry Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime ArchiveDate { get; }
Visual Basic
Public ReadOnly Property ArchiveDate As DateTime
    Get
Visual C++
public:
property DateTime ArchiveDate {
    DateTime get ();
}

Field Value

The archive date.

See Also

ArchiveEntry Class
Sitecore.Data.Archiving Namespace


ArchivedBy Property

[image]

Sitecore 6.4.1 API
ArchiveEntry..::..ArchivedBy Property
ArchiveEntry Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ArchivedBy { get; }
Visual Basic
Public ReadOnly Property ArchivedBy As String
    Get
Visual C++
public:
property String^ ArchivedBy {
    String^ get ();
}

Field Value

The archived by.

See Also

ArchiveEntry Class
Sitecore.Data.Archiving Namespace


ArchiveLocalDate Property

[image]

Sitecore 6.4.1 API
ArchiveEntry..::..ArchiveLocalDate Property
ArchiveEntry Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime ArchiveLocalDate { get; }
Visual Basic
Public ReadOnly Property ArchiveLocalDate As DateTime
    Get
Visual C++
public:
property DateTime ArchiveLocalDate {
    DateTime get ();
}

Field Value

The archive local date.

See Also

ArchiveEntry Class
Sitecore.Data.Archiving Namespace


ArchiveName Property

[image]

Sitecore 6.4.1 API
ArchiveEntry..::..ArchiveName Property
ArchiveEntry Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ArchiveName { get; }
Visual Basic
Public ReadOnly Property ArchiveName As String
    Get
Visual C++
public:
property String^ ArchiveName {
    String^ get ();
}

Field Value

The name of the archive.

See Also

ArchiveEntry Class
Sitecore.Data.Archiving Namespace


ItemId Property

[image]

Sitecore 6.4.1 API
ArchiveEntry..::..ItemId Property
ArchiveEntry Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ItemId { get; }
Visual Basic
Public ReadOnly Property ItemId As ID
    Get
Visual C++
public:
property ID^ ItemId {
    ID^ get ();
}

Field Value

The item id.

See Also

ArchiveEntry Class
Sitecore.Data.Archiving Namespace


Name Property

[image]

Sitecore 6.4.1 API
ArchiveEntry..::..Name Property
ArchiveEntry Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

ArchiveEntry Class
Sitecore.Data.Archiving Namespace


OriginalLocation Property

[image]

Sitecore 6.4.1 API
ArchiveEntry..::..OriginalLocation Property
ArchiveEntry Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string OriginalLocation { get; }
Visual Basic
Public ReadOnly Property OriginalLocation As String
    Get
Visual C++
public:
property String^ OriginalLocation {
    String^ get ();
}

Field Value

The original location.

See Also

ArchiveEntry Class
Sitecore.Data.Archiving Namespace


ArchiveEntryList Members

[image] [image]

Sitecore 6.4.1 API
ArchiveEntryList Members
ArchiveEntryList Class Constructors Methods Properties See Also Send Feedback

The ArchiveEntryList type exposes the following members.

Constructors

 | Name | Description
Public method | ArchiveEntryList()()()() | Initializes a new instance of the ArchiveEntryList class.
Public method | ArchiveEntryList(IEnumerable<(Of <<'(ArchiveEntry>)>>)) | Initializes a new instance of the ArchiveEntryList class.

Methods

 | Name | Description
Public method | Contains | Determines whether the list contains the specified element. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToArray | Converts the list to an array. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of entries in the list. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public property | Item | Gets the element at the specified index. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)

See Also

ArchiveEntryList Class
Sitecore.Data.Archiving Namespace


ArchiveEntryList Constructor

[image] [image]

Sitecore 6.4.1 API
ArchiveEntryList Constructor
ArchiveEntryList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ArchiveEntryList()()()() | Initializes a new instance of the ArchiveEntryList class.
Public method | ArchiveEntryList(IEnumerable<(Of <<'(ArchiveEntry>)>>)) | Initializes a new instance of the ArchiveEntryList class.

See Also

ArchiveEntryList Class
ArchiveEntryList Members
Sitecore.Data.Archiving Namespace


ArchiveEntryList Constructor

[image]

Sitecore 6.4.1 API
ArchiveEntryList Constructor
ArchiveEntryList Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ArchiveEntryList()
Visual Basic
Public Sub New
Visual C++
public:
ArchiveEntryList()

See Also

ArchiveEntryList Class
ArchiveEntryList Overload
Sitecore.Data.Archiving Namespace


ArchiveEntryList Constructor (IEnumerable(ArchiveEntry))

[image]

Sitecore 6.4.1 API
ArchiveEntryList Constructor (IEnumerable<(Of <(<'ArchiveEntry>)>)>)
ArchiveEntryList Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ArchiveEntryList(
    IEnumerable<ArchiveEntry> entries
)
Visual Basic
Public Sub New ( _
    entries As IEnumerable(Of ArchiveEntry) _
)
Visual C++
public:
ArchiveEntryList(
    IEnumerable<ArchiveEntry^>^ entries
)

Parameters

entries
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' ArchiveEntry >)>)>
The entries.

See Also

ArchiveEntryList Class
ArchiveEntryList Overload
Sitecore.Data.Archiving Namespace


ArchiveEntryList Methods

[image] [image]

Sitecore 6.4.1 API
ArchiveEntryList Methods
ArchiveEntryList Class See Also Send Feedback

The ArchiveEntryList type exposes the following members.

Methods

 | Name | Description
Public method | Contains | Determines whether the list contains the specified element. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToArray | Converts the list to an array. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ArchiveEntryList Class
Sitecore.Data.Archiving Namespace


ArchiveEntryList Properties

[image] [image]

Sitecore 6.4.1 API
ArchiveEntryList Properties
ArchiveEntryList Class See Also Send Feedback

The ArchiveEntryList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of entries in the list. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public property | Item | Gets the element at the specified index. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)

See Also

ArchiveEntryList Class
Sitecore.Data.Archiving Namespace


ArchiveItemCompletedEvent Class

[image]

Sitecore 6.4.1 API
ArchiveItemCompletedEvent Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ArchiveItemCompletedEvent
Visual Basic
Public Class ArchiveItemCompletedEvent
Visual C++
public ref class ArchiveItemCompletedEvent

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Archiving..::..ArchiveItemCompletedEvent

See Also

ArchiveItemCompletedEvent Members
Sitecore.Data.Archiving Namespace


ArchiveItemCompletedEvent Members

[image] [image]

Sitecore 6.4.1 API
ArchiveItemCompletedEvent Members
ArchiveItemCompletedEvent Class Constructors Methods See Also Send Feedback

The ArchiveItemCompletedEvent type exposes the following members.

Constructors

 | Name | Description
Public method | ArchiveItemCompletedEvent | Initializes a new instance of the ArchiveItemCompletedEvent class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ArchiveItemCompletedEvent Class
Sitecore.Data.Archiving Namespace


ArchiveItemCompletedEvent Constructor

[image]

Sitecore 6.4.1 API
ArchiveItemCompletedEvent Constructor
ArchiveItemCompletedEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ArchiveItemCompletedEvent()
Visual Basic
Public Sub New
Visual C++
public:
ArchiveItemCompletedEvent()

See Also

ArchiveItemCompletedEvent Class
Sitecore.Data.Archiving Namespace


ArchiveItemCompletedEvent Methods

[image] [image]

Sitecore 6.4.1 API
ArchiveItemCompletedEvent Methods
ArchiveItemCompletedEvent Class See Also Send Feedback

The ArchiveItemCompletedEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ArchiveItemCompletedEvent Class
Sitecore.Data.Archiving Namespace


ArchiveManager Class

[image]

Sitecore 6.4.1 API
ArchiveManager Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class ArchiveManager
Visual Basic
Public NotInheritable Class ArchiveManager
Visual C++
public ref class ArchiveManager abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Archiving..::..ArchiveManager

See Also

ArchiveManager Members
Sitecore.Data.Archiving Namespace


ArchiveManager Members

[image] [image]

Sitecore 6.4.1 API
ArchiveManager Members
ArchiveManager Class Methods Properties See Also Send Feedback

The ArchiveManager type exposes the following members.

Methods

Name | Description
GetArchive | Gets an archive by name from the specifoed database.
GetArchiveCount | Gets the archive count for the specified database.
GetArchives | Gets all the archives of the specified database.

Properties

Name | Description
Provider | Gets the provider.
Providers | Gets all providers.

See Also

ArchiveManager Class
Sitecore.Data.Archiving Namespace


ArchiveManager Methods

[image] [image]

Sitecore 6.4.1 API
ArchiveManager Methods
ArchiveManager Class See Also Send Feedback

The ArchiveManager type exposes the following members.

Methods

Name | Description
GetArchive | Gets an archive by name from the specifoed database.
GetArchiveCount | Gets the archive count for the specified database.
GetArchives | Gets all the archives of the specified database.

See Also

ArchiveManager Class
Sitecore.Data.Archiving Namespace


GetArchive Method

[image]

Sitecore 6.4.1 API
ArchiveManager..::..GetArchive Method
ArchiveManager Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Archive GetArchive(
    string archiveName,
    Database database
)
Visual Basic
Public Shared Function GetArchive ( _
    archiveName As String, _
    database As Database _
) As Archive
Visual C++
public:
static Archive^ GetArchive(
    String^ archiveName,
    Database^ database
)

Parameters

archiveName
Type: System..::..String
Name of the archive.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Archiving.ArchiveManager.GetArchive(System.String,Sitecore.Data.Database)"]

See Also

ArchiveManager Class
Sitecore.Data.Archiving Namespace


GetArchiveCount Method

[image]

Sitecore 6.4.1 API
ArchiveManager..::..GetArchiveCount Method
ArchiveManager Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int GetArchiveCount(
    Database database
)
Visual Basic
Public Shared Function GetArchiveCount ( _
    database As Database _
) As Integer
Visual C++
public:
static int GetArchiveCount(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Archiving.ArchiveManager.GetArchiveCount(Sitecore.Data.Database)"]

See Also

ArchiveManager Class
Sitecore.Data.Archiving Namespace


GetArchives Method

[image]

Sitecore 6.4.1 API
ArchiveManager..::..GetArchives Method
ArchiveManager Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static List<Archive> GetArchives(
    Database database
)
Visual Basic
Public Shared Function GetArchives ( _
    database As Database _
) As List(Of Archive)
Visual C++
public:
static List<Archive^>^ GetArchives(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Archiving.ArchiveManager.GetArchives(Sitecore.Data.Database)"]

See Also

ArchiveManager Class
Sitecore.Data.Archiving Namespace


ArchiveManager Properties

[image] [image]

Sitecore 6.4.1 API
ArchiveManager Properties
ArchiveManager Class See Also Send Feedback

The ArchiveManager type exposes the following members.

Properties

Name | Description
Provider | Gets the provider.
Providers | Gets all providers.

See Also

ArchiveManager Class
Sitecore.Data.Archiving Namespace


Provider Property

[image]

Sitecore 6.4.1 API
ArchiveManager..::..Provider Property
ArchiveManager Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ArchiveProvider Provider { get; }
Visual Basic
Public Shared ReadOnly Property Provider As ArchiveProvider
    Get
Visual C++
public:
static property ArchiveProvider^ Provider {
    ArchiveProvider^ get ();
}

Field Value

The provider.

See Also

ArchiveManager Class
Sitecore.Data.Archiving Namespace


Providers Property

[image]

Sitecore 6.4.1 API
ArchiveManager..::..Providers Property
ArchiveManager Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ArchiveProviderCollection Providers { get; }
Visual Basic
Public Shared ReadOnly Property Providers As ArchiveProviderCollection
    Get
Visual C++
public:
static property ArchiveProviderCollection^ Providers {
    ArchiveProviderCollection^ get ();
}

Field Value

The providers.

See Also

ArchiveManager Class
Sitecore.Data.Archiving Namespace


ArchiveProvider Class

[image]

Sitecore 6.4.1 API
ArchiveProvider Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class ArchiveProvider : ProviderBase
Visual Basic
Public MustInherit Class ArchiveProvider _
    Inherits ProviderBase
Visual C++
public ref class ArchiveProvider abstract : public ProviderBase

Inheritance Hierarchy

System..::..Object
System.Configuration.Provider..::..ProviderBase
Sitecore.Data.Archiving..::..ArchiveProvider
Sitecore.Data.Archiving..::..SqlArchiveProvider
Sitecore.Data.Archiving..::..SwitchingArchiveProvider

See Also

ArchiveProvider Members
Sitecore.Data.Archiving Namespace


ArchiveProvider Members

[image] [image]

Sitecore 6.4.1 API
ArchiveProvider Members
ArchiveProvider Class Constructors Methods Properties See Also Send Feedback

The ArchiveProvider type exposes the following members.

Constructors

 | Name | Description
Protected method | ArchiveProvider | Initializes a new instance of the ArchiveProvider class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetArchive | Gets an archive by name from the specifoed database.
Public method | GetArchiveCount | Gets the archive count for the specified database.
Public method | GetArchives | Gets all the archives of the specified database.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the provider. (Overrides ProviderBase..::..Initialize(String, NameValueCollection).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | MatchDatabaseNames | Gets the match databases.
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

ArchiveProvider Class
Sitecore.Data.Archiving Namespace


ArchiveProvider Constructor

[image]

Sitecore 6.4.1 API
ArchiveProvider Constructor
ArchiveProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected ArchiveProvider()
Visual Basic
Protected Sub New
Visual C++
protected:
ArchiveProvider()

See Also

ArchiveProvider Class
Sitecore.Data.Archiving Namespace


ArchiveProvider Methods

[image] [image]

Sitecore 6.4.1 API
ArchiveProvider Methods
ArchiveProvider Class See Also Send Feedback

The ArchiveProvider type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetArchive | Gets an archive by name from the specifoed database.
Public method | GetArchiveCount | Gets the archive count for the specified database.
Public method | GetArchives | Gets all the archives of the specified database.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the provider. (Overrides ProviderBase..::..Initialize(String, NameValueCollection).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ArchiveProvider Class
Sitecore.Data.Archiving Namespace


GetArchive Method

[image]

Sitecore 6.4.1 API
ArchiveProvider..::..GetArchive Method
ArchiveProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract Archive GetArchive(
    string archiveName,
    Database database
)
Visual Basic
Public MustOverride Function GetArchive ( _
    archiveName As String, _
    database As Database _
) As Archive
Visual C++
public:
virtual Archive^ GetArchive(
    String^ archiveName,
    Database^ database
) abstract

Parameters

archiveName
Type: System..::..String
Name of the archive.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Archiving.ArchiveProvider.GetArchive(System.String,Sitecore.Data.Database)"]

See Also

ArchiveProvider Class
Sitecore.Data.Archiving Namespace


GetArchiveCount Method

[image]

Sitecore 6.4.1 API
ArchiveProvider..::..GetArchiveCount Method
ArchiveProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract int GetArchiveCount(
    Database database
)
Visual Basic
Public MustOverride Function GetArchiveCount ( _
    database As Database _
) As Integer
Visual C++
public:
virtual int GetArchiveCount(
    Database^ database
) abstract

Parameters

database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Archiving.ArchiveProvider.GetArchiveCount(Sitecore.Data.Database)"]

See Also

ArchiveProvider Class
Sitecore.Data.Archiving Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
ArchiveProvider..::..Initialize Method
ArchiveProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Initialize(
    string name,
    NameValueCollection config
)
Visual Basic
Public Overrides Sub Initialize ( _
    name As String, _
    config As NameValueCollection _
)
Visual C++
public:
virtual void Initialize(
    String^ name,
    NameValueCollection^ config
) override

Parameters

name
Type: System..::..String
The friendly name of the provider.
config
Type: System.Collections.Specialized..::..NameValueCollection
A collection of the name/value pairs representing the provider-specific attributes specified in the configuration for this provider.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The name of the provider is null.
System..::..ArgumentException | The name of the provider has a length of zero.
System..::..InvalidOperationException | An attempt is made to call Initialize(String, NameValueCollection) on a provider after the provider has already been initialized.

See Also

ArchiveProvider Class
Sitecore.Data.Archiving Namespace


ArchiveProvider Properties

[image] [image]

Sitecore 6.4.1 API
ArchiveProvider Properties
ArchiveProvider Class See Also Send Feedback

The ArchiveProvider type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | MatchDatabaseNames | Gets the match databases.
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

ArchiveProvider Class
Sitecore.Data.Archiving Namespace


MatchDatabaseNames Property

[image]

Sitecore 6.4.1 API
ArchiveProvider..::..MatchDatabaseNames Property
ArchiveProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual List<string> MatchDatabaseNames { get; }
Visual Basic
Public Overridable ReadOnly Property MatchDatabaseNames As List(Of String)
    Get
Visual C++
public:
virtual property List<String^>^ MatchDatabaseNames {
    List<String^>^ get ();
}

Field Value

The match databases.

See Also

ArchiveProvider Class
Sitecore.Data.Archiving Namespace


ArchiveProviderCollection Class

[image]

Sitecore 6.4.1 API
ArchiveProviderCollection Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ArchiveProviderCollection : ProviderCollection
Visual Basic
Public Class ArchiveProviderCollection _
    Inherits ProviderCollection
Visual C++
public ref class ArchiveProviderCollection : public ProviderCollection

Inheritance Hierarchy

System..::..Object
System.Configuration.Provider..::..ProviderCollection
Sitecore.Data.Archiving..::..ArchiveProviderCollection

See Also

ArchiveProviderCollection Members
Sitecore.Data.Archiving Namespace


ArchiveProviderCollection Members

[image] [image]

Sitecore 6.4.1 API
ArchiveProviderCollection Members
ArchiveProviderCollection Class Constructors Methods Properties See Also Send Feedback

The ArchiveProviderCollection type exposes the following members.

Constructors

 | Name | Description
Public method | ArchiveProviderCollection | Initializes a new instance of the ArchiveProviderCollection class

Methods

 | Name | Description
Public method | Add | Adds a provider to the collection. (Inherited from ProviderCollection.)
Public method | Clear | Removes all items from the collection. (Inherited from ProviderCollection.)
Public method | CopyTo | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a provider from the collection. (Inherited from ProviderCollection.)
Public method | SetReadOnly | Sets the collection to be read-only. (Inherited from ProviderCollection.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
Public property | Item | Gets the ArchiveProvider with the specified name.
Public property | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)

See Also

ArchiveProviderCollection Class
Sitecore.Data.Archiving Namespace


ArchiveProviderCollection Constructor

[image]

Sitecore 6.4.1 API
ArchiveProviderCollection Constructor
ArchiveProviderCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ArchiveProviderCollection()
Visual Basic
Public Sub New
Visual C++
public:
ArchiveProviderCollection()

See Also

ArchiveProviderCollection Class
Sitecore.Data.Archiving Namespace


ArchiveProviderCollection Methods

[image] [image]

Sitecore 6.4.1 API
ArchiveProviderCollection Methods
ArchiveProviderCollection Class See Also Send Feedback

The ArchiveProviderCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds a provider to the collection. (Inherited from ProviderCollection.)
Public method | Clear | Removes all items from the collection. (Inherited from ProviderCollection.)
Public method | CopyTo | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a provider from the collection. (Inherited from ProviderCollection.)
Public method | SetReadOnly | Sets the collection to be read-only. (Inherited from ProviderCollection.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ArchiveProviderCollection Class
Sitecore.Data.Archiving Namespace


ArchiveProviderCollection Properties

[image] [image]

Sitecore 6.4.1 API
ArchiveProviderCollection Properties
ArchiveProviderCollection Class See Also Send Feedback

The ArchiveProviderCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
Public property | Item | Gets the ArchiveProvider with the specified name.
Public property | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)

See Also

ArchiveProviderCollection Class
Sitecore.Data.Archiving Namespace


Item Property

[image]

Sitecore 6.4.1 API
ArchiveProviderCollection..::..Item Property
ArchiveProviderCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ArchiveProvider this[
    string name
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    name As String _
) As ArchiveProvider
    Get
Visual C++
public:
property ArchiveProvider^ default[String^ name] {
    ArchiveProvider^ get (String^ name);
}

Parameters

name
Type: System..::..String

Field Value

See Also

ArchiveProviderCollection Class
Sitecore.Data.Archiving Namespace


ArchiveQuery Class

[image]

Sitecore 6.4.1 API
ArchiveQuery Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ArchiveQuery
Visual Basic
Public Class ArchiveQuery
Visual C++
public ref class ArchiveQuery

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Archiving..::..ArchiveQuery

See Also

ArchiveQuery Members
Sitecore.Data.Archiving Namespace


ArchiveQuery Members

[image] [image]

Sitecore 6.4.1 API
ArchiveQuery Members
ArchiveQuery Class Constructors Methods Properties See Also Send Feedback

The ArchiveQuery type exposes the following members.

Constructors

 | Name | Description
Public method | ArchiveQuery | Initializes a new instance of the ArchiveQuery class

Methods

 | Name | Description
Public method | AddOrdering | Adds an ordering.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ArchivalId | Gets or sets the archival id.
Public property | ArchiveDateBegin | Gets or sets the archive date begin.
Public property | ArchiveDateEnd | Gets or sets the archive date end.
Public property | ArchivedBy | Gets or sets the archived by start.
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | ItemId | Gets or sets the item id.
Public property | Name | Gets or sets the name.
Public property | Orderings | Gets the orderings.
Public property | OriginalLocation | Gets or sets the original location.
Public property | ParentId | Gets or sets the parent id.

See Also

ArchiveQuery Class
Sitecore.Data.Archiving Namespace


ArchiveQuery Constructor

[image]

Sitecore 6.4.1 API
ArchiveQuery Constructor
ArchiveQuery Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ArchiveQuery()
Visual Basic
Public Sub New
Visual C++
public:
ArchiveQuery()

See Also

ArchiveQuery Class
Sitecore.Data.Archiving Namespace


AddOrdering Method

[image]

Sitecore 6.4.1 API
ArchiveQuery..::..AddOrdering Method
ArchiveQuery Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddOrdering(
    ArchiveQuery..::..ArchiveField field,
    ArchiveQuery..::..OrderDirection orderDirection
)
Visual Basic
Public Sub AddOrdering ( _
    field As ArchiveQuery..::..ArchiveField, _
    orderDirection As ArchiveQuery..::..OrderDirection _
)
Visual C++
public:
void AddOrdering(
    ArchiveQuery..::..ArchiveField field,
    ArchiveQuery..::..OrderDirection orderDirection
)

Parameters

field
Type: Sitecore.Data.Archiving..::..ArchiveQuery..::..ArchiveField
The field.
orderDirection
Type: Sitecore.Data.Archiving..::..ArchiveQuery..::..OrderDirection
The order direction.

See Also

ArchiveQuery Class
Sitecore.Data.Archiving Namespace


ArchiveQuery Properties

[image] [image]

Sitecore 6.4.1 API
ArchiveQuery Properties
ArchiveQuery Class See Also Send Feedback

The ArchiveQuery type exposes the following members.

Properties

 | Name | Description
Public property | ArchivalId | Gets or sets the archival id.
Public property | ArchiveDateBegin | Gets or sets the archive date begin.
Public property | ArchiveDateEnd | Gets or sets the archive date end.
Public property | ArchivedBy | Gets or sets the archived by start.
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | ItemId | Gets or sets the item id.
Public property | Name | Gets or sets the name.
Public property | Orderings | Gets the orderings.
Public property | OriginalLocation | Gets or sets the original location.
Public property | ParentId | Gets or sets the parent id.

See Also

ArchiveQuery Class
Sitecore.Data.Archiving Namespace


ArchivalId Property

[image]

Sitecore 6.4.1 API
ArchiveQuery..::..ArchivalId Property
ArchiveQuery Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Guid ArchivalId { get; set; }
Visual Basic
Public Property ArchivalId As Guid
    Get
    Set
Visual C++
public:
property Guid ArchivalId {
    Guid get ();
    void set (Guid value);
}

Field Value

The archival id.

See Also

ArchiveQuery Class
Sitecore.Data.Archiving Namespace


ArchiveDateBegin Property

[image]

Sitecore 6.4.1 API
ArchiveQuery..::..ArchiveDateBegin Property
ArchiveQuery Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime ArchiveDateBegin { get; set; }
Visual Basic
Public Property ArchiveDateBegin As DateTime
    Get
    Set
Visual C++
public:
property DateTime ArchiveDateBegin {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The archive date begin.

See Also

ArchiveQuery Class
Sitecore.Data.Archiving Namespace


ArchiveDateEnd Property

[image]

Sitecore 6.4.1 API
ArchiveQuery..::..ArchiveDateEnd Property
ArchiveQuery Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime ArchiveDateEnd { get; set; }
Visual Basic
Public Property ArchiveDateEnd As DateTime
    Get
    Set
Visual C++
public:
property DateTime ArchiveDateEnd {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The archive date end.

See Also

ArchiveQuery Class
Sitecore.Data.Archiving Namespace


ArchivedBy Property

[image]

Sitecore 6.4.1 API
ArchiveQuery..::..ArchivedBy Property
ArchiveQuery Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ArchivedBy { get; set; }
Visual Basic
Public Property ArchivedBy As String
    Get
    Set
Visual C++
public:
property String^ ArchivedBy {
    String^ get ();
    void set (String^ value);
}

Field Value

The archived by start.

See Also

ArchiveQuery Class
Sitecore.Data.Archiving Namespace


IsEmpty Property

[image]

Sitecore 6.4.1 API
ArchiveQuery..::..IsEmpty Property
ArchiveQuery Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
property bool IsEmpty {
    bool get ();
}

Field Value

true if this instance is empty; otherwise, false.

See Also

ArchiveQuery Class
Sitecore.Data.Archiving Namespace


ItemId Property

[image]

Sitecore 6.4.1 API
ArchiveQuery..::..ItemId Property
ArchiveQuery Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ItemId { get; set; }
Visual Basic
Public Property ItemId As ID
    Get
    Set
Visual C++
public:
property ID^ ItemId {
    ID^ get ();
    void set (ID^ value);
}

Field Value

The item id.

See Also

ArchiveQuery Class
Sitecore.Data.Archiving Namespace


Name Property

[image]

Sitecore 6.4.1 API
ArchiveQuery..::..Name Property
ArchiveQuery Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Field Value

The name.

See Also

ArchiveQuery Class
Sitecore.Data.Archiving Namespace


Orderings Property

[image]

Sitecore 6.4.1 API
ArchiveQuery..::..Orderings Property
ArchiveQuery Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public List<ArchiveQuery..::..Ordering> Orderings { get; }
Visual Basic
Public ReadOnly Property Orderings As List(Of ArchiveQuery..::..Ordering)
    Get
Visual C++
public:
property List<ArchiveQuery..::..Ordering^>^ Orderings {
    List<ArchiveQuery..::..Ordering^>^ get ();
}

Field Value

The orderings.

See Also

ArchiveQuery Class
Sitecore.Data.Archiving Namespace


OriginalLocation Property

[image]

Sitecore 6.4.1 API
ArchiveQuery..::..OriginalLocation Property
ArchiveQuery Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string OriginalLocation { get; set; }
Visual Basic
Public Property OriginalLocation As String
    Get
    Set
Visual C++
public:
property String^ OriginalLocation {
    String^ get ();
    void set (String^ value);
}

Field Value

The original location.

See Also

ArchiveQuery Class
Sitecore.Data.Archiving Namespace


ParentId Property

[image]

Sitecore 6.4.1 API
ArchiveQuery..::..ParentId Property
ArchiveQuery Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ParentId { get; set; }
Visual Basic
Public Property ParentId As ID
    Get
    Set
Visual C++
public:
property ID^ ParentId {
    ID^ get ();
    void set (ID^ value);
}

Field Value

The parent id.

See Also

ArchiveQuery Class
Sitecore.Data.Archiving Namespace


ArchiveQuery.OrderDirection Enumeration

[image]

Sitecore 6.4.1 API
ArchiveQuery..::..OrderDirection Enumeration
ArchiveQuery Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum OrderDirection
Visual Basic
Public Enumeration OrderDirection
Visual C++
public enum class OrderDirection

Members

Member name | Value | Description
Ascending | 0 |
Descending | 1 |

See Also

Sitecore.Data.Archiving Namespace


ArchiveQuery.Ordering Class

[image]

Sitecore 6.4.1 API
ArchiveQuery..::..Ordering Class
ArchiveQuery Class Members See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Ordering
Visual Basic
Public Class Ordering
Visual C++
public ref class Ordering

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Archiving..::..ArchiveQuery..::..Ordering

See Also

ArchiveQuery..::..Ordering Members
Sitecore.Data.Archiving Namespace


ArchiveQuery.Ordering Members

[image] [image]

Sitecore 6.4.1 API
ArchiveQuery..::..Ordering Members
ArchiveQuery..::..Ordering Class Constructors Methods Properties See Also Send Feedback

ArchiveQuery

The ArchiveQuery..::..Ordering type exposes the following members.

Constructors

 | Name | Description
Public method | ArchiveQuery..::..Ordering | Initializes a new instance of the ArchiveQuery..::..Ordering class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Direction | Gets the direction.
Public property | Field | Gets the field.

See Also

ArchiveQuery..::..Ordering Class
Sitecore.Data.Archiving Namespace


ArchiveQuery.Ordering Constructor

[image]

Sitecore 6.4.1 API
ArchiveQuery..::..Ordering Constructor
ArchiveQuery..::..Ordering Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Ordering(
    ArchiveQuery..::..ArchiveField field,
    ArchiveQuery..::..OrderDirection direction
)
Visual Basic
Public Sub New ( _
    field As ArchiveQuery..::..ArchiveField, _
    direction As ArchiveQuery..::..OrderDirection _
)
Visual C++
public:
Ordering(
    ArchiveQuery..::..ArchiveField field,
    ArchiveQuery..::..OrderDirection direction
)

Parameters

field
Type: Sitecore.Data.Archiving..::..ArchiveQuery..::..ArchiveField
The field.
direction
Type: Sitecore.Data.Archiving..::..ArchiveQuery..::..OrderDirection
The direction.

See Also

ArchiveQuery..::..Ordering Class
Sitecore.Data.Archiving Namespace


ArchiveQuery.Ordering Properties

[image] [image]

Sitecore 6.4.1 API
ArchiveQuery..::..Ordering Properties
ArchiveQuery..::..Ordering Class See Also Send Feedback

The ArchiveQuery..::..Ordering type exposes the following members.

Properties

 | Name | Description
Public property | Direction | Gets the direction.
Public property | Field | Gets the field.

See Also

ArchiveQuery..::..Ordering Class
Sitecore.Data.Archiving Namespace


Direction Property

[image]

Sitecore 6.4.1 API
ArchiveQuery..::..Ordering..::..Direction Property
ArchiveQuery..::..Ordering Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ArchiveQuery..::..OrderDirection Direction { get; }
Visual Basic
Public ReadOnly Property Direction As ArchiveQuery..::..OrderDirection
    Get
Visual C++
public:
property ArchiveQuery..::..OrderDirection Direction {
    ArchiveQuery..::..OrderDirection get ();
}

Field Value

The direction.

See Also

ArchiveQuery..::..Ordering Class
Sitecore.Data.Archiving Namespace


DataArchives Members

[image] [image]

Sitecore 6.4.1 API
DataArchives Members
DataArchives Class Constructors Methods Properties See Also Send Feedback

The DataArchives type exposes the following members.

Constructors

 | Name | Description
Public method | DataArchives | Initializes a new instance of the DataArchives class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of archives.
Public property | Item | Gets the Archive with the specified name.

See Also

DataArchives Class
Sitecore.Data.Archiving Namespace


DataArchives Constructor

[image]

Sitecore 6.4.1 API
DataArchives Constructor
DataArchives Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataArchives(
    Database database
)
Visual Basic
Public Sub New ( _
    database As Database _
)
Visual C++
public:
DataArchives(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database

[Missing <param name="database"/> documentation for "M:Sitecore.Data.Archiving.DataArchives.#ctor(Sitecore.Data.Database)"]

See Also

DataArchives Class
Sitecore.Data.Archiving Namespace


DataArchives Properties

[image] [image]

Sitecore 6.4.1 API
DataArchives Properties
DataArchives Class See Also Send Feedback

The DataArchives type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of archives.
Public property | Item | Gets the Archive with the specified name.

See Also

DataArchives Class
Sitecore.Data.Archiving Namespace


Count Property

[image]

Sitecore 6.4.1 API
DataArchives..::..Count Property
DataArchives Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
property int Count {
    int get ();
}

Field Value

The count.

See Also

DataArchives Class
Sitecore.Data.Archiving Namespace


Item Property

[image]

Sitecore 6.4.1 API
DataArchives..::..Item Property
DataArchives Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Archive this[
    string name
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    name As String _
) As Archive
    Get
Visual C++
public:
property Archive^ default[String^ name] {
    Archive^ get (String^ name);
}

Parameters

name
Type: System..::..String

See Also

DataArchives Class
Sitecore.Data.Archiving Namespace


SqlArchive Class

[image]

Sitecore 6.4.1 API
SqlArchive Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SqlArchive : Archive
Visual Basic
Public Class SqlArchive _
    Inherits Archive
Visual C++
public ref class SqlArchive : public Archive

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Archiving..::..Archive
Sitecore.Data.Archiving..::..SqlArchive

See Also

SqlArchive Members
Sitecore.Data.Archiving Namespace


SqlArchive Members

[image] [image]

Sitecore 6.4.1 API
SqlArchive Members
SqlArchive Class Constructors Methods Fields Properties See Also Send Feedback

The SqlArchive type exposes the following members.

Constructors

 | Name | Description
Public method | SqlArchive | Initializes a new instance of the SqlArchive class.

Methods

 | Name | Description
Protected method | AddDate | Adds the lower date.
Protected method | AddGuid | Adds an id.
Protected method | AddId | Adds an id.
Protected method | AddOrderByClause | Adds an 'order by' clause.
Protected method | AddString | Adds the string.
Protected method | AddWhereClause | Adds the where clause.
Public method | ArchiveItem | Archives an item. (Overrides Archive..::..ArchiveItem(Item).)
Protected method | CreateDataApi | Initializes the data API.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetArchivalId | Gets the archival id associated with an item. (Overrides Archive..::..GetArchivalId(ID).)
Protected method | GetEntries(SqlStatement) | Gets the entries.
Public method | GetEntries(Int32, Int32) | Gets a list of entries. (Inherited from Archive.)
Public method | GetEntries(ArchiveQuery, Int32, Int32) | Gets a list of entries. (Overrides Archive..::..GetEntries(ArchiveQuery, Int32, Int32).)
Public method | GetEntriesForUser | Gets a list of entries owned by the specified user. (Inherited from Archive.)
Public method | GetEntryCount()()()() | Gets the number of entries currently in the archive. (Inherited from Archive.)
Public method | GetEntryCount(ArchiveQuery) | Gets the number of entries currently in the archive. (Overrides Archive..::..GetEntryCount(ArchiveQuery).)
Public method | GetEntryCountForUser | Gets the entry count for current user. (Inherited from Archive.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetParameterName | Gets the name of the parameter.
Protected method | GetSelectStatement(ArchiveQuery, String) | Gets a select statement.
Protected method | GetSelectStatement(ArchiveQuery, String, Int32, Int32) | Gets a paged select statement.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotifyItemDeleted | Notifies the item deleted. (Inherited from Archive.)
Protected method | NotifyItemDeleting | Notifies the item deleting. (Inherited from Archive.)
Public method | RemoveEntries()()()() | Removes all entries from the archive. (Inherited from Archive.)
Public method | RemoveEntries(ArchiveQuery) | Removes all entries from the archive. (Overrides Archive..::..RemoveEntries(ArchiveQuery).)
Public method | RestoreItem | Restores an item. (Overrides Archive..::..RestoreItem(Guid).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _dataApi | Obsolete. data API
Protected field | _database | Database

Properties

 | Name | Description
Protected property | Api | Gets the Server Data API.
Public property | Name | Gets the name of the archive. (Inherited from Archive.)

See Also

SqlArchive Class
Sitecore.Data.Archiving Namespace


SqlArchive Constructor

[image]

Sitecore 6.4.1 API
SqlArchive Constructor
SqlArchive Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlArchive(
    string name,
    Database database
)
Visual Basic
Public Sub New ( _
    name As String, _
    database As Database _
)
Visual C++
public:
SqlArchive(
    String^ name,
    Database^ database
)

Parameters

name
Type: System..::..String
Archive Name.
database
Type: Sitecore.Data..::..Database
The database.

See Also

SqlArchive Class
Sitecore.Data.Archiving Namespace


SqlArchive Fields

[image] [image]

Sitecore 6.4.1 API
SqlArchive Fields
SqlArchive Class See Also Send Feedback

The SqlArchive type exposes the following members.

Fields

 | Name | Description
Protected field | _dataApi | Obsolete. data API
Protected field | _database | Database

See Also

SqlArchive Class
Sitecore.Data.Archiving Namespace


_database Field

[image]

Sitecore 6.4.1 API
SqlArchive..::.._database Field
SqlArchive Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected readonly Database _database
Visual Basic
Protected ReadOnly _database As Database
Visual C++
protected:
initonly Database^ _database

See Also

SqlArchive Class
Sitecore.Data.Archiving Namespace


SqlArchive Methods

[image] [image]

Sitecore 6.4.1 API
SqlArchive Methods
SqlArchive Class See Also Send Feedback

The SqlArchive type exposes the following members.

Methods

 | Name | Description
Protected method | AddDate | Adds the lower date.
Protected method | AddGuid | Adds an id.
Protected method | AddId | Adds an id.
Protected method | AddOrderByClause | Adds an 'order by' clause.
Protected method | AddString | Adds the string.
Protected method | AddWhereClause | Adds the where clause.
Public method | ArchiveItem | Archives an item. (Overrides Archive..::..ArchiveItem(Item).)
Protected method | CreateDataApi | Initializes the data API.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetArchivalId | Gets the archival id associated with an item. (Overrides Archive..::..GetArchivalId(ID).)
Protected method | GetEntries(SqlStatement) | Gets the entries.
Public method | GetEntries(Int32, Int32) | Gets a list of entries. (Inherited from Archive.)
Public method | GetEntries(ArchiveQuery, Int32, Int32) | Gets a list of entries. (Overrides Archive..::..GetEntries(ArchiveQuery, Int32, Int32).)
Public method | GetEntriesForUser | Gets a list of entries owned by the specified user. (Inherited from Archive.)
Public method | GetEntryCount()()()() | Gets the number of entries currently in the archive. (Inherited from Archive.)
Public method | GetEntryCount(ArchiveQuery) | Gets the number of entries currently in the archive. (Overrides Archive..::..GetEntryCount(ArchiveQuery).)
Public method | GetEntryCountForUser | Gets the entry count for current user. (Inherited from Archive.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetParameterName | Gets the name of the parameter.
Protected method | GetSelectStatement(ArchiveQuery, String) | Gets a select statement.
Protected method | GetSelectStatement(ArchiveQuery, String, Int32, Int32) | Gets a paged select statement.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotifyItemDeleted | Notifies the item deleted. (Inherited from Archive.)
Protected method | NotifyItemDeleting | Notifies the item deleting. (Inherited from Archive.)
Public method | RemoveEntries()()()() | Removes all entries from the archive. (Inherited from Archive.)
Public method | RemoveEntries(ArchiveQuery) | Removes all entries from the archive. (Overrides Archive..::..RemoveEntries(ArchiveQuery).)
Public method | RestoreItem | Restores an item. (Overrides Archive..::..RestoreItem(Guid).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SqlArchive Class
Sitecore.Data.Archiving Namespace


AddDate Method

[image]

Sitecore 6.4.1 API
SqlArchive..::..AddDate Method
SqlArchive Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void AddDate(
    DateTime value,
    string columnName,
    string comparisonOperator,
    StringBuilder whereClause,
    SqlStatement statement
)
Visual Basic
Protected Overridable Sub AddDate ( _
    value As DateTime, _
    columnName As String, _
    comparisonOperator As String, _
    whereClause As StringBuilder, _
    statement As SqlStatement _
)
Visual C++
protected:
virtual void AddDate(
    DateTime value,
    String^ columnName,
    String^ comparisonOperator,
    StringBuilder^ whereClause,
    SqlStatement^ statement
)

Parameters

value
Type: System..::..DateTime
The value.
columnName
Type: System..::..String
Name of the column.
comparisonOperator
Type: System..::..String
The comparison operator.
whereClause
Type: System.Text..::..StringBuilder
The where clause.
statement
Type: Sitecore.Data.DataProviders.Sql..::..SqlStatement
The statement.

See Also

SqlArchive Class
Sitecore.Data.Archiving Namespace


AddGuid Method

[image]

Sitecore 6.4.1 API
SqlArchive..::..AddGuid Method
SqlArchive Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void AddGuid(
    Guid id,
    string columnName,
    StringBuilder whereClause,
    SqlStatement statement
)
Visual Basic
Protected Overridable Sub AddGuid ( _
    id As Guid, _
    columnName As String, _
    whereClause As StringBuilder, _
    statement As SqlStatement _
)
Visual C++
protected:
virtual void AddGuid(
    Guid id,
    String^ columnName,
    StringBuilder^ whereClause,
    SqlStatement^ statement
)

Parameters

id
Type: System..::..Guid
The archival id.
columnName
Type: System..::..String
Name of the column.
whereClause
Type: System.Text..::..StringBuilder
The where clause.
statement
Type: Sitecore.Data.DataProviders.Sql..::..SqlStatement
The statement.

See Also

SqlArchive Class
Sitecore.Data.Archiving Namespace


AddId Method

[image]

Sitecore 6.4.1 API
SqlArchive..::..AddId Method
SqlArchive Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void AddId(
    ID id,
    string columnName,
    StringBuilder whereClause,
    SqlStatement statement
)
Visual Basic
Protected Overridable Sub AddId ( _
    id As ID, _
    columnName As String, _
    whereClause As StringBuilder, _
    statement As SqlStatement _
)
Visual C++
protected:
virtual void AddId(
    ID^ id,
    String^ columnName,
    StringBuilder^ whereClause,
    SqlStatement^ statement
)

Parameters

id
Type: Sitecore.Data..::..ID
The entity id.
columnName
Type: System..::..String
Name of the column.
whereClause
Type: System.Text..::..StringBuilder
The where clause.
statement
Type: Sitecore.Data.DataProviders.Sql..::..SqlStatement
The statement.

See Also

SqlArchive Class
Sitecore.Data.Archiving Namespace


AddOrderByClause Method

[image]

Sitecore 6.4.1 API
SqlArchive..::..AddOrderByClause Method
SqlArchive Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void AddOrderByClause(
    ArchiveQuery query,
    SqlStatement statement
)
Visual Basic
Protected Overridable Sub AddOrderByClause ( _
    query As ArchiveQuery, _
    statement As SqlStatement _
)
Visual C++
protected:
virtual void AddOrderByClause(
    ArchiveQuery^ query,
    SqlStatement^ statement
)

Parameters

query
Type: Sitecore.Data.Archiving..::..ArchiveQuery
The query.
statement
Type: Sitecore.Data.DataProviders.Sql..::..SqlStatement
The statement.

See Also

SqlArchive Class
Sitecore.Data.Archiving Namespace


AddString Method

[image]

Sitecore 6.4.1 API
SqlArchive..::..AddString Method
SqlArchive Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void AddString(
    string value,
    string columnName,
    StringBuilder whereClause,
    SqlStatement statement
)
Visual Basic
Protected Overridable Sub AddString ( _
    value As String, _
    columnName As String, _
    whereClause As StringBuilder, _
    statement As SqlStatement _
)
Visual C++
protected:
virtual void AddString(
    String^ value,
    String^ columnName,
    StringBuilder^ whereClause,
    SqlStatement^ statement
)

Parameters

value
Type: System..::..String
The value.
columnName
Type: System..::..String
Name of the column.
whereClause
Type: System.Text..::..StringBuilder
The where clause.
statement
Type: Sitecore.Data.DataProviders.Sql..::..SqlStatement
The statement.

See Also

SqlArchive Class
Sitecore.Data.Archiving Namespace


AddWhereClause Method

[image]

Sitecore 6.4.1 API
SqlArchive..::..AddWhereClause Method
SqlArchive Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void AddWhereClause(
    ArchiveQuery query,
    SqlStatement statement
)
Visual Basic
Protected Overridable Sub AddWhereClause ( _
    query As ArchiveQuery, _
    statement As SqlStatement _
)
Visual C++
protected:
virtual void AddWhereClause(
    ArchiveQuery^ query,
    SqlStatement^ statement
)

Parameters

query
Type: Sitecore.Data.Archiving..::..ArchiveQuery
The query.
statement
Type: Sitecore.Data.DataProviders.Sql..::..SqlStatement
The statement.

See Also

SqlArchive Class
Sitecore.Data.Archiving Namespace


ArchiveItem Method

[image]

Sitecore 6.4.1 API
SqlArchive..::..ArchiveItem Method
SqlArchive Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Guid ArchiveItem(
    Item item
)
Visual Basic
Public Overrides Function ArchiveItem ( _
    item As Item _
) As Guid
Visual C++
public:
virtual Guid ArchiveItem(
    Item^ item
) override

Parameters

item
Type: Sitecore.Data.Items..::..Item
Item to be archived.

Return Value

The archival id.

See Also

SqlArchive Class
Sitecore.Data.Archiving Namespace


CreateDataApi Method

[image]

Sitecore 6.4.1 API
SqlArchive..::..CreateDataApi Method
SqlArchive Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual SqlDataApi CreateDataApi()
Visual Basic
Protected Overridable Function CreateDataApi As SqlDataApi
Visual C++
protected:
virtual SqlDataApi^ CreateDataApi()

Return Value

The data api.

Exceptions

Exception | Condition
System..::..InvalidOperationException | SqlArchive can only be used for databases with a valid ConnectionStringName

See Also

SqlArchive Class
Sitecore.Data.Archiving Namespace


GetArchivalId Method

[image]

Sitecore 6.4.1 API
SqlArchive..::..GetArchivalId Method
SqlArchive Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Guid GetArchivalId(
    ID itemId
)
Visual Basic
Public Overrides Function GetArchivalId ( _
    itemId As ID _
) As Guid
Visual C++
public:
virtual Guid GetArchivalId(
    ID^ itemId
) override

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.

Return Value

The archivek ID.

See Also

SqlArchive Class
Sitecore.Data.Archiving Namespace


GetEntries Method

[image] [image]

Sitecore 6.4.1 API
SqlArchive..::..GetEntries Method
SqlArchive Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetEntries(SqlStatement) | Gets the entries.
Public method | GetEntries(Int32, Int32) | Gets a list of entries. (Inherited from Archive.)
Public method | GetEntries(ArchiveQuery, Int32, Int32) | Gets a list of entries. (Overrides Archive..::..GetEntries(ArchiveQuery, Int32, Int32).)

See Also

SqlArchive Class
SqlArchive Members
Sitecore.Data.Archiving Namespace


GetEntries Method (SqlStatement)

[image]

Sitecore 6.4.1 API
SqlArchive..::..GetEntries Method (SqlStatement)
SqlArchive Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual IEnumerable<ArchiveEntry> GetEntries(
    SqlStatement statement
)
Visual Basic
Protected Overridable Function GetEntries ( _
    statement As SqlStatement _
) As IEnumerable(Of ArchiveEntry)
Visual C++
protected:
virtual IEnumerable<ArchiveEntry^>^ GetEntries(
    SqlStatement^ statement
)

Parameters

statement
Type: Sitecore.Data.DataProviders.Sql..::..SqlStatement
The statement.

Return Value

The IEnumerable archive entries by sql statement.

See Also

SqlArchive Class
GetEntries Overload
Sitecore.Data.Archiving Namespace


GetEntries Method (ArchiveQuery, Int32, Int32)

[image]

Sitecore 6.4.1 API
SqlArchive..::..GetEntries Method (ArchiveQuery, Int32, Int32)
SqlArchive Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override IEnumerable<ArchiveEntry> GetEntries(
    ArchiveQuery query,
    int pageIndex,
    int pageSize
)
Visual Basic
Public Overrides Function GetEntries ( _
    query As ArchiveQuery, _
    pageIndex As Integer, _
    pageSize As Integer _
) As IEnumerable(Of ArchiveEntry)
Visual C++
public:
virtual IEnumerable<ArchiveEntry^>^ GetEntries(
    ArchiveQuery^ query,
    int pageIndex,
    int pageSize
) override

Parameters

query
Type: Sitecore.Data.Archiving..::..ArchiveQuery
The query.
pageIndex
Type: System..::..Int32
Index of the page.
pageSize
Type: System..::..Int32
Size of the page.

Return Value

The IEnumerable archived entries filtered by specified query.

See Also

SqlArchive Class
GetEntries Overload
Sitecore.Data.Archiving Namespace


GetEntryCount Method

[image] [image]

Sitecore 6.4.1 API
SqlArchive..::..GetEntryCount Method
SqlArchive Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetEntryCount()()()() | Gets the number of entries currently in the archive. (Inherited from Archive.)
Public method | GetEntryCount(ArchiveQuery) | Gets the number of entries currently in the archive. (Overrides Archive..::..GetEntryCount(ArchiveQuery).)

See Also

SqlArchive Class
SqlArchive Members
Sitecore.Data.Archiving Namespace


GetEntryCount Method (ArchiveQuery)

[image]

Sitecore 6.4.1 API
SqlArchive..::..GetEntryCount Method (ArchiveQuery)
SqlArchive Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override int GetEntryCount(
    ArchiveQuery query
)
Visual Basic
Public Overrides Function GetEntryCount ( _
    query As ArchiveQuery _
) As Integer
Visual C++
public:
virtual int GetEntryCount(
    ArchiveQuery^ query
) override

Parameters

query
Type: Sitecore.Data.Archiving..::..ArchiveQuery
The query.

Return Value

The get entry count.

See Also

SqlArchive Class
GetEntryCount Overload
Sitecore.Data.Archiving Namespace


GetParameterName Method

[image]

Sitecore 6.4.1 API
SqlArchive..::..GetParameterName Method
SqlArchive Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string GetParameterName(
    string columnName
)
Visual Basic
Protected Overridable Function GetParameterName ( _
    columnName As String _
) As String
Visual C++
protected:
virtual String^ GetParameterName(
    String^ columnName
)

Parameters

columnName
Type: System..::..String
Name of the column.

Return Value

The get parameter name.

See Also

SqlArchive Class
Sitecore.Data.Archiving Namespace


GetSelectStatement Method

[image] [image]

Sitecore 6.4.1 API
SqlArchive..::..GetSelectStatement Method
SqlArchive Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetSelectStatement(ArchiveQuery, String) | Gets a select statement.
Protected method | GetSelectStatement(ArchiveQuery, String, Int32, Int32) | Gets a paged select statement.

See Also

SqlArchive Class
SqlArchive Members
Sitecore.Data.Archiving Namespace


GetSelectStatement Method (ArchiveQuery, String)

[image]

Sitecore 6.4.1 API
SqlArchive..::..GetSelectStatement Method (ArchiveQuery, String)
SqlArchive Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual SqlStatement GetSelectStatement(
    ArchiveQuery query,
    string columns
)
Visual Basic
Protected Overridable Function GetSelectStatement ( _
    query As ArchiveQuery, _
    columns As String _
) As SqlStatement
Visual C++
protected:
virtual SqlStatement^ GetSelectStatement(
    ArchiveQuery^ query,
    String^ columns
)

Parameters

query
Type: Sitecore.Data.Archiving..::..ArchiveQuery
The query.
columns
Type: System..::..String
The columns.

Return Value

The Sql statement.

See Also

SqlArchive Class
GetSelectStatement Overload
Sitecore.Data.Archiving Namespace


GetSelectStatement Method (ArchiveQuery, String, Int32, Int32)

[image]

Sitecore 6.4.1 API
SqlArchive..::..GetSelectStatement Method (ArchiveQuery, String, Int32, Int32)
SqlArchive Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual SqlStatement GetSelectStatement(
    ArchiveQuery query,
    string columns,
    int pageIndex,
    int pageSize
)
Visual Basic
Protected Overridable Function GetSelectStatement ( _
    query As ArchiveQuery, _
    columns As String, _
    pageIndex As Integer, _
    pageSize As Integer _
) As SqlStatement
Visual C++
protected:
virtual SqlStatement^ GetSelectStatement(
    ArchiveQuery^ query,
    String^ columns,
    int pageIndex,
    int pageSize
)

Parameters

query
Type: Sitecore.Data.Archiving..::..ArchiveQuery
The query.
columns
Type: System..::..String
The columns.
pageIndex
Type: System..::..Int32
Index of the page.
pageSize
Type: System..::..Int32
Size of the page.

Return Value

The Sql statement.

See Also

SqlArchive Class
GetSelectStatement Overload
Sitecore.Data.Archiving Namespace


RemoveEntries Method

[image] [image]

Sitecore 6.4.1 API
SqlArchive..::..RemoveEntries Method
SqlArchive Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveEntries()()()() | Removes all entries from the archive. (Inherited from Archive.)
Public method | RemoveEntries(ArchiveQuery) | Removes all entries from the archive. (Overrides Archive..::..RemoveEntries(ArchiveQuery).)

See Also

SqlArchive Class
SqlArchive Members
Sitecore.Data.Archiving Namespace


RemoveEntries Method (ArchiveQuery)

[image]

Sitecore 6.4.1 API
SqlArchive..::..RemoveEntries Method (ArchiveQuery)
SqlArchive Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void RemoveEntries(
    ArchiveQuery query
)
Visual Basic
Public Overrides Sub RemoveEntries ( _
    query As ArchiveQuery _
)
Visual C++
public:
virtual void RemoveEntries(
    ArchiveQuery^ query
) override

Parameters

query
Type: Sitecore.Data.Archiving..::..ArchiveQuery
The Query.

See Also

SqlArchive Class
RemoveEntries Overload
Sitecore.Data.Archiving Namespace


RestoreItem Method

[image]

Sitecore 6.4.1 API
SqlArchive..::..RestoreItem Method
SqlArchive Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool RestoreItem(
    Guid archivalId
)
Visual Basic
Public Overrides Function RestoreItem ( _
    archivalId As Guid _
) As Boolean
Visual C++
public:
virtual bool RestoreItem(
    Guid archivalId
) override

Parameters

archivalId
Type: System..::..Guid
The archival id.

Return Value

The restore item.

See Also

SqlArchive Class
Sitecore.Data.Archiving Namespace


SqlArchive Properties

[image] [image]

Sitecore 6.4.1 API
SqlArchive Properties
SqlArchive Class See Also Send Feedback

The SqlArchive type exposes the following members.

Properties

 | Name | Description
Protected property | Api | Gets the Server Data API.
Public property | Name | Gets the name of the archive. (Inherited from Archive.)

See Also

SqlArchive Class
Sitecore.Data.Archiving Namespace


SqlArchiveProvider Class

[image]

Sitecore 6.4.1 API
SqlArchiveProvider Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SqlArchiveProvider : ArchiveProvider
Visual Basic
Public Class SqlArchiveProvider _
    Inherits ArchiveProvider
Visual C++
public ref class SqlArchiveProvider : public ArchiveProvider

Inheritance Hierarchy

System..::..Object
System.Configuration.Provider..::..ProviderBase
Sitecore.Data.Archiving..::..ArchiveProvider
Sitecore.Data.Archiving..::..SqlArchiveProvider

See Also

SqlArchiveProvider Members
Sitecore.Data.Archiving Namespace


SqlArchiveProvider Members

[image] [image]

Sitecore 6.4.1 API
SqlArchiveProvider Members
SqlArchiveProvider Class Constructors Methods Properties See Also Send Feedback

The SqlArchiveProvider type exposes the following members.

Constructors

 | Name | Description
Public method | SqlArchiveProvider | Initializes a new instance of the SqlArchiveProvider class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetArchive(String, Database) | Gets an archive by name from the specified database. (Overrides ArchiveProvider..::..GetArchive(String, Database).)
Protected method | GetArchive(XmlNode, Database) | Gets the archive.
Public method | GetArchiveCount | Gets the archive count for the specified database. (Overrides ArchiveProvider..::..GetArchiveCount(Database).)
Public method | GetArchives | Gets all the archives of the specified database. (Overrides ArchiveProvider..::..GetArchives(Database).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the provider. (Inherited from ArchiveProvider.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | MatchDatabaseNames | Gets the match databases. (Inherited from ArchiveProvider.)
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

SqlArchiveProvider Class
Sitecore.Data.Archiving Namespace


SqlArchiveProvider Constructor

[image]

Sitecore 6.4.1 API
SqlArchiveProvider Constructor
SqlArchiveProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlArchiveProvider()
Visual Basic
Public Sub New
Visual C++
public:
SqlArchiveProvider()

See Also

SqlArchiveProvider Class
Sitecore.Data.Archiving Namespace


SqlArchiveProvider Methods

[image] [image]

Sitecore 6.4.1 API
SqlArchiveProvider Methods
SqlArchiveProvider Class See Also Send Feedback

The SqlArchiveProvider type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetArchive(String, Database) | Gets an archive by name from the specified database. (Overrides ArchiveProvider..::..GetArchive(String, Database).)
Protected method | GetArchive(XmlNode, Database) | Gets the archive.
Public method | GetArchiveCount | Gets the archive count for the specified database. (Overrides ArchiveProvider..::..GetArchiveCount(Database).)
Public method | GetArchives | Gets all the archives of the specified database. (Overrides ArchiveProvider..::..GetArchives(Database).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the provider. (Inherited from ArchiveProvider.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SqlArchiveProvider Class
Sitecore.Data.Archiving Namespace


GetArchive Method

[image] [image]

Sitecore 6.4.1 API
SqlArchiveProvider..::..GetArchive Method
SqlArchiveProvider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetArchive(String, Database) | Gets an archive by name from the specified database. (Overrides ArchiveProvider..::..GetArchive(String, Database).)
Protected method | GetArchive(XmlNode, Database) | Gets the archive.

See Also

SqlArchiveProvider Class
SqlArchiveProvider Members
Sitecore.Data.Archiving Namespace


GetArchive Method (String, Database)

[image]

Sitecore 6.4.1 API
SqlArchiveProvider..::..GetArchive Method (String, Database)
SqlArchiveProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Archive GetArchive(
    string archiveName,
    Database database
)
Visual Basic
Public Overrides Function GetArchive ( _
    archiveName As String, _
    database As Database _
) As Archive
Visual C++
public:
virtual Archive^ GetArchive(
    String^ archiveName,
    Database^ database
) override

Parameters

archiveName
Type: System..::..String
Name of the archive.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Archiving.SqlArchiveProvider.GetArchive(System.String,Sitecore.Data.Database)"]

See Also

SqlArchiveProvider Class
GetArchive Overload
Sitecore.Data.Archiving Namespace


GetArchive Method (XmlNode, Database)

[image]

Sitecore 6.4.1 API
SqlArchiveProvider..::..GetArchive Method (XmlNode, Database)
SqlArchiveProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual Archive GetArchive(
    XmlNode configNode,
    Database database
)
Visual Basic
Protected Overridable Function GetArchive ( _
    configNode As XmlNode, _
    database As Database _
) As Archive
Visual C++
protected:
virtual Archive^ GetArchive(
    XmlNode^ configNode,
    Database^ database
)

Parameters

configNode
Type: System.Xml..::..XmlNode
The config node.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Archiving.SqlArchiveProvider.GetArchive(System.Xml.XmlNode,Sitecore.Data.Database)"]

See Also

SqlArchiveProvider Class
GetArchive Overload
Sitecore.Data.Archiving Namespace


GetArchives Method

[image]

Sitecore 6.4.1 API
SqlArchiveProvider..::..GetArchives Method
SqlArchiveProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override List<Archive> GetArchives(
    Database database
)
Visual Basic
Public Overrides Function GetArchives ( _
    database As Database _
) As List(Of Archive)
Visual C++
public:
virtual List<Archive^>^ GetArchives(
    Database^ database
) override

Parameters

database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Archiving.SqlArchiveProvider.GetArchives(Sitecore.Data.Database)"]

See Also

SqlArchiveProvider Class
Sitecore.Data.Archiving Namespace


SqlArchiveProvider Properties

[image] [image]

Sitecore 6.4.1 API
SqlArchiveProvider Properties
SqlArchiveProvider Class See Also Send Feedback

The SqlArchiveProvider type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | MatchDatabaseNames | Gets the match databases. (Inherited from ArchiveProvider.)
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

SqlArchiveProvider Class
Sitecore.Data.Archiving Namespace


SwitchingArchiveProvider Members

[image] [image]

Sitecore 6.4.1 API
SwitchingArchiveProvider Members
SwitchingArchiveProvider Class Constructors Methods Properties See Also Send Feedback

The SwitchingArchiveProvider type exposes the following members.

Constructors

 | Name | Description
Public method | SwitchingArchiveProvider | Initializes a new instance of the SwitchingArchiveProvider class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetArchive | Gets an archive by name from the specified database. (Overrides ArchiveProvider..::..GetArchive(String, Database).)
Public method | GetArchiveCount | Gets the archive count for the specified database. (Overrides ArchiveProvider..::..GetArchiveCount(Database).)
Public method | GetArchives | Gets all the archives of the specified database. (Overrides ArchiveProvider..::..GetArchives(Database).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetProvider | Gets appropriate provider for database.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the provider. (Inherited from ArchiveProvider.)
Protected method | InitializeMapping | Initializes the mapping.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | MatchDatabaseNames | Gets the match databases. (Inherited from ArchiveProvider.)
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

SwitchingArchiveProvider Class
Sitecore.Data.Archiving Namespace


SwitchingArchiveProvider Constructor

[image]

Sitecore 6.4.1 API
SwitchingArchiveProvider Constructor
SwitchingArchiveProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SwitchingArchiveProvider()
Visual Basic
Public Sub New
Visual C++
public:
SwitchingArchiveProvider()

See Also

SwitchingArchiveProvider Class
Sitecore.Data.Archiving Namespace


SwitchingArchiveProvider Methods

[image] [image]

Sitecore 6.4.1 API
SwitchingArchiveProvider Methods
SwitchingArchiveProvider Class See Also Send Feedback

The SwitchingArchiveProvider type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetArchive | Gets an archive by name from the specified database. (Overrides ArchiveProvider..::..GetArchive(String, Database).)
Public method | GetArchiveCount | Gets the archive count for the specified database. (Overrides ArchiveProvider..::..GetArchiveCount(Database).)
Public method | GetArchives | Gets all the archives of the specified database. (Overrides ArchiveProvider..::..GetArchives(Database).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetProvider | Gets appropriate provider for database.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the provider. (Inherited from ArchiveProvider.)
Protected method | InitializeMapping | Initializes the mapping.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SwitchingArchiveProvider Class
Sitecore.Data.Archiving Namespace


GetArchive Method

[image]

Sitecore 6.4.1 API
SwitchingArchiveProvider..::..GetArchive Method
SwitchingArchiveProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Archive GetArchive(
    string archiveName,
    Database database
)
Visual Basic
Public Overrides Function GetArchive ( _
    archiveName As String, _
    database As Database _
) As Archive
Visual C++
public:
virtual Archive^ GetArchive(
    String^ archiveName,
    Database^ database
) override

Parameters

archiveName
Type: System..::..String
Name of the archive.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Archiving.SwitchingArchiveProvider.GetArchive(System.String,Sitecore.Data.Database)"]

See Also

SwitchingArchiveProvider Class
Sitecore.Data.Archiving Namespace


GetArchives Method

[image]

Sitecore 6.4.1 API
SwitchingArchiveProvider..::..GetArchives Method
SwitchingArchiveProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override List<Archive> GetArchives(
    Database database
)
Visual Basic
Public Overrides Function GetArchives ( _
    database As Database _
) As List(Of Archive)
Visual C++
public:
virtual List<Archive^>^ GetArchives(
    Database^ database
) override

Parameters

database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Archiving.SwitchingArchiveProvider.GetArchives(Sitecore.Data.Database)"]

See Also

SwitchingArchiveProvider Class
Sitecore.Data.Archiving Namespace


GetProvider Method

[image]

Sitecore 6.4.1 API
SwitchingArchiveProvider..::..GetProvider Method
SwitchingArchiveProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual ArchiveProvider GetProvider(
    Database database
)
Visual Basic
Protected Overridable Function GetProvider ( _
    database As Database _
) As ArchiveProvider
Visual C++
protected:
virtual ArchiveProvider^ GetProvider(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Archiving.SwitchingArchiveProvider.GetProvider(Sitecore.Data.Database)"]

See Also

SwitchingArchiveProvider Class
Sitecore.Data.Archiving Namespace


InitializeMapping Method

[image]

Sitecore 6.4.1 API
SwitchingArchiveProvider..::..InitializeMapping Method
SwitchingArchiveProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Archiving
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void InitializeMapping()
Visual Basic
Protected Overridable Sub InitializeMapping
Visual C++
protected:
virtual void InitializeMapping()

Exceptions

Exception | Condition
Sitecore.Exceptions..::..ProviderConfigurationException | ProviderConfigurationException.

See Also

SwitchingArchiveProvider Class
Sitecore.Data.Archiving Namespace


SwitchingArchiveProvider Properties

[image] [image]

Sitecore 6.4.1 API
SwitchingArchiveProvider Properties
SwitchingArchiveProvider Class See Also Send Feedback

The SwitchingArchiveProvider type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | MatchDatabaseNames | Gets the match databases. (Inherited from ArchiveProvider.)
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

SwitchingArchiveProvider Class
Sitecore.Data.Archiving Namespace


Sitecore.Data.Clones Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Data.Clones Namespace
Send Feedback

Classes

 | Class | Description
Public class | ChildCreatedNotification | Defines the child created notification class.
Public class | FieldChangedNotification | Defines the field changed notification class.
Public class | FirstVersionAddedNotification | The first version added notification.
Public class | ItemVersionNotification | The item version notification.
Public class | MemoryNotificationProvider | The Notification Database that stores all data in static list.
Public class | Notification | Defines the notification class.
Public class | NotificationProvider | Defines the notifications database class.
Public class | VersionAddedNotification | Defines the version added notification class.


ChildCreatedNotification Class

[image]

Sitecore 6.4.1 API
ChildCreatedNotification Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ChildCreatedNotification : Notification
Visual Basic
Public Class ChildCreatedNotification _
    Inherits Notification
Visual C++
public ref class ChildCreatedNotification : public Notification

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Clones..::..Notification
Sitecore.Data.Clones..::..ChildCreatedNotification

See Also

ChildCreatedNotification Members
Sitecore.Data.Clones Namespace


ChildCreatedNotification Members

[image] [image]

Sitecore 6.4.1 API
ChildCreatedNotification Members
ChildCreatedNotification Class Constructors Methods Properties See Also Send Feedback

The ChildCreatedNotification type exposes the following members.

Constructors

 | Name | Description
Public method | ChildCreatedNotification | Initializes a new instance of the ChildCreatedNotification class

Methods

 | Name | Description
Public method | Accept | Accepts the specified item. (Overrides Notification..::..Accept(Item).)
Public method | Clone | Clones the source object. Has the same effect as creating a new instance of the type. (Overrides Notification..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RegisterWarnings | Registers the warnings. (Overrides Notification..::..RegisterWarnings(GetContentEditorWarningsArgs, Item).)
Public method | Reject | Rejects the specified item. (Inherited from Notification.)
Protected method | Remove | Removes current notification from database. (Inherited from Notification.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ChildId | Gets or sets the child id.
Public property | ID | Gets or sets the notification ID. (Inherited from Notification.)
Public property | Processed | Gets or sets a value indicating whether this Notification is processed. (Inherited from Notification.)
Public property | Uri | Gets or sets the URI. (Inherited from Notification.)

See Also

ChildCreatedNotification Class
Sitecore.Data.Clones Namespace


ChildCreatedNotification Constructor

[image]

Sitecore 6.4.1 API
ChildCreatedNotification Constructor
ChildCreatedNotification Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ChildCreatedNotification()
Visual Basic
Public Sub New
Visual C++
public:
ChildCreatedNotification()

See Also

ChildCreatedNotification Class
Sitecore.Data.Clones Namespace


ChildCreatedNotification Methods

[image] [image]

Sitecore 6.4.1 API
ChildCreatedNotification Methods
ChildCreatedNotification Class See Also Send Feedback

The ChildCreatedNotification type exposes the following members.

Methods

 | Name | Description
Public method | Accept | Accepts the specified item. (Overrides Notification..::..Accept(Item).)
Public method | Clone | Clones the source object. Has the same effect as creating a new instance of the type. (Overrides Notification..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RegisterWarnings | Registers the warnings. (Overrides Notification..::..RegisterWarnings(GetContentEditorWarningsArgs, Item).)
Public method | Reject | Rejects the specified item. (Inherited from Notification.)
Protected method | Remove | Removes current notification from database. (Inherited from Notification.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChildCreatedNotification Class
Sitecore.Data.Clones Namespace


Accept Method

[image]

Sitecore 6.4.1 API
ChildCreatedNotification..::..Accept Method
ChildCreatedNotification Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Accept(
    Item item
)
Visual Basic
Public Overrides Sub Accept ( _
    item As Item _
)
Visual C++
public:
virtual void Accept(
    Item^ item
) override

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item to accept the notification for.

See Also

ChildCreatedNotification Class
Sitecore.Data.Clones Namespace


Clone Method

[image]

Sitecore 6.4.1 API
ChildCreatedNotification..::..Clone Method
ChildCreatedNotification Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Notification Clone()
Visual Basic
Public Overrides Function Clone As Notification
Visual C++
public:
virtual Notification^ Clone() override

Return Value

The empty Notification instance.

Implements

IPrototype<(Of <(<'TObjectType>)>)>..::..Clone()()()()

See Also

ChildCreatedNotification Class
Sitecore.Data.Clones Namespace


RegisterWarnings Method

[image]

Sitecore 6.4.1 API
ChildCreatedNotification..::..RegisterWarnings Method
ChildCreatedNotification Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void RegisterWarnings(
    GetContentEditorWarningsArgs args,
    Item item
)
Visual Basic
Public Overrides Sub RegisterWarnings ( _
    args As GetContentEditorWarningsArgs, _
    item As Item _
)
Visual C++
public:
virtual void RegisterWarnings(
    GetContentEditorWarningsArgs^ args,
    Item^ item
) override

Parameters

args
Type: Sitecore.Pipelines.GetContentEditorWarnings..::..GetContentEditorWarningsArgs
The arguments.
item
Type: Sitecore.Data.Items..::..Item
The Sitecore item to register warning for.

See Also

ChildCreatedNotification Class
Sitecore.Data.Clones Namespace


ChildCreatedNotification Properties

[image] [image]

Sitecore 6.4.1 API
ChildCreatedNotification Properties
ChildCreatedNotification Class See Also Send Feedback

The ChildCreatedNotification type exposes the following members.

Properties

 | Name | Description
Public property | ChildId | Gets or sets the child id.
Public property | ID | Gets or sets the notification ID. (Inherited from Notification.)
Public property | Processed | Gets or sets a value indicating whether this Notification is processed. (Inherited from Notification.)
Public property | Uri | Gets or sets the URI. (Inherited from Notification.)

See Also

ChildCreatedNotification Class
Sitecore.Data.Clones Namespace


ChildId Property

[image]

Sitecore 6.4.1 API
ChildCreatedNotification..::..ChildId Property
ChildCreatedNotification Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ChildId { get; set; }
Visual Basic
Public Property ChildId As ID
    Get
    Set
Visual C++
public:
property ID^ ChildId {
    ID^ get ();
    void set (ID^ value);
}

Field Value

The child id.

See Also

ChildCreatedNotification Class
Sitecore.Data.Clones Namespace


FieldChangedNotification Class

[image]

Sitecore 6.4.1 API
FieldChangedNotification Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FieldChangedNotification : Notification
Visual Basic
Public Class FieldChangedNotification _
    Inherits Notification
Visual C++
public ref class FieldChangedNotification : public Notification

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Clones..::..Notification
Sitecore.Data.Clones..::..FieldChangedNotification

See Also

FieldChangedNotification Members
Sitecore.Data.Clones Namespace


FieldChangedNotification Members

[image] [image]

Sitecore 6.4.1 API
FieldChangedNotification Members
FieldChangedNotification Class Constructors Methods Properties See Also Send Feedback

The FieldChangedNotification type exposes the following members.

Constructors

 | Name | Description
Public method | FieldChangedNotification | Initializes a new instance of the FieldChangedNotification class

Methods

 | Name | Description
Public method | Accept | Accepts the specified item. (Overrides Notification..::..Accept(Item).)
Public method | Clone | Clones the source object. Has the same effect as creating a new instance of the type. (Overrides Notification..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RegisterWarnings | Registers the warnings. (Overrides Notification..::..RegisterWarnings(GetContentEditorWarningsArgs, Item).)
Public method | Reject | Rejects the specified item. (Inherited from Notification.)
Protected method | Remove | Removes current notification from database. (Inherited from Notification.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FieldID | Gets or sets the name of the field.
Public property | ID | Gets or sets the notification ID. (Inherited from Notification.)
Public property | NewValue | Gets or sets the new value.
Public property | OldValue | Gets or sets the old value.
Public property | Processed | Gets or sets a value indicating whether this Notification is processed. (Inherited from Notification.)
Public property | Uri | Gets or sets the URI. (Inherited from Notification.)
Public property | VersionUri | Gets or sets the version URI.

See Also

FieldChangedNotification Class
Sitecore.Data.Clones Namespace


FieldChangedNotification Constructor

[image]

Sitecore 6.4.1 API
FieldChangedNotification Constructor
FieldChangedNotification Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FieldChangedNotification()
Visual Basic
Public Sub New
Visual C++
public:
FieldChangedNotification()

See Also

FieldChangedNotification Class
Sitecore.Data.Clones Namespace


FieldChangedNotification Methods

[image] [image]

Sitecore 6.4.1 API
FieldChangedNotification Methods
FieldChangedNotification Class See Also Send Feedback

The FieldChangedNotification type exposes the following members.

Methods

 | Name | Description
Public method | Accept | Accepts the specified item. (Overrides Notification..::..Accept(Item).)
Public method | Clone | Clones the source object. Has the same effect as creating a new instance of the type. (Overrides Notification..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RegisterWarnings | Registers the warnings. (Overrides Notification..::..RegisterWarnings(GetContentEditorWarningsArgs, Item).)
Public method | Reject | Rejects the specified item. (Inherited from Notification.)
Protected method | Remove | Removes current notification from database. (Inherited from Notification.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldChangedNotification Class
Sitecore.Data.Clones Namespace


Accept Method

[image]

Sitecore 6.4.1 API
FieldChangedNotification..::..Accept Method
FieldChangedNotification Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Accept(
    Item item
)
Visual Basic
Public Overrides Sub Accept ( _
    item As Item _
)
Visual C++
public:
virtual void Accept(
    Item^ item
) override

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item to accept the notification.

See Also

FieldChangedNotification Class
Sitecore.Data.Clones Namespace


Clone Method

[image]

Sitecore 6.4.1 API
FieldChangedNotification..::..Clone Method
FieldChangedNotification Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Notification Clone()
Visual Basic
Public Overrides Function Clone As Notification
Visual C++
public:
virtual Notification^ Clone() override

Return Value

The empty Notification instance.

Implements

IPrototype<(Of <(<'TObjectType>)>)>..::..Clone()()()()

See Also

FieldChangedNotification Class
Sitecore.Data.Clones Namespace


RegisterWarnings Method

[image]

Sitecore 6.4.1 API
FieldChangedNotification..::..RegisterWarnings Method
FieldChangedNotification Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void RegisterWarnings(
    GetContentEditorWarningsArgs args,
    Item item
)
Visual Basic
Public Overrides Sub RegisterWarnings ( _
    args As GetContentEditorWarningsArgs, _
    item As Item _
)
Visual C++
public:
virtual void RegisterWarnings(
    GetContentEditorWarningsArgs^ args,
    Item^ item
) override

Parameters

args
Type: Sitecore.Pipelines.GetContentEditorWarnings..::..GetContentEditorWarningsArgs
The arguments.
item
Type: Sitecore.Data.Items..::..Item
The Sitecore item to register a worning for.

See Also

FieldChangedNotification Class
Sitecore.Data.Clones Namespace


FieldChangedNotification Properties

[image] [image]

Sitecore 6.4.1 API
FieldChangedNotification Properties
FieldChangedNotification Class See Also Send Feedback

The FieldChangedNotification type exposes the following members.

Properties

 | Name | Description
Public property | FieldID | Gets or sets the name of the field.
Public property | ID | Gets or sets the notification ID. (Inherited from Notification.)
Public property | NewValue | Gets or sets the new value.
Public property | OldValue | Gets or sets the old value.
Public property | Processed | Gets or sets a value indicating whether this Notification is processed. (Inherited from Notification.)
Public property | Uri | Gets or sets the URI. (Inherited from Notification.)
Public property | VersionUri | Gets or sets the version URI.

See Also

FieldChangedNotification Class
Sitecore.Data.Clones Namespace


FieldID Property

[image]

Sitecore 6.4.1 API
FieldChangedNotification..::..FieldID Property
FieldChangedNotification Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID FieldID { get; set; }
Visual Basic
Public Property FieldID As ID
    Get
    Set
Visual C++
public:
property ID^ FieldID {
    ID^ get ();
    void set (ID^ value);
}

Field Value

The name of the field.

See Also

FieldChangedNotification Class
Sitecore.Data.Clones Namespace


NewValue Property

[image]

Sitecore 6.4.1 API
FieldChangedNotification..::..NewValue Property
FieldChangedNotification Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string NewValue { get; set; }
Visual Basic
Public Property NewValue As String
    Get
    Set
Visual C++
public:
property String^ NewValue {
    String^ get ();
    void set (String^ value);
}

Field Value

The new value.

See Also

FieldChangedNotification Class
Sitecore.Data.Clones Namespace


OldValue Property

[image]

Sitecore 6.4.1 API
FieldChangedNotification..::..OldValue Property
FieldChangedNotification Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string OldValue { get; set; }
Visual Basic
Public Property OldValue As String
    Get
    Set
Visual C++
public:
property String^ OldValue {
    String^ get ();
    void set (String^ value);
}

Field Value

The old value.

See Also

FieldChangedNotification Class
Sitecore.Data.Clones Namespace


FirstVersionAddedNotification Class

[image]

Sitecore 6.4.1 API
FirstVersionAddedNotification Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FirstVersionAddedNotification : VersionAddedNotification
Visual Basic
Public Class FirstVersionAddedNotification _
    Inherits VersionAddedNotification
Visual C++
public ref class FirstVersionAddedNotification : public VersionAddedNotification

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Clones..::..Notification
Sitecore.Data.Clones..::..VersionAddedNotification
Sitecore.Data.Clones..::..FirstVersionAddedNotification

See Also

FirstVersionAddedNotification Members
Sitecore.Data.Clones Namespace


FirstVersionAddedNotification Members

[image] [image]

Sitecore 6.4.1 API
FirstVersionAddedNotification Members
FirstVersionAddedNotification Class Constructors Methods Properties See Also Send Feedback

The FirstVersionAddedNotification type exposes the following members.

Constructors

 | Name | Description
Public method | FirstVersionAddedNotification | Initializes a new instance of the FirstVersionAddedNotification class

Methods

 | Name | Description
Public method | Accept | Accepts the specified item. (Overrides VersionAddedNotification..::..Accept(Item).)
Public method | Clone | Clones the source object. Has the same effect as creating a new instance of the type. (Overrides VersionAddedNotification..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RegisterWarnings | Registers the warnings. (Overrides VersionAddedNotification..::..RegisterWarnings(GetContentEditorWarningsArgs, Item).)
Public method | Reject | Rejects the specified item. (Inherited from Notification.)
Protected method | Remove | Removes current notification from database. (Inherited from Notification.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ID | Gets or sets the notification ID. (Inherited from Notification.)
Public property | Processed | Gets or sets a value indicating whether this Notification is processed. (Inherited from Notification.)
Public property | Uri | Gets or sets the URI. (Inherited from Notification.)
Public property | VersionUri | Gets or sets the version URI. (Inherited from VersionAddedNotification.)

See Also

FirstVersionAddedNotification Class
Sitecore.Data.Clones Namespace


FirstVersionAddedNotification Constructor

[image]

Sitecore 6.4.1 API
FirstVersionAddedNotification Constructor
FirstVersionAddedNotification Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FirstVersionAddedNotification()
Visual Basic
Public Sub New
Visual C++
public:
FirstVersionAddedNotification()

See Also

FirstVersionAddedNotification Class
Sitecore.Data.Clones Namespace


FirstVersionAddedNotification Methods

[image] [image]

Sitecore 6.4.1 API
FirstVersionAddedNotification Methods
FirstVersionAddedNotification Class See Also Send Feedback

The FirstVersionAddedNotification type exposes the following members.

Methods

 | Name | Description
Public method | Accept | Accepts the specified item. (Overrides VersionAddedNotification..::..Accept(Item).)
Public method | Clone | Clones the source object. Has the same effect as creating a new instance of the type. (Overrides VersionAddedNotification..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RegisterWarnings | Registers the warnings. (Overrides VersionAddedNotification..::..RegisterWarnings(GetContentEditorWarningsArgs, Item).)
Public method | Reject | Rejects the specified item. (Inherited from Notification.)
Protected method | Remove | Removes current notification from database. (Inherited from Notification.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FirstVersionAddedNotification Class
Sitecore.Data.Clones Namespace


Accept Method

[image]

Sitecore 6.4.1 API
FirstVersionAddedNotification..::..Accept Method
FirstVersionAddedNotification Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Accept(
    Item item
)
Visual Basic
Public Overrides Sub Accept ( _
    item As Item _
)
Visual C++
public:
virtual void Accept(
    Item^ item
) override

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item to accept the Notification for.

See Also

FirstVersionAddedNotification Class
Sitecore.Data.Clones Namespace


Clone Method

[image]

Sitecore 6.4.1 API
FirstVersionAddedNotification..::..Clone Method
FirstVersionAddedNotification Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Notification Clone()
Visual Basic
Public Overrides Function Clone As Notification
Visual C++
public:
virtual Notification^ Clone() override

Return Value

The empty Notification instance.

Implements

IPrototype<(Of <(<'TObjectType>)>)>..::..Clone()()()()

See Also

FirstVersionAddedNotification Class
Sitecore.Data.Clones Namespace


RegisterWarnings Method

[image]

Sitecore 6.4.1 API
FirstVersionAddedNotification..::..RegisterWarnings Method
FirstVersionAddedNotification Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void RegisterWarnings(
    GetContentEditorWarningsArgs args,
    Item item
)
Visual Basic
Public Overrides Sub RegisterWarnings ( _
    args As GetContentEditorWarningsArgs, _
    item As Item _
)
Visual C++
public:
virtual void RegisterWarnings(
    GetContentEditorWarningsArgs^ args,
    Item^ item
) override

Parameters

args
Type: Sitecore.Pipelines.GetContentEditorWarnings..::..GetContentEditorWarningsArgs
The arguments.
item
Type: Sitecore.Data.Items..::..Item
The Sitecore item to register a worning for.

See Also

FirstVersionAddedNotification Class
Sitecore.Data.Clones Namespace


FirstVersionAddedNotification Properties

[image] [image]

Sitecore 6.4.1 API
FirstVersionAddedNotification Properties
FirstVersionAddedNotification Class See Also Send Feedback

The FirstVersionAddedNotification type exposes the following members.

Properties

 | Name | Description
Public property | ID | Gets or sets the notification ID. (Inherited from Notification.)
Public property | Processed | Gets or sets a value indicating whether this Notification is processed. (Inherited from Notification.)
Public property | Uri | Gets or sets the URI. (Inherited from Notification.)
Public property | VersionUri | Gets or sets the version URI. (Inherited from VersionAddedNotification.)

See Also

FirstVersionAddedNotification Class
Sitecore.Data.Clones Namespace


ItemVersionNotification Class

[image]

Sitecore 6.4.1 API
ItemVersionNotification Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemVersionNotification : VersionAddedNotification
Visual Basic
Public Class ItemVersionNotification _
    Inherits VersionAddedNotification
Visual C++
public ref class ItemVersionNotification : public VersionAddedNotification

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Clones..::..Notification
Sitecore.Data.Clones..::..VersionAddedNotification
Sitecore.Data.Clones..::..ItemVersionNotification

See Also

ItemVersionNotification Members
Sitecore.Data.Clones Namespace


ItemVersionNotification Members

[image] [image]

Sitecore 6.4.1 API
ItemVersionNotification Members
ItemVersionNotification Class Constructors Methods Properties See Also Send Feedback

The ItemVersionNotification type exposes the following members.

Constructors

 | Name | Description
Public method | ItemVersionNotification | Initializes a new instance of the ItemVersionNotification class

Methods

 | Name | Description
Public method | Accept | Accepts the specified item. (Overrides VersionAddedNotification..::..Accept(Item).)
Public method | Clone | Clones the source object. Has the same effect as creating a new instance of the type. (Overrides VersionAddedNotification..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RegisterWarnings | Registers the warnings. (Overrides VersionAddedNotification..::..RegisterWarnings(GetContentEditorWarningsArgs, Item).)
Public method | Reject | Rejects the specified item. (Overrides Notification..::..Reject(Item).)
Protected method | Remove | Removes current notification from database. (Inherited from Notification.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ID | Gets or sets the notification ID. (Inherited from Notification.)
Public property | Processed | Gets or sets a value indicating whether this Notification is processed. (Inherited from Notification.)
Public property | Uri | Gets or sets the URI. (Inherited from Notification.)
Public property | VersionUri | Gets or sets the version URI. (Inherited from VersionAddedNotification.)

See Also

ItemVersionNotification Class
Sitecore.Data.Clones Namespace


ItemVersionNotification Constructor

[image]

Sitecore 6.4.1 API
ItemVersionNotification Constructor
ItemVersionNotification Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemVersionNotification()
Visual Basic
Public Sub New
Visual C++
public:
ItemVersionNotification()

See Also

ItemVersionNotification Class
Sitecore.Data.Clones Namespace


ItemVersionNotification Methods

[image] [image]

Sitecore 6.4.1 API
ItemVersionNotification Methods
ItemVersionNotification Class See Also Send Feedback

The ItemVersionNotification type exposes the following members.

Methods

 | Name | Description
Public method | Accept | Accepts the specified item. (Overrides VersionAddedNotification..::..Accept(Item).)
Public method | Clone | Clones the source object. Has the same effect as creating a new instance of the type. (Overrides VersionAddedNotification..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RegisterWarnings | Registers the warnings. (Overrides VersionAddedNotification..::..RegisterWarnings(GetContentEditorWarningsArgs, Item).)
Public method | Reject | Rejects the specified item. (Overrides Notification..::..Reject(Item).)
Protected method | Remove | Removes current notification from database. (Inherited from Notification.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemVersionNotification Class
Sitecore.Data.Clones Namespace


Accept Method

[image]

Sitecore 6.4.1 API
ItemVersionNotification..::..Accept Method
ItemVersionNotification Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Accept(
    Item item
)
Visual Basic
Public Overrides Sub Accept ( _
    item As Item _
)
Visual C++
public:
virtual void Accept(
    Item^ item
) override

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item to accept the Notification for.

Exceptions

Exception | Condition
System..::..NotImplementedException | NotImplementedException.

See Also

ItemVersionNotification Class
Sitecore.Data.Clones Namespace


Clone Method

[image]

Sitecore 6.4.1 API
ItemVersionNotification..::..Clone Method
ItemVersionNotification Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Notification Clone()
Visual Basic
Public Overrides Function Clone As Notification
Visual C++
public:
virtual Notification^ Clone() override

Return Value

The empty Notification instance.

Implements

IPrototype<(Of <(<'TObjectType>)>)>..::..Clone()()()()

See Also

ItemVersionNotification Class
Sitecore.Data.Clones Namespace


RegisterWarnings Method

[image]

Sitecore 6.4.1 API
ItemVersionNotification..::..RegisterWarnings Method
ItemVersionNotification Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void RegisterWarnings(
    GetContentEditorWarningsArgs args,
    Item item
)
Visual Basic
Public Overrides Sub RegisterWarnings ( _
    args As GetContentEditorWarningsArgs, _
    item As Item _
)
Visual C++
public:
virtual void RegisterWarnings(
    GetContentEditorWarningsArgs^ args,
    Item^ item
) override

Parameters

args
Type: Sitecore.Pipelines.GetContentEditorWarnings..::..GetContentEditorWarningsArgs
The arguments.
item
Type: Sitecore.Data.Items..::..Item
The Sitecore item to register a worning for.

See Also

ItemVersionNotification Class
Sitecore.Data.Clones Namespace


Reject Method

[image]

Sitecore 6.4.1 API
ItemVersionNotification..::..Reject Method
ItemVersionNotification Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Reject(
    Item item
)
Visual Basic
Public Overrides Sub Reject ( _
    item As Item _
)
Visual C++
public:
virtual void Reject(
    Item^ item
) override

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item to reject the notification for.

See Also

ItemVersionNotification Class
Sitecore.Data.Clones Namespace


ItemVersionNotification Properties

[image] [image]

Sitecore 6.4.1 API
ItemVersionNotification Properties
ItemVersionNotification Class See Also Send Feedback

The ItemVersionNotification type exposes the following members.

Properties

 | Name | Description
Public property | ID | Gets or sets the notification ID. (Inherited from Notification.)
Public property | Processed | Gets or sets a value indicating whether this Notification is processed. (Inherited from Notification.)
Public property | Uri | Gets or sets the URI. (Inherited from Notification.)
Public property | VersionUri | Gets or sets the version URI. (Inherited from VersionAddedNotification.)

See Also

ItemVersionNotification Class
Sitecore.Data.Clones Namespace


MemoryNotificationProvider Class

[image]

Sitecore 6.4.1 API
MemoryNotificationProvider Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class MemoryNotificationProvider : NotificationProvider
Visual Basic
Public Class MemoryNotificationProvider _
    Inherits NotificationProvider
Visual C++
public ref class MemoryNotificationProvider : public NotificationProvider

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Clones..::..NotificationProvider
Sitecore.Data.Clones..::..MemoryNotificationProvider

See Also

MemoryNotificationProvider Members
Sitecore.Data.Clones Namespace


MemoryNotificationProvider Members

[image] [image]

Sitecore 6.4.1 API
MemoryNotificationProvider Members
MemoryNotificationProvider Class Constructors Methods See Also Send Feedback

The MemoryNotificationProvider type exposes the following members.

Constructors

 | Name | Description
Public method | MemoryNotificationProvider | Initializes a new instance of the MemoryNotificationProvider class

Methods

 | Name | Description
Public method | AddNotification | Adds notification. (Overrides NotificationProvider..::..AddNotification(Notification).)
Public method | Cleanup | Removes obsolete notifications. (Inherited from NotificationProvider.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNotification | Gets notification by ID. (Overrides NotificationProvider..::..GetNotification(ID).)
Public method | GetNotifications()()()() | Gets all notifications. (Overrides NotificationProvider..::..GetNotifications()()()().)
Public method | GetNotifications(Item) | The get notifications. (Overrides NotificationProvider..::..GetNotifications(Item).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasNotificationOwner | Determines whether the notification has an owner item. (Inherited from NotificationProvider.)
Protected method | IsOrphanChildNotification | Checks whether the specified notification is referred to missed item. (Inherited from NotificationProvider.)
Protected method | IsOrphanVersionNotification | Checks whether the notification is a notification for removed version. (Inherited from NotificationProvider.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessNotification | Precesses the specified notification and removes it if it is orphan. (Inherited from NotificationProvider.)
Public method | RemoveNotification | Removes the notification with specified ID. (Overrides NotificationProvider..::..RemoveNotification(ID).)
Public method | RemoveNotifications | Removes the notifications for the specified item. (Inherited from NotificationProvider.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MemoryNotificationProvider Class
Sitecore.Data.Clones Namespace


MemoryNotificationProvider Constructor

[image]

Sitecore 6.4.1 API
MemoryNotificationProvider Constructor
MemoryNotificationProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MemoryNotificationProvider()
Visual Basic
Public Sub New
Visual C++
public:
MemoryNotificationProvider()

See Also

MemoryNotificationProvider Class
Sitecore.Data.Clones Namespace


MemoryNotificationProvider Methods

[image] [image]

Sitecore 6.4.1 API
MemoryNotificationProvider Methods
MemoryNotificationProvider Class See Also Send Feedback

The MemoryNotificationProvider type exposes the following members.

Methods

 | Name | Description
Public method | AddNotification | Adds notification. (Overrides NotificationProvider..::..AddNotification(Notification).)
Public method | Cleanup | Removes obsolete notifications. (Inherited from NotificationProvider.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNotification | Gets notification by ID. (Overrides NotificationProvider..::..GetNotification(ID).)
Public method | GetNotifications()()()() | Gets all notifications. (Overrides NotificationProvider..::..GetNotifications()()()().)
Public method | GetNotifications(Item) | The get notifications. (Overrides NotificationProvider..::..GetNotifications(Item).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasNotificationOwner | Determines whether the notification has an owner item. (Inherited from NotificationProvider.)
Protected method | IsOrphanChildNotification | Checks whether the specified notification is referred to missed item. (Inherited from NotificationProvider.)
Protected method | IsOrphanVersionNotification | Checks whether the notification is a notification for removed version. (Inherited from NotificationProvider.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessNotification | Precesses the specified notification and removes it if it is orphan. (Inherited from NotificationProvider.)
Public method | RemoveNotification | Removes the notification with specified ID. (Overrides NotificationProvider..::..RemoveNotification(ID).)
Public method | RemoveNotifications | Removes the notifications for the specified item. (Inherited from NotificationProvider.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MemoryNotificationProvider Class
Sitecore.Data.Clones Namespace


AddNotification Method

[image]

Sitecore 6.4.1 API
MemoryNotificationProvider..::..AddNotification Method
MemoryNotificationProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void AddNotification(
    Notification notification
)
Visual Basic
Public Overrides Sub AddNotification ( _
    notification As Notification _
)
Visual C++
public:
virtual void AddNotification(
    Notification^ notification
) override

Parameters

notification
Type: Sitecore.Data.Clones..::..Notification
The notification.

See Also

MemoryNotificationProvider Class
Sitecore.Data.Clones Namespace


GetNotification Method

[image]

Sitecore 6.4.1 API
MemoryNotificationProvider..::..GetNotification Method
MemoryNotificationProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Notification GetNotification(
    ID id
)
Visual Basic
Public Overrides Function GetNotification ( _
    id As ID _
) As Notification
Visual C++
public:
virtual Notification^ GetNotification(
    ID^ id
) override

Parameters

id
Type: Sitecore.Data..::..ID
The Notification ID

Return Value

The Notification.

See Also

MemoryNotificationProvider Class
Sitecore.Data.Clones Namespace


GetNotifications Method

[image] [image]

Sitecore 6.4.1 API
MemoryNotificationProvider..::..GetNotifications Method
MemoryNotificationProvider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetNotifications()()()() | Gets all notifications. (Overrides NotificationProvider..::..GetNotifications()()()().)
Public method | GetNotifications(Item) | The get notifications. (Overrides NotificationProvider..::..GetNotifications(Item).)

See Also

MemoryNotificationProvider Class
MemoryNotificationProvider Members
Sitecore.Data.Clones Namespace


GetNotifications Method

[image]

Sitecore 6.4.1 API
MemoryNotificationProvider..::..GetNotifications Method
MemoryNotificationProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override IEnumerable<Notification> GetNotifications()
Visual Basic
Public Overrides Function GetNotifications As IEnumerable(Of Notification)
Visual C++
public:
virtual IEnumerable<Notification^>^ GetNotifications() override

Return Value

The list of all registered Notifications.

See Also

MemoryNotificationProvider Class
GetNotifications Overload
Sitecore.Data.Clones Namespace


GetNotifications Method (Item)

[image]

Sitecore 6.4.1 API
MemoryNotificationProvider..::..GetNotifications Method (Item)
MemoryNotificationProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override IEnumerable<Notification> GetNotifications(
    Item clone
)
Visual Basic
Public Overrides Function GetNotifications ( _
    clone As Item _
) As IEnumerable(Of Notification)
Visual C++
public:
virtual IEnumerable<Notification^>^ GetNotifications(
    Item^ clone
) override

Parameters

clone
Type: Sitecore.Data.Items..::..Item
The Sitecore Item to get notifications for.

Return Value

The list of Notifications for the item.

See Also

MemoryNotificationProvider Class
GetNotifications Overload
Sitecore.Data.Clones Namespace


RemoveNotification Method

[image]

Sitecore 6.4.1 API
MemoryNotificationProvider..::..RemoveNotification Method
MemoryNotificationProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool RemoveNotification(
    ID id
)
Visual Basic
Public Overrides Function RemoveNotification ( _
    id As ID _
) As Boolean
Visual C++
public:
virtual bool RemoveNotification(
    ID^ id
) override

Parameters

id
Type: Sitecore.Data..::..ID
The notification id.

Return Value

true if specification with specified ID has been found and removed.

See Also

MemoryNotificationProvider Class
Sitecore.Data.Clones Namespace


Notification Class

[image]

Sitecore 6.4.1 API
Notification Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class Notification : IPrototype<Notification>
Visual Basic
Public MustInherit Class Notification _
    Implements IPrototype(Of Notification)
Visual C++
public ref class Notification abstract : IPrototype<Notification^>

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Clones..::..Notification
Sitecore.Data.Clones..::..ChildCreatedNotification
Sitecore.Data.Clones..::..FieldChangedNotification
Sitecore.Data.Clones..::..VersionAddedNotification

See Also

Notification Members
Sitecore.Data.Clones Namespace


Notification Members

[image] [image]

Sitecore 6.4.1 API
Notification Members
Notification Class Constructors Methods Properties See Also Send Feedback

The Notification type exposes the following members.

Constructors

 | Name | Description
Public method | Notification | Initializes a new instance of the Notification class. Initializes a new instance of the FieldChangedNotification class.

Methods

 | Name | Description
Public method | Accept | Accepts the specified item.
Public method | Clone | Clones the source object. Has the same effect as creating a new instance of the type.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RegisterWarnings | Registers the warnings.
Public method | Reject | Rejects the specified item.
Protected method | Remove | Removes current notification from database.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ID | Gets or sets the notification ID.
Public property | Processed | Gets or sets a value indicating whether this Notification is processed.
Public property | Uri | Gets or sets the URI.

See Also

Notification Class
Sitecore.Data.Clones Namespace


Notification Constructor

[image]

Sitecore 6.4.1 API
Notification Constructor
Notification Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Notification()
Visual Basic
Public Sub New
Visual C++
public:
Notification()

See Also

Notification Class
Sitecore.Data.Clones Namespace


Notification Methods

[image] [image]

Sitecore 6.4.1 API
Notification Methods
Notification Class See Also Send Feedback

The Notification type exposes the following members.

Methods

 | Name | Description
Public method | Accept | Accepts the specified item.
Public method | Clone | Clones the source object. Has the same effect as creating a new instance of the type.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RegisterWarnings | Registers the warnings.
Public method | Reject | Rejects the specified item.
Protected method | Remove | Removes current notification from database.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Notification Class
Sitecore.Data.Clones Namespace


Accept Method

[image]

Sitecore 6.4.1 API
Notification..::..Accept Method
Notification Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Accept(
    Item item
)
Visual Basic
Public Overridable Sub Accept ( _
    item As Item _
)
Visual C++
public:
virtual void Accept(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item to accept the notification.

See Also

Notification Class
Sitecore.Data.Clones Namespace


Clone Method

[image]

Sitecore 6.4.1 API
Notification..::..Clone Method
Notification Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract Notification Clone()
Visual Basic
Public MustOverride Function Clone As Notification
Visual C++
public:
virtual Notification^ Clone() abstract

Return Value

The empty Notification instance.

Implements

IPrototype<(Of <(<'TObjectType>)>)>..::..Clone()()()()

See Also

Notification Class
Sitecore.Data.Clones Namespace


Reject Method

[image]

Sitecore 6.4.1 API
Notification..::..Reject Method
Notification Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Reject(
    Item item
)
Visual Basic
Public Overridable Sub Reject ( _
    item As Item _
)
Visual C++
public:
virtual void Reject(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item to reject the notification for.

See Also

Notification Class
Sitecore.Data.Clones Namespace


Remove Method

[image]

Sitecore 6.4.1 API
Notification..::..Remove Method
Notification Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void Remove()
Visual Basic
Protected Overridable Sub Remove
Visual C++
protected:
virtual void Remove()

See Also

Notification Class
Sitecore.Data.Clones Namespace


Notification Properties

[image] [image]

Sitecore 6.4.1 API
Notification Properties
Notification Class See Also Send Feedback

The Notification type exposes the following members.

Properties

 | Name | Description
Public property | ID | Gets or sets the notification ID.
Public property | Processed | Gets or sets a value indicating whether this Notification is processed.
Public property | Uri | Gets or sets the URI.

See Also

Notification Class
Sitecore.Data.Clones Namespace


ID Property

[image]

Sitecore 6.4.1 API
Notification..::..ID Property
Notification Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ID { get; set; }
Visual Basic
Public Property ID As ID
    Get
    Set
Visual C++
public:
property ID^ ID {
    ID^ get ();
    void set (ID^ value);
}

Field Value

The notification ID.

See Also

Notification Class
Sitecore.Data.Clones Namespace


Processed Property

[image]

Sitecore 6.4.1 API
Notification..::..Processed Property
Notification Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Processed { get; set; }
Visual Basic
Public Property Processed As Boolean
    Get
    Set
Visual C++
public:
property bool Processed {
    bool get ();
    void set (bool value);
}

Field Value

true if processed; otherwise, false.

See Also

Notification Class
Sitecore.Data.Clones Namespace


Uri Property

[image]

Sitecore 6.4.1 API
Notification..::..Uri Property
Notification Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemUri Uri { get; set; }
Visual Basic
Public Property Uri As ItemUri
    Get
    Set
Visual C++
public:
property ItemUri^ Uri {
    ItemUri^ get ();
    void set (ItemUri^ value);
}

Field Value

The notification item URI to apply to.

See Also

Notification Class
Sitecore.Data.Clones Namespace


NotificationProvider Class

[image]

Sitecore 6.4.1 API
NotificationProvider Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class NotificationProvider
Visual Basic
Public MustInherit Class NotificationProvider
Visual C++
public ref class NotificationProvider abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Clones..::..NotificationProvider
Sitecore.Data.Clones..::..MemoryNotificationProvider
Sitecore.Data.DataProviders.SqlServer..::..SqlServerNotificationProvider

See Also

NotificationProvider Members
Sitecore.Data.Clones Namespace


NotificationProvider Members

[image] [image]

Sitecore 6.4.1 API
NotificationProvider Members
NotificationProvider Class Constructors Methods See Also Send Feedback

The NotificationProvider type exposes the following members.

Constructors

 | Name | Description
Protected method | NotificationProvider | Initializes a new instance of the NotificationProvider class

Methods

 | Name | Description
Public method | AddNotification | Adds notification.
Public method | Cleanup | Removes obsolete notifications.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNotification | Gets notification by ID.
Public method | GetNotifications()()()() | Gets all notifications.
Public method | GetNotifications(Item) | The get notifications.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasNotificationOwner | Determines whether the notification has an owner item.
Protected method | IsOrphanChildNotification | Checks whether the specified notification is referred to missed item.
Protected method | IsOrphanVersionNotification | Checks whether the notification is a notification for removed version.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessNotification | Precesses the specified notification and removes it if it is orphan.
Public method | RemoveNotification | Removes the notification with specified ID.
Public method | RemoveNotifications | Removes the notifications for the specified item.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NotificationProvider Class
Sitecore.Data.Clones Namespace


NotificationProvider Constructor

[image]

Sitecore 6.4.1 API
NotificationProvider Constructor
NotificationProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected NotificationProvider()
Visual Basic
Protected Sub New
Visual C++
protected:
NotificationProvider()

See Also

NotificationProvider Class
Sitecore.Data.Clones Namespace


NotificationProvider Methods

[image] [image]

Sitecore 6.4.1 API
NotificationProvider Methods
NotificationProvider Class See Also Send Feedback

The NotificationProvider type exposes the following members.

Methods

 | Name | Description
Public method | AddNotification | Adds notification.
Public method | Cleanup | Removes obsolete notifications.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNotification | Gets notification by ID.
Public method | GetNotifications()()()() | Gets all notifications.
Public method | GetNotifications(Item) | The get notifications.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasNotificationOwner | Determines whether the notification has an owner item.
Protected method | IsOrphanChildNotification | Checks whether the specified notification is referred to missed item.
Protected method | IsOrphanVersionNotification | Checks whether the notification is a notification for removed version.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessNotification | Precesses the specified notification and removes it if it is orphan.
Public method | RemoveNotification | Removes the notification with specified ID.
Public method | RemoveNotifications | Removes the notifications for the specified item.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NotificationProvider Class
Sitecore.Data.Clones Namespace


AddNotification Method

[image]

Sitecore 6.4.1 API
NotificationProvider..::..AddNotification Method
NotificationProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract void AddNotification(
    Notification notification
)
Visual Basic
Public MustOverride Sub AddNotification ( _
    notification As Notification _
)
Visual C++
public:
virtual void AddNotification(
    Notification^ notification
) abstract

Parameters

notification
Type: Sitecore.Data.Clones..::..Notification
The notification.

See Also

NotificationProvider Class
Sitecore.Data.Clones Namespace


Cleanup Method

[image]

Sitecore 6.4.1 API
NotificationProvider..::..Cleanup Method
NotificationProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Cleanup()
Visual Basic
Public Overridable Sub Cleanup
Visual C++
public:
virtual void Cleanup()

See Also

NotificationProvider Class
Sitecore.Data.Clones Namespace


GetNotifications Method

[image] [image]

Sitecore 6.4.1 API
NotificationProvider..::..GetNotifications Method
NotificationProvider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetNotifications()()()() | Gets all notifications.
Public method | GetNotifications(Item) | The get notifications.

See Also

NotificationProvider Class
NotificationProvider Members
Sitecore.Data.Clones Namespace


GetNotifications Method

[image]

Sitecore 6.4.1 API
NotificationProvider..::..GetNotifications Method
NotificationProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract IEnumerable<Notification> GetNotifications()
Visual Basic
Public MustOverride Function GetNotifications As IEnumerable(Of Notification)
Visual C++
public:
virtual IEnumerable<Notification^>^ GetNotifications() abstract

Return Value

The list of all registered Notifications.

See Also

NotificationProvider Class
GetNotifications Overload
Sitecore.Data.Clones Namespace


GetNotifications Method (Item)

[image]

Sitecore 6.4.1 API
NotificationProvider..::..GetNotifications Method (Item)
NotificationProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract IEnumerable<Notification> GetNotifications(
    Item clone
)
Visual Basic
Public MustOverride Function GetNotifications ( _
    clone As Item _
) As IEnumerable(Of Notification)
Visual C++
public:
virtual IEnumerable<Notification^>^ GetNotifications(
    Item^ clone
) abstract

Parameters

clone
Type: Sitecore.Data.Items..::..Item
The Sitecore Item to get notifications for.

Return Value

The list of Notifications for the item.

See Also

NotificationProvider Class
GetNotifications Overload
Sitecore.Data.Clones Namespace


HasNotificationOwner Method

[image]

Sitecore 6.4.1 API
NotificationProvider..::..HasNotificationOwner Method
NotificationProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool HasNotificationOwner(
    Notification notification
)
Visual Basic
Protected Overridable Function HasNotificationOwner ( _
    notification As Notification _
) As Boolean
Visual C++
protected:
virtual bool HasNotificationOwner(
    Notification^ notification
)

Parameters

notification
Type: Sitecore.Data.Clones..::..Notification
The notification.

Return Value

true if the notification has an owner item; otherwise, false.

See Also

NotificationProvider Class
Sitecore.Data.Clones Namespace


IsOrphanChildNotification Method

[image]

Sitecore 6.4.1 API
NotificationProvider..::..IsOrphanChildNotification Method
NotificationProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool IsOrphanChildNotification(
    Notification notification
)
Visual Basic
Protected Overridable Function IsOrphanChildNotification ( _
    notification As Notification _
) As Boolean
Visual C++
protected:
virtual bool IsOrphanChildNotification(
    Notification^ notification
)

Parameters

notification
Type: Sitecore.Data.Clones..::..Notification
The notification.

Return Value

true when target item does not exist.

See Also

NotificationProvider Class
Sitecore.Data.Clones Namespace


IsOrphanVersionNotification Method

[image]

Sitecore 6.4.1 API
NotificationProvider..::..IsOrphanVersionNotification Method
NotificationProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool IsOrphanVersionNotification(
    Notification notification
)
Visual Basic
Protected Overridable Function IsOrphanVersionNotification ( _
    notification As Notification _
) As Boolean
Visual C++
protected:
virtual bool IsOrphanVersionNotification(
    Notification^ notification
)

Parameters

notification
Type: Sitecore.Data.Clones..::..Notification
The notification.

Return Value

true if the specifid notification is orphan.

See Also

NotificationProvider Class
Sitecore.Data.Clones Namespace


ProcessNotification Method

[image]

Sitecore 6.4.1 API
NotificationProvider..::..ProcessNotification Method
NotificationProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void ProcessNotification(
    Notification notification
)
Visual Basic
Protected Overridable Sub ProcessNotification ( _
    notification As Notification _
)
Visual C++
protected:
virtual void ProcessNotification(
    Notification^ notification
)

Parameters

notification
Type: Sitecore.Data.Clones..::..Notification
The notification.

See Also

NotificationProvider Class
Sitecore.Data.Clones Namespace


RemoveNotification Method

[image]

Sitecore 6.4.1 API
NotificationProvider..::..RemoveNotification Method
NotificationProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract bool RemoveNotification(
    ID id
)
Visual Basic
Public MustOverride Function RemoveNotification ( _
    id As ID _
) As Boolean
Visual C++
public:
virtual bool RemoveNotification(
    ID^ id
) abstract

Parameters

id
Type: Sitecore.Data..::..ID
The notification id.

Return Value

true if specification with specified ID has been found and removed.

See Also

NotificationProvider Class
Sitecore.Data.Clones Namespace


RemoveNotifications Method

[image]

Sitecore 6.4.1 API
NotificationProvider..::..RemoveNotifications Method
NotificationProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual int RemoveNotifications(
    Item item
)
Visual Basic
Public Overridable Function RemoveNotifications ( _
    item As Item _
) As Integer
Visual C++
public:
virtual int RemoveNotifications(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item to remove notifications for.

Return Value

The number of removed notifications.

See Also

NotificationProvider Class
Sitecore.Data.Clones Namespace


VersionAddedNotification Class

[image]

Sitecore 6.4.1 API
VersionAddedNotification Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class VersionAddedNotification : Notification
Visual Basic
Public Class VersionAddedNotification _
    Inherits Notification
Visual C++
public ref class VersionAddedNotification : public Notification

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Clones..::..Notification
Sitecore.Data.Clones..::..VersionAddedNotification
Sitecore.Data.Clones..::..FirstVersionAddedNotification
Sitecore.Data.Clones..::..ItemVersionNotification

See Also

VersionAddedNotification Members
Sitecore.Data.Clones Namespace


VersionAddedNotification Members

[image] [image]

Sitecore 6.4.1 API
VersionAddedNotification Members
VersionAddedNotification Class Constructors Methods Properties See Also Send Feedback

The VersionAddedNotification type exposes the following members.

Constructors

 | Name | Description
Public method | VersionAddedNotification | Initializes a new instance of the VersionAddedNotification class

Methods

 | Name | Description
Public method | Accept | Accepts the specified item. (Overrides Notification..::..Accept(Item).)
Public method | Clone | Clones the source object. Has the same effect as creating a new instance of the type. (Overrides Notification..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RegisterWarnings | Registers the warnings. (Overrides Notification..::..RegisterWarnings(GetContentEditorWarningsArgs, Item).)
Public method | Reject | Rejects the specified item. (Inherited from Notification.)
Protected method | Remove | Removes current notification from database. (Inherited from Notification.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ID | Gets or sets the notification ID. (Inherited from Notification.)
Public property | Processed | Gets or sets a value indicating whether this Notification is processed. (Inherited from Notification.)
Public property | Uri | Gets or sets the URI. (Inherited from Notification.)
Public property | VersionUri | Gets or sets the version URI.

See Also

VersionAddedNotification Class
Sitecore.Data.Clones Namespace


VersionAddedNotification Constructor

[image]

Sitecore 6.4.1 API
VersionAddedNotification Constructor
VersionAddedNotification Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public VersionAddedNotification()
Visual Basic
Public Sub New
Visual C++
public:
VersionAddedNotification()

See Also

VersionAddedNotification Class
Sitecore.Data.Clones Namespace


VersionAddedNotification Methods

[image] [image]

Sitecore 6.4.1 API
VersionAddedNotification Methods
VersionAddedNotification Class See Also Send Feedback

The VersionAddedNotification type exposes the following members.

Methods

 | Name | Description
Public method | Accept | Accepts the specified item. (Overrides Notification..::..Accept(Item).)
Public method | Clone | Clones the source object. Has the same effect as creating a new instance of the type. (Overrides Notification..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RegisterWarnings | Registers the warnings. (Overrides Notification..::..RegisterWarnings(GetContentEditorWarningsArgs, Item).)
Public method | Reject | Rejects the specified item. (Inherited from Notification.)
Protected method | Remove | Removes current notification from database. (Inherited from Notification.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VersionAddedNotification Class
Sitecore.Data.Clones Namespace


Accept Method

[image]

Sitecore 6.4.1 API
VersionAddedNotification..::..Accept Method
VersionAddedNotification Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Accept(
    Item item
)
Visual Basic
Public Overrides Sub Accept ( _
    item As Item _
)
Visual C++
public:
virtual void Accept(
    Item^ item
) override

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item to accept the Notification for.

See Also

VersionAddedNotification Class
Sitecore.Data.Clones Namespace


Clone Method

[image]

Sitecore 6.4.1 API
VersionAddedNotification..::..Clone Method
VersionAddedNotification Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Notification Clone()
Visual Basic
Public Overrides Function Clone As Notification
Visual C++
public:
virtual Notification^ Clone() override

Return Value

The empty Notification instance.

Implements

IPrototype<(Of <(<'TObjectType>)>)>..::..Clone()()()()

See Also

VersionAddedNotification Class
Sitecore.Data.Clones Namespace


VersionAddedNotification Properties

[image] [image]

Sitecore 6.4.1 API
VersionAddedNotification Properties
VersionAddedNotification Class See Also Send Feedback

The VersionAddedNotification type exposes the following members.

Properties

 | Name | Description
Public property | ID | Gets or sets the notification ID. (Inherited from Notification.)
Public property | Processed | Gets or sets a value indicating whether this Notification is processed. (Inherited from Notification.)
Public property | Uri | Gets or sets the URI. (Inherited from Notification.)
Public property | VersionUri | Gets or sets the version URI.

See Also

VersionAddedNotification Class
Sitecore.Data.Clones Namespace


VersionUri Property

[image]

Sitecore 6.4.1 API
VersionAddedNotification..::..VersionUri Property
VersionAddedNotification Class See Also Send Feedback

Namespace: Sitecore.Data.Clones
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemUri VersionUri { get; set; }
Visual Basic
Public Property VersionUri As ItemUri
    Get
    Set
Visual C++
public:
property ItemUri^ VersionUri {
    ItemUri^ get ();
    void set (ItemUri^ value);
}

Field Value

The version URI.

See Also

VersionAddedNotification Class
Sitecore.Data.Clones Namespace


Comparer Members

[image] [image]

Sitecore 6.4.1 API
Comparer Members
Comparer Class Constructors Methods See Also Send Feedback

The Comparer type exposes the following members.

Constructors

 | Name | Description
Protected method | Comparer | Initializes a new instance of the Comparer class

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Protected method | DoCompare | Compares two items.
Protected method | DoCompareSortorder | Compares the sortorder of two items.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Comparer Class
Sitecore.Data.Comparers Namespace


Comparer Constructor

[image]

Sitecore 6.4.1 API
Comparer Constructor
Comparer Class See Also Send Feedback

Namespace: Sitecore.Data.Comparers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Comparer()
Visual Basic
Protected Sub New
Visual C++
protected:
Comparer()

See Also

Comparer Class
Sitecore.Data.Comparers Namespace


Comparer Methods

[image] [image]

Sitecore 6.4.1 API
Comparer Methods
Comparer Class See Also Send Feedback

The Comparer type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Protected method | DoCompare | Compares two items.
Protected method | DoCompareSortorder | Compares the sortorder of two items.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Comparer Class
Sitecore.Data.Comparers Namespace


Compare Method

[image]

Sitecore 6.4.1 API
Comparer..::..Compare Method
Comparer Class See Also Send Feedback

Namespace: Sitecore.Data.Comparers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Compare(
    Item item1,
    Item item2
)
Visual Basic
Public Function Compare ( _
    item1 As Item, _
    item2 As Item _
) As Integer
Visual C++
public:
virtual int Compare(
    Item^ item1,
    Item^ item2
) sealed

Parameters

item1
Type: Sitecore.Data.Items..::..Item
The first object to compare.
item2
Type: Sitecore.Data.Items..::..Item
The second object to compare.

Return Value

Value Condition Less than zero if x is less than y. Zero if x equals y. Greater than zero if x is greater than y.

Implements

IComparer<(Of <(<'T>)>)>..::..Compare(T, T)

See Also

Comparer Class
Sitecore.Data.Comparers Namespace


DoCompare Method

[image]

Sitecore 6.4.1 API
Comparer..::..DoCompare Method
Comparer Class See Also Send Feedback

Namespace: Sitecore.Data.Comparers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected abstract int DoCompare(
    Item item1,
    Item item2
)
Visual Basic
Protected MustOverride Function DoCompare ( _
    item1 As Item, _
    item2 As Item _
) As Integer
Visual C++
protected:
virtual int DoCompare(
    Item^ item1,
    Item^ item2
) abstract

Parameters

item1
Type: Sitecore.Data.Items..::..Item
The item1.
item2
Type: Sitecore.Data.Items..::..Item
The item2.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Comparers.Comparer.DoCompare(Sitecore.Data.Items.Item,Sitecore.Data.Items.Item)"]

See Also

Comparer Class
Sitecore.Data.Comparers Namespace


DoCompareSortorder Method

[image]

Sitecore 6.4.1 API
Comparer..::..DoCompareSortorder Method
Comparer Class See Also Send Feedback

Namespace: Sitecore.Data.Comparers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool DoCompareSortorder(
    Item item1,
    Item item2,
    out int result
)
Visual Basic
Protected Overridable Function DoCompareSortorder ( _
    item1 As Item, _
    item2 As Item, _
    <OutAttribute> ByRef result As Integer _
) As Boolean
Visual C++
protected:
virtual bool DoCompareSortorder(
    Item^ item1,
    Item^ item2,
    [OutAttribute] int% result
)

Parameters

item1
Type: Sitecore.Data.Items..::..Item
The item1.
item2
Type: Sitecore.Data.Items..::..Item
The item2.
result
Type: System..::..Int32 %
The result.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Comparers.Comparer.DoCompareSortorder(Sitecore.Data.Items.Item,Sitecore.Data.Items.Item,System.Int32@)"]

See Also

Comparer Class
Sitecore.Data.Comparers Namespace


ComparerFactory Class

[image]

Sitecore 6.4.1 API
ComparerFactory Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Comparers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class ComparerFactory
Visual Basic
Public NotInheritable Class ComparerFactory
Visual C++
public ref class ComparerFactory abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Comparers..::..ComparerFactory

See Also

ComparerFactory Members
Sitecore.Data.Comparers Namespace


ComparerFactory Members

[image] [image]

Sitecore 6.4.1 API
ComparerFactory Members
ComparerFactory Class Methods See Also Send Feedback

Methods

Name | Description
GetComparer(String) | Obsolete. Gets the comparer.
GetComparer(Item) | Gets the comparer.
GetComparer(String, Database) | Gets the comparer.

See Also

ComparerFactory Class
Sitecore.Data.Comparers Namespace


ComparerFactory Methods

[image] [image]

Sitecore 6.4.1 API
ComparerFactory Methods
ComparerFactory Class See Also Send Feedback

Methods

Name | Description
GetComparer(String) | Obsolete. Gets the comparer.
GetComparer(Item) | Gets the comparer.
GetComparer(String, Database) | Gets the comparer.

See Also

ComparerFactory Class
Sitecore.Data.Comparers Namespace


GetComparer Method

[image] [image]

Sitecore 6.4.1 API
ComparerFactory..::..GetComparer Method
ComparerFactory Class See Also Send Feedback

Overload List

Name | Description
GetComparer(String) | Obsolete. Gets the comparer.
GetComparer(Item) | Gets the comparer.
GetComparer(String, Database) | Gets the comparer.

See Also

ComparerFactory Class
ComparerFactory Members
Sitecore.Data.Comparers Namespace


GetComparer Method (String)

[image]

Sitecore 6.4.1 API
ComparerFactory..::..GetComparer Method (String)
ComparerFactory Class See Also Send Feedback

Namespace: Sitecore.Data.Comparers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use GetComparer(sortingId, database) instead.")]
public static IComparer<Item> GetComparer(
    string sortingID
)
Visual Basic
<ObsoleteAttribute("Deprecated - Use GetComparer(sortingId, database) instead.")> _
Public Shared Function GetComparer ( _
    sortingID As String _
) As IComparer(Of Item)
Visual C++
[ObsoleteAttribute(L"Deprecated - Use GetComparer(sortingId, database) instead.")]
public:
static IComparer<Item^>^ GetComparer(
    String^ sortingID
)

Parameters

sortingID
Type: System..::..String
The sorting ID.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Comparers.ComparerFactory.GetComparer(System.String)"]

See Also

ComparerFactory Class
GetComparer Overload
Sitecore.Data.Comparers Namespace


GetComparer Method (Item)

[image]

Sitecore 6.4.1 API
ComparerFactory..::..GetComparer Method (Item)
ComparerFactory Class See Also Send Feedback

Namespace: Sitecore.Data.Comparers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static IComparer<Item> GetComparer(
    Item item
)
Visual Basic
Public Shared Function GetComparer ( _
    item As Item _
) As IComparer(Of Item)
Visual C++
public:
static IComparer<Item^>^ GetComparer(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Comparers.ComparerFactory.GetComparer(Sitecore.Data.Items.Item)"]

See Also

ComparerFactory Class
GetComparer Overload
Sitecore.Data.Comparers Namespace


GetComparer Method (String, Database)

[image]

Sitecore 6.4.1 API
ComparerFactory..::..GetComparer Method (String, Database)
ComparerFactory Class See Also Send Feedback

Namespace: Sitecore.Data.Comparers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static IComparer<Item> GetComparer(
    string sortingId,
    Database database
)
Visual Basic
Public Shared Function GetComparer ( _
    sortingId As String, _
    database As Database _
) As IComparer(Of Item)
Visual C++
public:
static IComparer<Item^>^ GetComparer(
    String^ sortingId,
    Database^ database
)

Parameters

sortingId
Type: System..::..String
The sorting ID.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Comparers.ComparerFactory.GetComparer(System.String,Sitecore.Data.Database)"]

See Also

ComparerFactory Class
GetComparer Overload
Sitecore.Data.Comparers Namespace


CreatedComparer Class

[image]

Sitecore 6.4.1 API
CreatedComparer Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Comparers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CreatedComparer : Comparer
Visual Basic
Public Class CreatedComparer _
    Inherits Comparer
Visual C++
public ref class CreatedComparer : public Comparer

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Comparers..::..Comparer
Sitecore.Data.Comparers..::..CreatedComparer

See Also

CreatedComparer Members
Sitecore.Data.Comparers Namespace


CreatedComparer Members

[image] [image]

Sitecore 6.4.1 API
CreatedComparer Members
CreatedComparer Class Constructors Methods See Also Send Feedback

The CreatedComparer type exposes the following members.

Constructors

 | Name | Description
Public method | CreatedComparer | Initializes a new instance of the CreatedComparer class

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from Comparer.)
Protected method | DoCompare | Compares two items. (Overrides Comparer..::..DoCompare(Item, Item).)
Protected method | DoCompareSortorder | Compares the sortorder of two items. (Inherited from Comparer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CreatedComparer Class
Sitecore.Data.Comparers Namespace


CreatedComparer Constructor

[image]

Sitecore 6.4.1 API
CreatedComparer Constructor
CreatedComparer Class See Also Send Feedback

Namespace: Sitecore.Data.Comparers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CreatedComparer()
Visual Basic
Public Sub New
Visual C++
public:
CreatedComparer()

See Also

CreatedComparer Class
Sitecore.Data.Comparers Namespace


CreatedComparer Methods

[image] [image]

Sitecore 6.4.1 API
CreatedComparer Methods
CreatedComparer Class See Also Send Feedback

The CreatedComparer type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from Comparer.)
Protected method | DoCompare | Compares two items. (Overrides Comparer..::..DoCompare(Item, Item).)
Protected method | DoCompareSortorder | Compares the sortorder of two items. (Inherited from Comparer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CreatedComparer Class
Sitecore.Data.Comparers Namespace


DoCompare Method

[image]

Sitecore 6.4.1 API
CreatedComparer..::..DoCompare Method
CreatedComparer Class See Also Send Feedback

Namespace: Sitecore.Data.Comparers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override int DoCompare(
    Item item1,
    Item item2
)
Visual Basic
Protected Overrides Function DoCompare ( _
    item1 As Item, _
    item2 As Item _
) As Integer
Visual C++
protected:
virtual int DoCompare(
    Item^ item1,
    Item^ item2
) override

Parameters

item1
Type: Sitecore.Data.Items..::..Item
The item1.
item2
Type: Sitecore.Data.Items..::..Item
The item2.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Comparers.CreatedComparer.DoCompare(Sitecore.Data.Items.Item,Sitecore.Data.Items.Item)"]

See Also

CreatedComparer Class
Sitecore.Data.Comparers Namespace


DefaultComparer Class

[image]

Sitecore 6.4.1 API
DefaultComparer Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Comparers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DefaultComparer : Comparer
Visual Basic
Public Class DefaultComparer _
    Inherits Comparer
Visual C++
public ref class DefaultComparer : public Comparer

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Comparers..::..Comparer
Sitecore.Data.Comparers..::..DefaultComparer

See Also

DefaultComparer Members
Sitecore.Data.Comparers Namespace


DefaultComparer Members

[image] [image]

Sitecore 6.4.1 API
DefaultComparer Members
DefaultComparer Class Constructors Methods See Also Send Feedback

The DefaultComparer type exposes the following members.

Constructors

 | Name | Description
Public method | DefaultComparer | Initializes a new instance of the DefaultComparer class

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from Comparer.)
Protected method | DoCompare | Compares two items. (Overrides Comparer..::..DoCompare(Item, Item).)
Protected method | DoCompareSortorder | Compares the sortorder of two items. (Inherited from Comparer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultComparer Class
Sitecore.Data.Comparers Namespace


DefaultComparer Constructor

[image]

Sitecore 6.4.1 API
DefaultComparer Constructor
DefaultComparer Class See Also Send Feedback

Namespace: Sitecore.Data.Comparers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DefaultComparer()
Visual Basic
Public Sub New
Visual C++
public:
DefaultComparer()

See Also

DefaultComparer Class
Sitecore.Data.Comparers Namespace


DefaultComparer Methods

[image] [image]

Sitecore 6.4.1 API
DefaultComparer Methods
DefaultComparer Class See Also Send Feedback

The DefaultComparer type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from Comparer.)
Protected method | DoCompare | Compares two items. (Overrides Comparer..::..DoCompare(Item, Item).)
Protected method | DoCompareSortorder | Compares the sortorder of two items. (Inherited from Comparer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultComparer Class
Sitecore.Data.Comparers Namespace


DoCompare Method

[image]

Sitecore 6.4.1 API
DefaultComparer..::..DoCompare Method
DefaultComparer Class See Also Send Feedback

Namespace: Sitecore.Data.Comparers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override int DoCompare(
    Item item1,
    Item item2
)
Visual Basic
Protected Overrides Function DoCompare ( _
    item1 As Item, _
    item2 As Item _
) As Integer
Visual C++
protected:
virtual int DoCompare(
    Item^ item1,
    Item^ item2
) override

Parameters

item1
Type: Sitecore.Data.Items..::..Item
The item1.
item2
Type: Sitecore.Data.Items..::..Item
The item2.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Comparers.DefaultComparer.DoCompare(Sitecore.Data.Items.Item,Sitecore.Data.Items.Item)"]

See Also

DefaultComparer Class
Sitecore.Data.Comparers Namespace


DisplayNameComparer Class

[image]

Sitecore 6.4.1 API
DisplayNameComparer Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Comparers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DisplayNameComparer : Comparer
Visual Basic
Public Class DisplayNameComparer _
    Inherits Comparer
Visual C++
public ref class DisplayNameComparer : public Comparer

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Comparers..::..Comparer
Sitecore.Data.Comparers..::..DisplayNameComparer

See Also

DisplayNameComparer Members
Sitecore.Data.Comparers Namespace


DisplayNameComparer Members

[image] [image]

Sitecore 6.4.1 API
DisplayNameComparer Members
DisplayNameComparer Class Constructors Methods See Also Send Feedback

The DisplayNameComparer type exposes the following members.

Constructors

 | Name | Description
Public method | DisplayNameComparer | Initializes a new instance of the DisplayNameComparer class

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from Comparer.)
Protected method | DoCompare | Compares two items. (Overrides Comparer..::..DoCompare(Item, Item).)
Protected method | DoCompareSortorder | Compares the sortorder of two items. (Inherited from Comparer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DisplayNameComparer Class
Sitecore.Data.Comparers Namespace


DisplayNameComparer Constructor

[image]

Sitecore 6.4.1 API
DisplayNameComparer Constructor
DisplayNameComparer Class See Also Send Feedback

Namespace: Sitecore.Data.Comparers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DisplayNameComparer()
Visual Basic
Public Sub New
Visual C++
public:
DisplayNameComparer()

See Also

DisplayNameComparer Class
Sitecore.Data.Comparers Namespace


DisplayNameComparer Methods

[image] [image]

Sitecore 6.4.1 API
DisplayNameComparer Methods
DisplayNameComparer Class See Also Send Feedback

The DisplayNameComparer type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from Comparer.)
Protected method | DoCompare | Compares two items. (Overrides Comparer..::..DoCompare(Item, Item).)
Protected method | DoCompareSortorder | Compares the sortorder of two items. (Inherited from Comparer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DisplayNameComparer Class
Sitecore.Data.Comparers Namespace


DoCompare Method

[image]

Sitecore 6.4.1 API
DisplayNameComparer..::..DoCompare Method
DisplayNameComparer Class See Also Send Feedback

Namespace: Sitecore.Data.Comparers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override int DoCompare(
    Item item1,
    Item item2
)
Visual Basic
Protected Overrides Function DoCompare ( _
    item1 As Item, _
    item2 As Item _
) As Integer
Visual C++
protected:
virtual int DoCompare(
    Item^ item1,
    Item^ item2
) override

Parameters

item1
Type: Sitecore.Data.Items..::..Item
The item1.
item2
Type: Sitecore.Data.Items..::..Item
The item2.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Comparers.DisplayNameComparer.DoCompare(Sitecore.Data.Items.Item,Sitecore.Data.Items.Item)"]

See Also

DisplayNameComparer Class
Sitecore.Data.Comparers Namespace


IDComparer Class

[image]

Sitecore 6.4.1 API
IDComparer Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Comparers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class IDComparer : IComparer<ID>,
    IComparer
Visual Basic
Public Class IDComparer _
    Implements IComparer(Of ID), IComparer
Visual C++
public ref class IDComparer : IComparer<ID^>,
    IComparer

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Comparers..::..IDComparer

See Also

IDComparer Members
Sitecore.Data.Comparers Namespace


IDComparer Members

[image] [image]

Sitecore 6.4.1 API
IDComparer Members
IDComparer Class Constructors Methods See Also Send Feedback

The IDComparer type exposes the following members.

Constructors

 | Name | Description
Public method | IDComparer | Initializes a new instance of the IDComparer class

Methods

 | Name | Description
Public method | Compare(Object, Object) | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Public method | Compare(ID, ID) | Compares the specified items.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IDComparer Class
Sitecore.Data.Comparers Namespace


IDComparer Constructor

[image]

Sitecore 6.4.1 API
IDComparer Constructor
IDComparer Class See Also Send Feedback

Namespace: Sitecore.Data.Comparers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IDComparer()
Visual Basic
Public Sub New
Visual C++
public:
IDComparer()

See Also

IDComparer Class
Sitecore.Data.Comparers Namespace


IDComparer Methods

[image] [image]

Sitecore 6.4.1 API
IDComparer Methods
IDComparer Class See Also Send Feedback

The IDComparer type exposes the following members.

Methods

 | Name | Description
Public method | Compare(Object, Object) | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Public method | Compare(ID, ID) | Compares the specified items.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IDComparer Class
Sitecore.Data.Comparers Namespace


Compare Method

[image] [image]

Sitecore 6.4.1 API
IDComparer..::..Compare Method
IDComparer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Compare(Object, Object) | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Public method | Compare(ID, ID) | Compares the specified items.

See Also

IDComparer Class
IDComparer Members
Sitecore.Data.Comparers Namespace


Compare Method (ID, ID)

[image]

Sitecore 6.4.1 API
IDComparer..::..Compare Method (ID, ID)
IDComparer Class See Also Send Feedback

Namespace: Sitecore.Data.Comparers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Compare(
    ID id1,
    ID id2
)
Visual Basic
Public Function Compare ( _
    id1 As ID, _
    id2 As ID _
) As Integer
Visual C++
public:
virtual int Compare(
    ID^ id1,
    ID^ id2
) sealed

Parameters

id1
Type: Sitecore.Data..::..ID
Item1.
id2
Type: Sitecore.Data..::..ID
Item2.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Comparers.IDComparer.Compare(Sitecore.Data.ID,Sitecore.Data.ID)"]

Implements

IComparer<(Of <(<'T>)>)>..::..Compare(T, T)

See Also

IDComparer Class
Compare Overload
Sitecore.Data.Comparers Namespace


ItemComparer Class

[image]

Sitecore 6.4.1 API
ItemComparer Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Comparers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemComparer : IComparer<Item>
Visual Basic
Public Class ItemComparer _
    Implements IComparer(Of Item)
Visual C++
public ref class ItemComparer : IComparer<Item^>

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Comparers..::..ItemComparer

See Also

ItemComparer Members
Sitecore.Data.Comparers Namespace


ItemComparer Members

[image] [image]

Sitecore 6.4.1 API
ItemComparer Members
ItemComparer Class Constructors Methods See Also Send Feedback

The ItemComparer type exposes the following members.

Constructors

 | Name | Description
Public method | ItemComparer | Initializes a new instance of the ItemComparer class

Methods

 | Name | Description
Public method | Compare | Compares the specified items.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemComparer Class
Sitecore.Data.Comparers Namespace


ItemComparer Constructor

[image]

Sitecore 6.4.1 API
ItemComparer Constructor
ItemComparer Class See Also Send Feedback

Namespace: Sitecore.Data.Comparers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemComparer()
Visual Basic
Public Sub New
Visual C++
public:
ItemComparer()

See Also

ItemComparer Class
Sitecore.Data.Comparers Namespace


ItemComparer Methods

[image] [image]

Sitecore 6.4.1 API
ItemComparer Methods
ItemComparer Class See Also Send Feedback

The ItemComparer type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares the specified items.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemComparer Class
Sitecore.Data.Comparers Namespace


Compare Method

[image]

Sitecore 6.4.1 API
ItemComparer..::..Compare Method
ItemComparer Class See Also Send Feedback

Namespace: Sitecore.Data.Comparers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Compare(
    Item item1,
    Item item2
)
Visual Basic
Public Function Compare ( _
    item1 As Item, _
    item2 As Item _
) As Integer
Visual C++
public:
virtual int Compare(
    Item^ item1,
    Item^ item2
) sealed

Parameters

item1
Type: Sitecore.Data.Items..::..Item
Item1.
item2
Type: Sitecore.Data.Items..::..Item
Item2.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Comparers.ItemComparer.Compare(Sitecore.Data.Items.Item,Sitecore.Data.Items.Item)"]

Implements

IComparer<(Of <(<'T>)>)>..::..Compare(T, T)

See Also

ItemComparer Class
Sitecore.Data.Comparers Namespace


LogicalComparer Members

[image] [image]

Sitecore 6.4.1 API
LogicalComparer Members
LogicalComparer Class Constructors Methods See Also Send Feedback

The LogicalComparer type exposes the following members.

Constructors

 | Name | Description
Public method | LogicalComparer | Initializes a new instance of the LogicalComparer class

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from Comparer.)
Protected method | DoCompare | Compares two items. (Overrides Comparer..::..DoCompare(Item, Item).)
Protected method | DoCompareSortorder | Compares the sortorder of two items. (Inherited from Comparer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LogicalComparer Class
Sitecore.Data.Comparers Namespace


LogicalComparer Constructor

[image]

Sitecore 6.4.1 API
LogicalComparer Constructor
LogicalComparer Class See Also Send Feedback

Namespace: Sitecore.Data.Comparers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LogicalComparer()
Visual Basic
Public Sub New
Visual C++
public:
LogicalComparer()

See Also

LogicalComparer Class
Sitecore.Data.Comparers Namespace


LogicalComparer Methods

[image] [image]

Sitecore 6.4.1 API
LogicalComparer Methods
LogicalComparer Class See Also Send Feedback

The LogicalComparer type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from Comparer.)
Protected method | DoCompare | Compares two items. (Overrides Comparer..::..DoCompare(Item, Item).)
Protected method | DoCompareSortorder | Compares the sortorder of two items. (Inherited from Comparer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LogicalComparer Class
Sitecore.Data.Comparers Namespace


DoCompare Method

[image]

Sitecore 6.4.1 API
LogicalComparer..::..DoCompare Method
LogicalComparer Class See Also Send Feedback

Namespace: Sitecore.Data.Comparers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override int DoCompare(
    Item item1,
    Item item2
)
Visual Basic
Protected Overrides Function DoCompare ( _
    item1 As Item, _
    item2 As Item _
) As Integer
Visual C++
protected:
virtual int DoCompare(
    Item^ item1,
    Item^ item2
) override

Parameters

item1
Type: Sitecore.Data.Items..::..Item
The item1.
item2
Type: Sitecore.Data.Items..::..Item
The item2.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Comparers.LogicalComparer.DoCompare(Sitecore.Data.Items.Item,Sitecore.Data.Items.Item)"]

See Also

LogicalComparer Class
Sitecore.Data.Comparers Namespace


ReverseComparer Class

[image]

Sitecore 6.4.1 API
ReverseComparer Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Comparers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ReverseComparer : Comparer
Visual Basic
Public Class ReverseComparer _
    Inherits Comparer
Visual C++
public ref class ReverseComparer : public Comparer

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Comparers..::..Comparer
Sitecore.Data.Comparers..::..ReverseComparer

See Also

ReverseComparer Members
Sitecore.Data.Comparers Namespace


ReverseComparer Constructor

[image]

Sitecore 6.4.1 API
ReverseComparer Constructor
ReverseComparer Class See Also Send Feedback

Namespace: Sitecore.Data.Comparers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ReverseComparer()
Visual Basic
Public Sub New
Visual C++
public:
ReverseComparer()

See Also

ReverseComparer Class
Sitecore.Data.Comparers Namespace


ReverseComparer Methods

[image] [image]

Sitecore 6.4.1 API
ReverseComparer Methods
ReverseComparer Class See Also Send Feedback

The ReverseComparer type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from Comparer.)
Protected method | DoCompare | Compares two items. (Overrides Comparer..::..DoCompare(Item, Item).)
Protected method | DoCompareSortorder | Compares the sortorder of two items. (Overrides Comparer..::..DoCompareSortorder(Item, Item, Int32%).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReverseComparer Class
Sitecore.Data.Comparers Namespace


DoCompare Method

[image]

Sitecore 6.4.1 API
ReverseComparer..::..DoCompare Method
ReverseComparer Class See Also Send Feedback

Namespace: Sitecore.Data.Comparers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override int DoCompare(
    Item item1,
    Item item2
)
Visual Basic
Protected Overrides Function DoCompare ( _
    item1 As Item, _
    item2 As Item _
) As Integer
Visual C++
protected:
virtual int DoCompare(
    Item^ item1,
    Item^ item2
) override

Parameters

item1
Type: Sitecore.Data.Items..::..Item
The item1.
item2
Type: Sitecore.Data.Items..::..Item
The item2.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Comparers.ReverseComparer.DoCompare(Sitecore.Data.Items.Item,Sitecore.Data.Items.Item)"]

See Also

ReverseComparer Class
Sitecore.Data.Comparers Namespace


DoCompareSortorder Method

[image]

Sitecore 6.4.1 API
ReverseComparer..::..DoCompareSortorder Method
ReverseComparer Class See Also Send Feedback

Namespace: Sitecore.Data.Comparers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override bool DoCompareSortorder(
    Item item1,
    Item item2,
    out int result
)
Visual Basic
Protected Overrides Function DoCompareSortorder ( _
    item1 As Item, _
    item2 As Item, _
    <OutAttribute> ByRef result As Integer _
) As Boolean
Visual C++
protected:
virtual bool DoCompareSortorder(
    Item^ item1,
    Item^ item2,
    [OutAttribute] int% result
) override

Parameters

item1
Type: Sitecore.Data.Items..::..Item
The item1.
item2
Type: Sitecore.Data.Items..::..Item
The item2.
result
Type: System..::..Int32 %
The result.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Comparers.ReverseComparer.DoCompareSortorder(Sitecore.Data.Items.Item,Sitecore.Data.Items.Item,System.Int32@)"]

See Also

ReverseComparer Class
Sitecore.Data.Comparers Namespace


UpdatedComparer Class

[image]

Sitecore 6.4.1 API
UpdatedComparer Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Comparers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class UpdatedComparer : Comparer
Visual Basic
Public Class UpdatedComparer _
    Inherits Comparer
Visual C++
public ref class UpdatedComparer : public Comparer

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Comparers..::..Comparer
Sitecore.Data.Comparers..::..UpdatedComparer

See Also

UpdatedComparer Members
Sitecore.Data.Comparers Namespace


UpdatedComparer Members

[image] [image]

Sitecore 6.4.1 API
UpdatedComparer Members
UpdatedComparer Class Constructors Methods See Also Send Feedback

The UpdatedComparer type exposes the following members.

Constructors

 | Name | Description
Public method | UpdatedComparer | Initializes a new instance of the UpdatedComparer class

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from Comparer.)
Protected method | DoCompare | Compares two items. (Overrides Comparer..::..DoCompare(Item, Item).)
Protected method | DoCompareSortorder | Compares the sortorder of two items. (Inherited from Comparer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UpdatedComparer Class
Sitecore.Data.Comparers Namespace


UpdatedComparer Constructor

[image]

Sitecore 6.4.1 API
UpdatedComparer Constructor
UpdatedComparer Class See Also Send Feedback

Namespace: Sitecore.Data.Comparers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UpdatedComparer()
Visual Basic
Public Sub New
Visual C++
public:
UpdatedComparer()

See Also

UpdatedComparer Class
Sitecore.Data.Comparers Namespace


UpdatedComparer Methods

[image] [image]

Sitecore 6.4.1 API
UpdatedComparer Methods
UpdatedComparer Class See Also Send Feedback

The UpdatedComparer type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from Comparer.)
Protected method | DoCompare | Compares two items. (Overrides Comparer..::..DoCompare(Item, Item).)
Protected method | DoCompareSortorder | Compares the sortorder of two items. (Inherited from Comparer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UpdatedComparer Class
Sitecore.Data.Comparers Namespace


DoCompare Method

[image]

Sitecore 6.4.1 API
UpdatedComparer..::..DoCompare Method
UpdatedComparer Class See Also Send Feedback

Namespace: Sitecore.Data.Comparers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override int DoCompare(
    Item item1,
    Item item2
)
Visual Basic
Protected Overrides Function DoCompare ( _
    item1 As Item, _
    item2 As Item _
) As Integer
Visual C++
protected:
virtual int DoCompare(
    Item^ item1,
    Item^ item2
) override

Parameters

item1
Type: Sitecore.Data.Items..::..Item
The item1.
item2
Type: Sitecore.Data.Items..::..Item
The item2.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Comparers.UpdatedComparer.DoCompare(Sitecore.Data.Items.Item,Sitecore.Data.Items.Item)"]

See Also

UpdatedComparer Class
Sitecore.Data.Comparers Namespace


Sitecore.Data.Databases Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Data.Databases Namespace
Send Feedback

Classes

 | Class | Description
Public class | CustomDatabase | Defines the basic functionality of a custom database.
Public class | DomainDatabase | Encapsulates a security base database.


CustomDatabase Class

[image]

Sitecore 6.4.1 API
CustomDatabase Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Databases
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class CustomDatabase
Visual Basic
Public MustInherit Class CustomDatabase
Visual C++
public ref class CustomDatabase abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Databases..::..CustomDatabase
Sitecore.Data.Databases..::..DomainDatabase

See Also

CustomDatabase Members
Sitecore.Data.Databases Namespace


CustomDatabase Members

[image] [image]

Sitecore 6.4.1 API
CustomDatabase Members
CustomDatabase Class Constructors Methods Properties See Also Send Feedback

The CustomDatabase type exposes the following members.

Constructors

 | Name | Description
Protected method | CustomDatabase | Creates a new CustomDatabase instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SelectItems | Performs an Sitecore XPath query against the database.
Public method | SelectSingleItem | Performs an Sitecore XPath query against the database.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | InnerDatabase | Gets the inner database.
Public property | Items | Gets the items.
Public property | Name | Gets the name.

See Also

CustomDatabase Class
Sitecore.Data.Databases Namespace


CustomDatabase Constructor

[image]

Sitecore 6.4.1 API
CustomDatabase Constructor
CustomDatabase Class See Also Send Feedback

Namespace: Sitecore.Data.Databases
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected CustomDatabase(
    Database innerDatabase
)
Visual Basic
Protected Sub New ( _
    innerDatabase As Database _
)
Visual C++
protected:
CustomDatabase(
    Database^ innerDatabase
)

Parameters

innerDatabase
Type: Sitecore.Data..::..Database
Inner database.

See Also

CustomDatabase Class
Sitecore.Data.Databases Namespace


CustomDatabase Methods

[image] [image]

Sitecore 6.4.1 API
CustomDatabase Methods
CustomDatabase Class See Also Send Feedback

The CustomDatabase type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SelectItems | Performs an Sitecore XPath query against the database.
Public method | SelectSingleItem | Performs an Sitecore XPath query against the database.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomDatabase Class
Sitecore.Data.Databases Namespace


SelectItems Method

[image]

Sitecore 6.4.1 API
CustomDatabase..::..SelectItems Method
CustomDatabase Class See Also Send Feedback

Namespace: Sitecore.Data.Databases
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item[] SelectItems(
    string query
)
Visual Basic
Public Function SelectItems ( _
    query As String _
) As Item()
Visual C++
public:
array<Item^>^ SelectItems(
    String^ query
)

Parameters

query
Type: System..::..String
The query.

Return Value

The items.

See Also

CustomDatabase Class
Sitecore.Data.Databases Namespace


SelectSingleItem Method

[image]

Sitecore 6.4.1 API
CustomDatabase..::..SelectSingleItem Method
CustomDatabase Class See Also Send Feedback

Namespace: Sitecore.Data.Databases
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item SelectSingleItem(
    string query
)
Visual Basic
Public Function SelectSingleItem ( _
    query As String _
) As Item
Visual C++
public:
Item^ SelectSingleItem(
    String^ query
)

Parameters

query
Type: System..::..String
The query.

Return Value

The single item.

See Also

CustomDatabase Class
Sitecore.Data.Databases Namespace


CustomDatabase Properties

[image] [image]

Sitecore 6.4.1 API
CustomDatabase Properties
CustomDatabase Class See Also Send Feedback

The CustomDatabase type exposes the following members.

Properties

 | Name | Description
Public property | InnerDatabase | Gets the inner database.
Public property | Items | Gets the items.
Public property | Name | Gets the name.

See Also

CustomDatabase Class
Sitecore.Data.Databases Namespace


InnerDatabase Property

[image]

Sitecore 6.4.1 API
CustomDatabase..::..InnerDatabase Property
CustomDatabase Class See Also Send Feedback

Namespace: Sitecore.Data.Databases
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database InnerDatabase { get; }
Visual Basic
Public ReadOnly Property InnerDatabase As Database
    Get
Visual C++
public:
property Database^ InnerDatabase {
    Database^ get ();
}

Field Value

The inner database.

See Also

CustomDatabase Class
Sitecore.Data.Databases Namespace


Items Property

[image]

Sitecore 6.4.1 API
CustomDatabase..::..Items Property
CustomDatabase Class See Also Send Feedback

Namespace: Sitecore.Data.Databases
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemRecords Items { get; }
Visual Basic
Public ReadOnly Property Items As ItemRecords
    Get
Visual C++
public:
property ItemRecords^ Items {
    ItemRecords^ get ();
}

Field Value

The items.

See Also

CustomDatabase Class
Sitecore.Data.Databases Namespace


Name Property

[image]

Sitecore 6.4.1 API
CustomDatabase..::..Name Property
CustomDatabase Class See Also Send Feedback

Namespace: Sitecore.Data.Databases
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

CustomDatabase Class
Sitecore.Data.Databases Namespace


DomainDatabase Class

[image]

Sitecore 6.4.1 API
DomainDatabase Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Databases
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DomainDatabase : CustomDatabase
Visual Basic
Public Class DomainDatabase _
    Inherits CustomDatabase
Visual C++
public ref class DomainDatabase : public CustomDatabase

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Databases..::..CustomDatabase
Sitecore.Data.Databases..::..DomainDatabase

See Also

DomainDatabase Members
Sitecore.Data.Databases Namespace


DomainDatabase Members

[image] [image]

Sitecore 6.4.1 API
DomainDatabase Members
DomainDatabase Class Constructors Methods Operators Properties See Also Send Feedback

The DomainDatabase type exposes the following members.

Constructors

 | Name | Description
Public method | DomainDatabase | Creates a new DomainDatabase instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRoleNames | Gets the role names defined in the database.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SelectItems | Performs an Sitecore XPath query against the database. (Inherited from CustomDatabase.)
Public method | SelectSingleItem | Performs an Sitecore XPath query against the database. (Inherited from CustomDatabase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Database to DomainDatabase) | Implicit operators the specified database.

Properties

 | Name | Description
Public property | InnerDatabase | Gets the inner database. (Inherited from CustomDatabase.)
Public property | Items | Gets the items. (Inherited from CustomDatabase.)
Public property | Name | Gets the name. (Inherited from CustomDatabase.)

See Also

DomainDatabase Class
Sitecore.Data.Databases Namespace


DomainDatabase Constructor

[image]

Sitecore 6.4.1 API
DomainDatabase Constructor
DomainDatabase Class See Also Send Feedback

Namespace: Sitecore.Data.Databases
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DomainDatabase(
    Database innerDatabase
)
Visual Basic
Public Sub New ( _
    innerDatabase As Database _
)
Visual C++
public:
DomainDatabase(
    Database^ innerDatabase
)

Parameters

innerDatabase
Type: Sitecore.Data..::..Database
Inner database.

See Also

DomainDatabase Class
Sitecore.Data.Databases Namespace


DomainDatabase Methods

[image] [image]

Sitecore 6.4.1 API
DomainDatabase Methods
DomainDatabase Class See Also Send Feedback

The DomainDatabase type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRoleNames | Gets the role names defined in the database.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SelectItems | Performs an Sitecore XPath query against the database. (Inherited from CustomDatabase.)
Public method | SelectSingleItem | Performs an Sitecore XPath query against the database. (Inherited from CustomDatabase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DomainDatabase Class
Sitecore.Data.Databases Namespace


GetRoleNames Method

[image]

Sitecore 6.4.1 API
DomainDatabase..::..GetRoleNames Method
DomainDatabase Class See Also Send Feedback

Namespace: Sitecore.Data.Databases
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string[] GetRoleNames()
Visual Basic
Public Function GetRoleNames As String()
Visual C++
public:
array<String^>^ GetRoleNames()

Return Value

The role names.

See Also

DomainDatabase Class
Sitecore.Data.Databases Namespace


DomainDatabase Type Conversions

[image] [image]

Sitecore 6.4.1 API
DomainDatabase Type Conversions
DomainDatabase Class See Also Send Feedback

The DomainDatabase type exposes the following members.

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Database to DomainDatabase) | Implicit operators the specified database.

See Also

DomainDatabase Class
Sitecore.Data.Databases Namespace


Implicit Conversion (Database to DomainDatabase)

[image]

Sitecore 6.4.1 API
DomainDatabase ImplicitWideningImplicitImplicitImplicit Conversion (Database to DomainDatabase)
DomainDatabase Class See Also Send Feedback

Namespace: Sitecore.Data.Databases
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator DomainDatabase (
    Database database
)
Visual Basic
Public Shared Widening Operator CType ( _
    database As Database _
) As DomainDatabase
Visual C++
static implicit operator DomainDatabase^ (
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

Return Value

The implicit operator.

See Also

DomainDatabase Class
Sitecore.Data.Databases Namespace


Sitecore.Data.DataProviders Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Data.DataProviders Namespace
Send Feedback

Classes

 | Class | Description
Public class | CacheOptions | Represents a set of cache options.
Public class | CallContext | Represents a call context.
Public class | DatabaseViewStateStore | Serializes ViewState using the ClientContext.DataStore object.
Public class | DataProvider | DataProvider
Public class | FileSystemDataProvider | Represents a file system data provider.
Public class | HelloWorldProvider | Test class
Public class | PrefetchData | Prefetch data container
Public class | PropertyStore | Defines the basic methods of a property store.
Public class | TemplateFileResolver | Represents a template file resolver.


CacheOptions Class

[image]

Sitecore 6.4.1 API
CacheOptions Class
Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CacheOptions
Visual Basic
Public Class CacheOptions
Visual C++
public ref class CacheOptions

Inheritance Hierarchy

System..::..Object
Sitecore.Data.DataProviders..::..CacheOptions

See Also

CacheOptions Members
Sitecore.Data.DataProviders Namespace


CacheOptions Members

[image] [image]

Sitecore 6.4.1 API
CacheOptions Members
CacheOptions Class Constructors Methods Properties See Also Send Feedback

The CacheOptions type exposes the following members.

Constructors

 | Name | Description
Public method | CacheOptions | Initializes a new instance of the CacheOptions class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DisableAll | Gets or sets a value indicating whether the CacheOptions disables all.

See Also

CacheOptions Class
Sitecore.Data.DataProviders Namespace


CacheOptions Constructor

[image]

Sitecore 6.4.1 API
CacheOptions Constructor
CacheOptions Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CacheOptions()
Visual Basic
Public Sub New
Visual C++
public:
CacheOptions()

See Also

CacheOptions Class
Sitecore.Data.DataProviders Namespace


CacheOptions Methods

[image] [image]

Sitecore 6.4.1 API
CacheOptions Methods
CacheOptions Class See Also Send Feedback

The CacheOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CacheOptions Class
Sitecore.Data.DataProviders Namespace


CacheOptions Properties

[image] [image]

Sitecore 6.4.1 API
CacheOptions Properties
CacheOptions Class See Also Send Feedback

The CacheOptions type exposes the following members.

Properties

 | Name | Description
Public property | DisableAll | Gets or sets a value indicating whether the CacheOptions disables all.

See Also

CacheOptions Class
Sitecore.Data.DataProviders Namespace


DisableAll Property

[image]

Sitecore 6.4.1 API
CacheOptions..::..DisableAll Property
CacheOptions Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool DisableAll { get; set; }
Visual Basic
Public Property DisableAll As Boolean
    Get
    Set
Visual C++
public:
property bool DisableAll {
    bool get ();
    void set (bool value);
}

Field Value

true if the CacheOptions disables all; otherwise, false.

See Also

CacheOptions Class
Sitecore.Data.DataProviders Namespace


CallContext Class

[image]

Sitecore 6.4.1 API
CallContext Class
Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CallContext
Visual Basic
Public Class CallContext
Visual C++
public ref class CallContext

Inheritance Hierarchy

System..::..Object
Sitecore.Data.DataProviders..::..CallContext

See Also

CallContext Members
Sitecore.Data.DataProviders Namespace


CallContext Members

[image] [image]

Sitecore 6.4.1 API
CallContext Members
CallContext Class Constructors Methods Properties See Also Send Feedback

The CallContext type exposes the following members.

Constructors

 | Name | Description
Public method | CallContext | Initializes a new instance of the CallContext class.

Methods

 | Name | Description
Public method | Abort | Aborts this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetNextIndex | Sets the index of the next.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this CallContext is aborted.
Public property | CurrentResult | Gets or sets the current result.
Public property | DataManager | Gets the data manager.
Public property | Index | Gets the index.
Public property | ProviderCount | Gets the provider count.

See Also

CallContext Class
Sitecore.Data.DataProviders Namespace


CallContext Constructor

[image]

Sitecore 6.4.1 API
CallContext Constructor
CallContext Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CallContext(
    DataManager manager,
    int providerCount
)
Visual Basic
Public Sub New ( _
    manager As DataManager, _
    providerCount As Integer _
)
Visual C++
public:
CallContext(
    DataManager^ manager,
    int providerCount
)

Parameters

manager
Type: Sitecore.Data..::..DataManager
The manager.
providerCount
Type: System..::..Int32
The provider count.

See Also

CallContext Class
Sitecore.Data.DataProviders Namespace


CallContext Methods

[image] [image]

Sitecore 6.4.1 API
CallContext Methods
CallContext Class See Also Send Feedback

The CallContext type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Aborts this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetNextIndex | Sets the index of the next.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CallContext Class
Sitecore.Data.DataProviders Namespace


SetNextIndex Method

[image]

Sitecore 6.4.1 API
CallContext..::..SetNextIndex Method
CallContext Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetNextIndex(
    int value
)
Visual Basic
Public Sub SetNextIndex ( _
    value As Integer _
)
Visual C++
public:
void SetNextIndex(
    int value
)

Parameters

value
Type: System..::..Int32
The value.

See Also

CallContext Class
Sitecore.Data.DataProviders Namespace


CallContext Properties

[image] [image]

Sitecore 6.4.1 API
CallContext Properties
CallContext Class See Also Send Feedback

The CallContext type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this CallContext is aborted.
Public property | CurrentResult | Gets or sets the current result.
Public property | DataManager | Gets the data manager.
Public property | Index | Gets the index.
Public property | ProviderCount | Gets the provider count.

See Also

CallContext Class
Sitecore.Data.DataProviders Namespace


Aborted Property

[image]

Sitecore 6.4.1 API
CallContext..::..Aborted Property
CallContext Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Aborted { get; }
Visual Basic
Public ReadOnly Property Aborted As Boolean
    Get
Visual C++
public:
property bool Aborted {
    bool get ();
}

Field Value

true if aborted; otherwise, false.

See Also

CallContext Class
Sitecore.Data.DataProviders Namespace


CurrentResult Property

[image]

Sitecore 6.4.1 API
CallContext..::..CurrentResult Property
CallContext Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object CurrentResult { get; set; }
Visual Basic
Public Property CurrentResult As Object
    Get
    Set
Visual C++
public:
property Object^ CurrentResult {
    Object^ get ();
    void set (Object^ value);
}

Field Value

The current result.

See Also

CallContext Class
Sitecore.Data.DataProviders Namespace


DataManager Property

[image]

Sitecore 6.4.1 API
CallContext..::..DataManager Property
CallContext Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataManager DataManager { get; }
Visual Basic
Public ReadOnly Property DataManager As DataManager
    Get
Visual C++
public:
property DataManager^ DataManager {
    DataManager^ get ();
}

Field Value

The data manager.

See Also

CallContext Class
Sitecore.Data.DataProviders Namespace


Index Property

[image]

Sitecore 6.4.1 API
CallContext..::..Index Property
CallContext Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Index { get; }
Visual Basic
Public ReadOnly Property Index As Integer
    Get
Visual C++
public:
property int Index {
    int get ();
}

Field Value

The index.

See Also

CallContext Class
Sitecore.Data.DataProviders Namespace


ProviderCount Property

[image]

Sitecore 6.4.1 API
CallContext..::..ProviderCount Property
CallContext Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int ProviderCount { get; }
Visual Basic
Public ReadOnly Property ProviderCount As Integer
    Get
Visual C++
public:
property int ProviderCount {
    int get ();
}

Field Value

The provider count.

See Also

CallContext Class
Sitecore.Data.DataProviders Namespace


DatabaseViewStateStore Class

[image]

Sitecore 6.4.1 API
DatabaseViewStateStore Class
Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DatabaseViewStateStore : IViewStateStore
Visual Basic
Public Class DatabaseViewStateStore _
    Implements IViewStateStore
Visual C++
public ref class DatabaseViewStateStore : IViewStateStore

Inheritance Hierarchy

System..::..Object
Sitecore.Data.DataProviders..::..DatabaseViewStateStore

See Also

DatabaseViewStateStore Members
Sitecore.Data.DataProviders Namespace


DatabaseViewStateStore Members

[image] [image]

Sitecore 6.4.1 API
DatabaseViewStateStore Members
DatabaseViewStateStore Class Constructors Methods See Also Send Feedback

The DatabaseViewStateStore type exposes the following members.

Constructors

 | Name | Description
Public method | DatabaseViewStateStore | Initializes a new instance of the DatabaseViewStateStore class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Loads viewstate data by the the specified key.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes data that has the specified key.
Public method | Save | Saves the viewstate data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DatabaseViewStateStore Class
Sitecore.Data.DataProviders Namespace


DatabaseViewStateStore Constructor

[image]

Sitecore 6.4.1 API
DatabaseViewStateStore Constructor
DatabaseViewStateStore Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DatabaseViewStateStore()
Visual Basic
Public Sub New
Visual C++
public:
DatabaseViewStateStore()

See Also

DatabaseViewStateStore Class
Sitecore.Data.DataProviders Namespace


DatabaseViewStateStore Methods

[image] [image]

Sitecore 6.4.1 API
DatabaseViewStateStore Methods
DatabaseViewStateStore Class See Also Send Feedback

The DatabaseViewStateStore type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Loads viewstate data by the the specified key.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes data that has the specified key.
Public method | Save | Saves the viewstate data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DatabaseViewStateStore Class
Sitecore.Data.DataProviders Namespace


Load Method

[image]

Sitecore 6.4.1 API
DatabaseViewStateStore..::..Load Method
DatabaseViewStateStore Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Load(
    string key
)
Visual Basic
Public Function Load ( _
    key As String _
) As String
Visual C++
public:
virtual String^ Load(
    String^ key
) sealed

Parameters

key
Type: System..::..String
The key.

Return Value

The loaded data.

Implements

IViewStateStore..::..Load(String)

See Also

DatabaseViewStateStore Class
Sitecore.Data.DataProviders Namespace


Remove Method

[image]

Sitecore 6.4.1 API
DatabaseViewStateStore..::..Remove Method
DatabaseViewStateStore Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Remove(
    string key
)
Visual Basic
Public Sub Remove ( _
    key As String _
)
Visual C++
public:
virtual void Remove(
    String^ key
) sealed

Parameters

key
Type: System..::..String
The key.

Implements

IViewStateStore..::..Remove(String)

See Also

DatabaseViewStateStore Class
Sitecore.Data.DataProviders Namespace


Save Method

[image]

Sitecore 6.4.1 API
DatabaseViewStateStore..::..Save Method
DatabaseViewStateStore Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Save(
    string key,
    string viewstate
)
Visual Basic
Public Sub Save ( _
    key As String, _
    viewstate As String _
)
Visual C++
public:
virtual void Save(
    String^ key,
    String^ viewstate
) sealed

Parameters

key
Type: System..::..String
The key.
viewstate
Type: System..::..String
The viewstate.

Implements

IViewStateStore..::..Save(String, String)

See Also

DatabaseViewStateStore Class
Sitecore.Data.DataProviders Namespace


DataProvider Class

[image]

Sitecore 6.4.1 API
DataProvider Class
Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class DataProvider
Visual Basic
Public MustInherit Class DataProvider
Visual C++
public ref class DataProvider abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Data.DataProviders..::..DataProvider
Sitecore.Data.DataProviders..::..FileSystemDataProvider
Sitecore.Data.DataProviders..::..HelloWorldProvider
Sitecore.Data.DataProviders.Sql..::..SqlDataProvider
Sitecore.Data.DataProviders..::..TemplateFileResolver
Sitecore.Data.Serialization.Templates..::..SerializationTemplateProvider

See Also

DataProvider Members
Sitecore.Data.DataProviders Namespace


DataProvider Members

[image] [image]

Sitecore 6.4.1 API
DataProvider Members
DataProvider Class Constructors Methods Properties See Also Send Feedback

The DataProvider type exposes the following members.

Constructors

 | Name | Description
Protected method | DataProvider | Initializes a new instance of the DataProvider class

Methods

 | Name | Description
Public method | AddToPublishQueue | Adds an item to the publish queue.
Public method | AddVersion | Adds a version to an item.
Public method | BlobStreamExists | Determines whether the specified field contains a BLOB value.
Public method | ChangeFieldSharing | Changes the type of field sharing for a single field.
Public method | ChangeTemplate | Changes the template of an item.
Public method | CleanupDatabase | Cleans up the database.
Public method | CleanupPublishQueue | Cleans up the publish queue.
Public method | CopyItem | Copies an item.
Public method | CreateItem | Creates a item.
Public method | DeleteItem | Deletes an item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBlobStream | Gets the BLOB stream associated with a field.
Public method | GetChildIDs | Gets the child ids of an item.
Public method | GetDataSize | Gets the size of the data managed by the provider.
Public method | GetDictionaryEntryCount | Gets the number of dictionary entries.
Public method | GetEventQueue | Gets the event queue driver.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemDefinition | Gets the definition of an item.
Public method | GetItemFields | Gets the fields of a specific item version.
Public method | GetItemsInWorkflowState | Gets all items that are in a specific workflow state.
Public method | GetItemVersions | Gets a list of the available versions of an item.
Public method | GetLanguages | Gets a list of all the language that have been defined in the database.
Public method | GetParentID | Gets the parent ID of an item.
Public method | GetProperty | Gets a property.
Public method | GetPropertyKeys | Gets a list of property keys matching a specific prefix.
Public method | GetPublishQueue | Gets the publish queue.
Public method | GetRootID | Gets the root ID.
Public method | GetTemplateItemIds | Gets the template item ids.
Public method | GetTemplates | Gets the templates.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWorkflowInfo | Gets the workflow info form an item.
Public method | HasChildren | Determines whether the specified item definition has children.
Public method | IsEnabled | Determines whether the specified method is enabled.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveItem | Moves an item (ie. changes its parent).
Public method | RemoveLanguageData | Removes a language and all the data using the language from the database.
Public method | RemoveProperty | Removes a property.
Public method | RemoveVersion | Removes a version from an item.
Public method | RemoveVersions(ItemDefinition, Language, CallContext) | Removes versions from an item.
Public method | RemoveVersions(ItemDefinition, Language, Boolean, CallContext) | Removes versions from an item.
Public method | RenameLanguageData | Renames a language binding.
Public method | ResolvePath | Resolves the path.
Public method | SaveItem | Saves an item.
Public method | SelectIDs | Selects a set of ids.
Public method | SelectSingleID | Selects a single ID.
Public method | SetBlobStream | Sets the BLOB stream associated with a field.
Public method | SetProperty | Sets a property.
Public method | SetWorkflowInfo | Sets the workflow info for an item.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CacheOptions | Gets the cache options.
Public property | Database | Gets the database.
Protected property | Disable | Disables a method.
Protected property | DisableGroup | Disables a group.
Protected property | Enable | Enables a method.
Protected property | EnableGroup | Enables a group.

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


DataProvider Constructor

[image]

Sitecore 6.4.1 API
DataProvider Constructor
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected DataProvider()
Visual Basic
Protected Sub New
Visual C++
protected:
DataProvider()

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


DataProvider Methods

[image] [image]

Sitecore 6.4.1 API
DataProvider Methods
DataProvider Class See Also Send Feedback

The DataProvider type exposes the following members.

Methods

 | Name | Description
Public method | AddToPublishQueue | Adds an item to the publish queue.
Public method | AddVersion | Adds a version to an item.
Public method | BlobStreamExists | Determines whether the specified field contains a BLOB value.
Public method | ChangeFieldSharing | Changes the type of field sharing for a single field.
Public method | ChangeTemplate | Changes the template of an item.
Public method | CleanupDatabase | Cleans up the database.
Public method | CleanupPublishQueue | Cleans up the publish queue.
Public method | CopyItem | Copies an item.
Public method | CreateItem | Creates a item.
Public method | DeleteItem | Deletes an item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBlobStream | Gets the BLOB stream associated with a field.
Public method | GetChildIDs | Gets the child ids of an item.
Public method | GetDataSize | Gets the size of the data managed by the provider.
Public method | GetDictionaryEntryCount | Gets the number of dictionary entries.
Public method | GetEventQueue | Gets the event queue driver.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemDefinition | Gets the definition of an item.
Public method | GetItemFields | Gets the fields of a specific item version.
Public method | GetItemsInWorkflowState | Gets all items that are in a specific workflow state.
Public method | GetItemVersions | Gets a list of the available versions of an item.
Public method | GetLanguages | Gets a list of all the language that have been defined in the database.
Public method | GetParentID | Gets the parent ID of an item.
Public method | GetProperty | Gets a property.
Public method | GetPropertyKeys | Gets a list of property keys matching a specific prefix.
Public method | GetPublishQueue | Gets the publish queue.
Public method | GetRootID | Gets the root ID.
Public method | GetTemplateItemIds | Gets the template item ids.
Public method | GetTemplates | Gets the templates.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWorkflowInfo | Gets the workflow info form an item.
Public method | HasChildren | Determines whether the specified item definition has children.
Public method | IsEnabled | Determines whether the specified method is enabled.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveItem | Moves an item (ie. changes its parent).
Public method | RemoveLanguageData | Removes a language and all the data using the language from the database.
Public method | RemoveProperty | Removes a property.
Public method | RemoveVersion | Removes a version from an item.
Public method | RemoveVersions(ItemDefinition, Language, CallContext) | Removes versions from an item.
Public method | RemoveVersions(ItemDefinition, Language, Boolean, CallContext) | Removes versions from an item.
Public method | RenameLanguageData | Renames a language binding.
Public method | ResolvePath | Resolves the path.
Public method | SaveItem | Saves an item.
Public method | SelectIDs | Selects a set of ids.
Public method | SelectSingleID | Selects a single ID.
Public method | SetBlobStream | Sets the BLOB stream associated with a field.
Public method | SetProperty | Sets a property.
Public method | SetWorkflowInfo | Sets the workflow info for an item.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


AddToPublishQueue Method

[image]

Sitecore 6.4.1 API
DataProvider..::..AddToPublishQueue Method
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool AddToPublishQueue(
    ID itemID,
    string action,
    DateTime date,
    CallContext context
)
Visual Basic
Public Overridable Function AddToPublishQueue ( _
    itemID As ID, _
    action As String, _
    date As DateTime, _
    context As CallContext _
) As Boolean
Visual C++
public:
virtual bool AddToPublishQueue(
    ID^ itemID,
    String^ action,
    DateTime date,
    CallContext^ context
)

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.
action
Type: System..::..String
The action.
date
Type: System..::..DateTime
The date.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.DataProvider.AddToPublishQueue(Sitecore.Data.ID,System.String,System.DateTime,Sitecore.Data.DataProviders.CallContext)"]

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


AddVersion Method

[image]

Sitecore 6.4.1 API
DataProvider..::..AddVersion Method
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual int AddVersion(
    ItemDefinition itemDefinition,
    VersionUri baseVersion,
    CallContext context
)
Visual Basic
Public Overridable Function AddVersion ( _
    itemDefinition As ItemDefinition, _
    baseVersion As VersionUri, _
    context As CallContext _
) As Integer
Visual C++
public:
virtual int AddVersion(
    ItemDefinition^ itemDefinition,
    VersionUri^ baseVersion,
    CallContext^ context
)

Parameters

itemDefinition
Type: Sitecore.Data..::..ItemDefinition
The item definition.
baseVersion
Type: Sitecore.Data..::..VersionUri
The base version.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.DataProvider.AddVersion(Sitecore.Data.ItemDefinition,Sitecore.Data.VersionUri,Sitecore.Data.DataProviders.CallContext)"]

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


BlobStreamExists Method

[image]

Sitecore 6.4.1 API
DataProvider..::..BlobStreamExists Method
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool BlobStreamExists(
    Guid blobId,
    CallContext context
)
Visual Basic
Public Overridable Function BlobStreamExists ( _
    blobId As Guid, _
    context As CallContext _
) As Boolean
Visual C++
public:
virtual bool BlobStreamExists(
    Guid blobId,
    CallContext^ context
)

Parameters

blobId
Type: System..::..Guid
The BLOB id.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

true if the specified item definition has children; otherwise, false.

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


ChangeFieldSharing Method

[image]

Sitecore 6.4.1 API
DataProvider..::..ChangeFieldSharing Method
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool ChangeFieldSharing(
    TemplateField fieldDefinition,
    TemplateFieldSharing sharing,
    CallContext context
)
Visual Basic
Public Overridable Function ChangeFieldSharing ( _
    fieldDefinition As TemplateField, _
    sharing As TemplateFieldSharing, _
    context As CallContext _
) As Boolean
Visual C++
public:
virtual bool ChangeFieldSharing(
    TemplateField^ fieldDefinition,
    TemplateFieldSharing sharing,
    CallContext^ context
)

Parameters

fieldDefinition
Type: Sitecore.Data.Templates..::..TemplateField
The field definition.
sharing
Type: Sitecore.Data.Templates..::..TemplateFieldSharing
The new sharing type.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.DataProvider.ChangeFieldSharing(Sitecore.Data.Templates.TemplateField,Sitecore.Data.Templates.TemplateFieldSharing,Sitecore.Data.DataProviders.CallContext)"]

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


ChangeTemplate Method

[image]

Sitecore 6.4.1 API
DataProvider..::..ChangeTemplate Method
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool ChangeTemplate(
    ItemDefinition itemDefinition,
    TemplateChangeList changes,
    CallContext context
)
Visual Basic
Public Overridable Function ChangeTemplate ( _
    itemDefinition As ItemDefinition, _
    changes As TemplateChangeList, _
    context As CallContext _
) As Boolean
Visual C++
public:
virtual bool ChangeTemplate(
    ItemDefinition^ itemDefinition,
    TemplateChangeList^ changes,
    CallContext^ context
)

Parameters

itemDefinition
Type: Sitecore.Data..::..ItemDefinition
The item definition.
changes
Type: Sitecore.Data.Templates..::..TemplateChangeList
The changes.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.DataProvider.ChangeTemplate(Sitecore.Data.ItemDefinition,Sitecore.Data.Templates.TemplateChangeList,Sitecore.Data.DataProviders.CallContext)"]

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


CleanupPublishQueue Method

[image]

Sitecore 6.4.1 API
DataProvider..::..CleanupPublishQueue Method
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool CleanupPublishQueue(
    DateTime to,
    CallContext context
)
Visual Basic
Public Overridable Function CleanupPublishQueue ( _
    to As DateTime, _
    context As CallContext _
) As Boolean
Visual C++
public:
virtual bool CleanupPublishQueue(
    DateTime to,
    CallContext^ context
)

Parameters

to
Type: System..::..DateTime
To.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.DataProvider.CleanupPublishQueue(System.DateTime,Sitecore.Data.DataProviders.CallContext)"]

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


CopyItem Method

[image]

Sitecore 6.4.1 API
DataProvider..::..CopyItem Method
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool CopyItem(
    ItemDefinition source,
    ItemDefinition destination,
    string copyName,
    ID copyID,
    CallContext context
)
Visual Basic
Public Overridable Function CopyItem ( _
    source As ItemDefinition, _
    destination As ItemDefinition, _
    copyName As String, _
    copyID As ID, _
    context As CallContext _
) As Boolean
Visual C++
public:
virtual bool CopyItem(
    ItemDefinition^ source,
    ItemDefinition^ destination,
    String^ copyName,
    ID^ copyID,
    CallContext^ context
)

Parameters

source
Type: Sitecore.Data..::..ItemDefinition
The source.
destination
Type: Sitecore.Data..::..ItemDefinition
The destination.
copyName
Type: System..::..String
Name of the copy.
copyID
Type: Sitecore.Data..::..ID
The copy ID.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.DataProvider.CopyItem(Sitecore.Data.ItemDefinition,Sitecore.Data.ItemDefinition,System.String,Sitecore.Data.ID,Sitecore.Data.DataProviders.CallContext)"]

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


CreateItem Method

[image]

Sitecore 6.4.1 API
DataProvider..::..CreateItem Method
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool CreateItem(
    ID itemID,
    string itemName,
    ID templateID,
    ItemDefinition parent,
    CallContext context
)
Visual Basic
Public Overridable Function CreateItem ( _
    itemID As ID, _
    itemName As String, _
    templateID As ID, _
    parent As ItemDefinition, _
    context As CallContext _
) As Boolean
Visual C++
public:
virtual bool CreateItem(
    ID^ itemID,
    String^ itemName,
    ID^ templateID,
    ItemDefinition^ parent,
    CallContext^ context
)

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.
itemName
Type: System..::..String
Name of the item.
templateID
Type: Sitecore.Data..::..ID
The template ID.
parent
Type: Sitecore.Data..::..ItemDefinition
The parent.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.DataProvider.CreateItem(Sitecore.Data.ID,System.String,Sitecore.Data.ID,Sitecore.Data.ItemDefinition,Sitecore.Data.DataProviders.CallContext)"]

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


DeleteItem Method

[image]

Sitecore 6.4.1 API
DataProvider..::..DeleteItem Method
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool DeleteItem(
    ItemDefinition itemDefinition,
    CallContext context
)
Visual Basic
Public Overridable Function DeleteItem ( _
    itemDefinition As ItemDefinition, _
    context As CallContext _
) As Boolean
Visual C++
public:
virtual bool DeleteItem(
    ItemDefinition^ itemDefinition,
    CallContext^ context
)

Parameters

itemDefinition
Type: Sitecore.Data..::..ItemDefinition
The item definition.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.DataProvider.DeleteItem(Sitecore.Data.ItemDefinition,Sitecore.Data.DataProviders.CallContext)"]

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


GetBlobStream Method

[image]

Sitecore 6.4.1 API
DataProvider..::..GetBlobStream Method
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Stream GetBlobStream(
    Guid blobId,
    CallContext context
)
Visual Basic
Public Overridable Function GetBlobStream ( _
    blobId As Guid, _
    context As CallContext _
) As Stream
Visual C++
public:
virtual Stream^ GetBlobStream(
    Guid blobId,
    CallContext^ context
)

Parameters

blobId
Type: System..::..Guid
The BLOB id.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The call context.

Return Value

The stream.

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


GetChildIDs Method

[image]

Sitecore 6.4.1 API
DataProvider..::..GetChildIDs Method
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual IDList GetChildIDs(
    ItemDefinition itemDefinition,
    CallContext context
)
Visual Basic
Public Overridable Function GetChildIDs ( _
    itemDefinition As ItemDefinition, _
    context As CallContext _
) As IDList
Visual C++
public:
virtual IDList^ GetChildIDs(
    ItemDefinition^ itemDefinition,
    CallContext^ context
)

Parameters

itemDefinition
Type: Sitecore.Data..::..ItemDefinition
The item definition.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.DataProvider.GetChildIDs(Sitecore.Data.ItemDefinition,Sitecore.Data.DataProviders.CallContext)"]

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


GetDataSize Method

[image]

Sitecore 6.4.1 API
DataProvider..::..GetDataSize Method
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual long GetDataSize(
    int minEntitySize,
    int maxEntitySize
)
Visual Basic
Public Overridable Function GetDataSize ( _
    minEntitySize As Integer, _
    maxEntitySize As Integer _
) As Long
Visual C++
public:
virtual long long GetDataSize(
    int minEntitySize,
    int maxEntitySize
)

Parameters

minEntitySize
Type: System..::..Int32

[Missing <param name="minEntitySize"/> documentation for "M:Sitecore.Data.DataProviders.DataProvider.GetDataSize(System.Int32,System.Int32)"]

maxEntitySize
Type: System..::..Int32

[Missing <param name="maxEntitySize"/> documentation for "M:Sitecore.Data.DataProviders.DataProvider.GetDataSize(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.DataProvider.GetDataSize(System.Int32,System.Int32)"]

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


GetDictionaryEntryCount Method

[image]

Sitecore 6.4.1 API
DataProvider..::..GetDictionaryEntryCount Method
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual long GetDictionaryEntryCount()
Visual Basic
Public Overridable Function GetDictionaryEntryCount As Long
Visual C++
public:
virtual long long GetDictionaryEntryCount()

Return Value

The number of dictionary entries.

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


GetEventQueue Method

[image]

Sitecore 6.4.1 API
DataProvider..::..GetEventQueue Method
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual EventQueue GetEventQueue()
Visual Basic
Public Overridable Function GetEventQueue As EventQueue
Visual C++
public:
virtual EventQueue^ GetEventQueue()

Return Value

The event queue driver.

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


GetItemFields Method

[image]

Sitecore 6.4.1 API
DataProvider..::..GetItemFields Method
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual FieldList GetItemFields(
    ItemDefinition itemDefinition,
    VersionUri versionUri,
    CallContext context
)
Visual Basic
Public Overridable Function GetItemFields ( _
    itemDefinition As ItemDefinition, _
    versionUri As VersionUri, _
    context As CallContext _
) As FieldList
Visual C++
public:
virtual FieldList^ GetItemFields(
    ItemDefinition^ itemDefinition,
    VersionUri^ versionUri,
    CallContext^ context
)

Parameters

itemDefinition
Type: Sitecore.Data..::..ItemDefinition
The item.
versionUri
Type: Sitecore.Data..::..VersionUri
The version URI.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.DataProvider.GetItemFields(Sitecore.Data.ItemDefinition,Sitecore.Data.VersionUri,Sitecore.Data.DataProviders.CallContext)"]

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


GetItemsInWorkflowState Method

[image]

Sitecore 6.4.1 API
DataProvider..::..GetItemsInWorkflowState Method
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual DataUri[] GetItemsInWorkflowState(
    WorkflowInfo info,
    CallContext context
)
Visual Basic
Public Overridable Function GetItemsInWorkflowState ( _
    info As WorkflowInfo, _
    context As CallContext _
) As DataUri()
Visual C++
public:
virtual array<DataUri^>^ GetItemsInWorkflowState(
    WorkflowInfo^ info,
    CallContext^ context
)

Parameters

info
Type: Sitecore.Workflows..::..WorkflowInfo
The info.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.DataProvider.GetItemsInWorkflowState(Sitecore.Workflows.WorkflowInfo,Sitecore.Data.DataProviders.CallContext)"]

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


GetItemVersions Method

[image]

Sitecore 6.4.1 API
DataProvider..::..GetItemVersions Method
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual VersionUriList GetItemVersions(
    ItemDefinition itemDefinition,
    CallContext context
)
Visual Basic
Public Overridable Function GetItemVersions ( _
    itemDefinition As ItemDefinition, _
    context As CallContext _
) As VersionUriList
Visual C++
public:
virtual VersionUriList^ GetItemVersions(
    ItemDefinition^ itemDefinition,
    CallContext^ context
)

Parameters

itemDefinition
Type: Sitecore.Data..::..ItemDefinition
The item.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.DataProvider.GetItemVersions(Sitecore.Data.ItemDefinition,Sitecore.Data.DataProviders.CallContext)"]

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


GetLanguages Method

[image]

Sitecore 6.4.1 API
DataProvider..::..GetLanguages Method
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual LanguageCollection GetLanguages(
    CallContext context
)
Visual Basic
Public Overridable Function GetLanguages ( _
    context As CallContext _
) As LanguageCollection
Visual C++
public:
virtual LanguageCollection^ GetLanguages(
    CallContext^ context
)

Parameters

context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.DataProvider.GetLanguages(Sitecore.Data.DataProviders.CallContext)"]

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


GetParentID Method

[image]

Sitecore 6.4.1 API
DataProvider..::..GetParentID Method
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ID GetParentID(
    ItemDefinition itemDefinition,
    CallContext context
)
Visual Basic
Public Overridable Function GetParentID ( _
    itemDefinition As ItemDefinition, _
    context As CallContext _
) As ID
Visual C++
public:
virtual ID^ GetParentID(
    ItemDefinition^ itemDefinition,
    CallContext^ context
)

Parameters

itemDefinition
Type: Sitecore.Data..::..ItemDefinition
The item definition.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.DataProvider.GetParentID(Sitecore.Data.ItemDefinition,Sitecore.Data.DataProviders.CallContext)"]

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


GetProperty Method

[image]

Sitecore 6.4.1 API
DataProvider..::..GetProperty Method
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string GetProperty(
    string name,
    CallContext context
)
Visual Basic
Public Overridable Function GetProperty ( _
    name As String, _
    context As CallContext _
) As String
Visual C++
public:
virtual String^ GetProperty(
    String^ name,
    CallContext^ context
)

Parameters

name
Type: System..::..String
The name.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.DataProvider.GetProperty(System.String,Sitecore.Data.DataProviders.CallContext)"]

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


GetPropertyKeys Method

[image]

Sitecore 6.4.1 API
DataProvider..::..GetPropertyKeys Method
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual List<string> GetPropertyKeys(
    string prefix,
    CallContext context
)
Visual Basic
Public Overridable Function GetPropertyKeys ( _
    prefix As String, _
    context As CallContext _
) As List(Of String)
Visual C++
public:
virtual List<String^>^ GetPropertyKeys(
    String^ prefix,
    CallContext^ context
)

Parameters

prefix
Type: System..::..String
The prefix.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.DataProvider.GetPropertyKeys(System.String,Sitecore.Data.DataProviders.CallContext)"]

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


GetPublishQueue Method

[image]

Sitecore 6.4.1 API
DataProvider..::..GetPublishQueue Method
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual IDList GetPublishQueue(
    DateTime from,
    DateTime to,
    CallContext context
)
Visual Basic
Public Overridable Function GetPublishQueue ( _
    from As DateTime, _
    to As DateTime, _
    context As CallContext _
) As IDList
Visual C++
public:
virtual IDList^ GetPublishQueue(
    DateTime from,
    DateTime to,
    CallContext^ context
)

Parameters

from
Type: System..::..DateTime
From.
to
Type: System..::..DateTime
To.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.DataProvider.GetPublishQueue(System.DateTime,System.DateTime,Sitecore.Data.DataProviders.CallContext)"]

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


GetRootID Method

[image]

Sitecore 6.4.1 API
DataProvider..::..GetRootID Method
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ID GetRootID(
    CallContext context
)
Visual Basic
Public Overridable Function GetRootID ( _
    context As CallContext _
) As ID
Visual C++
public:
virtual ID^ GetRootID(
    CallContext^ context
)

Parameters

context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.DataProvider.GetRootID(Sitecore.Data.DataProviders.CallContext)"]

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


GetTemplateItemIds Method

[image]

Sitecore 6.4.1 API
DataProvider..::..GetTemplateItemIds Method
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual IdCollection GetTemplateItemIds(
    CallContext context
)
Visual Basic
Public Overridable Function GetTemplateItemIds ( _
    context As CallContext _
) As IdCollection
Visual C++
public:
virtual IdCollection^ GetTemplateItemIds(
    CallContext^ context
)

Parameters

context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.DataProvider.GetTemplateItemIds(Sitecore.Data.DataProviders.CallContext)"]

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


GetTemplates Method

[image]

Sitecore 6.4.1 API
DataProvider..::..GetTemplates Method
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual TemplateCollection GetTemplates(
    CallContext context
)
Visual Basic
Public Overridable Function GetTemplates ( _
    context As CallContext _
) As TemplateCollection
Visual C++
public:
virtual TemplateCollection^ GetTemplates(
    CallContext^ context
)

Parameters

context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.DataProvider.GetTemplates(Sitecore.Data.DataProviders.CallContext)"]

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


GetWorkflowInfo Method

[image]

Sitecore 6.4.1 API
DataProvider..::..GetWorkflowInfo Method
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual WorkflowInfo GetWorkflowInfo(
    ItemDefinition item,
    VersionUri version,
    CallContext context
)
Visual Basic
Public Overridable Function GetWorkflowInfo ( _
    item As ItemDefinition, _
    version As VersionUri, _
    context As CallContext _
) As WorkflowInfo
Visual C++
public:
virtual WorkflowInfo^ GetWorkflowInfo(
    ItemDefinition^ item,
    VersionUri^ version,
    CallContext^ context
)

Parameters

item
Type: Sitecore.Data..::..ItemDefinition
The item.
version
Type: Sitecore.Data..::..VersionUri
The version.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.DataProvider.GetWorkflowInfo(Sitecore.Data.ItemDefinition,Sitecore.Data.VersionUri,Sitecore.Data.DataProviders.CallContext)"]

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


HasChildren Method

[image]

Sitecore 6.4.1 API
DataProvider..::..HasChildren Method
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool HasChildren(
    ItemDefinition itemDefinition,
    CallContext context
)
Visual Basic
Public Overridable Function HasChildren ( _
    itemDefinition As ItemDefinition, _
    context As CallContext _
) As Boolean
Visual C++
public:
virtual bool HasChildren(
    ItemDefinition^ itemDefinition,
    CallContext^ context
)

Parameters

itemDefinition
Type: Sitecore.Data..::..ItemDefinition
The item definition.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

true if the specified item definition has children; otherwise, false.

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


IsEnabled Method

[image]

Sitecore 6.4.1 API
DataProvider..::..IsEnabled Method
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsEnabled(
    string methodName
)
Visual Basic
Public Function IsEnabled ( _
    methodName As String _
) As Boolean
Visual C++
public:
bool IsEnabled(
    String^ methodName
)

Parameters

methodName
Type: System..::..String
Name of the method.

Return Value

true if the specified method name is enabled; otherwise, false.

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


MoveItem Method

[image]

Sitecore 6.4.1 API
DataProvider..::..MoveItem Method
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool MoveItem(
    ItemDefinition itemDefinition,
    ItemDefinition destination,
    CallContext context
)
Visual Basic
Public Overridable Function MoveItem ( _
    itemDefinition As ItemDefinition, _
    destination As ItemDefinition, _
    context As CallContext _
) As Boolean
Visual C++
public:
virtual bool MoveItem(
    ItemDefinition^ itemDefinition,
    ItemDefinition^ destination,
    CallContext^ context
)

Parameters

itemDefinition
Type: Sitecore.Data..::..ItemDefinition
The item definition.
destination
Type: Sitecore.Data..::..ItemDefinition
The destination.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The call context.

Return Value

True if the item was moved by the provider, false otherwise.

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


RemoveLanguageData Method

[image]

Sitecore 6.4.1 API
DataProvider..::..RemoveLanguageData Method
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void RemoveLanguageData(
    Language language,
    CallContext context
)
Visual Basic
Public Overridable Sub RemoveLanguageData ( _
    language As Language, _
    context As CallContext _
)
Visual C++
public:
virtual void RemoveLanguageData(
    Language^ language,
    CallContext^ context
)

Parameters

language
Type: Sitecore.Globalization..::..Language
The language.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Remarks

Proceeed with caution.

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


RemoveProperty Method

[image]

Sitecore 6.4.1 API
DataProvider..::..RemoveProperty Method
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool RemoveProperty(
    string name,
    bool isPrefix,
    CallContext context
)
Visual Basic
Public Overridable Function RemoveProperty ( _
    name As String, _
    isPrefix As Boolean, _
    context As CallContext _
) As Boolean
Visual C++
public:
virtual bool RemoveProperty(
    String^ name,
    bool isPrefix,
    CallContext^ context
)

Parameters

name
Type: System..::..String
The name.
isPrefix
Type: System..::..Boolean
if set to true this instance is is prefix.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.DataProvider.RemoveProperty(System.String,System.Boolean,Sitecore.Data.DataProviders.CallContext)"]

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


RemoveVersion Method

[image]

Sitecore 6.4.1 API
DataProvider..::..RemoveVersion Method
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool RemoveVersion(
    ItemDefinition itemDefinition,
    VersionUri version,
    CallContext context
)
Visual Basic
Public Overridable Function RemoveVersion ( _
    itemDefinition As ItemDefinition, _
    version As VersionUri, _
    context As CallContext _
) As Boolean
Visual C++
public:
virtual bool RemoveVersion(
    ItemDefinition^ itemDefinition,
    VersionUri^ version,
    CallContext^ context
)

Parameters

itemDefinition
Type: Sitecore.Data..::..ItemDefinition
The item definition.
version
Type: Sitecore.Data..::..VersionUri
The version.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.DataProvider.RemoveVersion(Sitecore.Data.ItemDefinition,Sitecore.Data.VersionUri,Sitecore.Data.DataProviders.CallContext)"]

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


RemoveVersions Method

[image] [image]

Sitecore 6.4.1 API
DataProvider..::..RemoveVersions Method
DataProvider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveVersions(ItemDefinition, Language, CallContext) | Removes versions from an item.
Public method | RemoveVersions(ItemDefinition, Language, Boolean, CallContext) | Removes versions from an item.

See Also

DataProvider Class
DataProvider Members
Sitecore.Data.DataProviders Namespace


RemoveVersions Method (ItemDefinition, Language, CallContext)

[image]

Sitecore 6.4.1 API
DataProvider..::..RemoveVersions Method (ItemDefinition, Language, CallContext)
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool RemoveVersions(
    ItemDefinition itemDefinition,
    Language language,
    CallContext context
)
Visual Basic
Public Overridable Function RemoveVersions ( _
    itemDefinition As ItemDefinition, _
    language As Language, _
    context As CallContext _
) As Boolean
Visual C++
public:
virtual bool RemoveVersions(
    ItemDefinition^ itemDefinition,
    Language^ language,
    CallContext^ context
)

Parameters

itemDefinition
Type: Sitecore.Data..::..ItemDefinition
The item definition.
language
Type: Sitecore.Globalization..::..Language
The language.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.DataProvider.RemoveVersions(Sitecore.Data.ItemDefinition,Sitecore.Globalization.Language,Sitecore.Data.DataProviders.CallContext)"]

See Also

DataProvider Class
RemoveVersions Overload
Sitecore.Data.DataProviders Namespace


RemoveVersions Method (ItemDefinition, Language, Boolean, CallContext)

[image]

Sitecore 6.4.1 API
DataProvider..::..RemoveVersions Method (ItemDefinition, Language, Boolean, CallContext)
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool RemoveVersions(
    ItemDefinition itemDefinition,
    Language language,
    bool removeSharedData,
    CallContext context
)
Visual Basic
Public Overridable Function RemoveVersions ( _
    itemDefinition As ItemDefinition, _
    language As Language, _
    removeSharedData As Boolean, _
    context As CallContext _
) As Boolean
Visual C++
public:
virtual bool RemoveVersions(
    ItemDefinition^ itemDefinition,
    Language^ language,
    bool removeSharedData,
    CallContext^ context
)

Parameters

itemDefinition
Type: Sitecore.Data..::..ItemDefinition
The item definition.
language
Type: Sitecore.Globalization..::..Language
The language.
removeSharedData
Type: System..::..Boolean
If set to true shared data is removed.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.DataProvider.RemoveVersions(Sitecore.Data.ItemDefinition,Sitecore.Globalization.Language,System.Boolean,Sitecore.Data.DataProviders.CallContext)"]

See Also

DataProvider Class
RemoveVersions Overload
Sitecore.Data.DataProviders Namespace


RenameLanguageData Method

[image]

Sitecore 6.4.1 API
DataProvider..::..RenameLanguageData Method
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void RenameLanguageData(
    string fromLanguage,
    string toLanguage,
    CallContext context
)
Visual Basic
Public Overridable Sub RenameLanguageData ( _
    fromLanguage As String, _
    toLanguage As String, _
    context As CallContext _
)
Visual C++
public:
virtual void RenameLanguageData(
    String^ fromLanguage,
    String^ toLanguage,
    CallContext^ context
)

Parameters

fromLanguage
Type: System..::..String
Rename from this language name.
toLanguage
Type: System..::..String
Rename to this language name.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


ResolvePath Method

[image]

Sitecore 6.4.1 API
DataProvider..::..ResolvePath Method
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ID ResolvePath(
    string itemPath,
    CallContext context
)
Visual Basic
Public Overridable Function ResolvePath ( _
    itemPath As String, _
    context As CallContext _
) As ID
Visual C++
public:
virtual ID^ ResolvePath(
    String^ itemPath,
    CallContext^ context
)

Parameters

itemPath
Type: System..::..String
The item path.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.DataProvider.ResolvePath(System.String,Sitecore.Data.DataProviders.CallContext)"]

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


SaveItem Method

[image]

Sitecore 6.4.1 API
DataProvider..::..SaveItem Method
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool SaveItem(
    ItemDefinition itemDefinition,
    ItemChanges changes,
    CallContext context
)
Visual Basic
Public Overridable Function SaveItem ( _
    itemDefinition As ItemDefinition, _
    changes As ItemChanges, _
    context As CallContext _
) As Boolean
Visual C++
public:
virtual bool SaveItem(
    ItemDefinition^ itemDefinition,
    ItemChanges^ changes,
    CallContext^ context
)

Parameters

itemDefinition
Type: Sitecore.Data..::..ItemDefinition
The item definition.
changes
Type: Sitecore.Data.Items..::..ItemChanges
The changes.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.DataProvider.SaveItem(Sitecore.Data.ItemDefinition,Sitecore.Data.Items.ItemChanges,Sitecore.Data.DataProviders.CallContext)"]

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


SelectIDs Method

[image]

Sitecore 6.4.1 API
DataProvider..::..SelectIDs Method
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual IDList SelectIDs(
    string query,
    CallContext context
)
Visual Basic
Public Overridable Function SelectIDs ( _
    query As String, _
    context As CallContext _
) As IDList
Visual C++
public:
virtual IDList^ SelectIDs(
    String^ query,
    CallContext^ context
)

Parameters

query
Type: System..::..String
The query.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.DataProvider.SelectIDs(System.String,Sitecore.Data.DataProviders.CallContext)"]

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


SelectSingleID Method

[image]

Sitecore 6.4.1 API
DataProvider..::..SelectSingleID Method
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ID SelectSingleID(
    string query,
    CallContext context
)
Visual Basic
Public Overridable Function SelectSingleID ( _
    query As String, _
    context As CallContext _
) As ID
Visual C++
public:
virtual ID^ SelectSingleID(
    String^ query,
    CallContext^ context
)

Parameters

query
Type: System..::..String
The query.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.DataProvider.SelectSingleID(System.String,Sitecore.Data.DataProviders.CallContext)"]

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


SetBlobStream Method

[image]

Sitecore 6.4.1 API
DataProvider..::..SetBlobStream Method
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool SetBlobStream(
    Stream stream,
    Guid blobId,
    CallContext context
)
Visual Basic
Public Overridable Function SetBlobStream ( _
    stream As Stream, _
    blobId As Guid, _
    context As CallContext _
) As Boolean
Visual C++
public:
virtual bool SetBlobStream(
    Stream^ stream,
    Guid blobId,
    CallContext^ context
)

Parameters

stream
Type: System.IO..::..Stream
The stream.
blobId
Type: System..::..Guid
The BLOB id.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The call context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.DataProvider.SetBlobStream(System.IO.Stream,System.Guid,Sitecore.Data.DataProviders.CallContext)"]

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


SetProperty Method

[image]

Sitecore 6.4.1 API
DataProvider..::..SetProperty Method
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool SetProperty(
    string name,
    string value,
    CallContext context
)
Visual Basic
Public Overridable Function SetProperty ( _
    name As String, _
    value As String, _
    context As CallContext _
) As Boolean
Visual C++
public:
virtual bool SetProperty(
    String^ name,
    String^ value,
    CallContext^ context
)

Parameters

name
Type: System..::..String
The name.
value
Type: System..::..String
The value.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.DataProvider.SetProperty(System.String,System.String,Sitecore.Data.DataProviders.CallContext)"]

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


DataProvider Properties

[image] [image]

Sitecore 6.4.1 API
DataProvider Properties
DataProvider Class See Also Send Feedback

The DataProvider type exposes the following members.

Properties

 | Name | Description
Public property | CacheOptions | Gets the cache options.
Public property | Database | Gets the database.
Protected property | Disable | Disables a method.
Protected property | DisableGroup | Disables a group.
Protected property | Enable | Enables a method.
Protected property | EnableGroup | Enables a group.

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


CacheOptions Property

[image]

Sitecore 6.4.1 API
DataProvider..::..CacheOptions Property
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual CacheOptions CacheOptions { get; }
Visual Basic
Public Overridable ReadOnly Property CacheOptions As CacheOptions
    Get
Visual C++
public:
virtual property CacheOptions^ CacheOptions {
    CacheOptions^ get ();
}

Field Value

The cache options.

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


Database Property

[image]

Sitecore 6.4.1 API
DataProvider..::..Database Property
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database Database { get; internal set; }
Visual Basic
Public Property Database As Database
    Get
    Friend Set
Visual C++
public:
property Database^ Database {
    Database^ get ();
    internal: void set (Database^ value);
}

Field Value

The database.

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


Disable Property

[image]

Sitecore 6.4.1 API
DataProvider..::..Disable Property
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string Disable { set; }
Visual Basic
Protected Overridable WriteOnly Property Disable As String
    Set
Visual C++
protected:
virtual property String^ Disable {
    void set (String^ value);
}

Field Value

The disable.

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


DisableGroup Property

[image]

Sitecore 6.4.1 API
DataProvider..::..DisableGroup Property
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string DisableGroup { set; }
Visual Basic
Protected Overridable WriteOnly Property DisableGroup As String
    Set
Visual C++
protected:
virtual property String^ DisableGroup {
    void set (String^ value);
}

Field Value

The disable group.

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


EnableGroup Property

[image]

Sitecore 6.4.1 API
DataProvider..::..EnableGroup Property
DataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string EnableGroup { set; }
Visual Basic
Protected Overridable WriteOnly Property EnableGroup As String
    Set
Visual C++
protected:
virtual property String^ EnableGroup {
    void set (String^ value);
}

Field Value

The enable group.

See Also

DataProvider Class
Sitecore.Data.DataProviders Namespace


FileSystemDataProvider Class

[image]

Sitecore 6.4.1 API
FileSystemDataProvider Class
Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FileSystemDataProvider : DataProvider
Visual Basic
Public Class FileSystemDataProvider _
    Inherits DataProvider
Visual C++
public ref class FileSystemDataProvider : public DataProvider

Inheritance Hierarchy

System..::..Object
Sitecore.Data.DataProviders..::..DataProvider
Sitecore.Data.DataProviders..::..FileSystemDataProvider

See Also

FileSystemDataProvider Members
Sitecore.Data.DataProviders Namespace


FileSystemDataProvider Members

[image] [image]

Sitecore 6.4.1 API
FileSystemDataProvider Members
FileSystemDataProvider Class Constructors Methods Fields Properties See Also Send Feedback

The FileSystemDataProvider type exposes the following members.

Constructors

 | Name | Description
Public method | FileSystemDataProvider | Initializes a new instance of the FileSystemDataProvider class.

Methods

 | Name | Description
Public method | AddToPublishQueue | Adds an item to the publish queue. (Inherited from DataProvider.)
Public method | AddVersion | Adds a version to an item. (Inherited from DataProvider.)
Public method | BlobStreamExists | Determines whether the specified field contains a BLOB value. (Inherited from DataProvider.)
Public method | ChangeFieldSharing | Changes the type of field sharing for a single field. (Inherited from DataProvider.)
Public method | ChangeTemplate | Changes the template of an item. (Inherited from DataProvider.)
Public method | CleanupDatabase | Cleans up the database. (Inherited from DataProvider.)
Public method | CleanupPublishQueue | Cleans up the publish queue. (Inherited from DataProvider.)
Public method | CopyItem | Copies an item. (Inherited from DataProvider.)
Public method | CreateItem | Creates a item. (Inherited from DataProvider.)
Public method | DeleteItem | Deletes an item. (Inherited from DataProvider.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBlobStream | Gets the BLOB stream associated with a field. (Inherited from DataProvider.)
Public method | GetChildIDs(ID, Boolean) | Gets the child I ds.
Public method | GetChildIDs(ItemDefinition, CallContext) | Gets the child ids of an item. (Overrides DataProvider..::..GetChildIDs(ItemDefinition, CallContext).)
Public method | GetDataSize | Gets the size of the data managed by the provider. (Inherited from DataProvider.)
Public method | GetDictionaryEntryCount | Gets the number of dictionary entries. (Inherited from DataProvider.)
Public method | GetEventQueue | Gets the event queue driver. (Inherited from DataProvider.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemDefinition | Gets the definition of an item. (Overrides DataProvider..::..GetItemDefinition(ID, CallContext).)
Public method | GetItemFields | Gets the item fields. (Overrides DataProvider..::..GetItemFields(ItemDefinition, VersionUri, CallContext).)
Public method | GetItemsInWorkflowState | Gets all items that are in a specific workflow state. (Inherited from DataProvider.)
Public method | GetItemVersions | Gets a list of the available versions of an item. (Inherited from DataProvider.)
Public method | GetLanguages | Gets a list of all the language that have been defined in the database. (Inherited from DataProvider.)
Public method | GetParentID | Gets the parent ID of an item. (Overrides DataProvider..::..GetParentID(ItemDefinition, CallContext).)
Public method | GetProperty | Gets a property. (Inherited from DataProvider.)
Public method | GetPropertyKeys | Gets a list of property keys matching a specific prefix. (Inherited from DataProvider.)
Public method | GetPublishQueue | Gets the publish queue. (Inherited from DataProvider.)
Public method | GetRootID()()()() | Gets the root ID.
Public method | GetRootID(CallContext) | Gets the root ID. (Overrides DataProvider..::..GetRootID(CallContext).)
Public method | GetTemplateItemIds | Gets the template item ids. (Inherited from DataProvider.)
Public method | GetTemplates | Gets the templates. (Overrides DataProvider..::..GetTemplates(CallContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWorkflowInfo | Gets the workflow info form an item. (Inherited from DataProvider.)
Public method | HasChildren | Determines whether the specified item definition has children. (Inherited from DataProvider.)
Public method | IsEnabled | Determines whether the specified method is enabled. (Inherited from DataProvider.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveItem | Moves an item (ie. changes its parent). (Inherited from DataProvider.)
Public method | RemoveLanguageData | Removes a language and all the data using the language from the database. (Inherited from DataProvider.)
Public method | RemoveProperty | Removes a property. (Inherited from DataProvider.)
Public method | RemoveVersion | Removes a version from an item. (Inherited from DataProvider.)
Public method | RemoveVersions(ItemDefinition, Language, CallContext) | Removes versions from an item. (Inherited from DataProvider.)
Public method | RemoveVersions(ItemDefinition, Language, Boolean, CallContext) | Removes versions from an item. (Inherited from DataProvider.)
Public method | RenameLanguageData | Renames a language binding. (Inherited from DataProvider.)
Public method | ResolvePath(String) | Resolves the path.
Public method | ResolvePath(String, CallContext) | Resolves the path. (Overrides DataProvider..::..ResolvePath(String, CallContext).)
Public method | SaveItem | Saves an item. (Inherited from DataProvider.)
Public method | SelectIDs | Selects a set of ids. (Inherited from DataProvider.)
Public method | SelectSingleID | Selects a single ID. (Inherited from DataProvider.)
Public method | SetBlobStream | Sets the BLOB stream associated with a field. (Inherited from DataProvider.)
Public method | SetProperty | Sets a property. (Inherited from DataProvider.)
Public method | SetWorkflowInfo | Sets the workflow info for an item. (Inherited from DataProvider.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
DataFolderName | Data folder
FileID |
FileModifiedID |
FilePathID |
FileSizeID |
FolderID |
FolderPathID |

Properties

 | Name | Description
Public property | CacheOptions | Gets the cache options. (Inherited from DataProvider.)
Public property | Database | Gets the database. (Inherited from DataProvider.)
Protected property | Disable | Disables a method. (Inherited from DataProvider.)
Protected property | DisableGroup | Disables a group. (Inherited from DataProvider.)
Protected property | Enable | Enables a method. (Inherited from DataProvider.)
Protected property | EnableGroup | Enables a group. (Inherited from DataProvider.)
Public property | IncludeRelocatedFolders | Gets or sets a value indicating whether relocated folders will be included.

See Also

FileSystemDataProvider Class
Sitecore.Data.DataProviders Namespace


FileSystemDataProvider Fields

[image] [image]

Sitecore 6.4.1 API
FileSystemDataProvider Fields
FileSystemDataProvider Class See Also Send Feedback

The FileSystemDataProvider type exposes the following members.

Fields

Name | Description
DataFolderName | Data folder
FileID |
FileModifiedID |
FilePathID |
FileSizeID |
FolderID |
FolderPathID |

See Also

FileSystemDataProvider Class
Sitecore.Data.DataProviders Namespace


DataFolderName Field

[image]

Sitecore 6.4.1 API
FileSystemDataProvider..::..DataFolderName Field
FileSystemDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly string DataFolderName
Visual Basic
Public Shared ReadOnly DataFolderName As String
Visual C++
public:
static initonly String^ DataFolderName

See Also

FileSystemDataProvider Class
Sitecore.Data.DataProviders Namespace


FileID Field

[image]

Sitecore 6.4.1 API
FileSystemDataProvider..::..FileID Field
FileSystemDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly ID FileID
Visual Basic
Public Shared ReadOnly FileID As ID
Visual C++
public:
static initonly ID^ FileID

See Also

FileSystemDataProvider Class
Sitecore.Data.DataProviders Namespace


FileModifiedID Field

[image]

Sitecore 6.4.1 API
FileSystemDataProvider..::..FileModifiedID Field
FileSystemDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly ID FileModifiedID
Visual Basic
Public Shared ReadOnly FileModifiedID As ID
Visual C++
public:
static initonly ID^ FileModifiedID

See Also

FileSystemDataProvider Class
Sitecore.Data.DataProviders Namespace


FilePathID Field

[image]

Sitecore 6.4.1 API
FileSystemDataProvider..::..FilePathID Field
FileSystemDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly ID FilePathID
Visual Basic
Public Shared ReadOnly FilePathID As ID
Visual C++
public:
static initonly ID^ FilePathID

See Also

FileSystemDataProvider Class
Sitecore.Data.DataProviders Namespace


FolderID Field

[image]

Sitecore 6.4.1 API
FileSystemDataProvider..::..FolderID Field
FileSystemDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly ID FolderID
Visual Basic
Public Shared ReadOnly FolderID As ID
Visual C++
public:
static initonly ID^ FolderID

See Also

FileSystemDataProvider Class
Sitecore.Data.DataProviders Namespace


FolderPathID Field

[image]

Sitecore 6.4.1 API
FileSystemDataProvider..::..FolderPathID Field
FileSystemDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly ID FolderPathID
Visual Basic
Public Shared ReadOnly FolderPathID As ID
Visual C++
public:
static initonly ID^ FolderPathID

See Also

FileSystemDataProvider Class
Sitecore.Data.DataProviders Namespace


FileSystemDataProvider Methods

[image] [image]

Sitecore 6.4.1 API
FileSystemDataProvider Methods
FileSystemDataProvider Class See Also Send Feedback

The FileSystemDataProvider type exposes the following members.

Methods

 | Name | Description
Public method | AddToPublishQueue | Adds an item to the publish queue. (Inherited from DataProvider.)
Public method | AddVersion | Adds a version to an item. (Inherited from DataProvider.)
Public method | BlobStreamExists | Determines whether the specified field contains a BLOB value. (Inherited from DataProvider.)
Public method | ChangeFieldSharing | Changes the type of field sharing for a single field. (Inherited from DataProvider.)
Public method | ChangeTemplate | Changes the template of an item. (Inherited from DataProvider.)
Public method | CleanupDatabase | Cleans up the database. (Inherited from DataProvider.)
Public method | CleanupPublishQueue | Cleans up the publish queue. (Inherited from DataProvider.)
Public method | CopyItem | Copies an item. (Inherited from DataProvider.)
Public method | CreateItem | Creates a item. (Inherited from DataProvider.)
Public method | DeleteItem | Deletes an item. (Inherited from DataProvider.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBlobStream | Gets the BLOB stream associated with a field. (Inherited from DataProvider.)
Public method | GetChildIDs(ID, Boolean) | Gets the child I ds.
Public method | GetChildIDs(ItemDefinition, CallContext) | Gets the child ids of an item. (Overrides DataProvider..::..GetChildIDs(ItemDefinition, CallContext).)
Public method | GetDataSize | Gets the size of the data managed by the provider. (Inherited from DataProvider.)
Public method | GetDictionaryEntryCount | Gets the number of dictionary entries. (Inherited from DataProvider.)
Public method | GetEventQueue | Gets the event queue driver. (Inherited from DataProvider.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemDefinition | Gets the definition of an item. (Overrides DataProvider..::..GetItemDefinition(ID, CallContext).)
Public method | GetItemFields | Gets the item fields. (Overrides DataProvider..::..GetItemFields(ItemDefinition, VersionUri, CallContext).)
Public method | GetItemsInWorkflowState | Gets all items that are in a specific workflow state. (Inherited from DataProvider.)
Public method | GetItemVersions | Gets a list of the available versions of an item. (Inherited from DataProvider.)
Public method | GetLanguages | Gets a list of all the language that have been defined in the database. (Inherited from DataProvider.)
Public method | GetParentID | Gets the parent ID of an item. (Overrides DataProvider..::..GetParentID(ItemDefinition, CallContext).)
Public method | GetProperty | Gets a property. (Inherited from DataProvider.)
Public method | GetPropertyKeys | Gets a list of property keys matching a specific prefix. (Inherited from DataProvider.)
Public method | GetPublishQueue | Gets the publish queue. (Inherited from DataProvider.)
Public method | GetRootID()()()() | Gets the root ID.
Public method | GetRootID(CallContext) | Gets the root ID. (Overrides DataProvider..::..GetRootID(CallContext).)
Public method | GetTemplateItemIds | Gets the template item ids. (Inherited from DataProvider.)
Public method | GetTemplates | Gets the templates. (Overrides DataProvider..::..GetTemplates(CallContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWorkflowInfo | Gets the workflow info form an item. (Inherited from DataProvider.)
Public method | HasChildren | Determines whether the specified item definition has children. (Inherited from DataProvider.)
Public method | IsEnabled | Determines whether the specified method is enabled. (Inherited from DataProvider.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveItem | Moves an item (ie. changes its parent). (Inherited from DataProvider.)
Public method | RemoveLanguageData | Removes a language and all the data using the language from the database. (Inherited from DataProvider.)
Public method | RemoveProperty | Removes a property. (Inherited from DataProvider.)
Public method | RemoveVersion | Removes a version from an item. (Inherited from DataProvider.)
Public method | RemoveVersions(ItemDefinition, Language, CallContext) | Removes versions from an item. (Inherited from DataProvider.)
Public method | RemoveVersions(ItemDefinition, Language, Boolean, CallContext) | Removes versions from an item. (Inherited from DataProvider.)
Public method | RenameLanguageData | Renames a language binding. (Inherited from DataProvider.)
Public method | ResolvePath(String) | Resolves the path.
Public method | ResolvePath(String, CallContext) | Resolves the path. (Overrides DataProvider..::..ResolvePath(String, CallContext).)
Public method | SaveItem | Saves an item. (Inherited from DataProvider.)
Public method | SelectIDs | Selects a set of ids. (Inherited from DataProvider.)
Public method | SelectSingleID | Selects a single ID. (Inherited from DataProvider.)
Public method | SetBlobStream | Sets the BLOB stream associated with a field. (Inherited from DataProvider.)
Public method | SetProperty | Sets a property. (Inherited from DataProvider.)
Public method | SetWorkflowInfo | Sets the workflow info for an item. (Inherited from DataProvider.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileSystemDataProvider Class
Sitecore.Data.DataProviders Namespace


GetChildIDs Method

[image] [image]

Sitecore 6.4.1 API
FileSystemDataProvider..::..GetChildIDs Method
FileSystemDataProvider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildIDs(ID, Boolean) | Gets the child I ds.
Public method | GetChildIDs(ItemDefinition, CallContext) | Gets the child ids of an item. (Overrides DataProvider..::..GetChildIDs(ItemDefinition, CallContext).)

See Also

FileSystemDataProvider Class
FileSystemDataProvider Members
Sitecore.Data.DataProviders Namespace


GetChildIDs Method (ID, Boolean)

[image]

Sitecore 6.4.1 API
FileSystemDataProvider..::..GetChildIDs Method (ID, Boolean)
FileSystemDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IDList GetChildIDs(
    ID itemID,
    bool forseIncludeRelocated
)
Visual Basic
Public Function GetChildIDs ( _
    itemID As ID, _
    forseIncludeRelocated As Boolean _
) As IDList
Visual C++
public:
IDList^ GetChildIDs(
    ID^ itemID,
    bool forseIncludeRelocated
)

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.
forseIncludeRelocated
Type: System..::..Boolean
if set to true [forse include relocated].

Return Value

The child I ds.

See Also

FileSystemDataProvider Class
GetChildIDs Overload
Sitecore.Data.DataProviders Namespace


GetChildIDs Method (ItemDefinition, CallContext)

[image]

Sitecore 6.4.1 API
FileSystemDataProvider..::..GetChildIDs Method (ItemDefinition, CallContext)
FileSystemDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override IDList GetChildIDs(
    ItemDefinition itemDefinition,
    CallContext context
)
Visual Basic
Public Overrides Function GetChildIDs ( _
    itemDefinition As ItemDefinition, _
    context As CallContext _
) As IDList
Visual C++
public:
virtual IDList^ GetChildIDs(
    ItemDefinition^ itemDefinition,
    CallContext^ context
) override

Parameters

itemDefinition
Type: Sitecore.Data..::..ItemDefinition
The item definition.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.FileSystemDataProvider.GetChildIDs(Sitecore.Data.ItemDefinition,Sitecore.Data.DataProviders.CallContext)"]

See Also

FileSystemDataProvider Class
GetChildIDs Overload
Sitecore.Data.DataProviders Namespace


GetItemDefinition Method

[image]

Sitecore 6.4.1 API
FileSystemDataProvider..::..GetItemDefinition Method
FileSystemDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override ItemDefinition GetItemDefinition(
    ID itemId,
    CallContext context
)
Visual Basic
Public Overrides Function GetItemDefinition ( _
    itemId As ID, _
    context As CallContext _
) As ItemDefinition
Visual C++
public:
virtual ItemDefinition^ GetItemDefinition(
    ID^ itemId,
    CallContext^ context
) override

Parameters

itemId
Type: Sitecore.Data..::..ID
The item ID.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.FileSystemDataProvider.GetItemDefinition(Sitecore.Data.ID,Sitecore.Data.DataProviders.CallContext)"]

See Also

FileSystemDataProvider Class
Sitecore.Data.DataProviders Namespace


GetItemFields Method

[image]

Sitecore 6.4.1 API
FileSystemDataProvider..::..GetItemFields Method
FileSystemDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override FieldList GetItemFields(
    ItemDefinition itemDefinition,
    VersionUri version,
    CallContext context
)
Visual Basic
Public Overrides Function GetItemFields ( _
    itemDefinition As ItemDefinition, _
    version As VersionUri, _
    context As CallContext _
) As FieldList
Visual C++
public:
virtual FieldList^ GetItemFields(
    ItemDefinition^ itemDefinition,
    VersionUri^ version,
    CallContext^ context
) override

Parameters

itemDefinition
Type: Sitecore.Data..::..ItemDefinition
The item definition.
version
Type: Sitecore.Data..::..VersionUri
The version.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

The item fields.

See Also

FileSystemDataProvider Class
Sitecore.Data.DataProviders Namespace


GetParentID Method

[image]

Sitecore 6.4.1 API
FileSystemDataProvider..::..GetParentID Method
FileSystemDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override ID GetParentID(
    ItemDefinition itemDefinition,
    CallContext context
)
Visual Basic
Public Overrides Function GetParentID ( _
    itemDefinition As ItemDefinition, _
    context As CallContext _
) As ID
Visual C++
public:
virtual ID^ GetParentID(
    ItemDefinition^ itemDefinition,
    CallContext^ context
) override

Parameters

itemDefinition
Type: Sitecore.Data..::..ItemDefinition
The item definition.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.FileSystemDataProvider.GetParentID(Sitecore.Data.ItemDefinition,Sitecore.Data.DataProviders.CallContext)"]

See Also

FileSystemDataProvider Class
Sitecore.Data.DataProviders Namespace


GetRootID Method

[image] [image]

Sitecore 6.4.1 API
FileSystemDataProvider..::..GetRootID Method
FileSystemDataProvider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRootID()()()() | Gets the root ID.
Public method | GetRootID(CallContext) | Gets the root ID. (Overrides DataProvider..::..GetRootID(CallContext).)

See Also

FileSystemDataProvider Class
FileSystemDataProvider Members
Sitecore.Data.DataProviders Namespace


GetRootID Method

[image]

Sitecore 6.4.1 API
FileSystemDataProvider..::..GetRootID Method
FileSystemDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID GetRootID()
Visual Basic
Public Function GetRootID As ID
Visual C++
public:
ID^ GetRootID()

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.FileSystemDataProvider.GetRootID"]

See Also

FileSystemDataProvider Class
GetRootID Overload
Sitecore.Data.DataProviders Namespace


GetRootID Method (CallContext)

[image]

Sitecore 6.4.1 API
FileSystemDataProvider..::..GetRootID Method (CallContext)
FileSystemDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override ID GetRootID(
    CallContext context
)
Visual Basic
Public Overrides Function GetRootID ( _
    context As CallContext _
) As ID
Visual C++
public:
virtual ID^ GetRootID(
    CallContext^ context
) override

Parameters

context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.FileSystemDataProvider.GetRootID(Sitecore.Data.DataProviders.CallContext)"]

See Also

FileSystemDataProvider Class
GetRootID Overload
Sitecore.Data.DataProviders Namespace


GetTemplates Method

[image]

Sitecore 6.4.1 API
FileSystemDataProvider..::..GetTemplates Method
FileSystemDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override TemplateCollection GetTemplates(
    CallContext context
)
Visual Basic
Public Overrides Function GetTemplates ( _
    context As CallContext _
) As TemplateCollection
Visual C++
public:
virtual TemplateCollection^ GetTemplates(
    CallContext^ context
) override

Parameters

context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.FileSystemDataProvider.GetTemplates(Sitecore.Data.DataProviders.CallContext)"]

See Also

FileSystemDataProvider Class
Sitecore.Data.DataProviders Namespace


RemoveVersions Method

[image] [image]

Sitecore 6.4.1 API
FileSystemDataProvider..::..RemoveVersions Method
FileSystemDataProvider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveVersions(ItemDefinition, Language, CallContext) | Removes versions from an item. (Inherited from DataProvider.)
Public method | RemoveVersions(ItemDefinition, Language, Boolean, CallContext) | Removes versions from an item. (Inherited from DataProvider.)

See Also

FileSystemDataProvider Class
FileSystemDataProvider Members
Sitecore.Data.DataProviders Namespace


ResolvePath Method

[image] [image]

Sitecore 6.4.1 API
FileSystemDataProvider..::..ResolvePath Method
FileSystemDataProvider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResolvePath(String) | Resolves the path.
Public method | ResolvePath(String, CallContext) | Resolves the path. (Overrides DataProvider..::..ResolvePath(String, CallContext).)

See Also

FileSystemDataProvider Class
FileSystemDataProvider Members
Sitecore.Data.DataProviders Namespace


ResolvePath Method (String)

[image]

Sitecore 6.4.1 API
FileSystemDataProvider..::..ResolvePath Method (String)
FileSystemDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ResolvePath(
    string path
)
Visual Basic
Public Function ResolvePath ( _
    path As String _
) As ID
Visual C++
public:
ID^ ResolvePath(
    String^ path
)

Parameters

path
Type: System..::..String
The path.

Return Value

The path.

See Also

FileSystemDataProvider Class
ResolvePath Overload
Sitecore.Data.DataProviders Namespace


ResolvePath Method (String, CallContext)

[image]

Sitecore 6.4.1 API
FileSystemDataProvider..::..ResolvePath Method (String, CallContext)
FileSystemDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override ID ResolvePath(
    string itemPath,
    CallContext context
)
Visual Basic
Public Overrides Function ResolvePath ( _
    itemPath As String, _
    context As CallContext _
) As ID
Visual C++
public:
virtual ID^ ResolvePath(
    String^ itemPath,
    CallContext^ context
) override

Parameters

itemPath
Type: System..::..String
The item path.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.FileSystemDataProvider.ResolvePath(System.String,Sitecore.Data.DataProviders.CallContext)"]

See Also

FileSystemDataProvider Class
ResolvePath Overload
Sitecore.Data.DataProviders Namespace


FileSystemDataProvider Properties

[image] [image]

Sitecore 6.4.1 API
FileSystemDataProvider Properties
FileSystemDataProvider Class See Also Send Feedback

The FileSystemDataProvider type exposes the following members.

Properties

 | Name | Description
Public property | CacheOptions | Gets the cache options. (Inherited from DataProvider.)
Public property | Database | Gets the database. (Inherited from DataProvider.)
Protected property | Disable | Disables a method. (Inherited from DataProvider.)
Protected property | DisableGroup | Disables a group. (Inherited from DataProvider.)
Protected property | Enable | Enables a method. (Inherited from DataProvider.)
Protected property | EnableGroup | Enables a group. (Inherited from DataProvider.)
Public property | IncludeRelocatedFolders | Gets or sets a value indicating whether relocated folders will be included.

See Also

FileSystemDataProvider Class
Sitecore.Data.DataProviders Namespace


IncludeRelocatedFolders Property

[image]

Sitecore 6.4.1 API
FileSystemDataProvider..::..IncludeRelocatedFolders Property
FileSystemDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IncludeRelocatedFolders { get; set; }
Visual Basic
Public Property IncludeRelocatedFolders As Boolean
    Get
    Set
Visual C++
public:
property bool IncludeRelocatedFolders {
    bool get ();
    void set (bool value);
}

Field Value

true if include relocated folders are included; otherwise, false.

See Also

FileSystemDataProvider Class
Sitecore.Data.DataProviders Namespace


HelloWorldProvider Class

[image]

Sitecore 6.4.1 API
HelloWorldProvider Class
Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class HelloWorldProvider : DataProvider
Visual Basic
Public Class HelloWorldProvider _
    Inherits DataProvider
Visual C++
public ref class HelloWorldProvider : public DataProvider

Inheritance Hierarchy

System..::..Object
Sitecore.Data.DataProviders..::..DataProvider
Sitecore.Data.DataProviders..::..HelloWorldProvider

See Also

HelloWorldProvider Members
Sitecore.Data.DataProviders Namespace


HelloWorldProvider Members

[image] [image]

Sitecore 6.4.1 API
HelloWorldProvider Members
HelloWorldProvider Class Constructors Methods Properties See Also Send Feedback

The HelloWorldProvider type exposes the following members.

Constructors

 | Name | Description
Public method | HelloWorldProvider | Initializes a new instance of the HelloWorldProvider class

Methods

 | Name | Description
Public method | AddToPublishQueue | Adds an item to the publish queue. (Inherited from DataProvider.)
Public method | AddVersion | Adds a version to an item. (Inherited from DataProvider.)
Public method | BlobStreamExists | Determines whether the specified field contains a BLOB value. (Inherited from DataProvider.)
Public method | ChangeFieldSharing | Changes the type of field sharing for a single field. (Inherited from DataProvider.)
Public method | ChangeTemplate | Changes the template of an item. (Inherited from DataProvider.)
Public method | CleanupDatabase | Cleans up the database. (Inherited from DataProvider.)
Public method | CleanupPublishQueue | Cleans up the publish queue. (Inherited from DataProvider.)
Public method | CopyItem | Copies an item. (Inherited from DataProvider.)
Public method | CreateItem | Creates a item. (Inherited from DataProvider.)
Public method | DeleteItem | Deletes an item. (Inherited from DataProvider.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBlobStream | Gets the BLOB stream associated with a field. (Inherited from DataProvider.)
Public method | GetChildIDs | Gets the child ids of an item. (Inherited from DataProvider.)
Public method | GetDataSize | Gets the size of the data managed by the provider. (Inherited from DataProvider.)
Public method | GetDictionaryEntryCount | Gets the number of dictionary entries. (Inherited from DataProvider.)
Public method | GetEventQueue | Gets the event queue driver. (Inherited from DataProvider.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemDefinition | Gets the item definition. (Overrides DataProvider..::..GetItemDefinition(ID, CallContext).)
Public method | GetItemFields | Gets the item fields. (Overrides DataProvider..::..GetItemFields(ItemDefinition, VersionUri, CallContext).)
Public method | GetItemsInWorkflowState | Gets all items that are in a specific workflow state. (Inherited from DataProvider.)
Public method | GetItemVersions | Gets a list of the available versions of an item. (Inherited from DataProvider.)
Public method | GetLanguages | Gets a list of all the language that have been defined in the database. (Inherited from DataProvider.)
Public method | GetParentID | Gets the parent ID of an item. (Inherited from DataProvider.)
Public method | GetProperty | Gets a property. (Inherited from DataProvider.)
Public method | GetPropertyKeys | Gets a list of property keys matching a specific prefix. (Inherited from DataProvider.)
Public method | GetPublishQueue | Gets the publish queue. (Inherited from DataProvider.)
Public method | GetRootID | Gets the root ID. (Inherited from DataProvider.)
Public method | GetTemplateItemIds | Gets the template item ids. (Inherited from DataProvider.)
Public method | GetTemplates | Gets the templates. (Overrides DataProvider..::..GetTemplates(CallContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWorkflowInfo | Gets the workflow info form an item. (Inherited from DataProvider.)
Public method | HasChildren | Determines whether the specified item definition has children. (Inherited from DataProvider.)
Public method | IsEnabled | Determines whether the specified method is enabled. (Inherited from DataProvider.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveItem | Moves an item (ie. changes its parent). (Inherited from DataProvider.)
Public method | RemoveLanguageData | Removes a language and all the data using the language from the database. (Inherited from DataProvider.)
Public method | RemoveProperty | Removes a property. (Inherited from DataProvider.)
Public method | RemoveVersion | Removes a version from an item. (Inherited from DataProvider.)
Public method | RemoveVersions(ItemDefinition, Language, CallContext) | Removes versions from an item. (Inherited from DataProvider.)
Public method | RemoveVersions(ItemDefinition, Language, Boolean, CallContext) | Removes versions from an item. (Inherited from DataProvider.)
Public method | RenameLanguageData | Renames a language binding. (Inherited from DataProvider.)
Public method | ResolvePath | Resolves the path. (Inherited from DataProvider.)
Public method | SaveItem | Saves an item. (Inherited from DataProvider.)
Public method | SelectIDs | Selects a set of ids. (Inherited from DataProvider.)
Public method | SelectSingleID | Selects a single ID. (Inherited from DataProvider.)
Public method | SetBlobStream | Sets the BLOB stream associated with a field. (Inherited from DataProvider.)
Public method | SetProperty | Sets a property. (Inherited from DataProvider.)
Public method | SetWorkflowInfo | Sets the workflow info for an item. (Inherited from DataProvider.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CacheOptions | Gets the cache options. (Inherited from DataProvider.)
Public property | Database | Gets the database. (Inherited from DataProvider.)
Protected property | Disable | Disables a method. (Inherited from DataProvider.)
Protected property | DisableGroup | Disables a group. (Inherited from DataProvider.)
Protected property | Enable | Enables a method. (Inherited from DataProvider.)
Protected property | EnableGroup | Enables a group. (Inherited from DataProvider.)

See Also

HelloWorldProvider Class
Sitecore.Data.DataProviders Namespace


HelloWorldProvider Constructor

[image]

Sitecore 6.4.1 API
HelloWorldProvider Constructor
HelloWorldProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HelloWorldProvider()
Visual Basic
Public Sub New
Visual C++
public:
HelloWorldProvider()

See Also

HelloWorldProvider Class
Sitecore.Data.DataProviders Namespace


HelloWorldProvider Methods

[image] [image]

Sitecore 6.4.1 API
HelloWorldProvider Methods
HelloWorldProvider Class See Also Send Feedback

The HelloWorldProvider type exposes the following members.

Methods

 | Name | Description
Public method | AddToPublishQueue | Adds an item to the publish queue. (Inherited from DataProvider.)
Public method | AddVersion | Adds a version to an item. (Inherited from DataProvider.)
Public method | BlobStreamExists | Determines whether the specified field contains a BLOB value. (Inherited from DataProvider.)
Public method | ChangeFieldSharing | Changes the type of field sharing for a single field. (Inherited from DataProvider.)
Public method | ChangeTemplate | Changes the template of an item. (Inherited from DataProvider.)
Public method | CleanupDatabase | Cleans up the database. (Inherited from DataProvider.)
Public method | CleanupPublishQueue | Cleans up the publish queue. (Inherited from DataProvider.)
Public method | CopyItem | Copies an item. (Inherited from DataProvider.)
Public method | CreateItem | Creates a item. (Inherited from DataProvider.)
Public method | DeleteItem | Deletes an item. (Inherited from DataProvider.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBlobStream | Gets the BLOB stream associated with a field. (Inherited from DataProvider.)
Public method | GetChildIDs | Gets the child ids of an item. (Inherited from DataProvider.)
Public method | GetDataSize | Gets the size of the data managed by the provider. (Inherited from DataProvider.)
Public method | GetDictionaryEntryCount | Gets the number of dictionary entries. (Inherited from DataProvider.)
Public method | GetEventQueue | Gets the event queue driver. (Inherited from DataProvider.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemDefinition | Gets the item definition. (Overrides DataProvider..::..GetItemDefinition(ID, CallContext).)
Public method | GetItemFields | Gets the item fields. (Overrides DataProvider..::..GetItemFields(ItemDefinition, VersionUri, CallContext).)
Public method | GetItemsInWorkflowState | Gets all items that are in a specific workflow state. (Inherited from DataProvider.)
Public method | GetItemVersions | Gets a list of the available versions of an item. (Inherited from DataProvider.)
Public method | GetLanguages | Gets a list of all the language that have been defined in the database. (Inherited from DataProvider.)
Public method | GetParentID | Gets the parent ID of an item. (Inherited from DataProvider.)
Public method | GetProperty | Gets a property. (Inherited from DataProvider.)
Public method | GetPropertyKeys | Gets a list of property keys matching a specific prefix. (Inherited from DataProvider.)
Public method | GetPublishQueue | Gets the publish queue. (Inherited from DataProvider.)
Public method | GetRootID | Gets the root ID. (Inherited from DataProvider.)
Public method | GetTemplateItemIds | Gets the template item ids. (Inherited from DataProvider.)
Public method | GetTemplates | Gets the templates. (Overrides DataProvider..::..GetTemplates(CallContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWorkflowInfo | Gets the workflow info form an item. (Inherited from DataProvider.)
Public method | HasChildren | Determines whether the specified item definition has children. (Inherited from DataProvider.)
Public method | IsEnabled | Determines whether the specified method is enabled. (Inherited from DataProvider.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveItem | Moves an item (ie. changes its parent). (Inherited from DataProvider.)
Public method | RemoveLanguageData | Removes a language and all the data using the language from the database. (Inherited from DataProvider.)
Public method | RemoveProperty | Removes a property. (Inherited from DataProvider.)
Public method | RemoveVersion | Removes a version from an item. (Inherited from DataProvider.)
Public method | RemoveVersions(ItemDefinition, Language, CallContext) | Removes versions from an item. (Inherited from DataProvider.)
Public method | RemoveVersions(ItemDefinition, Language, Boolean, CallContext) | Removes versions from an item. (Inherited from DataProvider.)
Public method | RenameLanguageData | Renames a language binding. (Inherited from DataProvider.)
Public method | ResolvePath | Resolves the path. (Inherited from DataProvider.)
Public method | SaveItem | Saves an item. (Inherited from DataProvider.)
Public method | SelectIDs | Selects a set of ids. (Inherited from DataProvider.)
Public method | SelectSingleID | Selects a single ID. (Inherited from DataProvider.)
Public method | SetBlobStream | Sets the BLOB stream associated with a field. (Inherited from DataProvider.)
Public method | SetProperty | Sets a property. (Inherited from DataProvider.)
Public method | SetWorkflowInfo | Sets the workflow info for an item. (Inherited from DataProvider.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HelloWorldProvider Class
Sitecore.Data.DataProviders Namespace


GetItemDefinition Method

[image]

Sitecore 6.4.1 API
HelloWorldProvider..::..GetItemDefinition Method
HelloWorldProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override ItemDefinition GetItemDefinition(
    ID itemId,
    CallContext context
)
Visual Basic
Public Overrides Function GetItemDefinition ( _
    itemId As ID, _
    context As CallContext _
) As ItemDefinition
Visual C++
public:
virtual ItemDefinition^ GetItemDefinition(
    ID^ itemId,
    CallContext^ context
) override

Parameters

itemId
Type: Sitecore.Data..::..ID
The item ID.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.HelloWorldProvider.GetItemDefinition(Sitecore.Data.ID,Sitecore.Data.DataProviders.CallContext)"]

See Also

HelloWorldProvider Class
Sitecore.Data.DataProviders Namespace


GetItemFields Method

[image]

Sitecore 6.4.1 API
HelloWorldProvider..::..GetItemFields Method
HelloWorldProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override FieldList GetItemFields(
    ItemDefinition item,
    VersionUri version,
    CallContext context
)
Visual Basic
Public Overrides Function GetItemFields ( _
    item As ItemDefinition, _
    version As VersionUri, _
    context As CallContext _
) As FieldList
Visual C++
public:
virtual FieldList^ GetItemFields(
    ItemDefinition^ item,
    VersionUri^ version,
    CallContext^ context
) override

Parameters

item
Type: Sitecore.Data..::..ItemDefinition
The item.
version
Type: Sitecore.Data..::..VersionUri
The version.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.HelloWorldProvider.GetItemFields(Sitecore.Data.ItemDefinition,Sitecore.Data.VersionUri,Sitecore.Data.DataProviders.CallContext)"]

See Also

HelloWorldProvider Class
Sitecore.Data.DataProviders Namespace


GetTemplates Method

[image]

Sitecore 6.4.1 API
HelloWorldProvider..::..GetTemplates Method
HelloWorldProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override TemplateCollection GetTemplates(
    CallContext context
)
Visual Basic
Public Overrides Function GetTemplates ( _
    context As CallContext _
) As TemplateCollection
Visual C++
public:
virtual TemplateCollection^ GetTemplates(
    CallContext^ context
) override

Parameters

context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.HelloWorldProvider.GetTemplates(Sitecore.Data.DataProviders.CallContext)"]

See Also

HelloWorldProvider Class
Sitecore.Data.DataProviders Namespace


RemoveVersions Method

[image] [image]

Sitecore 6.4.1 API
HelloWorldProvider..::..RemoveVersions Method
HelloWorldProvider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveVersions(ItemDefinition, Language, CallContext) | Removes versions from an item. (Inherited from DataProvider.)
Public method | RemoveVersions(ItemDefinition, Language, Boolean, CallContext) | Removes versions from an item. (Inherited from DataProvider.)

See Also

HelloWorldProvider Class
HelloWorldProvider Members
Sitecore.Data.DataProviders Namespace


HelloWorldProvider Properties

[image] [image]

Sitecore 6.4.1 API
HelloWorldProvider Properties
HelloWorldProvider Class See Also Send Feedback

The HelloWorldProvider type exposes the following members.

Properties

 | Name | Description
Public property | CacheOptions | Gets the cache options. (Inherited from DataProvider.)
Public property | Database | Gets the database. (Inherited from DataProvider.)
Protected property | Disable | Disables a method. (Inherited from DataProvider.)
Protected property | DisableGroup | Disables a group. (Inherited from DataProvider.)
Protected property | Enable | Enables a method. (Inherited from DataProvider.)
Protected property | EnableGroup | Enables a group. (Inherited from DataProvider.)

See Also

HelloWorldProvider Class
Sitecore.Data.DataProviders Namespace


PrefetchData Class

[image]

Sitecore 6.4.1 API
PrefetchData Class
Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PrefetchData
Visual Basic
Public Class PrefetchData
Visual C++
public ref class PrefetchData

Inheritance Hierarchy

System..::..Object
Sitecore.Data.DataProviders..::..PrefetchData

See Also

PrefetchData Members
Sitecore.Data.DataProviders Namespace


PrefetchData Members

[image] [image]

Sitecore 6.4.1 API
PrefetchData Members
PrefetchData Class Constructors Methods Properties See Also Send Feedback

The PrefetchData type exposes the following members.

Constructors

 | Name | Description
Public method | PrefetchData | Initializes a new instance of the PrefetchData class.

Methods

 | Name | Description
Public method | AddChildId | Adds the child id.
Public method | AddField | Adds a field.
Public method | AddSharedField | Adds a shared field.
Public method | AddUnversionedField | Adds an unversioned field.
Public method | AddVersionedField | Adds a versioned field.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChildIds | Gets the child ids.
Public method | GetDataLength | Gets the size of the data to use when caching.
Public method | GetFieldList(String, Int32) | Gets a field list.
Public method | GetFieldList(String, Int32, Boolean) | Gets a field list.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSharedFields | Gets the shared fields.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersionUris | Gets the version uris.
Public method | InitializeFieldLists | Initializes the field lists.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ItemDefinition | Gets or sets the item definition.
Public property | ParentId | Gets or sets the parent id.

See Also

PrefetchData Class
Sitecore.Data.DataProviders Namespace


PrefetchData Constructor

[image]

Sitecore 6.4.1 API
PrefetchData Constructor
PrefetchData Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PrefetchData(
    ItemDefinition itemDefinition,
    ID parentId
)
Visual Basic
Public Sub New ( _
    itemDefinition As ItemDefinition, _
    parentId As ID _
)
Visual C++
public:
PrefetchData(
    ItemDefinition^ itemDefinition,
    ID^ parentId
)

Parameters

itemDefinition
Type: Sitecore.Data..::..ItemDefinition
The item definition.
parentId
Type: Sitecore.Data..::..ID
The parent id.

See Also

PrefetchData Class
Sitecore.Data.DataProviders Namespace


AddChildId Method

[image]

Sitecore 6.4.1 API
PrefetchData..::..AddChildId Method
PrefetchData Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddChildId(
    ID childId
)
Visual Basic
Public Sub AddChildId ( _
    childId As ID _
)
Visual C++
public:
void AddChildId(
    ID^ childId
)

Parameters

childId
Type: Sitecore.Data..::..ID
The child id.

See Also

PrefetchData Class
Sitecore.Data.DataProviders Namespace


AddField Method

[image]

Sitecore 6.4.1 API
PrefetchData..::..AddField Method
PrefetchData Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddField(
    string language,
    int version,
    ID fieldId,
    string value
)
Visual Basic
Public Sub AddField ( _
    language As String, _
    version As Integer, _
    fieldId As ID, _
    value As String _
)
Visual C++
public:
void AddField(
    String^ language,
    int version,
    ID^ fieldId,
    String^ value
)

Parameters

language
Type: System..::..String
The language.
version
Type: System..::..Int32
The version.
fieldId
Type: Sitecore.Data..::..ID
The field id.
value
Type: System..::..String
The value.

See Also

PrefetchData Class
Sitecore.Data.DataProviders Namespace


AddSharedField Method

[image]

Sitecore 6.4.1 API
PrefetchData..::..AddSharedField Method
PrefetchData Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddSharedField(
    ID fieldId,
    string value
)
Visual Basic
Public Sub AddSharedField ( _
    fieldId As ID, _
    value As String _
)
Visual C++
public:
void AddSharedField(
    ID^ fieldId,
    String^ value
)

Parameters

fieldId
Type: Sitecore.Data..::..ID
The field id.
value
Type: System..::..String
The value.

See Also

PrefetchData Class
Sitecore.Data.DataProviders Namespace


AddUnversionedField Method

[image]

Sitecore 6.4.1 API
PrefetchData..::..AddUnversionedField Method
PrefetchData Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddUnversionedField(
    string language,
    ID fieldId,
    string value
)
Visual Basic
Public Sub AddUnversionedField ( _
    language As String, _
    fieldId As ID, _
    value As String _
)
Visual C++
public:
void AddUnversionedField(
    String^ language,
    ID^ fieldId,
    String^ value
)

Parameters

language
Type: System..::..String
The language.
fieldId
Type: Sitecore.Data..::..ID
The field id.
value
Type: System..::..String
The value.

See Also

PrefetchData Class
Sitecore.Data.DataProviders Namespace


AddVersionedField Method

[image]

Sitecore 6.4.1 API
PrefetchData..::..AddVersionedField Method
PrefetchData Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddVersionedField(
    string language,
    int version,
    ID fieldId,
    string value
)
Visual Basic
Public Sub AddVersionedField ( _
    language As String, _
    version As Integer, _
    fieldId As ID, _
    value As String _
)
Visual C++
public:
void AddVersionedField(
    String^ language,
    int version,
    ID^ fieldId,
    String^ value
)

Parameters

language
Type: System..::..String
The language.
version
Type: System..::..Int32
The version.
fieldId
Type: Sitecore.Data..::..ID
The field id.
value
Type: System..::..String
The value.

See Also

PrefetchData Class
Sitecore.Data.DataProviders Namespace


GetChildIds Method

[image]

Sitecore 6.4.1 API
PrefetchData..::..GetChildIds Method
PrefetchData Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IDList GetChildIds()
Visual Basic
Public Function GetChildIds As IDList
Visual C++
public:
IDList^ GetChildIds()

Field Value

The child ids.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.PrefetchData.GetChildIds"]

See Also

PrefetchData Class
Sitecore.Data.DataProviders Namespace


GetDataLength Method

[image]

Sitecore 6.4.1 API
PrefetchData..::..GetDataLength Method
PrefetchData Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long GetDataLength()
Visual Basic
Public Function GetDataLength As Long
Visual C++
public:
long long GetDataLength()

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.PrefetchData.GetDataLength"]

See Also

PrefetchData Class
Sitecore.Data.DataProviders Namespace


GetFieldList Method

[image] [image]

Sitecore 6.4.1 API
PrefetchData..::..GetFieldList Method
PrefetchData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetFieldList(String, Int32) | Gets a field list.
Public method | GetFieldList(String, Int32, Boolean) | Gets a field list.

See Also

PrefetchData Class
PrefetchData Members
Sitecore.Data.DataProviders Namespace


GetFieldList Method (String, Int32)

[image]

Sitecore 6.4.1 API
PrefetchData..::..GetFieldList Method (String, Int32)
PrefetchData Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FieldList GetFieldList(
    string language,
    int version
)
Visual Basic
Public Function GetFieldList ( _
    language As String, _
    version As Integer _
) As FieldList
Visual C++
public:
FieldList^ GetFieldList(
    String^ language,
    int version
)

Parameters

language
Type: System..::..String
The language.
version
Type: System..::..Int32
The version.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.PrefetchData.GetFieldList(System.String,System.Int32)"]

See Also

PrefetchData Class
GetFieldList Overload
Sitecore.Data.DataProviders Namespace


GetFieldList Method (String, Int32, Boolean)

[image]

Sitecore 6.4.1 API
PrefetchData..::..GetFieldList Method (String, Int32, Boolean)
PrefetchData Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FieldList GetFieldList(
    string language,
    int version,
    bool force
)
Visual Basic
Public Function GetFieldList ( _
    language As String, _
    version As Integer, _
    force As Boolean _
) As FieldList
Visual C++
public:
FieldList^ GetFieldList(
    String^ language,
    int version,
    bool force
)

Parameters

language
Type: System..::..String
The language.
version
Type: System..::..Int32
The version.
force
Type: System..::..Boolean
If set to true create the list if it does not exist.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.PrefetchData.GetFieldList(System.String,System.Int32,System.Boolean)"]

See Also

PrefetchData Class
GetFieldList Overload
Sitecore.Data.DataProviders Namespace


GetSharedFields Method

[image]

Sitecore 6.4.1 API
PrefetchData..::..GetSharedFields Method
PrefetchData Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FieldList GetSharedFields()
Visual Basic
Public Function GetSharedFields As FieldList
Visual C++
public:
FieldList^ GetSharedFields()

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.PrefetchData.GetSharedFields"]

See Also

PrefetchData Class
Sitecore.Data.DataProviders Namespace


GetVersionUris Method

[image]

Sitecore 6.4.1 API
PrefetchData..::..GetVersionUris Method
PrefetchData Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public VersionUriList GetVersionUris()
Visual Basic
Public Function GetVersionUris As VersionUriList
Visual C++
public:
VersionUriList^ GetVersionUris()

Field Value

The version uris.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.PrefetchData.GetVersionUris"]

See Also

PrefetchData Class
Sitecore.Data.DataProviders Namespace


InitializeFieldLists Method

[image]

Sitecore 6.4.1 API
PrefetchData..::..InitializeFieldLists Method
PrefetchData Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void InitializeFieldLists(
    LanguageCollection languages
)
Visual Basic
Public Sub InitializeFieldLists ( _
    languages As LanguageCollection _
)
Visual C++
public:
void InitializeFieldLists(
    LanguageCollection^ languages
)

Parameters

languages
Type: Sitecore.Collections..::..LanguageCollection
The languages.

See Also

PrefetchData Class
Sitecore.Data.DataProviders Namespace


PrefetchData Properties

[image] [image]

Sitecore 6.4.1 API
PrefetchData Properties
PrefetchData Class See Also Send Feedback

The PrefetchData type exposes the following members.

Properties

 | Name | Description
Public property | ItemDefinition | Gets or sets the item definition.
Public property | ParentId | Gets or sets the parent id.

See Also

PrefetchData Class
Sitecore.Data.DataProviders Namespace


ItemDefinition Property

[image]

Sitecore 6.4.1 API
PrefetchData..::..ItemDefinition Property
PrefetchData Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemDefinition ItemDefinition { get; }
Visual Basic
Public ReadOnly Property ItemDefinition As ItemDefinition
    Get
Visual C++
public:
property ItemDefinition^ ItemDefinition {
    ItemDefinition^ get ();
}

Field Value

The item definition.

See Also

PrefetchData Class
Sitecore.Data.DataProviders Namespace


ParentId Property

[image]

Sitecore 6.4.1 API
PrefetchData..::..ParentId Property
PrefetchData Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ParentId { get; }
Visual Basic
Public ReadOnly Property ParentId As ID
    Get
Visual C++
public:
property ID^ ParentId {
    ID^ get ();
}

Field Value

The parent id.

See Also

PrefetchData Class
Sitecore.Data.DataProviders Namespace


PropertyStore Class

[image]

Sitecore 6.4.1 API
PropertyStore Class
Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class PropertyStore
Visual Basic
Public MustInherit Class PropertyStore
Visual C++
public ref class PropertyStore abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Data.DataProviders..::..PropertyStore

See Also

PropertyStore Members
Sitecore.Data.DataProviders Namespace


PropertyStore Members

[image] [image]

Sitecore 6.4.1 API
PropertyStore Members
PropertyStore Class Constructors Methods See Also Send Feedback

The PropertyStore type exposes the following members.

Constructors

 | Name | Description
Protected method | PropertyStore | Initializes a new instance of the PropertyStore class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetString | Gets the string.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PropertyStore Class
Sitecore.Data.DataProviders Namespace


PropertyStore Constructor

[image]

Sitecore 6.4.1 API
PropertyStore Constructor
PropertyStore Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected PropertyStore()
Visual Basic
Protected Sub New
Visual C++
protected:
PropertyStore()

See Also

PropertyStore Class
Sitecore.Data.DataProviders Namespace


PropertyStore Methods

[image] [image]

Sitecore 6.4.1 API
PropertyStore Methods
PropertyStore Class See Also Send Feedback

The PropertyStore type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetString | Gets the string.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PropertyStore Class
Sitecore.Data.DataProviders Namespace


GetString Method

[image]

Sitecore 6.4.1 API
PropertyStore..::..GetString Method
PropertyStore Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract string GetString(
    string key,
    string keyField,
    string valueField
)
Visual Basic
Public MustOverride Function GetString ( _
    key As String, _
    keyField As String, _
    valueField As String _
) As String
Visual C++
public:
virtual String^ GetString(
    String^ key,
    String^ keyField,
    String^ valueField
) abstract

Parameters

key
Type: System..::..String
The key.
keyField
Type: System..::..String
The key field.
valueField
Type: System..::..String
The value field.

Return Value

The string.

See Also

PropertyStore Class
Sitecore.Data.DataProviders Namespace


TemplateFileResolver Class

[image]

Sitecore 6.4.1 API
TemplateFileResolver Class
Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class TemplateFileResolver : DataProvider
Visual Basic
Public Class TemplateFileResolver _
    Inherits DataProvider
Visual C++
public ref class TemplateFileResolver : public DataProvider

Inheritance Hierarchy

System..::..Object
Sitecore.Data.DataProviders..::..DataProvider
Sitecore.Data.DataProviders..::..TemplateFileResolver

See Also

TemplateFileResolver Members
Sitecore.Data.DataProviders Namespace


TemplateFileResolver Members

[image] [image]

Sitecore 6.4.1 API
TemplateFileResolver Members
TemplateFileResolver Class Constructors Methods Properties See Also Send Feedback

The TemplateFileResolver type exposes the following members.

Constructors

 | Name | Description
Public method | TemplateFileResolver | Creates a new TemplateFileResolver instance.

Methods

 | Name | Description
Public method | AddToPublishQueue | Adds an item to the publish queue. (Inherited from DataProvider.)
Public method | AddVersion | Adds a version to an item. (Inherited from DataProvider.)
Public method | BlobStreamExists | Determines whether the specified field contains a BLOB value. (Inherited from DataProvider.)
Public method | ChangeFieldSharing | Changes the type of field sharing for a single field. (Inherited from DataProvider.)
Public method | ChangeTemplate | Changes the template of an item. (Inherited from DataProvider.)
Public method | CleanupDatabase | Cleans up the database. (Inherited from DataProvider.)
Public method | CleanupPublishQueue | Cleans up the publish queue. (Inherited from DataProvider.)
Public method | CopyItem | Copies an item. (Inherited from DataProvider.)
Public method | CreateItem | Creates a item. (Inherited from DataProvider.)
Public method | DeleteItem | Deletes an item. (Inherited from DataProvider.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBlobStream | Gets the BLOB stream associated with a field. (Inherited from DataProvider.)
Public method | GetChildIDs | Gets the child ids of an item. (Inherited from DataProvider.)
Public method | GetDataSize | Gets the size of the data managed by the provider. (Inherited from DataProvider.)
Public method | GetDictionaryEntryCount | Gets the number of dictionary entries. (Inherited from DataProvider.)
Public method | GetEventQueue | Gets the event queue driver. (Inherited from DataProvider.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemDefinition | Gets the definition of an item. (Inherited from DataProvider.)
Public method | GetItemFields | Gets the fields of a specific item version. (Inherited from DataProvider.)
Public method | GetItemsInWorkflowState | Gets all items that are in a specific workflow state. (Inherited from DataProvider.)
Public method | GetItemVersions | Gets a list of the available versions of an item. (Inherited from DataProvider.)
Public method | GetLanguages | Gets a list of all the language that have been defined in the database. (Inherited from DataProvider.)
Public method | GetParentID | Gets the parent ID of an item. (Inherited from DataProvider.)
Public method | GetProperty | Gets a property. (Inherited from DataProvider.)
Public method | GetPropertyKeys | Gets a list of property keys matching a specific prefix. (Inherited from DataProvider.)
Public method | GetPublishQueue | Gets the publish queue. (Inherited from DataProvider.)
Public method | GetRootID | Gets the root ID. (Inherited from DataProvider.)
Public method | GetTemplateItemIds | Gets the template item ids. (Inherited from DataProvider.)
Public method | GetTemplates | Gets the templates. (Overrides DataProvider..::..GetTemplates(CallContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWorkflowInfo | Gets the workflow info form an item. (Inherited from DataProvider.)
Public method | HasChildren | Determines whether the specified item definition has children. (Inherited from DataProvider.)
Public method | IsEnabled | Determines whether the specified method is enabled. (Inherited from DataProvider.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveItem | Moves an item (ie. changes its parent). (Inherited from DataProvider.)
Public method | RemoveLanguageData | Removes a language and all the data using the language from the database. (Inherited from DataProvider.)
Public method | RemoveProperty | Removes a property. (Inherited from DataProvider.)
Public method | RemoveVersion | Removes a version from an item. (Inherited from DataProvider.)
Public method | RemoveVersions(ItemDefinition, Language, CallContext) | Removes versions from an item. (Inherited from DataProvider.)
Public method | RemoveVersions(ItemDefinition, Language, Boolean, CallContext) | Removes versions from an item. (Inherited from DataProvider.)
Public method | RenameLanguageData | Renames a language binding. (Inherited from DataProvider.)
Public method | ResolvePath | Resolves the path. (Inherited from DataProvider.)
Public method | SaveItem | Saves an item. (Inherited from DataProvider.)
Public method | SelectIDs | Selects a set of ids. (Inherited from DataProvider.)
Public method | SelectSingleID | Selects a single ID. (Inherited from DataProvider.)
Public method | SetBlobStream | Sets the BLOB stream associated with a field. (Inherited from DataProvider.)
Public method | SetProperty | Sets a property. (Inherited from DataProvider.)
Public method | SetWorkflowInfo | Sets the workflow info for an item. (Inherited from DataProvider.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AbortChain | Gets or sets a value indicating whether the TemplateFileResolver aborts the chain.
Public property | CacheOptions | Gets the cache options. (Inherited from DataProvider.)
Public property | Database | Gets the database. (Inherited from DataProvider.)
Protected property | Disable | Disables a method. (Inherited from DataProvider.)
Protected property | DisableGroup | Disables a group. (Inherited from DataProvider.)
Protected property | Enable | Enables a method. (Inherited from DataProvider.)
Protected property | EnableGroup | Enables a group. (Inherited from DataProvider.)

See Also

TemplateFileResolver Class
Sitecore.Data.DataProviders Namespace


TemplateFileResolver Constructor

[image]

Sitecore 6.4.1 API
TemplateFileResolver Constructor
TemplateFileResolver Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateFileResolver(
    string templateFile
)
Visual Basic
Public Sub New ( _
    templateFile As String _
)
Visual C++
public:
TemplateFileResolver(
    String^ templateFile
)

Parameters

templateFile
Type: System..::..String
Template file.

See Also

TemplateFileResolver Class
Sitecore.Data.DataProviders Namespace


TemplateFileResolver Methods

[image] [image]

Sitecore 6.4.1 API
TemplateFileResolver Methods
TemplateFileResolver Class See Also Send Feedback

The TemplateFileResolver type exposes the following members.

Methods

 | Name | Description
Public method | AddToPublishQueue | Adds an item to the publish queue. (Inherited from DataProvider.)
Public method | AddVersion | Adds a version to an item. (Inherited from DataProvider.)
Public method | BlobStreamExists | Determines whether the specified field contains a BLOB value. (Inherited from DataProvider.)
Public method | ChangeFieldSharing | Changes the type of field sharing for a single field. (Inherited from DataProvider.)
Public method | ChangeTemplate | Changes the template of an item. (Inherited from DataProvider.)
Public method | CleanupDatabase | Cleans up the database. (Inherited from DataProvider.)
Public method | CleanupPublishQueue | Cleans up the publish queue. (Inherited from DataProvider.)
Public method | CopyItem | Copies an item. (Inherited from DataProvider.)
Public method | CreateItem | Creates a item. (Inherited from DataProvider.)
Public method | DeleteItem | Deletes an item. (Inherited from DataProvider.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBlobStream | Gets the BLOB stream associated with a field. (Inherited from DataProvider.)
Public method | GetChildIDs | Gets the child ids of an item. (Inherited from DataProvider.)
Public method | GetDataSize | Gets the size of the data managed by the provider. (Inherited from DataProvider.)
Public method | GetDictionaryEntryCount | Gets the number of dictionary entries. (Inherited from DataProvider.)
Public method | GetEventQueue | Gets the event queue driver. (Inherited from DataProvider.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemDefinition | Gets the definition of an item. (Inherited from DataProvider.)
Public method | GetItemFields | Gets the fields of a specific item version. (Inherited from DataProvider.)
Public method | GetItemsInWorkflowState | Gets all items that are in a specific workflow state. (Inherited from DataProvider.)
Public method | GetItemVersions | Gets a list of the available versions of an item. (Inherited from DataProvider.)
Public method | GetLanguages | Gets a list of all the language that have been defined in the database. (Inherited from DataProvider.)
Public method | GetParentID | Gets the parent ID of an item. (Inherited from DataProvider.)
Public method | GetProperty | Gets a property. (Inherited from DataProvider.)
Public method | GetPropertyKeys | Gets a list of property keys matching a specific prefix. (Inherited from DataProvider.)
Public method | GetPublishQueue | Gets the publish queue. (Inherited from DataProvider.)
Public method | GetRootID | Gets the root ID. (Inherited from DataProvider.)
Public method | GetTemplateItemIds | Gets the template item ids. (Inherited from DataProvider.)
Public method | GetTemplates | Gets the templates. (Overrides DataProvider..::..GetTemplates(CallContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWorkflowInfo | Gets the workflow info form an item. (Inherited from DataProvider.)
Public method | HasChildren | Determines whether the specified item definition has children. (Inherited from DataProvider.)
Public method | IsEnabled | Determines whether the specified method is enabled. (Inherited from DataProvider.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveItem | Moves an item (ie. changes its parent). (Inherited from DataProvider.)
Public method | RemoveLanguageData | Removes a language and all the data using the language from the database. (Inherited from DataProvider.)
Public method | RemoveProperty | Removes a property. (Inherited from DataProvider.)
Public method | RemoveVersion | Removes a version from an item. (Inherited from DataProvider.)
Public method | RemoveVersions(ItemDefinition, Language, CallContext) | Removes versions from an item. (Inherited from DataProvider.)
Public method | RemoveVersions(ItemDefinition, Language, Boolean, CallContext) | Removes versions from an item. (Inherited from DataProvider.)
Public method | RenameLanguageData | Renames a language binding. (Inherited from DataProvider.)
Public method | ResolvePath | Resolves the path. (Inherited from DataProvider.)
Public method | SaveItem | Saves an item. (Inherited from DataProvider.)
Public method | SelectIDs | Selects a set of ids. (Inherited from DataProvider.)
Public method | SelectSingleID | Selects a single ID. (Inherited from DataProvider.)
Public method | SetBlobStream | Sets the BLOB stream associated with a field. (Inherited from DataProvider.)
Public method | SetProperty | Sets a property. (Inherited from DataProvider.)
Public method | SetWorkflowInfo | Sets the workflow info for an item. (Inherited from DataProvider.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TemplateFileResolver Class
Sitecore.Data.DataProviders Namespace


RemoveVersions Method

[image] [image]

Sitecore 6.4.1 API
TemplateFileResolver..::..RemoveVersions Method
TemplateFileResolver Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveVersions(ItemDefinition, Language, CallContext) | Removes versions from an item. (Inherited from DataProvider.)
Public method | RemoveVersions(ItemDefinition, Language, Boolean, CallContext) | Removes versions from an item. (Inherited from DataProvider.)

See Also

TemplateFileResolver Class
TemplateFileResolver Members
Sitecore.Data.DataProviders Namespace


TemplateFileResolver Properties

[image] [image]

Sitecore 6.4.1 API
TemplateFileResolver Properties
TemplateFileResolver Class See Also Send Feedback

The TemplateFileResolver type exposes the following members.

Properties

 | Name | Description
Public property | AbortChain | Gets or sets a value indicating whether the TemplateFileResolver aborts the chain.
Public property | CacheOptions | Gets the cache options. (Inherited from DataProvider.)
Public property | Database | Gets the database. (Inherited from DataProvider.)
Protected property | Disable | Disables a method. (Inherited from DataProvider.)
Protected property | DisableGroup | Disables a group. (Inherited from DataProvider.)
Protected property | Enable | Enables a method. (Inherited from DataProvider.)
Protected property | EnableGroup | Enables a group. (Inherited from DataProvider.)

See Also

TemplateFileResolver Class
Sitecore.Data.DataProviders Namespace


AbortChain Property

[image]

Sitecore 6.4.1 API
TemplateFileResolver..::..AbortChain Property
TemplateFileResolver Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool AbortChain { get; set; }
Visual Basic
Public Property AbortChain As Boolean
    Get
    Set
Visual C++
public:
property bool AbortChain {
    bool get ();
    void set (bool value);
}

Field Value

true if the TemplateFileResolver aborts the chain; otherwise, false.

See Also

TemplateFileResolver Class
Sitecore.Data.DataProviders Namespace


Sitecore.Data.DataProviders.Sql Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Data.DataProviders.Sql Namespace
Send Feedback

Classes

 | Class | Description
Public class | ConnectionInfo<(Of <(<'TConnection, TTransaction>)>)> | Represents a connection info.
Public class | DataProviderCommand | Base command class for SQL based data providers.
Public class | DataProviderReader | Base reader class for SQL based data providers.
Public class | DataProviderTransaction | Base transaction class for SQL based data providers.
Public class | SqlCommandBatch | Defines the SQL batch class.
Public class | SqlDataApi | Base class for SQL based data APIs.
Public class | SqlDataProvider | Base class for SQL based data providers.
Public class | SqlDataProvider..::..FieldSharingConverter | FieldSharingConverter object.
Public class | SqlStatement | SqlStatement

Delegates

 | Delegate | Description
Public delegate | SqlDataProvider..::..UpdateFieldValueDelegate | Delegate to update field values


ConnectionInfo(TConnection, TTransaction) Class

[image]

Sitecore 6.4.1 API
ConnectionInfo<(Of <(<'TConnection, TTransaction>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ConnectionInfo<TConnection, TTransaction>
where TConnection : IDbConnection
where TTransaction : IDbTransaction
Visual Basic
Public Class ConnectionInfo(Of TConnection As IDbConnection, TTransaction As IDbTransaction)
Visual C++
generic<typename TConnection, typename TTransaction>
where TConnection : IDbConnection
where TTransaction : IDbTransaction
public ref class ConnectionInfo

Type Parameters

TConnection

[Missing <typeparam name="TConnection"/> documentation for "T:Sitecore.Data.DataProviders.Sql.ConnectionInfo`2"]

TTransaction

[Missing <typeparam name="TTransaction"/> documentation for "T:Sitecore.Data.DataProviders.Sql.ConnectionInfo`2"]

Inheritance Hierarchy

System..::..Object
Sitecore.Data.DataProviders.Sql..::..ConnectionInfo<(Of <(<'TConnection, TTransaction>)>)>

See Also

ConnectionInfo<(Of <(<'TConnection, TTransaction>)>)> Members
Sitecore.Data.DataProviders.Sql Namespace


ConnectionInfo(TConnection, TTransaction) Constructor

[image] [image]

Sitecore 6.4.1 API
ConnectionInfo<(Of <(<'TConnection, TTransaction>)>)> Constructor
ConnectionInfo<(Of <(<'TConnection, TTransaction>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ConnectionInfo<(Of <(<'TConnection, TTransaction>)>)>(TConnection) | Initializes a new instance of the ConnectionInfo class.
Public method | ConnectionInfo<(Of <(<'TConnection, TTransaction>)>)>(TTransaction) | Initializes a new instance of the ConnectionInfo class.

See Also

ConnectionInfo<(Of <(<'TConnection, TTransaction>)>)> Class
ConnectionInfo<(Of <(<'TConnection, TTransaction>)>)> Members
Sitecore.Data.DataProviders.Sql Namespace


ConnectionInfo(TConnection, TTransaction) Constructor (TConnection)

[image]

Sitecore 6.4.1 API
ConnectionInfo<(Of <(<'TConnection, TTransaction>)>)> Constructor (TConnection)
ConnectionInfo<(Of <(<'TConnection, TTransaction>)>)> Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ConnectionInfo(
    TConnection connection
)
Visual Basic
Public Sub New ( _
    connection As TConnection _
)
Visual C++
public:
ConnectionInfo(
    TConnection connection
)

Parameters

connection
Type: TConnection
The connection.

See Also

ConnectionInfo<(Of <(<'TConnection, TTransaction>)>)> Class
ConnectionInfo<(Of <(<'TConnection, TTransaction>)>)> Overload
Sitecore.Data.DataProviders.Sql Namespace


ConnectionInfo(TConnection, TTransaction) Constructor (TTransaction)

[image]

Sitecore 6.4.1 API
ConnectionInfo<(Of <(<'TConnection, TTransaction>)>)> Constructor (TTransaction)
ConnectionInfo<(Of <(<'TConnection, TTransaction>)>)> Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ConnectionInfo(
    TTransaction transaction
)
Visual Basic
Public Sub New ( _
    transaction As TTransaction _
)
Visual C++
public:
ConnectionInfo(
    TTransaction transaction
)

Parameters

transaction
Type: TTransaction
The transaction.

See Also

ConnectionInfo<(Of <(<'TConnection, TTransaction>)>)> Class
ConnectionInfo<(Of <(<'TConnection, TTransaction>)>)> Overload
Sitecore.Data.DataProviders.Sql Namespace


ConnectionInfo(TConnection, TTransaction) Methods

[image] [image]

Sitecore 6.4.1 API
ConnectionInfo<(Of <(<'TConnection, TTransaction>)>)> Methods
ConnectionInfo<(Of <(<'TConnection, TTransaction>)>)> Class See Also Send Feedback

The ConnectionInfo<(Of <(<'TConnection, TTransaction>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConnectionInfo<(Of <(<'TConnection, TTransaction>)>)> Class
Sitecore.Data.DataProviders.Sql Namespace


ConnectionInfo(TConnection, TTransaction) Properties

[image] [image]

Sitecore 6.4.1 API
ConnectionInfo<(Of <(<'TConnection, TTransaction>)>)> Properties
ConnectionInfo<(Of <(<'TConnection, TTransaction>)>)> Class See Also Send Feedback

The ConnectionInfo<(Of <(<'TConnection, TTransaction>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Connection | Gets the connection.
Public property | Transaction | Gets the transaction.

See Also

ConnectionInfo<(Of <(<'TConnection, TTransaction>)>)> Class
Sitecore.Data.DataProviders.Sql Namespace


Connection Property

[image]

Sitecore 6.4.1 API
ConnectionInfo<(Of <(<'TConnection, TTransaction>)>)>..::..Connection Property
ConnectionInfo<(Of <(<'TConnection, TTransaction>)>)> Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TConnection Connection { get; }
Visual Basic
Public ReadOnly Property Connection As TConnection
    Get
Visual C++
public:
property TConnection Connection {
    TConnection get ();
}

Field Value

The connection.

See Also

ConnectionInfo<(Of <(<'TConnection, TTransaction>)>)> Class
Sitecore.Data.DataProviders.Sql Namespace


DataProviderCommand Members

[image] [image]

Sitecore 6.4.1 API
DataProviderCommand Members
DataProviderCommand Class Constructors Methods See Also Send Feedback

The DataProviderCommand type exposes the following members.

Constructors

 | Name | Description
Public method | DataProviderCommand(IDbCommand, Boolean) | Constructs an instance of DataProviderCommand
Public method | DataProviderCommand(IDbCommand, DataProviderTransaction, Boolean) | Constructs an instance of DataProviderCommand

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteNonQuery | Executes the non query.
Public method | ExecuteNoResult | Executes with no result.
Public method | ExecuteReader | Executes the reader.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataProviderCommand Class
Sitecore.Data.DataProviders.Sql Namespace


DataProviderCommand Constructor

[image] [image]

Sitecore 6.4.1 API
DataProviderCommand Constructor
DataProviderCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DataProviderCommand(IDbCommand, Boolean) | Constructs an instance of DataProviderCommand
Public method | DataProviderCommand(IDbCommand, DataProviderTransaction, Boolean) | Constructs an instance of DataProviderCommand

See Also

DataProviderCommand Class
DataProviderCommand Members
Sitecore.Data.DataProviders.Sql Namespace


DataProviderCommand Constructor (IDbCommand, Boolean)

[image]

Sitecore 6.4.1 API
DataProviderCommand Constructor (IDbCommand, Boolean)
DataProviderCommand Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataProviderCommand(
    IDbCommand command,
    bool openConnection
)
Visual Basic
Public Sub New ( _
    command As IDbCommand, _
    openConnection As Boolean _
)
Visual C++
public:
DataProviderCommand(
    IDbCommand^ command,
    bool openConnection
)

Parameters

command
Type: System.Data..::..IDbCommand
The command.
openConnection
Type: System..::..Boolean
if set to true this instance is open connection.

See Also

DataProviderCommand Class
DataProviderCommand Overload
Sitecore.Data.DataProviders.Sql Namespace


DataProviderCommand Constructor (IDbCommand, DataProviderTransaction, Boolean)

[image]

Sitecore 6.4.1 API
DataProviderCommand Constructor (IDbCommand, DataProviderTransaction, Boolean)
DataProviderCommand Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataProviderCommand(
    IDbCommand command,
    DataProviderTransaction transaction,
    bool openConnection
)
Visual Basic
Public Sub New ( _
    command As IDbCommand, _
    transaction As DataProviderTransaction, _
    openConnection As Boolean _
)
Visual C++
public:
DataProviderCommand(
    IDbCommand^ command,
    DataProviderTransaction^ transaction,
    bool openConnection
)

Parameters

command
Type: System.Data..::..IDbCommand
The command.
transaction
Type: Sitecore.Data.DataProviders.Sql..::..DataProviderTransaction
The transaction.
openConnection
Type: System..::..Boolean
if set to true this instance is open connection.

See Also

DataProviderCommand Class
DataProviderCommand Overload
Sitecore.Data.DataProviders.Sql Namespace


DataProviderCommand Methods

[image] [image]

Sitecore 6.4.1 API
DataProviderCommand Methods
DataProviderCommand Class See Also Send Feedback

The DataProviderCommand type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteNonQuery | Executes the non query.
Public method | ExecuteNoResult | Executes with no result.
Public method | ExecuteReader | Executes the reader.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataProviderCommand Class
Sitecore.Data.DataProviders.Sql Namespace


Dispose Method

[image]

Sitecore 6.4.1 API
DataProviderCommand..::..Dispose Method
DataProviderCommand Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Dispose()
Visual Basic
Public Overridable Sub Dispose
Visual C++
public:
virtual void Dispose()

Implements

IDisposable..::..Dispose()()()()

See Also

DataProviderCommand Class
Sitecore.Data.DataProviders.Sql Namespace


ExecuteNonQuery Method

[image]

Sitecore 6.4.1 API
DataProviderCommand..::..ExecuteNonQuery Method
DataProviderCommand Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual int ExecuteNonQuery()
Visual Basic
Public Overridable Function ExecuteNonQuery As Integer
Visual C++
public:
virtual int ExecuteNonQuery()

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.Sql.DataProviderCommand.ExecuteNonQuery"]

See Also

DataProviderCommand Class
Sitecore.Data.DataProviders.Sql Namespace


ExecuteNoResult Method

[image]

Sitecore 6.4.1 API
DataProviderCommand..::..ExecuteNoResult Method
DataProviderCommand Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void ExecuteNoResult()
Visual Basic
Public Overridable Sub ExecuteNoResult
Visual C++
public:
virtual void ExecuteNoResult()

See Also

DataProviderCommand Class
Sitecore.Data.DataProviders.Sql Namespace


ExecuteReader Method

[image]

Sitecore 6.4.1 API
DataProviderCommand..::..ExecuteReader Method
DataProviderCommand Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual IDataReader ExecuteReader()
Visual Basic
Public Overridable Function ExecuteReader As IDataReader
Visual C++
public:
virtual IDataReader^ ExecuteReader()

Return Value

The reader.

See Also

DataProviderCommand Class
Sitecore.Data.DataProviders.Sql Namespace


DataProviderReader Class

[image]

Sitecore 6.4.1 API
DataProviderReader Class
Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DataProviderReader : IDisposable
Visual Basic
Public Class DataProviderReader _
    Implements IDisposable
Visual C++
public ref class DataProviderReader : IDisposable

Inheritance Hierarchy

System..::..Object
Sitecore.Data.DataProviders.Sql..::..DataProviderReader

See Also

DataProviderReader Members
Sitecore.Data.DataProviders.Sql Namespace


DataProviderReader Members

[image] [image]

Sitecore 6.4.1 API
DataProviderReader Members
DataProviderReader Class Constructors Methods Properties See Also Send Feedback

The DataProviderReader type exposes the following members.

Constructors

 | Name | Description
Public method | DataProviderReader | Initializes a new instance of the DataProviderReader class.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads this instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | InnerReader | Gets a reference to the embedded reader.

See Also

DataProviderReader Class
Sitecore.Data.DataProviders.Sql Namespace


DataProviderReader Constructor

[image]

Sitecore 6.4.1 API
DataProviderReader Constructor
DataProviderReader Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataProviderReader(
    DataProviderCommand command
)
Visual Basic
Public Sub New ( _
    command As DataProviderCommand _
)
Visual C++
public:
DataProviderReader(
    DataProviderCommand^ command
)

Parameters

command
Type: Sitecore.Data.DataProviders.Sql..::..DataProviderCommand
The command.

See Also

DataProviderReader Class
Sitecore.Data.DataProviders.Sql Namespace


DataProviderReader Methods

[image] [image]

Sitecore 6.4.1 API
DataProviderReader Methods
DataProviderReader Class See Also Send Feedback

The DataProviderReader type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads this instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataProviderReader Class
Sitecore.Data.DataProviders.Sql Namespace


Dispose Method

[image]

Sitecore 6.4.1 API
DataProviderReader..::..Dispose Method
DataProviderReader Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Dispose()
Visual Basic
Public Overridable Sub Dispose
Visual C++
public:
virtual void Dispose()

Implements

IDisposable..::..Dispose()()()()

See Also

DataProviderReader Class
Sitecore.Data.DataProviders.Sql Namespace


Read Method

[image]

Sitecore 6.4.1 API
DataProviderReader..::..Read Method
DataProviderReader Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool Read()
Visual Basic
Public Overridable Function Read As Boolean
Visual C++
public:
virtual bool Read()

Return Value

The read.

See Also

DataProviderReader Class
Sitecore.Data.DataProviders.Sql Namespace


DataProviderReader Properties

[image] [image]

Sitecore 6.4.1 API
DataProviderReader Properties
DataProviderReader Class See Also Send Feedback

The DataProviderReader type exposes the following members.

Properties

 | Name | Description
Public property | InnerReader | Gets a reference to the embedded reader.

See Also

DataProviderReader Class
Sitecore.Data.DataProviders.Sql Namespace


InnerReader Property

[image]

Sitecore 6.4.1 API
DataProviderReader..::..InnerReader Property
DataProviderReader Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IDataReader InnerReader { get; }
Visual Basic
Public ReadOnly Property InnerReader As IDataReader
    Get
Visual C++
public:
property IDataReader^ InnerReader {
    IDataReader^ get ();
}

Field Value

The inner reader.

See Also

DataProviderReader Class
Sitecore.Data.DataProviders.Sql Namespace


DataProviderTransaction Class

[image]

Sitecore 6.4.1 API
DataProviderTransaction Class
Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DataProviderTransaction : IDisposable
Visual Basic
Public Class DataProviderTransaction _
    Implements IDisposable
Visual C++
public ref class DataProviderTransaction : IDisposable

Inheritance Hierarchy

System..::..Object
Sitecore.Data.DataProviders.Sql..::..DataProviderTransaction

See Also

DataProviderTransaction Members
Sitecore.Data.DataProviders.Sql Namespace


DataProviderTransaction Members

[image] [image]

Sitecore 6.4.1 API
DataProviderTransaction Members
DataProviderTransaction Class Constructors Methods Properties See Also Send Feedback

The DataProviderTransaction type exposes the following members.

Constructors

 | Name | Description
Public method | DataProviderTransaction(IDbConnection, String) | Initializes a new instance of the DataProviderTransaction class. Constructs an instance of DataProviderTransactionScope
Public method | DataProviderTransaction(IDbConnection, String, SqlCommandBatch) | Initializes a new instance of the DataProviderTransaction class. Constructs an instance of DataProviderTransactionScope

Methods

 | Name | Description
Public method | AppendCommand | Appends command to transaction batch.
Public method | Complete | Completes this instance.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | Commits the batch.
 | GetCurrentDataProviderTransaction | Gets the current data provider transaction.
 | GetCurrentTransaction | Gets the current transaction context.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PopTransaction | Pops the transaction.
Protected method | PushTransaction | Pushes the transaction.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Transaction | Gets the transaction.

See Also

DataProviderTransaction Class
Sitecore.Data.DataProviders.Sql Namespace


DataProviderTransaction Constructor

[image] [image]

Sitecore 6.4.1 API
DataProviderTransaction Constructor
DataProviderTransaction Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DataProviderTransaction(IDbConnection, String) | Initializes a new instance of the DataProviderTransaction class. Constructs an instance of DataProviderTransactionScope
Public method | DataProviderTransaction(IDbConnection, String, SqlCommandBatch) | Initializes a new instance of the DataProviderTransaction class. Constructs an instance of DataProviderTransactionScope

See Also

DataProviderTransaction Class
DataProviderTransaction Members
Sitecore.Data.DataProviders.Sql Namespace


DataProviderTransaction Constructor (IDbConnection, String)

[image]

Sitecore 6.4.1 API
DataProviderTransaction Constructor (IDbConnection, String)
DataProviderTransaction Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataProviderTransaction(
    IDbConnection connection,
    string key
)
Visual Basic
Public Sub New ( _
    connection As IDbConnection, _
    key As String _
)
Visual C++
public:
DataProviderTransaction(
    IDbConnection^ connection,
    String^ key
)

Parameters

connection
Type: System.Data..::..IDbConnection
The connection.
key
Type: System..::..String
The key of the transaction in the current thread's transaction dictionary.

See Also

DataProviderTransaction Class
DataProviderTransaction Overload
Sitecore.Data.DataProviders.Sql Namespace


DataProviderTransaction Constructor (IDbConnection, String, SqlCommandBatch)

[image]

Sitecore 6.4.1 API
DataProviderTransaction Constructor (IDbConnection, String, SqlCommandBatch)
DataProviderTransaction Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataProviderTransaction(
    IDbConnection connection,
    string key,
    SqlCommandBatch batch
)
Visual Basic
Public Sub New ( _
    connection As IDbConnection, _
    key As String, _
    batch As SqlCommandBatch _
)
Visual C++
public:
DataProviderTransaction(
    IDbConnection^ connection,
    String^ key,
    SqlCommandBatch^ batch
)

Parameters

connection
Type: System.Data..::..IDbConnection
The connection.
key
Type: System..::..String
The key of the transaction in the current thread's transaction dictionary.
batch
Type: Sitecore.Data.DataProviders.Sql..::..SqlCommandBatch
The implementation of SqlBatch to use.

See Also

DataProviderTransaction Class
DataProviderTransaction Overload
Sitecore.Data.DataProviders.Sql Namespace


DataProviderTransaction Methods

[image] [image]

Sitecore 6.4.1 API
DataProviderTransaction Methods
DataProviderTransaction Class See Also Send Feedback

The DataProviderTransaction type exposes the following members.

Methods

 | Name | Description
Public method | AppendCommand | Appends command to transaction batch.
Public method | Complete | Completes this instance.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | Commits the batch.
 | GetCurrentDataProviderTransaction | Gets the current data provider transaction.
 | GetCurrentTransaction | Gets the current transaction context.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PopTransaction | Pops the transaction.
Protected method | PushTransaction | Pushes the transaction.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataProviderTransaction Class
Sitecore.Data.DataProviders.Sql Namespace


AppendCommand Method

[image]

Sitecore 6.4.1 API
DataProviderTransaction..::..AppendCommand Method
DataProviderTransaction Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AppendCommand(
    IDbCommand command
)
Visual Basic
Public Sub AppendCommand ( _
    command As IDbCommand _
)
Visual C++
public:
void AppendCommand(
    IDbCommand^ command
)

Parameters

command
Type: System.Data..::..IDbCommand
The command.

See Also

DataProviderTransaction Class
Sitecore.Data.DataProviders.Sql Namespace


Complete Method

[image]

Sitecore 6.4.1 API
DataProviderTransaction..::..Complete Method
DataProviderTransaction Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Complete()
Visual Basic
Public Overridable Sub Complete
Visual C++
public:
virtual void Complete()

See Also

DataProviderTransaction Class
Sitecore.Data.DataProviders.Sql Namespace


Flush Method

[image]

Sitecore 6.4.1 API
DataProviderTransaction..::..Flush Method
DataProviderTransaction Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Flush()
Visual Basic
Public Overridable Sub Flush
Visual C++
public:
virtual void Flush()

See Also

DataProviderTransaction Class
Sitecore.Data.DataProviders.Sql Namespace


GetCurrentDataProviderTransaction Method

[image]

Sitecore 6.4.1 API
DataProviderTransaction..::..GetCurrentDataProviderTransaction Method
DataProviderTransaction Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static DataProviderTransaction GetCurrentDataProviderTransaction(
    string key
)
Visual Basic
Public Shared Function GetCurrentDataProviderTransaction ( _
    key As String _
) As DataProviderTransaction
Visual C++
public:
static DataProviderTransaction^ GetCurrentDataProviderTransaction(
    String^ key
)

Parameters

key
Type: System..::..String
The key.

Return Value

The current data provider transaction.

See Also

DataProviderTransaction Class
Sitecore.Data.DataProviders.Sql Namespace


GetCurrentTransaction Method

[image]

Sitecore 6.4.1 API
DataProviderTransaction..::..GetCurrentTransaction Method
DataProviderTransaction Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static IDbTransaction GetCurrentTransaction(
    string key
)
Visual Basic
Public Shared Function GetCurrentTransaction ( _
    key As String _
) As IDbTransaction
Visual C++
public:
static IDbTransaction^ GetCurrentTransaction(
    String^ key
)

Parameters

key
Type: System..::..String
The connection string.

Return Value

The current transaction.

See Also

DataProviderTransaction Class
Sitecore.Data.DataProviders.Sql Namespace


PopTransaction Method

[image]

Sitecore 6.4.1 API
DataProviderTransaction..::..PopTransaction Method
DataProviderTransaction Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void PopTransaction()
Visual Basic
Protected Overridable Sub PopTransaction
Visual C++
protected:
virtual void PopTransaction()

See Also

DataProviderTransaction Class
Sitecore.Data.DataProviders.Sql Namespace


PushTransaction Method

[image]

Sitecore 6.4.1 API
DataProviderTransaction..::..PushTransaction Method
DataProviderTransaction Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void PushTransaction()
Visual Basic
Protected Overridable Sub PushTransaction
Visual C++
protected:
virtual void PushTransaction()

See Also

DataProviderTransaction Class
Sitecore.Data.DataProviders.Sql Namespace


DataProviderTransaction Properties

[image] [image]

Sitecore 6.4.1 API
DataProviderTransaction Properties
DataProviderTransaction Class See Also Send Feedback

The DataProviderTransaction type exposes the following members.

Properties

 | Name | Description
Public property | Transaction | Gets the transaction.

See Also

DataProviderTransaction Class
Sitecore.Data.DataProviders.Sql Namespace


Transaction Property

[image]

Sitecore 6.4.1 API
DataProviderTransaction..::..Transaction Property
DataProviderTransaction Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IDbTransaction Transaction { get; }
Visual Basic
Public ReadOnly Property Transaction As IDbTransaction
    Get
Visual C++
public:
property IDbTransaction^ Transaction {
    IDbTransaction^ get ();
}

Field Value

The transaction.

See Also

DataProviderTransaction Class
Sitecore.Data.DataProviders.Sql Namespace


SqlCommandBatch Class

[image]

Sitecore 6.4.1 API
SqlCommandBatch Class
Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SqlCommandBatch
Visual Basic
Public Class SqlCommandBatch
Visual C++
public ref class SqlCommandBatch

Inheritance Hierarchy

System..::..Object
Sitecore.Data.DataProviders.Sql..::..SqlCommandBatch
Sitecore.Data.SqlServer..::..SqlServerCommandBatch

See Also

SqlCommandBatch Members
Sitecore.Data.DataProviders.Sql Namespace


SqlCommandBatch Members

[image] [image]

Sitecore 6.4.1 API
SqlCommandBatch Members
SqlCommandBatch Class Constructors Methods Properties See Also Send Feedback

The SqlCommandBatch type exposes the following members.

Constructors

 | Name | Description
Public method | SqlCommandBatch | Initializes a new instance of the SqlCommandBatch class

Methods

 | Name | Description
Public method | AddCommand | Adds the command.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Translate | Translates this batch into a command

Properties

 | Name | Description
Public property | Count | Gets the count of commands in the batch.

See Also

SqlCommandBatch Class
Sitecore.Data.DataProviders.Sql Namespace


SqlCommandBatch Constructor

[image]

Sitecore 6.4.1 API
SqlCommandBatch Constructor
SqlCommandBatch Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlCommandBatch()
Visual Basic
Public Sub New
Visual C++
public:
SqlCommandBatch()

See Also

SqlCommandBatch Class
Sitecore.Data.DataProviders.Sql Namespace


SqlCommandBatch Methods

[image] [image]

Sitecore 6.4.1 API
SqlCommandBatch Methods
SqlCommandBatch Class See Also Send Feedback

The SqlCommandBatch type exposes the following members.

Methods

 | Name | Description
Public method | AddCommand | Adds the command.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Translate | Translates this batch into a command

See Also

SqlCommandBatch Class
Sitecore.Data.DataProviders.Sql Namespace


AddCommand Method

[image]

Sitecore 6.4.1 API
SqlCommandBatch..::..AddCommand Method
SqlCommandBatch Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void AddCommand(
    IDbCommand command
)
Visual Basic
Public Overridable Sub AddCommand ( _
    command As IDbCommand _
)
Visual C++
public:
virtual void AddCommand(
    IDbCommand^ command
)

Parameters

command
Type: System.Data..::..IDbCommand
The command.

See Also

SqlCommandBatch Class
Sitecore.Data.DataProviders.Sql Namespace


Translate Method

[image]

Sitecore 6.4.1 API
SqlCommandBatch..::..Translate Method
SqlCommandBatch Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual IDbCommand Translate()
Visual Basic
Public Overridable Function Translate As IDbCommand
Visual C++
public:
virtual IDbCommand^ Translate()

Return Value

The IDbCommand to execute.

See Also

SqlCommandBatch Class
Sitecore.Data.DataProviders.Sql Namespace


SqlCommandBatch Properties

[image] [image]

Sitecore 6.4.1 API
SqlCommandBatch Properties
SqlCommandBatch Class See Also Send Feedback

The SqlCommandBatch type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the count of commands in the batch.

See Also

SqlCommandBatch Class
Sitecore.Data.DataProviders.Sql Namespace


SqlDataApi Class

[image]

Sitecore 6.4.1 API
SqlDataApi Class
Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class SqlDataApi
Visual Basic
Public MustInherit Class SqlDataApi
Visual C++
public ref class SqlDataApi abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Data.DataProviders.Sql..::..SqlDataApi
Sitecore.Data.SqlServer..::..SqlServerDataApi

See Also

SqlDataApi Members
Sitecore.Data.DataProviders.Sql Namespace


SqlDataApi Members

[image] [image]

Sitecore 6.4.1 API
SqlDataApi Members
SqlDataApi Class Constructors Methods Properties See Also Send Feedback

The SqlDataApi type exposes the following members.

Constructors

 | Name | Description
Protected method | SqlDataApi | Initializes a new instance of the SqlDataApi class

Methods

 | Name | Description
Public method | CreateBatch | Creates the sql command batch batch.
Public method | CreateCommand | Factory method for creating a new command object.
Protected method | CreateConnection | Creates a physical database connection.
Public method | CreateObjectReader<(Of <<'(T>)>>)(String, array<Object>[]()[][], Func<(Of <<'(DataProviderReader, T>)>>)) | Creates the object reader.
Public method | CreateObjectReader<(Of <<'(T>)>>)(String, array<Object>[]()[][], Func<(Of <<'(IDataReader, T>)>>)) | Creates the object reader.
Protected method | CreateParameter | Creates a parameter for use in a command.
Public method | CreateReader | Factory method for creating an instance of a DataProviderReader
Public method | CreateTransaction | Factory method for creating an instance of a DataProviderTransaction
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the specified SQL.
Public method | ExecuteNoResult | Executes the no result.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Format | Formats the specified SQL.
Public method | FormatRawID | Formats ID to be used in raw SQL queries (e.g. itemID in 'select * from items where id = :itemID')
Public method | GetBoolean | Gets the boolean.
Public method | GetDateTime | Gets a date/time value from a specified column.
Public method | GetGuid | Gets an id value from a specified column.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetId | Gets an id value from a specified column.
Public method | GetInt | Gets an int32 value from a specified column.
Public method | GetInt32 | Gets an integer result from an SQL query.
Public method | GetLanguage | Gets a language value from a specified column.
Public method | GetLong | Gets an int64 value from a specified column.
Public method | GetString | Gets a string value from a specified column.
Public method | GetStringList | Gets a list of string values from a database.
Public method | GetStringSet | Gets a list of string values from a database.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Gets a version value from a specified column.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Safe | Escapes a string for use in SQL statements.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConnectionString | Gets or sets the connection string for this connection.
Public property | EmptyStringLiteral | Gets the empty literal.
Public property | Identifier | Gets an identifier for the data API.
Public property | NamePostfix | Gets the postfix used for encapsulating table and column names in SQL statements.
Public property | NamePrefix | Gets the prefix used for encapsulating table and column names in SQL statements.
Public property | ParameterPostfix | Gets the postfix used for encapsulating parameter names in SQL statements.
Public property | ParameterPrefix | Gets the prefix used for encapsulating parameter names in SQL statements.
Public property | Quote | Gets the character used for encapsulating a string value in SQL statements.
Public property | Wildcard | Gets the character used for wildcard queries in SQL statements.

See Also

SqlDataApi Class
Sitecore.Data.DataProviders.Sql Namespace


SqlDataApi Methods

[image] [image]

Sitecore 6.4.1 API
SqlDataApi Methods
SqlDataApi Class See Also Send Feedback

The SqlDataApi type exposes the following members.

Methods

 | Name | Description
Public method | CreateBatch | Creates the sql command batch batch.
Public method | CreateCommand | Factory method for creating a new command object.
Protected method | CreateConnection | Creates a physical database connection.
Public method | CreateObjectReader<(Of <<'(T>)>>)(String, array<Object>[]()[][], Func<(Of <<'(DataProviderReader, T>)>>)) | Creates the object reader.
Public method | CreateObjectReader<(Of <<'(T>)>>)(String, array<Object>[]()[][], Func<(Of <<'(IDataReader, T>)>>)) | Creates the object reader.
Protected method | CreateParameter | Creates a parameter for use in a command.
Public method | CreateReader | Factory method for creating an instance of a DataProviderReader
Public method | CreateTransaction | Factory method for creating an instance of a DataProviderTransaction
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the specified SQL.
Public method | ExecuteNoResult | Executes the no result.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Format | Formats the specified SQL.
Public method | FormatRawID | Formats ID to be used in raw SQL queries (e.g. itemID in 'select * from items where id = :itemID')
Public method | GetBoolean | Gets the boolean.
Public method | GetDateTime | Gets a date/time value from a specified column.
Public method | GetGuid | Gets an id value from a specified column.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetId | Gets an id value from a specified column.
Public method | GetInt | Gets an int32 value from a specified column.
Public method | GetInt32 | Gets an integer result from an SQL query.
Public method | GetLanguage | Gets a language value from a specified column.
Public method | GetLong | Gets an int64 value from a specified column.
Public method | GetString | Gets a string value from a specified column.
Public method | GetStringList | Gets a list of string values from a database.
Public method | GetStringSet | Gets a list of string values from a database.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Gets a version value from a specified column.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Safe | Escapes a string for use in SQL statements.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SqlDataApi Class
Sitecore.Data.DataProviders.Sql Namespace


CreateBatch Method

[image]

Sitecore 6.4.1 API
SqlDataApi..::..CreateBatch Method
SqlDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual SqlCommandBatch CreateBatch()
Visual Basic
Public Overridable Function CreateBatch As SqlCommandBatch
Visual C++
public:
virtual SqlCommandBatch^ CreateBatch()

Return Value

The batch.

See Also

SqlDataApi Class
Sitecore.Data.DataProviders.Sql Namespace


CreateCommand Method

[image]

Sitecore 6.4.1 API
SqlDataApi..::..CreateCommand Method
SqlDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual DataProviderCommand CreateCommand(
    string sql,
    params Object[] parameters
)
Visual Basic
Public Overridable Function CreateCommand ( _
    sql As String, _
    ParamArray parameters As Object() _
) As DataProviderCommand
Visual C++
public:
virtual DataProviderCommand^ CreateCommand(
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

sql
Type: System..::..String
The SQL to execute.
parameters
Type: array< System..::..Object >[]()[][]
The values of any parameters embedded in the SQL. These should be on the form {"name1", value1, "name2", value2}.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.Sql.SqlDataApi.CreateCommand(System.String,System.Object[])"]

See Also

SqlDataApi Class
Sitecore.Data.DataProviders.Sql Namespace


CreateConnection Method

[image]

Sitecore 6.4.1 API
SqlDataApi..::..CreateConnection Method
SqlDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected abstract IDbConnection CreateConnection()
Visual Basic
Protected MustOverride Function CreateConnection As IDbConnection
Visual C++
protected:
virtual IDbConnection^ CreateConnection() abstract

Return Value

A connection to the database. Note that the connection will not be open.

See Also

SqlDataApi Class
Sitecore.Data.DataProviders.Sql Namespace


CreateObjectReader Method

[image] [image]

Sitecore 6.4.1 API
SqlDataApi..::..CreateObjectReader Method
SqlDataApi Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateObjectReader<(Of <<'(T>)>>)(String, array<Object>[]()[][], Func<(Of <<'(DataProviderReader, T>)>>)) | Creates the object reader.
Public method | CreateObjectReader<(Of <<'(T>)>>)(String, array<Object>[]()[][], Func<(Of <<'(IDataReader, T>)>>)) | Creates the object reader.

See Also

SqlDataApi Class
SqlDataApi Members
Sitecore.Data.DataProviders.Sql Namespace


CreateObjectReader(T) Method (String, Object[], Func(DataProviderReader, T))

[image]

Sitecore 6.4.1 API
SqlDataApi..::..CreateObjectReader<(Of <(<'T>)>)> Method (String, array<Object>[]()[][], Func<(Of <(<'DataProviderReader, T>)>)>)
SqlDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IEnumerable<T> CreateObjectReader<T>(
    string sql,
    Object[] parameters,
    Func<DataProviderReader, T> materializer
)
Visual Basic
Public Function CreateObjectReader(Of T) ( _
    sql As String, _
    parameters As Object(), _
    materializer As Func(Of DataProviderReader, T) _
) As IEnumerable(Of T)
Visual C++
public:
generic<typename T>
IEnumerable<T>^ CreateObjectReader(
    String^ sql,
    array<Object^>^ parameters,
    Func<DataProviderReader^, T>^ materializer
)

Parameters

sql
Type: System..::..String
The SQL statement to execute.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.
materializer
Type: System..::..Func <(Of <(<' DataProviderReader, T>)>)>
The materializer.

Type Parameters

T
The generic type.

Return Value

The result.

See Also

SqlDataApi Class
CreateObjectReader Overload
Sitecore.Data.DataProviders.Sql Namespace


CreateObjectReader(T) Method (String, Object[], Func(IDataReader, T))

[image]

Sitecore 6.4.1 API
SqlDataApi..::..CreateObjectReader<(Of <(<'T>)>)> Method (String, array<Object>[]()[][], Func<(Of <(<'IDataReader, T>)>)>)
SqlDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IEnumerable<T> CreateObjectReader<T>(
    string sql,
    Object[] parameters,
    Func<IDataReader, T> materializer
)
Visual Basic
Public Function CreateObjectReader(Of T) ( _
    sql As String, _
    parameters As Object(), _
    materializer As Func(Of IDataReader, T) _
) As IEnumerable(Of T)
Visual C++
public:
generic<typename T>
IEnumerable<T>^ CreateObjectReader(
    String^ sql,
    array<Object^>^ parameters,
    Func<IDataReader^, T>^ materializer
)

Parameters

sql
Type: System..::..String
The SQL statement to execute.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.
materializer
Type: System..::..Func <(Of <(<' IDataReader, T>)>)>
The materializer.

Type Parameters

T
The generic type.

Return Value

The result.

See Also

SqlDataApi Class
CreateObjectReader Overload
Sitecore.Data.DataProviders.Sql Namespace


CreateParameter Method

[image]

Sitecore 6.4.1 API
SqlDataApi..::..CreateParameter Method
SqlDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected abstract IDbDataParameter CreateParameter(
    string name,
    Object value
)
Visual Basic
Protected MustOverride Function CreateParameter ( _
    name As String, _
    value As Object _
) As IDbDataParameter
Visual C++
protected:
virtual IDbDataParameter^ CreateParameter(
    String^ name,
    Object^ value
) abstract

Parameters

name
Type: System..::..String
The name of the parameter.
value
Type: System..::..Object
The value of the parameter.

Return Value

A parameter object in which the DbType of the value has been set and where the parameter value has been mapped to the native value expected by the database.

For instance, if value is an ID, the parameter value might be a Guid representing the same value.

See Also

SqlDataApi Class
Sitecore.Data.DataProviders.Sql Namespace


CreateReader Method

[image]

Sitecore 6.4.1 API
SqlDataApi..::..CreateReader Method
SqlDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual DataProviderReader CreateReader(
    string sql,
    params Object[] parameters
)
Visual Basic
Public Overridable Function CreateReader ( _
    sql As String, _
    ParamArray parameters As Object() _
) As DataProviderReader
Visual C++
public:
virtual DataProviderReader^ CreateReader(
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

sql
Type: System..::..String
The SQL that will be executed to obtain the reader.
parameters
Type: array< System..::..Object >[]()[][]
The parameters for the SQl command.

Return Value

A reader that can be used to traverse the result set.

Exceptions

Exception | Condition
System..::..Exception | Exception.

See Also

SqlDataApi Class
Sitecore.Data.DataProviders.Sql Namespace


CreateTransaction Method

[image]

Sitecore 6.4.1 API
SqlDataApi..::..CreateTransaction Method
SqlDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual DataProviderTransaction CreateTransaction()
Visual Basic
Public Overridable Function CreateTransaction As DataProviderTransaction
Visual C++
public:
virtual DataProviderTransaction^ CreateTransaction()

Return Value

A transaction object.

See Also

SqlDataApi Class
Sitecore.Data.DataProviders.Sql Namespace


Execute Method

[image]

Sitecore 6.4.1 API
SqlDataApi..::..Execute Method
SqlDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual int Execute(
    string sql,
    params Object[] parameters
)
Visual Basic
Public Overridable Function Execute ( _
    sql As String, _
    ParamArray parameters As Object() _
) As Integer
Visual C++
public:
virtual int Execute(
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

sql
Type: System..::..String
The SQL statement to execute.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.

Return Value

The execute.

See Also

SqlDataApi Class
Sitecore.Data.DataProviders.Sql Namespace


ExecuteNoResult Method

[image]

Sitecore 6.4.1 API
SqlDataApi..::..ExecuteNoResult Method
SqlDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void ExecuteNoResult(
    string sql,
    params Object[] parameters
)
Visual Basic
Public Overridable Sub ExecuteNoResult ( _
    sql As String, _
    ParamArray parameters As Object() _
)
Visual C++
public:
virtual void ExecuteNoResult(
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

sql
Type: System..::..String
The SQL.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.

See Also

SqlDataApi Class
Sitecore.Data.DataProviders.Sql Namespace


Format Method

[image]

Sitecore 6.4.1 API
SqlDataApi..::..Format Method
SqlDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string Format(
    string sql
)
Visual Basic
Public Overridable Function Format ( _
    sql As String _
) As String
Visual C++
public:
virtual String^ Format(
    String^ sql
)

Parameters

sql
Type: System..::..String
The SQL statement to format.

Return Value

The format.

See Also

SqlDataApi Class
Sitecore.Data.DataProviders.Sql Namespace


FormatRawID Method

[image]

Sitecore 6.4.1 API
SqlDataApi..::..FormatRawID Method
SqlDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string FormatRawID(
    ID id
)
Visual Basic
Public Overridable Function FormatRawID ( _
    id As ID _
) As String
Visual C++
public:
virtual String^ FormatRawID(
    ID^ id
)

Parameters

id
Type: Sitecore.Data..::..ID
The id to format.

Return Value

The raw ID.

See Also

SqlDataApi Class
Sitecore.Data.DataProviders.Sql Namespace


GetBoolean Method

[image]

Sitecore 6.4.1 API
SqlDataApi..::..GetBoolean Method
SqlDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool GetBoolean(
    int columnIndex,
    DataProviderReader reader
)
Visual Basic
Public Overridable Function GetBoolean ( _
    columnIndex As Integer, _
    reader As DataProviderReader _
) As Boolean
Visual C++
public:
virtual bool GetBoolean(
    int columnIndex,
    DataProviderReader^ reader
)

Parameters

columnIndex
Type: System..::..Int32
Index of the column.
reader
Type: Sitecore.Data.DataProviders.Sql..::..DataProviderReader
The reader.

Return Value

The boolean value.

See Also

SqlDataApi Class
Sitecore.Data.DataProviders.Sql Namespace


GetDateTime Method

[image]

Sitecore 6.4.1 API
SqlDataApi..::..GetDateTime Method
SqlDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract DateTime GetDateTime(
    int columnIndex,
    DataProviderReader reader
)
Visual Basic
Public MustOverride Function GetDateTime ( _
    columnIndex As Integer, _
    reader As DataProviderReader _
) As DateTime
Visual C++
public:
virtual DateTime GetDateTime(
    int columnIndex,
    DataProviderReader^ reader
) abstract

Parameters

columnIndex
Type: System..::..Int32
Index of the column.
reader
Type: Sitecore.Data.DataProviders.Sql..::..DataProviderReader
The reader.

Return Value

The column value cast to a DateTime

See Also

SqlDataApi Class
Sitecore.Data.DataProviders.Sql Namespace


GetGuid Method

[image]

Sitecore 6.4.1 API
SqlDataApi..::..GetGuid Method
SqlDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract Guid GetGuid(
    int columnIndex,
    DataProviderReader reader
)
Visual Basic
Public MustOverride Function GetGuid ( _
    columnIndex As Integer, _
    reader As DataProviderReader _
) As Guid
Visual C++
public:
virtual Guid GetGuid(
    int columnIndex,
    DataProviderReader^ reader
) abstract

Parameters

columnIndex
Type: System..::..Int32
Index of the column.
reader
Type: Sitecore.Data.DataProviders.Sql..::..DataProviderReader
The reader.

Return Value

The column value cast to a Guid

See Also

SqlDataApi Class
Sitecore.Data.DataProviders.Sql Namespace


GetId Method

[image]

Sitecore 6.4.1 API
SqlDataApi..::..GetId Method
SqlDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract ID GetId(
    int columnIndex,
    DataProviderReader reader
)
Visual Basic
Public MustOverride Function GetId ( _
    columnIndex As Integer, _
    reader As DataProviderReader _
) As ID
Visual C++
public:
virtual ID^ GetId(
    int columnIndex,
    DataProviderReader^ reader
) abstract

Parameters

columnIndex
Type: System..::..Int32
Index of the column.
reader
Type: Sitecore.Data.DataProviders.Sql..::..DataProviderReader
The reader.

Return Value

The column value cast to an ID

See Also

SqlDataApi Class
Sitecore.Data.DataProviders.Sql Namespace


GetInt Method

[image]

Sitecore 6.4.1 API
SqlDataApi..::..GetInt Method
SqlDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract int GetInt(
    int columnIndex,
    DataProviderReader reader
)
Visual Basic
Public MustOverride Function GetInt ( _
    columnIndex As Integer, _
    reader As DataProviderReader _
) As Integer
Visual C++
public:
virtual int GetInt(
    int columnIndex,
    DataProviderReader^ reader
) abstract

Parameters

columnIndex
Type: System..::..Int32
Index of the column.
reader
Type: Sitecore.Data.DataProviders.Sql..::..DataProviderReader
The reader.

Return Value

The column value cast to an Int32

See Also

SqlDataApi Class
Sitecore.Data.DataProviders.Sql Namespace


GetInt32 Method

[image]

Sitecore 6.4.1 API
SqlDataApi..::..GetInt32 Method
SqlDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual int GetInt32(
    string sql,
    int defaultValue,
    params Object[] parameters
)
Visual Basic
Public Overridable Function GetInt32 ( _
    sql As String, _
    defaultValue As Integer, _
    ParamArray parameters As Object() _
) As Integer
Visual C++
public:
virtual int GetInt32(
    String^ sql,
    int defaultValue,
    ... array<Object^>^ parameters
)

Parameters

sql
Type: System..::..String
A string containing an SQL statement.
defaultValue
Type: System..::..Int32
The default value.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.

Return Value

The result of the query as an integer.

See Also

SqlDataApi Class
Sitecore.Data.DataProviders.Sql Namespace


GetLong Method

[image]

Sitecore 6.4.1 API
SqlDataApi..::..GetLong Method
SqlDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract long GetLong(
    int columnIndex,
    DataProviderReader reader
)
Visual Basic
Public MustOverride Function GetLong ( _
    columnIndex As Integer, _
    reader As DataProviderReader _
) As Long
Visual C++
public:
virtual long long GetLong(
    int columnIndex,
    DataProviderReader^ reader
) abstract

Parameters

columnIndex
Type: System..::..Int32
Index of the column.
reader
Type: Sitecore.Data.DataProviders.Sql..::..DataProviderReader
The reader.

Return Value

The column value cast to an Int32

See Also

SqlDataApi Class
Sitecore.Data.DataProviders.Sql Namespace


GetStringList Method

[image]

Sitecore 6.4.1 API
SqlDataApi..::..GetStringList Method
SqlDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual List<string> GetStringList(
    string sql,
    Object[] parameters
)
Visual Basic
Public Overridable Function GetStringList ( _
    sql As String, _
    parameters As Object() _
) As List(Of String)
Visual C++
public:
virtual List<String^>^ GetStringList(
    String^ sql,
    array<Object^>^ parameters
)

Parameters

sql
Type: System..::..String
The SQL statement to execute.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.

Return Value

List of strings

See Also

SqlDataApi Class
Sitecore.Data.DataProviders.Sql Namespace


GetStringSet Method

[image]

Sitecore 6.4.1 API
SqlDataApi..::..GetStringSet Method
SqlDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Set<string> GetStringSet(
    string sql,
    params Object[] parameters
)
Visual Basic
Public Overridable Function GetStringSet ( _
    sql As String, _
    ParamArray parameters As Object() _
) As Set(Of String)
Visual C++
public:
virtual Set<String^>^ GetStringSet(
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

sql
Type: System..::..String
The SQL statement to execute.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.

Return Value

Set of strings

See Also

SqlDataApi Class
Sitecore.Data.DataProviders.Sql Namespace


GetVersion Method

[image]

Sitecore 6.4.1 API
SqlDataApi..::..GetVersion Method
SqlDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract Version GetVersion(
    int columnIndex,
    DataProviderReader reader
)
Visual Basic
Public MustOverride Function GetVersion ( _
    columnIndex As Integer, _
    reader As DataProviderReader _
) As Version
Visual C++
public:
virtual Version^ GetVersion(
    int columnIndex,
    DataProviderReader^ reader
) abstract

Parameters

columnIndex
Type: System..::..Int32
Index of the column.
reader
Type: Sitecore.Data.DataProviders.Sql..::..DataProviderReader
The reader.

Return Value

The column value cast to a Version

See Also

SqlDataApi Class
Sitecore.Data.DataProviders.Sql Namespace


Safe Method

[image]

Sitecore 6.4.1 API
SqlDataApi..::..Safe Method
SqlDataApi Class Example See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string Safe(
    string text
)
Visual Basic
Public Overridable Function Safe ( _
    text As String _
) As String
Visual C++
public:
virtual String^ Safe(
    String^ text
)

Parameters

text
Type: System..::..String
A string to escape.

Return Value

The escaped string.

Remarks

The base version of the method simply replaces a single quote with two single quotes, but individual implementations may override this behaviour.

Examples

CopyC#
string parameter = Safe("Andy's"); // "Andy''s"

See Also

SqlDataApi Class
Sitecore.Data.DataProviders.Sql Namespace


SqlDataApi Properties

[image] [image]

Sitecore 6.4.1 API
SqlDataApi Properties
SqlDataApi Class See Also Send Feedback

The SqlDataApi type exposes the following members.

Properties

 | Name | Description
Public property | ConnectionString | Gets or sets the connection string for this connection.
Public property | EmptyStringLiteral | Gets the empty literal.
Public property | Identifier | Gets an identifier for the data API.
Public property | NamePostfix | Gets the postfix used for encapsulating table and column names in SQL statements.
Public property | NamePrefix | Gets the prefix used for encapsulating table and column names in SQL statements.
Public property | ParameterPostfix | Gets the postfix used for encapsulating parameter names in SQL statements.
Public property | ParameterPrefix | Gets the prefix used for encapsulating parameter names in SQL statements.
Public property | Quote | Gets the character used for encapsulating a string value in SQL statements.
Public property | Wildcard | Gets the character used for wildcard queries in SQL statements.

See Also

SqlDataApi Class
Sitecore.Data.DataProviders.Sql Namespace


ConnectionString Property

[image]

Sitecore 6.4.1 API
SqlDataApi..::..ConnectionString Property
SqlDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract string ConnectionString { get; set; }
Visual Basic
Public MustOverride Property ConnectionString As String
    Get
    Set
Visual C++
public:
virtual property String^ ConnectionString {
    String^ get () abstract;
    void set (String^ value) abstract;
}

Field Value

The connection string.

See Also

SqlDataApi Class
Sitecore.Data.DataProviders.Sql Namespace


EmptyStringLiteral Property

[image]

Sitecore 6.4.1 API
SqlDataApi..::..EmptyStringLiteral Property
SqlDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string EmptyStringLiteral { get; }
Visual Basic
Public Overridable ReadOnly Property EmptyStringLiteral As String
    Get
Visual C++
public:
virtual property String^ EmptyStringLiteral {
    String^ get ();
}

Field Value

The empty literal.

See Also

SqlDataApi Class
Sitecore.Data.DataProviders.Sql Namespace


Identifier Property

[image]

Sitecore 6.4.1 API
SqlDataApi..::..Identifier Property
SqlDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string Identifier { get; }
Visual Basic
Public Overridable ReadOnly Property Identifier As String
    Get
Visual C++
public:
virtual property String^ Identifier {
    String^ get ();
}

Field Value

For SQL Server: The connection string.

See Also

SqlDataApi Class
Sitecore.Data.DataProviders.Sql Namespace


NamePostfix Property

[image]

Sitecore 6.4.1 API
SqlDataApi..::..NamePostfix Property
SqlDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract string NamePostfix { get; }
Visual Basic
Public MustOverride ReadOnly Property NamePostfix As String
    Get
Visual C++
public:
virtual property String^ NamePostfix {
    String^ get () abstract;
}

Remarks

For example, SQL Server will use: ].

See Also

SqlDataApi Class
Sitecore.Data.DataProviders.Sql Namespace


NamePrefix Property

[image]

Sitecore 6.4.1 API
SqlDataApi..::..NamePrefix Property
SqlDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract string NamePrefix { get; }
Visual Basic
Public MustOverride ReadOnly Property NamePrefix As String
    Get
Visual C++
public:
virtual property String^ NamePrefix {
    String^ get () abstract;
}

Remarks

For example, SQL Server will use: [.

See Also

SqlDataApi Class
Sitecore.Data.DataProviders.Sql Namespace


ParameterPostfix Property

[image]

Sitecore 6.4.1 API
SqlDataApi..::..ParameterPostfix Property
SqlDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract string ParameterPostfix { get; }
Visual Basic
Public MustOverride ReadOnly Property ParameterPostfix As String
    Get
Visual C++
public:
virtual property String^ ParameterPostfix {
    String^ get () abstract;
}

Remarks

For example, SQL Server will use: Empty.

See Also

SqlDataApi Class
Sitecore.Data.DataProviders.Sql Namespace


Quote Property

[image]

Sitecore 6.4.1 API
SqlDataApi..::..Quote Property
SqlDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract string Quote { get; }
Visual Basic
Public MustOverride ReadOnly Property Quote As String
    Get
Visual C++
public:
virtual property String^ Quote {
    String^ get () abstract;
}

Remarks

For example, SQL Server will use: '.

See Also

SqlDataApi Class
Sitecore.Data.DataProviders.Sql Namespace


Wildcard Property

[image]

Sitecore 6.4.1 API
SqlDataApi..::..Wildcard Property
SqlDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract string Wildcard { get; }
Visual Basic
Public MustOverride ReadOnly Property Wildcard As String
    Get
Visual C++
public:
virtual property String^ Wildcard {
    String^ get () abstract;
}

Remarks

For example, SQL Server will use: %.

See Also

SqlDataApi Class
Sitecore.Data.DataProviders.Sql Namespace


SqlDataProvider Class

[image]

Sitecore 6.4.1 API
SqlDataProvider Class
Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SqlDataProvider : DataProvider
Visual Basic
Public Class SqlDataProvider _
    Inherits DataProvider
Visual C++
public ref class SqlDataProvider : public DataProvider

Inheritance Hierarchy

System..::..Object
Sitecore.Data.DataProviders..::..DataProvider
Sitecore.Data.DataProviders.Sql..::..SqlDataProvider
Sitecore.Data.SqlServer..::..SqlServerDataProvider

See Also

SqlDataProvider Members
Sitecore.Data.DataProviders.Sql Namespace


SqlDataProvider Members

[image] [image]

Sitecore 6.4.1 API
SqlDataProvider Members
SqlDataProvider Class Constructors Methods Fields Properties See Also Send Feedback

The SqlDataProvider type exposes the following members.

Constructors

 | Name | Description
Public method | SqlDataProvider | Initializes a new instance of the SqlDataProvider class.

Methods

 | Name | Description
Protected method | AddPrefetch | Adds a prefetch option.
Public method | AddToPublishQueue | Adds an item to the publish queue. (Overrides DataProvider..::..AddToPublishQueue(ID, String, DateTime, CallContext).)
Public method | AddVersion | Adds a version to an item. (Overrides DataProvider..::..AddVersion(ItemDefinition, VersionUri, CallContext).)
Public method | BlobStreamExists | Determines whether the specified field contains a BLOB value. (Inherited from DataProvider.)
Public method | ChangeFieldSharing | Changes the type of field sharing for a single field. (Overrides DataProvider..::..ChangeFieldSharing(TemplateField, TemplateFieldSharing, CallContext).)
Public method | ChangeTemplate | Changes the template. (Overrides DataProvider..::..ChangeTemplate(ItemDefinition, TemplateChangeList, CallContext).)
Protected method | CleanupBlobs | Removes unused blob fields
Protected method | CleanupCyclicDependences | Cleanups the cyclic dependences. The items couldn't be removed by CleanupOrphans because always have a parent but is not participated in item tree.
Public method | CleanupDatabase | Cleanups the database. (Overrides DataProvider..::..CleanupDatabase(CallContext).)
Protected method | CleanupFields | Removes all field data for non-existing items.
Protected method | CleanupInvalidLanguageData | Removes all invalid language data (ie. data for which the language does not exist).
Protected method | CleanupOrphans | Removes orphaned items from the database.
Public method | CleanupPublishQueue | Cleans up the publish queue. (Overrides DataProvider..::..CleanupPublishQueue(DateTime, CallContext).)
Protected method | CleanupTemplateFields | Cleanups the template fields.
Public method | CopyItem | Copies an item. (Overrides DataProvider..::..CopyItem(ItemDefinition, ItemDefinition, String, ID, CallContext).)
Public method | CreateItem | Creates a item. (Overrides DataProvider..::..CreateItem(ID, String, ID, ItemDefinition, CallContext).)
Protected method | CreateSqlTranslator | Creates the SQL translator.
Public method | DeleteItem | Deletes an item. (Overrides DataProvider..::..DeleteItem(ItemDefinition, CallContext).)
Protected method | Descendants_ItemCreated | Performs changes to 'Descandants' table after item creation.
Protected method | Descendants_ItemDeleted | Performs changes to 'Descandants' table after item deleting.
Protected method | DoInitializeEvents | Performs the actual event initialization.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Exists | Check if data satisfying the specified SQL exists.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBlobStream | Gets the BLOB stream associated with a field. (Inherited from DataProvider.)
Public method | GetChildIDs | Gets the child ids of an item. (Overrides DataProvider..::..GetChildIDs(ItemDefinition, CallContext).)
Public method | GetDataSize | Gets the size of the data managed by the provider. (Overrides DataProvider..::..GetDataSize(Int32, Int32).)
Public method | GetDictionaryEntryCount | Gets the number of dictionary entries. (Overrides DataProvider..::..GetDictionaryEntryCount()()()().)
Public method | GetEventQueue | Gets the event queue driver. (Overrides DataProvider..::..GetEventQueue()()()().)
Protected method | GetFieldSharingConverter | Gets a SqlDataProvider..::..FieldSharingConverter.
Protected method | GetFieldValue | Gets the field value.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetIdEnumerator | Gets all id values.
Public method | GetItemDefinition | Gets the definition of an item. (Overrides DataProvider..::..GetItemDefinition(ID, CallContext).)
Public method | GetItemFields | Gets the fields of a specific item version. (Overrides DataProvider..::..GetItemFields(ItemDefinition, VersionUri, CallContext).)
Protected method | GetItemKeyColumnName | Gets the name of the 'item name' column.
Public method | GetItemsInWorkflowState | Gets all items that are in a specific workflow state. (Overrides DataProvider..::..GetItemsInWorkflowState(WorkflowInfo, CallContext).)
Public method | GetItemVersions | Gets a list of the available versions of an item. (Overrides DataProvider..::..GetItemVersions(ItemDefinition, CallContext).)
Public method | GetLanguages()()()() | Gets a list of all the language that have been defined in the database.
Public method | GetLanguages(CallContext) | Gets a list of all the language that have been defined in the database. (Overrides DataProvider..::..GetLanguages(CallContext).)
Protected method | GetLock | Gets a lock.
Public method | GetParentID | Gets the parent ID of an item. (Overrides DataProvider..::..GetParentID(ItemDefinition, CallContext).)
Protected method | GetPrefetchDataFromCache | Gets the prefetch data from cache.
Public method | GetProperty | Gets a property. (Overrides DataProvider..::..GetProperty(String, CallContext).)
Protected method | GetPropertyCore | Gets the property core.
Public method | GetPropertyKeys | Gets a list of property keys matching a specific prefix. (Overrides DataProvider..::..GetPropertyKeys(String, CallContext).)
Public method | GetPublishQueue | Gets the publish queue. (Overrides DataProvider..::..GetPublishQueue(DateTime, DateTime, CallContext).)
Protected method | GetResolverSql | Gets the resolver SQL.
Public method | GetRootID | Gets the root ID. (Overrides DataProvider..::..GetRootID(CallContext).)
Public method | GetSharingType | Gets the type of the sharing.
Public method | GetTemplateItemIds | Gets the template item id. (Overrides DataProvider..::..GetTemplateItemIds(CallContext).)
Public method | GetTemplates | Gets the templates. (Inherited from DataProvider.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetVersions | Gets a list of all versions that have been defined in the entire database.
Public method | GetWorkflowInfo | Gets the workflow info form an item. (Inherited from DataProvider.)
Public method | HasChildren | Determines whether the specified item definition has children. (Overrides DataProvider..::..HasChildren(ItemDefinition, CallContext).)
Public method | IsEnabled | Determines whether the specified method is enabled. (Inherited from DataProvider.)
Protected method | LoadChildIds | Loads the child ids.
Protected method | LoadItemDefinitions | Loads the item definitions.
Protected method | LoadItemFields | Loads the item fields.
Protected method | LoadLanguages | Loads the list of languages from the database.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveItem | Moves an item (ie. changes its parent). (Overrides DataProvider..::..MoveItem(ItemDefinition, ItemDefinition, CallContext).)
Protected method | QueryFast | Executes fast query.
Protected method | RebuildDescendants | Rebuilds the descendants table.
Protected method | RemoveFields | Removes the fields.
Public method | RemoveLanguageData | Removes a language and all the data using the language from the database. (Overrides DataProvider..::..RemoveLanguageData(Language, CallContext).)
Protected method | RemovePrefetchDataFromCache | Removes prefetch data from the cache.
Public method | RemoveProperty | Removes a property. (Overrides DataProvider..::..RemoveProperty(String, Boolean, CallContext).)
Protected method | RemovePropertyCore | Removes the property core.
Public method | RemoveVersion | Removes a version from an item. (Overrides DataProvider..::..RemoveVersion(ItemDefinition, VersionUri, CallContext).)
Public method | RemoveVersions(ItemDefinition, Language, CallContext) | Removes versions from an item. (Inherited from DataProvider.)
Public method | RemoveVersions(ItemDefinition, Language, Boolean, CallContext) | Removes versions from an item. (Overrides DataProvider..::..RemoveVersions(ItemDefinition, Language, Boolean, CallContext).)
Public method | RenameLanguageData | Renames a language binding. (Overrides DataProvider..::..RenameLanguageData(String, String, CallContext).)
Protected method | ResolveNames | Resolves the names.
Public method | ResolvePath | Resolves the path. (Inherited from DataProvider.)
Public method | SaveItem | Saves an item. (Overrides DataProvider..::..SaveItem(ItemDefinition, ItemChanges, CallContext).)
Public method | SelectIDs | Selects a set of ids. (Overrides DataProvider..::..SelectIDs(String, CallContext).)
Public method | SelectSingleID | Selects a single ID. (Overrides DataProvider..::..SelectSingleID(String, CallContext).)
Public method | SetBlobStream | Sets the BLOB stream associated with a field. (Inherited from DataProvider.)
Protected method | SetFieldValue | Sets the field value.
Public method | SetProperty | Sets a property. (Overrides DataProvider..::..SetProperty(String, String, CallContext).)
Protected method | SetPropertyCore | Sets the property core.
Public method | SetWorkflowInfo | Sets the workflow info for an item. (Inherited from DataProvider.)
Protected method | StartRebuildDescendants | Starts the rebuild descendants.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateFieldValues | Updates field values.
Protected method | WriteSharedField | Writes the shared field.
Protected method | WriteUnversionedField | Writes the unversioned field.
Protected method | WriteVersionedField | Writes the versioned field.

Fields

 | Name | Description
Protected field | DescendantsLock | Used for syncronization of access to [Descendants] table
Protected field | PrefetchCacheLock | The _prefetch cache lock.

Properties

 | Name | Description
Protected property | Api | Gets the data API to the physical database.
Public property | CacheOptions | Gets the cache options. (Inherited from DataProvider.)
Public property | Database | Gets the database. (Inherited from DataProvider.)
Protected property | DescendantsShouldBeUpdated | Gets or sets a value indicating whether Descendants table should be updated
Protected property | Disable | Disables a method. (Inherited from DataProvider.)
Protected property | DisableGroup | Disables a group. (Inherited from DataProvider.)
Protected property | Enable | Enables a method. (Inherited from DataProvider.)
Protected property | EnableGroup | Enables a group. (Inherited from DataProvider.)
Protected property | Languages | Gets or sets languages
Public property | Name | Gets or sets the name.
Protected property | PrefetchCache | Gets the prefetch cache.
Protected property | PropertyCache | Gets the property cache.
Protected property | RebuildThread | Gets or sets a value indicating rebuilding thread
Protected property | SkipDescendantsUpdate | Gets a value indicating whether Descendantsd table should be updated.
Protected property | Translator | Gets the Sitecore Query to SQL translator.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


SqlDataProvider Constructor

[image]

Sitecore 6.4.1 API
SqlDataProvider Constructor
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlDataProvider(
    SqlDataApi api
)
Visual Basic
Public Sub New ( _
    api As SqlDataApi _
)
Visual C++
public:
SqlDataProvider(
    SqlDataApi^ api
)

Parameters

api
Type: Sitecore.Data.DataProviders.Sql..::..SqlDataApi
The data API.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


DescendantsLock Field

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..DescendantsLock Field
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected readonly ReaderWriterLock DescendantsLock
Visual Basic
Protected ReadOnly DescendantsLock As ReaderWriterLock
Visual C++
protected:
initonly ReaderWriterLock^ DescendantsLock

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


PrefetchCacheLock Field

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..PrefetchCacheLock Field
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected readonly Object PrefetchCacheLock
Visual Basic
Protected ReadOnly PrefetchCacheLock As Object
Visual C++
protected:
initonly Object^ PrefetchCacheLock

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


SqlDataProvider Methods

[image] [image]

Sitecore 6.4.1 API
SqlDataProvider Methods
SqlDataProvider Class See Also Send Feedback

The SqlDataProvider type exposes the following members.

Methods

 | Name | Description
Protected method | AddPrefetch | Adds a prefetch option.
Public method | AddToPublishQueue | Adds an item to the publish queue. (Overrides DataProvider..::..AddToPublishQueue(ID, String, DateTime, CallContext).)
Public method | AddVersion | Adds a version to an item. (Overrides DataProvider..::..AddVersion(ItemDefinition, VersionUri, CallContext).)
Public method | BlobStreamExists | Determines whether the specified field contains a BLOB value. (Inherited from DataProvider.)
Public method | ChangeFieldSharing | Changes the type of field sharing for a single field. (Overrides DataProvider..::..ChangeFieldSharing(TemplateField, TemplateFieldSharing, CallContext).)
Public method | ChangeTemplate | Changes the template. (Overrides DataProvider..::..ChangeTemplate(ItemDefinition, TemplateChangeList, CallContext).)
Protected method | CleanupBlobs | Removes unused blob fields
Protected method | CleanupCyclicDependences | Cleanups the cyclic dependences. The items couldn't be removed by CleanupOrphans because always have a parent but is not participated in item tree.
Public method | CleanupDatabase | Cleanups the database. (Overrides DataProvider..::..CleanupDatabase(CallContext).)
Protected method | CleanupFields | Removes all field data for non-existing items.
Protected method | CleanupInvalidLanguageData | Removes all invalid language data (ie. data for which the language does not exist).
Protected method | CleanupOrphans | Removes orphaned items from the database.
Public method | CleanupPublishQueue | Cleans up the publish queue. (Overrides DataProvider..::..CleanupPublishQueue(DateTime, CallContext).)
Protected method | CleanupTemplateFields | Cleanups the template fields.
Public method | CopyItem | Copies an item. (Overrides DataProvider..::..CopyItem(ItemDefinition, ItemDefinition, String, ID, CallContext).)
Public method | CreateItem | Creates a item. (Overrides DataProvider..::..CreateItem(ID, String, ID, ItemDefinition, CallContext).)
Protected method | CreateSqlTranslator | Creates the SQL translator.
Public method | DeleteItem | Deletes an item. (Overrides DataProvider..::..DeleteItem(ItemDefinition, CallContext).)
Protected method | Descendants_ItemCreated | Performs changes to 'Descandants' table after item creation.
Protected method | Descendants_ItemDeleted | Performs changes to 'Descandants' table after item deleting.
Protected method | DoInitializeEvents | Performs the actual event initialization.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Exists | Check if data satisfying the specified SQL exists.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBlobStream | Gets the BLOB stream associated with a field. (Inherited from DataProvider.)
Public method | GetChildIDs | Gets the child ids of an item. (Overrides DataProvider..::..GetChildIDs(ItemDefinition, CallContext).)
Public method | GetDataSize | Gets the size of the data managed by the provider. (Overrides DataProvider..::..GetDataSize(Int32, Int32).)
Public method | GetDictionaryEntryCount | Gets the number of dictionary entries. (Overrides DataProvider..::..GetDictionaryEntryCount()()()().)
Public method | GetEventQueue | Gets the event queue driver. (Overrides DataProvider..::..GetEventQueue()()()().)
Protected method | GetFieldSharingConverter | Gets a SqlDataProvider..::..FieldSharingConverter.
Protected method | GetFieldValue | Gets the field value.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetIdEnumerator | Gets all id values.
Public method | GetItemDefinition | Gets the definition of an item. (Overrides DataProvider..::..GetItemDefinition(ID, CallContext).)
Public method | GetItemFields | Gets the fields of a specific item version. (Overrides DataProvider..::..GetItemFields(ItemDefinition, VersionUri, CallContext).)
Protected method | GetItemKeyColumnName | Gets the name of the 'item name' column.
Public method | GetItemsInWorkflowState | Gets all items that are in a specific workflow state. (Overrides DataProvider..::..GetItemsInWorkflowState(WorkflowInfo, CallContext).)
Public method | GetItemVersions | Gets a list of the available versions of an item. (Overrides DataProvider..::..GetItemVersions(ItemDefinition, CallContext).)
Public method | GetLanguages()()()() | Gets a list of all the language that have been defined in the database.
Public method | GetLanguages(CallContext) | Gets a list of all the language that have been defined in the database. (Overrides DataProvider..::..GetLanguages(CallContext).)
Protected method | GetLock | Gets a lock.
Public method | GetParentID | Gets the parent ID of an item. (Overrides DataProvider..::..GetParentID(ItemDefinition, CallContext).)
Protected method | GetPrefetchDataFromCache | Gets the prefetch data from cache.
Public method | GetProperty | Gets a property. (Overrides DataProvider..::..GetProperty(String, CallContext).)
Protected method | GetPropertyCore | Gets the property core.
Public method | GetPropertyKeys | Gets a list of property keys matching a specific prefix. (Overrides DataProvider..::..GetPropertyKeys(String, CallContext).)
Public method | GetPublishQueue | Gets the publish queue. (Overrides DataProvider..::..GetPublishQueue(DateTime, DateTime, CallContext).)
Protected method | GetResolverSql | Gets the resolver SQL.
Public method | GetRootID | Gets the root ID. (Overrides DataProvider..::..GetRootID(CallContext).)
Public method | GetSharingType | Gets the type of the sharing.
Public method | GetTemplateItemIds | Gets the template item id. (Overrides DataProvider..::..GetTemplateItemIds(CallContext).)
Public method | GetTemplates | Gets the templates. (Inherited from DataProvider.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetVersions | Gets a list of all versions that have been defined in the entire database.
Public method | GetWorkflowInfo | Gets the workflow info form an item. (Inherited from DataProvider.)
Public method | HasChildren | Determines whether the specified item definition has children. (Overrides DataProvider..::..HasChildren(ItemDefinition, CallContext).)
Public method | IsEnabled | Determines whether the specified method is enabled. (Inherited from DataProvider.)
Protected method | LoadChildIds | Loads the child ids.
Protected method | LoadItemDefinitions | Loads the item definitions.
Protected method | LoadItemFields | Loads the item fields.
Protected method | LoadLanguages | Loads the list of languages from the database.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveItem | Moves an item (ie. changes its parent). (Overrides DataProvider..::..MoveItem(ItemDefinition, ItemDefinition, CallContext).)
Protected method | QueryFast | Executes fast query.
Protected method | RebuildDescendants | Rebuilds the descendants table.
Protected method | RemoveFields | Removes the fields.
Public method | RemoveLanguageData | Removes a language and all the data using the language from the database. (Overrides DataProvider..::..RemoveLanguageData(Language, CallContext).)
Protected method | RemovePrefetchDataFromCache | Removes prefetch data from the cache.
Public method | RemoveProperty | Removes a property. (Overrides DataProvider..::..RemoveProperty(String, Boolean, CallContext).)
Protected method | RemovePropertyCore | Removes the property core.
Public method | RemoveVersion | Removes a version from an item. (Overrides DataProvider..::..RemoveVersion(ItemDefinition, VersionUri, CallContext).)
Public method | RemoveVersions(ItemDefinition, Language, CallContext) | Removes versions from an item. (Inherited from DataProvider.)
Public method | RemoveVersions(ItemDefinition, Language, Boolean, CallContext) | Removes versions from an item. (Overrides DataProvider..::..RemoveVersions(ItemDefinition, Language, Boolean, CallContext).)
Public method | RenameLanguageData | Renames a language binding. (Overrides DataProvider..::..RenameLanguageData(String, String, CallContext).)
Protected method | ResolveNames | Resolves the names.
Public method | ResolvePath | Resolves the path. (Inherited from DataProvider.)
Public method | SaveItem | Saves an item. (Overrides DataProvider..::..SaveItem(ItemDefinition, ItemChanges, CallContext).)
Public method | SelectIDs | Selects a set of ids. (Overrides DataProvider..::..SelectIDs(String, CallContext).)
Public method | SelectSingleID | Selects a single ID. (Overrides DataProvider..::..SelectSingleID(String, CallContext).)
Public method | SetBlobStream | Sets the BLOB stream associated with a field. (Inherited from DataProvider.)
Protected method | SetFieldValue | Sets the field value.
Public method | SetProperty | Sets a property. (Overrides DataProvider..::..SetProperty(String, String, CallContext).)
Protected method | SetPropertyCore | Sets the property core.
Public method | SetWorkflowInfo | Sets the workflow info for an item. (Inherited from DataProvider.)
Protected method | StartRebuildDescendants | Starts the rebuild descendants.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateFieldValues | Updates field values.
Protected method | WriteSharedField | Writes the shared field.
Protected method | WriteUnversionedField | Writes the unversioned field.
Protected method | WriteVersionedField | Writes the versioned field.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


AddPrefetch Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..AddPrefetch Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void AddPrefetch(
    XmlNode configNode
)
Visual Basic
Protected Overridable Sub AddPrefetch ( _
    configNode As XmlNode _
)
Visual C++
protected:
virtual void AddPrefetch(
    XmlNode^ configNode
)

Parameters

configNode
Type: System.Xml..::..XmlNode
The config node.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


AddToPublishQueue Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..AddToPublishQueue Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool AddToPublishQueue(
    ID itemID,
    string action,
    DateTime date,
    CallContext context
)
Visual Basic
Public Overrides Function AddToPublishQueue ( _
    itemID As ID, _
    action As String, _
    date As DateTime, _
    context As CallContext _
) As Boolean
Visual C++
public:
virtual bool AddToPublishQueue(
    ID^ itemID,
    String^ action,
    DateTime date,
    CallContext^ context
) override

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.
action
Type: System..::..String
The action.
date
Type: System..::..DateTime
The modfication date.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

The add to publish queue.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


AddVersion Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..AddVersion Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override int AddVersion(
    ItemDefinition itemDefinition,
    VersionUri baseVersion,
    CallContext context
)
Visual Basic
Public Overrides Function AddVersion ( _
    itemDefinition As ItemDefinition, _
    baseVersion As VersionUri, _
    context As CallContext _
) As Integer
Visual C++
public:
virtual int AddVersion(
    ItemDefinition^ itemDefinition,
    VersionUri^ baseVersion,
    CallContext^ context
) override

Parameters

itemDefinition
Type: Sitecore.Data..::..ItemDefinition
The item definition.
baseVersion
Type: Sitecore.Data..::..VersionUri
The base version.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

The add version.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


ChangeFieldSharing Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..ChangeFieldSharing Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool ChangeFieldSharing(
    TemplateField fieldDefinition,
    TemplateFieldSharing sharing,
    CallContext context
)
Visual Basic
Public Overrides Function ChangeFieldSharing ( _
    fieldDefinition As TemplateField, _
    sharing As TemplateFieldSharing, _
    context As CallContext _
) As Boolean
Visual C++
public:
virtual bool ChangeFieldSharing(
    TemplateField^ fieldDefinition,
    TemplateFieldSharing sharing,
    CallContext^ context
) override

Parameters

fieldDefinition
Type: Sitecore.Data.Templates..::..TemplateField
The field definition.
sharing
Type: Sitecore.Data.Templates..::..TemplateFieldSharing
The new sharing type.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

The change field sharing.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


ChangeTemplate Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..ChangeTemplate Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool ChangeTemplate(
    ItemDefinition itemDefinition,
    TemplateChangeList changeList,
    CallContext context
)
Visual Basic
Public Overrides Function ChangeTemplate ( _
    itemDefinition As ItemDefinition, _
    changeList As TemplateChangeList, _
    context As CallContext _
) As Boolean
Visual C++
public:
virtual bool ChangeTemplate(
    ItemDefinition^ itemDefinition,
    TemplateChangeList^ changeList,
    CallContext^ context
) override

Parameters

itemDefinition
Type: Sitecore.Data..::..ItemDefinition
The item definition.
changeList
Type: Sitecore.Data.Templates..::..TemplateChangeList
The change list.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

The change template.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


CleanupBlobs Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..CleanupBlobs Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void CleanupBlobs(
    CallContext context
)
Visual Basic
Protected Overridable Sub CleanupBlobs ( _
    context As CallContext _
)
Visual C++
protected:
virtual void CleanupBlobs(
    CallContext^ context
)

Parameters

context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


CleanupCyclicDependences Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..CleanupCyclicDependences Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void CleanupCyclicDependences()
Visual Basic
Protected Overridable Sub CleanupCyclicDependences
Visual C++
protected:
virtual void CleanupCyclicDependences()

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


CleanupDatabase Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..CleanupDatabase Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool CleanupDatabase(
    CallContext context
)
Visual Basic
Public Overrides Function CleanupDatabase ( _
    context As CallContext _
) As Boolean
Visual C++
public:
virtual bool CleanupDatabase(
    CallContext^ context
) override

Parameters

context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

true if cleanup was performed; false otherwise.

Remarks

Typically, a cleanup operation will remove data in invalid languages and items in orphaned trees.

Specific operations depends on the actual data provider implementation.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


CleanupFields Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..CleanupFields Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void CleanupFields(
    CallContext context
)
Visual Basic
Protected Overridable Sub CleanupFields ( _
    context As CallContext _
)
Visual C++
protected:
virtual void CleanupFields(
    CallContext^ context
)

Parameters

context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


CleanupInvalidLanguageData Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..CleanupInvalidLanguageData Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void CleanupInvalidLanguageData()
Visual Basic
Protected Overridable Sub CleanupInvalidLanguageData
Visual C++
protected:
virtual void CleanupInvalidLanguageData()

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


CleanupOrphans Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..CleanupOrphans Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void CleanupOrphans()
Visual Basic
Protected Overridable Sub CleanupOrphans
Visual C++
protected:
virtual void CleanupOrphans()

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


CleanupTemplateFields Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..CleanupTemplateFields Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void CleanupTemplateFields(
    string[] tables,
    CallContext context
)
Visual Basic
Protected Overridable Sub CleanupTemplateFields ( _
    tables As String(), _
    context As CallContext _
)
Visual C++
protected:
virtual void CleanupTemplateFields(
    array<String^>^ tables,
    CallContext^ context
)

Parameters

tables
Type: array< System..::..String >[]()[][]
The tables.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


CopyItem Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..CopyItem Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool CopyItem(
    ItemDefinition source,
    ItemDefinition destination,
    string copyName,
    ID copyID,
    CallContext context
)
Visual Basic
Public Overrides Function CopyItem ( _
    source As ItemDefinition, _
    destination As ItemDefinition, _
    copyName As String, _
    copyID As ID, _
    context As CallContext _
) As Boolean
Visual C++
public:
virtual bool CopyItem(
    ItemDefinition^ source,
    ItemDefinition^ destination,
    String^ copyName,
    ID^ copyID,
    CallContext^ context
) override

Parameters

source
Type: Sitecore.Data..::..ItemDefinition
The source.
destination
Type: Sitecore.Data..::..ItemDefinition
The destination.
copyName
Type: System..::..String
Name of the copy.
copyID
Type: Sitecore.Data..::..ID
The copy ID.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

The copy item.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


CreateItem Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..CreateItem Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool CreateItem(
    ID itemID,
    string itemName,
    ID templateID,
    ItemDefinition parent,
    CallContext context
)
Visual Basic
Public Overrides Function CreateItem ( _
    itemID As ID, _
    itemName As String, _
    templateID As ID, _
    parent As ItemDefinition, _
    context As CallContext _
) As Boolean
Visual C++
public:
virtual bool CreateItem(
    ID^ itemID,
    String^ itemName,
    ID^ templateID,
    ItemDefinition^ parent,
    CallContext^ context
) override

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.
itemName
Type: System..::..String
Name of the item.
templateID
Type: Sitecore.Data..::..ID
The template ID.
parent
Type: Sitecore.Data..::..ItemDefinition
The parent.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

The create item.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


CreateSqlTranslator Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..CreateSqlTranslator Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual QueryToSqlTranslator CreateSqlTranslator()
Visual Basic
Protected Overridable Function CreateSqlTranslator As QueryToSqlTranslator
Visual C++
protected:
virtual QueryToSqlTranslator^ CreateSqlTranslator()

Return Value

The SQL translator.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


DeleteItem Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..DeleteItem Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool DeleteItem(
    ItemDefinition itemDefinition,
    CallContext context
)
Visual Basic
Public Overrides Function DeleteItem ( _
    itemDefinition As ItemDefinition, _
    context As CallContext _
) As Boolean
Visual C++
public:
virtual bool DeleteItem(
    ItemDefinition^ itemDefinition,
    CallContext^ context
) override

Parameters

itemDefinition
Type: Sitecore.Data..::..ItemDefinition
The item definition.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

The delete item.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


Descendants_ItemCreated Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..Descendants_ItemCreated Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void Descendants_ItemCreated(
    ID parentId,
    ID itemId
)
Visual Basic
Protected Overridable Sub Descendants_ItemCreated ( _
    parentId As ID, _
    itemId As ID _
)
Visual C++
protected:
virtual void Descendants_ItemCreated(
    ID^ parentId,
    ID^ itemId
)

Parameters

parentId
Type: Sitecore.Data..::..ID
The parent item id.
itemId
Type: Sitecore.Data..::..ID
The item id.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


Descendants_ItemDeleted Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..Descendants_ItemDeleted Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void Descendants_ItemDeleted(
    ID itemId
)
Visual Basic
Protected Overridable Sub Descendants_ItemDeleted ( _
    itemId As ID _
)
Visual C++
protected:
virtual void Descendants_ItemDeleted(
    ID^ itemId
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


DoInitializeEvents Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..DoInitializeEvents Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void DoInitializeEvents()
Visual Basic
Protected Overridable Sub DoInitializeEvents
Visual C++
protected:
virtual void DoInitializeEvents()

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


Exists Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..Exists Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected bool Exists(
    string sql,
    params Object[] parameters
)
Visual Basic
Protected Function Exists ( _
    sql As String, _
    ParamArray parameters As Object() _
) As Boolean
Visual C++
protected:
bool Exists(
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

sql
Type: System..::..String
The SQL query.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.

Return Value

True, if data is found, false otherwise.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


GetChildIDs Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..GetChildIDs Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override IDList GetChildIDs(
    ItemDefinition itemDefinition,
    CallContext context
)
Visual Basic
Public Overrides Function GetChildIDs ( _
    itemDefinition As ItemDefinition, _
    context As CallContext _
) As IDList
Visual C++
public:
virtual IDList^ GetChildIDs(
    ItemDefinition^ itemDefinition,
    CallContext^ context
) override

Parameters

itemDefinition
Type: Sitecore.Data..::..ItemDefinition
The item definition.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

List of child id.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


GetDataSize Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..GetDataSize Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override long GetDataSize(
    int minEntitySize,
    int maxEntitySize
)
Visual Basic
Public Overrides Function GetDataSize ( _
    minEntitySize As Integer, _
    maxEntitySize As Integer _
) As Long
Visual C++
public:
virtual long long GetDataSize(
    int minEntitySize,
    int maxEntitySize
) override

Parameters

minEntitySize
Type: System..::..Int32
The min Entity Size.
maxEntitySize
Type: System..::..Int32
The max Entity Size.

Return Value

The get data size.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


GetDictionaryEntryCount Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..GetDictionaryEntryCount Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override long GetDictionaryEntryCount()
Visual Basic
Public Overrides Function GetDictionaryEntryCount As Long
Visual C++
public:
virtual long long GetDictionaryEntryCount() override

Return Value

The number of dictionary entries.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


GetEventQueue Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..GetEventQueue Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override EventQueue GetEventQueue()
Visual Basic
Public Overrides Function GetEventQueue As EventQueue
Visual C++
public:
virtual EventQueue^ GetEventQueue() override

Return Value

The event queue driver.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


GetFieldSharingConverter Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..GetFieldSharingConverter Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual SqlDataProvider..::..FieldSharingConverter GetFieldSharingConverter()
Visual Basic
Protected Overridable Function GetFieldSharingConverter As SqlDataProvider..::..FieldSharingConverter
Visual C++
protected:
virtual SqlDataProvider..::..FieldSharingConverter^ GetFieldSharingConverter()

Return Value

FieldSharingConverter object.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


GetFieldValue Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..GetFieldValue Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string GetFieldValue(
    string tableName,
    Guid entryId
)
Visual Basic
Protected Overridable Function GetFieldValue ( _
    tableName As String, _
    entryId As Guid _
) As String
Visual C++
protected:
virtual String^ GetFieldValue(
    String^ tableName,
    Guid entryId
)

Parameters

tableName
Type: System..::..String
Name of the table.
entryId
Type: System..::..Guid
The entry id.

Return Value

The get field value.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


GetItemDefinition Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..GetItemDefinition Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override ItemDefinition GetItemDefinition(
    ID itemId,
    CallContext context
)
Visual Basic
Public Overrides Function GetItemDefinition ( _
    itemId As ID, _
    context As CallContext _
) As ItemDefinition
Visual C++
public:
virtual ItemDefinition^ GetItemDefinition(
    ID^ itemId,
    CallContext^ context
) override

Parameters

itemId
Type: Sitecore.Data..::..ID
The item ID.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

ItemDefinition object.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


GetItemFields Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..GetItemFields Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override FieldList GetItemFields(
    ItemDefinition itemDefinition,
    VersionUri versionUri,
    CallContext context
)
Visual Basic
Public Overrides Function GetItemFields ( _
    itemDefinition As ItemDefinition, _
    versionUri As VersionUri, _
    context As CallContext _
) As FieldList
Visual C++
public:
virtual FieldList^ GetItemFields(
    ItemDefinition^ itemDefinition,
    VersionUri^ versionUri,
    CallContext^ context
) override

Parameters

itemDefinition
Type: Sitecore.Data..::..ItemDefinition
The item to get fields for.
versionUri
Type: Sitecore.Data..::..VersionUri
The version URI.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

Item fields list

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


GetItemsInWorkflowState Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..GetItemsInWorkflowState Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override DataUri[] GetItemsInWorkflowState(
    WorkflowInfo info,
    CallContext context
)
Visual Basic
Public Overrides Function GetItemsInWorkflowState ( _
    info As WorkflowInfo, _
    context As CallContext _
) As DataUri()
Visual C++
public:
virtual array<DataUri^>^ GetItemsInWorkflowState(
    WorkflowInfo^ info,
    CallContext^ context
) override

Parameters

info
Type: Sitecore.Workflows..::..WorkflowInfo
The workflow info.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

Arrray of items that are in requested workflow state.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


GetItemVersions Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..GetItemVersions Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override VersionUriList GetItemVersions(
    ItemDefinition itemDefinition,
    CallContext context
)
Visual Basic
Public Overrides Function GetItemVersions ( _
    itemDefinition As ItemDefinition, _
    context As CallContext _
) As VersionUriList
Visual C++
public:
virtual VersionUriList^ GetItemVersions(
    ItemDefinition^ itemDefinition,
    CallContext^ context
) override

Parameters

itemDefinition
Type: Sitecore.Data..::..ItemDefinition
The item to get versions for.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

Item version list.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


GetLanguages Method

[image] [image]

Sitecore 6.4.1 API
SqlDataProvider..::..GetLanguages Method
SqlDataProvider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetLanguages()()()() | Gets a list of all the language that have been defined in the database.
Public method | GetLanguages(CallContext) | Gets a list of all the language that have been defined in the database. (Overrides DataProvider..::..GetLanguages(CallContext).)

See Also

SqlDataProvider Class
SqlDataProvider Members
Sitecore.Data.DataProviders.Sql Namespace


GetLanguages Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..GetLanguages Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual LanguageCollection GetLanguages()
Visual Basic
Public Overridable Function GetLanguages As LanguageCollection
Visual C++
public:
virtual LanguageCollection^ GetLanguages()

Return Value

LanguageCollection object.

See Also

SqlDataProvider Class
GetLanguages Overload
Sitecore.Data.DataProviders.Sql Namespace


GetLanguages Method (CallContext)

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..GetLanguages Method (CallContext)
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override LanguageCollection GetLanguages(
    CallContext context
)
Visual Basic
Public Overrides Function GetLanguages ( _
    context As CallContext _
) As LanguageCollection
Visual C++
public:
virtual LanguageCollection^ GetLanguages(
    CallContext^ context
) override

Parameters

context
Type: Sitecore.Data.DataProviders..::..CallContext
CallContext object.

Return Value

LanguageCollection object.

See Also

SqlDataProvider Class
GetLanguages Overload
Sitecore.Data.DataProviders.Sql Namespace


GetParentID Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..GetParentID Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override ID GetParentID(
    ItemDefinition itemDefinition,
    CallContext context
)
Visual Basic
Public Overrides Function GetParentID ( _
    itemDefinition As ItemDefinition, _
    context As CallContext _
) As ID
Visual C++
public:
virtual ID^ GetParentID(
    ItemDefinition^ itemDefinition,
    CallContext^ context
) override

Parameters

itemDefinition
Type: Sitecore.Data..::..ItemDefinition
The item definition.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

Parent ID.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


GetPrefetchDataFromCache Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..GetPrefetchDataFromCache Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected PrefetchData GetPrefetchDataFromCache(
    ID itemId
)
Visual Basic
Protected Function GetPrefetchDataFromCache ( _
    itemId As ID _
) As PrefetchData
Visual C++
protected:
PrefetchData^ GetPrefetchDataFromCache(
    ID^ itemId
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.

Return Value

PrefetchData object.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


GetProperty Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..GetProperty Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string GetProperty(
    string propertyName,
    CallContext context
)
Visual Basic
Public Overrides Function GetProperty ( _
    propertyName As String, _
    context As CallContext _
) As String
Visual C++
public:
virtual String^ GetProperty(
    String^ propertyName,
    CallContext^ context
) override

Parameters

propertyName
Type: System..::..String
The property propertyName.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

The get property.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


GetPropertyCore Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..GetPropertyCore Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string GetPropertyCore(
    string propertyName,
    CallContext context
)
Visual Basic
Protected Overridable Function GetPropertyCore ( _
    propertyName As String, _
    context As CallContext _
) As String
Visual C++
protected:
virtual String^ GetPropertyCore(
    String^ propertyName,
    CallContext^ context
)

Parameters

propertyName
Type: System..::..String
The property name.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

The get property core.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


GetPropertyKeys Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..GetPropertyKeys Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override List<string> GetPropertyKeys(
    string prefix,
    CallContext context
)
Visual Basic
Public Overrides Function GetPropertyKeys ( _
    prefix As String, _
    context As CallContext _
) As List(Of String)
Visual C++
public:
virtual List<String^>^ GetPropertyKeys(
    String^ prefix,
    CallContext^ context
) override

Parameters

prefix
Type: System..::..String
The prefix.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

List of property keys.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


GetPublishQueue Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..GetPublishQueue Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override IDList GetPublishQueue(
    DateTime from,
    DateTime to,
    CallContext context
)
Visual Basic
Public Overrides Function GetPublishQueue ( _
    from As DateTime, _
    to As DateTime, _
    context As CallContext _
) As IDList
Visual C++
public:
virtual IDList^ GetPublishQueue(
    DateTime from,
    DateTime to,
    CallContext^ context
) override

Parameters

from
Type: System..::..DateTime
From date condition.
to
Type: System..::..DateTime
To date condition.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

List of Item ID that are in publish queue.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


GetResolverSql Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..GetResolverSql Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string GetResolverSql(
    string path
)
Visual Basic
Protected Overridable Function GetResolverSql ( _
    path As String _
) As String
Visual C++
protected:
virtual String^ GetResolverSql(
    String^ path
)

Parameters

path
Type: System..::..String
The path to resolve.

Return Value

The get resolver sql.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


GetRootID Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..GetRootID Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override ID GetRootID(
    CallContext context
)
Visual Basic
Public Overrides Function GetRootID ( _
    context As CallContext _
) As ID
Visual C++
public:
virtual ID^ GetRootID(
    CallContext^ context
) override

Parameters

context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

Root ID from predefined constants.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


GetSharingType Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..GetSharingType Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DefaultFieldSharing..::..SharingType GetSharingType(
    TemplateField templateField
)
Visual Basic
Public Function GetSharingType ( _
    templateField As TemplateField _
) As DefaultFieldSharing..::..SharingType
Visual C++
public:
DefaultFieldSharing..::..SharingType GetSharingType(
    TemplateField^ templateField
)

Parameters

templateField
Type: Sitecore.Data.Templates..::..TemplateField
The template of the field.

Return Value

Shareing type for template field.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


GetTemplateItemIds Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..GetTemplateItemIds Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override IdCollection GetTemplateItemIds(
    CallContext context
)
Visual Basic
Public Overrides Function GetTemplateItemIds ( _
    context As CallContext _
) As IdCollection
Visual C++
public:
virtual IdCollection^ GetTemplateItemIds(
    CallContext^ context
) override

Parameters

context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

Collection of Template ID.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


GetVersions Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..GetVersions Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual List<Version> GetVersions()
Visual Basic
Protected Overridable Function GetVersions As List(Of Version)
Visual C++
protected:
virtual List<Version^>^ GetVersions()

Return Value

List of versions.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


HasChildren Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..HasChildren Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool HasChildren(
    ItemDefinition itemDefinition,
    CallContext context
)
Visual Basic
Public Overrides Function HasChildren ( _
    itemDefinition As ItemDefinition, _
    context As CallContext _
) As Boolean
Visual C++
public:
virtual bool HasChildren(
    ItemDefinition^ itemDefinition,
    CallContext^ context
) override

Parameters

itemDefinition
Type: Sitecore.Data..::..ItemDefinition
The item definition.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

true if the specified item definition has children; otherwise, false.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


LoadChildIds Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..LoadChildIds Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void LoadChildIds(
    string condition,
    Object[] parameters,
    SafeDictionary<ID, PrefetchData> prefetchData
)
Visual Basic
Protected Overridable Sub LoadChildIds ( _
    condition As String, _
    parameters As Object(), _
    prefetchData As SafeDictionary(Of ID, PrefetchData) _
)
Visual C++
protected:
virtual void LoadChildIds(
    String^ condition,
    array<Object^>^ parameters,
    SafeDictionary<ID^, PrefetchData^>^ prefetchData
)

Parameters

condition
Type: System..::..String
The condition.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.
prefetchData
Type: Sitecore.Collections..::..SafeDictionary <(Of <(<' ID, PrefetchData >)>)>
The working set.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


LoadItemDefinitions Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..LoadItemDefinitions Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void LoadItemDefinitions(
    string condition,
    Object[] parameters,
    SafeDictionary<ID, PrefetchData> prefetchData
)
Visual Basic
Protected Overridable Sub LoadItemDefinitions ( _
    condition As String, _
    parameters As Object(), _
    prefetchData As SafeDictionary(Of ID, PrefetchData) _
)
Visual C++
protected:
virtual void LoadItemDefinitions(
    String^ condition,
    array<Object^>^ parameters,
    SafeDictionary<ID^, PrefetchData^>^ prefetchData
)

Parameters

condition
Type: System..::..String
The condition.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.
prefetchData
Type: Sitecore.Collections..::..SafeDictionary <(Of <(<' ID, PrefetchData >)>)>
The working set.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


LoadItemFields Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..LoadItemFields Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void LoadItemFields(
    string itemCondition,
    string fieldCondition,
    Object[] parameters,
    SafeDictionary<ID, PrefetchData> prefetchData
)
Visual Basic
Protected Overridable Sub LoadItemFields ( _
    itemCondition As String, _
    fieldCondition As String, _
    parameters As Object(), _
    prefetchData As SafeDictionary(Of ID, PrefetchData) _
)
Visual C++
protected:
virtual void LoadItemFields(
    String^ itemCondition,
    String^ fieldCondition,
    array<Object^>^ parameters,
    SafeDictionary<ID^, PrefetchData^>^ prefetchData
)

Parameters

itemCondition
Type: System..::..String
The item condition.
fieldCondition
Type: System..::..String
The field condition.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.
prefetchData
Type: Sitecore.Collections..::..SafeDictionary <(Of <(<' ID, PrefetchData >)>)>
The working set.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


LoadLanguages Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..LoadLanguages Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual LanguageCollection LoadLanguages()
Visual Basic
Protected Overridable Function LoadLanguages As LanguageCollection
Visual C++
protected:
virtual LanguageCollection^ LoadLanguages()

Return Value

LanguageCollection object.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


MoveItem Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..MoveItem Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool MoveItem(
    ItemDefinition itemDefinition,
    ItemDefinition destination,
    CallContext context
)
Visual Basic
Public Overrides Function MoveItem ( _
    itemDefinition As ItemDefinition, _
    destination As ItemDefinition, _
    context As CallContext _
) As Boolean
Visual C++
public:
virtual bool MoveItem(
    ItemDefinition^ itemDefinition,
    ItemDefinition^ destination,
    CallContext^ context
) override

Parameters

itemDefinition
Type: Sitecore.Data..::..ItemDefinition
The item definition.
destination
Type: Sitecore.Data..::..ItemDefinition
The destination.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The call context.

Return Value

True if the item was moved by the provider, false otherwise.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


QueryFast Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..QueryFast Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual IDList QueryFast(
    string query,
    CallContext context
)
Visual Basic
Protected Overridable Function QueryFast ( _
    query As String, _
    context As CallContext _
) As IDList
Visual C++
protected:
virtual IDList^ QueryFast(
    String^ query,
    CallContext^ context
)

Parameters

query
Type: System..::..String
The query.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

List of IDs.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


RebuildDescendants Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..RebuildDescendants Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void RebuildDescendants()
Visual Basic
Protected Overridable Sub RebuildDescendants
Visual C++
protected:
virtual void RebuildDescendants()

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


RemoveFields Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..RemoveFields Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void RemoveFields(
    ID itemId,
    Language language,
    Version version
)
Visual Basic
Protected Overridable Sub RemoveFields ( _
    itemId As ID, _
    language As Language, _
    version As Version _
)
Visual C++
protected:
virtual void RemoveFields(
    ID^ itemId,
    Language^ language,
    Version^ version
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
language
Type: Sitecore.Globalization..::..Language
The language.
version
Type: Sitecore.Data..::..Version
The version.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


RemoveLanguageData Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..RemoveLanguageData Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void RemoveLanguageData(
    Language language,
    CallContext context
)
Visual Basic
Public Overrides Sub RemoveLanguageData ( _
    language As Language, _
    context As CallContext _
)
Visual C++
public:
virtual void RemoveLanguageData(
    Language^ language,
    CallContext^ context
) override

Parameters

language
Type: Sitecore.Globalization..::..Language
The language.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Remarks

Proceeed with caution.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


RemovePrefetchDataFromCache Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..RemovePrefetchDataFromCache Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void RemovePrefetchDataFromCache(
    ID itemId
)
Visual Basic
Protected Sub RemovePrefetchDataFromCache ( _
    itemId As ID _
)
Visual C++
protected:
void RemovePrefetchDataFromCache(
    ID^ itemId
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


RemoveProperty Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..RemoveProperty Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool RemoveProperty(
    string propertyName,
    bool isPrefix,
    CallContext context
)
Visual Basic
Public Overrides Function RemoveProperty ( _
    propertyName As String, _
    isPrefix As Boolean, _
    context As CallContext _
) As Boolean
Visual C++
public:
virtual bool RemoveProperty(
    String^ propertyName,
    bool isPrefix,
    CallContext^ context
) override

Parameters

propertyName
Type: System..::..String
The property name.
isPrefix
Type: System..::..Boolean
if set to true this instance is is prefix.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

The remove property.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


RemovePropertyCore Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..RemovePropertyCore Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool RemovePropertyCore(
    string propertyName,
    bool isPrefix,
    CallContext context
)
Visual Basic
Protected Overridable Function RemovePropertyCore ( _
    propertyName As String, _
    isPrefix As Boolean, _
    context As CallContext _
) As Boolean
Visual C++
protected:
virtual bool RemovePropertyCore(
    String^ propertyName,
    bool isPrefix,
    CallContext^ context
)

Parameters

propertyName
Type: System..::..String
The property name.
isPrefix
Type: System..::..Boolean
if set to true this instance is is prefix.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

The remove property core.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


RemoveVersion Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..RemoveVersion Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool RemoveVersion(
    ItemDefinition itemDefinition,
    VersionUri version,
    CallContext context
)
Visual Basic
Public Overrides Function RemoveVersion ( _
    itemDefinition As ItemDefinition, _
    version As VersionUri, _
    context As CallContext _
) As Boolean
Visual C++
public:
virtual bool RemoveVersion(
    ItemDefinition^ itemDefinition,
    VersionUri^ version,
    CallContext^ context
) override

Parameters

itemDefinition
Type: Sitecore.Data..::..ItemDefinition
The item definition.
version
Type: Sitecore.Data..::..VersionUri
The version.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

The remove version.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


RemoveVersions Method

[image] [image]

Sitecore 6.4.1 API
SqlDataProvider..::..RemoveVersions Method
SqlDataProvider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveVersions(ItemDefinition, Language, CallContext) | Removes versions from an item. (Inherited from DataProvider.)
Public method | RemoveVersions(ItemDefinition, Language, Boolean, CallContext) | Removes versions from an item. (Overrides DataProvider..::..RemoveVersions(ItemDefinition, Language, Boolean, CallContext).)

See Also

SqlDataProvider Class
SqlDataProvider Members
Sitecore.Data.DataProviders.Sql Namespace


RenameLanguageData Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..RenameLanguageData Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void RenameLanguageData(
    string fromLanguage,
    string toLanguage,
    CallContext context
)
Visual Basic
Public Overrides Sub RenameLanguageData ( _
    fromLanguage As String, _
    toLanguage As String, _
    context As CallContext _
)
Visual C++
public:
virtual void RenameLanguageData(
    String^ fromLanguage,
    String^ toLanguage,
    CallContext^ context
) override

Parameters

fromLanguage
Type: System..::..String
Rename from this language name.
toLanguage
Type: System..::..String
Rename to this language name.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The call context.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


ResolveNames Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..ResolveNames Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual IDList ResolveNames(
    string itemName
)
Visual Basic
Protected Overridable Function ResolveNames ( _
    itemName As String _
) As IDList
Visual C++
protected:
virtual IDList^ ResolveNames(
    String^ itemName
)

Parameters

itemName
Type: System..::..String
Name of the item.

Return Value

IDList object.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


SaveItem Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..SaveItem Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool SaveItem(
    ItemDefinition itemDefinition,
    ItemChanges changes,
    CallContext context
)
Visual Basic
Public Overrides Function SaveItem ( _
    itemDefinition As ItemDefinition, _
    changes As ItemChanges, _
    context As CallContext _
) As Boolean
Visual C++
public:
virtual bool SaveItem(
    ItemDefinition^ itemDefinition,
    ItemChanges^ changes,
    CallContext^ context
) override

Parameters

itemDefinition
Type: Sitecore.Data..::..ItemDefinition
The item definition.
changes
Type: Sitecore.Data.Items..::..ItemChanges
The changes.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

The save item.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


SelectIDs Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..SelectIDs Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override IDList SelectIDs(
    string query,
    CallContext context
)
Visual Basic
Public Overrides Function SelectIDs ( _
    query As String, _
    context As CallContext _
) As IDList
Visual C++
public:
virtual IDList^ SelectIDs(
    String^ query,
    CallContext^ context
) override

Parameters

query
Type: System..::..String
The query.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

IDList object.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


SelectSingleID Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..SelectSingleID Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override ID SelectSingleID(
    string query,
    CallContext context
)
Visual Basic
Public Overrides Function SelectSingleID ( _
    query As String, _
    context As CallContext _
) As ID
Visual C++
public:
virtual ID^ SelectSingleID(
    String^ query,
    CallContext^ context
) override

Parameters

query
Type: System..::..String
The query.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

Single ID.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


SetFieldValue Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..SetFieldValue Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void SetFieldValue(
    string tableName,
    Guid entryId,
    string value
)
Visual Basic
Protected Overridable Sub SetFieldValue ( _
    tableName As String, _
    entryId As Guid, _
    value As String _
)
Visual C++
protected:
virtual void SetFieldValue(
    String^ tableName,
    Guid entryId,
    String^ value
)

Parameters

tableName
Type: System..::..String
Name of the table.
entryId
Type: System..::..Guid
The entry id.
value
Type: System..::..String
The value.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


SetProperty Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..SetProperty Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool SetProperty(
    string parameterName,
    string value,
    CallContext context
)
Visual Basic
Public Overrides Function SetProperty ( _
    parameterName As String, _
    value As String, _
    context As CallContext _
) As Boolean
Visual C++
public:
virtual bool SetProperty(
    String^ parameterName,
    String^ value,
    CallContext^ context
) override

Parameters

parameterName
Type: System..::..String
The property name.
value
Type: System..::..String
The property value.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

The set property.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


SetPropertyCore Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..SetPropertyCore Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool SetPropertyCore(
    string propertyName,
    string value,
    CallContext context
)
Visual Basic
Protected Overridable Function SetPropertyCore ( _
    propertyName As String, _
    value As String, _
    context As CallContext _
) As Boolean
Visual C++
protected:
virtual bool SetPropertyCore(
    String^ propertyName,
    String^ value,
    CallContext^ context
)

Parameters

propertyName
Type: System..::..String
The property name.
value
Type: System..::..String
The value.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

The set property core.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


StartRebuildDescendants Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..StartRebuildDescendants Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void StartRebuildDescendants()
Visual Basic
Protected Overridable Sub StartRebuildDescendants
Visual C++
protected:
virtual void StartRebuildDescendants()

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


UpdateFieldValues Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..UpdateFieldValues Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual int UpdateFieldValues(
    ID fieldId,
    SqlDataProvider..::..UpdateFieldValueDelegate updateFunction,
    bool skipEmpty
)
Visual Basic
Public Overridable Function UpdateFieldValues ( _
    fieldId As ID, _
    updateFunction As SqlDataProvider..::..UpdateFieldValueDelegate, _
    skipEmpty As Boolean _
) As Integer
Visual C++
public:
virtual int UpdateFieldValues(
    ID^ fieldId,
    SqlDataProvider..::..UpdateFieldValueDelegate^ updateFunction,
    bool skipEmpty
)

Parameters

fieldId
Type: Sitecore.Data..::..ID
The field id.
updateFunction
Type: Sitecore.Data.DataProviders.Sql..::..SqlDataProvider..::..UpdateFieldValueDelegate
The update function.
skipEmpty
Type: System..::..Boolean
if set to true empty fields will be skipped.

Return Value

The update field values.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


WriteSharedField Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..WriteSharedField Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void WriteSharedField(
    ID itemId,
    FieldChange change,
    DateTime now,
    bool fieldsAreEmpty
)
Visual Basic
Protected Overridable Sub WriteSharedField ( _
    itemId As ID, _
    change As FieldChange, _
    now As DateTime, _
    fieldsAreEmpty As Boolean _
)
Visual C++
protected:
virtual void WriteSharedField(
    ID^ itemId,
    FieldChange^ change,
    DateTime now,
    bool fieldsAreEmpty
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
change
Type: Sitecore.Data.Items..::..FieldChange
The change.
now
Type: System..::..DateTime
The current date.
fieldsAreEmpty
Type: System..::..Boolean
if set to true fields are empty.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


WriteUnversionedField Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..WriteUnversionedField Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void WriteUnversionedField(
    ID itemId,
    FieldChange change,
    DateTime now,
    bool fieldsAreEmpty
)
Visual Basic
Protected Overridable Sub WriteUnversionedField ( _
    itemId As ID, _
    change As FieldChange, _
    now As DateTime, _
    fieldsAreEmpty As Boolean _
)
Visual C++
protected:
virtual void WriteUnversionedField(
    ID^ itemId,
    FieldChange^ change,
    DateTime now,
    bool fieldsAreEmpty
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
change
Type: Sitecore.Data.Items..::..FieldChange
The change.
now
Type: System..::..DateTime
The current date.
fieldsAreEmpty
Type: System..::..Boolean
if set to true fields are empty.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


WriteVersionedField Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..WriteVersionedField Method
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void WriteVersionedField(
    ID itemId,
    FieldChange change,
    DateTime now,
    bool fieldsAreEmpty
)
Visual Basic
Protected Overridable Sub WriteVersionedField ( _
    itemId As ID, _
    change As FieldChange, _
    now As DateTime, _
    fieldsAreEmpty As Boolean _
)
Visual C++
protected:
virtual void WriteVersionedField(
    ID^ itemId,
    FieldChange^ change,
    DateTime now,
    bool fieldsAreEmpty
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
change
Type: Sitecore.Data.Items..::..FieldChange
The change.
now
Type: System..::..DateTime
The current date.
fieldsAreEmpty
Type: System..::..Boolean
if set to true fields are empty.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


SqlDataProvider Properties

[image] [image]

Sitecore 6.4.1 API
SqlDataProvider Properties
SqlDataProvider Class See Also Send Feedback

The SqlDataProvider type exposes the following members.

Properties

 | Name | Description
Protected property | Api | Gets the data API to the physical database.
Public property | CacheOptions | Gets the cache options. (Inherited from DataProvider.)
Public property | Database | Gets the database. (Inherited from DataProvider.)
Protected property | DescendantsShouldBeUpdated | Gets or sets a value indicating whether Descendants table should be updated
Protected property | Disable | Disables a method. (Inherited from DataProvider.)
Protected property | DisableGroup | Disables a group. (Inherited from DataProvider.)
Protected property | Enable | Enables a method. (Inherited from DataProvider.)
Protected property | EnableGroup | Enables a group. (Inherited from DataProvider.)
Protected property | Languages | Gets or sets languages
Public property | Name | Gets or sets the name.
Protected property | PrefetchCache | Gets the prefetch cache.
Protected property | PropertyCache | Gets the property cache.
Protected property | RebuildThread | Gets or sets a value indicating rebuilding thread
Protected property | SkipDescendantsUpdate | Gets a value indicating whether Descendantsd table should be updated.
Protected property | Translator | Gets the Sitecore Query to SQL translator.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


Api Property

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..Api Property
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected SqlDataApi Api { get; }
Visual Basic
Protected ReadOnly Property Api As SqlDataApi
    Get
Visual C++
protected:
property SqlDataApi^ Api {
    SqlDataApi^ get ();
}

Field Value

The data API.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


DescendantsShouldBeUpdated Property

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..DescendantsShouldBeUpdated Property
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected bool DescendantsShouldBeUpdated { get; set; }
Visual Basic
Protected Property DescendantsShouldBeUpdated As Boolean
    Get
    Set
Visual C++
protected:
property bool DescendantsShouldBeUpdated {
    bool get ();
    void set (bool value);
}

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


Languages Property

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..Languages Property
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected LanguageCollection Languages { get; set; }
Visual Basic
Protected Property Languages As LanguageCollection
    Get
    Set
Visual C++
protected:
property LanguageCollection^ Languages {
    LanguageCollection^ get ();
    void set (LanguageCollection^ value);
}

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


Name Property

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..Name Property
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string Name { get; set; }
Visual Basic
Public Overridable Property Name As String
    Get
    Set
Visual C++
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}

Field Value

The provider name.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


PrefetchCache Property

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..PrefetchCache Property
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Cache PrefetchCache { get; }
Visual Basic
Protected ReadOnly Property PrefetchCache As Cache
    Get
Visual C++
protected:
property Cache^ PrefetchCache {
    Cache^ get ();
}

Field Value

The prefetch cache.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


PropertyCache Property

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..PropertyCache Property
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Cache PropertyCache { get; }
Visual Basic
Protected ReadOnly Property PropertyCache As Cache
    Get
Visual C++
protected:
property Cache^ PropertyCache {
    Cache^ get ();
}

Field Value

The property cache.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


RebuildThread Property

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..RebuildThread Property
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Thread RebuildThread { get; set; }
Visual Basic
Protected Property RebuildThread As Thread
    Get
    Set
Visual C++
protected:
property Thread^ RebuildThread {
    Thread^ get ();
    void set (Thread^ value);
}

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


SkipDescendantsUpdate Property

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..SkipDescendantsUpdate Property
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool SkipDescendantsUpdate { get; }
Visual Basic
Protected Overridable ReadOnly Property SkipDescendantsUpdate As Boolean
    Get
Visual C++
protected:
virtual property bool SkipDescendantsUpdate {
    bool get ();
}

Return Value

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


Translator Property

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..Translator Property
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected QueryToSqlTranslator Translator { get; }
Visual Basic
Protected ReadOnly Property Translator As QueryToSqlTranslator
    Get
Visual C++
protected:
property QueryToSqlTranslator^ Translator {
    QueryToSqlTranslator^ get ();
}

Field Value

An intstance of QueryToSqlTranslator class.

See Also

SqlDataProvider Class
Sitecore.Data.DataProviders.Sql Namespace


SqlDataProvider.FieldSharingConverter Class

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..FieldSharingConverter Class
SqlDataProvider Class Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FieldSharingConverter
Visual Basic
Public Class FieldSharingConverter
Visual C++
public ref class FieldSharingConverter

Inheritance Hierarchy

System..::..Object
Sitecore.Data.DataProviders.Sql..::..SqlDataProvider..::..FieldSharingConverter

See Also

SqlDataProvider..::..FieldSharingConverter Members
Sitecore.Data.DataProviders.Sql Namespace


SqlDataProvider.FieldSharingConverter Members

[image] [image]

Sitecore 6.4.1 API
SqlDataProvider..::..FieldSharingConverter Members
SqlDataProvider..::..FieldSharingConverter Class Constructors Methods See Also Send Feedback

Base class for SQL based data providers.

The SqlDataProvider..::..FieldSharingConverter type exposes the following members.

Constructors

 | Name | Description
Public method | SqlDataProvider..::..FieldSharingConverter | Initializes a new instance of the SqlDataProvider..::..FieldSharingConverter class.

Methods

 | Name | Description
Public method | ChangeShareType | Changes type of the field sharing.
Protected method | DeleteSharedFields | Deletes the shared field values by id.
Protected method | DeleteUnversionedFields | Deletes the unversioned field values by id.
Protected method | DeleteVersionedFields | Deletes the versioned field values by id.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeShared(TemplateField) | Makes field shared.
Public method | MakeShared(ID, DefaultFieldSharing..::..SharingType) | Makes the field shared.
Protected method | MakeSharedFromUnversioned | Converts the field from unversioned to shared.
Protected method | MakeSharedFromVersioned | Converts the field from versioned to shared.
Public method | MakeUnversioned(TemplateField) | Makes the field unversioned.
Public method | MakeUnversioned(ID, DefaultFieldSharing..::..SharingType) | Makes the field unversioned.
Protected method | MakeUnversionedFromShared | Converts the field from shared to unversioned.
Protected method | MakeUnversionedFromVersioned | Converts the field from versioned to unversioned.
Public method | MakeVersioned(TemplateField) | Makes the field versioned.
Public method | MakeVersioned(ID, DefaultFieldSharing..::..SharingType) | Makes the field versioned.
Protected method | MakeVersionedFromShared | Converts the field from shared to versioned.
Protected method | MakeVersionedFromUnversioned | Converts the field from unversioned to versioned.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MoveDataToSharedFromUnversioned | Moves the data to shared from unversioned.
Protected method | MoveDataToSharedFromVersioned | Moves the data to shared from versioned.
Protected method | MoveDataToUnversionedFromShared | Converts the field from shared to unversioned.
Protected method | MoveDataToUnversionedFromVersioned | Converts the field from versioned to unversioned.
Protected method | MoveDataToVersionedFromShared | Converts the field from shared to versioned.
Protected method | MoveDataToVersionedFromUnversioned | Moves the data to versioned from unversioned.
Public method | MoveFieldData | Changes field sharing.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SqlDataProvider..::..FieldSharingConverter Class
Sitecore.Data.DataProviders.Sql Namespace


SqlDataProvider.FieldSharingConverter Methods

[image] [image]

Sitecore 6.4.1 API
SqlDataProvider..::..FieldSharingConverter Methods
SqlDataProvider..::..FieldSharingConverter Class See Also Send Feedback

The SqlDataProvider..::..FieldSharingConverter type exposes the following members.

Methods

 | Name | Description
Public method | ChangeShareType | Changes type of the field sharing.
Protected method | DeleteSharedFields | Deletes the shared field values by id.
Protected method | DeleteUnversionedFields | Deletes the unversioned field values by id.
Protected method | DeleteVersionedFields | Deletes the versioned field values by id.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeShared(TemplateField) | Makes field shared.
Public method | MakeShared(ID, DefaultFieldSharing..::..SharingType) | Makes the field shared.
Protected method | MakeSharedFromUnversioned | Converts the field from unversioned to shared.
Protected method | MakeSharedFromVersioned | Converts the field from versioned to shared.
Public method | MakeUnversioned(TemplateField) | Makes the field unversioned.
Public method | MakeUnversioned(ID, DefaultFieldSharing..::..SharingType) | Makes the field unversioned.
Protected method | MakeUnversionedFromShared | Converts the field from shared to unversioned.
Protected method | MakeUnversionedFromVersioned | Converts the field from versioned to unversioned.
Public method | MakeVersioned(TemplateField) | Makes the field versioned.
Public method | MakeVersioned(ID, DefaultFieldSharing..::..SharingType) | Makes the field versioned.
Protected method | MakeVersionedFromShared | Converts the field from shared to versioned.
Protected method | MakeVersionedFromUnversioned | Converts the field from unversioned to versioned.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MoveDataToSharedFromUnversioned | Moves the data to shared from unversioned.
Protected method | MoveDataToSharedFromVersioned | Moves the data to shared from versioned.
Protected method | MoveDataToUnversionedFromShared | Converts the field from shared to unversioned.
Protected method | MoveDataToUnversionedFromVersioned | Converts the field from versioned to unversioned.
Protected method | MoveDataToVersionedFromShared | Converts the field from shared to versioned.
Protected method | MoveDataToVersionedFromUnversioned | Moves the data to versioned from unversioned.
Public method | MoveFieldData | Changes field sharing.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SqlDataProvider..::..FieldSharingConverter Class
Sitecore.Data.DataProviders.Sql Namespace


ChangeShareType Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..FieldSharingConverter..::..ChangeShareType Method
SqlDataProvider..::..FieldSharingConverter Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool ChangeShareType(
    ID fieldId,
    DefaultFieldSharing..::..SharingType sourceType,
    DefaultFieldSharing..::..SharingType targetType
)
Visual Basic
Public Overridable Function ChangeShareType ( _
    fieldId As ID, _
    sourceType As DefaultFieldSharing..::..SharingType, _
    targetType As DefaultFieldSharing..::..SharingType _
) As Boolean
Visual C++
public:
virtual bool ChangeShareType(
    ID^ fieldId,
    DefaultFieldSharing..::..SharingType sourceType,
    DefaultFieldSharing..::..SharingType targetType
)

Parameters

fieldId
Type: Sitecore.Data..::..ID
The field id.
sourceType
Type: Sitecore.Data.Templates..::..DefaultFieldSharing..::..SharingType
Source type
targetType
Type: Sitecore.Data.Templates..::..DefaultFieldSharing..::..SharingType
Target type

Return Value

The change share type.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Unknown sharing type.

See Also

SqlDataProvider..::..FieldSharingConverter Class
Sitecore.Data.DataProviders.Sql Namespace


DeleteSharedFields Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..FieldSharingConverter..::..DeleteSharedFields Method
SqlDataProvider..::..FieldSharingConverter Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void DeleteSharedFields(
    ID fieldId,
    ID itemId
)
Visual Basic
Protected Overridable Sub DeleteSharedFields ( _
    fieldId As ID, _
    itemId As ID _
)
Visual C++
protected:
virtual void DeleteSharedFields(
    ID^ fieldId,
    ID^ itemId
)

Parameters

fieldId
Type: Sitecore.Data..::..ID
The field id.
itemId
Type: Sitecore.Data..::..ID
The item id.

See Also

SqlDataProvider..::..FieldSharingConverter Class
Sitecore.Data.DataProviders.Sql Namespace


DeleteUnversionedFields Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..FieldSharingConverter..::..DeleteUnversionedFields Method
SqlDataProvider..::..FieldSharingConverter Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void DeleteUnversionedFields(
    ID fieldId,
    ID itemId
)
Visual Basic
Protected Overridable Sub DeleteUnversionedFields ( _
    fieldId As ID, _
    itemId As ID _
)
Visual C++
protected:
virtual void DeleteUnversionedFields(
    ID^ fieldId,
    ID^ itemId
)

Parameters

fieldId
Type: Sitecore.Data..::..ID
The field id.
itemId
Type: Sitecore.Data..::..ID
The item id.

See Also

SqlDataProvider..::..FieldSharingConverter Class
Sitecore.Data.DataProviders.Sql Namespace


DeleteVersionedFields Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..FieldSharingConverter..::..DeleteVersionedFields Method
SqlDataProvider..::..FieldSharingConverter Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void DeleteVersionedFields(
    ID fieldId,
    ID itemId
)
Visual Basic
Protected Overridable Sub DeleteVersionedFields ( _
    fieldId As ID, _
    itemId As ID _
)
Visual C++
protected:
virtual void DeleteVersionedFields(
    ID^ fieldId,
    ID^ itemId
)

Parameters

fieldId
Type: Sitecore.Data..::..ID
The field id.
itemId
Type: Sitecore.Data..::..ID
The item ID.

See Also

SqlDataProvider..::..FieldSharingConverter Class
Sitecore.Data.DataProviders.Sql Namespace


MakeShared Method

[image] [image]

Sitecore 6.4.1 API
SqlDataProvider..::..FieldSharingConverter..::..MakeShared Method
SqlDataProvider..::..FieldSharingConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MakeShared(TemplateField) | Makes field shared.
Public method | MakeShared(ID, DefaultFieldSharing..::..SharingType) | Makes the field shared.

See Also

SqlDataProvider..::..FieldSharingConverter Class
SqlDataProvider..::..FieldSharingConverter Members
Sitecore.Data.DataProviders.Sql Namespace


MakeShared Method (TemplateField)

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..FieldSharingConverter..::..MakeShared Method (TemplateField)
SqlDataProvider..::..FieldSharingConverter Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool MakeShared(
    TemplateField fieldDefinition
)
Visual Basic
Public Overridable Function MakeShared ( _
    fieldDefinition As TemplateField _
) As Boolean
Visual C++
public:
virtual bool MakeShared(
    TemplateField^ fieldDefinition
)

Parameters

fieldDefinition
Type: Sitecore.Data.Templates..::..TemplateField
The field definition.

Return Value

The make shared.

See Also

SqlDataProvider..::..FieldSharingConverter Class
MakeShared Overload
Sitecore.Data.DataProviders.Sql Namespace


MakeShared Method (ID, DefaultFieldSharing.SharingType)

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..FieldSharingConverter..::..MakeShared Method (ID, DefaultFieldSharing..::..SharingType)
SqlDataProvider..::..FieldSharingConverter Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool MakeShared(
    ID fieldId,
    DefaultFieldSharing..::..SharingType sharingType
)
Visual Basic
Public Overridable Function MakeShared ( _
    fieldId As ID, _
    sharingType As DefaultFieldSharing..::..SharingType _
) As Boolean
Visual C++
public:
virtual bool MakeShared(
    ID^ fieldId,
    DefaultFieldSharing..::..SharingType sharingType
)

Parameters

fieldId
Type: Sitecore.Data..::..ID
The field id.
sharingType
Type: Sitecore.Data.Templates..::..DefaultFieldSharing..::..SharingType
The sharing type

Return Value

The make shared.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Unknown sharing type.

See Also

SqlDataProvider..::..FieldSharingConverter Class
MakeShared Overload
Sitecore.Data.DataProviders.Sql Namespace


MakeSharedFromUnversioned Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..FieldSharingConverter..::..MakeSharedFromUnversioned Method
SqlDataProvider..::..FieldSharingConverter Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool MakeSharedFromUnversioned(
    ID fieldId
)
Visual Basic
Protected Overridable Function MakeSharedFromUnversioned ( _
    fieldId As ID _
) As Boolean
Visual C++
protected:
virtual bool MakeSharedFromUnversioned(
    ID^ fieldId
)

Parameters

fieldId
Type: Sitecore.Data..::..ID
The field id.

Return Value

The make shared from unversioned.

See Also

SqlDataProvider..::..FieldSharingConverter Class
Sitecore.Data.DataProviders.Sql Namespace


MakeSharedFromVersioned Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..FieldSharingConverter..::..MakeSharedFromVersioned Method
SqlDataProvider..::..FieldSharingConverter Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool MakeSharedFromVersioned(
    ID fieldId
)
Visual Basic
Protected Overridable Function MakeSharedFromVersioned ( _
    fieldId As ID _
) As Boolean
Visual C++
protected:
virtual bool MakeSharedFromVersioned(
    ID^ fieldId
)

Parameters

fieldId
Type: Sitecore.Data..::..ID
The field id.

Return Value

The make shared from versioned.

See Also

SqlDataProvider..::..FieldSharingConverter Class
Sitecore.Data.DataProviders.Sql Namespace


MakeUnversioned Method

[image] [image]

Sitecore 6.4.1 API
SqlDataProvider..::..FieldSharingConverter..::..MakeUnversioned Method
SqlDataProvider..::..FieldSharingConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MakeUnversioned(TemplateField) | Makes the field unversioned.
Public method | MakeUnversioned(ID, DefaultFieldSharing..::..SharingType) | Makes the field unversioned.

See Also

SqlDataProvider..::..FieldSharingConverter Class
SqlDataProvider..::..FieldSharingConverter Members
Sitecore.Data.DataProviders.Sql Namespace


MakeUnversioned Method (TemplateField)

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..FieldSharingConverter..::..MakeUnversioned Method (TemplateField)
SqlDataProvider..::..FieldSharingConverter Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool MakeUnversioned(
    TemplateField fieldDefinition
)
Visual Basic
Public Overridable Function MakeUnversioned ( _
    fieldDefinition As TemplateField _
) As Boolean
Visual C++
public:
virtual bool MakeUnversioned(
    TemplateField^ fieldDefinition
)

Parameters

fieldDefinition
Type: Sitecore.Data.Templates..::..TemplateField
The field definition.

Return Value

The make unversioned.

See Also

SqlDataProvider..::..FieldSharingConverter Class
MakeUnversioned Overload
Sitecore.Data.DataProviders.Sql Namespace


MakeUnversioned Method (ID, DefaultFieldSharing.SharingType)

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..FieldSharingConverter..::..MakeUnversioned Method (ID, DefaultFieldSharing..::..SharingType)
SqlDataProvider..::..FieldSharingConverter Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool MakeUnversioned(
    ID fieldId,
    DefaultFieldSharing..::..SharingType sharingType
)
Visual Basic
Public Overridable Function MakeUnversioned ( _
    fieldId As ID, _
    sharingType As DefaultFieldSharing..::..SharingType _
) As Boolean
Visual C++
public:
virtual bool MakeUnversioned(
    ID^ fieldId,
    DefaultFieldSharing..::..SharingType sharingType
)

Parameters

fieldId
Type: Sitecore.Data..::..ID
The field id
sharingType
Type: Sitecore.Data.Templates..::..DefaultFieldSharing..::..SharingType
The sharing type

Return Value

The make unversioned.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Unknown sharing type.

See Also

SqlDataProvider..::..FieldSharingConverter Class
MakeUnversioned Overload
Sitecore.Data.DataProviders.Sql Namespace


MakeVersioned Method

[image] [image]

Sitecore 6.4.1 API
SqlDataProvider..::..FieldSharingConverter..::..MakeVersioned Method
SqlDataProvider..::..FieldSharingConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MakeVersioned(TemplateField) | Makes the field versioned.
Public method | MakeVersioned(ID, DefaultFieldSharing..::..SharingType) | Makes the field versioned.

See Also

SqlDataProvider..::..FieldSharingConverter Class
SqlDataProvider..::..FieldSharingConverter Members
Sitecore.Data.DataProviders.Sql Namespace


MakeVersioned Method (TemplateField)

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..FieldSharingConverter..::..MakeVersioned Method (TemplateField)
SqlDataProvider..::..FieldSharingConverter Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool MakeVersioned(
    TemplateField fieldDefinition
)
Visual Basic
Public Overridable Function MakeVersioned ( _
    fieldDefinition As TemplateField _
) As Boolean
Visual C++
public:
virtual bool MakeVersioned(
    TemplateField^ fieldDefinition
)

Parameters

fieldDefinition
Type: Sitecore.Data.Templates..::..TemplateField
The field definition.

Return Value

The make versioned.

See Also

SqlDataProvider..::..FieldSharingConverter Class
MakeVersioned Overload
Sitecore.Data.DataProviders.Sql Namespace


MakeVersioned Method (ID, DefaultFieldSharing.SharingType)

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..FieldSharingConverter..::..MakeVersioned Method (ID, DefaultFieldSharing..::..SharingType)
SqlDataProvider..::..FieldSharingConverter Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool MakeVersioned(
    ID fieldId,
    DefaultFieldSharing..::..SharingType sharingType
)
Visual Basic
Public Overridable Function MakeVersioned ( _
    fieldId As ID, _
    sharingType As DefaultFieldSharing..::..SharingType _
) As Boolean
Visual C++
public:
virtual bool MakeVersioned(
    ID^ fieldId,
    DefaultFieldSharing..::..SharingType sharingType
)

Parameters

fieldId
Type: Sitecore.Data..::..ID
The field id
sharingType
Type: Sitecore.Data.Templates..::..DefaultFieldSharing..::..SharingType
The sharing type

Return Value

The make versioned.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Unknown sharing type.

See Also

SqlDataProvider..::..FieldSharingConverter Class
MakeVersioned Overload
Sitecore.Data.DataProviders.Sql Namespace


MakeVersionedFromShared Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..FieldSharingConverter..::..MakeVersionedFromShared Method
SqlDataProvider..::..FieldSharingConverter Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool MakeVersionedFromShared(
    ID fieldId
)
Visual Basic
Protected Overridable Function MakeVersionedFromShared ( _
    fieldId As ID _
) As Boolean
Visual C++
protected:
virtual bool MakeVersionedFromShared(
    ID^ fieldId
)

Parameters

fieldId
Type: Sitecore.Data..::..ID
The field id.

Return Value

The make versioned from shared.

See Also

SqlDataProvider..::..FieldSharingConverter Class
Sitecore.Data.DataProviders.Sql Namespace


MakeVersionedFromUnversioned Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..FieldSharingConverter..::..MakeVersionedFromUnversioned Method
SqlDataProvider..::..FieldSharingConverter Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool MakeVersionedFromUnversioned(
    ID fieldId
)
Visual Basic
Protected Overridable Function MakeVersionedFromUnversioned ( _
    fieldId As ID _
) As Boolean
Visual C++
protected:
virtual bool MakeVersionedFromUnversioned(
    ID^ fieldId
)

Parameters

fieldId
Type: Sitecore.Data..::..ID
The field id.

Return Value

The make versioned from unversioned.

See Also

SqlDataProvider..::..FieldSharingConverter Class
Sitecore.Data.DataProviders.Sql Namespace


MoveDataToSharedFromUnversioned Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..FieldSharingConverter..::..MoveDataToSharedFromUnversioned Method
SqlDataProvider..::..FieldSharingConverter Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool MoveDataToSharedFromUnversioned(
    ID fieldId,
    ID itemId
)
Visual Basic
Protected Overridable Function MoveDataToSharedFromUnversioned ( _
    fieldId As ID, _
    itemId As ID _
) As Boolean
Visual C++
protected:
virtual bool MoveDataToSharedFromUnversioned(
    ID^ fieldId,
    ID^ itemId
)

Parameters

fieldId
Type: Sitecore.Data..::..ID
The field id.
itemId
Type: Sitecore.Data..::..ID
The item id.

Return Value

The move data to shared from unversioned.

See Also

SqlDataProvider..::..FieldSharingConverter Class
Sitecore.Data.DataProviders.Sql Namespace


MoveDataToSharedFromVersioned Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..FieldSharingConverter..::..MoveDataToSharedFromVersioned Method
SqlDataProvider..::..FieldSharingConverter Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool MoveDataToSharedFromVersioned(
    ID fieldId,
    ID itemId
)
Visual Basic
Protected Overridable Function MoveDataToSharedFromVersioned ( _
    fieldId As ID, _
    itemId As ID _
) As Boolean
Visual C++
protected:
virtual bool MoveDataToSharedFromVersioned(
    ID^ fieldId,
    ID^ itemId
)

Parameters

fieldId
Type: Sitecore.Data..::..ID
The field id.
itemId
Type: Sitecore.Data..::..ID
The item id.

Return Value

The data to shared from versioned.

See Also

SqlDataProvider..::..FieldSharingConverter Class
Sitecore.Data.DataProviders.Sql Namespace


MoveDataToUnversionedFromShared Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..FieldSharingConverter..::..MoveDataToUnversionedFromShared Method
SqlDataProvider..::..FieldSharingConverter Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool MoveDataToUnversionedFromShared(
    ID fieldId,
    ID itemId
)
Visual Basic
Protected Overridable Function MoveDataToUnversionedFromShared ( _
    fieldId As ID, _
    itemId As ID _
) As Boolean
Visual C++
protected:
virtual bool MoveDataToUnversionedFromShared(
    ID^ fieldId,
    ID^ itemId
)

Parameters

fieldId
Type: Sitecore.Data..::..ID
The field id.
itemId
Type: Sitecore.Data..::..ID
The item id.

Return Value

The move data to unversioned from shared.

See Also

SqlDataProvider..::..FieldSharingConverter Class
Sitecore.Data.DataProviders.Sql Namespace


MoveDataToUnversionedFromVersioned Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..FieldSharingConverter..::..MoveDataToUnversionedFromVersioned Method
SqlDataProvider..::..FieldSharingConverter Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool MoveDataToUnversionedFromVersioned(
    ID fieldId,
    ID itemId
)
Visual Basic
Protected Overridable Function MoveDataToUnversionedFromVersioned ( _
    fieldId As ID, _
    itemId As ID _
) As Boolean
Visual C++
protected:
virtual bool MoveDataToUnversionedFromVersioned(
    ID^ fieldId,
    ID^ itemId
)

Parameters

fieldId
Type: Sitecore.Data..::..ID
The field id.
itemId
Type: Sitecore.Data..::..ID
The item id.

Return Value

The move data to unversioned from versioned.

See Also

SqlDataProvider..::..FieldSharingConverter Class
Sitecore.Data.DataProviders.Sql Namespace


MoveDataToVersionedFromShared Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..FieldSharingConverter..::..MoveDataToVersionedFromShared Method
SqlDataProvider..::..FieldSharingConverter Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool MoveDataToVersionedFromShared(
    ID fieldId,
    ID itemId
)
Visual Basic
Protected Overridable Function MoveDataToVersionedFromShared ( _
    fieldId As ID, _
    itemId As ID _
) As Boolean
Visual C++
protected:
virtual bool MoveDataToVersionedFromShared(
    ID^ fieldId,
    ID^ itemId
)

Parameters

fieldId
Type: Sitecore.Data..::..ID
The field id.
itemId
Type: Sitecore.Data..::..ID
The item id.

Return Value

The move data to versioned from shared.

See Also

SqlDataProvider..::..FieldSharingConverter Class
Sitecore.Data.DataProviders.Sql Namespace


MoveDataToVersionedFromUnversioned Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..FieldSharingConverter..::..MoveDataToVersionedFromUnversioned Method
SqlDataProvider..::..FieldSharingConverter Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool MoveDataToVersionedFromUnversioned(
    ID fieldId,
    ID itemId
)
Visual Basic
Protected Overridable Function MoveDataToVersionedFromUnversioned ( _
    fieldId As ID, _
    itemId As ID _
) As Boolean
Visual C++
protected:
virtual bool MoveDataToVersionedFromUnversioned(
    ID^ fieldId,
    ID^ itemId
)

Parameters

fieldId
Type: Sitecore.Data..::..ID
The field id.
itemId
Type: Sitecore.Data..::..ID
The item id.

Return Value

The data to versioned from unversioned.

See Also

SqlDataProvider..::..FieldSharingConverter Class
Sitecore.Data.DataProviders.Sql Namespace


MoveFieldData Method

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..FieldSharingConverter..::..MoveFieldData Method
SqlDataProvider..::..FieldSharingConverter Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool MoveFieldData(
    TemplateField sourceField,
    TemplateField targetField,
    ID itemID
)
Visual Basic
Public Overridable Function MoveFieldData ( _
    sourceField As TemplateField, _
    targetField As TemplateField, _
    itemID As ID _
) As Boolean
Visual C++
public:
virtual bool MoveFieldData(
    TemplateField^ sourceField,
    TemplateField^ targetField,
    ID^ itemID
)

Parameters

sourceField
Type: Sitecore.Data.Templates..::..TemplateField
The source field.
targetField
Type: Sitecore.Data.Templates..::..TemplateField
The field.
itemID
Type: Sitecore.Data..::..ID
The item ID.

Return Value

true is data has been modified, false otherwise.

See Also

SqlDataProvider..::..FieldSharingConverter Class
Sitecore.Data.DataProviders.Sql Namespace


SqlDataProvider.UpdateFieldValueDelegate Delegate

[image]

Sitecore 6.4.1 API
SqlDataProvider..::..UpdateFieldValueDelegate Delegate
SqlDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public delegate string UpdateFieldValueDelegate(
    string value
)
Visual Basic
Public Delegate Function UpdateFieldValueDelegate ( _
    value As String _
) As String
Visual C++
public delegate String^ UpdateFieldValueDelegate(
    String^ value
)

Parameters

value
Type: System..::..String
value of a field

Return Value

New value for the field

See Also

Sitecore.Data.DataProviders.Sql Namespace


SqlStatement Class

[image]

Sitecore 6.4.1 API
SqlStatement Class
Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SqlStatement
Visual Basic
Public Class SqlStatement
Visual C++
public ref class SqlStatement

Inheritance Hierarchy

System..::..Object
Sitecore.Data.DataProviders.Sql..::..SqlStatement

See Also

SqlStatement Members
Sitecore.Data.DataProviders.Sql Namespace


SqlStatement Members

[image] [image]

Sitecore 6.4.1 API
SqlStatement Members
SqlStatement Class Constructors Methods Properties See Also Send Feedback

The SqlStatement type exposes the following members.

Constructors

 | Name | Description
Public method | SqlStatement | Initializes a new instance of the SqlStatement class

Methods

 | Name | Description
Public method | AddParameter | Adds a parameter.
Public method | AddParameters | Adds the parameters.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParameters | Gets the parameters.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | From | Gets or sets the FROM part.
Public property | OrderBy | Gets the order by.
Public property | Select | Gets or sets the SELECT part.
Public property | Sql | Gets the SQL.
Public property | Where | Gets or sets the where.

See Also

SqlStatement Class
Sitecore.Data.DataProviders.Sql Namespace


SqlStatement Constructor

[image]

Sitecore 6.4.1 API
SqlStatement Constructor
SqlStatement Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlStatement()
Visual Basic
Public Sub New
Visual C++
public:
SqlStatement()

See Also

SqlStatement Class
Sitecore.Data.DataProviders.Sql Namespace


SqlStatement Methods

[image] [image]

Sitecore 6.4.1 API
SqlStatement Methods
SqlStatement Class See Also Send Feedback

The SqlStatement type exposes the following members.

Methods

 | Name | Description
Public method | AddParameter | Adds a parameter.
Public method | AddParameters | Adds the parameters.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParameters | Gets the parameters.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SqlStatement Class
Sitecore.Data.DataProviders.Sql Namespace


AddParameter Method

[image]

Sitecore 6.4.1 API
SqlStatement..::..AddParameter Method
SqlStatement Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddParameter(
    string name,
    Object value
)
Visual Basic
Public Sub AddParameter ( _
    name As String, _
    value As Object _
)
Visual C++
public:
void AddParameter(
    String^ name,
    Object^ value
)

Parameters

name
Type: System..::..String
The name.
value
Type: System..::..Object
The value.

See Also

SqlStatement Class
Sitecore.Data.DataProviders.Sql Namespace


AddParameters Method

[image]

Sitecore 6.4.1 API
SqlStatement..::..AddParameters Method
SqlStatement Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddParameters(
    IEnumerable parameters
)
Visual Basic
Public Sub AddParameters ( _
    parameters As IEnumerable _
)
Visual C++
public:
void AddParameters(
    IEnumerable^ parameters
)

Parameters

parameters
Type: System.Collections..::..IEnumerable
The parameters.

See Also

SqlStatement Class
Sitecore.Data.DataProviders.Sql Namespace


GetParameters Method

[image]

Sitecore 6.4.1 API
SqlStatement..::..GetParameters Method
SqlStatement Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object[] GetParameters()
Visual Basic
Public Function GetParameters As Object()
Visual C++
public:
array<Object^>^ GetParameters()

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.Sql.SqlStatement.GetParameters"]

See Also

SqlStatement Class
Sitecore.Data.DataProviders.Sql Namespace


SqlStatement Properties

[image] [image]

Sitecore 6.4.1 API
SqlStatement Properties
SqlStatement Class See Also Send Feedback

The SqlStatement type exposes the following members.

Properties

 | Name | Description
Public property | From | Gets or sets the FROM part.
Public property | OrderBy | Gets the order by.
Public property | Select | Gets or sets the SELECT part.
Public property | Sql | Gets the SQL.
Public property | Where | Gets or sets the where.

See Also

SqlStatement Class
Sitecore.Data.DataProviders.Sql Namespace


OrderBy Property

[image]

Sitecore 6.4.1 API
SqlStatement..::..OrderBy Property
SqlStatement Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string OrderBy { get; set; }
Visual Basic
Public Property OrderBy As String
    Get
    Set
Visual C++
public:
property String^ OrderBy {
    String^ get ();
    void set (String^ value);
}

Field Value

The order by.

See Also

SqlStatement Class
Sitecore.Data.DataProviders.Sql Namespace


Select Property

[image]

Sitecore 6.4.1 API
SqlStatement..::..Select Property
SqlStatement Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Select { get; set; }
Visual Basic
Public Property Select As String
    Get
    Set
Visual C++
public:
property String^ Select {
    String^ get ();
    void set (String^ value);
}

Field Value

The select.

See Also

SqlStatement Class
Sitecore.Data.DataProviders.Sql Namespace


Sql Property

[image]

Sitecore 6.4.1 API
SqlStatement..::..Sql Property
SqlStatement Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Sql { get; }
Visual Basic
Public ReadOnly Property Sql As String
    Get
Visual C++
public:
property String^ Sql {
    String^ get ();
}

Field Value

The SQL.

See Also

SqlStatement Class
Sitecore.Data.DataProviders.Sql Namespace


Where Property

[image]

Sitecore 6.4.1 API
SqlStatement..::..Where Property
SqlStatement Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Where { get; set; }
Visual Basic
Public Property Where As String
    Get
    Set
Visual C++
public:
property String^ Where {
    String^ get ();
    void set (String^ value);
}

Field Value

The where.

See Also

SqlStatement Class
Sitecore.Data.DataProviders.Sql Namespace


Sitecore.Data.DataProviders.Sql.FastQuery Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Data.DataProviders.Sql.FastQuery Namespace
Send Feedback

Classes

 | Class | Description
Public class | BasicTranslationContext | Defines context for Query opcode to SQL translation operation.
Public class | BasicTranslatorFactory | Simple factory of objects translating Query opcodes to SQL
Public class | BooleanValueTranslator | Translator for Boolean values
Public class | ComparisonOperatorTranslator | Translates comparison operators (=, !=, >=, <=) into SQL predicates
Public class | EqualsOperatorTraits | Traits description for '==' and '!=' operators
Public class | FieldTranslator | Translates item field reference in query to SQL.
Public class | IDFieldInfo | IFieldInfo implementation for field references by ID
Public class | LiteralOpcodeTranslator | Translates string literal to SQL.
Public class | LocalTranslationContext | ITranlationContext implementation with isolated LocalData property.
Public class | LogicalOperatorTranslator | Translates logical operator (OR | AND) to SQL.
Public class | NameFieldInfo | IFieldInfo for field references by name
Public class | NumberValueTranslator | Converts number to SQL
Public class | ParametersList | Passes SQL parameters from translator to the caller.
Public class | QueryToSqlTranslator | Summary description for QueryToSqlTranslator.
Public class | RelationOperatorTraits | Description for comparison operators other that '==' and '!=';

Interfaces

 | Interface | Description
Public interface | IFieldInfo | Carries additional info for a field in the translation context
Public interface | IOpcodeTranslator | Interface for Query opcode translators.
Public interface | IOpcodeTranslatorFactory | Interface for a factory of objects performing translation of Query staements into SQL statements.
Public interface | IOperatorTraits | Describes features of eachs operator
Public interface | ITranslationContext | Defines context for Query to SQL translation operation.


BasicTranslationContext Class

[image]

Sitecore 6.4.1 API
BasicTranslationContext Class
Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class BasicTranslationContext : ITranslationContext
Visual Basic
Public Class BasicTranslationContext _
    Implements ITranslationContext
Visual C++
public ref class BasicTranslationContext : ITranslationContext

Inheritance Hierarchy

System..::..Object
Sitecore.Data.DataProviders.Sql.FastQuery..::..BasicTranslationContext

See Also

BasicTranslationContext Members
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


BasicTranslationContext Members

[image] [image]

Sitecore 6.4.1 API
BasicTranslationContext Members
BasicTranslationContext Class Constructors Methods Properties See Also Send Feedback

The BasicTranslationContext type exposes the following members.

Constructors

 | Name | Description
Public method | BasicTranslationContext | Initializes a new instance of the BasicTranslationContext class.

Methods

 | Name | Description
Public method | AddSubquery | Adds the subquery.
Public method | AddTable | Adds the table.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNextAlias | Gets the next alias.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Data | Gets the data.
Public property | Database | Gets the database for which translation is performed.
Public property | Factory | Gets the factory.
Public property | Fields | Gets the fields.
Public property | LocalData | Gets the local data.
Public property | Parameters | Gets the parameters manager for the SQL query.
Public property | ParentContext | Gets the parent context.
Public property | SqlApi | Gets the SQL API.
Public property | Tables | Gets the tables.

See Also

BasicTranslationContext Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


BasicTranslationContext Constructor

[image]

Sitecore 6.4.1 API
BasicTranslationContext Constructor
BasicTranslationContext Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BasicTranslationContext(
    IOpcodeTranslatorFactory factory,
    SqlDataApi api,
    Database database,
    ParametersList parameters
)
Visual Basic
Public Sub New ( _
    factory As IOpcodeTranslatorFactory, _
    api As SqlDataApi, _
    database As Database, _
    parameters As ParametersList _
)
Visual C++
public:
BasicTranslationContext(
    IOpcodeTranslatorFactory^ factory,
    SqlDataApi^ api,
    Database^ database,
    ParametersList^ parameters
)

Parameters

factory
Type: Sitecore.Data.DataProviders.Sql.FastQuery..::..IOpcodeTranslatorFactory
The factory.
api
Type: Sitecore.Data.DataProviders.Sql..::..SqlDataApi
The API.
database
Type: Sitecore.Data..::..Database
The database.
parameters
Type: Sitecore.Data.DataProviders.Sql.FastQuery..::..ParametersList
The parameters.

See Also

BasicTranslationContext Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


BasicTranslationContext Methods

[image] [image]

Sitecore 6.4.1 API
BasicTranslationContext Methods
BasicTranslationContext Class See Also Send Feedback

The BasicTranslationContext type exposes the following members.

Methods

 | Name | Description
Public method | AddSubquery | Adds the subquery.
Public method | AddTable | Adds the table.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNextAlias | Gets the next alias.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BasicTranslationContext Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


AddSubquery Method

[image]

Sitecore 6.4.1 API
BasicTranslationContext..::..AddSubquery Method
BasicTranslationContext Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string AddSubquery(
    string query,
    string tableName
)
Visual Basic
Public Function AddSubquery ( _
    query As String, _
    tableName As String _
) As String
Visual C++
public:
virtual String^ AddSubquery(
    String^ query,
    String^ tableName
) sealed

Parameters

query
Type: System..::..String
The query.
tableName
Type: System..::..String
Name of the table.

Return Value

The subquery.

Implements

ITranslationContext..::..AddSubquery(String, String)

See Also

BasicTranslationContext Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


AddTable Method

[image]

Sitecore 6.4.1 API
BasicTranslationContext..::..AddTable Method
BasicTranslationContext Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string AddTable(
    string tableName
)
Visual Basic
Public Function AddTable ( _
    tableName As String _
) As String
Visual C++
public:
virtual String^ AddTable(
    String^ tableName
) sealed

Parameters

tableName
Type: System..::..String
Name of the table.

Return Value

The table.

Implements

ITranslationContext..::..AddTable(String)

See Also

BasicTranslationContext Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


GetNextAlias Method

[image]

Sitecore 6.4.1 API
BasicTranslationContext..::..GetNextAlias Method
BasicTranslationContext Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetNextAlias(
    string prefix
)
Visual Basic
Public Function GetNextAlias ( _
    prefix As String _
) As String
Visual C++
public:
virtual String^ GetNextAlias(
    String^ prefix
) sealed

Parameters

prefix
Type: System..::..String
The prefix.

Return Value

The next alias.

Implements

ITranslationContext..::..GetNextAlias(String)

See Also

BasicTranslationContext Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


BasicTranslationContext Properties

[image] [image]

Sitecore 6.4.1 API
BasicTranslationContext Properties
BasicTranslationContext Class See Also Send Feedback

The BasicTranslationContext type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets the data.
Public property | Database | Gets the database for which translation is performed.
Public property | Factory | Gets the factory.
Public property | Fields | Gets the fields.
Public property | LocalData | Gets the local data.
Public property | Parameters | Gets the parameters manager for the SQL query.
Public property | ParentContext | Gets the parent context.
Public property | SqlApi | Gets the SQL API.
Public property | Tables | Gets the tables.

See Also

BasicTranslationContext Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


Data Property

[image]

Sitecore 6.4.1 API
BasicTranslationContext..::..Data Property
BasicTranslationContext Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IDictionary Data { get; }
Visual Basic
Public ReadOnly Property Data As IDictionary
    Get
Visual C++
public:
virtual property IDictionary^ Data {
    IDictionary^ get () sealed;
}

Field Value

The data.

Implements

ITranslationContext..::..Data

See Also

BasicTranslationContext Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


Database Property

[image]

Sitecore 6.4.1 API
BasicTranslationContext..::..Database Property
BasicTranslationContext Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database Database { get; }
Visual Basic
Public ReadOnly Property Database As Database
    Get
Visual C++
public:
virtual property Database^ Database {
    Database^ get () sealed;
}

Field Value

The database.

Implements

ITranslationContext..::..Database

See Also

BasicTranslationContext Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


Factory Property

[image]

Sitecore 6.4.1 API
BasicTranslationContext..::..Factory Property
BasicTranslationContext Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IOpcodeTranslatorFactory Factory { get; }
Visual Basic
Public ReadOnly Property Factory As IOpcodeTranslatorFactory
    Get
Visual C++
public:
virtual property IOpcodeTranslatorFactory^ Factory {
    IOpcodeTranslatorFactory^ get () sealed;
}

Field Value

The factory.

Implements

ITranslationContext..::..Factory

See Also

BasicTranslationContext Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


Fields Property

[image]

Sitecore 6.4.1 API
BasicTranslationContext..::..Fields Property
BasicTranslationContext Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IDictionary Fields { get; }
Visual Basic
Public ReadOnly Property Fields As IDictionary
    Get
Visual C++
public:
virtual property IDictionary^ Fields {
    IDictionary^ get () sealed;
}

Field Value

The fields.

Implements

ITranslationContext..::..Fields

See Also

BasicTranslationContext Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


LocalData Property

[image]

Sitecore 6.4.1 API
BasicTranslationContext..::..LocalData Property
BasicTranslationContext Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IDictionary LocalData { get; }
Visual Basic
Public ReadOnly Property LocalData As IDictionary
    Get
Visual C++
public:
virtual property IDictionary^ LocalData {
    IDictionary^ get () sealed;
}

Field Value

The local data.

Implements

ITranslationContext..::..LocalData

See Also

BasicTranslationContext Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


Parameters Property

[image]

Sitecore 6.4.1 API
BasicTranslationContext..::..Parameters Property
BasicTranslationContext Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ParametersList Parameters { get; }
Visual Basic
Public ReadOnly Property Parameters As ParametersList
    Get
Visual C++
public:
virtual property ParametersList^ Parameters {
    ParametersList^ get () sealed;
}

Field Value

The parameters.

Implements

ITranslationContext..::..Parameters

See Also

BasicTranslationContext Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


ParentContext Property

[image]

Sitecore 6.4.1 API
BasicTranslationContext..::..ParentContext Property
BasicTranslationContext Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ITranslationContext ParentContext { get; }
Visual Basic
Public ReadOnly Property ParentContext As ITranslationContext
    Get
Visual C++
public:
virtual property ITranslationContext^ ParentContext {
    ITranslationContext^ get () sealed;
}

Field Value

The parent context.

Implements

ITranslationContext..::..ParentContext

See Also

BasicTranslationContext Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


SqlApi Property

[image]

Sitecore 6.4.1 API
BasicTranslationContext..::..SqlApi Property
BasicTranslationContext Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlDataApi SqlApi { get; }
Visual Basic
Public ReadOnly Property SqlApi As SqlDataApi
    Get
Visual C++
public:
virtual property SqlDataApi^ SqlApi {
    SqlDataApi^ get () sealed;
}

Field Value

The SQL API.

Implements

ITranslationContext..::..SqlApi

See Also

BasicTranslationContext Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


Tables Property

[image]

Sitecore 6.4.1 API
BasicTranslationContext..::..Tables Property
BasicTranslationContext Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IDictionary Tables { get; }
Visual Basic
Public ReadOnly Property Tables As IDictionary
    Get
Visual C++
public:
virtual property IDictionary^ Tables {
    IDictionary^ get () sealed;
}

Field Value

The tables.

Implements

ITranslationContext..::..Tables

See Also

BasicTranslationContext Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


BasicTranslatorFactory Class

[image]

Sitecore 6.4.1 API
BasicTranslatorFactory Class
Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class BasicTranslatorFactory : IOpcodeTranslatorFactory
Visual Basic
Public Class BasicTranslatorFactory _
    Implements IOpcodeTranslatorFactory
Visual C++
public ref class BasicTranslatorFactory : IOpcodeTranslatorFactory

Inheritance Hierarchy

System..::..Object
Sitecore.Data.DataProviders.Sql.FastQuery..::..BasicTranslatorFactory

See Also

BasicTranslatorFactory Members
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


BasicTranslatorFactory Members

[image] [image]

Sitecore 6.4.1 API
BasicTranslatorFactory Members
BasicTranslatorFactory Class Constructors Methods See Also Send Feedback

The BasicTranslatorFactory type exposes the following members.

Constructors

 | Name | Description
Public method | BasicTranslatorFactory | Initializes a new instance of the BasicTranslatorFactory class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTranslator | Gets the translator for the opcode
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Register | Registers the specified type.
Public method | Remove | Removes the specified type.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BasicTranslatorFactory Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


BasicTranslatorFactory Constructor

[image]

Sitecore 6.4.1 API
BasicTranslatorFactory Constructor
BasicTranslatorFactory Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BasicTranslatorFactory()
Visual Basic
Public Sub New
Visual C++
public:
BasicTranslatorFactory()

See Also

BasicTranslatorFactory Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


BasicTranslatorFactory Methods

[image] [image]

Sitecore 6.4.1 API
BasicTranslatorFactory Methods
BasicTranslatorFactory Class See Also Send Feedback

The BasicTranslatorFactory type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTranslator | Gets the translator for the opcode
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Register | Registers the specified type.
Public method | Remove | Removes the specified type.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BasicTranslatorFactory Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


GetTranslator Method

[image]

Sitecore 6.4.1 API
BasicTranslatorFactory..::..GetTranslator Method
BasicTranslatorFactory Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IOpcodeTranslator GetTranslator(
    Opcode opcode
)
Visual Basic
Public Function GetTranslator ( _
    opcode As Opcode _
) As IOpcodeTranslator
Visual C++
public:
virtual IOpcodeTranslator^ GetTranslator(
    Opcode^ opcode
) sealed

Parameters

opcode
Type: Sitecore.Data.Query..::..Opcode
The opcode.

Return Value

The translator.

Implements

IOpcodeTranslatorFactory..::..GetTranslator(Opcode)

See Also

BasicTranslatorFactory Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


Register Method

[image]

Sitecore 6.4.1 API
BasicTranslatorFactory..::..Register Method
BasicTranslatorFactory Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Register(
    Type type,
    IOpcodeTranslator translator
)
Visual Basic
Public Sub Register ( _
    type As Type, _
    translator As IOpcodeTranslator _
)
Visual C++
public:
void Register(
    Type^ type,
    IOpcodeTranslator^ translator
)

Parameters

type
Type: System..::..Type
The type.
translator
Type: Sitecore.Data.DataProviders.Sql.FastQuery..::..IOpcodeTranslator
The translator.

See Also

BasicTranslatorFactory Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


Remove Method

[image]

Sitecore 6.4.1 API
BasicTranslatorFactory..::..Remove Method
BasicTranslatorFactory Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Remove(
    Type type
)
Visual Basic
Public Sub Remove ( _
    type As Type _
)
Visual C++
public:
void Remove(
    Type^ type
)

Parameters

type
Type: System..::..Type
The type.

See Also

BasicTranslatorFactory Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


BooleanValueTranslator Class

[image]

Sitecore 6.4.1 API
BooleanValueTranslator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class BooleanValueTranslator : IOpcodeTranslator
Visual Basic
Public Class BooleanValueTranslator _
    Implements IOpcodeTranslator
Visual C++
public ref class BooleanValueTranslator : IOpcodeTranslator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.DataProviders.Sql.FastQuery..::..BooleanValueTranslator

See Also

BooleanValueTranslator Members
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


BooleanValueTranslator Members

[image] [image]

Sitecore 6.4.1 API
BooleanValueTranslator Members
BooleanValueTranslator Class Constructors Methods See Also Send Feedback

The BooleanValueTranslator type exposes the following members.

Constructors

 | Name | Description
Public method | BooleanValueTranslator | Initializes a new instance of the BooleanValueTranslator class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetFalseExpression | Gets the false expression.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTrueExpression | Gets the true expression.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Translate | Translates the specified opcode.

See Also

BooleanValueTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


BooleanValueTranslator Constructor

[image]

Sitecore 6.4.1 API
BooleanValueTranslator Constructor
BooleanValueTranslator Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BooleanValueTranslator()
Visual Basic
Public Sub New
Visual C++
public:
BooleanValueTranslator()

See Also

BooleanValueTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


BooleanValueTranslator Methods

[image] [image]

Sitecore 6.4.1 API
BooleanValueTranslator Methods
BooleanValueTranslator Class See Also Send Feedback

The BooleanValueTranslator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetFalseExpression | Gets the false expression.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTrueExpression | Gets the true expression.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Translate | Translates the specified opcode.

See Also

BooleanValueTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


GetFalseExpression Method

[image]

Sitecore 6.4.1 API
BooleanValueTranslator..::..GetFalseExpression Method
BooleanValueTranslator Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string GetFalseExpression()
Visual Basic
Protected Overridable Function GetFalseExpression As String
Visual C++
protected:
virtual String^ GetFalseExpression()

Return Value

The false expression.

See Also

BooleanValueTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


GetTrueExpression Method

[image]

Sitecore 6.4.1 API
BooleanValueTranslator..::..GetTrueExpression Method
BooleanValueTranslator Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string GetTrueExpression()
Visual Basic
Protected Overridable Function GetTrueExpression As String
Visual C++
protected:
virtual String^ GetTrueExpression()

Return Value

The true expression.

See Also

BooleanValueTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


Translate Method

[image]

Sitecore 6.4.1 API
BooleanValueTranslator..::..Translate Method
BooleanValueTranslator Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Translate(
    Opcode opcode,
    ITranslationContext context
)
Visual Basic
Public Function Translate ( _
    opcode As Opcode, _
    context As ITranslationContext _
) As String
Visual C++
public:
virtual String^ Translate(
    Opcode^ opcode,
    ITranslationContext^ context
) sealed

Parameters

opcode
Type: Sitecore.Data.Query..::..Opcode
The opcode.
context
Type: Sitecore.Data.DataProviders.Sql.FastQuery..::..ITranslationContext
The context.

Return Value

The translate.

Implements

IOpcodeTranslator..::..Translate(Opcode, ITranslationContext)

See Also

BooleanValueTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


ComparisonOperatorTranslator Class

[image]

Sitecore 6.4.1 API
ComparisonOperatorTranslator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ComparisonOperatorTranslator : IOpcodeTranslator
Visual Basic
Public Class ComparisonOperatorTranslator _
    Implements IOpcodeTranslator
Visual C++
public ref class ComparisonOperatorTranslator : IOpcodeTranslator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.DataProviders.Sql.FastQuery..::..ComparisonOperatorTranslator

See Also

ComparisonOperatorTranslator Members
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


ComparisonOperatorTranslator Members

[image] [image]

Sitecore 6.4.1 API
ComparisonOperatorTranslator Members
ComparisonOperatorTranslator Class Constructors Methods See Also Send Feedback

The ComparisonOperatorTranslator type exposes the following members.

Constructors

 | Name | Description
Public method | ComparisonOperatorTranslator | Initializes a new instance of the ComparisonOperatorTranslator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareLeft | Prepares the left side of the relation.
Protected method | PrepareRight | Prepares the right side of the relation.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Translate | Translates the specified opcode.

See Also

ComparisonOperatorTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


ComparisonOperatorTranslator Constructor

[image]

Sitecore 6.4.1 API
ComparisonOperatorTranslator Constructor
ComparisonOperatorTranslator Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ComparisonOperatorTranslator(
    IOperatorTraits traits
)
Visual Basic
Public Sub New ( _
    traits As IOperatorTraits _
)
Visual C++
public:
ComparisonOperatorTranslator(
    IOperatorTraits^ traits
)

Parameters

traits
Type: Sitecore.Data.DataProviders.Sql.FastQuery..::..IOperatorTraits
The traits.

See Also

ComparisonOperatorTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


ComparisonOperatorTranslator Methods

[image] [image]

Sitecore 6.4.1 API
ComparisonOperatorTranslator Methods
ComparisonOperatorTranslator Class See Also Send Feedback

The ComparisonOperatorTranslator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareLeft | Prepares the left side of the relation.
Protected method | PrepareRight | Prepares the right side of the relation.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Translate | Translates the specified opcode.

See Also

ComparisonOperatorTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


PrepareLeft Method

[image]

Sitecore 6.4.1 API
ComparisonOperatorTranslator..::..PrepareLeft Method
ComparisonOperatorTranslator Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string PrepareLeft(
    string left
)
Visual Basic
Protected Overridable Function PrepareLeft ( _
    left As String _
) As String
Visual C++
protected:
virtual String^ PrepareLeft(
    String^ left
)

Parameters

left
Type: System..::..String
The left.

Return Value

The left.

See Also

ComparisonOperatorTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


PrepareRight Method

[image]

Sitecore 6.4.1 API
ComparisonOperatorTranslator..::..PrepareRight Method
ComparisonOperatorTranslator Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string PrepareRight(
    string right
)
Visual Basic
Protected Overridable Function PrepareRight ( _
    right As String _
) As String
Visual C++
protected:
virtual String^ PrepareRight(
    String^ right
)

Parameters

right
Type: System..::..String
The right.

Return Value

The right.

See Also

ComparisonOperatorTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


Translate Method

[image]

Sitecore 6.4.1 API
ComparisonOperatorTranslator..::..Translate Method
ComparisonOperatorTranslator Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Translate(
    Opcode opcode,
    ITranslationContext context
)
Visual Basic
Public Function Translate ( _
    opcode As Opcode, _
    context As ITranslationContext _
) As String
Visual C++
public:
virtual String^ Translate(
    Opcode^ opcode,
    ITranslationContext^ context
) sealed

Parameters

opcode
Type: Sitecore.Data.Query..::..Opcode
The opcode.
context
Type: Sitecore.Data.DataProviders.Sql.FastQuery..::..ITranslationContext
The context.

Return Value

The translate.

Implements

IOpcodeTranslator..::..Translate(Opcode, ITranslationContext)

See Also

ComparisonOperatorTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


EqualsOperatorTraits Class

[image]

Sitecore 6.4.1 API
EqualsOperatorTraits Class
Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class EqualsOperatorTraits : IOperatorTraits
Visual Basic
Public Class EqualsOperatorTraits _
    Implements IOperatorTraits
Visual C++
public ref class EqualsOperatorTraits : IOperatorTraits

Inheritance Hierarchy

System..::..Object
Sitecore.Data.DataProviders.Sql.FastQuery..::..EqualsOperatorTraits

See Also

EqualsOperatorTraits Members
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


EqualsOperatorTraits Members

[image] [image]

Sitecore 6.4.1 API
EqualsOperatorTraits Members
EqualsOperatorTraits Class Constructors Methods Properties See Also Send Feedback

The EqualsOperatorTraits type exposes the following members.

Constructors

 | Name | Description
Public method | EqualsOperatorTraits | Initializes a new instance of the EqualsOperatorTraits class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOperatorString | Gets the operator string.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | NeedsSimpleValues | Gets a value indicating whether the IOperatorTraits needss the simple values.

See Also

EqualsOperatorTraits Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


EqualsOperatorTraits Constructor

[image]

Sitecore 6.4.1 API
EqualsOperatorTraits Constructor
EqualsOperatorTraits Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public EqualsOperatorTraits(
    bool equals
)
Visual Basic
Public Sub New ( _
    equals As Boolean _
)
Visual C++
public:
EqualsOperatorTraits(
    bool equals
)

Parameters

equals
Type: System..::..Boolean
if set to true this instance is equals.

See Also

EqualsOperatorTraits Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


EqualsOperatorTraits Methods

[image] [image]

Sitecore 6.4.1 API
EqualsOperatorTraits Methods
EqualsOperatorTraits Class See Also Send Feedback

The EqualsOperatorTraits type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOperatorString | Gets the operator string.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EqualsOperatorTraits Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


GetOperatorString Method

[image]

Sitecore 6.4.1 API
EqualsOperatorTraits..::..GetOperatorString Method
EqualsOperatorTraits Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetOperatorString(
    ITranslationContext left,
    ITranslationContext right
)
Visual Basic
Public Function GetOperatorString ( _
    left As ITranslationContext, _
    right As ITranslationContext _
) As String
Visual C++
public:
virtual String^ GetOperatorString(
    ITranslationContext^ left,
    ITranslationContext^ right
) sealed

Parameters

left
Type: Sitecore.Data.DataProviders.Sql.FastQuery..::..ITranslationContext
The left.
right
Type: Sitecore.Data.DataProviders.Sql.FastQuery..::..ITranslationContext
The right.

Return Value

The operator string.

Implements

IOperatorTraits..::..GetOperatorString(ITranslationContext, ITranslationContext)

See Also

EqualsOperatorTraits Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


EqualsOperatorTraits Properties

[image] [image]

Sitecore 6.4.1 API
EqualsOperatorTraits Properties
EqualsOperatorTraits Class See Also Send Feedback

The EqualsOperatorTraits type exposes the following members.

Properties

 | Name | Description
Public property | NeedsSimpleValues | Gets a value indicating whether the IOperatorTraits needss the simple values.

See Also

EqualsOperatorTraits Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


NeedsSimpleValues Property

[image]

Sitecore 6.4.1 API
EqualsOperatorTraits..::..NeedsSimpleValues Property
EqualsOperatorTraits Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool NeedsSimpleValues { get; }
Visual Basic
Public ReadOnly Property NeedsSimpleValues As Boolean
    Get
Visual C++
public:
virtual property bool NeedsSimpleValues {
    bool get () sealed;
}

Field Value

true if the IOperatorTraits needss the simple values; otherwise, false.

Implements

IOperatorTraits..::..NeedsSimpleValues

See Also

EqualsOperatorTraits Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


FieldTranslator Class

[image]

Sitecore 6.4.1 API
FieldTranslator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FieldTranslator : IOpcodeTranslator
Visual Basic
Public Class FieldTranslator _
    Implements IOpcodeTranslator
Visual C++
public ref class FieldTranslator : IOpcodeTranslator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.DataProviders.Sql.FastQuery..::..FieldTranslator

See Also

FieldTranslator Members
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


FieldTranslator Members

[image] [image]

Sitecore 6.4.1 API
FieldTranslator Members
FieldTranslator Class Constructors Methods See Also Send Feedback

The FieldTranslator type exposes the following members.

Constructors

 | Name | Description
Public method | FieldTranslator | Initializes a new instance of the FieldTranslator class

Methods

 | Name | Description
Protected method | EnsureNotNull | Transforms expression to ensure it does not return NULL
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MakeSimpleString | Changes the expression so it returns a simple string value to allow comparison operators other than LIKE or equality.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RenderAttribute | Renders the attribute.
Protected method | RenderField | Renders the field from field info.
Protected method | RenderFieldByGuid | Renders the field by GUID.
Protected method | RenderFieldByName | Renders field by name.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Translate | Translates the specified opcode.

See Also

FieldTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


FieldTranslator Constructor

[image]

Sitecore 6.4.1 API
FieldTranslator Constructor
FieldTranslator Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FieldTranslator()
Visual Basic
Public Sub New
Visual C++
public:
FieldTranslator()

See Also

FieldTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


FieldTranslator Methods

[image] [image]

Sitecore 6.4.1 API
FieldTranslator Methods
FieldTranslator Class See Also Send Feedback

The FieldTranslator type exposes the following members.

Methods

 | Name | Description
Protected method | EnsureNotNull | Transforms expression to ensure it does not return NULL
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MakeSimpleString | Changes the expression so it returns a simple string value to allow comparison operators other than LIKE or equality.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RenderAttribute | Renders the attribute.
Protected method | RenderField | Renders the field from field info.
Protected method | RenderFieldByGuid | Renders the field by GUID.
Protected method | RenderFieldByName | Renders field by name.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Translate | Translates the specified opcode.

See Also

FieldTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


EnsureNotNull Method

[image]

Sitecore 6.4.1 API
FieldTranslator..::..EnsureNotNull Method
FieldTranslator Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string EnsureNotNull(
    string expression
)
Visual Basic
Protected Overridable Function EnsureNotNull ( _
    expression As String _
) As String
Visual C++
protected:
virtual String^ EnsureNotNull(
    String^ expression
)

Parameters

expression
Type: System..::..String
The expression.

Return Value

The not null.

See Also

FieldTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


MakeSimpleString Method

[image]

Sitecore 6.4.1 API
FieldTranslator..::..MakeSimpleString Method
FieldTranslator Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string MakeSimpleString(
    string expression
)
Visual Basic
Protected Overridable Function MakeSimpleString ( _
    expression As String _
) As String
Visual C++
protected:
virtual String^ MakeSimpleString(
    String^ expression
)

Parameters

expression
Type: System..::..String
The expression.

Return Value

Transformed expression.

See Also

FieldTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


RenderAttribute Method

[image]

Sitecore 6.4.1 API
FieldTranslator..::..RenderAttribute Method
FieldTranslator Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string RenderAttribute(
    string attribute,
    ITranslationContext context
)
Visual Basic
Protected Overridable Function RenderAttribute ( _
    attribute As String, _
    context As ITranslationContext _
) As String
Visual C++
protected:
virtual String^ RenderAttribute(
    String^ attribute,
    ITranslationContext^ context
)

Parameters

attribute
Type: System..::..String
The attribute.
context
Type: Sitecore.Data.DataProviders.Sql.FastQuery..::..ITranslationContext
The context.

Return Value

The attribute.

See Also

FieldTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


RenderField Method

[image]

Sitecore 6.4.1 API
FieldTranslator..::..RenderField Method
FieldTranslator Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string RenderField(
    IFieldInfo info,
    ITranslationContext context
)
Visual Basic
Protected Overridable Function RenderField ( _
    info As IFieldInfo, _
    context As ITranslationContext _
) As String
Visual C++
protected:
virtual String^ RenderField(
    IFieldInfo^ info,
    ITranslationContext^ context
)

Parameters

info
Type: Sitecore.Data.DataProviders.Sql.FastQuery..::..IFieldInfo
The info.
context
Type: Sitecore.Data.DataProviders.Sql.FastQuery..::..ITranslationContext
The context.

Return Value

The field.

See Also

FieldTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


RenderFieldByGuid Method

[image]

Sitecore 6.4.1 API
FieldTranslator..::..RenderFieldByGuid Method
FieldTranslator Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string RenderFieldByGuid(
    ID fieldID,
    ITranslationContext context
)
Visual Basic
Protected Overridable Function RenderFieldByGuid ( _
    fieldID As ID, _
    context As ITranslationContext _
) As String
Visual C++
protected:
virtual String^ RenderFieldByGuid(
    ID^ fieldID,
    ITranslationContext^ context
)

Parameters

fieldID
Type: Sitecore.Data..::..ID
The field ID.
context
Type: Sitecore.Data.DataProviders.Sql.FastQuery..::..ITranslationContext
The context.

Return Value

The field by GUID.

See Also

FieldTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


RenderFieldByName Method

[image]

Sitecore 6.4.1 API
FieldTranslator..::..RenderFieldByName Method
FieldTranslator Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string RenderFieldByName(
    string fieldName,
    ITranslationContext context
)
Visual Basic
Protected Overridable Function RenderFieldByName ( _
    fieldName As String, _
    context As ITranslationContext _
) As String
Visual C++
protected:
virtual String^ RenderFieldByName(
    String^ fieldName,
    ITranslationContext^ context
)

Parameters

fieldName
Type: System..::..String
Name of the field.
context
Type: Sitecore.Data.DataProviders.Sql.FastQuery..::..ITranslationContext
The context.

Return Value

The field by name.

See Also

FieldTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


IDFieldInfo Class

[image]

Sitecore 6.4.1 API
IDFieldInfo Class
Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class IDFieldInfo : IFieldInfo
Visual Basic
Public Class IDFieldInfo _
    Implements IFieldInfo
Visual C++
public ref class IDFieldInfo : IFieldInfo

Inheritance Hierarchy

System..::..Object
Sitecore.Data.DataProviders.Sql.FastQuery..::..IDFieldInfo

See Also

IDFieldInfo Members
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


IDFieldInfo Members

[image] [image]

Sitecore 6.4.1 API
IDFieldInfo Members
IDFieldInfo Class Constructors Methods Properties See Also Send Feedback

The IDFieldInfo type exposes the following members.

Constructors

 | Name | Description
Public method | IDFieldInfo | Initializes a new instance of the IDFieldInfo class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Alias | Gets the alias/name of the table/view holding the field value. The view will have VALUE column.

See Also

IDFieldInfo Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


IDFieldInfo Constructor

[image]

Sitecore 6.4.1 API
IDFieldInfo Constructor
IDFieldInfo Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IDFieldInfo(
    ID fieldId,
    ITranslationContext context
)
Visual Basic
Public Sub New ( _
    fieldId As ID, _
    context As ITranslationContext _
)
Visual C++
public:
IDFieldInfo(
    ID^ fieldId,
    ITranslationContext^ context
)

Parameters

fieldId
Type: Sitecore.Data..::..ID
The field id.
context
Type: Sitecore.Data.DataProviders.Sql.FastQuery..::..ITranslationContext
The context.

See Also

IDFieldInfo Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


IDFieldInfo Methods

[image] [image]

Sitecore 6.4.1 API
IDFieldInfo Methods
IDFieldInfo Class See Also Send Feedback

The IDFieldInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IDFieldInfo Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


IDFieldInfo Properties

[image] [image]

Sitecore 6.4.1 API
IDFieldInfo Properties
IDFieldInfo Class See Also Send Feedback

The IDFieldInfo type exposes the following members.

Properties

 | Name | Description
Public property | Alias | Gets the alias/name of the table/view holding the field value. The view will have VALUE column.

See Also

IDFieldInfo Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


Alias Property

[image]

Sitecore 6.4.1 API
IDFieldInfo..::..Alias Property
IDFieldInfo Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Alias { get; }
Visual Basic
Public ReadOnly Property Alias As String
    Get
Visual C++
public:
virtual property String^ Alias {
    String^ get () sealed;
}

Field Value

The alias.

Implements

IFieldInfo..::..Alias

See Also

IDFieldInfo Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


IFieldInfo Interface

[image]

Sitecore 6.4.1 API
IFieldInfo Interface
Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IFieldInfo
Visual Basic
Public Interface IFieldInfo
Visual C++
public interface class IFieldInfo

See Also

IFieldInfo Members
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


IFieldInfo Members

[image] [image]

Sitecore 6.4.1 API
IFieldInfo Members
IFieldInfo Interface Properties See Also Send Feedback

The IFieldInfo type exposes the following members.

Properties

 | Name | Description
Public property | Alias | Gets the alias/name of the table/view holding the field value. The view will have VALUE column.

See Also

IFieldInfo Interface
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


IFieldInfo Properties

[image] [image]

Sitecore 6.4.1 API
IFieldInfo Properties
IFieldInfo Interface See Also Send Feedback

The IFieldInfo type exposes the following members.

Properties

 | Name | Description
Public property | Alias | Gets the alias/name of the table/view holding the field value. The view will have VALUE column.

See Also

IFieldInfo Interface
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


Alias Property

[image]

Sitecore 6.4.1 API
IFieldInfo..::..Alias Property
IFieldInfo Interface See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
string Alias { get; }
Visual Basic
ReadOnly Property Alias As String
    Get
Visual C++
property String^ Alias {
    String^ get ();
}

Field Value

The alias.

See Also

IFieldInfo Interface
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


IOpcodeTranslator Interface

[image]

Sitecore 6.4.1 API
IOpcodeTranslator Interface
Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IOpcodeTranslator
Visual Basic
Public Interface IOpcodeTranslator
Visual C++
public interface class IOpcodeTranslator

See Also

IOpcodeTranslator Members
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


IOpcodeTranslator Members

[image] [image]

Sitecore 6.4.1 API
IOpcodeTranslator Members
IOpcodeTranslator Interface Methods See Also Send Feedback

The IOpcodeTranslator type exposes the following members.

Methods

 | Name | Description
Public method | Translate | Translates the specified opcode.

See Also

IOpcodeTranslator Interface
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


IOpcodeTranslator Methods

[image] [image]

Sitecore 6.4.1 API
IOpcodeTranslator Methods
IOpcodeTranslator Interface See Also Send Feedback

The IOpcodeTranslator type exposes the following members.

Methods

 | Name | Description
Public method | Translate | Translates the specified opcode.

See Also

IOpcodeTranslator Interface
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


Translate Method

[image]

Sitecore 6.4.1 API
IOpcodeTranslator..::..Translate Method
IOpcodeTranslator Interface See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
string Translate(
    Opcode opcode,
    ITranslationContext context
)
Visual Basic
Function Translate ( _
    opcode As Opcode, _
    context As ITranslationContext _
) As String
Visual C++
String^ Translate(
    Opcode^ opcode,
    ITranslationContext^ context
)

Parameters

opcode
Type: Sitecore.Data.Query..::..Opcode
The opcode.
context
Type: Sitecore.Data.DataProviders.Sql.FastQuery..::..ITranslationContext
The context.

Return Value

The translate.

See Also

IOpcodeTranslator Interface
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


IOpcodeTranslatorFactory Interface

[image]

Sitecore 6.4.1 API
IOpcodeTranslatorFactory Interface
Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IOpcodeTranslatorFactory
Visual Basic
Public Interface IOpcodeTranslatorFactory
Visual C++
public interface class IOpcodeTranslatorFactory

See Also

IOpcodeTranslatorFactory Members
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


IOpcodeTranslatorFactory Members

[image] [image]

Sitecore 6.4.1 API
IOpcodeTranslatorFactory Members
IOpcodeTranslatorFactory Interface Methods See Also Send Feedback

The IOpcodeTranslatorFactory type exposes the following members.

Methods

 | Name | Description
Public method | GetTranslator | Gets the translator for specific opcode.

See Also

IOpcodeTranslatorFactory Interface
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


GetTranslator Method

[image]

Sitecore 6.4.1 API
IOpcodeTranslatorFactory..::..GetTranslator Method
IOpcodeTranslatorFactory Interface See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
IOpcodeTranslator GetTranslator(
    Opcode opcode
)
Visual Basic
Function GetTranslator ( _
    opcode As Opcode _
) As IOpcodeTranslator
Visual C++
IOpcodeTranslator^ GetTranslator(
    Opcode^ opcode
)

Parameters

opcode
Type: Sitecore.Data.Query..::..Opcode
The opcode.

Return Value

The translator.

See Also

IOpcodeTranslatorFactory Interface
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


IOperatorTraits Interface

[image]

Sitecore 6.4.1 API
IOperatorTraits Interface
Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IOperatorTraits
Visual Basic
Public Interface IOperatorTraits
Visual C++
public interface class IOperatorTraits

See Also

IOperatorTraits Members
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


IOperatorTraits Members

[image] [image]

Sitecore 6.4.1 API
IOperatorTraits Members
IOperatorTraits Interface Methods Properties See Also Send Feedback

The IOperatorTraits type exposes the following members.

Methods

 | Name | Description
Public method | GetOperatorString | Gets the operator string.

Properties

 | Name | Description
Public property | NeedsSimpleValues | Gets a value indicating whether the IOperatorTraits needss the simple values.

See Also

IOperatorTraits Interface
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


IOperatorTraits Methods

[image] [image]

Sitecore 6.4.1 API
IOperatorTraits Methods
IOperatorTraits Interface See Also Send Feedback

The IOperatorTraits type exposes the following members.

Methods

 | Name | Description
Public method | GetOperatorString | Gets the operator string.

See Also

IOperatorTraits Interface
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


GetOperatorString Method

[image]

Sitecore 6.4.1 API
IOperatorTraits..::..GetOperatorString Method
IOperatorTraits Interface See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
string GetOperatorString(
    ITranslationContext left,
    ITranslationContext right
)
Visual Basic
Function GetOperatorString ( _
    left As ITranslationContext, _
    right As ITranslationContext _
) As String
Visual C++
String^ GetOperatorString(
    ITranslationContext^ left,
    ITranslationContext^ right
)

Parameters

left
Type: Sitecore.Data.DataProviders.Sql.FastQuery..::..ITranslationContext
The left.
right
Type: Sitecore.Data.DataProviders.Sql.FastQuery..::..ITranslationContext
The right.

Return Value

The operator string.

See Also

IOperatorTraits Interface
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


IOperatorTraits Properties

[image] [image]

Sitecore 6.4.1 API
IOperatorTraits Properties
IOperatorTraits Interface See Also Send Feedback

The IOperatorTraits type exposes the following members.

Properties

 | Name | Description
Public property | NeedsSimpleValues | Gets a value indicating whether the IOperatorTraits needss the simple values.

See Also

IOperatorTraits Interface
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


NeedsSimpleValues Property

[image]

Sitecore 6.4.1 API
IOperatorTraits..::..NeedsSimpleValues Property
IOperatorTraits Interface See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
bool NeedsSimpleValues { get; }
Visual Basic
ReadOnly Property NeedsSimpleValues As Boolean
    Get
Visual C++
property bool NeedsSimpleValues {
    bool get ();
}

Field Value

true if the IOperatorTraits needss the simple values; otherwise, false.

See Also

IOperatorTraits Interface
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


ITranslationContext Interface

[image]

Sitecore 6.4.1 API
ITranslationContext Interface
Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface ITranslationContext
Visual Basic
Public Interface ITranslationContext
Visual C++
public interface class ITranslationContext

See Also

ITranslationContext Members
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


ITranslationContext Members

[image] [image]

Sitecore 6.4.1 API
ITranslationContext Members
ITranslationContext Interface Methods Properties See Also Send Feedback

The ITranslationContext type exposes the following members.

Methods

 | Name | Description
Public method | AddSubquery | Adds the subquery.
Public method | AddTable | Adds the table.
Public method | GetNextAlias | Gets the next alias.

Properties

 | Name | Description
Public property | Data | Custom data dictionary (global).
Public property | Database | Gets the database for which translation is performed.
Public property | Factory | Gets the factory.
Public property | Fields | Gets the fields and their extra information.
Public property | LocalData | Local data dictionary.
Public property | Parameters | Gets the parameters manager for the SQL query.
Public property | ParentContext | Gets the parent context.
Public property | SqlApi | Gets the SQL API.
Public property | Tables | Gets the tables and their aliases.

See Also

ITranslationContext Interface
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


ITranslationContext Methods

[image] [image]

Sitecore 6.4.1 API
ITranslationContext Methods
ITranslationContext Interface See Also Send Feedback

The ITranslationContext type exposes the following members.

Methods

 | Name | Description
Public method | AddSubquery | Adds the subquery.
Public method | AddTable | Adds the table.
Public method | GetNextAlias | Gets the next alias.

See Also

ITranslationContext Interface
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


AddTable Method

[image]

Sitecore 6.4.1 API
ITranslationContext..::..AddTable Method
ITranslationContext Interface See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
string AddTable(
    string tableName
)
Visual Basic
Function AddTable ( _
    tableName As String _
) As String
Visual C++
String^ AddTable(
    String^ tableName
)

Parameters

tableName
Type: System..::..String
Name of the table.

Return Value

The table.

See Also

ITranslationContext Interface
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


GetNextAlias Method

[image]

Sitecore 6.4.1 API
ITranslationContext..::..GetNextAlias Method
ITranslationContext Interface See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
string GetNextAlias(
    string prefix
)
Visual Basic
Function GetNextAlias ( _
    prefix As String _
) As String
Visual C++
String^ GetNextAlias(
    String^ prefix
)

Parameters

prefix
Type: System..::..String
The prefix.

Return Value

The next alias.

See Also

ITranslationContext Interface
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


Data Property

[image]

Sitecore 6.4.1 API
ITranslationContext..::..Data Property
ITranslationContext Interface See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
IDictionary Data { get; }
Visual Basic
ReadOnly Property Data As IDictionary
    Get
Visual C++
property IDictionary^ Data {
    IDictionary^ get ();
}

Field Value

The data.

See Also

ITranslationContext Interface
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


Database Property

[image]

Sitecore 6.4.1 API
ITranslationContext..::..Database Property
ITranslationContext Interface See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
Database Database { get; }
Visual Basic
ReadOnly Property Database As Database
    Get
Visual C++
property Database^ Database {
    Database^ get ();
}

Field Value

The database.

See Also

ITranslationContext Interface
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


Factory Property

[image]

Sitecore 6.4.1 API
ITranslationContext..::..Factory Property
ITranslationContext Interface See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
IOpcodeTranslatorFactory Factory { get; }
Visual Basic
ReadOnly Property Factory As IOpcodeTranslatorFactory
    Get
Visual C++
property IOpcodeTranslatorFactory^ Factory {
    IOpcodeTranslatorFactory^ get ();
}

Field Value

The factory.

See Also

ITranslationContext Interface
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


LocalData Property

[image]

Sitecore 6.4.1 API
ITranslationContext..::..LocalData Property
ITranslationContext Interface See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
IDictionary LocalData { get; }
Visual Basic
ReadOnly Property LocalData As IDictionary
    Get
Visual C++
property IDictionary^ LocalData {
    IDictionary^ get ();
}

Field Value

The local data.

See Also

ITranslationContext Interface
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


Parameters Property

[image]

Sitecore 6.4.1 API
ITranslationContext..::..Parameters Property
ITranslationContext Interface See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
ParametersList Parameters { get; }
Visual Basic
ReadOnly Property Parameters As ParametersList
    Get
Visual C++
property ParametersList^ Parameters {
    ParametersList^ get ();
}

Field Value

The parameters.

See Also

ITranslationContext Interface
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


ParentContext Property

[image]

Sitecore 6.4.1 API
ITranslationContext..::..ParentContext Property
ITranslationContext Interface See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
ITranslationContext ParentContext { get; }
Visual Basic
ReadOnly Property ParentContext As ITranslationContext
    Get
Visual C++
property ITranslationContext^ ParentContext {
    ITranslationContext^ get ();
}

Field Value

The parent context.

See Also

ITranslationContext Interface
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


SqlApi Property

[image]

Sitecore 6.4.1 API
ITranslationContext..::..SqlApi Property
ITranslationContext Interface See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
SqlDataApi SqlApi { get; }
Visual Basic
ReadOnly Property SqlApi As SqlDataApi
    Get
Visual C++
property SqlDataApi^ SqlApi {
    SqlDataApi^ get ();
}

Field Value

The SQL API.

See Also

ITranslationContext Interface
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


Tables Property

[image]

Sitecore 6.4.1 API
ITranslationContext..::..Tables Property
ITranslationContext Interface See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
IDictionary Tables { get; }
Visual Basic
ReadOnly Property Tables As IDictionary
    Get
Visual C++
property IDictionary^ Tables {
    IDictionary^ get ();
}

Field Value

The tables.

See Also

ITranslationContext Interface
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


LiteralOpcodeTranslator Class

[image]

Sitecore 6.4.1 API
LiteralOpcodeTranslator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class LiteralOpcodeTranslator : IOpcodeTranslator
Visual Basic
Public Class LiteralOpcodeTranslator _
    Implements IOpcodeTranslator
Visual C++
public ref class LiteralOpcodeTranslator : IOpcodeTranslator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.DataProviders.Sql.FastQuery..::..LiteralOpcodeTranslator

See Also

LiteralOpcodeTranslator Members
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


LiteralOpcodeTranslator Members

[image] [image]

Sitecore 6.4.1 API
LiteralOpcodeTranslator Members
LiteralOpcodeTranslator Class Constructors Methods See Also Send Feedback

The LiteralOpcodeTranslator type exposes the following members.

Constructors

 | Name | Description
Public method | LiteralOpcodeTranslator | Initializes a new instance of the LiteralOpcodeTranslator class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplates | Gets the templates.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RenderTemplateReference | Renders the template reference.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Translate | Translates the specified opcode.

See Also

LiteralOpcodeTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


LiteralOpcodeTranslator Constructor

[image]

Sitecore 6.4.1 API
LiteralOpcodeTranslator Constructor
LiteralOpcodeTranslator Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LiteralOpcodeTranslator()
Visual Basic
Public Sub New
Visual C++
public:
LiteralOpcodeTranslator()

See Also

LiteralOpcodeTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


LiteralOpcodeTranslator Methods

[image] [image]

Sitecore 6.4.1 API
LiteralOpcodeTranslator Methods
LiteralOpcodeTranslator Class See Also Send Feedback

The LiteralOpcodeTranslator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplates | Gets the templates.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RenderTemplateReference | Renders the template reference.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Translate | Translates the specified opcode.

See Also

LiteralOpcodeTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


GetTemplates Method

[image]

Sitecore 6.4.1 API
LiteralOpcodeTranslator..::..GetTemplates Method
LiteralOpcodeTranslator Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Dictionary<string, string> GetTemplates(
    ITranslationContext context
)
Visual Basic
Protected Function GetTemplates ( _
    context As ITranslationContext _
) As Dictionary(Of String, String)
Visual C++
protected:
Dictionary<String^, String^>^ GetTemplates(
    ITranslationContext^ context
)

Parameters

context
Type: Sitecore.Data.DataProviders.Sql.FastQuery..::..ITranslationContext
The context.

Return Value

The templates.

See Also

LiteralOpcodeTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


RenderTemplateReference Method

[image]

Sitecore 6.4.1 API
LiteralOpcodeTranslator..::..RenderTemplateReference Method
LiteralOpcodeTranslator Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string RenderTemplateReference(
    ITranslationContext context,
    Literal literal
)
Visual Basic
Protected Overridable Function RenderTemplateReference ( _
    context As ITranslationContext, _
    literal As Literal _
) As String
Visual C++
protected:
virtual String^ RenderTemplateReference(
    ITranslationContext^ context,
    Literal^ literal
)

Parameters

context
Type: Sitecore.Data.DataProviders.Sql.FastQuery..::..ITranslationContext
The context.
literal
Type: Sitecore.Data.Query..::..Literal
The literal.

Return Value

The template reference.

See Also

LiteralOpcodeTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


Translate Method

[image]

Sitecore 6.4.1 API
LiteralOpcodeTranslator..::..Translate Method
LiteralOpcodeTranslator Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Translate(
    Opcode opcode,
    ITranslationContext context
)
Visual Basic
Public Function Translate ( _
    opcode As Opcode, _
    context As ITranslationContext _
) As String
Visual C++
public:
virtual String^ Translate(
    Opcode^ opcode,
    ITranslationContext^ context
) sealed

Parameters

opcode
Type: Sitecore.Data.Query..::..Opcode
The opcode.
context
Type: Sitecore.Data.DataProviders.Sql.FastQuery..::..ITranslationContext
The context.

Return Value

The translate.

Implements

IOpcodeTranslator..::..Translate(Opcode, ITranslationContext)

See Also

LiteralOpcodeTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


LocalTranslationContext Class

[image]

Sitecore 6.4.1 API
LocalTranslationContext Class
Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class LocalTranslationContext : ITranslationContext
Visual Basic
Public Class LocalTranslationContext _
    Implements ITranslationContext
Visual C++
public ref class LocalTranslationContext : ITranslationContext

Inheritance Hierarchy

System..::..Object
Sitecore.Data.DataProviders.Sql.FastQuery..::..LocalTranslationContext

See Also

LocalTranslationContext Members
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


LocalTranslationContext Members

[image] [image]

Sitecore 6.4.1 API
LocalTranslationContext Members
LocalTranslationContext Class Constructors Methods Properties See Also Send Feedback

The LocalTranslationContext type exposes the following members.

Constructors

 | Name | Description
Public method | LocalTranslationContext | Initializes a new instance of the LocalTranslationContext class.

Methods

 | Name | Description
Public method | AddSubquery | Adds the subquery.
Public method | AddTable | Adds the table.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNextAlias | Gets the next alias.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Data | Gets the data.
Public property | Database | Gets the database for which translation is performed.
Public property | Factory | Gets the factory.
Public property | Fields | Gets the fields.
Public property | LocalData | Gets the local data.
Public property | Parameters | Gets the parameters manager for the SQL query.
Public property | ParentContext | Gets the parent context.
Public property | SqlApi | Gets the SQL API.
Public property | Tables | Gets the tables.

See Also

LocalTranslationContext Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


LocalTranslationContext Constructor

[image]

Sitecore 6.4.1 API
LocalTranslationContext Constructor
LocalTranslationContext Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LocalTranslationContext(
    ITranslationContext baseContext
)
Visual Basic
Public Sub New ( _
    baseContext As ITranslationContext _
)
Visual C++
public:
LocalTranslationContext(
    ITranslationContext^ baseContext
)

Parameters

baseContext
Type: Sitecore.Data.DataProviders.Sql.FastQuery..::..ITranslationContext
The base context.

See Also

LocalTranslationContext Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


LocalTranslationContext Methods

[image] [image]

Sitecore 6.4.1 API
LocalTranslationContext Methods
LocalTranslationContext Class See Also Send Feedback

The LocalTranslationContext type exposes the following members.

Methods

 | Name | Description
Public method | AddSubquery | Adds the subquery.
Public method | AddTable | Adds the table.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNextAlias | Gets the next alias.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LocalTranslationContext Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


AddSubquery Method

[image]

Sitecore 6.4.1 API
LocalTranslationContext..::..AddSubquery Method
LocalTranslationContext Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string AddSubquery(
    string query,
    string tableName
)
Visual Basic
Public Function AddSubquery ( _
    query As String, _
    tableName As String _
) As String
Visual C++
public:
virtual String^ AddSubquery(
    String^ query,
    String^ tableName
) sealed

Parameters

query
Type: System..::..String
The query.
tableName
Type: System..::..String
Name of the table.

Return Value

The subquery.

Implements

ITranslationContext..::..AddSubquery(String, String)

See Also

LocalTranslationContext Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


AddTable Method

[image]

Sitecore 6.4.1 API
LocalTranslationContext..::..AddTable Method
LocalTranslationContext Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string AddTable(
    string tableName
)
Visual Basic
Public Function AddTable ( _
    tableName As String _
) As String
Visual C++
public:
virtual String^ AddTable(
    String^ tableName
) sealed

Parameters

tableName
Type: System..::..String
Name of the table.

Return Value

The table.

Implements

ITranslationContext..::..AddTable(String)

See Also

LocalTranslationContext Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


GetNextAlias Method

[image]

Sitecore 6.4.1 API
LocalTranslationContext..::..GetNextAlias Method
LocalTranslationContext Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetNextAlias(
    string prefix
)
Visual Basic
Public Function GetNextAlias ( _
    prefix As String _
) As String
Visual C++
public:
virtual String^ GetNextAlias(
    String^ prefix
) sealed

Parameters

prefix
Type: System..::..String
The prefix.

Return Value

The next alias.

Implements

ITranslationContext..::..GetNextAlias(String)

See Also

LocalTranslationContext Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


LocalTranslationContext Properties

[image] [image]

Sitecore 6.4.1 API
LocalTranslationContext Properties
LocalTranslationContext Class See Also Send Feedback

The LocalTranslationContext type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets the data.
Public property | Database | Gets the database for which translation is performed.
Public property | Factory | Gets the factory.
Public property | Fields | Gets the fields.
Public property | LocalData | Gets the local data.
Public property | Parameters | Gets the parameters manager for the SQL query.
Public property | ParentContext | Gets the parent context.
Public property | SqlApi | Gets the SQL API.
Public property | Tables | Gets the tables.

See Also

LocalTranslationContext Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


Data Property

[image]

Sitecore 6.4.1 API
LocalTranslationContext..::..Data Property
LocalTranslationContext Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IDictionary Data { get; }
Visual Basic
Public ReadOnly Property Data As IDictionary
    Get
Visual C++
public:
virtual property IDictionary^ Data {
    IDictionary^ get () sealed;
}

Field Value

The data.

Implements

ITranslationContext..::..Data

See Also

LocalTranslationContext Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


Database Property

[image]

Sitecore 6.4.1 API
LocalTranslationContext..::..Database Property
LocalTranslationContext Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database Database { get; }
Visual Basic
Public ReadOnly Property Database As Database
    Get
Visual C++
public:
virtual property Database^ Database {
    Database^ get () sealed;
}

Field Value

The database.

Implements

ITranslationContext..::..Database

See Also

LocalTranslationContext Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


Factory Property

[image]

Sitecore 6.4.1 API
LocalTranslationContext..::..Factory Property
LocalTranslationContext Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IOpcodeTranslatorFactory Factory { get; }
Visual Basic
Public ReadOnly Property Factory As IOpcodeTranslatorFactory
    Get
Visual C++
public:
virtual property IOpcodeTranslatorFactory^ Factory {
    IOpcodeTranslatorFactory^ get () sealed;
}

Field Value

The factory.

Implements

ITranslationContext..::..Factory

See Also

LocalTranslationContext Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


Fields Property

[image]

Sitecore 6.4.1 API
LocalTranslationContext..::..Fields Property
LocalTranslationContext Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IDictionary Fields { get; }
Visual Basic
Public ReadOnly Property Fields As IDictionary
    Get
Visual C++
public:
virtual property IDictionary^ Fields {
    IDictionary^ get () sealed;
}

Field Value

The fields.

Implements

ITranslationContext..::..Fields

See Also

LocalTranslationContext Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


LocalData Property

[image]

Sitecore 6.4.1 API
LocalTranslationContext..::..LocalData Property
LocalTranslationContext Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IDictionary LocalData { get; }
Visual Basic
Public ReadOnly Property LocalData As IDictionary
    Get
Visual C++
public:
virtual property IDictionary^ LocalData {
    IDictionary^ get () sealed;
}

Field Value

The local data.

Implements

ITranslationContext..::..LocalData

See Also

LocalTranslationContext Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


Parameters Property

[image]

Sitecore 6.4.1 API
LocalTranslationContext..::..Parameters Property
LocalTranslationContext Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ParametersList Parameters { get; }
Visual Basic
Public ReadOnly Property Parameters As ParametersList
    Get
Visual C++
public:
virtual property ParametersList^ Parameters {
    ParametersList^ get () sealed;
}

Field Value

The parameters.

Implements

ITranslationContext..::..Parameters

See Also

LocalTranslationContext Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


SqlApi Property

[image]

Sitecore 6.4.1 API
LocalTranslationContext..::..SqlApi Property
LocalTranslationContext Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlDataApi SqlApi { get; }
Visual Basic
Public ReadOnly Property SqlApi As SqlDataApi
    Get
Visual C++
public:
virtual property SqlDataApi^ SqlApi {
    SqlDataApi^ get () sealed;
}

Field Value

The SQL API.

Implements

ITranslationContext..::..SqlApi

See Also

LocalTranslationContext Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


Tables Property

[image]

Sitecore 6.4.1 API
LocalTranslationContext..::..Tables Property
LocalTranslationContext Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IDictionary Tables { get; }
Visual Basic
Public ReadOnly Property Tables As IDictionary
    Get
Visual C++
public:
virtual property IDictionary^ Tables {
    IDictionary^ get () sealed;
}

Field Value

The tables.

Implements

ITranslationContext..::..Tables

See Also

LocalTranslationContext Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


LogicalOperatorTranslator Class

[image]

Sitecore 6.4.1 API
LogicalOperatorTranslator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class LogicalOperatorTranslator : IOpcodeTranslator
Visual Basic
Public Class LogicalOperatorTranslator _
    Implements IOpcodeTranslator
Visual C++
public ref class LogicalOperatorTranslator : IOpcodeTranslator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.DataProviders.Sql.FastQuery..::..LogicalOperatorTranslator

See Also

LogicalOperatorTranslator Members
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


LogicalOperatorTranslator Members

[image] [image]

Sitecore 6.4.1 API
LogicalOperatorTranslator Members
LogicalOperatorTranslator Class Constructors Methods See Also Send Feedback

The LogicalOperatorTranslator type exposes the following members.

Constructors

 | Name | Description
Public method | LogicalOperatorTranslator | Initializes a new instance of the LogicalOperatorTranslator class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Translate | Translates the specified opcode.

See Also

LogicalOperatorTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


LogicalOperatorTranslator Constructor

[image]

Sitecore 6.4.1 API
LogicalOperatorTranslator Constructor
LogicalOperatorTranslator Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LogicalOperatorTranslator()
Visual Basic
Public Sub New
Visual C++
public:
LogicalOperatorTranslator()

See Also

LogicalOperatorTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


LogicalOperatorTranslator Methods

[image] [image]

Sitecore 6.4.1 API
LogicalOperatorTranslator Methods
LogicalOperatorTranslator Class See Also Send Feedback

The LogicalOperatorTranslator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Translate | Translates the specified opcode.

See Also

LogicalOperatorTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


Translate Method

[image]

Sitecore 6.4.1 API
LogicalOperatorTranslator..::..Translate Method
LogicalOperatorTranslator Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Translate(
    Opcode opcode,
    ITranslationContext context
)
Visual Basic
Public Function Translate ( _
    opcode As Opcode, _
    context As ITranslationContext _
) As String
Visual C++
public:
virtual String^ Translate(
    Opcode^ opcode,
    ITranslationContext^ context
) sealed

Parameters

opcode
Type: Sitecore.Data.Query..::..Opcode
The opcode.
context
Type: Sitecore.Data.DataProviders.Sql.FastQuery..::..ITranslationContext
The context.

Return Value

The translate.

Implements

IOpcodeTranslator..::..Translate(Opcode, ITranslationContext)

See Also

LogicalOperatorTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


NameFieldInfo Class

[image]

Sitecore 6.4.1 API
NameFieldInfo Class
Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class NameFieldInfo : IFieldInfo
Visual Basic
Public Class NameFieldInfo _
    Implements IFieldInfo
Visual C++
public ref class NameFieldInfo : IFieldInfo

Inheritance Hierarchy

System..::..Object
Sitecore.Data.DataProviders.Sql.FastQuery..::..NameFieldInfo

See Also

NameFieldInfo Members
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


NameFieldInfo Constructor

[image]

Sitecore 6.4.1 API
NameFieldInfo Constructor
NameFieldInfo Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public NameFieldInfo(
    string fieldName,
    ITranslationContext context
)
Visual Basic
Public Sub New ( _
    fieldName As String, _
    context As ITranslationContext _
)
Visual C++
public:
NameFieldInfo(
    String^ fieldName,
    ITranslationContext^ context
)

Parameters

fieldName
Type: System..::..String
Name of the field.
context
Type: Sitecore.Data.DataProviders.Sql.FastQuery..::..ITranslationContext
The context.

See Also

NameFieldInfo Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


NameFieldInfo Methods

[image] [image]

Sitecore 6.4.1 API
NameFieldInfo Methods
NameFieldInfo Class See Also Send Feedback

The NameFieldInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NameFieldInfo Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


NameFieldInfo Properties

[image] [image]

Sitecore 6.4.1 API
NameFieldInfo Properties
NameFieldInfo Class See Also Send Feedback

The NameFieldInfo type exposes the following members.

Properties

 | Name | Description
Public property | Alias | Gets the alias/name of the table/view holding the field value. The view will have VALUE column.

See Also

NameFieldInfo Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


Alias Property

[image]

Sitecore 6.4.1 API
NameFieldInfo..::..Alias Property
NameFieldInfo Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Alias { get; }
Visual Basic
Public ReadOnly Property Alias As String
    Get
Visual C++
public:
virtual property String^ Alias {
    String^ get () sealed;
}

Field Value

The alias.

Implements

IFieldInfo..::..Alias

See Also

NameFieldInfo Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


NumberValueTranslator Class

[image]

Sitecore 6.4.1 API
NumberValueTranslator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class NumberValueTranslator : IOpcodeTranslator
Visual Basic
Public Class NumberValueTranslator _
    Implements IOpcodeTranslator
Visual C++
public ref class NumberValueTranslator : IOpcodeTranslator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.DataProviders.Sql.FastQuery..::..NumberValueTranslator

See Also

NumberValueTranslator Members
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


NumberValueTranslator Members

[image] [image]

Sitecore 6.4.1 API
NumberValueTranslator Members
NumberValueTranslator Class Constructors Methods See Also Send Feedback

The NumberValueTranslator type exposes the following members.

Constructors

 | Name | Description
Public method | NumberValueTranslator | Initializes a new instance of the NumberValueTranslator class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Translate | Translates the specified opcode.

See Also

NumberValueTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


NumberValueTranslator Constructor

[image]

Sitecore 6.4.1 API
NumberValueTranslator Constructor
NumberValueTranslator Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public NumberValueTranslator()
Visual Basic
Public Sub New
Visual C++
public:
NumberValueTranslator()

See Also

NumberValueTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


NumberValueTranslator Methods

[image] [image]

Sitecore 6.4.1 API
NumberValueTranslator Methods
NumberValueTranslator Class See Also Send Feedback

The NumberValueTranslator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Translate | Translates the specified opcode.

See Also

NumberValueTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


Translate Method

[image]

Sitecore 6.4.1 API
NumberValueTranslator..::..Translate Method
NumberValueTranslator Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Translate(
    Opcode opcode,
    ITranslationContext context
)
Visual Basic
Public Function Translate ( _
    opcode As Opcode, _
    context As ITranslationContext _
) As String
Visual C++
public:
virtual String^ Translate(
    Opcode^ opcode,
    ITranslationContext^ context
) sealed

Parameters

opcode
Type: Sitecore.Data.Query..::..Opcode
The opcode.
context
Type: Sitecore.Data.DataProviders.Sql.FastQuery..::..ITranslationContext
The context.

Return Value

The translate.

Implements

IOpcodeTranslator..::..Translate(Opcode, ITranslationContext)

See Also

NumberValueTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


ParametersList Class

[image]

Sitecore 6.4.1 API
ParametersList Class
Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ParametersList
Visual Basic
Public Class ParametersList
Visual C++
public ref class ParametersList

Inheritance Hierarchy

System..::..Object
Sitecore.Data.DataProviders.Sql.FastQuery..::..ParametersList

See Also

ParametersList Members
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


ParametersList Members

[image] [image]

Sitecore 6.4.1 API
ParametersList Members
ParametersList Class Constructors Methods See Also Send Feedback

The ParametersList type exposes the following members.

Constructors

 | Name | Description
Public method | ParametersList | Initializes a new instance of the ParametersList class

Methods

 | Name | Description
Public method | AddParameter | Adds the parameter.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToArray | Converts the ParametersList to an array of objects.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParametersList Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


ParametersList Constructor

[image]

Sitecore 6.4.1 API
ParametersList Constructor
ParametersList Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ParametersList()
Visual Basic
Public Sub New
Visual C++
public:
ParametersList()

See Also

ParametersList Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


ParametersList Methods

[image] [image]

Sitecore 6.4.1 API
ParametersList Methods
ParametersList Class See Also Send Feedback

The ParametersList type exposes the following members.

Methods

 | Name | Description
Public method | AddParameter | Adds the parameter.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToArray | Converts the ParametersList to an array of objects.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParametersList Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


AddParameter Method

[image]

Sitecore 6.4.1 API
ParametersList..::..AddParameter Method
ParametersList Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string AddParameter(
    Object value
)
Visual Basic
Public Function AddParameter ( _
    value As Object _
) As String
Visual C++
public:
String^ AddParameter(
    Object^ value
)

Parameters

value
Type: System..::..Object
The value.

Return Value

The parameter.

See Also

ParametersList Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


ToArray Method

[image]

Sitecore 6.4.1 API
ParametersList..::..ToArray Method
ParametersList Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object[] ToArray()
Visual Basic
Public Function ToArray As Object()
Visual C++
public:
array<Object^>^ ToArray()

Return Value

The array of parameters suitable for SqlDataApi.

See Also

ParametersList Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


QueryToSqlTranslator Class

[image]

Sitecore 6.4.1 API
QueryToSqlTranslator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class QueryToSqlTranslator
Visual Basic
Public Class QueryToSqlTranslator
Visual C++
public ref class QueryToSqlTranslator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.DataProviders.Sql.FastQuery..::..QueryToSqlTranslator

See Also

QueryToSqlTranslator Members
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


QueryToSqlTranslator Members

[image] [image]

Sitecore 6.4.1 API
QueryToSqlTranslator Members
QueryToSqlTranslator Class Constructors Methods Fields See Also Send Feedback

The QueryToSqlTranslator type exposes the following members.

Constructors

 | Name | Description
Public method | QueryToSqlTranslator | Initializes a new instance of the QueryToSqlTranslator class.

Methods

 | Name | Description
Protected method | AddConditionJoint | Adds the condition joint.
Protected method | AddExtraJoins | Adds the extra joins.
Protected method | AddFieldJoins | Adds the field joins.
Protected method | AddInitialStatement | Adds the initial statement.
Protected method | AddName | Adds the name to the query.
Protected method | AddNameFilter | Adds the name filter.
Protected method | AddNestedQuery | Adds the nested query.
Protected method | AddRootItemFilter | Adds the root item filter.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetName | Gets the name.
Protected method | GetPredicate | Gets the predicate.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TranslateQuery | Translates the query.

Fields

 | Name | Description
Protected field | _api | Database-specific SQL Api
Protected field | _factory | Factory of translator objects

See Also

QueryToSqlTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


QueryToSqlTranslator Constructor

[image]

Sitecore 6.4.1 API
QueryToSqlTranslator Constructor
QueryToSqlTranslator Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public QueryToSqlTranslator(
    SqlDataApi api
)
Visual Basic
Public Sub New ( _
    api As SqlDataApi _
)
Visual C++
public:
QueryToSqlTranslator(
    SqlDataApi^ api
)

Parameters

api
Type: Sitecore.Data.DataProviders.Sql..::..SqlDataApi
The API.

See Also

QueryToSqlTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


QueryToSqlTranslator Fields

[image] [image]

Sitecore 6.4.1 API
QueryToSqlTranslator Fields
QueryToSqlTranslator Class See Also Send Feedback

The QueryToSqlTranslator type exposes the following members.

Fields

 | Name | Description
Protected field | _api | Database-specific SQL Api
Protected field | _factory | Factory of translator objects

See Also

QueryToSqlTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


_api Field

[image]

Sitecore 6.4.1 API
QueryToSqlTranslator..::.._api Field
QueryToSqlTranslator Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected SqlDataApi _api
Visual Basic
Protected _api As SqlDataApi
Visual C++
protected:
SqlDataApi^ _api

See Also

QueryToSqlTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


_factory Field

[image]

Sitecore 6.4.1 API
QueryToSqlTranslator..::.._factory Field
QueryToSqlTranslator Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected IOpcodeTranslatorFactory _factory
Visual Basic
Protected _factory As IOpcodeTranslatorFactory
Visual C++
protected:
IOpcodeTranslatorFactory^ _factory

See Also

QueryToSqlTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


QueryToSqlTranslator Methods

[image] [image]

Sitecore 6.4.1 API
QueryToSqlTranslator Methods
QueryToSqlTranslator Class See Also Send Feedback

The QueryToSqlTranslator type exposes the following members.

Methods

 | Name | Description
Protected method | AddConditionJoint | Adds the condition joint.
Protected method | AddExtraJoins | Adds the extra joins.
Protected method | AddFieldJoins | Adds the field joins.
Protected method | AddInitialStatement | Adds the initial statement.
Protected method | AddName | Adds the name to the query.
Protected method | AddNameFilter | Adds the name filter.
Protected method | AddNestedQuery | Adds the nested query.
Protected method | AddRootItemFilter | Adds the root item filter.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetName | Gets the name.
Protected method | GetPredicate | Gets the predicate.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TranslateQuery | Translates the query.

See Also

QueryToSqlTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


AddConditionJoint Method

[image]

Sitecore 6.4.1 API
QueryToSqlTranslator..::..AddConditionJoint Method
QueryToSqlTranslator Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool AddConditionJoint(
    bool whereAppended,
    StringBuilder builder
)
Visual Basic
Protected Overridable Function AddConditionJoint ( _
    whereAppended As Boolean, _
    builder As StringBuilder _
) As Boolean
Visual C++
protected:
virtual bool AddConditionJoint(
    bool whereAppended,
    StringBuilder^ builder
)

Parameters

whereAppended
Type: System..::..Boolean
if set to true this instance is where appended.
builder
Type: System.Text..::..StringBuilder
The builder.

Return Value

The condition joint.

See Also

QueryToSqlTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


AddExtraJoins Method

[image]

Sitecore 6.4.1 API
QueryToSqlTranslator..::..AddExtraJoins Method
QueryToSqlTranslator Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void AddExtraJoins(
    ITranslationContext context,
    StringBuilder builder
)
Visual Basic
Protected Overridable Sub AddExtraJoins ( _
    context As ITranslationContext, _
    builder As StringBuilder _
)
Visual C++
protected:
virtual void AddExtraJoins(
    ITranslationContext^ context,
    StringBuilder^ builder
)

Parameters

context
Type: Sitecore.Data.DataProviders.Sql.FastQuery..::..ITranslationContext
The context.
builder
Type: System.Text..::..StringBuilder
The builder.

See Also

QueryToSqlTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


AddFieldJoins Method

[image]

Sitecore 6.4.1 API
QueryToSqlTranslator..::..AddFieldJoins Method
QueryToSqlTranslator Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void AddFieldJoins(
    ITranslationContext context,
    StringBuilder builder
)
Visual Basic
Protected Overridable Sub AddFieldJoins ( _
    context As ITranslationContext, _
    builder As StringBuilder _
)
Visual C++
protected:
virtual void AddFieldJoins(
    ITranslationContext^ context,
    StringBuilder^ builder
)

Parameters

context
Type: Sitecore.Data.DataProviders.Sql.FastQuery..::..ITranslationContext
The context.
builder
Type: System.Text..::..StringBuilder
The builder.

See Also

QueryToSqlTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


AddName Method

[image]

Sitecore 6.4.1 API
QueryToSqlTranslator..::..AddName Method
QueryToSqlTranslator Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void AddName(
    StringBuilder builder,
    Object name
)
Visual Basic
Protected Sub AddName ( _
    builder As StringBuilder, _
    name As Object _
)
Visual C++
protected:
void AddName(
    StringBuilder^ builder,
    Object^ name
)

Parameters

builder
Type: System.Text..::..StringBuilder
The builder.
name
Type: System..::..Object
The name.

See Also

QueryToSqlTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


AddNameFilter Method

[image]

Sitecore 6.4.1 API
QueryToSqlTranslator..::..AddNameFilter Method
QueryToSqlTranslator Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void AddNameFilter(
    string name,
    StringBuilder builder
)
Visual Basic
Protected Overridable Sub AddNameFilter ( _
    name As String, _
    builder As StringBuilder _
)
Visual C++
protected:
virtual void AddNameFilter(
    String^ name,
    StringBuilder^ builder
)

Parameters

name
Type: System..::..String
The name.
builder
Type: System.Text..::..StringBuilder
The builder.

See Also

QueryToSqlTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


AddNestedQuery Method

[image]

Sitecore 6.4.1 API
QueryToSqlTranslator..::..AddNestedQuery Method
QueryToSqlTranslator Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void AddNestedQuery(
    Step step,
    string sql,
    StringBuilder builder
)
Visual Basic
Protected Overridable Sub AddNestedQuery ( _
    step As Step, _
    sql As String, _
    builder As StringBuilder _
)
Visual C++
protected:
virtual void AddNestedQuery(
    Step^ step,
    String^ sql,
    StringBuilder^ builder
)

Parameters

step
Type: Sitecore.Data.Query..::..Step
The step.
sql
Type: System..::..String
The SQL.
builder
Type: System.Text..::..StringBuilder
The builder.

See Also

QueryToSqlTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


AddRootItemFilter Method

[image]

Sitecore 6.4.1 API
QueryToSqlTranslator..::..AddRootItemFilter Method
QueryToSqlTranslator Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void AddRootItemFilter(
    ParametersList parameters,
    StringBuilder builder
)
Visual Basic
Protected Overridable Sub AddRootItemFilter ( _
    parameters As ParametersList, _
    builder As StringBuilder _
)
Visual C++
protected:
virtual void AddRootItemFilter(
    ParametersList^ parameters,
    StringBuilder^ builder
)

Parameters

parameters
Type: Sitecore.Data.DataProviders.Sql.FastQuery..::..ParametersList
The parameters.
builder
Type: System.Text..::..StringBuilder
The builder.

See Also

QueryToSqlTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


GetName Method

[image]

Sitecore 6.4.1 API
QueryToSqlTranslator..::..GetName Method
QueryToSqlTranslator Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected string GetName(
    Step step
)
Visual Basic
Protected Function GetName ( _
    step As Step _
) As String
Visual C++
protected:
String^ GetName(
    Step^ step
)

Parameters

step
Type: Sitecore.Data.Query..::..Step
The step.

Return Value

The name.

See Also

QueryToSqlTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


GetPredicate Method

[image]

Sitecore 6.4.1 API
QueryToSqlTranslator..::..GetPredicate Method
QueryToSqlTranslator Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Predicate GetPredicate(
    Step step
)
Visual Basic
Protected Function GetPredicate ( _
    step As Step _
) As Predicate
Visual C++
protected:
Predicate^ GetPredicate(
    Step^ step
)

Parameters

step
Type: Sitecore.Data.Query..::..Step
The step.

Return Value

The predicate.

See Also

QueryToSqlTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


TranslateQuery Method

[image]

Sitecore 6.4.1 API
QueryToSqlTranslator..::..TranslateQuery Method
QueryToSqlTranslator Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string TranslateQuery(
    string query,
    CallContext callContext,
    ParametersList parameters
)
Visual Basic
Public Overridable Function TranslateQuery ( _
    query As String, _
    callContext As CallContext, _
    parameters As ParametersList _
) As String
Visual C++
public:
virtual String^ TranslateQuery(
    String^ query,
    CallContext^ callContext,
    ParametersList^ parameters
)

Parameters

query
Type: System..::..String
The query.
callContext
Type: Sitecore.Data.DataProviders..::..CallContext
The call context.
parameters
Type: Sitecore.Data.DataProviders.Sql.FastQuery..::..ParametersList
The parameters.

Return Value

The query.

See Also

QueryToSqlTranslator Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


RelationOperatorTraits Class

[image]

Sitecore 6.4.1 API
RelationOperatorTraits Class
Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RelationOperatorTraits : IOperatorTraits
Visual Basic
Public Class RelationOperatorTraits _
    Implements IOperatorTraits
Visual C++
public ref class RelationOperatorTraits : IOperatorTraits

Inheritance Hierarchy

System..::..Object
Sitecore.Data.DataProviders.Sql.FastQuery..::..RelationOperatorTraits

See Also

RelationOperatorTraits Members
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


RelationOperatorTraits Members

[image] [image]

Sitecore 6.4.1 API
RelationOperatorTraits Members
RelationOperatorTraits Class Constructors Methods Properties See Also Send Feedback

The RelationOperatorTraits type exposes the following members.

Constructors

 | Name | Description
Public method | RelationOperatorTraits | Initializes a new instance of the RelationOperatorTraits class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOperatorString | Gets the operator string.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | NeedsSimpleValues | Gets a value indicating whether the IOperatorTraits needss the simple values.

See Also

RelationOperatorTraits Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


RelationOperatorTraits Constructor

[image]

Sitecore 6.4.1 API
RelationOperatorTraits Constructor
RelationOperatorTraits Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RelationOperatorTraits(
    string operatorString
)
Visual Basic
Public Sub New ( _
    operatorString As String _
)
Visual C++
public:
RelationOperatorTraits(
    String^ operatorString
)

Parameters

operatorString
Type: System..::..String
The operator string.

See Also

RelationOperatorTraits Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


RelationOperatorTraits Methods

[image] [image]

Sitecore 6.4.1 API
RelationOperatorTraits Methods
RelationOperatorTraits Class See Also Send Feedback

The RelationOperatorTraits type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOperatorString | Gets the operator string.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RelationOperatorTraits Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


GetOperatorString Method

[image]

Sitecore 6.4.1 API
RelationOperatorTraits..::..GetOperatorString Method
RelationOperatorTraits Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetOperatorString(
    ITranslationContext left,
    ITranslationContext right
)
Visual Basic
Public Function GetOperatorString ( _
    left As ITranslationContext, _
    right As ITranslationContext _
) As String
Visual C++
public:
virtual String^ GetOperatorString(
    ITranslationContext^ left,
    ITranslationContext^ right
) sealed

Parameters

left
Type: Sitecore.Data.DataProviders.Sql.FastQuery..::..ITranslationContext
The left.
right
Type: Sitecore.Data.DataProviders.Sql.FastQuery..::..ITranslationContext
The right.

Return Value

The operator string.

Implements

IOperatorTraits..::..GetOperatorString(ITranslationContext, ITranslationContext)

See Also

RelationOperatorTraits Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


RelationOperatorTraits Properties

[image] [image]

Sitecore 6.4.1 API
RelationOperatorTraits Properties
RelationOperatorTraits Class See Also Send Feedback

The RelationOperatorTraits type exposes the following members.

Properties

 | Name | Description
Public property | NeedsSimpleValues | Gets a value indicating whether the IOperatorTraits needss the simple values.

See Also

RelationOperatorTraits Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


NeedsSimpleValues Property

[image]

Sitecore 6.4.1 API
RelationOperatorTraits..::..NeedsSimpleValues Property
RelationOperatorTraits Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.Sql.FastQuery
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool NeedsSimpleValues { get; }
Visual Basic
Public ReadOnly Property NeedsSimpleValues As Boolean
    Get
Visual C++
public:
virtual property bool NeedsSimpleValues {
    bool get () sealed;
}

Field Value

true if the IOperatorTraits needss the simple values; otherwise, false.

Implements

IOperatorTraits..::..NeedsSimpleValues

See Also

RelationOperatorTraits Class
Sitecore.Data.DataProviders.Sql.FastQuery Namespace


Sitecore.Data.DataProviders.SqlServer Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Data.DataProviders.SqlServer Namespace
Send Feedback

Classes

 | Class | Description
Public class | SqlServerHelper | SqlServerHelper class
Public class | SqlServerNotificationProvider | The sql server notification database.
Public class | SqlServerStream | SqlServerStream class


SqlServerHelper Class

[image]

Sitecore 6.4.1 API
SqlServerHelper Class
Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class SqlServerHelper
Visual Basic
Public NotInheritable Class SqlServerHelper
Visual C++
public ref class SqlServerHelper abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Data.DataProviders.SqlServer..::..SqlServerHelper

See Also

SqlServerHelper Members
Sitecore.Data.DataProviders.SqlServer Namespace


SqlServerHelper Methods

[image] [image]

Sitecore 6.4.1 API
SqlServerHelper Methods
SqlServerHelper Class See Also Send Feedback

The SqlServerHelper type exposes the following members.

Methods

Name | Description
GetInt | Gets an Int32 value from a reader.
GetLong | Gets a Int64 value from a reader.

See Also

SqlServerHelper Class
Sitecore.Data.DataProviders.SqlServer Namespace


GetInt Method

[image]

Sitecore 6.4.1 API
SqlServerHelper..::..GetInt Method
SqlServerHelper Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int GetInt(
    SqlDataReader reader,
    int columnIndex
)
Visual Basic
Public Shared Function GetInt ( _
    reader As SqlDataReader, _
    columnIndex As Integer _
) As Integer
Visual C++
public:
static int GetInt(
    SqlDataReader^ reader,
    int columnIndex
)

Parameters

reader
Type: System.Data.SqlClient..::..SqlDataReader
The reader.
columnIndex
Type: System..::..Int32
Index of the column.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.SqlServer.SqlServerHelper.GetInt(System.Data.SqlClient.SqlDataReader,System.Int32)"]

See Also

SqlServerHelper Class
Sitecore.Data.DataProviders.SqlServer Namespace


GetLong Method

[image]

Sitecore 6.4.1 API
SqlServerHelper..::..GetLong Method
SqlServerHelper Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long GetLong(
    SqlDataReader reader,
    int columnIndex
)
Visual Basic
Public Shared Function GetLong ( _
    reader As SqlDataReader, _
    columnIndex As Integer _
) As Long
Visual C++
public:
static long long GetLong(
    SqlDataReader^ reader,
    int columnIndex
)

Parameters

reader
Type: System.Data.SqlClient..::..SqlDataReader
The reader.
columnIndex
Type: System..::..Int32
Index of the column.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.DataProviders.SqlServer.SqlServerHelper.GetLong(System.Data.SqlClient.SqlDataReader,System.Int32)"]

See Also

SqlServerHelper Class
Sitecore.Data.DataProviders.SqlServer Namespace


SqlServerNotificationProvider Class

[image]

Sitecore 6.4.1 API
SqlServerNotificationProvider Class
Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SqlServerNotificationProvider : NotificationProvider
Visual Basic
Public Class SqlServerNotificationProvider _
    Inherits NotificationProvider
Visual C++
public ref class SqlServerNotificationProvider : public NotificationProvider

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Clones..::..NotificationProvider
Sitecore.Data.DataProviders.SqlServer..::..SqlServerNotificationProvider

See Also

SqlServerNotificationProvider Members
Sitecore.Data.DataProviders.SqlServer Namespace


SqlServerNotificationProvider Members

[image] [image]

Sitecore 6.4.1 API
SqlServerNotificationProvider Members
SqlServerNotificationProvider Class Constructors Methods Properties See Also Send Feedback

The SqlServerNotificationProvider type exposes the following members.

Constructors

 | Name | Description
Public method | SqlServerNotificationProvider(String, String) | Initializes a new instance of the SqlServerNotificationProvider class.
Protected method | SqlServerNotificationProvider(SqlDataApi, String) | Initializes a new instance of the SqlServerNotificationProvider class.

Methods

 | Name | Description
Public method | AddNotification | The add notification. (Overrides NotificationProvider..::..AddNotification(Notification).)
Public method | Cleanup | Removes obsolete notifications. (Overrides NotificationProvider..::..Cleanup()()()().)
Protected method | CreateNotification | The create the notification from table row.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNotification | The get notification. (Overrides NotificationProvider..::..GetNotification(ID).)
Public method | GetNotifications()()()() | Gets all notifications. (Overrides NotificationProvider..::..GetNotifications()()()().)
Public method | GetNotifications(Item) | The get notifications. (Overrides NotificationProvider..::..GetNotifications(Item).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasNotificationOwner | Determines whether the notification has an owner item. (Inherited from NotificationProvider.)
Protected method | IsOrphanChildNotification | Checks whether the specified notification is referred to missed item. (Inherited from NotificationProvider.)
Protected method | IsOrphanVersionNotification | Checks whether the notification is a notification for removed version. (Inherited from NotificationProvider.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessNotification | Precesses the specified notification and removes it if it is orphan. (Inherited from NotificationProvider.)
Public method | RemoveNotification | The remove notification. (Overrides NotificationProvider..::..RemoveNotification(ID).)
Public method | RemoveNotifications | Removes the notifications for the specified item. (Inherited from NotificationProvider.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Protected property | DataApi | Gets the data API.
Protected property | DatabaseName | Gets the name of the database the provider refers to.
Protected property | Serializer | Gets or sets the serializer.

See Also

SqlServerNotificationProvider Class
Sitecore.Data.DataProviders.SqlServer Namespace


SqlServerNotificationProvider Constructor

[image] [image]

Sitecore 6.4.1 API
SqlServerNotificationProvider Constructor
SqlServerNotificationProvider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SqlServerNotificationProvider(String, String) | Initializes a new instance of the SqlServerNotificationProvider class.
Protected method | SqlServerNotificationProvider(SqlDataApi, String) | Initializes a new instance of the SqlServerNotificationProvider class.

See Also

SqlServerNotificationProvider Class
SqlServerNotificationProvider Members
Sitecore.Data.DataProviders.SqlServer Namespace


SqlServerNotificationProvider Constructor (String, String)

[image]

Sitecore 6.4.1 API
SqlServerNotificationProvider Constructor (String, String)
SqlServerNotificationProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlServerNotificationProvider(
    string connectionStringName,
    string databaseName
)
Visual Basic
Public Sub New ( _
    connectionStringName As String, _
    databaseName As String _
)
Visual C++
public:
SqlServerNotificationProvider(
    String^ connectionStringName,
    String^ databaseName
)

Parameters

connectionStringName
Type: System..::..String
The connection string name.
databaseName
Type: System..::..String
Name of the database.

See Also

SqlServerNotificationProvider Class
SqlServerNotificationProvider Overload
Sitecore.Data.DataProviders.SqlServer Namespace


SqlServerNotificationProvider Constructor (SqlDataApi, String)

[image]

Sitecore 6.4.1 API
SqlServerNotificationProvider Constructor (SqlDataApi, String)
SqlServerNotificationProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected SqlServerNotificationProvider(
    SqlDataApi api,
    string databaseName
)
Visual Basic
Protected Sub New ( _
    api As SqlDataApi, _
    databaseName As String _
)
Visual C++
protected:
SqlServerNotificationProvider(
    SqlDataApi^ api,
    String^ databaseName
)

Parameters

api
Type: Sitecore.Data.DataProviders.Sql..::..SqlDataApi
The Data API.
databaseName
Type: System..::..String
Name of the database.

See Also

SqlServerNotificationProvider Class
SqlServerNotificationProvider Overload
Sitecore.Data.DataProviders.SqlServer Namespace


SqlServerNotificationProvider Methods

[image] [image]

Sitecore 6.4.1 API
SqlServerNotificationProvider Methods
SqlServerNotificationProvider Class See Also Send Feedback

The SqlServerNotificationProvider type exposes the following members.

Methods

 | Name | Description
Public method | AddNotification | The add notification. (Overrides NotificationProvider..::..AddNotification(Notification).)
Public method | Cleanup | Removes obsolete notifications. (Overrides NotificationProvider..::..Cleanup()()()().)
Protected method | CreateNotification | The create the notification from table row.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNotification | The get notification. (Overrides NotificationProvider..::..GetNotification(ID).)
Public method | GetNotifications()()()() | Gets all notifications. (Overrides NotificationProvider..::..GetNotifications()()()().)
Public method | GetNotifications(Item) | The get notifications. (Overrides NotificationProvider..::..GetNotifications(Item).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasNotificationOwner | Determines whether the notification has an owner item. (Inherited from NotificationProvider.)
Protected method | IsOrphanChildNotification | Checks whether the specified notification is referred to missed item. (Inherited from NotificationProvider.)
Protected method | IsOrphanVersionNotification | Checks whether the notification is a notification for removed version. (Inherited from NotificationProvider.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessNotification | Precesses the specified notification and removes it if it is orphan. (Inherited from NotificationProvider.)
Public method | RemoveNotification | The remove notification. (Overrides NotificationProvider..::..RemoveNotification(ID).)
Public method | RemoveNotifications | Removes the notifications for the specified item. (Inherited from NotificationProvider.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SqlServerNotificationProvider Class
Sitecore.Data.DataProviders.SqlServer Namespace


AddNotification Method

[image]

Sitecore 6.4.1 API
SqlServerNotificationProvider..::..AddNotification Method
SqlServerNotificationProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void AddNotification(
    Notification notification
)
Visual Basic
Public Overrides Sub AddNotification ( _
    notification As Notification _
)
Visual C++
public:
virtual void AddNotification(
    Notification^ notification
) override

Parameters

notification
Type: Sitecore.Data.Clones..::..Notification
The notification.

Exceptions

Exception | Condition
System..::..NotImplementedException |

See Also

SqlServerNotificationProvider Class
Sitecore.Data.DataProviders.SqlServer Namespace


Cleanup Method

[image]

Sitecore 6.4.1 API
SqlServerNotificationProvider..::..Cleanup Method
SqlServerNotificationProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Cleanup()
Visual Basic
Public Overrides Sub Cleanup
Visual C++
public:
virtual void Cleanup() override

See Also

SqlServerNotificationProvider Class
Sitecore.Data.DataProviders.SqlServer Namespace


CreateNotification Method

[image]

Sitecore 6.4.1 API
SqlServerNotificationProvider..::..CreateNotification Method
SqlServerNotificationProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Notification CreateNotification(
    DataProviderReader reader
)
Visual Basic
Protected Function CreateNotification ( _
    reader As DataProviderReader _
) As Notification
Visual C++
protected:
Notification^ CreateNotification(
    DataProviderReader^ reader
)

Parameters

reader
Type: Sitecore.Data.DataProviders.Sql..::..DataProviderReader
The data reader.

Return Value

The saved Notification object.

See Also

SqlServerNotificationProvider Class
Sitecore.Data.DataProviders.SqlServer Namespace


GetNotification Method

[image]

Sitecore 6.4.1 API
SqlServerNotificationProvider..::..GetNotification Method
SqlServerNotificationProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Notification GetNotification(
    ID id
)
Visual Basic
Public Overrides Function GetNotification ( _
    id As ID _
) As Notification
Visual C++
public:
virtual Notification^ GetNotification(
    ID^ id
) override

Parameters

id
Type: Sitecore.Data..::..ID
The notification id.

Return Value

The Notification object by Id.

See Also

SqlServerNotificationProvider Class
Sitecore.Data.DataProviders.SqlServer Namespace


GetNotifications Method

[image] [image]

Sitecore 6.4.1 API
SqlServerNotificationProvider..::..GetNotifications Method
SqlServerNotificationProvider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetNotifications()()()() | Gets all notifications. (Overrides NotificationProvider..::..GetNotifications()()()().)
Public method | GetNotifications(Item) | The get notifications. (Overrides NotificationProvider..::..GetNotifications(Item).)

See Also

SqlServerNotificationProvider Class
SqlServerNotificationProvider Members
Sitecore.Data.DataProviders.SqlServer Namespace


GetNotifications Method

[image]

Sitecore 6.4.1 API
SqlServerNotificationProvider..::..GetNotifications Method
SqlServerNotificationProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override IEnumerable<Notification> GetNotifications()
Visual Basic
Public Overrides Function GetNotifications As IEnumerable(Of Notification)
Visual C++
public:
virtual IEnumerable<Notification^>^ GetNotifications() override

Return Value

The list of all registered Notifications.

See Also

SqlServerNotificationProvider Class
GetNotifications Overload
Sitecore.Data.DataProviders.SqlServer Namespace


GetNotifications Method (Item)

[image]

Sitecore 6.4.1 API
SqlServerNotificationProvider..::..GetNotifications Method (Item)
SqlServerNotificationProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override IEnumerable<Notification> GetNotifications(
    Item clone
)
Visual Basic
Public Overrides Function GetNotifications ( _
    clone As Item _
) As IEnumerable(Of Notification)
Visual C++
public:
virtual IEnumerable<Notification^>^ GetNotifications(
    Item^ clone
) override

Parameters

clone
Type: Sitecore.Data.Items..::..Item
The Stecore item.

Return Value

The notifications for the specified item.

See Also

SqlServerNotificationProvider Class
GetNotifications Overload
Sitecore.Data.DataProviders.SqlServer Namespace


RemoveNotification Method

[image]

Sitecore 6.4.1 API
SqlServerNotificationProvider..::..RemoveNotification Method
SqlServerNotificationProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool RemoveNotification(
    ID id
)
Visual Basic
Public Overrides Function RemoveNotification ( _
    id As ID _
) As Boolean
Visual C++
public:
virtual bool RemoveNotification(
    ID^ id
) override

Parameters

id
Type: Sitecore.Data..::..ID
The notification id.

Return Value

true if notification with specified id has been removed.

See Also

SqlServerNotificationProvider Class
Sitecore.Data.DataProviders.SqlServer Namespace


SqlServerNotificationProvider Properties

[image] [image]

Sitecore 6.4.1 API
SqlServerNotificationProvider Properties
SqlServerNotificationProvider Class See Also Send Feedback

The SqlServerNotificationProvider type exposes the following members.

Properties

 | Name | Description
Protected property | DataApi | Gets the data API.
Protected property | DatabaseName | Gets the name of the database the provider refers to.
Protected property | Serializer | Gets or sets the serializer.

See Also

SqlServerNotificationProvider Class
Sitecore.Data.DataProviders.SqlServer Namespace


DataApi Property

[image]

Sitecore 6.4.1 API
SqlServerNotificationProvider..::..DataApi Property
SqlServerNotificationProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected SqlDataApi DataApi { get; }
Visual Basic
Protected ReadOnly Property DataApi As SqlDataApi
    Get
Visual C++
protected:
property SqlDataApi^ DataApi {
    SqlDataApi^ get ();
}

Field Value

The data API.

See Also

SqlServerNotificationProvider Class
Sitecore.Data.DataProviders.SqlServer Namespace


DatabaseName Property

[image]

Sitecore 6.4.1 API
SqlServerNotificationProvider..::..DatabaseName Property
SqlServerNotificationProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected string DatabaseName { get; }
Visual Basic
Protected ReadOnly Property DatabaseName As String
    Get
Visual C++
protected:
property String^ DatabaseName {
    String^ get ();
}

Field Value

The name of the database.

See Also

SqlServerNotificationProvider Class
Sitecore.Data.DataProviders.SqlServer Namespace


Serializer Property

[image]

Sitecore 6.4.1 API
SqlServerNotificationProvider..::..Serializer Property
SqlServerNotificationProvider Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Serializer Serializer { get; set; }
Visual Basic
Protected Property Serializer As Serializer
    Get
    Set
Visual C++
protected:
property Serializer^ Serializer {
    Serializer^ get ();
    void set (Serializer^ value);
}

Field Value

The serializer.

See Also

SqlServerNotificationProvider Class
Sitecore.Data.DataProviders.SqlServer Namespace


SqlServerStream Class

[image]

Sitecore 6.4.1 API
SqlServerStream Class
Members See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SqlServerStream : Stream
Visual Basic
Public Class SqlServerStream _
    Inherits Stream
Visual C++
public ref class SqlServerStream : public Stream

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.IO..::..Stream
Sitecore.Data.DataProviders.SqlServer..::..SqlServerStream

See Also

SqlServerStream Members
Sitecore.Data.DataProviders.SqlServer Namespace


SqlServerStream Members

[image] [image]

Sitecore 6.4.1 API
SqlServerStream Members
SqlServerStream Class Constructors Methods Properties See Also Send Feedback

The SqlServerStream type exposes the following members.

Constructors

 | Name | Description
Public method | SqlServerStream | Initializes a new instance of the SqlServerStream class.

Methods

 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Inherited from Stream.)
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. (Overrides Stream..::..Close()()()().)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose()()()() | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources. (Inherited from Stream.)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Overrides Stream..::..Flush()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Read | When overridden in a derived class, reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Overrides Stream..::..Read(array<Byte>[]()[][], Int32, Int32).)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Public method | Seek | When overridden in a derived class, sets the position within the current stream. (Overrides Stream..::..Seek(Int64, SeekOrigin).)
Public method | SetLength | When overridden in a derived class, sets the length of the current stream. (Overrides Stream..::..SetLength(Int64).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Write | When overridden in a derived class, writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Overrides Stream..::..Write(array<Byte>[]()[][], Int32, Int32).)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)

Properties

 | Name | Description
Public property | CanRead | When overridden in a derived class, gets a value indicating whether the current stream supports reading. (Overrides Stream..::..CanRead.)
Public property | CanSeek | When overridden in a derived class, gets a value indicating whether the current stream supports seeking. (Overrides Stream..::..CanSeek.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | When overridden in a derived class, gets a value indicating whether the current stream supports writing. (Overrides Stream..::..CanWrite.)
Public property | Length | When overridden in a derived class, gets the length in bytes of the stream. (Overrides Stream..::..Length.)
Public property | Position | When overridden in a derived class, gets or sets the position within the current stream. (Overrides Stream..::..Position.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)

See Also

SqlServerStream Class
Sitecore.Data.DataProviders.SqlServer Namespace


SqlServerStream Constructor

[image]

Sitecore 6.4.1 API
SqlServerStream Constructor
SqlServerStream Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlServerStream(
    SqlDataReader reader,
    long length
)
Visual Basic
Public Sub New ( _
    reader As SqlDataReader, _
    length As Long _
)
Visual C++
public:
SqlServerStream(
    SqlDataReader^ reader,
    long long length
)

Parameters

reader
Type: System.Data.SqlClient..::..SqlDataReader
The reader.
length
Type: System..::..Int64
The length of the data in the stream.

See Also

SqlServerStream Class
Sitecore.Data.DataProviders.SqlServer Namespace


SqlServerStream Methods

[image] [image]

Sitecore 6.4.1 API
SqlServerStream Methods
SqlServerStream Class See Also Send Feedback

The SqlServerStream type exposes the following members.

Methods

 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Inherited from Stream.)
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. (Overrides Stream..::..Close()()()().)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose()()()() | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources. (Inherited from Stream.)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Overrides Stream..::..Flush()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Read | When overridden in a derived class, reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Overrides Stream..::..Read(array<Byte>[]()[][], Int32, Int32).)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Public method | Seek | When overridden in a derived class, sets the position within the current stream. (Overrides Stream..::..Seek(Int64, SeekOrigin).)
Public method | SetLength | When overridden in a derived class, sets the length of the current stream. (Overrides Stream..::..SetLength(Int64).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Write | When overridden in a derived class, writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Overrides Stream..::..Write(array<Byte>[]()[][], Int32, Int32).)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)

See Also

SqlServerStream Class
Sitecore.Data.DataProviders.SqlServer Namespace


Close Method

[image]

Sitecore 6.4.1 API
SqlServerStream..::..Close Method
SqlServerStream Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Close()
Visual Basic
Public Overrides Sub Close
Visual C++
public:
virtual void Close() override

See Also

SqlServerStream Class
Sitecore.Data.DataProviders.SqlServer Namespace


Dispose Method

[image] [image]

Sitecore 6.4.1 API
SqlServerStream..::..Dispose Method
SqlServerStream Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources. (Inherited from Stream.)

See Also

SqlServerStream Class
SqlServerStream Members
Sitecore.Data.DataProviders.SqlServer Namespace


MemberwiseClone Method

[image] [image]

Sitecore 6.4.1 API
SqlServerStream..::..MemberwiseClone Method
SqlServerStream Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

SqlServerStream Class
SqlServerStream Members
Sitecore.Data.DataProviders.SqlServer Namespace


Read Method

[image]

Sitecore 6.4.1 API
SqlServerStream..::..Read Method
SqlServerStream Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
Visual Basic
Public Overrides Function Read ( _
    buffer As Byte(), _
    offset As Integer, _
    count As Integer _
) As Integer
Visual C++
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override

Parameters

buffer
Type: array< System..::..Byte >[]()[][]
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the bytes read from the current source.
offset
Type: System..::..Int32
The zero-based byte offset in buffer at which to begin storing the data read from the current stream.
count
Type: System..::..Int32
The maximum number of bytes to be read from the current stream.

Return Value

The total number of bytes read into the buffer. This can be less than the number of bytes requested if that many bytes are not currently available, or zero (0) if the end of the stream has been reached.

Exceptions

Exception | Condition
System..::..ArgumentException | The sum of offset and count is larger than the buffer length.
System..::..ArgumentNullException | buffer is null.
System..::..ArgumentOutOfRangeException | offset or count is negative.
System.IO..::..IOException | An I/O error occurs.
System..::..NotSupportedException | The stream does not support reading.
System..::..ObjectDisposedException | Methods were called after the stream was closed.

See Also

SqlServerStream Class
Sitecore.Data.DataProviders.SqlServer Namespace


Seek Method

[image]

Sitecore 6.4.1 API
SqlServerStream..::..Seek Method
SqlServerStream Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override long Seek(
    long offset,
    SeekOrigin origin
)
Visual Basic
Public Overrides Function Seek ( _
    offset As Long, _
    origin As SeekOrigin _
) As Long
Visual C++
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override

Parameters

offset
Type: System..::..Int64
A byte offset relative to the origin parameter.
origin
Type: System.IO..::..SeekOrigin
A value of type SeekOrigin indicating the reference point used to obtain the new position.

Return Value

The new position within the current stream.

Exceptions

Exception | Condition
System.IO..::..IOException | An I/O error occurs.
System..::..NotSupportedException | The stream does not support seeking, such as if the stream is constructed from a pipe or console output.
System..::..ObjectDisposedException | Methods were called after the stream was closed.

See Also

SqlServerStream Class
Sitecore.Data.DataProviders.SqlServer Namespace


SetLength Method

[image]

Sitecore 6.4.1 API
SqlServerStream..::..SetLength Method
SqlServerStream Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void SetLength(
    long value
)
Visual Basic
Public Overrides Sub SetLength ( _
    value As Long _
)
Visual C++
public:
virtual void SetLength(
    long long value
) override

Parameters

value
Type: System..::..Int64
The desired length of the current stream in bytes.

Exceptions

Exception | Condition
System.IO..::..IOException | An I/O error occurs.
System..::..NotSupportedException | The stream does not support both writing and seeking, such as if the stream is constructed from a pipe or console output.
System..::..ObjectDisposedException | Methods were called after the stream was closed.

See Also

SqlServerStream Class
Sitecore.Data.DataProviders.SqlServer Namespace


Write Method

[image]

Sitecore 6.4.1 API
SqlServerStream..::..Write Method
SqlServerStream Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
Visual Basic
Public Overrides Sub Write ( _
    buffer As Byte(), _
    offset As Integer, _
    count As Integer _
)
Visual C++
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override

Parameters

buffer
Type: array< System..::..Byte >[]()[][]
An array of bytes. This method copies count bytes from buffer to the current stream.
offset
Type: System..::..Int32
The zero-based byte offset in buffer at which to begin copying bytes to the current stream.
count
Type: System..::..Int32
The number of bytes to be written to the current stream.

Exceptions

Exception | Condition
System..::..ArgumentException | The sum of offset and count is greater than the buffer length.
System..::..ArgumentNullException | buffer is null.
System..::..ArgumentOutOfRangeException | offset or count is negative.
System.IO..::..IOException | An I/O error occurs.
System..::..NotSupportedException | The stream does not support writing.
System..::..ObjectDisposedException | Methods were called after the stream was closed.

See Also

SqlServerStream Class
Sitecore.Data.DataProviders.SqlServer Namespace


SqlServerStream Properties

[image] [image]

Sitecore 6.4.1 API
SqlServerStream Properties
SqlServerStream Class See Also Send Feedback

The SqlServerStream type exposes the following members.

Properties

 | Name | Description
Public property | CanRead | When overridden in a derived class, gets a value indicating whether the current stream supports reading. (Overrides Stream..::..CanRead.)
Public property | CanSeek | When overridden in a derived class, gets a value indicating whether the current stream supports seeking. (Overrides Stream..::..CanSeek.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | When overridden in a derived class, gets a value indicating whether the current stream supports writing. (Overrides Stream..::..CanWrite.)
Public property | Length | When overridden in a derived class, gets the length in bytes of the stream. (Overrides Stream..::..Length.)
Public property | Position | When overridden in a derived class, gets or sets the position within the current stream. (Overrides Stream..::..Position.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)

See Also

SqlServerStream Class
Sitecore.Data.DataProviders.SqlServer Namespace


CanRead Property

[image]

Sitecore 6.4.1 API
SqlServerStream..::..CanRead Property
SqlServerStream Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool CanRead { get; }
Visual Basic
Public Overrides ReadOnly Property CanRead As Boolean
    Get
Visual C++
public:
virtual property bool CanRead {
    bool get () override;
}

Return Value

true if the stream supports reading; otherwise, false.

See Also

SqlServerStream Class
Sitecore.Data.DataProviders.SqlServer Namespace


CanSeek Property

[image]

Sitecore 6.4.1 API
SqlServerStream..::..CanSeek Property
SqlServerStream Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool CanSeek { get; }
Visual Basic
Public Overrides ReadOnly Property CanSeek As Boolean
    Get
Visual C++
public:
virtual property bool CanSeek {
    bool get () override;
}

Return Value

true if the stream supports seeking; otherwise, false.

See Also

SqlServerStream Class
Sitecore.Data.DataProviders.SqlServer Namespace


CanWrite Property

[image]

Sitecore 6.4.1 API
SqlServerStream..::..CanWrite Property
SqlServerStream Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool CanWrite { get; }
Visual Basic
Public Overrides ReadOnly Property CanWrite As Boolean
    Get
Visual C++
public:
virtual property bool CanWrite {
    bool get () override;
}

Return Value

true if the stream supports writing; otherwise, false.

See Also

SqlServerStream Class
Sitecore.Data.DataProviders.SqlServer Namespace


Length Property

[image]

Sitecore 6.4.1 API
SqlServerStream..::..Length Property
SqlServerStream Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override long Length { get; }
Visual Basic
Public Overrides ReadOnly Property Length As Long
    Get
Visual C++
public:
virtual property long long Length {
    long long get () override;
}

Return Value

A long value representing the length of the stream in bytes.

Exceptions

Exception | Condition
System..::..NotSupportedException | A class derived from Stream does not support seeking.
System..::..ObjectDisposedException | Methods were called after the stream was closed.

See Also

SqlServerStream Class
Sitecore.Data.DataProviders.SqlServer Namespace


Position Property

[image]

Sitecore 6.4.1 API
SqlServerStream..::..Position Property
SqlServerStream Class See Also Send Feedback

Namespace: Sitecore.Data.DataProviders.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override long Position { get; set; }
Visual Basic
Public Overrides Property Position As Long
    Get
    Set
Visual C++
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}

Return Value

The current position within the stream.

Exceptions

Exception | Condition
System.IO..::..IOException | An I/O error occurs.
System..::..NotSupportedException | The stream does not support seeking.
System..::..ObjectDisposedException | Methods were called after the stream was closed.

See Also

SqlServerStream Class
Sitecore.Data.DataProviders.SqlServer Namespace


Sitecore.Data.Engines Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Data.Engines Namespace
Send Feedback

Classes

 | Class | Description
Public class | DataEngine | The engine dealing with data retrieval and update.
Public class | DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> | Base class for engine commands
Public class | EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> | Base class for engine commands
Public class | HistoryAddedEventArgs | HistoryAddedEventArgs
Public class | HistoryEngine | The engine dealing with data history.
Public class | HistoryEntry | Defines an entry in the history.
Public class | HistoryEntry..::..Builder | Builder used for generating HistoryEntrys.
Public class | HistoryStorage | The abstract base class for data history storage providers.
Public class | SyncOperationContext | Notifies database engines to make all operations synchronously.
Public class | TemplateEngine | The template engine.
Public class | WorkflowEngine | The engine dealing with workflows

Enumerations

 | Enumeration | Description
Public enumeration | DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..EngineLockingType | EngineLockingType class
Public enumeration | HistoryAction |
Public enumeration | HistoryCategory |


DataEngine Class

[image]

Sitecore 6.4.1 API
DataEngine Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DataEngine
Visual Basic
Public Class DataEngine
Visual C++
public ref class DataEngine

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Engines..::..DataEngine

See Also

DataEngine Members
Sitecore.Data.Engines Namespace


DataEngine Members

[image] [image]

Sitecore 6.4.1 API
DataEngine Members
DataEngine Class Constructors Methods Fields Properties Events See Also Send Feedback

The DataEngine type exposes the following members.

Constructors

 | Name | Description
Public method | DataEngine | Initializes a new instance of the DataEngine class.

Methods

 | Name | Description
Public method | AddFromTemplate | Adds a new item from a template.
Public method | AddVersion | Adds a new version to an item by copying the data from an existing version.
Public method | BlobStreamExists | Determines whether the specified field contains a BLOB value.
Public method | CopyItem | Copies a specified item.
Public method | CreateItem | Creates an empty item.
Public method | DeleteItem | Deletes an item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBlobStream | Gets the BLOB stream associated with a field.
Public method | GetChildren | Gets the children of an item.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItem | Gets an item.
Public method | GetParent | Gets the parent of an item.
Public method | GetRootItem | Gets the root item.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersions | Gets the version numbers of an item.
Public method | HasChildren | Determines whether the specified item has children.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveItem | Moves an item.
Public method | RaiseAddedFromTemplate | Raises the 'added from template' event.
Public method | RaiseAddedFromTemplateRemote | Raises the added from template.
Public method | RaiseAddedVersion | Raises the 'added version' event.
Public method | RaiseAddedVersionRemote | Raises the 'added version remote' event.
Public method | RaiseCopiedItem | Raises the 'copied item' event.
Public method | RaiseCopiedItemRemote | Raises the copied item remote.
Public method | RaiseCopyProcessedSingleItem | Raises the copy processed single item.
Public method | RaiseCreatedItem | Raises the created item event.
Public method | RaiseCreatedItemRemote | Raises the created item remote.
Public method | RaiseDeletedItem | Raises the deleted event.
Public method | RaiseDeletedItemRemote | Raises the deleted item remote.
Public method | RaiseDeleteProcessedSingleItem | Raises the 'delete processed single item' event.
Public method | RaiseDeletingItem | Raises the deleting event.
Public method | RaiseMovedItem | Raises the 'moved item' event.
Public method | RaiseMovedItemRemote | Raises the moved item remote.
Public method | RaiseRemovedDataRemote | Raises the removed data remote.
Public method | RaiseRemovedVersion | Raises the 'removed version' event.
Public method | RaiseRemovedVersionRemote | Raises the removed version removed.
Public method | RaiseSavedItem | Raises the 'saved item' event.
Public method | RaiseSavedItemRemote | Raises the 'saved item remote' event.
Public method | RemoveData | Removes all data in a specific language from an item.
Public method | RemoveVersion | Removes a version from an item.
Public method | ResolvePath | Resolves an item path to an id.
Public method | SaveItem | Saves changes to an item.
Public method | SetBlobStream | Sets the BLOB stream associated with a field.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | ItemAccessLock | Item access lock.

Properties

 | Name | Description
Public property | Commands | Gets the command collection.
Public property | Database | Gets the database associated with the engine.

Events

 | Name | Description
Public event | AddedFromTemplate | Item added from template event.
Public event | AddedFromTemplateRemote | Item added from template remote event.
Public event | AddedVersion | Item added version event.
Public event | AddedVersionRemote | Item added version remote event.
Public event | AddingFromTemplate | Item adding from template event.
Public event | AddingVersion | Item adding version event.
Public event | CopiedItem | Item copied event.
Public event | CopiedItemRemote | Item copied remote event.
Public event | CopyingItem | Item copying event.
Public event | CopyProcessedSingleItem | Occurs for each item that 'copy item' operation processes.
Public event | CreatedItem | Item created event.
Public event | CreatedItemRemote | Item created remote event.
Public event | CreatingItem | Item creating event.
Public event | DeletedItem | Item deleted event.
Public event | DeletedItemRemote | Item deleted remote event.
Public event | DeleteProcessedSingleItem | Occurs for each item that the 'delete item' operation processes.
Public event | DeletingItem | Item deleting event.
Public event | MovedItem | Item moved event.
Public event | MovedItemRemote | Item moved remote event.
Public event | MovingItem | Item moving event.
Public event | RemovedData | Item removed data event.
Public event | RemovedDataRemote | Item removed data remote event.
Public event | RemovedVersion | Item removed version event.
Public event | RemovedVersionRemote | Item removed version remote event.
Public event | RemovingData | Item removing data event.
Public event | RemovingVersion | Item removing version event.
Public event | SavedItem | Item saved event.
Public event | SavedItemRemote | Item saved remote event.
Public event | SavingItem | Item saving event.

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


DataEngine Constructor

[image]

Sitecore 6.4.1 API
DataEngine Constructor
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataEngine(
    Database database
)
Visual Basic
Public Sub New ( _
    database As Database _
)
Visual C++
public:
DataEngine(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


ItemAccessLock Field

[image]

Sitecore 6.4.1 API
DataEngine..::..ItemAccessLock Field
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public readonly ReaderWriterLock ItemAccessLock
Visual Basic
Public ReadOnly ItemAccessLock As ReaderWriterLock
Visual C++
public:
initonly ReaderWriterLock^ ItemAccessLock

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


DataEngine Methods

[image] [image]

Sitecore 6.4.1 API
DataEngine Methods
DataEngine Class See Also Send Feedback

The DataEngine type exposes the following members.

Methods

 | Name | Description
Public method | AddFromTemplate | Adds a new item from a template.
Public method | AddVersion | Adds a new version to an item by copying the data from an existing version.
Public method | BlobStreamExists | Determines whether the specified field contains a BLOB value.
Public method | CopyItem | Copies a specified item.
Public method | CreateItem | Creates an empty item.
Public method | DeleteItem | Deletes an item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBlobStream | Gets the BLOB stream associated with a field.
Public method | GetChildren | Gets the children of an item.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItem | Gets an item.
Public method | GetParent | Gets the parent of an item.
Public method | GetRootItem | Gets the root item.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersions | Gets the version numbers of an item.
Public method | HasChildren | Determines whether the specified item has children.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveItem | Moves an item.
Public method | RaiseAddedFromTemplate | Raises the 'added from template' event.
Public method | RaiseAddedFromTemplateRemote | Raises the added from template.
Public method | RaiseAddedVersion | Raises the 'added version' event.
Public method | RaiseAddedVersionRemote | Raises the 'added version remote' event.
Public method | RaiseCopiedItem | Raises the 'copied item' event.
Public method | RaiseCopiedItemRemote | Raises the copied item remote.
Public method | RaiseCopyProcessedSingleItem | Raises the copy processed single item.
Public method | RaiseCreatedItem | Raises the created item event.
Public method | RaiseCreatedItemRemote | Raises the created item remote.
Public method | RaiseDeletedItem | Raises the deleted event.
Public method | RaiseDeletedItemRemote | Raises the deleted item remote.
Public method | RaiseDeleteProcessedSingleItem | Raises the 'delete processed single item' event.
Public method | RaiseDeletingItem | Raises the deleting event.
Public method | RaiseMovedItem | Raises the 'moved item' event.
Public method | RaiseMovedItemRemote | Raises the moved item remote.
Public method | RaiseRemovedDataRemote | Raises the removed data remote.
Public method | RaiseRemovedVersion | Raises the 'removed version' event.
Public method | RaiseRemovedVersionRemote | Raises the removed version removed.
Public method | RaiseSavedItem | Raises the 'saved item' event.
Public method | RaiseSavedItemRemote | Raises the 'saved item remote' event.
Public method | RemoveData | Removes all data in a specific language from an item.
Public method | RemoveVersion | Removes a version from an item.
Public method | ResolvePath | Resolves an item path to an id.
Public method | SaveItem | Saves changes to an item.
Public method | SetBlobStream | Sets the BLOB stream associated with a field.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


AddFromTemplate Method

[image]

Sitecore 6.4.1 API
DataEngine..::..AddFromTemplate Method
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item AddFromTemplate(
    string itemName,
    ID templateId,
    Item destination,
    ID newId
)
Visual Basic
Public Function AddFromTemplate ( _
    itemName As String, _
    templateId As ID, _
    destination As Item, _
    newId As ID _
) As Item
Visual C++
public:
Item^ AddFromTemplate(
    String^ itemName,
    ID^ templateId,
    Item^ destination,
    ID^ newId
)

Parameters

itemName
Type: System..::..String
Name of the item.
templateId
Type: Sitecore.Data..::..ID
The template id.
destination
Type: Sitecore.Data.Items..::..Item
The target item. This will be the parent of the new item.
newId
Type: Sitecore.Data..::..ID
The id of the new item.

Return Value

The newly created item. If the item could not be created, null is returned.

Note that the item is returned in the same language as the destination item.

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


AddVersion Method

[image]

Sitecore 6.4.1 API
DataEngine..::..AddVersion Method
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item AddVersion(
    Item item
)
Visual Basic
Public Function AddVersion ( _
    item As Item _
) As Item
Visual C++
public:
Item^ AddVersion(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item that will have a version added.

Return Value

The added version of the item. If a version could not be added to the item, null is returned.

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


BlobStreamExists Method

[image]

Sitecore 6.4.1 API
DataEngine..::..BlobStreamExists Method
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool BlobStreamExists(
    Guid blobId
)
Visual Basic
Public Function BlobStreamExists ( _
    blobId As Guid _
) As Boolean
Visual C++
public:
bool BlobStreamExists(
    Guid blobId
)

Parameters

blobId
Type: System..::..Guid
The BLOB id.

Return Value

The value.

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


CopyItem Method

[image]

Sitecore 6.4.1 API
DataEngine..::..CopyItem Method
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item CopyItem(
    Item source,
    Item destination,
    bool deep,
    string copyName,
    ID copyId
)
Visual Basic
Public Function CopyItem ( _
    source As Item, _
    destination As Item, _
    deep As Boolean, _
    copyName As String, _
    copyId As ID _
) As Item
Visual C++
public:
Item^ CopyItem(
    Item^ source,
    Item^ destination,
    bool deep,
    String^ copyName,
    ID^ copyId
)

Parameters

source
Type: Sitecore.Data.Items..::..Item
The item to copy.
destination
Type: Sitecore.Data.Items..::..Item
The destination.
deep
Type: System..::..Boolean
If set to true, child items will be copied recursively.
copyName
Type: System..::..String
Name of the copy.
copyId
Type: Sitecore.Data..::..ID
Id of the copy.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Engines.DataEngine.CopyItem(Sitecore.Data.Items.Item,Sitecore.Data.Items.Item,System.Boolean,System.String,Sitecore.Data.ID)"]

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


CreateItem Method

[image]

Sitecore 6.4.1 API
DataEngine..::..CreateItem Method
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item CreateItem(
    string itemName,
    Item destination,
    ID templateId,
    ID newId
)
Visual Basic
Public Function CreateItem ( _
    itemName As String, _
    destination As Item, _
    templateId As ID, _
    newId As ID _
) As Item
Visual C++
public:
Item^ CreateItem(
    String^ itemName,
    Item^ destination,
    ID^ templateId,
    ID^ newId
)

Parameters

itemName
Type: System..::..String
Name of the item.
destination
Type: Sitecore.Data.Items..::..Item
The destination.
templateId
Type: Sitecore.Data..::..ID
The template ID.
newId
Type: Sitecore.Data..::..ID
The item id.

Return Value

The created item. If the item could not be created, null is returned.

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


DeleteItem Method

[image]

Sitecore 6.4.1 API
DataEngine..::..DeleteItem Method
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool DeleteItem(
    Item item
)
Visual Basic
Public Function DeleteItem ( _
    item As Item _
) As Boolean
Visual C++
public:
bool DeleteItem(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item to delete.

Return Value

True if the item was deleted, false otherwise.

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


GetBlobStream Method

[image]

Sitecore 6.4.1 API
DataEngine..::..GetBlobStream Method
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Stream GetBlobStream(
    Guid blobId
)
Visual Basic
Public Function GetBlobStream ( _
    blobId As Guid _
) As Stream
Visual C++
public:
Stream^ GetBlobStream(
    Guid blobId
)

Parameters

blobId
Type: System..::..Guid
The BLOB id.

Return Value

The stream.

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


GetChildren Method

[image]

Sitecore 6.4.1 API
DataEngine..::..GetChildren Method
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemList GetChildren(
    Item item
)
Visual Basic
Public Function GetChildren ( _
    item As Item _
) As ItemList
Visual C++
public:
ItemList^ GetChildren(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The parent item.

Return Value

The child items.

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


GetItem Method

[image]

Sitecore 6.4.1 API
DataEngine..::..GetItem Method
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetItem(
    ID itemId,
    Language language,
    Version version
)
Visual Basic
Public Function GetItem ( _
    itemId As ID, _
    language As Language, _
    version As Version _
) As Item
Visual C++
public:
Item^ GetItem(
    ID^ itemId,
    Language^ language,
    Version^ version
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The id of the item to get.
language
Type: Sitecore.Globalization..::..Language
The language of the item to get.
version
Type: Sitecore.Data..::..Version
The version of the item to get.

Return Value

The item. If no item is found, null is returned.

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


GetRootItem Method

[image]

Sitecore 6.4.1 API
DataEngine..::..GetRootItem Method
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetRootItem(
    Language language,
    Version version
)
Visual Basic
Public Function GetRootItem ( _
    language As Language, _
    version As Version _
) As Item
Visual C++
public:
Item^ GetRootItem(
    Language^ language,
    Version^ version
)

Parameters

language
Type: Sitecore.Globalization..::..Language
The language to return.
version
Type: Sitecore.Data..::..Version
The version to return.

Return Value

The root item. If no item is found, null is returned.

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


GetVersions Method

[image]

Sitecore 6.4.1 API
DataEngine..::..GetVersions Method
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public VersionCollection GetVersions(
    Item item,
    Language language
)
Visual Basic
Public Function GetVersions ( _
    item As Item, _
    language As Language _
) As VersionCollection
Visual C++
public:
VersionCollection^ GetVersions(
    Item^ item,
    Language^ language
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
language
Type: Sitecore.Globalization..::..Language
The language.

Return Value

The list of versions.

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


HasChildren Method

[image]

Sitecore 6.4.1 API
DataEngine..::..HasChildren Method
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool HasChildren(
    Item item
)
Visual Basic
Public Function HasChildren ( _
    item As Item _
) As Boolean
Visual C++
public:
bool HasChildren(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The parent item.

Return Value

The child items.

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


MoveItem Method

[image]

Sitecore 6.4.1 API
DataEngine..::..MoveItem Method
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool MoveItem(
    Item item,
    Item destination
)
Visual Basic
Public Function MoveItem ( _
    item As Item, _
    destination As Item _
) As Boolean
Visual C++
public:
bool MoveItem(
    Item^ item,
    Item^ destination
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item to move.
destination
Type: Sitecore.Data.Items..::..Item
The destination. This will become the new parent of item.

Return Value

true if the item was moved; false otherwise.

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


RaiseAddedFromTemplate Method

[image]

Sitecore 6.4.1 API
DataEngine..::..RaiseAddedFromTemplate Method
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RaiseAddedFromTemplate(
    string itemName,
    ID templateId,
    Item destination,
    ID newId,
    Item result
)
Visual Basic
Public Sub RaiseAddedFromTemplate ( _
    itemName As String, _
    templateId As ID, _
    destination As Item, _
    newId As ID, _
    result As Item _
)
Visual C++
public:
void RaiseAddedFromTemplate(
    String^ itemName,
    ID^ templateId,
    Item^ destination,
    ID^ newId,
    Item^ result
)

Parameters

itemName
Type: System..::..String
Name of the item.
templateId
Type: Sitecore.Data..::..ID
The template id.
destination
Type: Sitecore.Data.Items..::..Item
The destination.
newId
Type: Sitecore.Data..::..ID
The new id.
result
Type: Sitecore.Data.Items..::..Item
The result.

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


RaiseAddedFromTemplateRemote Method

[image]

Sitecore 6.4.1 API
DataEngine..::..RaiseAddedFromTemplateRemote Method
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RaiseAddedFromTemplateRemote(
    Item item,
    Item destination
)
Visual Basic
Public Sub RaiseAddedFromTemplateRemote ( _
    item As Item, _
    destination As Item _
)
Visual C++
public:
void RaiseAddedFromTemplateRemote(
    Item^ item,
    Item^ destination
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
destination
Type: Sitecore.Data.Items..::..Item
The destination.

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


RaiseAddedVersion Method

[image]

Sitecore 6.4.1 API
DataEngine..::..RaiseAddedVersion Method
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RaiseAddedVersion(
    Item item,
    Item result
)
Visual Basic
Public Sub RaiseAddedVersion ( _
    item As Item, _
    result As Item _
)
Visual C++
public:
void RaiseAddedVersion(
    Item^ item,
    Item^ result
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
result
Type: Sitecore.Data.Items..::..Item
The result.

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


RaiseAddedVersionRemote Method

[image]

Sitecore 6.4.1 API
DataEngine..::..RaiseAddedVersionRemote Method
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RaiseAddedVersionRemote(
    Item item
)
Visual Basic
Public Sub RaiseAddedVersionRemote ( _
    item As Item _
)
Visual C++
public:
void RaiseAddedVersionRemote(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


RaiseCopiedItem Method

[image]

Sitecore 6.4.1 API
DataEngine..::..RaiseCopiedItem Method
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RaiseCopiedItem(
    Item source,
    Item destination,
    string copyName,
    ID copyId,
    bool deep,
    Item result
)
Visual Basic
Public Sub RaiseCopiedItem ( _
    source As Item, _
    destination As Item, _
    copyName As String, _
    copyId As ID, _
    deep As Boolean, _
    result As Item _
)
Visual C++
public:
void RaiseCopiedItem(
    Item^ source,
    Item^ destination,
    String^ copyName,
    ID^ copyId,
    bool deep,
    Item^ result
)

Parameters

source
Type: Sitecore.Data.Items..::..Item
The source.
destination
Type: Sitecore.Data.Items..::..Item
The destination.
copyName
Type: System..::..String
Name of the copy.
copyId
Type: Sitecore.Data..::..ID
The copy id.
deep
Type: System..::..Boolean
if set to true [deep].
result
Type: Sitecore.Data.Items..::..Item
The result.

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


RaiseCopiedItemRemote Method

[image]

Sitecore 6.4.1 API
DataEngine..::..RaiseCopiedItemRemote Method
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RaiseCopiedItemRemote(
    Item item,
    Item source,
    Item destination,
    bool deep
)
Visual Basic
Public Sub RaiseCopiedItemRemote ( _
    item As Item, _
    source As Item, _
    destination As Item, _
    deep As Boolean _
)
Visual C++
public:
void RaiseCopiedItemRemote(
    Item^ item,
    Item^ source,
    Item^ destination,
    bool deep
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
source
Type: Sitecore.Data.Items..::..Item
The source.
destination
Type: Sitecore.Data.Items..::..Item
The destination.
deep
Type: System..::..Boolean
if set to true [deep].

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


RaiseCopyProcessedSingleItem Method

[image]

Sitecore 6.4.1 API
DataEngine..::..RaiseCopyProcessedSingleItem Method
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RaiseCopyProcessedSingleItem(
    ID sourceID,
    ID destinationID,
    ID copyID
)
Visual Basic
Public Sub RaiseCopyProcessedSingleItem ( _
    sourceID As ID, _
    destinationID As ID, _
    copyID As ID _
)
Visual C++
public:
void RaiseCopyProcessedSingleItem(
    ID^ sourceID,
    ID^ destinationID,
    ID^ copyID
)

Parameters

sourceID
Type: Sitecore.Data..::..ID
The source ID.
destinationID
Type: Sitecore.Data..::..ID
The destination ID.
copyID
Type: Sitecore.Data..::..ID
The copy ID.

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


RaiseCreatedItemRemote Method

[image]

Sitecore 6.4.1 API
DataEngine..::..RaiseCreatedItemRemote Method
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RaiseCreatedItemRemote(
    Item item,
    Item destination
)
Visual Basic
Public Sub RaiseCreatedItemRemote ( _
    item As Item, _
    destination As Item _
)
Visual C++
public:
void RaiseCreatedItemRemote(
    Item^ item,
    Item^ destination
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
destination
Type: Sitecore.Data.Items..::..Item
The destination.

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


RaiseDeletedItem Method

[image]

Sitecore 6.4.1 API
DataEngine..::..RaiseDeletedItem Method
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RaiseDeletedItem(
    Item item,
    ID parentId,
    bool result
)
Visual Basic
Public Sub RaiseDeletedItem ( _
    item As Item, _
    parentId As ID, _
    result As Boolean _
)
Visual C++
public:
void RaiseDeletedItem(
    Item^ item,
    ID^ parentId,
    bool result
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
parentId
Type: Sitecore.Data..::..ID
The parent id.
result
Type: System..::..Boolean
The result.

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


RaiseDeletedItemRemote Method

[image]

Sitecore 6.4.1 API
DataEngine..::..RaiseDeletedItemRemote Method
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RaiseDeletedItemRemote(
    Item item,
    ID parentId
)
Visual Basic
Public Sub RaiseDeletedItemRemote ( _
    item As Item, _
    parentId As ID _
)
Visual C++
public:
void RaiseDeletedItemRemote(
    Item^ item,
    ID^ parentId
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
parentId
Type: Sitecore.Data..::..ID
The parent id.

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


RaiseDeleteProcessedSingleItem Method

[image]

Sitecore 6.4.1 API
DataEngine..::..RaiseDeleteProcessedSingleItem Method
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RaiseDeleteProcessedSingleItem(
    ID itemID
)
Visual Basic
Public Sub RaiseDeleteProcessedSingleItem ( _
    itemID As ID _
)
Visual C++
public:
void RaiseDeleteProcessedSingleItem(
    ID^ itemID
)

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


RaiseDeletingItem Method

[image]

Sitecore 6.4.1 API
DataEngine..::..RaiseDeletingItem Method
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RaiseDeletingItem(
    Item item,
    out bool cancelled
)
Visual Basic
Public Sub RaiseDeletingItem ( _
    item As Item, _
    <OutAttribute> ByRef cancelled As Boolean _
)
Visual C++
public:
void RaiseDeletingItem(
    Item^ item,
    [OutAttribute] bool% cancelled
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
cancelled
Type: System..::..Boolean %
if set to true this instance is cancelled.

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


RaiseMovedItem Method

[image]

Sitecore 6.4.1 API
DataEngine..::..RaiseMovedItem Method
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RaiseMovedItem(
    Item item,
    Item destination,
    bool result
)
Visual Basic
Public Sub RaiseMovedItem ( _
    item As Item, _
    destination As Item, _
    result As Boolean _
)
Visual C++
public:
void RaiseMovedItem(
    Item^ item,
    Item^ destination,
    bool result
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
destination
Type: Sitecore.Data.Items..::..Item
The destination.
result
Type: System..::..Boolean
The result.

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


RaiseMovedItemRemote Method

[image]

Sitecore 6.4.1 API
DataEngine..::..RaiseMovedItemRemote Method
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RaiseMovedItemRemote(
    Item item,
    ID oldParentId
)
Visual Basic
Public Sub RaiseMovedItemRemote ( _
    item As Item, _
    oldParentId As ID _
)
Visual C++
public:
void RaiseMovedItemRemote(
    Item^ item,
    ID^ oldParentId
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
oldParentId
Type: Sitecore.Data..::..ID
The old parent id.

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


RaiseRemovedDataRemote Method

[image]

Sitecore 6.4.1 API
DataEngine..::..RaiseRemovedDataRemote Method
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RaiseRemovedDataRemote(
    ID itemId,
    Language language,
    bool removeAllLanguages,
    bool removeSharedData
)
Visual Basic
Public Sub RaiseRemovedDataRemote ( _
    itemId As ID, _
    language As Language, _
    removeAllLanguages As Boolean, _
    removeSharedData As Boolean _
)
Visual C++
public:
void RaiseRemovedDataRemote(
    ID^ itemId,
    Language^ language,
    bool removeAllLanguages,
    bool removeSharedData
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
language
Type: Sitecore.Globalization..::..Language
The language.
removeAllLanguages
Type: System..::..Boolean
if set to true [remove all languages].
removeSharedData
Type: System..::..Boolean
if set to true [remove shared data].

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


RaiseRemovedVersion Method

[image]

Sitecore 6.4.1 API
DataEngine..::..RaiseRemovedVersion Method
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RaiseRemovedVersion(
    Item item,
    bool result
)
Visual Basic
Public Sub RaiseRemovedVersion ( _
    item As Item, _
    result As Boolean _
)
Visual C++
public:
void RaiseRemovedVersion(
    Item^ item,
    bool result
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
result
Type: System..::..Boolean
The result.

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


RaiseRemovedVersionRemote Method

[image]

Sitecore 6.4.1 API
DataEngine..::..RaiseRemovedVersionRemote Method
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RaiseRemovedVersionRemote(
    Item item,
    Version removedVersion
)
Visual Basic
Public Sub RaiseRemovedVersionRemote ( _
    item As Item, _
    removedVersion As Version _
)
Visual C++
public:
void RaiseRemovedVersionRemote(
    Item^ item,
    Version^ removedVersion
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
removedVersion
Type: Sitecore.Data..::..Version
The removed version.

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


RaiseSavedItemRemote Method

[image]

Sitecore 6.4.1 API
DataEngine..::..RaiseSavedItemRemote Method
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RaiseSavedItemRemote(
    Item item,
    ItemChanges changes
)
Visual Basic
Public Sub RaiseSavedItemRemote ( _
    item As Item, _
    changes As ItemChanges _
)
Visual C++
public:
void RaiseSavedItemRemote(
    Item^ item,
    ItemChanges^ changes
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
changes
Type: Sitecore.Data.Items..::..ItemChanges
The changes.

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


RemoveData Method

[image]

Sitecore 6.4.1 API
DataEngine..::..RemoveData Method
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool RemoveData(
    ID itemId,
    Language language,
    bool removeSharedData
)
Visual Basic
Public Function RemoveData ( _
    itemId As ID, _
    language As Language, _
    removeSharedData As Boolean _
) As Boolean
Visual C++
public:
bool RemoveData(
    ID^ itemId,
    Language^ language,
    bool removeSharedData
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
language
Type: Sitecore.Globalization..::..Language
The language of the data to remove. Specify Invariant to remove data in all languages.
removeSharedData
Type: System..::..Boolean
If set to true shared data is removed.

Return Value

true if the data was removed, otherwise false.

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


RemoveVersion Method

[image]

Sitecore 6.4.1 API
DataEngine..::..RemoveVersion Method
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool RemoveVersion(
    Item item
)
Visual Basic
Public Function RemoveVersion ( _
    item As Item _
) As Boolean
Visual C++
public:
bool RemoveVersion(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item representing the version to remove.

Return Value

true if the version was removed, otherwise false.

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


ResolvePath Method

[image]

Sitecore 6.4.1 API
DataEngine..::..ResolvePath Method
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ResolvePath(
    string itemPath
)
Visual Basic
Public Function ResolvePath ( _
    itemPath As String _
) As ID
Visual C++
public:
ID^ ResolvePath(
    String^ itemPath
)

Parameters

itemPath
Type: System..::..String
The item path.

Return Value

The id of the item with the path specified by itemPath.

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


SaveItem Method

[image]

Sitecore 6.4.1 API
DataEngine..::..SaveItem Method
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool SaveItem(
    Item item
)
Visual Basic
Public Function SaveItem ( _
    item As Item _
) As Boolean
Visual C++
public:
bool SaveItem(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

True if the item was saved, false otherwise.

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


DataEngine Properties

[image] [image]

Sitecore 6.4.1 API
DataEngine Properties
DataEngine Class See Also Send Feedback

The DataEngine type exposes the following members.

Properties

 | Name | Description
Public property | Commands | Gets the command collection.
Public property | Database | Gets the database associated with the engine.

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


Commands Property

[image]

Sitecore 6.4.1 API
DataEngine..::..Commands Property
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CommandCollection Commands { get; }
Visual Basic
Public ReadOnly Property Commands As CommandCollection
    Get
Visual C++
public:
property CommandCollection^ Commands {
    CommandCollection^ get ();
}

Field Value

The commands.

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


Database Property

[image]

Sitecore 6.4.1 API
DataEngine..::..Database Property
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database Database { get; }
Visual Basic
Public ReadOnly Property Database As Database
    Get
Visual C++
public:
property Database^ Database {
    Database^ get ();
}

Field Value

The database.

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


DataEngine Events

[image] [image]

Sitecore 6.4.1 API
DataEngine Events
DataEngine Class See Also Send Feedback

The DataEngine type exposes the following members.

Events

 | Name | Description
Public event | AddedFromTemplate | Item added from template event.
Public event | AddedFromTemplateRemote | Item added from template remote event.
Public event | AddedVersion | Item added version event.
Public event | AddedVersionRemote | Item added version remote event.
Public event | AddingFromTemplate | Item adding from template event.
Public event | AddingVersion | Item adding version event.
Public event | CopiedItem | Item copied event.
Public event | CopiedItemRemote | Item copied remote event.
Public event | CopyingItem | Item copying event.
Public event | CopyProcessedSingleItem | Occurs for each item that 'copy item' operation processes.
Public event | CreatedItem | Item created event.
Public event | CreatedItemRemote | Item created remote event.
Public event | CreatingItem | Item creating event.
Public event | DeletedItem | Item deleted event.
Public event | DeletedItemRemote | Item deleted remote event.
Public event | DeleteProcessedSingleItem | Occurs for each item that the 'delete item' operation processes.
Public event | DeletingItem | Item deleting event.
Public event | MovedItem | Item moved event.
Public event | MovedItemRemote | Item moved remote event.
Public event | MovingItem | Item moving event.
Public event | RemovedData | Item removed data event.
Public event | RemovedDataRemote | Item removed data remote event.
Public event | RemovedVersion | Item removed version event.
Public event | RemovedVersionRemote | Item removed version remote event.
Public event | RemovingData | Item removing data event.
Public event | RemovingVersion | Item removing version event.
Public event | SavedItem | Item saved event.
Public event | SavedItemRemote | Item saved remote event.
Public event | SavingItem | Item saving event.

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


AddedFromTemplate Event

[image]

Sitecore 6.4.1 API
DataEngine..::..AddedFromTemplate Event
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler<ExecutedEventArgs<AddFromTemplateCommand>> AddedFromTemplate
Visual Basic
Public Event AddedFromTemplate As EventHandler(Of ExecutedEventArgs(Of AddFromTemplateCommand))
Visual C++
public:
 event EventHandler<ExecutedEventArgs<AddFromTemplateCommand^>^>^ AddedFromTemplate {
    void add (EventHandler<ExecutedEventArgs<AddFromTemplateCommand^>^>^ value);
    void remove (EventHandler<ExecutedEventArgs<AddFromTemplateCommand^>^>^ value);
}

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


AddedFromTemplateRemote Event

[image]

Sitecore 6.4.1 API
DataEngine..::..AddedFromTemplateRemote Event
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler<AddedFromTemplateRemoteEventArgs> AddedFromTemplateRemote
Visual Basic
Public Event AddedFromTemplateRemote As EventHandler(Of AddedFromTemplateRemoteEventArgs)
Visual C++
public:
 event EventHandler<AddedFromTemplateRemoteEventArgs^>^ AddedFromTemplateRemote {
    void add (EventHandler<AddedFromTemplateRemoteEventArgs^>^ value);
    void remove (EventHandler<AddedFromTemplateRemoteEventArgs^>^ value);
}

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


AddedVersion Event

[image]

Sitecore 6.4.1 API
DataEngine..::..AddedVersion Event
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler<ExecutedEventArgs<AddVersionCommand>> AddedVersion
Visual Basic
Public Event AddedVersion As EventHandler(Of ExecutedEventArgs(Of AddVersionCommand))
Visual C++
public:
 event EventHandler<ExecutedEventArgs<AddVersionCommand^>^>^ AddedVersion {
    void add (EventHandler<ExecutedEventArgs<AddVersionCommand^>^>^ value);
    void remove (EventHandler<ExecutedEventArgs<AddVersionCommand^>^>^ value);
}

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


AddedVersionRemote Event

[image]

Sitecore 6.4.1 API
DataEngine..::..AddedVersionRemote Event
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler<AddedVersionRemoteEventArgs> AddedVersionRemote
Visual Basic
Public Event AddedVersionRemote As EventHandler(Of AddedVersionRemoteEventArgs)
Visual C++
public:
 event EventHandler<AddedVersionRemoteEventArgs^>^ AddedVersionRemote {
    void add (EventHandler<AddedVersionRemoteEventArgs^>^ value);
    void remove (EventHandler<AddedVersionRemoteEventArgs^>^ value);
}

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


AddingFromTemplate Event

[image]

Sitecore 6.4.1 API
DataEngine..::..AddingFromTemplate Event
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler<ExecutingEventArgs<AddFromTemplateCommand>> AddingFromTemplate
Visual Basic
Public Event AddingFromTemplate As EventHandler(Of ExecutingEventArgs(Of AddFromTemplateCommand))
Visual C++
public:
 event EventHandler<ExecutingEventArgs<AddFromTemplateCommand^>^>^ AddingFromTemplate {
    void add (EventHandler<ExecutingEventArgs<AddFromTemplateCommand^>^>^ value);
    void remove (EventHandler<ExecutingEventArgs<AddFromTemplateCommand^>^>^ value);
}

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


AddingVersion Event

[image]

Sitecore 6.4.1 API
DataEngine..::..AddingVersion Event
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler<ExecutingEventArgs<AddVersionCommand>> AddingVersion
Visual Basic
Public Event AddingVersion As EventHandler(Of ExecutingEventArgs(Of AddVersionCommand))
Visual C++
public:
 event EventHandler<ExecutingEventArgs<AddVersionCommand^>^>^ AddingVersion {
    void add (EventHandler<ExecutingEventArgs<AddVersionCommand^>^>^ value);
    void remove (EventHandler<ExecutingEventArgs<AddVersionCommand^>^>^ value);
}

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


CopiedItem Event

[image]

Sitecore 6.4.1 API
DataEngine..::..CopiedItem Event
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler<ExecutedEventArgs<CopyItemCommand>> CopiedItem
Visual Basic
Public Event CopiedItem As EventHandler(Of ExecutedEventArgs(Of CopyItemCommand))
Visual C++
public:
 event EventHandler<ExecutedEventArgs<CopyItemCommand^>^>^ CopiedItem {
    void add (EventHandler<ExecutedEventArgs<CopyItemCommand^>^>^ value);
    void remove (EventHandler<ExecutedEventArgs<CopyItemCommand^>^>^ value);
}

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


CopiedItemRemote Event

[image]

Sitecore 6.4.1 API
DataEngine..::..CopiedItemRemote Event
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler<CopiedItemRemoteEventArgs> CopiedItemRemote
Visual Basic
Public Event CopiedItemRemote As EventHandler(Of CopiedItemRemoteEventArgs)
Visual C++
public:
 event EventHandler<CopiedItemRemoteEventArgs^>^ CopiedItemRemote {
    void add (EventHandler<CopiedItemRemoteEventArgs^>^ value);
    void remove (EventHandler<CopiedItemRemoteEventArgs^>^ value);
}

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


CopyingItem Event

[image]

Sitecore 6.4.1 API
DataEngine..::..CopyingItem Event
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler<ExecutingEventArgs<CopyItemCommand>> CopyingItem
Visual Basic
Public Event CopyingItem As EventHandler(Of ExecutingEventArgs(Of CopyItemCommand))
Visual C++
public:
 event EventHandler<ExecutingEventArgs<CopyItemCommand^>^>^ CopyingItem {
    void add (EventHandler<ExecutingEventArgs<CopyItemCommand^>^>^ value);
    void remove (EventHandler<ExecutingEventArgs<CopyItemCommand^>^>^ value);
}

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


CopyProcessedSingleItem Event

[image]

Sitecore 6.4.1 API
DataEngine..::..CopyProcessedSingleItem Event
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler<CopyProcessedSingleItemEventArgs> CopyProcessedSingleItem
Visual Basic
Public Event CopyProcessedSingleItem As EventHandler(Of CopyProcessedSingleItemEventArgs)
Visual C++
public:
 event EventHandler<CopyProcessedSingleItemEventArgs^>^ CopyProcessedSingleItem {
    void add (EventHandler<CopyProcessedSingleItemEventArgs^>^ value);
    void remove (EventHandler<CopyProcessedSingleItemEventArgs^>^ value);
}

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


CreatedItem Event

[image]

Sitecore 6.4.1 API
DataEngine..::..CreatedItem Event
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler<ExecutedEventArgs<CreateItemCommand>> CreatedItem
Visual Basic
Public Event CreatedItem As EventHandler(Of ExecutedEventArgs(Of CreateItemCommand))
Visual C++
public:
 event EventHandler<ExecutedEventArgs<CreateItemCommand^>^>^ CreatedItem {
    void add (EventHandler<ExecutedEventArgs<CreateItemCommand^>^>^ value);
    void remove (EventHandler<ExecutedEventArgs<CreateItemCommand^>^>^ value);
}

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


CreatedItemRemote Event

[image]

Sitecore 6.4.1 API
DataEngine..::..CreatedItemRemote Event
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler<ItemCreatedRemoteEventArgs> CreatedItemRemote
Visual Basic
Public Event CreatedItemRemote As EventHandler(Of ItemCreatedRemoteEventArgs)
Visual C++
public:
 event EventHandler<ItemCreatedRemoteEventArgs^>^ CreatedItemRemote {
    void add (EventHandler<ItemCreatedRemoteEventArgs^>^ value);
    void remove (EventHandler<ItemCreatedRemoteEventArgs^>^ value);
}

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


CreatingItem Event

[image]

Sitecore 6.4.1 API
DataEngine..::..CreatingItem Event
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler<ExecutingEventArgs<CreateItemCommand>> CreatingItem
Visual Basic
Public Event CreatingItem As EventHandler(Of ExecutingEventArgs(Of CreateItemCommand))
Visual C++
public:
 event EventHandler<ExecutingEventArgs<CreateItemCommand^>^>^ CreatingItem {
    void add (EventHandler<ExecutingEventArgs<CreateItemCommand^>^>^ value);
    void remove (EventHandler<ExecutingEventArgs<CreateItemCommand^>^>^ value);
}

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


DeletedItem Event

[image]

Sitecore 6.4.1 API
DataEngine..::..DeletedItem Event
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler<ExecutedEventArgs<DeleteItemCommand>> DeletedItem
Visual Basic
Public Event DeletedItem As EventHandler(Of ExecutedEventArgs(Of DeleteItemCommand))
Visual C++
public:
 event EventHandler<ExecutedEventArgs<DeleteItemCommand^>^>^ DeletedItem {
    void add (EventHandler<ExecutedEventArgs<DeleteItemCommand^>^>^ value);
    void remove (EventHandler<ExecutedEventArgs<DeleteItemCommand^>^>^ value);
}

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


DeletedItemRemote Event

[image]

Sitecore 6.4.1 API
DataEngine..::..DeletedItemRemote Event
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler<ItemDeletedRemoteEventArgs> DeletedItemRemote
Visual Basic
Public Event DeletedItemRemote As EventHandler(Of ItemDeletedRemoteEventArgs)
Visual C++
public:
 event EventHandler<ItemDeletedRemoteEventArgs^>^ DeletedItemRemote {
    void add (EventHandler<ItemDeletedRemoteEventArgs^>^ value);
    void remove (EventHandler<ItemDeletedRemoteEventArgs^>^ value);
}

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


DeleteProcessedSingleItem Event

[image]

Sitecore 6.4.1 API
DataEngine..::..DeleteProcessedSingleItem Event
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler<DeleteProcessedSingleItemEventArgs> DeleteProcessedSingleItem
Visual Basic
Public Event DeleteProcessedSingleItem As EventHandler(Of DeleteProcessedSingleItemEventArgs)
Visual C++
public:
 event EventHandler<DeleteProcessedSingleItemEventArgs^>^ DeleteProcessedSingleItem {
    void add (EventHandler<DeleteProcessedSingleItemEventArgs^>^ value);
    void remove (EventHandler<DeleteProcessedSingleItemEventArgs^>^ value);
}

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


DeletingItem Event

[image]

Sitecore 6.4.1 API
DataEngine..::..DeletingItem Event
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler<ExecutingEventArgs<DeleteItemCommand>> DeletingItem
Visual Basic
Public Event DeletingItem As EventHandler(Of ExecutingEventArgs(Of DeleteItemCommand))
Visual C++
public:
 event EventHandler<ExecutingEventArgs<DeleteItemCommand^>^>^ DeletingItem {
    void add (EventHandler<ExecutingEventArgs<DeleteItemCommand^>^>^ value);
    void remove (EventHandler<ExecutingEventArgs<DeleteItemCommand^>^>^ value);
}

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


MovedItem Event

[image]

Sitecore 6.4.1 API
DataEngine..::..MovedItem Event
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler<ExecutedEventArgs<MoveItemCommand>> MovedItem
Visual Basic
Public Event MovedItem As EventHandler(Of ExecutedEventArgs(Of MoveItemCommand))
Visual C++
public:
 event EventHandler<ExecutedEventArgs<MoveItemCommand^>^>^ MovedItem {
    void add (EventHandler<ExecutedEventArgs<MoveItemCommand^>^>^ value);
    void remove (EventHandler<ExecutedEventArgs<MoveItemCommand^>^>^ value);
}

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


MovedItemRemote Event

[image]

Sitecore 6.4.1 API
DataEngine..::..MovedItemRemote Event
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler<ItemMovedRemoteEventArgs> MovedItemRemote
Visual Basic
Public Event MovedItemRemote As EventHandler(Of ItemMovedRemoteEventArgs)
Visual C++
public:
 event EventHandler<ItemMovedRemoteEventArgs^>^ MovedItemRemote {
    void add (EventHandler<ItemMovedRemoteEventArgs^>^ value);
    void remove (EventHandler<ItemMovedRemoteEventArgs^>^ value);
}

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


MovingItem Event

[image]

Sitecore 6.4.1 API
DataEngine..::..MovingItem Event
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler<ExecutingEventArgs<MoveItemCommand>> MovingItem
Visual Basic
Public Event MovingItem As EventHandler(Of ExecutingEventArgs(Of MoveItemCommand))
Visual C++
public:
 event EventHandler<ExecutingEventArgs<MoveItemCommand^>^>^ MovingItem {
    void add (EventHandler<ExecutingEventArgs<MoveItemCommand^>^>^ value);
    void remove (EventHandler<ExecutingEventArgs<MoveItemCommand^>^>^ value);
}

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


RemovedData Event

[image]

Sitecore 6.4.1 API
DataEngine..::..RemovedData Event
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler<ExecutedEventArgs<RemoveDataCommand>> RemovedData
Visual Basic
Public Event RemovedData As EventHandler(Of ExecutedEventArgs(Of RemoveDataCommand))
Visual C++
public:
 event EventHandler<ExecutedEventArgs<RemoveDataCommand^>^>^ RemovedData {
    void add (EventHandler<ExecutedEventArgs<RemoveDataCommand^>^>^ value);
    void remove (EventHandler<ExecutedEventArgs<RemoveDataCommand^>^>^ value);
}

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


RemovedDataRemote Event

[image]

Sitecore 6.4.1 API
DataEngine..::..RemovedDataRemote Event
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler<RemovedDataRemoteEventArgs> RemovedDataRemote
Visual Basic
Public Event RemovedDataRemote As EventHandler(Of RemovedDataRemoteEventArgs)
Visual C++
public:
 event EventHandler<RemovedDataRemoteEventArgs^>^ RemovedDataRemote {
    void add (EventHandler<RemovedDataRemoteEventArgs^>^ value);
    void remove (EventHandler<RemovedDataRemoteEventArgs^>^ value);
}

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


RemovedVersion Event

[image]

Sitecore 6.4.1 API
DataEngine..::..RemovedVersion Event
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler<ExecutedEventArgs<RemoveVersionCommand>> RemovedVersion
Visual Basic
Public Event RemovedVersion As EventHandler(Of ExecutedEventArgs(Of RemoveVersionCommand))
Visual C++
public:
 event EventHandler<ExecutedEventArgs<RemoveVersionCommand^>^>^ RemovedVersion {
    void add (EventHandler<ExecutedEventArgs<RemoveVersionCommand^>^>^ value);
    void remove (EventHandler<ExecutedEventArgs<RemoveVersionCommand^>^>^ value);
}

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


RemovedVersionRemote Event

[image]

Sitecore 6.4.1 API
DataEngine..::..RemovedVersionRemote Event
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler<VersionRemovedRemoteEventArgs> RemovedVersionRemote
Visual Basic
Public Event RemovedVersionRemote As EventHandler(Of VersionRemovedRemoteEventArgs)
Visual C++
public:
 event EventHandler<VersionRemovedRemoteEventArgs^>^ RemovedVersionRemote {
    void add (EventHandler<VersionRemovedRemoteEventArgs^>^ value);
    void remove (EventHandler<VersionRemovedRemoteEventArgs^>^ value);
}

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


RemovingData Event

[image]

Sitecore 6.4.1 API
DataEngine..::..RemovingData Event
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler<ExecutingEventArgs<RemoveDataCommand>> RemovingData
Visual Basic
Public Event RemovingData As EventHandler(Of ExecutingEventArgs(Of RemoveDataCommand))
Visual C++
public:
 event EventHandler<ExecutingEventArgs<RemoveDataCommand^>^>^ RemovingData {
    void add (EventHandler<ExecutingEventArgs<RemoveDataCommand^>^>^ value);
    void remove (EventHandler<ExecutingEventArgs<RemoveDataCommand^>^>^ value);
}

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


RemovingVersion Event

[image]

Sitecore 6.4.1 API
DataEngine..::..RemovingVersion Event
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler<ExecutingEventArgs<RemoveVersionCommand>> RemovingVersion
Visual Basic
Public Event RemovingVersion As EventHandler(Of ExecutingEventArgs(Of RemoveVersionCommand))
Visual C++
public:
 event EventHandler<ExecutingEventArgs<RemoveVersionCommand^>^>^ RemovingVersion {
    void add (EventHandler<ExecutingEventArgs<RemoveVersionCommand^>^>^ value);
    void remove (EventHandler<ExecutingEventArgs<RemoveVersionCommand^>^>^ value);
}

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


SavedItem Event

[image]

Sitecore 6.4.1 API
DataEngine..::..SavedItem Event
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler<ExecutedEventArgs<SaveItemCommand>> SavedItem
Visual Basic
Public Event SavedItem As EventHandler(Of ExecutedEventArgs(Of SaveItemCommand))
Visual C++
public:
 event EventHandler<ExecutedEventArgs<SaveItemCommand^>^>^ SavedItem {
    void add (EventHandler<ExecutedEventArgs<SaveItemCommand^>^>^ value);
    void remove (EventHandler<ExecutedEventArgs<SaveItemCommand^>^>^ value);
}

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


SavingItem Event

[image]

Sitecore 6.4.1 API
DataEngine..::..SavingItem Event
DataEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler<ExecutingEventArgs<SaveItemCommand>> SavingItem
Visual Basic
Public Event SavingItem As EventHandler(Of ExecutingEventArgs(Of SaveItemCommand))
Visual C++
public:
 event EventHandler<ExecutingEventArgs<SaveItemCommand^>^>^ SavingItem {
    void add (EventHandler<ExecutingEventArgs<SaveItemCommand^>^>^ value);
    void remove (EventHandler<ExecutingEventArgs<SaveItemCommand^>^>^ value);
}

See Also

DataEngine Class
Sitecore.Data.Engines Namespace


DataEngineCommand(TReturnType, TCommandType) Class

[image]

Sitecore 6.4.1 API
DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class DataEngineCommand<TReturnType, TCommandType> : EngineCommand<TReturnType, TCommandType>
where TCommandType : new(), DataEngineCommand<TReturnType, TCommandType>
Visual Basic
Public MustInherit Class DataEngineCommand(Of TReturnType, TCommandType As {New, DataEngineCommand(Of TReturnType, TCommandType)}) _
    Inherits EngineCommand(Of TReturnType, TCommandType)
Visual C++
generic<typename TReturnType, typename TCommandType>
where TCommandType : gcnew(), DataEngineCommand<TReturnType, TCommandType>
public ref class DataEngineCommand abstract : public EngineCommand<TReturnType, TCommandType>

Type Parameters

TReturnType

[Missing <typeparam name="TReturnType"/> documentation for "T:Sitecore.Data.Engines.DataEngineCommand`2"]

TCommandType

[Missing <typeparam name="TCommandType"/> documentation for "T:Sitecore.Data.Engines.DataEngineCommand`2"]

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Engines..::..EngineCommand <(Of <(<' TReturnType, TCommandType >)>)>
Sitecore.Data.Engines..::..DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>
Sitecore.Data.Engines.DataCommands..::..AddFromTemplateCommand
Sitecore.Data.Engines.DataCommands..::..AddVersionCommand
Sitecore.Data.Engines.DataCommands..::..BlobStreamExistsCommand
Sitecore.Data.Engines.DataCommands..::..CopyItemCommand
Sitecore.Data.Engines.DataCommands..::..CreateItemCommand
Sitecore.Data.Engines.DataCommands..::..DeleteItemCommand
Sitecore.Data.Engines.DataCommands..::..GetBlobStreamCommand
Sitecore.Data.Engines.DataCommands..::..GetChildrenCommand
Sitecore.Data.Engines.DataCommands..::..GetItemCommand
Sitecore.Data.Engines.DataCommands..::..GetParentCommand
Sitecore.Data.Engines.DataCommands..::..GetRootItemCommand
Sitecore.Data.Engines.DataCommands..::..GetVersionsCommand
Sitecore.Data.Engines.DataCommands..::..HasChildrenCommand
Sitecore.Data.Engines.DataCommands..::..MoveItemCommand
Sitecore.Data.Engines.DataCommands..::..RemoveDataCommand
Sitecore.Data.Engines.DataCommands..::..RemoveVersionCommand
Sitecore.Data.Engines.DataCommands..::..ResolvePathCommand
Sitecore.Data.Engines.DataCommands..::..SaveItemCommand
Sitecore.Data.Engines.DataCommands..::..SetBlobStreamCommand

See Also

DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Members
Sitecore.Data.Engines Namespace


DataEngineCommand(TReturnType, TCommandType) Members

[image] [image]

Sitecore 6.4.1 API
DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Members
DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class Constructors Methods Fields Properties See Also Send Feedback

The DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> type exposes the following members.

Constructors

 | Name | Description
Protected method | DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> | Initializes a new instance of the DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> class

Methods

 | Name | Description
Protected method | CanExecute | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..Clone()()()().)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events.
 | Construct | Constructs an instance of a command.
Protected method | CreateInstance | Creates an instance of the command class.
Protected method | DoExecute | Executes the command. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Executed | Post processing handler. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalizeExecution | Finalizes the execution. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..FinalizeExecution()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareExecution | Prepares the execution. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..PrepareExecution()()()().)
Public method | RaiseExecuted | Raises the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuting | Raises the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _lockType |

Properties

 | Name | Description
Public property | Database | Gets the database owning the engine.
Public property | DataSource | Gets the data source.
Public property | Engine | Gets the data engine associated with this command.
Protected property | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class
Sitecore.Data.Engines Namespace


DataEngineCommand(TReturnType, TCommandType) Constructor

[image]

Sitecore 6.4.1 API
DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Constructor
DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected DataEngineCommand()
Visual Basic
Protected Sub New
Visual C++
protected:
DataEngineCommand()

See Also

DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class
Sitecore.Data.Engines Namespace


DataEngineCommand(TReturnType, TCommandType) Fields

[image] [image]

Sitecore 6.4.1 API
DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Fields
DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class See Also Send Feedback

The DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> type exposes the following members.

Fields

 | Name | Description
Protected field | _lockType |

See Also

DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class
Sitecore.Data.Engines Namespace


_lockType Field

[image]

Sitecore 6.4.1 API
DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::.._lockType Field
DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..EngineLockingType _lockType
Visual Basic
Protected _lockType As DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..EngineLockingType
Visual C++
protected:
DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..EngineLockingType _lockType

See Also

DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class
Sitecore.Data.Engines Namespace


DataEngineCommand(TReturnType, TCommandType) Methods

[image] [image]

Sitecore 6.4.1 API
DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Methods
DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class See Also Send Feedback

The DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> type exposes the following members.

Methods

 | Name | Description
Protected method | CanExecute | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..Clone()()()().)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events.
 | Construct | Constructs an instance of a command.
Protected method | CreateInstance | Creates an instance of the command class.
Protected method | DoExecute | Executes the command. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Executed | Post processing handler. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalizeExecution | Finalizes the execution. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..FinalizeExecution()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareExecution | Prepares the execution. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..PrepareExecution()()()().)
Public method | RaiseExecuted | Raises the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuting | Raises the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class
Sitecore.Data.Engines Namespace


Clone Method

[image] [image]

Sitecore 6.4.1 API
DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..Clone Method
DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..Clone()()()().)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events.

See Also

DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class
DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Members
Sitecore.Data.Engines Namespace


Clone Method

[image]

Sitecore 6.4.1 API
DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..Clone Method
DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override TCommandType Clone()
Visual Basic
Public Overrides Function Clone As TCommandType
Visual C++
public:
virtual TCommandType Clone() override

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Engines.DataEngineCommand`2.Clone"]

See Also

DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class
Clone Overload
Sitecore.Data.Engines Namespace


Clone Method (EventHandler(ExecutingEventArgs(TCommandType)), EventHandler(ExecutedEventArgs(TCommandType)))

[image]

Sitecore 6.4.1 API
DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..Clone Method (EventHandler<(Of <(<'ExecutingEventArgs<(Of <(<'TCommandType>)>)>>)>)>, EventHandler<(Of <(<'ExecutedEventArgs<(Of <(<'TCommandType>)>)>>)>)>)
DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual TCommandType Clone(
    EventHandler<ExecutingEventArgs<TCommandType>> executingEvent,
    EventHandler<ExecutedEventArgs<TCommandType>> executedEvent
)
Visual Basic
Public Overridable Function Clone ( _
    executingEvent As EventHandler(Of ExecutingEventArgs(Of TCommandType)), _
    executedEvent As EventHandler(Of ExecutedEventArgs(Of TCommandType)) _
) As TCommandType
Visual C++
public:
virtual TCommandType Clone(
    EventHandler<ExecutingEventArgs<TCommandType>^>^ executingEvent,
    EventHandler<ExecutedEventArgs<TCommandType>^>^ executedEvent
)

Parameters

executingEvent
Type: System..::..EventHandler <(Of <(<' ExecutingEventArgs <(Of <(<' TCommandType >)>)>>)>)>
The executing event.
executedEvent
Type: System..::..EventHandler <(Of <(<' ExecutedEventArgs <(Of <(<' TCommandType >)>)>>)>)>
The executed event.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Engines.DataEngineCommand`2.Clone(System.EventHandler{Sitecore.Data.Events.ExecutingEventArgs{`1}},System.EventHandler{Sitecore.Data.Events.ExecutedEventArgs{`1}})"]

See Also

DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class
Clone Overload
Sitecore.Data.Engines Namespace


Construct Method

[image]

Sitecore 6.4.1 API
DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..Construct Method
DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TCommandType Construct(
    DataEngine engine
)
Visual Basic
Public Shared Function Construct ( _
    engine As DataEngine _
) As TCommandType
Visual C++
public:
static TCommandType Construct(
    DataEngine^ engine
)

Parameters

engine
Type: Sitecore.Data.Engines..::..DataEngine
The data engine.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Engines.DataEngineCommand`2.Construct(Sitecore.Data.Engines.DataEngine)"]

See Also

DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class
Sitecore.Data.Engines Namespace


CreateInstance Method

[image]

Sitecore 6.4.1 API
DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..CreateInstance Method
DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected abstract TCommandType CreateInstance()
Visual Basic
Protected MustOverride Function CreateInstance As TCommandType
Visual C++
protected:
virtual TCommandType CreateInstance() abstract

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Engines.DataEngineCommand`2.CreateInstance"]

See Also

DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class
Sitecore.Data.Engines Namespace


FinalizeExecution Method

[image]

Sitecore 6.4.1 API
DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..FinalizeExecution Method
DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void FinalizeExecution()
Visual Basic
Protected Overrides Sub FinalizeExecution
Visual C++
protected:
virtual void FinalizeExecution() override

See Also

DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class
Sitecore.Data.Engines Namespace


PrepareExecution Method

[image]

Sitecore 6.4.1 API
DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..PrepareExecution Method
DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void PrepareExecution()
Visual Basic
Protected Overrides Sub PrepareExecution
Visual C++
protected:
virtual void PrepareExecution() override

See Also

DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class
Sitecore.Data.Engines Namespace


DataEngineCommand(TReturnType, TCommandType) Properties

[image] [image]

Sitecore 6.4.1 API
DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Properties
DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class See Also Send Feedback

The DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Database | Gets the database owning the engine.
Public property | DataSource | Gets the data source.
Public property | Engine | Gets the data engine associated with this command.
Protected property | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class
Sitecore.Data.Engines Namespace


Database Property

[image]

Sitecore 6.4.1 API
DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..Database Property
DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database Database { get; }
Visual Basic
Public ReadOnly Property Database As Database
    Get
Visual C++
public:
property Database^ Database {
    Database^ get ();
}

Field Value

The database.

See Also

DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class
Sitecore.Data.Engines Namespace


DataSource Property

[image]

Sitecore 6.4.1 API
DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..DataSource Property
DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataSource DataSource { get; }
Visual Basic
Public ReadOnly Property DataSource As DataSource
    Get
Visual C++
public:
property DataSource^ DataSource {
    DataSource^ get ();
}

Field Value

The data source.

See Also

DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class
Sitecore.Data.Engines Namespace


Engine Property

[image]

Sitecore 6.4.1 API
DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..Engine Property
DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataEngine Engine { get; set; }
Visual Basic
Public Property Engine As DataEngine
    Get
    Set
Visual C++
public:
property DataEngine^ Engine {
    DataEngine^ get ();
    void set (DataEngine^ value);
}

Field Value

The data engine.

See Also

DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class
Sitecore.Data.Engines Namespace


EngineCommand(TReturnType, TCommandType) Class

[image]

Sitecore 6.4.1 API
EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class EngineCommand<TReturnType, TCommandType> : ICommand<TReturnType>,
    IPrototype<TCommandType>
where TCommandType : EngineCommand<TReturnType, TCommandType>
Visual Basic
Public MustInherit Class EngineCommand(Of TReturnType, TCommandType As EngineCommand(Of TReturnType, TCommandType)) _
    Implements ICommand(Of TReturnType), IPrototype(Of TCommandType)
Visual C++
generic<typename TReturnType, typename TCommandType>
where TCommandType : EngineCommand<TReturnType, TCommandType>
public ref class EngineCommand abstract : ICommand<TReturnType>,
    IPrototype<TCommandType>

Type Parameters

TReturnType

[Missing <typeparam name="TReturnType"/> documentation for "T:Sitecore.Data.Engines.EngineCommand`2"]

TCommandType

[Missing <typeparam name="TCommandType"/> documentation for "T:Sitecore.Data.Engines.EngineCommand`2"]

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Engines..::..EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>
Sitecore.Data.Engines..::..DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>

See Also

EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Members
Sitecore.Data.Engines Namespace


EngineCommand(TReturnType, TCommandType) Members

[image] [image]

Sitecore 6.4.1 API
EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Members
EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class Constructors Methods Properties See Also Send Feedback

The EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> type exposes the following members.

Constructors

 | Name | Description
Protected method | EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> | Initializes a new instance of the EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> class

Methods

 | Name | Description
Protected method | CanExecute | Determines whether the command can be executed.
Public method | Clone | Clones the source object. Has the same effect as creating a new instance of the type.
Protected method | DoExecute | Executes the command.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command.
Protected method | Executed | Post processing handler.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalizeExecution | Finalizes the execution.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareExecution | Prepares the execution.
Public method | RaiseExecuted | Raises the executed event.
Public method | RaiseExecuting | Raises the executing event.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Protected property | ExecutedEvent | Gets the executed event.
Protected property | ExecutingEvent | Gets the executing event.
Public property | Result | Gets the result of the execution.

See Also

EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class
Sitecore.Data.Engines Namespace


EngineCommand(TReturnType, TCommandType) Constructor

[image]

Sitecore 6.4.1 API
EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Constructor
EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected EngineCommand()
Visual Basic
Protected Sub New
Visual C++
protected:
EngineCommand()

See Also

EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class
Sitecore.Data.Engines Namespace


EngineCommand(TReturnType, TCommandType) Methods

[image] [image]

Sitecore 6.4.1 API
EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Methods
EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class See Also Send Feedback

The EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> type exposes the following members.

Methods

 | Name | Description
Protected method | CanExecute | Determines whether the command can be executed.
Public method | Clone | Clones the source object. Has the same effect as creating a new instance of the type.
Protected method | DoExecute | Executes the command.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command.
Protected method | Executed | Post processing handler.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalizeExecution | Finalizes the execution.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareExecution | Prepares the execution.
Public method | RaiseExecuted | Raises the executed event.
Public method | RaiseExecuting | Raises the executing event.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class
Sitecore.Data.Engines Namespace


Clone Method

[image]

Sitecore 6.4.1 API
EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..Clone Method
EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract TCommandType Clone()
Visual Basic
Public MustOverride Function Clone As TCommandType
Visual C++
public:
virtual TCommandType Clone() abstract

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Engines.EngineCommand`2.Clone"]

Implements

IPrototype<(Of <(<'TObjectType>)>)>..::..Clone()()()()

See Also

EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class
Sitecore.Data.Engines Namespace


DoExecute Method

[image]

Sitecore 6.4.1 API
EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..DoExecute Method
EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected abstract TReturnType DoExecute()
Visual Basic
Protected MustOverride Function DoExecute As TReturnType
Visual C++
protected:
virtual TReturnType DoExecute() abstract

Return Value

The result of execution.

See Also

EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class
Sitecore.Data.Engines Namespace


Execute Method

[image]

Sitecore 6.4.1 API
EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..Execute Method
EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual TReturnType Execute()
Visual Basic
Public Overridable Function Execute As TReturnType
Visual C++
public:
virtual TReturnType Execute()

Return Value

The result of execution.

Implements

ICommand<(Of <(<'TReturnType>)>)>..::..Execute()()()()

See Also

EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class
Sitecore.Data.Engines Namespace


Executed Method

[image]

Sitecore 6.4.1 API
EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..Executed Method
EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void Executed()
Visual Basic
Protected Overridable Sub Executed
Visual C++
protected:
virtual void Executed()

Remarks

This method is called right after the command has been executed.

The result of the execution can be accessed through the Result property.

See Also

EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class
Sitecore.Data.Engines Namespace


FinalizeExecution Method

[image]

Sitecore 6.4.1 API
EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..FinalizeExecution Method
EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void FinalizeExecution()
Visual Basic
Protected Overridable Sub FinalizeExecution
Visual C++
protected:
virtual void FinalizeExecution()

See Also

EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class
Sitecore.Data.Engines Namespace


PrepareExecution Method

[image]

Sitecore 6.4.1 API
EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..PrepareExecution Method
EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void PrepareExecution()
Visual Basic
Protected Overridable Sub PrepareExecution
Visual C++
protected:
virtual void PrepareExecution()

See Also

EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class
Sitecore.Data.Engines Namespace


RaiseExecuted Method

[image]

Sitecore 6.4.1 API
EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..RaiseExecuted Method
EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void RaiseExecuted()
Visual Basic
Public Overridable Sub RaiseExecuted
Visual C++
public:
virtual void RaiseExecuted()

See Also

EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class
Sitecore.Data.Engines Namespace


EngineCommand(TReturnType, TCommandType) Properties

[image] [image]

Sitecore 6.4.1 API
EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Properties
EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class See Also Send Feedback

The EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> type exposes the following members.

Properties

 | Name | Description
Protected property | ExecutedEvent | Gets the executed event.
Protected property | ExecutingEvent | Gets the executing event.
Public property | Result | Gets the result of the execution.

See Also

EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class
Sitecore.Data.Engines Namespace


ExecutedEvent Property

[image]

Sitecore 6.4.1 API
EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..ExecutedEvent Property
EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected EventHandler<ExecutedEventArgs<TCommandType>> ExecutedEvent { get; set; }
Visual Basic
Protected Property ExecutedEvent As EventHandler(Of ExecutedEventArgs(Of TCommandType))
    Get
    Set
Visual C++
protected:
property EventHandler<ExecutedEventArgs<TCommandType>^>^ ExecutedEvent {
    EventHandler<ExecutedEventArgs<TCommandType>^>^ get ();
    void set (EventHandler<ExecutedEventArgs<TCommandType>^>^ value);
}

Field Value

The executed event.

See Also

EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class
Sitecore.Data.Engines Namespace


ExecutingEvent Property

[image]

Sitecore 6.4.1 API
EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..ExecutingEvent Property
EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected EventHandler<ExecutingEventArgs<TCommandType>> ExecutingEvent { get; set; }
Visual Basic
Protected Property ExecutingEvent As EventHandler(Of ExecutingEventArgs(Of TCommandType))
    Get
    Set
Visual C++
protected:
property EventHandler<ExecutingEventArgs<TCommandType>^>^ ExecutingEvent {
    EventHandler<ExecutingEventArgs<TCommandType>^>^ get ();
    void set (EventHandler<ExecutingEventArgs<TCommandType>^>^ value);
}

Field Value

The executing event.

See Also

EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class
Sitecore.Data.Engines Namespace


Result Property

[image]

Sitecore 6.4.1 API
EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..Result Property
EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TReturnType Result { get; internal set; }
Visual Basic
Public Property Result As TReturnType
    Get
    Friend Set
Visual C++
public:
property TReturnType Result {
    TReturnType get ();
    internal: void set (TReturnType value);
}

Field Value

The result of execution. If the command has not been executed yet, the value will be default(TReturnType).

See Also

EngineCommand<(Of <(<'TReturnType, TCommandType>)>)> Class
Sitecore.Data.Engines Namespace


HistoryAction Enumeration

[image]

Sitecore 6.4.1 API
HistoryAction Enumeration
See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum HistoryAction
Visual Basic
Public Enumeration HistoryAction
Visual C++
public enum class HistoryAction

Members

Member name | Value | Description
Unknown | 0 | Unknown.
AddedVersion | 1 | A new version was added to an existing item.
Copied | 2 | An item was copied.
Created | 3 | An new item was created.
Deleted | 4 | An item was deleted.
Moved | 5 | An item was moved.
Saved | 6 | An item was saved.
RemovedVersion | 7 | A version was removed from an existing item.

See Also

Sitecore.Data.Engines Namespace


HistoryAddedEventArgs Class

[image]

Sitecore 6.4.1 API
HistoryAddedEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class HistoryAddedEventArgs : EventArgs
Visual Basic
Public Class HistoryAddedEventArgs _
    Inherits EventArgs
Visual C++
public ref class HistoryAddedEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Data.Engines..::..HistoryAddedEventArgs

See Also

HistoryAddedEventArgs Members
Sitecore.Data.Engines Namespace


HistoryAddedEventArgs Members

[image] [image]

Sitecore 6.4.1 API
HistoryAddedEventArgs Members
HistoryAddedEventArgs Class Constructors Methods Properties See Also Send Feedback

The HistoryAddedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | HistoryAddedEventArgs | Initializes a new instance of the HistoryAddedEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Database | Gets the database.
Public property | Entry | Gets the entry that was added.

See Also

HistoryAddedEventArgs Class
Sitecore.Data.Engines Namespace


HistoryAddedEventArgs Constructor

[image]

Sitecore 6.4.1 API
HistoryAddedEventArgs Constructor
HistoryAddedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HistoryAddedEventArgs(
    HistoryEntry entry,
    Database database
)
Visual Basic
Public Sub New ( _
    entry As HistoryEntry, _
    database As Database _
)
Visual C++
public:
HistoryAddedEventArgs(
    HistoryEntry^ entry,
    Database^ database
)

Parameters

entry
Type: Sitecore.Data.Engines..::..HistoryEntry

[Missing <param name="entry"/> documentation for "M:Sitecore.Data.Engines.HistoryAddedEventArgs.#ctor(Sitecore.Data.Engines.HistoryEntry,Sitecore.Data.Database)"]

database
Type: Sitecore.Data..::..Database

[Missing <param name="database"/> documentation for "M:Sitecore.Data.Engines.HistoryAddedEventArgs.#ctor(Sitecore.Data.Engines.HistoryEntry,Sitecore.Data.Database)"]

See Also

HistoryAddedEventArgs Class
Sitecore.Data.Engines Namespace


HistoryAddedEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
HistoryAddedEventArgs Methods
HistoryAddedEventArgs Class See Also Send Feedback

The HistoryAddedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HistoryAddedEventArgs Class
Sitecore.Data.Engines Namespace


HistoryAddedEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
HistoryAddedEventArgs Properties
HistoryAddedEventArgs Class See Also Send Feedback

The HistoryAddedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Database | Gets the database.
Public property | Entry | Gets the entry that was added.

See Also

HistoryAddedEventArgs Class
Sitecore.Data.Engines Namespace


Database Property

[image]

Sitecore 6.4.1 API
HistoryAddedEventArgs..::..Database Property
HistoryAddedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database Database { get; }
Visual Basic
Public ReadOnly Property Database As Database
    Get
Visual C++
public:
property Database^ Database {
    Database^ get ();
}

Field Value

The database.

See Also

HistoryAddedEventArgs Class
Sitecore.Data.Engines Namespace


Entry Property

[image]

Sitecore 6.4.1 API
HistoryAddedEventArgs..::..Entry Property
HistoryAddedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HistoryEntry Entry { get; }
Visual Basic
Public ReadOnly Property Entry As HistoryEntry
    Get
Visual C++
public:
property HistoryEntry^ Entry {
    HistoryEntry^ get ();
}

Field Value

The entry.

See Also

HistoryAddedEventArgs Class
Sitecore.Data.Engines Namespace


HistoryCategory Enumeration

[image]

Sitecore 6.4.1 API
HistoryCategory Enumeration
See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum HistoryCategory
Visual Basic
Public Enumeration HistoryCategory
Visual C++
public enum class HistoryCategory

Members

Member name | Value | Description
Unknown | 0 | Unknown.
Item | 1 | Item.

See Also

Sitecore.Data.Engines Namespace


HistoryEngine Class

[image]

Sitecore 6.4.1 API
HistoryEngine Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class HistoryEngine
Visual Basic
Public Class HistoryEngine
Visual C++
public ref class HistoryEngine

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Engines..::..HistoryEngine

See Also

HistoryEngine Members
Sitecore.Data.Engines Namespace


HistoryEngine Members

[image] [image]

Sitecore 6.4.1 API
HistoryEngine Members
HistoryEngine Class Constructors Methods Properties Events See Also Send Feedback

The HistoryEngine type exposes the following members.

Constructors

 | Name | Description
Public method | HistoryEngine | Constructs an instance of AuditEngine

Methods

 | Name | Description
Public method | Cleanup | Removes outdated entries from storage.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHistory | Gets the history for the database in a specified interval.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RegisterItemCopied | Registers an 'item created' event in the history storage.
Public method | RegisterItemCreated | Registers an 'item created' event in the history storage.
Public method | RegisterItemDeleted | Registers an 'item deleted' event in the history storage.
Public method | RegisterItemMoved | Registers an 'item moved' event in the history storage.
Public method | RegisterItemSaved | Registers an 'item saved' event in the history storage.
Public method | RegisterVersionAdded | Registers an 'version added' event in the history storage.
Public method | RegisterVersionRemoved | Registers an 'version removed' event in the history storage.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Database | Gets the database associated with the engine.
Public property | SaveDotNetCallStack | Gets or sets a value indicating whether the HistoryEngine saves the dot net call stack.
Public property | Storage | Gets the storage provider.

Events

 | Name | Description
Public event | AddedEntry |

See Also

HistoryEngine Class
Sitecore.Data.Engines Namespace


HistoryEngine Constructor

[image]

Sitecore 6.4.1 API
HistoryEngine Constructor
HistoryEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HistoryEngine(
    Database database
)
Visual Basic
Public Sub New ( _
    database As Database _
)
Visual C++
public:
HistoryEngine(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

See Also

HistoryEngine Class
Sitecore.Data.Engines Namespace


Cleanup Method

[image]

Sitecore 6.4.1 API
HistoryEngine..::..Cleanup Method
HistoryEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Cleanup()
Visual Basic
Public Sub Cleanup
Visual C++
public:
void Cleanup()

See Also

HistoryEngine Class
Sitecore.Data.Engines Namespace


GetHistory Method

[image]

Sitecore 6.4.1 API
HistoryEngine..::..GetHistory Method
HistoryEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HistoryEntryCollection GetHistory(
    DateTime from,
    DateTime to
)
Visual Basic
Public Function GetHistory ( _
    from As DateTime, _
    to As DateTime _
) As HistoryEntryCollection
Visual C++
public:
HistoryEntryCollection^ GetHistory(
    DateTime from,
    DateTime to
)

Parameters

from
Type: System..::..DateTime
From date (UTC).
to
Type: System..::..DateTime
To date (UTC).

Return Value

The history entries for the period.

See Also

HistoryEngine Class
Sitecore.Data.Engines Namespace


RegisterItemCopied Method

[image]

Sitecore 6.4.1 API
HistoryEngine..::..RegisterItemCopied Method
HistoryEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RegisterItemCopied(
    Item copiedItem,
    Item sourceItem
)
Visual Basic
Public Sub RegisterItemCopied ( _
    copiedItem As Item, _
    sourceItem As Item _
)
Visual C++
public:
void RegisterItemCopied(
    Item^ copiedItem,
    Item^ sourceItem
)

Parameters

copiedItem
Type: Sitecore.Data.Items..::..Item
The copied item.
sourceItem
Type: Sitecore.Data.Items..::..Item
The source item.

See Also

HistoryEngine Class
Sitecore.Data.Engines Namespace


RegisterItemCreated Method

[image]

Sitecore 6.4.1 API
HistoryEngine..::..RegisterItemCreated Method
HistoryEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RegisterItemCreated(
    Item item
)
Visual Basic
Public Sub RegisterItemCreated ( _
    item As Item _
)
Visual C++
public:
void RegisterItemCreated(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

HistoryEngine Class
Sitecore.Data.Engines Namespace


RegisterItemDeleted Method

[image]

Sitecore 6.4.1 API
HistoryEngine..::..RegisterItemDeleted Method
HistoryEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RegisterItemDeleted(
    Item item,
    ID oldParentId
)
Visual Basic
Public Sub RegisterItemDeleted ( _
    item As Item, _
    oldParentId As ID _
)
Visual C++
public:
void RegisterItemDeleted(
    Item^ item,
    ID^ oldParentId
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
oldParentId
Type: Sitecore.Data..::..ID
The old parent id.

See Also

HistoryEngine Class
Sitecore.Data.Engines Namespace


RegisterItemMoved Method

[image]

Sitecore 6.4.1 API
HistoryEngine..::..RegisterItemMoved Method
HistoryEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void RegisterItemMoved(
    Item item,
    ID oldParentId
)
Visual Basic
Public Overridable Sub RegisterItemMoved ( _
    item As Item, _
    oldParentId As ID _
)
Visual C++
public:
virtual void RegisterItemMoved(
    Item^ item,
    ID^ oldParentId
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
oldParentId
Type: Sitecore.Data..::..ID
The old parent id.

See Also

HistoryEngine Class
Sitecore.Data.Engines Namespace


RegisterItemSaved Method

[image]

Sitecore 6.4.1 API
HistoryEngine..::..RegisterItemSaved Method
HistoryEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RegisterItemSaved(
    Item item,
    ItemChanges changes
)
Visual Basic
Public Sub RegisterItemSaved ( _
    item As Item, _
    changes As ItemChanges _
)
Visual C++
public:
void RegisterItemSaved(
    Item^ item,
    ItemChanges^ changes
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
changes
Type: Sitecore.Data.Items..::..ItemChanges
The changes.

See Also

HistoryEngine Class
Sitecore.Data.Engines Namespace


RegisterVersionAdded Method

[image]

Sitecore 6.4.1 API
HistoryEngine..::..RegisterVersionAdded Method
HistoryEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RegisterVersionAdded(
    Item item
)
Visual Basic
Public Sub RegisterVersionAdded ( _
    item As Item _
)
Visual C++
public:
void RegisterVersionAdded(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The version that was added.

See Also

HistoryEngine Class
Sitecore.Data.Engines Namespace


RegisterVersionRemoved Method

[image]

Sitecore 6.4.1 API
HistoryEngine..::..RegisterVersionRemoved Method
HistoryEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void RegisterVersionRemoved(
    Item item
)
Visual Basic
Public Overridable Sub RegisterVersionRemoved ( _
    item As Item _
)
Visual C++
public:
virtual void RegisterVersionRemoved(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The version that was removed.

See Also

HistoryEngine Class
Sitecore.Data.Engines Namespace


HistoryEngine Properties

[image] [image]

Sitecore 6.4.1 API
HistoryEngine Properties
HistoryEngine Class See Also Send Feedback

The HistoryEngine type exposes the following members.

Properties

 | Name | Description
Public property | Database | Gets the database associated with the engine.
Public property | SaveDotNetCallStack | Gets or sets a value indicating whether the HistoryEngine saves the dot net call stack.
Public property | Storage | Gets the storage provider.

See Also

HistoryEngine Class
Sitecore.Data.Engines Namespace


Database Property

[image]

Sitecore 6.4.1 API
HistoryEngine..::..Database Property
HistoryEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database Database { get; }
Visual Basic
Public ReadOnly Property Database As Database
    Get
Visual C++
public:
property Database^ Database {
    Database^ get ();
}

Field Value

The database.

See Also

HistoryEngine Class
Sitecore.Data.Engines Namespace


SaveDotNetCallStack Property

[image]

Sitecore 6.4.1 API
HistoryEngine..::..SaveDotNetCallStack Property
HistoryEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool SaveDotNetCallStack { get; set; }
Visual Basic
Public Property SaveDotNetCallStack As Boolean
    Get
    Set
Visual C++
public:
property bool SaveDotNetCallStack {
    bool get ();
    void set (bool value);
}

Field Value

true if the HistoryEngine saves the dot net call stack; otherwise, false.

See Also

HistoryEngine Class
Sitecore.Data.Engines Namespace


Storage Property

[image]

Sitecore 6.4.1 API
HistoryEngine..::..Storage Property
HistoryEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HistoryStorage Storage { get; set; }
Visual Basic
Public Property Storage As HistoryStorage
    Get
    Set
Visual C++
public:
property HistoryStorage^ Storage {
    HistoryStorage^ get ();
    void set (HistoryStorage^ value);
}

Field Value

The storage.

See Also

HistoryEngine Class
Sitecore.Data.Engines Namespace


HistoryEngine Events

[image] [image]

Sitecore 6.4.1 API
HistoryEngine Events
HistoryEngine Class See Also Send Feedback

The HistoryEngine type exposes the following members.

Events

 | Name | Description
Public event | AddedEntry |

See Also

HistoryEngine Class
Sitecore.Data.Engines Namespace


AddedEntry Event

[image]

Sitecore 6.4.1 API
HistoryEngine..::..AddedEntry Event
HistoryEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler<HistoryAddedEventArgs> AddedEntry
Visual Basic
Public Event AddedEntry As EventHandler(Of HistoryAddedEventArgs)
Visual C++
public:
 event EventHandler<HistoryAddedEventArgs^>^ AddedEntry {
    void add (EventHandler<HistoryAddedEventArgs^>^ value);
    void remove (EventHandler<HistoryAddedEventArgs^>^ value);
}

See Also

HistoryEngine Class
Sitecore.Data.Engines Namespace


HistoryEntry Class

[image]

Sitecore 6.4.1 API
HistoryEntry Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class HistoryEntry
Visual Basic
Public Class HistoryEntry
Visual C++
public ref class HistoryEntry

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Engines..::..HistoryEntry

See Also

HistoryEntry Members
Sitecore.Data.Engines Namespace


HistoryEntry Members

[image] [image]

Sitecore 6.4.1 API
HistoryEntry Members
HistoryEntry Class Constructors Methods Properties See Also Send Feedback

The HistoryEntry type exposes the following members.

Constructors

 | Name | Description
Public method | HistoryEntry | Constructs an instance of HistoryEntry.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Action | Gets the action associated with the entry.
Public property | AdditionalInfo | Gets the additional info.
Public property | Category | Gets the category associated with the entry.
Public property | Created | Gets the creation date of the entry (UTC).
Public property | EntryId | Gets the unique id of the entry.
Public property | ItemId | Gets the item id associated with the entry.
Public property | ItemLanguage | Gets the item language associated with the entry.
Public property | ItemPath | Gets the item path.
Public property | ItemVersion | Gets the item version associated with the entry.
Public property | TaskStack | Gets the task stack.
Public property | UserName | Gets the name of the user that caused the entry to be created.

See Also

HistoryEntry Class
Sitecore.Data.Engines Namespace


HistoryEntry Constructor

[image]

Sitecore 6.4.1 API
HistoryEntry Constructor
HistoryEntry Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HistoryEntry(
    HistoryCategory category,
    HistoryAction action,
    Item item,
    ID parentId,
    string additionalInfo
)
Visual Basic
Public Sub New ( _
    category As HistoryCategory, _
    action As HistoryAction, _
    item As Item, _
    parentId As ID, _
    additionalInfo As String _
)
Visual C++
public:
HistoryEntry(
    HistoryCategory category,
    HistoryAction action,
    Item^ item,
    ID^ parentId,
    String^ additionalInfo
)

Parameters

category
Type: Sitecore.Data.Engines..::..HistoryCategory
The category.
action
Type: Sitecore.Data.Engines..::..HistoryAction
The action.
item
Type: Sitecore.Data.Items..::..Item
The item.
parentId
Type: Sitecore.Data..::..ID
The parent id.
additionalInfo
Type: System..::..String
The additional info.

See Also

HistoryEntry Class
Sitecore.Data.Engines Namespace


HistoryEntry Methods

[image] [image]

Sitecore 6.4.1 API
HistoryEntry Methods
HistoryEntry Class See Also Send Feedback

The HistoryEntry type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HistoryEntry Class
Sitecore.Data.Engines Namespace


HistoryEntry Properties

[image] [image]

Sitecore 6.4.1 API
HistoryEntry Properties
HistoryEntry Class See Also Send Feedback

The HistoryEntry type exposes the following members.

Properties

 | Name | Description
Public property | Action | Gets the action associated with the entry.
Public property | AdditionalInfo | Gets the additional info.
Public property | Category | Gets the category associated with the entry.
Public property | Created | Gets the creation date of the entry (UTC).
Public property | EntryId | Gets the unique id of the entry.
Public property | ItemId | Gets the item id associated with the entry.
Public property | ItemLanguage | Gets the item language associated with the entry.
Public property | ItemPath | Gets the item path.
Public property | ItemVersion | Gets the item version associated with the entry.
Public property | TaskStack | Gets the task stack.
Public property | UserName | Gets the name of the user that caused the entry to be created.

See Also

HistoryEntry Class
Sitecore.Data.Engines Namespace


Action Property

[image]

Sitecore 6.4.1 API
HistoryEntry..::..Action Property
HistoryEntry Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HistoryAction Action { get; }
Visual Basic
Public ReadOnly Property Action As HistoryAction
    Get
Visual C++
public:
property HistoryAction Action {
    HistoryAction get ();
}

Field Value

The action.

See Also

HistoryEntry Class
Sitecore.Data.Engines Namespace


AdditionalInfo Property

[image]

Sitecore 6.4.1 API
HistoryEntry..::..AdditionalInfo Property
HistoryEntry Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string AdditionalInfo { get; }
Visual Basic
Public ReadOnly Property AdditionalInfo As String
    Get
Visual C++
public:
property String^ AdditionalInfo {
    String^ get ();
}

Field Value

The additional info.

See Also

HistoryEntry Class
Sitecore.Data.Engines Namespace


Category Property

[image]

Sitecore 6.4.1 API
HistoryEntry..::..Category Property
HistoryEntry Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HistoryCategory Category { get; }
Visual Basic
Public ReadOnly Property Category As HistoryCategory
    Get
Visual C++
public:
property HistoryCategory Category {
    HistoryCategory get ();
}

Field Value

The category.

See Also

HistoryEntry Class
Sitecore.Data.Engines Namespace


Created Property

[image]

Sitecore 6.4.1 API
HistoryEntry..::..Created Property
HistoryEntry Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime Created { get; }
Visual Basic
Public ReadOnly Property Created As DateTime
    Get
Visual C++
public:
property DateTime Created {
    DateTime get ();
}

Field Value

The creation date (UTC).

See Also

HistoryEntry Class
Sitecore.Data.Engines Namespace


EntryId Property

[image]

Sitecore 6.4.1 API
HistoryEntry..::..EntryId Property
HistoryEntry Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID EntryId { get; }
Visual Basic
Public ReadOnly Property EntryId As ID
    Get
Visual C++
public:
property ID^ EntryId {
    ID^ get ();
}

Field Value

The entry id.

See Also

HistoryEntry Class
Sitecore.Data.Engines Namespace


ItemId Property

[image]

Sitecore 6.4.1 API
HistoryEntry..::..ItemId Property
HistoryEntry Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ItemId { get; }
Visual Basic
Public ReadOnly Property ItemId As ID
    Get
Visual C++
public:
property ID^ ItemId {
    ID^ get ();
}

Field Value

The item id.

See Also

HistoryEntry Class
Sitecore.Data.Engines Namespace


ItemLanguage Property

[image]

Sitecore 6.4.1 API
HistoryEntry..::..ItemLanguage Property
HistoryEntry Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Language ItemLanguage { get; }
Visual Basic
Public ReadOnly Property ItemLanguage As Language
    Get
Visual C++
public:
property Language^ ItemLanguage {
    Language^ get ();
}

Field Value

The item language.

See Also

HistoryEntry Class
Sitecore.Data.Engines Namespace


ItemPath Property

[image]

Sitecore 6.4.1 API
HistoryEntry..::..ItemPath Property
HistoryEntry Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ItemPath { get; }
Visual Basic
Public ReadOnly Property ItemPath As String
    Get
Visual C++
public:
property String^ ItemPath {
    String^ get ();
}

Field Value

The item path.

See Also

HistoryEntry Class
Sitecore.Data.Engines Namespace


ItemVersion Property

[image]

Sitecore 6.4.1 API
HistoryEntry..::..ItemVersion Property
HistoryEntry Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Version ItemVersion { get; }
Visual Basic
Public ReadOnly Property ItemVersion As Version
    Get
Visual C++
public:
property Version^ ItemVersion {
    Version^ get ();
}

Field Value

The item version.

See Also

HistoryEntry Class
Sitecore.Data.Engines Namespace


TaskStack Property

[image]

Sitecore 6.4.1 API
HistoryEntry..::..TaskStack Property
HistoryEntry Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string TaskStack { get; set; }
Visual Basic
Public Property TaskStack As String
    Get
    Set
Visual C++
public:
property String^ TaskStack {
    String^ get ();
    void set (String^ value);
}

Field Value

The task stack.

See Also

HistoryEntry Class
Sitecore.Data.Engines Namespace


UserName Property

[image]

Sitecore 6.4.1 API
HistoryEntry..::..UserName Property
HistoryEntry Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string UserName { get; }
Visual Basic
Public ReadOnly Property UserName As String
    Get
Visual C++
public:
property String^ UserName {
    String^ get ();
}

Field Value

The name of the user.

See Also

HistoryEntry Class
Sitecore.Data.Engines Namespace


HistoryEntry.Builder Class

[image]

Sitecore 6.4.1 API
HistoryEntry..::..Builder Class
HistoryEntry Class Members See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Builder
Visual Basic
Public Class Builder
Visual C++
public ref class Builder

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Engines..::..HistoryEntry..::..Builder

See Also

HistoryEntry..::..Builder Members
Sitecore.Data.Engines Namespace


HistoryEntry.Builder Members

[image] [image]

Sitecore 6.4.1 API
HistoryEntry..::..Builder Members
HistoryEntry..::..Builder Class Constructors Methods See Also Send Feedback

Defines an entry in the history.

The HistoryEntry..::..Builder type exposes the following members.

Constructors

 | Name | Description
Public method | HistoryEntry..::..Builder | Initializes a new instance of the HistoryEntry..::..Builder class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEntry | Creates an entry based in the current data.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetAction | Sets the action associated with the entry.
Public method | SetAdditionalInfo | Sets the additional information associated with the entry.
Public method | SetCategory | Sets the category associated with the entry.
Public method | SetCreated | Sets the creation date associated with the entry.
Public method | SetId | Sets the entry id associated with the entry.
Public method | SetItemId | Sets the item id associated with the entry.
Public method | SetItemLanguage | Sets the item language associated with the entry.
Public method | SetItemPath | Sets the item path associated with the entry.
Public method | SetItemVersion | Sets the item version associated with the entry.
Public method | SetTaskStack | Sets the task stack associated with the entry.
Public method | SetUserName | Sets the user name associated with the entry.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HistoryEntry..::..Builder Class
Sitecore.Data.Engines Namespace


HistoryEntry.Builder Constructor

[image]

Sitecore 6.4.1 API
HistoryEntry..::..Builder Constructor
HistoryEntry..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Builder()
Visual Basic
Public Sub New
Visual C++
public:
Builder()

See Also

HistoryEntry..::..Builder Class
Sitecore.Data.Engines Namespace


HistoryEntry.Builder Methods

[image] [image]

Sitecore 6.4.1 API
HistoryEntry..::..Builder Methods
HistoryEntry..::..Builder Class See Also Send Feedback

The HistoryEntry..::..Builder type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEntry | Creates an entry based in the current data.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetAction | Sets the action associated with the entry.
Public method | SetAdditionalInfo | Sets the additional information associated with the entry.
Public method | SetCategory | Sets the category associated with the entry.
Public method | SetCreated | Sets the creation date associated with the entry.
Public method | SetId | Sets the entry id associated with the entry.
Public method | SetItemId | Sets the item id associated with the entry.
Public method | SetItemLanguage | Sets the item language associated with the entry.
Public method | SetItemPath | Sets the item path associated with the entry.
Public method | SetItemVersion | Sets the item version associated with the entry.
Public method | SetTaskStack | Sets the task stack associated with the entry.
Public method | SetUserName | Sets the user name associated with the entry.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HistoryEntry..::..Builder Class
Sitecore.Data.Engines Namespace


GetEntry Method

[image]

Sitecore 6.4.1 API
HistoryEntry..::..Builder..::..GetEntry Method
HistoryEntry..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HistoryEntry GetEntry()
Visual Basic
Public Function GetEntry As HistoryEntry
Visual C++
public:
HistoryEntry^ GetEntry()

Return Value

The entry.

See Also

HistoryEntry..::..Builder Class
Sitecore.Data.Engines Namespace


SetAction Method

[image]

Sitecore 6.4.1 API
HistoryEntry..::..Builder..::..SetAction Method
HistoryEntry..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetAction(
    string actionName
)
Visual Basic
Public Sub SetAction ( _
    actionName As String _
)
Visual C++
public:
void SetAction(
    String^ actionName
)

Parameters

actionName
Type: System..::..String
Name of the action.

See Also

HistoryEntry..::..Builder Class
Sitecore.Data.Engines Namespace


SetAdditionalInfo Method

[image]

Sitecore 6.4.1 API
HistoryEntry..::..Builder..::..SetAdditionalInfo Method
HistoryEntry..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetAdditionalInfo(
    string additionalInfo
)
Visual Basic
Public Sub SetAdditionalInfo ( _
    additionalInfo As String _
)
Visual C++
public:
void SetAdditionalInfo(
    String^ additionalInfo
)

Parameters

additionalInfo
Type: System..::..String
The additional info.

See Also

HistoryEntry..::..Builder Class
Sitecore.Data.Engines Namespace


SetCreated Method

[image]

Sitecore 6.4.1 API
HistoryEntry..::..Builder..::..SetCreated Method
HistoryEntry..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetCreated(
    DateTime created
)
Visual Basic
Public Sub SetCreated ( _
    created As DateTime _
)
Visual C++
public:
void SetCreated(
    DateTime created
)

Parameters

created
Type: System..::..DateTime
The creation date (UTC).

See Also

HistoryEntry..::..Builder Class
Sitecore.Data.Engines Namespace


SetId Method

[image]

Sitecore 6.4.1 API
HistoryEntry..::..Builder..::..SetId Method
HistoryEntry..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetId(
    ID id
)
Visual Basic
Public Sub SetId ( _
    id As ID _
)
Visual C++
public:
void SetId(
    ID^ id
)

Parameters

id
Type: Sitecore.Data..::..ID
The id.

See Also

HistoryEntry..::..Builder Class
Sitecore.Data.Engines Namespace


SetItemId Method

[image]

Sitecore 6.4.1 API
HistoryEntry..::..Builder..::..SetItemId Method
HistoryEntry..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetItemId(
    ID itemId
)
Visual Basic
Public Sub SetItemId ( _
    itemId As ID _
)
Visual C++
public:
void SetItemId(
    ID^ itemId
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.

See Also

HistoryEntry..::..Builder Class
Sitecore.Data.Engines Namespace


SetItemLanguage Method

[image]

Sitecore 6.4.1 API
HistoryEntry..::..Builder..::..SetItemLanguage Method
HistoryEntry..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetItemLanguage(
    Language itemLanguage
)
Visual Basic
Public Sub SetItemLanguage ( _
    itemLanguage As Language _
)
Visual C++
public:
void SetItemLanguage(
    Language^ itemLanguage
)

Parameters

itemLanguage
Type: Sitecore.Globalization..::..Language
The item language.

See Also

HistoryEntry..::..Builder Class
Sitecore.Data.Engines Namespace


SetItemPath Method

[image]

Sitecore 6.4.1 API
HistoryEntry..::..Builder..::..SetItemPath Method
HistoryEntry..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetItemPath(
    string itemPath
)
Visual Basic
Public Sub SetItemPath ( _
    itemPath As String _
)
Visual C++
public:
void SetItemPath(
    String^ itemPath
)

Parameters

itemPath
Type: System..::..String
The item path.

See Also

HistoryEntry..::..Builder Class
Sitecore.Data.Engines Namespace


SetItemVersion Method

[image]

Sitecore 6.4.1 API
HistoryEntry..::..Builder..::..SetItemVersion Method
HistoryEntry..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetItemVersion(
    Version itemVersion
)
Visual Basic
Public Sub SetItemVersion ( _
    itemVersion As Version _
)
Visual C++
public:
void SetItemVersion(
    Version^ itemVersion
)

Parameters

itemVersion
Type: Sitecore.Data..::..Version
The item version.

See Also

HistoryEntry..::..Builder Class
Sitecore.Data.Engines Namespace


SetTaskStack Method

[image]

Sitecore 6.4.1 API
HistoryEntry..::..Builder..::..SetTaskStack Method
HistoryEntry..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetTaskStack(
    string taskStack
)
Visual Basic
Public Sub SetTaskStack ( _
    taskStack As String _
)
Visual C++
public:
void SetTaskStack(
    String^ taskStack
)

Parameters

taskStack
Type: System..::..String
The task stack.

See Also

HistoryEntry..::..Builder Class
Sitecore.Data.Engines Namespace


SetUserName Method

[image]

Sitecore 6.4.1 API
HistoryEntry..::..Builder..::..SetUserName Method
HistoryEntry..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetUserName(
    string userName
)
Visual Basic
Public Sub SetUserName ( _
    userName As String _
)
Visual C++
public:
void SetUserName(
    String^ userName
)

Parameters

userName
Type: System..::..String
Name of the user.

See Also

HistoryEntry..::..Builder Class
Sitecore.Data.Engines Namespace


HistoryStorage Class

[image]

Sitecore 6.4.1 API
HistoryStorage Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class HistoryStorage
Visual Basic
Public MustInherit Class HistoryStorage
Visual C++
public ref class HistoryStorage abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Engines..::..HistoryStorage
Sitecore.Data.SqlServer..::..SqlServerHistoryStorage

See Also

HistoryStorage Members
Sitecore.Data.Engines Namespace


HistoryStorage Members

[image] [image]

Sitecore 6.4.1 API
HistoryStorage Members
HistoryStorage Class Constructors Methods Properties See Also Send Feedback

The HistoryStorage type exposes the following members.

Constructors

 | Name | Description
Protected method | HistoryStorage | Initializes a new instance of the HistoryStorage class

Methods

 | Name | Description
Public method | AddEntry | Adds an entry to the history storage.
Public method | Cleanup | Removes outdated entries from storage.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHistory | Gets the history for the database in a specified interval.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EntryLifeTime | Gets or sets the entry life time.

See Also

HistoryStorage Class
Sitecore.Data.Engines Namespace


HistoryStorage Constructor

[image]

Sitecore 6.4.1 API
HistoryStorage Constructor
HistoryStorage Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected HistoryStorage()
Visual Basic
Protected Sub New
Visual C++
protected:
HistoryStorage()

See Also

HistoryStorage Class
Sitecore.Data.Engines Namespace


HistoryStorage Methods

[image] [image]

Sitecore 6.4.1 API
HistoryStorage Methods
HistoryStorage Class See Also Send Feedback

The HistoryStorage type exposes the following members.

Methods

 | Name | Description
Public method | AddEntry | Adds an entry to the history storage.
Public method | Cleanup | Removes outdated entries from storage.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHistory | Gets the history for the database in a specified interval.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HistoryStorage Class
Sitecore.Data.Engines Namespace


AddEntry Method

[image]

Sitecore 6.4.1 API
HistoryStorage..::..AddEntry Method
HistoryStorage Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract void AddEntry(
    HistoryEntry entry
)
Visual Basic
Public MustOverride Sub AddEntry ( _
    entry As HistoryEntry _
)
Visual C++
public:
virtual void AddEntry(
    HistoryEntry^ entry
) abstract

Parameters

entry
Type: Sitecore.Data.Engines..::..HistoryEntry
The entry.

See Also

HistoryStorage Class
Sitecore.Data.Engines Namespace


Cleanup Method

[image]

Sitecore 6.4.1 API
HistoryStorage..::..Cleanup Method
HistoryStorage Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Cleanup()
Visual Basic
Public Overridable Sub Cleanup
Visual C++
public:
virtual void Cleanup()

See Also

HistoryStorage Class
Sitecore.Data.Engines Namespace


GetHistory Method

[image]

Sitecore 6.4.1 API
HistoryStorage..::..GetHistory Method
HistoryStorage Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract HistoryEntryCollection GetHistory(
    DateTime from,
    DateTime to
)
Visual Basic
Public MustOverride Function GetHistory ( _
    from As DateTime, _
    to As DateTime _
) As HistoryEntryCollection
Visual C++
public:
virtual HistoryEntryCollection^ GetHistory(
    DateTime from,
    DateTime to
) abstract

Parameters

from
Type: System..::..DateTime
From date (UTC).
to
Type: System..::..DateTime
To date (UTC).

Return Value

The history entries for the period.

See Also

HistoryStorage Class
Sitecore.Data.Engines Namespace


HistoryStorage Properties

[image] [image]

Sitecore 6.4.1 API
HistoryStorage Properties
HistoryStorage Class See Also Send Feedback

The HistoryStorage type exposes the following members.

Properties

 | Name | Description
Public property | EntryLifeTime | Gets or sets the entry life time.

See Also

HistoryStorage Class
Sitecore.Data.Engines Namespace


EntryLifeTime Property

[image]

Sitecore 6.4.1 API
HistoryStorage..::..EntryLifeTime Property
HistoryStorage Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual TimeSpan EntryLifeTime { get; set; }
Visual Basic
Public Overridable Property EntryLifeTime As TimeSpan
    Get
    Set
Visual C++
public:
virtual property TimeSpan EntryLifeTime {
    TimeSpan get ();
    void set (TimeSpan value);
}

Field Value

The entry life time.

See Also

HistoryStorage Class
Sitecore.Data.Engines Namespace


SyncOperationContext Class

[image]

Sitecore 6.4.1 API
SyncOperationContext Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SyncOperationContext : Switcher<bool, SyncOperationContext>
Visual Basic
Public Class SyncOperationContext _
    Inherits Switcher(Of Boolean, SyncOperationContext)
Visual C++
public ref class SyncOperationContext : public Switcher<bool, SyncOperationContext^>

Inheritance Hierarchy

System..::..Object
Sitecore.Common..::..Switcher <(Of <(<' Boolean, SyncOperationContext>)>)>
Sitecore.Data.Engines..::..SyncOperationContext

See Also

SyncOperationContext Members
Sitecore.Data.Engines Namespace


SyncOperationContext Members

[image] [image]

Sitecore 6.4.1 API
SyncOperationContext Members
SyncOperationContext Class Constructors Methods Events See Also Send Feedback

The SyncOperationContext type exposes the following members.

Constructors

 | Name | Description
Public method | SyncOperationContext()()()() | Initializes a new instance of the SyncOperationContext class.
Public method | SyncOperationContext(Boolean) | Initializes a new instance of the SyncOperationContext class.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Switcher<(Of <(<'TValue, TSwitchType>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

 | Name | Description
Protected event | Disposed | Occurs when the object has been disposed. (Inherited from Switcher<(Of <(<'TValue, TSwitchType>)>)>.)

See Also

SyncOperationContext Class
Sitecore.Data.Engines Namespace


SyncOperationContext Constructor

[image] [image]

Sitecore 6.4.1 API
SyncOperationContext Constructor
SyncOperationContext Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SyncOperationContext()()()() | Initializes a new instance of the SyncOperationContext class.
Public method | SyncOperationContext(Boolean) | Initializes a new instance of the SyncOperationContext class.

See Also

SyncOperationContext Class
SyncOperationContext Members
Sitecore.Data.Engines Namespace


SyncOperationContext Constructor

[image]

Sitecore 6.4.1 API
SyncOperationContext Constructor
SyncOperationContext Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SyncOperationContext()
Visual Basic
Public Sub New
Visual C++
public:
SyncOperationContext()

See Also

SyncOperationContext Class
SyncOperationContext Overload
Sitecore.Data.Engines Namespace


SyncOperationContext Constructor (Boolean)

[image]

Sitecore 6.4.1 API
SyncOperationContext Constructor (Boolean)
SyncOperationContext Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SyncOperationContext(
    bool enable
)
Visual Basic
Public Sub New ( _
    enable As Boolean _
)
Visual C++
public:
SyncOperationContext(
    bool enable
)

Parameters

enable
Type: System..::..Boolean
if set to true this switch should be enabled.

See Also

SyncOperationContext Class
SyncOperationContext Overload
Sitecore.Data.Engines Namespace


SyncOperationContext Methods

[image] [image]

Sitecore 6.4.1 API
SyncOperationContext Methods
SyncOperationContext Class See Also Send Feedback

The SyncOperationContext type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Switcher<(Of <(<'TValue, TSwitchType>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SyncOperationContext Class
Sitecore.Data.Engines Namespace


SyncOperationContext Events

[image] [image]

Sitecore 6.4.1 API
SyncOperationContext Events
SyncOperationContext Class See Also Send Feedback

The SyncOperationContext type exposes the following members.

Events

 | Name | Description
Protected event | Disposed | Occurs when the object has been disposed. (Inherited from Switcher<(Of <(<'TValue, TSwitchType>)>)>.)

See Also

SyncOperationContext Class
Sitecore.Data.Engines Namespace


TemplateEngine Class

[image]

Sitecore 6.4.1 API
TemplateEngine Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class TemplateEngine
Visual Basic
Public Class TemplateEngine
Visual C++
public ref class TemplateEngine

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Engines..::..TemplateEngine

See Also

TemplateEngine Members
Sitecore.Data.Engines Namespace


TemplateEngine Members

[image] [image]

Sitecore 6.4.1 API
TemplateEngine Members
TemplateEngine Class Constructors Methods Properties See Also Send Feedback

The TemplateEngine type exposes the following members.

Constructors

 | Name | Description
Public method | TemplateEngine | Constructs an instance of TemplateEngine

Methods

 | Name | Description
Public method | ChangeFieldSharing | Changes the type of field sharing for a single field.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTemplate(String) | Gets a template with a specific full name.
Public method | GetTemplate(ID) | Gets a template with a specific id.
Public method | GetTemplates | Gets the templates.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsTemplate(Item) | Determines whether an item is a templatepart.
Protected method | IsTemplate(ID, String) | Determines whether the specified template id is template.
Public method | IsTemplatePart | Determines whether an item is a template part.
Public method | IsTemplateSection(Item) | Determines whether item is template section.
Public method | IsTemplateSection(ItemDefinition) | Determines whether item is template section.
Protected method | IsTemplateSection(ID, String) | Determines whether is template section the specified template id.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Resets the engine.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DataEngine | Gets the data engine of the owner database.
Public property | DataManager | Gets the data manager.
Public property | DataSource | Gets the data source.

See Also

TemplateEngine Class
Sitecore.Data.Engines Namespace


TemplateEngine Constructor

[image]

Sitecore 6.4.1 API
TemplateEngine Constructor
TemplateEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateEngine(
    Database database
)
Visual Basic
Public Sub New ( _
    database As Database _
)
Visual C++
public:
TemplateEngine(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

See Also

TemplateEngine Class
Sitecore.Data.Engines Namespace


TemplateEngine Methods

[image] [image]

Sitecore 6.4.1 API
TemplateEngine Methods
TemplateEngine Class See Also Send Feedback

The TemplateEngine type exposes the following members.

Methods

 | Name | Description
Public method | ChangeFieldSharing | Changes the type of field sharing for a single field.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTemplate(String) | Gets a template with a specific full name.
Public method | GetTemplate(ID) | Gets a template with a specific id.
Public method | GetTemplates | Gets the templates.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsTemplate(Item) | Determines whether an item is a templatepart.
Protected method | IsTemplate(ID, String) | Determines whether the specified template id is template.
Public method | IsTemplatePart | Determines whether an item is a template part.
Public method | IsTemplateSection(Item) | Determines whether item is template section.
Public method | IsTemplateSection(ItemDefinition) | Determines whether item is template section.
Protected method | IsTemplateSection(ID, String) | Determines whether is template section the specified template id.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Resets the engine.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TemplateEngine Class
Sitecore.Data.Engines Namespace


GetTemplate Method

[image] [image]

Sitecore 6.4.1 API
TemplateEngine..::..GetTemplate Method
TemplateEngine Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTemplate(String) | Gets a template with a specific full name.
Public method | GetTemplate(ID) | Gets a template with a specific id.

See Also

TemplateEngine Class
TemplateEngine Members
Sitecore.Data.Engines Namespace


GetTemplate Method (ID)

[image]

Sitecore 6.4.1 API
TemplateEngine..::..GetTemplate Method (ID)
TemplateEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Template GetTemplate(
    ID templateId
)
Visual Basic
Public Function GetTemplate ( _
    templateId As ID _
) As Template
Visual C++
public:
Template^ GetTemplate(
    ID^ templateId
)

Parameters

templateId
Type: Sitecore.Data..::..ID
The template id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Engines.TemplateEngine.GetTemplate(Sitecore.Data.ID)"]

See Also

TemplateEngine Class
GetTemplate Overload
Sitecore.Data.Engines Namespace


GetTemplates Method

[image]

Sitecore 6.4.1 API
TemplateEngine..::..GetTemplates Method
TemplateEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateDictionary GetTemplates()
Visual Basic
Public Function GetTemplates As TemplateDictionary
Visual C++
public:
TemplateDictionary^ GetTemplates()

Return Value

The templates.

See Also

TemplateEngine Class
Sitecore.Data.Engines Namespace


IsTemplate Method

[image] [image]

Sitecore 6.4.1 API
TemplateEngine..::..IsTemplate Method
TemplateEngine Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsTemplate(Item) | Determines whether an item is a templatepart.
Protected method | IsTemplate(ID, String) | Determines whether the specified template id is template.

See Also

TemplateEngine Class
TemplateEngine Members
Sitecore.Data.Engines Namespace


IsTemplate Method (Item)

[image]

Sitecore 6.4.1 API
TemplateEngine..::..IsTemplate Method (Item)
TemplateEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsTemplate(
    Item item
)
Visual Basic
Public Function IsTemplate ( _
    item As Item _
) As Boolean
Visual C++
public:
bool IsTemplate(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

true if the item is a template; otherwise, false.

See Also

TemplateEngine Class
IsTemplate Overload
Sitecore.Data.Engines Namespace


IsTemplatePart Method

[image]

Sitecore 6.4.1 API
TemplateEngine..::..IsTemplatePart Method
TemplateEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsTemplatePart(
    Item item
)
Visual Basic
Public Function IsTemplatePart ( _
    item As Item _
) As Boolean
Visual C++
public:
bool IsTemplatePart(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

true if the item is a template part; otherwise, false.

See Also

TemplateEngine Class
Sitecore.Data.Engines Namespace


IsTemplateSection Method

[image] [image]

Sitecore 6.4.1 API
TemplateEngine..::..IsTemplateSection Method
TemplateEngine Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsTemplateSection(Item) | Determines whether item is template section.
Public method | IsTemplateSection(ItemDefinition) | Determines whether item is template section.
Protected method | IsTemplateSection(ID, String) | Determines whether is template section the specified template id.

See Also

TemplateEngine Class
TemplateEngine Members
Sitecore.Data.Engines Namespace


IsTemplateSection Method (ItemDefinition)

[image]

Sitecore 6.4.1 API
TemplateEngine..::..IsTemplateSection Method (ItemDefinition)
TemplateEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsTemplateSection(
    ItemDefinition item
)
Visual Basic
Public Function IsTemplateSection ( _
    item As ItemDefinition _
) As Boolean
Visual C++
public:
bool IsTemplateSection(
    ItemDefinition^ item
)

Parameters

item
Type: Sitecore.Data..::..ItemDefinition
The item.

Return Value

true if [is template section] [the specified item]; otherwise, false.

See Also

TemplateEngine Class
IsTemplateSection Overload
Sitecore.Data.Engines Namespace


IsTemplateSection Method (ID, String)

[image]

Sitecore 6.4.1 API
TemplateEngine..::..IsTemplateSection Method (ID, String)
TemplateEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected bool IsTemplateSection(
    ID templateId,
    string itemName
)
Visual Basic
Protected Function IsTemplateSection ( _
    templateId As ID, _
    itemName As String _
) As Boolean
Visual C++
protected:
bool IsTemplateSection(
    ID^ templateId,
    String^ itemName
)

Parameters

templateId
Type: Sitecore.Data..::..ID
The template id.
itemName
Type: System..::..String
Name of the item.

Return Value

true if [is template section] [the specified template id]; otherwise, false.

See Also

TemplateEngine Class
IsTemplateSection Overload
Sitecore.Data.Engines Namespace


Reset Method

[image]

Sitecore 6.4.1 API
TemplateEngine..::..Reset Method
TemplateEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset
Visual C++
public:
void Reset()

See Also

TemplateEngine Class
Sitecore.Data.Engines Namespace


TemplateEngine Properties

[image] [image]

Sitecore 6.4.1 API
TemplateEngine Properties
TemplateEngine Class See Also Send Feedback

The TemplateEngine type exposes the following members.

Properties

 | Name | Description
Public property | DataEngine | Gets the data engine of the owner database.
Public property | DataManager | Gets the data manager.
Public property | DataSource | Gets the data source.

See Also

TemplateEngine Class
Sitecore.Data.Engines Namespace


DataEngine Property

[image]

Sitecore 6.4.1 API
TemplateEngine..::..DataEngine Property
TemplateEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataEngine DataEngine { get; }
Visual Basic
Public ReadOnly Property DataEngine As DataEngine
    Get
Visual C++
public:
property DataEngine^ DataEngine {
    DataEngine^ get ();
}

Field Value

The data engine.

See Also

TemplateEngine Class
Sitecore.Data.Engines Namespace


DataManager Property

[image]

Sitecore 6.4.1 API
TemplateEngine..::..DataManager Property
TemplateEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataManager DataManager { get; }
Visual Basic
Public ReadOnly Property DataManager As DataManager
    Get
Visual C++
public:
property DataManager^ DataManager {
    DataManager^ get ();
}

Field Value

The data manager.

See Also

TemplateEngine Class
Sitecore.Data.Engines Namespace


DataSource Property

[image]

Sitecore 6.4.1 API
TemplateEngine..::..DataSource Property
TemplateEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataSource DataSource { get; }
Visual Basic
Public ReadOnly Property DataSource As DataSource
    Get
Visual C++
public:
property DataSource^ DataSource {
    DataSource^ get ();
}

Field Value

The data source.

See Also

TemplateEngine Class
Sitecore.Data.Engines Namespace


WorkflowEngine Members

[image] [image]

Sitecore 6.4.1 API
WorkflowEngine Members
WorkflowEngine Class Constructors Methods See Also Send Feedback

The WorkflowEngine type exposes the following members.

Constructors

 | Name | Description
Public method | WorkflowEngine | Initializes a new instance of the DataEngine class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WorkflowEngine Class
Sitecore.Data.Engines Namespace


WorkflowEngine Constructor

[image]

Sitecore 6.4.1 API
WorkflowEngine Constructor
WorkflowEngine Class See Also Send Feedback

Namespace: Sitecore.Data.Engines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WorkflowEngine(
    Database database
)
Visual Basic
Public Sub New ( _
    database As Database _
)
Visual C++
public:
WorkflowEngine(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

See Also

WorkflowEngine Class
Sitecore.Data.Engines Namespace


WorkflowEngine Methods

[image] [image]

Sitecore 6.4.1 API
WorkflowEngine Methods
WorkflowEngine Class See Also Send Feedback

The WorkflowEngine type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WorkflowEngine Class
Sitecore.Data.Engines Namespace


Sitecore.Data.Engines.Data Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Data.Engines.Data Namespace
Send Feedback

Classes

 | Class | Description
Public class | CommandCollection | Command collection for DataEngine


CommandCollection Class

[image]

Sitecore 6.4.1 API
CommandCollection Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Engines.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CommandCollection
Visual Basic
Public Class CommandCollection
Visual C++
public ref class CommandCollection

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Engines.Data..::..CommandCollection

See Also

CommandCollection Members
Sitecore.Data.Engines.Data Namespace


CommandCollection Members

[image] [image]

Sitecore 6.4.1 API
CommandCollection Members
CommandCollection Class Constructors Methods Properties See Also Send Feedback

The CommandCollection type exposes the following members.

Constructors

 | Name | Description
Public method | CommandCollection | Initializes a new instance of the CommandCollection class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AddFromTemplatePrototype | Gets the prototype for creating instances of AddFromTemplateCommand objects.
Public property | AddVersionPrototype | Gets the prototype for creating instances of AddVersionCommand objects.
Public property | BlobStreamExistsPrototype | Gets the prototype for creating instances of BlobStreamExistsCommand objects.
Public property | CopyItemPrototype | Gets the prototype for creating instances of CopyItemCommand objects.
Public property | CreateItemPrototype | Gets the prototype for creating instances of CreateItemCommand objects.
Public property | DeletePrototype | Gets the prototype for creating instances of DeleteItemCommand objects.
Public property | GetBlobStreamPrototype | Gets the prototype for creating instances of GetBlobStreamCommand objects.
Public property | GetChildrenPrototype | Gets the prototype for creating instances of GetChildrenCommand objects.
Public property | GetItemPrototype | Gets the prototype for creating instances of GetItemCommand objects.
Public property | GetParentPrototype | Gets the prototype for creating instances of GetParentCommand objects.
Public property | GetRootItemPrototype | Gets the prototype for creating instances of GetRootItemCommand objects.
Public property | GetVersionsPrototype | Gets the prototype for creating instances of GetVersionsCommand objects.
Public property | HasChildrenPrototype | Gets the prototype for creating instances of HasChildrenCommand objects.
Public property | MoveItemPrototype | Gets the prototype for creating instances of MoveItemCommand objects.
Public property | RemoveDataPrototype | Gets the prototype for creating instances of RemoveDataCommand objects.
Public property | RemoveVersionPrototype | Gets the prototype for creating instances of RemoveVersionCommand objects.
Public property | ResolvePathPrototype | Gets the prototype for creating instances of ResolvePathCommand objects.
Public property | SaveItemPrototype | Gets the prototype for creating instances of SaveItemCommand objects.
Public property | SetBlobStreamPrototype | Gets the prototype for creating instances of SetBlobStreamCommand objects.

See Also

CommandCollection Class
Sitecore.Data.Engines.Data Namespace


CommandCollection Constructor

[image]

Sitecore 6.4.1 API
CommandCollection Constructor
CommandCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CommandCollection(
    DataEngine engine
)
Visual Basic
Public Sub New ( _
    engine As DataEngine _
)
Visual C++
public:
CommandCollection(
    DataEngine^ engine
)

Parameters

engine
Type: Sitecore.Data.Engines..::..DataEngine
The engine.

See Also

CommandCollection Class
Sitecore.Data.Engines.Data Namespace


CommandCollection Methods

[image] [image]

Sitecore 6.4.1 API
CommandCollection Methods
CommandCollection Class See Also Send Feedback

The CommandCollection type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CommandCollection Class
Sitecore.Data.Engines.Data Namespace


CommandCollection Properties

[image] [image]

Sitecore 6.4.1 API
CommandCollection Properties
CommandCollection Class See Also Send Feedback

The CommandCollection type exposes the following members.

Properties

 | Name | Description
Public property | AddFromTemplatePrototype | Gets the prototype for creating instances of AddFromTemplateCommand objects.
Public property | AddVersionPrototype | Gets the prototype for creating instances of AddVersionCommand objects.
Public property | BlobStreamExistsPrototype | Gets the prototype for creating instances of BlobStreamExistsCommand objects.
Public property | CopyItemPrototype | Gets the prototype for creating instances of CopyItemCommand objects.
Public property | CreateItemPrototype | Gets the prototype for creating instances of CreateItemCommand objects.
Public property | DeletePrototype | Gets the prototype for creating instances of DeleteItemCommand objects.
Public property | GetBlobStreamPrototype | Gets the prototype for creating instances of GetBlobStreamCommand objects.
Public property | GetChildrenPrototype | Gets the prototype for creating instances of GetChildrenCommand objects.
Public property | GetItemPrototype | Gets the prototype for creating instances of GetItemCommand objects.
Public property | GetParentPrototype | Gets the prototype for creating instances of GetParentCommand objects.
Public property | GetRootItemPrototype | Gets the prototype for creating instances of GetRootItemCommand objects.
Public property | GetVersionsPrototype | Gets the prototype for creating instances of GetVersionsCommand objects.
Public property | HasChildrenPrototype | Gets the prototype for creating instances of HasChildrenCommand objects.
Public property | MoveItemPrototype | Gets the prototype for creating instances of MoveItemCommand objects.
Public property | RemoveDataPrototype | Gets the prototype for creating instances of RemoveDataCommand objects.
Public property | RemoveVersionPrototype | Gets the prototype for creating instances of RemoveVersionCommand objects.
Public property | ResolvePathPrototype | Gets the prototype for creating instances of ResolvePathCommand objects.
Public property | SaveItemPrototype | Gets the prototype for creating instances of SaveItemCommand objects.
Public property | SetBlobStreamPrototype | Gets the prototype for creating instances of SetBlobStreamCommand objects.

See Also

CommandCollection Class
Sitecore.Data.Engines.Data Namespace


AddFromTemplatePrototype Property

[image]

Sitecore 6.4.1 API
CommandCollection..::..AddFromTemplatePrototype Property
CommandCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AddFromTemplateCommand AddFromTemplatePrototype { get; set; }
Visual Basic
Public Property AddFromTemplatePrototype As AddFromTemplateCommand
    Get
    Set
Visual C++
public:
property AddFromTemplateCommand^ AddFromTemplatePrototype {
    AddFromTemplateCommand^ get ();
    void set (AddFromTemplateCommand^ value);
}

Field Value

The prototype.

See Also

CommandCollection Class
Sitecore.Data.Engines.Data Namespace


AddVersionPrototype Property

[image]

Sitecore 6.4.1 API
CommandCollection..::..AddVersionPrototype Property
CommandCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AddVersionCommand AddVersionPrototype { get; set; }
Visual Basic
Public Property AddVersionPrototype As AddVersionCommand
    Get
    Set
Visual C++
public:
property AddVersionCommand^ AddVersionPrototype {
    AddVersionCommand^ get ();
    void set (AddVersionCommand^ value);
}

Field Value

The prototype.

See Also

CommandCollection Class
Sitecore.Data.Engines.Data Namespace


BlobStreamExistsPrototype Property

[image]

Sitecore 6.4.1 API
CommandCollection..::..BlobStreamExistsPrototype Property
CommandCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BlobStreamExistsCommand BlobStreamExistsPrototype { get; set; }
Visual Basic
Public Property BlobStreamExistsPrototype As BlobStreamExistsCommand
    Get
    Set
Visual C++
public:
property BlobStreamExistsCommand^ BlobStreamExistsPrototype {
    BlobStreamExistsCommand^ get ();
    void set (BlobStreamExistsCommand^ value);
}

Field Value

The prototype.

See Also

CommandCollection Class
Sitecore.Data.Engines.Data Namespace


CopyItemPrototype Property

[image]

Sitecore 6.4.1 API
CommandCollection..::..CopyItemPrototype Property
CommandCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CopyItemCommand CopyItemPrototype { get; set; }
Visual Basic
Public Property CopyItemPrototype As CopyItemCommand
    Get
    Set
Visual C++
public:
property CopyItemCommand^ CopyItemPrototype {
    CopyItemCommand^ get ();
    void set (CopyItemCommand^ value);
}

Field Value

The prototype.

See Also

CommandCollection Class
Sitecore.Data.Engines.Data Namespace


CreateItemPrototype Property

[image]

Sitecore 6.4.1 API
CommandCollection..::..CreateItemPrototype Property
CommandCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CreateItemCommand CreateItemPrototype { get; set; }
Visual Basic
Public Property CreateItemPrototype As CreateItemCommand
    Get
    Set
Visual C++
public:
property CreateItemCommand^ CreateItemPrototype {
    CreateItemCommand^ get ();
    void set (CreateItemCommand^ value);
}

Field Value

The prototype.

See Also

CommandCollection Class
Sitecore.Data.Engines.Data Namespace


DeletePrototype Property

[image]

Sitecore 6.4.1 API
CommandCollection..::..DeletePrototype Property
CommandCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DeleteItemCommand DeletePrototype { get; set; }
Visual Basic
Public Property DeletePrototype As DeleteItemCommand
    Get
    Set
Visual C++
public:
property DeleteItemCommand^ DeletePrototype {
    DeleteItemCommand^ get ();
    void set (DeleteItemCommand^ value);
}

Field Value

The prototype.

See Also

CommandCollection Class
Sitecore.Data.Engines.Data Namespace


GetBlobStreamPrototype Property

[image]

Sitecore 6.4.1 API
CommandCollection..::..GetBlobStreamPrototype Property
CommandCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetBlobStreamCommand GetBlobStreamPrototype { get; set; }
Visual Basic
Public Property GetBlobStreamPrototype As GetBlobStreamCommand
    Get
    Set
Visual C++
public:
property GetBlobStreamCommand^ GetBlobStreamPrototype {
    GetBlobStreamCommand^ get ();
    void set (GetBlobStreamCommand^ value);
}

Field Value

The prototype.

See Also

CommandCollection Class
Sitecore.Data.Engines.Data Namespace


GetChildrenPrototype Property

[image]

Sitecore 6.4.1 API
CommandCollection..::..GetChildrenPrototype Property
CommandCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetChildrenCommand GetChildrenPrototype { get; set; }
Visual Basic
Public Property GetChildrenPrototype As GetChildrenCommand
    Get
    Set
Visual C++
public:
property GetChildrenCommand^ GetChildrenPrototype {
    GetChildrenCommand^ get ();
    void set (GetChildrenCommand^ value);
}

Field Value

The prototype.

See Also

CommandCollection Class
Sitecore.Data.Engines.Data Namespace


GetItemPrototype Property

[image]

Sitecore 6.4.1 API
CommandCollection..::..GetItemPrototype Property
CommandCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetItemCommand GetItemPrototype { get; set; }
Visual Basic
Public Property GetItemPrototype As GetItemCommand
    Get
    Set
Visual C++
public:
property GetItemCommand^ GetItemPrototype {
    GetItemCommand^ get ();
    void set (GetItemCommand^ value);
}

Field Value

The prototype.

See Also

CommandCollection Class
Sitecore.Data.Engines.Data Namespace


GetParentPrototype Property

[image]

Sitecore 6.4.1 API
CommandCollection..::..GetParentPrototype Property
CommandCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetParentCommand GetParentPrototype { get; set; }
Visual Basic
Public Property GetParentPrototype As GetParentCommand
    Get
    Set
Visual C++
public:
property GetParentCommand^ GetParentPrototype {
    GetParentCommand^ get ();
    void set (GetParentCommand^ value);
}

Field Value

The prototype.

See Also

CommandCollection Class
Sitecore.Data.Engines.Data Namespace


GetRootItemPrototype Property

[image]

Sitecore 6.4.1 API
CommandCollection..::..GetRootItemPrototype Property
CommandCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetRootItemCommand GetRootItemPrototype { get; set; }
Visual Basic
Public Property GetRootItemPrototype As GetRootItemCommand
    Get
    Set
Visual C++
public:
property GetRootItemCommand^ GetRootItemPrototype {
    GetRootItemCommand^ get ();
    void set (GetRootItemCommand^ value);
}

Field Value

The prototype.

See Also

CommandCollection Class
Sitecore.Data.Engines.Data Namespace


GetVersionsPrototype Property

[image]

Sitecore 6.4.1 API
CommandCollection..::..GetVersionsPrototype Property
CommandCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetVersionsCommand GetVersionsPrototype { get; set; }
Visual Basic
Public Property GetVersionsPrototype As GetVersionsCommand
    Get
    Set
Visual C++
public:
property GetVersionsCommand^ GetVersionsPrototype {
    GetVersionsCommand^ get ();
    void set (GetVersionsCommand^ value);
}

Field Value

The prototype.

See Also

CommandCollection Class
Sitecore.Data.Engines.Data Namespace


HasChildrenPrototype Property

[image]

Sitecore 6.4.1 API
CommandCollection..::..HasChildrenPrototype Property
CommandCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HasChildrenCommand HasChildrenPrototype { get; set; }
Visual Basic
Public Property HasChildrenPrototype As HasChildrenCommand
    Get
    Set
Visual C++
public:
property HasChildrenCommand^ HasChildrenPrototype {
    HasChildrenCommand^ get ();
    void set (HasChildrenCommand^ value);
}

Field Value

The prototype.

See Also

CommandCollection Class
Sitecore.Data.Engines.Data Namespace


MoveItemPrototype Property

[image]

Sitecore 6.4.1 API
CommandCollection..::..MoveItemPrototype Property
CommandCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MoveItemCommand MoveItemPrototype { get; set; }
Visual Basic
Public Property MoveItemPrototype As MoveItemCommand
    Get
    Set
Visual C++
public:
property MoveItemCommand^ MoveItemPrototype {
    MoveItemCommand^ get ();
    void set (MoveItemCommand^ value);
}

Field Value

The prototype.

See Also

CommandCollection Class
Sitecore.Data.Engines.Data Namespace


RemoveDataPrototype Property

[image]

Sitecore 6.4.1 API
CommandCollection..::..RemoveDataPrototype Property
CommandCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RemoveDataCommand RemoveDataPrototype { get; set; }
Visual Basic
Public Property RemoveDataPrototype As RemoveDataCommand
    Get
    Set
Visual C++
public:
property RemoveDataCommand^ RemoveDataPrototype {
    RemoveDataCommand^ get ();
    void set (RemoveDataCommand^ value);
}

Field Value

The prototype.

See Also

CommandCollection Class
Sitecore.Data.Engines.Data Namespace


RemoveVersionPrototype Property

[image]

Sitecore 6.4.1 API
CommandCollection..::..RemoveVersionPrototype Property
CommandCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RemoveVersionCommand RemoveVersionPrototype { get; set; }
Visual Basic
Public Property RemoveVersionPrototype As RemoveVersionCommand
    Get
    Set
Visual C++
public:
property RemoveVersionCommand^ RemoveVersionPrototype {
    RemoveVersionCommand^ get ();
    void set (RemoveVersionCommand^ value);
}

Field Value

The prototype.

See Also

CommandCollection Class
Sitecore.Data.Engines.Data Namespace


ResolvePathPrototype Property

[image]

Sitecore 6.4.1 API
CommandCollection..::..ResolvePathPrototype Property
CommandCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ResolvePathCommand ResolvePathPrototype { get; set; }
Visual Basic
Public Property ResolvePathPrototype As ResolvePathCommand
    Get
    Set
Visual C++
public:
property ResolvePathCommand^ ResolvePathPrototype {
    ResolvePathCommand^ get ();
    void set (ResolvePathCommand^ value);
}

Field Value

The prototype.

See Also

CommandCollection Class
Sitecore.Data.Engines.Data Namespace


SaveItemPrototype Property

[image]

Sitecore 6.4.1 API
CommandCollection..::..SaveItemPrototype Property
CommandCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SaveItemCommand SaveItemPrototype { get; set; }
Visual Basic
Public Property SaveItemPrototype As SaveItemCommand
    Get
    Set
Visual C++
public:
property SaveItemCommand^ SaveItemPrototype {
    SaveItemCommand^ get ();
    void set (SaveItemCommand^ value);
}

Field Value

The prototype.

See Also

CommandCollection Class
Sitecore.Data.Engines.Data Namespace


SetBlobStreamPrototype Property

[image]

Sitecore 6.4.1 API
CommandCollection..::..SetBlobStreamPrototype Property
CommandCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.Data
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SetBlobStreamCommand SetBlobStreamPrototype { get; set; }
Visual Basic
Public Property SetBlobStreamPrototype As SetBlobStreamCommand
    Get
    Set
Visual C++
public:
property SetBlobStreamCommand^ SetBlobStreamPrototype {
    SetBlobStreamCommand^ get ();
    void set (SetBlobStreamCommand^ value);
}

Field Value

The prototype.

See Also

CommandCollection Class
Sitecore.Data.Engines.Data Namespace


Sitecore.Data.Engines.DataCommands Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Data.Engines.DataCommands Namespace
Send Feedback

Classes

 | Class | Description
Public class | AddFromTemplateCommand | The command used by the engine when deleting items.
Public class | AddVersionCommand | The command used by the engine when adding a version to an item.
Public class | BlobStreamExistsCommand | The command used by the engine when deleting items.
Public class | CopyItemCommand | The command used by the engine when copying items.
Public class | CreateItemCommand | The command used by the engine when deleting items.
Public class | DeleteItemCommand | The command used by the engine when deleting items.
Public class | GetBlobStreamCommand | The command used by the engine when deleting items.
Public class | GetChildrenCommand | The command used by the engine when getting child items.
Public class | GetItemCommand | The command used by the engine when getting items.
Public class | GetParentCommand | The command used by the engine when getting parent items.
Public class | GetRootItemCommand | The command used by the engine when getting the root item.
Public class | GetVersionsCommand | The command used by the engine when getting versions of an item.
Public class | HasChildrenCommand | The command used by the engine when getting child items.
Public class | MoveItemCommand | The command used by the engine when moving items.
Public class | RemoveDataCommand | The command used by the engine when removing data from an item.
Public class | RemoveVersionCommand | The command used by the engine when removing a version of an item.
Public class | ResolvePathCommand | The command used by the engine when getting items.
Public class | SaveItemCommand | The command used by the engine when saving items.
Public class | SetBlobStreamCommand | The command used by the engine when deleting items.


AddFromTemplateCommand Class

[image]

Sitecore 6.4.1 API
AddFromTemplateCommand Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class AddFromTemplateCommand : DataEngineCommand<Item, AddFromTemplateCommand>
Visual Basic
Public Class AddFromTemplateCommand _
    Inherits DataEngineCommand(Of Item, AddFromTemplateCommand)
Visual C++
public ref class AddFromTemplateCommand : public DataEngineCommand<Item^, AddFromTemplateCommand^>

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Engines..::..EngineCommand <(Of <(<' TReturnType, TCommandType >)>)>
Sitecore.Data.Engines..::..DataEngineCommand <(Of <(<' Item, AddFromTemplateCommand>)>)>
Sitecore.Data.Engines.DataCommands..::..AddFromTemplateCommand

See Also

AddFromTemplateCommand Members
Sitecore.Data.Engines.DataCommands Namespace


AddFromTemplateCommand Members

[image] [image]

Sitecore 6.4.1 API
AddFromTemplateCommand Members
AddFromTemplateCommand Class Constructors Methods Fields Properties See Also Send Feedback

The AddFromTemplateCommand type exposes the following members.

Constructors

 | Name | Description
Public method | AddFromTemplateCommand | Adds from tempalte command.

Methods

 | Name | Description
Protected method | CanExecute | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | CreateInstance | Creates an instance of the command class. (Overrides DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..CreateInstance()()()().)
Protected method | DoExecute | Executes the command. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..DoExecute()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Executed | Post processing handler. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..Executed()()()().)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalizeExecution | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the command.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareExecution | Prepares the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuted | Raises the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuting | Raises the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _lockType | (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

Properties

 | Name | Description
Public property | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Destination | Gets the destination. The newly created item will be a child of the destination item.
Public property | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | ItemName | Gets the name of the item.
Public property | NewId | Gets the id of the new item.
Public property | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | TemplateId | Gets the id of the template to use.

See Also

AddFromTemplateCommand Class
Sitecore.Data.Engines.DataCommands Namespace


AddFromTemplateCommand Constructor

[image]

Sitecore 6.4.1 API
AddFromTemplateCommand Constructor
AddFromTemplateCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AddFromTemplateCommand()
Visual Basic
Public Sub New
Visual C++
public:
AddFromTemplateCommand()

See Also

AddFromTemplateCommand Class
Sitecore.Data.Engines.DataCommands Namespace


AddFromTemplateCommand Fields

[image] [image]

Sitecore 6.4.1 API
AddFromTemplateCommand Fields
AddFromTemplateCommand Class See Also Send Feedback

The AddFromTemplateCommand type exposes the following members.

Fields

 | Name | Description
Protected field | _lockType | (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

AddFromTemplateCommand Class
Sitecore.Data.Engines.DataCommands Namespace


AddFromTemplateCommand Methods

[image] [image]

Sitecore 6.4.1 API
AddFromTemplateCommand Methods
AddFromTemplateCommand Class See Also Send Feedback

The AddFromTemplateCommand type exposes the following members.

Methods

 | Name | Description
Protected method | CanExecute | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | CreateInstance | Creates an instance of the command class. (Overrides DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..CreateInstance()()()().)
Protected method | DoExecute | Executes the command. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..DoExecute()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Executed | Post processing handler. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..Executed()()()().)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalizeExecution | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the command.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareExecution | Prepares the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuted | Raises the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuting | Raises the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddFromTemplateCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Clone Method

[image] [image]

Sitecore 6.4.1 API
AddFromTemplateCommand..::..Clone Method
AddFromTemplateCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

AddFromTemplateCommand Class
AddFromTemplateCommand Members
Sitecore.Data.Engines.DataCommands Namespace


CreateInstance Method

[image]

Sitecore 6.4.1 API
AddFromTemplateCommand..::..CreateInstance Method
AddFromTemplateCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override AddFromTemplateCommand CreateInstance()
Visual Basic
Protected Overrides Function CreateInstance As AddFromTemplateCommand
Visual C++
protected:
virtual AddFromTemplateCommand^ CreateInstance() override

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Engines.DataCommands.AddFromTemplateCommand.CreateInstance"]

See Also

AddFromTemplateCommand Class
Sitecore.Data.Engines.DataCommands Namespace


DoExecute Method

[image]

Sitecore 6.4.1 API
AddFromTemplateCommand..::..DoExecute Method
AddFromTemplateCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override Item DoExecute()
Visual Basic
Protected Overrides Function DoExecute As Item
Visual C++
protected:
virtual Item^ DoExecute() override

Return Value

The id of the newly created item. If the item could not be created, null is returned.

See Also

AddFromTemplateCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Executed Method

[image]

Sitecore 6.4.1 API
AddFromTemplateCommand..::..Executed Method
AddFromTemplateCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void Executed()
Visual Basic
Protected Overrides Sub Executed
Visual C++
protected:
virtual void Executed() override

Remarks

This method is called right after the command has been executed.

The result of the execution can be accessed through the Result property.

See Also

AddFromTemplateCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
AddFromTemplateCommand..::..Initialize Method
AddFromTemplateCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Initialize(
    string itemName,
    ID templateId,
    Item destination,
    ID newId
)
Visual Basic
Public Overridable Sub Initialize ( _
    itemName As String, _
    templateId As ID, _
    destination As Item, _
    newId As ID _
)
Visual C++
public:
virtual void Initialize(
    String^ itemName,
    ID^ templateId,
    Item^ destination,
    ID^ newId
)

Parameters

itemName
Type: System..::..String
Name of the item.
templateId
Type: Sitecore.Data..::..ID
The template id.
destination
Type: Sitecore.Data.Items..::..Item
The destination.
newId
Type: Sitecore.Data..::..ID
The id of the new item.

See Also

AddFromTemplateCommand Class
Sitecore.Data.Engines.DataCommands Namespace


AddFromTemplateCommand Properties

[image] [image]

Sitecore 6.4.1 API
AddFromTemplateCommand Properties
AddFromTemplateCommand Class See Also Send Feedback

The AddFromTemplateCommand type exposes the following members.

Properties

 | Name | Description
Public property | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Destination | Gets the destination. The newly created item will be a child of the destination item.
Public property | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | ItemName | Gets the name of the item.
Public property | NewId | Gets the id of the new item.
Public property | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | TemplateId | Gets the id of the template to use.

See Also

AddFromTemplateCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Destination Property

[image]

Sitecore 6.4.1 API
AddFromTemplateCommand..::..Destination Property
AddFromTemplateCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Item Destination { get; }
Visual Basic
Public Overridable ReadOnly Property Destination As Item
    Get
Visual C++
public:
virtual property Item^ Destination {
    Item^ get ();
}

Field Value

The destination item.

See Also

AddFromTemplateCommand Class
Sitecore.Data.Engines.DataCommands Namespace


ItemName Property

[image]

Sitecore 6.4.1 API
AddFromTemplateCommand..::..ItemName Property
AddFromTemplateCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ItemName { get; }
Visual Basic
Public ReadOnly Property ItemName As String
    Get
Visual C++
public:
property String^ ItemName {
    String^ get ();
}

Field Value

The name of the item.

See Also

AddFromTemplateCommand Class
Sitecore.Data.Engines.DataCommands Namespace


NewId Property

[image]

Sitecore 6.4.1 API
AddFromTemplateCommand..::..NewId Property
AddFromTemplateCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID NewId { get; }
Visual Basic
Public ReadOnly Property NewId As ID
    Get
Visual C++
public:
property ID^ NewId {
    ID^ get ();
}

Field Value

The new id.

See Also

AddFromTemplateCommand Class
Sitecore.Data.Engines.DataCommands Namespace


TemplateId Property

[image]

Sitecore 6.4.1 API
AddFromTemplateCommand..::..TemplateId Property
AddFromTemplateCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ID TemplateId { get; }
Visual Basic
Public Overridable ReadOnly Property TemplateId As ID
    Get
Visual C++
public:
virtual property ID^ TemplateId {
    ID^ get ();
}

Field Value

The template id.

See Also

AddFromTemplateCommand Class
Sitecore.Data.Engines.DataCommands Namespace


AddVersionCommand Class

[image]

Sitecore 6.4.1 API
AddVersionCommand Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class AddVersionCommand : DataEngineCommand<Item, AddVersionCommand>
Visual Basic
Public Class AddVersionCommand _
    Inherits DataEngineCommand(Of Item, AddVersionCommand)
Visual C++
public ref class AddVersionCommand : public DataEngineCommand<Item^, AddVersionCommand^>

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Engines..::..EngineCommand <(Of <(<' TReturnType, TCommandType >)>)>
Sitecore.Data.Engines..::..DataEngineCommand <(Of <(<' Item, AddVersionCommand>)>)>
Sitecore.Data.Engines.DataCommands..::..AddVersionCommand

See Also

AddVersionCommand Members
Sitecore.Data.Engines.DataCommands Namespace


AddVersionCommand Members

[image] [image]

Sitecore 6.4.1 API
AddVersionCommand Members
AddVersionCommand Class Constructors Methods Fields Properties See Also Send Feedback

The AddVersionCommand type exposes the following members.

Constructors

 | Name | Description
Public method | AddVersionCommand | Initializes a new instance of the AddVersionCommand class.

Methods

 | Name | Description
Protected method | CanExecute | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | CreateInstance | Creates an instance of the command class. (Overrides DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..CreateInstance()()()().)
Protected method | DoExecute | Executes the command. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..DoExecute()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Executed | Post processing handler. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..Executed()()()().)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalizeExecution | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the command.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareExecution | Prepares the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuted | Raises the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuting | Raises the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _lockType | (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

Properties

 | Name | Description
Public property | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Item | Gets the item that will have a version added.
Public property | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

AddVersionCommand Class
Sitecore.Data.Engines.DataCommands Namespace


AddVersionCommand Constructor

[image]

Sitecore 6.4.1 API
AddVersionCommand Constructor
AddVersionCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AddVersionCommand()
Visual Basic
Public Sub New
Visual C++
public:
AddVersionCommand()

See Also

AddVersionCommand Class
Sitecore.Data.Engines.DataCommands Namespace


AddVersionCommand Fields

[image] [image]

Sitecore 6.4.1 API
AddVersionCommand Fields
AddVersionCommand Class See Also Send Feedback

The AddVersionCommand type exposes the following members.

Fields

 | Name | Description
Protected field | _lockType | (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

AddVersionCommand Class
Sitecore.Data.Engines.DataCommands Namespace


AddVersionCommand Methods

[image] [image]

Sitecore 6.4.1 API
AddVersionCommand Methods
AddVersionCommand Class See Also Send Feedback

The AddVersionCommand type exposes the following members.

Methods

 | Name | Description
Protected method | CanExecute | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | CreateInstance | Creates an instance of the command class. (Overrides DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..CreateInstance()()()().)
Protected method | DoExecute | Executes the command. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..DoExecute()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Executed | Post processing handler. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..Executed()()()().)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalizeExecution | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the command.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareExecution | Prepares the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuted | Raises the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuting | Raises the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddVersionCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Clone Method

[image] [image]

Sitecore 6.4.1 API
AddVersionCommand..::..Clone Method
AddVersionCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

AddVersionCommand Class
AddVersionCommand Members
Sitecore.Data.Engines.DataCommands Namespace


CreateInstance Method

[image]

Sitecore 6.4.1 API
AddVersionCommand..::..CreateInstance Method
AddVersionCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override AddVersionCommand CreateInstance()
Visual Basic
Protected Overrides Function CreateInstance As AddVersionCommand
Visual C++
protected:
virtual AddVersionCommand^ CreateInstance() override

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Engines.DataCommands.AddVersionCommand.CreateInstance"]

See Also

AddVersionCommand Class
Sitecore.Data.Engines.DataCommands Namespace


DoExecute Method

[image]

Sitecore 6.4.1 API
AddVersionCommand..::..DoExecute Method
AddVersionCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override Item DoExecute()
Visual Basic
Protected Overrides Function DoExecute As Item
Visual C++
protected:
virtual Item^ DoExecute() override

Return Value

The added version of the item. If a version could not be added to the item, null is returned.

See Also

AddVersionCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Executed Method

[image]

Sitecore 6.4.1 API
AddVersionCommand..::..Executed Method
AddVersionCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void Executed()
Visual Basic
Protected Overrides Sub Executed
Visual C++
protected:
virtual void Executed() override

Remarks

This method is called right after the command has been executed.

The result of the execution can be accessed through the Result property.

See Also

AddVersionCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
AddVersionCommand..::..Initialize Method
AddVersionCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Initialize(
    Item item
)
Visual Basic
Public Overridable Sub Initialize ( _
    item As Item _
)
Visual C++
public:
virtual void Initialize(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item that will have a version added.

See Also

AddVersionCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Item Property

[image]

Sitecore 6.4.1 API
AddVersionCommand..::..Item Property
AddVersionCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Item { get; }
Visual Basic
Public ReadOnly Property Item As Item
    Get
Visual C++
public:
property Item^ Item {
    Item^ get ();
}

Field Value

The item.

See Also

AddVersionCommand Class
Sitecore.Data.Engines.DataCommands Namespace


BlobStreamExistsCommand Class

[image]

Sitecore 6.4.1 API
BlobStreamExistsCommand Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class BlobStreamExistsCommand : DataEngineCommand<bool, BlobStreamExistsCommand>
Visual Basic
Public Class BlobStreamExistsCommand _
    Inherits DataEngineCommand(Of Boolean, BlobStreamExistsCommand)
Visual C++
public ref class BlobStreamExistsCommand : public DataEngineCommand<bool, BlobStreamExistsCommand^>

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Engines..::..EngineCommand <(Of <(<' TReturnType, TCommandType >)>)>
Sitecore.Data.Engines..::..DataEngineCommand <(Of <(<' Boolean, BlobStreamExistsCommand>)>)>
Sitecore.Data.Engines.DataCommands..::..BlobStreamExistsCommand

See Also

BlobStreamExistsCommand Members
Sitecore.Data.Engines.DataCommands Namespace


BlobStreamExistsCommand Members

[image] [image]

Sitecore 6.4.1 API
BlobStreamExistsCommand Members
BlobStreamExistsCommand Class Constructors Methods Fields Properties See Also Send Feedback

The BlobStreamExistsCommand type exposes the following members.

Constructors

 | Name | Description
Public method | BlobStreamExistsCommand | Initializes a new instance of the BlobStreamExistsCommand class

Methods

 | Name | Description
Protected method | CanExecute | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | CreateInstance | Creates an instance of the command class. (Overrides DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..CreateInstance()()()().)
Protected method | DoExecute | Executes the command. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..DoExecute()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Executed | Post processing handler. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalizeExecution | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareExecution | Prepares the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuted | Raises the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuting | Raises the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _lockType | (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

Properties

 | Name | Description
Public property | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

BlobStreamExistsCommand Class
Sitecore.Data.Engines.DataCommands Namespace


BlobStreamExistsCommand Constructor

[image]

Sitecore 6.4.1 API
BlobStreamExistsCommand Constructor
BlobStreamExistsCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BlobStreamExistsCommand()
Visual Basic
Public Sub New
Visual C++
public:
BlobStreamExistsCommand()

See Also

BlobStreamExistsCommand Class
Sitecore.Data.Engines.DataCommands Namespace


BlobStreamExistsCommand Fields

[image] [image]

Sitecore 6.4.1 API
BlobStreamExistsCommand Fields
BlobStreamExistsCommand Class See Also Send Feedback

The BlobStreamExistsCommand type exposes the following members.

Fields

 | Name | Description
Protected field | _lockType | (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

BlobStreamExistsCommand Class
Sitecore.Data.Engines.DataCommands Namespace


BlobStreamExistsCommand Methods

[image] [image]

Sitecore 6.4.1 API
BlobStreamExistsCommand Methods
BlobStreamExistsCommand Class See Also Send Feedback

The BlobStreamExistsCommand type exposes the following members.

Methods

 | Name | Description
Protected method | CanExecute | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | CreateInstance | Creates an instance of the command class. (Overrides DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..CreateInstance()()()().)
Protected method | DoExecute | Executes the command. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..DoExecute()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Executed | Post processing handler. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalizeExecution | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareExecution | Prepares the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuted | Raises the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuting | Raises the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BlobStreamExistsCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Clone Method

[image] [image]

Sitecore 6.4.1 API
BlobStreamExistsCommand..::..Clone Method
BlobStreamExistsCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

BlobStreamExistsCommand Class
BlobStreamExistsCommand Members
Sitecore.Data.Engines.DataCommands Namespace


CreateInstance Method

[image]

Sitecore 6.4.1 API
BlobStreamExistsCommand..::..CreateInstance Method
BlobStreamExistsCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override BlobStreamExistsCommand CreateInstance()
Visual Basic
Protected Overrides Function CreateInstance As BlobStreamExistsCommand
Visual C++
protected:
virtual BlobStreamExistsCommand^ CreateInstance() override

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Engines.DataCommands.BlobStreamExistsCommand.CreateInstance"]

See Also

BlobStreamExistsCommand Class
Sitecore.Data.Engines.DataCommands Namespace


DoExecute Method

[image]

Sitecore 6.4.1 API
BlobStreamExistsCommand..::..DoExecute Method
BlobStreamExistsCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override bool DoExecute()
Visual Basic
Protected Overrides Function DoExecute As Boolean
Visual C++
protected:
virtual bool DoExecute() override

Return Value

The blob value (or null if no value was found).

See Also

BlobStreamExistsCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
BlobStreamExistsCommand..::..Initialize Method
BlobStreamExistsCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Initialize(
    Guid blobId
)
Visual Basic
Public Overridable Sub Initialize ( _
    blobId As Guid _
)
Visual C++
public:
virtual void Initialize(
    Guid blobId
)

Parameters

blobId
Type: System..::..Guid
The BLOB id.

See Also

BlobStreamExistsCommand Class
Sitecore.Data.Engines.DataCommands Namespace


BlobStreamExistsCommand Properties

[image] [image]

Sitecore 6.4.1 API
BlobStreamExistsCommand Properties
BlobStreamExistsCommand Class See Also Send Feedback

The BlobStreamExistsCommand type exposes the following members.

Properties

 | Name | Description
Public property | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

BlobStreamExistsCommand Class
Sitecore.Data.Engines.DataCommands Namespace


CopyItemCommand Class

[image]

Sitecore 6.4.1 API
CopyItemCommand Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CopyItemCommand : DataEngineCommand<Item, CopyItemCommand>
Visual Basic
Public Class CopyItemCommand _
    Inherits DataEngineCommand(Of Item, CopyItemCommand)
Visual C++
public ref class CopyItemCommand : public DataEngineCommand<Item^, CopyItemCommand^>

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Engines..::..EngineCommand <(Of <(<' TReturnType, TCommandType >)>)>
Sitecore.Data.Engines..::..DataEngineCommand <(Of <(<' Item, CopyItemCommand>)>)>
Sitecore.Data.Engines.DataCommands..::..CopyItemCommand

See Also

CopyItemCommand Members
Sitecore.Data.Engines.DataCommands Namespace


CopyItemCommand Members

[image] [image]

Sitecore 6.4.1 API
CopyItemCommand Members
CopyItemCommand Class Constructors Methods Fields Properties See Also Send Feedback

The CopyItemCommand type exposes the following members.

Constructors

 | Name | Description
Public method | CopyItemCommand | Initializes a new instance of the CopyItemCommand class.

Methods

 | Name | Description
Protected method | CanExecute | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | CreateInstance | Creates an instance of the command class. (Overrides DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..CreateInstance()()()().)
Protected method | DoExecute | Executes the command. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..DoExecute()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Executed | Post processing handler. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..Executed()()()().)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalizeExecution | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the command.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareExecution | Prepares the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuted | Raises the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuting | Raises the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _lockType | (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

Properties

 | Name | Description
Public property | CopyId | Gets the id of the copy.
Public property | CopyName | Gets the name of the copy.
Public property | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Deep | Gets a value indicating whether child items should be copied.
Public property | Destination | Gets the destination for the copy. This will be the parent of the copied item.
Public property | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Source | Gets the item to copy.

See Also

CopyItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


CopyItemCommand Constructor

[image]

Sitecore 6.4.1 API
CopyItemCommand Constructor
CopyItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CopyItemCommand()
Visual Basic
Public Sub New
Visual C++
public:
CopyItemCommand()

See Also

CopyItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


CopyItemCommand Fields

[image] [image]

Sitecore 6.4.1 API
CopyItemCommand Fields
CopyItemCommand Class See Also Send Feedback

The CopyItemCommand type exposes the following members.

Fields

 | Name | Description
Protected field | _lockType | (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

CopyItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


CopyItemCommand Methods

[image] [image]

Sitecore 6.4.1 API
CopyItemCommand Methods
CopyItemCommand Class See Also Send Feedback

The CopyItemCommand type exposes the following members.

Methods

 | Name | Description
Protected method | CanExecute | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | CreateInstance | Creates an instance of the command class. (Overrides DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..CreateInstance()()()().)
Protected method | DoExecute | Executes the command. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..DoExecute()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Executed | Post processing handler. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..Executed()()()().)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalizeExecution | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the command.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareExecution | Prepares the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuted | Raises the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuting | Raises the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CopyItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Clone Method

[image] [image]

Sitecore 6.4.1 API
CopyItemCommand..::..Clone Method
CopyItemCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

CopyItemCommand Class
CopyItemCommand Members
Sitecore.Data.Engines.DataCommands Namespace


CreateInstance Method

[image]

Sitecore 6.4.1 API
CopyItemCommand..::..CreateInstance Method
CopyItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override CopyItemCommand CreateInstance()
Visual Basic
Protected Overrides Function CreateInstance As CopyItemCommand
Visual C++
protected:
virtual CopyItemCommand^ CreateInstance() override

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Engines.DataCommands.CopyItemCommand.CreateInstance"]

See Also

CopyItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


DoExecute Method

[image]

Sitecore 6.4.1 API
CopyItemCommand..::..DoExecute Method
CopyItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override Item DoExecute()
Visual Basic
Protected Overrides Function DoExecute As Item
Visual C++
protected:
virtual Item^ DoExecute() override

Return Value

The copy of Source. If the item was ot copied, null is returned.

See Also

CopyItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Executed Method

[image]

Sitecore 6.4.1 API
CopyItemCommand..::..Executed Method
CopyItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void Executed()
Visual Basic
Protected Overrides Sub Executed
Visual C++
protected:
virtual void Executed() override

Remarks

This method is called right after the command has been executed.

The result of the execution can be accessed through the Result property.

See Also

CopyItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
CopyItemCommand..::..Initialize Method
CopyItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Initialize(
    Item source,
    Item destination,
    string copyName,
    ID copyId,
    bool deep
)
Visual Basic
Public Overridable Sub Initialize ( _
    source As Item, _
    destination As Item, _
    copyName As String, _
    copyId As ID, _
    deep As Boolean _
)
Visual C++
public:
virtual void Initialize(
    Item^ source,
    Item^ destination,
    String^ copyName,
    ID^ copyId,
    bool deep
)

Parameters

source
Type: Sitecore.Data.Items..::..Item
The item to copy.
destination
Type: Sitecore.Data.Items..::..Item
The destination.
copyName
Type: System..::..String
Name of the copy.
copyId
Type: Sitecore.Data..::..ID
Id of the copy.
deep
Type: System..::..Boolean
If set to true, child items will be copied recursively.

See Also

CopyItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


CopyItemCommand Properties

[image] [image]

Sitecore 6.4.1 API
CopyItemCommand Properties
CopyItemCommand Class See Also Send Feedback

The CopyItemCommand type exposes the following members.

Properties

 | Name | Description
Public property | CopyId | Gets the id of the copy.
Public property | CopyName | Gets the name of the copy.
Public property | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Deep | Gets a value indicating whether child items should be copied.
Public property | Destination | Gets the destination for the copy. This will be the parent of the copied item.
Public property | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Source | Gets the item to copy.

See Also

CopyItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


CopyId Property

[image]

Sitecore 6.4.1 API
CopyItemCommand..::..CopyId Property
CopyItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID CopyId { get; }
Visual Basic
Public ReadOnly Property CopyId As ID
    Get
Visual C++
public:
property ID^ CopyId {
    ID^ get ();
}

Field Value

The copy id.

See Also

CopyItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


CopyName Property

[image]

Sitecore 6.4.1 API
CopyItemCommand..::..CopyName Property
CopyItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string CopyName { get; }
Visual Basic
Public ReadOnly Property CopyName As String
    Get
Visual C++
public:
property String^ CopyName {
    String^ get ();
}

Field Value

The name of the copy.

See Also

CopyItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Deep Property

[image]

Sitecore 6.4.1 API
CopyItemCommand..::..Deep Property
CopyItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Deep { get; }
Visual Basic
Public ReadOnly Property Deep As Boolean
    Get
Visual C++
public:
property bool Deep {
    bool get ();
}

Field Value

true if child items should be copied; otherwise, false.

See Also

CopyItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Destination Property

[image]

Sitecore 6.4.1 API
CopyItemCommand..::..Destination Property
CopyItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Destination { get; }
Visual Basic
Public ReadOnly Property Destination As Item
    Get
Visual C++
public:
property Item^ Destination {
    Item^ get ();
}

Field Value

The destination.

See Also

CopyItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Source Property

[image]

Sitecore 6.4.1 API
CopyItemCommand..::..Source Property
CopyItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Item Source { get; }
Visual Basic
Public Overridable ReadOnly Property Source As Item
    Get
Visual C++
public:
virtual property Item^ Source {
    Item^ get ();
}

Field Value

The item.

See Also

CopyItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


CreateItemCommand Class

[image]

Sitecore 6.4.1 API
CreateItemCommand Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CreateItemCommand : DataEngineCommand<Item, CreateItemCommand>
Visual Basic
Public Class CreateItemCommand _
    Inherits DataEngineCommand(Of Item, CreateItemCommand)
Visual C++
public ref class CreateItemCommand : public DataEngineCommand<Item^, CreateItemCommand^>

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Engines..::..EngineCommand <(Of <(<' TReturnType, TCommandType >)>)>
Sitecore.Data.Engines..::..DataEngineCommand <(Of <(<' Item, CreateItemCommand>)>)>
Sitecore.Data.Engines.DataCommands..::..CreateItemCommand

See Also

CreateItemCommand Members
Sitecore.Data.Engines.DataCommands Namespace


CreateItemCommand Members

[image] [image]

Sitecore 6.4.1 API
CreateItemCommand Members
CreateItemCommand Class Constructors Methods Fields Properties See Also Send Feedback

The CreateItemCommand type exposes the following members.

Constructors

 | Name | Description
Public method | CreateItemCommand | Initializes a new instance of the CreateItemCommand class.

Methods

 | Name | Description
Protected method | CanExecute | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | CreateInstance | Creates an instance of the command class. (Overrides DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..CreateInstance()()()().)
Protected method | DoExecute | Executes the command. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..DoExecute()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Executed | Post processing handler. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..Executed()()()().)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalizeExecution | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the command.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareExecution | Prepares the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuted | Raises the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuting | Raises the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _lockType | (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

Properties

 | Name | Description
Public property | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Destination | Gets the destination. The newly created item will be a child of the destination item.
Public property | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | ItemId | Gets the item id.
Public property | ItemName | Gets the name of the item.
Public property | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | TemplateId | Gets the id of the template to use.

See Also

CreateItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


CreateItemCommand Constructor

[image]

Sitecore 6.4.1 API
CreateItemCommand Constructor
CreateItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CreateItemCommand()
Visual Basic
Public Sub New
Visual C++
public:
CreateItemCommand()

See Also

CreateItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


CreateItemCommand Fields

[image] [image]

Sitecore 6.4.1 API
CreateItemCommand Fields
CreateItemCommand Class See Also Send Feedback

The CreateItemCommand type exposes the following members.

Fields

 | Name | Description
Protected field | _lockType | (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

CreateItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


CreateItemCommand Methods

[image] [image]

Sitecore 6.4.1 API
CreateItemCommand Methods
CreateItemCommand Class See Also Send Feedback

The CreateItemCommand type exposes the following members.

Methods

 | Name | Description
Protected method | CanExecute | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | CreateInstance | Creates an instance of the command class. (Overrides DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..CreateInstance()()()().)
Protected method | DoExecute | Executes the command. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..DoExecute()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Executed | Post processing handler. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..Executed()()()().)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalizeExecution | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the command.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareExecution | Prepares the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuted | Raises the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuting | Raises the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CreateItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Clone Method

[image] [image]

Sitecore 6.4.1 API
CreateItemCommand..::..Clone Method
CreateItemCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

CreateItemCommand Class
CreateItemCommand Members
Sitecore.Data.Engines.DataCommands Namespace


CreateInstance Method

[image]

Sitecore 6.4.1 API
CreateItemCommand..::..CreateInstance Method
CreateItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override CreateItemCommand CreateInstance()
Visual Basic
Protected Overrides Function CreateInstance As CreateItemCommand
Visual C++
protected:
virtual CreateItemCommand^ CreateInstance() override

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Engines.DataCommands.CreateItemCommand.CreateInstance"]

See Also

CreateItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


DoExecute Method

[image]

Sitecore 6.4.1 API
CreateItemCommand..::..DoExecute Method
CreateItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override Item DoExecute()
Visual Basic
Protected Overrides Function DoExecute As Item
Visual C++
protected:
virtual Item^ DoExecute() override

Return Value

true if the item was created; false otherwise.

See Also

CreateItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Executed Method

[image]

Sitecore 6.4.1 API
CreateItemCommand..::..Executed Method
CreateItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void Executed()
Visual Basic
Protected Overrides Sub Executed
Visual C++
protected:
virtual void Executed() override

Remarks

This method is called right after the command has been executed.

The result of the execution can be accessed through the Result property.

See Also

CreateItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
CreateItemCommand..::..Initialize Method
CreateItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Initialize(
    ID itemId,
    string itemName,
    ID templateId,
    Item destination
)
Visual Basic
Public Overridable Sub Initialize ( _
    itemId As ID, _
    itemName As String, _
    templateId As ID, _
    destination As Item _
)
Visual C++
public:
virtual void Initialize(
    ID^ itemId,
    String^ itemName,
    ID^ templateId,
    Item^ destination
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
itemName
Type: System..::..String
Name of the item.
templateId
Type: Sitecore.Data..::..ID
The template ID.
destination
Type: Sitecore.Data.Items..::..Item
The destination.

See Also

CreateItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


CreateItemCommand Properties

[image] [image]

Sitecore 6.4.1 API
CreateItemCommand Properties
CreateItemCommand Class See Also Send Feedback

The CreateItemCommand type exposes the following members.

Properties

 | Name | Description
Public property | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Destination | Gets the destination. The newly created item will be a child of the destination item.
Public property | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | ItemId | Gets the item id.
Public property | ItemName | Gets the name of the item.
Public property | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | TemplateId | Gets the id of the template to use.

See Also

CreateItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Destination Property

[image]

Sitecore 6.4.1 API
CreateItemCommand..::..Destination Property
CreateItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Destination { get; }
Visual Basic
Public ReadOnly Property Destination As Item
    Get
Visual C++
public:
property Item^ Destination {
    Item^ get ();
}

Field Value

The destination.

See Also

CreateItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


ItemId Property

[image]

Sitecore 6.4.1 API
CreateItemCommand..::..ItemId Property
CreateItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ItemId { get; }
Visual Basic
Public ReadOnly Property ItemId As ID
    Get
Visual C++
public:
property ID^ ItemId {
    ID^ get ();
}

Field Value

The item id.

See Also

CreateItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


ItemName Property

[image]

Sitecore 6.4.1 API
CreateItemCommand..::..ItemName Property
CreateItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ItemName { get; }
Visual Basic
Public ReadOnly Property ItemName As String
    Get
Visual C++
public:
property String^ ItemName {
    String^ get ();
}

Field Value

The name of the item.

See Also

CreateItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


TemplateId Property

[image]

Sitecore 6.4.1 API
CreateItemCommand..::..TemplateId Property
CreateItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ID TemplateId { get; }
Visual Basic
Public Overridable ReadOnly Property TemplateId As ID
    Get
Visual C++
public:
virtual property ID^ TemplateId {
    ID^ get ();
}

Field Value

The template id.

See Also

CreateItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


DeleteItemCommand Class

[image]

Sitecore 6.4.1 API
DeleteItemCommand Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DeleteItemCommand : DataEngineCommand<bool, DeleteItemCommand>
Visual Basic
Public Class DeleteItemCommand _
    Inherits DataEngineCommand(Of Boolean, DeleteItemCommand)
Visual C++
public ref class DeleteItemCommand : public DataEngineCommand<bool, DeleteItemCommand^>

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Engines..::..EngineCommand <(Of <(<' TReturnType, TCommandType >)>)>
Sitecore.Data.Engines..::..DataEngineCommand <(Of <(<' Boolean, DeleteItemCommand>)>)>
Sitecore.Data.Engines.DataCommands..::..DeleteItemCommand

See Also

DeleteItemCommand Members
Sitecore.Data.Engines.DataCommands Namespace


DeleteItemCommand Members

[image] [image]

Sitecore 6.4.1 API
DeleteItemCommand Members
DeleteItemCommand Class Constructors Methods Fields Properties See Also Send Feedback

The DeleteItemCommand type exposes the following members.

Constructors

 | Name | Description
Public method | DeleteItemCommand | Initializes a new instance of the DeleteItemCommand class.

Methods

 | Name | Description
Protected method | CanExecute | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | CreateInstance | Creates an instance of the command class. (Overrides DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..CreateInstance()()()().)
Protected method | DoExecute | Executes the delete command. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..DoExecute()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Executed | Post processing handler. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalizeExecution | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareExecution | Prepares the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuted | Raises the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuting | Raises the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _lockType | (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

Properties

 | Name | Description
Public property | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Item | Gets the Item being saved.
Public property | ParentId | Gets the parent id of the item being deleted.
Public property | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

DeleteItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


DeleteItemCommand Constructor

[image]

Sitecore 6.4.1 API
DeleteItemCommand Constructor
DeleteItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DeleteItemCommand()
Visual Basic
Public Sub New
Visual C++
public:
DeleteItemCommand()

See Also

DeleteItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


DeleteItemCommand Fields

[image] [image]

Sitecore 6.4.1 API
DeleteItemCommand Fields
DeleteItemCommand Class See Also Send Feedback

The DeleteItemCommand type exposes the following members.

Fields

 | Name | Description
Protected field | _lockType | (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

DeleteItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


DeleteItemCommand Methods

[image] [image]

Sitecore 6.4.1 API
DeleteItemCommand Methods
DeleteItemCommand Class See Also Send Feedback

The DeleteItemCommand type exposes the following members.

Methods

 | Name | Description
Protected method | CanExecute | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | CreateInstance | Creates an instance of the command class. (Overrides DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..CreateInstance()()()().)
Protected method | DoExecute | Executes the delete command. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..DoExecute()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Executed | Post processing handler. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalizeExecution | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareExecution | Prepares the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuted | Raises the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuting | Raises the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DeleteItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Clone Method

[image] [image]

Sitecore 6.4.1 API
DeleteItemCommand..::..Clone Method
DeleteItemCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

DeleteItemCommand Class
DeleteItemCommand Members
Sitecore.Data.Engines.DataCommands Namespace


CreateInstance Method

[image]

Sitecore 6.4.1 API
DeleteItemCommand..::..CreateInstance Method
DeleteItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override DeleteItemCommand CreateInstance()
Visual Basic
Protected Overrides Function CreateInstance As DeleteItemCommand
Visual C++
protected:
virtual DeleteItemCommand^ CreateInstance() override

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Engines.DataCommands.DeleteItemCommand.CreateInstance"]

See Also

DeleteItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
DeleteItemCommand..::..Initialize Method
DeleteItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Initialize(
    Item item,
    ID parentId
)
Visual Basic
Public Overridable Sub Initialize ( _
    item As Item, _
    parentId As ID _
)
Visual C++
public:
virtual void Initialize(
    Item^ item,
    ID^ parentId
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item to delete.
parentId
Type: Sitecore.Data..::..ID
The parent id.

See Also

DeleteItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


DeleteItemCommand Properties

[image] [image]

Sitecore 6.4.1 API
DeleteItemCommand Properties
DeleteItemCommand Class See Also Send Feedback

The DeleteItemCommand type exposes the following members.

Properties

 | Name | Description
Public property | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Item | Gets the Item being saved.
Public property | ParentId | Gets the parent id of the item being deleted.
Public property | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

DeleteItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Item Property

[image]

Sitecore 6.4.1 API
DeleteItemCommand..::..Item Property
DeleteItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Item Item { get; }
Visual Basic
Public Overridable ReadOnly Property Item As Item
    Get
Visual C++
public:
virtual property Item^ Item {
    Item^ get ();
}

Field Value

The item.

See Also

DeleteItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


ParentId Property

[image]

Sitecore 6.4.1 API
DeleteItemCommand..::..ParentId Property
DeleteItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ID ParentId { get; }
Visual Basic
Public Overridable ReadOnly Property ParentId As ID
    Get
Visual C++
public:
virtual property ID^ ParentId {
    ID^ get ();
}

Field Value

The parent id.

See Also

DeleteItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


GetBlobStreamCommand Class

[image]

Sitecore 6.4.1 API
GetBlobStreamCommand Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetBlobStreamCommand : DataEngineCommand<Stream, GetBlobStreamCommand>
Visual Basic
Public Class GetBlobStreamCommand _
    Inherits DataEngineCommand(Of Stream, GetBlobStreamCommand)
Visual C++
public ref class GetBlobStreamCommand : public DataEngineCommand<Stream^, GetBlobStreamCommand^>

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Engines..::..EngineCommand <(Of <(<' TReturnType, TCommandType >)>)>
Sitecore.Data.Engines..::..DataEngineCommand <(Of <(<' Stream, GetBlobStreamCommand>)>)>
Sitecore.Data.Engines.DataCommands..::..GetBlobStreamCommand

See Also

GetBlobStreamCommand Members
Sitecore.Data.Engines.DataCommands Namespace


GetBlobStreamCommand Members

[image] [image]

Sitecore 6.4.1 API
GetBlobStreamCommand Members
GetBlobStreamCommand Class Constructors Methods Fields Properties See Also Send Feedback

The GetBlobStreamCommand type exposes the following members.

Constructors

 | Name | Description
Public method | GetBlobStreamCommand | Initializes a new instance of the GetBlobStreamCommand class

Methods

 | Name | Description
Protected method | CanExecute | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | CreateInstance | Creates an instance of the command class. (Overrides DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..CreateInstance()()()().)
Protected method | DoExecute | Executes the command. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..DoExecute()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Executed | Post processing handler. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalizeExecution | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareExecution | Prepares the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuted | Raises the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuting | Raises the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _lockType | (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

Properties

 | Name | Description
Public property | BlobId | Gets the BLOB id.
Public property | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

GetBlobStreamCommand Class
Sitecore.Data.Engines.DataCommands Namespace


GetBlobStreamCommand Constructor

[image]

Sitecore 6.4.1 API
GetBlobStreamCommand Constructor
GetBlobStreamCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetBlobStreamCommand()
Visual Basic
Public Sub New
Visual C++
public:
GetBlobStreamCommand()

See Also

GetBlobStreamCommand Class
Sitecore.Data.Engines.DataCommands Namespace


GetBlobStreamCommand Fields

[image] [image]

Sitecore 6.4.1 API
GetBlobStreamCommand Fields
GetBlobStreamCommand Class See Also Send Feedback

The GetBlobStreamCommand type exposes the following members.

Fields

 | Name | Description
Protected field | _lockType | (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

GetBlobStreamCommand Class
Sitecore.Data.Engines.DataCommands Namespace


GetBlobStreamCommand Methods

[image] [image]

Sitecore 6.4.1 API
GetBlobStreamCommand Methods
GetBlobStreamCommand Class See Also Send Feedback

The GetBlobStreamCommand type exposes the following members.

Methods

 | Name | Description
Protected method | CanExecute | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | CreateInstance | Creates an instance of the command class. (Overrides DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..CreateInstance()()()().)
Protected method | DoExecute | Executes the command. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..DoExecute()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Executed | Post processing handler. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalizeExecution | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareExecution | Prepares the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuted | Raises the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuting | Raises the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetBlobStreamCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Clone Method

[image] [image]

Sitecore 6.4.1 API
GetBlobStreamCommand..::..Clone Method
GetBlobStreamCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

GetBlobStreamCommand Class
GetBlobStreamCommand Members
Sitecore.Data.Engines.DataCommands Namespace


CreateInstance Method

[image]

Sitecore 6.4.1 API
GetBlobStreamCommand..::..CreateInstance Method
GetBlobStreamCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override GetBlobStreamCommand CreateInstance()
Visual Basic
Protected Overrides Function CreateInstance As GetBlobStreamCommand
Visual C++
protected:
virtual GetBlobStreamCommand^ CreateInstance() override

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Engines.DataCommands.GetBlobStreamCommand.CreateInstance"]

See Also

GetBlobStreamCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
GetBlobStreamCommand..::..Initialize Method
GetBlobStreamCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Initialize(
    Guid blobId
)
Visual Basic
Public Overridable Sub Initialize ( _
    blobId As Guid _
)
Visual C++
public:
virtual void Initialize(
    Guid blobId
)

Parameters

blobId
Type: System..::..Guid
The BLOB id.

See Also

GetBlobStreamCommand Class
Sitecore.Data.Engines.DataCommands Namespace


GetBlobStreamCommand Properties

[image] [image]

Sitecore 6.4.1 API
GetBlobStreamCommand Properties
GetBlobStreamCommand Class See Also Send Feedback

The GetBlobStreamCommand type exposes the following members.

Properties

 | Name | Description
Public property | BlobId | Gets the BLOB id.
Public property | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

GetBlobStreamCommand Class
Sitecore.Data.Engines.DataCommands Namespace


BlobId Property

[image]

Sitecore 6.4.1 API
GetBlobStreamCommand..::..BlobId Property
GetBlobStreamCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Guid BlobId { get; }
Visual Basic
Public ReadOnly Property BlobId As Guid
    Get
Visual C++
public:
property Guid BlobId {
    Guid get ();
}

Field Value

The BLOB id.

See Also

GetBlobStreamCommand Class
Sitecore.Data.Engines.DataCommands Namespace


GetChildrenCommand Class

[image]

Sitecore 6.4.1 API
GetChildrenCommand Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetChildrenCommand : DataEngineCommand<ItemList, GetChildrenCommand>
Visual Basic
Public Class GetChildrenCommand _
    Inherits DataEngineCommand(Of ItemList, GetChildrenCommand)
Visual C++
public ref class GetChildrenCommand : public DataEngineCommand<ItemList^, GetChildrenCommand^>

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Engines..::..EngineCommand <(Of <(<' TReturnType, TCommandType >)>)>
Sitecore.Data.Engines..::..DataEngineCommand <(Of <(<' ItemList, GetChildrenCommand>)>)>
Sitecore.Data.Engines.DataCommands..::..GetChildrenCommand

See Also

GetChildrenCommand Members
Sitecore.Data.Engines.DataCommands Namespace


GetChildrenCommand Members

[image] [image]

Sitecore 6.4.1 API
GetChildrenCommand Members
GetChildrenCommand Class Constructors Methods Fields Properties See Also Send Feedback

The GetChildrenCommand type exposes the following members.

Constructors

 | Name | Description
Public method | GetChildrenCommand | Initializes a new instance of the GetChildrenCommand class

Methods

 | Name | Description
Protected method | CanExecute | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | CreateInstance | Creates an instance of the command class. (Overrides DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..CreateInstance()()()().)
Protected method | DoExecute | Performs the actual save operation. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..DoExecute()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Executed | Post processing handler. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalizeExecution | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the specified item.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareExecution | Prepares the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuted | Raises the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuting | Raises the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _lockType | (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

Properties

 | Name | Description
Public property | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Item | Gets the id of the item to get.
Public property | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

GetChildrenCommand Class
Sitecore.Data.Engines.DataCommands Namespace


GetChildrenCommand Constructor

[image]

Sitecore 6.4.1 API
GetChildrenCommand Constructor
GetChildrenCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetChildrenCommand()
Visual Basic
Public Sub New
Visual C++
public:
GetChildrenCommand()

See Also

GetChildrenCommand Class
Sitecore.Data.Engines.DataCommands Namespace


GetChildrenCommand Fields

[image] [image]

Sitecore 6.4.1 API
GetChildrenCommand Fields
GetChildrenCommand Class See Also Send Feedback

The GetChildrenCommand type exposes the following members.

Fields

 | Name | Description
Protected field | _lockType | (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

GetChildrenCommand Class
Sitecore.Data.Engines.DataCommands Namespace


GetChildrenCommand Methods

[image] [image]

Sitecore 6.4.1 API
GetChildrenCommand Methods
GetChildrenCommand Class See Also Send Feedback

The GetChildrenCommand type exposes the following members.

Methods

 | Name | Description
Protected method | CanExecute | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | CreateInstance | Creates an instance of the command class. (Overrides DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..CreateInstance()()()().)
Protected method | DoExecute | Performs the actual save operation. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..DoExecute()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Executed | Post processing handler. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalizeExecution | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the specified item.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareExecution | Prepares the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuted | Raises the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuting | Raises the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetChildrenCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Clone Method

[image] [image]

Sitecore 6.4.1 API
GetChildrenCommand..::..Clone Method
GetChildrenCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

GetChildrenCommand Class
GetChildrenCommand Members
Sitecore.Data.Engines.DataCommands Namespace


CreateInstance Method

[image]

Sitecore 6.4.1 API
GetChildrenCommand..::..CreateInstance Method
GetChildrenCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override GetChildrenCommand CreateInstance()
Visual Basic
Protected Overrides Function CreateInstance As GetChildrenCommand
Visual C++
protected:
virtual GetChildrenCommand^ CreateInstance() override

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Engines.DataCommands.GetChildrenCommand.CreateInstance"]

See Also

GetChildrenCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
GetChildrenCommand..::..Initialize Method
GetChildrenCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Initialize(
    Item item
)
Visual Basic
Public Overridable Sub Initialize ( _
    item As Item _
)
Visual C++
public:
virtual void Initialize(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

GetChildrenCommand Class
Sitecore.Data.Engines.DataCommands Namespace


GetChildrenCommand Properties

[image] [image]

Sitecore 6.4.1 API
GetChildrenCommand Properties
GetChildrenCommand Class See Also Send Feedback

The GetChildrenCommand type exposes the following members.

Properties

 | Name | Description
Public property | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Item | Gets the id of the item to get.
Public property | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

GetChildrenCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Item Property

[image]

Sitecore 6.4.1 API
GetChildrenCommand..::..Item Property
GetChildrenCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Item Item { get; }
Visual Basic
Public Overridable ReadOnly Property Item As Item
    Get
Visual C++
public:
virtual property Item^ Item {
    Item^ get ();
}

Field Value

The item.

See Also

GetChildrenCommand Class
Sitecore.Data.Engines.DataCommands Namespace


GetItemCommand Class

[image]

Sitecore 6.4.1 API
GetItemCommand Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetItemCommand : DataEngineCommand<Item, GetItemCommand>
Visual Basic
Public Class GetItemCommand _
    Inherits DataEngineCommand(Of Item, GetItemCommand)
Visual C++
public ref class GetItemCommand : public DataEngineCommand<Item^, GetItemCommand^>

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Engines..::..EngineCommand <(Of <(<' TReturnType, TCommandType >)>)>
Sitecore.Data.Engines..::..DataEngineCommand <(Of <(<' Item, GetItemCommand>)>)>
Sitecore.Data.Engines.DataCommands..::..GetItemCommand

See Also

GetItemCommand Members
Sitecore.Data.Engines.DataCommands Namespace


GetItemCommand Members

[image] [image]

Sitecore 6.4.1 API
GetItemCommand Members
GetItemCommand Class Constructors Methods Fields Properties See Also Send Feedback

The GetItemCommand type exposes the following members.

Constructors

 | Name | Description
Public method | GetItemCommand | Initializes a new instance of the GetItemCommand class.

Methods

 | Name | Description
Protected method | CanExecute | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | CreateInstance | Creates an instance of the command class. (Overrides DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..CreateInstance()()()().)
Protected method | DoExecute | Executes the command. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..DoExecute()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Executed | Post processing handler. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalizeExecution | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the specified item id.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareExecution | Prepares the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuted | Raises the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuting | Raises the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _lockType | (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

Properties

 | Name | Description
Public property | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | ItemId | Gets the id of the item to get.
Public property | Language | Gets the language of the item to get.
Public property | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Version | Gets the version of the item to get.

See Also

GetItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


GetItemCommand Constructor

[image]

Sitecore 6.4.1 API
GetItemCommand Constructor
GetItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetItemCommand()
Visual Basic
Public Sub New
Visual C++
public:
GetItemCommand()

See Also

GetItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


GetItemCommand Fields

[image] [image]

Sitecore 6.4.1 API
GetItemCommand Fields
GetItemCommand Class See Also Send Feedback

The GetItemCommand type exposes the following members.

Fields

 | Name | Description
Protected field | _lockType | (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

GetItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


GetItemCommand Methods

[image] [image]

Sitecore 6.4.1 API
GetItemCommand Methods
GetItemCommand Class See Also Send Feedback

The GetItemCommand type exposes the following members.

Methods

 | Name | Description
Protected method | CanExecute | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | CreateInstance | Creates an instance of the command class. (Overrides DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..CreateInstance()()()().)
Protected method | DoExecute | Executes the command. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..DoExecute()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Executed | Post processing handler. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalizeExecution | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the specified item id.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareExecution | Prepares the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuted | Raises the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuting | Raises the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Clone Method

[image] [image]

Sitecore 6.4.1 API
GetItemCommand..::..Clone Method
GetItemCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

GetItemCommand Class
GetItemCommand Members
Sitecore.Data.Engines.DataCommands Namespace


CreateInstance Method

[image]

Sitecore 6.4.1 API
GetItemCommand..::..CreateInstance Method
GetItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override GetItemCommand CreateInstance()
Visual Basic
Protected Overrides Function CreateInstance As GetItemCommand
Visual C++
protected:
virtual GetItemCommand^ CreateInstance() override

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Engines.DataCommands.GetItemCommand.CreateInstance"]

See Also

GetItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


DoExecute Method

[image]

Sitecore 6.4.1 API
GetItemCommand..::..DoExecute Method
GetItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override Item DoExecute()
Visual Basic
Protected Overrides Function DoExecute As Item
Visual C++
protected:
virtual Item^ DoExecute() override

Return Value

The item that was found. If no item was found, null is returned.

See Also

GetItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


GetItemCommand Properties

[image] [image]

Sitecore 6.4.1 API
GetItemCommand Properties
GetItemCommand Class See Also Send Feedback

The GetItemCommand type exposes the following members.

Properties

 | Name | Description
Public property | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | ItemId | Gets the id of the item to get.
Public property | Language | Gets the language of the item to get.
Public property | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Version | Gets the version of the item to get.

See Also

GetItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


ItemId Property

[image]

Sitecore 6.4.1 API
GetItemCommand..::..ItemId Property
GetItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ID ItemId { get; }
Visual Basic
Public Overridable ReadOnly Property ItemId As ID
    Get
Visual C++
public:
virtual property ID^ ItemId {
    ID^ get ();
}

Field Value

The item id.

See Also

GetItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Language Property

[image]

Sitecore 6.4.1 API
GetItemCommand..::..Language Property
GetItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Language Language { get; }
Visual Basic
Public Overridable ReadOnly Property Language As Language
    Get
Visual C++
public:
virtual property Language^ Language {
    Language^ get ();
}

Field Value

The language of the item to get.

See Also

GetItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Version Property

[image]

Sitecore 6.4.1 API
GetItemCommand..::..Version Property
GetItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Version Version { get; }
Visual Basic
Public Overridable ReadOnly Property Version As Version
    Get
Visual C++
public:
virtual property Version^ Version {
    Version^ get ();
}

Field Value

The version of the item to get.

See Also

GetItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


GetParentCommand Class

[image]

Sitecore 6.4.1 API
GetParentCommand Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetParentCommand : DataEngineCommand<Item, GetParentCommand>
Visual Basic
Public Class GetParentCommand _
    Inherits DataEngineCommand(Of Item, GetParentCommand)
Visual C++
public ref class GetParentCommand : public DataEngineCommand<Item^, GetParentCommand^>

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Engines..::..EngineCommand <(Of <(<' TReturnType, TCommandType >)>)>
Sitecore.Data.Engines..::..DataEngineCommand <(Of <(<' Item, GetParentCommand>)>)>
Sitecore.Data.Engines.DataCommands..::..GetParentCommand

See Also

GetParentCommand Members
Sitecore.Data.Engines.DataCommands Namespace


GetParentCommand Members

[image] [image]

Sitecore 6.4.1 API
GetParentCommand Members
GetParentCommand Class Constructors Methods Fields Properties See Also Send Feedback

The GetParentCommand type exposes the following members.

Constructors

 | Name | Description
Public method | GetParentCommand | Initializes a new instance of the GetParentCommand class

Methods

 | Name | Description
Protected method | CanExecute | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | CreateInstance | Creates an instance of the command class. (Overrides DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..CreateInstance()()()().)
Protected method | DoExecute | Executes the command. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..DoExecute()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Executed | Post processing handler. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalizeExecution | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the command.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareExecution | Prepares the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuted | Raises the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuting | Raises the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _lockType | (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

Properties

 | Name | Description
Public property | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Item | Gets the item to get the parent for.
Public property | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

GetParentCommand Class
Sitecore.Data.Engines.DataCommands Namespace


GetParentCommand Constructor

[image]

Sitecore 6.4.1 API
GetParentCommand Constructor
GetParentCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetParentCommand()
Visual Basic
Public Sub New
Visual C++
public:
GetParentCommand()

See Also

GetParentCommand Class
Sitecore.Data.Engines.DataCommands Namespace


GetParentCommand Fields

[image] [image]

Sitecore 6.4.1 API
GetParentCommand Fields
GetParentCommand Class See Also Send Feedback

The GetParentCommand type exposes the following members.

Fields

 | Name | Description
Protected field | _lockType | (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

GetParentCommand Class
Sitecore.Data.Engines.DataCommands Namespace


GetParentCommand Methods

[image] [image]

Sitecore 6.4.1 API
GetParentCommand Methods
GetParentCommand Class See Also Send Feedback

The GetParentCommand type exposes the following members.

Methods

 | Name | Description
Protected method | CanExecute | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | CreateInstance | Creates an instance of the command class. (Overrides DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..CreateInstance()()()().)
Protected method | DoExecute | Executes the command. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..DoExecute()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Executed | Post processing handler. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalizeExecution | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the command.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareExecution | Prepares the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuted | Raises the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuting | Raises the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetParentCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Clone Method

[image] [image]

Sitecore 6.4.1 API
GetParentCommand..::..Clone Method
GetParentCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

GetParentCommand Class
GetParentCommand Members
Sitecore.Data.Engines.DataCommands Namespace


CreateInstance Method

[image]

Sitecore 6.4.1 API
GetParentCommand..::..CreateInstance Method
GetParentCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override GetParentCommand CreateInstance()
Visual Basic
Protected Overrides Function CreateInstance As GetParentCommand
Visual C++
protected:
virtual GetParentCommand^ CreateInstance() override

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Engines.DataCommands.GetParentCommand.CreateInstance"]

See Also

GetParentCommand Class
Sitecore.Data.Engines.DataCommands Namespace


DoExecute Method

[image]

Sitecore 6.4.1 API
GetParentCommand..::..DoExecute Method
GetParentCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override Item DoExecute()
Visual Basic
Protected Overrides Function DoExecute As Item
Visual C++
protected:
virtual Item^ DoExecute() override

Return Value

The parent of Item. If the parent can not be found, null is returned.

See Also

GetParentCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
GetParentCommand..::..Initialize Method
GetParentCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Initialize(
    Item item
)
Visual Basic
Public Overridable Sub Initialize ( _
    item As Item _
)
Visual C++
public:
virtual void Initialize(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item to get the parent for.

See Also

GetParentCommand Class
Sitecore.Data.Engines.DataCommands Namespace


GetParentCommand Properties

[image] [image]

Sitecore 6.4.1 API
GetParentCommand Properties
GetParentCommand Class See Also Send Feedback

The GetParentCommand type exposes the following members.

Properties

 | Name | Description
Public property | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Item | Gets the item to get the parent for.
Public property | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

GetParentCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Item Property

[image]

Sitecore 6.4.1 API
GetParentCommand..::..Item Property
GetParentCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Item Item { get; }
Visual Basic
Public Overridable ReadOnly Property Item As Item
    Get
Visual C++
public:
virtual property Item^ Item {
    Item^ get ();
}

Field Value

The item.

See Also

GetParentCommand Class
Sitecore.Data.Engines.DataCommands Namespace


GetRootItemCommand Class

[image]

Sitecore 6.4.1 API
GetRootItemCommand Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetRootItemCommand : DataEngineCommand<Item, GetRootItemCommand>
Visual Basic
Public Class GetRootItemCommand _
    Inherits DataEngineCommand(Of Item, GetRootItemCommand)
Visual C++
public ref class GetRootItemCommand : public DataEngineCommand<Item^, GetRootItemCommand^>

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Engines..::..EngineCommand <(Of <(<' TReturnType, TCommandType >)>)>
Sitecore.Data.Engines..::..DataEngineCommand <(Of <(<' Item, GetRootItemCommand>)>)>
Sitecore.Data.Engines.DataCommands..::..GetRootItemCommand

See Also

GetRootItemCommand Members
Sitecore.Data.Engines.DataCommands Namespace


GetRootItemCommand Constructor

[image]

Sitecore 6.4.1 API
GetRootItemCommand Constructor
GetRootItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetRootItemCommand()
Visual Basic
Public Sub New
Visual C++
public:
GetRootItemCommand()

See Also

GetRootItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


GetRootItemCommand Fields

[image] [image]

Sitecore 6.4.1 API
GetRootItemCommand Fields
GetRootItemCommand Class See Also Send Feedback

The GetRootItemCommand type exposes the following members.

Fields

 | Name | Description
Protected field | _lockType | (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

GetRootItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Clone Method

[image] [image]

Sitecore 6.4.1 API
GetRootItemCommand..::..Clone Method
GetRootItemCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

GetRootItemCommand Class
GetRootItemCommand Members
Sitecore.Data.Engines.DataCommands Namespace


CreateInstance Method

[image]

Sitecore 6.4.1 API
GetRootItemCommand..::..CreateInstance Method
GetRootItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override GetRootItemCommand CreateInstance()
Visual Basic
Protected Overrides Function CreateInstance As GetRootItemCommand
Visual C++
protected:
virtual GetRootItemCommand^ CreateInstance() override

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Engines.DataCommands.GetRootItemCommand.CreateInstance"]

See Also

GetRootItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


DoExecute Method

[image]

Sitecore 6.4.1 API
GetRootItemCommand..::..DoExecute Method
GetRootItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override Item DoExecute()
Visual Basic
Protected Overrides Function DoExecute As Item
Visual C++
protected:
virtual Item^ DoExecute() override

Return Value

The the root item, null if no root item was found.

See Also

GetRootItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
GetRootItemCommand..::..Initialize Method
GetRootItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Initialize(
    Language language,
    Version version
)
Visual Basic
Public Overridable Sub Initialize ( _
    language As Language, _
    version As Version _
)
Visual C++
public:
virtual void Initialize(
    Language^ language,
    Version^ version
)

Parameters

language
Type: Sitecore.Globalization..::..Language

[Missing <param name="language"/> documentation for "M:Sitecore.Data.Engines.DataCommands.GetRootItemCommand.Initialize(Sitecore.Globalization.Language,Sitecore.Data.Version)"]

version
Type: Sitecore.Data..::..Version

[Missing <param name="version"/> documentation for "M:Sitecore.Data.Engines.DataCommands.GetRootItemCommand.Initialize(Sitecore.Globalization.Language,Sitecore.Data.Version)"]

See Also

GetRootItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


GetRootItemCommand Properties

[image] [image]

Sitecore 6.4.1 API
GetRootItemCommand Properties
GetRootItemCommand Class See Also Send Feedback

The GetRootItemCommand type exposes the following members.

Properties

 | Name | Description
Public property | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Language | Gets the language.
Public property | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Version | Gets the version.

See Also

GetRootItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Language Property

[image]

Sitecore 6.4.1 API
GetRootItemCommand..::..Language Property
GetRootItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Language Language { get; }
Visual Basic
Public ReadOnly Property Language As Language
    Get
Visual C++
public:
property Language^ Language {
    Language^ get ();
}

Field Value

The language.

See Also

GetRootItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Version Property

[image]

Sitecore 6.4.1 API
GetRootItemCommand..::..Version Property
GetRootItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Version Version { get; }
Visual Basic
Public ReadOnly Property Version As Version
    Get
Visual C++
public:
property Version^ Version {
    Version^ get ();
}

Field Value

The version.

See Also

GetRootItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


GetVersionsCommand Class

[image]

Sitecore 6.4.1 API
GetVersionsCommand Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetVersionsCommand : DataEngineCommand<VersionCollection, GetVersionsCommand>
Visual Basic
Public Class GetVersionsCommand _
    Inherits DataEngineCommand(Of VersionCollection, GetVersionsCommand)
Visual C++
public ref class GetVersionsCommand : public DataEngineCommand<VersionCollection^, GetVersionsCommand^>

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Engines..::..EngineCommand <(Of <(<' TReturnType, TCommandType >)>)>
Sitecore.Data.Engines..::..DataEngineCommand <(Of <(<' VersionCollection, GetVersionsCommand>)>)>
Sitecore.Data.Engines.DataCommands..::..GetVersionsCommand

See Also

GetVersionsCommand Members
Sitecore.Data.Engines.DataCommands Namespace


GetVersionsCommand Members

[image] [image]

Sitecore 6.4.1 API
GetVersionsCommand Members
GetVersionsCommand Class Constructors Methods Fields Properties See Also Send Feedback

The GetVersionsCommand type exposes the following members.

Constructors

 | Name | Description
Public method | GetVersionsCommand | Initializes a new instance of the GetVersionsCommand class

Methods

 | Name | Description
Protected method | CanExecute | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | CreateInstance | Creates an instance of the command class. (Overrides DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..CreateInstance()()()().)
Protected method | DoExecute | Executes the command. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..DoExecute()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Executed | Post processing handler. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalizeExecution | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the command.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareExecution | Prepares the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuted | Raises the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuting | Raises the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _lockType | (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

Properties

 | Name | Description
Public property | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Item | Gets the id of the item to get the versions for.
Public property | Language | Gets the language to get the versions for.
Public property | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

GetVersionsCommand Class
Sitecore.Data.Engines.DataCommands Namespace


GetVersionsCommand Constructor

[image]

Sitecore 6.4.1 API
GetVersionsCommand Constructor
GetVersionsCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetVersionsCommand()
Visual Basic
Public Sub New
Visual C++
public:
GetVersionsCommand()

See Also

GetVersionsCommand Class
Sitecore.Data.Engines.DataCommands Namespace


GetVersionsCommand Fields

[image] [image]

Sitecore 6.4.1 API
GetVersionsCommand Fields
GetVersionsCommand Class See Also Send Feedback

The GetVersionsCommand type exposes the following members.

Fields

 | Name | Description
Protected field | _lockType | (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

GetVersionsCommand Class
Sitecore.Data.Engines.DataCommands Namespace


GetVersionsCommand Methods

[image] [image]

Sitecore 6.4.1 API
GetVersionsCommand Methods
GetVersionsCommand Class See Also Send Feedback

The GetVersionsCommand type exposes the following members.

Methods

 | Name | Description
Protected method | CanExecute | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | CreateInstance | Creates an instance of the command class. (Overrides DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..CreateInstance()()()().)
Protected method | DoExecute | Executes the command. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..DoExecute()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Executed | Post processing handler. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalizeExecution | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the command.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareExecution | Prepares the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuted | Raises the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuting | Raises the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetVersionsCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Clone Method

[image] [image]

Sitecore 6.4.1 API
GetVersionsCommand..::..Clone Method
GetVersionsCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

GetVersionsCommand Class
GetVersionsCommand Members
Sitecore.Data.Engines.DataCommands Namespace


CreateInstance Method

[image]

Sitecore 6.4.1 API
GetVersionsCommand..::..CreateInstance Method
GetVersionsCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override GetVersionsCommand CreateInstance()
Visual Basic
Protected Overrides Function CreateInstance As GetVersionsCommand
Visual C++
protected:
virtual GetVersionsCommand^ CreateInstance() override

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Engines.DataCommands.GetVersionsCommand.CreateInstance"]

See Also

GetVersionsCommand Class
Sitecore.Data.Engines.DataCommands Namespace


DoExecute Method

[image]

Sitecore 6.4.1 API
GetVersionsCommand..::..DoExecute Method
GetVersionsCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override VersionCollection DoExecute()
Visual Basic
Protected Overrides Function DoExecute As VersionCollection
Visual C++
protected:
virtual VersionCollection^ DoExecute() override

Return Value

The parent of Item. If the parent can not be found, null is returned.

See Also

GetVersionsCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
GetVersionsCommand..::..Initialize Method
GetVersionsCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Initialize(
    Item item,
    Language language
)
Visual Basic
Public Overridable Sub Initialize ( _
    item As Item, _
    language As Language _
)
Visual C++
public:
virtual void Initialize(
    Item^ item,
    Language^ language
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
language
Type: Sitecore.Globalization..::..Language
The language.

See Also

GetVersionsCommand Class
Sitecore.Data.Engines.DataCommands Namespace


GetVersionsCommand Properties

[image] [image]

Sitecore 6.4.1 API
GetVersionsCommand Properties
GetVersionsCommand Class See Also Send Feedback

The GetVersionsCommand type exposes the following members.

Properties

 | Name | Description
Public property | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Item | Gets the id of the item to get the versions for.
Public property | Language | Gets the language to get the versions for.
Public property | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

GetVersionsCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Item Property

[image]

Sitecore 6.4.1 API
GetVersionsCommand..::..Item Property
GetVersionsCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Item Item { get; }
Visual Basic
Public Overridable ReadOnly Property Item As Item
    Get
Visual C++
public:
virtual property Item^ Item {
    Item^ get ();
}

Field Value

The item id.

See Also

GetVersionsCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Language Property

[image]

Sitecore 6.4.1 API
GetVersionsCommand..::..Language Property
GetVersionsCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Language Language { get; }
Visual Basic
Public ReadOnly Property Language As Language
    Get
Visual C++
public:
property Language^ Language {
    Language^ get ();
}

Field Value

The language.

See Also

GetVersionsCommand Class
Sitecore.Data.Engines.DataCommands Namespace


HasChildrenCommand Class

[image]

Sitecore 6.4.1 API
HasChildrenCommand Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class HasChildrenCommand : DataEngineCommand<bool, HasChildrenCommand>
Visual Basic
Public Class HasChildrenCommand _
    Inherits DataEngineCommand(Of Boolean, HasChildrenCommand)
Visual C++
public ref class HasChildrenCommand : public DataEngineCommand<bool, HasChildrenCommand^>

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Engines..::..EngineCommand <(Of <(<' TReturnType, TCommandType >)>)>
Sitecore.Data.Engines..::..DataEngineCommand <(Of <(<' Boolean, HasChildrenCommand>)>)>
Sitecore.Data.Engines.DataCommands..::..HasChildrenCommand

See Also

HasChildrenCommand Members
Sitecore.Data.Engines.DataCommands Namespace


HasChildrenCommand Members

[image] [image]

Sitecore 6.4.1 API
HasChildrenCommand Members
HasChildrenCommand Class Constructors Methods Fields Properties See Also Send Feedback

The HasChildrenCommand type exposes the following members.

Constructors

 | Name | Description
Public method | HasChildrenCommand | Initializes a new instance of the HasChildrenCommand class

Methods

 | Name | Description
Protected method | CanExecute | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | CreateInstance | Creates an instance of the command class. (Overrides DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..CreateInstance()()()().)
Protected method | DoExecute | Performs the actual save operation. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..DoExecute()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Executed | Post processing handler. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalizeExecution | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the specified item.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareExecution | Prepares the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuted | Raises the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuting | Raises the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _lockType | (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

Properties

 | Name | Description
Public property | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Item | Gets the id of the item to get.
Public property | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

HasChildrenCommand Class
Sitecore.Data.Engines.DataCommands Namespace


HasChildrenCommand Fields

[image] [image]

Sitecore 6.4.1 API
HasChildrenCommand Fields
HasChildrenCommand Class See Also Send Feedback

The HasChildrenCommand type exposes the following members.

Fields

 | Name | Description
Protected field | _lockType | (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

HasChildrenCommand Class
Sitecore.Data.Engines.DataCommands Namespace


HasChildrenCommand Methods

[image] [image]

Sitecore 6.4.1 API
HasChildrenCommand Methods
HasChildrenCommand Class See Also Send Feedback

The HasChildrenCommand type exposes the following members.

Methods

 | Name | Description
Protected method | CanExecute | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | CreateInstance | Creates an instance of the command class. (Overrides DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..CreateInstance()()()().)
Protected method | DoExecute | Performs the actual save operation. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..DoExecute()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Executed | Post processing handler. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalizeExecution | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the specified item.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareExecution | Prepares the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuted | Raises the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuting | Raises the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HasChildrenCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Clone Method

[image] [image]

Sitecore 6.4.1 API
HasChildrenCommand..::..Clone Method
HasChildrenCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

HasChildrenCommand Class
HasChildrenCommand Members
Sitecore.Data.Engines.DataCommands Namespace


CreateInstance Method

[image]

Sitecore 6.4.1 API
HasChildrenCommand..::..CreateInstance Method
HasChildrenCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override HasChildrenCommand CreateInstance()
Visual Basic
Protected Overrides Function CreateInstance As HasChildrenCommand
Visual C++
protected:
virtual HasChildrenCommand^ CreateInstance() override

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Engines.DataCommands.HasChildrenCommand.CreateInstance"]

See Also

HasChildrenCommand Class
Sitecore.Data.Engines.DataCommands Namespace


DoExecute Method

[image]

Sitecore 6.4.1 API
HasChildrenCommand..::..DoExecute Method
HasChildrenCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override bool DoExecute()
Visual Basic
Protected Overrides Function DoExecute As Boolean
Visual C++
protected:
virtual bool DoExecute() override

Return Value

The result of execution.

See Also

HasChildrenCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
HasChildrenCommand..::..Initialize Method
HasChildrenCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Initialize(
    Item item
)
Visual Basic
Public Overridable Sub Initialize ( _
    item As Item _
)
Visual C++
public:
virtual void Initialize(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

HasChildrenCommand Class
Sitecore.Data.Engines.DataCommands Namespace


HasChildrenCommand Properties

[image] [image]

Sitecore 6.4.1 API
HasChildrenCommand Properties
HasChildrenCommand Class See Also Send Feedback

The HasChildrenCommand type exposes the following members.

Properties

 | Name | Description
Public property | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Item | Gets the id of the item to get.
Public property | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

HasChildrenCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Item Property

[image]

Sitecore 6.4.1 API
HasChildrenCommand..::..Item Property
HasChildrenCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Item Item { get; }
Visual Basic
Public Overridable ReadOnly Property Item As Item
    Get
Visual C++
public:
virtual property Item^ Item {
    Item^ get ();
}

Field Value

The item.

See Also

HasChildrenCommand Class
Sitecore.Data.Engines.DataCommands Namespace


MoveItemCommand Class

[image]

Sitecore 6.4.1 API
MoveItemCommand Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class MoveItemCommand : DataEngineCommand<bool, MoveItemCommand>
Visual Basic
Public Class MoveItemCommand _
    Inherits DataEngineCommand(Of Boolean, MoveItemCommand)
Visual C++
public ref class MoveItemCommand : public DataEngineCommand<bool, MoveItemCommand^>

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Engines..::..EngineCommand <(Of <(<' TReturnType, TCommandType >)>)>
Sitecore.Data.Engines..::..DataEngineCommand <(Of <(<' Boolean, MoveItemCommand>)>)>
Sitecore.Data.Engines.DataCommands..::..MoveItemCommand

See Also

MoveItemCommand Members
Sitecore.Data.Engines.DataCommands Namespace


MoveItemCommand Members

[image] [image]

Sitecore 6.4.1 API
MoveItemCommand Members
MoveItemCommand Class Constructors Methods Fields Properties See Also Send Feedback

The MoveItemCommand type exposes the following members.

Constructors

 | Name | Description
Public method | MoveItemCommand | Initializes a new instance of the MoveItemCommand class

Methods

 | Name | Description
Protected method | CanExecute | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | CreateInstance | Creates an instance of the command class. (Overrides DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..CreateInstance()()()().)
Protected method | DoExecute | Executes the command. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..DoExecute()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Executed | Post processing handler. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalizeExecution | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the command.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareExecution | Prepares the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuted | Raises the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuting | Raises the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _lockType | (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

Properties

 | Name | Description
Public property | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Destination | Gets the destination. This will be the parent of the moved item.
Public property | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Item | Gets the item to move.
Public property | OldParentId | Gets the old parent id.
Public property | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

MoveItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


MoveItemCommand Constructor

[image]

Sitecore 6.4.1 API
MoveItemCommand Constructor
MoveItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MoveItemCommand()
Visual Basic
Public Sub New
Visual C++
public:
MoveItemCommand()

See Also

MoveItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


MoveItemCommand Fields

[image] [image]

Sitecore 6.4.1 API
MoveItemCommand Fields
MoveItemCommand Class See Also Send Feedback

The MoveItemCommand type exposes the following members.

Fields

 | Name | Description
Protected field | _lockType | (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

MoveItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


MoveItemCommand Methods

[image] [image]

Sitecore 6.4.1 API
MoveItemCommand Methods
MoveItemCommand Class See Also Send Feedback

The MoveItemCommand type exposes the following members.

Methods

 | Name | Description
Protected method | CanExecute | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | CreateInstance | Creates an instance of the command class. (Overrides DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..CreateInstance()()()().)
Protected method | DoExecute | Executes the command. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..DoExecute()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Executed | Post processing handler. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalizeExecution | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the command.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareExecution | Prepares the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuted | Raises the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuting | Raises the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MoveItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Clone Method

[image] [image]

Sitecore 6.4.1 API
MoveItemCommand..::..Clone Method
MoveItemCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

MoveItemCommand Class
MoveItemCommand Members
Sitecore.Data.Engines.DataCommands Namespace


DoExecute Method

[image]

Sitecore 6.4.1 API
MoveItemCommand..::..DoExecute Method
MoveItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override bool DoExecute()
Visual Basic
Protected Overrides Function DoExecute As Boolean
Visual C++
protected:
virtual bool DoExecute() override

Return Value

If the item was moved, true is returned. Otherwise, false is returned.

See Also

MoveItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
MoveItemCommand..::..Initialize Method
MoveItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Initialize(
    Item item,
    Item destination
)
Visual Basic
Public Overridable Sub Initialize ( _
    item As Item, _
    destination As Item _
)
Visual C++
public:
virtual void Initialize(
    Item^ item,
    Item^ destination
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item to move.
destination
Type: Sitecore.Data.Items..::..Item
The destination.

See Also

MoveItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


MoveItemCommand Properties

[image] [image]

Sitecore 6.4.1 API
MoveItemCommand Properties
MoveItemCommand Class See Also Send Feedback

The MoveItemCommand type exposes the following members.

Properties

 | Name | Description
Public property | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Destination | Gets the destination. This will be the parent of the moved item.
Public property | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Item | Gets the item to move.
Public property | OldParentId | Gets the old parent id.
Public property | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

MoveItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Destination Property

[image]

Sitecore 6.4.1 API
MoveItemCommand..::..Destination Property
MoveItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Destination { get; }
Visual Basic
Public ReadOnly Property Destination As Item
    Get
Visual C++
public:
property Item^ Destination {
    Item^ get ();
}

Field Value

The destination.

See Also

MoveItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Item Property

[image]

Sitecore 6.4.1 API
MoveItemCommand..::..Item Property
MoveItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Item Item { get; }
Visual Basic
Public Overridable ReadOnly Property Item As Item
    Get
Visual C++
public:
virtual property Item^ Item {
    Item^ get ();
}

Field Value

The item.

See Also

MoveItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


OldParentId Property

[image]

Sitecore 6.4.1 API
MoveItemCommand..::..OldParentId Property
MoveItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID OldParentId { get; }
Visual Basic
Public ReadOnly Property OldParentId As ID
    Get
Visual C++
public:
property ID^ OldParentId {
    ID^ get ();
}

Field Value

The old parent id.

See Also

MoveItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


RemoveDataCommand Class

[image]

Sitecore 6.4.1 API
RemoveDataCommand Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RemoveDataCommand : DataEngineCommand<bool, RemoveDataCommand>
Visual Basic
Public Class RemoveDataCommand _
    Inherits DataEngineCommand(Of Boolean, RemoveDataCommand)
Visual C++
public ref class RemoveDataCommand : public DataEngineCommand<bool, RemoveDataCommand^>

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Engines..::..EngineCommand <(Of <(<' TReturnType, TCommandType >)>)>
Sitecore.Data.Engines..::..DataEngineCommand <(Of <(<' Boolean, RemoveDataCommand>)>)>
Sitecore.Data.Engines.DataCommands..::..RemoveDataCommand

See Also

RemoveDataCommand Members
Sitecore.Data.Engines.DataCommands Namespace


RemoveDataCommand Members

[image] [image]

Sitecore 6.4.1 API
RemoveDataCommand Members
RemoveDataCommand Class Constructors Methods Fields Properties See Also Send Feedback

The RemoveDataCommand type exposes the following members.

Constructors

 | Name | Description
Public method | RemoveDataCommand | Initializes a new instance of the RemoveDataCommand class.

Methods

 | Name | Description
Protected method | CanExecute | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | CreateInstance | Creates an instance of the command class. (Overrides DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..CreateInstance()()()().)
Protected method | DoExecute | Executes the command. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..DoExecute()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Executed | Post processing handler. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalizeExecution | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the command.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareExecution | Prepares the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuted | Raises the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuting | Raises the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _lockType | (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

Properties

 | Name | Description
Public property | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | ItemId | Gets the id of the item.
Public property | Language | Gets the language of the data to remove.
Public property | RemoveAllLanguages | Gets a value indicating whether to remove data in all languages.
Public property | RemoveSharedData | Gets a value indicating whether to remove shared data.
Public property | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

RemoveDataCommand Class
Sitecore.Data.Engines.DataCommands Namespace


RemoveDataCommand Constructor

[image]

Sitecore 6.4.1 API
RemoveDataCommand Constructor
RemoveDataCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RemoveDataCommand()
Visual Basic
Public Sub New
Visual C++
public:
RemoveDataCommand()

See Also

RemoveDataCommand Class
Sitecore.Data.Engines.DataCommands Namespace


RemoveDataCommand Fields

[image] [image]

Sitecore 6.4.1 API
RemoveDataCommand Fields
RemoveDataCommand Class See Also Send Feedback

The RemoveDataCommand type exposes the following members.

Fields

 | Name | Description
Protected field | _lockType | (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

RemoveDataCommand Class
Sitecore.Data.Engines.DataCommands Namespace


RemoveDataCommand Methods

[image] [image]

Sitecore 6.4.1 API
RemoveDataCommand Methods
RemoveDataCommand Class See Also Send Feedback

The RemoveDataCommand type exposes the following members.

Methods

 | Name | Description
Protected method | CanExecute | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | CreateInstance | Creates an instance of the command class. (Overrides DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..CreateInstance()()()().)
Protected method | DoExecute | Executes the command. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..DoExecute()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Executed | Post processing handler. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalizeExecution | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the command.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareExecution | Prepares the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuted | Raises the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuting | Raises the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RemoveDataCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Clone Method

[image] [image]

Sitecore 6.4.1 API
RemoveDataCommand..::..Clone Method
RemoveDataCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

RemoveDataCommand Class
RemoveDataCommand Members
Sitecore.Data.Engines.DataCommands Namespace


CreateInstance Method

[image]

Sitecore 6.4.1 API
RemoveDataCommand..::..CreateInstance Method
RemoveDataCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override RemoveDataCommand CreateInstance()
Visual Basic
Protected Overrides Function CreateInstance As RemoveDataCommand
Visual C++
protected:
virtual RemoveDataCommand^ CreateInstance() override

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Engines.DataCommands.RemoveDataCommand.CreateInstance"]

See Also

RemoveDataCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
RemoveDataCommand..::..Initialize Method
RemoveDataCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Initialize(
    ID itemId,
    Language language,
    bool removeSharedData
)
Visual Basic
Public Overridable Sub Initialize ( _
    itemId As ID, _
    language As Language, _
    removeSharedData As Boolean _
)
Visual C++
public:
virtual void Initialize(
    ID^ itemId,
    Language^ language,
    bool removeSharedData
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The id of the item.
language
Type: Sitecore.Globalization..::..Language
The language of the data to remove.
removeSharedData
Type: System..::..Boolean
If set to true shared data is removed.

See Also

RemoveDataCommand Class
Sitecore.Data.Engines.DataCommands Namespace


RemoveDataCommand Properties

[image] [image]

Sitecore 6.4.1 API
RemoveDataCommand Properties
RemoveDataCommand Class See Also Send Feedback

The RemoveDataCommand type exposes the following members.

Properties

 | Name | Description
Public property | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | ItemId | Gets the id of the item.
Public property | Language | Gets the language of the data to remove.
Public property | RemoveAllLanguages | Gets a value indicating whether to remove data in all languages.
Public property | RemoveSharedData | Gets a value indicating whether to remove shared data.
Public property | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

RemoveDataCommand Class
Sitecore.Data.Engines.DataCommands Namespace


ItemId Property

[image]

Sitecore 6.4.1 API
RemoveDataCommand..::..ItemId Property
RemoveDataCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ID ItemId { get; }
Visual Basic
Public Overridable ReadOnly Property ItemId As ID
    Get
Visual C++
public:
virtual property ID^ ItemId {
    ID^ get ();
}

Field Value

The item id.

See Also

RemoveDataCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Language Property

[image]

Sitecore 6.4.1 API
RemoveDataCommand..::..Language Property
RemoveDataCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Language Language { get; }
Visual Basic
Public Overridable ReadOnly Property Language As Language
    Get
Visual C++
public:
virtual property Language^ Language {
    Language^ get ();
}

Field Value

The language.

Remarks

If all data is to be removed, Invariant is returned.

See Also

RemoveDataCommand Class
Sitecore.Data.Engines.DataCommands Namespace


RemoveAllLanguages Property

[image]

Sitecore 6.4.1 API
RemoveDataCommand..::..RemoveAllLanguages Property
RemoveDataCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool RemoveAllLanguages { get; }
Visual Basic
Public Overridable ReadOnly Property RemoveAllLanguages As Boolean
    Get
Visual C++
public:
virtual property bool RemoveAllLanguages {
    bool get ();
}

Field Value

true if data in all languages will be removed; otherwise, false.

See Also

RemoveDataCommand Class
Sitecore.Data.Engines.DataCommands Namespace


RemoveVersionCommand Class

[image]

Sitecore 6.4.1 API
RemoveVersionCommand Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RemoveVersionCommand : DataEngineCommand<bool, RemoveVersionCommand>
Visual Basic
Public Class RemoveVersionCommand _
    Inherits DataEngineCommand(Of Boolean, RemoveVersionCommand)
Visual C++
public ref class RemoveVersionCommand : public DataEngineCommand<bool, RemoveVersionCommand^>

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Engines..::..EngineCommand <(Of <(<' TReturnType, TCommandType >)>)>
Sitecore.Data.Engines..::..DataEngineCommand <(Of <(<' Boolean, RemoveVersionCommand>)>)>
Sitecore.Data.Engines.DataCommands..::..RemoveVersionCommand

See Also

RemoveVersionCommand Members
Sitecore.Data.Engines.DataCommands Namespace


RemoveVersionCommand Constructor

[image]

Sitecore 6.4.1 API
RemoveVersionCommand Constructor
RemoveVersionCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RemoveVersionCommand()
Visual Basic
Public Sub New
Visual C++
public:
RemoveVersionCommand()

See Also

RemoveVersionCommand Class
Sitecore.Data.Engines.DataCommands Namespace


RemoveVersionCommand Fields

[image] [image]

Sitecore 6.4.1 API
RemoveVersionCommand Fields
RemoveVersionCommand Class See Also Send Feedback

The RemoveVersionCommand type exposes the following members.

Fields

 | Name | Description
Protected field | _lockType | (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

RemoveVersionCommand Class
Sitecore.Data.Engines.DataCommands Namespace


RemoveVersionCommand Methods

[image] [image]

Sitecore 6.4.1 API
RemoveVersionCommand Methods
RemoveVersionCommand Class See Also Send Feedback

The RemoveVersionCommand type exposes the following members.

Methods

 | Name | Description
Protected method | CanExecute | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | CreateInstance | Creates an instance of the command class. (Overrides DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..CreateInstance()()()().)
Protected method | DoExecute | Executes the command. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..DoExecute()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Executed | Post processing handler. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalizeExecution | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the command.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareExecution | Prepares the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuted | Raises the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuting | Raises the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RemoveVersionCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Clone Method

[image] [image]

Sitecore 6.4.1 API
RemoveVersionCommand..::..Clone Method
RemoveVersionCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

RemoveVersionCommand Class
RemoveVersionCommand Members
Sitecore.Data.Engines.DataCommands Namespace


CreateInstance Method

[image]

Sitecore 6.4.1 API
RemoveVersionCommand..::..CreateInstance Method
RemoveVersionCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override RemoveVersionCommand CreateInstance()
Visual Basic
Protected Overrides Function CreateInstance As RemoveVersionCommand
Visual C++
protected:
virtual RemoveVersionCommand^ CreateInstance() override

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Engines.DataCommands.RemoveVersionCommand.CreateInstance"]

See Also

RemoveVersionCommand Class
Sitecore.Data.Engines.DataCommands Namespace


DoExecute Method

[image]

Sitecore 6.4.1 API
RemoveVersionCommand..::..DoExecute Method
RemoveVersionCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override bool DoExecute()
Visual Basic
Protected Overrides Function DoExecute As Boolean
Visual C++
protected:
virtual bool DoExecute() override

Return Value

true if the version was removed; otherwise false.

See Also

RemoveVersionCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
RemoveVersionCommand..::..Initialize Method
RemoveVersionCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Initialize(
    Item item
)
Visual Basic
Public Overridable Sub Initialize ( _
    item As Item _
)
Visual C++
public:
virtual void Initialize(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item representing the version to remove.

See Also

RemoveVersionCommand Class
Sitecore.Data.Engines.DataCommands Namespace


RemoveVersionCommand Properties

[image] [image]

Sitecore 6.4.1 API
RemoveVersionCommand Properties
RemoveVersionCommand Class See Also Send Feedback

The RemoveVersionCommand type exposes the following members.

Properties

 | Name | Description
Public property | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Item | Gets the item representing the version to remove.
Public property | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

RemoveVersionCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Item Property

[image]

Sitecore 6.4.1 API
RemoveVersionCommand..::..Item Property
RemoveVersionCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Item Item { get; }
Visual Basic
Public Overridable ReadOnly Property Item As Item
    Get
Visual C++
public:
virtual property Item^ Item {
    Item^ get ();
}

Field Value

The item.

See Also

RemoveVersionCommand Class
Sitecore.Data.Engines.DataCommands Namespace


ResolvePathCommand Class

[image]

Sitecore 6.4.1 API
ResolvePathCommand Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ResolvePathCommand : DataEngineCommand<ID, ResolvePathCommand>
Visual Basic
Public Class ResolvePathCommand _
    Inherits DataEngineCommand(Of ID, ResolvePathCommand)
Visual C++
public ref class ResolvePathCommand : public DataEngineCommand<ID^, ResolvePathCommand^>

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Engines..::..EngineCommand <(Of <(<' TReturnType, TCommandType >)>)>
Sitecore.Data.Engines..::..DataEngineCommand <(Of <(<' ID, ResolvePathCommand>)>)>
Sitecore.Data.Engines.DataCommands..::..ResolvePathCommand

See Also

ResolvePathCommand Members
Sitecore.Data.Engines.DataCommands Namespace


ResolvePathCommand Members

[image] [image]

Sitecore 6.4.1 API
ResolvePathCommand Members
ResolvePathCommand Class Constructors Methods Fields Properties See Also Send Feedback

The ResolvePathCommand type exposes the following members.

Constructors

 | Name | Description
Public method | ResolvePathCommand | Initializes a new instance of the ResolvePathCommand class

Methods

 | Name | Description
Protected method | CanExecute | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | CreateInstance | Creates an instance of the command class. (Overrides DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..CreateInstance()()()().)
Protected method | DoExecute | Executes the command. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..DoExecute()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Executed | Post processing handler. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalizeExecution | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the specified item path.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareExecution | Prepares the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuted | Raises the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuting | Raises the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _lockType | (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

Properties

 | Name | Description
Public property | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | ItemPath | Gets the id of the item to get.
Public property | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

ResolvePathCommand Class
Sitecore.Data.Engines.DataCommands Namespace


ResolvePathCommand Constructor

[image]

Sitecore 6.4.1 API
ResolvePathCommand Constructor
ResolvePathCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ResolvePathCommand()
Visual Basic
Public Sub New
Visual C++
public:
ResolvePathCommand()

See Also

ResolvePathCommand Class
Sitecore.Data.Engines.DataCommands Namespace


ResolvePathCommand Fields

[image] [image]

Sitecore 6.4.1 API
ResolvePathCommand Fields
ResolvePathCommand Class See Also Send Feedback

The ResolvePathCommand type exposes the following members.

Fields

 | Name | Description
Protected field | _lockType | (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

ResolvePathCommand Class
Sitecore.Data.Engines.DataCommands Namespace


ResolvePathCommand Methods

[image] [image]

Sitecore 6.4.1 API
ResolvePathCommand Methods
ResolvePathCommand Class See Also Send Feedback

The ResolvePathCommand type exposes the following members.

Methods

 | Name | Description
Protected method | CanExecute | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | CreateInstance | Creates an instance of the command class. (Overrides DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..CreateInstance()()()().)
Protected method | DoExecute | Executes the command. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..DoExecute()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Executed | Post processing handler. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalizeExecution | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the specified item path.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareExecution | Prepares the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuted | Raises the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuting | Raises the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ResolvePathCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Clone Method

[image] [image]

Sitecore 6.4.1 API
ResolvePathCommand..::..Clone Method
ResolvePathCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

ResolvePathCommand Class
ResolvePathCommand Members
Sitecore.Data.Engines.DataCommands Namespace


CreateInstance Method

[image]

Sitecore 6.4.1 API
ResolvePathCommand..::..CreateInstance Method
ResolvePathCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ResolvePathCommand CreateInstance()
Visual Basic
Protected Overrides Function CreateInstance As ResolvePathCommand
Visual C++
protected:
virtual ResolvePathCommand^ CreateInstance() override

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Engines.DataCommands.ResolvePathCommand.CreateInstance"]

See Also

ResolvePathCommand Class
Sitecore.Data.Engines.DataCommands Namespace


DoExecute Method

[image]

Sitecore 6.4.1 API
ResolvePathCommand..::..DoExecute Method
ResolvePathCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ID DoExecute()
Visual Basic
Protected Overrides Function DoExecute As ID
Visual C++
protected:
virtual ID^ DoExecute() override

Return Value

The id of the resolved item. If no item is found, null is returned.

See Also

ResolvePathCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
ResolvePathCommand..::..Initialize Method
ResolvePathCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Initialize(
    string itemPath
)
Visual Basic
Public Overridable Sub Initialize ( _
    itemPath As String _
)
Visual C++
public:
virtual void Initialize(
    String^ itemPath
)

Parameters

itemPath
Type: System..::..String
The item path.

See Also

ResolvePathCommand Class
Sitecore.Data.Engines.DataCommands Namespace


ResolvePathCommand Properties

[image] [image]

Sitecore 6.4.1 API
ResolvePathCommand Properties
ResolvePathCommand Class See Also Send Feedback

The ResolvePathCommand type exposes the following members.

Properties

 | Name | Description
Public property | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | ItemPath | Gets the id of the item to get.
Public property | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

ResolvePathCommand Class
Sitecore.Data.Engines.DataCommands Namespace


SaveItemCommand Class

[image]

Sitecore 6.4.1 API
SaveItemCommand Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SaveItemCommand : DataEngineCommand<bool, SaveItemCommand>
Visual Basic
Public Class SaveItemCommand _
    Inherits DataEngineCommand(Of Boolean, SaveItemCommand)
Visual C++
public ref class SaveItemCommand : public DataEngineCommand<bool, SaveItemCommand^>

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Engines..::..EngineCommand <(Of <(<' TReturnType, TCommandType >)>)>
Sitecore.Data.Engines..::..DataEngineCommand <(Of <(<' Boolean, SaveItemCommand>)>)>
Sitecore.Data.Engines.DataCommands..::..SaveItemCommand

See Also

SaveItemCommand Members
Sitecore.Data.Engines.DataCommands Namespace


SaveItemCommand Members

[image] [image]

Sitecore 6.4.1 API
SaveItemCommand Members
SaveItemCommand Class Constructors Methods Fields Properties See Also Send Feedback

The SaveItemCommand type exposes the following members.

Constructors

 | Name | Description
Public method | SaveItemCommand | Initializes a new instance of the SaveItemCommand class.

Methods

 | Name | Description
Protected method | CanExecute | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | CreateInstance | Creates an instance of the command class. (Overrides DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..CreateInstance()()()().)
Protected method | DoExecute | Executes the save command. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..DoExecute()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Executed | Post processing handler. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalizeExecution | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the command.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareExecution | Prepares the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuted | Raises the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuting | Raises the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _lockType | (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

Properties

 | Name | Description
Public property | Changes | Gets the changes being saved.
Public property | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Item | Gets the Item being saved.
Public property | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

SaveItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


SaveItemCommand Constructor

[image]

Sitecore 6.4.1 API
SaveItemCommand Constructor
SaveItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SaveItemCommand()
Visual Basic
Public Sub New
Visual C++
public:
SaveItemCommand()

See Also

SaveItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


SaveItemCommand Fields

[image] [image]

Sitecore 6.4.1 API
SaveItemCommand Fields
SaveItemCommand Class See Also Send Feedback

The SaveItemCommand type exposes the following members.

Fields

 | Name | Description
Protected field | _lockType | (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

SaveItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


SaveItemCommand Methods

[image] [image]

Sitecore 6.4.1 API
SaveItemCommand Methods
SaveItemCommand Class See Also Send Feedback

The SaveItemCommand type exposes the following members.

Methods

 | Name | Description
Protected method | CanExecute | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | CreateInstance | Creates an instance of the command class. (Overrides DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..CreateInstance()()()().)
Protected method | DoExecute | Executes the save command. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..DoExecute()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Executed | Post processing handler. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalizeExecution | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the command.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareExecution | Prepares the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuted | Raises the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuting | Raises the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SaveItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


CreateInstance Method

[image]

Sitecore 6.4.1 API
SaveItemCommand..::..CreateInstance Method
SaveItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override SaveItemCommand CreateInstance()
Visual Basic
Protected Overrides Function CreateInstance As SaveItemCommand
Visual C++
protected:
virtual SaveItemCommand^ CreateInstance() override

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Engines.DataCommands.SaveItemCommand.CreateInstance"]

See Also

SaveItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


DoExecute Method

[image]

Sitecore 6.4.1 API
SaveItemCommand..::..DoExecute Method
SaveItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override bool DoExecute()
Visual Basic
Protected Overrides Function DoExecute As Boolean
Visual C++
protected:
virtual bool DoExecute() override

Return Value

True if the item was saved, false otherwise.

See Also

SaveItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
SaveItemCommand..::..Initialize Method
SaveItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Initialize(
    Item item
)
Visual Basic
Public Overridable Sub Initialize ( _
    item As Item _
)
Visual C++
public:
virtual void Initialize(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item to save.

See Also

SaveItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


SaveItemCommand Properties

[image] [image]

Sitecore 6.4.1 API
SaveItemCommand Properties
SaveItemCommand Class See Also Send Feedback

The SaveItemCommand type exposes the following members.

Properties

 | Name | Description
Public property | Changes | Gets the changes being saved.
Public property | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Item | Gets the Item being saved.
Public property | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

SaveItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Changes Property

[image]

Sitecore 6.4.1 API
SaveItemCommand..::..Changes Property
SaveItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ItemChanges Changes { get; }
Visual Basic
Public Overridable ReadOnly Property Changes As ItemChanges
    Get
Visual C++
public:
virtual property ItemChanges^ Changes {
    ItemChanges^ get ();
}

Field Value

The changes.

See Also

SaveItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Item Property

[image]

Sitecore 6.4.1 API
SaveItemCommand..::..Item Property
SaveItemCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Item Item { get; }
Visual Basic
Public Overridable ReadOnly Property Item As Item
    Get
Visual C++
public:
virtual property Item^ Item {
    Item^ get ();
}

Field Value

The item.

See Also

SaveItemCommand Class
Sitecore.Data.Engines.DataCommands Namespace


SetBlobStreamCommand Class

[image]

Sitecore 6.4.1 API
SetBlobStreamCommand Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SetBlobStreamCommand : DataEngineCommand<bool, SetBlobStreamCommand>
Visual Basic
Public Class SetBlobStreamCommand _
    Inherits DataEngineCommand(Of Boolean, SetBlobStreamCommand)
Visual C++
public ref class SetBlobStreamCommand : public DataEngineCommand<bool, SetBlobStreamCommand^>

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Engines..::..EngineCommand <(Of <(<' TReturnType, TCommandType >)>)>
Sitecore.Data.Engines..::..DataEngineCommand <(Of <(<' Boolean, SetBlobStreamCommand>)>)>
Sitecore.Data.Engines.DataCommands..::..SetBlobStreamCommand

See Also

SetBlobStreamCommand Members
Sitecore.Data.Engines.DataCommands Namespace


SetBlobStreamCommand Members

[image] [image]

Sitecore 6.4.1 API
SetBlobStreamCommand Members
SetBlobStreamCommand Class Constructors Methods Fields Properties See Also Send Feedback

The SetBlobStreamCommand type exposes the following members.

Constructors

 | Name | Description
Public method | SetBlobStreamCommand | Initializes a new instance of the SetBlobStreamCommand class

Methods

 | Name | Description
Protected method | CanExecute | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | CreateInstance | Creates an instance of the command class. (Overrides DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..CreateInstance()()()().)
Protected method | DoExecute | Executes the command. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..DoExecute()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Executed | Post processing handler. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalizeExecution | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareExecution | Prepares the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuted | Raises the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuting | Raises the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _lockType | (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

Properties

 | Name | Description
Public property | BlobId | Gets the BLOB id.
Public property | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Stream | Gets the stream.

See Also

SetBlobStreamCommand Class
Sitecore.Data.Engines.DataCommands Namespace


SetBlobStreamCommand Constructor

[image]

Sitecore 6.4.1 API
SetBlobStreamCommand Constructor
SetBlobStreamCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SetBlobStreamCommand()
Visual Basic
Public Sub New
Visual C++
public:
SetBlobStreamCommand()

See Also

SetBlobStreamCommand Class
Sitecore.Data.Engines.DataCommands Namespace


SetBlobStreamCommand Fields

[image] [image]

Sitecore 6.4.1 API
SetBlobStreamCommand Fields
SetBlobStreamCommand Class See Also Send Feedback

The SetBlobStreamCommand type exposes the following members.

Fields

 | Name | Description
Protected field | _lockType | (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

SetBlobStreamCommand Class
Sitecore.Data.Engines.DataCommands Namespace


SetBlobStreamCommand Methods

[image] [image]

Sitecore 6.4.1 API
SetBlobStreamCommand Methods
SetBlobStreamCommand Class See Also Send Feedback

The SetBlobStreamCommand type exposes the following members.

Methods

 | Name | Description
Protected method | CanExecute | Determines whether the command can be executed. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | CreateInstance | Creates an instance of the command class. (Overrides DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..CreateInstance()()()().)
Protected method | DoExecute | Executes the command. (Overrides EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>..::..DoExecute()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the command. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Executed | Post processing handler. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinalizeExecution | Finalizes the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the instance.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareExecution | Prepares the execution. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuted | Raises the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | RaiseExecuting | Raises the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SetBlobStreamCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Clone Method

[image] [image]

Sitecore 6.4.1 API
SetBlobStreamCommand..::..Clone Method
SetBlobStreamCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clone()()()() | Clones the source object. Has the same effect as creating a new instance of the prototype. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public method | Clone(EventHandler<(Of <<'(ExecutingEventArgs<(Of <<'(TCommandType>)>>)>)>>), EventHandler<(Of <<'(ExecutedEventArgs<(Of <<'(TCommandType>)>>)>)>>)) | Clones the object and sets the events. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)

See Also

SetBlobStreamCommand Class
SetBlobStreamCommand Members
Sitecore.Data.Engines.DataCommands Namespace


CreateInstance Method

[image]

Sitecore 6.4.1 API
SetBlobStreamCommand..::..CreateInstance Method
SetBlobStreamCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override SetBlobStreamCommand CreateInstance()
Visual Basic
Protected Overrides Function CreateInstance As SetBlobStreamCommand
Visual C++
protected:
virtual SetBlobStreamCommand^ CreateInstance() override

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Engines.DataCommands.SetBlobStreamCommand.CreateInstance"]

See Also

SetBlobStreamCommand Class
Sitecore.Data.Engines.DataCommands Namespace


DoExecute Method

[image]

Sitecore 6.4.1 API
SetBlobStreamCommand..::..DoExecute Method
SetBlobStreamCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override bool DoExecute()
Visual Basic
Protected Overrides Function DoExecute As Boolean
Visual C++
protected:
virtual bool DoExecute() override

Return Value

The blob stream (or null if no stream was found).

See Also

SetBlobStreamCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
SetBlobStreamCommand..::..Initialize Method
SetBlobStreamCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Initialize(
    Stream stream,
    Guid blobId
)
Visual Basic
Public Overridable Sub Initialize ( _
    stream As Stream, _
    blobId As Guid _
)
Visual C++
public:
virtual void Initialize(
    Stream^ stream,
    Guid blobId
)

Parameters

stream
Type: System.IO..::..Stream
The stream.
blobId
Type: System..::..Guid
The BLOB id.

See Also

SetBlobStreamCommand Class
Sitecore.Data.Engines.DataCommands Namespace


SetBlobStreamCommand Properties

[image] [image]

Sitecore 6.4.1 API
SetBlobStreamCommand Properties
SetBlobStreamCommand Class See Also Send Feedback

The SetBlobStreamCommand type exposes the following members.

Properties

 | Name | Description
Public property | BlobId | Gets the BLOB id.
Public property | Database | Gets the database owning the engine. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | DataSource | Gets the data source. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Engine | Gets the data engine associated with this command. (Inherited from DataEngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutedEvent | Gets the executed event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Protected property | ExecutingEvent | Gets the executing event. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Result | Gets the result of the execution. (Inherited from EngineCommand<(Of <(<'TReturnType, TCommandType>)>)>.)
Public property | Stream | Gets the stream.

See Also

SetBlobStreamCommand Class
Sitecore.Data.Engines.DataCommands Namespace


BlobId Property

[image]

Sitecore 6.4.1 API
SetBlobStreamCommand..::..BlobId Property
SetBlobStreamCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Guid BlobId { get; }
Visual Basic
Public ReadOnly Property BlobId As Guid
    Get
Visual C++
public:
property Guid BlobId {
    Guid get ();
}

Field Value

The BLOB id.

See Also

SetBlobStreamCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Stream Property

[image]

Sitecore 6.4.1 API
SetBlobStreamCommand..::..Stream Property
SetBlobStreamCommand Class See Also Send Feedback

Namespace: Sitecore.Data.Engines.DataCommands
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Stream Stream { get; }
Visual Basic
Public ReadOnly Property Stream As Stream
    Get
Visual C++
public:
property Stream^ Stream {
    Stream^ get ();
}

Field Value

The stream.

See Also

SetBlobStreamCommand Class
Sitecore.Data.Engines.DataCommands Namespace


Sitecore.Data.Eventing Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Data.Eventing Namespace
Send Feedback

Classes

 | Class | Description
Public class | DatabaseRemoteEvents | Implements subsystem which propagates database events across multiple servers
Public class | EventQueueMonitor | The event queue monitor.
Public class | SqlEventQueue | SQL EventQueue imlementation.


DatabaseRemoteEvents Members

[image] [image]

Sitecore 6.4.1 API
DatabaseRemoteEvents Members
DatabaseRemoteEvents Class Constructors Methods Properties See Also Send Feedback

The DatabaseRemoteEvents type exposes the following members.

Constructors

 | Name | Description
Public method | DatabaseRemoteEvents | Initializes a new instance of the DatabaseRemoteEvents class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ListenToEvents | Gets or sets a value indicating whether this instance will listen to database events.
Public property | Queue | Gets or sets the remote events provider.

See Also

DatabaseRemoteEvents Class
Sitecore.Data.Eventing Namespace


DatabaseRemoteEvents Constructor

[image]

Sitecore 6.4.1 API
DatabaseRemoteEvents Constructor
DatabaseRemoteEvents Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DatabaseRemoteEvents(
    Database database
)
Visual Basic
Public Sub New ( _
    database As Database _
)
Visual C++
public:
DatabaseRemoteEvents(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

See Also

DatabaseRemoteEvents Class
Sitecore.Data.Eventing Namespace


DatabaseRemoteEvents Methods

[image] [image]

Sitecore 6.4.1 API
DatabaseRemoteEvents Methods
DatabaseRemoteEvents Class See Also Send Feedback

The DatabaseRemoteEvents type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DatabaseRemoteEvents Class
Sitecore.Data.Eventing Namespace


ListenToEvents Property

[image]

Sitecore 6.4.1 API
DatabaseRemoteEvents..::..ListenToEvents Property
DatabaseRemoteEvents Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ListenToEvents { get; set; }
Visual Basic
Public Property ListenToEvents As Boolean
    Get
    Set
Visual C++
public:
property bool ListenToEvents {
    bool get ();
    void set (bool value);
}

Field Value

true if this instance will listen to database events; otherwise, false.

See Also

DatabaseRemoteEvents Class
Sitecore.Data.Eventing Namespace


Queue Property

[image]

Sitecore 6.4.1 API
DatabaseRemoteEvents..::..Queue Property
DatabaseRemoteEvents Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public EventQueue Queue { get; set; }
Visual Basic
Public Property Queue As EventQueue
    Get
    Set
Visual C++
public:
property EventQueue^ Queue {
    EventQueue^ get ();
    void set (EventQueue^ value);
}

Field Value

The provider.

See Also

DatabaseRemoteEvents Class
Sitecore.Data.Eventing Namespace


EventQueueMonitor Class

[image]

Sitecore 6.4.1 API
EventQueueMonitor Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class EventQueueMonitor
Visual Basic
Public Class EventQueueMonitor
Visual C++
public ref class EventQueueMonitor

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Eventing..::..EventQueueMonitor

See Also

EventQueueMonitor Members
Sitecore.Data.Eventing Namespace


EventQueueMonitor Members

[image] [image]

Sitecore 6.4.1 API
EventQueueMonitor Members
EventQueueMonitor Class Constructors Methods Properties See Also Send Feedback

The EventQueueMonitor type exposes the following members.

Constructors

 | Name | Description
Public method | EventQueueMonitor | Initializes a new instance of the EventQueueMonitor class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Stop | Stops this instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Protected property | AlarmClock | Gets or sets the alarm clock.

See Also

EventQueueMonitor Class
Sitecore.Data.Eventing Namespace


EventQueueMonitor Constructor

[image]

Sitecore 6.4.1 API
EventQueueMonitor Constructor
EventQueueMonitor Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public EventQueueMonitor(
    EventProvider provider
)
Visual Basic
Public Sub New ( _
    provider As EventProvider _
)
Visual C++
public:
EventQueueMonitor(
    EventProvider^ provider
)

Parameters

provider
Type: Sitecore.Eventing..::..EventProvider

[Missing <param name="provider"/> documentation for "M:Sitecore.Data.Eventing.EventQueueMonitor.#ctor(Sitecore.Eventing.EventProvider)"]

See Also

EventQueueMonitor Class
Sitecore.Data.Eventing Namespace


EventQueueMonitor Methods

[image] [image]

Sitecore 6.4.1 API
EventQueueMonitor Methods
EventQueueMonitor Class See Also Send Feedback

The EventQueueMonitor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Stop | Stops this instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EventQueueMonitor Class
Sitecore.Data.Eventing Namespace


Stop Method

[image]

Sitecore 6.4.1 API
EventQueueMonitor..::..Stop Method
EventQueueMonitor Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Stop()
Visual Basic
Public Sub Stop
Visual C++
public:
void Stop()

See Also

EventQueueMonitor Class
Sitecore.Data.Eventing Namespace


EventQueueMonitor Properties

[image] [image]

Sitecore 6.4.1 API
EventQueueMonitor Properties
EventQueueMonitor Class See Also Send Feedback

The EventQueueMonitor type exposes the following members.

Properties

 | Name | Description
Protected property | AlarmClock | Gets or sets the alarm clock.

See Also

EventQueueMonitor Class
Sitecore.Data.Eventing Namespace


AlarmClock Property

[image]

Sitecore 6.4.1 API
EventQueueMonitor..::..AlarmClock Property
EventQueueMonitor Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected AlarmClock AlarmClock { get; set; }
Visual Basic
Protected Property AlarmClock As AlarmClock
    Get
    Set
Visual C++
protected:
property AlarmClock^ AlarmClock {
    AlarmClock^ get ();
    void set (AlarmClock^ value);
}

Field Value

The alarm clock.

See Also

EventQueueMonitor Class
Sitecore.Data.Eventing Namespace


SqlEventQueue Class

[image]

Sitecore 6.4.1 API
SqlEventQueue Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SqlEventQueue : EventQueue
Visual Basic
Public Class SqlEventQueue _
    Inherits EventQueue
Visual C++
public ref class SqlEventQueue : public EventQueue

Inheritance Hierarchy

System..::..Object
Sitecore.Eventing..::..EventQueue
Sitecore.Data.Eventing..::..SqlEventQueue

See Also

SqlEventQueue Members
Sitecore.Data.Eventing Namespace


SqlEventQueue Members

[image] [image]

Sitecore 6.4.1 API
SqlEventQueue Members
SqlEventQueue Class Constructors Methods Fields Properties See Also Send Feedback

The SqlEventQueue type exposes the following members.

Constructors

 | Name | Description
Public method | SqlEventQueue(SqlDataApi) | Obsolete. Initializes a new instance of the SqlEventQueue class.
Public method | SqlEventQueue(SqlDataApi, Database) | Initializes a new instance of the SqlEventQueue class.

Methods

 | Name | Description
Protected method | AddCriteria | Adds the criteria.
Public method | Cleanup | Performs cleanup of the event queue. (Overrides EventQueue..::..Cleanup(UInt32).)
Public method | ClearQueue | Clears the queue.
Protected method | CreateQueuedEvent | Creates the queued event.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDateTime | Gets the date time.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLong | Gets the long.
Public method | GetQueuedEventCount | Gets the queued event count. (Overrides EventQueue..::..GetQueuedEventCount()()()().)
Public method | GetQueuedEvents()()()() | The get queued events. (Inherited from EventQueue.)
Public method | GetQueuedEvents(String) | The get queued events. (Inherited from EventQueue.)
Public method | GetQueuedEvents(EventQueueQuery) | Gets the queued events. (Overrides EventQueue..::..GetQueuedEvents(EventQueueQuery).)
Protected method | GetSqlStatement | Gets the SQL statement.
Protected method | GetTimestampForLastProcessing | Gets the time stamp for last processing. (Overrides EventQueue..::..GetTimestampForLastProcessing()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MarkProcessed | Marks the processed. (Inherited from EventQueue.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessEvents | Processes the events. (Inherited from EventQueue.)
Protected method | QueueEvent(QueuedEvent, Boolean, Boolean) | Queues the event. (Overrides EventQueue..::..QueueEvent(QueuedEvent, Boolean, Boolean).)
Public method | QueueEvent<(Of <<'(TEvent>)>>)(TEvent) | Queues the event. (Inherited from EventQueue.)
Public method | QueueEvent<(Of <<'(TEvent>)>>)(TEvent, Boolean, Boolean) | Queues the event. (Inherited from EventQueue.)
Public method | RemoveQueuedEvents | Removes the queued events matching the criteria specified by the query. (Overrides EventQueue..::..RemoveQueuedEvents(EventQueueQuery).)
Protected method | SetTimestampForLastProcessing | Sets the currentTimestamp for last processing. (Overrides EventQueue..::..SetTimestampForLastProcessing(EventQueue..::..TimeStamp).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | timestamp | Cached queue timestamp

Properties

 | Name | Description
Protected property | DataApi | Gets the data API.
Protected property | InstanceName | Gets or sets the name of the instance. (Inherited from EventQueue.)
Public property | ListenToRemoteEvents | Gets or sets a value indicating whether this queue will process remote events. (Inherited from EventQueue.)
Protected property | PersistentTimestamp | Gets or sets the persistent timestamp. (Inherited from EventQueue.)
Protected property | Serializer | Gets or sets the serializer. (Inherited from EventQueue.)

See Also

SqlEventQueue Class
Sitecore.Data.Eventing Namespace


SqlEventQueue Constructor

[image] [image]

Sitecore 6.4.1 API
SqlEventQueue Constructor
SqlEventQueue Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SqlEventQueue(SqlDataApi) | Obsolete. Initializes a new instance of the SqlEventQueue class.
Public method | SqlEventQueue(SqlDataApi, Database) | Initializes a new instance of the SqlEventQueue class.

See Also

SqlEventQueue Class
SqlEventQueue Members
Sitecore.Data.Eventing Namespace


SqlEventQueue Constructor (SqlDataApi, Database)

[image]

Sitecore 6.4.1 API
SqlEventQueue Constructor (SqlDataApi, Database)
SqlEventQueue Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlEventQueue(
    SqlDataApi api,
    Database database
)
Visual Basic
Public Sub New ( _
    api As SqlDataApi, _
    database As Database _
)
Visual C++
public:
SqlEventQueue(
    SqlDataApi^ api,
    Database^ database
)

Parameters

api
Type: Sitecore.Data.DataProviders.Sql..::..SqlDataApi
The data API.
database
Type: Sitecore.Data..::..Database
The database.

See Also

SqlEventQueue Class
SqlEventQueue Overload
Sitecore.Data.Eventing Namespace


SqlEventQueue Fields

[image] [image]

Sitecore 6.4.1 API
SqlEventQueue Fields
SqlEventQueue Class See Also Send Feedback

The SqlEventQueue type exposes the following members.

Fields

 | Name | Description
Protected field | timestamp | Cached queue timestamp

See Also

SqlEventQueue Class
Sitecore.Data.Eventing Namespace


timestamp Field

[image]

Sitecore 6.4.1 API
SqlEventQueue..::..timestamp Field
SqlEventQueue Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected EventQueue..::..TimeStamp timestamp
Visual Basic
Protected timestamp As EventQueue..::..TimeStamp
Visual C++
protected:
EventQueue..::..TimeStamp^ timestamp

See Also

SqlEventQueue Class
Sitecore.Data.Eventing Namespace


SqlEventQueue Methods

[image] [image]

Sitecore 6.4.1 API
SqlEventQueue Methods
SqlEventQueue Class See Also Send Feedback

The SqlEventQueue type exposes the following members.

Methods

 | Name | Description
Protected method | AddCriteria | Adds the criteria.
Public method | Cleanup | Performs cleanup of the event queue. (Overrides EventQueue..::..Cleanup(UInt32).)
Public method | ClearQueue | Clears the queue.
Protected method | CreateQueuedEvent | Creates the queued event.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDateTime | Gets the date time.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLong | Gets the long.
Public method | GetQueuedEventCount | Gets the queued event count. (Overrides EventQueue..::..GetQueuedEventCount()()()().)
Public method | GetQueuedEvents()()()() | The get queued events. (Inherited from EventQueue.)
Public method | GetQueuedEvents(String) | The get queued events. (Inherited from EventQueue.)
Public method | GetQueuedEvents(EventQueueQuery) | Gets the queued events. (Overrides EventQueue..::..GetQueuedEvents(EventQueueQuery).)
Protected method | GetSqlStatement | Gets the SQL statement.
Protected method | GetTimestampForLastProcessing | Gets the time stamp for last processing. (Overrides EventQueue..::..GetTimestampForLastProcessing()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MarkProcessed | Marks the processed. (Inherited from EventQueue.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessEvents | Processes the events. (Inherited from EventQueue.)
Protected method | QueueEvent(QueuedEvent, Boolean, Boolean) | Queues the event. (Overrides EventQueue..::..QueueEvent(QueuedEvent, Boolean, Boolean).)
Public method | QueueEvent<(Of <<'(TEvent>)>>)(TEvent) | Queues the event. (Inherited from EventQueue.)
Public method | QueueEvent<(Of <<'(TEvent>)>>)(TEvent, Boolean, Boolean) | Queues the event. (Inherited from EventQueue.)
Public method | RemoveQueuedEvents | Removes the queued events matching the criteria specified by the query. (Overrides EventQueue..::..RemoveQueuedEvents(EventQueueQuery).)
Protected method | SetTimestampForLastProcessing | Sets the currentTimestamp for last processing. (Overrides EventQueue..::..SetTimestampForLastProcessing(EventQueue..::..TimeStamp).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SqlEventQueue Class
Sitecore.Data.Eventing Namespace


ClearQueue Method

[image]

Sitecore 6.4.1 API
SqlEventQueue..::..ClearQueue Method
SqlEventQueue Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void ClearQueue()
Visual Basic
Public Overridable Sub ClearQueue
Visual C++
public:
virtual void ClearQueue()

See Also

SqlEventQueue Class
Sitecore.Data.Eventing Namespace


CreateQueuedEvent Method

[image]

Sitecore 6.4.1 API
SqlEventQueue..::..CreateQueuedEvent Method
SqlEventQueue Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual QueuedEvent CreateQueuedEvent(
    IDataReader dataReader
)
Visual Basic
Protected Overridable Function CreateQueuedEvent ( _
    dataReader As IDataReader _
) As QueuedEvent
Visual C++
protected:
virtual QueuedEvent^ CreateQueuedEvent(
    IDataReader^ dataReader
)

Parameters

dataReader
Type: System.Data..::..IDataReader
The data reader.

Return Value

The result.

See Also

SqlEventQueue Class
Sitecore.Data.Eventing Namespace


GetDateTime Method

[image]

Sitecore 6.4.1 API
SqlEventQueue..::..GetDateTime Method
SqlEventQueue Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected static DateTime GetDateTime(
    IDataReader reader,
    int columnIndex
)
Visual Basic
Protected Shared Function GetDateTime ( _
    reader As IDataReader, _
    columnIndex As Integer _
) As DateTime
Visual C++
protected:
static DateTime GetDateTime(
    IDataReader^ reader,
    int columnIndex
)

Parameters

reader
Type: System.Data..::..IDataReader
The reader.
columnIndex
Type: System..::..Int32
Index of the column.

Return Value

The date time.

See Also

SqlEventQueue Class
Sitecore.Data.Eventing Namespace


GetLong Method

[image]

Sitecore 6.4.1 API
SqlEventQueue..::..GetLong Method
SqlEventQueue Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected static long GetLong(
    IDataReader reader,
    int columnIndex
)
Visual Basic
Protected Shared Function GetLong ( _
    reader As IDataReader, _
    columnIndex As Integer _
) As Long
Visual C++
protected:
static long long GetLong(
    IDataReader^ reader,
    int columnIndex
)

Parameters

reader
Type: System.Data..::..IDataReader
The reader.
columnIndex
Type: System..::..Int32
Index of the column.

Return Value

The result.

See Also

SqlEventQueue Class
Sitecore.Data.Eventing Namespace


GetQueuedEventCount Method

[image]

Sitecore 6.4.1 API
SqlEventQueue..::..GetQueuedEventCount Method
SqlEventQueue Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override long GetQueuedEventCount()
Visual Basic
Public Overrides Function GetQueuedEventCount As Long
Visual C++
public:
virtual long long GetQueuedEventCount() override

Return Value

The result.

See Also

SqlEventQueue Class
Sitecore.Data.Eventing Namespace


GetQueuedEvents Method (EventQueueQuery)

[image]

Sitecore 6.4.1 API
SqlEventQueue..::..GetQueuedEvents Method (EventQueueQuery)
SqlEventQueue Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override IEnumerable<QueuedEvent> GetQueuedEvents(
    EventQueueQuery query
)
Visual Basic
Public Overrides Function GetQueuedEvents ( _
    query As EventQueueQuery _
) As IEnumerable(Of QueuedEvent)
Visual C++
public:
virtual IEnumerable<QueuedEvent^>^ GetQueuedEvents(
    EventQueueQuery^ query
) override

Parameters

query
Type: Sitecore.Eventing..::..EventQueueQuery
The query.

Return Value

The result.

See Also

SqlEventQueue Class
GetQueuedEvents Overload
Sitecore.Data.Eventing Namespace


GetSqlStatement Method

[image]

Sitecore 6.4.1 API
SqlEventQueue..::..GetSqlStatement Method
SqlEventQueue Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual SqlStatement GetSqlStatement(
    EventQueueQuery query
)
Visual Basic
Protected Overridable Function GetSqlStatement ( _
    query As EventQueueQuery _
) As SqlStatement
Visual C++
protected:
virtual SqlStatement^ GetSqlStatement(
    EventQueueQuery^ query
)

Parameters

query
Type: Sitecore.Eventing..::..EventQueueQuery
The query.

Return Value

The result.

See Also

SqlEventQueue Class
Sitecore.Data.Eventing Namespace


GetTimestampForLastProcessing Method

[image]

Sitecore 6.4.1 API
SqlEventQueue..::..GetTimestampForLastProcessing Method
SqlEventQueue Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override EventQueue..::..TimeStamp GetTimestampForLastProcessing()
Visual Basic
Protected Overrides Function GetTimestampForLastProcessing As EventQueue..::..TimeStamp
Visual C++
protected:
virtual EventQueue..::..TimeStamp^ GetTimestampForLastProcessing() override

Return Value

The result.

See Also

SqlEventQueue Class
Sitecore.Data.Eventing Namespace


QueueEvent Method

[image] [image]

Sitecore 6.4.1 API
SqlEventQueue..::..QueueEvent Method
SqlEventQueue Class See Also Send Feedback

Overload List

 | Name | Description
Public method | QueueEvent<(Of <<'(TEvent>)>>)(TEvent) | Queues the event. (Inherited from EventQueue.)
Public method | QueueEvent<(Of <<'(TEvent>)>>)(TEvent, Boolean, Boolean) | Queues the event. (Inherited from EventQueue.)
Protected method | QueueEvent(QueuedEvent, Boolean, Boolean) | Queues the event. (Overrides EventQueue..::..QueueEvent(QueuedEvent, Boolean, Boolean).)

See Also

SqlEventQueue Class
SqlEventQueue Members
Sitecore.Data.Eventing Namespace


QueueEvent Method (QueuedEvent, Boolean, Boolean)

[image]

Sitecore 6.4.1 API
SqlEventQueue..::..QueueEvent Method (QueuedEvent, Boolean, Boolean)
SqlEventQueue Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void QueueEvent(
    QueuedEvent queuedEvent,
    bool addToGlobalQueue,
    bool addToLocalQueue
)
Visual Basic
Protected Overrides Sub QueueEvent ( _
    queuedEvent As QueuedEvent, _
    addToGlobalQueue As Boolean, _
    addToLocalQueue As Boolean _
)
Visual C++
protected:
virtual void QueueEvent(
    QueuedEvent^ queuedEvent,
    bool addToGlobalQueue,
    bool addToLocalQueue
) override

Parameters

queuedEvent
Type: Sitecore.Eventing..::..QueuedEvent
The queued event.
addToGlobalQueue
Type: System..::..Boolean
if set to true add the event to the global queue.
addToLocalQueue
Type: System..::..Boolean
if set to true add the event to the local queue.

See Also

SqlEventQueue Class
QueueEvent Overload
Sitecore.Data.Eventing Namespace


RemoveQueuedEvents Method

[image]

Sitecore 6.4.1 API
SqlEventQueue..::..RemoveQueuedEvents Method
SqlEventQueue Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void RemoveQueuedEvents(
    EventQueueQuery query
)
Visual Basic
Public Overrides Sub RemoveQueuedEvents ( _
    query As EventQueueQuery _
)
Visual C++
public:
virtual void RemoveQueuedEvents(
    EventQueueQuery^ query
) override

Parameters

query
Type: Sitecore.Eventing..::..EventQueueQuery
The query.

See Also

SqlEventQueue Class
Sitecore.Data.Eventing Namespace


SetTimestampForLastProcessing Method

[image]

Sitecore 6.4.1 API
SqlEventQueue..::..SetTimestampForLastProcessing Method
SqlEventQueue Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void SetTimestampForLastProcessing(
    EventQueue..::..TimeStamp currentTimestamp
)
Visual Basic
Protected Overrides Sub SetTimestampForLastProcessing ( _
    currentTimestamp As EventQueue..::..TimeStamp _
)
Visual C++
protected:
virtual void SetTimestampForLastProcessing(
    EventQueue..::..TimeStamp^ currentTimestamp
) override

Parameters

currentTimestamp
Type: Sitecore.Eventing..::..EventQueue..::..TimeStamp
The currentTimestamp.

See Also

SqlEventQueue Class
Sitecore.Data.Eventing Namespace


SqlEventQueue Properties

[image] [image]

Sitecore 6.4.1 API
SqlEventQueue Properties
SqlEventQueue Class See Also Send Feedback

The SqlEventQueue type exposes the following members.

Properties

 | Name | Description
Protected property | DataApi | Gets the data API.
Protected property | InstanceName | Gets or sets the name of the instance. (Inherited from EventQueue.)
Public property | ListenToRemoteEvents | Gets or sets a value indicating whether this queue will process remote events. (Inherited from EventQueue.)
Protected property | PersistentTimestamp | Gets or sets the persistent timestamp. (Inherited from EventQueue.)
Protected property | Serializer | Gets or sets the serializer. (Inherited from EventQueue.)

See Also

SqlEventQueue Class
Sitecore.Data.Eventing Namespace


DataApi Property

[image]

Sitecore 6.4.1 API
SqlEventQueue..::..DataApi Property
SqlEventQueue Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected SqlDataApi DataApi { get; private set; }
Visual Basic
Protected Property DataApi As SqlDataApi
    Get
    Private Set
Visual C++
protected:
property SqlDataApi^ DataApi {
    SqlDataApi^ get ();
    private: void set (SqlDataApi^ value);
}

Field Value

The data API.

See Also

SqlEventQueue Class
Sitecore.Data.Eventing Namespace


Sitecore.Data.Eventing.Remote Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Data.Eventing.Remote Namespace
Send Feedback

Classes

 | Class | Description
Public class | AddedFromTemplateRemoteEvent | AddedFromTemplateRemoteEvent class.
Public class | AddedVersionRemoteEvent | AddedVersionRemoteEvent class.
Public class | CopiedItemRemoteEvent | CopiedItemRemoteEvent class.
Public class | CreatedItemRemoteEvent | ItemCreatedRemoteEvent class.
Public class | DeletedItemRemoteEvent | ItemDeletedRemoteEvent class.
Public class | IDTableEntryAddedRemoteEvent | Defines the ID table entry removed remote event class.
Public class | IDTableEntryRemovedRemoteEvent | Defines the ID table entry removed remote event class.
Public class | ItemLockedRemoteEvent | ItemLockedRemoteEvent class.
Public class | ItemRemoteEventBase | Defines the item remote event base class.
Public class | ItemTemplateChangedRemoteEvent | ItemTemplateChangedRemoteEvent class.
Public class | ItemUnlockedRemoteEvent | ItemUnlockedRemoteEvent class.
Public class | MovedItemRemoteEvent | MovedItemRemoteEvent class.
Public class | PropertyChangedRemoteEvent | Defines the property changed remote event class.
Public class | PropertyRemovedRemoteEvent | Defines the property removed remote event class.
Public class | RemovedDataRemoteEvent | RemovedDataRemoteEvent class.
Public class | RemovedVersionRemoteEvent | RemovedVersionRemoteEvent class.
Public class | SavedItemRemoteEvent | ItemSavedRemoteEvent class.
Public class | SavedItemRemoteEvent..::..FieldChange | FieldChange class.
Public class | SavedItemRemoteEvent..::..PropertyChange | PropertyChange class.


AddedFromTemplateRemoteEvent Class

[image]

Sitecore 6.4.1 API
AddedFromTemplateRemoteEvent Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class AddedFromTemplateRemoteEvent : ItemRemoteEventBase
Visual Basic
Public Class AddedFromTemplateRemoteEvent _
    Inherits ItemRemoteEventBase
Visual C++
public ref class AddedFromTemplateRemoteEvent : public ItemRemoteEventBase

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Eventing.Remote..::..ItemRemoteEventBase
Sitecore.Data.Eventing.Remote..::..AddedFromTemplateRemoteEvent

See Also

AddedFromTemplateRemoteEvent Members
Sitecore.Data.Eventing.Remote Namespace


AddedFromTemplateRemoteEvent Members

[image] [image]

Sitecore 6.4.1 API
AddedFromTemplateRemoteEvent Members
AddedFromTemplateRemoteEvent Class Constructors Methods Properties See Also Send Feedback

The AddedFromTemplateRemoteEvent type exposes the following members.

Constructors

 | Name | Description
Public method | AddedFromTemplateRemoteEvent | Initializes a new instance of the AddedFromTemplateRemoteEvent class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DestinationId | Gets or sets the destination id.
Public property | ItemId | Gets or sets ItemId. (Inherited from ItemRemoteEventBase.)
Public property | ItemName | Gets or sets the name of the item. (Inherited from ItemRemoteEventBase.)
Public property | LanguageName | Gets or sets Language. (Inherited from ItemRemoteEventBase.)
Public property | TemplateId | Gets or sets the template ID of the item being saved. (Inherited from ItemRemoteEventBase.)
Public property | VersionNumber | Gets or sets Version. (Inherited from ItemRemoteEventBase.)

See Also

AddedFromTemplateRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


AddedFromTemplateRemoteEvent Methods

[image] [image]

Sitecore 6.4.1 API
AddedFromTemplateRemoteEvent Methods
AddedFromTemplateRemoteEvent Class See Also Send Feedback

The AddedFromTemplateRemoteEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddedFromTemplateRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


AddedFromTemplateRemoteEvent Properties

[image] [image]

Sitecore 6.4.1 API
AddedFromTemplateRemoteEvent Properties
AddedFromTemplateRemoteEvent Class See Also Send Feedback

The AddedFromTemplateRemoteEvent type exposes the following members.

Properties

 | Name | Description
Public property | DestinationId | Gets or sets the destination id.
Public property | ItemId | Gets or sets ItemId. (Inherited from ItemRemoteEventBase.)
Public property | ItemName | Gets or sets the name of the item. (Inherited from ItemRemoteEventBase.)
Public property | LanguageName | Gets or sets Language. (Inherited from ItemRemoteEventBase.)
Public property | TemplateId | Gets or sets the template ID of the item being saved. (Inherited from ItemRemoteEventBase.)
Public property | VersionNumber | Gets or sets Version. (Inherited from ItemRemoteEventBase.)

See Also

AddedFromTemplateRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


DestinationId Property

[image]

Sitecore 6.4.1 API
AddedFromTemplateRemoteEvent..::..DestinationId Property
AddedFromTemplateRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Guid DestinationId { get; protected set; }
Visual Basic
Public Property DestinationId As Guid
    Get
    Protected Set
Visual C++
public:
property Guid DestinationId {
    Guid get ();
    protected: void set (Guid value);
}

Field Value

The destination id.

See Also

AddedFromTemplateRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


AddedVersionRemoteEvent Class

[image]

Sitecore 6.4.1 API
AddedVersionRemoteEvent Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class AddedVersionRemoteEvent : ItemRemoteEventBase
Visual Basic
Public Class AddedVersionRemoteEvent _
    Inherits ItemRemoteEventBase
Visual C++
public ref class AddedVersionRemoteEvent : public ItemRemoteEventBase

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Eventing.Remote..::..ItemRemoteEventBase
Sitecore.Data.Eventing.Remote..::..AddedVersionRemoteEvent

See Also

AddedVersionRemoteEvent Members
Sitecore.Data.Eventing.Remote Namespace


AddedVersionRemoteEvent Members

[image] [image]

Sitecore 6.4.1 API
AddedVersionRemoteEvent Members
AddedVersionRemoteEvent Class Constructors Methods Properties See Also Send Feedback

The AddedVersionRemoteEvent type exposes the following members.

Constructors

 | Name | Description
Public method | AddedVersionRemoteEvent | Initializes a new instance of the AddedVersionRemoteEvent class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ItemId | Gets or sets ItemId. (Inherited from ItemRemoteEventBase.)
Public property | ItemName | Gets or sets the name of the item. (Inherited from ItemRemoteEventBase.)
Public property | LanguageName | Gets or sets Language. (Inherited from ItemRemoteEventBase.)
Public property | TemplateId | Gets or sets the template ID of the item being saved. (Inherited from ItemRemoteEventBase.)
Public property | VersionNumber | Gets or sets Version. (Inherited from ItemRemoteEventBase.)

See Also

AddedVersionRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


AddedVersionRemoteEvent Constructor

[image]

Sitecore 6.4.1 API
AddedVersionRemoteEvent Constructor
AddedVersionRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AddedVersionRemoteEvent(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
AddedVersionRemoteEvent(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

AddedVersionRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


AddedVersionRemoteEvent Methods

[image] [image]

Sitecore 6.4.1 API
AddedVersionRemoteEvent Methods
AddedVersionRemoteEvent Class See Also Send Feedback

The AddedVersionRemoteEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddedVersionRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


AddedVersionRemoteEvent Properties

[image] [image]

Sitecore 6.4.1 API
AddedVersionRemoteEvent Properties
AddedVersionRemoteEvent Class See Also Send Feedback

The AddedVersionRemoteEvent type exposes the following members.

Properties

 | Name | Description
Public property | ItemId | Gets or sets ItemId. (Inherited from ItemRemoteEventBase.)
Public property | ItemName | Gets or sets the name of the item. (Inherited from ItemRemoteEventBase.)
Public property | LanguageName | Gets or sets Language. (Inherited from ItemRemoteEventBase.)
Public property | TemplateId | Gets or sets the template ID of the item being saved. (Inherited from ItemRemoteEventBase.)
Public property | VersionNumber | Gets or sets Version. (Inherited from ItemRemoteEventBase.)

See Also

AddedVersionRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


CopiedItemRemoteEvent Class

[image]

Sitecore 6.4.1 API
CopiedItemRemoteEvent Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CopiedItemRemoteEvent : ItemRemoteEventBase
Visual Basic
Public Class CopiedItemRemoteEvent _
    Inherits ItemRemoteEventBase
Visual C++
public ref class CopiedItemRemoteEvent : public ItemRemoteEventBase

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Eventing.Remote..::..ItemRemoteEventBase
Sitecore.Data.Eventing.Remote..::..CopiedItemRemoteEvent

See Also

CopiedItemRemoteEvent Members
Sitecore.Data.Eventing.Remote Namespace


CopiedItemRemoteEvent Members

[image] [image]

Sitecore 6.4.1 API
CopiedItemRemoteEvent Members
CopiedItemRemoteEvent Class Constructors Methods Properties See Also Send Feedback

The CopiedItemRemoteEvent type exposes the following members.

Constructors

 | Name | Description
Public method | CopiedItemRemoteEvent | Initializes a new instance of the CopiedItemRemoteEvent class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Deep | Gets or sets a value indicating whether Deep.
Public property | DestinationItemId | Gets or sets DestinationItemId.
Public property | DestinationLanguageName | Gets or sets DestinationLanguageName.
Public property | DestinationName | Gets or sets the name of the destination.
Public property | DestinationVersionNumber | Gets or sets DestinationVersionNumber.
Public property | ItemId | Gets or sets ItemId. (Inherited from ItemRemoteEventBase.)
Public property | ItemName | Gets or sets the name of the item. (Inherited from ItemRemoteEventBase.)
Public property | LanguageName | Gets or sets Language. (Inherited from ItemRemoteEventBase.)
Public property | SourceItemId | Gets or sets SourceItemId.
Public property | SourceLanguageName | Gets or sets SourceLanguageName.
Public property | SourceVersionNumber | Gets or sets SourceVersionNumber.
Public property | TemplateId | Gets or sets the template ID of the item being saved. (Inherited from ItemRemoteEventBase.)
Public property | VersionNumber | Gets or sets Version. (Inherited from ItemRemoteEventBase.)

See Also

CopiedItemRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


CopiedItemRemoteEvent Constructor

[image]

Sitecore 6.4.1 API
CopiedItemRemoteEvent Constructor
CopiedItemRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CopiedItemRemoteEvent(
    Item item,
    Item source,
    Item destination,
    bool deep
)
Visual Basic
Public Sub New ( _
    item As Item, _
    source As Item, _
    destination As Item, _
    deep As Boolean _
)
Visual C++
public:
CopiedItemRemoteEvent(
    Item^ item,
    Item^ source,
    Item^ destination,
    bool deep
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
source
Type: Sitecore.Data.Items..::..Item
The source.
destination
Type: Sitecore.Data.Items..::..Item
The destination.
deep
Type: System..::..Boolean
if set to true [deep].

See Also

CopiedItemRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


CopiedItemRemoteEvent Properties

[image] [image]

Sitecore 6.4.1 API
CopiedItemRemoteEvent Properties
CopiedItemRemoteEvent Class See Also Send Feedback

The CopiedItemRemoteEvent type exposes the following members.

Properties

 | Name | Description
Public property | Deep | Gets or sets a value indicating whether Deep.
Public property | DestinationItemId | Gets or sets DestinationItemId.
Public property | DestinationLanguageName | Gets or sets DestinationLanguageName.
Public property | DestinationName | Gets or sets the name of the destination.
Public property | DestinationVersionNumber | Gets or sets DestinationVersionNumber.
Public property | ItemId | Gets or sets ItemId. (Inherited from ItemRemoteEventBase.)
Public property | ItemName | Gets or sets the name of the item. (Inherited from ItemRemoteEventBase.)
Public property | LanguageName | Gets or sets Language. (Inherited from ItemRemoteEventBase.)
Public property | SourceItemId | Gets or sets SourceItemId.
Public property | SourceLanguageName | Gets or sets SourceLanguageName.
Public property | SourceVersionNumber | Gets or sets SourceVersionNumber.
Public property | TemplateId | Gets or sets the template ID of the item being saved. (Inherited from ItemRemoteEventBase.)
Public property | VersionNumber | Gets or sets Version. (Inherited from ItemRemoteEventBase.)

See Also

CopiedItemRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


DestinationLanguageName Property

[image]

Sitecore 6.4.1 API
CopiedItemRemoteEvent..::..DestinationLanguageName Property
CopiedItemRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string DestinationLanguageName { get; protected set; }
Visual Basic
Public Property DestinationLanguageName As String
    Get
    Protected Set
Visual C++
public:
property String^ DestinationLanguageName {
    String^ get ();
    protected: void set (String^ value);
}

See Also

CopiedItemRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


DestinationName Property

[image]

Sitecore 6.4.1 API
CopiedItemRemoteEvent..::..DestinationName Property
CopiedItemRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string DestinationName { get; protected set; }
Visual Basic
Public Property DestinationName As String
    Get
    Protected Set
Visual C++
public:
property String^ DestinationName {
    String^ get ();
    protected: void set (String^ value);
}

Field Value

The name of the destination.

See Also

CopiedItemRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


SourceItemId Property

[image]

Sitecore 6.4.1 API
CopiedItemRemoteEvent..::..SourceItemId Property
CopiedItemRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Guid SourceItemId { get; protected set; }
Visual Basic
Public Property SourceItemId As Guid
    Get
    Protected Set
Visual C++
public:
property Guid SourceItemId {
    Guid get ();
    protected: void set (Guid value);
}

See Also

CopiedItemRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


SourceLanguageName Property

[image]

Sitecore 6.4.1 API
CopiedItemRemoteEvent..::..SourceLanguageName Property
CopiedItemRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string SourceLanguageName { get; protected set; }
Visual Basic
Public Property SourceLanguageName As String
    Get
    Protected Set
Visual C++
public:
property String^ SourceLanguageName {
    String^ get ();
    protected: void set (String^ value);
}

See Also

CopiedItemRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


SourceVersionNumber Property

[image]

Sitecore 6.4.1 API
CopiedItemRemoteEvent..::..SourceVersionNumber Property
CopiedItemRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int SourceVersionNumber { get; protected set; }
Visual Basic
Public Property SourceVersionNumber As Integer
    Get
    Protected Set
Visual C++
public:
property int SourceVersionNumber {
    int get ();
    protected: void set (int value);
}

See Also

CopiedItemRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


CreatedItemRemoteEvent Members

[image] [image]

Sitecore 6.4.1 API
CreatedItemRemoteEvent Members
CreatedItemRemoteEvent Class Constructors Methods Properties See Also Send Feedback

The CreatedItemRemoteEvent type exposes the following members.

Constructors

 | Name | Description
Public method | CreatedItemRemoteEvent | Initializes a new instance of the CreatedItemRemoteEvent class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DestinationId | Gets or sets DestinationId.
Public property | DestinationName | Gets or sets the name of the destination.
Public property | ItemId | Gets or sets ItemId. (Inherited from ItemRemoteEventBase.)
Public property | ItemName | Gets or sets the name of the item. (Inherited from ItemRemoteEventBase.)
Public property | LanguageName | Gets or sets Language. (Inherited from ItemRemoteEventBase.)
Public property | TemplateId | Gets or sets the template ID of the item being saved. (Inherited from ItemRemoteEventBase.)
Public property | VersionNumber | Gets or sets Version. (Inherited from ItemRemoteEventBase.)

See Also

CreatedItemRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


CreatedItemRemoteEvent Constructor

[image]

Sitecore 6.4.1 API
CreatedItemRemoteEvent Constructor
CreatedItemRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CreatedItemRemoteEvent(
    Item item,
    Item destination
)
Visual Basic
Public Sub New ( _
    item As Item, _
    destination As Item _
)
Visual C++
public:
CreatedItemRemoteEvent(
    Item^ item,
    Item^ destination
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The created item.
destination
Type: Sitecore.Data.Items..::..Item
The destination.

See Also

CreatedItemRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


CreatedItemRemoteEvent Methods

[image] [image]

Sitecore 6.4.1 API
CreatedItemRemoteEvent Methods
CreatedItemRemoteEvent Class See Also Send Feedback

The CreatedItemRemoteEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CreatedItemRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


CreatedItemRemoteEvent Properties

[image] [image]

Sitecore 6.4.1 API
CreatedItemRemoteEvent Properties
CreatedItemRemoteEvent Class See Also Send Feedback

The CreatedItemRemoteEvent type exposes the following members.

Properties

 | Name | Description
Public property | DestinationId | Gets or sets DestinationId.
Public property | DestinationName | Gets or sets the name of the destination.
Public property | ItemId | Gets or sets ItemId. (Inherited from ItemRemoteEventBase.)
Public property | ItemName | Gets or sets the name of the item. (Inherited from ItemRemoteEventBase.)
Public property | LanguageName | Gets or sets Language. (Inherited from ItemRemoteEventBase.)
Public property | TemplateId | Gets or sets the template ID of the item being saved. (Inherited from ItemRemoteEventBase.)
Public property | VersionNumber | Gets or sets Version. (Inherited from ItemRemoteEventBase.)

See Also

CreatedItemRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


DestinationId Property

[image]

Sitecore 6.4.1 API
CreatedItemRemoteEvent..::..DestinationId Property
CreatedItemRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Guid DestinationId { get; protected set; }
Visual Basic
Public Property DestinationId As Guid
    Get
    Protected Set
Visual C++
public:
property Guid DestinationId {
    Guid get ();
    protected: void set (Guid value);
}

Field Value

The destination id.

See Also

CreatedItemRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


DeletedItemRemoteEvent Class

[image]

Sitecore 6.4.1 API
DeletedItemRemoteEvent Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DeletedItemRemoteEvent : ItemRemoteEventBase
Visual Basic
Public Class DeletedItemRemoteEvent _
    Inherits ItemRemoteEventBase
Visual C++
public ref class DeletedItemRemoteEvent : public ItemRemoteEventBase

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Eventing.Remote..::..ItemRemoteEventBase
Sitecore.Data.Eventing.Remote..::..DeletedItemRemoteEvent

See Also

DeletedItemRemoteEvent Members
Sitecore.Data.Eventing.Remote Namespace


DeletedItemRemoteEvent Members

[image] [image]

Sitecore 6.4.1 API
DeletedItemRemoteEvent Members
DeletedItemRemoteEvent Class Constructors Methods Properties See Also Send Feedback

The DeletedItemRemoteEvent type exposes the following members.

Constructors

 | Name | Description
Public method | DeletedItemRemoteEvent | Initializes a new instance of the DeletedItemRemoteEvent class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ItemId | Gets or sets ItemId. (Inherited from ItemRemoteEventBase.)
Public property | ItemName | Gets or sets the name of the item. (Inherited from ItemRemoteEventBase.)
Public property | LanguageName | Gets or sets Language. (Inherited from ItemRemoteEventBase.)
Public property | ParentId | Gets or sets the parent id.
Public property | TemplateId | Gets or sets the template ID of the item being saved. (Inherited from ItemRemoteEventBase.)
Public property | VersionNumber | Gets or sets Version. (Inherited from ItemRemoteEventBase.)

See Also

DeletedItemRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


DeletedItemRemoteEvent Constructor

[image]

Sitecore 6.4.1 API
DeletedItemRemoteEvent Constructor
DeletedItemRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DeletedItemRemoteEvent(
    Item item,
    ID parentId
)
Visual Basic
Public Sub New ( _
    item As Item, _
    parentId As ID _
)
Visual C++
public:
DeletedItemRemoteEvent(
    Item^ item,
    ID^ parentId
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
parentId
Type: Sitecore.Data..::..ID
The parent id.

See Also

DeletedItemRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


DeletedItemRemoteEvent Methods

[image] [image]

Sitecore 6.4.1 API
DeletedItemRemoteEvent Methods
DeletedItemRemoteEvent Class See Also Send Feedback

The DeletedItemRemoteEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DeletedItemRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


DeletedItemRemoteEvent Properties

[image] [image]

Sitecore 6.4.1 API
DeletedItemRemoteEvent Properties
DeletedItemRemoteEvent Class See Also Send Feedback

The DeletedItemRemoteEvent type exposes the following members.

Properties

 | Name | Description
Public property | ItemId | Gets or sets ItemId. (Inherited from ItemRemoteEventBase.)
Public property | ItemName | Gets or sets the name of the item. (Inherited from ItemRemoteEventBase.)
Public property | LanguageName | Gets or sets Language. (Inherited from ItemRemoteEventBase.)
Public property | ParentId | Gets or sets the parent id.
Public property | TemplateId | Gets or sets the template ID of the item being saved. (Inherited from ItemRemoteEventBase.)
Public property | VersionNumber | Gets or sets Version. (Inherited from ItemRemoteEventBase.)

See Also

DeletedItemRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


ParentId Property

[image]

Sitecore 6.4.1 API
DeletedItemRemoteEvent..::..ParentId Property
DeletedItemRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Guid ParentId { get; protected set; }
Visual Basic
Public Property ParentId As Guid
    Get
    Protected Set
Visual C++
public:
property Guid ParentId {
    Guid get ();
    protected: void set (Guid value);
}

Field Value

The parent id.

See Also

DeletedItemRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


IDTableEntryAddedRemoteEvent Class

[image]

Sitecore 6.4.1 API
IDTableEntryAddedRemoteEvent Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class IDTableEntryAddedRemoteEvent
Visual Basic
Public Class IDTableEntryAddedRemoteEvent
Visual C++
public ref class IDTableEntryAddedRemoteEvent

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Eventing.Remote..::..IDTableEntryAddedRemoteEvent

See Also

IDTableEntryAddedRemoteEvent Members
Sitecore.Data.Eventing.Remote Namespace


IDTableEntryAddedRemoteEvent Members

[image] [image]

Sitecore 6.4.1 API
IDTableEntryAddedRemoteEvent Members
IDTableEntryAddedRemoteEvent Class Constructors Methods Properties See Also Send Feedback

The IDTableEntryAddedRemoteEvent type exposes the following members.

Constructors

 | Name | Description
Public method | IDTableEntryAddedRemoteEvent | Initializes a new instance of the IDTableEntryAddedRemoteEvent class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Key | Gets or sets the key.
Public property | Prefix | Gets or sets the prefix.

See Also

IDTableEntryAddedRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


IDTableEntryAddedRemoteEvent Constructor

[image]

Sitecore 6.4.1 API
IDTableEntryAddedRemoteEvent Constructor
IDTableEntryAddedRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IDTableEntryAddedRemoteEvent(
    string prefix,
    string key
)
Visual Basic
Public Sub New ( _
    prefix As String, _
    key As String _
)
Visual C++
public:
IDTableEntryAddedRemoteEvent(
    String^ prefix,
    String^ key
)

Parameters

prefix
Type: System..::..String
Entry prefix
key
Type: System..::..String
The cache key.

See Also

IDTableEntryAddedRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


IDTableEntryAddedRemoteEvent Methods

[image] [image]

Sitecore 6.4.1 API
IDTableEntryAddedRemoteEvent Methods
IDTableEntryAddedRemoteEvent Class See Also Send Feedback

The IDTableEntryAddedRemoteEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IDTableEntryAddedRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


IDTableEntryAddedRemoteEvent Properties

[image] [image]

Sitecore 6.4.1 API
IDTableEntryAddedRemoteEvent Properties
IDTableEntryAddedRemoteEvent Class See Also Send Feedback

The IDTableEntryAddedRemoteEvent type exposes the following members.

Properties

 | Name | Description
Public property | Key | Gets or sets the key.
Public property | Prefix | Gets or sets the prefix.

See Also

IDTableEntryAddedRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


Key Property

[image]

Sitecore 6.4.1 API
IDTableEntryAddedRemoteEvent..::..Key Property
IDTableEntryAddedRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Key { get; set; }
Visual Basic
Public Property Key As String
    Get
    Set
Visual C++
public:
property String^ Key {
    String^ get ();
    void set (String^ value);
}

Field Value

The Entry key.

See Also

IDTableEntryAddedRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


Prefix Property

[image]

Sitecore 6.4.1 API
IDTableEntryAddedRemoteEvent..::..Prefix Property
IDTableEntryAddedRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Prefix { get; set; }
Visual Basic
Public Property Prefix As String
    Get
    Set
Visual C++
public:
property String^ Prefix {
    String^ get ();
    void set (String^ value);
}

Field Value

The prefix.

See Also

IDTableEntryAddedRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


IDTableEntryRemovedRemoteEvent Class

[image]

Sitecore 6.4.1 API
IDTableEntryRemovedRemoteEvent Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class IDTableEntryRemovedRemoteEvent
Visual Basic
Public Class IDTableEntryRemovedRemoteEvent
Visual C++
public ref class IDTableEntryRemovedRemoteEvent

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Eventing.Remote..::..IDTableEntryRemovedRemoteEvent

See Also

IDTableEntryRemovedRemoteEvent Members
Sitecore.Data.Eventing.Remote Namespace


IDTableEntryRemovedRemoteEvent Constructor

[image]

Sitecore 6.4.1 API
IDTableEntryRemovedRemoteEvent Constructor
IDTableEntryRemovedRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IDTableEntryRemovedRemoteEvent(
    string prefix,
    string key
)
Visual Basic
Public Sub New ( _
    prefix As String, _
    key As String _
)
Visual C++
public:
IDTableEntryRemovedRemoteEvent(
    String^ prefix,
    String^ key
)

Parameters

prefix
Type: System..::..String
Entry prefix
key
Type: System..::..String
The cache key.

See Also

IDTableEntryRemovedRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


IDTableEntryRemovedRemoteEvent Methods

[image] [image]

Sitecore 6.4.1 API
IDTableEntryRemovedRemoteEvent Methods
IDTableEntryRemovedRemoteEvent Class See Also Send Feedback

The IDTableEntryRemovedRemoteEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IDTableEntryRemovedRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


IDTableEntryRemovedRemoteEvent Properties

[image] [image]

Sitecore 6.4.1 API
IDTableEntryRemovedRemoteEvent Properties
IDTableEntryRemovedRemoteEvent Class See Also Send Feedback

The IDTableEntryRemovedRemoteEvent type exposes the following members.

Properties

 | Name | Description
Public property | Key | Gets or sets the key.
Public property | Prefix | Gets or sets the prefix.

See Also

IDTableEntryRemovedRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


Key Property

[image]

Sitecore 6.4.1 API
IDTableEntryRemovedRemoteEvent..::..Key Property
IDTableEntryRemovedRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Key { get; set; }
Visual Basic
Public Property Key As String
    Get
    Set
Visual C++
public:
property String^ Key {
    String^ get ();
    void set (String^ value);
}

Field Value

The Entry key.

See Also

IDTableEntryRemovedRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


Prefix Property

[image]

Sitecore 6.4.1 API
IDTableEntryRemovedRemoteEvent..::..Prefix Property
IDTableEntryRemovedRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Prefix { get; set; }
Visual Basic
Public Property Prefix As String
    Get
    Set
Visual C++
public:
property String^ Prefix {
    String^ get ();
    void set (String^ value);
}

Field Value

The prefix.

See Also

IDTableEntryRemovedRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


ItemLockedRemoteEvent Class

[image]

Sitecore 6.4.1 API
ItemLockedRemoteEvent Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemLockedRemoteEvent : ItemRemoteEventBase
Visual Basic
Public Class ItemLockedRemoteEvent _
    Inherits ItemRemoteEventBase
Visual C++
public ref class ItemLockedRemoteEvent : public ItemRemoteEventBase

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Eventing.Remote..::..ItemRemoteEventBase
Sitecore.Data.Eventing.Remote..::..ItemLockedRemoteEvent

See Also

ItemLockedRemoteEvent Members
Sitecore.Data.Eventing.Remote Namespace


ItemLockedRemoteEvent Members

[image] [image]

Sitecore 6.4.1 API
ItemLockedRemoteEvent Members
ItemLockedRemoteEvent Class Constructors Methods Properties See Also Send Feedback

The ItemLockedRemoteEvent type exposes the following members.

Constructors

 | Name | Description
Public method | ItemLockedRemoteEvent | Initializes a new instance of the ItemLockedRemoteEvent class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ItemId | Gets or sets ItemId. (Inherited from ItemRemoteEventBase.)
Public property | ItemName | Gets or sets the name of the item. (Inherited from ItemRemoteEventBase.)
Public property | LanguageName | Gets or sets Language. (Inherited from ItemRemoteEventBase.)
Public property | TemplateId | Gets or sets the template ID of the item being saved. (Inherited from ItemRemoteEventBase.)
Public property | VersionNumber | Gets or sets Version. (Inherited from ItemRemoteEventBase.)

See Also

ItemLockedRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


ItemLockedRemoteEvent Constructor

[image]

Sitecore 6.4.1 API
ItemLockedRemoteEvent Constructor
ItemLockedRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemLockedRemoteEvent(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
ItemLockedRemoteEvent(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

ItemLockedRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


ItemLockedRemoteEvent Methods

[image] [image]

Sitecore 6.4.1 API
ItemLockedRemoteEvent Methods
ItemLockedRemoteEvent Class See Also Send Feedback

The ItemLockedRemoteEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemLockedRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


ItemLockedRemoteEvent Properties

[image] [image]

Sitecore 6.4.1 API
ItemLockedRemoteEvent Properties
ItemLockedRemoteEvent Class See Also Send Feedback

The ItemLockedRemoteEvent type exposes the following members.

Properties

 | Name | Description
Public property | ItemId | Gets or sets ItemId. (Inherited from ItemRemoteEventBase.)
Public property | ItemName | Gets or sets the name of the item. (Inherited from ItemRemoteEventBase.)
Public property | LanguageName | Gets or sets Language. (Inherited from ItemRemoteEventBase.)
Public property | TemplateId | Gets or sets the template ID of the item being saved. (Inherited from ItemRemoteEventBase.)
Public property | VersionNumber | Gets or sets Version. (Inherited from ItemRemoteEventBase.)

See Also

ItemLockedRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


ItemRemoteEventBase Class

[image]

Sitecore 6.4.1 API
ItemRemoteEventBase Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class ItemRemoteEventBase
Visual Basic
Public MustInherit Class ItemRemoteEventBase
Visual C++
public ref class ItemRemoteEventBase abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Eventing.Remote..::..ItemRemoteEventBase
Sitecore.Data.Eventing.Remote..::..AddedFromTemplateRemoteEvent
Sitecore.Data.Eventing.Remote..::..AddedVersionRemoteEvent
Sitecore.Data.Eventing.Remote..::..CopiedItemRemoteEvent
Sitecore.Data.Eventing.Remote..::..CreatedItemRemoteEvent
Sitecore.Data.Eventing.Remote..::..DeletedItemRemoteEvent
Sitecore.Data.Eventing.Remote..::..ItemLockedRemoteEvent
Sitecore.Data.Eventing.Remote..::..ItemTemplateChangedRemoteEvent
Sitecore.Data.Eventing.Remote..::..ItemUnlockedRemoteEvent
Sitecore.Data.Eventing.Remote..::..MovedItemRemoteEvent
Sitecore.Data.Eventing.Remote..::..RemovedVersionRemoteEvent
Sitecore.Data.Eventing.Remote..::..SavedItemRemoteEvent

See Also

ItemRemoteEventBase Members
Sitecore.Data.Eventing.Remote Namespace


ItemRemoteEventBase Members

[image] [image]

Sitecore 6.4.1 API
ItemRemoteEventBase Members
ItemRemoteEventBase Class Constructors Methods Properties See Also Send Feedback

The ItemRemoteEventBase type exposes the following members.

Constructors

 | Name | Description
Protected method | ItemRemoteEventBase | Initializes a new instance of the ItemRemoteEventBase class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ItemId | Gets or sets ItemId.
Public property | ItemName | Gets or sets the name of the item.
Public property | LanguageName | Gets or sets Language.
Public property | TemplateId | Gets or sets the template ID of the item being saved.
Public property | VersionNumber | Gets or sets Version.

See Also

ItemRemoteEventBase Class
Sitecore.Data.Eventing.Remote Namespace


ItemRemoteEventBase Constructor

[image]

Sitecore 6.4.1 API
ItemRemoteEventBase Constructor
ItemRemoteEventBase Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected ItemRemoteEventBase(
    Item item
)
Visual Basic
Protected Sub New ( _
    item As Item _
)
Visual C++
protected:
ItemRemoteEventBase(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

ItemRemoteEventBase Class
Sitecore.Data.Eventing.Remote Namespace


ItemRemoteEventBase Methods

[image] [image]

Sitecore 6.4.1 API
ItemRemoteEventBase Methods
ItemRemoteEventBase Class See Also Send Feedback

The ItemRemoteEventBase type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemRemoteEventBase Class
Sitecore.Data.Eventing.Remote Namespace


ItemRemoteEventBase Properties

[image] [image]

Sitecore 6.4.1 API
ItemRemoteEventBase Properties
ItemRemoteEventBase Class See Also Send Feedback

The ItemRemoteEventBase type exposes the following members.

Properties

 | Name | Description
Public property | ItemId | Gets or sets ItemId.
Public property | ItemName | Gets or sets the name of the item.
Public property | LanguageName | Gets or sets Language.
Public property | TemplateId | Gets or sets the template ID of the item being saved.
Public property | VersionNumber | Gets or sets Version.

See Also

ItemRemoteEventBase Class
Sitecore.Data.Eventing.Remote Namespace


ItemId Property

[image]

Sitecore 6.4.1 API
ItemRemoteEventBase..::..ItemId Property
ItemRemoteEventBase Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Guid ItemId { get; protected set; }
Visual Basic
Public Property ItemId As Guid
    Get
    Protected Set
Visual C++
public:
property Guid ItemId {
    Guid get ();
    protected: void set (Guid value);
}

Field Value

The item id.

See Also

ItemRemoteEventBase Class
Sitecore.Data.Eventing.Remote Namespace


ItemName Property

[image]

Sitecore 6.4.1 API
ItemRemoteEventBase..::..ItemName Property
ItemRemoteEventBase Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ItemName { get; protected set; }
Visual Basic
Public Property ItemName As String
    Get
    Protected Set
Visual C++
public:
property String^ ItemName {
    String^ get ();
    protected: void set (String^ value);
}

Field Value

The name of the item.

See Also

ItemRemoteEventBase Class
Sitecore.Data.Eventing.Remote Namespace


LanguageName Property

[image]

Sitecore 6.4.1 API
ItemRemoteEventBase..::..LanguageName Property
ItemRemoteEventBase Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string LanguageName { get; protected set; }
Visual Basic
Public Property LanguageName As String
    Get
    Protected Set
Visual C++
public:
property String^ LanguageName {
    String^ get ();
    protected: void set (String^ value);
}

Field Value

The language.

See Also

ItemRemoteEventBase Class
Sitecore.Data.Eventing.Remote Namespace


TemplateId Property

[image]

Sitecore 6.4.1 API
ItemRemoteEventBase..::..TemplateId Property
ItemRemoteEventBase Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Guid TemplateId { get; protected set; }
Visual Basic
Public Property TemplateId As Guid
    Get
    Protected Set
Visual C++
public:
property Guid TemplateId {
    Guid get ();
    protected: void set (Guid value);
}

Field Value

A Guid representing the template ID of the item.

See Also

ItemRemoteEventBase Class
Sitecore.Data.Eventing.Remote Namespace


VersionNumber Property

[image]

Sitecore 6.4.1 API
ItemRemoteEventBase..::..VersionNumber Property
ItemRemoteEventBase Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int VersionNumber { get; protected set; }
Visual Basic
Public Property VersionNumber As Integer
    Get
    Protected Set
Visual C++
public:
property int VersionNumber {
    int get ();
    protected: void set (int value);
}

Field Value

The version.

See Also

ItemRemoteEventBase Class
Sitecore.Data.Eventing.Remote Namespace


ItemTemplateChangedRemoteEvent Class

[image]

Sitecore 6.4.1 API
ItemTemplateChangedRemoteEvent Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemTemplateChangedRemoteEvent : ItemRemoteEventBase
Visual Basic
Public Class ItemTemplateChangedRemoteEvent _
    Inherits ItemRemoteEventBase
Visual C++
public ref class ItemTemplateChangedRemoteEvent : public ItemRemoteEventBase

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Eventing.Remote..::..ItemRemoteEventBase
Sitecore.Data.Eventing.Remote..::..ItemTemplateChangedRemoteEvent

See Also

ItemTemplateChangedRemoteEvent Members
Sitecore.Data.Eventing.Remote Namespace


ItemTemplateChangedRemoteEvent Constructor

[image]

Sitecore 6.4.1 API
ItemTemplateChangedRemoteEvent Constructor
ItemTemplateChangedRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemTemplateChangedRemoteEvent(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
ItemTemplateChangedRemoteEvent(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

ItemTemplateChangedRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


ItemTemplateChangedRemoteEvent Methods

[image] [image]

Sitecore 6.4.1 API
ItemTemplateChangedRemoteEvent Methods
ItemTemplateChangedRemoteEvent Class See Also Send Feedback

The ItemTemplateChangedRemoteEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemTemplateChangedRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


ItemTemplateChangedRemoteEvent Properties

[image] [image]

Sitecore 6.4.1 API
ItemTemplateChangedRemoteEvent Properties
ItemTemplateChangedRemoteEvent Class See Also Send Feedback

The ItemTemplateChangedRemoteEvent type exposes the following members.

Properties

 | Name | Description
Public property | ItemId | Gets or sets ItemId. (Inherited from ItemRemoteEventBase.)
Public property | ItemName | Gets or sets the name of the item. (Inherited from ItemRemoteEventBase.)
Public property | LanguageName | Gets or sets Language. (Inherited from ItemRemoteEventBase.)
Public property | TemplateId | Gets or sets the template ID of the item being saved. (Inherited from ItemRemoteEventBase.)
Public property | VersionNumber | Gets or sets Version. (Inherited from ItemRemoteEventBase.)

See Also

ItemTemplateChangedRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


ItemUnlockedRemoteEvent Class

[image]

Sitecore 6.4.1 API
ItemUnlockedRemoteEvent Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemUnlockedRemoteEvent : ItemRemoteEventBase
Visual Basic
Public Class ItemUnlockedRemoteEvent _
    Inherits ItemRemoteEventBase
Visual C++
public ref class ItemUnlockedRemoteEvent : public ItemRemoteEventBase

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Eventing.Remote..::..ItemRemoteEventBase
Sitecore.Data.Eventing.Remote..::..ItemUnlockedRemoteEvent

See Also

ItemUnlockedRemoteEvent Members
Sitecore.Data.Eventing.Remote Namespace


ItemUnlockedRemoteEvent Members

[image] [image]

Sitecore 6.4.1 API
ItemUnlockedRemoteEvent Members
ItemUnlockedRemoteEvent Class Constructors Methods Properties See Also Send Feedback

The ItemUnlockedRemoteEvent type exposes the following members.

Constructors

 | Name | Description
Public method | ItemUnlockedRemoteEvent | Initializes a new instance of the ItemUnlockedRemoteEvent class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ItemId | Gets or sets ItemId. (Inherited from ItemRemoteEventBase.)
Public property | ItemName | Gets or sets the name of the item. (Inherited from ItemRemoteEventBase.)
Public property | LanguageName | Gets or sets Language. (Inherited from ItemRemoteEventBase.)
Public property | TemplateId | Gets or sets the template ID of the item being saved. (Inherited from ItemRemoteEventBase.)
Public property | VersionNumber | Gets or sets Version. (Inherited from ItemRemoteEventBase.)

See Also

ItemUnlockedRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


ItemUnlockedRemoteEvent Constructor

[image]

Sitecore 6.4.1 API
ItemUnlockedRemoteEvent Constructor
ItemUnlockedRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemUnlockedRemoteEvent(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
ItemUnlockedRemoteEvent(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

ItemUnlockedRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


ItemUnlockedRemoteEvent Methods

[image] [image]

Sitecore 6.4.1 API
ItemUnlockedRemoteEvent Methods
ItemUnlockedRemoteEvent Class See Also Send Feedback

The ItemUnlockedRemoteEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemUnlockedRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


ItemUnlockedRemoteEvent Properties

[image] [image]

Sitecore 6.4.1 API
ItemUnlockedRemoteEvent Properties
ItemUnlockedRemoteEvent Class See Also Send Feedback

The ItemUnlockedRemoteEvent type exposes the following members.

Properties

 | Name | Description
Public property | ItemId | Gets or sets ItemId. (Inherited from ItemRemoteEventBase.)
Public property | ItemName | Gets or sets the name of the item. (Inherited from ItemRemoteEventBase.)
Public property | LanguageName | Gets or sets Language. (Inherited from ItemRemoteEventBase.)
Public property | TemplateId | Gets or sets the template ID of the item being saved. (Inherited from ItemRemoteEventBase.)
Public property | VersionNumber | Gets or sets Version. (Inherited from ItemRemoteEventBase.)

See Also

ItemUnlockedRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


MovedItemRemoteEvent Class

[image]

Sitecore 6.4.1 API
MovedItemRemoteEvent Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class MovedItemRemoteEvent : ItemRemoteEventBase
Visual Basic
Public Class MovedItemRemoteEvent _
    Inherits ItemRemoteEventBase
Visual C++
public ref class MovedItemRemoteEvent : public ItemRemoteEventBase

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Eventing.Remote..::..ItemRemoteEventBase
Sitecore.Data.Eventing.Remote..::..MovedItemRemoteEvent

See Also

MovedItemRemoteEvent Members
Sitecore.Data.Eventing.Remote Namespace


MovedItemRemoteEvent Members

[image] [image]

Sitecore 6.4.1 API
MovedItemRemoteEvent Members
MovedItemRemoteEvent Class Constructors Methods Properties See Also Send Feedback

The MovedItemRemoteEvent type exposes the following members.

Constructors

 | Name | Description
Public method | MovedItemRemoteEvent | Initializes a new instance of the MovedItemRemoteEvent class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DestinationId | Gets or sets destination item ID;
Public property | ItemId | Gets or sets ItemId. (Inherited from ItemRemoteEventBase.)
Public property | ItemName | Gets or sets the name of the item. (Inherited from ItemRemoteEventBase.)
Public property | LanguageName | Gets or sets Language. (Inherited from ItemRemoteEventBase.)
Public property | OldParentId | Gets or sets OldParentId.
Public property | TemplateId | Gets or sets the template ID of the item being saved. (Inherited from ItemRemoteEventBase.)
Public property | VersionNumber | Gets or sets Version. (Inherited from ItemRemoteEventBase.)

See Also

MovedItemRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


MovedItemRemoteEvent Constructor

[image]

Sitecore 6.4.1 API
MovedItemRemoteEvent Constructor
MovedItemRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MovedItemRemoteEvent(
    Item item,
    ID oldParentId
)
Visual Basic
Public Sub New ( _
    item As Item, _
    oldParentId As ID _
)
Visual C++
public:
MovedItemRemoteEvent(
    Item^ item,
    ID^ oldParentId
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
oldParentId
Type: Sitecore.Data..::..ID
The old parent id.

See Also

MovedItemRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


MovedItemRemoteEvent Methods

[image] [image]

Sitecore 6.4.1 API
MovedItemRemoteEvent Methods
MovedItemRemoteEvent Class See Also Send Feedback

The MovedItemRemoteEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MovedItemRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


MovedItemRemoteEvent Properties

[image] [image]

Sitecore 6.4.1 API
MovedItemRemoteEvent Properties
MovedItemRemoteEvent Class See Also Send Feedback

The MovedItemRemoteEvent type exposes the following members.

Properties

 | Name | Description
Public property | DestinationId | Gets or sets destination item ID;
Public property | ItemId | Gets or sets ItemId. (Inherited from ItemRemoteEventBase.)
Public property | ItemName | Gets or sets the name of the item. (Inherited from ItemRemoteEventBase.)
Public property | LanguageName | Gets or sets Language. (Inherited from ItemRemoteEventBase.)
Public property | OldParentId | Gets or sets OldParentId.
Public property | TemplateId | Gets or sets the template ID of the item being saved. (Inherited from ItemRemoteEventBase.)
Public property | VersionNumber | Gets or sets Version. (Inherited from ItemRemoteEventBase.)

See Also

MovedItemRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


DestinationId Property

[image]

Sitecore 6.4.1 API
MovedItemRemoteEvent..::..DestinationId Property
MovedItemRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Guid DestinationId { get; protected set; }
Visual Basic
Public Property DestinationId As Guid
    Get
    Protected Set
Visual C++
public:
property Guid DestinationId {
    Guid get ();
    protected: void set (Guid value);
}

See Also

MovedItemRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


OldParentId Property

[image]

Sitecore 6.4.1 API
MovedItemRemoteEvent..::..OldParentId Property
MovedItemRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Guid OldParentId { get; protected set; }
Visual Basic
Public Property OldParentId As Guid
    Get
    Protected Set
Visual C++
public:
property Guid OldParentId {
    Guid get ();
    protected: void set (Guid value);
}

See Also

MovedItemRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


PropertyChangedRemoteEvent Class

[image]

Sitecore 6.4.1 API
PropertyChangedRemoteEvent Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PropertyChangedRemoteEvent
Visual Basic
Public Class PropertyChangedRemoteEvent
Visual C++
public ref class PropertyChangedRemoteEvent

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Eventing.Remote..::..PropertyChangedRemoteEvent

See Also

PropertyChangedRemoteEvent Members
Sitecore.Data.Eventing.Remote Namespace


PropertyChangedRemoteEvent Members

[image] [image]

Sitecore 6.4.1 API
PropertyChangedRemoteEvent Members
PropertyChangedRemoteEvent Class Constructors Methods Properties See Also Send Feedback

The PropertyChangedRemoteEvent type exposes the following members.

Constructors

 | Name | Description
Public method | PropertyChangedRemoteEvent | Initializes a new instance of the PropertyChangedRemoteEvent class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PropertyName | Gets or sets the name of the property.

See Also

PropertyChangedRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


PropertyChangedRemoteEvent Constructor

[image]

Sitecore 6.4.1 API
PropertyChangedRemoteEvent Constructor
PropertyChangedRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PropertyChangedRemoteEvent(
    string propertyName
)
Visual Basic
Public Sub New ( _
    propertyName As String _
)
Visual C++
public:
PropertyChangedRemoteEvent(
    String^ propertyName
)

Parameters

propertyName
Type: System..::..String
Name of the property.

See Also

PropertyChangedRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


PropertyChangedRemoteEvent Methods

[image] [image]

Sitecore 6.4.1 API
PropertyChangedRemoteEvent Methods
PropertyChangedRemoteEvent Class See Also Send Feedback

The PropertyChangedRemoteEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PropertyChangedRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


PropertyChangedRemoteEvent Properties

[image] [image]

Sitecore 6.4.1 API
PropertyChangedRemoteEvent Properties
PropertyChangedRemoteEvent Class See Also Send Feedback

The PropertyChangedRemoteEvent type exposes the following members.

Properties

 | Name | Description
Public property | PropertyName | Gets or sets the name of the property.

See Also

PropertyChangedRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


PropertyName Property

[image]

Sitecore 6.4.1 API
PropertyChangedRemoteEvent..::..PropertyName Property
PropertyChangedRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string PropertyName { get; set; }
Visual Basic
Public Property PropertyName As String
    Get
    Set
Visual C++
public:
property String^ PropertyName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the property.

See Also

PropertyChangedRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


PropertyRemovedRemoteEvent Class

[image]

Sitecore 6.4.1 API
PropertyRemovedRemoteEvent Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PropertyRemovedRemoteEvent
Visual Basic
Public Class PropertyRemovedRemoteEvent
Visual C++
public ref class PropertyRemovedRemoteEvent

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Eventing.Remote..::..PropertyRemovedRemoteEvent

See Also

PropertyRemovedRemoteEvent Members
Sitecore.Data.Eventing.Remote Namespace


PropertyRemovedRemoteEvent Members

[image] [image]

Sitecore 6.4.1 API
PropertyRemovedRemoteEvent Members
PropertyRemovedRemoteEvent Class Constructors Methods Properties See Also Send Feedback

The PropertyRemovedRemoteEvent type exposes the following members.

Constructors

 | Name | Description
Public method | PropertyRemovedRemoteEvent | Initializes a new instance of the PropertyRemovedRemoteEvent class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsPrefix | Gets or sets a value indicating whether this PropertyName holds a prefix.
Public property | PropertyName | Gets or sets the name of the property.

See Also

PropertyRemovedRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


PropertyRemovedRemoteEvent Constructor

[image]

Sitecore 6.4.1 API
PropertyRemovedRemoteEvent Constructor
PropertyRemovedRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PropertyRemovedRemoteEvent(
    string propertyName,
    bool isPrefix
)
Visual Basic
Public Sub New ( _
    propertyName As String, _
    isPrefix As Boolean _
)
Visual C++
public:
PropertyRemovedRemoteEvent(
    String^ propertyName,
    bool isPrefix
)

Parameters

propertyName
Type: System..::..String
Name of the property.
isPrefix
Type: System..::..Boolean
Mark the name as a prefix.

See Also

PropertyRemovedRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


PropertyRemovedRemoteEvent Methods

[image] [image]

Sitecore 6.4.1 API
PropertyRemovedRemoteEvent Methods
PropertyRemovedRemoteEvent Class See Also Send Feedback

The PropertyRemovedRemoteEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PropertyRemovedRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


IsPrefix Property

[image]

Sitecore 6.4.1 API
PropertyRemovedRemoteEvent..::..IsPrefix Property
PropertyRemovedRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsPrefix { get; set; }
Visual Basic
Public Property IsPrefix As Boolean
    Get
    Set
Visual C++
public:
property bool IsPrefix {
    bool get ();
    void set (bool value);
}

Field Value

true if the PropertyName value is a prefix; otherwise, false.

See Also

PropertyRemovedRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


PropertyName Property

[image]

Sitecore 6.4.1 API
PropertyRemovedRemoteEvent..::..PropertyName Property
PropertyRemovedRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string PropertyName { get; set; }
Visual Basic
Public Property PropertyName As String
    Get
    Set
Visual C++
public:
property String^ PropertyName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the property.

See Also

PropertyRemovedRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


RemovedDataRemoteEvent Members

[image] [image]

Sitecore 6.4.1 API
RemovedDataRemoteEvent Members
RemovedDataRemoteEvent Class Constructors Methods Properties See Also Send Feedback

The RemovedDataRemoteEvent type exposes the following members.

Constructors

 | Name | Description
Public method | RemovedDataRemoteEvent | Initializes a new instance of the RemovedDataRemoteEvent class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ItemId | Gets or sets ItemId.
Public property | LanguageName | Gets or sets Language.
Public property | RemoveAllLanguages | Gets or sets a value indicating whether RemoveAllLanguages.
Public property | RemoveSharedData | Gets or sets a value indicating whether RemoveSharedData.

See Also

RemovedDataRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


RemovedDataRemoteEvent Constructor

[image]

Sitecore 6.4.1 API
RemovedDataRemoteEvent Constructor
RemovedDataRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RemovedDataRemoteEvent(
    ID itemId,
    Language language,
    bool removeAllLanguages,
    bool removeSharedData,
    Database database
)
Visual Basic
Public Sub New ( _
    itemId As ID, _
    language As Language, _
    removeAllLanguages As Boolean, _
    removeSharedData As Boolean, _
    database As Database _
)
Visual C++
public:
RemovedDataRemoteEvent(
    ID^ itemId,
    Language^ language,
    bool removeAllLanguages,
    bool removeSharedData,
    Database^ database
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
language
Type: Sitecore.Globalization..::..Language
The language.
removeAllLanguages
Type: System..::..Boolean
if set to true [remove all languages].
removeSharedData
Type: System..::..Boolean
if set to true [remove shared data].
database
Type: Sitecore.Data..::..Database
The database.

See Also

RemovedDataRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


RemovedDataRemoteEvent Properties

[image] [image]

Sitecore 6.4.1 API
RemovedDataRemoteEvent Properties
RemovedDataRemoteEvent Class See Also Send Feedback

The RemovedDataRemoteEvent type exposes the following members.

Properties

 | Name | Description
Public property | ItemId | Gets or sets ItemId.
Public property | LanguageName | Gets or sets Language.
Public property | RemoveAllLanguages | Gets or sets a value indicating whether RemoveAllLanguages.
Public property | RemoveSharedData | Gets or sets a value indicating whether RemoveSharedData.

See Also

RemovedDataRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


ItemId Property

[image]

Sitecore 6.4.1 API
RemovedDataRemoteEvent..::..ItemId Property
RemovedDataRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Guid ItemId { get; protected set; }
Visual Basic
Public Property ItemId As Guid
    Get
    Protected Set
Visual C++
public:
property Guid ItemId {
    Guid get ();
    protected: void set (Guid value);
}

See Also

RemovedDataRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


LanguageName Property

[image]

Sitecore 6.4.1 API
RemovedDataRemoteEvent..::..LanguageName Property
RemovedDataRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string LanguageName { get; protected set; }
Visual Basic
Public Property LanguageName As String
    Get
    Protected Set
Visual C++
public:
property String^ LanguageName {
    String^ get ();
    protected: void set (String^ value);
}

See Also

RemovedDataRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


RemoveAllLanguages Property

[image]

Sitecore 6.4.1 API
RemovedDataRemoteEvent..::..RemoveAllLanguages Property
RemovedDataRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool RemoveAllLanguages { get; protected set; }
Visual Basic
Public Property RemoveAllLanguages As Boolean
    Get
    Protected Set
Visual C++
public:
property bool RemoveAllLanguages {
    bool get ();
    protected: void set (bool value);
}

See Also

RemovedDataRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


RemoveSharedData Property

[image]

Sitecore 6.4.1 API
RemovedDataRemoteEvent..::..RemoveSharedData Property
RemovedDataRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool RemoveSharedData { get; protected set; }
Visual Basic
Public Property RemoveSharedData As Boolean
    Get
    Protected Set
Visual C++
public:
property bool RemoveSharedData {
    bool get ();
    protected: void set (bool value);
}

See Also

RemovedDataRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


RemovedVersionRemoteEvent Class

[image]

Sitecore 6.4.1 API
RemovedVersionRemoteEvent Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RemovedVersionRemoteEvent : ItemRemoteEventBase
Visual Basic
Public Class RemovedVersionRemoteEvent _
    Inherits ItemRemoteEventBase
Visual C++
public ref class RemovedVersionRemoteEvent : public ItemRemoteEventBase

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Eventing.Remote..::..ItemRemoteEventBase
Sitecore.Data.Eventing.Remote..::..RemovedVersionRemoteEvent

See Also

RemovedVersionRemoteEvent Members
Sitecore.Data.Eventing.Remote Namespace


RemovedVersionRemoteEvent Members

[image] [image]

Sitecore 6.4.1 API
RemovedVersionRemoteEvent Members
RemovedVersionRemoteEvent Class Constructors Methods Properties See Also Send Feedback

The RemovedVersionRemoteEvent type exposes the following members.

Constructors

 | Name | Description
Public method | RemovedVersionRemoteEvent | Initializes a new instance of the RemovedVersionRemoteEvent class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ItemId | Gets or sets ItemId. (Inherited from ItemRemoteEventBase.)
Public property | ItemName | Gets or sets the name of the item. (Inherited from ItemRemoteEventBase.)
Public property | LanguageName | Gets or sets Language. (Inherited from ItemRemoteEventBase.)
Public property | TemplateId | Gets or sets the template ID of the item being saved. (Inherited from ItemRemoteEventBase.)
Public property | VersionNumber | Gets or sets Version. (Inherited from ItemRemoteEventBase.)

See Also

RemovedVersionRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


RemovedVersionRemoteEvent Constructor

[image]

Sitecore 6.4.1 API
RemovedVersionRemoteEvent Constructor
RemovedVersionRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RemovedVersionRemoteEvent(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
RemovedVersionRemoteEvent(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

RemovedVersionRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


RemovedVersionRemoteEvent Properties

[image] [image]

Sitecore 6.4.1 API
RemovedVersionRemoteEvent Properties
RemovedVersionRemoteEvent Class See Also Send Feedback

The RemovedVersionRemoteEvent type exposes the following members.

Properties

 | Name | Description
Public property | ItemId | Gets or sets ItemId. (Inherited from ItemRemoteEventBase.)
Public property | ItemName | Gets or sets the name of the item. (Inherited from ItemRemoteEventBase.)
Public property | LanguageName | Gets or sets Language. (Inherited from ItemRemoteEventBase.)
Public property | TemplateId | Gets or sets the template ID of the item being saved. (Inherited from ItemRemoteEventBase.)
Public property | VersionNumber | Gets or sets Version. (Inherited from ItemRemoteEventBase.)

See Also

RemovedVersionRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


SavedItemRemoteEvent Class

[image]

Sitecore 6.4.1 API
SavedItemRemoteEvent Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SavedItemRemoteEvent : ItemRemoteEventBase
Visual Basic
Public Class SavedItemRemoteEvent _
    Inherits ItemRemoteEventBase
Visual C++
public ref class SavedItemRemoteEvent : public ItemRemoteEventBase

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Eventing.Remote..::..ItemRemoteEventBase
Sitecore.Data.Eventing.Remote..::..SavedItemRemoteEvent

See Also

SavedItemRemoteEvent Members
Sitecore.Data.Eventing.Remote Namespace


SavedItemRemoteEvent Members

[image] [image]

Sitecore 6.4.1 API
SavedItemRemoteEvent Members
SavedItemRemoteEvent Class Constructors Methods Properties See Also Send Feedback

The SavedItemRemoteEvent type exposes the following members.

Constructors

 | Name | Description
Public method | SavedItemRemoteEvent | Initializes a new instance of the SavedItemRemoteEvent class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FieldChanges | Gets or sets the field changes.
Public property | ItemId | Gets or sets ItemId. (Inherited from ItemRemoteEventBase.)
Public property | ItemName | Gets or sets the name of the item. (Inherited from ItemRemoteEventBase.)
Public property | LanguageName | Gets or sets Language. (Inherited from ItemRemoteEventBase.)
Public property | PropertyChanges | Gets or sets the property changes.
Public property | TemplateId | Gets or sets the template ID of the item being saved. (Inherited from ItemRemoteEventBase.)
Public property | VersionNumber | Gets or sets Version. (Inherited from ItemRemoteEventBase.)

See Also

SavedItemRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


SavedItemRemoteEvent Constructor

[image]

Sitecore 6.4.1 API
SavedItemRemoteEvent Constructor
SavedItemRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SavedItemRemoteEvent(
    Item item,
    ItemChanges changes
)
Visual Basic
Public Sub New ( _
    item As Item, _
    changes As ItemChanges _
)
Visual C++
public:
SavedItemRemoteEvent(
    Item^ item,
    ItemChanges^ changes
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
changes
Type: Sitecore.Data.Items..::..ItemChanges
The changes.

See Also

SavedItemRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


SavedItemRemoteEvent Methods

[image] [image]

Sitecore 6.4.1 API
SavedItemRemoteEvent Methods
SavedItemRemoteEvent Class See Also Send Feedback

The SavedItemRemoteEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SavedItemRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


SavedItemRemoteEvent Properties

[image] [image]

Sitecore 6.4.1 API
SavedItemRemoteEvent Properties
SavedItemRemoteEvent Class See Also Send Feedback

The SavedItemRemoteEvent type exposes the following members.

Properties

 | Name | Description
Public property | FieldChanges | Gets or sets the field changes.
Public property | ItemId | Gets or sets ItemId. (Inherited from ItemRemoteEventBase.)
Public property | ItemName | Gets or sets the name of the item. (Inherited from ItemRemoteEventBase.)
Public property | LanguageName | Gets or sets Language. (Inherited from ItemRemoteEventBase.)
Public property | PropertyChanges | Gets or sets the property changes.
Public property | TemplateId | Gets or sets the template ID of the item being saved. (Inherited from ItemRemoteEventBase.)
Public property | VersionNumber | Gets or sets Version. (Inherited from ItemRemoteEventBase.)

See Also

SavedItemRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


FieldChanges Property

[image]

Sitecore 6.4.1 API
SavedItemRemoteEvent..::..FieldChanges Property
SavedItemRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public List<SavedItemRemoteEvent..::..FieldChange> FieldChanges { get; protected set; }
Visual Basic
Public Property FieldChanges As List(Of SavedItemRemoteEvent..::..FieldChange)
    Get
    Protected Set
Visual C++
public:
property List<SavedItemRemoteEvent..::..FieldChange^>^ FieldChanges {
    List<SavedItemRemoteEvent..::..FieldChange^>^ get ();
    protected: void set (List<SavedItemRemoteEvent..::..FieldChange^>^ value);
}

Field Value

The field changes.

See Also

SavedItemRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


PropertyChanges Property

[image]

Sitecore 6.4.1 API
SavedItemRemoteEvent..::..PropertyChanges Property
SavedItemRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public List<SavedItemRemoteEvent..::..PropertyChange> PropertyChanges { get; protected set; }
Visual Basic
Public Property PropertyChanges As List(Of SavedItemRemoteEvent..::..PropertyChange)
    Get
    Protected Set
Visual C++
public:
property List<SavedItemRemoteEvent..::..PropertyChange^>^ PropertyChanges {
    List<SavedItemRemoteEvent..::..PropertyChange^>^ get ();
    protected: void set (List<SavedItemRemoteEvent..::..PropertyChange^>^ value);
}

Field Value

The property changes.

See Also

SavedItemRemoteEvent Class
Sitecore.Data.Eventing.Remote Namespace


SavedItemRemoteEvent.FieldChange Class

[image]

Sitecore 6.4.1 API
SavedItemRemoteEvent..::..FieldChange Class
SavedItemRemoteEvent Class Members See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FieldChange
Visual Basic
Public Class FieldChange
Visual C++
public ref class FieldChange

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Eventing.Remote..::..SavedItemRemoteEvent..::..FieldChange

See Also

SavedItemRemoteEvent..::..FieldChange Members
Sitecore.Data.Eventing.Remote Namespace


SavedItemRemoteEvent.FieldChange Members

[image] [image]

Sitecore 6.4.1 API
SavedItemRemoteEvent..::..FieldChange Members
SavedItemRemoteEvent..::..FieldChange Class Constructors Methods Properties See Also Send Feedback

ItemSavedRemoteEvent class.

The SavedItemRemoteEvent..::..FieldChange type exposes the following members.

Constructors

 | Name | Description
Protected method | SavedItemRemoteEvent..::..FieldChange()()()() | Initializes a new instance of the SavedItemRemoteEvent..::..FieldChange class.
Public method | SavedItemRemoteEvent..::..FieldChange(Guid, String) | Initializes a new instance of the SavedItemRemoteEvent..::..FieldChange class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FieldId | Gets or sets FieldId.
Public property | Value | Gets or sets Value.

See Also

SavedItemRemoteEvent..::..FieldChange Class
Sitecore.Data.Eventing.Remote Namespace


SavedItemRemoteEvent.FieldChange Constructor

[image] [image]

Sitecore 6.4.1 API
SavedItemRemoteEvent..::..FieldChange Constructor
SavedItemRemoteEvent..::..FieldChange Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SavedItemRemoteEvent..::..FieldChange()()()() | Initializes a new instance of the SavedItemRemoteEvent..::..FieldChange class.
Public method | SavedItemRemoteEvent..::..FieldChange(Guid, String) | Initializes a new instance of the SavedItemRemoteEvent..::..FieldChange class.

See Also

SavedItemRemoteEvent..::..FieldChange Class
SavedItemRemoteEvent..::..FieldChange Members
Sitecore.Data.Eventing.Remote Namespace


SavedItemRemoteEvent.FieldChange Constructor

[image]

Sitecore 6.4.1 API
SavedItemRemoteEvent..::..FieldChange Constructor
SavedItemRemoteEvent..::..FieldChange Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected FieldChange()
Visual Basic
Protected Sub New
Visual C++
protected:
FieldChange()

See Also

SavedItemRemoteEvent..::..FieldChange Class
SavedItemRemoteEvent..::..FieldChange Overload
Sitecore.Data.Eventing.Remote Namespace


SavedItemRemoteEvent.FieldChange Constructor (Guid, String)

[image]

Sitecore 6.4.1 API
SavedItemRemoteEvent..::..FieldChange Constructor (Guid, String)
SavedItemRemoteEvent..::..FieldChange Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FieldChange(
    Guid fieldId,
    string value
)
Visual Basic
Public Sub New ( _
    fieldId As Guid, _
    value As String _
)
Visual C++
public:
FieldChange(
    Guid fieldId,
    String^ value
)

Parameters

fieldId
Type: System..::..Guid
The field id.
value
Type: System..::..String
The value.

See Also

SavedItemRemoteEvent..::..FieldChange Class
SavedItemRemoteEvent..::..FieldChange Overload
Sitecore.Data.Eventing.Remote Namespace


SavedItemRemoteEvent.FieldChange Methods

[image] [image]

Sitecore 6.4.1 API
SavedItemRemoteEvent..::..FieldChange Methods
SavedItemRemoteEvent..::..FieldChange Class See Also Send Feedback

The SavedItemRemoteEvent..::..FieldChange type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SavedItemRemoteEvent..::..FieldChange Class
Sitecore.Data.Eventing.Remote Namespace


SavedItemRemoteEvent.FieldChange Properties

[image] [image]

Sitecore 6.4.1 API
SavedItemRemoteEvent..::..FieldChange Properties
SavedItemRemoteEvent..::..FieldChange Class See Also Send Feedback

The SavedItemRemoteEvent..::..FieldChange type exposes the following members.

Properties

 | Name | Description
Public property | FieldId | Gets or sets FieldId.
Public property | Value | Gets or sets Value.

See Also

SavedItemRemoteEvent..::..FieldChange Class
Sitecore.Data.Eventing.Remote Namespace


FieldId Property

[image]

Sitecore 6.4.1 API
SavedItemRemoteEvent..::..FieldChange..::..FieldId Property
SavedItemRemoteEvent..::..FieldChange Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Guid FieldId { get; protected set; }
Visual Basic
Public Property FieldId As Guid
    Get
    Protected Set
Visual C++
public:
property Guid FieldId {
    Guid get ();
    protected: void set (Guid value);
}

See Also

SavedItemRemoteEvent..::..FieldChange Class
Sitecore.Data.Eventing.Remote Namespace


Value Property

[image]

Sitecore 6.4.1 API
SavedItemRemoteEvent..::..FieldChange..::..Value Property
SavedItemRemoteEvent..::..FieldChange Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Value { get; protected set; }
Visual Basic
Public Property Value As String
    Get
    Protected Set
Visual C++
public:
property String^ Value {
    String^ get ();
    protected: void set (String^ value);
}

See Also

SavedItemRemoteEvent..::..FieldChange Class
Sitecore.Data.Eventing.Remote Namespace


SavedItemRemoteEvent.PropertyChange Class

[image]

Sitecore 6.4.1 API
SavedItemRemoteEvent..::..PropertyChange Class
SavedItemRemoteEvent Class Members See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PropertyChange
Visual Basic
Public Class PropertyChange
Visual C++
public ref class PropertyChange

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Eventing.Remote..::..SavedItemRemoteEvent..::..PropertyChange

See Also

SavedItemRemoteEvent..::..PropertyChange Members
Sitecore.Data.Eventing.Remote Namespace


SavedItemRemoteEvent.PropertyChange Members

[image] [image]

Sitecore 6.4.1 API
SavedItemRemoteEvent..::..PropertyChange Members
SavedItemRemoteEvent..::..PropertyChange Class Constructors Methods Properties See Also Send Feedback

ItemSavedRemoteEvent class.

The SavedItemRemoteEvent..::..PropertyChange type exposes the following members.

Constructors

 | Name | Description
Protected method | SavedItemRemoteEvent..::..PropertyChange()()()() | Initializes a new instance of the SavedItemRemoteEvent..::..PropertyChange class.
Public method | SavedItemRemoteEvent..::..PropertyChange(String, Object) | Initializes a new instance of the SavedItemRemoteEvent..::..PropertyChange class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Protected property | GuidValue | Gets or sets the GUID value.
Public property | PropertyName | Gets or sets PropertyName.
Protected property | StringValue | Gets or sets StringValue.
Public property | Value | Gets the value.

See Also

SavedItemRemoteEvent..::..PropertyChange Class
Sitecore.Data.Eventing.Remote Namespace


SavedItemRemoteEvent.PropertyChange Constructor

[image] [image]

Sitecore 6.4.1 API
SavedItemRemoteEvent..::..PropertyChange Constructor
SavedItemRemoteEvent..::..PropertyChange Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SavedItemRemoteEvent..::..PropertyChange()()()() | Initializes a new instance of the SavedItemRemoteEvent..::..PropertyChange class.
Public method | SavedItemRemoteEvent..::..PropertyChange(String, Object) | Initializes a new instance of the SavedItemRemoteEvent..::..PropertyChange class.

See Also

SavedItemRemoteEvent..::..PropertyChange Class
SavedItemRemoteEvent..::..PropertyChange Members
Sitecore.Data.Eventing.Remote Namespace


SavedItemRemoteEvent.PropertyChange Constructor

[image]

Sitecore 6.4.1 API
SavedItemRemoteEvent..::..PropertyChange Constructor
SavedItemRemoteEvent..::..PropertyChange Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected PropertyChange()
Visual Basic
Protected Sub New
Visual C++
protected:
PropertyChange()

See Also

SavedItemRemoteEvent..::..PropertyChange Class
SavedItemRemoteEvent..::..PropertyChange Overload
Sitecore.Data.Eventing.Remote Namespace


SavedItemRemoteEvent.PropertyChange Constructor (String, Object)

[image]

Sitecore 6.4.1 API
SavedItemRemoteEvent..::..PropertyChange Constructor (String, Object)
SavedItemRemoteEvent..::..PropertyChange Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PropertyChange(
    string propertyName,
    Object value
)
Visual Basic
Public Sub New ( _
    propertyName As String, _
    value As Object _
)
Visual C++
public:
PropertyChange(
    String^ propertyName,
    Object^ value
)

Parameters

propertyName
Type: System..::..String
Name of the property.
value
Type: System..::..Object
The value.

See Also

SavedItemRemoteEvent..::..PropertyChange Class
SavedItemRemoteEvent..::..PropertyChange Overload
Sitecore.Data.Eventing.Remote Namespace


SavedItemRemoteEvent.PropertyChange Methods

[image] [image]

Sitecore 6.4.1 API
SavedItemRemoteEvent..::..PropertyChange Methods
SavedItemRemoteEvent..::..PropertyChange Class See Also Send Feedback

The SavedItemRemoteEvent..::..PropertyChange type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SavedItemRemoteEvent..::..PropertyChange Class
Sitecore.Data.Eventing.Remote Namespace


SavedItemRemoteEvent.PropertyChange Properties

[image] [image]

Sitecore 6.4.1 API
SavedItemRemoteEvent..::..PropertyChange Properties
SavedItemRemoteEvent..::..PropertyChange Class See Also Send Feedback

The SavedItemRemoteEvent..::..PropertyChange type exposes the following members.

Properties

 | Name | Description
Protected property | GuidValue | Gets or sets the GUID value.
Public property | PropertyName | Gets or sets PropertyName.
Protected property | StringValue | Gets or sets StringValue.
Public property | Value | Gets the value.

See Also

SavedItemRemoteEvent..::..PropertyChange Class
Sitecore.Data.Eventing.Remote Namespace


GuidValue Property

[image]

Sitecore 6.4.1 API
SavedItemRemoteEvent..::..PropertyChange..::..GuidValue Property
SavedItemRemoteEvent..::..PropertyChange Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Guid GuidValue { get; set; }
Visual Basic
Protected Property GuidValue As Guid
    Get
    Set
Visual C++
protected:
property Guid GuidValue {
    Guid get ();
    void set (Guid value);
}

Field Value

The GUID value.

See Also

SavedItemRemoteEvent..::..PropertyChange Class
Sitecore.Data.Eventing.Remote Namespace


PropertyName Property

[image]

Sitecore 6.4.1 API
SavedItemRemoteEvent..::..PropertyChange..::..PropertyName Property
SavedItemRemoteEvent..::..PropertyChange Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string PropertyName { get; protected set; }
Visual Basic
Public Property PropertyName As String
    Get
    Protected Set
Visual C++
public:
property String^ PropertyName {
    String^ get ();
    protected: void set (String^ value);
}

See Also

SavedItemRemoteEvent..::..PropertyChange Class
Sitecore.Data.Eventing.Remote Namespace


StringValue Property

[image]

Sitecore 6.4.1 API
SavedItemRemoteEvent..::..PropertyChange..::..StringValue Property
SavedItemRemoteEvent..::..PropertyChange Class See Also Send Feedback

Namespace: Sitecore.Data.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected string StringValue { get; set; }
Visual Basic
Protected Property StringValue As String
    Get
    Set
Visual C++
protected:
property String^ StringValue {
    String^ get ();
    void set (String^ value);
}

See Also

SavedItemRemoteEvent..::..PropertyChange Class
Sitecore.Data.Eventing.Remote Namespace


Sitecore.Data.Events Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Data.Events Namespace
Send Feedback

Classes

 | Class | Description
Public class | AddedFromTemplateRemoteEventArgs | AddedFromTemplateRemoteEventArgs class.
Public class | AddedVersionRemoteEventArgs | AddedVersionRemoteEventArgs class.
Public class | ConstructedEventArgs | Represents the arguments of a constructed event.
Public class | CopiedItemRemoteEventArgs | CopiedItemRemoteEventArgs class.
Public class | CopyProcessedSingleItemEventArgs |
Public class | DeleteProcessedSingleItemEventArgs |
Public class | EventDisabler | EventDisabler class
Public class | ExecutedEventArgs<(Of <(<'TCommand>)>)> | Defines the arguments passed in a AddingFromMaster event.
Public class | ExecutingEventArgs<(Of <(<'TCommand>)>)> | Defines the arguments passed in a AddingFromMaster event.
Public class | FieldSavedEventArgs | Defines the arguments passed in a FieldSaved event.
Public class | GetChildrenEventArgs | Defines the arguments passed in a BeforeItemMove event.
Public class | GetItemEventArgs | Defines the arguments passed in a GetItem event.
Public class | GetParentIDEventArgs | Defines the arguments passed in a GetParentID event.
Public class | GetVersionNumbersEventArgs | Defines the arguments passed in a GetVersionNumbers event.
Public class | InstanceCreatedEventArgs | Represents the arguments of a instance created event.
Public class | ItemAddedEventArgs | Defines the arguments passed in a ItemAdded event.
Public class | ItemChildrenChangedEventArgs | Defines the arguments passed in a ItemChildrenChanged event.
Public class | ItemCopiedEventArgs | Defines the arguments passed in a ItemCopied event.
Public class | ItemCreatedEventArgs | Defines the arguments passed in a ItemCreated event.
Public class | ItemCreatedRemoteEventArgs | ItemCreatedRemoteEventArgs class.
Public class | ItemCreatingEventArgs | Defines the arguments passed in a ItemAdded event.
Public class | ItemDeletedEventArgs | Defines the arguments passed in a ItemDeleted event.
Public class | ItemDeletedRemoteEventArgs | ItemDeletedRemoteEventArgs class.
Public class | ItemDeletingEventArgs | Defines the arguments passed in a ItemDeleting event.
Public class | ItemLockedRemoteEventArgs | ItemLockedRemoteEventArgs class.
Public class | ItemMovedEventArgs | Defines the arguments passed in a ItemMoved event.
Public class | ItemMovedRemoteEventArgs | ItemMovedRemoteEventArgs class.
Public class | ItemRemovedEventArgs | Defines the arguments passed in a ItemRemoved event.
Public class | ItemRenamedEventArgs | Defines the arguments passed in a ItemRenamed event.
Public class | ItemSavedEventArgs | Defines the arguments passed in a ItemSaved event.
Public class | ItemSavedRemoteEventArgs | ItemSavedRemoteEventArgs class.
Public class | ItemSavingEventArgs | Defines the arguments passed in a ItemSaving event.
Public class | ItemSortorderChangedEventArgs | Defines the arguments passed in a ItemSortorderChanged event.
Public class | ItemTemplateChangedRemoteEventArgs | ItemTemplateChangedRemoteEventArgs class.
Public class | ItemUnlockedRemoteEventArgs | ItemUnlockedRemoteEventArgs class.
Public class | PublishEndRemoteEventArgs | PublishEndRemoteEventArgs class.
Public class | RemoteEventArgs<(Of <(<'TEvent>)>)> | RemoteEventArgs<(Of <(<'TEvent>)>)> class.
Public class | RemovedDataRemoteEventArgs | RemovedDataRemoteEventArgs class.
Public class | ResolvePathEventArgs | Defines the arguments passed in a ResolvePath event.
Public class | RoleCreatedRemoteEventArgs | RoleCreatedRemoteEventArgs class.
Public class | RoleDeletedRemoteEventArgs | RoleDeletedRemoteEventArgs class.
Public class | RoleRelationsRemovedRemoteEventArgs | RoleRelationsRemovedRemoteEventArgs class.
Public class | RolesAddedToRolesRemoteEventArgs | RolesAddedToRolesRemoteEventArgs class.
Public class | RolesRemovedFromRolesRemoteEventArgs | RolesRemovedFromRolesRemoteEventArgs class.
Public class | SecurableUpdatedRemoteEventArgs | securable updated remote event args.
Public class | UserCreatedRemoteEventArgs | UserCreatedRemoteEventArgs class.
Public class | UserDeletedRemoteEventArgs | UserDeletedRemoteEventArgs class.
Public class | UsersAddedToRolesRemoteEventArgs | UsersAddedToRolesRemoteEventArgs class.
Public class | UsersRemovedFromRolesRemoteEventArgs | UsersRemovedFromRolesRemoteEventArgs class.
Public class | UserUpdatedRemoteEventArgs | UserUpdatedRemoteEventArgs class.
Public class | VersionAddedEventArgs | Defines the arguments passed in a VersionAdded event.
Public class | VersionRemovedRemoteEventArgs | VersionRemovedRemoteEventArgs class.
Public class | VersionsRemovedEventArgs | Defines the arguments passed in a VersionsRemoved event.

Delegates

 | Delegate | Description
Public delegate | FieldSavedDelegate | Represents the method that will handle the FieldSaved event.
Public delegate | ItemAddedDelegate | Obsolete. Represents the method that will handle the ItemAdded event.
Public delegate | ItemChildrenChangedDelegate | Represents the method that will handle the ItemChildrenChanged event.
Public delegate | ItemCopiedDelegate | Represents the method that will handle the ItemCopied event.
Public delegate | ItemCreatedDelegate | Represents the method that will handle the ItemCreated event.
Public delegate | ItemDeletedDelegate | Represents the method that will handle the ItemDeleted event.
Public delegate | ItemMovedDelegate | Represents the method that will handle the ItemMoved event.
Public delegate | ItemRenamedDelegate | Represents the method that will handle the ItemRenamed event.
Public delegate | ItemSavedDelegate | Represents the method that will handle the ItemSaved event.
Public delegate | ItemSortorderChangedDelegate | Represents the method that will handle the ItemSortorderChanged event.
Public delegate | VersionAddedDelegate | Represents the method that will handle the VersionAdded event.
Public delegate | VersionRemovedDelegate | Represents the method that will handle the VersionRemoved event.

Enumerations

 | Enumeration | Description
Public enumeration | EventDisablerState |


AddedFromTemplateRemoteEventArgs Class

[image]

Sitecore 6.4.1 API
AddedFromTemplateRemoteEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class AddedFromTemplateRemoteEventArgs : EventArgs,
    IPassNativeEventArgs
Visual Basic
Public Class AddedFromTemplateRemoteEventArgs _
    Inherits EventArgs _
    Implements IPassNativeEventArgs
Visual C++
public ref class AddedFromTemplateRemoteEventArgs : public EventArgs,
    IPassNativeEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Data.Events..::..AddedFromTemplateRemoteEventArgs

See Also

AddedFromTemplateRemoteEventArgs Members
Sitecore.Data.Events Namespace


AddedFromTemplateRemoteEventArgs Members

[image] [image]

Sitecore 6.4.1 API
AddedFromTemplateRemoteEventArgs Members
AddedFromTemplateRemoteEventArgs Class Constructors Methods Properties See Also Send Feedback

The AddedFromTemplateRemoteEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | AddedFromTemplateRemoteEventArgs | Initializes a new instance of the AddedFromTemplateRemoteEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Destination | Gets or sets Destination.
Public property | Item | Gets or sets Item.

See Also

AddedFromTemplateRemoteEventArgs Class
Sitecore.Data.Events Namespace


AddedFromTemplateRemoteEventArgs Constructor

[image]

Sitecore 6.4.1 API
AddedFromTemplateRemoteEventArgs Constructor
AddedFromTemplateRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AddedFromTemplateRemoteEventArgs(
    Item item,
    Item destination
)
Visual Basic
Public Sub New ( _
    item As Item, _
    destination As Item _
)
Visual C++
public:
AddedFromTemplateRemoteEventArgs(
    Item^ item,
    Item^ destination
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
destination
Type: Sitecore.Data.Items..::..Item
The destination.

See Also

AddedFromTemplateRemoteEventArgs Class
Sitecore.Data.Events Namespace


AddedFromTemplateRemoteEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
AddedFromTemplateRemoteEventArgs Methods
AddedFromTemplateRemoteEventArgs Class See Also Send Feedback

The AddedFromTemplateRemoteEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddedFromTemplateRemoteEventArgs Class
Sitecore.Data.Events Namespace


AddedFromTemplateRemoteEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
AddedFromTemplateRemoteEventArgs Properties
AddedFromTemplateRemoteEventArgs Class See Also Send Feedback

The AddedFromTemplateRemoteEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Destination | Gets or sets Destination.
Public property | Item | Gets or sets Item.

See Also

AddedFromTemplateRemoteEventArgs Class
Sitecore.Data.Events Namespace


Item Property

[image]

Sitecore 6.4.1 API
AddedFromTemplateRemoteEventArgs..::..Item Property
AddedFromTemplateRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Item { get; protected set; }
Visual Basic
Public Property Item As Item
    Get
    Protected Set
Visual C++
public:
property Item^ Item {
    Item^ get ();
    protected: void set (Item^ value);
}

See Also

AddedFromTemplateRemoteEventArgs Class
Sitecore.Data.Events Namespace


AddedVersionRemoteEventArgs Members

[image] [image]

Sitecore 6.4.1 API
AddedVersionRemoteEventArgs Members
AddedVersionRemoteEventArgs Class Constructors Methods Properties See Also Send Feedback

The AddedVersionRemoteEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | AddedVersionRemoteEventArgs | Initializes a new instance of the AddedVersionRemoteEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | Gets or sets Item.

See Also

AddedVersionRemoteEventArgs Class
Sitecore.Data.Events Namespace


AddedVersionRemoteEventArgs Constructor

[image]

Sitecore 6.4.1 API
AddedVersionRemoteEventArgs Constructor
AddedVersionRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AddedVersionRemoteEventArgs(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
AddedVersionRemoteEventArgs(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

AddedVersionRemoteEventArgs Class
Sitecore.Data.Events Namespace


AddedVersionRemoteEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
AddedVersionRemoteEventArgs Methods
AddedVersionRemoteEventArgs Class See Also Send Feedback

The AddedVersionRemoteEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddedVersionRemoteEventArgs Class
Sitecore.Data.Events Namespace


AddedVersionRemoteEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
AddedVersionRemoteEventArgs Properties
AddedVersionRemoteEventArgs Class See Also Send Feedback

The AddedVersionRemoteEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets or sets Item.

See Also

AddedVersionRemoteEventArgs Class
Sitecore.Data.Events Namespace


ConstructedEventArgs Class

[image]

Sitecore 6.4.1 API
ConstructedEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ConstructedEventArgs : EventArgs
Visual Basic
Public Class ConstructedEventArgs _
    Inherits EventArgs
Visual C++
public ref class ConstructedEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Data.Events..::..ConstructedEventArgs

See Also

ConstructedEventArgs Members
Sitecore.Data.Events Namespace


ConstructedEventArgs Members

[image] [image]

Sitecore 6.4.1 API
ConstructedEventArgs Members
ConstructedEventArgs Class Constructors Methods Properties See Also Send Feedback

The ConstructedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ConstructedEventArgs | Constructs an instance of DatabaseLoadedEventArgs

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Database | Gets the database that was loaded.

See Also

ConstructedEventArgs Class
Sitecore.Data.Events Namespace


ConstructedEventArgs Constructor

[image]

Sitecore 6.4.1 API
ConstructedEventArgs Constructor
ConstructedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ConstructedEventArgs(
    Database database
)
Visual Basic
Public Sub New ( _
    database As Database _
)
Visual C++
public:
ConstructedEventArgs(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

See Also

ConstructedEventArgs Class
Sitecore.Data.Events Namespace


ConstructedEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
ConstructedEventArgs Methods
ConstructedEventArgs Class See Also Send Feedback

The ConstructedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConstructedEventArgs Class
Sitecore.Data.Events Namespace


ConstructedEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
ConstructedEventArgs Properties
ConstructedEventArgs Class See Also Send Feedback

The ConstructedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Database | Gets the database that was loaded.

See Also

ConstructedEventArgs Class
Sitecore.Data.Events Namespace


Database Property

[image]

Sitecore 6.4.1 API
ConstructedEventArgs..::..Database Property
ConstructedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database Database { get; }
Visual Basic
Public ReadOnly Property Database As Database
    Get
Visual C++
public:
property Database^ Database {
    Database^ get ();
}

Field Value

The database.

See Also

ConstructedEventArgs Class
Sitecore.Data.Events Namespace


CopiedItemRemoteEventArgs Class

[image]

Sitecore 6.4.1 API
CopiedItemRemoteEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CopiedItemRemoteEventArgs : EventArgs,
    IPassNativeEventArgs
Visual Basic
Public Class CopiedItemRemoteEventArgs _
    Inherits EventArgs _
    Implements IPassNativeEventArgs
Visual C++
public ref class CopiedItemRemoteEventArgs : public EventArgs,
    IPassNativeEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Data.Events..::..CopiedItemRemoteEventArgs

See Also

CopiedItemRemoteEventArgs Members
Sitecore.Data.Events Namespace


CopiedItemRemoteEventArgs Members

[image] [image]

Sitecore 6.4.1 API
CopiedItemRemoteEventArgs Members
CopiedItemRemoteEventArgs Class Constructors Methods Properties See Also Send Feedback

The CopiedItemRemoteEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | CopiedItemRemoteEventArgs | Initializes a new instance of the CopiedItemRemoteEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Deep | Gets or sets a value indicating whether Deep.
Public property | Destination | Gets or sets Destination.
Public property | Item | Gets or sets Item.
Public property | Source | Gets or sets Source.

See Also

CopiedItemRemoteEventArgs Class
Sitecore.Data.Events Namespace


CopiedItemRemoteEventArgs Constructor

[image]

Sitecore 6.4.1 API
CopiedItemRemoteEventArgs Constructor
CopiedItemRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CopiedItemRemoteEventArgs(
    Item item,
    Item source,
    Item destination,
    bool deep
)
Visual Basic
Public Sub New ( _
    item As Item, _
    source As Item, _
    destination As Item, _
    deep As Boolean _
)
Visual C++
public:
CopiedItemRemoteEventArgs(
    Item^ item,
    Item^ source,
    Item^ destination,
    bool deep
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
source
Type: Sitecore.Data.Items..::..Item
The source.
destination
Type: Sitecore.Data.Items..::..Item
The destination.
deep
Type: System..::..Boolean
if set to true [deep].

See Also

CopiedItemRemoteEventArgs Class
Sitecore.Data.Events Namespace


CopiedItemRemoteEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
CopiedItemRemoteEventArgs Methods
CopiedItemRemoteEventArgs Class See Also Send Feedback

The CopiedItemRemoteEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CopiedItemRemoteEventArgs Class
Sitecore.Data.Events Namespace


CopiedItemRemoteEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
CopiedItemRemoteEventArgs Properties
CopiedItemRemoteEventArgs Class See Also Send Feedback

The CopiedItemRemoteEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Deep | Gets or sets a value indicating whether Deep.
Public property | Destination | Gets or sets Destination.
Public property | Item | Gets or sets Item.
Public property | Source | Gets or sets Source.

See Also

CopiedItemRemoteEventArgs Class
Sitecore.Data.Events Namespace


Deep Property

[image]

Sitecore 6.4.1 API
CopiedItemRemoteEventArgs..::..Deep Property
CopiedItemRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Deep { get; protected set; }
Visual Basic
Public Property Deep As Boolean
    Get
    Protected Set
Visual C++
public:
property bool Deep {
    bool get ();
    protected: void set (bool value);
}

See Also

CopiedItemRemoteEventArgs Class
Sitecore.Data.Events Namespace


Item Property

[image]

Sitecore 6.4.1 API
CopiedItemRemoteEventArgs..::..Item Property
CopiedItemRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Item { get; protected set; }
Visual Basic
Public Property Item As Item
    Get
    Protected Set
Visual C++
public:
property Item^ Item {
    Item^ get ();
    protected: void set (Item^ value);
}

See Also

CopiedItemRemoteEventArgs Class
Sitecore.Data.Events Namespace


Source Property

[image]

Sitecore 6.4.1 API
CopiedItemRemoteEventArgs..::..Source Property
CopiedItemRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Source { get; protected set; }
Visual Basic
Public Property Source As Item
    Get
    Protected Set
Visual C++
public:
property Item^ Source {
    Item^ get ();
    protected: void set (Item^ value);
}

See Also

CopiedItemRemoteEventArgs Class
Sitecore.Data.Events Namespace


CopyProcessedSingleItemEventArgs Class

[image]

Sitecore 6.4.1 API
CopyProcessedSingleItemEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CopyProcessedSingleItemEventArgs : EventArgs
Visual Basic
Public Class CopyProcessedSingleItemEventArgs _
    Inherits EventArgs
Visual C++
public ref class CopyProcessedSingleItemEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Data.Events..::..CopyProcessedSingleItemEventArgs

See Also

CopyProcessedSingleItemEventArgs Members
Sitecore.Data.Events Namespace


CopyProcessedSingleItemEventArgs Members

[image] [image]

Sitecore 6.4.1 API
CopyProcessedSingleItemEventArgs Members
CopyProcessedSingleItemEventArgs Class Constructors Methods Properties See Also Send Feedback

The CopyProcessedSingleItemEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | CopyProcessedSingleItemEventArgs | Creates a new CopyProcessedSingleItemEventArgs instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CopyID | Gets the copy ID.
Public property | Database | Gets the database.
Public property | DestinationID | Gets the destination ID.
Public property | SourceID | Gets the source ID.

See Also

CopyProcessedSingleItemEventArgs Class
Sitecore.Data.Events Namespace


CopyProcessedSingleItemEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
CopyProcessedSingleItemEventArgs Methods
CopyProcessedSingleItemEventArgs Class See Also Send Feedback

The CopyProcessedSingleItemEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CopyProcessedSingleItemEventArgs Class
Sitecore.Data.Events Namespace


CopyProcessedSingleItemEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
CopyProcessedSingleItemEventArgs Properties
CopyProcessedSingleItemEventArgs Class See Also Send Feedback

The CopyProcessedSingleItemEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | CopyID | Gets the copy ID.
Public property | Database | Gets the database.
Public property | DestinationID | Gets the destination ID.
Public property | SourceID | Gets the source ID.

See Also

CopyProcessedSingleItemEventArgs Class
Sitecore.Data.Events Namespace


CopyID Property

[image]

Sitecore 6.4.1 API
CopyProcessedSingleItemEventArgs..::..CopyID Property
CopyProcessedSingleItemEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID CopyID { get; }
Visual Basic
Public ReadOnly Property CopyID As ID
    Get
Visual C++
public:
property ID^ CopyID {
    ID^ get ();
}

Field Value

The copy ID.

See Also

CopyProcessedSingleItemEventArgs Class
Sitecore.Data.Events Namespace


Database Property

[image]

Sitecore 6.4.1 API
CopyProcessedSingleItemEventArgs..::..Database Property
CopyProcessedSingleItemEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database Database { get; }
Visual Basic
Public ReadOnly Property Database As Database
    Get
Visual C++
public:
property Database^ Database {
    Database^ get ();
}

Field Value

The database.

See Also

CopyProcessedSingleItemEventArgs Class
Sitecore.Data.Events Namespace


DestinationID Property

[image]

Sitecore 6.4.1 API
CopyProcessedSingleItemEventArgs..::..DestinationID Property
CopyProcessedSingleItemEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID DestinationID { get; }
Visual Basic
Public ReadOnly Property DestinationID As ID
    Get
Visual C++
public:
property ID^ DestinationID {
    ID^ get ();
}

Field Value

The destination ID.

See Also

CopyProcessedSingleItemEventArgs Class
Sitecore.Data.Events Namespace


SourceID Property

[image]

Sitecore 6.4.1 API
CopyProcessedSingleItemEventArgs..::..SourceID Property
CopyProcessedSingleItemEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID SourceID { get; }
Visual Basic
Public ReadOnly Property SourceID As ID
    Get
Visual C++
public:
property ID^ SourceID {
    ID^ get ();
}

Field Value

The source ID.

See Also

CopyProcessedSingleItemEventArgs Class
Sitecore.Data.Events Namespace


DeleteProcessedSingleItemEventArgs Class

[image]

Sitecore 6.4.1 API
DeleteProcessedSingleItemEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DeleteProcessedSingleItemEventArgs : EventArgs
Visual Basic
Public Class DeleteProcessedSingleItemEventArgs _
    Inherits EventArgs
Visual C++
public ref class DeleteProcessedSingleItemEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Data.Events..::..DeleteProcessedSingleItemEventArgs

See Also

DeleteProcessedSingleItemEventArgs Members
Sitecore.Data.Events Namespace


DeleteProcessedSingleItemEventArgs Members

[image] [image]

Sitecore 6.4.1 API
DeleteProcessedSingleItemEventArgs Members
DeleteProcessedSingleItemEventArgs Class Constructors Methods Properties See Also Send Feedback

The DeleteProcessedSingleItemEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | DeleteProcessedSingleItemEventArgs | Initializes a new instance of the DeleteProcessedSingleItemEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Database | Gets the database.
Public property | ItemID | Gets the item ID. Item itself is not available already.

See Also

DeleteProcessedSingleItemEventArgs Class
Sitecore.Data.Events Namespace


DeleteProcessedSingleItemEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
DeleteProcessedSingleItemEventArgs Methods
DeleteProcessedSingleItemEventArgs Class See Also Send Feedback

The DeleteProcessedSingleItemEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DeleteProcessedSingleItemEventArgs Class
Sitecore.Data.Events Namespace


DeleteProcessedSingleItemEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
DeleteProcessedSingleItemEventArgs Properties
DeleteProcessedSingleItemEventArgs Class See Also Send Feedback

The DeleteProcessedSingleItemEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Database | Gets the database.
Public property | ItemID | Gets the item ID. Item itself is not available already.

See Also

DeleteProcessedSingleItemEventArgs Class
Sitecore.Data.Events Namespace


Database Property

[image]

Sitecore 6.4.1 API
DeleteProcessedSingleItemEventArgs..::..Database Property
DeleteProcessedSingleItemEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database Database { get; }
Visual Basic
Public ReadOnly Property Database As Database
    Get
Visual C++
public:
property Database^ Database {
    Database^ get ();
}

Field Value

The database.

See Also

DeleteProcessedSingleItemEventArgs Class
Sitecore.Data.Events Namespace


EventDisabler Class

[image]

Sitecore 6.4.1 API
EventDisabler Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public sealed class EventDisabler : Switcher<EventDisablerState, EventDisabler>
Visual Basic
Public NotInheritable Class EventDisabler _
    Inherits Switcher(Of EventDisablerState, EventDisabler)
Visual C++
public ref class EventDisabler sealed : public Switcher<EventDisablerState, EventDisabler^>

Inheritance Hierarchy

System..::..Object
Sitecore.Common..::..Switcher <(Of <(<' EventDisablerState, EventDisabler>)>)>
Sitecore.Data.Events..::..EventDisabler

See Also

EventDisabler Members
Sitecore.Data.Events Namespace


EventDisabler Members

[image] [image]

Sitecore 6.4.1 API
EventDisabler Members
EventDisabler Class Constructors Methods Properties Events See Also Send Feedback

The EventDisabler type exposes the following members.

Constructors

 | Name | Description
Public method | EventDisabler | Initializes a new instance of the EventDisabler class.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Switcher<(Of <(<'TValue, TSwitchType>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsActive | Gets a value indicating whether this instance is active.

Events

 | Name | Description
Protected event | Disposed | Occurs when the object has been disposed. (Inherited from Switcher<(Of <(<'TValue, TSwitchType>)>)>.)

See Also

EventDisabler Class
Sitecore.Data.Events Namespace


EventDisabler Constructor

[image]

Sitecore 6.4.1 API
EventDisabler Constructor
EventDisabler Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public EventDisabler()
Visual Basic
Public Sub New
Visual C++
public:
EventDisabler()

See Also

EventDisabler Class
Sitecore.Data.Events Namespace


EventDisabler Methods

[image] [image]

Sitecore 6.4.1 API
EventDisabler Methods
EventDisabler Class See Also Send Feedback

The EventDisabler type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Switcher<(Of <(<'TValue, TSwitchType>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EventDisabler Class
Sitecore.Data.Events Namespace


EventDisabler Properties

[image] [image]

Sitecore 6.4.1 API
EventDisabler Properties
EventDisabler Class See Also Send Feedback

The EventDisabler type exposes the following members.

Properties

Name | Description
IsActive | Gets a value indicating whether this instance is active.

See Also

EventDisabler Class
Sitecore.Data.Events Namespace


IsActive Property

[image]

Sitecore 6.4.1 API
EventDisabler..::..IsActive Property
EventDisabler Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsActive { get; }
Visual Basic
Public Shared ReadOnly Property IsActive As Boolean
    Get
Visual C++
public:
static property bool IsActive {
    bool get ();
}

Field Value

true if this instance is active; otherwise, false.

See Also

EventDisabler Class
Sitecore.Data.Events Namespace


EventDisabler Events

[image] [image]

Sitecore 6.4.1 API
EventDisabler Events
EventDisabler Class See Also Send Feedback

The EventDisabler type exposes the following members.

Events

 | Name | Description
Protected event | Disposed | Occurs when the object has been disposed. (Inherited from Switcher<(Of <(<'TValue, TSwitchType>)>)>.)

See Also

EventDisabler Class
Sitecore.Data.Events Namespace


EventDisablerState Enumeration

[image]

Sitecore 6.4.1 API
EventDisablerState Enumeration
See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum EventDisablerState
Visual Basic
Public Enumeration EventDisablerState
Visual C++
public enum class EventDisablerState

Members

Member name | Value | Description
Disabled | 0 |
Enabled | 1 |

See Also

Sitecore.Data.Events Namespace


ExecutedEventArgs(TCommand) Class

[image]

Sitecore 6.4.1 API
ExecutedEventArgs<(Of <(<'TCommand>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ExecutedEventArgs<TCommand> : EventArgs
Visual Basic
Public Class ExecutedEventArgs(Of TCommand) _
    Inherits EventArgs
Visual C++
generic<typename TCommand>
public ref class ExecutedEventArgs : public EventArgs

Type Parameters

TCommand

[Missing <typeparam name="TCommand"/> documentation for "T:Sitecore.Data.Events.ExecutedEventArgs`1"]

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Data.Events..::..ExecutedEventArgs<(Of <(<'TCommand>)>)>

See Also

ExecutedEventArgs<(Of <(<'TCommand>)>)> Members
Sitecore.Data.Events Namespace


ExecutedEventArgs(TCommand) Members

[image] [image]

Sitecore 6.4.1 API
ExecutedEventArgs<(Of <(<'TCommand>)>)> Members
ExecutedEventArgs<(Of <(<'TCommand>)>)> Class Constructors Methods Properties See Also Send Feedback

The ExecutedEventArgs<(Of <(<'TCommand>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | ExecutedEventArgs<(Of <(<'TCommand>)>)> | Creates a new ExecutingEventArgs instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Command | Gets the item.

See Also

ExecutedEventArgs<(Of <(<'TCommand>)>)> Class
Sitecore.Data.Events Namespace


ExecutedEventArgs(TCommand) Constructor

[image]

Sitecore 6.4.1 API
ExecutedEventArgs<(Of <(<'TCommand>)>)> Constructor
ExecutedEventArgs<(Of <(<'TCommand>)>)> Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ExecutedEventArgs(
    TCommand command
)
Visual Basic
Public Sub New ( _
    command As TCommand _
)
Visual C++
public:
ExecutedEventArgs(
    TCommand command
)

Parameters

command
Type: TCommand
The command.

See Also

ExecutedEventArgs<(Of <(<'TCommand>)>)> Class
Sitecore.Data.Events Namespace


ExecutedEventArgs(TCommand) Methods

[image] [image]

Sitecore 6.4.1 API
ExecutedEventArgs<(Of <(<'TCommand>)>)> Methods
ExecutedEventArgs<(Of <(<'TCommand>)>)> Class See Also Send Feedback

The ExecutedEventArgs<(Of <(<'TCommand>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExecutedEventArgs<(Of <(<'TCommand>)>)> Class
Sitecore.Data.Events Namespace


ExecutedEventArgs(TCommand) Properties

[image] [image]

Sitecore 6.4.1 API
ExecutedEventArgs<(Of <(<'TCommand>)>)> Properties
ExecutedEventArgs<(Of <(<'TCommand>)>)> Class See Also Send Feedback

The ExecutedEventArgs<(Of <(<'TCommand>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Command | Gets the item.

See Also

ExecutedEventArgs<(Of <(<'TCommand>)>)> Class
Sitecore.Data.Events Namespace


Command Property

[image]

Sitecore 6.4.1 API
ExecutedEventArgs<(Of <(<'TCommand>)>)>..::..Command Property
ExecutedEventArgs<(Of <(<'TCommand>)>)> Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TCommand Command { get; }
Visual Basic
Public ReadOnly Property Command As TCommand
    Get
Visual C++
public:
property TCommand Command {
    TCommand get ();
}

Field Value

The command.

See Also

ExecutedEventArgs<(Of <(<'TCommand>)>)> Class
Sitecore.Data.Events Namespace


ExecutingEventArgs(TCommand) Class

[image]

Sitecore 6.4.1 API
ExecutingEventArgs<(Of <(<'TCommand>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ExecutingEventArgs<TCommand> : CancelEventArgs
Visual Basic
Public Class ExecutingEventArgs(Of TCommand) _
    Inherits CancelEventArgs
Visual C++
generic<typename TCommand>
public ref class ExecutingEventArgs : public CancelEventArgs

Type Parameters

TCommand

[Missing <typeparam name="TCommand"/> documentation for "T:Sitecore.Data.Events.ExecutingEventArgs`1"]

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..CancelEventArgs
Sitecore.Data.Events..::..ExecutingEventArgs<(Of <(<'TCommand>)>)>

See Also

ExecutingEventArgs<(Of <(<'TCommand>)>)> Members
Sitecore.Data.Events Namespace


ExecutingEventArgs(TCommand) Members

[image] [image]

Sitecore 6.4.1 API
ExecutingEventArgs<(Of <(<'TCommand>)>)> Members
ExecutingEventArgs<(Of <(<'TCommand>)>)> Class Constructors Methods Properties See Also Send Feedback

The ExecutingEventArgs<(Of <(<'TCommand>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | ExecutingEventArgs<(Of <(<'TCommand>)>)> | Creates a new instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | Command | Gets the item.

See Also

ExecutingEventArgs<(Of <(<'TCommand>)>)> Class
Sitecore.Data.Events Namespace


ExecutingEventArgs(TCommand) Constructor

[image]

Sitecore 6.4.1 API
ExecutingEventArgs<(Of <(<'TCommand>)>)> Constructor
ExecutingEventArgs<(Of <(<'TCommand>)>)> Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ExecutingEventArgs(
    TCommand command
)
Visual Basic
Public Sub New ( _
    command As TCommand _
)
Visual C++
public:
ExecutingEventArgs(
    TCommand command
)

Parameters

command
Type: TCommand
The command.

See Also

ExecutingEventArgs<(Of <(<'TCommand>)>)> Class
Sitecore.Data.Events Namespace


ExecutingEventArgs(TCommand) Properties

[image] [image]

Sitecore 6.4.1 API
ExecutingEventArgs<(Of <(<'TCommand>)>)> Properties
ExecutingEventArgs<(Of <(<'TCommand>)>)> Class See Also Send Feedback

The ExecutingEventArgs<(Of <(<'TCommand>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | Command | Gets the item.

See Also

ExecutingEventArgs<(Of <(<'TCommand>)>)> Class
Sitecore.Data.Events Namespace


Command Property

[image]

Sitecore 6.4.1 API
ExecutingEventArgs<(Of <(<'TCommand>)>)>..::..Command Property
ExecutingEventArgs<(Of <(<'TCommand>)>)> Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TCommand Command { get; }
Visual Basic
Public ReadOnly Property Command As TCommand
    Get
Visual C++
public:
property TCommand Command {
    TCommand get ();
}

Field Value

The command.

See Also

ExecutingEventArgs<(Of <(<'TCommand>)>)> Class
Sitecore.Data.Events Namespace


FieldSavedDelegate Delegate

[image]

Sitecore 6.4.1 API
FieldSavedDelegate Delegate
See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public delegate void FieldSavedDelegate(
    Object sender,
    FieldSavedEventArgs args
)
Visual Basic
Public Delegate Sub FieldSavedDelegate ( _
    sender As Object, _
    args As FieldSavedEventArgs _
)
Visual C++
public delegate void FieldSavedDelegate(
    Object^ sender,
    FieldSavedEventArgs^ args
)

Parameters

sender
Type: System..::..Object
args
Type: Sitecore.Data.Events..::..FieldSavedEventArgs

Remarks

When you create a FieldSavedDelegate delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

See Also

Sitecore.Data.Events Namespace


FieldSavedEventArgs Class

[image]

Sitecore 6.4.1 API
FieldSavedEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FieldSavedEventArgs
Visual Basic
Public Class FieldSavedEventArgs
Visual C++
public ref class FieldSavedEventArgs

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Events..::..FieldSavedEventArgs

See Also

FieldSavedEventArgs Members
Sitecore.Data.Events Namespace


FieldSavedEventArgs Members

[image] [image]

Sitecore 6.4.1 API
FieldSavedEventArgs Members
FieldSavedEventArgs Class Constructors Methods Properties See Also Send Feedback

The FieldSavedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | FieldSavedEventArgs | Creates a new FieldSavedEventArgs instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Field | Gets the field.

See Also

FieldSavedEventArgs Class
Sitecore.Data.Events Namespace


FieldSavedEventArgs Constructor

[image]

Sitecore 6.4.1 API
FieldSavedEventArgs Constructor
FieldSavedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FieldSavedEventArgs(
    Field field
)
Visual Basic
Public Sub New ( _
    field As Field _
)
Visual C++
public:
FieldSavedEventArgs(
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
Field.

See Also

FieldSavedEventArgs Class
Sitecore.Data.Events Namespace


FieldSavedEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
FieldSavedEventArgs Methods
FieldSavedEventArgs Class See Also Send Feedback

The FieldSavedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldSavedEventArgs Class
Sitecore.Data.Events Namespace


FieldSavedEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
FieldSavedEventArgs Properties
FieldSavedEventArgs Class See Also Send Feedback

The FieldSavedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Field | Gets the field.

See Also

FieldSavedEventArgs Class
Sitecore.Data.Events Namespace


Field Property

[image]

Sitecore 6.4.1 API
FieldSavedEventArgs..::..Field Property
FieldSavedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Field Field { get; }
Visual Basic
Public ReadOnly Property Field As Field
    Get
Visual C++
public:
property Field^ Field {
    Field^ get ();
}

Field Value

The field.

See Also

FieldSavedEventArgs Class
Sitecore.Data.Events Namespace


GetChildrenEventArgs Class

[image]

Sitecore 6.4.1 API
GetChildrenEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetChildrenEventArgs : CancelEventArgs
Visual Basic
Public Class GetChildrenEventArgs _
    Inherits CancelEventArgs
Visual C++
public ref class GetChildrenEventArgs : public CancelEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..CancelEventArgs
Sitecore.Data.Events..::..GetChildrenEventArgs

See Also

GetChildrenEventArgs Members
Sitecore.Data.Events Namespace


GetChildrenEventArgs Members

[image] [image]

Sitecore 6.4.1 API
GetChildrenEventArgs Members
GetChildrenEventArgs Class Constructors Methods Properties See Also Send Feedback

The GetChildrenEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GetChildrenEventArgs | Creates a new GetChildrenEventArgs instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | CustomResult | Gets or sets the custom result.
Public property | ItemID | Gets the item ID.

See Also

GetChildrenEventArgs Class
Sitecore.Data.Events Namespace


GetChildrenEventArgs Constructor

[image]

Sitecore 6.4.1 API
GetChildrenEventArgs Constructor
GetChildrenEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetChildrenEventArgs(
    ID itemID
)
Visual Basic
Public Sub New ( _
    itemID As ID _
)
Visual C++
public:
GetChildrenEventArgs(
    ID^ itemID
)

Parameters

itemID
Type: Sitecore.Data..::..ID
Item ID.

See Also

GetChildrenEventArgs Class
Sitecore.Data.Events Namespace


GetChildrenEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
GetChildrenEventArgs Methods
GetChildrenEventArgs Class See Also Send Feedback

The GetChildrenEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetChildrenEventArgs Class
Sitecore.Data.Events Namespace


GetChildrenEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
GetChildrenEventArgs Properties
GetChildrenEventArgs Class See Also Send Feedback

The GetChildrenEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | CustomResult | Gets or sets the custom result.
Public property | ItemID | Gets the item ID.

See Also

GetChildrenEventArgs Class
Sitecore.Data.Events Namespace


CustomResult Property

[image]

Sitecore 6.4.1 API
GetChildrenEventArgs..::..CustomResult Property
GetChildrenEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID[] CustomResult { get; set; }
Visual Basic
Public Property CustomResult As ID()
    Get
    Set
Visual C++
public:
property array<ID^>^ CustomResult {
    array<ID^>^ get ();
    void set (array<ID^>^ value);
}

Field Value

The custom result.

See Also

GetChildrenEventArgs Class
Sitecore.Data.Events Namespace


ItemID Property

[image]

Sitecore 6.4.1 API
GetChildrenEventArgs..::..ItemID Property
GetChildrenEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ItemID { get; }
Visual Basic
Public ReadOnly Property ItemID As ID
    Get
Visual C++
public:
property ID^ ItemID {
    ID^ get ();
}

Field Value

The item ID.

See Also

GetChildrenEventArgs Class
Sitecore.Data.Events Namespace


GetItemEventArgs Class

[image]

Sitecore 6.4.1 API
GetItemEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetItemEventArgs : CancelEventArgs
Visual Basic
Public Class GetItemEventArgs _
    Inherits CancelEventArgs
Visual C++
public ref class GetItemEventArgs : public CancelEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..CancelEventArgs
Sitecore.Data.Events..::..GetItemEventArgs

See Also

GetItemEventArgs Members
Sitecore.Data.Events Namespace


GetItemEventArgs Members

[image] [image]

Sitecore 6.4.1 API
GetItemEventArgs Members
GetItemEventArgs Class Constructors Methods Properties See Also Send Feedback

The GetItemEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GetItemEventArgs | Creates a new GetItemEventArgs instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | CustomResult | Gets or sets the custom result.
Public property | ItemId | Gets the item id.
Public property | Language | Gets the language.
Public property | Version | Gets the version.

See Also

GetItemEventArgs Class
Sitecore.Data.Events Namespace


GetItemEventArgs Constructor

[image]

Sitecore 6.4.1 API
GetItemEventArgs Constructor
GetItemEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetItemEventArgs(
    ID itemID,
    Language language,
    Version version
)
Visual Basic
Public Sub New ( _
    itemID As ID, _
    language As Language, _
    version As Version _
)
Visual C++
public:
GetItemEventArgs(
    ID^ itemID,
    Language^ language,
    Version^ version
)

Parameters

itemID
Type: Sitecore.Data..::..ID
Item ID.
language
Type: Sitecore.Globalization..::..Language
Language.
version
Type: Sitecore.Data..::..Version
Version.

See Also

GetItemEventArgs Class
Sitecore.Data.Events Namespace


GetItemEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
GetItemEventArgs Methods
GetItemEventArgs Class See Also Send Feedback

The GetItemEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetItemEventArgs Class
Sitecore.Data.Events Namespace


GetItemEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
GetItemEventArgs Properties
GetItemEventArgs Class See Also Send Feedback

The GetItemEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | CustomResult | Gets or sets the custom result.
Public property | ItemId | Gets the item id.
Public property | Language | Gets the language.
Public property | Version | Gets the version.

See Also

GetItemEventArgs Class
Sitecore.Data.Events Namespace


CustomResult Property

[image]

Sitecore 6.4.1 API
GetItemEventArgs..::..CustomResult Property
GetItemEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item CustomResult { get; set; }
Visual Basic
Public Property CustomResult As Item
    Get
    Set
Visual C++
public:
property Item^ CustomResult {
    Item^ get ();
    void set (Item^ value);
}

Field Value

The custom result.

See Also

GetItemEventArgs Class
Sitecore.Data.Events Namespace


ItemId Property

[image]

Sitecore 6.4.1 API
GetItemEventArgs..::..ItemId Property
GetItemEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ItemId { get; }
Visual Basic
Public ReadOnly Property ItemId As ID
    Get
Visual C++
public:
property ID^ ItemId {
    ID^ get ();
}

Field Value

The item id.

See Also

GetItemEventArgs Class
Sitecore.Data.Events Namespace


Language Property

[image]

Sitecore 6.4.1 API
GetItemEventArgs..::..Language Property
GetItemEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Language Language { get; }
Visual Basic
Public ReadOnly Property Language As Language
    Get
Visual C++
public:
property Language^ Language {
    Language^ get ();
}

Field Value

The language.

See Also

GetItemEventArgs Class
Sitecore.Data.Events Namespace


Version Property

[image]

Sitecore 6.4.1 API
GetItemEventArgs..::..Version Property
GetItemEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Version Version { get; }
Visual Basic
Public ReadOnly Property Version As Version
    Get
Visual C++
public:
property Version^ Version {
    Version^ get ();
}

Field Value

The version.

See Also

GetItemEventArgs Class
Sitecore.Data.Events Namespace


GetParentIDEventArgs Class

[image]

Sitecore 6.4.1 API
GetParentIDEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetParentIDEventArgs : CancelEventArgs
Visual Basic
Public Class GetParentIDEventArgs _
    Inherits CancelEventArgs
Visual C++
public ref class GetParentIDEventArgs : public CancelEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..CancelEventArgs
Sitecore.Data.Events..::..GetParentIDEventArgs

See Also

GetParentIDEventArgs Members
Sitecore.Data.Events Namespace


GetParentIDEventArgs Members

[image] [image]

Sitecore 6.4.1 API
GetParentIDEventArgs Members
GetParentIDEventArgs Class Constructors Methods Properties See Also Send Feedback

The GetParentIDEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GetParentIDEventArgs | Creates a new GetParentIDEventArgs instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | CustomResult | Gets or sets the custom result.
Public property | ItemID | Gets the item ID.

See Also

GetParentIDEventArgs Class
Sitecore.Data.Events Namespace


GetParentIDEventArgs Constructor

[image]

Sitecore 6.4.1 API
GetParentIDEventArgs Constructor
GetParentIDEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetParentIDEventArgs(
    ID itemID
)
Visual Basic
Public Sub New ( _
    itemID As ID _
)
Visual C++
public:
GetParentIDEventArgs(
    ID^ itemID
)

Parameters

itemID
Type: Sitecore.Data..::..ID
Item ID.

See Also

GetParentIDEventArgs Class
Sitecore.Data.Events Namespace


GetParentIDEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
GetParentIDEventArgs Methods
GetParentIDEventArgs Class See Also Send Feedback

The GetParentIDEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetParentIDEventArgs Class
Sitecore.Data.Events Namespace


GetParentIDEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
GetParentIDEventArgs Properties
GetParentIDEventArgs Class See Also Send Feedback

The GetParentIDEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | CustomResult | Gets or sets the custom result.
Public property | ItemID | Gets the item ID.

See Also

GetParentIDEventArgs Class
Sitecore.Data.Events Namespace


CustomResult Property

[image]

Sitecore 6.4.1 API
GetParentIDEventArgs..::..CustomResult Property
GetParentIDEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID CustomResult { get; set; }
Visual Basic
Public Property CustomResult As ID
    Get
    Set
Visual C++
public:
property ID^ CustomResult {
    ID^ get ();
    void set (ID^ value);
}

Field Value

The custom result.

See Also

GetParentIDEventArgs Class
Sitecore.Data.Events Namespace


ItemID Property

[image]

Sitecore 6.4.1 API
GetParentIDEventArgs..::..ItemID Property
GetParentIDEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ItemID { get; }
Visual Basic
Public ReadOnly Property ItemID As ID
    Get
Visual C++
public:
property ID^ ItemID {
    ID^ get ();
}

Field Value

The item ID.

See Also

GetParentIDEventArgs Class
Sitecore.Data.Events Namespace


GetVersionNumbersEventArgs Class

[image]

Sitecore 6.4.1 API
GetVersionNumbersEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetVersionNumbersEventArgs : CancelEventArgs
Visual Basic
Public Class GetVersionNumbersEventArgs _
    Inherits CancelEventArgs
Visual C++
public ref class GetVersionNumbersEventArgs : public CancelEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..CancelEventArgs
Sitecore.Data.Events..::..GetVersionNumbersEventArgs

See Also

GetVersionNumbersEventArgs Members
Sitecore.Data.Events Namespace


GetVersionNumbersEventArgs Members

[image] [image]

Sitecore 6.4.1 API
GetVersionNumbersEventArgs Members
GetVersionNumbersEventArgs Class Constructors Methods Properties See Also Send Feedback

The GetVersionNumbersEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GetVersionNumbersEventArgs | Creates a new GetVersionNumbersEventArgs instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | CustomResult | Gets or sets the custom result.
Public property | ItemID | Gets the item ID.
Public property | Language | Gets the language.

See Also

GetVersionNumbersEventArgs Class
Sitecore.Data.Events Namespace


GetVersionNumbersEventArgs Constructor

[image]

Sitecore 6.4.1 API
GetVersionNumbersEventArgs Constructor
GetVersionNumbersEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetVersionNumbersEventArgs(
    ID itemID,
    Language language
)
Visual Basic
Public Sub New ( _
    itemID As ID, _
    language As Language _
)
Visual C++
public:
GetVersionNumbersEventArgs(
    ID^ itemID,
    Language^ language
)

Parameters

itemID
Type: Sitecore.Data..::..ID
Item ID.
language
Type: Sitecore.Globalization..::..Language
Language.

See Also

GetVersionNumbersEventArgs Class
Sitecore.Data.Events Namespace


GetVersionNumbersEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
GetVersionNumbersEventArgs Methods
GetVersionNumbersEventArgs Class See Also Send Feedback

The GetVersionNumbersEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetVersionNumbersEventArgs Class
Sitecore.Data.Events Namespace


GetVersionNumbersEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
GetVersionNumbersEventArgs Properties
GetVersionNumbersEventArgs Class See Also Send Feedback

The GetVersionNumbersEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | CustomResult | Gets or sets the custom result.
Public property | ItemID | Gets the item ID.
Public property | Language | Gets the language.

See Also

GetVersionNumbersEventArgs Class
Sitecore.Data.Events Namespace


CustomResult Property

[image]

Sitecore 6.4.1 API
GetVersionNumbersEventArgs..::..CustomResult Property
GetVersionNumbersEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Version[] CustomResult { get; set; }
Visual Basic
Public Property CustomResult As Version()
    Get
    Set
Visual C++
public:
property array<Version^>^ CustomResult {
    array<Version^>^ get ();
    void set (array<Version^>^ value);
}

Field Value

The custom result.

See Also

GetVersionNumbersEventArgs Class
Sitecore.Data.Events Namespace


Language Property

[image]

Sitecore 6.4.1 API
GetVersionNumbersEventArgs..::..Language Property
GetVersionNumbersEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Language Language { get; }
Visual Basic
Public ReadOnly Property Language As Language
    Get
Visual C++
public:
property Language^ Language {
    Language^ get ();
}

Field Value

The language.

See Also

GetVersionNumbersEventArgs Class
Sitecore.Data.Events Namespace


InstanceCreatedEventArgs Class

[image]

Sitecore 6.4.1 API
InstanceCreatedEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class InstanceCreatedEventArgs : EventArgs
Visual Basic
Public Class InstanceCreatedEventArgs _
    Inherits EventArgs
Visual C++
public ref class InstanceCreatedEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Data.Events..::..InstanceCreatedEventArgs

See Also

InstanceCreatedEventArgs Members
Sitecore.Data.Events Namespace


InstanceCreatedEventArgs Members

[image] [image]

Sitecore 6.4.1 API
InstanceCreatedEventArgs Members
InstanceCreatedEventArgs Class Constructors Methods Properties See Also Send Feedback

The InstanceCreatedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | InstanceCreatedEventArgs | Constructs an instance of DatabaseLoadedEventArgs

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Database | Gets the database that was loaded.

See Also

InstanceCreatedEventArgs Class
Sitecore.Data.Events Namespace


InstanceCreatedEventArgs Constructor

[image]

Sitecore 6.4.1 API
InstanceCreatedEventArgs Constructor
InstanceCreatedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public InstanceCreatedEventArgs(
    Database database
)
Visual Basic
Public Sub New ( _
    database As Database _
)
Visual C++
public:
InstanceCreatedEventArgs(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

See Also

InstanceCreatedEventArgs Class
Sitecore.Data.Events Namespace


InstanceCreatedEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
InstanceCreatedEventArgs Methods
InstanceCreatedEventArgs Class See Also Send Feedback

The InstanceCreatedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InstanceCreatedEventArgs Class
Sitecore.Data.Events Namespace


InstanceCreatedEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
InstanceCreatedEventArgs Properties
InstanceCreatedEventArgs Class See Also Send Feedback

The InstanceCreatedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Database | Gets the database that was loaded.

See Also

InstanceCreatedEventArgs Class
Sitecore.Data.Events Namespace


Database Property

[image]

Sitecore 6.4.1 API
InstanceCreatedEventArgs..::..Database Property
InstanceCreatedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database Database { get; }
Visual Basic
Public ReadOnly Property Database As Database
    Get
Visual C++
public:
property Database^ Database {
    Database^ get ();
}

Field Value

The database.

See Also

InstanceCreatedEventArgs Class
Sitecore.Data.Events Namespace


ItemAddedDelegate Delegate

[image]

Sitecore 6.4.1 API
ItemAddedDelegate Delegate
See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use the ItemCreatedDelegate event instead.")]
public delegate void ItemAddedDelegate(
    Object sender,
    ItemAddedEventArgs args
)
Visual Basic
<ObsoleteAttribute("Use the ItemCreatedDelegate event instead.")> _
Public Delegate Sub ItemAddedDelegate ( _
    sender As Object, _
    args As ItemAddedEventArgs _
)
Visual C++
[ObsoleteAttribute(L"Use the ItemCreatedDelegate event instead.")]
public delegate void ItemAddedDelegate(
    Object^ sender,
    ItemAddedEventArgs^ args
)

Parameters

sender
Type: System..::..Object
args
Type: Sitecore.Data.Events..::..ItemAddedEventArgs

Remarks

When you create a ItemAddedDelegate delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

See Also

Sitecore.Data.Events Namespace


ItemAddedEventArgs Class

[image]

Sitecore 6.4.1 API
ItemAddedEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemAddedEventArgs : EventArgs
Visual Basic
Public Class ItemAddedEventArgs _
    Inherits EventArgs
Visual C++
public ref class ItemAddedEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Data.Events..::..ItemAddedEventArgs

See Also

ItemAddedEventArgs Members
Sitecore.Data.Events Namespace


ItemAddedEventArgs Members

[image] [image]

Sitecore 6.4.1 API
ItemAddedEventArgs Members
ItemAddedEventArgs Class Constructors Methods Properties See Also Send Feedback

The ItemAddedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ItemAddedEventArgs | Creates a new ItemAddedEventArgs instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | Gets the item.

See Also

ItemAddedEventArgs Class
Sitecore.Data.Events Namespace


ItemAddedEventArgs Constructor

[image]

Sitecore 6.4.1 API
ItemAddedEventArgs Constructor
ItemAddedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemAddedEventArgs(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
ItemAddedEventArgs(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
Item.

See Also

ItemAddedEventArgs Class
Sitecore.Data.Events Namespace


ItemAddedEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
ItemAddedEventArgs Methods
ItemAddedEventArgs Class See Also Send Feedback

The ItemAddedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemAddedEventArgs Class
Sitecore.Data.Events Namespace


ItemAddedEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
ItemAddedEventArgs Properties
ItemAddedEventArgs Class See Also Send Feedback

The ItemAddedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets the item.

See Also

ItemAddedEventArgs Class
Sitecore.Data.Events Namespace


Item Property

[image]

Sitecore 6.4.1 API
ItemAddedEventArgs..::..Item Property
ItemAddedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Item { get; }
Visual Basic
Public ReadOnly Property Item As Item
    Get
Visual C++
public:
property Item^ Item {
    Item^ get ();
}

Field Value

The item.

See Also

ItemAddedEventArgs Class
Sitecore.Data.Events Namespace


ItemChildrenChangedDelegate Delegate

[image]

Sitecore 6.4.1 API
ItemChildrenChangedDelegate Delegate
See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public delegate void ItemChildrenChangedDelegate(
    Object sender,
    ItemChildrenChangedEventArgs args
)
Visual Basic
Public Delegate Sub ItemChildrenChangedDelegate ( _
    sender As Object, _
    args As ItemChildrenChangedEventArgs _
)
Visual C++
public delegate void ItemChildrenChangedDelegate(
    Object^ sender,
    ItemChildrenChangedEventArgs^ args
)

Parameters

sender
Type: System..::..Object
args
Type: Sitecore.Data.Events..::..ItemChildrenChangedEventArgs

Remarks

When you create a ItemChildrenChangedDelegate delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

See Also

Sitecore.Data.Events Namespace


ItemChildrenChangedEventArgs Class

[image]

Sitecore 6.4.1 API
ItemChildrenChangedEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemChildrenChangedEventArgs
Visual Basic
Public Class ItemChildrenChangedEventArgs
Visual C++
public ref class ItemChildrenChangedEventArgs

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Events..::..ItemChildrenChangedEventArgs

See Also

ItemChildrenChangedEventArgs Members
Sitecore.Data.Events Namespace


ItemChildrenChangedEventArgs Members

[image] [image]

Sitecore 6.4.1 API
ItemChildrenChangedEventArgs Members
ItemChildrenChangedEventArgs Class Constructors Methods Properties See Also Send Feedback

The ItemChildrenChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ItemChildrenChangedEventArgs | Creates a new ItemCopiedEventArgs instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | Gets the item.

See Also

ItemChildrenChangedEventArgs Class
Sitecore.Data.Events Namespace


ItemChildrenChangedEventArgs Constructor

[image]

Sitecore 6.4.1 API
ItemChildrenChangedEventArgs Constructor
ItemChildrenChangedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemChildrenChangedEventArgs(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
ItemChildrenChangedEventArgs(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
Item.

See Also

ItemChildrenChangedEventArgs Class
Sitecore.Data.Events Namespace


ItemChildrenChangedEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
ItemChildrenChangedEventArgs Methods
ItemChildrenChangedEventArgs Class See Also Send Feedback

The ItemChildrenChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemChildrenChangedEventArgs Class
Sitecore.Data.Events Namespace


ItemChildrenChangedEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
ItemChildrenChangedEventArgs Properties
ItemChildrenChangedEventArgs Class See Also Send Feedback

The ItemChildrenChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets the item.

See Also

ItemChildrenChangedEventArgs Class
Sitecore.Data.Events Namespace


Item Property

[image]

Sitecore 6.4.1 API
ItemChildrenChangedEventArgs..::..Item Property
ItemChildrenChangedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Item { get; }
Visual Basic
Public ReadOnly Property Item As Item
    Get
Visual C++
public:
property Item^ Item {
    Item^ get ();
}

Field Value

The item.

See Also

ItemChildrenChangedEventArgs Class
Sitecore.Data.Events Namespace


ItemCopiedDelegate Delegate

[image]

Sitecore 6.4.1 API
ItemCopiedDelegate Delegate
See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public delegate void ItemCopiedDelegate(
    Object sender,
    ItemCopiedEventArgs args
)
Visual Basic
Public Delegate Sub ItemCopiedDelegate ( _
    sender As Object, _
    args As ItemCopiedEventArgs _
)
Visual C++
public delegate void ItemCopiedDelegate(
    Object^ sender,
    ItemCopiedEventArgs^ args
)

Parameters

sender
Type: System..::..Object
args
Type: Sitecore.Data.Events..::..ItemCopiedEventArgs

Remarks

When you create a ItemCopiedDelegate delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

See Also

Sitecore.Data.Events Namespace


ItemCopiedEventArgs Class

[image]

Sitecore 6.4.1 API
ItemCopiedEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemCopiedEventArgs : EventArgs
Visual Basic
Public Class ItemCopiedEventArgs _
    Inherits EventArgs
Visual C++
public ref class ItemCopiedEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Data.Events..::..ItemCopiedEventArgs

See Also

ItemCopiedEventArgs Members
Sitecore.Data.Events Namespace


ItemCopiedEventArgs Members

[image] [image]

Sitecore 6.4.1 API
ItemCopiedEventArgs Members
ItemCopiedEventArgs Class Constructors Methods Properties See Also Send Feedback

The ItemCopiedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ItemCopiedEventArgs | Creates a new ItemCopiedEventArgs instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Copy | Gets the copy.
Public property | Source | Gets the source.

See Also

ItemCopiedEventArgs Class
Sitecore.Data.Events Namespace


ItemCopiedEventArgs Constructor

[image]

Sitecore 6.4.1 API
ItemCopiedEventArgs Constructor
ItemCopiedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemCopiedEventArgs(
    Item source,
    Item copy
)
Visual Basic
Public Sub New ( _
    source As Item, _
    copy As Item _
)
Visual C++
public:
ItemCopiedEventArgs(
    Item^ source,
    Item^ copy
)

Parameters

source
Type: Sitecore.Data.Items..::..Item
Source.
copy
Type: Sitecore.Data.Items..::..Item
Copy.

See Also

ItemCopiedEventArgs Class
Sitecore.Data.Events Namespace


ItemCopiedEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
ItemCopiedEventArgs Methods
ItemCopiedEventArgs Class See Also Send Feedback

The ItemCopiedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemCopiedEventArgs Class
Sitecore.Data.Events Namespace


ItemCopiedEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
ItemCopiedEventArgs Properties
ItemCopiedEventArgs Class See Also Send Feedback

The ItemCopiedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Copy | Gets the copy.
Public property | Source | Gets the source.

See Also

ItemCopiedEventArgs Class
Sitecore.Data.Events Namespace


Copy Property

[image]

Sitecore 6.4.1 API
ItemCopiedEventArgs..::..Copy Property
ItemCopiedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Copy { get; }
Visual Basic
Public ReadOnly Property Copy As Item
    Get
Visual C++
public:
property Item^ Copy {
    Item^ get ();
}

Field Value

The copy.

See Also

ItemCopiedEventArgs Class
Sitecore.Data.Events Namespace


Source Property

[image]

Sitecore 6.4.1 API
ItemCopiedEventArgs..::..Source Property
ItemCopiedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Source { get; }
Visual Basic
Public ReadOnly Property Source As Item
    Get
Visual C++
public:
property Item^ Source {
    Item^ get ();
}

Field Value

The source.

See Also

ItemCopiedEventArgs Class
Sitecore.Data.Events Namespace


ItemCreatedDelegate Delegate

[image]

Sitecore 6.4.1 API
ItemCreatedDelegate Delegate
See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public delegate void ItemCreatedDelegate(
    Object sender,
    ItemCreatedEventArgs args
)
Visual Basic
Public Delegate Sub ItemCreatedDelegate ( _
    sender As Object, _
    args As ItemCreatedEventArgs _
)
Visual C++
public delegate void ItemCreatedDelegate(
    Object^ sender,
    ItemCreatedEventArgs^ args
)

Parameters

sender
Type: System..::..Object
args
Type: Sitecore.Data.Events..::..ItemCreatedEventArgs

Remarks

When you create a ItemCreatedDelegate delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

See Also

Sitecore.Data.Events Namespace


ItemCreatedEventArgs Class

[image]

Sitecore 6.4.1 API
ItemCreatedEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemCreatedEventArgs
Visual Basic
Public Class ItemCreatedEventArgs
Visual C++
public ref class ItemCreatedEventArgs

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Events..::..ItemCreatedEventArgs

See Also

ItemCreatedEventArgs Members
Sitecore.Data.Events Namespace


ItemCreatedEventArgs Members

[image] [image]

Sitecore 6.4.1 API
ItemCreatedEventArgs Members
ItemCreatedEventArgs Class Constructors Methods Properties See Also Send Feedback

The ItemCreatedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ItemCreatedEventArgs | Creates a new ItemCreatedEventArgs instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | Gets the item.

See Also

ItemCreatedEventArgs Class
Sitecore.Data.Events Namespace


ItemCreatedEventArgs Constructor

[image]

Sitecore 6.4.1 API
ItemCreatedEventArgs Constructor
ItemCreatedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemCreatedEventArgs(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
ItemCreatedEventArgs(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
Item.

See Also

ItemCreatedEventArgs Class
Sitecore.Data.Events Namespace


ItemCreatedEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
ItemCreatedEventArgs Methods
ItemCreatedEventArgs Class See Also Send Feedback

The ItemCreatedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemCreatedEventArgs Class
Sitecore.Data.Events Namespace


ItemCreatedEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
ItemCreatedEventArgs Properties
ItemCreatedEventArgs Class See Also Send Feedback

The ItemCreatedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets the item.

See Also

ItemCreatedEventArgs Class
Sitecore.Data.Events Namespace


Item Property

[image]

Sitecore 6.4.1 API
ItemCreatedEventArgs..::..Item Property
ItemCreatedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Item { get; }
Visual Basic
Public ReadOnly Property Item As Item
    Get
Visual C++
public:
property Item^ Item {
    Item^ get ();
}

Field Value

The item.

See Also

ItemCreatedEventArgs Class
Sitecore.Data.Events Namespace


ItemCreatedRemoteEventArgs Class

[image]

Sitecore 6.4.1 API
ItemCreatedRemoteEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemCreatedRemoteEventArgs : EventArgs,
    IPassNativeEventArgs
Visual Basic
Public Class ItemCreatedRemoteEventArgs _
    Inherits EventArgs _
    Implements IPassNativeEventArgs
Visual C++
public ref class ItemCreatedRemoteEventArgs : public EventArgs,
    IPassNativeEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Data.Events..::..ItemCreatedRemoteEventArgs

See Also

ItemCreatedRemoteEventArgs Members
Sitecore.Data.Events Namespace


ItemCreatedRemoteEventArgs Members

[image] [image]

Sitecore 6.4.1 API
ItemCreatedRemoteEventArgs Members
ItemCreatedRemoteEventArgs Class Constructors Methods Properties See Also Send Feedback

The ItemCreatedRemoteEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ItemCreatedRemoteEventArgs | Initializes a new instance of the ItemCreatedRemoteEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Destination | Gets or sets Destination.
Public property | Item | Gets or sets Item.

See Also

ItemCreatedRemoteEventArgs Class
Sitecore.Data.Events Namespace


ItemCreatedRemoteEventArgs Constructor

[image]

Sitecore 6.4.1 API
ItemCreatedRemoteEventArgs Constructor
ItemCreatedRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemCreatedRemoteEventArgs(
    Item item,
    Item destination
)
Visual Basic
Public Sub New ( _
    item As Item, _
    destination As Item _
)
Visual C++
public:
ItemCreatedRemoteEventArgs(
    Item^ item,
    Item^ destination
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
destination
Type: Sitecore.Data.Items..::..Item
The destination.

See Also

ItemCreatedRemoteEventArgs Class
Sitecore.Data.Events Namespace


ItemCreatedRemoteEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
ItemCreatedRemoteEventArgs Properties
ItemCreatedRemoteEventArgs Class See Also Send Feedback

The ItemCreatedRemoteEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Destination | Gets or sets Destination.
Public property | Item | Gets or sets Item.

See Also

ItemCreatedRemoteEventArgs Class
Sitecore.Data.Events Namespace


Destination Property

[image]

Sitecore 6.4.1 API
ItemCreatedRemoteEventArgs..::..Destination Property
ItemCreatedRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Destination { get; protected set; }
Visual Basic
Public Property Destination As Item
    Get
    Protected Set
Visual C++
public:
property Item^ Destination {
    Item^ get ();
    protected: void set (Item^ value);
}

See Also

ItemCreatedRemoteEventArgs Class
Sitecore.Data.Events Namespace


Item Property

[image]

Sitecore 6.4.1 API
ItemCreatedRemoteEventArgs..::..Item Property
ItemCreatedRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Item { get; protected set; }
Visual Basic
Public Property Item As Item
    Get
    Protected Set
Visual C++
public:
property Item^ Item {
    Item^ get ();
    protected: void set (Item^ value);
}

See Also

ItemCreatedRemoteEventArgs Class
Sitecore.Data.Events Namespace


ItemCreatingEventArgs Class

[image]

Sitecore 6.4.1 API
ItemCreatingEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemCreatingEventArgs : CancelEventArgs
Visual Basic
Public Class ItemCreatingEventArgs _
    Inherits CancelEventArgs
Visual C++
public ref class ItemCreatingEventArgs : public CancelEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..CancelEventArgs
Sitecore.Data.Events..::..ItemCreatingEventArgs

See Also

ItemCreatingEventArgs Members
Sitecore.Data.Events Namespace


ItemCreatingEventArgs Members

[image] [image]

Sitecore 6.4.1 API
ItemCreatingEventArgs Members
ItemCreatingEventArgs Class Constructors Methods Properties See Also Send Feedback

The ItemCreatingEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ItemCreatingEventArgs | Creates a new ItemCreatingEventArgs instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | ItemId | Gets the item id.
Public property | ItemName | Gets the name of the item being created.
Public property | Parent | Gets the parent.
Public property | TemplateId | Gets the template id of the item being created.

See Also

ItemCreatingEventArgs Class
Sitecore.Data.Events Namespace


ItemCreatingEventArgs Constructor

[image]

Sitecore 6.4.1 API
ItemCreatingEventArgs Constructor
ItemCreatingEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemCreatingEventArgs(
    string itemName,
    ID itemId,
    ID templateId,
    Item parent
)
Visual Basic
Public Sub New ( _
    itemName As String, _
    itemId As ID, _
    templateId As ID, _
    parent As Item _
)
Visual C++
public:
ItemCreatingEventArgs(
    String^ itemName,
    ID^ itemId,
    ID^ templateId,
    Item^ parent
)

Parameters

itemName
Type: System..::..String
Name of the item.
itemId
Type: Sitecore.Data..::..ID
The item id.
templateId
Type: Sitecore.Data..::..ID
The template id.
parent
Type: Sitecore.Data.Items..::..Item
The parent.

See Also

ItemCreatingEventArgs Class
Sitecore.Data.Events Namespace


ItemCreatingEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
ItemCreatingEventArgs Methods
ItemCreatingEventArgs Class See Also Send Feedback

The ItemCreatingEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemCreatingEventArgs Class
Sitecore.Data.Events Namespace


ItemId Property

[image]

Sitecore 6.4.1 API
ItemCreatingEventArgs..::..ItemId Property
ItemCreatingEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ItemId { get; }
Visual Basic
Public ReadOnly Property ItemId As ID
    Get
Visual C++
public:
property ID^ ItemId {
    ID^ get ();
}

Field Value

The item id.

See Also

ItemCreatingEventArgs Class
Sitecore.Data.Events Namespace


ItemName Property

[image]

Sitecore 6.4.1 API
ItemCreatingEventArgs..::..ItemName Property
ItemCreatingEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ItemName { get; }
Visual Basic
Public ReadOnly Property ItemName As String
    Get
Visual C++
public:
property String^ ItemName {
    String^ get ();
}

Field Value

The name of the item.

See Also

ItemCreatingEventArgs Class
Sitecore.Data.Events Namespace


Parent Property

[image]

Sitecore 6.4.1 API
ItemCreatingEventArgs..::..Parent Property
ItemCreatingEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Parent { get; }
Visual Basic
Public ReadOnly Property Parent As Item
    Get
Visual C++
public:
property Item^ Parent {
    Item^ get ();
}

Field Value

The parent.

See Also

ItemCreatingEventArgs Class
Sitecore.Data.Events Namespace


TemplateId Property

[image]

Sitecore 6.4.1 API
ItemCreatingEventArgs..::..TemplateId Property
ItemCreatingEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID TemplateId { get; }
Visual Basic
Public ReadOnly Property TemplateId As ID
    Get
Visual C++
public:
property ID^ TemplateId {
    ID^ get ();
}

Field Value

The template id.

See Also

ItemCreatingEventArgs Class
Sitecore.Data.Events Namespace


ItemDeletedDelegate Delegate

[image]

Sitecore 6.4.1 API
ItemDeletedDelegate Delegate
See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public delegate void ItemDeletedDelegate(
    Object sender,
    ItemDeletedEventArgs args
)
Visual Basic
Public Delegate Sub ItemDeletedDelegate ( _
    sender As Object, _
    args As ItemDeletedEventArgs _
)
Visual C++
public delegate void ItemDeletedDelegate(
    Object^ sender,
    ItemDeletedEventArgs^ args
)

Parameters

sender
Type: System..::..Object
args
Type: Sitecore.Data.Events..::..ItemDeletedEventArgs

Remarks

When you create a ItemDeletedDelegate delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

See Also

Sitecore.Data.Events Namespace


ItemDeletedEventArgs Class

[image]

Sitecore 6.4.1 API
ItemDeletedEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemDeletedEventArgs : EventArgs
Visual Basic
Public Class ItemDeletedEventArgs _
    Inherits EventArgs
Visual C++
public ref class ItemDeletedEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Data.Events..::..ItemDeletedEventArgs

See Also

ItemDeletedEventArgs Members
Sitecore.Data.Events Namespace


ItemDeletedEventArgs Members

[image] [image]

Sitecore 6.4.1 API
ItemDeletedEventArgs Members
ItemDeletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The ItemDeletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ItemDeletedEventArgs(Item, ID) | Creates a new ItemDeletedEventArgs instance.
Public method | ItemDeletedEventArgs(Item, ID, Int32) | Creates a new ItemDeletedEventArgs instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Index | Gets the ID of the item that should be focused in the client after this item is deleted.
Public property | Item | Gets the item.
Public property | ParentID | Gets the parent ID.

See Also

ItemDeletedEventArgs Class
Sitecore.Data.Events Namespace


ItemDeletedEventArgs Constructor

[image] [image]

Sitecore 6.4.1 API
ItemDeletedEventArgs Constructor
ItemDeletedEventArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ItemDeletedEventArgs(Item, ID) | Creates a new ItemDeletedEventArgs instance.
Public method | ItemDeletedEventArgs(Item, ID, Int32) | Creates a new ItemDeletedEventArgs instance.

See Also

ItemDeletedEventArgs Class
ItemDeletedEventArgs Members
Sitecore.Data.Events Namespace


ItemDeletedEventArgs Constructor (Item, ID)

[image]

Sitecore 6.4.1 API
ItemDeletedEventArgs Constructor (Item, ID)
ItemDeletedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemDeletedEventArgs(
    Item item,
    ID parentID
)
Visual Basic
Public Sub New ( _
    item As Item, _
    parentID As ID _
)
Visual C++
public:
ItemDeletedEventArgs(
    Item^ item,
    ID^ parentID
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
Item.
parentID
Type: Sitecore.Data..::..ID
Parent ID.

See Also

ItemDeletedEventArgs Class
ItemDeletedEventArgs Overload
Sitecore.Data.Events Namespace


ItemDeletedEventArgs Constructor (Item, ID, Int32)

[image]

Sitecore 6.4.1 API
ItemDeletedEventArgs Constructor (Item, ID, Int32)
ItemDeletedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemDeletedEventArgs(
    Item item,
    ID parentID,
    int index
)
Visual Basic
Public Sub New ( _
    item As Item, _
    parentID As ID, _
    index As Integer _
)
Visual C++
public:
ItemDeletedEventArgs(
    Item^ item,
    ID^ parentID,
    int index
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
Item.
parentID
Type: Sitecore.Data..::..ID
Parent ID.
index
Type: System..::..Int32
Index of the item (among its siblings) before it was deleted.

See Also

ItemDeletedEventArgs Class
ItemDeletedEventArgs Overload
Sitecore.Data.Events Namespace


ItemDeletedEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
ItemDeletedEventArgs Methods
ItemDeletedEventArgs Class See Also Send Feedback

The ItemDeletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemDeletedEventArgs Class
Sitecore.Data.Events Namespace


ItemDeletedEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
ItemDeletedEventArgs Properties
ItemDeletedEventArgs Class See Also Send Feedback

The ItemDeletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Index | Gets the ID of the item that should be focused in the client after this item is deleted.
Public property | Item | Gets the item.
Public property | ParentID | Gets the parent ID.

See Also

ItemDeletedEventArgs Class
Sitecore.Data.Events Namespace


Index Property

[image]

Sitecore 6.4.1 API
ItemDeletedEventArgs..::..Index Property
ItemDeletedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Index { get; }
Visual Basic
Public ReadOnly Property Index As Integer
    Get
Visual C++
public:
property int Index {
    int get ();
}

Field Value

The index.

See Also

ItemDeletedEventArgs Class
Sitecore.Data.Events Namespace


Item Property

[image]

Sitecore 6.4.1 API
ItemDeletedEventArgs..::..Item Property
ItemDeletedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Item { get; }
Visual Basic
Public ReadOnly Property Item As Item
    Get
Visual C++
public:
property Item^ Item {
    Item^ get ();
}

Field Value

The item.

See Also

ItemDeletedEventArgs Class
Sitecore.Data.Events Namespace


ParentID Property

[image]

Sitecore 6.4.1 API
ItemDeletedEventArgs..::..ParentID Property
ItemDeletedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ParentID { get; }
Visual Basic
Public ReadOnly Property ParentID As ID
    Get
Visual C++
public:
property ID^ ParentID {
    ID^ get ();
}

Field Value

The parent ID.

See Also

ItemDeletedEventArgs Class
Sitecore.Data.Events Namespace


ItemDeletedRemoteEventArgs Class

[image]

Sitecore 6.4.1 API
ItemDeletedRemoteEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemDeletedRemoteEventArgs : EventArgs,
    IPassNativeEventArgs
Visual Basic
Public Class ItemDeletedRemoteEventArgs _
    Inherits EventArgs _
    Implements IPassNativeEventArgs
Visual C++
public ref class ItemDeletedRemoteEventArgs : public EventArgs,
    IPassNativeEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Data.Events..::..ItemDeletedRemoteEventArgs

See Also

ItemDeletedRemoteEventArgs Members
Sitecore.Data.Events Namespace


ItemDeletedRemoteEventArgs Members

[image] [image]

Sitecore 6.4.1 API
ItemDeletedRemoteEventArgs Members
ItemDeletedRemoteEventArgs Class Constructors Methods Properties See Also Send Feedback

The ItemDeletedRemoteEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ItemDeletedRemoteEventArgs | Initializes a new instance of the ItemDeletedRemoteEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | Gets or sets Item.
Public property | ParentId | Gets or sets ParentId.

See Also

ItemDeletedRemoteEventArgs Class
Sitecore.Data.Events Namespace


ItemDeletedRemoteEventArgs Constructor

[image]

Sitecore 6.4.1 API
ItemDeletedRemoteEventArgs Constructor
ItemDeletedRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemDeletedRemoteEventArgs(
    Item item,
    ID parentId
)
Visual Basic
Public Sub New ( _
    item As Item, _
    parentId As ID _
)
Visual C++
public:
ItemDeletedRemoteEventArgs(
    Item^ item,
    ID^ parentId
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
parentId
Type: Sitecore.Data..::..ID
The parent id.

See Also

ItemDeletedRemoteEventArgs Class
Sitecore.Data.Events Namespace


ItemDeletedRemoteEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
ItemDeletedRemoteEventArgs Methods
ItemDeletedRemoteEventArgs Class See Also Send Feedback

The ItemDeletedRemoteEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemDeletedRemoteEventArgs Class
Sitecore.Data.Events Namespace


ItemDeletedRemoteEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
ItemDeletedRemoteEventArgs Properties
ItemDeletedRemoteEventArgs Class See Also Send Feedback

The ItemDeletedRemoteEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets or sets Item.
Public property | ParentId | Gets or sets ParentId.

See Also

ItemDeletedRemoteEventArgs Class
Sitecore.Data.Events Namespace


Item Property

[image]

Sitecore 6.4.1 API
ItemDeletedRemoteEventArgs..::..Item Property
ItemDeletedRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Item { get; protected set; }
Visual Basic
Public Property Item As Item
    Get
    Protected Set
Visual C++
public:
property Item^ Item {
    Item^ get ();
    protected: void set (Item^ value);
}

See Also

ItemDeletedRemoteEventArgs Class
Sitecore.Data.Events Namespace


ParentId Property

[image]

Sitecore 6.4.1 API
ItemDeletedRemoteEventArgs..::..ParentId Property
ItemDeletedRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ParentId { get; protected set; }
Visual Basic
Public Property ParentId As ID
    Get
    Protected Set
Visual C++
public:
property ID^ ParentId {
    ID^ get ();
    protected: void set (ID^ value);
}

See Also

ItemDeletedRemoteEventArgs Class
Sitecore.Data.Events Namespace


ItemDeletingEventArgs Class

[image]

Sitecore 6.4.1 API
ItemDeletingEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemDeletingEventArgs : CancelEventArgs
Visual Basic
Public Class ItemDeletingEventArgs _
    Inherits CancelEventArgs
Visual C++
public ref class ItemDeletingEventArgs : public CancelEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..CancelEventArgs
Sitecore.Data.Events..::..ItemDeletingEventArgs

See Also

ItemDeletingEventArgs Members
Sitecore.Data.Events Namespace


ItemDeletingEventArgs Members

[image] [image]

Sitecore 6.4.1 API
ItemDeletingEventArgs Members
ItemDeletingEventArgs Class Constructors Methods Properties See Also Send Feedback

The ItemDeletingEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ItemDeletingEventArgs | Creates a new ItemDeletingEventArgs instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | Item | Gets the item.

See Also

ItemDeletingEventArgs Class
Sitecore.Data.Events Namespace


ItemDeletingEventArgs Constructor

[image]

Sitecore 6.4.1 API
ItemDeletingEventArgs Constructor
ItemDeletingEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemDeletingEventArgs(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
ItemDeletingEventArgs(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
Item.

See Also

ItemDeletingEventArgs Class
Sitecore.Data.Events Namespace


ItemDeletingEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
ItemDeletingEventArgs Methods
ItemDeletingEventArgs Class See Also Send Feedback

The ItemDeletingEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemDeletingEventArgs Class
Sitecore.Data.Events Namespace


ItemDeletingEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
ItemDeletingEventArgs Properties
ItemDeletingEventArgs Class See Also Send Feedback

The ItemDeletingEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | Item | Gets the item.

See Also

ItemDeletingEventArgs Class
Sitecore.Data.Events Namespace


Item Property

[image]

Sitecore 6.4.1 API
ItemDeletingEventArgs..::..Item Property
ItemDeletingEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Item { get; }
Visual Basic
Public ReadOnly Property Item As Item
    Get
Visual C++
public:
property Item^ Item {
    Item^ get ();
}

Field Value

The item.

See Also

ItemDeletingEventArgs Class
Sitecore.Data.Events Namespace


ItemLockedRemoteEventArgs Class

[image]

Sitecore 6.4.1 API
ItemLockedRemoteEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemLockedRemoteEventArgs : EventArgs,
    IPassNativeEventArgs
Visual Basic
Public Class ItemLockedRemoteEventArgs _
    Inherits EventArgs _
    Implements IPassNativeEventArgs
Visual C++
public ref class ItemLockedRemoteEventArgs : public EventArgs,
    IPassNativeEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Data.Events..::..ItemLockedRemoteEventArgs

See Also

ItemLockedRemoteEventArgs Members
Sitecore.Data.Events Namespace


ItemLockedRemoteEventArgs Members

[image] [image]

Sitecore 6.4.1 API
ItemLockedRemoteEventArgs Members
ItemLockedRemoteEventArgs Class Constructors Methods Properties See Also Send Feedback

The ItemLockedRemoteEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ItemLockedRemoteEventArgs | Initializes a new instance of the ItemLockedRemoteEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | Gets or sets Item.

See Also

ItemLockedRemoteEventArgs Class
Sitecore.Data.Events Namespace


ItemLockedRemoteEventArgs Constructor

[image]

Sitecore 6.4.1 API
ItemLockedRemoteEventArgs Constructor
ItemLockedRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemLockedRemoteEventArgs(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
ItemLockedRemoteEventArgs(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

ItemLockedRemoteEventArgs Class
Sitecore.Data.Events Namespace


ItemLockedRemoteEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
ItemLockedRemoteEventArgs Methods
ItemLockedRemoteEventArgs Class See Also Send Feedback

The ItemLockedRemoteEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemLockedRemoteEventArgs Class
Sitecore.Data.Events Namespace


ItemLockedRemoteEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
ItemLockedRemoteEventArgs Properties
ItemLockedRemoteEventArgs Class See Also Send Feedback

The ItemLockedRemoteEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets or sets Item.

See Also

ItemLockedRemoteEventArgs Class
Sitecore.Data.Events Namespace


Item Property

[image]

Sitecore 6.4.1 API
ItemLockedRemoteEventArgs..::..Item Property
ItemLockedRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Item { get; protected set; }
Visual Basic
Public Property Item As Item
    Get
    Protected Set
Visual C++
public:
property Item^ Item {
    Item^ get ();
    protected: void set (Item^ value);
}

See Also

ItemLockedRemoteEventArgs Class
Sitecore.Data.Events Namespace


ItemMovedDelegate Delegate

[image]

Sitecore 6.4.1 API
ItemMovedDelegate Delegate
See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public delegate void ItemMovedDelegate(
    Object sender,
    ItemMovedEventArgs args
)
Visual Basic
Public Delegate Sub ItemMovedDelegate ( _
    sender As Object, _
    args As ItemMovedEventArgs _
)
Visual C++
public delegate void ItemMovedDelegate(
    Object^ sender,
    ItemMovedEventArgs^ args
)

Parameters

sender
Type: System..::..Object
args
Type: Sitecore.Data.Events..::..ItemMovedEventArgs

Remarks

When you create a ItemMovedDelegate delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

See Also

Sitecore.Data.Events Namespace


ItemMovedEventArgs Class

[image]

Sitecore 6.4.1 API
ItemMovedEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemMovedEventArgs
Visual Basic
Public Class ItemMovedEventArgs
Visual C++
public ref class ItemMovedEventArgs

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Events..::..ItemMovedEventArgs

See Also

ItemMovedEventArgs Members
Sitecore.Data.Events Namespace


ItemMovedEventArgs Members

[image] [image]

Sitecore 6.4.1 API
ItemMovedEventArgs Members
ItemMovedEventArgs Class Constructors Methods Properties See Also Send Feedback

The ItemMovedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ItemMovedEventArgs | Initializes a new instance of the ItemMovedEventArgs class. Creates a new ItemMovedEventArgs instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | Gets the item.
Public property | OldParentID | Gets the old parent ID.

See Also

ItemMovedEventArgs Class
Sitecore.Data.Events Namespace


ItemMovedEventArgs Constructor

[image]

Sitecore 6.4.1 API
ItemMovedEventArgs Constructor
ItemMovedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemMovedEventArgs(
    Item item,
    ID oldParentID
)
Visual Basic
Public Sub New ( _
    item As Item, _
    oldParentID As ID _
)
Visual C++
public:
ItemMovedEventArgs(
    Item^ item,
    ID^ oldParentID
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
Item.
oldParentID
Type: Sitecore.Data..::..ID
Old parent ID.

See Also

ItemMovedEventArgs Class
Sitecore.Data.Events Namespace


ItemMovedEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
ItemMovedEventArgs Methods
ItemMovedEventArgs Class See Also Send Feedback

The ItemMovedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemMovedEventArgs Class
Sitecore.Data.Events Namespace


ItemMovedEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
ItemMovedEventArgs Properties
ItemMovedEventArgs Class See Also Send Feedback

The ItemMovedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets the item.
Public property | OldParentID | Gets the old parent ID.

See Also

ItemMovedEventArgs Class
Sitecore.Data.Events Namespace


Item Property

[image]

Sitecore 6.4.1 API
ItemMovedEventArgs..::..Item Property
ItemMovedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Item { get; }
Visual Basic
Public ReadOnly Property Item As Item
    Get
Visual C++
public:
property Item^ Item {
    Item^ get ();
}

Field Value

The item.

See Also

ItemMovedEventArgs Class
Sitecore.Data.Events Namespace


OldParentID Property

[image]

Sitecore 6.4.1 API
ItemMovedEventArgs..::..OldParentID Property
ItemMovedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID OldParentID { get; }
Visual Basic
Public ReadOnly Property OldParentID As ID
    Get
Visual C++
public:
property ID^ OldParentID {
    ID^ get ();
}

Field Value

The old parent ID.

See Also

ItemMovedEventArgs Class
Sitecore.Data.Events Namespace


ItemMovedRemoteEventArgs Class

[image]

Sitecore 6.4.1 API
ItemMovedRemoteEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemMovedRemoteEventArgs : EventArgs,
    IPassNativeEventArgs
Visual Basic
Public Class ItemMovedRemoteEventArgs _
    Inherits EventArgs _
    Implements IPassNativeEventArgs
Visual C++
public ref class ItemMovedRemoteEventArgs : public EventArgs,
    IPassNativeEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Data.Events..::..ItemMovedRemoteEventArgs

See Also

ItemMovedRemoteEventArgs Members
Sitecore.Data.Events Namespace


ItemMovedRemoteEventArgs Members

[image] [image]

Sitecore 6.4.1 API
ItemMovedRemoteEventArgs Members
ItemMovedRemoteEventArgs Class Constructors Methods Properties See Also Send Feedback

The ItemMovedRemoteEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ItemMovedRemoteEventArgs | Initializes a new instance of the ItemMovedRemoteEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | Gets or sets Item.
Public property | OldParentId | Gets or sets OldParentId.

See Also

ItemMovedRemoteEventArgs Class
Sitecore.Data.Events Namespace


ItemMovedRemoteEventArgs Constructor

[image]

Sitecore 6.4.1 API
ItemMovedRemoteEventArgs Constructor
ItemMovedRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemMovedRemoteEventArgs(
    Item item,
    ID oldParentId
)
Visual Basic
Public Sub New ( _
    item As Item, _
    oldParentId As ID _
)
Visual C++
public:
ItemMovedRemoteEventArgs(
    Item^ item,
    ID^ oldParentId
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
oldParentId
Type: Sitecore.Data..::..ID
The old parent id.

See Also

ItemMovedRemoteEventArgs Class
Sitecore.Data.Events Namespace


ItemMovedRemoteEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
ItemMovedRemoteEventArgs Methods
ItemMovedRemoteEventArgs Class See Also Send Feedback

The ItemMovedRemoteEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemMovedRemoteEventArgs Class
Sitecore.Data.Events Namespace


ItemMovedRemoteEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
ItemMovedRemoteEventArgs Properties
ItemMovedRemoteEventArgs Class See Also Send Feedback

The ItemMovedRemoteEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets or sets Item.
Public property | OldParentId | Gets or sets OldParentId.

See Also

ItemMovedRemoteEventArgs Class
Sitecore.Data.Events Namespace


OldParentId Property

[image]

Sitecore 6.4.1 API
ItemMovedRemoteEventArgs..::..OldParentId Property
ItemMovedRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID OldParentId { get; protected set; }
Visual Basic
Public Property OldParentId As ID
    Get
    Protected Set
Visual C++
public:
property ID^ OldParentId {
    ID^ get ();
    protected: void set (ID^ value);
}

See Also

ItemMovedRemoteEventArgs Class
Sitecore.Data.Events Namespace


ItemRemovedEventArgs Class

[image]

Sitecore 6.4.1 API
ItemRemovedEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemRemovedEventArgs : EventArgs
Visual Basic
Public Class ItemRemovedEventArgs _
    Inherits EventArgs
Visual C++
public ref class ItemRemovedEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Data.Events..::..ItemRemovedEventArgs

See Also

ItemRemovedEventArgs Members
Sitecore.Data.Events Namespace


ItemRemovedEventArgs Members

[image] [image]

Sitecore 6.4.1 API
ItemRemovedEventArgs Members
ItemRemovedEventArgs Class Constructors Methods Properties See Also Send Feedback

The ItemRemovedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ItemRemovedEventArgs | Creates a new ItemRemovedEventArgs instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ItemId | Gets the item.

See Also

ItemRemovedEventArgs Class
Sitecore.Data.Events Namespace


ItemRemovedEventArgs Constructor

[image]

Sitecore 6.4.1 API
ItemRemovedEventArgs Constructor
ItemRemovedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemRemovedEventArgs(
    ID itemId
)
Visual Basic
Public Sub New ( _
    itemId As ID _
)
Visual C++
public:
ItemRemovedEventArgs(
    ID^ itemId
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.

See Also

ItemRemovedEventArgs Class
Sitecore.Data.Events Namespace


ItemRemovedEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
ItemRemovedEventArgs Methods
ItemRemovedEventArgs Class See Also Send Feedback

The ItemRemovedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemRemovedEventArgs Class
Sitecore.Data.Events Namespace


ItemRemovedEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
ItemRemovedEventArgs Properties
ItemRemovedEventArgs Class See Also Send Feedback

The ItemRemovedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ItemId | Gets the item.

See Also

ItemRemovedEventArgs Class
Sitecore.Data.Events Namespace


ItemId Property

[image]

Sitecore 6.4.1 API
ItemRemovedEventArgs..::..ItemId Property
ItemRemovedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ItemId { get; }
Visual Basic
Public ReadOnly Property ItemId As ID
    Get
Visual C++
public:
property ID^ ItemId {
    ID^ get ();
}

Field Value

The item id.

See Also

ItemRemovedEventArgs Class
Sitecore.Data.Events Namespace


ItemRenamedDelegate Delegate

[image]

Sitecore 6.4.1 API
ItemRenamedDelegate Delegate
See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public delegate void ItemRenamedDelegate(
    Object sender,
    ItemRenamedEventArgs args
)
Visual Basic
Public Delegate Sub ItemRenamedDelegate ( _
    sender As Object, _
    args As ItemRenamedEventArgs _
)
Visual C++
public delegate void ItemRenamedDelegate(
    Object^ sender,
    ItemRenamedEventArgs^ args
)

Parameters

sender
Type: System..::..Object
args
Type: Sitecore.Data.Events..::..ItemRenamedEventArgs

Remarks

When you create a ItemRenamedDelegate delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

See Also

Sitecore.Data.Events Namespace


ItemRenamedEventArgs Class

[image]

Sitecore 6.4.1 API
ItemRenamedEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemRenamedEventArgs
Visual Basic
Public Class ItemRenamedEventArgs
Visual C++
public ref class ItemRenamedEventArgs

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Events..::..ItemRenamedEventArgs

See Also

ItemRenamedEventArgs Members
Sitecore.Data.Events Namespace


ItemRenamedEventArgs Members

[image] [image]

Sitecore 6.4.1 API
ItemRenamedEventArgs Members
ItemRenamedEventArgs Class Constructors Methods Properties See Also Send Feedback

The ItemRenamedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ItemRenamedEventArgs | Creates a new ItemRenamedEventArgs instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | Gets the item.
Public property | OldName | Gets the old name of the item.

See Also

ItemRenamedEventArgs Class
Sitecore.Data.Events Namespace


ItemRenamedEventArgs Constructor

[image]

Sitecore 6.4.1 API
ItemRenamedEventArgs Constructor
ItemRenamedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemRenamedEventArgs(
    Item item,
    string oldName
)
Visual Basic
Public Sub New ( _
    item As Item, _
    oldName As String _
)
Visual C++
public:
ItemRenamedEventArgs(
    Item^ item,
    String^ oldName
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
Item.
oldName
Type: System..::..String
Old Name of the item.

See Also

ItemRenamedEventArgs Class
Sitecore.Data.Events Namespace


ItemRenamedEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
ItemRenamedEventArgs Methods
ItemRenamedEventArgs Class See Also Send Feedback

The ItemRenamedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemRenamedEventArgs Class
Sitecore.Data.Events Namespace


ItemRenamedEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
ItemRenamedEventArgs Properties
ItemRenamedEventArgs Class See Also Send Feedback

The ItemRenamedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets the item.
Public property | OldName | Gets the old name of the item.

See Also

ItemRenamedEventArgs Class
Sitecore.Data.Events Namespace


Item Property

[image]

Sitecore 6.4.1 API
ItemRenamedEventArgs..::..Item Property
ItemRenamedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Item { get; }
Visual Basic
Public ReadOnly Property Item As Item
    Get
Visual C++
public:
property Item^ Item {
    Item^ get ();
}

Field Value

The item.

See Also

ItemRenamedEventArgs Class
Sitecore.Data.Events Namespace


OldName Property

[image]

Sitecore 6.4.1 API
ItemRenamedEventArgs..::..OldName Property
ItemRenamedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object OldName { get; }
Visual Basic
Public ReadOnly Property OldName As Object
    Get
Visual C++
public:
property Object^ OldName {
    Object^ get ();
}

Field Value

The old name.

See Also

ItemRenamedEventArgs Class
Sitecore.Data.Events Namespace


ItemSavedDelegate Delegate

[image]

Sitecore 6.4.1 API
ItemSavedDelegate Delegate
See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public delegate void ItemSavedDelegate(
    Object sender,
    ItemSavedEventArgs args
)
Visual Basic
Public Delegate Sub ItemSavedDelegate ( _
    sender As Object, _
    args As ItemSavedEventArgs _
)
Visual C++
public delegate void ItemSavedDelegate(
    Object^ sender,
    ItemSavedEventArgs^ args
)

Parameters

sender
Type: System..::..Object
args
Type: Sitecore.Data.Events..::..ItemSavedEventArgs

Remarks

When you create a ItemSavedDelegate delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

See Also

Sitecore.Data.Events Namespace


ItemSavedEventArgs Class

[image]

Sitecore 6.4.1 API
ItemSavedEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemSavedEventArgs : EventArgs
Visual Basic
Public Class ItemSavedEventArgs _
    Inherits EventArgs
Visual C++
public ref class ItemSavedEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Data.Events..::..ItemSavedEventArgs

See Also

ItemSavedEventArgs Members
Sitecore.Data.Events Namespace


ItemSavedEventArgs Members

[image] [image]

Sitecore 6.4.1 API
ItemSavedEventArgs Members
ItemSavedEventArgs Class Constructors Methods Properties See Also Send Feedback

The ItemSavedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ItemSavedEventArgs(Item) | Creates a new ItemSavedEventArgs instance.
Public method | ItemSavedEventArgs(Item, ItemChanges) | Creates a new ItemSavedEventArgs instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Changes | Gets the changes that were saved.
Public property | Item | Gets the item.

See Also

ItemSavedEventArgs Class
Sitecore.Data.Events Namespace


ItemSavedEventArgs Constructor

[image] [image]

Sitecore 6.4.1 API
ItemSavedEventArgs Constructor
ItemSavedEventArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ItemSavedEventArgs(Item) | Creates a new ItemSavedEventArgs instance.
Public method | ItemSavedEventArgs(Item, ItemChanges) | Creates a new ItemSavedEventArgs instance.

See Also

ItemSavedEventArgs Class
ItemSavedEventArgs Members
Sitecore.Data.Events Namespace


ItemSavedEventArgs Constructor (Item)

[image]

Sitecore 6.4.1 API
ItemSavedEventArgs Constructor (Item)
ItemSavedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemSavedEventArgs(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
ItemSavedEventArgs(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
Item.

See Also

ItemSavedEventArgs Class
ItemSavedEventArgs Overload
Sitecore.Data.Events Namespace


ItemSavedEventArgs Constructor (Item, ItemChanges)

[image]

Sitecore 6.4.1 API
ItemSavedEventArgs Constructor (Item, ItemChanges)
ItemSavedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemSavedEventArgs(
    Item item,
    ItemChanges changes
)
Visual Basic
Public Sub New ( _
    item As Item, _
    changes As ItemChanges _
)
Visual C++
public:
ItemSavedEventArgs(
    Item^ item,
    ItemChanges^ changes
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
Item.
changes
Type: Sitecore.Data.Items..::..ItemChanges
The changes that were saved.

See Also

ItemSavedEventArgs Class
ItemSavedEventArgs Overload
Sitecore.Data.Events Namespace


ItemSavedEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
ItemSavedEventArgs Methods
ItemSavedEventArgs Class See Also Send Feedback

The ItemSavedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemSavedEventArgs Class
Sitecore.Data.Events Namespace


ItemSavedEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
ItemSavedEventArgs Properties
ItemSavedEventArgs Class See Also Send Feedback

The ItemSavedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Changes | Gets the changes that were saved.
Public property | Item | Gets the item.

See Also

ItemSavedEventArgs Class
Sitecore.Data.Events Namespace


Item Property

[image]

Sitecore 6.4.1 API
ItemSavedEventArgs..::..Item Property
ItemSavedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Item { get; }
Visual Basic
Public ReadOnly Property Item As Item
    Get
Visual C++
public:
property Item^ Item {
    Item^ get ();
}

Field Value

The item.

See Also

ItemSavedEventArgs Class
Sitecore.Data.Events Namespace


ItemSavedRemoteEventArgs Class

[image]

Sitecore 6.4.1 API
ItemSavedRemoteEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemSavedRemoteEventArgs : EventArgs,
    IPassNativeEventArgs
Visual Basic
Public Class ItemSavedRemoteEventArgs _
    Inherits EventArgs _
    Implements IPassNativeEventArgs
Visual C++
public ref class ItemSavedRemoteEventArgs : public EventArgs,
    IPassNativeEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Data.Events..::..ItemSavedRemoteEventArgs

See Also

ItemSavedRemoteEventArgs Members
Sitecore.Data.Events Namespace


ItemSavedRemoteEventArgs Members

[image] [image]

Sitecore 6.4.1 API
ItemSavedRemoteEventArgs Members
ItemSavedRemoteEventArgs Class Constructors Methods Properties See Also Send Feedback

The ItemSavedRemoteEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ItemSavedRemoteEventArgs | Initializes a new instance of the ItemSavedRemoteEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Changes | Gets or sets Changes.
Public property | Item | Gets or sets Item.

See Also

ItemSavedRemoteEventArgs Class
Sitecore.Data.Events Namespace


ItemSavedRemoteEventArgs Constructor

[image]

Sitecore 6.4.1 API
ItemSavedRemoteEventArgs Constructor
ItemSavedRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemSavedRemoteEventArgs(
    Item item,
    ItemChanges changes
)
Visual Basic
Public Sub New ( _
    item As Item, _
    changes As ItemChanges _
)
Visual C++
public:
ItemSavedRemoteEventArgs(
    Item^ item,
    ItemChanges^ changes
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
changes
Type: Sitecore.Data.Items..::..ItemChanges
The changes.

See Also

ItemSavedRemoteEventArgs Class
Sitecore.Data.Events Namespace


ItemSavedRemoteEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
ItemSavedRemoteEventArgs Methods
ItemSavedRemoteEventArgs Class See Also Send Feedback

The ItemSavedRemoteEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemSavedRemoteEventArgs Class
Sitecore.Data.Events Namespace


ItemSavedRemoteEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
ItemSavedRemoteEventArgs Properties
ItemSavedRemoteEventArgs Class See Also Send Feedback

The ItemSavedRemoteEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Changes | Gets or sets Changes.
Public property | Item | Gets or sets Item.

See Also

ItemSavedRemoteEventArgs Class
Sitecore.Data.Events Namespace


Changes Property

[image]

Sitecore 6.4.1 API
ItemSavedRemoteEventArgs..::..Changes Property
ItemSavedRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemChanges Changes { get; protected set; }
Visual Basic
Public Property Changes As ItemChanges
    Get
    Protected Set
Visual C++
public:
property ItemChanges^ Changes {
    ItemChanges^ get ();
    protected: void set (ItemChanges^ value);
}

See Also

ItemSavedRemoteEventArgs Class
Sitecore.Data.Events Namespace


Item Property

[image]

Sitecore 6.4.1 API
ItemSavedRemoteEventArgs..::..Item Property
ItemSavedRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Item { get; protected set; }
Visual Basic
Public Property Item As Item
    Get
    Protected Set
Visual C++
public:
property Item^ Item {
    Item^ get ();
    protected: void set (Item^ value);
}

See Also

ItemSavedRemoteEventArgs Class
Sitecore.Data.Events Namespace


ItemSavingEventArgs Class

[image]

Sitecore 6.4.1 API
ItemSavingEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemSavingEventArgs : CancelEventArgs
Visual Basic
Public Class ItemSavingEventArgs _
    Inherits CancelEventArgs
Visual C++
public ref class ItemSavingEventArgs : public CancelEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..CancelEventArgs
Sitecore.Data.Events..::..ItemSavingEventArgs

See Also

ItemSavingEventArgs Members
Sitecore.Data.Events Namespace


ItemSavingEventArgs Members

[image] [image]

Sitecore 6.4.1 API
ItemSavingEventArgs Members
ItemSavingEventArgs Class Constructors Methods Properties See Also Send Feedback

The ItemSavingEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ItemSavingEventArgs | Creates a new ItemSavedEventArgs instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | Changes | Gets the changes that were saved.
Public property | Item | Gets the item.

See Also

ItemSavingEventArgs Class
Sitecore.Data.Events Namespace


ItemSavingEventArgs Constructor

[image]

Sitecore 6.4.1 API
ItemSavingEventArgs Constructor
ItemSavingEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemSavingEventArgs(
    Item item,
    ItemChanges changes
)
Visual Basic
Public Sub New ( _
    item As Item, _
    changes As ItemChanges _
)
Visual C++
public:
ItemSavingEventArgs(
    Item^ item,
    ItemChanges^ changes
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
Item.
changes
Type: Sitecore.Data.Items..::..ItemChanges
The changes that were saved.

See Also

ItemSavingEventArgs Class
Sitecore.Data.Events Namespace


ItemSavingEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
ItemSavingEventArgs Methods
ItemSavingEventArgs Class See Also Send Feedback

The ItemSavingEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemSavingEventArgs Class
Sitecore.Data.Events Namespace


ItemSavingEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
ItemSavingEventArgs Properties
ItemSavingEventArgs Class See Also Send Feedback

The ItemSavingEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | Changes | Gets the changes that were saved.
Public property | Item | Gets the item.

See Also

ItemSavingEventArgs Class
Sitecore.Data.Events Namespace


Changes Property

[image]

Sitecore 6.4.1 API
ItemSavingEventArgs..::..Changes Property
ItemSavingEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemChanges Changes { get; }
Visual Basic
Public ReadOnly Property Changes As ItemChanges
    Get
Visual C++
public:
property ItemChanges^ Changes {
    ItemChanges^ get ();
}

Field Value

The changes.

See Also

ItemSavingEventArgs Class
Sitecore.Data.Events Namespace


Item Property

[image]

Sitecore 6.4.1 API
ItemSavingEventArgs..::..Item Property
ItemSavingEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Item { get; }
Visual Basic
Public ReadOnly Property Item As Item
    Get
Visual C++
public:
property Item^ Item {
    Item^ get ();
}

Field Value

The item.

See Also

ItemSavingEventArgs Class
Sitecore.Data.Events Namespace


ItemSortorderChangedDelegate Delegate

[image]

Sitecore 6.4.1 API
ItemSortorderChangedDelegate Delegate
See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public delegate void ItemSortorderChangedDelegate(
    Object sender,
    ItemSortorderChangedEventArgs args
)
Visual Basic
Public Delegate Sub ItemSortorderChangedDelegate ( _
    sender As Object, _
    args As ItemSortorderChangedEventArgs _
)
Visual C++
public delegate void ItemSortorderChangedDelegate(
    Object^ sender,
    ItemSortorderChangedEventArgs^ args
)

Parameters

sender
Type: System..::..Object
args
Type: Sitecore.Data.Events..::..ItemSortorderChangedEventArgs

Remarks

When you create a ItemSortorderChangedDelegate delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

See Also

Sitecore.Data.Events Namespace


ItemSortorderChangedEventArgs Class

[image]

Sitecore 6.4.1 API
ItemSortorderChangedEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemSortorderChangedEventArgs
Visual Basic
Public Class ItemSortorderChangedEventArgs
Visual C++
public ref class ItemSortorderChangedEventArgs

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Events..::..ItemSortorderChangedEventArgs

See Also

ItemSortorderChangedEventArgs Members
Sitecore.Data.Events Namespace


ItemSortorderChangedEventArgs Members

[image] [image]

Sitecore 6.4.1 API
ItemSortorderChangedEventArgs Members
ItemSortorderChangedEventArgs Class Constructors Methods Properties See Also Send Feedback

The ItemSortorderChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ItemSortorderChangedEventArgs | Creates a new ItemSortorderChangedEventArgs instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | Gets the item.
Public property | OldSortorder | Gets the old sortorder.

See Also

ItemSortorderChangedEventArgs Class
Sitecore.Data.Events Namespace


ItemSortorderChangedEventArgs Constructor

[image]

Sitecore 6.4.1 API
ItemSortorderChangedEventArgs Constructor
ItemSortorderChangedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemSortorderChangedEventArgs(
    Item item,
    string oldSortorder
)
Visual Basic
Public Sub New ( _
    item As Item, _
    oldSortorder As String _
)
Visual C++
public:
ItemSortorderChangedEventArgs(
    Item^ item,
    String^ oldSortorder
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
Item.
oldSortorder
Type: System..::..String
Old sortorder.

See Also

ItemSortorderChangedEventArgs Class
Sitecore.Data.Events Namespace


ItemSortorderChangedEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
ItemSortorderChangedEventArgs Properties
ItemSortorderChangedEventArgs Class See Also Send Feedback

The ItemSortorderChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets the item.
Public property | OldSortorder | Gets the old sortorder.

See Also

ItemSortorderChangedEventArgs Class
Sitecore.Data.Events Namespace


Item Property

[image]

Sitecore 6.4.1 API
ItemSortorderChangedEventArgs..::..Item Property
ItemSortorderChangedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Item { get; }
Visual Basic
Public ReadOnly Property Item As Item
    Get
Visual C++
public:
property Item^ Item {
    Item^ get ();
}

Field Value

The item.

See Also

ItemSortorderChangedEventArgs Class
Sitecore.Data.Events Namespace


OldSortorder Property

[image]

Sitecore 6.4.1 API
ItemSortorderChangedEventArgs..::..OldSortorder Property
ItemSortorderChangedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object OldSortorder { get; }
Visual Basic
Public ReadOnly Property OldSortorder As Object
    Get
Visual C++
public:
property Object^ OldSortorder {
    Object^ get ();
}

Field Value

The old sortorder.

See Also

ItemSortorderChangedEventArgs Class
Sitecore.Data.Events Namespace


ItemTemplateChangedRemoteEventArgs Class

[image]

Sitecore 6.4.1 API
ItemTemplateChangedRemoteEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemTemplateChangedRemoteEventArgs : EventArgs,
    IPassNativeEventArgs
Visual Basic
Public Class ItemTemplateChangedRemoteEventArgs _
    Inherits EventArgs _
    Implements IPassNativeEventArgs
Visual C++
public ref class ItemTemplateChangedRemoteEventArgs : public EventArgs,
    IPassNativeEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Data.Events..::..ItemTemplateChangedRemoteEventArgs

See Also

ItemTemplateChangedRemoteEventArgs Members
Sitecore.Data.Events Namespace


ItemTemplateChangedRemoteEventArgs Members

[image] [image]

Sitecore 6.4.1 API
ItemTemplateChangedRemoteEventArgs Members
ItemTemplateChangedRemoteEventArgs Class Constructors Methods Properties See Also Send Feedback

The ItemTemplateChangedRemoteEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ItemTemplateChangedRemoteEventArgs | Initializes a new instance of the ItemTemplateChangedRemoteEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | Gets or sets Item.

See Also

ItemTemplateChangedRemoteEventArgs Class
Sitecore.Data.Events Namespace


ItemTemplateChangedRemoteEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
ItemTemplateChangedRemoteEventArgs Properties
ItemTemplateChangedRemoteEventArgs Class See Also Send Feedback

The ItemTemplateChangedRemoteEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets or sets Item.

See Also

ItemTemplateChangedRemoteEventArgs Class
Sitecore.Data.Events Namespace


Item Property

[image]

Sitecore 6.4.1 API
ItemTemplateChangedRemoteEventArgs..::..Item Property
ItemTemplateChangedRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Item { get; protected set; }
Visual Basic
Public Property Item As Item
    Get
    Protected Set
Visual C++
public:
property Item^ Item {
    Item^ get ();
    protected: void set (Item^ value);
}

See Also

ItemTemplateChangedRemoteEventArgs Class
Sitecore.Data.Events Namespace


ItemUnlockedRemoteEventArgs Class

[image]

Sitecore 6.4.1 API
ItemUnlockedRemoteEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemUnlockedRemoteEventArgs : EventArgs,
    IPassNativeEventArgs
Visual Basic
Public Class ItemUnlockedRemoteEventArgs _
    Inherits EventArgs _
    Implements IPassNativeEventArgs
Visual C++
public ref class ItemUnlockedRemoteEventArgs : public EventArgs,
    IPassNativeEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Data.Events..::..ItemUnlockedRemoteEventArgs

See Also

ItemUnlockedRemoteEventArgs Members
Sitecore.Data.Events Namespace


ItemUnlockedRemoteEventArgs Members

[image] [image]

Sitecore 6.4.1 API
ItemUnlockedRemoteEventArgs Members
ItemUnlockedRemoteEventArgs Class Constructors Methods Properties See Also Send Feedback

The ItemUnlockedRemoteEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ItemUnlockedRemoteEventArgs | Initializes a new instance of the ItemUnlockedRemoteEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | Gets or sets Item.

See Also

ItemUnlockedRemoteEventArgs Class
Sitecore.Data.Events Namespace


ItemUnlockedRemoteEventArgs Constructor

[image]

Sitecore 6.4.1 API
ItemUnlockedRemoteEventArgs Constructor
ItemUnlockedRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemUnlockedRemoteEventArgs(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
ItemUnlockedRemoteEventArgs(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

ItemUnlockedRemoteEventArgs Class
Sitecore.Data.Events Namespace


ItemUnlockedRemoteEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
ItemUnlockedRemoteEventArgs Methods
ItemUnlockedRemoteEventArgs Class See Also Send Feedback

The ItemUnlockedRemoteEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemUnlockedRemoteEventArgs Class
Sitecore.Data.Events Namespace


ItemUnlockedRemoteEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
ItemUnlockedRemoteEventArgs Properties
ItemUnlockedRemoteEventArgs Class See Also Send Feedback

The ItemUnlockedRemoteEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets or sets Item.

See Also

ItemUnlockedRemoteEventArgs Class
Sitecore.Data.Events Namespace


PublishEndRemoteEventArgs Class

[image]

Sitecore 6.4.1 API
PublishEndRemoteEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PublishEndRemoteEventArgs : EventArgs,
    IPassNativeEventArgs
Visual Basic
Public Class PublishEndRemoteEventArgs _
    Inherits EventArgs _
    Implements IPassNativeEventArgs
Visual C++
public ref class PublishEndRemoteEventArgs : public EventArgs,
    IPassNativeEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Data.Events..::..PublishEndRemoteEventArgs

See Also

PublishEndRemoteEventArgs Members
Sitecore.Data.Events Namespace


PublishEndRemoteEventArgs Members

[image] [image]

Sitecore 6.4.1 API
PublishEndRemoteEventArgs Members
PublishEndRemoteEventArgs Class Constructors Methods Properties See Also Send Feedback

The PublishEndRemoteEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | PublishEndRemoteEventArgs | Initializes a new instance of the PublishEndRemoteEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CompareRevisions | Gets or sets a value indicating whether to compare revisions.
Public property | Deep | Gets or sets a value indicating whether this PublishEndRemoteEvent is deep.
Public property | FromDate | Gets or sets from date.
Public property | LanguageName | Gets or sets the name of the language.
Public property | Mode | Gets or sets the mode.
Public property | PublishDate | Gets or sets the publish date.
Public property | PublishingTargets | Gets or sets the publishing targets.
Public property | RepublishAll | Gets or sets a value indicating whether [republish all].
Public property | RootItemId | Gets or sets the root item id.
Public property | SourceDatabaseName | Gets or sets the name of the source database.
Public property | TargetDatabaseName | Gets or sets the name of the target database.

See Also

PublishEndRemoteEventArgs Class
Sitecore.Data.Events Namespace


PublishEndRemoteEventArgs Constructor

[image]

Sitecore 6.4.1 API
PublishEndRemoteEventArgs Constructor
PublishEndRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PublishEndRemoteEventArgs(
    PublishEndRemoteEvent event
)
Visual Basic
Public Sub New ( _
    event As PublishEndRemoteEvent _
)
Visual C++
public:
PublishEndRemoteEventArgs(
    PublishEndRemoteEvent^ event
)

Parameters

event
Type: Sitecore.Eventing.Remote..::..PublishEndRemoteEvent
The @event.

See Also

PublishEndRemoteEventArgs Class
Sitecore.Data.Events Namespace


PublishEndRemoteEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
PublishEndRemoteEventArgs Methods
PublishEndRemoteEventArgs Class See Also Send Feedback

The PublishEndRemoteEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PublishEndRemoteEventArgs Class
Sitecore.Data.Events Namespace


PublishEndRemoteEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
PublishEndRemoteEventArgs Properties
PublishEndRemoteEventArgs Class See Also Send Feedback

The PublishEndRemoteEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | CompareRevisions | Gets or sets a value indicating whether to compare revisions.
Public property | Deep | Gets or sets a value indicating whether this PublishEndRemoteEvent is deep.
Public property | FromDate | Gets or sets from date.
Public property | LanguageName | Gets or sets the name of the language.
Public property | Mode | Gets or sets the mode.
Public property | PublishDate | Gets or sets the publish date.
Public property | PublishingTargets | Gets or sets the publishing targets.
Public property | RepublishAll | Gets or sets a value indicating whether [republish all].
Public property | RootItemId | Gets or sets the root item id.
Public property | SourceDatabaseName | Gets or sets the name of the source database.
Public property | TargetDatabaseName | Gets or sets the name of the target database.

See Also

PublishEndRemoteEventArgs Class
Sitecore.Data.Events Namespace


CompareRevisions Property

[image]

Sitecore 6.4.1 API
PublishEndRemoteEventArgs..::..CompareRevisions Property
PublishEndRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool CompareRevisions { get; protected set; }
Visual Basic
Public Property CompareRevisions As Boolean
    Get
    Protected Set
Visual C++
public:
property bool CompareRevisions {
    bool get ();
    protected: void set (bool value);
}

Field Value

true if compare revisions; otherwise, false.

See Also

PublishEndRemoteEventArgs Class
Sitecore.Data.Events Namespace


FromDate Property

[image]

Sitecore 6.4.1 API
PublishEndRemoteEventArgs..::..FromDate Property
PublishEndRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime FromDate { get; protected set; }
Visual Basic
Public Property FromDate As DateTime
    Get
    Protected Set
Visual C++
public:
property DateTime FromDate {
    DateTime get ();
    protected: void set (DateTime value);
}

Field Value

From date.

See Also

PublishEndRemoteEventArgs Class
Sitecore.Data.Events Namespace


LanguageName Property

[image]

Sitecore 6.4.1 API
PublishEndRemoteEventArgs..::..LanguageName Property
PublishEndRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string LanguageName { get; protected set; }
Visual Basic
Public Property LanguageName As String
    Get
    Protected Set
Visual C++
public:
property String^ LanguageName {
    String^ get ();
    protected: void set (String^ value);
}

Field Value

The name of the language.

See Also

PublishEndRemoteEventArgs Class
Sitecore.Data.Events Namespace


Mode Property

[image]

Sitecore 6.4.1 API
PublishEndRemoteEventArgs..::..Mode Property
PublishEndRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PublishMode Mode { get; protected set; }
Visual Basic
Public Property Mode As PublishMode
    Get
    Protected Set
Visual C++
public:
property PublishMode Mode {
    PublishMode get ();
    protected: void set (PublishMode value);
}

Field Value

The mode.

See Also

PublishEndRemoteEventArgs Class
Sitecore.Data.Events Namespace


PublishDate Property

[image]

Sitecore 6.4.1 API
PublishEndRemoteEventArgs..::..PublishDate Property
PublishEndRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime PublishDate { get; protected set; }
Visual Basic
Public Property PublishDate As DateTime
    Get
    Protected Set
Visual C++
public:
property DateTime PublishDate {
    DateTime get ();
    protected: void set (DateTime value);
}

Field Value

The publish date.

See Also

PublishEndRemoteEventArgs Class
Sitecore.Data.Events Namespace


PublishingTargets Property

[image]

Sitecore 6.4.1 API
PublishEndRemoteEventArgs..::..PublishingTargets Property
PublishEndRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public List<string> PublishingTargets { get; protected set; }
Visual Basic
Public Property PublishingTargets As List(Of String)
    Get
    Protected Set
Visual C++
public:
property List<String^>^ PublishingTargets {
    List<String^>^ get ();
    protected: void set (List<String^>^ value);
}

Field Value

The publishing targets.

See Also

PublishEndRemoteEventArgs Class
Sitecore.Data.Events Namespace


RepublishAll Property

[image]

Sitecore 6.4.1 API
PublishEndRemoteEventArgs..::..RepublishAll Property
PublishEndRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool RepublishAll { get; protected set; }
Visual Basic
Public Property RepublishAll As Boolean
    Get
    Protected Set
Visual C++
public:
property bool RepublishAll {
    bool get ();
    protected: void set (bool value);
}

Field Value

true if [republish all]; otherwise, false.

See Also

PublishEndRemoteEventArgs Class
Sitecore.Data.Events Namespace


RootItemId Property

[image]

Sitecore 6.4.1 API
PublishEndRemoteEventArgs..::..RootItemId Property
PublishEndRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Guid RootItemId { get; protected set; }
Visual Basic
Public Property RootItemId As Guid
    Get
    Protected Set
Visual C++
public:
property Guid RootItemId {
    Guid get ();
    protected: void set (Guid value);
}

Field Value

The root item id.

See Also

PublishEndRemoteEventArgs Class
Sitecore.Data.Events Namespace


SourceDatabaseName Property

[image]

Sitecore 6.4.1 API
PublishEndRemoteEventArgs..::..SourceDatabaseName Property
PublishEndRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string SourceDatabaseName { get; protected set; }
Visual Basic
Public Property SourceDatabaseName As String
    Get
    Protected Set
Visual C++
public:
property String^ SourceDatabaseName {
    String^ get ();
    protected: void set (String^ value);
}

Field Value

The name of the source database.

See Also

PublishEndRemoteEventArgs Class
Sitecore.Data.Events Namespace


TargetDatabaseName Property

[image]

Sitecore 6.4.1 API
PublishEndRemoteEventArgs..::..TargetDatabaseName Property
PublishEndRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string TargetDatabaseName { get; protected set; }
Visual Basic
Public Property TargetDatabaseName As String
    Get
    Protected Set
Visual C++
public:
property String^ TargetDatabaseName {
    String^ get ();
    protected: void set (String^ value);
}

Field Value

The name of the target database.

See Also

PublishEndRemoteEventArgs Class
Sitecore.Data.Events Namespace


RemoteEventArgs(TEvent) Class

[image]

Sitecore 6.4.1 API
RemoteEventArgs<(Of <(<'TEvent>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RemoteEventArgs<TEvent> : EventArgs,
    IPassNativeEventArgs
Visual Basic
Public Class RemoteEventArgs(Of TEvent) _
    Inherits EventArgs _
    Implements IPassNativeEventArgs
Visual C++
generic<typename TEvent>
public ref class RemoteEventArgs : public EventArgs,
    IPassNativeEventArgs

Type Parameters

TEvent
The type of the event.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Data.Events..::..RemoteEventArgs<(Of <(<'TEvent>)>)>

See Also

RemoteEventArgs<(Of <(<'TEvent>)>)> Members
Sitecore.Data.Events Namespace


RemoteEventArgs(TEvent) Members

[image] [image]

Sitecore 6.4.1 API
RemoteEventArgs<(Of <(<'TEvent>)>)> Members
RemoteEventArgs<(Of <(<'TEvent>)>)> Class Constructors Methods Properties See Also Send Feedback

The RemoteEventArgs<(Of <(<'TEvent>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | RemoteEventArgs<(Of <(<'TEvent>)>)> | Initializes a new instance of the RemoteEventArgs<(Of <(<'TEvent>)>)> class. Initializes a new instance of the RemoteEventArgs<(Of <(<'TEvent>)>)> class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Event | Gets or sets the event.

See Also

RemoteEventArgs<(Of <(<'TEvent>)>)> Class
Sitecore.Data.Events Namespace


RemoteEventArgs(TEvent) Constructor

[image]

Sitecore 6.4.1 API
RemoteEventArgs<(Of <(<'TEvent>)>)> Constructor
RemoteEventArgs<(Of <(<'TEvent>)>)> Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RemoteEventArgs(
    TEvent event
)
Visual Basic
Public Sub New ( _
    event As TEvent _
)
Visual C++
public:
RemoteEventArgs(
    TEvent event
)

Parameters

event
Type: TEvent
The @event.

See Also

RemoteEventArgs<(Of <(<'TEvent>)>)> Class
Sitecore.Data.Events Namespace


RemoteEventArgs(TEvent) Methods

[image] [image]

Sitecore 6.4.1 API
RemoteEventArgs<(Of <(<'TEvent>)>)> Methods
RemoteEventArgs<(Of <(<'TEvent>)>)> Class See Also Send Feedback

The RemoteEventArgs<(Of <(<'TEvent>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RemoteEventArgs<(Of <(<'TEvent>)>)> Class
Sitecore.Data.Events Namespace


RemoteEventArgs(TEvent) Properties

[image] [image]

Sitecore 6.4.1 API
RemoteEventArgs<(Of <(<'TEvent>)>)> Properties
RemoteEventArgs<(Of <(<'TEvent>)>)> Class See Also Send Feedback

The RemoteEventArgs<(Of <(<'TEvent>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Event | Gets or sets the event.

See Also

RemoteEventArgs<(Of <(<'TEvent>)>)> Class
Sitecore.Data.Events Namespace


Event Property

[image]

Sitecore 6.4.1 API
RemoteEventArgs<(Of <(<'TEvent>)>)>..::..Event Property
RemoteEventArgs<(Of <(<'TEvent>)>)> Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TEvent Event { get; protected set; }
Visual Basic
Public Property Event As TEvent
    Get
    Protected Set
Visual C++
public:
property TEvent Event {
    TEvent get ();
    protected: void set (TEvent value);
}

Field Value

The event.

See Also

RemoteEventArgs<(Of <(<'TEvent>)>)> Class
Sitecore.Data.Events Namespace


RemovedDataRemoteEventArgs Class

[image]

Sitecore 6.4.1 API
RemovedDataRemoteEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RemovedDataRemoteEventArgs : EventArgs,
    IPassNativeEventArgs
Visual Basic
Public Class RemovedDataRemoteEventArgs _
    Inherits EventArgs _
    Implements IPassNativeEventArgs
Visual C++
public ref class RemovedDataRemoteEventArgs : public EventArgs,
    IPassNativeEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Data.Events..::..RemovedDataRemoteEventArgs

See Also

RemovedDataRemoteEventArgs Members
Sitecore.Data.Events Namespace


RemovedDataRemoteEventArgs Members

[image] [image]

Sitecore 6.4.1 API
RemovedDataRemoteEventArgs Members
RemovedDataRemoteEventArgs Class Constructors Methods Properties See Also Send Feedback

The RemovedDataRemoteEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | RemovedDataRemoteEventArgs | Initializes a new instance of the RemovedDataRemoteEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ItemId | Gets or sets ItemId.
Public property | Language | Gets or sets Language.
Public property | RemoveAllLanguages | Gets or sets a value indicating whether RemoveAllLanguages.
Public property | RemoveSharedData | Gets or sets a value indicating whether RemoveSharedData.

See Also

RemovedDataRemoteEventArgs Class
Sitecore.Data.Events Namespace


RemovedDataRemoteEventArgs Constructor

[image]

Sitecore 6.4.1 API
RemovedDataRemoteEventArgs Constructor
RemovedDataRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RemovedDataRemoteEventArgs(
    ID itemId,
    Language language,
    bool removeAllLanguages,
    bool removeSharedData
)
Visual Basic
Public Sub New ( _
    itemId As ID, _
    language As Language, _
    removeAllLanguages As Boolean, _
    removeSharedData As Boolean _
)
Visual C++
public:
RemovedDataRemoteEventArgs(
    ID^ itemId,
    Language^ language,
    bool removeAllLanguages,
    bool removeSharedData
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item Id.
language
Type: Sitecore.Globalization..::..Language
The language.
removeAllLanguages
Type: System..::..Boolean
The remove All Languages.
removeSharedData
Type: System..::..Boolean
The remove Shared Data.

See Also

RemovedDataRemoteEventArgs Class
Sitecore.Data.Events Namespace


RemovedDataRemoteEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
RemovedDataRemoteEventArgs Methods
RemovedDataRemoteEventArgs Class See Also Send Feedback

The RemovedDataRemoteEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RemovedDataRemoteEventArgs Class
Sitecore.Data.Events Namespace


RemovedDataRemoteEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
RemovedDataRemoteEventArgs Properties
RemovedDataRemoteEventArgs Class See Also Send Feedback

The RemovedDataRemoteEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ItemId | Gets or sets ItemId.
Public property | Language | Gets or sets Language.
Public property | RemoveAllLanguages | Gets or sets a value indicating whether RemoveAllLanguages.
Public property | RemoveSharedData | Gets or sets a value indicating whether RemoveSharedData.

See Also

RemovedDataRemoteEventArgs Class
Sitecore.Data.Events Namespace


ItemId Property

[image]

Sitecore 6.4.1 API
RemovedDataRemoteEventArgs..::..ItemId Property
RemovedDataRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ItemId { get; protected set; }
Visual Basic
Public Property ItemId As ID
    Get
    Protected Set
Visual C++
public:
property ID^ ItemId {
    ID^ get ();
    protected: void set (ID^ value);
}

See Also

RemovedDataRemoteEventArgs Class
Sitecore.Data.Events Namespace


Language Property

[image]

Sitecore 6.4.1 API
RemovedDataRemoteEventArgs..::..Language Property
RemovedDataRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Language Language { get; protected set; }
Visual Basic
Public Property Language As Language
    Get
    Protected Set
Visual C++
public:
property Language^ Language {
    Language^ get ();
    protected: void set (Language^ value);
}

See Also

RemovedDataRemoteEventArgs Class
Sitecore.Data.Events Namespace


RemoveAllLanguages Property

[image]

Sitecore 6.4.1 API
RemovedDataRemoteEventArgs..::..RemoveAllLanguages Property
RemovedDataRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool RemoveAllLanguages { get; protected set; }
Visual Basic
Public Property RemoveAllLanguages As Boolean
    Get
    Protected Set
Visual C++
public:
property bool RemoveAllLanguages {
    bool get ();
    protected: void set (bool value);
}

See Also

RemovedDataRemoteEventArgs Class
Sitecore.Data.Events Namespace


RemoveSharedData Property

[image]

Sitecore 6.4.1 API
RemovedDataRemoteEventArgs..::..RemoveSharedData Property
RemovedDataRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool RemoveSharedData { get; protected set; }
Visual Basic
Public Property RemoveSharedData As Boolean
    Get
    Protected Set
Visual C++
public:
property bool RemoveSharedData {
    bool get ();
    protected: void set (bool value);
}

See Also

RemovedDataRemoteEventArgs Class
Sitecore.Data.Events Namespace


ResolvePathEventArgs Class

[image]

Sitecore 6.4.1 API
ResolvePathEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ResolvePathEventArgs : CancelEventArgs
Visual Basic
Public Class ResolvePathEventArgs _
    Inherits CancelEventArgs
Visual C++
public ref class ResolvePathEventArgs : public CancelEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..CancelEventArgs
Sitecore.Data.Events..::..ResolvePathEventArgs

See Also

ResolvePathEventArgs Members
Sitecore.Data.Events Namespace


ResolvePathEventArgs Members

[image] [image]

Sitecore 6.4.1 API
ResolvePathEventArgs Members
ResolvePathEventArgs Class Constructors Methods Properties See Also Send Feedback

The ResolvePathEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ResolvePathEventArgs | Creates a new ResolvePathEventArgs instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | CustomResult | Gets or sets the custom result.
Public property | Path | Gets the path.

See Also

ResolvePathEventArgs Class
Sitecore.Data.Events Namespace


ResolvePathEventArgs Constructor

[image]

Sitecore 6.4.1 API
ResolvePathEventArgs Constructor
ResolvePathEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ResolvePathEventArgs(
    string path
)
Visual Basic
Public Sub New ( _
    path As String _
)
Visual C++
public:
ResolvePathEventArgs(
    String^ path
)

Parameters

path
Type: System..::..String
Path.

See Also

ResolvePathEventArgs Class
Sitecore.Data.Events Namespace


ResolvePathEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
ResolvePathEventArgs Methods
ResolvePathEventArgs Class See Also Send Feedback

The ResolvePathEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ResolvePathEventArgs Class
Sitecore.Data.Events Namespace


ResolvePathEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
ResolvePathEventArgs Properties
ResolvePathEventArgs Class See Also Send Feedback

The ResolvePathEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | CustomResult | Gets or sets the custom result.
Public property | Path | Gets the path.

See Also

ResolvePathEventArgs Class
Sitecore.Data.Events Namespace


CustomResult Property

[image]

Sitecore 6.4.1 API
ResolvePathEventArgs..::..CustomResult Property
ResolvePathEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID CustomResult { get; set; }
Visual Basic
Public Property CustomResult As ID
    Get
    Set
Visual C++
public:
property ID^ CustomResult {
    ID^ get ();
    void set (ID^ value);
}

Field Value

The custom result.

See Also

ResolvePathEventArgs Class
Sitecore.Data.Events Namespace


Path Property

[image]

Sitecore 6.4.1 API
ResolvePathEventArgs..::..Path Property
ResolvePathEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Path { get; }
Visual Basic
Public ReadOnly Property Path As String
    Get
Visual C++
public:
property String^ Path {
    String^ get ();
}

Field Value

The path.

See Also

ResolvePathEventArgs Class
Sitecore.Data.Events Namespace


RoleCreatedRemoteEventArgs Members

[image] [image]

Sitecore 6.4.1 API
RoleCreatedRemoteEventArgs Members
RoleCreatedRemoteEventArgs Class Constructors Methods Properties See Also Send Feedback

The RoleCreatedRemoteEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | RoleCreatedRemoteEventArgs | Initializes a new instance of the RoleCreatedRemoteEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | RoleName | Gets or sets RoleName.

See Also

RoleCreatedRemoteEventArgs Class
Sitecore.Data.Events Namespace


RoleCreatedRemoteEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
RoleCreatedRemoteEventArgs Methods
RoleCreatedRemoteEventArgs Class See Also Send Feedback

The RoleCreatedRemoteEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoleCreatedRemoteEventArgs Class
Sitecore.Data.Events Namespace


RoleCreatedRemoteEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
RoleCreatedRemoteEventArgs Properties
RoleCreatedRemoteEventArgs Class See Also Send Feedback

The RoleCreatedRemoteEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | RoleName | Gets or sets RoleName.

See Also

RoleCreatedRemoteEventArgs Class
Sitecore.Data.Events Namespace


RoleName Property

[image]

Sitecore 6.4.1 API
RoleCreatedRemoteEventArgs..::..RoleName Property
RoleCreatedRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string RoleName { get; protected set; }
Visual Basic
Public Property RoleName As String
    Get
    Protected Set
Visual C++
public:
property String^ RoleName {
    String^ get ();
    protected: void set (String^ value);
}

See Also

RoleCreatedRemoteEventArgs Class
Sitecore.Data.Events Namespace


RoleDeletedRemoteEventArgs Class

[image]

Sitecore 6.4.1 API
RoleDeletedRemoteEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RoleDeletedRemoteEventArgs : EventArgs,
    IPassNativeEventArgs
Visual Basic
Public Class RoleDeletedRemoteEventArgs _
    Inherits EventArgs _
    Implements IPassNativeEventArgs
Visual C++
public ref class RoleDeletedRemoteEventArgs : public EventArgs,
    IPassNativeEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Data.Events..::..RoleDeletedRemoteEventArgs

See Also

RoleDeletedRemoteEventArgs Members
Sitecore.Data.Events Namespace


RoleDeletedRemoteEventArgs Members

[image] [image]

Sitecore 6.4.1 API
RoleDeletedRemoteEventArgs Members
RoleDeletedRemoteEventArgs Class Constructors Methods Properties See Also Send Feedback

The RoleDeletedRemoteEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | RoleDeletedRemoteEventArgs | Initializes a new instance of the RoleDeletedRemoteEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | RoleName | Gets or sets RoleName.

See Also

RoleDeletedRemoteEventArgs Class
Sitecore.Data.Events Namespace


RoleDeletedRemoteEventArgs Constructor

[image]

Sitecore 6.4.1 API
RoleDeletedRemoteEventArgs Constructor
RoleDeletedRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RoleDeletedRemoteEventArgs(
    string roleName
)
Visual Basic
Public Sub New ( _
    roleName As String _
)
Visual C++
public:
RoleDeletedRemoteEventArgs(
    String^ roleName
)

Parameters

roleName
Type: System..::..String
Name of the role.

See Also

RoleDeletedRemoteEventArgs Class
Sitecore.Data.Events Namespace


RoleDeletedRemoteEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
RoleDeletedRemoteEventArgs Methods
RoleDeletedRemoteEventArgs Class See Also Send Feedback

The RoleDeletedRemoteEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoleDeletedRemoteEventArgs Class
Sitecore.Data.Events Namespace


RoleDeletedRemoteEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
RoleDeletedRemoteEventArgs Properties
RoleDeletedRemoteEventArgs Class See Also Send Feedback

The RoleDeletedRemoteEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | RoleName | Gets or sets RoleName.

See Also

RoleDeletedRemoteEventArgs Class
Sitecore.Data.Events Namespace


RoleName Property

[image]

Sitecore 6.4.1 API
RoleDeletedRemoteEventArgs..::..RoleName Property
RoleDeletedRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string RoleName { get; protected set; }
Visual Basic
Public Property RoleName As String
    Get
    Protected Set
Visual C++
public:
property String^ RoleName {
    String^ get ();
    protected: void set (String^ value);
}

See Also

RoleDeletedRemoteEventArgs Class
Sitecore.Data.Events Namespace


RoleRelationsRemovedRemoteEventArgs Class

[image]

Sitecore 6.4.1 API
RoleRelationsRemovedRemoteEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RoleRelationsRemovedRemoteEventArgs
Visual Basic
Public Class RoleRelationsRemovedRemoteEventArgs
Visual C++
public ref class RoleRelationsRemovedRemoteEventArgs

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Events..::..RoleRelationsRemovedRemoteEventArgs

See Also

RoleRelationsRemovedRemoteEventArgs Members
Sitecore.Data.Events Namespace


RoleRelationsRemovedRemoteEventArgs Members

[image] [image]

Sitecore 6.4.1 API
RoleRelationsRemovedRemoteEventArgs Members
RoleRelationsRemovedRemoteEventArgs Class Constructors Methods Properties See Also Send Feedback

The RoleRelationsRemovedRemoteEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | RoleRelationsRemovedRemoteEventArgs | Initializes a new instance of the RoleRelationsRemovedRemoteEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | RoleName | Gets or sets RoleName.

See Also

RoleRelationsRemovedRemoteEventArgs Class
Sitecore.Data.Events Namespace


RoleRelationsRemovedRemoteEventArgs Constructor

[image]

Sitecore 6.4.1 API
RoleRelationsRemovedRemoteEventArgs Constructor
RoleRelationsRemovedRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RoleRelationsRemovedRemoteEventArgs(
    string roleName
)
Visual Basic
Public Sub New ( _
    roleName As String _
)
Visual C++
public:
RoleRelationsRemovedRemoteEventArgs(
    String^ roleName
)

Parameters

roleName
Type: System..::..String
Name of the role.

See Also

RoleRelationsRemovedRemoteEventArgs Class
Sitecore.Data.Events Namespace


RoleRelationsRemovedRemoteEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
RoleRelationsRemovedRemoteEventArgs Methods
RoleRelationsRemovedRemoteEventArgs Class See Also Send Feedback

The RoleRelationsRemovedRemoteEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoleRelationsRemovedRemoteEventArgs Class
Sitecore.Data.Events Namespace


RoleRelationsRemovedRemoteEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
RoleRelationsRemovedRemoteEventArgs Properties
RoleRelationsRemovedRemoteEventArgs Class See Also Send Feedback

The RoleRelationsRemovedRemoteEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | RoleName | Gets or sets RoleName.

See Also

RoleRelationsRemovedRemoteEventArgs Class
Sitecore.Data.Events Namespace


RoleName Property

[image]

Sitecore 6.4.1 API
RoleRelationsRemovedRemoteEventArgs..::..RoleName Property
RoleRelationsRemovedRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string RoleName { get; protected set; }
Visual Basic
Public Property RoleName As String
    Get
    Protected Set
Visual C++
public:
property String^ RoleName {
    String^ get ();
    protected: void set (String^ value);
}

Field Value

The role name.

See Also

RoleRelationsRemovedRemoteEventArgs Class
Sitecore.Data.Events Namespace


RolesAddedToRolesRemoteEventArgs Class

[image]

Sitecore 6.4.1 API
RolesAddedToRolesRemoteEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RolesAddedToRolesRemoteEventArgs
Visual Basic
Public Class RolesAddedToRolesRemoteEventArgs
Visual C++
public ref class RolesAddedToRolesRemoteEventArgs

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Events..::..RolesAddedToRolesRemoteEventArgs

See Also

RolesAddedToRolesRemoteEventArgs Members
Sitecore.Data.Events Namespace


RolesAddedToRolesRemoteEventArgs Members

[image] [image]

Sitecore 6.4.1 API
RolesAddedToRolesRemoteEventArgs Members
RolesAddedToRolesRemoteEventArgs Class Constructors Methods Properties See Also Send Feedback

The RolesAddedToRolesRemoteEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | RolesAddedToRolesRemoteEventArgs | Initializes a new instance of the RolesAddedToRolesRemoteEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | MemberRoles | Gets or sets MemberRoles.
Public property | TargetRoles | Gets or sets TargetRoles.

See Also

RolesAddedToRolesRemoteEventArgs Class
Sitecore.Data.Events Namespace


RolesAddedToRolesRemoteEventArgs Constructor

[image]

Sitecore 6.4.1 API
RolesAddedToRolesRemoteEventArgs Constructor
RolesAddedToRolesRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RolesAddedToRolesRemoteEventArgs(
    IEnumerable<Role> memberRoles,
    IEnumerable<Role> targetRoles
)
Visual Basic
Public Sub New ( _
    memberRoles As IEnumerable(Of Role), _
    targetRoles As IEnumerable(Of Role) _
)
Visual C++
public:
RolesAddedToRolesRemoteEventArgs(
    IEnumerable<Role^>^ memberRoles,
    IEnumerable<Role^>^ targetRoles
)

Parameters

memberRoles
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Role >)>)>
The member roles.
targetRoles
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Role >)>)>
The target roles.

See Also

RolesAddedToRolesRemoteEventArgs Class
Sitecore.Data.Events Namespace


RolesAddedToRolesRemoteEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
RolesAddedToRolesRemoteEventArgs Methods
RolesAddedToRolesRemoteEventArgs Class See Also Send Feedback

The RolesAddedToRolesRemoteEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RolesAddedToRolesRemoteEventArgs Class
Sitecore.Data.Events Namespace


RolesAddedToRolesRemoteEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
RolesAddedToRolesRemoteEventArgs Properties
RolesAddedToRolesRemoteEventArgs Class See Also Send Feedback

The RolesAddedToRolesRemoteEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | MemberRoles | Gets or sets MemberRoles.
Public property | TargetRoles | Gets or sets TargetRoles.

See Also

RolesAddedToRolesRemoteEventArgs Class
Sitecore.Data.Events Namespace


TargetRoles Property

[image]

Sitecore 6.4.1 API
RolesAddedToRolesRemoteEventArgs..::..TargetRoles Property
RolesAddedToRolesRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IEnumerable<Role> TargetRoles { get; protected set; }
Visual Basic
Public Property TargetRoles As IEnumerable(Of Role)
    Get
    Protected Set
Visual C++
public:
property IEnumerable<Role^>^ TargetRoles {
    IEnumerable<Role^>^ get ();
    protected: void set (IEnumerable<Role^>^ value);
}

Field Value

The target roles.

See Also

RolesAddedToRolesRemoteEventArgs Class
Sitecore.Data.Events Namespace


RolesRemovedFromRolesRemoteEventArgs Class

[image]

Sitecore 6.4.1 API
RolesRemovedFromRolesRemoteEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RolesRemovedFromRolesRemoteEventArgs
Visual Basic
Public Class RolesRemovedFromRolesRemoteEventArgs
Visual C++
public ref class RolesRemovedFromRolesRemoteEventArgs

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Events..::..RolesRemovedFromRolesRemoteEventArgs

See Also

RolesRemovedFromRolesRemoteEventArgs Members
Sitecore.Data.Events Namespace


RolesRemovedFromRolesRemoteEventArgs Members

[image] [image]

Sitecore 6.4.1 API
RolesRemovedFromRolesRemoteEventArgs Members
RolesRemovedFromRolesRemoteEventArgs Class Constructors Methods Properties See Also Send Feedback

The RolesRemovedFromRolesRemoteEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | RolesRemovedFromRolesRemoteEventArgs | Initializes a new instance of the RolesRemovedFromRolesRemoteEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | MemberRoles | Gets or sets MemberRoles.
Public property | TargetRoles | Gets or sets TargetRoles.

See Also

RolesRemovedFromRolesRemoteEventArgs Class
Sitecore.Data.Events Namespace


RolesRemovedFromRolesRemoteEventArgs Constructor

[image]

Sitecore 6.4.1 API
RolesRemovedFromRolesRemoteEventArgs Constructor
RolesRemovedFromRolesRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RolesRemovedFromRolesRemoteEventArgs(
    IEnumerable<Role> memberRoles,
    IEnumerable<Role> targetRoles
)
Visual Basic
Public Sub New ( _
    memberRoles As IEnumerable(Of Role), _
    targetRoles As IEnumerable(Of Role) _
)
Visual C++
public:
RolesRemovedFromRolesRemoteEventArgs(
    IEnumerable<Role^>^ memberRoles,
    IEnumerable<Role^>^ targetRoles
)

Parameters

memberRoles
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Role >)>)>
The member roles.
targetRoles
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Role >)>)>
The target roles.

See Also

RolesRemovedFromRolesRemoteEventArgs Class
Sitecore.Data.Events Namespace


RolesRemovedFromRolesRemoteEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
RolesRemovedFromRolesRemoteEventArgs Methods
RolesRemovedFromRolesRemoteEventArgs Class See Also Send Feedback

The RolesRemovedFromRolesRemoteEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RolesRemovedFromRolesRemoteEventArgs Class
Sitecore.Data.Events Namespace


RolesRemovedFromRolesRemoteEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
RolesRemovedFromRolesRemoteEventArgs Properties
RolesRemovedFromRolesRemoteEventArgs Class See Also Send Feedback

The RolesRemovedFromRolesRemoteEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | MemberRoles | Gets or sets MemberRoles.
Public property | TargetRoles | Gets or sets TargetRoles.

See Also

RolesRemovedFromRolesRemoteEventArgs Class
Sitecore.Data.Events Namespace


MemberRoles Property

[image]

Sitecore 6.4.1 API
RolesRemovedFromRolesRemoteEventArgs..::..MemberRoles Property
RolesRemovedFromRolesRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IEnumerable<Role> MemberRoles { get; protected set; }
Visual Basic
Public Property MemberRoles As IEnumerable(Of Role)
    Get
    Protected Set
Visual C++
public:
property IEnumerable<Role^>^ MemberRoles {
    IEnumerable<Role^>^ get ();
    protected: void set (IEnumerable<Role^>^ value);
}

Field Value

The member roles.

See Also

RolesRemovedFromRolesRemoteEventArgs Class
Sitecore.Data.Events Namespace


TargetRoles Property

[image]

Sitecore 6.4.1 API
RolesRemovedFromRolesRemoteEventArgs..::..TargetRoles Property
RolesRemovedFromRolesRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IEnumerable<Role> TargetRoles { get; protected set; }
Visual Basic
Public Property TargetRoles As IEnumerable(Of Role)
    Get
    Protected Set
Visual C++
public:
property IEnumerable<Role^>^ TargetRoles {
    IEnumerable<Role^>^ get ();
    protected: void set (IEnumerable<Role^>^ value);
}

Field Value

The target roles.

See Also

RolesRemovedFromRolesRemoteEventArgs Class
Sitecore.Data.Events Namespace


SecurableUpdatedRemoteEventArgs Class

[image]

Sitecore 6.4.1 API
SecurableUpdatedRemoteEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SecurableUpdatedRemoteEventArgs : EventArgs,
    IPassNativeEventArgs
Visual Basic
Public Class SecurableUpdatedRemoteEventArgs _
    Inherits EventArgs _
    Implements IPassNativeEventArgs
Visual C++
public ref class SecurableUpdatedRemoteEventArgs : public EventArgs,
    IPassNativeEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Data.Events..::..SecurableUpdatedRemoteEventArgs

See Also

SecurableUpdatedRemoteEventArgs Members
Sitecore.Data.Events Namespace


SecurableUpdatedRemoteEventArgs Members

[image] [image]

Sitecore 6.4.1 API
SecurableUpdatedRemoteEventArgs Members
SecurableUpdatedRemoteEventArgs Class Constructors Methods Properties See Also Send Feedback

The SecurableUpdatedRemoteEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | SecurableUpdatedRemoteEventArgs | Initializes a new instance of the SecurableUpdatedRemoteEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | TypeName | Gets or sets TypeName.
Public property | UniqueId | Gets or sets UniqueId.

See Also

SecurableUpdatedRemoteEventArgs Class
Sitecore.Data.Events Namespace


SecurableUpdatedRemoteEventArgs Constructor

[image]

Sitecore 6.4.1 API
SecurableUpdatedRemoteEventArgs Constructor
SecurableUpdatedRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SecurableUpdatedRemoteEventArgs(
    string uniqueId,
    string typeName
)
Visual Basic
Public Sub New ( _
    uniqueId As String, _
    typeName As String _
)
Visual C++
public:
SecurableUpdatedRemoteEventArgs(
    String^ uniqueId,
    String^ typeName
)

Parameters

uniqueId
Type: System..::..String
The unique id.
typeName
Type: System..::..String
Name of the type.

See Also

SecurableUpdatedRemoteEventArgs Class
Sitecore.Data.Events Namespace


SecurableUpdatedRemoteEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
SecurableUpdatedRemoteEventArgs Methods
SecurableUpdatedRemoteEventArgs Class See Also Send Feedback

The SecurableUpdatedRemoteEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SecurableUpdatedRemoteEventArgs Class
Sitecore.Data.Events Namespace


SecurableUpdatedRemoteEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
SecurableUpdatedRemoteEventArgs Properties
SecurableUpdatedRemoteEventArgs Class See Also Send Feedback

The SecurableUpdatedRemoteEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | TypeName | Gets or sets TypeName.
Public property | UniqueId | Gets or sets UniqueId.

See Also

SecurableUpdatedRemoteEventArgs Class
Sitecore.Data.Events Namespace


UserCreatedRemoteEventArgs Class

[image]

Sitecore 6.4.1 API
UserCreatedRemoteEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class UserCreatedRemoteEventArgs : EventArgs,
    IPassNativeEventArgs
Visual Basic
Public Class UserCreatedRemoteEventArgs _
    Inherits EventArgs _
    Implements IPassNativeEventArgs
Visual C++
public ref class UserCreatedRemoteEventArgs : public EventArgs,
    IPassNativeEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Data.Events..::..UserCreatedRemoteEventArgs

See Also

UserCreatedRemoteEventArgs Members
Sitecore.Data.Events Namespace


UserCreatedRemoteEventArgs Members

[image] [image]

Sitecore 6.4.1 API
UserCreatedRemoteEventArgs Members
UserCreatedRemoteEventArgs Class Constructors Methods Properties See Also Send Feedback

The UserCreatedRemoteEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | UserCreatedRemoteEventArgs | Initializes a new instance of the UserCreatedRemoteEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | UserName | Gets or sets UserName.

See Also

UserCreatedRemoteEventArgs Class
Sitecore.Data.Events Namespace


UserCreatedRemoteEventArgs Constructor

[image]

Sitecore 6.4.1 API
UserCreatedRemoteEventArgs Constructor
UserCreatedRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UserCreatedRemoteEventArgs(
    string userName
)
Visual Basic
Public Sub New ( _
    userName As String _
)
Visual C++
public:
UserCreatedRemoteEventArgs(
    String^ userName
)

Parameters

userName
Type: System..::..String
Name of the user.

See Also

UserCreatedRemoteEventArgs Class
Sitecore.Data.Events Namespace


UserCreatedRemoteEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
UserCreatedRemoteEventArgs Methods
UserCreatedRemoteEventArgs Class See Also Send Feedback

The UserCreatedRemoteEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UserCreatedRemoteEventArgs Class
Sitecore.Data.Events Namespace


UserCreatedRemoteEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
UserCreatedRemoteEventArgs Properties
UserCreatedRemoteEventArgs Class See Also Send Feedback

The UserCreatedRemoteEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | UserName | Gets or sets UserName.

See Also

UserCreatedRemoteEventArgs Class
Sitecore.Data.Events Namespace


UserName Property

[image]

Sitecore 6.4.1 API
UserCreatedRemoteEventArgs..::..UserName Property
UserCreatedRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string UserName { get; protected set; }
Visual Basic
Public Property UserName As String
    Get
    Protected Set
Visual C++
public:
property String^ UserName {
    String^ get ();
    protected: void set (String^ value);
}

See Also

UserCreatedRemoteEventArgs Class
Sitecore.Data.Events Namespace


UserDeletedRemoteEventArgs Class

[image]

Sitecore 6.4.1 API
UserDeletedRemoteEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class UserDeletedRemoteEventArgs : EventArgs,
    IPassNativeEventArgs
Visual Basic
Public Class UserDeletedRemoteEventArgs _
    Inherits EventArgs _
    Implements IPassNativeEventArgs
Visual C++
public ref class UserDeletedRemoteEventArgs : public EventArgs,
    IPassNativeEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Data.Events..::..UserDeletedRemoteEventArgs

See Also

UserDeletedRemoteEventArgs Members
Sitecore.Data.Events Namespace


UserDeletedRemoteEventArgs Members

[image] [image]

Sitecore 6.4.1 API
UserDeletedRemoteEventArgs Members
UserDeletedRemoteEventArgs Class Constructors Methods Properties See Also Send Feedback

The UserDeletedRemoteEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | UserDeletedRemoteEventArgs | Initializes a new instance of the UserDeletedRemoteEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | UserName | Gets or sets UserName.

See Also

UserDeletedRemoteEventArgs Class
Sitecore.Data.Events Namespace


UserDeletedRemoteEventArgs Constructor

[image]

Sitecore 6.4.1 API
UserDeletedRemoteEventArgs Constructor
UserDeletedRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UserDeletedRemoteEventArgs(
    string userName
)
Visual Basic
Public Sub New ( _
    userName As String _
)
Visual C++
public:
UserDeletedRemoteEventArgs(
    String^ userName
)

Parameters

userName
Type: System..::..String
Name of the user.

See Also

UserDeletedRemoteEventArgs Class
Sitecore.Data.Events Namespace


UserDeletedRemoteEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
UserDeletedRemoteEventArgs Methods
UserDeletedRemoteEventArgs Class See Also Send Feedback

The UserDeletedRemoteEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UserDeletedRemoteEventArgs Class
Sitecore.Data.Events Namespace


UserDeletedRemoteEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
UserDeletedRemoteEventArgs Properties
UserDeletedRemoteEventArgs Class See Also Send Feedback

The UserDeletedRemoteEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | UserName | Gets or sets UserName.

See Also

UserDeletedRemoteEventArgs Class
Sitecore.Data.Events Namespace


UserName Property

[image]

Sitecore 6.4.1 API
UserDeletedRemoteEventArgs..::..UserName Property
UserDeletedRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string UserName { get; protected set; }
Visual Basic
Public Property UserName As String
    Get
    Protected Set
Visual C++
public:
property String^ UserName {
    String^ get ();
    protected: void set (String^ value);
}

See Also

UserDeletedRemoteEventArgs Class
Sitecore.Data.Events Namespace


UsersAddedToRolesRemoteEventArgs Class

[image]

Sitecore 6.4.1 API
UsersAddedToRolesRemoteEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class UsersAddedToRolesRemoteEventArgs : EventArgs,
    IPassNativeEventArgs
Visual Basic
Public Class UsersAddedToRolesRemoteEventArgs _
    Inherits EventArgs _
    Implements IPassNativeEventArgs
Visual C++
public ref class UsersAddedToRolesRemoteEventArgs : public EventArgs,
    IPassNativeEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Data.Events..::..UsersAddedToRolesRemoteEventArgs

See Also

UsersAddedToRolesRemoteEventArgs Members
Sitecore.Data.Events Namespace


UsersAddedToRolesRemoteEventArgs Members

[image] [image]

Sitecore 6.4.1 API
UsersAddedToRolesRemoteEventArgs Members
UsersAddedToRolesRemoteEventArgs Class Constructors Methods Properties See Also Send Feedback

The UsersAddedToRolesRemoteEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | UsersAddedToRolesRemoteEventArgs | Initializes a new instance of the UsersAddedToRolesRemoteEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | RoleNames | Gets or sets RoleNames.
Public property | UserNames | Gets or sets UserNames.

See Also

UsersAddedToRolesRemoteEventArgs Class
Sitecore.Data.Events Namespace


UsersAddedToRolesRemoteEventArgs Constructor

[image]

Sitecore 6.4.1 API
UsersAddedToRolesRemoteEventArgs Constructor
UsersAddedToRolesRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UsersAddedToRolesRemoteEventArgs(
    string[] userNames,
    string[] roleNames
)
Visual Basic
Public Sub New ( _
    userNames As String(), _
    roleNames As String() _
)
Visual C++
public:
UsersAddedToRolesRemoteEventArgs(
    array<String^>^ userNames,
    array<String^>^ roleNames
)

Parameters

userNames
Type: array< System..::..String >[]()[][]
The user names.
roleNames
Type: array< System..::..String >[]()[][]
The role names.

See Also

UsersAddedToRolesRemoteEventArgs Class
Sitecore.Data.Events Namespace


UsersAddedToRolesRemoteEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
UsersAddedToRolesRemoteEventArgs Methods
UsersAddedToRolesRemoteEventArgs Class See Also Send Feedback

The UsersAddedToRolesRemoteEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UsersAddedToRolesRemoteEventArgs Class
Sitecore.Data.Events Namespace


UsersAddedToRolesRemoteEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
UsersAddedToRolesRemoteEventArgs Properties
UsersAddedToRolesRemoteEventArgs Class See Also Send Feedback

The UsersAddedToRolesRemoteEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | RoleNames | Gets or sets RoleNames.
Public property | UserNames | Gets or sets UserNames.

See Also

UsersAddedToRolesRemoteEventArgs Class
Sitecore.Data.Events Namespace


RoleNames Property

[image]

Sitecore 6.4.1 API
UsersAddedToRolesRemoteEventArgs..::..RoleNames Property
UsersAddedToRolesRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string[] RoleNames { get; protected set; }
Visual Basic
Public Property RoleNames As String()
    Get
    Protected Set
Visual C++
public:
property array<String^>^ RoleNames {
    array<String^>^ get ();
    protected: void set (array<String^>^ value);
}

See Also

UsersAddedToRolesRemoteEventArgs Class
Sitecore.Data.Events Namespace


UserNames Property

[image]

Sitecore 6.4.1 API
UsersAddedToRolesRemoteEventArgs..::..UserNames Property
UsersAddedToRolesRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string[] UserNames { get; protected set; }
Visual Basic
Public Property UserNames As String()
    Get
    Protected Set
Visual C++
public:
property array<String^>^ UserNames {
    array<String^>^ get ();
    protected: void set (array<String^>^ value);
}

See Also

UsersAddedToRolesRemoteEventArgs Class
Sitecore.Data.Events Namespace


UsersRemovedFromRolesRemoteEventArgs Class

[image]

Sitecore 6.4.1 API
UsersRemovedFromRolesRemoteEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class UsersRemovedFromRolesRemoteEventArgs : EventArgs,
    IPassNativeEventArgs
Visual Basic
Public Class UsersRemovedFromRolesRemoteEventArgs _
    Inherits EventArgs _
    Implements IPassNativeEventArgs
Visual C++
public ref class UsersRemovedFromRolesRemoteEventArgs : public EventArgs,
    IPassNativeEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Data.Events..::..UsersRemovedFromRolesRemoteEventArgs

See Also

UsersRemovedFromRolesRemoteEventArgs Members
Sitecore.Data.Events Namespace


UsersRemovedFromRolesRemoteEventArgs Members

[image] [image]

Sitecore 6.4.1 API
UsersRemovedFromRolesRemoteEventArgs Members
UsersRemovedFromRolesRemoteEventArgs Class Constructors Methods Properties See Also Send Feedback

The UsersRemovedFromRolesRemoteEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | UsersRemovedFromRolesRemoteEventArgs | Initializes a new instance of the UsersRemovedFromRolesRemoteEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | RoleNames | Gets or sets RoleNames.
Public property | UserNames | Gets or sets UserNames.

See Also

UsersRemovedFromRolesRemoteEventArgs Class
Sitecore.Data.Events Namespace


UsersRemovedFromRolesRemoteEventArgs Constructor

[image]

Sitecore 6.4.1 API
UsersRemovedFromRolesRemoteEventArgs Constructor
UsersRemovedFromRolesRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UsersRemovedFromRolesRemoteEventArgs(
    string[] userNames,
    string[] roleNames
)
Visual Basic
Public Sub New ( _
    userNames As String(), _
    roleNames As String() _
)
Visual C++
public:
UsersRemovedFromRolesRemoteEventArgs(
    array<String^>^ userNames,
    array<String^>^ roleNames
)

Parameters

userNames
Type: array< System..::..String >[]()[][]
The user names.
roleNames
Type: array< System..::..String >[]()[][]
The role names.

See Also

UsersRemovedFromRolesRemoteEventArgs Class
Sitecore.Data.Events Namespace


UsersRemovedFromRolesRemoteEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
UsersRemovedFromRolesRemoteEventArgs Methods
UsersRemovedFromRolesRemoteEventArgs Class See Also Send Feedback

The UsersRemovedFromRolesRemoteEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UsersRemovedFromRolesRemoteEventArgs Class
Sitecore.Data.Events Namespace


UsersRemovedFromRolesRemoteEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
UsersRemovedFromRolesRemoteEventArgs Properties
UsersRemovedFromRolesRemoteEventArgs Class See Also Send Feedback

The UsersRemovedFromRolesRemoteEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | RoleNames | Gets or sets RoleNames.
Public property | UserNames | Gets or sets UserNames.

See Also

UsersRemovedFromRolesRemoteEventArgs Class
Sitecore.Data.Events Namespace


RoleNames Property

[image]

Sitecore 6.4.1 API
UsersRemovedFromRolesRemoteEventArgs..::..RoleNames Property
UsersRemovedFromRolesRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string[] RoleNames { get; protected set; }
Visual Basic
Public Property RoleNames As String()
    Get
    Protected Set
Visual C++
public:
property array<String^>^ RoleNames {
    array<String^>^ get ();
    protected: void set (array<String^>^ value);
}

See Also

UsersRemovedFromRolesRemoteEventArgs Class
Sitecore.Data.Events Namespace


UserNames Property

[image]

Sitecore 6.4.1 API
UsersRemovedFromRolesRemoteEventArgs..::..UserNames Property
UsersRemovedFromRolesRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string[] UserNames { get; protected set; }
Visual Basic
Public Property UserNames As String()
    Get
    Protected Set
Visual C++
public:
property array<String^>^ UserNames {
    array<String^>^ get ();
    protected: void set (array<String^>^ value);
}

See Also

UsersRemovedFromRolesRemoteEventArgs Class
Sitecore.Data.Events Namespace


UserUpdatedRemoteEventArgs Class

[image]

Sitecore 6.4.1 API
UserUpdatedRemoteEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class UserUpdatedRemoteEventArgs : EventArgs,
    IPassNativeEventArgs
Visual Basic
Public Class UserUpdatedRemoteEventArgs _
    Inherits EventArgs _
    Implements IPassNativeEventArgs
Visual C++
public ref class UserUpdatedRemoteEventArgs : public EventArgs,
    IPassNativeEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Data.Events..::..UserUpdatedRemoteEventArgs

See Also

UserUpdatedRemoteEventArgs Members
Sitecore.Data.Events Namespace


UserUpdatedRemoteEventArgs Members

[image] [image]

Sitecore 6.4.1 API
UserUpdatedRemoteEventArgs Members
UserUpdatedRemoteEventArgs Class Constructors Methods Properties See Also Send Feedback

The UserUpdatedRemoteEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | UserUpdatedRemoteEventArgs | Initializes a new instance of the UserUpdatedRemoteEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | UserName | Gets or sets UserName.

See Also

UserUpdatedRemoteEventArgs Class
Sitecore.Data.Events Namespace


UserUpdatedRemoteEventArgs Constructor

[image]

Sitecore 6.4.1 API
UserUpdatedRemoteEventArgs Constructor
UserUpdatedRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UserUpdatedRemoteEventArgs(
    string userName
)
Visual Basic
Public Sub New ( _
    userName As String _
)
Visual C++
public:
UserUpdatedRemoteEventArgs(
    String^ userName
)

Parameters

userName
Type: System..::..String
Name of the user.

See Also

UserUpdatedRemoteEventArgs Class
Sitecore.Data.Events Namespace


UserUpdatedRemoteEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
UserUpdatedRemoteEventArgs Methods
UserUpdatedRemoteEventArgs Class See Also Send Feedback

The UserUpdatedRemoteEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UserUpdatedRemoteEventArgs Class
Sitecore.Data.Events Namespace


UserUpdatedRemoteEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
UserUpdatedRemoteEventArgs Properties
UserUpdatedRemoteEventArgs Class See Also Send Feedback

The UserUpdatedRemoteEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | UserName | Gets or sets UserName.

See Also

UserUpdatedRemoteEventArgs Class
Sitecore.Data.Events Namespace


VersionAddedDelegate Delegate

[image]

Sitecore 6.4.1 API
VersionAddedDelegate Delegate
See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public delegate void VersionAddedDelegate(
    Object sender,
    VersionAddedEventArgs args
)
Visual Basic
Public Delegate Sub VersionAddedDelegate ( _
    sender As Object, _
    args As VersionAddedEventArgs _
)
Visual C++
public delegate void VersionAddedDelegate(
    Object^ sender,
    VersionAddedEventArgs^ args
)

Parameters

sender
Type: System..::..Object
args
Type: Sitecore.Data.Events..::..VersionAddedEventArgs

Remarks

When you create a VersionAddedDelegate delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

See Also

Sitecore.Data.Events Namespace


VersionAddedEventArgs Members

[image] [image]

Sitecore 6.4.1 API
VersionAddedEventArgs Members
VersionAddedEventArgs Class Constructors Methods Properties See Also Send Feedback

The VersionAddedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | VersionAddedEventArgs | Creates a new VersionAddedEventArgs instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | Gets the item.

See Also

VersionAddedEventArgs Class
Sitecore.Data.Events Namespace


VersionAddedEventArgs Constructor

[image]

Sitecore 6.4.1 API
VersionAddedEventArgs Constructor
VersionAddedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public VersionAddedEventArgs(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
VersionAddedEventArgs(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
Item.

See Also

VersionAddedEventArgs Class
Sitecore.Data.Events Namespace


VersionAddedEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
VersionAddedEventArgs Methods
VersionAddedEventArgs Class See Also Send Feedback

The VersionAddedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VersionAddedEventArgs Class
Sitecore.Data.Events Namespace


VersionAddedEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
VersionAddedEventArgs Properties
VersionAddedEventArgs Class See Also Send Feedback

The VersionAddedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets the item.

See Also

VersionAddedEventArgs Class
Sitecore.Data.Events Namespace


Item Property

[image]

Sitecore 6.4.1 API
VersionAddedEventArgs..::..Item Property
VersionAddedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Item { get; }
Visual Basic
Public ReadOnly Property Item As Item
    Get
Visual C++
public:
property Item^ Item {
    Item^ get ();
}

Field Value

The item.

See Also

VersionAddedEventArgs Class
Sitecore.Data.Events Namespace


VersionRemovedDelegate Delegate

[image]

Sitecore 6.4.1 API
VersionRemovedDelegate Delegate
See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public delegate void VersionRemovedDelegate(
    Object sender,
    VersionRemovedEventArgs args
)
Visual Basic
Public Delegate Sub VersionRemovedDelegate ( _
    sender As Object, _
    args As VersionRemovedEventArgs _
)
Visual C++
public delegate void VersionRemovedDelegate(
    Object^ sender,
    VersionRemovedEventArgs^ args
)

Parameters

sender
Type: System..::..Object
args
Type: Sitecore.Events..::..VersionRemovedEventArgs

Remarks

When you create a ItemRemovedDelegate delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

See Also

Sitecore.Data.Events Namespace


VersionRemovedRemoteEventArgs Class

[image]

Sitecore 6.4.1 API
VersionRemovedRemoteEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class VersionRemovedRemoteEventArgs : EventArgs,
    IPassNativeEventArgs
Visual Basic
Public Class VersionRemovedRemoteEventArgs _
    Inherits EventArgs _
    Implements IPassNativeEventArgs
Visual C++
public ref class VersionRemovedRemoteEventArgs : public EventArgs,
    IPassNativeEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Data.Events..::..VersionRemovedRemoteEventArgs

See Also

VersionRemovedRemoteEventArgs Members
Sitecore.Data.Events Namespace


VersionRemovedRemoteEventArgs Members

[image] [image]

Sitecore 6.4.1 API
VersionRemovedRemoteEventArgs Members
VersionRemovedRemoteEventArgs Class Constructors Methods Properties See Also Send Feedback

The VersionRemovedRemoteEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | VersionRemovedRemoteEventArgs | Initializes a new instance of the VersionRemovedRemoteEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | Gets or sets Item.
Public property | RemovedVersion | Gets or sets RemovedVersion.

See Also

VersionRemovedRemoteEventArgs Class
Sitecore.Data.Events Namespace


VersionRemovedRemoteEventArgs Constructor

[image]

Sitecore 6.4.1 API
VersionRemovedRemoteEventArgs Constructor
VersionRemovedRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public VersionRemovedRemoteEventArgs(
    Item item,
    Version removedVersion
)
Visual Basic
Public Sub New ( _
    item As Item, _
    removedVersion As Version _
)
Visual C++
public:
VersionRemovedRemoteEventArgs(
    Item^ item,
    Version^ removedVersion
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
removedVersion
Type: Sitecore.Data..::..Version
The removed version.

See Also

VersionRemovedRemoteEventArgs Class
Sitecore.Data.Events Namespace


VersionRemovedRemoteEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
VersionRemovedRemoteEventArgs Methods
VersionRemovedRemoteEventArgs Class See Also Send Feedback

The VersionRemovedRemoteEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VersionRemovedRemoteEventArgs Class
Sitecore.Data.Events Namespace


VersionRemovedRemoteEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
VersionRemovedRemoteEventArgs Properties
VersionRemovedRemoteEventArgs Class See Also Send Feedback

The VersionRemovedRemoteEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets or sets Item.
Public property | RemovedVersion | Gets or sets RemovedVersion.

See Also

VersionRemovedRemoteEventArgs Class
Sitecore.Data.Events Namespace


Item Property

[image]

Sitecore 6.4.1 API
VersionRemovedRemoteEventArgs..::..Item Property
VersionRemovedRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Item { get; protected set; }
Visual Basic
Public Property Item As Item
    Get
    Protected Set
Visual C++
public:
property Item^ Item {
    Item^ get ();
    protected: void set (Item^ value);
}

See Also

VersionRemovedRemoteEventArgs Class
Sitecore.Data.Events Namespace


RemovedVersion Property

[image]

Sitecore 6.4.1 API
VersionRemovedRemoteEventArgs..::..RemovedVersion Property
VersionRemovedRemoteEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Version RemovedVersion { get; protected set; }
Visual Basic
Public Property RemovedVersion As Version
    Get
    Protected Set
Visual C++
public:
property Version^ RemovedVersion {
    Version^ get ();
    protected: void set (Version^ value);
}

See Also

VersionRemovedRemoteEventArgs Class
Sitecore.Data.Events Namespace


VersionsRemovedEventArgs Class

[image]

Sitecore 6.4.1 API
VersionsRemovedEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class VersionsRemovedEventArgs : EventArgs
Visual Basic
Public Class VersionsRemovedEventArgs _
    Inherits EventArgs
Visual C++
public ref class VersionsRemovedEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Data.Events..::..VersionsRemovedEventArgs

See Also

VersionsRemovedEventArgs Members
Sitecore.Data.Events Namespace


VersionsRemovedEventArgs Members

[image] [image]

Sitecore 6.4.1 API
VersionsRemovedEventArgs Members
VersionsRemovedEventArgs Class Constructors Methods Properties See Also Send Feedback

The VersionsRemovedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | VersionsRemovedEventArgs | Creates a new VersionsRemovedEventArgs instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ItemId | Gets the item id.
Public property | Language | Gets the language.

See Also

VersionsRemovedEventArgs Class
Sitecore.Data.Events Namespace


VersionsRemovedEventArgs Constructor

[image]

Sitecore 6.4.1 API
VersionsRemovedEventArgs Constructor
VersionsRemovedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public VersionsRemovedEventArgs(
    ID itemId,
    Language language
)
Visual Basic
Public Sub New ( _
    itemId As ID, _
    language As Language _
)
Visual C++
public:
VersionsRemovedEventArgs(
    ID^ itemId,
    Language^ language
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
language
Type: Sitecore.Globalization..::..Language
The language.

See Also

VersionsRemovedEventArgs Class
Sitecore.Data.Events Namespace


VersionsRemovedEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
VersionsRemovedEventArgs Properties
VersionsRemovedEventArgs Class See Also Send Feedback

The VersionsRemovedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ItemId | Gets the item id.
Public property | Language | Gets the language.

See Also

VersionsRemovedEventArgs Class
Sitecore.Data.Events Namespace


ItemId Property

[image]

Sitecore 6.4.1 API
VersionsRemovedEventArgs..::..ItemId Property
VersionsRemovedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ItemId { get; }
Visual Basic
Public ReadOnly Property ItemId As ID
    Get
Visual C++
public:
property ID^ ItemId {
    ID^ get ();
}

Field Value

The item id.

See Also

VersionsRemovedEventArgs Class
Sitecore.Data.Events Namespace


Language Property

[image]

Sitecore 6.4.1 API
VersionsRemovedEventArgs..::..Language Property
VersionsRemovedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Language Language { get; }
Visual Basic
Public ReadOnly Property Language As Language
    Get
Visual C++
public:
property Language^ Language {
    Language^ get ();
}

Field Value

The language.

See Also

VersionsRemovedEventArgs Class
Sitecore.Data.Events Namespace


Sitecore.Data.Fields Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Data.Fields Namespace
Send Feedback

Classes

 | Class | Description
Public class | CheckboxField | Represents a Checkbox field.
Public class | CustomCustomField | Defines the custom custom field class.
Public class | CustomField | Defines the basic functionality of a custom field.
Public class | DatasourceField | Represents a Datasource field.
Public class | DateField | Represents a Date field.
Public class | DelimitedField | Defines the basic functionality of a field type where the value is a delimited string.
Public class | Field | Represents a field in an Item.
Public class | FieldComparer | Field comparer
Public class | FieldType | Represents a FieldType.
Public class | FieldTypeManager | Represents the Field Type Manager.
Public class | FileDropAreaField | File Drop Area Field helper.
Public class | FileField | Represents an Image field.
Public class | GroupedDroplinkField | Represents a Group Droplink field.
Public class | GroupedDroplistField | Represents a Lookup field.
Public class | HtmlField | Represents an Html field.
Public class | ImageField | Represents an Image field.
Public class | InternalLinkField | The internal link field.
Public class | ItemEventHandler | Represents an item event handler.
Public class | LayoutField | Represents a Layout field.
Public class | LinkField | Represents a Link field.
Public class | LockField | Represents the Lock field.
Public class | LookupField | Represents a Lookup field.
Public class | MediaPath | Represents a Media Path field.
Public class | MultilistField | Represents a MultiList field.
Public class | ParametersField | Defines the custom field for parameters class.
Public class | PropertyField | Represents a Property field.
Public class | ReferenceField | The reference field.
Public class | RendererField | Represents the Renderer field.
Public class | TemplateFieldSourceField | Represents a Link field.
Public class | TextField | Represents a Date field.
Public class | ThumbnailField | Defines the thumbnail field class.
Public class | ValueLookupField | Represents a Lookup field.
Public class | VersionLinkField | Defines the version link field class.
Public class | WebEditButton | Represents a WebEditButton. Serialized to JSON to pass data to Page Editor client code.
Public class | WordDocumentField | Represents an Html field.
Public class | XmlDeltas | Utility class that implements support for delta values in XML fields such as the LayoutField
Public class | XmlField | Defines the basic functionality of a field where the value is an XML document.


CheckboxField Class

[image]

Sitecore 6.4.1 API
CheckboxField Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CheckboxField : CustomField
Visual Basic
Public Class CheckboxField _
    Inherits CustomField
Visual C++
public ref class CheckboxField : public CustomField

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Fields..::..CustomField
Sitecore.Data.Fields..::..CheckboxField

See Also

CheckboxField Members
Sitecore.Data.Fields Namespace


CheckboxField Members

[image] [image]

Sitecore 6.4.1 API
CheckboxField Members
CheckboxField Class Constructors Methods Operators Fields Properties See Also Send Feedback

The CheckboxField type exposes the following members.

Constructors

 | Name | Description
Public method | CheckboxField | Creates a new CheckboxField instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item. (Inherited from CustomField.)
Public method | RemoveLink | Removes the link. (Inherited from CustomField.)
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Inherited from CustomField.)
Public method | ValidateLinks | Validates the links. (Inherited from CustomField.)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to CheckboxField) | Converts a Field to a CheckboxField.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

Properties

 | Name | Description
Public property | Checked | Gets or sets a value indicating whether this CheckboxField is checked.
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

CheckboxField Class
Sitecore.Data.Fields Namespace


CheckboxField Constructor

[image]

Sitecore 6.4.1 API
CheckboxField Constructor
CheckboxField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CheckboxField(
    Field innerField
)
Visual Basic
Public Sub New ( _
    innerField As Field _
)
Visual C++
public:
CheckboxField(
    Field^ innerField
)

Parameters

innerField
Type: Sitecore.Data.Fields..::..Field
Inner field.

See Also

CheckboxField Class
Sitecore.Data.Fields Namespace


CheckboxField Fields

[image] [image]

Sitecore 6.4.1 API
CheckboxField Fields
CheckboxField Class See Also Send Feedback

The CheckboxField type exposes the following members.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

See Also

CheckboxField Class
Sitecore.Data.Fields Namespace


CheckboxField Methods

[image] [image]

Sitecore 6.4.1 API
CheckboxField Methods
CheckboxField Class See Also Send Feedback

The CheckboxField type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item. (Inherited from CustomField.)
Public method | RemoveLink | Removes the link. (Inherited from CustomField.)
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Inherited from CustomField.)
Public method | ValidateLinks | Validates the links. (Inherited from CustomField.)

See Also

CheckboxField Class
Sitecore.Data.Fields Namespace


CheckboxField Type Conversions

[image] [image]

Sitecore 6.4.1 API
CheckboxField Type Conversions
CheckboxField Class See Also Send Feedback

The CheckboxField type exposes the following members.

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to CheckboxField) | Converts a Field to a CheckboxField.

See Also

CheckboxField Class
Sitecore.Data.Fields Namespace


Implicit Conversion (Field to CheckboxField)

[image]

Sitecore 6.4.1 API
CheckboxField ImplicitWideningImplicitImplicitImplicit Conversion (Field to CheckboxField)
CheckboxField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator CheckboxField (
    Field field
)
Visual Basic
Public Shared Widening Operator CType ( _
    field As Field _
) As CheckboxField
Visual C++
static implicit operator CheckboxField^ (
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.

Return Value

The implicit operator.

See Also

CheckboxField Class
Sitecore.Data.Fields Namespace


CheckboxField Properties

[image] [image]

Sitecore 6.4.1 API
CheckboxField Properties
CheckboxField Class See Also Send Feedback

The CheckboxField type exposes the following members.

Properties

 | Name | Description
Public property | Checked | Gets or sets a value indicating whether this CheckboxField is checked.
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

CheckboxField Class
Sitecore.Data.Fields Namespace


Checked Property

[image]

Sitecore 6.4.1 API
CheckboxField..::..Checked Property
CheckboxField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Checked { get; set; }
Visual Basic
Public Property Checked As Boolean
    Get
    Set
Visual C++
public:
property bool Checked {
    bool get ();
    void set (bool value);
}

Field Value

true if checked; otherwise, false.

See Also

CheckboxField Class
Sitecore.Data.Fields Namespace


CustomCustomField Class

[image]

Sitecore 6.4.1 API
CustomCustomField Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CustomCustomField : CustomField
Visual Basic
Public Class CustomCustomField _
    Inherits CustomField
Visual C++
public ref class CustomCustomField : public CustomField

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Fields..::..CustomField
Sitecore.Data.Fields..::..CustomCustomField

See Also

CustomCustomField Members
Sitecore.Data.Fields Namespace


CustomCustomField Members

[image] [image]

Sitecore 6.4.1 API
CustomCustomField Members
CustomCustomField Class Constructors Methods Operators Fields Properties See Also Send Feedback

The CustomCustomField type exposes the following members.

Constructors

 | Name | Description
Public method | CustomCustomField(Field) | Initializes a new instance of the CustomCustomField class. Creates a new LinkField instance.
Public method | CustomCustomField(Field, String) | Initializes a new instance of the CustomCustomField class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item. (Overrides CustomField..::..Relink(ItemLink, Item).)
Public method | RemoveLink | Removes the link. (Overrides CustomField..::..RemoveLink(ItemLink).)
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Overrides CustomField..::..UpdateLink(ItemLink).)
Public method | ValidateLinks | Validates the links. (Overrides CustomField..::..ValidateLinks(LinksValidationResult).)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to CustomCustomField) | Converts a Field to a LinkField.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

Properties

 | Name | Description
Public property | Database | Gets the database.
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

CustomCustomField Class
Sitecore.Data.Fields Namespace


CustomCustomField Constructor

[image] [image]

Sitecore 6.4.1 API
CustomCustomField Constructor
CustomCustomField Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CustomCustomField(Field) | Initializes a new instance of the CustomCustomField class. Creates a new LinkField instance.
Public method | CustomCustomField(Field, String) | Initializes a new instance of the CustomCustomField class.

See Also

CustomCustomField Class
CustomCustomField Members
Sitecore.Data.Fields Namespace


CustomCustomField Constructor (Field)

[image]

Sitecore 6.4.1 API
CustomCustomField Constructor (Field)
CustomCustomField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CustomCustomField(
    Field innerField
)
Visual Basic
Public Sub New ( _
    innerField As Field _
)
Visual C++
public:
CustomCustomField(
    Field^ innerField
)

Parameters

innerField
Type: Sitecore.Data.Fields..::..Field
Inner field.

See Also

CustomCustomField Class
CustomCustomField Overload
Sitecore.Data.Fields Namespace


CustomCustomField Constructor (Field, String)

[image]

Sitecore 6.4.1 API
CustomCustomField Constructor (Field, String)
CustomCustomField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CustomCustomField(
    Field innerField,
    string runtimeValue
)
Visual Basic
Public Sub New ( _
    innerField As Field, _
    runtimeValue As String _
)
Visual C++
public:
CustomCustomField(
    Field^ innerField,
    String^ runtimeValue
)

Parameters

innerField
Type: Sitecore.Data.Fields..::..Field
The inner field.
runtimeValue
Type: System..::..String
The runtime value.

See Also

CustomCustomField Class
CustomCustomField Overload
Sitecore.Data.Fields Namespace


CustomCustomField Fields

[image] [image]

Sitecore 6.4.1 API
CustomCustomField Fields
CustomCustomField Class See Also Send Feedback

The CustomCustomField type exposes the following members.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

See Also

CustomCustomField Class
Sitecore.Data.Fields Namespace


CustomCustomField Methods

[image] [image]

Sitecore 6.4.1 API
CustomCustomField Methods
CustomCustomField Class See Also Send Feedback

The CustomCustomField type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item. (Overrides CustomField..::..Relink(ItemLink, Item).)
Public method | RemoveLink | Removes the link. (Overrides CustomField..::..RemoveLink(ItemLink).)
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Overrides CustomField..::..UpdateLink(ItemLink).)
Public method | ValidateLinks | Validates the links. (Overrides CustomField..::..ValidateLinks(LinksValidationResult).)

See Also

CustomCustomField Class
Sitecore.Data.Fields Namespace


RemoveLink Method

[image]

Sitecore 6.4.1 API
CustomCustomField..::..RemoveLink Method
CustomCustomField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void RemoveLink(
    ItemLink itemLink
)
Visual Basic
Public Overrides Sub RemoveLink ( _
    itemLink As ItemLink _
)
Visual C++
public:
virtual void RemoveLink(
    ItemLink^ itemLink
) override

Parameters

itemLink
Type: Sitecore.Links..::..ItemLink
The item link.

See Also

CustomCustomField Class
Sitecore.Data.Fields Namespace


UpdateLink Method

[image]

Sitecore 6.4.1 API
CustomCustomField..::..UpdateLink Method
CustomCustomField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void UpdateLink(
    ItemLink itemLink
)
Visual Basic
Public Overrides Sub UpdateLink ( _
    itemLink As ItemLink _
)
Visual C++
public:
virtual void UpdateLink(
    ItemLink^ itemLink
) override

Parameters

itemLink
Type: Sitecore.Links..::..ItemLink
The link.

See Also

CustomCustomField Class
Sitecore.Data.Fields Namespace


CustomCustomField Type Conversions

[image] [image]

Sitecore 6.4.1 API
CustomCustomField Type Conversions
CustomCustomField Class See Also Send Feedback

The CustomCustomField type exposes the following members.

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to CustomCustomField) | Converts a Field to a LinkField.

See Also

CustomCustomField Class
Sitecore.Data.Fields Namespace


Implicit Conversion (Field to CustomCustomField)

[image]

Sitecore 6.4.1 API
CustomCustomField ImplicitWideningImplicitImplicitImplicit Conversion (Field to CustomCustomField)
CustomCustomField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator CustomCustomField (
    Field field
)
Visual Basic
Public Shared Widening Operator CType ( _
    field As Field _
) As CustomCustomField
Visual C++
static implicit operator CustomCustomField^ (
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.

Return Value

The implicit operator.

See Also

CustomCustomField Class
Sitecore.Data.Fields Namespace


CustomCustomField Properties

[image] [image]

Sitecore 6.4.1 API
CustomCustomField Properties
CustomCustomField Class See Also Send Feedback

The CustomCustomField type exposes the following members.

Properties

 | Name | Description
Public property | Database | Gets the database.
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

CustomCustomField Class
Sitecore.Data.Fields Namespace


Database Property

[image]

Sitecore 6.4.1 API
CustomCustomField..::..Database Property
CustomCustomField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database Database { get; }
Visual Basic
Public ReadOnly Property Database As Database
    Get
Visual C++
public:
property Database^ Database {
    Database^ get ();
}

Field Value

The database.

See Also

CustomCustomField Class
Sitecore.Data.Fields Namespace


CustomField Members

[image] [image]

Sitecore 6.4.1 API
CustomField Members
CustomField Class Constructors Methods Fields Properties See Also Send Feedback

The CustomField type exposes the following members.

Constructors

 | Name | Description
Protected method | CustomField(Field) | Initializes a new instance of the CustomField class. Creates a new CustomField instance.
Protected method | CustomField(Field, String) | Initializes a new instance of the CustomField class. Creates a new CustomField instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value.
Public method | GetWebEditButtons()()()() | Gets the web edit buttons.
 | GetWebEditButtons(Field) | Gets the web edit buttons. This static overload used for Fields which type is not listed in FieldTypes.config.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item.
Public method | RemoveLink | Removes the link.
Protected method | SetValue | Sets the value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link.
Public method | ValidateLinks | Validates the links.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field.
Protected field | _innerField | Reference to the field being wrapped.
Protected field | _runtimeValue | Runtime value when it is defined.

Properties

 | Name | Description
Public property | InnerField | Gets the inner field.
Public property | Value | Gets or sets the field value.

See Also

CustomField Class
Sitecore.Data.Fields Namespace


CustomField Constructor

[image] [image]

Sitecore 6.4.1 API
CustomField Constructor
CustomField Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | CustomField(Field) | Initializes a new instance of the CustomField class. Creates a new CustomField instance.
Protected method | CustomField(Field, String) | Initializes a new instance of the CustomField class. Creates a new CustomField instance.

See Also

CustomField Class
CustomField Members
Sitecore.Data.Fields Namespace


CustomField Constructor (Field)

[image]

Sitecore 6.4.1 API
CustomField Constructor (Field)
CustomField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected CustomField(
    Field innerField
)
Visual Basic
Protected Sub New ( _
    innerField As Field _
)
Visual C++
protected:
CustomField(
    Field^ innerField
)

Parameters

innerField
Type: Sitecore.Data.Fields..::..Field
Inner field.

See Also

CustomField Class
CustomField Overload
Sitecore.Data.Fields Namespace


CustomField Constructor (Field, String)

[image]

Sitecore 6.4.1 API
CustomField Constructor (Field, String)
CustomField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected CustomField(
    Field innerField,
    string runtimeValue
)
Visual Basic
Protected Sub New ( _
    innerField As Field, _
    runtimeValue As String _
)
Visual C++
protected:
CustomField(
    Field^ innerField,
    String^ runtimeValue
)

Parameters

innerField
Type: Sitecore.Data.Fields..::..Field
Inner field.
runtimeValue
Type: System..::..String
The runtime value.

See Also

CustomField Class
CustomField Overload
Sitecore.Data.Fields Namespace


CustomField Fields

[image] [image]

Sitecore 6.4.1 API
CustomField Fields
CustomField Class See Also Send Feedback

The CustomField type exposes the following members.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field.
Protected field | _innerField | Reference to the field being wrapped.
Protected field | _runtimeValue | Runtime value when it is defined.

See Also

CustomField Class
Sitecore.Data.Fields Namespace


_hasRuntimeValue Field

[image]

Sitecore 6.4.1 API
CustomField..::.._hasRuntimeValue Field
CustomField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected readonly bool _hasRuntimeValue
Visual Basic
Protected ReadOnly _hasRuntimeValue As Boolean
Visual C++
protected:
initonly bool _hasRuntimeValue

See Also

CustomField Class
Sitecore.Data.Fields Namespace


_runtimeValue Field

[image]

Sitecore 6.4.1 API
CustomField..::.._runtimeValue Field
CustomField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected string _runtimeValue
Visual Basic
Protected _runtimeValue As String
Visual C++
protected:
String^ _runtimeValue

See Also

CustomField Class
Sitecore.Data.Fields Namespace


CustomField Methods

[image] [image]

Sitecore 6.4.1 API
CustomField Methods
CustomField Class See Also Send Feedback

The CustomField type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value.
Public method | GetWebEditButtons()()()() | Gets the web edit buttons.
 | GetWebEditButtons(Field) | Gets the web edit buttons. This static overload used for Fields which type is not listed in FieldTypes.config.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item.
Public method | RemoveLink | Removes the link.
Protected method | SetValue | Sets the value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link.
Public method | ValidateLinks | Validates the links.

See Also

CustomField Class
Sitecore.Data.Fields Namespace


GetValue Method

[image]

Sitecore 6.4.1 API
CustomField..::..GetValue Method
CustomField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string GetValue()
Visual Basic
Protected Overridable Function GetValue As String
Visual C++
protected:
virtual String^ GetValue()

Return Value

The value.

See Also

CustomField Class
Sitecore.Data.Fields Namespace


GetWebEditButtons Method

[image] [image]

Sitecore 6.4.1 API
CustomField..::..GetWebEditButtons Method
CustomField Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetWebEditButtons()()()() | Gets the web edit buttons.
 | GetWebEditButtons(Field) | Gets the web edit buttons. This static overload used for Fields which type is not listed in FieldTypes.config.

See Also

CustomField Class
CustomField Members
Sitecore.Data.Fields Namespace


GetWebEditButtons Method

[image]

Sitecore 6.4.1 API
CustomField..::..GetWebEditButtons Method
CustomField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual List<WebEditButton> GetWebEditButtons()
Visual Basic
Public Overridable Function GetWebEditButtons As List(Of WebEditButton)
Visual C++
public:
virtual List<WebEditButton^>^ GetWebEditButtons()

Return Value

The web edit buttons.

See Also

CustomField Class
GetWebEditButtons Overload
Sitecore.Data.Fields Namespace


GetWebEditButtons Method (Field)

[image]

Sitecore 6.4.1 API
CustomField..::..GetWebEditButtons Method (Field)
CustomField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static List<WebEditButton> GetWebEditButtons(
    Field field
)
Visual Basic
Public Shared Function GetWebEditButtons ( _
    field As Field _
) As List(Of WebEditButton)
Visual C++
public:
static List<WebEditButton^>^ GetWebEditButtons(
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.

Return Value

The web edit buttons.

See Also

CustomField Class
GetWebEditButtons Overload
Sitecore.Data.Fields Namespace


Relink Method

[image]

Sitecore 6.4.1 API
CustomField..::..Relink Method
CustomField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Relink(
    ItemLink item,
    Item newLink
)
Visual Basic
Public Overridable Sub Relink ( _
    item As ItemLink, _
    newLink As Item _
)
Visual C++
public:
virtual void Relink(
    ItemLink^ item,
    Item^ newLink
)

Parameters

item
Type: Sitecore.Links..::..ItemLink
The item.
newLink
Type: Sitecore.Data.Items..::..Item
The new link.

See Also

CustomField Class
Sitecore.Data.Fields Namespace


RemoveLink Method

[image]

Sitecore 6.4.1 API
CustomField..::..RemoveLink Method
CustomField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void RemoveLink(
    ItemLink itemLink
)
Visual Basic
Public Overridable Sub RemoveLink ( _
    itemLink As ItemLink _
)
Visual C++
public:
virtual void RemoveLink(
    ItemLink^ itemLink
)

Parameters

itemLink
Type: Sitecore.Links..::..ItemLink
The item link.

See Also

CustomField Class
Sitecore.Data.Fields Namespace


SetValue Method

[image]

Sitecore 6.4.1 API
CustomField..::..SetValue Method
CustomField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void SetValue(
    string value
)
Visual Basic
Protected Overridable Sub SetValue ( _
    value As String _
)
Visual C++
protected:
virtual void SetValue(
    String^ value
)

Parameters

value
Type: System..::..String
The value.

See Also

CustomField Class
Sitecore.Data.Fields Namespace


UpdateLink Method

[image]

Sitecore 6.4.1 API
CustomField..::..UpdateLink Method
CustomField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void UpdateLink(
    ItemLink itemLink
)
Visual Basic
Public Overridable Sub UpdateLink ( _
    itemLink As ItemLink _
)
Visual C++
public:
virtual void UpdateLink(
    ItemLink^ itemLink
)

Parameters

itemLink
Type: Sitecore.Links..::..ItemLink
The item link.

See Also

CustomField Class
Sitecore.Data.Fields Namespace


ValidateLinks Method

[image]

Sitecore 6.4.1 API
CustomField..::..ValidateLinks Method
CustomField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void ValidateLinks(
    LinksValidationResult result
)
Visual Basic
Public Overridable Sub ValidateLinks ( _
    result As LinksValidationResult _
)
Visual C++
public:
virtual void ValidateLinks(
    LinksValidationResult^ result
)

Parameters

result
Type: Sitecore.Links..::..LinksValidationResult
The result.

See Also

CustomField Class
Sitecore.Data.Fields Namespace


CustomField Properties

[image] [image]

Sitecore 6.4.1 API
CustomField Properties
CustomField Class See Also Send Feedback

The CustomField type exposes the following members.

Properties

 | Name | Description
Public property | InnerField | Gets the inner field.
Public property | Value | Gets or sets the field value.

See Also

CustomField Class
Sitecore.Data.Fields Namespace


InnerField Property

[image]

Sitecore 6.4.1 API
CustomField..::..InnerField Property
CustomField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Field InnerField { get; }
Visual Basic
Public ReadOnly Property InnerField As Field
    Get
Visual C++
public:
property Field^ InnerField {
    Field^ get ();
}

Field Value

The inner field.

Remarks

The Inner Field propertu points to the original Field that is being wrapped by this class.

See Also

CustomField Class
Sitecore.Data.Fields Namespace


Value Property

[image]

Sitecore 6.4.1 API
CustomField..::..Value Property
CustomField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Field Value

The value.

See Also

CustomField Class
Sitecore.Data.Fields Namespace


DatasourceField Class

[image]

Sitecore 6.4.1 API
DatasourceField Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DatasourceField : InternalLinkField
Visual Basic
Public Class DatasourceField _
    Inherits InternalLinkField
Visual C++
public ref class DatasourceField : public InternalLinkField

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Fields..::..CustomField
Sitecore.Data.Fields..::..InternalLinkField
Sitecore.Data.Fields..::..DatasourceField

See Also

DatasourceField Members
Sitecore.Data.Fields Namespace


DatasourceField Members

[image] [image]

Sitecore 6.4.1 API
DatasourceField Members
DatasourceField Class Constructors Methods Fields Properties See Also Send Feedback

The DatasourceField type exposes the following members.

Constructors

 | Name | Description
Public method | DatasourceField(Field) | Creates a new DatasourceField instance.
Public method | DatasourceField(Field, String) | Initializes a new instance of the DatasourceField class.

Methods

 | Name | Description
Public method | Clear | Clears this instance. (Inherited from InternalLinkField.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item link. (Inherited from InternalLinkField.)
Public method | RemoveLink | Removes the link. (Inherited from InternalLinkField.)
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Inherited from InternalLinkField.)
Public method | ValidateLinks | Validates the links. (Overrides InternalLinkField..::..ValidateLinks(LinksValidationResult).)

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

Properties

 | Name | Description
Public property | Database | Gets the database. (Inherited from InternalLinkField.)
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | Path | Gets or sets the path. (Inherited from InternalLinkField.)
Public property | TargetID | Gets the target ID. (Inherited from InternalLinkField.)
Public property | TargetItem | Gets the target item. (Inherited from InternalLinkField.)
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

DatasourceField Class
Sitecore.Data.Fields Namespace


DatasourceField Constructor

[image] [image]

Sitecore 6.4.1 API
DatasourceField Constructor
DatasourceField Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DatasourceField(Field) | Creates a new DatasourceField instance.
Public method | DatasourceField(Field, String) | Initializes a new instance of the DatasourceField class.

See Also

DatasourceField Class
DatasourceField Members
Sitecore.Data.Fields Namespace


DatasourceField Constructor (Field)

[image]

Sitecore 6.4.1 API
DatasourceField Constructor (Field)
DatasourceField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DatasourceField(
    Field innerField
)
Visual Basic
Public Sub New ( _
    innerField As Field _
)
Visual C++
public:
DatasourceField(
    Field^ innerField
)

Parameters

innerField
Type: Sitecore.Data.Fields..::..Field
Inner field.

See Also

DatasourceField Class
DatasourceField Overload
Sitecore.Data.Fields Namespace


DatasourceField Constructor (Field, String)

[image]

Sitecore 6.4.1 API
DatasourceField Constructor (Field, String)
DatasourceField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DatasourceField(
    Field innerField,
    string runtimeValue
)
Visual Basic
Public Sub New ( _
    innerField As Field, _
    runtimeValue As String _
)
Visual C++
public:
DatasourceField(
    Field^ innerField,
    String^ runtimeValue
)

Parameters

innerField
Type: Sitecore.Data.Fields..::..Field
The inner field.
runtimeValue
Type: System..::..String
The runtime value.

See Also

DatasourceField Class
DatasourceField Overload
Sitecore.Data.Fields Namespace


DatasourceField Fields

[image] [image]

Sitecore 6.4.1 API
DatasourceField Fields
DatasourceField Class See Also Send Feedback

The DatasourceField type exposes the following members.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

See Also

DatasourceField Class
Sitecore.Data.Fields Namespace


DatasourceField Methods

[image] [image]

Sitecore 6.4.1 API
DatasourceField Methods
DatasourceField Class See Also Send Feedback

The DatasourceField type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Clears this instance. (Inherited from InternalLinkField.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item link. (Inherited from InternalLinkField.)
Public method | RemoveLink | Removes the link. (Inherited from InternalLinkField.)
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Inherited from InternalLinkField.)
Public method | ValidateLinks | Validates the links. (Overrides InternalLinkField..::..ValidateLinks(LinksValidationResult).)

See Also

DatasourceField Class
Sitecore.Data.Fields Namespace


ValidateLinks Method

[image]

Sitecore 6.4.1 API
DatasourceField..::..ValidateLinks Method
DatasourceField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void ValidateLinks(
    LinksValidationResult result
)
Visual Basic
Public Overrides Sub ValidateLinks ( _
    result As LinksValidationResult _
)
Visual C++
public:
virtual void ValidateLinks(
    LinksValidationResult^ result
) override

Parameters

result
Type: Sitecore.Links..::..LinksValidationResult
The result.

See Also

DatasourceField Class
Sitecore.Data.Fields Namespace


DatasourceField Properties

[image] [image]

Sitecore 6.4.1 API
DatasourceField Properties
DatasourceField Class See Also Send Feedback

The DatasourceField type exposes the following members.

Properties

 | Name | Description
Public property | Database | Gets the database. (Inherited from InternalLinkField.)
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | Path | Gets or sets the path. (Inherited from InternalLinkField.)
Public property | TargetID | Gets the target ID. (Inherited from InternalLinkField.)
Public property | TargetItem | Gets the target item. (Inherited from InternalLinkField.)
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

DatasourceField Class
Sitecore.Data.Fields Namespace


DateField Class

[image]

Sitecore 6.4.1 API
DateField Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DateField : CustomField
Visual Basic
Public Class DateField _
    Inherits CustomField
Visual C++
public ref class DateField : public CustomField

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Fields..::..CustomField
Sitecore.Data.Fields..::..DateField

See Also

DateField Members
Sitecore.Data.Fields Namespace


DateField Members

[image] [image]

Sitecore 6.4.1 API
DateField Members
DateField Class Constructors Methods Operators Fields Properties See Also Send Feedback

The DateField type exposes the following members.

Constructors

 | Name | Description
Public method | DateField | Creates a new DateField instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item. (Inherited from CustomField.)
Public method | RemoveLink | Removes the link. (Inherited from CustomField.)
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
Public method | ToString | Formats the value as a string. (Overrides Object..::..ToString()()()().)
Public method | UpdateLink | Updates the link. (Inherited from CustomField.)
Public method | ValidateLinks | Validates the links. (Inherited from CustomField.)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to DateField) | Converts a Field to a DateField

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

Properties

 | Name | Description
Public property | DateTime | Gets the value as a DateTime.
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

DateField Class
Sitecore.Data.Fields Namespace


DateField Constructor

[image]

Sitecore 6.4.1 API
DateField Constructor
DateField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateField(
    Field innerField
)
Visual Basic
Public Sub New ( _
    innerField As Field _
)
Visual C++
public:
DateField(
    Field^ innerField
)

Parameters

innerField
Type: Sitecore.Data.Fields..::..Field
Inner field.

See Also

DateField Class
Sitecore.Data.Fields Namespace


DateField Fields

[image] [image]

Sitecore 6.4.1 API
DateField Fields
DateField Class See Also Send Feedback

The DateField type exposes the following members.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

See Also

DateField Class
Sitecore.Data.Fields Namespace


DateField Methods

[image] [image]

Sitecore 6.4.1 API
DateField Methods
DateField Class See Also Send Feedback

The DateField type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item. (Inherited from CustomField.)
Public method | RemoveLink | Removes the link. (Inherited from CustomField.)
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
Public method | ToString | Formats the value as a string. (Overrides Object..::..ToString()()()().)
Public method | UpdateLink | Updates the link. (Inherited from CustomField.)
Public method | ValidateLinks | Validates the links. (Inherited from CustomField.)

See Also

DateField Class
Sitecore.Data.Fields Namespace


ToString Method

[image]

Sitecore 6.4.1 API
DateField..::..ToString Method
DateField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

DateField Class
Sitecore.Data.Fields Namespace


DateField Type Conversions

[image] [image]

Sitecore 6.4.1 API
DateField Type Conversions
DateField Class See Also Send Feedback

The DateField type exposes the following members.

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to DateField) | Converts a Field to a DateField

See Also

DateField Class
Sitecore.Data.Fields Namespace


Implicit Conversion (Field to DateField)

[image]

Sitecore 6.4.1 API
DateField ImplicitWideningImplicitImplicitImplicit Conversion (Field to DateField)
DateField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator DateField (
    Field field
)
Visual Basic
Public Shared Widening Operator CType ( _
    field As Field _
) As DateField
Visual C++
static implicit operator DateField^ (
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.

Return Value

The implicit operator.

See Also

DateField Class
Sitecore.Data.Fields Namespace


DateField Properties

[image] [image]

Sitecore 6.4.1 API
DateField Properties
DateField Class See Also Send Feedback

The DateField type exposes the following members.

Properties

 | Name | Description
Public property | DateTime | Gets the value as a DateTime.
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

DateField Class
Sitecore.Data.Fields Namespace


DateTime Property

[image]

Sitecore 6.4.1 API
DateField..::..DateTime Property
DateField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime DateTime { get; }
Visual Basic
Public ReadOnly Property DateTime As DateTime
    Get
Visual C++
public:
property DateTime DateTime {
    DateTime get ();
}

Field Value

The date time.

See Also

DateField Class
Sitecore.Data.Fields Namespace


DelimitedField Class

[image]

Sitecore 6.4.1 API
DelimitedField Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DelimitedField : CustomField
Visual Basic
Public Class DelimitedField _
    Inherits CustomField
Visual C++
public ref class DelimitedField : public CustomField

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Fields..::..CustomField
Sitecore.Data.Fields..::..DelimitedField
Sitecore.Data.Fields..::..MultilistField

See Also

DelimitedField Members
Sitecore.Data.Fields Namespace


DelimitedField Members

[image] [image]

Sitecore 6.4.1 API
DelimitedField Members
DelimitedField Class Constructors Methods Operators Fields Properties See Also Send Feedback

The DelimitedField type exposes the following members.

Constructors

 | Name | Description
Public method | DelimitedField | Creates a new DelimitedField instance.

Methods

 | Name | Description
Public method | Add(String) | Adds the specified item.
Public method | Add(String, Boolean) | Adds the specified item.
Public method | CharIndexOf | Gets the index of an item in the value.
Public method | Contains | Determines if the specified item is present in the value.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Gets an enumerator.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Public method | IndexOf | Get the index of an item.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink(Item, Item) | Obsolete. Relinks the specified item.
Public method | Relink(ItemLink, Item) | Relinks the specified item. (Overrides CustomField..::..Relink(ItemLink, Item).)
Public method | Remove | Removes the specified item.
Public method | RemoveLink(Item) | Obsolete. Removes the link.
Public method | RemoveLink(ItemLink) | Removes the link. (Overrides CustomField..::..RemoveLink(ItemLink).)
Public method | Replace | Replaces the specified item.
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
Public method | ToString | Gets the value. (Overrides Object..::..ToString()()()().)
Public method | UpdateLink | Updates the link. (Inherited from CustomField.)
Public method | ValidateLinks | Validates the links. (Overrides CustomField..::..ValidateLinks(LinksValidationResult).)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to DelimitedField) | Converts a Field to a DelimitedField.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

Properties

 | Name | Description
Public property | Count | Gets the count of items in this field.
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | Item | Gets the value at the specified index.
Public property | Items | Gets an array of values..
Public property | List | Gets the value a as ListString.
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

DelimitedField Class
Sitecore.Data.Fields Namespace


DelimitedField Constructor

[image]

Sitecore 6.4.1 API
DelimitedField Constructor
DelimitedField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DelimitedField(
    Field innerField,
    char separator
)
Visual Basic
Public Sub New ( _
    innerField As Field, _
    separator As Char _
)
Visual C++
public:
DelimitedField(
    Field^ innerField,
    wchar_t separator
)

Parameters

innerField
Type: Sitecore.Data.Fields..::..Field
Inner field.
separator
Type: System..::..Char
Separator.

See Also

DelimitedField Class
Sitecore.Data.Fields Namespace


DelimitedField Fields

[image] [image]

Sitecore 6.4.1 API
DelimitedField Fields
DelimitedField Class See Also Send Feedback

The DelimitedField type exposes the following members.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

See Also

DelimitedField Class
Sitecore.Data.Fields Namespace


DelimitedField Methods

[image] [image]

Sitecore 6.4.1 API
DelimitedField Methods
DelimitedField Class See Also Send Feedback

The DelimitedField type exposes the following members.

Methods

 | Name | Description
Public method | Add(String) | Adds the specified item.
Public method | Add(String, Boolean) | Adds the specified item.
Public method | CharIndexOf | Gets the index of an item in the value.
Public method | Contains | Determines if the specified item is present in the value.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Gets an enumerator.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Public method | IndexOf | Get the index of an item.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink(Item, Item) | Obsolete. Relinks the specified item.
Public method | Relink(ItemLink, Item) | Relinks the specified item. (Overrides CustomField..::..Relink(ItemLink, Item).)
Public method | Remove | Removes the specified item.
Public method | RemoveLink(Item) | Obsolete. Removes the link.
Public method | RemoveLink(ItemLink) | Removes the link. (Overrides CustomField..::..RemoveLink(ItemLink).)
Public method | Replace | Replaces the specified item.
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
Public method | ToString | Gets the value. (Overrides Object..::..ToString()()()().)
Public method | UpdateLink | Updates the link. (Inherited from CustomField.)
Public method | ValidateLinks | Validates the links. (Overrides CustomField..::..ValidateLinks(LinksValidationResult).)

See Also

DelimitedField Class
Sitecore.Data.Fields Namespace


Add Method

[image] [image]

Sitecore 6.4.1 API
DelimitedField..::..Add Method
DelimitedField Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(String) | Adds the specified item.
Public method | Add(String, Boolean) | Adds the specified item.

See Also

DelimitedField Class
DelimitedField Members
Sitecore.Data.Fields Namespace


Add Method (String, Boolean)

[image]

Sitecore 6.4.1 API
DelimitedField..::..Add Method (String, Boolean)
DelimitedField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Add(
    string item,
    bool includeBlank
)
Visual Basic
Public Function Add ( _
    item As String, _
    includeBlank As Boolean _
) As String
Visual C++
public:
String^ Add(
    String^ item,
    bool includeBlank
)

Parameters

item
Type: System..::..String
Item.
includeBlank
Type: System..::..Boolean
Include blank.

Return Value

The add.

See Also

DelimitedField Class
Add Overload
Sitecore.Data.Fields Namespace


CharIndexOf Method

[image]

Sitecore 6.4.1 API
DelimitedField..::..CharIndexOf Method
DelimitedField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int CharIndexOf(
    string item
)
Visual Basic
Public Function CharIndexOf ( _
    item As String _
) As Integer
Visual C++
public:
int CharIndexOf(
    String^ item
)

Parameters

item
Type: System..::..String
Item.

Return Value

The index of.

See Also

DelimitedField Class
Sitecore.Data.Fields Namespace


Contains Method

[image]

Sitecore 6.4.1 API
DelimitedField..::..Contains Method
DelimitedField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Contains(
    string item
)
Visual Basic
Public Function Contains ( _
    item As String _
) As Boolean
Visual C++
public:
bool Contains(
    String^ item
)

Parameters

item
Type: System..::..String
Item.

Return Value

true if [contains] [the specified item]; otherwise, false.

See Also

DelimitedField Class
Sitecore.Data.Fields Namespace


GetEnumerator Method

[image]

Sitecore 6.4.1 API
DelimitedField..::..GetEnumerator Method
DelimitedField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator
Visual C++
public:
IEnumerator^ GetEnumerator()

Return Value

The enumerator.

See Also

DelimitedField Class
Sitecore.Data.Fields Namespace


IndexOf Method

[image]

Sitecore 6.4.1 API
DelimitedField..::..IndexOf Method
DelimitedField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int IndexOf(
    string item
)
Visual Basic
Public Function IndexOf ( _
    item As String _
) As Integer
Visual C++
public:
int IndexOf(
    String^ item
)

Parameters

item
Type: System..::..String
Item.

Return Value

The index position of the item if the item is found, or -1 if it is not.

See Also

DelimitedField Class
Sitecore.Data.Fields Namespace


Relink Method

[image] [image]

Sitecore 6.4.1 API
DelimitedField..::..Relink Method
DelimitedField Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Relink(Item, Item) | Obsolete. Relinks the specified item.
Public method | Relink(ItemLink, Item) | Relinks the specified item. (Overrides CustomField..::..Relink(ItemLink, Item).)

See Also

DelimitedField Class
DelimitedField Members
Sitecore.Data.Fields Namespace


Relink Method (Item, Item)

[image]

Sitecore 6.4.1 API
DelimitedField..::..Relink Method (Item, Item)
DelimitedField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use Relink(ItemLink, Item) instead.")]
public void Relink(
    Item item,
    Item newLink
)
Visual Basic
<ObsoleteAttribute("Deprecated - Use Relink(ItemLink, Item) instead.")> _
Public Sub Relink ( _
    item As Item, _
    newLink As Item _
)
Visual C++
[ObsoleteAttribute(L"Deprecated - Use Relink(ItemLink, Item) instead.")]
public:
void Relink(
    Item^ item,
    Item^ newLink
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
newLink
Type: Sitecore.Data.Items..::..Item
The new link.

See Also

DelimitedField Class
Relink Overload
Sitecore.Data.Fields Namespace


Relink Method (ItemLink, Item)

[image]

Sitecore 6.4.1 API
DelimitedField..::..Relink Method (ItemLink, Item)
DelimitedField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Relink(
    ItemLink itemLink,
    Item newLink
)
Visual Basic
Public Overrides Sub Relink ( _
    itemLink As ItemLink, _
    newLink As Item _
)
Visual C++
public:
virtual void Relink(
    ItemLink^ itemLink,
    Item^ newLink
) override

Parameters

itemLink
Type: Sitecore.Links..::..ItemLink
The item link.
newLink
Type: Sitecore.Data.Items..::..Item
The new link.

See Also

DelimitedField Class
Relink Overload
Sitecore.Data.Fields Namespace


Remove Method

[image]

Sitecore 6.4.1 API
DelimitedField..::..Remove Method
DelimitedField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Remove(
    string item
)
Visual Basic
Public Function Remove ( _
    item As String _
) As String
Visual C++
public:
String^ Remove(
    String^ item
)

Parameters

item
Type: System..::..String
Item.

Return Value

The remove.

See Also

DelimitedField Class
Sitecore.Data.Fields Namespace


RemoveLink Method (Item)

[image]

Sitecore 6.4.1 API
DelimitedField..::..RemoveLink Method (Item)
DelimitedField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use RemoveLink(ItemLink) instead.")]
public void RemoveLink(
    Item item
)
Visual Basic
<ObsoleteAttribute("Deprecated - Use RemoveLink(ItemLink) instead.")> _
Public Sub RemoveLink ( _
    item As Item _
)
Visual C++
[ObsoleteAttribute(L"Deprecated - Use RemoveLink(ItemLink) instead.")]
public:
void RemoveLink(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

DelimitedField Class
RemoveLink Overload
Sitecore.Data.Fields Namespace


RemoveLink Method (ItemLink)

[image]

Sitecore 6.4.1 API
DelimitedField..::..RemoveLink Method (ItemLink)
DelimitedField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void RemoveLink(
    ItemLink itemLink
)
Visual Basic
Public Overrides Sub RemoveLink ( _
    itemLink As ItemLink _
)
Visual C++
public:
virtual void RemoveLink(
    ItemLink^ itemLink
) override

Parameters

itemLink
Type: Sitecore.Links..::..ItemLink
The item link.

See Also

DelimitedField Class
RemoveLink Overload
Sitecore.Data.Fields Namespace


Replace Method

[image]

Sitecore 6.4.1 API
DelimitedField..::..Replace Method
DelimitedField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Replace(
    string item,
    string with
)
Visual Basic
Public Function Replace ( _
    item As String, _
    with As String _
) As String
Visual C++
public:
String^ Replace(
    String^ item,
    String^ with
)

Parameters

item
Type: System..::..String
Item.
with
Type: System..::..String
With.

Return Value

The replace.

See Also

DelimitedField Class
Sitecore.Data.Fields Namespace


ToString Method

[image]

Sitecore 6.4.1 API
DelimitedField..::..ToString Method
DelimitedField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

DelimitedField Class
Sitecore.Data.Fields Namespace


Implicit Conversion (Field to DelimitedField)

[image]

Sitecore 6.4.1 API
DelimitedField ImplicitWideningImplicitImplicitImplicit Conversion (Field to DelimitedField)
DelimitedField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator DelimitedField (
    Field field
)
Visual Basic
Public Shared Widening Operator CType ( _
    field As Field _
) As DelimitedField
Visual C++
static implicit operator DelimitedField^ (
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.

Return Value

The implicit operator.

See Also

DelimitedField Class
Sitecore.Data.Fields Namespace


DelimitedField Properties

[image] [image]

Sitecore 6.4.1 API
DelimitedField Properties
DelimitedField Class See Also Send Feedback

The DelimitedField type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the count of items in this field.
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | Item | Gets the value at the specified index.
Public property | Items | Gets an array of values..
Public property | List | Gets the value a as ListString.
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

DelimitedField Class
Sitecore.Data.Fields Namespace


Count Property

[image]

Sitecore 6.4.1 API
DelimitedField..::..Count Property
DelimitedField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
property int Count {
    int get ();
}

Field Value

The count.

See Also

DelimitedField Class
Sitecore.Data.Fields Namespace


List Property

[image]

Sitecore 6.4.1 API
DelimitedField..::..List Property
DelimitedField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ListString List { get; }
Visual Basic
Public ReadOnly Property List As ListString
    Get
Visual C++
public:
property ListString^ List {
    ListString^ get ();
}

Field Value

The list.

See Also

DelimitedField Class
Sitecore.Data.Fields Namespace


Field Class

[image]

Sitecore 6.4.1 API
Field Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Field : ISecurable
Visual Basic
Public Class Field _
    Implements ISecurable
Visual C++
public ref class Field : ISecurable

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Fields..::..Field
Sitecore.Data.Fields..::..ParametersField

See Also

Field Members
Sitecore.Data.Fields Namespace


Field Members

[image] [image]

Sitecore 6.4.1 API
Field Members
Field Class Constructors Methods Properties See Also Send Feedback

The Field type exposes the following members.

Constructors

 | Name | Description
Public method | Field | Initializes a new instance of the Field class. Creates a new Field instance.

Methods

 | Name | Description
 | Compare | Compares the specified fields.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBlobStream | Gets the BLOB stream associated with the field.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInheritedValue | Gets the inherited value.
Public method | GetStandardValue | Gets the standard value for the field.
Public method | GetTemplateField | Gets the template field.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueId | Gets a unique id.
Public method | GetValue(Boolean) | Gets the current value of the field.
Public method | GetValue(Boolean, Boolean) | Gets the current value of the field.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Resets the field.
Public method | SetBlobStream | Sets the BLOB stream associated with the field.
Public method | SetValue | Sets the value of the field.
Public method | ToString | Gets the value of the field. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CanRead | Gets a value indicating whether this field can be read by the current user.
Public property | CanWrite | Gets a value indicating whether this field can be written to.
Public property | ContainsStandardValue | Gets a value indicating whether [contains standard value].
Public property | Database | Gets the database.
Public property | Definition | Gets the definition.
Public property | Description | Gets the description.
Public property | DisplayName | Gets the display name.
Public property | HasBlobStream | Gets a value indicating whether this field instance has a value.
Public property | HasValue | Gets a value indicating whether this field instance has a value.
Public property | HelpLink | Gets the help link.
Public property | ID | Gets the ID.
Public property | InheritedValue | Gets the inherited value.
Public property | InheritsValueFromOtherItem | Gets a value indicating whether the current Value is inherited from other item (ie. it has been retrieved from the some other item but not from the standard values).
Public property | IsBlobField | Gets a value indicating whether this instance is a BLOB field.
Public property | IsModified | Gets a value indicating whether this field is modified.
Public property | Item | Gets the Item.
Public property | Key | Gets the key.
Public property | Language | Gets the language.
Public property | Name | Gets the name of field.
Public property | ResetBlank | Gets a value indicating whether this Field should be reset if its value is blank.
Public property | Section | Gets the section name.
Public property | SectionDisplayName | Gets the display name of the section.
Public property | SectionNameByUILocale | Gets the section name by UI locale.
Public property | SectionSortorder | Gets the section sortorder.
Public property | Shared | Gets a value indicating whether this Field is shared.
Public property | ShouldBeTranslated | Gets a value indicating whether a field is eligable for translation.
Public property | Sortorder | Gets the field sortorder.
Public property | Source | Gets the source.
Public property | Style | Gets the CSS style.
Public property | Title | Gets the title.
Public property | ToolTip | Gets the tool tip.
Public property | Translatable | Gets a value indicating whether a field can be translated.
Public property | Type | Gets the type.
Public property | TypeKey | Gets the type key.
Public property | Unversioned | Gets a value indicating whether this Field is unversioned.
Public property | Validation | Gets the validation regular expression.
Public property | ValidationText | Gets the validation text that is displayed if the Validation regular expression fails.
Public property | Value | Gets or sets the value.

See Also

Field Class
Sitecore.Data.Fields Namespace


Field Constructor

[image]

Sitecore 6.4.1 API
Field Constructor
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Field(
    ID fieldID,
    Item ownerItem
)
Visual Basic
Public Sub New ( _
    fieldID As ID, _
    ownerItem As Item _
)
Visual C++
public:
Field(
    ID^ fieldID,
    Item^ ownerItem
)

Parameters

fieldID
Type: Sitecore.Data..::..ID
The field Id.
ownerItem
Type: Sitecore.Data.Items..::..Item
Owner item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | fieldId or ownerItem was null.

See Also

Field Class
Sitecore.Data.Fields Namespace


Field Methods

[image] [image]

Sitecore 6.4.1 API
Field Methods
Field Class See Also Send Feedback

The Field type exposes the following members.

Methods

 | Name | Description
 | Compare | Compares the specified fields.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBlobStream | Gets the BLOB stream associated with the field.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInheritedValue | Gets the inherited value.
Public method | GetStandardValue | Gets the standard value for the field.
Public method | GetTemplateField | Gets the template field.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueId | Gets a unique id.
Public method | GetValue(Boolean) | Gets the current value of the field.
Public method | GetValue(Boolean, Boolean) | Gets the current value of the field.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Resets the field.
Public method | SetBlobStream | Sets the BLOB stream associated with the field.
Public method | SetValue | Sets the value of the field.
Public method | ToString | Gets the value of the field. (Overrides Object..::..ToString()()()().)

See Also

Field Class
Sitecore.Data.Fields Namespace


Compare Method

[image]

Sitecore 6.4.1 API
Field..::..Compare Method
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int Compare(
    Field field1,
    Field field2
)
Visual Basic
Public Shared Function Compare ( _
    field1 As Field, _
    field2 As Field _
) As Integer
Visual C++
public:
static int Compare(
    Field^ field1,
    Field^ field2
)

Parameters

field1
Type: Sitecore.Data.Fields..::..Field
Field1.
field2
Type: Sitecore.Data.Fields..::..Field
Field2.

Return Value

The compare.

See Also

Field Class
Sitecore.Data.Fields Namespace


GetInheritedValue Method

[image]

Sitecore 6.4.1 API
Field..::..GetInheritedValue Method
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetInheritedValue()
Visual Basic
Public Function GetInheritedValue As String
Visual C++
public:
String^ GetInheritedValue()

Return Value

The inherited value.

See Also

Field Class
Sitecore.Data.Fields Namespace


GetStandardValue Method

[image]

Sitecore 6.4.1 API
Field..::..GetStandardValue Method
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetStandardValue()
Visual Basic
Public Function GetStandardValue As String
Visual C++
public:
String^ GetStandardValue()

Return Value

The standard value for the field if it has one. Otherwise, null is returned.

See Also

Field Class
Sitecore.Data.Fields Namespace


GetTemplateField Method

[image]

Sitecore 6.4.1 API
Field..::..GetTemplateField Method
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateField GetTemplateField()
Visual Basic
Public Function GetTemplateField As TemplateField
Visual C++
public:
TemplateField^ GetTemplateField()

Return Value

The template field.

See Also

Field Class
Sitecore.Data.Fields Namespace


GetUniqueId Method

[image]

Sitecore 6.4.1 API
Field..::..GetUniqueId Method
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetUniqueId()
Visual Basic
Public Function GetUniqueId As String
Visual C++
public:
virtual String^ GetUniqueId() sealed

Return Value

The get unique id.

Implements

ISecurable..::..GetUniqueId()()()()

Remarks

The id must be unique enough to be used in a global cache.

For example, an Item might implement this as Database.Name + ID.

The resulting key used by Item might therefore be typeof(Item).FullName + divider + Database.Name + ID.

See Also

Field Class
Sitecore.Data.Fields Namespace


GetValue Method

[image] [image]

Sitecore 6.4.1 API
Field..::..GetValue Method
Field Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue(Boolean) | Gets the current value of the field.
Public method | GetValue(Boolean, Boolean) | Gets the current value of the field.

See Also

Field Class
Field Members
Sitecore.Data.Fields Namespace


GetValue Method (Boolean)

[image]

Sitecore 6.4.1 API
Field..::..GetValue Method (Boolean)
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetValue(
    bool allowStandardValue
)
Visual Basic
Public Function GetValue ( _
    allowStandardValue As Boolean _
) As String
Visual C++
public:
String^ GetValue(
    bool allowStandardValue
)

Parameters

allowStandardValue
Type: System..::..Boolean
Indicates if an standard value should be returned if the field itself does not contain any data.

Return Value

The get value.

Remarks

This is similar to calling Value with the important difference that this method supports null values.

If the field contains no data, null will be returned. Calling Value in the same case will yield Empty

See Also

Field Class
GetValue Overload
Sitecore.Data.Fields Namespace


GetValue Method (Boolean, Boolean)

[image]

Sitecore 6.4.1 API
Field..::..GetValue Method (Boolean, Boolean)
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetValue(
    bool allowStandardValue,
    bool allowDefaultValue
)
Visual Basic
Public Function GetValue ( _
    allowStandardValue As Boolean, _
    allowDefaultValue As Boolean _
) As String
Visual C++
public:
String^ GetValue(
    bool allowStandardValue,
    bool allowDefaultValue
)

Parameters

allowStandardValue
Type: System..::..Boolean
Indicates if an standard value should be returned if the field itself does not contain any data.
allowDefaultValue
Type: System..::..Boolean
if set to true this instance is allow default value.

Return Value

The get value.

Remarks

This is similar to calling Value with the important difference that this method supports null values.

If the field contains no data, null will be returned. Calling Value in the same case will yield Empty

See Also

Field Class
GetValue Overload
Sitecore.Data.Fields Namespace


Reset Method

[image]

Sitecore 6.4.1 API
Field..::..Reset Method
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset
Visual C++
public:
void Reset()

Remarks

Equivalent to setting the field value to null.

See Also

Field Class
Sitecore.Data.Fields Namespace


SetBlobStream Method

[image]

Sitecore 6.4.1 API
Field..::..SetBlobStream Method
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetBlobStream(
    Stream stream
)
Visual Basic
Public Sub SetBlobStream ( _
    stream As Stream _
)
Visual C++
public:
void SetBlobStream(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::..Stream
The stream.

See Also

Field Class
Sitecore.Data.Fields Namespace


ToString Method

[image]

Sitecore 6.4.1 API
Field..::..ToString Method
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

Field Class
Sitecore.Data.Fields Namespace


Field Properties

[image] [image]

Sitecore 6.4.1 API
Field Properties
Field Class See Also Send Feedback

The Field type exposes the following members.

Properties

 | Name | Description
Public property | CanRead | Gets a value indicating whether this field can be read by the current user.
Public property | CanWrite | Gets a value indicating whether this field can be written to.
Public property | ContainsStandardValue | Gets a value indicating whether [contains standard value].
Public property | Database | Gets the database.
Public property | Definition | Gets the definition.
Public property | Description | Gets the description.
Public property | DisplayName | Gets the display name.
Public property | HasBlobStream | Gets a value indicating whether this field instance has a value.
Public property | HasValue | Gets a value indicating whether this field instance has a value.
Public property | HelpLink | Gets the help link.
Public property | ID | Gets the ID.
Public property | InheritedValue | Gets the inherited value.
Public property | InheritsValueFromOtherItem | Gets a value indicating whether the current Value is inherited from other item (ie. it has been retrieved from the some other item but not from the standard values).
Public property | IsBlobField | Gets a value indicating whether this instance is a BLOB field.
Public property | IsModified | Gets a value indicating whether this field is modified.
Public property | Item | Gets the Item.
Public property | Key | Gets the key.
Public property | Language | Gets the language.
Public property | Name | Gets the name of field.
Public property | ResetBlank | Gets a value indicating whether this Field should be reset if its value is blank.
Public property | Section | Gets the section name.
Public property | SectionDisplayName | Gets the display name of the section.
Public property | SectionNameByUILocale | Gets the section name by UI locale.
Public property | SectionSortorder | Gets the section sortorder.
Public property | Shared | Gets a value indicating whether this Field is shared.
Public property | ShouldBeTranslated | Gets a value indicating whether a field is eligable for translation.
Public property | Sortorder | Gets the field sortorder.
Public property | Source | Gets the source.
Public property | Style | Gets the CSS style.
Public property | Title | Gets the title.
Public property | ToolTip | Gets the tool tip.
Public property | Translatable | Gets a value indicating whether a field can be translated.
Public property | Type | Gets the type.
Public property | TypeKey | Gets the type key.
Public property | Unversioned | Gets a value indicating whether this Field is unversioned.
Public property | Validation | Gets the validation regular expression.
Public property | ValidationText | Gets the validation text that is displayed if the Validation regular expression fails.
Public property | Value | Gets or sets the value.

See Also

Field Class
Sitecore.Data.Fields Namespace


CanRead Property

[image]

Sitecore 6.4.1 API
Field..::..CanRead Property
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool CanRead { get; }
Visual Basic
Public ReadOnly Property CanRead As Boolean
    Get
Visual C++
public:
property bool CanRead {
    bool get ();
}

Field Value

true if this field can be read; otherwise, false.

See Also

Field Class
Sitecore.Data.Fields Namespace


CanWrite Property

[image]

Sitecore 6.4.1 API
Field..::..CanWrite Property
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool CanWrite { get; }
Visual Basic
Public ReadOnly Property CanWrite As Boolean
    Get
Visual C++
public:
property bool CanWrite {
    bool get ();
}

Field Value

true if this field can be written to; otherwise, false.

See Also

Field Class
Sitecore.Data.Fields Namespace


ContainsStandardValue Property

[image]

Sitecore 6.4.1 API
Field..::..ContainsStandardValue Property
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool ContainsStandardValue { get; }
Visual Basic
Public Overridable ReadOnly Property ContainsStandardValue As Boolean
    Get
Visual C++
public:
virtual property bool ContainsStandardValue {
    bool get ();
}

Field Value

true if [contains standard value]; otherwise, false.

See Also

Field Class
Sitecore.Data.Fields Namespace


Database Property

[image]

Sitecore 6.4.1 API
Field..::..Database Property
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database Database { get; }
Visual Basic
Public ReadOnly Property Database As Database
    Get
Visual C++
public:
property Database^ Database {
    Database^ get ();
}

Field Value

The database.

See Also

Field Class
Sitecore.Data.Fields Namespace


Definition Property

[image]

Sitecore 6.4.1 API
Field..::..Definition Property
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateField Definition { get; }
Visual Basic
Public ReadOnly Property Definition As TemplateField
    Get
Visual C++
public:
property TemplateField^ Definition {
    TemplateField^ get ();
}

Field Value

The definition.

See Also

Field Class
Sitecore.Data.Fields Namespace


Description Property

[image]

Sitecore 6.4.1 API
Field..::..Description Property
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Description { get; }
Visual Basic
Public ReadOnly Property Description As String
    Get
Visual C++
public:
property String^ Description {
    String^ get ();
}

Field Value

The description.

See Also

Field Class
Sitecore.Data.Fields Namespace


DisplayName Property

[image]

Sitecore 6.4.1 API
Field..::..DisplayName Property
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string DisplayName { get; }
Visual Basic
Public ReadOnly Property DisplayName As String
    Get
Visual C++
public:
property String^ DisplayName {
    String^ get ();
}

Field Value

The name of the display.

See Also

Field Class
Sitecore.Data.Fields Namespace


HasBlobStream Property

[image]

Sitecore 6.4.1 API
Field..::..HasBlobStream Property
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool HasBlobStream { get; }
Visual Basic
Public ReadOnly Property HasBlobStream As Boolean
    Get
Visual C++
public:
property bool HasBlobStream {
    bool get ();
}

Field Value

true if this instance has value; otherwise, false.

See Also

Field Class
Sitecore.Data.Fields Namespace


HasValue Property

[image]

Sitecore 6.4.1 API
Field..::..HasValue Property
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool HasValue { get; }
Visual Basic
Public ReadOnly Property HasValue As Boolean
    Get
Visual C++
public:
property bool HasValue {
    bool get ();
}

Field Value

true if this instance has value; otherwise, false.

See Also

Field Class
Sitecore.Data.Fields Namespace


ID Property

[image]

Sitecore 6.4.1 API
Field..::..ID Property
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ID { get; }
Visual Basic
Public ReadOnly Property ID As ID
    Get
Visual C++
public:
property ID^ ID {
    ID^ get ();
}

Field Value

The field Id.

See Also

Field Class
Sitecore.Data.Fields Namespace


InheritedValue Property

[image]

Sitecore 6.4.1 API
Field..::..InheritedValue Property
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string InheritedValue { get; }
Visual Basic
Public ReadOnly Property InheritedValue As String
    Get
Visual C++
public:
property String^ InheritedValue {
    String^ get ();
}

Field Value

The inherited value.

Remarks

If the field does not have a value, the value is fetched from the owning items template.

See Also

Field Class
Sitecore.Data.Fields Namespace


InheritsValueFromOtherItem Property

[image]

Sitecore 6.4.1 API
Field..::..InheritsValueFromOtherItem Property
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool InheritsValueFromOtherItem { get; }
Visual Basic
Public ReadOnly Property InheritsValueFromOtherItem As Boolean
    Get
Visual C++
public:
property bool InheritsValueFromOtherItem {
    bool get ();
}

Field Value

true if the Field contains the inherited value; otherwise, false.

See Also

Field Class
Sitecore.Data.Fields Namespace


IsModified Property

[image]

Sitecore 6.4.1 API
Field..::..IsModified Property
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsModified { get; }
Visual Basic
Public ReadOnly Property IsModified As Boolean
    Get
Visual C++
public:
property bool IsModified {
    bool get ();
}

Field Value

true if this field is modified; otherwise, false.

See Also

Field Class
Sitecore.Data.Fields Namespace


Item Property

[image]

Sitecore 6.4.1 API
Field..::..Item Property
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Item { get; }
Visual Basic
Public ReadOnly Property Item As Item
    Get
Visual C++
public:
property Item^ Item {
    Item^ get ();
}

Field Value

The field owner item.

See Also

Field Class
Sitecore.Data.Fields Namespace


Key Property

[image]

Sitecore 6.4.1 API
Field..::..Key Property
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Key { get; }
Visual Basic
Public ReadOnly Property Key As String
    Get
Visual C++
public:
property String^ Key {
    String^ get ();
}

Field Value

The field key.

See Also

Field Class
Sitecore.Data.Fields Namespace


Language Property

[image]

Sitecore 6.4.1 API
Field..::..Language Property
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Language Language { get; }
Visual Basic
Public ReadOnly Property Language As Language
    Get
Visual C++
public:
property Language^ Language {
    Language^ get ();
}

Field Value

The language.

See Also

Field Class
Sitecore.Data.Fields Namespace


Name Property

[image]

Sitecore 6.4.1 API
Field..::..Name Property
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Field Value

The field name.

See Also

Field Class
Sitecore.Data.Fields Namespace


ResetBlank Property

[image]

Sitecore 6.4.1 API
Field..::..ResetBlank Property
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ResetBlank { get; }
Visual Basic
Public ReadOnly Property ResetBlank As Boolean
    Get
Visual C++
public:
property bool ResetBlank {
    bool get ();
}

Field Value

true if 'reset blank' has been set on the field definition in the template; otherwise, false.

Remarks

When a field is reset, it will again reflect the default value from the template.

See Also

Field Class
Sitecore.Data.Fields Namespace


Section Property

[image]

Sitecore 6.4.1 API
Field..::..Section Property
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Section { get; }
Visual Basic
Public ReadOnly Property Section As String
    Get
Visual C++
public:
property String^ Section {
    String^ get ();
}

Field Value

The section.

See Also

Field Class
Sitecore.Data.Fields Namespace


SectionDisplayName Property

[image]

Sitecore 6.4.1 API
Field..::..SectionDisplayName Property
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string SectionDisplayName { get; }
Visual Basic
Public ReadOnly Property SectionDisplayName As String
    Get
Visual C++
public:
property String^ SectionDisplayName {
    String^ get ();
}

Field Value

The display name of the section.

See Also

Field Class
Sitecore.Data.Fields Namespace


SectionNameByUILocale Property

[image]

Sitecore 6.4.1 API
Field..::..SectionNameByUILocale Property
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string SectionNameByUILocale { get; }
Visual Basic
Public ReadOnly Property SectionNameByUILocale As String
    Get
Visual C++
public:
property String^ SectionNameByUILocale {
    String^ get ();
}

Field Value

The section name by UI locale.

See Also

Field Class
Sitecore.Data.Fields Namespace


SectionSortorder Property

[image]

Sitecore 6.4.1 API
Field..::..SectionSortorder Property
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int SectionSortorder { get; }
Visual Basic
Public ReadOnly Property SectionSortorder As Integer
    Get
Visual C++
public:
property int SectionSortorder {
    int get ();
}

Field Value

The section sortorder.

See Also

Field Class
Sitecore.Data.Fields Namespace


Shared Property

[image]

Sitecore 6.4.1 API
Field..::..Shared Property
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Shared { get; }
Visual Basic
Public ReadOnly Property Shared As Boolean
    Get
Visual C++
public:
property bool Shared {
    bool get ();
}

Field Value

true if shared; otherwise, false.

Remarks

A shared field has the same value regardless of language and item version.

See Also

Field Class
Sitecore.Data.Fields Namespace


ShouldBeTranslated Property

[image]

Sitecore 6.4.1 API
Field..::..ShouldBeTranslated Property
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ShouldBeTranslated { get; }
Visual Basic
Public ReadOnly Property ShouldBeTranslated As Boolean
    Get
Visual C++
public:
property bool ShouldBeTranslated {
    bool get ();
}

Field Value

true if the Field should be translated; otherwise, false.

Remarks

Most fields that are not shared should be translated. However the followed shared system fields should not be translated: Created, CreateBy, Updated, UpdatedBy, ValiedFrom, ValidTo, Lock, Revision, WorkflowState, ReminderDate, ReminderRecipents, ReminderText and HideVersion.

See Also

Field Class
Sitecore.Data.Fields Namespace


Sortorder Property

[image]

Sitecore 6.4.1 API
Field..::..Sortorder Property
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Sortorder { get; }
Visual Basic
Public ReadOnly Property Sortorder As Integer
    Get
Visual C++
public:
property int Sortorder {
    int get ();
}

Field Value

The sortorder.

See Also

Field Class
Sitecore.Data.Fields Namespace


Source Property

[image]

Sitecore 6.4.1 API
Field..::..Source Property
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Source { get; }
Visual Basic
Public ReadOnly Property Source As String
    Get
Visual C++
public:
property String^ Source {
    String^ get ();
}

Field Value

The source.

See Also

Field Class
Sitecore.Data.Fields Namespace


Style Property

[image]

Sitecore 6.4.1 API
Field..::..Style Property
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Style { get; }
Visual Basic
Public ReadOnly Property Style As String
    Get
Visual C++
public:
property String^ Style {
    String^ get ();
}

Field Value

The style.

Remarks

The CSS style is used in the client.

See Also

Field Class
Sitecore.Data.Fields Namespace


Title Property

[image]

Sitecore 6.4.1 API
Field..::..Title Property
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Title { get; }
Visual Basic
Public ReadOnly Property Title As String
    Get
Visual C++
public:
property String^ Title {
    String^ get ();
}

Field Value

The title.

See Also

Field Class
Sitecore.Data.Fields Namespace


ToolTip Property

[image]

Sitecore 6.4.1 API
Field..::..ToolTip Property
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ToolTip { get; }
Visual Basic
Public ReadOnly Property ToolTip As String
    Get
Visual C++
public:
property String^ ToolTip {
    String^ get ();
}

Field Value

The tool tip.

See Also

Field Class
Sitecore.Data.Fields Namespace


Translatable Property

[image]

Sitecore 6.4.1 API
Field..::..Translatable Property
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Translatable { get; }
Visual Basic
Public ReadOnly Property Translatable As Boolean
    Get
Visual C++
public:
property bool Translatable {
    bool get ();
}

Field Value

true if translatable; otherwise, false.

Remarks

The Field types Text, Memo, Html, Rich Text are translatable.

See Also

Field Class
Sitecore.Data.Fields Namespace


Type Property

[image]

Sitecore 6.4.1 API
Field..::..Type Property
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Type { get; }
Visual Basic
Public ReadOnly Property Type As String
    Get
Visual C++
public:
property String^ Type {
    String^ get ();
}

Field Value

The field type.

Remarks

The field types are located in /sitecore/system/Field types.

See Also

Field Class
Sitecore.Data.Fields Namespace


Unversioned Property

[image]

Sitecore 6.4.1 API
Field..::..Unversioned Property
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Unversioned { get; }
Visual Basic
Public ReadOnly Property Unversioned As Boolean
    Get
Visual C++
public:
property bool Unversioned {
    bool get ();
}

Field Value

true if unversioned; otherwise, false.

See Also

Field Class
Sitecore.Data.Fields Namespace


Validation Property

[image]

Sitecore 6.4.1 API
Field..::..Validation Property
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Validation { get; }
Visual Basic
Public ReadOnly Property Validation As String
    Get
Visual C++
public:
property String^ Validation {
    String^ get ();
}

Field Value

The validation.

See Also

Field Class
Sitecore.Data.Fields Namespace


ValidationText Property

[image]

Sitecore 6.4.1 API
Field..::..ValidationText Property
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ValidationText { get; }
Visual Basic
Public ReadOnly Property ValidationText As String
    Get
Visual C++
public:
property String^ ValidationText {
    String^ get ();
}

Field Value

The validation text.

See Also

Field Class
Sitecore.Data.Fields Namespace


Value Property

[image]

Sitecore 6.4.1 API
Field..::..Value Property
Field Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Field Value

The value.

See Also

Field Class
Sitecore.Data.Fields Namespace


FieldComparer Class

[image]

Sitecore 6.4.1 API
FieldComparer Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FieldComparer : IComparer<Field>
Visual Basic
Public Class FieldComparer _
    Implements IComparer(Of Field)
Visual C++
public ref class FieldComparer : IComparer<Field^>

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Fields..::..FieldComparer

See Also

FieldComparer Members
Sitecore.Data.Fields Namespace


FieldComparer Members

[image] [image]

Sitecore 6.4.1 API
FieldComparer Members
FieldComparer Class Constructors Methods See Also Send Feedback

The FieldComparer type exposes the following members.

Constructors

 | Name | Description
Public method | FieldComparer | Initializes a new instance of the FieldComparer class

Methods

 | Name | Description
Public method | Compare | Compares the specified field1.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldComparer Class
Sitecore.Data.Fields Namespace


FieldComparer Constructor

[image]

Sitecore 6.4.1 API
FieldComparer Constructor
FieldComparer Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FieldComparer()
Visual Basic
Public Sub New
Visual C++
public:
FieldComparer()

See Also

FieldComparer Class
Sitecore.Data.Fields Namespace


FieldComparer Methods

[image] [image]

Sitecore 6.4.1 API
FieldComparer Methods
FieldComparer Class See Also Send Feedback

The FieldComparer type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares the specified field1.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldComparer Class
Sitecore.Data.Fields Namespace


Compare Method

[image]

Sitecore 6.4.1 API
FieldComparer..::..Compare Method
FieldComparer Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Compare(
    Field field1,
    Field field2
)
Visual Basic
Public Function Compare ( _
    field1 As Field, _
    field2 As Field _
) As Integer
Visual C++
public:
virtual int Compare(
    Field^ field1,
    Field^ field2
) sealed

Parameters

field1
Type: Sitecore.Data.Fields..::..Field
Field1.
field2
Type: Sitecore.Data.Fields..::..Field
Field2.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Fields.FieldComparer.Compare(Sitecore.Data.Fields.Field,Sitecore.Data.Fields.Field)"]

Implements

IComparer<(Of <(<'T>)>)>..::..Compare(T, T)

See Also

FieldComparer Class
Sitecore.Data.Fields Namespace


FieldType Class

[image]

Sitecore 6.4.1 API
FieldType Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FieldType
Visual Basic
Public Class FieldType
Visual C++
public ref class FieldType

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Fields..::..FieldType

See Also

FieldType Members
Sitecore.Data.Fields Namespace


FieldType Members

[image] [image]

Sitecore 6.4.1 API
FieldType Members
FieldType Class Constructors Methods Properties See Also Send Feedback

The FieldType type exposes the following members.

Constructors

 | Name | Description
Public method | FieldType | Initializes a new instance of the FieldType class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetField | Gets the field.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsBlob | Gets a value indicating whether the field type describes a BLOB field.
Public property | Name | Gets the name.
Public property | Resizable | Gets or sets a value indicating whether this FieldType is resizable.
Public property | Type | Gets the type.

See Also

FieldType Class
Sitecore.Data.Fields Namespace


FieldType Constructor

[image]

Sitecore 6.4.1 API
FieldType Constructor
FieldType Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FieldType(
    XmlNode node
)
Visual Basic
Public Sub New ( _
    node As XmlNode _
)
Visual C++
public:
FieldType(
    XmlNode^ node
)

Parameters

node
Type: System.Xml..::..XmlNode
The node.

See Also

FieldType Class
Sitecore.Data.Fields Namespace


FieldType Methods

[image] [image]

Sitecore 6.4.1 API
FieldType Methods
FieldType Class See Also Send Feedback

The FieldType type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetField | Gets the field.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldType Class
Sitecore.Data.Fields Namespace


FieldType Properties

[image] [image]

Sitecore 6.4.1 API
FieldType Properties
FieldType Class See Also Send Feedback

The FieldType type exposes the following members.

Properties

 | Name | Description
Public property | IsBlob | Gets a value indicating whether the field type describes a BLOB field.
Public property | Name | Gets the name.
Public property | Resizable | Gets or sets a value indicating whether this FieldType is resizable.
Public property | Type | Gets the type.

See Also

FieldType Class
Sitecore.Data.Fields Namespace


IsBlob Property

[image]

Sitecore 6.4.1 API
FieldType..::..IsBlob Property
FieldType Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsBlob { get; }
Visual Basic
Public ReadOnly Property IsBlob As Boolean
    Get
Visual C++
public:
property bool IsBlob {
    bool get ();
}

Field Value

true if this instance describes a BLOB field; otherwise, false.

See Also

FieldType Class
Sitecore.Data.Fields Namespace


Name Property

[image]

Sitecore 6.4.1 API
FieldType..::..Name Property
FieldType Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

FieldType Class
Sitecore.Data.Fields Namespace


Resizable Property

[image]

Sitecore 6.4.1 API
FieldType..::..Resizable Property
FieldType Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Resizable { get; set; }
Visual Basic
Public Property Resizable As Boolean
    Get
    Set
Visual C++
public:
property bool Resizable {
    bool get ();
    void set (bool value);
}

Field Value

true if resizable; otherwise, false.

See Also

FieldType Class
Sitecore.Data.Fields Namespace


Type Property

[image]

Sitecore 6.4.1 API
FieldType..::..Type Property
FieldType Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Type Type { get; }
Visual Basic
Public ReadOnly Property Type As Type
    Get
Visual C++
public:
property Type^ Type {
    Type^ get ();
}

Field Value

The type.

See Also

FieldType Class
Sitecore.Data.Fields Namespace


FieldTypeManager Class

[image]

Sitecore 6.4.1 API
FieldTypeManager Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class FieldTypeManager
Visual Basic
Public NotInheritable Class FieldTypeManager
Visual C++
public ref class FieldTypeManager abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Fields..::..FieldTypeManager

See Also

FieldTypeManager Members
Sitecore.Data.Fields Namespace


FieldTypeManager Members

[image] [image]

Sitecore 6.4.1 API
FieldTypeManager Members
FieldTypeManager Class Methods See Also Send Feedback

The FieldTypeManager type exposes the following members.

Methods

Name | Description
Clear | Clears this instance.
GetDefaultFieldTypeItem | Gets the type of the default field.
GetField | Gets the field.
GetFieldType | Gets the type of the field.
GetFieldTypeItem(String) | Gets the field type item.
GetFieldTypeItem(Field) | Gets the field type item.
GetTemplateFieldItem | Gets the template field item.

See Also

FieldTypeManager Class
Sitecore.Data.Fields Namespace


FieldTypeManager Methods

[image] [image]

Sitecore 6.4.1 API
FieldTypeManager Methods
FieldTypeManager Class See Also Send Feedback

The FieldTypeManager type exposes the following members.

Methods

Name | Description
Clear | Clears this instance.
GetDefaultFieldTypeItem | Gets the type of the default field.
GetField | Gets the field.
GetFieldType | Gets the type of the field.
GetFieldTypeItem(String) | Gets the field type item.
GetFieldTypeItem(Field) | Gets the field type item.
GetTemplateFieldItem | Gets the template field item.

See Also

FieldTypeManager Class
Sitecore.Data.Fields Namespace


Clear Method

[image]

Sitecore 6.4.1 API
FieldTypeManager..::..Clear Method
FieldTypeManager Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Clear()
Visual Basic
Public Shared Sub Clear
Visual C++
public:
static void Clear()

See Also

FieldTypeManager Class
Sitecore.Data.Fields Namespace


GetDefaultFieldTypeItem Method

[image]

Sitecore 6.4.1 API
FieldTypeManager..::..GetDefaultFieldTypeItem Method
FieldTypeManager Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item GetDefaultFieldTypeItem()
Visual Basic
Public Shared Function GetDefaultFieldTypeItem As Item
Visual C++
public:
static Item^ GetDefaultFieldTypeItem()

Return Value

The default field type.

See Also

FieldTypeManager Class
Sitecore.Data.Fields Namespace


GetField Method

[image]

Sitecore 6.4.1 API
FieldTypeManager..::..GetField Method
FieldTypeManager Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static CustomField GetField(
    Field field
)
Visual Basic
Public Shared Function GetField ( _
    field As Field _
) As CustomField
Visual C++
public:
static CustomField^ GetField(
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.

Return Value

The field.

See Also

FieldTypeManager Class
Sitecore.Data.Fields Namespace


GetFieldType Method

[image]

Sitecore 6.4.1 API
FieldTypeManager..::..GetFieldType Method
FieldTypeManager Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static FieldType GetFieldType(
    string name
)
Visual Basic
Public Shared Function GetFieldType ( _
    name As String _
) As FieldType
Visual C++
public:
static FieldType^ GetFieldType(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

Return Value

The FieldType.

See Also

FieldTypeManager Class
Sitecore.Data.Fields Namespace


GetFieldTypeItem Method

[image] [image]

Sitecore 6.4.1 API
FieldTypeManager..::..GetFieldTypeItem Method
FieldTypeManager Class See Also Send Feedback

Overload List

Name | Description
GetFieldTypeItem(String) | Gets the field type item.
GetFieldTypeItem(Field) | Gets the field type item.

See Also

FieldTypeManager Class
FieldTypeManager Members
Sitecore.Data.Fields Namespace


GetFieldTypeItem Method (String)

[image]

Sitecore 6.4.1 API
FieldTypeManager..::..GetFieldTypeItem Method (String)
FieldTypeManager Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item GetFieldTypeItem(
    string fieldType
)
Visual Basic
Public Shared Function GetFieldTypeItem ( _
    fieldType As String _
) As Item
Visual C++
public:
static Item^ GetFieldTypeItem(
    String^ fieldType
)

Parameters

fieldType
Type: System..::..String
Type of the field.

Return Value

The field type item.

See Also

FieldTypeManager Class
GetFieldTypeItem Overload
Sitecore.Data.Fields Namespace


GetFieldTypeItem Method (Field)

[image]

Sitecore 6.4.1 API
FieldTypeManager..::..GetFieldTypeItem Method (Field)
FieldTypeManager Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item GetFieldTypeItem(
    Field field
)
Visual Basic
Public Shared Function GetFieldTypeItem ( _
    field As Field _
) As Item
Visual C++
public:
static Item^ GetFieldTypeItem(
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.

Return Value

The field type item.

See Also

FieldTypeManager Class
GetFieldTypeItem Overload
Sitecore.Data.Fields Namespace


GetTemplateFieldItem Method

[image]

Sitecore 6.4.1 API
FieldTypeManager..::..GetTemplateFieldItem Method
FieldTypeManager Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TemplateFieldItem GetTemplateFieldItem(
    Field field
)
Visual Basic
Public Shared Function GetTemplateFieldItem ( _
    field As Field _
) As TemplateFieldItem
Visual C++
public:
static TemplateFieldItem^ GetTemplateFieldItem(
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.

Return Value

The template field item.

See Also

FieldTypeManager Class
Sitecore.Data.Fields Namespace


FileDropAreaField Class

[image]

Sitecore 6.4.1 API
FileDropAreaField Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FileDropAreaField : XmlField
Visual Basic
Public Class FileDropAreaField _
    Inherits XmlField
Visual C++
public ref class FileDropAreaField : public XmlField

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Fields..::..CustomField
Sitecore.Data.Fields..::..XmlField
Sitecore.Data.Fields..::..FileDropAreaField

See Also

FileDropAreaField Members
Sitecore.Data.Fields Namespace


FileDropAreaField Members

[image] [image]

Sitecore 6.4.1 API
FileDropAreaField Members
FileDropAreaField Class Constructors Methods Operators Fields Properties See Also Send Feedback

The FileDropAreaField type exposes the following members.

Constructors

 | Name | Description
Public method | FileDropAreaField(Field) | Initializes a new instance of the FileDropAreaField class.
Public method | FileDropAreaField(Field, String) | Initializes a new instance of the FileDropAreaField class.

Methods

 | Name | Description
Public method | ChangeMediaFolder | Changes the media folder for the field.
Public method | Clear | Clears the field value.
Public method | ClearMediaItems | Removes all associated media items.
Protected method | CreateRootFolder | Creates the root folder.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateMediaFolderPath | Generates the media folder path.
Public method | GetAttribute | Gets the attribute. (Inherited from XmlField.)
Protected method | GetCreateMediaFolder | Gets the create media folder.
Protected method | GetCreateMediaFolderPath | Gets or creates media folder path.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetKey | Gets the key.
Protected method | GetMediaFolderPath | Gets the media folder path.
Public method | GetMediaItems | Gets the media items.
Protected method | GetRoot | Gets the root.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | HasOwnMediaFolder | Determines whether field has own media folder.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item link. (Overrides CustomField..::..Relink(ItemLink, Item).)
Public method | RemoveLink | Removes the link. (Overrides CustomField..::..RemoveLink(ItemLink).)
Public method | SetAttribute | Sets the attribute. (Inherited from XmlField.)
Protected method | SetRootFolder | Sets the root folder.
Protected method | SetValue | Sets the value. (Inherited from XmlField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Overrides CustomField..::..UpdateLink(ItemLink).)
Public method | ValidateLinks | Validates the links. (Overrides CustomField..::..ValidateLinks(LinksValidationResult).)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to FileDropAreaField) | Performs an implicit conversion from Field to FileDropAreaField.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)
 | SystemFolderLocation | System folder location.
 | SystemFolderName | System folder name.

Properties

 | Name | Description
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | MediaFolder | Gets the root of the media collection.
Public property | MediaFolderID | Gets the root media item ID of the media collection.
Protected property | MediaID | Gets or sets the media ID attribute value.
Public property | Root | Gets or sets the root tag. (Inherited from XmlField.)
Protected property | UniqueID | Gets or sets the unique ID.
Public property | UseUniqueMediaFolder | Gets or sets a value indicating whether each field must use unique media folder.
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)
Public property | Xml | Gets the XML document contained in this field value. (Inherited from XmlField.)

See Also

FileDropAreaField Class
Sitecore.Data.Fields Namespace


FileDropAreaField Constructor

[image] [image]

Sitecore 6.4.1 API
FileDropAreaField Constructor
FileDropAreaField Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FileDropAreaField(Field) | Initializes a new instance of the FileDropAreaField class.
Public method | FileDropAreaField(Field, String) | Initializes a new instance of the FileDropAreaField class.

See Also

FileDropAreaField Class
FileDropAreaField Members
Sitecore.Data.Fields Namespace


FileDropAreaField Constructor (Field)

[image]

Sitecore 6.4.1 API
FileDropAreaField Constructor (Field)
FileDropAreaField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FileDropAreaField(
    Field innerField
)
Visual Basic
Public Sub New ( _
    innerField As Field _
)
Visual C++
public:
FileDropAreaField(
    Field^ innerField
)

Parameters

innerField
Type: Sitecore.Data.Fields..::..Field
Inner field.

See Also

FileDropAreaField Class
FileDropAreaField Overload
Sitecore.Data.Fields Namespace


FileDropAreaField Fields

[image] [image]

Sitecore 6.4.1 API
FileDropAreaField Fields
FileDropAreaField Class See Also Send Feedback

The FileDropAreaField type exposes the following members.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)
 | SystemFolderLocation | System folder location.
 | SystemFolderName | System folder name.

See Also

FileDropAreaField Class
Sitecore.Data.Fields Namespace


SystemFolderLocation Field

[image]

Sitecore 6.4.1 API
FileDropAreaField..::..SystemFolderLocation Field
FileDropAreaField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly string SystemFolderLocation
Visual Basic
Public Shared ReadOnly SystemFolderLocation As String
Visual C++
public:
static initonly String^ SystemFolderLocation

See Also

FileDropAreaField Class
Sitecore.Data.Fields Namespace


SystemFolderName Field

[image]

Sitecore 6.4.1 API
FileDropAreaField..::..SystemFolderName Field
FileDropAreaField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly string SystemFolderName
Visual Basic
Public Shared ReadOnly SystemFolderName As String
Visual C++
public:
static initonly String^ SystemFolderName

See Also

FileDropAreaField Class
Sitecore.Data.Fields Namespace


FileDropAreaField Methods

[image] [image]

Sitecore 6.4.1 API
FileDropAreaField Methods
FileDropAreaField Class See Also Send Feedback

The FileDropAreaField type exposes the following members.

Methods

 | Name | Description
Public method | ChangeMediaFolder | Changes the media folder for the field.
Public method | Clear | Clears the field value.
Public method | ClearMediaItems | Removes all associated media items.
Protected method | CreateRootFolder | Creates the root folder.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateMediaFolderPath | Generates the media folder path.
Public method | GetAttribute | Gets the attribute. (Inherited from XmlField.)
Protected method | GetCreateMediaFolder | Gets the create media folder.
Protected method | GetCreateMediaFolderPath | Gets or creates media folder path.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetKey | Gets the key.
Protected method | GetMediaFolderPath | Gets the media folder path.
Public method | GetMediaItems | Gets the media items.
Protected method | GetRoot | Gets the root.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | HasOwnMediaFolder | Determines whether field has own media folder.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item link. (Overrides CustomField..::..Relink(ItemLink, Item).)
Public method | RemoveLink | Removes the link. (Overrides CustomField..::..RemoveLink(ItemLink).)
Public method | SetAttribute | Sets the attribute. (Inherited from XmlField.)
Protected method | SetRootFolder | Sets the root folder.
Protected method | SetValue | Sets the value. (Inherited from XmlField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Overrides CustomField..::..UpdateLink(ItemLink).)
Public method | ValidateLinks | Validates the links. (Overrides CustomField..::..ValidateLinks(LinksValidationResult).)

See Also

FileDropAreaField Class
Sitecore.Data.Fields Namespace


ChangeMediaFolder Method

[image]

Sitecore 6.4.1 API
FileDropAreaField..::..ChangeMediaFolder Method
FileDropAreaField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void ChangeMediaFolder(
    Item item
)
Visual Basic
Public Sub ChangeMediaFolder ( _
    item As Item _
)
Visual C++
public:
void ChangeMediaFolder(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The media folder.

See Also

FileDropAreaField Class
Sitecore.Data.Fields Namespace


ClearMediaItems Method

[image]

Sitecore 6.4.1 API
FileDropAreaField..::..ClearMediaItems Method
FileDropAreaField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void ClearMediaItems()
Visual Basic
Public Sub ClearMediaItems
Visual C++
public:
void ClearMediaItems()

See Also

FileDropAreaField Class
Sitecore.Data.Fields Namespace


CreateRootFolder Method

[image]

Sitecore 6.4.1 API
FileDropAreaField..::..CreateRootFolder Method
FileDropAreaField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual Item CreateRootFolder(
    string path
)
Visual Basic
Protected Overridable Function CreateRootFolder ( _
    path As String _
) As Item
Visual C++
protected:
virtual Item^ CreateRootFolder(
    String^ path
)

Parameters

path
Type: System..::..String
The root folder path.

Return Value

The Root folder.

See Also

FileDropAreaField Class
Sitecore.Data.Fields Namespace


GenerateMediaFolderPath Method

[image]

Sitecore 6.4.1 API
FileDropAreaField..::..GenerateMediaFolderPath Method
FileDropAreaField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string GenerateMediaFolderPath(
    string systemLocation,
    string key
)
Visual Basic
Protected Overridable Function GenerateMediaFolderPath ( _
    systemLocation As String, _
    key As String _
) As String
Visual C++
protected:
virtual String^ GenerateMediaFolderPath(
    String^ systemLocation,
    String^ key
)

Parameters

systemLocation
Type: System..::..String
The system location.
key
Type: System..::..String
The item ID.

Return Value

The location of Media folder.

See Also

FileDropAreaField Class
Sitecore.Data.Fields Namespace


GetCreateMediaFolder Method

[image]

Sitecore 6.4.1 API
FileDropAreaField..::..GetCreateMediaFolder Method
FileDropAreaField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected internal virtual Item GetCreateMediaFolder(
    out bool modified
)
Visual Basic
Protected Friend Overridable Function GetCreateMediaFolder ( _
    <OutAttribute> ByRef modified As Boolean _
) As Item
Visual C++
protected public:
virtual Item^ GetCreateMediaFolder(
    [OutAttribute] bool% modified
)

Parameters

modified
Type: System..::..Boolean %
if set to true [modified].

Return Value

The media folder.

See Also

FileDropAreaField Class
Sitecore.Data.Fields Namespace


GetCreateMediaFolderPath Method

[image]

Sitecore 6.4.1 API
FileDropAreaField..::..GetCreateMediaFolderPath Method
FileDropAreaField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected internal virtual string GetCreateMediaFolderPath(
    out bool modified
)
Visual Basic
Protected Friend Overridable Function GetCreateMediaFolderPath ( _
    <OutAttribute> ByRef modified As Boolean _
) As String
Visual C++
protected public:
virtual String^ GetCreateMediaFolderPath(
    [OutAttribute] bool% modified
)

Parameters

modified
Type: System..::..Boolean %
if set to true [modified].

Return Value

The Media folder path.

See Also

FileDropAreaField Class
Sitecore.Data.Fields Namespace


GetKey Method

[image]

Sitecore 6.4.1 API
FileDropAreaField..::..GetKey Method
FileDropAreaField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string GetKey()
Visual Basic
Protected Overridable Function GetKey As String
Visual C++
protected:
virtual String^ GetKey()

Return Value

The unique key.

See Also

FileDropAreaField Class
Sitecore.Data.Fields Namespace


GetMediaFolderPath Method

[image]

Sitecore 6.4.1 API
FileDropAreaField..::..GetMediaFolderPath Method
FileDropAreaField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected internal virtual string GetMediaFolderPath()
Visual Basic
Protected Friend Overridable Function GetMediaFolderPath As String
Visual C++
protected public:
virtual String^ GetMediaFolderPath()

Return Value

The media folder path.

See Also

FileDropAreaField Class
Sitecore.Data.Fields Namespace


GetRoot Method

[image]

Sitecore 6.4.1 API
FileDropAreaField..::..GetRoot Method
FileDropAreaField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected internal virtual Item GetRoot()
Visual Basic
Protected Friend Overridable Function GetRoot As Item
Visual C++
protected public:
virtual Item^ GetRoot()

Return Value

The Root Media folder.

See Also

FileDropAreaField Class
Sitecore.Data.Fields Namespace


Relink Method

[image]

Sitecore 6.4.1 API
FileDropAreaField..::..Relink Method
FileDropAreaField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Relink(
    ItemLink itemLink,
    Item newLink
)
Visual Basic
Public Overrides Sub Relink ( _
    itemLink As ItemLink, _
    newLink As Item _
)
Visual C++
public:
virtual void Relink(
    ItemLink^ itemLink,
    Item^ newLink
) override

Parameters

itemLink
Type: Sitecore.Links..::..ItemLink
The item link.
newLink
Type: Sitecore.Data.Items..::..Item
The new link.

See Also

FileDropAreaField Class
Sitecore.Data.Fields Namespace


RemoveLink Method

[image]

Sitecore 6.4.1 API
FileDropAreaField..::..RemoveLink Method
FileDropAreaField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void RemoveLink(
    ItemLink itemLink
)
Visual Basic
Public Overrides Sub RemoveLink ( _
    itemLink As ItemLink _
)
Visual C++
public:
virtual void RemoveLink(
    ItemLink^ itemLink
) override

Parameters

itemLink
Type: Sitecore.Links..::..ItemLink
The item link.

See Also

FileDropAreaField Class
Sitecore.Data.Fields Namespace


SetRootFolder Method

[image]

Sitecore 6.4.1 API
FileDropAreaField..::..SetRootFolder Method
FileDropAreaField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void SetRootFolder(
    ID id
)
Visual Basic
Protected Overridable Sub SetRootFolder ( _
    id As ID _
)
Visual C++
protected:
virtual void SetRootFolder(
    ID^ id
)

Parameters

id
Type: Sitecore.Data..::..ID
The root ID.

See Also

FileDropAreaField Class
Sitecore.Data.Fields Namespace


UpdateLink Method

[image]

Sitecore 6.4.1 API
FileDropAreaField..::..UpdateLink Method
FileDropAreaField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void UpdateLink(
    ItemLink itemLink
)
Visual Basic
Public Overrides Sub UpdateLink ( _
    itemLink As ItemLink _
)
Visual C++
public:
virtual void UpdateLink(
    ItemLink^ itemLink
) override

Parameters

itemLink
Type: Sitecore.Links..::..ItemLink
The item link.

See Also

FileDropAreaField Class
Sitecore.Data.Fields Namespace


FileDropAreaField Type Conversions

[image] [image]

Sitecore 6.4.1 API
FileDropAreaField Type Conversions
FileDropAreaField Class See Also Send Feedback

The FileDropAreaField type exposes the following members.

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to FileDropAreaField) | Performs an implicit conversion from Field to FileDropAreaField.

See Also

FileDropAreaField Class
Sitecore.Data.Fields Namespace


Implicit Conversion (Field to FileDropAreaField)

[image]

Sitecore 6.4.1 API
FileDropAreaField ImplicitWideningImplicitImplicitImplicit Conversion (Field to FileDropAreaField)
FileDropAreaField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator FileDropAreaField (
    Field field
)
Visual Basic
Public Shared Widening Operator CType ( _
    field As Field _
) As FileDropAreaField
Visual C++
static implicit operator FileDropAreaField^ (
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.

Return Value

The result of the conversion.

See Also

FileDropAreaField Class
Sitecore.Data.Fields Namespace


FileDropAreaField Properties

[image] [image]

Sitecore 6.4.1 API
FileDropAreaField Properties
FileDropAreaField Class See Also Send Feedback

The FileDropAreaField type exposes the following members.

Properties

 | Name | Description
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | MediaFolder | Gets the root of the media collection.
Public property | MediaFolderID | Gets the root media item ID of the media collection.
Protected property | MediaID | Gets or sets the media ID attribute value.
Public property | Root | Gets or sets the root tag. (Inherited from XmlField.)
Protected property | UniqueID | Gets or sets the unique ID.
Public property | UseUniqueMediaFolder | Gets or sets a value indicating whether each field must use unique media folder.
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)
Public property | Xml | Gets the XML document contained in this field value. (Inherited from XmlField.)

See Also

FileDropAreaField Class
Sitecore.Data.Fields Namespace


MediaFolder Property

[image]

Sitecore 6.4.1 API
FileDropAreaField..::..MediaFolder Property
FileDropAreaField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item MediaFolder { get; }
Visual Basic
Public ReadOnly Property MediaFolder As Item
    Get
Visual C++
public:
property Item^ MediaFolder {
    Item^ get ();
}

Field Value

The root for the media collection.

See Also

FileDropAreaField Class
Sitecore.Data.Fields Namespace


MediaFolderID Property

[image]

Sitecore 6.4.1 API
FileDropAreaField..::..MediaFolderID Property
FileDropAreaField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID MediaFolderID { get; }
Visual Basic
Public ReadOnly Property MediaFolderID As ID
    Get
Visual C++
public:
property ID^ MediaFolderID {
    ID^ get ();
}

Field Value

The root media folder ID.

See Also

FileDropAreaField Class
Sitecore.Data.Fields Namespace


MediaID Property

[image]

Sitecore 6.4.1 API
FileDropAreaField..::..MediaID Property
FileDropAreaField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected string MediaID { get; set; }
Visual Basic
Protected Property MediaID As String
    Get
    Set
Visual C++
protected:
property String^ MediaID {
    String^ get ();
    void set (String^ value);
}

Field Value

The media ID attribute value.

See Also

FileDropAreaField Class
Sitecore.Data.Fields Namespace


UniqueID Property

[image]

Sitecore 6.4.1 API
FileDropAreaField..::..UniqueID Property
FileDropAreaField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected internal string UniqueID { get; set; }
Visual Basic
Protected Friend Property UniqueID As String
    Get
    Set
Visual C++
protected public:
property String^ UniqueID {
    String^ get ();
    void set (String^ value);
}

Field Value

The unique ID.

See Also

FileDropAreaField Class
Sitecore.Data.Fields Namespace


UseUniqueMediaFolder Property

[image]

Sitecore 6.4.1 API
FileDropAreaField..::..UseUniqueMediaFolder Property
FileDropAreaField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool UseUniqueMediaFolder { get; set; }
Visual Basic
Public Property UseUniqueMediaFolder As Boolean
    Get
    Set
Visual C++
public:
property bool UseUniqueMediaFolder {
    bool get ();
    void set (bool value);
}

Field Value

true if the field must use unique media folder; otherwise, false.

See Also

FileDropAreaField Class
Sitecore.Data.Fields Namespace


FileField Class

[image]

Sitecore 6.4.1 API
FileField Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FileField : XmlField
Visual Basic
Public Class FileField _
    Inherits XmlField
Visual C++
public ref class FileField : public XmlField

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Fields..::..CustomField
Sitecore.Data.Fields..::..XmlField
Sitecore.Data.Fields..::..FileField

See Also

FileField Members
Sitecore.Data.Fields Namespace


FileField Members

[image] [image]

Sitecore 6.4.1 API
FileField Members
FileField Class Constructors Methods Operators Fields Properties See Also Send Feedback

The FileField type exposes the following members.

Constructors

 | Name | Description
Public method | FileField(Field) | Creates a new FileField instance.
Public method | FileField(Field, String) | Initializes a new instance of the FileField class.

Methods

 | Name | Description
Public method | Clear | Clears this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttribute | Gets the attribute. (Inherited from XmlField.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item. (Overrides CustomField..::..Relink(ItemLink, Item).)
Public method | RemoveLink | Removes the link. (Overrides CustomField..::..RemoveLink(ItemLink).)
Public method | SetAttribute | Sets the attribute. (Inherited from XmlField.)
Protected method | SetValue | Sets the value. (Inherited from XmlField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Overrides CustomField..::..UpdateLink(ItemLink).)
Public method | ValidateLinks | Validates the links. (Overrides CustomField..::..ValidateLinks(LinksValidationResult).)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to FileField) | Converts a Field to a FileField.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

Properties

 | Name | Description
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | MediaDatabase | Gets or sets the database containing the the media.
Public property | MediaID | Gets or sets the ID of the media item.
Public property | MediaItem | Gets the media item.
Public property | MediaLanguage | Gets or sets the language of the media item to use.
Public property | MediaVersion | Gets or sets the version of the media item to use.
Public property | Root | Gets or sets the root tag. (Inherited from XmlField.)
Public property | Src | Gets or sets the source path.
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)
Public property | Xml | Gets the XML document contained in this field value. (Inherited from XmlField.)

See Also

FileField Class
Sitecore.Data.Fields Namespace


FileField Constructor

[image] [image]

Sitecore 6.4.1 API
FileField Constructor
FileField Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FileField(Field) | Creates a new FileField instance.
Public method | FileField(Field, String) | Initializes a new instance of the FileField class.

See Also

FileField Class
FileField Members
Sitecore.Data.Fields Namespace


FileField Constructor (Field)

[image]

Sitecore 6.4.1 API
FileField Constructor (Field)
FileField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FileField(
    Field innerField
)
Visual Basic
Public Sub New ( _
    innerField As Field _
)
Visual C++
public:
FileField(
    Field^ innerField
)

Parameters

innerField
Type: Sitecore.Data.Fields..::..Field
Inner field.

See Also

FileField Class
FileField Overload
Sitecore.Data.Fields Namespace


FileField Constructor (Field, String)

[image]

Sitecore 6.4.1 API
FileField Constructor (Field, String)
FileField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FileField(
    Field innerField,
    string runtimeValue
)
Visual Basic
Public Sub New ( _
    innerField As Field, _
    runtimeValue As String _
)
Visual C++
public:
FileField(
    Field^ innerField,
    String^ runtimeValue
)

Parameters

innerField
Type: Sitecore.Data.Fields..::..Field
The inner field.
runtimeValue
Type: System..::..String
The runtime value.

See Also

FileField Class
FileField Overload
Sitecore.Data.Fields Namespace


FileField Fields

[image] [image]

Sitecore 6.4.1 API
FileField Fields
FileField Class See Also Send Feedback

The FileField type exposes the following members.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

See Also

FileField Class
Sitecore.Data.Fields Namespace


FileField Methods

[image] [image]

Sitecore 6.4.1 API
FileField Methods
FileField Class See Also Send Feedback

The FileField type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Clears this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttribute | Gets the attribute. (Inherited from XmlField.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item. (Overrides CustomField..::..Relink(ItemLink, Item).)
Public method | RemoveLink | Removes the link. (Overrides CustomField..::..RemoveLink(ItemLink).)
Public method | SetAttribute | Sets the attribute. (Inherited from XmlField.)
Protected method | SetValue | Sets the value. (Inherited from XmlField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Overrides CustomField..::..UpdateLink(ItemLink).)
Public method | ValidateLinks | Validates the links. (Overrides CustomField..::..ValidateLinks(LinksValidationResult).)

See Also

FileField Class
Sitecore.Data.Fields Namespace


Clear Method

[image]

Sitecore 6.4.1 API
FileField..::..Clear Method
FileField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

FileField Class
Sitecore.Data.Fields Namespace


RemoveLink Method

[image]

Sitecore 6.4.1 API
FileField..::..RemoveLink Method
FileField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void RemoveLink(
    ItemLink itemLink
)
Visual Basic
Public Overrides Sub RemoveLink ( _
    itemLink As ItemLink _
)
Visual C++
public:
virtual void RemoveLink(
    ItemLink^ itemLink
) override

Parameters

itemLink
Type: Sitecore.Links..::..ItemLink
The item link.

See Also

FileField Class
Sitecore.Data.Fields Namespace


UpdateLink Method

[image]

Sitecore 6.4.1 API
FileField..::..UpdateLink Method
FileField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void UpdateLink(
    ItemLink itemLink
)
Visual Basic
Public Overrides Sub UpdateLink ( _
    itemLink As ItemLink _
)
Visual C++
public:
virtual void UpdateLink(
    ItemLink^ itemLink
) override

Parameters

itemLink
Type: Sitecore.Links..::..ItemLink
The link.

See Also

FileField Class
Sitecore.Data.Fields Namespace


ValidateLinks Method

[image]

Sitecore 6.4.1 API
FileField..::..ValidateLinks Method
FileField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void ValidateLinks(
    LinksValidationResult result
)
Visual Basic
Public Overrides Sub ValidateLinks ( _
    result As LinksValidationResult _
)
Visual C++
public:
virtual void ValidateLinks(
    LinksValidationResult^ result
) override

Parameters

result
Type: Sitecore.Links..::..LinksValidationResult
The result.

See Also

FileField Class
Sitecore.Data.Fields Namespace


Implicit Conversion (Field to FileField)

[image]

Sitecore 6.4.1 API
FileField ImplicitWideningImplicitImplicitImplicit Conversion (Field to FileField)
FileField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator FileField (
    Field field
)
Visual Basic
Public Shared Widening Operator CType ( _
    field As Field _
) As FileField
Visual C++
static implicit operator FileField^ (
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
Field.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Fields.FileField.op_Implicit(Sitecore.Data.Fields.Field)~Sitecore.Data.Fields.FileField"]

See Also

FileField Class
Sitecore.Data.Fields Namespace


MediaDatabase Property

[image]

Sitecore 6.4.1 API
FileField..::..MediaDatabase Property
FileField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database MediaDatabase { get; set; }
Visual Basic
Public Property MediaDatabase As Database
    Get
    Set
Visual C++
public:
property Database^ MediaDatabase {
    Database^ get ();
    void set (Database^ value);
}

Field Value

The media database.

See Also

FileField Class
Sitecore.Data.Fields Namespace


MediaID Property

[image]

Sitecore 6.4.1 API
FileField..::..MediaID Property
FileField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID MediaID { get; set; }
Visual Basic
Public Property MediaID As ID
    Get
    Set
Visual C++
public:
property ID^ MediaID {
    ID^ get ();
    void set (ID^ value);
}

Field Value

The media ID.

See Also

FileField Class
Sitecore.Data.Fields Namespace


MediaItem Property

[image]

Sitecore 6.4.1 API
FileField..::..MediaItem Property
FileField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item MediaItem { get; }
Visual Basic
Public ReadOnly Property MediaItem As Item
    Get
Visual C++
public:
property Item^ MediaItem {
    Item^ get ();
}

Field Value

The media item.

See Also

FileField Class
Sitecore.Data.Fields Namespace


MediaVersion Property

[image]

Sitecore 6.4.1 API
FileField..::..MediaVersion Property
FileField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Version MediaVersion { get; set; }
Visual Basic
Public Property MediaVersion As Version
    Get
    Set
Visual C++
public:
property Version^ MediaVersion {
    Version^ get ();
    void set (Version^ value);
}

Field Value

The media version.

See Also

FileField Class
Sitecore.Data.Fields Namespace


Src Property

[image]

Sitecore 6.4.1 API
FileField..::..Src Property
FileField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Src { get; set; }
Visual Basic
Public Property Src As String
    Get
    Set
Visual C++
public:
property String^ Src {
    String^ get ();
    void set (String^ value);
}

Field Value

The source.

See Also

FileField Class
Sitecore.Data.Fields Namespace


GroupedDroplinkField Class

[image]

Sitecore 6.4.1 API
GroupedDroplinkField Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public sealed class GroupedDroplinkField : LookupField
Visual Basic
Public NotInheritable Class GroupedDroplinkField _
    Inherits LookupField
Visual C++
public ref class GroupedDroplinkField sealed : public LookupField

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Fields..::..CustomField
Sitecore.Data.Fields..::..LookupField
Sitecore.Data.Fields..::..GroupedDroplinkField

See Also

GroupedDroplinkField Members
Sitecore.Data.Fields Namespace


GroupedDroplinkField Members

[image] [image]

Sitecore 6.4.1 API
GroupedDroplinkField Members
GroupedDroplinkField Class Constructors Methods Operators Fields Properties See Also Send Feedback

The GroupedDroplinkField type exposes the following members.

Constructors

 | Name | Description
Public method | GroupedDroplinkField | Creates a new GroupedDroplinkField instance.

Methods

 | Name | Description
Public method | Clear | Clears this instance. (Inherited from LookupField.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item. (Inherited from LookupField.)
Public method | RemoveLink | Removes the link. (Inherited from LookupField.)
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Inherited from CustomField.)
Public method | ValidateLinks | Validates the links. (Inherited from LookupField.)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to GroupedDroplinkField) | Converts a Field to a GroupedDroplinkField.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

Properties

 | Name | Description
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | TargetID | Gets the target ID. (Inherited from LookupField.)
Public property | TargetItem | Gets the target item. (Inherited from LookupField.)
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

GroupedDroplinkField Class
Sitecore.Data.Fields Namespace


GroupedDroplinkField Constructor

[image]

Sitecore 6.4.1 API
GroupedDroplinkField Constructor
GroupedDroplinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GroupedDroplinkField(
    Field innerField
)
Visual Basic
Public Sub New ( _
    innerField As Field _
)
Visual C++
public:
GroupedDroplinkField(
    Field^ innerField
)

Parameters

innerField
Type: Sitecore.Data.Fields..::..Field
Inner field.

See Also

GroupedDroplinkField Class
Sitecore.Data.Fields Namespace


GroupedDroplinkField Fields

[image] [image]

Sitecore 6.4.1 API
GroupedDroplinkField Fields
GroupedDroplinkField Class See Also Send Feedback

The GroupedDroplinkField type exposes the following members.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

See Also

GroupedDroplinkField Class
Sitecore.Data.Fields Namespace


GroupedDroplinkField Methods

[image] [image]

Sitecore 6.4.1 API
GroupedDroplinkField Methods
GroupedDroplinkField Class See Also Send Feedback

The GroupedDroplinkField type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Clears this instance. (Inherited from LookupField.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item. (Inherited from LookupField.)
Public method | RemoveLink | Removes the link. (Inherited from LookupField.)
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Inherited from CustomField.)
Public method | ValidateLinks | Validates the links. (Inherited from LookupField.)

See Also

GroupedDroplinkField Class
Sitecore.Data.Fields Namespace


GroupedDroplinkField Type Conversions

[image] [image]

Sitecore 6.4.1 API
GroupedDroplinkField Type Conversions
GroupedDroplinkField Class See Also Send Feedback

The GroupedDroplinkField type exposes the following members.

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to GroupedDroplinkField) | Converts a Field to a GroupedDroplinkField.

See Also

GroupedDroplinkField Class
Sitecore.Data.Fields Namespace


Implicit Conversion (Field to GroupedDroplinkField)

[image]

Sitecore 6.4.1 API
GroupedDroplinkField ImplicitWideningImplicitImplicitImplicit Conversion (Field to GroupedDroplinkField)
GroupedDroplinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator GroupedDroplinkField (
    Field field
)
Visual Basic
Public Shared Widening Operator CType ( _
    field As Field _
) As GroupedDroplinkField
Visual C++
static implicit operator GroupedDroplinkField^ (
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.

Return Value

The implicit operator.

See Also

GroupedDroplinkField Class
Sitecore.Data.Fields Namespace


GroupedDroplinkField Properties

[image] [image]

Sitecore 6.4.1 API
GroupedDroplinkField Properties
GroupedDroplinkField Class See Also Send Feedback

The GroupedDroplinkField type exposes the following members.

Properties

 | Name | Description
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | TargetID | Gets the target ID. (Inherited from LookupField.)
Public property | TargetItem | Gets the target item. (Inherited from LookupField.)
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

GroupedDroplinkField Class
Sitecore.Data.Fields Namespace


GroupedDroplistField Class

[image]

Sitecore 6.4.1 API
GroupedDroplistField Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GroupedDroplistField : ValueLookupField
Visual Basic
Public Class GroupedDroplistField _
    Inherits ValueLookupField
Visual C++
public ref class GroupedDroplistField : public ValueLookupField

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Fields..::..CustomField
Sitecore.Data.Fields..::..ValueLookupField
Sitecore.Data.Fields..::..GroupedDroplistField

See Also

GroupedDroplistField Members
Sitecore.Data.Fields Namespace


GroupedDroplistField Members

[image] [image]

Sitecore 6.4.1 API
GroupedDroplistField Members
GroupedDroplistField Class Constructors Methods Operators Fields Properties See Also Send Feedback

The GroupedDroplistField type exposes the following members.

Constructors

 | Name | Description
Public method | GroupedDroplistField | Creates a new LookupField instance.

Methods

 | Name | Description
Public method | Clear | Clears this instance. (Inherited from ValueLookupField.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item. (Inherited from ValueLookupField.)
Public method | RemoveLink | Removes the link. (Inherited from ValueLookupField.)
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Inherited from ValueLookupField.)
Public method | ValidateLinks | Validates the links. (Overrides ValueLookupField..::..ValidateLinks(LinksValidationResult).)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to GroupedDroplistField) | Converts a Field to a LookupField.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

Properties

 | Name | Description
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

GroupedDroplistField Class
Sitecore.Data.Fields Namespace


GroupedDroplistField Constructor

[image]

Sitecore 6.4.1 API
GroupedDroplistField Constructor
GroupedDroplistField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GroupedDroplistField(
    Field innerField
)
Visual Basic
Public Sub New ( _
    innerField As Field _
)
Visual C++
public:
GroupedDroplistField(
    Field^ innerField
)

Parameters

innerField
Type: Sitecore.Data.Fields..::..Field
Inner field.

See Also

GroupedDroplistField Class
Sitecore.Data.Fields Namespace


GroupedDroplistField Fields

[image] [image]

Sitecore 6.4.1 API
GroupedDroplistField Fields
GroupedDroplistField Class See Also Send Feedback

The GroupedDroplistField type exposes the following members.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

See Also

GroupedDroplistField Class
Sitecore.Data.Fields Namespace


GroupedDroplistField Methods

[image] [image]

Sitecore 6.4.1 API
GroupedDroplistField Methods
GroupedDroplistField Class See Also Send Feedback

The GroupedDroplistField type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Clears this instance. (Inherited from ValueLookupField.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item. (Inherited from ValueLookupField.)
Public method | RemoveLink | Removes the link. (Inherited from ValueLookupField.)
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Inherited from ValueLookupField.)
Public method | ValidateLinks | Validates the links. (Overrides ValueLookupField..::..ValidateLinks(LinksValidationResult).)

See Also

GroupedDroplistField Class
Sitecore.Data.Fields Namespace


ValidateLinks Method

[image]

Sitecore 6.4.1 API
GroupedDroplistField..::..ValidateLinks Method
GroupedDroplistField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void ValidateLinks(
    LinksValidationResult result
)
Visual Basic
Public Overrides Sub ValidateLinks ( _
    result As LinksValidationResult _
)
Visual C++
public:
virtual void ValidateLinks(
    LinksValidationResult^ result
) override

Parameters

result
Type: Sitecore.Links..::..LinksValidationResult
The result.

See Also

GroupedDroplistField Class
Sitecore.Data.Fields Namespace


GroupedDroplistField Type Conversions

[image] [image]

Sitecore 6.4.1 API
GroupedDroplistField Type Conversions
GroupedDroplistField Class See Also Send Feedback

The GroupedDroplistField type exposes the following members.

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to GroupedDroplistField) | Converts a Field to a LookupField.

See Also

GroupedDroplistField Class
Sitecore.Data.Fields Namespace


Implicit Conversion (Field to GroupedDroplistField)

[image]

Sitecore 6.4.1 API
GroupedDroplistField ImplicitWideningImplicitImplicitImplicit Conversion (Field to GroupedDroplistField)
GroupedDroplistField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator GroupedDroplistField (
    Field field
)
Visual Basic
Public Shared Widening Operator CType ( _
    field As Field _
) As GroupedDroplistField
Visual C++
static implicit operator GroupedDroplistField^ (
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.

Return Value

The implicit operator.

See Also

GroupedDroplistField Class
Sitecore.Data.Fields Namespace


GroupedDroplistField Properties

[image] [image]

Sitecore 6.4.1 API
GroupedDroplistField Properties
GroupedDroplistField Class See Also Send Feedback

The GroupedDroplistField type exposes the following members.

Properties

 | Name | Description
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

GroupedDroplistField Class
Sitecore.Data.Fields Namespace


HtmlField Class

[image]

Sitecore 6.4.1 API
HtmlField Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class HtmlField : CustomField
Visual Basic
Public Class HtmlField _
    Inherits CustomField
Visual C++
public ref class HtmlField : public CustomField

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Fields..::..CustomField
Sitecore.Data.Fields..::..HtmlField

See Also

HtmlField Members
Sitecore.Data.Fields Namespace


HtmlField Members

[image] [image]

Sitecore 6.4.1 API
HtmlField Members
HtmlField Class Constructors Methods Operators Fields Properties See Also Send Feedback

The HtmlField type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlField | Creates a new HtmlField instance.

Methods

 | Name | Description
 | ConvertToXHtml | Obsolete. Converts to HTML fragment to XHTML.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons | Gets the web edit buttons. (Overrides CustomField..::..GetWebEditButtons()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item. (Overrides CustomField..::..Relink(ItemLink, Item).)
Public method | RemoveLink | Removes the link. (Overrides CustomField..::..RemoveLink(ItemLink).)
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
 | TightenRelativeImageLinks | Tightens the relative image links.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Inherited from CustomField.)
Public method | ValidateLinks | Validates the links. (Overrides CustomField..::..ValidateLinks(LinksValidationResult).)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to HtmlField) | Converts a Field to a HtmlField.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

Properties

 | Name | Description
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

HtmlField Class
Sitecore.Data.Fields Namespace


HtmlField Constructor

[image]

Sitecore 6.4.1 API
HtmlField Constructor
HtmlField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HtmlField(
    Field innerField
)
Visual Basic
Public Sub New ( _
    innerField As Field _
)
Visual C++
public:
HtmlField(
    Field^ innerField
)

Parameters

innerField
Type: Sitecore.Data.Fields..::..Field
Inner field.

See Also

HtmlField Class
Sitecore.Data.Fields Namespace


HtmlField Methods

[image] [image]

Sitecore 6.4.1 API
HtmlField Methods
HtmlField Class See Also Send Feedback

The HtmlField type exposes the following members.

Methods

 | Name | Description
 | ConvertToXHtml | Obsolete. Converts to HTML fragment to XHTML.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons | Gets the web edit buttons. (Overrides CustomField..::..GetWebEditButtons()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item. (Overrides CustomField..::..Relink(ItemLink, Item).)
Public method | RemoveLink | Removes the link. (Overrides CustomField..::..RemoveLink(ItemLink).)
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
 | TightenRelativeImageLinks | Tightens the relative image links.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Inherited from CustomField.)
Public method | ValidateLinks | Validates the links. (Overrides CustomField..::..ValidateLinks(LinksValidationResult).)

See Also

HtmlField Class
Sitecore.Data.Fields Namespace


ConvertToXHtml Method

[image]

Sitecore 6.4.1 API
HtmlField..::..ConvertToXHtml Method
HtmlField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use XHtml.Convert() instead.")]
public static string ConvertToXHtml(
    string html
)
Visual Basic
<ObsoleteAttribute("Use XHtml.Convert() instead.")> _
Public Shared Function ConvertToXHtml ( _
    html As String _
) As String
Visual C++
[ObsoleteAttribute(L"Use XHtml.Convert() instead.")]
public:
static String^ ConvertToXHtml(
    String^ html
)

Parameters

html
Type: System..::..String
HTML.

Return Value

The to X HTML.

See Also

HtmlField Class
Sitecore.Data.Fields Namespace


GetWebEditButtons Method

[image]

Sitecore 6.4.1 API
HtmlField..::..GetWebEditButtons Method
HtmlField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override List<WebEditButton> GetWebEditButtons()
Visual Basic
Public Overrides Function GetWebEditButtons As List(Of WebEditButton)
Visual C++
public:
virtual List<WebEditButton^>^ GetWebEditButtons() override

Return Value

The web edit buttons.

See Also

HtmlField Class
Sitecore.Data.Fields Namespace


Relink Method

[image]

Sitecore 6.4.1 API
HtmlField..::..Relink Method
HtmlField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Relink(
    ItemLink itemLink,
    Item newLink
)
Visual Basic
Public Overrides Sub Relink ( _
    itemLink As ItemLink, _
    newLink As Item _
)
Visual C++
public:
virtual void Relink(
    ItemLink^ itemLink,
    Item^ newLink
) override

Parameters

itemLink
Type: Sitecore.Links..::..ItemLink
The item link.
newLink
Type: Sitecore.Data.Items..::..Item
The new link.

See Also

HtmlField Class
Sitecore.Data.Fields Namespace


RemoveLink Method

[image]

Sitecore 6.4.1 API
HtmlField..::..RemoveLink Method
HtmlField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void RemoveLink(
    ItemLink itemLink
)
Visual Basic
Public Overrides Sub RemoveLink ( _
    itemLink As ItemLink _
)
Visual C++
public:
virtual void RemoveLink(
    ItemLink^ itemLink
) override

Parameters

itemLink
Type: Sitecore.Links..::..ItemLink
The item link.

See Also

HtmlField Class
Sitecore.Data.Fields Namespace


TightenRelativeImageLinks Method

[image]

Sitecore 6.4.1 API
HtmlField..::..TightenRelativeImageLinks Method
HtmlField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string TightenRelativeImageLinks(
    string html
)
Visual Basic
Public Shared Function TightenRelativeImageLinks ( _
    html As String _
) As String
Visual C++
public:
static String^ TightenRelativeImageLinks(
    String^ html
)

Parameters

html
Type: System..::..String
The HTML.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Fields.HtmlField.TightenRelativeImageLinks(System.String)"]

See Also

HtmlField Class
Sitecore.Data.Fields Namespace


ValidateLinks Method

[image]

Sitecore 6.4.1 API
HtmlField..::..ValidateLinks Method
HtmlField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void ValidateLinks(
    LinksValidationResult result
)
Visual Basic
Public Overrides Sub ValidateLinks ( _
    result As LinksValidationResult _
)
Visual C++
public:
virtual void ValidateLinks(
    LinksValidationResult^ result
) override

Parameters

result
Type: Sitecore.Links..::..LinksValidationResult
The result.

See Also

HtmlField Class
Sitecore.Data.Fields Namespace


HtmlField Type Conversions

[image] [image]

Sitecore 6.4.1 API
HtmlField Type Conversions
HtmlField Class See Also Send Feedback

The HtmlField type exposes the following members.

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to HtmlField) | Converts a Field to a HtmlField.

See Also

HtmlField Class
Sitecore.Data.Fields Namespace


Implicit Conversion (Field to HtmlField)

[image]

Sitecore 6.4.1 API
HtmlField ImplicitWideningImplicitImplicitImplicit Conversion (Field to HtmlField)
HtmlField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator HtmlField (
    Field field
)
Visual Basic
Public Shared Widening Operator CType ( _
    field As Field _
) As HtmlField
Visual C++
static implicit operator HtmlField^ (
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.

Return Value

The implicit operator.

See Also

HtmlField Class
Sitecore.Data.Fields Namespace


ImageField Class

[image]

Sitecore 6.4.1 API
ImageField Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ImageField : XmlField
Visual Basic
Public Class ImageField _
    Inherits XmlField
Visual C++
public ref class ImageField : public XmlField

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Fields..::..CustomField
Sitecore.Data.Fields..::..XmlField
Sitecore.Data.Fields..::..ImageField
Sitecore.Data.Fields..::..ThumbnailField

See Also

ImageField Members
Sitecore.Data.Fields Namespace


ImageField Members

[image] [image]

Sitecore 6.4.1 API
ImageField Members
ImageField Class Constructors Methods Operators Fields Properties See Also Send Feedback

The ImageField type exposes the following members.

Constructors

 | Name | Description
Public method | ImageField(Field) | Initializes a new instance of the ImageField class. Creates a new ImageField instance.
Public method | ImageField(Field, String) | Initializes a new instance of the ImageField class.

Methods

 | Name | Description
Public method | Clear | Clears this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttribute | Gets the attribute. (Inherited from XmlField.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item. (Overrides CustomField..::..Relink(ItemLink, Item).)
Public method | RemoveLink | Removes the link. (Overrides CustomField..::..RemoveLink(ItemLink).)
Public method | SetAttribute | Sets the attribute. (Inherited from XmlField.)
Protected method | SetValue | Sets the value. (Inherited from XmlField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Inherited from CustomField.)
Public method | ValidateLinks | Validates the links. (Overrides CustomField..::..ValidateLinks(LinksValidationResult).)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to ImageField) | Converts a Field to a ImageField.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

Properties

 | Name | Description
Public property | Alt | Gets or sets the Alt text.
Public property | Border | Gets or sets the Border value.
Public property | Class | Gets or sets the HTML class.
Public property | Height | Gets or sets the height.
Public property | HSpace | Gets or sets the HSpace value.
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | InternalPath | Obsolete. Gets the internal path, if any.
Public property | IsInternal | Gets a value indicating whether the image is internal.
Public property | LinkType | Gets or sets the link type.
Public property | MediaDatabase | Gets or sets the database containing the the media.
Public property | MediaID | Gets or sets the ID of the media item.
Public property | MediaItem | Gets the media item.
Public property | MediaLanguage | Gets or sets the language of the media item to use.
Public property | MediaPath | Obsolete. Gets or sets the media path.
Public property | MediaVersion | Gets or sets the version of the media item to use.
Public property | Root | Gets or sets the root tag. (Inherited from XmlField.)
Public property | Src | Obsolete. Gets or sets the source path.
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)
Public property | VSpace | Gets or sets the VSpace value.
Public property | Width | Gets or sets the width.
Public property | Xml | Gets the XML document contained in this field value. (Inherited from XmlField.)

See Also

ImageField Class
Sitecore.Data.Fields Namespace


ImageField Constructor

[image] [image]

Sitecore 6.4.1 API
ImageField Constructor
ImageField Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ImageField(Field) | Initializes a new instance of the ImageField class. Creates a new ImageField instance.
Public method | ImageField(Field, String) | Initializes a new instance of the ImageField class.

See Also

ImageField Class
ImageField Members
Sitecore.Data.Fields Namespace


ImageField Constructor (Field)

[image]

Sitecore 6.4.1 API
ImageField Constructor (Field)
ImageField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ImageField(
    Field innerField
)
Visual Basic
Public Sub New ( _
    innerField As Field _
)
Visual C++
public:
ImageField(
    Field^ innerField
)

Parameters

innerField
Type: Sitecore.Data.Fields..::..Field
Inner field.

See Also

ImageField Class
ImageField Overload
Sitecore.Data.Fields Namespace


ImageField Constructor (Field, String)

[image]

Sitecore 6.4.1 API
ImageField Constructor (Field, String)
ImageField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ImageField(
    Field innerField,
    string runtimeValue
)
Visual Basic
Public Sub New ( _
    innerField As Field, _
    runtimeValue As String _
)
Visual C++
public:
ImageField(
    Field^ innerField,
    String^ runtimeValue
)

Parameters

innerField
Type: Sitecore.Data.Fields..::..Field
The inner field.
runtimeValue
Type: System..::..String
The runtime value.

See Also

ImageField Class
ImageField Overload
Sitecore.Data.Fields Namespace


ImageField Fields

[image] [image]

Sitecore 6.4.1 API
ImageField Fields
ImageField Class See Also Send Feedback

The ImageField type exposes the following members.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

See Also

ImageField Class
Sitecore.Data.Fields Namespace


ImageField Methods

[image] [image]

Sitecore 6.4.1 API
ImageField Methods
ImageField Class See Also Send Feedback

The ImageField type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Clears this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttribute | Gets the attribute. (Inherited from XmlField.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item. (Overrides CustomField..::..Relink(ItemLink, Item).)
Public method | RemoveLink | Removes the link. (Overrides CustomField..::..RemoveLink(ItemLink).)
Public method | SetAttribute | Sets the attribute. (Inherited from XmlField.)
Protected method | SetValue | Sets the value. (Inherited from XmlField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Inherited from CustomField.)
Public method | ValidateLinks | Validates the links. (Overrides CustomField..::..ValidateLinks(LinksValidationResult).)

See Also

ImageField Class
Sitecore.Data.Fields Namespace


Clear Method

[image]

Sitecore 6.4.1 API
ImageField..::..Clear Method
ImageField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

ImageField Class
Sitecore.Data.Fields Namespace


Relink Method

[image]

Sitecore 6.4.1 API
ImageField..::..Relink Method
ImageField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Relink(
    ItemLink itemLink,
    Item newLink
)
Visual Basic
Public Overrides Sub Relink ( _
    itemLink As ItemLink, _
    newLink As Item _
)
Visual C++
public:
virtual void Relink(
    ItemLink^ itemLink,
    Item^ newLink
) override

Parameters

itemLink
Type: Sitecore.Links..::..ItemLink
The item link.
newLink
Type: Sitecore.Data.Items..::..Item
The new link.

See Also

ImageField Class
Sitecore.Data.Fields Namespace


RemoveLink Method

[image]

Sitecore 6.4.1 API
ImageField..::..RemoveLink Method
ImageField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void RemoveLink(
    ItemLink itemLink
)
Visual Basic
Public Overrides Sub RemoveLink ( _
    itemLink As ItemLink _
)
Visual C++
public:
virtual void RemoveLink(
    ItemLink^ itemLink
) override

Parameters

itemLink
Type: Sitecore.Links..::..ItemLink
The item link.

See Also

ImageField Class
Sitecore.Data.Fields Namespace


ValidateLinks Method

[image]

Sitecore 6.4.1 API
ImageField..::..ValidateLinks Method
ImageField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void ValidateLinks(
    LinksValidationResult result
)
Visual Basic
Public Overrides Sub ValidateLinks ( _
    result As LinksValidationResult _
)
Visual C++
public:
virtual void ValidateLinks(
    LinksValidationResult^ result
) override

Parameters

result
Type: Sitecore.Links..::..LinksValidationResult
The result.

See Also

ImageField Class
Sitecore.Data.Fields Namespace


ImageField Type Conversions

[image] [image]

Sitecore 6.4.1 API
ImageField Type Conversions
ImageField Class See Also Send Feedback

The ImageField type exposes the following members.

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to ImageField) | Converts a Field to a ImageField.

See Also

ImageField Class
Sitecore.Data.Fields Namespace


Implicit Conversion (Field to ImageField)

[image]

Sitecore 6.4.1 API
ImageField ImplicitWideningImplicitImplicitImplicit Conversion (Field to ImageField)
ImageField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator ImageField (
    Field field
)
Visual Basic
Public Shared Widening Operator CType ( _
    field As Field _
) As ImageField
Visual C++
static implicit operator ImageField^ (
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
Field to convert.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Fields.ImageField.op_Implicit(Sitecore.Data.Fields.Field)~Sitecore.Data.Fields.ImageField"]

See Also

ImageField Class
Sitecore.Data.Fields Namespace


ImageField Properties

[image] [image]

Sitecore 6.4.1 API
ImageField Properties
ImageField Class See Also Send Feedback

The ImageField type exposes the following members.

Properties

 | Name | Description
Public property | Alt | Gets or sets the Alt text.
Public property | Border | Gets or sets the Border value.
Public property | Class | Gets or sets the HTML class.
Public property | Height | Gets or sets the height.
Public property | HSpace | Gets or sets the HSpace value.
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | InternalPath | Obsolete. Gets the internal path, if any.
Public property | IsInternal | Gets a value indicating whether the image is internal.
Public property | LinkType | Gets or sets the link type.
Public property | MediaDatabase | Gets or sets the database containing the the media.
Public property | MediaID | Gets or sets the ID of the media item.
Public property | MediaItem | Gets the media item.
Public property | MediaLanguage | Gets or sets the language of the media item to use.
Public property | MediaPath | Obsolete. Gets or sets the media path.
Public property | MediaVersion | Gets or sets the version of the media item to use.
Public property | Root | Gets or sets the root tag. (Inherited from XmlField.)
Public property | Src | Obsolete. Gets or sets the source path.
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)
Public property | VSpace | Gets or sets the VSpace value.
Public property | Width | Gets or sets the width.
Public property | Xml | Gets the XML document contained in this field value. (Inherited from XmlField.)

See Also

ImageField Class
Sitecore.Data.Fields Namespace


Alt Property

[image]

Sitecore 6.4.1 API
ImageField..::..Alt Property
ImageField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Alt { get; set; }
Visual Basic
Public Property Alt As String
    Get
    Set
Visual C++
public:
property String^ Alt {
    String^ get ();
    void set (String^ value);
}

Field Value

The alt text.

See Also

ImageField Class
Sitecore.Data.Fields Namespace


Border Property

[image]

Sitecore 6.4.1 API
ImageField..::..Border Property
ImageField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Border { get; set; }
Visual Basic
Public Property Border As String
    Get
    Set
Visual C++
public:
property String^ Border {
    String^ get ();
    void set (String^ value);
}

Field Value

The Border value.

See Also

ImageField Class
Sitecore.Data.Fields Namespace


Class Property

[image]

Sitecore 6.4.1 API
ImageField..::..Class Property
ImageField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Class { get; set; }
Visual Basic
Public Property Class As String
    Get
    Set
Visual C++
public:
property String^ Class {
    String^ get ();
    void set (String^ value);
}

Field Value

The class.

See Also

ImageField Class
Sitecore.Data.Fields Namespace


Height Property

[image]

Sitecore 6.4.1 API
ImageField..::..Height Property
ImageField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Height { get; set; }
Visual Basic
Public Property Height As String
    Get
    Set
Visual C++
public:
property String^ Height {
    String^ get ();
    void set (String^ value);
}

Field Value

The height.

See Also

ImageField Class
Sitecore.Data.Fields Namespace


HSpace Property

[image]

Sitecore 6.4.1 API
ImageField..::..HSpace Property
ImageField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string HSpace { get; set; }
Visual Basic
Public Property HSpace As String
    Get
    Set
Visual C++
public:
property String^ HSpace {
    String^ get ();
    void set (String^ value);
}

Field Value

The HSpace value.

See Also

ImageField Class
Sitecore.Data.Fields Namespace


LinkType Property

[image]

Sitecore 6.4.1 API
ImageField..::..LinkType Property
ImageField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string LinkType { get; set; }
Visual Basic
Public Property LinkType As String
    Get
    Set
Visual C++
public:
property String^ LinkType {
    String^ get ();
    void set (String^ value);
}

Field Value

The type of the link.

See Also

ImageField Class
Sitecore.Data.Fields Namespace


MediaDatabase Property

[image]

Sitecore 6.4.1 API
ImageField..::..MediaDatabase Property
ImageField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database MediaDatabase { get; set; }
Visual Basic
Public Property MediaDatabase As Database
    Get
    Set
Visual C++
public:
property Database^ MediaDatabase {
    Database^ get ();
    void set (Database^ value);
}

Field Value

The media database.

See Also

ImageField Class
Sitecore.Data.Fields Namespace


MediaID Property

[image]

Sitecore 6.4.1 API
ImageField..::..MediaID Property
ImageField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID MediaID { get; set; }
Visual Basic
Public Property MediaID As ID
    Get
    Set
Visual C++
public:
property ID^ MediaID {
    ID^ get ();
    void set (ID^ value);
}

Field Value

The media ID.

See Also

ImageField Class
Sitecore.Data.Fields Namespace


MediaItem Property

[image]

Sitecore 6.4.1 API
ImageField..::..MediaItem Property
ImageField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item MediaItem { get; }
Visual Basic
Public ReadOnly Property MediaItem As Item
    Get
Visual C++
public:
property Item^ MediaItem {
    Item^ get ();
}

Field Value

The media item.

See Also

ImageField Class
Sitecore.Data.Fields Namespace


MediaPath Property

[image]

Sitecore 6.4.1 API
ImageField..::..MediaPath Property
ImageField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("You can retrive Path from MediaItem.")]
public string MediaPath { get; set; }
Visual Basic
<ObsoleteAttribute("You can retrive Path from MediaItem.")> _
Public Property MediaPath As String
    Get
    Set
Visual C++
[ObsoleteAttribute(L"You can retrive Path from MediaItem.")]
public:
property String^ MediaPath {
    String^ get ();
    void set (String^ value);
}

Field Value

The media path.

See Also

ImageField Class
Sitecore.Data.Fields Namespace


MediaVersion Property

[image]

Sitecore 6.4.1 API
ImageField..::..MediaVersion Property
ImageField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Version MediaVersion { get; set; }
Visual Basic
Public Property MediaVersion As Version
    Get
    Set
Visual C++
public:
property Version^ MediaVersion {
    Version^ get ();
    void set (Version^ value);
}

Field Value

The media version.

See Also

ImageField Class
Sitecore.Data.Fields Namespace


Src Property

[image]

Sitecore 6.4.1 API
ImageField..::..Src Property
ImageField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use MediaItem property instead.")]
public string Src { get; set; }
Visual Basic
<ObsoleteAttribute("Use MediaItem property instead.")> _
Public Property Src As String
    Get
    Set
Visual C++
[ObsoleteAttribute(L"Use MediaItem property instead.")]
public:
property String^ Src {
    String^ get ();
    void set (String^ value);
}

Field Value

The source.

See Also

ImageField Class
Sitecore.Data.Fields Namespace


VSpace Property

[image]

Sitecore 6.4.1 API
ImageField..::..VSpace Property
ImageField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string VSpace { get; set; }
Visual Basic
Public Property VSpace As String
    Get
    Set
Visual C++
public:
property String^ VSpace {
    String^ get ();
    void set (String^ value);
}

Field Value

The VSpace value.

See Also

ImageField Class
Sitecore.Data.Fields Namespace


Width Property

[image]

Sitecore 6.4.1 API
ImageField..::..Width Property
ImageField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Width { get; set; }
Visual Basic
Public Property Width As String
    Get
    Set
Visual C++
public:
property String^ Width {
    String^ get ();
    void set (String^ value);
}

Field Value

The width.

See Also

ImageField Class
Sitecore.Data.Fields Namespace


InternalLinkField Class

[image]

Sitecore 6.4.1 API
InternalLinkField Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class InternalLinkField : CustomField
Visual Basic
Public Class InternalLinkField _
    Inherits CustomField
Visual C++
public ref class InternalLinkField : public CustomField

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Fields..::..CustomField
Sitecore.Data.Fields..::..InternalLinkField
Sitecore.Data.Fields..::..DatasourceField
Sitecore.Data.Fields..::..TemplateFieldSourceField

See Also

InternalLinkField Members
Sitecore.Data.Fields Namespace


InternalLinkField Members

[image] [image]

Sitecore 6.4.1 API
InternalLinkField Members
InternalLinkField Class Constructors Methods Operators Fields Properties See Also Send Feedback

The InternalLinkField type exposes the following members.

Constructors

 | Name | Description
Public method | InternalLinkField(Field) | Initializes a new instance of the InternalLinkField class.
Public method | InternalLinkField(Field, String) | Initializes a new instance of the InternalLinkField class.

Methods

 | Name | Description
Public method | Clear | Clears this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item link. (Overrides CustomField..::..Relink(ItemLink, Item).)
Public method | RemoveLink | Removes the link. (Overrides CustomField..::..RemoveLink(ItemLink).)
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Overrides CustomField..::..UpdateLink(ItemLink).)
Public method | ValidateLinks | Validates the links. (Overrides CustomField..::..ValidateLinks(LinksValidationResult).)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to InternalLinkField) | Performs an implicit conversion from Field to InternalLinkField.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

Properties

 | Name | Description
Public property | Database | Gets the database.
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | Path | Gets or sets the path.
Public property | TargetID | Gets the target ID.
Public property | TargetItem | Gets the target item.
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

InternalLinkField Class
Sitecore.Data.Fields Namespace


InternalLinkField Constructor

[image] [image]

Sitecore 6.4.1 API
InternalLinkField Constructor
InternalLinkField Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InternalLinkField(Field) | Initializes a new instance of the InternalLinkField class.
Public method | InternalLinkField(Field, String) | Initializes a new instance of the InternalLinkField class.

See Also

InternalLinkField Class
InternalLinkField Members
Sitecore.Data.Fields Namespace


InternalLinkField Constructor (Field)

[image]

Sitecore 6.4.1 API
InternalLinkField Constructor (Field)
InternalLinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public InternalLinkField(
    Field innerField
)
Visual Basic
Public Sub New ( _
    innerField As Field _
)
Visual C++
public:
InternalLinkField(
    Field^ innerField
)

Parameters

innerField
Type: Sitecore.Data.Fields..::..Field
The inner field.

See Also

InternalLinkField Class
InternalLinkField Overload
Sitecore.Data.Fields Namespace


InternalLinkField Constructor (Field, String)

[image]

Sitecore 6.4.1 API
InternalLinkField Constructor (Field, String)
InternalLinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public InternalLinkField(
    Field innerField,
    string runtimeValue
)
Visual Basic
Public Sub New ( _
    innerField As Field, _
    runtimeValue As String _
)
Visual C++
public:
InternalLinkField(
    Field^ innerField,
    String^ runtimeValue
)

Parameters

innerField
Type: Sitecore.Data.Fields..::..Field
The inner field.
runtimeValue
Type: System..::..String
The runtime value.

See Also

InternalLinkField Class
InternalLinkField Overload
Sitecore.Data.Fields Namespace


InternalLinkField Methods

[image] [image]

Sitecore 6.4.1 API
InternalLinkField Methods
InternalLinkField Class See Also Send Feedback

The InternalLinkField type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Clears this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item link. (Overrides CustomField..::..Relink(ItemLink, Item).)
Public method | RemoveLink | Removes the link. (Overrides CustomField..::..RemoveLink(ItemLink).)
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Overrides CustomField..::..UpdateLink(ItemLink).)
Public method | ValidateLinks | Validates the links. (Overrides CustomField..::..ValidateLinks(LinksValidationResult).)

See Also

InternalLinkField Class
Sitecore.Data.Fields Namespace


Clear Method

[image]

Sitecore 6.4.1 API
InternalLinkField..::..Clear Method
InternalLinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

InternalLinkField Class
Sitecore.Data.Fields Namespace


Relink Method

[image]

Sitecore 6.4.1 API
InternalLinkField..::..Relink Method
InternalLinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Relink(
    ItemLink itemLink,
    Item newLink
)
Visual Basic
Public Overrides Sub Relink ( _
    itemLink As ItemLink, _
    newLink As Item _
)
Visual C++
public:
virtual void Relink(
    ItemLink^ itemLink,
    Item^ newLink
) override

Parameters

itemLink
Type: Sitecore.Links..::..ItemLink
The item link.
newLink
Type: Sitecore.Data.Items..::..Item
The new link.

See Also

InternalLinkField Class
Sitecore.Data.Fields Namespace


RemoveLink Method

[image]

Sitecore 6.4.1 API
InternalLinkField..::..RemoveLink Method
InternalLinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void RemoveLink(
    ItemLink itemLink
)
Visual Basic
Public Overrides Sub RemoveLink ( _
    itemLink As ItemLink _
)
Visual C++
public:
virtual void RemoveLink(
    ItemLink^ itemLink
) override

Parameters

itemLink
Type: Sitecore.Links..::..ItemLink
The item link.

See Also

InternalLinkField Class
Sitecore.Data.Fields Namespace


UpdateLink Method

[image]

Sitecore 6.4.1 API
InternalLinkField..::..UpdateLink Method
InternalLinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void UpdateLink(
    ItemLink itemLink
)
Visual Basic
Public Overrides Sub UpdateLink ( _
    itemLink As ItemLink _
)
Visual C++
public:
virtual void UpdateLink(
    ItemLink^ itemLink
) override

Parameters

itemLink
Type: Sitecore.Links..::..ItemLink
The item link.

See Also

InternalLinkField Class
Sitecore.Data.Fields Namespace


ValidateLinks Method

[image]

Sitecore 6.4.1 API
InternalLinkField..::..ValidateLinks Method
InternalLinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void ValidateLinks(
    LinksValidationResult result
)
Visual Basic
Public Overrides Sub ValidateLinks ( _
    result As LinksValidationResult _
)
Visual C++
public:
virtual void ValidateLinks(
    LinksValidationResult^ result
) override

Parameters

result
Type: Sitecore.Links..::..LinksValidationResult
The result.

See Also

InternalLinkField Class
Sitecore.Data.Fields Namespace


InternalLinkField Type Conversions

[image] [image]

Sitecore 6.4.1 API
InternalLinkField Type Conversions
InternalLinkField Class See Also Send Feedback

The InternalLinkField type exposes the following members.

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to InternalLinkField) | Performs an implicit conversion from Field to InternalLinkField.

See Also

InternalLinkField Class
Sitecore.Data.Fields Namespace


Implicit Conversion (Field to InternalLinkField)

[image]

Sitecore 6.4.1 API
InternalLinkField ImplicitWideningImplicitImplicitImplicit Conversion (Field to InternalLinkField)
InternalLinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator InternalLinkField (
    Field field
)
Visual Basic
Public Shared Widening Operator CType ( _
    field As Field _
) As InternalLinkField
Visual C++
static implicit operator InternalLinkField^ (
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.

Return Value

The result of the conversion.

See Also

InternalLinkField Class
Sitecore.Data.Fields Namespace


InternalLinkField Properties

[image] [image]

Sitecore 6.4.1 API
InternalLinkField Properties
InternalLinkField Class See Also Send Feedback

The InternalLinkField type exposes the following members.

Properties

 | Name | Description
Public property | Database | Gets the database.
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | Path | Gets or sets the path.
Public property | TargetID | Gets the target ID.
Public property | TargetItem | Gets the target item.
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

InternalLinkField Class
Sitecore.Data.Fields Namespace


Database Property

[image]

Sitecore 6.4.1 API
InternalLinkField..::..Database Property
InternalLinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database Database { get; }
Visual Basic
Public ReadOnly Property Database As Database
    Get
Visual C++
public:
property Database^ Database {
    Database^ get ();
}

Field Value

The database.

See Also

InternalLinkField Class
Sitecore.Data.Fields Namespace


Path Property

[image]

Sitecore 6.4.1 API
InternalLinkField..::..Path Property
InternalLinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Path { get; set; }
Visual Basic
Public Property Path As String
    Get
    Set
Visual C++
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}

Field Value

The path.

See Also

InternalLinkField Class
Sitecore.Data.Fields Namespace


TargetID Property

[image]

Sitecore 6.4.1 API
InternalLinkField..::..TargetID Property
InternalLinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID TargetID { get; }
Visual Basic
Public ReadOnly Property TargetID As ID
    Get
Visual C++
public:
property ID^ TargetID {
    ID^ get ();
}

Field Value

The target ID.

See Also

InternalLinkField Class
Sitecore.Data.Fields Namespace


TargetItem Property

[image]

Sitecore 6.4.1 API
InternalLinkField..::..TargetItem Property
InternalLinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item TargetItem { get; }
Visual Basic
Public ReadOnly Property TargetItem As Item
    Get
Visual C++
public:
property Item^ TargetItem {
    Item^ get ();
}

Field Value

The target item.

See Also

InternalLinkField Class
Sitecore.Data.Fields Namespace


ItemEventHandler Class

[image]

Sitecore 6.4.1 API
ItemEventHandler Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemEventHandler
Visual Basic
Public Class ItemEventHandler
Visual C++
public ref class ItemEventHandler

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Fields..::..ItemEventHandler

See Also

ItemEventHandler Members
Sitecore.Data.Fields Namespace


ItemEventHandler Members

[image] [image]

Sitecore 6.4.1 API
ItemEventHandler Members
ItemEventHandler Class Constructors Methods See Also Send Feedback

The ItemEventHandler type exposes the following members.

Constructors

 | Name | Description
Public method | ItemEventHandler | Initializes a new instance of the ItemEventHandler class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnItemAdded | Called when the item has added.
Protected method | OnItemAddedRemote | Called when the item has added.
Protected method | OnItemDeleted | Called when the item has been deleted.
Protected method | OnItemDeletedRemote | Called when the item has been deleted.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemEventHandler Class
Sitecore.Data.Fields Namespace


ItemEventHandler Constructor

[image]

Sitecore 6.4.1 API
ItemEventHandler Constructor
ItemEventHandler Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemEventHandler()
Visual Basic
Public Sub New
Visual C++
public:
ItemEventHandler()

See Also

ItemEventHandler Class
Sitecore.Data.Fields Namespace


ItemEventHandler Methods

[image] [image]

Sitecore 6.4.1 API
ItemEventHandler Methods
ItemEventHandler Class See Also Send Feedback

The ItemEventHandler type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnItemAdded | Called when the item has added.
Protected method | OnItemAddedRemote | Called when the item has added.
Protected method | OnItemDeleted | Called when the item has been deleted.
Protected method | OnItemDeletedRemote | Called when the item has been deleted.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemEventHandler Class
Sitecore.Data.Fields Namespace


OnItemAdded Method

[image]

Sitecore 6.4.1 API
ItemEventHandler..::..OnItemAdded Method
ItemEventHandler Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void OnItemAdded(
    Object sender,
    EventArgs args
)
Visual Basic
Protected Sub OnItemAdded ( _
    sender As Object, _
    args As EventArgs _
)
Visual C++
protected:
void OnItemAdded(
    Object^ sender,
    EventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: System..::..EventArgs
The arguments.

See Also

ItemEventHandler Class
Sitecore.Data.Fields Namespace


OnItemAddedRemote Method

[image]

Sitecore 6.4.1 API
ItemEventHandler..::..OnItemAddedRemote Method
ItemEventHandler Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void OnItemAddedRemote(
    Object sender,
    EventArgs args
)
Visual Basic
Protected Sub OnItemAddedRemote ( _
    sender As Object, _
    args As EventArgs _
)
Visual C++
protected:
void OnItemAddedRemote(
    Object^ sender,
    EventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: System..::..EventArgs
The arguments.

See Also

ItemEventHandler Class
Sitecore.Data.Fields Namespace


OnItemDeleted Method

[image]

Sitecore 6.4.1 API
ItemEventHandler..::..OnItemDeleted Method
ItemEventHandler Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void OnItemDeleted(
    Object sender,
    EventArgs args
)
Visual Basic
Protected Sub OnItemDeleted ( _
    sender As Object, _
    args As EventArgs _
)
Visual C++
protected:
void OnItemDeleted(
    Object^ sender,
    EventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: System..::..EventArgs
The arguments.

See Also

ItemEventHandler Class
Sitecore.Data.Fields Namespace


OnItemDeletedRemote Method

[image]

Sitecore 6.4.1 API
ItemEventHandler..::..OnItemDeletedRemote Method
ItemEventHandler Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void OnItemDeletedRemote(
    Object sender,
    EventArgs args
)
Visual Basic
Protected Sub OnItemDeletedRemote ( _
    sender As Object, _
    args As EventArgs _
)
Visual C++
protected:
void OnItemDeletedRemote(
    Object^ sender,
    EventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: System..::..EventArgs
The arguments.

See Also

ItemEventHandler Class
Sitecore.Data.Fields Namespace


LayoutField Class

[image]

Sitecore 6.4.1 API
LayoutField Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class LayoutField : CustomField
Visual Basic
Public Class LayoutField _
    Inherits CustomField
Visual C++
public ref class LayoutField : public CustomField

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Fields..::..CustomField
Sitecore.Data.Fields..::..LayoutField

See Also

LayoutField Members
Sitecore.Data.Fields Namespace


LayoutField Members

[image] [image]

Sitecore 6.4.1 API
LayoutField Members
LayoutField Class Constructors Methods Operators Fields Properties See Also Send Feedback

The LayoutField type exposes the following members.

Constructors

 | Name | Description
Public method | LayoutField(Field) | Creates a new LayoutField instance.
Public method | LayoutField(Item) | Creates LayoutField from specific item.
Public method | LayoutField(Field, String) | Initializes a new instance of the LayoutField class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExtractLayoutID | Extracts the layout ID.
 | ExtractReferences | Extracts the Rendering references.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDeviceNode | Gets the device node.
 | GetFieldValue | Gets the field value, applying any layout deltas.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLayoutID | Gets the layout ID.
Public method | GetReferences | Gets the Rendering references for a device.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the actual value of this field. (Overrides CustomField..::..GetValue()()()().)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item. (Overrides CustomField..::..Relink(ItemLink, Item).)
Public method | RemoveLink | Removes the link. (Overrides CustomField..::..RemoveLink(ItemLink).)
 | SetFieldValue | Sets the field value.
Protected method | SetValue | Sets the value of this field. (Overrides CustomField..::..SetValue(String).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Inherited from CustomField.)
Public method | ValidateLinks | Validates the links. (Overrides CustomField..::..ValidateLinks(LinksValidationResult).)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to LayoutField) | Converts a Field to a LayoutField.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)
 | EmptyValue | Specifies empty value for the layout field.

Properties

 | Name | Description
Public property | Data | Gets the XML data document.
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

LayoutField Class
Sitecore.Data.Fields Namespace


LayoutField Constructor

[image] [image]

Sitecore 6.4.1 API
LayoutField Constructor
LayoutField Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LayoutField(Field) | Creates a new LayoutField instance.
Public method | LayoutField(Item) | Creates LayoutField from specific item.
Public method | LayoutField(Field, String) | Initializes a new instance of the LayoutField class.

See Also

LayoutField Class
LayoutField Members
Sitecore.Data.Fields Namespace


LayoutField Constructor (Field)

[image]

Sitecore 6.4.1 API
LayoutField Constructor (Field)
LayoutField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LayoutField(
    Field innerField
)
Visual Basic
Public Sub New ( _
    innerField As Field _
)
Visual C++
public:
LayoutField(
    Field^ innerField
)

Parameters

innerField
Type: Sitecore.Data.Fields..::..Field
Inner field.

See Also

LayoutField Class
LayoutField Overload
Sitecore.Data.Fields Namespace


LayoutField Constructor (Item)

[image]

Sitecore 6.4.1 API
LayoutField Constructor (Item)
LayoutField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LayoutField(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
LayoutField(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
Item to get layout for.

See Also

LayoutField Class
LayoutField Overload
Sitecore.Data.Fields Namespace


LayoutField Constructor (Field, String)

[image]

Sitecore 6.4.1 API
LayoutField Constructor (Field, String)
LayoutField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LayoutField(
    Field innerField,
    string runtimeValue
)
Visual Basic
Public Sub New ( _
    innerField As Field, _
    runtimeValue As String _
)
Visual C++
public:
LayoutField(
    Field^ innerField,
    String^ runtimeValue
)

Parameters

innerField
Type: Sitecore.Data.Fields..::..Field
The inner field.
runtimeValue
Type: System..::..String
The runtime value.

See Also

LayoutField Class
LayoutField Overload
Sitecore.Data.Fields Namespace


LayoutField Fields

[image] [image]

Sitecore 6.4.1 API
LayoutField Fields
LayoutField Class See Also Send Feedback

The LayoutField type exposes the following members.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)
 | EmptyValue | Specifies empty value for the layout field.

See Also

LayoutField Class
Sitecore.Data.Fields Namespace


EmptyValue Field

[image]

Sitecore 6.4.1 API
LayoutField..::..EmptyValue Field
LayoutField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string EmptyValue
Visual Basic
Public Const EmptyValue As String
Visual C++
public:
literal String^ EmptyValue

See Also

LayoutField Class
Sitecore.Data.Fields Namespace


LayoutField Methods

[image] [image]

Sitecore 6.4.1 API
LayoutField Methods
LayoutField Class See Also Send Feedback

The LayoutField type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExtractLayoutID | Extracts the layout ID.
 | ExtractReferences | Extracts the Rendering references.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDeviceNode | Gets the device node.
 | GetFieldValue | Gets the field value, applying any layout deltas.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLayoutID | Gets the layout ID.
Public method | GetReferences | Gets the Rendering references for a device.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the actual value of this field. (Overrides CustomField..::..GetValue()()()().)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item. (Overrides CustomField..::..Relink(ItemLink, Item).)
Public method | RemoveLink | Removes the link. (Overrides CustomField..::..RemoveLink(ItemLink).)
 | SetFieldValue | Sets the field value.
Protected method | SetValue | Sets the value of this field. (Overrides CustomField..::..SetValue(String).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Inherited from CustomField.)
Public method | ValidateLinks | Validates the links. (Overrides CustomField..::..ValidateLinks(LinksValidationResult).)

See Also

LayoutField Class
Sitecore.Data.Fields Namespace


ExtractLayoutID Method

[image]

Sitecore 6.4.1 API
LayoutField..::..ExtractLayoutID Method
LayoutField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID ExtractLayoutID(
    XmlNode deviceNode
)
Visual Basic
Public Shared Function ExtractLayoutID ( _
    deviceNode As XmlNode _
) As ID
Visual C++
public:
static ID^ ExtractLayoutID(
    XmlNode^ deviceNode
)

Parameters

deviceNode
Type: System.Xml..::..XmlNode
Device node.

Return Value

The layout ID.

See Also

LayoutField Class
Sitecore.Data.Fields Namespace


ExtractReferences Method

[image]

Sitecore 6.4.1 API
LayoutField..::..ExtractReferences Method
LayoutField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static RenderingReference[] ExtractReferences(
    XmlNode deviceNode,
    Language language,
    Database database
)
Visual Basic
Public Shared Function ExtractReferences ( _
    deviceNode As XmlNode, _
    language As Language, _
    database As Database _
) As RenderingReference()
Visual C++
public:
static array<RenderingReference^>^ ExtractReferences(
    XmlNode^ deviceNode,
    Language^ language,
    Database^ database
)

Parameters

deviceNode
Type: System.Xml..::..XmlNode
Device node.
language
Type: Sitecore.Globalization..::..Language
Language.
database
Type: Sitecore.Data..::..Database
Database.

Return Value

The references.

See Also

LayoutField Class
Sitecore.Data.Fields Namespace


GetDeviceNode Method

[image]

Sitecore 6.4.1 API
LayoutField..::..GetDeviceNode Method
LayoutField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public XmlNode GetDeviceNode(
    DeviceItem device
)
Visual Basic
Public Function GetDeviceNode ( _
    device As DeviceItem _
) As XmlNode
Visual C++
public:
XmlNode^ GetDeviceNode(
    DeviceItem^ device
)

Parameters

device
Type: Sitecore.Data.Items..::..DeviceItem
Device.

Return Value

The device node.

See Also

LayoutField Class
Sitecore.Data.Fields Namespace


GetFieldValue Method

[image]

Sitecore 6.4.1 API
LayoutField..::..GetFieldValue Method
LayoutField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetFieldValue(
    Field field
)
Visual Basic
Public Shared Function GetFieldValue ( _
    field As Field _
) As String
Visual C++
public:
static String^ GetFieldValue(
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field to get value for.

Return Value

The calculated layout value.

See Also

LayoutField Class
Sitecore.Data.Fields Namespace


GetReferences Method

[image]

Sitecore 6.4.1 API
LayoutField..::..GetReferences Method
LayoutField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderingReference[] GetReferences(
    DeviceItem device
)
Visual Basic
Public Function GetReferences ( _
    device As DeviceItem _
) As RenderingReference()
Visual C++
public:
array<RenderingReference^>^ GetReferences(
    DeviceItem^ device
)

Parameters

device
Type: Sitecore.Data.Items..::..DeviceItem
Device.

Return Value

The references.

See Also

LayoutField Class
Sitecore.Data.Fields Namespace


GetValue Method

[image]

Sitecore 6.4.1 API
LayoutField..::..GetValue Method
LayoutField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override string GetValue()
Visual Basic
Protected Overrides Function GetValue As String
Visual C++
protected:
virtual String^ GetValue() override

Return Value

Actual value of this field object

See Also

LayoutField Class
Sitecore.Data.Fields Namespace


Relink Method

[image]

Sitecore 6.4.1 API
LayoutField..::..Relink Method
LayoutField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Relink(
    ItemLink itemLink,
    Item newLink
)
Visual Basic
Public Overrides Sub Relink ( _
    itemLink As ItemLink, _
    newLink As Item _
)
Visual C++
public:
virtual void Relink(
    ItemLink^ itemLink,
    Item^ newLink
) override

Parameters

itemLink
Type: Sitecore.Links..::..ItemLink
The item link.
newLink
Type: Sitecore.Data.Items..::..Item
The new link.

See Also

LayoutField Class
Sitecore.Data.Fields Namespace


SetFieldValue Method

[image]

Sitecore 6.4.1 API
LayoutField..::..SetFieldValue Method
LayoutField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void SetFieldValue(
    Field field,
    string value
)
Visual Basic
Public Shared Sub SetFieldValue ( _
    field As Field, _
    value As String _
)
Visual C++
public:
static void SetFieldValue(
    Field^ field,
    String^ value
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.
value
Type: System..::..String
The value.

See Also

LayoutField Class
Sitecore.Data.Fields Namespace


ValidateLinks Method

[image]

Sitecore 6.4.1 API
LayoutField..::..ValidateLinks Method
LayoutField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void ValidateLinks(
    LinksValidationResult result
)
Visual Basic
Public Overrides Sub ValidateLinks ( _
    result As LinksValidationResult _
)
Visual C++
public:
virtual void ValidateLinks(
    LinksValidationResult^ result
) override

Parameters

result
Type: Sitecore.Links..::..LinksValidationResult
The result.

See Also

LayoutField Class
Sitecore.Data.Fields Namespace


LayoutField Type Conversions

[image] [image]

Sitecore 6.4.1 API
LayoutField Type Conversions
LayoutField Class See Also Send Feedback

The LayoutField type exposes the following members.

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to LayoutField) | Converts a Field to a LayoutField.

See Also

LayoutField Class
Sitecore.Data.Fields Namespace


Implicit Conversion (Field to LayoutField)

[image]

Sitecore 6.4.1 API
LayoutField ImplicitWideningImplicitImplicitImplicit Conversion (Field to LayoutField)
LayoutField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator LayoutField (
    Field field
)
Visual Basic
Public Shared Widening Operator CType ( _
    field As Field _
) As LayoutField
Visual C++
static implicit operator LayoutField^ (
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.

Return Value

The implicit operator.

See Also

LayoutField Class
Sitecore.Data.Fields Namespace


LayoutField Properties

[image] [image]

Sitecore 6.4.1 API
LayoutField Properties
LayoutField Class See Also Send Feedback

The LayoutField type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets the XML data document.
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

LayoutField Class
Sitecore.Data.Fields Namespace


Data Property

[image]

Sitecore 6.4.1 API
LayoutField..::..Data Property
LayoutField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public XmlDocument Data { get; }
Visual Basic
Public ReadOnly Property Data As XmlDocument
    Get
Visual C++
public:
property XmlDocument^ Data {
    XmlDocument^ get ();
}

Field Value

The data.

See Also

LayoutField Class
Sitecore.Data.Fields Namespace


LinkField Class

[image]

Sitecore 6.4.1 API
LinkField Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class LinkField : XmlField
Visual Basic
Public Class LinkField _
    Inherits XmlField
Visual C++
public ref class LinkField : public XmlField

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Fields..::..CustomField
Sitecore.Data.Fields..::..XmlField
Sitecore.Data.Fields..::..LinkField

See Also

LinkField Members
Sitecore.Data.Fields Namespace


LinkField Members

[image] [image]

Sitecore 6.4.1 API
LinkField Members
LinkField Class Constructors Methods Operators Fields Properties See Also Send Feedback

The LinkField type exposes the following members.

Constructors

 | Name | Description
Public method | LinkField(Field) | Creates a new LinkField instance.
Public method | LinkField(Field, String) | Creates a new LinkField instance.

Methods

 | Name | Description
Public method | Clear | Clears this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttribute | Gets the attribute. (Inherited from XmlField.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink(Item, Item) | Obsolete. Relinks the specified item.
Public method | Relink(ItemLink, Item) | Relinks the specified item link. (Overrides CustomField..::..Relink(ItemLink, Item).)
Public method | RemoveLink(Item) | Obsolete. Removes the link.
Public method | RemoveLink(ItemLink) | Removes the link. (Overrides CustomField..::..RemoveLink(ItemLink).)
Public method | SetAttribute | Sets the attribute. (Inherited from XmlField.)
Protected method | SetValue | Sets the value. (Inherited from XmlField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink(ItemLink) | Updates the link. (Overrides CustomField..::..UpdateLink(ItemLink).)
Public method | UpdateLink(Item, String, String) | Obsolete. Updates the link.
Public method | ValidateLinks | Validates the links. (Overrides CustomField..::..ValidateLinks(LinksValidationResult).)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to LinkField) | Converts a Field to a LinkField.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

Properties

 | Name | Description
Public property | Anchor | Gets or sets the anchor.
Public property | Class | Gets or sets the HTML class.
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | InternalPath | Gets the internal path.
Public property | IsInternal | Gets a value indicating whether this link is internal.
Public property | IsMediaLink | Gets a value indicating whether this instance is media link.
Public property | LinkType | Gets or sets the link type.
Public property | MediaPath |
Public property | QueryString | Gets or sets the query string in internal links.
Public property | Root | Gets or sets the root tag. (Inherited from XmlField.)
Public property | Target | Gets or sets the HTML target.
Public property | TargetID | Gets or sets the target ID.
Public property | TargetItem | Gets the target item.
Public property | Text | Gets or sets the text.
Public property | Title | Gets or sets the title.
Public property | Url | Gets or sets the URL.
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)
Public property | Xml | Gets the XML document contained in this field value. (Inherited from XmlField.)

See Also

LinkField Class
Sitecore.Data.Fields Namespace


LinkField Constructor

[image] [image]

Sitecore 6.4.1 API
LinkField Constructor
LinkField Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LinkField(Field) | Creates a new LinkField instance.
Public method | LinkField(Field, String) | Creates a new LinkField instance.

See Also

LinkField Class
LinkField Members
Sitecore.Data.Fields Namespace


LinkField Constructor (Field)

[image]

Sitecore 6.4.1 API
LinkField Constructor (Field)
LinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LinkField(
    Field innerField
)
Visual Basic
Public Sub New ( _
    innerField As Field _
)
Visual C++
public:
LinkField(
    Field^ innerField
)

Parameters

innerField
Type: Sitecore.Data.Fields..::..Field
Inner field.

See Also

LinkField Class
LinkField Overload
Sitecore.Data.Fields Namespace


LinkField Constructor (Field, String)

[image]

Sitecore 6.4.1 API
LinkField Constructor (Field, String)
LinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LinkField(
    Field innerField,
    string runtimeValue
)
Visual Basic
Public Sub New ( _
    innerField As Field, _
    runtimeValue As String _
)
Visual C++
public:
LinkField(
    Field^ innerField,
    String^ runtimeValue
)

Parameters

innerField
Type: Sitecore.Data.Fields..::..Field
The inner field.
runtimeValue
Type: System..::..String
The runtime value.

See Also

LinkField Class
LinkField Overload
Sitecore.Data.Fields Namespace


LinkField Fields

[image] [image]

Sitecore 6.4.1 API
LinkField Fields
LinkField Class See Also Send Feedback

The LinkField type exposes the following members.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

See Also

LinkField Class
Sitecore.Data.Fields Namespace


LinkField Methods

[image] [image]

Sitecore 6.4.1 API
LinkField Methods
LinkField Class See Also Send Feedback

The LinkField type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Clears this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttribute | Gets the attribute. (Inherited from XmlField.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink(Item, Item) | Obsolete. Relinks the specified item.
Public method | Relink(ItemLink, Item) | Relinks the specified item link. (Overrides CustomField..::..Relink(ItemLink, Item).)
Public method | RemoveLink(Item) | Obsolete. Removes the link.
Public method | RemoveLink(ItemLink) | Removes the link. (Overrides CustomField..::..RemoveLink(ItemLink).)
Public method | SetAttribute | Sets the attribute. (Inherited from XmlField.)
Protected method | SetValue | Sets the value. (Inherited from XmlField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink(ItemLink) | Updates the link. (Overrides CustomField..::..UpdateLink(ItemLink).)
Public method | UpdateLink(Item, String, String) | Obsolete. Updates the link.
Public method | ValidateLinks | Validates the links. (Overrides CustomField..::..ValidateLinks(LinksValidationResult).)

See Also

LinkField Class
Sitecore.Data.Fields Namespace


Clear Method

[image]

Sitecore 6.4.1 API
LinkField..::..Clear Method
LinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

LinkField Class
Sitecore.Data.Fields Namespace


Relink Method (Item, Item)

[image]

Sitecore 6.4.1 API
LinkField..::..Relink Method (Item, Item)
LinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use Relink(ItemLink, Item) instead.")]
public void Relink(
    Item item,
    Item newLink
)
Visual Basic
<ObsoleteAttribute("Deprecated - Use Relink(ItemLink, Item) instead.")> _
Public Sub Relink ( _
    item As Item, _
    newLink As Item _
)
Visual C++
[ObsoleteAttribute(L"Deprecated - Use Relink(ItemLink, Item) instead.")]
public:
void Relink(
    Item^ item,
    Item^ newLink
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
newLink
Type: Sitecore.Data.Items..::..Item
The new link.

See Also

LinkField Class
Relink Overload
Sitecore.Data.Fields Namespace


RemoveLink Method (Item)

[image]

Sitecore 6.4.1 API
LinkField..::..RemoveLink Method (Item)
LinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use RemoveLink(ItemLink) instead.")]
public void RemoveLink(
    Item item
)
Visual Basic
<ObsoleteAttribute("Deprecated - Use RemoveLink(ItemLink) instead.")> _
Public Sub RemoveLink ( _
    item As Item _
)
Visual C++
[ObsoleteAttribute(L"Deprecated - Use RemoveLink(ItemLink) instead.")]
public:
void RemoveLink(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

LinkField Class
RemoveLink Overload
Sitecore.Data.Fields Namespace


RemoveLink Method (ItemLink)

[image]

Sitecore 6.4.1 API
LinkField..::..RemoveLink Method (ItemLink)
LinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void RemoveLink(
    ItemLink itemLink
)
Visual Basic
Public Overrides Sub RemoveLink ( _
    itemLink As ItemLink _
)
Visual C++
public:
virtual void RemoveLink(
    ItemLink^ itemLink
) override

Parameters

itemLink
Type: Sitecore.Links..::..ItemLink
The item link.

See Also

LinkField Class
RemoveLink Overload
Sitecore.Data.Fields Namespace


UpdateLink Method

[image] [image]

Sitecore 6.4.1 API
LinkField..::..UpdateLink Method
LinkField Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UpdateLink(ItemLink) | Updates the link. (Overrides CustomField..::..UpdateLink(ItemLink).)
Public method | UpdateLink(Item, String, String) | Obsolete. Updates the link.

See Also

LinkField Class
LinkField Members
Sitecore.Data.Fields Namespace


UpdateLink Method (Item, String, String)

[image]

Sitecore 6.4.1 API
LinkField..::..UpdateLink Method (Item, String, String)
LinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use UpdateLink(ItemLink) instead.")]
public void UpdateLink(
    Item item,
    string oldShortPath,
    string oldLongPath
)
Visual Basic
<ObsoleteAttribute("Deprecated - Use UpdateLink(ItemLink) instead.")> _
Public Sub UpdateLink ( _
    item As Item, _
    oldShortPath As String, _
    oldLongPath As String _
)
Visual C++
[ObsoleteAttribute(L"Deprecated - Use UpdateLink(ItemLink) instead.")]
public:
void UpdateLink(
    Item^ item,
    String^ oldShortPath,
    String^ oldLongPath
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
oldShortPath
Type: System..::..String
The old short path.
oldLongPath
Type: System..::..String
The old long path.

See Also

LinkField Class
UpdateLink Overload
Sitecore.Data.Fields Namespace


ValidateLinks Method

[image]

Sitecore 6.4.1 API
LinkField..::..ValidateLinks Method
LinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void ValidateLinks(
    LinksValidationResult result
)
Visual Basic
Public Overrides Sub ValidateLinks ( _
    result As LinksValidationResult _
)
Visual C++
public:
virtual void ValidateLinks(
    LinksValidationResult^ result
) override

Parameters

result
Type: Sitecore.Links..::..LinksValidationResult
The result.

See Also

LinkField Class
Sitecore.Data.Fields Namespace


Implicit Conversion (Field to LinkField)

[image]

Sitecore 6.4.1 API
LinkField ImplicitWideningImplicitImplicitImplicit Conversion (Field to LinkField)
LinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator LinkField (
    Field field
)
Visual Basic
Public Shared Widening Operator CType ( _
    field As Field _
) As LinkField
Visual C++
static implicit operator LinkField^ (
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.

Return Value

The implicit operator.

See Also

LinkField Class
Sitecore.Data.Fields Namespace


LinkField Properties

[image] [image]

Sitecore 6.4.1 API
LinkField Properties
LinkField Class See Also Send Feedback

The LinkField type exposes the following members.

Properties

 | Name | Description
Public property | Anchor | Gets or sets the anchor.
Public property | Class | Gets or sets the HTML class.
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | InternalPath | Gets the internal path.
Public property | IsInternal | Gets a value indicating whether this link is internal.
Public property | IsMediaLink | Gets a value indicating whether this instance is media link.
Public property | LinkType | Gets or sets the link type.
Public property | MediaPath |
Public property | QueryString | Gets or sets the query string in internal links.
Public property | Root | Gets or sets the root tag. (Inherited from XmlField.)
Public property | Target | Gets or sets the HTML target.
Public property | TargetID | Gets or sets the target ID.
Public property | TargetItem | Gets the target item.
Public property | Text | Gets or sets the text.
Public property | Title | Gets or sets the title.
Public property | Url | Gets or sets the URL.
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)
Public property | Xml | Gets the XML document contained in this field value. (Inherited from XmlField.)

See Also

LinkField Class
Sitecore.Data.Fields Namespace


Anchor Property

[image]

Sitecore 6.4.1 API
LinkField..::..Anchor Property
LinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Anchor { get; set; }
Visual Basic
Public Property Anchor As String
    Get
    Set
Visual C++
public:
property String^ Anchor {
    String^ get ();
    void set (String^ value);
}

Field Value

The anchor.

See Also

LinkField Class
Sitecore.Data.Fields Namespace


Class Property

[image]

Sitecore 6.4.1 API
LinkField..::..Class Property
LinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Class { get; set; }
Visual Basic
Public Property Class As String
    Get
    Set
Visual C++
public:
property String^ Class {
    String^ get ();
    void set (String^ value);
}

Field Value

The class.

See Also

LinkField Class
Sitecore.Data.Fields Namespace


IsInternal Property

[image]

Sitecore 6.4.1 API
LinkField..::..IsInternal Property
LinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsInternal { get; }
Visual Basic
Public ReadOnly Property IsInternal As Boolean
    Get
Visual C++
public:
property bool IsInternal {
    bool get ();
}

Field Value

true if this link is internal; otherwise, false.

See Also

LinkField Class
Sitecore.Data.Fields Namespace


IsMediaLink Property

[image]

Sitecore 6.4.1 API
LinkField..::..IsMediaLink Property
LinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsMediaLink { get; }
Visual Basic
Public ReadOnly Property IsMediaLink As Boolean
    Get
Visual C++
public:
property bool IsMediaLink {
    bool get ();
}

Field Value

true if this instance is media link; otherwise, false.

See Also

LinkField Class
Sitecore.Data.Fields Namespace


LinkType Property

[image]

Sitecore 6.4.1 API
LinkField..::..LinkType Property
LinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string LinkType { get; set; }
Visual Basic
Public Property LinkType As String
    Get
    Set
Visual C++
public:
property String^ LinkType {
    String^ get ();
    void set (String^ value);
}

Field Value

The type of the link.

See Also

LinkField Class
Sitecore.Data.Fields Namespace


MediaPath Property

[image]

Sitecore 6.4.1 API
LinkField..::..MediaPath Property
LinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string MediaPath { get; }
Visual Basic
Public ReadOnly Property MediaPath As String
    Get
Visual C++
public:
property String^ MediaPath {
    String^ get ();
}

Field Value

The internal path.

See Also

LinkField Class
Sitecore.Data.Fields Namespace


QueryString Property

[image]

Sitecore 6.4.1 API
LinkField..::..QueryString Property
LinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string QueryString { get; set; }
Visual Basic
Public Property QueryString As String
    Get
    Set
Visual C++
public:
property String^ QueryString {
    String^ get ();
    void set (String^ value);
}

Field Value

The query string.

See Also

LinkField Class
Sitecore.Data.Fields Namespace


Target Property

[image]

Sitecore 6.4.1 API
LinkField..::..Target Property
LinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Target { get; set; }
Visual Basic
Public Property Target As String
    Get
    Set
Visual C++
public:
property String^ Target {
    String^ get ();
    void set (String^ value);
}

Field Value

The target.

See Also

LinkField Class
Sitecore.Data.Fields Namespace


TargetID Property

[image]

Sitecore 6.4.1 API
LinkField..::..TargetID Property
LinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID TargetID { get; set; }
Visual Basic
Public Property TargetID As ID
    Get
    Set
Visual C++
public:
property ID^ TargetID {
    ID^ get ();
    void set (ID^ value);
}

Field Value

The target ID.

See Also

LinkField Class
Sitecore.Data.Fields Namespace


TargetItem Property

[image]

Sitecore 6.4.1 API
LinkField..::..TargetItem Property
LinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item TargetItem { get; }
Visual Basic
Public ReadOnly Property TargetItem As Item
    Get
Visual C++
public:
property Item^ TargetItem {
    Item^ get ();
}

Field Value

The target item.

See Also

LinkField Class
Sitecore.Data.Fields Namespace


Text Property

[image]

Sitecore 6.4.1 API
LinkField..::..Text Property
LinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Field Value

The text.

See Also

LinkField Class
Sitecore.Data.Fields Namespace


Title Property

[image]

Sitecore 6.4.1 API
LinkField..::..Title Property
LinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Title { get; set; }
Visual Basic
Public Property Title As String
    Get
    Set
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

Field Value

The title.

See Also

LinkField Class
Sitecore.Data.Fields Namespace


Url Property

[image]

Sitecore 6.4.1 API
LinkField..::..Url Property
LinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Url { get; set; }
Visual Basic
Public Property Url As String
    Get
    Set
Visual C++
public:
property String^ Url {
    String^ get ();
    void set (String^ value);
}

Field Value

The URL.

See Also

LinkField Class
Sitecore.Data.Fields Namespace


LockField Class

[image]

Sitecore 6.4.1 API
LockField Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class LockField : CustomField
Visual Basic
Public Class LockField _
    Inherits CustomField
Visual C++
public ref class LockField : public CustomField

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Fields..::..CustomField
Sitecore.Data.Fields..::..LockField

See Also

LockField Members
Sitecore.Data.Fields Namespace


LockField Members

[image] [image]

Sitecore 6.4.1 API
LockField Members
LockField Class Constructors Methods Operators Fields Properties See Also Send Feedback

The LockField type exposes the following members.

Constructors

 | Name | Description
Public method | LockField | Creates a new LockField instance.

Methods

 | Name | Description
Public method | AcquireLock | Acquires the lock.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReleaseLock | Releases the lock.
Public method | Relink | Relinks the specified item. (Inherited from CustomField.)
Public method | RemoveLink | Removes the link. (Inherited from CustomField.)
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Inherited from CustomField.)
Public method | ValidateLinks | Validates the links. (Inherited from CustomField.)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to LockField) | Converts a Field to a LockField.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

Properties

 | Name | Description
Public property | Date | Gets the lock date.
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | Owner | Gets the owner of the lock.
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

LockField Class
Sitecore.Data.Fields Namespace


LockField Constructor

[image]

Sitecore 6.4.1 API
LockField Constructor
LockField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LockField(
    Field innerField
)
Visual Basic
Public Sub New ( _
    innerField As Field _
)
Visual C++
public:
LockField(
    Field^ innerField
)

Parameters

innerField
Type: Sitecore.Data.Fields..::..Field
Inner field.

See Also

LockField Class
Sitecore.Data.Fields Namespace


LockField Methods

[image] [image]

Sitecore 6.4.1 API
LockField Methods
LockField Class See Also Send Feedback

The LockField type exposes the following members.

Methods

 | Name | Description
Public method | AcquireLock | Acquires the lock.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReleaseLock | Releases the lock.
Public method | Relink | Relinks the specified item. (Inherited from CustomField.)
Public method | RemoveLink | Removes the link. (Inherited from CustomField.)
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Inherited from CustomField.)
Public method | ValidateLinks | Validates the links. (Inherited from CustomField.)

See Also

LockField Class
Sitecore.Data.Fields Namespace


AcquireLock Method

[image]

Sitecore 6.4.1 API
LockField..::..AcquireLock Method
LockField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool AcquireLock()
Visual Basic
Public Function AcquireLock As Boolean
Visual C++
public:
bool AcquireLock()

Return Value

The lock.

See Also

LockField Class
Sitecore.Data.Fields Namespace


ReleaseLock Method

[image]

Sitecore 6.4.1 API
LockField..::..ReleaseLock Method
LockField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ReleaseLock()
Visual Basic
Public Function ReleaseLock As Boolean
Visual C++
public:
bool ReleaseLock()

Return Value

The lock.

See Also

LockField Class
Sitecore.Data.Fields Namespace


LockField Type Conversions

[image] [image]

Sitecore 6.4.1 API
LockField Type Conversions
LockField Class See Also Send Feedback

The LockField type exposes the following members.

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to LockField) | Converts a Field to a LockField.

See Also

LockField Class
Sitecore.Data.Fields Namespace


Implicit Conversion (Field to LockField)

[image]

Sitecore 6.4.1 API
LockField ImplicitWideningImplicitImplicitImplicit Conversion (Field to LockField)
LockField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator LockField (
    Field field
)
Visual Basic
Public Shared Widening Operator CType ( _
    field As Field _
) As LockField
Visual C++
static implicit operator LockField^ (
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.

Return Value

The implicit operator.

See Also

LockField Class
Sitecore.Data.Fields Namespace


LockField Properties

[image] [image]

Sitecore 6.4.1 API
LockField Properties
LockField Class See Also Send Feedback

The LockField type exposes the following members.

Properties

 | Name | Description
Public property | Date | Gets the lock date.
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | Owner | Gets the owner of the lock.
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

LockField Class
Sitecore.Data.Fields Namespace


Date Property

[image]

Sitecore 6.4.1 API
LockField..::..Date Property
LockField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime Date { get; }
Visual Basic
Public ReadOnly Property Date As DateTime
    Get
Visual C++
public:
property DateTime Date {
    DateTime get ();
}

Field Value

The date.

See Also

LockField Class
Sitecore.Data.Fields Namespace


Owner Property

[image]

Sitecore 6.4.1 API
LockField..::..Owner Property
LockField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Owner { get; }
Visual Basic
Public ReadOnly Property Owner As String
    Get
Visual C++
public:
property String^ Owner {
    String^ get ();
}

Field Value

The owner.

See Also

LockField Class
Sitecore.Data.Fields Namespace


LookupField Class

[image]

Sitecore 6.4.1 API
LookupField Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class LookupField : CustomField
Visual Basic
Public Class LookupField _
    Inherits CustomField
Visual C++
public ref class LookupField : public CustomField

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Fields..::..CustomField
Sitecore.Data.Fields..::..LookupField
Sitecore.Data.Fields..::..GroupedDroplinkField

See Also

LookupField Members
Sitecore.Data.Fields Namespace


LookupField Members

[image] [image]

Sitecore 6.4.1 API
LookupField Members
LookupField Class Constructors Methods Operators Fields Properties See Also Send Feedback

The LookupField type exposes the following members.

Constructors

 | Name | Description
Public method | LookupField | Creates a new LookupField instance.

Methods

 | Name | Description
Public method | Clear | Clears this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item. (Overrides CustomField..::..Relink(ItemLink, Item).)
Public method | RemoveLink | Removes the link. (Overrides CustomField..::..RemoveLink(ItemLink).)
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Inherited from CustomField.)
Public method | ValidateLinks | Validates the links. (Overrides CustomField..::..ValidateLinks(LinksValidationResult).)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to LookupField) | Converts a Field to a LookupField.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

Properties

 | Name | Description
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | TargetID | Gets the target ID.
Public property | TargetItem | Gets the target item.
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

LookupField Class
Sitecore.Data.Fields Namespace


LookupField Constructor

[image]

Sitecore 6.4.1 API
LookupField Constructor
LookupField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LookupField(
    Field innerField
)
Visual Basic
Public Sub New ( _
    innerField As Field _
)
Visual C++
public:
LookupField(
    Field^ innerField
)

Parameters

innerField
Type: Sitecore.Data.Fields..::..Field
Inner field.

See Also

LookupField Class
Sitecore.Data.Fields Namespace


LookupField Fields

[image] [image]

Sitecore 6.4.1 API
LookupField Fields
LookupField Class See Also Send Feedback

The LookupField type exposes the following members.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

See Also

LookupField Class
Sitecore.Data.Fields Namespace


LookupField Methods

[image] [image]

Sitecore 6.4.1 API
LookupField Methods
LookupField Class See Also Send Feedback

The LookupField type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Clears this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item. (Overrides CustomField..::..Relink(ItemLink, Item).)
Public method | RemoveLink | Removes the link. (Overrides CustomField..::..RemoveLink(ItemLink).)
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Inherited from CustomField.)
Public method | ValidateLinks | Validates the links. (Overrides CustomField..::..ValidateLinks(LinksValidationResult).)

See Also

LookupField Class
Sitecore.Data.Fields Namespace


Clear Method

[image]

Sitecore 6.4.1 API
LookupField..::..Clear Method
LookupField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

LookupField Class
Sitecore.Data.Fields Namespace


Relink Method

[image]

Sitecore 6.4.1 API
LookupField..::..Relink Method
LookupField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Relink(
    ItemLink itemLink,
    Item newLink
)
Visual Basic
Public Overrides Sub Relink ( _
    itemLink As ItemLink, _
    newLink As Item _
)
Visual C++
public:
virtual void Relink(
    ItemLink^ itemLink,
    Item^ newLink
) override

Parameters

itemLink
Type: Sitecore.Links..::..ItemLink
The item link.
newLink
Type: Sitecore.Data.Items..::..Item
The new link.

See Also

LookupField Class
Sitecore.Data.Fields Namespace


RemoveLink Method

[image]

Sitecore 6.4.1 API
LookupField..::..RemoveLink Method
LookupField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void RemoveLink(
    ItemLink itemLink
)
Visual Basic
Public Overrides Sub RemoveLink ( _
    itemLink As ItemLink _
)
Visual C++
public:
virtual void RemoveLink(
    ItemLink^ itemLink
) override

Parameters

itemLink
Type: Sitecore.Links..::..ItemLink
The item link.

See Also

LookupField Class
Sitecore.Data.Fields Namespace


ValidateLinks Method

[image]

Sitecore 6.4.1 API
LookupField..::..ValidateLinks Method
LookupField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void ValidateLinks(
    LinksValidationResult result
)
Visual Basic
Public Overrides Sub ValidateLinks ( _
    result As LinksValidationResult _
)
Visual C++
public:
virtual void ValidateLinks(
    LinksValidationResult^ result
) override

Parameters

result
Type: Sitecore.Links..::..LinksValidationResult
The result.

See Also

LookupField Class
Sitecore.Data.Fields Namespace


LookupField Type Conversions

[image] [image]

Sitecore 6.4.1 API
LookupField Type Conversions
LookupField Class See Also Send Feedback

The LookupField type exposes the following members.

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to LookupField) | Converts a Field to a LookupField.

See Also

LookupField Class
Sitecore.Data.Fields Namespace


Implicit Conversion (Field to LookupField)

[image]

Sitecore 6.4.1 API
LookupField ImplicitWideningImplicitImplicitImplicit Conversion (Field to LookupField)
LookupField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator LookupField (
    Field field
)
Visual Basic
Public Shared Widening Operator CType ( _
    field As Field _
) As LookupField
Visual C++
static implicit operator LookupField^ (
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.

Return Value

The implicit operator.

See Also

LookupField Class
Sitecore.Data.Fields Namespace


LookupField Properties

[image] [image]

Sitecore 6.4.1 API
LookupField Properties
LookupField Class See Also Send Feedback

The LookupField type exposes the following members.

Properties

 | Name | Description
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | TargetID | Gets the target ID.
Public property | TargetItem | Gets the target item.
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

LookupField Class
Sitecore.Data.Fields Namespace


TargetID Property

[image]

Sitecore 6.4.1 API
LookupField..::..TargetID Property
LookupField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID TargetID { get; }
Visual Basic
Public ReadOnly Property TargetID As ID
    Get
Visual C++
public:
property ID^ TargetID {
    ID^ get ();
}

Field Value

The target ID.

See Also

LookupField Class
Sitecore.Data.Fields Namespace


TargetItem Property

[image]

Sitecore 6.4.1 API
LookupField..::..TargetItem Property
LookupField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item TargetItem { get; }
Visual Basic
Public ReadOnly Property TargetItem As Item
    Get
Visual C++
public:
property Item^ TargetItem {
    Item^ get ();
}

Field Value

The target item.

See Also

LookupField Class
Sitecore.Data.Fields Namespace


MediaPath Class

[image]

Sitecore 6.4.1 API
MediaPath Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class MediaPath : CustomField
Visual Basic
Public Class MediaPath _
    Inherits CustomField
Visual C++
public ref class MediaPath : public CustomField

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Fields..::..CustomField
Sitecore.Data.Fields..::..MediaPath

See Also

MediaPath Members
Sitecore.Data.Fields Namespace


MediaPath Constructor

[image]

Sitecore 6.4.1 API
MediaPath Constructor
MediaPath Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MediaPath(
    Field innerField
)
Visual Basic
Public Sub New ( _
    innerField As Field _
)
Visual C++
public:
MediaPath(
    Field^ innerField
)

Parameters

innerField
Type: Sitecore.Data.Fields..::..Field
Inner field.

See Also

MediaPath Class
Sitecore.Data.Fields Namespace


MediaPath Fields

[image] [image]

Sitecore 6.4.1 API
MediaPath Fields
MediaPath Class See Also Send Feedback

The MediaPath type exposes the following members.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

See Also

MediaPath Class
Sitecore.Data.Fields Namespace


MediaPath Methods

[image] [image]

Sitecore 6.4.1 API
MediaPath Methods
MediaPath Class See Also Send Feedback

The MediaPath type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Clears this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item. (Overrides CustomField..::..Relink(ItemLink, Item).)
Public method | RemoveLink | Removes the link. (Overrides CustomField..::..RemoveLink(ItemLink).)
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Overrides CustomField..::..UpdateLink(ItemLink).)
Public method | ValidateLinks | Validates the links. (Overrides CustomField..::..ValidateLinks(LinksValidationResult).)

See Also

MediaPath Class
Sitecore.Data.Fields Namespace


Clear Method

[image]

Sitecore 6.4.1 API
MediaPath..::..Clear Method
MediaPath Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

MediaPath Class
Sitecore.Data.Fields Namespace


Relink Method

[image]

Sitecore 6.4.1 API
MediaPath..::..Relink Method
MediaPath Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Relink(
    ItemLink itemLink,
    Item newLink
)
Visual Basic
Public Overrides Sub Relink ( _
    itemLink As ItemLink, _
    newLink As Item _
)
Visual C++
public:
virtual void Relink(
    ItemLink^ itemLink,
    Item^ newLink
) override

Parameters

itemLink
Type: Sitecore.Links..::..ItemLink
The item link.
newLink
Type: Sitecore.Data.Items..::..Item
The new link.

See Also

MediaPath Class
Sitecore.Data.Fields Namespace


RemoveLink Method

[image]

Sitecore 6.4.1 API
MediaPath..::..RemoveLink Method
MediaPath Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void RemoveLink(
    ItemLink itemLink
)
Visual Basic
Public Overrides Sub RemoveLink ( _
    itemLink As ItemLink _
)
Visual C++
public:
virtual void RemoveLink(
    ItemLink^ itemLink
) override

Parameters

itemLink
Type: Sitecore.Links..::..ItemLink
The item link.

See Also

MediaPath Class
Sitecore.Data.Fields Namespace


UpdateLink Method

[image]

Sitecore 6.4.1 API
MediaPath..::..UpdateLink Method
MediaPath Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void UpdateLink(
    ItemLink itemLink
)
Visual Basic
Public Overrides Sub UpdateLink ( _
    itemLink As ItemLink _
)
Visual C++
public:
virtual void UpdateLink(
    ItemLink^ itemLink
) override

Parameters

itemLink
Type: Sitecore.Links..::..ItemLink
The link.

See Also

MediaPath Class
Sitecore.Data.Fields Namespace


ValidateLinks Method

[image]

Sitecore 6.4.1 API
MediaPath..::..ValidateLinks Method
MediaPath Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void ValidateLinks(
    LinksValidationResult result
)
Visual Basic
Public Overrides Sub ValidateLinks ( _
    result As LinksValidationResult _
)
Visual C++
public:
virtual void ValidateLinks(
    LinksValidationResult^ result
) override

Parameters

result
Type: Sitecore.Links..::..LinksValidationResult
The result.

See Also

MediaPath Class
Sitecore.Data.Fields Namespace


MediaPath Type Conversions

[image] [image]

Sitecore 6.4.1 API
MediaPath Type Conversions
MediaPath Class See Also Send Feedback

The MediaPath type exposes the following members.

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to MediaPath) | Converts a Field to a LinkField.

See Also

MediaPath Class
Sitecore.Data.Fields Namespace


Implicit Conversion (Field to MediaPath)

[image]

Sitecore 6.4.1 API
MediaPath ImplicitWideningImplicitImplicitImplicit Conversion (Field to MediaPath)
MediaPath Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator MediaPath (
    Field field
)
Visual Basic
Public Shared Widening Operator CType ( _
    field As Field _
) As MediaPath
Visual C++
static implicit operator MediaPath^ (
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.

Return Value

The implicit operator.

See Also

MediaPath Class
Sitecore.Data.Fields Namespace


MediaPath Properties

[image] [image]

Sitecore 6.4.1 API
MediaPath Properties
MediaPath Class See Also Send Feedback

The MediaPath type exposes the following members.

Properties

 | Name | Description
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | Path | Gets or sets the HTML class.
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

MediaPath Class
Sitecore.Data.Fields Namespace


Path Property

[image]

Sitecore 6.4.1 API
MediaPath..::..Path Property
MediaPath Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Path { get; set; }
Visual Basic
Public Property Path As String
    Get
    Set
Visual C++
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}

Field Value

The path.

See Also

MediaPath Class
Sitecore.Data.Fields Namespace


MultilistField Class

[image]

Sitecore 6.4.1 API
MultilistField Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class MultilistField : DelimitedField
Visual Basic
Public Class MultilistField _
    Inherits DelimitedField
Visual C++
public ref class MultilistField : public DelimitedField

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Fields..::..CustomField
Sitecore.Data.Fields..::..DelimitedField
Sitecore.Data.Fields..::..MultilistField

See Also

MultilistField Members
Sitecore.Data.Fields Namespace


MultilistField Members

[image] [image]

Sitecore 6.4.1 API
MultilistField Members
MultilistField Class Constructors Methods Operators Fields Properties See Also Send Feedback

The MultilistField type exposes the following members.

Constructors

 | Name | Description
Public method | MultilistField | Creates a new MultilistField instance.

Methods

 | Name | Description
Public method | Add(String) | Adds the specified item. (Inherited from DelimitedField.)
Public method | Add(String, Boolean) | Adds the specified item. (Inherited from DelimitedField.)
Public method | CharIndexOf | Gets the index of an item in the value. (Inherited from DelimitedField.)
Public method | Contains | Determines if the specified item is present in the value. (Inherited from DelimitedField.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Gets an enumerator. (Inherited from DelimitedField.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItems | Gets the items.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Public method | IndexOf | Get the index of an item. (Inherited from DelimitedField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink(Item, Item) | Obsolete. Relinks the specified item. (Inherited from DelimitedField.)
Public method | Relink(ItemLink, Item) | Relinks the specified item. (Inherited from DelimitedField.)
Public method | Remove | Removes the specified item. (Inherited from DelimitedField.)
Public method | RemoveLink(Item) | Obsolete. Removes the link. (Inherited from DelimitedField.)
Public method | RemoveLink(ItemLink) | Removes the link. (Inherited from DelimitedField.)
Public method | Replace | Replaces the specified item. (Inherited from DelimitedField.)
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
Public method | ToString | Gets the value. (Inherited from DelimitedField.)
Public method | UpdateLink | Updates the link. (Inherited from CustomField.)
Public method | ValidateLinks | Validates the links. (Inherited from DelimitedField.)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to MultilistField) | Converts a Field to a MultilistField.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

Properties

 | Name | Description
Public property | Count | Gets the count of items in this field. (Inherited from DelimitedField.)
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | Item | Gets the value at the specified index. (Inherited from DelimitedField.)
Public property | Items | Gets an array of values.. (Inherited from DelimitedField.)
Public property | List | Gets the value a as ListString. (Inherited from DelimitedField.)
Public property | TargetIDs | Gets the list of target IDs.
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

MultilistField Class
Sitecore.Data.Fields Namespace


MultilistField Constructor

[image]

Sitecore 6.4.1 API
MultilistField Constructor
MultilistField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MultilistField(
    Field innerField
)
Visual Basic
Public Sub New ( _
    innerField As Field _
)
Visual C++
public:
MultilistField(
    Field^ innerField
)

Parameters

innerField
Type: Sitecore.Data.Fields..::..Field
Inner field.

See Also

MultilistField Class
Sitecore.Data.Fields Namespace


MultilistField Methods

[image] [image]

Sitecore 6.4.1 API
MultilistField Methods
MultilistField Class See Also Send Feedback

The MultilistField type exposes the following members.

Methods

 | Name | Description
Public method | Add(String) | Adds the specified item. (Inherited from DelimitedField.)
Public method | Add(String, Boolean) | Adds the specified item. (Inherited from DelimitedField.)
Public method | CharIndexOf | Gets the index of an item in the value. (Inherited from DelimitedField.)
Public method | Contains | Determines if the specified item is present in the value. (Inherited from DelimitedField.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Gets an enumerator. (Inherited from DelimitedField.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItems | Gets the items.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Public method | IndexOf | Get the index of an item. (Inherited from DelimitedField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink(Item, Item) | Obsolete. Relinks the specified item. (Inherited from DelimitedField.)
Public method | Relink(ItemLink, Item) | Relinks the specified item. (Inherited from DelimitedField.)
Public method | Remove | Removes the specified item. (Inherited from DelimitedField.)
Public method | RemoveLink(Item) | Obsolete. Removes the link. (Inherited from DelimitedField.)
Public method | RemoveLink(ItemLink) | Removes the link. (Inherited from DelimitedField.)
Public method | Replace | Replaces the specified item. (Inherited from DelimitedField.)
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
Public method | ToString | Gets the value. (Inherited from DelimitedField.)
Public method | UpdateLink | Updates the link. (Inherited from CustomField.)
Public method | ValidateLinks | Validates the links. (Inherited from DelimitedField.)

See Also

MultilistField Class
Sitecore.Data.Fields Namespace


GetItems Method

[image]

Sitecore 6.4.1 API
MultilistField..::..GetItems Method
MultilistField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item[] GetItems()
Visual Basic
Public Function GetItems As Item()
Visual C++
public:
array<Item^>^ GetItems()

Return Value

The items.

See Also

MultilistField Class
Sitecore.Data.Fields Namespace


Relink Method

[image] [image]

Sitecore 6.4.1 API
MultilistField..::..Relink Method
MultilistField Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Relink(Item, Item) | Obsolete. Relinks the specified item. (Inherited from DelimitedField.)
Public method | Relink(ItemLink, Item) | Relinks the specified item. (Inherited from DelimitedField.)

See Also

MultilistField Class
MultilistField Members
Sitecore.Data.Fields Namespace


RemoveLink Method

[image] [image]

Sitecore 6.4.1 API
MultilistField..::..RemoveLink Method
MultilistField Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveLink(Item) | Obsolete. Removes the link. (Inherited from DelimitedField.)
Public method | RemoveLink(ItemLink) | Removes the link. (Inherited from DelimitedField.)

See Also

MultilistField Class
MultilistField Members
Sitecore.Data.Fields Namespace


MultilistField Type Conversions

[image] [image]

Sitecore 6.4.1 API
MultilistField Type Conversions
MultilistField Class See Also Send Feedback

The MultilistField type exposes the following members.

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to MultilistField) | Converts a Field to a MultilistField.

See Also

MultilistField Class
Sitecore.Data.Fields Namespace


Implicit Conversion (Field to MultilistField)

[image]

Sitecore 6.4.1 API
MultilistField ImplicitWideningImplicitImplicitImplicit Conversion (Field to MultilistField)
MultilistField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator MultilistField (
    Field field
)
Visual Basic
Public Shared Widening Operator CType ( _
    field As Field _
) As MultilistField
Visual C++
static implicit operator MultilistField^ (
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.

Return Value

The implicit operator.

See Also

MultilistField Class
Sitecore.Data.Fields Namespace


MultilistField Properties

[image] [image]

Sitecore 6.4.1 API
MultilistField Properties
MultilistField Class See Also Send Feedback

The MultilistField type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the count of items in this field. (Inherited from DelimitedField.)
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | Item | Gets the value at the specified index. (Inherited from DelimitedField.)
Public property | Items | Gets an array of values.. (Inherited from DelimitedField.)
Public property | List | Gets the value a as ListString. (Inherited from DelimitedField.)
Public property | TargetIDs | Gets the list of target IDs.
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

MultilistField Class
Sitecore.Data.Fields Namespace


TargetIDs Property

[image]

Sitecore 6.4.1 API
MultilistField..::..TargetIDs Property
MultilistField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID[] TargetIDs { get; }
Visual Basic
Public ReadOnly Property TargetIDs As ID()
    Get
Visual C++
public:
property array<ID^>^ TargetIDs {
    array<ID^>^ get ();
}

Field Value

The target I ds.

See Also

MultilistField Class
Sitecore.Data.Fields Namespace


ParametersField Class

[image]

Sitecore 6.4.1 API
ParametersField Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ParametersField : Field
Visual Basic
Public Class ParametersField _
    Inherits Field
Visual C++
public ref class ParametersField : public Field

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Fields..::..Field
Sitecore.Data.Fields..::..ParametersField

See Also

ParametersField Members
Sitecore.Data.Fields Namespace


ParametersField Members

[image] [image]

Sitecore 6.4.1 API
ParametersField Members
ParametersField Class Constructors Methods Properties See Also Send Feedback

The ParametersField type exposes the following members.

Constructors

 | Name | Description
Public method | ParametersField | Initializes a new instance of the ParametersField class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBlobStream | Gets the BLOB stream associated with the field. (Inherited from Field.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInheritedValue | Gets the inherited value. (Inherited from Field.)
Public method | GetStandardValue | Gets the standard value for the field. (Inherited from Field.)
Public method | GetTemplateField | Gets the template field. (Inherited from Field.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueId | Gets a unique id. (Inherited from Field.)
Public method | GetValue(Boolean) | Gets the current value of the field. (Inherited from Field.)
Public method | GetValue(Boolean, Boolean) | Gets the current value of the field. (Inherited from Field.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Resets the field. (Inherited from Field.)
Public method | SetBlobStream | Sets the BLOB stream associated with the field. (Inherited from Field.)
Public method | SetValue | Sets the value of the field. (Inherited from Field.)
Public method | ToString | Gets the value of the field. (Inherited from Field.)

Properties

 | Name | Description
Public property | CanRead | Gets a value indicating whether this field can be read by the current user. (Inherited from Field.)
Public property | CanWrite | Gets a value indicating whether this field can be written to. (Inherited from Field.)
Public property | ContainsStandardValue | Gets a value indicating whether [contains standard value]. (Overrides Field..::..ContainsStandardValue.)
Public property | Database | Gets the database. (Inherited from Field.)
Public property | Definition | Gets the definition. (Inherited from Field.)
Public property | Description | Gets the description. (Inherited from Field.)
Public property | DisplayName | Gets the display name. (Inherited from Field.)
Public property | HasBlobStream | Gets a value indicating whether this field instance has a value. (Inherited from Field.)
Public property | HasValue | Gets a value indicating whether this field instance has a value. (Inherited from Field.)
Public property | HelpLink | Gets the help link. (Inherited from Field.)
Public property | ID | Gets the ID. (Inherited from Field.)
Public property | InheritedValue | Gets the inherited value. (Inherited from Field.)
Public property | InheritsValueFromOtherItem | Gets a value indicating whether the current Value is inherited from other item (ie. it has been retrieved from the some other item but not from the standard values). (Inherited from Field.)
Public property | IsBlobField | Gets a value indicating whether this instance is a BLOB field. (Inherited from Field.)
Public property | IsModified | Gets a value indicating whether this field is modified. (Inherited from Field.)
Public property | Item | Gets the Item. (Inherited from Field.)
Public property | Key | Gets the key. (Inherited from Field.)
Public property | Language | Gets the language. (Inherited from Field.)
Public property | Name | Gets the name of field. (Inherited from Field.)
Public property | ResetBlank | Gets a value indicating whether this Field should be reset if its value is blank. (Inherited from Field.)
Public property | Section | Gets the section name. (Inherited from Field.)
Public property | SectionDisplayName | Gets the display name of the section. (Inherited from Field.)
Public property | SectionNameByUILocale | Gets the section name by UI locale. (Inherited from Field.)
Public property | SectionSortorder | Gets the section sortorder. (Inherited from Field.)
Public property | Shared | Gets a value indicating whether this Field is shared. (Inherited from Field.)
Public property | ShouldBeTranslated | Gets a value indicating whether a field is eligable for translation. (Inherited from Field.)
Public property | Sortorder | Gets the field sortorder. (Inherited from Field.)
Public property | Source | Gets the source. (Inherited from Field.)
Public property | Style | Gets the CSS style. (Inherited from Field.)
Public property | Title | Gets the title. (Inherited from Field.)
Public property | ToolTip | Gets the tool tip. (Inherited from Field.)
Public property | Translatable | Gets a value indicating whether a field can be translated. (Inherited from Field.)
Public property | Type | Gets the type. (Inherited from Field.)
Public property | TypeKey | Gets the type key. (Inherited from Field.)
Public property | Unversioned | Gets a value indicating whether this Field is unversioned. (Inherited from Field.)
Public property | Validation | Gets the validation regular expression. (Inherited from Field.)
Public property | ValidationText | Gets the validation text that is displayed if the Validation regular expression fails. (Inherited from Field.)
Public property | Value | Gets or sets the value. (Inherited from Field.)

See Also

ParametersField Class
Sitecore.Data.Fields Namespace


ParametersField Constructor

[image]

Sitecore 6.4.1 API
ParametersField Constructor
ParametersField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ParametersField(
    Field field,
    bool containsStandardValue
)
Visual Basic
Public Sub New ( _
    field As Field, _
    containsStandardValue As Boolean _
)
Visual C++
public:
ParametersField(
    Field^ field,
    bool containsStandardValue
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.
containsStandardValue
Type: System..::..Boolean
if set to true [from standart value].

See Also

ParametersField Class
Sitecore.Data.Fields Namespace


ParametersField Methods

[image] [image]

Sitecore 6.4.1 API
ParametersField Methods
ParametersField Class See Also Send Feedback

The ParametersField type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBlobStream | Gets the BLOB stream associated with the field. (Inherited from Field.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInheritedValue | Gets the inherited value. (Inherited from Field.)
Public method | GetStandardValue | Gets the standard value for the field. (Inherited from Field.)
Public method | GetTemplateField | Gets the template field. (Inherited from Field.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueId | Gets a unique id. (Inherited from Field.)
Public method | GetValue(Boolean) | Gets the current value of the field. (Inherited from Field.)
Public method | GetValue(Boolean, Boolean) | Gets the current value of the field. (Inherited from Field.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Resets the field. (Inherited from Field.)
Public method | SetBlobStream | Sets the BLOB stream associated with the field. (Inherited from Field.)
Public method | SetValue | Sets the value of the field. (Inherited from Field.)
Public method | ToString | Gets the value of the field. (Inherited from Field.)

See Also

ParametersField Class
Sitecore.Data.Fields Namespace


ParametersField Properties

[image] [image]

Sitecore 6.4.1 API
ParametersField Properties
ParametersField Class See Also Send Feedback

The ParametersField type exposes the following members.

Properties

 | Name | Description
Public property | CanRead | Gets a value indicating whether this field can be read by the current user. (Inherited from Field.)
Public property | CanWrite | Gets a value indicating whether this field can be written to. (Inherited from Field.)
Public property | ContainsStandardValue | Gets a value indicating whether [contains standard value]. (Overrides Field..::..ContainsStandardValue.)
Public property | Database | Gets the database. (Inherited from Field.)
Public property | Definition | Gets the definition. (Inherited from Field.)
Public property | Description | Gets the description. (Inherited from Field.)
Public property | DisplayName | Gets the display name. (Inherited from Field.)
Public property | HasBlobStream | Gets a value indicating whether this field instance has a value. (Inherited from Field.)
Public property | HasValue | Gets a value indicating whether this field instance has a value. (Inherited from Field.)
Public property | HelpLink | Gets the help link. (Inherited from Field.)
Public property | ID | Gets the ID. (Inherited from Field.)
Public property | InheritedValue | Gets the inherited value. (Inherited from Field.)
Public property | InheritsValueFromOtherItem | Gets a value indicating whether the current Value is inherited from other item (ie. it has been retrieved from the some other item but not from the standard values). (Inherited from Field.)
Public property | IsBlobField | Gets a value indicating whether this instance is a BLOB field. (Inherited from Field.)
Public property | IsModified | Gets a value indicating whether this field is modified. (Inherited from Field.)
Public property | Item | Gets the Item. (Inherited from Field.)
Public property | Key | Gets the key. (Inherited from Field.)
Public property | Language | Gets the language. (Inherited from Field.)
Public property | Name | Gets the name of field. (Inherited from Field.)
Public property | ResetBlank | Gets a value indicating whether this Field should be reset if its value is blank. (Inherited from Field.)
Public property | Section | Gets the section name. (Inherited from Field.)
Public property | SectionDisplayName | Gets the display name of the section. (Inherited from Field.)
Public property | SectionNameByUILocale | Gets the section name by UI locale. (Inherited from Field.)
Public property | SectionSortorder | Gets the section sortorder. (Inherited from Field.)
Public property | Shared | Gets a value indicating whether this Field is shared. (Inherited from Field.)
Public property | ShouldBeTranslated | Gets a value indicating whether a field is eligable for translation. (Inherited from Field.)
Public property | Sortorder | Gets the field sortorder. (Inherited from Field.)
Public property | Source | Gets the source. (Inherited from Field.)
Public property | Style | Gets the CSS style. (Inherited from Field.)
Public property | Title | Gets the title. (Inherited from Field.)
Public property | ToolTip | Gets the tool tip. (Inherited from Field.)
Public property | Translatable | Gets a value indicating whether a field can be translated. (Inherited from Field.)
Public property | Type | Gets the type. (Inherited from Field.)
Public property | TypeKey | Gets the type key. (Inherited from Field.)
Public property | Unversioned | Gets a value indicating whether this Field is unversioned. (Inherited from Field.)
Public property | Validation | Gets the validation regular expression. (Inherited from Field.)
Public property | ValidationText | Gets the validation text that is displayed if the Validation regular expression fails. (Inherited from Field.)
Public property | Value | Gets or sets the value. (Inherited from Field.)

See Also

ParametersField Class
Sitecore.Data.Fields Namespace


ContainsStandardValue Property

[image]

Sitecore 6.4.1 API
ParametersField..::..ContainsStandardValue Property
ParametersField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool ContainsStandardValue { get; }
Visual Basic
Public Overrides ReadOnly Property ContainsStandardValue As Boolean
    Get
Visual C++
public:
virtual property bool ContainsStandardValue {
    bool get () override;
}

Field Value

true if [contains standard value]; otherwise, false.

See Also

ParametersField Class
Sitecore.Data.Fields Namespace


PropertyField Class

[image]

Sitecore 6.4.1 API
PropertyField Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PropertyField : CustomField
Visual Basic
Public Class PropertyField _
    Inherits CustomField
Visual C++
public ref class PropertyField : public CustomField

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Fields..::..CustomField
Sitecore.Data.Fields..::..PropertyField

See Also

PropertyField Members
Sitecore.Data.Fields Namespace


PropertyField Members

[image] [image]

Sitecore 6.4.1 API
PropertyField Members
PropertyField Class Constructors Methods Operators Fields Properties See Also Send Feedback

The PropertyField type exposes the following members.

Constructors

 | Name | Description
Public method | PropertyField | Creates a new PropertyField instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item. (Inherited from CustomField.)
Public method | RemoveLink | Removes the link. (Inherited from CustomField.)
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Inherited from CustomField.)
Public method | ValidateLinks | Validates the links. (Inherited from CustomField.)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to PropertyField) | Converts a Field to a PropertyField.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

Properties

 | Name | Description
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | Item | Gets or sets the value with the specified key.
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

PropertyField Class
Sitecore.Data.Fields Namespace


PropertyField Constructor

[image]

Sitecore 6.4.1 API
PropertyField Constructor
PropertyField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PropertyField(
    Field innerField
)
Visual Basic
Public Sub New ( _
    innerField As Field _
)
Visual C++
public:
PropertyField(
    Field^ innerField
)

Parameters

innerField
Type: Sitecore.Data.Fields..::..Field
Inner field.

See Also

PropertyField Class
Sitecore.Data.Fields Namespace


PropertyField Fields

[image] [image]

Sitecore 6.4.1 API
PropertyField Fields
PropertyField Class See Also Send Feedback

The PropertyField type exposes the following members.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

See Also

PropertyField Class
Sitecore.Data.Fields Namespace


PropertyField Methods

[image] [image]

Sitecore 6.4.1 API
PropertyField Methods
PropertyField Class See Also Send Feedback

The PropertyField type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item. (Inherited from CustomField.)
Public method | RemoveLink | Removes the link. (Inherited from CustomField.)
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Inherited from CustomField.)
Public method | ValidateLinks | Validates the links. (Inherited from CustomField.)

See Also

PropertyField Class
Sitecore.Data.Fields Namespace


PropertyField Type Conversions

[image] [image]

Sitecore 6.4.1 API
PropertyField Type Conversions
PropertyField Class See Also Send Feedback

The PropertyField type exposes the following members.

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to PropertyField) | Converts a Field to a PropertyField.

See Also

PropertyField Class
Sitecore.Data.Fields Namespace


Implicit Conversion (Field to PropertyField)

[image]

Sitecore 6.4.1 API
PropertyField ImplicitWideningImplicitImplicitImplicit Conversion (Field to PropertyField)
PropertyField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator PropertyField (
    Field field
)
Visual Basic
Public Shared Widening Operator CType ( _
    field As Field _
) As PropertyField
Visual C++
static implicit operator PropertyField^ (
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.

Return Value

The implicit operator.

See Also

PropertyField Class
Sitecore.Data.Fields Namespace


PropertyField Properties

[image] [image]

Sitecore 6.4.1 API
PropertyField Properties
PropertyField Class See Also Send Feedback

The PropertyField type exposes the following members.

Properties

 | Name | Description
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | Item | Gets or sets the value with the specified key.
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

PropertyField Class
Sitecore.Data.Fields Namespace


Item Property

[image]

Sitecore 6.4.1 API
PropertyField..::..Item Property
PropertyField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string this[
    string key
] { get; set; }
Visual Basic
Public Default Property Item ( _
    key As String _
) As String
    Get
    Set
Visual C++
public:
property String^ default[String^ key] {
    String^ get (String^ key);
    void set (String^ key, String^ value);
}

Parameters

key
Type: System..::..String

Field Value

See Also

PropertyField Class
Sitecore.Data.Fields Namespace


ReferenceField Class

[image]

Sitecore 6.4.1 API
ReferenceField Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ReferenceField : CustomField
Visual Basic
Public Class ReferenceField _
    Inherits CustomField
Visual C++
public ref class ReferenceField : public CustomField

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Fields..::..CustomField
Sitecore.Data.Fields..::..ReferenceField

See Also

ReferenceField Members
Sitecore.Data.Fields Namespace


ReferenceField Members

[image] [image]

Sitecore 6.4.1 API
ReferenceField Members
ReferenceField Class Constructors Methods Operators Fields Properties See Also Send Feedback

The ReferenceField type exposes the following members.

Constructors

 | Name | Description
Public method | ReferenceField | Initializes a new instance of the ReferenceField class.

Methods

 | Name | Description
Public method | Clear | Clears this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item. (Overrides CustomField..::..Relink(ItemLink, Item).)
Public method | RemoveLink | Removes the link. (Overrides CustomField..::..RemoveLink(ItemLink).)
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Inherited from CustomField.)
Public method | ValidateLinks | Validates the links. (Overrides CustomField..::..ValidateLinks(LinksValidationResult).)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to ReferenceField) | Converts a Field to a LinkField.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

Properties

 | Name | Description
Public property | Database | Gets the database.
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | Path | Gets or sets the path to the target.
Public property | TargetID | Gets the target ID.
Public property | TargetItem | Gets the target item.
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

ReferenceField Class
Sitecore.Data.Fields Namespace


ReferenceField Constructor

[image]

Sitecore 6.4.1 API
ReferenceField Constructor
ReferenceField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ReferenceField(
    Field innerField
)
Visual Basic
Public Sub New ( _
    innerField As Field _
)
Visual C++
public:
ReferenceField(
    Field^ innerField
)

Parameters

innerField
Type: Sitecore.Data.Fields..::..Field
Inner field.

See Also

ReferenceField Class
Sitecore.Data.Fields Namespace


ReferenceField Fields

[image] [image]

Sitecore 6.4.1 API
ReferenceField Fields
ReferenceField Class See Also Send Feedback

The ReferenceField type exposes the following members.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

See Also

ReferenceField Class
Sitecore.Data.Fields Namespace


ReferenceField Methods

[image] [image]

Sitecore 6.4.1 API
ReferenceField Methods
ReferenceField Class See Also Send Feedback

The ReferenceField type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Clears this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item. (Overrides CustomField..::..Relink(ItemLink, Item).)
Public method | RemoveLink | Removes the link. (Overrides CustomField..::..RemoveLink(ItemLink).)
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Inherited from CustomField.)
Public method | ValidateLinks | Validates the links. (Overrides CustomField..::..ValidateLinks(LinksValidationResult).)

See Also

ReferenceField Class
Sitecore.Data.Fields Namespace


Clear Method

[image]

Sitecore 6.4.1 API
ReferenceField..::..Clear Method
ReferenceField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

ReferenceField Class
Sitecore.Data.Fields Namespace


Relink Method

[image]

Sitecore 6.4.1 API
ReferenceField..::..Relink Method
ReferenceField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Relink(
    ItemLink itemLink,
    Item newLink
)
Visual Basic
Public Overrides Sub Relink ( _
    itemLink As ItemLink, _
    newLink As Item _
)
Visual C++
public:
virtual void Relink(
    ItemLink^ itemLink,
    Item^ newLink
) override

Parameters

itemLink
Type: Sitecore.Links..::..ItemLink
The item link.
newLink
Type: Sitecore.Data.Items..::..Item
The new link.

See Also

ReferenceField Class
Sitecore.Data.Fields Namespace


RemoveLink Method

[image]

Sitecore 6.4.1 API
ReferenceField..::..RemoveLink Method
ReferenceField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void RemoveLink(
    ItemLink itemLink
)
Visual Basic
Public Overrides Sub RemoveLink ( _
    itemLink As ItemLink _
)
Visual C++
public:
virtual void RemoveLink(
    ItemLink^ itemLink
) override

Parameters

itemLink
Type: Sitecore.Links..::..ItemLink
The item link.

See Also

ReferenceField Class
Sitecore.Data.Fields Namespace


ValidateLinks Method

[image]

Sitecore 6.4.1 API
ReferenceField..::..ValidateLinks Method
ReferenceField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void ValidateLinks(
    LinksValidationResult result
)
Visual Basic
Public Overrides Sub ValidateLinks ( _
    result As LinksValidationResult _
)
Visual C++
public:
virtual void ValidateLinks(
    LinksValidationResult^ result
) override

Parameters

result
Type: Sitecore.Links..::..LinksValidationResult
The result.

See Also

ReferenceField Class
Sitecore.Data.Fields Namespace


ReferenceField Type Conversions

[image] [image]

Sitecore 6.4.1 API
ReferenceField Type Conversions
ReferenceField Class See Also Send Feedback

The ReferenceField type exposes the following members.

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to ReferenceField) | Converts a Field to a LinkField.

See Also

ReferenceField Class
Sitecore.Data.Fields Namespace


Implicit Conversion (Field to ReferenceField)

[image]

Sitecore 6.4.1 API
ReferenceField ImplicitWideningImplicitImplicitImplicit Conversion (Field to ReferenceField)
ReferenceField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator ReferenceField (
    Field field
)
Visual Basic
Public Shared Widening Operator CType ( _
    field As Field _
) As ReferenceField
Visual C++
static implicit operator ReferenceField^ (
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.

Return Value

The implicit operator.

See Also

ReferenceField Class
Sitecore.Data.Fields Namespace


ReferenceField Properties

[image] [image]

Sitecore 6.4.1 API
ReferenceField Properties
ReferenceField Class See Also Send Feedback

The ReferenceField type exposes the following members.

Properties

 | Name | Description
Public property | Database | Gets the database.
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | Path | Gets or sets the path to the target.
Public property | TargetID | Gets the target ID.
Public property | TargetItem | Gets the target item.
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

ReferenceField Class
Sitecore.Data.Fields Namespace


Database Property

[image]

Sitecore 6.4.1 API
ReferenceField..::..Database Property
ReferenceField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database Database { get; }
Visual Basic
Public ReadOnly Property Database As Database
    Get
Visual C++
public:
property Database^ Database {
    Database^ get ();
}

Field Value

The database.

See Also

ReferenceField Class
Sitecore.Data.Fields Namespace


Path Property

[image]

Sitecore 6.4.1 API
ReferenceField..::..Path Property
ReferenceField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Path { get; set; }
Visual Basic
Public Property Path As String
    Get
    Set
Visual C++
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}

Field Value

The path.

See Also

ReferenceField Class
Sitecore.Data.Fields Namespace


TargetID Property

[image]

Sitecore 6.4.1 API
ReferenceField..::..TargetID Property
ReferenceField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID TargetID { get; }
Visual Basic
Public ReadOnly Property TargetID As ID
    Get
Visual C++
public:
property ID^ TargetID {
    ID^ get ();
}

Field Value

The target ID.

See Also

ReferenceField Class
Sitecore.Data.Fields Namespace


TargetItem Property

[image]

Sitecore 6.4.1 API
ReferenceField..::..TargetItem Property
ReferenceField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item TargetItem { get; }
Visual Basic
Public ReadOnly Property TargetItem As Item
    Get
Visual C++
public:
property Item^ TargetItem {
    Item^ get ();
}

Field Value

The target item.

See Also

ReferenceField Class
Sitecore.Data.Fields Namespace


RendererField Class

[image]

Sitecore 6.4.1 API
RendererField Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RendererField : CustomField
Visual Basic
Public Class RendererField _
    Inherits CustomField
Visual C++
public ref class RendererField : public CustomField

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Fields..::..CustomField
Sitecore.Data.Fields..::..RendererField

See Also

RendererField Members
Sitecore.Data.Fields Namespace


RendererField Members

[image] [image]

Sitecore 6.4.1 API
RendererField Members
RendererField Class Constructors Methods Operators Fields Properties See Also Send Feedback

The RendererField type exposes the following members.

Constructors

 | Name | Description
Public method | RendererField | Creates a new RendererField instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControl | Gets the control.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item. (Inherited from CustomField.)
Public method | RemoveLink | Removes the link. (Inherited from CustomField.)
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Inherited from CustomField.)
Public method | ValidateLinks | Validates the links. (Inherited from CustomField.)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to RendererField) | Converts a Field to a RendererField.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

Properties

 | Name | Description
Public property | Data | Gets the value as an XML document.
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

RendererField Class
Sitecore.Data.Fields Namespace


RendererField Constructor

[image]

Sitecore 6.4.1 API
RendererField Constructor
RendererField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RendererField(
    Field innerField
)
Visual Basic
Public Sub New ( _
    innerField As Field _
)
Visual C++
public:
RendererField(
    Field^ innerField
)

Parameters

innerField
Type: Sitecore.Data.Fields..::..Field
Inner field.

See Also

RendererField Class
Sitecore.Data.Fields Namespace


RendererField Fields

[image] [image]

Sitecore 6.4.1 API
RendererField Fields
RendererField Class See Also Send Feedback

The RendererField type exposes the following members.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

See Also

RendererField Class
Sitecore.Data.Fields Namespace


RendererField Methods

[image] [image]

Sitecore 6.4.1 API
RendererField Methods
RendererField Class See Also Send Feedback

The RendererField type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControl | Gets the control.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item. (Inherited from CustomField.)
Public method | RemoveLink | Removes the link. (Inherited from CustomField.)
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Inherited from CustomField.)
Public method | ValidateLinks | Validates the links. (Inherited from CustomField.)

See Also

RendererField Class
Sitecore.Data.Fields Namespace


GetControl Method

[image]

Sitecore 6.4.1 API
RendererField..::..GetControl Method
RendererField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Control GetControl(
    string mode,
    bool allowDefault,
    Item dataItem
)
Visual Basic
Public Function GetControl ( _
    mode As String, _
    allowDefault As Boolean, _
    dataItem As Item _
) As Control
Visual C++
public:
Control^ GetControl(
    String^ mode,
    bool allowDefault,
    Item^ dataItem
)

Parameters

mode
Type: System..::..String
Mode.
allowDefault
Type: System..::..Boolean
Allow default.
dataItem
Type: Sitecore.Data.Items..::..Item
Data item.

Return Value

The control.

See Also

RendererField Class
Sitecore.Data.Fields Namespace


RendererField Type Conversions

[image] [image]

Sitecore 6.4.1 API
RendererField Type Conversions
RendererField Class See Also Send Feedback

The RendererField type exposes the following members.

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to RendererField) | Converts a Field to a RendererField.

See Also

RendererField Class
Sitecore.Data.Fields Namespace


Implicit Conversion (Field to RendererField)

[image]

Sitecore 6.4.1 API
RendererField ImplicitWideningImplicitImplicitImplicit Conversion (Field to RendererField)
RendererField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator RendererField (
    Field field
)
Visual Basic
Public Shared Widening Operator CType ( _
    field As Field _
) As RendererField
Visual C++
static implicit operator RendererField^ (
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.

Return Value

The implicit operator.

See Also

RendererField Class
Sitecore.Data.Fields Namespace


RendererField Properties

[image] [image]

Sitecore 6.4.1 API
RendererField Properties
RendererField Class See Also Send Feedback

The RendererField type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets the value as an XML document.
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

RendererField Class
Sitecore.Data.Fields Namespace


Data Property

[image]

Sitecore 6.4.1 API
RendererField..::..Data Property
RendererField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public XmlDocument Data { get; }
Visual Basic
Public ReadOnly Property Data As XmlDocument
    Get
Visual C++
public:
property XmlDocument^ Data {
    XmlDocument^ get ();
}

Field Value

The data.

See Also

RendererField Class
Sitecore.Data.Fields Namespace


TemplateFieldSourceField Class

[image]

Sitecore 6.4.1 API
TemplateFieldSourceField Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class TemplateFieldSourceField : InternalLinkField
Visual Basic
Public Class TemplateFieldSourceField _
    Inherits InternalLinkField
Visual C++
public ref class TemplateFieldSourceField : public InternalLinkField

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Fields..::..CustomField
Sitecore.Data.Fields..::..InternalLinkField
Sitecore.Data.Fields..::..TemplateFieldSourceField

See Also

TemplateFieldSourceField Members
Sitecore.Data.Fields Namespace


TemplateFieldSourceField Members

[image] [image]

Sitecore 6.4.1 API
TemplateFieldSourceField Members
TemplateFieldSourceField Class Constructors Methods Operators Fields Properties See Also Send Feedback

The TemplateFieldSourceField type exposes the following members.

Constructors

 | Name | Description
Public method | TemplateFieldSourceField | Creates a new LinkField instance.

Methods

 | Name | Description
Public method | Clear | Clears this instance. (Inherited from InternalLinkField.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item link. (Inherited from InternalLinkField.)
Public method | RemoveLink | Removes the link. (Inherited from InternalLinkField.)
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Inherited from InternalLinkField.)
Public method | ValidateImage | Validates the links.
Public method | ValidateLinks | Validates the links. (Overrides InternalLinkField..::..ValidateLinks(LinksValidationResult).)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to TemplateFieldSourceField) | Converts a Field to a LinkField.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

Properties

 | Name | Description
Public property | Database | Gets the database. (Inherited from InternalLinkField.)
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | Path | Gets or sets the path. (Inherited from InternalLinkField.)
Public property | TargetID | Gets the target ID. (Inherited from InternalLinkField.)
Public property | TargetItem | Gets the target item. (Inherited from InternalLinkField.)
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

TemplateFieldSourceField Class
Sitecore.Data.Fields Namespace


TemplateFieldSourceField Constructor

[image]

Sitecore 6.4.1 API
TemplateFieldSourceField Constructor
TemplateFieldSourceField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateFieldSourceField(
    Field innerField
)
Visual Basic
Public Sub New ( _
    innerField As Field _
)
Visual C++
public:
TemplateFieldSourceField(
    Field^ innerField
)

Parameters

innerField
Type: Sitecore.Data.Fields..::..Field
Inner field.

See Also

TemplateFieldSourceField Class
Sitecore.Data.Fields Namespace


TemplateFieldSourceField Fields

[image] [image]

Sitecore 6.4.1 API
TemplateFieldSourceField Fields
TemplateFieldSourceField Class See Also Send Feedback

The TemplateFieldSourceField type exposes the following members.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

See Also

TemplateFieldSourceField Class
Sitecore.Data.Fields Namespace


TemplateFieldSourceField Methods

[image] [image]

Sitecore 6.4.1 API
TemplateFieldSourceField Methods
TemplateFieldSourceField Class See Also Send Feedback

The TemplateFieldSourceField type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Clears this instance. (Inherited from InternalLinkField.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item link. (Inherited from InternalLinkField.)
Public method | RemoveLink | Removes the link. (Inherited from InternalLinkField.)
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Inherited from InternalLinkField.)
Public method | ValidateImage | Validates the links.
Public method | ValidateLinks | Validates the links. (Overrides InternalLinkField..::..ValidateLinks(LinksValidationResult).)

See Also

TemplateFieldSourceField Class
Sitecore.Data.Fields Namespace


ValidateImage Method

[image]

Sitecore 6.4.1 API
TemplateFieldSourceField..::..ValidateImage Method
TemplateFieldSourceField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void ValidateImage(
    LinksValidationResult result
)
Visual Basic
Public Sub ValidateImage ( _
    result As LinksValidationResult _
)
Visual C++
public:
void ValidateImage(
    LinksValidationResult^ result
)

Parameters

result
Type: Sitecore.Links..::..LinksValidationResult
The result.

See Also

TemplateFieldSourceField Class
Sitecore.Data.Fields Namespace


ValidateLinks Method

[image]

Sitecore 6.4.1 API
TemplateFieldSourceField..::..ValidateLinks Method
TemplateFieldSourceField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void ValidateLinks(
    LinksValidationResult result
)
Visual Basic
Public Overrides Sub ValidateLinks ( _
    result As LinksValidationResult _
)
Visual C++
public:
virtual void ValidateLinks(
    LinksValidationResult^ result
) override

Parameters

result
Type: Sitecore.Links..::..LinksValidationResult
The result.

See Also

TemplateFieldSourceField Class
Sitecore.Data.Fields Namespace


TemplateFieldSourceField Type Conversions

[image] [image]

Sitecore 6.4.1 API
TemplateFieldSourceField Type Conversions
TemplateFieldSourceField Class See Also Send Feedback

The TemplateFieldSourceField type exposes the following members.

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to TemplateFieldSourceField) | Converts a Field to a LinkField.

See Also

TemplateFieldSourceField Class
Sitecore.Data.Fields Namespace


Implicit Conversion (Field to TemplateFieldSourceField)

[image]

Sitecore 6.4.1 API
TemplateFieldSourceField ImplicitWideningImplicitImplicitImplicit Conversion (Field to TemplateFieldSourceField)
TemplateFieldSourceField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator TemplateFieldSourceField (
    Field field
)
Visual Basic
Public Shared Widening Operator CType ( _
    field As Field _
) As TemplateFieldSourceField
Visual C++
static implicit operator TemplateFieldSourceField^ (
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.

Return Value

The implicit operator.

See Also

TemplateFieldSourceField Class
Sitecore.Data.Fields Namespace


TemplateFieldSourceField Properties

[image] [image]

Sitecore 6.4.1 API
TemplateFieldSourceField Properties
TemplateFieldSourceField Class See Also Send Feedback

The TemplateFieldSourceField type exposes the following members.

Properties

 | Name | Description
Public property | Database | Gets the database. (Inherited from InternalLinkField.)
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | Path | Gets or sets the path. (Inherited from InternalLinkField.)
Public property | TargetID | Gets the target ID. (Inherited from InternalLinkField.)
Public property | TargetItem | Gets the target item. (Inherited from InternalLinkField.)
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

TemplateFieldSourceField Class
Sitecore.Data.Fields Namespace


TextField Class

[image]

Sitecore 6.4.1 API
TextField Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public sealed class TextField : CustomField
Visual Basic
Public NotInheritable Class TextField _
    Inherits CustomField
Visual C++
public ref class TextField sealed : public CustomField

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Fields..::..CustomField
Sitecore.Data.Fields..::..TextField

See Also

TextField Members
Sitecore.Data.Fields Namespace


TextField Members

[image] [image]

Sitecore 6.4.1 API
TextField Members
TextField Class Constructors Methods Operators Fields Properties See Also Send Feedback

The TextField type exposes the following members.

Constructors

 | Name | Description
Public method | TextField | Creates a new DateField instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item. (Inherited from CustomField.)
Public method | RemoveLink | Removes the link. (Inherited from CustomField.)
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Inherited from CustomField.)
Public method | ValidateLinks | Validates the links. (Inherited from CustomField.)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to TextField) | Converts a Field to a DateField

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

Properties

 | Name | Description
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

TextField Class
Sitecore.Data.Fields Namespace


TextField Constructor

[image]

Sitecore 6.4.1 API
TextField Constructor
TextField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TextField(
    Field innerField
)
Visual Basic
Public Sub New ( _
    innerField As Field _
)
Visual C++
public:
TextField(
    Field^ innerField
)

Parameters

innerField
Type: Sitecore.Data.Fields..::..Field
Inner field.

See Also

TextField Class
Sitecore.Data.Fields Namespace


TextField Fields

[image] [image]

Sitecore 6.4.1 API
TextField Fields
TextField Class See Also Send Feedback

The TextField type exposes the following members.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

See Also

TextField Class
Sitecore.Data.Fields Namespace


TextField Methods

[image] [image]

Sitecore 6.4.1 API
TextField Methods
TextField Class See Also Send Feedback

The TextField type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item. (Inherited from CustomField.)
Public method | RemoveLink | Removes the link. (Inherited from CustomField.)
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Inherited from CustomField.)
Public method | ValidateLinks | Validates the links. (Inherited from CustomField.)

See Also

TextField Class
Sitecore.Data.Fields Namespace


TextField Type Conversions

[image] [image]

Sitecore 6.4.1 API
TextField Type Conversions
TextField Class See Also Send Feedback

The TextField type exposes the following members.

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to TextField) | Converts a Field to a DateField

See Also

TextField Class
Sitecore.Data.Fields Namespace


Implicit Conversion (Field to TextField)

[image]

Sitecore 6.4.1 API
TextField ImplicitWideningImplicitImplicitImplicit Conversion (Field to TextField)
TextField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator TextField (
    Field field
)
Visual Basic
Public Shared Widening Operator CType ( _
    field As Field _
) As TextField
Visual C++
static implicit operator TextField^ (
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.

Return Value

The implicit operator.

See Also

TextField Class
Sitecore.Data.Fields Namespace


TextField Properties

[image] [image]

Sitecore 6.4.1 API
TextField Properties
TextField Class See Also Send Feedback

The TextField type exposes the following members.

Properties

 | Name | Description
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

TextField Class
Sitecore.Data.Fields Namespace


ThumbnailField Class

[image]

Sitecore 6.4.1 API
ThumbnailField Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ThumbnailField : ImageField
Visual Basic
Public Class ThumbnailField _
    Inherits ImageField
Visual C++
public ref class ThumbnailField : public ImageField

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Fields..::..CustomField
Sitecore.Data.Fields..::..XmlField
Sitecore.Data.Fields..::..ImageField
Sitecore.Data.Fields..::..ThumbnailField

See Also

ThumbnailField Members
Sitecore.Data.Fields Namespace


ThumbnailField Constructor

[image] [image]

Sitecore 6.4.1 API
ThumbnailField Constructor
ThumbnailField Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ThumbnailField(Field) | Initializes a new instance of the ThumbnailField class.
Public method | ThumbnailField(Field, String) | Initializes a new instance of the ThumbnailField class.

See Also

ThumbnailField Class
ThumbnailField Members
Sitecore.Data.Fields Namespace


ThumbnailField Constructor (Field)

[image]

Sitecore 6.4.1 API
ThumbnailField Constructor (Field)
ThumbnailField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ThumbnailField(
    Field innerField
)
Visual Basic
Public Sub New ( _
    innerField As Field _
)
Visual C++
public:
ThumbnailField(
    Field^ innerField
)

Parameters

innerField
Type: Sitecore.Data.Fields..::..Field
Inner field.

See Also

ThumbnailField Class
ThumbnailField Overload
Sitecore.Data.Fields Namespace


ThumbnailField Constructor (Field, String)

[image]

Sitecore 6.4.1 API
ThumbnailField Constructor (Field, String)
ThumbnailField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ThumbnailField(
    Field innerField,
    string runtimeValue
)
Visual Basic
Public Sub New ( _
    innerField As Field, _
    runtimeValue As String _
)
Visual C++
public:
ThumbnailField(
    Field^ innerField,
    String^ runtimeValue
)

Parameters

innerField
Type: Sitecore.Data.Fields..::..Field
The inner field.
runtimeValue
Type: System..::..String
The runtime value.

See Also

ThumbnailField Class
ThumbnailField Overload
Sitecore.Data.Fields Namespace


ThumbnailField Methods

[image] [image]

Sitecore 6.4.1 API
ThumbnailField Methods
ThumbnailField Class See Also Send Feedback

The ThumbnailField type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Clears this instance. (Inherited from ImageField.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttribute | Gets the attribute. (Inherited from XmlField.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item. (Inherited from ImageField.)
Public method | RemoveLink | Removes the link. (Inherited from ImageField.)
Public method | SetAttribute | Sets the attribute. (Inherited from XmlField.)
Protected method | SetValue | Sets the value. (Inherited from XmlField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Inherited from CustomField.)
Public method | ValidateLinks | Validates the links. (Inherited from ImageField.)

See Also

ThumbnailField Class
Sitecore.Data.Fields Namespace


ThumbnailField Type Conversions

[image] [image]

Sitecore 6.4.1 API
ThumbnailField Type Conversions
ThumbnailField Class See Also Send Feedback

The ThumbnailField type exposes the following members.

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to ThumbnailField) | Converts a Field to a ImageField.

See Also

ThumbnailField Class
Sitecore.Data.Fields Namespace


Implicit Conversion (Field to ThumbnailField)

[image]

Sitecore 6.4.1 API
ThumbnailField ImplicitWideningImplicitImplicitImplicit Conversion (Field to ThumbnailField)
ThumbnailField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator ThumbnailField (
    Field field
)
Visual Basic
Public Shared Widening Operator CType ( _
    field As Field _
) As ThumbnailField
Visual C++
static implicit operator ThumbnailField^ (
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The source field.

Return Value

The result of the conversion.

See Also

ThumbnailField Class
Sitecore.Data.Fields Namespace


ThumbnailField Properties

[image] [image]

Sitecore 6.4.1 API
ThumbnailField Properties
ThumbnailField Class See Also Send Feedback

The ThumbnailField type exposes the following members.

Properties

 | Name | Description
Public property | Alt | Gets or sets the Alt text. (Inherited from ImageField.)
Public property | Border | Gets or sets the Border value. (Inherited from ImageField.)
Public property | Class | Gets or sets the HTML class. (Inherited from ImageField.)
Public property | Height | Gets or sets the height. (Inherited from ImageField.)
Public property | HSpace | Gets or sets the HSpace value. (Inherited from ImageField.)
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | InternalPath | Obsolete. Gets the internal path, if any. (Inherited from ImageField.)
Public property | IsInternal | Gets a value indicating whether the image is internal. (Inherited from ImageField.)
Public property | LinkType | Gets or sets the link type. (Inherited from ImageField.)
Public property | MediaDatabase | Gets or sets the database containing the the media. (Inherited from ImageField.)
Public property | MediaID | Gets or sets the ID of the media item. (Inherited from ImageField.)
Public property | MediaItem | Gets the media item. (Inherited from ImageField.)
Public property | MediaLanguage | Gets or sets the language of the media item to use. (Inherited from ImageField.)
Public property | MediaPath | Obsolete. Gets or sets the media path. (Inherited from ImageField.)
Public property | MediaVersion | Gets or sets the version of the media item to use. (Inherited from ImageField.)
Public property | Root | Gets or sets the root tag. (Inherited from XmlField.)
Public property | Src | Obsolete. Gets or sets the source path. (Inherited from ImageField.)
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)
Public property | VSpace | Gets or sets the VSpace value. (Inherited from ImageField.)
Public property | Width | Gets or sets the width. (Inherited from ImageField.)
Public property | Xml | Gets the XML document contained in this field value. (Inherited from XmlField.)

See Also

ThumbnailField Class
Sitecore.Data.Fields Namespace


ValueLookupField Class

[image]

Sitecore 6.4.1 API
ValueLookupField Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ValueLookupField : CustomField
Visual Basic
Public Class ValueLookupField _
    Inherits CustomField
Visual C++
public ref class ValueLookupField : public CustomField

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Fields..::..CustomField
Sitecore.Data.Fields..::..ValueLookupField
Sitecore.Data.Fields..::..GroupedDroplistField

See Also

ValueLookupField Members
Sitecore.Data.Fields Namespace


ValueLookupField Members

[image] [image]

Sitecore 6.4.1 API
ValueLookupField Members
ValueLookupField Class Constructors Methods Operators Fields Properties See Also Send Feedback

The ValueLookupField type exposes the following members.

Constructors

 | Name | Description
Public method | ValueLookupField | Creates a new LookupField instance.

Methods

 | Name | Description
Public method | Clear | Clears this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item. (Overrides CustomField..::..Relink(ItemLink, Item).)
Public method | RemoveLink | Removes the link. (Overrides CustomField..::..RemoveLink(ItemLink).)
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Overrides CustomField..::..UpdateLink(ItemLink).)
Public method | ValidateLinks | Validates the links. (Overrides CustomField..::..ValidateLinks(LinksValidationResult).)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to ValueLookupField) | Converts a Field to a LookupField.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

Properties

 | Name | Description
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

ValueLookupField Class
Sitecore.Data.Fields Namespace


ValueLookupField Constructor

[image]

Sitecore 6.4.1 API
ValueLookupField Constructor
ValueLookupField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ValueLookupField(
    Field innerField
)
Visual Basic
Public Sub New ( _
    innerField As Field _
)
Visual C++
public:
ValueLookupField(
    Field^ innerField
)

Parameters

innerField
Type: Sitecore.Data.Fields..::..Field
Inner field.

See Also

ValueLookupField Class
Sitecore.Data.Fields Namespace


ValueLookupField Fields

[image] [image]

Sitecore 6.4.1 API
ValueLookupField Fields
ValueLookupField Class See Also Send Feedback

The ValueLookupField type exposes the following members.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

See Also

ValueLookupField Class
Sitecore.Data.Fields Namespace


ValueLookupField Methods

[image] [image]

Sitecore 6.4.1 API
ValueLookupField Methods
ValueLookupField Class See Also Send Feedback

The ValueLookupField type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Clears this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item. (Overrides CustomField..::..Relink(ItemLink, Item).)
Public method | RemoveLink | Removes the link. (Overrides CustomField..::..RemoveLink(ItemLink).)
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Overrides CustomField..::..UpdateLink(ItemLink).)
Public method | ValidateLinks | Validates the links. (Overrides CustomField..::..ValidateLinks(LinksValidationResult).)

See Also

ValueLookupField Class
Sitecore.Data.Fields Namespace


Clear Method

[image]

Sitecore 6.4.1 API
ValueLookupField..::..Clear Method
ValueLookupField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

ValueLookupField Class
Sitecore.Data.Fields Namespace


Relink Method

[image]

Sitecore 6.4.1 API
ValueLookupField..::..Relink Method
ValueLookupField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Relink(
    ItemLink itemLink,
    Item newLink
)
Visual Basic
Public Overrides Sub Relink ( _
    itemLink As ItemLink, _
    newLink As Item _
)
Visual C++
public:
virtual void Relink(
    ItemLink^ itemLink,
    Item^ newLink
) override

Parameters

itemLink
Type: Sitecore.Links..::..ItemLink
The item link.
newLink
Type: Sitecore.Data.Items..::..Item
The new link.

See Also

ValueLookupField Class
Sitecore.Data.Fields Namespace


RemoveLink Method

[image]

Sitecore 6.4.1 API
ValueLookupField..::..RemoveLink Method
ValueLookupField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void RemoveLink(
    ItemLink itemLink
)
Visual Basic
Public Overrides Sub RemoveLink ( _
    itemLink As ItemLink _
)
Visual C++
public:
virtual void RemoveLink(
    ItemLink^ itemLink
) override

Parameters

itemLink
Type: Sitecore.Links..::..ItemLink
The item link.

See Also

ValueLookupField Class
Sitecore.Data.Fields Namespace


UpdateLink Method

[image]

Sitecore 6.4.1 API
ValueLookupField..::..UpdateLink Method
ValueLookupField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void UpdateLink(
    ItemLink itemLink
)
Visual Basic
Public Overrides Sub UpdateLink ( _
    itemLink As ItemLink _
)
Visual C++
public:
virtual void UpdateLink(
    ItemLink^ itemLink
) override

Parameters

itemLink
Type: Sitecore.Links..::..ItemLink
The link.

See Also

ValueLookupField Class
Sitecore.Data.Fields Namespace


ValidateLinks Method

[image]

Sitecore 6.4.1 API
ValueLookupField..::..ValidateLinks Method
ValueLookupField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void ValidateLinks(
    LinksValidationResult result
)
Visual Basic
Public Overrides Sub ValidateLinks ( _
    result As LinksValidationResult _
)
Visual C++
public:
virtual void ValidateLinks(
    LinksValidationResult^ result
) override

Parameters

result
Type: Sitecore.Links..::..LinksValidationResult
The result.

See Also

ValueLookupField Class
Sitecore.Data.Fields Namespace


ValueLookupField Type Conversions

[image] [image]

Sitecore 6.4.1 API
ValueLookupField Type Conversions
ValueLookupField Class See Also Send Feedback

The ValueLookupField type exposes the following members.

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to ValueLookupField) | Converts a Field to a LookupField.

See Also

ValueLookupField Class
Sitecore.Data.Fields Namespace


Implicit Conversion (Field to ValueLookupField)

[image]

Sitecore 6.4.1 API
ValueLookupField ImplicitWideningImplicitImplicitImplicit Conversion (Field to ValueLookupField)
ValueLookupField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator ValueLookupField (
    Field field
)
Visual Basic
Public Shared Widening Operator CType ( _
    field As Field _
) As ValueLookupField
Visual C++
static implicit operator ValueLookupField^ (
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.

Return Value

The implicit operator.

See Also

ValueLookupField Class
Sitecore.Data.Fields Namespace


ValueLookupField Properties

[image] [image]

Sitecore 6.4.1 API
ValueLookupField Properties
ValueLookupField Class See Also Send Feedback

The ValueLookupField type exposes the following members.

Properties

 | Name | Description
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

ValueLookupField Class
Sitecore.Data.Fields Namespace


VersionLinkField Class

[image]

Sitecore 6.4.1 API
VersionLinkField Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class VersionLinkField : CustomField
Visual Basic
Public Class VersionLinkField _
    Inherits CustomField
Visual C++
public ref class VersionLinkField : public CustomField

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Fields..::..CustomField
Sitecore.Data.Fields..::..VersionLinkField

See Also

VersionLinkField Members
Sitecore.Data.Fields Namespace


VersionLinkField Members

[image] [image]

Sitecore 6.4.1 API
VersionLinkField Members
VersionLinkField Class Constructors Methods Fields Properties See Also Send Feedback

The VersionLinkField type exposes the following members.

Constructors

 | Name | Description
Public method | VersionLinkField(Field) | Initializes a new instance of the VersionLinkField class.
Public method | VersionLinkField(Field, String) | Initializes a new instance of the VersionLinkField class.

Methods

 | Name | Description
Public method | Clear | Clears the field value.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item link. (Overrides CustomField..::..Relink(ItemLink, Item).)
Public method | RemoveLink | Removes the link. (Overrides CustomField..::..RemoveLink(ItemLink).)
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Inherited from CustomField.)
Public method | ValidateLinks | Validates the links. (Overrides CustomField..::..ValidateLinks(LinksValidationResult).)

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

Properties

 | Name | Description
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | Uri | Gets or sets the URI.
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

VersionLinkField Class
Sitecore.Data.Fields Namespace


VersionLinkField Constructor

[image] [image]

Sitecore 6.4.1 API
VersionLinkField Constructor
VersionLinkField Class See Also Send Feedback

Overload List

 | Name | Description
Public method | VersionLinkField(Field) | Initializes a new instance of the VersionLinkField class.
Public method | VersionLinkField(Field, String) | Initializes a new instance of the VersionLinkField class.

See Also

VersionLinkField Class
VersionLinkField Members
Sitecore.Data.Fields Namespace


VersionLinkField Constructor (Field)

[image]

Sitecore 6.4.1 API
VersionLinkField Constructor (Field)
VersionLinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public VersionLinkField(
    Field innerField
)
Visual Basic
Public Sub New ( _
    innerField As Field _
)
Visual C++
public:
VersionLinkField(
    Field^ innerField
)

Parameters

innerField
Type: Sitecore.Data.Fields..::..Field
Inner field.

See Also

VersionLinkField Class
VersionLinkField Overload
Sitecore.Data.Fields Namespace


VersionLinkField Fields

[image] [image]

Sitecore 6.4.1 API
VersionLinkField Fields
VersionLinkField Class See Also Send Feedback

The VersionLinkField type exposes the following members.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

See Also

VersionLinkField Class
Sitecore.Data.Fields Namespace


VersionLinkField Methods

[image] [image]

Sitecore 6.4.1 API
VersionLinkField Methods
VersionLinkField Class See Also Send Feedback

The VersionLinkField type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Clears the field value.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item link. (Overrides CustomField..::..Relink(ItemLink, Item).)
Public method | RemoveLink | Removes the link. (Overrides CustomField..::..RemoveLink(ItemLink).)
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Inherited from CustomField.)
Public method | ValidateLinks | Validates the links. (Overrides CustomField..::..ValidateLinks(LinksValidationResult).)

See Also

VersionLinkField Class
Sitecore.Data.Fields Namespace


Relink Method

[image]

Sitecore 6.4.1 API
VersionLinkField..::..Relink Method
VersionLinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Relink(
    ItemLink itemLink,
    Item newLink
)
Visual Basic
Public Overrides Sub Relink ( _
    itemLink As ItemLink, _
    newLink As Item _
)
Visual C++
public:
virtual void Relink(
    ItemLink^ itemLink,
    Item^ newLink
) override

Parameters

itemLink
Type: Sitecore.Links..::..ItemLink
The item link.
newLink
Type: Sitecore.Data.Items..::..Item
The new link.

See Also

VersionLinkField Class
Sitecore.Data.Fields Namespace


RemoveLink Method

[image]

Sitecore 6.4.1 API
VersionLinkField..::..RemoveLink Method
VersionLinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void RemoveLink(
    ItemLink itemLink
)
Visual Basic
Public Overrides Sub RemoveLink ( _
    itemLink As ItemLink _
)
Visual C++
public:
virtual void RemoveLink(
    ItemLink^ itemLink
) override

Parameters

itemLink
Type: Sitecore.Links..::..ItemLink
The item link.

See Also

VersionLinkField Class
Sitecore.Data.Fields Namespace


ValidateLinks Method

[image]

Sitecore 6.4.1 API
VersionLinkField..::..ValidateLinks Method
VersionLinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void ValidateLinks(
    LinksValidationResult result
)
Visual Basic
Public Overrides Sub ValidateLinks ( _
    result As LinksValidationResult _
)
Visual C++
public:
virtual void ValidateLinks(
    LinksValidationResult^ result
) override

Parameters

result
Type: Sitecore.Links..::..LinksValidationResult
The result.

See Also

VersionLinkField Class
Sitecore.Data.Fields Namespace


VersionLinkField Properties

[image] [image]

Sitecore 6.4.1 API
VersionLinkField Properties
VersionLinkField Class See Also Send Feedback

The VersionLinkField type exposes the following members.

Properties

 | Name | Description
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | Uri | Gets or sets the URI.
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

VersionLinkField Class
Sitecore.Data.Fields Namespace


Uri Property

[image]

Sitecore 6.4.1 API
VersionLinkField..::..Uri Property
VersionLinkField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemUri Uri { get; set; }
Visual Basic
Public Property Uri As ItemUri
    Get
    Set
Visual C++
public:
property ItemUri^ Uri {
    ItemUri^ get ();
    void set (ItemUri^ value);
}

Field Value

The referred item URI.

See Also

VersionLinkField Class
Sitecore.Data.Fields Namespace


WebEditButton Class

[image]

Sitecore 6.4.1 API
WebEditButton Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class WebEditButton
Visual Basic
Public Class WebEditButton
Visual C++
public ref class WebEditButton

Remarks

Serialized as JSON.

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Fields..::..WebEditButton

See Also

WebEditButton Members
Sitecore.Data.Fields Namespace


WebEditButton Members

[image] [image]

Sitecore 6.4.1 API
WebEditButton Members
WebEditButton Class Constructors Methods Properties See Also Send Feedback

The WebEditButton type exposes the following members.

Constructors

 | Name | Description
Public method | WebEditButton | Initializes a new instance of the WebEditButton class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Click | Gets or sets the click.
Public property | Header | Gets or sets the header.
Public property | Icon | Gets or sets the icon.
Public property | IsDivider | Gets or sets a value indicating whether this WebEditButton is a divider.
Public property | Parameters | Gets the parameters.
Public property | Tooltip | Gets or sets the tooltip.
Public property | Type | Gets or sets the type.

See Also

WebEditButton Class
Sitecore.Data.Fields Namespace


WebEditButton Constructor

[image]

Sitecore 6.4.1 API
WebEditButton Constructor
WebEditButton Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WebEditButton()
Visual Basic
Public Sub New
Visual C++
public:
WebEditButton()

See Also

WebEditButton Class
Sitecore.Data.Fields Namespace


WebEditButton Methods

[image] [image]

Sitecore 6.4.1 API
WebEditButton Methods
WebEditButton Class See Also Send Feedback

The WebEditButton type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WebEditButton Class
Sitecore.Data.Fields Namespace


WebEditButton Properties

[image] [image]

Sitecore 6.4.1 API
WebEditButton Properties
WebEditButton Class See Also Send Feedback

The WebEditButton type exposes the following members.

Properties

 | Name | Description
Public property | Click | Gets or sets the click.
Public property | Header | Gets or sets the header.
Public property | Icon | Gets or sets the icon.
Public property | IsDivider | Gets or sets a value indicating whether this WebEditButton is a divider.
Public property | Parameters | Gets the parameters.
Public property | Tooltip | Gets or sets the tooltip.
Public property | Type | Gets or sets the type.

See Also

WebEditButton Class
Sitecore.Data.Fields Namespace


Click Property

[image]

Sitecore 6.4.1 API
WebEditButton..::..Click Property
WebEditButton Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Click { get; set; }
Visual Basic
Public Property Click As String
    Get
    Set
Visual C++
public:
property String^ Click {
    String^ get ();
    void set (String^ value);
}

Field Value

The click.

See Also

WebEditButton Class
Sitecore.Data.Fields Namespace


Header Property

[image]

Sitecore 6.4.1 API
WebEditButton..::..Header Property
WebEditButton Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Header { get; set; }
Visual Basic
Public Property Header As String
    Get
    Set
Visual C++
public:
property String^ Header {
    String^ get ();
    void set (String^ value);
}

Field Value

The header.

See Also

WebEditButton Class
Sitecore.Data.Fields Namespace


IsDivider Property

[image]

Sitecore 6.4.1 API
WebEditButton..::..IsDivider Property
WebEditButton Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsDivider { get; set; }
Visual Basic
Public Property IsDivider As Boolean
    Get
    Set
Visual C++
public:
property bool IsDivider {
    bool get ();
    void set (bool value);
}

Field Value

true if divider; otherwise, false.

See Also

WebEditButton Class
Sitecore.Data.Fields Namespace


Parameters Property

[image]

Sitecore 6.4.1 API
WebEditButton..::..Parameters Property
WebEditButton Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SafeDictionary<string> Parameters { get; internal set; }
Visual Basic
Public Property Parameters As SafeDictionary(Of String)
    Get
    Friend Set
Visual C++
public:
property SafeDictionary<String^>^ Parameters {
    SafeDictionary<String^>^ get ();
    internal: void set (SafeDictionary<String^>^ value);
}

Field Value

The parameters.

See Also

WebEditButton Class
Sitecore.Data.Fields Namespace


Tooltip Property

[image]

Sitecore 6.4.1 API
WebEditButton..::..Tooltip Property
WebEditButton Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Tooltip { get; set; }
Visual Basic
Public Property Tooltip As String
    Get
    Set
Visual C++
public:
property String^ Tooltip {
    String^ get ();
    void set (String^ value);
}

Field Value

The tooltip.

See Also

WebEditButton Class
Sitecore.Data.Fields Namespace


Type Property

[image]

Sitecore 6.4.1 API
WebEditButton..::..Type Property
WebEditButton Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Type { get; set; }
Visual Basic
Public Property Type As String
    Get
    Set
Visual C++
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}

Field Value

The type.

See Also

WebEditButton Class
Sitecore.Data.Fields Namespace


WordDocumentField Class

[image]

Sitecore 6.4.1 API
WordDocumentField Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class WordDocumentField : CustomField
Visual Basic
Public Class WordDocumentField _
    Inherits CustomField
Visual C++
public ref class WordDocumentField : public CustomField

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Fields..::..CustomField
Sitecore.Data.Fields..::..WordDocumentField

See Also

WordDocumentField Members
Sitecore.Data.Fields Namespace


WordDocumentField Constructor

[image]

Sitecore 6.4.1 API
WordDocumentField Constructor
WordDocumentField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WordDocumentField(
    Field innerField
)
Visual Basic
Public Sub New ( _
    innerField As Field _
)
Visual C++
public:
WordDocumentField(
    Field^ innerField
)

Parameters

innerField
Type: Sitecore.Data.Fields..::..Field
Inner field.

See Also

WordDocumentField Class
Sitecore.Data.Fields Namespace


WordDocumentField Fields

[image] [image]

Sitecore 6.4.1 API
WordDocumentField Fields
WordDocumentField Class See Also Send Feedback

The WordDocumentField type exposes the following members.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

See Also

WordDocumentField Class
Sitecore.Data.Fields Namespace


WordDocumentField Methods

[image] [image]

Sitecore 6.4.1 API
WordDocumentField Methods
WordDocumentField Class See Also Send Feedback

The WordDocumentField type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons | Gets the web edit buttons. (Overrides CustomField..::..GetWebEditButtons()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item. (Inherited from CustomField.)
Public method | RemoveLink | Removes the link. (Inherited from CustomField.)
Protected method | SetValue | Sets the value. (Inherited from CustomField.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Inherited from CustomField.)
Public method | ValidateLinks | Validates the links. (Overrides CustomField..::..ValidateLinks(LinksValidationResult).)

See Also

WordDocumentField Class
Sitecore.Data.Fields Namespace


GetWebEditButtons Method

[image]

Sitecore 6.4.1 API
WordDocumentField..::..GetWebEditButtons Method
WordDocumentField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override List<WebEditButton> GetWebEditButtons()
Visual Basic
Public Overrides Function GetWebEditButtons As List(Of WebEditButton)
Visual C++
public:
virtual List<WebEditButton^>^ GetWebEditButtons() override

Return Value

The web edit buttons.

See Also

WordDocumentField Class
Sitecore.Data.Fields Namespace


ValidateLinks Method

[image]

Sitecore 6.4.1 API
WordDocumentField..::..ValidateLinks Method
WordDocumentField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void ValidateLinks(
    LinksValidationResult result
)
Visual Basic
Public Overrides Sub ValidateLinks ( _
    result As LinksValidationResult _
)
Visual C++
public:
virtual void ValidateLinks(
    LinksValidationResult^ result
) override

Parameters

result
Type: Sitecore.Links..::..LinksValidationResult
The result.

See Also

WordDocumentField Class
Sitecore.Data.Fields Namespace


WordDocumentField Type Conversions

[image] [image]

Sitecore 6.4.1 API
WordDocumentField Type Conversions
WordDocumentField Class See Also Send Feedback

The WordDocumentField type exposes the following members.

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to WordDocumentField) | Converts a Field to a WordDocumentField.

See Also

WordDocumentField Class
Sitecore.Data.Fields Namespace


Implicit Conversion (Field to WordDocumentField)

[image]

Sitecore 6.4.1 API
WordDocumentField ImplicitWideningImplicitImplicitImplicit Conversion (Field to WordDocumentField)
WordDocumentField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator WordDocumentField (
    Field field
)
Visual Basic
Public Shared Widening Operator CType ( _
    field As Field _
) As WordDocumentField
Visual C++
static implicit operator WordDocumentField^ (
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.

Return Value

The implicit operator.

See Also

WordDocumentField Class
Sitecore.Data.Fields Namespace


WordDocumentField Properties

[image] [image]

Sitecore 6.4.1 API
WordDocumentField Properties
WordDocumentField Class See Also Send Feedback

The WordDocumentField type exposes the following members.

Properties

 | Name | Description
Public property | BlobId | Gets the BLOB id.
Public property | Html | Gets the HTML.
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | PlainText | Gets the plain text.
Public property | Styles | Gets the styles.
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)

See Also

WordDocumentField Class
Sitecore.Data.Fields Namespace


BlobId Property

[image]

Sitecore 6.4.1 API
WordDocumentField..::..BlobId Property
WordDocumentField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID BlobId { get; }
Visual Basic
Public ReadOnly Property BlobId As ID
    Get
Visual C++
public:
property ID^ BlobId {
    ID^ get ();
}

Field Value

The BLOB id.

See Also

WordDocumentField Class
Sitecore.Data.Fields Namespace


Html Property

[image]

Sitecore 6.4.1 API
WordDocumentField..::..Html Property
WordDocumentField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Html { get; }
Visual Basic
Public ReadOnly Property Html As String
    Get
Visual C++
public:
property String^ Html {
    String^ get ();
}

Field Value

The HTML.

See Also

WordDocumentField Class
Sitecore.Data.Fields Namespace


PlainText Property

[image]

Sitecore 6.4.1 API
WordDocumentField..::..PlainText Property
WordDocumentField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string PlainText { get; }
Visual Basic
Public ReadOnly Property PlainText As String
    Get
Visual C++
public:
property String^ PlainText {
    String^ get ();
}

Field Value

The plain text.

See Also

WordDocumentField Class
Sitecore.Data.Fields Namespace


Styles Property

[image]

Sitecore 6.4.1 API
WordDocumentField..::..Styles Property
WordDocumentField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Styles { get; }
Visual Basic
Public ReadOnly Property Styles As String
    Get
Visual C++
public:
property String^ Styles {
    String^ get ();
}

Field Value

The styles.

See Also

WordDocumentField Class
Sitecore.Data.Fields Namespace


XmlDeltas Class

[image]

Sitecore 6.4.1 API
XmlDeltas Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class XmlDeltas
Visual Basic
Public NotInheritable Class XmlDeltas
Visual C++
public ref class XmlDeltas abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Fields..::..XmlDeltas

See Also

XmlDeltas Members
Sitecore.Data.Fields Namespace


XmlDeltas Methods

[image] [image]

Sitecore 6.4.1 API
XmlDeltas Methods
XmlDeltas Class See Also Send Feedback

The XmlDeltas type exposes the following members.

Methods

Name | Description
ApplyDelta | Applies the delta to a base value.
GetDelta | Gets the delta for a specific layout field.
GetFieldValue | Gets the layout value, applying Layout Delta if necessary.
GetStandardValue | Gets the standard value for the specified field.
SetFieldValue | Sets the field value.
WithEmptyValue | Can be used together with GetFieldValue(Field, Func<(Of <<'(Field, String>)>>)) to provide a default implementation of getBaseValue parameter with a specific value to be used in place of empty field values.

See Also

XmlDeltas Class
Sitecore.Data.Fields Namespace


ApplyDelta Method

[image]

Sitecore 6.4.1 API
XmlDeltas..::..ApplyDelta Method
XmlDeltas Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ApplyDelta(
    string baseValue,
    string delta
)
Visual Basic
Public Shared Function ApplyDelta ( _
    baseValue As String, _
    delta As String _
) As String
Visual C++
public:
static String^ ApplyDelta(
    String^ baseValue,
    String^ delta
)

Parameters

baseValue
Type: System..::..String
The base value.
delta
Type: System..::..String
The delta value.

Return Value

The final XML markup.

See Also

XmlDeltas Class
Sitecore.Data.Fields Namespace


GetFieldValue Method

[image]

Sitecore 6.4.1 API
XmlDeltas..::..GetFieldValue Method
XmlDeltas Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetFieldValue(
    Field field,
    Func<Field, string> getBaseValue
)
Visual Basic
Public Shared Function GetFieldValue ( _
    field As Field, _
    getBaseValue As Func(Of Field, String) _
) As String
Visual C++
public:
static String^ GetFieldValue(
    Field^ field,
    Func<Field^, String^>^ getBaseValue
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field to get delta value for.
getBaseValue
Type: System..::..Func <(Of <(<' Field, String >)>)>
The function which will return a base value to calculate delta.

Return Value

The layout value.

See Also

XmlDeltas Class
Sitecore.Data.Fields Namespace


GetStandardValue Method

[image]

Sitecore 6.4.1 API
XmlDeltas..::..GetStandardValue Method
XmlDeltas Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetStandardValue(
    Field field
)
Visual Basic
Public Shared Function GetStandardValue ( _
    field As Field _
) As String
Visual C++
public:
static String^ GetStandardValue(
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field to return standard value for.

Return Value

The standard value for the field.

See Also

XmlDeltas Class
Sitecore.Data.Fields Namespace


SetFieldValue Method

[image]

Sitecore 6.4.1 API
XmlDeltas..::..SetFieldValue Method
XmlDeltas Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void SetFieldValue(
    Field field,
    string value
)
Visual Basic
Public Shared Sub SetFieldValue ( _
    field As Field, _
    value As String _
)
Visual C++
public:
static void SetFieldValue(
    Field^ field,
    String^ value
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.
value
Type: System..::..String
The value.

See Also

XmlDeltas Class
Sitecore.Data.Fields Namespace


WithEmptyValue Method

[image]

Sitecore 6.4.1 API
XmlDeltas..::..WithEmptyValue Method
XmlDeltas Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Func<Field, string> WithEmptyValue(
    string emptyValue
)
Visual Basic
Public Shared Function WithEmptyValue ( _
    emptyValue As String _
) As Func(Of Field, String)
Visual C++
public:
static Func<Field^, String^>^ WithEmptyValue(
    String^ emptyValue
)

Parameters

emptyValue
Type: System..::..String
The default XML markup of an empty value of the XML field.

Return Value

The function which will provide standard value or empty value for the field.

See Also

XmlDeltas Class
Sitecore.Data.Fields Namespace


XmlField Class

[image]

Sitecore 6.4.1 API
XmlField Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class XmlField : CustomField
Visual Basic
Public Class XmlField _
    Inherits CustomField
Visual C++
public ref class XmlField : public CustomField

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Fields..::..CustomField
Sitecore.Data.Fields..::..XmlField
Sitecore.Data.Fields..::..FileDropAreaField
Sitecore.Data.Fields..::..FileField
Sitecore.Data.Fields..::..ImageField
Sitecore.Data.Fields..::..LinkField

See Also

XmlField Members
Sitecore.Data.Fields Namespace


XmlField Members

[image] [image]

Sitecore 6.4.1 API
XmlField Members
XmlField Class Constructors Methods Operators Fields Properties See Also Send Feedback

The XmlField type exposes the following members.

Constructors

 | Name | Description
Public method | XmlField(Field, String) | Creates a new XmlField instance.
Public method | XmlField(Field, String, String) | Initializes a new instance of the XmlField class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttribute | Gets the attribute.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item. (Inherited from CustomField.)
Public method | RemoveLink | Removes the link. (Inherited from CustomField.)
Public method | SetAttribute | Sets the attribute.
Protected method | SetValue | Sets the value. (Overrides CustomField..::..SetValue(String).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Inherited from CustomField.)
Public method | ValidateLinks | Validates the links. (Inherited from CustomField.)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to XmlField) | Converts a Field to a XmlField.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

Properties

 | Name | Description
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | Root | Gets or sets the root tag.
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)
Public property | Xml | Gets the XML document contained in this field value.

See Also

XmlField Class
Sitecore.Data.Fields Namespace


XmlField Constructor

[image] [image]

Sitecore 6.4.1 API
XmlField Constructor
XmlField Class See Also Send Feedback

Overload List

 | Name | Description
Public method | XmlField(Field, String) | Creates a new XmlField instance.
Public method | XmlField(Field, String, String) | Initializes a new instance of the XmlField class.

See Also

XmlField Class
XmlField Members
Sitecore.Data.Fields Namespace


XmlField Constructor (Field, String)

[image]

Sitecore 6.4.1 API
XmlField Constructor (Field, String)
XmlField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public XmlField(
    Field innerField,
    string root
)
Visual Basic
Public Sub New ( _
    innerField As Field, _
    root As String _
)
Visual C++
public:
XmlField(
    Field^ innerField,
    String^ root
)

Parameters

innerField
Type: Sitecore.Data.Fields..::..Field
Inner field.
root
Type: System..::..String
Root tag.

See Also

XmlField Class
XmlField Overload
Sitecore.Data.Fields Namespace


XmlField Constructor (Field, String, String)

[image]

Sitecore 6.4.1 API
XmlField Constructor (Field, String, String)
XmlField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public XmlField(
    Field innerField,
    string root,
    string runtimeValue
)
Visual Basic
Public Sub New ( _
    innerField As Field, _
    root As String, _
    runtimeValue As String _
)
Visual C++
public:
XmlField(
    Field^ innerField,
    String^ root,
    String^ runtimeValue
)

Parameters

innerField
Type: Sitecore.Data.Fields..::..Field
The inner field.
root
Type: System..::..String
The root.
runtimeValue
Type: System..::..String
The runtime value.

See Also

XmlField Class
XmlField Overload
Sitecore.Data.Fields Namespace


XmlField Fields

[image] [image]

Sitecore 6.4.1 API
XmlField Fields
XmlField Class See Also Send Feedback

The XmlField type exposes the following members.

Fields

 | Name | Description
Protected field | _hasRuntimeValue | Marks the field as containing a custom runtime value instead of modifying the field. (Inherited from CustomField.)
Protected field | _innerField | Reference to the field being wrapped. (Inherited from CustomField.)
Protected field | _runtimeValue | Runtime value when it is defined. (Inherited from CustomField.)

See Also

XmlField Class
Sitecore.Data.Fields Namespace


XmlField Methods

[image] [image]

Sitecore 6.4.1 API
XmlField Methods
XmlField Class See Also Send Feedback

The XmlField type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttribute | Gets the attribute.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from CustomField.)
Public method | GetWebEditButtons()()()() | Gets the web edit buttons. (Inherited from CustomField.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Relink | Relinks the specified item. (Inherited from CustomField.)
Public method | RemoveLink | Removes the link. (Inherited from CustomField.)
Public method | SetAttribute | Sets the attribute.
Protected method | SetValue | Sets the value. (Overrides CustomField..::..SetValue(String).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLink | Updates the link. (Inherited from CustomField.)
Public method | ValidateLinks | Validates the links. (Inherited from CustomField.)

See Also

XmlField Class
Sitecore.Data.Fields Namespace


GetAttribute Method

[image]

Sitecore 6.4.1 API
XmlField..::..GetAttribute Method
XmlField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetAttribute(
    string name
)
Visual Basic
Public Function GetAttribute ( _
    name As String _
) As String
Visual C++
public:
String^ GetAttribute(
    String^ name
)

Parameters

name
Type: System..::..String
Name.

Return Value

The attribute.

See Also

XmlField Class
Sitecore.Data.Fields Namespace


SetAttribute Method

[image]

Sitecore 6.4.1 API
XmlField..::..SetAttribute Method
XmlField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetAttribute(
    string name,
    string value
)
Visual Basic
Public Sub SetAttribute ( _
    name As String, _
    value As String _
)
Visual C++
public:
void SetAttribute(
    String^ name,
    String^ value
)

Parameters

name
Type: System..::..String
Name.
value
Type: System..::..String
Value.

See Also

XmlField Class
Sitecore.Data.Fields Namespace


SetValue Method

[image]

Sitecore 6.4.1 API
XmlField..::..SetValue Method
XmlField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void SetValue(
    string value
)
Visual Basic
Protected Overrides Sub SetValue ( _
    value As String _
)
Visual C++
protected:
virtual void SetValue(
    String^ value
) override

Parameters

value
Type: System..::..String
The value.

See Also

XmlField Class
Sitecore.Data.Fields Namespace


XmlField Type Conversions

[image] [image]

Sitecore 6.4.1 API
XmlField Type Conversions
XmlField Class See Also Send Feedback

The XmlField type exposes the following members.

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Field to XmlField) | Converts a Field to a XmlField.

See Also

XmlField Class
Sitecore.Data.Fields Namespace


Implicit Conversion (Field to XmlField)

[image]

Sitecore 6.4.1 API
XmlField ImplicitWideningImplicitImplicitImplicit Conversion (Field to XmlField)
XmlField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator XmlField (
    Field field
)
Visual Basic
Public Shared Widening Operator CType ( _
    field As Field _
) As XmlField
Visual C++
static implicit operator XmlField^ (
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.

Return Value

The implicit operator.

See Also

XmlField Class
Sitecore.Data.Fields Namespace


XmlField Properties

[image] [image]

Sitecore 6.4.1 API
XmlField Properties
XmlField Class See Also Send Feedback

The XmlField type exposes the following members.

Properties

 | Name | Description
Public property | InnerField | Gets the inner field. (Inherited from CustomField.)
Public property | Root | Gets or sets the root tag.
Public property | Value | Gets or sets the field value. (Inherited from CustomField.)
Public property | Xml | Gets the XML document contained in this field value.

See Also

XmlField Class
Sitecore.Data.Fields Namespace


Root Property

[image]

Sitecore 6.4.1 API
XmlField..::..Root Property
XmlField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Root { get; set; }
Visual Basic
Public Property Root As String
    Get
    Set
Visual C++
public:
property String^ Root {
    String^ get ();
    void set (String^ value);
}

Field Value

The root.

See Also

XmlField Class
Sitecore.Data.Fields Namespace


Xml Property

[image]

Sitecore 6.4.1 API
XmlField..::..Xml Property
XmlField Class See Also Send Feedback

Namespace: Sitecore.Data.Fields
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public XmlDocument Xml { get; }
Visual Basic
Public ReadOnly Property Xml As XmlDocument
    Get
Visual C++
public:
property XmlDocument^ Xml {
    XmlDocument^ get ();
}

Field Value

The XML.

See Also

XmlField Class
Sitecore.Data.Fields Namespace


Sitecore.Data.IDTables Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Data.IDTables Namespace
Send Feedback

Classes

 | Class | Description
Public class | IDTable | Represents a table of IDs.
Public class | IDTableEntry | Represents an entrey in the ID table.
Public class | IDTableProvider | Defines the basic properties and methods of an ID table provider.


IDTable Class

[image]

Sitecore 6.4.1 API
IDTable Class
Members See Also Send Feedback

Namespace: Sitecore.Data.IDTables
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public sealed class IDTable
Visual Basic
Public NotInheritable Class IDTable
Visual C++
public ref class IDTable sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Data.IDTables..::..IDTable

See Also

IDTable Members
Sitecore.Data.IDTables Namespace


IDTable Members

[image] [image]

Sitecore 6.4.1 API
IDTable Members
IDTable Class Methods See Also Send Feedback

The IDTable type exposes the following members.

Methods

 | Name | Description
 | Add(String, String, ID) | Adds the specified ID.
 | Add(String, String, ID, ID) | Adds the specified ID.
 | Add(String, String, ID, ID, String) | Adds the specified ID.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID | Gets the ID.
 | GetKeys(String) | The list of IDTable entries.
 | GetKeys(String, ID) | Gets the keys.
 | GetNewID(String, String) | Gets the new ID.
 | GetNewID(String, String, ID) | Gets the new ID.
 | GetNewID(String, String, ID, String) | Gets the new ID.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RemoveID | Removes the ID.
 | RemoveKey | Removes the key.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IDTable Class
Sitecore.Data.IDTables Namespace


IDTable Methods

[image] [image]

Sitecore 6.4.1 API
IDTable Methods
IDTable Class See Also Send Feedback

The IDTable type exposes the following members.

Methods

 | Name | Description
 | Add(String, String, ID) | Adds the specified ID.
 | Add(String, String, ID, ID) | Adds the specified ID.
 | Add(String, String, ID, ID, String) | Adds the specified ID.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID | Gets the ID.
 | GetKeys(String) | The list of IDTable entries.
 | GetKeys(String, ID) | Gets the keys.
 | GetNewID(String, String) | Gets the new ID.
 | GetNewID(String, String, ID) | Gets the new ID.
 | GetNewID(String, String, ID, String) | Gets the new ID.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RemoveID | Removes the ID.
 | RemoveKey | Removes the key.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IDTable Class
Sitecore.Data.IDTables Namespace


Add Method

[image] [image]

Sitecore 6.4.1 API
IDTable..::..Add Method
IDTable Class See Also Send Feedback

Overload List

Name | Description
Add(String, String, ID) | Adds the specified ID.
Add(String, String, ID, ID) | Adds the specified ID.
Add(String, String, ID, ID, String) | Adds the specified ID.

See Also

IDTable Class
IDTable Members
Sitecore.Data.IDTables Namespace


Add Method (String, String, ID)

[image]

Sitecore 6.4.1 API
IDTable..::..Add Method (String, String, ID)
IDTable Class See Also Send Feedback

Namespace: Sitecore.Data.IDTables
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static IDTableEntry Add(
    string prefix,
    string key,
    ID id
)
Visual Basic
Public Shared Function Add ( _
    prefix As String, _
    key As String, _
    id As ID _
) As IDTableEntry
Visual C++
public:
static IDTableEntry^ Add(
    String^ prefix,
    String^ key,
    ID^ id
)

Parameters

prefix
Type: System..::..String
The prefix.
key
Type: System..::..String
The entry key.
id
Type: Sitecore.Data..::..ID
The entry id.

Return Value

The added IDtable entry.

See Also

IDTable Class
Add Overload
Sitecore.Data.IDTables Namespace


Add Method (String, String, ID, ID)

[image]

Sitecore 6.4.1 API
IDTable..::..Add Method (String, String, ID, ID)
IDTable Class See Also Send Feedback

Namespace: Sitecore.Data.IDTables
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static IDTableEntry Add(
    string prefix,
    string key,
    ID id,
    ID parentID
)
Visual Basic
Public Shared Function Add ( _
    prefix As String, _
    key As String, _
    id As ID, _
    parentID As ID _
) As IDTableEntry
Visual C++
public:
static IDTableEntry^ Add(
    String^ prefix,
    String^ key,
    ID^ id,
    ID^ parentID
)

Parameters

prefix
Type: System..::..String
The prefix.
key
Type: System..::..String
The entry key.
id
Type: Sitecore.Data..::..ID
The entry id.
parentID
Type: Sitecore.Data..::..ID
The parent ID.

Return Value

The added IDTtable entry.

See Also

IDTable Class
Add Overload
Sitecore.Data.IDTables Namespace


Add Method (String, String, ID, ID, String)

[image]

Sitecore 6.4.1 API
IDTable..::..Add Method (String, String, ID, ID, String)
IDTable Class See Also Send Feedback

Namespace: Sitecore.Data.IDTables
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static IDTableEntry Add(
    string prefix,
    string key,
    ID id,
    ID parentID,
    string customData
)
Visual Basic
Public Shared Function Add ( _
    prefix As String, _
    key As String, _
    id As ID, _
    parentID As ID, _
    customData As String _
) As IDTableEntry
Visual C++
public:
static IDTableEntry^ Add(
    String^ prefix,
    String^ key,
    ID^ id,
    ID^ parentID,
    String^ customData
)

Parameters

prefix
Type: System..::..String
The prefix.
key
Type: System..::..String
The entry key.
id
Type: Sitecore.Data..::..ID
The entry id.
parentID
Type: Sitecore.Data..::..ID
The parent ID.
customData
Type: System..::..String
The custom data.

Return Value

The added IDTable entry.

See Also

IDTable Class
Add Overload
Sitecore.Data.IDTables Namespace


GetID Method

[image]

Sitecore 6.4.1 API
IDTable..::..GetID Method
IDTable Class See Also Send Feedback

Namespace: Sitecore.Data.IDTables
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static IDTableEntry GetID(
    string prefix,
    string key
)
Visual Basic
Public Shared Function GetID ( _
    prefix As String, _
    key As String _
) As IDTableEntry
Visual C++
public:
static IDTableEntry^ GetID(
    String^ prefix,
    String^ key
)

Parameters

prefix
Type: System..::..String
The prefix.
key
Type: System..::..String
The entry key.

Return Value

The entry ID.

See Also

IDTable Class
Sitecore.Data.IDTables Namespace


GetKeys Method

[image] [image]

Sitecore 6.4.1 API
IDTable..::..GetKeys Method
IDTable Class See Also Send Feedback

Overload List

Name | Description
GetKeys(String) | The list of IDTable entries.
GetKeys(String, ID) | Gets the keys.

See Also

IDTable Class
IDTable Members
Sitecore.Data.IDTables Namespace


GetKeys Method (String, ID)

[image]

Sitecore 6.4.1 API
IDTable..::..GetKeys Method (String, ID)
IDTable Class See Also Send Feedback

Namespace: Sitecore.Data.IDTables
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static IDTableEntry[] GetKeys(
    string prefix,
    ID id
)
Visual Basic
Public Shared Function GetKeys ( _
    prefix As String, _
    id As ID _
) As IDTableEntry()
Visual C++
public:
static array<IDTableEntry^>^ GetKeys(
    String^ prefix,
    ID^ id
)

Parameters

prefix
Type: System..::..String
The prefix.
id
Type: Sitecore.Data..::..ID
The entry id.

Return Value

The IDTable entry keys.

See Also

IDTable Class
GetKeys Overload
Sitecore.Data.IDTables Namespace


GetNewID Method (String, String)

[image]

Sitecore 6.4.1 API
IDTable..::..GetNewID Method (String, String)
IDTable Class See Also Send Feedback

Namespace: Sitecore.Data.IDTables
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static IDTableEntry GetNewID(
    string prefix,
    string key
)
Visual Basic
Public Shared Function GetNewID ( _
    prefix As String, _
    key As String _
) As IDTableEntry
Visual C++
public:
static IDTableEntry^ GetNewID(
    String^ prefix,
    String^ key
)

Parameters

prefix
Type: System..::..String
The prefix.
key
Type: System..::..String
The entry key.

Return Value

The new ID.

See Also

IDTable Class
GetNewID Overload
Sitecore.Data.IDTables Namespace


GetNewID Method (String, String, ID)

[image]

Sitecore 6.4.1 API
IDTable..::..GetNewID Method (String, String, ID)
IDTable Class See Also Send Feedback

Namespace: Sitecore.Data.IDTables
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static IDTableEntry GetNewID(
    string prefix,
    string key,
    ID parentID
)
Visual Basic
Public Shared Function GetNewID ( _
    prefix As String, _
    key As String, _
    parentID As ID _
) As IDTableEntry
Visual C++
public:
static IDTableEntry^ GetNewID(
    String^ prefix,
    String^ key,
    ID^ parentID
)

Parameters

prefix
Type: System..::..String
The prefix.
key
Type: System..::..String
The entry key.
parentID
Type: Sitecore.Data..::..ID
The parent ID.

Return Value

The new ID.

See Also

IDTable Class
GetNewID Overload
Sitecore.Data.IDTables Namespace


GetNewID Method (String, String, ID, String)

[image]

Sitecore 6.4.1 API
IDTable..::..GetNewID Method (String, String, ID, String)
IDTable Class See Also Send Feedback

Namespace: Sitecore.Data.IDTables
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static IDTableEntry GetNewID(
    string prefix,
    string key,
    ID parentID,
    string customData
)
Visual Basic
Public Shared Function GetNewID ( _
    prefix As String, _
    key As String, _
    parentID As ID, _
    customData As String _
) As IDTableEntry
Visual C++
public:
static IDTableEntry^ GetNewID(
    String^ prefix,
    String^ key,
    ID^ parentID,
    String^ customData
)

Parameters

prefix
Type: System..::..String
The prefix.
key
Type: System..::..String
The entry key.
parentID
Type: Sitecore.Data..::..ID
The parent ID.
customData
Type: System..::..String
The custom data.

Return Value

The new ID.

See Also

IDTable Class
GetNewID Overload
Sitecore.Data.IDTables Namespace


RemoveID Method

[image]

Sitecore 6.4.1 API
IDTable..::..RemoveID Method
IDTable Class See Also Send Feedback

Namespace: Sitecore.Data.IDTables
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void RemoveID(
    string prefix,
    ID id
)
Visual Basic
Public Shared Sub RemoveID ( _
    prefix As String, _
    id As ID _
)
Visual C++
public:
static void RemoveID(
    String^ prefix,
    ID^ id
)

Parameters

prefix
Type: System..::..String
The prefix.
id
Type: Sitecore.Data..::..ID
The entry id.

See Also

IDTable Class
Sitecore.Data.IDTables Namespace


RemoveKey Method

[image]

Sitecore 6.4.1 API
IDTable..::..RemoveKey Method
IDTable Class See Also Send Feedback

Namespace: Sitecore.Data.IDTables
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void RemoveKey(
    string prefix,
    string key
)
Visual Basic
Public Shared Sub RemoveKey ( _
    prefix As String, _
    key As String _
)
Visual C++
public:
static void RemoveKey(
    String^ prefix,
    String^ key
)

Parameters

prefix
Type: System..::..String
The prefix.
key
Type: System..::..String
The entry key.

See Also

IDTable Class
Sitecore.Data.IDTables Namespace


IDTableEntry Class

[image]

Sitecore 6.4.1 API
IDTableEntry Class
Members See Also Send Feedback

Namespace: Sitecore.Data.IDTables
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class IDTableEntry : ICacheable
Visual Basic
Public Class IDTableEntry _
    Implements ICacheable
Visual C++
public ref class IDTableEntry : ICacheable

Inheritance Hierarchy

System..::..Object
Sitecore.Data.IDTables..::..IDTableEntry

See Also

IDTableEntry Members
Sitecore.Data.IDTables Namespace


IDTableEntry Members

[image] [image]

Sitecore 6.4.1 API
IDTableEntry Members
IDTableEntry Class Constructors Methods Properties See Also Send Feedback

The IDTableEntry type exposes the following members.

Constructors

 | Name | Description
Public method | IDTableEntry | Initializes a new instance of the IDTableEntry class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CustomData | Gets the custom data.
Public property | ID | Gets the ID.
Public property | Key | Gets the key.
Public property | ParentID | Gets the parent ID.
Public property | Prefix | Gets the prefix.

See Also

IDTableEntry Class
Sitecore.Data.IDTables Namespace


IDTableEntry Constructor

[image]

Sitecore 6.4.1 API
IDTableEntry Constructor
IDTableEntry Class See Also Send Feedback

Namespace: Sitecore.Data.IDTables
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IDTableEntry(
    string prefix,
    string key,
    ID id,
    ID parentID,
    string customData
)
Visual Basic
Public Sub New ( _
    prefix As String, _
    key As String, _
    id As ID, _
    parentID As ID, _
    customData As String _
)
Visual C++
public:
IDTableEntry(
    String^ prefix,
    String^ key,
    ID^ id,
    ID^ parentID,
    String^ customData
)

Parameters

prefix
Type: System..::..String
The prefix.
key
Type: System..::..String
The key.
id
Type: Sitecore.Data..::..ID
The id.
parentID
Type: Sitecore.Data..::..ID
The parent ID.
customData
Type: System..::..String
The custom data.

See Also

IDTableEntry Class
Sitecore.Data.IDTables Namespace


IDTableEntry Methods

[image] [image]

Sitecore 6.4.1 API
IDTableEntry Methods
IDTableEntry Class See Also Send Feedback

The IDTableEntry type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IDTableEntry Class
Sitecore.Data.IDTables Namespace


IDTableEntry Properties

[image] [image]

Sitecore 6.4.1 API
IDTableEntry Properties
IDTableEntry Class See Also Send Feedback

The IDTableEntry type exposes the following members.

Properties

 | Name | Description
Public property | CustomData | Gets the custom data.
Public property | ID | Gets the ID.
Public property | Key | Gets the key.
Public property | ParentID | Gets the parent ID.
Public property | Prefix | Gets the prefix.

See Also

IDTableEntry Class
Sitecore.Data.IDTables Namespace


CustomData Property

[image]

Sitecore 6.4.1 API
IDTableEntry..::..CustomData Property
IDTableEntry Class See Also Send Feedback

Namespace: Sitecore.Data.IDTables
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string CustomData { get; }
Visual Basic
Public ReadOnly Property CustomData As String
    Get
Visual C++
public:
property String^ CustomData {
    String^ get ();
}

Field Value

The custom data.

See Also

IDTableEntry Class
Sitecore.Data.IDTables Namespace


ID Property

[image]

Sitecore 6.4.1 API
IDTableEntry..::..ID Property
IDTableEntry Class See Also Send Feedback

Namespace: Sitecore.Data.IDTables
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ID { get; }
Visual Basic
Public ReadOnly Property ID As ID
    Get
Visual C++
public:
property ID^ ID {
    ID^ get ();
}

Field Value

The ID.

See Also

IDTableEntry Class
Sitecore.Data.IDTables Namespace


Key Property

[image]

Sitecore 6.4.1 API
IDTableEntry..::..Key Property
IDTableEntry Class See Also Send Feedback

Namespace: Sitecore.Data.IDTables
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Key { get; }
Visual Basic
Public ReadOnly Property Key As String
    Get
Visual C++
public:
property String^ Key {
    String^ get ();
}

Field Value

The key.

See Also

IDTableEntry Class
Sitecore.Data.IDTables Namespace


ParentID Property

[image]

Sitecore 6.4.1 API
IDTableEntry..::..ParentID Property
IDTableEntry Class See Also Send Feedback

Namespace: Sitecore.Data.IDTables
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ParentID { get; }
Visual Basic
Public ReadOnly Property ParentID As ID
    Get
Visual C++
public:
property ID^ ParentID {
    ID^ get ();
}

Field Value

The parent ID.

See Also

IDTableEntry Class
Sitecore.Data.IDTables Namespace


Prefix Property

[image]

Sitecore 6.4.1 API
IDTableEntry..::..Prefix Property
IDTableEntry Class See Also Send Feedback

Namespace: Sitecore.Data.IDTables
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Prefix { get; }
Visual Basic
Public ReadOnly Property Prefix As String
    Get
Visual C++
public:
property String^ Prefix {
    String^ get ();
}

Field Value

The prefix.

See Also

IDTableEntry Class
Sitecore.Data.IDTables Namespace


IDTableProvider Class

[image]

Sitecore 6.4.1 API
IDTableProvider Class
Members See Also Send Feedback

Namespace: Sitecore.Data.IDTables
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class IDTableProvider
Visual Basic
Public MustInherit Class IDTableProvider
Visual C++
public ref class IDTableProvider abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Data.IDTables..::..IDTableProvider
Sitecore.Data.SqlServer..::..SqlServerIDTable

See Also

IDTableProvider Members
Sitecore.Data.IDTables Namespace


IDTableProvider Constructor

[image]

Sitecore 6.4.1 API
IDTableProvider Constructor
IDTableProvider Class See Also Send Feedback

Namespace: Sitecore.Data.IDTables
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected IDTableProvider()
Visual Basic
Protected Sub New
Visual C++
protected:
IDTableProvider()

See Also

IDTableProvider Class
Sitecore.Data.IDTables Namespace


IDTableProvider Methods

[image] [image]

Sitecore 6.4.1 API
IDTableProvider Methods
IDTableProvider Class See Also Send Feedback

The IDTableProvider type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified entry.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetID | Gets the ID.
Public method | GetKeys(String) | The list of IDTable entries.
Public method | GetKeys(String, ID) | Gets the keys.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the specified prefix.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IDTableProvider Class
Sitecore.Data.IDTables Namespace


Add Method

[image]

Sitecore 6.4.1 API
IDTableProvider..::..Add Method
IDTableProvider Class See Also Send Feedback

Namespace: Sitecore.Data.IDTables
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract void Add(
    IDTableEntry entry
)
Visual Basic
Public MustOverride Sub Add ( _
    entry As IDTableEntry _
)
Visual C++
public:
virtual void Add(
    IDTableEntry^ entry
) abstract

Parameters

entry
Type: Sitecore.Data.IDTables..::..IDTableEntry
The entry.

See Also

IDTableProvider Class
Sitecore.Data.IDTables Namespace


GetID Method

[image]

Sitecore 6.4.1 API
IDTableProvider..::..GetID Method
IDTableProvider Class See Also Send Feedback

Namespace: Sitecore.Data.IDTables
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract IDTableEntry GetID(
    string prefix,
    string key
)
Visual Basic
Public MustOverride Function GetID ( _
    prefix As String, _
    key As String _
) As IDTableEntry
Visual C++
public:
virtual IDTableEntry^ GetID(
    String^ prefix,
    String^ key
) abstract

Parameters

prefix
Type: System..::..String
The prefix.
key
Type: System..::..String
The entry key.

Return Value

The entry ID.

See Also

IDTableProvider Class
Sitecore.Data.IDTables Namespace


GetKeys Method

[image] [image]

Sitecore 6.4.1 API
IDTableProvider..::..GetKeys Method
IDTableProvider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetKeys(String) | The list of IDTable entries.
Public method | GetKeys(String, ID) | Gets the keys.

See Also

IDTableProvider Class
IDTableProvider Members
Sitecore.Data.IDTables Namespace


GetKeys Method (String)

[image]

Sitecore 6.4.1 API
IDTableProvider..::..GetKeys Method (String)
IDTableProvider Class See Also Send Feedback

Namespace: Sitecore.Data.IDTables
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual IDTableEntry[] GetKeys(
    string prefix
)
Visual Basic
Public Overridable Function GetKeys ( _
    prefix As String _
) As IDTableEntry()
Visual C++
public:
virtual array<IDTableEntry^>^ GetKeys(
    String^ prefix
)

Parameters

prefix
Type: System..::..String
The prefix.

Return Value

The list of IDTable entries with specified prefix

See Also

IDTableProvider Class
GetKeys Overload
Sitecore.Data.IDTables Namespace


GetKeys Method (String, ID)

[image]

Sitecore 6.4.1 API
IDTableProvider..::..GetKeys Method (String, ID)
IDTableProvider Class See Also Send Feedback

Namespace: Sitecore.Data.IDTables
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract IDTableEntry[] GetKeys(
    string prefix,
    ID id
)
Visual Basic
Public MustOverride Function GetKeys ( _
    prefix As String, _
    id As ID _
) As IDTableEntry()
Visual C++
public:
virtual array<IDTableEntry^>^ GetKeys(
    String^ prefix,
    ID^ id
) abstract

Parameters

prefix
Type: System..::..String
The prefix.
id
Type: Sitecore.Data..::..ID
The entry id.

Return Value

The entry keys.

See Also

IDTableProvider Class
GetKeys Overload
Sitecore.Data.IDTables Namespace


Remove Method

[image]

Sitecore 6.4.1 API
IDTableProvider..::..Remove Method
IDTableProvider Class See Also Send Feedback

Namespace: Sitecore.Data.IDTables
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract void Remove(
    string prefix,
    string key
)
Visual Basic
Public MustOverride Sub Remove ( _
    prefix As String, _
    key As String _
)
Visual C++
public:
virtual void Remove(
    String^ prefix,
    String^ key
) abstract

Parameters

prefix
Type: System..::..String
The prefix.
key
Type: System..::..String
The entry key.

See Also

IDTableProvider Class
Sitecore.Data.IDTables Namespace


Sitecore.Data.Indexing Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Data.Indexing Namespace
Send Feedback

Classes

 | Class | Description
Public class | DataIndexes | Represents the indexes defined on a database
Public class | DebugFSDirectory | FSDirectory derivative with diagnostics capabilities
Public class | FSDirectory | A reimplementation of Lucene's FSDirectory fixing several bugs and increasing performance.
Public class | FSLock | Implements proper locking using files. The class itself is not thread-safe.
Public class | Index | Represents an index in a database.
Public class | Index..::..Criterion |
Public class | Index..::..IndexData |
Public class | IndexLocker | IDisposable holder for Lucene.NET Lock objects
Public class | ItemEventHandler | Implements an event handler for updating indexes.
Public class | LockScope | Implements nesting scopes for lucene (write) locks.

Enumerations

 | Enumeration | Description
Public enumeration | StorageType | Defines the Lucene storage types for a field.


DataIndexes Class

[image]

Sitecore 6.4.1 API
DataIndexes Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DataIndexes
Visual Basic
Public Class DataIndexes
Visual C++
public ref class DataIndexes

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Indexing..::..DataIndexes

See Also

DataIndexes Members
Sitecore.Data.Indexing Namespace


DataIndexes Constructor

[image]

Sitecore 6.4.1 API
DataIndexes Constructor
DataIndexes Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataIndexes()
Visual Basic
Public Sub New
Visual C++
public:
DataIndexes()

See Also

DataIndexes Class
Sitecore.Data.Indexing Namespace


DataIndexes Methods

[image] [image]

Sitecore 6.4.1 API
DataIndexes Methods
DataIndexes Class See Also Send Feedback

The DataIndexes type exposes the following members.

Methods

 | Name | Description
Public method | AddIndex | Adds an index.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveItem | Removes an item.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateItem | Updates an item.

See Also

DataIndexes Class
Sitecore.Data.Indexing Namespace


AddIndex Method

[image]

Sitecore 6.4.1 API
DataIndexes..::..AddIndex Method
DataIndexes Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddIndex(
    Index index
)
Visual Basic
Public Sub AddIndex ( _
    index As Index _
)
Visual C++
public:
void AddIndex(
    Index^ index
)

Parameters

index
Type: Sitecore.Data.Indexing..::..Index
Index.

See Also

DataIndexes Class
Sitecore.Data.Indexing Namespace


RemoveItem Method

[image]

Sitecore 6.4.1 API
DataIndexes..::..RemoveItem Method
DataIndexes Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RemoveItem(
    Item item,
    bool removeAllVersions
)
Visual Basic
Public Sub RemoveItem ( _
    item As Item, _
    removeAllVersions As Boolean _
)
Visual C++
public:
void RemoveItem(
    Item^ item,
    bool removeAllVersions
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
Item.
removeAllVersions
Type: System..::..Boolean
Remove all versions.

See Also

DataIndexes Class
Sitecore.Data.Indexing Namespace


UpdateItem Method

[image]

Sitecore 6.4.1 API
DataIndexes..::..UpdateItem Method
DataIndexes Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void UpdateItem(
    Item item
)
Visual Basic
Public Sub UpdateItem ( _
    item As Item _
)
Visual C++
public:
void UpdateItem(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
Item.

See Also

DataIndexes Class
Sitecore.Data.Indexing Namespace


DataIndexes Properties

[image] [image]

Sitecore 6.4.1 API
DataIndexes Properties
DataIndexes Class See Also Send Feedback

The DataIndexes type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of indexes.
Public property | Item[([( Int32])]) | Gets the Index at the specified index.
Public property | Item[([( String])]) | Gets the Index with the specified name.

See Also

DataIndexes Class
Sitecore.Data.Indexing Namespace


Count Property

[image]

Sitecore 6.4.1 API
DataIndexes..::..Count Property
DataIndexes Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
property int Count {
    int get ();
}

Field Value

The count.

See Also

DataIndexes Class
Sitecore.Data.Indexing Namespace


Item Property

[image] [image]

Sitecore 6.4.1 API
DataIndexes..::..Item Property
DataIndexes Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gets the Index at the specified index.
Public property | Item[([( String])]) | Gets the Index with the specified name.

See Also

DataIndexes Class
DataIndexes Members
Sitecore.Data.Indexing Namespace


Item Property (String)

[image]

Sitecore 6.4.1 API
DataIndexes..::..Item Property (String)
DataIndexes Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Index this[
    string name
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    name As String _
) As Index
    Get
Visual C++
public:
property Index^ default[String^ name] {
    Index^ get (String^ name);
}

Parameters

name
Type: System..::..String

See Also

DataIndexes Class
Item Overload
Sitecore.Data.Indexing Namespace


DebugFSDirectory Class

[image]

Sitecore 6.4.1 API
DebugFSDirectory Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DebugFSDirectory : FSDirectory
Visual Basic
Public Class DebugFSDirectory _
    Inherits FSDirectory
Visual C++
public ref class DebugFSDirectory : public FSDirectory

Inheritance Hierarchy

System..::..Object
Directory
FSDirectory
Sitecore.Data.Indexing..::..FSDirectory
Sitecore.Data.Indexing..::..DebugFSDirectory

See Also

DebugFSDirectory Members
Sitecore.Data.Indexing Namespace


DebugFSDirectory Members

[image] [image]

Sitecore 6.4.1 API
DebugFSDirectory Members
DebugFSDirectory Class Constructors Methods Fields See Also Send Feedback

The DebugFSDirectory type exposes the following members.

Constructors

 | Name | Description
Public method | DebugFSDirectory | Initializes a new instance of the DebugFSDirectory class

Methods

 | Name | Description
Public method | ClearLock | (Inherited from Directory.)
Public method | Close | (Inherited from FSDirectory.)
Public method | CreateOutput | Creates output stream for the specified file. (Overrides FSDirectory..::..CreateOutput(String).)
Protected method | Debug | Outputs debugging information. (Overrides FSDirectory..::..Debug(String, array<Object>[]()[][]).)
Public method | DeleteFile | (Inherited from FSDirectory.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FileExists | (Inherited from FSDirectory.)
Public method | FileLength | (Inherited from FSDirectory.)
Public method | FileModified | (Inherited from FSDirectory.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFile | (Inherited from FSDirectory.)
Protected method | GetFullLockName | Gets the full name of the lock. (Inherited from FSDirectory.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLockFactory | (Inherited from Directory.)
Public method | GetLockID | (Inherited from FSDirectory.)
Protected method | GetLockPrefix | Gets the lock prefix. (Inherited from FSDirectory.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | KeepsLock | Checks whether current thread keeps the given lock for this directory. (Inherited from FSDirectory.)
Public method | List | (Inherited from FSDirectory.)
Public method | MakeLock | Makes a lock of a given name. (Inherited from FSDirectory.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnRetryFailed | Called when the retry has failed. (Overrides FSDirectory..::..OnRetryFailed()()()().)
Public method | OpenInput(String) | Opens the input. (Overrides FSDirectory..::..OpenInput(String).)
Public method | OpenInput(String, Int32) | (Inherited from FSDirectory.)
Public method | ReleasePendingLocks | Releases locks of the given name that were obtained in the current thread. (Inherited from FSDirectory.)
Public method | RenameFile | (Inherited from FSDirectory.)
Protected method | Retry | Retries the specified callback. (Inherited from FSDirectory.)
Public method | SetLockFactory | (Inherited from Directory.)
Public method | ToString | (Inherited from FSDirectory.)
Public method | TouchFile | (Inherited from FSDirectory.)

Extension Methods

 | Name | Description
Public Extension Method | Exists | Check if directory exists on file system. (Defined by DirectoryExtension.)
Public Extension Method | GetPath | Returns path for existing FSDirectory. (Defined by DirectoryExtension.)

Fields

 | Name | Description
Protected field | lockFactory | (Inherited from Directory.)

See Also

DebugFSDirectory Class
Sitecore.Data.Indexing Namespace


DebugFSDirectory Constructor

[image]

Sitecore 6.4.1 API
DebugFSDirectory Constructor
DebugFSDirectory Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DebugFSDirectory()
Visual Basic
Public Sub New
Visual C++
public:
DebugFSDirectory()

See Also

DebugFSDirectory Class
Sitecore.Data.Indexing Namespace


DebugFSDirectory Fields

[image] [image]

Sitecore 6.4.1 API
DebugFSDirectory Fields
DebugFSDirectory Class See Also Send Feedback

The DebugFSDirectory type exposes the following members.

Fields

 | Name | Description
Protected field | lockFactory | (Inherited from Directory.)

See Also

DebugFSDirectory Class
Sitecore.Data.Indexing Namespace


CreateOutput Method

[image]

Sitecore 6.4.1 API
DebugFSDirectory..::..CreateOutput Method
DebugFSDirectory Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override IndexOutput CreateOutput(
    string name
)
Visual Basic
Public Overrides Function CreateOutput ( _
    name As String _
) As IndexOutput
Visual C++
public:
virtual IndexOutput^ CreateOutput(
    String^ name
) override

Parameters

name
Type: System..::..String
The name of the file.

Return Value

The output stream.

See Also

DebugFSDirectory Class
Sitecore.Data.Indexing Namespace


Debug Method

[image]

Sitecore 6.4.1 API
DebugFSDirectory..::..Debug Method
DebugFSDirectory Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void Debug(
    string format,
    params Object[] args
)
Visual Basic
Protected Overrides Sub Debug ( _
    format As String, _
    ParamArray args As Object() _
)
Visual C++
protected:
virtual void Debug(
    String^ format,
    ... array<Object^>^ args
) override

Parameters

format
Type: System..::..String
The format.
args
Type: array< System..::..Object >[]()[][]
The arguments.

See Also

DebugFSDirectory Class
Sitecore.Data.Indexing Namespace


OnRetryFailed Method

[image]

Sitecore 6.4.1 API
DebugFSDirectory..::..OnRetryFailed Method
DebugFSDirectory Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void OnRetryFailed()
Visual Basic
Protected Overrides Sub OnRetryFailed
Visual C++
protected:
virtual void OnRetryFailed() override

See Also

DebugFSDirectory Class
Sitecore.Data.Indexing Namespace


OpenInput Method

[image] [image]

Sitecore 6.4.1 API
DebugFSDirectory..::..OpenInput Method
DebugFSDirectory Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OpenInput(String) | Opens the input. (Overrides FSDirectory..::..OpenInput(String).)
Public method | OpenInput(String, Int32) | (Inherited from FSDirectory.)

See Also

DebugFSDirectory Class
DebugFSDirectory Members
Sitecore.Data.Indexing Namespace


OpenInput Method (String)

[image]

Sitecore 6.4.1 API
DebugFSDirectory..::..OpenInput Method (String)
DebugFSDirectory Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override IndexInput OpenInput(
    string name
)
Visual Basic
Public Overrides Function OpenInput ( _
    name As String _
) As IndexInput
Visual C++
public:
virtual IndexInput^ OpenInput(
    String^ name
) override

Parameters

name
Type: System..::..String
The name.

Return Value

The input.

See Also

DebugFSDirectory Class
OpenInput Overload
Sitecore.Data.Indexing Namespace


FSDirectory Class

[image]

Sitecore 6.4.1 API
FSDirectory Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FSDirectory : FSDirectory
Visual Basic
Public Class FSDirectory _
    Inherits FSDirectory
Visual C++
public ref class FSDirectory : public FSDirectory

Inheritance Hierarchy

System..::..Object
Directory
FSDirectory
Sitecore.Data.Indexing..::..FSDirectory
Sitecore.Data.Indexing..::..DebugFSDirectory

See Also

FSDirectory Members
Sitecore.Data.Indexing Namespace


FSDirectory Members

[image] [image]

Sitecore 6.4.1 API
FSDirectory Members
FSDirectory Class Constructors Methods Fields See Also Send Feedback

The FSDirectory type exposes the following members.

Constructors

 | Name | Description
Public method | FSDirectory | Initializes a new instance of the FSDirectory class

Methods

 | Name | Description
Public method | ClearLock | (Inherited from Directory.)
Public method | Close | (Inherited from FSDirectory.)
Public method | CreateOutput | Creates output stream for the specified file. (Overrides FSDirectoryCreateOutput(String).)
Protected method | Debug | Outputs debugging information.
Public method | DeleteFile | (Inherited from FSDirectory.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FileExists | (Inherited from FSDirectory.)
Public method | FileLength | (Inherited from FSDirectory.)
Public method | FileModified | (Inherited from FSDirectory.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFile | (Inherited from FSDirectory.)
Protected method | GetFullLockName | Gets the full name of the lock.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLockFactory | (Inherited from Directory.)
Public method | GetLockID | (Inherited from FSDirectory.)
Protected method | GetLockPrefix | Gets the lock prefix.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | KeepsLock | Checks whether current thread keeps the given lock for this directory.
Public method | List | (Inherited from FSDirectory.)
Public method | MakeLock | Makes a lock of a given name. (Overrides DirectoryMakeLock(String).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnRetryFailed | Called when the retry has failed.
Public method | OpenInput(String) | Opens the input. (Overrides FSDirectoryOpenInput(String).)
Public method | OpenInput(String, Int32) | (Inherited from FSDirectory.)
Public method | ReleasePendingLocks | Releases locks of the given name that were obtained in the current thread.
Public method | RenameFile | (Inherited from FSDirectory.)
Protected method | Retry | Retries the specified callback.
Public method | SetLockFactory | (Inherited from Directory.)
Public method | ToString | (Inherited from FSDirectory.)
Public method | TouchFile | (Inherited from FSDirectory.)

Extension Methods

 | Name | Description
Public Extension Method | Exists | Check if directory exists on file system. (Defined by DirectoryExtension.)
Public Extension Method | GetPath | Returns path for existing FSDirectory. (Defined by DirectoryExtension.)

Fields

 | Name | Description
Protected field | lockFactory | (Inherited from Directory.)
 | MaxRetries | Maximum number of times Sitecore will retry a file operation before reporting a failure.
 | RetryInterval | Sitecore will wait this number of milliseconds between tries.

See Also

FSDirectory Class
Sitecore.Data.Indexing Namespace


FSDirectory Constructor

[image]

Sitecore 6.4.1 API
FSDirectory Constructor
FSDirectory Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FSDirectory()
Visual Basic
Public Sub New
Visual C++
public:
FSDirectory()

See Also

FSDirectory Class
Sitecore.Data.Indexing Namespace


FSDirectory Fields

[image] [image]

Sitecore 6.4.1 API
FSDirectory Fields
FSDirectory Class See Also Send Feedback

The FSDirectory type exposes the following members.

Fields

 | Name | Description
Protected field | lockFactory | (Inherited from Directory.)
 | MaxRetries | Maximum number of times Sitecore will retry a file operation before reporting a failure.
 | RetryInterval | Sitecore will wait this number of milliseconds between tries.

See Also

FSDirectory Class
Sitecore.Data.Indexing Namespace


MaxRetries Field

[image]

Sitecore 6.4.1 API
FSDirectory..::..MaxRetries Field
FSDirectory Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int MaxRetries
Visual Basic
Public Shared MaxRetries As Integer
Visual C++
public:
static int MaxRetries

See Also

FSDirectory Class
Sitecore.Data.Indexing Namespace


RetryInterval Field

[image]

Sitecore 6.4.1 API
FSDirectory..::..RetryInterval Field
FSDirectory Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int RetryInterval
Visual Basic
Public Shared RetryInterval As Integer
Visual C++
public:
static int RetryInterval

See Also

FSDirectory Class
Sitecore.Data.Indexing Namespace


FSDirectory Methods

[image] [image]

Sitecore 6.4.1 API
FSDirectory Methods
FSDirectory Class See Also Send Feedback

The FSDirectory type exposes the following members.

Methods

 | Name | Description
Public method | ClearLock | (Inherited from Directory.)
Public method | Close | (Inherited from FSDirectory.)
Public method | CreateOutput | Creates output stream for the specified file. (Overrides FSDirectoryCreateOutput(String).)
Protected method | Debug | Outputs debugging information.
Public method | DeleteFile | (Inherited from FSDirectory.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FileExists | (Inherited from FSDirectory.)
Public method | FileLength | (Inherited from FSDirectory.)
Public method | FileModified | (Inherited from FSDirectory.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFile | (Inherited from FSDirectory.)
Protected method | GetFullLockName | Gets the full name of the lock.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLockFactory | (Inherited from Directory.)
Public method | GetLockID | (Inherited from FSDirectory.)
Protected method | GetLockPrefix | Gets the lock prefix.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | KeepsLock | Checks whether current thread keeps the given lock for this directory.
Public method | List | (Inherited from FSDirectory.)
Public method | MakeLock | Makes a lock of a given name. (Overrides DirectoryMakeLock(String).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnRetryFailed | Called when the retry has failed.
Public method | OpenInput(String) | Opens the input. (Overrides FSDirectoryOpenInput(String).)
Public method | OpenInput(String, Int32) | (Inherited from FSDirectory.)
Public method | ReleasePendingLocks | Releases locks of the given name that were obtained in the current thread.
Public method | RenameFile | (Inherited from FSDirectory.)
Protected method | Retry | Retries the specified callback.
Public method | SetLockFactory | (Inherited from Directory.)
Public method | ToString | (Inherited from FSDirectory.)
Public method | TouchFile | (Inherited from FSDirectory.)

Extension Methods

 | Name | Description
Public Extension Method | Exists | Check if directory exists on file system. (Defined by DirectoryExtension.)
Public Extension Method | GetPath | Returns path for existing FSDirectory. (Defined by DirectoryExtension.)

See Also

FSDirectory Class
Sitecore.Data.Indexing Namespace


CreateOutput Method

[image]

Sitecore 6.4.1 API
FSDirectory..::..CreateOutput Method
FSDirectory Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override IndexOutput CreateOutput(
    string name
)
Visual Basic
Public Overrides Function CreateOutput ( _
    name As String _
) As IndexOutput
Visual C++
public:
virtual IndexOutput^ CreateOutput(
    String^ name
) override

Parameters

name
Type: System..::..String
The name of the file.

Return Value

The output stream.

See Also

FSDirectory Class
Sitecore.Data.Indexing Namespace


GetFullLockName Method

[image]

Sitecore 6.4.1 API
FSDirectory..::..GetFullLockName Method
FSDirectory Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected string GetFullLockName(
    string name
)
Visual Basic
Protected Function GetFullLockName ( _
    name As String _
) As String
Visual C++
protected:
String^ GetFullLockName(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

Return Value

The full lock name.

See Also

FSDirectory Class
Sitecore.Data.Indexing Namespace


GetLockPrefix Method

[image]

Sitecore 6.4.1 API
FSDirectory..::..GetLockPrefix Method
FSDirectory Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual StringBuilder GetLockPrefix()
Visual Basic
Protected Overridable Function GetLockPrefix As StringBuilder
Visual C++
protected:
virtual StringBuilder^ GetLockPrefix()

Return Value

The lock prefix.

See Also

FSDirectory Class
Sitecore.Data.Indexing Namespace


KeepsLock Method

[image]

Sitecore 6.4.1 API
FSDirectory..::..KeepsLock Method
FSDirectory Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool KeepsLock(
    string lockName
)
Visual Basic
Public Function KeepsLock ( _
    lockName As String _
) As Boolean
Visual C++
public:
bool KeepsLock(
    String^ lockName
)

Parameters

lockName
Type: System..::..String
Name of the lock.

Return Value

The lock.

See Also

FSDirectory Class
Sitecore.Data.Indexing Namespace


MakeLock Method

[image]

Sitecore 6.4.1 API
FSDirectory..::..MakeLock Method
FSDirectory Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Lock MakeLock(
    string name
)
Visual Basic
Public Overrides Function MakeLock ( _
    name As String _
) As Lock
Visual C++
public:
virtual Lock^ MakeLock(
    String^ name
) override

Parameters

name
Type: System..::..String
The name.

Return Value

The lock.

See Also

FSDirectory Class
Sitecore.Data.Indexing Namespace


OnRetryFailed Method

[image]

Sitecore 6.4.1 API
FSDirectory..::..OnRetryFailed Method
FSDirectory Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void OnRetryFailed()
Visual Basic
Protected Overridable Sub OnRetryFailed
Visual C++
protected:
virtual void OnRetryFailed()

See Also

FSDirectory Class
Sitecore.Data.Indexing Namespace


OpenInput Method

[image] [image]

Sitecore 6.4.1 API
FSDirectory..::..OpenInput Method
FSDirectory Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OpenInput(String) | Opens the input. (Overrides FSDirectoryOpenInput(String).)
Public method | OpenInput(String, Int32) | (Inherited from FSDirectory.)

See Also

FSDirectory Class
FSDirectory Members
Sitecore.Data.Indexing Namespace


OpenInput Method (String)

[image]

Sitecore 6.4.1 API
FSDirectory..::..OpenInput Method (String)
FSDirectory Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override IndexInput OpenInput(
    string name
)
Visual Basic
Public Overrides Function OpenInput ( _
    name As String _
) As IndexInput
Visual C++
public:
virtual IndexInput^ OpenInput(
    String^ name
) override

Parameters

name
Type: System..::..String
The name.

Return Value

The input.

See Also

FSDirectory Class
OpenInput Overload
Sitecore.Data.Indexing Namespace


ReleasePendingLocks Method

[image]

Sitecore 6.4.1 API
FSDirectory..::..ReleasePendingLocks Method
FSDirectory Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void ReleasePendingLocks(
    string lockName
)
Visual Basic
Public Sub ReleasePendingLocks ( _
    lockName As String _
)
Visual C++
public:
void ReleasePendingLocks(
    String^ lockName
)

Parameters

lockName
Type: System..::..String
Name of the lock.

See Also

FSDirectory Class
Sitecore.Data.Indexing Namespace


Retry Method

[image]

Sitecore 6.4.1 API
FSDirectory..::..Retry Method
FSDirectory Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void Retry(
    ThreadStart callback
)
Visual Basic
Protected Sub Retry ( _
    callback As ThreadStart _
)
Visual C++
protected:
void Retry(
    ThreadStart^ callback
)

Parameters

callback
Type: System.Threading..::..ThreadStart
The callback.

Exceptions

Exception | Condition
System.IO..::..IOException | IOException.

See Also

FSDirectory Class
Sitecore.Data.Indexing Namespace


FSLock Class

[image]

Sitecore 6.4.1 API
FSLock Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FSLock : Lock, IDisposable
Visual Basic
Public Class FSLock _
    Inherits Lock _
    Implements IDisposable
Visual C++
public ref class FSLock : public Lock,
    IDisposable

Inheritance Hierarchy

System..::..Object
Lock
Sitecore.Data.Indexing..::..FSLock

See Also

FSLock Members
Sitecore.Data.Indexing Namespace


FSLock Members

[image] [image]

Sitecore 6.4.1 API
FSLock Members
FSLock Class Constructors Methods Fields Properties Events See Also Send Feedback

The FSLock type exposes the following members.

Constructors

 | Name | Description
Public method | FSLock | Initializes a new instance of the FSLock class.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the FSLock is reclaimed by garbage collection. (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsLocked | Determines whether this instance is locked. (Overrides LockIsLocked()()()().)
 | KeepsLock | Checks whether the current thread holds a particular lock.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Obtain()()()() | Obtains the lock for this instance. (Overrides LockObtain()()()().)
Public method | Obtain(Int64) | (Inherited from Lock.)
Public method | Release | Releases this instance. (Overrides LockRelease()()()().)
 | ReleasePendingLocks | Releases the pending locks.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Fields

 | Name | Description
Protected field | failureReason | (Inherited from Lock.)

Properties

 | Name | Description
Public property | Name | Gets the name of the lock.

Events

 | Name | Description
Public event | Obtained | Occurs right after the lock is obtained.
Public event | Released | Occurs right after the lock has been released.
Public event | Releasing | Occurs right before the lock gets released.

See Also

FSLock Class
Sitecore.Data.Indexing Namespace


FSLock Constructor

[image]

Sitecore 6.4.1 API
FSLock Constructor
FSLock Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FSLock(
    string filename
)
Visual Basic
Public Sub New ( _
    filename As String _
)
Visual C++
public:
FSLock(
    String^ filename
)

Parameters

filename
Type: System..::..String
The filename to lock.

See Also

FSLock Class
Sitecore.Data.Indexing Namespace


FSLock Fields

[image] [image]

Sitecore 6.4.1 API
FSLock Fields
FSLock Class See Also Send Feedback

The FSLock type exposes the following members.

Fields

 | Name | Description
Protected field | failureReason | (Inherited from Lock.)

See Also

FSLock Class
Sitecore.Data.Indexing Namespace


FSLock Methods

[image] [image]

Sitecore 6.4.1 API
FSLock Methods
FSLock Class See Also Send Feedback

The FSLock type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the FSLock is reclaimed by garbage collection. (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsLocked | Determines whether this instance is locked. (Overrides LockIsLocked()()()().)
 | KeepsLock | Checks whether the current thread holds a particular lock.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Obtain()()()() | Obtains the lock for this instance. (Overrides LockObtain()()()().)
Public method | Obtain(Int64) | (Inherited from Lock.)
Public method | Release | Releases this instance. (Overrides LockRelease()()()().)
 | ReleasePendingLocks | Releases the pending locks.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

FSLock Class
Sitecore.Data.Indexing Namespace


Finalize Method

[image]

Sitecore 6.4.1 API
FSLock..::..Finalize Method
FSLock Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

FSLock Class
Sitecore.Data.Indexing Namespace


IsLocked Method

[image]

Sitecore 6.4.1 API
FSLock..::..IsLocked Method
FSLock Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool IsLocked()
Visual Basic
Public Overrides Function IsLocked As Boolean
Visual C++
public:
virtual bool IsLocked() override

Return Value

true if this instance is locked; otherwise, false.

See Also

FSLock Class
Sitecore.Data.Indexing Namespace


KeepsLock Method

[image]

Sitecore 6.4.1 API
FSLock..::..KeepsLock Method
FSLock Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool KeepsLock(
    string filename
)
Visual Basic
Public Shared Function KeepsLock ( _
    filename As String _
) As Boolean
Visual C++
public:
static bool KeepsLock(
    String^ filename
)

Parameters

filename
Type: System..::..String
Name of the lock.

Return Value

The lock.

See Also

FSLock Class
Sitecore.Data.Indexing Namespace


Obtain Method

[image] [image]

Sitecore 6.4.1 API
FSLock..::..Obtain Method
FSLock Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Obtain()()()() | Obtains the lock for this instance. (Overrides LockObtain()()()().)
Public method | Obtain(Int64) | (Inherited from Lock.)

See Also

FSLock Class
FSLock Members
Sitecore.Data.Indexing Namespace


Obtain Method

[image]

Sitecore 6.4.1 API
FSLock..::..Obtain Method
FSLock Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool Obtain()
Visual Basic
Public Overrides Function Obtain As Boolean
Visual C++
public:
virtual bool Obtain() override

Return Value

The obtain.

See Also

FSLock Class
Obtain Overload
Sitecore.Data.Indexing Namespace


Release Method

[image]

Sitecore 6.4.1 API
FSLock..::..Release Method
FSLock Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Release()
Visual Basic
Public Overrides Sub Release
Visual C++
public:
virtual void Release() override

See Also

FSLock Class
Sitecore.Data.Indexing Namespace


ReleasePendingLocks Method

[image]

Sitecore 6.4.1 API
FSLock..::..ReleasePendingLocks Method
FSLock Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void ReleasePendingLocks(
    string filename
)
Visual Basic
Public Shared Sub ReleasePendingLocks ( _
    filename As String _
)
Visual C++
public:
static void ReleasePendingLocks(
    String^ filename
)

Parameters

filename
Type: System..::..String
The filename.

See Also

FSLock Class
Sitecore.Data.Indexing Namespace


ToString Method

[image]

Sitecore 6.4.1 API
FSLock..::..ToString Method
FSLock Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

FSLock Class
Sitecore.Data.Indexing Namespace


FSLock Properties

[image] [image]

Sitecore 6.4.1 API
FSLock Properties
FSLock Class See Also Send Feedback

The FSLock type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the name of the lock.

See Also

FSLock Class
Sitecore.Data.Indexing Namespace


Name Property

[image]

Sitecore 6.4.1 API
FSLock..::..Name Property
FSLock Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

FSLock Class
Sitecore.Data.Indexing Namespace


Obtained Event

[image]

Sitecore 6.4.1 API
FSLock..::..Obtained Event
FSLock Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler Obtained
Visual Basic
Public Event Obtained As EventHandler
Visual C++
public:
 event EventHandler^ Obtained {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

FSLock Class
Sitecore.Data.Indexing Namespace


Released Event

[image]

Sitecore 6.4.1 API
FSLock..::..Released Event
FSLock Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler Released
Visual Basic
Public Event Released As EventHandler
Visual C++
public:
 event EventHandler^ Released {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

FSLock Class
Sitecore.Data.Indexing Namespace


Releasing Event

[image]

Sitecore 6.4.1 API
FSLock..::..Releasing Event
FSLock Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler Releasing
Visual Basic
Public Event Releasing As EventHandler
Visual C++
public:
 event EventHandler^ Releasing {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

FSLock Class
Sitecore.Data.Indexing Namespace


Index Class

[image]

Sitecore 6.4.1 API
Index Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Index
Visual Basic
Public Class Index
Visual C++
public ref class Index

Remarks

Indexes are implemented using DotLucene.

Indexes are accessed through the Indexes property.

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Indexing..::..Index

See Also

Index Members
Sitecore.Data.Indexing Namespace


Index Members

[image] [image]

Sitecore 6.4.1 API
Index Members
Index Class Constructors Methods Fields Properties See Also Send Feedback

The Index type exposes the following members.

Constructors

 | Name | Description
Public method | Index | Creates a new Index instance.

Methods

 | Name | Description
Public method | AddField | Adds a field.
Protected method | AddFields | Adds the fields.
Protected method | AddIndexData | Adds the index data.
Public method | AddTemplate | Adds a template.
Protected method | CreateWriter | Creates the writer.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDocID(ID) | Gets a doc ID.
Public method | GetDocID(Item, Boolean) | Gets the doc ID.
Public method | GetDocID(ID, Language, Version) | Gets a doc ID.
Public method | GetDocumentCount | Gets the document count.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndexDirectory | Gets the file directory where the index is located.
 | GetItem | Gets an item.
Public method | GetSearcher | Gets a IndexSearcher object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetVersionsToIndex | Gets the versions to index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenReader | Opens a IndexReader.
Public method | OpenWriter | Opens a IndexWriter.
Public method | Rebuild | Rebuilds the index.
Public method | RebuildAsync | Rebuilds the index using a Job.
Public method | Reindex | Reindexes an item.
Public method | RemoveItem(ID, Database) | Removes an item.
Public method | RemoveItem(Item, Boolean) | Removes an item.
Public method | RemoveItem(ID, Language, Version, Database) | Removes a specific version of an item.
Public method | Reset | Resets the index.
Public method | Search | Searches the index.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateItem(Item) | Updates an item.
Protected method | UpdateItem(Item, Boolean, Boolean, IndexWriter) | Updates the item.
Protected method | UpdateVersion | Updates a single version.

Fields

Name | Description
ContentFieldName |
DocIDFieldName |
FieldIDFieldName |

Properties

 | Name | Description
Public property | Name | Gets the name of the index.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the Index.

See Also

Index Class
Sitecore.Data.Indexing Namespace


Index Constructor

[image]

Sitecore 6.4.1 API
Index Constructor
Index Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Index(
    string name
)
Visual Basic
Public Sub New ( _
    name As String _
)
Visual C++
public:
Index(
    String^ name
)

Parameters

name
Type: System..::..String
Name.

See Also

Index Class
Sitecore.Data.Indexing Namespace


Index Fields

[image] [image]

Sitecore 6.4.1 API
Index Fields
Index Class See Also Send Feedback

The Index type exposes the following members.

Fields

Name | Description
ContentFieldName |
DocIDFieldName |
FieldIDFieldName |

See Also

Index Class
Sitecore.Data.Indexing Namespace


ContentFieldName Field

[image]

Sitecore 6.4.1 API
Index..::..ContentFieldName Field
Index Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string ContentFieldName
Visual Basic
Public Const ContentFieldName As String
Visual C++
public:
literal String^ ContentFieldName

See Also

Index Class
Sitecore.Data.Indexing Namespace


FieldIDFieldName Field

[image]

Sitecore 6.4.1 API
Index..::..FieldIDFieldName Field
Index Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string FieldIDFieldName
Visual Basic
Public Const FieldIDFieldName As String
Visual C++
public:
literal String^ FieldIDFieldName

See Also

Index Class
Sitecore.Data.Indexing Namespace


Index Methods

[image] [image]

Sitecore 6.4.1 API
Index Methods
Index Class See Also Send Feedback

The Index type exposes the following members.

Methods

 | Name | Description
Public method | AddField | Adds a field.
Protected method | AddFields | Adds the fields.
Protected method | AddIndexData | Adds the index data.
Public method | AddTemplate | Adds a template.
Protected method | CreateWriter | Creates the writer.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDocID(ID) | Gets a doc ID.
Public method | GetDocID(Item, Boolean) | Gets the doc ID.
Public method | GetDocID(ID, Language, Version) | Gets a doc ID.
Public method | GetDocumentCount | Gets the document count.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndexDirectory | Gets the file directory where the index is located.
 | GetItem | Gets an item.
Public method | GetSearcher | Gets a IndexSearcher object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetVersionsToIndex | Gets the versions to index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenReader | Opens a IndexReader.
Public method | OpenWriter | Opens a IndexWriter.
Public method | Rebuild | Rebuilds the index.
Public method | RebuildAsync | Rebuilds the index using a Job.
Public method | Reindex | Reindexes an item.
Public method | RemoveItem(ID, Database) | Removes an item.
Public method | RemoveItem(Item, Boolean) | Removes an item.
Public method | RemoveItem(ID, Language, Version, Database) | Removes a specific version of an item.
Public method | Reset | Resets the index.
Public method | Search | Searches the index.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateItem(Item) | Updates an item.
Protected method | UpdateItem(Item, Boolean, Boolean, IndexWriter) | Updates the item.
Protected method | UpdateVersion | Updates a single version.

See Also

Index Class
Sitecore.Data.Indexing Namespace


AddField Method

[image]

Sitecore 6.4.1 API
Index..::..AddField Method
Index Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void AddField(
    XmlNode configNode
)
Visual Basic
Public Overridable Sub AddField ( _
    configNode As XmlNode _
)
Visual C++
public:
virtual void AddField(
    XmlNode^ configNode
)

Parameters

configNode
Type: System.Xml..::..XmlNode
Config node.

Exceptions

Exception | Condition
System..::..InvalidOperationException | InvalidOperationException.

See Also

Index Class
Sitecore.Data.Indexing Namespace


AddFields Method

[image]

Sitecore 6.4.1 API
Index..::..AddFields Method
Index Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void AddFields(
    Item item,
    Document document
)
Visual Basic
Protected Overridable Sub AddFields ( _
    item As Item, _
    document As Document _
)
Visual C++
protected:
virtual void AddFields(
    Item^ item,
    Document^ document
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
document
Type: Document
The document.

See Also

Index Class
Sitecore.Data.Indexing Namespace


AddIndexData Method

[image]

Sitecore 6.4.1 API
Index..::..AddIndexData Method
Index Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void AddIndexData(
    ArrayList indexData,
    Document document
)
Visual Basic
Protected Overridable Sub AddIndexData ( _
    indexData As ArrayList, _
    document As Document _
)
Visual C++
protected:
virtual void AddIndexData(
    ArrayList^ indexData,
    Document^ document
)

Parameters

indexData
Type: System.Collections..::..ArrayList
The index data.
document
Type: Document
The document.

See Also

Index Class
Sitecore.Data.Indexing Namespace


CreateWriter Method

[image]

Sitecore 6.4.1 API
Index..::..CreateWriter Method
Index Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual IndexWriter CreateWriter(
    Directory folder,
    bool forceCreate
)
Visual Basic
Protected Overridable Function CreateWriter ( _
    folder As Directory, _
    forceCreate As Boolean _
) As IndexWriter
Visual C++
protected:
virtual IndexWriter^ CreateWriter(
    Directory^ folder,
    bool forceCreate
)

Parameters

folder
Type: Directory
The folder.
forceCreate
Type: System..::..Boolean
if set to true this instance is force create.

Return Value

The writer.

See Also

Index Class
Sitecore.Data.Indexing Namespace


GetDocID Method

[image] [image]

Sitecore 6.4.1 API
Index..::..GetDocID Method
Index Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDocID(ID) | Gets a doc ID.
Public method | GetDocID(Item, Boolean) | Gets the doc ID.
Public method | GetDocID(ID, Language, Version) | Gets a doc ID.

See Also

Index Class
Index Members
Sitecore.Data.Indexing Namespace


GetDocID Method (ID)

[image]

Sitecore 6.4.1 API
Index..::..GetDocID Method (ID)
Index Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string GetDocID(
    ID itemId
)
Visual Basic
Public Overridable Function GetDocID ( _
    itemId As ID _
) As String
Visual C++
public:
virtual String^ GetDocID(
    ID^ itemId
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.

Return Value

The doc ID.

See Also

Index Class
GetDocID Overload
Sitecore.Data.Indexing Namespace


GetDocID Method (Item, Boolean)

[image]

Sitecore 6.4.1 API
Index..::..GetDocID Method (Item, Boolean)
Index Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string GetDocID(
    Item item,
    bool versionSpecific
)
Visual Basic
Public Overridable Function GetDocID ( _
    item As Item, _
    versionSpecific As Boolean _
) As String
Visual C++
public:
virtual String^ GetDocID(
    Item^ item,
    bool versionSpecific
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
Item.
versionSpecific
Type: System..::..Boolean
Version specific.

Return Value

The doc ID.

See Also

Index Class
GetDocID Overload
Sitecore.Data.Indexing Namespace


GetDocID Method (ID, Language, Version)

[image]

Sitecore 6.4.1 API
Index..::..GetDocID Method (ID, Language, Version)
Index Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string GetDocID(
    ID itemId,
    Language language,
    Version version
)
Visual Basic
Public Overridable Function GetDocID ( _
    itemId As ID, _
    language As Language, _
    version As Version _
) As String
Visual C++
public:
virtual String^ GetDocID(
    ID^ itemId,
    Language^ language,
    Version^ version
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
language
Type: Sitecore.Globalization..::..Language
The language.
version
Type: Sitecore.Data..::..Version
The version.

Return Value

The doc ID.

See Also

Index Class
GetDocID Overload
Sitecore.Data.Indexing Namespace


GetDocumentCount Method

[image]

Sitecore 6.4.1 API
Index..::..GetDocumentCount Method
Index Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual int GetDocumentCount(
    Database database
)
Visual Basic
Public Overridable Function GetDocumentCount ( _
    database As Database _
) As Integer
Visual C++
public:
virtual int GetDocumentCount(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
Database.

Return Value

The document count.

See Also

Index Class
Sitecore.Data.Indexing Namespace


GetIndexDirectory Method

[image]

Sitecore 6.4.1 API
Index..::..GetIndexDirectory Method
Index Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Directory GetIndexDirectory(
    Database database
)
Visual Basic
Public Overridable Function GetIndexDirectory ( _
    database As Database _
) As Directory
Visual C++
public:
virtual Directory^ GetIndexDirectory(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
Database.

Return Value

The index directory.

See Also

Index Class
Sitecore.Data.Indexing Namespace


GetItem Method

[image]

Sitecore 6.4.1 API
Index..::..GetItem Method
Index Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item GetItem(
    Document document,
    Database database
)
Visual Basic
Public Shared Function GetItem ( _
    document As Document, _
    database As Database _
) As Item
Visual C++
public:
static Item^ GetItem(
    Document^ document,
    Database^ database
)

Parameters

document
Type: Document
Document.
database
Type: Sitecore.Data..::..Database
Database.

Return Value

The item.

See Also

Index Class
Sitecore.Data.Indexing Namespace


GetSearcher Method

[image]

Sitecore 6.4.1 API
Index..::..GetSearcher Method
Index Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual IndexSearcher GetSearcher(
    Database database
)
Visual Basic
Public Overridable Function GetSearcher ( _
    database As Database _
) As IndexSearcher
Visual C++
public:
virtual IndexSearcher^ GetSearcher(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
Database.

Return Value

The searcher.

See Also

Index Class
Sitecore.Data.Indexing Namespace


GetVersionsToIndex Method

[image]

Sitecore 6.4.1 API
Index..::..GetVersionsToIndex Method
Index Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual Item[] GetVersionsToIndex(
    Item item,
    bool updateAllVersions
)
Visual Basic
Protected Overridable Function GetVersionsToIndex ( _
    item As Item, _
    updateAllVersions As Boolean _
) As Item()
Visual C++
protected:
virtual array<Item^>^ GetVersionsToIndex(
    Item^ item,
    bool updateAllVersions
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
updateAllVersions
Type: System..::..Boolean
if set to true [update all versions].

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Indexing.Index.GetVersionsToIndex(Sitecore.Data.Items.Item,System.Boolean)"]

See Also

Index Class
Sitecore.Data.Indexing Namespace


OpenReader Method

[image]

Sitecore 6.4.1 API
Index..::..OpenReader Method
Index Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual IndexReader OpenReader(
    Database database
)
Visual Basic
Public Overridable Function OpenReader ( _
    database As Database _
) As IndexReader
Visual C++
public:
virtual IndexReader^ OpenReader(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
Database.

Return Value

The reader.

See Also

Index Class
Sitecore.Data.Indexing Namespace


OpenWriter Method

[image]

Sitecore 6.4.1 API
Index..::..OpenWriter Method
Index Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual IndexWriter OpenWriter(
    Database database
)
Visual Basic
Public Overridable Function OpenWriter ( _
    database As Database _
) As IndexWriter
Visual C++
public:
virtual IndexWriter^ OpenWriter(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
Database.

Return Value

The writer.

See Also

Index Class
Sitecore.Data.Indexing Namespace


Rebuild Method

[image]

Sitecore 6.4.1 API
Index..::..Rebuild Method
Index Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Rebuild(
    Database database
)
Visual Basic
Public Overridable Sub Rebuild ( _
    database As Database _
)
Visual C++
public:
virtual void Rebuild(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
Database.

See Also

Index Class
Sitecore.Data.Indexing Namespace


RebuildAsync Method

[image]

Sitecore 6.4.1 API
Index..::..RebuildAsync Method
Index Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Job RebuildAsync(
    Database database
)
Visual Basic
Public Overridable Function RebuildAsync ( _
    database As Database _
) As Job
Visual C++
public:
virtual Job^ RebuildAsync(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
Database.

Return Value

The async.

See Also

Index Class
Sitecore.Data.Indexing Namespace


Reindex Method

[image]

Sitecore 6.4.1 API
Index..::..Reindex Method
Index Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Reindex(
    Item item,
    bool deep,
    bool removeOld
)
Visual Basic
Public Overridable Sub Reindex ( _
    item As Item, _
    deep As Boolean, _
    removeOld As Boolean _
)
Visual C++
public:
virtual void Reindex(
    Item^ item,
    bool deep,
    bool removeOld
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item to reindex.
deep
Type: System..::..Boolean
Include children?
removeOld
Type: System..::..Boolean
Remove old entries for the item before reindexing?

Remarks

All versions of the item will be reindexed.

See Also

Index Class
Sitecore.Data.Indexing Namespace


RemoveItem Method

[image] [image]

Sitecore 6.4.1 API
Index..::..RemoveItem Method
Index Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveItem(ID, Database) | Removes an item.
Public method | RemoveItem(Item, Boolean) | Removes an item.
Public method | RemoveItem(ID, Language, Version, Database) | Removes a specific version of an item.

See Also

Index Class
Index Members
Sitecore.Data.Indexing Namespace


RemoveItem Method (ID, Database)

[image]

Sitecore 6.4.1 API
Index..::..RemoveItem Method (ID, Database)
Index Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void RemoveItem(
    ID itemId,
    Database database
)
Visual Basic
Public Overridable Sub RemoveItem ( _
    itemId As ID, _
    database As Database _
)
Visual C++
public:
virtual void RemoveItem(
    ID^ itemId,
    Database^ database
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
database
Type: Sitecore.Data..::..Database
The database.

See Also

Index Class
RemoveItem Overload
Sitecore.Data.Indexing Namespace


RemoveItem Method (Item, Boolean)

[image]

Sitecore 6.4.1 API
Index..::..RemoveItem Method (Item, Boolean)
Index Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void RemoveItem(
    Item item,
    bool removeAllVersions
)
Visual Basic
Public Overridable Sub RemoveItem ( _
    item As Item, _
    removeAllVersions As Boolean _
)
Visual C++
public:
virtual void RemoveItem(
    Item^ item,
    bool removeAllVersions
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
Item.
removeAllVersions
Type: System..::..Boolean
Remove all versions.

See Also

Index Class
RemoveItem Overload
Sitecore.Data.Indexing Namespace


RemoveItem Method (ID, Language, Version, Database)

[image]

Sitecore 6.4.1 API
Index..::..RemoveItem Method (ID, Language, Version, Database)
Index Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void RemoveItem(
    ID itemId,
    Language language,
    Version version,
    Database database
)
Visual Basic
Public Overridable Sub RemoveItem ( _
    itemId As ID, _
    language As Language, _
    version As Version, _
    database As Database _
)
Visual C++
public:
virtual void RemoveItem(
    ID^ itemId,
    Language^ language,
    Version^ version,
    Database^ database
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
language
Type: Sitecore.Globalization..::..Language
The language.
version
Type: Sitecore.Data..::..Version
The version.
database
Type: Sitecore.Data..::..Database
The database.

See Also

Index Class
RemoveItem Overload
Sitecore.Data.Indexing Namespace


Search Method

[image]

Sitecore 6.4.1 API
Index..::..Search Method
Index Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Hits Search(
    string query,
    Database database
)
Visual Basic
Public Overridable Function Search ( _
    query As String, _
    database As Database _
) As Hits
Visual C++
public:
virtual Hits^ Search(
    String^ query,
    Database^ database
)

Parameters

query
Type: System..::..String
Query.
database
Type: Sitecore.Data..::..Database
Database.

Return Value

The search.

See Also

Index Class
Sitecore.Data.Indexing Namespace


UpdateItem Method

[image] [image]

Sitecore 6.4.1 API
Index..::..UpdateItem Method
Index Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UpdateItem(Item) | Updates an item.
Protected method | UpdateItem(Item, Boolean, Boolean, IndexWriter) | Updates the item.

See Also

Index Class
Index Members
Sitecore.Data.Indexing Namespace


UpdateItem Method (Item)

[image]

Sitecore 6.4.1 API
Index..::..UpdateItem Method (Item)
Index Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void UpdateItem(
    Item item
)
Visual Basic
Public Overridable Sub UpdateItem ( _
    item As Item _
)
Visual C++
public:
virtual void UpdateItem(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
Item.

See Also

Index Class
UpdateItem Overload
Sitecore.Data.Indexing Namespace


UpdateVersion Method

[image]

Sitecore 6.4.1 API
Index..::..UpdateVersion Method
Index Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void UpdateVersion(
    Item version,
    IndexWriter writer
)
Visual Basic
Protected Overridable Sub UpdateVersion ( _
    version As Item, _
    writer As IndexWriter _
)
Visual C++
protected:
virtual void UpdateVersion(
    Item^ version,
    IndexWriter^ writer
)

Parameters

version
Type: Sitecore.Data.Items..::..Item
The version.
writer
Type: IndexWriter
The writer.

See Also

Index Class
Sitecore.Data.Indexing Namespace


Index Properties

[image] [image]

Sitecore 6.4.1 API
Index Properties
Index Class See Also Send Feedback

The Index type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the name of the index.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the Index.

See Also

Index Class
Sitecore.Data.Indexing Namespace


Name Property

[image]

Sitecore 6.4.1 API
Index..::..Name Property
Index Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string Name { get; }
Visual Basic
Public Overridable ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

Index Class
Sitecore.Data.Indexing Namespace


SyncRoot Property

[image]

Sitecore 6.4.1 API
Index..::..SyncRoot Property
Index Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Object SyncRoot { get; }
Visual Basic
Public Overridable ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}

Field Value

The sync root.

See Also

Index Class
Sitecore.Data.Indexing Namespace


Index.Criterion Class

[image]

Sitecore 6.4.1 API
Index..::..Criterion Class
Index Class Members See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Criterion
Visual Basic
Public Class Criterion
Visual C++
public ref class Criterion

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Indexing..::..Index..::..Criterion

See Also

Index..::..Criterion Members
Sitecore.Data.Indexing Namespace


Index.Criterion Members

[image] [image]

Sitecore 6.4.1 API
Index..::..Criterion Members
Index..::..Criterion Class Constructors Methods Properties See Also Send Feedback

Represents an index in a database.

The Index..::..Criterion type exposes the following members.

Constructors

 | Name | Description
Public method | Index..::..Criterion | Initializes a new instance of the Index..::..Criterion class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndexData | Gets the index data.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseConfigNode | Parses the config node.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Exclude | Gets or sets a value indicating whether this Index..::..Criterion is exclude.
Public property | FieldID | Gets the field ID.
Public property | FieldName | Gets the name of the field.
Public property | FieldType | Gets the type of the field.
Public property | StorageType | Gets or sets the type of the storage.
Public property | StripTags | Gets or sets a value indicating whether the Index..::..Criterion strips the tags.
Public property | Target | Gets or sets the target.

See Also

Index..::..Criterion Class
Sitecore.Data.Indexing Namespace


Index.Criterion Constructor

[image]

Sitecore 6.4.1 API
Index..::..Criterion Constructor
Index..::..Criterion Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Criterion()
Visual Basic
Public Sub New
Visual C++
public:
Criterion()

See Also

Index..::..Criterion Class
Sitecore.Data.Indexing Namespace


Index.Criterion Methods

[image] [image]

Sitecore 6.4.1 API
Index..::..Criterion Methods
Index..::..Criterion Class See Also Send Feedback

The Index..::..Criterion type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndexData | Gets the index data.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseConfigNode | Parses the config node.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Index..::..Criterion Class
Sitecore.Data.Indexing Namespace


GetIndexData Method

[image]

Sitecore 6.4.1 API
Index..::..Criterion..::..GetIndexData Method
Index..::..Criterion Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Index..::..IndexData[] GetIndexData(
    Item item
)
Visual Basic
Public Function GetIndexData ( _
    item As Item _
) As Index..::..IndexData()
Visual C++
public:
array<Index..::..IndexData^>^ GetIndexData(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

The index data.

See Also

Index..::..Criterion Class
Sitecore.Data.Indexing Namespace


ParseConfigNode Method

[image]

Sitecore 6.4.1 API
Index..::..Criterion..::..ParseConfigNode Method
Index..::..Criterion Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Index..::..Criterion ParseConfigNode(
    XmlNode configNode
)
Visual Basic
Public Shared Function ParseConfigNode ( _
    configNode As XmlNode _
) As Index..::..Criterion
Visual C++
public:
static Index..::..Criterion^ ParseConfigNode(
    XmlNode^ configNode
)

Parameters

configNode
Type: System.Xml..::..XmlNode
The config node.

Return Value

The config node.

See Also

Index..::..Criterion Class
Sitecore.Data.Indexing Namespace


Index.Criterion Properties

[image] [image]

Sitecore 6.4.1 API
Index..::..Criterion Properties
Index..::..Criterion Class See Also Send Feedback

The Index..::..Criterion type exposes the following members.

Properties

 | Name | Description
Public property | Exclude | Gets or sets a value indicating whether this Index..::..Criterion is exclude.
Public property | FieldID | Gets the field ID.
Public property | FieldName | Gets the name of the field.
Public property | FieldType | Gets the type of the field.
Public property | StorageType | Gets or sets the type of the storage.
Public property | StripTags | Gets or sets a value indicating whether the Index..::..Criterion strips the tags.
Public property | Target | Gets or sets the target.

See Also

Index..::..Criterion Class
Sitecore.Data.Indexing Namespace


Exclude Property

[image]

Sitecore 6.4.1 API
Index..::..Criterion..::..Exclude Property
Index..::..Criterion Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Exclude { get; set; }
Visual Basic
Public Property Exclude As Boolean
    Get
    Set
Visual C++
public:
property bool Exclude {
    bool get ();
    void set (bool value);
}

Field Value

true if exclude; otherwise, false.

See Also

Index..::..Criterion Class
Sitecore.Data.Indexing Namespace


FieldID Property

[image]

Sitecore 6.4.1 API
Index..::..Criterion..::..FieldID Property
Index..::..Criterion Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID FieldID { get; }
Visual Basic
Public ReadOnly Property FieldID As ID
    Get
Visual C++
public:
property ID^ FieldID {
    ID^ get ();
}

Field Value

The field ID.

See Also

Index..::..Criterion Class
Sitecore.Data.Indexing Namespace


FieldName Property

[image]

Sitecore 6.4.1 API
Index..::..Criterion..::..FieldName Property
Index..::..Criterion Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string FieldName { get; }
Visual Basic
Public ReadOnly Property FieldName As String
    Get
Visual C++
public:
property String^ FieldName {
    String^ get ();
}

Field Value

The name of the field.

See Also

Index..::..Criterion Class
Sitecore.Data.Indexing Namespace


FieldType Property

[image]

Sitecore 6.4.1 API
Index..::..Criterion..::..FieldType Property
Index..::..Criterion Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string FieldType { get; }
Visual Basic
Public ReadOnly Property FieldType As String
    Get
Visual C++
public:
property String^ FieldType {
    String^ get ();
}

Field Value

The type of the field.

See Also

Index..::..Criterion Class
Sitecore.Data.Indexing Namespace


StorageType Property

[image]

Sitecore 6.4.1 API
Index..::..Criterion..::..StorageType Property
Index..::..Criterion Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StorageType StorageType { get; set; }
Visual Basic
Public Property StorageType As StorageType
    Get
    Set
Visual C++
public:
property StorageType StorageType {
    StorageType get ();
    void set (StorageType value);
}

Field Value

The type of the storage.

See Also

Index..::..Criterion Class
Sitecore.Data.Indexing Namespace


StripTags Property

[image]

Sitecore 6.4.1 API
Index..::..Criterion..::..StripTags Property
Index..::..Criterion Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool StripTags { get; set; }
Visual Basic
Public Property StripTags As Boolean
    Get
    Set
Visual C++
public:
property bool StripTags {
    bool get ();
    void set (bool value);
}

Field Value

true if the Index..::..Criterion strips the tags; otherwise, false.

See Also

Index..::..Criterion Class
Sitecore.Data.Indexing Namespace


Target Property

[image]

Sitecore 6.4.1 API
Index..::..Criterion..::..Target Property
Index..::..Criterion Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Target { get; set; }
Visual Basic
Public Property Target As String
    Get
    Set
Visual C++
public:
property String^ Target {
    String^ get ();
    void set (String^ value);
}

Field Value

The target.

See Also

Index..::..Criterion Class
Sitecore.Data.Indexing Namespace


Index.IndexData Class

[image]

Sitecore 6.4.1 API
Index..::..IndexData Class
Index Class Members See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class IndexData
Visual Basic
Public Class IndexData
Visual C++
public ref class IndexData

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Indexing..::..Index..::..IndexData

See Also

Index..::..IndexData Members
Sitecore.Data.Indexing Namespace


Index.IndexData Members

[image] [image]

Sitecore 6.4.1 API
Index..::..IndexData Members
Index..::..IndexData Class Constructors Methods Properties See Also Send Feedback

Represents an index in a database.

The Index..::..IndexData type exposes the following members.

Constructors

 | Name | Description
Public method | Index..::..IndexData(Index..::..Criterion) | Initializes a new instance of the Index..::..IndexData class.
Public method | Index..::..IndexData(Index..::..Criterion, Field) | Initializes a new instance of the Index..::..IndexData class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDate | Gets the date.
Public method | GetFieldID()()()() | Gets the field ID.
Public method | GetFieldID(Boolean) | Gets the field ID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValueField()()()() | Gets the value field.
Public method | GetValueField(Boolean) | Gets the value field.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Criterion | Gets the criterion.
Public property | DocumentField | Gets the document field.
Public property | Exclude | Gets a value indicating whether this Index..::..IndexData is exclude.
Public property | IndexFieldType | Gets the type of the index field.
Public property | IsDate | Gets a value indicating whether this instance is date.
Public property | Target | Gets or sets the target.
Public property | Value | Gets or sets the value.

See Also

Index..::..IndexData Class
Sitecore.Data.Indexing Namespace


Index.IndexData Constructor

[image] [image]

Sitecore 6.4.1 API
Index..::..IndexData Constructor
Index..::..IndexData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Index..::..IndexData(Index..::..Criterion) | Initializes a new instance of the Index..::..IndexData class.
Public method | Index..::..IndexData(Index..::..Criterion, Field) | Initializes a new instance of the Index..::..IndexData class.

See Also

Index..::..IndexData Class
Index..::..IndexData Members
Sitecore.Data.Indexing Namespace


Index.IndexData Constructor (Index.Criterion)

[image]

Sitecore 6.4.1 API
Index..::..IndexData Constructor (Index..::..Criterion)
Index..::..IndexData Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IndexData(
    Index..::..Criterion criterion
)
Visual Basic
Public Sub New ( _
    criterion As Index..::..Criterion _
)
Visual C++
public:
IndexData(
    Index..::..Criterion^ criterion
)

Parameters

criterion
Type: Sitecore.Data.Indexing..::..Index..::..Criterion
The criterion.

See Also

Index..::..IndexData Class
Index..::..IndexData Overload
Sitecore.Data.Indexing Namespace


Index.IndexData Methods

[image] [image]

Sitecore 6.4.1 API
Index..::..IndexData Methods
Index..::..IndexData Class See Also Send Feedback

The Index..::..IndexData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDate | Gets the date.
Public method | GetFieldID()()()() | Gets the field ID.
Public method | GetFieldID(Boolean) | Gets the field ID.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValueField()()()() | Gets the value field.
Public method | GetValueField(Boolean) | Gets the value field.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Index..::..IndexData Class
Sitecore.Data.Indexing Namespace


GetDate Method

[image]

Sitecore 6.4.1 API
Index..::..IndexData..::..GetDate Method
Index..::..IndexData Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime GetDate()
Visual Basic
Public Function GetDate As DateTime
Visual C++
public:
DateTime GetDate()

Return Value

The date.

See Also

Index..::..IndexData Class
Sitecore.Data.Indexing Namespace


GetFieldID Method

[image] [image]

Sitecore 6.4.1 API
Index..::..IndexData..::..GetFieldID Method
Index..::..IndexData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetFieldID()()()() | Gets the field ID.
Public method | GetFieldID(Boolean) | Gets the field ID.

See Also

Index..::..IndexData Class
Index..::..IndexData Members
Sitecore.Data.Indexing Namespace


GetFieldID Method

[image]

Sitecore 6.4.1 API
Index..::..IndexData..::..GetFieldID Method
Index..::..IndexData Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID GetFieldID()
Visual Basic
Public Function GetFieldID As ID
Visual C++
public:
ID^ GetFieldID()

Return Value

The field ID.

See Also

Index..::..IndexData Class
GetFieldID Overload
Sitecore.Data.Indexing Namespace


GetFieldID Method (Boolean)

[image]

Sitecore 6.4.1 API
Index..::..IndexData..::..GetFieldID Method (Boolean)
Index..::..IndexData Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID GetFieldID(
    bool ignoreTarget
)
Visual Basic
Public Function GetFieldID ( _
    ignoreTarget As Boolean _
) As ID
Visual C++
public:
ID^ GetFieldID(
    bool ignoreTarget
)

Parameters

ignoreTarget
Type: System..::..Boolean

[Missing <param name="ignoreTarget"/> documentation for "M:Sitecore.Data.Indexing.Index.IndexData.GetFieldID(System.Boolean)"]

Return Value

The field ID.

See Also

Index..::..IndexData Class
GetFieldID Overload
Sitecore.Data.Indexing Namespace


GetValueField Method

[image] [image]

Sitecore 6.4.1 API
Index..::..IndexData..::..GetValueField Method
Index..::..IndexData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValueField()()()() | Gets the value field.
Public method | GetValueField(Boolean) | Gets the value field.

See Also

Index..::..IndexData Class
Index..::..IndexData Members
Sitecore.Data.Indexing Namespace


GetValueField Method

[image]

Sitecore 6.4.1 API
Index..::..IndexData..::..GetValueField Method
Index..::..IndexData Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Field GetValueField()
Visual Basic
Public Function GetValueField As Field
Visual C++
public:
Field^ GetValueField()

Return Value

The value field.

See Also

Index..::..IndexData Class
GetValueField Overload
Sitecore.Data.Indexing Namespace


GetValueField Method (Boolean)

[image]

Sitecore 6.4.1 API
Index..::..IndexData..::..GetValueField Method (Boolean)
Index..::..IndexData Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Field GetValueField(
    bool ignoreTarget
)
Visual Basic
Public Function GetValueField ( _
    ignoreTarget As Boolean _
) As Field
Visual C++
public:
Field^ GetValueField(
    bool ignoreTarget
)

Parameters

ignoreTarget
Type: System..::..Boolean

[Missing <param name="ignoreTarget"/> documentation for "M:Sitecore.Data.Indexing.Index.IndexData.GetValueField(System.Boolean)"]

Return Value

The value field.

See Also

Index..::..IndexData Class
GetValueField Overload
Sitecore.Data.Indexing Namespace


Index.IndexData Properties

[image] [image]

Sitecore 6.4.1 API
Index..::..IndexData Properties
Index..::..IndexData Class See Also Send Feedback

The Index..::..IndexData type exposes the following members.

Properties

 | Name | Description
Public property | Criterion | Gets the criterion.
Public property | DocumentField | Gets the document field.
Public property | Exclude | Gets a value indicating whether this Index..::..IndexData is exclude.
Public property | IndexFieldType | Gets the type of the index field.
Public property | IsDate | Gets a value indicating whether this instance is date.
Public property | Target | Gets or sets the target.
Public property | Value | Gets or sets the value.

See Also

Index..::..IndexData Class
Sitecore.Data.Indexing Namespace


Criterion Property

[image]

Sitecore 6.4.1 API
Index..::..IndexData..::..Criterion Property
Index..::..IndexData Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Index..::..Criterion Criterion { get; }
Visual Basic
Public ReadOnly Property Criterion As Index..::..Criterion
    Get
Visual C++
public:
property Index..::..Criterion^ Criterion {
    Index..::..Criterion^ get ();
}

Field Value

The criterion.

See Also

Index..::..IndexData Class
Sitecore.Data.Indexing Namespace


DocumentField Property

[image]

Sitecore 6.4.1 API
Index..::..IndexData..::..DocumentField Property
Index..::..IndexData Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string DocumentField { get; }
Visual Basic
Public ReadOnly Property DocumentField As String
    Get
Visual C++
public:
property String^ DocumentField {
    String^ get ();
}

Field Value

The document field.

See Also

Index..::..IndexData Class
Sitecore.Data.Indexing Namespace


Exclude Property

[image]

Sitecore 6.4.1 API
Index..::..IndexData..::..Exclude Property
Index..::..IndexData Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Exclude { get; }
Visual Basic
Public ReadOnly Property Exclude As Boolean
    Get
Visual C++
public:
property bool Exclude {
    bool get ();
}

Field Value

true if exclude; otherwise, false.

See Also

Index..::..IndexData Class
Sitecore.Data.Indexing Namespace


IndexFieldType Property

[image]

Sitecore 6.4.1 API
Index..::..IndexData..::..IndexFieldType Property
Index..::..IndexData Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StorageType IndexFieldType { get; }
Visual Basic
Public ReadOnly Property IndexFieldType As StorageType
    Get
Visual C++
public:
property StorageType IndexFieldType {
    StorageType get ();
}

Field Value

The type of the index field.

See Also

Index..::..IndexData Class
Sitecore.Data.Indexing Namespace


IsDate Property

[image]

Sitecore 6.4.1 API
Index..::..IndexData..::..IsDate Property
Index..::..IndexData Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsDate { get; }
Visual Basic
Public ReadOnly Property IsDate As Boolean
    Get
Visual C++
public:
property bool IsDate {
    bool get ();
}

Field Value

true if this instance is date; otherwise, false.

See Also

Index..::..IndexData Class
Sitecore.Data.Indexing Namespace


Target Property

[image]

Sitecore 6.4.1 API
Index..::..IndexData..::..Target Property
Index..::..IndexData Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Target { get; set; }
Visual Basic
Public Property Target As String
    Get
    Set
Visual C++
public:
property String^ Target {
    String^ get ();
    void set (String^ value);
}

Field Value

The target.

See Also

Index..::..IndexData Class
Sitecore.Data.Indexing Namespace


Value Property

[image]

Sitecore 6.4.1 API
Index..::..IndexData..::..Value Property
Index..::..IndexData Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Field Value

The value.

See Also

Index..::..IndexData Class
Sitecore.Data.Indexing Namespace


IndexLocker Members

[image] [image]

Sitecore 6.4.1 API
IndexLocker Members
IndexLocker Class Constructors Methods See Also Send Feedback

The IndexLocker type exposes the following members.

Constructors

 | Name | Description
Public method | IndexLocker | Initializes a new instance of the IndexLocker class.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IndexLocker Class
Sitecore.Data.Indexing Namespace


IndexLocker Constructor

[image]

Sitecore 6.4.1 API
IndexLocker Constructor
IndexLocker Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IndexLocker(
    Lock instance
)
Visual Basic
Public Sub New ( _
    instance As Lock _
)
Visual C++
public:
IndexLocker(
    Lock^ instance
)

Parameters

instance
Type: Lock
The lock instance.

Exceptions

Exception | Condition
System..::..Exception | Could not obtain lock

See Also

IndexLocker Class
Sitecore.Data.Indexing Namespace


IndexLocker Methods

[image] [image]

Sitecore 6.4.1 API
IndexLocker Methods
IndexLocker Class See Also Send Feedback

The IndexLocker type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IndexLocker Class
Sitecore.Data.Indexing Namespace


Dispose Method

[image]

Sitecore 6.4.1 API
IndexLocker..::..Dispose Method
IndexLocker Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

IndexLocker Class
Sitecore.Data.Indexing Namespace


ItemEventHandler Class

[image]

Sitecore 6.4.1 API
ItemEventHandler Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemEventHandler
Visual Basic
Public Class ItemEventHandler
Visual C++
public ref class ItemEventHandler

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Indexing..::..ItemEventHandler

See Also

ItemEventHandler Members
Sitecore.Data.Indexing Namespace


ItemEventHandler Members

[image] [image]

Sitecore 6.4.1 API
ItemEventHandler Members
ItemEventHandler Class Constructors Methods See Also Send Feedback

The ItemEventHandler type exposes the following members.

Constructors

 | Name | Description
Public method | ItemEventHandler | Initializes a new instance of the ItemEventHandler class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnItemDeleted | Handles an ItemDeleted event.
Protected method | OnItemSaved | Handles an ItemSaved event.
Public method | Test | Tests the specified sender.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemEventHandler Class
Sitecore.Data.Indexing Namespace


ItemEventHandler Constructor

[image]

Sitecore 6.4.1 API
ItemEventHandler Constructor
ItemEventHandler Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemEventHandler()
Visual Basic
Public Sub New
Visual C++
public:
ItemEventHandler()

See Also

ItemEventHandler Class
Sitecore.Data.Indexing Namespace


OnItemDeleted Method

[image]

Sitecore 6.4.1 API
ItemEventHandler..::..OnItemDeleted Method
ItemEventHandler Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void OnItemDeleted(
    Object sender,
    EventArgs args
)
Visual Basic
Protected Sub OnItemDeleted ( _
    sender As Object, _
    args As EventArgs _
)
Visual C++
protected:
void OnItemDeleted(
    Object^ sender,
    EventArgs^ args
)

Parameters

sender
Type: System..::..Object
Sender.
args
Type: System..::..EventArgs
Args.

See Also

ItemEventHandler Class
Sitecore.Data.Indexing Namespace


OnItemSaved Method

[image]

Sitecore 6.4.1 API
ItemEventHandler..::..OnItemSaved Method
ItemEventHandler Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void OnItemSaved(
    Object sender,
    EventArgs args
)
Visual Basic
Protected Sub OnItemSaved ( _
    sender As Object, _
    args As EventArgs _
)
Visual C++
protected:
void OnItemSaved(
    Object^ sender,
    EventArgs^ args
)

Parameters

sender
Type: System..::..Object
Sender.
args
Type: System..::..EventArgs
Args.

See Also

ItemEventHandler Class
Sitecore.Data.Indexing Namespace


Test Method

[image]

Sitecore 6.4.1 API
ItemEventHandler..::..Test Method
ItemEventHandler Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Test(
    Object sender,
    EventArgs args
)
Visual Basic
Public Sub Test ( _
    sender As Object, _
    args As EventArgs _
)
Visual C++
public:
void Test(
    Object^ sender,
    EventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: System..::..EventArgs
The arguments.

See Also

ItemEventHandler Class
Sitecore.Data.Indexing Namespace


LockScope Class

[image]

Sitecore 6.4.1 API
LockScope Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class LockScope : IDisposable
Visual Basic
Public Class LockScope _
    Implements IDisposable
Visual C++
public ref class LockScope : IDisposable

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Indexing..::..LockScope

See Also

LockScope Members
Sitecore.Data.Indexing Namespace


LockScope Members

[image] [image]

Sitecore 6.4.1 API
LockScope Members
LockScope Class Constructors Methods See Also Send Feedback

The LockScope type exposes the following members.

Constructors

 | Name | Description
Public method | LockScope(Directory) | Initializes a new instance of the LockScope class for write.lock.
Public method | LockScope(Directory, String) | Initializes a new instance of the LockScope class.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LockScope Class
Sitecore.Data.Indexing Namespace


LockScope Constructor

[image] [image]

Sitecore 6.4.1 API
LockScope Constructor
LockScope Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LockScope(Directory) | Initializes a new instance of the LockScope class for write.lock.
Public method | LockScope(Directory, String) | Initializes a new instance of the LockScope class.

See Also

LockScope Class
LockScope Members
Sitecore.Data.Indexing Namespace


LockScope Constructor ()

[image]

Sitecore 6.4.1 API
LockScope Constructor ()
LockScope Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LockScope(
    Directory directory
)
Visual Basic
Public Sub New ( _
    directory As Directory _
)
Visual C++
public:
LockScope(
    Directory^ directory
)

Parameters

directory
Type: Directory
The directory.

See Also

LockScope Class
LockScope Overload
Sitecore.Data.Indexing Namespace


LockScope Constructor (, String)

[image]

Sitecore 6.4.1 API
LockScope Constructor (, String)
LockScope Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LockScope(
    Directory directory,
    string lockName
)
Visual Basic
Public Sub New ( _
    directory As Directory, _
    lockName As String _
)
Visual C++
public:
LockScope(
    Directory^ directory,
    String^ lockName
)

Parameters

directory
Type: Directory
The directory.
lockName
Type: System..::..String
Name of the lock.

See Also

LockScope Class
LockScope Overload
Sitecore.Data.Indexing Namespace


LockScope Methods

[image] [image]

Sitecore 6.4.1 API
LockScope Methods
LockScope Class See Also Send Feedback

The LockScope type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LockScope Class
Sitecore.Data.Indexing Namespace


Dispose Method

[image]

Sitecore 6.4.1 API
LockScope..::..Dispose Method
LockScope Class See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

LockScope Class
Sitecore.Data.Indexing Namespace


StorageType Enumeration

[image]

Sitecore 6.4.1 API
StorageType Enumeration
See Also Send Feedback

Namespace: Sitecore.Data.Indexing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum StorageType
Visual Basic
Public Enumeration StorageType
Visual C++
public enum class StorageType

Members

Member name | Value | Description
Text | 0 | Text.
Keyword | 1 | Keyword.
Unstored | 2 | Unstored.
Unindexed | 3 | Unindexed.

See Also

Sitecore.Data.Indexing Namespace


Sitecore.Data.Items Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Data.Items Namespace
Send Feedback

Classes

 | Class | Description
Public class | BaseItem | Defines the basic functionality of an item.
Public class | BranchItem | Represents a master.
Public class | CloneItem | The clone item.
Public class | ContextItemSwitcher | Switches the context item
Public class | CoreItem | Represents a basic item.
Public class | CoreItem..::..Builder | Builds an item.
Public class | CustomItem | Implements the basic functionality of a custom item.
Public class | CustomItemBase | Implements the basic functionality of a custom item.
Public class | DeviceItem | Represents a Device item.
Public class | EditContext | Provides a mean to put an item in editing mode.
Public class | FieldChange | Represents a field change.
Public class | FieldChangeList | Represents a list of field changes.
Public class | FileDropAreaMediaFolderItem | Represents the File Drop Area media folder item.
Public class | Item | Represents an item.
Public class | Item..::..ItemDebuggerTypeProxy | ItemDebuggerTypeProxy class
Public class | ItemAppearance | Defines the appearance of the item.
Public class | ItemAxes | Provides access to other items relative to a source item.
Public class | ItemChanges | ItemChanges
Public class | ItemEditing | Retrieves information about the editing of a source item.
Public class | ItemHelp | Contains help information for a source item.
Public class | ItemPublishing | Retrieves information about the publishing of a source item.
Public class | ItemRuntimeSettings | Provides miscellaneous information about a source item.
Public class | ItemSerializer | Represents an item serializer.
Public class | ItemState | Provides information about the workflow state of a source item.
Public class | ItemStatistics | Provides information about changes to a source item.
Public class | ItemUtil | Provides miscellaneous functions that operates on an item.
Public class | ItemVersions | Provides methods for working with versions of an item.
Public class | ItemVisualization | Defines how an item is visible to a user.
Public class | LayoutItem | Represents a Layout item.
Public class | MediaItem | Represents a media item.
Public class | ProcessorItem | Represents a Processor item.
Public class | ReadOnlyItemList |
Public class | RenderingItem | Represents a Rendering item.
Public class | SectionTimer | SectionTimer
Public class | SublayoutItem | Represents a Sublayout item.
Public class | TemplateFieldItem | Represents a TemplateField item.
Public class | TemplateItem | Represents a Template item.
Public class | TemplateSectionItem | Represents a Template Section item.
Public class | WebDAVFakeFolder | Represents unreal item. Needed for running under mini-redirector 6.
Public class | WebDAVFolder | Web DAV Folder item.
Public class | WebDAVHierarchyItem | Abstract class Hierarchy item.
Public class | WebDAVItemUtil | Web DAV utility class.
Public class | WebDAVLanguageFolder | Represents Web DAV Language folder for Detailed view.
Public class | WebDAVLockNullItem | Represents Web DAV lock null item.
Public class | WebDAVLockNullSingleVersion | Lock Null item for detailed view.
Public class | WebDAVMediaItem | Web DAV Media Item representation.
Public class | WebDAVSingleItemVersion | Represents single version of versioned item in Detailed view.
Public class | WebDAVVersionedMediaItem | Representation of Versioned media item in Detailed View.
Public class | WebEditButtonItem | The web edit button item

Interfaces

 | Interface | Description
Public interface | ITrackingItem | Defines the basic functionality for an item that tracks modifications.

Enumerations

 | Enumeration | Description
Public enumeration | ItemPathType | Specifies how the path is constructed.
Public enumeration | ItemUpdateType | Defines the type of update to an item.
Public enumeration | PasteMode |
Public enumeration | WebDAVOperation | List of Web DAV operations with DAV items.


BaseItem Class

[image]

Sitecore 6.4.1 API
BaseItem Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class BaseItem
Visual Basic
Public MustInherit Class BaseItem
Visual C++
public ref class BaseItem abstract

Remarks

This is a work-around to provides an Item collection on a class named Item.

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..BaseItem
Sitecore.Data.Items..::..Item

See Also

BaseItem Members
Sitecore.Data.Items Namespace


BaseItem Members

[image] [image]

Sitecore 6.4.1 API
BaseItem Members
BaseItem Class Constructors Methods Properties See Also Send Feedback

The BaseItem type exposes the following members.

Constructors

 | Name | Description
Protected method | BaseItem | Initializes a new instance of the BaseItem class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Fields | Gets the fields of the item.
Public property | Item[([( Int32])]) | Gets or sets the value of a specified field.
Public property | Item[([( String])]) | Gets or sets the value of the field with the specified name.
Public property | Item[([( ID])]) | Gets or sets the value of a specified field.

See Also

BaseItem Class
Sitecore.Data.Items Namespace


BaseItem Methods

[image] [image]

Sitecore 6.4.1 API
BaseItem Methods
BaseItem Class See Also Send Feedback

The BaseItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BaseItem Class
Sitecore.Data.Items Namespace


BaseItem Properties

[image] [image]

Sitecore 6.4.1 API
BaseItem Properties
BaseItem Class See Also Send Feedback

The BaseItem type exposes the following members.

Properties

 | Name | Description
Public property | Fields | Gets the fields of the item.
Public property | Item[([( Int32])]) | Gets or sets the value of a specified field.
Public property | Item[([( String])]) | Gets or sets the value of the field with the specified name.
Public property | Item[([( ID])]) | Gets or sets the value of a specified field.

See Also

BaseItem Class
Sitecore.Data.Items Namespace


Item Property

[image] [image]

Sitecore 6.4.1 API
BaseItem..::..Item Property
BaseItem Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gets or sets the value of a specified field.
Public property | Item[([( String])]) | Gets or sets the value of the field with the specified name.
Public property | Item[([( ID])]) | Gets or sets the value of a specified field.

See Also

BaseItem Class
BaseItem Members
Sitecore.Data.Items Namespace


Item Property (Int32)

[image]

Sitecore 6.4.1 API
BaseItem..::..Item Property (Int32)
BaseItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string this[
    int index
] { get; set; }
Visual Basic
Public Default Property Item ( _
    index As Integer _
) As String
    Get
    Set
Visual C++
public:
property String^ default[int index] {
    String^ get (int index);
    void set (int index, String^ value);
}

Parameters

index
Type: System..::..Int32

Field Value

See Also

BaseItem Class
Item Overload
Sitecore.Data.Items Namespace


Item Property (String)

[image]

Sitecore 6.4.1 API
BaseItem..::..Item Property (String)
BaseItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string this[
    string fieldName
] { get; set; }
Visual Basic
Public Default Property Item ( _
    fieldName As String _
) As String
    Get
    Set
Visual C++
public:
property String^ default[String^ fieldName] {
    String^ get (String^ fieldName);
    void set (String^ fieldName, String^ value);
}

Parameters

fieldName
Type: System..::..String

Field Value

See Also

BaseItem Class
Item Overload
Sitecore.Data.Items Namespace


Item Property (ID)

[image]

Sitecore 6.4.1 API
BaseItem..::..Item Property (ID)
BaseItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string this[
    ID fieldID
] { get; set; }
Visual Basic
Public Default Property Item ( _
    fieldID As ID _
) As String
    Get
    Set
Visual C++
public:
property String^ default[ID^ fieldID] {
    String^ get (ID^ fieldID);
    void set (ID^ fieldID, String^ value);
}

Parameters

fieldID
Type: Sitecore.Data..::..ID

Field Value

See Also

BaseItem Class
Item Overload
Sitecore.Data.Items Namespace


BranchItem Class

[image]

Sitecore 6.4.1 API
BranchItem Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class BranchItem : CustomItem
Visual Basic
Public Class BranchItem _
    Inherits CustomItem
Visual C++
public ref class BranchItem : public CustomItem

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..CustomItemBase
Sitecore.Data.Items..::..CustomItem
Sitecore.Data.Items..::..BranchItem

See Also

BranchItem Members
Sitecore.Data.Items Namespace


BranchItem Members

[image] [image]

Sitecore 6.4.1 API
BranchItem Members
BranchItem Class Constructors Methods Operators Properties See Also Send Feedback

The BranchItem type exposes the following members.

Constructors

 | Name | Description
Public method | BranchItem | Creates a new BranchItem instance.

Methods

 | Name | Description
Public method | AddTo | Adds an item based on this master to another item.
Public method | BeginEdit | Begins editing the item. (Inherited from CustomItemBase.)
Public method | EndEdit | Ends editing the item. (Inherited from CustomItemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(BranchItem to Item) | Converts a BranchItem to a Item.
ImplicitWideningImplicitImplicitImplicit(Item to BranchItem) | Converts an item to BranchItem.

Properties

 | Name | Description
Public property | Database | Gets the database. (Inherited from CustomItemBase.)
Public property | DisplayName | Gets the display name. (Inherited from CustomItemBase.)
Public property | Icon | Gets the icon. (Inherited from CustomItemBase.)
Public property | ID | Gets the ID. (Inherited from CustomItemBase.)
Public property | InnerItem | Gets the inner item. (Inherited from CustomItemBase.)
Public property | Item[([( Int32])]) | Gets or sets the value of a specified field. (Inherited from CustomItem.)
Public property | Item[([( String])]) | Gets or sets the value of a specified field. (Inherited from CustomItem.)
Public property | Item[([( ID])]) | Gets or sets the value of a specified field. (Inherited from CustomItem.)
Public property | Key | Gets the key.
Public property | Name | Gets the name. (Inherited from CustomItemBase.)
Public property | StandardValues | Gets the standard values.

See Also

BranchItem Class
Sitecore.Data.Items Namespace


BranchItem Constructor

[image]

Sitecore 6.4.1 API
BranchItem Constructor
BranchItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BranchItem(
    Item innerItem
)
Visual Basic
Public Sub New ( _
    innerItem As Item _
)
Visual C++
public:
BranchItem(
    Item^ innerItem
)

Parameters

innerItem
Type: Sitecore.Data.Items..::..Item
Inner item.

See Also

BranchItem Class
Sitecore.Data.Items Namespace


BranchItem Methods

[image] [image]

Sitecore 6.4.1 API
BranchItem Methods
BranchItem Class See Also Send Feedback

The BranchItem type exposes the following members.

Methods

 | Name | Description
Public method | AddTo | Adds an item based on this master to another item.
Public method | BeginEdit | Begins editing the item. (Inherited from CustomItemBase.)
Public method | EndEdit | Ends editing the item. (Inherited from CustomItemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BranchItem Class
Sitecore.Data.Items Namespace


AddTo Method

[image]

Sitecore 6.4.1 API
BranchItem..::..AddTo Method
BranchItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item AddTo(
    Item parentItem,
    string name
)
Visual Basic
Public Function AddTo ( _
    parentItem As Item, _
    name As String _
) As Item
Visual C++
public:
Item^ AddTo(
    Item^ parentItem,
    String^ name
)

Parameters

parentItem
Type: Sitecore.Data.Items..::..Item
Parent item.
name
Type: System..::..String
Name.

Return Value

The to.

See Also

BranchItem Class
Sitecore.Data.Items Namespace


BranchItem Type Conversions

[image] [image]

Sitecore 6.4.1 API
BranchItem Type Conversions
BranchItem Class See Also Send Feedback

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(BranchItem to Item) | Converts a BranchItem to a Item.
ImplicitWideningImplicitImplicitImplicit(Item to BranchItem) | Converts an item to BranchItem.

See Also

BranchItem Class
Sitecore.Data.Items Namespace


Implicit Conversion Operators

[image] [image]

Sitecore 6.4.1 API
BranchItem ImplicitWideningImplicitImplicitImplicit Conversion Operators
BranchItem Class See Also Send Feedback

Overload List

Name | Description
ImplicitWideningImplicitImplicitImplicit(BranchItem to Item) | Converts a BranchItem to a Item.
ImplicitWideningImplicitImplicitImplicit(Item to BranchItem) | Converts an item to BranchItem.

See Also

BranchItem Class
BranchItem Members
Sitecore.Data.Items Namespace


Implicit Conversion (BranchItem to Item)

[image]

Sitecore 6.4.1 API
BranchItem ImplicitWideningImplicitImplicitImplicit Conversion (BranchItem to Item)
BranchItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator Item (
    BranchItem branchItem
)
Visual Basic
Public Shared Widening Operator CType ( _
    branchItem As BranchItem _
) As Item
Visual C++
static implicit operator Item^ (
    BranchItem^ branchItem
)

Parameters

branchItem
Type: Sitecore.Data.Items..::..BranchItem
The item.

Return Value

The implicit operator.

See Also

BranchItem Class
ImplicitWideningImplicitImplicitImplicit Overload
Sitecore.Data.Items Namespace


Implicit Conversion (Item to BranchItem)

[image]

Sitecore 6.4.1 API
BranchItem ImplicitWideningImplicitImplicitImplicit Conversion (Item to BranchItem)
BranchItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator BranchItem (
    Item item
)
Visual Basic
Public Shared Widening Operator CType ( _
    item As Item _
) As BranchItem
Visual C++
static implicit operator BranchItem^ (
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

The implicit operator.

See Also

BranchItem Class
ImplicitWideningImplicitImplicitImplicit Overload
Sitecore.Data.Items Namespace


BranchItem Properties

[image] [image]

Sitecore 6.4.1 API
BranchItem Properties
BranchItem Class See Also Send Feedback

The BranchItem type exposes the following members.

Properties

 | Name | Description
Public property | Database | Gets the database. (Inherited from CustomItemBase.)
Public property | DisplayName | Gets the display name. (Inherited from CustomItemBase.)
Public property | Icon | Gets the icon. (Inherited from CustomItemBase.)
Public property | ID | Gets the ID. (Inherited from CustomItemBase.)
Public property | InnerItem | Gets the inner item. (Inherited from CustomItemBase.)
Public property | Item[([( Int32])]) | Gets or sets the value of a specified field. (Inherited from CustomItem.)
Public property | Item[([( String])]) | Gets or sets the value of a specified field. (Inherited from CustomItem.)
Public property | Item[([( ID])]) | Gets or sets the value of a specified field. (Inherited from CustomItem.)
Public property | Key | Gets the key.
Public property | Name | Gets the name. (Inherited from CustomItemBase.)
Public property | StandardValues | Gets the standard values.

See Also

BranchItem Class
Sitecore.Data.Items Namespace


Item Property

[image] [image]

Sitecore 6.4.1 API
BranchItem..::..Item Property
BranchItem Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gets or sets the value of a specified field. (Inherited from CustomItem.)
Public property | Item[([( String])]) | Gets or sets the value of a specified field. (Inherited from CustomItem.)
Public property | Item[([( ID])]) | Gets or sets the value of a specified field. (Inherited from CustomItem.)

See Also

BranchItem Class
BranchItem Members
Sitecore.Data.Items Namespace


Key Property

[image]

Sitecore 6.4.1 API
BranchItem..::..Key Property
BranchItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Key { get; }
Visual Basic
Public ReadOnly Property Key As String
    Get
Visual C++
public:
property String^ Key {
    String^ get ();
}

Field Value

The key.

Remarks

See Also

BranchItem Class
Sitecore.Data.Items Namespace
Item..::..Key


StandardValues Property

[image]

Sitecore 6.4.1 API
BranchItem..::..StandardValues Property
BranchItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item StandardValues { get; }
Visual Basic
Public ReadOnly Property StandardValues As Item
    Get
Visual C++
public:
property Item^ StandardValues {
    Item^ get ();
}

Field Value

The standard values.

See Also

BranchItem Class
Sitecore.Data.Items Namespace


CloneItem Class

[image]

Sitecore 6.4.1 API
CloneItem Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CloneItem : CustomItem
Visual Basic
Public Class CloneItem _
    Inherits CustomItem
Visual C++
public ref class CloneItem : public CustomItem

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..CustomItemBase
Sitecore.Data.Items..::..CustomItem
Sitecore.Data.Items..::..CloneItem

See Also

CloneItem Members
Sitecore.Data.Items Namespace


CloneItem Members

[image] [image]

Sitecore 6.4.1 API
CloneItem Members
CloneItem Class Constructors Methods Properties See Also Send Feedback

The CloneItem type exposes the following members.

Constructors

 | Name | Description
Public method | CloneItem | Initializes a new instance of the CloneItem class.

Methods

 | Name | Description
Public method | BeginEdit | Begins editing the item. (Inherited from CustomItemBase.)
Public method | EndEdit | Ends editing the item. (Inherited from CustomItemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetNonInheritedFieldIDs | Gets the non tracking field IDs.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unclone | Unclones this instance - copies the field values and break the clone link.
Protected method | UpdateBlobField | Updates the BLOB field.
Protected method | UpdateField | Updates the field.

Properties

 | Name | Description
Public property | Database | Gets the database. (Inherited from CustomItemBase.)
Public property | DisplayName | Gets the display name. (Inherited from CustomItemBase.)
Public property | Icon | Gets the icon. (Inherited from CustomItemBase.)
Public property | ID | Gets the ID. (Inherited from CustomItemBase.)
Public property | InnerItem | Gets the inner item. (Inherited from CustomItemBase.)
Public property | Item[([( Int32])]) | Gets or sets the value of a specified field. (Inherited from CustomItem.)
Public property | Item[([( String])]) | Gets or sets the value of a specified field. (Inherited from CustomItem.)
Public property | Item[([( ID])]) | Gets or sets the value of a specified field. (Inherited from CustomItem.)
Public property | Name | Gets the name. (Inherited from CustomItemBase.)

See Also

CloneItem Class
Sitecore.Data.Items Namespace


CloneItem Constructor

[image]

Sitecore 6.4.1 API
CloneItem Constructor
CloneItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CloneItem(
    Item innerItem
)
Visual Basic
Public Sub New ( _
    innerItem As Item _
)
Visual C++
public:
CloneItem(
    Item^ innerItem
)

Parameters

innerItem
Type: Sitecore.Data.Items..::..Item
Inner item.

See Also

CloneItem Class
Sitecore.Data.Items Namespace


CloneItem Methods

[image] [image]

Sitecore 6.4.1 API
CloneItem Methods
CloneItem Class See Also Send Feedback

The CloneItem type exposes the following members.

Methods

 | Name | Description
Public method | BeginEdit | Begins editing the item. (Inherited from CustomItemBase.)
Public method | EndEdit | Ends editing the item. (Inherited from CustomItemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetNonInheritedFieldIDs | Gets the non tracking field IDs.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unclone | Unclones this instance - copies the field values and break the clone link.
Protected method | UpdateBlobField | Updates the BLOB field.
Protected method | UpdateField | Updates the field.

See Also

CloneItem Class
Sitecore.Data.Items Namespace


Unclone Method

[image]

Sitecore 6.4.1 API
CloneItem..::..Unclone Method
CloneItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Unclone()
Visual Basic
Public Function Unclone As Item
Visual C++
public:
Item^ Unclone()

Return Value

The real item version.

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | UnauthorizedAccessException.

See Also

CloneItem Class
Sitecore.Data.Items Namespace


UpdateBlobField Method

[image]

Sitecore 6.4.1 API
CloneItem..::..UpdateBlobField Method
CloneItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void UpdateBlobField(
    Field field,
    Item item
)
Visual Basic
Protected Overridable Sub UpdateBlobField ( _
    field As Field, _
    item As Item _
)
Visual C++
protected:
virtual void UpdateBlobField(
    Field^ field,
    Item^ item
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The original blob field.
item
Type: Sitecore.Data.Items..::..Item
The clone item.

See Also

CloneItem Class
Sitecore.Data.Items Namespace


UpdateField Method

[image]

Sitecore 6.4.1 API
CloneItem..::..UpdateField Method
CloneItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void UpdateField(
    Field field,
    Item item
)
Visual Basic
Protected Overridable Sub UpdateField ( _
    field As Field, _
    item As Item _
)
Visual C++
protected:
virtual void UpdateField(
    Field^ field,
    Item^ item
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The original item field.
item
Type: Sitecore.Data.Items..::..Item
The clone item.

See Also

CloneItem Class
Sitecore.Data.Items Namespace


CloneItem Properties

[image] [image]

Sitecore 6.4.1 API
CloneItem Properties
CloneItem Class See Also Send Feedback

The CloneItem type exposes the following members.

Properties

 | Name | Description
Public property | Database | Gets the database. (Inherited from CustomItemBase.)
Public property | DisplayName | Gets the display name. (Inherited from CustomItemBase.)
Public property | Icon | Gets the icon. (Inherited from CustomItemBase.)
Public property | ID | Gets the ID. (Inherited from CustomItemBase.)
Public property | InnerItem | Gets the inner item. (Inherited from CustomItemBase.)
Public property | Item[([( Int32])]) | Gets or sets the value of a specified field. (Inherited from CustomItem.)
Public property | Item[([( String])]) | Gets or sets the value of a specified field. (Inherited from CustomItem.)
Public property | Item[([( ID])]) | Gets or sets the value of a specified field. (Inherited from CustomItem.)
Public property | Name | Gets the name. (Inherited from CustomItemBase.)

See Also

CloneItem Class
Sitecore.Data.Items Namespace


Item Property

[image] [image]

Sitecore 6.4.1 API
CloneItem..::..Item Property
CloneItem Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gets or sets the value of a specified field. (Inherited from CustomItem.)
Public property | Item[([( String])]) | Gets or sets the value of a specified field. (Inherited from CustomItem.)
Public property | Item[([( ID])]) | Gets or sets the value of a specified field. (Inherited from CustomItem.)

See Also

CloneItem Class
CloneItem Members
Sitecore.Data.Items Namespace


ContextItemSwitcher Class

[image]

Sitecore 6.4.1 API
ContextItemSwitcher Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ContextItemSwitcher : Switcher<Item, ContextItemSwitcher>
Visual Basic
Public Class ContextItemSwitcher _
    Inherits Switcher(Of Item, ContextItemSwitcher)
Visual C++
public ref class ContextItemSwitcher : public Switcher<Item^, ContextItemSwitcher^>

Inheritance Hierarchy

System..::..Object
Sitecore.Common..::..Switcher <(Of <(<' Item, ContextItemSwitcher>)>)>
Sitecore.Data.Items..::..ContextItemSwitcher

See Also

ContextItemSwitcher Members
Sitecore.Data.Items Namespace


ContextItemSwitcher Members

[image] [image]

Sitecore 6.4.1 API
ContextItemSwitcher Members
ContextItemSwitcher Class Constructors Methods Events See Also Send Feedback

The ContextItemSwitcher type exposes the following members.

Constructors

 | Name | Description
Public method | ContextItemSwitcher | Switches the context item

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Switcher<(Of <(<'TValue, TSwitchType>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

 | Name | Description
Protected event | Disposed | Occurs when the object has been disposed. (Inherited from Switcher<(Of <(<'TValue, TSwitchType>)>)>.)

See Also

ContextItemSwitcher Class
Sitecore.Data.Items Namespace


ContextItemSwitcher Constructor

[image]

Sitecore 6.4.1 API
ContextItemSwitcher Constructor
ContextItemSwitcher Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ContextItemSwitcher(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
ContextItemSwitcher(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item to be used as a new context item

See Also

ContextItemSwitcher Class
Sitecore.Data.Items Namespace


ContextItemSwitcher Methods

[image] [image]

Sitecore 6.4.1 API
ContextItemSwitcher Methods
ContextItemSwitcher Class See Also Send Feedback

The ContextItemSwitcher type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Switcher<(Of <(<'TValue, TSwitchType>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ContextItemSwitcher Class
Sitecore.Data.Items Namespace


ContextItemSwitcher Events

[image] [image]

Sitecore 6.4.1 API
ContextItemSwitcher Events
ContextItemSwitcher Class See Also Send Feedback

The ContextItemSwitcher type exposes the following members.

Events

 | Name | Description
Protected event | Disposed | Occurs when the object has been disposed. (Inherited from Switcher<(Of <(<'TValue, TSwitchType>)>)>.)

See Also

ContextItemSwitcher Class
Sitecore.Data.Items Namespace


CoreItem Class

[image]

Sitecore 6.4.1 API
CoreItem Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CoreItem
Visual Basic
Public Class CoreItem
Visual C++
public ref class CoreItem

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..CoreItem

See Also

CoreItem Members
Sitecore.Data.Items Namespace


CoreItem Members

[image] [image]

Sitecore 6.4.1 API
CoreItem Members
CoreItem Class Methods Properties See Also Send Feedback

The CoreItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDataLength | Gets the length of the data.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BranchId | Id of branch used for creating the item
Public property | Data | Gets the data.
Public property | ID | Gets the ID of item
Public property | Item | Gets or sets the field value with the specified field ID.
Public property | Language | Gets the language.
Public property | MasterID | Obsolete. ID of master used for creating the item
Public property | Name | Gets or sets the name.
Public property | TemplateID | Gets the ID of the items template
Public property | Version | Gets the version.

See Also

CoreItem Class
Sitecore.Data.Items Namespace


CoreItem Methods

[image] [image]

Sitecore 6.4.1 API
CoreItem Methods
CoreItem Class See Also Send Feedback

The CoreItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDataLength | Gets the length of the data.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CoreItem Class
Sitecore.Data.Items Namespace


GetDataLength Method

[image]

Sitecore 6.4.1 API
CoreItem..::..GetDataLength Method
CoreItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual long GetDataLength()
Visual Basic
Public Overridable Function GetDataLength As Long
Visual C++
public:
virtual long long GetDataLength()

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Items.CoreItem.GetDataLength"]

See Also

CoreItem Class
Sitecore.Data.Items Namespace


CoreItem Properties

[image] [image]

Sitecore 6.4.1 API
CoreItem Properties
CoreItem Class See Also Send Feedback

The CoreItem type exposes the following members.

Properties

 | Name | Description
Public property | BranchId | Id of branch used for creating the item
Public property | Data | Gets the data.
Public property | ID | Gets the ID of item
Public property | Item | Gets or sets the field value with the specified field ID.
Public property | Language | Gets the language.
Public property | MasterID | Obsolete. ID of master used for creating the item
Public property | Name | Gets or sets the name.
Public property | TemplateID | Gets the ID of the items template
Public property | Version | Gets the version.

See Also

CoreItem Class
Sitecore.Data.Items Namespace


BranchId Property

[image]

Sitecore 6.4.1 API
CoreItem..::..BranchId Property
CoreItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID BranchId { get; set; }
Visual Basic
Public Property BranchId As ID
    Get
    Set
Visual C++
public:
property ID^ BranchId {
    ID^ get ();
    void set (ID^ value);
}

Field Value

The branch id.

See Also

CoreItem Class
Sitecore.Data.Items Namespace


Data Property

[image]

Sitecore 6.4.1 API
CoreItem..::..Data Property
CoreItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Hashtable Data { get; }
Visual Basic
Public ReadOnly Property Data As Hashtable
    Get
Visual C++
public:
property Hashtable^ Data {
    Hashtable^ get ();
}

Field Value

The data.

See Also

CoreItem Class
Sitecore.Data.Items Namespace


Item Property

[image]

Sitecore 6.4.1 API
CoreItem..::..Item Property
CoreItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string this[
    ID fieldID
] { get; set; }
Visual Basic
Public Default Property Item ( _
    fieldID As ID _
) As String
    Get
    Set
Visual C++
public:
property String^ default[ID^ fieldID] {
    String^ get (ID^ fieldID);
    void set (ID^ fieldID, String^ value);
}

Parameters

fieldID
Type: Sitecore.Data..::..ID

Field Value

See Also

CoreItem Class
Sitecore.Data.Items Namespace


MasterID Property

[image]

Sitecore 6.4.1 API
CoreItem..::..MasterID Property
CoreItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use BranchId instead.")]
public ID MasterID { get; set; }
Visual Basic
<ObsoleteAttribute("Deprecated - Use BranchId instead.")> _
Public Property MasterID As ID
    Get
    Set
Visual C++
[ObsoleteAttribute(L"Deprecated - Use BranchId instead.")]
public:
property ID^ MasterID {
    ID^ get ();
    void set (ID^ value);
}

Field Value

The master ID.

See Also

CoreItem Class
Sitecore.Data.Items Namespace


Name Property

[image]

Sitecore 6.4.1 API
CoreItem..::..Name Property
CoreItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Field Value

The name.

See Also

CoreItem Class
Sitecore.Data.Items Namespace


TemplateID Property

[image]

Sitecore 6.4.1 API
CoreItem..::..TemplateID Property
CoreItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID TemplateID { get; set; }
Visual Basic
Public Property TemplateID As ID
    Get
    Set
Visual C++
public:
property ID^ TemplateID {
    ID^ get ();
    void set (ID^ value);
}

Field Value

The template ID.

See Also

CoreItem Class
Sitecore.Data.Items Namespace


Version Property

[image]

Sitecore 6.4.1 API
CoreItem..::..Version Property
CoreItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Version Version { get; }
Visual Basic
Public ReadOnly Property Version As Version
    Get
Visual C++
public:
property Version^ Version {
    Version^ get ();
}

Field Value

The version.

See Also

CoreItem Class
Sitecore.Data.Items Namespace


CoreItem.Builder Class

[image]

Sitecore 6.4.1 API
CoreItem..::..Builder Class
CoreItem Class Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Builder
Visual Basic
Public Class Builder
Visual C++
public ref class Builder

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..CoreItem..::..Builder

See Also

CoreItem..::..Builder Members
Sitecore.Data.Items Namespace


CoreItem.Builder Members

[image] [image]

Sitecore 6.4.1 API
CoreItem..::..Builder Members
CoreItem..::..Builder Class Constructors Methods Properties See Also Send Feedback

Represents a basic item.

The CoreItem..::..Builder type exposes the following members.

Constructors

 | Name | Description
Public method | CoreItem..::..Builder | Initializes a new instance of the CoreItem..::..Builder class.

Methods

 | Name | Description
Public method | AddField(String, String) | Adds the field.
Public method | AddField(ID, String) | Adds the field.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetBranchId | Sets the branch id.
Public method | SetLanguage | Sets the language.
Public method | SetMasterID | Obsolete. Sets the master ID.
Public method | SetVersion | Sets the version.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ItemData | Gets the item data.
Public property | Template | Gets the template.

See Also

CoreItem..::..Builder Class
Sitecore.Data.Items Namespace


CoreItem.Builder Constructor

[image]

Sitecore 6.4.1 API
CoreItem..::..Builder Constructor
CoreItem..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Builder(
    ID itemID,
    string itemName,
    ID templateID,
    DataManager manager
)
Visual Basic
Public Sub New ( _
    itemID As ID, _
    itemName As String, _
    templateID As ID, _
    manager As DataManager _
)
Visual C++
public:
Builder(
    ID^ itemID,
    String^ itemName,
    ID^ templateID,
    DataManager^ manager
)

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.
itemName
Type: System..::..String
Name of the item.
templateID
Type: Sitecore.Data..::..ID
The template ID.
manager
Type: Sitecore.Data..::..DataManager
The manager.

See Also

CoreItem..::..Builder Class
Sitecore.Data.Items Namespace


CoreItem.Builder Methods

[image] [image]

Sitecore 6.4.1 API
CoreItem..::..Builder Methods
CoreItem..::..Builder Class See Also Send Feedback

The CoreItem..::..Builder type exposes the following members.

Methods

 | Name | Description
Public method | AddField(String, String) | Adds the field.
Public method | AddField(ID, String) | Adds the field.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetBranchId | Sets the branch id.
Public method | SetLanguage | Sets the language.
Public method | SetMasterID | Obsolete. Sets the master ID.
Public method | SetVersion | Sets the version.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CoreItem..::..Builder Class
Sitecore.Data.Items Namespace


AddField Method

[image] [image]

Sitecore 6.4.1 API
CoreItem..::..Builder..::..AddField Method
CoreItem..::..Builder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddField(String, String) | Adds the field.
Public method | AddField(ID, String) | Adds the field.

See Also

CoreItem..::..Builder Class
CoreItem..::..Builder Members
Sitecore.Data.Items Namespace


AddField Method (String, String)

[image]

Sitecore 6.4.1 API
CoreItem..::..Builder..::..AddField Method (String, String)
CoreItem..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddField(
    string fieldName,
    string fieldValue
)
Visual Basic
Public Sub AddField ( _
    fieldName As String, _
    fieldValue As String _
)
Visual C++
public:
void AddField(
    String^ fieldName,
    String^ fieldValue
)

Parameters

fieldName
Type: System..::..String
Name of the field.
fieldValue
Type: System..::..String
The field value.

See Also

CoreItem..::..Builder Class
AddField Overload
Sitecore.Data.Items Namespace


AddField Method (ID, String)

[image]

Sitecore 6.4.1 API
CoreItem..::..Builder..::..AddField Method (ID, String)
CoreItem..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddField(
    ID fieldID,
    string fieldValue
)
Visual Basic
Public Sub AddField ( _
    fieldID As ID, _
    fieldValue As String _
)
Visual C++
public:
void AddField(
    ID^ fieldID,
    String^ fieldValue
)

Parameters

fieldID
Type: Sitecore.Data..::..ID
The field ID.
fieldValue
Type: System..::..String
The field value.

See Also

CoreItem..::..Builder Class
AddField Overload
Sitecore.Data.Items Namespace


SetLanguage Method

[image]

Sitecore 6.4.1 API
CoreItem..::..Builder..::..SetLanguage Method
CoreItem..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetLanguage(
    Language language
)
Visual Basic
Public Sub SetLanguage ( _
    language As Language _
)
Visual C++
public:
void SetLanguage(
    Language^ language
)

Parameters

language
Type: Sitecore.Globalization..::..Language
The language.

See Also

CoreItem..::..Builder Class
Sitecore.Data.Items Namespace


SetMasterID Method

[image]

Sitecore 6.4.1 API
CoreItem..::..Builder..::..SetMasterID Method
CoreItem..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use SetBranchId instead.")]
public void SetMasterID(
    ID masterID
)
Visual Basic
<ObsoleteAttribute("Deprecated - Use SetBranchId instead.")> _
Public Sub SetMasterID ( _
    masterID As ID _
)
Visual C++
[ObsoleteAttribute(L"Deprecated - Use SetBranchId instead.")]
public:
void SetMasterID(
    ID^ masterID
)

Parameters

masterID
Type: Sitecore.Data..::..ID
The master ID.

See Also

CoreItem..::..Builder Class
Sitecore.Data.Items Namespace


SetVersion Method

[image]

Sitecore 6.4.1 API
CoreItem..::..Builder..::..SetVersion Method
CoreItem..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetVersion(
    Version version
)
Visual Basic
Public Sub SetVersion ( _
    version As Version _
)
Visual C++
public:
void SetVersion(
    Version^ version
)

Parameters

version
Type: Sitecore.Data..::..Version
The version.

See Also

CoreItem..::..Builder Class
Sitecore.Data.Items Namespace


CoreItem.Builder Properties

[image] [image]

Sitecore 6.4.1 API
CoreItem..::..Builder Properties
CoreItem..::..Builder Class See Also Send Feedback

The CoreItem..::..Builder type exposes the following members.

Properties

 | Name | Description
Public property | ItemData | Gets the item data.
Public property | Template | Gets the template.

See Also

CoreItem..::..Builder Class
Sitecore.Data.Items Namespace


ItemData Property

[image]

Sitecore 6.4.1 API
CoreItem..::..Builder..::..ItemData Property
CoreItem..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemData ItemData { get; }
Visual Basic
Public ReadOnly Property ItemData As ItemData
    Get
Visual C++
public:
property ItemData^ ItemData {
    ItemData^ get ();
}

Field Value

The item data.

See Also

CoreItem..::..Builder Class
Sitecore.Data.Items Namespace


Template Property

[image]

Sitecore 6.4.1 API
CoreItem..::..Builder..::..Template Property
CoreItem..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Template Template { get; }
Visual Basic
Public ReadOnly Property Template As Template
    Get
Visual C++
public:
property Template^ Template {
    Template^ get ();
}

Field Value

The template.

See Also

CoreItem..::..Builder Class
Sitecore.Data.Items Namespace


CustomItem Members

[image] [image]

Sitecore 6.4.1 API
CustomItem Members
CustomItem Class Constructors Methods Properties See Also Send Feedback

The CustomItem type exposes the following members.

Constructors

 | Name | Description
Protected method | CustomItem | Creates a new CustomItem instance.

Methods

 | Name | Description
Public method | BeginEdit | Begins editing the item. (Inherited from CustomItemBase.)
Public method | EndEdit | Ends editing the item. (Inherited from CustomItemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Database | Gets the database. (Inherited from CustomItemBase.)
Public property | DisplayName | Gets the display name. (Inherited from CustomItemBase.)
Public property | Icon | Gets the icon. (Inherited from CustomItemBase.)
Public property | ID | Gets the ID. (Inherited from CustomItemBase.)
Public property | InnerItem | Gets the inner item. (Inherited from CustomItemBase.)
Public property | Item[([( Int32])]) | Gets or sets the value of a specified field.
Public property | Item[([( String])]) | Gets or sets the value of a specified field.
Public property | Item[([( ID])]) | Gets or sets the value of a specified field.
Public property | Name | Gets the name. (Inherited from CustomItemBase.)

See Also

CustomItem Class
Sitecore.Data.Items Namespace


CustomItem Constructor

[image]

Sitecore 6.4.1 API
CustomItem Constructor
CustomItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected CustomItem(
    Item innerItem
)
Visual Basic
Protected Sub New ( _
    innerItem As Item _
)
Visual C++
protected:
CustomItem(
    Item^ innerItem
)

Parameters

innerItem
Type: Sitecore.Data.Items..::..Item
Inner item.

See Also

CustomItem Class
Sitecore.Data.Items Namespace


CustomItem Methods

[image] [image]

Sitecore 6.4.1 API
CustomItem Methods
CustomItem Class See Also Send Feedback

The CustomItem type exposes the following members.

Methods

 | Name | Description
Public method | BeginEdit | Begins editing the item. (Inherited from CustomItemBase.)
Public method | EndEdit | Ends editing the item. (Inherited from CustomItemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomItem Class
Sitecore.Data.Items Namespace


Item Property

[image] [image]

Sitecore 6.4.1 API
CustomItem..::..Item Property
CustomItem Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gets or sets the value of a specified field.
Public property | Item[([( String])]) | Gets or sets the value of a specified field.
Public property | Item[([( ID])]) | Gets or sets the value of a specified field.

See Also

CustomItem Class
CustomItem Members
Sitecore.Data.Items Namespace


Item Property (Int32)

[image]

Sitecore 6.4.1 API
CustomItem..::..Item Property (Int32)
CustomItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string this[
    int fieldIndex
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    fieldIndex As Integer _
) As String
    Get
Visual C++
public:
property String^ default[int fieldIndex] {
    String^ get (int fieldIndex);
}

Parameters

fieldIndex
Type: System..::..Int32

See Also

CustomItem Class
Item Overload
Sitecore.Data.Items Namespace


Item Property (String)

[image]

Sitecore 6.4.1 API
CustomItem..::..Item Property (String)
CustomItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string this[
    string fieldName
] { get; set; }
Visual Basic
Public Default Property Item ( _
    fieldName As String _
) As String
    Get
    Set
Visual C++
public:
property String^ default[String^ fieldName] {
    String^ get (String^ fieldName);
    void set (String^ fieldName, String^ value);
}

Parameters

fieldName
Type: System..::..String

See Also

CustomItem Class
Item Overload
Sitecore.Data.Items Namespace


Item Property (ID)

[image]

Sitecore 6.4.1 API
CustomItem..::..Item Property (ID)
CustomItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string this[
    ID fieldID
] { get; set; }
Visual Basic
Public Default Property Item ( _
    fieldID As ID _
) As String
    Get
    Set
Visual C++
public:
property String^ default[ID^ fieldID] {
    String^ get (ID^ fieldID);
    void set (ID^ fieldID, String^ value);
}

Parameters

fieldID
Type: Sitecore.Data..::..ID

See Also

CustomItem Class
Item Overload
Sitecore.Data.Items Namespace


CustomItemBase Class

[image]

Sitecore 6.4.1 API
CustomItemBase Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class CustomItemBase
Visual Basic
Public MustInherit Class CustomItemBase
Visual C++
public ref class CustomItemBase abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..CustomItemBase
Sitecore.Data.Items..::..CustomItem
Sitecore.Data.Items..::..DeviceItem
Sitecore.Data.Items..::..LayoutItem
Sitecore.Data.Items..::..MediaItem
Sitecore.Data.Items..::..ProcessorItem
Sitecore.Data.Items..::..RenderingItem
Sitecore.Data.Items..::..SublayoutItem
Sitecore.Data.Items..::..TemplateFieldItem
Sitecore.Data.Items..::..TemplateItem
Sitecore.Data.Items..::..TemplateSectionItem
Sitecore.Web.UI.Portal..::..PortletItem

See Also

CustomItemBase Members
Sitecore.Data.Items Namespace


CustomItemBase Members

[image] [image]

Sitecore 6.4.1 API
CustomItemBase Members
CustomItemBase Class Constructors Methods Properties See Also Send Feedback

The CustomItemBase type exposes the following members.

Constructors

 | Name | Description
Protected method | CustomItemBase | Creates a new CustomItemBase instance.

Methods

 | Name | Description
Public method | BeginEdit | Begins editing the item.
Public method | EndEdit | Ends editing the item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Database | Gets the database.
Public property | DisplayName | Gets the display name.
Public property | Icon | Gets the icon.
Public property | ID | Gets the ID.
Public property | InnerItem | Gets the inner item.
Public property | Name | Gets the name.

See Also

CustomItemBase Class
Sitecore.Data.Items Namespace


CustomItemBase Constructor

[image]

Sitecore 6.4.1 API
CustomItemBase Constructor
CustomItemBase Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected CustomItemBase(
    Item innerItem
)
Visual Basic
Protected Sub New ( _
    innerItem As Item _
)
Visual C++
protected:
CustomItemBase(
    Item^ innerItem
)

Parameters

innerItem
Type: Sitecore.Data.Items..::..Item
Inner item.

See Also

CustomItemBase Class
Sitecore.Data.Items Namespace


CustomItemBase Methods

[image] [image]

Sitecore 6.4.1 API
CustomItemBase Methods
CustomItemBase Class See Also Send Feedback

The CustomItemBase type exposes the following members.

Methods

 | Name | Description
Public method | BeginEdit | Begins editing the item.
Public method | EndEdit | Ends editing the item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomItemBase Class
Sitecore.Data.Items Namespace


BeginEdit Method

[image]

Sitecore 6.4.1 API
CustomItemBase..::..BeginEdit Method
CustomItemBase Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void BeginEdit()
Visual Basic
Public Sub BeginEdit
Visual C++
public:
void BeginEdit()

Remarks

See Also

CustomItemBase Class
Sitecore.Data.Items Namespace
ItemEditing..::..BeginEdit()()()()


EndEdit Method

[image]

Sitecore 6.4.1 API
CustomItemBase..::..EndEdit Method
CustomItemBase Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void EndEdit()
Visual Basic
Public Sub EndEdit
Visual C++
public:
void EndEdit()

Remarks

See Also

CustomItemBase Class
Sitecore.Data.Items Namespace
ItemEditing..::..EndEdit()()()()


CustomItemBase Properties

[image] [image]

Sitecore 6.4.1 API
CustomItemBase Properties
CustomItemBase Class See Also Send Feedback

The CustomItemBase type exposes the following members.

Properties

 | Name | Description
Public property | Database | Gets the database.
Public property | DisplayName | Gets the display name.
Public property | Icon | Gets the icon.
Public property | ID | Gets the ID.
Public property | InnerItem | Gets the inner item.
Public property | Name | Gets the name.

See Also

CustomItemBase Class
Sitecore.Data.Items Namespace


Database Property

[image]

Sitecore 6.4.1 API
CustomItemBase..::..Database Property
CustomItemBase Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database Database { get; }
Visual Basic
Public ReadOnly Property Database As Database
    Get
Visual C++
public:
property Database^ Database {
    Database^ get ();
}

Field Value

The database.

Remarks

See Also

CustomItemBase Class
Sitecore.Data.Items Namespace
Item..::..Database


DisplayName Property

[image]

Sitecore 6.4.1 API
CustomItemBase..::..DisplayName Property
CustomItemBase Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string DisplayName { get; }
Visual Basic
Public Overridable ReadOnly Property DisplayName As String
    Get
Visual C++
public:
virtual property String^ DisplayName {
    String^ get ();
}

Field Value

The name of the display.

Remarks

See Also

CustomItemBase Class
Sitecore.Data.Items Namespace
Item..::..DisplayName


Icon Property

[image]

Sitecore 6.4.1 API
CustomItemBase..::..Icon Property
CustomItemBase Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string Icon { get; }
Visual Basic
Public Overridable ReadOnly Property Icon As String
    Get
Visual C++
public:
virtual property String^ Icon {
    String^ get ();
}

Field Value

The icon.

Remarks

See Also

CustomItemBase Class
Sitecore.Data.Items Namespace
ItemAppearance..::..Icon


ID Property

[image]

Sitecore 6.4.1 API
CustomItemBase..::..ID Property
CustomItemBase Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ID { get; }
Visual Basic
Public ReadOnly Property ID As ID
    Get
Visual C++
public:
property ID^ ID {
    ID^ get ();
}

Field Value

The ID.

See Also

CustomItemBase Class
Sitecore.Data.Items Namespace


InnerItem Property

[image]

Sitecore 6.4.1 API
CustomItemBase..::..InnerItem Property
CustomItemBase Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item InnerItem { get; }
Visual Basic
Public ReadOnly Property InnerItem As Item
    Get
Visual C++
public:
property Item^ InnerItem {
    Item^ get ();
}

Field Value

The inner item.

See Also

CustomItemBase Class
Sitecore.Data.Items Namespace


Name Property

[image]

Sitecore 6.4.1 API
CustomItemBase..::..Name Property
CustomItemBase Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Field Value

The name.

Remarks

See Also

CustomItemBase Class
Sitecore.Data.Items Namespace
Item..::..Name


DeviceItem Constructor

[image]

Sitecore 6.4.1 API
DeviceItem Constructor
DeviceItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DeviceItem(
    Item innerItem
)
Visual Basic
Public Sub New ( _
    innerItem As Item _
)
Visual C++
public:
DeviceItem(
    Item^ innerItem
)

Parameters

innerItem
Type: Sitecore.Data.Items..::..Item
Inner item.

See Also

DeviceItem Class
Sitecore.Data.Items Namespace


DeviceItem Methods

[image] [image]

Sitecore 6.4.1 API
DeviceItem Methods
DeviceItem Class See Also Send Feedback

The DeviceItem type exposes the following members.

Methods

 | Name | Description
Public method | BeginEdit | Begins editing the item. (Inherited from CustomItemBase.)
Public method | EndEdit | Ends editing the item. (Inherited from CustomItemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MatchesAgent | Determines if the current Http query string matches the Agent.
Public method | MatchesQueryString | Determines if the current Http query string matches the QueryString.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ResolveDevice | Gets the current device.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DeviceItem Class
Sitecore.Data.Items Namespace


MatchesAgent Method

[image]

Sitecore 6.4.1 API
DeviceItem..::..MatchesAgent Method
DeviceItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool MatchesAgent()
Visual Basic
Public Function MatchesAgent As Boolean
Visual C++
public:
bool MatchesAgent()

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Items.DeviceItem.MatchesAgent"]

See Also

DeviceItem Class
Sitecore.Data.Items Namespace


MatchesQueryString Method

[image]

Sitecore 6.4.1 API
DeviceItem..::..MatchesQueryString Method
DeviceItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool MatchesQueryString()
Visual Basic
Public Function MatchesQueryString As Boolean
Visual C++
public:
bool MatchesQueryString()

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Items.DeviceItem.MatchesQueryString"]

See Also

DeviceItem Class
Sitecore.Data.Items Namespace


ResolveDevice Method

[image]

Sitecore 6.4.1 API
DeviceItem..::..ResolveDevice Method
DeviceItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static DeviceItem ResolveDevice(
    Database database
)
Visual Basic
Public Shared Function ResolveDevice ( _
    database As Database _
) As DeviceItem
Visual C++
public:
static DeviceItem^ ResolveDevice(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

Return Value

The current device.

See Also

DeviceItem Class
Sitecore.Data.Items Namespace


DeviceItem Type Conversions

[image] [image]

Sitecore 6.4.1 API
DeviceItem Type Conversions
DeviceItem Class See Also Send Feedback

The DeviceItem type exposes the following members.

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Item to DeviceItem) | Converts an item to a DeviceItem.

See Also

DeviceItem Class
Sitecore.Data.Items Namespace


Implicit Conversion (Item to DeviceItem)

[image]

Sitecore 6.4.1 API
DeviceItem ImplicitWideningImplicitImplicitImplicit Conversion (Item to DeviceItem)
DeviceItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator DeviceItem (
    Item item
)
Visual Basic
Public Shared Widening Operator CType ( _
    item As Item _
) As DeviceItem
Visual C++
static implicit operator DeviceItem^ (
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item

[Missing <param name="item"/> documentation for "M:Sitecore.Data.Items.DeviceItem.op_Implicit(Sitecore.Data.Items.Item)~Sitecore.Data.Items.DeviceItem"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Items.DeviceItem.op_Implicit(Sitecore.Data.Items.Item)~Sitecore.Data.Items.DeviceItem"]

See Also

DeviceItem Class
Sitecore.Data.Items Namespace


DeviceItem Properties

[image] [image]

Sitecore 6.4.1 API
DeviceItem Properties
DeviceItem Class See Also Send Feedback

The DeviceItem type exposes the following members.

Properties

 | Name | Description
Public property | Agent | Gets the agent identification string.
Public property | Capabilities | Gets the capabilities of the device.
Public property | Database | Gets the database. (Inherited from CustomItemBase.)
Public property | DisplayName | Gets the display name. (Inherited from CustomItemBase.)
Public property | FallbackDevice | Gets the fallback device.
Public property | Icon | Gets the icon. (Inherited from CustomItemBase.)
Public property | ID | Gets the ID. (Inherited from CustomItemBase.)
Public property | InnerItem | Gets the inner item. (Inherited from CustomItemBase.)
Public property | IsDefault | Gets a value indicating whether this device is default.
Public property | IsValid | Gets a value indicating whether this device is valid.
Public property | Name | Gets the name. (Inherited from CustomItemBase.)
Public property | QueryString | Gets the Http query string that must be matched for this device to be valid.

See Also

DeviceItem Class
Sitecore.Data.Items Namespace


Agent Property

[image]

Sitecore 6.4.1 API
DeviceItem..::..Agent Property
DeviceItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Agent { get; }
Visual Basic
Public ReadOnly Property Agent As String
    Get
Visual C++
public:
property String^ Agent {
    String^ get ();
}

Field Value

See Also

DeviceItem Class
Sitecore.Data.Items Namespace


Capabilities Property

[image]

Sitecore 6.4.1 API
DeviceItem..::..Capabilities Property
DeviceItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DeviceCapabilities Capabilities { get; }
Visual Basic
Public ReadOnly Property Capabilities As DeviceCapabilities
    Get
Visual C++
public:
property DeviceCapabilities^ Capabilities {
    DeviceCapabilities^ get ();
}

Field Value

The capabilities of the device.

See Also

DeviceItem Class
Sitecore.Data.Items Namespace


FallbackDevice Property

[image]

Sitecore 6.4.1 API
DeviceItem..::..FallbackDevice Property
DeviceItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DeviceItem FallbackDevice { get; }
Visual Basic
Public ReadOnly Property FallbackDevice As DeviceItem
    Get
Visual C++
public:
property DeviceItem^ FallbackDevice {
    DeviceItem^ get ();
}

Field Value

See Also

DeviceItem Class
Sitecore.Data.Items Namespace


IsDefault Property

[image]

Sitecore 6.4.1 API
DeviceItem..::..IsDefault Property
DeviceItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsDefault { get; }
Visual Basic
Public ReadOnly Property IsDefault As Boolean
    Get
Visual C++
public:
property bool IsDefault {
    bool get ();
}

Field Value

true if this device is default; otherwise, false.

See Also

DeviceItem Class
Sitecore.Data.Items Namespace


IsValid Property

[image]

Sitecore 6.4.1 API
DeviceItem..::..IsValid Property
DeviceItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsValid { get; }
Visual Basic
Public ReadOnly Property IsValid As Boolean
    Get
Visual C++
public:
property bool IsValid {
    bool get ();
}

Field Value

true if this device is valid; otherwise, false.

See Also

DeviceItem Class
Sitecore.Data.Items Namespace


QueryString Property

[image]

Sitecore 6.4.1 API
DeviceItem..::..QueryString Property
DeviceItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string QueryString { get; }
Visual Basic
Public ReadOnly Property QueryString As String
    Get
Visual C++
public:
property String^ QueryString {
    String^ get ();
}

Field Value

See Also

DeviceItem Class
Sitecore.Data.Items Namespace


EditContext Class

[image]

Sitecore 6.4.1 API
EditContext Class
Members Example See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class EditContext : IDisposable
Visual Basic
Public Class EditContext _
    Implements IDisposable
Visual C++
public ref class EditContext : IDisposable

Remarks

The item is enters editing mode when this object is created and leaves editing mode when the object is disposed.

This provides an easy to use mechanism for editing items.

Examples

The following code updates the Title field of the Home item.
CopyC#
Item item = Sitecore.Context.Item["/sitecore/context/Home"];
  using (new EditContext(item)) {
    item["Title"] = "My title";
  }

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..EditContext

See Also

EditContext Members
Sitecore.Data.Items Namespace


EditContext Members

[image] [image]

Sitecore 6.4.1 API
EditContext Members
EditContext Class Constructors Methods See Also Send Feedback

The EditContext type exposes the following members.

Constructors

 | Name | Description
Public method | EditContext(Item) | Creates a new EditContext instance.
Public method | EditContext(Item, SecurityCheck) | Creates a new EditContext instance.
Public method | EditContext(Item, Boolean, Boolean) | Creates a new EditContext instance.

Methods

 | Name | Description
Public method | Dispose | Disposes this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EditContext Class
Sitecore.Data.Items Namespace


EditContext Constructor

[image] [image]

Sitecore 6.4.1 API
EditContext Constructor
EditContext Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EditContext(Item) | Creates a new EditContext instance.
Public method | EditContext(Item, SecurityCheck) | Creates a new EditContext instance.
Public method | EditContext(Item, Boolean, Boolean) | Creates a new EditContext instance.

See Also

EditContext Class
EditContext Members
Sitecore.Data.Items Namespace


EditContext Constructor (Item)

[image]

Sitecore 6.4.1 API
EditContext Constructor (Item)
EditContext Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public EditContext(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
EditContext(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
Item.

Remarks

The item enters editing mode.

See Also

EditContext Class
EditContext Overload
Sitecore.Data.Items Namespace


EditContext Constructor (Item, SecurityCheck)

[image]

Sitecore 6.4.1 API
EditContext Constructor (Item, SecurityCheck)
EditContext Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public EditContext(
    Item item,
    SecurityCheck securityCheck
)
Visual Basic
Public Sub New ( _
    item As Item, _
    securityCheck As SecurityCheck _
)
Visual C++
public:
EditContext(
    Item^ item,
    SecurityCheck securityCheck
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
Item.
securityCheck
Type: Sitecore.SecurityModel..::..SecurityCheck
The security check.

Remarks

The item enters editing mode.

See Also

EditContext Class
EditContext Overload
Sitecore.Data.Items Namespace


EditContext Constructor (Item, Boolean, Boolean)

[image]

Sitecore 6.4.1 API
EditContext Constructor (Item, Boolean, Boolean)
EditContext Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public EditContext(
    Item item,
    bool updateStatistics,
    bool silent
)
Visual Basic
Public Sub New ( _
    item As Item, _
    updateStatistics As Boolean, _
    silent As Boolean _
)
Visual C++
public:
EditContext(
    Item^ item,
    bool updateStatistics,
    bool silent
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
updateStatistics
Type: System..::..Boolean
if set to true this instance is update statistics.
silent
Type: System..::..Boolean
if set to true this instance is silent.

Remarks

The item enters editing mode.

See Also

EditContext Class
EditContext Overload
Sitecore.Data.Items Namespace


EditContext Methods

[image] [image]

Sitecore 6.4.1 API
EditContext Methods
EditContext Class See Also Send Feedback

The EditContext type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Disposes this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EditContext Class
Sitecore.Data.Items Namespace


Dispose Method

[image]

Sitecore 6.4.1 API
EditContext..::..Dispose Method
EditContext Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

Remarks

The item leaves editing mode.

See Also

EditContext Class
Sitecore.Data.Items Namespace


FieldChange Class

[image]

Sitecore 6.4.1 API
FieldChange Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FieldChange
Visual Basic
Public Class FieldChange
Visual C++
public ref class FieldChange

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..FieldChange

See Also

FieldChange Members
Sitecore.Data.Items Namespace


FieldChange Members

[image] [image]

Sitecore 6.4.1 API
FieldChange Members
FieldChange Class Constructors Methods Properties See Also Send Feedback

The FieldChange type exposes the following members.

Constructors

 | Name | Description
Public method | FieldChange | Initializes a new instance of the FieldChange class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Definition | Gets the definition.
Public property | FieldID | Gets the field ID.
Public property | Language | Gets the language.
Public property | RemoveField | Gets a value indicating whether the FieldChange removes the field.
Public property | Value | Gets the value.
Public property | Version | Gets the version.

See Also

FieldChange Class
Sitecore.Data.Items Namespace


FieldChange Constructor

[image]

Sitecore 6.4.1 API
FieldChange Constructor
FieldChange Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FieldChange(
    Field field,
    string value
)
Visual Basic
Public Sub New ( _
    field As Field, _
    value As String _
)
Visual C++
public:
FieldChange(
    Field^ field,
    String^ value
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.
value
Type: System..::..String
The value.

See Also

FieldChange Class
Sitecore.Data.Items Namespace


FieldChange Methods

[image] [image]

Sitecore 6.4.1 API
FieldChange Methods
FieldChange Class See Also Send Feedback

The FieldChange type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldChange Class
Sitecore.Data.Items Namespace


FieldChange Properties

[image] [image]

Sitecore 6.4.1 API
FieldChange Properties
FieldChange Class See Also Send Feedback

The FieldChange type exposes the following members.

Properties

 | Name | Description
Public property | Definition | Gets the definition.
Public property | FieldID | Gets the field ID.
Public property | Language | Gets the language.
Public property | RemoveField | Gets a value indicating whether the FieldChange removes the field.
Public property | Value | Gets the value.
Public property | Version | Gets the version.

See Also

FieldChange Class
Sitecore.Data.Items Namespace


Definition Property

[image]

Sitecore 6.4.1 API
FieldChange..::..Definition Property
FieldChange Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateField Definition { get; }
Visual Basic
Public ReadOnly Property Definition As TemplateField
    Get
Visual C++
public:
property TemplateField^ Definition {
    TemplateField^ get ();
}

Field Value

The definition.

See Also

FieldChange Class
Sitecore.Data.Items Namespace


FieldID Property

[image]

Sitecore 6.4.1 API
FieldChange..::..FieldID Property
FieldChange Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID FieldID { get; }
Visual Basic
Public ReadOnly Property FieldID As ID
    Get
Visual C++
public:
property ID^ FieldID {
    ID^ get ();
}

Field Value

The field ID.

See Also

FieldChange Class
Sitecore.Data.Items Namespace


Language Property

[image]

Sitecore 6.4.1 API
FieldChange..::..Language Property
FieldChange Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Language Language { get; }
Visual Basic
Public ReadOnly Property Language As Language
    Get
Visual C++
public:
property Language^ Language {
    Language^ get ();
}

Field Value

The language.

See Also

FieldChange Class
Sitecore.Data.Items Namespace


RemoveField Property

[image]

Sitecore 6.4.1 API
FieldChange..::..RemoveField Property
FieldChange Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool RemoveField { get; }
Visual Basic
Public ReadOnly Property RemoveField As Boolean
    Get
Visual C++
public:
property bool RemoveField {
    bool get ();
}

Field Value

true if the FieldChange removes the field; otherwise, false.

See Also

FieldChange Class
Sitecore.Data.Items Namespace


Value Property

[image]

Sitecore 6.4.1 API
FieldChange..::..Value Property
FieldChange Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Value { get; }
Visual Basic
Public ReadOnly Property Value As String
    Get
Visual C++
public:
property String^ Value {
    String^ get ();
}

Field Value

The value.

See Also

FieldChange Class
Sitecore.Data.Items Namespace


Version Property

[image]

Sitecore 6.4.1 API
FieldChange..::..Version Property
FieldChange Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Version Version { get; }
Visual Basic
Public ReadOnly Property Version As Version
    Get
Visual C++
public:
property Version^ Version {
    Version^ get ();
}

Field Value

The version.

See Also

FieldChange Class
Sitecore.Data.Items Namespace


FieldChangeList Class

[image]

Sitecore 6.4.1 API
FieldChangeList Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FieldChangeList : IEnumerable
Visual Basic
Public Class FieldChangeList _
    Implements IEnumerable
Visual C++
public ref class FieldChangeList : IEnumerable

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..FieldChangeList

See Also

FieldChangeList Members
Sitecore.Data.Items Namespace


FieldChangeList Members

[image] [image]

Sitecore 6.4.1 API
FieldChangeList Members
FieldChangeList Class Constructors Methods Properties See Also Send Feedback

The FieldChangeList type exposes the following members.

Constructors

 | Name | Description
Public method | FieldChangeList | Initializes a new instance of the FieldChangeList class

Methods

 | Name | Description
Public method | Contains | Determines whether the list of changed fields contains the specified field id.
Public method | ContainsAnyOf | Determines whether the list of changed fields contains any of the specified field ids.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the count.
Public property | Item | Gets or sets the FieldChange with the specified field ID.
Public property | SyncRoot | Gets the sync root.

See Also

FieldChangeList Class
Sitecore.Data.Items Namespace


FieldChangeList Constructor

[image]

Sitecore 6.4.1 API
FieldChangeList Constructor
FieldChangeList Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FieldChangeList()
Visual Basic
Public Sub New
Visual C++
public:
FieldChangeList()

See Also

FieldChangeList Class
Sitecore.Data.Items Namespace


FieldChangeList Methods

[image] [image]

Sitecore 6.4.1 API
FieldChangeList Methods
FieldChangeList Class See Also Send Feedback

The FieldChangeList type exposes the following members.

Methods

 | Name | Description
Public method | Contains | Determines whether the list of changed fields contains the specified field id.
Public method | ContainsAnyOf | Determines whether the list of changed fields contains any of the specified field ids.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldChangeList Class
Sitecore.Data.Items Namespace


ContainsAnyOf Method

[image]

Sitecore 6.4.1 API
FieldChangeList..::..ContainsAnyOf Method
FieldChangeList Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ContainsAnyOf(
    params ID[] fieldIds
)
Visual Basic
Public Function ContainsAnyOf ( _
    ParamArray fieldIds As ID() _
) As Boolean
Visual C++
public:
bool ContainsAnyOf(
    ... array<ID^>^ fieldIds
)

Parameters

fieldIds
Type: array< Sitecore.Data..::..ID >[]()[][]
The field ids.

Return Value

true if any of the field ids are contained; otherwise, false.

See Also

FieldChangeList Class
Sitecore.Data.Items Namespace


GetEnumerator Method

[image]

Sitecore 6.4.1 API
FieldChangeList..::..GetEnumerator Method
FieldChangeList Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator() sealed

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

FieldChangeList Class
Sitecore.Data.Items Namespace


FieldChangeList Properties

[image] [image]

Sitecore 6.4.1 API
FieldChangeList Properties
FieldChangeList Class See Also Send Feedback

The FieldChangeList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the count.
Public property | Item | Gets or sets the FieldChange with the specified field ID.
Public property | SyncRoot | Gets the sync root.

See Also

FieldChangeList Class
Sitecore.Data.Items Namespace


Count Property

[image]

Sitecore 6.4.1 API
FieldChangeList..::..Count Property
FieldChangeList Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
property int Count {
    int get ();
}

Field Value

The count.

See Also

FieldChangeList Class
Sitecore.Data.Items Namespace


Item Property

[image]

Sitecore 6.4.1 API
FieldChangeList..::..Item Property
FieldChangeList Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FieldChange this[
    ID fieldID
] { get; set; }
Visual Basic
Public Default Property Item ( _
    fieldID As ID _
) As FieldChange
    Get
    Set
Visual C++
public:
property FieldChange^ default[ID^ fieldID] {
    FieldChange^ get (ID^ fieldID);
    void set (ID^ fieldID, FieldChange^ value);
}

Parameters

fieldID
Type: Sitecore.Data..::..ID

Field Value

The FieldChange.

See Also

FieldChangeList Class
Sitecore.Data.Items Namespace


FileDropAreaMediaFolderItem Class

[image]

Sitecore 6.4.1 API
FileDropAreaMediaFolderItem Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FileDropAreaMediaFolderItem : CustomItem
Visual Basic
Public Class FileDropAreaMediaFolderItem _
    Inherits CustomItem
Visual C++
public ref class FileDropAreaMediaFolderItem : public CustomItem

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..CustomItemBase
Sitecore.Data.Items..::..CustomItem
Sitecore.Data.Items..::..FileDropAreaMediaFolderItem

See Also

FileDropAreaMediaFolderItem Members
Sitecore.Data.Items Namespace


FileDropAreaMediaFolderItem Constructor

[image]

Sitecore 6.4.1 API
FileDropAreaMediaFolderItem Constructor
FileDropAreaMediaFolderItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FileDropAreaMediaFolderItem(
    Item innerItem
)
Visual Basic
Public Sub New ( _
    innerItem As Item _
)
Visual C++
public:
FileDropAreaMediaFolderItem(
    Item^ innerItem
)

Parameters

innerItem
Type: Sitecore.Data.Items..::..Item
Sitecore Inner item.

See Also

FileDropAreaMediaFolderItem Class
Sitecore.Data.Items Namespace


FileDropAreaMediaFolderItem Fields

[image] [image]

Sitecore 6.4.1 API
FileDropAreaMediaFolderItem Fields
FileDropAreaMediaFolderItem Class See Also Send Feedback

The FileDropAreaMediaFolderItem type exposes the following members.

Fields

Name | Description
FileDropAreaMediaFolderTemplateID | Template ID for FDA media folder item.
ReferrersFieldID | The ID for the field that stores Referrers data.

See Also

FileDropAreaMediaFolderItem Class
Sitecore.Data.Items Namespace


FileDropAreaMediaFolderTemplateID Field

[image]

Sitecore 6.4.1 API
FileDropAreaMediaFolderItem..::..FileDropAreaMediaFolderTemplateID Field
FileDropAreaMediaFolderItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly ID FileDropAreaMediaFolderTemplateID
Visual Basic
Public Shared ReadOnly FileDropAreaMediaFolderTemplateID As ID
Visual C++
public:
static initonly ID^ FileDropAreaMediaFolderTemplateID

See Also

FileDropAreaMediaFolderItem Class
Sitecore.Data.Items Namespace


ReferrersFieldID Field

[image]

Sitecore 6.4.1 API
FileDropAreaMediaFolderItem..::..ReferrersFieldID Field
FileDropAreaMediaFolderItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly ID ReferrersFieldID
Visual Basic
Public Shared ReadOnly ReferrersFieldID As ID
Visual C++
public:
static initonly ID^ ReferrersFieldID

See Also

FileDropAreaMediaFolderItem Class
Sitecore.Data.Items Namespace


FileDropAreaMediaFolderItem Methods

[image] [image]

Sitecore 6.4.1 API
FileDropAreaMediaFolderItem Methods
FileDropAreaMediaFolderItem Class See Also Send Feedback

The FileDropAreaMediaFolderItem type exposes the following members.

Methods

 | Name | Description
Public method | AddReferrer | Adds the referrer.
Public method | BeginEdit | Begins editing the item. (Inherited from CustomItemBase.)
Protected method | BuildReferrerLink | Builds the referrer link.
 | ConvertToFDAMediaFolder | Converts item to FDA media folder.
Public method | EndEdit | Ends editing the item. (Inherited from CustomItemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExtractReferrersCollection | Extracts the referrers collection from Referrers field.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetReferrerString | Gets the referrer string.
Public method | GetRegisteredReferrers | Gets the registered referrers.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsFileDropAreaMediaFolder | Determines whether specified item is file drop area media folder.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetReferrers | Sets the referrers.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileDropAreaMediaFolderItem Class
Sitecore.Data.Items Namespace


AddReferrer Method

[image]

Sitecore 6.4.1 API
FileDropAreaMediaFolderItem..::..AddReferrer Method
FileDropAreaMediaFolderItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void AddReferrer(
    FileDropAreaField field
)
Visual Basic
Public Overridable Sub AddReferrer ( _
    field As FileDropAreaField _
)
Visual C++
public:
virtual void AddReferrer(
    FileDropAreaField^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..FileDropAreaField
The referrer.

See Also

FileDropAreaMediaFolderItem Class
Sitecore.Data.Items Namespace


BuildReferrerLink Method

[image]

Sitecore 6.4.1 API
FileDropAreaMediaFolderItem..::..BuildReferrerLink Method
FileDropAreaMediaFolderItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected ItemLink BuildReferrerLink(
    string data
)
Visual Basic
Protected Function BuildReferrerLink ( _
    data As String _
) As ItemLink
Visual C++
protected:
ItemLink^ BuildReferrerLink(
    String^ data
)

Parameters

data
Type: System..::..String
The serialized data.

Return Value

The Referrer.

See Also

FileDropAreaMediaFolderItem Class
Sitecore.Data.Items Namespace


ConvertToFDAMediaFolder Method

[image]

Sitecore 6.4.1 API
FileDropAreaMediaFolderItem..::..ConvertToFDAMediaFolder Method
FileDropAreaMediaFolderItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static FileDropAreaMediaFolderItem ConvertToFDAMediaFolder(
    Item item,
    FileDropAreaField field
)
Visual Basic
Public Shared Function ConvertToFDAMediaFolder ( _
    item As Item, _
    field As FileDropAreaField _
) As FileDropAreaMediaFolderItem
Visual C++
public:
static FileDropAreaMediaFolderItem^ ConvertToFDAMediaFolder(
    Item^ item,
    FileDropAreaField^ field
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item to be converted.
field
Type: Sitecore.Data.Fields..::..FileDropAreaField
The field.

Return Value

The converted item.

See Also

FileDropAreaMediaFolderItem Class
Sitecore.Data.Items Namespace


ExtractReferrersCollection Method

[image]

Sitecore 6.4.1 API
FileDropAreaMediaFolderItem..::..ExtractReferrersCollection Method
FileDropAreaMediaFolderItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual List<string> ExtractReferrersCollection()
Visual Basic
Protected Overridable Function ExtractReferrersCollection As List(Of String)
Visual C++
protected:
virtual List<String^>^ ExtractReferrersCollection()

Return Value

The list of referrers stored in the Referrers field.

See Also

FileDropAreaMediaFolderItem Class
Sitecore.Data.Items Namespace


GetReferrerString Method

[image]

Sitecore 6.4.1 API
FileDropAreaMediaFolderItem..::..GetReferrerString Method
FileDropAreaMediaFolderItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string GetReferrerString(
    FileDropAreaField field
)
Visual Basic
Protected Overridable Function GetReferrerString ( _
    field As FileDropAreaField _
) As String
Visual C++
protected:
virtual String^ GetReferrerString(
    FileDropAreaField^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..FileDropAreaField
The FDA field.

Return Value

The serialized referrer string.

See Also

FileDropAreaMediaFolderItem Class
Sitecore.Data.Items Namespace


GetRegisteredReferrers Method

[image]

Sitecore 6.4.1 API
FileDropAreaMediaFolderItem..::..GetRegisteredReferrers Method
FileDropAreaMediaFolderItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual List<ItemLink> GetRegisteredReferrers()
Visual Basic
Public Overridable Function GetRegisteredReferrers As List(Of ItemLink)
Visual C++
public:
virtual List<ItemLink^>^ GetRegisteredReferrers()

Return Value

The registered referrers list.

See Also

FileDropAreaMediaFolderItem Class
Sitecore.Data.Items Namespace


FileDropAreaMediaFolderItem Properties

[image] [image]

Sitecore 6.4.1 API
FileDropAreaMediaFolderItem Properties
FileDropAreaMediaFolderItem Class See Also Send Feedback

The FileDropAreaMediaFolderItem type exposes the following members.

Properties

 | Name | Description
Public property | Database | Gets the database. (Inherited from CustomItemBase.)
Public property | DisplayName | Gets the display name. (Inherited from CustomItemBase.)
Public property | Icon | Gets the icon. (Inherited from CustomItemBase.)
Public property | ID | Gets the ID. (Inherited from CustomItemBase.)
Public property | InnerItem | Gets the inner item. (Inherited from CustomItemBase.)
Public property | Item[([( Int32])]) | Gets or sets the value of a specified field. (Inherited from CustomItem.)
Public property | Item[([( String])]) | Gets or sets the value of a specified field. (Inherited from CustomItem.)
Public property | Item[([( ID])]) | Gets or sets the value of a specified field. (Inherited from CustomItem.)
Public property | Name | Gets the name. (Inherited from CustomItemBase.)

See Also

FileDropAreaMediaFolderItem Class
Sitecore.Data.Items Namespace


Item Class

[image]

Sitecore 6.4.1 API
Item Class
Members Example See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Item : BaseItem, ISecurable
Visual Basic
Public Class Item _
    Inherits BaseItem _
    Implements ISecurable
Visual C++
public ref class Item : public BaseItem,
    ISecurable

Remarks

The item is language-specific and represents a single version.

The Item class is a top-level class that provide access to many operations within the system.

An item is usually obtained directly from a database.

Examples

Item item = Sitecore.Context.Database["/sitecore/content/Home"];

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..BaseItem
Sitecore.Data.Items..::..Item

See Also

Item Members
Sitecore.Data.Items Namespace


Item Members

[image] [image]

Sitecore 6.4.1 API
Item Members
Item Class Constructors Methods Properties See Also Send Feedback

The Item type exposes the following members.

Constructors

 | Name | Description
Public method | Item | Initializes a new instance of the Item class.

Methods

 | Name | Description
Public method | Add(String, BranchId) | Creates an item under this item from a master ID.
Public method | Add(String, BranchItem) | Creates an item under this item from a master.
Public method | Add(String, TemplateItem) | Creates an item under this item from a template.
Public method | Add(String, TemplateID) | Creates an item under this item from a template ID.
Public method | BeginEdit | Obsolete. Marks the beginning of an editing operation.
Public method | ChangeTemplate | Changes the template of the item.
Public method | Clone(Item) | Clones the specified item.
Public method | Clone(ID, Database) | Clones the specified item.
Public method | CloneTo(Item) | Clones the item to the given destination.
Public method | CloneTo(Item, Boolean) | Clones the item to the given destination.
Public method | CloneTo(Item, String, Boolean) | Clones the item to the given destination.
Public method | CopyTo(Item, String) | Copies an item to another location.
Public method | CopyTo(Item, String, ID, Boolean) | Copies an item to another location.
Public method | Delete | Deletes the item.
Public method | DeleteChildren | Deletes all child items to which the current user has delete access.
Public method | Duplicate()()()() | Duplicates the item.
Public method | Duplicate(String) | Duplicates the item.
Public method | EndEdit | Obsolete. Ends an edit operation.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChildren()()()() | Gets the children.
Public method | GetChildren(ChildListOptions) | Gets the children.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOuterXml | Gets the outer XML of the item.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueId | Gets a unique id.
 | IsEmpty | Gets a value that indicates if the item is empty (i.e. has no versions).
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveTo | Moves the item to another location.
Public method | Paste | Inserts new items from an XML string.
Public method | PasteItem | Inserts new items from an XML string.
Public method | Recycle | Puts the item in the Recycle Bin database.
Public method | RecycleChildren | Deletes all child items to which the current user has delete access.
Public method | Reload | Reloads the item from storage.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Access | Provides access to the Access framework.
Public property | Appearance | Provides access to appearance information.
Public property | Axes | Provides access to functions that retrieve other item relative to this item.
Public property | Branch | Gets the branch from which the item was created.
Public property | Branches | Gets a list of branches that are allowed to be created under this item.
Public property | BranchId | Gets the id of the branch that was used to create this item.
Public property | Children | Gets a list of child items.
Public property | Database | Gets the database.
Public property | DisplayName | Gets the language-specific display name.
Public property | Editing | Provides access to the publishing framework.
Public property | Empty | Gets a value indicating whether this Item is empty (i.e. has no versions in any language).
Public property | Fields | Gets the list of fields. (Overrides BaseItem..::..Fields.)
Public property | HasChildren | Gets a value that indicates if the item has child items.
Public property | Help | Provides access to help information.
Public property | ID | Gets the ID of the item.
Public property | InnerData | Gets the inner data.
Public property | IsClone | Gets a value indicating whether this instance is clone.
Public property | IsEditing | Obsolete. Gets a value that indicates if the item is being edited.
Public property | Item[([( Int32])]) | Gets or sets the value of a specified field. (Inherited from BaseItem.)
Public property | Item[([( String])]) | Gets or sets the value of the field with the specified name. (Inherited from BaseItem.)
Public property | Item[([( ID])]) | Gets or sets the value of a specified field. (Inherited from BaseItem.)
Public property | Key | Gets the key of item.
Public property | Language | Get the language of the item.
Public property | Languages | Gets a list of languages that the item has content in.
Public property | Links | Provides access to the Links framework.
Public property | Locking | Provides to the Locking framework.
Public property | Master | Obsolete. Gets the master from which the item was created.
Public property | MasterID | Obsolete. Gets the ID of the master that was used to create this item.
Public property | Masters | Obsolete. Gets a list of masters that are allowed to be created under this item.
Public property | Modified | Gets a value that indicates if the item has been modified.
Public property | Name | Gets or sets the name.
Public property | OriginatorId | Gets the originator id.
Public property | Parent | Gets the parent item.
Public property | ParentID | Gets the ID of the parent item.
Public property | Paths | Provides access to Path information.
Public property | Publishing | Provides access to the publishing framework.
Public property | RuntimeSettings | Provides access to miscellaneous runtime information.
Public property | Security | Gets the access rules defined for the item.
Public property | Source | Gets the source.
Public property | SourceUri | Gets the source URI.
Public property | State | Gets the state.
Public property | Statistics | Provides access to statistical information.
Public property | SyncRoot | Gets the sync root.
Public property | Template | Gets the template of the item.
Public property | TemplateID | Gets the ID of the template.
Public property | TemplateName | Gets the name of the template.
Public property | Uri | Gets an URI for the item.
Public property | Version | Gets the version represented by this item.
Public property | Versions | Provides access to different versions of the item.
Public property | Visualization | Provides access to the visible representations of the item.

See Also

Item Class
Sitecore.Data.Items Namespace


Item Constructor

[image]

Sitecore 6.4.1 API
Item Constructor
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item(
    ID itemID,
    ItemData data,
    Database database
)
Visual Basic
Public Sub New ( _
    itemID As ID, _
    data As ItemData, _
    database As Database _
)
Visual C++
public:
Item(
    ID^ itemID,
    ItemData^ data,
    Database^ database
)

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.
data
Type: Sitecore.Data..::..ItemData
The data.
database
Type: Sitecore.Data..::..Database
The database.

See Also

Item Class
Sitecore.Data.Items Namespace


Item Methods

[image] [image]

Sitecore 6.4.1 API
Item Methods
Item Class See Also Send Feedback

The Item type exposes the following members.

Methods

 | Name | Description
Public method | Add(String, BranchId) | Creates an item under this item from a master ID.
Public method | Add(String, BranchItem) | Creates an item under this item from a master.
Public method | Add(String, TemplateItem) | Creates an item under this item from a template.
Public method | Add(String, TemplateID) | Creates an item under this item from a template ID.
Public method | BeginEdit | Obsolete. Marks the beginning of an editing operation.
Public method | ChangeTemplate | Changes the template of the item.
Public method | Clone(Item) | Clones the specified item.
Public method | Clone(ID, Database) | Clones the specified item.
Public method | CloneTo(Item) | Clones the item to the given destination.
Public method | CloneTo(Item, Boolean) | Clones the item to the given destination.
Public method | CloneTo(Item, String, Boolean) | Clones the item to the given destination.
Public method | CopyTo(Item, String) | Copies an item to another location.
Public method | CopyTo(Item, String, ID, Boolean) | Copies an item to another location.
Public method | Delete | Deletes the item.
Public method | DeleteChildren | Deletes all child items to which the current user has delete access.
Public method | Duplicate()()()() | Duplicates the item.
Public method | Duplicate(String) | Duplicates the item.
Public method | EndEdit | Obsolete. Ends an edit operation.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChildren()()()() | Gets the children.
Public method | GetChildren(ChildListOptions) | Gets the children.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOuterXml | Gets the outer XML of the item.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueId | Gets a unique id.
 | IsEmpty | Gets a value that indicates if the item is empty (i.e. has no versions).
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveTo | Moves the item to another location.
Public method | Paste | Inserts new items from an XML string.
Public method | PasteItem | Inserts new items from an XML string.
Public method | Recycle | Puts the item in the Recycle Bin database.
Public method | RecycleChildren | Deletes all child items to which the current user has delete access.
Public method | Reload | Reloads the item from storage.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Item Class
Sitecore.Data.Items Namespace


Add Method (String, BranchId)

[image]

Sitecore 6.4.1 API
Item..::..Add Method (String, BranchId)
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Add(
    string name,
    BranchId branchId
)
Visual Basic
Public Function Add ( _
    name As String, _
    branchId As BranchId _
) As Item
Visual C++
public:
Item^ Add(
    String^ name,
    BranchId branchId
)

Parameters

name
Type: System..::..String
The name.
branchId
Type: Sitecore.Data..::..BranchId
The master ID.

Return Value

The add.

See Also

Item Class
Add Overload
Sitecore.Data.Items Namespace


Add Method (String, BranchItem)

[image]

Sitecore 6.4.1 API
Item..::..Add Method (String, BranchItem)
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Add(
    string name,
    BranchItem branch
)
Visual Basic
Public Function Add ( _
    name As String, _
    branch As BranchItem _
) As Item
Visual C++
public:
Item^ Add(
    String^ name,
    BranchItem^ branch
)

Parameters

name
Type: System..::..String
The name.
branch
Type: Sitecore.Data.Items..::..BranchItem
The master.

Return Value

The add.

See Also

Item Class
Add Overload
Sitecore.Data.Items Namespace


Add Method (String, TemplateItem)

[image]

Sitecore 6.4.1 API
Item..::..Add Method (String, TemplateItem)
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Add(
    string name,
    TemplateItem template
)
Visual Basic
Public Function Add ( _
    name As String, _
    template As TemplateItem _
) As Item
Visual C++
public:
Item^ Add(
    String^ name,
    TemplateItem^ template
)

Parameters

name
Type: System..::..String
The name.
template
Type: Sitecore.Data.Items..::..TemplateItem
The template.

Return Value

The add.

See Also

Item Class
Add Overload
Sitecore.Data.Items Namespace


BeginEdit Method

[image]

Sitecore 6.4.1 API
Item..::..BeginEdit Method
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use Item.Editing.BeginEdit instead.")]
public void BeginEdit()
Visual Basic
<ObsoleteAttribute("Use Item.Editing.BeginEdit instead.")> _
Public Sub BeginEdit
Visual C++
[ObsoleteAttribute(L"Use Item.Editing.BeginEdit instead.")]
public:
void BeginEdit()

Remarks

This method is deprecated from version 5.1.

See Also

Item Class
Sitecore.Data.Items Namespace


ChangeTemplate Method

[image]

Sitecore 6.4.1 API
Item..::..ChangeTemplate Method
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void ChangeTemplate(
    TemplateItem template
)
Visual Basic
Public Sub ChangeTemplate ( _
    template As TemplateItem _
)
Visual C++
public:
void ChangeTemplate(
    TemplateItem^ template
)

Parameters

template
Type: Sitecore.Data.Items..::..TemplateItem
The template.

Remarks

Field values are transfered by name.

See Also

Item Class
Sitecore.Data.Items Namespace


Clone Method

[image] [image]

Sitecore 6.4.1 API
Item..::..Clone Method
Item Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clone(Item) | Clones the specified item.
Public method | Clone(ID, Database) | Clones the specified item.

See Also

Item Class
Item Members
Sitecore.Data.Items Namespace


Clone Method (Item)

[image]

Sitecore 6.4.1 API
Item..::..Clone Method (Item)
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Clone(
    Item item
)
Visual Basic
Public Function Clone ( _
    item As Item _
) As Item
Visual C++
public:
Item^ Clone(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Items.Item.Clone(Sitecore.Data.Items.Item)"]

See Also

Item Class
Clone Overload
Sitecore.Data.Items Namespace


Clone Method (ID, Database)

[image]

Sitecore 6.4.1 API
Item..::..Clone Method (ID, Database)
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Clone(
    ID cloneID,
    Database ownerDatabase
)
Visual Basic
Public Function Clone ( _
    cloneID As ID, _
    ownerDatabase As Database _
) As Item
Visual C++
public:
Item^ Clone(
    ID^ cloneID,
    Database^ ownerDatabase
)

Parameters

cloneID
Type: Sitecore.Data..::..ID
The clone ID.
ownerDatabase
Type: Sitecore.Data..::..Database
The database that is to own the clone.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Items.Item.Clone(Sitecore.Data.ID,Sitecore.Data.Database)"]

See Also

Item Class
Clone Overload
Sitecore.Data.Items Namespace


CloneTo Method

[image] [image]

Sitecore 6.4.1 API
Item..::..CloneTo Method
Item Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CloneTo(Item) | Clones the item to the given destination.
Public method | CloneTo(Item, Boolean) | Clones the item to the given destination.
Public method | CloneTo(Item, String, Boolean) | Clones the item to the given destination.

See Also

Item Class
Item Members
Sitecore.Data.Items Namespace


CloneTo Method (Item)

[image]

Sitecore 6.4.1 API
Item..::..CloneTo Method (Item)
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item CloneTo(
    Item destination
)
Visual Basic
Public Function CloneTo ( _
    destination As Item _
) As Item
Visual C++
public:
Item^ CloneTo(
    Item^ destination
)

Parameters

destination
Type: Sitecore.Data.Items..::..Item
The destination.

Return Value

The clone.

See Also

Item Class
CloneTo Overload
Sitecore.Data.Items Namespace


CloneTo Method (Item, Boolean)

[image]

Sitecore 6.4.1 API
Item..::..CloneTo Method (Item, Boolean)
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item CloneTo(
    Item destination,
    bool deep
)
Visual Basic
Public Function CloneTo ( _
    destination As Item, _
    deep As Boolean _
) As Item
Visual C++
public:
Item^ CloneTo(
    Item^ destination,
    bool deep
)

Parameters

destination
Type: Sitecore.Data.Items..::..Item
The destination.
deep
Type: System..::..Boolean
if set to true clone descendants too.

Return Value

The clone.

See Also

Item Class
CloneTo Overload
Sitecore.Data.Items Namespace


CloneTo Method (Item, String, Boolean)

[image]

Sitecore 6.4.1 API
Item..::..CloneTo Method (Item, String, Boolean)
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item CloneTo(
    Item destination,
    string name,
    bool deep
)
Visual Basic
Public Function CloneTo ( _
    destination As Item, _
    name As String, _
    deep As Boolean _
) As Item
Visual C++
public:
Item^ CloneTo(
    Item^ destination,
    String^ name,
    bool deep
)

Parameters

destination
Type: Sitecore.Data.Items..::..Item
The destination.
name
Type: System..::..String
The clone name.
deep
Type: System..::..Boolean
if set to true clone descendants too.

Return Value

The created clone.

See Also

Item Class
CloneTo Overload
Sitecore.Data.Items Namespace


CopyTo Method

[image] [image]

Sitecore 6.4.1 API
Item..::..CopyTo Method
Item Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(Item, String) | Copies an item to another location.
Public method | CopyTo(Item, String, ID, Boolean) | Copies an item to another location.

See Also

Item Class
Item Members
Sitecore.Data.Items Namespace


CopyTo Method (Item, String)

[image]

Sitecore 6.4.1 API
Item..::..CopyTo Method (Item, String)
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item CopyTo(
    Item destination,
    string copyName
)
Visual Basic
Public Function CopyTo ( _
    destination As Item, _
    copyName As String _
) As Item
Visual C++
public:
Item^ CopyTo(
    Item^ destination,
    String^ copyName
)

Parameters

destination
Type: Sitecore.Data.Items..::..Item
The destination item (i.e. the item that will serve as the parent of the copy).
copyName
Type: System..::..String
Name of the copy.

Return Value

The copied item (i.e. the root of the copied subtree).

Remarks

Copies an item and all of its descendants to another location in the content tree.

All item IDs are changed before the copy is merged into the content tree.

See Also

Item Class
CopyTo Overload
Sitecore.Data.Items Namespace


CopyTo Method (Item, String, ID, Boolean)

[image]

Sitecore 6.4.1 API
Item..::..CopyTo Method (Item, String, ID, Boolean)
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item CopyTo(
    Item destination,
    string copyName,
    ID copyID,
    bool deep
)
Visual Basic
Public Function CopyTo ( _
    destination As Item, _
    copyName As String, _
    copyID As ID, _
    deep As Boolean _
) As Item
Visual C++
public:
Item^ CopyTo(
    Item^ destination,
    String^ copyName,
    ID^ copyID,
    bool deep
)

Parameters

destination
Type: Sitecore.Data.Items..::..Item
The destination item (i.e. the item that will serve as the parent of the copy).
copyName
Type: System..::..String
Name of the copy.
copyID
Type: Sitecore.Data..::..ID
The copy ID.
deep
Type: System..::..Boolean
Indicates if child items are copied.

Return Value

The copied item (i.e. the root of the copied subtree).

Remarks

Copies an item to another location in the content tree.

All item IDs are changed before the copy is merged into the content tree.

See Also

Item Class
CopyTo Overload
Sitecore.Data.Items Namespace


Delete Method

[image]

Sitecore 6.4.1 API
Item..::..Delete Method
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Delete()
Visual Basic
Public Sub Delete
Visual C++
public:
void Delete()

See Also

Item Class
Sitecore.Data.Items Namespace


DeleteChildren Method

[image]

Sitecore 6.4.1 API
Item..::..DeleteChildren Method
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int DeleteChildren()
Visual Basic
Public Function DeleteChildren As Integer
Visual C++
public:
int DeleteChildren()

Return Value

The number of child items deleted.

See Also

Item Class
Sitecore.Data.Items Namespace


Duplicate Method

[image] [image]

Sitecore 6.4.1 API
Item..::..Duplicate Method
Item Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Duplicate()()()() | Duplicates the item.
Public method | Duplicate(String) | Duplicates the item.

See Also

Item Class
Item Members
Sitecore.Data.Items Namespace


Duplicate Method

[image]

Sitecore 6.4.1 API
Item..::..Duplicate Method
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Duplicate()
Visual Basic
Public Function Duplicate As Item
Visual C++
public:
Item^ Duplicate()

Return Value

The new item.

Remarks

Creates a copy of the item and all of its child items under the same parent item. All new items will have new IDs assigned.

See Also

Item Class
Duplicate Overload
Sitecore.Data.Items Namespace


Duplicate Method (String)

[image]

Sitecore 6.4.1 API
Item..::..Duplicate Method (String)
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Duplicate(
    string copyName
)
Visual Basic
Public Function Duplicate ( _
    copyName As String _
) As Item
Visual C++
public:
Item^ Duplicate(
    String^ copyName
)

Parameters

copyName
Type: System..::..String
Name of the copy.

Return Value

The new item.

Remarks

Creates a copy of the item and all of its subitems under the same parent item. All new items will have new IDs assigned

See Also

Item Class
Duplicate Overload
Sitecore.Data.Items Namespace


EndEdit Method

[image]

Sitecore 6.4.1 API
Item..::..EndEdit Method
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use Item.Editing.EndEdit instead.")]
public bool EndEdit()
Visual Basic
<ObsoleteAttribute("Use Item.Editing.EndEdit instead.")> _
Public Function EndEdit As Boolean
Visual C++
[ObsoleteAttribute(L"Use Item.Editing.EndEdit instead.")]
public:
bool EndEdit()

Return Value

The edit.

Remarks

This method is deprecated from version 5.1.

See Also

Item Class
Sitecore.Data.Items Namespace


GetChildren Method

[image] [image]

Sitecore 6.4.1 API
Item..::..GetChildren Method
Item Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildren()()()() | Gets the children.
Public method | GetChildren(ChildListOptions) | Gets the children.

See Also

Item Class
Item Members
Sitecore.Data.Items Namespace


GetChildren Method

[image]

Sitecore 6.4.1 API
Item..::..GetChildren Method
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ChildList GetChildren()
Visual Basic
Public Function GetChildren As ChildList
Visual C++
public:
ChildList^ GetChildren()

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Items.Item.GetChildren"]

See Also

Item Class
GetChildren Overload
Sitecore.Data.Items Namespace


GetChildren Method (ChildListOptions)

[image]

Sitecore 6.4.1 API
Item..::..GetChildren Method (ChildListOptions)
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ChildList GetChildren(
    ChildListOptions options
)
Visual Basic
Public Function GetChildren ( _
    options As ChildListOptions _
) As ChildList
Visual C++
public:
ChildList^ GetChildren(
    ChildListOptions options
)

Parameters

options
Type: Sitecore.Collections..::..ChildListOptions
The options.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Items.Item.GetChildren(Sitecore.Collections.ChildListOptions)"]

See Also

Item Class
GetChildren Overload
Sitecore.Data.Items Namespace


GetOuterXml Method

[image]

Sitecore 6.4.1 API
Item..::..GetOuterXml Method
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetOuterXml(
    bool includeSubitems
)
Visual Basic
Public Function GetOuterXml ( _
    includeSubitems As Boolean _
) As String
Visual C++
public:
String^ GetOuterXml(
    bool includeSubitems
)

Parameters

includeSubitems
Type: System..::..Boolean
if set to true the XML includes subitems.

Return Value

The get outer xml.

See Also

Item Class
Sitecore.Data.Items Namespace


GetUniqueId Method

[image]

Sitecore 6.4.1 API
Item..::..GetUniqueId Method
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetUniqueId()
Visual Basic
Public Function GetUniqueId As String
Visual C++
public:
virtual String^ GetUniqueId() sealed

Return Value

The get unique id.

Implements

ISecurable..::..GetUniqueId()()()()

Remarks

The id must be unique enough to be used in a global cache.

For example, an Item might implement this as Database.Name + ID.

The resulting key used by the AuthorizationManager might therefore be typeof(Item).FullName + divider + Database.Name + ID.

See Also

Item Class
Sitecore.Data.Items Namespace


MoveTo Method

[image]

Sitecore 6.4.1 API
Item..::..MoveTo Method
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void MoveTo(
    Item destination
)
Visual Basic
Public Sub MoveTo ( _
    destination As Item _
)
Visual C++
public:
void MoveTo(
    Item^ destination
)

Parameters

destination
Type: Sitecore.Data.Items..::..Item
Destination item (i.e. the item that will serve as the new parent of the item).

Remarks

Moves an item and all of its descendants to another location in the content tree.

See Also

Item Class
Sitecore.Data.Items Namespace


Paste Method

[image]

Sitecore 6.4.1 API
Item..::..Paste Method
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Paste(
    string xml,
    bool changeIDs,
    PasteMode mode
)
Visual Basic
Public Sub Paste ( _
    xml As String, _
    changeIDs As Boolean, _
    mode As PasteMode _
)
Visual C++
public:
void Paste(
    String^ xml,
    bool changeIDs,
    PasteMode mode
)

Parameters

xml
Type: System..::..String
The XML.
changeIDs
Type: System..::..Boolean
if set to true ids should be changed.
mode
Type: Sitecore.Data.Items..::..PasteMode
The mode.

See Also

Item Class
Sitecore.Data.Items Namespace


PasteItem Method

[image]

Sitecore 6.4.1 API
Item..::..PasteItem Method
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item PasteItem(
    string xml,
    bool changeIDs,
    PasteMode mode
)
Visual Basic
Public Function PasteItem ( _
    xml As String, _
    changeIDs As Boolean, _
    mode As PasteMode _
) As Item
Visual C++
public:
Item^ PasteItem(
    String^ xml,
    bool changeIDs,
    PasteMode mode
)

Parameters

xml
Type: System..::..String
The XML.
changeIDs
Type: System..::..Boolean
if set to true ids should be changed.
mode
Type: Sitecore.Data.Items..::..PasteMode
The mode.

Return Value

The item.

See Also

Item Class
Sitecore.Data.Items Namespace


Recycle Method

[image]

Sitecore 6.4.1 API
Item..::..Recycle Method
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Guid Recycle()
Visual Basic
Public Function Recycle As Guid
Visual C++
public:
Guid Recycle()

Return Value

The id of archive entry. If an archive entry hasn't been created, the return value will be Guid.Empty.

See Also

Item Class
Sitecore.Data.Items Namespace


Reload Method

[image]

Sitecore 6.4.1 API
Item..::..Reload Method
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Reload()
Visual Basic
Public Sub Reload
Visual C++
public:
void Reload()

See Also

Item Class
Sitecore.Data.Items Namespace


Access Property

[image]

Sitecore 6.4.1 API
Item..::..Access Property
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemAccess Access { get; }
Visual Basic
Public ReadOnly Property Access As ItemAccess
    Get
Visual C++
public:
property ItemAccess^ Access {
    ItemAccess^ get ();
}

Field Value

The access.

Remarks

The Access framework determine user rights from security and workflow settings.

See Also

Item Class
Sitecore.Data.Items Namespace


Appearance Property

[image]

Sitecore 6.4.1 API
Item..::..Appearance Property
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemAppearance Appearance { get; }
Visual Basic
Public ReadOnly Property Appearance As ItemAppearance
    Get
Visual C++
public:
property ItemAppearance^ Appearance {
    ItemAppearance^ get ();
}

Field Value

The appearance.

Remarks

Appearance information includes CSS style and an icon.

See Also

Item Class
Sitecore.Data.Items Namespace


Axes Property

[image]

Sitecore 6.4.1 API
Item..::..Axes Property
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemAxes Axes { get; }
Visual Basic
Public ReadOnly Property Axes As ItemAxes
    Get
Visual C++
public:
property ItemAxes^ Axes {
    ItemAxes^ get ();
}

Field Value

The axes.

See Also

Item Class
Sitecore.Data.Items Namespace


Branch Property

[image]

Sitecore 6.4.1 API
Item..::..Branch Property
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BranchItem Branch { get; }
Visual Basic
Public ReadOnly Property Branch As BranchItem
    Get
Visual C++
public:
property BranchItem^ Branch {
    BranchItem^ get ();
}

Field Value

The branch.

See Also

Item Class
Sitecore.Data.Items Namespace


Branches Property

[image]

Sitecore 6.4.1 API
Item..::..Branches Property
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BranchItem[] Branches { get; }
Visual Basic
Public ReadOnly Property Branches As BranchItem()
    Get
Visual C++
public:
property array<BranchItem^>^ Branches {
    array<BranchItem^>^ get ();
}

Field Value

The branches.

See Also

Item Class
Sitecore.Data.Items Namespace


BranchId Property

[image]

Sitecore 6.4.1 API
Item..::..BranchId Property
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID BranchId { get; set; }
Visual Basic
Public Property BranchId As ID
    Get
    Set
Visual C++
public:
property ID^ BranchId {
    ID^ get ();
    void set (ID^ value);
}

Field Value

The branch ID.

See Also

Item Class
Sitecore.Data.Items Namespace


Database Property

[image]

Sitecore 6.4.1 API
Item..::..Database Property
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database Database { get; }
Visual Basic
Public ReadOnly Property Database As Database
    Get
Visual C++
public:
property Database^ Database {
    Database^ get ();
}

Field Value

The database.

Remarks

Gets the database that item resides in.

The Database class is a top-level class that provides access many other functions within the system.

See Also

Item Class
Sitecore.Data.Items Namespace


DisplayName Property

[image]

Sitecore 6.4.1 API
Item..::..DisplayName Property
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string DisplayName { get; }
Visual Basic
Public ReadOnly Property DisplayName As String
    Get
Visual C++
public:
property String^ DisplayName {
    String^ get ();
}

Field Value

The name of the display.

See Also

Item Class
Sitecore.Data.Items Namespace


Editing Property

[image]

Sitecore 6.4.1 API
Item..::..Editing Property
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemEditing Editing { get; }
Visual Basic
Public ReadOnly Property Editing As ItemEditing
    Get
Visual C++
public:
property ItemEditing^ Editing {
    ItemEditing^ get ();
}

Field Value

The editing.

See Also

Item Class
Sitecore.Data.Items Namespace


Empty Property

[image]

Sitecore 6.4.1 API
Item..::..Empty Property
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Empty { get; }
Visual Basic
Public ReadOnly Property Empty As Boolean
    Get
Visual C++
public:
property bool Empty {
    bool get ();
}

Field Value

true if empty; otherwise, false.

See Also

Item Class
Sitecore.Data.Items Namespace


Fields Property

[image]

Sitecore 6.4.1 API
Item..::..Fields Property
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override FieldCollection Fields { get; }
Visual Basic
Public Overrides ReadOnly Property Fields As FieldCollection
    Get
Visual C++
public:
virtual property FieldCollection^ Fields {
    FieldCollection^ get () override;
}

Field Value

The fields.

Remarks

The list only contains the fields that have content.

To get all fields defined by the template, use the ReadAll method on the returned list.

See Also

Item Class
Sitecore.Data.Items Namespace


Help Property

[image]

Sitecore 6.4.1 API
Item..::..Help Property
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemHelp Help { get; }
Visual Basic
Public ReadOnly Property Help As ItemHelp
    Get
Visual C++
public:
property ItemHelp^ Help {
    ItemHelp^ get ();
}

Field Value

The help.

Remarks

Help information include Short Description (ToolTip) Long Help (Description) and Help link.

See Also

Item Class
Sitecore.Data.Items Namespace


ID Property

[image]

Sitecore 6.4.1 API
Item..::..ID Property
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ID { get; }
Visual Basic
Public ReadOnly Property ID As ID
    Get
Visual C++
public:
property ID^ ID {
    ID^ get ();
}

Field Value

The ID.

See Also

Item Class
Sitecore.Data.Items Namespace


InnerData Property

[image]

Sitecore 6.4.1 API
Item..::..InnerData Property
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemData InnerData { get; }
Visual Basic
Public ReadOnly Property InnerData As ItemData
    Get
Visual C++
public:
property ItemData^ InnerData {
    ItemData^ get ();
}

Field Value

The inner data.

See Also

Item Class
Sitecore.Data.Items Namespace


IsClone Property

[image]

Sitecore 6.4.1 API
Item..::..IsClone Property
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsClone { get; }
Visual Basic
Public ReadOnly Property IsClone As Boolean
    Get
Visual C++
public:
property bool IsClone {
    bool get ();
}

Field Value

true if this instance is clone; otherwise, false.

See Also

Item Class
Sitecore.Data.Items Namespace


IsEditing Property

[image]

Sitecore 6.4.1 API
Item..::..IsEditing Property
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use Item.Editing.IsEditing instead.")]
public bool IsEditing { get; }
Visual Basic
<ObsoleteAttribute("Use Item.Editing.IsEditing instead.")> _
Public ReadOnly Property IsEditing As Boolean
    Get
Visual C++
[ObsoleteAttribute(L"Use Item.Editing.IsEditing instead.")]
public:
property bool IsEditing {
    bool get ();
}

Field Value

true if this instance is editing; otherwise, false.

Remarks

This property is deprecated from version 5.1.

See Also

Item Class
Sitecore.Data.Items Namespace


Item Property

[image] [image]

Sitecore 6.4.1 API
Item..::..Item Property
Item Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gets or sets the value of a specified field. (Inherited from BaseItem.)
Public property | Item[([( String])]) | Gets or sets the value of the field with the specified name. (Inherited from BaseItem.)
Public property | Item[([( ID])]) | Gets or sets the value of a specified field. (Inherited from BaseItem.)

See Also

Item Class
Item Members
Sitecore.Data.Items Namespace


Key Property

[image]

Sitecore 6.4.1 API
Item..::..Key Property
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Key { get; }
Visual Basic
Public ReadOnly Property Key As String
    Get
Visual C++
public:
property String^ Key {
    String^ get ();
}

Field Value

The key.

Remarks

The key is always %Name% in lowercase.

See Also

Item Class
Sitecore.Data.Items Namespace


Language Property

[image]

Sitecore 6.4.1 API
Item..::..Language Property
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Language Language { get; }
Visual Basic
Public ReadOnly Property Language As Language
    Get
Visual C++
public:
property Language^ Language {
    Language^ get ();
}

Field Value

The language.

See Also

Item Class
Sitecore.Data.Items Namespace


Languages Property

[image]

Sitecore 6.4.1 API
Item..::..Languages Property
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Language[] Languages { get; }
Visual Basic
Public ReadOnly Property Languages As Language()
    Get
Visual C++
public:
property array<Language^>^ Languages {
    array<Language^>^ get ();
}

Field Value

The languages.

See Also

Item Class
Sitecore.Data.Items Namespace


Locking Property

[image]

Sitecore 6.4.1 API
Item..::..Locking Property
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemLocking Locking { get; }
Visual Basic
Public ReadOnly Property Locking As ItemLocking
    Get
Visual C++
public:
property ItemLocking^ Locking {
    ItemLocking^ get ();
}

Field Value

The locking.

Remarks

The Locking framework ensures, if enabled, that only one user can edit an item at a time.

See Also

Item Class
Sitecore.Data.Items Namespace


MasterID Property

[image]

Sitecore 6.4.1 API
Item..::..MasterID Property
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use BranchId instead.")]
public ID MasterID { get; set; }
Visual Basic
<ObsoleteAttribute("Deprecated - Use BranchId instead.")> _
Public Property MasterID As ID
    Get
    Set
Visual C++
[ObsoleteAttribute(L"Deprecated - Use BranchId instead.")]
public:
property ID^ MasterID {
    ID^ get ();
    void set (ID^ value);
}

Field Value

The master ID.

See Also

Item Class
Sitecore.Data.Items Namespace


Masters Property

[image]

Sitecore 6.4.1 API
Item..::..Masters Property
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use Branches instead.")]
public BranchItem[] Masters { get; }
Visual Basic
<ObsoleteAttribute("Deprecated - Use Branches instead.")> _
Public ReadOnly Property Masters As BranchItem()
    Get
Visual C++
[ObsoleteAttribute(L"Deprecated - Use Branches instead.")]
public:
property array<BranchItem^>^ Masters {
    array<BranchItem^>^ get ();
}

Field Value

The masters.

See Also

Item Class
Sitecore.Data.Items Namespace


Modified Property

[image]

Sitecore 6.4.1 API
Item..::..Modified Property
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Modified { get; }
Visual Basic
Public ReadOnly Property Modified As Boolean
    Get
Visual C++
public:
property bool Modified {
    bool get ();
}

Field Value

true if modified; otherwise, false.

See Also

Item Class
Sitecore.Data.Items Namespace


Name Property

[image]

Sitecore 6.4.1 API
Item..::..Name Property
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Field Value

The name.

Remarks

The name is a short textual description of the item, like a filename in Windows.

It can not be language versioned.

See Also

Item Class
Sitecore.Data.Items Namespace


OriginatorId Property

[image]

Sitecore 6.4.1 API
Item..::..OriginatorId Property
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID OriginatorId { get; }
Visual Basic
Public ReadOnly Property OriginatorId As ID
    Get
Visual C++
public:
property ID^ OriginatorId {
    ID^ get ();
}

Field Value

The originator id.

See Also

Item Class
Sitecore.Data.Items Namespace


Parent Property

[image]

Sitecore 6.4.1 API
Item..::..Parent Property
Item Class Example See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Parent { get; }
Visual Basic
Public ReadOnly Property Parent As Item
    Get
Visual C++
public:
property Item^ Parent {
    Item^ get ();
}

Field Value

The parent.

Remarks

For the root element, null is returned.

Examples

Get the parent of the Home item:
CopyC#
Item home = Sitecore.Context.Database["/sitecore/content/Home"];
Item parent = home.Parent;
MainUtil.Out("Parent is: " + parent.Parent.Path);
// Parent is: /sitecore/content
CopyC#
  See Also
Item Class
Sitecore.Data.Items Namespace

Send comments on this topic to
        dv@sitecore.net


ParentID Property

[image]

Sitecore 6.4.1 API
Item..::..ParentID Property
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ParentID { get; }
Visual Basic
Public ReadOnly Property ParentID As ID
    Get
Visual C++
public:
property ID^ ParentID {
    ID^ get ();
}

Field Value

The parent ID.

See Also

Item Class
Sitecore.Data.Items Namespace


Publishing Property

[image]

Sitecore 6.4.1 API
Item..::..Publishing Property
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemPublishing Publishing { get; }
Visual Basic
Public ReadOnly Property Publishing As ItemPublishing
    Get
Visual C++
public:
property ItemPublishing^ Publishing {
    ItemPublishing^ get ();
}

Field Value

The publishing.

See Also

Item Class
Sitecore.Data.Items Namespace


RuntimeSettings Property

[image]

Sitecore 6.4.1 API
Item..::..RuntimeSettings Property
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemRuntimeSettings RuntimeSettings { get; }
Visual Basic
Public ReadOnly Property RuntimeSettings As ItemRuntimeSettings
    Get
Visual C++
public:
property ItemRuntimeSettings^ RuntimeSettings {
    ItemRuntimeSettings^ get ();
}

Field Value

The runtime settings.

See Also

Item Class
Sitecore.Data.Items Namespace


Security Property

[image]

Sitecore 6.4.1 API
Item..::..Security Property
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemSecurity Security { get; set; }
Visual Basic
Public Property Security As ItemSecurity
    Get
    Set
Visual C++
public:
property ItemSecurity^ Security {
    ItemSecurity^ get ();
    void set (ItemSecurity^ value);
}

Field Value

The access rules.

See Also

Item Class
Sitecore.Data.Items Namespace


Source Property

[image]

Sitecore 6.4.1 API
Item..::..Source Property
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Source { get; }
Visual Basic
Public ReadOnly Property Source As Item
    Get
Visual C++
public:
property Item^ Source {
    Item^ get ();
}

Field Value

The source.

See Also

Item Class
Sitecore.Data.Items Namespace


SourceUri Property

[image]

Sitecore 6.4.1 API
Item..::..SourceUri Property
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemUri SourceUri { get; }
Visual Basic
Public ReadOnly Property SourceUri As ItemUri
    Get
Visual C++
public:
property ItemUri^ SourceUri {
    ItemUri^ get ();
}

Field Value

The source URI.

See Also

Item Class
Sitecore.Data.Items Namespace


State Property

[image]

Sitecore 6.4.1 API
Item..::..State Property
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemState State { get; }
Visual Basic
Public ReadOnly Property State As ItemState
    Get
Visual C++
public:
property ItemState^ State {
    ItemState^ get ();
}

Field Value

The state.

See Also

Item Class
Sitecore.Data.Items Namespace


Statistics Property

[image]

Sitecore 6.4.1 API
Item..::..Statistics Property
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemStatistics Statistics { get; }
Visual Basic
Public ReadOnly Property Statistics As ItemStatistics
    Get
Visual C++
public:
property ItemStatistics^ Statistics {
    ItemStatistics^ get ();
}

Field Value

The statistics.

Remarks

Statistical information is creation time, author, last updated time and more.

See Also

Item Class
Sitecore.Data.Items Namespace


SyncRoot Property

[image]

Sitecore 6.4.1 API
Item..::..SyncRoot Property
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object SyncRoot { get; }
Visual Basic
Public ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
property Object^ SyncRoot {
    Object^ get ();
}

Field Value

The sync root.

See Also

Item Class
Sitecore.Data.Items Namespace


Template Property

[image]

Sitecore 6.4.1 API
Item..::..Template Property
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateItem Template { get; }
Visual Basic
Public ReadOnly Property Template As TemplateItem
    Get
Visual C++
public:
property TemplateItem^ Template {
    TemplateItem^ get ();
}

Field Value

The template.

See Also

Item Class
Sitecore.Data.Items Namespace


TemplateID Property

[image]

Sitecore 6.4.1 API
Item..::..TemplateID Property
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID TemplateID { get; set; }
Visual Basic
Public Property TemplateID As ID
    Get
    Set
Visual C++
public:
property ID^ TemplateID {
    ID^ get ();
    void set (ID^ value);
}

Field Value

The template ID.

See Also

Item Class
Sitecore.Data.Items Namespace


TemplateName Property

[image]

Sitecore 6.4.1 API
Item..::..TemplateName Property
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string TemplateName { get; }
Visual Basic
Public ReadOnly Property TemplateName As String
    Get
Visual C++
public:
property String^ TemplateName {
    String^ get ();
}

Field Value

The name of the template.

See Also

Item Class
Sitecore.Data.Items Namespace


Uri Property

[image]

Sitecore 6.4.1 API
Item..::..Uri Property
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemUri Uri { get; }
Visual Basic
Public ReadOnly Property Uri As ItemUri
    Get
Visual C++
public:
property ItemUri^ Uri {
    ItemUri^ get ();
}

Field Value

The URI.

See Also

Item Class
Sitecore.Data.Items Namespace


Visualization Property

[image]

Sitecore 6.4.1 API
Item..::..Visualization Property
Item Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemVisualization Visualization { get; }
Visual Basic
Public ReadOnly Property Visualization As ItemVisualization
    Get
Visual C++
public:
property ItemVisualization^ Visualization {
    ItemVisualization^ get ();
}

Field Value

The visualization.

Remarks

Visible representation is usually the layout of the item.

See Also

Item Class
Sitecore.Data.Items Namespace


Item.ItemDebuggerTypeProxy Class

[image]

Sitecore 6.4.1 API
Item..::..ItemDebuggerTypeProxy Class
Item Class Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemDebuggerTypeProxy
Visual Basic
Public Class ItemDebuggerTypeProxy
Visual C++
public ref class ItemDebuggerTypeProxy

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..Item..::..ItemDebuggerTypeProxy

See Also

Item..::..ItemDebuggerTypeProxy Members
Sitecore.Data.Items Namespace


Item.ItemDebuggerTypeProxy Members

[image] [image]

Sitecore 6.4.1 API
Item..::..ItemDebuggerTypeProxy Members
Item..::..ItemDebuggerTypeProxy Class Constructors Methods Properties See Also Send Feedback

Represents an item.

The Item..::..ItemDebuggerTypeProxy type exposes the following members.

Constructors

 | Name | Description
Public method | Item..::..ItemDebuggerTypeProxy | Initializes a new instance of the Item..::..ItemDebuggerTypeProxy class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Database | Gets the database name.
Public property | Id | Gets the item id.
Public property | Language | Gets the item language.
Public property | Name | Gets the item name.
Public property | Version | Gets the item version.

See Also

Item..::..ItemDebuggerTypeProxy Class
Sitecore.Data.Items Namespace


Item.ItemDebuggerTypeProxy Constructor

[image]

Sitecore 6.4.1 API
Item..::..ItemDebuggerTypeProxy Constructor
Item..::..ItemDebuggerTypeProxy Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemDebuggerTypeProxy(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
ItemDebuggerTypeProxy(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

Item..::..ItemDebuggerTypeProxy Class
Sitecore.Data.Items Namespace


Item.ItemDebuggerTypeProxy Methods

[image] [image]

Sitecore 6.4.1 API
Item..::..ItemDebuggerTypeProxy Methods
Item..::..ItemDebuggerTypeProxy Class See Also Send Feedback

The Item..::..ItemDebuggerTypeProxy type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Item..::..ItemDebuggerTypeProxy Class
Sitecore.Data.Items Namespace


Item.ItemDebuggerTypeProxy Properties

[image] [image]

Sitecore 6.4.1 API
Item..::..ItemDebuggerTypeProxy Properties
Item..::..ItemDebuggerTypeProxy Class See Also Send Feedback

The Item..::..ItemDebuggerTypeProxy type exposes the following members.

Properties

 | Name | Description
Public property | Database | Gets the database name.
Public property | Id | Gets the item id.
Public property | Language | Gets the item language.
Public property | Name | Gets the item name.
Public property | Version | Gets the item version.

See Also

Item..::..ItemDebuggerTypeProxy Class
Sitecore.Data.Items Namespace


Database Property

[image]

Sitecore 6.4.1 API
Item..::..ItemDebuggerTypeProxy..::..Database Property
Item..::..ItemDebuggerTypeProxy Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Database { get; }
Visual Basic
Public ReadOnly Property Database As String
    Get
Visual C++
public:
property String^ Database {
    String^ get ();
}

Field Value

The database.

See Also

Item..::..ItemDebuggerTypeProxy Class
Sitecore.Data.Items Namespace


Id Property

[image]

Sitecore 6.4.1 API
Item..::..ItemDebuggerTypeProxy..::..Id Property
Item..::..ItemDebuggerTypeProxy Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get
Visual C++
public:
property String^ Id {
    String^ get ();
}

Field Value

The id.

See Also

Item..::..ItemDebuggerTypeProxy Class
Sitecore.Data.Items Namespace


Language Property

[image]

Sitecore 6.4.1 API
Item..::..ItemDebuggerTypeProxy..::..Language Property
Item..::..ItemDebuggerTypeProxy Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Language { get; }
Visual Basic
Public ReadOnly Property Language As String
    Get
Visual C++
public:
property String^ Language {
    String^ get ();
}

Field Value

The language.

See Also

Item..::..ItemDebuggerTypeProxy Class
Sitecore.Data.Items Namespace


Name Property

[image]

Sitecore 6.4.1 API
Item..::..ItemDebuggerTypeProxy..::..Name Property
Item..::..ItemDebuggerTypeProxy Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

Item..::..ItemDebuggerTypeProxy Class
Sitecore.Data.Items Namespace


Version Property

[image]

Sitecore 6.4.1 API
Item..::..ItemDebuggerTypeProxy..::..Version Property
Item..::..ItemDebuggerTypeProxy Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Version { get; }
Visual Basic
Public ReadOnly Property Version As String
    Get
Visual C++
public:
property String^ Version {
    String^ get ();
}

Field Value

The version.

See Also

Item..::..ItemDebuggerTypeProxy Class
Sitecore.Data.Items Namespace


ItemAppearance Class

[image]

Sitecore 6.4.1 API
ItemAppearance Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemAppearance : Appearance
Visual Basic
Public Class ItemAppearance _
    Inherits Appearance
Visual C++
public ref class ItemAppearance : public Appearance

Remarks

Appearance defines how the item appears in the Sitecore client.

The %Icon% property provides the item with a graphical representation.

The Style property defines the CSS style that is applied to item when displayed in the content tree.

Inheritance Hierarchy

System..::..Object
Sitecore.Data..::..Appearance
Sitecore.Data.Items..::..ItemAppearance

See Also

ItemAppearance Members
Sitecore.Data.Items Namespace


ItemAppearance Members

[image] [image]

Sitecore 6.4.1 API
ItemAppearance Members
ItemAppearance Class Constructors Methods Properties See Also Send Feedback

The ItemAppearance type exposes the following members.

Constructors

 | Name | Description
Public method | ItemAppearance | Initializes a new instance of the ItemAppearance class. Initializes a ItemAppearance class for an item.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ContextMenu | Gets or sets the context menu.
Public property | CustomEditor | Obsolete. Gets or sets the custom editor.
Public property | DisplayName | Gets or sets the display name. (Overrides Appearance..::..DisplayName.)
Public property | HelpLink | Gets or sets the help link. (Overrides Appearance..::..HelpLink.)
Public property | Hidden | Gets or sets a value indicating whether this Item is hidden.
Public property | Icon | Gets the path to the icon file. (Overrides Appearance..::..Icon.)
Public property | LongDescription | Gets or sets the long description. (Overrides Appearance..::..LongDescription.)
Public property | ReadOnly | Gets or sets a value indicating whether this Item is read-only.
Public property | Ribbon | Gets or sets the ribbon.
Public property | ShortDescription | Gets or sets the short description. (Overrides Appearance..::..ShortDescription.)
Public property | Skin | Gets the skin.
Public property | Sortorder | Gets or sets the sortorder.
Public property | Style | Gets the CSS style for the item. (Overrides Appearance..::..Style.)
Public property | Thumbnail | Gets or sets the thumbnail.

See Also

ItemAppearance Class
Sitecore.Data.Items Namespace


ItemAppearance Constructor

[image]

Sitecore 6.4.1 API
ItemAppearance Constructor
ItemAppearance Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemAppearance(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
ItemAppearance(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

ItemAppearance Class
Sitecore.Data.Items Namespace


ItemAppearance Methods

[image] [image]

Sitecore 6.4.1 API
ItemAppearance Methods
ItemAppearance Class See Also Send Feedback

The ItemAppearance type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemAppearance Class
Sitecore.Data.Items Namespace


ItemAppearance Properties

[image] [image]

Sitecore 6.4.1 API
ItemAppearance Properties
ItemAppearance Class See Also Send Feedback

The ItemAppearance type exposes the following members.

Properties

 | Name | Description
Public property | ContextMenu | Gets or sets the context menu.
Public property | CustomEditor | Obsolete. Gets or sets the custom editor.
Public property | DisplayName | Gets or sets the display name. (Overrides Appearance..::..DisplayName.)
Public property | HelpLink | Gets or sets the help link. (Overrides Appearance..::..HelpLink.)
Public property | Hidden | Gets or sets a value indicating whether this Item is hidden.
Public property | Icon | Gets the path to the icon file. (Overrides Appearance..::..Icon.)
Public property | LongDescription | Gets or sets the long description. (Overrides Appearance..::..LongDescription.)
Public property | ReadOnly | Gets or sets a value indicating whether this Item is read-only.
Public property | Ribbon | Gets or sets the ribbon.
Public property | ShortDescription | Gets or sets the short description. (Overrides Appearance..::..ShortDescription.)
Public property | Skin | Gets the skin.
Public property | Sortorder | Gets or sets the sortorder.
Public property | Style | Gets the CSS style for the item. (Overrides Appearance..::..Style.)
Public property | Thumbnail | Gets or sets the thumbnail.

See Also

ItemAppearance Class
Sitecore.Data.Items Namespace


ContextMenu Property

[image]

Sitecore 6.4.1 API
ItemAppearance..::..ContextMenu Property
ItemAppearance Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ContextMenu { get; set; }
Visual Basic
Public Property ContextMenu As String
    Get
    Set
Visual C++
public:
property String^ ContextMenu {
    String^ get ();
    void set (String^ value);
}

Field Value

The context menu.

See Also

ItemAppearance Class
Sitecore.Data.Items Namespace


CustomEditor Property

[image]

Sitecore 6.4.1 API
ItemAppearance..::..CustomEditor Property
ItemAppearance Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use Editors instead.")]
public string CustomEditor { get; set; }
Visual Basic
<ObsoleteAttribute("Use Editors instead.")> _
Public Property CustomEditor As String
    Get
    Set
Visual C++
[ObsoleteAttribute(L"Use Editors instead.")]
public:
property String^ CustomEditor {
    String^ get ();
    void set (String^ value);
}

Field Value

The custom editor.

See Also

ItemAppearance Class
Sitecore.Data.Items Namespace


DisplayName Property

[image]

Sitecore 6.4.1 API
ItemAppearance..::..DisplayName Property
ItemAppearance Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string DisplayName { get; set; }
Visual Basic
Public Overrides Property DisplayName As String
    Get
    Set
Visual C++
public:
virtual property String^ DisplayName {
    String^ get () override;
    void set (String^ value) override;
}

Field Value

See Also

ItemAppearance Class
Sitecore.Data.Items Namespace


HelpLink Property

[image]

Sitecore 6.4.1 API
ItemAppearance..::..HelpLink Property
ItemAppearance Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string HelpLink { get; set; }
Visual Basic
Public Overrides Property HelpLink As String
    Get
    Set
Visual C++
public:
virtual property String^ HelpLink {
    String^ get () override;
    void set (String^ value) override;
}

Field Value

The help link.

See Also

ItemAppearance Class
Sitecore.Data.Items Namespace


Hidden Property

[image]

Sitecore 6.4.1 API
ItemAppearance..::..Hidden Property
ItemAppearance Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Hidden { get; set; }
Visual Basic
Public Property Hidden As Boolean
    Get
    Set
Visual C++
public:
property bool Hidden {
    bool get ();
    void set (bool value);
}

Field Value

true if hidden; otherwise, false.

See Also

ItemAppearance Class
Sitecore.Data.Items Namespace


Icon Property

[image]

Sitecore 6.4.1 API
ItemAppearance..::..Icon Property
ItemAppearance Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Icon { get; set; }
Visual Basic
Public Overrides Property Icon As String
    Get
    Set
Visual C++
public:
virtual property String^ Icon {
    String^ get () override;
    void set (String^ value) override;
}

Remarks

This can be a themed path, e.g. "Applications/16x16/About.png", or an absolute path, e.g. "/sitecore/shell/Themes/Standard/Applications/16x16/About.png". The value is get from item's field, but information about database of an item is being added automatically

See Also

ItemAppearance Class
Sitecore.Data.Items Namespace


LongDescription Property

[image]

Sitecore 6.4.1 API
ItemAppearance..::..LongDescription Property
ItemAppearance Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string LongDescription { get; set; }
Visual Basic
Public Overrides Property LongDescription As String
    Get
    Set
Visual C++
public:
virtual property String^ LongDescription {
    String^ get () override;
    void set (String^ value) override;
}

Field Value

The long description.

See Also

ItemAppearance Class
Sitecore.Data.Items Namespace


ReadOnly Property

[image]

Sitecore 6.4.1 API
ItemAppearance..::..ReadOnly Property
ItemAppearance Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ReadOnly { get; set; }
Visual Basic
Public Property ReadOnly As Boolean
    Get
    Set
Visual C++
public:
property bool ReadOnly {
    bool get ();
    void set (bool value);
}

Field Value

true if read-only; otherwise, false.

See Also

ItemAppearance Class
Sitecore.Data.Items Namespace


Ribbon Property

[image]

Sitecore 6.4.1 API
ItemAppearance..::..Ribbon Property
ItemAppearance Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Ribbon { get; set; }
Visual Basic
Public Property Ribbon As String
    Get
    Set
Visual C++
public:
property String^ Ribbon {
    String^ get ();
    void set (String^ value);
}

Field Value

The ribbon.

See Also

ItemAppearance Class
Sitecore.Data.Items Namespace


ShortDescription Property

[image]

Sitecore 6.4.1 API
ItemAppearance..::..ShortDescription Property
ItemAppearance Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string ShortDescription { get; set; }
Visual Basic
Public Overrides Property ShortDescription As String
    Get
    Set
Visual C++
public:
virtual property String^ ShortDescription {
    String^ get () override;
    void set (String^ value) override;
}

Field Value

The short description.

See Also

ItemAppearance Class
Sitecore.Data.Items Namespace


Skin Property

[image]

Sitecore 6.4.1 API
ItemAppearance..::..Skin Property
ItemAppearance Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Skin { get; }
Visual Basic
Public ReadOnly Property Skin As String
    Get
Visual C++
public:
property String^ Skin {
    String^ get ();
}

Field Value

The skin.

See Also

ItemAppearance Class
Sitecore.Data.Items Namespace


Sortorder Property

[image]

Sitecore 6.4.1 API
ItemAppearance..::..Sortorder Property
ItemAppearance Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual int Sortorder { get; set; }
Visual Basic
Public Overridable Property Sortorder As Integer
    Get
    Set
Visual C++
public:
virtual property int Sortorder {
    int get ();
    void set (int value);
}

Field Value

The sortorder.

See Also

ItemAppearance Class
Sitecore.Data.Items Namespace


Style Property

[image]

Sitecore 6.4.1 API
ItemAppearance..::..Style Property
ItemAppearance Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Style { get; set; }
Visual Basic
Public Overrides Property Style As String
    Get
    Set
Visual C++
public:
virtual property String^ Style {
    String^ get () override;
    void set (String^ value) override;
}

Field Value

Remarks

This must be a valid CSS style string, e.g. "color:red; font-weight:bold".

See Also

ItemAppearance Class
Sitecore.Data.Items Namespace


Thumbnail Property

[image]

Sitecore 6.4.1 API
ItemAppearance..::..Thumbnail Property
ItemAppearance Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Thumbnail { get; set; }
Visual Basic
Public Property Thumbnail As String
    Get
    Set
Visual C++
public:
property String^ Thumbnail {
    String^ get ();
    void set (String^ value);
}

Field Value

The thumbnail.

See Also

ItemAppearance Class
Sitecore.Data.Items Namespace


ItemAxes Class

[image]

Sitecore 6.4.1 API
ItemAxes Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemAxes
Visual Basic
Public Class ItemAxes
Visual C++
public ref class ItemAxes

Remarks

Implements the Axes property.

You should never instantiate this class.

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..ItemAxes

See Also

ItemAxes Members
Sitecore.Data.Items Namespace


ItemAxes Constructor

[image]

Sitecore 6.4.1 API
ItemAxes Constructor
ItemAxes Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemAxes(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
ItemAxes(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

ItemAxes Class
Sitecore.Data.Items Namespace


ItemAxes Methods

[image] [image]

Sitecore 6.4.1 API
ItemAxes Methods
ItemAxes Class See Also Send Feedback

The ItemAxes type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAncestor | Gets an ancestor item.
Public method | GetAncestors | Gets all ancestors.
Public method | GetChild(String) | Gets a child item.
Public method | GetChild(ID) | Gets a child item.
Public method | GetDescendant | Gets an item that is in the descendants axis of the source item.
Public method | GetDescendants | Gets a list of items that is in descendant axis of the source item.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItem | Gets an item relative to the source item.
Public method | GetNextSibling | Gets the next item in the sibling axis.
Public method | GetPreviousSibling | Gets the previous item in the sibling axis.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAncestorOf | Tests if the source item is an ancestor of an item (or the item itself).
Public method | IsDecendantOf | Obsolete. Tests if the source item is a descendant of an item.
Public method | IsDescendantOf | Determines whether if the item is a descendant of the specified item.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SelectItems | Performs a Sitecore XPath query using the source item as context item.
Public method | SelectSingleItem | Performs a Sitecore XPath query using the source item as context item.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemAxes Class
Sitecore.Data.Items Namespace


GetAncestor Method

[image]

Sitecore 6.4.1 API
ItemAxes..::..GetAncestor Method
ItemAxes Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetAncestor(
    ID itemID,
    bool includeSelf
)
Visual Basic
Public Function GetAncestor ( _
    itemID As ID, _
    includeSelf As Boolean _
) As Item
Visual C++
public:
Item^ GetAncestor(
    ID^ itemID,
    bool includeSelf
)

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.
includeSelf
Type: System..::..Boolean
if set to true this instance is include self.

Return Value

The ancestor.

See Also

ItemAxes Class
Sitecore.Data.Items Namespace


GetAncestors Method

[image]

Sitecore 6.4.1 API
ItemAxes..::..GetAncestors Method
ItemAxes Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item[] GetAncestors()
Visual Basic
Public Function GetAncestors As Item()
Visual C++
public:
array<Item^>^ GetAncestors()

Return Value

The ancestors.

See Also

ItemAxes Class
Sitecore.Data.Items Namespace


GetChild Method (String)

[image]

Sitecore 6.4.1 API
ItemAxes..::..GetChild Method (String)
ItemAxes Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetChild(
    string itemName
)
Visual Basic
Public Function GetChild ( _
    itemName As String _
) As Item
Visual C++
public:
Item^ GetChild(
    String^ itemName
)

Parameters

itemName
Type: System..::..String
Name of the item.

Return Value

The child.

See Also

ItemAxes Class
GetChild Overload
Sitecore.Data.Items Namespace


GetChild Method (ID)

[image]

Sitecore 6.4.1 API
ItemAxes..::..GetChild Method (ID)
ItemAxes Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetChild(
    ID childID
)
Visual Basic
Public Function GetChild ( _
    childID As ID _
) As Item
Visual C++
public:
Item^ GetChild(
    ID^ childID
)

Parameters

childID
Type: Sitecore.Data..::..ID
The child ID.

Return Value

The child.

See Also

ItemAxes Class
GetChild Overload
Sitecore.Data.Items Namespace


GetDescendant Method

[image]

Sitecore 6.4.1 API
ItemAxes..::..GetDescendant Method
ItemAxes Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetDescendant(
    string name
)
Visual Basic
Public Function GetDescendant ( _
    name As String _
) As Item
Visual C++
public:
Item^ GetDescendant(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

Return Value

The descendant.

See Also

ItemAxes Class
Sitecore.Data.Items Namespace


GetDescendants Method

[image]

Sitecore 6.4.1 API
ItemAxes..::..GetDescendants Method
ItemAxes Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item[] GetDescendants()
Visual Basic
Public Function GetDescendants As Item()
Visual C++
public:
array<Item^>^ GetDescendants()

Return Value

The descendants.

See Also

ItemAxes Class
Sitecore.Data.Items Namespace


GetItem Method

[image]

Sitecore 6.4.1 API
ItemAxes..::..GetItem Method
ItemAxes Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetItem(
    string path
)
Visual Basic
Public Function GetItem ( _
    path As String _
) As Item
Visual C++
public:
Item^ GetItem(
    String^ path
)

Parameters

path
Type: System..::..String
The path.

Return Value

The item.

Remarks

The path can be a relative path. In that case the path of the source item is prepend to the path before the item is retrieved.

See Also

ItemAxes Class
Sitecore.Data.Items Namespace


GetNextSibling Method

[image]

Sitecore 6.4.1 API
ItemAxes..::..GetNextSibling Method
ItemAxes Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetNextSibling()
Visual Basic
Public Function GetNextSibling As Item
Visual C++
public:
Item^ GetNextSibling()

Return Value

The next sibling.

See Also

ItemAxes Class
Sitecore.Data.Items Namespace


GetPreviousSibling Method

[image]

Sitecore 6.4.1 API
ItemAxes..::..GetPreviousSibling Method
ItemAxes Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetPreviousSibling()
Visual Basic
Public Function GetPreviousSibling As Item
Visual C++
public:
Item^ GetPreviousSibling()

Return Value

The previous sibling.

See Also

ItemAxes Class
Sitecore.Data.Items Namespace


IsAncestorOf Method

[image]

Sitecore 6.4.1 API
ItemAxes..::..IsAncestorOf Method
ItemAxes Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsAncestorOf(
    Item item
)
Visual Basic
Public Function IsAncestorOf ( _
    item As Item _
) As Boolean
Visual C++
public:
bool IsAncestorOf(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

true if [is ancestor of] [the specified item]; otherwise, false.

See Also

ItemAxes Class
Sitecore.Data.Items Namespace


IsDecendantOf Method

[image]

Sitecore 6.4.1 API
ItemAxes..::..IsDecendantOf Method
ItemAxes Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use IsDescendantOf method instead.")]
public bool IsDecendantOf(
    Item item
)
Visual Basic
<ObsoleteAttribute("Use IsDescendantOf method instead.")> _
Public Function IsDecendantOf ( _
    item As Item _
) As Boolean
Visual C++
[ObsoleteAttribute(L"Use IsDescendantOf method instead.")]
public:
bool IsDecendantOf(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

true if [is decendant of] [the specified item]; otherwise, false.

See Also

ItemAxes Class
Sitecore.Data.Items Namespace


IsDescendantOf Method

[image]

Sitecore 6.4.1 API
ItemAxes..::..IsDescendantOf Method
ItemAxes Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsDescendantOf(
    Item item
)
Visual Basic
Public Function IsDescendantOf ( _
    item As Item _
) As Boolean
Visual C++
public:
bool IsDescendantOf(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

true if the item is a descendant of the specified item; otherwise, false.

See Also

ItemAxes Class
Sitecore.Data.Items Namespace


SelectItems Method

[image]

Sitecore 6.4.1 API
ItemAxes..::..SelectItems Method
ItemAxes Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item[] SelectItems(
    string query
)
Visual Basic
Public Function SelectItems ( _
    query As String _
) As Item()
Visual C++
public:
array<Item^>^ SelectItems(
    String^ query
)

Parameters

query
Type: System..::..String
The query.

Return Value

The items.

See Also

ItemAxes Class
Sitecore.Data.Items Namespace


SelectSingleItem Method

[image]

Sitecore 6.4.1 API
ItemAxes..::..SelectSingleItem Method
ItemAxes Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item SelectSingleItem(
    string query
)
Visual Basic
Public Function SelectSingleItem ( _
    query As String _
) As Item
Visual C++
public:
Item^ SelectSingleItem(
    String^ query
)

Parameters

query
Type: System..::..String
The query.

Return Value

The single item.

See Also

ItemAxes Class
Sitecore.Data.Items Namespace


ItemAxes Properties

[image] [image]

Sitecore 6.4.1 API
ItemAxes Properties
ItemAxes Class See Also Send Feedback

The ItemAxes type exposes the following members.

Properties

 | Name | Description
Public property | Level | Gets the number of parents of the source item.
Public property | Root | Gets the root item of the items database.

See Also

ItemAxes Class
Sitecore.Data.Items Namespace


Level Property

[image]

Sitecore 6.4.1 API
ItemAxes..::..Level Property
ItemAxes Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Level { get; }
Visual Basic
Public ReadOnly Property Level As Integer
    Get
Visual C++
public:
property int Level {
    int get ();
}

Field Value

The level.

See Also

ItemAxes Class
Sitecore.Data.Items Namespace


Root Property

[image]

Sitecore 6.4.1 API
ItemAxes..::..Root Property
ItemAxes Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Root { get; }
Visual Basic
Public ReadOnly Property Root As Item
    Get
Visual C++
public:
property Item^ Root {
    Item^ get ();
}

Field Value

The root.

See Also

ItemAxes Class
Sitecore.Data.Items Namespace


ItemChanges Class

[image]

Sitecore 6.4.1 API
ItemChanges Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemChanges
Visual Basic
Public Class ItemChanges
Visual C++
public ref class ItemChanges

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..ItemChanges

See Also

ItemChanges Members
Sitecore.Data.Items Namespace


ItemChanges Members

[image] [image]

Sitecore 6.4.1 API
ItemChanges Members
ItemChanges Class Constructors Methods Properties See Also Send Feedback

The ItemChanges type exposes the following members.

Constructors

 | Name | Description
Public method | ItemChanges | Initializes a new instance of the ItemChanges class.

Methods

 | Name | Description
Public method | Clone | Clones the specified owner.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFieldValue(Field) | Gets the field value.
Public method | GetFieldValue(ID) | Gets the field value.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets the property value.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsFieldModified(Field) | Determines whether [is field modified] [the specified field].
Public method | IsFieldModified(ID) | Determines whether [is field modified] [the specified field ID].
Public method | IsPropertyModified | Determines whether [is property modified] [the specified property name].
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetFieldValue | Sets the field value.
Public method | SetPropertyValue(String, ID) | Sets the property value.
Public method | SetPropertyValue(String, String) | Sets the property value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FieldChanges | Gets the field changes.
Public property | HasFieldsChanged | Gets a value indicating whether this instance has fields changed.
Public property | HasPropertiesChanged | Gets a value indicating whether this instance has properties changed.
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | Item | Gets the item.
Public property | PropertyChanges | Gets the property changes.
Public property | Renamed | Gets a value indicating if the item was renamed (ie. the Name was changed).

See Also

ItemChanges Class
Sitecore.Data.Items Namespace


ItemChanges Constructor

[image]

Sitecore 6.4.1 API
ItemChanges Constructor
ItemChanges Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemChanges(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
ItemChanges(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item

[Missing <param name="item"/> documentation for "M:Sitecore.Data.Items.ItemChanges.#ctor(Sitecore.Data.Items.Item)"]

See Also

ItemChanges Class
Sitecore.Data.Items Namespace


ItemChanges Methods

[image] [image]

Sitecore 6.4.1 API
ItemChanges Methods
ItemChanges Class See Also Send Feedback

The ItemChanges type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones the specified owner.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFieldValue(Field) | Gets the field value.
Public method | GetFieldValue(ID) | Gets the field value.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPropertyValue | Gets the property value.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsFieldModified(Field) | Determines whether [is field modified] [the specified field].
Public method | IsFieldModified(ID) | Determines whether [is field modified] [the specified field ID].
Public method | IsPropertyModified | Determines whether [is property modified] [the specified property name].
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetFieldValue | Sets the field value.
Public method | SetPropertyValue(String, ID) | Sets the property value.
Public method | SetPropertyValue(String, String) | Sets the property value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemChanges Class
Sitecore.Data.Items Namespace


Clone Method

[image]

Sitecore 6.4.1 API
ItemChanges..::..Clone Method
ItemChanges Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemChanges Clone(
    Item owner
)
Visual Basic
Public Function Clone ( _
    owner As Item _
) As ItemChanges
Visual C++
public:
ItemChanges^ Clone(
    Item^ owner
)

Parameters

owner
Type: Sitecore.Data.Items..::..Item
The owner.

Return Value

The clone.

See Also

ItemChanges Class
Sitecore.Data.Items Namespace


GetFieldValue Method

[image] [image]

Sitecore 6.4.1 API
ItemChanges..::..GetFieldValue Method
ItemChanges Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetFieldValue(Field) | Gets the field value.
Public method | GetFieldValue(ID) | Gets the field value.

See Also

ItemChanges Class
ItemChanges Members
Sitecore.Data.Items Namespace


GetFieldValue Method (Field)

[image]

Sitecore 6.4.1 API
ItemChanges..::..GetFieldValue Method (Field)
ItemChanges Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetFieldValue(
    Field field
)
Visual Basic
Public Function GetFieldValue ( _
    field As Field _
) As String
Visual C++
public:
String^ GetFieldValue(
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.

Return Value

The field value.

See Also

ItemChanges Class
GetFieldValue Overload
Sitecore.Data.Items Namespace


GetFieldValue Method (ID)

[image]

Sitecore 6.4.1 API
ItemChanges..::..GetFieldValue Method (ID)
ItemChanges Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetFieldValue(
    ID fieldId
)
Visual Basic
Public Function GetFieldValue ( _
    fieldId As ID _
) As String
Visual C++
public:
String^ GetFieldValue(
    ID^ fieldId
)

Parameters

fieldId
Type: Sitecore.Data..::..ID
The field id.

Return Value

The field value.

See Also

ItemChanges Class
GetFieldValue Overload
Sitecore.Data.Items Namespace


GetPropertyValue Method

[image]

Sitecore 6.4.1 API
ItemChanges..::..GetPropertyValue Method
ItemChanges Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object GetPropertyValue(
    string propertyName
)
Visual Basic
Public Function GetPropertyValue ( _
    propertyName As String _
) As Object
Visual C++
public:
Object^ GetPropertyValue(
    String^ propertyName
)

Parameters

propertyName
Type: System..::..String
Name of the property.

Return Value

The property value.

See Also

ItemChanges Class
Sitecore.Data.Items Namespace


IsFieldModified Method

[image] [image]

Sitecore 6.4.1 API
ItemChanges..::..IsFieldModified Method
ItemChanges Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsFieldModified(Field) | Determines whether [is field modified] [the specified field].
Public method | IsFieldModified(ID) | Determines whether [is field modified] [the specified field ID].

See Also

ItemChanges Class
ItemChanges Members
Sitecore.Data.Items Namespace


IsFieldModified Method (Field)

[image]

Sitecore 6.4.1 API
ItemChanges..::..IsFieldModified Method (Field)
ItemChanges Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsFieldModified(
    Field field
)
Visual Basic
Public Function IsFieldModified ( _
    field As Field _
) As Boolean
Visual C++
public:
bool IsFieldModified(
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.

Return Value

true if [is field modified] [the specified field]; otherwise, false.

See Also

ItemChanges Class
IsFieldModified Overload
Sitecore.Data.Items Namespace


IsFieldModified Method (ID)

[image]

Sitecore 6.4.1 API
ItemChanges..::..IsFieldModified Method (ID)
ItemChanges Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsFieldModified(
    ID fieldID
)
Visual Basic
Public Function IsFieldModified ( _
    fieldID As ID _
) As Boolean
Visual C++
public:
bool IsFieldModified(
    ID^ fieldID
)

Parameters

fieldID
Type: Sitecore.Data..::..ID
The field ID.

Return Value

true if [is field modified] [the specified field ID]; otherwise, false.

See Also

ItemChanges Class
IsFieldModified Overload
Sitecore.Data.Items Namespace


IsPropertyModified Method

[image]

Sitecore 6.4.1 API
ItemChanges..::..IsPropertyModified Method
ItemChanges Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsPropertyModified(
    string propertyName
)
Visual Basic
Public Function IsPropertyModified ( _
    propertyName As String _
) As Boolean
Visual C++
public:
bool IsPropertyModified(
    String^ propertyName
)

Parameters

propertyName
Type: System..::..String
Name of the property.

Return Value

true if [is property modified] [the specified property name]; otherwise, false.

See Also

ItemChanges Class
Sitecore.Data.Items Namespace


SetFieldValue Method

[image]

Sitecore 6.4.1 API
ItemChanges..::..SetFieldValue Method
ItemChanges Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetFieldValue(
    Field field,
    string value
)
Visual Basic
Public Sub SetFieldValue ( _
    field As Field, _
    value As String _
)
Visual C++
public:
void SetFieldValue(
    Field^ field,
    String^ value
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.
value
Type: System..::..String
The value.

See Also

ItemChanges Class
Sitecore.Data.Items Namespace


SetPropertyValue Method

[image] [image]

Sitecore 6.4.1 API
ItemChanges..::..SetPropertyValue Method
ItemChanges Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetPropertyValue(String, ID) | Sets the property value.
Public method | SetPropertyValue(String, String) | Sets the property value.

See Also

ItemChanges Class
ItemChanges Members
Sitecore.Data.Items Namespace


SetPropertyValue Method (String, ID)

[image]

Sitecore 6.4.1 API
ItemChanges..::..SetPropertyValue Method (String, ID)
ItemChanges Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetPropertyValue(
    string propertyName,
    ID value
)
Visual Basic
Public Sub SetPropertyValue ( _
    propertyName As String, _
    value As ID _
)
Visual C++
public:
void SetPropertyValue(
    String^ propertyName,
    ID^ value
)

Parameters

propertyName
Type: System..::..String
Name of the property.
value
Type: Sitecore.Data..::..ID
The value.

See Also

ItemChanges Class
SetPropertyValue Overload
Sitecore.Data.Items Namespace


SetPropertyValue Method (String, String)

[image]

Sitecore 6.4.1 API
ItemChanges..::..SetPropertyValue Method (String, String)
ItemChanges Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetPropertyValue(
    string propertyName,
    string value
)
Visual Basic
Public Sub SetPropertyValue ( _
    propertyName As String, _
    value As String _
)
Visual C++
public:
void SetPropertyValue(
    String^ propertyName,
    String^ value
)

Parameters

propertyName
Type: System..::..String
Name of the property.
value
Type: System..::..String
The value.

See Also

ItemChanges Class
SetPropertyValue Overload
Sitecore.Data.Items Namespace


ItemChanges Properties

[image] [image]

Sitecore 6.4.1 API
ItemChanges Properties
ItemChanges Class See Also Send Feedback

The ItemChanges type exposes the following members.

Properties

 | Name | Description
Public property | FieldChanges | Gets the field changes.
Public property | HasFieldsChanged | Gets a value indicating whether this instance has fields changed.
Public property | HasPropertiesChanged | Gets a value indicating whether this instance has properties changed.
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | Item | Gets the item.
Public property | PropertyChanges | Gets the property changes.
Public property | Renamed | Gets a value indicating if the item was renamed (ie. the Name was changed).

See Also

ItemChanges Class
Sitecore.Data.Items Namespace


FieldChanges Property

[image]

Sitecore 6.4.1 API
ItemChanges..::..FieldChanges Property
ItemChanges Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FieldChangeList FieldChanges { get; }
Visual Basic
Public ReadOnly Property FieldChanges As FieldChangeList
    Get
Visual C++
public:
property FieldChangeList^ FieldChanges {
    FieldChangeList^ get ();
}

Field Value

The field changes.

See Also

ItemChanges Class
Sitecore.Data.Items Namespace


HasFieldsChanged Property

[image]

Sitecore 6.4.1 API
ItemChanges..::..HasFieldsChanged Property
ItemChanges Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool HasFieldsChanged { get; }
Visual Basic
Public ReadOnly Property HasFieldsChanged As Boolean
    Get
Visual C++
public:
property bool HasFieldsChanged {
    bool get ();
}

Field Value

true if this instance has fields changed; otherwise, false.

See Also

ItemChanges Class
Sitecore.Data.Items Namespace


HasPropertiesChanged Property

[image]

Sitecore 6.4.1 API
ItemChanges..::..HasPropertiesChanged Property
ItemChanges Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool HasPropertiesChanged { get; }
Visual Basic
Public ReadOnly Property HasPropertiesChanged As Boolean
    Get
Visual C++
public:
property bool HasPropertiesChanged {
    bool get ();
}

Field Value

true if this instance has properties changed; otherwise, false.

See Also

ItemChanges Class
Sitecore.Data.Items Namespace


IsEmpty Property

[image]

Sitecore 6.4.1 API
ItemChanges..::..IsEmpty Property
ItemChanges Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
property bool IsEmpty {
    bool get ();
}

Field Value

true if this instance is empty; otherwise, false.

See Also

ItemChanges Class
Sitecore.Data.Items Namespace


PropertyChanges Property

[image]

Sitecore 6.4.1 API
ItemChanges..::..PropertyChanges Property
ItemChanges Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Hashtable PropertyChanges { get; }
Visual Basic
Public ReadOnly Property PropertyChanges As Hashtable
    Get
Visual C++
public:
property Hashtable^ PropertyChanges {
    Hashtable^ get ();
}

Field Value

The property changes.

See Also

ItemChanges Class
Sitecore.Data.Items Namespace


Renamed Property

[image]

Sitecore 6.4.1 API
ItemChanges..::..Renamed Property
ItemChanges Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Renamed { get; }
Visual Basic
Public ReadOnly Property Renamed As Boolean
    Get
Visual C++
public:
property bool Renamed {
    bool get ();
}

Field Value

true if renamed; otherwise, false.

See Also

ItemChanges Class
Sitecore.Data.Items Namespace


ItemEditing Class

[image]

Sitecore 6.4.1 API
ItemEditing Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemEditing
Visual Basic
Public Class ItemEditing
Visual C++
public ref class ItemEditing

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..ItemEditing

See Also

ItemEditing Members
Sitecore.Data.Items Namespace


ItemEditing Members

[image] [image]

Sitecore 6.4.1 API
ItemEditing Members
ItemEditing Class Constructors Methods Properties See Also Send Feedback

The ItemEditing type exposes the following members.

Constructors

 | Name | Description
Public method | ItemEditing | Creates a new ItemPublishing instance.

Methods

 | Name | Description
Public method | AcceptChanges()()()() | Accepts the changes.
Public method | AcceptChanges(Boolean, Boolean) | Ends an edit operation.
Public method | AssertEditing | Asserts the editing.
Public method | BeginEdit | Marks the beginning of an editing operation.
Public method | CancelEdit | Cancels the edit.
Public method | Clone | Clones this instance.
Public method | EndEdit()()()() | Ends an edit operation.
Public method | EndEdit(Boolean) | Ends the edit.
Public method | EndEdit(Boolean, Boolean) | Ends an edit operation.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RejectChanges | Rejects the changes.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEditing | Gets a value that indicates if the item is being edited.

See Also

ItemEditing Class
Sitecore.Data.Items Namespace


ItemEditing Constructor

[image]

Sitecore 6.4.1 API
ItemEditing Constructor
ItemEditing Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemEditing(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
ItemEditing(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

ItemEditing Class
Sitecore.Data.Items Namespace


ItemEditing Methods

[image] [image]

Sitecore 6.4.1 API
ItemEditing Methods
ItemEditing Class See Also Send Feedback

The ItemEditing type exposes the following members.

Methods

 | Name | Description
Public method | AcceptChanges()()()() | Accepts the changes.
Public method | AcceptChanges(Boolean, Boolean) | Ends an edit operation.
Public method | AssertEditing | Asserts the editing.
Public method | BeginEdit | Marks the beginning of an editing operation.
Public method | CancelEdit | Cancels the edit.
Public method | Clone | Clones this instance.
Public method | EndEdit()()()() | Ends an edit operation.
Public method | EndEdit(Boolean) | Ends the edit.
Public method | EndEdit(Boolean, Boolean) | Ends an edit operation.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RejectChanges | Rejects the changes.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemEditing Class
Sitecore.Data.Items Namespace


AcceptChanges Method

[image] [image]

Sitecore 6.4.1 API
ItemEditing..::..AcceptChanges Method
ItemEditing Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AcceptChanges()()()() | Accepts the changes.
Public method | AcceptChanges(Boolean, Boolean) | Ends an edit operation.

See Also

ItemEditing Class
ItemEditing Members
Sitecore.Data.Items Namespace


AcceptChanges Method

[image]

Sitecore 6.4.1 API
ItemEditing..::..AcceptChanges Method
ItemEditing Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool AcceptChanges()
Visual Basic
Public Function AcceptChanges As Boolean
Visual C++
public:
bool AcceptChanges()

Return Value

The changes.

See Also

ItemEditing Class
AcceptChanges Overload
Sitecore.Data.Items Namespace


AcceptChanges Method (Boolean, Boolean)

[image]

Sitecore 6.4.1 API
ItemEditing..::..AcceptChanges Method (Boolean, Boolean)
ItemEditing Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool AcceptChanges(
    bool updateStatistics,
    bool silent
)
Visual Basic
Public Function AcceptChanges ( _
    updateStatistics As Boolean, _
    silent As Boolean _
) As Boolean
Visual C++
public:
bool AcceptChanges(
    bool updateStatistics,
    bool silent
)

Parameters

updateStatistics
Type: System..::..Boolean
if set to true this instance is update statistics.
silent
Type: System..::..Boolean
if set to true this instance is silent.

Return Value

The changes.

Remarks

Editing an item without calling BeginEdit throws an exception.

It is usually easier and more readable to using the EditContext class instead of a BeginEdit and EndEdit pair.

See Also

ItemEditing Class
AcceptChanges Overload
Sitecore.Data.Items Namespace


AssertEditing Method

[image]

Sitecore 6.4.1 API
ItemEditing..::..AssertEditing Method
ItemEditing Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AssertEditing()
Visual Basic
Public Sub AssertEditing
Visual C++
public:
void AssertEditing()

See Also

ItemEditing Class
Sitecore.Data.Items Namespace


BeginEdit Method

[image]

Sitecore 6.4.1 API
ItemEditing..::..BeginEdit Method
ItemEditing Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void BeginEdit()
Visual Basic
Public Sub BeginEdit
Visual C++
public:
void BeginEdit()

See Also

ItemEditing Class
Sitecore.Data.Items Namespace


CancelEdit Method

[image]

Sitecore 6.4.1 API
ItemEditing..::..CancelEdit Method
ItemEditing Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void CancelEdit()
Visual Basic
Public Sub CancelEdit
Visual C++
public:
void CancelEdit()

See Also

ItemEditing Class
Sitecore.Data.Items Namespace


Clone Method

[image]

Sitecore 6.4.1 API
ItemEditing..::..Clone Method
ItemEditing Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemEditing Clone(
    Item owner
)
Visual Basic
Public Function Clone ( _
    owner As Item _
) As ItemEditing
Visual C++
public:
ItemEditing^ Clone(
    Item^ owner
)

Parameters

owner
Type: Sitecore.Data.Items..::..Item
The owner item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Items.ItemEditing.Clone(Sitecore.Data.Items.Item)"]

See Also

ItemEditing Class
Sitecore.Data.Items Namespace


EndEdit Method

[image] [image]

Sitecore 6.4.1 API
ItemEditing..::..EndEdit Method
ItemEditing Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EndEdit()()()() | Ends an edit operation.
Public method | EndEdit(Boolean) | Ends the edit.
Public method | EndEdit(Boolean, Boolean) | Ends an edit operation.

See Also

ItemEditing Class
ItemEditing Members
Sitecore.Data.Items Namespace


EndEdit Method

[image]

Sitecore 6.4.1 API
ItemEditing..::..EndEdit Method
ItemEditing Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool EndEdit()
Visual Basic
Public Function EndEdit As Boolean
Visual C++
public:
bool EndEdit()

Return Value

The edit.

Remarks

Editing an item without calling BeginEdit throws an exception.

It is usually easier and more readable to using the EditContext class instead of a BeginEdit and EndEdit pair.

See Also

ItemEditing Class
EndEdit Overload
Sitecore.Data.Items Namespace


EndEdit Method (Boolean)

[image]

Sitecore 6.4.1 API
ItemEditing..::..EndEdit Method (Boolean)
ItemEditing Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool EndEdit(
    bool silent
)
Visual Basic
Public Function EndEdit ( _
    silent As Boolean _
) As Boolean
Visual C++
public:
bool EndEdit(
    bool silent
)

Parameters

silent
Type: System..::..Boolean
If set to true, no events will be raised due to saving.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Items.ItemEditing.EndEdit(System.Boolean)"]

See Also

ItemEditing Class
EndEdit Overload
Sitecore.Data.Items Namespace


EndEdit Method (Boolean, Boolean)

[image]

Sitecore 6.4.1 API
ItemEditing..::..EndEdit Method (Boolean, Boolean)
ItemEditing Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool EndEdit(
    bool updateStatistics,
    bool silent
)
Visual Basic
Public Function EndEdit ( _
    updateStatistics As Boolean, _
    silent As Boolean _
) As Boolean
Visual C++
public:
bool EndEdit(
    bool updateStatistics,
    bool silent
)

Parameters

updateStatistics
Type: System..::..Boolean
if set to true this instance is update statistics.
silent
Type: System..::..Boolean
if set to true this instance is silent.

Return Value

The edit.

Remarks

Editing an item without calling BeginEdit throws an exception.

It is usually easier and more readable to using the EditContext class instead of a BeginEdit and EndEdit pair.

See Also

ItemEditing Class
EndEdit Overload
Sitecore.Data.Items Namespace


RejectChanges Method

[image]

Sitecore 6.4.1 API
ItemEditing..::..RejectChanges Method
ItemEditing Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RejectChanges()
Visual Basic
Public Sub RejectChanges
Visual C++
public:
void RejectChanges()

See Also

ItemEditing Class
Sitecore.Data.Items Namespace


ItemEditing Properties

[image] [image]

Sitecore 6.4.1 API
ItemEditing Properties
ItemEditing Class See Also Send Feedback

The ItemEditing type exposes the following members.

Properties

 | Name | Description
Public property | IsEditing | Gets a value that indicates if the item is being edited.

See Also

ItemEditing Class
Sitecore.Data.Items Namespace


IsEditing Property

[image]

Sitecore 6.4.1 API
ItemEditing..::..IsEditing Property
ItemEditing Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsEditing { get; }
Visual Basic
Public ReadOnly Property IsEditing As Boolean
    Get
Visual C++
public:
property bool IsEditing {
    bool get ();
}

Field Value

true if this instance is editing; otherwise, false.

See Also

ItemEditing Class
Sitecore.Data.Items Namespace


ItemHelp Class

[image]

Sitecore 6.4.1 API
ItemHelp Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemHelp
Visual Basic
Public Class ItemHelp
Visual C++
public ref class ItemHelp

Remarks

The help information includes:

  • Short description (ToolTip)
  • Long description (Description)
  • Link

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..ItemHelp

See Also

ItemHelp Members
Sitecore.Data.Items Namespace


ItemHelp Members

[image] [image]

Sitecore 6.4.1 API
ItemHelp Members
ItemHelp Class Constructors Methods Properties See Also Send Feedback

The ItemHelp type exposes the following members.

Constructors

 | Name | Description
Public method | ItemHelp | Creates a new ItemHelp instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Link | Gets or sets the help link.
Public property | Text | Gets or sets the text (long description).
Public property | ToolTip | Gets or sets the tool tip.

See Also

ItemHelp Class
Sitecore.Data.Items Namespace


ItemHelp Constructor

[image]

Sitecore 6.4.1 API
ItemHelp Constructor
ItemHelp Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemHelp(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
ItemHelp(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
Source item.

See Also

ItemHelp Class
Sitecore.Data.Items Namespace


ItemHelp Methods

[image] [image]

Sitecore 6.4.1 API
ItemHelp Methods
ItemHelp Class See Also Send Feedback

The ItemHelp type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemHelp Class
Sitecore.Data.Items Namespace


ItemHelp Properties

[image] [image]

Sitecore 6.4.1 API
ItemHelp Properties
ItemHelp Class See Also Send Feedback

The ItemHelp type exposes the following members.

Properties

 | Name | Description
Public property | Link | Gets or sets the help link.
Public property | Text | Gets or sets the text (long description).
Public property | ToolTip | Gets or sets the tool tip.

See Also

ItemHelp Class
Sitecore.Data.Items Namespace


Text Property

[image]

Sitecore 6.4.1 API
ItemHelp..::..Text Property
ItemHelp Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Field Value

The text.

See Also

ItemHelp Class
Sitecore.Data.Items Namespace


ToolTip Property

[image]

Sitecore 6.4.1 API
ItemHelp..::..ToolTip Property
ItemHelp Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ToolTip { get; set; }
Visual Basic
Public Property ToolTip As String
    Get
    Set
Visual C++
public:
property String^ ToolTip {
    String^ get ();
    void set (String^ value);
}

Field Value

The tool tip.

See Also

ItemHelp Class
Sitecore.Data.Items Namespace


ItemPathType Enumeration

[image]

Sitecore 6.4.1 API
ItemPathType Enumeration
See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum ItemPathType
Visual Basic
Public Enumeration ItemPathType
Visual C++
public enum class ItemPathType

Members

Member name | Value | Description
ItemID | 0 | Path of IDs.
Key | 1 | Path of keys (lowercase name).
Name | 2 | Path of names.
DisplayName | 3 | Path of display names.

See Also

Sitecore.Data.Items Namespace


ItemPublishing Class

[image]

Sitecore 6.4.1 API
ItemPublishing Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemPublishing
Visual Basic
Public Class ItemPublishing
Visual C++
public ref class ItemPublishing

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..ItemPublishing

See Also

ItemPublishing Members
Sitecore.Data.Items Namespace


ItemPublishing Members

[image] [image]

Sitecore 6.4.1 API
ItemPublishing Members
ItemPublishing Class Constructors Methods Properties See Also Send Feedback

The ItemPublishing type exposes the following members.

Constructors

 | Name | Description
Public method | ItemPublishing | Creates a new ItemPublishing instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidVersion(DateTime, Boolean) | Gets the valid version on a specific date.
Public method | GetValidVersion(DateTime, Boolean, Boolean) | Gets the valid version on a specific date.
Public method | GetVisibleInterval | Gets the interval around date for which the current item version is potentially visible (i.e. published).
Public method | IsPublishable | Determines whether the item is publishable on a specified date.
Public method | IsValid | Determines whether the version is valid on a specified date.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | HideVersion | Gets or sets a value indicating whether the version can be published.
Public property | NeverPublish | Gets or sets a value indicating whether the entire item can be published.
Public property | PublishDate | Gets or sets the publish date of the entire item.
Public property | UnpublishDate | Gets or sets the unpublish date of the entire item.
Public property | ValidFrom | Gets or sets the valid from date of the version.
Public property | ValidTo | Gets or sets the valid to date of the version.

See Also

ItemPublishing Class
Sitecore.Data.Items Namespace


ItemPublishing Constructor

[image]

Sitecore 6.4.1 API
ItemPublishing Constructor
ItemPublishing Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemPublishing(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
ItemPublishing(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

ItemPublishing Class
Sitecore.Data.Items Namespace


ItemPublishing Methods

[image] [image]

Sitecore 6.4.1 API
ItemPublishing Methods
ItemPublishing Class See Also Send Feedback

The ItemPublishing type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidVersion(DateTime, Boolean) | Gets the valid version on a specific date.
Public method | GetValidVersion(DateTime, Boolean, Boolean) | Gets the valid version on a specific date.
Public method | GetVisibleInterval | Gets the interval around date for which the current item version is potentially visible (i.e. published).
Public method | IsPublishable | Determines whether the item is publishable on a specified date.
Public method | IsValid | Determines whether the version is valid on a specified date.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemPublishing Class
Sitecore.Data.Items Namespace


GetValidVersion Method

[image] [image]

Sitecore 6.4.1 API
ItemPublishing..::..GetValidVersion Method
ItemPublishing Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValidVersion(DateTime, Boolean) | Gets the valid version on a specific date.
Public method | GetValidVersion(DateTime, Boolean, Boolean) | Gets the valid version on a specific date.

See Also

ItemPublishing Class
ItemPublishing Members
Sitecore.Data.Items Namespace


GetValidVersion Method (DateTime, Boolean)

[image]

Sitecore 6.4.1 API
ItemPublishing..::..GetValidVersion Method (DateTime, Boolean)
ItemPublishing Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetValidVersion(
    DateTime date,
    bool requireApproved
)
Visual Basic
Public Function GetValidVersion ( _
    date As DateTime, _
    requireApproved As Boolean _
) As Item
Visual C++
public:
Item^ GetValidVersion(
    DateTime date,
    bool requireApproved
)

Parameters

date
Type: System..::..DateTime
Date.
requireApproved
Type: System..::..Boolean
Require that the version is approved.

Return Value

The valid version.

See Also

ItemPublishing Class
GetValidVersion Overload
Sitecore.Data.Items Namespace


GetValidVersion Method (DateTime, Boolean, Boolean)

[image]

Sitecore 6.4.1 API
ItemPublishing..::..GetValidVersion Method (DateTime, Boolean, Boolean)
ItemPublishing Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetValidVersion(
    DateTime date,
    bool requireApproved,
    bool allowEmpty
)
Visual Basic
Public Function GetValidVersion ( _
    date As DateTime, _
    requireApproved As Boolean, _
    allowEmpty As Boolean _
) As Item
Visual C++
public:
Item^ GetValidVersion(
    DateTime date,
    bool requireApproved,
    bool allowEmpty
)

Parameters

date
Type: System..::..DateTime
Date.
requireApproved
Type: System..::..Boolean
Require that the version is approved.
allowEmpty
Type: System..::..Boolean
If set to true allow an empty item to be returned.

Return Value

The valid version.

See Also

ItemPublishing Class
GetValidVersion Overload
Sitecore.Data.Items Namespace


GetVisibleInterval Method

[image]

Sitecore 6.4.1 API
ItemPublishing..::..GetVisibleInterval Method
ItemPublishing Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTimeRange GetVisibleInterval(
    DateTime date,
    bool checkAncestors
)
Visual Basic
Public Function GetVisibleInterval ( _
    date As DateTime, _
    checkAncestors As Boolean _
) As DateTimeRange
Visual C++
public:
DateTimeRange^ GetVisibleInterval(
    DateTime date,
    bool checkAncestors
)

Parameters

date
Type: System..::..DateTime

[Missing <param name="date"/> documentation for "M:Sitecore.Data.Items.ItemPublishing.GetVisibleInterval(System.DateTime,System.Boolean)"]

checkAncestors
Type: System..::..Boolean

[Missing <param name="checkAncestors"/> documentation for "M:Sitecore.Data.Items.ItemPublishing.GetVisibleInterval(System.DateTime,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Items.ItemPublishing.GetVisibleInterval(System.DateTime,System.Boolean)"]

See Also

ItemPublishing Class
Sitecore.Data.Items Namespace


IsPublishable Method

[image]

Sitecore 6.4.1 API
ItemPublishing..::..IsPublishable Method
ItemPublishing Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsPublishable(
    DateTime date,
    bool checkAncestors
)
Visual Basic
Public Function IsPublishable ( _
    date As DateTime, _
    checkAncestors As Boolean _
) As Boolean
Visual C++
public:
bool IsPublishable(
    DateTime date,
    bool checkAncestors
)

Parameters

date
Type: System..::..DateTime
Date.
checkAncestors
Type: System..::..Boolean
Check if ancestors are publishable.

Return Value

true if the item is publishable on a specified date; otherwise, false.

See Also

ItemPublishing Class
Sitecore.Data.Items Namespace


IsValid Method

[image]

Sitecore 6.4.1 API
ItemPublishing..::..IsValid Method
ItemPublishing Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsValid(
    DateTime date,
    bool requireApproved
)
Visual Basic
Public Function IsValid ( _
    date As DateTime, _
    requireApproved As Boolean _
) As Boolean
Visual C++
public:
bool IsValid(
    DateTime date,
    bool requireApproved
)

Parameters

date
Type: System..::..DateTime
Date.
requireApproved
Type: System..::..Boolean
Require that the version is approved.

Return Value

true if the version is valid on the specified date; otherwise, false.

See Also

ItemPublishing Class
Sitecore.Data.Items Namespace


ItemPublishing Properties

[image] [image]

Sitecore 6.4.1 API
ItemPublishing Properties
ItemPublishing Class See Also Send Feedback

The ItemPublishing type exposes the following members.

Properties

 | Name | Description
Public property | HideVersion | Gets or sets a value indicating whether the version can be published.
Public property | NeverPublish | Gets or sets a value indicating whether the entire item can be published.
Public property | PublishDate | Gets or sets the publish date of the entire item.
Public property | UnpublishDate | Gets or sets the unpublish date of the entire item.
Public property | ValidFrom | Gets or sets the valid from date of the version.
Public property | ValidTo | Gets or sets the valid to date of the version.

See Also

ItemPublishing Class
Sitecore.Data.Items Namespace


HideVersion Property

[image]

Sitecore 6.4.1 API
ItemPublishing..::..HideVersion Property
ItemPublishing Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool HideVersion { get; set; }
Visual Basic
Public Property HideVersion As Boolean
    Get
    Set
Visual C++
public:
property bool HideVersion {
    bool get ();
    void set (bool value);
}

Field Value

true if the version can be published; otherwise, false.

See Also

ItemPublishing Class
Sitecore.Data.Items Namespace


NeverPublish Property

[image]

Sitecore 6.4.1 API
ItemPublishing..::..NeverPublish Property
ItemPublishing Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool NeverPublish { get; set; }
Visual Basic
Public Property NeverPublish As Boolean
    Get
    Set
Visual C++
public:
property bool NeverPublish {
    bool get ();
    void set (bool value);
}

Field Value

true if the item cannot be published; otherwise, false.

See Also

ItemPublishing Class
Sitecore.Data.Items Namespace


PublishDate Property

[image]

Sitecore 6.4.1 API
ItemPublishing..::..PublishDate Property
ItemPublishing Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime PublishDate { get; set; }
Visual Basic
Public Property PublishDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime PublishDate {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The publish date.

See Also

ItemPublishing Class
Sitecore.Data.Items Namespace


UnpublishDate Property

[image]

Sitecore 6.4.1 API
ItemPublishing..::..UnpublishDate Property
ItemPublishing Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime UnpublishDate { get; set; }
Visual Basic
Public Property UnpublishDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime UnpublishDate {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The unpublish date.

See Also

ItemPublishing Class
Sitecore.Data.Items Namespace


ValidFrom Property

[image]

Sitecore 6.4.1 API
ItemPublishing..::..ValidFrom Property
ItemPublishing Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime ValidFrom { get; set; }
Visual Basic
Public Property ValidFrom As DateTime
    Get
    Set
Visual C++
public:
property DateTime ValidFrom {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The valid from.

See Also

ItemPublishing Class
Sitecore.Data.Items Namespace


ValidTo Property

[image]

Sitecore 6.4.1 API
ItemPublishing..::..ValidTo Property
ItemPublishing Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime ValidTo { get; set; }
Visual Basic
Public Property ValidTo As DateTime
    Get
    Set
Visual C++
public:
property DateTime ValidTo {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The valid to.

See Also

ItemPublishing Class
Sitecore.Data.Items Namespace


ItemRuntimeSettings Members

[image] [image]

Sitecore 6.4.1 API
ItemRuntimeSettings Members
ItemRuntimeSettings Class Constructors Methods Properties See Also Send Feedback

The ItemRuntimeSettings type exposes the following members.

Constructors

 | Name | Description
Public method | ItemRuntimeSettings | Creates a new ItemRuntimeSettings instance.

Methods

 | Name | Description
Public method | Clone | Clones the specified owner.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeBrowseOnly | Marks the item as browse only.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetupVirtual | Make nesessary, after changing IsVirtual property, changes.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BrowseOnly | Gets a value indicating whether the item is in browse only mode.
Public property | ForceModified | Gets or sets a value indicating whether to force Modified to return true.
Public property | Invalid | Gets a value indicating whether the owning Item is invalid.
Public property | IsExternal | Gets a value indicating whether this instance is external.
Public property | IsVirtual | Gets a value indicating whether this instance is virtual.
Public property | OwnerDatabase | Gets or sets the owner database.
Public property | ProxyId | Gets or sets the proxy id.
Public property | ReadOnlyStatistics | Gets or sets a value indicating whether the item statistics are read-only.
Public property | SaveAll | Gets or sets a value indicating whether to save all data.
Public property | SortOrder | Gets or sets the sort order.
Public property | TemplateDatabase | Gets the database to use when resolving the template for the item.
Public property | Temporary | Gets or sets a value indicating whether the item is temporary.
Public property | ValidFrom | Gets or sets the (UTC) date for which the item is valid from.
Public property | ValidTo | Gets or sets the (UTC) date for which the item is valid until.

See Also

ItemRuntimeSettings Class
Sitecore.Data.Items Namespace


ItemRuntimeSettings Constructor

[image]

Sitecore 6.4.1 API
ItemRuntimeSettings Constructor
ItemRuntimeSettings Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemRuntimeSettings(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
ItemRuntimeSettings(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
Source item.

See Also

ItemRuntimeSettings Class
Sitecore.Data.Items Namespace


ItemRuntimeSettings Methods

[image] [image]

Sitecore 6.4.1 API
ItemRuntimeSettings Methods
ItemRuntimeSettings Class See Also Send Feedback

The ItemRuntimeSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones the specified owner.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeBrowseOnly | Marks the item as browse only.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetupVirtual | Make nesessary, after changing IsVirtual property, changes.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemRuntimeSettings Class
Sitecore.Data.Items Namespace


MakeBrowseOnly Method

[image]

Sitecore 6.4.1 API
ItemRuntimeSettings..::..MakeBrowseOnly Method
ItemRuntimeSettings Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void MakeBrowseOnly()
Visual Basic
Public Sub MakeBrowseOnly
Visual C++
public:
void MakeBrowseOnly()

See Also

ItemRuntimeSettings Class
Sitecore.Data.Items Namespace


SetupVirtual Method

[image]

Sitecore 6.4.1 API
ItemRuntimeSettings..::..SetupVirtual Method
ItemRuntimeSettings Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void SetupVirtual(
    bool isVitrualOld,
    bool isVirtualNew
)
Visual Basic
Protected Overridable Sub SetupVirtual ( _
    isVitrualOld As Boolean, _
    isVirtualNew As Boolean _
)
Visual C++
protected:
virtual void SetupVirtual(
    bool isVitrualOld,
    bool isVirtualNew
)

Parameters

isVitrualOld
Type: System..::..Boolean
old value of IsVirtual property.
isVirtualNew
Type: System..::..Boolean
new value of IsVirtual property.

See Also

ItemRuntimeSettings Class
Sitecore.Data.Items Namespace


ItemRuntimeSettings Properties

[image] [image]

Sitecore 6.4.1 API
ItemRuntimeSettings Properties
ItemRuntimeSettings Class See Also Send Feedback

The ItemRuntimeSettings type exposes the following members.

Properties

 | Name | Description
Public property | BrowseOnly | Gets a value indicating whether the item is in browse only mode.
Public property | ForceModified | Gets or sets a value indicating whether to force Modified to return true.
Public property | Invalid | Gets a value indicating whether the owning Item is invalid.
Public property | IsExternal | Gets a value indicating whether this instance is external.
Public property | IsVirtual | Gets a value indicating whether this instance is virtual.
Public property | OwnerDatabase | Gets or sets the owner database.
Public property | ProxyId | Gets or sets the proxy id.
Public property | ReadOnlyStatistics | Gets or sets a value indicating whether the item statistics are read-only.
Public property | SaveAll | Gets or sets a value indicating whether to save all data.
Public property | SortOrder | Gets or sets the sort order.
Public property | TemplateDatabase | Gets the database to use when resolving the template for the item.
Public property | Temporary | Gets or sets a value indicating whether the item is temporary.
Public property | ValidFrom | Gets or sets the (UTC) date for which the item is valid from.
Public property | ValidTo | Gets or sets the (UTC) date for which the item is valid until.

See Also

ItemRuntimeSettings Class
Sitecore.Data.Items Namespace


BrowseOnly Property

[image]

Sitecore 6.4.1 API
ItemRuntimeSettings..::..BrowseOnly Property
ItemRuntimeSettings Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool BrowseOnly { get; }
Visual Basic
Public ReadOnly Property BrowseOnly As Boolean
    Get
Visual C++
public:
property bool BrowseOnly {
    bool get ();
}

Field Value

true if the item is in browse only mode; otherwise, false.

See Also

ItemRuntimeSettings Class
Sitecore.Data.Items Namespace


ForceModified Property

[image]

Sitecore 6.4.1 API
ItemRuntimeSettings..::..ForceModified Property
ItemRuntimeSettings Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ForceModified { get; set; }
Visual Basic
Public Property ForceModified As Boolean
    Get
    Set
Visual C++
public:
property bool ForceModified {
    bool get ();
    void set (bool value);
}

Remarks

If false, the property will be ignored.

See Also

ItemRuntimeSettings Class
Sitecore.Data.Items Namespace


Invalid Property

[image]

Sitecore 6.4.1 API
ItemRuntimeSettings..::..Invalid Property
ItemRuntimeSettings Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Invalid { get; set; }
Visual Basic
Public Property Invalid As Boolean
    Get
    Set
Visual C++
public:
property bool Invalid {
    bool get ();
    void set (bool value);
}

Field Value

true if invalid; otherwise, false.

See Also

ItemRuntimeSettings Class
Sitecore.Data.Items Namespace


IsVirtual Property

[image]

Sitecore 6.4.1 API
ItemRuntimeSettings..::..IsVirtual Property
ItemRuntimeSettings Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsVirtual { get; set; }
Visual Basic
Public Property IsVirtual As Boolean
    Get
    Set
Visual C++
public:
property bool IsVirtual {
    bool get ();
    void set (bool value);
}

Field Value

true if this instance is virtual; otherwise, false.

See Also

ItemRuntimeSettings Class
Sitecore.Data.Items Namespace


OwnerDatabase Property

[image]

Sitecore 6.4.1 API
ItemRuntimeSettings..::..OwnerDatabase Property
ItemRuntimeSettings Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database OwnerDatabase { get; set; }
Visual Basic
Public Property OwnerDatabase As Database
    Get
    Set
Visual C++
public:
property Database^ OwnerDatabase {
    Database^ get ();
    void set (Database^ value);
}

Field Value

The owner database.

See Also

ItemRuntimeSettings Class
Sitecore.Data.Items Namespace


ProxyId Property

[image]

Sitecore 6.4.1 API
ItemRuntimeSettings..::..ProxyId Property
ItemRuntimeSettings Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ProxyId { get; set; }
Visual Basic
Public Property ProxyId As ID
    Get
    Set
Visual C++
public:
property ID^ ProxyId {
    ID^ get ();
    void set (ID^ value);
}

Field Value

The proxy id.

See Also

ItemRuntimeSettings Class
Sitecore.Data.Items Namespace


ReadOnlyStatistics Property

[image]

Sitecore 6.4.1 API
ItemRuntimeSettings..::..ReadOnlyStatistics Property
ItemRuntimeSettings Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ReadOnlyStatistics { get; set; }
Visual Basic
Public Property ReadOnlyStatistics As Boolean
    Get
    Set
Visual C++
public:
property bool ReadOnlyStatistics {
    bool get ();
    void set (bool value);
}

Field Value

true if the item statistics are read-only; otherwise, false.

See Also

ItemRuntimeSettings Class
Sitecore.Data.Items Namespace


SaveAll Property

[image]

Sitecore 6.4.1 API
ItemRuntimeSettings..::..SaveAll Property
ItemRuntimeSettings Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool SaveAll { get; set; }
Visual Basic
Public Property SaveAll As Boolean
    Get
    Set
Visual C++
public:
property bool SaveAll {
    bool get ();
    void set (bool value);
}

Remarks

If false, only changed data will be saved.

See Also

ItemRuntimeSettings Class
Sitecore.Data.Items Namespace


SortOrder Property

[image]

Sitecore 6.4.1 API
ItemRuntimeSettings..::..SortOrder Property
ItemRuntimeSettings Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string SortOrder { get; set; }
Visual Basic
Public Property SortOrder As String
    Get
    Set
Visual C++
public:
property String^ SortOrder {
    String^ get ();
    void set (String^ value);
}

Field Value

The sort order.

See Also

ItemRuntimeSettings Class
Sitecore.Data.Items Namespace


TemplateDatabase Property

[image]

Sitecore 6.4.1 API
ItemRuntimeSettings..::..TemplateDatabase Property
ItemRuntimeSettings Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database TemplateDatabase { get; set; }
Visual Basic
Public Property TemplateDatabase As Database
    Get
    Set
Visual C++
public:
property Database^ TemplateDatabase {
    Database^ get ();
    void set (Database^ value);
}

Field Value

The template database.

See Also

ItemRuntimeSettings Class
Sitecore.Data.Items Namespace


ValidFrom Property

[image]

Sitecore 6.4.1 API
ItemRuntimeSettings..::..ValidFrom Property
ItemRuntimeSettings Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime ValidFrom { get; set; }
Visual Basic
Public Property ValidFrom As DateTime
    Get
    Set
Visual C++
public:
property DateTime ValidFrom {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The valid until.

See Also

ItemRuntimeSettings Class
Sitecore.Data.Items Namespace


ValidTo Property

[image]

Sitecore 6.4.1 API
ItemRuntimeSettings..::..ValidTo Property
ItemRuntimeSettings Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime ValidTo { get; set; }
Visual Basic
Public Property ValidTo As DateTime
    Get
    Set
Visual C++
public:
property DateTime ValidTo {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The valid until.

See Also

ItemRuntimeSettings Class
Sitecore.Data.Items Namespace


ItemSerializer Class

[image]

Sitecore 6.4.1 API
ItemSerializer Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public sealed class ItemSerializer
Visual Basic
Public NotInheritable Class ItemSerializer
Visual C++
public ref class ItemSerializer sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..ItemSerializer

See Also

ItemSerializer Members
Sitecore.Data.Items Namespace


ItemSerializer Members

[image] [image]

Sitecore 6.4.1 API
ItemSerializer Members
ItemSerializer Class Constructors Methods See Also Send Feedback

The ItemSerializer type exposes the following members.

Constructors

 | Name | Description
Public method | ItemSerializer | Initializes a new instance of the ItemSerializer class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItemXml(Item, Boolean) | Gets the item XML.
 | GetItemXml(Item, Boolean, Boolean) | Gets the item XML.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetVersionXml | Gets the version XML.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseItemXml | Parses the item XML.
 | PasteItemXml | Pastes the item XML.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemSerializer Class
Sitecore.Data.Items Namespace


ItemSerializer Constructor

[image]

Sitecore 6.4.1 API
ItemSerializer Constructor
ItemSerializer Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemSerializer()
Visual Basic
Public Sub New
Visual C++
public:
ItemSerializer()

See Also

ItemSerializer Class
Sitecore.Data.Items Namespace


ItemSerializer Methods

[image] [image]

Sitecore 6.4.1 API
ItemSerializer Methods
ItemSerializer Class See Also Send Feedback

The ItemSerializer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItemXml(Item, Boolean) | Gets the item XML.
 | GetItemXml(Item, Boolean, Boolean) | Gets the item XML.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetVersionXml | Gets the version XML.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseItemXml | Parses the item XML.
 | PasteItemXml | Pastes the item XML.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemSerializer Class
Sitecore.Data.Items Namespace


GetItemXml Method

[image] [image]

Sitecore 6.4.1 API
ItemSerializer..::..GetItemXml Method
ItemSerializer Class See Also Send Feedback

Overload List

Name | Description
GetItemXml(Item, Boolean) | Gets the item XML.
GetItemXml(Item, Boolean, Boolean) | Gets the item XML.

See Also

ItemSerializer Class
ItemSerializer Members
Sitecore.Data.Items Namespace


GetItemXml Method (Item, Boolean)

[image]

Sitecore 6.4.1 API
ItemSerializer..::..GetItemXml Method (Item, Boolean)
ItemSerializer Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetItemXml(
    Item item,
    bool deep
)
Visual Basic
Public Shared Function GetItemXml ( _
    item As Item, _
    deep As Boolean _
) As String
Visual C++
public:
static String^ GetItemXml(
    Item^ item,
    bool deep
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
deep
Type: System..::..Boolean
if set to true this instance is deep.

Return Value

The item XML.

See Also

ItemSerializer Class
GetItemXml Overload
Sitecore.Data.Items Namespace


GetItemXml Method (Item, Boolean, Boolean)

[image]

Sitecore 6.4.1 API
ItemSerializer..::..GetItemXml Method (Item, Boolean, Boolean)
ItemSerializer Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetItemXml(
    Item item,
    bool deep,
    bool includeBlobs
)
Visual Basic
Public Shared Function GetItemXml ( _
    item As Item, _
    deep As Boolean, _
    includeBlobs As Boolean _
) As String
Visual C++
public:
static String^ GetItemXml(
    Item^ item,
    bool deep,
    bool includeBlobs
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
deep
Type: System..::..Boolean
if set to true [deep].
includeBlobs
Type: System..::..Boolean
if set to true include blob fields in the result.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Items.ItemSerializer.GetItemXml(Sitecore.Data.Items.Item,System.Boolean,System.Boolean)"]

See Also

ItemSerializer Class
GetItemXml Overload
Sitecore.Data.Items Namespace


ParseItemXml Method

[image]

Sitecore 6.4.1 API
ItemSerializer..::..ParseItemXml Method
ItemSerializer Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item[] ParseItemXml(
    string xml,
    Database database,
    bool changeID
)
Visual Basic
Public Shared Function ParseItemXml ( _
    xml As String, _
    database As Database, _
    changeID As Boolean _
) As Item()
Visual C++
public:
static array<Item^>^ ParseItemXml(
    String^ xml,
    Database^ database,
    bool changeID
)

Parameters

xml
Type: System..::..String
The XML.
database
Type: Sitecore.Data..::..Database
The database.
changeID
Type: System..::..Boolean
if set to true this instance is change ID.

Return Value

The item XML.

See Also

ItemSerializer Class
Sitecore.Data.Items Namespace


PasteItemXml Method

[image]

Sitecore 6.4.1 API
ItemSerializer..::..PasteItemXml Method
ItemSerializer Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item PasteItemXml(
    string xml,
    Item target,
    bool changeIDs,
    PasteMode mode
)
Visual Basic
Public Shared Function PasteItemXml ( _
    xml As String, _
    target As Item, _
    changeIDs As Boolean, _
    mode As PasteMode _
) As Item
Visual C++
public:
static Item^ PasteItemXml(
    String^ xml,
    Item^ target,
    bool changeIDs,
    PasteMode mode
)

Parameters

xml
Type: System..::..String
The XML.
target
Type: Sitecore.Data.Items..::..Item
The target.
changeIDs
Type: System..::..Boolean
if set to true this instance is change I ds.
mode
Type: Sitecore.Data.Items..::..PasteMode
The mode.

Return Value

The item XML.

See Also

ItemSerializer Class
Sitecore.Data.Items Namespace


ItemState Class

[image]

Sitecore 6.4.1 API
ItemState Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemState
Visual Basic
Public Class ItemState
Visual C++
public ref class ItemState

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..ItemState

See Also

ItemState Members
Sitecore.Data.Items Namespace


ItemState Members

[image] [image]

Sitecore 6.4.1 API
ItemState Members
ItemState Class Constructors Methods See Also Send Feedback

The ItemState type exposes the following members.

Constructors

 | Name | Description
Public method | ItemState | Creates a new ItemState instance.

Methods

 | Name | Description
Public method | CanEdit | Determines whether the source item can be edited.
Public method | CanSave | Determines whether the source item can be saved.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWorkflow | Gets the workflow.
Public method | GetWorkflowState | Gets the workflow state of the item.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemState Class
Sitecore.Data.Items Namespace


CanEdit Method

[image]

Sitecore 6.4.1 API
ItemState..::..CanEdit Method
ItemState Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool CanEdit()
Visual Basic
Public Function CanEdit As Boolean
Visual C++
public:
bool CanEdit()

Return Value

true if the source item can be edited; otherwise, false.

See Also

ItemState Class
Sitecore.Data.Items Namespace


CanSave Method

[image]

Sitecore 6.4.1 API
ItemState..::..CanSave Method
ItemState Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool CanSave()
Visual Basic
Public Function CanSave As Boolean
Visual C++
public:
bool CanSave()

Return Value

true if the source item can be saved; otherwise, false.

See Also

ItemState Class
Sitecore.Data.Items Namespace


GetWorkflow Method

[image]

Sitecore 6.4.1 API
ItemState..::..GetWorkflow Method
ItemState Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IWorkflow GetWorkflow()
Visual Basic
Public Function GetWorkflow As IWorkflow
Visual C++
public:
IWorkflow^ GetWorkflow()

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Items.ItemState.GetWorkflow"]

See Also

ItemState Class
Sitecore.Data.Items Namespace


GetWorkflowState Method

[image]

Sitecore 6.4.1 API
ItemState..::..GetWorkflowState Method
ItemState Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WorkflowState GetWorkflowState()
Visual Basic
Public Function GetWorkflowState As WorkflowState
Visual C++
public:
WorkflowState^ GetWorkflowState()

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Items.ItemState.GetWorkflowState"]

See Also

ItemState Class
Sitecore.Data.Items Namespace


ItemStatistics Class

[image]

Sitecore 6.4.1 API
ItemStatistics Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemStatistics
Visual Basic
Public Class ItemStatistics
Visual C++
public ref class ItemStatistics

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..ItemStatistics

See Also

ItemStatistics Members
Sitecore.Data.Items Namespace


ItemStatistics Members

[image] [image]

Sitecore 6.4.1 API
ItemStatistics Members
ItemStatistics Class Constructors Methods Properties See Also Send Feedback

The ItemStatistics type exposes the following members.

Constructors

 | Name | Description
Public method | ItemStatistics | Creates a new ItemStatistics instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateRevision | Updates the revision.

Properties

 | Name | Description
Public property | Created | Gets the creation date of the source item.
Public property | CreatedBy | Gets the original author of the source item.
Public property | Revision | Gets the current revision of the source item.
Public property | Updated | Gets the date of the latest update to the item.
Public property | UpdatedBy | Gets the author of the latest update.

See Also

ItemStatistics Class
Sitecore.Data.Items Namespace


ItemStatistics Constructor

[image]

Sitecore 6.4.1 API
ItemStatistics Constructor
ItemStatistics Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemStatistics(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
ItemStatistics(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
Item.

See Also

ItemStatistics Class
Sitecore.Data.Items Namespace


ItemStatistics Methods

[image] [image]

Sitecore 6.4.1 API
ItemStatistics Methods
ItemStatistics Class See Also Send Feedback

The ItemStatistics type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateRevision | Updates the revision.

See Also

ItemStatistics Class
Sitecore.Data.Items Namespace


UpdateRevision Method

[image]

Sitecore 6.4.1 API
ItemStatistics..::..UpdateRevision Method
ItemStatistics Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void UpdateRevision()
Visual Basic
Public Sub UpdateRevision
Visual C++
public:
void UpdateRevision()

See Also

ItemStatistics Class
Sitecore.Data.Items Namespace


ItemStatistics Properties

[image] [image]

Sitecore 6.4.1 API
ItemStatistics Properties
ItemStatistics Class See Also Send Feedback

The ItemStatistics type exposes the following members.

Properties

 | Name | Description
Public property | Created | Gets the creation date of the source item.
Public property | CreatedBy | Gets the original author of the source item.
Public property | Revision | Gets the current revision of the source item.
Public property | Updated | Gets the date of the latest update to the item.
Public property | UpdatedBy | Gets the author of the latest update.

See Also

ItemStatistics Class
Sitecore.Data.Items Namespace


Created Property

[image]

Sitecore 6.4.1 API
ItemStatistics..::..Created Property
ItemStatistics Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime Created { get; }
Visual Basic
Public ReadOnly Property Created As DateTime
    Get
Visual C++
public:
property DateTime Created {
    DateTime get ();
}

Field Value

The created.

See Also

ItemStatistics Class
Sitecore.Data.Items Namespace


CreatedBy Property

[image]

Sitecore 6.4.1 API
ItemStatistics..::..CreatedBy Property
ItemStatistics Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string CreatedBy { get; }
Visual Basic
Public ReadOnly Property CreatedBy As String
    Get
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
}

Field Value

The created by.

See Also

ItemStatistics Class
Sitecore.Data.Items Namespace


Revision Property

[image]

Sitecore 6.4.1 API
ItemStatistics..::..Revision Property
ItemStatistics Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Revision { get; }
Visual Basic
Public ReadOnly Property Revision As String
    Get
Visual C++
public:
property String^ Revision {
    String^ get ();
}

Field Value

The revision.

Remarks

The revision is updated each time the source item is updated.

See Also

ItemStatistics Class
Sitecore.Data.Items Namespace


Updated Property

[image]

Sitecore 6.4.1 API
ItemStatistics..::..Updated Property
ItemStatistics Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime Updated { get; }
Visual Basic
Public ReadOnly Property Updated As DateTime
    Get
Visual C++
public:
property DateTime Updated {
    DateTime get ();
}

Field Value

The updated.

See Also

ItemStatistics Class
Sitecore.Data.Items Namespace


UpdatedBy Property

[image]

Sitecore 6.4.1 API
ItemStatistics..::..UpdatedBy Property
ItemStatistics Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string UpdatedBy { get; }
Visual Basic
Public ReadOnly Property UpdatedBy As String
    Get
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
}

Field Value

The updated by.

See Also

ItemStatistics Class
Sitecore.Data.Items Namespace


ItemUpdateType Enumeration

[image]

Sitecore 6.4.1 API
ItemUpdateType Enumeration
See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum ItemUpdateType
Visual Basic
Public Enumeration ItemUpdateType
Visual C++
public enum class ItemUpdateType

Members

Member name | Value | Description
Added | 0 | Obsolete. Item was added.
Copied | 1 | Item was copied.
Created | 2 | Item was copied.
Deleted | 3 | Item was deleted.
Moved | 4 | Item was moved.
Saved | 5 | Item was saved.
VersionAdded | 6 | A version was added to the item.
VersionRemoved | 7 | A version was removed from the item.

See Also

Sitecore.Data.Items Namespace


ItemUtil Class

[image]

Sitecore 6.4.1 API
ItemUtil Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public sealed class ItemUtil
Visual Basic
Public NotInheritable Class ItemUtil
Visual C++
public ref class ItemUtil sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..ItemUtil

See Also

ItemUtil Members
Sitecore.Data.Items Namespace


ItemUtil Members

[image] [image]

Sitecore 6.4.1 API
ItemUtil Members
ItemUtil Class Constructors Methods See Also Send Feedback

The ItemUtil type exposes the following members.

Constructors

 | Name | Description
Public method | ItemUtil | Initializes a new instance of the ItemUtil class

Methods

 | Name | Description
 | AddFromTemplate | Adds from template.
 | AssertItemName | Asserts that the name of the item is valid.
 | CopyItem | Copies the item.
 | DeleteItem(String, Database) | Deletes an item.
 | DeleteItem(ID, Database) | Deletes an item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetChildrenAt | Gets the children at.
 | GetCopyOfName | Gets an item name that includes a "Copy of" text.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItemFromPartialPath | Gets an item from a partial path.
 | GetItemID | Gets the item ID.
 | GetItemNameError | Gets an error text for an item name.
 | GetLevel | Gets the level of an item.
 | GetParentID | Gets the parent ID of an item.
 | GetParentName(Item) | Gets the name of the parent of an item.
 | GetParentName(Item, Boolean) | Gets the name of the parent.
 | GetTemplateKey | Gets the template key.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsDataField | Determines whether [is data field] [the specified template field].
 | IsItemNameValid | Determines whether an item name is valid.
 | IsNull | Determines whether the specified id is null.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProposeValidItemName(String) | Given a invalid itemname, proposes a new itemname where all invalid characters have been replased with an empty character.
 | ProposeValidItemName(String, String) | Given a invalid itemname, proposes a new itemname where all invalid characters have been replased with an empty character.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemUtil Class
Sitecore.Data.Items Namespace


ItemUtil Constructor

[image]

Sitecore 6.4.1 API
ItemUtil Constructor
ItemUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemUtil()
Visual Basic
Public Sub New
Visual C++
public:
ItemUtil()

See Also

ItemUtil Class
Sitecore.Data.Items Namespace


ItemUtil Methods

[image] [image]

Sitecore 6.4.1 API
ItemUtil Methods
ItemUtil Class See Also Send Feedback

The ItemUtil type exposes the following members.

Methods

 | Name | Description
 | AddFromTemplate | Adds from template.
 | AssertItemName | Asserts that the name of the item is valid.
 | CopyItem | Copies the item.
 | DeleteItem(String, Database) | Deletes an item.
 | DeleteItem(ID, Database) | Deletes an item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetChildrenAt | Gets the children at.
 | GetCopyOfName | Gets an item name that includes a "Copy of" text.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItemFromPartialPath | Gets an item from a partial path.
 | GetItemID | Gets the item ID.
 | GetItemNameError | Gets an error text for an item name.
 | GetLevel | Gets the level of an item.
 | GetParentID | Gets the parent ID of an item.
 | GetParentName(Item) | Gets the name of the parent of an item.
 | GetParentName(Item, Boolean) | Gets the name of the parent.
 | GetTemplateKey | Gets the template key.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsDataField | Determines whether [is data field] [the specified template field].
 | IsItemNameValid | Determines whether an item name is valid.
 | IsNull | Determines whether the specified id is null.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProposeValidItemName(String) | Given a invalid itemname, proposes a new itemname where all invalid characters have been replased with an empty character.
 | ProposeValidItemName(String, String) | Given a invalid itemname, proposes a new itemname where all invalid characters have been replased with an empty character.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemUtil Class
Sitecore.Data.Items Namespace


AddFromTemplate Method

[image]

Sitecore 6.4.1 API
ItemUtil..::..AddFromTemplate Method
ItemUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item AddFromTemplate(
    string itemName,
    string templateName,
    Item parent
)
Visual Basic
Public Shared Function AddFromTemplate ( _
    itemName As String, _
    templateName As String, _
    parent As Item _
) As Item
Visual C++
public:
static Item^ AddFromTemplate(
    String^ itemName,
    String^ templateName,
    Item^ parent
)

Parameters

itemName
Type: System..::..String
Name of the item.
templateName
Type: System..::..String
Name of the template.
parent
Type: Sitecore.Data.Items..::..Item
The parent.

Return Value

The from template.

See Also

ItemUtil Class
Sitecore.Data.Items Namespace


AssertItemName Method

[image]

Sitecore 6.4.1 API
ItemUtil..::..AssertItemName Method
ItemUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void AssertItemName(
    string name
)
Visual Basic
Public Shared Sub AssertItemName ( _
    name As String _
)
Visual C++
public:
static void AssertItemName(
    String^ name
)

Parameters

name
Type: System..::..String
Item name.

See Also

ItemUtil Class
Sitecore.Data.Items Namespace


CopyItem Method

[image]

Sitecore 6.4.1 API
ItemUtil..::..CopyItem Method
ItemUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item CopyItem(
    Item source,
    Item destination,
    bool saveIds,
    bool deep
)
Visual Basic
Public Shared Function CopyItem ( _
    source As Item, _
    destination As Item, _
    saveIds As Boolean, _
    deep As Boolean _
) As Item
Visual C++
public:
static Item^ CopyItem(
    Item^ source,
    Item^ destination,
    bool saveIds,
    bool deep
)

Parameters

source
Type: Sitecore.Data.Items..::..Item
The source.
destination
Type: Sitecore.Data.Items..::..Item
The destination.
saveIds
Type: System..::..Boolean
if set to true values of ids will be saved.
deep
Type: System..::..Boolean
if set to true childer will be copied.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Items.ItemUtil.CopyItem(Sitecore.Data.Items.Item,Sitecore.Data.Items.Item,System.Boolean,System.Boolean)"]

See Also

ItemUtil Class
Sitecore.Data.Items Namespace


DeleteItem Method

[image] [image]

Sitecore 6.4.1 API
ItemUtil..::..DeleteItem Method
ItemUtil Class See Also Send Feedback

Overload List

Name | Description
DeleteItem(String, Database) | Deletes an item.
DeleteItem(ID, Database) | Deletes an item.

See Also

ItemUtil Class
ItemUtil Members
Sitecore.Data.Items Namespace


DeleteItem Method (String, Database)

[image]

Sitecore 6.4.1 API
ItemUtil..::..DeleteItem Method (String, Database)
ItemUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void DeleteItem(
    string path,
    Database database
)
Visual Basic
Public Shared Sub DeleteItem ( _
    path As String, _
    database As Database _
)
Visual C++
public:
static void DeleteItem(
    String^ path,
    Database^ database
)

Parameters

path
Type: System..::..String
Path of the item.
database
Type: Sitecore.Data..::..Database
Database.

See Also

ItemUtil Class
DeleteItem Overload
Sitecore.Data.Items Namespace


DeleteItem Method (ID, Database)

[image]

Sitecore 6.4.1 API
ItemUtil..::..DeleteItem Method (ID, Database)
ItemUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void DeleteItem(
    ID itemID,
    Database database
)
Visual Basic
Public Shared Sub DeleteItem ( _
    itemID As ID, _
    database As Database _
)
Visual C++
public:
static void DeleteItem(
    ID^ itemID,
    Database^ database
)

Parameters

itemID
Type: Sitecore.Data..::..ID
ID of the item.
database
Type: Sitecore.Data..::..Database
Database.

See Also

ItemUtil Class
DeleteItem Overload
Sitecore.Data.Items Namespace


GetChildrenAt Method

[image]

Sitecore 6.4.1 API
ItemUtil..::..GetChildrenAt Method
ItemUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static List<Item> GetChildrenAt(
    string path
)
Visual Basic
Public Shared Function GetChildrenAt ( _
    path As String _
) As List(Of Item)
Visual C++
public:
static List<Item^>^ GetChildrenAt(
    String^ path
)

Parameters

path
Type: System..::..String
The path.

Return Value

The children at.

See Also

ItemUtil Class
Sitecore.Data.Items Namespace


GetCopyOfName Method

[image]

Sitecore 6.4.1 API
ItemUtil..::..GetCopyOfName Method
ItemUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetCopyOfName(
    Item destination,
    string name
)
Visual Basic
Public Shared Function GetCopyOfName ( _
    destination As Item, _
    name As String _
) As String
Visual C++
public:
static String^ GetCopyOfName(
    Item^ destination,
    String^ name
)

Parameters

destination
Type: Sitecore.Data.Items..::..Item
Parent item of the item.
name
Type: System..::..String
Name.

Return Value

The name.

See Also

ItemUtil Class
Sitecore.Data.Items Namespace


GetItemFromPartialPath Method

[image]

Sitecore 6.4.1 API
ItemUtil..::..GetItemFromPartialPath Method
ItemUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item GetItemFromPartialPath(
    string partialPath,
    Database database
)
Visual Basic
Public Shared Function GetItemFromPartialPath ( _
    partialPath As String, _
    database As Database _
) As Item
Visual C++
public:
static Item^ GetItemFromPartialPath(
    String^ partialPath,
    Database^ database
)

Parameters

partialPath
Type: System..::..String
Partial path.
database
Type: Sitecore.Data..::..Database
Database.

Return Value

The item from partial path.

See Also

ItemUtil Class
Sitecore.Data.Items Namespace


GetItemID Method

[image]

Sitecore 6.4.1 API
ItemUtil..::..GetItemID Method
ItemUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID GetItemID(
    string itemPath,
    Database database
)
Visual Basic
Public Shared Function GetItemID ( _
    itemPath As String, _
    database As Database _
) As ID
Visual C++
public:
static ID^ GetItemID(
    String^ itemPath,
    Database^ database
)

Parameters

itemPath
Type: System..::..String
The item path.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

The item ID.

See Also

ItemUtil Class
Sitecore.Data.Items Namespace


GetItemNameError Method

[image]

Sitecore 6.4.1 API
ItemUtil..::..GetItemNameError Method
ItemUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetItemNameError(
    string name
)
Visual Basic
Public Shared Function GetItemNameError ( _
    name As String _
) As String
Visual C++
public:
static String^ GetItemNameError(
    String^ name
)

Parameters

name
Type: System..::..String
Item name.

Return Value

The item name error.

See Also

ItemUtil Class
Sitecore.Data.Items Namespace


GetLevel Method

[image]

Sitecore 6.4.1 API
ItemUtil..::..GetLevel Method
ItemUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int GetLevel(
    Item itm
)
Visual Basic
Public Shared Function GetLevel ( _
    itm As Item _
) As Integer
Visual C++
public:
static int GetLevel(
    Item^ itm
)

Parameters

itm
Type: Sitecore.Data.Items..::..Item
The itm.

Return Value

The level.

Remarks

"/sitecore" is level 0 (zero), "/sitecore/content" is level 1 (one) and so forth.

See Also

ItemUtil Class
Sitecore.Data.Items Namespace


GetParentID Method

[image]

Sitecore 6.4.1 API
ItemUtil..::..GetParentID Method
ItemUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID GetParentID(
    Item item
)
Visual Basic
Public Shared Function GetParentID ( _
    item As Item _
) As ID
Visual C++
public:
static ID^ GetParentID(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
Item.

Return Value

The parent ID.

See Also

ItemUtil Class
Sitecore.Data.Items Namespace


GetParentName Method

[image] [image]

Sitecore 6.4.1 API
ItemUtil..::..GetParentName Method
ItemUtil Class See Also Send Feedback

Overload List

Name | Description
GetParentName(Item) | Gets the name of the parent of an item.
GetParentName(Item, Boolean) | Gets the name of the parent.

See Also

ItemUtil Class
ItemUtil Members
Sitecore.Data.Items Namespace


GetParentName Method (Item)

[image]

Sitecore 6.4.1 API
ItemUtil..::..GetParentName Method (Item)
ItemUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetParentName(
    Item item
)
Visual Basic
Public Shared Function GetParentName ( _
    item As Item _
) As String
Visual C++
public:
static String^ GetParentName(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
Item.

Return Value

The name.

See Also

ItemUtil Class
GetParentName Overload
Sitecore.Data.Items Namespace


GetParentName Method (Item, Boolean)

[image]

Sitecore 6.4.1 API
ItemUtil..::..GetParentName Method (Item, Boolean)
ItemUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetParentName(
    Item item,
    bool useDisplayName
)
Visual Basic
Public Shared Function GetParentName ( _
    item As Item, _
    useDisplayName As Boolean _
) As String
Visual C++
public:
static String^ GetParentName(
    Item^ item,
    bool useDisplayName
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
Item.
useDisplayName
Type: System..::..Boolean
Use the display name of the parent item.

Return Value

The parent name.

See Also

ItemUtil Class
GetParentName Overload
Sitecore.Data.Items Namespace


GetTemplateKey Method

[image]

Sitecore 6.4.1 API
ItemUtil..::..GetTemplateKey Method
ItemUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetTemplateKey(
    Item item
)
Visual Basic
Public Shared Function GetTemplateKey ( _
    item As Item _
) As String
Visual C++
public:
static String^ GetTemplateKey(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Items.ItemUtil.GetTemplateKey(Sitecore.Data.Items.Item)"]

See Also

ItemUtil Class
Sitecore.Data.Items Namespace


IsDataField Method

[image]

Sitecore 6.4.1 API
ItemUtil..::..IsDataField Method
ItemUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsDataField(
    TemplateField templateField
)
Visual Basic
Public Shared Function IsDataField ( _
    templateField As TemplateField _
) As Boolean
Visual C++
public:
static bool IsDataField(
    TemplateField^ templateField
)

Parameters

templateField
Type: Sitecore.Data.Templates..::..TemplateField
The template field.

Return Value

true if [is data field] [the specified template field]; otherwise, false.

See Also

ItemUtil Class
Sitecore.Data.Items Namespace


IsItemNameValid Method

[image]

Sitecore 6.4.1 API
ItemUtil..::..IsItemNameValid Method
ItemUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsItemNameValid(
    string name
)
Visual Basic
Public Shared Function IsItemNameValid ( _
    name As String _
) As Boolean
Visual C++
public:
static bool IsItemNameValid(
    String^ name
)

Parameters

name
Type: System..::..String
Name.

Return Value

true if the item name is valid; otherwise, false.

See Also

ItemUtil Class
Sitecore.Data.Items Namespace


IsNull Method

[image]

Sitecore 6.4.1 API
ItemUtil..::..IsNull Method
ItemUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsNull(
    ID id
)
Visual Basic
Public Shared Function IsNull ( _
    id As ID _
) As Boolean
Visual C++
public:
static bool IsNull(
    ID^ id
)

Parameters

id
Type: Sitecore.Data..::..ID
The id.

Return Value

true if the specified id is null; otherwise, false.

See Also

ItemUtil Class
Sitecore.Data.Items Namespace


ProposeValidItemName Method

[image] [image]

Sitecore 6.4.1 API
ItemUtil..::..ProposeValidItemName Method
ItemUtil Class See Also Send Feedback

Overload List

Name | Description
ProposeValidItemName(String) | Given a invalid itemname, proposes a new itemname where all invalid characters have been replased with an empty character.
ProposeValidItemName(String, String) | Given a invalid itemname, proposes a new itemname where all invalid characters have been replased with an empty character.

See Also

ItemUtil Class
ItemUtil Members
Sitecore.Data.Items Namespace


ProposeValidItemName Method (String)

[image]

Sitecore 6.4.1 API
ItemUtil..::..ProposeValidItemName Method (String)
ItemUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ProposeValidItemName(
    string name
)
Visual Basic
Public Shared Function ProposeValidItemName ( _
    name As String _
) As String
Visual C++
public:
static String^ ProposeValidItemName(
    String^ name
)

Parameters

name
Type: System..::..String
Item name.

Return Value

The name.

See Also

ItemUtil Class
ProposeValidItemName Overload
Sitecore.Data.Items Namespace


ProposeValidItemName Method (String, String)

[image]

Sitecore 6.4.1 API
ItemUtil..::..ProposeValidItemName Method (String, String)
ItemUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ProposeValidItemName(
    string name,
    string defaultValue
)
Visual Basic
Public Shared Function ProposeValidItemName ( _
    name As String, _
    defaultValue As String _
) As String
Visual C++
public:
static String^ ProposeValidItemName(
    String^ name,
    String^ defaultValue
)

Parameters

name
Type: System..::..String
Item name.
defaultValue
Type: System..::..String
The default value.

Return Value

The name.

See Also

ItemUtil Class
ProposeValidItemName Overload
Sitecore.Data.Items Namespace


ItemVersions Class

[image]

Sitecore 6.4.1 API
ItemVersions Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemVersions
Visual Basic
Public Class ItemVersions
Visual C++
public ref class ItemVersions

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..ItemVersions

See Also

ItemVersions Members
Sitecore.Data.Items Namespace


ItemVersions Members

[image] [image]

Sitecore 6.4.1 API
ItemVersions Members
ItemVersions Class Constructors Methods Properties See Also Send Feedback

The ItemVersions type exposes the following members.

Constructors

 | Name | Description
Public method | ItemVersions | Creates a new ItemVersions instance.

Methods

 | Name | Description
Public method | AddVersion | Adds a new version to the source item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLaterVersions | Gets the versions that have come after the current version.
Public method | GetLatestVersion()()()() | Gets the latest version of current item language.
Public method | GetLatestVersion(Language) | Gets the latest version of item in defined language.
Public method | GetOlderVersions | Gets the versions that have come before the current version.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersionNumbers()()()() | Gets a list of version numbers for the source item.
Public method | GetVersionNumbers(Boolean) | Gets a list of version numbers for the source item.
Public method | GetVersions()()()() | Gets the versions of the source item.
Public method | GetVersions(Boolean) | Gets the versions of the source item.
Public method | IsLatestVersion | Determines whether item is the latest version in item language.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveAll | Removes all the versions of an item.
Public method | RemoveVersion | Removes a version.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the count.
Public property | Item | Gets the Item with the specified version.

See Also

ItemVersions Class
Sitecore.Data.Items Namespace


ItemVersions Constructor

[image]

Sitecore 6.4.1 API
ItemVersions Constructor
ItemVersions Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemVersions(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
ItemVersions(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
Source item.

See Also

ItemVersions Class
Sitecore.Data.Items Namespace


ItemVersions Methods

[image] [image]

Sitecore 6.4.1 API
ItemVersions Methods
ItemVersions Class See Also Send Feedback

The ItemVersions type exposes the following members.

Methods

 | Name | Description
Public method | AddVersion | Adds a new version to the source item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLaterVersions | Gets the versions that have come after the current version.
Public method | GetLatestVersion()()()() | Gets the latest version of current item language.
Public method | GetLatestVersion(Language) | Gets the latest version of item in defined language.
Public method | GetOlderVersions | Gets the versions that have come before the current version.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersionNumbers()()()() | Gets a list of version numbers for the source item.
Public method | GetVersionNumbers(Boolean) | Gets a list of version numbers for the source item.
Public method | GetVersions()()()() | Gets the versions of the source item.
Public method | GetVersions(Boolean) | Gets the versions of the source item.
Public method | IsLatestVersion | Determines whether item is the latest version in item language.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveAll | Removes all the versions of an item.
Public method | RemoveVersion | Removes a version.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemVersions Class
Sitecore.Data.Items Namespace


GetLaterVersions Method

[image]

Sitecore 6.4.1 API
ItemVersions..::..GetLaterVersions Method
ItemVersions Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item[] GetLaterVersions()
Visual Basic
Public Function GetLaterVersions As Item()
Visual C++
public:
array<Item^>^ GetLaterVersions()

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Items.ItemVersions.GetLaterVersions"]

See Also

ItemVersions Class
Sitecore.Data.Items Namespace


GetLatestVersion Method

[image] [image]

Sitecore 6.4.1 API
ItemVersions..::..GetLatestVersion Method
ItemVersions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetLatestVersion()()()() | Gets the latest version of current item language.
Public method | GetLatestVersion(Language) | Gets the latest version of item in defined language.

See Also

ItemVersions Class
ItemVersions Members
Sitecore.Data.Items Namespace


GetLatestVersion Method

[image]

Sitecore 6.4.1 API
ItemVersions..::..GetLatestVersion Method
ItemVersions Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetLatestVersion()
Visual Basic
Public Function GetLatestVersion As Item
Visual C++
public:
Item^ GetLatestVersion()

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Items.ItemVersions.GetLatestVersion"]

See Also

ItemVersions Class
GetLatestVersion Overload
Sitecore.Data.Items Namespace


GetLatestVersion Method (Language)

[image]

Sitecore 6.4.1 API
ItemVersions..::..GetLatestVersion Method (Language)
ItemVersions Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetLatestVersion(
    Language language
)
Visual Basic
Public Function GetLatestVersion ( _
    language As Language _
) As Item
Visual C++
public:
Item^ GetLatestVersion(
    Language^ language
)

Parameters

language
Type: Sitecore.Globalization..::..Language
The language.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Items.ItemVersions.GetLatestVersion(Sitecore.Globalization.Language)"]

See Also

ItemVersions Class
GetLatestVersion Overload
Sitecore.Data.Items Namespace


GetOlderVersions Method

[image]

Sitecore 6.4.1 API
ItemVersions..::..GetOlderVersions Method
ItemVersions Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item[] GetOlderVersions()
Visual Basic
Public Function GetOlderVersions As Item()
Visual C++
public:
array<Item^>^ GetOlderVersions()

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Items.ItemVersions.GetOlderVersions"]

See Also

ItemVersions Class
Sitecore.Data.Items Namespace


GetVersionNumbers Method

[image] [image]

Sitecore 6.4.1 API
ItemVersions..::..GetVersionNumbers Method
ItemVersions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetVersionNumbers()()()() | Gets a list of version numbers for the source item.
Public method | GetVersionNumbers(Boolean) | Gets a list of version numbers for the source item.

See Also

ItemVersions Class
ItemVersions Members
Sitecore.Data.Items Namespace


GetVersionNumbers Method

[image]

Sitecore 6.4.1 API
ItemVersions..::..GetVersionNumbers Method
ItemVersions Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Version[] GetVersionNumbers()
Visual Basic
Public Function GetVersionNumbers As Version()
Visual C++
public:
array<Version^>^ GetVersionNumbers()

Return Value

The version numbers.

See Also

ItemVersions Class
GetVersionNumbers Overload
Sitecore.Data.Items Namespace


GetVersionNumbers Method (Boolean)

[image]

Sitecore 6.4.1 API
ItemVersions..::..GetVersionNumbers Method (Boolean)
ItemVersions Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Version[] GetVersionNumbers(
    bool atLeastOne
)
Visual Basic
Public Function GetVersionNumbers ( _
    atLeastOne As Boolean _
) As Version()
Visual C++
public:
array<Version^>^ GetVersionNumbers(
    bool atLeastOne
)

Parameters

atLeastOne
Type: System..::..Boolean
if set to true this instance is at least one.

Return Value

The version numbers.

See Also

ItemVersions Class
GetVersionNumbers Overload
Sitecore.Data.Items Namespace


GetVersions Method

[image] [image]

Sitecore 6.4.1 API
ItemVersions..::..GetVersions Method
ItemVersions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetVersions()()()() | Gets the versions of the source item.
Public method | GetVersions(Boolean) | Gets the versions of the source item.

See Also

ItemVersions Class
ItemVersions Members
Sitecore.Data.Items Namespace


GetVersions Method

[image]

Sitecore 6.4.1 API
ItemVersions..::..GetVersions Method
ItemVersions Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item[] GetVersions()
Visual Basic
Public Function GetVersions As Item()
Visual C++
public:
array<Item^>^ GetVersions()

Return Value

The versions.

See Also

ItemVersions Class
GetVersions Overload
Sitecore.Data.Items Namespace


GetVersions Method (Boolean)

[image]

Sitecore 6.4.1 API
ItemVersions..::..GetVersions Method (Boolean)
ItemVersions Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item[] GetVersions(
    bool includeAllLanguages
)
Visual Basic
Public Function GetVersions ( _
    includeAllLanguages As Boolean _
) As Item()
Visual C++
public:
array<Item^>^ GetVersions(
    bool includeAllLanguages
)

Parameters

includeAllLanguages
Type: System..::..Boolean
Include all languages.

Return Value

The versions.

See Also

ItemVersions Class
GetVersions Overload
Sitecore.Data.Items Namespace


IsLatestVersion Method

[image]

Sitecore 6.4.1 API
ItemVersions..::..IsLatestVersion Method
ItemVersions Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsLatestVersion()
Visual Basic
Public Function IsLatestVersion As Boolean
Visual C++
public:
bool IsLatestVersion()

Return Value

true if item is the latest version in item language otherwise, false.

See Also

ItemVersions Class
Sitecore.Data.Items Namespace


RemoveAll Method

[image]

Sitecore 6.4.1 API
ItemVersions..::..RemoveAll Method
ItemVersions Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RemoveAll(
    bool includeAllLanguages
)
Visual Basic
Public Sub RemoveAll ( _
    includeAllLanguages As Boolean _
)
Visual C++
public:
void RemoveAll(
    bool includeAllLanguages
)

Parameters

includeAllLanguages
Type: System..::..Boolean
if set to true this instance is include all languages.

See Also

ItemVersions Class
Sitecore.Data.Items Namespace


RemoveVersion Method

[image]

Sitecore 6.4.1 API
ItemVersions..::..RemoveVersion Method
ItemVersions Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RemoveVersion()
Visual Basic
Public Sub RemoveVersion
Visual C++
public:
void RemoveVersion()

See Also

ItemVersions Class
Sitecore.Data.Items Namespace


ItemVersions Properties

[image] [image]

Sitecore 6.4.1 API
ItemVersions Properties
ItemVersions Class See Also Send Feedback

The ItemVersions type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the count.
Public property | Item | Gets the Item with the specified version.

See Also

ItemVersions Class
Sitecore.Data.Items Namespace


Count Property

[image]

Sitecore 6.4.1 API
ItemVersions..::..Count Property
ItemVersions Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
property int Count {
    int get ();
}

Field Value

The count.

See Also

ItemVersions Class
Sitecore.Data.Items Namespace


Item Property

[image]

Sitecore 6.4.1 API
ItemVersions..::..Item Property
ItemVersions Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item this[
    Version version
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    version As Version _
) As Item
    Get
Visual C++
public:
property Item^ default[Version^ version] {
    Item^ get (Version^ version);
}

Parameters

version
Type: Sitecore.Data..::..Version

Field Value

See Also

ItemVersions Class
Sitecore.Data.Items Namespace


ItemVisualization Class

[image]

Sitecore 6.4.1 API
ItemVisualization Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemVisualization
Visual Basic
Public Class ItemVisualization
Visual C++
public ref class ItemVisualization

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..ItemVisualization

See Also

ItemVisualization Members
Sitecore.Data.Items Namespace


ItemVisualization Members

[image] [image]

Sitecore 6.4.1 API
ItemVisualization Members
ItemVisualization Class Constructors Methods Properties See Also Send Feedback

The ItemVisualization type exposes the following members.

Constructors

 | Name | Description
Public method | ItemVisualization | Initializes a new instance of the ItemVisualization class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLayout | Gets the layout item for the source item in a specific device.
Public method | GetLayoutID | Gets the layout ID.
Public method | GetRenderer | Gets the renderer control for the item.
Public method | GetRenderings | Gets the renderings for a device.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Layout | Gets the layout item for the source item.

See Also

ItemVisualization Class
Sitecore.Data.Items Namespace


ItemVisualization Constructor

[image]

Sitecore 6.4.1 API
ItemVisualization Constructor
ItemVisualization Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemVisualization(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
ItemVisualization(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

ItemVisualization Class
Sitecore.Data.Items Namespace


ItemVisualization Methods

[image] [image]

Sitecore 6.4.1 API
ItemVisualization Methods
ItemVisualization Class See Also Send Feedback

The ItemVisualization type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLayout | Gets the layout item for the source item in a specific device.
Public method | GetLayoutID | Gets the layout ID.
Public method | GetRenderer | Gets the renderer control for the item.
Public method | GetRenderings | Gets the renderings for a device.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemVisualization Class
Sitecore.Data.Items Namespace


GetLayout Method

[image]

Sitecore 6.4.1 API
ItemVisualization..::..GetLayout Method
ItemVisualization Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LayoutItem GetLayout(
    DeviceItem device
)
Visual Basic
Public Function GetLayout ( _
    device As DeviceItem _
) As LayoutItem
Visual C++
public:
LayoutItem^ GetLayout(
    DeviceItem^ device
)

Parameters

device
Type: Sitecore.Data.Items..::..DeviceItem
The device.

Return Value

The layout.

See Also

ItemVisualization Class
Sitecore.Data.Items Namespace


GetLayoutID Method

[image]

Sitecore 6.4.1 API
ItemVisualization..::..GetLayoutID Method
ItemVisualization Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID GetLayoutID(
    DeviceItem device
)
Visual Basic
Public Function GetLayoutID ( _
    device As DeviceItem _
) As ID
Visual C++
public:
ID^ GetLayoutID(
    DeviceItem^ device
)

Parameters

device
Type: Sitecore.Data.Items..::..DeviceItem
The device.

Return Value

The layout ID.

See Also

ItemVisualization Class
Sitecore.Data.Items Namespace


GetRenderer Method

[image]

Sitecore 6.4.1 API
ItemVisualization..::..GetRenderer Method
ItemVisualization Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Control GetRenderer(
    string mode,
    bool allowDefault
)
Visual Basic
Public Function GetRenderer ( _
    mode As String, _
    allowDefault As Boolean _
) As Control
Visual C++
public:
Control^ GetRenderer(
    String^ mode,
    bool allowDefault
)

Parameters

mode
Type: System..::..String
The mode.
allowDefault
Type: System..::..Boolean
Allow default.

Return Value

The renderer.

See Also

ItemVisualization Class
Sitecore.Data.Items Namespace


GetRenderings Method

[image]

Sitecore 6.4.1 API
ItemVisualization..::..GetRenderings Method
ItemVisualization Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderingReference[] GetRenderings(
    DeviceItem device,
    bool checkLogin
)
Visual Basic
Public Function GetRenderings ( _
    device As DeviceItem, _
    checkLogin As Boolean _
) As RenderingReference()
Visual C++
public:
array<RenderingReference^>^ GetRenderings(
    DeviceItem^ device,
    bool checkLogin
)

Parameters

device
Type: Sitecore.Data.Items..::..DeviceItem
The device.
checkLogin
Type: System..::..Boolean
Check if a user is logged in. If not, use login renderings (if assigned).

Return Value

The renderings.

See Also

ItemVisualization Class
Sitecore.Data.Items Namespace


ItemVisualization Properties

[image] [image]

Sitecore 6.4.1 API
ItemVisualization Properties
ItemVisualization Class See Also Send Feedback

The ItemVisualization type exposes the following members.

Properties

 | Name | Description
Public property | Layout | Gets the layout item for the source item.

See Also

ItemVisualization Class
Sitecore.Data.Items Namespace


Layout Property

[image]

Sitecore 6.4.1 API
ItemVisualization..::..Layout Property
ItemVisualization Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LayoutItem Layout { get; }
Visual Basic
Public ReadOnly Property Layout As LayoutItem
    Get
Visual C++
public:
property LayoutItem^ Layout {
    LayoutItem^ get ();
}

Field Value

The layout.

See Also

ItemVisualization Class
Sitecore.Data.Items Namespace


ITrackingItem Interface

[image]

Sitecore 6.4.1 API
ITrackingItem Interface
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface ITrackingItem
Visual Basic
Public Interface ITrackingItem
Visual C++
public interface class ITrackingItem

See Also

ITrackingItem Members
Sitecore.Data.Items Namespace


ITrackingItem Members

[image] [image]

Sitecore 6.4.1 API
ITrackingItem Members
ITrackingItem Interface Properties See Also Send Feedback

The ITrackingItem type exposes the following members.

Properties

 | Name | Description
Public property | IsDefinitionModified | Gets a value indicating whether the definition has been modified.

See Also

ITrackingItem Interface
Sitecore.Data.Items Namespace


ITrackingItem Properties

[image] [image]

Sitecore 6.4.1 API
ITrackingItem Properties
ITrackingItem Interface See Also Send Feedback

The ITrackingItem type exposes the following members.

Properties

 | Name | Description
Public property | IsDefinitionModified | Gets a value indicating whether the definition has been modified.

See Also

ITrackingItem Interface
Sitecore.Data.Items Namespace


LayoutItem Class

[image]

Sitecore 6.4.1 API
LayoutItem Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class LayoutItem : CustomItemBase
Visual Basic
Public Class LayoutItem _
    Inherits CustomItemBase
Visual C++
public ref class LayoutItem : public CustomItemBase

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..CustomItemBase
Sitecore.Data.Items..::..LayoutItem

See Also

LayoutItem Members
Sitecore.Data.Items Namespace


LayoutItem Members

[image] [image]

Sitecore 6.4.1 API
LayoutItem Members
LayoutItem Class Constructors Methods Operators Properties See Also Send Feedback

The LayoutItem type exposes the following members.

Constructors

 | Name | Description
Public method | LayoutItem | Creates a new LayoutItem instance.

Methods

 | Name | Description
Public method | BeginEdit | Begins editing the item. (Inherited from CustomItemBase.)
Public method | EndEdit | Ends editing the item. (Inherited from CustomItemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Item to LayoutItem) | Converts an item to a LayoutItem.

Properties

 | Name | Description
Public property | Control | Gets the control of the layout.
Public property | Database | Gets the database. (Inherited from CustomItemBase.)
Public property | DisplayName | Gets the display name. (Inherited from CustomItemBase.)
Public property | FilePath | Gets the file path of the layout.
Public property | Icon | Gets the icon. (Inherited from CustomItemBase.)
Public property | ID | Gets the ID. (Inherited from CustomItemBase.)
Public property | InnerItem | Gets the inner item. (Inherited from CustomItemBase.)
Public property | Name | Gets the name. (Inherited from CustomItemBase.)

See Also

LayoutItem Class
Sitecore.Data.Items Namespace


LayoutItem Constructor

[image]

Sitecore 6.4.1 API
LayoutItem Constructor
LayoutItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LayoutItem(
    Item innerItem
)
Visual Basic
Public Sub New ( _
    innerItem As Item _
)
Visual C++
public:
LayoutItem(
    Item^ innerItem
)

Parameters

innerItem
Type: Sitecore.Data.Items..::..Item
Inner item.

See Also

LayoutItem Class
Sitecore.Data.Items Namespace


LayoutItem Methods

[image] [image]

Sitecore 6.4.1 API
LayoutItem Methods
LayoutItem Class See Also Send Feedback

The LayoutItem type exposes the following members.

Methods

 | Name | Description
Public method | BeginEdit | Begins editing the item. (Inherited from CustomItemBase.)
Public method | EndEdit | Ends editing the item. (Inherited from CustomItemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LayoutItem Class
Sitecore.Data.Items Namespace


Implicit Conversion (Item to LayoutItem)

[image]

Sitecore 6.4.1 API
LayoutItem ImplicitWideningImplicitImplicitImplicit Conversion (Item to LayoutItem)
LayoutItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator LayoutItem (
    Item item
)
Visual Basic
Public Shared Widening Operator CType ( _
    item As Item _
) As LayoutItem
Visual C++
static implicit operator LayoutItem^ (
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

The implicit operator.

See Also

LayoutItem Class
Sitecore.Data.Items Namespace


LayoutItem Properties

[image] [image]

Sitecore 6.4.1 API
LayoutItem Properties
LayoutItem Class See Also Send Feedback

The LayoutItem type exposes the following members.

Properties

 | Name | Description
Public property | Control | Gets the control of the layout.
Public property | Database | Gets the database. (Inherited from CustomItemBase.)
Public property | DisplayName | Gets the display name. (Inherited from CustomItemBase.)
Public property | FilePath | Gets the file path of the layout.
Public property | Icon | Gets the icon. (Inherited from CustomItemBase.)
Public property | ID | Gets the ID. (Inherited from CustomItemBase.)
Public property | InnerItem | Gets the inner item. (Inherited from CustomItemBase.)
Public property | Name | Gets the name. (Inherited from CustomItemBase.)

See Also

LayoutItem Class
Sitecore.Data.Items Namespace


Control Property

[image]

Sitecore 6.4.1 API
LayoutItem..::..Control Property
LayoutItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Control { get; }
Visual Basic
Public ReadOnly Property Control As String
    Get
Visual C++
public:
property String^ Control {
    String^ get ();
}

Field Value

The control.

See Also

LayoutItem Class
Sitecore.Data.Items Namespace


FilePath Property

[image]

Sitecore 6.4.1 API
LayoutItem..::..FilePath Property
LayoutItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string FilePath { get; }
Visual Basic
Public ReadOnly Property FilePath As String
    Get
Visual C++
public:
property String^ FilePath {
    String^ get ();
}

Field Value

The file path.

See Also

LayoutItem Class
Sitecore.Data.Items Namespace


MediaItem Class

[image]

Sitecore 6.4.1 API
MediaItem Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class MediaItem : CustomItemBase
Visual Basic
Public Class MediaItem _
    Inherits CustomItemBase
Visual C++
public ref class MediaItem : public CustomItemBase

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..CustomItemBase
Sitecore.Data.Items..::..MediaItem

See Also

MediaItem Members
Sitecore.Data.Items Namespace


MediaItem Members

[image] [image]

Sitecore 6.4.1 API
MediaItem Members
MediaItem Class Constructors Methods Operators Properties See Also Send Feedback

The MediaItem type exposes the following members.

Constructors

 | Name | Description
Public method | MediaItem | Creates a new MediaItem instance.

Methods

 | Name | Description
Public method | BeginEdit | Begins editing the item. (Inherited from CustomItemBase.)
Public method | EndEdit | Ends editing the item. (Inherited from CustomItemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMediaStream | Returns a Stream from the database
Public method | GetMetaData | Gets the meta data.
Public method | GetThumbnail | Obsolete. Gets the thumbnail.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasMediaStream | Determines whether this instance has a mediastream.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ValidateMedia | Validates the media.

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Item to MediaItem) | Converts an item to a MediaItem.
ImplicitWideningImplicitImplicitImplicit(MediaItem to Item) | Converts an item to a MediaItem.

Properties

 | Name | Description
Public property | Alt | Gets the Alt text.
Public property | Database | Gets the database. (Inherited from CustomItemBase.)
Public property | Description | Gets the description.
Public property | DisplayName | Gets the display name. (Inherited from CustomItemBase.)
Public property | Extension | Gets the extension.
Public property | FileBased | Gets a value indicating whether the media is file based.
Public property | FilePath | Gets or sets the path for file based media.
Public property | Icon | Gets the icon. (Inherited from CustomItemBase.)
Public property | ID | Gets the ID. (Inherited from CustomItemBase.)
Public property | InnerItem | Gets the inner item. (Inherited from CustomItemBase.)
Public property | MediaPath | Gets the path in the media library.
Public property | MimeType | Gets the MIME type of the item.
Public property | Name | Gets the name. (Inherited from CustomItemBase.)
Public property | Path | Gets the path.
Public property | Size | Gets or sets the size of the current media data.
Public property | Title | Gets the title.

See Also

MediaItem Class
Sitecore.Data.Items Namespace


MediaItem Methods

[image] [image]

Sitecore 6.4.1 API
MediaItem Methods
MediaItem Class See Also Send Feedback

The MediaItem type exposes the following members.

Methods

 | Name | Description
Public method | BeginEdit | Begins editing the item. (Inherited from CustomItemBase.)
Public method | EndEdit | Ends editing the item. (Inherited from CustomItemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMediaStream | Returns a Stream from the database
Public method | GetMetaData | Gets the meta data.
Public method | GetThumbnail | Obsolete. Gets the thumbnail.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasMediaStream | Determines whether this instance has a mediastream.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ValidateMedia | Validates the media.

See Also

MediaItem Class
Sitecore.Data.Items Namespace


GetMediaStream Method

[image]

Sitecore 6.4.1 API
MediaItem..::..GetMediaStream Method
MediaItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Stream GetMediaStream()
Visual Basic
Public Function GetMediaStream As Stream
Visual C++
public:
Stream^ GetMediaStream()

Return Value

A stream representation of the blob field of this Item

Remarks

It is absolutely essential that the caller closes the returned stream after use. Otherwise,the system may leak resources.

See Also

MediaItem Class
Sitecore.Data.Items Namespace


GetMetaData Method

[image]

Sitecore 6.4.1 API
MediaItem..::..GetMetaData Method
MediaItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MediaMetaDataCollection GetMetaData()
Visual Basic
Public Function GetMetaData As MediaMetaDataCollection
Visual C++
public:
MediaMetaDataCollection^ GetMetaData()

Return Value

The meta data.

See Also

MediaItem Class
Sitecore.Data.Items Namespace


GetThumbnail Method

[image]

Sitecore 6.4.1 API
MediaItem..::..GetThumbnail Method
MediaItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use Media.GetThumbnailStream instead.")]
public string GetThumbnail()
Visual Basic
<ObsoleteAttribute("Deprecated - Use Media.GetThumbnailStream instead.")> _
Public Function GetThumbnail As String
Visual C++
[ObsoleteAttribute(L"Deprecated - Use Media.GetThumbnailStream instead.")]
public:
String^ GetThumbnail()

Return Value

The thumbnail.

See Also

MediaItem Class
Sitecore.Data.Items Namespace


HasMediaStream Method

[image]

Sitecore 6.4.1 API
MediaItem..::..HasMediaStream Method
MediaItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool HasMediaStream(
    string fieldname
)
Visual Basic
Public Function HasMediaStream ( _
    fieldname As String _
) As Boolean
Visual C++
public:
bool HasMediaStream(
    String^ fieldname
)

Parameters

fieldname
Type: System..::..String

[Missing <param name="fieldname"/> documentation for "M:Sitecore.Data.Items.MediaItem.HasMediaStream(System.String)"]

Return Value

true if this instance has a mediastream otherwise, false.

See Also

MediaItem Class
Sitecore.Data.Items Namespace


ValidateMedia Method

[image]

Sitecore 6.4.1 API
MediaItem..::..ValidateMedia Method
MediaItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MediaValidatorResult ValidateMedia()
Visual Basic
Public Function ValidateMedia As MediaValidatorResult
Visual C++
public:
MediaValidatorResult^ ValidateMedia()

Return Value

The media.

See Also

MediaItem Class
Sitecore.Data.Items Namespace


MediaItem Type Conversions

[image] [image]

Sitecore 6.4.1 API
MediaItem Type Conversions
MediaItem Class See Also Send Feedback

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Item to MediaItem) | Converts an item to a MediaItem.
ImplicitWideningImplicitImplicitImplicit(MediaItem to Item) | Converts an item to a MediaItem.

See Also

MediaItem Class
Sitecore.Data.Items Namespace


Implicit Conversion Operators

[image] [image]

Sitecore 6.4.1 API
MediaItem ImplicitWideningImplicitImplicitImplicit Conversion Operators
MediaItem Class See Also Send Feedback

Overload List

Name | Description
ImplicitWideningImplicitImplicitImplicit(Item to MediaItem) | Converts an item to a MediaItem.
ImplicitWideningImplicitImplicitImplicit(MediaItem to Item) | Converts an item to a MediaItem.

See Also

MediaItem Class
MediaItem Members
Sitecore.Data.Items Namespace


Implicit Conversion (Item to MediaItem)

[image]

Sitecore 6.4.1 API
MediaItem ImplicitWideningImplicitImplicitImplicit Conversion (Item to MediaItem)
MediaItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator MediaItem (
    Item item
)
Visual Basic
Public Shared Widening Operator CType ( _
    item As Item _
) As MediaItem
Visual C++
static implicit operator MediaItem^ (
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

The implicit operator.

See Also

MediaItem Class
ImplicitWideningImplicitImplicitImplicit Overload
Sitecore.Data.Items Namespace


Implicit Conversion (MediaItem to Item)

[image]

Sitecore 6.4.1 API
MediaItem ImplicitWideningImplicitImplicitImplicit Conversion (MediaItem to Item)
MediaItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator Item (
    MediaItem mediaItem
)
Visual Basic
Public Shared Widening Operator CType ( _
    mediaItem As MediaItem _
) As Item
Visual C++
static implicit operator Item^ (
    MediaItem^ mediaItem
)

Parameters

mediaItem
Type: Sitecore.Data.Items..::..MediaItem
The item.

Return Value

The implicit operator.

See Also

MediaItem Class
ImplicitWideningImplicitImplicitImplicit Overload
Sitecore.Data.Items Namespace


Alt Property

[image]

Sitecore 6.4.1 API
MediaItem..::..Alt Property
MediaItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Alt { get; set; }
Visual Basic
Public Property Alt As String
    Get
    Set
Visual C++
public:
property String^ Alt {
    String^ get ();
    void set (String^ value);
}

Field Value

The alt.

See Also

MediaItem Class
Sitecore.Data.Items Namespace


Description Property

[image]

Sitecore 6.4.1 API
MediaItem..::..Description Property
MediaItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Description { get; }
Visual Basic
Public ReadOnly Property Description As String
    Get
Visual C++
public:
property String^ Description {
    String^ get ();
}

Field Value

The description.

See Also

MediaItem Class
Sitecore.Data.Items Namespace


Extension Property

[image]

Sitecore 6.4.1 API
MediaItem..::..Extension Property
MediaItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Extension { get; set; }
Visual Basic
Public Property Extension As String
    Get
    Set
Visual C++
public:
property String^ Extension {
    String^ get ();
    void set (String^ value);
}

Field Value

The extension.

See Also

MediaItem Class
Sitecore.Data.Items Namespace


FileBased Property

[image]

Sitecore 6.4.1 API
MediaItem..::..FileBased Property
MediaItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool FileBased { get; }
Visual Basic
Public ReadOnly Property FileBased As Boolean
    Get
Visual C++
public:
property bool FileBased {
    bool get ();
}

Field Value

true if the media is file based; otherwise, false.

See Also

MediaItem Class
Sitecore.Data.Items Namespace


FilePath Property

[image]

Sitecore 6.4.1 API
MediaItem..::..FilePath Property
MediaItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string FilePath { get; set; }
Visual Basic
Public Property FilePath As String
    Get
    Set
Visual C++
public:
property String^ FilePath {
    String^ get ();
    void set (String^ value);
}

Field Value

The file path.

See Also

MediaItem Class
Sitecore.Data.Items Namespace


MediaPath Property

[image]

Sitecore 6.4.1 API
MediaItem..::..MediaPath Property
MediaItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string MediaPath { get; }
Visual Basic
Public ReadOnly Property MediaPath As String
    Get
Visual C++
public:
property String^ MediaPath {
    String^ get ();
}

Field Value

The media path.

See Also

MediaItem Class
Sitecore.Data.Items Namespace


MimeType Property

[image]

Sitecore 6.4.1 API
MediaItem..::..MimeType Property
MediaItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string MimeType { get; }
Visual Basic
Public ReadOnly Property MimeType As String
    Get
Visual C++
public:
property String^ MimeType {
    String^ get ();
}

Field Value

The type of the MIME.

See Also

MediaItem Class
Sitecore.Data.Items Namespace


Path Property

[image]

Sitecore 6.4.1 API
MediaItem..::..Path Property
MediaItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Path { get; }
Visual Basic
Public ReadOnly Property Path As String
    Get
Visual C++
public:
property String^ Path {
    String^ get ();
}

Field Value

The path.

See Also

MediaItem Class
Sitecore.Data.Items Namespace


Size Property

[image]

Sitecore 6.4.1 API
MediaItem..::..Size Property
MediaItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long Size { get; set; }
Visual Basic
Public Property Size As Long
    Get
    Set
Visual C++
public:
property long long Size {
    long long get ();
    void set (long long value);
}

Field Value

The size.

See Also

MediaItem Class
Sitecore.Data.Items Namespace


Title Property

[image]

Sitecore 6.4.1 API
MediaItem..::..Title Property
MediaItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Title { get; }
Visual Basic
Public ReadOnly Property Title As String
    Get
Visual C++
public:
property String^ Title {
    String^ get ();
}

Field Value

The title.

See Also

MediaItem Class
Sitecore.Data.Items Namespace


ProcessorItem Class

[image]

Sitecore 6.4.1 API
ProcessorItem Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ProcessorItem : CustomItemBase
Visual Basic
Public Class ProcessorItem _
    Inherits CustomItemBase
Visual C++
public ref class ProcessorItem : public CustomItemBase

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..CustomItemBase
Sitecore.Data.Items..::..ProcessorItem

See Also

ProcessorItem Members
Sitecore.Data.Items Namespace


ProcessorItem Members

[image] [image]

Sitecore 6.4.1 API
ProcessorItem Members
ProcessorItem Class Constructors Methods Operators Properties See Also Send Feedback

The ProcessorItem type exposes the following members.

Constructors

 | Name | Description
Public method | ProcessorItem | Creates a new ProcessorItem instance.

Methods

 | Name | Description
Public method | BeginEdit | Begins editing the item. (Inherited from CustomItemBase.)
Public method | EndEdit | Ends editing the item. (Inherited from CustomItemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Item to ProcessorItem) | Converts an item to a ProcessorItem

Properties

 | Name | Description
Public property | Active | Obsolete. Gets a value indicating whether this ProcessorItem is active.
Public property | Database | Gets the database. (Inherited from CustomItemBase.)
Public property | Disabled | Gets a value indicating whether this ProcessorItem is disabled.
Public property | DisplayName | Gets the display name. (Inherited from CustomItemBase.)
Public property | Icon | Gets the icon. (Inherited from CustomItemBase.)
Public property | ID | Gets the ID. (Inherited from CustomItemBase.)
Public property | InnerItem | Gets the inner item. (Inherited from CustomItemBase.)
Public property | Method | Gets the method to invoke.
Public property | Name | Gets the name. (Inherited from CustomItemBase.)
Public property | Type | Gets the type/assembly identifier string.

See Also

ProcessorItem Class
Sitecore.Data.Items Namespace


ProcessorItem Constructor

[image]

Sitecore 6.4.1 API
ProcessorItem Constructor
ProcessorItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ProcessorItem(
    Item innerItem
)
Visual Basic
Public Sub New ( _
    innerItem As Item _
)
Visual C++
public:
ProcessorItem(
    Item^ innerItem
)

Parameters

innerItem
Type: Sitecore.Data.Items..::..Item
Inner item.

See Also

ProcessorItem Class
Sitecore.Data.Items Namespace


ProcessorItem Methods

[image] [image]

Sitecore 6.4.1 API
ProcessorItem Methods
ProcessorItem Class See Also Send Feedback

The ProcessorItem type exposes the following members.

Methods

 | Name | Description
Public method | BeginEdit | Begins editing the item. (Inherited from CustomItemBase.)
Public method | EndEdit | Ends editing the item. (Inherited from CustomItemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProcessorItem Class
Sitecore.Data.Items Namespace


ProcessorItem Type Conversions

[image] [image]

Sitecore 6.4.1 API
ProcessorItem Type Conversions
ProcessorItem Class See Also Send Feedback

The ProcessorItem type exposes the following members.

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Item to ProcessorItem) | Converts an item to a ProcessorItem

See Also

ProcessorItem Class
Sitecore.Data.Items Namespace


Implicit Conversion (Item to ProcessorItem)

[image]

Sitecore 6.4.1 API
ProcessorItem ImplicitWideningImplicitImplicitImplicit Conversion (Item to ProcessorItem)
ProcessorItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator ProcessorItem (
    Item item
)
Visual Basic
Public Shared Widening Operator CType ( _
    item As Item _
) As ProcessorItem
Visual C++
static implicit operator ProcessorItem^ (
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

The implicit operator.

See Also

ProcessorItem Class
Sitecore.Data.Items Namespace


ProcessorItem Properties

[image] [image]

Sitecore 6.4.1 API
ProcessorItem Properties
ProcessorItem Class See Also Send Feedback

The ProcessorItem type exposes the following members.

Properties

 | Name | Description
Public property | Active | Obsolete. Gets a value indicating whether this ProcessorItem is active.
Public property | Database | Gets the database. (Inherited from CustomItemBase.)
Public property | Disabled | Gets a value indicating whether this ProcessorItem is disabled.
Public property | DisplayName | Gets the display name. (Inherited from CustomItemBase.)
Public property | Icon | Gets the icon. (Inherited from CustomItemBase.)
Public property | ID | Gets the ID. (Inherited from CustomItemBase.)
Public property | InnerItem | Gets the inner item. (Inherited from CustomItemBase.)
Public property | Method | Gets the method to invoke.
Public property | Name | Gets the name. (Inherited from CustomItemBase.)
Public property | Type | Gets the type/assembly identifier string.

See Also

ProcessorItem Class
Sitecore.Data.Items Namespace


Active Property

[image]

Sitecore 6.4.1 API
ProcessorItem..::..Active Property
ProcessorItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use Disabled instead.")]
public bool Active { get; }
Visual Basic
<ObsoleteAttribute("Deprecated - Use Disabled instead.")> _
Public ReadOnly Property Active As Boolean
    Get
Visual C++
[ObsoleteAttribute(L"Deprecated - Use Disabled instead.")]
public:
property bool Active {
    bool get ();
}

Field Value

true if active; otherwise, false.

See Also

ProcessorItem Class
Sitecore.Data.Items Namespace


Disabled Property

[image]

Sitecore 6.4.1 API
ProcessorItem..::..Disabled Property
ProcessorItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Disabled { get; }
Visual Basic
Public ReadOnly Property Disabled As Boolean
    Get
Visual C++
public:
property bool Disabled {
    bool get ();
}

Field Value

true if disabled; otherwise, false.

See Also

ProcessorItem Class
Sitecore.Data.Items Namespace


Method Property

[image]

Sitecore 6.4.1 API
ProcessorItem..::..Method Property
ProcessorItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Method { get; }
Visual Basic
Public ReadOnly Property Method As String
    Get
Visual C++
public:
property String^ Method {
    String^ get ();
}

Field Value

The method.

See Also

ProcessorItem Class
Sitecore.Data.Items Namespace


Type Property

[image]

Sitecore 6.4.1 API
ProcessorItem..::..Type Property
ProcessorItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Type { get; }
Visual Basic
Public ReadOnly Property Type As String
    Get
Visual C++
public:
property String^ Type {
    String^ get ();
}

Field Value

The type.

See Also

ProcessorItem Class
Sitecore.Data.Items Namespace


ReadOnlyItemList Class

[image]

Sitecore 6.4.1 API
ReadOnlyItemList Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ReadOnlyItemList : ReadOnlyList<Item>
Visual Basic
Public Class ReadOnlyItemList _
    Inherits ReadOnlyList(Of Item)
Visual C++
public ref class ReadOnlyItemList : public ReadOnlyList<Item^>

Inheritance Hierarchy

System..::..Object
Sitecore.Collections..::..ReadOnlyList <(Of <(<' Item >)>)>
Sitecore.Data.Items..::..ReadOnlyItemList

See Also

ReadOnlyItemList Members
Sitecore.Data.Items Namespace


ReadOnlyItemList Constructor

[image] [image]

Sitecore 6.4.1 API
ReadOnlyItemList Constructor
ReadOnlyItemList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadOnlyItemList()()()() | Initializes a new instance of the ItemList class.
Public method | ReadOnlyItemList(IEnumerable<(Of <<'(Item>)>>)) | Initializes a new instance of the ItemList class.

See Also

ReadOnlyItemList Class
ReadOnlyItemList Members
Sitecore.Data.Items Namespace


ReadOnlyItemList Constructor

[image]

Sitecore 6.4.1 API
ReadOnlyItemList Constructor
ReadOnlyItemList Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ReadOnlyItemList()
Visual Basic
Public Sub New
Visual C++
public:
ReadOnlyItemList()

See Also

ReadOnlyItemList Class
ReadOnlyItemList Overload
Sitecore.Data.Items Namespace


ReadOnlyItemList Constructor (IEnumerable(Item))

[image]

Sitecore 6.4.1 API
ReadOnlyItemList Constructor (IEnumerable<(Of <(<'Item>)>)>)
ReadOnlyItemList Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ReadOnlyItemList(
    IEnumerable<Item> entries
)
Visual Basic
Public Sub New ( _
    entries As IEnumerable(Of Item) _
)
Visual C++
public:
ReadOnlyItemList(
    IEnumerable<Item^>^ entries
)

Parameters

entries
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Item >)>)>
The entries.

See Also

ReadOnlyItemList Class
ReadOnlyItemList Overload
Sitecore.Data.Items Namespace


ReadOnlyItemList Methods

[image] [image]

Sitecore 6.4.1 API
ReadOnlyItemList Methods
ReadOnlyItemList Class See Also Send Feedback

The ReadOnlyItemList type exposes the following members.

Methods

 | Name | Description
Public method | Contains | Determines whether the list contains the specified element. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToArray | Converts the list to an array. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReadOnlyItemList Class
Sitecore.Data.Items Namespace


ReadOnlyItemList Properties

[image] [image]

Sitecore 6.4.1 API
ReadOnlyItemList Properties
ReadOnlyItemList Class See Also Send Feedback

The ReadOnlyItemList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of entries in the list. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public property | Item | Gets the element at the specified index. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)

See Also

ReadOnlyItemList Class
Sitecore.Data.Items Namespace


RenderingItem Class

[image]

Sitecore 6.4.1 API
RenderingItem Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RenderingItem : CustomItemBase
Visual Basic
Public Class RenderingItem _
    Inherits CustomItemBase
Visual C++
public ref class RenderingItem : public CustomItemBase

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..CustomItemBase
Sitecore.Data.Items..::..RenderingItem

See Also

RenderingItem Members
Sitecore.Data.Items Namespace


RenderingItem Members

[image] [image]

Sitecore 6.4.1 API
RenderingItem Members
RenderingItem Class Constructors Methods Operators Properties See Also Send Feedback

The RenderingItem type exposes the following members.

Constructors

 | Name | Description
Public method | RenderingItem | Creates a new RenderingItem instance.

Methods

 | Name | Description
Public method | BeginEdit | Begins editing the item. (Inherited from CustomItemBase.)
Public method | EndEdit | Ends editing the item. (Inherited from CustomItemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttributes | Gets the attributes.
Public method | GetControl | Gets the control.
Public method | GetDesignTimeHtml(NameValueCollection, String%) | Gets the design time HTML.
 | GetDesignTimeHtml(String, String, String, String, String, String, NameValueCollection, String%) | Gets the design time HTML.
Public method | GetDesignTimeLiveControl | Gets the control.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem(String, Database, Boolean) | Gets the Rendering item.
 | GetItem(ID, Database, Boolean) | Gets the Rendering item.
Public method | GetParameters | Gets the rendering parameters.
 | GetStandardValuesItemFromParametersTemplate | Gets the standard values item from parameters template.
 | GetTagPrefix | Gets the tag prefix.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsAvalableNotBlobNotSystemField | Determines whether [is avalable not BLOB not system field] [the specified field].
Public method | MakeTagPrefix | Gets the tag prefix.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Item to RenderingItem) | Convert an item to a RenderingItem.

Properties

 | Name | Description
Public property | Caching | Gets caching information.
Public property | Conditions | Gets the conditions.
Public property | Database | Gets the database. (Inherited from CustomItemBase.)
Public property | DataSource | Gets the data source.
Public property | DisplayName | Gets the display name. (Inherited from CustomItemBase.)
Public property | Icon | Gets the icon. (Inherited from CustomItemBase.)
Public property | ID | Gets the ID. (Inherited from CustomItemBase.)
Public property | InnerItem | Gets the inner item. (Inherited from CustomItemBase.)
Public property | MultiVariateTest | Gets the multi variate test.
Public property | Name | Gets the name. (Inherited from CustomItemBase.)
Public property | Parameters | Gets the parameters.
Public property | Placeholder | Gets the placeholder.
Public property | TagName | Gets the name of the tag.
Public property | TagPrefix | Gets the tag prefix.

See Also

RenderingItem Class
Sitecore.Data.Items Namespace


RenderingItem Constructor

[image]

Sitecore 6.4.1 API
RenderingItem Constructor
RenderingItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderingItem(
    Item innerItem
)
Visual Basic
Public Sub New ( _
    innerItem As Item _
)
Visual C++
public:
RenderingItem(
    Item^ innerItem
)

Parameters

innerItem
Type: Sitecore.Data.Items..::..Item
Inner item.

See Also

RenderingItem Class
Sitecore.Data.Items Namespace


RenderingItem Methods

[image] [image]

Sitecore 6.4.1 API
RenderingItem Methods
RenderingItem Class See Also Send Feedback

The RenderingItem type exposes the following members.

Methods

 | Name | Description
Public method | BeginEdit | Begins editing the item. (Inherited from CustomItemBase.)
Public method | EndEdit | Ends editing the item. (Inherited from CustomItemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttributes | Gets the attributes.
Public method | GetControl | Gets the control.
Public method | GetDesignTimeHtml(NameValueCollection, String%) | Gets the design time HTML.
 | GetDesignTimeHtml(String, String, String, String, String, String, NameValueCollection, String%) | Gets the design time HTML.
Public method | GetDesignTimeLiveControl | Gets the control.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem(String, Database, Boolean) | Gets the Rendering item.
 | GetItem(ID, Database, Boolean) | Gets the Rendering item.
Public method | GetParameters | Gets the rendering parameters.
 | GetStandardValuesItemFromParametersTemplate | Gets the standard values item from parameters template.
 | GetTagPrefix | Gets the tag prefix.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsAvalableNotBlobNotSystemField | Determines whether [is avalable not BLOB not system field] [the specified field].
Public method | MakeTagPrefix | Gets the tag prefix.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenderingItem Class
Sitecore.Data.Items Namespace


GetAttributes Method

[image]

Sitecore 6.4.1 API
RenderingItem..::..GetAttributes Method
RenderingItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void GetAttributes(
    NameValueCollection attributes
)
Visual Basic
Public Sub GetAttributes ( _
    attributes As NameValueCollection _
)
Visual C++
public:
void GetAttributes(
    NameValueCollection^ attributes
)

Parameters

attributes
Type: System.Collections.Specialized..::..NameValueCollection
The attributes.

See Also

RenderingItem Class
Sitecore.Data.Items Namespace


GetDesignTimeHtml Method

[image] [image]

Sitecore 6.4.1 API
RenderingItem..::..GetDesignTimeHtml Method
RenderingItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDesignTimeHtml(NameValueCollection, String%) | Gets the design time HTML.
 | GetDesignTimeHtml(String, String, String, String, String, String, NameValueCollection, String%) | Gets the design time HTML.

See Also

RenderingItem Class
RenderingItem Members
Sitecore.Data.Items Namespace


GetDesignTimeHtml Method (NameValueCollection, String)

[image]

Sitecore 6.4.1 API
RenderingItem..::..GetDesignTimeHtml Method (NameValueCollection, String%)
RenderingItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetDesignTimeHtml(
    NameValueCollection querystring,
    ref string html
)
Visual Basic
Public Function GetDesignTimeHtml ( _
    querystring As NameValueCollection, _
    ByRef html As String _
) As String
Visual C++
public:
String^ GetDesignTimeHtml(
    NameValueCollection^ querystring,
    String^% html
)

Parameters

querystring
Type: System.Collections.Specialized..::..NameValueCollection
The querystring.
html
Type: System..::..String %
The HTML.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Items.RenderingItem.GetDesignTimeHtml(System.Collections.Specialized.NameValueCollection,System.String@)"]

See Also

RenderingItem Class
GetDesignTimeHtml Overload
Sitecore.Data.Items Namespace


GetDesignTimeHtml Method (String, String, String, String, String, String, NameValueCollection, String)

[image]

Sitecore 6.4.1 API
RenderingItem..::..GetDesignTimeHtml Method (String, String, String, String, String, String, NameValueCollection, String%)
RenderingItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetDesignTimeHtml(
    string ns,
    string assembly,
    string renderingID,
    string tagPrefix,
    string tagName,
    string parameters,
    NameValueCollection querystring,
    ref string html
)
Visual Basic
Public Shared Function GetDesignTimeHtml ( _
    ns As String, _
    assembly As String, _
    renderingID As String, _
    tagPrefix As String, _
    tagName As String, _
    parameters As String, _
    querystring As NameValueCollection, _
    ByRef html As String _
) As String
Visual C++
public:
static String^ GetDesignTimeHtml(
    String^ ns,
    String^ assembly,
    String^ renderingID,
    String^ tagPrefix,
    String^ tagName,
    String^ parameters,
    NameValueCollection^ querystring,
    String^% html
)

Parameters

ns
Type: System..::..String
The namespace.
assembly
Type: System..::..String
The assembly.
renderingID
Type: System..::..String
The rendering ID.
tagPrefix
Type: System..::..String
The tag prefix.
tagName
Type: System..::..String
Name of the tag.
parameters
Type: System..::..String
The parameters.
querystring
Type: System.Collections.Specialized..::..NameValueCollection
The querystring.
html
Type: System..::..String %
The HTML.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Items.RenderingItem.GetDesignTimeHtml(System.String,System.String,System.String,System.String,System.String,System.String,System.Collections.Specialized.NameValueCollection,System.String@)"]

See Also

RenderingItem Class
GetDesignTimeHtml Overload
Sitecore.Data.Items Namespace


GetDesignTimeLiveControl Method

[image]

Sitecore 6.4.1 API
RenderingItem..::..GetDesignTimeLiveControl Method
RenderingItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Control GetDesignTimeLiveControl(
    RenderingSettings settings
)
Visual Basic
Public Function GetDesignTimeLiveControl ( _
    settings As RenderingSettings _
) As Control
Visual C++
public:
Control^ GetDesignTimeLiveControl(
    RenderingSettings^ settings
)

Parameters

settings
Type: Sitecore.Layouts..::..RenderingSettings
Settings.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Items.RenderingItem.GetDesignTimeLiveControl(Sitecore.Layouts.RenderingSettings)"]

See Also

RenderingItem Class
Sitecore.Data.Items Namespace


GetItem Method

[image] [image]

Sitecore 6.4.1 API
RenderingItem..::..GetItem Method
RenderingItem Class See Also Send Feedback

Overload List

Name | Description
GetItem(String, Database, Boolean) | Gets the Rendering item.
GetItem(ID, Database, Boolean) | Gets the Rendering item.

See Also

RenderingItem Class
RenderingItem Members
Sitecore.Data.Items Namespace


GetItem Method (ID, Database, Boolean)

[image]

Sitecore 6.4.1 API
RenderingItem..::..GetItem Method (ID, Database, Boolean)
RenderingItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static RenderingItem GetItem(
    ID renderingID,
    Database database,
    bool assert
)
Visual Basic
Public Shared Function GetItem ( _
    renderingID As ID, _
    database As Database, _
    assert As Boolean _
) As RenderingItem
Visual C++
public:
static RenderingItem^ GetItem(
    ID^ renderingID,
    Database^ database,
    bool assert
)

Parameters

renderingID
Type: Sitecore.Data..::..ID
Rendering ID.
database
Type: Sitecore.Data..::..Database
Database.
assert
Type: System..::..Boolean
Assert that the item is found.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Items.RenderingItem.GetItem(Sitecore.Data.ID,Sitecore.Data.Database,System.Boolean)"]

See Also

RenderingItem Class
GetItem Overload
Sitecore.Data.Items Namespace


GetParameters Method

[image]

Sitecore 6.4.1 API
RenderingItem..::..GetParameters Method
RenderingItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UrlString GetParameters()
Visual Basic
Public Function GetParameters As UrlString
Visual C++
public:
UrlString^ GetParameters()

Return Value

The rendering parameters.

See Also

RenderingItem Class
Sitecore.Data.Items Namespace


GetStandardValuesItemFromParametersTemplate Method

[image]

Sitecore 6.4.1 API
RenderingItem..::..GetStandardValuesItemFromParametersTemplate Method
RenderingItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item GetStandardValuesItemFromParametersTemplate(
    Item renderingItem
)
Visual Basic
Public Shared Function GetStandardValuesItemFromParametersTemplate ( _
    renderingItem As Item _
) As Item
Visual C++
public:
static Item^ GetStandardValuesItemFromParametersTemplate(
    Item^ renderingItem
)

Parameters

renderingItem
Type: Sitecore.Data.Items..::..Item
The rendering item.

Return Value

The standard values item from parameters template.

See Also

RenderingItem Class
Sitecore.Data.Items Namespace


GetTagPrefix Method

[image]

Sitecore 6.4.1 API
RenderingItem..::..GetTagPrefix Method
RenderingItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void GetTagPrefix(
    string ns,
    string assembly,
    ref string tagPrefix,
    ref string html
)
Visual Basic
Public Shared Sub GetTagPrefix ( _
    ns As String, _
    assembly As String, _
    ByRef tagPrefix As String, _
    ByRef html As String _
)
Visual C++
public:
static void GetTagPrefix(
    String^ ns,
    String^ assembly,
    String^% tagPrefix,
    String^% html
)

Parameters

ns
Type: System..::..String
The namespace.
assembly
Type: System..::..String
The assembly.
tagPrefix
Type: System..::..String %
The tag prefix.
html
Type: System..::..String %
The HTML.

See Also

RenderingItem Class
Sitecore.Data.Items Namespace


IsAvalableNotBlobNotSystemField Method

[image]

Sitecore 6.4.1 API
RenderingItem..::..IsAvalableNotBlobNotSystemField Method
RenderingItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsAvalableNotBlobNotSystemField(
    Field field
)
Visual Basic
Public Shared Function IsAvalableNotBlobNotSystemField ( _
    field As Field _
) As Boolean
Visual C++
public:
static bool IsAvalableNotBlobNotSystemField(
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.

Return Value

true if [is avalable not BLOB not system field] [the specified field]; otherwise, false.

See Also

RenderingItem Class
Sitecore.Data.Items Namespace


MakeTagPrefix Method

[image]

Sitecore 6.4.1 API
RenderingItem..::..MakeTagPrefix Method
RenderingItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string MakeTagPrefix(
    ref string htmlHeader
)
Visual Basic
Public Function MakeTagPrefix ( _
    ByRef htmlHeader As String _
) As String
Visual C++
public:
String^ MakeTagPrefix(
    String^% htmlHeader
)

Parameters

htmlHeader
Type: System..::..String %
The HTML header. The method will add addional page declaration as needed for control to operate properly.

Return Value

The tag prefix.

See Also

RenderingItem Class
Sitecore.Data.Items Namespace


RenderingItem Type Conversions

[image] [image]

Sitecore 6.4.1 API
RenderingItem Type Conversions
RenderingItem Class See Also Send Feedback

The RenderingItem type exposes the following members.

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Item to RenderingItem) | Convert an item to a RenderingItem.

See Also

RenderingItem Class
Sitecore.Data.Items Namespace


Implicit Conversion (Item to RenderingItem)

[image]

Sitecore 6.4.1 API
RenderingItem ImplicitWideningImplicitImplicitImplicit Conversion (Item to RenderingItem)
RenderingItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator RenderingItem (
    Item item
)
Visual Basic
Public Shared Widening Operator CType ( _
    item As Item _
) As RenderingItem
Visual C++
static implicit operator RenderingItem^ (
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Items.RenderingItem.op_Implicit(Sitecore.Data.Items.Item)~Sitecore.Data.Items.RenderingItem"]

See Also

RenderingItem Class
Sitecore.Data.Items Namespace


RenderingItem Properties

[image] [image]

Sitecore 6.4.1 API
RenderingItem Properties
RenderingItem Class See Also Send Feedback

The RenderingItem type exposes the following members.

Properties

 | Name | Description
Public property | Caching | Gets caching information.
Public property | Conditions | Gets the conditions.
Public property | Database | Gets the database. (Inherited from CustomItemBase.)
Public property | DataSource | Gets the data source.
Public property | DisplayName | Gets the display name. (Inherited from CustomItemBase.)
Public property | Icon | Gets the icon. (Inherited from CustomItemBase.)
Public property | ID | Gets the ID. (Inherited from CustomItemBase.)
Public property | InnerItem | Gets the inner item. (Inherited from CustomItemBase.)
Public property | MultiVariateTest | Gets the multi variate test.
Public property | Name | Gets the name. (Inherited from CustomItemBase.)
Public property | Parameters | Gets the parameters.
Public property | Placeholder | Gets the placeholder.
Public property | TagName | Gets the name of the tag.
Public property | TagPrefix | Gets the tag prefix.

See Also

RenderingItem Class
Sitecore.Data.Items Namespace


Caching Property

[image]

Sitecore 6.4.1 API
RenderingItem..::..Caching Property
RenderingItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderingCaching Caching { get; }
Visual Basic
Public ReadOnly Property Caching As RenderingCaching
    Get
Visual C++
public:
property RenderingCaching^ Caching {
    RenderingCaching^ get ();
}

Field Value

The caching.

See Also

RenderingItem Class
Sitecore.Data.Items Namespace


Conditions Property

[image]

Sitecore 6.4.1 API
RenderingItem..::..Conditions Property
RenderingItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Conditions { get; }
Visual Basic
Public ReadOnly Property Conditions As String
    Get
Visual C++
public:
property String^ Conditions {
    String^ get ();
}

Field Value

The conditions.

See Also

RenderingItem Class
Sitecore.Data.Items Namespace


DataSource Property

[image]

Sitecore 6.4.1 API
RenderingItem..::..DataSource Property
RenderingItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string DataSource { get; }
Visual Basic
Public ReadOnly Property DataSource As String
    Get
Visual C++
public:
property String^ DataSource {
    String^ get ();
}

Field Value

The data source.

See Also

RenderingItem Class
Sitecore.Data.Items Namespace


MultiVariateTest Property

[image]

Sitecore 6.4.1 API
RenderingItem..::..MultiVariateTest Property
RenderingItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string MultiVariateTest { get; }
Visual Basic
Public ReadOnly Property MultiVariateTest As String
    Get
Visual C++
public:
property String^ MultiVariateTest {
    String^ get ();
}

Field Value

The multi variate test.

See Also

RenderingItem Class
Sitecore.Data.Items Namespace


Parameters Property

[image]

Sitecore 6.4.1 API
RenderingItem..::..Parameters Property
RenderingItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Parameters { get; }
Visual Basic
Public ReadOnly Property Parameters As String
    Get
Visual C++
public:
property String^ Parameters {
    String^ get ();
}

Field Value

The parameters.

See Also

RenderingItem Class
Sitecore.Data.Items Namespace


Placeholder Property

[image]

Sitecore 6.4.1 API
RenderingItem..::..Placeholder Property
RenderingItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Placeholder { get; }
Visual Basic
Public ReadOnly Property Placeholder As String
    Get
Visual C++
public:
property String^ Placeholder {
    String^ get ();
}

Field Value

The placeholder.

See Also

RenderingItem Class
Sitecore.Data.Items Namespace


TagName Property

[image]

Sitecore 6.4.1 API
RenderingItem..::..TagName Property
RenderingItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string TagName { get; }
Visual Basic
Public ReadOnly Property TagName As String
    Get
Visual C++
public:
property String^ TagName {
    String^ get ();
}

Field Value

The name of the tag.

See Also

RenderingItem Class
Sitecore.Data.Items Namespace


TagPrefix Property

[image]

Sitecore 6.4.1 API
RenderingItem..::..TagPrefix Property
RenderingItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string TagPrefix { get; }
Visual Basic
Public ReadOnly Property TagPrefix As String
    Get
Visual C++
public:
property String^ TagPrefix {
    String^ get ();
}

Field Value

The tag prefix.

See Also

RenderingItem Class
Sitecore.Data.Items Namespace


SectionTimer Class

[image]

Sitecore 6.4.1 API
SectionTimer Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SectionTimer : IDisposable
Visual Basic
Public Class SectionTimer _
    Implements IDisposable
Visual C++
public ref class SectionTimer : IDisposable

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..SectionTimer

See Also

SectionTimer Members
Sitecore.Data.Items Namespace


SectionTimer Members

[image] [image]

Sitecore 6.4.1 API
SectionTimer Members
SectionTimer Class Constructors Methods Properties See Also Send Feedback

The SectionTimer type exposes the following members.

Constructors

 | Name | Description
Public method | SectionTimer(String, Boolean) | Initializes a new instance of the SectionTimer class.
Public method | SectionTimer(String, String) | Initializes a new instance of the SectionTimer class that writes to a file.
Public method | SectionTimer(String, Boolean, Int32) | Initializes a new instance of the SectionTimer class.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Elapsed | Gets the current number of elapsed milliseconds

See Also

SectionTimer Class
Sitecore.Data.Items Namespace


SectionTimer Constructor

[image] [image]

Sitecore 6.4.1 API
SectionTimer Constructor
SectionTimer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SectionTimer(String, Boolean) | Initializes a new instance of the SectionTimer class.
Public method | SectionTimer(String, String) | Initializes a new instance of the SectionTimer class that writes to a file.
Public method | SectionTimer(String, Boolean, Int32) | Initializes a new instance of the SectionTimer class.

See Also

SectionTimer Class
SectionTimer Members
Sitecore.Data.Items Namespace


SectionTimer Constructor (String, Boolean)

[image]

Sitecore 6.4.1 API
SectionTimer Constructor (String, Boolean)
SectionTimer Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SectionTimer(
    string sectionName,
    bool displayResult
)
Visual Basic
Public Sub New ( _
    sectionName As String, _
    displayResult As Boolean _
)
Visual C++
public:
SectionTimer(
    String^ sectionName,
    bool displayResult
)

Parameters

sectionName
Type: System..::..String
Name of the section.
displayResult
Type: System..::..Boolean
if set to true this instance is displaying results on the screen.

See Also

SectionTimer Class
SectionTimer Overload
Sitecore.Data.Items Namespace


SectionTimer Constructor (String, Boolean, Int32)

[image]

Sitecore 6.4.1 API
SectionTimer Constructor (String, Boolean, Int32)
SectionTimer Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SectionTimer(
    string sectionName,
    bool displayResult,
    int divideBy
)
Visual Basic
Public Sub New ( _
    sectionName As String, _
    displayResult As Boolean, _
    divideBy As Integer _
)
Visual C++
public:
SectionTimer(
    String^ sectionName,
    bool displayResult,
    int divideBy
)

Parameters

sectionName
Type: System..::..String
Name of the section.
displayResult
Type: System..::..Boolean
if set to true this instance is displaying results on the screen.
divideBy
Type: System..::..Int32
The divide by factor.

See Also

SectionTimer Class
SectionTimer Overload
Sitecore.Data.Items Namespace


SectionTimer Methods

[image] [image]

Sitecore 6.4.1 API
SectionTimer Methods
SectionTimer Class See Also Send Feedback

The SectionTimer type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SectionTimer Class
Sitecore.Data.Items Namespace


Dispose Method

[image]

Sitecore 6.4.1 API
SectionTimer..::..Dispose Method
SectionTimer Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

SectionTimer Class
Sitecore.Data.Items Namespace


SectionTimer Properties

[image] [image]

Sitecore 6.4.1 API
SectionTimer Properties
SectionTimer Class See Also Send Feedback

The SectionTimer type exposes the following members.

Properties

 | Name | Description
Public property | Elapsed | Gets the current number of elapsed milliseconds

See Also

SectionTimer Class
Sitecore.Data.Items Namespace


Elapsed Property

[image]

Sitecore 6.4.1 API
SectionTimer..::..Elapsed Property
SectionTimer Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public double Elapsed { get; }
Visual Basic
Public ReadOnly Property Elapsed As Double
    Get
Visual C++
public:
property double Elapsed {
    double get ();
}

Field Value

The elapsed.

See Also

SectionTimer Class
Sitecore.Data.Items Namespace


SublayoutItem Class

[image]

Sitecore 6.4.1 API
SublayoutItem Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SublayoutItem : CustomItemBase
Visual Basic
Public Class SublayoutItem _
    Inherits CustomItemBase
Visual C++
public ref class SublayoutItem : public CustomItemBase

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..CustomItemBase
Sitecore.Data.Items..::..SublayoutItem

See Also

SublayoutItem Members
Sitecore.Data.Items Namespace


SublayoutItem Members

[image] [image]

Sitecore 6.4.1 API
SublayoutItem Members
SublayoutItem Class Constructors Methods Operators Properties See Also Send Feedback

The SublayoutItem type exposes the following members.

Constructors

 | Name | Description
Public method | SublayoutItem | Creates a new SublayoutItem instance.

Methods

 | Name | Description
Public method | BeginEdit | Begins editing the item. (Inherited from CustomItemBase.)
Public method | EndEdit | Ends editing the item. (Inherited from CustomItemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Item to SublayoutItem) | Converts an item to a SublayoutItem.

Properties

 | Name | Description
Public property | Database | Gets the database. (Inherited from CustomItemBase.)
Public property | DisplayName | Gets the display name. (Inherited from CustomItemBase.)
Public property | FilePath | Gets the file path of the sublayout.
Public property | Icon | Gets the icon. (Inherited from CustomItemBase.)
Public property | ID | Gets the ID. (Inherited from CustomItemBase.)
Public property | InnerItem | Gets the inner item. (Inherited from CustomItemBase.)
Public property | Name | Gets the name. (Inherited from CustomItemBase.)

See Also

SublayoutItem Class
Sitecore.Data.Items Namespace


SublayoutItem Constructor

[image]

Sitecore 6.4.1 API
SublayoutItem Constructor
SublayoutItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SublayoutItem(
    Item innerItem
)
Visual Basic
Public Sub New ( _
    innerItem As Item _
)
Visual C++
public:
SublayoutItem(
    Item^ innerItem
)

Parameters

innerItem
Type: Sitecore.Data.Items..::..Item
Inner item.

See Also

SublayoutItem Class
Sitecore.Data.Items Namespace


SublayoutItem Methods

[image] [image]

Sitecore 6.4.1 API
SublayoutItem Methods
SublayoutItem Class See Also Send Feedback

The SublayoutItem type exposes the following members.

Methods

 | Name | Description
Public method | BeginEdit | Begins editing the item. (Inherited from CustomItemBase.)
Public method | EndEdit | Ends editing the item. (Inherited from CustomItemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SublayoutItem Class
Sitecore.Data.Items Namespace


SublayoutItem Type Conversions

[image] [image]

Sitecore 6.4.1 API
SublayoutItem Type Conversions
SublayoutItem Class See Also Send Feedback

The SublayoutItem type exposes the following members.

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Item to SublayoutItem) | Converts an item to a SublayoutItem.

See Also

SublayoutItem Class
Sitecore.Data.Items Namespace


Implicit Conversion (Item to SublayoutItem)

[image]

Sitecore 6.4.1 API
SublayoutItem ImplicitWideningImplicitImplicitImplicit Conversion (Item to SublayoutItem)
SublayoutItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator SublayoutItem (
    Item item
)
Visual Basic
Public Shared Widening Operator CType ( _
    item As Item _
) As SublayoutItem
Visual C++
static implicit operator SublayoutItem^ (
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

The implicit operator.

See Also

SublayoutItem Class
Sitecore.Data.Items Namespace


SublayoutItem Properties

[image] [image]

Sitecore 6.4.1 API
SublayoutItem Properties
SublayoutItem Class See Also Send Feedback

The SublayoutItem type exposes the following members.

Properties

 | Name | Description
Public property | Database | Gets the database. (Inherited from CustomItemBase.)
Public property | DisplayName | Gets the display name. (Inherited from CustomItemBase.)
Public property | FilePath | Gets the file path of the sublayout.
Public property | Icon | Gets the icon. (Inherited from CustomItemBase.)
Public property | ID | Gets the ID. (Inherited from CustomItemBase.)
Public property | InnerItem | Gets the inner item. (Inherited from CustomItemBase.)
Public property | Name | Gets the name. (Inherited from CustomItemBase.)

See Also

SublayoutItem Class
Sitecore.Data.Items Namespace


FilePath Property

[image]

Sitecore 6.4.1 API
SublayoutItem..::..FilePath Property
SublayoutItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string FilePath { get; }
Visual Basic
Public ReadOnly Property FilePath As String
    Get
Visual C++
public:
property String^ FilePath {
    String^ get ();
}

Field Value

The file path.

See Also

SublayoutItem Class
Sitecore.Data.Items Namespace


TemplateFieldItem Class

[image]

Sitecore 6.4.1 API
TemplateFieldItem Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class TemplateFieldItem : CustomItemBase
Visual Basic
Public Class TemplateFieldItem _
    Inherits CustomItemBase
Visual C++
public ref class TemplateFieldItem : public CustomItemBase

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..CustomItemBase
Sitecore.Data.Items..::..TemplateFieldItem

See Also

TemplateFieldItem Members
Sitecore.Data.Items Namespace


TemplateFieldItem Members

[image] [image]

Sitecore 6.4.1 API
TemplateFieldItem Members
TemplateFieldItem Class Constructors Methods Operators Properties See Also Send Feedback

The TemplateFieldItem type exposes the following members.

Constructors

 | Name | Description
Public method | TemplateFieldItem | Creates a new TemplateFieldItem instance.

Methods

 | Name | Description
Public method | BeginEdit | Begins editing the item. (Inherited from CustomItemBase.)
Public method | EndEdit | Ends editing the item. (Inherited from CustomItemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Item to TemplateFieldItem) | Converts an item to a TemplateFieldItem.

Properties

 | Name | Description
Public property | Database | Gets the database. (Inherited from CustomItemBase.)
Public property | Description | Gets the description.
Public property | DisplayName | Gets the display name. (Inherited from CustomItemBase.)
Public property | HelpLink | Gets the help link.
Public property | Icon | Gets the icon. (Inherited from CustomItemBase.)
Public property | ID | Gets the ID. (Inherited from CustomItemBase.)
Public property | InnerItem | Gets the inner item. (Inherited from CustomItemBase.)
Public property | IsShared | Gets a value indicating whether this instance is shared.
Public property | IsUnversioned | Gets a value indicating whether this instance is unversioned.
Public property | Key | Gets the key.
Public property | Name | Gets the name. (Inherited from CustomItemBase.)
Public property | ResetBlank | Gets a value indicating whether the TemplateFieldItem resets the blank flag.
Public property | Section | Gets the section.
Public property | Shared | Gets a value indicating whether this TemplateFieldItem is shared.
Public property | Sortorder | Gets or sets the sortorder.
Public property | Source | Gets or sets the source.
Public property | Style | Gets or sets the CSS style.
Public property | Template | Gets the template.
Public property | Title | Gets or sets the title.
Public property | ToolTip | Gets the tool tip.
Public property | Type | Gets or sets the type.
Public property | Unversioned | Gets a value indicating whether this TemplateFieldItem is unversioned.
Public property | Validation | Gets or sets the validation regular expression.
Public property | ValidationText | Gets or sets the validation text that is shown if the Validation regular expression fails.

See Also

TemplateFieldItem Class
Sitecore.Data.Items Namespace


TemplateFieldItem Constructor

[image]

Sitecore 6.4.1 API
TemplateFieldItem Constructor
TemplateFieldItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateFieldItem(
    Item innerItem,
    TemplateSectionItem owner
)
Visual Basic
Public Sub New ( _
    innerItem As Item, _
    owner As TemplateSectionItem _
)
Visual C++
public:
TemplateFieldItem(
    Item^ innerItem,
    TemplateSectionItem^ owner
)

Parameters

innerItem
Type: Sitecore.Data.Items..::..Item
Inner item.
owner
Type: Sitecore.Data.Items..::..TemplateSectionItem
Owner.

See Also

TemplateFieldItem Class
Sitecore.Data.Items Namespace


TemplateFieldItem Methods

[image] [image]

Sitecore 6.4.1 API
TemplateFieldItem Methods
TemplateFieldItem Class See Also Send Feedback

The TemplateFieldItem type exposes the following members.

Methods

 | Name | Description
Public method | BeginEdit | Begins editing the item. (Inherited from CustomItemBase.)
Public method | EndEdit | Ends editing the item. (Inherited from CustomItemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TemplateFieldItem Class
Sitecore.Data.Items Namespace


TemplateFieldItem Type Conversions

[image] [image]

Sitecore 6.4.1 API
TemplateFieldItem Type Conversions
TemplateFieldItem Class See Also Send Feedback

The TemplateFieldItem type exposes the following members.

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Item to TemplateFieldItem) | Converts an item to a TemplateFieldItem.

See Also

TemplateFieldItem Class
Sitecore.Data.Items Namespace


Implicit Conversion (Item to TemplateFieldItem)

[image]

Sitecore 6.4.1 API
TemplateFieldItem ImplicitWideningImplicitImplicitImplicit Conversion (Item to TemplateFieldItem)
TemplateFieldItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator TemplateFieldItem (
    Item item
)
Visual Basic
Public Shared Widening Operator CType ( _
    item As Item _
) As TemplateFieldItem
Visual C++
static implicit operator TemplateFieldItem^ (
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

The implicit operator.

See Also

TemplateFieldItem Class
Sitecore.Data.Items Namespace


TemplateFieldItem Properties

[image] [image]

Sitecore 6.4.1 API
TemplateFieldItem Properties
TemplateFieldItem Class See Also Send Feedback

The TemplateFieldItem type exposes the following members.

Properties

 | Name | Description
Public property | Database | Gets the database. (Inherited from CustomItemBase.)
Public property | Description | Gets the description.
Public property | DisplayName | Gets the display name. (Inherited from CustomItemBase.)
Public property | HelpLink | Gets the help link.
Public property | Icon | Gets the icon. (Inherited from CustomItemBase.)
Public property | ID | Gets the ID. (Inherited from CustomItemBase.)
Public property | InnerItem | Gets the inner item. (Inherited from CustomItemBase.)
Public property | IsShared | Gets a value indicating whether this instance is shared.
Public property | IsUnversioned | Gets a value indicating whether this instance is unversioned.
Public property | Key | Gets the key.
Public property | Name | Gets the name. (Inherited from CustomItemBase.)
Public property | ResetBlank | Gets a value indicating whether the TemplateFieldItem resets the blank flag.
Public property | Section | Gets the section.
Public property | Shared | Gets a value indicating whether this TemplateFieldItem is shared.
Public property | Sortorder | Gets or sets the sortorder.
Public property | Source | Gets or sets the source.
Public property | Style | Gets or sets the CSS style.
Public property | Template | Gets the template.
Public property | Title | Gets or sets the title.
Public property | ToolTip | Gets the tool tip.
Public property | Type | Gets or sets the type.
Public property | Unversioned | Gets a value indicating whether this TemplateFieldItem is unversioned.
Public property | Validation | Gets or sets the validation regular expression.
Public property | ValidationText | Gets or sets the validation text that is shown if the Validation regular expression fails.

See Also

TemplateFieldItem Class
Sitecore.Data.Items Namespace


Description Property

[image]

Sitecore 6.4.1 API
TemplateFieldItem..::..Description Property
TemplateFieldItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Description { get; }
Visual Basic
Public ReadOnly Property Description As String
    Get
Visual C++
public:
property String^ Description {
    String^ get ();
}

Field Value

The description.

See Also

TemplateFieldItem Class
Sitecore.Data.Items Namespace


HelpLink Property

[image]

Sitecore 6.4.1 API
TemplateFieldItem..::..HelpLink Property
TemplateFieldItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LinkField HelpLink { get; }
Visual Basic
Public ReadOnly Property HelpLink As LinkField
    Get
Visual C++
public:
property LinkField^ HelpLink {
    LinkField^ get ();
}

Field Value

The help link.

See Also

TemplateFieldItem Class
Sitecore.Data.Items Namespace


IsUnversioned Property

[image]

Sitecore 6.4.1 API
TemplateFieldItem..::..IsUnversioned Property
TemplateFieldItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsUnversioned { get; }
Visual Basic
Public ReadOnly Property IsUnversioned As Boolean
    Get
Visual C++
public:
property bool IsUnversioned {
    bool get ();
}

Field Value

true if this instance is unversioned; otherwise, false.

See Also

TemplateFieldItem Class
Sitecore.Data.Items Namespace


Key Property

[image]

Sitecore 6.4.1 API
TemplateFieldItem..::..Key Property
TemplateFieldItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Key { get; }
Visual Basic
Public ReadOnly Property Key As String
    Get
Visual C++
public:
property String^ Key {
    String^ get ();
}

Field Value

The key.

See Also

TemplateFieldItem Class
Sitecore.Data.Items Namespace


ResetBlank Property

[image]

Sitecore 6.4.1 API
TemplateFieldItem..::..ResetBlank Property
TemplateFieldItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ResetBlank { get; }
Visual Basic
Public ReadOnly Property ResetBlank As Boolean
    Get
Visual C++
public:
property bool ResetBlank {
    bool get ();
}

Field Value

true if the TemplateFieldItem resets the blank flag; otherwise, false.

See Also

TemplateFieldItem Class
Sitecore.Data.Items Namespace


Section Property

[image]

Sitecore 6.4.1 API
TemplateFieldItem..::..Section Property
TemplateFieldItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateSectionItem Section { get; }
Visual Basic
Public ReadOnly Property Section As TemplateSectionItem
    Get
Visual C++
public:
property TemplateSectionItem^ Section {
    TemplateSectionItem^ get ();
}

Field Value

The section.

See Also

TemplateFieldItem Class
Sitecore.Data.Items Namespace


Shared Property

[image]

Sitecore 6.4.1 API
TemplateFieldItem..::..Shared Property
TemplateFieldItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Shared { get; }
Visual Basic
Public ReadOnly Property Shared As Boolean
    Get
Visual C++
public:
property bool Shared {
    bool get ();
}

Field Value

true if shared; otherwise, false.

See Also

TemplateFieldItem Class
Sitecore.Data.Items Namespace


Sortorder Property

[image]

Sitecore 6.4.1 API
TemplateFieldItem..::..Sortorder Property
TemplateFieldItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Sortorder { get; set; }
Visual Basic
Public Property Sortorder As Integer
    Get
    Set
Visual C++
public:
property int Sortorder {
    int get ();
    void set (int value);
}

Field Value

The sortorder.

See Also

TemplateFieldItem Class
Sitecore.Data.Items Namespace


Source Property

[image]

Sitecore 6.4.1 API
TemplateFieldItem..::..Source Property
TemplateFieldItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Source { get; set; }
Visual Basic
Public Property Source As String
    Get
    Set
Visual C++
public:
property String^ Source {
    String^ get ();
    void set (String^ value);
}

Field Value

The source.

See Also

TemplateFieldItem Class
Sitecore.Data.Items Namespace


Style Property

[image]

Sitecore 6.4.1 API
TemplateFieldItem..::..Style Property
TemplateFieldItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Style { get; set; }
Visual Basic
Public Property Style As String
    Get
    Set
Visual C++
public:
property String^ Style {
    String^ get ();
    void set (String^ value);
}

Field Value

The style.

See Also

TemplateFieldItem Class
Sitecore.Data.Items Namespace


Template Property

[image]

Sitecore 6.4.1 API
TemplateFieldItem..::..Template Property
TemplateFieldItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateItem Template { get; }
Visual Basic
Public ReadOnly Property Template As TemplateItem
    Get
Visual C++
public:
property TemplateItem^ Template {
    TemplateItem^ get ();
}

Field Value

The template.

See Also

TemplateFieldItem Class
Sitecore.Data.Items Namespace


Title Property

[image]

Sitecore 6.4.1 API
TemplateFieldItem..::..Title Property
TemplateFieldItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Title { get; set; }
Visual Basic
Public Property Title As String
    Get
    Set
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

Field Value

The title.

See Also

TemplateFieldItem Class
Sitecore.Data.Items Namespace


ToolTip Property

[image]

Sitecore 6.4.1 API
TemplateFieldItem..::..ToolTip Property
TemplateFieldItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ToolTip { get; }
Visual Basic
Public ReadOnly Property ToolTip As String
    Get
Visual C++
public:
property String^ ToolTip {
    String^ get ();
}

Field Value

The tool tip.

See Also

TemplateFieldItem Class
Sitecore.Data.Items Namespace


Type Property

[image]

Sitecore 6.4.1 API
TemplateFieldItem..::..Type Property
TemplateFieldItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Type { get; set; }
Visual Basic
Public Property Type As String
    Get
    Set
Visual C++
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}

Field Value

The type.

See Also

TemplateFieldItem Class
Sitecore.Data.Items Namespace


Unversioned Property

[image]

Sitecore 6.4.1 API
TemplateFieldItem..::..Unversioned Property
TemplateFieldItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Unversioned { get; }
Visual Basic
Public ReadOnly Property Unversioned As Boolean
    Get
Visual C++
public:
property bool Unversioned {
    bool get ();
}

Field Value

true if unversioned; otherwise, false.

See Also

TemplateFieldItem Class
Sitecore.Data.Items Namespace


Validation Property

[image]

Sitecore 6.4.1 API
TemplateFieldItem..::..Validation Property
TemplateFieldItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Validation { get; set; }
Visual Basic
Public Property Validation As String
    Get
    Set
Visual C++
public:
property String^ Validation {
    String^ get ();
    void set (String^ value);
}

Field Value

The validation.

See Also

TemplateFieldItem Class
Sitecore.Data.Items Namespace


ValidationText Property

[image]

Sitecore 6.4.1 API
TemplateFieldItem..::..ValidationText Property
TemplateFieldItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ValidationText { get; set; }
Visual Basic
Public Property ValidationText As String
    Get
    Set
Visual C++
public:
property String^ ValidationText {
    String^ get ();
    void set (String^ value);
}

Field Value

The validation text.

See Also

TemplateFieldItem Class
Sitecore.Data.Items Namespace


TemplateItem Class

[image]

Sitecore 6.4.1 API
TemplateItem Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class TemplateItem : CustomItemBase
Visual Basic
Public Class TemplateItem _
    Inherits CustomItemBase
Visual C++
public ref class TemplateItem : public CustomItemBase

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..CustomItemBase
Sitecore.Data.Items..::..TemplateItem

See Also

TemplateItem Members
Sitecore.Data.Items Namespace


TemplateItem Members

[image] [image]

Sitecore 6.4.1 API
TemplateItem Members
TemplateItem Class Constructors Methods Operators Properties See Also Send Feedback

The TemplateItem type exposes the following members.

Constructors

 | Name | Description
Public method | TemplateItem | Creates a new TemplateItem instance.

Methods

 | Name | Description
Public method | AddField | Adds a field.
Public method | AddSection(String) | Adds the section.
Public method | AddSection(String, Boolean) | Adds the section.
Public method | AddTo | Adds an item based on this template to another template.
Public method | BeginEdit | Begins editing the item. (Inherited from CustomItemBase.)
Public method | CreateItemFrom | Creates the item from another item.
Public method | CreateStandardValues | Creates the standard values.
Public method | EndEdit | Ends editing the item. (Inherited from CustomItemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetField(String) | Gets a field.
Public method | GetField(ID) | Gets a field.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSection(String) | Gets a section.
Public method | GetSection(ID) | Gets a section.
Public method | GetSection(ID, Boolean) | Gets a section.
Public method | GetSections | Gets a list of sections.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUsageIDs | Returns usages of template item.
Public method | GetUsages | Obsolete. Gets the usages of this template from Lucene.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveField(String) | Removes a field.
Public method | RemoveField(ID) | Removes a field.
Public method | RemoveSection(String) | Removes a section.
Public method | RemoveSection(ID) | Removes a section.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Item to TemplateItem) | Converts an Item to a TemplateItem.
ImplicitWideningImplicitImplicitImplicit(TemplateItem to Item) | Converts a TemplateItem to an Item.

Properties

 | Name | Description
Public property | BaseTemplates | Gets a list of base templates.
Public property | Database | Gets the database. (Inherited from CustomItemBase.)
Public property | DisplayName | Gets the display name. (Inherited from CustomItemBase.)
Public property | Fields | Gets the fields.
Public property | FullName | Gets the full name.
Public property | Icon | Gets the icon. (Inherited from CustomItemBase.)
Public property | ID | Gets the ID. (Inherited from CustomItemBase.)
Public property | InnerItem | Gets the inner item. (Inherited from CustomItemBase.)
Public property | Key | Gets the key.
Public property | Name | Gets the name. (Inherited from CustomItemBase.)
Public property | OwnFields | Gets the fields that are defined by this template.
Public property | StandardValues | Gets the standard values.

See Also

TemplateItem Class
Sitecore.Data.Items Namespace


TemplateItem Constructor

[image]

Sitecore 6.4.1 API
TemplateItem Constructor
TemplateItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateItem(
    Item innerItem
)
Visual Basic
Public Sub New ( _
    innerItem As Item _
)
Visual C++
public:
TemplateItem(
    Item^ innerItem
)

Parameters

innerItem
Type: Sitecore.Data.Items..::..Item
Inner item.

See Also

TemplateItem Class
Sitecore.Data.Items Namespace


TemplateItem Methods

[image] [image]

Sitecore 6.4.1 API
TemplateItem Methods
TemplateItem Class See Also Send Feedback

The TemplateItem type exposes the following members.

Methods

 | Name | Description
Public method | AddField | Adds a field.
Public method | AddSection(String) | Adds the section.
Public method | AddSection(String, Boolean) | Adds the section.
Public method | AddTo | Adds an item based on this template to another template.
Public method | BeginEdit | Begins editing the item. (Inherited from CustomItemBase.)
Public method | CreateItemFrom | Creates the item from another item.
Public method | CreateStandardValues | Creates the standard values.
Public method | EndEdit | Ends editing the item. (Inherited from CustomItemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetField(String) | Gets a field.
Public method | GetField(ID) | Gets a field.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSection(String) | Gets a section.
Public method | GetSection(ID) | Gets a section.
Public method | GetSection(ID, Boolean) | Gets a section.
Public method | GetSections | Gets a list of sections.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUsageIDs | Returns usages of template item.
Public method | GetUsages | Obsolete. Gets the usages of this template from Lucene.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveField(String) | Removes a field.
Public method | RemoveField(ID) | Removes a field.
Public method | RemoveSection(String) | Removes a section.
Public method | RemoveSection(ID) | Removes a section.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TemplateItem Class
Sitecore.Data.Items Namespace


AddField Method

[image]

Sitecore 6.4.1 API
TemplateItem..::..AddField Method
TemplateItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateFieldItem AddField(
    string fieldName,
    string sectionName
)
Visual Basic
Public Function AddField ( _
    fieldName As String, _
    sectionName As String _
) As TemplateFieldItem
Visual C++
public:
TemplateFieldItem^ AddField(
    String^ fieldName,
    String^ sectionName
)

Parameters

fieldName
Type: System..::..String
Name of the field.
sectionName
Type: System..::..String
Name of the section.

Return Value

A TemplateFieldItem

See Also

TemplateItem Class
Sitecore.Data.Items Namespace


AddSection Method

[image] [image]

Sitecore 6.4.1 API
TemplateItem..::..AddSection Method
TemplateItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddSection(String) | Adds the section.
Public method | AddSection(String, Boolean) | Adds the section.

See Also

TemplateItem Class
TemplateItem Members
Sitecore.Data.Items Namespace


AddSection Method (String)

[image]

Sitecore 6.4.1 API
TemplateItem..::..AddSection Method (String)
TemplateItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateSectionItem AddSection(
    string sectionName
)
Visual Basic
Public Function AddSection ( _
    sectionName As String _
) As TemplateSectionItem
Visual C++
public:
TemplateSectionItem^ AddSection(
    String^ sectionName
)

Parameters

sectionName
Type: System..::..String
Name of the section.

Return Value

The section.

See Also

TemplateItem Class
AddSection Overload
Sitecore.Data.Items Namespace


AddSection Method (String, Boolean)

[image]

Sitecore 6.4.1 API
TemplateItem..::..AddSection Method (String, Boolean)
TemplateItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateSectionItem AddSection(
    string sectionName,
    bool allowInheritedSection
)
Visual Basic
Public Function AddSection ( _
    sectionName As String, _
    allowInheritedSection As Boolean _
) As TemplateSectionItem
Visual C++
public:
TemplateSectionItem^ AddSection(
    String^ sectionName,
    bool allowInheritedSection
)

Parameters

sectionName
Type: System..::..String
Name of the section.
allowInheritedSection
Type: System..::..Boolean
if set to true this instance allows inherited section.

Return Value

The section.

See Also

TemplateItem Class
AddSection Overload
Sitecore.Data.Items Namespace


AddTo Method

[image]

Sitecore 6.4.1 API
TemplateItem..::..AddTo Method
TemplateItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item AddTo(
    Item item,
    string name
)
Visual Basic
Public Function AddTo ( _
    item As Item, _
    name As String _
) As Item
Visual C++
public:
Item^ AddTo(
    Item^ item,
    String^ name
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
Item.
name
Type: System..::..String
Name.

Return Value

The to.

See Also

TemplateItem Class
Sitecore.Data.Items Namespace


CreateStandardValues Method

[image]

Sitecore 6.4.1 API
TemplateItem..::..CreateStandardValues Method
TemplateItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item CreateStandardValues()
Visual Basic
Public Function CreateStandardValues As Item
Visual C++
public:
Item^ CreateStandardValues()

Return Value

The standard values.

See Also

TemplateItem Class
Sitecore.Data.Items Namespace


GetField Method

[image] [image]

Sitecore 6.4.1 API
TemplateItem..::..GetField Method
TemplateItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetField(String) | Gets a field.
Public method | GetField(ID) | Gets a field.

See Also

TemplateItem Class
TemplateItem Members
Sitecore.Data.Items Namespace


GetField Method (String)

[image]

Sitecore 6.4.1 API
TemplateItem..::..GetField Method (String)
TemplateItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateFieldItem GetField(
    string fieldName
)
Visual Basic
Public Function GetField ( _
    fieldName As String _
) As TemplateFieldItem
Visual C++
public:
TemplateFieldItem^ GetField(
    String^ fieldName
)

Parameters

fieldName
Type: System..::..String
Name of the field.

Return Value

The field.

See Also

TemplateItem Class
GetField Overload
Sitecore.Data.Items Namespace


GetField Method (ID)

[image]

Sitecore 6.4.1 API
TemplateItem..::..GetField Method (ID)
TemplateItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateFieldItem GetField(
    ID fieldID
)
Visual Basic
Public Function GetField ( _
    fieldID As ID _
) As TemplateFieldItem
Visual C++
public:
TemplateFieldItem^ GetField(
    ID^ fieldID
)

Parameters

fieldID
Type: Sitecore.Data..::..ID
Field ID.

Return Value

The field.

See Also

TemplateItem Class
GetField Overload
Sitecore.Data.Items Namespace


GetSection Method

[image] [image]

Sitecore 6.4.1 API
TemplateItem..::..GetSection Method
TemplateItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetSection(String) | Gets a section.
Public method | GetSection(ID) | Gets a section.
Public method | GetSection(ID, Boolean) | Gets a section.

See Also

TemplateItem Class
TemplateItem Members
Sitecore.Data.Items Namespace


GetSection Method (String)

[image]

Sitecore 6.4.1 API
TemplateItem..::..GetSection Method (String)
TemplateItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateSectionItem GetSection(
    string sectionName
)
Visual Basic
Public Function GetSection ( _
    sectionName As String _
) As TemplateSectionItem
Visual C++
public:
TemplateSectionItem^ GetSection(
    String^ sectionName
)

Parameters

sectionName
Type: System..::..String
Name of the section.

Return Value

The section.

See Also

TemplateItem Class
GetSection Overload
Sitecore.Data.Items Namespace


GetSection Method (ID)

[image]

Sitecore 6.4.1 API
TemplateItem..::..GetSection Method (ID)
TemplateItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateSectionItem GetSection(
    ID sectionID
)
Visual Basic
Public Function GetSection ( _
    sectionID As ID _
) As TemplateSectionItem
Visual C++
public:
TemplateSectionItem^ GetSection(
    ID^ sectionID
)

Parameters

sectionID
Type: Sitecore.Data..::..ID
Section ID.

Return Value

The section.

See Also

TemplateItem Class
GetSection Overload
Sitecore.Data.Items Namespace


GetSection Method (ID, Boolean)

[image]

Sitecore 6.4.1 API
TemplateItem..::..GetSection Method (ID, Boolean)
TemplateItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateSectionItem GetSection(
    ID sectionID,
    bool allowInheritedSection
)
Visual Basic
Public Function GetSection ( _
    sectionID As ID, _
    allowInheritedSection As Boolean _
) As TemplateSectionItem
Visual C++
public:
TemplateSectionItem^ GetSection(
    ID^ sectionID,
    bool allowInheritedSection
)

Parameters

sectionID
Type: Sitecore.Data..::..ID
Section ID.
allowInheritedSection
Type: System..::..Boolean
if set to true if inherited sections are allowed.

Return Value

The section.

See Also

TemplateItem Class
GetSection Overload
Sitecore.Data.Items Namespace


GetSections Method

[image]

Sitecore 6.4.1 API
TemplateItem..::..GetSections Method
TemplateItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateSectionItem[] GetSections()
Visual Basic
Public Function GetSections As TemplateSectionItem()
Visual C++
public:
array<TemplateSectionItem^>^ GetSections()

Return Value

The sections.

See Also

TemplateItem Class
Sitecore.Data.Items Namespace


GetUsages Method

[image]

Sitecore 6.4.1 API
TemplateItem..::..GetUsages Method
TemplateItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use GetUsageIDs instead")]
public Hits GetUsages()
Visual Basic
<ObsoleteAttribute("Use GetUsageIDs instead")> _
Public Function GetUsages As Hits
Visual C++
[ObsoleteAttribute(L"Use GetUsageIDs instead")]
public:
Hits^ GetUsages()

Return Value

The usages.

See Also

TemplateItem Class
Sitecore.Data.Items Namespace


RemoveField Method

[image] [image]

Sitecore 6.4.1 API
TemplateItem..::..RemoveField Method
TemplateItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveField(String) | Removes a field.
Public method | RemoveField(ID) | Removes a field.

See Also

TemplateItem Class
TemplateItem Members
Sitecore.Data.Items Namespace


RemoveField Method (String)

[image]

Sitecore 6.4.1 API
TemplateItem..::..RemoveField Method (String)
TemplateItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RemoveField(
    string fieldName
)
Visual Basic
Public Sub RemoveField ( _
    fieldName As String _
)
Visual C++
public:
void RemoveField(
    String^ fieldName
)

Parameters

fieldName
Type: System..::..String
Name of the field.

See Also

TemplateItem Class
RemoveField Overload
Sitecore.Data.Items Namespace


RemoveField Method (ID)

[image]

Sitecore 6.4.1 API
TemplateItem..::..RemoveField Method (ID)
TemplateItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RemoveField(
    ID fieldID
)
Visual Basic
Public Sub RemoveField ( _
    fieldID As ID _
)
Visual C++
public:
void RemoveField(
    ID^ fieldID
)

Parameters

fieldID
Type: Sitecore.Data..::..ID
Field ID.

See Also

TemplateItem Class
RemoveField Overload
Sitecore.Data.Items Namespace


RemoveSection Method

[image] [image]

Sitecore 6.4.1 API
TemplateItem..::..RemoveSection Method
TemplateItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveSection(String) | Removes a section.
Public method | RemoveSection(ID) | Removes a section.

See Also

TemplateItem Class
TemplateItem Members
Sitecore.Data.Items Namespace


RemoveSection Method (String)

[image]

Sitecore 6.4.1 API
TemplateItem..::..RemoveSection Method (String)
TemplateItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RemoveSection(
    string sectionName
)
Visual Basic
Public Sub RemoveSection ( _
    sectionName As String _
)
Visual C++
public:
void RemoveSection(
    String^ sectionName
)

Parameters

sectionName
Type: System..::..String
Name of the section.

See Also

TemplateItem Class
RemoveSection Overload
Sitecore.Data.Items Namespace


RemoveSection Method (ID)

[image]

Sitecore 6.4.1 API
TemplateItem..::..RemoveSection Method (ID)
TemplateItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RemoveSection(
    ID sectionID
)
Visual Basic
Public Sub RemoveSection ( _
    sectionID As ID _
)
Visual C++
public:
void RemoveSection(
    ID^ sectionID
)

Parameters

sectionID
Type: Sitecore.Data..::..ID
Section ID.

See Also

TemplateItem Class
RemoveSection Overload
Sitecore.Data.Items Namespace


TemplateItem Type Conversions

[image] [image]

Sitecore 6.4.1 API
TemplateItem Type Conversions
TemplateItem Class See Also Send Feedback

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Item to TemplateItem) | Converts an Item to a TemplateItem.
ImplicitWideningImplicitImplicitImplicit(TemplateItem to Item) | Converts a TemplateItem to an Item.

See Also

TemplateItem Class
Sitecore.Data.Items Namespace


Implicit Conversion Operators

[image] [image]

Sitecore 6.4.1 API
TemplateItem ImplicitWideningImplicitImplicitImplicit Conversion Operators
TemplateItem Class See Also Send Feedback

Overload List

Name | Description
ImplicitWideningImplicitImplicitImplicit(Item to TemplateItem) | Converts an Item to a TemplateItem.
ImplicitWideningImplicitImplicitImplicit(TemplateItem to Item) | Converts a TemplateItem to an Item.

See Also

TemplateItem Class
TemplateItem Members
Sitecore.Data.Items Namespace


Implicit Conversion (Item to TemplateItem)

[image]

Sitecore 6.4.1 API
TemplateItem ImplicitWideningImplicitImplicitImplicit Conversion (Item to TemplateItem)
TemplateItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator TemplateItem (
    Item item
)
Visual Basic
Public Shared Widening Operator CType ( _
    item As Item _
) As TemplateItem
Visual C++
static implicit operator TemplateItem^ (
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

The implicit operator.

Exceptions

Exception | Condition
Sitecore.Exceptions..::..InvalidItemException | InvalidItemException.

See Also

TemplateItem Class
ImplicitWideningImplicitImplicitImplicit Overload
Sitecore.Data.Items Namespace


Implicit Conversion (TemplateItem to Item)

[image]

Sitecore 6.4.1 API
TemplateItem ImplicitWideningImplicitImplicitImplicit Conversion (TemplateItem to Item)
TemplateItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator Item (
    TemplateItem templateItem
)
Visual Basic
Public Shared Widening Operator CType ( _
    templateItem As TemplateItem _
) As Item
Visual C++
static implicit operator Item^ (
    TemplateItem^ templateItem
)

Parameters

templateItem
Type: Sitecore.Data.Items..::..TemplateItem
The item.

Return Value

The implicit operator.

See Also

TemplateItem Class
ImplicitWideningImplicitImplicitImplicit Overload
Sitecore.Data.Items Namespace


TemplateItem Properties

[image] [image]

Sitecore 6.4.1 API
TemplateItem Properties
TemplateItem Class See Also Send Feedback

The TemplateItem type exposes the following members.

Properties

 | Name | Description
Public property | BaseTemplates | Gets a list of base templates.
Public property | Database | Gets the database. (Inherited from CustomItemBase.)
Public property | DisplayName | Gets the display name. (Inherited from CustomItemBase.)
Public property | Fields | Gets the fields.
Public property | FullName | Gets the full name.
Public property | Icon | Gets the icon. (Inherited from CustomItemBase.)
Public property | ID | Gets the ID. (Inherited from CustomItemBase.)
Public property | InnerItem | Gets the inner item. (Inherited from CustomItemBase.)
Public property | Key | Gets the key.
Public property | Name | Gets the name. (Inherited from CustomItemBase.)
Public property | OwnFields | Gets the fields that are defined by this template.
Public property | StandardValues | Gets the standard values.

See Also

TemplateItem Class
Sitecore.Data.Items Namespace


BaseTemplates Property

[image]

Sitecore 6.4.1 API
TemplateItem..::..BaseTemplates Property
TemplateItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateItem[] BaseTemplates { get; }
Visual Basic
Public ReadOnly Property BaseTemplates As TemplateItem()
    Get
Visual C++
public:
property array<TemplateItem^>^ BaseTemplates {
    array<TemplateItem^>^ get ();
}

Field Value

The base templates.

See Also

TemplateItem Class
Sitecore.Data.Items Namespace


Fields Property

[image]

Sitecore 6.4.1 API
TemplateItem..::..Fields Property
TemplateItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateFieldItem[] Fields { get; }
Visual Basic
Public ReadOnly Property Fields As TemplateFieldItem()
    Get
Visual C++
public:
property array<TemplateFieldItem^>^ Fields {
    array<TemplateFieldItem^>^ get ();
}

Field Value

The fields.

See Also

TemplateItem Class
Sitecore.Data.Items Namespace


FullName Property

[image]

Sitecore 6.4.1 API
TemplateItem..::..FullName Property
TemplateItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string FullName { get; }
Visual Basic
Public ReadOnly Property FullName As String
    Get
Visual C++
public:
property String^ FullName {
    String^ get ();
}

Field Value

The full name.

See Also

TemplateItem Class
Sitecore.Data.Items Namespace


Key Property

[image]

Sitecore 6.4.1 API
TemplateItem..::..Key Property
TemplateItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Key { get; }
Visual Basic
Public ReadOnly Property Key As String
    Get
Visual C++
public:
property String^ Key {
    String^ get ();
}

Field Value

The key.

See Also

TemplateItem Class
Sitecore.Data.Items Namespace


OwnFields Property

[image]

Sitecore 6.4.1 API
TemplateItem..::..OwnFields Property
TemplateItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateFieldItem[] OwnFields { get; }
Visual Basic
Public ReadOnly Property OwnFields As TemplateFieldItem()
    Get
Visual C++
public:
property array<TemplateFieldItem^>^ OwnFields {
    array<TemplateFieldItem^>^ get ();
}

Field Value

The own fields.

Remarks

Fields are that are inherited from other templates are omitted.

See Also

TemplateItem Class
Sitecore.Data.Items Namespace


StandardValues Property

[image]

Sitecore 6.4.1 API
TemplateItem..::..StandardValues Property
TemplateItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item StandardValues { get; }
Visual Basic
Public ReadOnly Property StandardValues As Item
    Get
Visual C++
public:
property Item^ StandardValues {
    Item^ get ();
}

Field Value

The standard values.

See Also

TemplateItem Class
Sitecore.Data.Items Namespace


TemplateSectionItem Members

[image] [image]

Sitecore 6.4.1 API
TemplateSectionItem Members
TemplateSectionItem Class Constructors Methods Operators Properties See Also Send Feedback

The TemplateSectionItem type exposes the following members.

Constructors

 | Name | Description
Public method | TemplateSectionItem | Creates a new TemplateSectionItem instance.

Methods

 | Name | Description
Public method | AddField | Adds a field.
Public method | BeginEdit | Begins editing the item. (Inherited from CustomItemBase.)
Public method | EndEdit | Ends editing the item. (Inherited from CustomItemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetField(String) | Gets a field.
Public method | GetField(ID) | Gets a field.
Public method | GetFields | Gets the fields.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveField(String) | Removes the field.
Public method | RemoveField(ID) | Removes the field.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Item to TemplateSectionItem) | Converts an Item to a TemplateSectionItem.

Properties

 | Name | Description
Public property | Control | Gets the control that is used to display section toolbars in the client.
Public property | Database | Gets the database. (Inherited from CustomItemBase.)
Public property | DisplayName | Gets the display name. (Overrides CustomItemBase..::..DisplayName.)
Public property | HiddenByDefault | Gets a value indicating whether the section is hidden by default.
Public property | HideFields | Gets a value indicating whether fields are hidden for this section in the client.
Public property | Icon | Gets the icon.
Public property | ID | Gets the ID. (Inherited from CustomItemBase.)
Public property | InnerItem | Gets the inner item. (Inherited from CustomItemBase.)
Public property | Key | Gets the key.
Public property | Name | Gets the name. (Inherited from CustomItemBase.)
Public property | Sortorder | Gets the sortorder.
Public property | Template | Gets the template.

See Also

TemplateSectionItem Class
Sitecore.Data.Items Namespace


TemplateSectionItem Constructor

[image]

Sitecore 6.4.1 API
TemplateSectionItem Constructor
TemplateSectionItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateSectionItem(
    Item innerItem,
    TemplateItem owner
)
Visual Basic
Public Sub New ( _
    innerItem As Item, _
    owner As TemplateItem _
)
Visual C++
public:
TemplateSectionItem(
    Item^ innerItem,
    TemplateItem^ owner
)

Parameters

innerItem
Type: Sitecore.Data.Items..::..Item
Inner item.
owner
Type: Sitecore.Data.Items..::..TemplateItem
Owner.

See Also

TemplateSectionItem Class
Sitecore.Data.Items Namespace


TemplateSectionItem Methods

[image] [image]

Sitecore 6.4.1 API
TemplateSectionItem Methods
TemplateSectionItem Class See Also Send Feedback

The TemplateSectionItem type exposes the following members.

Methods

 | Name | Description
Public method | AddField | Adds a field.
Public method | BeginEdit | Begins editing the item. (Inherited from CustomItemBase.)
Public method | EndEdit | Ends editing the item. (Inherited from CustomItemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetField(String) | Gets a field.
Public method | GetField(ID) | Gets a field.
Public method | GetFields | Gets the fields.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveField(String) | Removes the field.
Public method | RemoveField(ID) | Removes the field.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TemplateSectionItem Class
Sitecore.Data.Items Namespace


AddField Method

[image]

Sitecore 6.4.1 API
TemplateSectionItem..::..AddField Method
TemplateSectionItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateFieldItem AddField(
    string fieldName
)
Visual Basic
Public Function AddField ( _
    fieldName As String _
) As TemplateFieldItem
Visual C++
public:
TemplateFieldItem^ AddField(
    String^ fieldName
)

Parameters

fieldName
Type: System..::..String
Name of the field.

Return Value

The field.

See Also

TemplateSectionItem Class
Sitecore.Data.Items Namespace


GetField Method

[image] [image]

Sitecore 6.4.1 API
TemplateSectionItem..::..GetField Method
TemplateSectionItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetField(String) | Gets a field.
Public method | GetField(ID) | Gets a field.

See Also

TemplateSectionItem Class
TemplateSectionItem Members
Sitecore.Data.Items Namespace


GetField Method (String)

[image]

Sitecore 6.4.1 API
TemplateSectionItem..::..GetField Method (String)
TemplateSectionItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateFieldItem GetField(
    string fieldName
)
Visual Basic
Public Function GetField ( _
    fieldName As String _
) As TemplateFieldItem
Visual C++
public:
TemplateFieldItem^ GetField(
    String^ fieldName
)

Parameters

fieldName
Type: System..::..String
Name of the field.

Return Value

The field.

See Also

TemplateSectionItem Class
GetField Overload
Sitecore.Data.Items Namespace


GetField Method (ID)

[image]

Sitecore 6.4.1 API
TemplateSectionItem..::..GetField Method (ID)
TemplateSectionItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateFieldItem GetField(
    ID fieldID
)
Visual Basic
Public Function GetField ( _
    fieldID As ID _
) As TemplateFieldItem
Visual C++
public:
TemplateFieldItem^ GetField(
    ID^ fieldID
)

Parameters

fieldID
Type: Sitecore.Data..::..ID
Field ID.

Return Value

The field.

See Also

TemplateSectionItem Class
GetField Overload
Sitecore.Data.Items Namespace


GetFields Method

[image]

Sitecore 6.4.1 API
TemplateSectionItem..::..GetFields Method
TemplateSectionItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateFieldItem[] GetFields()
Visual Basic
Public Function GetFields As TemplateFieldItem()
Visual C++
public:
array<TemplateFieldItem^>^ GetFields()

Return Value

The fields.

See Also

TemplateSectionItem Class
Sitecore.Data.Items Namespace


RemoveField Method

[image] [image]

Sitecore 6.4.1 API
TemplateSectionItem..::..RemoveField Method
TemplateSectionItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveField(String) | Removes the field.
Public method | RemoveField(ID) | Removes the field.

See Also

TemplateSectionItem Class
TemplateSectionItem Members
Sitecore.Data.Items Namespace


RemoveField Method (String)

[image]

Sitecore 6.4.1 API
TemplateSectionItem..::..RemoveField Method (String)
TemplateSectionItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RemoveField(
    string fieldName
)
Visual Basic
Public Sub RemoveField ( _
    fieldName As String _
)
Visual C++
public:
void RemoveField(
    String^ fieldName
)

Parameters

fieldName
Type: System..::..String
Name of the field.

See Also

TemplateSectionItem Class
RemoveField Overload
Sitecore.Data.Items Namespace


RemoveField Method (ID)

[image]

Sitecore 6.4.1 API
TemplateSectionItem..::..RemoveField Method (ID)
TemplateSectionItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RemoveField(
    ID fieldID
)
Visual Basic
Public Sub RemoveField ( _
    fieldID As ID _
)
Visual C++
public:
void RemoveField(
    ID^ fieldID
)

Parameters

fieldID
Type: Sitecore.Data..::..ID
Field ID.

See Also

TemplateSectionItem Class
RemoveField Overload
Sitecore.Data.Items Namespace


TemplateSectionItem Type Conversions

[image] [image]

Sitecore 6.4.1 API
TemplateSectionItem Type Conversions
TemplateSectionItem Class See Also Send Feedback

The TemplateSectionItem type exposes the following members.

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Item to TemplateSectionItem) | Converts an Item to a TemplateSectionItem.

See Also

TemplateSectionItem Class
Sitecore.Data.Items Namespace


Implicit Conversion (Item to TemplateSectionItem)

[image]

Sitecore 6.4.1 API
TemplateSectionItem ImplicitWideningImplicitImplicitImplicit Conversion (Item to TemplateSectionItem)
TemplateSectionItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator TemplateSectionItem (
    Item item
)
Visual Basic
Public Shared Widening Operator CType ( _
    item As Item _
) As TemplateSectionItem
Visual C++
static implicit operator TemplateSectionItem^ (
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

The implicit operator.

See Also

TemplateSectionItem Class
Sitecore.Data.Items Namespace


TemplateSectionItem Properties

[image] [image]

Sitecore 6.4.1 API
TemplateSectionItem Properties
TemplateSectionItem Class See Also Send Feedback

The TemplateSectionItem type exposes the following members.

Properties

 | Name | Description
Public property | Control | Gets the control that is used to display section toolbars in the client.
Public property | Database | Gets the database. (Inherited from CustomItemBase.)
Public property | DisplayName | Gets the display name. (Overrides CustomItemBase..::..DisplayName.)
Public property | HiddenByDefault | Gets a value indicating whether the section is hidden by default.
Public property | HideFields | Gets a value indicating whether fields are hidden for this section in the client.
Public property | Icon | Gets the icon.
Public property | ID | Gets the ID. (Inherited from CustomItemBase.)
Public property | InnerItem | Gets the inner item. (Inherited from CustomItemBase.)
Public property | Key | Gets the key.
Public property | Name | Gets the name. (Inherited from CustomItemBase.)
Public property | Sortorder | Gets the sortorder.
Public property | Template | Gets the template.

See Also

TemplateSectionItem Class
Sitecore.Data.Items Namespace


Control Property

[image]

Sitecore 6.4.1 API
TemplateSectionItem..::..Control Property
TemplateSectionItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Control { get; }
Visual Basic
Public ReadOnly Property Control As String
    Get
Visual C++
public:
property String^ Control {
    String^ get ();
}

Field Value

The control.

See Also

TemplateSectionItem Class
Sitecore.Data.Items Namespace


DisplayName Property

[image]

Sitecore 6.4.1 API
TemplateSectionItem..::..DisplayName Property
TemplateSectionItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string DisplayName { get; }
Visual Basic
Public Overrides ReadOnly Property DisplayName As String
    Get
Visual C++
public:
virtual property String^ DisplayName {
    String^ get () override;
}

Field Value

The name of the display.

Remarks

See Also

TemplateSectionItem Class
Sitecore.Data.Items Namespace
Item..::..DisplayName


HiddenByDefault Property

[image]

Sitecore 6.4.1 API
TemplateSectionItem..::..HiddenByDefault Property
TemplateSectionItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool HiddenByDefault { get; }
Visual Basic
Public ReadOnly Property HiddenByDefault As Boolean
    Get
Visual C++
public:
property bool HiddenByDefault {
    bool get ();
}

Field Value

true if the section is hidden by default; otherwise, false.

See Also

TemplateSectionItem Class
Sitecore.Data.Items Namespace


HideFields Property

[image]

Sitecore 6.4.1 API
TemplateSectionItem..::..HideFields Property
TemplateSectionItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool HideFields { get; }
Visual Basic
Public ReadOnly Property HideFields As Boolean
    Get
Visual C++
public:
property bool HideFields {
    bool get ();
}

Field Value

true if fields are hidden; otherwise, false.

See Also

TemplateSectionItem Class
Sitecore.Data.Items Namespace


Icon Property

[image]

Sitecore 6.4.1 API
TemplateSectionItem..::..Icon Property
TemplateSectionItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Icon { get; }
Visual Basic
Public ReadOnly Property Icon As String
    Get
Visual C++
public:
property String^ Icon {
    String^ get ();
}

Field Value

The icon.

Remarks

See Also

TemplateSectionItem Class
Sitecore.Data.Items Namespace
ItemAppearance..::..Icon


Key Property

[image]

Sitecore 6.4.1 API
TemplateSectionItem..::..Key Property
TemplateSectionItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Key { get; }
Visual Basic
Public ReadOnly Property Key As String
    Get
Visual C++
public:
property String^ Key {
    String^ get ();
}

Field Value

The key.

See Also

TemplateSectionItem Class
Sitecore.Data.Items Namespace


Sortorder Property

[image]

Sitecore 6.4.1 API
TemplateSectionItem..::..Sortorder Property
TemplateSectionItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Sortorder { get; }
Visual Basic
Public ReadOnly Property Sortorder As Integer
    Get
Visual C++
public:
property int Sortorder {
    int get ();
}

Field Value

The sortorder.

See Also

TemplateSectionItem Class
Sitecore.Data.Items Namespace


Template Property

[image]

Sitecore 6.4.1 API
TemplateSectionItem..::..Template Property
TemplateSectionItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateItem Template { get; }
Visual Basic
Public ReadOnly Property Template As TemplateItem
    Get
Visual C++
public:
property TemplateItem^ Template {
    TemplateItem^ get ();
}

Field Value

The template.

See Also

TemplateSectionItem Class
Sitecore.Data.Items Namespace


WebDAVFakeFolder Class

[image]

Sitecore 6.4.1 API
WebDAVFakeFolder Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class WebDAVFakeFolder : WebDAVFolder
Visual Basic
Public Class WebDAVFakeFolder _
    Inherits WebDAVFolder
Visual C++
public ref class WebDAVFakeFolder : public WebDAVFolder

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..WebDAVHierarchyItem
Sitecore.Data.Items..::..WebDAVFolder
Sitecore.Data.Items..::..WebDAVFakeFolder

See Also

WebDAVFakeFolder Members
Sitecore.Data.Items Namespace


WebDAVFakeFolder Members

[image] [image]

Sitecore 6.4.1 API
WebDAVFakeFolder Members
WebDAVFakeFolder Class Constructors Methods Properties See Also Send Feedback

The WebDAVFakeFolder type exposes the following members.

Constructors

 | Name | Description
Public method | WebDAVFakeFolder | Initializes a new instance of the WebDAVFakeFolder class.

Methods

 | Name | Description
Protected method | AddVersion | Adds the version to the item. (Inherited from WebDAVHierarchyItem.)
Protected method | CanExecuteOperation | Validates the operation. (Inherited from WebDAVHierarchyItem.)
Public method | CopyTo | Copies to. (Overrides WebDAVHierarchyItem..::..CopyTo(IFolder, String, Boolean).)
Public method | CreateFolder | Creates the folder. (Overrides WebDAVFolder..::..CreateFolder(String).)
Public method | CreateLockNull | Creates the lock null item. (Overrides WebDAVFolder..::..CreateLockNull(String, LockInfo%).)
Public method | CreateResource | Creates the resource. (Overrides WebDAVFolder..::..CreateResource(String).)
Public method | Delete | Deletes current item. (Overrides WebDAVHierarchyItem..::..Delete()()()().)
Protected method | DoCopyTo | Executes the copy to event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoCreateFolder | Executes the create folder operation. (Inherited from WebDAVFolder.)
Protected method | DoCreateLockNull | Executes the create lock null event. (Inherited from WebDAVFolder.)
Protected method | DoCreateResource | Executes the create resource command. (Inherited from WebDAVFolder.)
Protected method | DoDelete | Executes the delete event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoGetProperties | Executes the get properties event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoGetPropertyNames | Executes the get property names event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoMoveTo | Executes the move to operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoMoveToItem | Executes the move item operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoRename | Executes the rename operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoUpdateProperties | Executes the update properties event. (Inherited from WebDAVHierarchyItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExtractItemName | Extracts the name of the item. (Inherited from WebDAVHierarchyItem.)
Protected method | ExtractMediaItemPath | Extracts the path of the media item. (Inherited from WebDAVHierarchyItem.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindLocksDown | Finds the locks down. (Inherited from WebDAVHierarchyItem.)
Protected method | GetFullContentPath | Gets the full content path. (Inherited from WebDAVHierarchyItem.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocks | Gets the locks for the specified hierarchy item. (Inherited from WebDAVHierarchyItem.)
Protected method | GetMediaPath | Gets the media path. (Inherited from WebDAVHierarchyItem.)
Public method | GetProperties | Gets the properties. (Overrides WebDAVHierarchyItem..::..GetProperties(array<Property>[]()[][]%).)
Public method | GetPropertyNames | Gets the property names. (Overrides WebDAVHierarchyItem..::..GetPropertyNames(array<Property>[]()[][]%).)
Protected method | GetSitecoreItemLocks | Gets the sitecore item locks. (Inherited from WebDAVHierarchyItem.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValidFolderName | Gets the name of the valid folder. (Inherited from WebDAVFolder.)
Protected method | ItemHasLock | The Item has the lock. (Inherited from WebDAVHierarchyItem.)
Public method | Lock(LockInfo%) | Locks the specified lock info. (Overrides WebDAVHierarchyItem..::..Lock(LockInfo%).)
Protected method | Lock(ExLockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)
Protected method | LockSitecoreItem | Locks the sitecore item. (Inherited from WebDAVHierarchyItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveTo | Moves to destination folder. (Overrides WebDAVHierarchyItem..::..MoveTo(IFolder, String).)
Public method | RefreshLock | Refreshes the lock. (Inherited from WebDAVHierarchyItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unlock | Unlocks the specified lock token. (Inherited from WebDAVHierarchyItem.)
Protected method | UnlockSitecoreItem | Unlocks the sitecore item. (Inherited from WebDAVHierarchyItem.)
Public method | UpdateProperties | Updates the properties. (Overrides WebDAVHierarchyItem..::..UpdateProperties(array<Property>[]()[][], array<Property>[]()[][]).)

Properties

 | Name | Description
Public property | ActiveLocks | Gets the active locks. (Inherited from WebDAVHierarchyItem.)
Public property | Children | Gets the children. (Overrides WebDAVFolder..::..Children.)
Protected property | ClientHasToken | Gets a value indicating whether client has lock tokens. (Inherited from WebDAVHierarchyItem.)
Public property | Created | Gets the created date. (Overrides WebDAVHierarchyItem..::..Created.)
Protected property | Engine | Gets the engine. (Inherited from WebDAVHierarchyItem.)
Protected property | InnerItem | Gets or sets the inner item. (Inherited from WebDAVHierarchyItem.)
Public property | Modified | Gets the modified date. (Overrides WebDAVHierarchyItem..::..Modified.)
Public property | Name | Gets the item name. (Overrides WebDAVHierarchyItem..::..Name.)
Public property | Parent | Gets the parent. (Overrides WebDAVHierarchyItem..::..Parent.)
Public property | Path | Gets the item path. (Overrides WebDAVHierarchyItem..::..Path.)
Public property | UniqueID | Gets the unique ID. (Inherited from WebDAVHierarchyItem.)
Protected property | View | Gets the Web DAV view. (Inherited from WebDAVHierarchyItem.)

See Also

WebDAVFakeFolder Class
Sitecore.Data.Items Namespace


WebDAVFakeFolder Constructor

[image]

Sitecore 6.4.1 API
WebDAVFakeFolder Constructor
WebDAVFakeFolder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WebDAVFakeFolder(
    string name,
    WebDAVFolder parent,
    WebDAVView view,
    WebDAVEngine engine
)
Visual Basic
Public Sub New ( _
    name As String, _
    parent As WebDAVFolder, _
    view As WebDAVView, _
    engine As WebDAVEngine _
)
Visual C++
public:
WebDAVFakeFolder(
    String^ name,
    WebDAVFolder^ parent,
    WebDAVView^ view,
    WebDAVEngine^ engine
)

Parameters

name
Type: System..::..String
The Item name.
parent
Type: Sitecore.Data.Items..::..WebDAVFolder
The parent.
view
Type: Sitecore.Data.Views..::..WebDAVView
The WebDAV view.
engine
Type: Sitecore.Web..::..WebDAVEngine
The engine.

See Also

WebDAVFakeFolder Class
Sitecore.Data.Items Namespace


WebDAVFakeFolder Methods

[image] [image]

Sitecore 6.4.1 API
WebDAVFakeFolder Methods
WebDAVFakeFolder Class See Also Send Feedback

The WebDAVFakeFolder type exposes the following members.

Methods

 | Name | Description
Protected method | AddVersion | Adds the version to the item. (Inherited from WebDAVHierarchyItem.)
Protected method | CanExecuteOperation | Validates the operation. (Inherited from WebDAVHierarchyItem.)
Public method | CopyTo | Copies to. (Overrides WebDAVHierarchyItem..::..CopyTo(IFolder, String, Boolean).)
Public method | CreateFolder | Creates the folder. (Overrides WebDAVFolder..::..CreateFolder(String).)
Public method | CreateLockNull | Creates the lock null item. (Overrides WebDAVFolder..::..CreateLockNull(String, LockInfo%).)
Public method | CreateResource | Creates the resource. (Overrides WebDAVFolder..::..CreateResource(String).)
Public method | Delete | Deletes current item. (Overrides WebDAVHierarchyItem..::..Delete()()()().)
Protected method | DoCopyTo | Executes the copy to event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoCreateFolder | Executes the create folder operation. (Inherited from WebDAVFolder.)
Protected method | DoCreateLockNull | Executes the create lock null event. (Inherited from WebDAVFolder.)
Protected method | DoCreateResource | Executes the create resource command. (Inherited from WebDAVFolder.)
Protected method | DoDelete | Executes the delete event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoGetProperties | Executes the get properties event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoGetPropertyNames | Executes the get property names event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoMoveTo | Executes the move to operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoMoveToItem | Executes the move item operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoRename | Executes the rename operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoUpdateProperties | Executes the update properties event. (Inherited from WebDAVHierarchyItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExtractItemName | Extracts the name of the item. (Inherited from WebDAVHierarchyItem.)
Protected method | ExtractMediaItemPath | Extracts the path of the media item. (Inherited from WebDAVHierarchyItem.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindLocksDown | Finds the locks down. (Inherited from WebDAVHierarchyItem.)
Protected method | GetFullContentPath | Gets the full content path. (Inherited from WebDAVHierarchyItem.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocks | Gets the locks for the specified hierarchy item. (Inherited from WebDAVHierarchyItem.)
Protected method | GetMediaPath | Gets the media path. (Inherited from WebDAVHierarchyItem.)
Public method | GetProperties | Gets the properties. (Overrides WebDAVHierarchyItem..::..GetProperties(array<Property>[]()[][]%).)
Public method | GetPropertyNames | Gets the property names. (Overrides WebDAVHierarchyItem..::..GetPropertyNames(array<Property>[]()[][]%).)
Protected method | GetSitecoreItemLocks | Gets the sitecore item locks. (Inherited from WebDAVHierarchyItem.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValidFolderName | Gets the name of the valid folder. (Inherited from WebDAVFolder.)
Protected method | ItemHasLock | The Item has the lock. (Inherited from WebDAVHierarchyItem.)
Public method | Lock(LockInfo%) | Locks the specified lock info. (Overrides WebDAVHierarchyItem..::..Lock(LockInfo%).)
Protected method | Lock(ExLockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)
Protected method | LockSitecoreItem | Locks the sitecore item. (Inherited from WebDAVHierarchyItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveTo | Moves to destination folder. (Overrides WebDAVHierarchyItem..::..MoveTo(IFolder, String).)
Public method | RefreshLock | Refreshes the lock. (Inherited from WebDAVHierarchyItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unlock | Unlocks the specified lock token. (Inherited from WebDAVHierarchyItem.)
Protected method | UnlockSitecoreItem | Unlocks the sitecore item. (Inherited from WebDAVHierarchyItem.)
Public method | UpdateProperties | Updates the properties. (Overrides WebDAVHierarchyItem..::..UpdateProperties(array<Property>[]()[][], array<Property>[]()[][]).)

See Also

WebDAVFakeFolder Class
Sitecore.Data.Items Namespace


CopyTo Method

[image]

Sitecore 6.4.1 API
WebDAVFakeFolder..::..CopyTo Method
WebDAVFakeFolder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override WebDAVResponse CopyTo(
    IFolder folder,
    string destName,
    bool deep
)
Visual Basic
Public Overrides Function CopyTo ( _
    folder As IFolder, _
    destName As String, _
    deep As Boolean _
) As WebDAVResponse
Visual C++
public:
virtual WebDAVResponse^ CopyTo(
    IFolder^ folder,
    String^ destName,
    bool deep
) override

Parameters

folder
Type: IFolder
The folder.
destName
Type: System..::..String
Name of the destination.
deep
Type: System..::..Boolean
if set to true all subtree will be copied.

Return Value

Web DAV response.

Implements

IHierarchyItemCopyTo(IFolder, String, Boolean)

See Also

WebDAVFakeFolder Class
Sitecore.Data.Items Namespace


CreateFolder Method

[image]

Sitecore 6.4.1 API
WebDAVFakeFolder..::..CreateFolder Method
WebDAVFakeFolder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override WebDAVResponse CreateFolder(
    string folderName
)
Visual Basic
Public Overrides Function CreateFolder ( _
    folderName As String _
) As WebDAVResponse
Visual C++
public:
virtual WebDAVResponse^ CreateFolder(
    String^ folderName
) override

Parameters

folderName
Type: System..::..String
Name of the folder.

Return Value

The Web DAV Response.

Implements

IFolderCreateFolder(String)

See Also

WebDAVFakeFolder Class
Sitecore.Data.Items Namespace


CreateLockNull Method

[image]

Sitecore 6.4.1 API
WebDAVFakeFolder..::..CreateLockNull Method
WebDAVFakeFolder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override WebDAVResponse CreateLockNull(
    string newItemName,
    ref LockInfo lockInfo
)
Visual Basic
Public Overrides Function CreateLockNull ( _
    newItemName As String, _
    ByRef lockInfo As LockInfo _
) As WebDAVResponse
Visual C++
public:
virtual WebDAVResponse^ CreateLockNull(
    String^ newItemName,
    LockInfo% lockInfo
) override

Parameters

newItemName
Type: System..::..String
New name of the item.
lockInfo
Type: LockInfo%
The lock info.

Return Value

Web DAV Response.

Implements

IFolderLockCreateLockNull(String, LockInfo%)

See Also

WebDAVFakeFolder Class
Sitecore.Data.Items Namespace


CreateResource Method

[image]

Sitecore 6.4.1 API
WebDAVFakeFolder..::..CreateResource Method
WebDAVFakeFolder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override WebDAVResponse CreateResource(
    string resourceName
)
Visual Basic
Public Overrides Function CreateResource ( _
    resourceName As String _
) As WebDAVResponse
Visual C++
public:
virtual WebDAVResponse^ CreateResource(
    String^ resourceName
) override

Parameters

resourceName
Type: System..::..String
Name of the resource.

Return Value

The Web DAV Response.

Implements

IFolderCreateResource(String)

See Also

WebDAVFakeFolder Class
Sitecore.Data.Items Namespace


Delete Method

[image]

Sitecore 6.4.1 API
WebDAVFakeFolder..::..Delete Method
WebDAVFakeFolder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override WebDAVResponse Delete()
Visual Basic
Public Overrides Function Delete As WebDAVResponse
Visual C++
public:
virtual WebDAVResponse^ Delete() override

Return Value

Web DAV response.

Implements

IHierarchyItemDelete()()()()

See Also

WebDAVFakeFolder Class
Sitecore.Data.Items Namespace


GetProperties Method

[image]

Sitecore 6.4.1 API
WebDAVFakeFolder..::..GetProperties Method
WebDAVFakeFolder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override WebDAVResponse GetProperties(
    ref Property[] props
)
Visual Basic
Public Overrides Function GetProperties ( _
    ByRef props As Property() _
) As WebDAVResponse
Visual C++
public:
virtual WebDAVResponse^ GetProperties(
    array<Property>^% props
) override

Parameters

props
Type: array<Property>[]()[][]%
The properties.

Return Value

Web DAV Response.

Implements

IHierarchyItemGetProperties(array<Property>[]()[][]%)

See Also

WebDAVFakeFolder Class
Sitecore.Data.Items Namespace


GetPropertyNames Method

[image]

Sitecore 6.4.1 API
WebDAVFakeFolder..::..GetPropertyNames Method
WebDAVFakeFolder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override WebDAVResponse GetPropertyNames(
    ref Property[] props
)
Visual Basic
Public Overrides Function GetPropertyNames ( _
    ByRef props As Property() _
) As WebDAVResponse
Visual C++
public:
virtual WebDAVResponse^ GetPropertyNames(
    array<Property>^% props
) override

Parameters

props
Type: array<Property>[]()[][]%
The properties.

Return Value

Web DAV response.

Implements

IHierarchyItemGetPropertyNames(array<Property>[]()[][]%)

See Also

WebDAVFakeFolder Class
Sitecore.Data.Items Namespace


Lock Method ()

[image]

Sitecore 6.4.1 API
WebDAVFakeFolder..::..Lock Method (%)
WebDAVFakeFolder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override WebDAVResponse Lock(
    ref LockInfo lockInfo
)
Visual Basic
Public Overrides Function Lock ( _
    ByRef lockInfo As LockInfo _
) As WebDAVResponse
Visual C++
public:
virtual WebDAVResponse^ Lock(
    LockInfo% lockInfo
) override

Parameters

lockInfo
Type: LockInfo%
The lock info.

Return Value

Web DAV Response.

Implements

ILockLock(LockInfo%)

See Also

WebDAVFakeFolder Class
Lock Overload
Sitecore.Data.Items Namespace


MoveTo Method

[image]

Sitecore 6.4.1 API
WebDAVFakeFolder..::..MoveTo Method
WebDAVFakeFolder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override WebDAVResponse MoveTo(
    IFolder folder,
    string destName
)
Visual Basic
Public Overrides Function MoveTo ( _
    folder As IFolder, _
    destName As String _
) As WebDAVResponse
Visual C++
public:
virtual WebDAVResponse^ MoveTo(
    IFolder^ folder,
    String^ destName
) override

Parameters

folder
Type: IFolder
The folder.
destName
Type: System..::..String
Name of the destination.

Return Value

Web DAV response.

Implements

IHierarchyItemMoveTo(IFolder, String)

See Also

WebDAVFakeFolder Class
Sitecore.Data.Items Namespace


UpdateProperties Method

[image]

Sitecore 6.4.1 API
WebDAVFakeFolder..::..UpdateProperties Method
WebDAVFakeFolder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override WebDAVResponse UpdateProperties(
    Property[] setProps,
    Property[] delProps
)
Visual Basic
Public Overrides Function UpdateProperties ( _
    setProps As Property(), _
    delProps As Property() _
) As WebDAVResponse
Visual C++
public:
virtual WebDAVResponse^ UpdateProperties(
    array<Property>^ setProps,
    array<Property>^ delProps
) override

Parameters

setProps
Type: array<Property>[]()[][]
The properties to be setted.
delProps
Type: array<Property>[]()[][]
The properties to be deleted.

Return Value

Web DAV response.

Implements

IHierarchyItemUpdateProperties(array<Property>[]()[][], array<Property>[]()[][])

See Also

WebDAVFakeFolder Class
Sitecore.Data.Items Namespace


WebDAVFakeFolder Properties

[image] [image]

Sitecore 6.4.1 API
WebDAVFakeFolder Properties
WebDAVFakeFolder Class See Also Send Feedback

The WebDAVFakeFolder type exposes the following members.

Properties

 | Name | Description
Public property | ActiveLocks | Gets the active locks. (Inherited from WebDAVHierarchyItem.)
Public property | Children | Gets the children. (Overrides WebDAVFolder..::..Children.)
Protected property | ClientHasToken | Gets a value indicating whether client has lock tokens. (Inherited from WebDAVHierarchyItem.)
Public property | Created | Gets the created date. (Overrides WebDAVHierarchyItem..::..Created.)
Protected property | Engine | Gets the engine. (Inherited from WebDAVHierarchyItem.)
Protected property | InnerItem | Gets or sets the inner item. (Inherited from WebDAVHierarchyItem.)
Public property | Modified | Gets the modified date. (Overrides WebDAVHierarchyItem..::..Modified.)
Public property | Name | Gets the item name. (Overrides WebDAVHierarchyItem..::..Name.)
Public property | Parent | Gets the parent. (Overrides WebDAVHierarchyItem..::..Parent.)
Public property | Path | Gets the item path. (Overrides WebDAVHierarchyItem..::..Path.)
Public property | UniqueID | Gets the unique ID. (Inherited from WebDAVHierarchyItem.)
Protected property | View | Gets the Web DAV view. (Inherited from WebDAVHierarchyItem.)

See Also

WebDAVFakeFolder Class
Sitecore.Data.Items Namespace


Children Property

[image]

Sitecore 6.4.1 API
WebDAVFakeFolder..::..Children Property
WebDAVFakeFolder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override IHierarchyItem[] Children { get; }
Visual Basic
Public Overrides ReadOnly Property Children As IHierarchyItem()
    Get
Visual C++
public:
virtual property array<IHierarchyItem^>^ Children {
    array<IHierarchyItem^>^ get () override;
}

Field Value

The children.

Implements

IFolderChildren()()()()

Exceptions

Exception | Condition
System..::..Exception | Cannot get the children for the folder.

See Also

WebDAVFakeFolder Class
Sitecore.Data.Items Namespace


Created Property

[image]

Sitecore 6.4.1 API
WebDAVFakeFolder..::..Created Property
WebDAVFakeFolder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override DateTime Created { get; }
Visual Basic
Public Overrides ReadOnly Property Created As DateTime
    Get
Visual C++
public:
virtual property DateTime Created {
    DateTime get () override;
}

Field Value

The created date.

Implements

IHierarchyItemCreated()()()()

See Also

WebDAVFakeFolder Class
Sitecore.Data.Items Namespace


Name Property

[image]

Sitecore 6.4.1 API
WebDAVFakeFolder..::..Name Property
WebDAVFakeFolder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The item name.

Implements

IHierarchyItemName()()()()

See Also

WebDAVFakeFolder Class
Sitecore.Data.Items Namespace


Parent Property

[image]

Sitecore 6.4.1 API
WebDAVFakeFolder..::..Parent Property
WebDAVFakeFolder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override IFolder Parent { get; }
Visual Basic
Public Overrides ReadOnly Property Parent As IFolder
    Get
Visual C++
public:
virtual property IFolder^ Parent {
    IFolder^ get () override;
}

Field Value

The parent.

Implements

IHierarchyItemParent()()()()

See Also

WebDAVFakeFolder Class
Sitecore.Data.Items Namespace


Path Property

[image]

Sitecore 6.4.1 API
WebDAVFakeFolder..::..Path Property
WebDAVFakeFolder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Path { get; }
Visual Basic
Public Overrides ReadOnly Property Path As String
    Get
Visual C++
public:
virtual property String^ Path {
    String^ get () override;
}

Field Value

The item path.

Implements

IHierarchyItemPath()()()()

See Also

WebDAVFakeFolder Class
Sitecore.Data.Items Namespace


WebDAVFolder Members

[image] [image]

Sitecore 6.4.1 API
WebDAVFolder Members
WebDAVFolder Class Constructors Methods Properties See Also Send Feedback

The WebDAVFolder type exposes the following members.

Constructors

 | Name | Description
Public method | WebDAVFolder | Initializes a new instance of the WebDAVFolder class.

Methods

 | Name | Description
Protected method | AddVersion | Adds the version to the item. (Inherited from WebDAVHierarchyItem.)
Protected method | CanExecuteOperation | Validates the operation. (Inherited from WebDAVHierarchyItem.)
Public method | CopyTo | Copies to. (Inherited from WebDAVHierarchyItem.)
Public method | CreateFolder | Creates the folder.
Public method | CreateLockNull | Creates the lock null item.
Public method | CreateResource | Creates the resource.
Public method | Delete | Deletes current item. (Inherited from WebDAVHierarchyItem.)
Protected method | DoCopyTo | Executes the copy to event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoCreateFolder | Executes the create folder operation.
Protected method | DoCreateLockNull | Executes the create lock null event.
Protected method | DoCreateResource | Executes the create resource command.
Protected method | DoDelete | Executes the delete event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoGetProperties | Executes the get properties event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoGetPropertyNames | Executes the get property names event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoMoveTo | Executes the move to operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoMoveToItem | Executes the move item operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoRename | Executes the rename operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoUpdateProperties | Executes the update properties event. (Inherited from WebDAVHierarchyItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExtractItemName | Extracts the name of the item. (Inherited from WebDAVHierarchyItem.)
Protected method | ExtractMediaItemPath | Extracts the path of the media item. (Inherited from WebDAVHierarchyItem.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindLocksDown | Finds the locks down. (Inherited from WebDAVHierarchyItem.)
Protected method | GetFullContentPath | Gets the full content path. (Inherited from WebDAVHierarchyItem.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocks | Gets the locks for the specified hierarchy item. (Inherited from WebDAVHierarchyItem.)
Protected method | GetMediaPath | Gets the media path. (Inherited from WebDAVHierarchyItem.)
Public method | GetProperties | Gets the properties. (Inherited from WebDAVHierarchyItem.)
Public method | GetPropertyNames | Gets the property names. (Inherited from WebDAVHierarchyItem.)
Protected method | GetSitecoreItemLocks | Gets the sitecore item locks. (Inherited from WebDAVHierarchyItem.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValidFolderName | Gets the name of the valid folder.
Protected method | ItemHasLock | The Item has the lock. (Inherited from WebDAVHierarchyItem.)
Public method | Lock(LockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)
Protected method | Lock(ExLockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)
Protected method | LockSitecoreItem | Locks the sitecore item. (Inherited from WebDAVHierarchyItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveTo | Moves to destination folder. (Inherited from WebDAVHierarchyItem.)
Public method | RefreshLock | Refreshes the lock. (Inherited from WebDAVHierarchyItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unlock | Unlocks the specified lock token. (Inherited from WebDAVHierarchyItem.)
Protected method | UnlockSitecoreItem | Unlocks the sitecore item. (Inherited from WebDAVHierarchyItem.)
Public method | UpdateProperties | Updates the properties. (Inherited from WebDAVHierarchyItem.)

Properties

 | Name | Description
Public property | ActiveLocks | Gets the active locks. (Inherited from WebDAVHierarchyItem.)
Public property | Children | Gets the children.
Protected property | ClientHasToken | Gets a value indicating whether client has lock tokens. (Inherited from WebDAVHierarchyItem.)
Public property | Created | Gets the created date. (Inherited from WebDAVHierarchyItem.)
Protected property | Engine | Gets the engine. (Inherited from WebDAVHierarchyItem.)
Protected property | InnerItem | Gets or sets the inner item. (Inherited from WebDAVHierarchyItem.)
Public property | Modified | Gets the modified date. (Inherited from WebDAVHierarchyItem.)
Public property | Name | Gets the item name. (Inherited from WebDAVHierarchyItem.)
Public property | Parent | Gets the parent. (Inherited from WebDAVHierarchyItem.)
Public property | Path | Gets the item path. (Inherited from WebDAVHierarchyItem.)
Public property | UniqueID | Gets the unique ID. (Inherited from WebDAVHierarchyItem.)
Protected property | View | Gets the Web DAV view. (Inherited from WebDAVHierarchyItem.)

See Also

WebDAVFolder Class
Sitecore.Data.Items Namespace


WebDAVFolder Constructor

[image]

Sitecore 6.4.1 API
WebDAVFolder Constructor
WebDAVFolder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WebDAVFolder(
    Item item,
    WebDAVView view,
    WebDAVEngine engine
)
Visual Basic
Public Sub New ( _
    item As Item, _
    view As WebDAVView, _
    engine As WebDAVEngine _
)
Visual C++
public:
WebDAVFolder(
    Item^ item,
    WebDAVView^ view,
    WebDAVEngine^ engine
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item.
view
Type: Sitecore.Data.Views..::..WebDAVView
The Web DAV view.
engine
Type: Sitecore.Web..::..WebDAVEngine
The Web DAV engine.

See Also

WebDAVFolder Class
Sitecore.Data.Items Namespace


WebDAVFolder Methods

[image] [image]

Sitecore 6.4.1 API
WebDAVFolder Methods
WebDAVFolder Class See Also Send Feedback

The WebDAVFolder type exposes the following members.

Methods

 | Name | Description
Protected method | AddVersion | Adds the version to the item. (Inherited from WebDAVHierarchyItem.)
Protected method | CanExecuteOperation | Validates the operation. (Inherited from WebDAVHierarchyItem.)
Public method | CopyTo | Copies to. (Inherited from WebDAVHierarchyItem.)
Public method | CreateFolder | Creates the folder.
Public method | CreateLockNull | Creates the lock null item.
Public method | CreateResource | Creates the resource.
Public method | Delete | Deletes current item. (Inherited from WebDAVHierarchyItem.)
Protected method | DoCopyTo | Executes the copy to event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoCreateFolder | Executes the create folder operation.
Protected method | DoCreateLockNull | Executes the create lock null event.
Protected method | DoCreateResource | Executes the create resource command.
Protected method | DoDelete | Executes the delete event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoGetProperties | Executes the get properties event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoGetPropertyNames | Executes the get property names event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoMoveTo | Executes the move to operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoMoveToItem | Executes the move item operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoRename | Executes the rename operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoUpdateProperties | Executes the update properties event. (Inherited from WebDAVHierarchyItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExtractItemName | Extracts the name of the item. (Inherited from WebDAVHierarchyItem.)
Protected method | ExtractMediaItemPath | Extracts the path of the media item. (Inherited from WebDAVHierarchyItem.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindLocksDown | Finds the locks down. (Inherited from WebDAVHierarchyItem.)
Protected method | GetFullContentPath | Gets the full content path. (Inherited from WebDAVHierarchyItem.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocks | Gets the locks for the specified hierarchy item. (Inherited from WebDAVHierarchyItem.)
Protected method | GetMediaPath | Gets the media path. (Inherited from WebDAVHierarchyItem.)
Public method | GetProperties | Gets the properties. (Inherited from WebDAVHierarchyItem.)
Public method | GetPropertyNames | Gets the property names. (Inherited from WebDAVHierarchyItem.)
Protected method | GetSitecoreItemLocks | Gets the sitecore item locks. (Inherited from WebDAVHierarchyItem.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValidFolderName | Gets the name of the valid folder.
Protected method | ItemHasLock | The Item has the lock. (Inherited from WebDAVHierarchyItem.)
Public method | Lock(LockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)
Protected method | Lock(ExLockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)
Protected method | LockSitecoreItem | Locks the sitecore item. (Inherited from WebDAVHierarchyItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveTo | Moves to destination folder. (Inherited from WebDAVHierarchyItem.)
Public method | RefreshLock | Refreshes the lock. (Inherited from WebDAVHierarchyItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unlock | Unlocks the specified lock token. (Inherited from WebDAVHierarchyItem.)
Protected method | UnlockSitecoreItem | Unlocks the sitecore item. (Inherited from WebDAVHierarchyItem.)
Public method | UpdateProperties | Updates the properties. (Inherited from WebDAVHierarchyItem.)

See Also

WebDAVFolder Class
Sitecore.Data.Items Namespace


CreateFolder Method

[image]

Sitecore 6.4.1 API
WebDAVFolder..::..CreateFolder Method
WebDAVFolder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual WebDAVResponse CreateFolder(
    string name
)
Visual Basic
Public Overridable Function CreateFolder ( _
    name As String _
) As WebDAVResponse
Visual C++
public:
virtual WebDAVResponse^ CreateFolder(
    String^ name
)

Parameters

name
Type: System..::..String
The folder name.

Return Value

The Web DAV Response.

Implements

IFolderCreateFolder(String)

See Also

WebDAVFolder Class
Sitecore.Data.Items Namespace


CreateLockNull Method

[image]

Sitecore 6.4.1 API
WebDAVFolder..::..CreateLockNull Method
WebDAVFolder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual WebDAVResponse CreateLockNull(
    string newItemName,
    ref LockInfo lockInfo
)
Visual Basic
Public Overridable Function CreateLockNull ( _
    newItemName As String, _
    ByRef lockInfo As LockInfo _
) As WebDAVResponse
Visual C++
public:
virtual WebDAVResponse^ CreateLockNull(
    String^ newItemName,
    LockInfo% lockInfo
)

Parameters

newItemName
Type: System..::..String
New name of the item.
lockInfo
Type: LockInfo%
The lock info.

Return Value

Web DAV Response.

Implements

IFolderLockCreateLockNull(String, LockInfo%)

See Also

WebDAVFolder Class
Sitecore.Data.Items Namespace


CreateResource Method

[image]

Sitecore 6.4.1 API
WebDAVFolder..::..CreateResource Method
WebDAVFolder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual WebDAVResponse CreateResource(
    string name
)
Visual Basic
Public Overridable Function CreateResource ( _
    name As String _
) As WebDAVResponse
Visual C++
public:
virtual WebDAVResponse^ CreateResource(
    String^ name
)

Parameters

name
Type: System..::..String
The resource name.

Return Value

The Web DAV Response.

Implements

IFolderCreateResource(String)

See Also

WebDAVFolder Class
Sitecore.Data.Items Namespace


DoCreateFolder Method

[image]

Sitecore 6.4.1 API
WebDAVFolder..::..DoCreateFolder Method
WebDAVFolder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual WebDAVResponse DoCreateFolder(
    string name
)
Visual Basic
Protected Overridable Function DoCreateFolder ( _
    name As String _
) As WebDAVResponse
Visual C++
protected:
virtual WebDAVResponse^ DoCreateFolder(
    String^ name
)

Parameters

name
Type: System..::..String
The folder name.

Return Value

The WebDAVResponse.

See Also

WebDAVFolder Class
Sitecore.Data.Items Namespace


DoCreateLockNull Method

[image]

Sitecore 6.4.1 API
WebDAVFolder..::..DoCreateLockNull Method
WebDAVFolder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual WebDAVResponse DoCreateLockNull(
    string newItemName,
    ref LockInfo lockInfo
)
Visual Basic
Protected Overridable Function DoCreateLockNull ( _
    newItemName As String, _
    ByRef lockInfo As LockInfo _
) As WebDAVResponse
Visual C++
protected:
virtual WebDAVResponse^ DoCreateLockNull(
    String^ newItemName,
    LockInfo% lockInfo
)

Parameters

newItemName
Type: System..::..String
New name of the item.
lockInfo
Type: LockInfo%
The lock info.

Return Value

The WebDAVResponse.

See Also

WebDAVFolder Class
Sitecore.Data.Items Namespace


DoCreateResource Method

[image]

Sitecore 6.4.1 API
WebDAVFolder..::..DoCreateResource Method
WebDAVFolder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual WebDAVResponse DoCreateResource(
    string name,
    Stream content,
    string contentType
)
Visual Basic
Protected Overridable Function DoCreateResource ( _
    name As String, _
    content As Stream, _
    contentType As String _
) As WebDAVResponse
Visual C++
protected:
virtual WebDAVResponse^ DoCreateResource(
    String^ name,
    Stream^ content,
    String^ contentType
)

Parameters

name
Type: System..::..String
The Resource name.
content
Type: System.IO..::..Stream
The content.
contentType
Type: System..::..String
Type of the content.

Return Value

The WebDAVResponse.

See Also

WebDAVFolder Class
Sitecore.Data.Items Namespace


GetValidFolderName Method

[image]

Sitecore 6.4.1 API
WebDAVFolder..::..GetValidFolderName Method
WebDAVFolder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected string GetValidFolderName(
    string name
)
Visual Basic
Protected Function GetValidFolderName ( _
    name As String _
) As String
Visual C++
protected:
String^ GetValidFolderName(
    String^ name
)

Parameters

name
Type: System..::..String
The folder name.

Return Value

The valid folder name.

See Also

WebDAVFolder Class
Sitecore.Data.Items Namespace


Lock Method

[image] [image]

Sitecore 6.4.1 API
WebDAVFolder..::..Lock Method
WebDAVFolder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Lock(LockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)
Protected method | Lock(ExLockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)

See Also

WebDAVFolder Class
WebDAVFolder Members
Sitecore.Data.Items Namespace


Children Property

[image]

Sitecore 6.4.1 API
WebDAVFolder..::..Children Property
WebDAVFolder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual IHierarchyItem[] Children { get; }
Visual Basic
Public Overridable ReadOnly Property Children As IHierarchyItem()
    Get
Visual C++
public:
virtual property array<IHierarchyItem^>^ Children {
    array<IHierarchyItem^>^ get ();
}

Field Value

The children.

Implements

IFolderChildren()()()()

Exceptions

Exception | Condition
System..::..Exception | Cannot get the children for the folder.

See Also

WebDAVFolder Class
Sitecore.Data.Items Namespace


WebDAVHierarchyItem Class

[image]

Sitecore 6.4.1 API
WebDAVHierarchyItem Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class WebDAVHierarchyItem : IHierarchyItem,
    ILock
Visual Basic
Public MustInherit Class WebDAVHierarchyItem _
    Implements IHierarchyItem, ILock
Visual C++
public ref class WebDAVHierarchyItem abstract : IHierarchyItem,
    ILock

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..WebDAVHierarchyItem
Sitecore.Data.Items..::..WebDAVFolder
Sitecore.Data.Items..::..WebDAVLockNullItem
Sitecore.Data.Items..::..WebDAVMediaItem

See Also

WebDAVHierarchyItem Members
Sitecore.Data.Items Namespace


WebDAVHierarchyItem Members

[image] [image]

Sitecore 6.4.1 API
WebDAVHierarchyItem Members
WebDAVHierarchyItem Class Constructors Methods Properties See Also Send Feedback

The WebDAVHierarchyItem type exposes the following members.

Constructors

 | Name | Description
Public method | WebDAVHierarchyItem | Initializes a new instance of the WebDAVHierarchyItem class.

Methods

 | Name | Description
Protected method | AddVersion | Adds the version to the item.
Protected method | CanExecuteOperation | Validates the operation.
Public method | CopyTo | Copies to.
Public method | Delete | Deletes current item.
Protected method | DoCopyTo | Executes the copy to event.
Protected method | DoDelete | Executes the delete event.
Protected method | DoGetProperties | Executes the get properties event.
Protected method | DoGetPropertyNames | Executes the get property names event.
Protected method | DoMoveTo | Executes the move to operation.
Protected method | DoMoveToItem | Executes the move item operation.
Protected method | DoRename | Executes the rename operation.
Protected method | DoUpdateProperties | Executes the update properties event.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExtractItemName | Extracts the name of the item.
Protected method | ExtractMediaItemPath | Extracts the path of the media item.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindLocksDown | Finds the locks down.
Protected method | GetFullContentPath | Gets the full content path.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocks | Gets the locks for the specified hierarchy item.
Protected method | GetMediaPath | Gets the media path.
Public method | GetProperties | Gets the properties.
Public method | GetPropertyNames | Gets the property names.
Protected method | GetSitecoreItemLocks | Gets the sitecore item locks.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetUniqueID | Gets the unique ID.
Protected method | ItemHasLock | The Item has the lock.
Public method | Lock(LockInfo%) | Locks the specified lock info.
Protected method | Lock(ExLockInfo%) | Locks the specified lock info.
Protected method | LockSitecoreItem | Locks the sitecore item.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveTo | Moves to destination folder.
Public method | RefreshLock | Refreshes the lock.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unlock | Unlocks the specified lock token.
Protected method | UnlockSitecoreItem | Unlocks the sitecore item.
Public method | UpdateProperties | Updates the properties.

Properties

 | Name | Description
Public property | ActiveLocks | Gets the active locks.
Protected property | ClientHasToken | Gets a value indicating whether client has lock tokens.
Public property | Created | Gets the created date.
Protected property | Engine | Gets the engine.
Protected property | InnerItem | Gets or sets the inner item.
Public property | Modified | Gets the modified date.
Public property | Name | Gets the item name.
Public property | Parent | Gets the parent.
Public property | Path | Gets the item path.
Public property | UniqueID | Gets the unique ID.
Protected property | View | Gets the Web DAV view.

See Also

WebDAVHierarchyItem Class
Sitecore.Data.Items Namespace


WebDAVHierarchyItem Constructor

[image]

Sitecore 6.4.1 API
WebDAVHierarchyItem Constructor
WebDAVHierarchyItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WebDAVHierarchyItem(
    Item item,
    WebDAVView view,
    WebDAVEngine engine
)
Visual Basic
Public Sub New ( _
    item As Item, _
    view As WebDAVView, _
    engine As WebDAVEngine _
)
Visual C++
public:
WebDAVHierarchyItem(
    Item^ item,
    WebDAVView^ view,
    WebDAVEngine^ engine
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item.
view
Type: Sitecore.Data.Views..::..WebDAVView
The Web DAV view.
engine
Type: Sitecore.Web..::..WebDAVEngine
The Web DAV engine.

See Also

WebDAVHierarchyItem Class
Sitecore.Data.Items Namespace


WebDAVHierarchyItem Methods

[image] [image]

Sitecore 6.4.1 API
WebDAVHierarchyItem Methods
WebDAVHierarchyItem Class See Also Send Feedback

The WebDAVHierarchyItem type exposes the following members.

Methods

 | Name | Description
Protected method | AddVersion | Adds the version to the item.
Protected method | CanExecuteOperation | Validates the operation.
Public method | CopyTo | Copies to.
Public method | Delete | Deletes current item.
Protected method | DoCopyTo | Executes the copy to event.
Protected method | DoDelete | Executes the delete event.
Protected method | DoGetProperties | Executes the get properties event.
Protected method | DoGetPropertyNames | Executes the get property names event.
Protected method | DoMoveTo | Executes the move to operation.
Protected method | DoMoveToItem | Executes the move item operation.
Protected method | DoRename | Executes the rename operation.
Protected method | DoUpdateProperties | Executes the update properties event.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExtractItemName | Extracts the name of the item.
Protected method | ExtractMediaItemPath | Extracts the path of the media item.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindLocksDown | Finds the locks down.
Protected method | GetFullContentPath | Gets the full content path.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocks | Gets the locks for the specified hierarchy item.
Protected method | GetMediaPath | Gets the media path.
Public method | GetProperties | Gets the properties.
Public method | GetPropertyNames | Gets the property names.
Protected method | GetSitecoreItemLocks | Gets the sitecore item locks.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetUniqueID | Gets the unique ID.
Protected method | ItemHasLock | The Item has the lock.
Public method | Lock(LockInfo%) | Locks the specified lock info.
Protected method | Lock(ExLockInfo%) | Locks the specified lock info.
Protected method | LockSitecoreItem | Locks the sitecore item.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveTo | Moves to destination folder.
Public method | RefreshLock | Refreshes the lock.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unlock | Unlocks the specified lock token.
Protected method | UnlockSitecoreItem | Unlocks the sitecore item.
Public method | UpdateProperties | Updates the properties.

See Also

WebDAVHierarchyItem Class
Sitecore.Data.Items Namespace


AddVersion Method

[image]

Sitecore 6.4.1 API
WebDAVHierarchyItem..::..AddVersion Method
WebDAVHierarchyItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Item AddVersion(
    Item sitecoreItem
)
Visual Basic
Protected Function AddVersion ( _
    sitecoreItem As Item _
) As Item
Visual C++
protected:
Item^ AddVersion(
    Item^ sitecoreItem
)

Parameters

sitecoreItem
Type: Sitecore.Data.Items..::..Item
The Sitecore item.

Return Value

New item version.

See Also

WebDAVHierarchyItem Class
Sitecore.Data.Items Namespace


CanExecuteOperation Method

[image]

Sitecore 6.4.1 API
WebDAVHierarchyItem..::..CanExecuteOperation Method
WebDAVHierarchyItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool CanExecuteOperation(
    WebDAVOperation operation,
    params Object[] parameters
)
Visual Basic
Protected Overridable Function CanExecuteOperation ( _
    operation As WebDAVOperation, _
    ParamArray parameters As Object() _
) As Boolean
Visual C++
protected:
virtual bool CanExecuteOperation(
    WebDAVOperation operation,
    ... array<Object^>^ parameters
)

Parameters

operation
Type: Sitecore.Data.Items..::..WebDAVOperation
The operation.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.

Return Value

true operation is allowed to be executed; otherwise, false.

See Also

WebDAVHierarchyItem Class
Sitecore.Data.Items Namespace


CopyTo Method

[image]

Sitecore 6.4.1 API
WebDAVHierarchyItem..::..CopyTo Method
WebDAVHierarchyItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual WebDAVResponse CopyTo(
    IFolder folder,
    string destName,
    bool deep
)
Visual Basic
Public Overridable Function CopyTo ( _
    folder As IFolder, _
    destName As String, _
    deep As Boolean _
) As WebDAVResponse
Visual C++
public:
virtual WebDAVResponse^ CopyTo(
    IFolder^ folder,
    String^ destName,
    bool deep
)

Parameters

folder
Type: IFolder
The folder.
destName
Type: System..::..String
Name of the destination.
deep
Type: System..::..Boolean
if set to true all subtree will be copied.

Return Value

Web DAV response.

Implements

IHierarchyItemCopyTo(IFolder, String, Boolean)

See Also

WebDAVHierarchyItem Class
Sitecore.Data.Items Namespace


Delete Method

[image]

Sitecore 6.4.1 API
WebDAVHierarchyItem..::..Delete Method
WebDAVHierarchyItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual WebDAVResponse Delete()
Visual Basic
Public Overridable Function Delete As WebDAVResponse
Visual C++
public:
virtual WebDAVResponse^ Delete()

Return Value

Web DAV response.

Implements

IHierarchyItemDelete()()()()

See Also

WebDAVHierarchyItem Class
Sitecore.Data.Items Namespace


DoGetPropertyNames Method

[image]

Sitecore 6.4.1 API
WebDAVHierarchyItem..::..DoGetPropertyNames Method
WebDAVHierarchyItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual WebDAVResponse DoGetPropertyNames(
    ref Property[] props
)
Visual Basic
Protected Overridable Function DoGetPropertyNames ( _
    ByRef props As Property() _
) As WebDAVResponse
Visual C++
protected:
virtual WebDAVResponse^ DoGetPropertyNames(
    array<Property>^% props
)

Parameters

props
Type: array<Property>[]()[][]%
The properties.

Return Value

The WebDAVResponse.

See Also

WebDAVHierarchyItem Class
Sitecore.Data.Items Namespace


DoMoveTo Method

[image]

Sitecore 6.4.1 API
WebDAVHierarchyItem..::..DoMoveTo Method
WebDAVHierarchyItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual WebDAVResponse DoMoveTo(
    IFolder folder,
    string destName
)
Visual Basic
Protected Overridable Function DoMoveTo ( _
    folder As IFolder, _
    destName As String _
) As WebDAVResponse
Visual C++
protected:
virtual WebDAVResponse^ DoMoveTo(
    IFolder^ folder,
    String^ destName
)

Parameters

folder
Type: IFolder
The destination folder.
destName
Type: System..::..String
Name of the destination.

Return Value

The WebDAVResponse.

See Also

WebDAVHierarchyItem Class
Sitecore.Data.Items Namespace


DoMoveToItem Method

[image]

Sitecore 6.4.1 API
WebDAVHierarchyItem..::..DoMoveToItem Method
WebDAVHierarchyItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual WebDAVResponse DoMoveToItem(
    WebDAVFolder targetItem,
    string destName
)
Visual Basic
Protected Overridable Function DoMoveToItem ( _
    targetItem As WebDAVFolder, _
    destName As String _
) As WebDAVResponse
Visual C++
protected:
virtual WebDAVResponse^ DoMoveToItem(
    WebDAVFolder^ targetItem,
    String^ destName
)

Parameters

targetItem
Type: Sitecore.Data.Items..::..WebDAVFolder
The target item.
destName
Type: System..::..String
Destination path.

Return Value

The WebDAVResponse.

See Also

WebDAVHierarchyItem Class
Sitecore.Data.Items Namespace


DoUpdateProperties Method

[image]

Sitecore 6.4.1 API
WebDAVHierarchyItem..::..DoUpdateProperties Method
WebDAVHierarchyItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual WebDAVResponse DoUpdateProperties(
    Property[] setProps,
    Property[] delProps
)
Visual Basic
Protected Overridable Function DoUpdateProperties ( _
    setProps As Property(), _
    delProps As Property() _
) As WebDAVResponse
Visual C++
protected:
virtual WebDAVResponse^ DoUpdateProperties(
    array<Property>^ setProps,
    array<Property>^ delProps
)

Parameters

setProps
Type: array<Property>[]()[][]
The set props.
delProps
Type: array<Property>[]()[][]
The del props.

Return Value

The WebDAVResponse.

See Also

WebDAVHierarchyItem Class
Sitecore.Data.Items Namespace


ExtractItemName Method

[image]

Sitecore 6.4.1 API
WebDAVHierarchyItem..::..ExtractItemName Method
WebDAVHierarchyItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string ExtractItemName(
    string url
)
Visual Basic
Protected Overridable Function ExtractItemName ( _
    url As String _
) As String
Visual C++
protected:
virtual String^ ExtractItemName(
    String^ url
)

Parameters

url
Type: System..::..String
The incoming URL.

Return Value

The name of the item.

See Also

WebDAVHierarchyItem Class
Sitecore.Data.Items Namespace


FindLocksDown Method

[image]

Sitecore 6.4.1 API
WebDAVHierarchyItem..::..FindLocksDown Method
WebDAVHierarchyItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual MultistatusResponse FindLocksDown(
    WebDAVHierarchyItem root,
    bool skipShared
)
Visual Basic
Protected Overridable Function FindLocksDown ( _
    root As WebDAVHierarchyItem, _
    skipShared As Boolean _
) As MultistatusResponse
Visual C++
protected:
virtual MultistatusResponse^ FindLocksDown(
    WebDAVHierarchyItem^ root,
    bool skipShared
)

Parameters

root
Type: Sitecore.Data.Items..::..WebDAVHierarchyItem
The root to start looking for.
skipShared
Type: System..::..Boolean
if set to true shared locks will be skiped.

Return Value

Web DAV Multistatus response.

See Also

WebDAVHierarchyItem Class
Sitecore.Data.Items Namespace


GetFullContentPath Method

[image]

Sitecore 6.4.1 API
WebDAVHierarchyItem..::..GetFullContentPath Method
WebDAVHierarchyItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string GetFullContentPath()
Visual Basic
Protected Overridable Function GetFullContentPath As String
Visual C++
protected:
virtual String^ GetFullContentPath()

Return Value

The full content path.

See Also

WebDAVHierarchyItem Class
Sitecore.Data.Items Namespace


GetLocks Method

[image]

Sitecore 6.4.1 API
WebDAVHierarchyItem..::..GetLocks Method
WebDAVHierarchyItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual List<ExLockInfo> GetLocks(
    WebDAVHierarchyItem hierarchyItem,
    bool onlyDeep
)
Visual Basic
Protected Overridable Function GetLocks ( _
    hierarchyItem As WebDAVHierarchyItem, _
    onlyDeep As Boolean _
) As List(Of ExLockInfo)
Visual C++
protected:
virtual List<ExLockInfo^>^ GetLocks(
    WebDAVHierarchyItem^ hierarchyItem,
    bool onlyDeep
)

Parameters

hierarchyItem
Type: Sitecore.Data.Items..::..WebDAVHierarchyItem
The hierarchy item.
onlyDeep
Type: System..::..Boolean
if set to true only deep locks will be returned.

Return Value

List of item locks.

See Also

WebDAVHierarchyItem Class
Sitecore.Data.Items Namespace


GetMediaPath Method

[image]

Sitecore 6.4.1 API
WebDAVHierarchyItem..::..GetMediaPath Method
WebDAVHierarchyItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string GetMediaPath()
Visual Basic
Protected Overridable Function GetMediaPath As String
Visual C++
protected:
virtual String^ GetMediaPath()

Return Value

The Media path.

See Also

WebDAVHierarchyItem Class
Sitecore.Data.Items Namespace


GetProperties Method

[image]

Sitecore 6.4.1 API
WebDAVHierarchyItem..::..GetProperties Method
WebDAVHierarchyItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual WebDAVResponse GetProperties(
    ref Property[] props
)
Visual Basic
Public Overridable Function GetProperties ( _
    ByRef props As Property() _
) As WebDAVResponse
Visual C++
public:
virtual WebDAVResponse^ GetProperties(
    array<Property>^% props
)

Parameters

props
Type: array<Property>[]()[][]%
The properties.

Return Value

Web DAV Response.

Implements

IHierarchyItemGetProperties(array<Property>[]()[][]%)

See Also

WebDAVHierarchyItem Class
Sitecore.Data.Items Namespace


GetPropertyNames Method

[image]

Sitecore 6.4.1 API
WebDAVHierarchyItem..::..GetPropertyNames Method
WebDAVHierarchyItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual WebDAVResponse GetPropertyNames(
    ref Property[] props
)
Visual Basic
Public Overridable Function GetPropertyNames ( _
    ByRef props As Property() _
) As WebDAVResponse
Visual C++
public:
virtual WebDAVResponse^ GetPropertyNames(
    array<Property>^% props
)

Parameters

props
Type: array<Property>[]()[][]%
The properties.

Return Value

Web DAV response.

Implements

IHierarchyItemGetPropertyNames(array<Property>[]()[][]%)

See Also

WebDAVHierarchyItem Class
Sitecore.Data.Items Namespace


GetSitecoreItemLocks Method

[image]

Sitecore 6.4.1 API
WebDAVHierarchyItem..::..GetSitecoreItemLocks Method
WebDAVHierarchyItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual List<ExLockInfo> GetSitecoreItemLocks()
Visual Basic
Protected Overridable Function GetSitecoreItemLocks As List(Of ExLockInfo)
Visual C++
protected:
virtual List<ExLockInfo^>^ GetSitecoreItemLocks()

Return Value

List of Sitecore locks.

See Also

WebDAVHierarchyItem Class
Sitecore.Data.Items Namespace


GetUniqueID Method

[image]

Sitecore 6.4.1 API
WebDAVHierarchyItem..::..GetUniqueID Method
WebDAVHierarchyItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetUniqueID(
    string itemID,
    string databaseName,
    string languageName,
    string versionNumber
)
Visual Basic
Public Shared Function GetUniqueID ( _
    itemID As String, _
    databaseName As String, _
    languageName As String, _
    versionNumber As String _
) As String
Visual C++
public:
static String^ GetUniqueID(
    String^ itemID,
    String^ databaseName,
    String^ languageName,
    String^ versionNumber
)

Parameters

itemID
Type: System..::..String
The item ID.
databaseName
Type: System..::..String
Name of the database.
languageName
Type: System..::..String
Name of the language.
versionNumber
Type: System..::..String
The version number.

Return Value

The uniqueID.

See Also

WebDAVHierarchyItem Class
Sitecore.Data.Items Namespace


ItemHasLock Method

[image]

Sitecore 6.4.1 API
WebDAVHierarchyItem..::..ItemHasLock Method
WebDAVHierarchyItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool ItemHasLock(
    bool skipShared
)
Visual Basic
Protected Overridable Function ItemHasLock ( _
    skipShared As Boolean _
) As Boolean
Visual C++
protected:
virtual bool ItemHasLock(
    bool skipShared
)

Parameters

skipShared
Type: System..::..Boolean
if set to true shared locks will not be taken into consideration.

Return Value

true if current item has locks.

See Also

WebDAVHierarchyItem Class
Sitecore.Data.Items Namespace


Lock Method

[image] [image]

Sitecore 6.4.1 API
WebDAVHierarchyItem..::..Lock Method
WebDAVHierarchyItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Lock(LockInfo%) | Locks the specified lock info.
Protected method | Lock(ExLockInfo%) | Locks the specified lock info.

See Also

WebDAVHierarchyItem Class
WebDAVHierarchyItem Members
Sitecore.Data.Items Namespace


Lock Method ()

[image]

Sitecore 6.4.1 API
WebDAVHierarchyItem..::..Lock Method (%)
WebDAVHierarchyItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual WebDAVResponse Lock(
    ref LockInfo lockInfo
)
Visual Basic
Public Overridable Function Lock ( _
    ByRef lockInfo As LockInfo _
) As WebDAVResponse
Visual C++
public:
virtual WebDAVResponse^ Lock(
    LockInfo% lockInfo
)

Parameters

lockInfo
Type: LockInfo%
The lock info.

Return Value

Web DAV Response.

Implements

ILockLock(LockInfo%)

See Also

WebDAVHierarchyItem Class
Lock Overload
Sitecore.Data.Items Namespace


Lock Method (ExLockInfo)

[image]

Sitecore 6.4.1 API
WebDAVHierarchyItem..::..Lock Method (ExLockInfo%)
WebDAVHierarchyItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual WebDAVResponse Lock(
    ref ExLockInfo lockInfo
)
Visual Basic
Protected Overridable Function Lock ( _
    ByRef lockInfo As ExLockInfo _
) As WebDAVResponse
Visual C++
protected:
virtual WebDAVResponse^ Lock(
    ExLockInfo^% lockInfo
)

Parameters

lockInfo
Type: Sitecore.Data.Locking..::..ExLockInfo %
The lock info.

Return Value

Web DAV response.

See Also

WebDAVHierarchyItem Class
Lock Overload
Sitecore.Data.Items Namespace


LockSitecoreItem Method

[image]

Sitecore 6.4.1 API
WebDAVHierarchyItem..::..LockSitecoreItem Method
WebDAVHierarchyItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool LockSitecoreItem()
Visual Basic
Protected Overridable Function LockSitecoreItem As Boolean
Visual C++
protected:
virtual bool LockSitecoreItem()

Return Value

true if current item has been locked.

See Also

WebDAVHierarchyItem Class
Sitecore.Data.Items Namespace


MoveTo Method

[image]

Sitecore 6.4.1 API
WebDAVHierarchyItem..::..MoveTo Method
WebDAVHierarchyItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual WebDAVResponse MoveTo(
    IFolder folder,
    string destName
)
Visual Basic
Public Overridable Function MoveTo ( _
    folder As IFolder, _
    destName As String _
) As WebDAVResponse
Visual C++
public:
virtual WebDAVResponse^ MoveTo(
    IFolder^ folder,
    String^ destName
)

Parameters

folder
Type: IFolder
The folder.
destName
Type: System..::..String
Name of the destination.

Return Value

Web DAV response.

Implements

IHierarchyItemMoveTo(IFolder, String)

See Also

WebDAVHierarchyItem Class
Sitecore.Data.Items Namespace


RefreshLock Method

[image]

Sitecore 6.4.1 API
WebDAVHierarchyItem..::..RefreshLock Method
WebDAVHierarchyItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WebDAVResponse RefreshLock(
    ref LockInfo lockInfo
)
Visual Basic
Public Function RefreshLock ( _
    ByRef lockInfo As LockInfo _
) As WebDAVResponse
Visual C++
public:
virtual WebDAVResponse^ RefreshLock(
    LockInfo% lockInfo
) sealed

Parameters

lockInfo
Type: LockInfo%
The lock info.

Return Value

Web DAV Response.

Implements

ILockRefreshLock(LockInfo%)

See Also

WebDAVHierarchyItem Class
Sitecore.Data.Items Namespace


Unlock Method

[image]

Sitecore 6.4.1 API
WebDAVHierarchyItem..::..Unlock Method
WebDAVHierarchyItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WebDAVResponse Unlock(
    string lockToken
)
Visual Basic
Public Function Unlock ( _
    lockToken As String _
) As WebDAVResponse
Visual C++
public:
virtual WebDAVResponse^ Unlock(
    String^ lockToken
) sealed

Parameters

lockToken
Type: System..::..String
The lock token.

Return Value

Web DAV Response.

Implements

ILockUnlock(String)

See Also

WebDAVHierarchyItem Class
Sitecore.Data.Items Namespace


UnlockSitecoreItem Method

[image]

Sitecore 6.4.1 API
WebDAVHierarchyItem..::..UnlockSitecoreItem Method
WebDAVHierarchyItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool UnlockSitecoreItem()
Visual Basic
Protected Overridable Function UnlockSitecoreItem As Boolean
Visual C++
protected:
virtual bool UnlockSitecoreItem()

Return Value

true if current item has been unlocked.

See Also

WebDAVHierarchyItem Class
Sitecore.Data.Items Namespace


UpdateProperties Method

[image]

Sitecore 6.4.1 API
WebDAVHierarchyItem..::..UpdateProperties Method
WebDAVHierarchyItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual WebDAVResponse UpdateProperties(
    Property[] setProps,
    Property[] delProps
)
Visual Basic
Public Overridable Function UpdateProperties ( _
    setProps As Property(), _
    delProps As Property() _
) As WebDAVResponse
Visual C++
public:
virtual WebDAVResponse^ UpdateProperties(
    array<Property>^ setProps,
    array<Property>^ delProps
)

Parameters

setProps
Type: array<Property>[]()[][]
The properties to be setted.
delProps
Type: array<Property>[]()[][]
The properties to be deleted.

Return Value

Web DAV response.

Implements

IHierarchyItemUpdateProperties(array<Property>[]()[][], array<Property>[]()[][])

See Also

WebDAVHierarchyItem Class
Sitecore.Data.Items Namespace


WebDAVHierarchyItem Properties

[image] [image]

Sitecore 6.4.1 API
WebDAVHierarchyItem Properties
WebDAVHierarchyItem Class See Also Send Feedback

The WebDAVHierarchyItem type exposes the following members.

Properties

 | Name | Description
Public property | ActiveLocks | Gets the active locks.
Protected property | ClientHasToken | Gets a value indicating whether client has lock tokens.
Public property | Created | Gets the created date.
Protected property | Engine | Gets the engine.
Protected property | InnerItem | Gets or sets the inner item.
Public property | Modified | Gets the modified date.
Public property | Name | Gets the item name.
Public property | Parent | Gets the parent.
Public property | Path | Gets the item path.
Public property | UniqueID | Gets the unique ID.
Protected property | View | Gets the Web DAV view.

See Also

WebDAVHierarchyItem Class
Sitecore.Data.Items Namespace


ActiveLocks Property

[image]

Sitecore 6.4.1 API
WebDAVHierarchyItem..::..ActiveLocks Property
WebDAVHierarchyItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LockInfo[] ActiveLocks { get; }
Visual Basic
Public ReadOnly Property ActiveLocks As LockInfo()
    Get
Visual C++
public:
virtual property array<LockInfo>^ ActiveLocks {
    array<LockInfo>^ get () sealed;
}

Field Value

The active locks.

Implements

ILockActiveLocks()()()()

See Also

WebDAVHierarchyItem Class
Sitecore.Data.Items Namespace


ClientHasToken Property

[image]

Sitecore 6.4.1 API
WebDAVHierarchyItem..::..ClientHasToken Property
WebDAVHierarchyItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected internal bool ClientHasToken { get; }
Visual Basic
Protected Friend ReadOnly Property ClientHasToken As Boolean
    Get
Visual C++
protected public:
property bool ClientHasToken {
    bool get ();
}

Field Value

true if client has lock tokens; otherwise, false.

See Also

WebDAVHierarchyItem Class
Sitecore.Data.Items Namespace


Created Property

[image]

Sitecore 6.4.1 API
WebDAVHierarchyItem..::..Created Property
WebDAVHierarchyItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual DateTime Created { get; }
Visual Basic
Public Overridable ReadOnly Property Created As DateTime
    Get
Visual C++
public:
virtual property DateTime Created {
    DateTime get ();
}

Field Value

The created date.

Implements

IHierarchyItemCreated()()()()

See Also

WebDAVHierarchyItem Class
Sitecore.Data.Items Namespace


Engine Property

[image]

Sitecore 6.4.1 API
WebDAVHierarchyItem..::..Engine Property
WebDAVHierarchyItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected internal virtual WebDAVEngine Engine { get; }
Visual Basic
Protected Friend Overridable ReadOnly Property Engine As WebDAVEngine
    Get
Visual C++
protected public:
virtual property WebDAVEngine^ Engine {
    WebDAVEngine^ get ();
}

Field Value

The engine.

See Also

WebDAVHierarchyItem Class
Sitecore.Data.Items Namespace


InnerItem Property

[image]

Sitecore 6.4.1 API
WebDAVHierarchyItem..::..InnerItem Property
WebDAVHierarchyItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected internal virtual Item InnerItem { get; set; }
Visual Basic
Protected Friend Overridable Property InnerItem As Item
    Get
    Set
Visual C++
protected public:
virtual property Item^ InnerItem {
    Item^ get ();
    void set (Item^ value);
}

Field Value

The inner item.

See Also

WebDAVHierarchyItem Class
Sitecore.Data.Items Namespace


Modified Property

[image]

Sitecore 6.4.1 API
WebDAVHierarchyItem..::..Modified Property
WebDAVHierarchyItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual DateTime Modified { get; }
Visual Basic
Public Overridable ReadOnly Property Modified As DateTime
    Get
Visual C++
public:
virtual property DateTime Modified {
    DateTime get ();
}

Field Value

The modified date.

Implements

IHierarchyItemModified()()()()

See Also

WebDAVHierarchyItem Class
Sitecore.Data.Items Namespace


Name Property

[image]

Sitecore 6.4.1 API
WebDAVHierarchyItem..::..Name Property
WebDAVHierarchyItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string Name { get; }
Visual Basic
Public Overridable ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get ();
}

Field Value

The item name.

Implements

IHierarchyItemName()()()()

See Also

WebDAVHierarchyItem Class
Sitecore.Data.Items Namespace


Path Property

[image]

Sitecore 6.4.1 API
WebDAVHierarchyItem..::..Path Property
WebDAVHierarchyItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string Path { get; }
Visual Basic
Public Overridable ReadOnly Property Path As String
    Get
Visual C++
public:
virtual property String^ Path {
    String^ get ();
}

Field Value

The item path.

Implements

IHierarchyItemPath()()()()

See Also

WebDAVHierarchyItem Class
Sitecore.Data.Items Namespace


UniqueID Property

[image]

Sitecore 6.4.1 API
WebDAVHierarchyItem..::..UniqueID Property
WebDAVHierarchyItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string UniqueID { get; }
Visual Basic
Public Overridable ReadOnly Property UniqueID As String
    Get
Visual C++
public:
virtual property String^ UniqueID {
    String^ get ();
}

Field Value

The unique ID.

See Also

WebDAVHierarchyItem Class
Sitecore.Data.Items Namespace


View Property

[image]

Sitecore 6.4.1 API
WebDAVHierarchyItem..::..View Property
WebDAVHierarchyItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected internal virtual WebDAVView View { get; }
Visual Basic
Protected Friend Overridable ReadOnly Property View As WebDAVView
    Get
Visual C++
protected public:
virtual property WebDAVView^ View {
    WebDAVView^ get ();
}

Field Value

The Web DAV view.

See Also

WebDAVHierarchyItem Class
Sitecore.Data.Items Namespace


WebDAVItemUtil Class

[image]

Sitecore 6.4.1 API
WebDAVItemUtil Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class WebDAVItemUtil
Visual Basic
Public NotInheritable Class WebDAVItemUtil
Visual C++
public ref class WebDAVItemUtil abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..WebDAVItemUtil

See Also

WebDAVItemUtil Members
Sitecore.Data.Items Namespace


WebDAVItemUtil Members

[image] [image]

Sitecore 6.4.1 API
WebDAVItemUtil Members
WebDAVItemUtil Class Methods See Also Send Feedback

The WebDAVItemUtil type exposes the following members.

Methods

Name | Description
IsMediaItem | Determines whether the items is media item or not.
IsVersioned | Determines whether this media item is versioned.

See Also

WebDAVItemUtil Class
Sitecore.Data.Items Namespace


IsMediaItem Method

[image]

Sitecore 6.4.1 API
WebDAVItemUtil..::..IsMediaItem Method
WebDAVItemUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsMediaItem(
    Item item,
    string dataFieldName
)
Visual Basic
Public Shared Function IsMediaItem ( _
    item As Item, _
    dataFieldName As String _
) As Boolean
Visual C++
public:
static bool IsMediaItem(
    Item^ item,
    String^ dataFieldName
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item.
dataFieldName
Type: System..::..String
Name of the data field.

Return Value

true if the specified item is media item; otherwise, false.

See Also

WebDAVItemUtil Class
Sitecore.Data.Items Namespace


IsVersioned Method

[image]

Sitecore 6.4.1 API
WebDAVItemUtil..::..IsVersioned Method
WebDAVItemUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsVersioned(
    Item item
)
Visual Basic
Public Shared Function IsVersioned ( _
    item As Item _
) As Boolean
Visual C++
public:
static bool IsVersioned(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item.

Return Value

true if media item is versioned; otherwise, false.

See Also

WebDAVItemUtil Class
Sitecore.Data.Items Namespace


WebDAVLanguageFolder Class

[image]

Sitecore 6.4.1 API
WebDAVLanguageFolder Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class WebDAVLanguageFolder : WebDAVFolder
Visual Basic
Public Class WebDAVLanguageFolder _
    Inherits WebDAVFolder
Visual C++
public ref class WebDAVLanguageFolder : public WebDAVFolder

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..WebDAVHierarchyItem
Sitecore.Data.Items..::..WebDAVFolder
Sitecore.Data.Items..::..WebDAVLanguageFolder

See Also

WebDAVLanguageFolder Members
Sitecore.Data.Items Namespace


WebDAVLanguageFolder Members

[image] [image]

Sitecore 6.4.1 API
WebDAVLanguageFolder Members
WebDAVLanguageFolder Class Constructors Methods Properties See Also Send Feedback

The WebDAVLanguageFolder type exposes the following members.

Constructors

 | Name | Description
Public method | WebDAVLanguageFolder | Initializes a new instance of the WebDAVLanguageFolder class.

Methods

 | Name | Description
Protected method | AddVersion | Adds the version to the item. (Inherited from WebDAVHierarchyItem.)
Protected method | CanExecuteOperation | Validates the operation. (Inherited from WebDAVHierarchyItem.)
Public method | CopyTo | Copies to. (Inherited from WebDAVHierarchyItem.)
Public method | CreateFolder | Creates the folder. (Inherited from WebDAVFolder.)
Public method | CreateLockNull | Creates the lock null item. (Inherited from WebDAVFolder.)
Public method | CreateResource | Creates the resource. (Inherited from WebDAVFolder.)
Public method | Delete | Deletes current item. (Inherited from WebDAVHierarchyItem.)
Protected method | DoCopyTo | Executes the copy to event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoCreateFolder | Executes the create folder operation. (Overrides WebDAVFolder..::..DoCreateFolder(String).)
Protected method | DoCreateLockNull | Executes the create lock null event. (Overrides WebDAVFolder..::..DoCreateLockNull(String, LockInfo%).)
Protected method | DoCreateResource | Executes the create resource command. (Overrides WebDAVFolder..::..DoCreateResource(String, Stream, String).)
Protected method | DoDelete | Executes the delete event. (Overrides WebDAVHierarchyItem..::..DoDelete()()()().)
Protected method | DoGetProperties | Executes the get properties event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoGetPropertyNames | Executes the get property names event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoMoveTo | Executes the move to operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoMoveToItem | Executes the move item operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoRename | Executes the rename operation. (Overrides WebDAVHierarchyItem..::..DoRename(WebDAVFolder, String).)
Protected method | DoUpdateProperties | Executes the update properties event. (Inherited from WebDAVHierarchyItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExtractItemName | Extracts the name of the item. (Inherited from WebDAVHierarchyItem.)
Protected method | ExtractMediaItemPath | Extracts the path of the media item. (Inherited from WebDAVHierarchyItem.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindLocksDown | Finds the locks down. (Inherited from WebDAVHierarchyItem.)
Protected method | GetFullContentPath | Gets the full content path. (Inherited from WebDAVHierarchyItem.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLatestVersionNumber | Gets the latest version number.
Protected method | GetLocks | Gets the locks for the specified hierarchy item. (Inherited from WebDAVHierarchyItem.)
Protected method | GetMediaPath | Gets the media path. (Inherited from WebDAVHierarchyItem.)
Public method | GetProperties | Gets the properties. (Inherited from WebDAVHierarchyItem.)
Public method | GetPropertyNames | Gets the property names. (Inherited from WebDAVHierarchyItem.)
Protected method | GetSitecoreItemLocks | Gets the sitecore item locks. (Inherited from WebDAVHierarchyItem.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValidFolderName | Gets the name of the valid folder. (Inherited from WebDAVFolder.)
Protected method | ItemHasLock | The Item has the lock. (Inherited from WebDAVHierarchyItem.)
Public method | Lock(LockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)
Protected method | Lock(ExLockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)
Protected method | LockSitecoreItem | Locks the sitecore item. (Inherited from WebDAVHierarchyItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveTo | Moves to destination folder. (Inherited from WebDAVHierarchyItem.)
Public method | RefreshLock | Refreshes the lock. (Inherited from WebDAVHierarchyItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unlock | Unlocks the specified lock token. (Inherited from WebDAVHierarchyItem.)
Protected method | UnlockSitecoreItem | Unlocks the sitecore item. (Inherited from WebDAVHierarchyItem.)
Public method | UpdateProperties | Updates the properties. (Inherited from WebDAVHierarchyItem.)

Properties

 | Name | Description
Public property | ActiveLocks | Gets the active locks. (Inherited from WebDAVHierarchyItem.)
Public property | Children | Gets the children. (Overrides WebDAVFolder..::..Children.)
Protected property | ClientHasToken | Gets a value indicating whether client has lock tokens. (Inherited from WebDAVHierarchyItem.)
Public property | Created | Gets the created date. (Inherited from WebDAVHierarchyItem.)
Protected property | Engine | Gets the engine. (Inherited from WebDAVHierarchyItem.)
Protected property | InnerItem | Gets or sets the inner item. (Inherited from WebDAVHierarchyItem.)
Public property | Modified | Gets the modified date. (Inherited from WebDAVHierarchyItem.)
Public property | Name | Gets the item name. (Overrides WebDAVHierarchyItem..::..Name.)
Public property | Parent | Gets the parent. (Overrides WebDAVHierarchyItem..::..Parent.)
Public property | Path | Gets the item path. (Overrides WebDAVHierarchyItem..::..Path.)
Public property | UniqueID | Gets the unique ID. (Overrides WebDAVHierarchyItem..::..UniqueID.)
Protected property | View | Gets the Web DAV view. (Inherited from WebDAVHierarchyItem.)

See Also

WebDAVLanguageFolder Class
Sitecore.Data.Items Namespace


WebDAVLanguageFolder Constructor

[image]

Sitecore 6.4.1 API
WebDAVLanguageFolder Constructor
WebDAVLanguageFolder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WebDAVLanguageFolder(
    Item item,
    WebDAVView view,
    WebDAVEngine engine
)
Visual Basic
Public Sub New ( _
    item As Item, _
    view As WebDAVView, _
    engine As WebDAVEngine _
)
Visual C++
public:
WebDAVLanguageFolder(
    Item^ item,
    WebDAVView^ view,
    WebDAVEngine^ engine
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item.
view
Type: Sitecore.Data.Views..::..WebDAVView
The Web DAV view.
engine
Type: Sitecore.Web..::..WebDAVEngine
The Web DAV engine.

See Also

WebDAVLanguageFolder Class
Sitecore.Data.Items Namespace


WebDAVLanguageFolder Methods

[image] [image]

Sitecore 6.4.1 API
WebDAVLanguageFolder Methods
WebDAVLanguageFolder Class See Also Send Feedback

The WebDAVLanguageFolder type exposes the following members.

Methods

 | Name | Description
Protected method | AddVersion | Adds the version to the item. (Inherited from WebDAVHierarchyItem.)
Protected method | CanExecuteOperation | Validates the operation. (Inherited from WebDAVHierarchyItem.)
Public method | CopyTo | Copies to. (Inherited from WebDAVHierarchyItem.)
Public method | CreateFolder | Creates the folder. (Inherited from WebDAVFolder.)
Public method | CreateLockNull | Creates the lock null item. (Inherited from WebDAVFolder.)
Public method | CreateResource | Creates the resource. (Inherited from WebDAVFolder.)
Public method | Delete | Deletes current item. (Inherited from WebDAVHierarchyItem.)
Protected method | DoCopyTo | Executes the copy to event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoCreateFolder | Executes the create folder operation. (Overrides WebDAVFolder..::..DoCreateFolder(String).)
Protected method | DoCreateLockNull | Executes the create lock null event. (Overrides WebDAVFolder..::..DoCreateLockNull(String, LockInfo%).)
Protected method | DoCreateResource | Executes the create resource command. (Overrides WebDAVFolder..::..DoCreateResource(String, Stream, String).)
Protected method | DoDelete | Executes the delete event. (Overrides WebDAVHierarchyItem..::..DoDelete()()()().)
Protected method | DoGetProperties | Executes the get properties event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoGetPropertyNames | Executes the get property names event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoMoveTo | Executes the move to operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoMoveToItem | Executes the move item operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoRename | Executes the rename operation. (Overrides WebDAVHierarchyItem..::..DoRename(WebDAVFolder, String).)
Protected method | DoUpdateProperties | Executes the update properties event. (Inherited from WebDAVHierarchyItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExtractItemName | Extracts the name of the item. (Inherited from WebDAVHierarchyItem.)
Protected method | ExtractMediaItemPath | Extracts the path of the media item. (Inherited from WebDAVHierarchyItem.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindLocksDown | Finds the locks down. (Inherited from WebDAVHierarchyItem.)
Protected method | GetFullContentPath | Gets the full content path. (Inherited from WebDAVHierarchyItem.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLatestVersionNumber | Gets the latest version number.
Protected method | GetLocks | Gets the locks for the specified hierarchy item. (Inherited from WebDAVHierarchyItem.)
Protected method | GetMediaPath | Gets the media path. (Inherited from WebDAVHierarchyItem.)
Public method | GetProperties | Gets the properties. (Inherited from WebDAVHierarchyItem.)
Public method | GetPropertyNames | Gets the property names. (Inherited from WebDAVHierarchyItem.)
Protected method | GetSitecoreItemLocks | Gets the sitecore item locks. (Inherited from WebDAVHierarchyItem.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValidFolderName | Gets the name of the valid folder. (Inherited from WebDAVFolder.)
Protected method | ItemHasLock | The Item has the lock. (Inherited from WebDAVHierarchyItem.)
Public method | Lock(LockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)
Protected method | Lock(ExLockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)
Protected method | LockSitecoreItem | Locks the sitecore item. (Inherited from WebDAVHierarchyItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveTo | Moves to destination folder. (Inherited from WebDAVHierarchyItem.)
Public method | RefreshLock | Refreshes the lock. (Inherited from WebDAVHierarchyItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unlock | Unlocks the specified lock token. (Inherited from WebDAVHierarchyItem.)
Protected method | UnlockSitecoreItem | Unlocks the sitecore item. (Inherited from WebDAVHierarchyItem.)
Public method | UpdateProperties | Updates the properties. (Inherited from WebDAVHierarchyItem.)

See Also

WebDAVLanguageFolder Class
Sitecore.Data.Items Namespace


DoCreateFolder Method

[image]

Sitecore 6.4.1 API
WebDAVLanguageFolder..::..DoCreateFolder Method
WebDAVLanguageFolder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override WebDAVResponse DoCreateFolder(
    string name
)
Visual Basic
Protected Overrides Function DoCreateFolder ( _
    name As String _
) As WebDAVResponse
Visual C++
protected:
virtual WebDAVResponse^ DoCreateFolder(
    String^ name
) override

Parameters

name
Type: System..::..String
The folder name.

Return Value

The WebDAVResponse.

See Also

WebDAVLanguageFolder Class
Sitecore.Data.Items Namespace


DoCreateResource Method

[image]

Sitecore 6.4.1 API
WebDAVLanguageFolder..::..DoCreateResource Method
WebDAVLanguageFolder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override WebDAVResponse DoCreateResource(
    string name,
    Stream content,
    string contentType
)
Visual Basic
Protected Overrides Function DoCreateResource ( _
    name As String, _
    content As Stream, _
    contentType As String _
) As WebDAVResponse
Visual C++
protected:
virtual WebDAVResponse^ DoCreateResource(
    String^ name,
    Stream^ content,
    String^ contentType
) override

Parameters

name
Type: System..::..String
The Resource name.
content
Type: System.IO..::..Stream
The content.
contentType
Type: System..::..String
Type of the content.

Return Value

The WebDAVResponse.

See Also

WebDAVLanguageFolder Class
Sitecore.Data.Items Namespace


DoDelete Method

[image]

Sitecore 6.4.1 API
WebDAVLanguageFolder..::..DoDelete Method
WebDAVLanguageFolder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override WebDAVResponse DoDelete()
Visual Basic
Protected Overrides Function DoDelete As WebDAVResponse
Visual C++
protected:
virtual WebDAVResponse^ DoDelete() override

Return Value

The WebDAVResponse.

See Also

WebDAVLanguageFolder Class
Sitecore.Data.Items Namespace


DoRename Method

[image]

Sitecore 6.4.1 API
WebDAVLanguageFolder..::..DoRename Method
WebDAVLanguageFolder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override WebDAVResponse DoRename(
    WebDAVFolder parent,
    string destName
)
Visual Basic
Protected Overrides Function DoRename ( _
    parent As WebDAVFolder, _
    destName As String _
) As WebDAVResponse
Visual C++
protected:
virtual WebDAVResponse^ DoRename(
    WebDAVFolder^ parent,
    String^ destName
) override

Parameters

parent
Type: Sitecore.Data.Items..::..WebDAVFolder
The item parent.
destName
Type: System..::..String
Destination path.

Return Value

The WebDAVResponse.

See Also

WebDAVLanguageFolder Class
Sitecore.Data.Items Namespace


GetLatestVersionNumber Method

[image]

Sitecore 6.4.1 API
WebDAVLanguageFolder..::..GetLatestVersionNumber Method
WebDAVLanguageFolder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual int GetLatestVersionNumber()
Visual Basic
Protected Overridable Function GetLatestVersionNumber As Integer
Visual C++
protected:
virtual int GetLatestVersionNumber()

Return Value

The latest version number.

See Also

WebDAVLanguageFolder Class
Sitecore.Data.Items Namespace


Lock Method

[image] [image]

Sitecore 6.4.1 API
WebDAVLanguageFolder..::..Lock Method
WebDAVLanguageFolder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Lock(LockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)
Protected method | Lock(ExLockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)

See Also

WebDAVLanguageFolder Class
WebDAVLanguageFolder Members
Sitecore.Data.Items Namespace


Children Property

[image]

Sitecore 6.4.1 API
WebDAVLanguageFolder..::..Children Property
WebDAVLanguageFolder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override IHierarchyItem[] Children { get; }
Visual Basic
Public Overrides ReadOnly Property Children As IHierarchyItem()
    Get
Visual C++
public:
virtual property array<IHierarchyItem^>^ Children {
    array<IHierarchyItem^>^ get () override;
}

Field Value

The children.

Implements

IFolderChildren()()()()

Exceptions

Exception | Condition
System..::..Exception | Cannot get the children for the folder.

See Also

WebDAVLanguageFolder Class
Sitecore.Data.Items Namespace


Name Property

[image]

Sitecore 6.4.1 API
WebDAVLanguageFolder..::..Name Property
WebDAVLanguageFolder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The item name.

Implements

IHierarchyItemName()()()()

See Also

WebDAVLanguageFolder Class
Sitecore.Data.Items Namespace


Parent Property

[image]

Sitecore 6.4.1 API
WebDAVLanguageFolder..::..Parent Property
WebDAVLanguageFolder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override IFolder Parent { get; }
Visual Basic
Public Overrides ReadOnly Property Parent As IFolder
    Get
Visual C++
public:
virtual property IFolder^ Parent {
    IFolder^ get () override;
}

Field Value

The parent.

Implements

IHierarchyItemParent()()()()

See Also

WebDAVLanguageFolder Class
Sitecore.Data.Items Namespace


Path Property

[image]

Sitecore 6.4.1 API
WebDAVLanguageFolder..::..Path Property
WebDAVLanguageFolder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Path { get; }
Visual Basic
Public Overrides ReadOnly Property Path As String
    Get
Visual C++
public:
virtual property String^ Path {
    String^ get () override;
}

Field Value

The item path.

Implements

IHierarchyItemPath()()()()

See Also

WebDAVLanguageFolder Class
Sitecore.Data.Items Namespace


UniqueID Property

[image]

Sitecore 6.4.1 API
WebDAVLanguageFolder..::..UniqueID Property
WebDAVLanguageFolder Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string UniqueID { get; }
Visual Basic
Public Overrides ReadOnly Property UniqueID As String
    Get
Visual C++
public:
virtual property String^ UniqueID {
    String^ get () override;
}

Field Value

The unique ID.

See Also

WebDAVLanguageFolder Class
Sitecore.Data.Items Namespace


WebDAVLockNullItem Class

[image]

Sitecore 6.4.1 API
WebDAVLockNullItem Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class WebDAVLockNullItem : WebDAVHierarchyItem,
    ILockNull, IHierarchyItem, ILock
Visual Basic
Public Class WebDAVLockNullItem _
    Inherits WebDAVHierarchyItem _
    Implements ILockNull, IHierarchyItem, ILock
Visual C++
public ref class WebDAVLockNullItem : public WebDAVHierarchyItem,
    ILockNull, IHierarchyItem, ILock

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..WebDAVHierarchyItem
Sitecore.Data.Items..::..WebDAVLockNullItem
Sitecore.Data.Items..::..WebDAVLockNullSingleVersion

See Also

WebDAVLockNullItem Members
Sitecore.Data.Items Namespace


WebDAVLockNullItem Members

[image] [image]

Sitecore 6.4.1 API
WebDAVLockNullItem Members
WebDAVLockNullItem Class Constructors Methods Properties See Also Send Feedback

The WebDAVLockNullItem type exposes the following members.

Constructors

 | Name | Description
Public method | WebDAVLockNullItem | Initializes a new instance of the WebDAVLockNullItem class.

Methods

 | Name | Description
Protected method | AddVersion | Adds the version to the item. (Inherited from WebDAVHierarchyItem.)
Protected method | CanExecuteOperation | Validates the operation. (Inherited from WebDAVHierarchyItem.)
Public method | ConvertToFolder | Converts the LockNull item to folder.
Public method | ConvertToResource | Converts LockNull item to resource.
Public method | CopyTo | Copies to. (Overrides WebDAVHierarchyItem..::..CopyTo(IFolder, String, Boolean).)
Public method | Delete | Deletes current item. (Overrides WebDAVHierarchyItem..::..Delete()()()().)
Protected method | DoCopyTo | Executes the copy to event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoDelete | Executes the delete event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoGetProperties | Executes the get properties event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoGetPropertyNames | Executes the get property names event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoMoveTo | Executes the move to operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoMoveToItem | Executes the move item operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoRename | Executes the rename operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoUpdateProperties | Executes the update properties event. (Inherited from WebDAVHierarchyItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExtractItemName | Extracts the name of the item. (Inherited from WebDAVHierarchyItem.)
Protected method | ExtractMediaItemPath | Extracts the path of the media item. (Inherited from WebDAVHierarchyItem.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindLocksDown | Finds the locks down. (Inherited from WebDAVHierarchyItem.)
Protected method | GetDatabase | Gets the database.
Protected method | GetFullContentPath | Gets the full content path. (Inherited from WebDAVHierarchyItem.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetItemName | Gets the name of the item.
Protected method | GetLocks | Gets the locks for the specified hierarchy item. (Inherited from WebDAVHierarchyItem.)
Protected method | GetMediaPath | Gets the media path. (Overrides WebDAVHierarchyItem..::..GetMediaPath()()()().)
Protected method | GetParentItem | Gets the parent item.
Protected method | GetParentPath | Gets the parent path.
Public method | GetProperties | Gets the properties. (Overrides WebDAVHierarchyItem..::..GetProperties(array<Property>[]()[][]%).)
Public method | GetPropertyNames | Gets the property names. (Overrides WebDAVHierarchyItem..::..GetPropertyNames(array<Property>[]()[][]%).)
Protected method | GetSitecoreItemLocks | Gets the sitecore item locks. (Inherited from WebDAVHierarchyItem.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ItemHasLock | The Item has the lock. (Inherited from WebDAVHierarchyItem.)
Public method | Lock(LockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)
Protected method | Lock(ExLockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)
Protected method | LockSitecoreItem | Locks the sitecore item. (Inherited from WebDAVHierarchyItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveTo | Moves to destination folder. (Overrides WebDAVHierarchyItem..::..MoveTo(IFolder, String).)
Public method | RefreshLock | Refreshes the lock. (Inherited from WebDAVHierarchyItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unlock | Unlocks the specified lock token. (Inherited from WebDAVHierarchyItem.)
Protected method | UnlockSitecoreItem | Unlocks the sitecore item. (Inherited from WebDAVHierarchyItem.)
Public method | UpdateProperties | Updates the properties. (Overrides WebDAVHierarchyItem..::..UpdateProperties(array<Property>[]()[][], array<Property>[]()[][]).)

Properties

 | Name | Description
Public property | ActiveLocks | Gets the active locks. (Inherited from WebDAVHierarchyItem.)
Protected property | ClientHasToken | Gets a value indicating whether client has lock tokens. (Inherited from WebDAVHierarchyItem.)
Public property | Created | Gets the created date. (Overrides WebDAVHierarchyItem..::..Created.)
Protected property | Engine | Gets the engine. (Inherited from WebDAVHierarchyItem.)
Protected property | InnerItem | Gets the Sitecore item. (Overrides WebDAVHierarchyItem..::..InnerItem.)
Public property | ItemUri | Gets the item URI.
Public property | Modified | Gets the modified date. (Overrides WebDAVHierarchyItem..::..Modified.)
Public property | Name | Gets the item name. (Inherited from WebDAVHierarchyItem.)
Public property | Parent | Gets the parent. (Overrides WebDAVHierarchyItem..::..Parent.)
Public property | Path | Gets the item path. (Overrides WebDAVHierarchyItem..::..Path.)
Public property | UniqueID | Gets the unique ID. (Inherited from WebDAVHierarchyItem.)
Protected property | View | Gets the Web DAV view. (Inherited from WebDAVHierarchyItem.)

See Also

WebDAVLockNullItem Class
Sitecore.Data.Items Namespace


WebDAVLockNullItem Constructor

[image]

Sitecore 6.4.1 API
WebDAVLockNullItem Constructor
WebDAVLockNullItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WebDAVLockNullItem(
    ItemUri uri,
    WebDAVView view,
    WebDAVEngine engine
)
Visual Basic
Public Sub New ( _
    uri As ItemUri, _
    view As WebDAVView, _
    engine As WebDAVEngine _
)
Visual C++
public:
WebDAVLockNullItem(
    ItemUri^ uri,
    WebDAVView^ view,
    WebDAVEngine^ engine
)

Parameters

uri
Type: Sitecore.Data..::..ItemUri
The LockNull URI.
view
Type: Sitecore.Data.Views..::..WebDAVView
The Web DAV view.
engine
Type: Sitecore.Web..::..WebDAVEngine
The Web DAV engine.

See Also

WebDAVLockNullItem Class
Sitecore.Data.Items Namespace


WebDAVLockNullItem Methods

[image] [image]

Sitecore 6.4.1 API
WebDAVLockNullItem Methods
WebDAVLockNullItem Class See Also Send Feedback

The WebDAVLockNullItem type exposes the following members.

Methods

 | Name | Description
Protected method | AddVersion | Adds the version to the item. (Inherited from WebDAVHierarchyItem.)
Protected method | CanExecuteOperation | Validates the operation. (Inherited from WebDAVHierarchyItem.)
Public method | ConvertToFolder | Converts the LockNull item to folder.
Public method | ConvertToResource | Converts LockNull item to resource.
Public method | CopyTo | Copies to. (Overrides WebDAVHierarchyItem..::..CopyTo(IFolder, String, Boolean).)
Public method | Delete | Deletes current item. (Overrides WebDAVHierarchyItem..::..Delete()()()().)
Protected method | DoCopyTo | Executes the copy to event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoDelete | Executes the delete event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoGetProperties | Executes the get properties event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoGetPropertyNames | Executes the get property names event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoMoveTo | Executes the move to operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoMoveToItem | Executes the move item operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoRename | Executes the rename operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoUpdateProperties | Executes the update properties event. (Inherited from WebDAVHierarchyItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExtractItemName | Extracts the name of the item. (Inherited from WebDAVHierarchyItem.)
Protected method | ExtractMediaItemPath | Extracts the path of the media item. (Inherited from WebDAVHierarchyItem.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindLocksDown | Finds the locks down. (Inherited from WebDAVHierarchyItem.)
Protected method | GetDatabase | Gets the database.
Protected method | GetFullContentPath | Gets the full content path. (Inherited from WebDAVHierarchyItem.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetItemName | Gets the name of the item.
Protected method | GetLocks | Gets the locks for the specified hierarchy item. (Inherited from WebDAVHierarchyItem.)
Protected method | GetMediaPath | Gets the media path. (Overrides WebDAVHierarchyItem..::..GetMediaPath()()()().)
Protected method | GetParentItem | Gets the parent item.
Protected method | GetParentPath | Gets the parent path.
Public method | GetProperties | Gets the properties. (Overrides WebDAVHierarchyItem..::..GetProperties(array<Property>[]()[][]%).)
Public method | GetPropertyNames | Gets the property names. (Overrides WebDAVHierarchyItem..::..GetPropertyNames(array<Property>[]()[][]%).)
Protected method | GetSitecoreItemLocks | Gets the sitecore item locks. (Inherited from WebDAVHierarchyItem.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ItemHasLock | The Item has the lock. (Inherited from WebDAVHierarchyItem.)
Public method | Lock(LockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)
Protected method | Lock(ExLockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)
Protected method | LockSitecoreItem | Locks the sitecore item. (Inherited from WebDAVHierarchyItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveTo | Moves to destination folder. (Overrides WebDAVHierarchyItem..::..MoveTo(IFolder, String).)
Public method | RefreshLock | Refreshes the lock. (Inherited from WebDAVHierarchyItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unlock | Unlocks the specified lock token. (Inherited from WebDAVHierarchyItem.)
Protected method | UnlockSitecoreItem | Unlocks the sitecore item. (Inherited from WebDAVHierarchyItem.)
Public method | UpdateProperties | Updates the properties. (Overrides WebDAVHierarchyItem..::..UpdateProperties(array<Property>[]()[][], array<Property>[]()[][]).)

See Also

WebDAVLockNullItem Class
Sitecore.Data.Items Namespace


ConvertToFolder Method

[image]

Sitecore 6.4.1 API
WebDAVLockNullItem..::..ConvertToFolder Method
WebDAVLockNullItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual WebDAVResponse ConvertToFolder()
Visual Basic
Public Overridable Function ConvertToFolder As WebDAVResponse
Visual C++
public:
virtual WebDAVResponse^ ConvertToFolder()

Return Value

The Web DAV response.

Implements

ILockNullConvertToFolder()()()()

See Also

WebDAVLockNullItem Class
Sitecore.Data.Items Namespace


ConvertToResource Method

[image]

Sitecore 6.4.1 API
WebDAVLockNullItem..::..ConvertToResource Method
WebDAVLockNullItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual WebDAVResponse ConvertToResource()
Visual Basic
Public Overridable Function ConvertToResource As WebDAVResponse
Visual C++
public:
virtual WebDAVResponse^ ConvertToResource()

Return Value

The Web DAV response.

Implements

ILockNullConvertToResource()()()()

See Also

WebDAVLockNullItem Class
Sitecore.Data.Items Namespace


CopyTo Method

[image]

Sitecore 6.4.1 API
WebDAVLockNullItem..::..CopyTo Method
WebDAVLockNullItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override WebDAVResponse CopyTo(
    IFolder folder,
    string destName,
    bool deep
)
Visual Basic
Public Overrides Function CopyTo ( _
    folder As IFolder, _
    destName As String, _
    deep As Boolean _
) As WebDAVResponse
Visual C++
public:
virtual WebDAVResponse^ CopyTo(
    IFolder^ folder,
    String^ destName,
    bool deep
) override

Parameters

folder
Type: IFolder
The folder.
destName
Type: System..::..String
Name of the destination.
deep
Type: System..::..Boolean
if set to true all subtree will be copied.

Return Value

Web DAV response.

Implements

IHierarchyItemCopyTo(IFolder, String, Boolean)
IHierarchyItemCopyTo(IFolder, String, Boolean)

See Also

WebDAVLockNullItem Class
Sitecore.Data.Items Namespace


Delete Method

[image]

Sitecore 6.4.1 API
WebDAVLockNullItem..::..Delete Method
WebDAVLockNullItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override WebDAVResponse Delete()
Visual Basic
Public Overrides Function Delete As WebDAVResponse
Visual C++
public:
virtual WebDAVResponse^ Delete() override

Return Value

Web DAV response.

Implements

IHierarchyItemDelete()()()()
IHierarchyItemDelete()()()()

See Also

WebDAVLockNullItem Class
Sitecore.Data.Items Namespace


GetDatabase Method

[image]

Sitecore 6.4.1 API
WebDAVLockNullItem..::..GetDatabase Method
WebDAVLockNullItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Database GetDatabase()
Visual Basic
Protected Function GetDatabase As Database
Visual C++
protected:
Database^ GetDatabase()

Return Value

The Database.

See Also

WebDAVLockNullItem Class
Sitecore.Data.Items Namespace


GetItemName Method

[image]

Sitecore 6.4.1 API
WebDAVLockNullItem..::..GetItemName Method
WebDAVLockNullItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected string GetItemName()
Visual Basic
Protected Function GetItemName As String
Visual C++
protected:
String^ GetItemName()

Return Value

The Sitecore Item name.

See Also

WebDAVLockNullItem Class
Sitecore.Data.Items Namespace


GetMediaPath Method

[image]

Sitecore 6.4.1 API
WebDAVLockNullItem..::..GetMediaPath Method
WebDAVLockNullItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override string GetMediaPath()
Visual Basic
Protected Overrides Function GetMediaPath As String
Visual C++
protected:
virtual String^ GetMediaPath() override

Return Value

The Media path.

See Also

WebDAVLockNullItem Class
Sitecore.Data.Items Namespace


GetParentItem Method

[image]

Sitecore 6.4.1 API
WebDAVLockNullItem..::..GetParentItem Method
WebDAVLockNullItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Item GetParentItem()
Visual Basic
Protected Function GetParentItem As Item
Visual C++
protected:
Item^ GetParentItem()

Return Value

The Sitecore parent item.

See Also

WebDAVLockNullItem Class
Sitecore.Data.Items Namespace


GetParentPath Method

[image]

Sitecore 6.4.1 API
WebDAVLockNullItem..::..GetParentPath Method
WebDAVLockNullItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected string GetParentPath()
Visual Basic
Protected Function GetParentPath As String
Visual C++
protected:
String^ GetParentPath()

Return Value

The Parent path in content tree.

See Also

WebDAVLockNullItem Class
Sitecore.Data.Items Namespace


GetProperties Method

[image]

Sitecore 6.4.1 API
WebDAVLockNullItem..::..GetProperties Method
WebDAVLockNullItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override WebDAVResponse GetProperties(
    ref Property[] props
)
Visual Basic
Public Overrides Function GetProperties ( _
    ByRef props As Property() _
) As WebDAVResponse
Visual C++
public:
virtual WebDAVResponse^ GetProperties(
    array<Property>^% props
) override

Parameters

props
Type: array<Property>[]()[][]%
The properties.

Return Value

Web DAV Response.

Implements

IHierarchyItemGetProperties(array<Property>[]()[][]%)
IHierarchyItemGetProperties(array<Property>[]()[][]%)

See Also

WebDAVLockNullItem Class
Sitecore.Data.Items Namespace


GetPropertyNames Method

[image]

Sitecore 6.4.1 API
WebDAVLockNullItem..::..GetPropertyNames Method
WebDAVLockNullItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override WebDAVResponse GetPropertyNames(
    ref Property[] props
)
Visual Basic
Public Overrides Function GetPropertyNames ( _
    ByRef props As Property() _
) As WebDAVResponse
Visual C++
public:
virtual WebDAVResponse^ GetPropertyNames(
    array<Property>^% props
) override

Parameters

props
Type: array<Property>[]()[][]%
The properties.

Return Value

Web DAV response.

Implements

IHierarchyItemGetPropertyNames(array<Property>[]()[][]%)
IHierarchyItemGetPropertyNames(array<Property>[]()[][]%)

See Also

WebDAVLockNullItem Class
Sitecore.Data.Items Namespace


Lock Method

[image] [image]

Sitecore 6.4.1 API
WebDAVLockNullItem..::..Lock Method
WebDAVLockNullItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Lock(LockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)
Protected method | Lock(ExLockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)

See Also

WebDAVLockNullItem Class
WebDAVLockNullItem Members
Sitecore.Data.Items Namespace


MoveTo Method

[image]

Sitecore 6.4.1 API
WebDAVLockNullItem..::..MoveTo Method
WebDAVLockNullItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override WebDAVResponse MoveTo(
    IFolder folder,
    string destName
)
Visual Basic
Public Overrides Function MoveTo ( _
    folder As IFolder, _
    destName As String _
) As WebDAVResponse
Visual C++
public:
virtual WebDAVResponse^ MoveTo(
    IFolder^ folder,
    String^ destName
) override

Parameters

folder
Type: IFolder
The folder.
destName
Type: System..::..String
Name of the destination.

Return Value

Web DAV response.

Implements

IHierarchyItemMoveTo(IFolder, String)
IHierarchyItemMoveTo(IFolder, String)

See Also

WebDAVLockNullItem Class
Sitecore.Data.Items Namespace


UpdateProperties Method

[image]

Sitecore 6.4.1 API
WebDAVLockNullItem..::..UpdateProperties Method
WebDAVLockNullItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override WebDAVResponse UpdateProperties(
    Property[] setProps,
    Property[] delProps
)
Visual Basic
Public Overrides Function UpdateProperties ( _
    setProps As Property(), _
    delProps As Property() _
) As WebDAVResponse
Visual C++
public:
virtual WebDAVResponse^ UpdateProperties(
    array<Property>^ setProps,
    array<Property>^ delProps
) override

Parameters

setProps
Type: array<Property>[]()[][]
The properties to be setted.
delProps
Type: array<Property>[]()[][]
The properties to be deleted.

Return Value

Web DAV response.

Implements

IHierarchyItemUpdateProperties(array<Property>[]()[][], array<Property>[]()[][])
IHierarchyItemUpdateProperties(array<Property>[]()[][], array<Property>[]()[][])

See Also

WebDAVLockNullItem Class
Sitecore.Data.Items Namespace


WebDAVLockNullItem Properties

[image] [image]

Sitecore 6.4.1 API
WebDAVLockNullItem Properties
WebDAVLockNullItem Class See Also Send Feedback

The WebDAVLockNullItem type exposes the following members.

Properties

 | Name | Description
Public property | ActiveLocks | Gets the active locks. (Inherited from WebDAVHierarchyItem.)
Protected property | ClientHasToken | Gets a value indicating whether client has lock tokens. (Inherited from WebDAVHierarchyItem.)
Public property | Created | Gets the created date. (Overrides WebDAVHierarchyItem..::..Created.)
Protected property | Engine | Gets the engine. (Inherited from WebDAVHierarchyItem.)
Protected property | InnerItem | Gets the Sitecore item. (Overrides WebDAVHierarchyItem..::..InnerItem.)
Public property | ItemUri | Gets the item URI.
Public property | Modified | Gets the modified date. (Overrides WebDAVHierarchyItem..::..Modified.)
Public property | Name | Gets the item name. (Inherited from WebDAVHierarchyItem.)
Public property | Parent | Gets the parent. (Overrides WebDAVHierarchyItem..::..Parent.)
Public property | Path | Gets the item path. (Overrides WebDAVHierarchyItem..::..Path.)
Public property | UniqueID | Gets the unique ID. (Inherited from WebDAVHierarchyItem.)
Protected property | View | Gets the Web DAV view. (Inherited from WebDAVHierarchyItem.)

See Also

WebDAVLockNullItem Class
Sitecore.Data.Items Namespace


Created Property

[image]

Sitecore 6.4.1 API
WebDAVLockNullItem..::..Created Property
WebDAVLockNullItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override DateTime Created { get; }
Visual Basic
Public Overrides ReadOnly Property Created As DateTime
    Get
Visual C++
public:
virtual property DateTime Created {
    DateTime get () override;
}

Field Value

The created date.

Implements

IHierarchyItemCreated()()()()
IHierarchyItemCreated()()()()

See Also

WebDAVLockNullItem Class
Sitecore.Data.Items Namespace


InnerItem Property

[image]

Sitecore 6.4.1 API
WebDAVLockNullItem..::..InnerItem Property
WebDAVLockNullItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected internal override Item InnerItem { get; }
Visual Basic
Protected Friend Overrides ReadOnly Property InnerItem As Item
    Get
Visual C++
protected public:
virtual property Item^ InnerItem {
    Item^ get () override;
}

Field Value

The Sitecore item.

See Also

WebDAVLockNullItem Class
Sitecore.Data.Items Namespace


ItemUri Property

[image]

Sitecore 6.4.1 API
WebDAVLockNullItem..::..ItemUri Property
WebDAVLockNullItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ItemUri ItemUri { get; }
Visual Basic
Public Overridable ReadOnly Property ItemUri As ItemUri
    Get
Visual C++
public:
virtual property ItemUri^ ItemUri {
    ItemUri^ get ();
}

Field Value

The item URI.

See Also

WebDAVLockNullItem Class
Sitecore.Data.Items Namespace


Modified Property

[image]

Sitecore 6.4.1 API
WebDAVLockNullItem..::..Modified Property
WebDAVLockNullItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override DateTime Modified { get; }
Visual Basic
Public Overrides ReadOnly Property Modified As DateTime
    Get
Visual C++
public:
virtual property DateTime Modified {
    DateTime get () override;
}

Field Value

The modified date.

Implements

IHierarchyItemModified()()()()
IHierarchyItemModified()()()()

See Also

WebDAVLockNullItem Class
Sitecore.Data.Items Namespace


Parent Property

[image]

Sitecore 6.4.1 API
WebDAVLockNullItem..::..Parent Property
WebDAVLockNullItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override IFolder Parent { get; }
Visual Basic
Public Overrides ReadOnly Property Parent As IFolder
    Get
Visual C++
public:
virtual property IFolder^ Parent {
    IFolder^ get () override;
}

Field Value

The parent.

Implements

IHierarchyItemParent()()()()
IHierarchyItemParent()()()()

See Also

WebDAVLockNullItem Class
Sitecore.Data.Items Namespace


Path Property

[image]

Sitecore 6.4.1 API
WebDAVLockNullItem..::..Path Property
WebDAVLockNullItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Path { get; }
Visual Basic
Public Overrides ReadOnly Property Path As String
    Get
Visual C++
public:
virtual property String^ Path {
    String^ get () override;
}

Field Value

The item path.

Implements

IHierarchyItemPath()()()()
IHierarchyItemPath()()()()

See Also

WebDAVLockNullItem Class
Sitecore.Data.Items Namespace


WebDAVLockNullSingleVersion Class

[image]

Sitecore 6.4.1 API
WebDAVLockNullSingleVersion Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class WebDAVLockNullSingleVersion : WebDAVLockNullItem
Visual Basic
Public Class WebDAVLockNullSingleVersion _
    Inherits WebDAVLockNullItem
Visual C++
public ref class WebDAVLockNullSingleVersion : public WebDAVLockNullItem

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..WebDAVHierarchyItem
Sitecore.Data.Items..::..WebDAVLockNullItem
Sitecore.Data.Items..::..WebDAVLockNullSingleVersion

See Also

WebDAVLockNullSingleVersion Members
Sitecore.Data.Items Namespace


WebDAVLockNullSingleVersion Members

[image] [image]

Sitecore 6.4.1 API
WebDAVLockNullSingleVersion Members
WebDAVLockNullSingleVersion Class Constructors Methods Properties See Also Send Feedback

The WebDAVLockNullSingleVersion type exposes the following members.

Constructors

 | Name | Description
Public method | WebDAVLockNullSingleVersion | Initializes a new instance of the WebDAVLockNullSingleVersion class.

Methods

 | Name | Description
Protected method | AddVersion | Adds the version to the item. (Inherited from WebDAVHierarchyItem.)
Protected method | CanExecuteOperation | Validates the operation. (Inherited from WebDAVHierarchyItem.)
Public method | ConvertToFolder | Converts the LockNull item to folder. (Inherited from WebDAVLockNullItem.)
Public method | ConvertToResource | Converts LockNull item to resource. (Inherited from WebDAVLockNullItem.)
Public method | CopyTo | Copies to. (Inherited from WebDAVLockNullItem.)
Public method | Delete | Deletes current item. (Inherited from WebDAVLockNullItem.)
Protected method | DoCopyTo | Executes the copy to event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoDelete | Executes the delete event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoGetProperties | Executes the get properties event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoGetPropertyNames | Executes the get property names event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoMoveTo | Executes the move to operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoMoveToItem | Executes the move item operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoRename | Executes the rename operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoUpdateProperties | Executes the update properties event. (Inherited from WebDAVHierarchyItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExtractItemName | Extracts the name of the item. (Inherited from WebDAVHierarchyItem.)
Protected method | ExtractMediaItemPath | Extracts the path of the media item. (Inherited from WebDAVHierarchyItem.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindLocksDown | Finds the locks down. (Inherited from WebDAVHierarchyItem.)
Protected method | GetDatabase | Gets the database. (Inherited from WebDAVLockNullItem.)
Protected method | GetFullContentPath | Gets the full content path. (Inherited from WebDAVHierarchyItem.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetItemName | Gets the name of the item. (Inherited from WebDAVLockNullItem.)
Protected method | GetLocks | Gets the locks for the specified hierarchy item. (Inherited from WebDAVHierarchyItem.)
Protected method | GetMediaPath | Gets the media path. (Inherited from WebDAVLockNullItem.)
Protected method | GetParentItem | Gets the parent item. (Inherited from WebDAVLockNullItem.)
Protected method | GetParentPath | Gets the parent path. (Inherited from WebDAVLockNullItem.)
Public method | GetProperties | Gets the properties. (Inherited from WebDAVLockNullItem.)
Public method | GetPropertyNames | Gets the property names. (Inherited from WebDAVLockNullItem.)
Protected method | GetSitecoreItemLocks | Gets the sitecore item locks. (Inherited from WebDAVHierarchyItem.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ItemHasLock | The Item has the lock. (Inherited from WebDAVHierarchyItem.)
Public method | Lock(LockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)
Protected method | Lock(ExLockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)
Protected method | LockSitecoreItem | Locks the sitecore item. (Inherited from WebDAVHierarchyItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveTo | Moves to destination folder. (Inherited from WebDAVLockNullItem.)
Public method | RefreshLock | Refreshes the lock. (Inherited from WebDAVHierarchyItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unlock | Unlocks the specified lock token. (Inherited from WebDAVHierarchyItem.)
Protected method | UnlockSitecoreItem | Unlocks the sitecore item. (Inherited from WebDAVHierarchyItem.)
Public method | UpdateProperties | Updates the properties. (Inherited from WebDAVLockNullItem.)

Properties

 | Name | Description
Public property | ActiveLocks | Gets the active locks. (Inherited from WebDAVHierarchyItem.)
Protected property | ClientHasToken | Gets a value indicating whether client has lock tokens. (Inherited from WebDAVHierarchyItem.)
Public property | Created | Gets the created date. (Inherited from WebDAVLockNullItem.)
Protected property | Engine | Gets the engine. (Inherited from WebDAVHierarchyItem.)
Protected property | InnerItem | Gets the Sitecore item. (Inherited from WebDAVLockNullItem.)
Public property | ItemUri | Gets the item URI. (Inherited from WebDAVLockNullItem.)
Public property | Modified | Gets the modified date. (Inherited from WebDAVLockNullItem.)
Public property | Name | Gets the item name. (Inherited from WebDAVHierarchyItem.)
Public property | Parent | Gets the parent. (Inherited from WebDAVLockNullItem.)
Public property | Path | Gets the item path. (Inherited from WebDAVLockNullItem.)
Public property | UniqueID | Gets the unique ID. (Overrides WebDAVHierarchyItem..::..UniqueID.)
Protected property | View | Gets the Web DAV view. (Inherited from WebDAVHierarchyItem.)

See Also

WebDAVLockNullSingleVersion Class
Sitecore.Data.Items Namespace


WebDAVLockNullSingleVersion Constructor

[image]

Sitecore 6.4.1 API
WebDAVLockNullSingleVersion Constructor
WebDAVLockNullSingleVersion Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WebDAVLockNullSingleVersion(
    ItemUri uri,
    WebDAVView view,
    WebDAVEngine engine
)
Visual Basic
Public Sub New ( _
    uri As ItemUri, _
    view As WebDAVView, _
    engine As WebDAVEngine _
)
Visual C++
public:
WebDAVLockNullSingleVersion(
    ItemUri^ uri,
    WebDAVView^ view,
    WebDAVEngine^ engine
)

Parameters

uri
Type: Sitecore.Data..::..ItemUri
The LockNull URI.
view
Type: Sitecore.Data.Views..::..WebDAVView
The Web DAV view.
engine
Type: Sitecore.Web..::..WebDAVEngine
The Web DAV engine.

See Also

WebDAVLockNullSingleVersion Class
Sitecore.Data.Items Namespace


WebDAVLockNullSingleVersion Methods

[image] [image]

Sitecore 6.4.1 API
WebDAVLockNullSingleVersion Methods
WebDAVLockNullSingleVersion Class See Also Send Feedback

The WebDAVLockNullSingleVersion type exposes the following members.

Methods

 | Name | Description
Protected method | AddVersion | Adds the version to the item. (Inherited from WebDAVHierarchyItem.)
Protected method | CanExecuteOperation | Validates the operation. (Inherited from WebDAVHierarchyItem.)
Public method | ConvertToFolder | Converts the LockNull item to folder. (Inherited from WebDAVLockNullItem.)
Public method | ConvertToResource | Converts LockNull item to resource. (Inherited from WebDAVLockNullItem.)
Public method | CopyTo | Copies to. (Inherited from WebDAVLockNullItem.)
Public method | Delete | Deletes current item. (Inherited from WebDAVLockNullItem.)
Protected method | DoCopyTo | Executes the copy to event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoDelete | Executes the delete event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoGetProperties | Executes the get properties event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoGetPropertyNames | Executes the get property names event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoMoveTo | Executes the move to operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoMoveToItem | Executes the move item operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoRename | Executes the rename operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoUpdateProperties | Executes the update properties event. (Inherited from WebDAVHierarchyItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExtractItemName | Extracts the name of the item. (Inherited from WebDAVHierarchyItem.)
Protected method | ExtractMediaItemPath | Extracts the path of the media item. (Inherited from WebDAVHierarchyItem.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindLocksDown | Finds the locks down. (Inherited from WebDAVHierarchyItem.)
Protected method | GetDatabase | Gets the database. (Inherited from WebDAVLockNullItem.)
Protected method | GetFullContentPath | Gets the full content path. (Inherited from WebDAVHierarchyItem.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetItemName | Gets the name of the item. (Inherited from WebDAVLockNullItem.)
Protected method | GetLocks | Gets the locks for the specified hierarchy item. (Inherited from WebDAVHierarchyItem.)
Protected method | GetMediaPath | Gets the media path. (Inherited from WebDAVLockNullItem.)
Protected method | GetParentItem | Gets the parent item. (Inherited from WebDAVLockNullItem.)
Protected method | GetParentPath | Gets the parent path. (Inherited from WebDAVLockNullItem.)
Public method | GetProperties | Gets the properties. (Inherited from WebDAVLockNullItem.)
Public method | GetPropertyNames | Gets the property names. (Inherited from WebDAVLockNullItem.)
Protected method | GetSitecoreItemLocks | Gets the sitecore item locks. (Inherited from WebDAVHierarchyItem.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | ItemHasLock | The Item has the lock. (Inherited from WebDAVHierarchyItem.)
Public method | Lock(LockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)
Protected method | Lock(ExLockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)
Protected method | LockSitecoreItem | Locks the sitecore item. (Inherited from WebDAVHierarchyItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveTo | Moves to destination folder. (Inherited from WebDAVLockNullItem.)
Public method | RefreshLock | Refreshes the lock. (Inherited from WebDAVHierarchyItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unlock | Unlocks the specified lock token. (Inherited from WebDAVHierarchyItem.)
Protected method | UnlockSitecoreItem | Unlocks the sitecore item. (Inherited from WebDAVHierarchyItem.)
Public method | UpdateProperties | Updates the properties. (Inherited from WebDAVLockNullItem.)

See Also

WebDAVLockNullSingleVersion Class
Sitecore.Data.Items Namespace


Lock Method

[image] [image]

Sitecore 6.4.1 API
WebDAVLockNullSingleVersion..::..Lock Method
WebDAVLockNullSingleVersion Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Lock(LockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)
Protected method | Lock(ExLockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)

See Also

WebDAVLockNullSingleVersion Class
WebDAVLockNullSingleVersion Members
Sitecore.Data.Items Namespace


WebDAVLockNullSingleVersion Properties

[image] [image]

Sitecore 6.4.1 API
WebDAVLockNullSingleVersion Properties
WebDAVLockNullSingleVersion Class See Also Send Feedback

The WebDAVLockNullSingleVersion type exposes the following members.

Properties

 | Name | Description
Public property | ActiveLocks | Gets the active locks. (Inherited from WebDAVHierarchyItem.)
Protected property | ClientHasToken | Gets a value indicating whether client has lock tokens. (Inherited from WebDAVHierarchyItem.)
Public property | Created | Gets the created date. (Inherited from WebDAVLockNullItem.)
Protected property | Engine | Gets the engine. (Inherited from WebDAVHierarchyItem.)
Protected property | InnerItem | Gets the Sitecore item. (Inherited from WebDAVLockNullItem.)
Public property | ItemUri | Gets the item URI. (Inherited from WebDAVLockNullItem.)
Public property | Modified | Gets the modified date. (Inherited from WebDAVLockNullItem.)
Public property | Name | Gets the item name. (Inherited from WebDAVHierarchyItem.)
Public property | Parent | Gets the parent. (Inherited from WebDAVLockNullItem.)
Public property | Path | Gets the item path. (Inherited from WebDAVLockNullItem.)
Public property | UniqueID | Gets the unique ID. (Overrides WebDAVHierarchyItem..::..UniqueID.)
Protected property | View | Gets the Web DAV view. (Inherited from WebDAVHierarchyItem.)

See Also

WebDAVLockNullSingleVersion Class
Sitecore.Data.Items Namespace


UniqueID Property

[image]

Sitecore 6.4.1 API
WebDAVLockNullSingleVersion..::..UniqueID Property
WebDAVLockNullSingleVersion Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string UniqueID { get; }
Visual Basic
Public Overrides ReadOnly Property UniqueID As String
    Get
Visual C++
public:
virtual property String^ UniqueID {
    String^ get () override;
}

Field Value

The unique ID.

See Also

WebDAVLockNullSingleVersion Class
Sitecore.Data.Items Namespace


WebDAVMediaItem Class

[image]

Sitecore 6.4.1 API
WebDAVMediaItem Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class WebDAVMediaItem : WebDAVHierarchyItem,
    IResource, IHierarchyItem
Visual Basic
Public Class WebDAVMediaItem _
    Inherits WebDAVHierarchyItem _
    Implements IResource, IHierarchyItem
Visual C++
public ref class WebDAVMediaItem : public WebDAVHierarchyItem,
    IResource, IHierarchyItem

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..WebDAVHierarchyItem
Sitecore.Data.Items..::..WebDAVMediaItem
Sitecore.Data.Items..::..WebDAVSingleItemVersion

See Also

WebDAVMediaItem Members
Sitecore.Data.Items Namespace


WebDAVMediaItem Members

[image] [image]

Sitecore 6.4.1 API
WebDAVMediaItem Members
WebDAVMediaItem Class Constructors Methods Properties See Also Send Feedback

The WebDAVMediaItem type exposes the following members.

Constructors

 | Name | Description
Public method | WebDAVMediaItem | Initializes a new instance of the WebDAVMediaItem class.

Methods

 | Name | Description
Protected method | AddVersion | Adds the version to the item. (Inherited from WebDAVHierarchyItem.)
Protected method | CanExecuteOperation | Validates the operation. (Inherited from WebDAVHierarchyItem.)
Public method | CopyTo | Copies to. (Inherited from WebDAVHierarchyItem.)
Protected method | CreateAndLock | Creates new version and lock the version.
Protected method | CreateNewVersion | Creates the new version.
Public method | Delete | Deletes current item. (Inherited from WebDAVHierarchyItem.)
Protected method | DoCopyTo | Executes the copy to event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoDelete | Executes the delete event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoGetProperties | Executes the get properties event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoGetPropertyNames | Executes the get property names event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoMoveTo | Executes the move to operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoMoveToItem | Executes the move item operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoRename | Executes the rename operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoUpdateProperties | Executes the update properties event. (Inherited from WebDAVHierarchyItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExtractItemName | Extracts the name of the item. (Inherited from WebDAVHierarchyItem.)
Protected method | ExtractMediaItemPath | Extracts the path of the media item. (Inherited from WebDAVHierarchyItem.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindLocksDown | Finds the locks down. (Inherited from WebDAVHierarchyItem.)
Protected method | GetFullContentPath | Gets the full content path. (Inherited from WebDAVHierarchyItem.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocks | Gets the locks for the specified hierarchy item. (Inherited from WebDAVHierarchyItem.)
Public method | GetMedia | Gets the media.
Protected method | GetMediaPath | Gets the media path. (Inherited from WebDAVHierarchyItem.)
Public method | GetMediaStream | Gets the media stream.
Protected method | GetNewFilePath | Gets the new file path.
Public method | GetProperties | Gets the properties. (Inherited from WebDAVHierarchyItem.)
Public method | GetPropertyNames | Gets the property names. (Inherited from WebDAVHierarchyItem.)
Protected method | GetSitecoreItemLocks | Gets the sitecore item locks. (Inherited from WebDAVHierarchyItem.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IsVersioned | Determines whether this media item is versioned.
Protected method | ItemHasLock | The Item has the lock. (Inherited from WebDAVHierarchyItem.)
Public method | Lock(LockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)
Protected method | Lock(ExLockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)
Protected method | LockSitecoreItem | Locks the sitecore item. (Overrides WebDAVHierarchyItem..::..LockSitecoreItem()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveTo | Moves to destination folder. (Inherited from WebDAVHierarchyItem.)
Public method | RefreshLock | Refreshes the lock. (Inherited from WebDAVHierarchyItem.)
Public method | SaveFromStream | Saves from stream.
Protected method | SupportedAutogenerating | Supporteds the autogenerating.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unlock | Unlocks the specified lock token. (Inherited from WebDAVHierarchyItem.)
Protected method | UnlockSitecoreItem | Unlocks the sitecore item. (Inherited from WebDAVHierarchyItem.)
Public method | UpdateProperties | Updates the properties. (Inherited from WebDAVHierarchyItem.)
Public method | WriteToStream | Writes to stream.

Properties

 | Name | Description
Public property | ActiveLocks | Gets the active locks. (Inherited from WebDAVHierarchyItem.)
Protected property | ClientHasToken | Gets a value indicating whether client has lock tokens. (Inherited from WebDAVHierarchyItem.)
Public property | ContentLength | Gets the length of the content.
Public property | ContentType | Gets the type of the content.
Public property | Created | Gets the created date. (Inherited from WebDAVHierarchyItem.)
Protected property | Engine | Gets the engine. (Inherited from WebDAVHierarchyItem.)
Protected property | InnerItem | Gets or sets the inner item. (Inherited from WebDAVHierarchyItem.)
Protected property | MediaItem | Gets the media item.
Protected property | MediaStream | Gets or sets the media stream.
Public property | Modified | Gets the modified date. (Inherited from WebDAVHierarchyItem.)
Public property | Name | Gets the name. (Overrides WebDAVHierarchyItem..::..Name.)
Public property | Parent | Gets the parent. (Inherited from WebDAVHierarchyItem.)
Public property | Path | Gets the path. (Overrides WebDAVHierarchyItem..::..Path.)
Public property | UniqueID | Gets the unique ID. (Inherited from WebDAVHierarchyItem.)
Protected property | View | Gets the Web DAV view. (Inherited from WebDAVHierarchyItem.)

See Also

WebDAVMediaItem Class
Sitecore.Data.Items Namespace


WebDAVMediaItem Constructor

[image]

Sitecore 6.4.1 API
WebDAVMediaItem Constructor
WebDAVMediaItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WebDAVMediaItem(
    Media media,
    WebDAVView view,
    WebDAVEngine engine
)
Visual Basic
Public Sub New ( _
    media As Media, _
    view As WebDAVView, _
    engine As WebDAVEngine _
)
Visual C++
public:
WebDAVMediaItem(
    Media^ media,
    WebDAVView^ view,
    WebDAVEngine^ engine
)

Parameters

media
Type: Sitecore.Resources.Media..::..Media
The media.
view
Type: Sitecore.Data.Views..::..WebDAVView
The Web DAV view.
engine
Type: Sitecore.Web..::..WebDAVEngine
The engine.

See Also

WebDAVMediaItem Class
Sitecore.Data.Items Namespace


WebDAVMediaItem Methods

[image] [image]

Sitecore 6.4.1 API
WebDAVMediaItem Methods
WebDAVMediaItem Class See Also Send Feedback

The WebDAVMediaItem type exposes the following members.

Methods

 | Name | Description
Protected method | AddVersion | Adds the version to the item. (Inherited from WebDAVHierarchyItem.)
Protected method | CanExecuteOperation | Validates the operation. (Inherited from WebDAVHierarchyItem.)
Public method | CopyTo | Copies to. (Inherited from WebDAVHierarchyItem.)
Protected method | CreateAndLock | Creates new version and lock the version.
Protected method | CreateNewVersion | Creates the new version.
Public method | Delete | Deletes current item. (Inherited from WebDAVHierarchyItem.)
Protected method | DoCopyTo | Executes the copy to event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoDelete | Executes the delete event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoGetProperties | Executes the get properties event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoGetPropertyNames | Executes the get property names event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoMoveTo | Executes the move to operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoMoveToItem | Executes the move item operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoRename | Executes the rename operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoUpdateProperties | Executes the update properties event. (Inherited from WebDAVHierarchyItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExtractItemName | Extracts the name of the item. (Inherited from WebDAVHierarchyItem.)
Protected method | ExtractMediaItemPath | Extracts the path of the media item. (Inherited from WebDAVHierarchyItem.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindLocksDown | Finds the locks down. (Inherited from WebDAVHierarchyItem.)
Protected method | GetFullContentPath | Gets the full content path. (Inherited from WebDAVHierarchyItem.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocks | Gets the locks for the specified hierarchy item. (Inherited from WebDAVHierarchyItem.)
Public method | GetMedia | Gets the media.
Protected method | GetMediaPath | Gets the media path. (Inherited from WebDAVHierarchyItem.)
Public method | GetMediaStream | Gets the media stream.
Protected method | GetNewFilePath | Gets the new file path.
Public method | GetProperties | Gets the properties. (Inherited from WebDAVHierarchyItem.)
Public method | GetPropertyNames | Gets the property names. (Inherited from WebDAVHierarchyItem.)
Protected method | GetSitecoreItemLocks | Gets the sitecore item locks. (Inherited from WebDAVHierarchyItem.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IsVersioned | Determines whether this media item is versioned.
Protected method | ItemHasLock | The Item has the lock. (Inherited from WebDAVHierarchyItem.)
Public method | Lock(LockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)
Protected method | Lock(ExLockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)
Protected method | LockSitecoreItem | Locks the sitecore item. (Overrides WebDAVHierarchyItem..::..LockSitecoreItem()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveTo | Moves to destination folder. (Inherited from WebDAVHierarchyItem.)
Public method | RefreshLock | Refreshes the lock. (Inherited from WebDAVHierarchyItem.)
Public method | SaveFromStream | Saves from stream.
Protected method | SupportedAutogenerating | Supporteds the autogenerating.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unlock | Unlocks the specified lock token. (Inherited from WebDAVHierarchyItem.)
Protected method | UnlockSitecoreItem | Unlocks the sitecore item. (Inherited from WebDAVHierarchyItem.)
Public method | UpdateProperties | Updates the properties. (Inherited from WebDAVHierarchyItem.)
Public method | WriteToStream | Writes to stream.

See Also

WebDAVMediaItem Class
Sitecore.Data.Items Namespace


CreateAndLock Method

[image]

Sitecore 6.4.1 API
WebDAVMediaItem..::..CreateAndLock Method
WebDAVMediaItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool CreateAndLock()
Visual Basic
Protected Overridable Function CreateAndLock As Boolean
Visual C++
protected:
virtual bool CreateAndLock()

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Items.WebDAVMediaItem.CreateAndLock"]

See Also

WebDAVMediaItem Class
Sitecore.Data.Items Namespace


CreateNewVersion Method

[image]

Sitecore 6.4.1 API
WebDAVMediaItem..::..CreateNewVersion Method
WebDAVMediaItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool CreateNewVersion()
Visual Basic
Protected Overridable Function CreateNewVersion As Boolean
Visual C++
protected:
virtual bool CreateNewVersion()

Return Value

true if new version should be created.

See Also

WebDAVMediaItem Class
Sitecore.Data.Items Namespace


GetMediaStream Method

[image]

Sitecore 6.4.1 API
WebDAVMediaItem..::..GetMediaStream Method
WebDAVMediaItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual MediaStream GetMediaStream()
Visual Basic
Public Overridable Function GetMediaStream As MediaStream
Visual C++
public:
virtual MediaStream^ GetMediaStream()

Return Value

The Media Stream.

See Also

WebDAVMediaItem Class
Sitecore.Data.Items Namespace


GetNewFilePath Method

[image]

Sitecore 6.4.1 API
WebDAVMediaItem..::..GetNewFilePath Method
WebDAVMediaItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string GetNewFilePath(
    string path
)
Visual Basic
Protected Overridable Function GetNewFilePath ( _
    path As String _
) As String
Visual C++
protected:
virtual String^ GetNewFilePath(
    String^ path
)

Parameters

path
Type: System..::..String
The path.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Items.WebDAVMediaItem.GetNewFilePath(System.String)"]

See Also

WebDAVMediaItem Class
Sitecore.Data.Items Namespace


IsVersioned Method

[image]

Sitecore 6.4.1 API
WebDAVMediaItem..::..IsVersioned Method
WebDAVMediaItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool IsVersioned()
Visual Basic
Protected Overridable Function IsVersioned As Boolean
Visual C++
protected:
virtual bool IsVersioned()

Return Value

true if media items is versioned; otherwise, false.

See Also

WebDAVMediaItem Class
Sitecore.Data.Items Namespace


Lock Method

[image] [image]

Sitecore 6.4.1 API
WebDAVMediaItem..::..Lock Method
WebDAVMediaItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Lock(LockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)
Protected method | Lock(ExLockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)

See Also

WebDAVMediaItem Class
WebDAVMediaItem Members
Sitecore.Data.Items Namespace


LockSitecoreItem Method

[image]

Sitecore 6.4.1 API
WebDAVMediaItem..::..LockSitecoreItem Method
WebDAVMediaItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override bool LockSitecoreItem()
Visual Basic
Protected Overrides Function LockSitecoreItem As Boolean
Visual C++
protected:
virtual bool LockSitecoreItem() override

Return Value

true if current item has been locked.

See Also

WebDAVMediaItem Class
Sitecore.Data.Items Namespace


SupportedAutogenerating Method

[image]

Sitecore 6.4.1 API
WebDAVMediaItem..::..SupportedAutogenerating Method
WebDAVMediaItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected bool SupportedAutogenerating()
Visual Basic
Protected Function SupportedAutogenerating As Boolean
Visual C++
protected:
bool SupportedAutogenerating()

Return Value

true if Autogeneration is supported.

See Also

WebDAVMediaItem Class
Sitecore.Data.Items Namespace


WriteToStream Method

[image]

Sitecore 6.4.1 API
WebDAVMediaItem..::..WriteToStream Method
WebDAVMediaItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WebDAVResponse WriteToStream(
    Stream output,
    long startIndex,
    long count
)
Visual Basic
Public Function WriteToStream ( _
    output As Stream, _
    startIndex As Long, _
    count As Long _
) As WebDAVResponse
Visual C++
public:
virtual WebDAVResponse^ WriteToStream(
    Stream^ output,
    long long startIndex,
    long long count
) sealed

Parameters

output
Type: System.IO..::..Stream
The output.
startIndex
Type: System..::..Int64
The start index.
count
Type: System..::..Int64
The count of bites to be written.

Return Value

Web DAV Response.

Implements

IResourceWriteToStream(Stream, Int64, Int64)

See Also

WebDAVMediaItem Class
Sitecore.Data.Items Namespace


WebDAVMediaItem Properties

[image] [image]

Sitecore 6.4.1 API
WebDAVMediaItem Properties
WebDAVMediaItem Class See Also Send Feedback

The WebDAVMediaItem type exposes the following members.

Properties

 | Name | Description
Public property | ActiveLocks | Gets the active locks. (Inherited from WebDAVHierarchyItem.)
Protected property | ClientHasToken | Gets a value indicating whether client has lock tokens. (Inherited from WebDAVHierarchyItem.)
Public property | ContentLength | Gets the length of the content.
Public property | ContentType | Gets the type of the content.
Public property | Created | Gets the created date. (Inherited from WebDAVHierarchyItem.)
Protected property | Engine | Gets the engine. (Inherited from WebDAVHierarchyItem.)
Protected property | InnerItem | Gets or sets the inner item. (Inherited from WebDAVHierarchyItem.)
Protected property | MediaItem | Gets the media item.
Protected property | MediaStream | Gets or sets the media stream.
Public property | Modified | Gets the modified date. (Inherited from WebDAVHierarchyItem.)
Public property | Name | Gets the name. (Overrides WebDAVHierarchyItem..::..Name.)
Public property | Parent | Gets the parent. (Inherited from WebDAVHierarchyItem.)
Public property | Path | Gets the path. (Overrides WebDAVHierarchyItem..::..Path.)
Public property | UniqueID | Gets the unique ID. (Inherited from WebDAVHierarchyItem.)
Protected property | View | Gets the Web DAV view. (Inherited from WebDAVHierarchyItem.)

See Also

WebDAVMediaItem Class
Sitecore.Data.Items Namespace


ContentLength Property

[image]

Sitecore 6.4.1 API
WebDAVMediaItem..::..ContentLength Property
WebDAVMediaItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long ContentLength { get; }
Visual Basic
Public ReadOnly Property ContentLength As Long
    Get
Visual C++
public:
virtual property long long ContentLength {
    long long get () sealed;
}

Field Value

The length of the content.

Implements

IResourceContentLength()()()()

See Also

WebDAVMediaItem Class
Sitecore.Data.Items Namespace


ContentType Property

[image]

Sitecore 6.4.1 API
WebDAVMediaItem..::..ContentType Property
WebDAVMediaItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ContentType { get; }
Visual Basic
Public ReadOnly Property ContentType As String
    Get
Visual C++
public:
virtual property String^ ContentType {
    String^ get () sealed;
}

Field Value

The type of the content.

Implements

IResourceContentType()()()()

See Also

WebDAVMediaItem Class
Sitecore.Data.Items Namespace


MediaItem Property

[image]

Sitecore 6.4.1 API
WebDAVMediaItem..::..MediaItem Property
WebDAVMediaItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected MediaItem MediaItem { get; }
Visual Basic
Protected ReadOnly Property MediaItem As MediaItem
    Get
Visual C++
protected:
property MediaItem^ MediaItem {
    MediaItem^ get ();
}

Field Value

The media item.

See Also

WebDAVMediaItem Class
Sitecore.Data.Items Namespace


MediaStream Property

[image]

Sitecore 6.4.1 API
WebDAVMediaItem..::..MediaStream Property
WebDAVMediaItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected MediaStream MediaStream { get; set; }
Visual Basic
Protected Property MediaStream As MediaStream
    Get
    Set
Visual C++
protected:
property MediaStream^ MediaStream {
    MediaStream^ get ();
    void set (MediaStream^ value);
}

Field Value

The media stream.

See Also

WebDAVMediaItem Class
Sitecore.Data.Items Namespace


Name Property

[image]

Sitecore 6.4.1 API
WebDAVMediaItem..::..Name Property
WebDAVMediaItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The Item name.

Implements

IHierarchyItemName()()()()
IHierarchyItemName()()()()

See Also

WebDAVMediaItem Class
Sitecore.Data.Items Namespace


Path Property

[image]

Sitecore 6.4.1 API
WebDAVMediaItem..::..Path Property
WebDAVMediaItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Path { get; }
Visual Basic
Public Overrides ReadOnly Property Path As String
    Get
Visual C++
public:
virtual property String^ Path {
    String^ get () override;
}

Field Value

The Item path.

Implements

IHierarchyItemPath()()()()
IHierarchyItemPath()()()()

See Also

WebDAVMediaItem Class
Sitecore.Data.Items Namespace


WebDAVOperation Enumeration

[image]

Sitecore 6.4.1 API
WebDAVOperation Enumeration
See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum WebDAVOperation
Visual Basic
Public Enumeration WebDAVOperation
Visual C++
public enum class WebDAVOperation

Members

Member name | Value | Description
CopyTo | 0 | CopyTo DAV item
Delete | 1 | Delete DAV Item
GetProperties | 2 | Get properties of DAV item.
GetPropertyNames | 3 | Get property names of DAV item.
MoveTo | 4 | MoveTo DAV item.
UpdateProperies | 5 | Update properies of DAV item.
CreateFolder | 6 | Create the folder.
CreateResource | 7 | Create Resource.
WriteToStream | 8 | Write To Stream
SaveFromStream | 9 | Save From Stream
CreateLockNull | 10 | Create LockNull item.

See Also

Sitecore.Data.Items Namespace


WebDAVSingleItemVersion Class

[image]

Sitecore 6.4.1 API
WebDAVSingleItemVersion Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class WebDAVSingleItemVersion : WebDAVMediaItem
Visual Basic
Public Class WebDAVSingleItemVersion _
    Inherits WebDAVMediaItem
Visual C++
public ref class WebDAVSingleItemVersion : public WebDAVMediaItem

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..WebDAVHierarchyItem
Sitecore.Data.Items..::..WebDAVMediaItem
Sitecore.Data.Items..::..WebDAVSingleItemVersion

See Also

WebDAVSingleItemVersion Members
Sitecore.Data.Items Namespace


WebDAVSingleItemVersion Members

[image] [image]

Sitecore 6.4.1 API
WebDAVSingleItemVersion Members
WebDAVSingleItemVersion Class Constructors Methods Properties See Also Send Feedback

The WebDAVSingleItemVersion type exposes the following members.

Constructors

 | Name | Description
Public method | WebDAVSingleItemVersion | Initializes a new instance of the WebDAVSingleItemVersion class.

Methods

 | Name | Description
Protected method | AddVersion | Adds the version to the item. (Inherited from WebDAVHierarchyItem.)
Protected method | CanExecuteOperation | Validates the operation. (Inherited from WebDAVHierarchyItem.)
Public method | CopyTo | Copies to. (Inherited from WebDAVHierarchyItem.)
Protected method | CreateAndLock | Creates new version and lock the version. (Inherited from WebDAVMediaItem.)
Protected method | CreateNewVersion | Creates the new version. (Overrides WebDAVMediaItem..::..CreateNewVersion()()()().)
Public method | Delete | Deletes current item. (Inherited from WebDAVHierarchyItem.)
Protected method | DoCopyTo | Executes the copy to event. (Overrides WebDAVHierarchyItem..::..DoCopyTo(IFolder, String, Boolean).)
Protected method | DoDelete | Executes the delete event. (Overrides WebDAVHierarchyItem..::..DoDelete()()()().)
Protected method | DoDuplicateVersion | Duplicates current version.
Protected method | DoGetProperties | Executes the get properties event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoGetPropertyNames | Executes the get property names event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoMoveTo | Executes the move to operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoMoveToItem | Executes the move item operation. (Overrides WebDAVHierarchyItem..::..DoMoveToItem(WebDAVFolder, String).)
Protected method | DoRename | Executes the rename operation. (Overrides WebDAVHierarchyItem..::..DoRename(WebDAVFolder, String).)
Protected method | DoUpdateProperties | Executes the update properties event. (Inherited from WebDAVHierarchyItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExtractItemName | Extracts the name of the item. (Inherited from WebDAVHierarchyItem.)
Protected method | ExtractMediaItemPath | Extracts the path of the media item. (Inherited from WebDAVHierarchyItem.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindLocksDown | Finds the locks down. (Inherited from WebDAVHierarchyItem.)
Protected method | GetFullContentPath | Gets the full content path. (Inherited from WebDAVHierarchyItem.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocks | Gets the locks for the specified hierarchy item. (Inherited from WebDAVHierarchyItem.)
Public method | GetMedia | Gets the media. (Inherited from WebDAVMediaItem.)
Protected method | GetMediaPath | Gets the media path. (Inherited from WebDAVHierarchyItem.)
Public method | GetMediaStream | Gets the media stream. (Inherited from WebDAVMediaItem.)
Protected method | GetNewFilePath | Gets the new file path. (Inherited from WebDAVMediaItem.)
Public method | GetProperties | Gets the properties. (Inherited from WebDAVHierarchyItem.)
Public method | GetPropertyNames | Gets the property names. (Inherited from WebDAVHierarchyItem.)
Protected method | GetSitecoreItemLocks | Gets the sitecore item locks. (Inherited from WebDAVHierarchyItem.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IsVersioned | Determines whether this media item is versioned. (Inherited from WebDAVMediaItem.)
Protected method | ItemHasLock | The Item has the lock. (Inherited from WebDAVHierarchyItem.)
Public method | Lock(LockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)
Protected method | Lock(ExLockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)
Protected method | LockSitecoreItem | Locks the sitecore item. (Inherited from WebDAVMediaItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveTo | Moves to destination folder. (Inherited from WebDAVHierarchyItem.)
Public method | RefreshLock | Refreshes the lock. (Inherited from WebDAVHierarchyItem.)
Public method | SaveFromStream | Saves from stream. (Inherited from WebDAVMediaItem.)
Protected method | SupportedAutogenerating | Supporteds the autogenerating. (Inherited from WebDAVMediaItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unlock | Unlocks the specified lock token. (Inherited from WebDAVHierarchyItem.)
Protected method | UnlockSitecoreItem | Unlocks the sitecore item. (Inherited from WebDAVHierarchyItem.)
Public method | UpdateProperties | Updates the properties. (Inherited from WebDAVHierarchyItem.)
Public method | WriteToStream | Writes to stream. (Inherited from WebDAVMediaItem.)

Properties

 | Name | Description
Public property | ActiveLocks | Gets the active locks. (Inherited from WebDAVHierarchyItem.)
Protected property | ClientHasToken | Gets a value indicating whether client has lock tokens. (Inherited from WebDAVHierarchyItem.)
Public property | ContentLength | Gets the length of the content. (Inherited from WebDAVMediaItem.)
Public property | ContentType | Gets the type of the content. (Inherited from WebDAVMediaItem.)
Public property | Created | Gets the created date. (Inherited from WebDAVHierarchyItem.)
Protected property | Engine | Gets the engine. (Inherited from WebDAVHierarchyItem.)
Protected property | InnerItem | Gets or sets the inner item. (Inherited from WebDAVHierarchyItem.)
Protected property | MediaItem | Gets the media item. (Inherited from WebDAVMediaItem.)
Protected property | MediaStream | Gets or sets the media stream. (Inherited from WebDAVMediaItem.)
Public property | Modified | Gets the modified date. (Inherited from WebDAVHierarchyItem.)
Public property | Name | Gets the name. (Overrides WebDAVMediaItem..::..Name.)
Public property | Parent | Gets the parent. (Overrides WebDAVHierarchyItem..::..Parent.)
Public property | Path | Gets the path. (Overrides WebDAVMediaItem..::..Path.)
Public property | UniqueID | Gets the unique ID. (Overrides WebDAVHierarchyItem..::..UniqueID.)
Protected property | View | Gets the Web DAV view. (Inherited from WebDAVHierarchyItem.)

See Also

WebDAVSingleItemVersion Class
Sitecore.Data.Items Namespace


WebDAVSingleItemVersion Constructor

[image]

Sitecore 6.4.1 API
WebDAVSingleItemVersion Constructor
WebDAVSingleItemVersion Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WebDAVSingleItemVersion(
    Media media,
    WebDAVView view,
    WebDAVEngine engine
)
Visual Basic
Public Sub New ( _
    media As Media, _
    view As WebDAVView, _
    engine As WebDAVEngine _
)
Visual C++
public:
WebDAVSingleItemVersion(
    Media^ media,
    WebDAVView^ view,
    WebDAVEngine^ engine
)

Parameters

media
Type: Sitecore.Resources.Media..::..Media
The media.
view
Type: Sitecore.Data.Views..::..WebDAVView
The Web DAV view.
engine
Type: Sitecore.Web..::..WebDAVEngine
The engine.

See Also

WebDAVSingleItemVersion Class
Sitecore.Data.Items Namespace


WebDAVSingleItemVersion Methods

[image] [image]

Sitecore 6.4.1 API
WebDAVSingleItemVersion Methods
WebDAVSingleItemVersion Class See Also Send Feedback

The WebDAVSingleItemVersion type exposes the following members.

Methods

 | Name | Description
Protected method | AddVersion | Adds the version to the item. (Inherited from WebDAVHierarchyItem.)
Protected method | CanExecuteOperation | Validates the operation. (Inherited from WebDAVHierarchyItem.)
Public method | CopyTo | Copies to. (Inherited from WebDAVHierarchyItem.)
Protected method | CreateAndLock | Creates new version and lock the version. (Inherited from WebDAVMediaItem.)
Protected method | CreateNewVersion | Creates the new version. (Overrides WebDAVMediaItem..::..CreateNewVersion()()()().)
Public method | Delete | Deletes current item. (Inherited from WebDAVHierarchyItem.)
Protected method | DoCopyTo | Executes the copy to event. (Overrides WebDAVHierarchyItem..::..DoCopyTo(IFolder, String, Boolean).)
Protected method | DoDelete | Executes the delete event. (Overrides WebDAVHierarchyItem..::..DoDelete()()()().)
Protected method | DoDuplicateVersion | Duplicates current version.
Protected method | DoGetProperties | Executes the get properties event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoGetPropertyNames | Executes the get property names event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoMoveTo | Executes the move to operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoMoveToItem | Executes the move item operation. (Overrides WebDAVHierarchyItem..::..DoMoveToItem(WebDAVFolder, String).)
Protected method | DoRename | Executes the rename operation. (Overrides WebDAVHierarchyItem..::..DoRename(WebDAVFolder, String).)
Protected method | DoUpdateProperties | Executes the update properties event. (Inherited from WebDAVHierarchyItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExtractItemName | Extracts the name of the item. (Inherited from WebDAVHierarchyItem.)
Protected method | ExtractMediaItemPath | Extracts the path of the media item. (Inherited from WebDAVHierarchyItem.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindLocksDown | Finds the locks down. (Inherited from WebDAVHierarchyItem.)
Protected method | GetFullContentPath | Gets the full content path. (Inherited from WebDAVHierarchyItem.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocks | Gets the locks for the specified hierarchy item. (Inherited from WebDAVHierarchyItem.)
Public method | GetMedia | Gets the media. (Inherited from WebDAVMediaItem.)
Protected method | GetMediaPath | Gets the media path. (Inherited from WebDAVHierarchyItem.)
Public method | GetMediaStream | Gets the media stream. (Inherited from WebDAVMediaItem.)
Protected method | GetNewFilePath | Gets the new file path. (Inherited from WebDAVMediaItem.)
Public method | GetProperties | Gets the properties. (Inherited from WebDAVHierarchyItem.)
Public method | GetPropertyNames | Gets the property names. (Inherited from WebDAVHierarchyItem.)
Protected method | GetSitecoreItemLocks | Gets the sitecore item locks. (Inherited from WebDAVHierarchyItem.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IsVersioned | Determines whether this media item is versioned. (Inherited from WebDAVMediaItem.)
Protected method | ItemHasLock | The Item has the lock. (Inherited from WebDAVHierarchyItem.)
Public method | Lock(LockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)
Protected method | Lock(ExLockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)
Protected method | LockSitecoreItem | Locks the sitecore item. (Inherited from WebDAVMediaItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveTo | Moves to destination folder. (Inherited from WebDAVHierarchyItem.)
Public method | RefreshLock | Refreshes the lock. (Inherited from WebDAVHierarchyItem.)
Public method | SaveFromStream | Saves from stream. (Inherited from WebDAVMediaItem.)
Protected method | SupportedAutogenerating | Supporteds the autogenerating. (Inherited from WebDAVMediaItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unlock | Unlocks the specified lock token. (Inherited from WebDAVHierarchyItem.)
Protected method | UnlockSitecoreItem | Unlocks the sitecore item. (Inherited from WebDAVHierarchyItem.)
Public method | UpdateProperties | Updates the properties. (Inherited from WebDAVHierarchyItem.)
Public method | WriteToStream | Writes to stream. (Inherited from WebDAVMediaItem.)

See Also

WebDAVSingleItemVersion Class
Sitecore.Data.Items Namespace


CreateNewVersion Method

[image]

Sitecore 6.4.1 API
WebDAVSingleItemVersion..::..CreateNewVersion Method
WebDAVSingleItemVersion Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override bool CreateNewVersion()
Visual Basic
Protected Overrides Function CreateNewVersion As Boolean
Visual C++
protected:
virtual bool CreateNewVersion() override

Return Value

true if new version should be created.

See Also

WebDAVSingleItemVersion Class
Sitecore.Data.Items Namespace


DoCopyTo Method

[image]

Sitecore 6.4.1 API
WebDAVSingleItemVersion..::..DoCopyTo Method
WebDAVSingleItemVersion Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override WebDAVResponse DoCopyTo(
    IFolder folder,
    string name,
    bool deep
)
Visual Basic
Protected Overrides Function DoCopyTo ( _
    folder As IFolder, _
    name As String, _
    deep As Boolean _
) As WebDAVResponse
Visual C++
protected:
virtual WebDAVResponse^ DoCopyTo(
    IFolder^ folder,
    String^ name,
    bool deep
) override

Parameters

folder
Type: IFolder
The folder.
name
Type: System..::..String
The destination name.
deep
Type: System..::..Boolean
if set to true full subtree will be copied.

Return Value

The WebDAVResponse.

Exceptions

Exception | Condition
System..::..Exception | Cannot set media stream to item version.

See Also

WebDAVSingleItemVersion Class
Sitecore.Data.Items Namespace


DoDuplicateVersion Method

[image]

Sitecore 6.4.1 API
WebDAVSingleItemVersion..::..DoDuplicateVersion Method
WebDAVSingleItemVersion Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual WebDAVResponse DoDuplicateVersion(
    WebDAVLanguageFolder folder
)
Visual Basic
Protected Overridable Function DoDuplicateVersion ( _
    folder As WebDAVLanguageFolder _
) As WebDAVResponse
Visual C++
protected:
virtual WebDAVResponse^ DoDuplicateVersion(
    WebDAVLanguageFolder^ folder
)

Parameters

folder
Type: Sitecore.Data.Items..::..WebDAVLanguageFolder
The folder.

Return Value

The WebDAVResponse.

Exceptions

Exception | Condition
System..::..Exception | Cannot set media stream to item version.

See Also

WebDAVSingleItemVersion Class
Sitecore.Data.Items Namespace


DoMoveToItem Method

[image]

Sitecore 6.4.1 API
WebDAVSingleItemVersion..::..DoMoveToItem Method
WebDAVSingleItemVersion Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override WebDAVResponse DoMoveToItem(
    WebDAVFolder targetItem,
    string destName
)
Visual Basic
Protected Overrides Function DoMoveToItem ( _
    targetItem As WebDAVFolder, _
    destName As String _
) As WebDAVResponse
Visual C++
protected:
virtual WebDAVResponse^ DoMoveToItem(
    WebDAVFolder^ targetItem,
    String^ destName
) override

Parameters

targetItem
Type: Sitecore.Data.Items..::..WebDAVFolder
The target item.
destName
Type: System..::..String
Destination path.

Return Value

The WebDAVResponse.

See Also

WebDAVSingleItemVersion Class
Sitecore.Data.Items Namespace


DoRename Method

[image]

Sitecore 6.4.1 API
WebDAVSingleItemVersion..::..DoRename Method
WebDAVSingleItemVersion Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override WebDAVResponse DoRename(
    WebDAVFolder parent,
    string destName
)
Visual Basic
Protected Overrides Function DoRename ( _
    parent As WebDAVFolder, _
    destName As String _
) As WebDAVResponse
Visual C++
protected:
virtual WebDAVResponse^ DoRename(
    WebDAVFolder^ parent,
    String^ destName
) override

Parameters

parent
Type: Sitecore.Data.Items..::..WebDAVFolder
The item parent.
destName
Type: System..::..String
Destination path.

Return Value

The WebDAVResponse.

See Also

WebDAVSingleItemVersion Class
Sitecore.Data.Items Namespace


Lock Method

[image] [image]

Sitecore 6.4.1 API
WebDAVSingleItemVersion..::..Lock Method
WebDAVSingleItemVersion Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Lock(LockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)
Protected method | Lock(ExLockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)

See Also

WebDAVSingleItemVersion Class
WebDAVSingleItemVersion Members
Sitecore.Data.Items Namespace


WebDAVSingleItemVersion Properties

[image] [image]

Sitecore 6.4.1 API
WebDAVSingleItemVersion Properties
WebDAVSingleItemVersion Class See Also Send Feedback

The WebDAVSingleItemVersion type exposes the following members.

Properties

 | Name | Description
Public property | ActiveLocks | Gets the active locks. (Inherited from WebDAVHierarchyItem.)
Protected property | ClientHasToken | Gets a value indicating whether client has lock tokens. (Inherited from WebDAVHierarchyItem.)
Public property | ContentLength | Gets the length of the content. (Inherited from WebDAVMediaItem.)
Public property | ContentType | Gets the type of the content. (Inherited from WebDAVMediaItem.)
Public property | Created | Gets the created date. (Inherited from WebDAVHierarchyItem.)
Protected property | Engine | Gets the engine. (Inherited from WebDAVHierarchyItem.)
Protected property | InnerItem | Gets or sets the inner item. (Inherited from WebDAVHierarchyItem.)
Protected property | MediaItem | Gets the media item. (Inherited from WebDAVMediaItem.)
Protected property | MediaStream | Gets or sets the media stream. (Inherited from WebDAVMediaItem.)
Public property | Modified | Gets the modified date. (Inherited from WebDAVHierarchyItem.)
Public property | Name | Gets the name. (Overrides WebDAVMediaItem..::..Name.)
Public property | Parent | Gets the parent. (Overrides WebDAVHierarchyItem..::..Parent.)
Public property | Path | Gets the path. (Overrides WebDAVMediaItem..::..Path.)
Public property | UniqueID | Gets the unique ID. (Overrides WebDAVHierarchyItem..::..UniqueID.)
Protected property | View | Gets the Web DAV view. (Inherited from WebDAVHierarchyItem.)

See Also

WebDAVSingleItemVersion Class
Sitecore.Data.Items Namespace


Name Property

[image]

Sitecore 6.4.1 API
WebDAVSingleItemVersion..::..Name Property
WebDAVSingleItemVersion Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The Item name.

Implements

IHierarchyItemName()()()()
IHierarchyItemName()()()()

See Also

WebDAVSingleItemVersion Class
Sitecore.Data.Items Namespace


Parent Property

[image]

Sitecore 6.4.1 API
WebDAVSingleItemVersion..::..Parent Property
WebDAVSingleItemVersion Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override IFolder Parent { get; }
Visual Basic
Public Overrides ReadOnly Property Parent As IFolder
    Get
Visual C++
public:
virtual property IFolder^ Parent {
    IFolder^ get () override;
}

Field Value

The parent.

Implements

IHierarchyItemParent()()()()

See Also

WebDAVSingleItemVersion Class
Sitecore.Data.Items Namespace


Path Property

[image]

Sitecore 6.4.1 API
WebDAVSingleItemVersion..::..Path Property
WebDAVSingleItemVersion Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Path { get; }
Visual Basic
Public Overrides ReadOnly Property Path As String
    Get
Visual C++
public:
virtual property String^ Path {
    String^ get () override;
}

Field Value

The Item path.

Implements

IHierarchyItemPath()()()()
IHierarchyItemPath()()()()

See Also

WebDAVSingleItemVersion Class
Sitecore.Data.Items Namespace


UniqueID Property

[image]

Sitecore 6.4.1 API
WebDAVSingleItemVersion..::..UniqueID Property
WebDAVSingleItemVersion Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string UniqueID { get; }
Visual Basic
Public Overrides ReadOnly Property UniqueID As String
    Get
Visual C++
public:
virtual property String^ UniqueID {
    String^ get () override;
}

Field Value

The unique ID.

See Also

WebDAVSingleItemVersion Class
Sitecore.Data.Items Namespace


WebDAVVersionedMediaItem Class

[image]

Sitecore 6.4.1 API
WebDAVVersionedMediaItem Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class WebDAVVersionedMediaItem : WebDAVFolder
Visual Basic
Public Class WebDAVVersionedMediaItem _
    Inherits WebDAVFolder
Visual C++
public ref class WebDAVVersionedMediaItem : public WebDAVFolder

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..WebDAVHierarchyItem
Sitecore.Data.Items..::..WebDAVFolder
Sitecore.Data.Items..::..WebDAVVersionedMediaItem

See Also

WebDAVVersionedMediaItem Members
Sitecore.Data.Items Namespace


WebDAVVersionedMediaItem Members

[image] [image]

Sitecore 6.4.1 API
WebDAVVersionedMediaItem Members
WebDAVVersionedMediaItem Class Constructors Methods Properties See Also Send Feedback

The WebDAVVersionedMediaItem type exposes the following members.

Constructors

 | Name | Description
Public method | WebDAVVersionedMediaItem | Initializes a new instance of the WebDAVVersionedMediaItem class.

Methods

 | Name | Description
Protected method | AddVersion | Adds the version to the item. (Inherited from WebDAVHierarchyItem.)
Protected method | CanExecuteOperation | Validates the operation. (Inherited from WebDAVHierarchyItem.)
Public method | CopyTo | Copies to. (Inherited from WebDAVHierarchyItem.)
Public method | CreateFolder | Creates the folder. (Inherited from WebDAVFolder.)
Public method | CreateLockNull | Creates the lock null item. (Inherited from WebDAVFolder.)
Public method | CreateResource | Creates the resource. (Inherited from WebDAVFolder.)
Public method | Delete | Deletes current item. (Inherited from WebDAVHierarchyItem.)
Protected method | DoCopyTo | Executes the copy to event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoCreateFolder | Executes the create folder operation. (Inherited from WebDAVFolder.)
Protected method | DoCreateLockNull | Executes the create lock null event. (Inherited from WebDAVFolder.)
Protected method | DoCreateResource | Executes the create resource command. (Inherited from WebDAVFolder.)
Protected method | DoDelete | Executes the delete event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoGetProperties | Executes the get properties event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoGetPropertyNames | Executes the get property names event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoMoveTo | Executes the move to operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoMoveToItem | Executes the move item operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoRename | Executes the rename operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoUpdateProperties | Executes the update properties event. (Inherited from WebDAVHierarchyItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExtractItemName | Extracts the name of the item. (Inherited from WebDAVHierarchyItem.)
Protected method | ExtractMediaItemPath | Extracts the path of the media item. (Inherited from WebDAVHierarchyItem.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindLocksDown | Finds the locks down. (Inherited from WebDAVHierarchyItem.)
Protected method | GetFullContentPath | Gets the full content path. (Inherited from WebDAVHierarchyItem.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocks | Gets the locks for the specified hierarchy item. (Inherited from WebDAVHierarchyItem.)
Protected method | GetMediaPath | Gets the media path. (Inherited from WebDAVHierarchyItem.)
Public method | GetProperties | Gets the properties. (Inherited from WebDAVHierarchyItem.)
Public method | GetPropertyNames | Gets the property names. (Inherited from WebDAVHierarchyItem.)
Protected method | GetSitecoreItemLocks | Gets the sitecore item locks. (Inherited from WebDAVHierarchyItem.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValidFolderName | Gets the name of the valid folder. (Inherited from WebDAVFolder.)
Protected method | ItemHasLock | The Item has the lock. (Inherited from WebDAVHierarchyItem.)
Public method | Lock(LockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)
Protected method | Lock(ExLockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)
Protected method | LockSitecoreItem | Locks the sitecore item. (Inherited from WebDAVHierarchyItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveTo | Moves to destination folder. (Inherited from WebDAVHierarchyItem.)
Public method | RefreshLock | Refreshes the lock. (Inherited from WebDAVHierarchyItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unlock | Unlocks the specified lock token. (Inherited from WebDAVHierarchyItem.)
Protected method | UnlockSitecoreItem | Unlocks the sitecore item. (Inherited from WebDAVHierarchyItem.)
Public method | UpdateProperties | Updates the properties. (Inherited from WebDAVHierarchyItem.)

Properties

 | Name | Description
Public property | ActiveLocks | Gets the active locks. (Inherited from WebDAVHierarchyItem.)
Public property | Children | Gets the children. (Overrides WebDAVFolder..::..Children.)
Protected property | ClientHasToken | Gets a value indicating whether client has lock tokens. (Inherited from WebDAVHierarchyItem.)
Public property | Created | Gets the created date. (Inherited from WebDAVHierarchyItem.)
Protected property | Engine | Gets the engine. (Inherited from WebDAVHierarchyItem.)
Protected property | InnerItem | Gets or sets the inner item. (Inherited from WebDAVHierarchyItem.)
Public property | Modified | Gets the modified date. (Inherited from WebDAVHierarchyItem.)
Public property | Name | Gets the item name. (Inherited from WebDAVHierarchyItem.)
Public property | Parent | Gets the parent. (Inherited from WebDAVHierarchyItem.)
Public property | Path | Gets the item path. (Inherited from WebDAVHierarchyItem.)
Public property | UniqueID | Gets the unique ID. (Inherited from WebDAVHierarchyItem.)
Protected property | View | Gets the Web DAV view. (Inherited from WebDAVHierarchyItem.)

See Also

WebDAVVersionedMediaItem Class
Sitecore.Data.Items Namespace


WebDAVVersionedMediaItem Constructor

[image]

Sitecore 6.4.1 API
WebDAVVersionedMediaItem Constructor
WebDAVVersionedMediaItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WebDAVVersionedMediaItem(
    Item item,
    WebDAVView view,
    WebDAVEngine engine
)
Visual Basic
Public Sub New ( _
    item As Item, _
    view As WebDAVView, _
    engine As WebDAVEngine _
)
Visual C++
public:
WebDAVVersionedMediaItem(
    Item^ item,
    WebDAVView^ view,
    WebDAVEngine^ engine
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item.
view
Type: Sitecore.Data.Views..::..WebDAVView
The Web DAV view.
engine
Type: Sitecore.Web..::..WebDAVEngine
The Web DAV engine.

See Also

WebDAVVersionedMediaItem Class
Sitecore.Data.Items Namespace


WebDAVVersionedMediaItem Methods

[image] [image]

Sitecore 6.4.1 API
WebDAVVersionedMediaItem Methods
WebDAVVersionedMediaItem Class See Also Send Feedback

The WebDAVVersionedMediaItem type exposes the following members.

Methods

 | Name | Description
Protected method | AddVersion | Adds the version to the item. (Inherited from WebDAVHierarchyItem.)
Protected method | CanExecuteOperation | Validates the operation. (Inherited from WebDAVHierarchyItem.)
Public method | CopyTo | Copies to. (Inherited from WebDAVHierarchyItem.)
Public method | CreateFolder | Creates the folder. (Inherited from WebDAVFolder.)
Public method | CreateLockNull | Creates the lock null item. (Inherited from WebDAVFolder.)
Public method | CreateResource | Creates the resource. (Inherited from WebDAVFolder.)
Public method | Delete | Deletes current item. (Inherited from WebDAVHierarchyItem.)
Protected method | DoCopyTo | Executes the copy to event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoCreateFolder | Executes the create folder operation. (Inherited from WebDAVFolder.)
Protected method | DoCreateLockNull | Executes the create lock null event. (Inherited from WebDAVFolder.)
Protected method | DoCreateResource | Executes the create resource command. (Inherited from WebDAVFolder.)
Protected method | DoDelete | Executes the delete event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoGetProperties | Executes the get properties event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoGetPropertyNames | Executes the get property names event. (Inherited from WebDAVHierarchyItem.)
Protected method | DoMoveTo | Executes the move to operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoMoveToItem | Executes the move item operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoRename | Executes the rename operation. (Inherited from WebDAVHierarchyItem.)
Protected method | DoUpdateProperties | Executes the update properties event. (Inherited from WebDAVHierarchyItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExtractItemName | Extracts the name of the item. (Inherited from WebDAVHierarchyItem.)
Protected method | ExtractMediaItemPath | Extracts the path of the media item. (Inherited from WebDAVHierarchyItem.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindLocksDown | Finds the locks down. (Inherited from WebDAVHierarchyItem.)
Protected method | GetFullContentPath | Gets the full content path. (Inherited from WebDAVHierarchyItem.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocks | Gets the locks for the specified hierarchy item. (Inherited from WebDAVHierarchyItem.)
Protected method | GetMediaPath | Gets the media path. (Inherited from WebDAVHierarchyItem.)
Public method | GetProperties | Gets the properties. (Inherited from WebDAVHierarchyItem.)
Public method | GetPropertyNames | Gets the property names. (Inherited from WebDAVHierarchyItem.)
Protected method | GetSitecoreItemLocks | Gets the sitecore item locks. (Inherited from WebDAVHierarchyItem.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValidFolderName | Gets the name of the valid folder. (Inherited from WebDAVFolder.)
Protected method | ItemHasLock | The Item has the lock. (Inherited from WebDAVHierarchyItem.)
Public method | Lock(LockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)
Protected method | Lock(ExLockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)
Protected method | LockSitecoreItem | Locks the sitecore item. (Inherited from WebDAVHierarchyItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveTo | Moves to destination folder. (Inherited from WebDAVHierarchyItem.)
Public method | RefreshLock | Refreshes the lock. (Inherited from WebDAVHierarchyItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unlock | Unlocks the specified lock token. (Inherited from WebDAVHierarchyItem.)
Protected method | UnlockSitecoreItem | Unlocks the sitecore item. (Inherited from WebDAVHierarchyItem.)
Public method | UpdateProperties | Updates the properties. (Inherited from WebDAVHierarchyItem.)

See Also

WebDAVVersionedMediaItem Class
Sitecore.Data.Items Namespace


Lock Method

[image] [image]

Sitecore 6.4.1 API
WebDAVVersionedMediaItem..::..Lock Method
WebDAVVersionedMediaItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Lock(LockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)
Protected method | Lock(ExLockInfo%) | Locks the specified lock info. (Inherited from WebDAVHierarchyItem.)

See Also

WebDAVVersionedMediaItem Class
WebDAVVersionedMediaItem Members
Sitecore.Data.Items Namespace


WebDAVVersionedMediaItem Properties

[image] [image]

Sitecore 6.4.1 API
WebDAVVersionedMediaItem Properties
WebDAVVersionedMediaItem Class See Also Send Feedback

The WebDAVVersionedMediaItem type exposes the following members.

Properties

 | Name | Description
Public property | ActiveLocks | Gets the active locks. (Inherited from WebDAVHierarchyItem.)
Public property | Children | Gets the children. (Overrides WebDAVFolder..::..Children.)
Protected property | ClientHasToken | Gets a value indicating whether client has lock tokens. (Inherited from WebDAVHierarchyItem.)
Public property | Created | Gets the created date. (Inherited from WebDAVHierarchyItem.)
Protected property | Engine | Gets the engine. (Inherited from WebDAVHierarchyItem.)
Protected property | InnerItem | Gets or sets the inner item. (Inherited from WebDAVHierarchyItem.)
Public property | Modified | Gets the modified date. (Inherited from WebDAVHierarchyItem.)
Public property | Name | Gets the item name. (Inherited from WebDAVHierarchyItem.)
Public property | Parent | Gets the parent. (Inherited from WebDAVHierarchyItem.)
Public property | Path | Gets the item path. (Inherited from WebDAVHierarchyItem.)
Public property | UniqueID | Gets the unique ID. (Inherited from WebDAVHierarchyItem.)
Protected property | View | Gets the Web DAV view. (Inherited from WebDAVHierarchyItem.)

See Also

WebDAVVersionedMediaItem Class
Sitecore.Data.Items Namespace


Children Property

[image]

Sitecore 6.4.1 API
WebDAVVersionedMediaItem..::..Children Property
WebDAVVersionedMediaItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override IHierarchyItem[] Children { get; }
Visual Basic
Public Overrides ReadOnly Property Children As IHierarchyItem()
    Get
Visual C++
public:
virtual property array<IHierarchyItem^>^ Children {
    array<IHierarchyItem^>^ get () override;
}

Field Value

The children.

Implements

IFolderChildren()()()()

Exceptions

Exception | Condition
System..::..Exception | Cannot get the children for the folder.

See Also

WebDAVVersionedMediaItem Class
Sitecore.Data.Items Namespace


WebEditButtonItem Class

[image]

Sitecore 6.4.1 API
WebEditButtonItem Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class WebEditButtonItem : CustomItem
Visual Basic
Public Class WebEditButtonItem _
    Inherits CustomItem
Visual C++
public ref class WebEditButtonItem : public CustomItem

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Items..::..CustomItemBase
Sitecore.Data.Items..::..CustomItem
Sitecore.Data.Items..::..WebEditButtonItem

See Also

WebEditButtonItem Members
Sitecore.Data.Items Namespace


WebEditButtonItem Constructor

[image]

Sitecore 6.4.1 API
WebEditButtonItem Constructor
WebEditButtonItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WebEditButtonItem(
    Item innerItem
)
Visual Basic
Public Sub New ( _
    innerItem As Item _
)
Visual C++
public:
WebEditButtonItem(
    Item^ innerItem
)

Parameters

innerItem
Type: Sitecore.Data.Items..::..Item
Inner item.

See Also

WebEditButtonItem Class
Sitecore.Data.Items Namespace


WebEditButtonItem Methods

[image] [image]

Sitecore 6.4.1 API
WebEditButtonItem Methods
WebEditButtonItem Class See Also Send Feedback

The WebEditButtonItem type exposes the following members.

Methods

 | Name | Description
Public method | BeginEdit | Begins editing the item. (Inherited from CustomItemBase.)
Public method | EndEdit | Ends editing the item. (Inherited from CustomItemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetButton | Gets the button.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WebEditButtonItem Class
Sitecore.Data.Items Namespace


GetButton Method

[image]

Sitecore 6.4.1 API
WebEditButtonItem..::..GetButton Method
WebEditButtonItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WebEditButton GetButton()
Visual Basic
Public Function GetButton As WebEditButton
Visual C++
public:
WebEditButton^ GetButton()

Return Value

The web edit button.

See Also

WebEditButtonItem Class
Sitecore.Data.Items Namespace


WebEditButtonItem Type Conversions

[image] [image]

Sitecore 6.4.1 API
WebEditButtonItem Type Conversions
WebEditButtonItem Class See Also Send Feedback

The WebEditButtonItem type exposes the following members.

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Item to WebEditButtonItem) | Converts an item to a DeviceItem.

See Also

WebEditButtonItem Class
Sitecore.Data.Items Namespace


Implicit Conversion (Item to WebEditButtonItem)

[image]

Sitecore 6.4.1 API
WebEditButtonItem ImplicitWideningImplicitImplicitImplicit Conversion (Item to WebEditButtonItem)
WebEditButtonItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator WebEditButtonItem (
    Item item
)
Visual Basic
Public Shared Widening Operator CType ( _
    item As Item _
) As WebEditButtonItem
Visual C++
static implicit operator WebEditButtonItem^ (
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

The result of the conversion.

See Also

WebEditButtonItem Class
Sitecore.Data.Items Namespace


WebEditButtonItem Properties

[image] [image]

Sitecore 6.4.1 API
WebEditButtonItem Properties
WebEditButtonItem Class See Also Send Feedback

The WebEditButtonItem type exposes the following members.

Properties

 | Name | Description
Public property | Click | Gets or sets the Click event.
Public property | Database | Gets the database. (Inherited from CustomItemBase.)
Public property | DisplayName | Gets the display name. (Inherited from CustomItemBase.)
Public property | Header | Gets or sets the header.
Public property | Icon | Gets or sets the icon.
Public property | ID | Gets the ID. (Inherited from CustomItemBase.)
Public property | InnerItem | Gets the inner item. (Inherited from CustomItemBase.)
Public property | Item[([( Int32])]) | Gets or sets the value of a specified field. (Inherited from CustomItem.)
Public property | Item[([( String])]) | Gets or sets the value of a specified field. (Inherited from CustomItem.)
Public property | Item[([( ID])]) | Gets or sets the value of a specified field. (Inherited from CustomItem.)
Public property | Name | Gets the name. (Inherited from CustomItemBase.)
Public property | Parameters | Gets the parameters.
Public property | Tooltip | Gets or sets the tooltip.

See Also

WebEditButtonItem Class
Sitecore.Data.Items Namespace


Click Property

[image]

Sitecore 6.4.1 API
WebEditButtonItem..::..Click Property
WebEditButtonItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Click { get; set; }
Visual Basic
Public Property Click As String
    Get
    Set
Visual C++
public:
property String^ Click {
    String^ get ();
    void set (String^ value);
}

Field Value

The event to be executed.

See Also

WebEditButtonItem Class
Sitecore.Data.Items Namespace


Header Property

[image]

Sitecore 6.4.1 API
WebEditButtonItem..::..Header Property
WebEditButtonItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Header { get; set; }
Visual Basic
Public Property Header As String
    Get
    Set
Visual C++
public:
property String^ Header {
    String^ get ();
    void set (String^ value);
}

Field Value

The header.

See Also

WebEditButtonItem Class
Sitecore.Data.Items Namespace


Icon Property

[image]

Sitecore 6.4.1 API
WebEditButtonItem..::..Icon Property
WebEditButtonItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Icon { get; set; }
Visual Basic
Public Property Icon As String
    Get
    Set
Visual C++
public:
property String^ Icon {
    String^ get ();
    void set (String^ value);
}

Field Value

The icon.

Remarks

See Also

WebEditButtonItem Class
Sitecore.Data.Items Namespace
ItemAppearance..::..Icon


Item Property

[image] [image]

Sitecore 6.4.1 API
WebEditButtonItem..::..Item Property
WebEditButtonItem Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gets or sets the value of a specified field. (Inherited from CustomItem.)
Public property | Item[([( String])]) | Gets or sets the value of a specified field. (Inherited from CustomItem.)
Public property | Item[([( ID])]) | Gets or sets the value of a specified field. (Inherited from CustomItem.)

See Also

WebEditButtonItem Class
WebEditButtonItem Members
Sitecore.Data.Items Namespace


Parameters Property

[image]

Sitecore 6.4.1 API
WebEditButtonItem..::..Parameters Property
WebEditButtonItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SafeDictionary<string> Parameters { get; }
Visual Basic
Public ReadOnly Property Parameters As SafeDictionary(Of String)
    Get
Visual C++
public:
property SafeDictionary<String^>^ Parameters {
    SafeDictionary<String^>^ get ();
}

Field Value

The parameters.

See Also

WebEditButtonItem Class
Sitecore.Data.Items Namespace


Tooltip Property

[image]

Sitecore 6.4.1 API
WebEditButtonItem..::..Tooltip Property
WebEditButtonItem Class See Also Send Feedback

Namespace: Sitecore.Data.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Tooltip { get; set; }
Visual Basic
Public Property Tooltip As String
    Get
    Set
Visual C++
public:
property String^ Tooltip {
    String^ get ();
    void set (String^ value);
}

Field Value

The tooltip.

See Also

WebEditButtonItem Class
Sitecore.Data.Items Namespace


Sitecore.Data.Locking Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Data.Locking Namespace
Send Feedback

Classes

 | Class | Description
Public class | ExLockInfo | Extended Lock Info
Public class | IDTableWebDAVLockingProvider | Stores lock information in IDTable.
Public class | ItemLocking | Represents the locking state of an item.
Public class | WebDAVCacheLockNullProvider | Stores LockNull items in static cache.
Public class | WebDAVLockingProvider | Base class for Web DAV locking providers.
Public class | WebDAVLockingProviderCollection | Represents Web DAV Locking Collection.
Public class | WebDAVLockNullProvider | Web DAV Lock null provider.
Public class | WebDAVLockNullProviderCollection | Web DAV lock null provider collection.


ExLockInfo Class

[image]

Sitecore 6.4.1 API
ExLockInfo Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ExLockInfo
Visual Basic
Public Class ExLockInfo
Visual C++
public ref class ExLockInfo

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Locking..::..ExLockInfo

See Also

ExLockInfo Members
Sitecore.Data.Locking Namespace


ExLockInfo Members

[image] [image]

Sitecore 6.4.1 API
ExLockInfo Members
ExLockInfo Class Constructors Methods Properties See Also Send Feedback

The ExLockInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ExLockInfo()()()() | Initializes a new instance of the ExLockInfo class.
Public method | ExLockInfo(LockInfo) | Initializes a new instance of the ExLockInfo class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Deep | Gets or sets a value indicating whether this ExLockInfo is deep.
Public property | LockDate | Gets or sets the lock date.
Public property | LockInfo | Gets the lock info.
Public property | Owner | Gets or sets the owner.
Public property | Shared | Gets or sets a value indicating whether this ExLockInfo is shared.
Public property | Timeout | Gets or sets the timeout.
Public property | Token | Gets or sets the token.

See Also

ExLockInfo Class
Sitecore.Data.Locking Namespace


ExLockInfo Constructor

[image] [image]

Sitecore 6.4.1 API
ExLockInfo Constructor
ExLockInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExLockInfo()()()() | Initializes a new instance of the ExLockInfo class.
Public method | ExLockInfo(LockInfo) | Initializes a new instance of the ExLockInfo class.

See Also

ExLockInfo Class
ExLockInfo Members
Sitecore.Data.Locking Namespace


ExLockInfo Constructor

[image]

Sitecore 6.4.1 API
ExLockInfo Constructor
ExLockInfo Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ExLockInfo()
Visual Basic
Public Sub New
Visual C++
public:
ExLockInfo()

See Also

ExLockInfo Class
ExLockInfo Overload
Sitecore.Data.Locking Namespace


ExLockInfo Constructor ()

[image]

Sitecore 6.4.1 API
ExLockInfo Constructor ()
ExLockInfo Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ExLockInfo(
    LockInfo lockInfo
)
Visual Basic
Public Sub New ( _
    lockInfo As LockInfo _
)
Visual C++
public:
ExLockInfo(
    LockInfo lockInfo
)

Parameters

lockInfo
Type: LockInfo
The lock info.

See Also

ExLockInfo Class
ExLockInfo Overload
Sitecore.Data.Locking Namespace


ExLockInfo Methods

[image] [image]

Sitecore 6.4.1 API
ExLockInfo Methods
ExLockInfo Class See Also Send Feedback

The ExLockInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExLockInfo Class
Sitecore.Data.Locking Namespace


ExLockInfo Properties

[image] [image]

Sitecore 6.4.1 API
ExLockInfo Properties
ExLockInfo Class See Also Send Feedback

The ExLockInfo type exposes the following members.

Properties

 | Name | Description
Public property | Deep | Gets or sets a value indicating whether this ExLockInfo is deep.
Public property | LockDate | Gets or sets the lock date.
Public property | LockInfo | Gets the lock info.
Public property | Owner | Gets or sets the owner.
Public property | Shared | Gets or sets a value indicating whether this ExLockInfo is shared.
Public property | Timeout | Gets or sets the timeout.
Public property | Token | Gets or sets the token.

See Also

ExLockInfo Class
Sitecore.Data.Locking Namespace


Deep Property

[image]

Sitecore 6.4.1 API
ExLockInfo..::..Deep Property
ExLockInfo Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Deep { get; set; }
Visual Basic
Public Property Deep As Boolean
    Get
    Set
Visual C++
public:
property bool Deep {
    bool get ();
    void set (bool value);
}

Field Value

true if deep; otherwise, false.

See Also

ExLockInfo Class
Sitecore.Data.Locking Namespace


LockDate Property

[image]

Sitecore 6.4.1 API
ExLockInfo..::..LockDate Property
ExLockInfo Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime LockDate { get; set; }
Visual Basic
Public Property LockDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime LockDate {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The lock date.

See Also

ExLockInfo Class
Sitecore.Data.Locking Namespace


LockInfo Property

[image]

Sitecore 6.4.1 API
ExLockInfo..::..LockInfo Property
ExLockInfo Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LockInfo LockInfo { get; }
Visual Basic
Public ReadOnly Property LockInfo As LockInfo
    Get
Visual C++
public:
property LockInfo LockInfo {
    LockInfo get ();
}

Field Value

The lock info.

See Also

ExLockInfo Class
Sitecore.Data.Locking Namespace


Owner Property

[image]

Sitecore 6.4.1 API
ExLockInfo..::..Owner Property
ExLockInfo Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Owner { get; set; }
Visual Basic
Public Property Owner As String
    Get
    Set
Visual C++
public:
property String^ Owner {
    String^ get ();
    void set (String^ value);
}

Field Value

The owner.

See Also

ExLockInfo Class
Sitecore.Data.Locking Namespace


Shared Property

[image]

Sitecore 6.4.1 API
ExLockInfo..::..Shared Property
ExLockInfo Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Shared { get; set; }
Visual Basic
Public Property Shared As Boolean
    Get
    Set
Visual C++
public:
property bool Shared {
    bool get ();
    void set (bool value);
}

Field Value

true if shared; otherwise, false.

See Also

ExLockInfo Class
Sitecore.Data.Locking Namespace


Timeout Property

[image]

Sitecore 6.4.1 API
ExLockInfo..::..Timeout Property
ExLockInfo Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long Timeout { get; set; }
Visual Basic
Public Property Timeout As Long
    Get
    Set
Visual C++
public:
property long long Timeout {
    long long get ();
    void set (long long value);
}

Field Value

The timeout.

See Also

ExLockInfo Class
Sitecore.Data.Locking Namespace


Token Property

[image]

Sitecore 6.4.1 API
ExLockInfo..::..Token Property
ExLockInfo Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Token { get; set; }
Visual Basic
Public Property Token As String
    Get
    Set
Visual C++
public:
property String^ Token {
    String^ get ();
    void set (String^ value);
}

Field Value

The token.

See Also

ExLockInfo Class
Sitecore.Data.Locking Namespace


IDTableWebDAVLockingProvider Class

[image]

Sitecore 6.4.1 API
IDTableWebDAVLockingProvider Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class IDTableWebDAVLockingProvider : WebDAVLockingProvider
Visual Basic
Public Class IDTableWebDAVLockingProvider _
    Inherits WebDAVLockingProvider
Visual C++
public ref class IDTableWebDAVLockingProvider : public WebDAVLockingProvider

Inheritance Hierarchy

System..::..Object
System.Configuration.Provider..::..ProviderBase
Sitecore.Data.Locking..::..WebDAVLockingProvider
Sitecore.Data.Locking..::..IDTableWebDAVLockingProvider

See Also

IDTableWebDAVLockingProvider Members
Sitecore.Data.Locking Namespace


IDTableWebDAVLockingProvider Members

[image] [image]

Sitecore 6.4.1 API
IDTableWebDAVLockingProvider Members
IDTableWebDAVLockingProvider Class Constructors Methods Properties See Also Send Feedback

The IDTableWebDAVLockingProvider type exposes the following members.

Constructors

 | Name | Description
Public method | IDTableWebDAVLockingProvider | Initializes a new instance of the IDTableWebDAVLockingProvider class

Methods

 | Name | Description
Protected method | AddLock(String, ExLockInfo) | Adds the lock. (Overrides WebDAVLockingProvider..::..AddLock(String, ExLockInfo).)
Public method | AddLock(WebDAVHierarchyItem, ExLockInfo) | Locks the specified item. (Inherited from WebDAVLockingProvider.)
Protected method | AddLocks | Adds the lock.
Protected method | DeserializeLock | Deserializes the lock. (Inherited from WebDAVLockingProvider.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocks(String) | Gets the locks. (Overrides WebDAVLockingProvider..::..GetLocks(String).)
Public method | GetLocks(WebDAVHierarchyItem, Boolean) | Gets the locks. (Inherited from WebDAVLockingProvider.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the provider. (Inherited from ProviderBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RemoveLock(String, String) | Removes the lock. (Overrides WebDAVLockingProvider..::..RemoveLock(String, String).)
Public method | RemoveLock(WebDAVHierarchyItem, String) | Removes the lock. (Inherited from WebDAVLockingProvider.)
Protected method | SerializeLock | Serializes the lock. (Inherited from WebDAVLockingProvider.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLock(WebDAVHierarchyItem, ExLockInfo) | Updates the lock. (Inherited from WebDAVLockingProvider.)
Protected method | UpdateLock(String, String, Int64) | Updates the lock. (Overrides WebDAVLockingProvider..::..UpdateLock(String, String, Int64).)

Properties

 | Name | Description
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

IDTableWebDAVLockingProvider Class
Sitecore.Data.Locking Namespace


IDTableWebDAVLockingProvider Methods

[image] [image]

Sitecore 6.4.1 API
IDTableWebDAVLockingProvider Methods
IDTableWebDAVLockingProvider Class See Also Send Feedback

The IDTableWebDAVLockingProvider type exposes the following members.

Methods

 | Name | Description
Protected method | AddLock(String, ExLockInfo) | Adds the lock. (Overrides WebDAVLockingProvider..::..AddLock(String, ExLockInfo).)
Public method | AddLock(WebDAVHierarchyItem, ExLockInfo) | Locks the specified item. (Inherited from WebDAVLockingProvider.)
Protected method | AddLocks | Adds the lock.
Protected method | DeserializeLock | Deserializes the lock. (Inherited from WebDAVLockingProvider.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocks(String) | Gets the locks. (Overrides WebDAVLockingProvider..::..GetLocks(String).)
Public method | GetLocks(WebDAVHierarchyItem, Boolean) | Gets the locks. (Inherited from WebDAVLockingProvider.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the provider. (Inherited from ProviderBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RemoveLock(String, String) | Removes the lock. (Overrides WebDAVLockingProvider..::..RemoveLock(String, String).)
Public method | RemoveLock(WebDAVHierarchyItem, String) | Removes the lock. (Inherited from WebDAVLockingProvider.)
Protected method | SerializeLock | Serializes the lock. (Inherited from WebDAVLockingProvider.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLock(WebDAVHierarchyItem, ExLockInfo) | Updates the lock. (Inherited from WebDAVLockingProvider.)
Protected method | UpdateLock(String, String, Int64) | Updates the lock. (Overrides WebDAVLockingProvider..::..UpdateLock(String, String, Int64).)

See Also

IDTableWebDAVLockingProvider Class
Sitecore.Data.Locking Namespace


AddLock Method

[image] [image]

Sitecore 6.4.1 API
IDTableWebDAVLockingProvider..::..AddLock Method
IDTableWebDAVLockingProvider Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AddLock(String, ExLockInfo) | Adds the lock. (Overrides WebDAVLockingProvider..::..AddLock(String, ExLockInfo).)
Public method | AddLock(WebDAVHierarchyItem, ExLockInfo) | Locks the specified item. (Inherited from WebDAVLockingProvider.)

See Also

IDTableWebDAVLockingProvider Class
IDTableWebDAVLockingProvider Members
Sitecore.Data.Locking Namespace


AddLock Method (String, ExLockInfo)

[image]

Sitecore 6.4.1 API
IDTableWebDAVLockingProvider..::..AddLock Method (String, ExLockInfo)
IDTableWebDAVLockingProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override bool AddLock(
    string key,
    ExLockInfo lockInfo
)
Visual Basic
Protected Overrides Function AddLock ( _
    key As String, _
    lockInfo As ExLockInfo _
) As Boolean
Visual C++
protected:
virtual bool AddLock(
    String^ key,
    ExLockInfo^ lockInfo
) override

Parameters

key
Type: System..::..String
The unique key.
lockInfo
Type: Sitecore.Data.Locking..::..ExLockInfo
The lock info.

Return Value

true if item has been locked.

See Also

IDTableWebDAVLockingProvider Class
AddLock Overload
Sitecore.Data.Locking Namespace


AddLocks Method

[image]

Sitecore 6.4.1 API
IDTableWebDAVLockingProvider..::..AddLocks Method
IDTableWebDAVLockingProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected bool AddLocks(
    string key,
    ExLockInfo[] locks
)
Visual Basic
Protected Function AddLocks ( _
    key As String, _
    locks As ExLockInfo() _
) As Boolean
Visual C++
protected:
bool AddLocks(
    String^ key,
    array<ExLockInfo^>^ locks
)

Parameters

key
Type: System..::..String
The unique key.
locks
Type: array< Sitecore.Data.Locking..::..ExLockInfo >[]()[][]
The locks array.

Return Value

true if item has been locked.

See Also

IDTableWebDAVLockingProvider Class
Sitecore.Data.Locking Namespace


GetLocks Method

[image] [image]

Sitecore 6.4.1 API
IDTableWebDAVLockingProvider..::..GetLocks Method
IDTableWebDAVLockingProvider Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetLocks(String) | Gets the locks. (Overrides WebDAVLockingProvider..::..GetLocks(String).)
Public method | GetLocks(WebDAVHierarchyItem, Boolean) | Gets the locks. (Inherited from WebDAVLockingProvider.)

See Also

IDTableWebDAVLockingProvider Class
IDTableWebDAVLockingProvider Members
Sitecore.Data.Locking Namespace


GetLocks Method (String)

[image]

Sitecore 6.4.1 API
IDTableWebDAVLockingProvider..::..GetLocks Method (String)
IDTableWebDAVLockingProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override List<ExLockInfo> GetLocks(
    string key
)
Visual Basic
Protected Overrides Function GetLocks ( _
    key As String _
) As List(Of ExLockInfo)
Visual C++
protected:
virtual List<ExLockInfo^>^ GetLocks(
    String^ key
) override

Parameters

key
Type: System..::..String
The unique key.

Return Value

List of locks for the specified hierarchy item.

See Also

IDTableWebDAVLockingProvider Class
GetLocks Overload
Sitecore.Data.Locking Namespace


RemoveLock Method

[image] [image]

Sitecore 6.4.1 API
IDTableWebDAVLockingProvider..::..RemoveLock Method
IDTableWebDAVLockingProvider Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RemoveLock(String, String) | Removes the lock. (Overrides WebDAVLockingProvider..::..RemoveLock(String, String).)
Public method | RemoveLock(WebDAVHierarchyItem, String) | Removes the lock. (Inherited from WebDAVLockingProvider.)

See Also

IDTableWebDAVLockingProvider Class
IDTableWebDAVLockingProvider Members
Sitecore.Data.Locking Namespace


RemoveLock Method (String, String)

[image]

Sitecore 6.4.1 API
IDTableWebDAVLockingProvider..::..RemoveLock Method (String, String)
IDTableWebDAVLockingProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override bool RemoveLock(
    string key,
    string lockToken
)
Visual Basic
Protected Overrides Function RemoveLock ( _
    key As String, _
    lockToken As String _
) As Boolean
Visual C++
protected:
virtual bool RemoveLock(
    String^ key,
    String^ lockToken
) override

Parameters

key
Type: System..::..String
The unique key.
lockToken
Type: System..::..String
The lock token.

Return Value

true if lock has been removed.

See Also

IDTableWebDAVLockingProvider Class
RemoveLock Overload
Sitecore.Data.Locking Namespace


UpdateLock Method (String, String, Int64)

[image]

Sitecore 6.4.1 API
IDTableWebDAVLockingProvider..::..UpdateLock Method (String, String, Int64)
IDTableWebDAVLockingProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override bool UpdateLock(
    string key,
    string lockToken,
    long timeout
)
Visual Basic
Protected Overrides Function UpdateLock ( _
    key As String, _
    lockToken As String, _
    timeout As Long _
) As Boolean
Visual C++
protected:
virtual bool UpdateLock(
    String^ key,
    String^ lockToken,
    long long timeout
) override

Parameters

key
Type: System..::..String
The unique key.
lockToken
Type: System..::..String
The lock token ID.
timeout
Type: System..::..Int64
The timeout.

Return Value

true if lock has been updated.

See Also

IDTableWebDAVLockingProvider Class
UpdateLock Overload
Sitecore.Data.Locking Namespace


IDTableWebDAVLockingProvider Properties

[image] [image]

Sitecore 6.4.1 API
IDTableWebDAVLockingProvider Properties
IDTableWebDAVLockingProvider Class See Also Send Feedback

The IDTableWebDAVLockingProvider type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

IDTableWebDAVLockingProvider Class
Sitecore.Data.Locking Namespace


ItemLocking Class

[image]

Sitecore 6.4.1 API
ItemLocking Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemLocking
Visual Basic
Public Class ItemLocking
Visual C++
public ref class ItemLocking

Remarks

Locking ensures that only one user can edit an item at a time.

Locking is tightly integrated with workflows.

Locking information is stored on the item in the field "__Lock".

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Locking..::..ItemLocking

See Also

ItemLocking Members
Sitecore.Data.Locking Namespace


ItemLocking Members

[image] [image]

Sitecore 6.4.1 API
ItemLocking Members
ItemLocking Class Constructors Methods See Also Send Feedback

The ItemLocking type exposes the following members.

Constructors

 | Name | Description
Public method | ItemLocking | Creates a new ItemLocking instance.

Methods

 | Name | Description
Public method | CanLock | Determines whether this item can be locked by the current user.
Public method | CanUnlock | Determines whether the current user can unlock this item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDatabaseName | Gets the name of the database.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOwner | Gets the user that owns the current lock.
Public method | GetOwnerWithoutDomain | Gets the user that owns the current lock.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasLock | Determines whether the current user has a lock on the item.
Public method | IsLocked | Determines whether the item is locked by a user.
Public method | Lock | Locks the item.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unlock | Unlocks the item.

See Also

ItemLocking Class
Sitecore.Data.Locking Namespace


ItemLocking Constructor

[image]

Sitecore 6.4.1 API
ItemLocking Constructor
ItemLocking Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemLocking(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
ItemLocking(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
Item.

See Also

ItemLocking Class
Sitecore.Data.Locking Namespace


ItemLocking Methods

[image] [image]

Sitecore 6.4.1 API
ItemLocking Methods
ItemLocking Class See Also Send Feedback

The ItemLocking type exposes the following members.

Methods

 | Name | Description
Public method | CanLock | Determines whether this item can be locked by the current user.
Public method | CanUnlock | Determines whether the current user can unlock this item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDatabaseName | Gets the name of the database.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOwner | Gets the user that owns the current lock.
Public method | GetOwnerWithoutDomain | Gets the user that owns the current lock.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasLock | Determines whether the current user has a lock on the item.
Public method | IsLocked | Determines whether the item is locked by a user.
Public method | Lock | Locks the item.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unlock | Unlocks the item.

See Also

ItemLocking Class
Sitecore.Data.Locking Namespace


CanLock Method

[image]

Sitecore 6.4.1 API
ItemLocking..::..CanLock Method
ItemLocking Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool CanLock()
Visual Basic
Public Function CanLock As Boolean
Visual C++
public:
bool CanLock()

Return Value

true if this item can be locked by the current user; otherwise, false.

See Also

ItemLocking Class
Sitecore.Data.Locking Namespace


CanUnlock Method

[image]

Sitecore 6.4.1 API
ItemLocking..::..CanUnlock Method
ItemLocking Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool CanUnlock()
Visual Basic
Public Function CanUnlock As Boolean
Visual C++
public:
bool CanUnlock()

Return Value

true if the current user can unlock this item; otherwise, false.

See Also

ItemLocking Class
Sitecore.Data.Locking Namespace


GetDatabaseName Method

[image]

Sitecore 6.4.1 API
ItemLocking..::..GetDatabaseName Method
ItemLocking Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void GetDatabaseName()
Visual Basic
Public Sub GetDatabaseName
Visual C++
public:
void GetDatabaseName()

See Also

ItemLocking Class
Sitecore.Data.Locking Namespace


GetOwner Method

[image]

Sitecore 6.4.1 API
ItemLocking..::..GetOwner Method
ItemLocking Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetOwner()
Visual Basic
Public Function GetOwner As String
Visual C++
public:
String^ GetOwner()

Return Value

The owner.

See Also

ItemLocking Class
Sitecore.Data.Locking Namespace


GetOwnerWithoutDomain Method

[image]

Sitecore 6.4.1 API
ItemLocking..::..GetOwnerWithoutDomain Method
ItemLocking Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetOwnerWithoutDomain()
Visual Basic
Public Function GetOwnerWithoutDomain As String
Visual C++
public:
String^ GetOwnerWithoutDomain()

Return Value

The owner.

See Also

ItemLocking Class
Sitecore.Data.Locking Namespace


HasLock Method

[image]

Sitecore 6.4.1 API
ItemLocking..::..HasLock Method
ItemLocking Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool HasLock()
Visual Basic
Public Function HasLock As Boolean
Visual C++
public:
bool HasLock()

Return Value

true if the current user has a lock on the item; otherwise, false.

See Also

ItemLocking Class
Sitecore.Data.Locking Namespace


IsLocked Method

[image]

Sitecore 6.4.1 API
ItemLocking..::..IsLocked Method
ItemLocking Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsLocked()
Visual Basic
Public Function IsLocked As Boolean
Visual C++
public:
bool IsLocked()

Return Value

true if the item is locked by a user; otherwise, false.

See Also

ItemLocking Class
Sitecore.Data.Locking Namespace


Lock Method

[image]

Sitecore 6.4.1 API
ItemLocking..::..Lock Method
ItemLocking Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Lock()
Visual Basic
Public Function Lock As Boolean
Visual C++
public:
bool Lock()

Return Value

The lock.

See Also

ItemLocking Class
Sitecore.Data.Locking Namespace


Unlock Method

[image]

Sitecore 6.4.1 API
ItemLocking..::..Unlock Method
ItemLocking Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Unlock()
Visual Basic
Public Function Unlock As Boolean
Visual C++
public:
bool Unlock()

Return Value

The unlock.

See Also

ItemLocking Class
Sitecore.Data.Locking Namespace


WebDAVCacheLockNullProvider Class

[image]

Sitecore 6.4.1 API
WebDAVCacheLockNullProvider Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class WebDAVCacheLockNullProvider : WebDAVLockNullProvider
Visual Basic
Public Class WebDAVCacheLockNullProvider _
    Inherits WebDAVLockNullProvider
Visual C++
public ref class WebDAVCacheLockNullProvider : public WebDAVLockNullProvider

Inheritance Hierarchy

System..::..Object
System.Configuration.Provider..::..ProviderBase
Sitecore.Data.Locking..::..WebDAVLockNullProvider
Sitecore.Data.Locking..::..WebDAVCacheLockNullProvider

See Also

WebDAVCacheLockNullProvider Members
Sitecore.Data.Locking Namespace


WebDAVCacheLockNullProvider Members

[image] [image]

Sitecore 6.4.1 API
WebDAVCacheLockNullProvider Members
WebDAVCacheLockNullProvider Class Constructors Methods Properties See Also Send Feedback

The WebDAVCacheLockNullProvider type exposes the following members.

Constructors

 | Name | Description
Public method | WebDAVCacheLockNullProvider | Initializes a new instance of the WebDAVCacheLockNullProvider class

Methods

 | Name | Description
Protected method | AddItemUri | Adds the item URI. (Overrides WebDAVLockNullProvider..::..AddItemUri(ItemUri).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindChildren | Finds the item children. (Inherited from WebDAVLockNullProvider.)
Public method | FindLockNullItemByPath | Finds the lock null item by path. (Inherited from WebDAVLockNullProvider.)
Protected method | GetChildUris | Gets the uris of child items. (Overrides WebDAVLockNullProvider..::..GetChildUris(ItemUri, Boolean).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetItemUriByPath | Gets the item URI by path. (Overrides WebDAVLockNullProvider..::..GetItemUriByPath(String).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the provider. (Inherited from ProviderBase.)
Protected method | IsItemUriExists(String) | Determines whether Item URI with the specified path exists or not.
Protected method | IsItemUriExists(ItemUri) | Determines whether URI is already registered or not. (Overrides WebDAVLockNullProvider..::..IsItemUriExists(ItemUri).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RegisterLockNullItem | Registers the lock null item. (Inherited from WebDAVLockNullProvider.)
Protected method | RemoveItemUri | Removes the item URI. (Overrides WebDAVLockNullProvider..::..RemoveItemUri(ItemUri).)
Public method | RemoveLockNullItem | Removes the lock null item. (Inherited from WebDAVLockNullProvider.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

WebDAVCacheLockNullProvider Class
Sitecore.Data.Locking Namespace


WebDAVCacheLockNullProvider Methods

[image] [image]

Sitecore 6.4.1 API
WebDAVCacheLockNullProvider Methods
WebDAVCacheLockNullProvider Class See Also Send Feedback

The WebDAVCacheLockNullProvider type exposes the following members.

Methods

 | Name | Description
Protected method | AddItemUri | Adds the item URI. (Overrides WebDAVLockNullProvider..::..AddItemUri(ItemUri).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindChildren | Finds the item children. (Inherited from WebDAVLockNullProvider.)
Public method | FindLockNullItemByPath | Finds the lock null item by path. (Inherited from WebDAVLockNullProvider.)
Protected method | GetChildUris | Gets the uris of child items. (Overrides WebDAVLockNullProvider..::..GetChildUris(ItemUri, Boolean).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetItemUriByPath | Gets the item URI by path. (Overrides WebDAVLockNullProvider..::..GetItemUriByPath(String).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the provider. (Inherited from ProviderBase.)
Protected method | IsItemUriExists(String) | Determines whether Item URI with the specified path exists or not.
Protected method | IsItemUriExists(ItemUri) | Determines whether URI is already registered or not. (Overrides WebDAVLockNullProvider..::..IsItemUriExists(ItemUri).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RegisterLockNullItem | Registers the lock null item. (Inherited from WebDAVLockNullProvider.)
Protected method | RemoveItemUri | Removes the item URI. (Overrides WebDAVLockNullProvider..::..RemoveItemUri(ItemUri).)
Public method | RemoveLockNullItem | Removes the lock null item. (Inherited from WebDAVLockNullProvider.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WebDAVCacheLockNullProvider Class
Sitecore.Data.Locking Namespace


AddItemUri Method

[image]

Sitecore 6.4.1 API
WebDAVCacheLockNullProvider..::..AddItemUri Method
WebDAVCacheLockNullProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override bool AddItemUri(
    ItemUri uri
)
Visual Basic
Protected Overrides Function AddItemUri ( _
    uri As ItemUri _
) As Boolean
Visual C++
protected:
virtual bool AddItemUri(
    ItemUri^ uri
) override

Parameters

uri
Type: Sitecore.Data..::..ItemUri
The LockNull Item URI.

Return Value

true if Item Uri has been added.

See Also

WebDAVCacheLockNullProvider Class
Sitecore.Data.Locking Namespace


GetChildUris Method

[image]

Sitecore 6.4.1 API
WebDAVCacheLockNullProvider..::..GetChildUris Method
WebDAVCacheLockNullProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override List<ItemUri> GetChildUris(
    ItemUri uri,
    bool deep
)
Visual Basic
Protected Overrides Function GetChildUris ( _
    uri As ItemUri, _
    deep As Boolean _
) As List(Of ItemUri)
Visual C++
protected:
virtual List<ItemUri^>^ GetChildUris(
    ItemUri^ uri,
    bool deep
) override

Parameters

uri
Type: Sitecore.Data..::..ItemUri
The Item URI.
deep
Type: System..::..Boolean
if set to true all descendant items will be returned.

Return Value

List of registered URIs.

See Also

WebDAVCacheLockNullProvider Class
Sitecore.Data.Locking Namespace


GetItemUriByPath Method

[image]

Sitecore 6.4.1 API
WebDAVCacheLockNullProvider..::..GetItemUriByPath Method
WebDAVCacheLockNullProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ItemUri GetItemUriByPath(
    string path
)
Visual Basic
Protected Overrides Function GetItemUriByPath ( _
    path As String _
) As ItemUri
Visual C++
protected:
virtual ItemUri^ GetItemUriByPath(
    String^ path
) override

Parameters

path
Type: System..::..String
The item path.

Return Value

The Item URI.

See Also

WebDAVCacheLockNullProvider Class
Sitecore.Data.Locking Namespace


IsItemUriExists Method

[image] [image]

Sitecore 6.4.1 API
WebDAVCacheLockNullProvider..::..IsItemUriExists Method
WebDAVCacheLockNullProvider Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | IsItemUriExists(String) | Determines whether Item URI with the specified path exists or not.
Protected method | IsItemUriExists(ItemUri) | Determines whether URI is already registered or not. (Overrides WebDAVLockNullProvider..::..IsItemUriExists(ItemUri).)

See Also

WebDAVCacheLockNullProvider Class
WebDAVCacheLockNullProvider Members
Sitecore.Data.Locking Namespace


IsItemUriExists Method (String)

[image]

Sitecore 6.4.1 API
WebDAVCacheLockNullProvider..::..IsItemUriExists Method (String)
WebDAVCacheLockNullProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected bool IsItemUriExists(
    string path
)
Visual Basic
Protected Function IsItemUriExists ( _
    path As String _
) As Boolean
Visual C++
protected:
bool IsItemUriExists(
    String^ path
)

Parameters

path
Type: System..::..String
The Item path.

Return Value

true if Item URI with the specified path exists; otherwise, false.

See Also

WebDAVCacheLockNullProvider Class
IsItemUriExists Overload
Sitecore.Data.Locking Namespace


IsItemUriExists Method (ItemUri)

[image]

Sitecore 6.4.1 API
WebDAVCacheLockNullProvider..::..IsItemUriExists Method (ItemUri)
WebDAVCacheLockNullProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override bool IsItemUriExists(
    ItemUri uri
)
Visual Basic
Protected Overrides Function IsItemUriExists ( _
    uri As ItemUri _
) As Boolean
Visual C++
protected:
virtual bool IsItemUriExists(
    ItemUri^ uri
) override

Parameters

uri
Type: Sitecore.Data..::..ItemUri
The Item URI.

Return Value

true if URI is already registered; otherwise, false.

See Also

WebDAVCacheLockNullProvider Class
IsItemUriExists Overload
Sitecore.Data.Locking Namespace


RemoveItemUri Method

[image]

Sitecore 6.4.1 API
WebDAVCacheLockNullProvider..::..RemoveItemUri Method
WebDAVCacheLockNullProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override bool RemoveItemUri(
    ItemUri uri
)
Visual Basic
Protected Overrides Function RemoveItemUri ( _
    uri As ItemUri _
) As Boolean
Visual C++
protected:
virtual bool RemoveItemUri(
    ItemUri^ uri
) override

Parameters

uri
Type: Sitecore.Data..::..ItemUri
The Item URI.

Return Value

true if URI has been removed.

See Also

WebDAVCacheLockNullProvider Class
Sitecore.Data.Locking Namespace


WebDAVCacheLockNullProvider Properties

[image] [image]

Sitecore 6.4.1 API
WebDAVCacheLockNullProvider Properties
WebDAVCacheLockNullProvider Class See Also Send Feedback

The WebDAVCacheLockNullProvider type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

WebDAVCacheLockNullProvider Class
Sitecore.Data.Locking Namespace


WebDAVLockingProvider Class

[image]

Sitecore 6.4.1 API
WebDAVLockingProvider Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class WebDAVLockingProvider : ProviderBase
Visual Basic
Public MustInherit Class WebDAVLockingProvider _
    Inherits ProviderBase
Visual C++
public ref class WebDAVLockingProvider abstract : public ProviderBase

Inheritance Hierarchy

System..::..Object
System.Configuration.Provider..::..ProviderBase
Sitecore.Data.Locking..::..WebDAVLockingProvider
Sitecore.Data.Locking..::..IDTableWebDAVLockingProvider

See Also

WebDAVLockingProvider Members
Sitecore.Data.Locking Namespace


WebDAVLockingProvider Members

[image] [image]

Sitecore 6.4.1 API
WebDAVLockingProvider Members
WebDAVLockingProvider Class Constructors Methods Properties See Also Send Feedback

The WebDAVLockingProvider type exposes the following members.

Constructors

 | Name | Description
Protected method | WebDAVLockingProvider | Initializes a new instance of the WebDAVLockingProvider class

Methods

 | Name | Description
Protected method | AddLock(String, ExLockInfo) | Adds the lock.
Public method | AddLock(WebDAVHierarchyItem, ExLockInfo) | Locks the specified item.
Protected method | DeserializeLock | Deserializes the lock.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocks(String) | Gets the locks.
Public method | GetLocks(WebDAVHierarchyItem, Boolean) | Gets the locks.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the provider. (Inherited from ProviderBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RemoveLock(String, String) | Removes the lock.
Public method | RemoveLock(WebDAVHierarchyItem, String) | Removes the lock.
Protected method | SerializeLock | Serializes the lock.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLock(WebDAVHierarchyItem, ExLockInfo) | Updates the lock.
Protected method | UpdateLock(String, String, Int64) | Updates the lock.

Properties

 | Name | Description
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

WebDAVLockingProvider Class
Sitecore.Data.Locking Namespace


WebDAVLockingProvider Constructor

[image]

Sitecore 6.4.1 API
WebDAVLockingProvider Constructor
WebDAVLockingProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected WebDAVLockingProvider()
Visual Basic
Protected Sub New
Visual C++
protected:
WebDAVLockingProvider()

See Also

WebDAVLockingProvider Class
Sitecore.Data.Locking Namespace


WebDAVLockingProvider Methods

[image] [image]

Sitecore 6.4.1 API
WebDAVLockingProvider Methods
WebDAVLockingProvider Class See Also Send Feedback

The WebDAVLockingProvider type exposes the following members.

Methods

 | Name | Description
Protected method | AddLock(String, ExLockInfo) | Adds the lock.
Public method | AddLock(WebDAVHierarchyItem, ExLockInfo) | Locks the specified item.
Protected method | DeserializeLock | Deserializes the lock.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocks(String) | Gets the locks.
Public method | GetLocks(WebDAVHierarchyItem, Boolean) | Gets the locks.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the provider. (Inherited from ProviderBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RemoveLock(String, String) | Removes the lock.
Public method | RemoveLock(WebDAVHierarchyItem, String) | Removes the lock.
Protected method | SerializeLock | Serializes the lock.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLock(WebDAVHierarchyItem, ExLockInfo) | Updates the lock.
Protected method | UpdateLock(String, String, Int64) | Updates the lock.

See Also

WebDAVLockingProvider Class
Sitecore.Data.Locking Namespace


AddLock Method

[image] [image]

Sitecore 6.4.1 API
WebDAVLockingProvider..::..AddLock Method
WebDAVLockingProvider Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AddLock(String, ExLockInfo) | Adds the lock.
Public method | AddLock(WebDAVHierarchyItem, ExLockInfo) | Locks the specified item.

See Also

WebDAVLockingProvider Class
WebDAVLockingProvider Members
Sitecore.Data.Locking Namespace


AddLock Method (String, ExLockInfo)

[image]

Sitecore 6.4.1 API
WebDAVLockingProvider..::..AddLock Method (String, ExLockInfo)
WebDAVLockingProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected abstract bool AddLock(
    string key,
    ExLockInfo lockInfo
)
Visual Basic
Protected MustOverride Function AddLock ( _
    key As String, _
    lockInfo As ExLockInfo _
) As Boolean
Visual C++
protected:
virtual bool AddLock(
    String^ key,
    ExLockInfo^ lockInfo
) abstract

Parameters

key
Type: System..::..String
The unique key.
lockInfo
Type: Sitecore.Data.Locking..::..ExLockInfo
The lock info.

Return Value

true if item has been locked.

See Also

WebDAVLockingProvider Class
AddLock Overload
Sitecore.Data.Locking Namespace


AddLock Method (WebDAVHierarchyItem, ExLockInfo)

[image]

Sitecore 6.4.1 API
WebDAVLockingProvider..::..AddLock Method (WebDAVHierarchyItem, ExLockInfo)
WebDAVLockingProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool AddLock(
    WebDAVHierarchyItem item,
    ExLockInfo info
)
Visual Basic
Public Overridable Function AddLock ( _
    item As WebDAVHierarchyItem, _
    info As ExLockInfo _
) As Boolean
Visual C++
public:
virtual bool AddLock(
    WebDAVHierarchyItem^ item,
    ExLockInfo^ info
)

Parameters

item
Type: Sitecore.Data.Items..::..WebDAVHierarchyItem
The Hierarchy item.
info
Type: Sitecore.Data.Locking..::..ExLockInfo
The Lock Info.

Return Value

true if item has been locked.

See Also

WebDAVLockingProvider Class
AddLock Overload
Sitecore.Data.Locking Namespace


DeserializeLock Method

[image]

Sitecore 6.4.1 API
WebDAVLockingProvider..::..DeserializeLock Method
WebDAVLockingProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual ExLockInfo DeserializeLock(
    string lockData
)
Visual Basic
Protected Overridable Function DeserializeLock ( _
    lockData As String _
) As ExLockInfo
Visual C++
protected:
virtual ExLockInfo^ DeserializeLock(
    String^ lockData
)

Parameters

lockData
Type: System..::..String
The lock data.

Return Value

The Lock object.

See Also

WebDAVLockingProvider Class
Sitecore.Data.Locking Namespace


GetLocks Method

[image] [image]

Sitecore 6.4.1 API
WebDAVLockingProvider..::..GetLocks Method
WebDAVLockingProvider Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetLocks(String) | Gets the locks.
Public method | GetLocks(WebDAVHierarchyItem, Boolean) | Gets the locks.

See Also

WebDAVLockingProvider Class
WebDAVLockingProvider Members
Sitecore.Data.Locking Namespace


GetLocks Method (String)

[image]

Sitecore 6.4.1 API
WebDAVLockingProvider..::..GetLocks Method (String)
WebDAVLockingProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected abstract List<ExLockInfo> GetLocks(
    string key
)
Visual Basic
Protected MustOverride Function GetLocks ( _
    key As String _
) As List(Of ExLockInfo)
Visual C++
protected:
virtual List<ExLockInfo^>^ GetLocks(
    String^ key
) abstract

Parameters

key
Type: System..::..String
The unique key.

Return Value

List of locks for the specified hierarchy item.

See Also

WebDAVLockingProvider Class
GetLocks Overload
Sitecore.Data.Locking Namespace


GetLocks Method (WebDAVHierarchyItem, Boolean)

[image]

Sitecore 6.4.1 API
WebDAVLockingProvider..::..GetLocks Method (WebDAVHierarchyItem, Boolean)
WebDAVLockingProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual List<ExLockInfo> GetLocks(
    WebDAVHierarchyItem item,
    bool onlyDeep
)
Visual Basic
Public Overridable Function GetLocks ( _
    item As WebDAVHierarchyItem, _
    onlyDeep As Boolean _
) As List(Of ExLockInfo)
Visual C++
public:
virtual List<ExLockInfo^>^ GetLocks(
    WebDAVHierarchyItem^ item,
    bool onlyDeep
)

Parameters

item
Type: Sitecore.Data.Items..::..WebDAVHierarchyItem
The Hierarchy item.
onlyDeep
Type: System..::..Boolean
if set to true only deep locks will be returned.

Return Value

List of locks for the specified hierarchy item.

See Also

WebDAVLockingProvider Class
GetLocks Overload
Sitecore.Data.Locking Namespace


RemoveLock Method

[image] [image]

Sitecore 6.4.1 API
WebDAVLockingProvider..::..RemoveLock Method
WebDAVLockingProvider Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RemoveLock(String, String) | Removes the lock.
Public method | RemoveLock(WebDAVHierarchyItem, String) | Removes the lock.

See Also

WebDAVLockingProvider Class
WebDAVLockingProvider Members
Sitecore.Data.Locking Namespace


RemoveLock Method (String, String)

[image]

Sitecore 6.4.1 API
WebDAVLockingProvider..::..RemoveLock Method (String, String)
WebDAVLockingProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected abstract bool RemoveLock(
    string key,
    string lockToken
)
Visual Basic
Protected MustOverride Function RemoveLock ( _
    key As String, _
    lockToken As String _
) As Boolean
Visual C++
protected:
virtual bool RemoveLock(
    String^ key,
    String^ lockToken
) abstract

Parameters

key
Type: System..::..String
The unique key.
lockToken
Type: System..::..String
The lock token.

Return Value

true if lock has been removed.

See Also

WebDAVLockingProvider Class
RemoveLock Overload
Sitecore.Data.Locking Namespace


RemoveLock Method (WebDAVHierarchyItem, String)

[image]

Sitecore 6.4.1 API
WebDAVLockingProvider..::..RemoveLock Method (WebDAVHierarchyItem, String)
WebDAVLockingProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool RemoveLock(
    WebDAVHierarchyItem item,
    string lockToken
)
Visual Basic
Public Overridable Function RemoveLock ( _
    item As WebDAVHierarchyItem, _
    lockToken As String _
) As Boolean
Visual C++
public:
virtual bool RemoveLock(
    WebDAVHierarchyItem^ item,
    String^ lockToken
)

Parameters

item
Type: Sitecore.Data.Items..::..WebDAVHierarchyItem
The Web DAV Hierarchy item.
lockToken
Type: System..::..String
The lock token.

Return Value

true if lock has been removed.

See Also

WebDAVLockingProvider Class
RemoveLock Overload
Sitecore.Data.Locking Namespace


SerializeLock Method

[image]

Sitecore 6.4.1 API
WebDAVLockingProvider..::..SerializeLock Method
WebDAVLockingProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string SerializeLock(
    ExLockInfo info
)
Visual Basic
Protected Overridable Function SerializeLock ( _
    info As ExLockInfo _
) As String
Visual C++
protected:
virtual String^ SerializeLock(
    ExLockInfo^ info
)

Parameters

info
Type: Sitecore.Data.Locking..::..ExLockInfo
The lock info.

Return Value

Serialized lock data.

See Also

WebDAVLockingProvider Class
Sitecore.Data.Locking Namespace


UpdateLock Method

[image] [image]

Sitecore 6.4.1 API
WebDAVLockingProvider..::..UpdateLock Method
WebDAVLockingProvider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UpdateLock(WebDAVHierarchyItem, ExLockInfo) | Updates the lock.
Protected method | UpdateLock(String, String, Int64) | Updates the lock.

See Also

WebDAVLockingProvider Class
WebDAVLockingProvider Members
Sitecore.Data.Locking Namespace


UpdateLock Method (WebDAVHierarchyItem, ExLockInfo)

[image]

Sitecore 6.4.1 API
WebDAVLockingProvider..::..UpdateLock Method (WebDAVHierarchyItem, ExLockInfo)
WebDAVLockingProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool UpdateLock(
    WebDAVHierarchyItem item,
    ExLockInfo info
)
Visual Basic
Public Overridable Function UpdateLock ( _
    item As WebDAVHierarchyItem, _
    info As ExLockInfo _
) As Boolean
Visual C++
public:
virtual bool UpdateLock(
    WebDAVHierarchyItem^ item,
    ExLockInfo^ info
)

Parameters

item
Type: Sitecore.Data.Items..::..WebDAVHierarchyItem
The Web DAV Hierarchy item.
info
Type: Sitecore.Data.Locking..::..ExLockInfo
The Lock info.

Return Value

true if lock has been updated.

See Also

WebDAVLockingProvider Class
UpdateLock Overload
Sitecore.Data.Locking Namespace


UpdateLock Method (String, String, Int64)

[image]

Sitecore 6.4.1 API
WebDAVLockingProvider..::..UpdateLock Method (String, String, Int64)
WebDAVLockingProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected abstract bool UpdateLock(
    string key,
    string lockToken,
    long timeout
)
Visual Basic
Protected MustOverride Function UpdateLock ( _
    key As String, _
    lockToken As String, _
    timeout As Long _
) As Boolean
Visual C++
protected:
virtual bool UpdateLock(
    String^ key,
    String^ lockToken,
    long long timeout
) abstract

Parameters

key
Type: System..::..String
The unique key.
lockToken
Type: System..::..String
The lock token ID.
timeout
Type: System..::..Int64
The timeout.

Return Value

true if lock has been updated.

See Also

WebDAVLockingProvider Class
UpdateLock Overload
Sitecore.Data.Locking Namespace


WebDAVLockingProvider Properties

[image] [image]

Sitecore 6.4.1 API
WebDAVLockingProvider Properties
WebDAVLockingProvider Class See Also Send Feedback

The WebDAVLockingProvider type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

WebDAVLockingProvider Class
Sitecore.Data.Locking Namespace


WebDAVLockingProviderCollection Class

[image]

Sitecore 6.4.1 API
WebDAVLockingProviderCollection Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class WebDAVLockingProviderCollection : ProviderCollection
Visual Basic
Public Class WebDAVLockingProviderCollection _
    Inherits ProviderCollection
Visual C++
public ref class WebDAVLockingProviderCollection : public ProviderCollection

Inheritance Hierarchy

System..::..Object
System.Configuration.Provider..::..ProviderCollection
Sitecore.Data.Locking..::..WebDAVLockingProviderCollection

See Also

WebDAVLockingProviderCollection Members
Sitecore.Data.Locking Namespace


WebDAVLockingProviderCollection Members

[image] [image]

Sitecore 6.4.1 API
WebDAVLockingProviderCollection Members
WebDAVLockingProviderCollection Class Constructors Methods Properties See Also Send Feedback

The WebDAVLockingProviderCollection type exposes the following members.

Constructors

 | Name | Description
Public method | WebDAVLockingProviderCollection | Initializes a new instance of the WebDAVLockingProviderCollection class

Methods

 | Name | Description
Public method | Add | Adds a provider to the collection. (Inherited from ProviderCollection.)
Public method | Clear | Removes all items from the collection. (Inherited from ProviderCollection.)
Public method | CopyTo | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a provider from the collection. (Inherited from ProviderCollection.)
Public method | SetReadOnly | Sets the collection to be read-only. (Inherited from ProviderCollection.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
Public property | Item | Gets the WebDAVLockingProvider with the specified name.
Public property | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)

See Also

WebDAVLockingProviderCollection Class
Sitecore.Data.Locking Namespace


WebDAVLockingProviderCollection Constructor

[image]

Sitecore 6.4.1 API
WebDAVLockingProviderCollection Constructor
WebDAVLockingProviderCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WebDAVLockingProviderCollection()
Visual Basic
Public Sub New
Visual C++
public:
WebDAVLockingProviderCollection()

See Also

WebDAVLockingProviderCollection Class
Sitecore.Data.Locking Namespace


WebDAVLockingProviderCollection Methods

[image] [image]

Sitecore 6.4.1 API
WebDAVLockingProviderCollection Methods
WebDAVLockingProviderCollection Class See Also Send Feedback

The WebDAVLockingProviderCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds a provider to the collection. (Inherited from ProviderCollection.)
Public method | Clear | Removes all items from the collection. (Inherited from ProviderCollection.)
Public method | CopyTo | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a provider from the collection. (Inherited from ProviderCollection.)
Public method | SetReadOnly | Sets the collection to be read-only. (Inherited from ProviderCollection.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WebDAVLockingProviderCollection Class
Sitecore.Data.Locking Namespace


WebDAVLockingProviderCollection Properties

[image] [image]

Sitecore 6.4.1 API
WebDAVLockingProviderCollection Properties
WebDAVLockingProviderCollection Class See Also Send Feedback

The WebDAVLockingProviderCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
Public property | Item | Gets the WebDAVLockingProvider with the specified name.
Public property | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)

See Also

WebDAVLockingProviderCollection Class
Sitecore.Data.Locking Namespace


Item Property

[image]

Sitecore 6.4.1 API
WebDAVLockingProviderCollection..::..Item Property
WebDAVLockingProviderCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WebDAVLockingProvider this[
    string name
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    name As String _
) As WebDAVLockingProvider
    Get
Visual C++
public:
property WebDAVLockingProvider^ default[String^ name] {
    WebDAVLockingProvider^ get (String^ name);
}

Parameters

name
Type: System..::..String
The locking provider name.

Field Value

Instance of Web DAV locking provider.

See Also

WebDAVLockingProviderCollection Class
Sitecore.Data.Locking Namespace


WebDAVLockNullProvider Class

[image]

Sitecore 6.4.1 API
WebDAVLockNullProvider Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class WebDAVLockNullProvider : ProviderBase
Visual Basic
Public MustInherit Class WebDAVLockNullProvider _
    Inherits ProviderBase
Visual C++
public ref class WebDAVLockNullProvider abstract : public ProviderBase

Inheritance Hierarchy

System..::..Object
System.Configuration.Provider..::..ProviderBase
Sitecore.Data.Locking..::..WebDAVLockNullProvider
Sitecore.Data.Locking..::..WebDAVCacheLockNullProvider

See Also

WebDAVLockNullProvider Members
Sitecore.Data.Locking Namespace


WebDAVLockNullProvider Members

[image] [image]

Sitecore 6.4.1 API
WebDAVLockNullProvider Members
WebDAVLockNullProvider Class Constructors Methods Properties See Also Send Feedback

The WebDAVLockNullProvider type exposes the following members.

Constructors

 | Name | Description
Protected method | WebDAVLockNullProvider | Initializes a new instance of the WebDAVLockNullProvider class

Methods

 | Name | Description
Protected method | AddItemUri | Adds the item URI.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindChildren | Finds the item children.
Public method | FindLockNullItemByPath | Finds the lock null item by path.
Protected method | GetChildUris | Gets the uris of child items.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetItemUriByPath | Gets the item URI by path.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the provider. (Inherited from ProviderBase.)
Protected method | IsItemUriExists | Determines whether URI is already registered or not.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RegisterLockNullItem | Registers the lock null item.
Protected method | RemoveItemUri | Removes the item URI.
Public method | RemoveLockNullItem | Removes the lock null item.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

WebDAVLockNullProvider Class
Sitecore.Data.Locking Namespace


WebDAVLockNullProvider Constructor

[image]

Sitecore 6.4.1 API
WebDAVLockNullProvider Constructor
WebDAVLockNullProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected WebDAVLockNullProvider()
Visual Basic
Protected Sub New
Visual C++
protected:
WebDAVLockNullProvider()

See Also

WebDAVLockNullProvider Class
Sitecore.Data.Locking Namespace


WebDAVLockNullProvider Methods

[image] [image]

Sitecore 6.4.1 API
WebDAVLockNullProvider Methods
WebDAVLockNullProvider Class See Also Send Feedback

The WebDAVLockNullProvider type exposes the following members.

Methods

 | Name | Description
Protected method | AddItemUri | Adds the item URI.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindChildren | Finds the item children.
Public method | FindLockNullItemByPath | Finds the lock null item by path.
Protected method | GetChildUris | Gets the uris of child items.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetItemUriByPath | Gets the item URI by path.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the provider. (Inherited from ProviderBase.)
Protected method | IsItemUriExists | Determines whether URI is already registered or not.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RegisterLockNullItem | Registers the lock null item.
Protected method | RemoveItemUri | Removes the item URI.
Public method | RemoveLockNullItem | Removes the lock null item.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WebDAVLockNullProvider Class
Sitecore.Data.Locking Namespace


AddItemUri Method

[image]

Sitecore 6.4.1 API
WebDAVLockNullProvider..::..AddItemUri Method
WebDAVLockNullProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected abstract bool AddItemUri(
    ItemUri uri
)
Visual Basic
Protected MustOverride Function AddItemUri ( _
    uri As ItemUri _
) As Boolean
Visual C++
protected:
virtual bool AddItemUri(
    ItemUri^ uri
) abstract

Parameters

uri
Type: Sitecore.Data..::..ItemUri
The LockNull Item URI.

Return Value

true if Item Uri has been added.

See Also

WebDAVLockNullProvider Class
Sitecore.Data.Locking Namespace


FindChildren Method

[image]

Sitecore 6.4.1 API
WebDAVLockNullProvider..::..FindChildren Method
WebDAVLockNullProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual List<WebDAVLockNullItem> FindChildren(
    WebDAVHierarchyItem item,
    bool deep
)
Visual Basic
Public Overridable Function FindChildren ( _
    item As WebDAVHierarchyItem, _
    deep As Boolean _
) As List(Of WebDAVLockNullItem)
Visual C++
public:
virtual List<WebDAVLockNullItem^>^ FindChildren(
    WebDAVHierarchyItem^ item,
    bool deep
)

Parameters

item
Type: Sitecore.Data.Items..::..WebDAVHierarchyItem
The Hierarchy item.
deep
Type: System..::..Boolean
if set to true all descendants will be returned.

Return Value

List of child LockNull items.

See Also

WebDAVLockNullProvider Class
Sitecore.Data.Locking Namespace


FindLockNullItemByPath Method

[image]

Sitecore 6.4.1 API
WebDAVLockNullProvider..::..FindLockNullItemByPath Method
WebDAVLockNullProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual WebDAVLockNullItem FindLockNullItemByPath(
    string path,
    WebDAVView view,
    WebDAVEngine engine
)
Visual Basic
Public Overridable Function FindLockNullItemByPath ( _
    path As String, _
    view As WebDAVView, _
    engine As WebDAVEngine _
) As WebDAVLockNullItem
Visual C++
public:
virtual WebDAVLockNullItem^ FindLockNullItemByPath(
    String^ path,
    WebDAVView^ view,
    WebDAVEngine^ engine
)

Parameters

path
Type: System..::..String
The item path.
view
Type: Sitecore.Data.Views..::..WebDAVView
The Web DAV view.
engine
Type: Sitecore.Web..::..WebDAVEngine
The Web DAV engine.

Return Value

The Web DAV LockNull item.

See Also

WebDAVLockNullProvider Class
Sitecore.Data.Locking Namespace


GetChildUris Method

[image]

Sitecore 6.4.1 API
WebDAVLockNullProvider..::..GetChildUris Method
WebDAVLockNullProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected abstract List<ItemUri> GetChildUris(
    ItemUri uri,
    bool deep
)
Visual Basic
Protected MustOverride Function GetChildUris ( _
    uri As ItemUri, _
    deep As Boolean _
) As List(Of ItemUri)
Visual C++
protected:
virtual List<ItemUri^>^ GetChildUris(
    ItemUri^ uri,
    bool deep
) abstract

Parameters

uri
Type: Sitecore.Data..::..ItemUri
The Item URI.
deep
Type: System..::..Boolean
if set to true all descendant items will be returned.

Return Value

List of registered URIs.

See Also

WebDAVLockNullProvider Class
Sitecore.Data.Locking Namespace


GetItemUriByPath Method

[image]

Sitecore 6.4.1 API
WebDAVLockNullProvider..::..GetItemUriByPath Method
WebDAVLockNullProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected abstract ItemUri GetItemUriByPath(
    string path
)
Visual Basic
Protected MustOverride Function GetItemUriByPath ( _
    path As String _
) As ItemUri
Visual C++
protected:
virtual ItemUri^ GetItemUriByPath(
    String^ path
) abstract

Parameters

path
Type: System..::..String
The item path.

Return Value

The Item URI.

See Also

WebDAVLockNullProvider Class
Sitecore.Data.Locking Namespace


IsItemUriExists Method

[image]

Sitecore 6.4.1 API
WebDAVLockNullProvider..::..IsItemUriExists Method
WebDAVLockNullProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected abstract bool IsItemUriExists(
    ItemUri uri
)
Visual Basic
Protected MustOverride Function IsItemUriExists ( _
    uri As ItemUri _
) As Boolean
Visual C++
protected:
virtual bool IsItemUriExists(
    ItemUri^ uri
) abstract

Parameters

uri
Type: Sitecore.Data..::..ItemUri
The Item URI.

Return Value

true if URI is already registered; otherwise, false.

See Also

WebDAVLockNullProvider Class
Sitecore.Data.Locking Namespace


RegisterLockNullItem Method

[image]

Sitecore 6.4.1 API
WebDAVLockNullProvider..::..RegisterLockNullItem Method
WebDAVLockNullProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool RegisterLockNullItem(
    WebDAVLockNullItem item
)
Visual Basic
Public Overridable Function RegisterLockNullItem ( _
    item As WebDAVLockNullItem _
) As Boolean
Visual C++
public:
virtual bool RegisterLockNullItem(
    WebDAVLockNullItem^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..WebDAVLockNullItem
The LockNull item.

Return Value

true if LockNull item has been registered.

See Also

WebDAVLockNullProvider Class
Sitecore.Data.Locking Namespace


RemoveItemUri Method

[image]

Sitecore 6.4.1 API
WebDAVLockNullProvider..::..RemoveItemUri Method
WebDAVLockNullProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected abstract bool RemoveItemUri(
    ItemUri uri
)
Visual Basic
Protected MustOverride Function RemoveItemUri ( _
    uri As ItemUri _
) As Boolean
Visual C++
protected:
virtual bool RemoveItemUri(
    ItemUri^ uri
) abstract

Parameters

uri
Type: Sitecore.Data..::..ItemUri
The Item URI.

Return Value

true if URI has been removed.

See Also

WebDAVLockNullProvider Class
Sitecore.Data.Locking Namespace


WebDAVLockNullProvider Properties

[image] [image]

Sitecore 6.4.1 API
WebDAVLockNullProvider Properties
WebDAVLockNullProvider Class See Also Send Feedback

The WebDAVLockNullProvider type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

WebDAVLockNullProvider Class
Sitecore.Data.Locking Namespace


WebDAVLockNullProviderCollection Class

[image]

Sitecore 6.4.1 API
WebDAVLockNullProviderCollection Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class WebDAVLockNullProviderCollection : ProviderCollection
Visual Basic
Public Class WebDAVLockNullProviderCollection _
    Inherits ProviderCollection
Visual C++
public ref class WebDAVLockNullProviderCollection : public ProviderCollection

Inheritance Hierarchy

System..::..Object
System.Configuration.Provider..::..ProviderCollection
Sitecore.Data.Locking..::..WebDAVLockNullProviderCollection

See Also

WebDAVLockNullProviderCollection Members
Sitecore.Data.Locking Namespace


WebDAVLockNullProviderCollection Members

[image] [image]

Sitecore 6.4.1 API
WebDAVLockNullProviderCollection Members
WebDAVLockNullProviderCollection Class Constructors Methods Properties See Also Send Feedback

The WebDAVLockNullProviderCollection type exposes the following members.

Constructors

 | Name | Description
Public method | WebDAVLockNullProviderCollection | Initializes a new instance of the WebDAVLockNullProviderCollection class

Methods

 | Name | Description
Public method | Add | Adds a provider to the collection. (Inherited from ProviderCollection.)
Public method | Clear | Removes all items from the collection. (Inherited from ProviderCollection.)
Public method | CopyTo | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a provider from the collection. (Inherited from ProviderCollection.)
Public method | SetReadOnly | Sets the collection to be read-only. (Inherited from ProviderCollection.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
Public property | Item | Gets the WebDAVLockNullProvider with the specified name.
Public property | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)

See Also

WebDAVLockNullProviderCollection Class
Sitecore.Data.Locking Namespace


WebDAVLockNullProviderCollection Constructor

[image]

Sitecore 6.4.1 API
WebDAVLockNullProviderCollection Constructor
WebDAVLockNullProviderCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WebDAVLockNullProviderCollection()
Visual Basic
Public Sub New
Visual C++
public:
WebDAVLockNullProviderCollection()

See Also

WebDAVLockNullProviderCollection Class
Sitecore.Data.Locking Namespace


WebDAVLockNullProviderCollection Methods

[image] [image]

Sitecore 6.4.1 API
WebDAVLockNullProviderCollection Methods
WebDAVLockNullProviderCollection Class See Also Send Feedback

The WebDAVLockNullProviderCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds a provider to the collection. (Inherited from ProviderCollection.)
Public method | Clear | Removes all items from the collection. (Inherited from ProviderCollection.)
Public method | CopyTo | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a provider from the collection. (Inherited from ProviderCollection.)
Public method | SetReadOnly | Sets the collection to be read-only. (Inherited from ProviderCollection.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WebDAVLockNullProviderCollection Class
Sitecore.Data.Locking Namespace


WebDAVLockNullProviderCollection Properties

[image] [image]

Sitecore 6.4.1 API
WebDAVLockNullProviderCollection Properties
WebDAVLockNullProviderCollection Class See Also Send Feedback

The WebDAVLockNullProviderCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
Public property | Item | Gets the WebDAVLockNullProvider with the specified name.
Public property | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)

See Also

WebDAVLockNullProviderCollection Class
Sitecore.Data.Locking Namespace


Item Property

[image]

Sitecore 6.4.1 API
WebDAVLockNullProviderCollection..::..Item Property
WebDAVLockNullProviderCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Locking
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WebDAVLockNullProvider this[
    string name
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    name As String _
) As WebDAVLockNullProvider
    Get
Visual C++
public:
property WebDAVLockNullProvider^ default[String^ name] {
    WebDAVLockNullProvider^ get (String^ name);
}

Parameters

name
Type: System..::..String
The LockNull provider name.

Field Value

Instance of Web DAV LockNull provider.

See Also

WebDAVLockNullProviderCollection Class
Sitecore.Data.Locking Namespace


HistoryManager Class

[image]

Sitecore 6.4.1 API
HistoryManager Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public sealed class HistoryManager
Visual Basic
Public NotInheritable Class HistoryManager
Visual C++
public ref class HistoryManager sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Managers..::..HistoryManager

See Also

HistoryManager Members
Sitecore.Data.Managers Namespace


HistoryManager Members

[image] [image]

Sitecore 6.4.1 API
HistoryManager Members
HistoryManager Class Constructors Methods Properties See Also Send Feedback

The HistoryManager type exposes the following members.

Constructors

 | Name | Description
Public method | HistoryManager | Initializes a new instance of the HistoryManager class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHistory | Gets the history for a database.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize | Initializes event handlers.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RegisterItemCopied | Registers an 'item copied' event in the audit log.
 | RegisterItemCreated | Registers an 'item created' event in the audit log.
 | RegisterItemDeleted | Registers an 'item deleted' event in the audit log.
 | RegisterItemMoved | Registers an 'item moved' event in the audit log.
 | RegisterItemSaved | Registers an 'item saved' event in the audit log.
 | RegisterVersionAdded | Registers an 'version added' event in the audit log.
 | RegisterVersionRemoved | Registers an 'version removed' event in the audit log.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Provider | Gets the active provider.

See Also

HistoryManager Class
Sitecore.Data.Managers Namespace


HistoryManager Constructor

[image]

Sitecore 6.4.1 API
HistoryManager Constructor
HistoryManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HistoryManager()
Visual Basic
Public Sub New
Visual C++
public:
HistoryManager()

See Also

HistoryManager Class
Sitecore.Data.Managers Namespace


HistoryManager Methods

[image] [image]

Sitecore 6.4.1 API
HistoryManager Methods
HistoryManager Class See Also Send Feedback

The HistoryManager type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHistory | Gets the history for a database.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize | Initializes event handlers.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RegisterItemCopied | Registers an 'item copied' event in the audit log.
 | RegisterItemCreated | Registers an 'item created' event in the audit log.
 | RegisterItemDeleted | Registers an 'item deleted' event in the audit log.
 | RegisterItemMoved | Registers an 'item moved' event in the audit log.
 | RegisterItemSaved | Registers an 'item saved' event in the audit log.
 | RegisterVersionAdded | Registers an 'version added' event in the audit log.
 | RegisterVersionRemoved | Registers an 'version removed' event in the audit log.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HistoryManager Class
Sitecore.Data.Managers Namespace


GetHistory Method

[image]

Sitecore 6.4.1 API
HistoryManager..::..GetHistory Method
HistoryManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static HistoryEntryCollection GetHistory(
    Database database,
    DateTime from,
    DateTime to
)
Visual Basic
Public Shared Function GetHistory ( _
    database As Database, _
    from As DateTime, _
    to As DateTime _
) As HistoryEntryCollection
Visual C++
public:
static HistoryEntryCollection^ GetHistory(
    Database^ database,
    DateTime from,
    DateTime to
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.
from
Type: System..::..DateTime
From date (UTC).
to
Type: System..::..DateTime
To date (UTC).

Return Value

The history.

See Also

HistoryManager Class
Sitecore.Data.Managers Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
HistoryManager..::..Initialize Method
HistoryManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Initialize()
Visual Basic
Public Shared Sub Initialize
Visual C++
public:
static void Initialize()

See Also

HistoryManager Class
Sitecore.Data.Managers Namespace


RegisterItemCopied Method

[image]

Sitecore 6.4.1 API
HistoryManager..::..RegisterItemCopied Method
HistoryManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void RegisterItemCopied(
    Item copiedItem,
    Item sourceItem
)
Visual Basic
Public Shared Sub RegisterItemCopied ( _
    copiedItem As Item, _
    sourceItem As Item _
)
Visual C++
public:
static void RegisterItemCopied(
    Item^ copiedItem,
    Item^ sourceItem
)

Parameters

copiedItem
Type: Sitecore.Data.Items..::..Item
The copied item.
sourceItem
Type: Sitecore.Data.Items..::..Item
The source item.

See Also

HistoryManager Class
Sitecore.Data.Managers Namespace


RegisterItemCreated Method

[image]

Sitecore 6.4.1 API
HistoryManager..::..RegisterItemCreated Method
HistoryManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void RegisterItemCreated(
    Item item
)
Visual Basic
Public Shared Sub RegisterItemCreated ( _
    item As Item _
)
Visual C++
public:
static void RegisterItemCreated(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

HistoryManager Class
Sitecore.Data.Managers Namespace


RegisterItemDeleted Method

[image]

Sitecore 6.4.1 API
HistoryManager..::..RegisterItemDeleted Method
HistoryManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void RegisterItemDeleted(
    Item item,
    ID oldParentId
)
Visual Basic
Public Shared Sub RegisterItemDeleted ( _
    item As Item, _
    oldParentId As ID _
)
Visual C++
public:
static void RegisterItemDeleted(
    Item^ item,
    ID^ oldParentId
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
oldParentId
Type: Sitecore.Data..::..ID
The old parent id.

See Also

HistoryManager Class
Sitecore.Data.Managers Namespace


RegisterItemSaved Method

[image]

Sitecore 6.4.1 API
HistoryManager..::..RegisterItemSaved Method
HistoryManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void RegisterItemSaved(
    Item item,
    ItemChanges changes
)
Visual Basic
Public Shared Sub RegisterItemSaved ( _
    item As Item, _
    changes As ItemChanges _
)
Visual C++
public:
static void RegisterItemSaved(
    Item^ item,
    ItemChanges^ changes
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
changes
Type: Sitecore.Data.Items..::..ItemChanges
The changes.

See Also

HistoryManager Class
Sitecore.Data.Managers Namespace


RegisterVersionAdded Method

[image]

Sitecore 6.4.1 API
HistoryManager..::..RegisterVersionAdded Method
HistoryManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void RegisterVersionAdded(
    Item item
)
Visual Basic
Public Shared Sub RegisterVersionAdded ( _
    item As Item _
)
Visual C++
public:
static void RegisterVersionAdded(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The added version.

See Also

HistoryManager Class
Sitecore.Data.Managers Namespace


RegisterVersionRemoved Method

[image]

Sitecore 6.4.1 API
HistoryManager..::..RegisterVersionRemoved Method
HistoryManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void RegisterVersionRemoved(
    Item item
)
Visual Basic
Public Shared Sub RegisterVersionRemoved ( _
    item As Item _
)
Visual C++
public:
static void RegisterVersionRemoved(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The version that was removed.

See Also

HistoryManager Class
Sitecore.Data.Managers Namespace


HistoryManager Properties

[image] [image]

Sitecore 6.4.1 API
HistoryManager Properties
HistoryManager Class See Also Send Feedback

The HistoryManager type exposes the following members.

Properties

Name | Description
Provider | Gets the active provider.

See Also

HistoryManager Class
Sitecore.Data.Managers Namespace


Provider Property

[image]

Sitecore 6.4.1 API
HistoryManager..::..Provider Property
HistoryManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static HistoryProvider Provider { get; }
Visual Basic
Public Shared ReadOnly Property Provider As HistoryProvider
    Get
Visual C++
public:
static property HistoryProvider^ Provider {
    HistoryProvider^ get ();
}

Field Value

The provider.

See Also

HistoryManager Class
Sitecore.Data.Managers Namespace


HistoryProvider Class

[image]

Sitecore 6.4.1 API
HistoryProvider Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class HistoryProvider
Visual Basic
Public Class HistoryProvider
Visual C++
public ref class HistoryProvider

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Managers..::..HistoryProvider

See Also

HistoryProvider Members
Sitecore.Data.Managers Namespace


HistoryProvider Members

[image] [image]

Sitecore 6.4.1 API
HistoryProvider Members
HistoryProvider Class Constructors Methods See Also Send Feedback

The HistoryProvider type exposes the following members.

Constructors

 | Name | Description
Public method | HistoryProvider | Initializes a new instance of the HistoryProvider class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHistory | Gets the history for a database.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RegisterItemCopied | Registers an 'item copied' event in the audit log.
Public method | RegisterItemCreated | Registers an 'item deleted' event in the audit log.
Public method | RegisterItemDeleted | Registers an 'item deleted' event in the audit log.
Public method | RegisterItemMoved | Registers an 'item moved' event in the audit log.
Public method | RegisterItemSaved | Registers an 'item saved' event in the audit log.
Public method | RegisterVersionAdded | Registers an 'version added' event in the audit log.
Public method | RegisterVersionRemoved | Registers an 'version removed' event in the audit log.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HistoryProvider Class
Sitecore.Data.Managers Namespace


HistoryProvider Constructor

[image]

Sitecore 6.4.1 API
HistoryProvider Constructor
HistoryProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HistoryProvider()
Visual Basic
Public Sub New
Visual C++
public:
HistoryProvider()

See Also

HistoryProvider Class
Sitecore.Data.Managers Namespace


HistoryProvider Methods

[image] [image]

Sitecore 6.4.1 API
HistoryProvider Methods
HistoryProvider Class See Also Send Feedback

The HistoryProvider type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHistory | Gets the history for a database.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RegisterItemCopied | Registers an 'item copied' event in the audit log.
Public method | RegisterItemCreated | Registers an 'item deleted' event in the audit log.
Public method | RegisterItemDeleted | Registers an 'item deleted' event in the audit log.
Public method | RegisterItemMoved | Registers an 'item moved' event in the audit log.
Public method | RegisterItemSaved | Registers an 'item saved' event in the audit log.
Public method | RegisterVersionAdded | Registers an 'version added' event in the audit log.
Public method | RegisterVersionRemoved | Registers an 'version removed' event in the audit log.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HistoryProvider Class
Sitecore.Data.Managers Namespace


GetHistory Method

[image]

Sitecore 6.4.1 API
HistoryProvider..::..GetHistory Method
HistoryProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual HistoryEntryCollection GetHistory(
    Database database,
    DateTime from,
    DateTime to
)
Visual Basic
Public Overridable Function GetHistory ( _
    database As Database, _
    from As DateTime, _
    to As DateTime _
) As HistoryEntryCollection
Visual C++
public:
virtual HistoryEntryCollection^ GetHistory(
    Database^ database,
    DateTime from,
    DateTime to
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.
from
Type: System..::..DateTime
From date (UTC).
to
Type: System..::..DateTime
To date (UTC).

Return Value

The history.

See Also

HistoryProvider Class
Sitecore.Data.Managers Namespace


RegisterItemCopied Method

[image]

Sitecore 6.4.1 API
HistoryProvider..::..RegisterItemCopied Method
HistoryProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void RegisterItemCopied(
    Item copiedItem,
    Item sourceItem
)
Visual Basic
Public Overridable Sub RegisterItemCopied ( _
    copiedItem As Item, _
    sourceItem As Item _
)
Visual C++
public:
virtual void RegisterItemCopied(
    Item^ copiedItem,
    Item^ sourceItem
)

Parameters

copiedItem
Type: Sitecore.Data.Items..::..Item
The copied item.
sourceItem
Type: Sitecore.Data.Items..::..Item
The source item.

See Also

HistoryProvider Class
Sitecore.Data.Managers Namespace


RegisterItemCreated Method

[image]

Sitecore 6.4.1 API
HistoryProvider..::..RegisterItemCreated Method
HistoryProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void RegisterItemCreated(
    Item item
)
Visual Basic
Public Overridable Sub RegisterItemCreated ( _
    item As Item _
)
Visual C++
public:
virtual void RegisterItemCreated(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

HistoryProvider Class
Sitecore.Data.Managers Namespace


RegisterItemDeleted Method

[image]

Sitecore 6.4.1 API
HistoryProvider..::..RegisterItemDeleted Method
HistoryProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void RegisterItemDeleted(
    Item item,
    ID oldParentId
)
Visual Basic
Public Overridable Sub RegisterItemDeleted ( _
    item As Item, _
    oldParentId As ID _
)
Visual C++
public:
virtual void RegisterItemDeleted(
    Item^ item,
    ID^ oldParentId
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
oldParentId
Type: Sitecore.Data..::..ID
The old parent id.

See Also

HistoryProvider Class
Sitecore.Data.Managers Namespace


RegisterItemMoved Method

[image]

Sitecore 6.4.1 API
HistoryProvider..::..RegisterItemMoved Method
HistoryProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void RegisterItemMoved(
    Item item,
    ID oldParentId
)
Visual Basic
Public Overridable Sub RegisterItemMoved ( _
    item As Item, _
    oldParentId As ID _
)
Visual C++
public:
virtual void RegisterItemMoved(
    Item^ item,
    ID^ oldParentId
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
oldParentId
Type: Sitecore.Data..::..ID
The old parent id.

See Also

HistoryProvider Class
Sitecore.Data.Managers Namespace


RegisterVersionAdded Method

[image]

Sitecore 6.4.1 API
HistoryProvider..::..RegisterVersionAdded Method
HistoryProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void RegisterVersionAdded(
    Item item
)
Visual Basic
Public Overridable Sub RegisterVersionAdded ( _
    item As Item _
)
Visual C++
public:
virtual void RegisterVersionAdded(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The added version.

See Also

HistoryProvider Class
Sitecore.Data.Managers Namespace


RegisterVersionRemoved Method

[image]

Sitecore 6.4.1 API
HistoryProvider..::..RegisterVersionRemoved Method
HistoryProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void RegisterVersionRemoved(
    Item item
)
Visual Basic
Public Overridable Sub RegisterVersionRemoved ( _
    item As Item _
)
Visual C++
public:
virtual void RegisterVersionRemoved(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The version that was removed.

See Also

HistoryProvider Class
Sitecore.Data.Managers Namespace


IndexingManager Class

[image]

Sitecore 6.4.1 API
IndexingManager Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class IndexingManager
Visual Basic
Public Class IndexingManager
Visual C++
public ref class IndexingManager

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Managers..::..IndexingManager

See Also

IndexingManager Members
Sitecore.Data.Managers Namespace


IndexingManager Members

[image] [image]

Sitecore 6.4.1 API
IndexingManager Members
IndexingManager Class Constructors Methods Fields Properties See Also Send Feedback

The IndexingManager type exposes the following members.

Constructors

 | Name | Description
Public method | IndexingManager | Initializes a new instance of the IndexingManager class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetUpdateJobName | Gets the name of the update job.
 | Initialize | Initializes event handlers.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateIndex | Updates the index(es) for a specific database.
 | UpdateIndexAsync | Updates the index(es) for a specific database.

Fields

Name | Description
LastUpdateKey | Name of the property holding the last update timestamp for this instance.

Properties

Name | Description
LastUpdatePropertyKey | Gets the key to use when storing the last update date.
Provider | Gets the active provider.

See Also

IndexingManager Class
Sitecore.Data.Managers Namespace


IndexingManager Constructor

[image]

Sitecore 6.4.1 API
IndexingManager Constructor
IndexingManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IndexingManager()
Visual Basic
Public Sub New
Visual C++
public:
IndexingManager()

See Also

IndexingManager Class
Sitecore.Data.Managers Namespace


IndexingManager Fields

[image] [image]

Sitecore 6.4.1 API
IndexingManager Fields
IndexingManager Class See Also Send Feedback

The IndexingManager type exposes the following members.

Fields

Name | Description
LastUpdateKey | Name of the property holding the last update timestamp for this instance.

See Also

IndexingManager Class
Sitecore.Data.Managers Namespace


LastUpdateKey Field

[image]

Sitecore 6.4.1 API
IndexingManager..::..LastUpdateKey Field
IndexingManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string LastUpdateKey
Visual Basic
Public Const LastUpdateKey As String
Visual C++
public:
literal String^ LastUpdateKey

See Also

IndexingManager Class
Sitecore.Data.Managers Namespace


IndexingManager Methods

[image] [image]

Sitecore 6.4.1 API
IndexingManager Methods
IndexingManager Class See Also Send Feedback

The IndexingManager type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetUpdateJobName | Gets the name of the update job.
 | Initialize | Initializes event handlers.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateIndex | Updates the index(es) for a specific database.
 | UpdateIndexAsync | Updates the index(es) for a specific database.

See Also

IndexingManager Class
Sitecore.Data.Managers Namespace


GetUpdateJobName Method

[image]

Sitecore 6.4.1 API
IndexingManager..::..GetUpdateJobName Method
IndexingManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetUpdateJobName(
    Database database
)
Visual Basic
Public Shared Function GetUpdateJobName ( _
    database As Database _
) As String
Visual C++
public:
static String^ GetUpdateJobName(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

Return Value

The job name.

See Also

IndexingManager Class
Sitecore.Data.Managers Namespace


UpdateIndex Method

[image]

Sitecore 6.4.1 API
IndexingManager..::..UpdateIndex Method
IndexingManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void UpdateIndex(
    Database database
)
Visual Basic
Public Shared Sub UpdateIndex ( _
    database As Database _
)
Visual C++
public:
static void UpdateIndex(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database

[Missing <param name="database"/> documentation for "M:Sitecore.Data.Managers.IndexingManager.UpdateIndex(Sitecore.Data.Database)"]

See Also

IndexingManager Class
Sitecore.Data.Managers Namespace


UpdateIndexAsync Method

[image]

Sitecore 6.4.1 API
IndexingManager..::..UpdateIndexAsync Method
IndexingManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void UpdateIndexAsync(
    Database database
)
Visual Basic
Public Shared Sub UpdateIndexAsync ( _
    database As Database _
)
Visual C++
public:
static void UpdateIndexAsync(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database

[Missing <param name="database"/> documentation for "M:Sitecore.Data.Managers.IndexingManager.UpdateIndexAsync(Sitecore.Data.Database)"]

See Also

IndexingManager Class
Sitecore.Data.Managers Namespace


IndexingManager Properties

[image] [image]

Sitecore 6.4.1 API
IndexingManager Properties
IndexingManager Class See Also Send Feedback

The IndexingManager type exposes the following members.

Properties

Name | Description
LastUpdatePropertyKey | Gets the key to use when storing the last update date.
Provider | Gets the active provider.

See Also

IndexingManager Class
Sitecore.Data.Managers Namespace


LastUpdatePropertyKey Property

[image]

Sitecore 6.4.1 API
IndexingManager..::..LastUpdatePropertyKey Property
IndexingManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string LastUpdatePropertyKey { get; }
Visual Basic
Public Shared ReadOnly Property LastUpdatePropertyKey As String
    Get
Visual C++
public:
static property String^ LastUpdatePropertyKey {
    String^ get ();
}

Return Value

See Also

IndexingManager Class
Sitecore.Data.Managers Namespace


Provider Property

[image]

Sitecore 6.4.1 API
IndexingManager..::..Provider Property
IndexingManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static IndexingProvider Provider { get; }
Visual Basic
Public Shared ReadOnly Property Provider As IndexingProvider
    Get
Visual C++
public:
static property IndexingProvider^ Provider {
    IndexingProvider^ get ();
}

Field Value

The provider.

See Also

IndexingManager Class
Sitecore.Data.Managers Namespace


IndexingProvider Class

[image]

Sitecore 6.4.1 API
IndexingProvider Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class IndexingProvider
Visual Basic
Public Class IndexingProvider
Visual C++
public ref class IndexingProvider

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Managers..::..IndexingProvider

See Also

IndexingProvider Members
Sitecore.Data.Managers Namespace


IndexingProvider Members

[image] [image]

Sitecore 6.4.1 API
IndexingProvider Members
IndexingProvider Class Constructors Methods Events See Also Send Feedback

The IndexingProvider type exposes the following members.

Constructors

 | Name | Description
Public method | IndexingProvider | Initializes a new instance of the IndexingProvider class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateIndex(Database) | Updates the index(es) for a specific database.
Public method | UpdateIndex(Database, DateTime) | Updates the index(es) for a specific database.

Events

 | Name | Description
Public event | OnRemoveItem | Occurs when the provider removes an item from the index.
Public event | OnRemoveVersion | Occurs when the provider removes a version from the index.
Public event | OnUpdateItem | Occurs when the provider updates an item in the index.

See Also

IndexingProvider Class
Sitecore.Data.Managers Namespace


IndexingProvider Constructor

[image]

Sitecore 6.4.1 API
IndexingProvider Constructor
IndexingProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IndexingProvider()
Visual Basic
Public Sub New
Visual C++
public:
IndexingProvider()

See Also

IndexingProvider Class
Sitecore.Data.Managers Namespace


IndexingProvider Methods

[image] [image]

Sitecore 6.4.1 API
IndexingProvider Methods
IndexingProvider Class See Also Send Feedback

The IndexingProvider type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateIndex(Database) | Updates the index(es) for a specific database.
Public method | UpdateIndex(Database, DateTime) | Updates the index(es) for a specific database.

See Also

IndexingProvider Class
Sitecore.Data.Managers Namespace


UpdateIndex Method

[image] [image]

Sitecore 6.4.1 API
IndexingProvider..::..UpdateIndex Method
IndexingProvider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UpdateIndex(Database) | Updates the index(es) for a specific database.
Public method | UpdateIndex(Database, DateTime) | Updates the index(es) for a specific database.

See Also

IndexingProvider Class
IndexingProvider Members
Sitecore.Data.Managers Namespace


UpdateIndex Method (Database)

[image]

Sitecore 6.4.1 API
IndexingProvider..::..UpdateIndex Method (Database)
IndexingProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void UpdateIndex(
    Database database
)
Visual Basic
Public Overridable Sub UpdateIndex ( _
    database As Database _
)
Visual C++
public:
virtual void UpdateIndex(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

See Also

IndexingProvider Class
UpdateIndex Overload
Sitecore.Data.Managers Namespace


UpdateIndex Method (Database, DateTime)

[image]

Sitecore 6.4.1 API
IndexingProvider..::..UpdateIndex Method (Database, DateTime)
IndexingProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void UpdateIndex(
    Database database,
    DateTime from
)
Visual Basic
Public Overridable Sub UpdateIndex ( _
    database As Database, _
    from As DateTime _
)
Visual C++
public:
virtual void UpdateIndex(
    Database^ database,
    DateTime from
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.
from
Type: System..::..DateTime
From date (UTC).

See Also

IndexingProvider Class
UpdateIndex Overload
Sitecore.Data.Managers Namespace


IndexingProvider Events

[image] [image]

Sitecore 6.4.1 API
IndexingProvider Events
IndexingProvider Class See Also Send Feedback

The IndexingProvider type exposes the following members.

Events

 | Name | Description
Public event | OnRemoveItem | Occurs when the provider removes an item from the index.
Public event | OnRemoveVersion | Occurs when the provider removes a version from the index.
Public event | OnUpdateItem | Occurs when the provider updates an item in the index.

See Also

IndexingProvider Class
Sitecore.Data.Managers Namespace


OnRemoveItem Event

[image]

Sitecore 6.4.1 API
IndexingProvider..::..OnRemoveItem Event
IndexingProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler OnRemoveItem
Visual Basic
Public Event OnRemoveItem As EventHandler
Visual C++
public:
 event EventHandler^ OnRemoveItem {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

IndexingProvider Class
Sitecore.Data.Managers Namespace


OnRemoveVersion Event

[image]

Sitecore 6.4.1 API
IndexingProvider..::..OnRemoveVersion Event
IndexingProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler OnRemoveVersion
Visual Basic
Public Event OnRemoveVersion As EventHandler
Visual C++
public:
 event EventHandler^ OnRemoveVersion {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

IndexingProvider Class
Sitecore.Data.Managers Namespace


OnUpdateItem Event

[image]

Sitecore 6.4.1 API
IndexingProvider..::..OnUpdateItem Event
IndexingProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler OnUpdateItem
Visual Basic
Public Event OnUpdateItem As EventHandler
Visual C++
public:
 event EventHandler^ OnUpdateItem {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

IndexingProvider Class
Sitecore.Data.Managers Namespace


ItemManager Class

[image]

Sitecore 6.4.1 API
ItemManager Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class ItemManager
Visual Basic
Public NotInheritable Class ItemManager
Visual C++
public ref class ItemManager abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Managers..::..ItemManager

See Also

ItemManager Members
Sitecore.Data.Managers Namespace


ItemManager Members

[image] [image]

Sitecore 6.4.1 API
ItemManager Members
ItemManager Class Methods Properties See Also Send Feedback

The ItemManager type exposes the following members.

Methods

Name | Description
AddFromTemplate(String, ID, Item) | Adds a new item from a template.
AddFromTemplate(String, ID, Item, ID) | Adds a new item from a template.
AddVersion(Item) | Adds a new version to an item by copying the data from an existing version.
AddVersion(Item, SecurityCheck) | Adds a new version to an item by copying the data from an existing version.
BlobStreamExists | Determines whether the specified field contains a BLOB value.
CopyItem(Item, Item, Boolean) | Copies a specified item. Destination item should be in the same database with target item.
CopyItem(Item, Item, Boolean, String) | Copies a specified item. Destination item should be in the same database with target item.
CopyItem(Item, Item, Boolean, String, ID) | Copies a specified item. Destination item should be in the same database with target item.
CreateItem(String, Item, ID) | Creates an empty item.
CreateItem(String, Item, ID, ID) | Creates an empty item.
CreateItem(String, Item, ID, ID, SecurityCheck) | Creates an empty item.
DeleteItem(Item) | Deletes an item.
DeleteItem(Item, SecurityCheck) | Deletes an item.
GetBlobStream(Field) | Gets the BLOB stream associated with a field.
GetBlobStream(Guid, Database) | Gets a BLOB stream from its id.
GetChildren(Item) | Gets the children of an item.
GetChildren(Item, SecurityCheck) | Gets the children of an item.
GetContentLanguages | Gets the content languages (ie. the languages for which the item has content).
GetItem(String, Language, Version, Database) | Gets an item from a database.
GetItem(ID, Language, Version, Database) | Gets an item from a database.
GetItem(String, Language, Version, Database, SecurityCheck) | Gets an item from a database.
GetItem(ID, Language, Version, Database, SecurityCheck) | Gets an item from a database.
GetParent(Item) | Gets the parent of an item.
GetParent(Item, SecurityCheck) | Gets the parent of an item.
GetRootItem(Language, Version, Database) | Gets the root item.
GetRootItem(Language, Version, Database, SecurityCheck) | Gets the root item.
GetVersions(Item) | Gets the version numbers of an item.
GetVersions(Item, Language) | Gets the version numbers of an item.
HasChildren(Item) | Determines whether the specified item has children.
HasChildren(Item, SecurityCheck) | Determines whether the specified item has children.
Initialize | Initializes class.
MoveItem(Item, Item) | Moves an item.
MoveItem(Item, Item, SecurityCheck) | Moves an item.
RemoveData(ID, Database) | Removes all data from an item.
RemoveData(ID, Language, Boolean, Database) | Removes all data in a specific language from an item.
RemoveVersion(Item) | Removes a version from an item.
RemoveVersion(Item, SecurityCheck) | Removes a version from an item.
RemoveVersions | Deletes all versions in the specified language.
ResolvePath | Resolves an item path to an id.
SaveItem | Saves changes to an item.
SetBlobStream | Sets the BLOB stream associated with a field.

Properties

Name | Description
Provider | The provider instance handling requests to the maanager.
Providers | Gets the providers.

See Also

ItemManager Class
Sitecore.Data.Managers Namespace


ItemManager Methods

[image] [image]

Sitecore 6.4.1 API
ItemManager Methods
ItemManager Class See Also Send Feedback

The ItemManager type exposes the following members.

Methods

Name | Description
AddFromTemplate(String, ID, Item) | Adds a new item from a template.
AddFromTemplate(String, ID, Item, ID) | Adds a new item from a template.
AddVersion(Item) | Adds a new version to an item by copying the data from an existing version.
AddVersion(Item, SecurityCheck) | Adds a new version to an item by copying the data from an existing version.
BlobStreamExists | Determines whether the specified field contains a BLOB value.
CopyItem(Item, Item, Boolean) | Copies a specified item. Destination item should be in the same database with target item.
CopyItem(Item, Item, Boolean, String) | Copies a specified item. Destination item should be in the same database with target item.
CopyItem(Item, Item, Boolean, String, ID) | Copies a specified item. Destination item should be in the same database with target item.
CreateItem(String, Item, ID) | Creates an empty item.
CreateItem(String, Item, ID, ID) | Creates an empty item.
CreateItem(String, Item, ID, ID, SecurityCheck) | Creates an empty item.
DeleteItem(Item) | Deletes an item.
DeleteItem(Item, SecurityCheck) | Deletes an item.
GetBlobStream(Field) | Gets the BLOB stream associated with a field.
GetBlobStream(Guid, Database) | Gets a BLOB stream from its id.
GetChildren(Item) | Gets the children of an item.
GetChildren(Item, SecurityCheck) | Gets the children of an item.
GetContentLanguages | Gets the content languages (ie. the languages for which the item has content).
GetItem(String, Language, Version, Database) | Gets an item from a database.
GetItem(ID, Language, Version, Database) | Gets an item from a database.
GetItem(String, Language, Version, Database, SecurityCheck) | Gets an item from a database.
GetItem(ID, Language, Version, Database, SecurityCheck) | Gets an item from a database.
GetParent(Item) | Gets the parent of an item.
GetParent(Item, SecurityCheck) | Gets the parent of an item.
GetRootItem(Language, Version, Database) | Gets the root item.
GetRootItem(Language, Version, Database, SecurityCheck) | Gets the root item.
GetVersions(Item) | Gets the version numbers of an item.
GetVersions(Item, Language) | Gets the version numbers of an item.
HasChildren(Item) | Determines whether the specified item has children.
HasChildren(Item, SecurityCheck) | Determines whether the specified item has children.
Initialize | Initializes class.
MoveItem(Item, Item) | Moves an item.
MoveItem(Item, Item, SecurityCheck) | Moves an item.
RemoveData(ID, Database) | Removes all data from an item.
RemoveData(ID, Language, Boolean, Database) | Removes all data in a specific language from an item.
RemoveVersion(Item) | Removes a version from an item.
RemoveVersion(Item, SecurityCheck) | Removes a version from an item.
RemoveVersions | Deletes all versions in the specified language.
ResolvePath | Resolves an item path to an id.
SaveItem | Saves changes to an item.
SetBlobStream | Sets the BLOB stream associated with a field.

See Also

ItemManager Class
Sitecore.Data.Managers Namespace


AddFromTemplate Method

[image] [image]

Sitecore 6.4.1 API
ItemManager..::..AddFromTemplate Method
ItemManager Class See Also Send Feedback

Overload List

Name | Description
AddFromTemplate(String, ID, Item) | Adds a new item from a template.
AddFromTemplate(String, ID, Item, ID) | Adds a new item from a template.

See Also

ItemManager Class
ItemManager Members
Sitecore.Data.Managers Namespace


AddFromTemplate Method (String, ID, Item)

[image]

Sitecore 6.4.1 API
ItemManager..::..AddFromTemplate Method (String, ID, Item)
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item AddFromTemplate(
    string itemName,
    ID templateId,
    Item destination
)
Visual Basic
Public Shared Function AddFromTemplate ( _
    itemName As String, _
    templateId As ID, _
    destination As Item _
) As Item
Visual C++
public:
static Item^ AddFromTemplate(
    String^ itemName,
    ID^ templateId,
    Item^ destination
)

Parameters

itemName
Type: System..::..String
Name of the new item.
templateId
Type: Sitecore.Data..::..ID
The template id.
destination
Type: Sitecore.Data.Items..::..Item
The destination item. This will be the parent of the new item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Managers.ItemManager.AddFromTemplate(System.String,Sitecore.Data.ID,Sitecore.Data.Items.Item)"]

See Also

ItemManager Class
AddFromTemplate Overload
Sitecore.Data.Managers Namespace


AddFromTemplate Method (String, ID, Item, ID)

[image]

Sitecore 6.4.1 API
ItemManager..::..AddFromTemplate Method (String, ID, Item, ID)
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item AddFromTemplate(
    string itemName,
    ID templateId,
    Item destination,
    ID newItemId
)
Visual Basic
Public Shared Function AddFromTemplate ( _
    itemName As String, _
    templateId As ID, _
    destination As Item, _
    newItemId As ID _
) As Item
Visual C++
public:
static Item^ AddFromTemplate(
    String^ itemName,
    ID^ templateId,
    Item^ destination,
    ID^ newItemId
)

Parameters

itemName
Type: System..::..String
Name of the new item.
templateId
Type: Sitecore.Data..::..ID
The template id.
destination
Type: Sitecore.Data.Items..::..Item
The destination item. This will be the parent of the new item.
newItemId
Type: Sitecore.Data..::..ID
The id of the new item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Managers.ItemManager.AddFromTemplate(System.String,Sitecore.Data.ID,Sitecore.Data.Items.Item,Sitecore.Data.ID)"]

See Also

ItemManager Class
AddFromTemplate Overload
Sitecore.Data.Managers Namespace


AddVersion Method

[image] [image]

Sitecore 6.4.1 API
ItemManager..::..AddVersion Method
ItemManager Class See Also Send Feedback

Overload List

Name | Description
AddVersion(Item) | Adds a new version to an item by copying the data from an existing version.
AddVersion(Item, SecurityCheck) | Adds a new version to an item by copying the data from an existing version.

See Also

ItemManager Class
ItemManager Members
Sitecore.Data.Managers Namespace


AddVersion Method (Item)

[image]

Sitecore 6.4.1 API
ItemManager..::..AddVersion Method (Item)
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item AddVersion(
    Item item
)
Visual Basic
Public Shared Function AddVersion ( _
    item As Item _
) As Item
Visual C++
public:
static Item^ AddVersion(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item that will have a version added.

Return Value

The added version of the item. If a version could not be added to the item, null is returned.

See Also

ItemManager Class
AddVersion Overload
Sitecore.Data.Managers Namespace


AddVersion Method (Item, SecurityCheck)

[image]

Sitecore 6.4.1 API
ItemManager..::..AddVersion Method (Item, SecurityCheck)
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item AddVersion(
    Item item,
    SecurityCheck securityCheck
)
Visual Basic
Public Shared Function AddVersion ( _
    item As Item, _
    securityCheck As SecurityCheck _
) As Item
Visual C++
public:
static Item^ AddVersion(
    Item^ item,
    SecurityCheck securityCheck
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item that will have a version added.
securityCheck
Type: Sitecore.SecurityModel..::..SecurityCheck
The security check.

Return Value

The added version of the item. If a version could not be added to the item, null is returned.

See Also

ItemManager Class
AddVersion Overload
Sitecore.Data.Managers Namespace


BlobStreamExists Method

[image]

Sitecore 6.4.1 API
ItemManager..::..BlobStreamExists Method
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool BlobStreamExists(
    Guid blobId,
    Database database
)
Visual Basic
Public Shared Function BlobStreamExists ( _
    blobId As Guid, _
    database As Database _
) As Boolean
Visual C++
public:
static bool BlobStreamExists(
    Guid blobId,
    Database^ database
)

Parameters

blobId
Type: System..::..Guid
The BLOB id.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

true if the specified field contains a BLOB value; otherwise, false.

See Also

ItemManager Class
Sitecore.Data.Managers Namespace


CopyItem Method (Item, Item, Boolean)

[image]

Sitecore 6.4.1 API
ItemManager..::..CopyItem Method (Item, Item, Boolean)
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item CopyItem(
    Item source,
    Item destination,
    bool deep
)
Visual Basic
Public Shared Function CopyItem ( _
    source As Item, _
    destination As Item, _
    deep As Boolean _
) As Item
Visual C++
public:
static Item^ CopyItem(
    Item^ source,
    Item^ destination,
    bool deep
)

Parameters

source
Type: Sitecore.Data.Items..::..Item
The item to copy.
destination
Type: Sitecore.Data.Items..::..Item
The destination.
deep
Type: System..::..Boolean
if set to true this instance is deep.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Managers.ItemManager.CopyItem(Sitecore.Data.Items.Item,Sitecore.Data.Items.Item,System.Boolean)"]

See Also

ItemManager Class
CopyItem Overload
Sitecore.Data.Managers Namespace


CopyItem Method (Item, Item, Boolean, String)

[image]

Sitecore 6.4.1 API
ItemManager..::..CopyItem Method (Item, Item, Boolean, String)
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item CopyItem(
    Item source,
    Item destination,
    bool deep,
    string copyName
)
Visual Basic
Public Shared Function CopyItem ( _
    source As Item, _
    destination As Item, _
    deep As Boolean, _
    copyName As String _
) As Item
Visual C++
public:
static Item^ CopyItem(
    Item^ source,
    Item^ destination,
    bool deep,
    String^ copyName
)

Parameters

source
Type: Sitecore.Data.Items..::..Item
The item to copy.
destination
Type: Sitecore.Data.Items..::..Item
The destination.
deep
Type: System..::..Boolean
if set to true [deep].
copyName
Type: System..::..String
Name of the copied item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Managers.ItemManager.CopyItem(Sitecore.Data.Items.Item,Sitecore.Data.Items.Item,System.Boolean,System.String)"]

See Also

ItemManager Class
CopyItem Overload
Sitecore.Data.Managers Namespace


CopyItem Method (Item, Item, Boolean, String, ID)

[image]

Sitecore 6.4.1 API
ItemManager..::..CopyItem Method (Item, Item, Boolean, String, ID)
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item CopyItem(
    Item source,
    Item destination,
    bool deep,
    string copyName,
    ID copyId
)
Visual Basic
Public Shared Function CopyItem ( _
    source As Item, _
    destination As Item, _
    deep As Boolean, _
    copyName As String, _
    copyId As ID _
) As Item
Visual C++
public:
static Item^ CopyItem(
    Item^ source,
    Item^ destination,
    bool deep,
    String^ copyName,
    ID^ copyId
)

Parameters

source
Type: Sitecore.Data.Items..::..Item
The item to copy.
destination
Type: Sitecore.Data.Items..::..Item
The destination.
deep
Type: System..::..Boolean
If set to true, child items will be copied recursively.
copyName
Type: System..::..String
Name of the copied item.
copyId
Type: Sitecore.Data..::..ID
Id of the copied item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Managers.ItemManager.CopyItem(Sitecore.Data.Items.Item,Sitecore.Data.Items.Item,System.Boolean,System.String,Sitecore.Data.ID)"]

See Also

ItemManager Class
CopyItem Overload
Sitecore.Data.Managers Namespace


CreateItem Method

[image] [image]

Sitecore 6.4.1 API
ItemManager..::..CreateItem Method
ItemManager Class See Also Send Feedback

Overload List

Name | Description
CreateItem(String, Item, ID) | Creates an empty item.
CreateItem(String, Item, ID, ID) | Creates an empty item.
CreateItem(String, Item, ID, ID, SecurityCheck) | Creates an empty item.

See Also

ItemManager Class
ItemManager Members
Sitecore.Data.Managers Namespace


CreateItem Method (String, Item, ID)

[image]

Sitecore 6.4.1 API
ItemManager..::..CreateItem Method (String, Item, ID)
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item CreateItem(
    string itemName,
    Item destination,
    ID templateId
)
Visual Basic
Public Shared Function CreateItem ( _
    itemName As String, _
    destination As Item, _
    templateId As ID _
) As Item
Visual C++
public:
static Item^ CreateItem(
    String^ itemName,
    Item^ destination,
    ID^ templateId
)

Parameters

itemName
Type: System..::..String
Name of the item.
destination
Type: Sitecore.Data.Items..::..Item
The destination.
templateId
Type: Sitecore.Data..::..ID
The template ID.

Return Value

The created item. If the item could not be created, null is returned.

See Also

ItemManager Class
CreateItem Overload
Sitecore.Data.Managers Namespace


CreateItem Method (String, Item, ID, ID)

[image]

Sitecore 6.4.1 API
ItemManager..::..CreateItem Method (String, Item, ID, ID)
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item CreateItem(
    string itemName,
    Item destination,
    ID templateId,
    ID newId
)
Visual Basic
Public Shared Function CreateItem ( _
    itemName As String, _
    destination As Item, _
    templateId As ID, _
    newId As ID _
) As Item
Visual C++
public:
static Item^ CreateItem(
    String^ itemName,
    Item^ destination,
    ID^ templateId,
    ID^ newId
)

Parameters

itemName
Type: System..::..String
Name of the item.
destination
Type: Sitecore.Data.Items..::..Item
The destination.
templateId
Type: Sitecore.Data..::..ID
The template ID.
newId
Type: Sitecore.Data..::..ID
The item id.

Return Value

The created item. If the item could not be created, null is returned.

See Also

ItemManager Class
CreateItem Overload
Sitecore.Data.Managers Namespace


CreateItem Method (String, Item, ID, ID, SecurityCheck)

[image]

Sitecore 6.4.1 API
ItemManager..::..CreateItem Method (String, Item, ID, ID, SecurityCheck)
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item CreateItem(
    string itemName,
    Item destination,
    ID templateId,
    ID newId,
    SecurityCheck securityCheck
)
Visual Basic
Public Shared Function CreateItem ( _
    itemName As String, _
    destination As Item, _
    templateId As ID, _
    newId As ID, _
    securityCheck As SecurityCheck _
) As Item
Visual C++
public:
static Item^ CreateItem(
    String^ itemName,
    Item^ destination,
    ID^ templateId,
    ID^ newId,
    SecurityCheck securityCheck
)

Parameters

itemName
Type: System..::..String
Name of the item.
destination
Type: Sitecore.Data.Items..::..Item
The destination.
templateId
Type: Sitecore.Data..::..ID
The template ID.
newId
Type: Sitecore.Data..::..ID
The item id.
securityCheck
Type: Sitecore.SecurityModel..::..SecurityCheck
The security check.

Return Value

The created item. If the item was created, but could not be read, null is returned.

See Also

ItemManager Class
CreateItem Overload
Sitecore.Data.Managers Namespace


DeleteItem Method

[image] [image]

Sitecore 6.4.1 API
ItemManager..::..DeleteItem Method
ItemManager Class See Also Send Feedback

Overload List

Name | Description
DeleteItem(Item) | Deletes an item.
DeleteItem(Item, SecurityCheck) | Deletes an item.

See Also

ItemManager Class
ItemManager Members
Sitecore.Data.Managers Namespace


DeleteItem Method (Item)

[image]

Sitecore 6.4.1 API
ItemManager..::..DeleteItem Method (Item)
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool DeleteItem(
    Item item
)
Visual Basic
Public Shared Function DeleteItem ( _
    item As Item _
) As Boolean
Visual C++
public:
static bool DeleteItem(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item to delete.

Return Value

True if the item was deleted, false otherwise.

See Also

ItemManager Class
DeleteItem Overload
Sitecore.Data.Managers Namespace


DeleteItem Method (Item, SecurityCheck)

[image]

Sitecore 6.4.1 API
ItemManager..::..DeleteItem Method (Item, SecurityCheck)
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool DeleteItem(
    Item item,
    SecurityCheck securityCheck
)
Visual Basic
Public Shared Function DeleteItem ( _
    item As Item, _
    securityCheck As SecurityCheck _
) As Boolean
Visual C++
public:
static bool DeleteItem(
    Item^ item,
    SecurityCheck securityCheck
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item to delete.
securityCheck
Type: Sitecore.SecurityModel..::..SecurityCheck
The security check.

Return Value

True if the item was deleted, false otherwise.

See Also

ItemManager Class
DeleteItem Overload
Sitecore.Data.Managers Namespace


GetBlobStream Method

[image] [image]

Sitecore 6.4.1 API
ItemManager..::..GetBlobStream Method
ItemManager Class See Also Send Feedback

Overload List

Name | Description
GetBlobStream(Field) | Gets the BLOB stream associated with a field.
GetBlobStream(Guid, Database) | Gets a BLOB stream from its id.

See Also

ItemManager Class
ItemManager Members
Sitecore.Data.Managers Namespace


GetBlobStream Method (Field)

[image]

Sitecore 6.4.1 API
ItemManager..::..GetBlobStream Method (Field)
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Stream GetBlobStream(
    Field field
)
Visual Basic
Public Shared Function GetBlobStream ( _
    field As Field _
) As Stream
Visual C++
public:
static Stream^ GetBlobStream(
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.

Return Value

The stream.

See Also

ItemManager Class
GetBlobStream Overload
Sitecore.Data.Managers Namespace


GetBlobStream Method (Guid, Database)

[image]

Sitecore 6.4.1 API
ItemManager..::..GetBlobStream Method (Guid, Database)
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Stream GetBlobStream(
    Guid blobId,
    Database database
)
Visual Basic
Public Shared Function GetBlobStream ( _
    blobId As Guid, _
    database As Database _
) As Stream
Visual C++
public:
static Stream^ GetBlobStream(
    Guid blobId,
    Database^ database
)

Parameters

blobId
Type: System..::..Guid
The BLOB id.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

The stream.

See Also

ItemManager Class
GetBlobStream Overload
Sitecore.Data.Managers Namespace


GetChildren Method

[image] [image]

Sitecore 6.4.1 API
ItemManager..::..GetChildren Method
ItemManager Class See Also Send Feedback

Overload List

Name | Description
GetChildren(Item) | Gets the children of an item.
GetChildren(Item, SecurityCheck) | Gets the children of an item.

See Also

ItemManager Class
ItemManager Members
Sitecore.Data.Managers Namespace


GetChildren Method (Item)

[image]

Sitecore 6.4.1 API
ItemManager..::..GetChildren Method (Item)
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ChildList GetChildren(
    Item item
)
Visual Basic
Public Shared Function GetChildren ( _
    item As Item _
) As ChildList
Visual C++
public:
static ChildList^ GetChildren(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The parent item.

Return Value

The child items.

See Also

ItemManager Class
GetChildren Overload
Sitecore.Data.Managers Namespace


GetChildren Method (Item, SecurityCheck)

[image]

Sitecore 6.4.1 API
ItemManager..::..GetChildren Method (Item, SecurityCheck)
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ChildList GetChildren(
    Item item,
    SecurityCheck securityCheck
)
Visual Basic
Public Shared Function GetChildren ( _
    item As Item, _
    securityCheck As SecurityCheck _
) As ChildList
Visual C++
public:
static ChildList^ GetChildren(
    Item^ item,
    SecurityCheck securityCheck
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The parent item.
securityCheck
Type: Sitecore.SecurityModel..::..SecurityCheck
The security check.

Return Value

The child items.

See Also

ItemManager Class
GetChildren Overload
Sitecore.Data.Managers Namespace


GetItem Method

[image] [image]

Sitecore 6.4.1 API
ItemManager..::..GetItem Method
ItemManager Class See Also Send Feedback

Overload List

Name | Description
GetItem(String, Language, Version, Database) | Gets an item from a database.
GetItem(ID, Language, Version, Database) | Gets an item from a database.
GetItem(String, Language, Version, Database, SecurityCheck) | Gets an item from a database.
GetItem(ID, Language, Version, Database, SecurityCheck) | Gets an item from a database.

See Also

ItemManager Class
ItemManager Members
Sitecore.Data.Managers Namespace


GetItem Method (String, Language, Version, Database)

[image]

Sitecore 6.4.1 API
ItemManager..::..GetItem Method (String, Language, Version, Database)
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item GetItem(
    string itemPath,
    Language language,
    Version version,
    Database database
)
Visual Basic
Public Shared Function GetItem ( _
    itemPath As String, _
    language As Language, _
    version As Version, _
    database As Database _
) As Item
Visual C++
public:
static Item^ GetItem(
    String^ itemPath,
    Language^ language,
    Version^ version,
    Database^ database
)

Parameters

itemPath
Type: System..::..String
The item path.
language
Type: Sitecore.Globalization..::..Language
The language of the item to get.
version
Type: Sitecore.Data..::..Version
The version of the item to get.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

The item. If no item is found, null is returned.

See Also

ItemManager Class
GetItem Overload
Sitecore.Data.Managers Namespace


GetItem Method (ID, Language, Version, Database)

[image]

Sitecore 6.4.1 API
ItemManager..::..GetItem Method (ID, Language, Version, Database)
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item GetItem(
    ID itemId,
    Language language,
    Version version,
    Database database
)
Visual Basic
Public Shared Function GetItem ( _
    itemId As ID, _
    language As Language, _
    version As Version, _
    database As Database _
) As Item
Visual C++
public:
static Item^ GetItem(
    ID^ itemId,
    Language^ language,
    Version^ version,
    Database^ database
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
language
Type: Sitecore.Globalization..::..Language
The language of the item to get.
version
Type: Sitecore.Data..::..Version
The version of the item to get.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

The item. If no item is found, null is returned.

See Also

ItemManager Class
GetItem Overload
Sitecore.Data.Managers Namespace


GetItem Method (String, Language, Version, Database, SecurityCheck)

[image]

Sitecore 6.4.1 API
ItemManager..::..GetItem Method (String, Language, Version, Database, SecurityCheck)
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item GetItem(
    string itemPath,
    Language language,
    Version version,
    Database database,
    SecurityCheck securityCheck
)
Visual Basic
Public Shared Function GetItem ( _
    itemPath As String, _
    language As Language, _
    version As Version, _
    database As Database, _
    securityCheck As SecurityCheck _
) As Item
Visual C++
public:
static Item^ GetItem(
    String^ itemPath,
    Language^ language,
    Version^ version,
    Database^ database,
    SecurityCheck securityCheck
)

Parameters

itemPath
Type: System..::..String
The item path.
language
Type: Sitecore.Globalization..::..Language
The language of the item to get.
version
Type: Sitecore.Data..::..Version
The version of the item to get.
database
Type: Sitecore.Data..::..Database
The database.
securityCheck
Type: Sitecore.SecurityModel..::..SecurityCheck
The security check.

Return Value

The item. If no item is found, null is returned.

See Also

ItemManager Class
GetItem Overload
Sitecore.Data.Managers Namespace


GetItem Method (ID, Language, Version, Database, SecurityCheck)

[image]

Sitecore 6.4.1 API
ItemManager..::..GetItem Method (ID, Language, Version, Database, SecurityCheck)
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item GetItem(
    ID itemId,
    Language language,
    Version version,
    Database database,
    SecurityCheck securityCheck
)
Visual Basic
Public Shared Function GetItem ( _
    itemId As ID, _
    language As Language, _
    version As Version, _
    database As Database, _
    securityCheck As SecurityCheck _
) As Item
Visual C++
public:
static Item^ GetItem(
    ID^ itemId,
    Language^ language,
    Version^ version,
    Database^ database,
    SecurityCheck securityCheck
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
language
Type: Sitecore.Globalization..::..Language
The language of the item to get.
version
Type: Sitecore.Data..::..Version
The version of the item to get.
database
Type: Sitecore.Data..::..Database
The database.
securityCheck
Type: Sitecore.SecurityModel..::..SecurityCheck
The security check.

Return Value

The item. If no item is found, null is returned.

See Also

ItemManager Class
GetItem Overload
Sitecore.Data.Managers Namespace


GetParent Method

[image] [image]

Sitecore 6.4.1 API
ItemManager..::..GetParent Method
ItemManager Class See Also Send Feedback

Overload List

Name | Description
GetParent(Item) | Gets the parent of an item.
GetParent(Item, SecurityCheck) | Gets the parent of an item.

See Also

ItemManager Class
ItemManager Members
Sitecore.Data.Managers Namespace


GetParent Method (Item)

[image]

Sitecore 6.4.1 API
ItemManager..::..GetParent Method (Item)
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item GetParent(
    Item item
)
Visual Basic
Public Shared Function GetParent ( _
    item As Item _
) As Item
Visual C++
public:
static Item^ GetParent(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

The parent item.

See Also

ItemManager Class
GetParent Overload
Sitecore.Data.Managers Namespace


GetParent Method (Item, SecurityCheck)

[image]

Sitecore 6.4.1 API
ItemManager..::..GetParent Method (Item, SecurityCheck)
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item GetParent(
    Item item,
    SecurityCheck securityCheck
)
Visual Basic
Public Shared Function GetParent ( _
    item As Item, _
    securityCheck As SecurityCheck _
) As Item
Visual C++
public:
static Item^ GetParent(
    Item^ item,
    SecurityCheck securityCheck
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
securityCheck
Type: Sitecore.SecurityModel..::..SecurityCheck
The security check.

Return Value

The parent item.

See Also

ItemManager Class
GetParent Overload
Sitecore.Data.Managers Namespace


GetRootItem Method

[image] [image]

Sitecore 6.4.1 API
ItemManager..::..GetRootItem Method
ItemManager Class See Also Send Feedback

Overload List

Name | Description
GetRootItem(Language, Version, Database) | Gets the root item.
GetRootItem(Language, Version, Database, SecurityCheck) | Gets the root item.

See Also

ItemManager Class
ItemManager Members
Sitecore.Data.Managers Namespace


GetRootItem Method (Language, Version, Database)

[image]

Sitecore 6.4.1 API
ItemManager..::..GetRootItem Method (Language, Version, Database)
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item GetRootItem(
    Language language,
    Version version,
    Database database
)
Visual Basic
Public Shared Function GetRootItem ( _
    language As Language, _
    version As Version, _
    database As Database _
) As Item
Visual C++
public:
static Item^ GetRootItem(
    Language^ language,
    Version^ version,
    Database^ database
)

Parameters

language
Type: Sitecore.Globalization..::..Language
The language to return.
version
Type: Sitecore.Data..::..Version
The version to return.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

The root item. If no item is found, null is returned.

See Also

ItemManager Class
GetRootItem Overload
Sitecore.Data.Managers Namespace


GetRootItem Method (Language, Version, Database, SecurityCheck)

[image]

Sitecore 6.4.1 API
ItemManager..::..GetRootItem Method (Language, Version, Database, SecurityCheck)
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item GetRootItem(
    Language language,
    Version version,
    Database database,
    SecurityCheck securityCheck
)
Visual Basic
Public Shared Function GetRootItem ( _
    language As Language, _
    version As Version, _
    database As Database, _
    securityCheck As SecurityCheck _
) As Item
Visual C++
public:
static Item^ GetRootItem(
    Language^ language,
    Version^ version,
    Database^ database,
    SecurityCheck securityCheck
)

Parameters

language
Type: Sitecore.Globalization..::..Language
The language to return.
version
Type: Sitecore.Data..::..Version
The version to return.
database
Type: Sitecore.Data..::..Database
The database.
securityCheck
Type: Sitecore.SecurityModel..::..SecurityCheck
The security check.

Return Value

The root item. If no item is found, null is returned.

See Also

ItemManager Class
GetRootItem Overload
Sitecore.Data.Managers Namespace


GetVersions Method

[image] [image]

Sitecore 6.4.1 API
ItemManager..::..GetVersions Method
ItemManager Class See Also Send Feedback

Overload List

Name | Description
GetVersions(Item) | Gets the version numbers of an item.
GetVersions(Item, Language) | Gets the version numbers of an item.

See Also

ItemManager Class
ItemManager Members
Sitecore.Data.Managers Namespace


GetVersions Method (Item)

[image]

Sitecore 6.4.1 API
ItemManager..::..GetVersions Method (Item)
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static VersionCollection GetVersions(
    Item item
)
Visual Basic
Public Shared Function GetVersions ( _
    item As Item _
) As VersionCollection
Visual C++
public:
static VersionCollection^ GetVersions(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

The list of versions.

See Also

ItemManager Class
GetVersions Overload
Sitecore.Data.Managers Namespace


GetVersions Method (Item, Language)

[image]

Sitecore 6.4.1 API
ItemManager..::..GetVersions Method (Item, Language)
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static VersionCollection GetVersions(
    Item item,
    Language language
)
Visual Basic
Public Shared Function GetVersions ( _
    item As Item, _
    language As Language _
) As VersionCollection
Visual C++
public:
static VersionCollection^ GetVersions(
    Item^ item,
    Language^ language
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
language
Type: Sitecore.Globalization..::..Language
The language.

Return Value

The list of versions.

See Also

ItemManager Class
GetVersions Overload
Sitecore.Data.Managers Namespace


HasChildren Method

[image] [image]

Sitecore 6.4.1 API
ItemManager..::..HasChildren Method
ItemManager Class See Also Send Feedback

Overload List

Name | Description
HasChildren(Item) | Determines whether the specified item has children.
HasChildren(Item, SecurityCheck) | Determines whether the specified item has children.

See Also

ItemManager Class
ItemManager Members
Sitecore.Data.Managers Namespace


HasChildren Method (Item)

[image]

Sitecore 6.4.1 API
ItemManager..::..HasChildren Method (Item)
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool HasChildren(
    Item item
)
Visual Basic
Public Shared Function HasChildren ( _
    item As Item _
) As Boolean
Visual C++
public:
static bool HasChildren(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

true if the specified item has children; otherwise, false.

See Also

ItemManager Class
HasChildren Overload
Sitecore.Data.Managers Namespace


HasChildren Method (Item, SecurityCheck)

[image]

Sitecore 6.4.1 API
ItemManager..::..HasChildren Method (Item, SecurityCheck)
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool HasChildren(
    Item item,
    SecurityCheck securityCheck
)
Visual Basic
Public Shared Function HasChildren ( _
    item As Item, _
    securityCheck As SecurityCheck _
) As Boolean
Visual C++
public:
static bool HasChildren(
    Item^ item,
    SecurityCheck securityCheck
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
securityCheck
Type: Sitecore.SecurityModel..::..SecurityCheck
The security check.

Return Value

true if the specified item has children; otherwise, false.

See Also

ItemManager Class
HasChildren Overload
Sitecore.Data.Managers Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
ItemManager..::..Initialize Method
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Initialize()
Visual Basic
Public Shared Sub Initialize
Visual C++
public:
static void Initialize()

See Also

ItemManager Class
Sitecore.Data.Managers Namespace


MoveItem Method

[image] [image]

Sitecore 6.4.1 API
ItemManager..::..MoveItem Method
ItemManager Class See Also Send Feedback

Overload List

Name | Description
MoveItem(Item, Item) | Moves an item.
MoveItem(Item, Item, SecurityCheck) | Moves an item.

See Also

ItemManager Class
ItemManager Members
Sitecore.Data.Managers Namespace


MoveItem Method (Item, Item)

[image]

Sitecore 6.4.1 API
ItemManager..::..MoveItem Method (Item, Item)
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool MoveItem(
    Item item,
    Item destination
)
Visual Basic
Public Shared Function MoveItem ( _
    item As Item, _
    destination As Item _
) As Boolean
Visual C++
public:
static bool MoveItem(
    Item^ item,
    Item^ destination
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item to move.
destination
Type: Sitecore.Data.Items..::..Item
The destination. This will become the new parent of item.

Return Value

true if the item was moved; false otherwise.

See Also

ItemManager Class
MoveItem Overload
Sitecore.Data.Managers Namespace


MoveItem Method (Item, Item, SecurityCheck)

[image]

Sitecore 6.4.1 API
ItemManager..::..MoveItem Method (Item, Item, SecurityCheck)
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool MoveItem(
    Item item,
    Item destination,
    SecurityCheck securityCheck
)
Visual Basic
Public Shared Function MoveItem ( _
    item As Item, _
    destination As Item, _
    securityCheck As SecurityCheck _
) As Boolean
Visual C++
public:
static bool MoveItem(
    Item^ item,
    Item^ destination,
    SecurityCheck securityCheck
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
destination
Type: Sitecore.Data.Items..::..Item
The destination.
securityCheck
Type: Sitecore.SecurityModel..::..SecurityCheck
The security check.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Managers.ItemManager.MoveItem(Sitecore.Data.Items.Item,Sitecore.Data.Items.Item,Sitecore.SecurityModel.SecurityCheck)"]

See Also

ItemManager Class
MoveItem Overload
Sitecore.Data.Managers Namespace


RemoveData Method

[image] [image]

Sitecore 6.4.1 API
ItemManager..::..RemoveData Method
ItemManager Class See Also Send Feedback

Overload List

Name | Description
RemoveData(ID, Database) | Removes all data from an item.
RemoveData(ID, Language, Boolean, Database) | Removes all data in a specific language from an item.

See Also

ItemManager Class
ItemManager Members
Sitecore.Data.Managers Namespace


RemoveData Method (ID, Database)

[image]

Sitecore 6.4.1 API
ItemManager..::..RemoveData Method (ID, Database)
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool RemoveData(
    ID itemId,
    Database database
)
Visual Basic
Public Shared Function RemoveData ( _
    itemId As ID, _
    database As Database _
) As Boolean
Visual C++
public:
static bool RemoveData(
    ID^ itemId,
    Database^ database
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

true if the data was removed, otherwise false.

See Also

ItemManager Class
RemoveData Overload
Sitecore.Data.Managers Namespace


RemoveData Method (ID, Language, Boolean, Database)

[image]

Sitecore 6.4.1 API
ItemManager..::..RemoveData Method (ID, Language, Boolean, Database)
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool RemoveData(
    ID itemId,
    Language language,
    bool removeSharedData,
    Database database
)
Visual Basic
Public Shared Function RemoveData ( _
    itemId As ID, _
    language As Language, _
    removeSharedData As Boolean, _
    database As Database _
) As Boolean
Visual C++
public:
static bool RemoveData(
    ID^ itemId,
    Language^ language,
    bool removeSharedData,
    Database^ database
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
language
Type: Sitecore.Globalization..::..Language
The language of the data to remove. Specify Invariant to remove data in all languages.
removeSharedData
Type: System..::..Boolean
If set to true shared data is removed.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

true if the data was removed, otherwise false.

See Also

ItemManager Class
RemoveData Overload
Sitecore.Data.Managers Namespace


RemoveVersion Method

[image] [image]

Sitecore 6.4.1 API
ItemManager..::..RemoveVersion Method
ItemManager Class See Also Send Feedback

Overload List

Name | Description
RemoveVersion(Item) | Removes a version from an item.
RemoveVersion(Item, SecurityCheck) | Removes a version from an item.

See Also

ItemManager Class
ItemManager Members
Sitecore.Data.Managers Namespace


RemoveVersion Method (Item)

[image]

Sitecore 6.4.1 API
ItemManager..::..RemoveVersion Method (Item)
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool RemoveVersion(
    Item item
)
Visual Basic
Public Shared Function RemoveVersion ( _
    item As Item _
) As Boolean
Visual C++
public:
static bool RemoveVersion(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item representing the version to remove.

Return Value

true if the version was removed, otherwise false.

See Also

ItemManager Class
RemoveVersion Overload
Sitecore.Data.Managers Namespace


RemoveVersion Method (Item, SecurityCheck)

[image]

Sitecore 6.4.1 API
ItemManager..::..RemoveVersion Method (Item, SecurityCheck)
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool RemoveVersion(
    Item item,
    SecurityCheck securityCheck
)
Visual Basic
Public Shared Function RemoveVersion ( _
    item As Item, _
    securityCheck As SecurityCheck _
) As Boolean
Visual C++
public:
static bool RemoveVersion(
    Item^ item,
    SecurityCheck securityCheck
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item representing the version to remove.
securityCheck
Type: Sitecore.SecurityModel..::..SecurityCheck
The security check.

Return Value

true if the version was removed, otherwise false.

See Also

ItemManager Class
RemoveVersion Overload
Sitecore.Data.Managers Namespace


RemoveVersions Method

[image]

Sitecore 6.4.1 API
ItemManager..::..RemoveVersions Method
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void RemoveVersions(
    Item item,
    Language language,
    SecurityCheck securityCheck
)
Visual Basic
Public Shared Sub RemoveVersions ( _
    item As Item, _
    language As Language, _
    securityCheck As SecurityCheck _
)
Visual C++
public:
static void RemoveVersions(
    Item^ item,
    Language^ language,
    SecurityCheck securityCheck
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
language
Type: Sitecore.Globalization..::..Language
The language.
securityCheck
Type: Sitecore.SecurityModel..::..SecurityCheck
The security check.

See Also

ItemManager Class
Sitecore.Data.Managers Namespace


SaveItem Method

[image]

Sitecore 6.4.1 API
ItemManager..::..SaveItem Method
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool SaveItem(
    Item item
)
Visual Basic
Public Shared Function SaveItem ( _
    item As Item _
) As Boolean
Visual C++
public:
static bool SaveItem(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

True if the item was saved, false otherwise.

See Also

ItemManager Class
Sitecore.Data.Managers Namespace


ItemManager Properties

[image] [image]

Sitecore 6.4.1 API
ItemManager Properties
ItemManager Class See Also Send Feedback

The ItemManager type exposes the following members.

Properties

Name | Description
Provider | The provider instance handling requests to the maanager.
Providers | Gets the providers.

See Also

ItemManager Class
Sitecore.Data.Managers Namespace


Provider Property

[image]

Sitecore 6.4.1 API
ItemManager..::..Provider Property
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ItemProvider Provider { get; }
Visual Basic
Public Shared ReadOnly Property Provider As ItemProvider
    Get
Visual C++
public:
static property ItemProvider^ Provider {
    ItemProvider^ get ();
}

Field Value

The provider.

See Also

ItemManager Class
Sitecore.Data.Managers Namespace


Providers Property

[image]

Sitecore 6.4.1 API
ItemManager..::..Providers Property
ItemManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ItemProviderCollection Providers { get; }
Visual Basic
Public Shared ReadOnly Property Providers As ItemProviderCollection
    Get
Visual C++
public:
static property ItemProviderCollection^ Providers {
    ItemProviderCollection^ get ();
}

Field Value

The providers.

See Also

ItemManager Class
Sitecore.Data.Managers Namespace


ItemProvider Class

[image]

Sitecore 6.4.1 API
ItemProvider Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemProvider : ProviderBase
Visual Basic
Public Class ItemProvider _
    Inherits ProviderBase
Visual C++
public ref class ItemProvider : public ProviderBase

Inheritance Hierarchy

System..::..Object
System.Configuration.Provider..::..ProviderBase
Sitecore.Data.Managers..::..ItemProvider

See Also

ItemProvider Members
Sitecore.Data.Managers Namespace


ItemProvider Members

[image] [image]

Sitecore 6.4.1 API
ItemProvider Members
ItemProvider Class Constructors Methods Properties See Also Send Feedback

The ItemProvider type exposes the following members.

Constructors

 | Name | Description
Public method | ItemProvider | Initializes a new instance of the ItemProvider class.

Methods

 | Name | Description
Public method | AddFromTemplate | Adds a new item from a template.
Public method | AddVersion | Adds a new version to an item by copying the data from an existing version.
Protected method | ApplySecurity(Item, SecurityCheck) | Applies security to an items.
Protected method | ApplySecurity(ItemList, SecurityCheck) | Applies security to a collection of items.
Public method | BlobStreamExists | Determines whether the specified field contains a BLOB value.
Public method | CopyItem | Copies a specified item.
Public method | CreateItem | Creates an empty item.
Public method | DeleteItem | Deletes an item.
Protected method | DoCreateItem | Creates a new item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBlobStream | Gets a BLOB stream from its id.
Protected method | GetChildren(Item) | Gets the children of an item.
Public method | GetChildren(Item, SecurityCheck) | Gets the children of an item.
Public method | GetContentLanguages | Gets the content languages (ie. the languages for which the item has content).
Protected method | GetDataEngine | Gets the data engine associated with a database.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetItem(ID, Language, Version, Database) | Gets an item from a database.
Public method | GetItem(String, Language, Version, Database, SecurityCheck) | Gets an item from a database.
Public method | GetItem(ID, Language, Version, Database, SecurityCheck) | Gets an item from a database.
Protected method | GetParent(Item) | Gets the parent of an item.
Public method | GetParent(Item, SecurityCheck) | Gets the parent of an item.
Public method | GetRootItem | Gets the root item.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersions | Gets the version numbers of an item.
Public method | HasChildren(Item) | Obsolete. Determines whether the specified item has children.
Public method | HasChildren(Item, SecurityCheck) | Determines whether the specified item has children.
Public method | Initialize | Initializes the provider. (Inherited from ProviderBase.)
Protected method | InsertVirtualChildren | Inserts shadows (if any) into a native list of children.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveItem | Moves an item.
Public method | RemoveData | Removes all data in a specific language from an item.
Public method | RemoveVersion | Removes a version from an item.
Public method | RemoveVersions | Deletes all versions in the specified language.
Public method | ResolvePath | Resolves an item path to an id.
Public method | SaveItem | Saves changes to an item.
Public method | SetBlobStream | Sets the BLOB stream associated with a field.
Protected method | Sort | Sorts the specified items.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

ItemProvider Class
Sitecore.Data.Managers Namespace


ItemProvider Constructor

[image]

Sitecore 6.4.1 API
ItemProvider Constructor
ItemProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemProvider()
Visual Basic
Public Sub New
Visual C++
public:
ItemProvider()

See Also

ItemProvider Class
Sitecore.Data.Managers Namespace


ItemProvider Methods

[image] [image]

Sitecore 6.4.1 API
ItemProvider Methods
ItemProvider Class See Also Send Feedback

The ItemProvider type exposes the following members.

Methods

 | Name | Description
Public method | AddFromTemplate | Adds a new item from a template.
Public method | AddVersion | Adds a new version to an item by copying the data from an existing version.
Protected method | ApplySecurity(Item, SecurityCheck) | Applies security to an items.
Protected method | ApplySecurity(ItemList, SecurityCheck) | Applies security to a collection of items.
Public method | BlobStreamExists | Determines whether the specified field contains a BLOB value.
Public method | CopyItem | Copies a specified item.
Public method | CreateItem | Creates an empty item.
Public method | DeleteItem | Deletes an item.
Protected method | DoCreateItem | Creates a new item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBlobStream | Gets a BLOB stream from its id.
Protected method | GetChildren(Item) | Gets the children of an item.
Public method | GetChildren(Item, SecurityCheck) | Gets the children of an item.
Public method | GetContentLanguages | Gets the content languages (ie. the languages for which the item has content).
Protected method | GetDataEngine | Gets the data engine associated with a database.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetItem(ID, Language, Version, Database) | Gets an item from a database.
Public method | GetItem(String, Language, Version, Database, SecurityCheck) | Gets an item from a database.
Public method | GetItem(ID, Language, Version, Database, SecurityCheck) | Gets an item from a database.
Protected method | GetParent(Item) | Gets the parent of an item.
Public method | GetParent(Item, SecurityCheck) | Gets the parent of an item.
Public method | GetRootItem | Gets the root item.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersions | Gets the version numbers of an item.
Public method | HasChildren(Item) | Obsolete. Determines whether the specified item has children.
Public method | HasChildren(Item, SecurityCheck) | Determines whether the specified item has children.
Public method | Initialize | Initializes the provider. (Inherited from ProviderBase.)
Protected method | InsertVirtualChildren | Inserts shadows (if any) into a native list of children.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveItem | Moves an item.
Public method | RemoveData | Removes all data in a specific language from an item.
Public method | RemoveVersion | Removes a version from an item.
Public method | RemoveVersions | Deletes all versions in the specified language.
Public method | ResolvePath | Resolves an item path to an id.
Public method | SaveItem | Saves changes to an item.
Public method | SetBlobStream | Sets the BLOB stream associated with a field.
Protected method | Sort | Sorts the specified items.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemProvider Class
Sitecore.Data.Managers Namespace


AddFromTemplate Method

[image]

Sitecore 6.4.1 API
ItemProvider..::..AddFromTemplate Method
ItemProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Item AddFromTemplate(
    string itemName,
    ID templateId,
    Item destination,
    ID newId
)
Visual Basic
Public Overridable Function AddFromTemplate ( _
    itemName As String, _
    templateId As ID, _
    destination As Item, _
    newId As ID _
) As Item
Visual C++
public:
virtual Item^ AddFromTemplate(
    String^ itemName,
    ID^ templateId,
    Item^ destination,
    ID^ newId
)

Parameters

itemName
Type: System..::..String
Name of the new item.
templateId
Type: Sitecore.Data..::..ID
The template id.
destination
Type: Sitecore.Data.Items..::..Item
The destination item. This will be the parent of the new item.
newId
Type: Sitecore.Data..::..ID
The id of the new item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Managers.ItemProvider.AddFromTemplate(System.String,Sitecore.Data.ID,Sitecore.Data.Items.Item,Sitecore.Data.ID)"]

See Also

ItemProvider Class
Sitecore.Data.Managers Namespace


ApplySecurity Method

[image] [image]

Sitecore 6.4.1 API
ItemProvider..::..ApplySecurity Method
ItemProvider Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | ApplySecurity(Item, SecurityCheck) | Applies security to an items.
Protected method | ApplySecurity(ItemList, SecurityCheck) | Applies security to a collection of items.

See Also

ItemProvider Class
ItemProvider Members
Sitecore.Data.Managers Namespace


ApplySecurity Method (Item, SecurityCheck)

[image]

Sitecore 6.4.1 API
ItemProvider..::..ApplySecurity Method (Item, SecurityCheck)
ItemProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual Item ApplySecurity(
    Item item,
    SecurityCheck securityCheck
)
Visual Basic
Protected Overridable Function ApplySecurity ( _
    item As Item, _
    securityCheck As SecurityCheck _
) As Item
Visual C++
protected:
virtual Item^ ApplySecurity(
    Item^ item,
    SecurityCheck securityCheck
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
securityCheck
Type: Sitecore.SecurityModel..::..SecurityCheck
The security check to perform.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Managers.ItemProvider.ApplySecurity(Sitecore.Data.Items.Item,Sitecore.SecurityModel.SecurityCheck)"]

Remarks

If the item can not be read by the current user, null will be returned.

See Also

ItemProvider Class
ApplySecurity Overload
Sitecore.Data.Managers Namespace


ApplySecurity Method (ItemList, SecurityCheck)

[image]

Sitecore 6.4.1 API
ItemProvider..::..ApplySecurity Method (ItemList, SecurityCheck)
ItemProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual ItemList ApplySecurity(
    ItemList children,
    SecurityCheck securityCheck
)
Visual Basic
Protected Overridable Function ApplySecurity ( _
    children As ItemList, _
    securityCheck As SecurityCheck _
) As ItemList
Visual C++
protected:
virtual ItemList^ ApplySecurity(
    ItemList^ children,
    SecurityCheck securityCheck
)

Parameters

children
Type: Sitecore.Collections..::..ItemList
The items.
securityCheck
Type: Sitecore.SecurityModel..::..SecurityCheck
The security check to perform.

Return Value

A collection with the items that the current user has 'read' access to.

Remarks

All items that can not be read by the current user will be removed from the collection.

See Also

ItemProvider Class
ApplySecurity Overload
Sitecore.Data.Managers Namespace


BlobStreamExists Method

[image]

Sitecore 6.4.1 API
ItemProvider..::..BlobStreamExists Method
ItemProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool BlobStreamExists(
    Guid blobId,
    Database database
)
Visual Basic
Public Overridable Function BlobStreamExists ( _
    blobId As Guid, _
    database As Database _
) As Boolean
Visual C++
public:
virtual bool BlobStreamExists(
    Guid blobId,
    Database^ database
)

Parameters

blobId
Type: System..::..Guid
The BLOB id.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

true if the specified field contains a BLOB value; otherwise, false.

See Also

ItemProvider Class
Sitecore.Data.Managers Namespace


CopyItem Method

[image]

Sitecore 6.4.1 API
ItemProvider..::..CopyItem Method
ItemProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Item CopyItem(
    Item source,
    Item destination,
    bool deep,
    string copyName,
    ID copyId
)
Visual Basic
Public Overridable Function CopyItem ( _
    source As Item, _
    destination As Item, _
    deep As Boolean, _
    copyName As String, _
    copyId As ID _
) As Item
Visual C++
public:
virtual Item^ CopyItem(
    Item^ source,
    Item^ destination,
    bool deep,
    String^ copyName,
    ID^ copyId
)

Parameters

source
Type: Sitecore.Data.Items..::..Item
The item to copy.
destination
Type: Sitecore.Data.Items..::..Item
The destination.
deep
Type: System..::..Boolean
If set to true, child items will be copied recursively.
copyName
Type: System..::..String
Name of the copied item.
copyId
Type: Sitecore.Data..::..ID
Id of the copied item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Managers.ItemProvider.CopyItem(Sitecore.Data.Items.Item,Sitecore.Data.Items.Item,System.Boolean,System.String,Sitecore.Data.ID)"]

See Also

ItemProvider Class
Sitecore.Data.Managers Namespace


CreateItem Method

[image]

Sitecore 6.4.1 API
ItemProvider..::..CreateItem Method
ItemProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Item CreateItem(
    string itemName,
    Item destination,
    ID templateId,
    ID newId,
    SecurityCheck securityCheck
)
Visual Basic
Public Overridable Function CreateItem ( _
    itemName As String, _
    destination As Item, _
    templateId As ID, _
    newId As ID, _
    securityCheck As SecurityCheck _
) As Item
Visual C++
public:
virtual Item^ CreateItem(
    String^ itemName,
    Item^ destination,
    ID^ templateId,
    ID^ newId,
    SecurityCheck securityCheck
)

Parameters

itemName
Type: System..::..String
Name of the item.
destination
Type: Sitecore.Data.Items..::..Item
The destination.
templateId
Type: Sitecore.Data..::..ID
The template ID.
newId
Type: Sitecore.Data..::..ID
The item id.
securityCheck
Type: Sitecore.SecurityModel..::..SecurityCheck
The security check.

Return Value

The created item. If the item was created, but could not be read, null is returned.

See Also

ItemProvider Class
Sitecore.Data.Managers Namespace


DoCreateItem Method

[image]

Sitecore 6.4.1 API
ItemProvider..::..DoCreateItem Method
ItemProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void DoCreateItem(
    string itemName,
    Item destination,
    ID templateId,
    ID newId
)
Visual Basic
Protected Overridable Sub DoCreateItem ( _
    itemName As String, _
    destination As Item, _
    templateId As ID, _
    newId As ID _
)
Visual C++
protected:
virtual void DoCreateItem(
    String^ itemName,
    Item^ destination,
    ID^ templateId,
    ID^ newId
)

Parameters

itemName
Type: System..::..String
Name of the item.
destination
Type: Sitecore.Data.Items..::..Item
The destination.
templateId
Type: Sitecore.Data..::..ID
The template id.
newId
Type: Sitecore.Data..::..ID
The new id.

See Also

ItemProvider Class
Sitecore.Data.Managers Namespace


GetBlobStream Method

[image]

Sitecore 6.4.1 API
ItemProvider..::..GetBlobStream Method
ItemProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Stream GetBlobStream(
    Guid blobId,
    Database database
)
Visual Basic
Public Overridable Function GetBlobStream ( _
    blobId As Guid, _
    database As Database _
) As Stream
Visual C++
public:
virtual Stream^ GetBlobStream(
    Guid blobId,
    Database^ database
)

Parameters

blobId
Type: System..::..Guid
The BLOB id.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

The stream.

See Also

ItemProvider Class
Sitecore.Data.Managers Namespace


GetChildren Method

[image] [image]

Sitecore 6.4.1 API
ItemProvider..::..GetChildren Method
ItemProvider Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetChildren(Item) | Gets the children of an item.
Public method | GetChildren(Item, SecurityCheck) | Gets the children of an item.

See Also

ItemProvider Class
ItemProvider Members
Sitecore.Data.Managers Namespace


GetChildren Method (Item, SecurityCheck)

[image]

Sitecore 6.4.1 API
ItemProvider..::..GetChildren Method (Item, SecurityCheck)
ItemProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ChildList GetChildren(
    Item item,
    SecurityCheck securityCheck
)
Visual Basic
Public Overridable Function GetChildren ( _
    item As Item, _
    securityCheck As SecurityCheck _
) As ChildList
Visual C++
public:
virtual ChildList^ GetChildren(
    Item^ item,
    SecurityCheck securityCheck
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The parent item.
securityCheck
Type: Sitecore.SecurityModel..::..SecurityCheck
The security check.

Return Value

The child items.

See Also

ItemProvider Class
GetChildren Overload
Sitecore.Data.Managers Namespace


GetContentLanguages Method

[image]

Sitecore 6.4.1 API
ItemProvider..::..GetContentLanguages Method
ItemProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual LanguageCollection GetContentLanguages(
    Item item
)
Visual Basic
Public Overridable Function GetContentLanguages ( _
    item As Item _
) As LanguageCollection
Visual C++
public:
virtual LanguageCollection^ GetContentLanguages(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Managers.ItemProvider.GetContentLanguages(Sitecore.Data.Items.Item)"]

See Also

ItemProvider Class
Sitecore.Data.Managers Namespace


GetDataEngine Method

[image]

Sitecore 6.4.1 API
ItemProvider..::..GetDataEngine Method
ItemProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual DataEngine GetDataEngine(
    Database database
)
Visual Basic
Protected Overridable Function GetDataEngine ( _
    database As Database _
) As DataEngine
Visual C++
protected:
virtual DataEngine^ GetDataEngine(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Managers.ItemProvider.GetDataEngine(Sitecore.Data.Database)"]

See Also

ItemProvider Class
Sitecore.Data.Managers Namespace


GetItem Method

[image] [image]

Sitecore 6.4.1 API
ItemProvider..::..GetItem Method
ItemProvider Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetItem(ID, Language, Version, Database) | Gets an item from a database.
Public method | GetItem(String, Language, Version, Database, SecurityCheck) | Gets an item from a database.
Public method | GetItem(ID, Language, Version, Database, SecurityCheck) | Gets an item from a database.

See Also

ItemProvider Class
ItemProvider Members
Sitecore.Data.Managers Namespace


GetItem Method (ID, Language, Version, Database)

[image]

Sitecore 6.4.1 API
ItemProvider..::..GetItem Method (ID, Language, Version, Database)
ItemProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual Item GetItem(
    ID itemId,
    Language language,
    Version version,
    Database database
)
Visual Basic
Protected Overridable Function GetItem ( _
    itemId As ID, _
    language As Language, _
    version As Version, _
    database As Database _
) As Item
Visual C++
protected:
virtual Item^ GetItem(
    ID^ itemId,
    Language^ language,
    Version^ version,
    Database^ database
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
language
Type: Sitecore.Globalization..::..Language
The language of the item to get.
version
Type: Sitecore.Data..::..Version
The version of the item to get.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

The item. If no item is found, null is returned.

See Also

ItemProvider Class
GetItem Overload
Sitecore.Data.Managers Namespace


GetItem Method (String, Language, Version, Database, SecurityCheck)

[image]

Sitecore 6.4.1 API
ItemProvider..::..GetItem Method (String, Language, Version, Database, SecurityCheck)
ItemProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Item GetItem(
    string itemPath,
    Language language,
    Version version,
    Database database,
    SecurityCheck securityCheck
)
Visual Basic
Public Overridable Function GetItem ( _
    itemPath As String, _
    language As Language, _
    version As Version, _
    database As Database, _
    securityCheck As SecurityCheck _
) As Item
Visual C++
public:
virtual Item^ GetItem(
    String^ itemPath,
    Language^ language,
    Version^ version,
    Database^ database,
    SecurityCheck securityCheck
)

Parameters

itemPath
Type: System..::..String
The item path.
language
Type: Sitecore.Globalization..::..Language
The language of the item to get.
version
Type: Sitecore.Data..::..Version
The version of the item to get.
database
Type: Sitecore.Data..::..Database
The database.
securityCheck
Type: Sitecore.SecurityModel..::..SecurityCheck
The security check.

Return Value

The item. If no item is found, null is returned.

See Also

ItemProvider Class
GetItem Overload
Sitecore.Data.Managers Namespace


GetItem Method (ID, Language, Version, Database, SecurityCheck)

[image]

Sitecore 6.4.1 API
ItemProvider..::..GetItem Method (ID, Language, Version, Database, SecurityCheck)
ItemProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Item GetItem(
    ID itemId,
    Language language,
    Version version,
    Database database,
    SecurityCheck securityCheck
)
Visual Basic
Public Overridable Function GetItem ( _
    itemId As ID, _
    language As Language, _
    version As Version, _
    database As Database, _
    securityCheck As SecurityCheck _
) As Item
Visual C++
public:
virtual Item^ GetItem(
    ID^ itemId,
    Language^ language,
    Version^ version,
    Database^ database,
    SecurityCheck securityCheck
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
language
Type: Sitecore.Globalization..::..Language
The language of the item to get.
version
Type: Sitecore.Data..::..Version
The version of the item to get.
database
Type: Sitecore.Data..::..Database
The database.
securityCheck
Type: Sitecore.SecurityModel..::..SecurityCheck
The security check.

Return Value

The item. If no item is found, null is returned.

See Also

ItemProvider Class
GetItem Overload
Sitecore.Data.Managers Namespace


GetParent Method

[image] [image]

Sitecore 6.4.1 API
ItemProvider..::..GetParent Method
ItemProvider Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetParent(Item) | Gets the parent of an item.
Public method | GetParent(Item, SecurityCheck) | Gets the parent of an item.

See Also

ItemProvider Class
ItemProvider Members
Sitecore.Data.Managers Namespace


GetParent Method (Item, SecurityCheck)

[image]

Sitecore 6.4.1 API
ItemProvider..::..GetParent Method (Item, SecurityCheck)
ItemProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Item GetParent(
    Item item,
    SecurityCheck securityCheck
)
Visual Basic
Public Overridable Function GetParent ( _
    item As Item, _
    securityCheck As SecurityCheck _
) As Item
Visual C++
public:
virtual Item^ GetParent(
    Item^ item,
    SecurityCheck securityCheck
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
securityCheck
Type: Sitecore.SecurityModel..::..SecurityCheck
The security check.

Return Value

The parent item.

See Also

ItemProvider Class
GetParent Overload
Sitecore.Data.Managers Namespace


GetRootItem Method

[image]

Sitecore 6.4.1 API
ItemProvider..::..GetRootItem Method
ItemProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Item GetRootItem(
    Language language,
    Version version,
    Database database,
    SecurityCheck securityCheck
)
Visual Basic
Public Overridable Function GetRootItem ( _
    language As Language, _
    version As Version, _
    database As Database, _
    securityCheck As SecurityCheck _
) As Item
Visual C++
public:
virtual Item^ GetRootItem(
    Language^ language,
    Version^ version,
    Database^ database,
    SecurityCheck securityCheck
)

Parameters

language
Type: Sitecore.Globalization..::..Language
The language to return.
version
Type: Sitecore.Data..::..Version
The version to return.
database
Type: Sitecore.Data..::..Database
The database.
securityCheck
Type: Sitecore.SecurityModel..::..SecurityCheck
The security check.

Return Value

The root item. If no item is found, null is returned.

See Also

ItemProvider Class
Sitecore.Data.Managers Namespace


GetVersions Method

[image]

Sitecore 6.4.1 API
ItemProvider..::..GetVersions Method
ItemProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual VersionCollection GetVersions(
    Item item,
    Language language
)
Visual Basic
Public Overridable Function GetVersions ( _
    item As Item, _
    language As Language _
) As VersionCollection
Visual C++
public:
virtual VersionCollection^ GetVersions(
    Item^ item,
    Language^ language
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
language
Type: Sitecore.Globalization..::..Language
The language.

Return Value

The list of versions.

See Also

ItemProvider Class
Sitecore.Data.Managers Namespace


HasChildren Method

[image] [image]

Sitecore 6.4.1 API
ItemProvider..::..HasChildren Method
ItemProvider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HasChildren(Item) | Obsolete. Determines whether the specified item has children.
Public method | HasChildren(Item, SecurityCheck) | Determines whether the specified item has children.

See Also

ItemProvider Class
ItemProvider Members
Sitecore.Data.Managers Namespace


HasChildren Method (Item)

[image]

Sitecore 6.4.1 API
ItemProvider..::..HasChildren Method (Item)
ItemProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use HasChildren(Item, SecurityCheck) instead.")]
public virtual bool HasChildren(
    Item item
)
Visual Basic
<ObsoleteAttribute("Deprecated - Use HasChildren(Item, SecurityCheck) instead.")> _
Public Overridable Function HasChildren ( _
    item As Item _
) As Boolean
Visual C++
[ObsoleteAttribute(L"Deprecated - Use HasChildren(Item, SecurityCheck) instead.")]
public:
virtual bool HasChildren(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

true if the specified item has children; otherwise, false.

See Also

ItemProvider Class
HasChildren Overload
Sitecore.Data.Managers Namespace


HasChildren Method (Item, SecurityCheck)

[image]

Sitecore 6.4.1 API
ItemProvider..::..HasChildren Method (Item, SecurityCheck)
ItemProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool HasChildren(
    Item item,
    SecurityCheck securityCheck
)
Visual Basic
Public Overridable Function HasChildren ( _
    item As Item, _
    securityCheck As SecurityCheck _
) As Boolean
Visual C++
public:
virtual bool HasChildren(
    Item^ item,
    SecurityCheck securityCheck
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
securityCheck
Type: Sitecore.SecurityModel..::..SecurityCheck
The security check.

Return Value

true if the specified item has children; otherwise, false.

See Also

ItemProvider Class
HasChildren Overload
Sitecore.Data.Managers Namespace


InsertVirtualChildren Method

[image]

Sitecore 6.4.1 API
ItemProvider..::..InsertVirtualChildren Method
ItemProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void InsertVirtualChildren(
    ItemList children,
    Item parent
)
Visual Basic
Protected Overridable Sub InsertVirtualChildren ( _
    children As ItemList, _
    parent As Item _
)
Visual C++
protected:
virtual void InsertVirtualChildren(
    ItemList^ children,
    Item^ parent
)

Parameters

children
Type: Sitecore.Collections..::..ItemList
The children.
parent
Type: Sitecore.Data.Items..::..Item
The parent of the children.

See Also

ItemProvider Class
Sitecore.Data.Managers Namespace


MoveItem Method

[image]

Sitecore 6.4.1 API
ItemProvider..::..MoveItem Method
ItemProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool MoveItem(
    Item item,
    Item destination,
    SecurityCheck securityCheck
)
Visual Basic
Public Overridable Function MoveItem ( _
    item As Item, _
    destination As Item, _
    securityCheck As SecurityCheck _
) As Boolean
Visual C++
public:
virtual bool MoveItem(
    Item^ item,
    Item^ destination,
    SecurityCheck securityCheck
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item to move.
destination
Type: Sitecore.Data.Items..::..Item
The destination. This will become the new parent of item.
securityCheck
Type: Sitecore.SecurityModel..::..SecurityCheck
The security check.

Return Value

true if the item was moved; false otherwise.

See Also

ItemProvider Class
Sitecore.Data.Managers Namespace


RemoveVersion Method

[image]

Sitecore 6.4.1 API
ItemProvider..::..RemoveVersion Method
ItemProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool RemoveVersion(
    Item item,
    SecurityCheck securityCheck
)
Visual Basic
Public Overridable Function RemoveVersion ( _
    item As Item, _
    securityCheck As SecurityCheck _
) As Boolean
Visual C++
public:
virtual bool RemoveVersion(
    Item^ item,
    SecurityCheck securityCheck
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item representing the version to remove.
securityCheck
Type: Sitecore.SecurityModel..::..SecurityCheck
The security check.

Return Value

true if the version was removed, otherwise false.

See Also

ItemProvider Class
Sitecore.Data.Managers Namespace


RemoveVersions Method

[image]

Sitecore 6.4.1 API
ItemProvider..::..RemoveVersions Method
ItemProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void RemoveVersions(
    Item item,
    Language language,
    SecurityCheck securityCheck
)
Visual Basic
Public Overridable Sub RemoveVersions ( _
    item As Item, _
    language As Language, _
    securityCheck As SecurityCheck _
)
Visual C++
public:
virtual void RemoveVersions(
    Item^ item,
    Language^ language,
    SecurityCheck securityCheck
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
language
Type: Sitecore.Globalization..::..Language
The language.
securityCheck
Type: Sitecore.SecurityModel..::..SecurityCheck
The security check.

See Also

ItemProvider Class
Sitecore.Data.Managers Namespace


ResolvePath Method

[image]

Sitecore 6.4.1 API
ItemProvider..::..ResolvePath Method
ItemProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ID ResolvePath(
    string itemPath,
    Database database
)
Visual Basic
Public Overridable Function ResolvePath ( _
    itemPath As String, _
    database As Database _
) As ID
Visual C++
public:
virtual ID^ ResolvePath(
    String^ itemPath,
    Database^ database
)

Parameters

itemPath
Type: System..::..String
The item path.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

The id of the item with the path specified by itemPath.

See Also

ItemProvider Class
Sitecore.Data.Managers Namespace


SaveItem Method

[image]

Sitecore 6.4.1 API
ItemProvider..::..SaveItem Method
ItemProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool SaveItem(
    Item item
)
Visual Basic
Public Overridable Function SaveItem ( _
    item As Item _
) As Boolean
Visual C++
public:
virtual bool SaveItem(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

True if the item was saved, false otherwise.

See Also

ItemProvider Class
Sitecore.Data.Managers Namespace


SetBlobStream Method

[image]

Sitecore 6.4.1 API
ItemProvider..::..SetBlobStream Method
ItemProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool SetBlobStream(
    Stream stream,
    Guid blobId,
    Database database
)
Visual Basic
Public Overridable Function SetBlobStream ( _
    stream As Stream, _
    blobId As Guid, _
    database As Database _
) As Boolean
Visual C++
public:
virtual bool SetBlobStream(
    Stream^ stream,
    Guid blobId,
    Database^ database
)

Parameters

stream
Type: System.IO..::..Stream
The stream.
blobId
Type: System..::..Guid
The BLOB id.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

The guid identifying the new blob.

See Also

ItemProvider Class
Sitecore.Data.Managers Namespace


Sort Method

[image]

Sitecore 6.4.1 API
ItemProvider..::..Sort Method
ItemProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void Sort(
    ItemList items,
    Item owner
)
Visual Basic
Protected Overridable Sub Sort ( _
    items As ItemList, _
    owner As Item _
)
Visual C++
protected:
virtual void Sort(
    ItemList^ items,
    Item^ owner
)

Parameters

items
Type: Sitecore.Collections..::..ItemList
The items.
owner
Type: Sitecore.Data.Items..::..Item
The owner.

See Also

ItemProvider Class
Sitecore.Data.Managers Namespace


ItemProvider Properties

[image] [image]

Sitecore 6.4.1 API
ItemProvider Properties
ItemProvider Class See Also Send Feedback

The ItemProvider type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

ItemProvider Class
Sitecore.Data.Managers Namespace


ItemProviderCollection Class

[image]

Sitecore 6.4.1 API
ItemProviderCollection Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemProviderCollection : ProviderCollection
Visual Basic
Public Class ItemProviderCollection _
    Inherits ProviderCollection
Visual C++
public ref class ItemProviderCollection : public ProviderCollection

Inheritance Hierarchy

System..::..Object
System.Configuration.Provider..::..ProviderCollection
Sitecore.Data.Managers..::..ItemProviderCollection

See Also

ItemProviderCollection Members
Sitecore.Data.Managers Namespace


ItemProviderCollection Members

[image] [image]

Sitecore 6.4.1 API
ItemProviderCollection Members
ItemProviderCollection Class Constructors Methods Properties See Also Send Feedback

The ItemProviderCollection type exposes the following members.

Constructors

 | Name | Description
Public method | ItemProviderCollection | Initializes a new instance of the ItemProviderCollection class

Methods

 | Name | Description
Public method | Add | Adds a provider to the collection. (Inherited from ProviderCollection.)
Public method | Clear | Removes all items from the collection. (Inherited from ProviderCollection.)
Public method | CopyTo | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a provider from the collection. (Inherited from ProviderCollection.)
Public method | SetReadOnly | Sets the collection to be read-only. (Inherited from ProviderCollection.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
Public property | Item | Gets the ItemProvider with the specified name.
Public property | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)

See Also

ItemProviderCollection Class
Sitecore.Data.Managers Namespace


ItemProviderCollection Constructor

[image]

Sitecore 6.4.1 API
ItemProviderCollection Constructor
ItemProviderCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemProviderCollection()
Visual Basic
Public Sub New
Visual C++
public:
ItemProviderCollection()

See Also

ItemProviderCollection Class
Sitecore.Data.Managers Namespace


ItemProviderCollection Methods

[image] [image]

Sitecore 6.4.1 API
ItemProviderCollection Methods
ItemProviderCollection Class See Also Send Feedback

The ItemProviderCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds a provider to the collection. (Inherited from ProviderCollection.)
Public method | Clear | Removes all items from the collection. (Inherited from ProviderCollection.)
Public method | CopyTo | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a provider from the collection. (Inherited from ProviderCollection.)
Public method | SetReadOnly | Sets the collection to be read-only. (Inherited from ProviderCollection.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemProviderCollection Class
Sitecore.Data.Managers Namespace


ItemProviderCollection Properties

[image] [image]

Sitecore 6.4.1 API
ItemProviderCollection Properties
ItemProviderCollection Class See Also Send Feedback

The ItemProviderCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
Public property | Item | Gets the ItemProvider with the specified name.
Public property | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)

See Also

ItemProviderCollection Class
Sitecore.Data.Managers Namespace


Item Property

[image]

Sitecore 6.4.1 API
ItemProviderCollection..::..Item Property
ItemProviderCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemProvider this[
    string name
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    name As String _
) As ItemProvider
    Get
Visual C++
public:
property ItemProvider^ default[String^ name] {
    ItemProvider^ get (String^ name);
}

Parameters

name
Type: System..::..String

Field Value

See Also

ItemProviderCollection Class
Sitecore.Data.Managers Namespace


LanguageManager Class

[image]

Sitecore 6.4.1 API
LanguageManager Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public sealed class LanguageManager
Visual Basic
Public NotInheritable Class LanguageManager
Visual C++
public ref class LanguageManager sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Managers..::..LanguageManager

See Also

LanguageManager Members
Sitecore.Data.Managers Namespace


LanguageManager Members

[image] [image]

Sitecore 6.4.1 API
LanguageManager Members
LanguageManager Class Constructors Methods Properties See Also Send Feedback

The LanguageManager type exposes the following members.

Constructors

 | Name | Description
Public method | LanguageManager | Initializes a new instance of the LanguageManager class

Methods

 | Name | Description
 | AddLanguage | Obsolete. Adds a Language to a specific database.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLanguage(String) | Gets a language by name.
 | GetLanguage(String, Database) | Gets a language (only if it is defined in the specified database).
 | GetLanguageItemId | Gets the id of the item representing the language in a specific database.
 | GetLanguages | Gets all the languages defined in a specific database.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize | Initialize type.
 | IsLanguageNameDefined | Determines if the language name is defined in the specified database.
 | IsValidLanguageName | Determines whether the specified name is a valid language name.
 | LanguageRegistered(String) | Gets a value indicating if a specific language is registered with the ASP.NET globalization engine.
 | LanguageRegistered(String, Database) | Gets a value indicating if a specific language is registered in a specific database.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RegisterLanguage | Registers a specific language in the ASP.NET globalization engine.
 | RemoveLanguageData | Removes all data using a specific language from the database.
 | RenameLanguageData | Rename all data language bindings for a specific language.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DefaultLanguage | Gets the default language.
Provider | Gets the current provider.

See Also

LanguageManager Class
Sitecore.Data.Managers Namespace


LanguageManager Constructor

[image]

Sitecore 6.4.1 API
LanguageManager Constructor
LanguageManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LanguageManager()
Visual Basic
Public Sub New
Visual C++
public:
LanguageManager()

See Also

LanguageManager Class
Sitecore.Data.Managers Namespace


LanguageManager Methods

[image] [image]

Sitecore 6.4.1 API
LanguageManager Methods
LanguageManager Class See Also Send Feedback

The LanguageManager type exposes the following members.

Methods

 | Name | Description
 | AddLanguage | Obsolete. Adds a Language to a specific database.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLanguage(String) | Gets a language by name.
 | GetLanguage(String, Database) | Gets a language (only if it is defined in the specified database).
 | GetLanguageItemId | Gets the id of the item representing the language in a specific database.
 | GetLanguages | Gets all the languages defined in a specific database.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize | Initialize type.
 | IsLanguageNameDefined | Determines if the language name is defined in the specified database.
 | IsValidLanguageName | Determines whether the specified name is a valid language name.
 | LanguageRegistered(String) | Gets a value indicating if a specific language is registered with the ASP.NET globalization engine.
 | LanguageRegistered(String, Database) | Gets a value indicating if a specific language is registered in a specific database.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RegisterLanguage | Registers a specific language in the ASP.NET globalization engine.
 | RemoveLanguageData | Removes all data using a specific language from the database.
 | RenameLanguageData | Rename all data language bindings for a specific language.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LanguageManager Class
Sitecore.Data.Managers Namespace


AddLanguage Method

[image]

Sitecore 6.4.1 API
LanguageManager..::..AddLanguage Method
LanguageManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public static void AddLanguage(
    Language language,
    Database database
)
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Shared Sub AddLanguage ( _
    language As Language, _
    database As Database _
)
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public:
static void AddLanguage(
    Language^ language,
    Database^ database
)

Parameters

language
Type: Sitecore.Globalization..::..Language
The language.
database
Type: Sitecore.Data..::..Database
The database.

Remarks

If the language already exists in the target database, no action will be taken.

See Also

LanguageManager Class
Sitecore.Data.Managers Namespace


GetLanguage Method

[image] [image]

Sitecore 6.4.1 API
LanguageManager..::..GetLanguage Method
LanguageManager Class See Also Send Feedback

Overload List

Name | Description
GetLanguage(String) | Gets a language by name.
GetLanguage(String, Database) | Gets a language (only if it is defined in the specified database).

See Also

LanguageManager Class
LanguageManager Members
Sitecore.Data.Managers Namespace


GetLanguage Method (String)

[image]

Sitecore 6.4.1 API
LanguageManager..::..GetLanguage Method (String)
LanguageManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Language GetLanguage(
    string name
)
Visual Basic
Public Shared Function GetLanguage ( _
    name As String _
) As Language
Visual C++
public:
static Language^ GetLanguage(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

Return Value

The language.

See Also

LanguageManager Class
GetLanguage Overload
Sitecore.Data.Managers Namespace


GetLanguage Method (String, Database)

[image]

Sitecore 6.4.1 API
LanguageManager..::..GetLanguage Method (String, Database)
LanguageManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Language GetLanguage(
    string name,
    Database database
)
Visual Basic
Public Shared Function GetLanguage ( _
    name As String, _
    database As Database _
) As Language
Visual C++
public:
static Language^ GetLanguage(
    String^ name,
    Database^ database
)

Parameters

name
Type: System..::..String
The name.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Managers.LanguageManager.GetLanguage(System.String,Sitecore.Data.Database)"]

See Also

LanguageManager Class
GetLanguage Overload
Sitecore.Data.Managers Namespace


GetLanguageItemId Method

[image]

Sitecore 6.4.1 API
LanguageManager..::..GetLanguageItemId Method
LanguageManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID GetLanguageItemId(
    Language language,
    Database database
)
Visual Basic
Public Shared Function GetLanguageItemId ( _
    language As Language, _
    database As Database _
) As ID
Visual C++
public:
static ID^ GetLanguageItemId(
    Language^ language,
    Database^ database
)

Parameters

language
Type: Sitecore.Globalization..::..Language
The language.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

The language item id.

See Also

LanguageManager Class
Sitecore.Data.Managers Namespace


GetLanguages Method

[image]

Sitecore 6.4.1 API
LanguageManager..::..GetLanguages Method
LanguageManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static LanguageCollection GetLanguages(
    Database database
)
Visual Basic
Public Shared Function GetLanguages ( _
    database As Database _
) As LanguageCollection
Visual C++
public:
static LanguageCollection^ GetLanguages(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

Return Value

The languages.

See Also

LanguageManager Class
Sitecore.Data.Managers Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
LanguageManager..::..Initialize Method
LanguageManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Initialize()
Visual Basic
Public Shared Sub Initialize
Visual C++
public:
static void Initialize()

See Also

LanguageManager Class
Sitecore.Data.Managers Namespace


IsValidLanguageName Method

[image]

Sitecore 6.4.1 API
LanguageManager..::..IsValidLanguageName Method
LanguageManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsValidLanguageName(
    string name
)
Visual Basic
Public Shared Function IsValidLanguageName ( _
    name As String _
) As Boolean
Visual C++
public:
static bool IsValidLanguageName(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

Return Value

true if the specified name is a valid language name; otherwise, false.

See Also

LanguageManager Class
Sitecore.Data.Managers Namespace


LanguageRegistered Method

[image] [image]

Sitecore 6.4.1 API
LanguageManager..::..LanguageRegistered Method
LanguageManager Class See Also Send Feedback

Overload List

Name | Description
LanguageRegistered(String) | Gets a value indicating if a specific language is registered with the ASP.NET globalization engine.
LanguageRegistered(String, Database) | Gets a value indicating if a specific language is registered in a specific database.

See Also

LanguageManager Class
LanguageManager Members
Sitecore.Data.Managers Namespace


LanguageRegistered Method (String)

[image]

Sitecore 6.4.1 API
LanguageManager..::..LanguageRegistered Method (String)
LanguageManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool LanguageRegistered(
    string name
)
Visual Basic
Public Shared Function LanguageRegistered ( _
    name As String _
) As Boolean
Visual C++
public:
static bool LanguageRegistered(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Managers.LanguageManager.LanguageRegistered(System.String)"]

See Also

LanguageManager Class
LanguageRegistered Overload
Sitecore.Data.Managers Namespace


LanguageRegistered Method (String, Database)

[image]

Sitecore 6.4.1 API
LanguageManager..::..LanguageRegistered Method (String, Database)
LanguageManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool LanguageRegistered(
    string name,
    Database database
)
Visual Basic
Public Shared Function LanguageRegistered ( _
    name As String, _
    database As Database _
) As Boolean
Visual C++
public:
static bool LanguageRegistered(
    String^ name,
    Database^ database
)

Parameters

name
Type: System..::..String
The name.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Managers.LanguageManager.LanguageRegistered(System.String,Sitecore.Data.Database)"]

See Also

LanguageManager Class
LanguageRegistered Overload
Sitecore.Data.Managers Namespace


RegisterLanguage Method

[image]

Sitecore 6.4.1 API
LanguageManager..::..RegisterLanguage Method
LanguageManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool RegisterLanguage(
    string name
)
Visual Basic
Public Shared Function RegisterLanguage ( _
    name As String _
) As Boolean
Visual C++
public:
static bool RegisterLanguage(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Managers.LanguageManager.RegisterLanguage(System.String)"]

See Also

LanguageManager Class
Sitecore.Data.Managers Namespace


RemoveLanguageData Method

[image]

Sitecore 6.4.1 API
LanguageManager..::..RemoveLanguageData Method
LanguageManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void RemoveLanguageData(
    Language language,
    Database database
)
Visual Basic
Public Shared Sub RemoveLanguageData ( _
    language As Language, _
    database As Database _
)
Visual C++
public:
static void RemoveLanguageData(
    Language^ language,
    Database^ database
)

Parameters

language
Type: Sitecore.Globalization..::..Language
The language.
database
Type: Sitecore.Data..::..Database
The database.

Remarks

If the language does not exist in the target database, no action will be taken.

See Also

LanguageManager Class
Sitecore.Data.Managers Namespace


RenameLanguageData Method

[image]

Sitecore 6.4.1 API
LanguageManager..::..RenameLanguageData Method
LanguageManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void RenameLanguageData(
    string fromLanguage,
    string toLanguage,
    Database database
)
Visual Basic
Public Shared Sub RenameLanguageData ( _
    fromLanguage As String, _
    toLanguage As String, _
    database As Database _
)
Visual C++
public:
static void RenameLanguageData(
    String^ fromLanguage,
    String^ toLanguage,
    Database^ database
)

Parameters

fromLanguage
Type: System..::..String
Rename from this language name.
toLanguage
Type: System..::..String
Rename to this language name.
database
Type: Sitecore.Data..::..Database
The database.

See Also

LanguageManager Class
Sitecore.Data.Managers Namespace


LanguageManager Properties

[image] [image]

Sitecore 6.4.1 API
LanguageManager Properties
LanguageManager Class See Also Send Feedback

The LanguageManager type exposes the following members.

Properties

Name | Description
DefaultLanguage | Gets the default language.
Provider | Gets the current provider.

See Also

LanguageManager Class
Sitecore.Data.Managers Namespace


DefaultLanguage Property

[image]

Sitecore 6.4.1 API
LanguageManager..::..DefaultLanguage Property
LanguageManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Language DefaultLanguage { get; }
Visual Basic
Public Shared ReadOnly Property DefaultLanguage As Language
    Get
Visual C++
public:
static property Language^ DefaultLanguage {
    Language^ get ();
}

Field Value

The default language.

See Also

LanguageManager Class
Sitecore.Data.Managers Namespace


Provider Property

[image]

Sitecore 6.4.1 API
LanguageManager..::..Provider Property
LanguageManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static LanguageProvider Provider { get; }
Visual Basic
Public Shared ReadOnly Property Provider As LanguageProvider
    Get
Visual C++
public:
static property LanguageProvider^ Provider {
    LanguageProvider^ get ();
}

Field Value

The provider.

See Also

LanguageManager Class
Sitecore.Data.Managers Namespace


LanguageProvider Class

[image]

Sitecore 6.4.1 API
LanguageProvider Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class LanguageProvider
Visual Basic
Public Class LanguageProvider
Visual C++
public ref class LanguageProvider

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Managers..::..LanguageProvider

See Also

LanguageProvider Members
Sitecore.Data.Managers Namespace


LanguageProvider Members

[image] [image]

Sitecore 6.4.1 API
LanguageProvider Members
LanguageProvider Class Constructors Methods See Also Send Feedback

The LanguageProvider type exposes the following members.

Constructors

 | Name | Description
Public method | LanguageProvider | Constructs an instance of LanguageProvider

Methods

 | Name | Description
Public method | AddLanguage | Obsolete. Adds a Language to a specific database.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLanguage(String) | Gets a language by name.
Public method | GetLanguage(String, Database) | Gets a language (only if it is defined in the specified database).
Public method | GetLanguageItemId | Gets the id of the item representing the language in a specific database.
Public method | GetLanguages | Gets all the languages defined in a specific database.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InvalidateCaches | Invalidates the caches for a specific database.
Public method | IsLanguageNameDefined | Determines if the language name is defined in the specified database.
Public method | IsValidLanguageName | Determines whether the specified name is a valid language name.
Public method | LanguageRegistered(String) | Gets a value indicating if a specific language is registered with the ASP.NET globalization engine.
Public method | LanguageRegistered(String, Database) | Gets a value indicating if a specific language is registered in a specific database.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RegisterLanguage | Registers a specific language in the ASP.NET globalization engine.
Public method | RemoveLanguageData | Removes all data using a specific language from the database.
Public method | RenameLanguageData | Rename all data language bindings for a specific language.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LanguageProvider Class
Sitecore.Data.Managers Namespace


LanguageProvider Constructor

[image]

Sitecore 6.4.1 API
LanguageProvider Constructor
LanguageProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LanguageProvider()
Visual Basic
Public Sub New
Visual C++
public:
LanguageProvider()

See Also

LanguageProvider Class
Sitecore.Data.Managers Namespace


LanguageProvider Methods

[image] [image]

Sitecore 6.4.1 API
LanguageProvider Methods
LanguageProvider Class See Also Send Feedback

The LanguageProvider type exposes the following members.

Methods

 | Name | Description
Public method | AddLanguage | Obsolete. Adds a Language to a specific database.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLanguage(String) | Gets a language by name.
Public method | GetLanguage(String, Database) | Gets a language (only if it is defined in the specified database).
Public method | GetLanguageItemId | Gets the id of the item representing the language in a specific database.
Public method | GetLanguages | Gets all the languages defined in a specific database.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InvalidateCaches | Invalidates the caches for a specific database.
Public method | IsLanguageNameDefined | Determines if the language name is defined in the specified database.
Public method | IsValidLanguageName | Determines whether the specified name is a valid language name.
Public method | LanguageRegistered(String) | Gets a value indicating if a specific language is registered with the ASP.NET globalization engine.
Public method | LanguageRegistered(String, Database) | Gets a value indicating if a specific language is registered in a specific database.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RegisterLanguage | Registers a specific language in the ASP.NET globalization engine.
Public method | RemoveLanguageData | Removes all data using a specific language from the database.
Public method | RenameLanguageData | Rename all data language bindings for a specific language.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LanguageProvider Class
Sitecore.Data.Managers Namespace


AddLanguage Method

[image]

Sitecore 6.4.1 API
LanguageProvider..::..AddLanguage Method
LanguageProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public virtual void AddLanguage(
    Language language,
    Database database
)
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Overridable Sub AddLanguage ( _
    language As Language, _
    database As Database _
)
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public:
virtual void AddLanguage(
    Language^ language,
    Database^ database
)

Parameters

language
Type: Sitecore.Globalization..::..Language
The language.
database
Type: Sitecore.Data..::..Database
The database.

Remarks

If the language already exists in the target database, no action will be taken.

See Also

LanguageProvider Class
Sitecore.Data.Managers Namespace


GetLanguage Method

[image] [image]

Sitecore 6.4.1 API
LanguageProvider..::..GetLanguage Method
LanguageProvider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetLanguage(String) | Gets a language by name.
Public method | GetLanguage(String, Database) | Gets a language (only if it is defined in the specified database).

See Also

LanguageProvider Class
LanguageProvider Members
Sitecore.Data.Managers Namespace


GetLanguage Method (String)

[image]

Sitecore 6.4.1 API
LanguageProvider..::..GetLanguage Method (String)
LanguageProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Language GetLanguage(
    string name
)
Visual Basic
Public Overridable Function GetLanguage ( _
    name As String _
) As Language
Visual C++
public:
virtual Language^ GetLanguage(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Managers.LanguageProvider.GetLanguage(System.String)"]

See Also

LanguageProvider Class
GetLanguage Overload
Sitecore.Data.Managers Namespace


GetLanguage Method (String, Database)

[image]

Sitecore 6.4.1 API
LanguageProvider..::..GetLanguage Method (String, Database)
LanguageProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Language GetLanguage(
    string name,
    Database database
)
Visual Basic
Public Function GetLanguage ( _
    name As String, _
    database As Database _
) As Language
Visual C++
public:
Language^ GetLanguage(
    String^ name,
    Database^ database
)

Parameters

name
Type: System..::..String
The name.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Managers.LanguageProvider.GetLanguage(System.String,Sitecore.Data.Database)"]

See Also

LanguageProvider Class
GetLanguage Overload
Sitecore.Data.Managers Namespace


GetLanguageItemId Method

[image]

Sitecore 6.4.1 API
LanguageProvider..::..GetLanguageItemId Method
LanguageProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ID GetLanguageItemId(
    Language language,
    Database database
)
Visual Basic
Public Overridable Function GetLanguageItemId ( _
    language As Language, _
    database As Database _
) As ID
Visual C++
public:
virtual ID^ GetLanguageItemId(
    Language^ language,
    Database^ database
)

Parameters

language
Type: Sitecore.Globalization..::..Language
The language.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Managers.LanguageProvider.GetLanguageItemId(Sitecore.Globalization.Language,Sitecore.Data.Database)"]

See Also

LanguageProvider Class
Sitecore.Data.Managers Namespace


GetLanguages Method

[image]

Sitecore 6.4.1 API
LanguageProvider..::..GetLanguages Method
LanguageProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual LanguageCollection GetLanguages(
    Database database
)
Visual Basic
Public Overridable Function GetLanguages ( _
    database As Database _
) As LanguageCollection
Visual C++
public:
virtual LanguageCollection^ GetLanguages(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Managers.LanguageProvider.GetLanguages(Sitecore.Data.Database)"]

See Also

LanguageProvider Class
Sitecore.Data.Managers Namespace


InvalidateCaches Method

[image]

Sitecore 6.4.1 API
LanguageProvider..::..InvalidateCaches Method
LanguageProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void InvalidateCaches(
    Database database
)
Visual Basic
Public Overridable Sub InvalidateCaches ( _
    database As Database _
)
Visual C++
public:
virtual void InvalidateCaches(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

See Also

LanguageProvider Class
Sitecore.Data.Managers Namespace


IsLanguageNameDefined Method

[image]

Sitecore 6.4.1 API
LanguageProvider..::..IsLanguageNameDefined Method
LanguageProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool IsLanguageNameDefined(
    Database database,
    string languageName
)
Visual Basic
Public Overridable Function IsLanguageNameDefined ( _
    database As Database, _
    languageName As String _
) As Boolean
Visual C++
public:
virtual bool IsLanguageNameDefined(
    Database^ database,
    String^ languageName
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.
languageName
Type: System..::..String
The name.

Return Value

true if the language name is defined in the specified database; otherwise, false.

See Also

LanguageProvider Class
Sitecore.Data.Managers Namespace


IsValidLanguageName Method

[image]

Sitecore 6.4.1 API
LanguageProvider..::..IsValidLanguageName Method
LanguageProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool IsValidLanguageName(
    string name
)
Visual Basic
Public Overridable Function IsValidLanguageName ( _
    name As String _
) As Boolean
Visual C++
public:
virtual bool IsValidLanguageName(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

Return Value

true if the specified name is a valid language name; otherwise, false.

See Also

LanguageProvider Class
Sitecore.Data.Managers Namespace


LanguageRegistered Method

[image] [image]

Sitecore 6.4.1 API
LanguageProvider..::..LanguageRegistered Method
LanguageProvider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LanguageRegistered(String) | Gets a value indicating if a specific language is registered with the ASP.NET globalization engine.
Public method | LanguageRegistered(String, Database) | Gets a value indicating if a specific language is registered in a specific database.

See Also

LanguageProvider Class
LanguageProvider Members
Sitecore.Data.Managers Namespace


LanguageRegistered Method (String)

[image]

Sitecore 6.4.1 API
LanguageProvider..::..LanguageRegistered Method (String)
LanguageProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool LanguageRegistered(
    string name
)
Visual Basic
Public Overridable Function LanguageRegistered ( _
    name As String _
) As Boolean
Visual C++
public:
virtual bool LanguageRegistered(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Managers.LanguageProvider.LanguageRegistered(System.String)"]

See Also

LanguageProvider Class
LanguageRegistered Overload
Sitecore.Data.Managers Namespace


LanguageRegistered Method (String, Database)

[image]

Sitecore 6.4.1 API
LanguageProvider..::..LanguageRegistered Method (String, Database)
LanguageProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool LanguageRegistered(
    string name,
    Database database
)
Visual Basic
Public Overridable Function LanguageRegistered ( _
    name As String, _
    database As Database _
) As Boolean
Visual C++
public:
virtual bool LanguageRegistered(
    String^ name,
    Database^ database
)

Parameters

name
Type: System..::..String
The name.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Managers.LanguageProvider.LanguageRegistered(System.String,Sitecore.Data.Database)"]

See Also

LanguageProvider Class
LanguageRegistered Overload
Sitecore.Data.Managers Namespace


RegisterLanguage Method

[image]

Sitecore 6.4.1 API
LanguageProvider..::..RegisterLanguage Method
LanguageProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool RegisterLanguage(
    string name
)
Visual Basic
Public Overridable Function RegisterLanguage ( _
    name As String _
) As Boolean
Visual C++
public:
virtual bool RegisterLanguage(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Managers.LanguageProvider.RegisterLanguage(System.String)"]

See Also

LanguageProvider Class
Sitecore.Data.Managers Namespace


RemoveLanguageData Method

[image]

Sitecore 6.4.1 API
LanguageProvider..::..RemoveLanguageData Method
LanguageProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void RemoveLanguageData(
    Language language,
    Database database
)
Visual Basic
Public Overridable Sub RemoveLanguageData ( _
    language As Language, _
    database As Database _
)
Visual C++
public:
virtual void RemoveLanguageData(
    Language^ language,
    Database^ database
)

Parameters

language
Type: Sitecore.Globalization..::..Language
The language.
database
Type: Sitecore.Data..::..Database
The database.

Remarks

If the language does not exist in the target database, no action will be taken.

See Also

LanguageProvider Class
Sitecore.Data.Managers Namespace


RenameLanguageData Method

[image]

Sitecore 6.4.1 API
LanguageProvider..::..RenameLanguageData Method
LanguageProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void RenameLanguageData(
    string fromLanguage,
    string toLanguage,
    Database database
)
Visual Basic
Public Overridable Sub RenameLanguageData ( _
    fromLanguage As String, _
    toLanguage As String, _
    database As Database _
)
Visual C++
public:
virtual void RenameLanguageData(
    String^ fromLanguage,
    String^ toLanguage,
    Database^ database
)

Parameters

fromLanguage
Type: System..::..String
Rename from this language name.
toLanguage
Type: System..::..String
Rename to this language name.
database
Type: Sitecore.Data..::..Database
The database.

See Also

LanguageProvider Class
Sitecore.Data.Managers Namespace


NotificationManager Class

[image]

Sitecore 6.4.1 API
NotificationManager Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class NotificationManager
Visual Basic
Public Class NotificationManager
Visual C++
public ref class NotificationManager

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Managers..::..NotificationManager

See Also

NotificationManager Members
Sitecore.Data.Managers Namespace


NotificationManager Members

[image] [image]

Sitecore 6.4.1 API
NotificationManager Members
NotificationManager Class Constructors Methods See Also Send Feedback

The NotificationManager type exposes the following members.

Constructors

 | Name | Description
Public method | NotificationManager | Initializes a new instance of the NotificationManager class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize | Initializes this instance.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NotificationManager Class
Sitecore.Data.Managers Namespace


NotificationManager Constructor

[image]

Sitecore 6.4.1 API
NotificationManager Constructor
NotificationManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public NotificationManager()
Visual Basic
Public Sub New
Visual C++
public:
NotificationManager()

See Also

NotificationManager Class
Sitecore.Data.Managers Namespace


NotificationManager Methods

[image] [image]

Sitecore 6.4.1 API
NotificationManager Methods
NotificationManager Class See Also Send Feedback

The NotificationManager type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize | Initializes this instance.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NotificationManager Class
Sitecore.Data.Managers Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
NotificationManager..::..Initialize Method
NotificationManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Initialize()
Visual Basic
Public Shared Sub Initialize
Visual C++
public:
static void Initialize()

See Also

NotificationManager Class
Sitecore.Data.Managers Namespace


TemplateManager Class

[image]

Sitecore 6.4.1 API
TemplateManager Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class TemplateManager
Visual Basic
Public NotInheritable Class TemplateManager
Visual C++
public ref class TemplateManager abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Managers..::..TemplateManager

See Also

TemplateManager Members
Sitecore.Data.Managers Namespace


TemplateManager Members

[image] [image]

Sitecore 6.4.1 API
TemplateManager Members
TemplateManager Class Methods See Also Send Feedback

The TemplateManager type exposes the following members.

Methods

Name | Description
ChangeFieldSharing | Changes the field sharing type of a single field.
ChangeTemplate | Changes the template of an item.
GetFieldId | Gets the id of a field.
GetTemplate(Item) | Gets the template associated with an item.
GetTemplate(String, Database) | Gets the template with a specific name.
GetTemplate(ID, Database) | Gets the template associated with a template id.
GetTemplateField(ID, Item) | Gets the template field.
GetTemplateField(ID, ID, Database) | Gets a template field.
GetTemplates | Gets all templates defined in a specific database.
IsDataField | Determines whether [is data field] [the specified template field].
IsFieldPartOfTemplate(ID, Item) | Determines whether a template contains a specific field.
IsFieldPartOfTemplate(ID, ID, Database) | Determines whether a template contains a specific field.
IsStandardValuesHolder | Determines whether the specified item is a is standard values holder for a template.
IsTemplate | Determines whether an item is a template.
IsTemplatePart | Determines whether an item is a template part.

See Also

TemplateManager Class
Sitecore.Data.Managers Namespace


TemplateManager Methods

[image] [image]

Sitecore 6.4.1 API
TemplateManager Methods
TemplateManager Class See Also Send Feedback

The TemplateManager type exposes the following members.

Methods

Name | Description
ChangeFieldSharing | Changes the field sharing type of a single field.
ChangeTemplate | Changes the template of an item.
GetFieldId | Gets the id of a field.
GetTemplate(Item) | Gets the template associated with an item.
GetTemplate(String, Database) | Gets the template with a specific name.
GetTemplate(ID, Database) | Gets the template associated with a template id.
GetTemplateField(ID, Item) | Gets the template field.
GetTemplateField(ID, ID, Database) | Gets a template field.
GetTemplates | Gets all templates defined in a specific database.
IsDataField | Determines whether [is data field] [the specified template field].
IsFieldPartOfTemplate(ID, Item) | Determines whether a template contains a specific field.
IsFieldPartOfTemplate(ID, ID, Database) | Determines whether a template contains a specific field.
IsStandardValuesHolder | Determines whether the specified item is a is standard values holder for a template.
IsTemplate | Determines whether an item is a template.
IsTemplatePart | Determines whether an item is a template part.

See Also

TemplateManager Class
Sitecore.Data.Managers Namespace


ChangeTemplate Method

[image]

Sitecore 6.4.1 API
TemplateManager..::..ChangeTemplate Method
TemplateManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool ChangeTemplate(
    Item item,
    TemplateChangeList changes
)
Visual Basic
Public Shared Function ChangeTemplate ( _
    item As Item, _
    changes As TemplateChangeList _
) As Boolean
Visual C++
public:
static bool ChangeTemplate(
    Item^ item,
    TemplateChangeList^ changes
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
changes
Type: Sitecore.Data.Templates..::..TemplateChangeList
The changes.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Managers.TemplateManager.ChangeTemplate(Sitecore.Data.Items.Item,Sitecore.Data.Templates.TemplateChangeList)"]

See Also

TemplateManager Class
Sitecore.Data.Managers Namespace


GetFieldId Method

[image]

Sitecore 6.4.1 API
TemplateManager..::..GetFieldId Method
TemplateManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID GetFieldId(
    string fieldName,
    ID templateId,
    Database database
)
Visual Basic
Public Shared Function GetFieldId ( _
    fieldName As String, _
    templateId As ID, _
    database As Database _
) As ID
Visual C++
public:
static ID^ GetFieldId(
    String^ fieldName,
    ID^ templateId,
    Database^ database
)

Parameters

fieldName
Type: System..::..String
Name of the field.
templateId
Type: Sitecore.Data..::..ID
The template id.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Managers.TemplateManager.GetFieldId(System.String,Sitecore.Data.ID,Sitecore.Data.Database)"]

See Also

TemplateManager Class
Sitecore.Data.Managers Namespace


GetTemplate Method

[image] [image]

Sitecore 6.4.1 API
TemplateManager..::..GetTemplate Method
TemplateManager Class See Also Send Feedback

Overload List

Name | Description
GetTemplate(Item) | Gets the template associated with an item.
GetTemplate(String, Database) | Gets the template with a specific name.
GetTemplate(ID, Database) | Gets the template associated with a template id.

See Also

TemplateManager Class
TemplateManager Members
Sitecore.Data.Managers Namespace


GetTemplate Method (Item)

[image]

Sitecore 6.4.1 API
TemplateManager..::..GetTemplate Method (Item)
TemplateManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Template GetTemplate(
    Item item
)
Visual Basic
Public Shared Function GetTemplate ( _
    item As Item _
) As Template
Visual C++
public:
static Template^ GetTemplate(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item to get the template for.

Return Value

The template.

See Also

TemplateManager Class
GetTemplate Overload
Sitecore.Data.Managers Namespace


GetTemplate Method (String, Database)

[image]

Sitecore 6.4.1 API
TemplateManager..::..GetTemplate Method (String, Database)
TemplateManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Template GetTemplate(
    string fullName,
    Database database
)
Visual Basic
Public Shared Function GetTemplate ( _
    fullName As String, _
    database As Database _
) As Template
Visual C++
public:
static Template^ GetTemplate(
    String^ fullName,
    Database^ database
)

Parameters

fullName
Type: System..::..String
The full name of the desired template. A full name is either a full Sitecore path (ie. /sitecore/templates/documents/Document) or a path relative to /sitecore/templates (ie. documents/Document). The name is case-insensitive.
database
Type: Sitecore.Data..::..Database
The database containing the template.

Return Value

The template.

See Also

TemplateManager Class
GetTemplate Overload
Sitecore.Data.Managers Namespace


GetTemplate Method (ID, Database)

[image]

Sitecore 6.4.1 API
TemplateManager..::..GetTemplate Method (ID, Database)
TemplateManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Template GetTemplate(
    ID templateId,
    Database database
)
Visual Basic
Public Shared Function GetTemplate ( _
    templateId As ID, _
    database As Database _
) As Template
Visual C++
public:
static Template^ GetTemplate(
    ID^ templateId,
    Database^ database
)

Parameters

templateId
Type: Sitecore.Data..::..ID
The id of the desired template.
database
Type: Sitecore.Data..::..Database
The database containing the template.

Return Value

The template.

See Also

TemplateManager Class
GetTemplate Overload
Sitecore.Data.Managers Namespace


GetTemplateField Method

[image] [image]

Sitecore 6.4.1 API
TemplateManager..::..GetTemplateField Method
TemplateManager Class See Also Send Feedback

Overload List

Name | Description
GetTemplateField(ID, Item) | Gets the template field.
GetTemplateField(ID, ID, Database) | Gets a template field.

See Also

TemplateManager Class
TemplateManager Members
Sitecore.Data.Managers Namespace


GetTemplates Method

[image]

Sitecore 6.4.1 API
TemplateManager..::..GetTemplates Method
TemplateManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TemplateDictionary GetTemplates(
    Database database
)
Visual Basic
Public Shared Function GetTemplates ( _
    database As Database _
) As TemplateDictionary
Visual C++
public:
static TemplateDictionary^ GetTemplates(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database containing the templates.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Managers.TemplateManager.GetTemplates(Sitecore.Data.Database)"]

See Also

TemplateManager Class
Sitecore.Data.Managers Namespace


IsDataField Method

[image]

Sitecore 6.4.1 API
TemplateManager..::..IsDataField Method
TemplateManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsDataField(
    TemplateField templateField
)
Visual Basic
Public Shared Function IsDataField ( _
    templateField As TemplateField _
) As Boolean
Visual C++
public:
static bool IsDataField(
    TemplateField^ templateField
)

Parameters

templateField
Type: Sitecore.Data.Templates..::..TemplateField
The template field.

Return Value

true if [is data field] [the specified template field]; otherwise, false.

See Also

TemplateManager Class
Sitecore.Data.Managers Namespace


IsFieldPartOfTemplate Method

[image] [image]

Sitecore 6.4.1 API
TemplateManager..::..IsFieldPartOfTemplate Method
TemplateManager Class See Also Send Feedback

Overload List

Name | Description
IsFieldPartOfTemplate(ID, Item) | Determines whether a template contains a specific field.
IsFieldPartOfTemplate(ID, ID, Database) | Determines whether a template contains a specific field.

See Also

TemplateManager Class
TemplateManager Members
Sitecore.Data.Managers Namespace


IsFieldPartOfTemplate Method (ID, Item)

[image]

Sitecore 6.4.1 API
TemplateManager..::..IsFieldPartOfTemplate Method (ID, Item)
TemplateManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsFieldPartOfTemplate(
    ID fieldId,
    Item item
)
Visual Basic
Public Shared Function IsFieldPartOfTemplate ( _
    fieldId As ID, _
    item As Item _
) As Boolean
Visual C++
public:
static bool IsFieldPartOfTemplate(
    ID^ fieldId,
    Item^ item
)

Parameters

fieldId
Type: Sitecore.Data..::..ID
The field id.
item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

The field part of template.

See Also

TemplateManager Class
IsFieldPartOfTemplate Overload
Sitecore.Data.Managers Namespace


IsFieldPartOfTemplate Method (ID, ID, Database)

[image]

Sitecore 6.4.1 API
TemplateManager..::..IsFieldPartOfTemplate Method (ID, ID, Database)
TemplateManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsFieldPartOfTemplate(
    ID fieldId,
    ID templateId,
    Database database
)
Visual Basic
Public Shared Function IsFieldPartOfTemplate ( _
    fieldId As ID, _
    templateId As ID, _
    database As Database _
) As Boolean
Visual C++
public:
static bool IsFieldPartOfTemplate(
    ID^ fieldId,
    ID^ templateId,
    Database^ database
)

Parameters

fieldId
Type: Sitecore.Data..::..ID
The field id.
templateId
Type: Sitecore.Data..::..ID
The template id.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

The field part of template.

See Also

TemplateManager Class
IsFieldPartOfTemplate Overload
Sitecore.Data.Managers Namespace


IsStandardValuesHolder Method

[image]

Sitecore 6.4.1 API
TemplateManager..::..IsStandardValuesHolder Method
TemplateManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsStandardValuesHolder(
    Item item
)
Visual Basic
Public Shared Function IsStandardValuesHolder ( _
    item As Item _
) As Boolean
Visual C++
public:
static bool IsStandardValuesHolder(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

true if the specified item is a standard values holder; otherwise, false.

See Also

TemplateManager Class
Sitecore.Data.Managers Namespace


IsTemplate Method

[image]

Sitecore 6.4.1 API
TemplateManager..::..IsTemplate Method
TemplateManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsTemplate(
    Item item
)
Visual Basic
Public Shared Function IsTemplate ( _
    item As Item _
) As Boolean
Visual C++
public:
static bool IsTemplate(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

true if the item is a template; otherwise, false.

See Also

TemplateManager Class
Sitecore.Data.Managers Namespace


IsTemplatePart Method

[image]

Sitecore 6.4.1 API
TemplateManager..::..IsTemplatePart Method
TemplateManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsTemplatePart(
    Item item
)
Visual Basic
Public Shared Function IsTemplatePart ( _
    item As Item _
) As Boolean
Visual C++
public:
static bool IsTemplatePart(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

true if the item is a template part; otherwise, false.

See Also

TemplateManager Class
Sitecore.Data.Managers Namespace


ThemeManager Class

[image]

Sitecore 6.4.1 API
ThemeManager Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public sealed class ThemeManager
Visual Basic
Public NotInheritable Class ThemeManager
Visual C++
public ref class ThemeManager sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Managers..::..ThemeManager

See Also

ThemeManager Members
Sitecore.Data.Managers Namespace


ThemeManager Members

[image] [image]

Sitecore 6.4.1 API
ThemeManager Members
ThemeManager Class Constructors Methods See Also Send Feedback

The ThemeManager type exposes the following members.

Constructors

 | Name | Description
Public method | ThemeManager | Initializes a new instance of the ThemeManager class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIconImage(Item, Int32, Int32, String, String) | Gets an image for an items icon.
 | GetIconImage(Item, Int32, Int32, String, String, String, String, Boolean) | Gets an image for an items icon.
 | GetImage(String, Int32, Int32) | Gets an image from a path.
 | GetImage(String, Int32, Int32, String, String, String, String, Boolean) | Gets an image from a path.
 | GetLanguageImage(Language, Database, Int32, Int32) | Gets the image symbolizing a language.
 | GetLanguageImage(Language, Database, Int32, Int32, String, String, String, String, Boolean) | Gets the image symbolizing a language.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ThemeManager Class
Sitecore.Data.Managers Namespace


ThemeManager Constructor

[image]

Sitecore 6.4.1 API
ThemeManager Constructor
ThemeManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ThemeManager()
Visual Basic
Public Sub New
Visual C++
public:
ThemeManager()

See Also

ThemeManager Class
Sitecore.Data.Managers Namespace


ThemeManager Methods

[image] [image]

Sitecore 6.4.1 API
ThemeManager Methods
ThemeManager Class See Also Send Feedback

The ThemeManager type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIconImage(Item, Int32, Int32, String, String) | Gets an image for an items icon.
 | GetIconImage(Item, Int32, Int32, String, String, String, String, Boolean) | Gets an image for an items icon.
 | GetImage(String, Int32, Int32) | Gets an image from a path.
 | GetImage(String, Int32, Int32, String, String, String, String, Boolean) | Gets an image from a path.
 | GetLanguageImage(Language, Database, Int32, Int32) | Gets the image symbolizing a language.
 | GetLanguageImage(Language, Database, Int32, Int32, String, String, String, String, Boolean) | Gets the image symbolizing a language.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ThemeManager Class
Sitecore.Data.Managers Namespace


GetIconImage Method

[image] [image]

Sitecore 6.4.1 API
ThemeManager..::..GetIconImage Method
ThemeManager Class See Also Send Feedback

Overload List

Name | Description
GetIconImage(Item, Int32, Int32, String, String) | Gets an image for an items icon.
GetIconImage(Item, Int32, Int32, String, String, String, String, Boolean) | Gets an image for an items icon.

See Also

ThemeManager Class
ThemeManager Members
Sitecore.Data.Managers Namespace


GetIconImage Method (Item, Int32, Int32, String, String)

[image]

Sitecore 6.4.1 API
ThemeManager..::..GetIconImage Method (Item, Int32, Int32, String, String)
ThemeManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetIconImage(
    Item item,
    int width,
    int height,
    string align,
    string margin
)
Visual Basic
Public Shared Function GetIconImage ( _
    item As Item, _
    width As Integer, _
    height As Integer, _
    align As String, _
    margin As String _
) As String
Visual C++
public:
static String^ GetIconImage(
    Item^ item,
    int width,
    int height,
    String^ align,
    String^ margin
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
width
Type: System..::..Int32
The width.
height
Type: System..::..Int32
The height.
align
Type: System..::..String
The align.
margin
Type: System..::..String
The margin.

Return Value

The icon image.

See Also

ThemeManager Class
GetIconImage Overload
Sitecore.Data.Managers Namespace


GetIconImage Method (Item, Int32, Int32, String, String, String, String, Boolean)

[image]

Sitecore 6.4.1 API
ThemeManager..::..GetIconImage Method (Item, Int32, Int32, String, String, String, String, Boolean)
ThemeManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetIconImage(
    Item item,
    int width,
    int height,
    string align,
    string margin,
    string alt,
    string id,
    bool resize
)
Visual Basic
Public Shared Function GetIconImage ( _
    item As Item, _
    width As Integer, _
    height As Integer, _
    align As String, _
    margin As String, _
    alt As String, _
    id As String, _
    resize As Boolean _
) As String
Visual C++
public:
static String^ GetIconImage(
    Item^ item,
    int width,
    int height,
    String^ align,
    String^ margin,
    String^ alt,
    String^ id,
    bool resize
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
width
Type: System..::..Int32
The width.
height
Type: System..::..Int32
The height.
align
Type: System..::..String
The align.
margin
Type: System..::..String
The margin.
alt
Type: System..::..String
The alt.
id
Type: System..::..String
The id.
resize
Type: System..::..Boolean
if set to true [resize].

Return Value

The icon image.

See Also

ThemeManager Class
GetIconImage Overload
Sitecore.Data.Managers Namespace


GetImage Method

[image] [image]

Sitecore 6.4.1 API
ThemeManager..::..GetImage Method
ThemeManager Class See Also Send Feedback

Overload List

Name | Description
GetImage(String, Int32, Int32) | Gets an image from a path.
GetImage(String, Int32, Int32, String, String, String, String, Boolean) | Gets an image from a path.

See Also

ThemeManager Class
ThemeManager Members
Sitecore.Data.Managers Namespace


GetImage Method (String, Int32, Int32)

[image]

Sitecore 6.4.1 API
ThemeManager..::..GetImage Method (String, Int32, Int32)
ThemeManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetImage(
    string path,
    int width,
    int height
)
Visual Basic
Public Shared Function GetImage ( _
    path As String, _
    width As Integer, _
    height As Integer _
) As String
Visual C++
public:
static String^ GetImage(
    String^ path,
    int width,
    int height
)

Parameters

path
Type: System..::..String
The path.
width
Type: System..::..Int32
The width.
height
Type: System..::..Int32
The height.

Return Value

The image.

See Also

ThemeManager Class
GetImage Overload
Sitecore.Data.Managers Namespace


GetImage Method (String, Int32, Int32, String, String, String, String, Boolean)

[image]

Sitecore 6.4.1 API
ThemeManager..::..GetImage Method (String, Int32, Int32, String, String, String, String, Boolean)
ThemeManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetImage(
    string path,
    int width,
    int height,
    string align,
    string margin,
    string alt,
    string id,
    bool resize
)
Visual Basic
Public Shared Function GetImage ( _
    path As String, _
    width As Integer, _
    height As Integer, _
    align As String, _
    margin As String, _
    alt As String, _
    id As String, _
    resize As Boolean _
) As String
Visual C++
public:
static String^ GetImage(
    String^ path,
    int width,
    int height,
    String^ align,
    String^ margin,
    String^ alt,
    String^ id,
    bool resize
)

Parameters

path
Type: System..::..String
The path.
width
Type: System..::..Int32
The width.
height
Type: System..::..Int32
The height.
align
Type: System..::..String
The align.
margin
Type: System..::..String
The margin.
alt
Type: System..::..String
The alt.
id
Type: System..::..String
The id.
resize
Type: System..::..Boolean
if set to true [resize].

Return Value

The image.

See Also

ThemeManager Class
GetImage Overload
Sitecore.Data.Managers Namespace


GetLanguageImage Method (Language, Database, Int32, Int32)

[image]

Sitecore 6.4.1 API
ThemeManager..::..GetLanguageImage Method (Language, Database, Int32, Int32)
ThemeManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetLanguageImage(
    Language language,
    Database database,
    int width,
    int height
)
Visual Basic
Public Shared Function GetLanguageImage ( _
    language As Language, _
    database As Database, _
    width As Integer, _
    height As Integer _
) As String
Visual C++
public:
static String^ GetLanguageImage(
    Language^ language,
    Database^ database,
    int width,
    int height
)

Parameters

language
Type: Sitecore.Globalization..::..Language
The language.
database
Type: Sitecore.Data..::..Database
The database.
width
Type: System..::..Int32
The width.
height
Type: System..::..Int32
The height.

Return Value

The language image.

See Also

ThemeManager Class
GetLanguageImage Overload
Sitecore.Data.Managers Namespace


GetLanguageImage Method (Language, Database, Int32, Int32, String, String, String, String, Boolean)

[image]

Sitecore 6.4.1 API
ThemeManager..::..GetLanguageImage Method (Language, Database, Int32, Int32, String, String, String, String, Boolean)
ThemeManager Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetLanguageImage(
    Language language,
    Database database,
    int width,
    int height,
    string align,
    string margin,
    string alt,
    string id,
    bool resize
)
Visual Basic
Public Shared Function GetLanguageImage ( _
    language As Language, _
    database As Database, _
    width As Integer, _
    height As Integer, _
    align As String, _
    margin As String, _
    alt As String, _
    id As String, _
    resize As Boolean _
) As String
Visual C++
public:
static String^ GetLanguageImage(
    Language^ language,
    Database^ database,
    int width,
    int height,
    String^ align,
    String^ margin,
    String^ alt,
    String^ id,
    bool resize
)

Parameters

language
Type: Sitecore.Globalization..::..Language
The language.
database
Type: Sitecore.Data..::..Database
The database.
width
Type: System..::..Int32
The width.
height
Type: System..::..Int32
The height.
align
Type: System..::..String
The align.
margin
Type: System..::..String
The margin.
alt
Type: System..::..String
The alt.
id
Type: System..::..String
The id.
resize
Type: System..::..Boolean
if set to true this instance is resize.

Return Value

The language image.

See Also

ThemeManager Class
GetLanguageImage Overload
Sitecore.Data.Managers Namespace


ThemeProvider Class

[image]

Sitecore 6.4.1 API
ThemeProvider Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ThemeProvider
Visual Basic
Public Class ThemeProvider
Visual C++
public ref class ThemeProvider

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Managers..::..ThemeProvider

See Also

ThemeProvider Members
Sitecore.Data.Managers Namespace


ThemeProvider Members

[image] [image]

Sitecore 6.4.1 API
ThemeProvider Members
ThemeProvider Class Constructors Methods See Also Send Feedback

The ThemeProvider type exposes the following members.

Constructors

 | Name | Description
Public method | ThemeProvider | Initializes a new instance of the ThemeProvider class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCurrentTheme | Gets the current theme.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIconImage | Gets an image for an items icon.
Public method | GetImage | Gets an image for an items icon.
Public method | GetLanguageImage | Gets the image symbolizing a language.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ThemeProvider Class
Sitecore.Data.Managers Namespace


ThemeProvider Constructor

[image]

Sitecore 6.4.1 API
ThemeProvider Constructor
ThemeProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ThemeProvider()
Visual Basic
Public Sub New
Visual C++
public:
ThemeProvider()

See Also

ThemeProvider Class
Sitecore.Data.Managers Namespace


ThemeProvider Methods

[image] [image]

Sitecore 6.4.1 API
ThemeProvider Methods
ThemeProvider Class See Also Send Feedback

The ThemeProvider type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCurrentTheme | Gets the current theme.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIconImage | Gets an image for an items icon.
Public method | GetImage | Gets an image for an items icon.
Public method | GetLanguageImage | Gets the image symbolizing a language.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ThemeProvider Class
Sitecore.Data.Managers Namespace


GetCurrentTheme Method

[image]

Sitecore 6.4.1 API
ThemeProvider..::..GetCurrentTheme Method
ThemeProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string GetCurrentTheme()
Visual Basic
Public Overridable Function GetCurrentTheme As String
Visual C++
public:
virtual String^ GetCurrentTheme()

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Managers.ThemeProvider.GetCurrentTheme"]

See Also

ThemeProvider Class
Sitecore.Data.Managers Namespace


GetIconImage Method

[image]

Sitecore 6.4.1 API
ThemeProvider..::..GetIconImage Method
ThemeProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string GetIconImage(
    Item item,
    int width,
    int height,
    string align,
    string margin,
    string alt,
    string id,
    bool resize
)
Visual Basic
Public Overridable Function GetIconImage ( _
    item As Item, _
    width As Integer, _
    height As Integer, _
    align As String, _
    margin As String, _
    alt As String, _
    id As String, _
    resize As Boolean _
) As String
Visual C++
public:
virtual String^ GetIconImage(
    Item^ item,
    int width,
    int height,
    String^ align,
    String^ margin,
    String^ alt,
    String^ id,
    bool resize
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
width
Type: System..::..Int32
The width.
height
Type: System..::..Int32
The height.
align
Type: System..::..String
The align.
margin
Type: System..::..String
The margin.
alt
Type: System..::..String
The alt.
id
Type: System..::..String
The id.
resize
Type: System..::..Boolean
if set to true [resize].

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Managers.ThemeProvider.GetIconImage(Sitecore.Data.Items.Item,System.Int32,System.Int32,System.String,System.String,System.String,System.String,System.Boolean)"]

See Also

ThemeProvider Class
Sitecore.Data.Managers Namespace


GetImage Method

[image]

Sitecore 6.4.1 API
ThemeProvider..::..GetImage Method
ThemeProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string GetImage(
    string path,
    int width,
    int height,
    string align,
    string margin,
    string alt,
    string id,
    bool resize
)
Visual Basic
Public Overridable Function GetImage ( _
    path As String, _
    width As Integer, _
    height As Integer, _
    align As String, _
    margin As String, _
    alt As String, _
    id As String, _
    resize As Boolean _
) As String
Visual C++
public:
virtual String^ GetImage(
    String^ path,
    int width,
    int height,
    String^ align,
    String^ margin,
    String^ alt,
    String^ id,
    bool resize
)

Parameters

path
Type: System..::..String
The path.
width
Type: System..::..Int32
The width.
height
Type: System..::..Int32
The height.
align
Type: System..::..String
The align.
margin
Type: System..::..String
The margin.
alt
Type: System..::..String
The alt.
id
Type: System..::..String
The id.
resize
Type: System..::..Boolean
if set to true [resize].

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Managers.ThemeProvider.GetImage(System.String,System.Int32,System.Int32,System.String,System.String,System.String,System.String,System.Boolean)"]

See Also

ThemeProvider Class
Sitecore.Data.Managers Namespace


GetLanguageImage Method

[image]

Sitecore 6.4.1 API
ThemeProvider..::..GetLanguageImage Method
ThemeProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Managers
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string GetLanguageImage(
    Language language,
    Database database,
    int width,
    int height,
    string align,
    string margin,
    string alt,
    string id,
    bool resize
)
Visual Basic
Public Overridable Function GetLanguageImage ( _
    language As Language, _
    database As Database, _
    width As Integer, _
    height As Integer, _
    align As String, _
    margin As String, _
    alt As String, _
    id As String, _
    resize As Boolean _
) As String
Visual C++
public:
virtual String^ GetLanguageImage(
    Language^ language,
    Database^ database,
    int width,
    int height,
    String^ align,
    String^ margin,
    String^ alt,
    String^ id,
    bool resize
)

Parameters

language
Type: Sitecore.Globalization..::..Language
The language.
database
Type: Sitecore.Data..::..Database
The database.
width
Type: System..::..Int32
The width.
height
Type: System..::..Int32
The height.
align
Type: System..::..String
The align.
margin
Type: System..::..String
The margin.
alt
Type: System..::..String
The alt.
id
Type: System..::..String
The id.
resize
Type: System..::..Boolean
if set to true this instance is resize.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Managers.ThemeProvider.GetLanguageImage(Sitecore.Globalization.Language,Sitecore.Data.Database,System.Int32,System.Int32,System.String,System.String,System.String,System.String,System.Boolean)"]

See Also

ThemeProvider Class
Sitecore.Data.Managers Namespace


InsertRule Class

[image]

Sitecore 6.4.1 API
InsertRule Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Masters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class InsertRule
Visual Basic
Public MustInherit Class InsertRule
Visual C++
public ref class InsertRule abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Masters..::..InsertRule

See Also

InsertRule Members
Sitecore.Data.Masters Namespace


InsertRule Members

[image] [image]

Sitecore 6.4.1 API
InsertRule Members
InsertRule Class Constructors Methods See Also Send Feedback

The InsertRule type exposes the following members.

Constructors

 | Name | Description
Protected method | InsertRule | Initializes a new instance of the InsertRule class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Expand | Expands the specified masters.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InsertRule Class
Sitecore.Data.Masters Namespace


InsertRule Constructor

[image]

Sitecore 6.4.1 API
InsertRule Constructor
InsertRule Class See Also Send Feedback

Namespace: Sitecore.Data.Masters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected InsertRule()
Visual Basic
Protected Sub New
Visual C++
protected:
InsertRule()

See Also

InsertRule Class
Sitecore.Data.Masters Namespace


InsertRule Methods

[image] [image]

Sitecore 6.4.1 API
InsertRule Methods
InsertRule Class See Also Send Feedback

The InsertRule type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Expand | Expands the specified masters.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InsertRule Class
Sitecore.Data.Masters Namespace


Expand Method

[image]

Sitecore 6.4.1 API
InsertRule..::..Expand Method
InsertRule Class See Also Send Feedback

Namespace: Sitecore.Data.Masters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract void Expand(
    List<Item> masters,
    Item item
)
Visual Basic
Public MustOverride Sub Expand ( _
    masters As List(Of Item), _
    item As Item _
)
Visual C++
public:
virtual void Expand(
    List<Item^>^ masters,
    Item^ item
) abstract

Parameters

masters
Type: System.Collections.Generic..::..List <(Of <(<' Item >)>)>
The masters.
item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

InsertRule Class
Sitecore.Data.Masters Namespace


Masters Class

[image]

Sitecore 6.4.1 API
Masters Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Masters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Masters
Visual Basic
Public NotInheritable Class Masters
Visual C++
public ref class Masters abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Masters..::..Masters

See Also

Masters Members
Sitecore.Data.Masters Namespace


Masters Members

[image] [image]

Sitecore 6.4.1 API
Masters Members
Masters Class Methods See Also Send Feedback

The Masters type exposes the following members.

Methods

Name | Description
CreateMaster | Creates the master.
GetClick(Item) | Gets the click.
GetClick(Item, Item) | Gets the click.
GetMasters | Gets the masters.

See Also

Masters Class
Sitecore.Data.Masters Namespace


CreateMaster Method

[image]

Sitecore 6.4.1 API
Masters..::..CreateMaster Method
Masters Class See Also Send Feedback

Namespace: Sitecore.Data.Masters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item CreateMaster(
    Item parent,
    ID templateId
)
Visual Basic
Public Shared Function CreateMaster ( _
    parent As Item, _
    templateId As ID _
) As Item
Visual C++
public:
static Item^ CreateMaster(
    Item^ parent,
    ID^ templateId
)

Parameters

parent
Type: Sitecore.Data.Items..::..Item
The parent.
templateId
Type: Sitecore.Data..::..ID
The template id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Masters.Masters.CreateMaster(Sitecore.Data.Items.Item,Sitecore.Data.ID)"]

See Also

Masters Class
Sitecore.Data.Masters Namespace


GetClick Method

[image] [image]

Sitecore 6.4.1 API
Masters..::..GetClick Method
Masters Class See Also Send Feedback

Overload List

Name | Description
GetClick(Item) | Gets the click.
GetClick(Item, Item) | Gets the click.

See Also

Masters Class
Masters Members
Sitecore.Data.Masters Namespace


GetClick Method (Item)

[image]

Sitecore 6.4.1 API
Masters..::..GetClick Method (Item)
Masters Class See Also Send Feedback

Namespace: Sitecore.Data.Masters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetClick(
    Item master
)
Visual Basic
Public Shared Function GetClick ( _
    master As Item _
) As String
Visual C++
public:
static String^ GetClick(
    Item^ master
)

Parameters

master
Type: Sitecore.Data.Items..::..Item
The master.

Return Value

The click.

See Also

Masters Class
GetClick Overload
Sitecore.Data.Masters Namespace


GetClick Method (Item, Item)

[image]

Sitecore 6.4.1 API
Masters..::..GetClick Method (Item, Item)
Masters Class See Also Send Feedback

Namespace: Sitecore.Data.Masters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetClick(
    Item master,
    Item parent
)
Visual Basic
Public Shared Function GetClick ( _
    master As Item, _
    parent As Item _
) As String
Visual C++
public:
static String^ GetClick(
    Item^ master,
    Item^ parent
)

Parameters

master
Type: Sitecore.Data.Items..::..Item
The master.
parent
Type: Sitecore.Data.Items..::..Item
The parent item.

Return Value

The click.

See Also

Masters Class
GetClick Overload
Sitecore.Data.Masters Namespace


GetMasters Method

[image]

Sitecore 6.4.1 API
Masters..::..GetMasters Method
Masters Class See Also Send Feedback

Namespace: Sitecore.Data.Masters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static List<Item> GetMasters(
    Item item
)
Visual Basic
Public Shared Function GetMasters ( _
    item As Item _
) As List(Of Item)
Visual C++
public:
static List<Item^>^ GetMasters(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

The masters.

See Also

Masters Class
Sitecore.Data.Masters Namespace


Sitecore.Data.Proxies Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Data.Proxies Namespace
Send Feedback

Classes

 | Class | Description
Public class | DomainSwitcher | Disables proxy resolving temporarily.
Public class | Proxy | Proxy class
Public class | ProxyCache | ProxyCache class
Public class | ProxyDataProvider | ProxyDataProvider class
Public class | ProxyDataRecord | ProxyDataRecord class
Public class | ProxyDisabler | Disables proxy resolving temporarily.
Public class | ProxyManager | ProxyManager class
Public class | ProxyMapper | ProxyMapper class
Public class | ProxyProvider | ProxyProvider class
Public class | ProxyReference | ProxyReference class
Public class | ProxyResolver | ProxyResolver class
Public class | ProxyStateMonitor | StateMonitor class
Public class | ProxyTarget | Represents a proxy target.
Public class | SqlProxyDataProvider | Base class for SQL based data providers.

Enumerations

 | Enumeration | Description
Public enumeration | ProxyState | ProxyState enum
Public enumeration | ProxyType | Insertion type for a proxy


DomainSwitcher Class

[image]

Sitecore 6.4.1 API
DomainSwitcher Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DomainSwitcher : Switcher<Domain>
Visual Basic
Public Class DomainSwitcher _
    Inherits Switcher(Of Domain)
Visual C++
public ref class DomainSwitcher : public Switcher<Domain^>

Inheritance Hierarchy

System..::..Object
Sitecore.Common..::..Switcher <(Of <(<' Domain, Domain >)>)>
Sitecore.Common..::..Switcher <(Of <(<' Domain >)>)>
Sitecore.Data.Proxies..::..DomainSwitcher

See Also

DomainSwitcher Members
Sitecore.Data.Proxies Namespace


DomainSwitcher Members

[image] [image]

Sitecore 6.4.1 API
DomainSwitcher Members
DomainSwitcher Class Constructors Methods Events See Also Send Feedback

The DomainSwitcher type exposes the following members.

Constructors

 | Name | Description
Public method | DomainSwitcher(String) | Initializes a new instance of the DomainSwitcher class.
Public method | DomainSwitcher(Domain) | Initializes a new instance of the DomainSwitcher class.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Switcher<(Of <(<'TValue, TSwitchType>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

 | Name | Description
Protected event | Disposed | Occurs when the object has been disposed. (Inherited from Switcher<(Of <(<'TValue, TSwitchType>)>)>.)

See Also

DomainSwitcher Class
Sitecore.Data.Proxies Namespace


DomainSwitcher Constructor

[image] [image]

Sitecore 6.4.1 API
DomainSwitcher Constructor
DomainSwitcher Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DomainSwitcher(String) | Initializes a new instance of the DomainSwitcher class.
Public method | DomainSwitcher(Domain) | Initializes a new instance of the DomainSwitcher class.

See Also

DomainSwitcher Class
DomainSwitcher Members
Sitecore.Data.Proxies Namespace


DomainSwitcher Constructor (String)

[image]

Sitecore 6.4.1 API
DomainSwitcher Constructor (String)
DomainSwitcher Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DomainSwitcher(
    string domainName
)
Visual Basic
Public Sub New ( _
    domainName As String _
)
Visual C++
public:
DomainSwitcher(
    String^ domainName
)

Parameters

domainName
Type: System..::..String
Name of the domain.

See Also

DomainSwitcher Class
DomainSwitcher Overload
Sitecore.Data.Proxies Namespace


DomainSwitcher Constructor (Domain)

[image]

Sitecore 6.4.1 API
DomainSwitcher Constructor (Domain)
DomainSwitcher Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DomainSwitcher(
    Domain domain
)
Visual Basic
Public Sub New ( _
    domain As Domain _
)
Visual C++
public:
DomainSwitcher(
    Domain^ domain
)

Parameters

domain
Type: Sitecore.Security.Domains..::..Domain
The domain.

See Also

DomainSwitcher Class
DomainSwitcher Overload
Sitecore.Data.Proxies Namespace


DomainSwitcher Methods

[image] [image]

Sitecore 6.4.1 API
DomainSwitcher Methods
DomainSwitcher Class See Also Send Feedback

The DomainSwitcher type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Switcher<(Of <(<'TValue, TSwitchType>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DomainSwitcher Class
Sitecore.Data.Proxies Namespace


DomainSwitcher Events

[image] [image]

Sitecore 6.4.1 API
DomainSwitcher Events
DomainSwitcher Class See Also Send Feedback

The DomainSwitcher type exposes the following members.

Events

 | Name | Description
Protected event | Disposed | Occurs when the object has been disposed. (Inherited from Switcher<(Of <(<'TValue, TSwitchType>)>)>.)

See Also

DomainSwitcher Class
Sitecore.Data.Proxies Namespace


Proxy Members

[image] [image]

Sitecore 6.4.1 API
Proxy Members
Proxy Class Constructors Methods Properties See Also Send Feedback

The Proxy type exposes the following members.

Constructors

 | Name | Description
Public method | Proxy | Initializes a new instance of the Proxy class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSourceItem | Gets the source item.
Public method | GetTargetItem | Gets the target item.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsNullOrEmpty | Determines whether a proxy class is null or does not contain any data.
Public method | IsRootItem | Determines whether the specified item is the root of the proxy tree.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
 | Null | Gets the null Proxy.
Public property | ProxyId | Gets the proxy id.
Public property | ProxyType | Gets or sets the type of the proxy.
Public property | SourceDatabase | Gets or sets the source database. Source database is where real item is located.
Public property | SourceId | Gets or sets the source id. Source item is real item that gets 'virtualized' under another item.
Public property | TargetDatabase | Gets or sets the target database. Target database is where virtual items get inserted.
Public property | TargetId | Gets or sets the target id. Target is the item under which virtual items get inserted.

See Also

Proxy Class
Sitecore.Data.Proxies Namespace


Proxy Constructor

[image]

Sitecore 6.4.1 API
Proxy Constructor
Proxy Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Proxy(
    ID proxyId
)
Visual Basic
Public Sub New ( _
    proxyId As ID _
)
Visual C++
public:
Proxy(
    ID^ proxyId
)

Parameters

proxyId
Type: Sitecore.Data..::..ID
The proxy id.

See Also

Proxy Class
Sitecore.Data.Proxies Namespace


GetSourceItem Method

[image]

Sitecore 6.4.1 API
Proxy..::..GetSourceItem Method
Proxy Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetSourceItem(
    Language language,
    Version version
)
Visual Basic
Public Function GetSourceItem ( _
    language As Language, _
    version As Version _
) As Item
Visual C++
public:
Item^ GetSourceItem(
    Language^ language,
    Version^ version
)

Parameters

language
Type: Sitecore.Globalization..::..Language

[Missing <param name="language"/> documentation for "M:Sitecore.Data.Proxies.Proxy.GetSourceItem(Sitecore.Globalization.Language,Sitecore.Data.Version)"]

version
Type: Sitecore.Data..::..Version

[Missing <param name="version"/> documentation for "M:Sitecore.Data.Proxies.Proxy.GetSourceItem(Sitecore.Globalization.Language,Sitecore.Data.Version)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.Proxy.GetSourceItem(Sitecore.Globalization.Language,Sitecore.Data.Version)"]

See Also

Proxy Class
Sitecore.Data.Proxies Namespace


GetTargetItem Method

[image]

Sitecore 6.4.1 API
Proxy..::..GetTargetItem Method
Proxy Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetTargetItem(
    Language language,
    Version version
)
Visual Basic
Public Function GetTargetItem ( _
    language As Language, _
    version As Version _
) As Item
Visual C++
public:
Item^ GetTargetItem(
    Language^ language,
    Version^ version
)

Parameters

language
Type: Sitecore.Globalization..::..Language
The language.
version
Type: Sitecore.Data..::..Version
The version.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.Proxy.GetTargetItem(Sitecore.Globalization.Language,Sitecore.Data.Version)"]

See Also

Proxy Class
Sitecore.Data.Proxies Namespace


IsNullOrEmpty Method

[image]

Sitecore 6.4.1 API
Proxy..::..IsNullOrEmpty Method
Proxy Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsNullOrEmpty(
    Proxy proxy
)
Visual Basic
Public Shared Function IsNullOrEmpty ( _
    proxy As Proxy _
) As Boolean
Visual C++
public:
static bool IsNullOrEmpty(
    Proxy^ proxy
)

Parameters

proxy
Type: Sitecore.Data.Proxies..::..Proxy

[Missing <param name="proxy"/> documentation for "M:Sitecore.Data.Proxies.Proxy.IsNullOrEmpty(Sitecore.Data.Proxies.Proxy)"]

Return Value

true if the instance is null or empty; otherwise, false.

See Also

Proxy Class
Sitecore.Data.Proxies Namespace


Proxy Properties

[image] [image]

Sitecore 6.4.1 API
Proxy Properties
Proxy Class See Also Send Feedback

The Proxy type exposes the following members.

Properties

 | Name | Description
 | Null | Gets the null Proxy.
Public property | ProxyId | Gets the proxy id.
Public property | ProxyType | Gets or sets the type of the proxy.
Public property | SourceDatabase | Gets or sets the source database. Source database is where real item is located.
Public property | SourceId | Gets or sets the source id. Source item is real item that gets 'virtualized' under another item.
Public property | TargetDatabase | Gets or sets the target database. Target database is where virtual items get inserted.
Public property | TargetId | Gets or sets the target id. Target is the item under which virtual items get inserted.

See Also

Proxy Class
Sitecore.Data.Proxies Namespace


Null Property

[image]

Sitecore 6.4.1 API
Proxy..::..Null Property
Proxy Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Proxy Null { get; }
Visual Basic
Public Shared ReadOnly Property Null As Proxy
    Get
Visual C++
public:
static property Proxy^ Null {
    Proxy^ get ();
}

Field Value

The null.

See Also

Proxy Class
Sitecore.Data.Proxies Namespace


ProxyId Property

[image]

Sitecore 6.4.1 API
Proxy..::..ProxyId Property
Proxy Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ProxyId { get; }
Visual Basic
Public ReadOnly Property ProxyId As ID
    Get
Visual C++
public:
property ID^ ProxyId {
    ID^ get ();
}

Field Value

The proxy id.

See Also

Proxy Class
Sitecore.Data.Proxies Namespace


ProxyType Property

[image]

Sitecore 6.4.1 API
Proxy..::..ProxyType Property
Proxy Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ProxyType ProxyType { get; set; }
Visual Basic
Public Property ProxyType As ProxyType
    Get
    Set
Visual C++
public:
property ProxyType ProxyType {
    ProxyType get ();
    void set (ProxyType value);
}

Field Value

The type of the proxy.

See Also

Proxy Class
Sitecore.Data.Proxies Namespace


SourceDatabase Property

[image]

Sitecore 6.4.1 API
Proxy..::..SourceDatabase Property
Proxy Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database SourceDatabase { get; set; }
Visual Basic
Public Property SourceDatabase As Database
    Get
    Set
Visual C++
public:
property Database^ SourceDatabase {
    Database^ get ();
    void set (Database^ value);
}

Field Value

The source database.

See Also

Proxy Class
Sitecore.Data.Proxies Namespace


SourceId Property

[image]

Sitecore 6.4.1 API
Proxy..::..SourceId Property
Proxy Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID SourceId { get; set; }
Visual Basic
Public Property SourceId As ID
    Get
    Set
Visual C++
public:
property ID^ SourceId {
    ID^ get ();
    void set (ID^ value);
}

Field Value

The source id.

See Also

Proxy Class
Sitecore.Data.Proxies Namespace


TargetDatabase Property

[image]

Sitecore 6.4.1 API
Proxy..::..TargetDatabase Property
Proxy Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database TargetDatabase { get; set; }
Visual Basic
Public Property TargetDatabase As Database
    Get
    Set
Visual C++
public:
property Database^ TargetDatabase {
    Database^ get ();
    void set (Database^ value);
}

Field Value

The target database.

See Also

Proxy Class
Sitecore.Data.Proxies Namespace


TargetId Property

[image]

Sitecore 6.4.1 API
Proxy..::..TargetId Property
Proxy Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID TargetId { get; set; }
Visual Basic
Public Property TargetId As ID
    Get
    Set
Visual C++
public:
property ID^ TargetId {
    ID^ get ();
    void set (ID^ value);
}

Field Value

The target id.

See Also

Proxy Class
Sitecore.Data.Proxies Namespace


ProxyCache Class

[image]

Sitecore 6.4.1 API
ProxyCache Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ProxyCache
Visual Basic
Public Class ProxyCache
Visual C++
public ref class ProxyCache

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Proxies..::..ProxyCache

See Also

ProxyCache Members
Sitecore.Data.Proxies Namespace


ProxyCache Members

[image] [image]

Sitecore 6.4.1 API
ProxyCache Members
ProxyCache Class Constructors Methods See Also Send Feedback

The ProxyCache type exposes the following members.

Constructors

 | Name | Description
Public method | ProxyCache | Initializes a new instance of the ProxyCache class.

Methods

 | Name | Description
Public method | AddProxy | Adds a proxy.
Public method | AddProxyTable | Adds the proxy list for the database to the cache.
Public method | AddReferences | Adds a list of references to the cache.
Public method | AddTarget | Adds an item id to cache.
Public method | AddVirtualId | Adds a virtual id to cache.
Public method | Clear | Clears the cache.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProxy | Gets a proxy.
Protected method | GetProxyListKey | Gets the proxy list key.
Public method | GetProxyTable | Gets the cached proxy list for the database.
Public method | GetReferences | Gets a list of references from the cache.
Protected method | GetReferencesKey | Gets a cache key for storing a list of references.
Public method | GetTarget | Gets the item id from the cache.
Protected method | GetTargetCacheKey | Gets a cache key for storing an item id.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVirtualId | Gets a virtual id from cache.
Protected method | GetVirtualIdCacheKey | Gets a cache key for storing a virtual id.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveProxyTable | Removes the proxy list for the database from the cache.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProxyCache Class
Sitecore.Data.Proxies Namespace


ProxyCache Constructor

[image]

Sitecore 6.4.1 API
ProxyCache Constructor
ProxyCache Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ProxyCache(
    ProxyProvider owner
)
Visual Basic
Public Sub New ( _
    owner As ProxyProvider _
)
Visual C++
public:
ProxyCache(
    ProxyProvider^ owner
)

Parameters

owner
Type: Sitecore.Data.Proxies..::..ProxyProvider

[Missing <param name="owner"/> documentation for "M:Sitecore.Data.Proxies.ProxyCache.#ctor(Sitecore.Data.Proxies.ProxyProvider)"]

See Also

ProxyCache Class
Sitecore.Data.Proxies Namespace


ProxyCache Methods

[image] [image]

Sitecore 6.4.1 API
ProxyCache Methods
ProxyCache Class See Also Send Feedback

The ProxyCache type exposes the following members.

Methods

 | Name | Description
Public method | AddProxy | Adds a proxy.
Public method | AddProxyTable | Adds the proxy list for the database to the cache.
Public method | AddReferences | Adds a list of references to the cache.
Public method | AddTarget | Adds an item id to cache.
Public method | AddVirtualId | Adds a virtual id to cache.
Public method | Clear | Clears the cache.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProxy | Gets a proxy.
Protected method | GetProxyListKey | Gets the proxy list key.
Public method | GetProxyTable | Gets the cached proxy list for the database.
Public method | GetReferences | Gets a list of references from the cache.
Protected method | GetReferencesKey | Gets a cache key for storing a list of references.
Public method | GetTarget | Gets the item id from the cache.
Protected method | GetTargetCacheKey | Gets a cache key for storing an item id.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVirtualId | Gets a virtual id from cache.
Protected method | GetVirtualIdCacheKey | Gets a cache key for storing a virtual id.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveProxyTable | Removes the proxy list for the database from the cache.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProxyCache Class
Sitecore.Data.Proxies Namespace


AddProxy Method

[image]

Sitecore 6.4.1 API
ProxyCache..::..AddProxy Method
ProxyCache Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddProxy(
    ID proxyId,
    Database database,
    Proxy proxy
)
Visual Basic
Public Sub AddProxy ( _
    proxyId As ID, _
    database As Database, _
    proxy As Proxy _
)
Visual C++
public:
void AddProxy(
    ID^ proxyId,
    Database^ database,
    Proxy^ proxy
)

Parameters

proxyId
Type: Sitecore.Data..::..ID
The proxy id.
database
Type: Sitecore.Data..::..Database
The database.
proxy
Type: Sitecore.Data.Proxies..::..Proxy
The proxy.

See Also

ProxyCache Class
Sitecore.Data.Proxies Namespace


AddProxyTable Method

[image]

Sitecore 6.4.1 API
ProxyCache..::..AddProxyTable Method
ProxyCache Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void AddProxyTable(
    Database database,
    SafeDictionary<Object, IList<Proxy>> list
)
Visual Basic
Public Overridable Sub AddProxyTable ( _
    database As Database, _
    list As SafeDictionary(Of Object, IList(Of Proxy)) _
)
Visual C++
public:
virtual void AddProxyTable(
    Database^ database,
    SafeDictionary<Object^, IList<Proxy^>^>^ list
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.
list
Type: Sitecore.Collections..::..SafeDictionary <(Of <(<' Object, IList <(Of <(<' Proxy >)>)>>)>)>
The list.

See Also

ProxyCache Class
Sitecore.Data.Proxies Namespace


AddReferences Method

[image]

Sitecore 6.4.1 API
ProxyCache..::..AddReferences Method
ProxyCache Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void AddReferences(
    Item item,
    List<ProxyReference> references
)
Visual Basic
Public Overridable Sub AddReferences ( _
    item As Item, _
    references As List(Of ProxyReference) _
)
Visual C++
public:
virtual void AddReferences(
    Item^ item,
    List<ProxyReference^>^ references
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
references
Type: System.Collections.Generic..::..List <(Of <(<' ProxyReference >)>)>
The references.

See Also

ProxyCache Class
Sitecore.Data.Proxies Namespace


AddTarget Method

[image]

Sitecore 6.4.1 API
ProxyCache..::..AddTarget Method
ProxyCache Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void AddTarget(
    ID virtualId,
    Database database,
    ProxyTarget target
)
Visual Basic
Public Overridable Sub AddTarget ( _
    virtualId As ID, _
    database As Database, _
    target As ProxyTarget _
)
Visual C++
public:
virtual void AddTarget(
    ID^ virtualId,
    Database^ database,
    ProxyTarget^ target
)

Parameters

virtualId
Type: Sitecore.Data..::..ID
The virtual id.
database
Type: Sitecore.Data..::..Database
The database.
target
Type: Sitecore.Data.Proxies..::..ProxyTarget
The item id.

See Also

ProxyCache Class
Sitecore.Data.Proxies Namespace


AddVirtualId Method

[image]

Sitecore 6.4.1 API
ProxyCache..::..AddVirtualId Method
ProxyCache Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void AddVirtualId(
    ID itemId,
    ID proxyId,
    Database proxyDatabase,
    ID virtualId
)
Visual Basic
Public Overridable Sub AddVirtualId ( _
    itemId As ID, _
    proxyId As ID, _
    proxyDatabase As Database, _
    virtualId As ID _
)
Visual C++
public:
virtual void AddVirtualId(
    ID^ itemId,
    ID^ proxyId,
    Database^ proxyDatabase,
    ID^ virtualId
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
proxyId
Type: Sitecore.Data..::..ID
The proxy id.
proxyDatabase
Type: Sitecore.Data..::..Database
The proxy database.
virtualId
Type: Sitecore.Data..::..ID
The virtual id.

See Also

ProxyCache Class
Sitecore.Data.Proxies Namespace


Clear Method

[image]

Sitecore 6.4.1 API
ProxyCache..::..Clear Method
ProxyCache Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ProxyCache Class
Sitecore.Data.Proxies Namespace


GetProxy Method

[image]

Sitecore 6.4.1 API
ProxyCache..::..GetProxy Method
ProxyCache Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Proxy GetProxy(
    ID proxyId,
    Database database
)
Visual Basic
Public Function GetProxy ( _
    proxyId As ID, _
    database As Database _
) As Proxy
Visual C++
public:
Proxy^ GetProxy(
    ID^ proxyId,
    Database^ database
)

Parameters

proxyId
Type: Sitecore.Data..::..ID
The proxy id.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyCache.GetProxy(Sitecore.Data.ID,Sitecore.Data.Database)"]

See Also

ProxyCache Class
Sitecore.Data.Proxies Namespace


GetProxyListKey Method

[image]

Sitecore 6.4.1 API
ProxyCache..::..GetProxyListKey Method
ProxyCache Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string GetProxyListKey(
    Database database
)
Visual Basic
Protected Overridable Function GetProxyListKey ( _
    database As Database _
) As String
Visual C++
protected:
virtual String^ GetProxyListKey(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

Return Value

The proxy list key.

See Also

ProxyCache Class
Sitecore.Data.Proxies Namespace


GetProxyTable Method

[image]

Sitecore 6.4.1 API
ProxyCache..::..GetProxyTable Method
ProxyCache Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual SafeDictionary<Object, IList<Proxy>> GetProxyTable(
    Database database
)
Visual Basic
Public Overridable Function GetProxyTable ( _
    database As Database _
) As SafeDictionary(Of Object, IList(Of Proxy))
Visual C++
public:
virtual SafeDictionary<Object^, IList<Proxy^>^>^ GetProxyTable(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

Return Value

The proxy list.

See Also

ProxyCache Class
Sitecore.Data.Proxies Namespace


GetReferences Method

[image]

Sitecore 6.4.1 API
ProxyCache..::..GetReferences Method
ProxyCache Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual List<ProxyReference> GetReferences(
    Item item
)
Visual Basic
Public Overridable Function GetReferences ( _
    item As Item _
) As List(Of ProxyReference)
Visual C++
public:
virtual List<ProxyReference^>^ GetReferences(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyCache.GetReferences(Sitecore.Data.Items.Item)"]

See Also

ProxyCache Class
Sitecore.Data.Proxies Namespace


GetReferencesKey Method

[image]

Sitecore 6.4.1 API
ProxyCache..::..GetReferencesKey Method
ProxyCache Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string GetReferencesKey(
    Item item
)
Visual Basic
Protected Overridable Function GetReferencesKey ( _
    item As Item _
) As String
Visual C++
protected:
virtual String^ GetReferencesKey(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyCache.GetReferencesKey(Sitecore.Data.Items.Item)"]

See Also

ProxyCache Class
Sitecore.Data.Proxies Namespace


GetTarget Method

[image]

Sitecore 6.4.1 API
ProxyCache..::..GetTarget Method
ProxyCache Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ProxyTarget GetTarget(
    ID virtualId,
    Database database
)
Visual Basic
Public Overridable Function GetTarget ( _
    virtualId As ID, _
    database As Database _
) As ProxyTarget
Visual C++
public:
virtual ProxyTarget^ GetTarget(
    ID^ virtualId,
    Database^ database
)

Parameters

virtualId
Type: Sitecore.Data..::..ID
The virtual id.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyCache.GetTarget(Sitecore.Data.ID,Sitecore.Data.Database)"]

See Also

ProxyCache Class
Sitecore.Data.Proxies Namespace


GetTargetCacheKey Method

[image]

Sitecore 6.4.1 API
ProxyCache..::..GetTargetCacheKey Method
ProxyCache Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string GetTargetCacheKey(
    ID virtualId,
    Database database
)
Visual Basic
Protected Overridable Function GetTargetCacheKey ( _
    virtualId As ID, _
    database As Database _
) As String
Visual C++
protected:
virtual String^ GetTargetCacheKey(
    ID^ virtualId,
    Database^ database
)

Parameters

virtualId
Type: Sitecore.Data..::..ID
The virtual id.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyCache.GetTargetCacheKey(Sitecore.Data.ID,Sitecore.Data.Database)"]

See Also

ProxyCache Class
Sitecore.Data.Proxies Namespace


GetVirtualId Method

[image]

Sitecore 6.4.1 API
ProxyCache..::..GetVirtualId Method
ProxyCache Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ID GetVirtualId(
    ID itemId,
    ID proxyId,
    Database proxyDatabase
)
Visual Basic
Public Overridable Function GetVirtualId ( _
    itemId As ID, _
    proxyId As ID, _
    proxyDatabase As Database _
) As ID
Visual C++
public:
virtual ID^ GetVirtualId(
    ID^ itemId,
    ID^ proxyId,
    Database^ proxyDatabase
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
proxyId
Type: Sitecore.Data..::..ID
The proxy id.
proxyDatabase
Type: Sitecore.Data..::..Database
The proxy database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyCache.GetVirtualId(Sitecore.Data.ID,Sitecore.Data.ID,Sitecore.Data.Database)"]

See Also

ProxyCache Class
Sitecore.Data.Proxies Namespace


GetVirtualIdCacheKey Method

[image]

Sitecore 6.4.1 API
ProxyCache..::..GetVirtualIdCacheKey Method
ProxyCache Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string GetVirtualIdCacheKey(
    ID itemId,
    ID proxyId,
    Database proxyDatabase
)
Visual Basic
Protected Overridable Function GetVirtualIdCacheKey ( _
    itemId As ID, _
    proxyId As ID, _
    proxyDatabase As Database _
) As String
Visual C++
protected:
virtual String^ GetVirtualIdCacheKey(
    ID^ itemId,
    ID^ proxyId,
    Database^ proxyDatabase
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
proxyId
Type: Sitecore.Data..::..ID
The proxy id.
proxyDatabase
Type: Sitecore.Data..::..Database
The proxy database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyCache.GetVirtualIdCacheKey(Sitecore.Data.ID,Sitecore.Data.ID,Sitecore.Data.Database)"]

See Also

ProxyCache Class
Sitecore.Data.Proxies Namespace


RemoveProxyTable Method

[image]

Sitecore 6.4.1 API
ProxyCache..::..RemoveProxyTable Method
ProxyCache Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void RemoveProxyTable(
    Database database
)
Visual Basic
Public Overridable Sub RemoveProxyTable ( _
    database As Database _
)
Visual C++
public:
virtual void RemoveProxyTable(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

See Also

ProxyCache Class
Sitecore.Data.Proxies Namespace


ProxyDataProvider Class

[image]

Sitecore 6.4.1 API
ProxyDataProvider Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class ProxyDataProvider
Visual Basic
Public MustInherit Class ProxyDataProvider
Visual C++
public ref class ProxyDataProvider abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Proxies..::..ProxyDataProvider
Sitecore.Data.Proxies..::..SqlProxyDataProvider

See Also

ProxyDataProvider Members
Sitecore.Data.Proxies Namespace


ProxyDataProvider Members

[image] [image]

Sitecore 6.4.1 API
ProxyDataProvider Members
ProxyDataProvider Class Constructors Methods Properties See Also Send Feedback

The ProxyDataProvider type exposes the following members.

Constructors

 | Name | Description
Protected method | ProxyDataProvider | Initializes a new instance of the ProxyDataProvider class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetReferences | Gets all references to a specific item.
Public method | GetTarget | Gets the id of the item pointed to by a virtual id.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVirtualId | Gets the id of a shadow pointing to a specific item id within a specific proxy.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveData | Removes all data associated with a specific proxy.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | Gets or sets the name.

See Also

ProxyDataProvider Class
Sitecore.Data.Proxies Namespace


ProxyDataProvider Constructor

[image]

Sitecore 6.4.1 API
ProxyDataProvider Constructor
ProxyDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected ProxyDataProvider()
Visual Basic
Protected Sub New
Visual C++
protected:
ProxyDataProvider()

See Also

ProxyDataProvider Class
Sitecore.Data.Proxies Namespace


ProxyDataProvider Methods

[image] [image]

Sitecore 6.4.1 API
ProxyDataProvider Methods
ProxyDataProvider Class See Also Send Feedback

The ProxyDataProvider type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetReferences | Gets all references to a specific item.
Public method | GetTarget | Gets the id of the item pointed to by a virtual id.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVirtualId | Gets the id of a shadow pointing to a specific item id within a specific proxy.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveData | Removes all data associated with a specific proxy.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProxyDataProvider Class
Sitecore.Data.Proxies Namespace


GetReferences Method

[image]

Sitecore 6.4.1 API
ProxyDataProvider..::..GetReferences Method
ProxyDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract List<ProxyDataRecord> GetReferences(
    ID itemId
)
Visual Basic
Public MustOverride Function GetReferences ( _
    itemId As ID _
) As List(Of ProxyDataRecord)
Visual C++
public:
virtual List<ProxyDataRecord^>^ GetReferences(
    ID^ itemId
) abstract

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyDataProvider.GetReferences(Sitecore.Data.ID)"]

See Also

ProxyDataProvider Class
Sitecore.Data.Proxies Namespace


GetTarget Method

[image]

Sitecore 6.4.1 API
ProxyDataProvider..::..GetTarget Method
ProxyDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract ProxyTarget GetTarget(
    ID virtualId
)
Visual Basic
Public MustOverride Function GetTarget ( _
    virtualId As ID _
) As ProxyTarget
Visual C++
public:
virtual ProxyTarget^ GetTarget(
    ID^ virtualId
) abstract

Parameters

virtualId
Type: Sitecore.Data..::..ID
The virtual id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyDataProvider.GetTarget(Sitecore.Data.ID)"]

See Also

ProxyDataProvider Class
Sitecore.Data.Proxies Namespace


GetVirtualId Method

[image]

Sitecore 6.4.1 API
ProxyDataProvider..::..GetVirtualId Method
ProxyDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract ID GetVirtualId(
    ID itemId,
    ID proxyId,
    bool generateIfNotFound
)
Visual Basic
Public MustOverride Function GetVirtualId ( _
    itemId As ID, _
    proxyId As ID, _
    generateIfNotFound As Boolean _
) As ID
Visual C++
public:
virtual ID^ GetVirtualId(
    ID^ itemId,
    ID^ proxyId,
    bool generateIfNotFound
) abstract

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
proxyId
Type: Sitecore.Data..::..ID
The proxy id.
generateIfNotFound
Type: System..::..Boolean
If set to true a virtual id will be generated if it does not already exist.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyDataProvider.GetVirtualId(Sitecore.Data.ID,Sitecore.Data.ID,System.Boolean)"]

See Also

ProxyDataProvider Class
Sitecore.Data.Proxies Namespace


ProxyDataProvider Properties

[image] [image]

Sitecore 6.4.1 API
ProxyDataProvider Properties
ProxyDataProvider Class See Also Send Feedback

The ProxyDataProvider type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets or sets the name.

See Also

ProxyDataProvider Class
Sitecore.Data.Proxies Namespace


ProxyDataRecord Class

[image]

Sitecore 6.4.1 API
ProxyDataRecord Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ProxyDataRecord
Visual Basic
Public Class ProxyDataRecord
Visual C++
public ref class ProxyDataRecord

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Proxies..::..ProxyDataRecord

See Also

ProxyDataRecord Members
Sitecore.Data.Proxies Namespace


ProxyDataRecord Members

[image] [image]

Sitecore 6.4.1 API
ProxyDataRecord Members
ProxyDataRecord Class Constructors Methods Properties See Also Send Feedback

The ProxyDataRecord type exposes the following members.

Constructors

 | Name | Description
Public method | ProxyDataRecord | Initializes a new instance of the ProxyDataRecord class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ItemId | Gets the item id.
Public property | ProxyId | Gets the proxy id.
Public property | VirtualId | Gets the virtual id.

See Also

ProxyDataRecord Class
Sitecore.Data.Proxies Namespace


ProxyDataRecord Constructor

[image]

Sitecore 6.4.1 API
ProxyDataRecord Constructor
ProxyDataRecord Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ProxyDataRecord(
    ID itemId,
    ID virtualId,
    ID proxyId
)
Visual Basic
Public Sub New ( _
    itemId As ID, _
    virtualId As ID, _
    proxyId As ID _
)
Visual C++
public:
ProxyDataRecord(
    ID^ itemId,
    ID^ virtualId,
    ID^ proxyId
)

Parameters

itemId
Type: Sitecore.Data..::..ID

[Missing <param name="itemId"/> documentation for "M:Sitecore.Data.Proxies.ProxyDataRecord.#ctor(Sitecore.Data.ID,Sitecore.Data.ID,Sitecore.Data.ID)"]

virtualId
Type: Sitecore.Data..::..ID

[Missing <param name="virtualId"/> documentation for "M:Sitecore.Data.Proxies.ProxyDataRecord.#ctor(Sitecore.Data.ID,Sitecore.Data.ID,Sitecore.Data.ID)"]

proxyId
Type: Sitecore.Data..::..ID

[Missing <param name="proxyId"/> documentation for "M:Sitecore.Data.Proxies.ProxyDataRecord.#ctor(Sitecore.Data.ID,Sitecore.Data.ID,Sitecore.Data.ID)"]

See Also

ProxyDataRecord Class
Sitecore.Data.Proxies Namespace


ProxyDataRecord Methods

[image] [image]

Sitecore 6.4.1 API
ProxyDataRecord Methods
ProxyDataRecord Class See Also Send Feedback

The ProxyDataRecord type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProxyDataRecord Class
Sitecore.Data.Proxies Namespace


ProxyDataRecord Properties

[image] [image]

Sitecore 6.4.1 API
ProxyDataRecord Properties
ProxyDataRecord Class See Also Send Feedback

The ProxyDataRecord type exposes the following members.

Properties

 | Name | Description
Public property | ItemId | Gets the item id.
Public property | ProxyId | Gets the proxy id.
Public property | VirtualId | Gets the virtual id.

See Also

ProxyDataRecord Class
Sitecore.Data.Proxies Namespace


ItemId Property

[image]

Sitecore 6.4.1 API
ProxyDataRecord..::..ItemId Property
ProxyDataRecord Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ItemId { get; }
Visual Basic
Public ReadOnly Property ItemId As ID
    Get
Visual C++
public:
property ID^ ItemId {
    ID^ get ();
}

Field Value

The item id.

See Also

ProxyDataRecord Class
Sitecore.Data.Proxies Namespace


ProxyId Property

[image]

Sitecore 6.4.1 API
ProxyDataRecord..::..ProxyId Property
ProxyDataRecord Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ProxyId { get; }
Visual Basic
Public ReadOnly Property ProxyId As ID
    Get
Visual C++
public:
property ID^ ProxyId {
    ID^ get ();
}

Field Value

The proxy id.

See Also

ProxyDataRecord Class
Sitecore.Data.Proxies Namespace


VirtualId Property

[image]

Sitecore 6.4.1 API
ProxyDataRecord..::..VirtualId Property
ProxyDataRecord Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID VirtualId { get; }
Visual Basic
Public ReadOnly Property VirtualId As ID
    Get
Visual C++
public:
property ID^ VirtualId {
    ID^ get ();
}

Field Value

The virtual id.

See Also

ProxyDataRecord Class
Sitecore.Data.Proxies Namespace


ProxyDisabler Class

[image]

Sitecore 6.4.1 API
ProxyDisabler Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ProxyDisabler : IDisposable
Visual Basic
Public Class ProxyDisabler _
    Implements IDisposable
Visual C++
public ref class ProxyDisabler : IDisposable

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Proxies..::..ProxyDisabler

See Also

ProxyDisabler Members
Sitecore.Data.Proxies Namespace


ProxyDisabler Members

[image] [image]

Sitecore 6.4.1 API
ProxyDisabler Members
ProxyDisabler Class Constructors Methods Fields See Also Send Feedback

The ProxyDisabler type exposes the following members.

Constructors

 | Name | Description
Public method | ProxyDisabler()()()() | Initializes a new instance of the ProxyDisabler class.
Public method | ProxyDisabler(Boolean) | Initializes a new instance of the ProxyDisabler class.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsActive | Determines whether this instance is active (ie. proxies are disabled).
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ItemsKey | Key used for storing state in Items

See Also

ProxyDisabler Class
Sitecore.Data.Proxies Namespace


ProxyDisabler Constructor

[image] [image]

Sitecore 6.4.1 API
ProxyDisabler Constructor
ProxyDisabler Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ProxyDisabler()()()() | Initializes a new instance of the ProxyDisabler class.
Public method | ProxyDisabler(Boolean) | Initializes a new instance of the ProxyDisabler class.

See Also

ProxyDisabler Class
ProxyDisabler Members
Sitecore.Data.Proxies Namespace


ProxyDisabler Constructor

[image]

Sitecore 6.4.1 API
ProxyDisabler Constructor
ProxyDisabler Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ProxyDisabler()
Visual Basic
Public Sub New
Visual C++
public:
ProxyDisabler()

See Also

ProxyDisabler Class
ProxyDisabler Overload
Sitecore.Data.Proxies Namespace


ProxyDisabler Constructor (Boolean)

[image]

Sitecore 6.4.1 API
ProxyDisabler Constructor (Boolean)
ProxyDisabler Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ProxyDisabler(
    bool disable
)
Visual Basic
Public Sub New ( _
    disable As Boolean _
)
Visual C++
public:
ProxyDisabler(
    bool disable
)

Parameters

disable
Type: System..::..Boolean
if set to true this instance disables proxies (default behavior). If set to false, this instance enables proxies down the scope.

See Also

ProxyDisabler Class
ProxyDisabler Overload
Sitecore.Data.Proxies Namespace


ProxyDisabler Fields

[image] [image]

Sitecore 6.4.1 API
ProxyDisabler Fields
ProxyDisabler Class See Also Send Feedback

The ProxyDisabler type exposes the following members.

Fields

Name | Description
ItemsKey | Key used for storing state in Items

See Also

ProxyDisabler Class
Sitecore.Data.Proxies Namespace


ItemsKey Field

[image]

Sitecore 6.4.1 API
ProxyDisabler..::..ItemsKey Field
ProxyDisabler Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string ItemsKey
Visual Basic
Public Const ItemsKey As String
Visual C++
public:
literal String^ ItemsKey

See Also

ProxyDisabler Class
Sitecore.Data.Proxies Namespace


ProxyDisabler Methods

[image] [image]

Sitecore 6.4.1 API
ProxyDisabler Methods
ProxyDisabler Class See Also Send Feedback

The ProxyDisabler type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsActive | Determines whether this instance is active (ie. proxies are disabled).
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProxyDisabler Class
Sitecore.Data.Proxies Namespace


Dispose Method

[image]

Sitecore 6.4.1 API
ProxyDisabler..::..Dispose Method
ProxyDisabler Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ProxyDisabler Class
Sitecore.Data.Proxies Namespace


IsActive Method

[image]

Sitecore 6.4.1 API
ProxyDisabler..::..IsActive Method
ProxyDisabler Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsActive()
Visual Basic
Public Shared Function IsActive As Boolean
Visual C++
public:
static bool IsActive()

Return Value

true if this instance is active; otherwise, false.

See Also

ProxyDisabler Class
Sitecore.Data.Proxies Namespace


ProxyManager Class

[image]

Sitecore 6.4.1 API
ProxyManager Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public sealed class ProxyManager
Visual Basic
Public NotInheritable Class ProxyManager
Visual C++
public ref class ProxyManager sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Proxies..::..ProxyManager

See Also

ProxyManager Members
Sitecore.Data.Proxies Namespace


ProxyManager Members

[image] [image]

Sitecore 6.4.1 API
ProxyManager Members
ProxyManager Class Constructors Methods See Also Send Feedback

The ProxyManager type exposes the following members.

Constructors

 | Name | Description
Public method | ProxyManager | Initializes a new instance of the ProxyManager class

Methods

 | Name | Description
 | AreProxiesEnabled | Checks if proxies are enabled for a specific database.
 | CopyVirtualTreeRoot | Copies the virtual item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem | Gets an item.
 | GetParent | Gets the parent of an item.
 | GetRealDatabase | Gets the real database of an item.
 | GetRealId | Gets the real item id of a virtual item.
 | GetRealItem | Gets the real item behind a virtual item.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetVirtualId | Gets the virtual id of an item within a specific proxy context.
 | GetVirtualInstances | Gets all virtual instances of an item.
 | GetVirtualItem | Gets the virtual version of an item within a specific proxy context.
 | HasVirtualItems | Determines whether the specified item has any shadows.
 | Initialize | Initialize type.
 | InsertVirtualChildren | Inserts virtual children (if any) into a native list of children.
 | IsProxy | Determines whether the specified item is a proxy definition.
 | IsVirtual | Determines whether the specified item is virtual.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProxyManager Class
Sitecore.Data.Proxies Namespace


ProxyManager Constructor

[image]

Sitecore 6.4.1 API
ProxyManager Constructor
ProxyManager Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ProxyManager()
Visual Basic
Public Sub New
Visual C++
public:
ProxyManager()

See Also

ProxyManager Class
Sitecore.Data.Proxies Namespace


ProxyManager Methods

[image] [image]

Sitecore 6.4.1 API
ProxyManager Methods
ProxyManager Class See Also Send Feedback

The ProxyManager type exposes the following members.

Methods

 | Name | Description
 | AreProxiesEnabled | Checks if proxies are enabled for a specific database.
 | CopyVirtualTreeRoot | Copies the virtual item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetItem | Gets an item.
 | GetParent | Gets the parent of an item.
 | GetRealDatabase | Gets the real database of an item.
 | GetRealId | Gets the real item id of a virtual item.
 | GetRealItem | Gets the real item behind a virtual item.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetVirtualId | Gets the virtual id of an item within a specific proxy context.
 | GetVirtualInstances | Gets all virtual instances of an item.
 | GetVirtualItem | Gets the virtual version of an item within a specific proxy context.
 | HasVirtualItems | Determines whether the specified item has any shadows.
 | Initialize | Initialize type.
 | InsertVirtualChildren | Inserts virtual children (if any) into a native list of children.
 | IsProxy | Determines whether the specified item is a proxy definition.
 | IsVirtual | Determines whether the specified item is virtual.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProxyManager Class
Sitecore.Data.Proxies Namespace


AreProxiesEnabled Method

[image]

Sitecore 6.4.1 API
ProxyManager..::..AreProxiesEnabled Method
ProxyManager Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool AreProxiesEnabled(
    Database database
)
Visual Basic
Public Shared Function AreProxiesEnabled ( _
    database As Database _
) As Boolean
Visual C++
public:
static bool AreProxiesEnabled(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyManager.AreProxiesEnabled(Sitecore.Data.Database)"]

See Also

ProxyManager Class
Sitecore.Data.Proxies Namespace


CopyVirtualTreeRoot Method

[image]

Sitecore 6.4.1 API
ProxyManager..::..CopyVirtualTreeRoot Method
ProxyManager Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item CopyVirtualTreeRoot(
    Item item,
    Item target
)
Visual Basic
Public Shared Function CopyVirtualTreeRoot ( _
    item As Item, _
    target As Item _
) As Item
Visual C++
public:
static Item^ CopyVirtualTreeRoot(
    Item^ item,
    Item^ target
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
target
Type: Sitecore.Data.Items..::..Item
The target.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyManager.CopyVirtualTreeRoot(Sitecore.Data.Items.Item,Sitecore.Data.Items.Item)"]

See Also

ProxyManager Class
Sitecore.Data.Proxies Namespace


GetItem Method

[image]

Sitecore 6.4.1 API
ProxyManager..::..GetItem Method
ProxyManager Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item GetItem(
    ID itemId,
    Language language,
    Version version,
    Database database
)
Visual Basic
Public Shared Function GetItem ( _
    itemId As ID, _
    language As Language, _
    version As Version, _
    database As Database _
) As Item
Visual C++
public:
static Item^ GetItem(
    ID^ itemId,
    Language^ language,
    Version^ version,
    Database^ database
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
language
Type: Sitecore.Globalization..::..Language
The language.
version
Type: Sitecore.Data..::..Version
The version.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyManager.GetItem(Sitecore.Data.ID,Sitecore.Globalization.Language,Sitecore.Data.Version,Sitecore.Data.Database)"]

See Also

ProxyManager Class
Sitecore.Data.Proxies Namespace


GetParent Method

[image]

Sitecore 6.4.1 API
ProxyManager..::..GetParent Method
ProxyManager Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item GetParent(
    Item item
)
Visual Basic
Public Shared Function GetParent ( _
    item As Item _
) As Item
Visual C++
public:
static Item^ GetParent(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

The parent item.

See Also

ProxyManager Class
Sitecore.Data.Proxies Namespace


GetRealDatabase Method

[image]

Sitecore 6.4.1 API
ProxyManager..::..GetRealDatabase Method
ProxyManager Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Database GetRealDatabase(
    Item item
)
Visual Basic
Public Shared Function GetRealDatabase ( _
    item As Item _
) As Database
Visual C++
public:
static Database^ GetRealDatabase(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyManager.GetRealDatabase(Sitecore.Data.Items.Item)"]

See Also

ProxyManager Class
Sitecore.Data.Proxies Namespace


GetRealId Method

[image]

Sitecore 6.4.1 API
ProxyManager..::..GetRealId Method
ProxyManager Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID GetRealId(
    Item item
)
Visual Basic
Public Shared Function GetRealId ( _
    item As Item _
) As ID
Visual C++
public:
static ID^ GetRealId(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyManager.GetRealId(Sitecore.Data.Items.Item)"]

See Also

ProxyManager Class
Sitecore.Data.Proxies Namespace


GetRealItem Method

[image]

Sitecore 6.4.1 API
ProxyManager..::..GetRealItem Method
ProxyManager Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item GetRealItem(
    Item item,
    bool preserveState
)
Visual Basic
Public Shared Function GetRealItem ( _
    item As Item, _
    preserveState As Boolean _
) As Item
Visual C++
public:
static Item^ GetRealItem(
    Item^ item,
    bool preserveState
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
preserveState
Type: System..::..Boolean
If set to true state is preserved.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyManager.GetRealItem(Sitecore.Data.Items.Item,System.Boolean)"]

See Also

ProxyManager Class
Sitecore.Data.Proxies Namespace


GetVirtualId Method

[image]

Sitecore 6.4.1 API
ProxyManager..::..GetVirtualId Method
ProxyManager Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID GetVirtualId(
    ID itemId,
    ID proxyId,
    Database proxyDatabase,
    bool generateIfNotFound
)
Visual Basic
Public Shared Function GetVirtualId ( _
    itemId As ID, _
    proxyId As ID, _
    proxyDatabase As Database, _
    generateIfNotFound As Boolean _
) As ID
Visual C++
public:
static ID^ GetVirtualId(
    ID^ itemId,
    ID^ proxyId,
    Database^ proxyDatabase,
    bool generateIfNotFound
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The real item id.
proxyId
Type: Sitecore.Data..::..ID
The proxy id.
proxyDatabase
Type: Sitecore.Data..::..Database
The proxy database.
generateIfNotFound
Type: System..::..Boolean
If set to true a virtual id will be generated if it does not already exist.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyManager.GetVirtualId(Sitecore.Data.ID,Sitecore.Data.ID,Sitecore.Data.Database,System.Boolean)"]

See Also

ProxyManager Class
Sitecore.Data.Proxies Namespace


GetVirtualInstances Method

[image]

Sitecore 6.4.1 API
ProxyManager..::..GetVirtualInstances Method
ProxyManager Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ItemList GetVirtualInstances(
    Item item,
    bool preserveState
)
Visual Basic
Public Shared Function GetVirtualInstances ( _
    item As Item, _
    preserveState As Boolean _
) As ItemList
Visual C++
public:
static ItemList^ GetVirtualInstances(
    Item^ item,
    bool preserveState
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
preserveState
Type: System..::..Boolean
If set to true, state is preserved.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyManager.GetVirtualInstances(Sitecore.Data.Items.Item,System.Boolean)"]

See Also

ProxyManager Class
Sitecore.Data.Proxies Namespace


GetVirtualItem Method

[image]

Sitecore 6.4.1 API
ProxyManager..::..GetVirtualItem Method
ProxyManager Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item GetVirtualItem(
    Item item,
    ID proxyId,
    Database database,
    bool preserveState
)
Visual Basic
Public Shared Function GetVirtualItem ( _
    item As Item, _
    proxyId As ID, _
    database As Database, _
    preserveState As Boolean _
) As Item
Visual C++
public:
static Item^ GetVirtualItem(
    Item^ item,
    ID^ proxyId,
    Database^ database,
    bool preserveState
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
proxyId
Type: Sitecore.Data..::..ID
The proxy id.
database
Type: Sitecore.Data..::..Database
The database.
preserveState
Type: System..::..Boolean
If set to true, state is preserved.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyManager.GetVirtualItem(Sitecore.Data.Items.Item,Sitecore.Data.ID,Sitecore.Data.Database,System.Boolean)"]

See Also

ProxyManager Class
Sitecore.Data.Proxies Namespace


HasVirtualItems Method

[image]

Sitecore 6.4.1 API
ProxyManager..::..HasVirtualItems Method
ProxyManager Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool HasVirtualItems(
    Item item
)
Visual Basic
Public Shared Function HasVirtualItems ( _
    item As Item _
) As Boolean
Visual C++
public:
static bool HasVirtualItems(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

true if the specified item has shadows; otherwise, false.

See Also

ProxyManager Class
Sitecore.Data.Proxies Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
ProxyManager..::..Initialize Method
ProxyManager Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Initialize()
Visual Basic
Public Shared Sub Initialize
Visual C++
public:
static void Initialize()

See Also

ProxyManager Class
Sitecore.Data.Proxies Namespace


InsertVirtualChildren Method

[image]

Sitecore 6.4.1 API
ProxyManager..::..InsertVirtualChildren Method
ProxyManager Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void InsertVirtualChildren(
    ItemList children,
    Item parent
)
Visual Basic
Public Shared Sub InsertVirtualChildren ( _
    children As ItemList, _
    parent As Item _
)
Visual C++
public:
static void InsertVirtualChildren(
    ItemList^ children,
    Item^ parent
)

Parameters

children
Type: Sitecore.Collections..::..ItemList
The children.
parent
Type: Sitecore.Data.Items..::..Item
The parent of the children.

See Also

ProxyManager Class
Sitecore.Data.Proxies Namespace


IsProxy Method

[image]

Sitecore 6.4.1 API
ProxyManager..::..IsProxy Method
ProxyManager Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsProxy(
    Item item
)
Visual Basic
Public Shared Function IsProxy ( _
    item As Item _
) As Boolean
Visual C++
public:
static bool IsProxy(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

true if the specified item is proxy; otherwise, false.

See Also

ProxyManager Class
Sitecore.Data.Proxies Namespace


ProxyMapper Class

[image]

Sitecore 6.4.1 API
ProxyMapper Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ProxyMapper
Visual Basic
Public Class ProxyMapper
Visual C++
public ref class ProxyMapper

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Proxies..::..ProxyMapper

See Also

ProxyMapper Members
Sitecore.Data.Proxies Namespace


ProxyMapper Constructor

[image]

Sitecore 6.4.1 API
ProxyMapper Constructor
ProxyMapper Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ProxyMapper(
    ProxyProvider owner
)
Visual Basic
Public Sub New ( _
    owner As ProxyProvider _
)
Visual C++
public:
ProxyMapper(
    ProxyProvider^ owner
)

Parameters

owner
Type: Sitecore.Data.Proxies..::..ProxyProvider

[Missing <param name="owner"/> documentation for "M:Sitecore.Data.Proxies.ProxyMapper.#ctor(Sitecore.Data.Proxies.ProxyProvider)"]

See Also

ProxyMapper Class
Sitecore.Data.Proxies Namespace


ProxyMapper Methods

[image] [image]

Sitecore 6.4.1 API
ProxyMapper Methods
ProxyMapper Class See Also Send Feedback

The ProxyMapper type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRealDatabase | Gets the real database of a virtual item.
Public method | GetRealId | Gets the real id of a virtual item.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVirtual | Determines whether the specified item is virtual.
Public method | MakeReal | Converts a virtual item to the real one.
Public method | MakeVirtual(Item, Proxy) | Makes an item virtual.
Public method | MakeVirtual(Item, ID, Database) | Makes an item virtual.
Public method | MakeVirtual(Item, ID, Database, Boolean) | Makes an item virtual.
Public method | MakeVirtual(Item, ID, ID, Database, Boolean) | Makes an item virtual.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProxyMapper Class
Sitecore.Data.Proxies Namespace


GetRealDatabase Method

[image]

Sitecore 6.4.1 API
ProxyMapper..::..GetRealDatabase Method
ProxyMapper Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database GetRealDatabase(
    Item item
)
Visual Basic
Public Function GetRealDatabase ( _
    item As Item _
) As Database
Visual C++
public:
Database^ GetRealDatabase(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyMapper.GetRealDatabase(Sitecore.Data.Items.Item)"]

See Also

ProxyMapper Class
Sitecore.Data.Proxies Namespace


GetRealId Method

[image]

Sitecore 6.4.1 API
ProxyMapper..::..GetRealId Method
ProxyMapper Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ID GetRealId(
    Item item
)
Visual Basic
Public Overridable Function GetRealId ( _
    item As Item _
) As ID
Visual C++
public:
virtual ID^ GetRealId(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyMapper.GetRealId(Sitecore.Data.Items.Item)"]

See Also

ProxyMapper Class
Sitecore.Data.Proxies Namespace


IsVirtual Method

[image]

Sitecore 6.4.1 API
ProxyMapper..::..IsVirtual Method
ProxyMapper Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool IsVirtual(
    Item item
)
Visual Basic
Public Overridable Function IsVirtual ( _
    item As Item _
) As Boolean
Visual C++
public:
virtual bool IsVirtual(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

true if the specified item is proxy; otherwise, false.

See Also

ProxyMapper Class
Sitecore.Data.Proxies Namespace


MakeReal Method

[image]

Sitecore 6.4.1 API
ProxyMapper..::..MakeReal Method
ProxyMapper Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item MakeReal(
    Item item,
    bool preserveState
)
Visual Basic
Public Function MakeReal ( _
    item As Item, _
    preserveState As Boolean _
) As Item
Visual C++
public:
Item^ MakeReal(
    Item^ item,
    bool preserveState
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
preserveState
Type: System..::..Boolean
if set to true [preserve state].

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyMapper.MakeReal(Sitecore.Data.Items.Item,System.Boolean)"]

See Also

ProxyMapper Class
Sitecore.Data.Proxies Namespace


MakeVirtual Method

[image] [image]

Sitecore 6.4.1 API
ProxyMapper..::..MakeVirtual Method
ProxyMapper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MakeVirtual(Item, Proxy) | Makes an item virtual.
Public method | MakeVirtual(Item, ID, Database) | Makes an item virtual.
Public method | MakeVirtual(Item, ID, Database, Boolean) | Makes an item virtual.
Public method | MakeVirtual(Item, ID, ID, Database, Boolean) | Makes an item virtual.

See Also

ProxyMapper Class
ProxyMapper Members
Sitecore.Data.Proxies Namespace


MakeVirtual Method (Item, ID, Database)

[image]

Sitecore 6.4.1 API
ProxyMapper..::..MakeVirtual Method (Item, ID, Database)
ProxyMapper Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Item MakeVirtual(
    Item item,
    ID proxyId,
    Database database
)
Visual Basic
Public Overridable Function MakeVirtual ( _
    item As Item, _
    proxyId As ID, _
    database As Database _
) As Item
Visual C++
public:
virtual Item^ MakeVirtual(
    Item^ item,
    ID^ proxyId,
    Database^ database
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
proxyId
Type: Sitecore.Data..::..ID
The proxy id.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyMapper.MakeVirtual(Sitecore.Data.Items.Item,Sitecore.Data.ID,Sitecore.Data.Database)"]

See Also

ProxyMapper Class
MakeVirtual Overload
Sitecore.Data.Proxies Namespace


MakeVirtual Method (Item, ID, Database, Boolean)

[image]

Sitecore 6.4.1 API
ProxyMapper..::..MakeVirtual Method (Item, ID, Database, Boolean)
ProxyMapper Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Item MakeVirtual(
    Item item,
    ID proxyId,
    Database database,
    bool preserveState
)
Visual Basic
Public Overridable Function MakeVirtual ( _
    item As Item, _
    proxyId As ID, _
    database As Database, _
    preserveState As Boolean _
) As Item
Visual C++
public:
virtual Item^ MakeVirtual(
    Item^ item,
    ID^ proxyId,
    Database^ database,
    bool preserveState
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
proxyId
Type: Sitecore.Data..::..ID
The proxy id.
database
Type: Sitecore.Data..::..Database
The database.
preserveState
Type: System..::..Boolean
If set to true, state is preserved.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyMapper.MakeVirtual(Sitecore.Data.Items.Item,Sitecore.Data.ID,Sitecore.Data.Database,System.Boolean)"]

See Also

ProxyMapper Class
MakeVirtual Overload
Sitecore.Data.Proxies Namespace


MakeVirtual Method (Item, ID, ID, Database, Boolean)

[image]

Sitecore 6.4.1 API
ProxyMapper..::..MakeVirtual Method (Item, ID, ID, Database, Boolean)
ProxyMapper Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Item MakeVirtual(
    Item item,
    ID virtualId,
    ID proxyId,
    Database database,
    bool preserveState
)
Visual Basic
Public Overridable Function MakeVirtual ( _
    item As Item, _
    virtualId As ID, _
    proxyId As ID, _
    database As Database, _
    preserveState As Boolean _
) As Item
Visual C++
public:
virtual Item^ MakeVirtual(
    Item^ item,
    ID^ virtualId,
    ID^ proxyId,
    Database^ database,
    bool preserveState
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
virtualId
Type: Sitecore.Data..::..ID
The virtual id.
proxyId
Type: Sitecore.Data..::..ID
The proxy id.
database
Type: Sitecore.Data..::..Database
The database.
preserveState
Type: System..::..Boolean
If set to true, state is preserved.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyMapper.MakeVirtual(Sitecore.Data.Items.Item,Sitecore.Data.ID,Sitecore.Data.ID,Sitecore.Data.Database,System.Boolean)"]

See Also

ProxyMapper Class
MakeVirtual Overload
Sitecore.Data.Proxies Namespace


ProxyProvider Class

[image]

Sitecore 6.4.1 API
ProxyProvider Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ProxyProvider
Visual Basic
Public Class ProxyProvider
Visual C++
public ref class ProxyProvider

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Proxies..::..ProxyProvider

See Also

ProxyProvider Members
Sitecore.Data.Proxies Namespace


ProxyProvider Members

[image] [image]

Sitecore 6.4.1 API
ProxyProvider Members
ProxyProvider Class Constructors Methods Fields Properties See Also Send Feedback

The ProxyProvider type exposes the following members.

Constructors

 | Name | Description
Public method | ProxyProvider | Initializes a new instance of the ProxyProvider class.

Methods

 | Name | Description
Public method | AreProxiesEnabled | Checks if proxies are enabled for a specific database.
Public method | ClearCaches | Clears all provider caches.
Public method | CopyVirtualTreeRoot | Copies the virtual tree root.
Protected method | DataEngine_AddedFromTemplate | Handles the AddedFromTemplate event of the DataEngine control.
Protected method | DataEngine_AddedVersion | Handles the AddedVersion event of the DataEngine control.
Protected method | DataEngine_AddedVersionRemote | Handles the AddedVersionRemote event of the DataEngine control.
Protected method | DataEngine_CopiedItem | Handles the CopiedItem event of the DataEngine control.
Protected method | DataEngine_CopiedItemRemote | Handles the CopiedItemRemote event of the DataEngine control.
Protected method | DataEngine_CopyProcessedSingleItem | Handles the CopyProcessedSingleItem event of a DataEngine.
Protected method | DataEngine_CreatedItem | Handles the CreatedItem event of the DataEngine control.
Protected method | DataEngine_DeletedItem | Handles the DeletedItem event of the DataEngine control.
Protected method | DataEngine_MovedItem | Handles the MovedItem event of the DataEngine control.
Protected method | DataEngine_RemovedData | Handles the RemovedData event of the DataEngine control.
Protected method | DataEngine_RemovedVersion | Handles the RemovedVersion event of the DataEngine control.
Protected method | DataEngine_SavedItem | Handles the SavedItem event of the DataEngine control.
Protected method | DataEngine_SavingItem | Handles the SavedItem event of the DataEngine control.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItem | Gets an item.
Public method | GetParent | Gets the parent of an item.
Protected method | GetProxyTargetId | Gets the proxy source id of the proxy having item as its root.
Public method | GetRealDatabase | Gets the real database of an item.
Public method | GetRealId | Gets the real id of a virtual.
Public method | GetRealItem | Gets the real item behind a virtual item.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVirtualId | Gets the virtual id of an item within a specific proxy.
Public method | GetVirtualInstances | Gets all virtual instances of an item.
Public method | GetVirtualItem | Gets the virtual version of an item within a specific proxy context.
Public method | HasVirtualItems | Determines whether the specified item has any virtual items associated with it.
Protected method | InitializeEventHandlers | Initializes the event handlers.
Public method | InsertVirtualChildren | Inserts virtual children (if any) into a list of native children.
Public method | IsProxy | Determines whether the specified item is a proxy definition.
Public method | IsVirtual | Determines whether the specified item is virtual.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PropagateAddedFromTemplate | Propagates the 'added from template' event.
Protected method | PropagateAddedVersion | Propagates the 'added version' event.
Protected method | PropagateCopiedItem | Propagates the 'copied item' event.
Protected method | PropagateCreatedItem | Propagates the 'created item' event.
Protected method | PropagateDeletedItem | Propagates the 'deleted item' event.
Protected method | PropagateDeletedProxy(DeleteItemCommand) | Propagates the deleted proxy.
Protected method | PropagateDeletedProxy(Item) | Propagates the deleted proxy.
Protected method | PropagateMovedItem | Propagates the 'moved item' event.
Protected method | PropagateRemovedVersion | Propagates the 'removed version' event.
Protected method | PropagateSavedItem | Propagates the 'saved item' event.
Protected method | ProxyChanged | Proxies the target changed.
Public method | RemoveProxyData | Removes all data releated to a proxy.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _cache | The cache.
Protected field | _mapper | The mapper.
Protected field | _resolver | The resolver.
Protected field | _state | The state.

Properties

 | Name | Description
Public property | Cache | Gets the cache.
Public property | Mapper | Gets the mapper.
Public property | Resolver | Gets the resolver.
Public property | State | Gets the state.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


ProxyProvider Constructor

[image]

Sitecore 6.4.1 API
ProxyProvider Constructor
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ProxyProvider()
Visual Basic
Public Sub New
Visual C++
public:
ProxyProvider()

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


ProxyProvider Fields

[image] [image]

Sitecore 6.4.1 API
ProxyProvider Fields
ProxyProvider Class See Also Send Feedback

The ProxyProvider type exposes the following members.

Fields

 | Name | Description
Protected field | _cache | The cache.
Protected field | _mapper | The mapper.
Protected field | _resolver | The resolver.
Protected field | _state | The state.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


_mapper Field

[image]

Sitecore 6.4.1 API
ProxyProvider..::.._mapper Field
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected ProxyMapper _mapper
Visual Basic
Protected _mapper As ProxyMapper
Visual C++
protected:
ProxyMapper^ _mapper

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


_resolver Field

[image]

Sitecore 6.4.1 API
ProxyProvider..::.._resolver Field
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected ProxyResolver _resolver
Visual Basic
Protected _resolver As ProxyResolver
Visual C++
protected:
ProxyResolver^ _resolver

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


_state Field

[image]

Sitecore 6.4.1 API
ProxyProvider..::.._state Field
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected ProxyStateMonitor _state
Visual Basic
Protected _state As ProxyStateMonitor
Visual C++
protected:
ProxyStateMonitor^ _state

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


ProxyProvider Methods

[image] [image]

Sitecore 6.4.1 API
ProxyProvider Methods
ProxyProvider Class See Also Send Feedback

The ProxyProvider type exposes the following members.

Methods

 | Name | Description
Public method | AreProxiesEnabled | Checks if proxies are enabled for a specific database.
Public method | ClearCaches | Clears all provider caches.
Public method | CopyVirtualTreeRoot | Copies the virtual tree root.
Protected method | DataEngine_AddedFromTemplate | Handles the AddedFromTemplate event of the DataEngine control.
Protected method | DataEngine_AddedVersion | Handles the AddedVersion event of the DataEngine control.
Protected method | DataEngine_AddedVersionRemote | Handles the AddedVersionRemote event of the DataEngine control.
Protected method | DataEngine_CopiedItem | Handles the CopiedItem event of the DataEngine control.
Protected method | DataEngine_CopiedItemRemote | Handles the CopiedItemRemote event of the DataEngine control.
Protected method | DataEngine_CopyProcessedSingleItem | Handles the CopyProcessedSingleItem event of a DataEngine.
Protected method | DataEngine_CreatedItem | Handles the CreatedItem event of the DataEngine control.
Protected method | DataEngine_DeletedItem | Handles the DeletedItem event of the DataEngine control.
Protected method | DataEngine_MovedItem | Handles the MovedItem event of the DataEngine control.
Protected method | DataEngine_RemovedData | Handles the RemovedData event of the DataEngine control.
Protected method | DataEngine_RemovedVersion | Handles the RemovedVersion event of the DataEngine control.
Protected method | DataEngine_SavedItem | Handles the SavedItem event of the DataEngine control.
Protected method | DataEngine_SavingItem | Handles the SavedItem event of the DataEngine control.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItem | Gets an item.
Public method | GetParent | Gets the parent of an item.
Protected method | GetProxyTargetId | Gets the proxy source id of the proxy having item as its root.
Public method | GetRealDatabase | Gets the real database of an item.
Public method | GetRealId | Gets the real id of a virtual.
Public method | GetRealItem | Gets the real item behind a virtual item.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVirtualId | Gets the virtual id of an item within a specific proxy.
Public method | GetVirtualInstances | Gets all virtual instances of an item.
Public method | GetVirtualItem | Gets the virtual version of an item within a specific proxy context.
Public method | HasVirtualItems | Determines whether the specified item has any virtual items associated with it.
Protected method | InitializeEventHandlers | Initializes the event handlers.
Public method | InsertVirtualChildren | Inserts virtual children (if any) into a list of native children.
Public method | IsProxy | Determines whether the specified item is a proxy definition.
Public method | IsVirtual | Determines whether the specified item is virtual.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PropagateAddedFromTemplate | Propagates the 'added from template' event.
Protected method | PropagateAddedVersion | Propagates the 'added version' event.
Protected method | PropagateCopiedItem | Propagates the 'copied item' event.
Protected method | PropagateCreatedItem | Propagates the 'created item' event.
Protected method | PropagateDeletedItem | Propagates the 'deleted item' event.
Protected method | PropagateDeletedProxy(DeleteItemCommand) | Propagates the deleted proxy.
Protected method | PropagateDeletedProxy(Item) | Propagates the deleted proxy.
Protected method | PropagateMovedItem | Propagates the 'moved item' event.
Protected method | PropagateRemovedVersion | Propagates the 'removed version' event.
Protected method | PropagateSavedItem | Propagates the 'saved item' event.
Protected method | ProxyChanged | Proxies the target changed.
Public method | RemoveProxyData | Removes all data releated to a proxy.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


AreProxiesEnabled Method

[image]

Sitecore 6.4.1 API
ProxyProvider..::..AreProxiesEnabled Method
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool AreProxiesEnabled(
    Database database
)
Visual Basic
Public Overridable Function AreProxiesEnabled ( _
    database As Database _
) As Boolean
Visual C++
public:
virtual bool AreProxiesEnabled(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

Return Value

The are proxies enabled.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


ClearCaches Method

[image]

Sitecore 6.4.1 API
ProxyProvider..::..ClearCaches Method
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void ClearCaches()
Visual Basic
Public Overridable Sub ClearCaches
Visual C++
public:
virtual void ClearCaches()

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


CopyVirtualTreeRoot Method

[image]

Sitecore 6.4.1 API
ProxyProvider..::..CopyVirtualTreeRoot Method
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Item CopyVirtualTreeRoot(
    Item item,
    Item target
)
Visual Basic
Public Overridable Function CopyVirtualTreeRoot ( _
    item As Item, _
    target As Item _
) As Item
Visual C++
public:
virtual Item^ CopyVirtualTreeRoot(
    Item^ item,
    Item^ target
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item root to copy.
target
Type: Sitecore.Data.Items..::..Item
The target.

Return Value

Root node.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


DataEngine_AddedFromTemplate Method

[image]

Sitecore 6.4.1 API
ProxyProvider..::..DataEngine_AddedFromTemplate Method
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void DataEngine_AddedFromTemplate(
    Object sender,
    ExecutedEventArgs<AddFromTemplateCommand> e
)
Visual Basic
Protected Overridable Sub DataEngine_AddedFromTemplate ( _
    sender As Object, _
    e As ExecutedEventArgs(Of AddFromTemplateCommand) _
)
Visual C++
protected:
virtual void DataEngine_AddedFromTemplate(
    Object^ sender,
    ExecutedEventArgs<AddFromTemplateCommand^>^ e
)

Parameters

sender
Type: System..::..Object
The source of the event.
e
Type: Sitecore.Data.Events..::..ExecutedEventArgs <(Of <(<' AddFromTemplateCommand >)>)>
The ExecutedEventArgs<(Of <(<'TCommand>)>)> instance containing the event data.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


DataEngine_AddedVersion Method

[image]

Sitecore 6.4.1 API
ProxyProvider..::..DataEngine_AddedVersion Method
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void DataEngine_AddedVersion(
    Object sender,
    ExecutedEventArgs<AddVersionCommand> e
)
Visual Basic
Protected Overridable Sub DataEngine_AddedVersion ( _
    sender As Object, _
    e As ExecutedEventArgs(Of AddVersionCommand) _
)
Visual C++
protected:
virtual void DataEngine_AddedVersion(
    Object^ sender,
    ExecutedEventArgs<AddVersionCommand^>^ e
)

Parameters

sender
Type: System..::..Object
The source of the event.
e
Type: Sitecore.Data.Events..::..ExecutedEventArgs <(Of <(<' AddVersionCommand >)>)>
The ExecutedEventArgs<(Of <(<'TCommand>)>)> instance containing the event data.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


DataEngine_AddedVersionRemote Method

[image]

Sitecore 6.4.1 API
ProxyProvider..::..DataEngine_AddedVersionRemote Method
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void DataEngine_AddedVersionRemote(
    Object sender,
    AddedVersionRemoteEventArgs e
)
Visual Basic
Protected Sub DataEngine_AddedVersionRemote ( _
    sender As Object, _
    e As AddedVersionRemoteEventArgs _
)
Visual C++
protected:
void DataEngine_AddedVersionRemote(
    Object^ sender,
    AddedVersionRemoteEventArgs^ e
)

Parameters

sender
Type: System..::..Object
The source of the event.
e
Type: Sitecore.Data.Events..::..AddedVersionRemoteEventArgs
The AddedVersionRemoteEventArgs instance containing the event data.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


DataEngine_CopiedItem Method

[image]

Sitecore 6.4.1 API
ProxyProvider..::..DataEngine_CopiedItem Method
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void DataEngine_CopiedItem(
    Object sender,
    ExecutedEventArgs<CopyItemCommand> e
)
Visual Basic
Protected Overridable Sub DataEngine_CopiedItem ( _
    sender As Object, _
    e As ExecutedEventArgs(Of CopyItemCommand) _
)
Visual C++
protected:
virtual void DataEngine_CopiedItem(
    Object^ sender,
    ExecutedEventArgs<CopyItemCommand^>^ e
)

Parameters

sender
Type: System..::..Object
The source of the event.
e
Type: Sitecore.Data.Events..::..ExecutedEventArgs <(Of <(<' CopyItemCommand >)>)>
The ExecutedEventArgs<(Of <(<'TCommand>)>)> instance containing the event data.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


DataEngine_CopiedItemRemote Method

[image]

Sitecore 6.4.1 API
ProxyProvider..::..DataEngine_CopiedItemRemote Method
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void DataEngine_CopiedItemRemote(
    Object sender,
    CopiedItemRemoteEventArgs e
)
Visual Basic
Protected Sub DataEngine_CopiedItemRemote ( _
    sender As Object, _
    e As CopiedItemRemoteEventArgs _
)
Visual C++
protected:
void DataEngine_CopiedItemRemote(
    Object^ sender,
    CopiedItemRemoteEventArgs^ e
)

Parameters

sender
Type: System..::..Object
The source of the event.
e
Type: Sitecore.Data.Events..::..CopiedItemRemoteEventArgs
The CopiedItemRemoteEventArgs instance containing the event data.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


DataEngine_CopyProcessedSingleItem Method

[image]

Sitecore 6.4.1 API
ProxyProvider..::..DataEngine_CopyProcessedSingleItem Method
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void DataEngine_CopyProcessedSingleItem(
    Object sender,
    CopyProcessedSingleItemEventArgs e
)
Visual Basic
Protected Overridable Sub DataEngine_CopyProcessedSingleItem ( _
    sender As Object, _
    e As CopyProcessedSingleItemEventArgs _
)
Visual C++
protected:
virtual void DataEngine_CopyProcessedSingleItem(
    Object^ sender,
    CopyProcessedSingleItemEventArgs^ e
)

Parameters

sender
Type: System..::..Object
The source of the event.
e
Type: Sitecore.Data.Events..::..CopyProcessedSingleItemEventArgs
The CopyProcessedSingleItemEventArgs instance containing the event data.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


DataEngine_CreatedItem Method

[image]

Sitecore 6.4.1 API
ProxyProvider..::..DataEngine_CreatedItem Method
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void DataEngine_CreatedItem(
    Object sender,
    ExecutedEventArgs<CreateItemCommand> e
)
Visual Basic
Protected Overridable Sub DataEngine_CreatedItem ( _
    sender As Object, _
    e As ExecutedEventArgs(Of CreateItemCommand) _
)
Visual C++
protected:
virtual void DataEngine_CreatedItem(
    Object^ sender,
    ExecutedEventArgs<CreateItemCommand^>^ e
)

Parameters

sender
Type: System..::..Object
The source of the event.
e
Type: Sitecore.Data.Events..::..ExecutedEventArgs <(Of <(<' CreateItemCommand >)>)>
The ExecutedEventArgs<(Of <(<'TCommand>)>)> instance containing the event data.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


DataEngine_DeletedItem Method

[image]

Sitecore 6.4.1 API
ProxyProvider..::..DataEngine_DeletedItem Method
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void DataEngine_DeletedItem(
    Object sender,
    ExecutedEventArgs<DeleteItemCommand> e
)
Visual Basic
Protected Overridable Sub DataEngine_DeletedItem ( _
    sender As Object, _
    e As ExecutedEventArgs(Of DeleteItemCommand) _
)
Visual C++
protected:
virtual void DataEngine_DeletedItem(
    Object^ sender,
    ExecutedEventArgs<DeleteItemCommand^>^ e
)

Parameters

sender
Type: System..::..Object
The source of the event.
e
Type: Sitecore.Data.Events..::..ExecutedEventArgs <(Of <(<' DeleteItemCommand >)>)>
The ExecutedEventArgs<(Of <(<'TCommand>)>)> instance containing the event data.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


DataEngine_MovedItem Method

[image]

Sitecore 6.4.1 API
ProxyProvider..::..DataEngine_MovedItem Method
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void DataEngine_MovedItem(
    Object sender,
    ExecutedEventArgs<MoveItemCommand> e
)
Visual Basic
Protected Overridable Sub DataEngine_MovedItem ( _
    sender As Object, _
    e As ExecutedEventArgs(Of MoveItemCommand) _
)
Visual C++
protected:
virtual void DataEngine_MovedItem(
    Object^ sender,
    ExecutedEventArgs<MoveItemCommand^>^ e
)

Parameters

sender
Type: System..::..Object
The source of the event.
e
Type: Sitecore.Data.Events..::..ExecutedEventArgs <(Of <(<' MoveItemCommand >)>)>
The ExecutedEventArgs<(Of <(<'TCommand>)>)> instance containing the event data.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


DataEngine_RemovedData Method

[image]

Sitecore 6.4.1 API
ProxyProvider..::..DataEngine_RemovedData Method
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void DataEngine_RemovedData(
    Object sender,
    ExecutedEventArgs<RemoveDataCommand> e
)
Visual Basic
Protected Overridable Sub DataEngine_RemovedData ( _
    sender As Object, _
    e As ExecutedEventArgs(Of RemoveDataCommand) _
)
Visual C++
protected:
virtual void DataEngine_RemovedData(
    Object^ sender,
    ExecutedEventArgs<RemoveDataCommand^>^ e
)

Parameters

sender
Type: System..::..Object
The source of the event.
e
Type: Sitecore.Data.Events..::..ExecutedEventArgs <(Of <(<' RemoveDataCommand >)>)>
The ExecutedEventArgs<(Of <(<'TCommand>)>)> instance containing the event data.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


DataEngine_RemovedVersion Method

[image]

Sitecore 6.4.1 API
ProxyProvider..::..DataEngine_RemovedVersion Method
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void DataEngine_RemovedVersion(
    Object sender,
    ExecutedEventArgs<RemoveVersionCommand> e
)
Visual Basic
Protected Overridable Sub DataEngine_RemovedVersion ( _
    sender As Object, _
    e As ExecutedEventArgs(Of RemoveVersionCommand) _
)
Visual C++
protected:
virtual void DataEngine_RemovedVersion(
    Object^ sender,
    ExecutedEventArgs<RemoveVersionCommand^>^ e
)

Parameters

sender
Type: System..::..Object
The source of the event.
e
Type: Sitecore.Data.Events..::..ExecutedEventArgs <(Of <(<' RemoveVersionCommand >)>)>
The ExecutedEventArgs<(Of <(<'TCommand>)>)> instance containing the event data.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


DataEngine_SavedItem Method

[image]

Sitecore 6.4.1 API
ProxyProvider..::..DataEngine_SavedItem Method
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void DataEngine_SavedItem(
    Object sender,
    ExecutedEventArgs<SaveItemCommand> e
)
Visual Basic
Protected Overridable Sub DataEngine_SavedItem ( _
    sender As Object, _
    e As ExecutedEventArgs(Of SaveItemCommand) _
)
Visual C++
protected:
virtual void DataEngine_SavedItem(
    Object^ sender,
    ExecutedEventArgs<SaveItemCommand^>^ e
)

Parameters

sender
Type: System..::..Object
The source of the event.
e
Type: Sitecore.Data.Events..::..ExecutedEventArgs <(Of <(<' SaveItemCommand >)>)>
The SaveItemCommand instance containing the event data.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


DataEngine_SavingItem Method

[image]

Sitecore 6.4.1 API
ProxyProvider..::..DataEngine_SavingItem Method
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void DataEngine_SavingItem(
    Object sender,
    ExecutingEventArgs<SaveItemCommand> e
)
Visual Basic
Protected Overridable Sub DataEngine_SavingItem ( _
    sender As Object, _
    e As ExecutingEventArgs(Of SaveItemCommand) _
)
Visual C++
protected:
virtual void DataEngine_SavingItem(
    Object^ sender,
    ExecutingEventArgs<SaveItemCommand^>^ e
)

Parameters

sender
Type: System..::..Object
The source of the event.
e
Type: Sitecore.Data.Events..::..ExecutingEventArgs <(Of <(<' SaveItemCommand >)>)>
The instance containing the event data.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


GetItem Method

[image]

Sitecore 6.4.1 API
ProxyProvider..::..GetItem Method
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Item GetItem(
    ID virtualId,
    Language language,
    Version version,
    Database database
)
Visual Basic
Public Overridable Function GetItem ( _
    virtualId As ID, _
    language As Language, _
    version As Version, _
    database As Database _
) As Item
Visual C++
public:
virtual Item^ GetItem(
    ID^ virtualId,
    Language^ language,
    Version^ version,
    Database^ database
)

Parameters

virtualId
Type: Sitecore.Data..::..ID
The virtual item id.
language
Type: Sitecore.Globalization..::..Language
The language.
version
Type: Sitecore.Data..::..Version
The version.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

The real item

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


GetParent Method

[image]

Sitecore 6.4.1 API
ProxyProvider..::..GetParent Method
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Item GetParent(
    Item item
)
Visual Basic
Public Overridable Function GetParent ( _
    item As Item _
) As Item
Visual C++
public:
virtual Item^ GetParent(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item to get parent for.

Return Value

The parent item.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


GetProxyTargetId Method

[image]

Sitecore 6.4.1 API
ProxyProvider..::..GetProxyTargetId Method
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual ID GetProxyTargetId(
    Item item
)
Visual Basic
Protected Overridable Function GetProxyTargetId ( _
    item As Item _
) As ID
Visual C++
protected:
virtual ID^ GetProxyTargetId(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The proxy item.

Return Value

The proxy target ID

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


GetRealDatabase Method

[image]

Sitecore 6.4.1 API
ProxyProvider..::..GetRealDatabase Method
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Database GetRealDatabase(
    Item item
)
Visual Basic
Public Overridable Function GetRealDatabase ( _
    item As Item _
) As Database
Visual C++
public:
virtual Database^ GetRealDatabase(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item to get real database for.

Return Value

The database.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


GetRealId Method

[image]

Sitecore 6.4.1 API
ProxyProvider..::..GetRealId Method
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ID GetRealId(
    Item item
)
Visual Basic
Public Overridable Function GetRealId ( _
    item As Item _
) As ID
Visual C++
public:
virtual ID^ GetRealId(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item to get ID.

Return Value

ID of real item.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


GetVirtualId Method

[image]

Sitecore 6.4.1 API
ProxyProvider..::..GetVirtualId Method
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ID GetVirtualId(
    ID itemId,
    ID proxyId,
    Database database,
    bool generateIfNotFound
)
Visual Basic
Public Overridable Function GetVirtualId ( _
    itemId As ID, _
    proxyId As ID, _
    database As Database, _
    generateIfNotFound As Boolean _
) As ID
Visual C++
public:
virtual ID^ GetVirtualId(
    ID^ itemId,
    ID^ proxyId,
    Database^ database,
    bool generateIfNotFound
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The real item id.
proxyId
Type: Sitecore.Data..::..ID
The proxy id.
database
Type: Sitecore.Data..::..Database
The database.
generateIfNotFound
Type: System..::..Boolean
If set to true a virtual id will be generated if it does not already exist.

Return Value

ID of virtual item.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


GetVirtualInstances Method

[image]

Sitecore 6.4.1 API
ProxyProvider..::..GetVirtualInstances Method
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ItemList GetVirtualInstances(
    Item item,
    bool preserveState
)
Visual Basic
Public Overridable Function GetVirtualInstances ( _
    item As Item, _
    preserveState As Boolean _
) As ItemList
Visual C++
public:
virtual ItemList^ GetVirtualInstances(
    Item^ item,
    bool preserveState
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item to search.
preserveState
Type: System..::..Boolean
If set to true, state is preserved.

Return Value

Virtual instances of an item.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


GetVirtualItem Method

[image]

Sitecore 6.4.1 API
ProxyProvider..::..GetVirtualItem Method
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Item GetVirtualItem(
    Item item,
    ID proxyId,
    Database database,
    bool preserveState
)
Visual Basic
Public Overridable Function GetVirtualItem ( _
    item As Item, _
    proxyId As ID, _
    database As Database, _
    preserveState As Boolean _
) As Item
Visual C++
public:
virtual Item^ GetVirtualItem(
    Item^ item,
    ID^ proxyId,
    Database^ database,
    bool preserveState
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The real item.
proxyId
Type: Sitecore.Data..::..ID
The proxy id.
database
Type: Sitecore.Data..::..Database
The database.
preserveState
Type: System..::..Boolean
If set to true, state is preserved.

Return Value

Virtual Item.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


HasVirtualItems Method

[image]

Sitecore 6.4.1 API
ProxyProvider..::..HasVirtualItems Method
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool HasVirtualItems(
    Item item
)
Visual Basic
Public Overridable Function HasVirtualItems ( _
    item As Item _
) As Boolean
Visual C++
public:
virtual bool HasVirtualItems(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item to check.

Return Value

true if the specified item has virtual items; otherwise, false.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


InitializeEventHandlers Method

[image]

Sitecore 6.4.1 API
ProxyProvider..::..InitializeEventHandlers Method
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void InitializeEventHandlers()
Visual Basic
Protected Sub InitializeEventHandlers
Visual C++
protected:
void InitializeEventHandlers()

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


InsertVirtualChildren Method

[image]

Sitecore 6.4.1 API
ProxyProvider..::..InsertVirtualChildren Method
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void InsertVirtualChildren(
    ItemList children,
    Item parent
)
Visual Basic
Public Overridable Sub InsertVirtualChildren ( _
    children As ItemList, _
    parent As Item _
)
Visual C++
public:
virtual void InsertVirtualChildren(
    ItemList^ children,
    Item^ parent
)

Parameters

children
Type: Sitecore.Collections..::..ItemList
The children.
parent
Type: Sitecore.Data.Items..::..Item
The parent of the children.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


IsProxy Method

[image]

Sitecore 6.4.1 API
ProxyProvider..::..IsProxy Method
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool IsProxy(
    Item item
)
Visual Basic
Public Overridable Function IsProxy ( _
    item As Item _
) As Boolean
Visual C++
public:
virtual bool IsProxy(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item to check.

Return Value

true if the specified item is proxy; otherwise, false.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


PropagateAddedFromTemplate Method

[image]

Sitecore 6.4.1 API
ProxyProvider..::..PropagateAddedFromTemplate Method
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void PropagateAddedFromTemplate(
    AddFromTemplateCommand command
)
Visual Basic
Protected Overridable Sub PropagateAddedFromTemplate ( _
    command As AddFromTemplateCommand _
)
Visual C++
protected:
virtual void PropagateAddedFromTemplate(
    AddFromTemplateCommand^ command
)

Parameters

command
Type: Sitecore.Data.Engines.DataCommands..::..AddFromTemplateCommand
The command.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


PropagateAddedVersion Method

[image]

Sitecore 6.4.1 API
ProxyProvider..::..PropagateAddedVersion Method
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void PropagateAddedVersion(
    AddVersionCommand command
)
Visual Basic
Protected Overridable Sub PropagateAddedVersion ( _
    command As AddVersionCommand _
)
Visual C++
protected:
virtual void PropagateAddedVersion(
    AddVersionCommand^ command
)

Parameters

command
Type: Sitecore.Data.Engines.DataCommands..::..AddVersionCommand
The command.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


PropagateCopiedItem Method

[image]

Sitecore 6.4.1 API
ProxyProvider..::..PropagateCopiedItem Method
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void PropagateCopiedItem(
    CopyItemCommand command
)
Visual Basic
Protected Overridable Sub PropagateCopiedItem ( _
    command As CopyItemCommand _
)
Visual C++
protected:
virtual void PropagateCopiedItem(
    CopyItemCommand^ command
)

Parameters

command
Type: Sitecore.Data.Engines.DataCommands..::..CopyItemCommand
The command.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


PropagateCreatedItem Method

[image]

Sitecore 6.4.1 API
ProxyProvider..::..PropagateCreatedItem Method
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void PropagateCreatedItem(
    CreateItemCommand command
)
Visual Basic
Protected Overridable Sub PropagateCreatedItem ( _
    command As CreateItemCommand _
)
Visual C++
protected:
virtual void PropagateCreatedItem(
    CreateItemCommand^ command
)

Parameters

command
Type: Sitecore.Data.Engines.DataCommands..::..CreateItemCommand
The command.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


PropagateDeletedItem Method

[image]

Sitecore 6.4.1 API
ProxyProvider..::..PropagateDeletedItem Method
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void PropagateDeletedItem(
    DeleteItemCommand command
)
Visual Basic
Protected Overridable Sub PropagateDeletedItem ( _
    command As DeleteItemCommand _
)
Visual C++
protected:
virtual void PropagateDeletedItem(
    DeleteItemCommand^ command
)

Parameters

command
Type: Sitecore.Data.Engines.DataCommands..::..DeleteItemCommand
The command.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


PropagateDeletedProxy Method

[image] [image]

Sitecore 6.4.1 API
ProxyProvider..::..PropagateDeletedProxy Method
ProxyProvider Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | PropagateDeletedProxy(DeleteItemCommand) | Propagates the deleted proxy.
Protected method | PropagateDeletedProxy(Item) | Propagates the deleted proxy.

See Also

ProxyProvider Class
ProxyProvider Members
Sitecore.Data.Proxies Namespace


PropagateDeletedProxy Method (DeleteItemCommand)

[image]

Sitecore 6.4.1 API
ProxyProvider..::..PropagateDeletedProxy Method (DeleteItemCommand)
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void PropagateDeletedProxy(
    DeleteItemCommand command
)
Visual Basic
Protected Overridable Sub PropagateDeletedProxy ( _
    command As DeleteItemCommand _
)
Visual C++
protected:
virtual void PropagateDeletedProxy(
    DeleteItemCommand^ command
)

Parameters

command
Type: Sitecore.Data.Engines.DataCommands..::..DeleteItemCommand
The command.

See Also

ProxyProvider Class
PropagateDeletedProxy Overload
Sitecore.Data.Proxies Namespace


PropagateDeletedProxy Method (Item)

[image]

Sitecore 6.4.1 API
ProxyProvider..::..PropagateDeletedProxy Method (Item)
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void PropagateDeletedProxy(
    Item item
)
Visual Basic
Protected Overridable Sub PropagateDeletedProxy ( _
    item As Item _
)
Visual C++
protected:
virtual void PropagateDeletedProxy(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item to propagate.

See Also

ProxyProvider Class
PropagateDeletedProxy Overload
Sitecore.Data.Proxies Namespace


PropagateMovedItem Method

[image]

Sitecore 6.4.1 API
ProxyProvider..::..PropagateMovedItem Method
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void PropagateMovedItem(
    MoveItemCommand command
)
Visual Basic
Protected Overridable Sub PropagateMovedItem ( _
    command As MoveItemCommand _
)
Visual C++
protected:
virtual void PropagateMovedItem(
    MoveItemCommand^ command
)

Parameters

command
Type: Sitecore.Data.Engines.DataCommands..::..MoveItemCommand
The command.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


PropagateRemovedVersion Method

[image]

Sitecore 6.4.1 API
ProxyProvider..::..PropagateRemovedVersion Method
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void PropagateRemovedVersion(
    RemoveVersionCommand command
)
Visual Basic
Protected Overridable Sub PropagateRemovedVersion ( _
    command As RemoveVersionCommand _
)
Visual C++
protected:
virtual void PropagateRemovedVersion(
    RemoveVersionCommand^ command
)

Parameters

command
Type: Sitecore.Data.Engines.DataCommands..::..RemoveVersionCommand
The command.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


PropagateSavedItem Method

[image]

Sitecore 6.4.1 API
ProxyProvider..::..PropagateSavedItem Method
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void PropagateSavedItem(
    SaveItemCommand command
)
Visual Basic
Protected Overridable Sub PropagateSavedItem ( _
    command As SaveItemCommand _
)
Visual C++
protected:
virtual void PropagateSavedItem(
    SaveItemCommand^ command
)

Parameters

command
Type: Sitecore.Data.Engines.DataCommands..::..SaveItemCommand
The command.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


ProxyChanged Method

[image]

Sitecore 6.4.1 API
ProxyProvider..::..ProxyChanged Method
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool ProxyChanged(
    Item item
)
Visual Basic
Protected Overridable Function ProxyChanged ( _
    item As Item _
) As Boolean
Visual C++
protected:
virtual bool ProxyChanged(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item to check.

Return Value

The target changed.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


RemoveProxyData Method

[image]

Sitecore 6.4.1 API
ProxyProvider..::..RemoveProxyData Method
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void RemoveProxyData(
    ID proxyId,
    Database database
)
Visual Basic
Public Overridable Sub RemoveProxyData ( _
    proxyId As ID, _
    database As Database _
)
Visual C++
public:
virtual void RemoveProxyData(
    ID^ proxyId,
    Database^ database
)

Parameters

proxyId
Type: Sitecore.Data..::..ID
The proxy id.
database
Type: Sitecore.Data..::..Database
The database.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


ProxyProvider Properties

[image] [image]

Sitecore 6.4.1 API
ProxyProvider Properties
ProxyProvider Class See Also Send Feedback

The ProxyProvider type exposes the following members.

Properties

 | Name | Description
Public property | Cache | Gets the cache.
Public property | Mapper | Gets the mapper.
Public property | Resolver | Gets the resolver.
Public property | State | Gets the state.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


Cache Property

[image]

Sitecore 6.4.1 API
ProxyProvider..::..Cache Property
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ProxyCache Cache { get; }
Visual Basic
Public Overridable ReadOnly Property Cache As ProxyCache
    Get
Visual C++
public:
virtual property ProxyCache^ Cache {
    ProxyCache^ get ();
}

Field Value

The cache.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


Mapper Property

[image]

Sitecore 6.4.1 API
ProxyProvider..::..Mapper Property
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ProxyMapper Mapper { get; }
Visual Basic
Public Overridable ReadOnly Property Mapper As ProxyMapper
    Get
Visual C++
public:
virtual property ProxyMapper^ Mapper {
    ProxyMapper^ get ();
}

Field Value

The mapper.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


Resolver Property

[image]

Sitecore 6.4.1 API
ProxyProvider..::..Resolver Property
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ProxyResolver Resolver { get; }
Visual Basic
Public Overridable ReadOnly Property Resolver As ProxyResolver
    Get
Visual C++
public:
virtual property ProxyResolver^ Resolver {
    ProxyResolver^ get ();
}

Field Value

The resolver.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


State Property

[image]

Sitecore 6.4.1 API
ProxyProvider..::..State Property
ProxyProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ProxyStateMonitor State { get; }
Visual Basic
Public Overridable ReadOnly Property State As ProxyStateMonitor
    Get
Visual C++
public:
virtual property ProxyStateMonitor^ State {
    ProxyStateMonitor^ get ();
}

Field Value

The state.

See Also

ProxyProvider Class
Sitecore.Data.Proxies Namespace


ProxyReference Members

[image] [image]

Sitecore 6.4.1 API
ProxyReference Members
ProxyReference Class Constructors Methods Properties See Also Send Feedback

The ProxyReference type exposes the following members.

Constructors

 | Name | Description
Public method | ProxyReference | Initializes a new instance of the ProxyReference class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Database | Gets the database.
Public property | ProxyId | Gets the proxy id.
Public property | VirtualId | Gets the virtual item id.

See Also

ProxyReference Class
Sitecore.Data.Proxies Namespace


ProxyReference Constructor

[image]

Sitecore 6.4.1 API
ProxyReference Constructor
ProxyReference Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ProxyReference(
    ID virtualId,
    ID proxyId,
    Database database
)
Visual Basic
Public Sub New ( _
    virtualId As ID, _
    proxyId As ID, _
    database As Database _
)
Visual C++
public:
ProxyReference(
    ID^ virtualId,
    ID^ proxyId,
    Database^ database
)

Parameters

virtualId
Type: Sitecore.Data..::..ID
The virtual id.
proxyId
Type: Sitecore.Data..::..ID
The proxy id.
database
Type: Sitecore.Data..::..Database
The database.

See Also

ProxyReference Class
Sitecore.Data.Proxies Namespace


ProxyReference Methods

[image] [image]

Sitecore 6.4.1 API
ProxyReference Methods
ProxyReference Class See Also Send Feedback

The ProxyReference type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProxyReference Class
Sitecore.Data.Proxies Namespace


Database Property

[image]

Sitecore 6.4.1 API
ProxyReference..::..Database Property
ProxyReference Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database Database { get; }
Visual Basic
Public ReadOnly Property Database As Database
    Get
Visual C++
public:
property Database^ Database {
    Database^ get ();
}

Field Value

The database.

See Also

ProxyReference Class
Sitecore.Data.Proxies Namespace


ProxyId Property

[image]

Sitecore 6.4.1 API
ProxyReference..::..ProxyId Property
ProxyReference Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ProxyId { get; }
Visual Basic
Public ReadOnly Property ProxyId As ID
    Get
Visual C++
public:
property ID^ ProxyId {
    ID^ get ();
}

Field Value

The proxy id.

See Also

ProxyReference Class
Sitecore.Data.Proxies Namespace


VirtualId Property

[image]

Sitecore 6.4.1 API
ProxyReference..::..VirtualId Property
ProxyReference Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID VirtualId { get; }
Visual Basic
Public ReadOnly Property VirtualId As ID
    Get
Visual C++
public:
property ID^ VirtualId {
    ID^ get ();
}

Field Value

The virtual item id.

See Also

ProxyReference Class
Sitecore.Data.Proxies Namespace


ProxyResolver Class

[image]

Sitecore 6.4.1 API
ProxyResolver Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ProxyResolver
Visual Basic
Public Class ProxyResolver
Visual C++
public ref class ProxyResolver

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Proxies..::..ProxyResolver

See Also

ProxyResolver Members
Sitecore.Data.Proxies Namespace


ProxyResolver Members

[image] [image]

Sitecore 6.4.1 API
ProxyResolver Members
ProxyResolver Class Constructors Methods Properties See Also Send Feedback

The ProxyResolver type exposes the following members.

Constructors

 | Name | Description
Public method | ProxyResolver | Initializes a new instance of the ProxyResolver class.

Methods

 | Name | Description
Protected method | AddProxyDefinition | Adds the proxy definition.
Public method | CopyVirtualTreeRoot | Copies the virtual item.
Public method | DuplicateProxyDefinitions | Duplicates the proxy definitions.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetDataProvider | Gets the data provider for a specific database.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParent | Gets the parent of a virtual item.
Protected method | GetProxies | Gets all proxies in a database.
Protected method | GetProxiesUnder | Gets all proxies linked to a specific item.
Public method | GetProxy(Item) | Gets the proxy for a virtual item.
Public method | GetProxy(ID, Database) | Gets the proxy with a specific id.
Protected method | GetProxyChildren | Gets all proxy targets for a specific item.
Protected method | GetProxyCore | Gets the proxy core.
Protected method | GetProxyDefinitionName | Gets the name of the proxy definition.
Public method | GetProxyId | Gets the proxy id for a virtual item.
Public method | GetProxyItem | Gets a proxy item.
Protected method | GetReferenceInstances | Gets the instances pointed to by a list of references.
Public method | GetReferences | Gets the references to an item.
Protected method | GetReferencesFromDataProvider | Gets the references to an item from the data providers.
Public method | GetTarget | Gets the target description for a virtual item.
Protected method | GetTargetCore | Gets the target.
Protected method | GetTargetFromDataProvider | Gets the item id from the data provider.
Public method | GetTargetItem | Gets the target item of a virtual id.
Protected method | GetTrueVirtualChildren | Inserts children for a virtual item.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVirtualChildren | Gets the virtual children of an item.
Public method | GetVirtualId | Gets the virtual id of an item within a specific proxy.
Protected method | GetVirtualIdCore | Gets the virtual id core.
Protected method | GetVirtualIdFromDataProvider | Gets a virtual id from data provider.
Public method | GetVirtualInstances | Gets all virtual instances of an item.
Public method | IsProxy | Determines whether the specified item is a proxy definition.
Protected method | LoadProxyDefinitions | Loads the proxy definitions.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ParseProxyItem | Parses a proxy item.
Public method | RemoveProxyData | Removes all data associated with a specific proxy.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cache | Gets the cache.
Public property | Mapper | Gets the mapper.

See Also

ProxyResolver Class
Sitecore.Data.Proxies Namespace


ProxyResolver Constructor

[image]

Sitecore 6.4.1 API
ProxyResolver Constructor
ProxyResolver Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ProxyResolver(
    ProxyProvider owner
)
Visual Basic
Public Sub New ( _
    owner As ProxyProvider _
)
Visual C++
public:
ProxyResolver(
    ProxyProvider^ owner
)

Parameters

owner
Type: Sitecore.Data.Proxies..::..ProxyProvider

[Missing <param name="owner"/> documentation for "M:Sitecore.Data.Proxies.ProxyResolver.#ctor(Sitecore.Data.Proxies.ProxyProvider)"]

See Also

ProxyResolver Class
Sitecore.Data.Proxies Namespace


ProxyResolver Methods

[image] [image]

Sitecore 6.4.1 API
ProxyResolver Methods
ProxyResolver Class See Also Send Feedback

The ProxyResolver type exposes the following members.

Methods

 | Name | Description
Protected method | AddProxyDefinition | Adds the proxy definition.
Public method | CopyVirtualTreeRoot | Copies the virtual item.
Public method | DuplicateProxyDefinitions | Duplicates the proxy definitions.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetDataProvider | Gets the data provider for a specific database.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParent | Gets the parent of a virtual item.
Protected method | GetProxies | Gets all proxies in a database.
Protected method | GetProxiesUnder | Gets all proxies linked to a specific item.
Public method | GetProxy(Item) | Gets the proxy for a virtual item.
Public method | GetProxy(ID, Database) | Gets the proxy with a specific id.
Protected method | GetProxyChildren | Gets all proxy targets for a specific item.
Protected method | GetProxyCore | Gets the proxy core.
Protected method | GetProxyDefinitionName | Gets the name of the proxy definition.
Public method | GetProxyId | Gets the proxy id for a virtual item.
Public method | GetProxyItem | Gets a proxy item.
Protected method | GetReferenceInstances | Gets the instances pointed to by a list of references.
Public method | GetReferences | Gets the references to an item.
Protected method | GetReferencesFromDataProvider | Gets the references to an item from the data providers.
Public method | GetTarget | Gets the target description for a virtual item.
Protected method | GetTargetCore | Gets the target.
Protected method | GetTargetFromDataProvider | Gets the item id from the data provider.
Public method | GetTargetItem | Gets the target item of a virtual id.
Protected method | GetTrueVirtualChildren | Inserts children for a virtual item.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVirtualChildren | Gets the virtual children of an item.
Public method | GetVirtualId | Gets the virtual id of an item within a specific proxy.
Protected method | GetVirtualIdCore | Gets the virtual id core.
Protected method | GetVirtualIdFromDataProvider | Gets a virtual id from data provider.
Public method | GetVirtualInstances | Gets all virtual instances of an item.
Public method | IsProxy | Determines whether the specified item is a proxy definition.
Protected method | LoadProxyDefinitions | Loads the proxy definitions.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ParseProxyItem | Parses a proxy item.
Public method | RemoveProxyData | Removes all data associated with a specific proxy.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProxyResolver Class
Sitecore.Data.Proxies Namespace


AddProxyDefinition Method

[image]

Sitecore 6.4.1 API
ProxyResolver..::..AddProxyDefinition Method
ProxyResolver Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void AddProxyDefinition(
    SafeDictionary<Object, IList<Proxy>> result,
    Proxy proxy
)
Visual Basic
Protected Sub AddProxyDefinition ( _
    result As SafeDictionary(Of Object, IList(Of Proxy)), _
    proxy As Proxy _
)
Visual C++
protected:
void AddProxyDefinition(
    SafeDictionary<Object^, IList<Proxy^>^>^ result,
    Proxy^ proxy
)

Parameters

result
Type: Sitecore.Collections..::..SafeDictionary <(Of <(<' Object, IList <(Of <(<' Proxy >)>)>>)>)>
The result.
proxy
Type: Sitecore.Data.Proxies..::..Proxy
The proxy.

See Also

ProxyResolver Class
Sitecore.Data.Proxies Namespace


CopyVirtualTreeRoot Method

[image]

Sitecore 6.4.1 API
ProxyResolver..::..CopyVirtualTreeRoot Method
ProxyResolver Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Item CopyVirtualTreeRoot(
    Item item,
    Item target
)
Visual Basic
Public Overridable Function CopyVirtualTreeRoot ( _
    item As Item, _
    target As Item _
) As Item
Visual C++
public:
virtual Item^ CopyVirtualTreeRoot(
    Item^ item,
    Item^ target
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
target
Type: Sitecore.Data.Items..::..Item
The target.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyResolver.CopyVirtualTreeRoot(Sitecore.Data.Items.Item,Sitecore.Data.Items.Item)"]

See Also

ProxyResolver Class
Sitecore.Data.Proxies Namespace


DuplicateProxyDefinitions Method

[image]

Sitecore 6.4.1 API
ProxyResolver..::..DuplicateProxyDefinitions Method
ProxyResolver Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void DuplicateProxyDefinitions(
    Item original,
    Item copy
)
Visual Basic
Public Overridable Sub DuplicateProxyDefinitions ( _
    original As Item, _
    copy As Item _
)
Visual C++
public:
virtual void DuplicateProxyDefinitions(
    Item^ original,
    Item^ copy
)

Parameters

original
Type: Sitecore.Data.Items..::..Item
The source.
copy
Type: Sitecore.Data.Items..::..Item
The copy.

See Also

ProxyResolver Class
Sitecore.Data.Proxies Namespace


GetDataProvider Method

[image]

Sitecore 6.4.1 API
ProxyResolver..::..GetDataProvider Method
ProxyResolver Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual ProxyDataProvider GetDataProvider(
    Database database
)
Visual Basic
Protected Overridable Function GetDataProvider ( _
    database As Database _
) As ProxyDataProvider
Visual C++
protected:
virtual ProxyDataProvider^ GetDataProvider(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyResolver.GetDataProvider(Sitecore.Data.Database)"]

See Also

ProxyResolver Class
Sitecore.Data.Proxies Namespace


GetParent Method

[image]

Sitecore 6.4.1 API
ProxyResolver..::..GetParent Method
ProxyResolver Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Item GetParent(
    Item item
)
Visual Basic
Public Overridable Function GetParent ( _
    item As Item _
) As Item
Visual C++
public:
virtual Item^ GetParent(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyResolver.GetParent(Sitecore.Data.Items.Item)"]

See Also

ProxyResolver Class
Sitecore.Data.Proxies Namespace


GetProxies Method

[image]

Sitecore 6.4.1 API
ProxyResolver..::..GetProxies Method
ProxyResolver Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual SafeDictionary<Object, IList<Proxy>> GetProxies(
    Database database
)
Visual Basic
Protected Overridable Function GetProxies ( _
    database As Database _
) As SafeDictionary(Of Object, IList(Of Proxy))
Visual C++
protected:
virtual SafeDictionary<Object^, IList<Proxy^>^>^ GetProxies(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

Return Value

The proxies.

See Also

ProxyResolver Class
Sitecore.Data.Proxies Namespace


GetProxiesUnder Method

[image]

Sitecore 6.4.1 API
ProxyResolver..::..GetProxiesUnder Method
ProxyResolver Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual IList<Proxy> GetProxiesUnder(
    Item item
)
Visual Basic
Protected Overridable Function GetProxiesUnder ( _
    item As Item _
) As IList(Of Proxy)
Visual C++
protected:
virtual IList<Proxy^>^ GetProxiesUnder(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyResolver.GetProxiesUnder(Sitecore.Data.Items.Item)"]

See Also

ProxyResolver Class
Sitecore.Data.Proxies Namespace


GetProxy Method

[image] [image]

Sitecore 6.4.1 API
ProxyResolver..::..GetProxy Method
ProxyResolver Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProxy(Item) | Gets the proxy for a virtual item.
Public method | GetProxy(ID, Database) | Gets the proxy with a specific id.

See Also

ProxyResolver Class
ProxyResolver Members
Sitecore.Data.Proxies Namespace


GetProxy Method (Item)

[image]

Sitecore 6.4.1 API
ProxyResolver..::..GetProxy Method (Item)
ProxyResolver Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Proxy GetProxy(
    Item item
)
Visual Basic
Public Overridable Function GetProxy ( _
    item As Item _
) As Proxy
Visual C++
public:
virtual Proxy^ GetProxy(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyResolver.GetProxy(Sitecore.Data.Items.Item)"]

See Also

ProxyResolver Class
GetProxy Overload
Sitecore.Data.Proxies Namespace


GetProxy Method (ID, Database)

[image]

Sitecore 6.4.1 API
ProxyResolver..::..GetProxy Method (ID, Database)
ProxyResolver Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Proxy GetProxy(
    ID proxyId,
    Database database
)
Visual Basic
Public Overridable Function GetProxy ( _
    proxyId As ID, _
    database As Database _
) As Proxy
Visual C++
public:
virtual Proxy^ GetProxy(
    ID^ proxyId,
    Database^ database
)

Parameters

proxyId
Type: Sitecore.Data..::..ID
The proxy id.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyResolver.GetProxy(Sitecore.Data.ID,Sitecore.Data.Database)"]

See Also

ProxyResolver Class
GetProxy Overload
Sitecore.Data.Proxies Namespace


GetProxyChildren Method

[image]

Sitecore 6.4.1 API
ProxyResolver..::..GetProxyChildren Method
ProxyResolver Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual ItemList GetProxyChildren(
    Item item
)
Visual Basic
Protected Overridable Function GetProxyChildren ( _
    item As Item _
) As ItemList
Visual C++
protected:
virtual ItemList^ GetProxyChildren(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyResolver.GetProxyChildren(Sitecore.Data.Items.Item)"]

See Also

ProxyResolver Class
Sitecore.Data.Proxies Namespace


GetProxyCore Method

[image]

Sitecore 6.4.1 API
ProxyResolver..::..GetProxyCore Method
ProxyResolver Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual Proxy GetProxyCore(
    ID proxyId,
    Database database
)
Visual Basic
Protected Overridable Function GetProxyCore ( _
    proxyId As ID, _
    database As Database _
) As Proxy
Visual C++
protected:
virtual Proxy^ GetProxyCore(
    ID^ proxyId,
    Database^ database
)

Parameters

proxyId
Type: Sitecore.Data..::..ID
The proxy id.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyResolver.GetProxyCore(Sitecore.Data.ID,Sitecore.Data.Database)"]

See Also

ProxyResolver Class
Sitecore.Data.Proxies Namespace


GetProxyDefinitionName Method

[image]

Sitecore 6.4.1 API
ProxyResolver..::..GetProxyDefinitionName Method
ProxyResolver Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string GetProxyDefinitionName(
    Item item,
    Item originalProxy,
    Item destination
)
Visual Basic
Protected Overridable Function GetProxyDefinitionName ( _
    item As Item, _
    originalProxy As Item, _
    destination As Item _
) As String
Visual C++
protected:
virtual String^ GetProxyDefinitionName(
    Item^ item,
    Item^ originalProxy,
    Item^ destination
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
originalProxy
Type: Sitecore.Data.Items..::..Item
The original proxy.
destination
Type: Sitecore.Data.Items..::..Item
The destination.

Return Value

The proxy definition name.

See Also

ProxyResolver Class
Sitecore.Data.Proxies Namespace


GetProxyId Method

[image]

Sitecore 6.4.1 API
ProxyResolver..::..GetProxyId Method
ProxyResolver Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ID GetProxyId(
    Item item
)
Visual Basic
Public Overridable Function GetProxyId ( _
    item As Item _
) As ID
Visual C++
public:
virtual ID^ GetProxyId(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyResolver.GetProxyId(Sitecore.Data.Items.Item)"]

See Also

ProxyResolver Class
Sitecore.Data.Proxies Namespace


GetProxyItem Method

[image]

Sitecore 6.4.1 API
ProxyResolver..::..GetProxyItem Method
ProxyResolver Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Item GetProxyItem(
    ID proxyId,
    Database database
)
Visual Basic
Public Overridable Function GetProxyItem ( _
    proxyId As ID, _
    database As Database _
) As Item
Visual C++
public:
virtual Item^ GetProxyItem(
    ID^ proxyId,
    Database^ database
)

Parameters

proxyId
Type: Sitecore.Data..::..ID
The proxy id.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyResolver.GetProxyItem(Sitecore.Data.ID,Sitecore.Data.Database)"]

See Also

ProxyResolver Class
Sitecore.Data.Proxies Namespace


GetReferences Method

[image]

Sitecore 6.4.1 API
ProxyResolver..::..GetReferences Method
ProxyResolver Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual List<ProxyReference> GetReferences(
    Item item
)
Visual Basic
Public Overridable Function GetReferences ( _
    item As Item _
) As List(Of ProxyReference)
Visual C++
public:
virtual List<ProxyReference^>^ GetReferences(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyResolver.GetReferences(Sitecore.Data.Items.Item)"]

See Also

ProxyResolver Class
Sitecore.Data.Proxies Namespace


GetReferencesFromDataProvider Method

[image]

Sitecore 6.4.1 API
ProxyResolver..::..GetReferencesFromDataProvider Method
ProxyResolver Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual List<ProxyReference> GetReferencesFromDataProvider(
    Item item
)
Visual Basic
Protected Overridable Function GetReferencesFromDataProvider ( _
    item As Item _
) As List(Of ProxyReference)
Visual C++
protected:
virtual List<ProxyReference^>^ GetReferencesFromDataProvider(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyResolver.GetReferencesFromDataProvider(Sitecore.Data.Items.Item)"]

See Also

ProxyResolver Class
Sitecore.Data.Proxies Namespace


GetTarget Method

[image]

Sitecore 6.4.1 API
ProxyResolver..::..GetTarget Method
ProxyResolver Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ProxyTarget GetTarget(
    ID virtualId,
    Database database
)
Visual Basic
Public Overridable Function GetTarget ( _
    virtualId As ID, _
    database As Database _
) As ProxyTarget
Visual C++
public:
virtual ProxyTarget^ GetTarget(
    ID^ virtualId,
    Database^ database
)

Parameters

virtualId
Type: Sitecore.Data..::..ID
The virtual id.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyResolver.GetTarget(Sitecore.Data.ID,Sitecore.Data.Database)"]

See Also

ProxyResolver Class
Sitecore.Data.Proxies Namespace


GetTargetCore Method

[image]

Sitecore 6.4.1 API
ProxyResolver..::..GetTargetCore Method
ProxyResolver Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual ProxyTarget GetTargetCore(
    ID virtualId,
    Database database
)
Visual Basic
Protected Overridable Function GetTargetCore ( _
    virtualId As ID, _
    database As Database _
) As ProxyTarget
Visual C++
protected:
virtual ProxyTarget^ GetTargetCore(
    ID^ virtualId,
    Database^ database
)

Parameters

virtualId
Type: Sitecore.Data..::..ID
The virtual id.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyResolver.GetTargetCore(Sitecore.Data.ID,Sitecore.Data.Database)"]

See Also

ProxyResolver Class
Sitecore.Data.Proxies Namespace


GetTargetFromDataProvider Method

[image]

Sitecore 6.4.1 API
ProxyResolver..::..GetTargetFromDataProvider Method
ProxyResolver Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual ProxyTarget GetTargetFromDataProvider(
    ID virtualId,
    Database database
)
Visual Basic
Protected Overridable Function GetTargetFromDataProvider ( _
    virtualId As ID, _
    database As Database _
) As ProxyTarget
Visual C++
protected:
virtual ProxyTarget^ GetTargetFromDataProvider(
    ID^ virtualId,
    Database^ database
)

Parameters

virtualId
Type: Sitecore.Data..::..ID
The virtual id.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyResolver.GetTargetFromDataProvider(Sitecore.Data.ID,Sitecore.Data.Database)"]

See Also

ProxyResolver Class
Sitecore.Data.Proxies Namespace


GetTargetItem Method

[image]

Sitecore 6.4.1 API
ProxyResolver..::..GetTargetItem Method
ProxyResolver Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetTargetItem(
    ID virtualId,
    Language language,
    Version version,
    Database database
)
Visual Basic
Public Function GetTargetItem ( _
    virtualId As ID, _
    language As Language, _
    version As Version, _
    database As Database _
) As Item
Visual C++
public:
Item^ GetTargetItem(
    ID^ virtualId,
    Language^ language,
    Version^ version,
    Database^ database
)

Parameters

virtualId
Type: Sitecore.Data..::..ID
The virtual id.
language
Type: Sitecore.Globalization..::..Language
The language.
version
Type: Sitecore.Data..::..Version
The version.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyResolver.GetTargetItem(Sitecore.Data.ID,Sitecore.Globalization.Language,Sitecore.Data.Version,Sitecore.Data.Database)"]

See Also

ProxyResolver Class
Sitecore.Data.Proxies Namespace


GetTrueVirtualChildren Method

[image]

Sitecore 6.4.1 API
ProxyResolver..::..GetTrueVirtualChildren Method
ProxyResolver Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual ItemList GetTrueVirtualChildren(
    Item item
)
Visual Basic
Protected Overridable Function GetTrueVirtualChildren ( _
    item As Item _
) As ItemList
Visual C++
protected:
virtual ItemList^ GetTrueVirtualChildren(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyResolver.GetTrueVirtualChildren(Sitecore.Data.Items.Item)"]

See Also

ProxyResolver Class
Sitecore.Data.Proxies Namespace


GetVirtualChildren Method

[image]

Sitecore 6.4.1 API
ProxyResolver..::..GetVirtualChildren Method
ProxyResolver Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemList GetVirtualChildren(
    Item item
)
Visual Basic
Public Function GetVirtualChildren ( _
    item As Item _
) As ItemList
Visual C++
public:
ItemList^ GetVirtualChildren(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyResolver.GetVirtualChildren(Sitecore.Data.Items.Item)"]

See Also

ProxyResolver Class
Sitecore.Data.Proxies Namespace


GetVirtualId Method

[image]

Sitecore 6.4.1 API
ProxyResolver..::..GetVirtualId Method
ProxyResolver Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ID GetVirtualId(
    ID itemId,
    ID proxyId,
    Database database,
    bool generateIfNotFound
)
Visual Basic
Public Overridable Function GetVirtualId ( _
    itemId As ID, _
    proxyId As ID, _
    database As Database, _
    generateIfNotFound As Boolean _
) As ID
Visual C++
public:
virtual ID^ GetVirtualId(
    ID^ itemId,
    ID^ proxyId,
    Database^ database,
    bool generateIfNotFound
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The real item id.
proxyId
Type: Sitecore.Data..::..ID
The proxy id.
database
Type: Sitecore.Data..::..Database
The database.
generateIfNotFound
Type: System..::..Boolean
If set to true a virtual id will be generated if it does not already exist.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyResolver.GetVirtualId(Sitecore.Data.ID,Sitecore.Data.ID,Sitecore.Data.Database,System.Boolean)"]

See Also

ProxyResolver Class
Sitecore.Data.Proxies Namespace


GetVirtualIdFromDataProvider Method

[image]

Sitecore 6.4.1 API
ProxyResolver..::..GetVirtualIdFromDataProvider Method
ProxyResolver Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual ID GetVirtualIdFromDataProvider(
    ID itemId,
    ID proxyId,
    Database database,
    bool generateIfNotFound
)
Visual Basic
Protected Overridable Function GetVirtualIdFromDataProvider ( _
    itemId As ID, _
    proxyId As ID, _
    database As Database, _
    generateIfNotFound As Boolean _
) As ID
Visual C++
protected:
virtual ID^ GetVirtualIdFromDataProvider(
    ID^ itemId,
    ID^ proxyId,
    Database^ database,
    bool generateIfNotFound
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
proxyId
Type: Sitecore.Data..::..ID
The proxy id.
database
Type: Sitecore.Data..::..Database
The proxy database.
generateIfNotFound
Type: System..::..Boolean
If set to true a virtual id will be generated if it does not already exist.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyResolver.GetVirtualIdFromDataProvider(Sitecore.Data.ID,Sitecore.Data.ID,Sitecore.Data.Database,System.Boolean)"]

See Also

ProxyResolver Class
Sitecore.Data.Proxies Namespace


GetVirtualInstances Method

[image]

Sitecore 6.4.1 API
ProxyResolver..::..GetVirtualInstances Method
ProxyResolver Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ItemList GetVirtualInstances(
    Item item,
    bool preserveState
)
Visual Basic
Public Overridable Function GetVirtualInstances ( _
    item As Item, _
    preserveState As Boolean _
) As ItemList
Visual C++
public:
virtual ItemList^ GetVirtualInstances(
    Item^ item,
    bool preserveState
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
preserveState
Type: System..::..Boolean
If set to true, state is preserved.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyResolver.GetVirtualInstances(Sitecore.Data.Items.Item,System.Boolean)"]

See Also

ProxyResolver Class
Sitecore.Data.Proxies Namespace


IsProxy Method

[image]

Sitecore 6.4.1 API
ProxyResolver..::..IsProxy Method
ProxyResolver Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool IsProxy(
    Item item
)
Visual Basic
Public Overridable Function IsProxy ( _
    item As Item _
) As Boolean
Visual C++
public:
virtual bool IsProxy(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

true if the specified item is proxy; otherwise, false.

See Also

ProxyResolver Class
Sitecore.Data.Proxies Namespace


LoadProxyDefinitions Method

[image]

Sitecore 6.4.1 API
ProxyResolver..::..LoadProxyDefinitions Method
ProxyResolver Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void LoadProxyDefinitions(
    Database database,
    Item root,
    SafeDictionary<Object, IList<Proxy>> result
)
Visual Basic
Protected Overridable Sub LoadProxyDefinitions ( _
    database As Database, _
    root As Item, _
    result As SafeDictionary(Of Object, IList(Of Proxy)) _
)
Visual C++
protected:
virtual void LoadProxyDefinitions(
    Database^ database,
    Item^ root,
    SafeDictionary<Object^, IList<Proxy^>^>^ result
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.
root
Type: Sitecore.Data.Items..::..Item
The root.
result
Type: Sitecore.Collections..::..SafeDictionary <(Of <(<' Object, IList <(Of <(<' Proxy >)>)>>)>)>
The result.

See Also

ProxyResolver Class
Sitecore.Data.Proxies Namespace


ParseProxyItem Method

[image]

Sitecore 6.4.1 API
ProxyResolver..::..ParseProxyItem Method
ProxyResolver Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual Proxy ParseProxyItem(
    Item proxyItem
)
Visual Basic
Protected Overridable Function ParseProxyItem ( _
    proxyItem As Item _
) As Proxy
Visual C++
protected:
virtual Proxy^ ParseProxyItem(
    Item^ proxyItem
)

Parameters

proxyItem
Type: Sitecore.Data.Items..::..Item
The proxy item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyResolver.ParseProxyItem(Sitecore.Data.Items.Item)"]

See Also

ProxyResolver Class
Sitecore.Data.Proxies Namespace


RemoveProxyData Method

[image]

Sitecore 6.4.1 API
ProxyResolver..::..RemoveProxyData Method
ProxyResolver Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void RemoveProxyData(
    ID proxyId,
    Database database
)
Visual Basic
Public Overridable Sub RemoveProxyData ( _
    proxyId As ID, _
    database As Database _
)
Visual C++
public:
virtual void RemoveProxyData(
    ID^ proxyId,
    Database^ database
)

Parameters

proxyId
Type: Sitecore.Data..::..ID
The proxy id.
database
Type: Sitecore.Data..::..Database
The database.

See Also

ProxyResolver Class
Sitecore.Data.Proxies Namespace


ProxyResolver Properties

[image] [image]

Sitecore 6.4.1 API
ProxyResolver Properties
ProxyResolver Class See Also Send Feedback

The ProxyResolver type exposes the following members.

Properties

 | Name | Description
Public property | Cache | Gets the cache.
Public property | Mapper | Gets the mapper.

See Also

ProxyResolver Class
Sitecore.Data.Proxies Namespace


Cache Property

[image]

Sitecore 6.4.1 API
ProxyResolver..::..Cache Property
ProxyResolver Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ProxyCache Cache { get; }
Visual Basic
Public ReadOnly Property Cache As ProxyCache
    Get
Visual C++
public:
property ProxyCache^ Cache {
    ProxyCache^ get ();
}

Field Value

The cache.

See Also

ProxyResolver Class
Sitecore.Data.Proxies Namespace


Mapper Property

[image]

Sitecore 6.4.1 API
ProxyResolver..::..Mapper Property
ProxyResolver Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ProxyMapper Mapper { get; }
Visual Basic
Public ReadOnly Property Mapper As ProxyMapper
    Get
Visual C++
public:
property ProxyMapper^ Mapper {
    ProxyMapper^ get ();
}

Field Value

The mapper.

See Also

ProxyResolver Class
Sitecore.Data.Proxies Namespace


ProxyState Enumeration

[image]

Sitecore 6.4.1 API
ProxyState Enumeration
See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum ProxyState
Visual Basic
Public Enumeration ProxyState
Visual C++
public enum class ProxyState

Members

Member name | Value | Description
Disabled | 0 |
Enabled | 1 |

See Also

Sitecore.Data.Proxies Namespace


ProxyStateMonitor Class

[image]

Sitecore 6.4.1 API
ProxyStateMonitor Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ProxyStateMonitor
Visual Basic
Public Class ProxyStateMonitor
Visual C++
public ref class ProxyStateMonitor

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Proxies..::..ProxyStateMonitor

See Also

ProxyStateMonitor Members
Sitecore.Data.Proxies Namespace


ProxyStateMonitor Members

[image] [image]

Sitecore 6.4.1 API
ProxyStateMonitor Members
ProxyStateMonitor Class Constructors Methods Properties See Also Send Feedback

The ProxyStateMonitor type exposes the following members.

Constructors

 | Name | Description
Public method | ProxyStateMonitor | Initializes a new instance of the ProxyStateMonitor class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetState()()()() | Gets the general system state (basically the same as ProxiesActive).
Public method | GetState(Database) | Gets the state for a specific database.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsActive | Determines whether proxies are active for the specified database.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ProxiesActive | Gets a value indicating whether proxies are active.

See Also

ProxyStateMonitor Class
Sitecore.Data.Proxies Namespace


ProxyStateMonitor Constructor

[image]

Sitecore 6.4.1 API
ProxyStateMonitor Constructor
ProxyStateMonitor Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ProxyStateMonitor()
Visual Basic
Public Sub New
Visual C++
public:
ProxyStateMonitor()

See Also

ProxyStateMonitor Class
Sitecore.Data.Proxies Namespace


ProxyStateMonitor Methods

[image] [image]

Sitecore 6.4.1 API
ProxyStateMonitor Methods
ProxyStateMonitor Class See Also Send Feedback

The ProxyStateMonitor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetState()()()() | Gets the general system state (basically the same as ProxiesActive).
Public method | GetState(Database) | Gets the state for a specific database.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsActive | Determines whether proxies are active for the specified database.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProxyStateMonitor Class
Sitecore.Data.Proxies Namespace


GetState Method

[image]

Sitecore 6.4.1 API
ProxyStateMonitor..::..GetState Method
ProxyStateMonitor Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ProxyState GetState()
Visual Basic
Public Function GetState As ProxyState
Visual C++
public:
ProxyState GetState()

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyStateMonitor.GetState"]

See Also

ProxyStateMonitor Class
GetState Overload
Sitecore.Data.Proxies Namespace


GetState Method (Database)

[image]

Sitecore 6.4.1 API
ProxyStateMonitor..::..GetState Method (Database)
ProxyStateMonitor Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ProxyState GetState(
    Database database
)
Visual Basic
Public Function GetState ( _
    database As Database _
) As ProxyState
Visual C++
public:
ProxyState GetState(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyStateMonitor.GetState(Sitecore.Data.Database)"]

Remarks

If proxy support has been disabled generally, this method will result Disabled for all databases regardless of their individual settings.

See Also

ProxyStateMonitor Class
GetState Overload
Sitecore.Data.Proxies Namespace


ProxyStateMonitor Properties

[image] [image]

Sitecore 6.4.1 API
ProxyStateMonitor Properties
ProxyStateMonitor Class See Also Send Feedback

The ProxyStateMonitor type exposes the following members.

Properties

 | Name | Description
Public property | ProxiesActive | Gets a value indicating whether proxies are active.

See Also

ProxyStateMonitor Class
Sitecore.Data.Proxies Namespace


ProxiesActive Property

[image]

Sitecore 6.4.1 API
ProxyStateMonitor..::..ProxiesActive Property
ProxyStateMonitor Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ProxiesActive { get; }
Visual Basic
Public ReadOnly Property ProxiesActive As Boolean
    Get
Visual C++
public:
property bool ProxiesActive {
    bool get ();
}

Field Value

true if proxies are active; otherwise, false.

See Also

ProxyStateMonitor Class
Sitecore.Data.Proxies Namespace


ProxyTarget Class

[image]

Sitecore 6.4.1 API
ProxyTarget Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ProxyTarget
Visual Basic
Public Class ProxyTarget
Visual C++
public ref class ProxyTarget

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Proxies..::..ProxyTarget

See Also

ProxyTarget Members
Sitecore.Data.Proxies Namespace


ProxyTarget Members

[image] [image]

Sitecore 6.4.1 API
ProxyTarget Members
ProxyTarget Class Constructors Methods Properties See Also Send Feedback

The ProxyTarget type exposes the following members.

Constructors

 | Name | Description
Public method | ProxyTarget | Initializes a new instance of the ProxyTarget class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTargetItem | Gets the target item.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsNullOrEmpty | Determines whether the specified target is null or empty.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
 | Null | Gets the null instance.
Public property | ProxyID | Gets the proxy ID.
Public property | TargetDatabase | Gets or sets the target database.
Public property | TargetID | Gets the target ID.

See Also

ProxyTarget Class
Sitecore.Data.Proxies Namespace


ProxyTarget Methods

[image] [image]

Sitecore 6.4.1 API
ProxyTarget Methods
ProxyTarget Class See Also Send Feedback

The ProxyTarget type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTargetItem | Gets the target item.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsNullOrEmpty | Determines whether the specified target is null or empty.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProxyTarget Class
Sitecore.Data.Proxies Namespace


GetTargetItem Method

[image]

Sitecore 6.4.1 API
ProxyTarget..::..GetTargetItem Method
ProxyTarget Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetTargetItem(
    Language language,
    Version version
)
Visual Basic
Public Function GetTargetItem ( _
    language As Language, _
    version As Version _
) As Item
Visual C++
public:
Item^ GetTargetItem(
    Language^ language,
    Version^ version
)

Parameters

language
Type: Sitecore.Globalization..::..Language
The language.
version
Type: Sitecore.Data..::..Version
The version.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyTarget.GetTargetItem(Sitecore.Globalization.Language,Sitecore.Data.Version)"]

See Also

ProxyTarget Class
Sitecore.Data.Proxies Namespace


IsNullOrEmpty Method

[image]

Sitecore 6.4.1 API
ProxyTarget..::..IsNullOrEmpty Method
ProxyTarget Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsNullOrEmpty(
    ProxyTarget target
)
Visual Basic
Public Shared Function IsNullOrEmpty ( _
    target As ProxyTarget _
) As Boolean
Visual C++
public:
static bool IsNullOrEmpty(
    ProxyTarget^ target
)

Parameters

target
Type: Sitecore.Data.Proxies..::..ProxyTarget
The target.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.ProxyTarget.IsNullOrEmpty(Sitecore.Data.Proxies.ProxyTarget)"]

See Also

ProxyTarget Class
Sitecore.Data.Proxies Namespace


ProxyTarget Properties

[image] [image]

Sitecore 6.4.1 API
ProxyTarget Properties
ProxyTarget Class See Also Send Feedback

The ProxyTarget type exposes the following members.

Properties

 | Name | Description
 | Null | Gets the null instance.
Public property | ProxyID | Gets the proxy ID.
Public property | TargetDatabase | Gets or sets the target database.
Public property | TargetID | Gets the target ID.

See Also

ProxyTarget Class
Sitecore.Data.Proxies Namespace


Null Property

[image]

Sitecore 6.4.1 API
ProxyTarget..::..Null Property
ProxyTarget Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ProxyTarget Null { get; }
Visual Basic
Public Shared ReadOnly Property Null As ProxyTarget
    Get
Visual C++
public:
static property ProxyTarget^ Null {
    ProxyTarget^ get ();
}

Field Value

The null.

See Also

ProxyTarget Class
Sitecore.Data.Proxies Namespace


ProxyID Property

[image]

Sitecore 6.4.1 API
ProxyTarget..::..ProxyID Property
ProxyTarget Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ProxyID { get; }
Visual Basic
Public ReadOnly Property ProxyID As ID
    Get
Visual C++
public:
property ID^ ProxyID {
    ID^ get ();
}

Field Value

The proxy ID.

See Also

ProxyTarget Class
Sitecore.Data.Proxies Namespace


TargetID Property

[image]

Sitecore 6.4.1 API
ProxyTarget..::..TargetID Property
ProxyTarget Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID TargetID { get; }
Visual Basic
Public ReadOnly Property TargetID As ID
    Get
Visual C++
public:
property ID^ TargetID {
    ID^ get ();
}

Field Value

The target ID.

See Also

ProxyTarget Class
Sitecore.Data.Proxies Namespace


ProxyType Enumeration

[image]

Sitecore 6.4.1 API
ProxyType Enumeration
See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum ProxyType
Visual Basic
Public Enumeration ProxyType
Visual C++
public enum class ProxyType

Members

Member name | Value | Description
EntireSubtree | 0 | All items will be included
RootOnly | 1 | Only source item will be included
DescendantsOnly | 2 | Only children of a source item will be included

See Also

Sitecore.Data.Proxies Namespace


SqlProxyDataProvider Class

[image]

Sitecore 6.4.1 API
SqlProxyDataProvider Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SqlProxyDataProvider : ProxyDataProvider
Visual Basic
Public Class SqlProxyDataProvider _
    Inherits ProxyDataProvider
Visual C++
public ref class SqlProxyDataProvider : public ProxyDataProvider

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Proxies..::..ProxyDataProvider
Sitecore.Data.Proxies..::..SqlProxyDataProvider
Sitecore.Data.SqlServer..::..SqlServerProxyDataProvider

See Also

SqlProxyDataProvider Members
Sitecore.Data.Proxies Namespace


SqlProxyDataProvider Members

[image] [image]

Sitecore 6.4.1 API
SqlProxyDataProvider Members
SqlProxyDataProvider Class Constructors Methods Properties See Also Send Feedback

The SqlProxyDataProvider type exposes the following members.

Constructors

 | Name | Description
Public method | SqlProxyDataProvider | Initializes a new instance of the SqlProxyDataProvider class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetReferences | Gets all references to a specific item. (Overrides ProxyDataProvider..::..GetReferences(ID).)
Public method | GetTarget | Gets the id of the item pointed to by a virtual id. (Overrides ProxyDataProvider..::..GetTarget(ID).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVirtualId | Gets the id of a shadow pointing to a specific item id within a specific proxy. (Overrides ProxyDataProvider..::..GetVirtualId(ID, ID, Boolean).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveData | Removes all data associated with a specific proxy. (Overrides ProxyDataProvider..::..RemoveData(ID).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | Gets or sets the name. (Inherited from ProxyDataProvider.)

See Also

SqlProxyDataProvider Class
Sitecore.Data.Proxies Namespace


SqlProxyDataProvider Constructor

[image]

Sitecore 6.4.1 API
SqlProxyDataProvider Constructor
SqlProxyDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlProxyDataProvider(
    SqlDataApi api
)
Visual Basic
Public Sub New ( _
    api As SqlDataApi _
)
Visual C++
public:
SqlProxyDataProvider(
    SqlDataApi^ api
)

Parameters

api
Type: Sitecore.Data.DataProviders.Sql..::..SqlDataApi
The API.

See Also

SqlProxyDataProvider Class
Sitecore.Data.Proxies Namespace


SqlProxyDataProvider Methods

[image] [image]

Sitecore 6.4.1 API
SqlProxyDataProvider Methods
SqlProxyDataProvider Class See Also Send Feedback

The SqlProxyDataProvider type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetReferences | Gets all references to a specific item. (Overrides ProxyDataProvider..::..GetReferences(ID).)
Public method | GetTarget | Gets the id of the item pointed to by a virtual id. (Overrides ProxyDataProvider..::..GetTarget(ID).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVirtualId | Gets the id of a shadow pointing to a specific item id within a specific proxy. (Overrides ProxyDataProvider..::..GetVirtualId(ID, ID, Boolean).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveData | Removes all data associated with a specific proxy. (Overrides ProxyDataProvider..::..RemoveData(ID).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SqlProxyDataProvider Class
Sitecore.Data.Proxies Namespace


GetTarget Method

[image]

Sitecore 6.4.1 API
SqlProxyDataProvider..::..GetTarget Method
SqlProxyDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override ProxyTarget GetTarget(
    ID virtualId
)
Visual Basic
Public Overrides Function GetTarget ( _
    virtualId As ID _
) As ProxyTarget
Visual C++
public:
virtual ProxyTarget^ GetTarget(
    ID^ virtualId
) override

Parameters

virtualId
Type: Sitecore.Data..::..ID
The virtual id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.SqlProxyDataProvider.GetTarget(Sitecore.Data.ID)"]

See Also

SqlProxyDataProvider Class
Sitecore.Data.Proxies Namespace


GetVirtualId Method

[image]

Sitecore 6.4.1 API
SqlProxyDataProvider..::..GetVirtualId Method
SqlProxyDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override ID GetVirtualId(
    ID itemId,
    ID proxyId,
    bool generateIfNotFound
)
Visual Basic
Public Overrides Function GetVirtualId ( _
    itemId As ID, _
    proxyId As ID, _
    generateIfNotFound As Boolean _
) As ID
Visual C++
public:
virtual ID^ GetVirtualId(
    ID^ itemId,
    ID^ proxyId,
    bool generateIfNotFound
) override

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
proxyId
Type: Sitecore.Data..::..ID
The proxy id.
generateIfNotFound
Type: System..::..Boolean
If set to true a virtual id will be generated if it does not already exist.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Proxies.SqlProxyDataProvider.GetVirtualId(Sitecore.Data.ID,Sitecore.Data.ID,System.Boolean)"]

See Also

SqlProxyDataProvider Class
Sitecore.Data.Proxies Namespace


RemoveData Method

[image]

Sitecore 6.4.1 API
SqlProxyDataProvider..::..RemoveData Method
SqlProxyDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Proxies
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void RemoveData(
    ID proxyId
)
Visual Basic
Public Overrides Sub RemoveData ( _
    proxyId As ID _
)
Visual C++
public:
virtual void RemoveData(
    ID^ proxyId
) override

Parameters

proxyId
Type: Sitecore.Data..::..ID
The proxy id.

See Also

SqlProxyDataProvider Class
Sitecore.Data.Proxies Namespace


SqlProxyDataProvider Properties

[image] [image]

Sitecore 6.4.1 API
SqlProxyDataProvider Properties
SqlProxyDataProvider Class See Also Send Feedback

The SqlProxyDataProvider type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets or sets the name. (Inherited from ProxyDataProvider.)

See Also

SqlProxyDataProvider Class
Sitecore.Data.Proxies Namespace


AddOperator Class

[image]

Sitecore 6.4.1 API
AddOperator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class AddOperator : BinaryOperator
Visual Basic
Public Class AddOperator _
    Inherits BinaryOperator
Visual C++
public ref class AddOperator : public BinaryOperator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..Opcode
Sitecore.Data.Query..::..BinaryOperator
Sitecore.Data.Query..::..AddOperator

See Also

AddOperator Members
Sitecore.Data.Query Namespace


AddOperator Members

[image] [image]

Sitecore 6.4.1 API
AddOperator Members
AddOperator Class Constructors Methods Properties See Also Send Feedback

The AddOperator type exposes the following members.

Constructors

 | Name | Description
Public method | AddOperator | Creates a new AddOperator instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate(Query, QueryContext) | Evaluates the specified query. (Inherited from BinaryOperator.)
Public method | Evaluate(Object, Object, Boolean%) | Evaluates the expression.
Public method | EvaluateOperands | Evaluates the expression. (Overrides BinaryOperator..::..EvaluateOperands(Object, Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from BinaryOperator.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Left | Gets the left expression. (Inherited from BinaryOperator.)
Public property | Right | Gets the right expression. (Inherited from BinaryOperator.)

See Also

AddOperator Class
Sitecore.Data.Query Namespace


AddOperator Constructor

[image]

Sitecore 6.4.1 API
AddOperator Constructor
AddOperator Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AddOperator(
    Opcode left,
    Opcode right
)
Visual Basic
Public Sub New ( _
    left As Opcode, _
    right As Opcode _
)
Visual C++
public:
AddOperator(
    Opcode^ left,
    Opcode^ right
)

Parameters

left
Type: Sitecore.Data.Query..::..Opcode
Left expression.
right
Type: Sitecore.Data.Query..::..Opcode
Right expression.

See Also

AddOperator Class
Sitecore.Data.Query Namespace


AddOperator Methods

[image] [image]

Sitecore 6.4.1 API
AddOperator Methods
AddOperator Class See Also Send Feedback

The AddOperator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate(Query, QueryContext) | Evaluates the specified query. (Inherited from BinaryOperator.)
Public method | Evaluate(Object, Object, Boolean%) | Evaluates the expression.
Public method | EvaluateOperands | Evaluates the expression. (Overrides BinaryOperator..::..EvaluateOperands(Object, Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from BinaryOperator.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddOperator Class
Sitecore.Data.Query Namespace


Evaluate Method (Object, Object, Boolean)

[image]

Sitecore 6.4.1 API
AddOperator..::..Evaluate Method (Object, Object, Boolean%)
AddOperator Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object Evaluate(
    Object left,
    Object right,
    out bool handled
)
Visual Basic
Public Function Evaluate ( _
    left As Object, _
    right As Object, _
    <OutAttribute> ByRef handled As Boolean _
) As Object
Visual C++
public:
Object^ Evaluate(
    Object^ left,
    Object^ right,
    [OutAttribute] bool% handled
)

Parameters

left
Type: System..::..Object
Left expression.
right
Type: System..::..Object
Right expression.
handled
Type: System..::..Boolean %
Handled.

Return Value

The result of the evaluation.

See Also

AddOperator Class
Evaluate Overload
Sitecore.Data.Query Namespace


EvaluateOperands Method

[image]

Sitecore 6.4.1 API
AddOperator..::..EvaluateOperands Method
AddOperator Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Object EvaluateOperands(
    Object left,
    Object right
)
Visual Basic
Public Overrides Function EvaluateOperands ( _
    left As Object, _
    right As Object _
) As Object
Visual C++
public:
virtual Object^ EvaluateOperands(
    Object^ left,
    Object^ right
) override

Parameters

left
Type: System..::..Object
Left expression.
right
Type: System..::..Object
Right expression.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Query.AddOperator.EvaluateOperands(System.Object,System.Object)"]

See Also

AddOperator Class
Sitecore.Data.Query Namespace


AddOperator Properties

[image] [image]

Sitecore 6.4.1 API
AddOperator Properties
AddOperator Class See Also Send Feedback

The AddOperator type exposes the following members.

Properties

 | Name | Description
Public property | Left | Gets the left expression. (Inherited from BinaryOperator.)
Public property | Right | Gets the right expression. (Inherited from BinaryOperator.)

See Also

AddOperator Class
Sitecore.Data.Query Namespace


Ancestor Class

[image]

Sitecore 6.4.1 API
Ancestor Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Ancestor : Step
Visual Basic
Public Class Ancestor _
    Inherits Step
Visual C++
public ref class Ancestor : public Step

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..Opcode
Sitecore.Data.Query..::..Step
Sitecore.Data.Query..::..Ancestor
Sitecore.Data.Query..::..AncestorOrSelf

See Also

Ancestor Members
Sitecore.Data.Query Namespace


Ancestor Members

[image] [image]

Sitecore 6.4.1 API
Ancestor Members
Ancestor Class Constructors Methods Properties See Also Send Feedback

The Ancestor type exposes the following members.

Constructors

 | Name | Description
Public method | Ancestor | Creates a new Ancestor instance.

Methods

 | Name | Description
Protected method | Break | Breaks the query. (Inherited from Step.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Overrides Opcode..::..Evaluate(Query, QueryContext).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetContextNode | Gets the context node.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Overrides Step..::..Print(HtmlTextWriter).)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | Gets the name.
Public property | NextStep | Gets or sets the next step. (Inherited from Step.)
Public property | Predicate | Gets the predicate.

See Also

Ancestor Class
Sitecore.Data.Query Namespace


Ancestor Constructor

[image]

Sitecore 6.4.1 API
Ancestor Constructor
Ancestor Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Ancestor(
    ElementBase element
)
Visual Basic
Public Sub New ( _
    element As ElementBase _
)
Visual C++
public:
Ancestor(
    ElementBase^ element
)

Parameters

element
Type: Sitecore.Data.Query..::..ElementBase
Element.

See Also

Ancestor Class
Sitecore.Data.Query Namespace


Ancestor Methods

[image] [image]

Sitecore 6.4.1 API
Ancestor Methods
Ancestor Class See Also Send Feedback

The Ancestor type exposes the following members.

Methods

 | Name | Description
Protected method | Break | Breaks the query. (Inherited from Step.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Overrides Opcode..::..Evaluate(Query, QueryContext).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetContextNode | Gets the context node.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Overrides Step..::..Print(HtmlTextWriter).)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Ancestor Class
Sitecore.Data.Query Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
Ancestor..::..Evaluate Method
Ancestor Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Object Evaluate(
    Query query,
    QueryContext contextNode
)
Visual Basic
Public Overrides Function Evaluate ( _
    query As Query, _
    contextNode As QueryContext _
) As Object
Visual C++
public:
virtual Object^ Evaluate(
    Query^ query,
    QueryContext^ contextNode
) override

Parameters

query
Type: Sitecore.Data.Query..::..Query
Query.
contextNode
Type: Sitecore.Data.Query..::..QueryContext
Context node.

Return Value

The result of the evaluation.

See Also

Ancestor Class
Sitecore.Data.Query Namespace


GetContextNode Method

[image]

Sitecore 6.4.1 API
Ancestor..::..GetContextNode Method
Ancestor Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual QueryContext GetContextNode(
    QueryContext node
)
Visual Basic
Protected Overridable Function GetContextNode ( _
    node As QueryContext _
) As QueryContext
Visual C++
protected:
virtual QueryContext^ GetContextNode(
    QueryContext^ node
)

Parameters

node
Type: Sitecore.Data.Query..::..QueryContext
Node.

Return Value

The context node.

See Also

Ancestor Class
Sitecore.Data.Query Namespace


Print Method

[image]

Sitecore 6.4.1 API
Ancestor..::..Print Method
Ancestor Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Print(
    HtmlTextWriter output
)
Visual Basic
Public Overrides Sub Print ( _
    output As HtmlTextWriter _
)
Visual C++
public:
virtual void Print(
    HtmlTextWriter^ output
) override

Parameters

output
Type: System.Web.UI..::..HtmlTextWriter
Output.

See Also

Ancestor Class
Sitecore.Data.Query Namespace


Ancestor Properties

[image] [image]

Sitecore 6.4.1 API
Ancestor Properties
Ancestor Class See Also Send Feedback

The Ancestor type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the name.
Public property | NextStep | Gets or sets the next step. (Inherited from Step.)
Public property | Predicate | Gets the predicate.

See Also

Ancestor Class
Sitecore.Data.Query Namespace


Name Property

[image]

Sitecore 6.4.1 API
Ancestor..::..Name Property
Ancestor Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

Ancestor Class
Sitecore.Data.Query Namespace


Predicate Property

[image]

Sitecore 6.4.1 API
Ancestor..::..Predicate Property
Ancestor Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Predicate Predicate { get; }
Visual Basic
Public ReadOnly Property Predicate As Predicate
    Get
Visual C++
public:
property Predicate^ Predicate {
    Predicate^ get ();
}

Field Value

The predicate.

See Also

Ancestor Class
Sitecore.Data.Query Namespace


AncestorOrSelf Class

[image]

Sitecore 6.4.1 API
AncestorOrSelf Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class AncestorOrSelf : Ancestor
Visual Basic
Public Class AncestorOrSelf _
    Inherits Ancestor
Visual C++
public ref class AncestorOrSelf : public Ancestor

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..Opcode
Sitecore.Data.Query..::..Step
Sitecore.Data.Query..::..Ancestor
Sitecore.Data.Query..::..AncestorOrSelf

See Also

AncestorOrSelf Members
Sitecore.Data.Query Namespace


AncestorOrSelf Members

[image] [image]

Sitecore 6.4.1 API
AncestorOrSelf Members
AncestorOrSelf Class Constructors Methods Properties See Also Send Feedback

The AncestorOrSelf type exposes the following members.

Constructors

 | Name | Description
Public method | AncestorOrSelf | Creates a new AncestorOrSelf instance.

Methods

 | Name | Description
Protected method | Break | Breaks the query. (Inherited from Step.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Inherited from Ancestor.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetContextNode | Gets the context node. (Overrides Ancestor..::..GetContextNode(QueryContext).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from Ancestor.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | Gets the name. (Inherited from Ancestor.)
Public property | NextStep | Gets or sets the next step. (Inherited from Step.)
Public property | Predicate | Gets the predicate. (Inherited from Ancestor.)

See Also

AncestorOrSelf Class
Sitecore.Data.Query Namespace


AncestorOrSelf Constructor

[image]

Sitecore 6.4.1 API
AncestorOrSelf Constructor
AncestorOrSelf Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AncestorOrSelf(
    ElementBase element
)
Visual Basic
Public Sub New ( _
    element As ElementBase _
)
Visual C++
public:
AncestorOrSelf(
    ElementBase^ element
)

Parameters

element
Type: Sitecore.Data.Query..::..ElementBase
Element.

See Also

AncestorOrSelf Class
Sitecore.Data.Query Namespace


AncestorOrSelf Methods

[image] [image]

Sitecore 6.4.1 API
AncestorOrSelf Methods
AncestorOrSelf Class See Also Send Feedback

The AncestorOrSelf type exposes the following members.

Methods

 | Name | Description
Protected method | Break | Breaks the query. (Inherited from Step.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Inherited from Ancestor.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetContextNode | Gets the context node. (Overrides Ancestor..::..GetContextNode(QueryContext).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from Ancestor.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AncestorOrSelf Class
Sitecore.Data.Query Namespace


GetContextNode Method

[image]

Sitecore 6.4.1 API
AncestorOrSelf..::..GetContextNode Method
AncestorOrSelf Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override QueryContext GetContextNode(
    QueryContext node
)
Visual Basic
Protected Overrides Function GetContextNode ( _
    node As QueryContext _
) As QueryContext
Visual C++
protected:
virtual QueryContext^ GetContextNode(
    QueryContext^ node
) override

Parameters

node
Type: Sitecore.Data.Query..::..QueryContext
Node.

Return Value

The context node.

See Also

AncestorOrSelf Class
Sitecore.Data.Query Namespace


AndOperator Class

[image]

Sitecore 6.4.1 API
AndOperator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class AndOperator : BinaryOperator
Visual Basic
Public Class AndOperator _
    Inherits BinaryOperator
Visual C++
public ref class AndOperator : public BinaryOperator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..Opcode
Sitecore.Data.Query..::..BinaryOperator
Sitecore.Data.Query..::..AndOperator

See Also

AndOperator Members
Sitecore.Data.Query Namespace


AndOperator Members

[image] [image]

Sitecore 6.4.1 API
AndOperator Members
AndOperator Class Constructors Methods Properties See Also Send Feedback

The AndOperator type exposes the following members.

Constructors

 | Name | Description
Public method | AndOperator | Creates a new AndOperator instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Inherited from BinaryOperator.)
Public method | EvaluateOperands | Evaluates the expression. (Overrides BinaryOperator..::..EvaluateOperands(Object, Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from BinaryOperator.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Left | Gets the left expression. (Inherited from BinaryOperator.)
Public property | Right | Gets the right expression. (Inherited from BinaryOperator.)

See Also

AndOperator Class
Sitecore.Data.Query Namespace


AndOperator Constructor

[image]

Sitecore 6.4.1 API
AndOperator Constructor
AndOperator Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AndOperator(
    Opcode left,
    Opcode right
)
Visual Basic
Public Sub New ( _
    left As Opcode, _
    right As Opcode _
)
Visual C++
public:
AndOperator(
    Opcode^ left,
    Opcode^ right
)

Parameters

left
Type: Sitecore.Data.Query..::..Opcode
Left expression.
right
Type: Sitecore.Data.Query..::..Opcode
Right expression.

See Also

AndOperator Class
Sitecore.Data.Query Namespace


AndOperator Methods

[image] [image]

Sitecore 6.4.1 API
AndOperator Methods
AndOperator Class See Also Send Feedback

The AndOperator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Inherited from BinaryOperator.)
Public method | EvaluateOperands | Evaluates the expression. (Overrides BinaryOperator..::..EvaluateOperands(Object, Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from BinaryOperator.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AndOperator Class
Sitecore.Data.Query Namespace


EvaluateOperands Method

[image]

Sitecore 6.4.1 API
AndOperator..::..EvaluateOperands Method
AndOperator Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Object EvaluateOperands(
    Object left,
    Object right
)
Visual Basic
Public Overrides Function EvaluateOperands ( _
    left As Object, _
    right As Object _
) As Object
Visual C++
public:
virtual Object^ EvaluateOperands(
    Object^ left,
    Object^ right
) override

Parameters

left
Type: System..::..Object
Left expression.
right
Type: System..::..Object
Right expression.

Return Value

The result of the evaluation.

See Also

AndOperator Class
Sitecore.Data.Query Namespace


AndOperator Properties

[image] [image]

Sitecore 6.4.1 API
AndOperator Properties
AndOperator Class See Also Send Feedback

The AndOperator type exposes the following members.

Properties

 | Name | Description
Public property | Left | Gets the left expression. (Inherited from BinaryOperator.)
Public property | Right | Gets the right expression. (Inherited from BinaryOperator.)

See Also

AndOperator Class
Sitecore.Data.Query Namespace


BinaryOperator Class

[image]

Sitecore 6.4.1 API
BinaryOperator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class BinaryOperator : Opcode
Visual Basic
Public MustInherit Class BinaryOperator _
    Inherits Opcode
Visual C++
public ref class BinaryOperator abstract : public Opcode

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..Opcode
Sitecore.Data.Query..::..BinaryOperator
Sitecore.Data.Query..::..AddOperator
Sitecore.Data.Query..::..AndOperator
Sitecore.Data.Query..::..DivideOperator
Sitecore.Data.Query..::..EqualsOperator
Sitecore.Data.Query..::..GreaterOperator
Sitecore.Data.Query..::..GreaterOrEqualsOperator
Sitecore.Data.Query..::..MinusOperator
Sitecore.Data.Query..::..ModulusOperator
Sitecore.Data.Query..::..MultiplyOperator
Sitecore.Data.Query..::..OrOperator
Sitecore.Data.Query..::..SmallerOperator
Sitecore.Data.Query..::..SmallerOrEqualsOperator
Sitecore.Data.Query..::..UnequalsOperator
Sitecore.Data.Query..::..XorOperator

See Also

BinaryOperator Members
Sitecore.Data.Query Namespace


BinaryOperator Members

[image] [image]

Sitecore 6.4.1 API
BinaryOperator Members
BinaryOperator Class Constructors Methods Properties See Also Send Feedback

The BinaryOperator type exposes the following members.

Constructors

 | Name | Description
Protected method | BinaryOperator | Creates a new BinaryOperator instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Overrides Opcode..::..Evaluate(Query, QueryContext).)
Public method | EvaluateOperands | Evaluates the expression.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Overrides Opcode..::..Print(HtmlTextWriter).)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Left | Gets the left expression.
Public property | Right | Gets the right expression.

See Also

BinaryOperator Class
Sitecore.Data.Query Namespace


BinaryOperator Constructor

[image]

Sitecore 6.4.1 API
BinaryOperator Constructor
BinaryOperator Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected BinaryOperator(
    Opcode left,
    Opcode right
)
Visual Basic
Protected Sub New ( _
    left As Opcode, _
    right As Opcode _
)
Visual C++
protected:
BinaryOperator(
    Opcode^ left,
    Opcode^ right
)

Parameters

left
Type: Sitecore.Data.Query..::..Opcode
Left expression.
right
Type: Sitecore.Data.Query..::..Opcode
Right expression.

See Also

BinaryOperator Class
Sitecore.Data.Query Namespace


BinaryOperator Methods

[image] [image]

Sitecore 6.4.1 API
BinaryOperator Methods
BinaryOperator Class See Also Send Feedback

The BinaryOperator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Overrides Opcode..::..Evaluate(Query, QueryContext).)
Public method | EvaluateOperands | Evaluates the expression.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Overrides Opcode..::..Print(HtmlTextWriter).)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BinaryOperator Class
Sitecore.Data.Query Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
BinaryOperator..::..Evaluate Method
BinaryOperator Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Object Evaluate(
    Query query,
    QueryContext node
)
Visual Basic
Public Overrides Function Evaluate ( _
    query As Query, _
    node As QueryContext _
) As Object
Visual C++
public:
virtual Object^ Evaluate(
    Query^ query,
    QueryContext^ node
) override

Parameters

query
Type: Sitecore.Data.Query..::..Query
Query.
node
Type: Sitecore.Data.Query..::..QueryContext
Node.

Return Value

The result of the evaluation.

See Also

BinaryOperator Class
Sitecore.Data.Query Namespace


EvaluateOperands Method

[image]

Sitecore 6.4.1 API
BinaryOperator..::..EvaluateOperands Method
BinaryOperator Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract Object EvaluateOperands(
    Object left,
    Object right
)
Visual Basic
Public MustOverride Function EvaluateOperands ( _
    left As Object, _
    right As Object _
) As Object
Visual C++
public:
virtual Object^ EvaluateOperands(
    Object^ left,
    Object^ right
) abstract

Parameters

left
Type: System..::..Object
Left expression.
right
Type: System..::..Object
Right expression.

Return Value

The result of the evaluation.

See Also

BinaryOperator Class
Sitecore.Data.Query Namespace


Print Method

[image]

Sitecore 6.4.1 API
BinaryOperator..::..Print Method
BinaryOperator Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Print(
    HtmlTextWriter output
)
Visual Basic
Public Overrides Sub Print ( _
    output As HtmlTextWriter _
)
Visual C++
public:
virtual void Print(
    HtmlTextWriter^ output
) override

Parameters

output
Type: System.Web.UI..::..HtmlTextWriter
Output.

See Also

BinaryOperator Class
Sitecore.Data.Query Namespace


BinaryOperator Properties

[image] [image]

Sitecore 6.4.1 API
BinaryOperator Properties
BinaryOperator Class See Also Send Feedback

The BinaryOperator type exposes the following members.

Properties

 | Name | Description
Public property | Left | Gets the left expression.
Public property | Right | Gets the right expression.

See Also

BinaryOperator Class
Sitecore.Data.Query Namespace


Left Property

[image]

Sitecore 6.4.1 API
BinaryOperator..::..Left Property
BinaryOperator Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Opcode Left { get; }
Visual Basic
Public ReadOnly Property Left As Opcode
    Get
Visual C++
public:
property Opcode^ Left {
    Opcode^ get ();
}

Field Value

The left.

See Also

BinaryOperator Class
Sitecore.Data.Query Namespace


Right Property

[image]

Sitecore 6.4.1 API
BinaryOperator..::..Right Property
BinaryOperator Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Opcode Right { get; }
Visual Basic
Public ReadOnly Property Right As Opcode
    Get
Visual C++
public:
property Opcode^ Right {
    Opcode^ get ();
}

Field Value

The right.

See Also

BinaryOperator Class
Sitecore.Data.Query Namespace


BooleanValue Class

[image]

Sitecore 6.4.1 API
BooleanValue Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class BooleanValue : Opcode
Visual Basic
Public Class BooleanValue _
    Inherits Opcode
Visual C++
public ref class BooleanValue : public Opcode

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..Opcode
Sitecore.Data.Query..::..BooleanValue

See Also

BooleanValue Members
Sitecore.Data.Query Namespace


BooleanValue Members

[image] [image]

Sitecore 6.4.1 API
BooleanValue Members
BooleanValue Class Constructors Methods Properties See Also Send Feedback

The BooleanValue type exposes the following members.

Constructors

 | Name | Description
Public method | BooleanValue | Creates a new BooleanValue instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Overrides Opcode..::..Evaluate(Query, QueryContext).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from Opcode.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Value | Gets a value indicating whether this BooleanValue is value.

See Also

BooleanValue Class
Sitecore.Data.Query Namespace


BooleanValue Constructor

[image]

Sitecore 6.4.1 API
BooleanValue Constructor
BooleanValue Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BooleanValue(
    bool value
)
Visual Basic
Public Sub New ( _
    value As Boolean _
)
Visual C++
public:
BooleanValue(
    bool value
)

Parameters

value
Type: System..::..Boolean
Value.

See Also

BooleanValue Class
Sitecore.Data.Query Namespace


BooleanValue Methods

[image] [image]

Sitecore 6.4.1 API
BooleanValue Methods
BooleanValue Class See Also Send Feedback

The BooleanValue type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Overrides Opcode..::..Evaluate(Query, QueryContext).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from Opcode.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BooleanValue Class
Sitecore.Data.Query Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
BooleanValue..::..Evaluate Method
BooleanValue Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Object Evaluate(
    Query query,
    QueryContext node
)
Visual Basic
Public Overrides Function Evaluate ( _
    query As Query, _
    node As QueryContext _
) As Object
Visual C++
public:
virtual Object^ Evaluate(
    Query^ query,
    QueryContext^ node
) override

Parameters

query
Type: Sitecore.Data.Query..::..Query
Query.
node
Type: Sitecore.Data.Query..::..QueryContext
Node.

Return Value

The result of the evaluatation.

See Also

BooleanValue Class
Sitecore.Data.Query Namespace


BooleanValue Properties

[image] [image]

Sitecore 6.4.1 API
BooleanValue Properties
BooleanValue Class See Also Send Feedback

The BooleanValue type exposes the following members.

Properties

 | Name | Description
Public property | Value | Gets a value indicating whether this BooleanValue is value.

See Also

BooleanValue Class
Sitecore.Data.Query Namespace


Value Property

[image]

Sitecore 6.4.1 API
BooleanValue..::..Value Property
BooleanValue Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Value { get; }
Visual Basic
Public ReadOnly Property Value As Boolean
    Get
Visual C++
public:
property bool Value {
    bool get ();
}

Field Value

true if value; otherwise, false.

See Also

BooleanValue Class
Sitecore.Data.Query Namespace


Children Class

[image]

Sitecore 6.4.1 API
Children Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Children : Step
Visual Basic
Public Class Children _
    Inherits Step
Visual C++
public ref class Children : public Step

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..Opcode
Sitecore.Data.Query..::..Step
Sitecore.Data.Query..::..Children

See Also

Children Members
Sitecore.Data.Query Namespace


Children Members

[image] [image]

Sitecore 6.4.1 API
Children Members
Children Class Constructors Methods Properties See Also Send Feedback

The Children type exposes the following members.

Constructors

 | Name | Description
Public method | Children | Creates a new Children instance.

Methods

 | Name | Description
Protected method | Break | Breaks the query. (Inherited from Step.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Overrides Opcode..::..Evaluate(Query, QueryContext).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Overrides Step..::..Print(HtmlTextWriter).)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | Gets the name.
Public property | NextStep | Gets or sets the next step. (Inherited from Step.)
Public property | Predicate | Gets the predicate.

See Also

Children Class
Sitecore.Data.Query Namespace


Children Constructor

[image]

Sitecore 6.4.1 API
Children Constructor
Children Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Children(
    ElementBase element
)
Visual Basic
Public Sub New ( _
    element As ElementBase _
)
Visual C++
public:
Children(
    ElementBase^ element
)

Parameters

element
Type: Sitecore.Data.Query..::..ElementBase
Element.

See Also

Children Class
Sitecore.Data.Query Namespace


Children Methods

[image] [image]

Sitecore 6.4.1 API
Children Methods
Children Class See Also Send Feedback

The Children type exposes the following members.

Methods

 | Name | Description
Protected method | Break | Breaks the query. (Inherited from Step.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Overrides Opcode..::..Evaluate(Query, QueryContext).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Overrides Step..::..Print(HtmlTextWriter).)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Children Class
Sitecore.Data.Query Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
Children..::..Evaluate Method
Children Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Object Evaluate(
    Query query,
    QueryContext node
)
Visual Basic
Public Overrides Function Evaluate ( _
    query As Query, _
    node As QueryContext _
) As Object
Visual C++
public:
virtual Object^ Evaluate(
    Query^ query,
    QueryContext^ node
) override

Parameters

query
Type: Sitecore.Data.Query..::..Query
Query.
node
Type: Sitecore.Data.Query..::..QueryContext
Node.

Return Value

The result of the evaluation.

See Also

Children Class
Sitecore.Data.Query Namespace


Print Method

[image]

Sitecore 6.4.1 API
Children..::..Print Method
Children Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Print(
    HtmlTextWriter output
)
Visual Basic
Public Overrides Sub Print ( _
    output As HtmlTextWriter _
)
Visual C++
public:
virtual void Print(
    HtmlTextWriter^ output
) override

Parameters

output
Type: System.Web.UI..::..HtmlTextWriter
Output.

See Also

Children Class
Sitecore.Data.Query Namespace


Children Properties

[image] [image]

Sitecore 6.4.1 API
Children Properties
Children Class See Also Send Feedback

The Children type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the name.
Public property | NextStep | Gets or sets the next step. (Inherited from Step.)
Public property | Predicate | Gets the predicate.

See Also

Children Class
Sitecore.Data.Query Namespace


Predicate Property

[image]

Sitecore 6.4.1 API
Children..::..Predicate Property
Children Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Predicate Predicate { get; }
Visual Basic
Public ReadOnly Property Predicate As Predicate
    Get
Visual C++
public:
property Predicate^ Predicate {
    Predicate^ get ();
}

Field Value

The predicate.

See Also

Children Class
Sitecore.Data.Query Namespace


Descendant Class

[image]

Sitecore 6.4.1 API
Descendant Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Descendant : Step
Visual Basic
Public Class Descendant _
    Inherits Step
Visual C++
public ref class Descendant : public Step

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..Opcode
Sitecore.Data.Query..::..Step
Sitecore.Data.Query..::..Descendant
Sitecore.Data.Query..::..DescendantOrSelf

See Also

Descendant Members
Sitecore.Data.Query Namespace


Descendant Members

[image] [image]

Sitecore 6.4.1 API
Descendant Members
Descendant Class Constructors Methods Properties See Also Send Feedback

The Descendant type exposes the following members.

Constructors

 | Name | Description
Public method | Descendant | Creates a new Descendant instance.

Methods

 | Name | Description
Protected method | Break | Breaks the query. (Inherited from Step.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Overrides Opcode..::..Evaluate(Query, QueryContext).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Iterate | Iterates the specified query.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Overrides Step..::..Print(HtmlTextWriter).)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Protected method | TestNode | Tests the node againt the predicate.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | Gets the name.
Public property | NextStep | Gets or sets the next step. (Inherited from Step.)
Public property | Predicate | Gets the predicate.

See Also

Descendant Class
Sitecore.Data.Query Namespace


Descendant Constructor

[image]

Sitecore 6.4.1 API
Descendant Constructor
Descendant Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Descendant(
    ElementBase element
)
Visual Basic
Public Sub New ( _
    element As ElementBase _
)
Visual C++
public:
Descendant(
    ElementBase^ element
)

Parameters

element
Type: Sitecore.Data.Query..::..ElementBase
Element.

See Also

Descendant Class
Sitecore.Data.Query Namespace


Descendant Methods

[image] [image]

Sitecore 6.4.1 API
Descendant Methods
Descendant Class See Also Send Feedback

The Descendant type exposes the following members.

Methods

 | Name | Description
Protected method | Break | Breaks the query. (Inherited from Step.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Overrides Opcode..::..Evaluate(Query, QueryContext).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Iterate | Iterates the specified query.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Overrides Step..::..Print(HtmlTextWriter).)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Protected method | TestNode | Tests the node againt the predicate.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Descendant Class
Sitecore.Data.Query Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
Descendant..::..Evaluate Method
Descendant Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Object Evaluate(
    Query query,
    QueryContext node
)
Visual Basic
Public Overrides Function Evaluate ( _
    query As Query, _
    node As QueryContext _
) As Object
Visual C++
public:
virtual Object^ Evaluate(
    Query^ query,
    QueryContext^ node
) override

Parameters

query
Type: Sitecore.Data.Query..::..Query
Query.
node
Type: Sitecore.Data.Query..::..QueryContext
Node.

Return Value

The result of the evaluation.

See Also

Descendant Class
Sitecore.Data.Query Namespace


Iterate Method

[image]

Sitecore 6.4.1 API
Descendant..::..Iterate Method
Descendant Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void Iterate(
    Query query,
    QueryContext node,
    ref Object result
)
Visual Basic
Protected Sub Iterate ( _
    query As Query, _
    node As QueryContext, _
    ByRef result As Object _
)
Visual C++
protected:
void Iterate(
    Query^ query,
    QueryContext^ node,
    Object^% result
)

Parameters

query
Type: Sitecore.Data.Query..::..Query
Query.
node
Type: Sitecore.Data.Query..::..QueryContext
Node.
result
Type: System..::..Object %
Result.

See Also

Descendant Class
Sitecore.Data.Query Namespace


Print Method

[image]

Sitecore 6.4.1 API
Descendant..::..Print Method
Descendant Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Print(
    HtmlTextWriter output
)
Visual Basic
Public Overrides Sub Print ( _
    output As HtmlTextWriter _
)
Visual C++
public:
virtual void Print(
    HtmlTextWriter^ output
) override

Parameters

output
Type: System.Web.UI..::..HtmlTextWriter
Output.

See Also

Descendant Class
Sitecore.Data.Query Namespace


TestNode Method

[image]

Sitecore 6.4.1 API
Descendant..::..TestNode Method
Descendant Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void TestNode(
    Query query,
    QueryContext node,
    ref Object result
)
Visual Basic
Protected Sub TestNode ( _
    query As Query, _
    node As QueryContext, _
    ByRef result As Object _
)
Visual C++
protected:
void TestNode(
    Query^ query,
    QueryContext^ node,
    Object^% result
)

Parameters

query
Type: Sitecore.Data.Query..::..Query
Query.
node
Type: Sitecore.Data.Query..::..QueryContext
Node.
result
Type: System..::..Object %
Result.

See Also

Descendant Class
Sitecore.Data.Query Namespace


Descendant Properties

[image] [image]

Sitecore 6.4.1 API
Descendant Properties
Descendant Class See Also Send Feedback

The Descendant type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the name.
Public property | NextStep | Gets or sets the next step. (Inherited from Step.)
Public property | Predicate | Gets the predicate.

See Also

Descendant Class
Sitecore.Data.Query Namespace


Name Property

[image]

Sitecore 6.4.1 API
Descendant..::..Name Property
Descendant Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

Descendant Class
Sitecore.Data.Query Namespace


Predicate Property

[image]

Sitecore 6.4.1 API
Descendant..::..Predicate Property
Descendant Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Predicate Predicate { get; }
Visual Basic
Public ReadOnly Property Predicate As Predicate
    Get
Visual C++
public:
property Predicate^ Predicate {
    Predicate^ get ();
}

Field Value

The predicate.

See Also

Descendant Class
Sitecore.Data.Query Namespace


DescendantOrSelf Class

[image]

Sitecore 6.4.1 API
DescendantOrSelf Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DescendantOrSelf : Descendant
Visual Basic
Public Class DescendantOrSelf _
    Inherits Descendant
Visual C++
public ref class DescendantOrSelf : public Descendant

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..Opcode
Sitecore.Data.Query..::..Step
Sitecore.Data.Query..::..Descendant
Sitecore.Data.Query..::..DescendantOrSelf

See Also

DescendantOrSelf Members
Sitecore.Data.Query Namespace


DescendantOrSelf Members

[image] [image]

Sitecore 6.4.1 API
DescendantOrSelf Members
DescendantOrSelf Class Constructors Methods Properties See Also Send Feedback

The DescendantOrSelf type exposes the following members.

Constructors

 | Name | Description
Public method | DescendantOrSelf | Creates a new DescendantOrSelf instance.

Methods

 | Name | Description
Protected method | Break | Breaks the query. (Inherited from Step.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Overrides Descendant..::..Evaluate(Query, QueryContext).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Iterate | Iterates the specified query. (Inherited from Descendant.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from Descendant.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Protected method | TestNode | Tests the node againt the predicate. (Inherited from Descendant.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | Gets the name. (Inherited from Descendant.)
Public property | NextStep | Gets or sets the next step. (Inherited from Step.)
Public property | Predicate | Gets the predicate. (Inherited from Descendant.)

See Also

DescendantOrSelf Class
Sitecore.Data.Query Namespace


DescendantOrSelf Constructor

[image]

Sitecore 6.4.1 API
DescendantOrSelf Constructor
DescendantOrSelf Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DescendantOrSelf(
    ElementBase element
)
Visual Basic
Public Sub New ( _
    element As ElementBase _
)
Visual C++
public:
DescendantOrSelf(
    ElementBase^ element
)

Parameters

element
Type: Sitecore.Data.Query..::..ElementBase
Element.

See Also

DescendantOrSelf Class
Sitecore.Data.Query Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
DescendantOrSelf..::..Evaluate Method
DescendantOrSelf Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Object Evaluate(
    Query query,
    QueryContext node
)
Visual Basic
Public Overrides Function Evaluate ( _
    query As Query, _
    node As QueryContext _
) As Object
Visual C++
public:
virtual Object^ Evaluate(
    Query^ query,
    QueryContext^ node
) override

Parameters

query
Type: Sitecore.Data.Query..::..Query
Query.
node
Type: Sitecore.Data.Query..::..QueryContext
Node.

Return Value

The result of the evaluation.

See Also

DescendantOrSelf Class
Sitecore.Data.Query Namespace


DescendantOrSelf Properties

[image] [image]

Sitecore 6.4.1 API
DescendantOrSelf Properties
DescendantOrSelf Class See Also Send Feedback

The DescendantOrSelf type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the name. (Inherited from Descendant.)
Public property | NextStep | Gets or sets the next step. (Inherited from Step.)
Public property | Predicate | Gets the predicate. (Inherited from Descendant.)

See Also

DescendantOrSelf Class
Sitecore.Data.Query Namespace


DivideOperator Class

[image]

Sitecore 6.4.1 API
DivideOperator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DivideOperator : BinaryOperator
Visual Basic
Public Class DivideOperator _
    Inherits BinaryOperator
Visual C++
public ref class DivideOperator : public BinaryOperator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..Opcode
Sitecore.Data.Query..::..BinaryOperator
Sitecore.Data.Query..::..DivideOperator

See Also

DivideOperator Members
Sitecore.Data.Query Namespace


DivideOperator Members

[image] [image]

Sitecore 6.4.1 API
DivideOperator Members
DivideOperator Class Constructors Methods Properties See Also Send Feedback

The DivideOperator type exposes the following members.

Constructors

 | Name | Description
Public method | DivideOperator | Creates a new DivideOperator instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Inherited from BinaryOperator.)
Public method | EvaluateOperands | Evaluates the expression. (Overrides BinaryOperator..::..EvaluateOperands(Object, Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from BinaryOperator.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Left | Gets the left expression. (Inherited from BinaryOperator.)
Public property | Right | Gets the right expression. (Inherited from BinaryOperator.)

See Also

DivideOperator Class
Sitecore.Data.Query Namespace


DivideOperator Constructor

[image]

Sitecore 6.4.1 API
DivideOperator Constructor
DivideOperator Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DivideOperator(
    Opcode left,
    Opcode right
)
Visual Basic
Public Sub New ( _
    left As Opcode, _
    right As Opcode _
)
Visual C++
public:
DivideOperator(
    Opcode^ left,
    Opcode^ right
)

Parameters

left
Type: Sitecore.Data.Query..::..Opcode
Left expression.
right
Type: Sitecore.Data.Query..::..Opcode
Right expression.

See Also

DivideOperator Class
Sitecore.Data.Query Namespace


DivideOperator Methods

[image] [image]

Sitecore 6.4.1 API
DivideOperator Methods
DivideOperator Class See Also Send Feedback

The DivideOperator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Inherited from BinaryOperator.)
Public method | EvaluateOperands | Evaluates the expression. (Overrides BinaryOperator..::..EvaluateOperands(Object, Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from BinaryOperator.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DivideOperator Class
Sitecore.Data.Query Namespace


EvaluateOperands Method

[image]

Sitecore 6.4.1 API
DivideOperator..::..EvaluateOperands Method
DivideOperator Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Object EvaluateOperands(
    Object left,
    Object right
)
Visual Basic
Public Overrides Function EvaluateOperands ( _
    left As Object, _
    right As Object _
) As Object
Visual C++
public:
virtual Object^ EvaluateOperands(
    Object^ left,
    Object^ right
) override

Parameters

left
Type: System..::..Object
Left expression.
right
Type: System..::..Object
Right expression.

Return Value

The result of the evaluation.

See Also

DivideOperator Class
Sitecore.Data.Query Namespace


DivideOperator Properties

[image] [image]

Sitecore 6.4.1 API
DivideOperator Properties
DivideOperator Class See Also Send Feedback

The DivideOperator type exposes the following members.

Properties

 | Name | Description
Public property | Left | Gets the left expression. (Inherited from BinaryOperator.)
Public property | Right | Gets the right expression. (Inherited from BinaryOperator.)

See Also

DivideOperator Class
Sitecore.Data.Query Namespace


ElementBase Members

[image] [image]

Sitecore 6.4.1 API
ElementBase Members
ElementBase Class Constructors Methods Properties See Also Send Feedback

The ElementBase type exposes the following members.

Constructors

 | Name | Description
Protected method | ElementBase | Creates a new ElementBase instance.

Methods

 | Name | Description
Protected method | Break | Breaks the query. (Inherited from Step.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Inherited from Opcode.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Overrides Step..::..Print(HtmlTextWriter).)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | Gets the name.
Public property | NextStep | Gets or sets the next step. (Inherited from Step.)

See Also

ElementBase Class
Sitecore.Data.Query Namespace


ElementBase Constructor

[image]

Sitecore 6.4.1 API
ElementBase Constructor
ElementBase Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected ElementBase(
    string name
)
Visual Basic
Protected Sub New ( _
    name As String _
)
Visual C++
protected:
ElementBase(
    String^ name
)

Parameters

name
Type: System..::..String
Name.

See Also

ElementBase Class
Sitecore.Data.Query Namespace


ElementBase Methods

[image] [image]

Sitecore 6.4.1 API
ElementBase Methods
ElementBase Class See Also Send Feedback

The ElementBase type exposes the following members.

Methods

 | Name | Description
Protected method | Break | Breaks the query. (Inherited from Step.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Inherited from Opcode.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Overrides Step..::..Print(HtmlTextWriter).)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementBase Class
Sitecore.Data.Query Namespace


Print Method

[image]

Sitecore 6.4.1 API
ElementBase..::..Print Method
ElementBase Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Print(
    HtmlTextWriter output
)
Visual Basic
Public Overrides Sub Print ( _
    output As HtmlTextWriter _
)
Visual C++
public:
virtual void Print(
    HtmlTextWriter^ output
) override

Parameters

output
Type: System.Web.UI..::..HtmlTextWriter
Output.

See Also

ElementBase Class
Sitecore.Data.Query Namespace


ElementBase Properties

[image] [image]

Sitecore 6.4.1 API
ElementBase Properties
ElementBase Class See Also Send Feedback

The ElementBase type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the name.
Public property | NextStep | Gets or sets the next step. (Inherited from Step.)

See Also

ElementBase Class
Sitecore.Data.Query Namespace


Name Property

[image]

Sitecore 6.4.1 API
ElementBase..::..Name Property
ElementBase Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

ElementBase Class
Sitecore.Data.Query Namespace


EqualsOperator Class

[image]

Sitecore 6.4.1 API
EqualsOperator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class EqualsOperator : BinaryOperator
Visual Basic
Public Class EqualsOperator _
    Inherits BinaryOperator
Visual C++
public ref class EqualsOperator : public BinaryOperator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..Opcode
Sitecore.Data.Query..::..BinaryOperator
Sitecore.Data.Query..::..EqualsOperator

See Also

EqualsOperator Members
Sitecore.Data.Query Namespace


EqualsOperator Members

[image] [image]

Sitecore 6.4.1 API
EqualsOperator Members
EqualsOperator Class Constructors Methods Properties See Also Send Feedback

The EqualsOperator type exposes the following members.

Constructors

 | Name | Description
Public method | EqualsOperator | Creates a new EqualsOperator instance.

Methods

 | Name | Description
 | Compare | Compares the specified expressions.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Inherited from BinaryOperator.)
Public method | EvaluateOperands | Evaluates the expression. (Overrides BinaryOperator..::..EvaluateOperands(Object, Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from BinaryOperator.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Left | Gets the left expression. (Inherited from BinaryOperator.)
Public property | Right | Gets the right expression. (Inherited from BinaryOperator.)

See Also

EqualsOperator Class
Sitecore.Data.Query Namespace


EqualsOperator Constructor

[image]

Sitecore 6.4.1 API
EqualsOperator Constructor
EqualsOperator Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public EqualsOperator(
    Opcode left,
    Opcode right
)
Visual Basic
Public Sub New ( _
    left As Opcode, _
    right As Opcode _
)
Visual C++
public:
EqualsOperator(
    Opcode^ left,
    Opcode^ right
)

Parameters

left
Type: Sitecore.Data.Query..::..Opcode
Left expression.
right
Type: Sitecore.Data.Query..::..Opcode
Right expression.

See Also

EqualsOperator Class
Sitecore.Data.Query Namespace


EqualsOperator Methods

[image] [image]

Sitecore 6.4.1 API
EqualsOperator Methods
EqualsOperator Class See Also Send Feedback

The EqualsOperator type exposes the following members.

Methods

 | Name | Description
 | Compare | Compares the specified expressions.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Inherited from BinaryOperator.)
Public method | EvaluateOperands | Evaluates the expression. (Overrides BinaryOperator..::..EvaluateOperands(Object, Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from BinaryOperator.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EqualsOperator Class
Sitecore.Data.Query Namespace


Compare Method

[image]

Sitecore 6.4.1 API
EqualsOperator..::..Compare Method
EqualsOperator Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool Compare(
    Object left,
    Object right,
    out bool handled
)
Visual Basic
Public Shared Function Compare ( _
    left As Object, _
    right As Object, _
    <OutAttribute> ByRef handled As Boolean _
) As Boolean
Visual C++
public:
static bool Compare(
    Object^ left,
    Object^ right,
    [OutAttribute] bool% handled
)

Parameters

left
Type: System..::..Object
Left expression.
right
Type: System..::..Object
Right expression.
handled
Type: System..::..Boolean %
Handled.

Return Value

The compare.

See Also

EqualsOperator Class
Sitecore.Data.Query Namespace


EvaluateOperands Method

[image]

Sitecore 6.4.1 API
EqualsOperator..::..EvaluateOperands Method
EqualsOperator Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Object EvaluateOperands(
    Object left,
    Object right
)
Visual Basic
Public Overrides Function EvaluateOperands ( _
    left As Object, _
    right As Object _
) As Object
Visual C++
public:
virtual Object^ EvaluateOperands(
    Object^ left,
    Object^ right
) override

Parameters

left
Type: System..::..Object
Left expression.
right
Type: System..::..Object
Right expression.

Return Value

The result of the evaluation.

See Also

EqualsOperator Class
Sitecore.Data.Query Namespace


EqualsOperator Properties

[image] [image]

Sitecore 6.4.1 API
EqualsOperator Properties
EqualsOperator Class See Also Send Feedback

The EqualsOperator type exposes the following members.

Properties

 | Name | Description
Public property | Left | Gets the left expression. (Inherited from BinaryOperator.)
Public property | Right | Gets the right expression. (Inherited from BinaryOperator.)

See Also

EqualsOperator Class
Sitecore.Data.Query Namespace


FieldElement Class

[image]

Sitecore 6.4.1 API
FieldElement Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FieldElement : ElementBase
Visual Basic
Public Class FieldElement _
    Inherits ElementBase
Visual C++
public ref class FieldElement : public ElementBase

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..Opcode
Sitecore.Data.Query..::..Step
Sitecore.Data.Query..::..ElementBase
Sitecore.Data.Query..::..FieldElement

See Also

FieldElement Members
Sitecore.Data.Query Namespace


FieldElement Members

[image] [image]

Sitecore 6.4.1 API
FieldElement Members
FieldElement Class Constructors Methods Properties See Also Send Feedback

The FieldElement type exposes the following members.

Constructors

 | Name | Description
Public method | FieldElement | Creates a new FieldElement instance.

Methods

 | Name | Description
Protected method | Break | Breaks the query. (Inherited from Step.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Overrides Opcode..::..Evaluate(Query, QueryContext).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from ElementBase.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | Gets the name. (Inherited from ElementBase.)
Public property | NextStep | Gets or sets the next step. (Inherited from Step.)

See Also

FieldElement Class
Sitecore.Data.Query Namespace


FieldElement Constructor

[image]

Sitecore 6.4.1 API
FieldElement Constructor
FieldElement Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FieldElement(
    string name
)
Visual Basic
Public Sub New ( _
    name As String _
)
Visual C++
public:
FieldElement(
    String^ name
)

Parameters

name
Type: System..::..String
Name.

See Also

FieldElement Class
Sitecore.Data.Query Namespace


FieldElement Methods

[image] [image]

Sitecore 6.4.1 API
FieldElement Methods
FieldElement Class See Also Send Feedback

The FieldElement type exposes the following members.

Methods

 | Name | Description
Protected method | Break | Breaks the query. (Inherited from Step.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Overrides Opcode..::..Evaluate(Query, QueryContext).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from ElementBase.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldElement Class
Sitecore.Data.Query Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
FieldElement..::..Evaluate Method
FieldElement Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Object Evaluate(
    Query query,
    QueryContext node
)
Visual Basic
Public Overrides Function Evaluate ( _
    query As Query, _
    node As QueryContext _
) As Object
Visual C++
public:
virtual Object^ Evaluate(
    Query^ query,
    QueryContext^ node
) override

Parameters

query
Type: Sitecore.Data.Query..::..Query
Query.
node
Type: Sitecore.Data.Query..::..QueryContext
Node.

Return Value

The result of the evaluation.

See Also

FieldElement Class
Sitecore.Data.Query Namespace


FieldElement Properties

[image] [image]

Sitecore 6.4.1 API
FieldElement Properties
FieldElement Class See Also Send Feedback

The FieldElement type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the name. (Inherited from ElementBase.)
Public property | NextStep | Gets or sets the next step. (Inherited from Step.)

See Also

FieldElement Class
Sitecore.Data.Query Namespace


Following Class

[image]

Sitecore 6.4.1 API
Following Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Following : Step
Visual Basic
Public Class Following _
    Inherits Step
Visual C++
public ref class Following : public Step

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..Opcode
Sitecore.Data.Query..::..Step
Sitecore.Data.Query..::..Following

See Also

Following Members
Sitecore.Data.Query Namespace


Following Members

[image] [image]

Sitecore 6.4.1 API
Following Members
Following Class Constructors Methods Properties See Also Send Feedback

The Following type exposes the following members.

Constructors

 | Name | Description
Public method | Following | Creates a new Following instance.

Methods

 | Name | Description
Protected method | Break | Breaks the query. (Inherited from Step.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Overrides Opcode..::..Evaluate(Query, QueryContext).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Overrides Step..::..Print(HtmlTextWriter).)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | NextStep | Gets or sets the next step. (Inherited from Step.)

See Also

Following Class
Sitecore.Data.Query Namespace


Following Constructor

[image]

Sitecore 6.4.1 API
Following Constructor
Following Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Following(
    ElementBase element
)
Visual Basic
Public Sub New ( _
    element As ElementBase _
)
Visual C++
public:
Following(
    ElementBase^ element
)

Parameters

element
Type: Sitecore.Data.Query..::..ElementBase
Element.

See Also

Following Class
Sitecore.Data.Query Namespace


Following Methods

[image] [image]

Sitecore 6.4.1 API
Following Methods
Following Class See Also Send Feedback

The Following type exposes the following members.

Methods

 | Name | Description
Protected method | Break | Breaks the query. (Inherited from Step.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Overrides Opcode..::..Evaluate(Query, QueryContext).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Overrides Step..::..Print(HtmlTextWriter).)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Following Class
Sitecore.Data.Query Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
Following..::..Evaluate Method
Following Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Object Evaluate(
    Query query,
    QueryContext node
)
Visual Basic
Public Overrides Function Evaluate ( _
    query As Query, _
    node As QueryContext _
) As Object
Visual C++
public:
virtual Object^ Evaluate(
    Query^ query,
    QueryContext^ node
) override

Parameters

query
Type: Sitecore.Data.Query..::..Query
Query.
node
Type: Sitecore.Data.Query..::..QueryContext
Node.

Return Value

The result of the evaluation.

See Also

Following Class
Sitecore.Data.Query Namespace


Print Method

[image]

Sitecore 6.4.1 API
Following..::..Print Method
Following Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Print(
    HtmlTextWriter output
)
Visual Basic
Public Overrides Sub Print ( _
    output As HtmlTextWriter _
)
Visual C++
public:
virtual void Print(
    HtmlTextWriter^ output
) override

Parameters

output
Type: System.Web.UI..::..HtmlTextWriter
Output.

See Also

Following Class
Sitecore.Data.Query Namespace


Following Properties

[image] [image]

Sitecore 6.4.1 API
Following Properties
Following Class See Also Send Feedback

The Following type exposes the following members.

Properties

 | Name | Description
Public property | NextStep | Gets or sets the next step. (Inherited from Step.)

See Also

Following Class
Sitecore.Data.Query Namespace


Function Class

[image]

Sitecore 6.4.1 API
Function Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Function : Opcode
Visual Basic
Public Class Function _
    Inherits Opcode
Visual C++
public ref class Function : public Opcode

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..Opcode
Sitecore.Data.Query..::..Function

See Also

Function Members
Sitecore.Data.Query Namespace


Function Constructor

[image]

Sitecore 6.4.1 API
Function Constructor
Function Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Function(
    string name
)
Visual Basic
Public Sub New ( _
    name As String _
)
Visual C++
public:
Function(
    String^ name
)

Parameters

name
Type: System..::..String
Name.

See Also

Function Class
Sitecore.Data.Query Namespace


Function Methods

[image] [image]

Sitecore 6.4.1 API
Function Methods
Function Class See Also Send Feedback

The Function type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an argument.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Overrides Opcode..::..Evaluate(Query, QueryContext).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from Opcode.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Function Class
Sitecore.Data.Query Namespace


Add Method

[image]

Sitecore 6.4.1 API
Function..::..Add Method
Function Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Add(
    Opcode argument
)
Visual Basic
Public Sub Add ( _
    argument As Opcode _
)
Visual C++
public:
void Add(
    Opcode^ argument
)

Parameters

argument
Type: Sitecore.Data.Query..::..Opcode
Argument.

See Also

Function Class
Sitecore.Data.Query Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
Function..::..Evaluate Method
Function Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Object Evaluate(
    Query query,
    QueryContext node
)
Visual Basic
Public Overrides Function Evaluate ( _
    query As Query, _
    node As QueryContext _
) As Object
Visual C++
public:
virtual Object^ Evaluate(
    Query^ query,
    QueryContext^ node
) override

Parameters

query
Type: Sitecore.Data.Query..::..Query
Query.
node
Type: Sitecore.Data.Query..::..QueryContext
Node.

Return Value

The result of the evaluation.

See Also

Function Class
Sitecore.Data.Query Namespace


Function Properties

[image] [image]

Sitecore 6.4.1 API
Function Properties
Function Class See Also Send Feedback

The Function type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the name of the function.

See Also

Function Class
Sitecore.Data.Query Namespace


Name Property

[image]

Sitecore 6.4.1 API
Function..::..Name Property
Function Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

Function Class
Sitecore.Data.Query Namespace


FunctionArgs Class

[image]

Sitecore 6.4.1 API
FunctionArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FunctionArgs : EventArgs
Visual Basic
Public Class FunctionArgs _
    Inherits EventArgs
Visual C++
public ref class FunctionArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Data.Query..::..FunctionArgs

See Also

FunctionArgs Members
Sitecore.Data.Query Namespace


FunctionArgs Members

[image] [image]

Sitecore 6.4.1 API
FunctionArgs Members
FunctionArgs Class Constructors Methods Properties See Also Send Feedback

The FunctionArgs type exposes the following members.

Constructors

 | Name | Description
Public method | FunctionArgs | Creates a new FunctionArgs instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Arguments | Arguments.
Public property | ContextNode | Context node.
Public property | Function | The function to be called.
Public property | FunctionName | The name of the function to be called.
Public property | Query | Query.

See Also

FunctionArgs Class
Sitecore.Data.Query Namespace


FunctionArgs Constructor

[image]

Sitecore 6.4.1 API
FunctionArgs Constructor
FunctionArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FunctionArgs(
    Query query,
    Function function,
    Opcode[] arguments,
    QueryContext contextNode
)
Visual Basic
Public Sub New ( _
    query As Query, _
    function As Function, _
    arguments As Opcode(), _
    contextNode As QueryContext _
)
Visual C++
public:
FunctionArgs(
    Query^ query,
    Function^ function,
    array<Opcode^>^ arguments,
    QueryContext^ contextNode
)

Parameters

query
Type: Sitecore.Data.Query..::..Query
Query.
function
Type: Sitecore.Data.Query..::..Function
Function.
arguments
Type: array< Sitecore.Data.Query..::..Opcode >[]()[][]
Arguments.
contextNode
Type: Sitecore.Data.Query..::..QueryContext
Context node.

See Also

FunctionArgs Class
Sitecore.Data.Query Namespace


FunctionArgs Methods

[image] [image]

Sitecore 6.4.1 API
FunctionArgs Methods
FunctionArgs Class See Also Send Feedback

The FunctionArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FunctionArgs Class
Sitecore.Data.Query Namespace


FunctionArgs Properties

[image] [image]

Sitecore 6.4.1 API
FunctionArgs Properties
FunctionArgs Class See Also Send Feedback

The FunctionArgs type exposes the following members.

Properties

 | Name | Description
Public property | Arguments | Arguments.
Public property | ContextNode | Context node.
Public property | Function | The function to be called.
Public property | FunctionName | The name of the function to be called.
Public property | Query | Query.

See Also

FunctionArgs Class
Sitecore.Data.Query Namespace


Arguments Property

[image]

Sitecore 6.4.1 API
FunctionArgs..::..Arguments Property
FunctionArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Opcode[] Arguments { get; set; }
Visual Basic
Public Property Arguments As Opcode()
    Get
    Set
Visual C++
public:
property array<Opcode^>^ Arguments {
    array<Opcode^>^ get ();
    void set (array<Opcode^>^ value);
}

Field Value

The arguments.

See Also

FunctionArgs Class
Sitecore.Data.Query Namespace


ContextNode Property

[image]

Sitecore 6.4.1 API
FunctionArgs..::..ContextNode Property
FunctionArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public QueryContext ContextNode { get; set; }
Visual Basic
Public Property ContextNode As QueryContext
    Get
    Set
Visual C++
public:
property QueryContext^ ContextNode {
    QueryContext^ get ();
    void set (QueryContext^ value);
}

Field Value

The context node.

See Also

FunctionArgs Class
Sitecore.Data.Query Namespace


Function Property

[image]

Sitecore 6.4.1 API
FunctionArgs..::..Function Property
FunctionArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Function Function { get; set; }
Visual Basic
Public Property Function As Function
    Get
    Set
Visual C++
public:
property Function^ Function {
    Function^ get ();
    void set (Function^ value);
}

Field Value

The function.

See Also

FunctionArgs Class
Sitecore.Data.Query Namespace


FunctionName Property

[image]

Sitecore 6.4.1 API
FunctionArgs..::..FunctionName Property
FunctionArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string FunctionName { get; set; }
Visual Basic
Public Property FunctionName As String
    Get
    Set
Visual C++
public:
property String^ FunctionName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the function.

See Also

FunctionArgs Class
Sitecore.Data.Query Namespace


Query Property

[image]

Sitecore 6.4.1 API
FunctionArgs..::..Query Property
FunctionArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Query Query { get; set; }
Visual Basic
Public Property Query As Query
    Get
    Set
Visual C++
public:
property Query^ Query {
    Query^ get ();
    void set (Query^ value);
}

Field Value

The query.

See Also

FunctionArgs Class
Sitecore.Data.Query Namespace


FunctionEventHandler Delegate

[image]

Sitecore 6.4.1 API
FunctionEventHandler Delegate
See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public delegate Object FunctionEventHandler(
    FunctionArgs args
)
Visual Basic
Public Delegate Function FunctionEventHandler ( _
    args As FunctionArgs _
) As Object
Visual C++
public delegate Object^ FunctionEventHandler(
    FunctionArgs^ args
)

Parameters

args
Type: Sitecore.Data.Query..::..FunctionArgs

Remarks

When you create a FieldSavedDelegate delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

See Also

Sitecore.Data.Query Namespace


Functions Class

[image]

Sitecore 6.4.1 API
Functions Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Functions
Visual Basic
Public Class Functions
Visual C++
public ref class Functions

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..Functions

See Also

Functions Members
Sitecore.Data.Query Namespace


Functions Members

[image] [image]

Sitecore 6.4.1 API
Functions Members
Functions Class Constructors Methods See Also Send Feedback

The Functions type exposes the following members.

Constructors

 | Name | Description
Public method | Functions | Initializes a new instance of the Functions class

Methods

 | Name | Description
 | CompareCaseInsensitive | Compares the strings case insensitive.
 | Contains | Determines if a string is contained in another string.
 | Current | Gets the current context node.
 | EndsWith | Determines if a string ends with another string.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FunctionCall | Calls a custom function.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Last | Gets the last child.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Not | Inverts the expression.
 | Number | Converts the specified args to a number.
 | Position | Gets the position index of a node in an expression.
 | StartsWith | Determines if a string begins with another string.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Functions Class
Sitecore.Data.Query Namespace


Functions Methods

[image] [image]

Sitecore 6.4.1 API
Functions Methods
Functions Class See Also Send Feedback

The Functions type exposes the following members.

Methods

 | Name | Description
 | CompareCaseInsensitive | Compares the strings case insensitive.
 | Contains | Determines if a string is contained in another string.
 | Current | Gets the current context node.
 | EndsWith | Determines if a string ends with another string.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FunctionCall | Calls a custom function.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Last | Gets the last child.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Not | Inverts the expression.
 | Number | Converts the specified args to a number.
 | Position | Gets the position index of a node in an expression.
 | StartsWith | Determines if a string begins with another string.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Functions Class
Sitecore.Data.Query Namespace


Contains Method

[image]

Sitecore 6.4.1 API
Functions..::..Contains Method
Functions Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool Contains(
    FunctionArgs args
)
Visual Basic
Public Shared Function Contains ( _
    args As FunctionArgs _
) As Boolean
Visual C++
public:
static bool Contains(
    FunctionArgs^ args
)

Parameters

args
Type: Sitecore.Data.Query..::..FunctionArgs
Arguments.

Return Value

true if [contains] [the specified args]; otherwise, false.

See Also

Functions Class
Sitecore.Data.Query Namespace


Current Method

[image]

Sitecore 6.4.1 API
Functions..::..Current Method
Functions Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static QueryContext Current(
    FunctionArgs args
)
Visual Basic
Public Shared Function Current ( _
    args As FunctionArgs _
) As QueryContext
Visual C++
public:
static QueryContext^ Current(
    FunctionArgs^ args
)

Parameters

args
Type: Sitecore.Data.Query..::..FunctionArgs
Arguments.

Return Value

The current.

See Also

Functions Class
Sitecore.Data.Query Namespace


EndsWith Method

[image]

Sitecore 6.4.1 API
Functions..::..EndsWith Method
Functions Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool EndsWith(
    FunctionArgs args
)
Visual Basic
Public Shared Function EndsWith ( _
    args As FunctionArgs _
) As Boolean
Visual C++
public:
static bool EndsWith(
    FunctionArgs^ args
)

Parameters

args
Type: Sitecore.Data.Query..::..FunctionArgs
Arguments.

Return Value

The with.

See Also

Functions Class
Sitecore.Data.Query Namespace


Last Method

[image]

Sitecore 6.4.1 API
Functions..::..Last Method
Functions Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int Last(
    FunctionArgs args
)
Visual Basic
Public Shared Function Last ( _
    args As FunctionArgs _
) As Integer
Visual C++
public:
static int Last(
    FunctionArgs^ args
)

Parameters

args
Type: Sitecore.Data.Query..::..FunctionArgs
Arguments.

Return Value

The last.

See Also

Functions Class
Sitecore.Data.Query Namespace


Not Method

[image]

Sitecore 6.4.1 API
Functions..::..Not Method
Functions Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool Not(
    FunctionArgs args
)
Visual Basic
Public Shared Function Not ( _
    args As FunctionArgs _
) As Boolean
Visual C++
public:
static bool Not(
    FunctionArgs^ args
)

Parameters

args
Type: Sitecore.Data.Query..::..FunctionArgs
Arguments.

Return Value

The not.

See Also

Functions Class
Sitecore.Data.Query Namespace


Number Method

[image]

Sitecore 6.4.1 API
Functions..::..Number Method
Functions Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int Number(
    FunctionArgs args
)
Visual Basic
Public Shared Function Number ( _
    args As FunctionArgs _
) As Integer
Visual C++
public:
static int Number(
    FunctionArgs^ args
)

Parameters

args
Type: Sitecore.Data.Query..::..FunctionArgs
The arguments.

Return Value

The number

Exceptions

Exception | Condition
Sitecore.Exceptions..::..QueryException | QueryException.

See Also

Functions Class
Sitecore.Data.Query Namespace


Position Method

[image]

Sitecore 6.4.1 API
Functions..::..Position Method
Functions Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int Position(
    FunctionArgs args
)
Visual Basic
Public Shared Function Position ( _
    args As FunctionArgs _
) As Integer
Visual C++
public:
static int Position(
    FunctionArgs^ args
)

Parameters

args
Type: Sitecore.Data.Query..::..FunctionArgs
Arguments.

Return Value

The position.

See Also

Functions Class
Sitecore.Data.Query Namespace


StartsWith Method

[image]

Sitecore 6.4.1 API
Functions..::..StartsWith Method
Functions Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool StartsWith(
    FunctionArgs args
)
Visual Basic
Public Shared Function StartsWith ( _
    args As FunctionArgs _
) As Boolean
Visual C++
public:
static bool StartsWith(
    FunctionArgs^ args
)

Parameters

args
Type: Sitecore.Data.Query..::..FunctionArgs
Arguments.

Return Value

The with.

See Also

Functions Class
Sitecore.Data.Query Namespace


GreaterOperator Members

[image] [image]

Sitecore 6.4.1 API
GreaterOperator Members
GreaterOperator Class Constructors Methods Properties See Also Send Feedback

The GreaterOperator type exposes the following members.

Constructors

 | Name | Description
Public method | GreaterOperator | Creates a new GreaterOperator instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Inherited from BinaryOperator.)
Public method | EvaluateOperands | Evaluates the expression. (Overrides BinaryOperator..::..EvaluateOperands(Object, Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from BinaryOperator.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Left | Gets the left expression. (Inherited from BinaryOperator.)
Public property | Right | Gets the right expression. (Inherited from BinaryOperator.)

See Also

GreaterOperator Class
Sitecore.Data.Query Namespace


GreaterOperator Constructor

[image]

Sitecore 6.4.1 API
GreaterOperator Constructor
GreaterOperator Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GreaterOperator(
    Opcode left,
    Opcode right
)
Visual Basic
Public Sub New ( _
    left As Opcode, _
    right As Opcode _
)
Visual C++
public:
GreaterOperator(
    Opcode^ left,
    Opcode^ right
)

Parameters

left
Type: Sitecore.Data.Query..::..Opcode
Left expression.
right
Type: Sitecore.Data.Query..::..Opcode
Right expression.

See Also

GreaterOperator Class
Sitecore.Data.Query Namespace


GreaterOperator Methods

[image] [image]

Sitecore 6.4.1 API
GreaterOperator Methods
GreaterOperator Class See Also Send Feedback

The GreaterOperator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Inherited from BinaryOperator.)
Public method | EvaluateOperands | Evaluates the expression. (Overrides BinaryOperator..::..EvaluateOperands(Object, Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from BinaryOperator.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GreaterOperator Class
Sitecore.Data.Query Namespace


GreaterOperator Properties

[image] [image]

Sitecore 6.4.1 API
GreaterOperator Properties
GreaterOperator Class See Also Send Feedback

The GreaterOperator type exposes the following members.

Properties

 | Name | Description
Public property | Left | Gets the left expression. (Inherited from BinaryOperator.)
Public property | Right | Gets the right expression. (Inherited from BinaryOperator.)

See Also

GreaterOperator Class
Sitecore.Data.Query Namespace


GreaterOrEqualsOperator Class

[image]

Sitecore 6.4.1 API
GreaterOrEqualsOperator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GreaterOrEqualsOperator : BinaryOperator
Visual Basic
Public Class GreaterOrEqualsOperator _
    Inherits BinaryOperator
Visual C++
public ref class GreaterOrEqualsOperator : public BinaryOperator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..Opcode
Sitecore.Data.Query..::..BinaryOperator
Sitecore.Data.Query..::..GreaterOrEqualsOperator

See Also

GreaterOrEqualsOperator Members
Sitecore.Data.Query Namespace


GreaterOrEqualsOperator Members

[image] [image]

Sitecore 6.4.1 API
GreaterOrEqualsOperator Members
GreaterOrEqualsOperator Class Constructors Methods Properties See Also Send Feedback

The GreaterOrEqualsOperator type exposes the following members.

Constructors

 | Name | Description
Public method | GreaterOrEqualsOperator | Creates a new GreaterOrEqualsOperator instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Inherited from BinaryOperator.)
Public method | EvaluateOperands | Evaluates the expression. (Overrides BinaryOperator..::..EvaluateOperands(Object, Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from BinaryOperator.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Left | Gets the left expression. (Inherited from BinaryOperator.)
Public property | Right | Gets the right expression. (Inherited from BinaryOperator.)

See Also

GreaterOrEqualsOperator Class
Sitecore.Data.Query Namespace


GreaterOrEqualsOperator Methods

[image] [image]

Sitecore 6.4.1 API
GreaterOrEqualsOperator Methods
GreaterOrEqualsOperator Class See Also Send Feedback

The GreaterOrEqualsOperator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Inherited from BinaryOperator.)
Public method | EvaluateOperands | Evaluates the expression. (Overrides BinaryOperator..::..EvaluateOperands(Object, Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from BinaryOperator.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GreaterOrEqualsOperator Class
Sitecore.Data.Query Namespace


EvaluateOperands Method

[image]

Sitecore 6.4.1 API
GreaterOrEqualsOperator..::..EvaluateOperands Method
GreaterOrEqualsOperator Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Object EvaluateOperands(
    Object left,
    Object right
)
Visual Basic
Public Overrides Function EvaluateOperands ( _
    left As Object, _
    right As Object _
) As Object
Visual C++
public:
virtual Object^ EvaluateOperands(
    Object^ left,
    Object^ right
) override

Parameters

left
Type: System..::..Object
Left expression.
right
Type: System..::..Object
Right expression.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Query.GreaterOrEqualsOperator.EvaluateOperands(System.Object,System.Object)"]

See Also

GreaterOrEqualsOperator Class
Sitecore.Data.Query Namespace


GreaterOrEqualsOperator Properties

[image] [image]

Sitecore 6.4.1 API
GreaterOrEqualsOperator Properties
GreaterOrEqualsOperator Class See Also Send Feedback

The GreaterOrEqualsOperator type exposes the following members.

Properties

 | Name | Description
Public property | Left | Gets the left expression. (Inherited from BinaryOperator.)
Public property | Right | Gets the right expression. (Inherited from BinaryOperator.)

See Also

GreaterOrEqualsOperator Class
Sitecore.Data.Query Namespace


IQueryable Interface

[image]

Sitecore 6.4.1 API
IQueryable Interface
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IQueryable
Visual Basic
Public Interface IQueryable
Visual C++
public interface class IQueryable

See Also

IQueryable Members
Sitecore.Data.Query Namespace


IQueryable Members

[image] [image]

Sitecore 6.4.1 API
IQueryable Members
IQueryable Interface Methods See Also Send Feedback

The IQueryable type exposes the following members.

Methods

 | Name | Description
Public method | GetChildIDs | Gets the IDs of child nodes.
Public method | GetFieldValue | Gets a field value.
Public method | GetName | Gets the name of a node.
Public method | GetParentID | Gets the parent ID of a node.
Public method | GetQueryContextItem | Gets the current query context item.

See Also

IQueryable Interface
Sitecore.Data.Query Namespace


IQueryable Methods

[image] [image]

Sitecore 6.4.1 API
IQueryable Methods
IQueryable Interface See Also Send Feedback

The IQueryable type exposes the following members.

Methods

 | Name | Description
Public method | GetChildIDs | Gets the IDs of child nodes.
Public method | GetFieldValue | Gets a field value.
Public method | GetName | Gets the name of a node.
Public method | GetParentID | Gets the parent ID of a node.
Public method | GetQueryContextItem | Gets the current query context item.

See Also

IQueryable Interface
Sitecore.Data.Query Namespace


GetFieldValue Method

[image]

Sitecore 6.4.1 API
IQueryable..::..GetFieldValue Method
IQueryable Interface See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
string GetFieldValue(
    ID itemID,
    string fieldName
)
Visual Basic
Function GetFieldValue ( _
    itemID As ID, _
    fieldName As String _
) As String
Visual C++
String^ GetFieldValue(
    ID^ itemID,
    String^ fieldName
)

Parameters

itemID
Type: Sitecore.Data..::..ID
Item ID.
fieldName
Type: System..::..String
Name of the field.

Return Value

The field value.

See Also

IQueryable Interface
Sitecore.Data.Query Namespace


GetName Method

[image]

Sitecore 6.4.1 API
IQueryable..::..GetName Method
IQueryable Interface See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
string GetName(
    ID itemID
)
Visual Basic
Function GetName ( _
    itemID As ID _
) As String
Visual C++
String^ GetName(
    ID^ itemID
)

Parameters

itemID
Type: Sitecore.Data..::..ID
Item ID.

Return Value

The name.

See Also

IQueryable Interface
Sitecore.Data.Query Namespace


GetParentID Method

[image]

Sitecore 6.4.1 API
IQueryable..::..GetParentID Method
IQueryable Interface See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
ID GetParentID(
    ID itemID
)
Visual Basic
Function GetParentID ( _
    itemID As ID _
) As ID
Visual C++
ID^ GetParentID(
    ID^ itemID
)

Parameters

itemID
Type: Sitecore.Data..::..ID
Item ID.

Return Value

The parent ID.

See Also

IQueryable Interface
Sitecore.Data.Query Namespace


GetQueryContextItem Method

[image]

Sitecore 6.4.1 API
IQueryable..::..GetQueryContextItem Method
IQueryable Interface See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
Item GetQueryContextItem(
    ID itemID
)
Visual Basic
Function GetQueryContextItem ( _
    itemID As ID _
) As Item
Visual C++
Item^ GetQueryContextItem(
    ID^ itemID
)

Parameters

itemID
Type: Sitecore.Data..::..ID
Item ID.

Return Value

The query context item.

See Also

IQueryable Interface
Sitecore.Data.Query Namespace


ISupportPaths Interface

[image]

Sitecore 6.4.1 API
ISupportPaths Interface
See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface ISupportPaths
Visual Basic
Public Interface ISupportPaths
Visual C++
public interface class ISupportPaths

See Also

Sitecore.Data.Query Namespace


ItemElement Class

[image]

Sitecore 6.4.1 API
ItemElement Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemElement : ElementBase
Visual Basic
Public Class ItemElement _
    Inherits ElementBase
Visual C++
public ref class ItemElement : public ElementBase

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..Opcode
Sitecore.Data.Query..::..Step
Sitecore.Data.Query..::..ElementBase
Sitecore.Data.Query..::..ItemElement

See Also

ItemElement Members
Sitecore.Data.Query Namespace


ItemElement Members

[image] [image]

Sitecore 6.4.1 API
ItemElement Members
ItemElement Class Constructors Methods Properties See Also Send Feedback

The ItemElement type exposes the following members.

Constructors

 | Name | Description
Public method | ItemElement | Creates a new ItemElement instance.

Methods

 | Name | Description
Protected method | Break | Breaks the query. (Inherited from Step.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Inherited from Opcode.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from ElementBase.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | Gets the name. (Inherited from ElementBase.)
Public property | NextStep | Gets or sets the next step. (Inherited from Step.)
Public property | Predicate | Gets or sets the predicate.

See Also

ItemElement Class
Sitecore.Data.Query Namespace


ItemElement Methods

[image] [image]

Sitecore 6.4.1 API
ItemElement Methods
ItemElement Class See Also Send Feedback

The ItemElement type exposes the following members.

Methods

 | Name | Description
Protected method | Break | Breaks the query. (Inherited from Step.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Inherited from Opcode.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from ElementBase.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemElement Class
Sitecore.Data.Query Namespace


ItemElement Properties

[image] [image]

Sitecore 6.4.1 API
ItemElement Properties
ItemElement Class See Also Send Feedback

The ItemElement type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the name. (Inherited from ElementBase.)
Public property | NextStep | Gets or sets the next step. (Inherited from Step.)
Public property | Predicate | Gets or sets the predicate.

See Also

ItemElement Class
Sitecore.Data.Query Namespace


Predicate Property

[image]

Sitecore 6.4.1 API
ItemElement..::..Predicate Property
ItemElement Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Predicate Predicate { get; set; }
Visual Basic
Public Property Predicate As Predicate
    Get
    Set
Visual C++
public:
property Predicate^ Predicate {
    Predicate^ get ();
    void set (Predicate^ value);
}

Field Value

The predicate.

See Also

ItemElement Class
Sitecore.Data.Query Namespace


Literal Class

[image]

Sitecore 6.4.1 API
Literal Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Literal : Opcode
Visual Basic
Public Class Literal _
    Inherits Opcode
Visual C++
public ref class Literal : public Opcode

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..Opcode
Sitecore.Data.Query..::..Literal

See Also

Literal Members
Sitecore.Data.Query Namespace


Literal Members

[image] [image]

Sitecore 6.4.1 API
Literal Members
Literal Class Constructors Methods Properties See Also Send Feedback

The Literal type exposes the following members.

Constructors

 | Name | Description
Public method | Literal | Creates a new Literal instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Overrides Opcode..::..Evaluate(Query, QueryContext).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Overrides Opcode..::..Print(HtmlTextWriter).)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Text | Gets the text.

See Also

Literal Class
Sitecore.Data.Query Namespace


Literal Constructor

[image]

Sitecore 6.4.1 API
Literal Constructor
Literal Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Literal(
    string text
)
Visual Basic
Public Sub New ( _
    text As String _
)
Visual C++
public:
Literal(
    String^ text
)

Parameters

text
Type: System..::..String
Text.

See Also

Literal Class
Sitecore.Data.Query Namespace


Literal Methods

[image] [image]

Sitecore 6.4.1 API
Literal Methods
Literal Class See Also Send Feedback

The Literal type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Overrides Opcode..::..Evaluate(Query, QueryContext).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Overrides Opcode..::..Print(HtmlTextWriter).)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Literal Class
Sitecore.Data.Query Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
Literal..::..Evaluate Method
Literal Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Object Evaluate(
    Query query,
    QueryContext node
)
Visual Basic
Public Overrides Function Evaluate ( _
    query As Query, _
    node As QueryContext _
) As Object
Visual C++
public:
virtual Object^ Evaluate(
    Query^ query,
    QueryContext^ node
) override

Parameters

query
Type: Sitecore.Data.Query..::..Query
Query.
node
Type: Sitecore.Data.Query..::..QueryContext
Node.

Return Value

The result of the evaluation.

See Also

Literal Class
Sitecore.Data.Query Namespace


Literal Properties

[image] [image]

Sitecore 6.4.1 API
Literal Properties
Literal Class See Also Send Feedback

The Literal type exposes the following members.

Properties

 | Name | Description
Public property | Text | Gets the text.

See Also

Literal Class
Sitecore.Data.Query Namespace


Text Property

[image]

Sitecore 6.4.1 API
Literal..::..Text Property
Literal Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Text { get; }
Visual Basic
Public ReadOnly Property Text As String
    Get
Visual C++
public:
property String^ Text {
    String^ get ();
}

Field Value

The text.

See Also

Literal Class
Sitecore.Data.Query Namespace


MatchArgs Class

[image]

Sitecore 6.4.1 API
MatchArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class MatchArgs : EventArgs
Visual Basic
Public Class MatchArgs _
    Inherits EventArgs
Visual C++
public ref class MatchArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Data.Query..::..MatchArgs

See Also

MatchArgs Members
Sitecore.Data.Query Namespace


MatchArgs Members

[image] [image]

Sitecore 6.4.1 API
MatchArgs Members
MatchArgs Class Constructors Methods Properties See Also Send Feedback

The MatchArgs type exposes the following members.

Constructors

 | Name | Description
Public method | MatchArgs | Creates a new MatchArgs instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Abort | Aborts the current query.
Public property | ContextNode | Context node.
Public property | IsMatch | Indicates that a match has been found.

See Also

MatchArgs Class
Sitecore.Data.Query Namespace


MatchArgs Constructor

[image]

Sitecore 6.4.1 API
MatchArgs Constructor
MatchArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MatchArgs(
    QueryContext contextNode
)
Visual Basic
Public Sub New ( _
    contextNode As QueryContext _
)
Visual C++
public:
MatchArgs(
    QueryContext^ contextNode
)

Parameters

contextNode
Type: Sitecore.Data.Query..::..QueryContext
Context node.

See Also

MatchArgs Class
Sitecore.Data.Query Namespace


MatchArgs Methods

[image] [image]

Sitecore 6.4.1 API
MatchArgs Methods
MatchArgs Class See Also Send Feedback

The MatchArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MatchArgs Class
Sitecore.Data.Query Namespace


MatchArgs Properties

[image] [image]

Sitecore 6.4.1 API
MatchArgs Properties
MatchArgs Class See Also Send Feedback

The MatchArgs type exposes the following members.

Properties

 | Name | Description
Public property | Abort | Aborts the current query.
Public property | ContextNode | Context node.
Public property | IsMatch | Indicates that a match has been found.

See Also

MatchArgs Class
Sitecore.Data.Query Namespace


ContextNode Property

[image]

Sitecore 6.4.1 API
MatchArgs..::..ContextNode Property
MatchArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public QueryContext ContextNode { get; set; }
Visual Basic
Public Property ContextNode As QueryContext
    Get
    Set
Visual C++
public:
property QueryContext^ ContextNode {
    QueryContext^ get ();
    void set (QueryContext^ value);
}

Field Value

The context node.

See Also

MatchArgs Class
Sitecore.Data.Query Namespace


IsMatch Property

[image]

Sitecore 6.4.1 API
MatchArgs..::..IsMatch Property
MatchArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsMatch { get; set; }
Visual Basic
Public Property IsMatch As Boolean
    Get
    Set
Visual C++
public:
property bool IsMatch {
    bool get ();
    void set (bool value);
}

Field Value

true if this instance is match; otherwise, false.

See Also

MatchArgs Class
Sitecore.Data.Query Namespace


MatchEventHandler Delegate

[image]

Sitecore 6.4.1 API
MatchEventHandler Delegate
See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public delegate void MatchEventHandler(
    MatchArgs args
)
Visual Basic
Public Delegate Sub MatchEventHandler ( _
    args As MatchArgs _
)
Visual C++
public delegate void MatchEventHandler(
    MatchArgs^ args
)

Parameters

args
Type: Sitecore.Data.Query..::..MatchArgs

Remarks

When you create a FieldSavedDelegate delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

See Also

Sitecore.Data.Query Namespace


MinusOperator Class

[image]

Sitecore 6.4.1 API
MinusOperator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class MinusOperator : BinaryOperator
Visual Basic
Public Class MinusOperator _
    Inherits BinaryOperator
Visual C++
public ref class MinusOperator : public BinaryOperator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..Opcode
Sitecore.Data.Query..::..BinaryOperator
Sitecore.Data.Query..::..MinusOperator

See Also

MinusOperator Members
Sitecore.Data.Query Namespace


MinusOperator Members

[image] [image]

Sitecore 6.4.1 API
MinusOperator Members
MinusOperator Class Constructors Methods Properties See Also Send Feedback

The MinusOperator type exposes the following members.

Constructors

 | Name | Description
Public method | MinusOperator | Creates a new MinusOperator instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Inherited from BinaryOperator.)
Public method | EvaluateOperands | Evaluates the expression. (Overrides BinaryOperator..::..EvaluateOperands(Object, Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from BinaryOperator.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Left | Gets the left expression. (Inherited from BinaryOperator.)
Public property | Right | Gets the right expression. (Inherited from BinaryOperator.)

See Also

MinusOperator Class
Sitecore.Data.Query Namespace


MinusOperator Constructor

[image]

Sitecore 6.4.1 API
MinusOperator Constructor
MinusOperator Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MinusOperator(
    Opcode left,
    Opcode right
)
Visual Basic
Public Sub New ( _
    left As Opcode, _
    right As Opcode _
)
Visual C++
public:
MinusOperator(
    Opcode^ left,
    Opcode^ right
)

Parameters

left
Type: Sitecore.Data.Query..::..Opcode
Left expression.
right
Type: Sitecore.Data.Query..::..Opcode
Right expression.

See Also

MinusOperator Class
Sitecore.Data.Query Namespace


MinusOperator Methods

[image] [image]

Sitecore 6.4.1 API
MinusOperator Methods
MinusOperator Class See Also Send Feedback

The MinusOperator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Inherited from BinaryOperator.)
Public method | EvaluateOperands | Evaluates the expression. (Overrides BinaryOperator..::..EvaluateOperands(Object, Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from BinaryOperator.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MinusOperator Class
Sitecore.Data.Query Namespace


EvaluateOperands Method

[image]

Sitecore 6.4.1 API
MinusOperator..::..EvaluateOperands Method
MinusOperator Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Object EvaluateOperands(
    Object left,
    Object right
)
Visual Basic
Public Overrides Function EvaluateOperands ( _
    left As Object, _
    right As Object _
) As Object
Visual C++
public:
virtual Object^ EvaluateOperands(
    Object^ left,
    Object^ right
) override

Parameters

left
Type: System..::..Object
Left expression.
right
Type: System..::..Object
Right expression.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Query.MinusOperator.EvaluateOperands(System.Object,System.Object)"]

See Also

MinusOperator Class
Sitecore.Data.Query Namespace


MinusOperator Properties

[image] [image]

Sitecore 6.4.1 API
MinusOperator Properties
MinusOperator Class See Also Send Feedback

The MinusOperator type exposes the following members.

Properties

 | Name | Description
Public property | Left | Gets the left expression. (Inherited from BinaryOperator.)
Public property | Right | Gets the right expression. (Inherited from BinaryOperator.)

See Also

MinusOperator Class
Sitecore.Data.Query Namespace


ModulusOperator Class

[image]

Sitecore 6.4.1 API
ModulusOperator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ModulusOperator : BinaryOperator
Visual Basic
Public Class ModulusOperator _
    Inherits BinaryOperator
Visual C++
public ref class ModulusOperator : public BinaryOperator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..Opcode
Sitecore.Data.Query..::..BinaryOperator
Sitecore.Data.Query..::..ModulusOperator

See Also

ModulusOperator Members
Sitecore.Data.Query Namespace


ModulusOperator Members

[image] [image]

Sitecore 6.4.1 API
ModulusOperator Members
ModulusOperator Class Constructors Methods Properties See Also Send Feedback

The ModulusOperator type exposes the following members.

Constructors

 | Name | Description
Public method | ModulusOperator | Creates a new ModulusOperator instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Inherited from BinaryOperator.)
Public method | EvaluateOperands | Evaluates the expression. (Overrides BinaryOperator..::..EvaluateOperands(Object, Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from BinaryOperator.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Left | Gets the left expression. (Inherited from BinaryOperator.)
Public property | Right | Gets the right expression. (Inherited from BinaryOperator.)

See Also

ModulusOperator Class
Sitecore.Data.Query Namespace


ModulusOperator Constructor

[image]

Sitecore 6.4.1 API
ModulusOperator Constructor
ModulusOperator Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ModulusOperator(
    Opcode left,
    Opcode right
)
Visual Basic
Public Sub New ( _
    left As Opcode, _
    right As Opcode _
)
Visual C++
public:
ModulusOperator(
    Opcode^ left,
    Opcode^ right
)

Parameters

left
Type: Sitecore.Data.Query..::..Opcode
Left expression.
right
Type: Sitecore.Data.Query..::..Opcode
Right expression.

See Also

ModulusOperator Class
Sitecore.Data.Query Namespace


ModulusOperator Methods

[image] [image]

Sitecore 6.4.1 API
ModulusOperator Methods
ModulusOperator Class See Also Send Feedback

The ModulusOperator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Inherited from BinaryOperator.)
Public method | EvaluateOperands | Evaluates the expression. (Overrides BinaryOperator..::..EvaluateOperands(Object, Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from BinaryOperator.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModulusOperator Class
Sitecore.Data.Query Namespace


ModulusOperator Properties

[image] [image]

Sitecore 6.4.1 API
ModulusOperator Properties
ModulusOperator Class See Also Send Feedback

The ModulusOperator type exposes the following members.

Properties

 | Name | Description
Public property | Left | Gets the left expression. (Inherited from BinaryOperator.)
Public property | Right | Gets the right expression. (Inherited from BinaryOperator.)

See Also

ModulusOperator Class
Sitecore.Data.Query Namespace


MultiplyOperator Class

[image]

Sitecore 6.4.1 API
MultiplyOperator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class MultiplyOperator : BinaryOperator
Visual Basic
Public Class MultiplyOperator _
    Inherits BinaryOperator
Visual C++
public ref class MultiplyOperator : public BinaryOperator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..Opcode
Sitecore.Data.Query..::..BinaryOperator
Sitecore.Data.Query..::..MultiplyOperator

See Also

MultiplyOperator Members
Sitecore.Data.Query Namespace


MultiplyOperator Members

[image] [image]

Sitecore 6.4.1 API
MultiplyOperator Members
MultiplyOperator Class Constructors Methods Properties See Also Send Feedback

The MultiplyOperator type exposes the following members.

Constructors

 | Name | Description
Public method | MultiplyOperator | Creates a new MultiplyOperator instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Inherited from BinaryOperator.)
Public method | EvaluateOperands | Evaluates the expression. (Overrides BinaryOperator..::..EvaluateOperands(Object, Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from BinaryOperator.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Left | Gets the left expression. (Inherited from BinaryOperator.)
Public property | Right | Gets the right expression. (Inherited from BinaryOperator.)

See Also

MultiplyOperator Class
Sitecore.Data.Query Namespace


MultiplyOperator Constructor

[image]

Sitecore 6.4.1 API
MultiplyOperator Constructor
MultiplyOperator Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MultiplyOperator(
    Opcode left,
    Opcode right
)
Visual Basic
Public Sub New ( _
    left As Opcode, _
    right As Opcode _
)
Visual C++
public:
MultiplyOperator(
    Opcode^ left,
    Opcode^ right
)

Parameters

left
Type: Sitecore.Data.Query..::..Opcode
Left expression.
right
Type: Sitecore.Data.Query..::..Opcode
Right expression.

See Also

MultiplyOperator Class
Sitecore.Data.Query Namespace


MultiplyOperator Methods

[image] [image]

Sitecore 6.4.1 API
MultiplyOperator Methods
MultiplyOperator Class See Also Send Feedback

The MultiplyOperator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Inherited from BinaryOperator.)
Public method | EvaluateOperands | Evaluates the expression. (Overrides BinaryOperator..::..EvaluateOperands(Object, Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from BinaryOperator.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MultiplyOperator Class
Sitecore.Data.Query Namespace


EvaluateOperands Method

[image]

Sitecore 6.4.1 API
MultiplyOperator..::..EvaluateOperands Method
MultiplyOperator Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Object EvaluateOperands(
    Object left,
    Object right
)
Visual Basic
Public Overrides Function EvaluateOperands ( _
    left As Object, _
    right As Object _
) As Object
Visual C++
public:
virtual Object^ EvaluateOperands(
    Object^ left,
    Object^ right
) override

Parameters

left
Type: System..::..Object
Left expression.
right
Type: System..::..Object
Right expression.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Query.MultiplyOperator.EvaluateOperands(System.Object,System.Object)"]

See Also

MultiplyOperator Class
Sitecore.Data.Query Namespace


MultiplyOperator Properties

[image] [image]

Sitecore 6.4.1 API
MultiplyOperator Properties
MultiplyOperator Class See Also Send Feedback

The MultiplyOperator type exposes the following members.

Properties

 | Name | Description
Public property | Left | Gets the left expression. (Inherited from BinaryOperator.)
Public property | Right | Gets the right expression. (Inherited from BinaryOperator.)

See Also

MultiplyOperator Class
Sitecore.Data.Query Namespace


Number Class

[image]

Sitecore 6.4.1 API
Number Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Number : Opcode
Visual Basic
Public Class Number _
    Inherits Opcode
Visual C++
public ref class Number : public Opcode

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..Opcode
Sitecore.Data.Query..::..Number

See Also

Number Members
Sitecore.Data.Query Namespace


Number Constructor

[image]

Sitecore 6.4.1 API
Number Constructor
Number Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Number(
    int number
)
Visual Basic
Public Sub New ( _
    number As Integer _
)
Visual C++
public:
Number(
    int number
)

Parameters

number
Type: System..::..Int32
Number.

See Also

Number Class
Sitecore.Data.Query Namespace


Number Methods

[image] [image]

Sitecore 6.4.1 API
Number Methods
Number Class See Also Send Feedback

The Number type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Overrides Opcode..::..Evaluate(Query, QueryContext).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Overrides Opcode..::..Print(HtmlTextWriter).)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Number Class
Sitecore.Data.Query Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
Number..::..Evaluate Method
Number Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Object Evaluate(
    Query query,
    QueryContext node
)
Visual Basic
Public Overrides Function Evaluate ( _
    query As Query, _
    node As QueryContext _
) As Object
Visual C++
public:
virtual Object^ Evaluate(
    Query^ query,
    QueryContext^ node
) override

Parameters

query
Type: Sitecore.Data.Query..::..Query
Query.
node
Type: Sitecore.Data.Query..::..QueryContext
Node.

Return Value

The result of the evaluation.

See Also

Number Class
Sitecore.Data.Query Namespace


Print Method

[image]

Sitecore 6.4.1 API
Number..::..Print Method
Number Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Print(
    HtmlTextWriter output
)
Visual Basic
Public Overrides Sub Print ( _
    output As HtmlTextWriter _
)
Visual C++
public:
virtual void Print(
    HtmlTextWriter^ output
) override

Parameters

output
Type: System.Web.UI..::..HtmlTextWriter
Output.

See Also

Number Class
Sitecore.Data.Query Namespace


Number Properties

[image] [image]

Sitecore 6.4.1 API
Number Properties
Number Class See Also Send Feedback

The Number type exposes the following members.

Properties

 | Name | Description
Public property | Value | Gets the value.

See Also

Number Class
Sitecore.Data.Query Namespace


Value Property

[image]

Sitecore 6.4.1 API
Number..::..Value Property
Number Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Value { get; }
Visual Basic
Public ReadOnly Property Value As Integer
    Get
Visual C++
public:
property int Value {
    int get ();
}

Field Value

The value.

See Also

Number Class
Sitecore.Data.Query Namespace


Opcode Members

[image] [image]

Sitecore 6.4.1 API
Opcode Members
Opcode Class Constructors Methods See Also Send Feedback

The Opcode type exposes the following members.

Constructors

 | Name | Description
Protected method | Opcode | Initializes a new instance of the Opcode class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression.
Public method | PrintIndent | Prints the indentation.
Public method | PrintLine | Prints a line of text.
Protected method | Process | Processes the specified query.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Opcode Class
Sitecore.Data.Query Namespace


Opcode Constructor

[image]

Sitecore 6.4.1 API
Opcode Constructor
Opcode Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Opcode()
Visual Basic
Protected Sub New
Visual C++
protected:
Opcode()

See Also

Opcode Class
Sitecore.Data.Query Namespace


Opcode Methods

[image] [image]

Sitecore 6.4.1 API
Opcode Methods
Opcode Class See Also Send Feedback

The Opcode type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression.
Public method | PrintIndent | Prints the indentation.
Public method | PrintLine | Prints a line of text.
Protected method | Process | Processes the specified query.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Opcode Class
Sitecore.Data.Query Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
Opcode..::..Evaluate Method
Opcode Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Object Evaluate(
    Query query,
    QueryContext contextNode
)
Visual Basic
Public Overridable Function Evaluate ( _
    query As Query, _
    contextNode As QueryContext _
) As Object
Visual C++
public:
virtual Object^ Evaluate(
    Query^ query,
    QueryContext^ contextNode
)

Parameters

query
Type: Sitecore.Data.Query..::..Query
Query.
contextNode
Type: Sitecore.Data.Query..::..QueryContext
Context node.

Return Value

The result of the evaluation.

See Also

Opcode Class
Sitecore.Data.Query Namespace


Print Method

[image]

Sitecore 6.4.1 API
Opcode..::..Print Method
Opcode Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Print(
    HtmlTextWriter output
)
Visual Basic
Public Overridable Sub Print ( _
    output As HtmlTextWriter _
)
Visual C++
public:
virtual void Print(
    HtmlTextWriter^ output
)

Parameters

output
Type: System.Web.UI..::..HtmlTextWriter
The output.

See Also

Opcode Class
Sitecore.Data.Query Namespace


PrintIndent Method

[image]

Sitecore 6.4.1 API
Opcode..::..PrintIndent Method
Opcode Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void PrintIndent(
    HtmlTextWriter output
)
Visual Basic
Public Sub PrintIndent ( _
    output As HtmlTextWriter _
)
Visual C++
public:
void PrintIndent(
    HtmlTextWriter^ output
)

Parameters

output
Type: System.Web.UI..::..HtmlTextWriter
Output.

See Also

Opcode Class
Sitecore.Data.Query Namespace


PrintLine Method

[image]

Sitecore 6.4.1 API
Opcode..::..PrintLine Method
Opcode Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void PrintLine(
    HtmlTextWriter output,
    string text
)
Visual Basic
Public Sub PrintLine ( _
    output As HtmlTextWriter, _
    text As String _
)
Visual C++
public:
void PrintLine(
    HtmlTextWriter^ output,
    String^ text
)

Parameters

output
Type: System.Web.UI..::..HtmlTextWriter
Output.
text
Type: System..::..String
Text.

See Also

Opcode Class
Sitecore.Data.Query Namespace


OrOperator Class

[image]

Sitecore 6.4.1 API
OrOperator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class OrOperator : BinaryOperator
Visual Basic
Public Class OrOperator _
    Inherits BinaryOperator
Visual C++
public ref class OrOperator : public BinaryOperator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..Opcode
Sitecore.Data.Query..::..BinaryOperator
Sitecore.Data.Query..::..OrOperator

See Also

OrOperator Members
Sitecore.Data.Query Namespace


OrOperator Members

[image] [image]

Sitecore 6.4.1 API
OrOperator Members
OrOperator Class Constructors Methods Properties See Also Send Feedback

The OrOperator type exposes the following members.

Constructors

 | Name | Description
Public method | OrOperator | Creates a new OrOperator instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Inherited from BinaryOperator.)
Public method | EvaluateOperands | Evaluates the expression. (Overrides BinaryOperator..::..EvaluateOperands(Object, Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from BinaryOperator.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Left | Gets the left expression. (Inherited from BinaryOperator.)
Public property | Right | Gets the right expression. (Inherited from BinaryOperator.)

See Also

OrOperator Class
Sitecore.Data.Query Namespace


OrOperator Constructor

[image]

Sitecore 6.4.1 API
OrOperator Constructor
OrOperator Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public OrOperator(
    Opcode left,
    Opcode right
)
Visual Basic
Public Sub New ( _
    left As Opcode, _
    right As Opcode _
)
Visual C++
public:
OrOperator(
    Opcode^ left,
    Opcode^ right
)

Parameters

left
Type: Sitecore.Data.Query..::..Opcode
Left expression.
right
Type: Sitecore.Data.Query..::..Opcode
Right expression.

See Also

OrOperator Class
Sitecore.Data.Query Namespace


OrOperator Methods

[image] [image]

Sitecore 6.4.1 API
OrOperator Methods
OrOperator Class See Also Send Feedback

The OrOperator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Inherited from BinaryOperator.)
Public method | EvaluateOperands | Evaluates the expression. (Overrides BinaryOperator..::..EvaluateOperands(Object, Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from BinaryOperator.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OrOperator Class
Sitecore.Data.Query Namespace


EvaluateOperands Method

[image]

Sitecore 6.4.1 API
OrOperator..::..EvaluateOperands Method
OrOperator Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Object EvaluateOperands(
    Object left,
    Object right
)
Visual Basic
Public Overrides Function EvaluateOperands ( _
    left As Object, _
    right As Object _
) As Object
Visual C++
public:
virtual Object^ EvaluateOperands(
    Object^ left,
    Object^ right
) override

Parameters

left
Type: System..::..Object
Left expression.
right
Type: System..::..Object
Right expression.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Query.OrOperator.EvaluateOperands(System.Object,System.Object)"]

See Also

OrOperator Class
Sitecore.Data.Query Namespace


OrOperator Properties

[image] [image]

Sitecore 6.4.1 API
OrOperator Properties
OrOperator Class See Also Send Feedback

The OrOperator type exposes the following members.

Properties

 | Name | Description
Public property | Left | Gets the left expression. (Inherited from BinaryOperator.)
Public property | Right | Gets the right expression. (Inherited from BinaryOperator.)

See Also

OrOperator Class
Sitecore.Data.Query Namespace


Parameter Class

[image]

Sitecore 6.4.1 API
Parameter Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Parameter : ElementBase
Visual Basic
Public Class Parameter _
    Inherits ElementBase
Visual C++
public ref class Parameter : public ElementBase

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..Opcode
Sitecore.Data.Query..::..Step
Sitecore.Data.Query..::..ElementBase
Sitecore.Data.Query..::..Parameter

See Also

Parameter Members
Sitecore.Data.Query Namespace


Parameter Members

[image] [image]

Sitecore 6.4.1 API
Parameter Members
Parameter Class Constructors Methods Properties See Also Send Feedback

The Parameter type exposes the following members.

Constructors

 | Name | Description
Public method | Parameter | Creates a new Parameter instance.

Methods

 | Name | Description
Protected method | Break | Breaks the query. (Inherited from Step.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Overrides Opcode..::..Evaluate(Query, QueryContext).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from ElementBase.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | Gets the name. (Inherited from ElementBase.)
Public property | NextStep | Gets or sets the next step. (Inherited from Step.)

See Also

Parameter Class
Sitecore.Data.Query Namespace


Parameter Methods

[image] [image]

Sitecore 6.4.1 API
Parameter Methods
Parameter Class See Also Send Feedback

The Parameter type exposes the following members.

Methods

 | Name | Description
Protected method | Break | Breaks the query. (Inherited from Step.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Overrides Opcode..::..Evaluate(Query, QueryContext).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from ElementBase.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Parameter Class
Sitecore.Data.Query Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
Parameter..::..Evaluate Method
Parameter Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Object Evaluate(
    Query query,
    QueryContext node
)
Visual Basic
Public Overrides Function Evaluate ( _
    query As Query, _
    node As QueryContext _
) As Object
Visual C++
public:
virtual Object^ Evaluate(
    Query^ query,
    QueryContext^ node
) override

Parameters

query
Type: Sitecore.Data.Query..::..Query
Query.
node
Type: Sitecore.Data.Query..::..QueryContext
Node.

Return Value

The result of the evaluation.

See Also

Parameter Class
Sitecore.Data.Query Namespace


Parameter Properties

[image] [image]

Sitecore 6.4.1 API
Parameter Properties
Parameter Class See Also Send Feedback

The Parameter type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the name. (Inherited from ElementBase.)
Public property | NextStep | Gets or sets the next step. (Inherited from Step.)

See Also

Parameter Class
Sitecore.Data.Query Namespace


Parent Class

[image]

Sitecore 6.4.1 API
Parent Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Parent : Step
Visual Basic
Public Class Parent _
    Inherits Step
Visual C++
public ref class Parent : public Step

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..Opcode
Sitecore.Data.Query..::..Step
Sitecore.Data.Query..::..Parent

See Also

Parent Members
Sitecore.Data.Query Namespace


Parent Members

[image] [image]

Sitecore 6.4.1 API
Parent Members
Parent Class Constructors Methods Properties See Also Send Feedback

The Parent type exposes the following members.

Constructors

 | Name | Description
Public method | Parent | Initializes a new instance of the Parent class

Methods

 | Name | Description
Protected method | Break | Breaks the query. (Inherited from Step.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Overrides Opcode..::..Evaluate(Query, QueryContext).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from Step.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | NextStep | Gets or sets the next step. (Inherited from Step.)

See Also

Parent Class
Sitecore.Data.Query Namespace


Parent Constructor

[image]

Sitecore 6.4.1 API
Parent Constructor
Parent Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Parent()
Visual Basic
Public Sub New
Visual C++
public:
Parent()

See Also

Parent Class
Sitecore.Data.Query Namespace


Parent Methods

[image] [image]

Sitecore 6.4.1 API
Parent Methods
Parent Class See Also Send Feedback

The Parent type exposes the following members.

Methods

 | Name | Description
Protected method | Break | Breaks the query. (Inherited from Step.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Overrides Opcode..::..Evaluate(Query, QueryContext).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from Step.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Parent Class
Sitecore.Data.Query Namespace


Parent Properties

[image] [image]

Sitecore 6.4.1 API
Parent Properties
Parent Class See Also Send Feedback

The Parent type exposes the following members.

Properties

 | Name | Description
Public property | NextStep | Gets or sets the next step. (Inherited from Step.)

See Also

Parent Class
Sitecore.Data.Query Namespace


ParseException Members

[image] [image]

Sitecore 6.4.1 API
ParseException Members
ParseException Class Constructors Methods Properties See Also Send Feedback

The ParseException type exposes the following members.

Constructors

 | Name | Description
Public method | ParseException | Creates a new ParseException instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ParseException Class
Sitecore.Data.Query Namespace


ParseException Constructor

[image]

Sitecore 6.4.1 API
ParseException Constructor
ParseException Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ParseException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
ParseException(
    String^ message
)

Parameters

message
Type: System..::..String
Message.

See Also

ParseException Class
Sitecore.Data.Query Namespace


ParseException Methods

[image] [image]

Sitecore 6.4.1 API
ParseException Methods
ParseException Class See Also Send Feedback

The ParseException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ParseException Class
Sitecore.Data.Query Namespace


ParseException Properties

[image] [image]

Sitecore 6.4.1 API
ParseException Properties
ParseException Class See Also Send Feedback

The ParseException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ParseException Class
Sitecore.Data.Query Namespace


Preceding Class

[image]

Sitecore 6.4.1 API
Preceding Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Preceding : Step
Visual Basic
Public Class Preceding _
    Inherits Step
Visual C++
public ref class Preceding : public Step

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..Opcode
Sitecore.Data.Query..::..Step
Sitecore.Data.Query..::..Preceding

See Also

Preceding Members
Sitecore.Data.Query Namespace


Preceding Members

[image] [image]

Sitecore 6.4.1 API
Preceding Members
Preceding Class Constructors Methods Properties See Also Send Feedback

The Preceding type exposes the following members.

Constructors

 | Name | Description
Public method | Preceding | Creates a new Preceding instance.

Methods

 | Name | Description
Protected method | Break | Breaks the query. (Inherited from Step.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Overrides Opcode..::..Evaluate(Query, QueryContext).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Overrides Step..::..Print(HtmlTextWriter).)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | NextStep | Gets or sets the next step. (Inherited from Step.)

See Also

Preceding Class
Sitecore.Data.Query Namespace


Preceding Constructor

[image]

Sitecore 6.4.1 API
Preceding Constructor
Preceding Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Preceding(
    ElementBase element
)
Visual Basic
Public Sub New ( _
    element As ElementBase _
)
Visual C++
public:
Preceding(
    ElementBase^ element
)

Parameters

element
Type: Sitecore.Data.Query..::..ElementBase
Element.

See Also

Preceding Class
Sitecore.Data.Query Namespace


Preceding Methods

[image] [image]

Sitecore 6.4.1 API
Preceding Methods
Preceding Class See Also Send Feedback

The Preceding type exposes the following members.

Methods

 | Name | Description
Protected method | Break | Breaks the query. (Inherited from Step.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Overrides Opcode..::..Evaluate(Query, QueryContext).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Overrides Step..::..Print(HtmlTextWriter).)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Preceding Class
Sitecore.Data.Query Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
Preceding..::..Evaluate Method
Preceding Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Object Evaluate(
    Query query,
    QueryContext node
)
Visual Basic
Public Overrides Function Evaluate ( _
    query As Query, _
    node As QueryContext _
) As Object
Visual C++
public:
virtual Object^ Evaluate(
    Query^ query,
    QueryContext^ node
) override

Parameters

query
Type: Sitecore.Data.Query..::..Query
Query.
node
Type: Sitecore.Data.Query..::..QueryContext
Node.

Return Value

The result of the evaluation.

See Also

Preceding Class
Sitecore.Data.Query Namespace


Print Method

[image]

Sitecore 6.4.1 API
Preceding..::..Print Method
Preceding Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Print(
    HtmlTextWriter output
)
Visual Basic
Public Overrides Sub Print ( _
    output As HtmlTextWriter _
)
Visual C++
public:
virtual void Print(
    HtmlTextWriter^ output
) override

Parameters

output
Type: System.Web.UI..::..HtmlTextWriter
Output.

See Also

Preceding Class
Sitecore.Data.Query Namespace


Preceding Properties

[image] [image]

Sitecore 6.4.1 API
Preceding Properties
Preceding Class See Also Send Feedback

The Preceding type exposes the following members.

Properties

 | Name | Description
Public property | NextStep | Gets or sets the next step. (Inherited from Step.)

See Also

Preceding Class
Sitecore.Data.Query Namespace


Predicate Class

[image]

Sitecore 6.4.1 API
Predicate Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Predicate : Step
Visual Basic
Public Class Predicate _
    Inherits Step
Visual C++
public ref class Predicate : public Step

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..Opcode
Sitecore.Data.Query..::..Step
Sitecore.Data.Query..::..Predicate

See Also

Predicate Members
Sitecore.Data.Query Namespace


Predicate Members

[image] [image]

Sitecore 6.4.1 API
Predicate Members
Predicate Class Constructors Methods Properties See Also Send Feedback

The Predicate type exposes the following members.

Constructors

 | Name | Description
Public method | Predicate(String) | Creates a new Predicate instance.
Public method | Predicate(Opcode) | Creates a new Predicate instance.

Methods

 | Name | Description
Protected method | Break | Breaks the query. (Inherited from Step.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the predicate. (Overrides Opcode..::..Evaluate(Query, QueryContext).)
Public method | Filter | Filters a list of items and returns the items that fulfill the predicate.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Overrides Step..::..Print(HtmlTextWriter).)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | Test(Item) | Tests if the specified context node fulfill the predicate.
Public method | Test(QueryContext) | Tests if the specified context node fulfill the predicate.
Public method | Test(Query, QueryContext) | Tests if the specified query fulfill the predicate.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Gets the current context node.
Public property | Expression | Gets the expression.
Public property | NextStep | Gets or sets the next step. (Inherited from Step.)

See Also

Predicate Class
Sitecore.Data.Query Namespace


Predicate Constructor

[image] [image]

Sitecore 6.4.1 API
Predicate Constructor
Predicate Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Predicate(String) | Creates a new Predicate instance.
Public method | Predicate(Opcode) | Creates a new Predicate instance.

See Also

Predicate Class
Predicate Members
Sitecore.Data.Query Namespace


Predicate Constructor (String)

[image]

Sitecore 6.4.1 API
Predicate Constructor (String)
Predicate Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Predicate(
    string expression
)
Visual Basic
Public Sub New ( _
    expression As String _
)
Visual C++
public:
Predicate(
    String^ expression
)

Parameters

expression
Type: System..::..String
Expression.

See Also

Predicate Class
Predicate Overload
Sitecore.Data.Query Namespace


Predicate Constructor (Opcode)

[image]

Sitecore 6.4.1 API
Predicate Constructor (Opcode)
Predicate Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Predicate(
    Opcode expression
)
Visual Basic
Public Sub New ( _
    expression As Opcode _
)
Visual C++
public:
Predicate(
    Opcode^ expression
)

Parameters

expression
Type: Sitecore.Data.Query..::..Opcode
Expression.

See Also

Predicate Class
Predicate Overload
Sitecore.Data.Query Namespace


Predicate Methods

[image] [image]

Sitecore 6.4.1 API
Predicate Methods
Predicate Class See Also Send Feedback

The Predicate type exposes the following members.

Methods

 | Name | Description
Protected method | Break | Breaks the query. (Inherited from Step.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the predicate. (Overrides Opcode..::..Evaluate(Query, QueryContext).)
Public method | Filter | Filters a list of items and returns the items that fulfill the predicate.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Overrides Step..::..Print(HtmlTextWriter).)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | Test(Item) | Tests if the specified context node fulfill the predicate.
Public method | Test(QueryContext) | Tests if the specified context node fulfill the predicate.
Public method | Test(Query, QueryContext) | Tests if the specified query fulfill the predicate.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Predicate Class
Sitecore.Data.Query Namespace


Filter Method

[image]

Sitecore 6.4.1 API
Predicate..::..Filter Method
Predicate Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item[] Filter(
    Item[] items
)
Visual Basic
Public Function Filter ( _
    items As Item() _
) As Item()
Visual C++
public:
array<Item^>^ Filter(
    array<Item^>^ items
)

Parameters

items
Type: array< Sitecore.Data.Items..::..Item >[]()[][]
Items.

Return Value

The filter.

See Also

Predicate Class
Sitecore.Data.Query Namespace


Print Method

[image]

Sitecore 6.4.1 API
Predicate..::..Print Method
Predicate Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Print(
    HtmlTextWriter output
)
Visual Basic
Public Overrides Sub Print ( _
    output As HtmlTextWriter _
)
Visual C++
public:
virtual void Print(
    HtmlTextWriter^ output
) override

Parameters

output
Type: System.Web.UI..::..HtmlTextWriter
Output.

See Also

Predicate Class
Sitecore.Data.Query Namespace


Test Method

[image] [image]

Sitecore 6.4.1 API
Predicate..::..Test Method
Predicate Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Test(Item) | Tests if the specified context node fulfill the predicate.
Public method | Test(QueryContext) | Tests if the specified context node fulfill the predicate.
Public method | Test(Query, QueryContext) | Tests if the specified query fulfill the predicate.

See Also

Predicate Class
Predicate Members
Sitecore.Data.Query Namespace


Test Method (Item)

[image]

Sitecore 6.4.1 API
Predicate..::..Test Method (Item)
Predicate Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Test(
    Item contextNode
)
Visual Basic
Public Function Test ( _
    contextNode As Item _
) As Boolean
Visual C++
public:
bool Test(
    Item^ contextNode
)

Parameters

contextNode
Type: Sitecore.Data.Items..::..Item
Context node.

Return Value

The test.

See Also

Predicate Class
Test Overload
Sitecore.Data.Query Namespace


Test Method (Query, QueryContext)

[image]

Sitecore 6.4.1 API
Predicate..::..Test Method (Query, QueryContext)
Predicate Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Test(
    Query query,
    QueryContext contextNode
)
Visual Basic
Public Function Test ( _
    query As Query, _
    contextNode As QueryContext _
) As Boolean
Visual C++
public:
bool Test(
    Query^ query,
    QueryContext^ contextNode
)

Parameters

query
Type: Sitecore.Data.Query..::..Query
Query.
contextNode
Type: Sitecore.Data.Query..::..QueryContext
Context node.

Return Value

The test.

See Also

Predicate Class
Test Overload
Sitecore.Data.Query Namespace


Predicate Properties

[image] [image]

Sitecore 6.4.1 API
Predicate Properties
Predicate Class See Also Send Feedback

The Predicate type exposes the following members.

Properties

 | Name | Description
Public property | Current | Gets the current context node.
Public property | Expression | Gets the expression.
Public property | NextStep | Gets or sets the next step. (Inherited from Step.)

See Also

Predicate Class
Sitecore.Data.Query Namespace


Current Property

[image]

Sitecore 6.4.1 API
Predicate..::..Current Property
Predicate Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public QueryContext Current { get; }
Visual Basic
Public ReadOnly Property Current As QueryContext
    Get
Visual C++
public:
property QueryContext^ Current {
    QueryContext^ get ();
}

Field Value

The current.

See Also

Predicate Class
Sitecore.Data.Query Namespace


Expression Property

[image]

Sitecore 6.4.1 API
Predicate..::..Expression Property
Predicate Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Opcode Expression { get; }
Visual Basic
Public ReadOnly Property Expression As Opcode
    Get
Visual C++
public:
property Opcode^ Expression {
    Opcode^ get ();
}

Field Value

The expression.

See Also

Predicate Class
Sitecore.Data.Query Namespace


Query Class

[image]

Sitecore 6.4.1 API
Query Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Query
Visual Basic
Public Class Query
Visual C++
public ref class Query

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..Query

See Also

Query Members
Sitecore.Data.Query Namespace


Query Members

[image] [image]

Sitecore 6.4.1 API
Query Members
Query Class Constructors Methods Properties Events See Also Send Feedback

The Query type exposes the following members.

Constructors

 | Name | Description
Protected method | Query()()()() | Creates a new Query instance.
Public method | Query(String) | Creates a new Query instance.
Public method | Query(Opcode) | Creates a new Query instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute()()()() | Executes the query.
Public method | Execute(Item) | Executes the query with a specified context node.
Public method | Execute(QueryContext) | Executes the query with a specified context node.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the query execution plan.
 | SelectItems(String) | Selects the items from a database using an Sitecore XPath query.
 | SelectItems(String, Database) | Selects the items from a database using an Sitecore XPath query.
 | SelectItems(String, Item) | Selects the items from a database using an Sitecore XPath query.
 | SelectItems(String, QueryContext, Database) | Selects the items from a database using an Sitecore XPath query.
 | SelectSingleID | Selects a single item ID from a database using an Sitecore XPath query.
 | SelectSingleItem(String) | Selects a single item from a database using an Sitecore XPath query.
 | SelectSingleItem(String, Database) | Selects a single item from a database using an Sitecore XPath query.
 | SelectSingleItem(String, Item) | Selects a single item from a database using an Sitecore XPath query.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Abort | Gets or sets a value indicating whether this Query is aborted.
Public property | Any | Gets or sets a value indicating whether this Query returns when any match is found..
Public property | Max | Gets the max number of items to find.
Public property | Parameters | Gets or sets the parameters.

Events

 | Name | Description
Public event | Function |
Public event | Match |

See Also

Query Class
Sitecore.Data.Query Namespace


Query Constructor

[image] [image]

Sitecore 6.4.1 API
Query Constructor
Query Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Query()()()() | Creates a new Query instance.
Public method | Query(String) | Creates a new Query instance.
Public method | Query(Opcode) | Creates a new Query instance.

See Also

Query Class
Query Members
Sitecore.Data.Query Namespace


Query Constructor

[image]

Sitecore 6.4.1 API
Query Constructor
Query Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Query()
Visual Basic
Protected Sub New
Visual C++
protected:
Query()

See Also

Query Class
Query Overload
Sitecore.Data.Query Namespace


Query Constructor (String)

[image]

Sitecore 6.4.1 API
Query Constructor (String)
Query Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Query(
    string query
)
Visual Basic
Public Sub New ( _
    query As String _
)
Visual C++
public:
Query(
    String^ query
)

Parameters

query
Type: System..::..String
Query.

See Also

Query Class
Query Overload
Sitecore.Data.Query Namespace


Query Constructor (Opcode)

[image]

Sitecore 6.4.1 API
Query Constructor (Opcode)
Query Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Query(
    Opcode query
)
Visual Basic
Public Sub New ( _
    query As Opcode _
)
Visual C++
public:
Query(
    Opcode^ query
)

Parameters

query
Type: Sitecore.Data.Query..::..Opcode
Query.

See Also

Query Class
Query Overload
Sitecore.Data.Query Namespace


Query Methods

[image] [image]

Sitecore 6.4.1 API
Query Methods
Query Class See Also Send Feedback

The Query type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute()()()() | Executes the query.
Public method | Execute(Item) | Executes the query with a specified context node.
Public method | Execute(QueryContext) | Executes the query with a specified context node.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the query execution plan.
 | SelectItems(String) | Selects the items from a database using an Sitecore XPath query.
 | SelectItems(String, Database) | Selects the items from a database using an Sitecore XPath query.
 | SelectItems(String, Item) | Selects the items from a database using an Sitecore XPath query.
 | SelectItems(String, QueryContext, Database) | Selects the items from a database using an Sitecore XPath query.
 | SelectSingleID | Selects a single item ID from a database using an Sitecore XPath query.
 | SelectSingleItem(String) | Selects a single item from a database using an Sitecore XPath query.
 | SelectSingleItem(String, Database) | Selects a single item from a database using an Sitecore XPath query.
 | SelectSingleItem(String, Item) | Selects a single item from a database using an Sitecore XPath query.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Query Class
Sitecore.Data.Query Namespace


Execute Method

[image] [image]

Sitecore 6.4.1 API
Query..::..Execute Method
Query Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Execute()()()() | Executes the query.
Public method | Execute(Item) | Executes the query with a specified context node.
Public method | Execute(QueryContext) | Executes the query with a specified context node.

See Also

Query Class
Query Members
Sitecore.Data.Query Namespace


Execute Method

[image]

Sitecore 6.4.1 API
Query..::..Execute Method
Query Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object Execute()
Visual Basic
Public Function Execute As Object
Visual C++
public:
Object^ Execute()

Return Value

The execute.

See Also

Query Class
Execute Overload
Sitecore.Data.Query Namespace


Execute Method (Item)

[image]

Sitecore 6.4.1 API
Query..::..Execute Method (Item)
Query Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object Execute(
    Item contextNode
)
Visual Basic
Public Function Execute ( _
    contextNode As Item _
) As Object
Visual C++
public:
Object^ Execute(
    Item^ contextNode
)

Parameters

contextNode
Type: Sitecore.Data.Items..::..Item
Context node.

Return Value

The execute.

See Also

Query Class
Execute Overload
Sitecore.Data.Query Namespace


Execute Method (QueryContext)

[image]

Sitecore 6.4.1 API
Query..::..Execute Method (QueryContext)
Query Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object Execute(
    QueryContext contextNode
)
Visual Basic
Public Function Execute ( _
    contextNode As QueryContext _
) As Object
Visual C++
public:
Object^ Execute(
    QueryContext^ contextNode
)

Parameters

contextNode
Type: Sitecore.Data.Query..::..QueryContext
Context node.

Return Value

The execute.

See Also

Query Class
Execute Overload
Sitecore.Data.Query Namespace


Print Method

[image]

Sitecore 6.4.1 API
Query..::..Print Method
Query Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Print(
    HtmlTextWriter output
)
Visual Basic
Public Sub Print ( _
    output As HtmlTextWriter _
)
Visual C++
public:
void Print(
    HtmlTextWriter^ output
)

Parameters

output
Type: System.Web.UI..::..HtmlTextWriter
Output.

See Also

Query Class
Sitecore.Data.Query Namespace


SelectItems Method (String)

[image]

Sitecore 6.4.1 API
Query..::..SelectItems Method (String)
Query Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item[] SelectItems(
    string query
)
Visual Basic
Public Shared Function SelectItems ( _
    query As String _
) As Item()
Visual C++
public:
static array<Item^>^ SelectItems(
    String^ query
)

Parameters

query
Type: System..::..String
Query.

Return Value

The items.

See Also

Query Class
SelectItems Overload
Sitecore.Data.Query Namespace


SelectItems Method (String, Database)

[image]

Sitecore 6.4.1 API
Query..::..SelectItems Method (String, Database)
Query Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item[] SelectItems(
    string query,
    Database database
)
Visual Basic
Public Shared Function SelectItems ( _
    query As String, _
    database As Database _
) As Item()
Visual C++
public:
static array<Item^>^ SelectItems(
    String^ query,
    Database^ database
)

Parameters

query
Type: System..::..String
Query.
database
Type: Sitecore.Data..::..Database
Database.

Return Value

The items.

See Also

Query Class
SelectItems Overload
Sitecore.Data.Query Namespace


SelectItems Method (String, Item)

[image]

Sitecore 6.4.1 API
Query..::..SelectItems Method (String, Item)
Query Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item[] SelectItems(
    string query,
    Item contextNode
)
Visual Basic
Public Shared Function SelectItems ( _
    query As String, _
    contextNode As Item _
) As Item()
Visual C++
public:
static array<Item^>^ SelectItems(
    String^ query,
    Item^ contextNode
)

Parameters

query
Type: System..::..String
Query.
contextNode
Type: Sitecore.Data.Items..::..Item
Context node.

Return Value

The items.

See Also

Query Class
SelectItems Overload
Sitecore.Data.Query Namespace


SelectItems Method (String, QueryContext, Database)

[image]

Sitecore 6.4.1 API
Query..::..SelectItems Method (String, QueryContext, Database)
Query Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item[] SelectItems(
    string query,
    QueryContext contextNode,
    Database database
)
Visual Basic
Public Shared Function SelectItems ( _
    query As String, _
    contextNode As QueryContext, _
    database As Database _
) As Item()
Visual C++
public:
static array<Item^>^ SelectItems(
    String^ query,
    QueryContext^ contextNode,
    Database^ database
)

Parameters

query
Type: System..::..String
Query.
contextNode
Type: Sitecore.Data.Query..::..QueryContext
Context node.
database
Type: Sitecore.Data..::..Database
Database.

Return Value

The items.

See Also

Query Class
SelectItems Overload
Sitecore.Data.Query Namespace


SelectSingleID Method

[image]

Sitecore 6.4.1 API
Query..::..SelectSingleID Method
Query Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID SelectSingleID(
    string path,
    QueryContext queryContext
)
Visual Basic
Public Shared Function SelectSingleID ( _
    path As String, _
    queryContext As QueryContext _
) As ID
Visual C++
public:
static ID^ SelectSingleID(
    String^ path,
    QueryContext^ queryContext
)

Parameters

path
Type: System..::..String
Path.
queryContext
Type: Sitecore.Data.Query..::..QueryContext
Query context.

Return Value

The single ID.

See Also

Query Class
Sitecore.Data.Query Namespace


SelectSingleItem Method

[image] [image]

Sitecore 6.4.1 API
Query..::..SelectSingleItem Method
Query Class See Also Send Feedback

Overload List

Name | Description
SelectSingleItem(String) | Selects a single item from a database using an Sitecore XPath query.
SelectSingleItem(String, Database) | Selects a single item from a database using an Sitecore XPath query.
SelectSingleItem(String, Item) | Selects a single item from a database using an Sitecore XPath query.

See Also

Query Class
Query Members
Sitecore.Data.Query Namespace


SelectSingleItem Method (String)

[image]

Sitecore 6.4.1 API
Query..::..SelectSingleItem Method (String)
Query Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item SelectSingleItem(
    string query
)
Visual Basic
Public Shared Function SelectSingleItem ( _
    query As String _
) As Item
Visual C++
public:
static Item^ SelectSingleItem(
    String^ query
)

Parameters

query
Type: System..::..String
Query.

Return Value

The single item.

See Also

Query Class
SelectSingleItem Overload
Sitecore.Data.Query Namespace


SelectSingleItem Method (String, Database)

[image]

Sitecore 6.4.1 API
Query..::..SelectSingleItem Method (String, Database)
Query Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item SelectSingleItem(
    string query,
    Database database
)
Visual Basic
Public Shared Function SelectSingleItem ( _
    query As String, _
    database As Database _
) As Item
Visual C++
public:
static Item^ SelectSingleItem(
    String^ query,
    Database^ database
)

Parameters

query
Type: System..::..String
Query.
database
Type: Sitecore.Data..::..Database
Database.

Return Value

The single item.

See Also

Query Class
SelectSingleItem Overload
Sitecore.Data.Query Namespace


SelectSingleItem Method (String, Item)

[image]

Sitecore 6.4.1 API
Query..::..SelectSingleItem Method (String, Item)
Query Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item SelectSingleItem(
    string query,
    Item contextNode
)
Visual Basic
Public Shared Function SelectSingleItem ( _
    query As String, _
    contextNode As Item _
) As Item
Visual C++
public:
static Item^ SelectSingleItem(
    String^ query,
    Item^ contextNode
)

Parameters

query
Type: System..::..String
Query.
contextNode
Type: Sitecore.Data.Items..::..Item
Context node.

Return Value

The single item.

See Also

Query Class
SelectSingleItem Overload
Sitecore.Data.Query Namespace


Query Properties

[image] [image]

Sitecore 6.4.1 API
Query Properties
Query Class See Also Send Feedback

The Query type exposes the following members.

Properties

 | Name | Description
Public property | Abort | Gets or sets a value indicating whether this Query is aborted.
Public property | Any | Gets or sets a value indicating whether this Query returns when any match is found..
Public property | Max | Gets the max number of items to find.
Public property | Parameters | Gets or sets the parameters.

See Also

Query Class
Sitecore.Data.Query Namespace


Abort Property

[image]

Sitecore 6.4.1 API
Query..::..Abort Property
Query Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Abort { get; set; }
Visual Basic
Public Property Abort As Boolean
    Get
    Set
Visual C++
public:
property bool Abort {
    bool get ();
    void set (bool value);
}

Field Value

true if aborted; otherwise, false.

See Also

Query Class
Sitecore.Data.Query Namespace


Any Property

[image]

Sitecore 6.4.1 API
Query..::..Any Property
Query Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Any { get; set; }
Visual Basic
Public Property Any As Boolean
    Get
    Set
Visual C++
public:
property bool Any {
    bool get ();
    void set (bool value);
}

Field Value

true if this Query returns when any match is found.; otherwise, false.

See Also

Query Class
Sitecore.Data.Query Namespace


Max Property

[image]

Sitecore 6.4.1 API
Query..::..Max Property
Query Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Max { get; set; }
Visual Basic
Public Property Max As Integer
    Get
    Set
Visual C++
public:
property int Max {
    int get ();
    void set (int value);
}

Field Value

The max.

See Also

Query Class
Sitecore.Data.Query Namespace


Parameters Property

[image]

Sitecore 6.4.1 API
Query..::..Parameters Property
Query Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Hashtable Parameters { get; set; }
Visual Basic
Public Property Parameters As Hashtable
    Get
    Set
Visual C++
public:
property Hashtable^ Parameters {
    Hashtable^ get ();
    void set (Hashtable^ value);
}

Field Value

The parameters.

See Also

Query Class
Sitecore.Data.Query Namespace


Query Events

[image] [image]

Sitecore 6.4.1 API
Query Events
Query Class See Also Send Feedback

The Query type exposes the following members.

Events

 | Name | Description
Public event | Function |
Public event | Match |

See Also

Query Class
Sitecore.Data.Query Namespace


Function Event

[image]

Sitecore 6.4.1 API
Query..::..Function Event
Query Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event FunctionEventHandler Function
Visual Basic
Public Event Function As FunctionEventHandler
Visual C++
public:
 event FunctionEventHandler^ Function {
    void add (FunctionEventHandler^ value);
    void remove (FunctionEventHandler^ value);
}

See Also

Query Class
Sitecore.Data.Query Namespace


QueryBuilder Class

[image]

Sitecore 6.4.1 API
QueryBuilder Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class QueryBuilder
Visual Basic
Public Class QueryBuilder
Visual C++
public ref class QueryBuilder

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..QueryBuilder

See Also

QueryBuilder Members
Sitecore.Data.Query Namespace


QueryBuilder Members

[image] [image]

Sitecore 6.4.1 API
QueryBuilder Members
QueryBuilder Class Constructors Methods See Also Send Feedback

The QueryBuilder type exposes the following members.

Constructors

 | Name | Description
Public method | QueryBuilder | Initializes a new instance of the QueryBuilder class

Methods

 | Name | Description
Public method | Add | Gets an Add operator.
Public method | Ancestor | Gets an Ancestor axis.
Public method | AncestorOrSelf | Gets an Ancestor-or-self axis.
Public method | And | Gets an And operator.
Public method | BooleanValue | Gets a boolean element.
Public method | Children | Gets a Children operator.
Public method | Descendants | Gets an Descendants axis.
Public method | DescendantsOrSelf | Gets an descendants-or-self axis.
Public method | Divide | Gets a Divide operator.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(Opcode, Opcode) | Gets an Equals operator.
Public method | FieldElement | Gets a Field value.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Following | Gets a Following axis.
Public method | Function | Gets a Function statement.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Greater | Gets a Greater Than operator.
Public method | GreaterOrEquals | Gets a Greater Than or Equals operator.
Public method | ItemElement | Gets an Item element.
Public method | Literal | Gets a Literal element.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Minus | Gets a Minus operator.
Public method | Modulus | Gets a Modulus operator.
Public method | Multiply | Gets a Multiply operator.
Public method | Number | Gets a Number element.
Public method | Or | Gets an Or operator.
Public method | Parent | Gets a Parent axis.
Public method | Preceding | Gets a Preceeding axis.
Public method | Predicate | Gets a predicate.
Public method | QueryParameter | Gets a Query parameter object.
Public method | Root | Gets a Root element.
Public method | Self | Gets a Self element axis.
Public method | Smaller | Gets a Smaller Than operator.
Public method | SmallerOrEquals | Gets a Smaller Than or Equals operator.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unequals | Gets a Unequals operator.
Public method | Xor | Gets a Xor operator.

See Also

QueryBuilder Class
Sitecore.Data.Query Namespace


QueryBuilder Constructor

[image]

Sitecore 6.4.1 API
QueryBuilder Constructor
QueryBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public QueryBuilder()
Visual Basic
Public Sub New
Visual C++
public:
QueryBuilder()

See Also

QueryBuilder Class
Sitecore.Data.Query Namespace


QueryBuilder Methods

[image] [image]

Sitecore 6.4.1 API
QueryBuilder Methods
QueryBuilder Class See Also Send Feedback

The QueryBuilder type exposes the following members.

Methods

 | Name | Description
Public method | Add | Gets an Add operator.
Public method | Ancestor | Gets an Ancestor axis.
Public method | AncestorOrSelf | Gets an Ancestor-or-self axis.
Public method | And | Gets an And operator.
Public method | BooleanValue | Gets a boolean element.
Public method | Children | Gets a Children operator.
Public method | Descendants | Gets an Descendants axis.
Public method | DescendantsOrSelf | Gets an descendants-or-self axis.
Public method | Divide | Gets a Divide operator.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(Opcode, Opcode) | Gets an Equals operator.
Public method | FieldElement | Gets a Field value.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Following | Gets a Following axis.
Public method | Function | Gets a Function statement.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Greater | Gets a Greater Than operator.
Public method | GreaterOrEquals | Gets a Greater Than or Equals operator.
Public method | ItemElement | Gets an Item element.
Public method | Literal | Gets a Literal element.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Minus | Gets a Minus operator.
Public method | Modulus | Gets a Modulus operator.
Public method | Multiply | Gets a Multiply operator.
Public method | Number | Gets a Number element.
Public method | Or | Gets an Or operator.
Public method | Parent | Gets a Parent axis.
Public method | Preceding | Gets a Preceeding axis.
Public method | Predicate | Gets a predicate.
Public method | QueryParameter | Gets a Query parameter object.
Public method | Root | Gets a Root element.
Public method | Self | Gets a Self element axis.
Public method | Smaller | Gets a Smaller Than operator.
Public method | SmallerOrEquals | Gets a Smaller Than or Equals operator.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unequals | Gets a Unequals operator.
Public method | Xor | Gets a Xor operator.

See Also

QueryBuilder Class
Sitecore.Data.Query Namespace


AncestorOrSelf Method

[image]

Sitecore 6.4.1 API
QueryBuilder..::..AncestorOrSelf Method
QueryBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Step AncestorOrSelf(
    ElementBase element
)
Visual Basic
Public Function AncestorOrSelf ( _
    element As ElementBase _
) As Step
Visual C++
public:
Step^ AncestorOrSelf(
    ElementBase^ element
)

Parameters

element
Type: Sitecore.Data.Query..::..ElementBase
Element.

Return Value

The or self.

See Also

QueryBuilder Class
Sitecore.Data.Query Namespace


And Method

[image]

Sitecore 6.4.1 API
QueryBuilder..::..And Method
QueryBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Opcode And(
    Opcode left,
    Opcode right
)
Visual Basic
Public Function And ( _
    left As Opcode, _
    right As Opcode _
) As Opcode
Visual C++
public:
Opcode^ And(
    Opcode^ left,
    Opcode^ right
)

Parameters

left
Type: Sitecore.Data.Query..::..Opcode
Left expression.
right
Type: Sitecore.Data.Query..::..Opcode
Right expression.

Return Value

The and.

See Also

QueryBuilder Class
Sitecore.Data.Query Namespace


BooleanValue Method

[image]

Sitecore 6.4.1 API
QueryBuilder..::..BooleanValue Method
QueryBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Opcode BooleanValue(
    bool value
)
Visual Basic
Public Function BooleanValue ( _
    value As Boolean _
) As Opcode
Visual C++
public:
Opcode^ BooleanValue(
    bool value
)

Parameters

value
Type: System..::..Boolean
Value.

Return Value

The value.

See Also

QueryBuilder Class
Sitecore.Data.Query Namespace


Children Method

[image]

Sitecore 6.4.1 API
QueryBuilder..::..Children Method
QueryBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Step Children(
    ElementBase element
)
Visual Basic
Public Function Children ( _
    element As ElementBase _
) As Step
Visual C++
public:
Step^ Children(
    ElementBase^ element
)

Parameters

element
Type: Sitecore.Data.Query..::..ElementBase
Element.

Return Value

The children.

See Also

QueryBuilder Class
Sitecore.Data.Query Namespace


Descendants Method

[image]

Sitecore 6.4.1 API
QueryBuilder..::..Descendants Method
QueryBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Step Descendants(
    ElementBase element
)
Visual Basic
Public Function Descendants ( _
    element As ElementBase _
) As Step
Visual C++
public:
Step^ Descendants(
    ElementBase^ element
)

Parameters

element
Type: Sitecore.Data.Query..::..ElementBase
Element.

Return Value

The descendants.

See Also

QueryBuilder Class
Sitecore.Data.Query Namespace


DescendantsOrSelf Method

[image]

Sitecore 6.4.1 API
QueryBuilder..::..DescendantsOrSelf Method
QueryBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Step DescendantsOrSelf(
    ElementBase element
)
Visual Basic
Public Function DescendantsOrSelf ( _
    element As ElementBase _
) As Step
Visual C++
public:
Step^ DescendantsOrSelf(
    ElementBase^ element
)

Parameters

element
Type: Sitecore.Data.Query..::..ElementBase
Element.

Return Value

The or self.

See Also

QueryBuilder Class
Sitecore.Data.Query Namespace


Divide Method

[image]

Sitecore 6.4.1 API
QueryBuilder..::..Divide Method
QueryBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Opcode Divide(
    Opcode left,
    Opcode right
)
Visual Basic
Public Function Divide ( _
    left As Opcode, _
    right As Opcode _
) As Opcode
Visual C++
public:
Opcode^ Divide(
    Opcode^ left,
    Opcode^ right
)

Parameters

left
Type: Sitecore.Data.Query..::..Opcode
Left expression.
right
Type: Sitecore.Data.Query..::..Opcode
Right expression.

Return Value

The divide.

See Also

QueryBuilder Class
Sitecore.Data.Query Namespace


Equals Method

[image] [image]

Sitecore 6.4.1 API
QueryBuilder..::..Equals Method
QueryBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(Opcode, Opcode) | Gets an Equals operator.

See Also

QueryBuilder Class
QueryBuilder Members
Sitecore.Data.Query Namespace


Equals Method (Opcode, Opcode)

[image]

Sitecore 6.4.1 API
QueryBuilder..::..Equals Method (Opcode, Opcode)
QueryBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Opcode Equals(
    Opcode left,
    Opcode right
)
Visual Basic
Public Function Equals ( _
    left As Opcode, _
    right As Opcode _
) As Opcode
Visual C++
public:
Opcode^ Equals(
    Opcode^ left,
    Opcode^ right
)

Parameters

left
Type: Sitecore.Data.Query..::..Opcode
Left expression.
right
Type: Sitecore.Data.Query..::..Opcode
Right expression.

Return Value

The equals.

See Also

QueryBuilder Class
Equals Overload
Sitecore.Data.Query Namespace


FieldElement Method

[image]

Sitecore 6.4.1 API
QueryBuilder..::..FieldElement Method
QueryBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FieldElement FieldElement(
    string name
)
Visual Basic
Public Function FieldElement ( _
    name As String _
) As FieldElement
Visual C++
public:
FieldElement^ FieldElement(
    String^ name
)

Parameters

name
Type: System..::..String
Name.

Return Value

The element.

See Also

QueryBuilder Class
Sitecore.Data.Query Namespace


Following Method

[image]

Sitecore 6.4.1 API
QueryBuilder..::..Following Method
QueryBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Step Following(
    ElementBase element
)
Visual Basic
Public Function Following ( _
    element As ElementBase _
) As Step
Visual C++
public:
Step^ Following(
    ElementBase^ element
)

Parameters

element
Type: Sitecore.Data.Query..::..ElementBase
Element.

Return Value

The following.

See Also

QueryBuilder Class
Sitecore.Data.Query Namespace


Function Method

[image]

Sitecore 6.4.1 API
QueryBuilder..::..Function Method
QueryBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Function Function(
    string name
)
Visual Basic
Public Function Function ( _
    name As String _
) As Function
Visual C++
public:
Function^ Function(
    String^ name
)

Parameters

name
Type: System..::..String
Name.

Return Value

The function.

See Also

QueryBuilder Class
Sitecore.Data.Query Namespace


Greater Method

[image]

Sitecore 6.4.1 API
QueryBuilder..::..Greater Method
QueryBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Opcode Greater(
    Opcode left,
    Opcode right
)
Visual Basic
Public Function Greater ( _
    left As Opcode, _
    right As Opcode _
) As Opcode
Visual C++
public:
Opcode^ Greater(
    Opcode^ left,
    Opcode^ right
)

Parameters

left
Type: Sitecore.Data.Query..::..Opcode
Left expression.
right
Type: Sitecore.Data.Query..::..Opcode
Right expression.

Return Value

The greater.

See Also

QueryBuilder Class
Sitecore.Data.Query Namespace


GreaterOrEquals Method

[image]

Sitecore 6.4.1 API
QueryBuilder..::..GreaterOrEquals Method
QueryBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Opcode GreaterOrEquals(
    Opcode left,
    Opcode right
)
Visual Basic
Public Function GreaterOrEquals ( _
    left As Opcode, _
    right As Opcode _
) As Opcode
Visual C++
public:
Opcode^ GreaterOrEquals(
    Opcode^ left,
    Opcode^ right
)

Parameters

left
Type: Sitecore.Data.Query..::..Opcode
Left expression.
right
Type: Sitecore.Data.Query..::..Opcode
Right expression.

Return Value

The or equals.

See Also

QueryBuilder Class
Sitecore.Data.Query Namespace


ItemElement Method

[image]

Sitecore 6.4.1 API
QueryBuilder..::..ItemElement Method
QueryBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemElement ItemElement(
    string name,
    Predicate predicate
)
Visual Basic
Public Function ItemElement ( _
    name As String, _
    predicate As Predicate _
) As ItemElement
Visual C++
public:
ItemElement^ ItemElement(
    String^ name,
    Predicate^ predicate
)

Parameters

name
Type: System..::..String
Name.
predicate
Type: Sitecore.Data.Query..::..Predicate
Predicate.

Return Value

The element.

See Also

QueryBuilder Class
Sitecore.Data.Query Namespace


Minus Method

[image]

Sitecore 6.4.1 API
QueryBuilder..::..Minus Method
QueryBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Opcode Minus(
    Opcode left,
    Opcode right
)
Visual Basic
Public Function Minus ( _
    left As Opcode, _
    right As Opcode _
) As Opcode
Visual C++
public:
Opcode^ Minus(
    Opcode^ left,
    Opcode^ right
)

Parameters

left
Type: Sitecore.Data.Query..::..Opcode
Left expression.
right
Type: Sitecore.Data.Query..::..Opcode
Right expression.

Return Value

The minus.

See Also

QueryBuilder Class
Sitecore.Data.Query Namespace


Modulus Method

[image]

Sitecore 6.4.1 API
QueryBuilder..::..Modulus Method
QueryBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Opcode Modulus(
    Opcode left,
    Opcode right
)
Visual Basic
Public Function Modulus ( _
    left As Opcode, _
    right As Opcode _
) As Opcode
Visual C++
public:
Opcode^ Modulus(
    Opcode^ left,
    Opcode^ right
)

Parameters

left
Type: Sitecore.Data.Query..::..Opcode
Left expression.
right
Type: Sitecore.Data.Query..::..Opcode
Right expression.

Return Value

The modulus.

See Also

QueryBuilder Class
Sitecore.Data.Query Namespace


Multiply Method

[image]

Sitecore 6.4.1 API
QueryBuilder..::..Multiply Method
QueryBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Opcode Multiply(
    Opcode left,
    Opcode right
)
Visual Basic
Public Function Multiply ( _
    left As Opcode, _
    right As Opcode _
) As Opcode
Visual C++
public:
Opcode^ Multiply(
    Opcode^ left,
    Opcode^ right
)

Parameters

left
Type: Sitecore.Data.Query..::..Opcode
Left expression.
right
Type: Sitecore.Data.Query..::..Opcode
Right expression.

Return Value

The multiply.

See Also

QueryBuilder Class
Sitecore.Data.Query Namespace


Number Method

[image]

Sitecore 6.4.1 API
QueryBuilder..::..Number Method
QueryBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Opcode Number(
    int value
)
Visual Basic
Public Function Number ( _
    value As Integer _
) As Opcode
Visual C++
public:
Opcode^ Number(
    int value
)

Parameters

value
Type: System..::..Int32
Value.

Return Value

The number.

See Also

QueryBuilder Class
Sitecore.Data.Query Namespace


Parent Method

[image]

Sitecore 6.4.1 API
QueryBuilder..::..Parent Method
QueryBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Step Parent()
Visual Basic
Public Function Parent As Step
Visual C++
public:
Step^ Parent()

Return Value

The parent.

See Also

QueryBuilder Class
Sitecore.Data.Query Namespace


Preceding Method

[image]

Sitecore 6.4.1 API
QueryBuilder..::..Preceding Method
QueryBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Step Preceding(
    ElementBase element
)
Visual Basic
Public Function Preceding ( _
    element As ElementBase _
) As Step
Visual C++
public:
Step^ Preceding(
    ElementBase^ element
)

Parameters

element
Type: Sitecore.Data.Query..::..ElementBase
Element.

Return Value

The preceding.

See Also

QueryBuilder Class
Sitecore.Data.Query Namespace


Predicate Method

[image]

Sitecore 6.4.1 API
QueryBuilder..::..Predicate Method
QueryBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Predicate Predicate(
    Opcode expression
)
Visual Basic
Public Function Predicate ( _
    expression As Opcode _
) As Predicate
Visual C++
public:
Predicate^ Predicate(
    Opcode^ expression
)

Parameters

expression
Type: Sitecore.Data.Query..::..Opcode
Expression.

Return Value

The predicate.

See Also

QueryBuilder Class
Sitecore.Data.Query Namespace


QueryParameter Method

[image]

Sitecore 6.4.1 API
QueryBuilder..::..QueryParameter Method
QueryBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Parameter QueryParameter(
    string name
)
Visual Basic
Public Function QueryParameter ( _
    name As String _
) As Parameter
Visual C++
public:
Parameter^ QueryParameter(
    String^ name
)

Parameters

name
Type: System..::..String
Name.

Return Value

The parameter.

See Also

QueryBuilder Class
Sitecore.Data.Query Namespace


Root Method

[image]

Sitecore 6.4.1 API
QueryBuilder..::..Root Method
QueryBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Step Root()
Visual Basic
Public Function Root As Step
Visual C++
public:
Step^ Root()

Return Value

The root.

See Also

QueryBuilder Class
Sitecore.Data.Query Namespace


Self Method

[image]

Sitecore 6.4.1 API
QueryBuilder..::..Self Method
QueryBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Step Self(
    Predicate predicate
)
Visual Basic
Public Function Self ( _
    predicate As Predicate _
) As Step
Visual C++
public:
Step^ Self(
    Predicate^ predicate
)

Parameters

predicate
Type: Sitecore.Data.Query..::..Predicate
Predicate.

Return Value

The self.

See Also

QueryBuilder Class
Sitecore.Data.Query Namespace


Smaller Method

[image]

Sitecore 6.4.1 API
QueryBuilder..::..Smaller Method
QueryBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Opcode Smaller(
    Opcode left,
    Opcode right
)
Visual Basic
Public Function Smaller ( _
    left As Opcode, _
    right As Opcode _
) As Opcode
Visual C++
public:
Opcode^ Smaller(
    Opcode^ left,
    Opcode^ right
)

Parameters

left
Type: Sitecore.Data.Query..::..Opcode
Left expression.
right
Type: Sitecore.Data.Query..::..Opcode
Right expression.

Return Value

The smaller.

See Also

QueryBuilder Class
Sitecore.Data.Query Namespace


SmallerOrEquals Method

[image]

Sitecore 6.4.1 API
QueryBuilder..::..SmallerOrEquals Method
QueryBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Opcode SmallerOrEquals(
    Opcode left,
    Opcode right
)
Visual Basic
Public Function SmallerOrEquals ( _
    left As Opcode, _
    right As Opcode _
) As Opcode
Visual C++
public:
Opcode^ SmallerOrEquals(
    Opcode^ left,
    Opcode^ right
)

Parameters

left
Type: Sitecore.Data.Query..::..Opcode
Left expression.
right
Type: Sitecore.Data.Query..::..Opcode
Right expression.

Return Value

The or equals.

See Also

QueryBuilder Class
Sitecore.Data.Query Namespace


Unequals Method

[image]

Sitecore 6.4.1 API
QueryBuilder..::..Unequals Method
QueryBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Opcode Unequals(
    Opcode left,
    Opcode right
)
Visual Basic
Public Function Unequals ( _
    left As Opcode, _
    right As Opcode _
) As Opcode
Visual C++
public:
Opcode^ Unequals(
    Opcode^ left,
    Opcode^ right
)

Parameters

left
Type: Sitecore.Data.Query..::..Opcode
Left expression.
right
Type: Sitecore.Data.Query..::..Opcode
Right expression.

Return Value

The unequals.

See Also

QueryBuilder Class
Sitecore.Data.Query Namespace


Xor Method

[image]

Sitecore 6.4.1 API
QueryBuilder..::..Xor Method
QueryBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Opcode Xor(
    Opcode left,
    Opcode right
)
Visual Basic
Public Function Xor ( _
    left As Opcode, _
    right As Opcode _
) As Opcode
Visual C++
public:
Opcode^ Xor(
    Opcode^ left,
    Opcode^ right
)

Parameters

left
Type: Sitecore.Data.Query..::..Opcode
Left expression.
right
Type: Sitecore.Data.Query..::..Opcode
Right expression.

Return Value

The xor.

See Also

QueryBuilder Class
Sitecore.Data.Query Namespace


QueryContext Class

[image]

Sitecore 6.4.1 API
QueryContext Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class QueryContext
Visual Basic
Public Class QueryContext
Visual C++
public ref class QueryContext

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..QueryContext

See Also

QueryContext Members
Sitecore.Data.Query Namespace


QueryContext Members

[image] [image]

Sitecore 6.4.1 API
QueryContext Members
QueryContext Class Constructors Methods Properties See Also Send Feedback

The QueryContext type exposes the following members.

Constructors

 | Name | Description
Public method | QueryContext(IQueryable) | Creates a new QueryContext instance.
Public method | QueryContext(IQueryable, ID) | Creates a new QueryContext instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetQueryContextItem | Gets the query context item.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Matches | Tests if the name of the item matches a specified name.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Children | Gets the children.
Public property | DocumentElement | Gets a value indicating whether this node is the document element.
Public property | ID | Gets the ID.
Public property | Item | Gets the field value with the specified name.
Public property | Name | Gets the name.
Public property | Parent | Gets the parent.
Public property | Queryable | Gets the source object that this node represents.

See Also

QueryContext Class
Sitecore.Data.Query Namespace


QueryContext Constructor

[image] [image]

Sitecore 6.4.1 API
QueryContext Constructor
QueryContext Class See Also Send Feedback

Overload List

 | Name | Description
Public method | QueryContext(IQueryable) | Creates a new QueryContext instance.
Public method | QueryContext(IQueryable, ID) | Creates a new QueryContext instance.

See Also

QueryContext Class
QueryContext Members
Sitecore.Data.Query Namespace


QueryContext Constructor (IQueryable)

[image]

Sitecore 6.4.1 API
QueryContext Constructor (IQueryable)
QueryContext Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public QueryContext(
    IQueryable queryable
)
Visual Basic
Public Sub New ( _
    queryable As IQueryable _
)
Visual C++
public:
QueryContext(
    IQueryable^ queryable
)

Parameters

queryable
Type: Sitecore.Data.Query..::..IQueryable
Queryable.

See Also

QueryContext Class
QueryContext Overload
Sitecore.Data.Query Namespace


QueryContext Constructor (IQueryable, ID)

[image]

Sitecore 6.4.1 API
QueryContext Constructor (IQueryable, ID)
QueryContext Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public QueryContext(
    IQueryable queryable,
    ID id
)
Visual Basic
Public Sub New ( _
    queryable As IQueryable, _
    id As ID _
)
Visual C++
public:
QueryContext(
    IQueryable^ queryable,
    ID^ id
)

Parameters

queryable
Type: Sitecore.Data.Query..::..IQueryable
Queryable.
id
Type: Sitecore.Data..::..ID
Id.

See Also

QueryContext Class
QueryContext Overload
Sitecore.Data.Query Namespace


QueryContext Methods

[image] [image]

Sitecore 6.4.1 API
QueryContext Methods
QueryContext Class See Also Send Feedback

The QueryContext type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetQueryContextItem | Gets the query context item.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Matches | Tests if the name of the item matches a specified name.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

QueryContext Class
Sitecore.Data.Query Namespace


GetQueryContextItem Method

[image]

Sitecore 6.4.1 API
QueryContext..::..GetQueryContextItem Method
QueryContext Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetQueryContextItem()
Visual Basic
Public Function GetQueryContextItem As Item
Visual C++
public:
Item^ GetQueryContextItem()

Return Value

The query context item.

See Also

QueryContext Class
Sitecore.Data.Query Namespace


Matches Method

[image]

Sitecore 6.4.1 API
QueryContext..::..Matches Method
QueryContext Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Matches(
    string name
)
Visual Basic
Public Function Matches ( _
    name As String _
) As Boolean
Visual C++
public:
bool Matches(
    String^ name
)

Parameters

name
Type: System..::..String
Name.

Return Value

The matches.

See Also

QueryContext Class
Sitecore.Data.Query Namespace


QueryContext Properties

[image] [image]

Sitecore 6.4.1 API
QueryContext Properties
QueryContext Class See Also Send Feedback

The QueryContext type exposes the following members.

Properties

 | Name | Description
Public property | Children | Gets the children.
Public property | DocumentElement | Gets a value indicating whether this node is the document element.
Public property | ID | Gets the ID.
Public property | Item | Gets the field value with the specified name.
Public property | Name | Gets the name.
Public property | Parent | Gets the parent.
Public property | Queryable | Gets the source object that this node represents.

See Also

QueryContext Class
Sitecore.Data.Query Namespace


Children Property

[image]

Sitecore 6.4.1 API
QueryContext..::..Children Property
QueryContext Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public QueryContext[] Children { get; }
Visual Basic
Public ReadOnly Property Children As QueryContext()
    Get
Visual C++
public:
property array<QueryContext^>^ Children {
    array<QueryContext^>^ get ();
}

Field Value

The children.

See Also

QueryContext Class
Sitecore.Data.Query Namespace


ID Property

[image]

Sitecore 6.4.1 API
QueryContext..::..ID Property
QueryContext Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ID { get; }
Visual Basic
Public ReadOnly Property ID As ID
    Get
Visual C++
public:
property ID^ ID {
    ID^ get ();
}

Field Value

The ID.

See Also

QueryContext Class
Sitecore.Data.Query Namespace


Parent Property

[image]

Sitecore 6.4.1 API
QueryContext..::..Parent Property
QueryContext Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public QueryContext Parent { get; }
Visual Basic
Public ReadOnly Property Parent As QueryContext
    Get
Visual C++
public:
property QueryContext^ Parent {
    QueryContext^ get ();
}

Field Value

The parent.

See Also

QueryContext Class
Sitecore.Data.Query Namespace


Queryable Property

[image]

Sitecore 6.4.1 API
QueryContext..::..Queryable Property
QueryContext Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IQueryable Queryable { get; }
Visual Basic
Public ReadOnly Property Queryable As IQueryable
    Get
Visual C++
public:
property IQueryable^ Queryable {
    IQueryable^ get ();
}

Field Value

The queryable.

Remarks

This is usually an Item.

See Also

QueryContext Class
Sitecore.Data.Query Namespace


QueryParser Class

[image]

Sitecore 6.4.1 API
QueryParser Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class QueryParser
Visual Basic
Public Class QueryParser
Visual C++
public ref class QueryParser

Remarks

Queries = Query | ( Queries "|" Query )
Query = PathStep ( PathStep )*
PathStep = Node | Children | Descendants
Children = "/" Node
Descendants = "//" Node
Node = Attribute | Element
Attribute = "@" Name
Element = [ Axis ] ( "*" | "." | ".." | Name ) [ Predicate ]
Name = Identifier | Name Identifier
Axis = ( "ancestor" | "ancestor-or-self" | "descendants" | "descendants-or-self" |
       "child" | "parent" | "following" | "preceding" | "self" ) "::"
Predicate = "[" Expression "]"
Expression = Term3 [ ( "or" | "xor" ) Term3 ]
Term3 = Term2 [ "and" Term2 ]
Term2 = Term1 [ ( "=" | ">" | ">=" | "<" | "<=" | "!=" ) Term1 ]
Term1 = Term0 [ ( "+" | "-" ) Term0 ]
Term0 = Factor [ ( "*" | "div" | "mod" ) Factor ]
Factor = Queries | Literal | Number | True | False | "(" Expression ")" |
         Attribute | Function | Parameter
Parameter = "$" Identifier
Function = Identifier "(" ExpressionList ")"
ExpressionList = Expression | ( ExpressionList "," Expression )

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..QueryParser

See Also

QueryParser Members
Sitecore.Data.Query Namespace


QueryParser Members

[image] [image]

Sitecore 6.4.1 API
QueryParser Members
QueryParser Class Constructors Methods See Also Send Feedback

The QueryParser type exposes the following members.

Constructors

 | Name | Description
Public method | QueryParser | Initializes a new instance of the QueryParser class

Methods

 | Name | Description
Protected method | DoParse | Performs the parsing.
Protected method | DoParsePredicate | Performs the parsing.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetAncestorAxis | Gets the ancestor axis.
Protected method | GetAttribute | Gets the attribute.
Protected method | GetChildAxis | Gets the child axis.
Protected method | GetChildren | Gets the children.
Protected method | GetDescendants | Gets the descendants.
Protected method | GetDescendantsAxis | Gets the descendants axis.
Protected method | GetDotDot | Gets the dot dot.
Protected method | GetElement | Gets the element.
Protected method | GetExpression | Gets the expression.
Protected method | GetFactor | Gets the factor.
Protected method | GetFollowingAxis | Gets the following axis.
Protected method | GetFunction | Gets the function.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetNode | Gets the node.
Protected method | GetParameter | Gets the parameter.
Protected method | GetParentAxis | Gets the parent axis.
Protected method | GetPathStep | Gets the path step.
Protected method | GetPrecedingAxis | Gets the preceding axis.
Protected method | GetPredicate | Gets the predicate.
Protected method | GetQueries | Gets the queries.
Protected method | GetQuery | Gets the query.
Protected method | GetSelf | Gets the self.
Protected method | GetSelfAxis | Gets the self axis.
Protected method | GetTerm0 | Gets the term0.
Protected method | GetTerm1 | Gets the term1.
Protected method | GetTerm2 | Gets the term2.
Protected method | GetTerm3 | Gets the term3.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Match()()()() | Matches this instance.
Protected method | Match(Int32, String) | Matches the specified type.
Protected method | MatchCheck | Matches the check.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Parses the specified query.
 | ParsePredicate | Parses a predicate.
Protected method | Peek | Peeks this instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

QueryParser Class
Sitecore.Data.Query Namespace


QueryParser Constructor

[image]

Sitecore 6.4.1 API
QueryParser Constructor
QueryParser Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public QueryParser()
Visual Basic
Public Sub New
Visual C++
public:
QueryParser()

See Also

QueryParser Class
Sitecore.Data.Query Namespace


QueryParser Methods

[image] [image]

Sitecore 6.4.1 API
QueryParser Methods
QueryParser Class See Also Send Feedback

The QueryParser type exposes the following members.

Methods

 | Name | Description
Protected method | DoParse | Performs the parsing.
Protected method | DoParsePredicate | Performs the parsing.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetAncestorAxis | Gets the ancestor axis.
Protected method | GetAttribute | Gets the attribute.
Protected method | GetChildAxis | Gets the child axis.
Protected method | GetChildren | Gets the children.
Protected method | GetDescendants | Gets the descendants.
Protected method | GetDescendantsAxis | Gets the descendants axis.
Protected method | GetDotDot | Gets the dot dot.
Protected method | GetElement | Gets the element.
Protected method | GetExpression | Gets the expression.
Protected method | GetFactor | Gets the factor.
Protected method | GetFollowingAxis | Gets the following axis.
Protected method | GetFunction | Gets the function.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetNode | Gets the node.
Protected method | GetParameter | Gets the parameter.
Protected method | GetParentAxis | Gets the parent axis.
Protected method | GetPathStep | Gets the path step.
Protected method | GetPrecedingAxis | Gets the preceding axis.
Protected method | GetPredicate | Gets the predicate.
Protected method | GetQueries | Gets the queries.
Protected method | GetQuery | Gets the query.
Protected method | GetSelf | Gets the self.
Protected method | GetSelfAxis | Gets the self axis.
Protected method | GetTerm0 | Gets the term0.
Protected method | GetTerm1 | Gets the term1.
Protected method | GetTerm2 | Gets the term2.
Protected method | GetTerm3 | Gets the term3.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Match()()()() | Matches this instance.
Protected method | Match(Int32, String) | Matches the specified type.
Protected method | MatchCheck | Matches the check.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Parses the specified query.
 | ParsePredicate | Parses a predicate.
Protected method | Peek | Peeks this instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

QueryParser Class
Sitecore.Data.Query Namespace


DoParse Method

[image]

Sitecore 6.4.1 API
QueryParser..::..DoParse Method
QueryParser Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual Opcode DoParse(
    string query
)
Visual Basic
Protected Overridable Function DoParse ( _
    query As String _
) As Opcode
Visual C++
protected:
virtual Opcode^ DoParse(
    String^ query
)

Parameters

query
Type: System..::..String
Query.

Return Value

The Opcode.

See Also

QueryParser Class
Sitecore.Data.Query Namespace


DoParsePredicate Method

[image]

Sitecore 6.4.1 API
QueryParser..::..DoParsePredicate Method
QueryParser Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual Opcode DoParsePredicate(
    string query
)
Visual Basic
Protected Overridable Function DoParsePredicate ( _
    query As String _
) As Opcode
Visual C++
protected:
virtual Opcode^ DoParsePredicate(
    String^ query
)

Parameters

query
Type: System..::..String
Query.

Return Value

The Opcode.

See Also

QueryParser Class
Sitecore.Data.Query Namespace


GetAncestorAxis Method

[image]

Sitecore 6.4.1 API
QueryParser..::..GetAncestorAxis Method
QueryParser Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Step GetAncestorAxis()
Visual Basic
Protected Function GetAncestorAxis As Step
Visual C++
protected:
Step^ GetAncestorAxis()

Return Value

The ancestor axis.

See Also

QueryParser Class
Sitecore.Data.Query Namespace


GetAttribute Method

[image]

Sitecore 6.4.1 API
QueryParser..::..GetAttribute Method
QueryParser Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected ElementBase GetAttribute()
Visual Basic
Protected Function GetAttribute As ElementBase
Visual C++
protected:
ElementBase^ GetAttribute()

Return Value

The attribute.

See Also

QueryParser Class
Sitecore.Data.Query Namespace


GetChildAxis Method

[image]

Sitecore 6.4.1 API
QueryParser..::..GetChildAxis Method
QueryParser Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Step GetChildAxis()
Visual Basic
Protected Function GetChildAxis As Step
Visual C++
protected:
Step^ GetChildAxis()

Return Value

The child axis.

See Also

QueryParser Class
Sitecore.Data.Query Namespace


GetChildren Method

[image]

Sitecore 6.4.1 API
QueryParser..::..GetChildren Method
QueryParser Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Step GetChildren()
Visual Basic
Protected Function GetChildren As Step
Visual C++
protected:
Step^ GetChildren()

Return Value

The children.

See Also

QueryParser Class
Sitecore.Data.Query Namespace


GetDescendants Method

[image]

Sitecore 6.4.1 API
QueryParser..::..GetDescendants Method
QueryParser Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Step GetDescendants()
Visual Basic
Protected Function GetDescendants As Step
Visual C++
protected:
Step^ GetDescendants()

Return Value

The descendants.

See Also

QueryParser Class
Sitecore.Data.Query Namespace


GetDescendantsAxis Method

[image]

Sitecore 6.4.1 API
QueryParser..::..GetDescendantsAxis Method
QueryParser Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Step GetDescendantsAxis()
Visual Basic
Protected Function GetDescendantsAxis As Step
Visual C++
protected:
Step^ GetDescendantsAxis()

Return Value

The descendants axis.

See Also

QueryParser Class
Sitecore.Data.Query Namespace


GetDotDot Method

[image]

Sitecore 6.4.1 API
QueryParser..::..GetDotDot Method
QueryParser Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Step GetDotDot()
Visual Basic
Protected Function GetDotDot As Step
Visual C++
protected:
Step^ GetDotDot()

Return Value

The dot dot.

See Also

QueryParser Class
Sitecore.Data.Query Namespace


GetElement Method

[image]

Sitecore 6.4.1 API
QueryParser..::..GetElement Method
QueryParser Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected ElementBase GetElement()
Visual Basic
Protected Function GetElement As ElementBase
Visual C++
protected:
ElementBase^ GetElement()

Return Value

The element.

See Also

QueryParser Class
Sitecore.Data.Query Namespace


GetExpression Method

[image]

Sitecore 6.4.1 API
QueryParser..::..GetExpression Method
QueryParser Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Opcode GetExpression()
Visual Basic
Protected Function GetExpression As Opcode
Visual C++
protected:
Opcode^ GetExpression()

Return Value

The expression.

See Also

QueryParser Class
Sitecore.Data.Query Namespace


GetFactor Method

[image]

Sitecore 6.4.1 API
QueryParser..::..GetFactor Method
QueryParser Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Opcode GetFactor()
Visual Basic
Protected Function GetFactor As Opcode
Visual C++
protected:
Opcode^ GetFactor()

Return Value

The factor.

See Also

QueryParser Class
Sitecore.Data.Query Namespace


GetFollowingAxis Method

[image]

Sitecore 6.4.1 API
QueryParser..::..GetFollowingAxis Method
QueryParser Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Step GetFollowingAxis()
Visual Basic
Protected Function GetFollowingAxis As Step
Visual C++
protected:
Step^ GetFollowingAxis()

Return Value

The following axis.

See Also

QueryParser Class
Sitecore.Data.Query Namespace


GetFunction Method

[image]

Sitecore 6.4.1 API
QueryParser..::..GetFunction Method
QueryParser Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Opcode GetFunction()
Visual Basic
Protected Function GetFunction As Opcode
Visual C++
protected:
Opcode^ GetFunction()

Return Value

The function.

See Also

QueryParser Class
Sitecore.Data.Query Namespace


GetParameter Method

[image]

Sitecore 6.4.1 API
QueryParser..::..GetParameter Method
QueryParser Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected ElementBase GetParameter()
Visual Basic
Protected Function GetParameter As ElementBase
Visual C++
protected:
ElementBase^ GetParameter()

Return Value

The parameter.

See Also

QueryParser Class
Sitecore.Data.Query Namespace


GetParentAxis Method

[image]

Sitecore 6.4.1 API
QueryParser..::..GetParentAxis Method
QueryParser Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Step GetParentAxis()
Visual Basic
Protected Function GetParentAxis As Step
Visual C++
protected:
Step^ GetParentAxis()

Return Value

The parent axis.

See Also

QueryParser Class
Sitecore.Data.Query Namespace


GetPathStep Method

[image]

Sitecore 6.4.1 API
QueryParser..::..GetPathStep Method
QueryParser Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Step GetPathStep()
Visual Basic
Protected Function GetPathStep As Step
Visual C++
protected:
Step^ GetPathStep()

Return Value

The path step.

See Also

QueryParser Class
Sitecore.Data.Query Namespace


GetPrecedingAxis Method

[image]

Sitecore 6.4.1 API
QueryParser..::..GetPrecedingAxis Method
QueryParser Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Step GetPrecedingAxis()
Visual Basic
Protected Function GetPrecedingAxis As Step
Visual C++
protected:
Step^ GetPrecedingAxis()

Return Value

The preceding axis.

See Also

QueryParser Class
Sitecore.Data.Query Namespace


GetQueries Method

[image]

Sitecore 6.4.1 API
QueryParser..::..GetQueries Method
QueryParser Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Opcode GetQueries()
Visual Basic
Protected Function GetQueries As Opcode
Visual C++
protected:
Opcode^ GetQueries()

Return Value

The queries.

See Also

QueryParser Class
Sitecore.Data.Query Namespace


GetQuery Method

[image]

Sitecore 6.4.1 API
QueryParser..::..GetQuery Method
QueryParser Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Opcode GetQuery()
Visual Basic
Protected Function GetQuery As Opcode
Visual C++
protected:
Opcode^ GetQuery()

Return Value

The query.

See Also

QueryParser Class
Sitecore.Data.Query Namespace


GetSelf Method

[image]

Sitecore 6.4.1 API
QueryParser..::..GetSelf Method
QueryParser Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Step GetSelf()
Visual Basic
Protected Function GetSelf As Step
Visual C++
protected:
Step^ GetSelf()

Return Value

The self.

See Also

QueryParser Class
Sitecore.Data.Query Namespace


GetSelfAxis Method

[image]

Sitecore 6.4.1 API
QueryParser..::..GetSelfAxis Method
QueryParser Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Step GetSelfAxis()
Visual Basic
Protected Function GetSelfAxis As Step
Visual C++
protected:
Step^ GetSelfAxis()

Return Value

The self axis.

See Also

QueryParser Class
Sitecore.Data.Query Namespace


GetTerm0 Method

[image]

Sitecore 6.4.1 API
QueryParser..::..GetTerm0 Method
QueryParser Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Opcode GetTerm0()
Visual Basic
Protected Function GetTerm0 As Opcode
Visual C++
protected:
Opcode^ GetTerm0()

Return Value

The term0.

See Also

QueryParser Class
Sitecore.Data.Query Namespace


GetTerm1 Method

[image]

Sitecore 6.4.1 API
QueryParser..::..GetTerm1 Method
QueryParser Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Opcode GetTerm1()
Visual Basic
Protected Function GetTerm1 As Opcode
Visual C++
protected:
Opcode^ GetTerm1()

Return Value

The term1.

See Also

QueryParser Class
Sitecore.Data.Query Namespace


GetTerm2 Method

[image]

Sitecore 6.4.1 API
QueryParser..::..GetTerm2 Method
QueryParser Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Opcode GetTerm2()
Visual Basic
Protected Function GetTerm2 As Opcode
Visual C++
protected:
Opcode^ GetTerm2()

Return Value

The term2.

See Also

QueryParser Class
Sitecore.Data.Query Namespace


GetTerm3 Method

[image]

Sitecore 6.4.1 API
QueryParser..::..GetTerm3 Method
QueryParser Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Opcode GetTerm3()
Visual Basic
Protected Function GetTerm3 As Opcode
Visual C++
protected:
Opcode^ GetTerm3()

Return Value

The term3.

See Also

QueryParser Class
Sitecore.Data.Query Namespace


Match Method

[image] [image]

Sitecore 6.4.1 API
QueryParser..::..Match Method
QueryParser Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Match()()()() | Matches this instance.
Protected method | Match(Int32, String) | Matches the specified type.

See Also

QueryParser Class
QueryParser Members
Sitecore.Data.Query Namespace


Match Method

[image]

Sitecore 6.4.1 API
QueryParser..::..Match Method
QueryParser Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void Match()
Visual Basic
Protected Sub Match
Visual C++
protected:
void Match()

See Also

QueryParser Class
Match Overload
Sitecore.Data.Query Namespace


Match Method (Int32, String)

[image]

Sitecore 6.4.1 API
QueryParser..::..Match Method (Int32, String)
QueryParser Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void Match(
    int type,
    string error
)
Visual Basic
Protected Sub Match ( _
    type As Integer, _
    error As String _
)
Visual C++
protected:
void Match(
    int type,
    String^ error
)

Parameters

type
Type: System..::..Int32
The type.
error
Type: System..::..String
The error.

See Also

QueryParser Class
Match Overload
Sitecore.Data.Query Namespace


MatchCheck Method

[image]

Sitecore 6.4.1 API
QueryParser..::..MatchCheck Method
QueryParser Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void MatchCheck(
    int type,
    string error
)
Visual Basic
Protected Sub MatchCheck ( _
    type As Integer, _
    error As String _
)
Visual C++
protected:
void MatchCheck(
    int type,
    String^ error
)

Parameters

type
Type: System..::..Int32
The type.
error
Type: System..::..String
The error.

See Also

QueryParser Class
Sitecore.Data.Query Namespace


Parse Method

[image]

Sitecore 6.4.1 API
QueryParser..::..Parse Method
QueryParser Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Opcode Parse(
    string query
)
Visual Basic
Public Shared Function Parse ( _
    query As String _
) As Opcode
Visual C++
public:
static Opcode^ Parse(
    String^ query
)

Parameters

query
Type: System..::..String
Query.

Return Value

The parse.

See Also

QueryParser Class
Sitecore.Data.Query Namespace


ParsePredicate Method

[image]

Sitecore 6.4.1 API
QueryParser..::..ParsePredicate Method
QueryParser Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Opcode ParsePredicate(
    string query
)
Visual Basic
Public Shared Function ParsePredicate ( _
    query As String _
) As Opcode
Visual C++
public:
static Opcode^ ParsePredicate(
    String^ query
)

Parameters

query
Type: System..::..String
Query.

Return Value

The predicate.

See Also

QueryParser Class
Sitecore.Data.Query Namespace


Peek Method

[image]

Sitecore 6.4.1 API
QueryParser..::..Peek Method
QueryParser Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected int Peek()
Visual Basic
Protected Function Peek As Integer
Visual C++
protected:
int Peek()

Return Value

The peek.

See Also

QueryParser Class
Sitecore.Data.Query Namespace


QueryTokenBuilder Class

[image]

Sitecore 6.4.1 API
QueryTokenBuilder Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class QueryTokenBuilder : TokenBuilder
Visual Basic
Public Class QueryTokenBuilder _
    Inherits TokenBuilder
Visual C++
public ref class QueryTokenBuilder : public TokenBuilder

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..TokenBuilder
Sitecore.Data.Query..::..QueryTokenBuilder

See Also

QueryTokenBuilder Members
Sitecore.Data.Query Namespace


QueryTokenBuilder Members

[image] [image]

Sitecore 6.4.1 API
QueryTokenBuilder Members
QueryTokenBuilder Class Constructors Methods Fields See Also Send Feedback

The QueryTokenBuilder type exposes the following members.

Constructors

 | Name | Description
Public method | QueryTokenBuilder | Initializes a new instance of the QueryTokenBuilder class

Methods

 | Name | Description
Public method | At | At. (Inherited from TokenBuilder.)
Public method | Axis | Axis. (Inherited from TokenBuilder.)
Public method | Comma | Comma. (Inherited from TokenBuilder.)
Public method | Dollar | Dollar. (Inherited from TokenBuilder.)
Public method | Dot | Dot. (Inherited from TokenBuilder.)
Public method | DotDot | Dot dot. (Inherited from TokenBuilder.)
Public method | DoubleSlash | Double slash. (Inherited from TokenBuilder.)
Public method | End | End. (Inherited from TokenBuilder.)
Public method | EndParentes | End parentes. (Inherited from TokenBuilder.)
Public method | EndSquareBracket | End square bracket. (Inherited from TokenBuilder.)
Public method | Equals()()()() | Equal. (Inherited from TokenBuilder.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Greater | Greater. (Inherited from TokenBuilder.)
Public method | GreaterOrEquals | Greater or equals. (Inherited from TokenBuilder.)
Public method | Guid | GUID. (Inherited from TokenBuilder.)
Public method | Identifier | Maps an identifier to a keyword. (Overrides TokenBuilder..::..Identifier(String).)
Public method | Literal | Literal. (Inherited from TokenBuilder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Minus | Minus. (Inherited from TokenBuilder.)
Public method | Namespace | Namespace. (Inherited from TokenBuilder.)
Public method | Number | Number. (Inherited from TokenBuilder.)
Public method | Pipe | Pipe. (Inherited from TokenBuilder.)
Public method | Plus | Plus. (Inherited from TokenBuilder.)
Public method | Slash | Slash. (Inherited from TokenBuilder.)
Public method | Smaller | Smaller. (Inherited from TokenBuilder.)
Public method | SmallerOrEquals | Smaller or equal. (Inherited from TokenBuilder.)
Public method | Star | Star. (Inherited from TokenBuilder.)
Public method | StartParentes | Start parentes. (Inherited from TokenBuilder.)
Public method | StartSquareBracket | Start square bracket. (Inherited from TokenBuilder.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unequals | Unequal. (Inherited from TokenBuilder.)

Fields

 | Name | Description
Public field | Token | The current token. (Inherited from TokenBuilder.)

See Also

QueryTokenBuilder Class
Sitecore.Data.Query Namespace


QueryTokenBuilder Constructor

[image]

Sitecore 6.4.1 API
QueryTokenBuilder Constructor
QueryTokenBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public QueryTokenBuilder()
Visual Basic
Public Sub New
Visual C++
public:
QueryTokenBuilder()

See Also

QueryTokenBuilder Class
Sitecore.Data.Query Namespace


QueryTokenBuilder Fields

[image] [image]

Sitecore 6.4.1 API
QueryTokenBuilder Fields
QueryTokenBuilder Class See Also Send Feedback

The QueryTokenBuilder type exposes the following members.

Fields

 | Name | Description
Public field | Token | The current token. (Inherited from TokenBuilder.)

See Also

QueryTokenBuilder Class
Sitecore.Data.Query Namespace


QueryTokenBuilder Methods

[image] [image]

Sitecore 6.4.1 API
QueryTokenBuilder Methods
QueryTokenBuilder Class See Also Send Feedback

The QueryTokenBuilder type exposes the following members.

Methods

 | Name | Description
Public method | At | At. (Inherited from TokenBuilder.)
Public method | Axis | Axis. (Inherited from TokenBuilder.)
Public method | Comma | Comma. (Inherited from TokenBuilder.)
Public method | Dollar | Dollar. (Inherited from TokenBuilder.)
Public method | Dot | Dot. (Inherited from TokenBuilder.)
Public method | DotDot | Dot dot. (Inherited from TokenBuilder.)
Public method | DoubleSlash | Double slash. (Inherited from TokenBuilder.)
Public method | End | End. (Inherited from TokenBuilder.)
Public method | EndParentes | End parentes. (Inherited from TokenBuilder.)
Public method | EndSquareBracket | End square bracket. (Inherited from TokenBuilder.)
Public method | Equals()()()() | Equal. (Inherited from TokenBuilder.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Greater | Greater. (Inherited from TokenBuilder.)
Public method | GreaterOrEquals | Greater or equals. (Inherited from TokenBuilder.)
Public method | Guid | GUID. (Inherited from TokenBuilder.)
Public method | Identifier | Maps an identifier to a keyword. (Overrides TokenBuilder..::..Identifier(String).)
Public method | Literal | Literal. (Inherited from TokenBuilder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Minus | Minus. (Inherited from TokenBuilder.)
Public method | Namespace | Namespace. (Inherited from TokenBuilder.)
Public method | Number | Number. (Inherited from TokenBuilder.)
Public method | Pipe | Pipe. (Inherited from TokenBuilder.)
Public method | Plus | Plus. (Inherited from TokenBuilder.)
Public method | Slash | Slash. (Inherited from TokenBuilder.)
Public method | Smaller | Smaller. (Inherited from TokenBuilder.)
Public method | SmallerOrEquals | Smaller or equal. (Inherited from TokenBuilder.)
Public method | Star | Star. (Inherited from TokenBuilder.)
Public method | StartParentes | Start parentes. (Inherited from TokenBuilder.)
Public method | StartSquareBracket | Start square bracket. (Inherited from TokenBuilder.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unequals | Unequal. (Inherited from TokenBuilder.)

See Also

QueryTokenBuilder Class
Sitecore.Data.Query Namespace


Equals Method

[image] [image]

Sitecore 6.4.1 API
QueryTokenBuilder..::..Equals Method
QueryTokenBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals()()()() | Equal. (Inherited from TokenBuilder.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)

See Also

QueryTokenBuilder Class
QueryTokenBuilder Members
Sitecore.Data.Query Namespace


Identifier Method

[image]

Sitecore 6.4.1 API
QueryTokenBuilder..::..Identifier Method
QueryTokenBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Identifier(
    string value
)
Visual Basic
Public Overrides Sub Identifier ( _
    value As String _
)
Visual C++
public:
virtual void Identifier(
    String^ value
) override

Parameters

value
Type: System..::..String
Identifier.

See Also

QueryTokenBuilder Class
Sitecore.Data.Query Namespace


QueryTokenType Class

[image]

Sitecore 6.4.1 API
QueryTokenType Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class QueryTokenType : TokenType
Visual Basic
Public Class QueryTokenType _
    Inherits TokenType
Visual C++
public ref class QueryTokenType : public TokenType

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..TokenType
Sitecore.Data.Query..::..QueryTokenType

See Also

QueryTokenType Members
Sitecore.Data.Query Namespace


QueryTokenType Members

[image] [image]

Sitecore 6.4.1 API
QueryTokenType Members
QueryTokenType Class Constructors Methods Fields See Also Send Feedback

The QueryTokenType type exposes the following members.

Constructors

 | Name | Description
Public method | QueryTokenType | Initializes a new instance of the QueryTokenType class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Ancestor | Ancestor
And | And
Child | Child
Descendant | Descandant
Div | Div
False | False
Following | Following
Mod | Modulus
Or | Or
Parent | Parent
Preceding | Preceding
Self | Self
True | True
Xor | Xor

See Also

QueryTokenType Class
Sitecore.Data.Query Namespace


QueryTokenType Constructor

[image]

Sitecore 6.4.1 API
QueryTokenType Constructor
QueryTokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public QueryTokenType()
Visual Basic
Public Sub New
Visual C++
public:
QueryTokenType()

See Also

QueryTokenType Class
Sitecore.Data.Query Namespace


QueryTokenType Fields

[image] [image]

Sitecore 6.4.1 API
QueryTokenType Fields
QueryTokenType Class See Also Send Feedback

The QueryTokenType type exposes the following members.

Fields

Name | Description
Ancestor | Ancestor
And | And
Child | Child
Descendant | Descandant
Div | Div
False | False
Following | Following
Mod | Modulus
Or | Or
Parent | Parent
Preceding | Preceding
Self | Self
True | True
Xor | Xor

See Also

QueryTokenType Class
Sitecore.Data.Query Namespace


Ancestor Field

[image]

Sitecore 6.4.1 API
QueryTokenType..::..Ancestor Field
QueryTokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int Ancestor
Visual Basic
Public Const Ancestor As Integer
Visual C++
public:
literal int Ancestor

See Also

QueryTokenType Class
Sitecore.Data.Query Namespace


And Field

[image]

Sitecore 6.4.1 API
QueryTokenType..::..And Field
QueryTokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int And
Visual Basic
Public Const And As Integer
Visual C++
public:
literal int And

See Also

QueryTokenType Class
Sitecore.Data.Query Namespace


Child Field

[image]

Sitecore 6.4.1 API
QueryTokenType..::..Child Field
QueryTokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int Child
Visual Basic
Public Const Child As Integer
Visual C++
public:
literal int Child

See Also

QueryTokenType Class
Sitecore.Data.Query Namespace


Descendant Field

[image]

Sitecore 6.4.1 API
QueryTokenType..::..Descendant Field
QueryTokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int Descendant
Visual Basic
Public Const Descendant As Integer
Visual C++
public:
literal int Descendant

See Also

QueryTokenType Class
Sitecore.Data.Query Namespace


Div Field

[image]

Sitecore 6.4.1 API
QueryTokenType..::..Div Field
QueryTokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int Div
Visual Basic
Public Const Div As Integer
Visual C++
public:
literal int Div

See Also

QueryTokenType Class
Sitecore.Data.Query Namespace


False Field

[image]

Sitecore 6.4.1 API
QueryTokenType..::..False Field
QueryTokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int False
Visual Basic
Public Const False As Integer
Visual C++
public:
literal int False

See Also

QueryTokenType Class
Sitecore.Data.Query Namespace


Following Field

[image]

Sitecore 6.4.1 API
QueryTokenType..::..Following Field
QueryTokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int Following
Visual Basic
Public Const Following As Integer
Visual C++
public:
literal int Following

See Also

QueryTokenType Class
Sitecore.Data.Query Namespace


Mod Field

[image]

Sitecore 6.4.1 API
QueryTokenType..::..Mod Field
QueryTokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int Mod
Visual Basic
Public Const Mod As Integer
Visual C++
public:
literal int Mod

See Also

QueryTokenType Class
Sitecore.Data.Query Namespace


Or Field

[image]

Sitecore 6.4.1 API
QueryTokenType..::..Or Field
QueryTokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int Or
Visual Basic
Public Const Or As Integer
Visual C++
public:
literal int Or

See Also

QueryTokenType Class
Sitecore.Data.Query Namespace


Parent Field

[image]

Sitecore 6.4.1 API
QueryTokenType..::..Parent Field
QueryTokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int Parent
Visual Basic
Public Const Parent As Integer
Visual C++
public:
literal int Parent

See Also

QueryTokenType Class
Sitecore.Data.Query Namespace


Self Field

[image]

Sitecore 6.4.1 API
QueryTokenType..::..Self Field
QueryTokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int Self
Visual Basic
Public Const Self As Integer
Visual C++
public:
literal int Self

See Also

QueryTokenType Class
Sitecore.Data.Query Namespace


True Field

[image]

Sitecore 6.4.1 API
QueryTokenType..::..True Field
QueryTokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int True
Visual Basic
Public Const True As Integer
Visual C++
public:
literal int True

See Also

QueryTokenType Class
Sitecore.Data.Query Namespace


Xor Field

[image]

Sitecore 6.4.1 API
QueryTokenType..::..Xor Field
QueryTokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int Xor
Visual Basic
Public Const Xor As Integer
Visual C++
public:
literal int Xor

See Also

QueryTokenType Class
Sitecore.Data.Query Namespace


QueryTokenType Methods

[image] [image]

Sitecore 6.4.1 API
QueryTokenType Methods
QueryTokenType Class See Also Send Feedback

The QueryTokenType type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

QueryTokenType Class
Sitecore.Data.Query Namespace


QueryUtil Class

[image]

Sitecore 6.4.1 API
QueryUtil Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class QueryUtil
Visual Basic
Public NotInheritable Class QueryUtil
Visual C++
public ref class QueryUtil abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..QueryUtil

See Also

QueryUtil Members
Sitecore.Data.Query Namespace


QueryUtil Members

[image] [image]

Sitecore 6.4.1 API
QueryUtil Members
QueryUtil Class Methods See Also Send Feedback

The QueryUtil type exposes the following members.

Methods

Name | Description
CanResolve | Determines whether an object can be resolved.
IsQueryPath | Determines whether if a string is a query path.

See Also

QueryUtil Class
Sitecore.Data.Query Namespace


QueryUtil Methods

[image] [image]

Sitecore 6.4.1 API
QueryUtil Methods
QueryUtil Class See Also Send Feedback

The QueryUtil type exposes the following members.

Methods

Name | Description
CanResolve | Determines whether an object can be resolved.
IsQueryPath | Determines whether if a string is a query path.

See Also

QueryUtil Class
Sitecore.Data.Query Namespace


CanResolve Method

[image]

Sitecore 6.4.1 API
QueryUtil..::..CanResolve Method
QueryUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool CanResolve(
    Object obj,
    DataUri uri
)
Visual Basic
Public Shared Function CanResolve ( _
    obj As Object, _
    uri As DataUri _
) As Boolean
Visual C++
public:
static bool CanResolve(
    Object^ obj,
    DataUri^ uri
)

Parameters

obj
Type: System..::..Object
Obj.
uri
Type: Sitecore.Data..::..DataUri
URI.

Return Value

true if an object can be resolved; otherwise, false.

See Also

QueryUtil Class
Sitecore.Data.Query Namespace


IsQueryPath Method

[image]

Sitecore 6.4.1 API
QueryUtil..::..IsQueryPath Method
QueryUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsQueryPath(
    string path
)
Visual Basic
Public Shared Function IsQueryPath ( _
    path As String _
) As Boolean
Visual C++
public:
static bool IsQueryPath(
    String^ path
)

Parameters

path
Type: System..::..String
Path.

Return Value

true if a string is a query path; otherwise, false.

Remarks

A query path is defined by containing either a "[" or a "::" string.

See Also

QueryUtil Class
Sitecore.Data.Query Namespace


Root Class

[image]

Sitecore 6.4.1 API
Root Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Root : Step
Visual Basic
Public Class Root _
    Inherits Step
Visual C++
public ref class Root : public Step

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..Opcode
Sitecore.Data.Query..::..Step
Sitecore.Data.Query..::..Root

See Also

Root Members
Sitecore.Data.Query Namespace


Root Members

[image] [image]

Sitecore 6.4.1 API
Root Members
Root Class Constructors Methods Properties See Also Send Feedback

The Root type exposes the following members.

Constructors

 | Name | Description
Public method | Root | Initializes a new instance of the Root class

Methods

 | Name | Description
Protected method | Break | Breaks the query. (Inherited from Step.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Overrides Opcode..::..Evaluate(Query, QueryContext).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from Step.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | NextStep | Gets or sets the next step. (Inherited from Step.)

See Also

Root Class
Sitecore.Data.Query Namespace


Root Constructor

[image]

Sitecore 6.4.1 API
Root Constructor
Root Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Root()
Visual Basic
Public Sub New
Visual C++
public:
Root()

See Also

Root Class
Sitecore.Data.Query Namespace


Root Methods

[image] [image]

Sitecore 6.4.1 API
Root Methods
Root Class See Also Send Feedback

The Root type exposes the following members.

Methods

 | Name | Description
Protected method | Break | Breaks the query. (Inherited from Step.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Overrides Opcode..::..Evaluate(Query, QueryContext).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from Step.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Root Class
Sitecore.Data.Query Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
Root..::..Evaluate Method
Root Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Object Evaluate(
    Query query,
    QueryContext node
)
Visual Basic
Public Overrides Function Evaluate ( _
    query As Query, _
    node As QueryContext _
) As Object
Visual C++
public:
virtual Object^ Evaluate(
    Query^ query,
    QueryContext^ node
) override

Parameters

query
Type: Sitecore.Data.Query..::..Query
Query.
node
Type: Sitecore.Data.Query..::..QueryContext
Node.

Return Value

The result of the evaluation.

See Also

Root Class
Sitecore.Data.Query Namespace


Self Class

[image]

Sitecore 6.4.1 API
Self Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Self : Step
Visual Basic
Public Class Self _
    Inherits Step
Visual C++
public ref class Self : public Step

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..Opcode
Sitecore.Data.Query..::..Step
Sitecore.Data.Query..::..Self

See Also

Self Members
Sitecore.Data.Query Namespace


Self Members

[image] [image]

Sitecore 6.4.1 API
Self Members
Self Class Constructors Methods Properties See Also Send Feedback

The Self type exposes the following members.

Constructors

 | Name | Description
Public method | Self | Creates a new Self instance.

Methods

 | Name | Description
Protected method | Break | Breaks the query. (Inherited from Step.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Overrides Opcode..::..Evaluate(Query, QueryContext).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Overrides Step..::..Print(HtmlTextWriter).)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | NextStep | Gets or sets the next step. (Inherited from Step.)

See Also

Self Class
Sitecore.Data.Query Namespace


Self Constructor

[image]

Sitecore 6.4.1 API
Self Constructor
Self Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Self(
    Predicate predicate
)
Visual Basic
Public Sub New ( _
    predicate As Predicate _
)
Visual C++
public:
Self(
    Predicate^ predicate
)

Parameters

predicate
Type: Sitecore.Data.Query..::..Predicate
Predicate.

See Also

Self Class
Sitecore.Data.Query Namespace


Self Methods

[image] [image]

Sitecore 6.4.1 API
Self Methods
Self Class See Also Send Feedback

The Self type exposes the following members.

Methods

 | Name | Description
Protected method | Break | Breaks the query. (Inherited from Step.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Overrides Opcode..::..Evaluate(Query, QueryContext).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Overrides Step..::..Print(HtmlTextWriter).)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Self Class
Sitecore.Data.Query Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
Self..::..Evaluate Method
Self Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Object Evaluate(
    Query query,
    QueryContext node
)
Visual Basic
Public Overrides Function Evaluate ( _
    query As Query, _
    node As QueryContext _
) As Object
Visual C++
public:
virtual Object^ Evaluate(
    Query^ query,
    QueryContext^ node
) override

Parameters

query
Type: Sitecore.Data.Query..::..Query
Query.
node
Type: Sitecore.Data.Query..::..QueryContext
Node.

Return Value

The result of the evaluation.

See Also

Self Class
Sitecore.Data.Query Namespace


Print Method

[image]

Sitecore 6.4.1 API
Self..::..Print Method
Self Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Print(
    HtmlTextWriter output
)
Visual Basic
Public Overrides Sub Print ( _
    output As HtmlTextWriter _
)
Visual C++
public:
virtual void Print(
    HtmlTextWriter^ output
) override

Parameters

output
Type: System.Web.UI..::..HtmlTextWriter
Output.

See Also

Self Class
Sitecore.Data.Query Namespace


Self Properties

[image] [image]

Sitecore 6.4.1 API
Self Properties
Self Class See Also Send Feedback

The Self type exposes the following members.

Properties

 | Name | Description
Public property | NextStep | Gets or sets the next step. (Inherited from Step.)

See Also

Self Class
Sitecore.Data.Query Namespace


SmallerOperator Members

[image] [image]

Sitecore 6.4.1 API
SmallerOperator Members
SmallerOperator Class Constructors Methods Properties See Also Send Feedback

The SmallerOperator type exposes the following members.

Constructors

 | Name | Description
Public method | SmallerOperator | Creates a new SmallerOperator instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Inherited from BinaryOperator.)
Public method | EvaluateOperands | Evaluates the expression. (Overrides BinaryOperator..::..EvaluateOperands(Object, Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from BinaryOperator.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Left | Gets the left expression. (Inherited from BinaryOperator.)
Public property | Right | Gets the right expression. (Inherited from BinaryOperator.)

See Also

SmallerOperator Class
Sitecore.Data.Query Namespace


SmallerOperator Constructor

[image]

Sitecore 6.4.1 API
SmallerOperator Constructor
SmallerOperator Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SmallerOperator(
    Opcode left,
    Opcode right
)
Visual Basic
Public Sub New ( _
    left As Opcode, _
    right As Opcode _
)
Visual C++
public:
SmallerOperator(
    Opcode^ left,
    Opcode^ right
)

Parameters

left
Type: Sitecore.Data.Query..::..Opcode
Left expression.
right
Type: Sitecore.Data.Query..::..Opcode
Right expression.

See Also

SmallerOperator Class
Sitecore.Data.Query Namespace


SmallerOperator Methods

[image] [image]

Sitecore 6.4.1 API
SmallerOperator Methods
SmallerOperator Class See Also Send Feedback

The SmallerOperator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Inherited from BinaryOperator.)
Public method | EvaluateOperands | Evaluates the expression. (Overrides BinaryOperator..::..EvaluateOperands(Object, Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from BinaryOperator.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SmallerOperator Class
Sitecore.Data.Query Namespace


EvaluateOperands Method

[image]

Sitecore 6.4.1 API
SmallerOperator..::..EvaluateOperands Method
SmallerOperator Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Object EvaluateOperands(
    Object left,
    Object right
)
Visual Basic
Public Overrides Function EvaluateOperands ( _
    left As Object, _
    right As Object _
) As Object
Visual C++
public:
virtual Object^ EvaluateOperands(
    Object^ left,
    Object^ right
) override

Parameters

left
Type: System..::..Object
Left expression.
right
Type: System..::..Object
Right expression.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Query.SmallerOperator.EvaluateOperands(System.Object,System.Object)"]

See Also

SmallerOperator Class
Sitecore.Data.Query Namespace


SmallerOperator Properties

[image] [image]

Sitecore 6.4.1 API
SmallerOperator Properties
SmallerOperator Class See Also Send Feedback

The SmallerOperator type exposes the following members.

Properties

 | Name | Description
Public property | Left | Gets the left expression. (Inherited from BinaryOperator.)
Public property | Right | Gets the right expression. (Inherited from BinaryOperator.)

See Also

SmallerOperator Class
Sitecore.Data.Query Namespace


SmallerOrEqualsOperator Class

[image]

Sitecore 6.4.1 API
SmallerOrEqualsOperator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SmallerOrEqualsOperator : BinaryOperator
Visual Basic
Public Class SmallerOrEqualsOperator _
    Inherits BinaryOperator
Visual C++
public ref class SmallerOrEqualsOperator : public BinaryOperator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..Opcode
Sitecore.Data.Query..::..BinaryOperator
Sitecore.Data.Query..::..SmallerOrEqualsOperator

See Also

SmallerOrEqualsOperator Members
Sitecore.Data.Query Namespace


SmallerOrEqualsOperator Members

[image] [image]

Sitecore 6.4.1 API
SmallerOrEqualsOperator Members
SmallerOrEqualsOperator Class Constructors Methods Properties See Also Send Feedback

The SmallerOrEqualsOperator type exposes the following members.

Constructors

 | Name | Description
Public method | SmallerOrEqualsOperator | Creates a new SmallerOrEqualsOperator instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Inherited from BinaryOperator.)
Public method | EvaluateOperands | Evaluates the expression. (Overrides BinaryOperator..::..EvaluateOperands(Object, Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from BinaryOperator.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Left | Gets the left expression. (Inherited from BinaryOperator.)
Public property | Right | Gets the right expression. (Inherited from BinaryOperator.)

See Also

SmallerOrEqualsOperator Class
Sitecore.Data.Query Namespace


SmallerOrEqualsOperator Constructor

[image]

Sitecore 6.4.1 API
SmallerOrEqualsOperator Constructor
SmallerOrEqualsOperator Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SmallerOrEqualsOperator(
    Opcode left,
    Opcode right
)
Visual Basic
Public Sub New ( _
    left As Opcode, _
    right As Opcode _
)
Visual C++
public:
SmallerOrEqualsOperator(
    Opcode^ left,
    Opcode^ right
)

Parameters

left
Type: Sitecore.Data.Query..::..Opcode
Left expression.
right
Type: Sitecore.Data.Query..::..Opcode
Right expression.

See Also

SmallerOrEqualsOperator Class
Sitecore.Data.Query Namespace


EvaluateOperands Method

[image]

Sitecore 6.4.1 API
SmallerOrEqualsOperator..::..EvaluateOperands Method
SmallerOrEqualsOperator Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Object EvaluateOperands(
    Object left,
    Object right
)
Visual Basic
Public Overrides Function EvaluateOperands ( _
    left As Object, _
    right As Object _
) As Object
Visual C++
public:
virtual Object^ EvaluateOperands(
    Object^ left,
    Object^ right
) override

Parameters

left
Type: System..::..Object
Left expression.
right
Type: System..::..Object
Right expression.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Query.SmallerOrEqualsOperator.EvaluateOperands(System.Object,System.Object)"]

See Also

SmallerOrEqualsOperator Class
Sitecore.Data.Query Namespace


SmallerOrEqualsOperator Properties

[image] [image]

Sitecore 6.4.1 API
SmallerOrEqualsOperator Properties
SmallerOrEqualsOperator Class See Also Send Feedback

The SmallerOrEqualsOperator type exposes the following members.

Properties

 | Name | Description
Public property | Left | Gets the left expression. (Inherited from BinaryOperator.)
Public property | Right | Gets the right expression. (Inherited from BinaryOperator.)

See Also

SmallerOrEqualsOperator Class
Sitecore.Data.Query Namespace


Step Class

[image]

Sitecore 6.4.1 API
Step Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class Step : Opcode
Visual Basic
Public MustInherit Class Step _
    Inherits Opcode
Visual C++
public ref class Step abstract : public Opcode

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..Opcode
Sitecore.Data.Query..::..Step
Sitecore.Data.Query..::..Ancestor
Sitecore.Data.Query..::..Children
Sitecore.Data.Query..::..Descendant
Sitecore.Data.Query..::..ElementBase
Sitecore.Data.Query..::..Following
Sitecore.Data.Query..::..Parent
Sitecore.Data.Query..::..Preceding
Sitecore.Data.Query..::..Predicate
Sitecore.Data.Query..::..Root
Sitecore.Data.Query..::..Self

See Also

Step Members
Sitecore.Data.Query Namespace


Step Members

[image] [image]

Sitecore 6.4.1 API
Step Members
Step Class Constructors Methods Properties See Also Send Feedback

The Step type exposes the following members.

Constructors

 | Name | Description
Protected method | Step | Initializes a new instance of the Step class

Methods

 | Name | Description
Protected method | Break | Breaks the query.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Inherited from Opcode.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Overrides Opcode..::..Print(HtmlTextWriter).)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | NextStep | Gets or sets the next step.

See Also

Step Class
Sitecore.Data.Query Namespace


Step Constructor

[image]

Sitecore 6.4.1 API
Step Constructor
Step Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Step()
Visual Basic
Protected Sub New
Visual C++
protected:
Step()

See Also

Step Class
Sitecore.Data.Query Namespace


Step Methods

[image] [image]

Sitecore 6.4.1 API
Step Methods
Step Class See Also Send Feedback

The Step type exposes the following members.

Methods

 | Name | Description
Protected method | Break | Breaks the query.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Inherited from Opcode.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Overrides Opcode..::..Print(HtmlTextWriter).)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Step Class
Sitecore.Data.Query Namespace


Break Method

[image]

Sitecore 6.4.1 API
Step..::..Break Method
Step Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected bool Break(
    Query query,
    Object result
)
Visual Basic
Protected Function Break ( _
    query As Query, _
    result As Object _
) As Boolean
Visual C++
protected:
bool Break(
    Query^ query,
    Object^ result
)

Parameters

query
Type: Sitecore.Data.Query..::..Query
Query.
result
Type: System..::..Object
Result.

Return Value

The break.

See Also

Step Class
Sitecore.Data.Query Namespace


Print Method

[image]

Sitecore 6.4.1 API
Step..::..Print Method
Step Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Print(
    HtmlTextWriter output
)
Visual Basic
Public Overrides Sub Print ( _
    output As HtmlTextWriter _
)
Visual C++
public:
virtual void Print(
    HtmlTextWriter^ output
) override

Parameters

output
Type: System.Web.UI..::..HtmlTextWriter
Output.

See Also

Step Class
Sitecore.Data.Query Namespace


Step Properties

[image] [image]

Sitecore 6.4.1 API
Step Properties
Step Class See Also Send Feedback

The Step type exposes the following members.

Properties

 | Name | Description
Public property | NextStep | Gets or sets the next step.

See Also

Step Class
Sitecore.Data.Query Namespace


NextStep Property

[image]

Sitecore 6.4.1 API
Step..::..NextStep Property
Step Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Step NextStep { get; set; }
Visual Basic
Public Property NextStep As Step
    Get
    Set
Visual C++
public:
property Step^ NextStep {
    Step^ get ();
    void set (Step^ value);
}

Field Value

The next step.

See Also

Step Class
Sitecore.Data.Query Namespace


Token Structure

[image]

Sitecore 6.4.1 API
Token Structure
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public struct Token
Visual Basic
Public Structure Token
Visual C++
public value class Token

See Also

Token Members
Sitecore.Data.Query Namespace


Token Members

[image] [image]

Sitecore 6.4.1 API
Token Members
Token Structure Methods Fields See Also Send Feedback

The Token type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | Index | Index.
Public field | NumberValue | NumberValue.
Public field | Type | Type.
Public field | Value | Value.
Public field | Whitespace | Whitespace.

See Also

Token Structure
Sitecore.Data.Query Namespace


Token Fields

[image] [image]

Sitecore 6.4.1 API
Token Fields
Token Structure See Also Send Feedback

The Token type exposes the following members.

Fields

 | Name | Description
Public field | Index | Index.
Public field | NumberValue | NumberValue.
Public field | Type | Type.
Public field | Value | Value.
Public field | Whitespace | Whitespace.

See Also

Token Structure
Sitecore.Data.Query Namespace


Index Field

[image]

Sitecore 6.4.1 API
Token..::..Index Field
Token Structure See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Index
Visual Basic
Public Index As Integer
Visual C++
public:
int Index

See Also

Token Structure
Sitecore.Data.Query Namespace


NumberValue Field

[image]

Sitecore 6.4.1 API
Token..::..NumberValue Field
Token Structure See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int NumberValue
Visual Basic
Public NumberValue As Integer
Visual C++
public:
int NumberValue

See Also

Token Structure
Sitecore.Data.Query Namespace


Type Field

[image]

Sitecore 6.4.1 API
Token..::..Type Field
Token Structure See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Type
Visual Basic
Public Type As Integer
Visual C++
public:
int Type

See Also

Token Structure
Sitecore.Data.Query Namespace


Value Field

[image]

Sitecore 6.4.1 API
Token..::..Value Field
Token Structure See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Value
Visual Basic
Public Value As String
Visual C++
public:
String^ Value

See Also

Token Structure
Sitecore.Data.Query Namespace


Whitespace Field

[image]

Sitecore 6.4.1 API
Token..::..Whitespace Field
Token Structure See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Whitespace
Visual Basic
Public Whitespace As String
Visual C++
public:
String^ Whitespace

See Also

Token Structure
Sitecore.Data.Query Namespace


Token Methods

[image] [image]

Sitecore 6.4.1 API
Token Methods
Token Structure See Also Send Feedback

The Token type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

Token Structure
Sitecore.Data.Query Namespace


TokenBuilder Class

[image]

Sitecore 6.4.1 API
TokenBuilder Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class TokenBuilder
Visual Basic
Public Class TokenBuilder
Visual C++
public ref class TokenBuilder

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..TokenBuilder
Sitecore.Data.Query..::..QueryTokenBuilder

See Also

TokenBuilder Members
Sitecore.Data.Query Namespace


TokenBuilder Members

[image] [image]

Sitecore 6.4.1 API
TokenBuilder Members
TokenBuilder Class Constructors Methods Fields See Also Send Feedback

The TokenBuilder type exposes the following members.

Constructors

 | Name | Description
Public method | TokenBuilder | Initializes a new instance of the TokenBuilder class

Methods

 | Name | Description
Public method | At | At.
Public method | Axis | Axis.
Public method | Comma | Comma.
Public method | Dollar | Dollar.
Public method | Dot | Dot.
Public method | DotDot | Dot dot.
Public method | DoubleSlash | Double slash.
Public method | End | End.
Public method | EndParentes | End parentes.
Public method | EndSquareBracket | End square bracket.
Public method | Equals()()()() | Equal.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Greater | Greater.
Public method | GreaterOrEquals | Greater or equals.
Public method | Guid | GUID.
Public method | Identifier | Identifier.
Public method | Literal | Literal.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Minus | Minus.
Public method | Namespace | Namespace.
Public method | Number | Number.
Public method | Pipe | Pipe.
Public method | Plus | Plus.
Public method | Slash | Slash.
Public method | Smaller | Smaller.
Public method | SmallerOrEquals | Smaller or equal.
Public method | Star | Star.
Public method | StartParentes | Start parentes.
Public method | StartSquareBracket | Start square bracket.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unequals | Unequal.

Fields

 | Name | Description
Public field | Token | The current token.

See Also

TokenBuilder Class
Sitecore.Data.Query Namespace


TokenBuilder Constructor

[image]

Sitecore 6.4.1 API
TokenBuilder Constructor
TokenBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TokenBuilder()
Visual Basic
Public Sub New
Visual C++
public:
TokenBuilder()

See Also

TokenBuilder Class
Sitecore.Data.Query Namespace


TokenBuilder Fields

[image] [image]

Sitecore 6.4.1 API
TokenBuilder Fields
TokenBuilder Class See Also Send Feedback

The TokenBuilder type exposes the following members.

Fields

 | Name | Description
Public field | Token | The current token.

See Also

TokenBuilder Class
Sitecore.Data.Query Namespace


Token Field

[image]

Sitecore 6.4.1 API
TokenBuilder..::..Token Field
TokenBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Token Token
Visual Basic
Public Token As Token
Visual C++
public:
Token Token

See Also

TokenBuilder Class
Sitecore.Data.Query Namespace


TokenBuilder Methods

[image] [image]

Sitecore 6.4.1 API
TokenBuilder Methods
TokenBuilder Class See Also Send Feedback

The TokenBuilder type exposes the following members.

Methods

 | Name | Description
Public method | At | At.
Public method | Axis | Axis.
Public method | Comma | Comma.
Public method | Dollar | Dollar.
Public method | Dot | Dot.
Public method | DotDot | Dot dot.
Public method | DoubleSlash | Double slash.
Public method | End | End.
Public method | EndParentes | End parentes.
Public method | EndSquareBracket | End square bracket.
Public method | Equals()()()() | Equal.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Greater | Greater.
Public method | GreaterOrEquals | Greater or equals.
Public method | Guid | GUID.
Public method | Identifier | Identifier.
Public method | Literal | Literal.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Minus | Minus.
Public method | Namespace | Namespace.
Public method | Number | Number.
Public method | Pipe | Pipe.
Public method | Plus | Plus.
Public method | Slash | Slash.
Public method | Smaller | Smaller.
Public method | SmallerOrEquals | Smaller or equal.
Public method | Star | Star.
Public method | StartParentes | Start parentes.
Public method | StartSquareBracket | Start square bracket.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unequals | Unequal.

See Also

TokenBuilder Class
Sitecore.Data.Query Namespace


At Method

[image]

Sitecore 6.4.1 API
TokenBuilder..::..At Method
TokenBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void At()
Visual Basic
Public Sub At
Visual C++
public:
void At()

See Also

TokenBuilder Class
Sitecore.Data.Query Namespace


Axis Method

[image]

Sitecore 6.4.1 API
TokenBuilder..::..Axis Method
TokenBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Axis()
Visual Basic
Public Sub Axis
Visual C++
public:
void Axis()

See Also

TokenBuilder Class
Sitecore.Data.Query Namespace


Comma Method

[image]

Sitecore 6.4.1 API
TokenBuilder..::..Comma Method
TokenBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Comma()
Visual Basic
Public Sub Comma
Visual C++
public:
void Comma()

See Also

TokenBuilder Class
Sitecore.Data.Query Namespace


Dot Method

[image]

Sitecore 6.4.1 API
TokenBuilder..::..Dot Method
TokenBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Dot()
Visual Basic
Public Sub Dot
Visual C++
public:
void Dot()

See Also

TokenBuilder Class
Sitecore.Data.Query Namespace


DotDot Method

[image]

Sitecore 6.4.1 API
TokenBuilder..::..DotDot Method
TokenBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void DotDot()
Visual Basic
Public Sub DotDot
Visual C++
public:
void DotDot()

See Also

TokenBuilder Class
Sitecore.Data.Query Namespace


DoubleSlash Method

[image]

Sitecore 6.4.1 API
TokenBuilder..::..DoubleSlash Method
TokenBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void DoubleSlash()
Visual Basic
Public Sub DoubleSlash
Visual C++
public:
void DoubleSlash()

See Also

TokenBuilder Class
Sitecore.Data.Query Namespace


End Method

[image]

Sitecore 6.4.1 API
TokenBuilder..::..End Method
TokenBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void End()
Visual Basic
Public Sub End
Visual C++
public:
void End()

See Also

TokenBuilder Class
Sitecore.Data.Query Namespace


EndParentes Method

[image]

Sitecore 6.4.1 API
TokenBuilder..::..EndParentes Method
TokenBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void EndParentes()
Visual Basic
Public Sub EndParentes
Visual C++
public:
void EndParentes()

See Also

TokenBuilder Class
Sitecore.Data.Query Namespace


Equals Method

[image]

Sitecore 6.4.1 API
TokenBuilder..::..Equals Method
TokenBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Equals()
Visual Basic
Public Sub Equals
Visual C++
public:
void Equals()

See Also

TokenBuilder Class
Equals Overload
Sitecore.Data.Query Namespace


Greater Method

[image]

Sitecore 6.4.1 API
TokenBuilder..::..Greater Method
TokenBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Greater()
Visual Basic
Public Sub Greater
Visual C++
public:
void Greater()

See Also

TokenBuilder Class
Sitecore.Data.Query Namespace


GreaterOrEquals Method

[image]

Sitecore 6.4.1 API
TokenBuilder..::..GreaterOrEquals Method
TokenBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void GreaterOrEquals()
Visual Basic
Public Sub GreaterOrEquals
Visual C++
public:
void GreaterOrEquals()

See Also

TokenBuilder Class
Sitecore.Data.Query Namespace


Identifier Method

[image]

Sitecore 6.4.1 API
TokenBuilder..::..Identifier Method
TokenBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Identifier(
    string value
)
Visual Basic
Public Overridable Sub Identifier ( _
    value As String _
)
Visual C++
public:
virtual void Identifier(
    String^ value
)

Parameters

value
Type: System..::..String
The identifier.

See Also

TokenBuilder Class
Sitecore.Data.Query Namespace


Literal Method

[image]

Sitecore 6.4.1 API
TokenBuilder..::..Literal Method
TokenBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Literal(
    string name
)
Visual Basic
Public Sub Literal ( _
    name As String _
)
Visual C++
public:
void Literal(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

See Also

TokenBuilder Class
Sitecore.Data.Query Namespace


Minus Method

[image]

Sitecore 6.4.1 API
TokenBuilder..::..Minus Method
TokenBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Minus()
Visual Basic
Public Sub Minus
Visual C++
public:
void Minus()

See Also

TokenBuilder Class
Sitecore.Data.Query Namespace


Namespace Method

[image]

Sitecore 6.4.1 API
TokenBuilder..::..Namespace Method
TokenBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Namespace()
Visual Basic
Public Sub Namespace
Visual C++
public:
void Namespace()

See Also

TokenBuilder Class
Sitecore.Data.Query Namespace


Number Method

[image]

Sitecore 6.4.1 API
TokenBuilder..::..Number Method
TokenBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Number(
    int value
)
Visual Basic
Public Sub Number ( _
    value As Integer _
)
Visual C++
public:
void Number(
    int value
)

Parameters

value
Type: System..::..Int32
The number.

See Also

TokenBuilder Class
Sitecore.Data.Query Namespace


Pipe Method

[image]

Sitecore 6.4.1 API
TokenBuilder..::..Pipe Method
TokenBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Pipe()
Visual Basic
Public Sub Pipe
Visual C++
public:
void Pipe()

See Also

TokenBuilder Class
Sitecore.Data.Query Namespace


Plus Method

[image]

Sitecore 6.4.1 API
TokenBuilder..::..Plus Method
TokenBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Plus()
Visual Basic
Public Sub Plus
Visual C++
public:
void Plus()

See Also

TokenBuilder Class
Sitecore.Data.Query Namespace


Slash Method

[image]

Sitecore 6.4.1 API
TokenBuilder..::..Slash Method
TokenBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Slash()
Visual Basic
Public Sub Slash
Visual C++
public:
void Slash()

See Also

TokenBuilder Class
Sitecore.Data.Query Namespace


SmallerOrEquals Method

[image]

Sitecore 6.4.1 API
TokenBuilder..::..SmallerOrEquals Method
TokenBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SmallerOrEquals()
Visual Basic
Public Sub SmallerOrEquals
Visual C++
public:
void SmallerOrEquals()

See Also

TokenBuilder Class
Sitecore.Data.Query Namespace


Star Method

[image]

Sitecore 6.4.1 API
TokenBuilder..::..Star Method
TokenBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Star()
Visual Basic
Public Sub Star
Visual C++
public:
void Star()

See Also

TokenBuilder Class
Sitecore.Data.Query Namespace


StartParentes Method

[image]

Sitecore 6.4.1 API
TokenBuilder..::..StartParentes Method
TokenBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void StartParentes()
Visual Basic
Public Sub StartParentes
Visual C++
public:
void StartParentes()

See Also

TokenBuilder Class
Sitecore.Data.Query Namespace


Unequals Method

[image]

Sitecore 6.4.1 API
TokenBuilder..::..Unequals Method
TokenBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Unequals()
Visual Basic
Public Sub Unequals
Visual C++
public:
void Unequals()

See Also

TokenBuilder Class
Sitecore.Data.Query Namespace


Tokenizer Class

[image]

Sitecore 6.4.1 API
Tokenizer Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Tokenizer
Visual Basic
Public Class Tokenizer
Visual C++
public ref class Tokenizer

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..Tokenizer

See Also

Tokenizer Members
Sitecore.Data.Query Namespace


Tokenizer Members

[image] [image]

Sitecore 6.4.1 API
Tokenizer Members
Tokenizer Class Constructors Methods Fields See Also Send Feedback

The Tokenizer type exposes the following members.

Constructors

 | Name | Description
Public method | Tokenizer | Creates a new Tokenizer instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextToken | Gets the next token.
Public method | PeekToken | Gets the next token without forwarding the current parsing location.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UngetToken | Ungets the token.

Fields

Name | Description
IdentifierCharacters | Identifier characters.

See Also

Tokenizer Class
Sitecore.Data.Query Namespace


Tokenizer Constructor

[image]

Sitecore 6.4.1 API
Tokenizer Constructor
Tokenizer Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Tokenizer(
    TokenBuilder builder,
    string text
)
Visual Basic
Public Sub New ( _
    builder As TokenBuilder, _
    text As String _
)
Visual C++
public:
Tokenizer(
    TokenBuilder^ builder,
    String^ text
)

Parameters

builder
Type: Sitecore.Data.Query..::..TokenBuilder
Builder.
text
Type: System..::..String
Text.

See Also

Tokenizer Class
Sitecore.Data.Query Namespace


Tokenizer Fields

[image] [image]

Sitecore 6.4.1 API
Tokenizer Fields
Tokenizer Class See Also Send Feedback

The Tokenizer type exposes the following members.

Fields

Name | Description
IdentifierCharacters | Identifier characters.

See Also

Tokenizer Class
Sitecore.Data.Query Namespace


IdentifierCharacters Field

[image]

Sitecore 6.4.1 API
Tokenizer..::..IdentifierCharacters Field
Tokenizer Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string IdentifierCharacters
Visual Basic
Public Const IdentifierCharacters As String
Visual C++
public:
literal String^ IdentifierCharacters

See Also

Tokenizer Class
Sitecore.Data.Query Namespace


Tokenizer Methods

[image] [image]

Sitecore 6.4.1 API
Tokenizer Methods
Tokenizer Class See Also Send Feedback

The Tokenizer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextToken | Gets the next token.
Public method | PeekToken | Gets the next token without forwarding the current parsing location.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UngetToken | Ungets the token.

See Also

Tokenizer Class
Sitecore.Data.Query Namespace


NextToken Method

[image]

Sitecore 6.4.1 API
Tokenizer..::..NextToken Method
Tokenizer Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Token NextToken()
Visual Basic
Public Overridable Function NextToken As Token
Visual C++
public:
virtual Token NextToken()

Return Value

The token.

See Also

Tokenizer Class
Sitecore.Data.Query Namespace


PeekToken Method

[image]

Sitecore 6.4.1 API
Tokenizer..::..PeekToken Method
Tokenizer Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Token PeekToken()
Visual Basic
Public Function PeekToken As Token
Visual C++
public:
Token PeekToken()

Return Value

The token.

See Also

Tokenizer Class
Sitecore.Data.Query Namespace


UngetToken Method

[image]

Sitecore 6.4.1 API
Tokenizer..::..UngetToken Method
Tokenizer Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void UngetToken(
    Token token
)
Visual Basic
Public Sub UngetToken ( _
    token As Token _
)
Visual C++
public:
void UngetToken(
    Token token
)

Parameters

token
Type: Sitecore.Data.Query..::..Token
The token.

See Also

Tokenizer Class
Sitecore.Data.Query Namespace


TokenType Class

[image]

Sitecore 6.4.1 API
TokenType Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class TokenType
Visual Basic
Public Class TokenType
Visual C++
public ref class TokenType

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..TokenType
Sitecore.Data.Query..::..QueryTokenType

See Also

TokenType Members
Sitecore.Data.Query Namespace


TokenType Members

[image] [image]

Sitecore 6.4.1 API
TokenType Members
TokenType Class Constructors Methods Fields See Also Send Feedback

The TokenType type exposes the following members.

Constructors

 | Name | Description
Public method | TokenType | Initializes a new instance of the TokenType class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
At | At.
Axis | Axis.
Comma | Comma.
Dollar | Dollar.
Dot | Dot.
DotDot | DotDot.
DoubleSlash | DoubleSlash.
End | End.
EndParentes | EndParentes.
EndSquareBracket | EndSquareBracket.
Equal | Equal.
Greater | Greater.
GreaterOrEquals | GreaterOrEquals.
Guid | Guid.
Identifier | Identifier.
Literal | Literal.
Minus | Minus.
Namespace | Namespace.
Number | Number.
Pipe | Pipe.
Plus | Plus.
Slash | Slash.
Smaller | Smaller.
SmallerOrEquals | SmallerOrEquals.
Star | Star.
StartParentes | StartParentes.
StartSquareBracket | StartSquareBracket.
Unequals | Unequals.

See Also

TokenType Class
Sitecore.Data.Query Namespace


TokenType Constructor

[image]

Sitecore 6.4.1 API
TokenType Constructor
TokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TokenType()
Visual Basic
Public Sub New
Visual C++
public:
TokenType()

See Also

TokenType Class
Sitecore.Data.Query Namespace


TokenType Fields

[image] [image]

Sitecore 6.4.1 API
TokenType Fields
TokenType Class See Also Send Feedback

The TokenType type exposes the following members.

Fields

Name | Description
At | At.
Axis | Axis.
Comma | Comma.
Dollar | Dollar.
Dot | Dot.
DotDot | DotDot.
DoubleSlash | DoubleSlash.
End | End.
EndParentes | EndParentes.
EndSquareBracket | EndSquareBracket.
Equal | Equal.
Greater | Greater.
GreaterOrEquals | GreaterOrEquals.
Guid | Guid.
Identifier | Identifier.
Literal | Literal.
Minus | Minus.
Namespace | Namespace.
Number | Number.
Pipe | Pipe.
Plus | Plus.
Slash | Slash.
Smaller | Smaller.
SmallerOrEquals | SmallerOrEquals.
Star | Star.
StartParentes | StartParentes.
StartSquareBracket | StartSquareBracket.
Unequals | Unequals.

See Also

TokenType Class
Sitecore.Data.Query Namespace


At Field

[image]

Sitecore 6.4.1 API
TokenType..::..At Field
TokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int At
Visual Basic
Public Const At As Integer
Visual C++
public:
literal int At

See Also

TokenType Class
Sitecore.Data.Query Namespace


Axis Field

[image]

Sitecore 6.4.1 API
TokenType..::..Axis Field
TokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int Axis
Visual Basic
Public Const Axis As Integer
Visual C++
public:
literal int Axis

See Also

TokenType Class
Sitecore.Data.Query Namespace


Comma Field

[image]

Sitecore 6.4.1 API
TokenType..::..Comma Field
TokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int Comma
Visual Basic
Public Const Comma As Integer
Visual C++
public:
literal int Comma

See Also

TokenType Class
Sitecore.Data.Query Namespace


Dollar Field

[image]

Sitecore 6.4.1 API
TokenType..::..Dollar Field
TokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int Dollar
Visual Basic
Public Const Dollar As Integer
Visual C++
public:
literal int Dollar

See Also

TokenType Class
Sitecore.Data.Query Namespace


Dot Field

[image]

Sitecore 6.4.1 API
TokenType..::..Dot Field
TokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int Dot
Visual Basic
Public Const Dot As Integer
Visual C++
public:
literal int Dot

See Also

TokenType Class
Sitecore.Data.Query Namespace


DotDot Field

[image]

Sitecore 6.4.1 API
TokenType..::..DotDot Field
TokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int DotDot
Visual Basic
Public Const DotDot As Integer
Visual C++
public:
literal int DotDot

See Also

TokenType Class
Sitecore.Data.Query Namespace


DoubleSlash Field

[image]

Sitecore 6.4.1 API
TokenType..::..DoubleSlash Field
TokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int DoubleSlash
Visual Basic
Public Const DoubleSlash As Integer
Visual C++
public:
literal int DoubleSlash

See Also

TokenType Class
Sitecore.Data.Query Namespace


End Field

[image]

Sitecore 6.4.1 API
TokenType..::..End Field
TokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int End
Visual Basic
Public Const End As Integer
Visual C++
public:
literal int End

See Also

TokenType Class
Sitecore.Data.Query Namespace


EndParentes Field

[image]

Sitecore 6.4.1 API
TokenType..::..EndParentes Field
TokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int EndParentes
Visual Basic
Public Const EndParentes As Integer
Visual C++
public:
literal int EndParentes

See Also

TokenType Class
Sitecore.Data.Query Namespace


EndSquareBracket Field

[image]

Sitecore 6.4.1 API
TokenType..::..EndSquareBracket Field
TokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int EndSquareBracket
Visual Basic
Public Const EndSquareBracket As Integer
Visual C++
public:
literal int EndSquareBracket

See Also

TokenType Class
Sitecore.Data.Query Namespace


Equal Field

[image]

Sitecore 6.4.1 API
TokenType..::..Equal Field
TokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int Equal
Visual Basic
Public Const Equal As Integer
Visual C++
public:
literal int Equal

See Also

TokenType Class
Sitecore.Data.Query Namespace


Greater Field

[image]

Sitecore 6.4.1 API
TokenType..::..Greater Field
TokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int Greater
Visual Basic
Public Const Greater As Integer
Visual C++
public:
literal int Greater

See Also

TokenType Class
Sitecore.Data.Query Namespace


GreaterOrEquals Field

[image]

Sitecore 6.4.1 API
TokenType..::..GreaterOrEquals Field
TokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int GreaterOrEquals
Visual Basic
Public Const GreaterOrEquals As Integer
Visual C++
public:
literal int GreaterOrEquals

See Also

TokenType Class
Sitecore.Data.Query Namespace


Guid Field

[image]

Sitecore 6.4.1 API
TokenType..::..Guid Field
TokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int Guid
Visual Basic
Public Const Guid As Integer
Visual C++
public:
literal int Guid

See Also

TokenType Class
Sitecore.Data.Query Namespace


Identifier Field

[image]

Sitecore 6.4.1 API
TokenType..::..Identifier Field
TokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int Identifier
Visual Basic
Public Const Identifier As Integer
Visual C++
public:
literal int Identifier

See Also

TokenType Class
Sitecore.Data.Query Namespace


Literal Field

[image]

Sitecore 6.4.1 API
TokenType..::..Literal Field
TokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int Literal
Visual Basic
Public Const Literal As Integer
Visual C++
public:
literal int Literal

See Also

TokenType Class
Sitecore.Data.Query Namespace


Minus Field

[image]

Sitecore 6.4.1 API
TokenType..::..Minus Field
TokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int Minus
Visual Basic
Public Const Minus As Integer
Visual C++
public:
literal int Minus

See Also

TokenType Class
Sitecore.Data.Query Namespace


Namespace Field

[image]

Sitecore 6.4.1 API
TokenType..::..Namespace Field
TokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int Namespace
Visual Basic
Public Const Namespace As Integer
Visual C++
public:
literal int Namespace

See Also

TokenType Class
Sitecore.Data.Query Namespace


Number Field

[image]

Sitecore 6.4.1 API
TokenType..::..Number Field
TokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int Number
Visual Basic
Public Const Number As Integer
Visual C++
public:
literal int Number

See Also

TokenType Class
Sitecore.Data.Query Namespace


Pipe Field

[image]

Sitecore 6.4.1 API
TokenType..::..Pipe Field
TokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int Pipe
Visual Basic
Public Const Pipe As Integer
Visual C++
public:
literal int Pipe

See Also

TokenType Class
Sitecore.Data.Query Namespace


Plus Field

[image]

Sitecore 6.4.1 API
TokenType..::..Plus Field
TokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int Plus
Visual Basic
Public Const Plus As Integer
Visual C++
public:
literal int Plus

See Also

TokenType Class
Sitecore.Data.Query Namespace


Slash Field

[image]

Sitecore 6.4.1 API
TokenType..::..Slash Field
TokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int Slash
Visual Basic
Public Const Slash As Integer
Visual C++
public:
literal int Slash

See Also

TokenType Class
Sitecore.Data.Query Namespace


Smaller Field

[image]

Sitecore 6.4.1 API
TokenType..::..Smaller Field
TokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int Smaller
Visual Basic
Public Const Smaller As Integer
Visual C++
public:
literal int Smaller

See Also

TokenType Class
Sitecore.Data.Query Namespace


Star Field

[image]

Sitecore 6.4.1 API
TokenType..::..Star Field
TokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int Star
Visual Basic
Public Const Star As Integer
Visual C++
public:
literal int Star

See Also

TokenType Class
Sitecore.Data.Query Namespace


StartParentes Field

[image]

Sitecore 6.4.1 API
TokenType..::..StartParentes Field
TokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int StartParentes
Visual Basic
Public Const StartParentes As Integer
Visual C++
public:
literal int StartParentes

See Also

TokenType Class
Sitecore.Data.Query Namespace


StartSquareBracket Field

[image]

Sitecore 6.4.1 API
TokenType..::..StartSquareBracket Field
TokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int StartSquareBracket
Visual Basic
Public Const StartSquareBracket As Integer
Visual C++
public:
literal int StartSquareBracket

See Also

TokenType Class
Sitecore.Data.Query Namespace


Unequals Field

[image]

Sitecore 6.4.1 API
TokenType..::..Unequals Field
TokenType Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const int Unequals
Visual Basic
Public Const Unequals As Integer
Visual C++
public:
literal int Unequals

See Also

TokenType Class
Sitecore.Data.Query Namespace


TokenType Methods

[image] [image]

Sitecore 6.4.1 API
TokenType Methods
TokenType Class See Also Send Feedback

The TokenType type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TokenType Class
Sitecore.Data.Query Namespace


UnequalsOperator Class

[image]

Sitecore 6.4.1 API
UnequalsOperator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class UnequalsOperator : BinaryOperator
Visual Basic
Public Class UnequalsOperator _
    Inherits BinaryOperator
Visual C++
public ref class UnequalsOperator : public BinaryOperator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..Opcode
Sitecore.Data.Query..::..BinaryOperator
Sitecore.Data.Query..::..UnequalsOperator

See Also

UnequalsOperator Members
Sitecore.Data.Query Namespace


UnequalsOperator Members

[image] [image]

Sitecore 6.4.1 API
UnequalsOperator Members
UnequalsOperator Class Constructors Methods Properties See Also Send Feedback

The UnequalsOperator type exposes the following members.

Constructors

 | Name | Description
Public method | UnequalsOperator | Creates a new UnequalsOperator instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Inherited from BinaryOperator.)
Public method | EvaluateOperands | Evaluates the expression. (Overrides BinaryOperator..::..EvaluateOperands(Object, Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from BinaryOperator.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Left | Gets the left expression. (Inherited from BinaryOperator.)
Public property | Right | Gets the right expression. (Inherited from BinaryOperator.)

See Also

UnequalsOperator Class
Sitecore.Data.Query Namespace


UnequalsOperator Constructor

[image]

Sitecore 6.4.1 API
UnequalsOperator Constructor
UnequalsOperator Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UnequalsOperator(
    Opcode left,
    Opcode right
)
Visual Basic
Public Sub New ( _
    left As Opcode, _
    right As Opcode _
)
Visual C++
public:
UnequalsOperator(
    Opcode^ left,
    Opcode^ right
)

Parameters

left
Type: Sitecore.Data.Query..::..Opcode
Left expression.
right
Type: Sitecore.Data.Query..::..Opcode
Right expression.

See Also

UnequalsOperator Class
Sitecore.Data.Query Namespace


UnequalsOperator Methods

[image] [image]

Sitecore 6.4.1 API
UnequalsOperator Methods
UnequalsOperator Class See Also Send Feedback

The UnequalsOperator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Inherited from BinaryOperator.)
Public method | EvaluateOperands | Evaluates the expression. (Overrides BinaryOperator..::..EvaluateOperands(Object, Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from BinaryOperator.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UnequalsOperator Class
Sitecore.Data.Query Namespace


UnequalsOperator Properties

[image] [image]

Sitecore 6.4.1 API
UnequalsOperator Properties
UnequalsOperator Class See Also Send Feedback

The UnequalsOperator type exposes the following members.

Properties

 | Name | Description
Public property | Left | Gets the left expression. (Inherited from BinaryOperator.)
Public property | Right | Gets the right expression. (Inherited from BinaryOperator.)

See Also

UnequalsOperator Class
Sitecore.Data.Query Namespace


XorOperator Class

[image]

Sitecore 6.4.1 API
XorOperator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class XorOperator : BinaryOperator
Visual Basic
Public Class XorOperator _
    Inherits BinaryOperator
Visual C++
public ref class XorOperator : public BinaryOperator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Query..::..Opcode
Sitecore.Data.Query..::..BinaryOperator
Sitecore.Data.Query..::..XorOperator

See Also

XorOperator Members
Sitecore.Data.Query Namespace


XorOperator Members

[image] [image]

Sitecore 6.4.1 API
XorOperator Members
XorOperator Class Constructors Methods Properties See Also Send Feedback

The XorOperator type exposes the following members.

Constructors

 | Name | Description
Public method | XorOperator | Creates a new XorOperator instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Inherited from BinaryOperator.)
Public method | EvaluateOperands | Evaluates the expression. (Overrides BinaryOperator..::..EvaluateOperands(Object, Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from BinaryOperator.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Left | Gets the left expression. (Inherited from BinaryOperator.)
Public property | Right | Gets the right expression. (Inherited from BinaryOperator.)

See Also

XorOperator Class
Sitecore.Data.Query Namespace


XorOperator Constructor

[image]

Sitecore 6.4.1 API
XorOperator Constructor
XorOperator Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public XorOperator(
    Opcode left,
    Opcode right
)
Visual Basic
Public Sub New ( _
    left As Opcode, _
    right As Opcode _
)
Visual C++
public:
XorOperator(
    Opcode^ left,
    Opcode^ right
)

Parameters

left
Type: Sitecore.Data.Query..::..Opcode
Left expression.
right
Type: Sitecore.Data.Query..::..Opcode
Right expression.

See Also

XorOperator Class
Sitecore.Data.Query Namespace


XorOperator Methods

[image] [image]

Sitecore 6.4.1 API
XorOperator Methods
XorOperator Class See Also Send Feedback

The XorOperator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified query. (Inherited from BinaryOperator.)
Public method | EvaluateOperands | Evaluates the expression. (Overrides BinaryOperator..::..EvaluateOperands(Object, Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Print | Prints the expression. (Inherited from BinaryOperator.)
Public method | PrintIndent | Prints the indentation. (Inherited from Opcode.)
Public method | PrintLine | Prints a line of text. (Inherited from Opcode.)
Protected method | Process | Processes the specified query. (Inherited from Opcode.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

XorOperator Class
Sitecore.Data.Query Namespace


EvaluateOperands Method

[image]

Sitecore 6.4.1 API
XorOperator..::..EvaluateOperands Method
XorOperator Class See Also Send Feedback

Namespace: Sitecore.Data.Query
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Object EvaluateOperands(
    Object left,
    Object right
)
Visual Basic
Public Overrides Function EvaluateOperands ( _
    left As Object, _
    right As Object _
) As Object
Visual C++
public:
virtual Object^ EvaluateOperands(
    Object^ left,
    Object^ right
) override

Parameters

left
Type: System..::..Object
Left expression.
right
Type: System..::..Object
Right expression.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Query.XorOperator.EvaluateOperands(System.Object,System.Object)"]

See Also

XorOperator Class
Sitecore.Data.Query Namespace


XorOperator Properties

[image] [image]

Sitecore 6.4.1 API
XorOperator Properties
XorOperator Class See Also Send Feedback

The XorOperator type exposes the following members.

Properties

 | Name | Description
Public property | Left | Gets the left expression. (Inherited from BinaryOperator.)
Public property | Right | Gets the right expression. (Inherited from BinaryOperator.)

See Also

XorOperator Class
Sitecore.Data.Query Namespace


Sitecore.Data.Serialization Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Data.Serialization Namespace
Send Feedback

Classes

 | Class | Description
Public class | CommonUtils | Common utilities used by Serialization.
Public class | DatabaseLoader | Description of DatabaseLoader.
Public class | FileSystemEventArgs | Arguments for FileOperationDelegate delegate
Public class | ItemHandler |
Public class | ItemOperation | Encapsulates an operation on an Item
Public class | ItemOperation..::..DataComparer | Compares ItemOperation objects by data.
Public class | ItemOperation..::..DataStampComparer | Compares ItemOperation objects by data then stamp.
Public class | ItemOperation..::..StampComparer | Compares ItemOperation objets by timestamp.
Public class | ItemReference | Path-based item reference with uniqueness support.
Public class | ItemSynchronization | Implements Item <-> File synchronization
Public class | LoadOptions | Specifies operation options when loading data from dumped database.
Public class | Manager | Facade to all Serialization operations.
Public class | PathUtils | Utility functions for managing paths inside dump root
Public class | SerializationFinishedEvent | Defines the serialization finished event class.
Public class | ShadowWriter | Encapsulates background process of synchronizing filesystem with the database.
Public class | SqlConnectionFactory | Description of SqlConnectionFactory.
Public class | SqlServerAdminConnection | Description of DbAdminConnection.

Interfaces

 | Interface | Description
Public interface | IDataConnectionFactory | Provides ways for DatabaseLoader to construct database-specific objects
Public interface | IDbAdminConnection | Description of IDbAdminConnection.

Enumerations

 | Enumeration | Description
Public enumeration | FileOperationType | Type of the occured event
Public enumeration | Operation | List of supported operations.


CommonUtils Class

[image]

Sitecore 6.4.1 API
CommonUtils Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class CommonUtils
Visual Basic
Public NotInheritable Class CommonUtils
Visual C++
public ref class CommonUtils abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Serialization..::..CommonUtils

See Also

CommonUtils Members
Sitecore.Data.Serialization Namespace


CommonUtils Members

[image] [image]

Sitecore 6.4.1 API
CommonUtils Members
CommonUtils Class Methods See Also Send Feedback

The CommonUtils type exposes the following members.

Methods

Name | Description
CreateCIHashtable | Creates the case-insensitive hashtable.
IsDirectoryHidden | Determines whether directory is hidden.
IsHidden | Determines whether the specified file/directory is hidden.
Uniq<(Of <<'(T>)>>) | Scans sorted workset for duplicate entries.

See Also

CommonUtils Class
Sitecore.Data.Serialization Namespace


CommonUtils Methods

[image] [image]

Sitecore 6.4.1 API
CommonUtils Methods
CommonUtils Class See Also Send Feedback

The CommonUtils type exposes the following members.

Methods

Name | Description
CreateCIHashtable | Creates the case-insensitive hashtable.
IsDirectoryHidden | Determines whether directory is hidden.
IsHidden | Determines whether the specified file/directory is hidden.
Uniq<(Of <<'(T>)>>) | Scans sorted workset for duplicate entries.

See Also

CommonUtils Class
Sitecore.Data.Serialization Namespace


CreateCIHashtable Method

[image]

Sitecore 6.4.1 API
CommonUtils..::..CreateCIHashtable Method
CommonUtils Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Hashtable CreateCIHashtable()
Visual Basic
Public Shared Function CreateCIHashtable As Hashtable
Visual C++
public:
static Hashtable^ CreateCIHashtable()

Return Value

The hashtable.

See Also

CommonUtils Class
Sitecore.Data.Serialization Namespace


IsDirectoryHidden Method

[image]

Sitecore 6.4.1 API
CommonUtils..::..IsDirectoryHidden Method
CommonUtils Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsDirectoryHidden(
    string path
)
Visual Basic
Public Shared Function IsDirectoryHidden ( _
    path As String _
) As Boolean
Visual C++
public:
static bool IsDirectoryHidden(
    String^ path
)

Parameters

path
Type: System..::..String
The path pointing to a directory.

Return Value

true if directory is hidden; otherwise, false.

See Also

CommonUtils Class
Sitecore.Data.Serialization Namespace


IsHidden Method

[image]

Sitecore 6.4.1 API
CommonUtils..::..IsHidden Method
CommonUtils Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsHidden(
    FileSystemInfo info
)
Visual Basic
Public Shared Function IsHidden ( _
    info As FileSystemInfo _
) As Boolean
Visual C++
public:
static bool IsHidden(
    FileSystemInfo^ info
)

Parameters

info
Type: System.IO..::..FileSystemInfo
The file system entry info.

Return Value

true if the specified file/info is hidden; otherwise, false.

See Also

CommonUtils Class
Sitecore.Data.Serialization Namespace


Uniq(T) Method

[image]

Sitecore 6.4.1 API
CommonUtils..::..Uniq<(Of <(<'T>)>)> Method
CommonUtils Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static List<T> Uniq<T>(
    List<T> workset,
    IComparer<T> comparer
)
Visual Basic
Public Shared Function Uniq(Of T) ( _
    workset As List(Of T), _
    comparer As IComparer(Of T) _
) As List(Of T)
Visual C++
public:
generic<typename T>
static List<T>^ Uniq(
    List<T>^ workset,
    IComparer<T>^ comparer
)

Parameters

workset
Type: System.Collections.Generic..::..List <(Of <(<'T>)>)>
The workset.
comparer
Type: System.Collections.Generic..::..IComparer <(Of <(<'T>)>)>
The comparer.

Type Parameters

T
Type parameter.

Return Value

The workset without duplicate entries.

See Also

CommonUtils Class
Sitecore.Data.Serialization Namespace


DatabaseLoader Class

[image]

Sitecore 6.4.1 API
DatabaseLoader Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DatabaseLoader
Visual Basic
Public Class DatabaseLoader
Visual C++
public ref class DatabaseLoader

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Serialization..::..DatabaseLoader

See Also

DatabaseLoader Members
Sitecore.Data.Serialization Namespace


DatabaseLoader Members

[image] [image]

Sitecore 6.4.1 API
DatabaseLoader Members
DatabaseLoader Class Constructors Methods See Also Send Feedback

The DatabaseLoader type exposes the following members.

Constructors

 | Name | Description
Public method | DatabaseLoader | Initializes a new instance of database loader.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadDatabase | Loads database
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DatabaseLoader Class
Sitecore.Data.Serialization Namespace


DatabaseLoader Constructor

[image]

Sitecore 6.4.1 API
DatabaseLoader Constructor
DatabaseLoader Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DatabaseLoader(
    string path
)
Visual Basic
Public Sub New ( _
    path As String _
)
Visual C++
public:
DatabaseLoader(
    String^ path
)

Parameters

path
Type: System..::..String
Path to the database dump and schema

See Also

DatabaseLoader Class
Sitecore.Data.Serialization Namespace


DatabaseLoader Methods

[image] [image]

Sitecore 6.4.1 API
DatabaseLoader Methods
DatabaseLoader Class See Also Send Feedback

The DatabaseLoader type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadDatabase | Loads database
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DatabaseLoader Class
Sitecore.Data.Serialization Namespace


LoadDatabase Method

[image]

Sitecore 6.4.1 API
DatabaseLoader..::..LoadDatabase Method
DatabaseLoader Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database LoadDatabase(
    IDataConnectionFactory factory
)
Visual Basic
Public Function LoadDatabase ( _
    factory As IDataConnectionFactory _
) As Database
Visual C++
public:
Database^ LoadDatabase(
    IDataConnectionFactory^ factory
)

Parameters

factory
Type: Sitecore.Data.Serialization..::..IDataConnectionFactory

[Missing <param name="factory"/> documentation for "M:Sitecore.Data.Serialization.DatabaseLoader.LoadDatabase(Sitecore.Data.Serialization.IDataConnectionFactory)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Serialization.DatabaseLoader.LoadDatabase(Sitecore.Data.Serialization.IDataConnectionFactory)"]

See Also

DatabaseLoader Class
Sitecore.Data.Serialization Namespace


FileOperationType Enumeration

[image]

Sitecore 6.4.1 API
FileOperationType Enumeration
See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum FileOperationType
Visual Basic
Public Enumeration FileOperationType
Visual C++
public enum class FileOperationType

Members

Member name | Value | Description
Created | 0 | Created file or directory
Deleted | 1 | Deleted file or directory

See Also

Sitecore.Data.Serialization Namespace


FileSystemEventArgs Class

[image]

Sitecore 6.4.1 API
FileSystemEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FileSystemEventArgs : EventArgs,
    IPassNativeEventArgs
Visual Basic
Public Class FileSystemEventArgs _
    Inherits EventArgs _
    Implements IPassNativeEventArgs
Visual C++
public ref class FileSystemEventArgs : public EventArgs,
    IPassNativeEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Data.Serialization..::..FileSystemEventArgs

See Also

FileSystemEventArgs Members
Sitecore.Data.Serialization Namespace


FileSystemEventArgs Members

[image] [image]

Sitecore 6.4.1 API
FileSystemEventArgs Members
FileSystemEventArgs Class Constructors Methods Properties See Also Send Feedback

The FileSystemEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | FileSystemEventArgs | Initializes a new instance of the FileSystemEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FileName | Gets the name of the file.
Public property | FileOperationType | Gets the type of the file operation.

See Also

FileSystemEventArgs Class
Sitecore.Data.Serialization Namespace


FileSystemEventArgs Constructor

[image]

Sitecore 6.4.1 API
FileSystemEventArgs Constructor
FileSystemEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FileSystemEventArgs(
    FileOperationType fileType,
    string fileName
)
Visual Basic
Public Sub New ( _
    fileType As FileOperationType, _
    fileName As String _
)
Visual C++
public:
FileSystemEventArgs(
    FileOperationType fileType,
    String^ fileName
)

Parameters

fileType
Type: Sitecore.Data.Serialization..::..FileOperationType
Type of the file.
fileName
Type: System..::..String
Name of the file.

See Also

FileSystemEventArgs Class
Sitecore.Data.Serialization Namespace


FileSystemEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
FileSystemEventArgs Methods
FileSystemEventArgs Class See Also Send Feedback

The FileSystemEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileSystemEventArgs Class
Sitecore.Data.Serialization Namespace


FileSystemEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
FileSystemEventArgs Properties
FileSystemEventArgs Class See Also Send Feedback

The FileSystemEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | FileName | Gets the name of the file.
Public property | FileOperationType | Gets the type of the file operation.

See Also

FileSystemEventArgs Class
Sitecore.Data.Serialization Namespace


FileName Property

[image]

Sitecore 6.4.1 API
FileSystemEventArgs..::..FileName Property
FileSystemEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string FileName { get; }
Visual Basic
Public ReadOnly Property FileName As String
    Get
Visual C++
public:
property String^ FileName {
    String^ get ();
}

Field Value

The name of the file.

See Also

FileSystemEventArgs Class
Sitecore.Data.Serialization Namespace


FileOperationType Property

[image]

Sitecore 6.4.1 API
FileSystemEventArgs..::..FileOperationType Property
FileSystemEventArgs Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FileOperationType FileOperationType { get; }
Visual Basic
Public ReadOnly Property FileOperationType As FileOperationType
    Get
Visual C++
public:
property FileOperationType FileOperationType {
    FileOperationType get ();
}

Field Value

The type of the file operation.

See Also

FileSystemEventArgs Class
Sitecore.Data.Serialization Namespace


IDataConnectionFactory Interface

[image]

Sitecore 6.4.1 API
IDataConnectionFactory Interface
Members See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IDataConnectionFactory
Visual Basic
Public Interface IDataConnectionFactory
Visual C++
public interface class IDataConnectionFactory

See Also

IDataConnectionFactory Members
Sitecore.Data.Serialization Namespace


IDataConnectionFactory Members

[image] [image]

Sitecore 6.4.1 API
IDataConnectionFactory Members
IDataConnectionFactory Interface Methods Properties See Also Send Feedback

The IDataConnectionFactory type exposes the following members.

Methods

 | Name | Description
Public method | CreateApi | Creates a new instance of SqlDataApi tied to the factory.
Public method | CreateProvider | Creates DataProvider instance tied to the factory.

Properties

 | Name | Description
Public property | ConnectionString | Gets the connection string for this database connection.

See Also

IDataConnectionFactory Interface
Sitecore.Data.Serialization Namespace


IDataConnectionFactory Methods

[image] [image]

Sitecore 6.4.1 API
IDataConnectionFactory Methods
IDataConnectionFactory Interface See Also Send Feedback

The IDataConnectionFactory type exposes the following members.

Methods

 | Name | Description
Public method | CreateApi | Creates a new instance of SqlDataApi tied to the factory.
Public method | CreateProvider | Creates DataProvider instance tied to the factory.

See Also

IDataConnectionFactory Interface
Sitecore.Data.Serialization Namespace


CreateApi Method

[image]

Sitecore 6.4.1 API
IDataConnectionFactory..::..CreateApi Method
IDataConnectionFactory Interface See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
SqlDataApi CreateApi()
Visual Basic
Function CreateApi As SqlDataApi
Visual C++
SqlDataApi^ CreateApi()

Return Value

Database-specific SqlDataApi implementation.

See Also

IDataConnectionFactory Interface
Sitecore.Data.Serialization Namespace


CreateProvider Method

[image]

Sitecore 6.4.1 API
IDataConnectionFactory..::..CreateProvider Method
IDataConnectionFactory Interface See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
DataProvider CreateProvider()
Visual Basic
Function CreateProvider As DataProvider
Visual C++
DataProvider^ CreateProvider()

Return Value

Database-specific DataProvider implementation

See Also

IDataConnectionFactory Interface
Sitecore.Data.Serialization Namespace


IDataConnectionFactory Properties

[image] [image]

Sitecore 6.4.1 API
IDataConnectionFactory Properties
IDataConnectionFactory Interface See Also Send Feedback

The IDataConnectionFactory type exposes the following members.

Properties

 | Name | Description
Public property | ConnectionString | Gets the connection string for this database connection.

See Also

IDataConnectionFactory Interface
Sitecore.Data.Serialization Namespace


ConnectionString Property

[image]

Sitecore 6.4.1 API
IDataConnectionFactory..::..ConnectionString Property
IDataConnectionFactory Interface See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
string ConnectionString { get; }
Visual Basic
ReadOnly Property ConnectionString As String
    Get
Visual C++
property String^ ConnectionString {
    String^ get ();
}

See Also

IDataConnectionFactory Interface
Sitecore.Data.Serialization Namespace


IDbAdminConnection Interface

[image]

Sitecore 6.4.1 API
IDbAdminConnection Interface
Members See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IDbAdminConnection
Visual Basic
Public Interface IDbAdminConnection
Visual C++
public interface class IDbAdminConnection

See Also

IDbAdminConnection Members
Sitecore.Data.Serialization Namespace


IDbAdminConnection Members

[image] [image]

Sitecore 6.4.1 API
IDbAdminConnection Members
IDbAdminConnection Interface Methods See Also Send Feedback

The IDbAdminConnection type exposes the following members.

Methods

 | Name | Description
Public method | CreateDatabase(String) | Creates a new database with the specified names
Public method | CreateDatabase(String, String) | Creates a new database with the specified names
Public method | Detach | Detach database to unlock file;
Public method | GetConnectionFactory | Returns connection factory pointing to specific database

See Also

IDbAdminConnection Interface
Sitecore.Data.Serialization Namespace


IDbAdminConnection Methods

[image] [image]

Sitecore 6.4.1 API
IDbAdminConnection Methods
IDbAdminConnection Interface See Also Send Feedback

The IDbAdminConnection type exposes the following members.

Methods

 | Name | Description
Public method | CreateDatabase(String) | Creates a new database with the specified names
Public method | CreateDatabase(String, String) | Creates a new database with the specified names
Public method | Detach | Detach database to unlock file;
Public method | GetConnectionFactory | Returns connection factory pointing to specific database

See Also

IDbAdminConnection Interface
Sitecore.Data.Serialization Namespace


CreateDatabase Method

[image] [image]

Sitecore 6.4.1 API
IDbAdminConnection..::..CreateDatabase Method
IDbAdminConnection Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateDatabase(String) | Creates a new database with the specified names
Public method | CreateDatabase(String, String) | Creates a new database with the specified names

See Also

IDbAdminConnection Interface
IDbAdminConnection Members
Sitecore.Data.Serialization Namespace


CreateDatabase Method (String)

[image]

Sitecore 6.4.1 API
IDbAdminConnection..::..CreateDatabase Method (String)
IDbAdminConnection Interface See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void CreateDatabase(
    string databaseName
)
Visual Basic
Sub CreateDatabase ( _
    databaseName As String _
)
Visual C++
void CreateDatabase(
    String^ databaseName
)

Parameters

databaseName
Type: System..::..String
Name of the database

See Also

IDbAdminConnection Interface
CreateDatabase Overload
Sitecore.Data.Serialization Namespace


CreateDatabase Method (String, String)

[image]

Sitecore 6.4.1 API
IDbAdminConnection..::..CreateDatabase Method (String, String)
IDbAdminConnection Interface See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void CreateDatabase(
    string databaseName,
    string fileName
)
Visual Basic
Sub CreateDatabase ( _
    databaseName As String, _
    fileName As String _
)
Visual C++
void CreateDatabase(
    String^ databaseName,
    String^ fileName
)

Parameters

databaseName
Type: System..::..String
Name of the database
fileName
Type: System..::..String
File to store created database

See Also

IDbAdminConnection Interface
CreateDatabase Overload
Sitecore.Data.Serialization Namespace


Detach Method

[image]

Sitecore 6.4.1 API
IDbAdminConnection..::..Detach Method
IDbAdminConnection Interface See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void Detach(
    string databaseName
)
Visual Basic
Sub Detach ( _
    databaseName As String _
)
Visual C++
void Detach(
    String^ databaseName
)

Parameters

databaseName
Type: System..::..String
Name of the database

See Also

IDbAdminConnection Interface
Sitecore.Data.Serialization Namespace


GetConnectionFactory Method

[image]

Sitecore 6.4.1 API
IDbAdminConnection..::..GetConnectionFactory Method
IDbAdminConnection Interface See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
IDataConnectionFactory GetConnectionFactory(
    string databaseName
)
Visual Basic
Function GetConnectionFactory ( _
    databaseName As String _
) As IDataConnectionFactory
Visual C++
IDataConnectionFactory^ GetConnectionFactory(
    String^ databaseName
)

Parameters

databaseName
Type: System..::..String
Name of the database

Return Value

Implementation of IDataConnectionFactory

See Also

IDbAdminConnection Interface
Sitecore.Data.Serialization Namespace


ItemHandler Class

[image]

Sitecore 6.4.1 API
ItemHandler Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemHandler
Visual Basic
Public Class ItemHandler
Visual C++
public ref class ItemHandler

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Serialization..::..ItemHandler

See Also

ItemHandler Members
Sitecore.Data.Serialization Namespace


ItemHandler Members

[image] [image]

Sitecore 6.4.1 API
ItemHandler Members
ItemHandler Class Constructors Methods Properties See Also Send Feedback

The ItemHandler type exposes the following members.

Constructors

 | Name | Description
Public method | ItemHandler | Initializes a new instance of the ItemHandler class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnItemDeleted | Called when the item has been deleted.
Public method | OnItemMoved | Called when the item has been moved.
Public method | OnItemSaved | Called when the item has been saved.
Public method | OnItemVersionRemoved | Called when the item version has been removed.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Disabled | Gets or sets a value indicating whether this ItemHandler is disabled.
DisabledLocally | Gets or sets a value indicating whether the ItemHandler is disabled in the calling thread.

See Also

ItemHandler Class
Sitecore.Data.Serialization Namespace


ItemHandler Constructor

[image]

Sitecore 6.4.1 API
ItemHandler Constructor
ItemHandler Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemHandler()
Visual Basic
Public Sub New
Visual C++
public:
ItemHandler()

See Also

ItemHandler Class
Sitecore.Data.Serialization Namespace


ItemHandler Methods

[image] [image]

Sitecore 6.4.1 API
ItemHandler Methods
ItemHandler Class See Also Send Feedback

The ItemHandler type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnItemDeleted | Called when the item has been deleted.
Public method | OnItemMoved | Called when the item has been moved.
Public method | OnItemSaved | Called when the item has been saved.
Public method | OnItemVersionRemoved | Called when the item version has been removed.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemHandler Class
Sitecore.Data.Serialization Namespace


OnItemDeleted Method

[image]

Sitecore 6.4.1 API
ItemHandler..::..OnItemDeleted Method
ItemHandler Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void OnItemDeleted(
    Object sender,
    EventArgs args
)
Visual Basic
Public Sub OnItemDeleted ( _
    sender As Object, _
    args As EventArgs _
)
Visual C++
public:
void OnItemDeleted(
    Object^ sender,
    EventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: System..::..EventArgs
The arguments.

See Also

ItemHandler Class
Sitecore.Data.Serialization Namespace


OnItemMoved Method

[image]

Sitecore 6.4.1 API
ItemHandler..::..OnItemMoved Method
ItemHandler Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void OnItemMoved(
    Object sender,
    EventArgs args
)
Visual Basic
Public Sub OnItemMoved ( _
    sender As Object, _
    args As EventArgs _
)
Visual C++
public:
void OnItemMoved(
    Object^ sender,
    EventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: System..::..EventArgs
The arguments.

See Also

ItemHandler Class
Sitecore.Data.Serialization Namespace


OnItemSaved Method

[image]

Sitecore 6.4.1 API
ItemHandler..::..OnItemSaved Method
ItemHandler Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void OnItemSaved(
    Object sender,
    EventArgs args
)
Visual Basic
Public Sub OnItemSaved ( _
    sender As Object, _
    args As EventArgs _
)
Visual C++
public:
void OnItemSaved(
    Object^ sender,
    EventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: System..::..EventArgs
The arguments.

See Also

ItemHandler Class
Sitecore.Data.Serialization Namespace


OnItemVersionRemoved Method

[image]

Sitecore 6.4.1 API
ItemHandler..::..OnItemVersionRemoved Method
ItemHandler Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void OnItemVersionRemoved(
    Object sender,
    EventArgs args
)
Visual Basic
Public Sub OnItemVersionRemoved ( _
    sender As Object, _
    args As EventArgs _
)
Visual C++
public:
void OnItemVersionRemoved(
    Object^ sender,
    EventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: System..::..EventArgs
The arguments.

See Also

ItemHandler Class
Sitecore.Data.Serialization Namespace


ItemHandler Properties

[image] [image]

Sitecore 6.4.1 API
ItemHandler Properties
ItemHandler Class See Also Send Feedback

The ItemHandler type exposes the following members.

Properties

Name | Description
Disabled | Gets or sets a value indicating whether this ItemHandler is disabled.
DisabledLocally | Gets or sets a value indicating whether the ItemHandler is disabled in the calling thread.

See Also

ItemHandler Class
Sitecore.Data.Serialization Namespace


Disabled Property

[image]

Sitecore 6.4.1 API
ItemHandler..::..Disabled Property
ItemHandler Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool Disabled { get; set; }
Visual Basic
Public Shared Property Disabled As Boolean
    Get
    Set
Visual C++
public:
static property bool Disabled {
    bool get ();
    void set (bool value);
}

Field Value

true if disabled; otherwise, false.

See Also

ItemHandler Class
Sitecore.Data.Serialization Namespace


DisabledLocally Property

[image]

Sitecore 6.4.1 API
ItemHandler..::..DisabledLocally Property
ItemHandler Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool DisabledLocally { get; set; }
Visual Basic
Public Shared Property DisabledLocally As Boolean
    Get
    Set
Visual C++
public:
static property bool DisabledLocally {
    bool get ();
    void set (bool value);
}

Field Value

true if the ItemHandler is disabled in the current thread; otherwise, false.

See Also

ItemHandler Class
Sitecore.Data.Serialization Namespace


ItemOperation Class

[image]

Sitecore 6.4.1 API
ItemOperation Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemOperation
Visual Basic
Public Class ItemOperation
Visual C++
public ref class ItemOperation

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Serialization..::..ItemOperation

See Also

ItemOperation Members
Sitecore.Data.Serialization Namespace


ItemOperation Members

[image] [image]

Sitecore 6.4.1 API
ItemOperation Members
ItemOperation Class Constructors Methods Properties See Also Send Feedback

The ItemOperation type exposes the following members.

Constructors

 | Name | Description
Public method | ItemOperation | Initializes a new instance of the ItemOperation class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | Gets or sets the data.
Public property | Operation | Gets or sets the operation.
Public property | Parent | Gets or sets the parent.
Public property | Stamp | Gets or sets the timestamp.

See Also

ItemOperation Class
Sitecore.Data.Serialization Namespace


ItemOperation Constructor

[image]

Sitecore 6.4.1 API
ItemOperation Constructor
ItemOperation Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemOperation(
    Operation operation,
    Item item,
    Item parent
)
Visual Basic
Public Sub New ( _
    operation As Operation, _
    item As Item, _
    parent As Item _
)
Visual C++
public:
ItemOperation(
    Operation operation,
    Item^ item,
    Item^ parent
)

Parameters

operation
Type: Sitecore.Data.Serialization..::..Operation
The op.
item
Type: Sitecore.Data.Items..::..Item
The item.
parent
Type: Sitecore.Data.Items..::..Item
The parent.

See Also

ItemOperation Class
Sitecore.Data.Serialization Namespace


ItemOperation Methods

[image] [image]

Sitecore 6.4.1 API
ItemOperation Methods
ItemOperation Class See Also Send Feedback

The ItemOperation type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemOperation Class
Sitecore.Data.Serialization Namespace


ItemOperation Properties

[image] [image]

Sitecore 6.4.1 API
ItemOperation Properties
ItemOperation Class See Also Send Feedback

The ItemOperation type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets or sets the data.
Public property | Operation | Gets or sets the operation.
Public property | Parent | Gets or sets the parent.
Public property | Stamp | Gets or sets the timestamp.

See Also

ItemOperation Class
Sitecore.Data.Serialization Namespace


Item Property

[image]

Sitecore 6.4.1 API
ItemOperation..::..Item Property
ItemOperation Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Item { get; set; }
Visual Basic
Public Property Item As Item
    Get
    Set
Visual C++
public:
property Item^ Item {
    Item^ get ();
    void set (Item^ value);
}

Field Value

The data.

See Also

ItemOperation Class
Sitecore.Data.Serialization Namespace


Operation Property

[image]

Sitecore 6.4.1 API
ItemOperation..::..Operation Property
ItemOperation Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Operation Operation { get; set; }
Visual Basic
Public Property Operation As Operation
    Get
    Set
Visual C++
public:
property Operation Operation {
    Operation get ();
    void set (Operation value);
}

Field Value

The operation.

See Also

ItemOperation Class
Sitecore.Data.Serialization Namespace


Parent Property

[image]

Sitecore 6.4.1 API
ItemOperation..::..Parent Property
ItemOperation Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Parent { get; set; }
Visual Basic
Public Property Parent As Item
    Get
    Set
Visual C++
public:
property Item^ Parent {
    Item^ get ();
    void set (Item^ value);
}

Field Value

The parent.

See Also

ItemOperation Class
Sitecore.Data.Serialization Namespace


Stamp Property

[image]

Sitecore 6.4.1 API
ItemOperation..::..Stamp Property
ItemOperation Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long Stamp { get; set; }
Visual Basic
Public Property Stamp As Long
    Get
    Set
Visual C++
public:
property long long Stamp {
    long long get ();
    void set (long long value);
}

Field Value

The stamp.

See Also

ItemOperation Class
Sitecore.Data.Serialization Namespace


ItemOperation.DataComparer Class

[image]

Sitecore 6.4.1 API
ItemOperation..::..DataComparer Class
ItemOperation Class Members See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DataComparer : IComparer<ItemOperation>
Visual Basic
Public Class DataComparer _
    Implements IComparer(Of ItemOperation)
Visual C++
public ref class DataComparer : IComparer<ItemOperation^>

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Serialization..::..ItemOperation..::..DataComparer
Sitecore.Data.Serialization..::..ItemOperation..::..DataStampComparer

See Also

ItemOperation..::..DataComparer Members
Sitecore.Data.Serialization Namespace


ItemOperation.DataComparer Members

[image] [image]

Sitecore 6.4.1 API
ItemOperation..::..DataComparer Members
ItemOperation..::..DataComparer Class Constructors Methods See Also Send Feedback

Encapsulates an operation on an Item

The ItemOperation..::..DataComparer type exposes the following members.

Constructors

 | Name | Description
Public method | ItemOperation..::..DataComparer | Initializes a new instance of the ItemOperation..::..DataComparer class

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemOperation..::..DataComparer Class
Sitecore.Data.Serialization Namespace


ItemOperation.DataComparer Constructor

[image]

Sitecore 6.4.1 API
ItemOperation..::..DataComparer Constructor
ItemOperation..::..DataComparer Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataComparer()
Visual Basic
Public Sub New
Visual C++
public:
DataComparer()

See Also

ItemOperation..::..DataComparer Class
Sitecore.Data.Serialization Namespace


ItemOperation.DataComparer Methods

[image] [image]

Sitecore 6.4.1 API
ItemOperation..::..DataComparer Methods
ItemOperation..::..DataComparer Class See Also Send Feedback

The ItemOperation..::..DataComparer type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemOperation..::..DataComparer Class
Sitecore.Data.Serialization Namespace


Compare Method

[image]

Sitecore 6.4.1 API
ItemOperation..::..DataComparer..::..Compare Method
ItemOperation..::..DataComparer Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Compare(
    ItemOperation x,
    ItemOperation y
)
Visual Basic
Public Function Compare ( _
    x As ItemOperation, _
    y As ItemOperation _
) As Integer
Visual C++
public:
virtual int Compare(
    ItemOperation^ x,
    ItemOperation^ y
) sealed

Parameters

x
Type: Sitecore.Data.Serialization..::..ItemOperation
The first object to compare.
y
Type: Sitecore.Data.Serialization..::..ItemOperation
The second object to compare.

Return Value

Value Condition Less than zerox is less than y.Zerox equals y.Greater than zerox is greater than y.

Implements

IComparer<(Of <(<'T>)>)>..::..Compare(T, T)

See Also

ItemOperation..::..DataComparer Class
Sitecore.Data.Serialization Namespace


ItemOperation.DataStampComparer Class

[image]

Sitecore 6.4.1 API
ItemOperation..::..DataStampComparer Class
ItemOperation Class Members See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DataStampComparer : ItemOperation..::..DataComparer,
    IComparer<ItemOperation>
Visual Basic
Public Class DataStampComparer _
    Inherits ItemOperation..::..DataComparer _
    Implements IComparer(Of ItemOperation)
Visual C++
public ref class DataStampComparer : public ItemOperation..::..DataComparer,
    IComparer<ItemOperation^>

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Serialization..::..ItemOperation..::..DataComparer
Sitecore.Data.Serialization..::..ItemOperation..::..DataStampComparer

See Also

ItemOperation..::..DataStampComparer Members
Sitecore.Data.Serialization Namespace


ItemOperation.DataStampComparer Members

[image] [image]

Sitecore 6.4.1 API
ItemOperation..::..DataStampComparer Members
ItemOperation..::..DataStampComparer Class Constructors Methods See Also Send Feedback

Encapsulates an operation on an Item

The ItemOperation..::..DataStampComparer type exposes the following members.

Constructors

 | Name | Description
Public method | ItemOperation..::..DataStampComparer | Initializes a new instance of the ItemOperation..::..DataStampComparer class

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemOperation..::..DataStampComparer Class
Sitecore.Data.Serialization Namespace


ItemOperation.DataStampComparer Constructor

[image]

Sitecore 6.4.1 API
ItemOperation..::..DataStampComparer Constructor
ItemOperation..::..DataStampComparer Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataStampComparer()
Visual Basic
Public Sub New
Visual C++
public:
DataStampComparer()

See Also

ItemOperation..::..DataStampComparer Class
Sitecore.Data.Serialization Namespace


ItemOperation.DataStampComparer Methods

[image] [image]

Sitecore 6.4.1 API
ItemOperation..::..DataStampComparer Methods
ItemOperation..::..DataStampComparer Class See Also Send Feedback

The ItemOperation..::..DataStampComparer type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemOperation..::..DataStampComparer Class
Sitecore.Data.Serialization Namespace


Compare Method

[image]

Sitecore 6.4.1 API
ItemOperation..::..DataStampComparer..::..Compare Method
ItemOperation..::..DataStampComparer Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Compare(
    ItemOperation x,
    ItemOperation y
)
Visual Basic
Public Function Compare ( _
    x As ItemOperation, _
    y As ItemOperation _
) As Integer
Visual C++
public:
virtual int Compare(
    ItemOperation^ x,
    ItemOperation^ y
) sealed

Parameters

x
Type: Sitecore.Data.Serialization..::..ItemOperation
The first object to compare.
y
Type: Sitecore.Data.Serialization..::..ItemOperation
The second object to compare.

Return Value

Value Condition Less than zerox is less than y.Zerox equals y.Greater than zerox is greater than y.

Implements

IComparer<(Of <(<'T>)>)>..::..Compare(T, T)

See Also

ItemOperation..::..DataStampComparer Class
Sitecore.Data.Serialization Namespace


ItemOperation.StampComparer Class

[image]

Sitecore 6.4.1 API
ItemOperation..::..StampComparer Class
ItemOperation Class Members See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class StampComparer : IComparer<ItemOperation>
Visual Basic
Public Class StampComparer _
    Implements IComparer(Of ItemOperation)
Visual C++
public ref class StampComparer : IComparer<ItemOperation^>

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Serialization..::..ItemOperation..::..StampComparer

See Also

ItemOperation..::..StampComparer Members
Sitecore.Data.Serialization Namespace


ItemOperation.StampComparer Constructor

[image]

Sitecore 6.4.1 API
ItemOperation..::..StampComparer Constructor
ItemOperation..::..StampComparer Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StampComparer()
Visual Basic
Public Sub New
Visual C++
public:
StampComparer()

See Also

ItemOperation..::..StampComparer Class
Sitecore.Data.Serialization Namespace


ItemOperation.StampComparer Methods

[image] [image]

Sitecore 6.4.1 API
ItemOperation..::..StampComparer Methods
ItemOperation..::..StampComparer Class See Also Send Feedback

The ItemOperation..::..StampComparer type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemOperation..::..StampComparer Class
Sitecore.Data.Serialization Namespace


Compare Method

[image]

Sitecore 6.4.1 API
ItemOperation..::..StampComparer..::..Compare Method
ItemOperation..::..StampComparer Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Compare(
    ItemOperation x,
    ItemOperation y
)
Visual Basic
Public Function Compare ( _
    x As ItemOperation, _
    y As ItemOperation _
) As Integer
Visual C++
public:
virtual int Compare(
    ItemOperation^ x,
    ItemOperation^ y
) sealed

Parameters

x
Type: Sitecore.Data.Serialization..::..ItemOperation
The first object to compare.
y
Type: Sitecore.Data.Serialization..::..ItemOperation
The second object to compare.

Return Value

Value Condition Less than zerox is less than y.Zerox equals y.Greater than zerox is greater than y.

Implements

IComparer<(Of <(<'T>)>)>..::..Compare(T, T)

See Also

ItemOperation..::..StampComparer Class
Sitecore.Data.Serialization Namespace


ItemReference Members

[image] [image]

Sitecore 6.4.1 API
ItemReference Members
ItemReference Class Constructors Methods Properties See Also Send Feedback

The ItemReference type exposes the following members.

Constructors

 | Name | Description
Public method | ItemReference(Item) | Initializes a new instance of the ItemReference class.
Public method | ItemReference(String, String) | Initializes a new instance of the ItemReference class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItem | Gets the item.
Public method | GetItemInDatabase | Gets the item in database.
Public method | GetItemStrict | Gets the item strict way. Ensures that reference for returned item is the same as 'this' one.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Parses the specified path.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Database | Gets the database.
Public property | Path | Gets the path.

See Also

ItemReference Class
Sitecore.Data.Serialization Namespace


ItemReference Constructor

[image] [image]

Sitecore 6.4.1 API
ItemReference Constructor
ItemReference Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ItemReference(Item) | Initializes a new instance of the ItemReference class.
Public method | ItemReference(String, String) | Initializes a new instance of the ItemReference class.

See Also

ItemReference Class
ItemReference Members
Sitecore.Data.Serialization Namespace


ItemReference Constructor (Item)

[image]

Sitecore 6.4.1 API
ItemReference Constructor (Item)
ItemReference Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemReference(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
ItemReference(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

ItemReference Class
ItemReference Overload
Sitecore.Data.Serialization Namespace


ItemReference Methods

[image] [image]

Sitecore 6.4.1 API
ItemReference Methods
ItemReference Class See Also Send Feedback

The ItemReference type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItem | Gets the item.
Public method | GetItemInDatabase | Gets the item in database.
Public method | GetItemStrict | Gets the item strict way. Ensures that reference for returned item is the same as 'this' one.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Parses the specified path.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ItemReference Class
Sitecore.Data.Serialization Namespace


GetItem Method

[image]

Sitecore 6.4.1 API
ItemReference..::..GetItem Method
ItemReference Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetItem()
Visual Basic
Public Function GetItem As Item
Visual C++
public:
Item^ GetItem()

Return Value

The item.

See Also

ItemReference Class
Sitecore.Data.Serialization Namespace


GetItemInDatabase Method

[image]

Sitecore 6.4.1 API
ItemReference..::..GetItemInDatabase Method
ItemReference Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetItemInDatabase(
    Database database
)
Visual Basic
Public Function GetItemInDatabase ( _
    database As Database _
) As Item
Visual C++
public:
Item^ GetItemInDatabase(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

Return Value

The item in database.

See Also

ItemReference Class
Sitecore.Data.Serialization Namespace


GetItemStrict Method

[image]

Sitecore 6.4.1 API
ItemReference..::..GetItemStrict Method
ItemReference Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetItemStrict()
Visual Basic
Public Function GetItemStrict As Item
Visual C++
public:
Item^ GetItemStrict()

Return Value

The item.

See Also

ItemReference Class
Sitecore.Data.Serialization Namespace


Parse Method

[image]

Sitecore 6.4.1 API
ItemReference..::..Parse Method
ItemReference Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ItemReference Parse(
    string path
)
Visual Basic
Public Shared Function Parse ( _
    path As String _
) As ItemReference
Visual C++
public:
static ItemReference^ Parse(
    String^ path
)

Parameters

path
Type: System..::..String
The path.

Return Value

The parse.

See Also

ItemReference Class
Sitecore.Data.Serialization Namespace


ToString Method

[image]

Sitecore 6.4.1 API
ItemReference..::..ToString Method
ItemReference Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

ItemReference Class
Sitecore.Data.Serialization Namespace


ItemReference Properties

[image] [image]

Sitecore 6.4.1 API
ItemReference Properties
ItemReference Class See Also Send Feedback

The ItemReference type exposes the following members.

Properties

 | Name | Description
Public property | Database | Gets the database.
Public property | Path | Gets the path.

See Also

ItemReference Class
Sitecore.Data.Serialization Namespace


Database Property

[image]

Sitecore 6.4.1 API
ItemReference..::..Database Property
ItemReference Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Database { get; }
Visual Basic
Public ReadOnly Property Database As String
    Get
Visual C++
public:
property String^ Database {
    String^ get ();
}

Field Value

The database.

See Also

ItemReference Class
Sitecore.Data.Serialization Namespace


Path Property

[image]

Sitecore 6.4.1 API
ItemReference..::..Path Property
ItemReference Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Path { get; }
Visual Basic
Public ReadOnly Property Path As String
    Get
Visual C++
public:
property String^ Path {
    String^ get ();
}

Field Value

The path.

See Also

ItemReference Class
Sitecore.Data.Serialization Namespace


ItemSynchronization Class

[image]

Sitecore 6.4.1 API
ItemSynchronization Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class ItemSynchronization
Visual Basic
Public NotInheritable Class ItemSynchronization
Visual C++
public ref class ItemSynchronization abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Serialization..::..ItemSynchronization

See Also

ItemSynchronization Members
Sitecore.Data.Serialization Namespace


ItemSynchronization Members

[image] [image]

Sitecore 6.4.1 API
ItemSynchronization Members
ItemSynchronization Class Methods See Also Send Feedback

The ItemSynchronization type exposes the following members.

Methods

Name | Description
BuildSyncItem | Builds the dump item object from item.
PasteSyncItem | Pastes SyncItem into the database.
ReadItem(TextReader) | Reads the item from TextReader.
ReadItem(TextReader, LoadOptions) | Reads the item from TextReader.
WriteItem | Writes the item to TextWriter.

See Also

ItemSynchronization Class
Sitecore.Data.Serialization Namespace


ItemSynchronization Methods

[image] [image]

Sitecore 6.4.1 API
ItemSynchronization Methods
ItemSynchronization Class See Also Send Feedback

The ItemSynchronization type exposes the following members.

Methods

Name | Description
BuildSyncItem | Builds the dump item object from item.
PasteSyncItem | Pastes SyncItem into the database.
ReadItem(TextReader) | Reads the item from TextReader.
ReadItem(TextReader, LoadOptions) | Reads the item from TextReader.
WriteItem | Writes the item to TextWriter.

See Also

ItemSynchronization Class
Sitecore.Data.Serialization Namespace


BuildSyncItem Method

[image]

Sitecore 6.4.1 API
ItemSynchronization..::..BuildSyncItem Method
ItemSynchronization Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static SyncItem BuildSyncItem(
    Item item
)
Visual Basic
Public Shared Function BuildSyncItem ( _
    item As Item _
) As SyncItem
Visual C++
public:
static SyncItem^ BuildSyncItem(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

The dump item.

See Also

ItemSynchronization Class
Sitecore.Data.Serialization Namespace


PasteSyncItem Method

[image]

Sitecore 6.4.1 API
ItemSynchronization..::..PasteSyncItem Method
ItemSynchronization Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item PasteSyncItem(
    SyncItem syncItem,
    LoadOptions options
)
Visual Basic
Public Shared Function PasteSyncItem ( _
    syncItem As SyncItem, _
    options As LoadOptions _
) As Item
Visual C++
public:
static Item^ PasteSyncItem(
    SyncItem^ syncItem,
    LoadOptions^ options
)

Parameters

syncItem
Type: Sitecore.Data.Serialization.ObjectModel..::..SyncItem
The sync item.
options
Type: Sitecore.Data.Serialization..::..LoadOptions
The options.

Return Value

The sync item.

See Also

ItemSynchronization Class
Sitecore.Data.Serialization Namespace


ReadItem Method

[image] [image]

Sitecore 6.4.1 API
ItemSynchronization..::..ReadItem Method
ItemSynchronization Class See Also Send Feedback

Overload List

Name | Description
ReadItem(TextReader) | Reads the item from TextReader.
ReadItem(TextReader, LoadOptions) | Reads the item from TextReader.

See Also

ItemSynchronization Class
ItemSynchronization Members
Sitecore.Data.Serialization Namespace


ReadItem Method (TextReader)

[image]

Sitecore 6.4.1 API
ItemSynchronization..::..ReadItem Method (TextReader)
ItemSynchronization Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item ReadItem(
    TextReader reader
)
Visual Basic
Public Shared Function ReadItem ( _
    reader As TextReader _
) As Item
Visual C++
public:
static Item^ ReadItem(
    TextReader^ reader
)

Parameters

reader
Type: System.IO..::..TextReader
The reader.

Return Value

The item.

See Also

ItemSynchronization Class
ReadItem Overload
Sitecore.Data.Serialization Namespace


ReadItem Method (TextReader, LoadOptions)

[image]

Sitecore 6.4.1 API
ItemSynchronization..::..ReadItem Method (TextReader, LoadOptions)
ItemSynchronization Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item ReadItem(
    TextReader reader,
    LoadOptions options
)
Visual Basic
Public Shared Function ReadItem ( _
    reader As TextReader, _
    options As LoadOptions _
) As Item
Visual C++
public:
static Item^ ReadItem(
    TextReader^ reader,
    LoadOptions^ options
)

Parameters

reader
Type: System.IO..::..TextReader
The reader.
options
Type: Sitecore.Data.Serialization..::..LoadOptions
The options.

Return Value

The item.

See Also

ItemSynchronization Class
ReadItem Overload
Sitecore.Data.Serialization Namespace


WriteItem Method

[image]

Sitecore 6.4.1 API
ItemSynchronization..::..WriteItem Method
ItemSynchronization Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void WriteItem(
    Item item,
    TextWriter writer
)
Visual Basic
Public Shared Sub WriteItem ( _
    item As Item, _
    writer As TextWriter _
)
Visual C++
public:
static void WriteItem(
    Item^ item,
    TextWriter^ writer
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
writer
Type: System.IO..::..TextWriter
The writer.

See Also

ItemSynchronization Class
Sitecore.Data.Serialization Namespace


LoadOptions Class

[image]

Sitecore 6.4.1 API
LoadOptions Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class LoadOptions
Visual Basic
Public Class LoadOptions
Visual C++
public ref class LoadOptions

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Serialization..::..LoadOptions

See Also

LoadOptions Members
Sitecore.Data.Serialization Namespace


LoadOptions Members

[image] [image]

Sitecore 6.4.1 API
LoadOptions Members
LoadOptions Class Constructors Methods Properties See Also Send Feedback

The LoadOptions type exposes the following members.

Constructors

 | Name | Description
Public method | LoadOptions()()()() | Initializes a new instance of the LoadOptions class.
Public method | LoadOptions(Database) | Creates LoadOptions instance tied to a database.
Public method | LoadOptions(LoadOptions) | Initializes a new instance of the LoadOptions class.
Public method | LoadOptions(Database, String) | Initializes a new instance of the LoadOptions class tied to a specific database and a custom serialization root.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Database | Database to use when loading data
Public property | DisableEvents | Specifies whether database events should be suppressed when loading (which makes it much faster and is the default).
Public property | ForceUpdate | Gets or sets a value indicating whether to clean all local modifications on the update.
Public property | Root | Custom serialization root for load operation.
Public property | UseNewID | Gets or sets a value indicating whether the to use new IDs always when inserting new items.

See Also

LoadOptions Class
Sitecore.Data.Serialization Namespace


LoadOptions Constructor

[image] [image]

Sitecore 6.4.1 API
LoadOptions Constructor
LoadOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LoadOptions()()()() | Initializes a new instance of the LoadOptions class.
Public method | LoadOptions(Database) | Creates LoadOptions instance tied to a database.
Public method | LoadOptions(LoadOptions) | Initializes a new instance of the LoadOptions class.
Public method | LoadOptions(Database, String) | Initializes a new instance of the LoadOptions class tied to a specific database and a custom serialization root.

See Also

LoadOptions Class
LoadOptions Members
Sitecore.Data.Serialization Namespace


LoadOptions Constructor

[image]

Sitecore 6.4.1 API
LoadOptions Constructor
LoadOptions Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LoadOptions()
Visual Basic
Public Sub New
Visual C++
public:
LoadOptions()

See Also

LoadOptions Class
LoadOptions Overload
Sitecore.Data.Serialization Namespace


LoadOptions Constructor (Database)

[image]

Sitecore 6.4.1 API
LoadOptions Constructor (Database)
LoadOptions Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LoadOptions(
    Database database
)
Visual Basic
Public Sub New ( _
    database As Database _
)
Visual C++
public:
LoadOptions(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database

[Missing <param name="database"/> documentation for "M:Sitecore.Data.Serialization.LoadOptions.#ctor(Sitecore.Data.Database)"]

See Also

LoadOptions Class
LoadOptions Overload
Sitecore.Data.Serialization Namespace


LoadOptions Constructor (LoadOptions)

[image]

Sitecore 6.4.1 API
LoadOptions Constructor (LoadOptions)
LoadOptions Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LoadOptions(
    LoadOptions options
)
Visual Basic
Public Sub New ( _
    options As LoadOptions _
)
Visual C++
public:
LoadOptions(
    LoadOptions^ options
)

Parameters

options
Type: Sitecore.Data.Serialization..::..LoadOptions
The options.

See Also

LoadOptions Class
LoadOptions Overload
Sitecore.Data.Serialization Namespace


LoadOptions Constructor (Database, String)

[image]

Sitecore 6.4.1 API
LoadOptions Constructor (Database, String)
LoadOptions Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LoadOptions(
    Database database,
    string root
)
Visual Basic
Public Sub New ( _
    database As Database, _
    root As String _
)
Visual C++
public:
LoadOptions(
    Database^ database,
    String^ root
)

Parameters

database
Type: Sitecore.Data..::..Database
The database
root
Type: System..::..String

[Missing <param name="root"/> documentation for "M:Sitecore.Data.Serialization.LoadOptions.#ctor(Sitecore.Data.Database,System.String)"]

See Also

LoadOptions Class
LoadOptions Overload
Sitecore.Data.Serialization Namespace


LoadOptions Methods

[image] [image]

Sitecore 6.4.1 API
LoadOptions Methods
LoadOptions Class See Also Send Feedback

The LoadOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadOptions Class
Sitecore.Data.Serialization Namespace


LoadOptions Properties

[image] [image]

Sitecore 6.4.1 API
LoadOptions Properties
LoadOptions Class See Also Send Feedback

The LoadOptions type exposes the following members.

Properties

 | Name | Description
Public property | Database | Database to use when loading data
Public property | DisableEvents | Specifies whether database events should be suppressed when loading (which makes it much faster and is the default).
Public property | ForceUpdate | Gets or sets a value indicating whether to clean all local modifications on the update.
Public property | Root | Custom serialization root for load operation.
Public property | UseNewID | Gets or sets a value indicating whether the to use new IDs always when inserting new items.

See Also

LoadOptions Class
Sitecore.Data.Serialization Namespace


Database Property

[image]

Sitecore 6.4.1 API
LoadOptions..::..Database Property
LoadOptions Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database Database { get; set; }
Visual Basic
Public Property Database As Database
    Get
    Set
Visual C++
public:
property Database^ Database {
    Database^ get ();
    void set (Database^ value);
}

See Also

LoadOptions Class
Sitecore.Data.Serialization Namespace


DisableEvents Property

[image]

Sitecore 6.4.1 API
LoadOptions..::..DisableEvents Property
LoadOptions Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool DisableEvents { get; set; }
Visual Basic
Public Property DisableEvents As Boolean
    Get
    Set
Visual C++
public:
property bool DisableEvents {
    bool get ();
    void set (bool value);
}

See Also

LoadOptions Class
Sitecore.Data.Serialization Namespace


ForceUpdate Property

[image]

Sitecore 6.4.1 API
LoadOptions..::..ForceUpdate Property
LoadOptions Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ForceUpdate { get; set; }
Visual Basic
Public Property ForceUpdate As Boolean
    Get
    Set
Visual C++
public:
property bool ForceUpdate {
    bool get ();
    void set (bool value);
}

Field Value

true if the LoadOptions forces the update; otherwise, false.

See Also

LoadOptions Class
Sitecore.Data.Serialization Namespace


Root Property

[image]

Sitecore 6.4.1 API
LoadOptions..::..Root Property
LoadOptions Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Root { get; set; }
Visual Basic
Public Property Root As String
    Get
    Set
Visual C++
public:
property String^ Root {
    String^ get ();
    void set (String^ value);
}

See Also

LoadOptions Class
Sitecore.Data.Serialization Namespace


UseNewID Property

[image]

Sitecore 6.4.1 API
LoadOptions..::..UseNewID Property
LoadOptions Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool UseNewID { get; set; }
Visual Basic
Public Property UseNewID As Boolean
    Get
    Set
Visual C++
public:
property bool UseNewID {
    bool get ();
    void set (bool value);
}

Field Value

true if new IDs should be used; otherwise, false.

See Also

LoadOptions Class
Sitecore.Data.Serialization Namespace


Manager Class

[image]

Sitecore 6.4.1 API
Manager Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Manager
Visual Basic
Public NotInheritable Class Manager
Visual C++
public ref class Manager abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Serialization..::..Manager

See Also

Manager Members
Sitecore.Data.Serialization Namespace


Manager Members

[image] [image]

Sitecore 6.4.1 API
Manager Members
Manager Class Methods See Also Send Feedback

The Manager type exposes the following members.

Methods

Name | Description
CleanupPath(String) | Cleans up the path removing all obsolete files and folders (which are not in database).
CleanupPath(String, Boolean) | Cleans up the path removing all obsolete files and folders (which are not in database).
DoLoadTree | Does the job of loading subtree from specified path.
DropItem | Drops the item identified by dump path.
DumpItem(Item) | Dumps the item to a corresponding file under dump root.
DumpItem(String, Item) | Dumps the item to the specified path.
DumpRole(String) | Dumps the role to a corresponding file under dump root.
DumpRole(String, Role) | Dumps the role to the specified path.
DumpSet | Dumps the specified item set.
DumpTemplates | Dumps templates to disk
DumpTree | Dumps the tree under the dump root.
DumpUser(String) | Dumps the user to a corresponding file under dump root.
DumpUser(String, MembershipUser) | Dumps the user to the specified path.
Initialize | Initializes this instance.
LoadAllRoles | Loads all roles from serialization.
LoadAllUsers | Loads all users from seriazation.
LoadItem | Loads the item from the specified file.
LoadRole | Loads the role from the specified file.
LoadTree | Loads the subtree from specified path.
LoadUser | Loads the user from the specified file.

See Also

Manager Class
Sitecore.Data.Serialization Namespace


Manager Methods

[image] [image]

Sitecore 6.4.1 API
Manager Methods
Manager Class See Also Send Feedback

The Manager type exposes the following members.

Methods

Name | Description
CleanupPath(String) | Cleans up the path removing all obsolete files and folders (which are not in database).
CleanupPath(String, Boolean) | Cleans up the path removing all obsolete files and folders (which are not in database).
DoLoadTree | Does the job of loading subtree from specified path.
DropItem | Drops the item identified by dump path.
DumpItem(Item) | Dumps the item to a corresponding file under dump root.
DumpItem(String, Item) | Dumps the item to the specified path.
DumpRole(String) | Dumps the role to a corresponding file under dump root.
DumpRole(String, Role) | Dumps the role to the specified path.
DumpSet | Dumps the specified item set.
DumpTemplates | Dumps templates to disk
DumpTree | Dumps the tree under the dump root.
DumpUser(String) | Dumps the user to a corresponding file under dump root.
DumpUser(String, MembershipUser) | Dumps the user to the specified path.
Initialize | Initializes this instance.
LoadAllRoles | Loads all roles from serialization.
LoadAllUsers | Loads all users from seriazation.
LoadItem | Loads the item from the specified file.
LoadRole | Loads the role from the specified file.
LoadTree | Loads the subtree from specified path.
LoadUser | Loads the user from the specified file.

See Also

Manager Class
Sitecore.Data.Serialization Namespace


CleanupPath Method

[image] [image]

Sitecore 6.4.1 API
Manager..::..CleanupPath Method
Manager Class See Also Send Feedback

Overload List

Name | Description
CleanupPath(String) | Cleans up the path removing all obsolete files and folders (which are not in database).
CleanupPath(String, Boolean) | Cleans up the path removing all obsolete files and folders (which are not in database).

See Also

Manager Class
Manager Members
Sitecore.Data.Serialization Namespace


CleanupPath Method (String)

[image]

Sitecore 6.4.1 API
Manager..::..CleanupPath Method (String)
Manager Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void CleanupPath(
    string path
)
Visual Basic
Public Shared Sub CleanupPath ( _
    path As String _
)
Visual C++
public:
static void CleanupPath(
    String^ path
)

Parameters

path
Type: System..::..String
The path to cleanup.

See Also

Manager Class
CleanupPath Overload
Sitecore.Data.Serialization Namespace


CleanupPath Method (String, Boolean)

[image]

Sitecore 6.4.1 API
Manager..::..CleanupPath Method (String, Boolean)
Manager Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void CleanupPath(
    string path,
    bool recursive
)
Visual Basic
Public Shared Sub CleanupPath ( _
    path As String, _
    recursive As Boolean _
)
Visual C++
public:
static void CleanupPath(
    String^ path,
    bool recursive
)

Parameters

path
Type: System..::..String
The path to cleanup.
recursive
Type: System..::..Boolean
if set to true this instance is recursive.

See Also

Manager Class
CleanupPath Overload
Sitecore.Data.Serialization Namespace


DoLoadTree Method

[image]

Sitecore 6.4.1 API
Manager..::..DoLoadTree Method
Manager Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void DoLoadTree(
    string path,
    LoadOptions options
)
Visual Basic
Public Shared Sub DoLoadTree ( _
    path As String, _
    options As LoadOptions _
)
Visual C++
public:
static void DoLoadTree(
    String^ path,
    LoadOptions^ options
)

Parameters

path
Type: System..::..String
The path to load.
options
Type: Sitecore.Data.Serialization..::..LoadOptions
The load options.

Exceptions

Exception | Condition
System..::..Exception | Exception.

See Also

Manager Class
Sitecore.Data.Serialization Namespace


DropItem Method

[image]

Sitecore 6.4.1 API
Manager..::..DropItem Method
Manager Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void DropItem(
    string path
)
Visual Basic
Public Shared Sub DropItem ( _
    path As String _
)
Visual C++
public:
static void DropItem(
    String^ path
)

Parameters

path
Type: System..::..String
The path to the item to drop.

See Also

Manager Class
Sitecore.Data.Serialization Namespace


DumpItem Method

[image] [image]

Sitecore 6.4.1 API
Manager..::..DumpItem Method
Manager Class See Also Send Feedback

Overload List

Name | Description
DumpItem(Item) | Dumps the item to a corresponding file under dump root.
DumpItem(String, Item) | Dumps the item to the specified path.

See Also

Manager Class
Manager Members
Sitecore.Data.Serialization Namespace


DumpItem Method (Item)

[image]

Sitecore 6.4.1 API
Manager..::..DumpItem Method (Item)
Manager Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void DumpItem(
    Item item
)
Visual Basic
Public Shared Sub DumpItem ( _
    item As Item _
)
Visual C++
public:
static void DumpItem(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item to dump.

See Also

Manager Class
DumpItem Overload
Sitecore.Data.Serialization Namespace


DumpItem Method (String, Item)

[image]

Sitecore 6.4.1 API
Manager..::..DumpItem Method (String, Item)
Manager Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void DumpItem(
    string path,
    Item item
)
Visual Basic
Public Shared Sub DumpItem ( _
    path As String, _
    item As Item _
)
Visual C++
public:
static void DumpItem(
    String^ path,
    Item^ item
)

Parameters

path
Type: System..::..String
The path to dump.
item
Type: Sitecore.Data.Items..::..Item
The item to dump.

See Also

Manager Class
DumpItem Overload
Sitecore.Data.Serialization Namespace


DumpRole Method (String)

[image]

Sitecore 6.4.1 API
Manager..::..DumpRole Method (String)
Manager Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void DumpRole(
    string rolename
)
Visual Basic
Public Shared Sub DumpRole ( _
    rolename As String _
)
Visual C++
public:
static void DumpRole(
    String^ rolename
)

Parameters

rolename
Type: System..::..String
The role name.

See Also

Manager Class
DumpRole Overload
Sitecore.Data.Serialization Namespace


DumpRole Method (String, Role)

[image]

Sitecore 6.4.1 API
Manager..::..DumpRole Method (String, Role)
Manager Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void DumpRole(
    string path,
    Role role
)
Visual Basic
Public Shared Sub DumpRole ( _
    path As String, _
    role As Role _
)
Visual C++
public:
static void DumpRole(
    String^ path,
    Role^ role
)

Parameters

path
Type: System..::..String
The path to dump.
role
Type: Sitecore.Security.Accounts..::..Role
The role to dump.

See Also

Manager Class
DumpRole Overload
Sitecore.Data.Serialization Namespace


DumpSet Method

[image]

Sitecore 6.4.1 API
Manager..::..DumpSet Method
Manager Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void DumpSet(
    IList<IncludeEntry> entries
)
Visual Basic
Public Shared Sub DumpSet ( _
    entries As IList(Of IncludeEntry) _
)
Visual C++
public:
static void DumpSet(
    IList<IncludeEntry^>^ entries
)

Parameters

entries
Type: System.Collections.Generic..::..IList <(Of <(<' IncludeEntry >)>)>
A list of IncludeEntry objects describing the set of items to process.

See Also

Manager Class
Sitecore.Data.Serialization Namespace


DumpTemplates Method

[image]

Sitecore 6.4.1 API
Manager..::..DumpTemplates Method
Manager Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void DumpTemplates(
    Database database
)
Visual Basic
Public Shared Sub DumpTemplates ( _
    database As Database _
)
Visual C++
public:
static void DumpTemplates(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
Database to dump templates for

See Also

Manager Class
Sitecore.Data.Serialization Namespace


DumpTree Method

[image]

Sitecore 6.4.1 API
Manager..::..DumpTree Method
Manager Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void DumpTree(
    Item item
)
Visual Basic
Public Shared Sub DumpTree ( _
    item As Item _
)
Visual C++
public:
static void DumpTree(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item to dump.

See Also

Manager Class
Sitecore.Data.Serialization Namespace


DumpUser Method

[image] [image]

Sitecore 6.4.1 API
Manager..::..DumpUser Method
Manager Class See Also Send Feedback

Overload List

Name | Description
DumpUser(String) | Dumps the user to a corresponding file under dump root.
DumpUser(String, MembershipUser) | Dumps the user to the specified path.

See Also

Manager Class
Manager Members
Sitecore.Data.Serialization Namespace


DumpUser Method (String)

[image]

Sitecore 6.4.1 API
Manager..::..DumpUser Method (String)
Manager Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void DumpUser(
    string username
)
Visual Basic
Public Shared Sub DumpUser ( _
    username As String _
)
Visual C++
public:
static void DumpUser(
    String^ username
)

Parameters

username
Type: System..::..String
The user name.

See Also

Manager Class
DumpUser Overload
Sitecore.Data.Serialization Namespace


DumpUser Method (String, MembershipUser)

[image]

Sitecore 6.4.1 API
Manager..::..DumpUser Method (String, MembershipUser)
Manager Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void DumpUser(
    string path,
    MembershipUser user
)
Visual Basic
Public Shared Sub DumpUser ( _
    path As String, _
    user As MembershipUser _
)
Visual C++
public:
static void DumpUser(
    String^ path,
    MembershipUser^ user
)

Parameters

path
Type: System..::..String
The path to dump.
user
Type: System.Web.Security..::..MembershipUser
The user to dump.

See Also

Manager Class
DumpUser Overload
Sitecore.Data.Serialization Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
Manager..::..Initialize Method
Manager Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Initialize()
Visual Basic
Public Shared Sub Initialize
Visual C++
public:
static void Initialize()

See Also

Manager Class
Sitecore.Data.Serialization Namespace


LoadAllRoles Method

[image]

Sitecore 6.4.1 API
Manager..::..LoadAllRoles Method
Manager Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void LoadAllRoles()
Visual Basic
Public Shared Sub LoadAllRoles
Visual C++
public:
static void LoadAllRoles()

See Also

Manager Class
Sitecore.Data.Serialization Namespace


LoadAllUsers Method

[image]

Sitecore 6.4.1 API
Manager..::..LoadAllUsers Method
Manager Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void LoadAllUsers()
Visual Basic
Public Shared Sub LoadAllUsers
Visual C++
public:
static void LoadAllUsers()

See Also

Manager Class
Sitecore.Data.Serialization Namespace


LoadItem Method

[image]

Sitecore 6.4.1 API
Manager..::..LoadItem Method
Manager Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item LoadItem(
    string path,
    LoadOptions options
)
Visual Basic
Public Shared Function LoadItem ( _
    path As String, _
    options As LoadOptions _
) As Item
Visual C++
public:
static Item^ LoadItem(
    String^ path,
    LoadOptions^ options
)

Parameters

path
Type: System..::..String
The path to load.
options
Type: Sitecore.Data.Serialization..::..LoadOptions
Load options.

Return Value

The item to load.

See Also

Manager Class
Sitecore.Data.Serialization Namespace


LoadRole Method

[image]

Sitecore 6.4.1 API
Manager..::..LoadRole Method
Manager Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Role LoadRole(
    string path
)
Visual Basic
Public Shared Function LoadRole ( _
    path As String _
) As Role
Visual C++
public:
static Role^ LoadRole(
    String^ path
)

Parameters

path
Type: System..::..String
The path to load.

Return Value

The role to load.

See Also

Manager Class
Sitecore.Data.Serialization Namespace


LoadTree Method

[image]

Sitecore 6.4.1 API
Manager..::..LoadTree Method
Manager Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void LoadTree(
    string path,
    LoadOptions options
)
Visual Basic
Public Shared Sub LoadTree ( _
    path As String, _
    options As LoadOptions _
)
Visual C++
public:
static void LoadTree(
    String^ path,
    LoadOptions^ options
)

Parameters

path
Type: System..::..String
The path to load.
options
Type: Sitecore.Data.Serialization..::..LoadOptions
The options.

See Also

Manager Class
Sitecore.Data.Serialization Namespace


LoadUser Method

[image]

Sitecore 6.4.1 API
Manager..::..LoadUser Method
Manager Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static User LoadUser(
    string path
)
Visual Basic
Public Shared Function LoadUser ( _
    path As String _
) As User
Visual C++
public:
static User^ LoadUser(
    String^ path
)

Parameters

path
Type: System..::..String
The path to load.

Return Value

The user to load.

See Also

Manager Class
Sitecore.Data.Serialization Namespace


Operation Enumeration

[image]

Sitecore 6.4.1 API
Operation Enumeration
See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum Operation
Visual Basic
Public Enumeration Operation
Visual C++
public enum class Operation

Members

Member name | Value | Description
Updated | 0 | Data object has been updated.
Deleted | 1 | Data object has been deleted.

See Also

Sitecore.Data.Serialization Namespace


PathUtils Class

[image]

Sitecore 6.4.1 API
PathUtils Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class PathUtils
Visual Basic
Public NotInheritable Class PathUtils
Visual C++
public ref class PathUtils abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Serialization..::..PathUtils

See Also

PathUtils Members
Sitecore.Data.Serialization Namespace


PathUtils Members

[image] [image]

Sitecore 6.4.1 API
PathUtils Members
PathUtils Class Methods Fields See Also Send Feedback

The PathUtils type exposes the following members.

Methods

Name | Description
CreateWatcher | Creates the FileSystemWatcher for dump root.
GetDatabaseRoot | Gets the database dump root folder.
GetDirectories | Gets the directories.
GetDirectoryPath(String) | Gets the directory path from item reference string representation.
GetDirectoryPath(String, String) | Gets the directory path from item reference string representation.
GetFilePath(String) | Gets the file path from item reference string representation.
GetFilePath(RoleReference) | Gets the file path from role reference.
GetFilePath(UserReference) | Gets the file path from user reference.
GetShortPath | Gets the short variant of specified path.
MakeItemPath(String) | Makes the item path from full file path. Uses Root as serialization root.
MakeItemPath(String, String) | Makes the item path from full file path.
StripPath | Removes item file extension from the filePath.
UnmapItemPath | Unmaps the item path, expanding any junction points.

Fields

Name | Description
Extension | Extension for item files.
RoleExtension | Extension for role files.
Root | Dump root folder.
UserExtension | Extension for user files.

See Also

PathUtils Class
Sitecore.Data.Serialization Namespace


PathUtils Fields

[image] [image]

Sitecore 6.4.1 API
PathUtils Fields
PathUtils Class See Also Send Feedback

The PathUtils type exposes the following members.

Fields

Name | Description
Extension | Extension for item files.
RoleExtension | Extension for role files.
Root | Dump root folder.
UserExtension | Extension for user files.

See Also

PathUtils Class
Sitecore.Data.Serialization Namespace


Extension Field

[image]

Sitecore 6.4.1 API
PathUtils..::..Extension Field
PathUtils Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly string Extension
Visual Basic
Public Shared ReadOnly Extension As String
Visual C++
public:
static initonly String^ Extension

See Also

PathUtils Class
Sitecore.Data.Serialization Namespace


RoleExtension Field

[image]

Sitecore 6.4.1 API
PathUtils..::..RoleExtension Field
PathUtils Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly string RoleExtension
Visual Basic
Public Shared ReadOnly RoleExtension As String
Visual C++
public:
static initonly String^ RoleExtension

See Also

PathUtils Class
Sitecore.Data.Serialization Namespace


Root Field

[image]

Sitecore 6.4.1 API
PathUtils..::..Root Field
PathUtils Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly string Root
Visual Basic
Public Shared ReadOnly Root As String
Visual C++
public:
static initonly String^ Root

See Also

PathUtils Class
Sitecore.Data.Serialization Namespace


UserExtension Field

[image]

Sitecore 6.4.1 API
PathUtils..::..UserExtension Field
PathUtils Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly string UserExtension
Visual Basic
Public Shared ReadOnly UserExtension As String
Visual C++
public:
static initonly String^ UserExtension

See Also

PathUtils Class
Sitecore.Data.Serialization Namespace


PathUtils Methods

[image] [image]

Sitecore 6.4.1 API
PathUtils Methods
PathUtils Class See Also Send Feedback

The PathUtils type exposes the following members.

Methods

Name | Description
CreateWatcher | Creates the FileSystemWatcher for dump root.
GetDatabaseRoot | Gets the database dump root folder.
GetDirectories | Gets the directories.
GetDirectoryPath(String) | Gets the directory path from item reference string representation.
GetDirectoryPath(String, String) | Gets the directory path from item reference string representation.
GetFilePath(String) | Gets the file path from item reference string representation.
GetFilePath(RoleReference) | Gets the file path from role reference.
GetFilePath(UserReference) | Gets the file path from user reference.
GetShortPath | Gets the short variant of specified path.
MakeItemPath(String) | Makes the item path from full file path. Uses Root as serialization root.
MakeItemPath(String, String) | Makes the item path from full file path.
StripPath | Removes item file extension from the filePath.
UnmapItemPath | Unmaps the item path, expanding any junction points.

See Also

PathUtils Class
Sitecore.Data.Serialization Namespace


GetDatabaseRoot Method

[image]

Sitecore 6.4.1 API
PathUtils..::..GetDatabaseRoot Method
PathUtils Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetDatabaseRoot(
    string databaseName
)
Visual Basic
Public Shared Function GetDatabaseRoot ( _
    databaseName As String _
) As String
Visual C++
public:
static String^ GetDatabaseRoot(
    String^ databaseName
)

Parameters

databaseName
Type: System..::..String
Name of the database.

Return Value

Root path of the database dump.

See Also

PathUtils Class
Sitecore.Data.Serialization Namespace


GetDirectories Method

[image]

Sitecore 6.4.1 API
PathUtils..::..GetDirectories Method
PathUtils Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string[] GetDirectories(
    string path
)
Visual Basic
Public Shared Function GetDirectories ( _
    path As String _
) As String()
Visual C++
public:
static array<String^>^ GetDirectories(
    String^ path
)

Parameters

path
Type: System..::..String
The path.

Return Value

The directories.

See Also

PathUtils Class
Sitecore.Data.Serialization Namespace


GetDirectoryPath Method

[image] [image]

Sitecore 6.4.1 API
PathUtils..::..GetDirectoryPath Method
PathUtils Class See Also Send Feedback

Overload List

Name | Description
GetDirectoryPath(String) | Gets the directory path from item reference string representation.
GetDirectoryPath(String, String) | Gets the directory path from item reference string representation.

See Also

PathUtils Class
PathUtils Members
Sitecore.Data.Serialization Namespace


GetDirectoryPath Method (String)

[image]

Sitecore 6.4.1 API
PathUtils..::..GetDirectoryPath Method (String)
PathUtils Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetDirectoryPath(
    string itempath
)
Visual Basic
Public Shared Function GetDirectoryPath ( _
    itempath As String _
) As String
Visual C++
public:
static String^ GetDirectoryPath(
    String^ itempath
)

Parameters

itempath
Type: System..::..String
The itempath.

Return Value

The directory path.

See Also

PathUtils Class
GetDirectoryPath Overload
Sitecore.Data.Serialization Namespace


GetDirectoryPath Method (String, String)

[image]

Sitecore 6.4.1 API
PathUtils..::..GetDirectoryPath Method (String, String)
PathUtils Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetDirectoryPath(
    string itempath,
    string root
)
Visual Basic
Public Shared Function GetDirectoryPath ( _
    itempath As String, _
    root As String _
) As String
Visual C++
public:
static String^ GetDirectoryPath(
    String^ itempath,
    String^ root
)

Parameters

itempath
Type: System..::..String
The itempath.
root
Type: System..::..String
Overridden serialization root.

Return Value

The directory path.

See Also

PathUtils Class
GetDirectoryPath Overload
Sitecore.Data.Serialization Namespace


GetFilePath Method

[image] [image]

Sitecore 6.4.1 API
PathUtils..::..GetFilePath Method
PathUtils Class See Also Send Feedback

Overload List

Name | Description
GetFilePath(String) | Gets the file path from item reference string representation.
GetFilePath(RoleReference) | Gets the file path from role reference.
GetFilePath(UserReference) | Gets the file path from user reference.

See Also

PathUtils Class
PathUtils Members
Sitecore.Data.Serialization Namespace


GetFilePath Method (RoleReference)

[image]

Sitecore 6.4.1 API
PathUtils..::..GetFilePath Method (RoleReference)
PathUtils Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetFilePath(
    RoleReference roleReference
)
Visual Basic
Public Shared Function GetFilePath ( _
    roleReference As RoleReference _
) As String
Visual C++
public:
static String^ GetFilePath(
    RoleReference^ roleReference
)

Parameters

roleReference
Type: Sitecore.Security.Serialization..::..RoleReference
The role reference.

Return Value

The file path.

See Also

PathUtils Class
GetFilePath Overload
Sitecore.Data.Serialization Namespace


GetFilePath Method (UserReference)

[image]

Sitecore 6.4.1 API
PathUtils..::..GetFilePath Method (UserReference)
PathUtils Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetFilePath(
    UserReference userReference
)
Visual Basic
Public Shared Function GetFilePath ( _
    userReference As UserReference _
) As String
Visual C++
public:
static String^ GetFilePath(
    UserReference^ userReference
)

Parameters

userReference
Type: Sitecore.Security.Serialization..::..UserReference
The user reference.

Return Value

The file path.

See Also

PathUtils Class
GetFilePath Overload
Sitecore.Data.Serialization Namespace


GetShortPath Method

[image]

Sitecore 6.4.1 API
PathUtils..::..GetShortPath Method
PathUtils Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetShortPath(
    string path
)
Visual Basic
Public Shared Function GetShortPath ( _
    path As String _
) As String
Visual C++
public:
static String^ GetShortPath(
    String^ path
)

Parameters

path
Type: System..::..String
The path.

Return Value

The short path.

Exceptions

Exception | Condition
System..::..Exception | path is not under the root

See Also

PathUtils Class
Sitecore.Data.Serialization Namespace


MakeItemPath Method (String, String)

[image]

Sitecore 6.4.1 API
PathUtils..::..MakeItemPath Method (String, String)
PathUtils Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string MakeItemPath(
    string path,
    string root
)
Visual Basic
Public Shared Function MakeItemPath ( _
    path As String, _
    root As String _
) As String
Visual C++
public:
static String^ MakeItemPath(
    String^ path,
    String^ root
)

Parameters

path
Type: System..::..String
The path.
root
Type: System..::..String
Overridden serialization root.

Return Value

The item path.

See Also

PathUtils Class
MakeItemPath Overload
Sitecore.Data.Serialization Namespace


StripPath Method

[image]

Sitecore 6.4.1 API
PathUtils..::..StripPath Method
PathUtils Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string StripPath(
    string filePath
)
Visual Basic
Public Shared Function StripPath ( _
    filePath As String _
) As String
Visual C++
public:
static String^ StripPath(
    String^ filePath
)

Parameters

filePath
Type: System..::..String
The path.

Return Value

The filePath.

See Also

PathUtils Class
Sitecore.Data.Serialization Namespace


UnmapItemPath Method

[image]

Sitecore 6.4.1 API
PathUtils..::..UnmapItemPath Method
PathUtils Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string UnmapItemPath(
    string filePath,
    string root
)
Visual Basic
Public Shared Function UnmapItemPath ( _
    filePath As String, _
    root As String _
) As String
Visual C++
public:
static String^ UnmapItemPath(
    String^ filePath,
    String^ root
)

Parameters

filePath
Type: System..::..String
The file path.
root
Type: System..::..String
root

Return Value

The item path.

Exceptions

Exception | Condition
System..::..Exception | File path is not under dump root

See Also

PathUtils Class
Sitecore.Data.Serialization Namespace


SerializationFinishedEvent Class

[image]

Sitecore 6.4.1 API
SerializationFinishedEvent Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SerializationFinishedEvent
Visual Basic
Public Class SerializationFinishedEvent
Visual C++
public ref class SerializationFinishedEvent

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Serialization..::..SerializationFinishedEvent

See Also

SerializationFinishedEvent Members
Sitecore.Data.Serialization Namespace


SerializationFinishedEvent Constructor

[image]

Sitecore 6.4.1 API
SerializationFinishedEvent Constructor
SerializationFinishedEvent Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SerializationFinishedEvent()
Visual Basic
Public Sub New
Visual C++
public:
SerializationFinishedEvent()

See Also

SerializationFinishedEvent Class
Sitecore.Data.Serialization Namespace


SerializationFinishedEvent Methods

[image] [image]

Sitecore 6.4.1 API
SerializationFinishedEvent Methods
SerializationFinishedEvent Class See Also Send Feedback

The SerializationFinishedEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SerializationFinishedEvent Class
Sitecore.Data.Serialization Namespace


ShadowWriter Class

[image]

Sitecore 6.4.1 API
ShadowWriter Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class ShadowWriter
Visual Basic
Public NotInheritable Class ShadowWriter
Visual C++
public ref class ShadowWriter abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Serialization..::..ShadowWriter

See Also

ShadowWriter Members
Sitecore.Data.Serialization Namespace


PutItem Method

[image]

Sitecore 6.4.1 API
ShadowWriter..::..PutItem Method
ShadowWriter Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void PutItem(
    Operation operation,
    Item item,
    Item parent
)
Visual Basic
Public Shared Sub PutItem ( _
    operation As Operation, _
    item As Item, _
    parent As Item _
)
Visual C++
public:
static void PutItem(
    Operation operation,
    Item^ item,
    Item^ parent
)

Parameters

operation
Type: Sitecore.Data.Serialization..::..Operation
The operation.
item
Type: Sitecore.Data.Items..::..Item
The item.
parent
Type: Sitecore.Data.Items..::..Item
The parent.

See Also

ShadowWriter Class
Sitecore.Data.Serialization Namespace


Terminate Method

[image]

Sitecore 6.4.1 API
ShadowWriter..::..Terminate Method
ShadowWriter Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Terminate()
Visual Basic
Public Shared Sub Terminate
Visual C++
public:
static void Terminate()

See Also

ShadowWriter Class
Sitecore.Data.Serialization Namespace


SqlConnectionFactory Members

[image] [image]

Sitecore 6.4.1 API
SqlConnectionFactory Members
SqlConnectionFactory Class Constructors Methods Properties See Also Send Feedback

The SqlConnectionFactory type exposes the following members.

Constructors

 | Name | Description
Public method | SqlConnectionFactory | Initializes a new instance of SqlConnectionFactory.

Methods

 | Name | Description
Public method | CreateApi | See DataConnectionFactory.CreateApi.
Public method | CreateProvider | See DataConnectionFactory.CreateProvider.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConnectionString | Gets the connection string for this database connection.

See Also

SqlConnectionFactory Class
Sitecore.Data.Serialization Namespace


SqlConnectionFactory Constructor

[image]

Sitecore 6.4.1 API
SqlConnectionFactory Constructor
SqlConnectionFactory Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlConnectionFactory(
    string connectionString
)
Visual Basic
Public Sub New ( _
    connectionString As String _
)
Visual C++
public:
SqlConnectionFactory(
    String^ connectionString
)

Parameters

connectionString
Type: System..::..String
Connection string to use

See Also

SqlConnectionFactory Class
Sitecore.Data.Serialization Namespace


SqlConnectionFactory Methods

[image] [image]

Sitecore 6.4.1 API
SqlConnectionFactory Methods
SqlConnectionFactory Class See Also Send Feedback

The SqlConnectionFactory type exposes the following members.

Methods

 | Name | Description
Public method | CreateApi | See DataConnectionFactory.CreateApi.
Public method | CreateProvider | See DataConnectionFactory.CreateProvider.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SqlConnectionFactory Class
Sitecore.Data.Serialization Namespace


CreateApi Method

[image]

Sitecore 6.4.1 API
SqlConnectionFactory..::..CreateApi Method
SqlConnectionFactory Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlDataApi CreateApi()
Visual Basic
Public Function CreateApi As SqlDataApi
Visual C++
public:
virtual SqlDataApi^ CreateApi() sealed

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Serialization.SqlConnectionFactory.CreateApi"]

Implements

IDataConnectionFactory..::..CreateApi()()()()

See Also

SqlConnectionFactory Class
Sitecore.Data.Serialization Namespace


CreateProvider Method

[image]

Sitecore 6.4.1 API
SqlConnectionFactory..::..CreateProvider Method
SqlConnectionFactory Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataProvider CreateProvider()
Visual Basic
Public Function CreateProvider As DataProvider
Visual C++
public:
virtual DataProvider^ CreateProvider() sealed

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Serialization.SqlConnectionFactory.CreateProvider"]

Implements

IDataConnectionFactory..::..CreateProvider()()()()

See Also

SqlConnectionFactory Class
Sitecore.Data.Serialization Namespace


SqlServerAdminConnection Class

[image]

Sitecore 6.4.1 API
SqlServerAdminConnection Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SqlServerAdminConnection : IDbAdminConnection
Visual Basic
Public Class SqlServerAdminConnection _
    Implements IDbAdminConnection
Visual C++
public ref class SqlServerAdminConnection : IDbAdminConnection

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Serialization..::..SqlServerAdminConnection

See Also

SqlServerAdminConnection Members
Sitecore.Data.Serialization Namespace


SqlServerAdminConnection Members

[image] [image]

Sitecore 6.4.1 API
SqlServerAdminConnection Members
SqlServerAdminConnection Class Constructors Methods See Also Send Feedback

The SqlServerAdminConnection type exposes the following members.

Constructors

 | Name | Description
Public method | SqlServerAdminConnection | Initializes new instance of administrative connection

Methods

 | Name | Description
Public method | CreateDatabase(String) | Creates a new database with the specified names
Public method | CreateDatabase(String, String) | Creates database with a specific name
Public method | Detach | Detach database to unlock file;
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConnectionFactory | Returns connection object factory for specific database
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SqlServerAdminConnection Class
Sitecore.Data.Serialization Namespace


SqlServerAdminConnection Constructor

[image]

Sitecore 6.4.1 API
SqlServerAdminConnection Constructor
SqlServerAdminConnection Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlServerAdminConnection(
    string connectionString
)
Visual Basic
Public Sub New ( _
    connectionString As String _
)
Visual C++
public:
SqlServerAdminConnection(
    String^ connectionString
)

Parameters

connectionString
Type: System..::..String
Connection string to the master database

See Also

SqlServerAdminConnection Class
Sitecore.Data.Serialization Namespace


SqlServerAdminConnection Methods

[image] [image]

Sitecore 6.4.1 API
SqlServerAdminConnection Methods
SqlServerAdminConnection Class See Also Send Feedback

The SqlServerAdminConnection type exposes the following members.

Methods

 | Name | Description
Public method | CreateDatabase(String) | Creates a new database with the specified names
Public method | CreateDatabase(String, String) | Creates database with a specific name
Public method | Detach | Detach database to unlock file;
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConnectionFactory | Returns connection object factory for specific database
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SqlServerAdminConnection Class
Sitecore.Data.Serialization Namespace


CreateDatabase Method (String)

[image]

Sitecore 6.4.1 API
SqlServerAdminConnection..::..CreateDatabase Method (String)
SqlServerAdminConnection Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void CreateDatabase(
    string databaseName
)
Visual Basic
Public Sub CreateDatabase ( _
    databaseName As String _
)
Visual C++
public:
virtual void CreateDatabase(
    String^ databaseName
) sealed

Parameters

databaseName
Type: System..::..String
Name of the database

Implements

IDbAdminConnection..::..CreateDatabase(String)

See Also

SqlServerAdminConnection Class
CreateDatabase Overload
Sitecore.Data.Serialization Namespace


CreateDatabase Method (String, String)

[image]

Sitecore 6.4.1 API
SqlServerAdminConnection..::..CreateDatabase Method (String, String)
SqlServerAdminConnection Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void CreateDatabase(
    string databaseName,
    string primaryFileName
)
Visual Basic
Public Sub CreateDatabase ( _
    databaseName As String, _
    primaryFileName As String _
)
Visual C++
public:
virtual void CreateDatabase(
    String^ databaseName,
    String^ primaryFileName
) sealed

Parameters

databaseName
Type: System..::..String
Name of the database
primaryFileName
Type: System..::..String
File to strore the database

Implements

IDbAdminConnection..::..CreateDatabase(String, String)

See Also

SqlServerAdminConnection Class
CreateDatabase Overload
Sitecore.Data.Serialization Namespace


Detach Method

[image]

Sitecore 6.4.1 API
SqlServerAdminConnection..::..Detach Method
SqlServerAdminConnection Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Detach(
    string databaseName
)
Visual Basic
Public Sub Detach ( _
    databaseName As String _
)
Visual C++
public:
virtual void Detach(
    String^ databaseName
) sealed

Parameters

databaseName
Type: System..::..String
Name of the database

Implements

IDbAdminConnection..::..Detach(String)

See Also

SqlServerAdminConnection Class
Sitecore.Data.Serialization Namespace


GetConnectionFactory Method

[image]

Sitecore 6.4.1 API
SqlServerAdminConnection..::..GetConnectionFactory Method
SqlServerAdminConnection Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IDataConnectionFactory GetConnectionFactory(
    string databaseName
)
Visual Basic
Public Function GetConnectionFactory ( _
    databaseName As String _
) As IDataConnectionFactory
Visual C++
public:
virtual IDataConnectionFactory^ GetConnectionFactory(
    String^ databaseName
) sealed

Parameters

databaseName
Type: System..::..String
Name of the database

Return Value

IDataConnectionFactory implementation pointing to the database

Implements

IDbAdminConnection..::..GetConnectionFactory(String)

See Also

SqlServerAdminConnection Class
Sitecore.Data.Serialization Namespace


Sitecore.Data.Serialization.ObjectModel Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Data.Serialization.ObjectModel Namespace
Send Feedback

Classes

 | Class | Description
Public class | SerializationUtils | Low-level formatting routines used when dumping items to text files and parsing back
Public class | SyncField | Represents item field in ItemDom
Public class | SyncItem | Represents Sitecore item in ItemDom.
Public class | SyncVersion | Represents item version in ItemDom
Public class | Tokenizer | Adapter for TextReader, convenient for line-based parsing.
Public class | ValuesDictionary | Encapsulates dictionary of field values


SerializationUtils Class

[image]

Sitecore 6.4.1 API
SerializationUtils Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class SerializationUtils
Visual Basic
Public NotInheritable Class SerializationUtils
Visual C++
public ref class SerializationUtils abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Serialization.ObjectModel..::..SerializationUtils

See Also

SerializationUtils Members
Sitecore.Data.Serialization.ObjectModel Namespace


SerializationUtils Members

[image] [image]

Sitecore 6.4.1 API
SerializationUtils Members
SerializationUtils Class Methods See Also Send Feedback

The SerializationUtils type exposes the following members.

Methods

Name | Description
IsItemSerialization | Checks whether file is itemsync file.

See Also

SerializationUtils Class
Sitecore.Data.Serialization.ObjectModel Namespace


SyncField Class

[image]

Sitecore 6.4.1 API
SyncField Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SyncField
Visual Basic
Public Class SyncField
Visual C++
public ref class SyncField

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Serialization.ObjectModel..::..SyncField

See Also

SyncField Members
Sitecore.Data.Serialization.ObjectModel Namespace


SyncField Members

[image] [image]

Sitecore 6.4.1 API
SyncField Members
SyncField Class Constructors Methods Properties See Also Send Feedback

The SyncField type exposes the following members.

Constructors

 | Name | Description
Public method | SyncField | Initializes a new instance of the SyncField class

Methods

 | Name | Description
 | BuildField | Builds the field.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReadField | Reads the field.
Public method | Serialize | Serializes field to the specified writer.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FieldID | Gets or sets the field ID.
Public property | FieldKey | Gets or sets the field key.
Public property | FieldName | Gets or sets the name of the field.
Public property | FieldValue | Gets or sets the field value.

See Also

SyncField Class
Sitecore.Data.Serialization.ObjectModel Namespace


SyncField Constructor

[image]

Sitecore 6.4.1 API
SyncField Constructor
SyncField Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SyncField()
Visual Basic
Public Sub New
Visual C++
public:
SyncField()

See Also

SyncField Class
Sitecore.Data.Serialization.ObjectModel Namespace


SyncField Methods

[image] [image]

Sitecore 6.4.1 API
SyncField Methods
SyncField Class See Also Send Feedback

The SyncField type exposes the following members.

Methods

 | Name | Description
 | BuildField | Builds the field.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReadField | Reads the field.
Public method | Serialize | Serializes field to the specified writer.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SyncField Class
Sitecore.Data.Serialization.ObjectModel Namespace


BuildField Method

[image]

Sitecore 6.4.1 API
SyncField..::..BuildField Method
SyncField Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static SyncField BuildField(
    string fieldID,
    string fieldName,
    string fieldKey,
    string fieldValue,
    bool hasValue
)
Visual Basic
Public Shared Function BuildField ( _
    fieldID As String, _
    fieldName As String, _
    fieldKey As String, _
    fieldValue As String, _
    hasValue As Boolean _
) As SyncField
Visual C++
public:
static SyncField^ BuildField(
    String^ fieldID,
    String^ fieldName,
    String^ fieldKey,
    String^ fieldValue,
    bool hasValue
)

Parameters

fieldID
Type: System..::..String
The field ID.
fieldName
Type: System..::..String
Name of the field.
fieldKey
Type: System..::..String
The field key.
fieldValue
Type: System..::..String
The field value.
hasValue
Type: System..::..Boolean
if set to true this instance is has value.

Return Value

The field.

See Also

SyncField Class
Sitecore.Data.Serialization.ObjectModel Namespace


ReadField Method

[image]

Sitecore 6.4.1 API
SyncField..::..ReadField Method
SyncField Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static SyncField ReadField(
    Tokenizer reader
)
Visual Basic
Public Shared Function ReadField ( _
    reader As Tokenizer _
) As SyncField
Visual C++
public:
static SyncField^ ReadField(
    Tokenizer^ reader
)

Parameters

reader
Type: Sitecore.Data.Serialization.ObjectModel..::..Tokenizer
The reader.

Return Value

The field.

Exceptions

Exception | Condition
System..::..Exception | Exception.

See Also

SyncField Class
Sitecore.Data.Serialization.ObjectModel Namespace


Serialize Method

[image]

Sitecore 6.4.1 API
SyncField..::..Serialize Method
SyncField Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Serialize(
    TextWriter writer
)
Visual Basic
Public Sub Serialize ( _
    writer As TextWriter _
)
Visual C++
public:
void Serialize(
    TextWriter^ writer
)

Parameters

writer
Type: System.IO..::..TextWriter
The writer.

See Also

SyncField Class
Sitecore.Data.Serialization.ObjectModel Namespace


FieldID Property

[image]

Sitecore 6.4.1 API
SyncField..::..FieldID Property
SyncField Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string FieldID { get; set; }
Visual Basic
Public Property FieldID As String
    Get
    Set
Visual C++
public:
property String^ FieldID {
    String^ get ();
    void set (String^ value);
}

Field Value

The field ID.

See Also

SyncField Class
Sitecore.Data.Serialization.ObjectModel Namespace


FieldKey Property

[image]

Sitecore 6.4.1 API
SyncField..::..FieldKey Property
SyncField Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string FieldKey { get; set; }
Visual Basic
Public Property FieldKey As String
    Get
    Set
Visual C++
public:
property String^ FieldKey {
    String^ get ();
    void set (String^ value);
}

Field Value

The field key.

See Also

SyncField Class
Sitecore.Data.Serialization.ObjectModel Namespace


FieldName Property

[image]

Sitecore 6.4.1 API
SyncField..::..FieldName Property
SyncField Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string FieldName { get; set; }
Visual Basic
Public Property FieldName As String
    Get
    Set
Visual C++
public:
property String^ FieldName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the field.

See Also

SyncField Class
Sitecore.Data.Serialization.ObjectModel Namespace


FieldValue Property

[image]

Sitecore 6.4.1 API
SyncField..::..FieldValue Property
SyncField Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string FieldValue { get; set; }
Visual Basic
Public Property FieldValue As String
    Get
    Set
Visual C++
public:
property String^ FieldValue {
    String^ get ();
    void set (String^ value);
}

Field Value

The field value.

See Also

SyncField Class
Sitecore.Data.Serialization.ObjectModel Namespace


SyncItem Class

[image]

Sitecore 6.4.1 API
SyncItem Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SyncItem
Visual Basic
Public Class SyncItem
Visual C++
public ref class SyncItem

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Serialization.ObjectModel..::..SyncItem

See Also

SyncItem Members
Sitecore.Data.Serialization.ObjectModel Namespace


SyncItem Members

[image] [image]

Sitecore 6.4.1 API
SyncItem Members
SyncItem Class Constructors Methods Fields Properties See Also Send Feedback

The SyncItem type exposes the following members.

Constructors

 | Name | Description
Public method | SyncItem | Initializes a new instance of the SyncItem class

Methods

 | Name | Description
Public method | AddSharedField | Adds the shared field.
Public method | AddVersion | Adds the version.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLatestVersions | Gets the latest versions.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReadItem(Tokenizer) | Reads the item.
 | ReadItem(Tokenizer, Boolean) | Reads the item from a Tokenizer.
Public method | RemoveField | Remove either shared field from item or versioned field from all versions.
Public method | RemoveSharedField | Remove shared field information from the version
Public method | RemoveVersion | Remove version by language and versionNumber
Public method | RemoveVersions | Remove all versions for specified language
Public method | Serialize | Serializes item to the specified writer.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
FormatVersion | Version of item dump file format.

Properties

 | Name | Description
Public property | BranchId | Gets or sets the branch id.
Public property | DatabaseName | Gets or sets the name of the database.
Public property | ID | Gets or sets the item ID.
Public property | ItemPath | Gets or sets the item path.
Public property | MasterID | Gets or sets the master ID.
Public property | Name | Gets or sets the name.
Public property | ParentID | Gets or sets the parent ID.
Public property | SharedFields | Gets the shared fields.
Public property | SharedValues | Gets the values.
Public property | TemplateID | Gets or sets the template ID.
Public property | TemplateName | Gets or sets the name of the template.
Public property | Versions | Gets the versions.

See Also

SyncItem Class
Sitecore.Data.Serialization.ObjectModel Namespace


SyncItem Constructor

[image]

Sitecore 6.4.1 API
SyncItem Constructor
SyncItem Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SyncItem()
Visual Basic
Public Sub New
Visual C++
public:
SyncItem()

See Also

SyncItem Class
Sitecore.Data.Serialization.ObjectModel Namespace


SyncItem Fields

[image] [image]

Sitecore 6.4.1 API
SyncItem Fields
SyncItem Class See Also Send Feedback

The SyncItem type exposes the following members.

Fields

Name | Description
FormatVersion | Version of item dump file format.

See Also

SyncItem Class
Sitecore.Data.Serialization.ObjectModel Namespace


FormatVersion Field

[image]

Sitecore 6.4.1 API
SyncItem..::..FormatVersion Field
SyncItem Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly int FormatVersion
Visual Basic
Public Shared ReadOnly FormatVersion As Integer
Visual C++
public:
static initonly int FormatVersion

See Also

SyncItem Class
Sitecore.Data.Serialization.ObjectModel Namespace


SyncItem Methods

[image] [image]

Sitecore 6.4.1 API
SyncItem Methods
SyncItem Class See Also Send Feedback

The SyncItem type exposes the following members.

Methods

 | Name | Description
Public method | AddSharedField | Adds the shared field.
Public method | AddVersion | Adds the version.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLatestVersions | Gets the latest versions.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReadItem(Tokenizer) | Reads the item.
 | ReadItem(Tokenizer, Boolean) | Reads the item from a Tokenizer.
Public method | RemoveField | Remove either shared field from item or versioned field from all versions.
Public method | RemoveSharedField | Remove shared field information from the version
Public method | RemoveVersion | Remove version by language and versionNumber
Public method | RemoveVersions | Remove all versions for specified language
Public method | Serialize | Serializes item to the specified writer.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SyncItem Class
Sitecore.Data.Serialization.ObjectModel Namespace


AddVersion Method

[image]

Sitecore 6.4.1 API
SyncItem..::..AddVersion Method
SyncItem Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SyncVersion AddVersion(
    string language,
    string version,
    string revision
)
Visual Basic
Public Function AddVersion ( _
    language As String, _
    version As String, _
    revision As String _
) As SyncVersion
Visual C++
public:
SyncVersion^ AddVersion(
    String^ language,
    String^ version,
    String^ revision
)

Parameters

language
Type: System..::..String
The language.
version
Type: System..::..String
The version.
revision
Type: System..::..String
The revision.

Return Value

The version.

See Also

SyncItem Class
Sitecore.Data.Serialization.ObjectModel Namespace


GetLatestVersions Method

[image]

Sitecore 6.4.1 API
SyncItem..::..GetLatestVersions Method
SyncItem Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IEnumerable<SyncVersion> GetLatestVersions()
Visual Basic
Public Function GetLatestVersions As IEnumerable(Of SyncVersion)
Visual C++
public:
IEnumerable<SyncVersion^>^ GetLatestVersions()

Return Value

The latest versions.

See Also

SyncItem Class
Sitecore.Data.Serialization.ObjectModel Namespace


ReadItem Method

[image] [image]

Sitecore 6.4.1 API
SyncItem..::..ReadItem Method
SyncItem Class See Also Send Feedback

Overload List

Name | Description
ReadItem(Tokenizer) | Reads the item.
ReadItem(Tokenizer, Boolean) | Reads the item from a Tokenizer.

See Also

SyncItem Class
SyncItem Members
Sitecore.Data.Serialization.ObjectModel Namespace


ReadItem Method (Tokenizer)

[image]

Sitecore 6.4.1 API
SyncItem..::..ReadItem Method (Tokenizer)
SyncItem Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static SyncItem ReadItem(
    Tokenizer reader
)
Visual Basic
Public Shared Function ReadItem ( _
    reader As Tokenizer _
) As SyncItem
Visual C++
public:
static SyncItem^ ReadItem(
    Tokenizer^ reader
)

Parameters

reader
Type: Sitecore.Data.Serialization.ObjectModel..::..Tokenizer
The reader.

Return Value

The item.

See Also

SyncItem Class
ReadItem Overload
Sitecore.Data.Serialization.ObjectModel Namespace


ReadItem Method (Tokenizer, Boolean)

[image]

Sitecore 6.4.1 API
SyncItem..::..ReadItem Method (Tokenizer, Boolean)
SyncItem Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static SyncItem ReadItem(
    Tokenizer reader,
    bool assertVersion
)
Visual Basic
Public Shared Function ReadItem ( _
    reader As Tokenizer, _
    assertVersion As Boolean _
) As SyncItem
Visual C++
public:
static SyncItem^ ReadItem(
    Tokenizer^ reader,
    bool assertVersion
)

Parameters

reader
Type: Sitecore.Data.Serialization.ObjectModel..::..Tokenizer
The reader.
assertVersion
Type: System..::..Boolean
Assert file format version flag.

Return Value

The item.

Exceptions

Exception | Condition
System..::..Exception | The file was generated using a newer version of Serialization

See Also

SyncItem Class
ReadItem Overload
Sitecore.Data.Serialization.ObjectModel Namespace


RemoveField Method

[image]

Sitecore 6.4.1 API
SyncItem..::..RemoveField Method
SyncItem Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool RemoveField(
    string fieldName
)
Visual Basic
Public Function RemoveField ( _
    fieldName As String _
) As Boolean
Visual C++
public:
bool RemoveField(
    String^ fieldName
)

Parameters

fieldName
Type: System..::..String
field name or ID

Return Value

true if field found and deleted

See Also

SyncItem Class
Sitecore.Data.Serialization.ObjectModel Namespace


RemoveSharedField Method

[image]

Sitecore 6.4.1 API
SyncItem..::..RemoveSharedField Method
SyncItem Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool RemoveSharedField(
    string fieldName
)
Visual Basic
Public Function RemoveSharedField ( _
    fieldName As String _
) As Boolean
Visual C++
public:
bool RemoveSharedField(
    String^ fieldName
)

Parameters

fieldName
Type: System..::..String
field name or ID

Return Value

true if field found and deleted

See Also

SyncItem Class
Sitecore.Data.Serialization.ObjectModel Namespace


RemoveVersion Method

[image]

Sitecore 6.4.1 API
SyncItem..::..RemoveVersion Method
SyncItem Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool RemoveVersion(
    string language,
    string versionNumber
)
Visual Basic
Public Function RemoveVersion ( _
    language As String, _
    versionNumber As String _
) As Boolean
Visual C++
public:
bool RemoveVersion(
    String^ language,
    String^ versionNumber
)

Parameters

language
Type: System..::..String
version language
versionNumber
Type: System..::..String
version number

Return Value

true if version found and deleted

See Also

SyncItem Class
Sitecore.Data.Serialization.ObjectModel Namespace


RemoveVersions Method

[image]

Sitecore 6.4.1 API
SyncItem..::..RemoveVersions Method
SyncItem Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool RemoveVersions(
    string language
)
Visual Basic
Public Function RemoveVersions ( _
    language As String _
) As Boolean
Visual C++
public:
bool RemoveVersions(
    String^ language
)

Parameters

language
Type: System..::..String
version language

Return Value

true if versions found and deleted

See Also

SyncItem Class
Sitecore.Data.Serialization.ObjectModel Namespace


Serialize Method

[image]

Sitecore 6.4.1 API
SyncItem..::..Serialize Method
SyncItem Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Serialize(
    TextWriter writer
)
Visual Basic
Public Sub Serialize ( _
    writer As TextWriter _
)
Visual C++
public:
void Serialize(
    TextWriter^ writer
)

Parameters

writer
Type: System.IO..::..TextWriter
The writer.

See Also

SyncItem Class
Sitecore.Data.Serialization.ObjectModel Namespace


SyncItem Properties

[image] [image]

Sitecore 6.4.1 API
SyncItem Properties
SyncItem Class See Also Send Feedback

The SyncItem type exposes the following members.

Properties

 | Name | Description
Public property | BranchId | Gets or sets the branch id.
Public property | DatabaseName | Gets or sets the name of the database.
Public property | ID | Gets or sets the item ID.
Public property | ItemPath | Gets or sets the item path.
Public property | MasterID | Gets or sets the master ID.
Public property | Name | Gets or sets the name.
Public property | ParentID | Gets or sets the parent ID.
Public property | SharedFields | Gets the shared fields.
Public property | SharedValues | Gets the values.
Public property | TemplateID | Gets or sets the template ID.
Public property | TemplateName | Gets or sets the name of the template.
Public property | Versions | Gets the versions.

See Also

SyncItem Class
Sitecore.Data.Serialization.ObjectModel Namespace


BranchId Property

[image]

Sitecore 6.4.1 API
SyncItem..::..BranchId Property
SyncItem Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string BranchId { get; set; }
Visual Basic
Public Property BranchId As String
    Get
    Set
Visual C++
public:
property String^ BranchId {
    String^ get ();
    void set (String^ value);
}

Field Value

The branch id.

See Also

SyncItem Class
Sitecore.Data.Serialization.ObjectModel Namespace


DatabaseName Property

[image]

Sitecore 6.4.1 API
SyncItem..::..DatabaseName Property
SyncItem Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string DatabaseName { get; set; }
Visual Basic
Public Property DatabaseName As String
    Get
    Set
Visual C++
public:
property String^ DatabaseName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the database.

See Also

SyncItem Class
Sitecore.Data.Serialization.ObjectModel Namespace


ID Property

[image]

Sitecore 6.4.1 API
SyncItem..::..ID Property
SyncItem Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ID { get; set; }
Visual Basic
Public Property ID As String
    Get
    Set
Visual C++
public:
property String^ ID {
    String^ get ();
    void set (String^ value);
}

Field Value

The ID.

See Also

SyncItem Class
Sitecore.Data.Serialization.ObjectModel Namespace


ItemPath Property

[image]

Sitecore 6.4.1 API
SyncItem..::..ItemPath Property
SyncItem Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ItemPath { get; set; }
Visual Basic
Public Property ItemPath As String
    Get
    Set
Visual C++
public:
property String^ ItemPath {
    String^ get ();
    void set (String^ value);
}

Field Value

The item path.

See Also

SyncItem Class
Sitecore.Data.Serialization.ObjectModel Namespace


MasterID Property

[image]

Sitecore 6.4.1 API
SyncItem..::..MasterID Property
SyncItem Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string MasterID { get; set; }
Visual Basic
Public Property MasterID As String
    Get
    Set
Visual C++
public:
property String^ MasterID {
    String^ get ();
    void set (String^ value);
}

Field Value

The master ID.

See Also

SyncItem Class
Sitecore.Data.Serialization.ObjectModel Namespace


Name Property

[image]

Sitecore 6.4.1 API
SyncItem..::..Name Property
SyncItem Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Field Value

The name.

See Also

SyncItem Class
Sitecore.Data.Serialization.ObjectModel Namespace


ParentID Property

[image]

Sitecore 6.4.1 API
SyncItem..::..ParentID Property
SyncItem Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ParentID { get; set; }
Visual Basic
Public Property ParentID As String
    Get
    Set
Visual C++
public:
property String^ ParentID {
    String^ get ();
    void set (String^ value);
}

Field Value

The parent ID.

See Also

SyncItem Class
Sitecore.Data.Serialization.ObjectModel Namespace


SharedFields Property

[image]

Sitecore 6.4.1 API
SyncItem..::..SharedFields Property
SyncItem Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IList<SyncField> SharedFields { get; }
Visual Basic
Public ReadOnly Property SharedFields As IList(Of SyncField)
    Get
Visual C++
public:
property IList<SyncField^>^ SharedFields {
    IList<SyncField^>^ get ();
}

Field Value

The shared fields.

See Also

SyncItem Class
Sitecore.Data.Serialization.ObjectModel Namespace


TemplateID Property

[image]

Sitecore 6.4.1 API
SyncItem..::..TemplateID Property
SyncItem Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string TemplateID { get; set; }
Visual Basic
Public Property TemplateID As String
    Get
    Set
Visual C++
public:
property String^ TemplateID {
    String^ get ();
    void set (String^ value);
}

Field Value

The template ID.

See Also

SyncItem Class
Sitecore.Data.Serialization.ObjectModel Namespace


TemplateName Property

[image]

Sitecore 6.4.1 API
SyncItem..::..TemplateName Property
SyncItem Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string TemplateName { get; set; }
Visual Basic
Public Property TemplateName As String
    Get
    Set
Visual C++
public:
property String^ TemplateName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the template.

See Also

SyncItem Class
Sitecore.Data.Serialization.ObjectModel Namespace


Versions Property

[image]

Sitecore 6.4.1 API
SyncItem..::..Versions Property
SyncItem Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IList<SyncVersion> Versions { get; }
Visual Basic
Public ReadOnly Property Versions As IList(Of SyncVersion)
    Get
Visual C++
public:
property IList<SyncVersion^>^ Versions {
    IList<SyncVersion^>^ get ();
}

Field Value

The versions.

See Also

SyncItem Class
Sitecore.Data.Serialization.ObjectModel Namespace


SyncVersion Class

[image]

Sitecore 6.4.1 API
SyncVersion Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SyncVersion
Visual Basic
Public Class SyncVersion
Visual C++
public ref class SyncVersion

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Serialization.ObjectModel..::..SyncVersion

See Also

SyncVersion Members
Sitecore.Data.Serialization.ObjectModel Namespace


SyncVersion Members

[image] [image]

Sitecore 6.4.1 API
SyncVersion Members
SyncVersion Class Constructors Methods Properties See Also Send Feedback

The SyncVersion type exposes the following members.

Constructors

 | Name | Description
Public method | SyncVersion | Initializes a new instance of the SyncVersion class

Methods

 | Name | Description
Public method | AddField | Adds the field.
 | BuildVersion | Builds the version.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReadVersion | Reads the version.
Public method | RemoveField | Remove field information from the version
Public method | Serialize | Serializes vesion to the specified writer.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Fields | Gets the fields.
Public property | Language | Gets or sets the language.
Public property | Revision | Gets or sets the revision.
Public property | Values | Gets the values.
Public property | Version | Gets or sets the version.

See Also

SyncVersion Class
Sitecore.Data.Serialization.ObjectModel Namespace


SyncVersion Constructor

[image]

Sitecore 6.4.1 API
SyncVersion Constructor
SyncVersion Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SyncVersion()
Visual Basic
Public Sub New
Visual C++
public:
SyncVersion()

See Also

SyncVersion Class
Sitecore.Data.Serialization.ObjectModel Namespace


AddField Method

[image]

Sitecore 6.4.1 API
SyncVersion..::..AddField Method
SyncVersion Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SyncField AddField(
    string fieldID,
    string fieldName,
    string fieldKey,
    string fieldValue,
    bool hasValue
)
Visual Basic
Public Function AddField ( _
    fieldID As String, _
    fieldName As String, _
    fieldKey As String, _
    fieldValue As String, _
    hasValue As Boolean _
) As SyncField
Visual C++
public:
SyncField^ AddField(
    String^ fieldID,
    String^ fieldName,
    String^ fieldKey,
    String^ fieldValue,
    bool hasValue
)

Parameters

fieldID
Type: System..::..String
The field ID.
fieldName
Type: System..::..String
Name of the field.
fieldKey
Type: System..::..String
The field key.
fieldValue
Type: System..::..String
The field value.
hasValue
Type: System..::..Boolean
if set to true this instance is has value.

Return Value

The field.

See Also

SyncVersion Class
Sitecore.Data.Serialization.ObjectModel Namespace


ReadVersion Method

[image]

Sitecore 6.4.1 API
SyncVersion..::..ReadVersion Method
SyncVersion Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static SyncVersion ReadVersion(
    Tokenizer reader
)
Visual Basic
Public Shared Function ReadVersion ( _
    reader As Tokenizer _
) As SyncVersion
Visual C++
public:
static SyncVersion^ ReadVersion(
    Tokenizer^ reader
)

Parameters

reader
Type: Sitecore.Data.Serialization.ObjectModel..::..Tokenizer
The reader.

Return Value

The version.

Exceptions

Exception | Condition
System..::..Exception | Exception.

See Also

SyncVersion Class
Sitecore.Data.Serialization.ObjectModel Namespace


RemoveField Method

[image]

Sitecore 6.4.1 API
SyncVersion..::..RemoveField Method
SyncVersion Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool RemoveField(
    string fieldName
)
Visual Basic
Public Function RemoveField ( _
    fieldName As String _
) As Boolean
Visual C++
public:
bool RemoveField(
    String^ fieldName
)

Parameters

fieldName
Type: System..::..String
field name or ID

Return Value

true if field found and deleted

See Also

SyncVersion Class
Sitecore.Data.Serialization.ObjectModel Namespace


Serialize Method

[image]

Sitecore 6.4.1 API
SyncVersion..::..Serialize Method
SyncVersion Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Serialize(
    TextWriter writer
)
Visual Basic
Public Sub Serialize ( _
    writer As TextWriter _
)
Visual C++
public:
void Serialize(
    TextWriter^ writer
)

Parameters

writer
Type: System.IO..::..TextWriter
The writer.

See Also

SyncVersion Class
Sitecore.Data.Serialization.ObjectModel Namespace


SyncVersion Properties

[image] [image]

Sitecore 6.4.1 API
SyncVersion Properties
SyncVersion Class See Also Send Feedback

The SyncVersion type exposes the following members.

Properties

 | Name | Description
Public property | Fields | Gets the fields.
Public property | Language | Gets or sets the language.
Public property | Revision | Gets or sets the revision.
Public property | Values | Gets the values.
Public property | Version | Gets or sets the version.

See Also

SyncVersion Class
Sitecore.Data.Serialization.ObjectModel Namespace


Fields Property

[image]

Sitecore 6.4.1 API
SyncVersion..::..Fields Property
SyncVersion Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IList<SyncField> Fields { get; }
Visual Basic
Public ReadOnly Property Fields As IList(Of SyncField)
    Get
Visual C++
public:
property IList<SyncField^>^ Fields {
    IList<SyncField^>^ get ();
}

Field Value

The fields.

See Also

SyncVersion Class
Sitecore.Data.Serialization.ObjectModel Namespace


Language Property

[image]

Sitecore 6.4.1 API
SyncVersion..::..Language Property
SyncVersion Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Language { get; set; }
Visual Basic
Public Property Language As String
    Get
    Set
Visual C++
public:
property String^ Language {
    String^ get ();
    void set (String^ value);
}

Field Value

The language.

See Also

SyncVersion Class
Sitecore.Data.Serialization.ObjectModel Namespace


Revision Property

[image]

Sitecore 6.4.1 API
SyncVersion..::..Revision Property
SyncVersion Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Revision { get; set; }
Visual Basic
Public Property Revision As String
    Get
    Set
Visual C++
public:
property String^ Revision {
    String^ get ();
    void set (String^ value);
}

Field Value

The revision.

See Also

SyncVersion Class
Sitecore.Data.Serialization.ObjectModel Namespace


Values Property

[image]

Sitecore 6.4.1 API
SyncVersion..::..Values Property
SyncVersion Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ValuesDictionary Values { get; }
Visual Basic
Public ReadOnly Property Values As ValuesDictionary
    Get
Visual C++
public:
property ValuesDictionary^ Values {
    ValuesDictionary^ get ();
}

Field Value

The values.

See Also

SyncVersion Class
Sitecore.Data.Serialization.ObjectModel Namespace


Version Property

[image]

Sitecore 6.4.1 API
SyncVersion..::..Version Property
SyncVersion Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Version { get; set; }
Visual Basic
Public Property Version As String
    Get
    Set
Visual C++
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}

Field Value

The version.

See Also

SyncVersion Class
Sitecore.Data.Serialization.ObjectModel Namespace


Tokenizer Class

[image]

Sitecore 6.4.1 API
Tokenizer Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Tokenizer
Visual Basic
Public Class Tokenizer
Visual C++
public ref class Tokenizer

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Serialization.ObjectModel..::..Tokenizer

See Also

Tokenizer Members
Sitecore.Data.Serialization.ObjectModel Namespace


Tokenizer Members

[image] [image]

Sitecore 6.4.1 API
Tokenizer Members
Tokenizer Class Constructors Methods Properties See Also Send Feedback

The Tokenizer type exposes the following members.

Constructors

 | Name | Description
Public method | Tokenizer | Initializes a new instance of the Tokenizer class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextLine | Moves to the next line.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Line | Gets the line.
Public property | Reader | Gets the reader.

See Also

Tokenizer Class
Sitecore.Data.Serialization.ObjectModel Namespace


Tokenizer Constructor

[image]

Sitecore 6.4.1 API
Tokenizer Constructor
Tokenizer Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Tokenizer(
    TextReader reader
)
Visual Basic
Public Sub New ( _
    reader As TextReader _
)
Visual C++
public:
Tokenizer(
    TextReader^ reader
)

Parameters

reader
Type: System.IO..::..TextReader
The reader.

See Also

Tokenizer Class
Sitecore.Data.Serialization.ObjectModel Namespace


Tokenizer Methods

[image] [image]

Sitecore 6.4.1 API
Tokenizer Methods
Tokenizer Class See Also Send Feedback

The Tokenizer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextLine | Moves to the next line.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Tokenizer Class
Sitecore.Data.Serialization.ObjectModel Namespace


NextLine Method

[image]

Sitecore 6.4.1 API
Tokenizer..::..NextLine Method
Tokenizer Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string NextLine()
Visual Basic
Public Function NextLine As String
Visual C++
public:
String^ NextLine()

Return Value

The line.

See Also

Tokenizer Class
Sitecore.Data.Serialization.ObjectModel Namespace


Tokenizer Properties

[image] [image]

Sitecore 6.4.1 API
Tokenizer Properties
Tokenizer Class See Also Send Feedback

The Tokenizer type exposes the following members.

Properties

 | Name | Description
Public property | Line | Gets the line.
Public property | Reader | Gets the reader.

See Also

Tokenizer Class
Sitecore.Data.Serialization.ObjectModel Namespace


Line Property

[image]

Sitecore 6.4.1 API
Tokenizer..::..Line Property
Tokenizer Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Line { get; }
Visual Basic
Public ReadOnly Property Line As String
    Get
Visual C++
public:
property String^ Line {
    String^ get ();
}

Field Value

The line.

See Also

Tokenizer Class
Sitecore.Data.Serialization.ObjectModel Namespace


ValuesDictionary Class

[image]

Sitecore 6.4.1 API
ValuesDictionary Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ValuesDictionary
Visual Basic
Public Class ValuesDictionary
Visual C++
public ref class ValuesDictionary

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Serialization.ObjectModel..::..ValuesDictionary

See Also

ValuesDictionary Members
Sitecore.Data.Serialization.ObjectModel Namespace


ValuesDictionary Members

[image] [image]

Sitecore 6.4.1 API
ValuesDictionary Members
ValuesDictionary Class Constructors Methods Properties See Also Send Feedback

The ValuesDictionary type exposes the following members.

Constructors

 | Name | Description
Public method | ValuesDictionary(IEnumerable<(Of <<'(SyncField>)>>)) | Initializes a new instance of the ValuesDictionary class.
Public method | ValuesDictionary(SyncVersion) | Initializes a new instance of the ValuesDictionary class.

Methods

 | Name | Description
Public method | Add | Adds the specified field.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | Gets the String with the specified id.

See Also

ValuesDictionary Class
Sitecore.Data.Serialization.ObjectModel Namespace


ValuesDictionary Constructor (IEnumerable(SyncField))

[image]

Sitecore 6.4.1 API
ValuesDictionary Constructor (IEnumerable<(Of <(<'SyncField>)>)>)
ValuesDictionary Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ValuesDictionary(
    IEnumerable<SyncField> fields
)
Visual Basic
Public Sub New ( _
    fields As IEnumerable(Of SyncField) _
)
Visual C++
public:
ValuesDictionary(
    IEnumerable<SyncField^>^ fields
)

Parameters

fields
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' SyncField >)>)>
List of fields to create ValuesDictionary from

See Also

ValuesDictionary Class
ValuesDictionary Overload
Sitecore.Data.Serialization.ObjectModel Namespace


ValuesDictionary Constructor (SyncVersion)

[image]

Sitecore 6.4.1 API
ValuesDictionary Constructor (SyncVersion)
ValuesDictionary Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ValuesDictionary(
    SyncVersion version
)
Visual Basic
Public Sub New ( _
    version As SyncVersion _
)
Visual C++
public:
ValuesDictionary(
    SyncVersion^ version
)

Parameters

version
Type: Sitecore.Data.Serialization.ObjectModel..::..SyncVersion
The version.

See Also

ValuesDictionary Class
ValuesDictionary Overload
Sitecore.Data.Serialization.ObjectModel Namespace


ValuesDictionary Methods

[image] [image]

Sitecore 6.4.1 API
ValuesDictionary Methods
ValuesDictionary Class See Also Send Feedback

The ValuesDictionary type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified field.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ValuesDictionary Class
Sitecore.Data.Serialization.ObjectModel Namespace


Add Method

[image]

Sitecore 6.4.1 API
ValuesDictionary..::..Add Method
ValuesDictionary Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Add(
    SyncField field
)
Visual Basic
Public Sub Add ( _
    field As SyncField _
)
Visual C++
public:
void Add(
    SyncField^ field
)

Parameters

field
Type: Sitecore.Data.Serialization.ObjectModel..::..SyncField
The field.

See Also

ValuesDictionary Class
Sitecore.Data.Serialization.ObjectModel Namespace


ValuesDictionary Properties

[image] [image]

Sitecore 6.4.1 API
ValuesDictionary Properties
ValuesDictionary Class See Also Send Feedback

The ValuesDictionary type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets the String with the specified id.

See Also

ValuesDictionary Class
Sitecore.Data.Serialization.ObjectModel Namespace


Item Property

[image]

Sitecore 6.4.1 API
ValuesDictionary..::..Item Property
ValuesDictionary Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.ObjectModel
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string this[
    string id
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    id As String _
) As String
    Get
Visual C++
public:
property String^ default[String^ id] {
    String^ get (String^ id);
}

Parameters

id
Type: System..::..String

Field Value

The String.

See Also

ValuesDictionary Class
Sitecore.Data.Serialization.ObjectModel Namespace


Sitecore.Data.Serialization.Presets Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Data.Serialization.Presets Namespace
Send Feedback

Classes

 | Class | Description
Public class | ExcludeEntry | Description of ExcludeEntry.
Public class | IncludeEntry | Description of IncludeEntry.
Public class | PresetFactory | Creates Interation entries from XML confguration;

Delegates

 | Delegate | Description
Public delegate | ItemCallback | Item handling callback.


ExcludeEntry Class

[image]

Sitecore 6.4.1 API
ExcludeEntry Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Serialization.Presets
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ExcludeEntry
Visual Basic
Public Class ExcludeEntry
Visual C++
public ref class ExcludeEntry

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Serialization.Presets..::..ExcludeEntry

See Also

ExcludeEntry Members
Sitecore.Data.Serialization.Presets Namespace


ExcludeEntry Constructor

[image] [image]

Sitecore 6.4.1 API
ExcludeEntry Constructor
ExcludeEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExcludeEntry()()()() | Creates a new instance of ExcludeEntry.
Public method | ExcludeEntry(String, String) | Creates a new instance of ExcludeEntry

See Also

ExcludeEntry Class
ExcludeEntry Members
Sitecore.Data.Serialization.Presets Namespace


ExcludeEntry Constructor

[image]

Sitecore 6.4.1 API
ExcludeEntry Constructor
ExcludeEntry Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.Presets
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ExcludeEntry()
Visual Basic
Public Sub New
Visual C++
public:
ExcludeEntry()

See Also

ExcludeEntry Class
ExcludeEntry Overload
Sitecore.Data.Serialization.Presets Namespace


ExcludeEntry Constructor (String, String)

[image]

Sitecore 6.4.1 API
ExcludeEntry Constructor (String, String)
ExcludeEntry Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.Presets
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ExcludeEntry(
    string type,
    string value
)
Visual Basic
Public Sub New ( _
    type As String, _
    value As String _
)
Visual C++
public:
ExcludeEntry(
    String^ type,
    String^ value
)

Parameters

type
Type: System..::..String

[Missing <param name="type"/> documentation for "M:Sitecore.Data.Serialization.Presets.ExcludeEntry.#ctor(System.String,System.String)"]

value
Type: System..::..String

[Missing <param name="value"/> documentation for "M:Sitecore.Data.Serialization.Presets.ExcludeEntry.#ctor(System.String,System.String)"]

See Also

ExcludeEntry Class
ExcludeEntry Overload
Sitecore.Data.Serialization.Presets Namespace


ExcludeEntry Methods

[image] [image]

Sitecore 6.4.1 API
ExcludeEntry Methods
ExcludeEntry Class See Also Send Feedback

The ExcludeEntry type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Matches | Checks whether exclude criterium matches the specified item.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExcludeEntry Class
Sitecore.Data.Serialization.Presets Namespace


Matches Method

[image]

Sitecore 6.4.1 API
ExcludeEntry..::..Matches Method
ExcludeEntry Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.Presets
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Matches(
    Item item
)
Visual Basic
Public Function Matches ( _
    item As Item _
) As Boolean
Visual C++
public:
bool Matches(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item

[Missing <param name="item"/> documentation for "M:Sitecore.Data.Serialization.Presets.ExcludeEntry.Matches(Sitecore.Data.Items.Item)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Serialization.Presets.ExcludeEntry.Matches(Sitecore.Data.Items.Item)"]

See Also

ExcludeEntry Class
Sitecore.Data.Serialization.Presets Namespace


ExcludeEntry Properties

[image] [image]

Sitecore 6.4.1 API
ExcludeEntry Properties
ExcludeEntry Class See Also Send Feedback

The ExcludeEntry type exposes the following members.

Properties

 | Name | Description
Public property | Include | List of overriding includes
Public property | Type | Sets or gets the type of this exclude entry.
Public property | Value | Value to match against

See Also

ExcludeEntry Class
Sitecore.Data.Serialization.Presets Namespace


Include Property

[image]

Sitecore 6.4.1 API
ExcludeEntry..::..Include Property
ExcludeEntry Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.Presets
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public List<IncludeEntry> Include { get; }
Visual Basic
Public ReadOnly Property Include As List(Of IncludeEntry)
    Get
Visual C++
public:
property List<IncludeEntry^>^ Include {
    List<IncludeEntry^>^ get ();
}

See Also

ExcludeEntry Class
Sitecore.Data.Serialization.Presets Namespace


Type Property

[image]

Sitecore 6.4.1 API
ExcludeEntry..::..Type Property
ExcludeEntry Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.Presets
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Type { get; set; }
Visual Basic
Public Property Type As String
    Get
    Set
Visual C++
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}

See Also

ExcludeEntry Class
Sitecore.Data.Serialization.Presets Namespace


Value Property

[image]

Sitecore 6.4.1 API
ExcludeEntry..::..Value Property
ExcludeEntry Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.Presets
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

See Also

ExcludeEntry Class
Sitecore.Data.Serialization.Presets Namespace


IncludeEntry Class

[image]

Sitecore 6.4.1 API
IncludeEntry Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Serialization.Presets
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class IncludeEntry
Visual Basic
Public Class IncludeEntry
Visual C++
public ref class IncludeEntry

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Serialization.Presets..::..IncludeEntry

See Also

IncludeEntry Members
Sitecore.Data.Serialization.Presets Namespace


IncludeEntry Members

[image] [image]

Sitecore 6.4.1 API
IncludeEntry Members
IncludeEntry Class Constructors Methods Properties See Also Send Feedback

The IncludeEntry type exposes the following members.

Constructors

 | Name | Description
Public method | IncludeEntry()()()() | Creates a new instance of IncludeEntry.
Public method | IncludeEntry(String) | Creates a new instance of IncludeEntry.
Public method | IncludeEntry(String, String) | Creates a new instance of IncludeEntry.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process(ItemCallback) | Invokes specified callback on all items
Public method | Process(ItemCallback, IncludeEntry) |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Database | Name of the database to get items in.
Public property | Exclude | List of exclusion criteria. Recursion stops at excluded items.
Public property | Path | Path to the root item.
Public property | Skip | List of skip criteria. Descendants are iterated bu the item itself i

See Also

IncludeEntry Class
Sitecore.Data.Serialization.Presets Namespace


IncludeEntry Constructor

[image] [image]

Sitecore 6.4.1 API
IncludeEntry Constructor
IncludeEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IncludeEntry()()()() | Creates a new instance of IncludeEntry.
Public method | IncludeEntry(String) | Creates a new instance of IncludeEntry.
Public method | IncludeEntry(String, String) | Creates a new instance of IncludeEntry.

See Also

IncludeEntry Class
IncludeEntry Members
Sitecore.Data.Serialization.Presets Namespace


IncludeEntry Constructor

[image]

Sitecore 6.4.1 API
IncludeEntry Constructor
IncludeEntry Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.Presets
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IncludeEntry()
Visual Basic
Public Sub New
Visual C++
public:
IncludeEntry()

See Also

IncludeEntry Class
IncludeEntry Overload
Sitecore.Data.Serialization.Presets Namespace


IncludeEntry Constructor (String)

[image]

Sitecore 6.4.1 API
IncludeEntry Constructor (String)
IncludeEntry Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.Presets
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IncludeEntry(
    string path
)
Visual Basic
Public Sub New ( _
    path As String _
)
Visual C++
public:
IncludeEntry(
    String^ path
)

Parameters

path
Type: System..::..String
Path to the root item to iterate.

See Also

IncludeEntry Class
IncludeEntry Overload
Sitecore.Data.Serialization.Presets Namespace


IncludeEntry Constructor (String, String)

[image]

Sitecore 6.4.1 API
IncludeEntry Constructor (String, String)
IncludeEntry Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.Presets
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IncludeEntry(
    string database,
    string path
)
Visual Basic
Public Sub New ( _
    database As String, _
    path As String _
)
Visual C++
public:
IncludeEntry(
    String^ database,
    String^ path
)

Parameters

database
Type: System..::..String
Name of the database.
path
Type: System..::..String
Path to the root item to iterate.

See Also

IncludeEntry Class
IncludeEntry Overload
Sitecore.Data.Serialization.Presets Namespace


IncludeEntry Methods

[image] [image]

Sitecore 6.4.1 API
IncludeEntry Methods
IncludeEntry Class See Also Send Feedback

The IncludeEntry type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process(ItemCallback) | Invokes specified callback on all items
Public method | Process(ItemCallback, IncludeEntry) |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IncludeEntry Class
Sitecore.Data.Serialization.Presets Namespace


Process Method

[image] [image]

Sitecore 6.4.1 API
IncludeEntry..::..Process Method
IncludeEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Process(ItemCallback) | Invokes specified callback on all items
Public method | Process(ItemCallback, IncludeEntry) |

See Also

IncludeEntry Class
IncludeEntry Members
Sitecore.Data.Serialization.Presets Namespace


Process Method (ItemCallback)

[image]

Sitecore 6.4.1 API
IncludeEntry..::..Process Method (ItemCallback)
IncludeEntry Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.Presets
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    ItemCallback callback
)
Visual Basic
Public Sub Process ( _
    callback As ItemCallback _
)
Visual C++
public:
void Process(
    ItemCallback^ callback
)

Parameters

callback
Type: Sitecore.Data.Serialization.Presets..::..ItemCallback

[Missing <param name="callback"/> documentation for "M:Sitecore.Data.Serialization.Presets.IncludeEntry.Process(Sitecore.Data.Serialization.Presets.ItemCallback)"]

See Also

IncludeEntry Class
Process Overload
Sitecore.Data.Serialization.Presets Namespace


Process Method (ItemCallback, IncludeEntry)

[image]

Sitecore 6.4.1 API
IncludeEntry..::..Process Method (ItemCallback, IncludeEntry)
IncludeEntry Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.Presets
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    ItemCallback callback,
    IncludeEntry parent
)
Visual Basic
Public Sub Process ( _
    callback As ItemCallback, _
    parent As IncludeEntry _
)
Visual C++
public:
void Process(
    ItemCallback^ callback,
    IncludeEntry^ parent
)

Parameters

callback
Type: Sitecore.Data.Serialization.Presets..::..ItemCallback

[Missing <param name="callback"/> documentation for "M:Sitecore.Data.Serialization.Presets.IncludeEntry.Process(Sitecore.Data.Serialization.Presets.ItemCallback,Sitecore.Data.Serialization.Presets.IncludeEntry)"]

parent
Type: Sitecore.Data.Serialization.Presets..::..IncludeEntry

[Missing <param name="parent"/> documentation for "M:Sitecore.Data.Serialization.Presets.IncludeEntry.Process(Sitecore.Data.Serialization.Presets.ItemCallback,Sitecore.Data.Serialization.Presets.IncludeEntry)"]

See Also

IncludeEntry Class
Process Overload
Sitecore.Data.Serialization.Presets Namespace


IncludeEntry Properties

[image] [image]

Sitecore 6.4.1 API
IncludeEntry Properties
IncludeEntry Class See Also Send Feedback

The IncludeEntry type exposes the following members.

Properties

 | Name | Description
Public property | Database | Name of the database to get items in.
Public property | Exclude | List of exclusion criteria. Recursion stops at excluded items.
Public property | Path | Path to the root item.
Public property | Skip | List of skip criteria. Descendants are iterated bu the item itself i

See Also

IncludeEntry Class
Sitecore.Data.Serialization.Presets Namespace


Database Property

[image]

Sitecore 6.4.1 API
IncludeEntry..::..Database Property
IncludeEntry Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.Presets
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Database { get; set; }
Visual Basic
Public Property Database As String
    Get
    Set
Visual C++
public:
property String^ Database {
    String^ get ();
    void set (String^ value);
}

See Also

IncludeEntry Class
Sitecore.Data.Serialization.Presets Namespace


Exclude Property

[image]

Sitecore 6.4.1 API
IncludeEntry..::..Exclude Property
IncludeEntry Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.Presets
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public List<ExcludeEntry> Exclude { get; }
Visual Basic
Public ReadOnly Property Exclude As List(Of ExcludeEntry)
    Get
Visual C++
public:
property List<ExcludeEntry^>^ Exclude {
    List<ExcludeEntry^>^ get ();
}

See Also

IncludeEntry Class
Sitecore.Data.Serialization.Presets Namespace


Path Property

[image]

Sitecore 6.4.1 API
IncludeEntry..::..Path Property
IncludeEntry Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.Presets
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Path { get; set; }
Visual Basic
Public Property Path As String
    Get
    Set
Visual C++
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}

See Also

IncludeEntry Class
Sitecore.Data.Serialization.Presets Namespace


Skip Property

[image]

Sitecore 6.4.1 API
IncludeEntry..::..Skip Property
IncludeEntry Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.Presets
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public List<ExcludeEntry> Skip { get; }
Visual Basic
Public ReadOnly Property Skip As List(Of ExcludeEntry)
    Get
Visual C++
public:
property List<ExcludeEntry^>^ Skip {
    List<ExcludeEntry^>^ get ();
}

See Also

IncludeEntry Class
Sitecore.Data.Serialization.Presets Namespace


ItemCallback Delegate

[image]

Sitecore 6.4.1 API
ItemCallback Delegate
See Also Send Feedback

Namespace: Sitecore.Data.Serialization.Presets
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public delegate void ItemCallback(
    Item item
)
Visual Basic
Public Delegate Sub ItemCallback ( _
    item As Item _
)
Visual C++
public delegate void ItemCallback(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item

See Also

Sitecore.Data.Serialization.Presets Namespace


PresetFactory Class

[image]

Sitecore 6.4.1 API
PresetFactory Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Serialization.Presets
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class PresetFactory
Visual Basic
Public NotInheritable Class PresetFactory
Visual C++
public ref class PresetFactory abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Serialization.Presets..::..PresetFactory

See Also

PresetFactory Members
Sitecore.Data.Serialization.Presets Namespace


PresetFactory Members

[image] [image]

Sitecore 6.4.1 API
PresetFactory Members
PresetFactory Class Methods See Also Send Feedback

The PresetFactory type exposes the following members.

Methods

Name | Description
Create | Creates a list of IncludeEntries from XML configuration

See Also

PresetFactory Class
Sitecore.Data.Serialization.Presets Namespace


Create Method

[image]

Sitecore 6.4.1 API
PresetFactory..::..Create Method
PresetFactory Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.Presets
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static IList<IncludeEntry> Create(
    XmlNode configuration
)
Visual Basic
Public Shared Function Create ( _
    configuration As XmlNode _
) As IList(Of IncludeEntry)
Visual C++
public:
static IList<IncludeEntry^>^ Create(
    XmlNode^ configuration
)

Parameters

configuration
Type: System.Xml..::..XmlNode

[Missing <param name="configuration"/> documentation for "M:Sitecore.Data.Serialization.Presets.PresetFactory.Create(System.Xml.XmlNode)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Serialization.Presets.PresetFactory.Create(System.Xml.XmlNode)"]

See Also

PresetFactory Class
Sitecore.Data.Serialization.Presets Namespace


SerializationTemplateProvider Class

[image]

Sitecore 6.4.1 API
SerializationTemplateProvider Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Serialization.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SerializationTemplateProvider : DataProvider
Visual Basic
Public Class SerializationTemplateProvider _
    Inherits DataProvider
Visual C++
public ref class SerializationTemplateProvider : public DataProvider

Inheritance Hierarchy

System..::..Object
Sitecore.Data.DataProviders..::..DataProvider
Sitecore.Data.Serialization.Templates..::..SerializationTemplateProvider

See Also

SerializationTemplateProvider Members
Sitecore.Data.Serialization.Templates Namespace


SerializationTemplateProvider Members

[image] [image]

Sitecore 6.4.1 API
SerializationTemplateProvider Members
SerializationTemplateProvider Class Constructors Methods Properties See Also Send Feedback

The SerializationTemplateProvider type exposes the following members.

Constructors

 | Name | Description
Public method | SerializationTemplateProvider | Create SyncTemplateManager

Methods

 | Name | Description
 | AddField | Add field to the template section
 | AddSection | Add section to template
Public method | AddToPublishQueue | Adds an item to the publish queue. (Inherited from DataProvider.)
Public method | AddVersion | Adds a version to an item. (Inherited from DataProvider.)
Public method | BlobStreamExists | Determines whether the specified field contains a BLOB value. (Inherited from DataProvider.)
Public method | ChangeFieldSharing | Changes the type of field sharing for a single field. (Inherited from DataProvider.)
Public method | ChangeTemplate | Changes the template of an item. (Inherited from DataProvider.)
Public method | CleanupDatabase | Cleans up the database. (Inherited from DataProvider.)
Public method | CleanupPublishQueue | Cleans up the publish queue. (Inherited from DataProvider.)
Public method | CopyItem | Copies an item. (Inherited from DataProvider.)
Public method | CreateItem | Creates a item. (Inherited from DataProvider.)
Public method | DeleteItem | Deletes an item. (Inherited from DataProvider.)
 | DoLoadTemplates | Recursively load templates from ISync dump tree
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBlobStream | Gets the BLOB stream associated with a field. (Inherited from DataProvider.)
Public method | GetChildIDs | Gets the child ids of an item. (Inherited from DataProvider.)
Public method | GetDataSize | Gets the size of the data managed by the provider. (Inherited from DataProvider.)
Public method | GetDictionaryEntryCount | Gets the number of dictionary entries. (Inherited from DataProvider.)
 | GetDirectoryPath | Helper method to retrieve correct directory path for item
Public method | GetEventQueue | Gets the event queue driver. (Inherited from DataProvider.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemDefinition | Gets the definition of an item. (Inherited from DataProvider.)
Public method | GetItemFields | Gets the fields of a specific item version. (Inherited from DataProvider.)
Public method | GetItemsInWorkflowState | Gets all items that are in a specific workflow state. (Inherited from DataProvider.)
Public method | GetItemVersions | Gets a list of the available versions of an item. (Inherited from DataProvider.)
Public method | GetLanguages | Gets a list of all the language that have been defined in the database. (Inherited from DataProvider.)
Public method | GetParentID | Gets the parent ID of an item. (Inherited from DataProvider.)
Public method | GetProperty | Gets a property. (Inherited from DataProvider.)
Public method | GetPropertyKeys | Gets a list of property keys matching a specific prefix. (Inherited from DataProvider.)
Public method | GetPublishQueue | Gets the publish queue. (Inherited from DataProvider.)
Public method | GetRootID | Gets the root ID. (Inherited from DataProvider.)
Public method | GetTemplateItemIds | Gets the template item ids. (Inherited from DataProvider.)
Public method | GetTemplates | Get templates from ISync tree (Overrides DataProvider..::..GetTemplates(CallContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWorkflowInfo | Gets the workflow info form an item. (Inherited from DataProvider.)
Public method | HasChildren | Determines whether the specified item definition has children. (Inherited from DataProvider.)
Public method | IsEnabled | Determines whether the specified method is enabled. (Inherited from DataProvider.)
 | LoadOneLevel | Load SyncItems from 1 level of ISync tree
 | LoadTemplatesFromTree | Load templates from ISync dump tree
 | LoadTemplatesFromXmlFile | Load templates from templates.xml file
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveItem | Moves an item (ie. changes its parent). (Inherited from DataProvider.)
Public method | RemoveLanguageData | Removes a language and all the data using the language from the database. (Inherited from DataProvider.)
Public method | RemoveProperty | Removes a property. (Inherited from DataProvider.)
Public method | RemoveVersion | Removes a version from an item. (Inherited from DataProvider.)
Public method | RemoveVersions(ItemDefinition, Language, CallContext) | Removes versions from an item. (Inherited from DataProvider.)
Public method | RemoveVersions(ItemDefinition, Language, Boolean, CallContext) | Removes versions from an item. (Inherited from DataProvider.)
Public method | RenameLanguageData | Renames a language binding. (Inherited from DataProvider.)
Public method | ResolvePath | Resolves the path. (Inherited from DataProvider.)
Public method | SaveItem | Saves an item. (Inherited from DataProvider.)
Public method | SelectIDs | Selects a set of ids. (Inherited from DataProvider.)
Public method | SelectSingleID | Selects a single ID. (Inherited from DataProvider.)
Public method | SetBlobStream | Sets the BLOB stream associated with a field. (Inherited from DataProvider.)
Public method | SetProperty | Sets a property. (Inherited from DataProvider.)
Public method | SetWorkflowInfo | Sets the workflow info for an item. (Inherited from DataProvider.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CacheOptions | Gets the cache options. (Inherited from DataProvider.)
Public property | Database | Gets the database. (Inherited from DataProvider.)
Protected property | Disable | Disables a method. (Inherited from DataProvider.)
Protected property | DisableGroup | Disables a group. (Inherited from DataProvider.)
Protected property | Enable | Enables a method. (Inherited from DataProvider.)
Protected property | EnableGroup | Enables a group. (Inherited from DataProvider.)

See Also

SerializationTemplateProvider Class
Sitecore.Data.Serialization.Templates Namespace


SerializationTemplateProvider Methods

[image] [image]

Sitecore 6.4.1 API
SerializationTemplateProvider Methods
SerializationTemplateProvider Class See Also Send Feedback

The SerializationTemplateProvider type exposes the following members.

Methods

 | Name | Description
 | AddField | Add field to the template section
 | AddSection | Add section to template
Public method | AddToPublishQueue | Adds an item to the publish queue. (Inherited from DataProvider.)
Public method | AddVersion | Adds a version to an item. (Inherited from DataProvider.)
Public method | BlobStreamExists | Determines whether the specified field contains a BLOB value. (Inherited from DataProvider.)
Public method | ChangeFieldSharing | Changes the type of field sharing for a single field. (Inherited from DataProvider.)
Public method | ChangeTemplate | Changes the template of an item. (Inherited from DataProvider.)
Public method | CleanupDatabase | Cleans up the database. (Inherited from DataProvider.)
Public method | CleanupPublishQueue | Cleans up the publish queue. (Inherited from DataProvider.)
Public method | CopyItem | Copies an item. (Inherited from DataProvider.)
Public method | CreateItem | Creates a item. (Inherited from DataProvider.)
Public method | DeleteItem | Deletes an item. (Inherited from DataProvider.)
 | DoLoadTemplates | Recursively load templates from ISync dump tree
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBlobStream | Gets the BLOB stream associated with a field. (Inherited from DataProvider.)
Public method | GetChildIDs | Gets the child ids of an item. (Inherited from DataProvider.)
Public method | GetDataSize | Gets the size of the data managed by the provider. (Inherited from DataProvider.)
Public method | GetDictionaryEntryCount | Gets the number of dictionary entries. (Inherited from DataProvider.)
 | GetDirectoryPath | Helper method to retrieve correct directory path for item
Public method | GetEventQueue | Gets the event queue driver. (Inherited from DataProvider.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemDefinition | Gets the definition of an item. (Inherited from DataProvider.)
Public method | GetItemFields | Gets the fields of a specific item version. (Inherited from DataProvider.)
Public method | GetItemsInWorkflowState | Gets all items that are in a specific workflow state. (Inherited from DataProvider.)
Public method | GetItemVersions | Gets a list of the available versions of an item. (Inherited from DataProvider.)
Public method | GetLanguages | Gets a list of all the language that have been defined in the database. (Inherited from DataProvider.)
Public method | GetParentID | Gets the parent ID of an item. (Inherited from DataProvider.)
Public method | GetProperty | Gets a property. (Inherited from DataProvider.)
Public method | GetPropertyKeys | Gets a list of property keys matching a specific prefix. (Inherited from DataProvider.)
Public method | GetPublishQueue | Gets the publish queue. (Inherited from DataProvider.)
Public method | GetRootID | Gets the root ID. (Inherited from DataProvider.)
Public method | GetTemplateItemIds | Gets the template item ids. (Inherited from DataProvider.)
Public method | GetTemplates | Get templates from ISync tree (Overrides DataProvider..::..GetTemplates(CallContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWorkflowInfo | Gets the workflow info form an item. (Inherited from DataProvider.)
Public method | HasChildren | Determines whether the specified item definition has children. (Inherited from DataProvider.)
Public method | IsEnabled | Determines whether the specified method is enabled. (Inherited from DataProvider.)
 | LoadOneLevel | Load SyncItems from 1 level of ISync tree
 | LoadTemplatesFromTree | Load templates from ISync dump tree
 | LoadTemplatesFromXmlFile | Load templates from templates.xml file
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveItem | Moves an item (ie. changes its parent). (Inherited from DataProvider.)
Public method | RemoveLanguageData | Removes a language and all the data using the language from the database. (Inherited from DataProvider.)
Public method | RemoveProperty | Removes a property. (Inherited from DataProvider.)
Public method | RemoveVersion | Removes a version from an item. (Inherited from DataProvider.)
Public method | RemoveVersions(ItemDefinition, Language, CallContext) | Removes versions from an item. (Inherited from DataProvider.)
Public method | RemoveVersions(ItemDefinition, Language, Boolean, CallContext) | Removes versions from an item. (Inherited from DataProvider.)
Public method | RenameLanguageData | Renames a language binding. (Inherited from DataProvider.)
Public method | ResolvePath | Resolves the path. (Inherited from DataProvider.)
Public method | SaveItem | Saves an item. (Inherited from DataProvider.)
Public method | SelectIDs | Selects a set of ids. (Inherited from DataProvider.)
Public method | SelectSingleID | Selects a single ID. (Inherited from DataProvider.)
Public method | SetBlobStream | Sets the BLOB stream associated with a field. (Inherited from DataProvider.)
Public method | SetProperty | Sets a property. (Inherited from DataProvider.)
Public method | SetWorkflowInfo | Sets the workflow info for an item. (Inherited from DataProvider.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SerializationTemplateProvider Class
Sitecore.Data.Serialization.Templates Namespace


AddField Method

[image]

Sitecore 6.4.1 API
SerializationTemplateProvider..::..AddField Method
SerializationTemplateProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected static void AddField(
    TemplateSection..::..Builder sectionBuilder,
    SyncItem item
)
Visual Basic
Protected Shared Sub AddField ( _
    sectionBuilder As TemplateSection..::..Builder, _
    item As SyncItem _
)
Visual C++
protected:
static void AddField(
    TemplateSection..::..Builder^ sectionBuilder,
    SyncItem^ item
)

Parameters

sectionBuilder
Type: Sitecore.Data.Templates..::..TemplateSection..::..Builder
Section to add field to
item
Type: Sitecore.Data.Serialization.ObjectModel..::..SyncItem
SyncItem represent TemplateField

See Also

SerializationTemplateProvider Class
Sitecore.Data.Serialization.Templates Namespace


AddSection Method

[image]

Sitecore 6.4.1 API
SerializationTemplateProvider..::..AddSection Method
SerializationTemplateProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected static void AddSection(
    Template..::..Builder template,
    SyncItem item,
    LoadOptions options
)
Visual Basic
Protected Shared Sub AddSection ( _
    template As Template..::..Builder, _
    item As SyncItem, _
    options As LoadOptions _
)
Visual C++
protected:
static void AddSection(
    Template..::..Builder^ template,
    SyncItem^ item,
    LoadOptions^ options
)

Parameters

template
Type: Sitecore.Data.Templates..::..Template..::..Builder
Template to add section to
item
Type: Sitecore.Data.Serialization.ObjectModel..::..SyncItem
SyncItem represent Section
options
Type: Sitecore.Data.Serialization..::..LoadOptions
Used to pass root

See Also

SerializationTemplateProvider Class
Sitecore.Data.Serialization.Templates Namespace


DoLoadTemplates Method

[image]

Sitecore 6.4.1 API
SerializationTemplateProvider..::..DoLoadTemplates Method
SerializationTemplateProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected static void DoLoadTemplates(
    string path,
    LoadOptions options,
    TemplateCollection templates
)
Visual Basic
Protected Shared Sub DoLoadTemplates ( _
    path As String, _
    options As LoadOptions, _
    templates As TemplateCollection _
)
Visual C++
protected:
static void DoLoadTemplates(
    String^ path,
    LoadOptions^ options,
    TemplateCollection^ templates
)

Parameters

path
Type: System..::..String
Path to the folder to load templates from
options
Type: Sitecore.Data.Serialization..::..LoadOptions
Option to pass database root path
templates
Type: Sitecore.Data.Templates..::..TemplateCollection
TemplateCollection to be filled

See Also

SerializationTemplateProvider Class
Sitecore.Data.Serialization.Templates Namespace


GetDirectoryPath Method

[image]

Sitecore 6.4.1 API
SerializationTemplateProvider..::..GetDirectoryPath Method
SerializationTemplateProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected static string GetDirectoryPath(
    SyncItem item,
    LoadOptions options
)
Visual Basic
Protected Shared Function GetDirectoryPath ( _
    item As SyncItem, _
    options As LoadOptions _
) As String
Visual C++
protected:
static String^ GetDirectoryPath(
    SyncItem^ item,
    LoadOptions^ options
)

Parameters

item
Type: Sitecore.Data.Serialization.ObjectModel..::..SyncItem
item to retrieve path from
options
Type: Sitecore.Data.Serialization..::..LoadOptions
used to pass root

Return Value

Directory path

See Also

SerializationTemplateProvider Class
Sitecore.Data.Serialization.Templates Namespace


GetTemplates Method

[image]

Sitecore 6.4.1 API
SerializationTemplateProvider..::..GetTemplates Method
SerializationTemplateProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override TemplateCollection GetTemplates(
    CallContext context
)
Visual Basic
Public Overrides Function GetTemplates ( _
    context As CallContext _
) As TemplateCollection
Visual C++
public:
virtual TemplateCollection^ GetTemplates(
    CallContext^ context
) override

Parameters

context
Type: Sitecore.Data.DataProviders..::..CallContext
not used

Return Value

Loaded templates

See Also

SerializationTemplateProvider Class
Sitecore.Data.Serialization.Templates Namespace


LoadOneLevel Method

[image]

Sitecore 6.4.1 API
SerializationTemplateProvider..::..LoadOneLevel Method
SerializationTemplateProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected static IList<SyncItem> LoadOneLevel(
    string path
)
Visual Basic
Protected Shared Function LoadOneLevel ( _
    path As String _
) As IList(Of SyncItem)
Visual C++
protected:
static IList<SyncItem^>^ LoadOneLevel(
    String^ path
)

Parameters

path
Type: System..::..String
Path to load SyncItems from

Return Value

List of SyncItems

See Also

SerializationTemplateProvider Class
Sitecore.Data.Serialization.Templates Namespace


LoadTemplatesFromTree Method

[image]

Sitecore 6.4.1 API
SerializationTemplateProvider..::..LoadTemplatesFromTree Method
SerializationTemplateProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void LoadTemplatesFromTree(
    string path,
    TemplateCollection templates
)
Visual Basic
Public Shared Sub LoadTemplatesFromTree ( _
    path As String, _
    templates As TemplateCollection _
)
Visual C++
public:
static void LoadTemplatesFromTree(
    String^ path,
    TemplateCollection^ templates
)

Parameters

path
Type: System..::..String
Root of the database dump
templates
Type: Sitecore.Data.Templates..::..TemplateCollection
TemplateCollection to be filled

See Also

SerializationTemplateProvider Class
Sitecore.Data.Serialization.Templates Namespace


LoadTemplatesFromXmlFile Method

[image]

Sitecore 6.4.1 API
SerializationTemplateProvider..::..LoadTemplatesFromXmlFile Method
SerializationTemplateProvider Class See Also Send Feedback

Namespace: Sitecore.Data.Serialization.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool LoadTemplatesFromXmlFile(
    string path,
    TemplateCollection templates
)
Visual Basic
Public Shared Function LoadTemplatesFromXmlFile ( _
    path As String, _
    templates As TemplateCollection _
) As Boolean
Visual C++
public:
static bool LoadTemplatesFromXmlFile(
    String^ path,
    TemplateCollection^ templates
)

Parameters

path
Type: System..::..String
Database root
templates
Type: Sitecore.Data.Templates..::..TemplateCollection
Collection to be filled

Return Value

true - in case of success

See Also

SerializationTemplateProvider Class
Sitecore.Data.Serialization.Templates Namespace


RemoveVersions Method

[image] [image]

Sitecore 6.4.1 API
SerializationTemplateProvider..::..RemoveVersions Method
SerializationTemplateProvider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveVersions(ItemDefinition, Language, CallContext) | Removes versions from an item. (Inherited from DataProvider.)
Public method | RemoveVersions(ItemDefinition, Language, Boolean, CallContext) | Removes versions from an item. (Inherited from DataProvider.)

See Also

SerializationTemplateProvider Class
SerializationTemplateProvider Members
Sitecore.Data.Serialization.Templates Namespace


SerializationTemplateProvider Properties

[image] [image]

Sitecore 6.4.1 API
SerializationTemplateProvider Properties
SerializationTemplateProvider Class See Also Send Feedback

The SerializationTemplateProvider type exposes the following members.

Properties

 | Name | Description
Public property | CacheOptions | Gets the cache options. (Inherited from DataProvider.)
Public property | Database | Gets the database. (Inherited from DataProvider.)
Protected property | Disable | Disables a method. (Inherited from DataProvider.)
Protected property | DisableGroup | Disables a group. (Inherited from DataProvider.)
Protected property | Enable | Enables a method. (Inherited from DataProvider.)
Protected property | EnableGroup | Enables a group. (Inherited from DataProvider.)

See Also

SerializationTemplateProvider Class
Sitecore.Data.Serialization.Templates Namespace


Sitecore.Data.Sql Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Data.Sql Namespace
Send Feedback

Classes

 | Class | Description
Public class | SqlBatch | Contructs and executes a series of SQL statements.
Public class | SqlBuilder | Implements a utility class for handling and executing SQL statements.
Public class | SqlUtil | Implements a utility class for handling and executing SQL statements.

Enumerations

 | Enumeration | Description
Public enumeration | SqlStatementType | Defines SQL statement types.


SqlBatch Members

[image] [image]

Sitecore 6.4.1 API
SqlBatch Members
SqlBatch Class Constructors Methods Properties See Also Send Feedback

The SqlBatch type exposes the following members.

Constructors

 | Name | Description
Public method | SqlBatch | Creates a new SqlBatch instance.

Methods

 | Name | Description
Public method | AddArgument | Adds an argument.
Public method | AddBreak | Adds a line break to the text.
Public method | AddParameter(String, Object) | Adds a parameter.
Public method | AddParameter(String, Object, Boolean) | Adds a parameter.
Public method | AddSql | Adds an SQL string.
Public method | AddVariable | Adds a variable.
Public method | AddVariableParameter | Adds a variable parameter.
Public method | EndFunctionCall | Ends a function call.
Public method | EndIf | Ends an if statement.
Public method | EndProcedureCall | Ends a procedure call.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the SQL batch.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartFunctionCall | Starts a function call.
Public method | StartIf | Starts an if statment.
Public method | StartProcedureCall | Starts a procedure call.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | Parameters | Gets the parameters.
Public property | Text | Gets the SQL text.
Public property | Timeout | Gets or sets the timeout.
Public property | UseTransaction | Gets a value indicating whether to use transactions.

See Also

SqlBatch Class
Sitecore.Data.Sql Namespace


SqlBatch Constructor

[image]

Sitecore 6.4.1 API
SqlBatch Constructor
SqlBatch Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlBatch(
    bool useTransaction
)
Visual Basic
Public Sub New ( _
    useTransaction As Boolean _
)
Visual C++
public:
SqlBatch(
    bool useTransaction
)

Parameters

useTransaction
Type: System..::..Boolean
Use transaction.

See Also

SqlBatch Class
Sitecore.Data.Sql Namespace


AddArgument Method

[image]

Sitecore 6.4.1 API
SqlBatch..::..AddArgument Method
SqlBatch Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string AddArgument(
    string name,
    Object value,
    bool sharedName
)
Visual Basic
Public Function AddArgument ( _
    name As String, _
    value As Object, _
    sharedName As Boolean _
) As String
Visual C++
public:
String^ AddArgument(
    String^ name,
    Object^ value,
    bool sharedName
)

Parameters

name
Type: System..::..String
Name.
value
Type: System..::..Object
Value.
sharedName
Type: System..::..Boolean
Name of the shared.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Sql.SqlBatch.AddArgument(System.String,System.Object,System.Boolean)"]

See Also

SqlBatch Class
Sitecore.Data.Sql Namespace


AddBreak Method

[image]

Sitecore 6.4.1 API
SqlBatch..::..AddBreak Method
SqlBatch Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddBreak()
Visual Basic
Public Sub AddBreak
Visual C++
public:
void AddBreak()

See Also

SqlBatch Class
Sitecore.Data.Sql Namespace


AddParameter Method

[image] [image]

Sitecore 6.4.1 API
SqlBatch..::..AddParameter Method
SqlBatch Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddParameter(String, Object) | Adds a parameter.
Public method | AddParameter(String, Object, Boolean) | Adds a parameter.

See Also

SqlBatch Class
SqlBatch Members
Sitecore.Data.Sql Namespace


AddParameter Method (String, Object)

[image]

Sitecore 6.4.1 API
SqlBatch..::..AddParameter Method (String, Object)
SqlBatch Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddParameter(
    string name,
    Object value
)
Visual Basic
Public Sub AddParameter ( _
    name As String, _
    value As Object _
)
Visual C++
public:
void AddParameter(
    String^ name,
    Object^ value
)

Parameters

name
Type: System..::..String
Name.
value
Type: System..::..Object
Value.

See Also

SqlBatch Class
AddParameter Overload
Sitecore.Data.Sql Namespace


AddParameter Method (String, Object, Boolean)

[image]

Sitecore 6.4.1 API
SqlBatch..::..AddParameter Method (String, Object, Boolean)
SqlBatch Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string AddParameter(
    string name,
    Object value,
    bool sharedName
)
Visual Basic
Public Function AddParameter ( _
    name As String, _
    value As Object, _
    sharedName As Boolean _
) As String
Visual C++
public:
String^ AddParameter(
    String^ name,
    Object^ value,
    bool sharedName
)

Parameters

name
Type: System..::..String
Name.
value
Type: System..::..Object
Value.
sharedName
Type: System..::..Boolean
Name of the shared.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Sql.SqlBatch.AddParameter(System.String,System.Object,System.Boolean)"]

See Also

SqlBatch Class
AddParameter Overload
Sitecore.Data.Sql Namespace


AddVariable Method

[image]

Sitecore 6.4.1 API
SqlBatch..::..AddVariable Method
SqlBatch Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddVariable(
    string variable,
    string type
)
Visual Basic
Public Sub AddVariable ( _
    variable As String, _
    type As String _
)
Visual C++
public:
void AddVariable(
    String^ variable,
    String^ type
)

Parameters

variable
Type: System..::..String
Variable.
type
Type: System..::..String
Type.

See Also

SqlBatch Class
Sitecore.Data.Sql Namespace


AddVariableParameter Method

[image]

Sitecore 6.4.1 API
SqlBatch..::..AddVariableParameter Method
SqlBatch Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddVariableParameter(
    string variable
)
Visual Basic
Public Sub AddVariableParameter ( _
    variable As String _
)
Visual C++
public:
void AddVariableParameter(
    String^ variable
)

Parameters

variable
Type: System..::..String
Variable.

See Also

SqlBatch Class
Sitecore.Data.Sql Namespace


EndFunctionCall Method

[image]

Sitecore 6.4.1 API
SqlBatch..::..EndFunctionCall Method
SqlBatch Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void EndFunctionCall()
Visual Basic
Public Sub EndFunctionCall
Visual C++
public:
void EndFunctionCall()

Remarks

See Also

SqlBatch Class
Sitecore.Data.Sql Namespace
SqlBatch..::..EndFunctionCall()()()()


EndIf Method

[image]

Sitecore 6.4.1 API
SqlBatch..::..EndIf Method
SqlBatch Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void EndIf()
Visual Basic
Public Sub EndIf
Visual C++
public:
void EndIf()

Remarks

See Also

SqlBatch Class
Sitecore.Data.Sql Namespace
SqlBatch..::..StartIf(String)


EndProcedureCall Method

[image]

Sitecore 6.4.1 API
SqlBatch..::..EndProcedureCall Method
SqlBatch Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void EndProcedureCall()
Visual Basic
Public Sub EndProcedureCall
Visual C++
public:
void EndProcedureCall()

Remarks

See Also

SqlBatch Class
Sitecore.Data.Sql Namespace
SqlBatch..::..StartProcedureCall(String)


Execute Method

[image]

Sitecore 6.4.1 API
SqlBatch..::..Execute Method
SqlBatch Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Execute(
    string connectionString
)
Visual Basic
Public Sub Execute ( _
    connectionString As String _
)
Visual C++
public:
void Execute(
    String^ connectionString
)

Parameters

connectionString
Type: System..::..String
Connection string.

See Also

SqlBatch Class
Sitecore.Data.Sql Namespace


StartFunctionCall Method

[image]

Sitecore 6.4.1 API
SqlBatch..::..StartFunctionCall Method
SqlBatch Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void StartFunctionCall(
    string functionName,
    string targetVariable
)
Visual Basic
Public Sub StartFunctionCall ( _
    functionName As String, _
    targetVariable As String _
)
Visual C++
public:
void StartFunctionCall(
    String^ functionName,
    String^ targetVariable
)

Parameters

functionName
Type: System..::..String
Name of the function.
targetVariable
Type: System..::..String
Target variable.

Remarks

See Also

SqlBatch Class
Sitecore.Data.Sql Namespace
SqlBatch..::..EndFunctionCall()()()()


StartIf Method

[image]

Sitecore 6.4.1 API
SqlBatch..::..StartIf Method
SqlBatch Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void StartIf(
    string condition
)
Visual Basic
Public Sub StartIf ( _
    condition As String _
)
Visual C++
public:
void StartIf(
    String^ condition
)

Parameters

condition
Type: System..::..String
Condition.

Remarks

See Also

SqlBatch Class
Sitecore.Data.Sql Namespace
SqlBatch..::..EndIf()()()()


StartProcedureCall Method

[image]

Sitecore 6.4.1 API
SqlBatch..::..StartProcedureCall Method
SqlBatch Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void StartProcedureCall(
    string procedureName
)
Visual Basic
Public Sub StartProcedureCall ( _
    procedureName As String _
)
Visual C++
public:
void StartProcedureCall(
    String^ procedureName
)

Parameters

procedureName
Type: System..::..String
Name of the procedure.

Remarks

See Also

SqlBatch Class
Sitecore.Data.Sql Namespace
SqlBatch..::..EndProcedureCall()()()()


SqlBatch Properties

[image] [image]

Sitecore 6.4.1 API
SqlBatch Properties
SqlBatch Class See Also Send Feedback

The SqlBatch type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | Parameters | Gets the parameters.
Public property | Text | Gets the SQL text.
Public property | Timeout | Gets or sets the timeout.
Public property | UseTransaction | Gets a value indicating whether to use transactions.

See Also

SqlBatch Class
Sitecore.Data.Sql Namespace


IsEmpty Property

[image]

Sitecore 6.4.1 API
SqlBatch..::..IsEmpty Property
SqlBatch Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
property bool IsEmpty {
    bool get ();
}

Field Value

true if this instance is empty; otherwise, false.

See Also

SqlBatch Class
Sitecore.Data.Sql Namespace


Parameters Property

[image]

Sitecore 6.4.1 API
SqlBatch..::..Parameters Property
SqlBatch Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Hashtable Parameters { get; }
Visual Basic
Public ReadOnly Property Parameters As Hashtable
    Get
Visual C++
public:
property Hashtable^ Parameters {
    Hashtable^ get ();
}

See Also

SqlBatch Class
Sitecore.Data.Sql Namespace


Text Property

[image]

Sitecore 6.4.1 API
SqlBatch..::..Text Property
SqlBatch Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Text { get; }
Visual Basic
Public ReadOnly Property Text As String
    Get
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

SqlBatch Class
Sitecore.Data.Sql Namespace


Timeout Property

[image]

Sitecore 6.4.1 API
SqlBatch..::..Timeout Property
SqlBatch Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TimeSpan Timeout { get; set; }
Visual Basic
Public Property Timeout As TimeSpan
    Get
    Set
Visual C++
public:
property TimeSpan Timeout {
    TimeSpan get ();
    void set (TimeSpan value);
}

See Also

SqlBatch Class
Sitecore.Data.Sql Namespace


UseTransaction Property

[image]

Sitecore 6.4.1 API
SqlBatch..::..UseTransaction Property
SqlBatch Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool UseTransaction { get; }
Visual Basic
Public ReadOnly Property UseTransaction As Boolean
    Get
Visual C++
public:
property bool UseTransaction {
    bool get ();
}

Field Value

true if to use transactions; otherwise, false.

See Also

SqlBatch Class
Sitecore.Data.Sql Namespace


SqlBuilder Class

[image]

Sitecore 6.4.1 API
SqlBuilder Class
Members Example See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SqlBuilder
Visual Basic
Public Class SqlBuilder
Visual C++
public ref class SqlBuilder

Remarks

The class is aimed at SQL Servers and uses the native .NET driver for optimal performance. This class will not work with other databases.

Normally only the AddParameter, AddWhereClause and Execute methods are called. The other methods function as utility methods for these methods.

Examples

The following code deletes the company "Alfreds Futterkiste" from the Customers table.
CopyC#
SqlBuilder builder = new SqlBuilder("Customers", SqlStatementType.Delete);
builder.AddWhereClause("CompanyName='Alfreds Futterkiste'");
builder.Execute(myConnectionString);

Remarks

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Sql..::..SqlBuilder

See Also

SqlBuilder Members
Sitecore.Data.Sql Namespace
Sitecore..::..DateUtil
Sitecore.IO..::..FileUtil
Sitecore.Web..::..HtmlUtil
Sitecore.Data.Sql..::..SqlUtil
Sitecore..::..StringUtil
Sitecore.Web..::..WebUtil
Sitecore.Xml..::..XmlUtil


SqlBuilder Members

[image] [image]

Sitecore 6.4.1 API
SqlBuilder Members
SqlBuilder Class Constructors Methods Properties See Also Send Feedback

The SqlBuilder type exposes the following members.

Constructors

 | Name | Description
Public method | SqlBuilder(String, SqlStatementType) | Constructs new instance of the SqlBuilder class from a table name and a statement type.
Public method | SqlBuilder(String, SqlStatementType, TimeSpan) | Constructs new instance of the SqlBuilder class from a table name and a statement type.

Methods

 | Name | Description
Public method | AddParameter(String, ID) | Adds a parameter.
Public method | AddParameter(String, Version) | Adds a parameter.
Public method | AddParameter(String, Language) | Adds a parameter.
Public method | AddParameter(String, DateTime) | Adds a parameter.
Public method | AddParameter(String, Object) | Adds a parameter to the parameters list.
Public method | AddVarRef | Adds the variable reference.
Public method | AddWhereClause | Adds a "where" clause as a string.
Public method | CreateCommand(SqlConnection) | Creates an SQL command object from a connection object.
Public method | CreateCommand(String) | Creates an SQL command object from a connection object.
Public method | CreateDeleteCommand | Creates an SQL Delete command object.
Public method | CreateInsertCommand | Creates an SQL Insert command object.
Public method | CreateStoredProcedureCommand | Creates a Stored Procedure command object.
Public method | CreateUDFCommand | Creates a User Defined Function command object.
Public method | CreateUpdateCommand | Creates an Update command object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes current SQL command.
Public method | ExecuteReader | Executes current SQL command and returns a reader.
Public method | ExecuteScalar | Executes current SQL command.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCommandText | Gets the command text.
Public method | GetDeleteCommandText | Gets the delete command text.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInsertCommandText | Gets the insert command text.
Public method | GetStoredProcedureCommandText | Gets the stored procedure command text.
Public method | GetStringArray | Get a string array of results.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUDFCommandText | Gets the UDF command text.
Public method | GetUpdateCommandText | Gets the update command text.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | StatementType | Gets the statement type.
Public property | Timeout | Gets or sets the timeout.

See Also

SqlBuilder Class
Sitecore.Data.Sql Namespace


SqlBuilder Constructor

[image] [image]

Sitecore 6.4.1 API
SqlBuilder Constructor
SqlBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SqlBuilder(String, SqlStatementType) | Constructs new instance of the SqlBuilder class from a table name and a statement type.
Public method | SqlBuilder(String, SqlStatementType, TimeSpan) | Constructs new instance of the SqlBuilder class from a table name and a statement type.

See Also

SqlBuilder Class
SqlBuilder Members
Sitecore.Data.Sql Namespace


SqlBuilder Constructor (String, SqlStatementType)

[image]

Sitecore 6.4.1 API
SqlBuilder Constructor (String, SqlStatementType)
SqlBuilder Class Example See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlBuilder(
    string objectName,
    SqlStatementType type
)
Visual Basic
Public Sub New ( _
    objectName As String, _
    type As SqlStatementType _
)
Visual C++
public:
SqlBuilder(
    String^ objectName,
    SqlStatementType type
)

Parameters

objectName
Type: System..::..String
Name of table.
type
Type: Sitecore.Data.Sql..::..SqlStatementType
Statement type.

Examples

The following code deletes the company "Alfreds Futterkiste" from the Customers table.
CopyC#
SqlBuilder builder = new SqlBuilder("Customers", SqlStatementType.Delete);
builder.AddWhereClause("CompanyName='Alfreds Futterkiste'");
builder.Execute(myConnectionString);

See Also

SqlBuilder Class
SqlBuilder Overload
Sitecore.Data.Sql Namespace
Sitecore.Data.Sql..::..SqlStatementType


SqlBuilder Constructor (String, SqlStatementType, TimeSpan)

[image]

Sitecore 6.4.1 API
SqlBuilder Constructor (String, SqlStatementType, TimeSpan)
SqlBuilder Class Example See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlBuilder(
    string objectName,
    SqlStatementType type,
    TimeSpan timeout
)
Visual Basic
Public Sub New ( _
    objectName As String, _
    type As SqlStatementType, _
    timeout As TimeSpan _
)
Visual C++
public:
SqlBuilder(
    String^ objectName,
    SqlStatementType type,
    TimeSpan timeout
)

Parameters

objectName
Type: System..::..String
Name of table.
type
Type: Sitecore.Data.Sql..::..SqlStatementType
Statement type.
timeout
Type: System..::..TimeSpan
Command timeout of the SQL call.

Examples

The following code deletes the company "Alfreds Futterkiste" from the Customers table.
CopyC#
SqlBuilder builder = new SqlBuilder("Customers", SqlStatementType.Delete);
builder.AddWhereClause("CompanyName='Alfreds Futterkiste'");
builder.Execute(myConnectionString);

See Also

SqlBuilder Class
SqlBuilder Overload
Sitecore.Data.Sql Namespace
Sitecore.Data.Sql..::..SqlStatementType


SqlBuilder Methods

[image] [image]

Sitecore 6.4.1 API
SqlBuilder Methods
SqlBuilder Class See Also Send Feedback

The SqlBuilder type exposes the following members.

Methods

 | Name | Description
Public method | AddParameter(String, ID) | Adds a parameter.
Public method | AddParameter(String, Version) | Adds a parameter.
Public method | AddParameter(String, Language) | Adds a parameter.
Public method | AddParameter(String, DateTime) | Adds a parameter.
Public method | AddParameter(String, Object) | Adds a parameter to the parameters list.
Public method | AddVarRef | Adds the variable reference.
Public method | AddWhereClause | Adds a "where" clause as a string.
Public method | CreateCommand(SqlConnection) | Creates an SQL command object from a connection object.
Public method | CreateCommand(String) | Creates an SQL command object from a connection object.
Public method | CreateDeleteCommand | Creates an SQL Delete command object.
Public method | CreateInsertCommand | Creates an SQL Insert command object.
Public method | CreateStoredProcedureCommand | Creates a Stored Procedure command object.
Public method | CreateUDFCommand | Creates a User Defined Function command object.
Public method | CreateUpdateCommand | Creates an Update command object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes current SQL command.
Public method | ExecuteReader | Executes current SQL command and returns a reader.
Public method | ExecuteScalar | Executes current SQL command.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCommandText | Gets the command text.
Public method | GetDeleteCommandText | Gets the delete command text.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInsertCommandText | Gets the insert command text.
Public method | GetStoredProcedureCommandText | Gets the stored procedure command text.
Public method | GetStringArray | Get a string array of results.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUDFCommandText | Gets the UDF command text.
Public method | GetUpdateCommandText | Gets the update command text.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SqlBuilder Class
Sitecore.Data.Sql Namespace


AddParameter Method

[image] [image]

Sitecore 6.4.1 API
SqlBuilder..::..AddParameter Method
SqlBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddParameter(String, ID) | Adds a parameter.
Public method | AddParameter(String, Version) | Adds a parameter.
Public method | AddParameter(String, Language) | Adds a parameter.
Public method | AddParameter(String, DateTime) | Adds a parameter.
Public method | AddParameter(String, Object) | Adds a parameter to the parameters list.

See Also

SqlBuilder Class
SqlBuilder Members
Sitecore.Data.Sql Namespace


AddParameter Method (String, ID)

[image]

Sitecore 6.4.1 API
SqlBuilder..::..AddParameter Method (String, ID)
SqlBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddParameter(
    string parameterName,
    ID parameterValue
)
Visual Basic
Public Sub AddParameter ( _
    parameterName As String, _
    parameterValue As ID _
)
Visual C++
public:
void AddParameter(
    String^ parameterName,
    ID^ parameterValue
)

Parameters

parameterName
Type: System..::..String
Name of the parameter.
parameterValue
Type: Sitecore.Data..::..ID
Parameter value.

See Also

SqlBuilder Class
AddParameter Overload
Sitecore.Data.Sql Namespace


AddParameter Method (String, Version)

[image]

Sitecore 6.4.1 API
SqlBuilder..::..AddParameter Method (String, Version)
SqlBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddParameter(
    string parameterName,
    Version parameterValue
)
Visual Basic
Public Sub AddParameter ( _
    parameterName As String, _
    parameterValue As Version _
)
Visual C++
public:
void AddParameter(
    String^ parameterName,
    Version^ parameterValue
)

Parameters

parameterName
Type: System..::..String
Name of the parameter.
parameterValue
Type: Sitecore.Data..::..Version
Parameter value.

See Also

SqlBuilder Class
AddParameter Overload
Sitecore.Data.Sql Namespace


AddParameter Method (String, Language)

[image]

Sitecore 6.4.1 API
SqlBuilder..::..AddParameter Method (String, Language)
SqlBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddParameter(
    string parameterName,
    Language parameterValue
)
Visual Basic
Public Sub AddParameter ( _
    parameterName As String, _
    parameterValue As Language _
)
Visual C++
public:
void AddParameter(
    String^ parameterName,
    Language^ parameterValue
)

Parameters

parameterName
Type: System..::..String
Name of the parameter.
parameterValue
Type: Sitecore.Globalization..::..Language
Parameter value.

See Also

SqlBuilder Class
AddParameter Overload
Sitecore.Data.Sql Namespace


AddParameter Method (String, DateTime)

[image]

Sitecore 6.4.1 API
SqlBuilder..::..AddParameter Method (String, DateTime)
SqlBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddParameter(
    string parameterName,
    DateTime parameterValue
)
Visual Basic
Public Sub AddParameter ( _
    parameterName As String, _
    parameterValue As DateTime _
)
Visual C++
public:
void AddParameter(
    String^ parameterName,
    DateTime parameterValue
)

Parameters

parameterName
Type: System..::..String
Name of the parameter.
parameterValue
Type: System..::..DateTime
Parameter value.

See Also

SqlBuilder Class
AddParameter Overload
Sitecore.Data.Sql Namespace


AddParameter Method (String, Object)

[image]

Sitecore 6.4.1 API
SqlBuilder..::..AddParameter Method (String, Object)
SqlBuilder Class Example See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddParameter(
    string parameterName,
    Object parameterValue
)
Visual Basic
Public Sub AddParameter ( _
    parameterName As String, _
    parameterValue As Object _
)
Visual C++
public:
void AddParameter(
    String^ parameterName,
    Object^ parameterValue
)

Parameters

parameterName
Type: System..::..String
A string containing the parameter name.
parameterValue
Type: System..::..Object
An object.

Remarks

The parameter is added to the internal parameters list.

Examples

CopyC#
SqlBuilder builder = new SqlBuilder("Customers", SqlStatementType.StoredProcedure);
builder.AddParameter("name", "Alfreds Futterkiste");

See Also

SqlBuilder Class
AddParameter Overload
Sitecore.Data.Sql Namespace


AddVarRef Method

[image]

Sitecore 6.4.1 API
SqlBuilder..::..AddVarRef Method
SqlBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddVarRef(
    string variableName
)
Visual Basic
Public Sub AddVarRef ( _
    variableName As String _
)
Visual C++
public:
void AddVarRef(
    String^ variableName
)

Parameters

variableName
Type: System..::..String
Name of the variable.

See Also

SqlBuilder Class
Sitecore.Data.Sql Namespace


AddWhereClause Method

[image]

Sitecore 6.4.1 API
SqlBuilder..::..AddWhereClause Method
SqlBuilder Class Example See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddWhereClause(
    string whereClause
)
Visual Basic
Public Sub AddWhereClause ( _
    whereClause As String _
)
Visual C++
public:
void AddWhereClause(
    String^ whereClause
)

Parameters

whereClause
Type: System..::..String
The SQL where clase excluding the "where" keyword.

Remarks

The "where" keyword is automatically added if the where clause is not blank.

Examples

CopyC#
SqlBuilder builder = new SqlBuilder("Customers", SqlStatementType.Delete);
builder.AddWhereClause("name='Alfreds Futterkiste' and address='Elmstreet');

See Also

SqlBuilder Class
Sitecore.Data.Sql Namespace


CreateCommand Method

[image] [image]

Sitecore 6.4.1 API
SqlBuilder..::..CreateCommand Method
SqlBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateCommand(SqlConnection) | Creates an SQL command object from a connection object.
Public method | CreateCommand(String) | Creates an SQL command object from a connection object.

See Also

SqlBuilder Class
SqlBuilder Members
Sitecore.Data.Sql Namespace


CreateCommand Method (SqlConnection)

[image]

Sitecore 6.4.1 API
SqlBuilder..::..CreateCommand Method (SqlConnection)
SqlBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlCommand CreateCommand(
    SqlConnection connection
)
Visual Basic
Public Function CreateCommand ( _
    connection As SqlConnection _
) As SqlCommand
Visual C++
public:
SqlCommand^ CreateCommand(
    SqlConnection^ connection
)

Parameters

connection
Type: System.Data.SqlClient..::..SqlConnection
An SQL connection object.

Return Value

The created SQL command object.

Remarks

This method is called by the Execute method. It is rarely used seperately.

See Also

SqlBuilder Class
CreateCommand Overload
Sitecore.Data.Sql Namespace


CreateCommand Method (String)

[image]

Sitecore 6.4.1 API
SqlBuilder..::..CreateCommand Method (String)
SqlBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlCommand CreateCommand(
    string connection
)
Visual Basic
Public Function CreateCommand ( _
    connection As String _
) As SqlCommand
Visual C++
public:
SqlCommand^ CreateCommand(
    String^ connection
)

Parameters

connection
Type: System..::..String
An SQL connection string.

Return Value

The created SQL command object.

Remarks

This method is called by the Execute method. It is rarely used seperately.

Important: Remember to close the connection after using the returned command object (cmd). Use cmd.Connection.Close().

See Also

SqlBuilder Class
CreateCommand Overload
Sitecore.Data.Sql Namespace


CreateDeleteCommand Method

[image]

Sitecore 6.4.1 API
SqlBuilder..::..CreateDeleteCommand Method
SqlBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlCommand CreateDeleteCommand(
    SqlCommand cmd
)
Visual Basic
Public Function CreateDeleteCommand ( _
    cmd As SqlCommand _
) As SqlCommand
Visual C++
public:
SqlCommand^ CreateDeleteCommand(
    SqlCommand^ cmd
)

Parameters

cmd
Type: System.Data.SqlClient..::..SqlCommand
An SQL command object.

Return Value

The created SQL command object.

Remarks

This method is called by the Execute method. It is rarely used seperately.

See Also

SqlBuilder Class
Sitecore.Data.Sql Namespace


CreateInsertCommand Method

[image]

Sitecore 6.4.1 API
SqlBuilder..::..CreateInsertCommand Method
SqlBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlCommand CreateInsertCommand(
    SqlCommand cmd
)
Visual Basic
Public Function CreateInsertCommand ( _
    cmd As SqlCommand _
) As SqlCommand
Visual C++
public:
SqlCommand^ CreateInsertCommand(
    SqlCommand^ cmd
)

Parameters

cmd
Type: System.Data.SqlClient..::..SqlCommand
An SQL command object.

Return Value

The created SQL command object.

Remarks

This method is called by the Execute method. It is rarely used seperately.

See Also

SqlBuilder Class
Sitecore.Data.Sql Namespace


CreateStoredProcedureCommand Method

[image]

Sitecore 6.4.1 API
SqlBuilder..::..CreateStoredProcedureCommand Method
SqlBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlCommand CreateStoredProcedureCommand(
    SqlCommand cmd
)
Visual Basic
Public Function CreateStoredProcedureCommand ( _
    cmd As SqlCommand _
) As SqlCommand
Visual C++
public:
SqlCommand^ CreateStoredProcedureCommand(
    SqlCommand^ cmd
)

Parameters

cmd
Type: System.Data.SqlClient..::..SqlCommand
An SQL command object.

Return Value

The created SQL command object.

Remarks

This method is called by the Execute method. It is rarely used seperately.

See Also

SqlBuilder Class
Sitecore.Data.Sql Namespace


CreateUpdateCommand Method

[image]

Sitecore 6.4.1 API
SqlBuilder..::..CreateUpdateCommand Method
SqlBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlCommand CreateUpdateCommand(
    SqlCommand cmd
)
Visual Basic
Public Function CreateUpdateCommand ( _
    cmd As SqlCommand _
) As SqlCommand
Visual C++
public:
SqlCommand^ CreateUpdateCommand(
    SqlCommand^ cmd
)

Parameters

cmd
Type: System.Data.SqlClient..::..SqlCommand
An SQL command object.

Return Value

The created SQL command object.

Remarks

This method is called by the Execute method. It is rarely used seperately.

See Also

SqlBuilder Class
Sitecore.Data.Sql Namespace


Execute Method

[image]

Sitecore 6.4.1 API
SqlBuilder..::..Execute Method
SqlBuilder Class Example See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Execute(
    string connection
)
Visual Basic
Public Sub Execute ( _
    connection As String _
)
Visual C++
public:
void Execute(
    String^ connection
)

Parameters

connection
Type: System..::..String
A connection string.

Remarks

The result of the command is discarded.

Examples

The following code deletes the company "Alfreds Futterkiste" from the Customers table.
CopyC#
SqlBuilder builder = new SqlBuilder("Customers", SqlStatementType.Delete);
builder.AddWhereClause("CompanyName='Alfreds Futterkiste'");
builder.Execute(myConnectionString);

See Also

SqlBuilder Class
Sitecore.Data.Sql Namespace


ExecuteScalar Method

[image]

Sitecore 6.4.1 API
SqlBuilder..::..ExecuteScalar Method
SqlBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object ExecuteScalar(
    string connection
)
Visual Basic
Public Function ExecuteScalar ( _
    connection As String _
) As Object
Visual C++
public:
Object^ ExecuteScalar(
    String^ connection
)

Parameters

connection
Type: System..::..String
Connection.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Sql.SqlBuilder.ExecuteScalar(System.String)"]

See Also

SqlBuilder Class
Sitecore.Data.Sql Namespace


GetCommandText Method

[image]

Sitecore 6.4.1 API
SqlBuilder..::..GetCommandText Method
SqlBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetCommandText()
Visual Basic
Public Function GetCommandText As String
Visual C++
public:
String^ GetCommandText()

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Sql.SqlBuilder.GetCommandText"]

See Also

SqlBuilder Class
Sitecore.Data.Sql Namespace


GetDeleteCommandText Method

[image]

Sitecore 6.4.1 API
SqlBuilder..::..GetDeleteCommandText Method
SqlBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetDeleteCommandText()
Visual Basic
Public Function GetDeleteCommandText As String
Visual C++
public:
String^ GetDeleteCommandText()

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Sql.SqlBuilder.GetDeleteCommandText"]

See Also

SqlBuilder Class
Sitecore.Data.Sql Namespace


GetStoredProcedureCommandText Method

[image]

Sitecore 6.4.1 API
SqlBuilder..::..GetStoredProcedureCommandText Method
SqlBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetStoredProcedureCommandText()
Visual Basic
Public Function GetStoredProcedureCommandText As String
Visual C++
public:
String^ GetStoredProcedureCommandText()

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Sql.SqlBuilder.GetStoredProcedureCommandText"]

See Also

SqlBuilder Class
Sitecore.Data.Sql Namespace


GetStringArray Method

[image]

Sitecore 6.4.1 API
SqlBuilder..::..GetStringArray Method
SqlBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string[] GetStringArray(
    string connection
)
Visual Basic
Public Function GetStringArray ( _
    connection As String _
) As String()
Visual C++
public:
array<String^>^ GetStringArray(
    String^ connection
)

Parameters

connection
Type: System..::..String
A connection string.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Sql.SqlBuilder.GetStringArray(System.String)"]

See Also

SqlBuilder Class
Sitecore.Data.Sql Namespace


GetUDFCommandText Method

[image]

Sitecore 6.4.1 API
SqlBuilder..::..GetUDFCommandText Method
SqlBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetUDFCommandText()
Visual Basic
Public Function GetUDFCommandText As String
Visual C++
public:
String^ GetUDFCommandText()

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Sql.SqlBuilder.GetUDFCommandText"]

See Also

SqlBuilder Class
Sitecore.Data.Sql Namespace


GetUpdateCommandText Method

[image]

Sitecore 6.4.1 API
SqlBuilder..::..GetUpdateCommandText Method
SqlBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetUpdateCommandText()
Visual Basic
Public Function GetUpdateCommandText As String
Visual C++
public:
String^ GetUpdateCommandText()

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Sql.SqlBuilder.GetUpdateCommandText"]

See Also

SqlBuilder Class
Sitecore.Data.Sql Namespace


SqlBuilder Properties

[image] [image]

Sitecore 6.4.1 API
SqlBuilder Properties
SqlBuilder Class See Also Send Feedback

The SqlBuilder type exposes the following members.

Properties

 | Name | Description
Public property | StatementType | Gets the statement type.
Public property | Timeout | Gets or sets the timeout.

See Also

SqlBuilder Class
Sitecore.Data.Sql Namespace


StatementType Property

[image]

Sitecore 6.4.1 API
SqlBuilder..::..StatementType Property
SqlBuilder Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlStatementType StatementType { get; }
Visual Basic
Public ReadOnly Property StatementType As SqlStatementType
    Get
Visual C++
public:
property SqlStatementType StatementType {
    SqlStatementType get ();
}

See Also

SqlBuilder Class
Sitecore.Data.Sql Namespace


SqlStatementType Enumeration

[image]

Sitecore 6.4.1 API
SqlStatementType Enumeration
See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum SqlStatementType
Visual Basic
Public Enumeration SqlStatementType
Visual C++
public enum class SqlStatementType

Members

Member name | Value | Description
Delete | 0 | Defines a Delete statement.
Insert | 1 | Defines an Insert statement.
StoredProcedure | 2 | Defines a Stored Procedure.
UDF | 3 | Defines a User Defined Function.
Update | 4 | Defines an Update statement.

See Also

Sitecore.Data.Sql Namespace
Sitecore.Data.Sql..::..SqlBuilder


SqlUtil Class

[image]

Sitecore 6.4.1 API
SqlUtil Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class SqlUtil
Visual Basic
Public NotInheritable Class SqlUtil
Visual C++
public ref class SqlUtil abstract sealed

Remarks

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Sql..::..SqlUtil

See Also

SqlUtil Members
Sitecore.Data.Sql Namespace
Sitecore..::..DateUtil
Sitecore.Data.Sql..::..SqlUtil
Sitecore..::..StringUtil


SqlUtil Members

[image] [image]

Sitecore 6.4.1 API
SqlUtil Members
SqlUtil Class Methods See Also Send Feedback

The SqlUtil type exposes the following members.

Methods

Name | Description
AddParameters | Adds the parameters.
CreateCommand(String, String) | Gets a SQL command object from a SQL statement string and a connection string.
CreateCommand(String, String, TimeSpan) | Gets a SQL command object from a SQL statement string and a connection string.
Delete | Deletes all data form a table.
ExecCommand(String, String) | Executes an SQL command statement.
ExecCommand(String, array<Object>[]()[][], String) | Executes an SQL command statement.
ExecCommand(String, String, TimeSpan) | Executes an SQL command statement.
ExecCommand(String, array<Object>[]()[][], String, TimeSpan) | Executes an SQL command statement.
ExecReader(SqlCommand, SqlConnection%) | Obsolete. Executes an SQL statement that yields a result.
ExecReader(SqlBuilder, String, SqlConnection%) | Obsolete. Executes an SQL statement that yields a result.
ExecReader(String, array<Object>[]()[][], String, SqlConnection%) | Obsolete. Executes an SQL statement that yields a result.
Execute | Executes an SQL command statement.
ExecuteNonQuery |
ExecuteReader(SqlCommand) | Executes a reader on a command.
ExecuteReader(String, array<Object>[]()[][], String) | Opens a reader using the specified SQL.
ExecuteScalar |
ExtractConnnectionValue | Extracts a value from a connection string.
GetArray(SqlBuilder, String) | Gets an array of results from an SQL statement.
GetArray(SqlCommand, Int32, Int32) | Gets an array of results from an SQL statement.
GetArray(String, array<Object>[]()[][], String) | Gets an array of results from an SQL statement.
GetCount(String, String) | Gets a row count for a table.
GetCount(SqlBuilder, String) | Gets a row count.
GetCount(String, String, array<Object>[]()[][], String) | Gets a row count for a table.
GetDataSet | Gets a Dataset object from an SQL statement.
GetFullTextSearchSql | Gets an SQL statement for use with a full-text query.
GetHashtable(SqlCommand) | Gets results from an SQL statement as a hashtable.
GetHashtable(SqlDataReader) | Gets results from an SQL statement as a hashtable.
GetHashtable(String, String) | Gets results from an SQL statement as a hashtable.
GetHashtable(SqlBuilder, String) | Gets results from an SQL statement as a hashtable.
GetID | Gets a result string from an SQL builder.
GetIDArray(String, String) | Gets an array of results from an SQL statement.
GetIDArray(SqlBuilder, String) | Gets an array of results from an SQL statement.
GetInt32 | Gets an integer result from an SQL query.
GetItemID(SqlCommand) | Gets the item ID.
GetItemID(String, String) | Gets an item ID.
GetItemID(SqlBuilder, String) | Gets an item ID.
GetString(SqlCommand) | Gets a result string from an SQL command.
GetString(String, String) | Gets a result string from an SQL query.
GetString(SqlBuilder, String) | Gets a result string from an SQL builder.
GetString(String, String, array<Object>[]()[][]) | Gets a string.
GetStringArray(SqlCommand) | Gets an array of results from an SQL statement.
GetStringArray(String, String) | Gets an array of results from an SQL statement.
GetStringArray(SqlBuilder, String) | Gets an array of results from an SQL statement.
GetStringArray(SqlCommand, Int32, Int32) | Gets an array of results from an SQL statement.
GetStringArray(String, String, Int32, Int32) | Gets an array of results from an SQL statement.
GetStringArray(SqlBuilder, String, Int32, Int32) | Gets an array of results from an SQL statement.
GetStringList | Gets a list of string values from a database.
GetStringSet | Gets a list of string values from a database.
MapType | Maps the type.
MapValue | Maps the value.
ObfuscatePassword | Obfuscates the password part of a connection string.
Safe(DateTime) | Gets a date.
Safe(String) | Escapes a string for use in SQL statements.
StripPasswords | Removes the passwords from connection string.

See Also

SqlUtil Class
Sitecore.Data.Sql Namespace


SqlUtil Methods

[image] [image]

Sitecore 6.4.1 API
SqlUtil Methods
SqlUtil Class See Also Send Feedback

The SqlUtil type exposes the following members.

Methods

Name | Description
AddParameters | Adds the parameters.
CreateCommand(String, String) | Gets a SQL command object from a SQL statement string and a connection string.
CreateCommand(String, String, TimeSpan) | Gets a SQL command object from a SQL statement string and a connection string.
Delete | Deletes all data form a table.
ExecCommand(String, String) | Executes an SQL command statement.
ExecCommand(String, array<Object>[]()[][], String) | Executes an SQL command statement.
ExecCommand(String, String, TimeSpan) | Executes an SQL command statement.
ExecCommand(String, array<Object>[]()[][], String, TimeSpan) | Executes an SQL command statement.
ExecReader(SqlCommand, SqlConnection%) | Obsolete. Executes an SQL statement that yields a result.
ExecReader(SqlBuilder, String, SqlConnection%) | Obsolete. Executes an SQL statement that yields a result.
ExecReader(String, array<Object>[]()[][], String, SqlConnection%) | Obsolete. Executes an SQL statement that yields a result.
Execute | Executes an SQL command statement.
ExecuteNonQuery |
ExecuteReader(SqlCommand) | Executes a reader on a command.
ExecuteReader(String, array<Object>[]()[][], String) | Opens a reader using the specified SQL.
ExecuteScalar |
ExtractConnnectionValue | Extracts a value from a connection string.
GetArray(SqlBuilder, String) | Gets an array of results from an SQL statement.
GetArray(SqlCommand, Int32, Int32) | Gets an array of results from an SQL statement.
GetArray(String, array<Object>[]()[][], String) | Gets an array of results from an SQL statement.
GetCount(String, String) | Gets a row count for a table.
GetCount(SqlBuilder, String) | Gets a row count.
GetCount(String, String, array<Object>[]()[][], String) | Gets a row count for a table.
GetDataSet | Gets a Dataset object from an SQL statement.
GetFullTextSearchSql | Gets an SQL statement for use with a full-text query.
GetHashtable(SqlCommand) | Gets results from an SQL statement as a hashtable.
GetHashtable(SqlDataReader) | Gets results from an SQL statement as a hashtable.
GetHashtable(String, String) | Gets results from an SQL statement as a hashtable.
GetHashtable(SqlBuilder, String) | Gets results from an SQL statement as a hashtable.
GetID | Gets a result string from an SQL builder.
GetIDArray(String, String) | Gets an array of results from an SQL statement.
GetIDArray(SqlBuilder, String) | Gets an array of results from an SQL statement.
GetInt32 | Gets an integer result from an SQL query.
GetItemID(SqlCommand) | Gets the item ID.
GetItemID(String, String) | Gets an item ID.
GetItemID(SqlBuilder, String) | Gets an item ID.
GetString(SqlCommand) | Gets a result string from an SQL command.
GetString(String, String) | Gets a result string from an SQL query.
GetString(SqlBuilder, String) | Gets a result string from an SQL builder.
GetString(String, String, array<Object>[]()[][]) | Gets a string.
GetStringArray(SqlCommand) | Gets an array of results from an SQL statement.
GetStringArray(String, String) | Gets an array of results from an SQL statement.
GetStringArray(SqlBuilder, String) | Gets an array of results from an SQL statement.
GetStringArray(SqlCommand, Int32, Int32) | Gets an array of results from an SQL statement.
GetStringArray(String, String, Int32, Int32) | Gets an array of results from an SQL statement.
GetStringArray(SqlBuilder, String, Int32, Int32) | Gets an array of results from an SQL statement.
GetStringList | Gets a list of string values from a database.
GetStringSet | Gets a list of string values from a database.
MapType | Maps the type.
MapValue | Maps the value.
ObfuscatePassword | Obfuscates the password part of a connection string.
Safe(DateTime) | Gets a date.
Safe(String) | Escapes a string for use in SQL statements.
StripPasswords | Removes the passwords from connection string.

See Also

SqlUtil Class
Sitecore.Data.Sql Namespace


AddParameters Method

[image]

Sitecore 6.4.1 API
SqlUtil..::..AddParameters Method
SqlUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void AddParameters(
    SqlCommand cmd,
    Object[] parameters
)
Visual Basic
Public Shared Sub AddParameters ( _
    cmd As SqlCommand, _
    parameters As Object() _
)
Visual C++
public:
static void AddParameters(
    SqlCommand^ cmd,
    array<Object^>^ parameters
)

Parameters

cmd
Type: System.Data.SqlClient..::..SqlCommand
CMD.
parameters
Type: array< System..::..Object >[]()[][]
Parameters.

See Also

SqlUtil Class
Sitecore.Data.Sql Namespace


CreateCommand Method

[image] [image]

Sitecore 6.4.1 API
SqlUtil..::..CreateCommand Method
SqlUtil Class See Also Send Feedback

Overload List

Name | Description
CreateCommand(String, String) | Gets a SQL command object from a SQL statement string and a connection string.
CreateCommand(String, String, TimeSpan) | Gets a SQL command object from a SQL statement string and a connection string.

See Also

SqlUtil Class
SqlUtil Members
Sitecore.Data.Sql Namespace


CreateCommand Method (String, String)

[image]

Sitecore 6.4.1 API
SqlUtil..::..CreateCommand Method (String, String)
SqlUtil Class Example See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static SqlCommand CreateCommand(
    string sql,
    string connection
)
Visual Basic
Public Shared Function CreateCommand ( _
    sql As String, _
    connection As String _
) As SqlCommand
Visual C++
public:
static SqlCommand^ CreateCommand(
    String^ sql,
    String^ connection
)

Parameters

sql
Type: System..::..String
A string containing an SQL statement.
connection
Type: System..::..String
A SQL Server connection string.

Return Value

The created SQL command object.

Examples

CopyC#
SqlCommand cmd = SqlUtil.CreateCommand("select * from Customers", myConnection);

See Also

SqlUtil Class
CreateCommand Overload
Sitecore.Data.Sql Namespace


CreateCommand Method (String, String, TimeSpan)

[image]

Sitecore 6.4.1 API
SqlUtil..::..CreateCommand Method (String, String, TimeSpan)
SqlUtil Class Example See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static SqlCommand CreateCommand(
    string sql,
    string connection,
    TimeSpan timeout
)
Visual Basic
Public Shared Function CreateCommand ( _
    sql As String, _
    connection As String, _
    timeout As TimeSpan _
) As SqlCommand
Visual C++
public:
static SqlCommand^ CreateCommand(
    String^ sql,
    String^ connection,
    TimeSpan timeout
)

Parameters

sql
Type: System..::..String
A string containing an SQL statement.
connection
Type: System..::..String
A SQL Server connection string.
timeout
Type: System..::..TimeSpan
Time before the command times out.

Return Value

The created SQL command object.

Examples

CopyC#
SqlCommand cmd = SqlUtil.CreateCommand("select * from Customers", myConnection);

See Also

SqlUtil Class
CreateCommand Overload
Sitecore.Data.Sql Namespace


Delete Method

[image]

Sitecore 6.4.1 API
SqlUtil..::..Delete Method
SqlUtil Class Example See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Delete(
    string table,
    string connection
)
Visual Basic
Public Shared Sub Delete ( _
    table As String, _
    connection As String _
)
Visual C++
public:
static void Delete(
    String^ table,
    String^ connection
)

Parameters

table
Type: System..::..String
Name of table.
connection
Type: System..::..String
A SQL Server connection string.

Examples

CopyC#
SqlUtil.Delete("customers", myConnection);

See Also

SqlUtil Class
Sitecore.Data.Sql Namespace


ExecCommand Method

[image] [image]

Sitecore 6.4.1 API
SqlUtil..::..ExecCommand Method
SqlUtil Class See Also Send Feedback

Overload List

Name | Description
ExecCommand(String, String) | Executes an SQL command statement.
ExecCommand(String, array<Object>[]()[][], String) | Executes an SQL command statement.
ExecCommand(String, String, TimeSpan) | Executes an SQL command statement.
ExecCommand(String, array<Object>[]()[][], String, TimeSpan) | Executes an SQL command statement.

See Also

SqlUtil Class
SqlUtil Members
Sitecore.Data.Sql Namespace


ExecCommand Method (String, String)

[image]

Sitecore 6.4.1 API
SqlUtil..::..ExecCommand Method (String, String)
SqlUtil Class Example See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void ExecCommand(
    string sql,
    string connection
)
Visual Basic
Public Shared Sub ExecCommand ( _
    sql As String, _
    connection As String _
)
Visual C++
public:
static void ExecCommand(
    String^ sql,
    String^ connection
)

Parameters

sql
Type: System..::..String
A string containing an SQL statement.
connection
Type: System..::..String
A SQL Server connection string.

Remarks

The SQL command statement can be an Insert, Delete or Update statement. The result from the command is discarded.

Examples

CopyC#
SqlUtil.ExecCommand("delete * from customers", myConnection);

See Also

SqlUtil Class
ExecCommand Overload
Sitecore.Data.Sql Namespace


ExecCommand Method (String, Object[], String)

[image]

Sitecore 6.4.1 API
SqlUtil..::..ExecCommand Method (String, array<Object>[]()[][], String)
SqlUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void ExecCommand(
    string sql,
    Object[] parameters,
    string connection
)
Visual Basic
Public Shared Sub ExecCommand ( _
    sql As String, _
    parameters As Object(), _
    connection As String _
)
Visual C++
public:
static void ExecCommand(
    String^ sql,
    array<Object^>^ parameters,
    String^ connection
)

Parameters

sql
Type: System..::..String
A string containing an SQL statement.
parameters
Type: array< System..::..Object >[]()[][]

[Missing <param name="parameters"/> documentation for "M:Sitecore.Data.Sql.SqlUtil.ExecCommand(System.String,System.Object[],System.String)"]

connection
Type: System..::..String
A SQL Server connection string.

Remarks

The SQL command statement can be an Insert, Delete or Update statement. The result from the command is discarded.

See Also

SqlUtil Class
ExecCommand Overload
Sitecore.Data.Sql Namespace


ExecCommand Method (String, String, TimeSpan)

[image]

Sitecore 6.4.1 API
SqlUtil..::..ExecCommand Method (String, String, TimeSpan)
SqlUtil Class Example See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void ExecCommand(
    string sql,
    string connection,
    TimeSpan timeout
)
Visual Basic
Public Shared Sub ExecCommand ( _
    sql As String, _
    connection As String, _
    timeout As TimeSpan _
)
Visual C++
public:
static void ExecCommand(
    String^ sql,
    String^ connection,
    TimeSpan timeout
)

Parameters

sql
Type: System..::..String
A string containing an SQL statement.
connection
Type: System..::..String
A SQL Server connection string.
timeout
Type: System..::..TimeSpan
Command timeout

Remarks

The SQL command statement can be an Insert, Delete or Update statement. The result from the command is discarded.

Examples

CopyC#
SqlUtil.ExecCommand("delete * from customers", myConnection);

See Also

SqlUtil Class
ExecCommand Overload
Sitecore.Data.Sql Namespace


ExecCommand Method (String, Object[], String, TimeSpan)

[image]

Sitecore 6.4.1 API
SqlUtil..::..ExecCommand Method (String, array<Object>[]()[][], String, TimeSpan)
SqlUtil Class Example See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void ExecCommand(
    string sql,
    Object[] parameters,
    string connection,
    TimeSpan timeout
)
Visual Basic
Public Shared Sub ExecCommand ( _
    sql As String, _
    parameters As Object(), _
    connection As String, _
    timeout As TimeSpan _
)
Visual C++
public:
static void ExecCommand(
    String^ sql,
    array<Object^>^ parameters,
    String^ connection,
    TimeSpan timeout
)

Parameters

sql
Type: System..::..String
A string containing an SQL statement.
parameters
Type: array< System..::..Object >[]()[][]

[Missing <param name="parameters"/> documentation for "M:Sitecore.Data.Sql.SqlUtil.ExecCommand(System.String,System.Object[],System.String,System.TimeSpan)"]

connection
Type: System..::..String
A SQL Server connection string.
timeout
Type: System..::..TimeSpan
Time before the command times out.

Remarks

The SQL command statement can be an Insert, Delete or Update statement. The result from the command is discarded.

Examples

CopyC#
SqlUtil.ExecCommand("delete * from customers", myConnection);

See Also

SqlUtil Class
ExecCommand Overload
Sitecore.Data.Sql Namespace


ExecReader Method

[image] [image]

Sitecore 6.4.1 API
SqlUtil..::..ExecReader Method
SqlUtil Class See Also Send Feedback

Overload List

Name | Description
ExecReader(SqlCommand, SqlConnection%) | Obsolete. Executes an SQL statement that yields a result.
ExecReader(SqlBuilder, String, SqlConnection%) | Obsolete. Executes an SQL statement that yields a result.
ExecReader(String, array<Object>[]()[][], String, SqlConnection%) | Obsolete. Executes an SQL statement that yields a result.

See Also

SqlUtil Class
SqlUtil Members
Sitecore.Data.Sql Namespace


ExecReader Method (SqlCommand, SqlConnection)

[image]

Sitecore 6.4.1 API
SqlUtil..::..ExecReader Method (SqlCommand, SqlConnection%)
SqlUtil Class Example See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public static SqlDataReader ExecReader(
    SqlCommand cmd,
    out SqlConnection conn
)
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Shared Function ExecReader ( _
    cmd As SqlCommand, _
    <OutAttribute> ByRef conn As SqlConnection _
) As SqlDataReader
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public:
static SqlDataReader^ ExecReader(
    SqlCommand^ cmd,
    [OutAttribute] SqlConnection^% conn
)

Parameters

cmd
Type: System.Data.SqlClient..::..SqlCommand
A SQL command.
conn
Type: System.Data.SqlClient..::..SqlConnection %
The resulting SQL connection object.

Return Value

The result dataset from the SQL Server.

Remarks

The connection that is created from the connection string is returned in the conn parameter.

Examples

CopyC#
SqlConnection conn = null;
SqlDataReader reader = SqlUtil.ExecReader("select * from customers", myConnection, out conn);
while (reader.Read()) {
  ...
}

See Also

SqlUtil Class
ExecReader Overload
Sitecore.Data.Sql Namespace


ExecReader Method (SqlBuilder, String, SqlConnection)

[image]

Sitecore 6.4.1 API
SqlUtil..::..ExecReader Method (SqlBuilder, String, SqlConnection%)
SqlUtil Class Example See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public static SqlDataReader ExecReader(
    SqlBuilder builder,
    string connection,
    out SqlConnection conn
)
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Shared Function ExecReader ( _
    builder As SqlBuilder, _
    connection As String, _
    <OutAttribute> ByRef conn As SqlConnection _
) As SqlDataReader
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public:
static SqlDataReader^ ExecReader(
    SqlBuilder^ builder,
    String^ connection,
    [OutAttribute] SqlConnection^% conn
)

Parameters

builder
Type: Sitecore.Data.Sql..::..SqlBuilder
A builder.
connection
Type: System..::..String
A SQL Server connection string.
conn
Type: System.Data.SqlClient..::..SqlConnection %
The resulting SQL connection object.

Return Value

The result dataset from the SQL Server.

Remarks

The connection that is created from the connection string is returned in the conn parameter.

Examples

CopyC#
SqlConnection conn = null;
SqlDataReader reader = SqlUtil.ExecReader("select * from customers", myConnection, out conn);
while (reader.Read()) {
  ...
}

See Also

SqlUtil Class
ExecReader Overload
Sitecore.Data.Sql Namespace


ExecReader Method (String, Object[], String, SqlConnection)

[image]

Sitecore 6.4.1 API
SqlUtil..::..ExecReader Method (String, array<Object>[]()[][], String, SqlConnection%)
SqlUtil Class Example See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public static SqlDataReader ExecReader(
    string sql,
    Object[] parameters,
    string connection,
    out SqlConnection conn
)
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Shared Function ExecReader ( _
    sql As String, _
    parameters As Object(), _
    connection As String, _
    <OutAttribute> ByRef conn As SqlConnection _
) As SqlDataReader
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public:
static SqlDataReader^ ExecReader(
    String^ sql,
    array<Object^>^ parameters,
    String^ connection,
    [OutAttribute] SqlConnection^% conn
)

Parameters

sql
Type: System..::..String
A string containing an SQL statement.
parameters
Type: array< System..::..Object >[]()[][]

[Missing <param name="parameters"/> documentation for "M:Sitecore.Data.Sql.SqlUtil.ExecReader(System.String,System.Object[],System.String,System.Data.SqlClient.SqlConnection@)"]

connection
Type: System..::..String
A SQL Server connection string.
conn
Type: System.Data.SqlClient..::..SqlConnection %
The resulting SQL connection object.

Return Value

The result dataset from the SQL Server.

Remarks

The connection that is created from the connection string is returned in the conn parameter.

Examples

CopyC#
SqlConnection conn = null;
SqlDataReader reader = SqlUtil.ExecReader("select * from customers", myConnection, out conn);
while (reader.Read()) {
  ...
}

See Also

SqlUtil Class
ExecReader Overload
Sitecore.Data.Sql Namespace


Execute Method

[image]

Sitecore 6.4.1 API
SqlUtil..::..Execute Method
SqlUtil Class Example See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Execute(
    string sql,
    Object[] parameters,
    string connectionString
)
Visual Basic
Public Shared Sub Execute ( _
    sql As String, _
    parameters As Object(), _
    connectionString As String _
)
Visual C++
public:
static void Execute(
    String^ sql,
    array<Object^>^ parameters,
    String^ connectionString
)

Parameters

sql
Type: System..::..String
A string containing an SQL statement.
parameters
Type: array< System..::..Object >[]()[][]

[Missing <param name="parameters"/> documentation for "M:Sitecore.Data.Sql.SqlUtil.Execute(System.String,System.Object[],System.String)"]

connectionString
Type: System..::..String
A SQL Server connection string.

Remarks

The SQL command statement can be an Insert, Delete or Update statement. The result from the command is discarded.

Examples

CopyC#
SqlUtil.ExecCommand("delete * from customers", myConnection);

See Also

SqlUtil Class
Sitecore.Data.Sql Namespace


ExecuteNonQuery Method

[image]

Sitecore 6.4.1 API
SqlUtil..::..ExecuteNonQuery Method
SqlUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void ExecuteNonQuery(
    SqlCommand cmd
)
Visual Basic
Public Shared Sub ExecuteNonQuery ( _
    cmd As SqlCommand _
)
Visual C++
public:
static void ExecuteNonQuery(
    SqlCommand^ cmd
)

Parameters

cmd
Type: System.Data.SqlClient..::..SqlCommand

[Missing <param name="cmd"/> documentation for "M:Sitecore.Data.Sql.SqlUtil.ExecuteNonQuery(System.Data.SqlClient.SqlCommand)"]

See Also

SqlUtil Class
Sitecore.Data.Sql Namespace


ExecuteReader Method

[image] [image]

Sitecore 6.4.1 API
SqlUtil..::..ExecuteReader Method
SqlUtil Class See Also Send Feedback

Overload List

Name | Description
ExecuteReader(SqlCommand) | Executes a reader on a command.
ExecuteReader(String, array<Object>[]()[][], String) | Opens a reader using the specified SQL.

See Also

SqlUtil Class
SqlUtil Members
Sitecore.Data.Sql Namespace


ExecuteReader Method (SqlCommand)

[image]

Sitecore 6.4.1 API
SqlUtil..::..ExecuteReader Method (SqlCommand)
SqlUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static SqlDataReader ExecuteReader(
    SqlCommand cmd
)
Visual Basic
Public Shared Function ExecuteReader ( _
    cmd As SqlCommand _
) As SqlDataReader
Visual C++
public:
static SqlDataReader^ ExecuteReader(
    SqlCommand^ cmd
)

Parameters

cmd
Type: System.Data.SqlClient..::..SqlCommand
The CMD.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Sql.SqlUtil.ExecuteReader(System.Data.SqlClient.SqlCommand)"]

Remarks

The reader is opened with the CloseConnection option, making it simple to use in using(...) scenarios.

See Also

SqlUtil Class
ExecuteReader Overload
Sitecore.Data.Sql Namespace


ExecuteReader Method (String, Object[], String)

[image]

Sitecore 6.4.1 API
SqlUtil..::..ExecuteReader Method (String, array<Object>[]()[][], String)
SqlUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static SqlDataReader ExecuteReader(
    string sql,
    Object[] parameters,
    string connectionString
)
Visual Basic
Public Shared Function ExecuteReader ( _
    sql As String, _
    parameters As Object(), _
    connectionString As String _
) As SqlDataReader
Visual C++
public:
static SqlDataReader^ ExecuteReader(
    String^ sql,
    array<Object^>^ parameters,
    String^ connectionString
)

Parameters

sql
Type: System..::..String
The SQL.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.
connectionString
Type: System..::..String
A valid SQL Server connection string.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Sql.SqlUtil.ExecuteReader(System.String,System.Object[],System.String)"]

Remarks

The reader is opened with the CloseConnection option, making it simple to use in using(...) scenarios.

See Also

SqlUtil Class
ExecuteReader Overload
Sitecore.Data.Sql Namespace


ExecuteScalar Method

[image]

Sitecore 6.4.1 API
SqlUtil..::..ExecuteScalar Method
SqlUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object ExecuteScalar(
    SqlCommand cmd
)
Visual Basic
Public Shared Function ExecuteScalar ( _
    cmd As SqlCommand _
) As Object
Visual C++
public:
static Object^ ExecuteScalar(
    SqlCommand^ cmd
)

Parameters

cmd
Type: System.Data.SqlClient..::..SqlCommand

[Missing <param name="cmd"/> documentation for "M:Sitecore.Data.Sql.SqlUtil.ExecuteScalar(System.Data.SqlClient.SqlCommand)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Sql.SqlUtil.ExecuteScalar(System.Data.SqlClient.SqlCommand)"]

See Also

SqlUtil Class
Sitecore.Data.Sql Namespace


ExtractConnnectionValue Method

[image]

Sitecore 6.4.1 API
SqlUtil..::..ExtractConnnectionValue Method
SqlUtil Class Example See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ExtractConnnectionValue(
    string name,
    string connection
)
Visual Basic
Public Shared Function ExtractConnnectionValue ( _
    name As String, _
    connection As String _
) As String
Visual C++
public:
static String^ ExtractConnnectionValue(
    String^ name,
    String^ connection
)

Parameters

name
Type: System..::..String
Name of the value to extract.
connection
Type: System..::..String
A connection string.

Return Value

The value of the named parameter. If not found, blank is returned.

Examples

CopyC#
string connectionString = "data source=myserver;user id=guest;password=;initial catalog=northwind;Connect Timeout=30";
string userID = SqlUtil.ExtractConnnectionValue("user id"); // guest

See Also

SqlUtil Class
Sitecore.Data.Sql Namespace


GetArray Method

[image] [image]

Sitecore 6.4.1 API
SqlUtil..::..GetArray Method
SqlUtil Class See Also Send Feedback

Overload List

Name | Description
GetArray(SqlBuilder, String) | Gets an array of results from an SQL statement.
GetArray(SqlCommand, Int32, Int32) | Gets an array of results from an SQL statement.
GetArray(String, array<Object>[]()[][], String) | Gets an array of results from an SQL statement.

See Also

SqlUtil Class
SqlUtil Members
Sitecore.Data.Sql Namespace


GetArray Method (SqlBuilder, String)

[image]

Sitecore 6.4.1 API
SqlUtil..::..GetArray Method (SqlBuilder, String)
SqlUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object[] GetArray(
    SqlBuilder builder,
    string connection
)
Visual Basic
Public Shared Function GetArray ( _
    builder As SqlBuilder, _
    connection As String _
) As Object()
Visual C++
public:
static array<Object^>^ GetArray(
    SqlBuilder^ builder,
    String^ connection
)

Parameters

builder
Type: Sitecore.Data.Sql..::..SqlBuilder

[Missing <param name="builder"/> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetArray(Sitecore.Data.Sql.SqlBuilder,System.String)"]

connection
Type: System..::..String

[Missing <param name="connection"/> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetArray(Sitecore.Data.Sql.SqlBuilder,System.String)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetArray(Sitecore.Data.Sql.SqlBuilder,System.String)"]

See Also

SqlUtil Class
GetArray Overload
Sitecore.Data.Sql Namespace


GetArray Method (SqlCommand, Int32, Int32)

[image]

Sitecore 6.4.1 API
SqlUtil..::..GetArray Method (SqlCommand, Int32, Int32)
SqlUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object[] GetArray(
    SqlCommand cmd,
    int fromRow,
    int maxCount
)
Visual Basic
Public Shared Function GetArray ( _
    cmd As SqlCommand, _
    fromRow As Integer, _
    maxCount As Integer _
) As Object()
Visual C++
public:
static array<Object^>^ GetArray(
    SqlCommand^ cmd,
    int fromRow,
    int maxCount
)

Parameters

cmd
Type: System.Data.SqlClient..::..SqlCommand

[Missing <param name="cmd"/> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetArray(System.Data.SqlClient.SqlCommand,System.Int32,System.Int32)"]

fromRow
Type: System..::..Int32

[Missing <param name="fromRow"/> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetArray(System.Data.SqlClient.SqlCommand,System.Int32,System.Int32)"]

maxCount
Type: System..::..Int32

[Missing <param name="maxCount"/> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetArray(System.Data.SqlClient.SqlCommand,System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetArray(System.Data.SqlClient.SqlCommand,System.Int32,System.Int32)"]

See Also

SqlUtil Class
GetArray Overload
Sitecore.Data.Sql Namespace


GetArray Method (String, Object[], String)

[image]

Sitecore 6.4.1 API
SqlUtil..::..GetArray Method (String, array<Object>[]()[][], String)
SqlUtil Class Example See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object[] GetArray(
    string sql,
    Object[] parameters,
    string connection
)
Visual Basic
Public Shared Function GetArray ( _
    sql As String, _
    parameters As Object(), _
    connection As String _
) As Object()
Visual C++
public:
static array<Object^>^ GetArray(
    String^ sql,
    array<Object^>^ parameters,
    String^ connection
)

Parameters

sql
Type: System..::..String
A string containing an SQL statement.
parameters
Type: array< System..::..Object >[]()[][]

[Missing <param name="parameters"/> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetArray(System.String,System.Object[],System.String)"]

connection
Type: System..::..String
A SQL Server connection string.

Return Value

An array of results from the query.

Examples

CopyC#
ArrayList result = SqlUtil.GetArray("select CompanyName from Customers",
  "data source=myserver;user id=guest;password=;initial catalog=northwind;Connect Timeout=30");

See Also

SqlUtil Class
GetArray Overload
Sitecore.Data.Sql Namespace


GetCount Method

[image] [image]

Sitecore 6.4.1 API
SqlUtil..::..GetCount Method
SqlUtil Class See Also Send Feedback

Overload List

Name | Description
GetCount(String, String) | Gets a row count for a table.
GetCount(SqlBuilder, String) | Gets a row count.
GetCount(String, String, array<Object>[]()[][], String) | Gets a row count for a table.

See Also

SqlUtil Class
SqlUtil Members
Sitecore.Data.Sql Namespace


GetCount Method (String, String)

[image]

Sitecore 6.4.1 API
SqlUtil..::..GetCount Method (String, String)
SqlUtil Class Example See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int GetCount(
    string tableName,
    string connection
)
Visual Basic
Public Shared Function GetCount ( _
    tableName As String, _
    connection As String _
) As Integer
Visual C++
public:
static int GetCount(
    String^ tableName,
    String^ connection
)

Parameters

tableName
Type: System..::..String
Name of the table.
connection
Type: System..::..String
A connection string.

Return Value

The number of rows in the table.

Examples

CopyC#
int count = SqlUtil.GetCount("customers", "data source=myserver;user id=guest;password=;initial catalog=northwind;Connect Timeout=30");

See Also

SqlUtil Class
GetCount Overload
Sitecore.Data.Sql Namespace


GetCount Method (String, String, Object[], String)

[image]

Sitecore 6.4.1 API
SqlUtil..::..GetCount Method (String, String, array<Object>[]()[][], String)
SqlUtil Class Example See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int GetCount(
    string tableName,
    string condition,
    Object[] parameters,
    string connection
)
Visual Basic
Public Shared Function GetCount ( _
    tableName As String, _
    condition As String, _
    parameters As Object(), _
    connection As String _
) As Integer
Visual C++
public:
static int GetCount(
    String^ tableName,
    String^ condition,
    array<Object^>^ parameters,
    String^ connection
)

Parameters

tableName
Type: System..::..String
Name of the table.
condition
Type: System..::..String
An SQL where clause.
parameters
Type: array< System..::..Object >[]()[][]

[Missing <param name="parameters"/> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetCount(System.String,System.String,System.Object[],System.String)"]

connection
Type: System..::..String
A connection string.

Return Value

The number of rows in the table.

Remarks

The condition is specified without the "where" keyword.

Examples

CopyC#
int count = SqlUtil.GetCount("customers", "Country='Germany'", "data source=myserver;user id=guest;password=;initial catalog=northwind;Connect Timeout=30");

See Also

SqlUtil Class
GetCount Overload
Sitecore.Data.Sql Namespace


GetDataSet Method

[image]

Sitecore 6.4.1 API
SqlUtil..::..GetDataSet Method
SqlUtil Class Example See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static DataSet GetDataSet(
    string sql,
    string connection,
    int startIndex,
    int maxCount
)
Visual Basic
Public Shared Function GetDataSet ( _
    sql As String, _
    connection As String, _
    startIndex As Integer, _
    maxCount As Integer _
) As DataSet
Visual C++
public:
static DataSet^ GetDataSet(
    String^ sql,
    String^ connection,
    int startIndex,
    int maxCount
)

Parameters

sql
Type: System..::..String
A string containing an SQL statement.
connection
Type: System..::..String
A connection string.
startIndex
Type: System..::..Int32
Starting position for the Dataset object.
maxCount
Type: System..::..Int32
Max number of rows.

Return Value

The created Dataset object.

Examples

The following example gets the first 100 customers from the Customers table.
CopyC#
Dataset dataset = SqlUtil.GetDataset("select * from customers",
  "data source=myserver;user id=guest;password=;initial catalog=northwind;Connect Timeout=30",
  0, 100);

See Also

SqlUtil Class
Sitecore.Data.Sql Namespace


GetFullTextSearchSql Method

[image]

Sitecore 6.4.1 API
SqlUtil..::..GetFullTextSearchSql Method
SqlUtil Class Example See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetFullTextSearchSql(
    string search,
    string table,
    string displayFields,
    string searchFields
)
Visual Basic
Public Shared Function GetFullTextSearchSql ( _
    search As String, _
    table As String, _
    displayFields As String, _
    searchFields As String _
) As String
Visual C++
public:
static String^ GetFullTextSearchSql(
    String^ search,
    String^ table,
    String^ displayFields,
    String^ searchFields
)

Parameters

search
Type: System..::..String
A List of words to search for (separated by spaces).
table
Type: System..::..String
Name of a table to search.
displayFields
Type: System..::..String
A comma separated list of fields to return.
searchFields
Type: System..::..String
A comma separated list of fields to search in.

Return Value

An SQL statement that can be executed.

Remarks

Searches are performed in Google style, ie. all words in search term must be present in result. The search is performed against all fields in the full-text index.

Examples

CopyC#
string sql = SqlUtil.GetFullTextSearchSql("helmet", "products", "description", "description");

See Also

SqlUtil Class
Sitecore.Data.Sql Namespace


GetHashtable Method

[image] [image]

Sitecore 6.4.1 API
SqlUtil..::..GetHashtable Method
SqlUtil Class See Also Send Feedback

Overload List

Name | Description
GetHashtable(SqlCommand) | Gets results from an SQL statement as a hashtable.
GetHashtable(SqlDataReader) | Gets results from an SQL statement as a hashtable.
GetHashtable(String, String) | Gets results from an SQL statement as a hashtable.
GetHashtable(SqlBuilder, String) | Gets results from an SQL statement as a hashtable.

See Also

SqlUtil Class
SqlUtil Members
Sitecore.Data.Sql Namespace


GetHashtable Method (SqlCommand)

[image]

Sitecore 6.4.1 API
SqlUtil..::..GetHashtable Method (SqlCommand)
SqlUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Hashtable GetHashtable(
    SqlCommand cmd
)
Visual Basic
Public Shared Function GetHashtable ( _
    cmd As SqlCommand _
) As Hashtable
Visual C++
public:
static Hashtable^ GetHashtable(
    SqlCommand^ cmd
)

Parameters

cmd
Type: System.Data.SqlClient..::..SqlCommand
A SQL command.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetHashtable(System.Data.SqlClient.SqlCommand)"]

See Also

SqlUtil Class
GetHashtable Overload
Sitecore.Data.Sql Namespace


GetHashtable Method (SqlDataReader)

[image]

Sitecore 6.4.1 API
SqlUtil..::..GetHashtable Method (SqlDataReader)
SqlUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Hashtable GetHashtable(
    SqlDataReader reader
)
Visual Basic
Public Shared Function GetHashtable ( _
    reader As SqlDataReader _
) As Hashtable
Visual C++
public:
static Hashtable^ GetHashtable(
    SqlDataReader^ reader
)

Parameters

reader
Type: System.Data.SqlClient..::..SqlDataReader
A reader.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetHashtable(System.Data.SqlClient.SqlDataReader)"]

See Also

SqlUtil Class
GetHashtable Overload
Sitecore.Data.Sql Namespace


GetHashtable Method (String, String)

[image]

Sitecore 6.4.1 API
SqlUtil..::..GetHashtable Method (String, String)
SqlUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Hashtable GetHashtable(
    string sql,
    string connection
)
Visual Basic
Public Shared Function GetHashtable ( _
    sql As String, _
    connection As String _
) As Hashtable
Visual C++
public:
static Hashtable^ GetHashtable(
    String^ sql,
    String^ connection
)

Parameters

sql
Type: System..::..String
A string containing an SQL statement.
connection
Type: System..::..String
A SQL Server connection string.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetHashtable(System.String,System.String)"]

See Also

SqlUtil Class
GetHashtable Overload
Sitecore.Data.Sql Namespace


GetHashtable Method (SqlBuilder, String)

[image]

Sitecore 6.4.1 API
SqlUtil..::..GetHashtable Method (SqlBuilder, String)
SqlUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Hashtable GetHashtable(
    SqlBuilder builder,
    string connection
)
Visual Basic
Public Shared Function GetHashtable ( _
    builder As SqlBuilder, _
    connection As String _
) As Hashtable
Visual C++
public:
static Hashtable^ GetHashtable(
    SqlBuilder^ builder,
    String^ connection
)

Parameters

builder
Type: Sitecore.Data.Sql..::..SqlBuilder
A SQL builder.
connection
Type: System..::..String
A SQL Server connection string.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetHashtable(Sitecore.Data.Sql.SqlBuilder,System.String)"]

See Also

SqlUtil Class
GetHashtable Overload
Sitecore.Data.Sql Namespace


GetID Method

[image]

Sitecore 6.4.1 API
SqlUtil..::..GetID Method
SqlUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID GetID(
    SqlBuilder builder,
    string connection
)
Visual Basic
Public Shared Function GetID ( _
    builder As SqlBuilder, _
    connection As String _
) As ID
Visual C++
public:
static ID^ GetID(
    SqlBuilder^ builder,
    String^ connection
)

Parameters

builder
Type: Sitecore.Data.Sql..::..SqlBuilder

[Missing <param name="builder"/> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetID(Sitecore.Data.Sql.SqlBuilder,System.String)"]

connection
Type: System..::..String

[Missing <param name="connection"/> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetID(Sitecore.Data.Sql.SqlBuilder,System.String)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetID(Sitecore.Data.Sql.SqlBuilder,System.String)"]

See Also

SqlUtil Class
Sitecore.Data.Sql Namespace


GetIDArray Method

[image] [image]

Sitecore 6.4.1 API
SqlUtil..::..GetIDArray Method
SqlUtil Class See Also Send Feedback

Overload List

Name | Description
GetIDArray(String, String) | Gets an array of results from an SQL statement.
GetIDArray(SqlBuilder, String) | Gets an array of results from an SQL statement.

See Also

SqlUtil Class
SqlUtil Members
Sitecore.Data.Sql Namespace


GetIDArray Method (String, String)

[image]

Sitecore 6.4.1 API
SqlUtil..::..GetIDArray Method (String, String)
SqlUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID[] GetIDArray(
    string sql,
    string connection
)
Visual Basic
Public Shared Function GetIDArray ( _
    sql As String, _
    connection As String _
) As ID()
Visual C++
public:
static array<ID^>^ GetIDArray(
    String^ sql,
    String^ connection
)

Parameters

sql
Type: System..::..String

[Missing <param name="sql"/> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetIDArray(System.String,System.String)"]

connection
Type: System..::..String

[Missing <param name="connection"/> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetIDArray(System.String,System.String)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetIDArray(System.String,System.String)"]

See Also

SqlUtil Class
GetIDArray Overload
Sitecore.Data.Sql Namespace


GetIDArray Method (SqlBuilder, String)

[image]

Sitecore 6.4.1 API
SqlUtil..::..GetIDArray Method (SqlBuilder, String)
SqlUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID[] GetIDArray(
    SqlBuilder builder,
    string connection
)
Visual Basic
Public Shared Function GetIDArray ( _
    builder As SqlBuilder, _
    connection As String _
) As ID()
Visual C++
public:
static array<ID^>^ GetIDArray(
    SqlBuilder^ builder,
    String^ connection
)

Parameters

builder
Type: Sitecore.Data.Sql..::..SqlBuilder

[Missing <param name="builder"/> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetIDArray(Sitecore.Data.Sql.SqlBuilder,System.String)"]

connection
Type: System..::..String

[Missing <param name="connection"/> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetIDArray(Sitecore.Data.Sql.SqlBuilder,System.String)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetIDArray(Sitecore.Data.Sql.SqlBuilder,System.String)"]

See Also

SqlUtil Class
GetIDArray Overload
Sitecore.Data.Sql Namespace


GetInt32 Method

[image]

Sitecore 6.4.1 API
SqlUtil..::..GetInt32 Method
SqlUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int GetInt32(
    string sql,
    Object[] parameters,
    string connectionString,
    int defaultValue
)
Visual Basic
Public Shared Function GetInt32 ( _
    sql As String, _
    parameters As Object(), _
    connectionString As String, _
    defaultValue As Integer _
) As Integer
Visual C++
public:
static int GetInt32(
    String^ sql,
    array<Object^>^ parameters,
    String^ connectionString,
    int defaultValue
)

Parameters

sql
Type: System..::..String
A string containing an SQL statement.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.
connectionString
Type: System..::..String
A SQL Server connection string.
defaultValue
Type: System..::..Int32
The default value.

Return Value

The result of the query as an integer.

See Also

SqlUtil Class
Sitecore.Data.Sql Namespace


GetItemID Method

[image] [image]

Sitecore 6.4.1 API
SqlUtil..::..GetItemID Method
SqlUtil Class See Also Send Feedback

Overload List

Name | Description
GetItemID(SqlCommand) | Gets the item ID.
GetItemID(String, String) | Gets an item ID.
GetItemID(SqlBuilder, String) | Gets an item ID.

See Also

SqlUtil Class
SqlUtil Members
Sitecore.Data.Sql Namespace


GetItemID Method (SqlCommand)

[image]

Sitecore 6.4.1 API
SqlUtil..::..GetItemID Method (SqlCommand)
SqlUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID GetItemID(
    SqlCommand cmd
)
Visual Basic
Public Shared Function GetItemID ( _
    cmd As SqlCommand _
) As ID
Visual C++
public:
static ID^ GetItemID(
    SqlCommand^ cmd
)

Parameters

cmd
Type: System.Data.SqlClient..::..SqlCommand
CMD.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetItemID(System.Data.SqlClient.SqlCommand)"]

See Also

SqlUtil Class
GetItemID Overload
Sitecore.Data.Sql Namespace


GetItemID Method (String, String)

[image]

Sitecore 6.4.1 API
SqlUtil..::..GetItemID Method (String, String)
SqlUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID GetItemID(
    string sql,
    string connection
)
Visual Basic
Public Shared Function GetItemID ( _
    sql As String, _
    connection As String _
) As ID
Visual C++
public:
static ID^ GetItemID(
    String^ sql,
    String^ connection
)

Parameters

sql
Type: System..::..String
SQL.
connection
Type: System..::..String
Connection.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetItemID(System.String,System.String)"]

See Also

SqlUtil Class
GetItemID Overload
Sitecore.Data.Sql Namespace


GetItemID Method (SqlBuilder, String)

[image]

Sitecore 6.4.1 API
SqlUtil..::..GetItemID Method (SqlBuilder, String)
SqlUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID GetItemID(
    SqlBuilder builder,
    string connection
)
Visual Basic
Public Shared Function GetItemID ( _
    builder As SqlBuilder, _
    connection As String _
) As ID
Visual C++
public:
static ID^ GetItemID(
    SqlBuilder^ builder,
    String^ connection
)

Parameters

builder
Type: Sitecore.Data.Sql..::..SqlBuilder
Builder.
connection
Type: System..::..String
Connection.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetItemID(Sitecore.Data.Sql.SqlBuilder,System.String)"]

See Also

SqlUtil Class
GetItemID Overload
Sitecore.Data.Sql Namespace


GetString Method

[image] [image]

Sitecore 6.4.1 API
SqlUtil..::..GetString Method
SqlUtil Class See Also Send Feedback

Overload List

Name | Description
GetString(SqlCommand) | Gets a result string from an SQL command.
GetString(String, String) | Gets a result string from an SQL query.
GetString(SqlBuilder, String) | Gets a result string from an SQL builder.
GetString(String, String, array<Object>[]()[][]) | Gets a string.

See Also

SqlUtil Class
SqlUtil Members
Sitecore.Data.Sql Namespace


GetString Method (SqlCommand)

[image]

Sitecore 6.4.1 API
SqlUtil..::..GetString Method (SqlCommand)
SqlUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetString(
    SqlCommand cmd
)
Visual Basic
Public Shared Function GetString ( _
    cmd As SqlCommand _
) As String
Visual C++
public:
static String^ GetString(
    SqlCommand^ cmd
)

Parameters

cmd
Type: System.Data.SqlClient..::..SqlCommand

[Missing <param name="cmd"/> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetString(System.Data.SqlClient.SqlCommand)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetString(System.Data.SqlClient.SqlCommand)"]

See Also

SqlUtil Class
GetString Overload
Sitecore.Data.Sql Namespace


GetString Method (String, String)

[image]

Sitecore 6.4.1 API
SqlUtil..::..GetString Method (String, String)
SqlUtil Class Example See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetString(
    string sql,
    string connection
)
Visual Basic
Public Shared Function GetString ( _
    sql As String, _
    connection As String _
) As String
Visual C++
public:
static String^ GetString(
    String^ sql,
    String^ connection
)

Parameters

sql
Type: System..::..String
A string containing an SQL statement.
connection
Type: System..::..String
A SQL Server connection string.

Return Value

The result of the query as a string.

Examples

CopyC#
string result = SqlUtil.GetString("select CompanyName from Customers where CustomerName='Alfreds Futterkiste'",
  "data source=myserver;user id=guest;password=;initial catalog=northwind;Connect Timeout=30");

See Also

SqlUtil Class
GetString Overload
Sitecore.Data.Sql Namespace


GetString Method (SqlBuilder, String)

[image]

Sitecore 6.4.1 API
SqlUtil..::..GetString Method (SqlBuilder, String)
SqlUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetString(
    SqlBuilder builder,
    string connection
)
Visual Basic
Public Shared Function GetString ( _
    builder As SqlBuilder, _
    connection As String _
) As String
Visual C++
public:
static String^ GetString(
    SqlBuilder^ builder,
    String^ connection
)

Parameters

builder
Type: Sitecore.Data.Sql..::..SqlBuilder

[Missing <param name="builder"/> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetString(Sitecore.Data.Sql.SqlBuilder,System.String)"]

connection
Type: System..::..String

[Missing <param name="connection"/> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetString(Sitecore.Data.Sql.SqlBuilder,System.String)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetString(Sitecore.Data.Sql.SqlBuilder,System.String)"]

See Also

SqlUtil Class
GetString Overload
Sitecore.Data.Sql Namespace


GetString Method (String, String, Object[])

[image]

Sitecore 6.4.1 API
SqlUtil..::..GetString Method (String, String, array<Object>[]()[][])
SqlUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetString(
    string sql,
    string connection,
    Object[] parameters
)
Visual Basic
Public Shared Function GetString ( _
    sql As String, _
    connection As String, _
    parameters As Object() _
) As String
Visual C++
public:
static String^ GetString(
    String^ sql,
    String^ connection,
    array<Object^>^ parameters
)

Parameters

sql
Type: System..::..String
SQL.
connection
Type: System..::..String
Connection.
parameters
Type: array< System..::..Object >[]()[][]
Parameters.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetString(System.String,System.String,System.Object[])"]

See Also

SqlUtil Class
GetString Overload
Sitecore.Data.Sql Namespace


GetStringArray Method

[image] [image]

Sitecore 6.4.1 API
SqlUtil..::..GetStringArray Method
SqlUtil Class See Also Send Feedback

Overload List

Name | Description
GetStringArray(SqlCommand) | Gets an array of results from an SQL statement.
GetStringArray(String, String) | Gets an array of results from an SQL statement.
GetStringArray(SqlBuilder, String) | Gets an array of results from an SQL statement.
GetStringArray(SqlCommand, Int32, Int32) | Gets an array of results from an SQL statement.
GetStringArray(String, String, Int32, Int32) | Gets an array of results from an SQL statement.
GetStringArray(SqlBuilder, String, Int32, Int32) | Gets an array of results from an SQL statement.

See Also

SqlUtil Class
SqlUtil Members
Sitecore.Data.Sql Namespace


GetStringArray Method (SqlCommand)

[image]

Sitecore 6.4.1 API
SqlUtil..::..GetStringArray Method (SqlCommand)
SqlUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string[] GetStringArray(
    SqlCommand cmd
)
Visual Basic
Public Shared Function GetStringArray ( _
    cmd As SqlCommand _
) As String()
Visual C++
public:
static array<String^>^ GetStringArray(
    SqlCommand^ cmd
)

Parameters

cmd
Type: System.Data.SqlClient..::..SqlCommand

[Missing <param name="cmd"/> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetStringArray(System.Data.SqlClient.SqlCommand)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetStringArray(System.Data.SqlClient.SqlCommand)"]

See Also

SqlUtil Class
GetStringArray Overload
Sitecore.Data.Sql Namespace


GetStringArray Method (String, String)

[image]

Sitecore 6.4.1 API
SqlUtil..::..GetStringArray Method (String, String)
SqlUtil Class Example See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string[] GetStringArray(
    string sql,
    string connection
)
Visual Basic
Public Shared Function GetStringArray ( _
    sql As String, _
    connection As String _
) As String()
Visual C++
public:
static array<String^>^ GetStringArray(
    String^ sql,
    String^ connection
)

Parameters

sql
Type: System..::..String
A string containing an SQL statement.
connection
Type: System..::..String
A SQL Server connection string.

Return Value

An array of results from the query.

Examples

CopyC#
ArrayList result = SqlUtil.GetStringArray("select CompanyName from Customers",
  "data source=myserver;user id=guest;password=;initial catalog=northwind;Connect Timeout=30");

See Also

SqlUtil Class
GetStringArray Overload
Sitecore.Data.Sql Namespace


GetStringArray Method (SqlBuilder, String)

[image]

Sitecore 6.4.1 API
SqlUtil..::..GetStringArray Method (SqlBuilder, String)
SqlUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string[] GetStringArray(
    SqlBuilder builder,
    string connection
)
Visual Basic
Public Shared Function GetStringArray ( _
    builder As SqlBuilder, _
    connection As String _
) As String()
Visual C++
public:
static array<String^>^ GetStringArray(
    SqlBuilder^ builder,
    String^ connection
)

Parameters

builder
Type: Sitecore.Data.Sql..::..SqlBuilder

[Missing <param name="builder"/> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetStringArray(Sitecore.Data.Sql.SqlBuilder,System.String)"]

connection
Type: System..::..String

[Missing <param name="connection"/> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetStringArray(Sitecore.Data.Sql.SqlBuilder,System.String)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetStringArray(Sitecore.Data.Sql.SqlBuilder,System.String)"]

See Also

SqlUtil Class
GetStringArray Overload
Sitecore.Data.Sql Namespace


GetStringArray Method (SqlCommand, Int32, Int32)

[image]

Sitecore 6.4.1 API
SqlUtil..::..GetStringArray Method (SqlCommand, Int32, Int32)
SqlUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string[] GetStringArray(
    SqlCommand cmd,
    int fromRow,
    int count
)
Visual Basic
Public Shared Function GetStringArray ( _
    cmd As SqlCommand, _
    fromRow As Integer, _
    count As Integer _
) As String()
Visual C++
public:
static array<String^>^ GetStringArray(
    SqlCommand^ cmd,
    int fromRow,
    int count
)

Parameters

cmd
Type: System.Data.SqlClient..::..SqlCommand

[Missing <param name="cmd"/> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetStringArray(System.Data.SqlClient.SqlCommand,System.Int32,System.Int32)"]

fromRow
Type: System..::..Int32

[Missing <param name="fromRow"/> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetStringArray(System.Data.SqlClient.SqlCommand,System.Int32,System.Int32)"]

count
Type: System..::..Int32

[Missing <param name="count"/> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetStringArray(System.Data.SqlClient.SqlCommand,System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetStringArray(System.Data.SqlClient.SqlCommand,System.Int32,System.Int32)"]

See Also

SqlUtil Class
GetStringArray Overload
Sitecore.Data.Sql Namespace


GetStringArray Method (String, String, Int32, Int32)

[image]

Sitecore 6.4.1 API
SqlUtil..::..GetStringArray Method (String, String, Int32, Int32)
SqlUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string[] GetStringArray(
    string sql,
    string connection,
    int fromRow,
    int count
)
Visual Basic
Public Shared Function GetStringArray ( _
    sql As String, _
    connection As String, _
    fromRow As Integer, _
    count As Integer _
) As String()
Visual C++
public:
static array<String^>^ GetStringArray(
    String^ sql,
    String^ connection,
    int fromRow,
    int count
)

Parameters

sql
Type: System..::..String

[Missing <param name="sql"/> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetStringArray(System.String,System.String,System.Int32,System.Int32)"]

connection
Type: System..::..String

[Missing <param name="connection"/> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetStringArray(System.String,System.String,System.Int32,System.Int32)"]

fromRow
Type: System..::..Int32

[Missing <param name="fromRow"/> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetStringArray(System.String,System.String,System.Int32,System.Int32)"]

count
Type: System..::..Int32

[Missing <param name="count"/> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetStringArray(System.String,System.String,System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetStringArray(System.String,System.String,System.Int32,System.Int32)"]

See Also

SqlUtil Class
GetStringArray Overload
Sitecore.Data.Sql Namespace


GetStringArray Method (SqlBuilder, String, Int32, Int32)

[image]

Sitecore 6.4.1 API
SqlUtil..::..GetStringArray Method (SqlBuilder, String, Int32, Int32)
SqlUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string[] GetStringArray(
    SqlBuilder builder,
    string connection,
    int fromRow,
    int count
)
Visual Basic
Public Shared Function GetStringArray ( _
    builder As SqlBuilder, _
    connection As String, _
    fromRow As Integer, _
    count As Integer _
) As String()
Visual C++
public:
static array<String^>^ GetStringArray(
    SqlBuilder^ builder,
    String^ connection,
    int fromRow,
    int count
)

Parameters

builder
Type: Sitecore.Data.Sql..::..SqlBuilder

[Missing <param name="builder"/> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetStringArray(Sitecore.Data.Sql.SqlBuilder,System.String,System.Int32,System.Int32)"]

connection
Type: System..::..String

[Missing <param name="connection"/> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetStringArray(Sitecore.Data.Sql.SqlBuilder,System.String,System.Int32,System.Int32)"]

fromRow
Type: System..::..Int32

[Missing <param name="fromRow"/> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetStringArray(Sitecore.Data.Sql.SqlBuilder,System.String,System.Int32,System.Int32)"]

count
Type: System..::..Int32

[Missing <param name="count"/> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetStringArray(Sitecore.Data.Sql.SqlBuilder,System.String,System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetStringArray(Sitecore.Data.Sql.SqlBuilder,System.String,System.Int32,System.Int32)"]

See Also

SqlUtil Class
GetStringArray Overload
Sitecore.Data.Sql Namespace


GetStringSet Method

[image]

Sitecore 6.4.1 API
SqlUtil..::..GetStringSet Method
SqlUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Set<string> GetStringSet(
    string sql,
    Object[] parameters,
    string connectionString
)
Visual Basic
Public Shared Function GetStringSet ( _
    sql As String, _
    parameters As Object(), _
    connectionString As String _
) As Set(Of String)
Visual C++
public:
static Set<String^>^ GetStringSet(
    String^ sql,
    array<Object^>^ parameters,
    String^ connectionString
)

Parameters

sql
Type: System..::..String
The SQL.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.
connectionString
Type: System..::..String
The connection string.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Sql.SqlUtil.GetStringSet(System.String,System.Object[],System.String)"]

See Also

SqlUtil Class
Sitecore.Data.Sql Namespace


MapType Method

[image]

Sitecore 6.4.1 API
SqlUtil..::..MapType Method
SqlUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static SqlDbType MapType(
    Object value
)
Visual Basic
Public Shared Function MapType ( _
    value As Object _
) As SqlDbType
Visual C++
public:
static SqlDbType MapType(
    Object^ value
)

Parameters

value
Type: System..::..Object
Value.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Sql.SqlUtil.MapType(System.Object)"]

See Also

SqlUtil Class
Sitecore.Data.Sql Namespace


ObfuscatePassword Method

[image]

Sitecore 6.4.1 API
SqlUtil..::..ObfuscatePassword Method
SqlUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ObfuscatePassword(
    string connection
)
Visual Basic
Public Shared Function ObfuscatePassword ( _
    connection As String _
) As String
Visual C++
public:
static String^ ObfuscatePassword(
    String^ connection
)

Parameters

connection
Type: System..::..String

[Missing <param name="connection"/> documentation for "M:Sitecore.Data.Sql.SqlUtil.ObfuscatePassword(System.String)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Sql.SqlUtil.ObfuscatePassword(System.String)"]

See Also

SqlUtil Class
Sitecore.Data.Sql Namespace


Safe Method (DateTime)

[image]

Sitecore 6.4.1 API
SqlUtil..::..Safe Method (DateTime)
SqlUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static DateTime Safe(
    DateTime date
)
Visual Basic
Public Shared Function Safe ( _
    date As DateTime _
) As DateTime
Visual C++
public:
static DateTime Safe(
    DateTime date
)

Parameters

date
Type: System..::..DateTime
Date.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Sql.SqlUtil.Safe(System.DateTime)"]

See Also

SqlUtil Class
Safe Overload
Sitecore.Data.Sql Namespace


Safe Method (String)

[image]

Sitecore 6.4.1 API
SqlUtil..::..Safe Method (String)
SqlUtil Class Example See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Safe(
    string text
)
Visual Basic
Public Shared Function Safe ( _
    text As String _
) As String
Visual C++
public:
static String^ Safe(
    String^ text
)

Parameters

text
Type: System..::..String
A string.

Return Value

The escaped string.

Remarks

This function replaces a single quote with two single quotes.

Examples

CopyC#
string parameter = SqlUtil.Safe("Andy's"); // "Andy''s"

See Also

SqlUtil Class
Safe Overload
Sitecore.Data.Sql Namespace


StripPasswords Method

[image]

Sitecore 6.4.1 API
SqlUtil..::..StripPasswords Method
SqlUtil Class See Also Send Feedback

Namespace: Sitecore.Data.Sql
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string StripPasswords(
    string connectionString
)
Visual Basic
Public Shared Function StripPasswords ( _
    connectionString As String _
) As String
Visual C++
public:
static String^ StripPasswords(
    String^ connectionString
)

Parameters

connectionString
Type: System..::..String
The connection string.

Return Value

The connection string with password removed.

See Also

SqlUtil Class
Sitecore.Data.Sql Namespace


Sitecore.Data.SqlServer Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Data.SqlServer Namespace
Send Feedback

Classes

 | Class | Description
Public class | SqlServerApi |
Public class | SqlServerClientDataStore | SqlServerClientDataStore
Public class | SqlServerCommand |
Public class | SqlServerCommandBatch | Defines the SQL server command batch class.
Public class | SqlServerConnectionInfo |
Public class | SqlServerDataApi | Class implementing the SQL Server data API.
Public class | SqlServerDataProvider | SQL Server based data provider.
Public class | SqlServerHistoryStorage | SqlServerHistoryStorage
Public class | SqlServerHistoryStore | SqlServerHistoryStore
Public class | SqlServerIDTable | The IDTable SqlServer provider
Public class | SqlServerLinkDatabase | Represents a SQL Server link database.
Public class | SqlServerProxyDataProvider | SQL Server based proxy data provider.
Public class | SqlServerTaskDatabase | SqlTaskDatabase provider.


SqlServerApi Class

[image]

Sitecore 6.4.1 API
SqlServerApi Class
Members See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SqlServerApi
Visual Basic
Public Class SqlServerApi
Visual C++
public ref class SqlServerApi

Inheritance Hierarchy

System..::..Object
Sitecore.Data.SqlServer..::..SqlServerApi

See Also

SqlServerApi Members
Sitecore.Data.SqlServer Namespace


SqlServerApi Constructor

[image]

Sitecore 6.4.1 API
SqlServerApi Constructor
SqlServerApi Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlServerApi(
    string connection
)
Visual Basic
Public Sub New ( _
    connection As String _
)
Visual C++
public:
SqlServerApi(
    String^ connection
)

Parameters

connection
Type: System..::..String

[Missing <param name="connection"/> documentation for "M:Sitecore.Data.SqlServer.SqlServerApi.#ctor(System.String)"]

See Also

SqlServerApi Class
Sitecore.Data.SqlServer Namespace


SqlServerApi Methods

[image] [image]

Sitecore 6.4.1 API
SqlServerApi Methods
SqlServerApi Class See Also Send Feedback

The SqlServerApi type exposes the following members.

Methods

 | Name | Description
Public method | CreateReader |
Public method | CreateTransactionScope |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute |
Public method | Exists |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCount |
Public method | GetDateTime |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetID |
Public method | GetInt32 |
Public method | GetString |
Public method | GetTopValues |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Safe | Escapes a string for use in SQL statements.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SqlServerApi Class
Sitecore.Data.SqlServer Namespace


CreateReader Method

[image]

Sitecore 6.4.1 API
SqlServerApi..::..CreateReader Method
SqlServerApi Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataProviderReader CreateReader(
    string sql,
    params Object[] parameters
)
Visual Basic
Public Function CreateReader ( _
    sql As String, _
    ParamArray parameters As Object() _
) As DataProviderReader
Visual C++
public:
DataProviderReader^ CreateReader(
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

sql
Type: System..::..String

[Missing <param name="sql"/> documentation for "M:Sitecore.Data.SqlServer.SqlServerApi.CreateReader(System.String,System.Object[])"]

parameters
Type: array< System..::..Object >[]()[][]

[Missing <param name="parameters"/> documentation for "M:Sitecore.Data.SqlServer.SqlServerApi.CreateReader(System.String,System.Object[])"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.SqlServer.SqlServerApi.CreateReader(System.String,System.Object[])"]

See Also

SqlServerApi Class
Sitecore.Data.SqlServer Namespace


CreateTransactionScope Method

[image]

Sitecore 6.4.1 API
SqlServerApi..::..CreateTransactionScope Method
SqlServerApi Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DataProviderTransaction CreateTransactionScope()
Visual Basic
Public Function CreateTransactionScope As DataProviderTransaction
Visual C++
public:
DataProviderTransaction^ CreateTransactionScope()

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.SqlServer.SqlServerApi.CreateTransactionScope"]

See Also

SqlServerApi Class
Sitecore.Data.SqlServer Namespace


Execute Method

[image]

Sitecore 6.4.1 API
SqlServerApi..::..Execute Method
SqlServerApi Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Execute(
    string sql,
    params Object[] parameters
)
Visual Basic
Public Sub Execute ( _
    sql As String, _
    ParamArray parameters As Object() _
)
Visual C++
public:
void Execute(
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

sql
Type: System..::..String

[Missing <param name="sql"/> documentation for "M:Sitecore.Data.SqlServer.SqlServerApi.Execute(System.String,System.Object[])"]

parameters
Type: array< System..::..Object >[]()[][]

[Missing <param name="parameters"/> documentation for "M:Sitecore.Data.SqlServer.SqlServerApi.Execute(System.String,System.Object[])"]

See Also

SqlServerApi Class
Sitecore.Data.SqlServer Namespace


Exists Method

[image]

Sitecore 6.4.1 API
SqlServerApi..::..Exists Method
SqlServerApi Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Exists(
    string sql,
    params Object[] parameters
)
Visual Basic
Public Function Exists ( _
    sql As String, _
    ParamArray parameters As Object() _
) As Boolean
Visual C++
public:
bool Exists(
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

sql
Type: System..::..String

[Missing <param name="sql"/> documentation for "M:Sitecore.Data.SqlServer.SqlServerApi.Exists(System.String,System.Object[])"]

parameters
Type: array< System..::..Object >[]()[][]

[Missing <param name="parameters"/> documentation for "M:Sitecore.Data.SqlServer.SqlServerApi.Exists(System.String,System.Object[])"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.SqlServer.SqlServerApi.Exists(System.String,System.Object[])"]

See Also

SqlServerApi Class
Sitecore.Data.SqlServer Namespace


GetCount Method

[image]

Sitecore 6.4.1 API
SqlServerApi..::..GetCount Method
SqlServerApi Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int GetCount(
    string sql,
    params Object[] parameters
)
Visual Basic
Public Function GetCount ( _
    sql As String, _
    ParamArray parameters As Object() _
) As Integer
Visual C++
public:
int GetCount(
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

sql
Type: System..::..String

[Missing <param name="sql"/> documentation for "M:Sitecore.Data.SqlServer.SqlServerApi.GetCount(System.String,System.Object[])"]

parameters
Type: array< System..::..Object >[]()[][]

[Missing <param name="parameters"/> documentation for "M:Sitecore.Data.SqlServer.SqlServerApi.GetCount(System.String,System.Object[])"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.SqlServer.SqlServerApi.GetCount(System.String,System.Object[])"]

See Also

SqlServerApi Class
Sitecore.Data.SqlServer Namespace


GetDateTime Method

[image]

Sitecore 6.4.1 API
SqlServerApi..::..GetDateTime Method
SqlServerApi Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime GetDateTime(
    Object value
)
Visual Basic
Public Function GetDateTime ( _
    value As Object _
) As DateTime
Visual C++
public:
DateTime GetDateTime(
    Object^ value
)

Parameters

value
Type: System..::..Object

[Missing <param name="value"/> documentation for "M:Sitecore.Data.SqlServer.SqlServerApi.GetDateTime(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.SqlServer.SqlServerApi.GetDateTime(System.Object)"]

See Also

SqlServerApi Class
Sitecore.Data.SqlServer Namespace


GetID Method

[image]

Sitecore 6.4.1 API
SqlServerApi..::..GetID Method
SqlServerApi Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID GetID(
    Object value
)
Visual Basic
Public Function GetID ( _
    value As Object _
) As ID
Visual C++
public:
ID^ GetID(
    Object^ value
)

Parameters

value
Type: System..::..Object

[Missing <param name="value"/> documentation for "M:Sitecore.Data.SqlServer.SqlServerApi.GetID(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.SqlServer.SqlServerApi.GetID(System.Object)"]

See Also

SqlServerApi Class
Sitecore.Data.SqlServer Namespace


GetInt32 Method

[image]

Sitecore 6.4.1 API
SqlServerApi..::..GetInt32 Method
SqlServerApi Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int GetInt32(
    Object value
)
Visual Basic
Public Function GetInt32 ( _
    value As Object _
) As Integer
Visual C++
public:
int GetInt32(
    Object^ value
)

Parameters

value
Type: System..::..Object

[Missing <param name="value"/> documentation for "M:Sitecore.Data.SqlServer.SqlServerApi.GetInt32(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.SqlServer.SqlServerApi.GetInt32(System.Object)"]

See Also

SqlServerApi Class
Sitecore.Data.SqlServer Namespace


GetString Method

[image]

Sitecore 6.4.1 API
SqlServerApi..::..GetString Method
SqlServerApi Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetString(
    Object value
)
Visual Basic
Public Function GetString ( _
    value As Object _
) As String
Visual C++
public:
String^ GetString(
    Object^ value
)

Parameters

value
Type: System..::..Object

[Missing <param name="value"/> documentation for "M:Sitecore.Data.SqlServer.SqlServerApi.GetString(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.SqlServer.SqlServerApi.GetString(System.Object)"]

See Also

SqlServerApi Class
Sitecore.Data.SqlServer Namespace


GetTopValues Method

[image]

Sitecore 6.4.1 API
SqlServerApi..::..GetTopValues Method
SqlServerApi Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ArrayList GetTopValues(
    string sql,
    int maxRecords,
    params Object[] parameters
)
Visual Basic
Public Function GetTopValues ( _
    sql As String, _
    maxRecords As Integer, _
    ParamArray parameters As Object() _
) As ArrayList
Visual C++
public:
ArrayList^ GetTopValues(
    String^ sql,
    int maxRecords,
    ... array<Object^>^ parameters
)

Parameters

sql
Type: System..::..String

[Missing <param name="sql"/> documentation for "M:Sitecore.Data.SqlServer.SqlServerApi.GetTopValues(System.String,System.Int32,System.Object[])"]

maxRecords
Type: System..::..Int32

[Missing <param name="maxRecords"/> documentation for "M:Sitecore.Data.SqlServer.SqlServerApi.GetTopValues(System.String,System.Int32,System.Object[])"]

parameters
Type: array< System..::..Object >[]()[][]

[Missing <param name="parameters"/> documentation for "M:Sitecore.Data.SqlServer.SqlServerApi.GetTopValues(System.String,System.Int32,System.Object[])"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.SqlServer.SqlServerApi.GetTopValues(System.String,System.Int32,System.Object[])"]

See Also

SqlServerApi Class
Sitecore.Data.SqlServer Namespace


GetValues Method

[image]

Sitecore 6.4.1 API
SqlServerApi..::..GetValues Method
SqlServerApi Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ArrayList GetValues(
    string sql,
    params Object[] parameters
)
Visual Basic
Public Function GetValues ( _
    sql As String, _
    ParamArray parameters As Object() _
) As ArrayList
Visual C++
public:
ArrayList^ GetValues(
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

sql
Type: System..::..String

[Missing <param name="sql"/> documentation for "M:Sitecore.Data.SqlServer.SqlServerApi.GetValues(System.String,System.Object[])"]

parameters
Type: array< System..::..Object >[]()[][]

[Missing <param name="parameters"/> documentation for "M:Sitecore.Data.SqlServer.SqlServerApi.GetValues(System.String,System.Object[])"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.SqlServer.SqlServerApi.GetValues(System.String,System.Object[])"]

See Also

SqlServerApi Class
Sitecore.Data.SqlServer Namespace


Safe Method

[image]

Sitecore 6.4.1 API
SqlServerApi..::..Safe Method
SqlServerApi Class Example See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Safe(
    string text
)
Visual Basic
Public Function Safe ( _
    text As String _
) As String
Visual C++
public:
String^ Safe(
    String^ text
)

Parameters

text
Type: System..::..String
A string.

Return Value

The escaped string.

Remarks

This function replaces a single quote with two single quotes.

Examples

CopyC#
string parameter = SqlUtil.Safe("Andy's"); // "Andy''s"

See Also

SqlServerApi Class
Sitecore.Data.SqlServer Namespace


SqlServerApi Properties

[image] [image]

Sitecore 6.4.1 API
SqlServerApi Properties
SqlServerApi Class See Also Send Feedback

The SqlServerApi type exposes the following members.

Properties

 | Name | Description
Public property | CommandTimeout | Gets the timeout used when issuing SQL Server commands.

See Also

SqlServerApi Class
Sitecore.Data.SqlServer Namespace


CommandTimeout Property

[image]

Sitecore 6.4.1 API
SqlServerApi..::..CommandTimeout Property
SqlServerApi Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TimeSpan CommandTimeout { get; set; }
Visual Basic
Public Property CommandTimeout As TimeSpan
    Get
    Set
Visual C++
public:
property TimeSpan CommandTimeout {
    TimeSpan get ();
    void set (TimeSpan value);
}

See Also

SqlServerApi Class
Sitecore.Data.SqlServer Namespace


SqlServerClientDataStore Class

[image]

Sitecore 6.4.1 API
SqlServerClientDataStore Class
Members See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SqlServerClientDataStore : ClientDataStore
Visual Basic
Public Class SqlServerClientDataStore _
    Inherits ClientDataStore
Visual C++
public ref class SqlServerClientDataStore : public ClientDataStore

Inheritance Hierarchy

System..::..Object
Sitecore.Configuration..::..ClientDataStore
Sitecore.Data.SqlServer..::..SqlServerClientDataStore

See Also

SqlServerClientDataStore Members
Sitecore.Data.SqlServer Namespace


SqlServerClientDataStore Members

[image] [image]

Sitecore 6.4.1 API
SqlServerClientDataStore Members
SqlServerClientDataStore Class Constructors Methods Fields Properties See Also Send Feedback

The SqlServerClientDataStore type exposes the following members.

Constructors

 | Name | Description
Public method | SqlServerClientDataStore(String, String) | Initializes a new instance of the SqlServerClientDataStore class.
Public method | SqlServerClientDataStore(SqlDataApi, String) | Initializes a new instance of the SqlServerClientDataStore class.

Methods

 | Name | Description
Protected method | AddDataToCache | Adds data to the cache. (Inherited from ClientDataStore.)
Public method | Compact | Compacts this instance. (Inherited from ClientDataStore.)
Protected method | CompactData | Compacts the data. (Overrides ClientDataStore..::..CompactData()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Exists | Check if data satisfying the specified SQL exists.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetDataFromCache | Gets data from the cache. (Inherited from ClientDataStore.)
Protected method | GetDataKey | Gets the data key. (Inherited from ClientDataStore.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSize | Gets the size of newly returned data. (Overrides ClientDataStore..::..GetSize(Hashtable).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the value. (Inherited from ClientDataStore.)
Public method | GetValueNames | Gets the value names. (Inherited from ClientDataStore.)
Protected method | LoadData()()()() | Loads the data. (Inherited from ClientDataStore.)
Protected method | LoadData(String) | Loads the data. (Overrides ClientDataStore..::..LoadData(String).)
Public method | LoadViewstate | Loads the viewstate. (Inherited from ClientDataStore.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveAll | Removes the values. (Inherited from ClientDataStore.)
Protected method | RemoveAllData | Removes all Client data. (Overrides ClientDataStore..::..RemoveAllData()()()().)
Protected method | RemoveData()()()() | Removes the data. (Inherited from ClientDataStore.)
Protected method | RemoveData(String) | Removes the data. (Overrides ClientDataStore..::..RemoveData(String).)
Protected method | RemoveDataFromCache | Removes data from the cache. (Inherited from ClientDataStore.)
Public method | RemoveValue | Removes the value. (Inherited from ClientDataStore.)
Public method | RemoveValues | Removes the values. (Inherited from ClientDataStore.)
Public method | RemoveViewstate | Removes the viewstate. (Inherited from ClientDataStore.)
Protected method | SaveData(Hashtable) | Saves the data. (Inherited from ClientDataStore.)
Protected method | SaveData(String, String) | Saves the data. (Overrides ClientDataStore..::..SaveData(String, String).)
Public method | SaveViewstate | Saves the viewstate. (Inherited from ClientDataStore.)
Public method | SetValue(String, String) | Sets the value. (Inherited from ClientDataStore.)
Public method | SetValue(String, Object, String) | Sets the value. (Inherited from ClientDataStore.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TouchActiveData | Touches all active data. (Inherited from ClientDataStore.)
Protected method | TouchData | Touches the data represented by key. (Overrides ClientDataStore..::..TouchData(String).)

Fields

 | Name | Description
Protected field | _api | The Server API

Properties

 | Name | Description
Public property | ObjectLifetime | Gets the object lifetime. (Inherited from ClientDataStore.)

See Also

SqlServerClientDataStore Class
Sitecore.Data.SqlServer Namespace


SqlServerClientDataStore Constructor

[image] [image]

Sitecore 6.4.1 API
SqlServerClientDataStore Constructor
SqlServerClientDataStore Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SqlServerClientDataStore(String, String) | Initializes a new instance of the SqlServerClientDataStore class.
Public method | SqlServerClientDataStore(SqlDataApi, String) | Initializes a new instance of the SqlServerClientDataStore class.

See Also

SqlServerClientDataStore Class
SqlServerClientDataStore Members
Sitecore.Data.SqlServer Namespace


SqlServerClientDataStore Constructor (String, String)

[image]

Sitecore 6.4.1 API
SqlServerClientDataStore Constructor (String, String)
SqlServerClientDataStore Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlServerClientDataStore(
    string connectionString,
    string objectLifetime
)
Visual Basic
Public Sub New ( _
    connectionString As String, _
    objectLifetime As String _
)
Visual C++
public:
SqlServerClientDataStore(
    String^ connectionString,
    String^ objectLifetime
)

Parameters

connectionString
Type: System..::..String
The connection string.
objectLifetime
Type: System..::..String
The object lifetime.

See Also

SqlServerClientDataStore Class
SqlServerClientDataStore Overload
Sitecore.Data.SqlServer Namespace


SqlServerClientDataStore Constructor (SqlDataApi, String)

[image]

Sitecore 6.4.1 API
SqlServerClientDataStore Constructor (SqlDataApi, String)
SqlServerClientDataStore Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlServerClientDataStore(
    SqlDataApi api,
    string objectLifetime
)
Visual Basic
Public Sub New ( _
    api As SqlDataApi, _
    objectLifetime As String _
)
Visual C++
public:
SqlServerClientDataStore(
    SqlDataApi^ api,
    String^ objectLifetime
)

Parameters

api
Type: Sitecore.Data.DataProviders.Sql..::..SqlDataApi
The API.
objectLifetime
Type: System..::..String
The object lifetime.

See Also

SqlServerClientDataStore Class
SqlServerClientDataStore Overload
Sitecore.Data.SqlServer Namespace


SqlServerClientDataStore Fields

[image] [image]

Sitecore 6.4.1 API
SqlServerClientDataStore Fields
SqlServerClientDataStore Class See Also Send Feedback

The SqlServerClientDataStore type exposes the following members.

Fields

 | Name | Description
Protected field | _api | The Server API

See Also

SqlServerClientDataStore Class
Sitecore.Data.SqlServer Namespace


_api Field

[image]

Sitecore 6.4.1 API
SqlServerClientDataStore..::.._api Field
SqlServerClientDataStore Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected SqlDataApi _api
Visual Basic
Protected _api As SqlDataApi
Visual C++
protected:
SqlDataApi^ _api

See Also

SqlServerClientDataStore Class
Sitecore.Data.SqlServer Namespace


SqlServerClientDataStore Methods

[image] [image]

Sitecore 6.4.1 API
SqlServerClientDataStore Methods
SqlServerClientDataStore Class See Also Send Feedback

The SqlServerClientDataStore type exposes the following members.

Methods

 | Name | Description
Protected method | AddDataToCache | Adds data to the cache. (Inherited from ClientDataStore.)
Public method | Compact | Compacts this instance. (Inherited from ClientDataStore.)
Protected method | CompactData | Compacts the data. (Overrides ClientDataStore..::..CompactData()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Exists | Check if data satisfying the specified SQL exists.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetDataFromCache | Gets data from the cache. (Inherited from ClientDataStore.)
Protected method | GetDataKey | Gets the data key. (Inherited from ClientDataStore.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSize | Gets the size of newly returned data. (Overrides ClientDataStore..::..GetSize(Hashtable).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the value. (Inherited from ClientDataStore.)
Public method | GetValueNames | Gets the value names. (Inherited from ClientDataStore.)
Protected method | LoadData()()()() | Loads the data. (Inherited from ClientDataStore.)
Protected method | LoadData(String) | Loads the data. (Overrides ClientDataStore..::..LoadData(String).)
Public method | LoadViewstate | Loads the viewstate. (Inherited from ClientDataStore.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveAll | Removes the values. (Inherited from ClientDataStore.)
Protected method | RemoveAllData | Removes all Client data. (Overrides ClientDataStore..::..RemoveAllData()()()().)
Protected method | RemoveData()()()() | Removes the data. (Inherited from ClientDataStore.)
Protected method | RemoveData(String) | Removes the data. (Overrides ClientDataStore..::..RemoveData(String).)
Protected method | RemoveDataFromCache | Removes data from the cache. (Inherited from ClientDataStore.)
Public method | RemoveValue | Removes the value. (Inherited from ClientDataStore.)
Public method | RemoveValues | Removes the values. (Inherited from ClientDataStore.)
Public method | RemoveViewstate | Removes the viewstate. (Inherited from ClientDataStore.)
Protected method | SaveData(Hashtable) | Saves the data. (Inherited from ClientDataStore.)
Protected method | SaveData(String, String) | Saves the data. (Overrides ClientDataStore..::..SaveData(String, String).)
Public method | SaveViewstate | Saves the viewstate. (Inherited from ClientDataStore.)
Public method | SetValue(String, String) | Sets the value. (Inherited from ClientDataStore.)
Public method | SetValue(String, Object, String) | Sets the value. (Inherited from ClientDataStore.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TouchActiveData | Touches all active data. (Inherited from ClientDataStore.)
Protected method | TouchData | Touches the data represented by key. (Overrides ClientDataStore..::..TouchData(String).)

See Also

SqlServerClientDataStore Class
Sitecore.Data.SqlServer Namespace


CompactData Method

[image]

Sitecore 6.4.1 API
SqlServerClientDataStore..::..CompactData Method
SqlServerClientDataStore Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void CompactData()
Visual Basic
Protected Overrides Sub CompactData
Visual C++
protected:
virtual void CompactData() override

See Also

SqlServerClientDataStore Class
Sitecore.Data.SqlServer Namespace


Exists Method

[image]

Sitecore 6.4.1 API
SqlServerClientDataStore..::..Exists Method
SqlServerClientDataStore Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected bool Exists(
    string key
)
Visual Basic
Protected Function Exists ( _
    key As String _
) As Boolean
Visual C++
protected:
bool Exists(
    String^ key
)

Parameters

key
Type: System..::..String

[Missing <param name="key"/> documentation for "M:Sitecore.Data.SqlServer.SqlServerClientDataStore.Exists(System.String)"]

Return Value

True, if data is found, false otherwise.

See Also

SqlServerClientDataStore Class
Sitecore.Data.SqlServer Namespace


GetSize Method

[image]

Sitecore 6.4.1 API
SqlServerClientDataStore..::..GetSize Method
SqlServerClientDataStore Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override long GetSize(
    Hashtable data
)
Visual Basic
Protected Overrides Function GetSize ( _
    data As Hashtable _
) As Long
Visual C++
protected:
virtual long long GetSize(
    Hashtable^ data
) override

Parameters

data
Type: System.Collections..::..Hashtable
The data.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.SqlServer.SqlServerClientDataStore.GetSize(System.Collections.Hashtable)"]

See Also

SqlServerClientDataStore Class
Sitecore.Data.SqlServer Namespace


LoadData Method

[image] [image]

Sitecore 6.4.1 API
SqlServerClientDataStore..::..LoadData Method
SqlServerClientDataStore Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | LoadData()()()() | Loads the data. (Inherited from ClientDataStore.)
Protected method | LoadData(String) | Loads the data. (Overrides ClientDataStore..::..LoadData(String).)

See Also

SqlServerClientDataStore Class
SqlServerClientDataStore Members
Sitecore.Data.SqlServer Namespace


LoadData Method (String)

[image]

Sitecore 6.4.1 API
SqlServerClientDataStore..::..LoadData Method (String)
SqlServerClientDataStore Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override string LoadData(
    string key
)
Visual Basic
Protected Overrides Function LoadData ( _
    key As String _
) As String
Visual C++
protected:
virtual String^ LoadData(
    String^ key
) override

Parameters

key
Type: System..::..String
The key.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.SqlServer.SqlServerClientDataStore.LoadData(System.String)"]

See Also

SqlServerClientDataStore Class
LoadData Overload
Sitecore.Data.SqlServer Namespace


RemoveAllData Method

[image]

Sitecore 6.4.1 API
SqlServerClientDataStore..::..RemoveAllData Method
SqlServerClientDataStore Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void RemoveAllData()
Visual Basic
Protected Overrides Sub RemoveAllData
Visual C++
protected:
virtual void RemoveAllData() override

See Also

SqlServerClientDataStore Class
Sitecore.Data.SqlServer Namespace


RemoveData Method

[image] [image]

Sitecore 6.4.1 API
SqlServerClientDataStore..::..RemoveData Method
SqlServerClientDataStore Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RemoveData()()()() | Removes the data. (Inherited from ClientDataStore.)
Protected method | RemoveData(String) | Removes the data. (Overrides ClientDataStore..::..RemoveData(String).)

See Also

SqlServerClientDataStore Class
SqlServerClientDataStore Members
Sitecore.Data.SqlServer Namespace


RemoveData Method (String)

[image]

Sitecore 6.4.1 API
SqlServerClientDataStore..::..RemoveData Method (String)
SqlServerClientDataStore Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void RemoveData(
    string key
)
Visual Basic
Protected Overrides Sub RemoveData ( _
    key As String _
)
Visual C++
protected:
virtual void RemoveData(
    String^ key
) override

Parameters

key
Type: System..::..String
The key.

See Also

SqlServerClientDataStore Class
RemoveData Overload
Sitecore.Data.SqlServer Namespace


SaveData Method

[image] [image]

Sitecore 6.4.1 API
SqlServerClientDataStore..::..SaveData Method
SqlServerClientDataStore Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SaveData(Hashtable) | Saves the data. (Inherited from ClientDataStore.)
Protected method | SaveData(String, String) | Saves the data. (Overrides ClientDataStore..::..SaveData(String, String).)

See Also

SqlServerClientDataStore Class
SqlServerClientDataStore Members
Sitecore.Data.SqlServer Namespace


SaveData Method (String, String)

[image]

Sitecore 6.4.1 API
SqlServerClientDataStore..::..SaveData Method (String, String)
SqlServerClientDataStore Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void SaveData(
    string key,
    string data
)
Visual Basic
Protected Overrides Sub SaveData ( _
    key As String, _
    data As String _
)
Visual C++
protected:
virtual void SaveData(
    String^ key,
    String^ data
) override

Parameters

key
Type: System..::..String
The key.
data
Type: System..::..String
The data.

See Also

SqlServerClientDataStore Class
SaveData Overload
Sitecore.Data.SqlServer Namespace


SetValue Method

[image] [image]

Sitecore 6.4.1 API
SqlServerClientDataStore..::..SetValue Method
SqlServerClientDataStore Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue(String, String) | Sets the value. (Inherited from ClientDataStore.)
Public method | SetValue(String, Object, String) | Sets the value. (Inherited from ClientDataStore.)

See Also

SqlServerClientDataStore Class
SqlServerClientDataStore Members
Sitecore.Data.SqlServer Namespace


TouchData Method

[image]

Sitecore 6.4.1 API
SqlServerClientDataStore..::..TouchData Method
SqlServerClientDataStore Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void TouchData(
    string key
)
Visual Basic
Protected Overrides Sub TouchData ( _
    key As String _
)
Visual C++
protected:
virtual void TouchData(
    String^ key
) override

Parameters

key
Type: System..::..String
The key.

See Also

SqlServerClientDataStore Class
Sitecore.Data.SqlServer Namespace


SqlServerClientDataStore Properties

[image] [image]

Sitecore 6.4.1 API
SqlServerClientDataStore Properties
SqlServerClientDataStore Class See Also Send Feedback

The SqlServerClientDataStore type exposes the following members.

Properties

 | Name | Description
Public property | ObjectLifetime | Gets the object lifetime. (Inherited from ClientDataStore.)

See Also

SqlServerClientDataStore Class
Sitecore.Data.SqlServer Namespace


SqlServerCommand Class

[image]

Sitecore 6.4.1 API
SqlServerCommand Class
Members See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SqlServerCommand : DataProviderCommand
Visual Basic
Public Class SqlServerCommand _
    Inherits DataProviderCommand
Visual C++
public ref class SqlServerCommand : public DataProviderCommand

Inheritance Hierarchy

System..::..Object
Sitecore.Data.DataProviders.Sql..::..DataProviderCommand
Sitecore.Data.SqlServer..::..SqlServerCommand

See Also

SqlServerCommand Members
Sitecore.Data.SqlServer Namespace


SqlServerCommand Members

[image] [image]

Sitecore 6.4.1 API
SqlServerCommand Members
SqlServerCommand Class Constructors Methods See Also Send Feedback

The SqlServerCommand type exposes the following members.

Constructors

 | Name | Description
Public method | SqlServerCommand | Constructs an instance of SqlServerCommand

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from DataProviderCommand.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteNonQuery | Executes the non query. (Inherited from DataProviderCommand.)
Public method | ExecuteNoResult | Executes with no result. (Inherited from DataProviderCommand.)
Public method | ExecuteReader | Executes the reader. (Inherited from DataProviderCommand.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SqlServerCommand Class
Sitecore.Data.SqlServer Namespace


SqlServerCommand Constructor

[image]

Sitecore 6.4.1 API
SqlServerCommand Constructor
SqlServerCommand Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlServerCommand(
    SqlCommand command,
    bool openConnection
)
Visual Basic
Public Sub New ( _
    command As SqlCommand, _
    openConnection As Boolean _
)
Visual C++
public:
SqlServerCommand(
    SqlCommand^ command,
    bool openConnection
)

Parameters

command
Type: System.Data.SqlClient..::..SqlCommand

[Missing <param name="command"/> documentation for "M:Sitecore.Data.SqlServer.SqlServerCommand.#ctor(System.Data.SqlClient.SqlCommand,System.Boolean)"]

openConnection
Type: System..::..Boolean

[Missing <param name="openConnection"/> documentation for "M:Sitecore.Data.SqlServer.SqlServerCommand.#ctor(System.Data.SqlClient.SqlCommand,System.Boolean)"]

See Also

SqlServerCommand Class
Sitecore.Data.SqlServer Namespace


SqlServerCommand Methods

[image] [image]

Sitecore 6.4.1 API
SqlServerCommand Methods
SqlServerCommand Class See Also Send Feedback

The SqlServerCommand type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from DataProviderCommand.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteNonQuery | Executes the non query. (Inherited from DataProviderCommand.)
Public method | ExecuteNoResult | Executes with no result. (Inherited from DataProviderCommand.)
Public method | ExecuteReader | Executes the reader. (Inherited from DataProviderCommand.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SqlServerCommand Class
Sitecore.Data.SqlServer Namespace


SqlServerCommandBatch Class

[image]

Sitecore 6.4.1 API
SqlServerCommandBatch Class
Members See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SqlServerCommandBatch : SqlCommandBatch
Visual Basic
Public Class SqlServerCommandBatch _
    Inherits SqlCommandBatch
Visual C++
public ref class SqlServerCommandBatch : public SqlCommandBatch

Inheritance Hierarchy

System..::..Object
Sitecore.Data.DataProviders.Sql..::..SqlCommandBatch
Sitecore.Data.SqlServer..::..SqlServerCommandBatch

See Also

SqlServerCommandBatch Members
Sitecore.Data.SqlServer Namespace


SqlServerCommandBatch Constructor

[image]

Sitecore 6.4.1 API
SqlServerCommandBatch Constructor
SqlServerCommandBatch Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlServerCommandBatch()
Visual Basic
Public Sub New
Visual C++
public:
SqlServerCommandBatch()

See Also

SqlServerCommandBatch Class
Sitecore.Data.SqlServer Namespace


SqlServerCommandBatch Methods

[image] [image]

Sitecore 6.4.1 API
SqlServerCommandBatch Methods
SqlServerCommandBatch Class See Also Send Feedback

The SqlServerCommandBatch type exposes the following members.

Methods

 | Name | Description
Public method | AddCommand | Adds the command. (Overrides SqlCommandBatch..::..AddCommand(IDbCommand).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Preprocess | Replaces the parameters in a specific SQL statement.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Translate | Translates this batch into a command (Overrides SqlCommandBatch..::..Translate()()()().)

See Also

SqlServerCommandBatch Class
Sitecore.Data.SqlServer Namespace


AddCommand Method

[image]

Sitecore 6.4.1 API
SqlServerCommandBatch..::..AddCommand Method
SqlServerCommandBatch Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void AddCommand(
    IDbCommand command
)
Visual Basic
Public Overrides Sub AddCommand ( _
    command As IDbCommand _
)
Visual C++
public:
virtual void AddCommand(
    IDbCommand^ command
) override

Parameters

command
Type: System.Data..::..IDbCommand
The command.

See Also

SqlServerCommandBatch Class
Sitecore.Data.SqlServer Namespace


Preprocess Method

[image]

Sitecore 6.4.1 API
SqlServerCommandBatch..::..Preprocess Method
SqlServerCommandBatch Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string Preprocess(
    string sourceStatement,
    Dictionary<string, IDataParameter> parametersHash
)
Visual Basic
Protected Overridable Function Preprocess ( _
    sourceStatement As String, _
    parametersHash As Dictionary(Of String, IDataParameter) _
) As String
Visual C++
protected:
virtual String^ Preprocess(
    String^ sourceStatement,
    Dictionary<String^, IDataParameter^>^ parametersHash
)

Parameters

sourceStatement
Type: System..::..String
The source statement.
parametersHash
Type: System.Collections.Generic..::..Dictionary <(Of <(<' String, IDataParameter >)>)>
The parameters hash.

Return Value

The parameters.

See Also

SqlServerCommandBatch Class
Sitecore.Data.SqlServer Namespace


Translate Method

[image]

Sitecore 6.4.1 API
SqlServerCommandBatch..::..Translate Method
SqlServerCommandBatch Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override IDbCommand Translate()
Visual Basic
Public Overrides Function Translate As IDbCommand
Visual C++
public:
virtual IDbCommand^ Translate() override

Return Value

The IDbCommand to execute.

See Also

SqlServerCommandBatch Class
Sitecore.Data.SqlServer Namespace


SqlServerCommandBatch Properties

[image] [image]

Sitecore 6.4.1 API
SqlServerCommandBatch Properties
SqlServerCommandBatch Class See Also Send Feedback

The SqlServerCommandBatch type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the count of commands in the batch so far. (Overrides SqlCommandBatch..::..Count.)
Protected property | ParameterLookup | Gets the parameter lookup regular expression.
Protected property | ParameterPrefix | Gets the parameter prefix.

See Also

SqlServerCommandBatch Class
Sitecore.Data.SqlServer Namespace


Count Property

[image]

Sitecore 6.4.1 API
SqlServerCommandBatch..::..Count Property
SqlServerCommandBatch Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override int Count { get; }
Visual Basic
Public Overrides ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get () override;
}

Field Value

The number of commands in the batch.

See Also

SqlServerCommandBatch Class
Sitecore.Data.SqlServer Namespace


ParameterLookup Property

[image]

Sitecore 6.4.1 API
SqlServerCommandBatch..::..ParameterLookup Property
SqlServerCommandBatch Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual Regex ParameterLookup { get; }
Visual Basic
Protected Overridable ReadOnly Property ParameterLookup As Regex
    Get
Visual C++
protected:
virtual property Regex^ ParameterLookup {
    Regex^ get ();
}

Field Value

The parameter lookup.

See Also

SqlServerCommandBatch Class
Sitecore.Data.SqlServer Namespace


ParameterPrefix Property

[image]

Sitecore 6.4.1 API
SqlServerCommandBatch..::..ParameterPrefix Property
SqlServerCommandBatch Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string ParameterPrefix { get; }
Visual Basic
Protected Overridable ReadOnly Property ParameterPrefix As String
    Get
Visual C++
protected:
virtual property String^ ParameterPrefix {
    String^ get ();
}

Field Value

The parameter prefix.

See Also

SqlServerCommandBatch Class
Sitecore.Data.SqlServer Namespace


SqlServerConnectionInfo Class

[image]

Sitecore 6.4.1 API
SqlServerConnectionInfo Class
Members See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SqlServerConnectionInfo
Visual Basic
Public Class SqlServerConnectionInfo
Visual C++
public ref class SqlServerConnectionInfo

Inheritance Hierarchy

System..::..Object
Sitecore.Data.SqlServer..::..SqlServerConnectionInfo

See Also

SqlServerConnectionInfo Members
Sitecore.Data.SqlServer Namespace


SqlServerConnectionInfo Members

[image] [image]

Sitecore 6.4.1 API
SqlServerConnectionInfo Members
SqlServerConnectionInfo Class Constructors Methods Properties See Also Send Feedback

The SqlServerConnectionInfo type exposes the following members.

Constructors

 | Name | Description
Public method | SqlServerConnectionInfo(SqlConnection) | Initializes a new instance of the SqlServerConnectionInfo class
Public method | SqlServerConnectionInfo(SqlTransaction) | Initializes a new instance of the SqlServerConnectionInfo class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Connection |
Public property | Transaction |

See Also

SqlServerConnectionInfo Class
Sitecore.Data.SqlServer Namespace


SqlServerConnectionInfo Constructor

[image] [image]

Sitecore 6.4.1 API
SqlServerConnectionInfo Constructor
SqlServerConnectionInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SqlServerConnectionInfo(SqlConnection) | Initializes a new instance of the SqlServerConnectionInfo class
Public method | SqlServerConnectionInfo(SqlTransaction) | Initializes a new instance of the SqlServerConnectionInfo class

See Also

SqlServerConnectionInfo Class
SqlServerConnectionInfo Members
Sitecore.Data.SqlServer Namespace


SqlServerConnectionInfo Constructor (SqlConnection)

[image]

Sitecore 6.4.1 API
SqlServerConnectionInfo Constructor (SqlConnection)
SqlServerConnectionInfo Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlServerConnectionInfo(
    SqlConnection connection
)
Visual Basic
Public Sub New ( _
    connection As SqlConnection _
)
Visual C++
public:
SqlServerConnectionInfo(
    SqlConnection^ connection
)

Parameters

connection
Type: System.Data.SqlClient..::..SqlConnection

[Missing <param name="connection"/> documentation for "M:Sitecore.Data.SqlServer.SqlServerConnectionInfo.#ctor(System.Data.SqlClient.SqlConnection)"]

See Also

SqlServerConnectionInfo Class
SqlServerConnectionInfo Overload
Sitecore.Data.SqlServer Namespace


SqlServerConnectionInfo Constructor (SqlTransaction)

[image]

Sitecore 6.4.1 API
SqlServerConnectionInfo Constructor (SqlTransaction)
SqlServerConnectionInfo Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlServerConnectionInfo(
    SqlTransaction transaction
)
Visual Basic
Public Sub New ( _
    transaction As SqlTransaction _
)
Visual C++
public:
SqlServerConnectionInfo(
    SqlTransaction^ transaction
)

Parameters

transaction
Type: System.Data.SqlClient..::..SqlTransaction

[Missing <param name="transaction"/> documentation for "M:Sitecore.Data.SqlServer.SqlServerConnectionInfo.#ctor(System.Data.SqlClient.SqlTransaction)"]

See Also

SqlServerConnectionInfo Class
SqlServerConnectionInfo Overload
Sitecore.Data.SqlServer Namespace


SqlServerConnectionInfo Methods

[image] [image]

Sitecore 6.4.1 API
SqlServerConnectionInfo Methods
SqlServerConnectionInfo Class See Also Send Feedback

The SqlServerConnectionInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SqlServerConnectionInfo Class
Sitecore.Data.SqlServer Namespace


SqlServerConnectionInfo Properties

[image] [image]

Sitecore 6.4.1 API
SqlServerConnectionInfo Properties
SqlServerConnectionInfo Class See Also Send Feedback

The SqlServerConnectionInfo type exposes the following members.

Properties

 | Name | Description
Public property | Connection |
Public property | Transaction |

See Also

SqlServerConnectionInfo Class
Sitecore.Data.SqlServer Namespace


Connection Property

[image]

Sitecore 6.4.1 API
SqlServerConnectionInfo..::..Connection Property
SqlServerConnectionInfo Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlConnection Connection { get; }
Visual Basic
Public ReadOnly Property Connection As SqlConnection
    Get
Visual C++
public:
property SqlConnection^ Connection {
    SqlConnection^ get ();
}

See Also

SqlServerConnectionInfo Class
Sitecore.Data.SqlServer Namespace


Transaction Property

[image]

Sitecore 6.4.1 API
SqlServerConnectionInfo..::..Transaction Property
SqlServerConnectionInfo Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlTransaction Transaction { get; }
Visual Basic
Public ReadOnly Property Transaction As SqlTransaction
    Get
Visual C++
public:
property SqlTransaction^ Transaction {
    SqlTransaction^ get ();
}

See Also

SqlServerConnectionInfo Class
Sitecore.Data.SqlServer Namespace


SqlServerDataApi Class

[image]

Sitecore 6.4.1 API
SqlServerDataApi Class
Members See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SqlServerDataApi : SqlDataApi
Visual Basic
Public Class SqlServerDataApi _
    Inherits SqlDataApi
Visual C++
public ref class SqlServerDataApi : public SqlDataApi

Inheritance Hierarchy

System..::..Object
Sitecore.Data.DataProviders.Sql..::..SqlDataApi
Sitecore.Data.SqlServer..::..SqlServerDataApi

See Also

SqlServerDataApi Members
Sitecore.Data.SqlServer Namespace


SqlServerDataApi Members

[image] [image]

Sitecore 6.4.1 API
SqlServerDataApi Members
SqlServerDataApi Class Constructors Methods Properties See Also Send Feedback

The SqlServerDataApi type exposes the following members.

Constructors

 | Name | Description
Public method | SqlServerDataApi()()()() | Initializes a new instance of the SqlServerDataApi class.
Public method | SqlServerDataApi(String) | Initializes a new instance of the SqlServerDataApi class.

Methods

 | Name | Description
Public method | CreateBatch | Creates the sql command batch batch. (Overrides SqlDataApi..::..CreateBatch()()()().)
Public method | CreateCommand | Factory method for creating a new command object. (Inherited from SqlDataApi.)
Protected method | CreateConnection | Creates a physical database connection. (Overrides SqlDataApi..::..CreateConnection()()()().)
Public method | CreateObjectReader<(Of <<'(T>)>>)(String, array<Object>[]()[][], Func<(Of <<'(DataProviderReader, T>)>>)) | Creates the object reader. (Inherited from SqlDataApi.)
Public method | CreateObjectReader<(Of <<'(T>)>>)(String, array<Object>[]()[][], Func<(Of <<'(IDataReader, T>)>>)) | Creates the object reader. (Inherited from SqlDataApi.)
Protected method | CreateParameter | Creates a parameter for use in a command. (Overrides SqlDataApi..::..CreateParameter(String, Object).)
Public method | CreateReader | Factory method for creating an instance of a DataProviderReader (Inherited from SqlDataApi.)
Public method | CreateTransaction | Factory method for creating an instance of a DataProviderTransaction (Inherited from SqlDataApi.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the specified SQL. (Inherited from SqlDataApi.)
Public method | ExecuteNoResult | Executes the no result. (Inherited from SqlDataApi.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Format | Formats the specified SQL. (Inherited from SqlDataApi.)
Public method | FormatRawID | Formats ID to be used in raw SQL queries (e.g. itemID in 'select * from items where id = :itemID') (Inherited from SqlDataApi.)
Public method | GetBoolean | Gets the boolean. (Inherited from SqlDataApi.)
Public method | GetDateTime | Gets a date/time value from a specified column. (Overrides SqlDataApi..::..GetDateTime(Int32, DataProviderReader).)
Public method | GetGuid(Int32, DataProviderReader) | Gets an id value from a specified column. (Overrides SqlDataApi..::..GetGuid(Int32, DataProviderReader).)
Public method | GetGuid(String, array<Object>[]()[][], Guid) | Gets a guid value from the database.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetId | Gets an id value from a specified column. (Overrides SqlDataApi..::..GetId(Int32, DataProviderReader).)
Public method | GetInt(Int32, DataProviderReader) | Gets an int32 value from a specified column. (Overrides SqlDataApi..::..GetInt(Int32, DataProviderReader).)
Public method | GetInt(String, array<Object>[]()[][], Int32) | Gets an integer value from the database.
Public method | GetInt32 | Gets an integer result from an SQL query. (Inherited from SqlDataApi.)
Public method | GetLanguage | Gets a language value from a specified column. (Overrides SqlDataApi..::..GetLanguage(Int32, DataProviderReader).)
Public method | GetLong | Gets an int64 value from a specified column. (Overrides SqlDataApi..::..GetLong(Int32, DataProviderReader).)
Public method | GetString | Gets a string value from a specified column. (Overrides SqlDataApi..::..GetString(Int32, DataProviderReader).)
Public method | GetStringList | Gets a list of string values from a database. (Inherited from SqlDataApi.)
Public method | GetStringSet | Gets a list of string values from a database. (Inherited from SqlDataApi.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersion | Gets a version value from a specified column. (Overrides SqlDataApi..::..GetVersion(Int32, DataProviderReader).)
 | MapFileNames | Maps the file names embedded in a connection string.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Safe | Escapes a string for use in SQL statements. (Inherited from SqlDataApi.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConnectionString | Gets the connection string. (Overrides SqlDataApi..::..ConnectionString.)
Public property | EmptyStringLiteral | Gets the empty literal. (Inherited from SqlDataApi.)
Public property | Identifier | Gets an identifier for the data API. (Overrides SqlDataApi..::..Identifier.)
Public property | NamePostfix | Gets the postfix used for encapsulating table and column names in SQL statements. (Overrides SqlDataApi..::..NamePostfix.)
Public property | NamePrefix | Gets the prefix used for encapsulating table and column names in SQL statements. (Overrides SqlDataApi..::..NamePrefix.)
Public property | ParameterPostfix | Gets the postfix used for encapsulating parameter names in SQL statements. (Overrides SqlDataApi..::..ParameterPostfix.)
Public property | ParameterPrefix | Gets the prefix used for encapsulating parameter names in SQL statements. (Overrides SqlDataApi..::..ParameterPrefix.)
Public property | Quote | Gets the character used for encapsulating a string value in SQL statements. (Overrides SqlDataApi..::..Quote.)
Public property | Wildcard | Gets the character used for wildcard queries in SQL statements. (Overrides SqlDataApi..::..Wildcard.)

See Also

SqlServerDataApi Class
Sitecore.Data.SqlServer Namespace


SqlServerDataApi Constructor

[image] [image]

Sitecore 6.4.1 API
SqlServerDataApi Constructor
SqlServerDataApi Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SqlServerDataApi()()()() | Initializes a new instance of the SqlServerDataApi class.
Public method | SqlServerDataApi(String) | Initializes a new instance of the SqlServerDataApi class.

See Also

SqlServerDataApi Class
SqlServerDataApi Members
Sitecore.Data.SqlServer Namespace


SqlServerDataApi Constructor

[image]

Sitecore 6.4.1 API
SqlServerDataApi Constructor
SqlServerDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlServerDataApi()
Visual Basic
Public Sub New
Visual C++
public:
SqlServerDataApi()

See Also

SqlServerDataApi Class
SqlServerDataApi Overload
Sitecore.Data.SqlServer Namespace


SqlServerDataApi Constructor (String)

[image]

Sitecore 6.4.1 API
SqlServerDataApi Constructor (String)
SqlServerDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlServerDataApi(
    string connectionString
)
Visual Basic
Public Sub New ( _
    connectionString As String _
)
Visual C++
public:
SqlServerDataApi(
    String^ connectionString
)

Parameters

connectionString
Type: System..::..String
The connection string.

See Also

SqlServerDataApi Class
SqlServerDataApi Overload
Sitecore.Data.SqlServer Namespace


CreateBatch Method

[image]

Sitecore 6.4.1 API
SqlServerDataApi..::..CreateBatch Method
SqlServerDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override SqlCommandBatch CreateBatch()
Visual Basic
Public Overrides Function CreateBatch As SqlCommandBatch
Visual C++
public:
virtual SqlCommandBatch^ CreateBatch() override

Return Value

The batch.

See Also

SqlServerDataApi Class
Sitecore.Data.SqlServer Namespace


CreateConnection Method

[image]

Sitecore 6.4.1 API
SqlServerDataApi..::..CreateConnection Method
SqlServerDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override IDbConnection CreateConnection()
Visual Basic
Protected Overrides Function CreateConnection As IDbConnection
Visual C++
protected:
virtual IDbConnection^ CreateConnection() override

Return Value

A connection object. Note that the connection is only created, not opened.

See Also

SqlServerDataApi Class
Sitecore.Data.SqlServer Namespace


CreateObjectReader Method

[image] [image]

Sitecore 6.4.1 API
SqlServerDataApi..::..CreateObjectReader Method
SqlServerDataApi Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateObjectReader<(Of <<'(T>)>>)(String, array<Object>[]()[][], Func<(Of <<'(DataProviderReader, T>)>>)) | Creates the object reader. (Inherited from SqlDataApi.)
Public method | CreateObjectReader<(Of <<'(T>)>>)(String, array<Object>[]()[][], Func<(Of <<'(IDataReader, T>)>>)) | Creates the object reader. (Inherited from SqlDataApi.)

See Also

SqlServerDataApi Class
SqlServerDataApi Members
Sitecore.Data.SqlServer Namespace


CreateParameter Method

[image]

Sitecore 6.4.1 API
SqlServerDataApi..::..CreateParameter Method
SqlServerDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override IDbDataParameter CreateParameter(
    string name,
    Object value
)
Visual Basic
Protected Overrides Function CreateParameter ( _
    name As String, _
    value As Object _
) As IDbDataParameter
Visual C++
protected:
virtual IDbDataParameter^ CreateParameter(
    String^ name,
    Object^ value
) override

Parameters

name
Type: System..::..String
The name of the parameter.
value
Type: System..::..Object
The value of the parameter.

Return Value

A parameter object in which the DbType of the value has been set and where the parameter value has been mapped to the native value expected by the database.

For instance, if value is an ID, the parameter value might be a Guid representing the same value.

See Also

SqlServerDataApi Class
Sitecore.Data.SqlServer Namespace


GetDateTime Method

[image]

Sitecore 6.4.1 API
SqlServerDataApi..::..GetDateTime Method
SqlServerDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override DateTime GetDateTime(
    int columnIndex,
    DataProviderReader reader
)
Visual Basic
Public Overrides Function GetDateTime ( _
    columnIndex As Integer, _
    reader As DataProviderReader _
) As DateTime
Visual C++
public:
virtual DateTime GetDateTime(
    int columnIndex,
    DataProviderReader^ reader
) override

Parameters

columnIndex
Type: System..::..Int32
Index of the column.
reader
Type: Sitecore.Data.DataProviders.Sql..::..DataProviderReader
The reader.

Return Value

The column value cast to a DateTime

See Also

SqlServerDataApi Class
Sitecore.Data.SqlServer Namespace


GetGuid Method

[image] [image]

Sitecore 6.4.1 API
SqlServerDataApi..::..GetGuid Method
SqlServerDataApi Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetGuid(Int32, DataProviderReader) | Gets an id value from a specified column. (Overrides SqlDataApi..::..GetGuid(Int32, DataProviderReader).)
Public method | GetGuid(String, array<Object>[]()[][], Guid) | Gets a guid value from the database.

See Also

SqlServerDataApi Class
SqlServerDataApi Members
Sitecore.Data.SqlServer Namespace


GetGuid Method (Int32, DataProviderReader)

[image]

Sitecore 6.4.1 API
SqlServerDataApi..::..GetGuid Method (Int32, DataProviderReader)
SqlServerDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Guid GetGuid(
    int columnIndex,
    DataProviderReader reader
)
Visual Basic
Public Overrides Function GetGuid ( _
    columnIndex As Integer, _
    reader As DataProviderReader _
) As Guid
Visual C++
public:
virtual Guid GetGuid(
    int columnIndex,
    DataProviderReader^ reader
) override

Parameters

columnIndex
Type: System..::..Int32
Index of the column.
reader
Type: Sitecore.Data.DataProviders.Sql..::..DataProviderReader
The reader.

Return Value

The column value cast to a Guid

See Also

SqlServerDataApi Class
GetGuid Overload
Sitecore.Data.SqlServer Namespace


GetGuid Method (String, Object[], Guid)

[image]

Sitecore 6.4.1 API
SqlServerDataApi..::..GetGuid Method (String, array<Object>[]()[][], Guid)
SqlServerDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Guid GetGuid(
    string sql,
    Object[] parameters,
    Guid defaultValue
)
Visual Basic
Public Function GetGuid ( _
    sql As String, _
    parameters As Object(), _
    defaultValue As Guid _
) As Guid
Visual C++
public:
Guid GetGuid(
    String^ sql,
    array<Object^>^ parameters,
    Guid defaultValue
)

Parameters

sql
Type: System..::..String
The SQL.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.
defaultValue
Type: System..::..Guid
The default value.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.SqlServer.SqlServerDataApi.GetGuid(System.String,System.Object[],System.Guid)"]

See Also

SqlServerDataApi Class
GetGuid Overload
Sitecore.Data.SqlServer Namespace


GetId Method

[image]

Sitecore 6.4.1 API
SqlServerDataApi..::..GetId Method
SqlServerDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override ID GetId(
    int columnIndex,
    DataProviderReader reader
)
Visual Basic
Public Overrides Function GetId ( _
    columnIndex As Integer, _
    reader As DataProviderReader _
) As ID
Visual C++
public:
virtual ID^ GetId(
    int columnIndex,
    DataProviderReader^ reader
) override

Parameters

columnIndex
Type: System..::..Int32
Index of the column.
reader
Type: Sitecore.Data.DataProviders.Sql..::..DataProviderReader
The reader.

Return Value

The column value cast to an ID

See Also

SqlServerDataApi Class
Sitecore.Data.SqlServer Namespace


GetInt Method

[image] [image]

Sitecore 6.4.1 API
SqlServerDataApi..::..GetInt Method
SqlServerDataApi Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetInt(Int32, DataProviderReader) | Gets an int32 value from a specified column. (Overrides SqlDataApi..::..GetInt(Int32, DataProviderReader).)
Public method | GetInt(String, array<Object>[]()[][], Int32) | Gets an integer value from the database.

See Also

SqlServerDataApi Class
SqlServerDataApi Members
Sitecore.Data.SqlServer Namespace


GetInt Method (Int32, DataProviderReader)

[image]

Sitecore 6.4.1 API
SqlServerDataApi..::..GetInt Method (Int32, DataProviderReader)
SqlServerDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override int GetInt(
    int columnIndex,
    DataProviderReader reader
)
Visual Basic
Public Overrides Function GetInt ( _
    columnIndex As Integer, _
    reader As DataProviderReader _
) As Integer
Visual C++
public:
virtual int GetInt(
    int columnIndex,
    DataProviderReader^ reader
) override

Parameters

columnIndex
Type: System..::..Int32
Index of the column.
reader
Type: Sitecore.Data.DataProviders.Sql..::..DataProviderReader
The reader.

Return Value

The column value cast to an Int32

See Also

SqlServerDataApi Class
GetInt Overload
Sitecore.Data.SqlServer Namespace


GetInt Method (String, Object[], Int32)

[image]

Sitecore 6.4.1 API
SqlServerDataApi..::..GetInt Method (String, array<Object>[]()[][], Int32)
SqlServerDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int GetInt(
    string sql,
    Object[] parameters,
    int defaultValue
)
Visual Basic
Public Function GetInt ( _
    sql As String, _
    parameters As Object(), _
    defaultValue As Integer _
) As Integer
Visual C++
public:
int GetInt(
    String^ sql,
    array<Object^>^ parameters,
    int defaultValue
)

Parameters

sql
Type: System..::..String
The SQL.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.
defaultValue
Type: System..::..Int32
The default value.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.SqlServer.SqlServerDataApi.GetInt(System.String,System.Object[],System.Int32)"]

See Also

SqlServerDataApi Class
GetInt Overload
Sitecore.Data.SqlServer Namespace


GetLong Method

[image]

Sitecore 6.4.1 API
SqlServerDataApi..::..GetLong Method
SqlServerDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override long GetLong(
    int columnIndex,
    DataProviderReader reader
)
Visual Basic
Public Overrides Function GetLong ( _
    columnIndex As Integer, _
    reader As DataProviderReader _
) As Long
Visual C++
public:
virtual long long GetLong(
    int columnIndex,
    DataProviderReader^ reader
) override

Parameters

columnIndex
Type: System..::..Int32
Index of the column.
reader
Type: Sitecore.Data.DataProviders.Sql..::..DataProviderReader
The reader.

Return Value

The column value cast to an Int32

See Also

SqlServerDataApi Class
Sitecore.Data.SqlServer Namespace


GetString Method

[image]

Sitecore 6.4.1 API
SqlServerDataApi..::..GetString Method
SqlServerDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string GetString(
    int columnIndex,
    DataProviderReader reader
)
Visual Basic
Public Overrides Function GetString ( _
    columnIndex As Integer, _
    reader As DataProviderReader _
) As String
Visual C++
public:
virtual String^ GetString(
    int columnIndex,
    DataProviderReader^ reader
) override

Parameters

columnIndex
Type: System..::..Int32
Index of the column.
reader
Type: Sitecore.Data.DataProviders.Sql..::..DataProviderReader
The reader.

Return Value

The column value cast to a String

See Also

SqlServerDataApi Class
Sitecore.Data.SqlServer Namespace


GetVersion Method

[image]

Sitecore 6.4.1 API
SqlServerDataApi..::..GetVersion Method
SqlServerDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Version GetVersion(
    int columnIndex,
    DataProviderReader reader
)
Visual Basic
Public Overrides Function GetVersion ( _
    columnIndex As Integer, _
    reader As DataProviderReader _
) As Version
Visual C++
public:
virtual Version^ GetVersion(
    int columnIndex,
    DataProviderReader^ reader
) override

Parameters

columnIndex
Type: System..::..Int32
Index of the column.
reader
Type: Sitecore.Data.DataProviders.Sql..::..DataProviderReader
The reader.

Return Value

The column value cast to a Version

See Also

SqlServerDataApi Class
Sitecore.Data.SqlServer Namespace


MapFileNames Method

[image]

Sitecore 6.4.1 API
SqlServerDataApi..::..MapFileNames Method
SqlServerDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string MapFileNames(
    string connectionString
)
Visual Basic
Public Shared Function MapFileNames ( _
    connectionString As String _
) As String
Visual C++
public:
static String^ MapFileNames(
    String^ connectionString
)

Parameters

connectionString
Type: System..::..String
The connection string.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.SqlServer.SqlServerDataApi.MapFileNames(System.String)"]

See Also

SqlServerDataApi Class
Sitecore.Data.SqlServer Namespace


ConnectionString Property

[image]

Sitecore 6.4.1 API
SqlServerDataApi..::..ConnectionString Property
SqlServerDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string ConnectionString { get; set; }
Visual Basic
Public Overrides Property ConnectionString As String
    Get
    Set
Visual C++
public:
virtual property String^ ConnectionString {
    String^ get () override;
    void set (String^ value) override;
}

Field Value

The connection string.

See Also

SqlServerDataApi Class
Sitecore.Data.SqlServer Namespace


Identifier Property

[image]

Sitecore 6.4.1 API
SqlServerDataApi..::..Identifier Property
SqlServerDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Identifier { get; }
Visual Basic
Public Overrides ReadOnly Property Identifier As String
    Get
Visual C++
public:
virtual property String^ Identifier {
    String^ get () override;
}

Field Value

For SQL Server: The connection string.

See Also

SqlServerDataApi Class
Sitecore.Data.SqlServer Namespace


NamePostfix Property

[image]

Sitecore 6.4.1 API
SqlServerDataApi..::..NamePostfix Property
SqlServerDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string NamePostfix { get; }
Visual Basic
Public Overrides ReadOnly Property NamePostfix As String
    Get
Visual C++
public:
virtual property String^ NamePostfix {
    String^ get () override;
}

Field Value

For SQL Server: ].

See Also

SqlServerDataApi Class
Sitecore.Data.SqlServer Namespace


NamePrefix Property

[image]

Sitecore 6.4.1 API
SqlServerDataApi..::..NamePrefix Property
SqlServerDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string NamePrefix { get; }
Visual Basic
Public Overrides ReadOnly Property NamePrefix As String
    Get
Visual C++
public:
virtual property String^ NamePrefix {
    String^ get () override;
}

Field Value

For SQL Server: [.

See Also

SqlServerDataApi Class
Sitecore.Data.SqlServer Namespace


ParameterPostfix Property

[image]

Sitecore 6.4.1 API
SqlServerDataApi..::..ParameterPostfix Property
SqlServerDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string ParameterPostfix { get; }
Visual Basic
Public Overrides ReadOnly Property ParameterPostfix As String
    Get
Visual C++
public:
virtual property String^ ParameterPostfix {
    String^ get () override;
}

Field Value

For SQL Server: Empty.

See Also

SqlServerDataApi Class
Sitecore.Data.SqlServer Namespace


ParameterPrefix Property

[image]

Sitecore 6.4.1 API
SqlServerDataApi..::..ParameterPrefix Property
SqlServerDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string ParameterPrefix { get; }
Visual Basic
Public Overrides ReadOnly Property ParameterPrefix As String
    Get
Visual C++
public:
virtual property String^ ParameterPrefix {
    String^ get () override;
}

Field Value

For SQL Server: @.

See Also

SqlServerDataApi Class
Sitecore.Data.SqlServer Namespace


Quote Property

[image]

Sitecore 6.4.1 API
SqlServerDataApi..::..Quote Property
SqlServerDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Quote { get; }
Visual Basic
Public Overrides ReadOnly Property Quote As String
    Get
Visual C++
public:
virtual property String^ Quote {
    String^ get () override;
}

Field Value

Remarks

For example, SQL Server will use: ', and so will Firebird.

See Also

SqlServerDataApi Class
Sitecore.Data.SqlServer Namespace


Wildcard Property

[image]

Sitecore 6.4.1 API
SqlServerDataApi..::..Wildcard Property
SqlServerDataApi Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Wildcard { get; }
Visual Basic
Public Overrides ReadOnly Property Wildcard As String
    Get
Visual C++
public:
virtual property String^ Wildcard {
    String^ get () override;
}

Remarks

For example, SQL Server will use: %.

See Also

SqlServerDataApi Class
Sitecore.Data.SqlServer Namespace


SqlServerDataProvider Class

[image]

Sitecore 6.4.1 API
SqlServerDataProvider Class
Members See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SqlServerDataProvider : SqlDataProvider
Visual Basic
Public Class SqlServerDataProvider _
    Inherits SqlDataProvider
Visual C++
public ref class SqlServerDataProvider : public SqlDataProvider

Inheritance Hierarchy

System..::..Object
Sitecore.Data.DataProviders..::..DataProvider
Sitecore.Data.DataProviders.Sql..::..SqlDataProvider
Sitecore.Data.SqlServer..::..SqlServerDataProvider

See Also

SqlServerDataProvider Members
Sitecore.Data.SqlServer Namespace


SqlServerDataProvider Members

[image] [image]

Sitecore 6.4.1 API
SqlServerDataProvider Members
SqlServerDataProvider Class Constructors Methods Fields Properties See Also Send Feedback

The SqlServerDataProvider type exposes the following members.

Constructors

 | Name | Description
Public method | SqlServerDataProvider | Initializes a new instance of the SqlServerDataProvider class.

Methods

 | Name | Description
Protected method | AddPrefetch | Adds a prefetch option. (Inherited from SqlDataProvider.)
Public method | AddToPublishQueue | Adds an item to the publish queue. (Inherited from SqlDataProvider.)
Public method | AddVersion | Adds a version to an item. (Inherited from SqlDataProvider.)
Public method | BlobStreamExists | Determines whether the specified field contains a BLOB value. (Overrides DataProvider..::..BlobStreamExists(Guid, CallContext).)
Public method | ChangeFieldSharing | Changes the type of field sharing for a single field. (Inherited from SqlDataProvider.)
Public method | ChangeTemplate | Changes the template. (Inherited from SqlDataProvider.)
Protected method | CleanupBlobs | Removes unused blob fields (Inherited from SqlDataProvider.)
Protected method | CleanupCyclicDependences | Cleanups the cyclic dependences. The items couldn't be removed by CleanupOrphans because always have a parent but is not participated in item tree. (Inherited from SqlDataProvider.)
Public method | CleanupDatabase | Cleanups the database. (Inherited from SqlDataProvider.)
Protected method | CleanupFields | Removes all field data for non-existing items. (Inherited from SqlDataProvider.)
Protected method | CleanupInvalidLanguageData | Removes all invalid language data (ie. data for which the language does not exist). (Inherited from SqlDataProvider.)
Protected method | CleanupOrphans | Removes orphaned items from the database. (Inherited from SqlDataProvider.)
Public method | CleanupPublishQueue | Cleans up the publish queue. (Inherited from SqlDataProvider.)
Protected method | CleanupTemplateFields | Cleanups the template fields. (Inherited from SqlDataProvider.)
Public method | CopyItem | Copies an item. (Inherited from SqlDataProvider.)
Public method | CreateItem | Creates a item. (Inherited from SqlDataProvider.)
Protected method | CreateSqlTranslator | Creates the SQL translator. (Inherited from SqlDataProvider.)
Public method | DeleteItem | Deletes an item. (Overrides SqlDataProvider..::..DeleteItem(ItemDefinition, CallContext).)
Protected method | Descendants_ItemCreated | Performs changes to 'Descandants' table after item creation. (Inherited from SqlDataProvider.)
Protected method | Descendants_ItemDeleted | Performs changes to 'Descandants' table after item deleting. (Inherited from SqlDataProvider.)
Protected method | DoInitializeEvents | Performs the actual event initialization. (Inherited from SqlDataProvider.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Exists | Check if data satisfying the specified SQL exists. (Inherited from SqlDataProvider.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBlobStream | Gets the BLOB stream associated with a field. (Overrides DataProvider..::..GetBlobStream(Guid, CallContext).)
Public method | GetChildIDs | Gets the child ids of an item. (Inherited from SqlDataProvider.)
Public method | GetDataSize | Gets the size of the data managed by the provider. (Inherited from SqlDataProvider.)
Public method | GetDictionaryEntryCount | Gets the number of dictionary entries. (Inherited from SqlDataProvider.)
Public method | GetEventQueue | Gets the event queue driver. (Inherited from SqlDataProvider.)
Protected method | GetFieldSharingConverter | Gets a SqlDataProvider..::..FieldSharingConverter. (Inherited from SqlDataProvider.)
Protected method | GetFieldValue | Gets the field value. (Inherited from SqlDataProvider.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetIdEnumerator | Gets all id values. (Inherited from SqlDataProvider.)
Public method | GetItemDefinition | Gets the definition of an item. (Inherited from SqlDataProvider.)
Public method | GetItemFields | Gets the fields of a specific item version. (Inherited from SqlDataProvider.)
Protected method | GetItemKeyColumnName | Gets the name of the 'item name' column. (Inherited from SqlDataProvider.)
Public method | GetItemsInWorkflowState | Gets all items that are in a specific workflow state. (Inherited from SqlDataProvider.)
Public method | GetItemVersions | Gets a list of the available versions of an item. (Inherited from SqlDataProvider.)
Public method | GetLanguages()()()() | Gets a list of all the language that have been defined in the database. (Inherited from SqlDataProvider.)
Public method | GetLanguages(CallContext) | Gets a list of all the language that have been defined in the database. (Inherited from SqlDataProvider.)
Protected method | GetLock | Gets a lock. (Inherited from SqlDataProvider.)
Public method | GetParentID | Gets the parent ID of an item. (Inherited from SqlDataProvider.)
Protected method | GetPrefetchDataFromCache | Gets the prefetch data from cache. (Inherited from SqlDataProvider.)
Public method | GetProperty | Gets a property. (Inherited from SqlDataProvider.)
Protected method | GetPropertyCore | Gets the property core. (Inherited from SqlDataProvider.)
Public method | GetPropertyKeys | Gets a list of property keys matching a specific prefix. (Inherited from SqlDataProvider.)
Public method | GetPublishQueue | Gets the publish queue. (Inherited from SqlDataProvider.)
Protected method | GetResolverSql | Gets the resolver SQL. (Inherited from SqlDataProvider.)
Public method | GetRootID | Gets the root ID. (Inherited from SqlDataProvider.)
Public method | GetSharingType | Gets the type of the sharing. (Inherited from SqlDataProvider.)
Public method | GetTemplateItemIds | Gets the template item id. (Inherited from SqlDataProvider.)
Public method | GetTemplates | Gets the templates. (Inherited from DataProvider.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetVersions | Gets a list of all versions that have been defined in the entire database. (Inherited from SqlDataProvider.)
Public method | GetWorkflowInfo | Gets the workflow info form an item. (Inherited from DataProvider.)
Public method | HasChildren | Determines whether the specified item definition has children. (Inherited from SqlDataProvider.)
Public method | IsEnabled | Determines whether the specified method is enabled. (Inherited from DataProvider.)
Protected method | LoadChildIds | Loads the child ids. (Overrides SqlDataProvider..::..LoadChildIds(String, array<Object>[]()[][], SafeDictionary<(Of <<'(ID, PrefetchData>)>>)).)
Protected method | LoadItemDefinitions | Loads the item definitions. (Overrides SqlDataProvider..::..LoadItemDefinitions(String, array<Object>[]()[][], SafeDictionary<(Of <<'(ID, PrefetchData>)>>)).)
Protected method | LoadItemFields | Loads the item fields. (Overrides SqlDataProvider..::..LoadItemFields(String, String, array<Object>[]()[][], SafeDictionary<(Of <<'(ID, PrefetchData>)>>)).)
Protected method | LoadLanguages | Loads the list of languages from the database. (Inherited from SqlDataProvider.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveItem | Moves an item (ie. changes its parent). (Inherited from SqlDataProvider.)
Protected method | QueryFast | Executes fast query. (Inherited from SqlDataProvider.)
Protected method | RebuildDescendants | Rebuilds the descendants table. (Inherited from SqlDataProvider.)
Protected method | RemoveFields | Removes the fields. (Overrides SqlDataProvider..::..RemoveFields(ID, Language, Version).)
Public method | RemoveLanguageData | Removes a language and all the data using the language from the database. (Inherited from SqlDataProvider.)
Protected method | RemovePrefetchDataFromCache | Removes prefetch data from the cache. (Inherited from SqlDataProvider.)
Public method | RemoveProperty | Removes a property. (Inherited from SqlDataProvider.)
Protected method | RemovePropertyCore | Removes the property core. (Inherited from SqlDataProvider.)
Public method | RemoveVersion | Removes a version from an item. (Inherited from SqlDataProvider.)
Public method | RemoveVersions(ItemDefinition, Language, CallContext) | Removes versions from an item. (Inherited from DataProvider.)
Public method | RemoveVersions(ItemDefinition, Language, Boolean, CallContext) | Removes versions from an item. (Inherited from SqlDataProvider.)
Public method | RenameLanguageData | Renames a language binding. (Inherited from SqlDataProvider.)
Protected method | ResolveNames | Resolves the names. (Inherited from SqlDataProvider.)
Public method | ResolvePath | Resolves the path. (Inherited from DataProvider.)
Public method | SaveItem | Saves an item. (Inherited from SqlDataProvider.)
Public method | SelectIDs | Selects a set of ids. (Inherited from SqlDataProvider.)
Public method | SelectSingleID | Selects a single ID. (Inherited from SqlDataProvider.)
Public method | SetBlobStream | Sets the BLOB stream associated with a field. (Overrides DataProvider..::..SetBlobStream(Stream, Guid, CallContext).)
Protected method | SetFieldValue | Sets the field value. (Inherited from SqlDataProvider.)
Public method | SetProperty | Sets a property. (Inherited from SqlDataProvider.)
Protected method | SetPropertyCore | Sets the property core. (Inherited from SqlDataProvider.)
Public method | SetWorkflowInfo | Sets the workflow info for an item. (Inherited from DataProvider.)
Protected method | StartRebuildDescendants | Starts the rebuild descendants. (Inherited from SqlDataProvider.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateFieldValues | Updates field values. (Inherited from SqlDataProvider.)
Protected method | WriteSharedField | Writes the shared field. (Inherited from SqlDataProvider.)
Protected method | WriteUnversionedField | Writes the unversioned field. (Inherited from SqlDataProvider.)
Protected method | WriteVersionedField | Writes the versioned field. (Inherited from SqlDataProvider.)

Fields

 | Name | Description
Protected field | DescendantsLock | Used for syncronization of access to [Descendants] table (Inherited from SqlDataProvider.)
Protected field | PrefetchCacheLock | The _prefetch cache lock. (Inherited from SqlDataProvider.)

Properties

 | Name | Description
Protected property | Api | Gets the data API to the physical database. (Inherited from SqlDataProvider.)
Public property | BlobChunkSize | Gets the size of the individual chunks making up a BLOB.
Public property | CacheOptions | Gets the cache options. (Inherited from DataProvider.)
Public property | Database | Gets the database. (Inherited from DataProvider.)
Protected property | DescendantsShouldBeUpdated | Gets or sets a value indicating whether Descendants table should be updated (Inherited from SqlDataProvider.)
Protected property | Disable | Disables a method. (Inherited from DataProvider.)
Protected property | DisableGroup | Disables a group. (Inherited from DataProvider.)
Protected property | Enable | Enables a method. (Inherited from DataProvider.)
Protected property | EnableGroup | Enables a group. (Inherited from DataProvider.)
Protected property | Languages | Gets or sets languages (Inherited from SqlDataProvider.)
Public property | Name | Gets or sets the name. (Inherited from SqlDataProvider.)
Protected property | PrefetchCache | Gets the prefetch cache. (Inherited from SqlDataProvider.)
Protected property | PropertyCache | Gets the property cache. (Inherited from SqlDataProvider.)
Protected property | RebuildThread | Gets or sets a value indicating rebuilding thread (Inherited from SqlDataProvider.)
Protected property | SkipDescendantsUpdate | Gets a value indicating whether Descendantsd table should be updated. (Inherited from SqlDataProvider.)
Protected property | Translator | Gets the Sitecore Query to SQL translator. (Inherited from SqlDataProvider.)

See Also

SqlServerDataProvider Class
Sitecore.Data.SqlServer Namespace


SqlServerDataProvider Constructor

[image]

Sitecore 6.4.1 API
SqlServerDataProvider Constructor
SqlServerDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlServerDataProvider(
    string connectionString
)
Visual Basic
Public Sub New ( _
    connectionString As String _
)
Visual C++
public:
SqlServerDataProvider(
    String^ connectionString
)

Parameters

connectionString
Type: System..::..String
The connection string.

See Also

SqlServerDataProvider Class
Sitecore.Data.SqlServer Namespace


SqlServerDataProvider Fields

[image] [image]

Sitecore 6.4.1 API
SqlServerDataProvider Fields
SqlServerDataProvider Class See Also Send Feedback

The SqlServerDataProvider type exposes the following members.

Fields

 | Name | Description
Protected field | DescendantsLock | Used for syncronization of access to [Descendants] table (Inherited from SqlDataProvider.)
Protected field | PrefetchCacheLock | The _prefetch cache lock. (Inherited from SqlDataProvider.)

See Also

SqlServerDataProvider Class
Sitecore.Data.SqlServer Namespace


SqlServerDataProvider Methods

[image] [image]

Sitecore 6.4.1 API
SqlServerDataProvider Methods
SqlServerDataProvider Class See Also Send Feedback

The SqlServerDataProvider type exposes the following members.

Methods

 | Name | Description
Protected method | AddPrefetch | Adds a prefetch option. (Inherited from SqlDataProvider.)
Public method | AddToPublishQueue | Adds an item to the publish queue. (Inherited from SqlDataProvider.)
Public method | AddVersion | Adds a version to an item. (Inherited from SqlDataProvider.)
Public method | BlobStreamExists | Determines whether the specified field contains a BLOB value. (Overrides DataProvider..::..BlobStreamExists(Guid, CallContext).)
Public method | ChangeFieldSharing | Changes the type of field sharing for a single field. (Inherited from SqlDataProvider.)
Public method | ChangeTemplate | Changes the template. (Inherited from SqlDataProvider.)
Protected method | CleanupBlobs | Removes unused blob fields (Inherited from SqlDataProvider.)
Protected method | CleanupCyclicDependences | Cleanups the cyclic dependences. The items couldn't be removed by CleanupOrphans because always have a parent but is not participated in item tree. (Inherited from SqlDataProvider.)
Public method | CleanupDatabase | Cleanups the database. (Inherited from SqlDataProvider.)
Protected method | CleanupFields | Removes all field data for non-existing items. (Inherited from SqlDataProvider.)
Protected method | CleanupInvalidLanguageData | Removes all invalid language data (ie. data for which the language does not exist). (Inherited from SqlDataProvider.)
Protected method | CleanupOrphans | Removes orphaned items from the database. (Inherited from SqlDataProvider.)
Public method | CleanupPublishQueue | Cleans up the publish queue. (Inherited from SqlDataProvider.)
Protected method | CleanupTemplateFields | Cleanups the template fields. (Inherited from SqlDataProvider.)
Public method | CopyItem | Copies an item. (Inherited from SqlDataProvider.)
Public method | CreateItem | Creates a item. (Inherited from SqlDataProvider.)
Protected method | CreateSqlTranslator | Creates the SQL translator. (Inherited from SqlDataProvider.)
Public method | DeleteItem | Deletes an item. (Overrides SqlDataProvider..::..DeleteItem(ItemDefinition, CallContext).)
Protected method | Descendants_ItemCreated | Performs changes to 'Descandants' table after item creation. (Inherited from SqlDataProvider.)
Protected method | Descendants_ItemDeleted | Performs changes to 'Descandants' table after item deleting. (Inherited from SqlDataProvider.)
Protected method | DoInitializeEvents | Performs the actual event initialization. (Inherited from SqlDataProvider.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Exists | Check if data satisfying the specified SQL exists. (Inherited from SqlDataProvider.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBlobStream | Gets the BLOB stream associated with a field. (Overrides DataProvider..::..GetBlobStream(Guid, CallContext).)
Public method | GetChildIDs | Gets the child ids of an item. (Inherited from SqlDataProvider.)
Public method | GetDataSize | Gets the size of the data managed by the provider. (Inherited from SqlDataProvider.)
Public method | GetDictionaryEntryCount | Gets the number of dictionary entries. (Inherited from SqlDataProvider.)
Public method | GetEventQueue | Gets the event queue driver. (Inherited from SqlDataProvider.)
Protected method | GetFieldSharingConverter | Gets a SqlDataProvider..::..FieldSharingConverter. (Inherited from SqlDataProvider.)
Protected method | GetFieldValue | Gets the field value. (Inherited from SqlDataProvider.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetIdEnumerator | Gets all id values. (Inherited from SqlDataProvider.)
Public method | GetItemDefinition | Gets the definition of an item. (Inherited from SqlDataProvider.)
Public method | GetItemFields | Gets the fields of a specific item version. (Inherited from SqlDataProvider.)
Protected method | GetItemKeyColumnName | Gets the name of the 'item name' column. (Inherited from SqlDataProvider.)
Public method | GetItemsInWorkflowState | Gets all items that are in a specific workflow state. (Inherited from SqlDataProvider.)
Public method | GetItemVersions | Gets a list of the available versions of an item. (Inherited from SqlDataProvider.)
Public method | GetLanguages()()()() | Gets a list of all the language that have been defined in the database. (Inherited from SqlDataProvider.)
Public method | GetLanguages(CallContext) | Gets a list of all the language that have been defined in the database. (Inherited from SqlDataProvider.)
Protected method | GetLock | Gets a lock. (Inherited from SqlDataProvider.)
Public method | GetParentID | Gets the parent ID of an item. (Inherited from SqlDataProvider.)
Protected method | GetPrefetchDataFromCache | Gets the prefetch data from cache. (Inherited from SqlDataProvider.)
Public method | GetProperty | Gets a property. (Inherited from SqlDataProvider.)
Protected method | GetPropertyCore | Gets the property core. (Inherited from SqlDataProvider.)
Public method | GetPropertyKeys | Gets a list of property keys matching a specific prefix. (Inherited from SqlDataProvider.)
Public method | GetPublishQueue | Gets the publish queue. (Inherited from SqlDataProvider.)
Protected method | GetResolverSql | Gets the resolver SQL. (Inherited from SqlDataProvider.)
Public method | GetRootID | Gets the root ID. (Inherited from SqlDataProvider.)
Public method | GetSharingType | Gets the type of the sharing. (Inherited from SqlDataProvider.)
Public method | GetTemplateItemIds | Gets the template item id. (Inherited from SqlDataProvider.)
Public method | GetTemplates | Gets the templates. (Inherited from DataProvider.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetVersions | Gets a list of all versions that have been defined in the entire database. (Inherited from SqlDataProvider.)
Public method | GetWorkflowInfo | Gets the workflow info form an item. (Inherited from DataProvider.)
Public method | HasChildren | Determines whether the specified item definition has children. (Inherited from SqlDataProvider.)
Public method | IsEnabled | Determines whether the specified method is enabled. (Inherited from DataProvider.)
Protected method | LoadChildIds | Loads the child ids. (Overrides SqlDataProvider..::..LoadChildIds(String, array<Object>[]()[][], SafeDictionary<(Of <<'(ID, PrefetchData>)>>)).)
Protected method | LoadItemDefinitions | Loads the item definitions. (Overrides SqlDataProvider..::..LoadItemDefinitions(String, array<Object>[]()[][], SafeDictionary<(Of <<'(ID, PrefetchData>)>>)).)
Protected method | LoadItemFields | Loads the item fields. (Overrides SqlDataProvider..::..LoadItemFields(String, String, array<Object>[]()[][], SafeDictionary<(Of <<'(ID, PrefetchData>)>>)).)
Protected method | LoadLanguages | Loads the list of languages from the database. (Inherited from SqlDataProvider.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveItem | Moves an item (ie. changes its parent). (Inherited from SqlDataProvider.)
Protected method | QueryFast | Executes fast query. (Inherited from SqlDataProvider.)
Protected method | RebuildDescendants | Rebuilds the descendants table. (Inherited from SqlDataProvider.)
Protected method | RemoveFields | Removes the fields. (Overrides SqlDataProvider..::..RemoveFields(ID, Language, Version).)
Public method | RemoveLanguageData | Removes a language and all the data using the language from the database. (Inherited from SqlDataProvider.)
Protected method | RemovePrefetchDataFromCache | Removes prefetch data from the cache. (Inherited from SqlDataProvider.)
Public method | RemoveProperty | Removes a property. (Inherited from SqlDataProvider.)
Protected method | RemovePropertyCore | Removes the property core. (Inherited from SqlDataProvider.)
Public method | RemoveVersion | Removes a version from an item. (Inherited from SqlDataProvider.)
Public method | RemoveVersions(ItemDefinition, Language, CallContext) | Removes versions from an item. (Inherited from DataProvider.)
Public method | RemoveVersions(ItemDefinition, Language, Boolean, CallContext) | Removes versions from an item. (Inherited from SqlDataProvider.)
Public method | RenameLanguageData | Renames a language binding. (Inherited from SqlDataProvider.)
Protected method | ResolveNames | Resolves the names. (Inherited from SqlDataProvider.)
Public method | ResolvePath | Resolves the path. (Inherited from DataProvider.)
Public method | SaveItem | Saves an item. (Inherited from SqlDataProvider.)
Public method | SelectIDs | Selects a set of ids. (Inherited from SqlDataProvider.)
Public method | SelectSingleID | Selects a single ID. (Inherited from SqlDataProvider.)
Public method | SetBlobStream | Sets the BLOB stream associated with a field. (Overrides DataProvider..::..SetBlobStream(Stream, Guid, CallContext).)
Protected method | SetFieldValue | Sets the field value. (Inherited from SqlDataProvider.)
Public method | SetProperty | Sets a property. (Inherited from SqlDataProvider.)
Protected method | SetPropertyCore | Sets the property core. (Inherited from SqlDataProvider.)
Public method | SetWorkflowInfo | Sets the workflow info for an item. (Inherited from DataProvider.)
Protected method | StartRebuildDescendants | Starts the rebuild descendants. (Inherited from SqlDataProvider.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateFieldValues | Updates field values. (Inherited from SqlDataProvider.)
Protected method | WriteSharedField | Writes the shared field. (Inherited from SqlDataProvider.)
Protected method | WriteUnversionedField | Writes the unversioned field. (Inherited from SqlDataProvider.)
Protected method | WriteVersionedField | Writes the versioned field. (Inherited from SqlDataProvider.)

See Also

SqlServerDataProvider Class
Sitecore.Data.SqlServer Namespace


BlobStreamExists Method

[image]

Sitecore 6.4.1 API
SqlServerDataProvider..::..BlobStreamExists Method
SqlServerDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool BlobStreamExists(
    Guid blobId,
    CallContext context
)
Visual Basic
Public Overrides Function BlobStreamExists ( _
    blobId As Guid, _
    context As CallContext _
) As Boolean
Visual C++
public:
virtual bool BlobStreamExists(
    Guid blobId,
    CallContext^ context
) override

Parameters

blobId
Type: System..::..Guid
The BLOB id.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

true if the specified item definition has children; otherwise, false.

See Also

SqlServerDataProvider Class
Sitecore.Data.SqlServer Namespace


DeleteItem Method

[image]

Sitecore 6.4.1 API
SqlServerDataProvider..::..DeleteItem Method
SqlServerDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool DeleteItem(
    ItemDefinition itemDefinition,
    CallContext context
)
Visual Basic
Public Overrides Function DeleteItem ( _
    itemDefinition As ItemDefinition, _
    context As CallContext _
) As Boolean
Visual C++
public:
virtual bool DeleteItem(
    ItemDefinition^ itemDefinition,
    CallContext^ context
) override

Parameters

itemDefinition
Type: Sitecore.Data..::..ItemDefinition
The item definition.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The context.

Return Value

The delete item.

See Also

SqlServerDataProvider Class
Sitecore.Data.SqlServer Namespace


GetBlobStream Method

[image]

Sitecore 6.4.1 API
SqlServerDataProvider..::..GetBlobStream Method
SqlServerDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Stream GetBlobStream(
    Guid blobId,
    CallContext context
)
Visual Basic
Public Overrides Function GetBlobStream ( _
    blobId As Guid, _
    context As CallContext _
) As Stream
Visual C++
public:
virtual Stream^ GetBlobStream(
    Guid blobId,
    CallContext^ context
) override

Parameters

blobId
Type: System..::..Guid
The BLOB id.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The call context.

Return Value

The stream.

See Also

SqlServerDataProvider Class
Sitecore.Data.SqlServer Namespace


GetLanguages Method

[image] [image]

Sitecore 6.4.1 API
SqlServerDataProvider..::..GetLanguages Method
SqlServerDataProvider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetLanguages()()()() | Gets a list of all the language that have been defined in the database. (Inherited from SqlDataProvider.)
Public method | GetLanguages(CallContext) | Gets a list of all the language that have been defined in the database. (Inherited from SqlDataProvider.)

See Also

SqlServerDataProvider Class
SqlServerDataProvider Members
Sitecore.Data.SqlServer Namespace


LoadChildIds Method

[image]

Sitecore 6.4.1 API
SqlServerDataProvider..::..LoadChildIds Method
SqlServerDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void LoadChildIds(
    string condition,
    Object[] parameters,
    SafeDictionary<ID, PrefetchData> prefetchData
)
Visual Basic
Protected Overrides Sub LoadChildIds ( _
    condition As String, _
    parameters As Object(), _
    prefetchData As SafeDictionary(Of ID, PrefetchData) _
)
Visual C++
protected:
virtual void LoadChildIds(
    String^ condition,
    array<Object^>^ parameters,
    SafeDictionary<ID^, PrefetchData^>^ prefetchData
) override

Parameters

condition
Type: System..::..String
The condition.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.
prefetchData
Type: Sitecore.Collections..::..SafeDictionary <(Of <(<' ID, PrefetchData >)>)>
The working set.

See Also

SqlServerDataProvider Class
Sitecore.Data.SqlServer Namespace


LoadItemDefinitions Method

[image]

Sitecore 6.4.1 API
SqlServerDataProvider..::..LoadItemDefinitions Method
SqlServerDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void LoadItemDefinitions(
    string condition,
    Object[] parameters,
    SafeDictionary<ID, PrefetchData> prefetchData
)
Visual Basic
Protected Overrides Sub LoadItemDefinitions ( _
    condition As String, _
    parameters As Object(), _
    prefetchData As SafeDictionary(Of ID, PrefetchData) _
)
Visual C++
protected:
virtual void LoadItemDefinitions(
    String^ condition,
    array<Object^>^ parameters,
    SafeDictionary<ID^, PrefetchData^>^ prefetchData
) override

Parameters

condition
Type: System..::..String
The condition.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.
prefetchData
Type: Sitecore.Collections..::..SafeDictionary <(Of <(<' ID, PrefetchData >)>)>
The working set.

Exceptions

Exception | Condition
System..::..Exception | Exception.

See Also

SqlServerDataProvider Class
Sitecore.Data.SqlServer Namespace


RemoveFields Method

[image]

Sitecore 6.4.1 API
SqlServerDataProvider..::..RemoveFields Method
SqlServerDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void RemoveFields(
    ID itemId,
    Language language,
    Version version
)
Visual Basic
Protected Overrides Sub RemoveFields ( _
    itemId As ID, _
    language As Language, _
    version As Version _
)
Visual C++
protected:
virtual void RemoveFields(
    ID^ itemId,
    Language^ language,
    Version^ version
) override

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
language
Type: Sitecore.Globalization..::..Language
The language.
version
Type: Sitecore.Data..::..Version
The version.

See Also

SqlServerDataProvider Class
Sitecore.Data.SqlServer Namespace


RemoveVersions Method

[image] [image]

Sitecore 6.4.1 API
SqlServerDataProvider..::..RemoveVersions Method
SqlServerDataProvider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveVersions(ItemDefinition, Language, CallContext) | Removes versions from an item. (Inherited from DataProvider.)
Public method | RemoveVersions(ItemDefinition, Language, Boolean, CallContext) | Removes versions from an item. (Inherited from SqlDataProvider.)

See Also

SqlServerDataProvider Class
SqlServerDataProvider Members
Sitecore.Data.SqlServer Namespace


SetBlobStream Method

[image]

Sitecore 6.4.1 API
SqlServerDataProvider..::..SetBlobStream Method
SqlServerDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool SetBlobStream(
    Stream stream,
    Guid blobId,
    CallContext context
)
Visual Basic
Public Overrides Function SetBlobStream ( _
    stream As Stream, _
    blobId As Guid, _
    context As CallContext _
) As Boolean
Visual C++
public:
virtual bool SetBlobStream(
    Stream^ stream,
    Guid blobId,
    CallContext^ context
) override

Parameters

stream
Type: System.IO..::..Stream
The stream.
blobId
Type: System..::..Guid
The BLOB id.
context
Type: Sitecore.Data.DataProviders..::..CallContext
The call context.

Return Value

The set blob stream.

See Also

SqlServerDataProvider Class
Sitecore.Data.SqlServer Namespace


SqlServerDataProvider Properties

[image] [image]

Sitecore 6.4.1 API
SqlServerDataProvider Properties
SqlServerDataProvider Class See Also Send Feedback

The SqlServerDataProvider type exposes the following members.

Properties

 | Name | Description
Protected property | Api | Gets the data API to the physical database. (Inherited from SqlDataProvider.)
Public property | BlobChunkSize | Gets the size of the individual chunks making up a BLOB.
Public property | CacheOptions | Gets the cache options. (Inherited from DataProvider.)
Public property | Database | Gets the database. (Inherited from DataProvider.)
Protected property | DescendantsShouldBeUpdated | Gets or sets a value indicating whether Descendants table should be updated (Inherited from SqlDataProvider.)
Protected property | Disable | Disables a method. (Inherited from DataProvider.)
Protected property | DisableGroup | Disables a group. (Inherited from DataProvider.)
Protected property | Enable | Enables a method. (Inherited from DataProvider.)
Protected property | EnableGroup | Enables a group. (Inherited from DataProvider.)
Protected property | Languages | Gets or sets languages (Inherited from SqlDataProvider.)
Public property | Name | Gets or sets the name. (Inherited from SqlDataProvider.)
Protected property | PrefetchCache | Gets the prefetch cache. (Inherited from SqlDataProvider.)
Protected property | PropertyCache | Gets the property cache. (Inherited from SqlDataProvider.)
Protected property | RebuildThread | Gets or sets a value indicating rebuilding thread (Inherited from SqlDataProvider.)
Protected property | SkipDescendantsUpdate | Gets a value indicating whether Descendantsd table should be updated. (Inherited from SqlDataProvider.)
Protected property | Translator | Gets the Sitecore Query to SQL translator. (Inherited from SqlDataProvider.)

See Also

SqlServerDataProvider Class
Sitecore.Data.SqlServer Namespace


BlobChunkSize Property

[image]

Sitecore 6.4.1 API
SqlServerDataProvider..::..BlobChunkSize Property
SqlServerDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual int BlobChunkSize { get; }
Visual Basic
Public Overridable ReadOnly Property BlobChunkSize As Integer
    Get
Visual C++
public:
virtual property int BlobChunkSize {
    int get ();
}

Field Value

The size of the BLOB chunk.

See Also

SqlServerDataProvider Class
Sitecore.Data.SqlServer Namespace


SqlServerHistoryStorage Class

[image]

Sitecore 6.4.1 API
SqlServerHistoryStorage Class
Members See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SqlServerHistoryStorage : HistoryStorage
Visual Basic
Public Class SqlServerHistoryStorage _
    Inherits HistoryStorage
Visual C++
public ref class SqlServerHistoryStorage : public HistoryStorage

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Engines..::..HistoryStorage
Sitecore.Data.SqlServer..::..SqlServerHistoryStorage

See Also

SqlServerHistoryStorage Members
Sitecore.Data.SqlServer Namespace


SqlServerHistoryStorage Members

[image] [image]

Sitecore 6.4.1 API
SqlServerHistoryStorage Members
SqlServerHistoryStorage Class Constructors Methods Fields Properties See Also Send Feedback

The SqlServerHistoryStorage type exposes the following members.

Constructors

 | Name | Description
Public method | SqlServerHistoryStorage(String) | Initializes a new instance of the SqlServerHistoryStorage class.
Public method | SqlServerHistoryStorage(SqlDataApi) | Initializes a new instance of the SqlServerHistoryStorage class.

Methods

 | Name | Description
Public method | AddEntry | Adds an entry to the database. (Overrides HistoryStorage..::..AddEntry(HistoryEntry).)
Public method | Cleanup | Removes outdated entries from storage. (Overrides HistoryStorage..::..Cleanup()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHistory | Gets the history for the database in a specified interval. (Overrides HistoryStorage..::..GetHistory(DateTime, DateTime).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _api | Data API

Properties

 | Name | Description
Public property | EntryLifeTime | Gets or sets the entry life time. (Inherited from HistoryStorage.)

See Also

SqlServerHistoryStorage Class
Sitecore.Data.SqlServer Namespace


SqlServerHistoryStorage Constructor

[image] [image]

Sitecore 6.4.1 API
SqlServerHistoryStorage Constructor
SqlServerHistoryStorage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SqlServerHistoryStorage(String) | Initializes a new instance of the SqlServerHistoryStorage class.
Public method | SqlServerHistoryStorage(SqlDataApi) | Initializes a new instance of the SqlServerHistoryStorage class.

See Also

SqlServerHistoryStorage Class
SqlServerHistoryStorage Members
Sitecore.Data.SqlServer Namespace


SqlServerHistoryStorage Constructor (SqlDataApi)

[image]

Sitecore 6.4.1 API
SqlServerHistoryStorage Constructor (SqlDataApi)
SqlServerHistoryStorage Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlServerHistoryStorage(
    SqlDataApi api
)
Visual Basic
Public Sub New ( _
    api As SqlDataApi _
)
Visual C++
public:
SqlServerHistoryStorage(
    SqlDataApi^ api
)

Parameters

api
Type: Sitecore.Data.DataProviders.Sql..::..SqlDataApi
The API.

See Also

SqlServerHistoryStorage Class
SqlServerHistoryStorage Overload
Sitecore.Data.SqlServer Namespace


SqlServerHistoryStorage Fields

[image] [image]

Sitecore 6.4.1 API
SqlServerHistoryStorage Fields
SqlServerHistoryStorage Class See Also Send Feedback

The SqlServerHistoryStorage type exposes the following members.

Fields

 | Name | Description
Protected field | _api | Data API

See Also

SqlServerHistoryStorage Class
Sitecore.Data.SqlServer Namespace


_api Field

[image]

Sitecore 6.4.1 API
SqlServerHistoryStorage..::.._api Field
SqlServerHistoryStorage Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected SqlDataApi _api
Visual Basic
Protected _api As SqlDataApi
Visual C++
protected:
SqlDataApi^ _api

See Also

SqlServerHistoryStorage Class
Sitecore.Data.SqlServer Namespace


SqlServerHistoryStorage Methods

[image] [image]

Sitecore 6.4.1 API
SqlServerHistoryStorage Methods
SqlServerHistoryStorage Class See Also Send Feedback

The SqlServerHistoryStorage type exposes the following members.

Methods

 | Name | Description
Public method | AddEntry | Adds an entry to the database. (Overrides HistoryStorage..::..AddEntry(HistoryEntry).)
Public method | Cleanup | Removes outdated entries from storage. (Overrides HistoryStorage..::..Cleanup()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHistory | Gets the history for the database in a specified interval. (Overrides HistoryStorage..::..GetHistory(DateTime, DateTime).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SqlServerHistoryStorage Class
Sitecore.Data.SqlServer Namespace


AddEntry Method

[image]

Sitecore 6.4.1 API
SqlServerHistoryStorage..::..AddEntry Method
SqlServerHistoryStorage Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void AddEntry(
    HistoryEntry entry
)
Visual Basic
Public Overrides Sub AddEntry ( _
    entry As HistoryEntry _
)
Visual C++
public:
virtual void AddEntry(
    HistoryEntry^ entry
) override

Parameters

entry
Type: Sitecore.Data.Engines..::..HistoryEntry
The entry.

See Also

SqlServerHistoryStorage Class
Sitecore.Data.SqlServer Namespace


Cleanup Method

[image]

Sitecore 6.4.1 API
SqlServerHistoryStorage..::..Cleanup Method
SqlServerHistoryStorage Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Cleanup()
Visual Basic
Public Overrides Sub Cleanup
Visual C++
public:
virtual void Cleanup() override

See Also

SqlServerHistoryStorage Class
Sitecore.Data.SqlServer Namespace


GetHistory Method

[image]

Sitecore 6.4.1 API
SqlServerHistoryStorage..::..GetHistory Method
SqlServerHistoryStorage Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override HistoryEntryCollection GetHistory(
    DateTime from,
    DateTime to
)
Visual Basic
Public Overrides Function GetHistory ( _
    from As DateTime, _
    to As DateTime _
) As HistoryEntryCollection
Visual C++
public:
virtual HistoryEntryCollection^ GetHistory(
    DateTime from,
    DateTime to
) override

Parameters

from
Type: System..::..DateTime
From date (UTC).
to
Type: System..::..DateTime
To date (UTC).

Return Value

The history entries for the period.

See Also

SqlServerHistoryStorage Class
Sitecore.Data.SqlServer Namespace


SqlServerHistoryStorage Properties

[image] [image]

Sitecore 6.4.1 API
SqlServerHistoryStorage Properties
SqlServerHistoryStorage Class See Also Send Feedback

The SqlServerHistoryStorage type exposes the following members.

Properties

 | Name | Description
Public property | EntryLifeTime | Gets or sets the entry life time. (Inherited from HistoryStorage.)

See Also

SqlServerHistoryStorage Class
Sitecore.Data.SqlServer Namespace


SqlServerHistoryStore Members

[image] [image]

Sitecore 6.4.1 API
SqlServerHistoryStore Members
SqlServerHistoryStore Class Constructors Methods Fields See Also Send Feedback

The SqlServerHistoryStore type exposes the following members.

Constructors

 | Name | Description
Public method | SqlServerHistoryStore(String) | Initializes a new instance of the SqlServerHistoryStore class.
Public method | SqlServerHistoryStore(SqlDataApi) | Initializes a new instance of the SqlServerHistoryStore class.

Methods

 | Name | Description
Public method | AddHistory | Adds the history. (Overrides HistoryStore..::..AddHistory(Item, String, String, String).)
Public method | ClearHistory | Clears the history. (Overrides HistoryStore..::..ClearHistory(Item).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHistory | Gets the history of the specified item. (Overrides HistoryStore..::..GetHistory(Item).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _api | Data API

See Also

SqlServerHistoryStore Class
Sitecore.Data.SqlServer Namespace


SqlServerHistoryStore Constructor

[image] [image]

Sitecore 6.4.1 API
SqlServerHistoryStore Constructor
SqlServerHistoryStore Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SqlServerHistoryStore(String) | Initializes a new instance of the SqlServerHistoryStore class.
Public method | SqlServerHistoryStore(SqlDataApi) | Initializes a new instance of the SqlServerHistoryStore class.

See Also

SqlServerHistoryStore Class
SqlServerHistoryStore Members
Sitecore.Data.SqlServer Namespace


SqlServerHistoryStore Constructor (String)

[image]

Sitecore 6.4.1 API
SqlServerHistoryStore Constructor (String)
SqlServerHistoryStore Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlServerHistoryStore(
    string connectionString
)
Visual Basic
Public Sub New ( _
    connectionString As String _
)
Visual C++
public:
SqlServerHistoryStore(
    String^ connectionString
)

Parameters

connectionString
Type: System..::..String
The connection string.

See Also

SqlServerHistoryStore Class
SqlServerHistoryStore Overload
Sitecore.Data.SqlServer Namespace


SqlServerHistoryStore Constructor (SqlDataApi)

[image]

Sitecore 6.4.1 API
SqlServerHistoryStore Constructor (SqlDataApi)
SqlServerHistoryStore Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlServerHistoryStore(
    SqlDataApi api
)
Visual Basic
Public Sub New ( _
    api As SqlDataApi _
)
Visual C++
public:
SqlServerHistoryStore(
    SqlDataApi^ api
)

Parameters

api
Type: Sitecore.Data.DataProviders.Sql..::..SqlDataApi
The API.

See Also

SqlServerHistoryStore Class
SqlServerHistoryStore Overload
Sitecore.Data.SqlServer Namespace


SqlServerHistoryStore Fields

[image] [image]

Sitecore 6.4.1 API
SqlServerHistoryStore Fields
SqlServerHistoryStore Class See Also Send Feedback

The SqlServerHistoryStore type exposes the following members.

Fields

 | Name | Description
Protected field | _api | Data API

See Also

SqlServerHistoryStore Class
Sitecore.Data.SqlServer Namespace


_api Field

[image]

Sitecore 6.4.1 API
SqlServerHistoryStore..::.._api Field
SqlServerHistoryStore Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected SqlDataApi _api
Visual Basic
Protected _api As SqlDataApi
Visual C++
protected:
SqlDataApi^ _api

See Also

SqlServerHistoryStore Class
Sitecore.Data.SqlServer Namespace


SqlServerHistoryStore Methods

[image] [image]

Sitecore 6.4.1 API
SqlServerHistoryStore Methods
SqlServerHistoryStore Class See Also Send Feedback

The SqlServerHistoryStore type exposes the following members.

Methods

 | Name | Description
Public method | AddHistory | Adds the history. (Overrides HistoryStore..::..AddHistory(Item, String, String, String).)
Public method | ClearHistory | Clears the history. (Overrides HistoryStore..::..ClearHistory(Item).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHistory | Gets the history of the specified item. (Overrides HistoryStore..::..GetHistory(Item).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SqlServerHistoryStore Class
Sitecore.Data.SqlServer Namespace


AddHistory Method

[image]

Sitecore 6.4.1 API
SqlServerHistoryStore..::..AddHistory Method
SqlServerHistoryStore Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void AddHistory(
    Item item,
    string oldState,
    string newState,
    string text
)
Visual Basic
Public Overrides Sub AddHistory ( _
    item As Item, _
    oldState As String, _
    newState As String, _
    text As String _
)
Visual C++
public:
virtual void AddHistory(
    Item^ item,
    String^ oldState,
    String^ newState,
    String^ text
) override

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
oldState
Type: System..::..String
The old state.
newState
Type: System..::..String
The new state.
text
Type: System..::..String
The text.

See Also

SqlServerHistoryStore Class
Sitecore.Data.SqlServer Namespace


GetHistory Method

[image]

Sitecore 6.4.1 API
SqlServerHistoryStore..::..GetHistory Method
SqlServerHistoryStore Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override WorkflowEvent[] GetHistory(
    Item item
)
Visual Basic
Public Overrides Function GetHistory ( _
    item As Item _
) As WorkflowEvent()
Visual C++
public:
virtual array<WorkflowEvent^>^ GetHistory(
    Item^ item
) override

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

The history.

See Also

SqlServerHistoryStore Class
Sitecore.Data.SqlServer Namespace


SqlServerIDTable Class

[image]

Sitecore 6.4.1 API
SqlServerIDTable Class
Members See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SqlServerIDTable : IDTableProvider
Visual Basic
Public Class SqlServerIDTable _
    Inherits IDTableProvider
Visual C++
public ref class SqlServerIDTable : public IDTableProvider

Inheritance Hierarchy

System..::..Object
Sitecore.Data.IDTables..::..IDTableProvider
Sitecore.Data.SqlServer..::..SqlServerIDTable

See Also

SqlServerIDTable Members
Sitecore.Data.SqlServer Namespace


SqlServerIDTable Members

[image] [image]

Sitecore 6.4.1 API
SqlServerIDTable Members
SqlServerIDTable Class Constructors Methods Properties See Also Send Feedback

The SqlServerIDTable type exposes the following members.

Constructors

 | Name | Description
Public method | SqlServerIDTable(String, String) | Initializes a new instance of the SqlServerIDTable class.
Public method | SqlServerIDTable(SqlDataApi, String) | Initializes a new instance of the SqlServerIDTable class.

Methods

 | Name | Description
Public method | Add | Adds the specified IDTable entry. (Overrides IDTableProvider..::..Add(IDTableEntry).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCacheKey | Gets the cache key.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetID | Gets the ID. (Overrides IDTableProvider..::..GetID(String, String).)
Public method | GetKeys(String) | The list of IDTable entries. (Overrides IDTableProvider..::..GetKeys(String).)
Public method | GetKeys(String, ID) | Gets the keys. (Overrides IDTableProvider..::..GetKeys(String, ID).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the specified prefix. (Overrides IDTableProvider..::..Remove(String, String).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Protected property | Api | Gets the Data API.
Protected property | Cache | Gets the IDTable cache.

See Also

SqlServerIDTable Class
Sitecore.Data.SqlServer Namespace


SqlServerIDTable Constructor

[image] [image]

Sitecore 6.4.1 API
SqlServerIDTable Constructor
SqlServerIDTable Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SqlServerIDTable(String, String) | Initializes a new instance of the SqlServerIDTable class.
Public method | SqlServerIDTable(SqlDataApi, String) | Initializes a new instance of the SqlServerIDTable class.

See Also

SqlServerIDTable Class
SqlServerIDTable Members
Sitecore.Data.SqlServer Namespace


SqlServerIDTable Constructor (String, String)

[image]

Sitecore 6.4.1 API
SqlServerIDTable Constructor (String, String)
SqlServerIDTable Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlServerIDTable(
    string connectionString,
    string cacheSize
)
Visual Basic
Public Sub New ( _
    connectionString As String, _
    cacheSize As String _
)
Visual C++
public:
SqlServerIDTable(
    String^ connectionString,
    String^ cacheSize
)

Parameters

connectionString
Type: System..::..String
The connection string.
cacheSize
Type: System..::..String
Size of the cache.

See Also

SqlServerIDTable Class
SqlServerIDTable Overload
Sitecore.Data.SqlServer Namespace


SqlServerIDTable Constructor (SqlDataApi, String)

[image]

Sitecore 6.4.1 API
SqlServerIDTable Constructor (SqlDataApi, String)
SqlServerIDTable Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlServerIDTable(
    SqlDataApi api,
    string cacheSize
)
Visual Basic
Public Sub New ( _
    api As SqlDataApi, _
    cacheSize As String _
)
Visual C++
public:
SqlServerIDTable(
    SqlDataApi^ api,
    String^ cacheSize
)

Parameters

api
Type: Sitecore.Data.DataProviders.Sql..::..SqlDataApi
The Data API.
cacheSize
Type: System..::..String
Size of the cache.

See Also

SqlServerIDTable Class
SqlServerIDTable Overload
Sitecore.Data.SqlServer Namespace


SqlServerIDTable Methods

[image] [image]

Sitecore 6.4.1 API
SqlServerIDTable Methods
SqlServerIDTable Class See Also Send Feedback

The SqlServerIDTable type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified IDTable entry. (Overrides IDTableProvider..::..Add(IDTableEntry).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCacheKey | Gets the cache key.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetID | Gets the ID. (Overrides IDTableProvider..::..GetID(String, String).)
Public method | GetKeys(String) | The list of IDTable entries. (Overrides IDTableProvider..::..GetKeys(String).)
Public method | GetKeys(String, ID) | Gets the keys. (Overrides IDTableProvider..::..GetKeys(String, ID).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the specified prefix. (Overrides IDTableProvider..::..Remove(String, String).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SqlServerIDTable Class
Sitecore.Data.SqlServer Namespace


Add Method

[image]

Sitecore 6.4.1 API
SqlServerIDTable..::..Add Method
SqlServerIDTable Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Add(
    IDTableEntry entry
)
Visual Basic
Public Overrides Sub Add ( _
    entry As IDTableEntry _
)
Visual C++
public:
virtual void Add(
    IDTableEntry^ entry
) override

Parameters

entry
Type: Sitecore.Data.IDTables..::..IDTableEntry
The IDTable entry.

See Also

SqlServerIDTable Class
Sitecore.Data.SqlServer Namespace


GetCacheKey Method

[image]

Sitecore 6.4.1 API
SqlServerIDTable..::..GetCacheKey Method
SqlServerIDTable Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string GetCacheKey(
    string prefix,
    string key
)
Visual Basic
Protected Overridable Function GetCacheKey ( _
    prefix As String, _
    key As String _
) As String
Visual C++
protected:
virtual String^ GetCacheKey(
    String^ prefix,
    String^ key
)

Parameters

prefix
Type: System..::..String
The entry prefix.
key
Type: System..::..String
The entry key.

Return Value

The cache key.

See Also

SqlServerIDTable Class
Sitecore.Data.SqlServer Namespace


GetID Method

[image]

Sitecore 6.4.1 API
SqlServerIDTable..::..GetID Method
SqlServerIDTable Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override IDTableEntry GetID(
    string prefix,
    string key
)
Visual Basic
Public Overrides Function GetID ( _
    prefix As String, _
    key As String _
) As IDTableEntry
Visual C++
public:
virtual IDTableEntry^ GetID(
    String^ prefix,
    String^ key
) override

Parameters

prefix
Type: System..::..String
The entry prefix.
key
Type: System..::..String
The entry key.

Return Value

The entry ID.

See Also

SqlServerIDTable Class
Sitecore.Data.SqlServer Namespace


GetKeys Method

[image] [image]

Sitecore 6.4.1 API
SqlServerIDTable..::..GetKeys Method
SqlServerIDTable Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetKeys(String) | The list of IDTable entries. (Overrides IDTableProvider..::..GetKeys(String).)
Public method | GetKeys(String, ID) | Gets the keys. (Overrides IDTableProvider..::..GetKeys(String, ID).)

See Also

SqlServerIDTable Class
SqlServerIDTable Members
Sitecore.Data.SqlServer Namespace


GetKeys Method (String)

[image]

Sitecore 6.4.1 API
SqlServerIDTable..::..GetKeys Method (String)
SqlServerIDTable Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override IDTableEntry[] GetKeys(
    string prefix
)
Visual Basic
Public Overrides Function GetKeys ( _
    prefix As String _
) As IDTableEntry()
Visual C++
public:
virtual array<IDTableEntry^>^ GetKeys(
    String^ prefix
) override

Parameters

prefix
Type: System..::..String
The prefix.

Return Value

The list of IDTable entries with specified prefix

See Also

SqlServerIDTable Class
GetKeys Overload
Sitecore.Data.SqlServer Namespace


GetKeys Method (String, ID)

[image]

Sitecore 6.4.1 API
SqlServerIDTable..::..GetKeys Method (String, ID)
SqlServerIDTable Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override IDTableEntry[] GetKeys(
    string prefix,
    ID id
)
Visual Basic
Public Overrides Function GetKeys ( _
    prefix As String, _
    id As ID _
) As IDTableEntry()
Visual C++
public:
virtual array<IDTableEntry^>^ GetKeys(
    String^ prefix,
    ID^ id
) override

Parameters

prefix
Type: System..::..String
The entry prefix.
id
Type: Sitecore.Data..::..ID
The entry id.

Return Value

The IDTable keys.

See Also

SqlServerIDTable Class
GetKeys Overload
Sitecore.Data.SqlServer Namespace


Remove Method

[image]

Sitecore 6.4.1 API
SqlServerIDTable..::..Remove Method
SqlServerIDTable Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Remove(
    string prefix,
    string key
)
Visual Basic
Public Overrides Sub Remove ( _
    prefix As String, _
    key As String _
)
Visual C++
public:
virtual void Remove(
    String^ prefix,
    String^ key
) override

Parameters

prefix
Type: System..::..String
The entry prefix.
key
Type: System..::..String
The entry key.

See Also

SqlServerIDTable Class
Sitecore.Data.SqlServer Namespace


SqlServerIDTable Properties

[image] [image]

Sitecore 6.4.1 API
SqlServerIDTable Properties
SqlServerIDTable Class See Also Send Feedback

The SqlServerIDTable type exposes the following members.

Properties

 | Name | Description
Protected property | Api | Gets the Data API.
Protected property | Cache | Gets the IDTable cache.

See Also

SqlServerIDTable Class
Sitecore.Data.SqlServer Namespace


Api Property

[image]

Sitecore 6.4.1 API
SqlServerIDTable..::..Api Property
SqlServerIDTable Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual SqlDataApi Api { get; }
Visual Basic
Protected Overridable ReadOnly Property Api As SqlDataApi
    Get
Visual C++
protected:
virtual property SqlDataApi^ Api {
    SqlDataApi^ get ();
}

Field Value

The Data API.

See Also

SqlServerIDTable Class
Sitecore.Data.SqlServer Namespace


Cache Property

[image]

Sitecore 6.4.1 API
SqlServerIDTable..::..Cache Property
SqlServerIDTable Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual Cache Cache { get; }
Visual Basic
Protected Overridable ReadOnly Property Cache As Cache
    Get
Visual C++
protected:
virtual property Cache^ Cache {
    Cache^ get ();
}

Field Value

The IDTable cache.

See Also

SqlServerIDTable Class
Sitecore.Data.SqlServer Namespace


SqlServerLinkDatabase Class

[image]

Sitecore 6.4.1 API
SqlServerLinkDatabase Class
Members See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SqlServerLinkDatabase : SqlLinkDatabase
Visual Basic
Public Class SqlServerLinkDatabase _
    Inherits SqlLinkDatabase
Visual C++
public ref class SqlServerLinkDatabase : public SqlLinkDatabase

Inheritance Hierarchy

System..::..Object
Sitecore.Links..::..LinkDatabase
Sitecore.Links..::..SqlLinkDatabase
Sitecore.Data.SqlServer..::..SqlServerLinkDatabase

See Also

SqlServerLinkDatabase Members
Sitecore.Data.SqlServer Namespace


SqlServerLinkDatabase Members

[image] [image]

Sitecore 6.4.1 API
SqlServerLinkDatabase Members
SqlServerLinkDatabase Class Constructors Methods Fields Properties See Also Send Feedback

The SqlServerLinkDatabase type exposes the following members.

Constructors

 | Name | Description
Public method | SqlServerLinkDatabase | Initializes a new instance of the SqlServerLinkDatabase class.

Methods

 | Name | Description
Protected method | AddLink | Adds the link. (Inherited from SqlLinkDatabase.)
Public method | Compact | Compacts the specified database. (Inherited from SqlLinkDatabase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBrokenLinks | Gets the broken links. (Inherited from SqlLinkDatabase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemVersionReferrers | Gets the item version referrers. (Inherited from SqlLinkDatabase.)
Public method | GetReferenceCount | Gets the reference count. (Inherited from SqlLinkDatabase.)
Public method | GetReferences | Gets the references. (Inherited from SqlLinkDatabase.)
Public method | GetRefererCount | Obsolete. Gets the referrer count. (Inherited from LinkDatabase.)
Public method | GetReferers | Obsolete. Gets the referrers. (Inherited from LinkDatabase.)
Public method | GetReferrerCount | Gets the referrer count. (Inherited from SqlLinkDatabase.)
Public method | GetReferrers(Item) | Gets the referrers. (Inherited from SqlLinkDatabase.)
Public method | GetReferrers(Item, Boolean) | Obsolete. Gets the referrers. (Inherited from SqlLinkDatabase.)
Protected method | GetString | Gets a string. (Inherited from SqlLinkDatabase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasExternalReferers | Obsolete. Determines whether the specified item has external referrers. (Inherited from LinkDatabase.)
Public method | HasExternalReferrers | Determines whether the specified item has external referrers. (Inherited from LinkDatabase.)
Protected method | ItemExists | Targets the exists. (Inherited from LinkDatabase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rebuild | Rebuilds the specified database. (Inherited from LinkDatabase.)
Protected method | RemoveItemVersionLinks | Removes the links. (Inherited from SqlLinkDatabase.)
Protected method | RemoveLinks | Removes the links. (Inherited from SqlLinkDatabase.)
Public method | RemoveReferences | Removes the references. (Inherited from SqlLinkDatabase.)
Protected method | TargetExists | Determines if the target exists. (Inherited from LinkDatabase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | UpdateItemVersionLinks | Updates the links. (Inherited from SqlLinkDatabase.)
Public method | UpdateItemVersionReferences | The update item version references. (Inherited from LinkDatabase.)
Protected method | UpdateLinks | Updates the links. (Inherited from SqlLinkDatabase.)
Public method | UpdateReferences | Updates the references. (Inherited from LinkDatabase.)

Fields

 | Name | Description
Protected field | _dataApi | Obsolete. data API (Inherited from SqlLinkDatabase.)

Properties

 | Name | Description
Public property | ConnectionString | Gets the connection string.
Protected property | DataApi | Gets the data API. (Inherited from SqlLinkDatabase.)

See Also

SqlServerLinkDatabase Class
Sitecore.Data.SqlServer Namespace


SqlServerLinkDatabase Constructor

[image]

Sitecore 6.4.1 API
SqlServerLinkDatabase Constructor
SqlServerLinkDatabase Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlServerLinkDatabase(
    string connectionString
)
Visual Basic
Public Sub New ( _
    connectionString As String _
)
Visual C++
public:
SqlServerLinkDatabase(
    String^ connectionString
)

Parameters

connectionString
Type: System..::..String
The connection string.

See Also

SqlServerLinkDatabase Class
Sitecore.Data.SqlServer Namespace


SqlServerLinkDatabase Fields

[image] [image]

Sitecore 6.4.1 API
SqlServerLinkDatabase Fields
SqlServerLinkDatabase Class See Also Send Feedback

The SqlServerLinkDatabase type exposes the following members.

Fields

 | Name | Description
Protected field | _dataApi | Obsolete. data API (Inherited from SqlLinkDatabase.)

See Also

SqlServerLinkDatabase Class
Sitecore.Data.SqlServer Namespace


GetReferrers Method

[image] [image]

Sitecore 6.4.1 API
SqlServerLinkDatabase..::..GetReferrers Method
SqlServerLinkDatabase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetReferrers(Item) | Gets the referrers. (Inherited from SqlLinkDatabase.)
Public method | GetReferrers(Item, Boolean) | Obsolete. Gets the referrers. (Inherited from SqlLinkDatabase.)

See Also

SqlServerLinkDatabase Class
SqlServerLinkDatabase Members
Sitecore.Data.SqlServer Namespace


SqlServerLinkDatabase Properties

[image] [image]

Sitecore 6.4.1 API
SqlServerLinkDatabase Properties
SqlServerLinkDatabase Class See Also Send Feedback

The SqlServerLinkDatabase type exposes the following members.

Properties

 | Name | Description
Public property | ConnectionString | Gets the connection string.
Protected property | DataApi | Gets the data API. (Inherited from SqlLinkDatabase.)

See Also

SqlServerLinkDatabase Class
Sitecore.Data.SqlServer Namespace


ConnectionString Property

[image]

Sitecore 6.4.1 API
SqlServerLinkDatabase..::..ConnectionString Property
SqlServerLinkDatabase Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string ConnectionString { get; }
Visual Basic
Public Overridable ReadOnly Property ConnectionString As String
    Get
Visual C++
public:
virtual property String^ ConnectionString {
    String^ get ();
}

Field Value

The connection string.

See Also

SqlServerLinkDatabase Class
Sitecore.Data.SqlServer Namespace


SqlServerProxyDataProvider Class

[image]

Sitecore 6.4.1 API
SqlServerProxyDataProvider Class
Members See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SqlServerProxyDataProvider : SqlProxyDataProvider
Visual Basic
Public Class SqlServerProxyDataProvider _
    Inherits SqlProxyDataProvider
Visual C++
public ref class SqlServerProxyDataProvider : public SqlProxyDataProvider

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Proxies..::..ProxyDataProvider
Sitecore.Data.Proxies..::..SqlProxyDataProvider
Sitecore.Data.SqlServer..::..SqlServerProxyDataProvider

See Also

SqlServerProxyDataProvider Members
Sitecore.Data.SqlServer Namespace


SqlServerProxyDataProvider Members

[image] [image]

Sitecore 6.4.1 API
SqlServerProxyDataProvider Members
SqlServerProxyDataProvider Class Constructors Methods Properties See Also Send Feedback

The SqlServerProxyDataProvider type exposes the following members.

Constructors

 | Name | Description
Public method | SqlServerProxyDataProvider | Initializes a new instance of the SqlServerDataProvider class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetReferences | Gets all references to a specific item. (Inherited from SqlProxyDataProvider.)
Public method | GetTarget | Gets the id of the item pointed to by a virtual id. (Inherited from SqlProxyDataProvider.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVirtualId | Gets the id of a shadow pointing to a specific item id within a specific proxy. (Inherited from SqlProxyDataProvider.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveData | Removes all data associated with a specific proxy. (Inherited from SqlProxyDataProvider.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | Gets or sets the name. (Inherited from ProxyDataProvider.)

See Also

SqlServerProxyDataProvider Class
Sitecore.Data.SqlServer Namespace


SqlServerProxyDataProvider Constructor

[image]

Sitecore 6.4.1 API
SqlServerProxyDataProvider Constructor
SqlServerProxyDataProvider Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlServerProxyDataProvider(
    string connectionString
)
Visual Basic
Public Sub New ( _
    connectionString As String _
)
Visual C++
public:
SqlServerProxyDataProvider(
    String^ connectionString
)

Parameters

connectionString
Type: System..::..String
The connection string.

See Also

SqlServerProxyDataProvider Class
Sitecore.Data.SqlServer Namespace


SqlServerProxyDataProvider Methods

[image] [image]

Sitecore 6.4.1 API
SqlServerProxyDataProvider Methods
SqlServerProxyDataProvider Class See Also Send Feedback

The SqlServerProxyDataProvider type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetReferences | Gets all references to a specific item. (Inherited from SqlProxyDataProvider.)
Public method | GetTarget | Gets the id of the item pointed to by a virtual id. (Inherited from SqlProxyDataProvider.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVirtualId | Gets the id of a shadow pointing to a specific item id within a specific proxy. (Inherited from SqlProxyDataProvider.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveData | Removes all data associated with a specific proxy. (Inherited from SqlProxyDataProvider.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SqlServerProxyDataProvider Class
Sitecore.Data.SqlServer Namespace


SqlServerProxyDataProvider Properties

[image] [image]

Sitecore 6.4.1 API
SqlServerProxyDataProvider Properties
SqlServerProxyDataProvider Class See Also Send Feedback

The SqlServerProxyDataProvider type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets or sets the name. (Inherited from ProxyDataProvider.)

See Also

SqlServerProxyDataProvider Class
Sitecore.Data.SqlServer Namespace


SqlServerTaskDatabase Members

[image] [image]

Sitecore 6.4.1 API
SqlServerTaskDatabase Members
SqlServerTaskDatabase Class Constructors Methods Properties See Also Send Feedback

The SqlServerTaskDatabase type exposes the following members.

Constructors

 | Name | Description
Public method | SqlServerTaskDatabase | Initializes a new instance of the SqlServerTaskDatabase class. The sql server task database.

Methods

 | Name | Description
Public method | Disable | The disable. (Overrides TaskDatabase..::..Disable(Task).)
Public method | Enable | The enable. (Overrides TaskDatabase..::..Enable(Task).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPendingTasks | Gets the pending tasks. (Overrides TaskDatabase..::..GetPendingTasks()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkDone | The mark done. (Overrides TaskDatabase..::..MarkDone(Task).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | The remove. (Overrides TaskDatabase..::..Remove(Task).)
Public method | RemoveItemTasks(Item) | The remove item tasks. (Overrides TaskDatabase..::..RemoveItemTasks(Item).)
Public method | RemoveItemTasks(Item, Type) | The remove item tasks. (Overrides TaskDatabase..::..RemoveItemTasks(Item, Type).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | The update. (Overrides TaskDatabase..::..Update(Task, Boolean).)
Public method | UpdateItemTask | The update item task. (Overrides TaskDatabase..::..UpdateItemTask(Task, Boolean).)

Properties

 | Name | Description
Public property | ConnectionString | Gets the connection string.

See Also

SqlServerTaskDatabase Class
Sitecore.Data.SqlServer Namespace


SqlServerTaskDatabase Constructor

[image]

Sitecore 6.4.1 API
SqlServerTaskDatabase Constructor
SqlServerTaskDatabase Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlServerTaskDatabase(
    string connectionString
)
Visual Basic
Public Sub New ( _
    connectionString As String _
)
Visual C++
public:
SqlServerTaskDatabase(
    String^ connectionString
)

Parameters

connectionString
Type: System..::..String
The connection String.

See Also

SqlServerTaskDatabase Class
Sitecore.Data.SqlServer Namespace


SqlServerTaskDatabase Methods

[image] [image]

Sitecore 6.4.1 API
SqlServerTaskDatabase Methods
SqlServerTaskDatabase Class See Also Send Feedback

The SqlServerTaskDatabase type exposes the following members.

Methods

 | Name | Description
Public method | Disable | The disable. (Overrides TaskDatabase..::..Disable(Task).)
Public method | Enable | The enable. (Overrides TaskDatabase..::..Enable(Task).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPendingTasks | Gets the pending tasks. (Overrides TaskDatabase..::..GetPendingTasks()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkDone | The mark done. (Overrides TaskDatabase..::..MarkDone(Task).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | The remove. (Overrides TaskDatabase..::..Remove(Task).)
Public method | RemoveItemTasks(Item) | The remove item tasks. (Overrides TaskDatabase..::..RemoveItemTasks(Item).)
Public method | RemoveItemTasks(Item, Type) | The remove item tasks. (Overrides TaskDatabase..::..RemoveItemTasks(Item, Type).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | The update. (Overrides TaskDatabase..::..Update(Task, Boolean).)
Public method | UpdateItemTask | The update item task. (Overrides TaskDatabase..::..UpdateItemTask(Task, Boolean).)

See Also

SqlServerTaskDatabase Class
Sitecore.Data.SqlServer Namespace


Disable Method

[image]

Sitecore 6.4.1 API
SqlServerTaskDatabase..::..Disable Method
SqlServerTaskDatabase Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Disable(
    Task task
)
Visual Basic
Public Overrides Sub Disable ( _
    task As Task _
)
Visual C++
public:
virtual void Disable(
    Task^ task
) override

Parameters

task
Type: Sitecore.Tasks..::..Task
The task to disable.

See Also

SqlServerTaskDatabase Class
Sitecore.Data.SqlServer Namespace


Enable Method

[image]

Sitecore 6.4.1 API
SqlServerTaskDatabase..::..Enable Method
SqlServerTaskDatabase Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Enable(
    Task task
)
Visual Basic
Public Overrides Sub Enable ( _
    task As Task _
)
Visual C++
public:
virtual void Enable(
    Task^ task
) override

Parameters

task
Type: Sitecore.Tasks..::..Task
The task to enable.

See Also

SqlServerTaskDatabase Class
Sitecore.Data.SqlServer Namespace


GetPendingTasks Method

[image]

Sitecore 6.4.1 API
SqlServerTaskDatabase..::..GetPendingTasks Method
SqlServerTaskDatabase Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Task[] GetPendingTasks()
Visual Basic
Public Overrides Function GetPendingTasks As Task()
Visual C++
public:
virtual array<Task^>^ GetPendingTasks() override

Return Value

Array of pending tasks.

See Also

SqlServerTaskDatabase Class
Sitecore.Data.SqlServer Namespace


MarkDone Method

[image]

Sitecore 6.4.1 API
SqlServerTaskDatabase..::..MarkDone Method
SqlServerTaskDatabase Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void MarkDone(
    Task task
)
Visual Basic
Public Overrides Sub MarkDone ( _
    task As Task _
)
Visual C++
public:
virtual void MarkDone(
    Task^ task
) override

Parameters

task
Type: Sitecore.Tasks..::..Task
The task to mark as done.

See Also

SqlServerTaskDatabase Class
Sitecore.Data.SqlServer Namespace


Remove Method

[image]

Sitecore 6.4.1 API
SqlServerTaskDatabase..::..Remove Method
SqlServerTaskDatabase Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Remove(
    Task task
)
Visual Basic
Public Overrides Sub Remove ( _
    task As Task _
)
Visual C++
public:
virtual void Remove(
    Task^ task
) override

Parameters

task
Type: Sitecore.Tasks..::..Task
The task to remove.

See Also

SqlServerTaskDatabase Class
Sitecore.Data.SqlServer Namespace


RemoveItemTasks Method

[image] [image]

Sitecore 6.4.1 API
SqlServerTaskDatabase..::..RemoveItemTasks Method
SqlServerTaskDatabase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveItemTasks(Item) | The remove item tasks. (Overrides TaskDatabase..::..RemoveItemTasks(Item).)
Public method | RemoveItemTasks(Item, Type) | The remove item tasks. (Overrides TaskDatabase..::..RemoveItemTasks(Item, Type).)

See Also

SqlServerTaskDatabase Class
SqlServerTaskDatabase Members
Sitecore.Data.SqlServer Namespace


RemoveItemTasks Method (Item)

[image]

Sitecore 6.4.1 API
SqlServerTaskDatabase..::..RemoveItemTasks Method (Item)
SqlServerTaskDatabase Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void RemoveItemTasks(
    Item item
)
Visual Basic
Public Overrides Sub RemoveItemTasks ( _
    item As Item _
)
Visual C++
public:
virtual void RemoveItemTasks(
    Item^ item
) override

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item to remove assosiated tasks for.

See Also

SqlServerTaskDatabase Class
RemoveItemTasks Overload
Sitecore.Data.SqlServer Namespace


RemoveItemTasks Method (Item, Type)

[image]

Sitecore 6.4.1 API
SqlServerTaskDatabase..::..RemoveItemTasks Method (Item, Type)
SqlServerTaskDatabase Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void RemoveItemTasks(
    Item item,
    Type taskType
)
Visual Basic
Public Overrides Sub RemoveItemTasks ( _
    item As Item, _
    taskType As Type _
)
Visual C++
public:
virtual void RemoveItemTasks(
    Item^ item,
    Type^ taskType
) override

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item to remove assosiated tasks for.
taskType
Type: System..::..Type
The task Type.

See Also

SqlServerTaskDatabase Class
RemoveItemTasks Overload
Sitecore.Data.SqlServer Namespace


Update Method

[image]

Sitecore 6.4.1 API
SqlServerTaskDatabase..::..Update Method
SqlServerTaskDatabase Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Update(
    Task task,
    bool insertIfNotFound
)
Visual Basic
Public Overrides Sub Update ( _
    task As Task, _
    insertIfNotFound As Boolean _
)
Visual C++
public:
virtual void Update(
    Task^ task,
    bool insertIfNotFound
) override

Parameters

task
Type: Sitecore.Tasks..::..Task
The task to update.
insertIfNotFound
Type: System..::..Boolean
The insert If Not Found.

See Also

SqlServerTaskDatabase Class
Sitecore.Data.SqlServer Namespace


UpdateItemTask Method

[image]

Sitecore 6.4.1 API
SqlServerTaskDatabase..::..UpdateItemTask Method
SqlServerTaskDatabase Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void UpdateItemTask(
    Task task,
    bool insertIfNotFound
)
Visual Basic
Public Overrides Sub UpdateItemTask ( _
    task As Task, _
    insertIfNotFound As Boolean _
)
Visual C++
public:
virtual void UpdateItemTask(
    Task^ task,
    bool insertIfNotFound
) override

Parameters

task
Type: Sitecore.Tasks..::..Task
The task to update.
insertIfNotFound
Type: System..::..Boolean
The insert If Not Found.

See Also

SqlServerTaskDatabase Class
Sitecore.Data.SqlServer Namespace


ConnectionString Property

[image]

Sitecore 6.4.1 API
SqlServerTaskDatabase..::..ConnectionString Property
SqlServerTaskDatabase Class See Also Send Feedback

Namespace: Sitecore.Data.SqlServer
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ConnectionString { get; }
Visual Basic
Public ReadOnly Property ConnectionString As String
    Get
Visual C++
public:
property String^ ConnectionString {
    String^ get ();
}

Field Value

The connection string.

See Also

SqlServerTaskDatabase Class
Sitecore.Data.SqlServer Namespace


Sitecore.Data.Templates Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Data.Templates Namespace
Send Feedback

Classes

 | Class | Description
Public class | DefaultFieldSharing | DefaultFieldSharing
Public class | Template | Template class
Public class | Template..::..Builder | Represents a builder.
Public class | TemplateChangeList | Holds a list of changes to be made when the template of an item is changed.
Public class | TemplateChangeList..::..TemplateChange | Represents a single change when changing the template of an item.
Public class | TemplateCollection | Represents a collection of templates.
Public class | TemplateField | Represents a template field.
Public class | TemplateField..::..Builder | Implements a builder class for TemplateField.
Public class | TemplateList | AccountList class
Public class | TemplateParser | Builds templates from an XML specification.
Public class | TemplateSection | Represents a template section.
Public class | TemplateSection..::..Builder | Implements a builder class for TemplateSection.
Public class | TemplateUpdateContext | Obsolete. Represents a template update context.

Enumerations

 | Enumeration | Description
Public enumeration | DefaultFieldSharing..::..SharingType | SharingType
Public enumeration | TemplateChangeAction | Defines the possible actions to make to a field when changing the template of an item.
Public enumeration | TemplateFieldSharing | TemplateFieldSharing class


DefaultFieldSharing Class

[image]

Sitecore 6.4.1 API
DefaultFieldSharing Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class DefaultFieldSharing
Visual Basic
Public NotInheritable Class DefaultFieldSharing
Visual C++
public ref class DefaultFieldSharing abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Templates..::..DefaultFieldSharing

See Also

DefaultFieldSharing Members
Sitecore.Data.Templates Namespace


DefaultFieldSharing Members

[image] [image]

Sitecore 6.4.1 API
DefaultFieldSharing Members
DefaultFieldSharing Class Properties See Also Send Feedback

The DefaultFieldSharing type exposes the following members.

Properties

Name | Description
Sharing | Gets the sharing.

See Also

DefaultFieldSharing Class
Sitecore.Data.Templates Namespace


DefaultFieldSharing Properties

[image] [image]

Sitecore 6.4.1 API
DefaultFieldSharing Properties
DefaultFieldSharing Class See Also Send Feedback

The DefaultFieldSharing type exposes the following members.

Properties

Name | Description
Sharing | Gets the sharing.

See Also

DefaultFieldSharing Class
Sitecore.Data.Templates Namespace


Sharing Property

[image]

Sitecore 6.4.1 API
DefaultFieldSharing..::..Sharing Property
DefaultFieldSharing Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static SafeDictionary<ID, DefaultFieldSharing..::..SharingType> Sharing { get; }
Visual Basic
Public Shared ReadOnly Property Sharing As SafeDictionary(Of ID, DefaultFieldSharing..::..SharingType)
    Get
Visual C++
public:
static property SafeDictionary<ID^, DefaultFieldSharing..::..SharingType>^ Sharing {
    SafeDictionary<ID^, DefaultFieldSharing..::..SharingType>^ get ();
}

Field Value

The sharing.

See Also

DefaultFieldSharing Class
Sitecore.Data.Templates Namespace


DefaultFieldSharing.SharingType Enumeration

[image]

Sitecore 6.4.1 API
DefaultFieldSharing..::..SharingType Enumeration
DefaultFieldSharing Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum SharingType
Visual Basic
Public Enumeration SharingType
Visual C++
public enum class SharingType

Members

Member name | Value | Description
Unknown | 0 | Unknown
Shared | 1 | Shared
Unversioned | 2 | Unversioned
Versioned | 3 | Versioned

See Also

Sitecore.Data.Templates Namespace


Template Class

[image]

Sitecore 6.4.1 API
Template Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Template
Visual Basic
Public Class Template
Visual C++
public ref class Template

Remarks

Remarks

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Templates..::..Template

See Also

Template Members
Sitecore.Data.Templates Namespace
Sitecore.Data.Templates..::..TemplateField
Sitecore.Data.Templates..::..TemplateSection


Template Members

[image] [image]

Sitecore 6.4.1 API
Template Members
Template Class Methods Properties See Also Send Feedback

The Template type exposes the following members.

Methods

 | Name | Description
Public method | AddDefault | Adds a default to a field.
Public method | ContainsField | Check if the template includes a specific field
Public method | DescendsFrom(ID) | Determines whether the template descends directly or indirectly from another template.
Public method | DescendsFrom(Template) | Descendses from.
Public method | DescendsFromOrEquals | A convenience method to determine whether the template equals or descends directly or indirectly from another template.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseTemplates | Gets the base templates.
Public method | GetDefaults | Gets the default values for all fields.
Public method | GetDescendants | Gets the templates that inherit from this template.
Public method | GetField(String) | Gets a field.
Public method | GetField(ID) | Gets a field.
Public method | GetFields()()()() | Gets the fields.
Public method | GetFields(Boolean) | Gets the fields.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSection(String) | Gets a section.
Public method | GetSection(ID) | Gets a section.
Public method | GetSections | Gets the sections.
Public method | GetTemplateChangeList | Gets the template change list.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InheritsFrom(String) | Determines whether template has a specific base template.
Public method | InheritsFrom(ID) | Determines whether the specified template has a specific base template.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Constructs a template from an XmlNode..
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BaseIDs | Gets the IDs of the base templates.
Public property | CustomValues | Gets the custom values.
Public property | FullName | Gets the full name.
Public property | Icon | Gets the icon.
Public property | ID | Gets the ID.
Public property | Name | Gets the name.
Public property | StandardValueHolderId | Gets the id of the item holding standard values for the template.

See Also

Template Class
Sitecore.Data.Templates Namespace


Template Methods

[image] [image]

Sitecore 6.4.1 API
Template Methods
Template Class See Also Send Feedback

The Template type exposes the following members.

Methods

 | Name | Description
Public method | AddDefault | Adds a default to a field.
Public method | ContainsField | Check if the template includes a specific field
Public method | DescendsFrom(ID) | Determines whether the template descends directly or indirectly from another template.
Public method | DescendsFrom(Template) | Descendses from.
Public method | DescendsFromOrEquals | A convenience method to determine whether the template equals or descends directly or indirectly from another template.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseTemplates | Gets the base templates.
Public method | GetDefaults | Gets the default values for all fields.
Public method | GetDescendants | Gets the templates that inherit from this template.
Public method | GetField(String) | Gets a field.
Public method | GetField(ID) | Gets a field.
Public method | GetFields()()()() | Gets the fields.
Public method | GetFields(Boolean) | Gets the fields.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSection(String) | Gets a section.
Public method | GetSection(ID) | Gets a section.
Public method | GetSections | Gets the sections.
Public method | GetTemplateChangeList | Gets the template change list.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InheritsFrom(String) | Determines whether template has a specific base template.
Public method | InheritsFrom(ID) | Determines whether the specified template has a specific base template.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Constructs a template from an XmlNode..
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Template Class
Sitecore.Data.Templates Namespace


AddDefault Method

[image]

Sitecore 6.4.1 API
Template..::..AddDefault Method
Template Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddDefault(
    ID fieldID,
    string value
)
Visual Basic
Public Sub AddDefault ( _
    fieldID As ID, _
    value As String _
)
Visual C++
public:
void AddDefault(
    ID^ fieldID,
    String^ value
)

Parameters

fieldID
Type: Sitecore.Data..::..ID
Field ID to add value for.
value
Type: System..::..String
Value to add.

See Also

Template Class
Sitecore.Data.Templates Namespace


ContainsField Method

[image]

Sitecore 6.4.1 API
Template..::..ContainsField Method
Template Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ContainsField(
    ID fieldID
)
Visual Basic
Public Function ContainsField ( _
    fieldID As ID _
) As Boolean
Visual C++
public:
bool ContainsField(
    ID^ fieldID
)

Parameters

fieldID
Type: Sitecore.Data..::..ID
The field ID.

Return Value

true if the specified field ID contains field; otherwise, false.

See Also

Template Class
Sitecore.Data.Templates Namespace


DescendsFrom Method

[image] [image]

Sitecore 6.4.1 API
Template..::..DescendsFrom Method
Template Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DescendsFrom(ID) | Determines whether the template descends directly or indirectly from another template.
Public method | DescendsFrom(Template) | Descendses from.

See Also

Template Class
Template Members
Sitecore.Data.Templates Namespace


DescendsFrom Method (ID)

[image]

Sitecore 6.4.1 API
Template..::..DescendsFrom Method (ID)
Template Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool DescendsFrom(
    ID templateId
)
Visual Basic
Public Function DescendsFrom ( _
    templateId As ID _
) As Boolean
Visual C++
public:
bool DescendsFrom(
    ID^ templateId
)

Parameters

templateId
Type: Sitecore.Data..::..ID
The template id.

Return Value

The descends from.

See Also

Template Class
DescendsFrom Overload
Sitecore.Data.Templates Namespace


DescendsFrom Method (Template)

[image]

Sitecore 6.4.1 API
Template..::..DescendsFrom Method (Template)
Template Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool DescendsFrom(
    Template template
)
Visual Basic
Public Function DescendsFrom ( _
    template As Template _
) As Boolean
Visual C++
public:
bool DescendsFrom(
    Template^ template
)

Parameters

template
Type: Sitecore.Data.Templates..::..Template
The template.

Return Value

The descends from.

See Also

Template Class
DescendsFrom Overload
Sitecore.Data.Templates Namespace


DescendsFromOrEquals Method

[image]

Sitecore 6.4.1 API
Template..::..DescendsFromOrEquals Method
Template Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool DescendsFromOrEquals(
    ID templateId
)
Visual Basic
Public Function DescendsFromOrEquals ( _
    templateId As ID _
) As Boolean
Visual C++
public:
bool DescendsFromOrEquals(
    ID^ templateId
)

Parameters

templateId
Type: Sitecore.Data..::..ID
The template id.

Return Value

The descends from or equals.

See Also

Template Class
Sitecore.Data.Templates Namespace


GetBaseTemplates Method

[image]

Sitecore 6.4.1 API
Template..::..GetBaseTemplates Method
Template Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateList GetBaseTemplates()
Visual Basic
Public Function GetBaseTemplates As TemplateList
Visual C++
public:
TemplateList^ GetBaseTemplates()

Return Value

TEmplates list.

See Also

Template Class
Sitecore.Data.Templates Namespace


GetDefaults Method

[image]

Sitecore 6.4.1 API
Template..::..GetDefaults Method
Template Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Hashtable GetDefaults()
Visual Basic
Public Function GetDefaults As Hashtable
Visual C++
public:
Hashtable^ GetDefaults()

Return Value

The defaults.

See Also

Template Class
Sitecore.Data.Templates Namespace


GetDescendants Method

[image]

Sitecore 6.4.1 API
Template..::..GetDescendants Method
Template Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Template[] GetDescendants()
Visual Basic
Public Function GetDescendants As Template()
Visual C++
public:
array<Template^>^ GetDescendants()

Return Value

The descendants.

See Also

Template Class
Sitecore.Data.Templates Namespace


GetField Method

[image] [image]

Sitecore 6.4.1 API
Template..::..GetField Method
Template Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetField(String) | Gets a field.
Public method | GetField(ID) | Gets a field.

See Also

Template Class
Template Members
Sitecore.Data.Templates Namespace


GetField Method (String)

[image]

Sitecore 6.4.1 API
Template..::..GetField Method (String)
Template Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateField GetField(
    string fieldName
)
Visual Basic
Public Function GetField ( _
    fieldName As String _
) As TemplateField
Visual C++
public:
TemplateField^ GetField(
    String^ fieldName
)

Parameters

fieldName
Type: System..::..String
Name of the field.

Return Value

The field.

See Also

Template Class
GetField Overload
Sitecore.Data.Templates Namespace


GetField Method (ID)

[image]

Sitecore 6.4.1 API
Template..::..GetField Method (ID)
Template Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateField GetField(
    ID fieldID
)
Visual Basic
Public Function GetField ( _
    fieldID As ID _
) As TemplateField
Visual C++
public:
TemplateField^ GetField(
    ID^ fieldID
)

Parameters

fieldID
Type: Sitecore.Data..::..ID
Field ID to get.

Return Value

The field.

See Also

Template Class
GetField Overload
Sitecore.Data.Templates Namespace


GetFields Method

[image]

Sitecore 6.4.1 API
Template..::..GetFields Method
Template Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateField[] GetFields()
Visual Basic
Public Function GetFields As TemplateField()
Visual C++
public:
array<TemplateField^>^ GetFields()

Return Value

The fields.

See Also

Template Class
GetFields Overload
Sitecore.Data.Templates Namespace


GetSection Method

[image] [image]

Sitecore 6.4.1 API
Template..::..GetSection Method
Template Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetSection(String) | Gets a section.
Public method | GetSection(ID) | Gets a section.

See Also

Template Class
Template Members
Sitecore.Data.Templates Namespace


GetSection Method (String)

[image]

Sitecore 6.4.1 API
Template..::..GetSection Method (String)
Template Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateSection GetSection(
    string sectionName
)
Visual Basic
Public Function GetSection ( _
    sectionName As String _
) As TemplateSection
Visual C++
public:
TemplateSection^ GetSection(
    String^ sectionName
)

Parameters

sectionName
Type: System..::..String
Name of the section.

Return Value

The section.

See Also

Template Class
GetSection Overload
Sitecore.Data.Templates Namespace


GetSection Method (ID)

[image]

Sitecore 6.4.1 API
Template..::..GetSection Method (ID)
Template Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateSection GetSection(
    ID sectionID
)
Visual Basic
Public Function GetSection ( _
    sectionID As ID _
) As TemplateSection
Visual C++
public:
TemplateSection^ GetSection(
    ID^ sectionID
)

Parameters

sectionID
Type: Sitecore.Data..::..ID
Section ID.

Return Value

The section.

See Also

Template Class
GetSection Overload
Sitecore.Data.Templates Namespace


GetSections Method

[image]

Sitecore 6.4.1 API
Template..::..GetSections Method
Template Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateSection[] GetSections()
Visual Basic
Public Function GetSections As TemplateSection()
Visual C++
public:
array<TemplateSection^>^ GetSections()

Return Value

The sections.

See Also

Template Class
Sitecore.Data.Templates Namespace


GetTemplateChangeList Method

[image]

Sitecore 6.4.1 API
Template..::..GetTemplateChangeList Method
Template Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateChangeList GetTemplateChangeList(
    Template target
)
Visual Basic
Public Function GetTemplateChangeList ( _
    target As Template _
) As TemplateChangeList
Visual C++
public:
TemplateChangeList^ GetTemplateChangeList(
    Template^ target
)

Parameters

target
Type: Sitecore.Data.Templates..::..Template
The target.

Return Value

The template change list.

See Also

Template Class
Sitecore.Data.Templates Namespace


InheritsFrom Method

[image] [image]

Sitecore 6.4.1 API
Template..::..InheritsFrom Method
Template Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InheritsFrom(String) | Determines whether template has a specific base template.
Public method | InheritsFrom(ID) | Determines whether the specified template has a specific base template.

See Also

Template Class
Template Members
Sitecore.Data.Templates Namespace


InheritsFrom Method (String)

[image]

Sitecore 6.4.1 API
Template..::..InheritsFrom Method (String)
Template Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool InheritsFrom(
    string baseTemplateName
)
Visual Basic
Public Function InheritsFrom ( _
    baseTemplateName As String _
) As Boolean
Visual C++
public:
bool InheritsFrom(
    String^ baseTemplateName
)

Parameters

baseTemplateName
Type: System..::..String
The base template name.

Return Value

true if template has a specific base template, false otherwise

See Also

Template Class
InheritsFrom Overload
Sitecore.Data.Templates Namespace


InheritsFrom Method (ID)

[image]

Sitecore 6.4.1 API
Template..::..InheritsFrom Method (ID)
Template Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool InheritsFrom(
    ID baseTemplateId
)
Visual Basic
Public Function InheritsFrom ( _
    baseTemplateId As ID _
) As Boolean
Visual C++
public:
bool InheritsFrom(
    ID^ baseTemplateId
)

Parameters

baseTemplateId
Type: Sitecore.Data..::..ID
The base template id.

Return Value

true if template has the specific base template; otherwise, false.

See Also

Template Class
InheritsFrom Overload
Sitecore.Data.Templates Namespace


Parse Method

[image]

Sitecore 6.4.1 API
Template..::..Parse Method
Template Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Template Parse(
    XmlNode node,
    TemplateCollection owner
)
Visual Basic
Public Shared Function Parse ( _
    node As XmlNode, _
    owner As TemplateCollection _
) As Template
Visual C++
public:
static Template^ Parse(
    XmlNode^ node,
    TemplateCollection^ owner
)

Parameters

node
Type: System.Xml..::..XmlNode
Xml Node to construct template from.
owner
Type: Sitecore.Data.Templates..::..TemplateCollection
Owner collection.

Return Value

The template.

See Also

Template Class
Sitecore.Data.Templates Namespace


Template Properties

[image] [image]

Sitecore 6.4.1 API
Template Properties
Template Class See Also Send Feedback

The Template type exposes the following members.

Properties

 | Name | Description
Public property | BaseIDs | Gets the IDs of the base templates.
Public property | CustomValues | Gets the custom values.
Public property | FullName | Gets the full name.
Public property | Icon | Gets the icon.
Public property | ID | Gets the ID.
Public property | Name | Gets the name.
Public property | StandardValueHolderId | Gets the id of the item holding standard values for the template.

See Also

Template Class
Sitecore.Data.Templates Namespace


BaseIDs Property

[image]

Sitecore 6.4.1 API
Template..::..BaseIDs Property
Template Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID[] BaseIDs { get; }
Visual Basic
Public ReadOnly Property BaseIDs As ID()
    Get
Visual C++
public:
property array<ID^>^ BaseIDs {
    array<ID^>^ get ();
}

Field Value

The base Ids.

See Also

Template Class
Sitecore.Data.Templates Namespace


Icon Property

[image]

Sitecore 6.4.1 API
Template..::..Icon Property
Template Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Icon { get; }
Visual Basic
Public ReadOnly Property Icon As String
    Get
Visual C++
public:
property String^ Icon {
    String^ get ();
}

Field Value

The template icon.

See Also

Template Class
Sitecore.Data.Templates Namespace


ID Property

[image]

Sitecore 6.4.1 API
Template..::..ID Property
Template Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ID { get; }
Visual Basic
Public ReadOnly Property ID As ID
    Get
Visual C++
public:
property ID^ ID {
    ID^ get ();
}

Field Value

The template ID.

See Also

Template Class
Sitecore.Data.Templates Namespace


Name Property

[image]

Sitecore 6.4.1 API
Template..::..Name Property
Template Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Field Value

The template name.

See Also

Template Class
Sitecore.Data.Templates Namespace


StandardValueHolderId Property

[image]

Sitecore 6.4.1 API
Template..::..StandardValueHolderId Property
Template Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID StandardValueHolderId { get; }
Visual Basic
Public ReadOnly Property StandardValueHolderId As ID
    Get
Visual C++
public:
property ID^ StandardValueHolderId {
    ID^ get ();
}

Field Value

The standard value holder id.

See Also

Template Class
Sitecore.Data.Templates Namespace


Template.Builder Class

[image]

Sitecore 6.4.1 API
Template..::..Builder Class
Template Class Members See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Builder
Visual Basic
Public Class Builder
Visual C++
public ref class Builder

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Templates..::..Template..::..Builder

See Also

Template..::..Builder Members
Sitecore.Data.Templates Namespace


Template.Builder Members

[image] [image]

Sitecore 6.4.1 API
Template..::..Builder Members
Template..::..Builder Class Constructors Methods Properties See Also Send Feedback

Template class
Represents a template.

The Template..::..Builder type exposes the following members.

Constructors

 | Name | Description
Public method | Template..::..Builder(String, ID, TemplateEngine) | Initializes a new instance of the Template..::..Builder class.
Public method | Template..::..Builder(String, ID, TemplateCollection) | Initializes a new instance of the Template..::..Builder class.

Methods

 | Name | Description
Public method | AddData | Adds the data.
Public method | AddSection(XmlNode) | Adds the section.
Public method | AddSection(String, ID) | Adds the section.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Parses the specified node.
Public method | SetBaseIDs | Sets the base Ids.
Public method | SetFullName | Sets the full name.
Public method | SetIcon | Sets the icon.
Public method | SetID | Sets the ID.
Public method | SetName | Sets the name.
Public method | SetStandardValueHolderId | Sets the standard value holder id.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Template | Gets the template.

See Also

Template..::..Builder Class
Sitecore.Data.Templates Namespace


Template.Builder Constructor

[image] [image]

Sitecore 6.4.1 API
Template..::..Builder Constructor
Template..::..Builder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Template..::..Builder(String, ID, TemplateEngine) | Initializes a new instance of the Template..::..Builder class.
Public method | Template..::..Builder(String, ID, TemplateCollection) | Initializes a new instance of the Template..::..Builder class.

See Also

Template..::..Builder Class
Template..::..Builder Members
Sitecore.Data.Templates Namespace


Template.Builder Constructor (String, ID, TemplateCollection)

[image]

Sitecore 6.4.1 API
Template..::..Builder Constructor (String, ID, TemplateCollection)
Template..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Builder(
    string templateName,
    ID templateID,
    TemplateCollection owner
)
Visual Basic
Public Sub New ( _
    templateName As String, _
    templateID As ID, _
    owner As TemplateCollection _
)
Visual C++
public:
Builder(
    String^ templateName,
    ID^ templateID,
    TemplateCollection^ owner
)

Parameters

templateName
Type: System..::..String
Name of the template.
templateID
Type: Sitecore.Data..::..ID
The template ID.
owner
Type: Sitecore.Data.Templates..::..TemplateCollection
The owner.

See Also

Template..::..Builder Class
Template..::..Builder Overload
Sitecore.Data.Templates Namespace


Template.Builder Methods

[image] [image]

Sitecore 6.4.1 API
Template..::..Builder Methods
Template..::..Builder Class See Also Send Feedback

The Template..::..Builder type exposes the following members.

Methods

 | Name | Description
Public method | AddData | Adds the data.
Public method | AddSection(XmlNode) | Adds the section.
Public method | AddSection(String, ID) | Adds the section.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Parses the specified node.
Public method | SetBaseIDs | Sets the base Ids.
Public method | SetFullName | Sets the full name.
Public method | SetIcon | Sets the icon.
Public method | SetID | Sets the ID.
Public method | SetName | Sets the name.
Public method | SetStandardValueHolderId | Sets the standard value holder id.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Template..::..Builder Class
Sitecore.Data.Templates Namespace


AddData Method

[image]

Sitecore 6.4.1 API
Template..::..Builder..::..AddData Method
Template..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddData(
    XmlNode node
)
Visual Basic
Public Sub AddData ( _
    node As XmlNode _
)
Visual C++
public:
void AddData(
    XmlNode^ node
)

Parameters

node
Type: System.Xml..::..XmlNode
The node to add data for.

See Also

Template..::..Builder Class
Sitecore.Data.Templates Namespace


AddSection Method

[image] [image]

Sitecore 6.4.1 API
Template..::..Builder..::..AddSection Method
Template..::..Builder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddSection(XmlNode) | Adds the section.
Public method | AddSection(String, ID) | Adds the section.

See Also

Template..::..Builder Class
Template..::..Builder Members
Sitecore.Data.Templates Namespace


AddSection Method (XmlNode)

[image]

Sitecore 6.4.1 API
Template..::..Builder..::..AddSection Method (XmlNode)
Template..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateSection..::..Builder AddSection(
    XmlNode node
)
Visual Basic
Public Function AddSection ( _
    node As XmlNode _
) As TemplateSection..::..Builder
Visual C++
public:
TemplateSection..::..Builder^ AddSection(
    XmlNode^ node
)

Parameters

node
Type: System.Xml..::..XmlNode
The XML node.

Return Value

The section.

See Also

Template..::..Builder Class
AddSection Overload
Sitecore.Data.Templates Namespace


AddSection Method (String, ID)

[image]

Sitecore 6.4.1 API
Template..::..Builder..::..AddSection Method (String, ID)
Template..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateSection..::..Builder AddSection(
    string sectionName,
    ID sectionID
)
Visual Basic
Public Function AddSection ( _
    sectionName As String, _
    sectionID As ID _
) As TemplateSection..::..Builder
Visual C++
public:
TemplateSection..::..Builder^ AddSection(
    String^ sectionName,
    ID^ sectionID
)

Parameters

sectionName
Type: System..::..String
Name of the section.
sectionID
Type: Sitecore.Data..::..ID
The section ID.

Return Value

The section.

See Also

Template..::..Builder Class
AddSection Overload
Sitecore.Data.Templates Namespace


Parse Method

[image]

Sitecore 6.4.1 API
Template..::..Builder..::..Parse Method
Template..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Template..::..Builder Parse(
    XmlNode node,
    TemplateCollection owner
)
Visual Basic
Public Shared Function Parse ( _
    node As XmlNode, _
    owner As TemplateCollection _
) As Template..::..Builder
Visual C++
public:
static Template..::..Builder^ Parse(
    XmlNode^ node,
    TemplateCollection^ owner
)

Parameters

node
Type: System.Xml..::..XmlNode
The node to parse.
owner
Type: Sitecore.Data.Templates..::..TemplateCollection
The owner.

Return Value

The parse.

See Also

Template..::..Builder Class
Sitecore.Data.Templates Namespace


SetBaseIDs Method

[image]

Sitecore 6.4.1 API
Template..::..Builder..::..SetBaseIDs Method
Template..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetBaseIDs(
    string baseIDs
)
Visual Basic
Public Sub SetBaseIDs ( _
    baseIDs As String _
)
Visual C++
public:
void SetBaseIDs(
    String^ baseIDs
)

Parameters

baseIDs
Type: System..::..String
The base Ids.

See Also

Template..::..Builder Class
Sitecore.Data.Templates Namespace


SetFullName Method

[image]

Sitecore 6.4.1 API
Template..::..Builder..::..SetFullName Method
Template..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetFullName(
    string fullName
)
Visual Basic
Public Sub SetFullName ( _
    fullName As String _
)
Visual C++
public:
void SetFullName(
    String^ fullName
)

Parameters

fullName
Type: System..::..String
The full name.

See Also

Template..::..Builder Class
Sitecore.Data.Templates Namespace


SetIcon Method

[image]

Sitecore 6.4.1 API
Template..::..Builder..::..SetIcon Method
Template..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetIcon(
    string icon
)
Visual Basic
Public Sub SetIcon ( _
    icon As String _
)
Visual C++
public:
void SetIcon(
    String^ icon
)

Parameters

icon
Type: System..::..String
The icon to set.

See Also

Template..::..Builder Class
Sitecore.Data.Templates Namespace


SetID Method

[image]

Sitecore 6.4.1 API
Template..::..Builder..::..SetID Method
Template..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetID(
    ID templateID
)
Visual Basic
Public Sub SetID ( _
    templateID As ID _
)
Visual C++
public:
void SetID(
    ID^ templateID
)

Parameters

templateID
Type: Sitecore.Data..::..ID
The template ID.

See Also

Template..::..Builder Class
Sitecore.Data.Templates Namespace


SetName Method

[image]

Sitecore 6.4.1 API
Template..::..Builder..::..SetName Method
Template..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetName(
    string name
)
Visual Basic
Public Sub SetName ( _
    name As String _
)
Visual C++
public:
void SetName(
    String^ name
)

Parameters

name
Type: System..::..String
The name to set.

See Also

Template..::..Builder Class
Sitecore.Data.Templates Namespace


SetStandardValueHolderId Method

[image]

Sitecore 6.4.1 API
Template..::..Builder..::..SetStandardValueHolderId Method
Template..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetStandardValueHolderId(
    string value
)
Visual Basic
Public Sub SetStandardValueHolderId ( _
    value As String _
)
Visual C++
public:
void SetStandardValueHolderId(
    String^ value
)

Parameters

value
Type: System..::..String
The value.

See Also

Template..::..Builder Class
Sitecore.Data.Templates Namespace


Template.Builder Properties

[image] [image]

Sitecore 6.4.1 API
Template..::..Builder Properties
Template..::..Builder Class See Also Send Feedback

The Template..::..Builder type exposes the following members.

Properties

 | Name | Description
Public property | Template | Gets the template.

See Also

Template..::..Builder Class
Sitecore.Data.Templates Namespace


Template Property

[image]

Sitecore 6.4.1 API
Template..::..Builder..::..Template Property
Template..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Template Template { get; }
Visual Basic
Public ReadOnly Property Template As Template
    Get
Visual C++
public:
property Template^ Template {
    Template^ get ();
}

Field Value

The template.

See Also

Template..::..Builder Class
Sitecore.Data.Templates Namespace


TemplateChangeList Class

[image]

Sitecore 6.4.1 API
TemplateChangeList Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class TemplateChangeList
Visual Basic
Public Class TemplateChangeList
Visual C++
public ref class TemplateChangeList

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Templates..::..TemplateChangeList

See Also

TemplateChangeList Members
Sitecore.Data.Templates Namespace


TemplateChangeList Members

[image] [image]

Sitecore 6.4.1 API
TemplateChangeList Members
TemplateChangeList Class Constructors Methods Properties See Also Send Feedback

The TemplateChangeList type exposes the following members.

Constructors

 | Name | Description
Public method | TemplateChangeList(Template, Template) | Creates a new TemplateChangeList instance.
Public method | TemplateChangeList(TemplateItem, TemplateItem) | Obsolete. Creates a new TemplateChangeList instance.

Methods

 | Name | Description
Public method | Add | Adds an action.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FieldChanged(TemplateField, TemplateField) | A field has changed.
Public method | FieldChanged(TemplateFieldItem, TemplateFieldItem) | Obsolete. A field has changed.
Public method | FieldRemoved(TemplateField) | A field has been removed.
Public method | FieldRemoved(TemplateFieldItem) | Obsolete. A field has been removed.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Changes | Gets the changes.
Public property | PreferredLanguage | Gets or sets the preferred language.
Public property | PreferredVersion | Gets or sets the preferred version.
Public property | Source | Gets the source.
Public property | Target | Gets the target.

See Also

TemplateChangeList Class
Sitecore.Data.Templates Namespace


TemplateChangeList Constructor

[image] [image]

Sitecore 6.4.1 API
TemplateChangeList Constructor
TemplateChangeList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TemplateChangeList(Template, Template) | Creates a new TemplateChangeList instance.
Public method | TemplateChangeList(TemplateItem, TemplateItem) | Obsolete. Creates a new TemplateChangeList instance.

See Also

TemplateChangeList Class
TemplateChangeList Members
Sitecore.Data.Templates Namespace


TemplateChangeList Constructor (Template, Template)

[image]

Sitecore 6.4.1 API
TemplateChangeList Constructor (Template, Template)
TemplateChangeList Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateChangeList(
    Template source,
    Template target
)
Visual Basic
Public Sub New ( _
    source As Template, _
    target As Template _
)
Visual C++
public:
TemplateChangeList(
    Template^ source,
    Template^ target
)

Parameters

source
Type: Sitecore.Data.Templates..::..Template
Source.
target
Type: Sitecore.Data.Templates..::..Template
Target.

See Also

TemplateChangeList Class
TemplateChangeList Overload
Sitecore.Data.Templates Namespace


TemplateChangeList Constructor (TemplateItem, TemplateItem)

[image]

Sitecore 6.4.1 API
TemplateChangeList Constructor (TemplateItem, TemplateItem)
TemplateChangeList Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public TemplateChangeList(
    TemplateItem source,
    TemplateItem target
)
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Sub New ( _
    source As TemplateItem, _
    target As TemplateItem _
)
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public:
TemplateChangeList(
    TemplateItem^ source,
    TemplateItem^ target
)

Parameters

source
Type: Sitecore.Data.Items..::..TemplateItem
Source.
target
Type: Sitecore.Data.Items..::..TemplateItem
Target.

See Also

TemplateChangeList Class
TemplateChangeList Overload
Sitecore.Data.Templates Namespace


TemplateChangeList Methods

[image] [image]

Sitecore 6.4.1 API
TemplateChangeList Methods
TemplateChangeList Class See Also Send Feedback

The TemplateChangeList type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an action.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FieldChanged(TemplateField, TemplateField) | A field has changed.
Public method | FieldChanged(TemplateFieldItem, TemplateFieldItem) | Obsolete. A field has changed.
Public method | FieldRemoved(TemplateField) | A field has been removed.
Public method | FieldRemoved(TemplateFieldItem) | Obsolete. A field has been removed.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TemplateChangeList Class
Sitecore.Data.Templates Namespace


Add Method

[image]

Sitecore 6.4.1 API
TemplateChangeList..::..Add Method
TemplateChangeList Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Add(
    TemplateChangeAction action,
    TemplateField source,
    TemplateField target
)
Visual Basic
Public Sub Add ( _
    action As TemplateChangeAction, _
    source As TemplateField, _
    target As TemplateField _
)
Visual C++
public:
void Add(
    TemplateChangeAction action,
    TemplateField^ source,
    TemplateField^ target
)

Parameters

action
Type: Sitecore.Data.Templates..::..TemplateChangeAction
Action.
source
Type: Sitecore.Data.Templates..::..TemplateField
Source.
target
Type: Sitecore.Data.Templates..::..TemplateField
Target.

See Also

TemplateChangeList Class
Sitecore.Data.Templates Namespace


FieldChanged Method

[image] [image]

Sitecore 6.4.1 API
TemplateChangeList..::..FieldChanged Method
TemplateChangeList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FieldChanged(TemplateField, TemplateField) | A field has changed.
Public method | FieldChanged(TemplateFieldItem, TemplateFieldItem) | Obsolete. A field has changed.

See Also

TemplateChangeList Class
TemplateChangeList Members
Sitecore.Data.Templates Namespace


FieldChanged Method (TemplateField, TemplateField)

[image]

Sitecore 6.4.1 API
TemplateChangeList..::..FieldChanged Method (TemplateField, TemplateField)
TemplateChangeList Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void FieldChanged(
    TemplateField source,
    TemplateField target
)
Visual Basic
Public Sub FieldChanged ( _
    source As TemplateField, _
    target As TemplateField _
)
Visual C++
public:
void FieldChanged(
    TemplateField^ source,
    TemplateField^ target
)

Parameters

source
Type: Sitecore.Data.Templates..::..TemplateField
Source.
target
Type: Sitecore.Data.Templates..::..TemplateField
Target.

See Also

TemplateChangeList Class
FieldChanged Overload
Sitecore.Data.Templates Namespace


FieldChanged Method (TemplateFieldItem, TemplateFieldItem)

[image]

Sitecore 6.4.1 API
TemplateChangeList..::..FieldChanged Method (TemplateFieldItem, TemplateFieldItem)
TemplateChangeList Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public void FieldChanged(
    TemplateFieldItem source,
    TemplateFieldItem target
)
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Sub FieldChanged ( _
    source As TemplateFieldItem, _
    target As TemplateFieldItem _
)
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public:
void FieldChanged(
    TemplateFieldItem^ source,
    TemplateFieldItem^ target
)

Parameters

source
Type: Sitecore.Data.Items..::..TemplateFieldItem
Source.
target
Type: Sitecore.Data.Items..::..TemplateFieldItem
Target.

See Also

TemplateChangeList Class
FieldChanged Overload
Sitecore.Data.Templates Namespace


FieldRemoved Method

[image] [image]

Sitecore 6.4.1 API
TemplateChangeList..::..FieldRemoved Method
TemplateChangeList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FieldRemoved(TemplateField) | A field has been removed.
Public method | FieldRemoved(TemplateFieldItem) | Obsolete. A field has been removed.

See Also

TemplateChangeList Class
TemplateChangeList Members
Sitecore.Data.Templates Namespace


FieldRemoved Method (TemplateField)

[image]

Sitecore 6.4.1 API
TemplateChangeList..::..FieldRemoved Method (TemplateField)
TemplateChangeList Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void FieldRemoved(
    TemplateField field
)
Visual Basic
Public Sub FieldRemoved ( _
    field As TemplateField _
)
Visual C++
public:
void FieldRemoved(
    TemplateField^ field
)

Parameters

field
Type: Sitecore.Data.Templates..::..TemplateField
Field.

See Also

TemplateChangeList Class
FieldRemoved Overload
Sitecore.Data.Templates Namespace


FieldRemoved Method (TemplateFieldItem)

[image]

Sitecore 6.4.1 API
TemplateChangeList..::..FieldRemoved Method (TemplateFieldItem)
TemplateChangeList Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public void FieldRemoved(
    TemplateFieldItem field
)
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Sub FieldRemoved ( _
    field As TemplateFieldItem _
)
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public:
void FieldRemoved(
    TemplateFieldItem^ field
)

Parameters

field
Type: Sitecore.Data.Items..::..TemplateFieldItem
Field.

See Also

TemplateChangeList Class
FieldRemoved Overload
Sitecore.Data.Templates Namespace


TemplateChangeList Properties

[image] [image]

Sitecore 6.4.1 API
TemplateChangeList Properties
TemplateChangeList Class See Also Send Feedback

The TemplateChangeList type exposes the following members.

Properties

 | Name | Description
Public property | Changes | Gets the changes.
Public property | PreferredLanguage | Gets or sets the preferred language.
Public property | PreferredVersion | Gets or sets the preferred version.
Public property | Source | Gets the source.
Public property | Target | Gets the target.

See Also

TemplateChangeList Class
Sitecore.Data.Templates Namespace


Changes Property

[image]

Sitecore 6.4.1 API
TemplateChangeList..::..Changes Property
TemplateChangeList Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateChangeList..::..TemplateChange[] Changes { get; }
Visual Basic
Public ReadOnly Property Changes As TemplateChangeList..::..TemplateChange()
    Get
Visual C++
public:
property array<TemplateChangeList..::..TemplateChange^>^ Changes {
    array<TemplateChangeList..::..TemplateChange^>^ get ();
}

Field Value

The changes.

See Also

TemplateChangeList Class
Sitecore.Data.Templates Namespace


PreferredLanguage Property

[image]

Sitecore 6.4.1 API
TemplateChangeList..::..PreferredLanguage Property
TemplateChangeList Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Language PreferredLanguage { get; set; }
Visual Basic
Public Property PreferredLanguage As Language
    Get
    Set
Visual C++
public:
property Language^ PreferredLanguage {
    Language^ get ();
    void set (Language^ value);
}

Field Value

The preferred language.

See Also

TemplateChangeList Class
Sitecore.Data.Templates Namespace


PreferredVersion Property

[image]

Sitecore 6.4.1 API
TemplateChangeList..::..PreferredVersion Property
TemplateChangeList Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Version PreferredVersion { get; set; }
Visual Basic
Public Property PreferredVersion As Version
    Get
    Set
Visual C++
public:
property Version^ PreferredVersion {
    Version^ get ();
    void set (Version^ value);
}

Field Value

The preferred version.

See Also

TemplateChangeList Class
Sitecore.Data.Templates Namespace


Source Property

[image]

Sitecore 6.4.1 API
TemplateChangeList..::..Source Property
TemplateChangeList Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Template Source { get; }
Visual Basic
Public ReadOnly Property Source As Template
    Get
Visual C++
public:
property Template^ Source {
    Template^ get ();
}

Field Value

The source.

See Also

TemplateChangeList Class
Sitecore.Data.Templates Namespace


Target Property

[image]

Sitecore 6.4.1 API
TemplateChangeList..::..Target Property
TemplateChangeList Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Template Target { get; }
Visual Basic
Public ReadOnly Property Target As Template
    Get
Visual C++
public:
property Template^ Target {
    Template^ get ();
}

Field Value

The target.

See Also

TemplateChangeList Class
Sitecore.Data.Templates Namespace


TemplateChangeList.TemplateChange Class

[image]

Sitecore 6.4.1 API
TemplateChangeList..::..TemplateChange Class
TemplateChangeList Class Members See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class TemplateChange
Visual Basic
Public Class TemplateChange
Visual C++
public ref class TemplateChange

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Templates..::..TemplateChangeList..::..TemplateChange

See Also

TemplateChangeList..::..TemplateChange Members
Sitecore.Data.Templates Namespace


TemplateChangeList.TemplateChange Members

[image] [image]

Sitecore 6.4.1 API
TemplateChangeList..::..TemplateChange Members
TemplateChangeList..::..TemplateChange Class Constructors Methods Properties See Also Send Feedback

Holds a list of changes to be made when the template of an item is changed.

The TemplateChangeList..::..TemplateChange type exposes the following members.

Constructors

 | Name | Description
Public method | TemplateChangeList..::..TemplateChange(TemplateChangeAction, TemplateField, TemplateChangeList) | Creates a new TemplateChangeList..::..TemplateChange instance.
Public method | TemplateChangeList..::..TemplateChange(TemplateChangeAction, TemplateField, TemplateField, TemplateChangeList) | Creates a new TemplateChangeList..::..TemplateChange instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Action | Gets the action.
Public property | Owner | Gets the owner.
Public property | SourceField | Gets the source field.
Public property | TargetField | Gets the target field.

See Also

TemplateChangeList..::..TemplateChange Class
Sitecore.Data.Templates Namespace


TemplateChangeList.TemplateChange Constructor

[image] [image]

Sitecore 6.4.1 API
TemplateChangeList..::..TemplateChange Constructor
TemplateChangeList..::..TemplateChange Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TemplateChangeList..::..TemplateChange(TemplateChangeAction, TemplateField, TemplateChangeList) | Creates a new TemplateChangeList..::..TemplateChange instance.
Public method | TemplateChangeList..::..TemplateChange(TemplateChangeAction, TemplateField, TemplateField, TemplateChangeList) | Creates a new TemplateChangeList..::..TemplateChange instance.

See Also

TemplateChangeList..::..TemplateChange Class
TemplateChangeList..::..TemplateChange Members
Sitecore.Data.Templates Namespace


TemplateChangeList.TemplateChange Constructor (TemplateChangeAction, TemplateField, TemplateChangeList)

[image]

Sitecore 6.4.1 API
TemplateChangeList..::..TemplateChange Constructor (TemplateChangeAction, TemplateField, TemplateChangeList)
TemplateChangeList..::..TemplateChange Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateChange(
    TemplateChangeAction action,
    TemplateField sourceField,
    TemplateChangeList owner
)
Visual Basic
Public Sub New ( _
    action As TemplateChangeAction, _
    sourceField As TemplateField, _
    owner As TemplateChangeList _
)
Visual C++
public:
TemplateChange(
    TemplateChangeAction action,
    TemplateField^ sourceField,
    TemplateChangeList^ owner
)

Parameters

action
Type: Sitecore.Data.Templates..::..TemplateChangeAction
Action.
sourceField
Type: Sitecore.Data.Templates..::..TemplateField
Source field.
owner
Type: Sitecore.Data.Templates..::..TemplateChangeList
Owner.

See Also

TemplateChangeList..::..TemplateChange Class
TemplateChangeList..::..TemplateChange Overload
Sitecore.Data.Templates Namespace


TemplateChangeList.TemplateChange Constructor (TemplateChangeAction, TemplateField, TemplateField, TemplateChangeList)

[image]

Sitecore 6.4.1 API
TemplateChangeList..::..TemplateChange Constructor (TemplateChangeAction, TemplateField, TemplateField, TemplateChangeList)
TemplateChangeList..::..TemplateChange Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateChange(
    TemplateChangeAction action,
    TemplateField sourceField,
    TemplateField targetField,
    TemplateChangeList owner
)
Visual Basic
Public Sub New ( _
    action As TemplateChangeAction, _
    sourceField As TemplateField, _
    targetField As TemplateField, _
    owner As TemplateChangeList _
)
Visual C++
public:
TemplateChange(
    TemplateChangeAction action,
    TemplateField^ sourceField,
    TemplateField^ targetField,
    TemplateChangeList^ owner
)

Parameters

action
Type: Sitecore.Data.Templates..::..TemplateChangeAction
Action.
sourceField
Type: Sitecore.Data.Templates..::..TemplateField
Source field.
targetField
Type: Sitecore.Data.Templates..::..TemplateField
Target field.
owner
Type: Sitecore.Data.Templates..::..TemplateChangeList
Owner.

See Also

TemplateChangeList..::..TemplateChange Class
TemplateChangeList..::..TemplateChange Overload
Sitecore.Data.Templates Namespace


TemplateChangeList.TemplateChange Methods

[image] [image]

Sitecore 6.4.1 API
TemplateChangeList..::..TemplateChange Methods
TemplateChangeList..::..TemplateChange Class See Also Send Feedback

The TemplateChangeList..::..TemplateChange type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TemplateChangeList..::..TemplateChange Class
Sitecore.Data.Templates Namespace


TemplateChangeList.TemplateChange Properties

[image] [image]

Sitecore 6.4.1 API
TemplateChangeList..::..TemplateChange Properties
TemplateChangeList..::..TemplateChange Class See Also Send Feedback

The TemplateChangeList..::..TemplateChange type exposes the following members.

Properties

 | Name | Description
Public property | Action | Gets the action.
Public property | Owner | Gets the owner.
Public property | SourceField | Gets the source field.
Public property | TargetField | Gets the target field.

See Also

TemplateChangeList..::..TemplateChange Class
Sitecore.Data.Templates Namespace


Action Property

[image]

Sitecore 6.4.1 API
TemplateChangeList..::..TemplateChange..::..Action Property
TemplateChangeList..::..TemplateChange Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateChangeAction Action { get; }
Visual Basic
Public ReadOnly Property Action As TemplateChangeAction
    Get
Visual C++
public:
property TemplateChangeAction Action {
    TemplateChangeAction get ();
}

Field Value

The action.

See Also

TemplateChangeList..::..TemplateChange Class
Sitecore.Data.Templates Namespace


Owner Property

[image]

Sitecore 6.4.1 API
TemplateChangeList..::..TemplateChange..::..Owner Property
TemplateChangeList..::..TemplateChange Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateChangeList Owner { get; }
Visual Basic
Public ReadOnly Property Owner As TemplateChangeList
    Get
Visual C++
public:
property TemplateChangeList^ Owner {
    TemplateChangeList^ get ();
}

Field Value

The owner.

See Also

TemplateChangeList..::..TemplateChange Class
Sitecore.Data.Templates Namespace


SourceField Property

[image]

Sitecore 6.4.1 API
TemplateChangeList..::..TemplateChange..::..SourceField Property
TemplateChangeList..::..TemplateChange Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateField SourceField { get; }
Visual Basic
Public ReadOnly Property SourceField As TemplateField
    Get
Visual C++
public:
property TemplateField^ SourceField {
    TemplateField^ get ();
}

Field Value

The source field.

See Also

TemplateChangeList..::..TemplateChange Class
Sitecore.Data.Templates Namespace


TargetField Property

[image]

Sitecore 6.4.1 API
TemplateChangeList..::..TemplateChange..::..TargetField Property
TemplateChangeList..::..TemplateChange Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateField TargetField { get; }
Visual Basic
Public ReadOnly Property TargetField As TemplateField
    Get
Visual C++
public:
property TemplateField^ TargetField {
    TemplateField^ get ();
}

Field Value

The target field.

See Also

TemplateChangeList..::..TemplateChange Class
Sitecore.Data.Templates Namespace


TemplateCollection Class

[image]

Sitecore 6.4.1 API
TemplateCollection Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class TemplateCollection : Collection<Template>
Visual Basic
Public Class TemplateCollection _
    Inherits Collection(Of Template)
Visual C++
public ref class TemplateCollection : public Collection<Template^>

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<' Template >)>)>
Sitecore.Data.Templates..::..TemplateCollection

See Also

TemplateCollection Members
Sitecore.Data.Templates Namespace


TemplateCollection Members

[image] [image]

Sitecore 6.4.1 API
TemplateCollection Members
TemplateCollection Class Constructors Methods Properties See Also Send Feedback

The TemplateCollection type exposes the following members.

Constructors

 | Name | Description
Public method | TemplateCollection()()()() | Initializes a new instance of the TemplateCollection class.
Public method | TemplateCollection(array<Template>[]()[][]) | Obsolete. Initializes a new instance of the TemplateCollection class.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Template >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Template >)>)>.)
Protected method | ClearItems | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Template >)>)>.)
Public method | Clone | Creates a shallow copy of the collection.
Public method | Contains(ID) | Creates a shallow copy of the collection.
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Template >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' Template >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAll | Gets all templates in the collection.
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Template >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTemplate(String) | Gets the template.
Public method | GetTemplate(ID) | Gets the template.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Template >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Template >)>)>.)
Protected method | InsertItem | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Template >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Template >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Template >)>)>.)
Protected method | RemoveItem | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Template >)>)>.)
Public method | Reset | Resets the specified templates.
Protected method | SetItem | Replaces the element at the specified index. (Inherited from Collection <(Of <(<' Template >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Template >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Template >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Template >)>)>.)

See Also

TemplateCollection Class
Sitecore.Data.Templates Namespace


TemplateCollection Constructor

[image] [image]

Sitecore 6.4.1 API
TemplateCollection Constructor
TemplateCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TemplateCollection()()()() | Initializes a new instance of the TemplateCollection class.
Public method | TemplateCollection(array<Template>[]()[][]) | Obsolete. Initializes a new instance of the TemplateCollection class.

See Also

TemplateCollection Class
TemplateCollection Members
Sitecore.Data.Templates Namespace


TemplateCollection Constructor (Template[])

[image]

Sitecore 6.4.1 API
TemplateCollection Constructor (array<Template>[]()[][])
TemplateCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated", false)]
public TemplateCollection(
    Template[] templates
)
Visual Basic
<ObsoleteAttribute("Deprecated", False)> _
Public Sub New ( _
    templates As Template() _
)
Visual C++
[ObsoleteAttribute(L"Deprecated", false)]
public:
TemplateCollection(
    array<Template^>^ templates
)

Parameters

templates
Type: array< Sitecore.Data.Templates..::..Template >[]()[][]
The templates.

See Also

TemplateCollection Class
TemplateCollection Overload
Sitecore.Data.Templates Namespace


TemplateCollection Methods

[image] [image]

Sitecore 6.4.1 API
TemplateCollection Methods
TemplateCollection Class See Also Send Feedback

The TemplateCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Template >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Template >)>)>.)
Protected method | ClearItems | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Template >)>)>.)
Public method | Clone | Creates a shallow copy of the collection.
Public method | Contains(ID) | Creates a shallow copy of the collection.
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Template >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' Template >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAll | Gets all templates in the collection.
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Template >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTemplate(String) | Gets the template.
Public method | GetTemplate(ID) | Gets the template.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Template >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Template >)>)>.)
Protected method | InsertItem | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Template >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Template >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Template >)>)>.)
Protected method | RemoveItem | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Template >)>)>.)
Public method | Reset | Resets the specified templates.
Protected method | SetItem | Replaces the element at the specified index. (Inherited from Collection <(Of <(<' Template >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TemplateCollection Class
Sitecore.Data.Templates Namespace


Clone Method

[image]

Sitecore 6.4.1 API
TemplateCollection..::..Clone Method
TemplateCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateCollection Clone()
Visual Basic
Public Function Clone As TemplateCollection
Visual C++
public:
TemplateCollection^ Clone()

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Templates.TemplateCollection.Clone"]

See Also

TemplateCollection Class
Sitecore.Data.Templates Namespace


Contains Method

[image] [image]

Sitecore 6.4.1 API
TemplateCollection..::..Contains Method
TemplateCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Contains(ID) | Creates a shallow copy of the collection.
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Template >)>)>.)

See Also

TemplateCollection Class
TemplateCollection Members
Sitecore.Data.Templates Namespace


Contains Method (ID)

[image]

Sitecore 6.4.1 API
TemplateCollection..::..Contains Method (ID)
TemplateCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Contains(
    ID templateId
)
Visual Basic
Public Function Contains ( _
    templateId As ID _
) As Boolean
Visual C++
public:
bool Contains(
    ID^ templateId
)

Parameters

templateId
Type: Sitecore.Data..::..ID
The template id.

Return Value

true if [contains] [the specified template id]; otherwise, false.

See Also

TemplateCollection Class
Contains Overload
Sitecore.Data.Templates Namespace


GetTemplate Method

[image] [image]

Sitecore 6.4.1 API
TemplateCollection..::..GetTemplate Method
TemplateCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTemplate(String) | Gets the template.
Public method | GetTemplate(ID) | Gets the template.

See Also

TemplateCollection Class
TemplateCollection Members
Sitecore.Data.Templates Namespace


GetTemplate Method (String)

[image]

Sitecore 6.4.1 API
TemplateCollection..::..GetTemplate Method (String)
TemplateCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Template GetTemplate(
    string fullName
)
Visual Basic
Public Overridable Function GetTemplate ( _
    fullName As String _
) As Template
Visual C++
public:
virtual Template^ GetTemplate(
    String^ fullName
)

Parameters

fullName
Type: System..::..String
The full name.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Templates.TemplateCollection.GetTemplate(System.String)"]

See Also

TemplateCollection Class
GetTemplate Overload
Sitecore.Data.Templates Namespace


GetTemplate Method (ID)

[image]

Sitecore 6.4.1 API
TemplateCollection..::..GetTemplate Method (ID)
TemplateCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Template GetTemplate(
    ID templateID
)
Visual Basic
Public Overridable Function GetTemplate ( _
    templateID As ID _
) As Template
Visual C++
public:
virtual Template^ GetTemplate(
    ID^ templateID
)

Parameters

templateID
Type: Sitecore.Data..::..ID
The template ID.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Templates.TemplateCollection.GetTemplate(Sitecore.Data.ID)"]

See Also

TemplateCollection Class
GetTemplate Overload
Sitecore.Data.Templates Namespace


Reset Method

[image]

Sitecore 6.4.1 API
TemplateCollection..::..Reset Method
TemplateCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Reset(
    Template[] templates
)
Visual Basic
Public Overridable Sub Reset ( _
    templates As Template() _
)
Visual C++
public:
virtual void Reset(
    array<Template^>^ templates
)

Parameters

templates
Type: array< Sitecore.Data.Templates..::..Template >[]()[][]
The templates.

See Also

TemplateCollection Class
Sitecore.Data.Templates Namespace


TemplateCollection Properties

[image] [image]

Sitecore 6.4.1 API
TemplateCollection Properties
TemplateCollection Class See Also Send Feedback

The TemplateCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Template >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Template >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Template >)>)>.)

See Also

TemplateCollection Class
Sitecore.Data.Templates Namespace


TemplateField Class

[image]

Sitecore 6.4.1 API
TemplateField Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class TemplateField
Visual Basic
Public Class TemplateField
Visual C++
public ref class TemplateField

Remarks

Remarks

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Templates..::..TemplateField

See Also

TemplateField Members
Sitecore.Data.Templates Namespace
Sitecore.Data.Templates..::..TemplateSection
TemplateField..::..Template


TemplateField Constructor

[image]

Sitecore 6.4.1 API
TemplateField Constructor
TemplateField Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateField(
    string name,
    ID id,
    TemplateSection section
)
Visual Basic
Public Sub New ( _
    name As String, _
    id As ID, _
    section As TemplateSection _
)
Visual C++
public:
TemplateField(
    String^ name,
    ID^ id,
    TemplateSection^ section
)

Parameters

name
Type: System..::..String
Name.
id
Type: Sitecore.Data..::..ID
Id.
section
Type: Sitecore.Data.Templates..::..TemplateSection
Section.

See Also

TemplateField Class
Sitecore.Data.Templates Namespace


TemplateField Methods

[image] [image]

Sitecore 6.4.1 API
TemplateField Methods
TemplateField Class See Also Send Feedback

The TemplateField type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDescription | Gets the description.
Public method | GetDescriptionIndex | Gets the description index.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTitle | Gets the title.
Public method | GetTitleIndex | Obsolete. Gets the index of the title.
Public method | GetToolTip | Gets the tool tip.
Public method | GetToolTipIndex | Obsolete. Gets the index of the tool tip.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TemplateField Class
Sitecore.Data.Templates Namespace


GetDescription Method

[image]

Sitecore 6.4.1 API
TemplateField..::..GetDescription Method
TemplateField Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetDescription(
    Language language
)
Visual Basic
Public Function GetDescription ( _
    language As Language _
) As String
Visual C++
public:
String^ GetDescription(
    Language^ language
)

Parameters

language
Type: Sitecore.Globalization..::..Language
Language.

Return Value

The description.

See Also

TemplateField Class
Sitecore.Data.Templates Namespace


GetDescriptionIndex Method

[image]

Sitecore 6.4.1 API
TemplateField..::..GetDescriptionIndex Method
TemplateField Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int GetDescriptionIndex(
    Language language
)
Visual Basic
Public Function GetDescriptionIndex ( _
    language As Language _
) As Integer
Visual C++
public:
int GetDescriptionIndex(
    Language^ language
)

Parameters

language
Type: Sitecore.Globalization..::..Language
Language.

Return Value

The description index.

See Also

TemplateField Class
Sitecore.Data.Templates Namespace


GetTitle Method

[image]

Sitecore 6.4.1 API
TemplateField..::..GetTitle Method
TemplateField Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetTitle(
    Language language
)
Visual Basic
Public Function GetTitle ( _
    language As Language _
) As String
Visual C++
public:
String^ GetTitle(
    Language^ language
)

Parameters

language
Type: Sitecore.Globalization..::..Language
Language.

Return Value

The title.

See Also

TemplateField Class
Sitecore.Data.Templates Namespace


GetTitleIndex Method

[image]

Sitecore 6.4.1 API
TemplateField..::..GetTitleIndex Method
TemplateField Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated")]
public int GetTitleIndex(
    Language language
)
Visual Basic
<ObsoleteAttribute("Deprecated")> _
Public Function GetTitleIndex ( _
    language As Language _
) As Integer
Visual C++
[ObsoleteAttribute(L"Deprecated")]
public:
int GetTitleIndex(
    Language^ language
)

Parameters

language
Type: Sitecore.Globalization..::..Language
The language.

Return Value

The index of the title.

See Also

TemplateField Class
Sitecore.Data.Templates Namespace


GetToolTip Method

[image]

Sitecore 6.4.1 API
TemplateField..::..GetToolTip Method
TemplateField Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetToolTip(
    Language language
)
Visual Basic
Public Function GetToolTip ( _
    language As Language _
) As String
Visual C++
public:
String^ GetToolTip(
    Language^ language
)

Parameters

language
Type: Sitecore.Globalization..::..Language
Language.

Return Value

The tool tip.

See Also

TemplateField Class
Sitecore.Data.Templates Namespace


GetToolTipIndex Method

[image]

Sitecore 6.4.1 API
TemplateField..::..GetToolTipIndex Method
TemplateField Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated")]
public int GetToolTipIndex(
    Language language
)
Visual Basic
<ObsoleteAttribute("Deprecated")> _
Public Function GetToolTipIndex ( _
    language As Language _
) As Integer
Visual C++
[ObsoleteAttribute(L"Deprecated")]
public:
int GetToolTipIndex(
    Language^ language
)

Parameters

language
Type: Sitecore.Globalization..::..Language
The language.

Return Value

The Int32.

See Also

TemplateField Class
Sitecore.Data.Templates Namespace


TemplateField Properties

[image] [image]

Sitecore 6.4.1 API
TemplateField Properties
TemplateField Class See Also Send Feedback

The TemplateField type exposes the following members.

Properties

 | Name | Description
Public property | DefaultValue | Gets the default value.
 | Empty | Gets the empty (ie. null) instance.
Public property | ExcludeFromTextSearch | Marks field to be skipped by index crawler when looking for fields using field type. Does not affect direct references to fields by name or ID. In default installation excludes a text field from Lucene FTS index ('system').
Public property | HelpLink | Gets the help link.
Public property | Icon | Gets the icon.
Public property | ID | Gets the ID.
Public property | IsBlob | Gets a value indicating whether the field should be loaded on demand.
Public property | IsEmpty | Gets a value indicating whether this instance is empty (ie. the null instance).
Public property | IsShared | Gets a value indicating whether this TemplateField is shared.
Public property | IsUnversioned | Gets a value indicating whether this TemplateField is unversioned.
Public property | IsVersioned | Gets a value indicating whether this TemplateField is versioned.
Public property | Key | Gets the key.
Public property | Name | Gets the name.
Public property | ResetBlank | Gets a value indicating whether blank fields should be set to their default value.
Public property | Section | Gets the section.
Public property | Sortorder | Gets the sortorder.
Public property | Source | Gets the source.
Public property | Style | Gets the CSS style to use in the client.
Public property | Template | Gets the template.
Public property | Type | Gets the type.
Public property | TypeKey | Gets the type key.
Public property | Validation | Gets the validation.
Public property | ValidationText | Gets the validation text.

See Also

TemplateField Class
Sitecore.Data.Templates Namespace


DefaultValue Property

[image]

Sitecore 6.4.1 API
TemplateField..::..DefaultValue Property
TemplateField Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string DefaultValue { get; }
Visual Basic
Public ReadOnly Property DefaultValue As String
    Get
Visual C++
public:
property String^ DefaultValue {
    String^ get ();
}

Field Value

The default value.

See Also

TemplateField Class
Sitecore.Data.Templates Namespace


ExcludeFromTextSearch Property

[image]

Sitecore 6.4.1 API
TemplateField..::..ExcludeFromTextSearch Property
TemplateField Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ExcludeFromTextSearch { get; }
Visual Basic
Public ReadOnly Property ExcludeFromTextSearch As Boolean
    Get
Visual C++
public:
property bool ExcludeFromTextSearch {
    bool get ();
}

See Also

TemplateField Class
Sitecore.Data.Templates Namespace


HelpLink Property

[image]

Sitecore 6.4.1 API
TemplateField..::..HelpLink Property
TemplateField Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string HelpLink { get; }
Visual Basic
Public ReadOnly Property HelpLink As String
    Get
Visual C++
public:
property String^ HelpLink {
    String^ get ();
}

Field Value

The help link.

See Also

TemplateField Class
Sitecore.Data.Templates Namespace


IsBlob Property

[image]

Sitecore 6.4.1 API
TemplateField..::..IsBlob Property
TemplateField Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsBlob { get; }
Visual Basic
Public ReadOnly Property IsBlob As Boolean
    Get
Visual C++
public:
property bool IsBlob {
    bool get ();
}

Field Value

true if shared; otherwise, false.

See Also

TemplateField Class
Sitecore.Data.Templates Namespace


IsEmpty Property

[image]

Sitecore 6.4.1 API
TemplateField..::..IsEmpty Property
TemplateField Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
property bool IsEmpty {
    bool get ();
}

Field Value

true if this instance is empty; otherwise, false.

See Also

TemplateField Class
Sitecore.Data.Templates Namespace


IsShared Property

[image]

Sitecore 6.4.1 API
TemplateField..::..IsShared Property
TemplateField Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsShared { get; }
Visual Basic
Public ReadOnly Property IsShared As Boolean
    Get
Visual C++
public:
property bool IsShared {
    bool get ();
}

Field Value

true if shared; otherwise, false.

See Also

TemplateField Class
Sitecore.Data.Templates Namespace


IsUnversioned Property

[image]

Sitecore 6.4.1 API
TemplateField..::..IsUnversioned Property
TemplateField Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsUnversioned { get; }
Visual Basic
Public ReadOnly Property IsUnversioned As Boolean
    Get
Visual C++
public:
property bool IsUnversioned {
    bool get ();
}

Field Value

true if unversioned; otherwise, false.

See Also

TemplateField Class
Sitecore.Data.Templates Namespace


IsVersioned Property

[image]

Sitecore 6.4.1 API
TemplateField..::..IsVersioned Property
TemplateField Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsVersioned { get; }
Visual Basic
Public ReadOnly Property IsVersioned As Boolean
    Get
Visual C++
public:
property bool IsVersioned {
    bool get ();
}

Field Value

true if versioned; otherwise, false.

See Also

TemplateField Class
Sitecore.Data.Templates Namespace


Key Property

[image]

Sitecore 6.4.1 API
TemplateField..::..Key Property
TemplateField Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Key { get; }
Visual Basic
Public ReadOnly Property Key As String
    Get
Visual C++
public:
property String^ Key {
    String^ get ();
}

Field Value

The key.

See Also

TemplateField Class
Sitecore.Data.Templates Namespace


Name Property

[image]

Sitecore 6.4.1 API
TemplateField..::..Name Property
TemplateField Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

TemplateField Class
Sitecore.Data.Templates Namespace


Section Property

[image]

Sitecore 6.4.1 API
TemplateField..::..Section Property
TemplateField Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateSection Section { get; }
Visual Basic
Public ReadOnly Property Section As TemplateSection
    Get
Visual C++
public:
property TemplateSection^ Section {
    TemplateSection^ get ();
}

Field Value

The section.

See Also

TemplateField Class
Sitecore.Data.Templates Namespace


Sortorder Property

[image]

Sitecore 6.4.1 API
TemplateField..::..Sortorder Property
TemplateField Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Sortorder { get; }
Visual Basic
Public ReadOnly Property Sortorder As Integer
    Get
Visual C++
public:
property int Sortorder {
    int get ();
}

Field Value

The sortorder.

See Also

TemplateField Class
Sitecore.Data.Templates Namespace


Source Property

[image]

Sitecore 6.4.1 API
TemplateField..::..Source Property
TemplateField Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Source { get; }
Visual Basic
Public ReadOnly Property Source As String
    Get
Visual C++
public:
property String^ Source {
    String^ get ();
}

Field Value

The source.

See Also

TemplateField Class
Sitecore.Data.Templates Namespace


Style Property

[image]

Sitecore 6.4.1 API
TemplateField..::..Style Property
TemplateField Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Style { get; }
Visual Basic
Public ReadOnly Property Style As String
    Get
Visual C++
public:
property String^ Style {
    String^ get ();
}

Field Value

The style.

See Also

TemplateField Class
Sitecore.Data.Templates Namespace


Template Property

[image]

Sitecore 6.4.1 API
TemplateField..::..Template Property
TemplateField Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Template Template { get; }
Visual Basic
Public ReadOnly Property Template As Template
    Get
Visual C++
public:
property Template^ Template {
    Template^ get ();
}

Field Value

The template.

See Also

TemplateField Class
Sitecore.Data.Templates Namespace


Type Property

[image]

Sitecore 6.4.1 API
TemplateField..::..Type Property
TemplateField Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Type { get; }
Visual Basic
Public ReadOnly Property Type As String
    Get
Visual C++
public:
property String^ Type {
    String^ get ();
}

Field Value

The type.

See Also

TemplateField Class
Sitecore.Data.Templates Namespace


TypeKey Property

[image]

Sitecore 6.4.1 API
TemplateField..::..TypeKey Property
TemplateField Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string TypeKey { get; }
Visual Basic
Public ReadOnly Property TypeKey As String
    Get
Visual C++
public:
property String^ TypeKey {
    String^ get ();
}

Field Value

The type key.

See Also

TemplateField Class
Sitecore.Data.Templates Namespace


Validation Property

[image]

Sitecore 6.4.1 API
TemplateField..::..Validation Property
TemplateField Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Validation { get; }
Visual Basic
Public ReadOnly Property Validation As String
    Get
Visual C++
public:
property String^ Validation {
    String^ get ();
}

Field Value

The validation.

See Also

TemplateField Class
Sitecore.Data.Templates Namespace


ValidationText Property

[image]

Sitecore 6.4.1 API
TemplateField..::..ValidationText Property
TemplateField Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ValidationText { get; }
Visual Basic
Public ReadOnly Property ValidationText As String
    Get
Visual C++
public:
property String^ ValidationText {
    String^ get ();
}

Field Value

The validation text.

See Also

TemplateField Class
Sitecore.Data.Templates Namespace


TemplateField.Builder Class

[image]

Sitecore 6.4.1 API
TemplateField..::..Builder Class
TemplateField Class Members See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Builder
Visual Basic
Public Class Builder
Visual C++
public ref class Builder

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Templates..::..TemplateField..::..Builder

See Also

TemplateField..::..Builder Members
Sitecore.Data.Templates Namespace


TemplateField.Builder Members

[image] [image]

Sitecore 6.4.1 API
TemplateField..::..Builder Members
TemplateField..::..Builder Class Constructors Methods Properties See Also Send Feedback

Represents a template field.

The TemplateField..::..Builder type exposes the following members.

Constructors

 | Name | Description
Public method | TemplateField..::..Builder | Creates a new TemplateField..::..Builder instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDefaultValue | Sets the default value.
Public method | SetDescription | Sets the description.
Public method | SetExcludeFromTextSearch | Sets the 'exclude from index' flag.
Public method | SetHelpLink | Sets the help link.
Public method | SetIcon | Sets the icon.
Public method | SetIsBlob | Sets the load on demand flag.
Public method | SetResetBlank | Sets the reset blank flag.
Public method | SetShared | Sets the shared flag.
Public method | SetSortorder | Sets the sortorder.
Public method | SetSource | Sets the source.
Public method | SetStyle | Sets the CSS style.
Public method | SetTitle | Sets the title.
Public method | SetToolTip | Sets the tool tip.
Public method | SetType | Sets the type.
Public method | SetUnversioned | Sets the unversioned flag.
Public method | SetValidation | Sets the validation.
Public method | SetValidationText | Sets the validation text.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Field | Gets the field.

See Also

TemplateField..::..Builder Class
Sitecore.Data.Templates Namespace


TemplateField.Builder Constructor

[image]

Sitecore 6.4.1 API
TemplateField..::..Builder Constructor
TemplateField..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Builder(
    string fieldName,
    ID fieldID,
    TemplateSection section
)
Visual Basic
Public Sub New ( _
    fieldName As String, _
    fieldID As ID, _
    section As TemplateSection _
)
Visual C++
public:
Builder(
    String^ fieldName,
    ID^ fieldID,
    TemplateSection^ section
)

Parameters

fieldName
Type: System..::..String
Name of the field.
fieldID
Type: Sitecore.Data..::..ID
Field ID.
section
Type: Sitecore.Data.Templates..::..TemplateSection
Section.

See Also

TemplateField..::..Builder Class
Sitecore.Data.Templates Namespace


TemplateField.Builder Methods

[image] [image]

Sitecore 6.4.1 API
TemplateField..::..Builder Methods
TemplateField..::..Builder Class See Also Send Feedback

The TemplateField..::..Builder type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDefaultValue | Sets the default value.
Public method | SetDescription | Sets the description.
Public method | SetExcludeFromTextSearch | Sets the 'exclude from index' flag.
Public method | SetHelpLink | Sets the help link.
Public method | SetIcon | Sets the icon.
Public method | SetIsBlob | Sets the load on demand flag.
Public method | SetResetBlank | Sets the reset blank flag.
Public method | SetShared | Sets the shared flag.
Public method | SetSortorder | Sets the sortorder.
Public method | SetSource | Sets the source.
Public method | SetStyle | Sets the CSS style.
Public method | SetTitle | Sets the title.
Public method | SetToolTip | Sets the tool tip.
Public method | SetType | Sets the type.
Public method | SetUnversioned | Sets the unversioned flag.
Public method | SetValidation | Sets the validation.
Public method | SetValidationText | Sets the validation text.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TemplateField..::..Builder Class
Sitecore.Data.Templates Namespace


SetDefaultValue Method

[image]

Sitecore 6.4.1 API
TemplateField..::..Builder..::..SetDefaultValue Method
TemplateField..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetDefaultValue(
    string value
)
Visual Basic
Public Sub SetDefaultValue ( _
    value As String _
)
Visual C++
public:
void SetDefaultValue(
    String^ value
)

Parameters

value
Type: System..::..String
Value.

See Also

TemplateField..::..Builder Class
Sitecore.Data.Templates Namespace


SetExcludeFromTextSearch Method

[image]

Sitecore 6.4.1 API
TemplateField..::..Builder..::..SetExcludeFromTextSearch Method
TemplateField..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetExcludeFromTextSearch(
    bool value
)
Visual Basic
Public Sub SetExcludeFromTextSearch ( _
    value As Boolean _
)
Visual C++
public:
void SetExcludeFromTextSearch(
    bool value
)

Parameters

value
Type: System..::..Boolean
Flag state

See Also

TemplateField..::..Builder Class
Sitecore.Data.Templates Namespace


SetHelpLink Method

[image]

Sitecore 6.4.1 API
TemplateField..::..Builder..::..SetHelpLink Method
TemplateField..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetHelpLink(
    string value
)
Visual Basic
Public Sub SetHelpLink ( _
    value As String _
)
Visual C++
public:
void SetHelpLink(
    String^ value
)

Parameters

value
Type: System..::..String
Value.

See Also

TemplateField..::..Builder Class
Sitecore.Data.Templates Namespace


SetIcon Method

[image]

Sitecore 6.4.1 API
TemplateField..::..Builder..::..SetIcon Method
TemplateField..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetIcon(
    string icon
)
Visual Basic
Public Sub SetIcon ( _
    icon As String _
)
Visual C++
public:
void SetIcon(
    String^ icon
)

Parameters

icon
Type: System..::..String
Icon.

See Also

TemplateField..::..Builder Class
Sitecore.Data.Templates Namespace


SetIsBlob Method

[image]

Sitecore 6.4.1 API
TemplateField..::..Builder..::..SetIsBlob Method
TemplateField..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetIsBlob(
    bool value
)
Visual Basic
Public Sub SetIsBlob ( _
    value As Boolean _
)
Visual C++
public:
void SetIsBlob(
    bool value
)

Parameters

value
Type: System..::..Boolean
The flag value.

See Also

TemplateField..::..Builder Class
Sitecore.Data.Templates Namespace


SetResetBlank Method

[image]

Sitecore 6.4.1 API
TemplateField..::..Builder..::..SetResetBlank Method
TemplateField..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetResetBlank(
    bool value
)
Visual Basic
Public Sub SetResetBlank ( _
    value As Boolean _
)
Visual C++
public:
void SetResetBlank(
    bool value
)

Parameters

value
Type: System..::..Boolean
Value.

See Also

TemplateField..::..Builder Class
Sitecore.Data.Templates Namespace


SetShared Method

[image]

Sitecore 6.4.1 API
TemplateField..::..Builder..::..SetShared Method
TemplateField..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetShared(
    bool value
)
Visual Basic
Public Sub SetShared ( _
    value As Boolean _
)
Visual C++
public:
void SetShared(
    bool value
)

Parameters

value
Type: System..::..Boolean
Value.

See Also

TemplateField..::..Builder Class
Sitecore.Data.Templates Namespace


SetSortorder Method

[image]

Sitecore 6.4.1 API
TemplateField..::..Builder..::..SetSortorder Method
TemplateField..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetSortorder(
    int value
)
Visual Basic
Public Sub SetSortorder ( _
    value As Integer _
)
Visual C++
public:
void SetSortorder(
    int value
)

Parameters

value
Type: System..::..Int32
Value.

See Also

TemplateField..::..Builder Class
Sitecore.Data.Templates Namespace


SetSource Method

[image]

Sitecore 6.4.1 API
TemplateField..::..Builder..::..SetSource Method
TemplateField..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetSource(
    string value
)
Visual Basic
Public Sub SetSource ( _
    value As String _
)
Visual C++
public:
void SetSource(
    String^ value
)

Parameters

value
Type: System..::..String
Value.

See Also

TemplateField..::..Builder Class
Sitecore.Data.Templates Namespace


SetStyle Method

[image]

Sitecore 6.4.1 API
TemplateField..::..Builder..::..SetStyle Method
TemplateField..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetStyle(
    string value
)
Visual Basic
Public Sub SetStyle ( _
    value As String _
)
Visual C++
public:
void SetStyle(
    String^ value
)

Parameters

value
Type: System..::..String
Value.

See Also

TemplateField..::..Builder Class
Sitecore.Data.Templates Namespace


SetTitle Method

[image]

Sitecore 6.4.1 API
TemplateField..::..Builder..::..SetTitle Method
TemplateField..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetTitle(
    string title,
    Language language
)
Visual Basic
Public Sub SetTitle ( _
    title As String, _
    language As Language _
)
Visual C++
public:
void SetTitle(
    String^ title,
    Language^ language
)

Parameters

title
Type: System..::..String
Title.
language
Type: Sitecore.Globalization..::..Language
Language.

See Also

TemplateField..::..Builder Class
Sitecore.Data.Templates Namespace


SetToolTip Method

[image]

Sitecore 6.4.1 API
TemplateField..::..Builder..::..SetToolTip Method
TemplateField..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetToolTip(
    string tooltip,
    Language language
)
Visual Basic
Public Sub SetToolTip ( _
    tooltip As String, _
    language As Language _
)
Visual C++
public:
void SetToolTip(
    String^ tooltip,
    Language^ language
)

Parameters

tooltip
Type: System..::..String
Tooltip.
language
Type: Sitecore.Globalization..::..Language
Language.

See Also

TemplateField..::..Builder Class
Sitecore.Data.Templates Namespace


SetType Method

[image]

Sitecore 6.4.1 API
TemplateField..::..Builder..::..SetType Method
TemplateField..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetType(
    string type
)
Visual Basic
Public Sub SetType ( _
    type As String _
)
Visual C++
public:
void SetType(
    String^ type
)

Parameters

type
Type: System..::..String
Type.

See Also

TemplateField..::..Builder Class
Sitecore.Data.Templates Namespace


SetUnversioned Method

[image]

Sitecore 6.4.1 API
TemplateField..::..Builder..::..SetUnversioned Method
TemplateField..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetUnversioned(
    bool value
)
Visual Basic
Public Sub SetUnversioned ( _
    value As Boolean _
)
Visual C++
public:
void SetUnversioned(
    bool value
)

Parameters

value
Type: System..::..Boolean
Value.

See Also

TemplateField..::..Builder Class
Sitecore.Data.Templates Namespace


SetValidation Method

[image]

Sitecore 6.4.1 API
TemplateField..::..Builder..::..SetValidation Method
TemplateField..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetValidation(
    string validation
)
Visual Basic
Public Sub SetValidation ( _
    validation As String _
)
Visual C++
public:
void SetValidation(
    String^ validation
)

Parameters

validation
Type: System..::..String
The validation.

See Also

TemplateField..::..Builder Class
Sitecore.Data.Templates Namespace


SetValidationText Method

[image]

Sitecore 6.4.1 API
TemplateField..::..Builder..::..SetValidationText Method
TemplateField..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetValidationText(
    string validationText
)
Visual Basic
Public Sub SetValidationText ( _
    validationText As String _
)
Visual C++
public:
void SetValidationText(
    String^ validationText
)

Parameters

validationText
Type: System..::..String
The validation text.

See Also

TemplateField..::..Builder Class
Sitecore.Data.Templates Namespace


TemplateField.Builder Properties

[image] [image]

Sitecore 6.4.1 API
TemplateField..::..Builder Properties
TemplateField..::..Builder Class See Also Send Feedback

The TemplateField..::..Builder type exposes the following members.

Properties

 | Name | Description
Public property | Field | Gets the field.

See Also

TemplateField..::..Builder Class
Sitecore.Data.Templates Namespace


Field Property

[image]

Sitecore 6.4.1 API
TemplateField..::..Builder..::..Field Property
TemplateField..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateField Field { get; }
Visual Basic
Public ReadOnly Property Field As TemplateField
    Get
Visual C++
public:
property TemplateField^ Field {
    TemplateField^ get ();
}

Field Value

The field.

See Also

TemplateField..::..Builder Class
Sitecore.Data.Templates Namespace


TemplateFieldSharing Enumeration

[image]

Sitecore 6.4.1 API
TemplateFieldSharing Enumeration
See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum TemplateFieldSharing
Visual Basic
Public Enumeration TemplateFieldSharing
Visual C++
public enum class TemplateFieldSharing

Members

Member name | Value | Description
None | 0 |
Unversioned | 1 |
Shared | 2 |

See Also

Sitecore.Data.Templates Namespace


TemplateList Class

[image]

Sitecore 6.4.1 API
TemplateList Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class TemplateList : ReadOnlyList<Template>
Visual Basic
Public Class TemplateList _
    Inherits ReadOnlyList(Of Template)
Visual C++
public ref class TemplateList : public ReadOnlyList<Template^>

Inheritance Hierarchy

System..::..Object
Sitecore.Collections..::..ReadOnlyList <(Of <(<' Template >)>)>
Sitecore.Data.Templates..::..TemplateList

See Also

TemplateList Members
Sitecore.Data.Templates Namespace


TemplateList Members

[image] [image]

Sitecore 6.4.1 API
TemplateList Members
TemplateList Class Constructors Methods Properties See Also Send Feedback

The TemplateList type exposes the following members.

Constructors

 | Name | Description
Public method | TemplateList()()()() | Initializes a new instance of the TemplateList class.
Public method | TemplateList(IEnumerable<(Of <<'(Template>)>>)) | Initializes a new instance of the TemplateList class.

Methods

 | Name | Description
Public method | Contains | Determines whether the list contains the specified element. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToArray | Converts the list to an array. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of entries in the list. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public property | Item | Gets the element at the specified index. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)

See Also

TemplateList Class
Sitecore.Data.Templates Namespace


TemplateList Constructor

[image] [image]

Sitecore 6.4.1 API
TemplateList Constructor
TemplateList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TemplateList()()()() | Initializes a new instance of the TemplateList class.
Public method | TemplateList(IEnumerable<(Of <<'(Template>)>>)) | Initializes a new instance of the TemplateList class.

See Also

TemplateList Class
TemplateList Members
Sitecore.Data.Templates Namespace


TemplateList Constructor

[image]

Sitecore 6.4.1 API
TemplateList Constructor
TemplateList Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateList()
Visual Basic
Public Sub New
Visual C++
public:
TemplateList()

See Also

TemplateList Class
TemplateList Overload
Sitecore.Data.Templates Namespace


TemplateList Constructor (IEnumerable(Template))

[image]

Sitecore 6.4.1 API
TemplateList Constructor (IEnumerable<(Of <(<'Template>)>)>)
TemplateList Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateList(
    IEnumerable<Template> entries
)
Visual Basic
Public Sub New ( _
    entries As IEnumerable(Of Template) _
)
Visual C++
public:
TemplateList(
    IEnumerable<Template^>^ entries
)

Parameters

entries
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Template >)>)>
The entries.

See Also

TemplateList Class
TemplateList Overload
Sitecore.Data.Templates Namespace


TemplateList Methods

[image] [image]

Sitecore 6.4.1 API
TemplateList Methods
TemplateList Class See Also Send Feedback

The TemplateList type exposes the following members.

Methods

 | Name | Description
Public method | Contains | Determines whether the list contains the specified element. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToArray | Converts the list to an array. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TemplateList Class
Sitecore.Data.Templates Namespace


TemplateList Properties

[image] [image]

Sitecore 6.4.1 API
TemplateList Properties
TemplateList Class See Also Send Feedback

The TemplateList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of entries in the list. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public property | Item | Gets the element at the specified index. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)

See Also

TemplateList Class
Sitecore.Data.Templates Namespace


TemplateParser Class

[image]

Sitecore 6.4.1 API
TemplateParser Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class TemplateParser
Visual Basic
Public NotInheritable Class TemplateParser
Visual C++
public ref class TemplateParser abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Templates..::..TemplateParser

See Also

TemplateParser Members
Sitecore.Data.Templates Namespace


TemplateParser Members

[image] [image]

Sitecore 6.4.1 API
TemplateParser Members
TemplateParser Class Methods See Also Send Feedback

The TemplateParser type exposes the following members.

Methods

Name | Description
Parse(String) | Builds template from XML string.
Parse(XmlDocument) | Builds templates from an XML document.
ParseFile | Builds templates from an XML file.

See Also

TemplateParser Class
Sitecore.Data.Templates Namespace


TemplateParser Methods

[image] [image]

Sitecore 6.4.1 API
TemplateParser Methods
TemplateParser Class See Also Send Feedback

The TemplateParser type exposes the following members.

Methods

Name | Description
Parse(String) | Builds template from XML string.
Parse(XmlDocument) | Builds templates from an XML document.
ParseFile | Builds templates from an XML file.

See Also

TemplateParser Class
Sitecore.Data.Templates Namespace


Parse Method

[image] [image]

Sitecore 6.4.1 API
TemplateParser..::..Parse Method
TemplateParser Class See Also Send Feedback

Overload List

Name | Description
Parse(String) | Builds template from XML string.
Parse(XmlDocument) | Builds templates from an XML document.

See Also

TemplateParser Class
TemplateParser Members
Sitecore.Data.Templates Namespace


Parse Method (String)

[image]

Sitecore 6.4.1 API
TemplateParser..::..Parse Method (String)
TemplateParser Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TemplateCollection Parse(
    string xml
)
Visual Basic
Public Shared Function Parse ( _
    xml As String _
) As TemplateCollection
Visual C++
public:
static TemplateCollection^ Parse(
    String^ xml
)

Parameters

xml
Type: System..::..String
XML.

Return Value

The parse.

See Also

TemplateParser Class
Parse Overload
Sitecore.Data.Templates Namespace


Parse Method (XmlDocument)

[image]

Sitecore 6.4.1 API
TemplateParser..::..Parse Method (XmlDocument)
TemplateParser Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TemplateCollection Parse(
    XmlDocument xmlDocument
)
Visual Basic
Public Shared Function Parse ( _
    xmlDocument As XmlDocument _
) As TemplateCollection
Visual C++
public:
static TemplateCollection^ Parse(
    XmlDocument^ xmlDocument
)

Parameters

xmlDocument
Type: System.Xml..::..XmlDocument
XML document.

Return Value

The parse.

See Also

TemplateParser Class
Parse Overload
Sitecore.Data.Templates Namespace


ParseFile Method

[image]

Sitecore 6.4.1 API
TemplateParser..::..ParseFile Method
TemplateParser Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TemplateCollection ParseFile(
    string filename
)
Visual Basic
Public Shared Function ParseFile ( _
    filename As String _
) As TemplateCollection
Visual C++
public:
static TemplateCollection^ ParseFile(
    String^ filename
)

Parameters

filename
Type: System..::..String
Filename.

Return Value

The file.

See Also

TemplateParser Class
Sitecore.Data.Templates Namespace


TemplateSection Class

[image]

Sitecore 6.4.1 API
TemplateSection Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class TemplateSection
Visual Basic
Public Class TemplateSection
Visual C++
public ref class TemplateSection

Remarks

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Templates..::..TemplateSection

See Also

TemplateSection Members
Sitecore.Data.Templates Namespace
TemplateSection..::..Template
Sitecore.Data.Templates..::..TemplateField


TemplateSection Members

[image] [image]

Sitecore 6.4.1 API
TemplateSection Members
TemplateSection Class Constructors Methods Properties See Also Send Feedback

The TemplateSection type exposes the following members.

Constructors

 | Name | Description
Public method | TemplateSection | Creates a new TemplateSection instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetField(String) | Gets a field.
Public method | GetField(ID) | Gets a field.
Public method | GetFields | Gets all the fields.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Fields | Gets the fields.
Public property | Icon | Gets the icon.
Public property | ID | Gets the ID.
Public property | Key | Gets the key.
Public property | Name | Gets the name.
Public property | Sortorder | Gets the sortorder.
Public property | Template | Gets the template.

See Also

TemplateSection Class
Sitecore.Data.Templates Namespace


TemplateSection Constructor

[image]

Sitecore 6.4.1 API
TemplateSection Constructor
TemplateSection Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateSection(
    string name,
    ID id,
    Template template
)
Visual Basic
Public Sub New ( _
    name As String, _
    id As ID, _
    template As Template _
)
Visual C++
public:
TemplateSection(
    String^ name,
    ID^ id,
    Template^ template
)

Parameters

name
Type: System..::..String
Name.
id
Type: Sitecore.Data..::..ID
Id.
template
Type: Sitecore.Data.Templates..::..Template
Template.

See Also

TemplateSection Class
Sitecore.Data.Templates Namespace


TemplateSection Methods

[image] [image]

Sitecore 6.4.1 API
TemplateSection Methods
TemplateSection Class See Also Send Feedback

The TemplateSection type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetField(String) | Gets a field.
Public method | GetField(ID) | Gets a field.
Public method | GetFields | Gets all the fields.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TemplateSection Class
Sitecore.Data.Templates Namespace


GetField Method

[image] [image]

Sitecore 6.4.1 API
TemplateSection..::..GetField Method
TemplateSection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetField(String) | Gets a field.
Public method | GetField(ID) | Gets a field.

See Also

TemplateSection Class
TemplateSection Members
Sitecore.Data.Templates Namespace


GetField Method (String)

[image]

Sitecore 6.4.1 API
TemplateSection..::..GetField Method (String)
TemplateSection Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateField GetField(
    string fieldName
)
Visual Basic
Public Function GetField ( _
    fieldName As String _
) As TemplateField
Visual C++
public:
TemplateField^ GetField(
    String^ fieldName
)

Parameters

fieldName
Type: System..::..String
Name of the field.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Templates.TemplateSection.GetField(System.String)"]

See Also

TemplateSection Class
GetField Overload
Sitecore.Data.Templates Namespace


GetField Method (ID)

[image]

Sitecore 6.4.1 API
TemplateSection..::..GetField Method (ID)
TemplateSection Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateField GetField(
    ID fieldID
)
Visual Basic
Public Function GetField ( _
    fieldID As ID _
) As TemplateField
Visual C++
public:
TemplateField^ GetField(
    ID^ fieldID
)

Parameters

fieldID
Type: Sitecore.Data..::..ID
Field ID.

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Templates.TemplateSection.GetField(Sitecore.Data.ID)"]

See Also

TemplateSection Class
GetField Overload
Sitecore.Data.Templates Namespace


GetFields Method

[image]

Sitecore 6.4.1 API
TemplateSection..::..GetFields Method
TemplateSection Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateField[] GetFields()
Visual Basic
Public Function GetFields As TemplateField()
Visual C++
public:
array<TemplateField^>^ GetFields()

Return Value

[Missing <returns> documentation for "M:Sitecore.Data.Templates.TemplateSection.GetFields"]

See Also

TemplateSection Class
Sitecore.Data.Templates Namespace


TemplateSection Properties

[image] [image]

Sitecore 6.4.1 API
TemplateSection Properties
TemplateSection Class See Also Send Feedback

The TemplateSection type exposes the following members.

Properties

 | Name | Description
Public property | Fields | Gets the fields.
Public property | Icon | Gets the icon.
Public property | ID | Gets the ID.
Public property | Key | Gets the key.
Public property | Name | Gets the name.
Public property | Sortorder | Gets the sortorder.
Public property | Template | Gets the template.

See Also

TemplateSection Class
Sitecore.Data.Templates Namespace


Fields Property

[image]

Sitecore 6.4.1 API
TemplateSection..::..Fields Property
TemplateSection Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ListDictionary Fields { get; }
Visual Basic
Public ReadOnly Property Fields As ListDictionary
    Get
Visual C++
public:
property ListDictionary^ Fields {
    ListDictionary^ get ();
}

Field Value

The fields.

See Also

TemplateSection Class
Sitecore.Data.Templates Namespace


Icon Property

[image]

Sitecore 6.4.1 API
TemplateSection..::..Icon Property
TemplateSection Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Icon { get; }
Visual Basic
Public ReadOnly Property Icon As String
    Get
Visual C++
public:
property String^ Icon {
    String^ get ();
}

Field Value

The icon.

See Also

TemplateSection Class
Sitecore.Data.Templates Namespace


ID Property

[image]

Sitecore 6.4.1 API
TemplateSection..::..ID Property
TemplateSection Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ID { get; }
Visual Basic
Public ReadOnly Property ID As ID
    Get
Visual C++
public:
property ID^ ID {
    ID^ get ();
}

Field Value

The ID.

See Also

TemplateSection Class
Sitecore.Data.Templates Namespace


Key Property

[image]

Sitecore 6.4.1 API
TemplateSection..::..Key Property
TemplateSection Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Key { get; }
Visual Basic
Public ReadOnly Property Key As String
    Get
Visual C++
public:
property String^ Key {
    String^ get ();
}

Field Value

The key.

See Also

TemplateSection Class
Sitecore.Data.Templates Namespace


Name Property

[image]

Sitecore 6.4.1 API
TemplateSection..::..Name Property
TemplateSection Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

TemplateSection Class
Sitecore.Data.Templates Namespace


Sortorder Property

[image]

Sitecore 6.4.1 API
TemplateSection..::..Sortorder Property
TemplateSection Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Sortorder { get; }
Visual Basic
Public ReadOnly Property Sortorder As Integer
    Get
Visual C++
public:
property int Sortorder {
    int get ();
}

Field Value

The sortorder.

See Also

TemplateSection Class
Sitecore.Data.Templates Namespace


Template Property

[image]

Sitecore 6.4.1 API
TemplateSection..::..Template Property
TemplateSection Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Template Template { get; }
Visual Basic
Public ReadOnly Property Template As Template
    Get
Visual C++
public:
property Template^ Template {
    Template^ get ();
}

Field Value

The template.

See Also

TemplateSection Class
Sitecore.Data.Templates Namespace


TemplateSection.Builder Class

[image]

Sitecore 6.4.1 API
TemplateSection..::..Builder Class
TemplateSection Class Members See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Builder
Visual Basic
Public Class Builder
Visual C++
public ref class Builder

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Templates..::..TemplateSection..::..Builder

See Also

TemplateSection..::..Builder Members
Sitecore.Data.Templates Namespace


TemplateSection.Builder Members

[image] [image]

Sitecore 6.4.1 API
TemplateSection..::..Builder Members
TemplateSection..::..Builder Class Constructors Methods Properties See Also Send Feedback

Represents a template section.

The TemplateSection..::..Builder type exposes the following members.

Constructors

 | Name | Description
Public method | TemplateSection..::..Builder | Creates a new TemplateSection..::..Builder instance.

Methods

 | Name | Description
Public method | AddField(XmlNode) | Adds a field.
Public method | AddField(String, ID) | Adds a field.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetIcon | Sets the icon.
Public method | SetSortorder | Sets the sortorder.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Section | Gets the section.

See Also

TemplateSection..::..Builder Class
Sitecore.Data.Templates Namespace


TemplateSection.Builder Constructor

[image]

Sitecore 6.4.1 API
TemplateSection..::..Builder Constructor
TemplateSection..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Builder(
    string sectionName,
    ID sectionID,
    Template template
)
Visual Basic
Public Sub New ( _
    sectionName As String, _
    sectionID As ID, _
    template As Template _
)
Visual C++
public:
Builder(
    String^ sectionName,
    ID^ sectionID,
    Template^ template
)

Parameters

sectionName
Type: System..::..String
Name of the section.
sectionID
Type: Sitecore.Data..::..ID
Section ID.
template
Type: Sitecore.Data.Templates..::..Template
Template.

See Also

TemplateSection..::..Builder Class
Sitecore.Data.Templates Namespace


TemplateSection.Builder Methods

[image] [image]

Sitecore 6.4.1 API
TemplateSection..::..Builder Methods
TemplateSection..::..Builder Class See Also Send Feedback

The TemplateSection..::..Builder type exposes the following members.

Methods

 | Name | Description
Public method | AddField(XmlNode) | Adds a field.
Public method | AddField(String, ID) | Adds a field.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetIcon | Sets the icon.
Public method | SetSortorder | Sets the sortorder.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TemplateSection..::..Builder Class
Sitecore.Data.Templates Namespace


AddField Method

[image] [image]

Sitecore 6.4.1 API
TemplateSection..::..Builder..::..AddField Method
TemplateSection..::..Builder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddField(XmlNode) | Adds a field.
Public method | AddField(String, ID) | Adds a field.

See Also

TemplateSection..::..Builder Class
TemplateSection..::..Builder Members
Sitecore.Data.Templates Namespace


AddField Method (XmlNode)

[image]

Sitecore 6.4.1 API
TemplateSection..::..Builder..::..AddField Method (XmlNode)
TemplateSection..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateField..::..Builder AddField(
    XmlNode node
)
Visual Basic
Public Function AddField ( _
    node As XmlNode _
) As TemplateField..::..Builder
Visual C++
public:
TemplateField..::..Builder^ AddField(
    XmlNode^ node
)

Parameters

node
Type: System.Xml..::..XmlNode
Node.

Return Value

The field.

See Also

TemplateSection..::..Builder Class
AddField Overload
Sitecore.Data.Templates Namespace


AddField Method (String, ID)

[image]

Sitecore 6.4.1 API
TemplateSection..::..Builder..::..AddField Method (String, ID)
TemplateSection..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateField..::..Builder AddField(
    string fieldName,
    ID fieldID
)
Visual Basic
Public Function AddField ( _
    fieldName As String, _
    fieldID As ID _
) As TemplateField..::..Builder
Visual C++
public:
TemplateField..::..Builder^ AddField(
    String^ fieldName,
    ID^ fieldID
)

Parameters

fieldName
Type: System..::..String
Name of the field.
fieldID
Type: Sitecore.Data..::..ID
Field ID.

Return Value

The field.

See Also

TemplateSection..::..Builder Class
AddField Overload
Sitecore.Data.Templates Namespace


SetIcon Method

[image]

Sitecore 6.4.1 API
TemplateSection..::..Builder..::..SetIcon Method
TemplateSection..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetIcon(
    string icon
)
Visual Basic
Public Sub SetIcon ( _
    icon As String _
)
Visual C++
public:
void SetIcon(
    String^ icon
)

Parameters

icon
Type: System..::..String
Icon.

See Also

TemplateSection..::..Builder Class
Sitecore.Data.Templates Namespace


SetSortorder Method

[image]

Sitecore 6.4.1 API
TemplateSection..::..Builder..::..SetSortorder Method
TemplateSection..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetSortorder(
    int value
)
Visual Basic
Public Sub SetSortorder ( _
    value As Integer _
)
Visual C++
public:
void SetSortorder(
    int value
)

Parameters

value
Type: System..::..Int32
Value.

See Also

TemplateSection..::..Builder Class
Sitecore.Data.Templates Namespace


TemplateSection.Builder Properties

[image] [image]

Sitecore 6.4.1 API
TemplateSection..::..Builder Properties
TemplateSection..::..Builder Class See Also Send Feedback

The TemplateSection..::..Builder type exposes the following members.

Properties

 | Name | Description
Public property | Section | Gets the section.

See Also

TemplateSection..::..Builder Class
Sitecore.Data.Templates Namespace


Section Property

[image]

Sitecore 6.4.1 API
TemplateSection..::..Builder..::..Section Property
TemplateSection..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateSection Section { get; }
Visual Basic
Public ReadOnly Property Section As TemplateSection
    Get
Visual C++
public:
property TemplateSection^ Section {
    TemplateSection^ get ();
}

Field Value

The section.

See Also

TemplateSection..::..Builder Class
Sitecore.Data.Templates Namespace


TemplateUpdateContext Class

[image]

Sitecore 6.4.1 API
TemplateUpdateContext Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("No longer needed", false)]
public class TemplateUpdateContext : IDisposable
Visual Basic
<ObsoleteAttribute("No longer needed", False)> _
Public Class TemplateUpdateContext _
    Implements IDisposable
Visual C++
[ObsoleteAttribute(L"No longer needed", false)]
public ref class TemplateUpdateContext : IDisposable

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Templates..::..TemplateUpdateContext

See Also

TemplateUpdateContext Members
Sitecore.Data.Templates Namespace


TemplateUpdateContext Members

[image] [image]

Sitecore 6.4.1 API
TemplateUpdateContext Members
TemplateUpdateContext Class Constructors Methods See Also Send Feedback

The TemplateUpdateContext type exposes the following members.

Constructors

 | Name | Description
Public method | TemplateUpdateContext | Initializes a new instance of the TemplateUpdateContext class.

Methods

 | Name | Description
Public method | Dispose | Disposes this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TemplateUpdateContext Class
Sitecore.Data.Templates Namespace


TemplateUpdateContext Constructor

[image]

Sitecore 6.4.1 API
TemplateUpdateContext Constructor
TemplateUpdateContext Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateUpdateContext(
    DataManager manager
)
Visual Basic
Public Sub New ( _
    manager As DataManager _
)
Visual C++
public:
TemplateUpdateContext(
    DataManager^ manager
)

Parameters

manager
Type: Sitecore.Data..::..DataManager
The manager.

See Also

TemplateUpdateContext Class
Sitecore.Data.Templates Namespace


TemplateUpdateContext Methods

[image] [image]

Sitecore 6.4.1 API
TemplateUpdateContext Methods
TemplateUpdateContext Class See Also Send Feedback

The TemplateUpdateContext type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Disposes this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TemplateUpdateContext Class
Sitecore.Data.Templates Namespace


Dispose Method

[image]

Sitecore 6.4.1 API
TemplateUpdateContext..::..Dispose Method
TemplateUpdateContext Class See Also Send Feedback

Namespace: Sitecore.Data.Templates
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

Remarks

The item leaves editing mode.

See Also

TemplateUpdateContext Class
Sitecore.Data.Templates Namespace


Sitecore.Data.Treeviews Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Data.Treeviews Namespace
Send Feedback

Classes

 | Class | Description
Public class | RenderingTreeviewSource | Represents a TreeviewSource.
Public class | TreeviewSource | Represents a TreeviewSource.


RenderingTreeviewSource Class

[image]

Sitecore 6.4.1 API
RenderingTreeviewSource Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Treeviews
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RenderingTreeviewSource : TreeviewSource
Visual Basic
Public Class RenderingTreeviewSource _
    Inherits TreeviewSource
Visual C++
public ref class RenderingTreeviewSource : public TreeviewSource

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Treeviews..::..TreeviewSource
Sitecore.Data.Treeviews..::..RenderingTreeviewSource

See Also

RenderingTreeviewSource Members
Sitecore.Data.Treeviews Namespace


RenderingTreeviewSource Members

[image] [image]

Sitecore 6.4.1 API
RenderingTreeviewSource Members
RenderingTreeviewSource Class Constructors Methods Properties See Also Send Feedback

The RenderingTreeviewSource type exposes the following members.

Constructors

 | Name | Description
Public method | RenderingTreeviewSource | Initializes a new instance of the RenderingTreeviewSource class

Methods

 | Name | Description
Protected method | BuildNode | Builds the node. (Inherited from TreeviewSource.)
Protected method | CanDisplay | Determines whether this instance can display the specified item. (Overrides TreeviewSource..::..CanDisplay(Item).)
Protected method | CanSelect | Determines whether this instance can select the specified item. (Overrides TreeviewSource..::..CanSelect(Item).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChildren | Gets the children. (Inherited from TreeviewSource.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetNodeUrl | Gets the node URL. (Inherited from TreeviewSource.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Render(TreeView, Item) | Renders the specified treeview. (Inherited from TreeviewSource.)
Public method | Render(TreeView, Item, Boolean) | Builds the specified treeview. (Inherited from TreeviewSource.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ExcludeTemplatesForDisplay | Gets or sets the exclude templates for display. (Inherited from TreeviewSource.)
Public property | ExcludeTemplatesForSelection | Gets or sets the exclude templates for selection. (Inherited from TreeviewSource.)
Public property | IncludeTemplatesForDisplay | Gets or sets the include templates for display. (Inherited from TreeviewSource.)
Public property | IncludeTemplatesForSelection | Gets or sets the include templates for selection. (Inherited from TreeviewSource.)

See Also

RenderingTreeviewSource Class
Sitecore.Data.Treeviews Namespace


RenderingTreeviewSource Constructor

[image]

Sitecore 6.4.1 API
RenderingTreeviewSource Constructor
RenderingTreeviewSource Class See Also Send Feedback

Namespace: Sitecore.Data.Treeviews
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderingTreeviewSource()
Visual Basic
Public Sub New
Visual C++
public:
RenderingTreeviewSource()

See Also

RenderingTreeviewSource Class
Sitecore.Data.Treeviews Namespace


RenderingTreeviewSource Methods

[image] [image]

Sitecore 6.4.1 API
RenderingTreeviewSource Methods
RenderingTreeviewSource Class See Also Send Feedback

The RenderingTreeviewSource type exposes the following members.

Methods

 | Name | Description
Protected method | BuildNode | Builds the node. (Inherited from TreeviewSource.)
Protected method | CanDisplay | Determines whether this instance can display the specified item. (Overrides TreeviewSource..::..CanDisplay(Item).)
Protected method | CanSelect | Determines whether this instance can select the specified item. (Overrides TreeviewSource..::..CanSelect(Item).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChildren | Gets the children. (Inherited from TreeviewSource.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetNodeUrl | Gets the node URL. (Inherited from TreeviewSource.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Render(TreeView, Item) | Renders the specified treeview. (Inherited from TreeviewSource.)
Public method | Render(TreeView, Item, Boolean) | Builds the specified treeview. (Inherited from TreeviewSource.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenderingTreeviewSource Class
Sitecore.Data.Treeviews Namespace


CanDisplay Method

[image]

Sitecore 6.4.1 API
RenderingTreeviewSource..::..CanDisplay Method
RenderingTreeviewSource Class See Also Send Feedback

Namespace: Sitecore.Data.Treeviews
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override bool CanDisplay(
    Item item
)
Visual Basic
Protected Overrides Function CanDisplay ( _
    item As Item _
) As Boolean
Visual C++
protected:
virtual bool CanDisplay(
    Item^ item
) override

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

true if this instance can display the specified item; otherwise, false.

See Also

RenderingTreeviewSource Class
Sitecore.Data.Treeviews Namespace


CanSelect Method

[image]

Sitecore 6.4.1 API
RenderingTreeviewSource..::..CanSelect Method
RenderingTreeviewSource Class See Also Send Feedback

Namespace: Sitecore.Data.Treeviews
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override bool CanSelect(
    Item item
)
Visual Basic
Protected Overrides Function CanSelect ( _
    item As Item _
) As Boolean
Visual C++
protected:
virtual bool CanSelect(
    Item^ item
) override

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

true if this instance can select the specified item; otherwise, false.

See Also

RenderingTreeviewSource Class
Sitecore.Data.Treeviews Namespace


Render Method

[image] [image]

Sitecore 6.4.1 API
RenderingTreeviewSource..::..Render Method
RenderingTreeviewSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Render(TreeView, Item) | Renders the specified treeview. (Inherited from TreeviewSource.)
Public method | Render(TreeView, Item, Boolean) | Builds the specified treeview. (Inherited from TreeviewSource.)

See Also

RenderingTreeviewSource Class
RenderingTreeviewSource Members
Sitecore.Data.Treeviews Namespace


RenderingTreeviewSource Properties

[image] [image]

Sitecore 6.4.1 API
RenderingTreeviewSource Properties
RenderingTreeviewSource Class See Also Send Feedback

The RenderingTreeviewSource type exposes the following members.

Properties

 | Name | Description
Public property | ExcludeTemplatesForDisplay | Gets or sets the exclude templates for display. (Inherited from TreeviewSource.)
Public property | ExcludeTemplatesForSelection | Gets or sets the exclude templates for selection. (Inherited from TreeviewSource.)
Public property | IncludeTemplatesForDisplay | Gets or sets the include templates for display. (Inherited from TreeviewSource.)
Public property | IncludeTemplatesForSelection | Gets or sets the include templates for selection. (Inherited from TreeviewSource.)

See Also

RenderingTreeviewSource Class
Sitecore.Data.Treeviews Namespace


TreeviewSource Members

[image] [image]

Sitecore 6.4.1 API
TreeviewSource Members
TreeviewSource Class Constructors Methods Properties See Also Send Feedback

The TreeviewSource type exposes the following members.

Constructors

 | Name | Description
Public method | TreeviewSource | Initializes a new instance of the TreeviewSource class

Methods

 | Name | Description
Protected method | BuildNode | Builds the node.
Protected method | CanDisplay | Determines whether this instance can display the specified item.
Protected method | CanSelect | Determines whether this instance can select the specified item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChildren | Gets the children.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetNodeUrl | Gets the node URL.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Render(TreeView, Item) | Renders the specified treeview.
Public method | Render(TreeView, Item, Boolean) | Builds the specified treeview.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ExcludeTemplatesForDisplay | Gets or sets the exclude templates for display.
Public property | ExcludeTemplatesForSelection | Gets or sets the exclude templates for selection.
Public property | IncludeTemplatesForDisplay | Gets or sets the include templates for display.
Public property | IncludeTemplatesForSelection | Gets or sets the include templates for selection.

See Also

TreeviewSource Class
Sitecore.Data.Treeviews Namespace


TreeviewSource Methods

[image] [image]

Sitecore 6.4.1 API
TreeviewSource Methods
TreeviewSource Class See Also Send Feedback

The TreeviewSource type exposes the following members.

Methods

 | Name | Description
Protected method | BuildNode | Builds the node.
Protected method | CanDisplay | Determines whether this instance can display the specified item.
Protected method | CanSelect | Determines whether this instance can select the specified item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChildren | Gets the children.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetNodeUrl | Gets the node URL.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Render(TreeView, Item) | Renders the specified treeview.
Public method | Render(TreeView, Item, Boolean) | Builds the specified treeview.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TreeviewSource Class
Sitecore.Data.Treeviews Namespace


BuildNode Method

[image]

Sitecore 6.4.1 API
TreeviewSource..::..BuildNode Method
TreeviewSource Class See Also Send Feedback

Namespace: Sitecore.Data.Treeviews
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void BuildNode(
    TreeViewNode node,
    Item item
)
Visual Basic
Protected Overridable Sub BuildNode ( _
    node As TreeViewNode, _
    item As Item _
)
Visual C++
protected:
virtual void BuildNode(
    TreeViewNode^ node,
    Item^ item
)

Parameters

node
Type: TreeViewNode
The node.
item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

TreeviewSource Class
Sitecore.Data.Treeviews Namespace


CanDisplay Method

[image]

Sitecore 6.4.1 API
TreeviewSource..::..CanDisplay Method
TreeviewSource Class See Also Send Feedback

Namespace: Sitecore.Data.Treeviews
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool CanDisplay(
    Item item
)
Visual Basic
Protected Overridable Function CanDisplay ( _
    item As Item _
) As Boolean
Visual C++
protected:
virtual bool CanDisplay(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

true if this instance can display the specified item; otherwise, false.

See Also

TreeviewSource Class
Sitecore.Data.Treeviews Namespace


CanSelect Method

[image]

Sitecore 6.4.1 API
TreeviewSource..::..CanSelect Method
TreeviewSource Class See Also Send Feedback

Namespace: Sitecore.Data.Treeviews
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool CanSelect(
    Item item
)
Visual Basic
Protected Overridable Function CanSelect ( _
    item As Item _
) As Boolean
Visual C++
protected:
virtual bool CanSelect(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

true if this instance can select the specified item; otherwise, false.

See Also

TreeviewSource Class
Sitecore.Data.Treeviews Namespace


GetChildren Method

[image]

Sitecore 6.4.1 API
TreeviewSource..::..GetChildren Method
TreeviewSource Class See Also Send Feedback

Namespace: Sitecore.Data.Treeviews
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual ChildList GetChildren(
    Item item
)
Visual Basic
Protected Overridable Function GetChildren ( _
    item As Item _
) As ChildList
Visual C++
protected:
virtual ChildList^ GetChildren(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

The children.

See Also

TreeviewSource Class
Sitecore.Data.Treeviews Namespace


Render Method

[image] [image]

Sitecore 6.4.1 API
TreeviewSource..::..Render Method
TreeviewSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Render(TreeView, Item) | Renders the specified treeview.
Public method | Render(TreeView, Item, Boolean) | Builds the specified treeview.

See Also

TreeviewSource Class
TreeviewSource Members
Sitecore.Data.Treeviews Namespace


Render Method (, Item)

[image]

Sitecore 6.4.1 API
TreeviewSource..::..Render Method (, Item)
TreeviewSource Class See Also Send Feedback

Namespace: Sitecore.Data.Treeviews
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Render(
    TreeView treeview,
    Item parent
)
Visual Basic
Public Overridable Sub Render ( _
    treeview As TreeView, _
    parent As Item _
)
Visual C++
public:
virtual void Render(
    TreeView^ treeview,
    Item^ parent
)

Parameters

treeview
Type: TreeView
The treeview.
parent
Type: Sitecore.Data.Items..::..Item
The parent.

See Also

TreeviewSource Class
Render Overload
Sitecore.Data.Treeviews Namespace


Render Method (, Item, Boolean)

[image]

Sitecore 6.4.1 API
TreeviewSource..::..Render Method (, Item, Boolean)
TreeviewSource Class See Also Send Feedback

Namespace: Sitecore.Data.Treeviews
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Render(
    TreeView treeview,
    Item parent,
    bool expandFirstLevel
)
Visual Basic
Public Overridable Sub Render ( _
    treeview As TreeView, _
    parent As Item, _
    expandFirstLevel As Boolean _
)
Visual C++
public:
virtual void Render(
    TreeView^ treeview,
    Item^ parent,
    bool expandFirstLevel
)

Parameters

treeview
Type: TreeView
The treeview.
parent
Type: Sitecore.Data.Items..::..Item
The parent.
expandFirstLevel
Type: System..::..Boolean
if set to true this instance expands the first level.

See Also

TreeviewSource Class
Render Overload
Sitecore.Data.Treeviews Namespace


TreeviewSource Properties

[image] [image]

Sitecore 6.4.1 API
TreeviewSource Properties
TreeviewSource Class See Also Send Feedback

The TreeviewSource type exposes the following members.

Properties

 | Name | Description
Public property | ExcludeTemplatesForDisplay | Gets or sets the exclude templates for display.
Public property | ExcludeTemplatesForSelection | Gets or sets the exclude templates for selection.
Public property | IncludeTemplatesForDisplay | Gets or sets the include templates for display.
Public property | IncludeTemplatesForSelection | Gets or sets the include templates for selection.

See Also

TreeviewSource Class
Sitecore.Data.Treeviews Namespace


ExcludeTemplatesForDisplay Property

[image]

Sitecore 6.4.1 API
TreeviewSource..::..ExcludeTemplatesForDisplay Property
TreeviewSource Class See Also Send Feedback

Namespace: Sitecore.Data.Treeviews
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ExcludeTemplatesForDisplay { get; set; }
Visual Basic
Public Property ExcludeTemplatesForDisplay As String
    Get
    Set
Visual C++
public:
property String^ ExcludeTemplatesForDisplay {
    String^ get ();
    void set (String^ value);
}

Field Value

The exclude templates for display.

See Also

TreeviewSource Class
Sitecore.Data.Treeviews Namespace


IncludeTemplatesForDisplay Property

[image]

Sitecore 6.4.1 API
TreeviewSource..::..IncludeTemplatesForDisplay Property
TreeviewSource Class See Also Send Feedback

Namespace: Sitecore.Data.Treeviews
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string IncludeTemplatesForDisplay { get; set; }
Visual Basic
Public Property IncludeTemplatesForDisplay As String
    Get
    Set
Visual C++
public:
property String^ IncludeTemplatesForDisplay {
    String^ get ();
    void set (String^ value);
}

Field Value

The include templates for display.

See Also

TreeviewSource Class
Sitecore.Data.Treeviews Namespace


IncludeTemplatesForSelection Property

[image]

Sitecore 6.4.1 API
TreeviewSource..::..IncludeTemplatesForSelection Property
TreeviewSource Class See Also Send Feedback

Namespace: Sitecore.Data.Treeviews
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string IncludeTemplatesForSelection { get; set; }
Visual Basic
Public Property IncludeTemplatesForSelection As String
    Get
    Set
Visual C++
public:
property String^ IncludeTemplatesForSelection {
    String^ get ();
    void set (String^ value);
}

Field Value

The include templates for selection.

See Also

TreeviewSource Class
Sitecore.Data.Treeviews Namespace


Sitecore.Data.Validators Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Data.Validators Namespace
Send Feedback

Classes

 | Class | Description
Public class | BaseValidator | Represents a base validator.
Public class | StandardValidator | Represents a Standard Validator.
Public class | ValidatorBarFormatter | Represents a ValidatorsFormatter.
Public class | ValidatorCollection | Represents a ValidatorCollection.
Public class | ValidatorManager | Represents a ValidationManager.
Public class | ValidatorOptions |
Public class | ValidatorPanelFormatter | Represents a ValidatorsFormatter.
Public class | ValidatorsQueue | Represents a ValidatorsQueue.
Public class | ValidatorWorker | Represents a ValidatorsWorker.

Enumerations

 | Enumeration | Description
Public enumeration | ValidatorEvaluationMode | Determines how the validator is evaluated.
Public enumeration | ValidatorResult | Represents the state of a Validator.
Public enumeration | ValidatorsMode | Specifies


BaseValidator Class

[image]

Sitecore 6.4.1 API
BaseValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public abstract class BaseValidator : ISerializable
Visual Basic
<SerializableAttribute> _
Public MustInherit Class BaseValidator _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class BaseValidator abstract : ISerializable

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator

See Also

BaseValidator Members
Sitecore.Data.Validators Namespace


BaseValidator Members

[image] [image]

Sitecore 6.4.1 API
BaseValidator Members
BaseValidator Class Constructors Methods Properties See Also Send Feedback

The BaseValidator type exposes the following members.

Constructors

 | Name | Description
Public method | BaseValidator()()()() | Initializes a new instance of the BaseValidator class.
Protected method | BaseValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the BaseValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid.
Public method | Expire | Expires this instance.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value.
Protected method | GetField | Gets the field.
Public method | GetFieldDisplayName | Gets the display name of the field.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon.
 | GetIcon(ValidatorResult) | Gets the icon.
Protected method | GetItem | Gets the item.
Protected method | GetMaxValidatorResult | Gets the max validator result.
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate.
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid.
Protected method | IsEvaluationRequired | Determines if evaluation should be performed.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance.
Public method | Validate | Validates this instance.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate.
Public property | ControlValidationValue | Gets the control validation value.
Public property | Errors | Gets the errors.
Public property | EvaluationMode | Gets or sets the evaluation.
Public property | Expiry | Gets or sets the expiry.
Public property | FieldID | Gets or sets the field ID.
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu.
Public property | Icon | Gets or sets the icon.
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating.
Public property | IsValid | Gets a value indicating whether the associated input control passes validation.
Public property | ItemUri | Gets or sets the item URI.
Public property | MarkerID | Gets the marker ID.
Public property | MaxValidatorResult | Gets the max validator result that the validator can return.
Public property | Name | Gets the name.
Public property | Options | Gets the options.
Public property | Parameters | Gets or sets the parameters.
Public property | Result | Gets or sets the state.
Public property | Text | Gets or sets the text.
Public property | ValidatorID | Gets or sets the validator ID.

See Also

BaseValidator Class
Sitecore.Data.Validators Namespace


BaseValidator Constructor

[image] [image]

Sitecore 6.4.1 API
BaseValidator Constructor
BaseValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BaseValidator()()()() | Initializes a new instance of the BaseValidator class.
Protected method | BaseValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the BaseValidator class.

See Also

BaseValidator Class
BaseValidator Members
Sitecore.Data.Validators Namespace


BaseValidator Constructor

[image]

Sitecore 6.4.1 API
BaseValidator Constructor
BaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BaseValidator()
Visual Basic
Public Sub New
Visual C++
public:
BaseValidator()

See Also

BaseValidator Class
BaseValidator Overload
Sitecore.Data.Validators Namespace


BaseValidator Methods

[image] [image]

Sitecore 6.4.1 API
BaseValidator Methods
BaseValidator Class See Also Send Feedback

The BaseValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid.
Public method | Expire | Expires this instance.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value.
Protected method | GetField | Gets the field.
Public method | GetFieldDisplayName | Gets the display name of the field.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon.
 | GetIcon(ValidatorResult) | Gets the icon.
Protected method | GetItem | Gets the item.
Protected method | GetMaxValidatorResult | Gets the max validator result.
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate.
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid.
Protected method | IsEvaluationRequired | Determines if evaluation should be performed.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance.
Public method | Validate | Validates this instance.

See Also

BaseValidator Class
Sitecore.Data.Validators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
BaseValidator..::..Evaluate Method
BaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected abstract ValidatorResult Evaluate()
Visual Basic
Protected MustOverride Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() abstract

Return Value

The result of the evaluation.

See Also

BaseValidator Class
Sitecore.Data.Validators Namespace


GetControlValidationValue Method

[image]

Sitecore 6.4.1 API
BaseValidator..::..GetControlValidationValue Method
BaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string GetControlValidationValue()
Visual Basic
Protected Overridable Function GetControlValidationValue As String
Visual C++
protected:
virtual String^ GetControlValidationValue()

Return Value

The control validation value.

See Also

BaseValidator Class
Sitecore.Data.Validators Namespace


GetField Method

[image]

Sitecore 6.4.1 API
BaseValidator..::..GetField Method
BaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Field GetField()
Visual Basic
Protected Function GetField As Field
Visual C++
protected:
Field^ GetField()

Return Value

The field.

See Also

BaseValidator Class
Sitecore.Data.Validators Namespace


GetFieldDisplayName Method

[image]

Sitecore 6.4.1 API
BaseValidator..::..GetFieldDisplayName Method
BaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetFieldDisplayName()
Visual Basic
Public Function GetFieldDisplayName As String
Visual C++
public:
String^ GetFieldDisplayName()

Return Value

The display name of the field.

See Also

BaseValidator Class
Sitecore.Data.Validators Namespace


GetIcon Method

[image] [image]

Sitecore 6.4.1 API
BaseValidator..::..GetIcon Method
BaseValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetIcon()()()() | Gets the icon.
 | GetIcon(ValidatorResult) | Gets the icon.

See Also

BaseValidator Class
BaseValidator Members
Sitecore.Data.Validators Namespace


GetItem Method

[image]

Sitecore 6.4.1 API
BaseValidator..::..GetItem Method
BaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Item GetItem()
Visual Basic
Protected Function GetItem As Item
Visual C++
protected:
Item^ GetItem()

Return Value

The validated item.

See Also

BaseValidator Class
Sitecore.Data.Validators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
BaseValidator..::..GetMaxValidatorResult Method
BaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected abstract ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected MustOverride Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() abstract

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

BaseValidator Class
Sitecore.Data.Validators Namespace


GetObjectData Method

[image]

Sitecore 6.4.1 API
BaseValidator..::..GetObjectData Method
BaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System.Security..::..SecurityException | The caller does not have the required permission.

See Also

BaseValidator Class
Sitecore.Data.Validators Namespace


HasControlToValidate Method

[image]

Sitecore 6.4.1 API
BaseValidator..::..HasControlToValidate Method
BaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool HasControlToValidate()
Visual Basic
Protected Overridable Function HasControlToValidate As Boolean
Visual C++
protected:
virtual bool HasControlToValidate()

Return Value

true if this instance has a control to validate; otherwise, false.

See Also

BaseValidator Class
Sitecore.Data.Validators Namespace


IsControlValidationValueValid Method

[image]

Sitecore 6.4.1 API
BaseValidator..::..IsControlValidationValueValid Method
BaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool IsControlValidationValueValid()
Visual Basic
Protected Overridable Function IsControlValidationValueValid As Boolean
Visual C++
protected:
virtual bool IsControlValidationValueValid()

Return Value

true if the control validation value is valid; otherwise, false.

See Also

BaseValidator Class
Sitecore.Data.Validators Namespace


IsEvaluationRequired Method

[image]

Sitecore 6.4.1 API
BaseValidator..::..IsEvaluationRequired Method
BaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool IsEvaluationRequired()
Visual Basic
Protected Overridable Function IsEvaluationRequired As Boolean
Visual C++
protected:
virtual bool IsEvaluationRequired()

Return Value

The evaluation.

See Also

BaseValidator Class
Sitecore.Data.Validators Namespace


Update Method

[image]

Sitecore 6.4.1 API
BaseValidator..::..Update Method
BaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Update()
Visual Basic
Public Sub Update
Visual C++
public:
void Update()

See Also

BaseValidator Class
Sitecore.Data.Validators Namespace


Validate Method

[image]

Sitecore 6.4.1 API
BaseValidator..::..Validate Method
BaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Validate(
    ValidatorOptions validatorOptions
)
Visual Basic
Public Sub Validate ( _
    validatorOptions As ValidatorOptions _
)
Visual C++
public:
void Validate(
    ValidatorOptions^ validatorOptions
)

Parameters

validatorOptions
Type: Sitecore.Data.Validators..::..ValidatorOptions
The validatorOptions.

See Also

BaseValidator Class
Sitecore.Data.Validators Namespace


BaseValidator Properties

[image] [image]

Sitecore 6.4.1 API
BaseValidator Properties
BaseValidator Class See Also Send Feedback

The BaseValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate.
Public property | ControlValidationValue | Gets the control validation value.
Public property | Errors | Gets the errors.
Public property | EvaluationMode | Gets or sets the evaluation.
Public property | Expiry | Gets or sets the expiry.
Public property | FieldID | Gets or sets the field ID.
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu.
Public property | Icon | Gets or sets the icon.
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating.
Public property | IsValid | Gets a value indicating whether the associated input control passes validation.
Public property | ItemUri | Gets or sets the item URI.
Public property | MarkerID | Gets the marker ID.
Public property | MaxValidatorResult | Gets the max validator result that the validator can return.
Public property | Name | Gets the name.
Public property | Options | Gets the options.
Public property | Parameters | Gets or sets the parameters.
Public property | Result | Gets or sets the state.
Public property | Text | Gets or sets the text.
Public property | ValidatorID | Gets or sets the validator ID.

See Also

BaseValidator Class
Sitecore.Data.Validators Namespace


ControlToValidate Property

[image]

Sitecore 6.4.1 API
BaseValidator..::..ControlToValidate Property
BaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ControlToValidate { get; set; }
Visual Basic
Public Property ControlToValidate As String
    Get
    Set
Visual C++
public:
property String^ ControlToValidate {
    String^ get ();
    void set (String^ value);
}

Field Value

The input control to validate. The default value is String.Empty, which indicates that this property is not set.

See Also

BaseValidator Class
Sitecore.Data.Validators Namespace


ControlValidationValue Property

[image]

Sitecore 6.4.1 API
BaseValidator..::..ControlValidationValue Property
BaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ControlValidationValue { get; }
Visual Basic
Public ReadOnly Property ControlValidationValue As String
    Get
Visual C++
public:
property String^ ControlValidationValue {
    String^ get ();
}

Field Value

The control validation value.

See Also

BaseValidator Class
Sitecore.Data.Validators Namespace


Errors Property

[image]

Sitecore 6.4.1 API
BaseValidator..::..Errors Property
BaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public List<string> Errors { get; }
Visual Basic
Public ReadOnly Property Errors As List(Of String)
    Get
Visual C++
public:
property List<String^>^ Errors {
    List<String^>^ get ();
}

Field Value

The errors.

See Also

BaseValidator Class
Sitecore.Data.Validators Namespace


EvaluationMode Property

[image]

Sitecore 6.4.1 API
BaseValidator..::..EvaluationMode Property
BaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ValidatorEvaluationMode EvaluationMode { get; set; }
Visual Basic
Public Property EvaluationMode As ValidatorEvaluationMode
    Get
    Set
Visual C++
public:
property ValidatorEvaluationMode EvaluationMode {
    ValidatorEvaluationMode get ();
    void set (ValidatorEvaluationMode value);
}

Field Value

The evaluation.

See Also

BaseValidator Class
Sitecore.Data.Validators Namespace


Expiry Property

[image]

Sitecore 6.4.1 API
BaseValidator..::..Expiry Property
BaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime Expiry { get; set; }
Visual Basic
Public Property Expiry As DateTime
    Get
    Set
Visual C++
public:
property DateTime Expiry {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The expiry.

See Also

BaseValidator Class
Sitecore.Data.Validators Namespace


HasMenu Property

[image]

Sitecore 6.4.1 API
BaseValidator..::..HasMenu Property
BaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool HasMenu { get; set; }
Visual Basic
Public Property HasMenu As Boolean
    Get
    Set
Visual C++
public:
property bool HasMenu {
    bool get ();
    void set (bool value);
}

Field Value

true if this instance has menu; otherwise, false.

See Also

BaseValidator Class
Sitecore.Data.Validators Namespace


Icon Property

[image]

Sitecore 6.4.1 API
BaseValidator..::..Icon Property
BaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Icon { get; set; }
Visual Basic
Public Property Icon As String
    Get
    Set
Visual C++
public:
property String^ Icon {
    String^ get ();
    void set (String^ value);
}

Field Value

The validator icon.

See Also

BaseValidator Class
Sitecore.Data.Validators Namespace


IsEvaluating Property

[image]

Sitecore 6.4.1 API
BaseValidator..::..IsEvaluating Property
BaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsEvaluating { get; set; }
Visual Basic
Public Property IsEvaluating As Boolean
    Get
    Set
Visual C++
public:
property bool IsEvaluating {
    bool get ();
    void set (bool value);
}

Field Value

true if this instance is evaluating; otherwise, false.

See Also

BaseValidator Class
Sitecore.Data.Validators Namespace


IsValid Property

[image]

Sitecore 6.4.1 API
BaseValidator..::..IsValid Property
BaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsValid { get; }
Visual Basic
Public ReadOnly Property IsValid As Boolean
    Get
Visual C++
public:
property bool IsValid {
    bool get ();
}

Field Value

true if the associated input control passes validation; otherwise, false. The default value is true.

See Also

BaseValidator Class
Sitecore.Data.Validators Namespace


ItemUri Property

[image]

Sitecore 6.4.1 API
BaseValidator..::..ItemUri Property
BaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemUri ItemUri { get; set; }
Visual Basic
Public Property ItemUri As ItemUri
    Get
    Set
Visual C++
public:
property ItemUri^ ItemUri {
    ItemUri^ get ();
    void set (ItemUri^ value);
}

Field Value

The item URI.

See Also

BaseValidator Class
Sitecore.Data.Validators Namespace


MarkerID Property

[image]

Sitecore 6.4.1 API
BaseValidator..::..MarkerID Property
BaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string MarkerID { get; }
Visual Basic
Public ReadOnly Property MarkerID As String
    Get
Visual C++
public:
property String^ MarkerID {
    String^ get ();
}

Field Value

The marker ID.

See Also

BaseValidator Class
Sitecore.Data.Validators Namespace


MaxValidatorResult Property

[image]

Sitecore 6.4.1 API
BaseValidator..::..MaxValidatorResult Property
BaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ValidatorResult MaxValidatorResult { get; }
Visual Basic
Public ReadOnly Property MaxValidatorResult As ValidatorResult
    Get
Visual C++
public:
property ValidatorResult MaxValidatorResult {
    ValidatorResult get ();
}

Field Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

BaseValidator Class
Sitecore.Data.Validators Namespace


Name Property

[image]

Sitecore 6.4.1 API
BaseValidator..::..Name Property
BaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract string Name { get; }
Visual Basic
Public MustOverride ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () abstract;
}

Field Value

The validator name.

See Also

BaseValidator Class
Sitecore.Data.Validators Namespace


Options Property

[image]

Sitecore 6.4.1 API
BaseValidator..::..Options Property
BaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ValidatorOptions Options { get; }
Visual Basic
Public ReadOnly Property Options As ValidatorOptions
    Get
Visual C++
public:
property ValidatorOptions^ Options {
    ValidatorOptions^ get ();
}

Field Value

The options.

See Also

BaseValidator Class
Sitecore.Data.Validators Namespace


Parameters Property

[image]

Sitecore 6.4.1 API
BaseValidator..::..Parameters Property
BaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SafeDictionary<string> Parameters { get; set; }
Visual Basic
Public Property Parameters As SafeDictionary(Of String)
    Get
    Set
Visual C++
public:
property SafeDictionary<String^>^ Parameters {
    SafeDictionary<String^>^ get ();
    void set (SafeDictionary<String^>^ value);
}

Field Value

The parameters.

See Also

BaseValidator Class
Sitecore.Data.Validators Namespace


Result Property

[image]

Sitecore 6.4.1 API
BaseValidator..::..Result Property
BaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ValidatorResult Result { get; set; }
Visual Basic
Public Property Result As ValidatorResult
    Get
    Set
Visual C++
public:
property ValidatorResult Result {
    ValidatorResult get ();
    void set (ValidatorResult value);
}

Field Value

The state.

See Also

BaseValidator Class
Sitecore.Data.Validators Namespace


Text Property

[image]

Sitecore 6.4.1 API
BaseValidator..::..Text Property
BaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Field Value

The text to show.

See Also

BaseValidator Class
Sitecore.Data.Validators Namespace


ValidatorID Property

[image]

Sitecore 6.4.1 API
BaseValidator..::..ValidatorID Property
BaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ValidatorID { get; set; }
Visual Basic
Public Property ValidatorID As ID
    Get
    Set
Visual C++
public:
property ID^ ValidatorID {
    ID^ get ();
    void set (ID^ value);
}

Field Value

The validator ID.

See Also

BaseValidator Class
Sitecore.Data.Validators Namespace


StandardValidator Class

[image]

Sitecore 6.4.1 API
StandardValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class StandardValidator : BaseValidator
Visual Basic
Public MustInherit Class StandardValidator _
    Inherits BaseValidator
Visual C++
public ref class StandardValidator abstract : public BaseValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.FieldValidators..::..BrokenLinksValidator
Sitecore.Data.Validators.FieldValidators..::..ContainsCharactersValidator
Sitecore.Data.Validators.FieldValidators..::..DatabaseNameValidator
Sitecore.Data.Validators.FieldValidators..::..DateTimeRangeValidator
Sitecore.Data.Validators.FieldValidators..::..ExternLinkTargetValidator
Sitecore.Data.Validators.FieldValidators..::..FileValidator
Sitecore.Data.Validators.FieldValidators..::..ImageAltFieldValidator
Sitecore.Data.Validators.FieldValidators..::..ImageAltFromMediaLibraryFieldValidator
Sitecore.Data.Validators.FieldValidators..::..ImageSizeValidator
Sitecore.Data.Validators.FieldValidators..::..IntegerFieldValidator
Sitecore.Data.Validators.FieldValidators..::..IntegerRangeValidator
Sitecore.Data.Validators.FieldValidators..::..LowerCaseValidator
Sitecore.Data.Validators.FieldValidators..::..MaxLengthFieldValidator
Sitecore.Data.Validators.FieldValidators..::..MinLengthFieldValidator
Sitecore.Data.Validators.FieldValidators..::..NoSpacesValidator
Sitecore.Data.Validators.FieldValidators..::..NoTagsValidator
Sitecore.Data.Validators.FieldValidators..::..ParametersValidator
Sitecore.Data.Validators.FieldValidators..::..RegexValidator
Sitecore.Data.Validators.FieldValidators..::..RequiredFieldValidator
Sitecore.Data.Validators.FieldValidators..::..ResetToStandardValueValidator
Sitecore.Data.Validators.FieldValidators..::..RichTextImageSizeValidator
Sitecore.Data.Validators.FieldValidators..::..ScriptCodeValidator
Sitecore.Data.Validators.FieldValidators..::..SitecoreCommandValidator
Sitecore.Data.Validators.FieldValidators..::..SpellcheckValidator
Sitecore.Data.Validators.FieldValidators..::..StartWithCapitalEndWithDotValidator
Sitecore.Data.Validators.FieldValidators..::..StringEnumValidator
Sitecore.Data.Validators.FieldValidators..::..TypeAndAssemblyValidator
Sitecore.Data.Validators.FieldValidators..::..UpperCaseValidator
Sitecore.Data.Validators.FieldValidators..::..W3CXhtmlValidator
Sitecore.Data.Validators.FieldValidators..::..XhtmlValidator
Sitecore.Data.Validators.FieldValidators..::..XmlValidator
Sitecore.Data.Validators.ItemValidators..::..BrokenLinkValidator
Sitecore.Data.Validators.ItemValidators..::..DateRangeValidator
Sitecore.Data.Validators.ItemValidators..::..DuplicateNameValidator
Sitecore.Data.Validators.ItemValidators..::..DuplicateSortOrderValidator
Sitecore.Data.Validators.ItemValidators..::..FullPageXHtmlValidator
Sitecore.Data.Validators.ItemValidators..::..ItemHasSubItemsButNoInsertOptionsValidator
Sitecore.Data.Validators.ItemValidators..::..ItemHasSubItemsThatAreNotInInsertOptionsValidator
Sitecore.Data.Validators.ItemValidators..::..ItemIsNotReferencedValidator
Sitecore.Data.Validators.ItemValidators..::..LockedByNonExistingUserValidator
Sitecore.Data.Validators.ItemValidators..::..MediaSizeValidator
Sitecore.Data.Validators.ItemValidators..::..Notifications
Sitecore.Data.Validators.ItemValidators..::..NotSerializedValidator
Sitecore.Data.Validators.ItemValidators..::..OwnedByNonExistingUserValidator
Sitecore.Data.Validators.ItemValidators..::..RadioCheckBoxValidator
Sitecore.Data.Validators.ItemValidators..::..RuleValidator
Sitecore.Data.Validators.ItemValidators..::..StandardValueHasNameMacroValidator
Sitecore.Data.Validators.ItemValidators..::..UrlCharacterValidator
Sitecore.Data.Validators.ItemValidators..::..ValidationRulesValidator
Sitecore.Data.Validators.ItemValidators..::..WorkflowFinalStateValidator

See Also

StandardValidator Members
Sitecore.Data.Validators Namespace


StandardValidator Members

[image] [image]

Sitecore 6.4.1 API
StandardValidator Members
StandardValidator Class Constructors Methods Properties See Also Send Feedback

The StandardValidator type exposes the following members.

Constructors

 | Name | Description
Protected method | StandardValidator()()()() | Initializes a new instance of the StandardValidator class.
Protected method | StandardValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the StandardValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Inherited from BaseValidator.)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result.
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Inherited from BaseValidator.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Inherited from BaseValidator.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

StandardValidator Class
Sitecore.Data.Validators Namespace


StandardValidator Constructor

[image] [image]

Sitecore 6.4.1 API
StandardValidator Constructor
StandardValidator Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | StandardValidator()()()() | Initializes a new instance of the StandardValidator class.
Protected method | StandardValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the StandardValidator class.

See Also

StandardValidator Class
StandardValidator Members
Sitecore.Data.Validators Namespace


StandardValidator Constructor

[image]

Sitecore 6.4.1 API
StandardValidator Constructor
StandardValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected StandardValidator()
Visual Basic
Protected Sub New
Visual C++
protected:
StandardValidator()

See Also

StandardValidator Class
StandardValidator Overload
Sitecore.Data.Validators Namespace


StandardValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
StandardValidator Constructor (SerializationInfo, StreamingContext)
StandardValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected StandardValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
StandardValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The Serialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

StandardValidator Class
StandardValidator Overload
Sitecore.Data.Validators Namespace


StandardValidator Methods

[image] [image]

Sitecore 6.4.1 API
StandardValidator Methods
StandardValidator Class See Also Send Feedback

The StandardValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Inherited from BaseValidator.)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result.
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Inherited from BaseValidator.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

StandardValidator Class
Sitecore.Data.Validators Namespace


GetFailedResult Method

[image]

Sitecore 6.4.1 API
StandardValidator..::..GetFailedResult Method
StandardValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected ValidatorResult GetFailedResult(
    ValidatorResult defaultResult
)
Visual Basic
Protected Function GetFailedResult ( _
    defaultResult As ValidatorResult _
) As ValidatorResult
Visual C++
protected:
ValidatorResult GetFailedResult(
    ValidatorResult defaultResult
)

Parameters

defaultResult
Type: Sitecore.Data.Validators..::..ValidatorResult
The default result.

Return Value

The result.

Exceptions

Exception | Condition
System..::..ArgumentNullException |
System..::..ArgumentException |

See Also

StandardValidator Class
Sitecore.Data.Validators Namespace


GetText Method

[image]

Sitecore 6.4.1 API
StandardValidator..::..GetText Method
StandardValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected string GetText(
    string text,
    params string[] arguments
)
Visual Basic
Protected Function GetText ( _
    text As String, _
    ParamArray arguments As String() _
) As String
Visual C++
protected:
String^ GetText(
    String^ text,
    ... array<String^>^ arguments
)

Parameters

text
Type: System..::..String
The text to use if nor Parameters nither item contains text to display.
arguments
Type: array< System..::..String >[]()[][]
The arguments.

Return Value

The formatted text.

Exceptions

Exception | Condition
System..::..ArgumentNullException |
System..::..FormatException |

See Also

StandardValidator Class
Sitecore.Data.Validators Namespace


StandardValidator Properties

[image] [image]

Sitecore 6.4.1 API
StandardValidator Properties
StandardValidator Class See Also Send Feedback

The StandardValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Inherited from BaseValidator.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

StandardValidator Class
Sitecore.Data.Validators Namespace


ValidatorBarFormatter Class

[image]

Sitecore 6.4.1 API
ValidatorBarFormatter Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class ValidatorBarFormatter
Visual Basic
Public NotInheritable Class ValidatorBarFormatter
Visual C++
public ref class ValidatorBarFormatter abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..ValidatorBarFormatter

See Also

ValidatorBarFormatter Members
Sitecore.Data.Validators Namespace


ValidatorBarFormatter Members

[image] [image]

Sitecore 6.4.1 API
ValidatorBarFormatter Members
ValidatorBarFormatter Class Methods See Also Send Feedback

The ValidatorBarFormatter type exposes the following members.

Methods

Name | Description
RenderValidationResult | Renders the validation result.

See Also

ValidatorBarFormatter Class
Sitecore.Data.Validators Namespace


ValidatorBarFormatter Methods

[image] [image]

Sitecore 6.4.1 API
ValidatorBarFormatter Methods
ValidatorBarFormatter Class See Also Send Feedback

The ValidatorBarFormatter type exposes the following members.

Methods

Name | Description
RenderValidationResult | Renders the validation result.

See Also

ValidatorBarFormatter Class
Sitecore.Data.Validators Namespace


RenderValidationResult Method

[image]

Sitecore 6.4.1 API
ValidatorBarFormatter..::..RenderValidationResult Method
ValidatorBarFormatter Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string RenderValidationResult(
    ValidatorCollection validators
)
Visual Basic
Public Shared Function RenderValidationResult ( _
    validators As ValidatorCollection _
) As String
Visual C++
public:
static String^ RenderValidationResult(
    ValidatorCollection^ validators
)

Parameters

validators
Type: Sitecore.Data.Validators..::..ValidatorCollection
The validators.

Return Value

The validation result.

See Also

ValidatorBarFormatter Class
Sitecore.Data.Validators Namespace


ValidatorCollection Class

[image]

Sitecore 6.4.1 API
ValidatorCollection Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class ValidatorCollection : ISerializable,
    IList<BaseValidator>, ICollection<BaseValidator>, IEnumerable<BaseValidator>,
    IEnumerable
Visual Basic
<SerializableAttribute> _
Public Class ValidatorCollection _
    Implements ISerializable, IList(Of BaseValidator),  _
    ICollection(Of BaseValidator), IEnumerable(Of BaseValidator), IEnumerable
Visual C++
[SerializableAttribute]
public ref class ValidatorCollection : ISerializable,
    IList<BaseValidator^>, ICollection<BaseValidator^>, IEnumerable<BaseValidator^>,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..ValidatorCollection

See Also

ValidatorCollection Members
Sitecore.Data.Validators Namespace


ValidatorCollection Members

[image] [image]

Sitecore 6.4.1 API
ValidatorCollection Members
ValidatorCollection Class Constructors Methods Properties See Also Send Feedback

The ValidatorCollection type exposes the following members.

Constructors

 | Name | Description
Public method | ValidatorCollection()()()() | Initializes a new instance of the ValidatorCollection class.
Protected method | ValidatorCollection(SerializationInfo, StreamingContext) | Initializes a new instance of the ValidatorCollection class.

Methods

 | Name | Description
Public method | Add | Adds the specified validator.
Public method | Clear | Removes all items from the ICollection<(Of <(<'T>)>)>.
Public method | Contains | Determines whether the ICollection<(Of <(<'T>)>)> contains a specific value.
Public method | CopyTo | Copies the elements of the ICollection<(Of <(<'T>)>)> to an Array, starting at a particular Array index.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByMarkerID | Gets the validator by marker ID.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IList<(Of <(<'T>)>)>.
Public method | Insert | Inserts an item to the IList<(Of <(<'T>)>)> at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(<'T>)>)>.
Public method | RemoveAt | Removes the IList<(Of <(<'T>)>)> item at the specified index.
Public method | Sort | Sorts this instance.
Public method | Suppress | Suppresses the specified suppressed validators.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | Convert<(Of <<'(BaseValidator, TTo>)>>) | Converts this instance. (Defined by EnumerableExtensions.)
Public Extension Method | StringConcatenate<(Of <<'(BaseValidator>)>>) | Concatenate strings (Defined by IEnumerableExtensions.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(<'T>)>)>.
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(<'T>)>)> is read-only.
Public property | Item | Gets the BaseValidator at the specified index.
Public property | Key | Gets or sets the key.

See Also

ValidatorCollection Class
Sitecore.Data.Validators Namespace


ValidatorCollection Constructor

[image] [image]

Sitecore 6.4.1 API
ValidatorCollection Constructor
ValidatorCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ValidatorCollection()()()() | Initializes a new instance of the ValidatorCollection class.
Protected method | ValidatorCollection(SerializationInfo, StreamingContext) | Initializes a new instance of the ValidatorCollection class.

See Also

ValidatorCollection Class
ValidatorCollection Members
Sitecore.Data.Validators Namespace


ValidatorCollection Constructor

[image]

Sitecore 6.4.1 API
ValidatorCollection Constructor
ValidatorCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ValidatorCollection()
Visual Basic
Public Sub New
Visual C++
public:
ValidatorCollection()

See Also

ValidatorCollection Class
ValidatorCollection Overload
Sitecore.Data.Validators Namespace


ValidatorCollection Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
ValidatorCollection Constructor (SerializationInfo, StreamingContext)
ValidatorCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected ValidatorCollection(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
ValidatorCollection(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

ValidatorCollection Class
ValidatorCollection Overload
Sitecore.Data.Validators Namespace


ValidatorCollection Methods

[image] [image]

Sitecore 6.4.1 API
ValidatorCollection Methods
ValidatorCollection Class See Also Send Feedback

The ValidatorCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified validator.
Public method | Clear | Removes all items from the ICollection<(Of <(<'T>)>)>.
Public method | Contains | Determines whether the ICollection<(Of <(<'T>)>)> contains a specific value.
Public method | CopyTo | Copies the elements of the ICollection<(Of <(<'T>)>)> to an Array, starting at a particular Array index.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByMarkerID | Gets the validator by marker ID.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IList<(Of <(<'T>)>)>.
Public method | Insert | Inserts an item to the IList<(Of <(<'T>)>)> at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(<'T>)>)>.
Public method | RemoveAt | Removes the IList<(Of <(<'T>)>)> item at the specified index.
Public method | Sort | Sorts this instance.
Public method | Suppress | Suppresses the specified suppressed validators.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | Convert<(Of <<'(BaseValidator, TTo>)>>) | Converts this instance. (Defined by EnumerableExtensions.)
Public Extension Method | StringConcatenate<(Of <<'(BaseValidator>)>>) | Concatenate strings (Defined by IEnumerableExtensions.)

See Also

ValidatorCollection Class
Sitecore.Data.Validators Namespace


Add Method

[image]

Sitecore 6.4.1 API
ValidatorCollection..::..Add Method
ValidatorCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Add(
    BaseValidator validator
)
Visual Basic
Public Sub Add ( _
    validator As BaseValidator _
)
Visual C++
public:
virtual void Add(
    BaseValidator^ validator
) sealed

Parameters

validator
Type: Sitecore.Data.Validators..::..BaseValidator
The validator.

Implements

ICollection<(Of <(<'T>)>)>..::..Add(T)

See Also

ValidatorCollection Class
Sitecore.Data.Validators Namespace


GetByMarkerID Method

[image]

Sitecore 6.4.1 API
ValidatorCollection..::..GetByMarkerID Method
ValidatorCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BaseValidator GetByMarkerID(
    string markerID
)
Visual Basic
Public Function GetByMarkerID ( _
    markerID As String _
) As BaseValidator
Visual C++
public:
BaseValidator^ GetByMarkerID(
    String^ markerID
)

Parameters

markerID
Type: System..::..String
The marker ID.

Return Value

The validator.

See Also

ValidatorCollection Class
Sitecore.Data.Validators Namespace


GetEnumerator Method

[image]

Sitecore 6.4.1 API
ValidatorCollection..::..GetEnumerator Method
ValidatorCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator() sealed

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

ValidatorCollection Class
Sitecore.Data.Validators Namespace


IndexOf Method

[image]

Sitecore 6.4.1 API
ValidatorCollection..::..IndexOf Method
ValidatorCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int IndexOf(
    BaseValidator item
)
Visual Basic
Public Function IndexOf ( _
    item As BaseValidator _
) As Integer
Visual C++
public:
virtual int IndexOf(
    BaseValidator^ item
) sealed

Parameters

item
Type: Sitecore.Data.Validators..::..BaseValidator
The object to locate in the IList<(Of <(<'T>)>)>.

Return Value

The index of item if found in the list; otherwise, -1.

Implements

IList<(Of <(<'T>)>)>..::..IndexOf(T)

See Also

ValidatorCollection Class
Sitecore.Data.Validators Namespace


Insert Method

[image]

Sitecore 6.4.1 API
ValidatorCollection..::..Insert Method
ValidatorCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Insert(
    int index,
    BaseValidator item
)
Visual Basic
Public Sub Insert ( _
    index As Integer, _
    item As BaseValidator _
)
Visual C++
public:
virtual void Insert(
    int index,
    BaseValidator^ item
) sealed

Parameters

index
Type: System..::..Int32
The zero-based index at which item should be inserted.
item
Type: Sitecore.Data.Validators..::..BaseValidator
The object to insert into the IList<(Of <(<'T>)>)>.

Implements

IList<(Of <(<'T>)>)>..::..Insert(Int32, T)

Exceptions

Exception | Condition
System..::..NotSupportedException | The IList<(Of <(<'T>)>)> is read-only.
System..::..ArgumentOutOfRangeException | index is not a valid index in the IList<(Of <(<'T>)>)>.

See Also

ValidatorCollection Class
Sitecore.Data.Validators Namespace


Remove Method

[image]

Sitecore 6.4.1 API
ValidatorCollection..::..Remove Method
ValidatorCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Remove(
    BaseValidator item
)
Visual Basic
Public Function Remove ( _
    item As BaseValidator _
) As Boolean
Visual C++
public:
virtual bool Remove(
    BaseValidator^ item
) sealed

Parameters

item
Type: Sitecore.Data.Validators..::..BaseValidator
The object to remove from the ICollection<(Of <(<'T>)>)>.

Return Value

true if item was successfully removed from the ICollection<(Of <(<'T>)>)>; otherwise, false. This method also returns false if item is not found in the original ICollection<(Of <(<'T>)>)>.

Implements

ICollection<(Of <(<'T>)>)>..::..Remove(T)

Exceptions

Exception | Condition
System..::..NotSupportedException | The ICollection<(Of <(<'T>)>)> is read-only.

See Also

ValidatorCollection Class
Sitecore.Data.Validators Namespace


RemoveAt Method

[image]

Sitecore 6.4.1 API
ValidatorCollection..::..RemoveAt Method
ValidatorCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RemoveAt(
    int index
)
Visual Basic
Public Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
virtual void RemoveAt(
    int index
) sealed

Parameters

index
Type: System..::..Int32
The zero-based index of the item to remove.

Implements

IList<(Of <(<'T>)>)>..::..RemoveAt(Int32)

Exceptions

Exception | Condition
System..::..NotSupportedException | The IList<(Of <(<'T>)>)> is read-only.
System..::..ArgumentOutOfRangeException | index is not a valid index in the IList<(Of <(<'T>)>)>.

See Also

ValidatorCollection Class
Sitecore.Data.Validators Namespace


Sort Method

[image]

Sitecore 6.4.1 API
ValidatorCollection..::..Sort Method
ValidatorCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Sort()
Visual Basic
Public Sub Sort
Visual C++
public:
void Sort()

See Also

ValidatorCollection Class
Sitecore.Data.Validators Namespace


Suppress Method

[image]

Sitecore 6.4.1 API
ValidatorCollection..::..Suppress Method
ValidatorCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Suppress(
    ListString suppressedValidators
)
Visual Basic
Public Sub Suppress ( _
    suppressedValidators As ListString _
)
Visual C++
public:
void Suppress(
    ListString^ suppressedValidators
)

Parameters

suppressedValidators
Type: Sitecore.Text..::..ListString
The suppressed validators.

See Also

ValidatorCollection Class
Sitecore.Data.Validators Namespace


Count Property

[image]

Sitecore 6.4.1 API
ValidatorCollection..::..Count Property
ValidatorCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Return Value

The number of elements contained in the ICollection<(Of <(<'T>)>)>.

Implements

ICollection<(Of <(<'T>)>)>..::..Count

See Also

ValidatorCollection Class
Sitecore.Data.Validators Namespace


IsReadOnly Property

[image]

Sitecore 6.4.1 API
ValidatorCollection..::..IsReadOnly Property
ValidatorCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic
Public ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Return Value

true if the ICollection<(Of <(<'T>)>)> is read-only; otherwise, false.

Implements

ICollection<(Of <(<'T>)>)>..::..IsReadOnly

See Also

ValidatorCollection Class
Sitecore.Data.Validators Namespace


Item Property

[image]

Sitecore 6.4.1 API
ValidatorCollection..::..Item Property
ValidatorCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BaseValidator this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    index As Integer _
) As BaseValidator
    Get
Visual C++
public:
property BaseValidator^ default[int index] {
    BaseValidator^ get (int index);
}

Parameters

index
Type: System..::..Int32

Field Value

The BaseValidator.

See Also

ValidatorCollection Class
Sitecore.Data.Validators Namespace


Key Property

[image]

Sitecore 6.4.1 API
ValidatorCollection..::..Key Property
ValidatorCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Key { get; set; }
Visual Basic
Public Property Key As String
    Get
    Set
Visual C++
public:
property String^ Key {
    String^ get ();
    void set (String^ value);
}

Field Value

The key.

See Also

ValidatorCollection Class
Sitecore.Data.Validators Namespace


ValidatorManager Class

[image]

Sitecore 6.4.1 API
ValidatorManager Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class ValidatorManager
Visual Basic
Public NotInheritable Class ValidatorManager
Visual C++
public ref class ValidatorManager abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..ValidatorManager

See Also

ValidatorManager Members
Sitecore.Data.Validators Namespace


ValidatorManager Members

[image] [image]

Sitecore 6.4.1 API
ValidatorManager Members
ValidatorManager Class Methods See Also Send Feedback

The ValidatorManager type exposes the following members.

Methods

Name | Description
BuildValidator | Gets the validator.
BuildValidators(ValidatorsMode, Item) | Builds the validation set.
BuildValidators(ValidatorsMode, String, Item, SafeDictionary<(Of <<'(String, String>)>>)) | Builds the validation set.
BuildValidators(ValidatorsMode, String, ICollection<(Of <<'(FieldDescriptor>)>>), Database, SafeDictionary<(Of <<'(String, String>)>>)) | Builds the validators.
GetValidators | Gets the validators.
UpdateValidators | Updates the validators.
Validate | Validates the specified result.

See Also

ValidatorManager Class
Sitecore.Data.Validators Namespace


ValidatorManager Methods

[image] [image]

Sitecore 6.4.1 API
ValidatorManager Methods
ValidatorManager Class See Also Send Feedback

The ValidatorManager type exposes the following members.

Methods

Name | Description
BuildValidator | Gets the validator.
BuildValidators(ValidatorsMode, Item) | Builds the validation set.
BuildValidators(ValidatorsMode, String, Item, SafeDictionary<(Of <<'(String, String>)>>)) | Builds the validation set.
BuildValidators(ValidatorsMode, String, ICollection<(Of <<'(FieldDescriptor>)>>), Database, SafeDictionary<(Of <<'(String, String>)>>)) | Builds the validators.
GetValidators | Gets the validators.
UpdateValidators | Updates the validators.
Validate | Validates the specified result.

See Also

ValidatorManager Class
Sitecore.Data.Validators Namespace


BuildValidator Method

[image]

Sitecore 6.4.1 API
ValidatorManager..::..BuildValidator Method
ValidatorManager Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static BaseValidator BuildValidator(
    Item validator,
    Item item
)
Visual Basic
Public Shared Function BuildValidator ( _
    validator As Item, _
    item As Item _
) As BaseValidator
Visual C++
public:
static BaseValidator^ BuildValidator(
    Item^ validator,
    Item^ item
)

Parameters

validator
Type: Sitecore.Data.Items..::..Item
The validator.
item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

The validator.

See Also

ValidatorManager Class
Sitecore.Data.Validators Namespace


BuildValidators Method

[image] [image]

Sitecore 6.4.1 API
ValidatorManager..::..BuildValidators Method
ValidatorManager Class See Also Send Feedback

Overload List

Name | Description
BuildValidators(ValidatorsMode, Item) | Builds the validation set.
BuildValidators(ValidatorsMode, String, Item, SafeDictionary<(Of <<'(String, String>)>>)) | Builds the validation set.
BuildValidators(ValidatorsMode, String, ICollection<(Of <<'(FieldDescriptor>)>>), Database, SafeDictionary<(Of <<'(String, String>)>>)) | Builds the validators.

See Also

ValidatorManager Class
ValidatorManager Members
Sitecore.Data.Validators Namespace


BuildValidators Method (ValidatorsMode, Item)

[image]

Sitecore 6.4.1 API
ValidatorManager..::..BuildValidators Method (ValidatorsMode, Item)
ValidatorManager Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ValidatorCollection BuildValidators(
    ValidatorsMode mode,
    Item item
)
Visual Basic
Public Shared Function BuildValidators ( _
    mode As ValidatorsMode, _
    item As Item _
) As ValidatorCollection
Visual C++
public:
static ValidatorCollection^ BuildValidators(
    ValidatorsMode mode,
    Item^ item
)

Parameters

mode
Type: Sitecore.Data.Validators..::..ValidatorsMode
The mode.
item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

The validators.

See Also

ValidatorManager Class
BuildValidators Overload
Sitecore.Data.Validators Namespace


BuildValidators Method (ValidatorsMode, String, Item, SafeDictionary(String, String))

[image]

Sitecore 6.4.1 API
ValidatorManager..::..BuildValidators Method (ValidatorsMode, String, Item, SafeDictionary<(Of <(<'String, String>)>)>)
ValidatorManager Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ValidatorCollection BuildValidators(
    ValidatorsMode mode,
    string key,
    Item item,
    SafeDictionary<string, string> controls
)
Visual Basic
Public Shared Function BuildValidators ( _
    mode As ValidatorsMode, _
    key As String, _
    item As Item, _
    controls As SafeDictionary(Of String, String) _
) As ValidatorCollection
Visual C++
public:
static ValidatorCollection^ BuildValidators(
    ValidatorsMode mode,
    String^ key,
    Item^ item,
    SafeDictionary<String^, String^>^ controls
)

Parameters

mode
Type: Sitecore.Data.Validators..::..ValidatorsMode
The mode.
key
Type: System..::..String
The key.
item
Type: Sitecore.Data.Items..::..Item
The item.
controls
Type: Sitecore.Collections..::..SafeDictionary <(Of <(<' String, String >)>)>
The controls.

Return Value

The validators.

See Also

ValidatorManager Class
BuildValidators Overload
Sitecore.Data.Validators Namespace


BuildValidators Method (ValidatorsMode, String, ICollection(FieldDescriptor), Database, SafeDictionary(String, String))

[image]

Sitecore 6.4.1 API
ValidatorManager..::..BuildValidators Method (ValidatorsMode, String, ICollection<(Of <(<'FieldDescriptor>)>)>, Database, SafeDictionary<(Of <(<'String, String>)>)>)
ValidatorManager Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ValidatorCollection BuildValidators(
    ValidatorsMode mode,
    string key,
    ICollection<FieldDescriptor> fields,
    Database database,
    SafeDictionary<string, string> controls
)
Visual Basic
Public Shared Function BuildValidators ( _
    mode As ValidatorsMode, _
    key As String, _
    fields As ICollection(Of FieldDescriptor), _
    database As Database, _
    controls As SafeDictionary(Of String, String) _
) As ValidatorCollection
Visual C++
public:
static ValidatorCollection^ BuildValidators(
    ValidatorsMode mode,
    String^ key,
    ICollection<FieldDescriptor^>^ fields,
    Database^ database,
    SafeDictionary<String^, String^>^ controls
)

Parameters

mode
Type: Sitecore.Data.Validators..::..ValidatorsMode
The mode.
key
Type: System..::..String
The key.
fields
Type: System.Collections.Generic..::..ICollection <(Of <(<' FieldDescriptor >)>)>
The fields.
database
Type: Sitecore.Data..::..Database
The database.
controls
Type: Sitecore.Collections..::..SafeDictionary <(Of <(<' String, String >)>)>
The controls.

Return Value

The validators.

See Also

ValidatorManager Class
BuildValidators Overload
Sitecore.Data.Validators Namespace


GetValidators Method

[image]

Sitecore 6.4.1 API
ValidatorManager..::..GetValidators Method
ValidatorManager Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ValidatorCollection GetValidators(
    ValidatorsMode mode,
    string key
)
Visual Basic
Public Shared Function GetValidators ( _
    mode As ValidatorsMode, _
    key As String _
) As ValidatorCollection
Visual C++
public:
static ValidatorCollection^ GetValidators(
    ValidatorsMode mode,
    String^ key
)

Parameters

mode
Type: Sitecore.Data.Validators..::..ValidatorsMode
The mode.
key
Type: System..::..String
The key.

Return Value

The validators.

See Also

ValidatorManager Class
Sitecore.Data.Validators Namespace


Validate Method

[image]

Sitecore 6.4.1 API
ValidatorManager..::..Validate Method
ValidatorManager Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Validate(
    ValidatorCollection validators,
    ValidatorOptions options
)
Visual Basic
Public Shared Sub Validate ( _
    validators As ValidatorCollection, _
    options As ValidatorOptions _
)
Visual C++
public:
static void Validate(
    ValidatorCollection^ validators,
    ValidatorOptions^ options
)

Parameters

validators
Type: Sitecore.Data.Validators..::..ValidatorCollection
The validators.
options
Type: Sitecore.Data.Validators..::..ValidatorOptions
The options.

See Also

ValidatorManager Class
Sitecore.Data.Validators Namespace


ValidatorOptions Class

[image]

Sitecore 6.4.1 API
ValidatorOptions Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class ValidatorOptions : ISerializable
Visual Basic
<SerializableAttribute> _
Public Class ValidatorOptions _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class ValidatorOptions : ISerializable

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..ValidatorOptions

See Also

ValidatorOptions Members
Sitecore.Data.Validators Namespace


ValidatorOptions Members

[image] [image]

Sitecore 6.4.1 API
ValidatorOptions Members
ValidatorOptions Class Constructors Methods Properties See Also Send Feedback

The ValidatorOptions type exposes the following members.

Constructors

 | Name | Description
Public method | ValidatorOptions(Boolean) | Initializes a new instance of the ValidatorOptions class.
Protected method | ValidatorOptions(SerializationInfo, StreamingContext) | Bases the validator.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Blocking | Gets a value indicating whether this ValidatorOptions is blocked.

See Also

ValidatorOptions Class
Sitecore.Data.Validators Namespace


ValidatorOptions Constructor

[image] [image]

Sitecore 6.4.1 API
ValidatorOptions Constructor
ValidatorOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ValidatorOptions(Boolean) | Initializes a new instance of the ValidatorOptions class.
Protected method | ValidatorOptions(SerializationInfo, StreamingContext) | Bases the validator.

See Also

ValidatorOptions Class
ValidatorOptions Members
Sitecore.Data.Validators Namespace


ValidatorOptions Constructor (Boolean)

[image]

Sitecore 6.4.1 API
ValidatorOptions Constructor (Boolean)
ValidatorOptions Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ValidatorOptions(
    bool blocking
)
Visual Basic
Public Sub New ( _
    blocking As Boolean _
)
Visual C++
public:
ValidatorOptions(
    bool blocking
)

Parameters

blocking
Type: System..::..Boolean
if set to true this instance is blocked.

See Also

ValidatorOptions Class
ValidatorOptions Overload
Sitecore.Data.Validators Namespace


ValidatorOptions Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
ValidatorOptions Constructor (SerializationInfo, StreamingContext)
ValidatorOptions Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected ValidatorOptions(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
ValidatorOptions(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

ValidatorOptions Class
ValidatorOptions Overload
Sitecore.Data.Validators Namespace


ValidatorOptions Methods

[image] [image]

Sitecore 6.4.1 API
ValidatorOptions Methods
ValidatorOptions Class See Also Send Feedback

The ValidatorOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ValidatorOptions Class
Sitecore.Data.Validators Namespace


GetObjectData Method

[image]

Sitecore 6.4.1 API
ValidatorOptions..::..GetObjectData Method
ValidatorOptions Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System.Security..::..SecurityException | The caller does not have the required permission.

See Also

ValidatorOptions Class
Sitecore.Data.Validators Namespace


ValidatorOptions Properties

[image] [image]

Sitecore 6.4.1 API
ValidatorOptions Properties
ValidatorOptions Class See Also Send Feedback

The ValidatorOptions type exposes the following members.

Properties

 | Name | Description
Public property | Blocking | Gets a value indicating whether this ValidatorOptions is blocked.

See Also

ValidatorOptions Class
Sitecore.Data.Validators Namespace


Blocking Property

[image]

Sitecore 6.4.1 API
ValidatorOptions..::..Blocking Property
ValidatorOptions Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Blocking { get; }
Visual Basic
Public ReadOnly Property Blocking As Boolean
    Get
Visual C++
public:
property bool Blocking {
    bool get ();
}

Field Value

true if blocked; otherwise, false.

See Also

ValidatorOptions Class
Sitecore.Data.Validators Namespace


ValidatorPanelFormatter Class

[image]

Sitecore 6.4.1 API
ValidatorPanelFormatter Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class ValidatorPanelFormatter
Visual Basic
Public NotInheritable Class ValidatorPanelFormatter
Visual C++
public ref class ValidatorPanelFormatter abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..ValidatorPanelFormatter

See Also

ValidatorPanelFormatter Members
Sitecore.Data.Validators Namespace


ValidatorPanelFormatter Members

[image] [image]

Sitecore 6.4.1 API
ValidatorPanelFormatter Members
ValidatorPanelFormatter Class Methods See Also Send Feedback

The ValidatorPanelFormatter type exposes the following members.

Methods

Name | Description
RenderValidationResult | Renders the validation result.

See Also

ValidatorPanelFormatter Class
Sitecore.Data.Validators Namespace


ValidatorPanelFormatter Methods

[image] [image]

Sitecore 6.4.1 API
ValidatorPanelFormatter Methods
ValidatorPanelFormatter Class See Also Send Feedback

The ValidatorPanelFormatter type exposes the following members.

Methods

Name | Description
RenderValidationResult | Renders the validation result.

See Also

ValidatorPanelFormatter Class
Sitecore.Data.Validators Namespace


RenderValidationResult Method

[image]

Sitecore 6.4.1 API
ValidatorPanelFormatter..::..RenderValidationResult Method
ValidatorPanelFormatter Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string RenderValidationResult(
    ValidatorCollection validators
)
Visual Basic
Public Shared Function RenderValidationResult ( _
    validators As ValidatorCollection _
) As String
Visual C++
public:
static String^ RenderValidationResult(
    ValidatorCollection^ validators
)

Parameters

validators
Type: Sitecore.Data.Validators..::..ValidatorCollection
The validators.

Return Value

The validation result.

See Also

ValidatorPanelFormatter Class
Sitecore.Data.Validators Namespace


ValidatorResult Enumeration

[image]

Sitecore 6.4.1 API
ValidatorResult Enumeration
See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum ValidatorResult
Visual Basic
Public Enumeration ValidatorResult
Visual C++
public enum class ValidatorResult

Members

Member name | Value | Description
Unknown | 0 | The validator has not yet evaluated.
Valid | 1 | The validator has evaluated and is valid.
Suggestion | 2 | The validator resulted in a suggestion.
Warning | 3 | The validator resulted in a warning.
Error | 4 | The validator resulted in an error.
CriticalError | 5 | The validator resulted in a critical error. The user will be warned before saving.
FatalError | 6 | The validator resulted in a fatal error. The user cannot save before the error has been resolved.

See Also

Sitecore.Data.Validators Namespace


ValidatorsMode Enumeration

[image]

Sitecore 6.4.1 API
ValidatorsMode Enumeration
See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum ValidatorsMode
Visual Basic
Public Enumeration ValidatorsMode
Visual C++
public enum class ValidatorsMode

Members

Member name | Value | Description
ValidatorBar | 0 | Validator Bar
ValidateButton | 1 | Validate Button
Gutter | 2 | Gutter
Workflow | 3 | Workflow

See Also

Sitecore.Data.Validators Namespace


ValidatorsQueue Class

[image]

Sitecore 6.4.1 API
ValidatorsQueue Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class ValidatorsQueue
Visual Basic
Public NotInheritable Class ValidatorsQueue
Visual C++
public ref class ValidatorsQueue abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..ValidatorsQueue

See Also

ValidatorsQueue Members
Sitecore.Data.Validators Namespace


ValidatorsQueue Members

[image] [image]

Sitecore 6.4.1 API
ValidatorsQueue Members
ValidatorsQueue Class Methods Properties See Also Send Feedback

The ValidatorsQueue type exposes the following members.

Methods

Name | Description
Enqueue | Queues the specified validator.
GetEvaluatedValidator | Gets the done validator.
GetQueuedValidator | Gets the queued validator.
Remove | Removes the specified validator.

Properties

Name | Description
Evaluated | Gets or sets the evaluated.
Queue | Gets or sets the queue.

See Also

ValidatorsQueue Class
Sitecore.Data.Validators Namespace


ValidatorsQueue Methods

[image] [image]

Sitecore 6.4.1 API
ValidatorsQueue Methods
ValidatorsQueue Class See Also Send Feedback

The ValidatorsQueue type exposes the following members.

Methods

Name | Description
Enqueue | Queues the specified validator.
GetEvaluatedValidator | Gets the done validator.
GetQueuedValidator | Gets the queued validator.
Remove | Removes the specified validator.

See Also

ValidatorsQueue Class
Sitecore.Data.Validators Namespace


Enqueue Method

[image]

Sitecore 6.4.1 API
ValidatorsQueue..::..Enqueue Method
ValidatorsQueue Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Enqueue(
    BaseValidator validator
)
Visual Basic
Public Shared Sub Enqueue ( _
    validator As BaseValidator _
)
Visual C++
public:
static void Enqueue(
    BaseValidator^ validator
)

Parameters

validator
Type: Sitecore.Data.Validators..::..BaseValidator
The validator.

See Also

ValidatorsQueue Class
Sitecore.Data.Validators Namespace


GetEvaluatedValidator Method

[image]

Sitecore 6.4.1 API
ValidatorsQueue..::..GetEvaluatedValidator Method
ValidatorsQueue Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static BaseValidator GetEvaluatedValidator(
    ID id
)
Visual Basic
Public Shared Function GetEvaluatedValidator ( _
    id As ID _
) As BaseValidator
Visual C++
public:
static BaseValidator^ GetEvaluatedValidator(
    ID^ id
)

Parameters

id
Type: Sitecore.Data..::..ID
The id.

Return Value

The done validator.

See Also

ValidatorsQueue Class
Sitecore.Data.Validators Namespace


GetQueuedValidator Method

[image]

Sitecore 6.4.1 API
ValidatorsQueue..::..GetQueuedValidator Method
ValidatorsQueue Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static BaseValidator GetQueuedValidator(
    ID id
)
Visual Basic
Public Shared Function GetQueuedValidator ( _
    id As ID _
) As BaseValidator
Visual C++
public:
static BaseValidator^ GetQueuedValidator(
    ID^ id
)

Parameters

id
Type: Sitecore.Data..::..ID
The id.

Return Value

The queued validator.

See Also

ValidatorsQueue Class
Sitecore.Data.Validators Namespace


Remove Method

[image]

Sitecore 6.4.1 API
ValidatorsQueue..::..Remove Method
ValidatorsQueue Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Remove(
    BaseValidator validator
)
Visual Basic
Public Shared Sub Remove ( _
    validator As BaseValidator _
)
Visual C++
public:
static void Remove(
    BaseValidator^ validator
)

Parameters

validator
Type: Sitecore.Data.Validators..::..BaseValidator
The validator.

See Also

ValidatorsQueue Class
Sitecore.Data.Validators Namespace


ValidatorsQueue Properties

[image] [image]

Sitecore 6.4.1 API
ValidatorsQueue Properties
ValidatorsQueue Class See Also Send Feedback

The ValidatorsQueue type exposes the following members.

Properties

Name | Description
Evaluated | Gets or sets the evaluated.
Queue | Gets or sets the queue.

See Also

ValidatorsQueue Class
Sitecore.Data.Validators Namespace


Evaluated Property

[image]

Sitecore 6.4.1 API
ValidatorsQueue..::..Evaluated Property
ValidatorsQueue Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static List<BaseValidator> Evaluated { get; }
Visual Basic
Public Shared ReadOnly Property Evaluated As List(Of BaseValidator)
    Get
Visual C++
public:
static property List<BaseValidator^>^ Evaluated {
    List<BaseValidator^>^ get ();
}

Field Value

The evaluated.

See Also

ValidatorsQueue Class
Sitecore.Data.Validators Namespace


Queue Property

[image]

Sitecore 6.4.1 API
ValidatorsQueue..::..Queue Property
ValidatorsQueue Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static List<BaseValidator> Queue { get; }
Visual Basic
Public Shared ReadOnly Property Queue As List(Of BaseValidator)
    Get
Visual C++
public:
static property List<BaseValidator^>^ Queue {
    List<BaseValidator^>^ get ();
}

Field Value

The queue.

See Also

ValidatorsQueue Class
Sitecore.Data.Validators Namespace


ValidatorWorker Class

[image]

Sitecore 6.4.1 API
ValidatorWorker Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ValidatorWorker
Visual Basic
Public Class ValidatorWorker
Visual C++
public ref class ValidatorWorker

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..ValidatorWorker

See Also

ValidatorWorker Members
Sitecore.Data.Validators Namespace


ValidatorWorker Members

[image] [image]

Sitecore 6.4.1 API
ValidatorWorker Members
ValidatorWorker Class Constructors Methods See Also Send Feedback

The ValidatorWorker type exposes the following members.

Constructors

 | Name | Description
Public method | ValidatorWorker | Initializes a new instance of the ValidatorWorker class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Start | Starts this instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ValidatorWorker Class
Sitecore.Data.Validators Namespace


ValidatorWorker Constructor

[image]

Sitecore 6.4.1 API
ValidatorWorker Constructor
ValidatorWorker Class See Also Send Feedback

Namespace: Sitecore.Data.Validators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ValidatorWorker(
    BaseValidator validator
)
Visual Basic
Public Sub New ( _
    validator As BaseValidator _
)
Visual C++
public:
ValidatorWorker(
    BaseValidator^ validator
)

Parameters

validator
Type: Sitecore.Data.Validators..::..BaseValidator
The validator.

See Also

ValidatorWorker Class
Sitecore.Data.Validators Namespace


ValidatorWorker Methods

[image] [image]

Sitecore 6.4.1 API
ValidatorWorker Methods
ValidatorWorker Class See Also Send Feedback

The ValidatorWorker type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Start | Starts this instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ValidatorWorker Class
Sitecore.Data.Validators Namespace


Sitecore.Data.Validators.FieldValidators Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Data.Validators.FieldValidators Namespace
Send Feedback

Classes

 | Class | Description
Public class | BrokenLinksValidator | Validates that a field doesn't have broken links.
Public class | ContainsCharactersValidator | Represents a MaxLengthFieldValidator.
Public class | DatabaseNameValidator | Defines the lower case validator class.
Public class | DateTimeRangeValidator | Represents a DateTimeRangeValidator.
Public class | ExternLinkTargetValidator | Represents a Image Alt Field Validator.
Public class | FileValidator | Defines the lower case validator class.
Public class | ImageAltFieldValidator | Represents a Image Alt Field Validator.
Public class | ImageAltFromMediaLibraryFieldValidator | Represents a Image Alt Field Validator.
Public class | ImageSizeValidator | Represents a DateTimeRangeValidator.
Public class | IntegerFieldValidator | Represents a IntegerFieldValidator.
Public class | IntegerRangeValidator | Represents a DateTimeRangeValidator.
Public class | LowerCaseValidator | Defines the lower case validator class.
Public class | MaxLengthFieldValidator | Represents a MaxLengthFieldValidator.
Public class | MinLengthFieldValidator | Represents a MaxLengthFieldValidator.
Public class | NoSpacesValidator | Defines the lower case validator class.
Public class | NoTagsValidator | Defines the lower case validator class.
Public class | ParametersValidator | Defines the lower case validator class.
Public class | RegexValidator | Represents a DateTimeRangeValidator.
Public class | RequiredFieldValidator | Represents a RequiredFieldValidationRule.
Public class | ResetToStandardValueValidator | Defines the lower case validator class.
Public class | RichTextImageSizeValidator | Represents a Image Alt Field Validator.
Public class | ScriptCodeValidator | Validates that a field doesn't have broken links.
Public class | SitecoreCommandValidator | Defines the lower case validator class.
Public class | SpellcheckValidator | Represents a DateTimeRangeValidator.
Public class | StartWithCapitalEndWithDotValidator | Represents a RequiredFieldValidationRule.
Public class | StringEnumValidator | Represents a StringEnumValidator.
Public class | TypeAndAssemblyValidator | Defines the type and assembly validator class.
Public class | UpperCaseValidator | Defines the lower case validator class.
Public class | W3CXhtmlValidator | Represents a DateTimeRangeValidator.
Public class | XhtmlValidator | Represents a DateTimeRangeValidator.
Public class | XmlValidator | Defines the lower case validator class.


BrokenLinksValidator Class

[image]

Sitecore 6.4.1 API
BrokenLinksValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class BrokenLinksValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class BrokenLinksValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class BrokenLinksValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.FieldValidators..::..BrokenLinksValidator

See Also

BrokenLinksValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


BrokenLinksValidator Members

[image] [image]

Sitecore 6.4.1 API
BrokenLinksValidator Members
BrokenLinksValidator Class Constructors Methods Properties See Also Send Feedback

The BrokenLinksValidator type exposes the following members.

Constructors

 | Name | Description
Public method | BrokenLinksValidator()()()() | Initializes a new instance of the BrokenLinksValidator class.
Public method | BrokenLinksValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the BrokenLinksValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

BrokenLinksValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


BrokenLinksValidator Constructor

[image] [image]

Sitecore 6.4.1 API
BrokenLinksValidator Constructor
BrokenLinksValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BrokenLinksValidator()()()() | Initializes a new instance of the BrokenLinksValidator class.
Public method | BrokenLinksValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the BrokenLinksValidator class.

See Also

BrokenLinksValidator Class
BrokenLinksValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


BrokenLinksValidator Constructor

[image]

Sitecore 6.4.1 API
BrokenLinksValidator Constructor
BrokenLinksValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BrokenLinksValidator()
Visual Basic
Public Sub New
Visual C++
public:
BrokenLinksValidator()

See Also

BrokenLinksValidator Class
BrokenLinksValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


BrokenLinksValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
BrokenLinksValidator Constructor (SerializationInfo, StreamingContext)
BrokenLinksValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BrokenLinksValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
BrokenLinksValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

BrokenLinksValidator Class
BrokenLinksValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


BrokenLinksValidator Methods

[image] [image]

Sitecore 6.4.1 API
BrokenLinksValidator Methods
BrokenLinksValidator Class See Also Send Feedback

The BrokenLinksValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

BrokenLinksValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
BrokenLinksValidator..::..Evaluate Method
BrokenLinksValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

BrokenLinksValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
BrokenLinksValidator..::..GetMaxValidatorResult Method
BrokenLinksValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

BrokenLinksValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


BrokenLinksValidator Properties

[image] [image]

Sitecore 6.4.1 API
BrokenLinksValidator Properties
BrokenLinksValidator Class See Also Send Feedback

The BrokenLinksValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

BrokenLinksValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


ContainsCharactersValidator Class

[image]

Sitecore 6.4.1 API
ContainsCharactersValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class ContainsCharactersValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class ContainsCharactersValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class ContainsCharactersValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.FieldValidators..::..ContainsCharactersValidator

See Also

ContainsCharactersValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


ContainsCharactersValidator Members

[image] [image]

Sitecore 6.4.1 API
ContainsCharactersValidator Members
ContainsCharactersValidator Class Constructors Methods Properties See Also Send Feedback

The ContainsCharactersValidator type exposes the following members.

Constructors

 | Name | Description
Public method | ContainsCharactersValidator()()()() | Initializes a new instance of the ContainsCharactersValidator class.
Public method | ContainsCharactersValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the ContainsCharactersValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

ContainsCharactersValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


ContainsCharactersValidator Constructor

[image]

Sitecore 6.4.1 API
ContainsCharactersValidator Constructor
ContainsCharactersValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ContainsCharactersValidator()
Visual Basic
Public Sub New
Visual C++
public:
ContainsCharactersValidator()

See Also

ContainsCharactersValidator Class
ContainsCharactersValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


ContainsCharactersValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
ContainsCharactersValidator Constructor (SerializationInfo, StreamingContext)
ContainsCharactersValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ContainsCharactersValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
ContainsCharactersValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

ContainsCharactersValidator Class
ContainsCharactersValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


ContainsCharactersValidator Methods

[image] [image]

Sitecore 6.4.1 API
ContainsCharactersValidator Methods
ContainsCharactersValidator Class See Also Send Feedback

The ContainsCharactersValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

ContainsCharactersValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
ContainsCharactersValidator..::..Evaluate Method
ContainsCharactersValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

ContainsCharactersValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
ContainsCharactersValidator..::..GetMaxValidatorResult Method
ContainsCharactersValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

ContainsCharactersValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


ContainsCharactersValidator Properties

[image] [image]

Sitecore 6.4.1 API
ContainsCharactersValidator Properties
ContainsCharactersValidator Class See Also Send Feedback

The ContainsCharactersValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

ContainsCharactersValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
ContainsCharactersValidator..::..Name Property
ContainsCharactersValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The validator name.

See Also

ContainsCharactersValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


DatabaseNameValidator Class

[image]

Sitecore 6.4.1 API
DatabaseNameValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class DatabaseNameValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class DatabaseNameValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class DatabaseNameValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.FieldValidators..::..DatabaseNameValidator

See Also

DatabaseNameValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


DatabaseNameValidator Members

[image] [image]

Sitecore 6.4.1 API
DatabaseNameValidator Members
DatabaseNameValidator Class Constructors Methods Properties See Also Send Feedback

The DatabaseNameValidator type exposes the following members.

Constructors

 | Name | Description
Public method | DatabaseNameValidator()()()() | Initializes a new instance of the DatabaseNameValidator class. Initializes a new instance of the DateTimeRangeValidator class.
Public method | DatabaseNameValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the DatabaseNameValidator class. Initializes a new instance of the DateTimeRangeValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

DatabaseNameValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


DatabaseNameValidator Constructor

[image] [image]

Sitecore 6.4.1 API
DatabaseNameValidator Constructor
DatabaseNameValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DatabaseNameValidator()()()() | Initializes a new instance of the DatabaseNameValidator class. Initializes a new instance of the DateTimeRangeValidator class.
Public method | DatabaseNameValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the DatabaseNameValidator class. Initializes a new instance of the DateTimeRangeValidator class.

See Also

DatabaseNameValidator Class
DatabaseNameValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


DatabaseNameValidator Constructor

[image]

Sitecore 6.4.1 API
DatabaseNameValidator Constructor
DatabaseNameValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DatabaseNameValidator()
Visual Basic
Public Sub New
Visual C++
public:
DatabaseNameValidator()

See Also

DatabaseNameValidator Class
DatabaseNameValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


DatabaseNameValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
DatabaseNameValidator Constructor (SerializationInfo, StreamingContext)
DatabaseNameValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DatabaseNameValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
DatabaseNameValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

DatabaseNameValidator Class
DatabaseNameValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


DatabaseNameValidator Methods

[image] [image]

Sitecore 6.4.1 API
DatabaseNameValidator Methods
DatabaseNameValidator Class See Also Send Feedback

The DatabaseNameValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

DatabaseNameValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
DatabaseNameValidator..::..Evaluate Method
DatabaseNameValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

DatabaseNameValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
DatabaseNameValidator..::..GetMaxValidatorResult Method
DatabaseNameValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

DatabaseNameValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


DatabaseNameValidator Properties

[image] [image]

Sitecore 6.4.1 API
DatabaseNameValidator Properties
DatabaseNameValidator Class See Also Send Feedback

The DatabaseNameValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

DatabaseNameValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
DatabaseNameValidator..::..Name Property
DatabaseNameValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The name.

See Also

DatabaseNameValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


DateTimeRangeValidator Class

[image]

Sitecore 6.4.1 API
DateTimeRangeValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class DateTimeRangeValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class DateTimeRangeValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class DateTimeRangeValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.FieldValidators..::..DateTimeRangeValidator

See Also

DateTimeRangeValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


DateTimeRangeValidator Members

[image] [image]

Sitecore 6.4.1 API
DateTimeRangeValidator Members
DateTimeRangeValidator Class Constructors Methods Properties See Also Send Feedback

The DateTimeRangeValidator type exposes the following members.

Constructors

 | Name | Description
Public method | DateTimeRangeValidator()()()() | Initializes a new instance of the DateTimeRangeValidator class.
Public method | DateTimeRangeValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the DateTimeRangeValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

DateTimeRangeValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


DateTimeRangeValidator Constructor

[image] [image]

Sitecore 6.4.1 API
DateTimeRangeValidator Constructor
DateTimeRangeValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DateTimeRangeValidator()()()() | Initializes a new instance of the DateTimeRangeValidator class.
Public method | DateTimeRangeValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the DateTimeRangeValidator class.

See Also

DateTimeRangeValidator Class
DateTimeRangeValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


DateTimeRangeValidator Constructor

[image]

Sitecore 6.4.1 API
DateTimeRangeValidator Constructor
DateTimeRangeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTimeRangeValidator()
Visual Basic
Public Sub New
Visual C++
public:
DateTimeRangeValidator()

See Also

DateTimeRangeValidator Class
DateTimeRangeValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


DateTimeRangeValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
DateTimeRangeValidator Constructor (SerializationInfo, StreamingContext)
DateTimeRangeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTimeRangeValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
DateTimeRangeValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

DateTimeRangeValidator Class
DateTimeRangeValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


DateTimeRangeValidator Methods

[image] [image]

Sitecore 6.4.1 API
DateTimeRangeValidator Methods
DateTimeRangeValidator Class See Also Send Feedback

The DateTimeRangeValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

DateTimeRangeValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
DateTimeRangeValidator..::..Evaluate Method
DateTimeRangeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

DateTimeRangeValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
DateTimeRangeValidator..::..GetMaxValidatorResult Method
DateTimeRangeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

DateTimeRangeValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


DateTimeRangeValidator Properties

[image] [image]

Sitecore 6.4.1 API
DateTimeRangeValidator Properties
DateTimeRangeValidator Class See Also Send Feedback

The DateTimeRangeValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

DateTimeRangeValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
DateTimeRangeValidator..::..Name Property
DateTimeRangeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The validator name.

See Also

DateTimeRangeValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


ExternLinkTargetValidator Class

[image]

Sitecore 6.4.1 API
ExternLinkTargetValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class ExternLinkTargetValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class ExternLinkTargetValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class ExternLinkTargetValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.FieldValidators..::..ExternLinkTargetValidator

See Also

ExternLinkTargetValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


ExternLinkTargetValidator Members

[image] [image]

Sitecore 6.4.1 API
ExternLinkTargetValidator Members
ExternLinkTargetValidator Class Constructors Methods Properties See Also Send Feedback

The ExternLinkTargetValidator type exposes the following members.

Constructors

 | Name | Description
Public method | ExternLinkTargetValidator()()()() | Initializes a new instance of the ExternLinkTargetValidator class.
Public method | ExternLinkTargetValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the ExternLinkTargetValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

ExternLinkTargetValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


ExternLinkTargetValidator Constructor

[image] [image]

Sitecore 6.4.1 API
ExternLinkTargetValidator Constructor
ExternLinkTargetValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExternLinkTargetValidator()()()() | Initializes a new instance of the ExternLinkTargetValidator class.
Public method | ExternLinkTargetValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the ExternLinkTargetValidator class.

See Also

ExternLinkTargetValidator Class
ExternLinkTargetValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


ExternLinkTargetValidator Constructor

[image]

Sitecore 6.4.1 API
ExternLinkTargetValidator Constructor
ExternLinkTargetValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ExternLinkTargetValidator()
Visual Basic
Public Sub New
Visual C++
public:
ExternLinkTargetValidator()

See Also

ExternLinkTargetValidator Class
ExternLinkTargetValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


ExternLinkTargetValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
ExternLinkTargetValidator Constructor (SerializationInfo, StreamingContext)
ExternLinkTargetValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ExternLinkTargetValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
ExternLinkTargetValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

ExternLinkTargetValidator Class
ExternLinkTargetValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


ExternLinkTargetValidator Methods

[image] [image]

Sitecore 6.4.1 API
ExternLinkTargetValidator Methods
ExternLinkTargetValidator Class See Also Send Feedback

The ExternLinkTargetValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

ExternLinkTargetValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
ExternLinkTargetValidator..::..Evaluate Method
ExternLinkTargetValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

ExternLinkTargetValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
ExternLinkTargetValidator..::..GetMaxValidatorResult Method
ExternLinkTargetValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

ExternLinkTargetValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


ExternLinkTargetValidator Properties

[image] [image]

Sitecore 6.4.1 API
ExternLinkTargetValidator Properties
ExternLinkTargetValidator Class See Also Send Feedback

The ExternLinkTargetValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

ExternLinkTargetValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
ExternLinkTargetValidator..::..Name Property
ExternLinkTargetValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The validator name.

See Also

ExternLinkTargetValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


FileValidator Members

[image] [image]

Sitecore 6.4.1 API
FileValidator Members
FileValidator Class Constructors Methods Properties See Also Send Feedback

The FileValidator type exposes the following members.

Constructors

 | Name | Description
Public method | FileValidator()()()() | Initializes a new instance of the FileValidator class. Initializes a new instance of the DateTimeRangeValidator class.
Public method | FileValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the FileValidator class. Initializes a new instance of the DateTimeRangeValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

FileValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


FileValidator Constructor

[image] [image]

Sitecore 6.4.1 API
FileValidator Constructor
FileValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FileValidator()()()() | Initializes a new instance of the FileValidator class. Initializes a new instance of the DateTimeRangeValidator class.
Public method | FileValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the FileValidator class. Initializes a new instance of the DateTimeRangeValidator class.

See Also

FileValidator Class
FileValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


FileValidator Constructor

[image]

Sitecore 6.4.1 API
FileValidator Constructor
FileValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FileValidator()
Visual Basic
Public Sub New
Visual C++
public:
FileValidator()

See Also

FileValidator Class
FileValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


FileValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
FileValidator Constructor (SerializationInfo, StreamingContext)
FileValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FileValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
FileValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

FileValidator Class
FileValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


FileValidator Methods

[image] [image]

Sitecore 6.4.1 API
FileValidator Methods
FileValidator Class See Also Send Feedback

The FileValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

FileValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
FileValidator..::..Evaluate Method
FileValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

FileValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
FileValidator..::..GetMaxValidatorResult Method
FileValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

FileValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


FileValidator Properties

[image] [image]

Sitecore 6.4.1 API
FileValidator Properties
FileValidator Class See Also Send Feedback

The FileValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

FileValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
FileValidator..::..Name Property
FileValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The name.

See Also

FileValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


ImageAltFieldValidator Class

[image]

Sitecore 6.4.1 API
ImageAltFieldValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class ImageAltFieldValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class ImageAltFieldValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class ImageAltFieldValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.FieldValidators..::..ImageAltFieldValidator

See Also

ImageAltFieldValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


ImageAltFieldValidator Members

[image] [image]

Sitecore 6.4.1 API
ImageAltFieldValidator Members
ImageAltFieldValidator Class Constructors Methods Properties See Also Send Feedback

The ImageAltFieldValidator type exposes the following members.

Constructors

 | Name | Description
Public method | ImageAltFieldValidator()()()() | Initializes a new instance of the ImageAltFieldValidator class.
Public method | ImageAltFieldValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the ImageAltFieldValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

ImageAltFieldValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


ImageAltFieldValidator Constructor

[image] [image]

Sitecore 6.4.1 API
ImageAltFieldValidator Constructor
ImageAltFieldValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ImageAltFieldValidator()()()() | Initializes a new instance of the ImageAltFieldValidator class.
Public method | ImageAltFieldValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the ImageAltFieldValidator class.

See Also

ImageAltFieldValidator Class
ImageAltFieldValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


ImageAltFieldValidator Constructor

[image]

Sitecore 6.4.1 API
ImageAltFieldValidator Constructor
ImageAltFieldValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ImageAltFieldValidator()
Visual Basic
Public Sub New
Visual C++
public:
ImageAltFieldValidator()

See Also

ImageAltFieldValidator Class
ImageAltFieldValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


ImageAltFieldValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
ImageAltFieldValidator Constructor (SerializationInfo, StreamingContext)
ImageAltFieldValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ImageAltFieldValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
ImageAltFieldValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

ImageAltFieldValidator Class
ImageAltFieldValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


ImageAltFieldValidator Methods

[image] [image]

Sitecore 6.4.1 API
ImageAltFieldValidator Methods
ImageAltFieldValidator Class See Also Send Feedback

The ImageAltFieldValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

ImageAltFieldValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
ImageAltFieldValidator..::..Evaluate Method
ImageAltFieldValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

ImageAltFieldValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
ImageAltFieldValidator..::..GetMaxValidatorResult Method
ImageAltFieldValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

ImageAltFieldValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


ImageAltFieldValidator Properties

[image] [image]

Sitecore 6.4.1 API
ImageAltFieldValidator Properties
ImageAltFieldValidator Class See Also Send Feedback

The ImageAltFieldValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

ImageAltFieldValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
ImageAltFieldValidator..::..Name Property
ImageAltFieldValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The validator name.

See Also

ImageAltFieldValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


ImageAltFromMediaLibraryFieldValidator Class

[image]

Sitecore 6.4.1 API
ImageAltFromMediaLibraryFieldValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class ImageAltFromMediaLibraryFieldValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class ImageAltFromMediaLibraryFieldValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class ImageAltFromMediaLibraryFieldValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.FieldValidators..::..ImageAltFromMediaLibraryFieldValidator

See Also

ImageAltFromMediaLibraryFieldValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


ImageAltFromMediaLibraryFieldValidator Members

[image] [image]

Sitecore 6.4.1 API
ImageAltFromMediaLibraryFieldValidator Members
ImageAltFromMediaLibraryFieldValidator Class Constructors Methods Properties See Also Send Feedback

The ImageAltFromMediaLibraryFieldValidator type exposes the following members.

Constructors

 | Name | Description
Public method | ImageAltFromMediaLibraryFieldValidator()()()() | Initializes a new instance of the ImageAltFromMediaLibraryFieldValidator class.
Public method | ImageAltFromMediaLibraryFieldValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the ImageAltFromMediaLibraryFieldValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

ImageAltFromMediaLibraryFieldValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


ImageAltFromMediaLibraryFieldValidator Constructor

[image] [image]

Sitecore 6.4.1 API
ImageAltFromMediaLibraryFieldValidator Constructor
ImageAltFromMediaLibraryFieldValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ImageAltFromMediaLibraryFieldValidator()()()() | Initializes a new instance of the ImageAltFromMediaLibraryFieldValidator class.
Public method | ImageAltFromMediaLibraryFieldValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the ImageAltFromMediaLibraryFieldValidator class.

See Also

ImageAltFromMediaLibraryFieldValidator Class
ImageAltFromMediaLibraryFieldValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


ImageAltFromMediaLibraryFieldValidator Constructor

[image]

Sitecore 6.4.1 API
ImageAltFromMediaLibraryFieldValidator Constructor
ImageAltFromMediaLibraryFieldValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ImageAltFromMediaLibraryFieldValidator()
Visual Basic
Public Sub New
Visual C++
public:
ImageAltFromMediaLibraryFieldValidator()

See Also

ImageAltFromMediaLibraryFieldValidator Class
ImageAltFromMediaLibraryFieldValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


ImageAltFromMediaLibraryFieldValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
ImageAltFromMediaLibraryFieldValidator Constructor (SerializationInfo, StreamingContext)
ImageAltFromMediaLibraryFieldValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ImageAltFromMediaLibraryFieldValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
ImageAltFromMediaLibraryFieldValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

ImageAltFromMediaLibraryFieldValidator Class
ImageAltFromMediaLibraryFieldValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


ImageAltFromMediaLibraryFieldValidator Methods

[image] [image]

Sitecore 6.4.1 API
ImageAltFromMediaLibraryFieldValidator Methods
ImageAltFromMediaLibraryFieldValidator Class See Also Send Feedback

The ImageAltFromMediaLibraryFieldValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

ImageAltFromMediaLibraryFieldValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
ImageAltFromMediaLibraryFieldValidator..::..Evaluate Method
ImageAltFromMediaLibraryFieldValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

ImageAltFromMediaLibraryFieldValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
ImageAltFromMediaLibraryFieldValidator..::..GetMaxValidatorResult Method
ImageAltFromMediaLibraryFieldValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

ImageAltFromMediaLibraryFieldValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
ImageAltFromMediaLibraryFieldValidator..::..Name Property
ImageAltFromMediaLibraryFieldValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The validator name.

See Also

ImageAltFromMediaLibraryFieldValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


ImageSizeValidator Class

[image]

Sitecore 6.4.1 API
ImageSizeValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class ImageSizeValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class ImageSizeValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class ImageSizeValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.FieldValidators..::..ImageSizeValidator

See Also

ImageSizeValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


ImageSizeValidator Constructor

[image] [image]

Sitecore 6.4.1 API
ImageSizeValidator Constructor
ImageSizeValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ImageSizeValidator()()()() | Initializes a new instance of the ImageSizeValidator class.
Public method | ImageSizeValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the ImageSizeValidator class.

See Also

ImageSizeValidator Class
ImageSizeValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


ImageSizeValidator Constructor

[image]

Sitecore 6.4.1 API
ImageSizeValidator Constructor
ImageSizeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ImageSizeValidator()
Visual Basic
Public Sub New
Visual C++
public:
ImageSizeValidator()

See Also

ImageSizeValidator Class
ImageSizeValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


ImageSizeValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
ImageSizeValidator Constructor (SerializationInfo, StreamingContext)
ImageSizeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ImageSizeValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
ImageSizeValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

ImageSizeValidator Class
ImageSizeValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
ImageSizeValidator..::..Evaluate Method
ImageSizeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

ImageSizeValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
ImageSizeValidator..::..GetMaxValidatorResult Method
ImageSizeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

ImageSizeValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


ImageSizeValidator Properties

[image] [image]

Sitecore 6.4.1 API
ImageSizeValidator Properties
ImageSizeValidator Class See Also Send Feedback

The ImageSizeValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

ImageSizeValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
ImageSizeValidator..::..Name Property
ImageSizeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The validator name.

See Also

ImageSizeValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


IntegerFieldValidator Class

[image]

Sitecore 6.4.1 API
IntegerFieldValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class IntegerFieldValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class IntegerFieldValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class IntegerFieldValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.FieldValidators..::..IntegerFieldValidator

See Also

IntegerFieldValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


IntegerFieldValidator Members

[image] [image]

Sitecore 6.4.1 API
IntegerFieldValidator Members
IntegerFieldValidator Class Constructors Methods Properties See Also Send Feedback

The IntegerFieldValidator type exposes the following members.

Constructors

 | Name | Description
Public method | IntegerFieldValidator()()()() | Initializes a new instance of the IntegerFieldValidator class. Initializes a new instance of the DateTimeRangeValidator class.
Public method | IntegerFieldValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the IntegerFieldValidator class. Initializes a new instance of the DateTimeRangeValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | AllowNegative | Gets a value indicating whether the IntegerFieldValidator allows the negative.
Public property | AllowZero | Gets a value indicating whether the IntegerFieldValidator allows the zero.
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

IntegerFieldValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


IntegerFieldValidator Constructor

[image] [image]

Sitecore 6.4.1 API
IntegerFieldValidator Constructor
IntegerFieldValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IntegerFieldValidator()()()() | Initializes a new instance of the IntegerFieldValidator class. Initializes a new instance of the DateTimeRangeValidator class.
Public method | IntegerFieldValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the IntegerFieldValidator class. Initializes a new instance of the DateTimeRangeValidator class.

See Also

IntegerFieldValidator Class
IntegerFieldValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


IntegerFieldValidator Constructor

[image]

Sitecore 6.4.1 API
IntegerFieldValidator Constructor
IntegerFieldValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IntegerFieldValidator()
Visual Basic
Public Sub New
Visual C++
public:
IntegerFieldValidator()

See Also

IntegerFieldValidator Class
IntegerFieldValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


IntegerFieldValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
IntegerFieldValidator Constructor (SerializationInfo, StreamingContext)
IntegerFieldValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IntegerFieldValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
IntegerFieldValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

IntegerFieldValidator Class
IntegerFieldValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


IntegerFieldValidator Methods

[image] [image]

Sitecore 6.4.1 API
IntegerFieldValidator Methods
IntegerFieldValidator Class See Also Send Feedback

The IntegerFieldValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

IntegerFieldValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
IntegerFieldValidator..::..Evaluate Method
IntegerFieldValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

IntegerFieldValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
IntegerFieldValidator..::..GetMaxValidatorResult Method
IntegerFieldValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

IntegerFieldValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


IntegerFieldValidator Properties

[image] [image]

Sitecore 6.4.1 API
IntegerFieldValidator Properties
IntegerFieldValidator Class See Also Send Feedback

The IntegerFieldValidator type exposes the following members.

Properties

 | Name | Description
Public property | AllowNegative | Gets a value indicating whether the IntegerFieldValidator allows the negative.
Public property | AllowZero | Gets a value indicating whether the IntegerFieldValidator allows the zero.
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

IntegerFieldValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


AllowNegative Property

[image]

Sitecore 6.4.1 API
IntegerFieldValidator..::..AllowNegative Property
IntegerFieldValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool AllowNegative { get; }
Visual Basic
Public ReadOnly Property AllowNegative As Boolean
    Get
Visual C++
public:
property bool AllowNegative {
    bool get ();
}

Field Value

true if the IntegerFieldValidator allows the negative; otherwise, false.

See Also

IntegerFieldValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


AllowZero Property

[image]

Sitecore 6.4.1 API
IntegerFieldValidator..::..AllowZero Property
IntegerFieldValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool AllowZero { get; }
Visual Basic
Public ReadOnly Property AllowZero As Boolean
    Get
Visual C++
public:
property bool AllowZero {
    bool get ();
}

Field Value

true if the IntegerFieldValidator allows the zero; otherwise, false.

See Also

IntegerFieldValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


IntegerRangeValidator Class

[image]

Sitecore 6.4.1 API
IntegerRangeValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class IntegerRangeValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class IntegerRangeValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class IntegerRangeValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.FieldValidators..::..IntegerRangeValidator

See Also

IntegerRangeValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


IntegerRangeValidator Members

[image] [image]

Sitecore 6.4.1 API
IntegerRangeValidator Members
IntegerRangeValidator Class Constructors Methods Properties See Also Send Feedback

The IntegerRangeValidator type exposes the following members.

Constructors

 | Name | Description
Public method | IntegerRangeValidator()()()() | Initializes a new instance of the IntegerRangeValidator class. Initializes a new instance of the DateTimeRangeValidator class.
Public method | IntegerRangeValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the IntegerRangeValidator class. Initializes a new instance of the DateTimeRangeValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

IntegerRangeValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


IntegerRangeValidator Constructor

[image] [image]

Sitecore 6.4.1 API
IntegerRangeValidator Constructor
IntegerRangeValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IntegerRangeValidator()()()() | Initializes a new instance of the IntegerRangeValidator class. Initializes a new instance of the DateTimeRangeValidator class.
Public method | IntegerRangeValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the IntegerRangeValidator class. Initializes a new instance of the DateTimeRangeValidator class.

See Also

IntegerRangeValidator Class
IntegerRangeValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


IntegerRangeValidator Constructor

[image]

Sitecore 6.4.1 API
IntegerRangeValidator Constructor
IntegerRangeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IntegerRangeValidator()
Visual Basic
Public Sub New
Visual C++
public:
IntegerRangeValidator()

See Also

IntegerRangeValidator Class
IntegerRangeValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


IntegerRangeValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
IntegerRangeValidator Constructor (SerializationInfo, StreamingContext)
IntegerRangeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IntegerRangeValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
IntegerRangeValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

IntegerRangeValidator Class
IntegerRangeValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


IntegerRangeValidator Methods

[image] [image]

Sitecore 6.4.1 API
IntegerRangeValidator Methods
IntegerRangeValidator Class See Also Send Feedback

The IntegerRangeValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

IntegerRangeValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
IntegerRangeValidator..::..Evaluate Method
IntegerRangeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

IntegerRangeValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


IntegerRangeValidator Properties

[image] [image]

Sitecore 6.4.1 API
IntegerRangeValidator Properties
IntegerRangeValidator Class See Also Send Feedback

The IntegerRangeValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

IntegerRangeValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
IntegerRangeValidator..::..Name Property
IntegerRangeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The validator name.

See Also

IntegerRangeValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


LowerCaseValidator Class

[image]

Sitecore 6.4.1 API
LowerCaseValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class LowerCaseValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class LowerCaseValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class LowerCaseValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.FieldValidators..::..LowerCaseValidator

See Also

LowerCaseValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


LowerCaseValidator Members

[image] [image]

Sitecore 6.4.1 API
LowerCaseValidator Members
LowerCaseValidator Class Constructors Methods Properties See Also Send Feedback

The LowerCaseValidator type exposes the following members.

Constructors

 | Name | Description
Public method | LowerCaseValidator()()()() | Initializes a new instance of the LowerCaseValidator class. Initializes a new instance of the DateTimeRangeValidator class.
Public method | LowerCaseValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the LowerCaseValidator class. Initializes a new instance of the DateTimeRangeValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

LowerCaseValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


LowerCaseValidator Constructor

[image] [image]

Sitecore 6.4.1 API
LowerCaseValidator Constructor
LowerCaseValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LowerCaseValidator()()()() | Initializes a new instance of the LowerCaseValidator class. Initializes a new instance of the DateTimeRangeValidator class.
Public method | LowerCaseValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the LowerCaseValidator class. Initializes a new instance of the DateTimeRangeValidator class.

See Also

LowerCaseValidator Class
LowerCaseValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


LowerCaseValidator Constructor

[image]

Sitecore 6.4.1 API
LowerCaseValidator Constructor
LowerCaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LowerCaseValidator()
Visual Basic
Public Sub New
Visual C++
public:
LowerCaseValidator()

See Also

LowerCaseValidator Class
LowerCaseValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


LowerCaseValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
LowerCaseValidator Constructor (SerializationInfo, StreamingContext)
LowerCaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LowerCaseValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
LowerCaseValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

LowerCaseValidator Class
LowerCaseValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
LowerCaseValidator..::..Evaluate Method
LowerCaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

LowerCaseValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
LowerCaseValidator..::..GetMaxValidatorResult Method
LowerCaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

LowerCaseValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
LowerCaseValidator..::..Name Property
LowerCaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The name.

See Also

LowerCaseValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


MaxLengthFieldValidator Class

[image]

Sitecore 6.4.1 API
MaxLengthFieldValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class MaxLengthFieldValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class MaxLengthFieldValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class MaxLengthFieldValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.FieldValidators..::..MaxLengthFieldValidator

See Also

MaxLengthFieldValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


MaxLengthFieldValidator Members

[image] [image]

Sitecore 6.4.1 API
MaxLengthFieldValidator Members
MaxLengthFieldValidator Class Constructors Methods Properties See Also Send Feedback

The MaxLengthFieldValidator type exposes the following members.

Constructors

 | Name | Description
Public method | MaxLengthFieldValidator()()()() | Initializes a new instance of the MaxLengthFieldValidator class. Initializes a new instance of the DateTimeRangeValidator class.
Public method | MaxLengthFieldValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the MaxLengthFieldValidator class. Initializes a new instance of the DateTimeRangeValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

MaxLengthFieldValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


MaxLengthFieldValidator Constructor

[image] [image]

Sitecore 6.4.1 API
MaxLengthFieldValidator Constructor
MaxLengthFieldValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MaxLengthFieldValidator()()()() | Initializes a new instance of the MaxLengthFieldValidator class. Initializes a new instance of the DateTimeRangeValidator class.
Public method | MaxLengthFieldValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the MaxLengthFieldValidator class. Initializes a new instance of the DateTimeRangeValidator class.

See Also

MaxLengthFieldValidator Class
MaxLengthFieldValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


MaxLengthFieldValidator Constructor

[image]

Sitecore 6.4.1 API
MaxLengthFieldValidator Constructor
MaxLengthFieldValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MaxLengthFieldValidator()
Visual Basic
Public Sub New
Visual C++
public:
MaxLengthFieldValidator()

See Also

MaxLengthFieldValidator Class
MaxLengthFieldValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


MaxLengthFieldValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
MaxLengthFieldValidator Constructor (SerializationInfo, StreamingContext)
MaxLengthFieldValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MaxLengthFieldValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
MaxLengthFieldValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

MaxLengthFieldValidator Class
MaxLengthFieldValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


MaxLengthFieldValidator Methods

[image] [image]

Sitecore 6.4.1 API
MaxLengthFieldValidator Methods
MaxLengthFieldValidator Class See Also Send Feedback

The MaxLengthFieldValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

MaxLengthFieldValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
MaxLengthFieldValidator..::..Evaluate Method
MaxLengthFieldValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

MaxLengthFieldValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
MaxLengthFieldValidator..::..GetMaxValidatorResult Method
MaxLengthFieldValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

MaxLengthFieldValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


MaxLengthFieldValidator Properties

[image] [image]

Sitecore 6.4.1 API
MaxLengthFieldValidator Properties
MaxLengthFieldValidator Class See Also Send Feedback

The MaxLengthFieldValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

MaxLengthFieldValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
MaxLengthFieldValidator..::..Name Property
MaxLengthFieldValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The validator name.

See Also

MaxLengthFieldValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


MinLengthFieldValidator Class

[image]

Sitecore 6.4.1 API
MinLengthFieldValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class MinLengthFieldValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class MinLengthFieldValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class MinLengthFieldValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.FieldValidators..::..MinLengthFieldValidator

See Also

MinLengthFieldValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


MinLengthFieldValidator Members

[image] [image]

Sitecore 6.4.1 API
MinLengthFieldValidator Members
MinLengthFieldValidator Class Constructors Methods Properties See Also Send Feedback

The MinLengthFieldValidator type exposes the following members.

Constructors

 | Name | Description
Public method | MinLengthFieldValidator()()()() | Initializes a new instance of the MinLengthFieldValidator class. Initializes a new instance of the DateTimeRangeValidator class.
Public method | MinLengthFieldValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the MinLengthFieldValidator class. Initializes a new instance of the DateTimeRangeValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

MinLengthFieldValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


MinLengthFieldValidator Constructor

[image] [image]

Sitecore 6.4.1 API
MinLengthFieldValidator Constructor
MinLengthFieldValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MinLengthFieldValidator()()()() | Initializes a new instance of the MinLengthFieldValidator class. Initializes a new instance of the DateTimeRangeValidator class.
Public method | MinLengthFieldValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the MinLengthFieldValidator class. Initializes a new instance of the DateTimeRangeValidator class.

See Also

MinLengthFieldValidator Class
MinLengthFieldValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


MinLengthFieldValidator Constructor

[image]

Sitecore 6.4.1 API
MinLengthFieldValidator Constructor
MinLengthFieldValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MinLengthFieldValidator()
Visual Basic
Public Sub New
Visual C++
public:
MinLengthFieldValidator()

See Also

MinLengthFieldValidator Class
MinLengthFieldValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


MinLengthFieldValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
MinLengthFieldValidator Constructor (SerializationInfo, StreamingContext)
MinLengthFieldValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MinLengthFieldValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
MinLengthFieldValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

MinLengthFieldValidator Class
MinLengthFieldValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


MinLengthFieldValidator Methods

[image] [image]

Sitecore 6.4.1 API
MinLengthFieldValidator Methods
MinLengthFieldValidator Class See Also Send Feedback

The MinLengthFieldValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

MinLengthFieldValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
MinLengthFieldValidator..::..Evaluate Method
MinLengthFieldValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

MinLengthFieldValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
MinLengthFieldValidator..::..GetMaxValidatorResult Method
MinLengthFieldValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

MinLengthFieldValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


MinLengthFieldValidator Properties

[image] [image]

Sitecore 6.4.1 API
MinLengthFieldValidator Properties
MinLengthFieldValidator Class See Also Send Feedback

The MinLengthFieldValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

MinLengthFieldValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
MinLengthFieldValidator..::..Name Property
MinLengthFieldValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The name.

See Also

MinLengthFieldValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


NoSpacesValidator Class

[image]

Sitecore 6.4.1 API
NoSpacesValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class NoSpacesValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class NoSpacesValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class NoSpacesValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.FieldValidators..::..NoSpacesValidator

See Also

NoSpacesValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


NoSpacesValidator Members

[image] [image]

Sitecore 6.4.1 API
NoSpacesValidator Members
NoSpacesValidator Class Constructors Methods Properties See Also Send Feedback

The NoSpacesValidator type exposes the following members.

Constructors

 | Name | Description
Public method | NoSpacesValidator()()()() | Initializes a new instance of the NoSpacesValidator class. Initializes a new instance of the DateTimeRangeValidator class.
Public method | NoSpacesValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the NoSpacesValidator class. Initializes a new instance of the DateTimeRangeValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

NoSpacesValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


NoSpacesValidator Constructor

[image] [image]

Sitecore 6.4.1 API
NoSpacesValidator Constructor
NoSpacesValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NoSpacesValidator()()()() | Initializes a new instance of the NoSpacesValidator class. Initializes a new instance of the DateTimeRangeValidator class.
Public method | NoSpacesValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the NoSpacesValidator class. Initializes a new instance of the DateTimeRangeValidator class.

See Also

NoSpacesValidator Class
NoSpacesValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


NoSpacesValidator Constructor

[image]

Sitecore 6.4.1 API
NoSpacesValidator Constructor
NoSpacesValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public NoSpacesValidator()
Visual Basic
Public Sub New
Visual C++
public:
NoSpacesValidator()

See Also

NoSpacesValidator Class
NoSpacesValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


NoSpacesValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
NoSpacesValidator Constructor (SerializationInfo, StreamingContext)
NoSpacesValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public NoSpacesValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
NoSpacesValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

NoSpacesValidator Class
NoSpacesValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


NoSpacesValidator Methods

[image] [image]

Sitecore 6.4.1 API
NoSpacesValidator Methods
NoSpacesValidator Class See Also Send Feedback

The NoSpacesValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

NoSpacesValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
NoSpacesValidator..::..Evaluate Method
NoSpacesValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

NoSpacesValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
NoSpacesValidator..::..GetMaxValidatorResult Method
NoSpacesValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

NoSpacesValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


NoSpacesValidator Properties

[image] [image]

Sitecore 6.4.1 API
NoSpacesValidator Properties
NoSpacesValidator Class See Also Send Feedback

The NoSpacesValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

NoSpacesValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
NoSpacesValidator..::..Name Property
NoSpacesValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The name.

See Also

NoSpacesValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


NoTagsValidator Class

[image]

Sitecore 6.4.1 API
NoTagsValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class NoTagsValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class NoTagsValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class NoTagsValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.FieldValidators..::..NoTagsValidator

See Also

NoTagsValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


NoTagsValidator Members

[image] [image]

Sitecore 6.4.1 API
NoTagsValidator Members
NoTagsValidator Class Constructors Methods Properties See Also Send Feedback

The NoTagsValidator type exposes the following members.

Constructors

 | Name | Description
Public method | NoTagsValidator()()()() | Initializes a new instance of the NoTagsValidator class. Initializes a new instance of the DateTimeRangeValidator class.
Public method | NoTagsValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the NoTagsValidator class. Initializes a new instance of the DateTimeRangeValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

NoTagsValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


NoTagsValidator Constructor

[image] [image]

Sitecore 6.4.1 API
NoTagsValidator Constructor
NoTagsValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NoTagsValidator()()()() | Initializes a new instance of the NoTagsValidator class. Initializes a new instance of the DateTimeRangeValidator class.
Public method | NoTagsValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the NoTagsValidator class. Initializes a new instance of the DateTimeRangeValidator class.

See Also

NoTagsValidator Class
NoTagsValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


NoTagsValidator Constructor

[image]

Sitecore 6.4.1 API
NoTagsValidator Constructor
NoTagsValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public NoTagsValidator()
Visual Basic
Public Sub New
Visual C++
public:
NoTagsValidator()

See Also

NoTagsValidator Class
NoTagsValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


NoTagsValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
NoTagsValidator Constructor (SerializationInfo, StreamingContext)
NoTagsValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public NoTagsValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
NoTagsValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

NoTagsValidator Class
NoTagsValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
NoTagsValidator..::..Evaluate Method
NoTagsValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

NoTagsValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
NoTagsValidator..::..GetMaxValidatorResult Method
NoTagsValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

NoTagsValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


NoTagsValidator Properties

[image] [image]

Sitecore 6.4.1 API
NoTagsValidator Properties
NoTagsValidator Class See Also Send Feedback

The NoTagsValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

NoTagsValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
NoTagsValidator..::..Name Property
NoTagsValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The name.

See Also

NoTagsValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


ParametersValidator Class

[image]

Sitecore 6.4.1 API
ParametersValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class ParametersValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class ParametersValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class ParametersValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.FieldValidators..::..ParametersValidator

See Also

ParametersValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


ParametersValidator Members

[image] [image]

Sitecore 6.4.1 API
ParametersValidator Members
ParametersValidator Class Constructors Methods Properties See Also Send Feedback

The ParametersValidator type exposes the following members.

Constructors

 | Name | Description
Public method | ParametersValidator()()()() | Initializes a new instance of the ParametersValidator class. Initializes a new instance of the DateTimeRangeValidator class.
Public method | ParametersValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the ParametersValidator class. Initializes a new instance of the DateTimeRangeValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

ParametersValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


ParametersValidator Constructor

[image] [image]

Sitecore 6.4.1 API
ParametersValidator Constructor
ParametersValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ParametersValidator()()()() | Initializes a new instance of the ParametersValidator class. Initializes a new instance of the DateTimeRangeValidator class.
Public method | ParametersValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the ParametersValidator class. Initializes a new instance of the DateTimeRangeValidator class.

See Also

ParametersValidator Class
ParametersValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


ParametersValidator Constructor

[image]

Sitecore 6.4.1 API
ParametersValidator Constructor
ParametersValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ParametersValidator()
Visual Basic
Public Sub New
Visual C++
public:
ParametersValidator()

See Also

ParametersValidator Class
ParametersValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


ParametersValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
ParametersValidator Constructor (SerializationInfo, StreamingContext)
ParametersValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ParametersValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
ParametersValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

ParametersValidator Class
ParametersValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


ParametersValidator Methods

[image] [image]

Sitecore 6.4.1 API
ParametersValidator Methods
ParametersValidator Class See Also Send Feedback

The ParametersValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

ParametersValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
ParametersValidator..::..Evaluate Method
ParametersValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

ParametersValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
ParametersValidator..::..GetMaxValidatorResult Method
ParametersValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

ParametersValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


ParametersValidator Properties

[image] [image]

Sitecore 6.4.1 API
ParametersValidator Properties
ParametersValidator Class See Also Send Feedback

The ParametersValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

ParametersValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
ParametersValidator..::..Name Property
ParametersValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The name.

See Also

ParametersValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


RegexValidator Class

[image]

Sitecore 6.4.1 API
RegexValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class RegexValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class RegexValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class RegexValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.FieldValidators..::..RegexValidator

See Also

RegexValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


RegexValidator Members

[image] [image]

Sitecore 6.4.1 API
RegexValidator Members
RegexValidator Class Constructors Methods Properties See Also Send Feedback

The RegexValidator type exposes the following members.

Constructors

 | Name | Description
Public method | RegexValidator()()()() | Initializes a new instance of the RegexValidator class. Initializes a new instance of the DateTimeRangeValidator class.
Public method | RegexValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the RegexValidator class. Initializes a new instance of the DateTimeRangeValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

RegexValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


RegexValidator Constructor

[image] [image]

Sitecore 6.4.1 API
RegexValidator Constructor
RegexValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RegexValidator()()()() | Initializes a new instance of the RegexValidator class. Initializes a new instance of the DateTimeRangeValidator class.
Public method | RegexValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the RegexValidator class. Initializes a new instance of the DateTimeRangeValidator class.

See Also

RegexValidator Class
RegexValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


RegexValidator Constructor

[image]

Sitecore 6.4.1 API
RegexValidator Constructor
RegexValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RegexValidator()
Visual Basic
Public Sub New
Visual C++
public:
RegexValidator()

See Also

RegexValidator Class
RegexValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


RegexValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
RegexValidator Constructor (SerializationInfo, StreamingContext)
RegexValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RegexValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
RegexValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

RegexValidator Class
RegexValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


RegexValidator Methods

[image] [image]

Sitecore 6.4.1 API
RegexValidator Methods
RegexValidator Class See Also Send Feedback

The RegexValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

RegexValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
RegexValidator..::..Evaluate Method
RegexValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

RegexValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
RegexValidator..::..GetMaxValidatorResult Method
RegexValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

RegexValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


RegexValidator Properties

[image] [image]

Sitecore 6.4.1 API
RegexValidator Properties
RegexValidator Class See Also Send Feedback

The RegexValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

RegexValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
RegexValidator..::..Name Property
RegexValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The validator name.

See Also

RegexValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


RequiredFieldValidator Class

[image]

Sitecore 6.4.1 API
RequiredFieldValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class RequiredFieldValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class RequiredFieldValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class RequiredFieldValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.FieldValidators..::..RequiredFieldValidator

See Also

RequiredFieldValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


RequiredFieldValidator Members

[image] [image]

Sitecore 6.4.1 API
RequiredFieldValidator Members
RequiredFieldValidator Class Constructors Methods Properties See Also Send Feedback

The RequiredFieldValidator type exposes the following members.

Constructors

 | Name | Description
Public method | RequiredFieldValidator()()()() | Initializes a new instance of the RequiredFieldValidator class. Initializes a new instance of the DateTimeRangeValidator class.
Public method | RequiredFieldValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the RequiredFieldValidator class. Initializes a new instance of the DateTimeRangeValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

RequiredFieldValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


RequiredFieldValidator Constructor

[image]

Sitecore 6.4.1 API
RequiredFieldValidator Constructor
RequiredFieldValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RequiredFieldValidator()
Visual Basic
Public Sub New
Visual C++
public:
RequiredFieldValidator()

See Also

RequiredFieldValidator Class
RequiredFieldValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


RequiredFieldValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
RequiredFieldValidator Constructor (SerializationInfo, StreamingContext)
RequiredFieldValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RequiredFieldValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
RequiredFieldValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

RequiredFieldValidator Class
RequiredFieldValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


RequiredFieldValidator Methods

[image] [image]

Sitecore 6.4.1 API
RequiredFieldValidator Methods
RequiredFieldValidator Class See Also Send Feedback

The RequiredFieldValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

RequiredFieldValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
RequiredFieldValidator..::..Evaluate Method
RequiredFieldValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

RequiredFieldValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


RequiredFieldValidator Properties

[image] [image]

Sitecore 6.4.1 API
RequiredFieldValidator Properties
RequiredFieldValidator Class See Also Send Feedback

The RequiredFieldValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

RequiredFieldValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
RequiredFieldValidator..::..Name Property
RequiredFieldValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The validator name.

See Also

RequiredFieldValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


ResetToStandardValueValidator Class

[image]

Sitecore 6.4.1 API
ResetToStandardValueValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class ResetToStandardValueValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class ResetToStandardValueValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class ResetToStandardValueValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.FieldValidators..::..ResetToStandardValueValidator

See Also

ResetToStandardValueValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


ResetToStandardValueValidator Members

[image] [image]

Sitecore 6.4.1 API
ResetToStandardValueValidator Members
ResetToStandardValueValidator Class Constructors Methods Properties See Also Send Feedback

The ResetToStandardValueValidator type exposes the following members.

Constructors

 | Name | Description
Public method | ResetToStandardValueValidator()()()() | Initializes a new instance of the ResetToStandardValueValidator class. Initializes a new instance of the DateTimeRangeValidator class.
Public method | ResetToStandardValueValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the ResetToStandardValueValidator class. Initializes a new instance of the DateTimeRangeValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

ResetToStandardValueValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


ResetToStandardValueValidator Constructor

[image] [image]

Sitecore 6.4.1 API
ResetToStandardValueValidator Constructor
ResetToStandardValueValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResetToStandardValueValidator()()()() | Initializes a new instance of the ResetToStandardValueValidator class. Initializes a new instance of the DateTimeRangeValidator class.
Public method | ResetToStandardValueValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the ResetToStandardValueValidator class. Initializes a new instance of the DateTimeRangeValidator class.

See Also

ResetToStandardValueValidator Class
ResetToStandardValueValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


ResetToStandardValueValidator Constructor

[image]

Sitecore 6.4.1 API
ResetToStandardValueValidator Constructor
ResetToStandardValueValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ResetToStandardValueValidator()
Visual Basic
Public Sub New
Visual C++
public:
ResetToStandardValueValidator()

See Also

ResetToStandardValueValidator Class
ResetToStandardValueValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


ResetToStandardValueValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
ResetToStandardValueValidator Constructor (SerializationInfo, StreamingContext)
ResetToStandardValueValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ResetToStandardValueValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
ResetToStandardValueValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

ResetToStandardValueValidator Class
ResetToStandardValueValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


ResetToStandardValueValidator Methods

[image] [image]

Sitecore 6.4.1 API
ResetToStandardValueValidator Methods
ResetToStandardValueValidator Class See Also Send Feedback

The ResetToStandardValueValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

ResetToStandardValueValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
ResetToStandardValueValidator..::..Evaluate Method
ResetToStandardValueValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

ResetToStandardValueValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
ResetToStandardValueValidator..::..GetMaxValidatorResult Method
ResetToStandardValueValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

ResetToStandardValueValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


ResetToStandardValueValidator Properties

[image] [image]

Sitecore 6.4.1 API
ResetToStandardValueValidator Properties
ResetToStandardValueValidator Class See Also Send Feedback

The ResetToStandardValueValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

ResetToStandardValueValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
ResetToStandardValueValidator..::..Name Property
ResetToStandardValueValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The name.

See Also

ResetToStandardValueValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


RichTextImageSizeValidator Class

[image]

Sitecore 6.4.1 API
RichTextImageSizeValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class RichTextImageSizeValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class RichTextImageSizeValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class RichTextImageSizeValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.FieldValidators..::..RichTextImageSizeValidator

See Also

RichTextImageSizeValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


RichTextImageSizeValidator Members

[image] [image]

Sitecore 6.4.1 API
RichTextImageSizeValidator Members
RichTextImageSizeValidator Class Constructors Methods Properties See Also Send Feedback

The RichTextImageSizeValidator type exposes the following members.

Constructors

 | Name | Description
Public method | RichTextImageSizeValidator()()()() | Initializes a new instance of the RichTextImageSizeValidator class.
Public method | RichTextImageSizeValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the RichTextImageSizeValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

RichTextImageSizeValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


RichTextImageSizeValidator Constructor

[image] [image]

Sitecore 6.4.1 API
RichTextImageSizeValidator Constructor
RichTextImageSizeValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RichTextImageSizeValidator()()()() | Initializes a new instance of the RichTextImageSizeValidator class.
Public method | RichTextImageSizeValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the RichTextImageSizeValidator class.

See Also

RichTextImageSizeValidator Class
RichTextImageSizeValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


RichTextImageSizeValidator Constructor

[image]

Sitecore 6.4.1 API
RichTextImageSizeValidator Constructor
RichTextImageSizeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RichTextImageSizeValidator()
Visual Basic
Public Sub New
Visual C++
public:
RichTextImageSizeValidator()

See Also

RichTextImageSizeValidator Class
RichTextImageSizeValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


RichTextImageSizeValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
RichTextImageSizeValidator Constructor (SerializationInfo, StreamingContext)
RichTextImageSizeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RichTextImageSizeValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
RichTextImageSizeValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

RichTextImageSizeValidator Class
RichTextImageSizeValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


RichTextImageSizeValidator Methods

[image] [image]

Sitecore 6.4.1 API
RichTextImageSizeValidator Methods
RichTextImageSizeValidator Class See Also Send Feedback

The RichTextImageSizeValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

RichTextImageSizeValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
RichTextImageSizeValidator..::..Evaluate Method
RichTextImageSizeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

RichTextImageSizeValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
RichTextImageSizeValidator..::..GetMaxValidatorResult Method
RichTextImageSizeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

RichTextImageSizeValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


RichTextImageSizeValidator Properties

[image] [image]

Sitecore 6.4.1 API
RichTextImageSizeValidator Properties
RichTextImageSizeValidator Class See Also Send Feedback

The RichTextImageSizeValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

RichTextImageSizeValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
RichTextImageSizeValidator..::..Name Property
RichTextImageSizeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The validator name.

See Also

RichTextImageSizeValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


ScriptCodeValidator Class

[image]

Sitecore 6.4.1 API
ScriptCodeValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class ScriptCodeValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class ScriptCodeValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class ScriptCodeValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.FieldValidators..::..ScriptCodeValidator

See Also

ScriptCodeValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


ScriptCodeValidator Members

[image] [image]

Sitecore 6.4.1 API
ScriptCodeValidator Members
ScriptCodeValidator Class Constructors Methods Properties See Also Send Feedback

The ScriptCodeValidator type exposes the following members.

Constructors

 | Name | Description
Public method | ScriptCodeValidator()()()() | Initializes a new instance of the ScriptCodeValidator class.
Public method | ScriptCodeValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the ScriptCodeValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

ScriptCodeValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


ScriptCodeValidator Constructor

[image] [image]

Sitecore 6.4.1 API
ScriptCodeValidator Constructor
ScriptCodeValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScriptCodeValidator()()()() | Initializes a new instance of the ScriptCodeValidator class.
Public method | ScriptCodeValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the ScriptCodeValidator class.

See Also

ScriptCodeValidator Class
ScriptCodeValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


ScriptCodeValidator Constructor

[image]

Sitecore 6.4.1 API
ScriptCodeValidator Constructor
ScriptCodeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ScriptCodeValidator()
Visual Basic
Public Sub New
Visual C++
public:
ScriptCodeValidator()

See Also

ScriptCodeValidator Class
ScriptCodeValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


ScriptCodeValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
ScriptCodeValidator Constructor (SerializationInfo, StreamingContext)
ScriptCodeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ScriptCodeValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
ScriptCodeValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

ScriptCodeValidator Class
ScriptCodeValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


ScriptCodeValidator Methods

[image] [image]

Sitecore 6.4.1 API
ScriptCodeValidator Methods
ScriptCodeValidator Class See Also Send Feedback

The ScriptCodeValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

ScriptCodeValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
ScriptCodeValidator..::..Evaluate Method
ScriptCodeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

ScriptCodeValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
ScriptCodeValidator..::..GetMaxValidatorResult Method
ScriptCodeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

ScriptCodeValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


ScriptCodeValidator Properties

[image] [image]

Sitecore 6.4.1 API
ScriptCodeValidator Properties
ScriptCodeValidator Class See Also Send Feedback

The ScriptCodeValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

ScriptCodeValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
ScriptCodeValidator..::..Name Property
ScriptCodeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The validator name.

See Also

ScriptCodeValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


SitecoreCommandValidator Class

[image]

Sitecore 6.4.1 API
SitecoreCommandValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class SitecoreCommandValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class SitecoreCommandValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class SitecoreCommandValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.FieldValidators..::..SitecoreCommandValidator

See Also

SitecoreCommandValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


SitecoreCommandValidator Constructor

[image] [image]

Sitecore 6.4.1 API
SitecoreCommandValidator Constructor
SitecoreCommandValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SitecoreCommandValidator()()()() | Initializes a new instance of the SitecoreCommandValidator class. Initializes a new instance of the DateTimeRangeValidator class.
Public method | SitecoreCommandValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the SitecoreCommandValidator class. Initializes a new instance of the DateTimeRangeValidator class.

See Also

SitecoreCommandValidator Class
SitecoreCommandValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


SitecoreCommandValidator Constructor

[image]

Sitecore 6.4.1 API
SitecoreCommandValidator Constructor
SitecoreCommandValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SitecoreCommandValidator()
Visual Basic
Public Sub New
Visual C++
public:
SitecoreCommandValidator()

See Also

SitecoreCommandValidator Class
SitecoreCommandValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


SitecoreCommandValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
SitecoreCommandValidator Constructor (SerializationInfo, StreamingContext)
SitecoreCommandValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SitecoreCommandValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
SitecoreCommandValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

SitecoreCommandValidator Class
SitecoreCommandValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


SitecoreCommandValidator Methods

[image] [image]

Sitecore 6.4.1 API
SitecoreCommandValidator Methods
SitecoreCommandValidator Class See Also Send Feedback

The SitecoreCommandValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

SitecoreCommandValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
SitecoreCommandValidator..::..Evaluate Method
SitecoreCommandValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

SitecoreCommandValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
SitecoreCommandValidator..::..GetMaxValidatorResult Method
SitecoreCommandValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

SitecoreCommandValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


SitecoreCommandValidator Properties

[image] [image]

Sitecore 6.4.1 API
SitecoreCommandValidator Properties
SitecoreCommandValidator Class See Also Send Feedback

The SitecoreCommandValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

SitecoreCommandValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
SitecoreCommandValidator..::..Name Property
SitecoreCommandValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The name.

See Also

SitecoreCommandValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


SpellcheckValidator Class

[image]

Sitecore 6.4.1 API
SpellcheckValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class SpellcheckValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class SpellcheckValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class SpellcheckValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.FieldValidators..::..SpellcheckValidator

See Also

SpellcheckValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


SpellcheckValidator Members

[image] [image]

Sitecore 6.4.1 API
SpellcheckValidator Members
SpellcheckValidator Class Constructors Methods Properties See Also Send Feedback

The SpellcheckValidator type exposes the following members.

Constructors

 | Name | Description
Public method | SpellcheckValidator()()()() | Initializes a new instance of the SpellcheckValidator class.
Public method | SpellcheckValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the SpellcheckValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

SpellcheckValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


SpellcheckValidator Constructor

[image] [image]

Sitecore 6.4.1 API
SpellcheckValidator Constructor
SpellcheckValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SpellcheckValidator()()()() | Initializes a new instance of the SpellcheckValidator class.
Public method | SpellcheckValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the SpellcheckValidator class.

See Also

SpellcheckValidator Class
SpellcheckValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


SpellcheckValidator Constructor

[image]

Sitecore 6.4.1 API
SpellcheckValidator Constructor
SpellcheckValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SpellcheckValidator()
Visual Basic
Public Sub New
Visual C++
public:
SpellcheckValidator()

See Also

SpellcheckValidator Class
SpellcheckValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


SpellcheckValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
SpellcheckValidator Constructor (SerializationInfo, StreamingContext)
SpellcheckValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SpellcheckValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
SpellcheckValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The sream context.

See Also

SpellcheckValidator Class
SpellcheckValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


SpellcheckValidator Methods

[image] [image]

Sitecore 6.4.1 API
SpellcheckValidator Methods
SpellcheckValidator Class See Also Send Feedback

The SpellcheckValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

SpellcheckValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
SpellcheckValidator..::..Evaluate Method
SpellcheckValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

SpellcheckValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
SpellcheckValidator..::..GetMaxValidatorResult Method
SpellcheckValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

SpellcheckValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


SpellcheckValidator Properties

[image] [image]

Sitecore 6.4.1 API
SpellcheckValidator Properties
SpellcheckValidator Class See Also Send Feedback

The SpellcheckValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

SpellcheckValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
SpellcheckValidator..::..Name Property
SpellcheckValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The validator name.

See Also

SpellcheckValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


StartWithCapitalEndWithDotValidator Class

[image]

Sitecore 6.4.1 API
StartWithCapitalEndWithDotValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class StartWithCapitalEndWithDotValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class StartWithCapitalEndWithDotValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class StartWithCapitalEndWithDotValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.FieldValidators..::..StartWithCapitalEndWithDotValidator

See Also

StartWithCapitalEndWithDotValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


StartWithCapitalEndWithDotValidator Members

[image] [image]

Sitecore 6.4.1 API
StartWithCapitalEndWithDotValidator Members
StartWithCapitalEndWithDotValidator Class Constructors Methods Properties See Also Send Feedback

The StartWithCapitalEndWithDotValidator type exposes the following members.

Constructors

 | Name | Description
Public method | StartWithCapitalEndWithDotValidator()()()() | Initializes a new instance of the StartWithCapitalEndWithDotValidator class. Initializes a new instance of the DateTimeRangeValidator class.
Public method | StartWithCapitalEndWithDotValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the StartWithCapitalEndWithDotValidator class. Initializes a new instance of the DateTimeRangeValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

StartWithCapitalEndWithDotValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


StartWithCapitalEndWithDotValidator Constructor

[image] [image]

Sitecore 6.4.1 API
StartWithCapitalEndWithDotValidator Constructor
StartWithCapitalEndWithDotValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StartWithCapitalEndWithDotValidator()()()() | Initializes a new instance of the StartWithCapitalEndWithDotValidator class. Initializes a new instance of the DateTimeRangeValidator class.
Public method | StartWithCapitalEndWithDotValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the StartWithCapitalEndWithDotValidator class. Initializes a new instance of the DateTimeRangeValidator class.

See Also

StartWithCapitalEndWithDotValidator Class
StartWithCapitalEndWithDotValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


StartWithCapitalEndWithDotValidator Constructor

[image]

Sitecore 6.4.1 API
StartWithCapitalEndWithDotValidator Constructor
StartWithCapitalEndWithDotValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StartWithCapitalEndWithDotValidator()
Visual Basic
Public Sub New
Visual C++
public:
StartWithCapitalEndWithDotValidator()

See Also

StartWithCapitalEndWithDotValidator Class
StartWithCapitalEndWithDotValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


StartWithCapitalEndWithDotValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
StartWithCapitalEndWithDotValidator Constructor (SerializationInfo, StreamingContext)
StartWithCapitalEndWithDotValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StartWithCapitalEndWithDotValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
StartWithCapitalEndWithDotValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

StartWithCapitalEndWithDotValidator Class
StartWithCapitalEndWithDotValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


StartWithCapitalEndWithDotValidator Methods

[image] [image]

Sitecore 6.4.1 API
StartWithCapitalEndWithDotValidator Methods
StartWithCapitalEndWithDotValidator Class See Also Send Feedback

The StartWithCapitalEndWithDotValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

StartWithCapitalEndWithDotValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
StartWithCapitalEndWithDotValidator..::..Evaluate Method
StartWithCapitalEndWithDotValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

StartWithCapitalEndWithDotValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
StartWithCapitalEndWithDotValidator..::..GetMaxValidatorResult Method
StartWithCapitalEndWithDotValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

StartWithCapitalEndWithDotValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


StartWithCapitalEndWithDotValidator Properties

[image] [image]

Sitecore 6.4.1 API
StartWithCapitalEndWithDotValidator Properties
StartWithCapitalEndWithDotValidator Class See Also Send Feedback

The StartWithCapitalEndWithDotValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

StartWithCapitalEndWithDotValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
StartWithCapitalEndWithDotValidator..::..Name Property
StartWithCapitalEndWithDotValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The name.

See Also

StartWithCapitalEndWithDotValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


StringEnumValidator Class

[image]

Sitecore 6.4.1 API
StringEnumValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class StringEnumValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class StringEnumValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class StringEnumValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.FieldValidators..::..StringEnumValidator

See Also

StringEnumValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


StringEnumValidator Members

[image] [image]

Sitecore 6.4.1 API
StringEnumValidator Members
StringEnumValidator Class Constructors Methods Properties See Also Send Feedback

The StringEnumValidator type exposes the following members.

Constructors

 | Name | Description
Public method | StringEnumValidator()()()() | Initializes a new instance of the StringEnumValidator class. Initializes a new instance of the DateTimeRangeValidator class.
Public method | StringEnumValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the StringEnumValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

StringEnumValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


StringEnumValidator Constructor

[image]

Sitecore 6.4.1 API
StringEnumValidator Constructor
StringEnumValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StringEnumValidator()
Visual Basic
Public Sub New
Visual C++
public:
StringEnumValidator()

See Also

StringEnumValidator Class
StringEnumValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


StringEnumValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
StringEnumValidator Constructor (SerializationInfo, StreamingContext)
StringEnumValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StringEnumValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
StringEnumValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The validator info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

StringEnumValidator Class
StringEnumValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


StringEnumValidator Methods

[image] [image]

Sitecore 6.4.1 API
StringEnumValidator Methods
StringEnumValidator Class See Also Send Feedback

The StringEnumValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

StringEnumValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
StringEnumValidator..::..Evaluate Method
StringEnumValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

StringEnumValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


StringEnumValidator Properties

[image] [image]

Sitecore 6.4.1 API
StringEnumValidator Properties
StringEnumValidator Class See Also Send Feedback

The StringEnumValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

StringEnumValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
StringEnumValidator..::..Name Property
StringEnumValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The validator name.

See Also

StringEnumValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


TypeAndAssemblyValidator Class

[image]

Sitecore 6.4.1 API
TypeAndAssemblyValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class TypeAndAssemblyValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class TypeAndAssemblyValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class TypeAndAssemblyValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.FieldValidators..::..TypeAndAssemblyValidator

See Also

TypeAndAssemblyValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


TypeAndAssemblyValidator Members

[image] [image]

Sitecore 6.4.1 API
TypeAndAssemblyValidator Members
TypeAndAssemblyValidator Class Constructors Methods Properties See Also Send Feedback

The TypeAndAssemblyValidator type exposes the following members.

Constructors

 | Name | Description
Public method | TypeAndAssemblyValidator()()()() | Initializes a new instance of the TypeAndAssemblyValidator class.
Public method | TypeAndAssemblyValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the TypeAndAssemblyValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

TypeAndAssemblyValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


TypeAndAssemblyValidator Constructor

[image] [image]

Sitecore 6.4.1 API
TypeAndAssemblyValidator Constructor
TypeAndAssemblyValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TypeAndAssemblyValidator()()()() | Initializes a new instance of the TypeAndAssemblyValidator class.
Public method | TypeAndAssemblyValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the TypeAndAssemblyValidator class.

See Also

TypeAndAssemblyValidator Class
TypeAndAssemblyValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


TypeAndAssemblyValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
TypeAndAssemblyValidator Constructor (SerializationInfo, StreamingContext)
TypeAndAssemblyValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TypeAndAssemblyValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
TypeAndAssemblyValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

TypeAndAssemblyValidator Class
TypeAndAssemblyValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


TypeAndAssemblyValidator Methods

[image] [image]

Sitecore 6.4.1 API
TypeAndAssemblyValidator Methods
TypeAndAssemblyValidator Class See Also Send Feedback

The TypeAndAssemblyValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

TypeAndAssemblyValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
TypeAndAssemblyValidator..::..Evaluate Method
TypeAndAssemblyValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

TypeAndAssemblyValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
TypeAndAssemblyValidator..::..GetMaxValidatorResult Method
TypeAndAssemblyValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

TypeAndAssemblyValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


TypeAndAssemblyValidator Properties

[image] [image]

Sitecore 6.4.1 API
TypeAndAssemblyValidator Properties
TypeAndAssemblyValidator Class See Also Send Feedback

The TypeAndAssemblyValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

TypeAndAssemblyValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
TypeAndAssemblyValidator..::..Name Property
TypeAndAssemblyValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The validator name.

See Also

TypeAndAssemblyValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


UpperCaseValidator Class

[image]

Sitecore 6.4.1 API
UpperCaseValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class UpperCaseValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class UpperCaseValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class UpperCaseValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.FieldValidators..::..UpperCaseValidator

See Also

UpperCaseValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


UpperCaseValidator Members

[image] [image]

Sitecore 6.4.1 API
UpperCaseValidator Members
UpperCaseValidator Class Constructors Methods Properties See Also Send Feedback

The UpperCaseValidator type exposes the following members.

Constructors

 | Name | Description
Public method | UpperCaseValidator()()()() | Initializes a new instance of the UpperCaseValidator class. Initializes a new instance of the DateTimeRangeValidator class.
Public method | UpperCaseValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the UpperCaseValidator class. Initializes a new instance of the DateTimeRangeValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

UpperCaseValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


UpperCaseValidator Constructor

[image] [image]

Sitecore 6.4.1 API
UpperCaseValidator Constructor
UpperCaseValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UpperCaseValidator()()()() | Initializes a new instance of the UpperCaseValidator class. Initializes a new instance of the DateTimeRangeValidator class.
Public method | UpperCaseValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the UpperCaseValidator class. Initializes a new instance of the DateTimeRangeValidator class.

See Also

UpperCaseValidator Class
UpperCaseValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


UpperCaseValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
UpperCaseValidator Constructor (SerializationInfo, StreamingContext)
UpperCaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UpperCaseValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
UpperCaseValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

UpperCaseValidator Class
UpperCaseValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


UpperCaseValidator Methods

[image] [image]

Sitecore 6.4.1 API
UpperCaseValidator Methods
UpperCaseValidator Class See Also Send Feedback

The UpperCaseValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

UpperCaseValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
UpperCaseValidator..::..Evaluate Method
UpperCaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

UpperCaseValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
UpperCaseValidator..::..GetMaxValidatorResult Method
UpperCaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

UpperCaseValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


UpperCaseValidator Properties

[image] [image]

Sitecore 6.4.1 API
UpperCaseValidator Properties
UpperCaseValidator Class See Also Send Feedback

The UpperCaseValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

UpperCaseValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
UpperCaseValidator..::..Name Property
UpperCaseValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The name.

See Also

UpperCaseValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


W3CXhtmlValidator Class

[image]

Sitecore 6.4.1 API
W3CXhtmlValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class W3CXhtmlValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class W3CXhtmlValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class W3CXhtmlValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.FieldValidators..::..W3CXhtmlValidator

See Also

W3CXhtmlValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


W3CXhtmlValidator Members

[image] [image]

Sitecore 6.4.1 API
W3CXhtmlValidator Members
W3CXhtmlValidator Class Constructors Methods Properties See Also Send Feedback

The W3CXhtmlValidator type exposes the following members.

Constructors

 | Name | Description
Public method | W3CXhtmlValidator()()()() | Initializes a new instance of the W3CXhtmlValidator class. Initializes a new instance of the BaseValidator class.
Protected method | W3CXhtmlValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the W3CXhtmlValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides BaseValidator..::..GetObjectData(SerializationInfo, StreamingContext).)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Report | Gets or sets the report.
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

W3CXhtmlValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


W3CXhtmlValidator Constructor

[image] [image]

Sitecore 6.4.1 API
W3CXhtmlValidator Constructor
W3CXhtmlValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | W3CXhtmlValidator()()()() | Initializes a new instance of the W3CXhtmlValidator class. Initializes a new instance of the BaseValidator class.
Protected method | W3CXhtmlValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the W3CXhtmlValidator class.

See Also

W3CXhtmlValidator Class
W3CXhtmlValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


W3CXhtmlValidator Constructor

[image]

Sitecore 6.4.1 API
W3CXhtmlValidator Constructor
W3CXhtmlValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public W3CXhtmlValidator()
Visual Basic
Public Sub New
Visual C++
public:
W3CXhtmlValidator()

See Also

W3CXhtmlValidator Class
W3CXhtmlValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


W3CXhtmlValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
W3CXhtmlValidator Constructor (SerializationInfo, StreamingContext)
W3CXhtmlValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected W3CXhtmlValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
W3CXhtmlValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

W3CXhtmlValidator Class
W3CXhtmlValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
W3CXhtmlValidator..::..Evaluate Method
W3CXhtmlValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

W3CXhtmlValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
W3CXhtmlValidator..::..GetMaxValidatorResult Method
W3CXhtmlValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

W3CXhtmlValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


W3CXhtmlValidator Properties

[image] [image]

Sitecore 6.4.1 API
W3CXhtmlValidator Properties
W3CXhtmlValidator Class See Also Send Feedback

The W3CXhtmlValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Report | Gets or sets the report.
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

W3CXhtmlValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
W3CXhtmlValidator..::..Name Property
W3CXhtmlValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The validator name.

See Also

W3CXhtmlValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Report Property

[image]

Sitecore 6.4.1 API
W3CXhtmlValidator..::..Report Property
W3CXhtmlValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Report { get; set; }
Visual Basic
Public Property Report As String
    Get
    Set
Visual C++
public:
property String^ Report {
    String^ get ();
    void set (String^ value);
}

Field Value

The report.

See Also

W3CXhtmlValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


XhtmlValidator Class

[image]

Sitecore 6.4.1 API
XhtmlValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class XhtmlValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class XhtmlValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class XhtmlValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.FieldValidators..::..XhtmlValidator

See Also

XhtmlValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


XhtmlValidator Members

[image] [image]

Sitecore 6.4.1 API
XhtmlValidator Members
XhtmlValidator Class Constructors Methods Properties See Also Send Feedback

The XhtmlValidator type exposes the following members.

Constructors

 | Name | Description
Public method | XhtmlValidator()()()() | Initializes a new instance of the XhtmlValidator class.
Public method | XhtmlValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the XhtmlValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

XhtmlValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


XhtmlValidator Constructor

[image] [image]

Sitecore 6.4.1 API
XhtmlValidator Constructor
XhtmlValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | XhtmlValidator()()()() | Initializes a new instance of the XhtmlValidator class.
Public method | XhtmlValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the XhtmlValidator class.

See Also

XhtmlValidator Class
XhtmlValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


XhtmlValidator Constructor

[image]

Sitecore 6.4.1 API
XhtmlValidator Constructor
XhtmlValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public XhtmlValidator()
Visual Basic
Public Sub New
Visual C++
public:
XhtmlValidator()

See Also

XhtmlValidator Class
XhtmlValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


XhtmlValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
XhtmlValidator Constructor (SerializationInfo, StreamingContext)
XhtmlValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public XhtmlValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
XhtmlValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

XhtmlValidator Class
XhtmlValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


XhtmlValidator Methods

[image] [image]

Sitecore 6.4.1 API
XhtmlValidator Methods
XhtmlValidator Class See Also Send Feedback

The XhtmlValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

XhtmlValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
XhtmlValidator..::..Evaluate Method
XhtmlValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

XhtmlValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
XhtmlValidator..::..GetMaxValidatorResult Method
XhtmlValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

XhtmlValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


XhtmlValidator Properties

[image] [image]

Sitecore 6.4.1 API
XhtmlValidator Properties
XhtmlValidator Class See Also Send Feedback

The XhtmlValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

XhtmlValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
XhtmlValidator..::..Name Property
XhtmlValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The validator name.

See Also

XhtmlValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


XmlValidator Class

[image]

Sitecore 6.4.1 API
XmlValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class XmlValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class XmlValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class XmlValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.FieldValidators..::..XmlValidator

See Also

XmlValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


XmlValidator Members

[image] [image]

Sitecore 6.4.1 API
XmlValidator Members
XmlValidator Class Constructors Methods Properties See Also Send Feedback

The XmlValidator type exposes the following members.

Constructors

 | Name | Description
Public method | XmlValidator()()()() | Initializes a new instance of the XmlValidator class. Initializes a new instance of the DateTimeRangeValidator class.
Public method | XmlValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the XmlValidator class. Initializes a new instance of the DateTimeRangeValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

XmlValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


XmlValidator Constructor

[image] [image]

Sitecore 6.4.1 API
XmlValidator Constructor
XmlValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | XmlValidator()()()() | Initializes a new instance of the XmlValidator class. Initializes a new instance of the DateTimeRangeValidator class.
Public method | XmlValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the XmlValidator class. Initializes a new instance of the DateTimeRangeValidator class.

See Also

XmlValidator Class
XmlValidator Members
Sitecore.Data.Validators.FieldValidators Namespace


XmlValidator Constructor

[image]

Sitecore 6.4.1 API
XmlValidator Constructor
XmlValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public XmlValidator()
Visual Basic
Public Sub New
Visual C++
public:
XmlValidator()

See Also

XmlValidator Class
XmlValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


XmlValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
XmlValidator Constructor (SerializationInfo, StreamingContext)
XmlValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public XmlValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
XmlValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

XmlValidator Class
XmlValidator Overload
Sitecore.Data.Validators.FieldValidators Namespace


XmlValidator Methods

[image] [image]

Sitecore 6.4.1 API
XmlValidator Methods
XmlValidator Class See Also Send Feedback

The XmlValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

XmlValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
XmlValidator..::..Evaluate Method
XmlValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

XmlValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
XmlValidator..::..GetMaxValidatorResult Method
XmlValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

XmlValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
XmlValidator..::..Name Property
XmlValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.FieldValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The name.

See Also

XmlValidator Class
Sitecore.Data.Validators.FieldValidators Namespace


Sitecore.Data.Validators.ItemValidators Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Data.Validators.ItemValidators Namespace
Send Feedback

Classes

 | Class | Description
Public class | BrokenLinkValidator | Implements an item validator that checks that no duplicate names appears on the same level.
Public class | DateRangeValidator | Implements an item validator that checks a date range.
Public class | DuplicateNameValidator | Implements an item validator that checks that no duplicate names appears on the same level.
Public class | DuplicateSortOrderValidator | Implements an item validator that checks that no duplicate names appears on the same level.
Public class | FullPageXHtmlValidator | Implements an item validator that checks that no duplicate names appears on the same level.
Public class | ItemHasSubItemsButNoInsertOptionsValidator | Implements an item validator that checks that if an item has subitems but no insert options.
Public class | ItemHasSubItemsThatAreNotInInsertOptionsValidator | Implements an item validator that checks that if an item has subitems but no insert options.
Public class | ItemIsNotReferencedValidator | Defines the item is not referenced validator class.
Public class | LockedByNonExistingUserValidator | Implements an item validator that checks a date range.
Public class | MediaSizeValidator | Implements an item validator that checks that no duplicate names appears on the same level.
Public class | Notifications | Defines the notifications class.
Public class | NotSerializedValidator | Implements an item validator that checks that if an item has subitems but no insert options.
Public class | OwnedByNonExistingUserValidator | Implements an item validator that checks a date range.
Public class | PublishUnpublishDateRangeValidator | Defines the publish unpublish date range validator class.
Public class | RadioCheckBoxValidator | Implements an item validator that checks that no duplicate names appears on the same level.
Public class | ReminderArchiveDateRangeValidator | Defines the valid reminder/archive date range validator class.
Public class | RuleValidator | Implements an item validator that runs rules.
Public class | StandardValueHasNameMacroValidator | Implements an item validator that checks that if an item has subitems but no insert options.
Public class | UrlCharacterValidator | Implements an item validator that checks that no duplicate names appears on the same level.
Public class | ValidationRulesValidator | Implements an item validator that checks that if an item has subitems but no insert options.
Public class | ValidFromValidToDateRangeValidator | Defines the valid from/valid to date range validator class.
Public class | WorkflowFinalStateValidator | Implements an item validator that checks that no duplicate names appears on the same level.


BrokenLinkValidator Class

[image]

Sitecore 6.4.1 API
BrokenLinkValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class BrokenLinkValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class BrokenLinkValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class BrokenLinkValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.ItemValidators..::..BrokenLinkValidator

See Also

BrokenLinkValidator Members
Sitecore.Data.Validators.ItemValidators Namespace


BrokenLinkValidator Members

[image] [image]

Sitecore 6.4.1 API
BrokenLinkValidator Members
BrokenLinkValidator Class Constructors Methods Properties See Also Send Feedback

The BrokenLinkValidator type exposes the following members.

Constructors

 | Name | Description
Public method | BrokenLinkValidator()()()() | Initializes a new instance of the BrokenLinkValidator class.
Public method | BrokenLinkValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the BrokenLinkValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

BrokenLinkValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


BrokenLinkValidator Constructor

[image] [image]

Sitecore 6.4.1 API
BrokenLinkValidator Constructor
BrokenLinkValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BrokenLinkValidator()()()() | Initializes a new instance of the BrokenLinkValidator class.
Public method | BrokenLinkValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the BrokenLinkValidator class.

See Also

BrokenLinkValidator Class
BrokenLinkValidator Members
Sitecore.Data.Validators.ItemValidators Namespace


BrokenLinkValidator Constructor

[image]

Sitecore 6.4.1 API
BrokenLinkValidator Constructor
BrokenLinkValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BrokenLinkValidator()
Visual Basic
Public Sub New
Visual C++
public:
BrokenLinkValidator()

See Also

BrokenLinkValidator Class
BrokenLinkValidator Overload
Sitecore.Data.Validators.ItemValidators Namespace


BrokenLinkValidator Methods

[image] [image]

Sitecore 6.4.1 API
BrokenLinkValidator Methods
BrokenLinkValidator Class See Also Send Feedback

The BrokenLinkValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

BrokenLinkValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
BrokenLinkValidator..::..GetMaxValidatorResult Method
BrokenLinkValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

BrokenLinkValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


BrokenLinkValidator Properties

[image] [image]

Sitecore 6.4.1 API
BrokenLinkValidator Properties
BrokenLinkValidator Class See Also Send Feedback

The BrokenLinkValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

BrokenLinkValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
BrokenLinkValidator..::..Name Property
BrokenLinkValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The validator name.

See Also

BrokenLinkValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


DateRangeValidator Class

[image]

Sitecore 6.4.1 API
DateRangeValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public abstract class DateRangeValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public MustInherit Class DateRangeValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class DateRangeValidator abstract : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.ItemValidators..::..DateRangeValidator
Sitecore.Data.Validators.ItemValidators..::..PublishUnpublishDateRangeValidator
Sitecore.Data.Validators.ItemValidators..::..ReminderArchiveDateRangeValidator
Sitecore.Data.Validators.ItemValidators..::..ValidFromValidToDateRangeValidator

See Also

DateRangeValidator Members
Sitecore.Data.Validators.ItemValidators Namespace


DateRangeValidator Constructor

[image] [image]

Sitecore 6.4.1 API
DateRangeValidator Constructor
DateRangeValidator Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | DateRangeValidator()()()() | Initializes a new instance of the DateRangeValidator class.
Protected method | DateRangeValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the DateRangeValidator class.

See Also

DateRangeValidator Class
DateRangeValidator Members
Sitecore.Data.Validators.ItemValidators Namespace


DateRangeValidator Constructor

[image]

Sitecore 6.4.1 API
DateRangeValidator Constructor
DateRangeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected DateRangeValidator()
Visual Basic
Protected Sub New
Visual C++
protected:
DateRangeValidator()

See Also

DateRangeValidator Class
DateRangeValidator Overload
Sitecore.Data.Validators.ItemValidators Namespace


DateRangeValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
DateRangeValidator Constructor (SerializationInfo, StreamingContext)
DateRangeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected DateRangeValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
DateRangeValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

DateRangeValidator Class
DateRangeValidator Overload
Sitecore.Data.Validators.ItemValidators Namespace


DateRangeValidator Methods

[image] [image]

Sitecore 6.4.1 API
DateRangeValidator Methods
DateRangeValidator Class See Also Send Feedback

The DateRangeValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

DateRangeValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
DateRangeValidator..::..Evaluate Method
DateRangeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

DateRangeValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
DateRangeValidator..::..GetMaxValidatorResult Method
DateRangeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

DateRangeValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


DateRangeValidator Properties

[image] [image]

Sitecore 6.4.1 API
DateRangeValidator Properties
DateRangeValidator Class See Also Send Feedback

The DateRangeValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Protected property | ErrorText | Gets or sets the error text.
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Protected property | Field1 | Gets or sets the field1.
Protected property | Field2 | Gets or sets the field2.
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Inherited from BaseValidator.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

DateRangeValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


ErrorText Property

[image]

Sitecore 6.4.1 API
DateRangeValidator..::..ErrorText Property
DateRangeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected string ErrorText { get; set; }
Visual Basic
Protected Property ErrorText As String
    Get
    Set
Visual C++
protected:
property String^ ErrorText {
    String^ get ();
    void set (String^ value);
}

Field Value

The error text.

See Also

DateRangeValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


Field1 Property

[image]

Sitecore 6.4.1 API
DateRangeValidator..::..Field1 Property
DateRangeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected string Field1 { get; set; }
Visual Basic
Protected Property Field1 As String
    Get
    Set
Visual C++
protected:
property String^ Field1 {
    String^ get ();
    void set (String^ value);
}

Field Value

The field1.

See Also

DateRangeValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


Field2 Property

[image]

Sitecore 6.4.1 API
DateRangeValidator..::..Field2 Property
DateRangeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected string Field2 { get; set; }
Visual Basic
Protected Property Field2 As String
    Get
    Set
Visual C++
protected:
property String^ Field2 {
    String^ get ();
    void set (String^ value);
}

Field Value

The field2.

See Also

DateRangeValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


DuplicateNameValidator Class

[image]

Sitecore 6.4.1 API
DuplicateNameValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class DuplicateNameValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class DuplicateNameValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class DuplicateNameValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.ItemValidators..::..DuplicateNameValidator

See Also

DuplicateNameValidator Members
Sitecore.Data.Validators.ItemValidators Namespace


DuplicateNameValidator Members

[image] [image]

Sitecore 6.4.1 API
DuplicateNameValidator Members
DuplicateNameValidator Class Constructors Methods Properties See Also Send Feedback

The DuplicateNameValidator type exposes the following members.

Constructors

 | Name | Description
Public method | DuplicateNameValidator()()()() | Initializes a new instance of the DuplicateNameValidator class.
Public method | DuplicateNameValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the DuplicateNameValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

DuplicateNameValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


DuplicateNameValidator Constructor

[image] [image]

Sitecore 6.4.1 API
DuplicateNameValidator Constructor
DuplicateNameValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DuplicateNameValidator()()()() | Initializes a new instance of the DuplicateNameValidator class.
Public method | DuplicateNameValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the DuplicateNameValidator class.

See Also

DuplicateNameValidator Class
DuplicateNameValidator Members
Sitecore.Data.Validators.ItemValidators Namespace


DuplicateNameValidator Constructor

[image]

Sitecore 6.4.1 API
DuplicateNameValidator Constructor
DuplicateNameValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DuplicateNameValidator()
Visual Basic
Public Sub New
Visual C++
public:
DuplicateNameValidator()

See Also

DuplicateNameValidator Class
DuplicateNameValidator Overload
Sitecore.Data.Validators.ItemValidators Namespace


DuplicateNameValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
DuplicateNameValidator Constructor (SerializationInfo, StreamingContext)
DuplicateNameValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DuplicateNameValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
DuplicateNameValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

DuplicateNameValidator Class
DuplicateNameValidator Overload
Sitecore.Data.Validators.ItemValidators Namespace


DuplicateNameValidator Methods

[image] [image]

Sitecore 6.4.1 API
DuplicateNameValidator Methods
DuplicateNameValidator Class See Also Send Feedback

The DuplicateNameValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

DuplicateNameValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
DuplicateNameValidator..::..Evaluate Method
DuplicateNameValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

DuplicateNameValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
DuplicateNameValidator..::..GetMaxValidatorResult Method
DuplicateNameValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

DuplicateNameValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


DuplicateNameValidator Properties

[image] [image]

Sitecore 6.4.1 API
DuplicateNameValidator Properties
DuplicateNameValidator Class See Also Send Feedback

The DuplicateNameValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

DuplicateNameValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
DuplicateNameValidator..::..Name Property
DuplicateNameValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The serialization name.

See Also

DuplicateNameValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


DuplicateSortOrderValidator Members

[image] [image]

Sitecore 6.4.1 API
DuplicateSortOrderValidator Members
DuplicateSortOrderValidator Class Constructors Methods Properties See Also Send Feedback

The DuplicateSortOrderValidator type exposes the following members.

Constructors

 | Name | Description
Public method | DuplicateSortOrderValidator()()()() | Initializes a new instance of the DuplicateSortOrderValidator class.
Public method | DuplicateSortOrderValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the DuplicateSortOrderValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

DuplicateSortOrderValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


DuplicateSortOrderValidator Constructor

[image] [image]

Sitecore 6.4.1 API
DuplicateSortOrderValidator Constructor
DuplicateSortOrderValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DuplicateSortOrderValidator()()()() | Initializes a new instance of the DuplicateSortOrderValidator class.
Public method | DuplicateSortOrderValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the DuplicateSortOrderValidator class.

See Also

DuplicateSortOrderValidator Class
DuplicateSortOrderValidator Members
Sitecore.Data.Validators.ItemValidators Namespace


DuplicateSortOrderValidator Constructor

[image]

Sitecore 6.4.1 API
DuplicateSortOrderValidator Constructor
DuplicateSortOrderValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DuplicateSortOrderValidator()
Visual Basic
Public Sub New
Visual C++
public:
DuplicateSortOrderValidator()

See Also

DuplicateSortOrderValidator Class
DuplicateSortOrderValidator Overload
Sitecore.Data.Validators.ItemValidators Namespace


DuplicateSortOrderValidator Methods

[image] [image]

Sitecore 6.4.1 API
DuplicateSortOrderValidator Methods
DuplicateSortOrderValidator Class See Also Send Feedback

The DuplicateSortOrderValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

DuplicateSortOrderValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
DuplicateSortOrderValidator..::..Evaluate Method
DuplicateSortOrderValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

DuplicateSortOrderValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
DuplicateSortOrderValidator..::..GetMaxValidatorResult Method
DuplicateSortOrderValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

DuplicateSortOrderValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


DuplicateSortOrderValidator Properties

[image] [image]

Sitecore 6.4.1 API
DuplicateSortOrderValidator Properties
DuplicateSortOrderValidator Class See Also Send Feedback

The DuplicateSortOrderValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

DuplicateSortOrderValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
DuplicateSortOrderValidator..::..Name Property
DuplicateSortOrderValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The name.

See Also

DuplicateSortOrderValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


FullPageXHtmlValidator Class

[image]

Sitecore 6.4.1 API
FullPageXHtmlValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class FullPageXHtmlValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class FullPageXHtmlValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class FullPageXHtmlValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.ItemValidators..::..FullPageXHtmlValidator

See Also

FullPageXHtmlValidator Members
Sitecore.Data.Validators.ItemValidators Namespace


FullPageXHtmlValidator Members

[image] [image]

Sitecore 6.4.1 API
FullPageXHtmlValidator Members
FullPageXHtmlValidator Class Constructors Methods Properties See Also Send Feedback

The FullPageXHtmlValidator type exposes the following members.

Constructors

 | Name | Description
Public method | FullPageXHtmlValidator()()()() | Initializes a new instance of the FullPageXHtmlValidator class. Initializes a new instance of the BrokenLinkValidator class.
Public method | FullPageXHtmlValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the FullPageXHtmlValidator class. Initializes a new instance of the BrokenLinkValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

FullPageXHtmlValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


FullPageXHtmlValidator Constructor

[image] [image]

Sitecore 6.4.1 API
FullPageXHtmlValidator Constructor
FullPageXHtmlValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FullPageXHtmlValidator()()()() | Initializes a new instance of the FullPageXHtmlValidator class. Initializes a new instance of the BrokenLinkValidator class.
Public method | FullPageXHtmlValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the FullPageXHtmlValidator class. Initializes a new instance of the BrokenLinkValidator class.

See Also

FullPageXHtmlValidator Class
FullPageXHtmlValidator Members
Sitecore.Data.Validators.ItemValidators Namespace


FullPageXHtmlValidator Constructor

[image]

Sitecore 6.4.1 API
FullPageXHtmlValidator Constructor
FullPageXHtmlValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FullPageXHtmlValidator()
Visual Basic
Public Sub New
Visual C++
public:
FullPageXHtmlValidator()

See Also

FullPageXHtmlValidator Class
FullPageXHtmlValidator Overload
Sitecore.Data.Validators.ItemValidators Namespace


FullPageXHtmlValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
FullPageXHtmlValidator Constructor (SerializationInfo, StreamingContext)
FullPageXHtmlValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FullPageXHtmlValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
FullPageXHtmlValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

FullPageXHtmlValidator Class
FullPageXHtmlValidator Overload
Sitecore.Data.Validators.ItemValidators Namespace


FullPageXHtmlValidator Methods

[image] [image]

Sitecore 6.4.1 API
FullPageXHtmlValidator Methods
FullPageXHtmlValidator Class See Also Send Feedback

The FullPageXHtmlValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

FullPageXHtmlValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
FullPageXHtmlValidator..::..Evaluate Method
FullPageXHtmlValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

FullPageXHtmlValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
FullPageXHtmlValidator..::..GetMaxValidatorResult Method
FullPageXHtmlValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is ValidatorResult.CriticalError or ValidatorResult.FatalError, the validator must have been evaluated before saving.

See Also

FullPageXHtmlValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


FullPageXHtmlValidator Properties

[image] [image]

Sitecore 6.4.1 API
FullPageXHtmlValidator Properties
FullPageXHtmlValidator Class See Also Send Feedback

The FullPageXHtmlValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

FullPageXHtmlValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
FullPageXHtmlValidator..::..Name Property
FullPageXHtmlValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The validator name.

See Also

FullPageXHtmlValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


ItemHasSubItemsButNoInsertOptionsValidator Class

[image]

Sitecore 6.4.1 API
ItemHasSubItemsButNoInsertOptionsValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class ItemHasSubItemsButNoInsertOptionsValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class ItemHasSubItemsButNoInsertOptionsValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class ItemHasSubItemsButNoInsertOptionsValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.ItemValidators..::..ItemHasSubItemsButNoInsertOptionsValidator

See Also

ItemHasSubItemsButNoInsertOptionsValidator Members
Sitecore.Data.Validators.ItemValidators Namespace


ItemHasSubItemsButNoInsertOptionsValidator Members

[image] [image]

Sitecore 6.4.1 API
ItemHasSubItemsButNoInsertOptionsValidator Members
ItemHasSubItemsButNoInsertOptionsValidator Class Constructors Methods Properties See Also Send Feedback

The ItemHasSubItemsButNoInsertOptionsValidator type exposes the following members.

Constructors

 | Name | Description
Public method | ItemHasSubItemsButNoInsertOptionsValidator()()()() | Initializes a new instance of the ItemHasSubItemsButNoInsertOptionsValidator class.
Public method | ItemHasSubItemsButNoInsertOptionsValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the ItemHasSubItemsButNoInsertOptionsValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

ItemHasSubItemsButNoInsertOptionsValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


ItemHasSubItemsButNoInsertOptionsValidator Constructor

[image] [image]

Sitecore 6.4.1 API
ItemHasSubItemsButNoInsertOptionsValidator Constructor
ItemHasSubItemsButNoInsertOptionsValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ItemHasSubItemsButNoInsertOptionsValidator()()()() | Initializes a new instance of the ItemHasSubItemsButNoInsertOptionsValidator class.
Public method | ItemHasSubItemsButNoInsertOptionsValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the ItemHasSubItemsButNoInsertOptionsValidator class.

See Also

ItemHasSubItemsButNoInsertOptionsValidator Class
ItemHasSubItemsButNoInsertOptionsValidator Members
Sitecore.Data.Validators.ItemValidators Namespace


ItemHasSubItemsButNoInsertOptionsValidator Constructor

[image]

Sitecore 6.4.1 API
ItemHasSubItemsButNoInsertOptionsValidator Constructor
ItemHasSubItemsButNoInsertOptionsValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemHasSubItemsButNoInsertOptionsValidator()
Visual Basic
Public Sub New
Visual C++
public:
ItemHasSubItemsButNoInsertOptionsValidator()

See Also

ItemHasSubItemsButNoInsertOptionsValidator Class
ItemHasSubItemsButNoInsertOptionsValidator Overload
Sitecore.Data.Validators.ItemValidators Namespace


ItemHasSubItemsButNoInsertOptionsValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
ItemHasSubItemsButNoInsertOptionsValidator Constructor (SerializationInfo, StreamingContext)
ItemHasSubItemsButNoInsertOptionsValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemHasSubItemsButNoInsertOptionsValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
ItemHasSubItemsButNoInsertOptionsValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

ItemHasSubItemsButNoInsertOptionsValidator Class
ItemHasSubItemsButNoInsertOptionsValidator Overload
Sitecore.Data.Validators.ItemValidators Namespace


ItemHasSubItemsButNoInsertOptionsValidator Methods

[image] [image]

Sitecore 6.4.1 API
ItemHasSubItemsButNoInsertOptionsValidator Methods
ItemHasSubItemsButNoInsertOptionsValidator Class See Also Send Feedback

The ItemHasSubItemsButNoInsertOptionsValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

ItemHasSubItemsButNoInsertOptionsValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
ItemHasSubItemsButNoInsertOptionsValidator..::..Evaluate Method
ItemHasSubItemsButNoInsertOptionsValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

ItemHasSubItemsButNoInsertOptionsValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
ItemHasSubItemsButNoInsertOptionsValidator..::..GetMaxValidatorResult Method
ItemHasSubItemsButNoInsertOptionsValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

ItemHasSubItemsButNoInsertOptionsValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


ItemHasSubItemsButNoInsertOptionsValidator Properties

[image] [image]

Sitecore 6.4.1 API
ItemHasSubItemsButNoInsertOptionsValidator Properties
ItemHasSubItemsButNoInsertOptionsValidator Class See Also Send Feedback

The ItemHasSubItemsButNoInsertOptionsValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

ItemHasSubItemsButNoInsertOptionsValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


ItemHasSubItemsThatAreNotInInsertOptionsValidator Class

[image]

Sitecore 6.4.1 API
ItemHasSubItemsThatAreNotInInsertOptionsValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class ItemHasSubItemsThatAreNotInInsertOptionsValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class ItemHasSubItemsThatAreNotInInsertOptionsValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class ItemHasSubItemsThatAreNotInInsertOptionsValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.ItemValidators..::..ItemHasSubItemsThatAreNotInInsertOptionsValidator

See Also

ItemHasSubItemsThatAreNotInInsertOptionsValidator Members
Sitecore.Data.Validators.ItemValidators Namespace


ItemHasSubItemsThatAreNotInInsertOptionsValidator Members

[image] [image]

Sitecore 6.4.1 API
ItemHasSubItemsThatAreNotInInsertOptionsValidator Members
ItemHasSubItemsThatAreNotInInsertOptionsValidator Class Constructors Methods Properties See Also Send Feedback

The ItemHasSubItemsThatAreNotInInsertOptionsValidator type exposes the following members.

Constructors

 | Name | Description
Public method | ItemHasSubItemsThatAreNotInInsertOptionsValidator()()()() | Initializes a new instance of the ItemHasSubItemsThatAreNotInInsertOptionsValidator class.
Public method | ItemHasSubItemsThatAreNotInInsertOptionsValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the ItemHasSubItemsThatAreNotInInsertOptionsValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

ItemHasSubItemsThatAreNotInInsertOptionsValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


ItemHasSubItemsThatAreNotInInsertOptionsValidator Constructor

[image] [image]

Sitecore 6.4.1 API
ItemHasSubItemsThatAreNotInInsertOptionsValidator Constructor
ItemHasSubItemsThatAreNotInInsertOptionsValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ItemHasSubItemsThatAreNotInInsertOptionsValidator()()()() | Initializes a new instance of the ItemHasSubItemsThatAreNotInInsertOptionsValidator class.
Public method | ItemHasSubItemsThatAreNotInInsertOptionsValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the ItemHasSubItemsThatAreNotInInsertOptionsValidator class.

See Also

ItemHasSubItemsThatAreNotInInsertOptionsValidator Class
ItemHasSubItemsThatAreNotInInsertOptionsValidator Members
Sitecore.Data.Validators.ItemValidators Namespace


ItemHasSubItemsThatAreNotInInsertOptionsValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
ItemHasSubItemsThatAreNotInInsertOptionsValidator Constructor (SerializationInfo, StreamingContext)
ItemHasSubItemsThatAreNotInInsertOptionsValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemHasSubItemsThatAreNotInInsertOptionsValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
ItemHasSubItemsThatAreNotInInsertOptionsValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

ItemHasSubItemsThatAreNotInInsertOptionsValidator Class
ItemHasSubItemsThatAreNotInInsertOptionsValidator Overload
Sitecore.Data.Validators.ItemValidators Namespace


ItemHasSubItemsThatAreNotInInsertOptionsValidator Methods

[image] [image]

Sitecore 6.4.1 API
ItemHasSubItemsThatAreNotInInsertOptionsValidator Methods
ItemHasSubItemsThatAreNotInInsertOptionsValidator Class See Also Send Feedback

The ItemHasSubItemsThatAreNotInInsertOptionsValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

ItemHasSubItemsThatAreNotInInsertOptionsValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
ItemHasSubItemsThatAreNotInInsertOptionsValidator..::..Evaluate Method
ItemHasSubItemsThatAreNotInInsertOptionsValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

ItemHasSubItemsThatAreNotInInsertOptionsValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


ItemHasSubItemsThatAreNotInInsertOptionsValidator Properties

[image] [image]

Sitecore 6.4.1 API
ItemHasSubItemsThatAreNotInInsertOptionsValidator Properties
ItemHasSubItemsThatAreNotInInsertOptionsValidator Class See Also Send Feedback

The ItemHasSubItemsThatAreNotInInsertOptionsValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

ItemHasSubItemsThatAreNotInInsertOptionsValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
ItemHasSubItemsThatAreNotInInsertOptionsValidator..::..Name Property
ItemHasSubItemsThatAreNotInInsertOptionsValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The name.

See Also

ItemHasSubItemsThatAreNotInInsertOptionsValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


ItemIsNotReferencedValidator Class

[image]

Sitecore 6.4.1 API
ItemIsNotReferencedValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class ItemIsNotReferencedValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class ItemIsNotReferencedValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class ItemIsNotReferencedValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.ItemValidators..::..ItemIsNotReferencedValidator

See Also

ItemIsNotReferencedValidator Members
Sitecore.Data.Validators.ItemValidators Namespace


ItemIsNotReferencedValidator Members

[image] [image]

Sitecore 6.4.1 API
ItemIsNotReferencedValidator Members
ItemIsNotReferencedValidator Class Constructors Methods Properties See Also Send Feedback

The ItemIsNotReferencedValidator type exposes the following members.

Constructors

 | Name | Description
Public method | ItemIsNotReferencedValidator()()()() | Initializes a new instance of the ItemIsNotReferencedValidator class.
Public method | ItemIsNotReferencedValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the ItemIsNotReferencedValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

ItemIsNotReferencedValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


ItemIsNotReferencedValidator Constructor

[image] [image]

Sitecore 6.4.1 API
ItemIsNotReferencedValidator Constructor
ItemIsNotReferencedValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ItemIsNotReferencedValidator()()()() | Initializes a new instance of the ItemIsNotReferencedValidator class.
Public method | ItemIsNotReferencedValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the ItemIsNotReferencedValidator class.

See Also

ItemIsNotReferencedValidator Class
ItemIsNotReferencedValidator Members
Sitecore.Data.Validators.ItemValidators Namespace


ItemIsNotReferencedValidator Constructor

[image]

Sitecore 6.4.1 API
ItemIsNotReferencedValidator Constructor
ItemIsNotReferencedValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemIsNotReferencedValidator()
Visual Basic
Public Sub New
Visual C++
public:
ItemIsNotReferencedValidator()

See Also

ItemIsNotReferencedValidator Class
ItemIsNotReferencedValidator Overload
Sitecore.Data.Validators.ItemValidators Namespace


ItemIsNotReferencedValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
ItemIsNotReferencedValidator Constructor (SerializationInfo, StreamingContext)
ItemIsNotReferencedValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemIsNotReferencedValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
ItemIsNotReferencedValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

ItemIsNotReferencedValidator Class
ItemIsNotReferencedValidator Overload
Sitecore.Data.Validators.ItemValidators Namespace


ItemIsNotReferencedValidator Methods

[image] [image]

Sitecore 6.4.1 API
ItemIsNotReferencedValidator Methods
ItemIsNotReferencedValidator Class See Also Send Feedback

The ItemIsNotReferencedValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

ItemIsNotReferencedValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
ItemIsNotReferencedValidator..::..Evaluate Method
ItemIsNotReferencedValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

ItemIsNotReferencedValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
ItemIsNotReferencedValidator..::..GetMaxValidatorResult Method
ItemIsNotReferencedValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

ItemIsNotReferencedValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


LockedByNonExistingUserValidator Class

[image]

Sitecore 6.4.1 API
LockedByNonExistingUserValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class LockedByNonExistingUserValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class LockedByNonExistingUserValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class LockedByNonExistingUserValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.ItemValidators..::..LockedByNonExistingUserValidator

See Also

LockedByNonExistingUserValidator Members
Sitecore.Data.Validators.ItemValidators Namespace


LockedByNonExistingUserValidator Members

[image] [image]

Sitecore 6.4.1 API
LockedByNonExistingUserValidator Members
LockedByNonExistingUserValidator Class Constructors Methods Properties See Also Send Feedback

The LockedByNonExistingUserValidator type exposes the following members.

Constructors

 | Name | Description
Public method | LockedByNonExistingUserValidator()()()() | Initializes a new instance of the LockedByNonExistingUserValidator class.
Public method | LockedByNonExistingUserValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the LockedByNonExistingUserValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

LockedByNonExistingUserValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


LockedByNonExistingUserValidator Constructor

[image] [image]

Sitecore 6.4.1 API
LockedByNonExistingUserValidator Constructor
LockedByNonExistingUserValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LockedByNonExistingUserValidator()()()() | Initializes a new instance of the LockedByNonExistingUserValidator class.
Public method | LockedByNonExistingUserValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the LockedByNonExistingUserValidator class.

See Also

LockedByNonExistingUserValidator Class
LockedByNonExistingUserValidator Members
Sitecore.Data.Validators.ItemValidators Namespace


LockedByNonExistingUserValidator Constructor

[image]

Sitecore 6.4.1 API
LockedByNonExistingUserValidator Constructor
LockedByNonExistingUserValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LockedByNonExistingUserValidator()
Visual Basic
Public Sub New
Visual C++
public:
LockedByNonExistingUserValidator()

See Also

LockedByNonExistingUserValidator Class
LockedByNonExistingUserValidator Overload
Sitecore.Data.Validators.ItemValidators Namespace


LockedByNonExistingUserValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
LockedByNonExistingUserValidator Constructor (SerializationInfo, StreamingContext)
LockedByNonExistingUserValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LockedByNonExistingUserValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
LockedByNonExistingUserValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

LockedByNonExistingUserValidator Class
LockedByNonExistingUserValidator Overload
Sitecore.Data.Validators.ItemValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
LockedByNonExistingUserValidator..::..GetMaxValidatorResult Method
LockedByNonExistingUserValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

LockedByNonExistingUserValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


LockedByNonExistingUserValidator Properties

[image] [image]

Sitecore 6.4.1 API
LockedByNonExistingUserValidator Properties
LockedByNonExistingUserValidator Class See Also Send Feedback

The LockedByNonExistingUserValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

LockedByNonExistingUserValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
LockedByNonExistingUserValidator..::..Name Property
LockedByNonExistingUserValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The name.

See Also

LockedByNonExistingUserValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


MediaSizeValidator Class

[image]

Sitecore 6.4.1 API
MediaSizeValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class MediaSizeValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class MediaSizeValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class MediaSizeValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.ItemValidators..::..MediaSizeValidator

See Also

MediaSizeValidator Members
Sitecore.Data.Validators.ItemValidators Namespace


MediaSizeValidator Members

[image] [image]

Sitecore 6.4.1 API
MediaSizeValidator Members
MediaSizeValidator Class Constructors Methods Properties See Also Send Feedback

The MediaSizeValidator type exposes the following members.

Constructors

 | Name | Description
Public method | MediaSizeValidator()()()() | Initializes a new instance of the MediaSizeValidator class.
Public method | MediaSizeValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the MediaSizeValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

MediaSizeValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


MediaSizeValidator Constructor

[image] [image]

Sitecore 6.4.1 API
MediaSizeValidator Constructor
MediaSizeValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MediaSizeValidator()()()() | Initializes a new instance of the MediaSizeValidator class.
Public method | MediaSizeValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the MediaSizeValidator class.

See Also

MediaSizeValidator Class
MediaSizeValidator Members
Sitecore.Data.Validators.ItemValidators Namespace


MediaSizeValidator Constructor

[image]

Sitecore 6.4.1 API
MediaSizeValidator Constructor
MediaSizeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MediaSizeValidator()
Visual Basic
Public Sub New
Visual C++
public:
MediaSizeValidator()

See Also

MediaSizeValidator Class
MediaSizeValidator Overload
Sitecore.Data.Validators.ItemValidators Namespace


MediaSizeValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
MediaSizeValidator Constructor (SerializationInfo, StreamingContext)
MediaSizeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MediaSizeValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
MediaSizeValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

MediaSizeValidator Class
MediaSizeValidator Overload
Sitecore.Data.Validators.ItemValidators Namespace


MediaSizeValidator Methods

[image] [image]

Sitecore 6.4.1 API
MediaSizeValidator Methods
MediaSizeValidator Class See Also Send Feedback

The MediaSizeValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

MediaSizeValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


MediaSizeValidator Properties

[image] [image]

Sitecore 6.4.1 API
MediaSizeValidator Properties
MediaSizeValidator Class See Also Send Feedback

The MediaSizeValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

MediaSizeValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
MediaSizeValidator..::..Name Property
MediaSizeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The validator name.

See Also

MediaSizeValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


Notifications Class

[image]

Sitecore 6.4.1 API
Notifications Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Notifications : StandardValidator
Visual Basic
Public Class Notifications _
    Inherits StandardValidator
Visual C++
public ref class Notifications : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.ItemValidators..::..Notifications

See Also

Notifications Members
Sitecore.Data.Validators.ItemValidators Namespace


Notifications Members

[image] [image]

Sitecore 6.4.1 API
Notifications Members
Notifications Class Constructors Methods Properties See Also Send Feedback

The Notifications type exposes the following members.

Constructors

 | Name | Description
Public method | Notifications()()()() | Initializes a new instance of the Notifications class.
Public method | Notifications(SerializationInfo, StreamingContext) | Initializes a new instance of the Notifications class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

Notifications Class
Sitecore.Data.Validators.ItemValidators Namespace


Notifications Constructor

[image] [image]

Sitecore 6.4.1 API
Notifications Constructor
Notifications Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Notifications()()()() | Initializes a new instance of the Notifications class.
Public method | Notifications(SerializationInfo, StreamingContext) | Initializes a new instance of the Notifications class.

See Also

Notifications Class
Notifications Members
Sitecore.Data.Validators.ItemValidators Namespace


Notifications Constructor

[image]

Sitecore 6.4.1 API
Notifications Constructor
Notifications Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Notifications()
Visual Basic
Public Sub New
Visual C++
public:
Notifications()

See Also

Notifications Class
Notifications Overload
Sitecore.Data.Validators.ItemValidators Namespace


Notifications Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
Notifications Constructor (SerializationInfo, StreamingContext)
Notifications Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Notifications(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
Notifications(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

Notifications Class
Notifications Overload
Sitecore.Data.Validators.ItemValidators Namespace


Notifications Methods

[image] [image]

Sitecore 6.4.1 API
Notifications Methods
Notifications Class See Also Send Feedback

The Notifications type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

Notifications Class
Sitecore.Data.Validators.ItemValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
Notifications..::..Evaluate Method
Notifications Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

Notifications Class
Sitecore.Data.Validators.ItemValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
Notifications..::..GetMaxValidatorResult Method
Notifications Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

Notifications Class
Sitecore.Data.Validators.ItemValidators Namespace


Notifications Properties

[image] [image]

Sitecore 6.4.1 API
Notifications Properties
Notifications Class See Also Send Feedback

The Notifications type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

Notifications Class
Sitecore.Data.Validators.ItemValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
Notifications..::..Name Property
Notifications Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The name.

See Also

Notifications Class
Sitecore.Data.Validators.ItemValidators Namespace


NotSerializedValidator Class

[image]

Sitecore 6.4.1 API
NotSerializedValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class NotSerializedValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class NotSerializedValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class NotSerializedValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.ItemValidators..::..NotSerializedValidator

See Also

NotSerializedValidator Members
Sitecore.Data.Validators.ItemValidators Namespace


NotSerializedValidator Members

[image] [image]

Sitecore 6.4.1 API
NotSerializedValidator Members
NotSerializedValidator Class Constructors Methods Properties See Also Send Feedback

The NotSerializedValidator type exposes the following members.

Constructors

 | Name | Description
Public method | NotSerializedValidator()()()() | Initializes a new instance of the NotSerializedValidator class.
Public method | NotSerializedValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the NotSerializedValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

NotSerializedValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


NotSerializedValidator Constructor

[image] [image]

Sitecore 6.4.1 API
NotSerializedValidator Constructor
NotSerializedValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NotSerializedValidator()()()() | Initializes a new instance of the NotSerializedValidator class.
Public method | NotSerializedValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the NotSerializedValidator class.

See Also

NotSerializedValidator Class
NotSerializedValidator Members
Sitecore.Data.Validators.ItemValidators Namespace


NotSerializedValidator Constructor

[image]

Sitecore 6.4.1 API
NotSerializedValidator Constructor
NotSerializedValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public NotSerializedValidator()
Visual Basic
Public Sub New
Visual C++
public:
NotSerializedValidator()

See Also

NotSerializedValidator Class
NotSerializedValidator Overload
Sitecore.Data.Validators.ItemValidators Namespace


NotSerializedValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
NotSerializedValidator Constructor (SerializationInfo, StreamingContext)
NotSerializedValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public NotSerializedValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
NotSerializedValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

NotSerializedValidator Class
NotSerializedValidator Overload
Sitecore.Data.Validators.ItemValidators Namespace


NotSerializedValidator Methods

[image] [image]

Sitecore 6.4.1 API
NotSerializedValidator Methods
NotSerializedValidator Class See Also Send Feedback

The NotSerializedValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

NotSerializedValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
NotSerializedValidator..::..Evaluate Method
NotSerializedValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

NotSerializedValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
NotSerializedValidator..::..GetMaxValidatorResult Method
NotSerializedValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

NotSerializedValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


NotSerializedValidator Properties

[image] [image]

Sitecore 6.4.1 API
NotSerializedValidator Properties
NotSerializedValidator Class See Also Send Feedback

The NotSerializedValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

NotSerializedValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
NotSerializedValidator..::..Name Property
NotSerializedValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The name.

See Also

NotSerializedValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


OwnedByNonExistingUserValidator Class

[image]

Sitecore 6.4.1 API
OwnedByNonExistingUserValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class OwnedByNonExistingUserValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class OwnedByNonExistingUserValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class OwnedByNonExistingUserValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.ItemValidators..::..OwnedByNonExistingUserValidator

See Also

OwnedByNonExistingUserValidator Members
Sitecore.Data.Validators.ItemValidators Namespace


OwnedByNonExistingUserValidator Members

[image] [image]

Sitecore 6.4.1 API
OwnedByNonExistingUserValidator Members
OwnedByNonExistingUserValidator Class Constructors Methods Properties See Also Send Feedback

The OwnedByNonExistingUserValidator type exposes the following members.

Constructors

 | Name | Description
Public method | OwnedByNonExistingUserValidator()()()() | Initializes a new instance of the OwnedByNonExistingUserValidator class.
Public method | OwnedByNonExistingUserValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the OwnedByNonExistingUserValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

OwnedByNonExistingUserValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


OwnedByNonExistingUserValidator Constructor

[image] [image]

Sitecore 6.4.1 API
OwnedByNonExistingUserValidator Constructor
OwnedByNonExistingUserValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OwnedByNonExistingUserValidator()()()() | Initializes a new instance of the OwnedByNonExistingUserValidator class.
Public method | OwnedByNonExistingUserValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the OwnedByNonExistingUserValidator class.

See Also

OwnedByNonExistingUserValidator Class
OwnedByNonExistingUserValidator Members
Sitecore.Data.Validators.ItemValidators Namespace


OwnedByNonExistingUserValidator Constructor

[image]

Sitecore 6.4.1 API
OwnedByNonExistingUserValidator Constructor
OwnedByNonExistingUserValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public OwnedByNonExistingUserValidator()
Visual Basic
Public Sub New
Visual C++
public:
OwnedByNonExistingUserValidator()

See Also

OwnedByNonExistingUserValidator Class
OwnedByNonExistingUserValidator Overload
Sitecore.Data.Validators.ItemValidators Namespace


OwnedByNonExistingUserValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
OwnedByNonExistingUserValidator Constructor (SerializationInfo, StreamingContext)
OwnedByNonExistingUserValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public OwnedByNonExistingUserValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
OwnedByNonExistingUserValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

OwnedByNonExistingUserValidator Class
OwnedByNonExistingUserValidator Overload
Sitecore.Data.Validators.ItemValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
OwnedByNonExistingUserValidator..::..Evaluate Method
OwnedByNonExistingUserValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

OwnedByNonExistingUserValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
OwnedByNonExistingUserValidator..::..GetMaxValidatorResult Method
OwnedByNonExistingUserValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

OwnedByNonExistingUserValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
OwnedByNonExistingUserValidator..::..Name Property
OwnedByNonExistingUserValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The name.

See Also

OwnedByNonExistingUserValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


PublishUnpublishDateRangeValidator Class

[image]

Sitecore 6.4.1 API
PublishUnpublishDateRangeValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class PublishUnpublishDateRangeValidator : DateRangeValidator
Visual Basic
<SerializableAttribute> _
Public Class PublishUnpublishDateRangeValidator _
    Inherits DateRangeValidator
Visual C++
[SerializableAttribute]
public ref class PublishUnpublishDateRangeValidator : public DateRangeValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.ItemValidators..::..DateRangeValidator
Sitecore.Data.Validators.ItemValidators..::..PublishUnpublishDateRangeValidator

See Also

PublishUnpublishDateRangeValidator Members
Sitecore.Data.Validators.ItemValidators Namespace


PublishUnpublishDateRangeValidator Constructor

[image] [image]

Sitecore 6.4.1 API
PublishUnpublishDateRangeValidator Constructor
PublishUnpublishDateRangeValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PublishUnpublishDateRangeValidator()()()() | Initializes a new instance of the PublishUnpublishDateRangeValidator class.
Public method | PublishUnpublishDateRangeValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the PublishUnpublishDateRangeValidator class.

See Also

PublishUnpublishDateRangeValidator Class
PublishUnpublishDateRangeValidator Members
Sitecore.Data.Validators.ItemValidators Namespace


PublishUnpublishDateRangeValidator Constructor

[image]

Sitecore 6.4.1 API
PublishUnpublishDateRangeValidator Constructor
PublishUnpublishDateRangeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PublishUnpublishDateRangeValidator()
Visual Basic
Public Sub New
Visual C++
public:
PublishUnpublishDateRangeValidator()

See Also

PublishUnpublishDateRangeValidator Class
PublishUnpublishDateRangeValidator Overload
Sitecore.Data.Validators.ItemValidators Namespace


PublishUnpublishDateRangeValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
PublishUnpublishDateRangeValidator Constructor (SerializationInfo, StreamingContext)
PublishUnpublishDateRangeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PublishUnpublishDateRangeValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
PublishUnpublishDateRangeValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

PublishUnpublishDateRangeValidator Class
PublishUnpublishDateRangeValidator Overload
Sitecore.Data.Validators.ItemValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
PublishUnpublishDateRangeValidator..::..Evaluate Method
PublishUnpublishDateRangeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

PublishUnpublishDateRangeValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


PublishUnpublishDateRangeValidator Properties

[image] [image]

Sitecore 6.4.1 API
PublishUnpublishDateRangeValidator Properties
PublishUnpublishDateRangeValidator Class See Also Send Feedback

The PublishUnpublishDateRangeValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Protected property | ErrorText | Gets or sets the error text. (Inherited from DateRangeValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Protected property | Field1 | Gets or sets the field1. (Inherited from DateRangeValidator.)
Protected property | Field2 | Gets or sets the field2. (Inherited from DateRangeValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

PublishUnpublishDateRangeValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
PublishUnpublishDateRangeValidator..::..Name Property
PublishUnpublishDateRangeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The name.

See Also

PublishUnpublishDateRangeValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


RadioCheckBoxValidator Class

[image]

Sitecore 6.4.1 API
RadioCheckBoxValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class RadioCheckBoxValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class RadioCheckBoxValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class RadioCheckBoxValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.ItemValidators..::..RadioCheckBoxValidator

See Also

RadioCheckBoxValidator Members
Sitecore.Data.Validators.ItemValidators Namespace


RadioCheckBoxValidator Members

[image] [image]

Sitecore 6.4.1 API
RadioCheckBoxValidator Members
RadioCheckBoxValidator Class Constructors Methods Properties See Also Send Feedback

The RadioCheckBoxValidator type exposes the following members.

Constructors

 | Name | Description
Public method | RadioCheckBoxValidator()()()() | Initializes a new instance of the RadioCheckBoxValidator class.
Public method | RadioCheckBoxValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the RadioCheckBoxValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

RadioCheckBoxValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


RadioCheckBoxValidator Constructor

[image] [image]

Sitecore 6.4.1 API
RadioCheckBoxValidator Constructor
RadioCheckBoxValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadioCheckBoxValidator()()()() | Initializes a new instance of the RadioCheckBoxValidator class.
Public method | RadioCheckBoxValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the RadioCheckBoxValidator class.

See Also

RadioCheckBoxValidator Class
RadioCheckBoxValidator Members
Sitecore.Data.Validators.ItemValidators Namespace


RadioCheckBoxValidator Constructor

[image]

Sitecore 6.4.1 API
RadioCheckBoxValidator Constructor
RadioCheckBoxValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RadioCheckBoxValidator()
Visual Basic
Public Sub New
Visual C++
public:
RadioCheckBoxValidator()

See Also

RadioCheckBoxValidator Class
RadioCheckBoxValidator Overload
Sitecore.Data.Validators.ItemValidators Namespace


RadioCheckBoxValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
RadioCheckBoxValidator Constructor (SerializationInfo, StreamingContext)
RadioCheckBoxValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RadioCheckBoxValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
RadioCheckBoxValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

RadioCheckBoxValidator Class
RadioCheckBoxValidator Overload
Sitecore.Data.Validators.ItemValidators Namespace


RadioCheckBoxValidator Methods

[image] [image]

Sitecore 6.4.1 API
RadioCheckBoxValidator Methods
RadioCheckBoxValidator Class See Also Send Feedback

The RadioCheckBoxValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

RadioCheckBoxValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
RadioCheckBoxValidator..::..Evaluate Method
RadioCheckBoxValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

RadioCheckBoxValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
RadioCheckBoxValidator..::..GetMaxValidatorResult Method
RadioCheckBoxValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

RadioCheckBoxValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


RadioCheckBoxValidator Properties

[image] [image]

Sitecore 6.4.1 API
RadioCheckBoxValidator Properties
RadioCheckBoxValidator Class See Also Send Feedback

The RadioCheckBoxValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

RadioCheckBoxValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
RadioCheckBoxValidator..::..Name Property
RadioCheckBoxValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The name.

See Also

RadioCheckBoxValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


ReminderArchiveDateRangeValidator Class

[image]

Sitecore 6.4.1 API
ReminderArchiveDateRangeValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class ReminderArchiveDateRangeValidator : DateRangeValidator
Visual Basic
<SerializableAttribute> _
Public Class ReminderArchiveDateRangeValidator _
    Inherits DateRangeValidator
Visual C++
[SerializableAttribute]
public ref class ReminderArchiveDateRangeValidator : public DateRangeValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.ItemValidators..::..DateRangeValidator
Sitecore.Data.Validators.ItemValidators..::..ReminderArchiveDateRangeValidator

See Also

ReminderArchiveDateRangeValidator Members
Sitecore.Data.Validators.ItemValidators Namespace


ReminderArchiveDateRangeValidator Members

[image] [image]

Sitecore 6.4.1 API
ReminderArchiveDateRangeValidator Members
ReminderArchiveDateRangeValidator Class Constructors Methods Properties See Also Send Feedback

The ReminderArchiveDateRangeValidator type exposes the following members.

Constructors

 | Name | Description
Public method | ReminderArchiveDateRangeValidator()()()() | Initializes a new instance of the ReminderArchiveDateRangeValidator class.
Public method | ReminderArchiveDateRangeValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the ReminderArchiveDateRangeValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Inherited from DateRangeValidator.)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Inherited from DateRangeValidator.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Protected property | ErrorText | Gets or sets the error text. (Inherited from DateRangeValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Protected property | Field1 | Gets or sets the field1. (Inherited from DateRangeValidator.)
Protected property | Field2 | Gets or sets the field2. (Inherited from DateRangeValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

ReminderArchiveDateRangeValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


ReminderArchiveDateRangeValidator Constructor

[image] [image]

Sitecore 6.4.1 API
ReminderArchiveDateRangeValidator Constructor
ReminderArchiveDateRangeValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReminderArchiveDateRangeValidator()()()() | Initializes a new instance of the ReminderArchiveDateRangeValidator class.
Public method | ReminderArchiveDateRangeValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the ReminderArchiveDateRangeValidator class.

See Also

ReminderArchiveDateRangeValidator Class
ReminderArchiveDateRangeValidator Members
Sitecore.Data.Validators.ItemValidators Namespace


ReminderArchiveDateRangeValidator Constructor

[image]

Sitecore 6.4.1 API
ReminderArchiveDateRangeValidator Constructor
ReminderArchiveDateRangeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ReminderArchiveDateRangeValidator()
Visual Basic
Public Sub New
Visual C++
public:
ReminderArchiveDateRangeValidator()

See Also

ReminderArchiveDateRangeValidator Class
ReminderArchiveDateRangeValidator Overload
Sitecore.Data.Validators.ItemValidators Namespace


ReminderArchiveDateRangeValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
ReminderArchiveDateRangeValidator Constructor (SerializationInfo, StreamingContext)
ReminderArchiveDateRangeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ReminderArchiveDateRangeValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
ReminderArchiveDateRangeValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

ReminderArchiveDateRangeValidator Class
ReminderArchiveDateRangeValidator Overload
Sitecore.Data.Validators.ItemValidators Namespace


ReminderArchiveDateRangeValidator Methods

[image] [image]

Sitecore 6.4.1 API
ReminderArchiveDateRangeValidator Methods
ReminderArchiveDateRangeValidator Class See Also Send Feedback

The ReminderArchiveDateRangeValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Inherited from DateRangeValidator.)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Inherited from DateRangeValidator.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

ReminderArchiveDateRangeValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


ReminderArchiveDateRangeValidator Properties

[image] [image]

Sitecore 6.4.1 API
ReminderArchiveDateRangeValidator Properties
ReminderArchiveDateRangeValidator Class See Also Send Feedback

The ReminderArchiveDateRangeValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Protected property | ErrorText | Gets or sets the error text. (Inherited from DateRangeValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Protected property | Field1 | Gets or sets the field1. (Inherited from DateRangeValidator.)
Protected property | Field2 | Gets or sets the field2. (Inherited from DateRangeValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

ReminderArchiveDateRangeValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
ReminderArchiveDateRangeValidator..::..Name Property
ReminderArchiveDateRangeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The name.

See Also

ReminderArchiveDateRangeValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


RuleValidator Members

[image] [image]

Sitecore 6.4.1 API
RuleValidator Members
RuleValidator Class Constructors Methods Properties See Also Send Feedback

The RuleValidator type exposes the following members.

Constructors

 | Name | Description
Public method | RuleValidator()()()() | Initializes a new instance of the RuleValidator class.
Public method | RuleValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the RuleValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

RuleValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


RuleValidator Constructor

[image]

Sitecore 6.4.1 API
RuleValidator Constructor
RuleValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RuleValidator()
Visual Basic
Public Sub New
Visual C++
public:
RuleValidator()

See Also

RuleValidator Class
RuleValidator Overload
Sitecore.Data.Validators.ItemValidators Namespace


RuleValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
RuleValidator Constructor (SerializationInfo, StreamingContext)
RuleValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RuleValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
RuleValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

RuleValidator Class
RuleValidator Overload
Sitecore.Data.Validators.ItemValidators Namespace


RuleValidator Methods

[image] [image]

Sitecore 6.4.1 API
RuleValidator Methods
RuleValidator Class See Also Send Feedback

The RuleValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

RuleValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
RuleValidator..::..GetMaxValidatorResult Method
RuleValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

RuleValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


RuleValidator Properties

[image] [image]

Sitecore 6.4.1 API
RuleValidator Properties
RuleValidator Class See Also Send Feedback

The RuleValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

RuleValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
RuleValidator..::..Name Property
RuleValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The name.

See Also

RuleValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


StandardValueHasNameMacroValidator Constructor

[image]

Sitecore 6.4.1 API
StandardValueHasNameMacroValidator Constructor
StandardValueHasNameMacroValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StandardValueHasNameMacroValidator()
Visual Basic
Public Sub New
Visual C++
public:
StandardValueHasNameMacroValidator()

See Also

StandardValueHasNameMacroValidator Class
StandardValueHasNameMacroValidator Overload
Sitecore.Data.Validators.ItemValidators Namespace


StandardValueHasNameMacroValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
StandardValueHasNameMacroValidator Constructor (SerializationInfo, StreamingContext)
StandardValueHasNameMacroValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StandardValueHasNameMacroValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
StandardValueHasNameMacroValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

StandardValueHasNameMacroValidator Class
StandardValueHasNameMacroValidator Overload
Sitecore.Data.Validators.ItemValidators Namespace


StandardValueHasNameMacroValidator Methods

[image] [image]

Sitecore 6.4.1 API
StandardValueHasNameMacroValidator Methods
StandardValueHasNameMacroValidator Class See Also Send Feedback

The StandardValueHasNameMacroValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

StandardValueHasNameMacroValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
StandardValueHasNameMacroValidator..::..Evaluate Method
StandardValueHasNameMacroValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

StandardValueHasNameMacroValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
StandardValueHasNameMacroValidator..::..GetMaxValidatorResult Method
StandardValueHasNameMacroValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

StandardValueHasNameMacroValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


StandardValueHasNameMacroValidator Properties

[image] [image]

Sitecore 6.4.1 API
StandardValueHasNameMacroValidator Properties
StandardValueHasNameMacroValidator Class See Also Send Feedback

The StandardValueHasNameMacroValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

StandardValueHasNameMacroValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
StandardValueHasNameMacroValidator..::..Name Property
StandardValueHasNameMacroValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The name.

See Also

StandardValueHasNameMacroValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


UrlCharacterValidator Class

[image]

Sitecore 6.4.1 API
UrlCharacterValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class UrlCharacterValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class UrlCharacterValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class UrlCharacterValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.ItemValidators..::..UrlCharacterValidator

See Also

UrlCharacterValidator Members
Sitecore.Data.Validators.ItemValidators Namespace


UrlCharacterValidator Constructor

[image] [image]

Sitecore 6.4.1 API
UrlCharacterValidator Constructor
UrlCharacterValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UrlCharacterValidator()()()() | Initializes a new instance of the UrlCharacterValidator class. Initializes a new instance of the DuplicateNameValidator class.
Public method | UrlCharacterValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the UrlCharacterValidator class. Initializes a new instance of the DuplicateNameValidator class.

See Also

UrlCharacterValidator Class
UrlCharacterValidator Members
Sitecore.Data.Validators.ItemValidators Namespace


UrlCharacterValidator Constructor

[image]

Sitecore 6.4.1 API
UrlCharacterValidator Constructor
UrlCharacterValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UrlCharacterValidator()
Visual Basic
Public Sub New
Visual C++
public:
UrlCharacterValidator()

See Also

UrlCharacterValidator Class
UrlCharacterValidator Overload
Sitecore.Data.Validators.ItemValidators Namespace


UrlCharacterValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
UrlCharacterValidator Constructor (SerializationInfo, StreamingContext)
UrlCharacterValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UrlCharacterValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
UrlCharacterValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The srialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

UrlCharacterValidator Class
UrlCharacterValidator Overload
Sitecore.Data.Validators.ItemValidators Namespace


UrlCharacterValidator Methods

[image] [image]

Sitecore 6.4.1 API
UrlCharacterValidator Methods
UrlCharacterValidator Class See Also Send Feedback

The UrlCharacterValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

UrlCharacterValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
UrlCharacterValidator..::..Evaluate Method
UrlCharacterValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

UrlCharacterValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
UrlCharacterValidator..::..GetMaxValidatorResult Method
UrlCharacterValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

UrlCharacterValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


UrlCharacterValidator Properties

[image] [image]

Sitecore 6.4.1 API
UrlCharacterValidator Properties
UrlCharacterValidator Class See Also Send Feedback

The UrlCharacterValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

UrlCharacterValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
UrlCharacterValidator..::..Name Property
UrlCharacterValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The validator name.

See Also

UrlCharacterValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


ValidationRulesValidator Class

[image]

Sitecore 6.4.1 API
ValidationRulesValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class ValidationRulesValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class ValidationRulesValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class ValidationRulesValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.ItemValidators..::..ValidationRulesValidator

See Also

ValidationRulesValidator Members
Sitecore.Data.Validators.ItemValidators Namespace


ValidationRulesValidator Members

[image] [image]

Sitecore 6.4.1 API
ValidationRulesValidator Members
ValidationRulesValidator Class Constructors Methods Properties See Also Send Feedback

The ValidationRulesValidator type exposes the following members.

Constructors

 | Name | Description
Public method | ValidationRulesValidator()()()() | Initializes a new instance of the ValidationRulesValidator class.
Public method | ValidationRulesValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the ValidationRulesValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

ValidationRulesValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


ValidationRulesValidator Constructor

[image] [image]

Sitecore 6.4.1 API
ValidationRulesValidator Constructor
ValidationRulesValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ValidationRulesValidator()()()() | Initializes a new instance of the ValidationRulesValidator class.
Public method | ValidationRulesValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the ValidationRulesValidator class.

See Also

ValidationRulesValidator Class
ValidationRulesValidator Members
Sitecore.Data.Validators.ItemValidators Namespace


ValidationRulesValidator Constructor

[image]

Sitecore 6.4.1 API
ValidationRulesValidator Constructor
ValidationRulesValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ValidationRulesValidator()
Visual Basic
Public Sub New
Visual C++
public:
ValidationRulesValidator()

See Also

ValidationRulesValidator Class
ValidationRulesValidator Overload
Sitecore.Data.Validators.ItemValidators Namespace


ValidationRulesValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
ValidationRulesValidator Constructor (SerializationInfo, StreamingContext)
ValidationRulesValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ValidationRulesValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
ValidationRulesValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

ValidationRulesValidator Class
ValidationRulesValidator Overload
Sitecore.Data.Validators.ItemValidators Namespace


ValidationRulesValidator Methods

[image] [image]

Sitecore 6.4.1 API
ValidationRulesValidator Methods
ValidationRulesValidator Class See Also Send Feedback

The ValidationRulesValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

ValidationRulesValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
ValidationRulesValidator..::..Evaluate Method
ValidationRulesValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

ValidationRulesValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


GetMaxValidatorResult Method

[image]

Sitecore 6.4.1 API
ValidationRulesValidator..::..GetMaxValidatorResult Method
ValidationRulesValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult GetMaxValidatorResult()
Visual Basic
Protected Overrides Function GetMaxValidatorResult As ValidatorResult
Visual C++
protected:
virtual ValidatorResult GetMaxValidatorResult() override

Return Value

The max validator result.

Remarks

This is used when saving and the validator uses a thread. If the Max Validator Result is Error or below, the validator does not have to be evaluated before saving. If the Max Validator Result is CriticalError or FatalError, the validator must have been evaluated before saving.

See Also

ValidationRulesValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


ValidationRulesValidator Properties

[image] [image]

Sitecore 6.4.1 API
ValidationRulesValidator Properties
ValidationRulesValidator Class See Also Send Feedback

The ValidationRulesValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

ValidationRulesValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
ValidationRulesValidator..::..Name Property
ValidationRulesValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The name.

See Also

ValidationRulesValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


ValidFromValidToDateRangeValidator Class

[image]

Sitecore 6.4.1 API
ValidFromValidToDateRangeValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class ValidFromValidToDateRangeValidator : DateRangeValidator
Visual Basic
<SerializableAttribute> _
Public Class ValidFromValidToDateRangeValidator _
    Inherits DateRangeValidator
Visual C++
[SerializableAttribute]
public ref class ValidFromValidToDateRangeValidator : public DateRangeValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.ItemValidators..::..DateRangeValidator
Sitecore.Data.Validators.ItemValidators..::..ValidFromValidToDateRangeValidator

See Also

ValidFromValidToDateRangeValidator Members
Sitecore.Data.Validators.ItemValidators Namespace


ValidFromValidToDateRangeValidator Members

[image] [image]

Sitecore 6.4.1 API
ValidFromValidToDateRangeValidator Members
ValidFromValidToDateRangeValidator Class Constructors Methods Properties See Also Send Feedback

The ValidFromValidToDateRangeValidator type exposes the following members.

Constructors

 | Name | Description
Public method | ValidFromValidToDateRangeValidator()()()() | Initializes a new instance of the ValidFromValidToDateRangeValidator class.
Public method | ValidFromValidToDateRangeValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the ValidFromValidToDateRangeValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides DateRangeValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Inherited from DateRangeValidator.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Protected property | ErrorText | Gets or sets the error text. (Inherited from DateRangeValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Protected property | Field1 | Gets or sets the field1. (Inherited from DateRangeValidator.)
Protected property | Field2 | Gets or sets the field2. (Inherited from DateRangeValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

ValidFromValidToDateRangeValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


ValidFromValidToDateRangeValidator Constructor

[image] [image]

Sitecore 6.4.1 API
ValidFromValidToDateRangeValidator Constructor
ValidFromValidToDateRangeValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ValidFromValidToDateRangeValidator()()()() | Initializes a new instance of the ValidFromValidToDateRangeValidator class.
Public method | ValidFromValidToDateRangeValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the ValidFromValidToDateRangeValidator class.

See Also

ValidFromValidToDateRangeValidator Class
ValidFromValidToDateRangeValidator Members
Sitecore.Data.Validators.ItemValidators Namespace


ValidFromValidToDateRangeValidator Constructor

[image]

Sitecore 6.4.1 API
ValidFromValidToDateRangeValidator Constructor
ValidFromValidToDateRangeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ValidFromValidToDateRangeValidator()
Visual Basic
Public Sub New
Visual C++
public:
ValidFromValidToDateRangeValidator()

See Also

ValidFromValidToDateRangeValidator Class
ValidFromValidToDateRangeValidator Overload
Sitecore.Data.Validators.ItemValidators Namespace


ValidFromValidToDateRangeValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
ValidFromValidToDateRangeValidator Constructor (SerializationInfo, StreamingContext)
ValidFromValidToDateRangeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ValidFromValidToDateRangeValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
ValidFromValidToDateRangeValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

ValidFromValidToDateRangeValidator Class
ValidFromValidToDateRangeValidator Overload
Sitecore.Data.Validators.ItemValidators Namespace


ValidFromValidToDateRangeValidator Methods

[image] [image]

Sitecore 6.4.1 API
ValidFromValidToDateRangeValidator Methods
ValidFromValidToDateRangeValidator Class See Also Send Feedback

The ValidFromValidToDateRangeValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides DateRangeValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Inherited from DateRangeValidator.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

ValidFromValidToDateRangeValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
ValidFromValidToDateRangeValidator..::..Evaluate Method
ValidFromValidToDateRangeValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

ValidFromValidToDateRangeValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


ValidFromValidToDateRangeValidator Properties

[image] [image]

Sitecore 6.4.1 API
ValidFromValidToDateRangeValidator Properties
ValidFromValidToDateRangeValidator Class See Also Send Feedback

The ValidFromValidToDateRangeValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Protected property | ErrorText | Gets or sets the error text. (Inherited from DateRangeValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Protected property | Field1 | Gets or sets the field1. (Inherited from DateRangeValidator.)
Protected property | Field2 | Gets or sets the field2. (Inherited from DateRangeValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

ValidFromValidToDateRangeValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


WorkflowFinalStateValidator Class

[image]

Sitecore 6.4.1 API
WorkflowFinalStateValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class WorkflowFinalStateValidator : StandardValidator
Visual Basic
<SerializableAttribute> _
Public Class WorkflowFinalStateValidator _
    Inherits StandardValidator
Visual C++
[SerializableAttribute]
public ref class WorkflowFinalStateValidator : public StandardValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Data.Validators..::..BaseValidator
Sitecore.Data.Validators..::..StandardValidator
Sitecore.Data.Validators.ItemValidators..::..WorkflowFinalStateValidator

See Also

WorkflowFinalStateValidator Members
Sitecore.Data.Validators.ItemValidators Namespace


WorkflowFinalStateValidator Members

[image] [image]

Sitecore 6.4.1 API
WorkflowFinalStateValidator Members
WorkflowFinalStateValidator Class Constructors Methods Properties See Also Send Feedback

The WorkflowFinalStateValidator type exposes the following members.

Constructors

 | Name | Description
Public method | WorkflowFinalStateValidator()()()() | Initializes a new instance of the WorkflowFinalStateValidator class.
Public method | WorkflowFinalStateValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the WorkflowFinalStateValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

WorkflowFinalStateValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


WorkflowFinalStateValidator Constructor

[image] [image]

Sitecore 6.4.1 API
WorkflowFinalStateValidator Constructor
WorkflowFinalStateValidator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WorkflowFinalStateValidator()()()() | Initializes a new instance of the WorkflowFinalStateValidator class.
Public method | WorkflowFinalStateValidator(SerializationInfo, StreamingContext) | Initializes a new instance of the WorkflowFinalStateValidator class.

See Also

WorkflowFinalStateValidator Class
WorkflowFinalStateValidator Members
Sitecore.Data.Validators.ItemValidators Namespace


WorkflowFinalStateValidator Constructor

[image]

Sitecore 6.4.1 API
WorkflowFinalStateValidator Constructor
WorkflowFinalStateValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WorkflowFinalStateValidator()
Visual Basic
Public Sub New
Visual C++
public:
WorkflowFinalStateValidator()

See Also

WorkflowFinalStateValidator Class
WorkflowFinalStateValidator Overload
Sitecore.Data.Validators.ItemValidators Namespace


WorkflowFinalStateValidator Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
WorkflowFinalStateValidator Constructor (SerializationInfo, StreamingContext)
WorkflowFinalStateValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WorkflowFinalStateValidator(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
WorkflowFinalStateValidator(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

WorkflowFinalStateValidator Class
WorkflowFinalStateValidator Overload
Sitecore.Data.Validators.ItemValidators Namespace


WorkflowFinalStateValidator Methods

[image] [image]

Sitecore 6.4.1 API
WorkflowFinalStateValidator Methods
WorkflowFinalStateValidator Class See Also Send Feedback

The WorkflowFinalStateValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid. (Overrides BaseValidator..::..Evaluate()()()().)
Public method | Expire | Expires this instance. (Inherited from BaseValidator.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Protected method | GetFailedResult | Gets the result. (Inherited from StandardValidator.)
Protected method | GetField | Gets the field. (Inherited from BaseValidator.)
Public method | GetFieldDisplayName | Gets the display name of the field. (Inherited from BaseValidator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIcon()()()() | Gets the icon. (Inherited from BaseValidator.)
Protected method | GetItem | Gets the item. (Inherited from BaseValidator.)
Protected method | GetMaxValidatorResult | Gets the max validator result. (Overrides BaseValidator..::..GetMaxValidatorResult()()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from BaseValidator.)
Protected method | GetText | Gets the text. (Inherited from StandardValidator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControlToValidate | Determines whether this instance has a control to validate. (Inherited from BaseValidator.)
Protected method | IsControlValidationValueValid | Determines whether the control validation value is valid. (Inherited from BaseValidator.)
Protected method | IsEvaluationRequired | Determines if evaluation should be performed. (Inherited from BaseValidator.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates this instance. (Inherited from BaseValidator.)
Public method | Validate | Validates this instance. (Inherited from BaseValidator.)

See Also

WorkflowFinalStateValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
WorkflowFinalStateValidator..::..Evaluate Method
WorkflowFinalStateValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ValidatorResult Evaluate()
Visual Basic
Protected Overrides Function Evaluate As ValidatorResult
Visual C++
protected:
virtual ValidatorResult Evaluate() override

Return Value

The result of the evaluation.

See Also

WorkflowFinalStateValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


WorkflowFinalStateValidator Properties

[image] [image]

Sitecore 6.4.1 API
WorkflowFinalStateValidator Properties
WorkflowFinalStateValidator Class See Also Send Feedback

The WorkflowFinalStateValidator type exposes the following members.

Properties

 | Name | Description
Public property | ControlToValidate | Gets or sets the input control to validate. (Inherited from BaseValidator.)
Public property | ControlValidationValue | Gets the control validation value. (Inherited from BaseValidator.)
Public property | Errors | Gets the errors. (Inherited from BaseValidator.)
Public property | EvaluationMode | Gets or sets the evaluation. (Inherited from BaseValidator.)
Public property | Expiry | Gets or sets the expiry. (Inherited from BaseValidator.)
Public property | FieldID | Gets or sets the field ID. (Inherited from BaseValidator.)
Public property | HasMenu | Gets or sets a value indicating whether this instance has menu. (Inherited from BaseValidator.)
Public property | Icon | Gets or sets the icon. (Inherited from BaseValidator.)
Public property | IsEvaluating | Gets or sets a value indicating whether this instance is evaluating. (Inherited from BaseValidator.)
Public property | IsValid | Gets a value indicating whether the associated input control passes validation. (Inherited from BaseValidator.)
Public property | ItemUri | Gets or sets the item URI. (Inherited from BaseValidator.)
Public property | MarkerID | Gets the marker ID. (Inherited from BaseValidator.)
Public property | MaxValidatorResult | Gets the max validator result that the validator can return. (Inherited from BaseValidator.)
Public property | Name | Gets the name. (Overrides BaseValidator..::..Name.)
Public property | Options | Gets the options. (Inherited from BaseValidator.)
Public property | Parameters | Gets or sets the parameters. (Inherited from BaseValidator.)
Public property | Result | Gets or sets the state. (Inherited from BaseValidator.)
Public property | Text | Gets or sets the text. (Inherited from BaseValidator.)
Public property | ValidatorID | Gets or sets the validator ID. (Inherited from BaseValidator.)

See Also

WorkflowFinalStateValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


Name Property

[image]

Sitecore 6.4.1 API
WorkflowFinalStateValidator..::..Name Property
WorkflowFinalStateValidator Class See Also Send Feedback

Namespace: Sitecore.Data.Validators.ItemValidators
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Field Value

The name.

See Also

WorkflowFinalStateValidator Class
Sitecore.Data.Validators.ItemValidators Namespace


Sitecore.Data.Views Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Data.Views Namespace
Send Feedback

Classes

 | Class | Description
Public class | DetailedWebDAVView | Dailed Web DAV view.
Public class | SimpleWebDAVView | Simple Web DAV view.
Public class | WebDAVView | Base class for WebDAV views.
Public class | WebDAVViewProviderCollection | Web DAV View provider collaction.


DetailedWebDAVView Class

[image]

Sitecore 6.4.1 API
DetailedWebDAVView Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Views
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DetailedWebDAVView : WebDAVView
Visual Basic
Public Class DetailedWebDAVView _
    Inherits WebDAVView
Visual C++
public ref class DetailedWebDAVView : public WebDAVView

Inheritance Hierarchy

System..::..Object
System.Configuration.Provider..::..ProviderBase
Sitecore.Data.Views..::..WebDAVView
Sitecore.Data.Views..::..DetailedWebDAVView

See Also

DetailedWebDAVView Members
Sitecore.Data.Views Namespace


DetailedWebDAVView Members

[image] [image]

Sitecore 6.4.1 API
DetailedWebDAVView Members
DetailedWebDAVView Class Constructors Methods Properties See Also Send Feedback

The DetailedWebDAVView type exposes the following members.

Constructors

 | Name | Description
Public method | DetailedWebDAVView | Initializes a new instance of the DetailedWebDAVView class

Methods

 | Name | Description
Public method | ConstructHierarchyItem | Constructs the hierarchy item. (Overrides WebDAVView..::..ConstructHierarchyItem(Item, WebDAVEngine).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateFakeFolder | Generates the fake folder. (Inherited from WebDAVView.)
Public method | GetChildren | Gets the children. (Inherited from WebDAVView.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHierarchyItem(String, WebDAVEngine) | Gets the hierarchy item. (Inherited from WebDAVView.)
Protected method | GetHierarchyItem(WebDAVMediaRequest, WebDAVEngine) | Gets the hierarchy item. (Overrides WebDAVView..::..GetHierarchyItem(WebDAVMediaRequest, WebDAVEngine).)
Protected method | GetLanguage | Gets the language.
Protected method | GetMedia | Gets the media. (Overrides WebDAVView..::..GetMedia(MediaRequest).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetVersion | Gets the version.
Protected method | GetVersionedHierarchyItem | Gets the versioned hierarchy item.
Public method | GetWebDAVItemPath | Gets the web DAV item path. (Overrides WebDAVView..::..GetWebDAVItemPath(MediaItem).)
Public method | Initialize | Initializes the provider. (Inherited from ProviderBase.)
Protected method | IsContentRequest | Determines whether it is request to sitecore content or not. (Inherited from WebDAVView.)
Protected method | IsMediaItem | Determines whether the items is media item or not. (Inherited from WebDAVView.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Modified | Checks for not-modified. (Inherited from WebDAVView.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | VersionExists | Checks whether specific version exists.

Properties

 | Name | Description
Public property | AutoGenerateVersionNumbers | Gets a value indicating whether we need to generate version numbers automatically. (Overrides WebDAVView..::..AutoGenerateVersionNumbers.)
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | DescriptionKey | Gets DescriptionKey. (Overrides WebDAVView..::..DescriptionKey.)
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

DetailedWebDAVView Class
Sitecore.Data.Views Namespace


DetailedWebDAVView Methods

[image] [image]

Sitecore 6.4.1 API
DetailedWebDAVView Methods
DetailedWebDAVView Class See Also Send Feedback

The DetailedWebDAVView type exposes the following members.

Methods

 | Name | Description
Public method | ConstructHierarchyItem | Constructs the hierarchy item. (Overrides WebDAVView..::..ConstructHierarchyItem(Item, WebDAVEngine).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateFakeFolder | Generates the fake folder. (Inherited from WebDAVView.)
Public method | GetChildren | Gets the children. (Inherited from WebDAVView.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHierarchyItem(String, WebDAVEngine) | Gets the hierarchy item. (Inherited from WebDAVView.)
Protected method | GetHierarchyItem(WebDAVMediaRequest, WebDAVEngine) | Gets the hierarchy item. (Overrides WebDAVView..::..GetHierarchyItem(WebDAVMediaRequest, WebDAVEngine).)
Protected method | GetLanguage | Gets the language.
Protected method | GetMedia | Gets the media. (Overrides WebDAVView..::..GetMedia(MediaRequest).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetVersion | Gets the version.
Protected method | GetVersionedHierarchyItem | Gets the versioned hierarchy item.
Public method | GetWebDAVItemPath | Gets the web DAV item path. (Overrides WebDAVView..::..GetWebDAVItemPath(MediaItem).)
Public method | Initialize | Initializes the provider. (Inherited from ProviderBase.)
Protected method | IsContentRequest | Determines whether it is request to sitecore content or not. (Inherited from WebDAVView.)
Protected method | IsMediaItem | Determines whether the items is media item or not. (Inherited from WebDAVView.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Modified | Checks for not-modified. (Inherited from WebDAVView.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | VersionExists | Checks whether specific version exists.

See Also

DetailedWebDAVView Class
Sitecore.Data.Views Namespace


ConstructHierarchyItem Method

[image]

Sitecore 6.4.1 API
DetailedWebDAVView..::..ConstructHierarchyItem Method
DetailedWebDAVView Class See Also Send Feedback

Namespace: Sitecore.Data.Views
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override WebDAVHierarchyItem[] ConstructHierarchyItem(
    Item item,
    WebDAVEngine engine
)
Visual Basic
Public Overrides Function ConstructHierarchyItem ( _
    item As Item, _
    engine As WebDAVEngine _
) As WebDAVHierarchyItem()
Visual C++
public:
virtual array<WebDAVHierarchyItem^>^ ConstructHierarchyItem(
    Item^ item,
    WebDAVEngine^ engine
) override

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item.
engine
Type: Sitecore.Web..::..WebDAVEngine
The engine.

Return Value

The Hierarchy item representation.

See Also

DetailedWebDAVView Class
Sitecore.Data.Views Namespace


GetHierarchyItem Method

[image] [image]

Sitecore 6.4.1 API
DetailedWebDAVView..::..GetHierarchyItem Method
DetailedWebDAVView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetHierarchyItem(String, WebDAVEngine) | Gets the hierarchy item. (Inherited from WebDAVView.)
Protected method | GetHierarchyItem(WebDAVMediaRequest, WebDAVEngine) | Gets the hierarchy item. (Overrides WebDAVView..::..GetHierarchyItem(WebDAVMediaRequest, WebDAVEngine).)

See Also

DetailedWebDAVView Class
DetailedWebDAVView Members
Sitecore.Data.Views Namespace


GetHierarchyItem Method (WebDAVMediaRequest, WebDAVEngine)

[image]

Sitecore 6.4.1 API
DetailedWebDAVView..::..GetHierarchyItem Method (WebDAVMediaRequest, WebDAVEngine)
DetailedWebDAVView Class See Also Send Feedback

Namespace: Sitecore.Data.Views
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override WebDAVHierarchyItem GetHierarchyItem(
    WebDAVMediaRequest request,
    WebDAVEngine engine
)
Visual Basic
Protected Overrides Function GetHierarchyItem ( _
    request As WebDAVMediaRequest, _
    engine As WebDAVEngine _
) As WebDAVHierarchyItem
Visual C++
protected:
virtual WebDAVHierarchyItem^ GetHierarchyItem(
    WebDAVMediaRequest^ request,
    WebDAVEngine^ engine
) override

Parameters

request
Type: Sitecore.Resources.Media..::..WebDAVMediaRequest
The media request.
engine
Type: Sitecore.Web..::..WebDAVEngine
The engine.

Return Value

The Hierarcy Item.

See Also

DetailedWebDAVView Class
GetHierarchyItem Overload
Sitecore.Data.Views Namespace


GetLanguage Method

[image]

Sitecore 6.4.1 API
DetailedWebDAVView..::..GetLanguage Method
DetailedWebDAVView Class See Also Send Feedback

Namespace: Sitecore.Data.Views
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual Language GetLanguage(
    string languageName
)
Visual Basic
Protected Overridable Function GetLanguage ( _
    languageName As String _
) As Language
Visual C++
protected:
virtual Language^ GetLanguage(
    String^ languageName
)

Parameters

languageName
Type: System..::..String
Name of the language.

Return Value

The Language instance.

See Also

DetailedWebDAVView Class
Sitecore.Data.Views Namespace


GetMedia Method

[image]

Sitecore 6.4.1 API
DetailedWebDAVView..::..GetMedia Method
DetailedWebDAVView Class See Also Send Feedback

Namespace: Sitecore.Data.Views
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override Media GetMedia(
    MediaRequest request
)
Visual Basic
Protected Overrides Function GetMedia ( _
    request As MediaRequest _
) As Media
Visual C++
protected:
virtual Media^ GetMedia(
    MediaRequest^ request
) override

Parameters

request
Type: Sitecore.Resources.Media..::..MediaRequest
The media request.

Return Value

The Media.

See Also

DetailedWebDAVView Class
Sitecore.Data.Views Namespace


GetVersion Method

[image]

Sitecore 6.4.1 API
DetailedWebDAVView..::..GetVersion Method
DetailedWebDAVView Class See Also Send Feedback

Namespace: Sitecore.Data.Views
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual Version GetVersion(
    string versionedItemName
)
Visual Basic
Protected Overridable Function GetVersion ( _
    versionedItemName As String _
) As Version
Visual C++
protected:
virtual Version^ GetVersion(
    String^ versionedItemName
)

Parameters

versionedItemName
Type: System..::..String
Name of the versioned item.

Return Value

The Item Version.

See Also

DetailedWebDAVView Class
Sitecore.Data.Views Namespace


GetVersionedHierarchyItem Method

[image]

Sitecore 6.4.1 API
DetailedWebDAVView..::..GetVersionedHierarchyItem Method
DetailedWebDAVView Class See Also Send Feedback

Namespace: Sitecore.Data.Views
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual WebDAVHierarchyItem GetVersionedHierarchyItem(
    string rawUrl,
    Media media,
    MediaRequest request,
    WebDAVEngine engine
)
Visual Basic
Protected Overridable Function GetVersionedHierarchyItem ( _
    rawUrl As String, _
    media As Media, _
    request As MediaRequest, _
    engine As WebDAVEngine _
) As WebDAVHierarchyItem
Visual C++
protected:
virtual WebDAVHierarchyItem^ GetVersionedHierarchyItem(
    String^ rawUrl,
    Media^ media,
    MediaRequest^ request,
    WebDAVEngine^ engine
)

Parameters

rawUrl
Type: System..::..String
The raw URL.
media
Type: Sitecore.Resources.Media..::..Media
The media.
request
Type: Sitecore.Resources.Media..::..MediaRequest
The request.
engine
Type: Sitecore.Web..::..WebDAVEngine
The engine.

Return Value

The Versioned WebDAV item representation.

See Also

DetailedWebDAVView Class
Sitecore.Data.Views Namespace


GetWebDAVItemPath Method

[image]

Sitecore 6.4.1 API
DetailedWebDAVView..::..GetWebDAVItemPath Method
DetailedWebDAVView Class See Also Send Feedback

Namespace: Sitecore.Data.Views
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string GetWebDAVItemPath(
    MediaItem item
)
Visual Basic
Public Overrides Function GetWebDAVItemPath ( _
    item As MediaItem _
) As String
Visual C++
public:
virtual String^ GetWebDAVItemPath(
    MediaItem^ item
) override

Parameters

item
Type: Sitecore.Data.Items..::..MediaItem
The Media item.

Return Value

The WebDAV item path.

See Also

DetailedWebDAVView Class
Sitecore.Data.Views Namespace


VersionExists Method

[image]

Sitecore 6.4.1 API
DetailedWebDAVView..::..VersionExists Method
DetailedWebDAVView Class See Also Send Feedback

Namespace: Sitecore.Data.Views
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool VersionExists(
    ID id,
    Language language,
    Version version,
    Database database
)
Visual Basic
Protected Overridable Function VersionExists ( _
    id As ID, _
    language As Language, _
    version As Version, _
    database As Database _
) As Boolean
Visual C++
protected:
virtual bool VersionExists(
    ID^ id,
    Language^ language,
    Version^ version,
    Database^ database
)

Parameters

id
Type: Sitecore.Data..::..ID
The item id.
language
Type: Sitecore.Globalization..::..Language
The language.
version
Type: Sitecore.Data..::..Version
The version.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

true if specific item version exists.

See Also

DetailedWebDAVView Class
Sitecore.Data.Views Namespace


DetailedWebDAVView Properties

[image] [image]

Sitecore 6.4.1 API
DetailedWebDAVView Properties
DetailedWebDAVView Class See Also Send Feedback

The DetailedWebDAVView type exposes the following members.

Properties

 | Name | Description
Public property | AutoGenerateVersionNumbers | Gets a value indicating whether we need to generate version numbers automatically. (Overrides WebDAVView..::..AutoGenerateVersionNumbers.)
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | DescriptionKey | Gets DescriptionKey. (Overrides WebDAVView..::..DescriptionKey.)
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

DetailedWebDAVView Class
Sitecore.Data.Views Namespace


AutoGenerateVersionNumbers Property

[image]

Sitecore 6.4.1 API
DetailedWebDAVView..::..AutoGenerateVersionNumbers Property
DetailedWebDAVView Class See Also Send Feedback

Namespace: Sitecore.Data.Views
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool AutoGenerateVersionNumbers { get; }
Visual Basic
Public Overrides ReadOnly Property AutoGenerateVersionNumbers As Boolean
    Get
Visual C++
public:
virtual property bool AutoGenerateVersionNumbers {
    bool get () override;
}

Field Value

true if we need to generate version numbers automatically; otherwise, false.

See Also

DetailedWebDAVView Class
Sitecore.Data.Views Namespace


DescriptionKey Property

[image]

Sitecore 6.4.1 API
DetailedWebDAVView..::..DescriptionKey Property
DetailedWebDAVView Class See Also Send Feedback

Namespace: Sitecore.Data.Views
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string DescriptionKey { get; }
Visual Basic
Public Overrides ReadOnly Property DescriptionKey As String
    Get
Visual C++
public:
virtual property String^ DescriptionKey {
    String^ get () override;
}

See Also

DetailedWebDAVView Class
Sitecore.Data.Views Namespace


SimpleWebDAVView Members

[image] [image]

Sitecore 6.4.1 API
SimpleWebDAVView Members
SimpleWebDAVView Class Constructors Methods Properties See Also Send Feedback

The SimpleWebDAVView type exposes the following members.

Constructors

 | Name | Description
Public method | SimpleWebDAVView | Initializes a new instance of the SimpleWebDAVView class

Methods

 | Name | Description
Public method | ConstructHierarchyItem | Constructs the hierarchy item. (Inherited from WebDAVView.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateFakeFolder | Generates the fake folder. (Inherited from WebDAVView.)
Public method | GetChildren | Gets the children. (Inherited from WebDAVView.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHierarchyItem(String, WebDAVEngine) | Gets the hierarchy item. (Inherited from WebDAVView.)
Protected method | GetHierarchyItem(WebDAVMediaRequest, WebDAVEngine) | Gets the hierarchy item. (Inherited from WebDAVView.)
Protected method | GetMedia | Gets the media. (Inherited from WebDAVView.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWebDAVItemPath | Gets the web DAV item path. (Inherited from WebDAVView.)
Public method | Initialize | Initializes the provider. (Inherited from ProviderBase.)
Protected method | IsContentRequest | Determines whether it is request to sitecore content or not. (Inherited from WebDAVView.)
Protected method | IsMediaItem | Determines whether the items is media item or not. (Inherited from WebDAVView.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Modified | Checks for not-modified. (Inherited from WebDAVView.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AutoGenerateVersionNumbers | Gets a value indicating whether we need to generate version numbers automatically. (Overrides WebDAVView..::..AutoGenerateVersionNumbers.)
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | DescriptionKey | Gets DescriptionKey. (Overrides WebDAVView..::..DescriptionKey.)
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

SimpleWebDAVView Class
Sitecore.Data.Views Namespace


SimpleWebDAVView Constructor

[image]

Sitecore 6.4.1 API
SimpleWebDAVView Constructor
SimpleWebDAVView Class See Also Send Feedback

Namespace: Sitecore.Data.Views
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SimpleWebDAVView()
Visual Basic
Public Sub New
Visual C++
public:
SimpleWebDAVView()

See Also

SimpleWebDAVView Class
Sitecore.Data.Views Namespace


SimpleWebDAVView Methods

[image] [image]

Sitecore 6.4.1 API
SimpleWebDAVView Methods
SimpleWebDAVView Class See Also Send Feedback

The SimpleWebDAVView type exposes the following members.

Methods

 | Name | Description
Public method | ConstructHierarchyItem | Constructs the hierarchy item. (Inherited from WebDAVView.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateFakeFolder | Generates the fake folder. (Inherited from WebDAVView.)
Public method | GetChildren | Gets the children. (Inherited from WebDAVView.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHierarchyItem(String, WebDAVEngine) | Gets the hierarchy item. (Inherited from WebDAVView.)
Protected method | GetHierarchyItem(WebDAVMediaRequest, WebDAVEngine) | Gets the hierarchy item. (Inherited from WebDAVView.)
Protected method | GetMedia | Gets the media. (Inherited from WebDAVView.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWebDAVItemPath | Gets the web DAV item path. (Inherited from WebDAVView.)
Public method | Initialize | Initializes the provider. (Inherited from ProviderBase.)
Protected method | IsContentRequest | Determines whether it is request to sitecore content or not. (Inherited from WebDAVView.)
Protected method | IsMediaItem | Determines whether the items is media item or not. (Inherited from WebDAVView.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Modified | Checks for not-modified. (Inherited from WebDAVView.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SimpleWebDAVView Class
Sitecore.Data.Views Namespace


GetHierarchyItem Method

[image] [image]

Sitecore 6.4.1 API
SimpleWebDAVView..::..GetHierarchyItem Method
SimpleWebDAVView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetHierarchyItem(String, WebDAVEngine) | Gets the hierarchy item. (Inherited from WebDAVView.)
Protected method | GetHierarchyItem(WebDAVMediaRequest, WebDAVEngine) | Gets the hierarchy item. (Inherited from WebDAVView.)

See Also

SimpleWebDAVView Class
SimpleWebDAVView Members
Sitecore.Data.Views Namespace


SimpleWebDAVView Properties

[image] [image]

Sitecore 6.4.1 API
SimpleWebDAVView Properties
SimpleWebDAVView Class See Also Send Feedback

The SimpleWebDAVView type exposes the following members.

Properties

 | Name | Description
Public property | AutoGenerateVersionNumbers | Gets a value indicating whether we need to generate version numbers automatically. (Overrides WebDAVView..::..AutoGenerateVersionNumbers.)
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | DescriptionKey | Gets DescriptionKey. (Overrides WebDAVView..::..DescriptionKey.)
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

SimpleWebDAVView Class
Sitecore.Data.Views Namespace


AutoGenerateVersionNumbers Property

[image]

Sitecore 6.4.1 API
SimpleWebDAVView..::..AutoGenerateVersionNumbers Property
SimpleWebDAVView Class See Also Send Feedback

Namespace: Sitecore.Data.Views
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool AutoGenerateVersionNumbers { get; }
Visual Basic
Public Overrides ReadOnly Property AutoGenerateVersionNumbers As Boolean
    Get
Visual C++
public:
virtual property bool AutoGenerateVersionNumbers {
    bool get () override;
}

Field Value

true if we need to generate version numbers automatically; otherwise, false.

See Also

SimpleWebDAVView Class
Sitecore.Data.Views Namespace


DescriptionKey Property

[image]

Sitecore 6.4.1 API
SimpleWebDAVView..::..DescriptionKey Property
SimpleWebDAVView Class See Also Send Feedback

Namespace: Sitecore.Data.Views
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string DescriptionKey { get; }
Visual Basic
Public Overrides ReadOnly Property DescriptionKey As String
    Get
Visual C++
public:
virtual property String^ DescriptionKey {
    String^ get () override;
}

See Also

SimpleWebDAVView Class
Sitecore.Data.Views Namespace


WebDAVView Class

[image]

Sitecore 6.4.1 API
WebDAVView Class
Members See Also Send Feedback

Namespace: Sitecore.Data.Views
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class WebDAVView : ProviderBase
Visual Basic
Public MustInherit Class WebDAVView _
    Inherits ProviderBase
Visual C++
public ref class WebDAVView abstract : public ProviderBase

Inheritance Hierarchy

System..::..Object
System.Configuration.Provider..::..ProviderBase
Sitecore.Data.Views..::..WebDAVView
Sitecore.Data.Views..::..DetailedWebDAVView
Sitecore.Data.Views..::..SimpleWebDAVView

See Also

WebDAVView Members
Sitecore.Data.Views Namespace


WebDAVView Members

[image] [image]

Sitecore 6.4.1 API
WebDAVView Members
WebDAVView Class Constructors Methods Properties See Also Send Feedback

The WebDAVView type exposes the following members.

Constructors

 | Name | Description
Protected method | WebDAVView | Initializes a new instance of the WebDAVView class

Methods

 | Name | Description
Public method | ConstructHierarchyItem | Constructs the hierarchy item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateFakeFolder | Generates the fake folder.
Public method | GetChildren | Gets the children.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHierarchyItem(String, WebDAVEngine) | Gets the hierarchy item.
Protected method | GetHierarchyItem(WebDAVMediaRequest, WebDAVEngine) | Gets the hierarchy item.
Protected method | GetMedia | Gets the media.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWebDAVItemPath | Gets the web DAV item path.
Public method | Initialize | Initializes the provider. (Inherited from ProviderBase.)
Protected method | IsContentRequest | Determines whether it is request to sitecore content or not.
Protected method | IsMediaItem | Determines whether the items is media item or not.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Modified | Checks for not-modified.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AutoGenerateVersionNumbers | Gets a value indicating whether we need to generate version numbers automatically.
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | DescriptionKey | Gets DescriptionKey.
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

WebDAVView Class
Sitecore.Data.Views Namespace


WebDAVView Constructor

[image]

Sitecore 6.4.1 API
WebDAVView Constructor
WebDAVView Class See Also Send Feedback

Namespace: Sitecore.Data.Views
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected WebDAVView()
Visual Basic
Protected Sub New
Visual C++
protected:
WebDAVView()

See Also

WebDAVView Class
Sitecore.Data.Views Namespace


WebDAVView Methods

[image] [image]

Sitecore 6.4.1 API
WebDAVView Methods
WebDAVView Class See Also Send Feedback

The WebDAVView type exposes the following members.

Methods

 | Name | Description
Public method | ConstructHierarchyItem | Constructs the hierarchy item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateFakeFolder | Generates the fake folder.
Public method | GetChildren | Gets the children.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHierarchyItem(String, WebDAVEngine) | Gets the hierarchy item.
Protected method | GetHierarchyItem(WebDAVMediaRequest, WebDAVEngine) | Gets the hierarchy item.
Protected method | GetMedia | Gets the media.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWebDAVItemPath | Gets the web DAV item path.
Public method | Initialize | Initializes the provider. (Inherited from ProviderBase.)
Protected method | IsContentRequest | Determines whether it is request to sitecore content or not.
Protected method | IsMediaItem | Determines whether the items is media item or not.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Modified | Checks for not-modified.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WebDAVView Class
Sitecore.Data.Views Namespace


GenerateFakeFolder Method

[image]

Sitecore 6.4.1 API
WebDAVView..::..GenerateFakeFolder Method
WebDAVView Class See Also Send Feedback

Namespace: Sitecore.Data.Views
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual WebDAVFakeFolder GenerateFakeFolder(
    string rawUrl,
    WebDAVEngine engine,
    HttpRequest request
)
Visual Basic
Protected Overridable Function GenerateFakeFolder ( _
    rawUrl As String, _
    engine As WebDAVEngine, _
    request As HttpRequest _
) As WebDAVFakeFolder
Visual C++
protected:
virtual WebDAVFakeFolder^ GenerateFakeFolder(
    String^ rawUrl,
    WebDAVEngine^ engine,
    HttpRequest^ request
)

Parameters

rawUrl
Type: System..::..String
The raw URL.
engine
Type: Sitecore.Web..::..WebDAVEngine
The engine.
request
Type: System.Web..::..HttpRequest
The request.

Return Value

The Fake folder for the current URL.

See Also

WebDAVView Class
Sitecore.Data.Views Namespace


GetChildren Method

[image]

Sitecore 6.4.1 API
WebDAVView..::..GetChildren Method
WebDAVView Class See Also Send Feedback

Namespace: Sitecore.Data.Views
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual WebDAVHierarchyItem[] GetChildren(
    WebDAVHierarchyItem item,
    WebDAVEngine engine
)
Visual Basic
Public Overridable Function GetChildren ( _
    item As WebDAVHierarchyItem, _
    engine As WebDAVEngine _
) As WebDAVHierarchyItem()
Visual C++
public:
virtual array<WebDAVHierarchyItem^>^ GetChildren(
    WebDAVHierarchyItem^ item,
    WebDAVEngine^ engine
)

Parameters

item
Type: Sitecore.Data.Items..::..WebDAVHierarchyItem
The Sitecore item.
engine
Type: Sitecore.Web..::..WebDAVEngine
The engine.

Return Value

Children collection.

See Also

WebDAVView Class
Sitecore.Data.Views Namespace


GetHierarchyItem Method

[image] [image]

Sitecore 6.4.1 API
WebDAVView..::..GetHierarchyItem Method
WebDAVView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetHierarchyItem(String, WebDAVEngine) | Gets the hierarchy item.
Protected method | GetHierarchyItem(WebDAVMediaRequest, WebDAVEngine) | Gets the hierarchy item.

See Also

WebDAVView Class
WebDAVView Members
Sitecore.Data.Views Namespace


GetHierarchyItem Method (String, WebDAVEngine)

[image]

Sitecore 6.4.1 API
WebDAVView..::..GetHierarchyItem Method (String, WebDAVEngine)
WebDAVView Class See Also Send Feedback

Namespace: Sitecore.Data.Views
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual IHierarchyItem GetHierarchyItem(
    string path,
    WebDAVEngine engine
)
Visual Basic
Public Overridable Function GetHierarchyItem ( _
    path As String, _
    engine As WebDAVEngine _
) As IHierarchyItem
Visual C++
public:
virtual IHierarchyItem^ GetHierarchyItem(
    String^ path,
    WebDAVEngine^ engine
)

Parameters

path
Type: System..::..String
The request path.
engine
Type: Sitecore.Web..::..WebDAVEngine
The engine.

Return Value

The Web DAV hierarchy item.

Exceptions

Exception | Condition
Sitecore.Exceptions..::..MediaException | Cannot parse media request.
Sitecore.Exceptions..::..ItemNotFoundException | ItemNotFoundException.
Sitecore.Exceptions..::..SecurityException | There is no access to the requested item.
Sitecore.Exceptions..::..MediaIsNotModifiedException | Media is not modified.
System..::..Exception | Exception.

See Also

WebDAVView Class
GetHierarchyItem Overload
Sitecore.Data.Views Namespace


GetHierarchyItem Method (WebDAVMediaRequest, WebDAVEngine)

[image]

Sitecore 6.4.1 API
WebDAVView..::..GetHierarchyItem Method (WebDAVMediaRequest, WebDAVEngine)
WebDAVView Class See Also Send Feedback

Namespace: Sitecore.Data.Views
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual WebDAVHierarchyItem GetHierarchyItem(
    WebDAVMediaRequest request,
    WebDAVEngine engine
)
Visual Basic
Protected Overridable Function GetHierarchyItem ( _
    request As WebDAVMediaRequest, _
    engine As WebDAVEngine _
) As WebDAVHierarchyItem
Visual C++
protected:
virtual WebDAVHierarchyItem^ GetHierarchyItem(
    WebDAVMediaRequest^ request,
    WebDAVEngine^ engine
)

Parameters

request
Type: Sitecore.Resources.Media..::..WebDAVMediaRequest
The media request.
engine
Type: Sitecore.Web..::..WebDAVEngine
The engine.

Return Value

The Hierarcy Item.

See Also

WebDAVView Class
GetHierarchyItem Overload
Sitecore.Data.Views Namespace


GetMedia Method

[image]

Sitecore 6.4.1 API
WebDAVView..::..GetMedia Method
WebDAVView Class See Also Send Feedback

Namespace: Sitecore.Data.Views
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual Media GetMedia(
    MediaRequest request
)
Visual Basic
Protected Overridable Function GetMedia ( _
    request As MediaRequest _
) As Media
Visual C++
protected:
virtual Media^ GetMedia(
    MediaRequest^ request
)

Parameters

request
Type: Sitecore.Resources.Media..::..MediaRequest
The media request.

Return Value

The Media.

See Also

WebDAVView Class
Sitecore.Data.Views Namespace


GetWebDAVItemPath Method

[image]

Sitecore 6.4.1 API
WebDAVView..::..GetWebDAVItemPath Method
WebDAVView Class See Also Send Feedback

Namespace: Sitecore.Data.Views
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string GetWebDAVItemPath(
    MediaItem item
)
Visual Basic
Public Overridable Function GetWebDAVItemPath ( _
    item As MediaItem _
) As String
Visual C++
public:
virtual String^ GetWebDAVItemPath(
    MediaItem^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..MediaItem
The Media item.

Return Value

The WebDAV item path.

See Also

WebDAVView Class
Sitecore.Data.Views Namespace


IsMediaItem Method

[image]

Sitecore 6.4.1 API
WebDAVView..::..IsMediaItem Method
WebDAVView Class See Also Send Feedback

Namespace: Sitecore.Data.Views
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool IsMediaItem(
    Item item,
    string dataFieldName
)
Visual Basic
Protected Overridable Function IsMediaItem ( _
    item As Item, _
    dataFieldName As String _
) As Boolean
Visual C++
protected:
virtual bool IsMediaItem(
    Item^ item,
    String^ dataFieldName
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item.
dataFieldName
Type: System..::..String
Name of the data field.

Return Value

true if the specified item is media item; otherwise, false.

See Also

WebDAVView Class
Sitecore.Data.Views Namespace


Modified Method

[image]

Sitecore 6.4.1 API
WebDAVView..::..Modified Method
WebDAVView Class See Also Send Feedback

Namespace: Sitecore.Data.Views
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual Tristate Modified(
    HttpRequest request,
    Media media,
    MediaOptions options
)
Visual Basic
Protected Overridable Function Modified ( _
    request As HttpRequest, _
    media As Media, _
    options As MediaOptions _
) As Tristate
Visual C++
protected:
virtual Tristate Modified(
    HttpRequest^ request,
    Media^ media,
    MediaOptions^ options
)

Parameters

request
Type: System.Web..::..HttpRequest
The request.
media
Type: Sitecore.Resources.Media..::..Media
The media.
options
Type: Sitecore.Resources.Media..::..MediaOptions
The options.

Return Value

The value that indicates whether Media was modified or not.

See Also

WebDAVView Class
Sitecore.Data.Views Namespace


DescriptionKey Property

[image]

Sitecore 6.4.1 API
WebDAVView..::..DescriptionKey Property
WebDAVView Class See Also Send Feedback

Namespace: Sitecore.Data.Views
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string DescriptionKey { get; }
Visual Basic
Public Overridable ReadOnly Property DescriptionKey As String
    Get
Visual C++
public:
virtual property String^ DescriptionKey {
    String^ get ();
}

Field Value

The description key.

See Also

WebDAVView Class
Sitecore.Data.Views Namespace


WebDAVViewProviderCollection Members

[image] [image]

Sitecore 6.4.1 API
WebDAVViewProviderCollection Members
WebDAVViewProviderCollection Class Constructors Methods Properties See Also Send Feedback

The WebDAVViewProviderCollection type exposes the following members.

Constructors

 | Name | Description
Public method | WebDAVViewProviderCollection | Initializes a new instance of the WebDAVViewProviderCollection class

Methods

 | Name | Description
Public method | Add | Adds a provider to the collection. (Inherited from ProviderCollection.)
Public method | Clear | Removes all items from the collection. (Inherited from ProviderCollection.)
Public method | CopyTo | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a provider from the collection. (Inherited from ProviderCollection.)
Public method | SetReadOnly | Sets the collection to be read-only. (Inherited from ProviderCollection.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
Public property | Item | Gets the WebDAVView with the specified name.
Public property | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)

See Also

WebDAVViewProviderCollection Class
Sitecore.Data.Views Namespace


WebDAVViewProviderCollection Constructor

[image]

Sitecore 6.4.1 API
WebDAVViewProviderCollection Constructor
WebDAVViewProviderCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Views
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WebDAVViewProviderCollection()
Visual Basic
Public Sub New
Visual C++
public:
WebDAVViewProviderCollection()

See Also

WebDAVViewProviderCollection Class
Sitecore.Data.Views Namespace


WebDAVViewProviderCollection Methods

[image] [image]

Sitecore 6.4.1 API
WebDAVViewProviderCollection Methods
WebDAVViewProviderCollection Class See Also Send Feedback

The WebDAVViewProviderCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds a provider to the collection. (Inherited from ProviderCollection.)
Public method | Clear | Removes all items from the collection. (Inherited from ProviderCollection.)
Public method | CopyTo | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a provider from the collection. (Inherited from ProviderCollection.)
Public method | SetReadOnly | Sets the collection to be read-only. (Inherited from ProviderCollection.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WebDAVViewProviderCollection Class
Sitecore.Data.Views Namespace


WebDAVViewProviderCollection Properties

[image] [image]

Sitecore 6.4.1 API
WebDAVViewProviderCollection Properties
WebDAVViewProviderCollection Class See Also Send Feedback

The WebDAVViewProviderCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
Public property | Item | Gets the WebDAVView with the specified name.
Public property | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)

See Also

WebDAVViewProviderCollection Class
Sitecore.Data.Views Namespace


Item Property

[image]

Sitecore 6.4.1 API
WebDAVViewProviderCollection..::..Item Property
WebDAVViewProviderCollection Class See Also Send Feedback

Namespace: Sitecore.Data.Views
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WebDAVView this[
    string name
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    name As String _
) As WebDAVView
    Get
Visual C++
public:
property WebDAVView^ default[String^ name] {
    WebDAVView^ get (String^ name);
}

Parameters

name
Type: System..::..String
The view name.

Field Value

The Web DAV view.

See Also

WebDAVViewProviderCollection Class
Sitecore.Data.Views Namespace


Sitecore.Diagnostics Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Diagnostics Namespace
Send Feedback

Classes

 | Class | Description
Public class | AnalyticsLogger | Defines the analytics logger class.
Public class | AnalyticsLogger..::..LogEntry | Defines the log entry class.
Public class | Assert | Assertions.
Public class | Audit | Writes Audit information to a file.
Public class | AuditFormatter |
Public class | AuditStorageProvider | The abstract base class for audit storage providers.
Public class | CallStack | Represents the current call stack.
Public class | Counter | Obsolete. Represents a Counter.
Public class | Counter..::..Worker | Represents a Worker.
Public class | CounterData | Obsolete. Container for counters.
Public class | CounterLock | Obsolete. Lock that can be held by many threads simultaneously.
Public class | Counters | Obsolete. Container for counters.
Public class | CycleAsserter | RecursionLimit class
Public class | CycleDetector | RecursionLimit class
Public class | Debug | Debug class
Public class | DiagnosticContext | Represents the current diagnostics context.
Public class | DiagnosticWorker | Represents a DiagnosticWorker.
Public class | DisposeHelper | DisposeHelper
Public class | Error | Defines methods for error handling.
Public class | EventDispatcher | Class for dispatching events.
Public class | HealthMonitorHook | Implements a hook for the health monitor
Public class | HighResTimer | Implements a class that encapsulates the operating system high resolution timer using native API functions.
Public class | Log | Represents the Log.
Public class | LoggerFactory | Creates the Log object.
Public class | LogNotification | Defines the log notification class.
Public class | LongRunningOperationWatcher | ProfileSection class
Public class | MemoryMonitorHook | Implements a hook for the memory monitor
Public class | ProfileEntry | ProfileData
Public class | Profiler | Represents the Profiler.
Public class | Profiler..::..Worker | Represents a Worker.
Public class | ProfileSection | ProfileSection class
Public class | RecursionLimit | RecursionLimit class
Public class | Statistics | Statistics
Public class | Statistics..::..PipelineTiming | PipelineTiming class
Public class | Statistics..::..RenderingData | RenderingData
Public class | TextLog | TextLog class
Public class | TextLogEntry | TextLogEntry class
Public class | ThreadError | Thread error container class.
Public class | Tracer | Represents the Tracer.
Public class | Tracer..::..Worker | Represents a Worker.
Public class | UnitTester | Test related utility functions
Public class | WebDAV | Log functionality for WebDAV requests.

Delegates

 | Delegate | Description
Public delegate | LogNotification..::..LogNotificationDelegate | Delegate.

Enumerations

 | Enumeration | Description
Public enumeration | FailureReason | FailureReason
Public enumeration | LogNotificationLevel | The level of log information.
Public enumeration | TextLog..::..Severity | Severity


AnalyticsLogger Class

[image]

Sitecore 6.4.1 API
AnalyticsLogger Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class AnalyticsLogger : IDisposable
Visual Basic
Public Class AnalyticsLogger _
    Implements IDisposable
Visual C++
public ref class AnalyticsLogger : IDisposable

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..AnalyticsLogger

See Also

AnalyticsLogger Members
Sitecore.Diagnostics Namespace


AnalyticsLogger Members

[image] [image]

Sitecore 6.4.1 API
AnalyticsLogger Members
AnalyticsLogger Class Constructors Methods Properties See Also Send Feedback

The AnalyticsLogger type exposes the following members.

Constructors

 | Name | Description
Public method | AnalyticsLogger | Initializes a new instance of the AnalyticsLogger class.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the AnalyticsLogger class. Releases unmanaged resources and performs other cleanup operations before the AnalyticsLoggeris reclaimed by garbage collection. (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Start | Starts this instance.
Public method | Stop | Stops this instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
 | Current | Gets the current.
Public property | Entries | Gets the log entries.

See Also

AnalyticsLogger Class
Sitecore.Diagnostics Namespace


AnalyticsLogger Constructor

[image]

Sitecore 6.4.1 API
AnalyticsLogger Constructor
AnalyticsLogger Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public AnalyticsLogger()
Visual Basic
Public Sub New
Visual C++
public:
AnalyticsLogger()

See Also

AnalyticsLogger Class
Sitecore.Diagnostics Namespace


AnalyticsLogger Methods

[image] [image]

Sitecore 6.4.1 API
AnalyticsLogger Methods
AnalyticsLogger Class See Also Send Feedback

The AnalyticsLogger type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalizes an instance of the AnalyticsLogger class. Releases unmanaged resources and performs other cleanup operations before the AnalyticsLoggeris reclaimed by garbage collection. (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Start | Starts this instance.
Public method | Stop | Stops this instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticsLogger Class
Sitecore.Diagnostics Namespace


Dispose Method

[image]

Sitecore 6.4.1 API
AnalyticsLogger..::..Dispose Method
AnalyticsLogger Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

Exceptions

Exception | Condition
System..::..ArgumentNullException |

See Also

AnalyticsLogger Class
Sitecore.Diagnostics Namespace


Finalize Method

[image]

Sitecore 6.4.1 API
AnalyticsLogger..::..Finalize Method
AnalyticsLogger Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

AnalyticsLogger Class
Sitecore.Diagnostics Namespace


Start Method

[image]

Sitecore 6.4.1 API
AnalyticsLogger..::..Start Method
AnalyticsLogger Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static void Start()
Visual Basic
Public Shared Sub Start
Visual C++
public:
static void Start()

See Also

AnalyticsLogger Class
Sitecore.Diagnostics Namespace


Stop Method

[image]

Sitecore 6.4.1 API
AnalyticsLogger..::..Stop Method
AnalyticsLogger Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void Stop()
Visual Basic
Public Sub Stop
Visual C++
public:
void Stop()

See Also

AnalyticsLogger Class
Sitecore.Diagnostics Namespace


AnalyticsLogger Properties

[image] [image]

Sitecore 6.4.1 API
AnalyticsLogger Properties
AnalyticsLogger Class See Also Send Feedback

The AnalyticsLogger type exposes the following members.

Properties

 | Name | Description
 | Current | Gets the current.
Public property | Entries | Gets the log entries.

See Also

AnalyticsLogger Class
Sitecore.Diagnostics Namespace


Current Property

[image]

Sitecore 6.4.1 API
AnalyticsLogger..::..Current Property
AnalyticsLogger Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static AnalyticsLogger Current { get; }
Visual Basic
Public Shared ReadOnly Property Current As AnalyticsLogger
    Get
Visual C++
public:
static property AnalyticsLogger^ Current {
    AnalyticsLogger^ get ();
}

Field Value

The current.

See Also

AnalyticsLogger Class
Sitecore.Diagnostics Namespace


Entries Property

[image]

Sitecore 6.4.1 API
AnalyticsLogger..::..Entries Property
AnalyticsLogger Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public List<AnalyticsLogger..::..LogEntry> Entries { get; }
Visual Basic
Public ReadOnly Property Entries As List(Of AnalyticsLogger..::..LogEntry)
    Get
Visual C++
public:
property List<AnalyticsLogger..::..LogEntry^>^ Entries {
    List<AnalyticsLogger..::..LogEntry^>^ get ();
}

Field Value

The list of log entries.

See Also

AnalyticsLogger Class
Sitecore.Diagnostics Namespace


AnalyticsLogger.LogEntry Class

[image]

Sitecore 6.4.1 API
AnalyticsLogger..::..LogEntry Class
AnalyticsLogger Class Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class LogEntry
Visual Basic
Public Class LogEntry
Visual C++
public ref class LogEntry

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..AnalyticsLogger..::..LogEntry

See Also

AnalyticsLogger..::..LogEntry Members
Sitecore.Diagnostics Namespace


AnalyticsLogger.LogEntry Members

[image] [image]

Sitecore 6.4.1 API
AnalyticsLogger..::..LogEntry Members
AnalyticsLogger..::..LogEntry Class Constructors Methods Properties See Also Send Feedback

Defines the analytics logger class.

The AnalyticsLogger..::..LogEntry type exposes the following members.

Constructors

 | Name | Description
Public method | AnalyticsLogger..::..LogEntry | Initializes a new instance of the AnalyticsLogger..::..LogEntry class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Exception | Gets or sets the exception.
Public property | Level | Gets or sets the level.
Public property | Message | Gets or sets the message.

See Also

AnalyticsLogger..::..LogEntry Class
Sitecore.Diagnostics Namespace


AnalyticsLogger.LogEntry Methods

[image] [image]

Sitecore 6.4.1 API
AnalyticsLogger..::..LogEntry Methods
AnalyticsLogger..::..LogEntry Class See Also Send Feedback

The AnalyticsLogger..::..LogEntry type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticsLogger..::..LogEntry Class
Sitecore.Diagnostics Namespace


AnalyticsLogger.LogEntry Properties

[image] [image]

Sitecore 6.4.1 API
AnalyticsLogger..::..LogEntry Properties
AnalyticsLogger..::..LogEntry Class See Also Send Feedback

The AnalyticsLogger..::..LogEntry type exposes the following members.

Properties

 | Name | Description
Public property | Exception | Gets or sets the exception.
Public property | Level | Gets or sets the level.
Public property | Message | Gets or sets the message.

See Also

AnalyticsLogger..::..LogEntry Class
Sitecore.Diagnostics Namespace


Exception Property

[image]

Sitecore 6.4.1 API
AnalyticsLogger..::..LogEntry..::..Exception Property
AnalyticsLogger..::..LogEntry Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Exception Exception { get; set; }
Visual Basic
Public Property Exception As Exception
    Get
    Set
Visual C++
public:
property Exception^ Exception {
    Exception^ get ();
    void set (Exception^ value);
}

Field Value

The exception.

See Also

AnalyticsLogger..::..LogEntry Class
Sitecore.Diagnostics Namespace


Level Property

[image]

Sitecore 6.4.1 API
AnalyticsLogger..::..LogEntry..::..Level Property
AnalyticsLogger..::..LogEntry Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public LogNotificationLevel Level { get; set; }
Visual Basic
Public Property Level As LogNotificationLevel
    Get
    Set
Visual C++
public:
property LogNotificationLevel Level {
    LogNotificationLevel get ();
    void set (LogNotificationLevel value);
}

Field Value

The level.

See Also

AnalyticsLogger..::..LogEntry Class
Sitecore.Diagnostics Namespace


Message Property

[image]

Sitecore 6.4.1 API
AnalyticsLogger..::..LogEntry..::..Message Property
AnalyticsLogger..::..LogEntry Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Analytics (in Sitecore.Analytics.dll) Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Message { get; set; }
Visual Basic
Public Property Message As String
    Get
    Set
Visual C++
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}

Field Value

The message.

See Also

AnalyticsLogger..::..LogEntry Class
Sitecore.Diagnostics Namespace


Assert Class

[image]

Sitecore 6.4.1 API
Assert Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Assert
Visual Basic
Public NotInheritable Class Assert
Visual C++
public ref class Assert abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..Assert

See Also

Assert Members
Sitecore.Diagnostics Namespace


Assert Members

[image] [image]

Sitecore 6.4.1 API
Assert Members
Assert Class Methods See Also Send Feedback

The Assert type exposes the following members.

Methods

Name | Description
AreEqual(Int32, Int32, String) | Asserts that the arguments are equal.
AreEqual(String, String, String) | Asserts that the arguments are equal.
AreEqual(Int32, Int32, String, array<Object>[]()[][]) | Asserts that the arguments are equal.
AreEqual(String, String, String, array<Object>[]()[][]) | Asserts that the arguments are equal.
ArgumentCondition | Asserts a condition on an argument.
ArgumentNotNull(Object, Func<(Of <<'(String>)>>)) | Asserts that the arguments are not null.
ArgumentNotNull(Object, String) | Asserts that the arguments are not null.
ArgumentNotNullOrEmpty(String, Func<(Of <<'(String>)>>)) | Asserts that the arguments are not null or empty.
ArgumentNotNullOrEmpty(String, String) | Asserts that the arguments are not null or empty.
ArgumentNotNullOrEmpty(ID, String) | Asserts that the arguments are not null or empty.
CanRunApplication | Determines whether this instance [can run application] the specified application.
HasAccess(Boolean, String) | Determines whether the specified access is allowed.
HasAccess(Boolean, String, array<Object>[]()[][]) | Determines whether the specified access is allowed.
IsEditing | Determines whether the specified item is in editing mode.
IsFalse(Boolean, Func<(Of <<'(String>)>>)) | Asserts that the specified condition is false.
IsFalse(Boolean, String) | Asserts that the specified condition is false.
IsFalse(Boolean, String, array<Object>[]()[][]) | Asserts that the specified condition is false.
IsNotNull(Object, String) | Asserts that the specified value is not null.
IsNotNull(Object, Type) | Asserts that the specified value is not null.
IsNotNull(Object, String, array<Object>[]()[][]) | Asserts that the specified value is not null.
IsNotNull(Object, Type, String, array<Object>[]()[][]) | Asserts that the specified value is not null.
IsNotNullOrEmpty(String, String) | Asserts that the specified value is not null.
IsNotNullOrEmpty(String, String, array<Object>[]()[][]) | Asserts that the specified string is not null or empty.
IsNull(Object, String) | Asserts that the specified value is null.
IsNull(Object, String, array<Object>[]()[][]) | Asserts that the specified value is null.
IsTrue(Boolean, Func<(Of <<'(String>)>>)) | Determines whether the specified condition is true.
IsTrue(Boolean, String) | Determines whether the specified condition is true.
IsTrue(Boolean, String, array<Object>[]()[][]) | Determines whether the specified condition is true.
ReflectionObjectCreated | Asserts that the object is created.
Required(Object, String) | Throws a RequiredObjectIsNullException if a specific condition is not met.
Required(Object, String, array<Object>[]()[][]) | Throws a RequiredObjectIsNullException if a specific condition is not met.
ResultNotNull<(Of <<'(T>)>>)(T) | Results the not null.
ResultNotNull<(Of <<'(T>)>>)(T, String) | Results the not null.

See Also

Assert Class
Sitecore.Diagnostics Namespace


Assert Methods

[image] [image]

Sitecore 6.4.1 API
Assert Methods
Assert Class See Also Send Feedback

The Assert type exposes the following members.

Methods

Name | Description
AreEqual(Int32, Int32, String) | Asserts that the arguments are equal.
AreEqual(String, String, String) | Asserts that the arguments are equal.
AreEqual(Int32, Int32, String, array<Object>[]()[][]) | Asserts that the arguments are equal.
AreEqual(String, String, String, array<Object>[]()[][]) | Asserts that the arguments are equal.
ArgumentCondition | Asserts a condition on an argument.
ArgumentNotNull(Object, Func<(Of <<'(String>)>>)) | Asserts that the arguments are not null.
ArgumentNotNull(Object, String) | Asserts that the arguments are not null.
ArgumentNotNullOrEmpty(String, Func<(Of <<'(String>)>>)) | Asserts that the arguments are not null or empty.
ArgumentNotNullOrEmpty(String, String) | Asserts that the arguments are not null or empty.
ArgumentNotNullOrEmpty(ID, String) | Asserts that the arguments are not null or empty.
CanRunApplication | Determines whether this instance [can run application] the specified application.
HasAccess(Boolean, String) | Determines whether the specified access is allowed.
HasAccess(Boolean, String, array<Object>[]()[][]) | Determines whether the specified access is allowed.
IsEditing | Determines whether the specified item is in editing mode.
IsFalse(Boolean, Func<(Of <<'(String>)>>)) | Asserts that the specified condition is false.
IsFalse(Boolean, String) | Asserts that the specified condition is false.
IsFalse(Boolean, String, array<Object>[]()[][]) | Asserts that the specified condition is false.
IsNotNull(Object, String) | Asserts that the specified value is not null.
IsNotNull(Object, Type) | Asserts that the specified value is not null.
IsNotNull(Object, String, array<Object>[]()[][]) | Asserts that the specified value is not null.
IsNotNull(Object, Type, String, array<Object>[]()[][]) | Asserts that the specified value is not null.
IsNotNullOrEmpty(String, String) | Asserts that the specified value is not null.
IsNotNullOrEmpty(String, String, array<Object>[]()[][]) | Asserts that the specified string is not null or empty.
IsNull(Object, String) | Asserts that the specified value is null.
IsNull(Object, String, array<Object>[]()[][]) | Asserts that the specified value is null.
IsTrue(Boolean, Func<(Of <<'(String>)>>)) | Determines whether the specified condition is true.
IsTrue(Boolean, String) | Determines whether the specified condition is true.
IsTrue(Boolean, String, array<Object>[]()[][]) | Determines whether the specified condition is true.
ReflectionObjectCreated | Asserts that the object is created.
Required(Object, String) | Throws a RequiredObjectIsNullException if a specific condition is not met.
Required(Object, String, array<Object>[]()[][]) | Throws a RequiredObjectIsNullException if a specific condition is not met.
ResultNotNull<(Of <<'(T>)>>)(T) | Results the not null.
ResultNotNull<(Of <<'(T>)>>)(T, String) | Results the not null.

See Also

Assert Class
Sitecore.Diagnostics Namespace


AreEqual Method

[image] [image]

Sitecore 6.4.1 API
Assert..::..AreEqual Method
Assert Class See Also Send Feedback

Overload List

Name | Description
AreEqual(Int32, Int32, String) | Asserts that the arguments are equal.
AreEqual(String, String, String) | Asserts that the arguments are equal.
AreEqual(Int32, Int32, String, array<Object>[]()[][]) | Asserts that the arguments are equal.
AreEqual(String, String, String, array<Object>[]()[][]) | Asserts that the arguments are equal.

See Also

Assert Class
Assert Members
Sitecore.Diagnostics Namespace


AreEqual Method (Int32, Int32, String)

[image]

Sitecore 6.4.1 API
Assert..::..AreEqual Method (Int32, Int32, String)
Assert Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void AreEqual(
    int value1,
    int value2,
    string message
)
Visual Basic
Public Shared Sub AreEqual ( _
    value1 As Integer, _
    value2 As Integer, _
    message As String _
)
Visual C++
public:
static void AreEqual(
    int value1,
    int value2,
    String^ message
)

Parameters

value1
Type: System..::..Int32
The value1.
value2
Type: System..::..Int32
The value2.
message
Type: System..::..String
The message.

Exceptions

Exception | Condition
Sitecore.Exceptions..::..InvalidValueException | InvalidValueException.

See Also

Assert Class
AreEqual Overload
Sitecore.Diagnostics Namespace


AreEqual Method (String, String, String)

[image]

Sitecore 6.4.1 API
Assert..::..AreEqual Method (String, String, String)
Assert Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void AreEqual(
    string value1,
    string value2,
    string message
)
Visual Basic
Public Shared Sub AreEqual ( _
    value1 As String, _
    value2 As String, _
    message As String _
)
Visual C++
public:
static void AreEqual(
    String^ value1,
    String^ value2,
    String^ message
)

Parameters

value1
Type: System..::..String
The value1.
value2
Type: System..::..String
The value2.
message
Type: System..::..String
The message.

Exceptions

Exception | Condition
Sitecore.Exceptions..::..InvalidValueException | InvalidValueException.

See Also

Assert Class
AreEqual Overload
Sitecore.Diagnostics Namespace


AreEqual Method (Int32, Int32, String, Object[])

[image]

Sitecore 6.4.1 API
Assert..::..AreEqual Method (Int32, Int32, String, array<Object>[]()[][])
Assert Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void AreEqual(
    int value1,
    int value2,
    string format,
    params Object[] args
)
Visual Basic
Public Shared Sub AreEqual ( _
    value1 As Integer, _
    value2 As Integer, _
    format As String, _
    ParamArray args As Object() _
)
Visual C++
public:
static void AreEqual(
    int value1,
    int value2,
    String^ format,
    ... array<Object^>^ args
)

Parameters

value1
Type: System..::..Int32
The value1.
value2
Type: System..::..Int32
The value2.
format
Type: System..::..String
The format.
args
Type: array< System..::..Object >[]()[][]
The arguments.

See Also

Assert Class
AreEqual Overload
Sitecore.Diagnostics Namespace


AreEqual Method (String, String, String, Object[])

[image]

Sitecore 6.4.1 API
Assert..::..AreEqual Method (String, String, String, array<Object>[]()[][])
Assert Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void AreEqual(
    string value1,
    string value2,
    string format,
    params Object[] args
)
Visual Basic
Public Shared Sub AreEqual ( _
    value1 As String, _
    value2 As String, _
    format As String, _
    ParamArray args As Object() _
)
Visual C++
public:
static void AreEqual(
    String^ value1,
    String^ value2,
    String^ format,
    ... array<Object^>^ args
)

Parameters

value1
Type: System..::..String
The value1.
value2
Type: System..::..String
The value2.
format
Type: System..::..String
The format.
args
Type: array< System..::..Object >[]()[][]
The arguments.

See Also

Assert Class
AreEqual Overload
Sitecore.Diagnostics Namespace


ArgumentCondition Method

[image]

Sitecore 6.4.1 API
Assert..::..ArgumentCondition Method
Assert Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void ArgumentCondition(
    bool condition,
    string argumentName,
    string message
)
Visual Basic
Public Shared Sub ArgumentCondition ( _
    condition As Boolean, _
    argumentName As String, _
    message As String _
)
Visual C++
public:
static void ArgumentCondition(
    bool condition,
    String^ argumentName,
    String^ message
)

Parameters

condition
Type: System..::..Boolean
if set to true [condition].
argumentName
Type: System..::..String
Name of the argument.
message
Type: System..::..String
The message.

Exceptions

Exception | Condition
System..::..ArgumentException | ArgumentException.

See Also

Assert Class
Sitecore.Diagnostics Namespace


ArgumentNotNull Method

[image] [image]

Sitecore 6.4.1 API
Assert..::..ArgumentNotNull Method
Assert Class See Also Send Feedback

Overload List

Name | Description
ArgumentNotNull(Object, Func<(Of <<'(String>)>>)) | Asserts that the arguments are not null.
ArgumentNotNull(Object, String) | Asserts that the arguments are not null.

See Also

Assert Class
Assert Members
Sitecore.Diagnostics Namespace


ArgumentNotNull Method (Object, Func(String))

[image]

Sitecore 6.4.1 API
Assert..::..ArgumentNotNull Method (Object, Func<(Of <(<'String>)>)>)
Assert Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void ArgumentNotNull(
    Object argument,
    Func<string> getArgumentName
)
Visual Basic
Public Shared Sub ArgumentNotNull ( _
    argument As Object, _
    getArgumentName As Func(Of String) _
)
Visual C++
public:
static void ArgumentNotNull(
    Object^ argument,
    Func<String^>^ getArgumentName
)

Parameters

argument
Type: System..::..Object
The argument value.
getArgumentName
Type: System..::..Func <(Of <(<' String >)>)>
The delegate used to get the parameter name.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the argument is null.

See Also

Assert Class
ArgumentNotNull Overload
Sitecore.Diagnostics Namespace


ArgumentNotNullOrEmpty Method

[image] [image]

Sitecore 6.4.1 API
Assert..::..ArgumentNotNullOrEmpty Method
Assert Class See Also Send Feedback

Overload List

Name | Description
ArgumentNotNullOrEmpty(String, Func<(Of <<'(String>)>>)) | Asserts that the arguments are not null or empty.
ArgumentNotNullOrEmpty(String, String) | Asserts that the arguments are not null or empty.
ArgumentNotNullOrEmpty(ID, String) | Asserts that the arguments are not null or empty.

See Also

Assert Class
Assert Members
Sitecore.Diagnostics Namespace


ArgumentNotNullOrEmpty Method (String, String)

[image]

Sitecore 6.4.1 API
Assert..::..ArgumentNotNullOrEmpty Method (String, String)
Assert Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void ArgumentNotNullOrEmpty(
    string argument,
    string argumentName
)
Visual Basic
Public Shared Sub ArgumentNotNullOrEmpty ( _
    argument As String, _
    argumentName As String _
)
Visual C++
public:
static void ArgumentNotNullOrEmpty(
    String^ argument,
    String^ argumentName
)

Parameters

argument
Type: System..::..String
The argument.
argumentName
Type: System..::..String
Name of the argument.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Null ids are not allowed.
System..::..ArgumentException | Empty strings are not allowed.

See Also

Assert Class
ArgumentNotNullOrEmpty Overload
Sitecore.Diagnostics Namespace


ArgumentNotNullOrEmpty Method (ID, String)

[image]

Sitecore 6.4.1 API
Assert..::..ArgumentNotNullOrEmpty Method (ID, String)
Assert Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void ArgumentNotNullOrEmpty(
    ID argument,
    string argumentName
)
Visual Basic
Public Shared Sub ArgumentNotNullOrEmpty ( _
    argument As ID, _
    argumentName As String _
)
Visual C++
public:
static void ArgumentNotNullOrEmpty(
    ID^ argument,
    String^ argumentName
)

Parameters

argument
Type: Sitecore.Data..::..ID
The argument.
argumentName
Type: System..::..String
Name of the argument.

Exceptions

Exception | Condition
System..::..ArgumentException | ArgumentException.

See Also

Assert Class
ArgumentNotNullOrEmpty Overload
Sitecore.Diagnostics Namespace


CanRunApplication Method

[image]

Sitecore 6.4.1 API
Assert..::..CanRunApplication Method
Assert Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void CanRunApplication(
    string application
)
Visual Basic
Public Shared Sub CanRunApplication ( _
    application As String _
)
Visual C++
public:
static void CanRunApplication(
    String^ application
)

Parameters

application
Type: System..::..String
The application.

See Also

Assert Class
Sitecore.Diagnostics Namespace


HasAccess Method

[image] [image]

Sitecore 6.4.1 API
Assert..::..HasAccess Method
Assert Class See Also Send Feedback

Overload List

Name | Description
HasAccess(Boolean, String) | Determines whether the specified access is allowed.
HasAccess(Boolean, String, array<Object>[]()[][]) | Determines whether the specified access is allowed.

See Also

Assert Class
Assert Members
Sitecore.Diagnostics Namespace


HasAccess Method (Boolean, String)

[image]

Sitecore 6.4.1 API
Assert..::..HasAccess Method (Boolean, String)
Assert Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void HasAccess(
    bool accessAllowed,
    string message
)
Visual Basic
Public Shared Sub HasAccess ( _
    accessAllowed As Boolean, _
    message As String _
)
Visual C++
public:
static void HasAccess(
    bool accessAllowed,
    String^ message
)

Parameters

accessAllowed
Type: System..::..Boolean
if set to true this access is allowed.
message
Type: System..::..String
The message.

Exceptions

Exception | Condition
Sitecore.Exceptions..::..AccessDeniedException | AccessDeniedException.

See Also

Assert Class
HasAccess Overload
Sitecore.Diagnostics Namespace


HasAccess Method (Boolean, String, Object[])

[image]

Sitecore 6.4.1 API
Assert..::..HasAccess Method (Boolean, String, array<Object>[]()[][])
Assert Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void HasAccess(
    bool accessAllowed,
    string format,
    params Object[] args
)
Visual Basic
Public Shared Sub HasAccess ( _
    accessAllowed As Boolean, _
    format As String, _
    ParamArray args As Object() _
)
Visual C++
public:
static void HasAccess(
    bool accessAllowed,
    String^ format,
    ... array<Object^>^ args
)

Parameters

accessAllowed
Type: System..::..Boolean
if set to true this access is allowed.
format
Type: System..::..String
The format.
args
Type: array< System..::..Object >[]()[][]
The arguments.

See Also

Assert Class
HasAccess Overload
Sitecore.Diagnostics Namespace


IsEditing Method

[image]

Sitecore 6.4.1 API
Assert..::..IsEditing Method
Assert Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void IsEditing(
    Item item
)
Visual Basic
Public Shared Sub IsEditing ( _
    item As Item _
)
Visual C++
public:
static void IsEditing(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Exceptions

Exception | Condition
Sitecore.Exceptions..::..EditingNotAllowedException | EditingNotAllowedException.

See Also

Assert Class
Sitecore.Diagnostics Namespace


IsFalse Method

[image] [image]

Sitecore 6.4.1 API
Assert..::..IsFalse Method
Assert Class See Also Send Feedback

Overload List

Name | Description
IsFalse(Boolean, Func<(Of <<'(String>)>>)) | Asserts that the specified condition is false.
IsFalse(Boolean, String) | Asserts that the specified condition is false.
IsFalse(Boolean, String, array<Object>[]()[][]) | Asserts that the specified condition is false.

See Also

Assert Class
Assert Members
Sitecore.Diagnostics Namespace


IsFalse Method (Boolean, Func(String))

[image]

Sitecore 6.4.1 API
Assert..::..IsFalse Method (Boolean, Func<(Of <(<'String>)>)>)
Assert Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void IsFalse(
    bool condition,
    Func<string> getMessage
)
Visual Basic
Public Shared Sub IsFalse ( _
    condition As Boolean, _
    getMessage As Func(Of String) _
)
Visual C++
public:
static void IsFalse(
    bool condition,
    Func<String^>^ getMessage
)

Parameters

condition
Type: System..::..Boolean

[Missing <param name="condition"/> documentation for "M:Sitecore.Diagnostics.Assert.IsFalse(System.Boolean,System.Func{System.String})"]

getMessage
Type: System..::..Func <(Of <(<' String >)>)>

[Missing <param name="getMessage"/> documentation for "M:Sitecore.Diagnostics.Assert.IsFalse(System.Boolean,System.Func{System.String})"]

Exceptions

Exception | Condition
System..::..InvalidOperationException | InvalidOperationException.

See Also

Assert Class
IsFalse Overload
Sitecore.Diagnostics Namespace


IsFalse Method (Boolean, String)

[image]

Sitecore 6.4.1 API
Assert..::..IsFalse Method (Boolean, String)
Assert Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void IsFalse(
    bool condition,
    string message
)
Visual Basic
Public Shared Sub IsFalse ( _
    condition As Boolean, _
    message As String _
)
Visual C++
public:
static void IsFalse(
    bool condition,
    String^ message
)

Parameters

condition
Type: System..::..Boolean

[Missing <param name="condition"/> documentation for "M:Sitecore.Diagnostics.Assert.IsFalse(System.Boolean,System.String)"]

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:Sitecore.Diagnostics.Assert.IsFalse(System.Boolean,System.String)"]

Exceptions

Exception | Condition
System..::..InvalidOperationException | InvalidOperationException.

See Also

Assert Class
IsFalse Overload
Sitecore.Diagnostics Namespace


IsFalse Method (Boolean, String, Object[])

[image]

Sitecore 6.4.1 API
Assert..::..IsFalse Method (Boolean, String, array<Object>[]()[][])
Assert Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void IsFalse(
    bool condition,
    string format,
    params Object[] args
)
Visual Basic
Public Shared Sub IsFalse ( _
    condition As Boolean, _
    format As String, _
    ParamArray args As Object() _
)
Visual C++
public:
static void IsFalse(
    bool condition,
    String^ format,
    ... array<Object^>^ args
)

Parameters

condition
Type: System..::..Boolean
The condition.
format
Type: System..::..String
The format.
args
Type: array< System..::..Object >[]()[][]
The arguments.

See Also

Assert Class
IsFalse Overload
Sitecore.Diagnostics Namespace


IsNotNull Method

[image] [image]

Sitecore 6.4.1 API
Assert..::..IsNotNull Method
Assert Class See Also Send Feedback

Overload List

Name | Description
IsNotNull(Object, String) | Asserts that the specified value is not null.
IsNotNull(Object, Type) | Asserts that the specified value is not null.
IsNotNull(Object, String, array<Object>[]()[][]) | Asserts that the specified value is not null.
IsNotNull(Object, Type, String, array<Object>[]()[][]) | Asserts that the specified value is not null.

See Also

Assert Class
Assert Members
Sitecore.Diagnostics Namespace


IsNotNull Method (Object, String)

[image]

Sitecore 6.4.1 API
Assert..::..IsNotNull Method (Object, String)
Assert Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void IsNotNull(
    Object value,
    string message
)
Visual Basic
Public Shared Sub IsNotNull ( _
    value As Object, _
    message As String _
)
Visual C++
public:
static void IsNotNull(
    Object^ value,
    String^ message
)

Parameters

value
Type: System..::..Object
The value.
message
Type: System..::..String
The message.

Exceptions

Exception | Condition
System..::..InvalidOperationException | InvalidOperationException.

See Also

Assert Class
IsNotNull Overload
Sitecore.Diagnostics Namespace


IsNotNull Method (Object, Type)

[image]

Sitecore 6.4.1 API
Assert..::..IsNotNull Method (Object, Type)
Assert Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void IsNotNull(
    Object value,
    Type type
)
Visual Basic
Public Shared Sub IsNotNull ( _
    value As Object, _
    type As Type _
)
Visual C++
public:
static void IsNotNull(
    Object^ value,
    Type^ type
)

Parameters

value
Type: System..::..Object
The value.
type
Type: System..::..Type
The object type.

See Also

Assert Class
IsNotNull Overload
Sitecore.Diagnostics Namespace


IsNotNull Method (Object, Type, String, Object[])

[image]

Sitecore 6.4.1 API
Assert..::..IsNotNull Method (Object, Type, String, array<Object>[]()[][])
Assert Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void IsNotNull(
    Object value,
    Type type,
    string format,
    params Object[] args
)
Visual Basic
Public Shared Sub IsNotNull ( _
    value As Object, _
    type As Type, _
    format As String, _
    ParamArray args As Object() _
)
Visual C++
public:
static void IsNotNull(
    Object^ value,
    Type^ type,
    String^ format,
    ... array<Object^>^ args
)

Parameters

value
Type: System..::..Object
The value.
type
Type: System..::..Type
The type.
format
Type: System..::..String
The format.
args
Type: array< System..::..Object >[]()[][]
The arguments.

See Also

Assert Class
IsNotNull Overload
Sitecore.Diagnostics Namespace


IsNotNullOrEmpty Method

[image] [image]

Sitecore 6.4.1 API
Assert..::..IsNotNullOrEmpty Method
Assert Class See Also Send Feedback

Overload List

Name | Description
IsNotNullOrEmpty(String, String) | Asserts that the specified value is not null.
IsNotNullOrEmpty(String, String, array<Object>[]()[][]) | Asserts that the specified string is not null or empty.

See Also

Assert Class
Assert Members
Sitecore.Diagnostics Namespace


IsNotNullOrEmpty Method (String, String)

[image]

Sitecore 6.4.1 API
Assert..::..IsNotNullOrEmpty Method (String, String)
Assert Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void IsNotNullOrEmpty(
    string value,
    string message
)
Visual Basic
Public Shared Sub IsNotNullOrEmpty ( _
    value As String, _
    message As String _
)
Visual C++
public:
static void IsNotNullOrEmpty(
    String^ value,
    String^ message
)

Parameters

value
Type: System..::..String
The value.
message
Type: System..::..String
The message.

Exceptions

Exception | Condition
System..::..InvalidOperationException | InvalidOperationException.

See Also

Assert Class
IsNotNullOrEmpty Overload
Sitecore.Diagnostics Namespace


IsNotNullOrEmpty Method (String, String, Object[])

[image]

Sitecore 6.4.1 API
Assert..::..IsNotNullOrEmpty Method (String, String, array<Object>[]()[][])
Assert Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void IsNotNullOrEmpty(
    string value,
    string format,
    params Object[] args
)
Visual Basic
Public Shared Sub IsNotNullOrEmpty ( _
    value As String, _
    format As String, _
    ParamArray args As Object() _
)
Visual C++
public:
static void IsNotNullOrEmpty(
    String^ value,
    String^ format,
    ... array<Object^>^ args
)

Parameters

value
Type: System..::..String
The value.
format
Type: System..::..String
The format.
args
Type: array< System..::..Object >[]()[][]
The args.

See Also

Assert Class
IsNotNullOrEmpty Overload
Sitecore.Diagnostics Namespace


IsNull Method (Object, String)

[image]

Sitecore 6.4.1 API
Assert..::..IsNull Method (Object, String)
Assert Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void IsNull(
    Object value,
    string message
)
Visual Basic
Public Shared Sub IsNull ( _
    value As Object, _
    message As String _
)
Visual C++
public:
static void IsNull(
    Object^ value,
    String^ message
)

Parameters

value
Type: System..::..Object
The value.
message
Type: System..::..String
The message.

Exceptions

Exception | Condition
System..::..InvalidOperationException | InvalidOperationException.

See Also

Assert Class
IsNull Overload
Sitecore.Diagnostics Namespace


IsNull Method (Object, String, Object[])

[image]

Sitecore 6.4.1 API
Assert..::..IsNull Method (Object, String, array<Object>[]()[][])
Assert Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void IsNull(
    Object value,
    string format,
    params Object[] args
)
Visual Basic
Public Shared Sub IsNull ( _
    value As Object, _
    format As String, _
    ParamArray args As Object() _
)
Visual C++
public:
static void IsNull(
    Object^ value,
    String^ format,
    ... array<Object^>^ args
)

Parameters

value
Type: System..::..Object
The value.
format
Type: System..::..String
The format.
args
Type: array< System..::..Object >[]()[][]
The arguments.

See Also

Assert Class
IsNull Overload
Sitecore.Diagnostics Namespace


IsTrue Method

[image] [image]

Sitecore 6.4.1 API
Assert..::..IsTrue Method
Assert Class See Also Send Feedback

Overload List

Name | Description
IsTrue(Boolean, Func<(Of <<'(String>)>>)) | Determines whether the specified condition is true.
IsTrue(Boolean, String) | Determines whether the specified condition is true.
IsTrue(Boolean, String, array<Object>[]()[][]) | Determines whether the specified condition is true.

See Also

Assert Class
Assert Members
Sitecore.Diagnostics Namespace


IsTrue Method (Boolean, Func(String))

[image]

Sitecore 6.4.1 API
Assert..::..IsTrue Method (Boolean, Func<(Of <(<'String>)>)>)
Assert Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void IsTrue(
    bool condition,
    Func<string> getMessage
)
Visual Basic
Public Shared Sub IsTrue ( _
    condition As Boolean, _
    getMessage As Func(Of String) _
)
Visual C++
public:
static void IsTrue(
    bool condition,
    Func<String^>^ getMessage
)

Parameters

condition
Type: System..::..Boolean
if set to true th condition is true.
getMessage
Type: System..::..Func <(Of <(<' String >)>)>
The get message delegate.

Exceptions

Exception | Condition
System..::..InvalidOperationException | InvalidOperationException.

See Also

Assert Class
IsTrue Overload
Sitecore.Diagnostics Namespace


IsTrue Method (Boolean, String)

[image]

Sitecore 6.4.1 API
Assert..::..IsTrue Method (Boolean, String)
Assert Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void IsTrue(
    bool condition,
    string message
)
Visual Basic
Public Shared Sub IsTrue ( _
    condition As Boolean, _
    message As String _
)
Visual C++
public:
static void IsTrue(
    bool condition,
    String^ message
)

Parameters

condition
Type: System..::..Boolean
if set to true th condition is true.
message
Type: System..::..String
The message.

Exceptions

Exception | Condition
System..::..InvalidOperationException | InvalidOperationException.

See Also

Assert Class
IsTrue Overload
Sitecore.Diagnostics Namespace


ReflectionObjectCreated Method

[image]

Sitecore 6.4.1 API
Assert..::..ReflectionObjectCreated Method
Assert Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void ReflectionObjectCreated(
    Object obj,
    string typeName
)
Visual Basic
Public Shared Sub ReflectionObjectCreated ( _
    obj As Object, _
    typeName As String _
)
Visual C++
public:
static void ReflectionObjectCreated(
    Object^ obj,
    String^ typeName
)

Parameters

obj
Type: System..::..Object
The object.
typeName
Type: System..::..String
Name of the type.

Exceptions

Exception | Condition
Sitecore.Exceptions..::..UnknownTypeException | The type could not be created.

See Also

Assert Class
Sitecore.Diagnostics Namespace


Required Method (Object, String)

[image]

Sitecore 6.4.1 API
Assert..::..Required Method (Object, String)
Assert Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Required(
    Object obj,
    string message
)
Visual Basic
Public Shared Sub Required ( _
    obj As Object, _
    message As String _
)
Visual C++
public:
static void Required(
    Object^ obj,
    String^ message
)

Parameters

obj
Type: System..::..Object
The object.
message
Type: System..::..String
The message.

Exceptions

Exception | Condition
Sitecore.Exceptions..::..RequiredObjectIsNullException | RequiredObjectIsNullException.

See Also

Assert Class
Required Overload
Sitecore.Diagnostics Namespace


Required Method (Object, String, Object[])

[image]

Sitecore 6.4.1 API
Assert..::..Required Method (Object, String, array<Object>[]()[][])
Assert Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Required(
    Object obj,
    string format,
    params Object[] args
)
Visual Basic
Public Shared Sub Required ( _
    obj As Object, _
    format As String, _
    ParamArray args As Object() _
)
Visual C++
public:
static void Required(
    Object^ obj,
    String^ format,
    ... array<Object^>^ args
)

Parameters

obj
Type: System..::..Object
The object.
format
Type: System..::..String
The format.
args
Type: array< System..::..Object >[]()[][]
The arguments.

See Also

Assert Class
Required Overload
Sitecore.Diagnostics Namespace


ResultNotNull Method

[image] [image]

Sitecore 6.4.1 API
Assert..::..ResultNotNull Method
Assert Class See Also Send Feedback

Overload List

Name | Description
ResultNotNull<(Of <<'(T>)>>)(T) | Results the not null.
ResultNotNull<(Of <<'(T>)>>)(T, String) | Results the not null.

See Also

Assert Class
Assert Members
Sitecore.Diagnostics Namespace


ResultNotNull(T) Method (T)

[image]

Sitecore 6.4.1 API
Assert..::..ResultNotNull<(Of <(<'T>)>)> Method (T)
Assert Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static T ResultNotNull<T>(
    T result
)
where T : class
Visual Basic
Public Shared Function ResultNotNull(Of T As Class) ( _
    result As T _
) As T
Visual C++
public:
generic<typename T>
where T : ref class
static T ResultNotNull(
    T result
)

Parameters

result
Type: T
The result.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Sitecore.Diagnostics.Assert.ResultNotNull``1(``0)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Diagnostics.Assert.ResultNotNull``1(``0)"]

See Also

Assert Class
ResultNotNull Overload
Sitecore.Diagnostics Namespace


ResultNotNull(T) Method (T, String)

[image]

Sitecore 6.4.1 API
Assert..::..ResultNotNull<(Of <(<'T>)>)> Method (T, String)
Assert Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static T ResultNotNull<T>(
    T result,
    string message
)
where T : class
Visual Basic
Public Shared Function ResultNotNull(Of T As Class) ( _
    result As T, _
    message As String _
) As T
Visual C++
public:
generic<typename T>
where T : ref class
static T ResultNotNull(
    T result,
    String^ message
)

Parameters

result
Type: T
The result.
message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:Sitecore.Diagnostics.Assert.ResultNotNull``1(``0,System.String)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Sitecore.Diagnostics.Assert.ResultNotNull``1(``0,System.String)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Diagnostics.Assert.ResultNotNull``1(``0,System.String)"]

See Also

Assert Class
ResultNotNull Overload
Sitecore.Diagnostics Namespace


Audit Class

[image]

Sitecore 6.4.1 API
Audit Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Audit
Visual Basic
Public NotInheritable Class Audit
Visual C++
public ref class Audit abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..Audit

See Also

Audit Members
Sitecore.Diagnostics Namespace


Audit Methods

[image] [image]

Sitecore 6.4.1 API
Audit Methods
Audit Class See Also Send Feedback

Methods

Name | Description
Write(String) | Obsolete. Writes an action to the audit log.
Write(String, Item) | Obsolete. Writes an action to the audit log.
Write(String, String) | Obsolete. Writes the specified action.
Write(String, String, Item) | Obsolete. Write an action to the audit log.

See Also

Audit Class
Sitecore.Diagnostics Namespace


Write Method

[image] [image]

Sitecore 6.4.1 API
Audit..::..Write Method
Audit Class See Also Send Feedback

Overload List

Name | Description
Write(String) | Obsolete. Writes an action to the audit log.
Write(String, Item) | Obsolete. Writes an action to the audit log.
Write(String, String) | Obsolete. Writes the specified action.
Write(String, String, Item) | Obsolete. Write an action to the audit log.

See Also

Audit Class
Audit Members
Sitecore.Diagnostics Namespace


Write Method (String)

[image]

Sitecore 6.4.1 API
Audit..::..Write Method (String)
Audit Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use Log.Audit instead.")]
public static void Write(
    string action
)
Visual Basic
<ObsoleteAttribute("Deprecated - Use Log.Audit instead.")> _
Public Shared Sub Write ( _
    action As String _
)
Visual C++
[ObsoleteAttribute(L"Deprecated - Use Log.Audit instead.")]
public:
static void Write(
    String^ action
)

Parameters

action
Type: System..::..String
The action.

See Also

Audit Class
Write Overload
Sitecore.Diagnostics Namespace


Write Method (String, Item)

[image]

Sitecore 6.4.1 API
Audit..::..Write Method (String, Item)
Audit Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use Log.Audit instead.")]
public static void Write(
    string action,
    Item item
)
Visual Basic
<ObsoleteAttribute("Deprecated - Use Log.Audit instead.")> _
Public Shared Sub Write ( _
    action As String, _
    item As Item _
)
Visual C++
[ObsoleteAttribute(L"Deprecated - Use Log.Audit instead.")]
public:
static void Write(
    String^ action,
    Item^ item
)

Parameters

action
Type: System..::..String
The action.
item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

Audit Class
Write Overload
Sitecore.Diagnostics Namespace


Write Method (String, String)

[image]

Sitecore 6.4.1 API
Audit..::..Write Method (String, String)
Audit Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use Log.Audit instead.")]
public static void Write(
    string action,
    string data
)
Visual Basic
<ObsoleteAttribute("Deprecated - Use Log.Audit instead.")> _
Public Shared Sub Write ( _
    action As String, _
    data As String _
)
Visual C++
[ObsoleteAttribute(L"Deprecated - Use Log.Audit instead.")]
public:
static void Write(
    String^ action,
    String^ data
)

Parameters

action
Type: System..::..String
The action.
data
Type: System..::..String
The data.

See Also

Audit Class
Write Overload
Sitecore.Diagnostics Namespace


Write Method (String, String, Item)

[image]

Sitecore 6.4.1 API
Audit..::..Write Method (String, String, Item)
Audit Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use Log.Audit instead.")]
public static void Write(
    string action,
    string data,
    Item item
)
Visual Basic
<ObsoleteAttribute("Deprecated - Use Log.Audit instead.")> _
Public Shared Sub Write ( _
    action As String, _
    data As String, _
    item As Item _
)
Visual C++
[ObsoleteAttribute(L"Deprecated - Use Log.Audit instead.")]
public:
static void Write(
    String^ action,
    String^ data,
    Item^ item
)

Parameters

action
Type: System..::..String
The action.
data
Type: System..::..String
The data.
item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

Audit Class
Write Overload
Sitecore.Diagnostics Namespace


AuditFormatter Members

[image] [image]

Sitecore 6.4.1 API
AuditFormatter Members
AuditFormatter Class Methods See Also Send Feedback

The AuditFormatter type exposes the following members.

Methods

Name | Description
FormatField | Formats the field.
FormatItem | Formats the item.

See Also

AuditFormatter Class
Sitecore.Diagnostics Namespace


AuditFormatter Methods

[image] [image]

Sitecore 6.4.1 API
AuditFormatter Methods
AuditFormatter Class See Also Send Feedback

The AuditFormatter type exposes the following members.

Methods

Name | Description
FormatField | Formats the field.
FormatItem | Formats the item.

See Also

AuditFormatter Class
Sitecore.Diagnostics Namespace


FormatField Method

[image]

Sitecore 6.4.1 API
AuditFormatter..::..FormatField Method
AuditFormatter Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string FormatField(
    Field field
)
Visual Basic
Public Shared Function FormatField ( _
    field As Field _
) As String
Visual C++
public:
static String^ FormatField(
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.

Return Value

The field.

See Also

AuditFormatter Class
Sitecore.Diagnostics Namespace


FormatItem Method

[image]

Sitecore 6.4.1 API
AuditFormatter..::..FormatItem Method
AuditFormatter Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string FormatItem(
    Item item
)
Visual Basic
Public Shared Function FormatItem ( _
    item As Item _
) As String
Visual C++
public:
static String^ FormatItem(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

The item.

See Also

AuditFormatter Class
Sitecore.Diagnostics Namespace


AuditStorageProvider Class

[image]

Sitecore 6.4.1 API
AuditStorageProvider Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class AuditStorageProvider
Visual Basic
Public MustInherit Class AuditStorageProvider
Visual C++
public ref class AuditStorageProvider abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..AuditStorageProvider

See Also

AuditStorageProvider Members
Sitecore.Diagnostics Namespace


AuditStorageProvider Members

[image] [image]

Sitecore 6.4.1 API
AuditStorageProvider Members
AuditStorageProvider Class Constructors Methods See Also Send Feedback

The AuditStorageProvider type exposes the following members.

Constructors

 | Name | Description
Protected method | AuditStorageProvider | Initializes a new instance of the AuditStorageProvider class

Methods

 | Name | Description
Public method | AddAudit | Adds auditing information to the audit log.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AuditStorageProvider Class
Sitecore.Diagnostics Namespace


AuditStorageProvider Constructor

[image]

Sitecore 6.4.1 API
AuditStorageProvider Constructor
AuditStorageProvider Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected AuditStorageProvider()
Visual Basic
Protected Sub New
Visual C++
protected:
AuditStorageProvider()

See Also

AuditStorageProvider Class
Sitecore.Diagnostics Namespace


AuditStorageProvider Methods

[image] [image]

Sitecore 6.4.1 API
AuditStorageProvider Methods
AuditStorageProvider Class See Also Send Feedback

The AuditStorageProvider type exposes the following members.

Methods

 | Name | Description
Public method | AddAudit | Adds auditing information to the audit log.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AuditStorageProvider Class
Sitecore.Diagnostics Namespace


AddAudit Method

[image]

Sitecore 6.4.1 API
AuditStorageProvider..::..AddAudit Method
AuditStorageProvider Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract void AddAudit(
    string category,
    string action,
    string entityId,
    string domainId
)
Visual Basic
Public MustOverride Sub AddAudit ( _
    category As String, _
    action As String, _
    entityId As String, _
    domainId As String _
)
Visual C++
public:
virtual void AddAudit(
    String^ category,
    String^ action,
    String^ entityId,
    String^ domainId
) abstract

Parameters

category
Type: System..::..String
The category.
action
Type: System..::..String
The action.
entityId
Type: System..::..String
The entity id.
domainId
Type: System..::..String
The domain id.

See Also

AuditStorageProvider Class
Sitecore.Diagnostics Namespace


CallStack Class

[image]

Sitecore 6.4.1 API
CallStack Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CallStack
Visual Basic
Public Class CallStack
Visual C++
public ref class CallStack

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..CallStack

See Also

CallStack Members
Sitecore.Diagnostics Namespace


CallStack Members

[image] [image]

Sitecore 6.4.1 API
CallStack Members
CallStack Class Constructors Methods Properties See Also Send Feedback

The CallStack type exposes the following members.

Constructors

 | Name | Description
Public method | CallStack | Initializes a new instance of the CallStack class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Peek | Peeks this instance.
Public method | Pop | Pops this instance.
Public method | Push | Pushes the specified entry.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the count.
Public property | ID | Gets the ID.
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | Sequence | Gets the sequence.

See Also

CallStack Class
Sitecore.Diagnostics Namespace


CallStack Methods

[image] [image]

Sitecore 6.4.1 API
CallStack Methods
CallStack Class See Also Send Feedback

The CallStack type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Peek | Peeks this instance.
Public method | Pop | Pops this instance.
Public method | Push | Pushes the specified entry.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CallStack Class
Sitecore.Diagnostics Namespace


Pop Method

[image]

Sitecore 6.4.1 API
CallStack..::..Pop Method
CallStack Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ProfileEntry Pop()
Visual Basic
Public Function Pop As ProfileEntry
Visual C++
public:
ProfileEntry^ Pop()

Return Value

[Missing <returns> documentation for "M:Sitecore.Diagnostics.CallStack.Pop"]

See Also

CallStack Class
Sitecore.Diagnostics Namespace


Push Method

[image]

Sitecore 6.4.1 API
CallStack..::..Push Method
CallStack Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Push(
    ProfileEntry entry
)
Visual Basic
Public Sub Push ( _
    entry As ProfileEntry _
)
Visual C++
public:
void Push(
    ProfileEntry^ entry
)

Parameters

entry
Type: Sitecore.Diagnostics..::..ProfileEntry
The entry.

See Also

CallStack Class
Sitecore.Diagnostics Namespace


CallStack Properties

[image] [image]

Sitecore 6.4.1 API
CallStack Properties
CallStack Class See Also Send Feedback

The CallStack type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the count.
Public property | ID | Gets the ID.
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | Sequence | Gets the sequence.

See Also

CallStack Class
Sitecore.Diagnostics Namespace


Count Property

[image]

Sitecore 6.4.1 API
CallStack..::..Count Property
CallStack Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
property int Count {
    int get ();
}

Field Value

The count.

See Also

CallStack Class
Sitecore.Diagnostics Namespace


ID Property

[image]

Sitecore 6.4.1 API
CallStack..::..ID Property
CallStack Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ID { get; }
Visual Basic
Public ReadOnly Property ID As String
    Get
Visual C++
public:
property String^ ID {
    String^ get ();
}

Field Value

The ID.

See Also

CallStack Class
Sitecore.Diagnostics Namespace


IsEmpty Property

[image]

Sitecore 6.4.1 API
CallStack..::..IsEmpty Property
CallStack Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
property bool IsEmpty {
    bool get ();
}

Field Value

true if this instance is empty; otherwise, false.

See Also

CallStack Class
Sitecore.Diagnostics Namespace


Sequence Property

[image]

Sitecore 6.4.1 API
CallStack..::..Sequence Property
CallStack Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Sequence { get; }
Visual Basic
Public ReadOnly Property Sequence As Integer
    Get
Visual C++
public:
property int Sequence {
    int get ();
}

Field Value

The sequence.

See Also

CallStack Class
Sitecore.Diagnostics Namespace


Counter Methods

[image] [image]

Sitecore 6.4.1 API
Counter Methods
Counter Class See Also Send Feedback

The Counter type exposes the following members.

Methods

Name | Description
EndSession | Ends the session.
GetReportFileName | Gets the name of the report file.
GetValue | Gets the value.
Increment | Increments the specified counter name.
SaveReport()()()() | Saves the report.
SaveReport(String) | Saves the report.
StartSession | Starts the session.

See Also

Counter Class
Sitecore.Diagnostics Namespace


EndSession Method

[image]

Sitecore 6.4.1 API
Counter..::..EndSession Method
Counter Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void EndSession()
Visual Basic
Public Shared Sub EndSession
Visual C++
public:
static void EndSession()

See Also

Counter Class
Sitecore.Diagnostics Namespace


GetReportFileName Method

[image]

Sitecore 6.4.1 API
Counter..::..GetReportFileName Method
Counter Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetReportFileName()
Visual Basic
Public Shared Function GetReportFileName As String
Visual C++
public:
static String^ GetReportFileName()

Return Value

[Missing <returns> documentation for "M:Sitecore.Diagnostics.Counter.GetReportFileName"]

See Also

Counter Class
Sitecore.Diagnostics Namespace


Increment Method

[image]

Sitecore 6.4.1 API
Counter..::..Increment Method
Counter Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Increment(
    string counterName
)
Visual Basic
Public Shared Sub Increment ( _
    counterName As String _
)
Visual C++
public:
static void Increment(
    String^ counterName
)

Parameters

counterName
Type: System..::..String
Name of the counter.

See Also

Counter Class
Sitecore.Diagnostics Namespace


SaveReport Method

[image] [image]

Sitecore 6.4.1 API
Counter..::..SaveReport Method
Counter Class See Also Send Feedback

Overload List

Name | Description
SaveReport()()()() | Saves the report.
SaveReport(String) | Saves the report.

See Also

Counter Class
Counter Members
Sitecore.Diagnostics Namespace


SaveReport Method

[image]

Sitecore 6.4.1 API
Counter..::..SaveReport Method
Counter Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void SaveReport()
Visual Basic
Public Shared Sub SaveReport
Visual C++
public:
static void SaveReport()

See Also

Counter Class
SaveReport Overload
Sitecore.Diagnostics Namespace


SaveReport Method (String)

[image]

Sitecore 6.4.1 API
Counter..::..SaveReport Method (String)
Counter Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void SaveReport(
    string fileName
)
Visual Basic
Public Shared Sub SaveReport ( _
    fileName As String _
)
Visual C++
public:
static void SaveReport(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
Name of the file.

See Also

Counter Class
SaveReport Overload
Sitecore.Diagnostics Namespace


StartSession Method

[image]

Sitecore 6.4.1 API
Counter..::..StartSession Method
Counter Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void StartSession()
Visual Basic
Public Shared Sub StartSession
Visual C++
public:
static void StartSession()

See Also

Counter Class
Sitecore.Diagnostics Namespace


Counter Properties

[image] [image]

Sitecore 6.4.1 API
Counter Properties
Counter Class See Also Send Feedback

The Counter type exposes the following members.

Properties

Name | Description
IsActive | Gets a value indicating whether this instance is active.

See Also

Counter Class
Sitecore.Diagnostics Namespace


IsActive Property

[image]

Sitecore 6.4.1 API
Counter..::..IsActive Property
Counter Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsActive { get; }
Visual Basic
Public Shared ReadOnly Property IsActive As Boolean
    Get
Visual C++
public:
static property bool IsActive {
    bool get ();
}

Field Value

true if this instance is active; otherwise, false.

See Also

Counter Class
Sitecore.Diagnostics Namespace


Counter.Worker Class

[image]

Sitecore 6.4.1 API
Counter..::..Worker Class
Counter Class Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Worker : DiagnosticWorker
Visual Basic
Public Class Worker _
    Inherits DiagnosticWorker
Visual C++
public ref class Worker : public DiagnosticWorker

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..DiagnosticWorker
Sitecore.Diagnostics..::..Counter..::..Worker

See Also

Counter..::..Worker Members
Sitecore.Diagnostics Namespace


Counter.Worker Members

[image] [image]

Sitecore 6.4.1 API
Counter..::..Worker Members
Counter..::..Worker Class Constructors Methods Properties See Also Send Feedback

Represents a Counter.

The Counter..::..Worker type exposes the following members.

Constructors

 | Name | Description
Public method | Counter..::..Worker | Initializes a new instance of the Counter..::..Worker class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetReportFileName | Gets the name of the report file.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the value.
Public method | Increment | Increments the specified counter name.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveReport | Saves the report. (Overrides DiagnosticWorker..::..SaveReport(String).)
Protected method | StartReport | Starts the report. (Inherited from DiagnosticWorker.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | Gets the name. (Inherited from DiagnosticWorker.)
Public property | Packet | Gets the packet. (Inherited from DiagnosticWorker.)

See Also

Counter..::..Worker Class
Sitecore.Diagnostics Namespace


Counter.Worker Constructor

[image]

Sitecore 6.4.1 API
Counter..::..Worker Constructor
Counter..::..Worker Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Worker()
Visual Basic
Public Sub New
Visual C++
public:
Worker()

See Also

Counter..::..Worker Class
Sitecore.Diagnostics Namespace


Counter.Worker Methods

[image] [image]

Sitecore 6.4.1 API
Counter..::..Worker Methods
Counter..::..Worker Class See Also Send Feedback

The Counter..::..Worker type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetReportFileName | Gets the name of the report file.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the value.
Public method | Increment | Increments the specified counter name.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveReport | Saves the report. (Overrides DiagnosticWorker..::..SaveReport(String).)
Protected method | StartReport | Starts the report. (Inherited from DiagnosticWorker.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Counter..::..Worker Class
Sitecore.Diagnostics Namespace


GetReportFileName Method

[image]

Sitecore 6.4.1 API
Counter..::..Worker..::..GetReportFileName Method
Counter..::..Worker Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetReportFileName()
Visual Basic
Public Shared Function GetReportFileName As String
Visual C++
public:
static String^ GetReportFileName()

Return Value

[Missing <returns> documentation for "M:Sitecore.Diagnostics.Counter.Worker.GetReportFileName"]

See Also

Counter..::..Worker Class
Sitecore.Diagnostics Namespace


GetValue Method

[image]

Sitecore 6.4.1 API
Counter..::..Worker..::..GetValue Method
Counter..::..Worker Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int GetValue(
    string counterName
)
Visual Basic
Public Function GetValue ( _
    counterName As String _
) As Integer
Visual C++
public:
int GetValue(
    String^ counterName
)

Parameters

counterName
Type: System..::..String
Name of the counter.

Return Value

[Missing <returns> documentation for "M:Sitecore.Diagnostics.Counter.Worker.GetValue(System.String)"]

See Also

Counter..::..Worker Class
Sitecore.Diagnostics Namespace


SaveReport Method

[image]

Sitecore 6.4.1 API
Counter..::..Worker..::..SaveReport Method
Counter..::..Worker Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void SaveReport(
    string fileName
)
Visual Basic
Public Overrides Sub SaveReport ( _
    fileName As String _
)
Visual C++
public:
virtual void SaveReport(
    String^ fileName
) override

Parameters

fileName
Type: System..::..String
Name of the file.

See Also

Counter..::..Worker Class
Sitecore.Diagnostics Namespace


Counter.Worker Properties

[image] [image]

Sitecore 6.4.1 API
Counter..::..Worker Properties
Counter..::..Worker Class See Also Send Feedback

The Counter..::..Worker type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the name. (Inherited from DiagnosticWorker.)
Public property | Packet | Gets the packet. (Inherited from DiagnosticWorker.)

See Also

Counter..::..Worker Class
Sitecore.Diagnostics Namespace


CounterData Class

[image]

Sitecore 6.4.1 API
CounterData Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use the Sitecore.Diagnostics.PerformanceCounters class framework instead.",
    false)]
public class CounterData
Visual Basic
<ObsoleteAttribute("Use the Sitecore.Diagnostics.PerformanceCounters class framework instead.",  _
    False)> _
Public Class CounterData
Visual C++
[ObsoleteAttribute(L"Use the Sitecore.Diagnostics.PerformanceCounters class framework instead.",
    false)]
public ref class CounterData

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..CounterData

See Also

CounterData Members
Sitecore.Diagnostics Namespace


CounterData Members

[image] [image]

Sitecore 6.4.1 API
CounterData Members
CounterData Class Constructors Methods Properties See Also Send Feedback

The CounterData type exposes the following members.

Constructors

 | Name | Description
Public method | CounterData | Constructor

Methods

 | Name | Description
Public method | Decrement()()()() | Decrement counter
Public method | Decrement(Int32) | Decrement counter
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Increment()()()() | Increment counter
Public method | Increment(Int32) | Increment counter
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Reset counter
Public method | Set | Set counter to a specific value
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | Get name
Public property | Value | Get value

See Also

CounterData Class
Sitecore.Diagnostics Namespace


CounterData Constructor

[image]

Sitecore 6.4.1 API
CounterData Constructor
CounterData Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CounterData(
    string name
)
Visual Basic
Public Sub New ( _
    name As String _
)
Visual C++
public:
CounterData(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

See Also

CounterData Class
Sitecore.Diagnostics Namespace


CounterData Methods

[image] [image]

Sitecore 6.4.1 API
CounterData Methods
CounterData Class See Also Send Feedback

The CounterData type exposes the following members.

Methods

 | Name | Description
Public method | Decrement()()()() | Decrement counter
Public method | Decrement(Int32) | Decrement counter
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Increment()()()() | Increment counter
Public method | Increment(Int32) | Increment counter
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Reset counter
Public method | Set | Set counter to a specific value
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CounterData Class
Sitecore.Diagnostics Namespace


Decrement Method

[image]

Sitecore 6.4.1 API
CounterData..::..Decrement Method
CounterData Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Decrement()
Visual Basic
Public Function Decrement As Integer
Visual C++
public:
int Decrement()

Return Value

[Missing <returns> documentation for "M:Sitecore.Diagnostics.CounterData.Decrement"]

See Also

CounterData Class
Decrement Overload
Sitecore.Diagnostics Namespace


Decrement Method (Int32)

[image]

Sitecore 6.4.1 API
CounterData..::..Decrement Method (Int32)
CounterData Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Decrement(
    int amount
)
Visual Basic
Public Function Decrement ( _
    amount As Integer _
) As Integer
Visual C++
public:
int Decrement(
    int amount
)

Parameters

amount
Type: System..::..Int32
The amount.

Return Value

[Missing <returns> documentation for "M:Sitecore.Diagnostics.CounterData.Decrement(System.Int32)"]

See Also

CounterData Class
Decrement Overload
Sitecore.Diagnostics Namespace


Increment Method

[image] [image]

Sitecore 6.4.1 API
CounterData..::..Increment Method
CounterData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Increment()()()() | Increment counter
Public method | Increment(Int32) | Increment counter

See Also

CounterData Class
CounterData Members
Sitecore.Diagnostics Namespace


Increment Method

[image]

Sitecore 6.4.1 API
CounterData..::..Increment Method
CounterData Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Increment()
Visual Basic
Public Function Increment As Integer
Visual C++
public:
int Increment()

Return Value

[Missing <returns> documentation for "M:Sitecore.Diagnostics.CounterData.Increment"]

See Also

CounterData Class
Increment Overload
Sitecore.Diagnostics Namespace


Increment Method (Int32)

[image]

Sitecore 6.4.1 API
CounterData..::..Increment Method (Int32)
CounterData Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Increment(
    int amount
)
Visual Basic
Public Function Increment ( _
    amount As Integer _
) As Integer
Visual C++
public:
int Increment(
    int amount
)

Parameters

amount
Type: System..::..Int32
The amount.

Return Value

[Missing <returns> documentation for "M:Sitecore.Diagnostics.CounterData.Increment(System.Int32)"]

See Also

CounterData Class
Increment Overload
Sitecore.Diagnostics Namespace


Reset Method

[image]

Sitecore 6.4.1 API
CounterData..::..Reset Method
CounterData Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Reset()
Visual Basic
Public Function Reset As Integer
Visual C++
public:
int Reset()

Return Value

[Missing <returns> documentation for "M:Sitecore.Diagnostics.CounterData.Reset"]

See Also

CounterData Class
Sitecore.Diagnostics Namespace


Set Method

[image]

Sitecore 6.4.1 API
CounterData..::..Set Method
CounterData Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Set(
    int value
)
Visual Basic
Public Function Set ( _
    value As Integer _
) As Integer
Visual C++
public:
int Set(
    int value
)

Parameters

value
Type: System..::..Int32
The _value.

Return Value

[Missing <returns> documentation for "M:Sitecore.Diagnostics.CounterData.Set(System.Int32)"]

See Also

CounterData Class
Sitecore.Diagnostics Namespace


CounterData Properties

[image] [image]

Sitecore 6.4.1 API
CounterData Properties
CounterData Class See Also Send Feedback

The CounterData type exposes the following members.

Properties

 | Name | Description
Public property | Name | Get name
Public property | Value | Get value

See Also

CounterData Class
Sitecore.Diagnostics Namespace


Name Property

[image]

Sitecore 6.4.1 API
CounterData..::..Name Property
CounterData Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

CounterData Class
Sitecore.Diagnostics Namespace


CounterLock Class

[image]

Sitecore 6.4.1 API
CounterLock Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use the Sitecore.Diagnostics.PerformanceCounters class framework instead.",
    false)]
public class CounterLock
Visual Basic
<ObsoleteAttribute("Use the Sitecore.Diagnostics.PerformanceCounters class framework instead.",  _
    False)> _
Public Class CounterLock
Visual C++
[ObsoleteAttribute(L"Use the Sitecore.Diagnostics.PerformanceCounters class framework instead.",
    false)]
public ref class CounterLock

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..CounterLock

See Also

CounterLock Members
Sitecore.Diagnostics Namespace


CounterLock Members

[image] [image]

Sitecore 6.4.1 API
CounterLock Members
CounterLock Class Constructors Methods Fields See Also Send Feedback

The CounterLock type exposes the following members.

Constructors

 | Name | Description
Public method | CounterLock | Initializes a new instance of the CounterLock class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | Count | Number of threads currently holding this lock info.
Public field | Lock | Lock object.

See Also

CounterLock Class
Sitecore.Diagnostics Namespace


CounterLock Constructor

[image]

Sitecore 6.4.1 API
CounterLock Constructor
CounterLock Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CounterLock()
Visual Basic
Public Sub New
Visual C++
public:
CounterLock()

See Also

CounterLock Class
Sitecore.Diagnostics Namespace


CounterLock Fields

[image] [image]

Sitecore 6.4.1 API
CounterLock Fields
CounterLock Class See Also Send Feedback

The CounterLock type exposes the following members.

Fields

 | Name | Description
Public field | Count | Number of threads currently holding this lock info.
Public field | Lock | Lock object.

See Also

CounterLock Class
Sitecore.Diagnostics Namespace


Count Field

[image]

Sitecore 6.4.1 API
CounterLock..::..Count Field
CounterLock Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Count
Visual Basic
Public Count As Integer
Visual C++
public:
int Count

See Also

CounterLock Class
Sitecore.Diagnostics Namespace


Lock Field

[image]

Sitecore 6.4.1 API
CounterLock..::..Lock Field
CounterLock Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object Lock
Visual Basic
Public Lock As Object
Visual C++
public:
Object^ Lock

See Also

CounterLock Class
Sitecore.Diagnostics Namespace


CounterLock Methods

[image] [image]

Sitecore 6.4.1 API
CounterLock Methods
CounterLock Class See Also Send Feedback

The CounterLock type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CounterLock Class
Sitecore.Diagnostics Namespace


Counters Class

[image]

Sitecore 6.4.1 API
Counters Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use the Sitecore.Diagnostics.PerformanceCounters class instead.",
    false)]
public static class Counters
Visual Basic
<ObsoleteAttribute("Use the Sitecore.Diagnostics.PerformanceCounters class instead.",  _
    False)> _
Public NotInheritable Class Counters
Visual C++
[ObsoleteAttribute(L"Use the Sitecore.Diagnostics.PerformanceCounters class instead.",
    false)]
public ref class Counters abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..Counters

See Also

Counters Members
Sitecore.Diagnostics Namespace


Counters Members

[image] [image]

Sitecore 6.4.1 API
Counters Members
Counters Class Methods Properties See Also Send Feedback

The Counters type exposes the following members.

Methods

Name | Description
Decrement(String) | Decrement named counter
Decrement(String, Int32) | Decrement named counter
GetCounter(Int32) | Get counter from its name
GetCounter(String) | Get counter from its name
GetValue | Get value of named counter
Increment(String) | Increment named counter
Increment(String, Int32) | Increment named counter
Reset | Reset named counter
ResetAll | Reset all counters

Properties

Name | Description
Count | Get number of counters

See Also

Counters Class
Sitecore.Diagnostics Namespace


Counters Methods

[image] [image]

Sitecore 6.4.1 API
Counters Methods
Counters Class See Also Send Feedback

The Counters type exposes the following members.

Methods

Name | Description
Decrement(String) | Decrement named counter
Decrement(String, Int32) | Decrement named counter
GetCounter(Int32) | Get counter from its name
GetCounter(String) | Get counter from its name
GetValue | Get value of named counter
Increment(String) | Increment named counter
Increment(String, Int32) | Increment named counter
Reset | Reset named counter
ResetAll | Reset all counters

See Also

Counters Class
Sitecore.Diagnostics Namespace


Decrement Method (String)

[image]

Sitecore 6.4.1 API
Counters..::..Decrement Method (String)
Counters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int Decrement(
    string name
)
Visual Basic
Public Shared Function Decrement ( _
    name As String _
) As Integer
Visual C++
public:
static int Decrement(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

Return Value

[Missing <returns> documentation for "M:Sitecore.Diagnostics.Counters.Decrement(System.String)"]

See Also

Counters Class
Decrement Overload
Sitecore.Diagnostics Namespace


Decrement Method (String, Int32)

[image]

Sitecore 6.4.1 API
Counters..::..Decrement Method (String, Int32)
Counters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int Decrement(
    string name,
    int amount
)
Visual Basic
Public Shared Function Decrement ( _
    name As String, _
    amount As Integer _
) As Integer
Visual C++
public:
static int Decrement(
    String^ name,
    int amount
)

Parameters

name
Type: System..::..String
The name.
amount
Type: System..::..Int32
The decrement.

Return Value

[Missing <returns> documentation for "M:Sitecore.Diagnostics.Counters.Decrement(System.String,System.Int32)"]

See Also

Counters Class
Decrement Overload
Sitecore.Diagnostics Namespace


GetCounter Method

[image] [image]

Sitecore 6.4.1 API
Counters..::..GetCounter Method
Counters Class See Also Send Feedback

Overload List

Name | Description
GetCounter(Int32) | Get counter from its name
GetCounter(String) | Get counter from its name

See Also

Counters Class
Counters Members
Sitecore.Diagnostics Namespace


GetCounter Method (Int32)

[image]

Sitecore 6.4.1 API
Counters..::..GetCounter Method (Int32)
Counters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static CounterData GetCounter(
    int index
)
Visual Basic
Public Shared Function GetCounter ( _
    index As Integer _
) As CounterData
Visual C++
public:
static CounterData^ GetCounter(
    int index
)

Parameters

index
Type: System..::..Int32
The index.

Return Value

[Missing <returns> documentation for "M:Sitecore.Diagnostics.Counters.GetCounter(System.Int32)"]

See Also

Counters Class
GetCounter Overload
Sitecore.Diagnostics Namespace


Increment Method

[image] [image]

Sitecore 6.4.1 API
Counters..::..Increment Method
Counters Class See Also Send Feedback

Overload List

Name | Description
Increment(String) | Increment named counter
Increment(String, Int32) | Increment named counter

See Also

Counters Class
Counters Members
Sitecore.Diagnostics Namespace


Increment Method (String)

[image]

Sitecore 6.4.1 API
Counters..::..Increment Method (String)
Counters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int Increment(
    string name
)
Visual Basic
Public Shared Function Increment ( _
    name As String _
) As Integer
Visual C++
public:
static int Increment(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

Return Value

[Missing <returns> documentation for "M:Sitecore.Diagnostics.Counters.Increment(System.String)"]

See Also

Counters Class
Increment Overload
Sitecore.Diagnostics Namespace


ResetAll Method

[image]

Sitecore 6.4.1 API
Counters..::..ResetAll Method
Counters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void ResetAll()
Visual Basic
Public Shared Sub ResetAll
Visual C++
public:
static void ResetAll()

See Also

Counters Class
Sitecore.Diagnostics Namespace


Counters Properties

[image] [image]

Sitecore 6.4.1 API
Counters Properties
Counters Class See Also Send Feedback

The Counters type exposes the following members.

Properties

Name | Description
Count | Get number of counters

See Also

Counters Class
Sitecore.Diagnostics Namespace


Count Property

[image]

Sitecore 6.4.1 API
Counters..::..Count Property
Counters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int Count { get; }
Visual Basic
Public Shared ReadOnly Property Count As Integer
    Get
Visual C++
public:
static property int Count {
    int get ();
}

Field Value

The count.

See Also

Counters Class
Sitecore.Diagnostics Namespace


CycleAsserter Class

[image]

Sitecore 6.4.1 API
CycleAsserter Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CycleAsserter : IDisposable
Visual Basic
Public Class CycleAsserter _
    Implements IDisposable
Visual C++
public ref class CycleAsserter : IDisposable

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..CycleAsserter

See Also

CycleAsserter Members
Sitecore.Diagnostics Namespace


CycleAsserter Members

[image] [image]

Sitecore 6.4.1 API
CycleAsserter Members
CycleAsserter Class Constructors Methods Properties See Also Send Feedback

The CycleAsserter type exposes the following members.

Constructors

 | Name | Description
Public method | CycleAsserter | Initializes a new instance of the RecursionLimit class.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Caller | Gets the caller.
Public property | Detail | Gets the detail (if any).

See Also

CycleAsserter Class
Sitecore.Diagnostics Namespace


CycleAsserter Constructor

[image]

Sitecore 6.4.1 API
CycleAsserter Constructor
CycleAsserter Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CycleAsserter(
    string caller,
    string detail
)
Visual Basic
Public Sub New ( _
    caller As String, _
    detail As String _
)
Visual C++
public:
CycleAsserter(
    String^ caller,
    String^ detail
)

Parameters

caller
Type: System..::..String

[Missing <param name="caller"/> documentation for "M:Sitecore.Diagnostics.CycleAsserter.#ctor(System.String,System.String)"]

detail
Type: System..::..String

[Missing <param name="detail"/> documentation for "M:Sitecore.Diagnostics.CycleAsserter.#ctor(System.String,System.String)"]

See Also

CycleAsserter Class
Sitecore.Diagnostics Namespace


CycleAsserter Methods

[image] [image]

Sitecore 6.4.1 API
CycleAsserter Methods
CycleAsserter Class See Also Send Feedback

The CycleAsserter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CycleAsserter Class
Sitecore.Diagnostics Namespace


Dispose Method

[image]

Sitecore 6.4.1 API
CycleAsserter..::..Dispose Method
CycleAsserter Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

CycleAsserter Class
Sitecore.Diagnostics Namespace


CycleAsserter Properties

[image] [image]

Sitecore 6.4.1 API
CycleAsserter Properties
CycleAsserter Class See Also Send Feedback

The CycleAsserter type exposes the following members.

Properties

 | Name | Description
Public property | Caller | Gets the caller.
Public property | Detail | Gets the detail (if any).

See Also

CycleAsserter Class
Sitecore.Diagnostics Namespace


Caller Property

[image]

Sitecore 6.4.1 API
CycleAsserter..::..Caller Property
CycleAsserter Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Caller { get; }
Visual Basic
Public ReadOnly Property Caller As String
    Get
Visual C++
public:
property String^ Caller {
    String^ get ();
}

Field Value

The caller.

See Also

CycleAsserter Class
Sitecore.Diagnostics Namespace


Detail Property

[image]

Sitecore 6.4.1 API
CycleAsserter..::..Detail Property
CycleAsserter Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Detail { get; }
Visual Basic
Public ReadOnly Property Detail As String
    Get
Visual C++
public:
property String^ Detail {
    String^ get ();
}

Field Value

The detail.

See Also

CycleAsserter Class
Sitecore.Diagnostics Namespace


CycleDetector Class

[image]

Sitecore 6.4.1 API
CycleDetector Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CycleDetector : IDisposable
Visual Basic
Public Class CycleDetector _
    Implements IDisposable
Visual C++
public ref class CycleDetector : IDisposable

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..CycleDetector

See Also

CycleDetector Members
Sitecore.Diagnostics Namespace


CycleDetector Constructor

[image]

Sitecore 6.4.1 API
CycleDetector Constructor
CycleDetector Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CycleDetector(
    string caller,
    string detail
)
Visual Basic
Public Sub New ( _
    caller As String, _
    detail As String _
)
Visual C++
public:
CycleDetector(
    String^ caller,
    String^ detail
)

Parameters

caller
Type: System..::..String

[Missing <param name="caller"/> documentation for "M:Sitecore.Diagnostics.CycleDetector.#ctor(System.String,System.String)"]

detail
Type: System..::..String

[Missing <param name="detail"/> documentation for "M:Sitecore.Diagnostics.CycleDetector.#ctor(System.String,System.String)"]

See Also

CycleDetector Class
Sitecore.Diagnostics Namespace


CycleDetector Methods

[image] [image]

Sitecore 6.4.1 API
CycleDetector Methods
CycleDetector Class See Also Send Feedback

The CycleDetector type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CycleDetector Class
Sitecore.Diagnostics Namespace


Dispose Method

[image]

Sitecore 6.4.1 API
CycleDetector..::..Dispose Method
CycleDetector Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

CycleDetector Class
Sitecore.Diagnostics Namespace


CycleDetector Properties

[image] [image]

Sitecore 6.4.1 API
CycleDetector Properties
CycleDetector Class See Also Send Feedback

The CycleDetector type exposes the following members.

Properties

 | Name | Description
Public property | Caller | Gets the caller.
Public property | Detail | Gets the detail (if any).

See Also

CycleDetector Class
Sitecore.Diagnostics Namespace


Caller Property

[image]

Sitecore 6.4.1 API
CycleDetector..::..Caller Property
CycleDetector Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Caller { get; }
Visual Basic
Public ReadOnly Property Caller As String
    Get
Visual C++
public:
property String^ Caller {
    String^ get ();
}

Field Value

The caller.

See Also

CycleDetector Class
Sitecore.Diagnostics Namespace


Detail Property

[image]

Sitecore 6.4.1 API
CycleDetector..::..Detail Property
CycleDetector Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Detail { get; }
Visual Basic
Public ReadOnly Property Detail As String
    Get
Visual C++
public:
property String^ Detail {
    String^ get ();
}

Field Value

The detail.

See Also

CycleDetector Class
Sitecore.Diagnostics Namespace


Debug Class

[image]

Sitecore 6.4.1 API
Debug Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Debug
Visual Basic
Public NotInheritable Class Debug
Visual C++
public ref class Debug abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..Debug

See Also

Debug Members
Sitecore.Diagnostics Namespace


ArgumentNotNull Method

[image]

Sitecore 6.4.1 API
Debug..::..ArgumentNotNull Method
Debug Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void ArgumentNotNull(
    Object argument,
    string argumentName
)
Visual Basic
Public Shared Sub ArgumentNotNull ( _
    argument As Object, _
    argumentName As String _
)
Visual C++
public:
static void ArgumentNotNull(
    Object^ argument,
    String^ argumentName
)

Parameters

argument
Type: System..::..Object
The argument.
argumentName
Type: System..::..String
Name of the argument.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the argument is null.

See Also

Debug Class
Sitecore.Diagnostics Namespace


ArgumentNotNullOrEmpty Method

[image]

Sitecore 6.4.1 API
Debug..::..ArgumentNotNullOrEmpty Method
Debug Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void ArgumentNotNullOrEmpty(
    string argument,
    string argumentName
)
Visual Basic
Public Shared Sub ArgumentNotNullOrEmpty ( _
    argument As String, _
    argumentName As String _
)
Visual C++
public:
static void ArgumentNotNullOrEmpty(
    String^ argument,
    String^ argumentName
)

Parameters

argument
Type: System..::..String
The argument.
argumentName
Type: System..::..String
Name of the argument.

See Also

Debug Class
Sitecore.Diagnostics Namespace


Assert Method

[image]

Sitecore 6.4.1 API
Debug..::..Assert Method
Debug Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Assert(
    bool condition,
    string errorMessage
)
Visual Basic
Public Shared Sub Assert ( _
    condition As Boolean, _
    errorMessage As String _
)
Visual C++
public:
static void Assert(
    bool condition,
    String^ errorMessage
)

Parameters

condition
Type: System..::..Boolean
if set to true this instance is condition.
errorMessage
Type: System..::..String
The error message.

Remarks

Requires the preprocessor constant DEBUG

Exceptions

Exception | Condition
System..::..Exception | Exception.

See Also

Debug Class
Sitecore.Diagnostics Namespace


DiagnosticContext Class

[image]

Sitecore 6.4.1 API
DiagnosticContext Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DiagnosticContext
Visual Basic
Public Class DiagnosticContext
Visual C++
public ref class DiagnosticContext

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..DiagnosticContext

See Also

DiagnosticContext Members
Sitecore.Diagnostics Namespace


DiagnosticContext Members

[image] [image]

Sitecore 6.4.1 API
DiagnosticContext Members
DiagnosticContext Class Constructors Methods Properties See Also Send Feedback

The DiagnosticContext type exposes the following members.

Constructors

 | Name | Description
Public method | DiagnosticContext | Initializes a new instance of the DiagnosticContext class.

Methods

 | Name | Description
Public method | AbortProfiling | Aborts the profiling.
Public method | AbortTracing | Aborts the tracing.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CounterWorker | Obsolete. Gets or sets the counter worker.
Public property | Counting | Obsolete. Gets or sets a value indicating whether this DiagnosticContext is counting.
Public property | Debugging | Gets or sets a value indicating whether this DiagnosticContext is debugging.
Public property | DrawRenderingBorders | Gets or sets a value indicating whether the DiagnosticContext draws the rendering borders.
Public property | ProfileWorker | Gets or sets the profile worker.
Public property | Profiling | Gets or sets a value indicating whether this DiagnosticContext is profiling.
Public property | ShowRenderingInfo | Gets or sets a value indicating whether the DiagnosticContext shows the rendering info.
Public property | TraceWorker | Gets or sets the trace worker.
Public property | Tracing | Gets or sets a value indicating whether this DiagnosticContext is tracing.

See Also

DiagnosticContext Class
Sitecore.Diagnostics Namespace


DiagnosticContext Constructor

[image]

Sitecore 6.4.1 API
DiagnosticContext Constructor
DiagnosticContext Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DiagnosticContext(
    Context..::..ContextData context
)
Visual Basic
Public Sub New ( _
    context As Context..::..ContextData _
)
Visual C++
public:
DiagnosticContext(
    Context..::..ContextData^ context
)

Parameters

context
Type: Sitecore..::..Context..::..ContextData
The context.

See Also

DiagnosticContext Class
Sitecore.Diagnostics Namespace


DiagnosticContext Methods

[image] [image]

Sitecore 6.4.1 API
DiagnosticContext Methods
DiagnosticContext Class See Also Send Feedback

The DiagnosticContext type exposes the following members.

Methods

 | Name | Description
Public method | AbortProfiling | Aborts the profiling.
Public method | AbortTracing | Aborts the tracing.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DiagnosticContext Class
Sitecore.Diagnostics Namespace


AbortTracing Method

[image]

Sitecore 6.4.1 API
DiagnosticContext..::..AbortTracing Method
DiagnosticContext Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AbortTracing()
Visual Basic
Public Sub AbortTracing
Visual C++
public:
void AbortTracing()

See Also

DiagnosticContext Class
Sitecore.Diagnostics Namespace


DiagnosticContext Properties

[image] [image]

Sitecore 6.4.1 API
DiagnosticContext Properties
DiagnosticContext Class See Also Send Feedback

The DiagnosticContext type exposes the following members.

Properties

 | Name | Description
Public property | CounterWorker | Obsolete. Gets or sets the counter worker.
Public property | Counting | Obsolete. Gets or sets a value indicating whether this DiagnosticContext is counting.
Public property | Debugging | Gets or sets a value indicating whether this DiagnosticContext is debugging.
Public property | DrawRenderingBorders | Gets or sets a value indicating whether the DiagnosticContext draws the rendering borders.
Public property | ProfileWorker | Gets or sets the profile worker.
Public property | Profiling | Gets or sets a value indicating whether this DiagnosticContext is profiling.
Public property | ShowRenderingInfo | Gets or sets a value indicating whether the DiagnosticContext shows the rendering info.
Public property | TraceWorker | Gets or sets the trace worker.
Public property | Tracing | Gets or sets a value indicating whether this DiagnosticContext is tracing.

See Also

DiagnosticContext Class
Sitecore.Diagnostics Namespace


CounterWorker Property

[image]

Sitecore 6.4.1 API
DiagnosticContext..::..CounterWorker Property
DiagnosticContext Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public Counter..::..Worker CounterWorker { get; set; }
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Property CounterWorker As Counter..::..Worker
    Get
    Set
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public:
property Counter..::..Worker^ CounterWorker {
    Counter..::..Worker^ get ();
    void set (Counter..::..Worker^ value);
}

Field Value

The counter worker.

See Also

DiagnosticContext Class
Sitecore.Diagnostics Namespace


Counting Property

[image]

Sitecore 6.4.1 API
DiagnosticContext..::..Counting Property
DiagnosticContext Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public bool Counting { get; set; }
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Property Counting As Boolean
    Get
    Set
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public:
property bool Counting {
    bool get ();
    void set (bool value);
}

Field Value

true if counting; otherwise, false.

See Also

DiagnosticContext Class
Sitecore.Diagnostics Namespace


Debugging Property

[image]

Sitecore 6.4.1 API
DiagnosticContext..::..Debugging Property
DiagnosticContext Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Debugging { get; set; }
Visual Basic
Public Property Debugging As Boolean
    Get
    Set
Visual C++
public:
property bool Debugging {
    bool get ();
    void set (bool value);
}

Field Value

true if debugging; otherwise, false.

See Also

DiagnosticContext Class
Sitecore.Diagnostics Namespace


DrawRenderingBorders Property

[image]

Sitecore 6.4.1 API
DiagnosticContext..::..DrawRenderingBorders Property
DiagnosticContext Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool DrawRenderingBorders { get; set; }
Visual Basic
Public Property DrawRenderingBorders As Boolean
    Get
    Set
Visual C++
public:
property bool DrawRenderingBorders {
    bool get ();
    void set (bool value);
}

Field Value

true if the DiagnosticContext draws the rendering borders; otherwise, false.

See Also

DiagnosticContext Class
Sitecore.Diagnostics Namespace


ProfileWorker Property

[image]

Sitecore 6.4.1 API
DiagnosticContext..::..ProfileWorker Property
DiagnosticContext Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Profiler..::..Worker ProfileWorker { get; set; }
Visual Basic
Public Property ProfileWorker As Profiler..::..Worker
    Get
    Set
Visual C++
public:
property Profiler..::..Worker^ ProfileWorker {
    Profiler..::..Worker^ get ();
    void set (Profiler..::..Worker^ value);
}

Field Value

The profile worker.

See Also

DiagnosticContext Class
Sitecore.Diagnostics Namespace


Profiling Property

[image]

Sitecore 6.4.1 API
DiagnosticContext..::..Profiling Property
DiagnosticContext Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Profiling { get; set; }
Visual Basic
Public Property Profiling As Boolean
    Get
    Set
Visual C++
public:
property bool Profiling {
    bool get ();
    void set (bool value);
}

Field Value

true if profiling; otherwise, false.

See Also

DiagnosticContext Class
Sitecore.Diagnostics Namespace


TraceWorker Property

[image]

Sitecore 6.4.1 API
DiagnosticContext..::..TraceWorker Property
DiagnosticContext Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Tracer..::..Worker TraceWorker { get; set; }
Visual Basic
Public Property TraceWorker As Tracer..::..Worker
    Get
    Set
Visual C++
public:
property Tracer..::..Worker^ TraceWorker {
    Tracer..::..Worker^ get ();
    void set (Tracer..::..Worker^ value);
}

Field Value

The trace worker.

See Also

DiagnosticContext Class
Sitecore.Diagnostics Namespace


Tracing Property

[image]

Sitecore 6.4.1 API
DiagnosticContext..::..Tracing Property
DiagnosticContext Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Tracing { get; set; }
Visual Basic
Public Property Tracing As Boolean
    Get
    Set
Visual C++
public:
property bool Tracing {
    bool get ();
    void set (bool value);
}

Field Value

true if tracing; otherwise, false.

See Also

DiagnosticContext Class
Sitecore.Diagnostics Namespace


DiagnosticWorker Class

[image]

Sitecore 6.4.1 API
DiagnosticWorker Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DiagnosticWorker
Visual Basic
Public Class DiagnosticWorker
Visual C++
public ref class DiagnosticWorker

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..DiagnosticWorker
Sitecore.Diagnostics..::..Counter..::..Worker
Sitecore.Diagnostics..::..Profiler..::..Worker
Sitecore.Diagnostics..::..Tracer..::..Worker

See Also

DiagnosticWorker Members
Sitecore.Diagnostics Namespace


DiagnosticWorker Members

[image] [image]

Sitecore 6.4.1 API
DiagnosticWorker Members
DiagnosticWorker Class Constructors Methods Properties See Also Send Feedback

The DiagnosticWorker type exposes the following members.

Constructors

 | Name | Description
Public method | DiagnosticWorker | Initializes a new instance of the DiagnosticWorker class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetReportFileName | Gets the name of the report file.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveReport | Saves the report.
Protected method | StartReport | Starts the report.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | Gets the name.
Public property | Packet | Gets the packet.

See Also

DiagnosticWorker Class
Sitecore.Diagnostics Namespace


DiagnosticWorker Methods

[image] [image]

Sitecore 6.4.1 API
DiagnosticWorker Methods
DiagnosticWorker Class See Also Send Feedback

The DiagnosticWorker type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetReportFileName | Gets the name of the report file.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveReport | Saves the report.
Protected method | StartReport | Starts the report.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DiagnosticWorker Class
Sitecore.Diagnostics Namespace


GetReportFileName Method

[image]

Sitecore 6.4.1 API
DiagnosticWorker..::..GetReportFileName Method
DiagnosticWorker Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetReportFileName(
    string name
)
Visual Basic
Public Shared Function GetReportFileName ( _
    name As String _
) As String
Visual C++
public:
static String^ GetReportFileName(
    String^ name
)

Parameters

name
Type: System..::..String
The prefix name.

Return Value

The get report file name.

See Also

DiagnosticWorker Class
Sitecore.Diagnostics Namespace


SaveReport Method

[image]

Sitecore 6.4.1 API
DiagnosticWorker..::..SaveReport Method
DiagnosticWorker Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void SaveReport(
    string fileName
)
Visual Basic
Public Overridable Sub SaveReport ( _
    fileName As String _
)
Visual C++
public:
virtual void SaveReport(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
Name of the file.

See Also

DiagnosticWorker Class
Sitecore.Diagnostics Namespace


StartReport Method

[image]

Sitecore 6.4.1 API
DiagnosticWorker..::..StartReport Method
DiagnosticWorker Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void StartReport(
    string rootElementName
)
Visual Basic
Protected Sub StartReport ( _
    rootElementName As String _
)
Visual C++
protected:
void StartReport(
    String^ rootElementName
)

Parameters

rootElementName
Type: System..::..String
Name of the root element.

See Also

DiagnosticWorker Class
Sitecore.Diagnostics Namespace


DiagnosticWorker Properties

[image] [image]

Sitecore 6.4.1 API
DiagnosticWorker Properties
DiagnosticWorker Class See Also Send Feedback

The DiagnosticWorker type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the name.
Public property | Packet | Gets the packet.

See Also

DiagnosticWorker Class
Sitecore.Diagnostics Namespace


Name Property

[image]

Sitecore 6.4.1 API
DiagnosticWorker..::..Name Property
DiagnosticWorker Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Field Value

The Worker name.

See Also

DiagnosticWorker Class
Sitecore.Diagnostics Namespace


Packet Property

[image]

Sitecore 6.4.1 API
DiagnosticWorker..::..Packet Property
DiagnosticWorker Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Packet Packet { get; }
Visual Basic
Public ReadOnly Property Packet As Packet
    Get
Visual C++
public:
property Packet^ Packet {
    Packet^ get ();
}

Field Value

The packet.

See Also

DiagnosticWorker Class
Sitecore.Diagnostics Namespace


DisposeHelper Class

[image]

Sitecore 6.4.1 API
DisposeHelper Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DisposeHelper
Visual Basic
Public Class DisposeHelper
Visual C++
public ref class DisposeHelper

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..DisposeHelper

See Also

DisposeHelper Members
Sitecore.Diagnostics Namespace


DisposeHelper Members

[image] [image]

Sitecore 6.4.1 API
DisposeHelper Members
DisposeHelper Class Constructors Methods Properties See Also Send Feedback

The DisposeHelper type exposes the following members.

Constructors

 | Name | Description
Public method | DisposeHelper | Initializes a new instance of the DisposeHelper class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Disposed | Gets the disposed status.

See Also

DisposeHelper Class
Sitecore.Diagnostics Namespace


DisposeHelper Constructor

[image]

Sitecore 6.4.1 API
DisposeHelper Constructor
DisposeHelper Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DisposeHelper(
    bool threadSafe
)
Visual Basic
Public Sub New ( _
    threadSafe As Boolean _
)
Visual C++
public:
DisposeHelper(
    bool threadSafe
)

Parameters

threadSafe
Type: System..::..Boolean

[Missing <param name="threadSafe"/> documentation for "M:Sitecore.Diagnostics.DisposeHelper.#ctor(System.Boolean)"]

See Also

DisposeHelper Class
Sitecore.Diagnostics Namespace


DisposeHelper Properties

[image] [image]

Sitecore 6.4.1 API
DisposeHelper Properties
DisposeHelper Class See Also Send Feedback

The DisposeHelper type exposes the following members.

Properties

 | Name | Description
Public property | Disposed | Gets the disposed status.

See Also

DisposeHelper Class
Sitecore.Diagnostics Namespace


Disposed Property

[image]

Sitecore 6.4.1 API
DisposeHelper..::..Disposed Property
DisposeHelper Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Disposed { get; }
Visual Basic
Public ReadOnly Property Disposed As Boolean
    Get
Visual C++
public:
property bool Disposed {
    bool get ();
}

Field Value

The disposed.

Remarks

Beware that accessing this property will set it to true. It will only be false on the very first access.

See Also

DisposeHelper Class
Sitecore.Diagnostics Namespace


Error Class

[image]

Sitecore 6.4.1 API
Error Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public sealed class Error
Visual Basic
Public NotInheritable Class Error
Visual C++
public ref class Error sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..Error

See Also

Error Members
Sitecore.Diagnostics Namespace


Error Members

[image] [image]

Sitecore 6.4.1 API
Error Members
Error Class Constructors Methods Properties See Also Send Feedback

The Error type exposes the following members.

Constructors

 | Name | Description
Public method | Error | Initializes a new instance of the Error class

Methods

 | Name | Description
 | Assert(Boolean, String) | Asserts the condition.
 | Assert(Boolean, String, String) | Asserts the condition.
 | AssertAccess | Asserts access.
 | AssertControl | Asserts the control.
 | AssertFile | Asserts that the specified file exists.
 | AssertGuid | Assert that a guid is valid
 | AssertID | Assert that an id is valid
 | AssertInt | Assert that an integer is valid
 | AssertItem | Assert that a item is not null
 | AssertItemFound(Item) | Asserts the item found.
 | AssertItemFound(Item, String) | Asserts the item found.
 | AssertItemID | Assert that a guid is valid
 | AssertLanguage | Asserts the language.
 | AssertLicense | Asserts that a certain license is valid.
 | AssertNotEqual | Asserts the objects are not equal.
 | AssertNotNull | Asserts that the object is not null.
 | AssertNull | Asserts that the object is null.
 | AssertObject | Assert that an object reference is not null
 | AssertString | Assert that a string is valid
 | AssertTemplate | Asserts that a certain license is valid.
 | AssertVersion | Asserts the version.
 | AssertXmlControl | Asserts the XML control.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCaller | Gets the caller.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LogError | Logs an error message to all logs.
 | LogToEventLog | Logs an error message to the Application. event log
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NotSupported | Raises an unsupported error.
 | Raise(String) | Raises the error.
 | Raise(Exception, String) | Raises the error
 | Raise(String, String) | Raises the error
 | RaiseNotImplemented | Raises the "Not implemented" error.
 | RaiseNotSupported | Raises the "Not supported" error.
 | RaiseThreadError | Raises an error from action occurring in a worker thread.
 | ThreadAssert | Asserts from worker thread.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | Warn | Dispatches a warning if some condition is true.

Properties

Name | Description
ThreadErrors | Get list of thread errors

See Also

Error Class
Sitecore.Diagnostics Namespace


Error Constructor

[image]

Sitecore 6.4.1 API
Error Constructor
Error Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Error()
Visual Basic
Public Sub New
Visual C++
public:
Error()

See Also

Error Class
Sitecore.Diagnostics Namespace


Assert Method

[image] [image]

Sitecore 6.4.1 API
Error..::..Assert Method
Error Class See Also Send Feedback

Overload List

Name | Description
Assert(Boolean, String) | Asserts the condition.
Assert(Boolean, String, String) | Asserts the condition.

See Also

Error Class
Error Members
Sitecore.Diagnostics Namespace


Assert Method (Boolean, String)

[image]

Sitecore 6.4.1 API
Error..::..Assert Method (Boolean, String)
Error Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Assert(
    bool condition,
    string error
)
Visual Basic
Public Shared Sub Assert ( _
    condition As Boolean, _
    error As String _
)
Visual C++
public:
static void Assert(
    bool condition,
    String^ error
)

Parameters

condition
Type: System..::..Boolean
if set to true this condition is true.
error
Type: System..::..String
The error.

See Also

Error Class
Assert Overload
Sitecore.Diagnostics Namespace


AssertAccess Method

[image]

Sitecore 6.4.1 API
Error..::..AssertAccess Method
Error Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void AssertAccess(
    bool condition,
    string operation
)
Visual Basic
Public Shared Sub AssertAccess ( _
    condition As Boolean, _
    operation As String _
)
Visual C++
public:
static void AssertAccess(
    bool condition,
    String^ operation
)

Parameters

condition
Type: System..::..Boolean
if set to true this condition is true.
operation
Type: System..::..String
The operation.

See Also

Error Class
Sitecore.Diagnostics Namespace


AssertFile Method

[image]

Sitecore 6.4.1 API
Error..::..AssertFile Method
Error Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void AssertFile(
    string fileName
)
Visual Basic
Public Shared Sub AssertFile ( _
    fileName As String _
)
Visual C++
public:
static void AssertFile(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
Name of the file.

See Also

Error Class
Sitecore.Diagnostics Namespace


AssertGuid Method

[image]

Sitecore 6.4.1 API
Error..::..AssertGuid Method
Error Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void AssertGuid(
    Guid argument,
    string name,
    bool allowNullGuid
)
Visual Basic
Public Shared Sub AssertGuid ( _
    argument As Guid, _
    name As String, _
    allowNullGuid As Boolean _
)
Visual C++
public:
static void AssertGuid(
    Guid argument,
    String^ name,
    bool allowNullGuid
)

Parameters

argument
Type: System..::..Guid
The argument.
name
Type: System..::..String
The name.
allowNullGuid
Type: System..::..Boolean
if set to true this instance is allow null GUID.

See Also

Error Class
Sitecore.Diagnostics Namespace


AssertID Method

[image]

Sitecore 6.4.1 API
Error..::..AssertID Method
Error Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void AssertID(
    ID argument,
    string name,
    bool allowNullID
)
Visual Basic
Public Shared Sub AssertID ( _
    argument As ID, _
    name As String, _
    allowNullID As Boolean _
)
Visual C++
public:
static void AssertID(
    ID^ argument,
    String^ name,
    bool allowNullID
)

Parameters

argument
Type: Sitecore.Data..::..ID
The argument.
name
Type: System..::..String
The name.
allowNullID
Type: System..::..Boolean
if set to true this instance is allow null ID.

See Also

Error Class
Sitecore.Diagnostics Namespace


AssertInt Method

[image]

Sitecore 6.4.1 API
Error..::..AssertInt Method
Error Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void AssertInt(
    int argument,
    string name,
    bool allowZero,
    bool allowNegative
)
Visual Basic
Public Shared Sub AssertInt ( _
    argument As Integer, _
    name As String, _
    allowZero As Boolean, _
    allowNegative As Boolean _
)
Visual C++
public:
static void AssertInt(
    int argument,
    String^ name,
    bool allowZero,
    bool allowNegative
)

Parameters

argument
Type: System..::..Int32
The argument.
name
Type: System..::..String
The name.
allowZero
Type: System..::..Boolean
if set to true this instance is allow zero.
allowNegative
Type: System..::..Boolean
if set to true this instance is allow negative.

See Also

Error Class
Sitecore.Diagnostics Namespace


AssertItem Method

[image]

Sitecore 6.4.1 API
Error..::..AssertItem Method
Error Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void AssertItem(
    Item item,
    string path
)
Visual Basic
Public Shared Sub AssertItem ( _
    item As Item, _
    path As String _
)
Visual C++
public:
static void AssertItem(
    Item^ item,
    String^ path
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
path
Type: System..::..String
The path.

See Also

Error Class
Sitecore.Diagnostics Namespace


AssertItemFound Method

[image] [image]

Sitecore 6.4.1 API
Error..::..AssertItemFound Method
Error Class See Also Send Feedback

Overload List

Name | Description
AssertItemFound(Item) | Asserts the item found.
AssertItemFound(Item, String) | Asserts the item found.

See Also

Error Class
Error Members
Sitecore.Diagnostics Namespace


AssertItemFound Method (Item)

[image]

Sitecore 6.4.1 API
Error..::..AssertItemFound Method (Item)
Error Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void AssertItemFound(
    Item item
)
Visual Basic
Public Shared Sub AssertItemFound ( _
    item As Item _
)
Visual C++
public:
static void AssertItemFound(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Exceptions

Exception | Condition
Sitecore.Exceptions..::..ItemNotFoundException | Item not found.

See Also

Error Class
AssertItemFound Overload
Sitecore.Diagnostics Namespace


AssertItemFound Method (Item, String)

[image]

Sitecore 6.4.1 API
Error..::..AssertItemFound Method (Item, String)
Error Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void AssertItemFound(
    Item item,
    string path
)
Visual Basic
Public Shared Sub AssertItemFound ( _
    item As Item, _
    path As String _
)
Visual C++
public:
static void AssertItemFound(
    Item^ item,
    String^ path
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
path
Type: System..::..String
The path.

Exceptions

Exception | Condition
Sitecore.Exceptions..::..ItemNotFoundException | Item not found.

See Also

Error Class
AssertItemFound Overload
Sitecore.Diagnostics Namespace


AssertItemID Method

[image]

Sitecore 6.4.1 API
Error..::..AssertItemID Method
Error Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void AssertItemID(
    ID argument,
    string name,
    bool allowNullGuid
)
Visual Basic
Public Shared Sub AssertItemID ( _
    argument As ID, _
    name As String, _
    allowNullGuid As Boolean _
)
Visual C++
public:
static void AssertItemID(
    ID^ argument,
    String^ name,
    bool allowNullGuid
)

Parameters

argument
Type: Sitecore.Data..::..ID
The argument.
name
Type: System..::..String
The name.
allowNullGuid
Type: System..::..Boolean
if set to true this instance is allow null GUID.

See Also

Error Class
Sitecore.Diagnostics Namespace


AssertLanguage Method

[image]

Sitecore 6.4.1 API
Error..::..AssertLanguage Method
Error Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void AssertLanguage(
    Language argument,
    string name,
    bool allowAny
)
Visual Basic
Public Shared Sub AssertLanguage ( _
    argument As Language, _
    name As String, _
    allowAny As Boolean _
)
Visual C++
public:
static void AssertLanguage(
    Language^ argument,
    String^ name,
    bool allowAny
)

Parameters

argument
Type: Sitecore.Globalization..::..Language
The argument.
name
Type: System..::..String
The name.
allowAny
Type: System..::..Boolean
if set to true this instance is allow any.

See Also

Error Class
Sitecore.Diagnostics Namespace


AssertNotEqual Method

[image]

Sitecore 6.4.1 API
Error..::..AssertNotEqual Method
Error Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void AssertNotEqual(
    Object obj1,
    Object obj2,
    string message
)
Visual Basic
Public Shared Sub AssertNotEqual ( _
    obj1 As Object, _
    obj2 As Object, _
    message As String _
)
Visual C++
public:
static void AssertNotEqual(
    Object^ obj1,
    Object^ obj2,
    String^ message
)

Parameters

obj1
Type: System..::..Object
The obj1.
obj2
Type: System..::..Object
The obj2.
message
Type: System..::..String
The message.

See Also

Error Class
Sitecore.Diagnostics Namespace


AssertNotNull Method

[image]

Sitecore 6.4.1 API
Error..::..AssertNotNull Method
Error Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void AssertNotNull(
    Object obj,
    string message
)
Visual Basic
Public Shared Sub AssertNotNull ( _
    obj As Object, _
    message As String _
)
Visual C++
public:
static void AssertNotNull(
    Object^ obj,
    String^ message
)

Parameters

obj
Type: System..::..Object
The object.
message
Type: System..::..String
The message.

See Also

Error Class
Sitecore.Diagnostics Namespace


AssertNull Method

[image]

Sitecore 6.4.1 API
Error..::..AssertNull Method
Error Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void AssertNull(
    Object obj,
    string message
)
Visual Basic
Public Shared Sub AssertNull ( _
    obj As Object, _
    message As String _
)
Visual C++
public:
static void AssertNull(
    Object^ obj,
    String^ message
)

Parameters

obj
Type: System..::..Object
The object.
message
Type: System..::..String
The message.

See Also

Error Class
Sitecore.Diagnostics Namespace


AssertObject Method

[image]

Sitecore 6.4.1 API
Error..::..AssertObject Method
Error Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void AssertObject(
    Object argument,
    string name
)
Visual Basic
Public Shared Sub AssertObject ( _
    argument As Object, _
    name As String _
)
Visual C++
public:
static void AssertObject(
    Object^ argument,
    String^ name
)

Parameters

argument
Type: System..::..Object
The argument.
name
Type: System..::..String
The name.

See Also

Error Class
Sitecore.Diagnostics Namespace


AssertString Method

[image]

Sitecore 6.4.1 API
Error..::..AssertString Method
Error Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void AssertString(
    string argument,
    string name,
    bool allowEmpty
)
Visual Basic
Public Shared Sub AssertString ( _
    argument As String, _
    name As String, _
    allowEmpty As Boolean _
)
Visual C++
public:
static void AssertString(
    String^ argument,
    String^ name,
    bool allowEmpty
)

Parameters

argument
Type: System..::..String
The argument.
name
Type: System..::..String
The name.
allowEmpty
Type: System..::..Boolean
if set to true this instance is allow empty.

See Also

Error Class
Sitecore.Diagnostics Namespace


AssertTemplate Method

[image]

Sitecore 6.4.1 API
Error..::..AssertTemplate Method
Error Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void AssertTemplate(
    TemplateItem template,
    string name
)
Visual Basic
Public Shared Sub AssertTemplate ( _
    template As TemplateItem, _
    name As String _
)
Visual C++
public:
static void AssertTemplate(
    TemplateItem^ template,
    String^ name
)

Parameters

template
Type: Sitecore.Data.Items..::..TemplateItem
The template.
name
Type: System..::..String
The name.

See Also

Error Class
Sitecore.Diagnostics Namespace


AssertVersion Method

[image]

Sitecore 6.4.1 API
Error..::..AssertVersion Method
Error Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void AssertVersion(
    Version argument,
    string name,
    bool allowUndefined
)
Visual Basic
Public Shared Sub AssertVersion ( _
    argument As Version, _
    name As String, _
    allowUndefined As Boolean _
)
Visual C++
public:
static void AssertVersion(
    Version^ argument,
    String^ name,
    bool allowUndefined
)

Parameters

argument
Type: Sitecore.Data..::..Version
The argument.
name
Type: System..::..String
The name.
allowUndefined
Type: System..::..Boolean
if set to true this instance is allow undefined.

See Also

Error Class
Sitecore.Diagnostics Namespace


AssertXmlControl Method

[image]

Sitecore 6.4.1 API
Error..::..AssertXmlControl Method
Error Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void AssertXmlControl(
    XmlControl control,
    string controlName
)
Visual Basic
Public Shared Sub AssertXmlControl ( _
    control As XmlControl, _
    controlName As String _
)
Visual C++
public:
static void AssertXmlControl(
    XmlControl^ control,
    String^ controlName
)

Parameters

control
Type: Sitecore.Web.UI.XmlControls..::..XmlControl
The control.
controlName
Type: System..::..String
Name of the control.

See Also

Error Class
Sitecore.Diagnostics Namespace


GetCaller Method

[image]

Sitecore 6.4.1 API
Error..::..GetCaller Method
Error Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetCaller(
    int indexInStack
)
Visual Basic
Public Shared Function GetCaller ( _
    indexInStack As Integer _
) As String
Visual C++
public:
static String^ GetCaller(
    int indexInStack
)

Parameters

indexInStack
Type: System..::..Int32
The index in stack.

Return Value

[Missing <returns> documentation for "M:Sitecore.Diagnostics.Error.GetCaller(System.Int32)"]

See Also

Error Class
Sitecore.Diagnostics Namespace


LogError Method

[image]

Sitecore 6.4.1 API
Error..::..LogError Method
Error Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void LogError(
    string error
)
Visual Basic
Public Shared Sub LogError ( _
    error As String _
)
Visual C++
public:
static void LogError(
    String^ error
)

Parameters

error
Type: System..::..String
The error.

See Also

Error Class
Sitecore.Diagnostics Namespace


LogToEventLog Method

[image]

Sitecore 6.4.1 API
Error..::..LogToEventLog Method
Error Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void LogToEventLog(
    string sError
)
Visual Basic
Public Shared Sub LogToEventLog ( _
    sError As String _
)
Visual C++
public:
static void LogToEventLog(
    String^ sError
)

Parameters

sError
Type: System..::..String
The s error.

See Also

Error Class
Sitecore.Diagnostics Namespace


NotSupported Method

[image]

Sitecore 6.4.1 API
Error..::..NotSupported Method
Error Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void NotSupported(
    string error
)
Visual Basic
Public Shared Sub NotSupported ( _
    error As String _
)
Visual C++
public:
static void NotSupported(
    String^ error
)

Parameters

error
Type: System..::..String
The error.

See Also

Error Class
Sitecore.Diagnostics Namespace


Raise Method

[image] [image]

Sitecore 6.4.1 API
Error..::..Raise Method
Error Class See Also Send Feedback

Overload List

Name | Description
Raise(String) | Raises the error.
Raise(Exception, String) | Raises the error
Raise(String, String) | Raises the error

See Also

Error Class
Error Members
Sitecore.Diagnostics Namespace


Raise Method (String)

[image]

Sitecore 6.4.1 API
Error..::..Raise Method (String)
Error Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Raise(
    string error
)
Visual Basic
Public Shared Sub Raise ( _
    error As String _
)
Visual C++
public:
static void Raise(
    String^ error
)

Parameters

error
Type: System..::..String
The error.

See Also

Error Class
Raise Overload
Sitecore.Diagnostics Namespace


Raise Method (Exception, String)

[image]

Sitecore 6.4.1 API
Error..::..Raise Method (Exception, String)
Error Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Raise(
    Exception exception,
    string method
)
Visual Basic
Public Shared Sub Raise ( _
    exception As Exception, _
    method As String _
)
Visual C++
public:
static void Raise(
    Exception^ exception,
    String^ method
)

Parameters

exception
Type: System..::..Exception
The exception.
method
Type: System..::..String
The method.

See Also

Error Class
Raise Overload
Sitecore.Diagnostics Namespace


Raise Method (String, String)

[image]

Sitecore 6.4.1 API
Error..::..Raise Method (String, String)
Error Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Raise(
    string error,
    string method
)
Visual Basic
Public Shared Sub Raise ( _
    error As String, _
    method As String _
)
Visual C++
public:
static void Raise(
    String^ error,
    String^ method
)

Parameters

error
Type: System..::..String
The error.
method
Type: System..::..String
The method.

See Also

Error Class
Raise Overload
Sitecore.Diagnostics Namespace


RaiseNotImplemented Method

[image]

Sitecore 6.4.1 API
Error..::..RaiseNotImplemented Method
Error Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void RaiseNotImplemented()
Visual Basic
Public Shared Sub RaiseNotImplemented
Visual C++
public:
static void RaiseNotImplemented()

See Also

Error Class
Sitecore.Diagnostics Namespace


RaiseNotSupported Method

[image]

Sitecore 6.4.1 API
Error..::..RaiseNotSupported Method
Error Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void RaiseNotSupported()
Visual Basic
Public Shared Sub RaiseNotSupported
Visual C++
public:
static void RaiseNotSupported()

See Also

Error Class
Sitecore.Diagnostics Namespace


RaiseThreadError Method

[image]

Sitecore 6.4.1 API
Error..::..RaiseThreadError Method
Error Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void RaiseThreadError(
    string error
)
Visual Basic
Public Shared Sub RaiseThreadError ( _
    error As String _
)
Visual C++
public:
static void RaiseThreadError(
    String^ error
)

Parameters

error
Type: System..::..String
The error.

See Also

Error Class
Sitecore.Diagnostics Namespace


ThreadAssert Method

[image]

Sitecore 6.4.1 API
Error..::..ThreadAssert Method
Error Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void ThreadAssert(
    bool condition,
    string error
)
Visual Basic
Public Shared Sub ThreadAssert ( _
    condition As Boolean, _
    error As String _
)
Visual C++
public:
static void ThreadAssert(
    bool condition,
    String^ error
)

Parameters

condition
Type: System..::..Boolean
if set to true this instance is condition.
error
Type: System..::..String
The error.

See Also

Error Class
Sitecore.Diagnostics Namespace


Warn Method

[image]

Sitecore 6.4.1 API
Error..::..Warn Method
Error Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Warn(
    bool condition,
    string warning
)
Visual Basic
Public Shared Sub Warn ( _
    condition As Boolean, _
    warning As String _
)
Visual C++
public:
static void Warn(
    bool condition,
    String^ warning
)

Parameters

condition
Type: System..::..Boolean
if set to true this instance is condition.
warning
Type: System..::..String
The warning.

See Also

Error Class
Sitecore.Diagnostics Namespace


Error Properties

[image] [image]

Sitecore 6.4.1 API
Error Properties
Error Class See Also Send Feedback

The Error type exposes the following members.

Properties

Name | Description
ThreadErrors | Get list of thread errors

See Also

Error Class
Sitecore.Diagnostics Namespace


ThreadErrors Property

[image]

Sitecore 6.4.1 API
Error..::..ThreadErrors Property
Error Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ArrayList ThreadErrors { get; }
Visual Basic
Public Shared ReadOnly Property ThreadErrors As ArrayList
    Get
Visual C++
public:
static property ArrayList^ ThreadErrors {
    ArrayList^ get ();
}

Field Value

The thread errors.

See Also

Error Class
Sitecore.Diagnostics Namespace


EventDispatcher Class

[image]

Sitecore 6.4.1 API
EventDispatcher Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class EventDispatcher
Visual Basic
Public NotInheritable Class EventDispatcher
Visual C++
public ref class EventDispatcher abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..EventDispatcher

See Also

EventDispatcher Members
Sitecore.Diagnostics Namespace


EventDispatcher Members

[image] [image]

Sitecore 6.4.1 API
EventDispatcher Members
EventDispatcher Class Methods See Also Send Feedback

The EventDispatcher type exposes the following members.

Methods

Name | Description
Debug | Dispatch a debug event
DispatchBeforeClientSave | Dispatch a 'before client save' event
DispatchError | Dispatch an error event
DispatchEvent | Dispatch a generic event
DispatchException | Dispatch an exception event
DispatchItemCopied | Dispatch a 'item copied' event
DispatchItemCreated | Dispatch a 'item created' event
DispatchItemDeleted | Dispatch a 'item deleted' event
DispatchItemMoved | Dispatch a 'item moved' event
DispatchItemRenamed | Dispatch a 'item renamed' event
DispatchItemSaved | Dispatch a 'item saved' event
DispatchMediaUploaded | Dispatch a 'media uploaded' event
DispatchPublishDone | Dispatch a 'published file' event
DispatchTrace | Dispatch a trace event
DispatchWarning | Dispatch a warning event
Error | Dispatch an error event
Trace | Dispatch a trace event
Warn | Dispatch a warning event

See Also

EventDispatcher Class
Sitecore.Diagnostics Namespace


EventDispatcher Methods

[image] [image]

Sitecore 6.4.1 API
EventDispatcher Methods
EventDispatcher Class See Also Send Feedback

The EventDispatcher type exposes the following members.

Methods

Name | Description
Debug | Dispatch a debug event
DispatchBeforeClientSave | Dispatch a 'before client save' event
DispatchError | Dispatch an error event
DispatchEvent | Dispatch a generic event
DispatchException | Dispatch an exception event
DispatchItemCopied | Dispatch a 'item copied' event
DispatchItemCreated | Dispatch a 'item created' event
DispatchItemDeleted | Dispatch a 'item deleted' event
DispatchItemMoved | Dispatch a 'item moved' event
DispatchItemRenamed | Dispatch a 'item renamed' event
DispatchItemSaved | Dispatch a 'item saved' event
DispatchMediaUploaded | Dispatch a 'media uploaded' event
DispatchPublishDone | Dispatch a 'published file' event
DispatchTrace | Dispatch a trace event
DispatchWarning | Dispatch a warning event
Error | Dispatch an error event
Trace | Dispatch a trace event
Warn | Dispatch a warning event

See Also

EventDispatcher Class
Sitecore.Diagnostics Namespace


Debug Method

[image]

Sitecore 6.4.1 API
EventDispatcher..::..Debug Method
EventDispatcher Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Debug(
    string message,
    params Object[] additionalInfo
)
Visual Basic
Public Shared Sub Debug ( _
    message As String, _
    ParamArray additionalInfo As Object() _
)
Visual C++
public:
static void Debug(
    String^ message,
    ... array<Object^>^ additionalInfo
)

Parameters

message
Type: System..::..String
The message.
additionalInfo
Type: array< System..::..Object >[]()[][]
The additional info.

See Also

EventDispatcher Class
Sitecore.Diagnostics Namespace


DispatchBeforeClientSave Method

[image]

Sitecore 6.4.1 API
EventDispatcher..::..DispatchBeforeClientSave Method
EventDispatcher Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void DispatchBeforeClientSave(
    XmlNode dataNode
)
Visual Basic
Public Shared Sub DispatchBeforeClientSave ( _
    dataNode As XmlNode _
)
Visual C++
public:
static void DispatchBeforeClientSave(
    XmlNode^ dataNode
)

Parameters

dataNode
Type: System.Xml..::..XmlNode
The data node.

See Also

EventDispatcher Class
Sitecore.Diagnostics Namespace


DispatchError Method

[image]

Sitecore 6.4.1 API
EventDispatcher..::..DispatchError Method
EventDispatcher Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void DispatchError(
    string message,
    params Object[] additionalInfo
)
Visual Basic
Public Shared Sub DispatchError ( _
    message As String, _
    ParamArray additionalInfo As Object() _
)
Visual C++
public:
static void DispatchError(
    String^ message,
    ... array<Object^>^ additionalInfo
)

Parameters

message
Type: System..::..String
The message.
additionalInfo
Type: array< System..::..Object >[]()[][]
The additional info.

See Also

EventDispatcher Class
Sitecore.Diagnostics Namespace


DispatchEvent Method

[image]

Sitecore 6.4.1 API
EventDispatcher..::..DispatchEvent Method
EventDispatcher Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void DispatchEvent(
    string name,
    params Object[] additionalInfo
)
Visual Basic
Public Shared Sub DispatchEvent ( _
    name As String, _
    ParamArray additionalInfo As Object() _
)
Visual C++
public:
static void DispatchEvent(
    String^ name,
    ... array<Object^>^ additionalInfo
)

Parameters

name
Type: System..::..String
The name.
additionalInfo
Type: array< System..::..Object >[]()[][]
The additional info.

See Also

EventDispatcher Class
Sitecore.Diagnostics Namespace


DispatchItemCopied Method

[image]

Sitecore 6.4.1 API
EventDispatcher..::..DispatchItemCopied Method
EventDispatcher Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void DispatchItemCopied(
    Item itm,
    Item source
)
Visual Basic
Public Shared Sub DispatchItemCopied ( _
    itm As Item, _
    source As Item _
)
Visual C++
public:
static void DispatchItemCopied(
    Item^ itm,
    Item^ source
)

Parameters

itm
Type: Sitecore.Data.Items..::..Item
The itm.
source
Type: Sitecore.Data.Items..::..Item
The source.

See Also

EventDispatcher Class
Sitecore.Diagnostics Namespace


DispatchItemCreated Method

[image]

Sitecore 6.4.1 API
EventDispatcher..::..DispatchItemCreated Method
EventDispatcher Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void DispatchItemCreated(
    Item itm
)
Visual Basic
Public Shared Sub DispatchItemCreated ( _
    itm As Item _
)
Visual C++
public:
static void DispatchItemCreated(
    Item^ itm
)

Parameters

itm
Type: Sitecore.Data.Items..::..Item
The itm.

See Also

EventDispatcher Class
Sitecore.Diagnostics Namespace


DispatchItemDeleted Method

[image]

Sitecore 6.4.1 API
EventDispatcher..::..DispatchItemDeleted Method
EventDispatcher Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void DispatchItemDeleted(
    Item itm,
    Item oldParent
)
Visual Basic
Public Shared Sub DispatchItemDeleted ( _
    itm As Item, _
    oldParent As Item _
)
Visual C++
public:
static void DispatchItemDeleted(
    Item^ itm,
    Item^ oldParent
)

Parameters

itm
Type: Sitecore.Data.Items..::..Item
The itm.
oldParent
Type: Sitecore.Data.Items..::..Item
The old parent.

See Also

EventDispatcher Class
Sitecore.Diagnostics Namespace


DispatchItemMoved Method

[image]

Sitecore 6.4.1 API
EventDispatcher..::..DispatchItemMoved Method
EventDispatcher Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void DispatchItemMoved(
    Item itm,
    Item oldParent
)
Visual Basic
Public Shared Sub DispatchItemMoved ( _
    itm As Item, _
    oldParent As Item _
)
Visual C++
public:
static void DispatchItemMoved(
    Item^ itm,
    Item^ oldParent
)

Parameters

itm
Type: Sitecore.Data.Items..::..Item
The itm.
oldParent
Type: Sitecore.Data.Items..::..Item
The old parent.

See Also

EventDispatcher Class
Sitecore.Diagnostics Namespace


DispatchItemSaved Method

[image]

Sitecore 6.4.1 API
EventDispatcher..::..DispatchItemSaved Method
EventDispatcher Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void DispatchItemSaved(
    Item itm
)
Visual Basic
Public Shared Sub DispatchItemSaved ( _
    itm As Item _
)
Visual C++
public:
static void DispatchItemSaved(
    Item^ itm
)

Parameters

itm
Type: Sitecore.Data.Items..::..Item
The itm.

See Also

EventDispatcher Class
Sitecore.Diagnostics Namespace


DispatchMediaUploaded Method

[image]

Sitecore 6.4.1 API
EventDispatcher..::..DispatchMediaUploaded Method
EventDispatcher Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void DispatchMediaUploaded(
    Item itm
)
Visual Basic
Public Shared Sub DispatchMediaUploaded ( _
    itm As Item _
)
Visual C++
public:
static void DispatchMediaUploaded(
    Item^ itm
)

Parameters

itm
Type: Sitecore.Data.Items..::..Item
The itm.

See Also

EventDispatcher Class
Sitecore.Diagnostics Namespace


DispatchPublishDone Method

[image]

Sitecore 6.4.1 API
EventDispatcher..::..DispatchPublishDone Method
EventDispatcher Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void DispatchPublishDone(
    IPublishingRequest request
)
Visual Basic
Public Shared Sub DispatchPublishDone ( _
    request As IPublishingRequest _
)
Visual C++
public:
static void DispatchPublishDone(
    IPublishingRequest^ request
)

Parameters

request
Type: Sitecore..::..IPublishingRequest
The request.

See Also

EventDispatcher Class
Sitecore.Diagnostics Namespace


DispatchTrace Method

[image]

Sitecore 6.4.1 API
EventDispatcher..::..DispatchTrace Method
EventDispatcher Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void DispatchTrace(
    string message,
    params Object[] additionalInfo
)
Visual Basic
Public Shared Sub DispatchTrace ( _
    message As String, _
    ParamArray additionalInfo As Object() _
)
Visual C++
public:
static void DispatchTrace(
    String^ message,
    ... array<Object^>^ additionalInfo
)

Parameters

message
Type: System..::..String
The message.
additionalInfo
Type: array< System..::..Object >[]()[][]
The additional info.

See Also

EventDispatcher Class
Sitecore.Diagnostics Namespace


DispatchWarning Method

[image]

Sitecore 6.4.1 API
EventDispatcher..::..DispatchWarning Method
EventDispatcher Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void DispatchWarning(
    string message,
    params Object[] additionalInfo
)
Visual Basic
Public Shared Sub DispatchWarning ( _
    message As String, _
    ParamArray additionalInfo As Object() _
)
Visual C++
public:
static void DispatchWarning(
    String^ message,
    ... array<Object^>^ additionalInfo
)

Parameters

message
Type: System..::..String
The message.
additionalInfo
Type: array< System..::..Object >[]()[][]
The additional info.

See Also

EventDispatcher Class
Sitecore.Diagnostics Namespace


Error Method

[image]

Sitecore 6.4.1 API
EventDispatcher..::..Error Method
EventDispatcher Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Error(
    string message,
    params Object[] additionalInfo
)
Visual Basic
Public Shared Sub Error ( _
    message As String, _
    ParamArray additionalInfo As Object() _
)
Visual C++
public:
static void Error(
    String^ message,
    ... array<Object^>^ additionalInfo
)

Parameters

message
Type: System..::..String
The message.
additionalInfo
Type: array< System..::..Object >[]()[][]
The additional info.

See Also

EventDispatcher Class
Sitecore.Diagnostics Namespace


Trace Method

[image]

Sitecore 6.4.1 API
EventDispatcher..::..Trace Method
EventDispatcher Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Trace(
    string message,
    params Object[] additionalInfo
)
Visual Basic
Public Shared Sub Trace ( _
    message As String, _
    ParamArray additionalInfo As Object() _
)
Visual C++
public:
static void Trace(
    String^ message,
    ... array<Object^>^ additionalInfo
)

Parameters

message
Type: System..::..String
The message.
additionalInfo
Type: array< System..::..Object >[]()[][]
The additional info.

See Also

EventDispatcher Class
Sitecore.Diagnostics Namespace


Warn Method

[image]

Sitecore 6.4.1 API
EventDispatcher..::..Warn Method
EventDispatcher Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Warn(
    string message,
    params Object[] additionalInfo
)
Visual Basic
Public Shared Sub Warn ( _
    message As String, _
    ParamArray additionalInfo As Object() _
)
Visual C++
public:
static void Warn(
    String^ message,
    ... array<Object^>^ additionalInfo
)

Parameters

message
Type: System..::..String
The message.
additionalInfo
Type: array< System..::..Object >[]()[][]
The additional info.

See Also

EventDispatcher Class
Sitecore.Diagnostics Namespace


FailureReason Enumeration

[image]

Sitecore 6.4.1 API
FailureReason Enumeration
See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum FailureReason
Visual Basic
Public Enumeration FailureReason
Visual C++
public enum class FailureReason

Members

Member name | Value | Description
None | 0 | No failure has occurred.
AccessDenied | 1 | Access to a ressource was denied.
ItemNotFound | 2 | An item was not found.

See Also

Sitecore.Diagnostics Namespace


HealthMonitorHook Class

[image]

Sitecore 6.4.1 API
HealthMonitorHook Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class HealthMonitorHook : IHook
Visual Basic
Public Class HealthMonitorHook _
    Implements IHook
Visual C++
public ref class HealthMonitorHook : IHook

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..HealthMonitorHook

See Also

HealthMonitorHook Members
Sitecore.Diagnostics Namespace


HealthMonitorHook Members

[image] [image]

Sitecore 6.4.1 API
HealthMonitorHook Members
HealthMonitorHook Class Constructors Methods See Also Send Feedback

The HealthMonitorHook type exposes the following members.

Constructors

 | Name | Description
Public method | HealthMonitorHook | Initializes a new instance of the HealthMonitorHook class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this instance.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HealthMonitorHook Class
Sitecore.Diagnostics Namespace


HealthMonitorHook Constructor

[image]

Sitecore 6.4.1 API
HealthMonitorHook Constructor
HealthMonitorHook Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HealthMonitorHook()
Visual Basic
Public Sub New
Visual C++
public:
HealthMonitorHook()

See Also

HealthMonitorHook Class
Sitecore.Diagnostics Namespace


HealthMonitorHook Methods

[image] [image]

Sitecore 6.4.1 API
HealthMonitorHook Methods
HealthMonitorHook Class See Also Send Feedback

The HealthMonitorHook type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this instance.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HealthMonitorHook Class
Sitecore.Diagnostics Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
HealthMonitorHook..::..Initialize Method
HealthMonitorHook Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Initialize()
Visual Basic
Public Sub Initialize
Visual C++
public:
virtual void Initialize() sealed

Implements

IHook..::..Initialize()()()()

See Also

HealthMonitorHook Class
Sitecore.Diagnostics Namespace


HighResTimer Class

[image]

Sitecore 6.4.1 API
HighResTimer Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class HighResTimer
Visual Basic
Public Class HighResTimer
Visual C++
public ref class HighResTimer

Remarks

This class is usually used for profiling.

The class uses the API functions QueryPerformanceCounter and QueryPerformanceFrequency.

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..HighResTimer

See Also

HighResTimer Members
Sitecore.Diagnostics Namespace


HighResTimer Members

[image] [image]

Sitecore 6.4.1 API
HighResTimer Members
HighResTimer Class Constructors Methods Properties See Also Send Feedback

The HighResTimer type exposes the following members.

Constructors

 | Name | Description
Public method | HighResTimer()()()() | Initializes a new instance of the HighResTimer class.
Public method | HighResTimer(Boolean) | Initializes a new instance of the HighResTimer class.

Methods

 | Name | Description
Public method | Elapsed | Gets the number of milliseconds that has elapsed since the timer was started.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetElapsed | Gets the number of milliseconds that has elapsed since the timer was started.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMillisecondsBetween | Gets the milliseconds between.
 | GetMillisecondsSince | Gets the milliseconds since.
 | GetTick | Gets the tick.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Pause | Pauses this instance.
Public method | QueryTimer | Queries the timer.
Public method | Resume | Resumes a stopped timer.
Public method | SecondsElapsed | Gets the number of seconds that has elapsed since the timer was started.
Public method | Start | Starts the timer.
Public method | Stop | Stops the timer.
Public method | Supported | Checks if timers is supported by the operating system.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ElapsedTimeSpan | Gets the elapsed time as a TimeSpan.
 | Frequency | Gets the frequency.

See Also

HighResTimer Class
Sitecore.Diagnostics Namespace


HighResTimer Constructor

[image] [image]

Sitecore 6.4.1 API
HighResTimer Constructor
HighResTimer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HighResTimer()()()() | Initializes a new instance of the HighResTimer class.
Public method | HighResTimer(Boolean) | Initializes a new instance of the HighResTimer class.

See Also

HighResTimer Class
HighResTimer Members
Sitecore.Diagnostics Namespace


HighResTimer Constructor

[image]

Sitecore 6.4.1 API
HighResTimer Constructor
HighResTimer Class Example See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HighResTimer()
Visual Basic
Public Sub New
Visual C++
public:
HighResTimer()

Remarks

The timer is not started automatically.

Examples

CopyC#
HighResTimer timer = new HighResTimer();
timer.Start();
timer.Stop();
double ms = timer.Elapsed();

See Also

HighResTimer Class
HighResTimer Overload
Sitecore.Diagnostics Namespace


HighResTimer Constructor (Boolean)

[image]

Sitecore 6.4.1 API
HighResTimer Constructor (Boolean)
HighResTimer Class Example See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HighResTimer(
    bool bAutoStart
)
Visual Basic
Public Sub New ( _
    bAutoStart As Boolean _
)
Visual C++
public:
HighResTimer(
    bool bAutoStart
)

Parameters

bAutoStart
Type: System..::..Boolean
A boolean indicating if the timer should be started.

Examples

CopyC#
HighResTimer timer = new HighResTimer(true);
timer.Stop();
double ms = timer.Elapsed();

See Also

HighResTimer Class
HighResTimer Overload
Sitecore.Diagnostics Namespace


HighResTimer Methods

[image] [image]

Sitecore 6.4.1 API
HighResTimer Methods
HighResTimer Class See Also Send Feedback

The HighResTimer type exposes the following members.

Methods

 | Name | Description
Public method | Elapsed | Gets the number of milliseconds that has elapsed since the timer was started.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetElapsed | Gets the number of milliseconds that has elapsed since the timer was started.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMillisecondsBetween | Gets the milliseconds between.
 | GetMillisecondsSince | Gets the milliseconds since.
 | GetTick | Gets the tick.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Pause | Pauses this instance.
Public method | QueryTimer | Queries the timer.
Public method | Resume | Resumes a stopped timer.
Public method | SecondsElapsed | Gets the number of seconds that has elapsed since the timer was started.
Public method | Start | Starts the timer.
Public method | Stop | Stops the timer.
Public method | Supported | Checks if timers is supported by the operating system.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HighResTimer Class
Sitecore.Diagnostics Namespace


Elapsed Method

[image]

Sitecore 6.4.1 API
HighResTimer..::..Elapsed Method
HighResTimer Class Example See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public double Elapsed()
Visual Basic
Public Function Elapsed As Double
Visual C++
public:
double Elapsed()

Return Value

Number of milliseconds since the timer was started.

Remarks

Stops the timer.

Examples

CopyC#
HighResTimer timer = new HighResTimer(true);
timer.Stop();
double ms = timer.Elapsed();

See Also

HighResTimer Class
Sitecore.Diagnostics Namespace
HighResTimer..::..Start()()()()


GetElapsed Method

[image]

Sitecore 6.4.1 API
HighResTimer..::..GetElapsed Method
HighResTimer Class Example See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public double GetElapsed()
Visual Basic
Public Function GetElapsed As Double
Visual C++
public:
double GetElapsed()

Return Value

Number of milliseconds since the timer was started.

Remarks

Does not stop the timer.

Examples

CopyC#
HighResTimer timer = new HighResTimer(true);
double ms = timer.GetElapsed();

See Also

HighResTimer Class
Sitecore.Diagnostics Namespace
HighResTimer..::..Start()()()()


GetMillisecondsBetween Method

[image]

Sitecore 6.4.1 API
HighResTimer..::..GetMillisecondsBetween Method
HighResTimer Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static double GetMillisecondsBetween(
    long startTick,
    long endTick
)
Visual Basic
Public Shared Function GetMillisecondsBetween ( _
    startTick As Long, _
    endTick As Long _
) As Double
Visual C++
public:
static double GetMillisecondsBetween(
    long long startTick,
    long long endTick
)

Parameters

startTick
Type: System..::..Int64
The start tick.
endTick
Type: System..::..Int64
The end tick.

Return Value

[Missing <returns> documentation for "M:Sitecore.Diagnostics.HighResTimer.GetMillisecondsBetween(System.Int64,System.Int64)"]

See Also

HighResTimer Class
Sitecore.Diagnostics Namespace


GetMillisecondsSince Method

[image]

Sitecore 6.4.1 API
HighResTimer..::..GetMillisecondsSince Method
HighResTimer Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static double GetMillisecondsSince(
    long tick
)
Visual Basic
Public Shared Function GetMillisecondsSince ( _
    tick As Long _
) As Double
Visual C++
public:
static double GetMillisecondsSince(
    long long tick
)

Parameters

tick
Type: System..::..Int64
The tick.

Return Value

[Missing <returns> documentation for "M:Sitecore.Diagnostics.HighResTimer.GetMillisecondsSince(System.Int64)"]

See Also

HighResTimer Class
Sitecore.Diagnostics Namespace


GetTick Method

[image]

Sitecore 6.4.1 API
HighResTimer..::..GetTick Method
HighResTimer Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long GetTick()
Visual Basic
Public Shared Function GetTick As Long
Visual C++
public:
static long long GetTick()

Return Value

[Missing <returns> documentation for "M:Sitecore.Diagnostics.HighResTimer.GetTick"]

See Also

HighResTimer Class
Sitecore.Diagnostics Namespace


Pause Method

[image]

Sitecore 6.4.1 API
HighResTimer..::..Pause Method
HighResTimer Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Pause()
Visual Basic
Public Sub Pause
Visual C++
public:
void Pause()

See Also

HighResTimer Class
Sitecore.Diagnostics Namespace


QueryTimer Method

[image]

Sitecore 6.4.1 API
HighResTimer..::..QueryTimer Method
HighResTimer Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public double QueryTimer()
Visual Basic
Public Function QueryTimer As Double
Visual C++
public:
double QueryTimer()

Return Value

Returns 1.0 divided by the timer frequency.

See Also

HighResTimer Class
Sitecore.Diagnostics Namespace


SecondsElapsed Method

[image]

Sitecore 6.4.1 API
HighResTimer..::..SecondsElapsed Method
HighResTimer Class Example See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public double SecondsElapsed()
Visual Basic
Public Function SecondsElapsed As Double
Visual C++
public:
double SecondsElapsed()

Return Value

Number of seconds since the timer was started.

Examples

CopyC#
HighResTimer timer = new HighResTimer(true);
timer.Stop();
double seconds = timer.SecondsElapsed();

See Also

HighResTimer Class
Sitecore.Diagnostics Namespace
HighResTimer..::..Start()()()()


Start Method

[image]

Sitecore 6.4.1 API
HighResTimer..::..Start Method
HighResTimer Class Example See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Start()
Visual Basic
Public Sub Start
Visual C++
public:
void Start()

Examples

CopyC#
HighResTimer timer = new HighResTimer();
timer.Start();
timer.Stop();
double ms = timer.Elapsed();

See Also

HighResTimer Class
Sitecore.Diagnostics Namespace
HighResTimer..::..Stop()()()()


Stop Method

[image]

Sitecore 6.4.1 API
HighResTimer..::..Stop Method
HighResTimer Class Example See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Stop()
Visual Basic
Public Sub Stop
Visual C++
public:
void Stop()

Examples

CopyC#
HighResTimer timer = new HighResTimer();
timer.Start();
timer.Stop();
double ms = timer.Elapsed();

See Also

HighResTimer Class
Sitecore.Diagnostics Namespace
HighResTimer..::..Start()()()()


Supported Method

[image]

Sitecore 6.4.1 API
HighResTimer..::..Supported Method
HighResTimer Class Example See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Supported()
Visual Basic
Public Function Supported As Boolean
Visual C++
public:
bool Supported()

Return Value

True, if the operating system supports timers, otherwise false.

Examples

CopyC#
HighResTimer timer = new HighResTimer(false);
if (timer.Supported()) {
timerStart();
timer.Stop();
double seconds = timer.Elapsed();
}

See Also

HighResTimer Class
Sitecore.Diagnostics Namespace
HighResTimer..::..Start()()()()


HighResTimer Properties

[image] [image]

Sitecore 6.4.1 API
HighResTimer Properties
HighResTimer Class See Also Send Feedback

The HighResTimer type exposes the following members.

Properties

 | Name | Description
Public property | ElapsedTimeSpan | Gets the elapsed time as a TimeSpan.
 | Frequency | Gets the frequency.

See Also

HighResTimer Class
Sitecore.Diagnostics Namespace


ElapsedTimeSpan Property

[image]

Sitecore 6.4.1 API
HighResTimer..::..ElapsedTimeSpan Property
HighResTimer Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TimeSpan ElapsedTimeSpan { get; }
Visual Basic
Public ReadOnly Property ElapsedTimeSpan As TimeSpan
    Get
Visual C++
public:
property TimeSpan ElapsedTimeSpan {
    TimeSpan get ();
}

Field Value

The elapsed time span.

See Also

HighResTimer Class
Sitecore.Diagnostics Namespace


Frequency Property

[image]

Sitecore 6.4.1 API
HighResTimer..::..Frequency Property
HighResTimer Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long Frequency { get; }
Visual Basic
Public Shared ReadOnly Property Frequency As Long
    Get
Visual C++
public:
static property long long Frequency {
    long long get ();
}

Field Value

The frequency.

See Also

HighResTimer Class
Sitecore.Diagnostics Namespace


Log Class

[image]

Sitecore 6.4.1 API
Log Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Log
Visual Basic
Public NotInheritable Class Log
Visual C++
public ref class Log abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..Log

See Also

Log Members
Sitecore.Diagnostics Namespace


Log Members

[image] [image]

Sitecore 6.4.1 API
Log Members
Log Class Methods Properties See Also Send Feedback

The Log type exposes the following members.

Methods

Name | Description
Audit(String, Object) | Infoes the specified message.
Audit(String, Type) | Audits the specified message.
Audit(Object, String, array<String>[]()[][]) | Audits the specified owner type.
Audit(Type, String, array<String>[]()[][]) | Audits the specified owner type.
Debug(String) | Debugs the specified message.
Debug(String, Object) | Debugs the specified message.
Error(String, Object) | Errors the specified message.
Error(String, Type) | Errors the specified message.
Error(String, Exception, Object) | Errors the specified message.
Error(String, Exception, Type) | Errors the specified message.
Fatal(String, Object) | Fatals the specified message.
Fatal(String, Type) | Fatals the specified message.
Fatal(String, Exception, Object) | Fatals the specified message.
Fatal(String, Exception, Type) | Fatals the specified message.
Info | Infoes the specified message.
SingleError | Logs a single error.
SingleFatal(String, Exception, Object) | Logs a single fatal message.
SingleFatal(String, Exception, Type) | Logs a single fatal message.
SingleWarn | Logs a single warning.
Warn(String, Object) | Warns the specified message.
Warn(String, Exception, Object) | Warns the specified message.

Properties

Name | Description
Enabled | Gets a value indicating whether this Log is enabled.
Singles | Gets the singles.

See Also

Log Class
Sitecore.Diagnostics Namespace


Log Methods

[image] [image]

Sitecore 6.4.1 API
Log Methods
Log Class See Also Send Feedback

The Log type exposes the following members.

Methods

Name | Description
Audit(String, Object) | Infoes the specified message.
Audit(String, Type) | Audits the specified message.
Audit(Object, String, array<String>[]()[][]) | Audits the specified owner type.
Audit(Type, String, array<String>[]()[][]) | Audits the specified owner type.
Debug(String) | Debugs the specified message.
Debug(String, Object) | Debugs the specified message.
Error(String, Object) | Errors the specified message.
Error(String, Type) | Errors the specified message.
Error(String, Exception, Object) | Errors the specified message.
Error(String, Exception, Type) | Errors the specified message.
Fatal(String, Object) | Fatals the specified message.
Fatal(String, Type) | Fatals the specified message.
Fatal(String, Exception, Object) | Fatals the specified message.
Fatal(String, Exception, Type) | Fatals the specified message.
Info | Infoes the specified message.
SingleError | Logs a single error.
SingleFatal(String, Exception, Object) | Logs a single fatal message.
SingleFatal(String, Exception, Type) | Logs a single fatal message.
SingleWarn | Logs a single warning.
Warn(String, Object) | Warns the specified message.
Warn(String, Exception, Object) | Warns the specified message.

See Also

Log Class
Sitecore.Diagnostics Namespace


Audit Method

[image] [image]

Sitecore 6.4.1 API
Log..::..Audit Method
Log Class See Also Send Feedback

Overload List

Name | Description
Audit(String, Object) | Infoes the specified message.
Audit(String, Type) | Audits the specified message.
Audit(Object, String, array<String>[]()[][]) | Audits the specified owner type.
Audit(Type, String, array<String>[]()[][]) | Audits the specified owner type.

See Also

Log Class
Log Members
Sitecore.Diagnostics Namespace


Audit Method (String, Object)

[image]

Sitecore 6.4.1 API
Log..::..Audit Method (String, Object)
Log Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Audit(
    string message,
    Object owner
)
Visual Basic
Public Shared Sub Audit ( _
    message As String, _
    owner As Object _
)
Visual C++
public:
static void Audit(
    String^ message,
    Object^ owner
)

Parameters

message
Type: System..::..String
The message.
owner
Type: System..::..Object
The owner.

See Also

Log Class
Audit Overload
Sitecore.Diagnostics Namespace


Audit Method (String, Type)

[image]

Sitecore 6.4.1 API
Log..::..Audit Method (String, Type)
Log Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Audit(
    string message,
    Type ownerType
)
Visual Basic
Public Shared Sub Audit ( _
    message As String, _
    ownerType As Type _
)
Visual C++
public:
static void Audit(
    String^ message,
    Type^ ownerType
)

Parameters

message
Type: System..::..String
The message.
ownerType
Type: System..::..Type
Type of the owner.

See Also

Log Class
Audit Overload
Sitecore.Diagnostics Namespace


Audit Method (Object, String, String[])

[image]

Sitecore 6.4.1 API
Log..::..Audit Method (Object, String, array<String>[]()[][])
Log Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Audit(
    Object owner,
    string format,
    params string[] parameters
)
Visual Basic
Public Shared Sub Audit ( _
    owner As Object, _
    format As String, _
    ParamArray parameters As String() _
)
Visual C++
public:
static void Audit(
    Object^ owner,
    String^ format,
    ... array<String^>^ parameters
)

Parameters

owner
Type: System..::..Object
The owner.
format
Type: System..::..String
The format.
parameters
Type: array< System..::..String >[]()[][]
The parameters.

See Also

Log Class
Audit Overload
Sitecore.Diagnostics Namespace


Debug Method

[image] [image]

Sitecore 6.4.1 API
Log..::..Debug Method
Log Class See Also Send Feedback

Overload List

Name | Description
Debug(String) | Debugs the specified message.
Debug(String, Object) | Debugs the specified message.

See Also

Log Class
Log Members
Sitecore.Diagnostics Namespace


Debug Method (String)

[image]

Sitecore 6.4.1 API
Log..::..Debug Method (String)
Log Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Debug(
    string message
)
Visual Basic
Public Shared Sub Debug ( _
    message As String _
)
Visual C++
public:
static void Debug(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

Log Class
Debug Overload
Sitecore.Diagnostics Namespace


Debug Method (String, Object)

[image]

Sitecore 6.4.1 API
Log..::..Debug Method (String, Object)
Log Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Debug(
    string message,
    Object owner
)
Visual Basic
Public Shared Sub Debug ( _
    message As String, _
    owner As Object _
)
Visual C++
public:
static void Debug(
    String^ message,
    Object^ owner
)

Parameters

message
Type: System..::..String
The message.
owner
Type: System..::..Object
The owner.

See Also

Log Class
Debug Overload
Sitecore.Diagnostics Namespace


Error Method

[image] [image]

Sitecore 6.4.1 API
Log..::..Error Method
Log Class See Also Send Feedback

Overload List

Name | Description
Error(String, Object) | Errors the specified message.
Error(String, Type) | Errors the specified message.
Error(String, Exception, Object) | Errors the specified message.
Error(String, Exception, Type) | Errors the specified message.

See Also

Log Class
Log Members
Sitecore.Diagnostics Namespace


Error Method (String, Type)

[image]

Sitecore 6.4.1 API
Log..::..Error Method (String, Type)
Log Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Error(
    string message,
    Type ownerType
)
Visual Basic
Public Shared Sub Error ( _
    message As String, _
    ownerType As Type _
)
Visual C++
public:
static void Error(
    String^ message,
    Type^ ownerType
)

Parameters

message
Type: System..::..String
The message.
ownerType
Type: System..::..Type
Type of the owner.

See Also

Log Class
Error Overload
Sitecore.Diagnostics Namespace


Error Method (String, Exception, Object)

[image]

Sitecore 6.4.1 API
Log..::..Error Method (String, Exception, Object)
Log Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Error(
    string message,
    Exception exception,
    Object owner
)
Visual Basic
Public Shared Sub Error ( _
    message As String, _
    exception As Exception, _
    owner As Object _
)
Visual C++
public:
static void Error(
    String^ message,
    Exception^ exception,
    Object^ owner
)

Parameters

message
Type: System..::..String
The message.
exception
Type: System..::..Exception
The exception.
owner
Type: System..::..Object
The owner.

See Also

Log Class
Error Overload
Sitecore.Diagnostics Namespace


Error Method (String, Exception, Type)

[image]

Sitecore 6.4.1 API
Log..::..Error Method (String, Exception, Type)
Log Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Error(
    string message,
    Exception exception,
    Type ownerType
)
Visual Basic
Public Shared Sub Error ( _
    message As String, _
    exception As Exception, _
    ownerType As Type _
)
Visual C++
public:
static void Error(
    String^ message,
    Exception^ exception,
    Type^ ownerType
)

Parameters

message
Type: System..::..String
The message.
exception
Type: System..::..Exception
The exception.
ownerType
Type: System..::..Type
Type of the owner.

See Also

Log Class
Error Overload
Sitecore.Diagnostics Namespace


Fatal Method

[image] [image]

Sitecore 6.4.1 API
Log..::..Fatal Method
Log Class See Also Send Feedback

Overload List

Name | Description
Fatal(String, Object) | Fatals the specified message.
Fatal(String, Type) | Fatals the specified message.
Fatal(String, Exception, Object) | Fatals the specified message.
Fatal(String, Exception, Type) | Fatals the specified message.

See Also

Log Class
Log Members
Sitecore.Diagnostics Namespace


Fatal Method (String, Object)

[image]

Sitecore 6.4.1 API
Log..::..Fatal Method (String, Object)
Log Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Fatal(
    string message,
    Object owner
)
Visual Basic
Public Shared Sub Fatal ( _
    message As String, _
    owner As Object _
)
Visual C++
public:
static void Fatal(
    String^ message,
    Object^ owner
)

Parameters

message
Type: System..::..String
The message.
owner
Type: System..::..Object
The owner.

See Also

Log Class
Fatal Overload
Sitecore.Diagnostics Namespace


Fatal Method (String, Type)

[image]

Sitecore 6.4.1 API
Log..::..Fatal Method (String, Type)
Log Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Fatal(
    string message,
    Type ownerType
)
Visual Basic
Public Shared Sub Fatal ( _
    message As String, _
    ownerType As Type _
)
Visual C++
public:
static void Fatal(
    String^ message,
    Type^ ownerType
)

Parameters

message
Type: System..::..String
The message.
ownerType
Type: System..::..Type
Type of the owner.

See Also

Log Class
Fatal Overload
Sitecore.Diagnostics Namespace


Fatal Method (String, Exception, Object)

[image]

Sitecore 6.4.1 API
Log..::..Fatal Method (String, Exception, Object)
Log Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Fatal(
    string message,
    Exception exception,
    Object owner
)
Visual Basic
Public Shared Sub Fatal ( _
    message As String, _
    exception As Exception, _
    owner As Object _
)
Visual C++
public:
static void Fatal(
    String^ message,
    Exception^ exception,
    Object^ owner
)

Parameters

message
Type: System..::..String
The message.
exception
Type: System..::..Exception
The exception.
owner
Type: System..::..Object
The owner.

See Also

Log Class
Fatal Overload
Sitecore.Diagnostics Namespace


Fatal Method (String, Exception, Type)

[image]

Sitecore 6.4.1 API
Log..::..Fatal Method (String, Exception, Type)
Log Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Fatal(
    string message,
    Exception exception,
    Type ownerType
)
Visual Basic
Public Shared Sub Fatal ( _
    message As String, _
    exception As Exception, _
    ownerType As Type _
)
Visual C++
public:
static void Fatal(
    String^ message,
    Exception^ exception,
    Type^ ownerType
)

Parameters

message
Type: System..::..String
The message.
exception
Type: System..::..Exception
The exception.
ownerType
Type: System..::..Type
Type of the owner.

See Also

Log Class
Fatal Overload
Sitecore.Diagnostics Namespace


Info Method

[image]

Sitecore 6.4.1 API
Log..::..Info Method
Log Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Info(
    string message,
    Object owner
)
Visual Basic
Public Shared Sub Info ( _
    message As String, _
    owner As Object _
)
Visual C++
public:
static void Info(
    String^ message,
    Object^ owner
)

Parameters

message
Type: System..::..String
The message.
owner
Type: System..::..Object
The owner.

See Also

Log Class
Sitecore.Diagnostics Namespace


SingleError Method

[image]

Sitecore 6.4.1 API
Log..::..SingleError Method
Log Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void SingleError(
    string message,
    Object owner
)
Visual Basic
Public Shared Sub SingleError ( _
    message As String, _
    owner As Object _
)
Visual C++
public:
static void SingleError(
    String^ message,
    Object^ owner
)

Parameters

message
Type: System..::..String
The message.
owner
Type: System..::..Object
The owner.

See Also

Log Class
Sitecore.Diagnostics Namespace


SingleFatal Method

[image] [image]

Sitecore 6.4.1 API
Log..::..SingleFatal Method
Log Class See Also Send Feedback

Overload List

Name | Description
SingleFatal(String, Exception, Object) | Logs a single fatal message.
SingleFatal(String, Exception, Type) | Logs a single fatal message.

See Also

Log Class
Log Members
Sitecore.Diagnostics Namespace


SingleFatal Method (String, Exception, Object)

[image]

Sitecore 6.4.1 API
Log..::..SingleFatal Method (String, Exception, Object)
Log Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void SingleFatal(
    string message,
    Exception exception,
    Object owner
)
Visual Basic
Public Shared Sub SingleFatal ( _
    message As String, _
    exception As Exception, _
    owner As Object _
)
Visual C++
public:
static void SingleFatal(
    String^ message,
    Exception^ exception,
    Object^ owner
)

Parameters

message
Type: System..::..String
The message.
exception
Type: System..::..Exception
The exception.
owner
Type: System..::..Object
The owner.

See Also

Log Class
SingleFatal Overload
Sitecore.Diagnostics Namespace


SingleFatal Method (String, Exception, Type)

[image]

Sitecore 6.4.1 API
Log..::..SingleFatal Method (String, Exception, Type)
Log Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void SingleFatal(
    string message,
    Exception exception,
    Type ownerType
)
Visual Basic
Public Shared Sub SingleFatal ( _
    message As String, _
    exception As Exception, _
    ownerType As Type _
)
Visual C++
public:
static void SingleFatal(
    String^ message,
    Exception^ exception,
    Type^ ownerType
)

Parameters

message
Type: System..::..String
The message.
exception
Type: System..::..Exception
The exception.
ownerType
Type: System..::..Type
Type of the owner.

See Also

Log Class
SingleFatal Overload
Sitecore.Diagnostics Namespace


SingleWarn Method

[image]

Sitecore 6.4.1 API
Log..::..SingleWarn Method
Log Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void SingleWarn(
    string message,
    Object owner
)
Visual Basic
Public Shared Sub SingleWarn ( _
    message As String, _
    owner As Object _
)
Visual C++
public:
static void SingleWarn(
    String^ message,
    Object^ owner
)

Parameters

message
Type: System..::..String
The message.
owner
Type: System..::..Object
The owner.

See Also

Log Class
Sitecore.Diagnostics Namespace


Warn Method

[image] [image]

Sitecore 6.4.1 API
Log..::..Warn Method
Log Class See Also Send Feedback

Overload List

Name | Description
Warn(String, Object) | Warns the specified message.
Warn(String, Exception, Object) | Warns the specified message.

See Also

Log Class
Log Members
Sitecore.Diagnostics Namespace


Warn Method (String, Object)

[image]

Sitecore 6.4.1 API
Log..::..Warn Method (String, Object)
Log Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Warn(
    string message,
    Object owner
)
Visual Basic
Public Shared Sub Warn ( _
    message As String, _
    owner As Object _
)
Visual C++
public:
static void Warn(
    String^ message,
    Object^ owner
)

Parameters

message
Type: System..::..String
The message.
owner
Type: System..::..Object
The owner.

See Also

Log Class
Warn Overload
Sitecore.Diagnostics Namespace


Warn Method (String, Exception, Object)

[image]

Sitecore 6.4.1 API
Log..::..Warn Method (String, Exception, Object)
Log Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Warn(
    string message,
    Exception exception,
    Object owner
)
Visual Basic
Public Shared Sub Warn ( _
    message As String, _
    exception As Exception, _
    owner As Object _
)
Visual C++
public:
static void Warn(
    String^ message,
    Exception^ exception,
    Object^ owner
)

Parameters

message
Type: System..::..String
The message.
exception
Type: System..::..Exception
The exception.
owner
Type: System..::..Object
The owner.

See Also

Log Class
Warn Overload
Sitecore.Diagnostics Namespace


Log Properties

[image] [image]

Sitecore 6.4.1 API
Log Properties
Log Class See Also Send Feedback

The Log type exposes the following members.

Properties

Name | Description
Enabled | Gets a value indicating whether this Log is enabled.
Singles | Gets the singles.

See Also

Log Class
Sitecore.Diagnostics Namespace


Enabled Property

[image]

Sitecore 6.4.1 API
Log..::..Enabled Property
Log Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool Enabled { get; }
Visual Basic
Public Shared ReadOnly Property Enabled As Boolean
    Get
Visual C++
public:
static property bool Enabled {
    bool get ();
}

Field Value

true if enabled; otherwise, false.

See Also

Log Class
Sitecore.Diagnostics Namespace


Singles Property

[image]

Sitecore 6.4.1 API
Log..::..Singles Property
Log Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Cache Singles { get; }
Visual Basic
Public Shared ReadOnly Property Singles As Cache
    Get
Visual C++
public:
static property Cache^ Singles {
    Cache^ get ();
}

Field Value

The singles.

See Also

Log Class
Sitecore.Diagnostics Namespace


LoggerFactory Class

[image]

Sitecore 6.4.1 API
LoggerFactory Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class LoggerFactory
Visual Basic
Public NotInheritable Class LoggerFactory
Visual C++
public ref class LoggerFactory abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..LoggerFactory

See Also

LoggerFactory Members
Sitecore.Diagnostics Namespace


LoggerFactory Members

[image] [image]

Sitecore 6.4.1 API
LoggerFactory Members
LoggerFactory Class Methods See Also Send Feedback

Methods

Name | Description
GetLogger(Object) | Gets the logger.
GetLogger(String) | Gets the logger.
GetLogger(Type) | Gets the logger.

See Also

LoggerFactory Class
Sitecore.Diagnostics Namespace


GetLogger Method

[image] [image]

Sitecore 6.4.1 API
LoggerFactory..::..GetLogger Method
LoggerFactory Class See Also Send Feedback

Overload List

Name | Description
GetLogger(Object) | Gets the logger.
GetLogger(String) | Gets the logger.
GetLogger(Type) | Gets the logger.

See Also

LoggerFactory Class
LoggerFactory Members
Sitecore.Diagnostics Namespace


GetLogger Method (Object)

[image]

Sitecore 6.4.1 API
LoggerFactory..::..GetLogger Method (Object)
LoggerFactory Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ILog GetLogger(
    Object owner
)
Visual Basic
Public Shared Function GetLogger ( _
    owner As Object _
) As ILog
Visual C++
public:
static ILog^ GetLogger(
    Object^ owner
)

Parameters

owner
Type: System..::..Object
The owner.

Return Value

[Missing <returns> documentation for "M:Sitecore.Diagnostics.LoggerFactory.GetLogger(System.Object)"]

See Also

LoggerFactory Class
GetLogger Overload
Sitecore.Diagnostics Namespace


GetLogger Method (String)

[image]

Sitecore 6.4.1 API
LoggerFactory..::..GetLogger Method (String)
LoggerFactory Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ILog GetLogger(
    string name
)
Visual Basic
Public Shared Function GetLogger ( _
    name As String _
) As ILog
Visual C++
public:
static ILog^ GetLogger(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

Return Value

[Missing <returns> documentation for "M:Sitecore.Diagnostics.LoggerFactory.GetLogger(System.String)"]

See Also

LoggerFactory Class
GetLogger Overload
Sitecore.Diagnostics Namespace


GetLogger Method (Type)

[image]

Sitecore 6.4.1 API
LoggerFactory..::..GetLogger Method (Type)
LoggerFactory Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ILog GetLogger(
    Type type
)
Visual Basic
Public Shared Function GetLogger ( _
    type As Type _
) As ILog
Visual C++
public:
static ILog^ GetLogger(
    Type^ type
)

Parameters

type
Type: System..::..Type
The type.

Return Value

[Missing <returns> documentation for "M:Sitecore.Diagnostics.LoggerFactory.GetLogger(System.Type)"]

See Also

LoggerFactory Class
GetLogger Overload
Sitecore.Diagnostics Namespace


LogNotification Class

[image]

Sitecore 6.4.1 API
LogNotification Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class LogNotification
Visual Basic
Public NotInheritable Class LogNotification
Visual C++
public ref class LogNotification abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..LogNotification

See Also

LogNotification Members
Sitecore.Diagnostics Namespace


LogNotification Members

[image] [image]

Sitecore 6.4.1 API
LogNotification Members
LogNotification Class Methods Events See Also Send Feedback

The LogNotification type exposes the following members.

Methods

Name | Description
RaiseNotification(LogNotificationLevel, String) | Raises the field saved event.
RaiseNotification(LogNotificationLevel, String, Exception) | Raises the field saved event.

Events

Name | Description
Notification | field saved.

See Also

LogNotification Class
Sitecore.Diagnostics Namespace


LogNotification Methods

[image] [image]

Sitecore 6.4.1 API
LogNotification Methods
LogNotification Class See Also Send Feedback

Methods

Name | Description
RaiseNotification(LogNotificationLevel, String) | Raises the field saved event.
RaiseNotification(LogNotificationLevel, String, Exception) | Raises the field saved event.

See Also

LogNotification Class
Sitecore.Diagnostics Namespace


RaiseNotification Method

[image] [image]

Sitecore 6.4.1 API
LogNotification..::..RaiseNotification Method
LogNotification Class See Also Send Feedback

Overload List

Name | Description
RaiseNotification(LogNotificationLevel, String) | Raises the field saved event.
RaiseNotification(LogNotificationLevel, String, Exception) | Raises the field saved event.

See Also

LogNotification Class
LogNotification Members
Sitecore.Diagnostics Namespace


RaiseNotification Method (LogNotificationLevel, String)

[image]

Sitecore 6.4.1 API
LogNotification..::..RaiseNotification Method (LogNotificationLevel, String)
LogNotification Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void RaiseNotification(
    LogNotificationLevel level,
    string message
)
Visual Basic
Public Shared Sub RaiseNotification ( _
    level As LogNotificationLevel, _
    message As String _
)
Visual C++
public:
static void RaiseNotification(
    LogNotificationLevel level,
    String^ message
)

Parameters

level
Type: Sitecore.Diagnostics..::..LogNotificationLevel
The level.
message
Type: System..::..String
The message.

See Also

LogNotification Class
RaiseNotification Overload
Sitecore.Diagnostics Namespace


RaiseNotification Method (LogNotificationLevel, String, Exception)

[image]

Sitecore 6.4.1 API
LogNotification..::..RaiseNotification Method (LogNotificationLevel, String, Exception)
LogNotification Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void RaiseNotification(
    LogNotificationLevel level,
    string message,
    Exception ex
)
Visual Basic
Public Shared Sub RaiseNotification ( _
    level As LogNotificationLevel, _
    message As String, _
    ex As Exception _
)
Visual C++
public:
static void RaiseNotification(
    LogNotificationLevel level,
    String^ message,
    Exception^ ex
)

Parameters

level
Type: Sitecore.Diagnostics..::..LogNotificationLevel
The level.
message
Type: System..::..String
The message.
ex
Type: System..::..Exception
The ex.

See Also

LogNotification Class
RaiseNotification Overload
Sitecore.Diagnostics Namespace


LogNotification Events

[image] [image]

Sitecore 6.4.1 API
LogNotification Events
LogNotification Class See Also Send Feedback

The LogNotification type exposes the following members.

Events

Name | Description
Notification | field saved.

See Also

LogNotification Class
Sitecore.Diagnostics Namespace


Notification Event

[image]

Sitecore 6.4.1 API
LogNotification..::..Notification Event
LogNotification Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static event LogNotification..::..LogNotificationDelegate Notification
Visual Basic
Public Shared Event Notification As LogNotification..::..LogNotificationDelegate
Visual C++
public:
static  event LogNotification..::..LogNotificationDelegate^ Notification {
    void add (LogNotification..::..LogNotificationDelegate^ value);
    void remove (LogNotification..::..LogNotificationDelegate^ value);
}

See Also

LogNotification Class
Sitecore.Diagnostics Namespace


LogNotification.LogNotificationDelegate Delegate

[image]

Sitecore 6.4.1 API
LogNotification..::..LogNotificationDelegate Delegate
LogNotification Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public delegate void LogNotificationDelegate(
    LogNotificationLevel level,
    string message,
    Exception exception
)
Visual Basic
Public Delegate Sub LogNotificationDelegate ( _
    level As LogNotificationLevel, _
    message As String, _
    exception As Exception _
)
Visual C++
public delegate void LogNotificationDelegate(
    LogNotificationLevel level,
    String^ message,
    Exception^ exception
)

Parameters

level
Type: Sitecore.Diagnostics..::..LogNotificationLevel
The notification level
message
Type: System..::..String
The message
exception
Type: System..::..Exception
The thrown exception if any.

See Also

Sitecore.Diagnostics Namespace


LogNotificationLevel Enumeration

[image]

Sitecore 6.4.1 API
LogNotificationLevel Enumeration
See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum LogNotificationLevel
Visual Basic
Public Enumeration LogNotificationLevel
Visual C++
public enum class LogNotificationLevel

Members

Member name | Value | Description
None | 0 | No logging.
Debug | 1 | Debug level.
Info | 2 | Information level.
Warning | 3 | Warning level.
Error | 4 | Error level.
Fatal | 5 | Fatal error level.

See Also

Sitecore.Diagnostics Namespace


LongRunningOperationWatcher Class

[image]

Sitecore 6.4.1 API
LongRunningOperationWatcher Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class LongRunningOperationWatcher : IDisposable
Visual Basic
Public Class LongRunningOperationWatcher _
    Implements IDisposable
Visual C++
public ref class LongRunningOperationWatcher : IDisposable

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..LongRunningOperationWatcher

See Also

LongRunningOperationWatcher Members
Sitecore.Diagnostics Namespace


LongRunningOperationWatcher Members

[image] [image]

Sitecore 6.4.1 API
LongRunningOperationWatcher Members
LongRunningOperationWatcher Class Constructors Methods See Also Send Feedback

The LongRunningOperationWatcher type exposes the following members.

Constructors

 | Name | Description
Public method | LongRunningOperationWatcher | Initializes a new instance of the LongRunningOperationWatcher class.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LongRunningOperationWatcher Class
Sitecore.Diagnostics Namespace


LongRunningOperationWatcher Constructor

[image]

Sitecore 6.4.1 API
LongRunningOperationWatcher Constructor
LongRunningOperationWatcher Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LongRunningOperationWatcher(
    int threshold,
    string message,
    params string[] parameters
)
Visual Basic
Public Sub New ( _
    threshold As Integer, _
    message As String, _
    ParamArray parameters As String() _
)
Visual C++
public:
LongRunningOperationWatcher(
    int threshold,
    String^ message,
    ... array<String^>^ parameters
)

Parameters

threshold
Type: System..::..Int32
The threshold.
message
Type: System..::..String
The message.
parameters
Type: array< System..::..String >[]()[][]
The parameters.

See Also

LongRunningOperationWatcher Class
Sitecore.Diagnostics Namespace


LongRunningOperationWatcher Methods

[image] [image]

Sitecore 6.4.1 API
LongRunningOperationWatcher Methods
LongRunningOperationWatcher Class See Also Send Feedback

The LongRunningOperationWatcher type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LongRunningOperationWatcher Class
Sitecore.Diagnostics Namespace


Dispose Method

[image]

Sitecore 6.4.1 API
LongRunningOperationWatcher..::..Dispose Method
LongRunningOperationWatcher Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

LongRunningOperationWatcher Class
Sitecore.Diagnostics Namespace


MemoryMonitorHook Class

[image]

Sitecore 6.4.1 API
MemoryMonitorHook Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class MemoryMonitorHook : IHook
Visual Basic
Public Class MemoryMonitorHook _
    Implements IHook
Visual C++
public ref class MemoryMonitorHook : IHook

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..MemoryMonitorHook

See Also

MemoryMonitorHook Members
Sitecore.Diagnostics Namespace


MemoryMonitorHook Constructor

[image]

Sitecore 6.4.1 API
MemoryMonitorHook Constructor
MemoryMonitorHook Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MemoryMonitorHook(
    string threshold,
    string checkInterval,
    string minimumLogInterval
)
Visual Basic
Public Sub New ( _
    threshold As String, _
    checkInterval As String, _
    minimumLogInterval As String _
)
Visual C++
public:
MemoryMonitorHook(
    String^ threshold,
    String^ checkInterval,
    String^ minimumLogInterval
)

Parameters

threshold
Type: System..::..String
The threshold.
checkInterval
Type: System..::..String
The check interval.
minimumLogInterval
Type: System..::..String
The minimum log interval.

See Also

MemoryMonitorHook Class
Sitecore.Diagnostics Namespace


MemoryMonitorHook Methods

[image] [image]

Sitecore 6.4.1 API
MemoryMonitorHook Methods
MemoryMonitorHook Class See Also Send Feedback

The MemoryMonitorHook type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this instance.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MemoryMonitorHook Class
Sitecore.Diagnostics Namespace


MemoryMonitorHook Properties

[image] [image]

Sitecore 6.4.1 API
MemoryMonitorHook Properties
MemoryMonitorHook Class See Also Send Feedback

The MemoryMonitorHook type exposes the following members.

Properties

 | Name | Description
Public property | AdjustLoadFactor | Gets or sets a value indicating whether to adjust the global cache load factor when the memory limit is exceeded.
Public property | ClearCaches | Gets or sets a value indicating whether to clear all caches when the memory limit is exceeded.
Public property | GarbageCollect | Gets or sets a value indicating whether to garbage collect when the memory limit is exceeded.

See Also

MemoryMonitorHook Class
Sitecore.Diagnostics Namespace


AdjustLoadFactor Property

[image]

Sitecore 6.4.1 API
MemoryMonitorHook..::..AdjustLoadFactor Property
MemoryMonitorHook Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool AdjustLoadFactor { get; set; }
Visual Basic
Public Property AdjustLoadFactor As Boolean
    Get
    Set
Visual C++
public:
property bool AdjustLoadFactor {
    bool get ();
    void set (bool value);
}

Field Value

true if the load factor should be adjusted; otherwise, false.

See Also

MemoryMonitorHook Class
Sitecore.Diagnostics Namespace


ClearCaches Property

[image]

Sitecore 6.4.1 API
MemoryMonitorHook..::..ClearCaches Property
MemoryMonitorHook Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ClearCaches { get; set; }
Visual Basic
Public Property ClearCaches As Boolean
    Get
    Set
Visual C++
public:
property bool ClearCaches {
    bool get ();
    void set (bool value);
}

Field Value

true if the caches should be cleared; otherwise, false.

See Also

MemoryMonitorHook Class
Sitecore.Diagnostics Namespace


ProfileEntry Class

[image]

Sitecore 6.4.1 API
ProfileEntry Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ProfileEntry
Visual Basic
Public Class ProfileEntry
Visual C++
public ref class ProfileEntry

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..ProfileEntry

See Also

ProfileEntry Members
Sitecore.Diagnostics Namespace


ProfileEntry Members

[image] [image]

Sitecore 6.4.1 API
ProfileEntry Members
ProfileEntry Class Constructors Methods Properties See Also Send Feedback

The ProfileEntry type exposes the following members.

Constructors

 | Name | Description
Public method | ProfileEntry | Initializes a new instance of the ProfileEntry class.

Methods

 | Name | Description
Public method | AddAdminTime | Adds the admin time.
Public method | AddChildTime | Adds the child time.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdminTime | Gets the admin time.
Public property | CallStackID | Gets or sets the call stack ID.
Public property | ChildTime | Gets the child time.
Public property | EndTick | Gets or sets the end tick.
Public property | Level | Gets or sets the level.
Public property | MethodName | Gets the name of the method.
Public property | OwnTime | Gets the own time.
Public property | Parameters | Gets the parameters.
Public property | RequestID | Gets the request ID.
Public property | Sequence | Gets or sets the sequence.
Public property | StartTick | Gets or sets the start tick.
Public property | TotalTime | Gets the total time.

See Also

ProfileEntry Class
Sitecore.Diagnostics Namespace


ProfileEntry Constructor

[image]

Sitecore 6.4.1 API
ProfileEntry Constructor
ProfileEntry Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ProfileEntry(
    string methodName,
    string[] parameters
)
Visual Basic
Public Sub New ( _
    methodName As String, _
    parameters As String() _
)
Visual C++
public:
ProfileEntry(
    String^ methodName,
    array<String^>^ parameters
)

Parameters

methodName
Type: System..::..String
Name of the method.
parameters
Type: array< System..::..String >[]()[][]
The parameters.

See Also

ProfileEntry Class
Sitecore.Diagnostics Namespace


ProfileEntry Methods

[image] [image]

Sitecore 6.4.1 API
ProfileEntry Methods
ProfileEntry Class See Also Send Feedback

The ProfileEntry type exposes the following members.

Methods

 | Name | Description
Public method | AddAdminTime | Adds the admin time.
Public method | AddChildTime | Adds the child time.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProfileEntry Class
Sitecore.Diagnostics Namespace


AddAdminTime Method

[image]

Sitecore 6.4.1 API
ProfileEntry..::..AddAdminTime Method
ProfileEntry Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddAdminTime(
    double time
)
Visual Basic
Public Sub AddAdminTime ( _
    time As Double _
)
Visual C++
public:
void AddAdminTime(
    double time
)

Parameters

time
Type: System..::..Double
The time.

See Also

ProfileEntry Class
Sitecore.Diagnostics Namespace


AddChildTime Method

[image]

Sitecore 6.4.1 API
ProfileEntry..::..AddChildTime Method
ProfileEntry Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddChildTime(
    double time
)
Visual Basic
Public Sub AddChildTime ( _
    time As Double _
)
Visual C++
public:
void AddChildTime(
    double time
)

Parameters

time
Type: System..::..Double
The time.

See Also

ProfileEntry Class
Sitecore.Diagnostics Namespace


ProfileEntry Properties

[image] [image]

Sitecore 6.4.1 API
ProfileEntry Properties
ProfileEntry Class See Also Send Feedback

The ProfileEntry type exposes the following members.

Properties

 | Name | Description
Public property | AdminTime | Gets the admin time.
Public property | CallStackID | Gets or sets the call stack ID.
Public property | ChildTime | Gets the child time.
Public property | EndTick | Gets or sets the end tick.
Public property | Level | Gets or sets the level.
Public property | MethodName | Gets the name of the method.
Public property | OwnTime | Gets the own time.
Public property | Parameters | Gets the parameters.
Public property | RequestID | Gets the request ID.
Public property | Sequence | Gets or sets the sequence.
Public property | StartTick | Gets or sets the start tick.
Public property | TotalTime | Gets the total time.

See Also

ProfileEntry Class
Sitecore.Diagnostics Namespace


AdminTime Property

[image]

Sitecore 6.4.1 API
ProfileEntry..::..AdminTime Property
ProfileEntry Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public double AdminTime { get; }
Visual Basic
Public ReadOnly Property AdminTime As Double
    Get
Visual C++
public:
property double AdminTime {
    double get ();
}

Field Value

The admin time.

See Also

ProfileEntry Class
Sitecore.Diagnostics Namespace


CallStackID Property

[image]

Sitecore 6.4.1 API
ProfileEntry..::..CallStackID Property
ProfileEntry Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string CallStackID { get; set; }
Visual Basic
Public Property CallStackID As String
    Get
    Set
Visual C++
public:
property String^ CallStackID {
    String^ get ();
    void set (String^ value);
}

Field Value

The call stack ID.

See Also

ProfileEntry Class
Sitecore.Diagnostics Namespace


ChildTime Property

[image]

Sitecore 6.4.1 API
ProfileEntry..::..ChildTime Property
ProfileEntry Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public double ChildTime { get; }
Visual Basic
Public ReadOnly Property ChildTime As Double
    Get
Visual C++
public:
property double ChildTime {
    double get ();
}

Field Value

The child time.

See Also

ProfileEntry Class
Sitecore.Diagnostics Namespace


EndTick Property

[image]

Sitecore 6.4.1 API
ProfileEntry..::..EndTick Property
ProfileEntry Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long EndTick { get; set; }
Visual Basic
Public Property EndTick As Long
    Get
    Set
Visual C++
public:
property long long EndTick {
    long long get ();
    void set (long long value);
}

Field Value

The end tick.

See Also

ProfileEntry Class
Sitecore.Diagnostics Namespace


MethodName Property

[image]

Sitecore 6.4.1 API
ProfileEntry..::..MethodName Property
ProfileEntry Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string MethodName { get; }
Visual Basic
Public ReadOnly Property MethodName As String
    Get
Visual C++
public:
property String^ MethodName {
    String^ get ();
}

Field Value

The name of the method.

See Also

ProfileEntry Class
Sitecore.Diagnostics Namespace


OwnTime Property

[image]

Sitecore 6.4.1 API
ProfileEntry..::..OwnTime Property
ProfileEntry Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public double OwnTime { get; }
Visual Basic
Public ReadOnly Property OwnTime As Double
    Get
Visual C++
public:
property double OwnTime {
    double get ();
}

Field Value

The own time.

See Also

ProfileEntry Class
Sitecore.Diagnostics Namespace


Parameters Property

[image]

Sitecore 6.4.1 API
ProfileEntry..::..Parameters Property
ProfileEntry Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string[] Parameters { get; }
Visual Basic
Public ReadOnly Property Parameters As String()
    Get
Visual C++
public:
property array<String^>^ Parameters {
    array<String^>^ get ();
}

Field Value

The parameters.

See Also

ProfileEntry Class
Sitecore.Diagnostics Namespace


RequestID Property

[image]

Sitecore 6.4.1 API
ProfileEntry..::..RequestID Property
ProfileEntry Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string RequestID { get; }
Visual Basic
Public ReadOnly Property RequestID As String
    Get
Visual C++
public:
property String^ RequestID {
    String^ get ();
}

Field Value

The request ID.

See Also

ProfileEntry Class
Sitecore.Diagnostics Namespace


Sequence Property

[image]

Sitecore 6.4.1 API
ProfileEntry..::..Sequence Property
ProfileEntry Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Sequence { get; set; }
Visual Basic
Public Property Sequence As Integer
    Get
    Set
Visual C++
public:
property int Sequence {
    int get ();
    void set (int value);
}

Field Value

The sequence.

See Also

ProfileEntry Class
Sitecore.Diagnostics Namespace


StartTick Property

[image]

Sitecore 6.4.1 API
ProfileEntry..::..StartTick Property
ProfileEntry Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long StartTick { get; set; }
Visual Basic
Public Property StartTick As Long
    Get
    Set
Visual C++
public:
property long long StartTick {
    long long get ();
    void set (long long value);
}

Field Value

The start tick.

See Also

ProfileEntry Class
Sitecore.Diagnostics Namespace


TotalTime Property

[image]

Sitecore 6.4.1 API
ProfileEntry..::..TotalTime Property
ProfileEntry Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public double TotalTime { get; }
Visual Basic
Public ReadOnly Property TotalTime As Double
    Get
Visual C++
public:
property double TotalTime {
    double get ();
}

Field Value

The total time.

See Also

ProfileEntry Class
Sitecore.Diagnostics Namespace


Profiler Class

[image]

Sitecore 6.4.1 API
Profiler Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Profiler
Visual Basic
Public NotInheritable Class Profiler
Visual C++
public ref class Profiler abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..Profiler

See Also

Profiler Members
Sitecore.Diagnostics Namespace


Profiler Members

[image] [image]

Sitecore 6.4.1 API
Profiler Members
Profiler Class Methods Properties See Also Send Feedback

The Profiler type exposes the following members.

Methods

Name | Description
Abort | Aborts profiling.
EndOperation()()()() | Ends the operation.
EndOperation(String) | Ends the operation.
EndSession | Ends the session.
GetFormattedProfile()()()() | Gets the formatted profile.
GetFormattedProfile(String) | Gets the formatted profile.
GetReportFileName | Gets the name of the report file.
Render | Renders this instance.
SaveReport()()()() | Saves the report.
SaveReport(String) | Saves the report.
StartOperation | Starts the operation.
StartSession | Starts the session.

Properties

Name | Description
IsActive | Gets a value indicating whether this instance is active.
RenderOnEndSession | Gets or sets a value indicating whether the Profiler renders the on end session.

See Also

Profiler Class
Sitecore.Diagnostics Namespace


Profiler Methods

[image] [image]

Sitecore 6.4.1 API
Profiler Methods
Profiler Class See Also Send Feedback

The Profiler type exposes the following members.

Methods

Name | Description
Abort | Aborts profiling.
EndOperation()()()() | Ends the operation.
EndOperation(String) | Ends the operation.
EndSession | Ends the session.
GetFormattedProfile()()()() | Gets the formatted profile.
GetFormattedProfile(String) | Gets the formatted profile.
GetReportFileName | Gets the name of the report file.
Render | Renders this instance.
SaveReport()()()() | Saves the report.
SaveReport(String) | Saves the report.
StartOperation | Starts the operation.
StartSession | Starts the session.

See Also

Profiler Class
Sitecore.Diagnostics Namespace


Abort Method

[image]

Sitecore 6.4.1 API
Profiler..::..Abort Method
Profiler Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Abort()
Visual Basic
Public Shared Sub Abort
Visual C++
public:
static void Abort()

See Also

Profiler Class
Sitecore.Diagnostics Namespace


EndOperation Method

[image] [image]

Sitecore 6.4.1 API
Profiler..::..EndOperation Method
Profiler Class See Also Send Feedback

Overload List

Name | Description
EndOperation()()()() | Ends the operation.
EndOperation(String) | Ends the operation.

See Also

Profiler Class
Profiler Members
Sitecore.Diagnostics Namespace


EndOperation Method

[image]

Sitecore 6.4.1 API
Profiler..::..EndOperation Method
Profiler Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void EndOperation()
Visual Basic
Public Shared Sub EndOperation
Visual C++
public:
static void EndOperation()

See Also

Profiler Class
EndOperation Overload
Sitecore.Diagnostics Namespace


EndOperation Method (String)

[image]

Sitecore 6.4.1 API
Profiler..::..EndOperation Method (String)
Profiler Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void EndOperation(
    string status
)
Visual Basic
Public Shared Sub EndOperation ( _
    status As String _
)
Visual C++
public:
static void EndOperation(
    String^ status
)

Parameters

status
Type: System..::..String
The status.

See Also

Profiler Class
EndOperation Overload
Sitecore.Diagnostics Namespace


EndSession Method

[image]

Sitecore 6.4.1 API
Profiler..::..EndSession Method
Profiler Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void EndSession()
Visual Basic
Public Shared Sub EndSession
Visual C++
public:
static void EndSession()

See Also

Profiler Class
Sitecore.Diagnostics Namespace


GetFormattedProfile Method

[image] [image]

Sitecore 6.4.1 API
Profiler..::..GetFormattedProfile Method
Profiler Class See Also Send Feedback

Overload List

Name | Description
GetFormattedProfile()()()() | Gets the formatted profile.
GetFormattedProfile(String) | Gets the formatted profile.

See Also

Profiler Class
Profiler Members
Sitecore.Diagnostics Namespace


GetFormattedProfile Method

[image]

Sitecore 6.4.1 API
Profiler..::..GetFormattedProfile Method
Profiler Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetFormattedProfile()
Visual Basic
Public Shared Function GetFormattedProfile As String
Visual C++
public:
static String^ GetFormattedProfile()

Return Value

The get formatted profile.

See Also

Profiler Class
GetFormattedProfile Overload
Sitecore.Diagnostics Namespace


GetFormattedProfile Method (String)

[image]

Sitecore 6.4.1 API
Profiler..::..GetFormattedProfile Method (String)
Profiler Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetFormattedProfile(
    string xslFile
)
Visual Basic
Public Shared Function GetFormattedProfile ( _
    xslFile As String _
) As String
Visual C++
public:
static String^ GetFormattedProfile(
    String^ xslFile
)

Parameters

xslFile
Type: System..::..String
The XSL file.

Return Value

The get formatted profile.

See Also

Profiler Class
GetFormattedProfile Overload
Sitecore.Diagnostics Namespace


GetReportFileName Method

[image]

Sitecore 6.4.1 API
Profiler..::..GetReportFileName Method
Profiler Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetReportFileName()
Visual Basic
Public Shared Function GetReportFileName As String
Visual C++
public:
static String^ GetReportFileName()

Return Value

The get report file name.

See Also

Profiler Class
Sitecore.Diagnostics Namespace


Render Method

[image]

Sitecore 6.4.1 API
Profiler..::..Render Method
Profiler Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Render()
Visual Basic
Public Shared Sub Render
Visual C++
public:
static void Render()

See Also

Profiler Class
Sitecore.Diagnostics Namespace


SaveReport Method

[image] [image]

Sitecore 6.4.1 API
Profiler..::..SaveReport Method
Profiler Class See Also Send Feedback

Overload List

Name | Description
SaveReport()()()() | Saves the report.
SaveReport(String) | Saves the report.

See Also

Profiler Class
Profiler Members
Sitecore.Diagnostics Namespace


SaveReport Method

[image]

Sitecore 6.4.1 API
Profiler..::..SaveReport Method
Profiler Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void SaveReport()
Visual Basic
Public Shared Sub SaveReport
Visual C++
public:
static void SaveReport()

See Also

Profiler Class
SaveReport Overload
Sitecore.Diagnostics Namespace


SaveReport Method (String)

[image]

Sitecore 6.4.1 API
Profiler..::..SaveReport Method (String)
Profiler Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void SaveReport(
    string fileName
)
Visual Basic
Public Shared Sub SaveReport ( _
    fileName As String _
)
Visual C++
public:
static void SaveReport(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
Name of the file.

See Also

Profiler Class
SaveReport Overload
Sitecore.Diagnostics Namespace


StartSession Method

[image]

Sitecore 6.4.1 API
Profiler..::..StartSession Method
Profiler Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void StartSession()
Visual Basic
Public Shared Sub StartSession
Visual C++
public:
static void StartSession()

See Also

Profiler Class
Sitecore.Diagnostics Namespace


Profiler Properties

[image] [image]

Sitecore 6.4.1 API
Profiler Properties
Profiler Class See Also Send Feedback

The Profiler type exposes the following members.

Properties

Name | Description
IsActive | Gets a value indicating whether this instance is active.
RenderOnEndSession | Gets or sets a value indicating whether the Profiler renders the on end session.

See Also

Profiler Class
Sitecore.Diagnostics Namespace


IsActive Property

[image]

Sitecore 6.4.1 API
Profiler..::..IsActive Property
Profiler Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsActive { get; }
Visual Basic
Public Shared ReadOnly Property IsActive As Boolean
    Get
Visual C++
public:
static property bool IsActive {
    bool get ();
}

Field Value

true if this instance is active; otherwise, false.

See Also

Profiler Class
Sitecore.Diagnostics Namespace


RenderOnEndSession Property

[image]

Sitecore 6.4.1 API
Profiler..::..RenderOnEndSession Property
Profiler Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool RenderOnEndSession { get; set; }
Visual Basic
Public Shared Property RenderOnEndSession As Boolean
    Get
    Set
Visual C++
public:
static property bool RenderOnEndSession {
    bool get ();
    void set (bool value);
}

Field Value

true if the Profiler renders the on end session; otherwise, false.

See Also

Profiler Class
Sitecore.Diagnostics Namespace


Profiler.Worker Class

[image]

Sitecore 6.4.1 API
Profiler..::..Worker Class
Profiler Class Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Worker : DiagnosticWorker
Visual Basic
Public Class Worker _
    Inherits DiagnosticWorker
Visual C++
public ref class Worker : public DiagnosticWorker

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..DiagnosticWorker
Sitecore.Diagnostics..::..Profiler..::..Worker

See Also

Profiler..::..Worker Members
Sitecore.Diagnostics Namespace


Profiler.Worker Members

[image] [image]

Sitecore 6.4.1 API
Profiler..::..Worker Members
Profiler..::..Worker Class Constructors Methods Properties See Also Send Feedback

Represents the Profiler.

The Profiler..::..Worker type exposes the following members.

Constructors

 | Name | Description
Public method | Profiler..::..Worker | Initializes a new instance of the Profiler..::..Worker class.

Methods

 | Name | Description
Public method | EndOperation | Ends the operation.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetReportFileName | Gets the name of the report file.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveReport | Saves the report. (Inherited from DiagnosticWorker.)
Public method | StartOperation | Starts the operation.
Protected method | StartReport | Starts the report. (Inherited from DiagnosticWorker.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | Gets the name. (Inherited from DiagnosticWorker.)
Public property | Packet | Gets the packet. (Inherited from DiagnosticWorker.)
Public property | RenderOnEndSession | Gets or sets a value indicating whether the Profiler..::..Worker renders the on end session.

See Also

Profiler..::..Worker Class
Sitecore.Diagnostics Namespace


Profiler.Worker Constructor

[image]

Sitecore 6.4.1 API
Profiler..::..Worker Constructor
Profiler..::..Worker Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Worker()
Visual Basic
Public Sub New
Visual C++
public:
Worker()

See Also

Profiler..::..Worker Class
Sitecore.Diagnostics Namespace


Profiler.Worker Methods

[image] [image]

Sitecore 6.4.1 API
Profiler..::..Worker Methods
Profiler..::..Worker Class See Also Send Feedback

The Profiler..::..Worker type exposes the following members.

Methods

 | Name | Description
Public method | EndOperation | Ends the operation.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetReportFileName | Gets the name of the report file.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveReport | Saves the report. (Inherited from DiagnosticWorker.)
Public method | StartOperation | Starts the operation.
Protected method | StartReport | Starts the report. (Inherited from DiagnosticWorker.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Profiler..::..Worker Class
Sitecore.Diagnostics Namespace


EndOperation Method

[image]

Sitecore 6.4.1 API
Profiler..::..Worker..::..EndOperation Method
Profiler..::..Worker Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void EndOperation(
    string status
)
Visual Basic
Public Sub EndOperation ( _
    status As String _
)
Visual C++
public:
void EndOperation(
    String^ status
)

Parameters

status
Type: System..::..String
The status.

See Also

Profiler..::..Worker Class
Sitecore.Diagnostics Namespace


GetReportFileName Method

[image]

Sitecore 6.4.1 API
Profiler..::..Worker..::..GetReportFileName Method
Profiler..::..Worker Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetReportFileName()
Visual Basic
Public Shared Function GetReportFileName As String
Visual C++
public:
static String^ GetReportFileName()

Return Value

The get report file name.

See Also

Profiler..::..Worker Class
Sitecore.Diagnostics Namespace


StartOperation Method

[image]

Sitecore 6.4.1 API
Profiler..::..Worker..::..StartOperation Method
Profiler..::..Worker Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void StartOperation(
    string name
)
Visual Basic
Public Sub StartOperation ( _
    name As String _
)
Visual C++
public:
void StartOperation(
    String^ name
)

Parameters

name
Type: System..::..String
The operation name.

See Also

Profiler..::..Worker Class
Sitecore.Diagnostics Namespace


Profiler.Worker Properties

[image] [image]

Sitecore 6.4.1 API
Profiler..::..Worker Properties
Profiler..::..Worker Class See Also Send Feedback

The Profiler..::..Worker type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the name. (Inherited from DiagnosticWorker.)
Public property | Packet | Gets the packet. (Inherited from DiagnosticWorker.)
Public property | RenderOnEndSession | Gets or sets a value indicating whether the Profiler..::..Worker renders the on end session.

See Also

Profiler..::..Worker Class
Sitecore.Diagnostics Namespace


RenderOnEndSession Property

[image]

Sitecore 6.4.1 API
Profiler..::..Worker..::..RenderOnEndSession Property
Profiler..::..Worker Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool RenderOnEndSession { get; set; }
Visual Basic
Public Property RenderOnEndSession As Boolean
    Get
    Set
Visual C++
public:
property bool RenderOnEndSession {
    bool get ();
    void set (bool value);
}

Field Value

true if the Profiler..::..Worker renders the on end session; otherwise, false.

See Also

Profiler..::..Worker Class
Sitecore.Diagnostics Namespace


ProfileSection Class

[image]

Sitecore 6.4.1 API
ProfileSection Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ProfileSection : IDisposable
Visual Basic
Public Class ProfileSection _
    Implements IDisposable
Visual C++
public ref class ProfileSection : IDisposable

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..ProfileSection

See Also

ProfileSection Members
Sitecore.Diagnostics Namespace


ProfileSection Members

[image] [image]

Sitecore 6.4.1 API
ProfileSection Members
ProfileSection Class Constructors Methods See Also Send Feedback

The ProfileSection type exposes the following members.

Constructors

 | Name | Description
Public method | ProfileSection | Initializes a new instance of the ProfileSection class.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProfileSection Class
Sitecore.Diagnostics Namespace


ProfileSection Constructor

[image]

Sitecore 6.4.1 API
ProfileSection Constructor
ProfileSection Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ProfileSection(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
ProfileSection(
    String^ message
)

Parameters

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:Sitecore.Diagnostics.ProfileSection.#ctor(System.String)"]

See Also

ProfileSection Class
Sitecore.Diagnostics Namespace


ProfileSection Methods

[image] [image]

Sitecore 6.4.1 API
ProfileSection Methods
ProfileSection Class See Also Send Feedback

The ProfileSection type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProfileSection Class
Sitecore.Diagnostics Namespace


Dispose Method

[image]

Sitecore 6.4.1 API
ProfileSection..::..Dispose Method
ProfileSection Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ProfileSection Class
Sitecore.Diagnostics Namespace


RecursionLimit Class

[image]

Sitecore 6.4.1 API
RecursionLimit Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RecursionLimit : IDisposable
Visual Basic
Public Class RecursionLimit _
    Implements IDisposable
Visual C++
public ref class RecursionLimit : IDisposable

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..RecursionLimit

See Also

RecursionLimit Members
Sitecore.Diagnostics Namespace


RecursionLimit Constructor

[image]

Sitecore 6.4.1 API
RecursionLimit Constructor
RecursionLimit Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RecursionLimit(
    string name,
    int maxLevel
)
Visual Basic
Public Sub New ( _
    name As String, _
    maxLevel As Integer _
)
Visual C++
public:
RecursionLimit(
    String^ name,
    int maxLevel
)

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Sitecore.Diagnostics.RecursionLimit.#ctor(System.String,System.Int32)"]

maxLevel
Type: System..::..Int32

[Missing <param name="maxLevel"/> documentation for "M:Sitecore.Diagnostics.RecursionLimit.#ctor(System.String,System.Int32)"]

See Also

RecursionLimit Class
Sitecore.Diagnostics Namespace


RecursionLimit Methods

[image] [image]

Sitecore 6.4.1 API
RecursionLimit Methods
RecursionLimit Class See Also Send Feedback

The RecursionLimit type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RecursionLimit Class
Sitecore.Diagnostics Namespace


Dispose Method

[image]

Sitecore 6.4.1 API
RecursionLimit..::..Dispose Method
RecursionLimit Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

RecursionLimit Class
Sitecore.Diagnostics Namespace


RecursionLimit Properties

[image] [image]

Sitecore 6.4.1 API
RecursionLimit Properties
RecursionLimit Class See Also Send Feedback

The RecursionLimit type exposes the following members.

Properties

 | Name | Description
Public property | Exceeded | Gets a value indicating whether this RecursionLimit is exceeded.
Public property | Level | Gets the current level.

See Also

RecursionLimit Class
Sitecore.Diagnostics Namespace


Exceeded Property

[image]

Sitecore 6.4.1 API
RecursionLimit..::..Exceeded Property
RecursionLimit Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Exceeded { get; }
Visual Basic
Public ReadOnly Property Exceeded As Boolean
    Get
Visual C++
public:
property bool Exceeded {
    bool get ();
}

Field Value

true if exceeded; otherwise, false.

See Also

RecursionLimit Class
Sitecore.Diagnostics Namespace


Statistics Class

[image]

Sitecore 6.4.1 API
Statistics Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public sealed class Statistics
Visual Basic
Public NotInheritable Class Statistics
Visual C++
public ref class Statistics sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..Statistics

See Also

Statistics Members
Sitecore.Diagnostics Namespace


Statistics Members

[image] [image]

Sitecore 6.4.1 API
Statistics Members
Statistics Class Constructors Methods Properties See Also Send Feedback

The Statistics type exposes the following members.

Constructors

 | Name | Description
Public method | Statistics | Initializes a new instance of the Statistics class

Methods

 | Name | Description
 | AddPipelineTiming | Adds a pipeline timing.
 | AddRenderingData | Adds rendering data.
 | AddRequestTiming | Adds the request timing.
 | Clear | Clears the current data
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPipelineTiming | Gets a pipeline timing.
 | GetRenderingData | Gets rendering data.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ResetPipelineTiming | Resets the pipeline timing.
 | ResetRequestTiming | Resets the request timing.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
RenderingStatistics | Gets the rendering data.
RequestCount | Gets the request count.
RequestTime | Gets the request time.

See Also

Statistics Class
Sitecore.Diagnostics Namespace


Statistics Constructor

[image]

Sitecore 6.4.1 API
Statistics Constructor
Statistics Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Statistics()
Visual Basic
Public Sub New
Visual C++
public:
Statistics()

See Also

Statistics Class
Sitecore.Diagnostics Namespace


Statistics Methods

[image] [image]

Sitecore 6.4.1 API
Statistics Methods
Statistics Class See Also Send Feedback

The Statistics type exposes the following members.

Methods

 | Name | Description
 | AddPipelineTiming | Adds a pipeline timing.
 | AddRenderingData | Adds rendering data.
 | AddRequestTiming | Adds the request timing.
 | Clear | Clears the current data
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPipelineTiming | Gets a pipeline timing.
 | GetRenderingData | Gets rendering data.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ResetPipelineTiming | Resets the pipeline timing.
 | ResetRequestTiming | Resets the request timing.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Statistics Class
Sitecore.Diagnostics Namespace


AddPipelineTiming Method

[image]

Sitecore 6.4.1 API
Statistics..::..AddPipelineTiming Method
Statistics Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void AddPipelineTiming(
    string pipelineName,
    TimeSpan elapsed
)
Visual Basic
Public Shared Sub AddPipelineTiming ( _
    pipelineName As String, _
    elapsed As TimeSpan _
)
Visual C++
public:
static void AddPipelineTiming(
    String^ pipelineName,
    TimeSpan elapsed
)

Parameters

pipelineName
Type: System..::..String

[Missing <param name="pipelineName"/> documentation for "M:Sitecore.Diagnostics.Statistics.AddPipelineTiming(System.String,System.TimeSpan)"]

elapsed
Type: System..::..TimeSpan

[Missing <param name="elapsed"/> documentation for "M:Sitecore.Diagnostics.Statistics.AddPipelineTiming(System.String,System.TimeSpan)"]

See Also

Statistics Class
Sitecore.Diagnostics Namespace


AddRenderingData Method

[image]

Sitecore 6.4.1 API
Statistics..::..AddRenderingData Method
Statistics Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void AddRenderingData(
    string traceName,
    double elapsed,
    long itemsAccessed,
    bool usedCache
)
Visual Basic
Public Shared Sub AddRenderingData ( _
    traceName As String, _
    elapsed As Double, _
    itemsAccessed As Long, _
    usedCache As Boolean _
)
Visual C++
public:
static void AddRenderingData(
    String^ traceName,
    double elapsed,
    long long itemsAccessed,
    bool usedCache
)

Parameters

traceName
Type: System..::..String
Name of the trace.
elapsed
Type: System..::..Double
The elapsed time (in ms.).
itemsAccessed
Type: System..::..Int64
The items accessed.
usedCache
Type: System..::..Boolean
if set to true this instance is used cache.

See Also

Statistics Class
Sitecore.Diagnostics Namespace


AddRequestTiming Method

[image]

Sitecore 6.4.1 API
Statistics..::..AddRequestTiming Method
Statistics Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void AddRequestTiming(
    TimeSpan requestTime
)
Visual Basic
Public Shared Sub AddRequestTiming ( _
    requestTime As TimeSpan _
)
Visual C++
public:
static void AddRequestTiming(
    TimeSpan requestTime
)

Parameters

requestTime
Type: System..::..TimeSpan
The request time.

See Also

Statistics Class
Sitecore.Diagnostics Namespace


Clear Method

[image]

Sitecore 6.4.1 API
Statistics..::..Clear Method
Statistics Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Clear()
Visual Basic
Public Shared Sub Clear
Visual C++
public:
static void Clear()

See Also

Statistics Class
Sitecore.Diagnostics Namespace


GetPipelineTiming Method

[image]

Sitecore 6.4.1 API
Statistics..::..GetPipelineTiming Method
Statistics Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Statistics..::..PipelineTiming GetPipelineTiming(
    string pipelineName
)
Visual Basic
Public Shared Function GetPipelineTiming ( _
    pipelineName As String _
) As Statistics..::..PipelineTiming
Visual C++
public:
static Statistics..::..PipelineTiming^ GetPipelineTiming(
    String^ pipelineName
)

Parameters

pipelineName
Type: System..::..String

[Missing <param name="pipelineName"/> documentation for "M:Sitecore.Diagnostics.Statistics.GetPipelineTiming(System.String)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Diagnostics.Statistics.GetPipelineTiming(System.String)"]

See Also

Statistics Class
Sitecore.Diagnostics Namespace


GetRenderingData Method

[image]

Sitecore 6.4.1 API
Statistics..::..GetRenderingData Method
Statistics Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Statistics..::..RenderingData GetRenderingData(
    string traceName
)
Visual Basic
Public Shared Function GetRenderingData ( _
    traceName As String _
) As Statistics..::..RenderingData
Visual C++
public:
static Statistics..::..RenderingData^ GetRenderingData(
    String^ traceName
)

Parameters

traceName
Type: System..::..String
Name of the trace.

Return Value

The rendering data.

See Also

Statistics Class
Sitecore.Diagnostics Namespace


ResetPipelineTiming Method

[image]

Sitecore 6.4.1 API
Statistics..::..ResetPipelineTiming Method
Statistics Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void ResetPipelineTiming()
Visual Basic
Public Shared Sub ResetPipelineTiming
Visual C++
public:
static void ResetPipelineTiming()

See Also

Statistics Class
Sitecore.Diagnostics Namespace


ResetRequestTiming Method

[image]

Sitecore 6.4.1 API
Statistics..::..ResetRequestTiming Method
Statistics Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void ResetRequestTiming()
Visual Basic
Public Shared Sub ResetRequestTiming
Visual C++
public:
static void ResetRequestTiming()

See Also

Statistics Class
Sitecore.Diagnostics Namespace


Statistics Properties

[image] [image]

Sitecore 6.4.1 API
Statistics Properties
Statistics Class See Also Send Feedback

The Statistics type exposes the following members.

Properties

Name | Description
RenderingStatistics | Gets the rendering data.
RequestCount | Gets the request count.
RequestTime | Gets the request time.

See Also

Statistics Class
Sitecore.Diagnostics Namespace


RenderingStatistics Property

[image]

Sitecore 6.4.1 API
Statistics..::..RenderingStatistics Property
Statistics Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static IEnumerable<Statistics..::..RenderingData> RenderingStatistics { get; }
Visual Basic
Public Shared ReadOnly Property RenderingStatistics As IEnumerable(Of Statistics..::..RenderingData)
    Get
Visual C++
public:
static property IEnumerable<Statistics..::..RenderingData^>^ RenderingStatistics {
    IEnumerable<Statistics..::..RenderingData^>^ get ();
}

Field Value

The rendering data.

See Also

Statistics Class
Sitecore.Diagnostics Namespace


RequestCount Property

[image]

Sitecore 6.4.1 API
Statistics..::..RequestCount Property
Statistics Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int RequestCount { get; }
Visual Basic
Public Shared ReadOnly Property RequestCount As Integer
    Get
Visual C++
public:
static property int RequestCount {
    int get ();
}

Field Value

The request count.

See Also

Statistics Class
Sitecore.Diagnostics Namespace


RequestTime Property

[image]

Sitecore 6.4.1 API
Statistics..::..RequestTime Property
Statistics Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TimeSpan RequestTime { get; }
Visual Basic
Public Shared ReadOnly Property RequestTime As TimeSpan
    Get
Visual C++
public:
static property TimeSpan RequestTime {
    TimeSpan get ();
}

Field Value

The request time.

See Also

Statistics Class
Sitecore.Diagnostics Namespace


Statistics.PipelineTiming Class

[image]

Sitecore 6.4.1 API
Statistics..::..PipelineTiming Class
Statistics Class Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PipelineTiming
Visual Basic
Public Class PipelineTiming
Visual C++
public ref class PipelineTiming

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..Statistics..::..PipelineTiming

See Also

Statistics..::..PipelineTiming Members
Sitecore.Diagnostics Namespace


Statistics.PipelineTiming Members

[image] [image]

Sitecore 6.4.1 API
Statistics..::..PipelineTiming Members
Statistics..::..PipelineTiming Class Constructors Methods Properties See Also Send Feedback

Statistics
Statistics
Statistics

The Statistics..::..PipelineTiming type exposes the following members.

Constructors

 | Name | Description
Public method | Statistics..::..PipelineTiming | Initializes a new instance of the Statistics..::..PipelineTiming class

Methods

 | Name | Description
Public method | Add | Adds the specified timing.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CallCount | Gets the call count.
Public property | TotalTime | Gets the total time.

See Also

Statistics..::..PipelineTiming Class
Sitecore.Diagnostics Namespace


Statistics.PipelineTiming Constructor

[image]

Sitecore 6.4.1 API
Statistics..::..PipelineTiming Constructor
Statistics..::..PipelineTiming Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PipelineTiming()
Visual Basic
Public Sub New
Visual C++
public:
PipelineTiming()

See Also

Statistics..::..PipelineTiming Class
Sitecore.Diagnostics Namespace


Statistics.PipelineTiming Methods

[image] [image]

Sitecore 6.4.1 API
Statistics..::..PipelineTiming Methods
Statistics..::..PipelineTiming Class See Also Send Feedback

The Statistics..::..PipelineTiming type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified timing.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Statistics..::..PipelineTiming Class
Sitecore.Diagnostics Namespace


Add Method

[image]

Sitecore 6.4.1 API
Statistics..::..PipelineTiming..::..Add Method
Statistics..::..PipelineTiming Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Statistics..::..PipelineTiming Add(
    TimeSpan elapsed
)
Visual Basic
Public Function Add ( _
    elapsed As TimeSpan _
) As Statistics..::..PipelineTiming
Visual C++
public:
Statistics..::..PipelineTiming^ Add(
    TimeSpan elapsed
)

Parameters

elapsed
Type: System..::..TimeSpan
The elapsed time.

Return Value

[Missing <returns> documentation for "M:Sitecore.Diagnostics.Statistics.PipelineTiming.Add(System.TimeSpan)"]

See Also

Statistics..::..PipelineTiming Class
Sitecore.Diagnostics Namespace


Statistics.PipelineTiming Properties

[image] [image]

Sitecore 6.4.1 API
Statistics..::..PipelineTiming Properties
Statistics..::..PipelineTiming Class See Also Send Feedback

The Statistics..::..PipelineTiming type exposes the following members.

Properties

 | Name | Description
Public property | CallCount | Gets the call count.
Public property | TotalTime | Gets the total time.

See Also

Statistics..::..PipelineTiming Class
Sitecore.Diagnostics Namespace


CallCount Property

[image]

Sitecore 6.4.1 API
Statistics..::..PipelineTiming..::..CallCount Property
Statistics..::..PipelineTiming Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int CallCount { get; }
Visual Basic
Public ReadOnly Property CallCount As Integer
    Get
Visual C++
public:
property int CallCount {
    int get ();
}

Field Value

The call count.

See Also

Statistics..::..PipelineTiming Class
Sitecore.Diagnostics Namespace


TotalTime Property

[image]

Sitecore 6.4.1 API
Statistics..::..PipelineTiming..::..TotalTime Property
Statistics..::..PipelineTiming Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TimeSpan TotalTime { get; }
Visual Basic
Public ReadOnly Property TotalTime As TimeSpan
    Get
Visual C++
public:
property TimeSpan TotalTime {
    TimeSpan get ();
}

Field Value

The total time.

See Also

Statistics..::..PipelineTiming Class
Sitecore.Diagnostics Namespace


Statistics.RenderingData Class

[image]

Sitecore 6.4.1 API
Statistics..::..RenderingData Class
Statistics Class Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RenderingData
Visual Basic
Public Class RenderingData
Visual C++
public ref class RenderingData

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..Statistics..::..RenderingData

See Also

Statistics..::..RenderingData Members
Sitecore.Diagnostics Namespace


Statistics.RenderingData Members

[image] [image]

Sitecore 6.4.1 API
Statistics..::..RenderingData Members
Statistics..::..RenderingData Class Constructors Methods Properties See Also Send Feedback

Statistics
Statistics
Statistics

The Statistics..::..RenderingData type exposes the following members.

Constructors

 | Name | Description
Public method | Statistics..::..RenderingData | Initializes a new instance of the Statistics..::..RenderingData class.

Methods

 | Name | Description
Public method | AddData | Adds the data.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AverageItemsAccessed | Gets the total number of items accessed by the rendering.
Public property | AverageTime | Gets the average time spent by the rendering.
Public property | CacheHitRatio | Gets the cache hit ratio.
Public property | LastRendered | Gets the time of the latest rendering.
Public property | MaxItemsAccessed | Gets the maximum number of items accessed during rendering.
Public property | MaxTime | Gets the slowest time of rendering (in ms.).
Public property | MinItemsAccessed | Gets the minimum number of items accessed during rendering.
Public property | MinTime | Gets the fastest time of rendering (in ms.).
Public property | RenderCount | Gets the total number of times the rendering has been rendered.
Public property | SiteName | Gets the name of the site where the rendering was rendered.
Public property | TotalItemsAccessed | Gets the total number of items accessed by the rendering.
Public property | TotalTime | Gets the total time spent by the rendering.
Public property | TraceName | Gets the trace name of the rendering.
Public property | UsedCache | Gets the number of times the rendering was rendered from cache.

See Also

Statistics..::..RenderingData Class
Sitecore.Diagnostics Namespace


Statistics.RenderingData Constructor

[image]

Sitecore 6.4.1 API
Statistics..::..RenderingData Constructor
Statistics..::..RenderingData Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderingData(
    string traceName,
    string site
)
Visual Basic
Public Sub New ( _
    traceName As String, _
    site As String _
)
Visual C++
public:
RenderingData(
    String^ traceName,
    String^ site
)

Parameters

traceName
Type: System..::..String
The trace name of the rendering.
site
Type: System..::..String
The site.

See Also

Statistics..::..RenderingData Class
Sitecore.Diagnostics Namespace


Statistics.RenderingData Methods

[image] [image]

Sitecore 6.4.1 API
Statistics..::..RenderingData Methods
Statistics..::..RenderingData Class See Also Send Feedback

The Statistics..::..RenderingData type exposes the following members.

Methods

 | Name | Description
Public method | AddData | Adds the data.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Statistics..::..RenderingData Class
Sitecore.Diagnostics Namespace


AddData Method

[image]

Sitecore 6.4.1 API
Statistics..::..RenderingData..::..AddData Method
Statistics..::..RenderingData Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddData(
    double elapsed,
    long itemsAccessed,
    bool usedCache
)
Visual Basic
Public Sub AddData ( _
    elapsed As Double, _
    itemsAccessed As Long, _
    usedCache As Boolean _
)
Visual C++
public:
void AddData(
    double elapsed,
    long long itemsAccessed,
    bool usedCache
)

Parameters

elapsed
Type: System..::..Double
The elapsed time (in ms.).
itemsAccessed
Type: System..::..Int64
The items accessed.
usedCache
Type: System..::..Boolean
if set to true this instance is used cache.

See Also

Statistics..::..RenderingData Class
Sitecore.Diagnostics Namespace


Statistics.RenderingData Properties

[image] [image]

Sitecore 6.4.1 API
Statistics..::..RenderingData Properties
Statistics..::..RenderingData Class See Also Send Feedback

The Statistics..::..RenderingData type exposes the following members.

Properties

 | Name | Description
Public property | AverageItemsAccessed | Gets the total number of items accessed by the rendering.
Public property | AverageTime | Gets the average time spent by the rendering.
Public property | CacheHitRatio | Gets the cache hit ratio.
Public property | LastRendered | Gets the time of the latest rendering.
Public property | MaxItemsAccessed | Gets the maximum number of items accessed during rendering.
Public property | MaxTime | Gets the slowest time of rendering (in ms.).
Public property | MinItemsAccessed | Gets the minimum number of items accessed during rendering.
Public property | MinTime | Gets the fastest time of rendering (in ms.).
Public property | RenderCount | Gets the total number of times the rendering has been rendered.
Public property | SiteName | Gets the name of the site where the rendering was rendered.
Public property | TotalItemsAccessed | Gets the total number of items accessed by the rendering.
Public property | TotalTime | Gets the total time spent by the rendering.
Public property | TraceName | Gets the trace name of the rendering.
Public property | UsedCache | Gets the number of times the rendering was rendered from cache.

See Also

Statistics..::..RenderingData Class
Sitecore.Diagnostics Namespace


AverageItemsAccessed Property

[image]

Sitecore 6.4.1 API
Statistics..::..RenderingData..::..AverageItemsAccessed Property
Statistics..::..RenderingData Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long AverageItemsAccessed { get; }
Visual Basic
Public ReadOnly Property AverageItemsAccessed As Long
    Get
Visual C++
public:
property long long AverageItemsAccessed {
    long long get ();
}

Field Value

The total number of items accessed by the rendering.

See Also

Statistics..::..RenderingData Class
Sitecore.Diagnostics Namespace


AverageTime Property

[image]

Sitecore 6.4.1 API
Statistics..::..RenderingData..::..AverageTime Property
Statistics..::..RenderingData Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TimeSpan AverageTime { get; }
Visual Basic
Public ReadOnly Property AverageTime As TimeSpan
    Get
Visual C++
public:
property TimeSpan AverageTime {
    TimeSpan get ();
}

Field Value

The average time spent by the rendering.

See Also

Statistics..::..RenderingData Class
Sitecore.Diagnostics Namespace


CacheHitRatio Property

[image]

Sitecore 6.4.1 API
Statistics..::..RenderingData..::..CacheHitRatio Property
Statistics..::..RenderingData Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public double CacheHitRatio { get; }
Visual Basic
Public ReadOnly Property CacheHitRatio As Double
    Get
Visual C++
public:
property double CacheHitRatio {
    double get ();
}

Field Value

The cache hit ratio.

See Also

Statistics..::..RenderingData Class
Sitecore.Diagnostics Namespace


LastRendered Property

[image]

Sitecore 6.4.1 API
Statistics..::..RenderingData..::..LastRendered Property
Statistics..::..RenderingData Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime LastRendered { get; }
Visual Basic
Public ReadOnly Property LastRendered As DateTime
    Get
Visual C++
public:
property DateTime LastRendered {
    DateTime get ();
}

Field Value

The time of the latest rendering.

See Also

Statistics..::..RenderingData Class
Sitecore.Diagnostics Namespace


MaxItemsAccessed Property

[image]

Sitecore 6.4.1 API
Statistics..::..RenderingData..::..MaxItemsAccessed Property
Statistics..::..RenderingData Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long MaxItemsAccessed { get; }
Visual Basic
Public ReadOnly Property MaxItemsAccessed As Long
    Get
Visual C++
public:
property long long MaxItemsAccessed {
    long long get ();
}

Field Value

The maximum number of items accessed during rendering.

See Also

Statistics..::..RenderingData Class
Sitecore.Diagnostics Namespace


MaxTime Property

[image]

Sitecore 6.4.1 API
Statistics..::..RenderingData..::..MaxTime Property
Statistics..::..RenderingData Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TimeSpan MaxTime { get; }
Visual Basic
Public ReadOnly Property MaxTime As TimeSpan
    Get
Visual C++
public:
property TimeSpan MaxTime {
    TimeSpan get ();
}

Field Value

The slowest time of rendering (in ms.).

See Also

Statistics..::..RenderingData Class
Sitecore.Diagnostics Namespace


MinItemsAccessed Property

[image]

Sitecore 6.4.1 API
Statistics..::..RenderingData..::..MinItemsAccessed Property
Statistics..::..RenderingData Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long MinItemsAccessed { get; }
Visual Basic
Public ReadOnly Property MinItemsAccessed As Long
    Get
Visual C++
public:
property long long MinItemsAccessed {
    long long get ();
}

Field Value

The minimum number of items accessed during rendering.

See Also

Statistics..::..RenderingData Class
Sitecore.Diagnostics Namespace


MinTime Property

[image]

Sitecore 6.4.1 API
Statistics..::..RenderingData..::..MinTime Property
Statistics..::..RenderingData Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TimeSpan MinTime { get; }
Visual Basic
Public ReadOnly Property MinTime As TimeSpan
    Get
Visual C++
public:
property TimeSpan MinTime {
    TimeSpan get ();
}

Field Value

The fastest time of rendering (in ms.).

See Also

Statistics..::..RenderingData Class
Sitecore.Diagnostics Namespace


RenderCount Property

[image]

Sitecore 6.4.1 API
Statistics..::..RenderingData..::..RenderCount Property
Statistics..::..RenderingData Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int RenderCount { get; }
Visual Basic
Public ReadOnly Property RenderCount As Integer
    Get
Visual C++
public:
property int RenderCount {
    int get ();
}

Field Value

The total number of times the rendering has been rendered.

See Also

Statistics..::..RenderingData Class
Sitecore.Diagnostics Namespace


SiteName Property

[image]

Sitecore 6.4.1 API
Statistics..::..RenderingData..::..SiteName Property
Statistics..::..RenderingData Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string SiteName { get; }
Visual Basic
Public ReadOnly Property SiteName As String
    Get
Visual C++
public:
property String^ SiteName {
    String^ get ();
}

Field Value

The name of the site where the rendering was rendered.

See Also

Statistics..::..RenderingData Class
Sitecore.Diagnostics Namespace


TotalItemsAccessed Property

[image]

Sitecore 6.4.1 API
Statistics..::..RenderingData..::..TotalItemsAccessed Property
Statistics..::..RenderingData Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long TotalItemsAccessed { get; }
Visual Basic
Public ReadOnly Property TotalItemsAccessed As Long
    Get
Visual C++
public:
property long long TotalItemsAccessed {
    long long get ();
}

Field Value

The total number of items accessed by the rendering.

See Also

Statistics..::..RenderingData Class
Sitecore.Diagnostics Namespace


TotalTime Property

[image]

Sitecore 6.4.1 API
Statistics..::..RenderingData..::..TotalTime Property
Statistics..::..RenderingData Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TimeSpan TotalTime { get; }
Visual Basic
Public ReadOnly Property TotalTime As TimeSpan
    Get
Visual C++
public:
property TimeSpan TotalTime {
    TimeSpan get ();
}

Field Value

The total number of items accessed by the rendering.

See Also

Statistics..::..RenderingData Class
Sitecore.Diagnostics Namespace


TraceName Property

[image]

Sitecore 6.4.1 API
Statistics..::..RenderingData..::..TraceName Property
Statistics..::..RenderingData Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string TraceName { get; }
Visual Basic
Public ReadOnly Property TraceName As String
    Get
Visual C++
public:
property String^ TraceName {
    String^ get ();
}

Field Value

The trace name of the rendering.

See Also

Statistics..::..RenderingData Class
Sitecore.Diagnostics Namespace


UsedCache Property

[image]

Sitecore 6.4.1 API
Statistics..::..RenderingData..::..UsedCache Property
Statistics..::..RenderingData Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int UsedCache { get; }
Visual Basic
Public ReadOnly Property UsedCache As Integer
    Get
Visual C++
public:
property int UsedCache {
    int get ();
}

Field Value

The number of times the rendering was rendered from cache.

See Also

Statistics..::..RenderingData Class
Sitecore.Diagnostics Namespace


TextLog Class

[image]

Sitecore 6.4.1 API
TextLog Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class TextLog
Visual Basic
Public Class TextLog
Visual C++
public ref class TextLog

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..TextLog

See Also

TextLog Members
Sitecore.Diagnostics Namespace


TextLog Members

[image] [image]

Sitecore 6.4.1 API
TextLog Members
TextLog Class Constructors Methods Properties See Also Send Feedback

The TextLog type exposes the following members.

Constructors

 | Name | Description
Public method | TextLog | Initializes a new instance of the TextLog class

Methods

 | Name | Description
Public method | AppendError | Appends an error to the log.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Entries | Gets the entries.
Public property | Errors | Gets the error entries.
Public property | Informations | Gets the informtational entries.
Public property | Warnings | Gets the warning entries.

See Also

TextLog Class
Sitecore.Diagnostics Namespace


TextLog Constructor

[image]

Sitecore 6.4.1 API
TextLog Constructor
TextLog Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TextLog()
Visual Basic
Public Sub New
Visual C++
public:
TextLog()

See Also

TextLog Class
Sitecore.Diagnostics Namespace


TextLog Methods

[image] [image]

Sitecore 6.4.1 API
TextLog Methods
TextLog Class See Also Send Feedback

The TextLog type exposes the following members.

Methods

 | Name | Description
Public method | AppendError | Appends an error to the log.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextLog Class
Sitecore.Diagnostics Namespace


TextLog Properties

[image] [image]

Sitecore 6.4.1 API
TextLog Properties
TextLog Class See Also Send Feedback

The TextLog type exposes the following members.

Properties

 | Name | Description
Public property | Entries | Gets the entries.
Public property | Errors | Gets the error entries.
Public property | Informations | Gets the informtational entries.
Public property | Warnings | Gets the warning entries.

See Also

TextLog Class
Sitecore.Diagnostics Namespace


Entries Property

[image]

Sitecore 6.4.1 API
TextLog..::..Entries Property
TextLog Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IEnumerable<TextLogEntry> Entries { get; }
Visual Basic
Public ReadOnly Property Entries As IEnumerable(Of TextLogEntry)
    Get
Visual C++
public:
property IEnumerable<TextLogEntry^>^ Entries {
    IEnumerable<TextLogEntry^>^ get ();
}

Field Value

The entries.

See Also

TextLog Class
Sitecore.Diagnostics Namespace


Errors Property

[image]

Sitecore 6.4.1 API
TextLog..::..Errors Property
TextLog Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IEnumerable<TextLogEntry> Errors { get; }
Visual Basic
Public ReadOnly Property Errors As IEnumerable(Of TextLogEntry)
    Get
Visual C++
public:
property IEnumerable<TextLogEntry^>^ Errors {
    IEnumerable<TextLogEntry^>^ get ();
}

Field Value

The error entries.

See Also

TextLog Class
Sitecore.Diagnostics Namespace


Informations Property

[image]

Sitecore 6.4.1 API
TextLog..::..Informations Property
TextLog Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IEnumerable<TextLogEntry> Informations { get; }
Visual Basic
Public ReadOnly Property Informations As IEnumerable(Of TextLogEntry)
    Get
Visual C++
public:
property IEnumerable<TextLogEntry^>^ Informations {
    IEnumerable<TextLogEntry^>^ get ();
}

Field Value

The error entries.

See Also

TextLog Class
Sitecore.Diagnostics Namespace


Warnings Property

[image]

Sitecore 6.4.1 API
TextLog..::..Warnings Property
TextLog Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IEnumerable<TextLogEntry> Warnings { get; }
Visual Basic
Public ReadOnly Property Warnings As IEnumerable(Of TextLogEntry)
    Get
Visual C++
public:
property IEnumerable<TextLogEntry^>^ Warnings {
    IEnumerable<TextLogEntry^>^ get ();
}

Field Value

The error entries.

See Also

TextLog Class
Sitecore.Diagnostics Namespace


TextLog.Severity Enumeration

[image]

Sitecore 6.4.1 API
TextLog..::..Severity Enumeration
TextLog Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum Severity
Visual Basic
Public Enumeration Severity
Visual C++
public enum class Severity

Members

Member name | Value | Description
Information | 0 | Informational entry.
Warning | 1 | Warning entry.
Error | 2 | Error entry.

See Also

Sitecore.Diagnostics Namespace


TextLogEntry Class

[image]

Sitecore 6.4.1 API
TextLogEntry Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class TextLogEntry
Visual Basic
Public Class TextLogEntry
Visual C++
public ref class TextLogEntry

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..TextLogEntry

See Also

TextLogEntry Members
Sitecore.Diagnostics Namespace


TextLogEntry Members

[image] [image]

Sitecore 6.4.1 API
TextLogEntry Members
TextLogEntry Class Constructors Methods Properties See Also Send Feedback

The TextLogEntry type exposes the following members.

Constructors

 | Name | Description
Public method | TextLogEntry(String, TextLog..::..Severity) | Initializes a new instance of the TextLogEntry class.
Public method | TextLogEntry(String, TextLog..::..Severity, Exception) | Initializes a new instance of the TextLogEntry class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Exception | Gets the exception.
Public property | Message | Gets the message.
Public property | Severity | Gets the severity.

See Also

TextLogEntry Class
Sitecore.Diagnostics Namespace


TextLogEntry Constructor

[image] [image]

Sitecore 6.4.1 API
TextLogEntry Constructor
TextLogEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TextLogEntry(String, TextLog..::..Severity) | Initializes a new instance of the TextLogEntry class.
Public method | TextLogEntry(String, TextLog..::..Severity, Exception) | Initializes a new instance of the TextLogEntry class.

See Also

TextLogEntry Class
TextLogEntry Members
Sitecore.Diagnostics Namespace


TextLogEntry Constructor (String, TextLog.Severity)

[image]

Sitecore 6.4.1 API
TextLogEntry Constructor (String, TextLog..::..Severity)
TextLogEntry Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TextLogEntry(
    string message,
    TextLog..::..Severity severity
)
Visual Basic
Public Sub New ( _
    message As String, _
    severity As TextLog..::..Severity _
)
Visual C++
public:
TextLogEntry(
    String^ message,
    TextLog..::..Severity severity
)

Parameters

message
Type: System..::..String
The message.
severity
Type: Sitecore.Diagnostics..::..TextLog..::..Severity
The severity.

See Also

TextLogEntry Class
TextLogEntry Overload
Sitecore.Diagnostics Namespace


TextLogEntry Constructor (String, TextLog.Severity, Exception)

[image]

Sitecore 6.4.1 API
TextLogEntry Constructor (String, TextLog..::..Severity, Exception)
TextLogEntry Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TextLogEntry(
    string message,
    TextLog..::..Severity severity,
    Exception exception
)
Visual Basic
Public Sub New ( _
    message As String, _
    severity As TextLog..::..Severity, _
    exception As Exception _
)
Visual C++
public:
TextLogEntry(
    String^ message,
    TextLog..::..Severity severity,
    Exception^ exception
)

Parameters

message
Type: System..::..String
The message.
severity
Type: Sitecore.Diagnostics..::..TextLog..::..Severity
The severity.
exception
Type: System..::..Exception
The exception.

See Also

TextLogEntry Class
TextLogEntry Overload
Sitecore.Diagnostics Namespace


TextLogEntry Methods

[image] [image]

Sitecore 6.4.1 API
TextLogEntry Methods
TextLogEntry Class See Also Send Feedback

The TextLogEntry type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextLogEntry Class
Sitecore.Diagnostics Namespace


TextLogEntry Properties

[image] [image]

Sitecore 6.4.1 API
TextLogEntry Properties
TextLogEntry Class See Also Send Feedback

The TextLogEntry type exposes the following members.

Properties

 | Name | Description
Public property | Exception | Gets the exception.
Public property | Message | Gets the message.
Public property | Severity | Gets the severity.

See Also

TextLogEntry Class
Sitecore.Diagnostics Namespace


Exception Property

[image]

Sitecore 6.4.1 API
TextLogEntry..::..Exception Property
TextLogEntry Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Exception Exception { get; }
Visual Basic
Public ReadOnly Property Exception As Exception
    Get
Visual C++
public:
property Exception^ Exception {
    Exception^ get ();
}

Field Value

The exception.

See Also

TextLogEntry Class
Sitecore.Diagnostics Namespace


Severity Property

[image]

Sitecore 6.4.1 API
TextLogEntry..::..Severity Property
TextLogEntry Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TextLog..::..Severity Severity { get; }
Visual Basic
Public ReadOnly Property Severity As TextLog..::..Severity
    Get
Visual C++
public:
property TextLog..::..Severity Severity {
    TextLog..::..Severity get ();
}

Field Value

The severity.

See Also

TextLogEntry Class
Sitecore.Diagnostics Namespace


ThreadError Class

[image]

Sitecore 6.4.1 API
ThreadError Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ThreadError
Visual Basic
Public Class ThreadError
Visual C++
public ref class ThreadError

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..ThreadError

See Also

ThreadError Members
Sitecore.Diagnostics Namespace


ThreadError Members

[image] [image]

Sitecore 6.4.1 API
ThreadError Members
ThreadError Class Constructors Methods Properties See Also Send Feedback

The ThreadError type exposes the following members.

Constructors

 | Name | Description
Public method | ThreadError | Initializes a new instance of the ThreadError class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ErrorText | Gets the error text.
Public property | Time | Gets the time of the error.

See Also

ThreadError Class
Sitecore.Diagnostics Namespace


ThreadError Constructor

[image]

Sitecore 6.4.1 API
ThreadError Constructor
ThreadError Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ThreadError(
    string errorText
)
Visual Basic
Public Sub New ( _
    errorText As String _
)
Visual C++
public:
ThreadError(
    String^ errorText
)

Parameters

errorText
Type: System..::..String
The error text.

See Also

ThreadError Class
Sitecore.Diagnostics Namespace


ThreadError Methods

[image] [image]

Sitecore 6.4.1 API
ThreadError Methods
ThreadError Class See Also Send Feedback

The ThreadError type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ThreadError Class
Sitecore.Diagnostics Namespace


ThreadError Properties

[image] [image]

Sitecore 6.4.1 API
ThreadError Properties
ThreadError Class See Also Send Feedback

The ThreadError type exposes the following members.

Properties

 | Name | Description
Public property | ErrorText | Gets the error text.
Public property | Time | Gets the time of the error.

See Also

ThreadError Class
Sitecore.Diagnostics Namespace


Time Property

[image]

Sitecore 6.4.1 API
ThreadError..::..Time Property
ThreadError Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime Time { get; }
Visual Basic
Public ReadOnly Property Time As DateTime
    Get
Visual C++
public:
property DateTime Time {
    DateTime get ();
}

Field Value

The time.

See Also

ThreadError Class
Sitecore.Diagnostics Namespace


Tracer Class

[image]

Sitecore 6.4.1 API
Tracer Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Tracer
Visual Basic
Public NotInheritable Class Tracer
Visual C++
public ref class Tracer abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..Tracer

See Also

Tracer Members
Sitecore.Diagnostics Namespace


Tracer Methods

[image] [image]

Sitecore 6.4.1 API
Tracer Methods
Tracer Class See Also Send Feedback

The Tracer type exposes the following members.

Methods

Name | Description
Abort | Aborts tracing.
Debug | Outputs the specified debug message.
DebugInfo | Outputs the specified debug information.
EndSession | Ends the session.
Error(Object) | Outputs the specified error message.
Error(Object, Object) | Outputs the specified error message.
Fatal | Outputs the specified fatal message.
GetFormattedTrace()()()() | Gets the formatted trace.
GetFormattedTrace(String) | Gets the formatted trace.
GetReportFileName | Gets the name of the report file.
Info(Object) | Outputs the specified information message.
Info(Object, Object) | Outputs the specified information message.
Render | Renders this instance.
SaveCurrentReport | Saves the current report.
SaveReport | Saves the report.
StartSession | Starts the session.
Warning(Object) | Outputs the specified warning message.
Warning(Object, Object) | Outputs the specified warning message.

See Also

Tracer Class
Sitecore.Diagnostics Namespace


Abort Method

[image]

Sitecore 6.4.1 API
Tracer..::..Abort Method
Tracer Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Abort()
Visual Basic
Public Shared Sub Abort
Visual C++
public:
static void Abort()

See Also

Tracer Class
Sitecore.Diagnostics Namespace


Debug Method

[image]

Sitecore 6.4.1 API
Tracer..::..Debug Method
Tracer Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Debug(
    Object message
)
Visual Basic
Public Shared Sub Debug ( _
    message As Object _
)
Visual C++
public:
static void Debug(
    Object^ message
)

Parameters

message
Type: System..::..Object
The message.

See Also

Tracer Class
Sitecore.Diagnostics Namespace


DebugInfo Method

[image]

Sitecore 6.4.1 API
Tracer..::..DebugInfo Method
Tracer Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void DebugInfo(
    string debugInfoID,
    Packet packet
)
Visual Basic
Public Shared Sub DebugInfo ( _
    debugInfoID As String, _
    packet As Packet _
)
Visual C++
public:
static void DebugInfo(
    String^ debugInfoID,
    Packet^ packet
)

Parameters

debugInfoID
Type: System..::..String
The debug info ID.
packet
Type: Sitecore.Xml..::..Packet
The debug info.

See Also

Tracer Class
Sitecore.Diagnostics Namespace


EndSession Method

[image]

Sitecore 6.4.1 API
Tracer..::..EndSession Method
Tracer Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void EndSession()
Visual Basic
Public Shared Sub EndSession
Visual C++
public:
static void EndSession()

See Also

Tracer Class
Sitecore.Diagnostics Namespace


Error Method

[image] [image]

Sitecore 6.4.1 API
Tracer..::..Error Method
Tracer Class See Also Send Feedback

Overload List

Name | Description
Error(Object) | Outputs the specified error message.
Error(Object, Object) | Outputs the specified error message.

See Also

Tracer Class
Tracer Members
Sitecore.Diagnostics Namespace


Error Method (Object)

[image]

Sitecore 6.4.1 API
Tracer..::..Error Method (Object)
Tracer Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Error(
    Object message
)
Visual Basic
Public Shared Sub Error ( _
    message As Object _
)
Visual C++
public:
static void Error(
    Object^ message
)

Parameters

message
Type: System..::..Object
The message.

See Also

Tracer Class
Error Overload
Sitecore.Diagnostics Namespace


Error Method (Object, Object)

[image]

Sitecore 6.4.1 API
Tracer..::..Error Method (Object, Object)
Tracer Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Error(
    Object message,
    Object details
)
Visual Basic
Public Shared Sub Error ( _
    message As Object, _
    details As Object _
)
Visual C++
public:
static void Error(
    Object^ message,
    Object^ details
)

Parameters

message
Type: System..::..Object
The message.
details
Type: System..::..Object
The details.

See Also

Tracer Class
Error Overload
Sitecore.Diagnostics Namespace


Fatal Method

[image]

Sitecore 6.4.1 API
Tracer..::..Fatal Method
Tracer Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Fatal(
    Object message
)
Visual Basic
Public Shared Sub Fatal ( _
    message As Object _
)
Visual C++
public:
static void Fatal(
    Object^ message
)

Parameters

message
Type: System..::..Object
The message.

See Also

Tracer Class
Sitecore.Diagnostics Namespace


GetFormattedTrace Method

[image] [image]

Sitecore 6.4.1 API
Tracer..::..GetFormattedTrace Method
Tracer Class See Also Send Feedback

Overload List

Name | Description
GetFormattedTrace()()()() | Gets the formatted trace.
GetFormattedTrace(String) | Gets the formatted trace.

See Also

Tracer Class
Tracer Members
Sitecore.Diagnostics Namespace


GetFormattedTrace Method

[image]

Sitecore 6.4.1 API
Tracer..::..GetFormattedTrace Method
Tracer Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetFormattedTrace()
Visual Basic
Public Shared Function GetFormattedTrace As String
Visual C++
public:
static String^ GetFormattedTrace()

Return Value

The get formatted trace.

See Also

Tracer Class
GetFormattedTrace Overload
Sitecore.Diagnostics Namespace


GetFormattedTrace Method (String)

[image]

Sitecore 6.4.1 API
Tracer..::..GetFormattedTrace Method (String)
Tracer Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetFormattedTrace(
    string xslFile
)
Visual Basic
Public Shared Function GetFormattedTrace ( _
    xslFile As String _
) As String
Visual C++
public:
static String^ GetFormattedTrace(
    String^ xslFile
)

Parameters

xslFile
Type: System..::..String
The XSL file.

Return Value

The get formatted trace.

See Also

Tracer Class
GetFormattedTrace Overload
Sitecore.Diagnostics Namespace


GetReportFileName Method

[image]

Sitecore 6.4.1 API
Tracer..::..GetReportFileName Method
Tracer Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetReportFileName()
Visual Basic
Public Shared Function GetReportFileName As String
Visual C++
public:
static String^ GetReportFileName()

Return Value

The get report file name.

See Also

Tracer Class
Sitecore.Diagnostics Namespace


Info Method (Object)

[image]

Sitecore 6.4.1 API
Tracer..::..Info Method (Object)
Tracer Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Info(
    Object message
)
Visual Basic
Public Shared Sub Info ( _
    message As Object _
)
Visual C++
public:
static void Info(
    Object^ message
)

Parameters

message
Type: System..::..Object
The message.

See Also

Tracer Class
Info Overload
Sitecore.Diagnostics Namespace


Info Method (Object, Object)

[image]

Sitecore 6.4.1 API
Tracer..::..Info Method (Object, Object)
Tracer Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Info(
    Object message,
    Object details
)
Visual Basic
Public Shared Sub Info ( _
    message As Object, _
    details As Object _
)
Visual C++
public:
static void Info(
    Object^ message,
    Object^ details
)

Parameters

message
Type: System..::..Object
The message.
details
Type: System..::..Object
The details.

See Also

Tracer Class
Info Overload
Sitecore.Diagnostics Namespace


Render Method

[image]

Sitecore 6.4.1 API
Tracer..::..Render Method
Tracer Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Render()
Visual Basic
Public Shared Sub Render
Visual C++
public:
static void Render()

See Also

Tracer Class
Sitecore.Diagnostics Namespace


SaveCurrentReport Method

[image]

Sitecore 6.4.1 API
Tracer..::..SaveCurrentReport Method
Tracer Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void SaveCurrentReport()
Visual Basic
Public Shared Sub SaveCurrentReport
Visual C++
public:
static void SaveCurrentReport()

See Also

Tracer Class
Sitecore.Diagnostics Namespace


SaveReport Method

[image]

Sitecore 6.4.1 API
Tracer..::..SaveReport Method
Tracer Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void SaveReport(
    string fileName
)
Visual Basic
Public Shared Sub SaveReport ( _
    fileName As String _
)
Visual C++
public:
static void SaveReport(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
Name of the file.

See Also

Tracer Class
Sitecore.Diagnostics Namespace


StartSession Method

[image]

Sitecore 6.4.1 API
Tracer..::..StartSession Method
Tracer Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void StartSession()
Visual Basic
Public Shared Sub StartSession
Visual C++
public:
static void StartSession()

See Also

Tracer Class
Sitecore.Diagnostics Namespace


Warning Method

[image] [image]

Sitecore 6.4.1 API
Tracer..::..Warning Method
Tracer Class See Also Send Feedback

Overload List

Name | Description
Warning(Object) | Outputs the specified warning message.
Warning(Object, Object) | Outputs the specified warning message.

See Also

Tracer Class
Tracer Members
Sitecore.Diagnostics Namespace


Warning Method (Object)

[image]

Sitecore 6.4.1 API
Tracer..::..Warning Method (Object)
Tracer Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Warning(
    Object message
)
Visual Basic
Public Shared Sub Warning ( _
    message As Object _
)
Visual C++
public:
static void Warning(
    Object^ message
)

Parameters

message
Type: System..::..Object
The message.

See Also

Tracer Class
Warning Overload
Sitecore.Diagnostics Namespace


Warning Method (Object, Object)

[image]

Sitecore 6.4.1 API
Tracer..::..Warning Method (Object, Object)
Tracer Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Warning(
    Object message,
    Object details
)
Visual Basic
Public Shared Sub Warning ( _
    message As Object, _
    details As Object _
)
Visual C++
public:
static void Warning(
    Object^ message,
    Object^ details
)

Parameters

message
Type: System..::..Object
The message.
details
Type: System..::..Object
The details.

See Also

Tracer Class
Warning Overload
Sitecore.Diagnostics Namespace


Tracer Properties

[image] [image]

Sitecore 6.4.1 API
Tracer Properties
Tracer Class See Also Send Feedback

The Tracer type exposes the following members.

Properties

Name | Description
Indent | Gets or sets the indent.
IsActive | Gets a value indicating whether this instance is active.
RenderOnEndSession | Gets or sets a value indicating whether the Tracer renders on end session.
TotalTime | Gets the total time.

See Also

Tracer Class
Sitecore.Diagnostics Namespace


Indent Property

[image]

Sitecore 6.4.1 API
Tracer..::..Indent Property
Tracer Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int Indent { get; set; }
Visual Basic
Public Shared Property Indent As Integer
    Get
    Set
Visual C++
public:
static property int Indent {
    int get ();
    void set (int value);
}

Field Value

The indent.

See Also

Tracer Class
Sitecore.Diagnostics Namespace


IsActive Property

[image]

Sitecore 6.4.1 API
Tracer..::..IsActive Property
Tracer Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsActive { get; }
Visual Basic
Public Shared ReadOnly Property IsActive As Boolean
    Get
Visual C++
public:
static property bool IsActive {
    bool get ();
}

Field Value

true if this instance is active; otherwise, false.

See Also

Tracer Class
Sitecore.Diagnostics Namespace


RenderOnEndSession Property

[image]

Sitecore 6.4.1 API
Tracer..::..RenderOnEndSession Property
Tracer Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool RenderOnEndSession { get; set; }
Visual Basic
Public Shared Property RenderOnEndSession As Boolean
    Get
    Set
Visual C++
public:
static property bool RenderOnEndSession {
    bool get ();
    void set (bool value);
}

Field Value

true if the Tracer renders on end session; otherwise, false.

See Also

Tracer Class
Sitecore.Diagnostics Namespace


TotalTime Property

[image]

Sitecore 6.4.1 API
Tracer..::..TotalTime Property
Tracer Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TimeSpan TotalTime { get; }
Visual Basic
Public Shared ReadOnly Property TotalTime As TimeSpan
    Get
Visual C++
public:
static property TimeSpan TotalTime {
    TimeSpan get ();
}

Field Value

The total time.

See Also

Tracer Class
Sitecore.Diagnostics Namespace


Tracer.Worker Class

[image]

Sitecore 6.4.1 API
Tracer..::..Worker Class
Tracer Class Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Worker : DiagnosticWorker
Visual Basic
Public Class Worker _
    Inherits DiagnosticWorker
Visual C++
public ref class Worker : public DiagnosticWorker

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..DiagnosticWorker
Sitecore.Diagnostics..::..Tracer..::..Worker

See Also

Tracer..::..Worker Members
Sitecore.Diagnostics Namespace


Tracer.Worker Members

[image] [image]

Sitecore 6.4.1 API
Tracer..::..Worker Members
Tracer..::..Worker Class Constructors Methods Properties See Also Send Feedback

Represents the Tracer.

The Tracer..::..Worker type exposes the following members.

Constructors

 | Name | Description
Public method | Tracer..::..Worker | Initializes a new instance of the Tracer..::..Worker class.

Methods

 | Name | Description
Public method | Add(Object, String) | Adds the specified message.
Public method | Add(Object, Object, String) | Adds the specified message.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetReportFileName | Gets the name of the report file.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveReport | Saves the report. (Inherited from DiagnosticWorker.)
Protected method | StartReport | Starts the report. (Inherited from DiagnosticWorker.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Indent | Gets or sets the indent.
Public property | Name | Gets the name. (Inherited from DiagnosticWorker.)
Public property | Packet | Gets the packet. (Inherited from DiagnosticWorker.)
Public property | RenderOnEndSession | Gets or sets a value indicating whether the Tracer..::..Worker renders the on end session.
Public property | TotalTime | Gets the total time.

See Also

Tracer..::..Worker Class
Sitecore.Diagnostics Namespace


Tracer.Worker Constructor

[image]

Sitecore 6.4.1 API
Tracer..::..Worker Constructor
Tracer..::..Worker Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Worker()
Visual Basic
Public Sub New
Visual C++
public:
Worker()

See Also

Tracer..::..Worker Class
Sitecore.Diagnostics Namespace


Tracer.Worker Methods

[image] [image]

Sitecore 6.4.1 API
Tracer..::..Worker Methods
Tracer..::..Worker Class See Also Send Feedback

The Tracer..::..Worker type exposes the following members.

Methods

 | Name | Description
Public method | Add(Object, String) | Adds the specified message.
Public method | Add(Object, Object, String) | Adds the specified message.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetReportFileName | Gets the name of the report file.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveReport | Saves the report. (Inherited from DiagnosticWorker.)
Protected method | StartReport | Starts the report. (Inherited from DiagnosticWorker.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Tracer..::..Worker Class
Sitecore.Diagnostics Namespace


Add Method (Object, String)

[image]

Sitecore 6.4.1 API
Tracer..::..Worker..::..Add Method (Object, String)
Tracer..::..Worker Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public XmlNode Add(
    Object message,
    string elementName
)
Visual Basic
Public Function Add ( _
    message As Object, _
    elementName As String _
) As XmlNode
Visual C++
public:
XmlNode^ Add(
    Object^ message,
    String^ elementName
)

Parameters

message
Type: System..::..Object
The message.
elementName
Type: System..::..String
Name of the element.

Return Value

Added node.

See Also

Tracer..::..Worker Class
Add Overload
Sitecore.Diagnostics Namespace


Add Method (Object, Object, String)

[image]

Sitecore 6.4.1 API
Tracer..::..Worker..::..Add Method (Object, Object, String)
Tracer..::..Worker Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public XmlNode Add(
    Object message,
    Object details,
    string elementName
)
Visual Basic
Public Function Add ( _
    message As Object, _
    details As Object, _
    elementName As String _
) As XmlNode
Visual C++
public:
XmlNode^ Add(
    Object^ message,
    Object^ details,
    String^ elementName
)

Parameters

message
Type: System..::..Object
The message.
details
Type: System..::..Object
The details.
elementName
Type: System..::..String
Name of the element.

Return Value

Added node.

See Also

Tracer..::..Worker Class
Add Overload
Sitecore.Diagnostics Namespace


GetReportFileName Method

[image]

Sitecore 6.4.1 API
Tracer..::..Worker..::..GetReportFileName Method
Tracer..::..Worker Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetReportFileName()
Visual Basic
Public Shared Function GetReportFileName As String
Visual C++
public:
static String^ GetReportFileName()

Return Value

The get report file name.

See Also

Tracer..::..Worker Class
Sitecore.Diagnostics Namespace


Tracer.Worker Properties

[image] [image]

Sitecore 6.4.1 API
Tracer..::..Worker Properties
Tracer..::..Worker Class See Also Send Feedback

The Tracer..::..Worker type exposes the following members.

Properties

 | Name | Description
Public property | Indent | Gets or sets the indent.
Public property | Name | Gets the name. (Inherited from DiagnosticWorker.)
Public property | Packet | Gets the packet. (Inherited from DiagnosticWorker.)
Public property | RenderOnEndSession | Gets or sets a value indicating whether the Tracer..::..Worker renders the on end session.
Public property | TotalTime | Gets the total time.

See Also

Tracer..::..Worker Class
Sitecore.Diagnostics Namespace


Indent Property

[image]

Sitecore 6.4.1 API
Tracer..::..Worker..::..Indent Property
Tracer..::..Worker Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Indent { get; set; }
Visual Basic
Public Property Indent As Integer
    Get
    Set
Visual C++
public:
property int Indent {
    int get ();
    void set (int value);
}

Field Value

The indent.

See Also

Tracer..::..Worker Class
Sitecore.Diagnostics Namespace


RenderOnEndSession Property

[image]

Sitecore 6.4.1 API
Tracer..::..Worker..::..RenderOnEndSession Property
Tracer..::..Worker Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool RenderOnEndSession { get; set; }
Visual Basic
Public Property RenderOnEndSession As Boolean
    Get
    Set
Visual C++
public:
property bool RenderOnEndSession {
    bool get ();
    void set (bool value);
}

Field Value

true if the Tracer..::..Worker renders the on end session; otherwise, false.

See Also

Tracer..::..Worker Class
Sitecore.Diagnostics Namespace


TotalTime Property

[image]

Sitecore 6.4.1 API
Tracer..::..Worker..::..TotalTime Property
Tracer..::..Worker Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TimeSpan TotalTime { get; }
Visual Basic
Public ReadOnly Property TotalTime As TimeSpan
    Get
Visual C++
public:
property TimeSpan TotalTime {
    TimeSpan get ();
}

Field Value

The total time.

See Also

Tracer..::..Worker Class
Sitecore.Diagnostics Namespace


UnitTester Class

[image]

Sitecore 6.4.1 API
UnitTester Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class UnitTester
Visual Basic
Public Class UnitTester
Visual C++
public ref class UnitTester

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..UnitTester

See Also

UnitTester Members
Sitecore.Diagnostics Namespace


UnitTester Members

[image] [image]

Sitecore 6.4.1 API
UnitTester Members
UnitTester Class Constructors Methods Properties See Also Send Feedback

The UnitTester type exposes the following members.

Constructors

 | Name | Description
Public method | UnitTester(Page) | Initializes a new instance of the UnitTester class.
Public method | UnitTester(Page, Boolean) | Initializes a new instance of the UnitTester class.

Methods

 | Name | Description
Public method | EndSection | Ends the section.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Initializes this instance.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Out | Write message to output
Public method | ShowStatistics | Show statistics
Public method | StartSection(String) | Starts the section.
Public method | StartSection(String, Boolean) | Starts the section.
Public method | StartTest | Starts a named test.
Public method | Test(Boolean, String) | Tests the specified condition.
Public method | Test(Boolean, String, Boolean) | Tests the specified condition.
Public method | Test(Boolean, String, String) | Tests the specified condition.
Public method | Test(Boolean, String, String, Boolean) | Tests the specified condition.
Public method | TestAssigned | Tests the assigned.
Public method | TestBool | Tests the bool.
Public method | TestCount(Int32, Int32, String) | Tests the count.
Public method | TestCount(Int32, Int32, String, String) | Tests the count.
Public method | TestEnum | Tests the enum.
Public method | TestHead | Tests the head.
Public method | TestIndex | Tests the index.
Public method | TestIterCount(String, Int32, XPathNavigator) | Tests the iter count.
Public method | TestIterCount(String, Int32, XPathNavigator, Int32) | Tests the iter count.
Public method | TestString | Tests the string.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Silent | Gets or sets a value indicating whether this UnitTester is silent.

See Also

UnitTester Class
Sitecore.Diagnostics Namespace


UnitTester Constructor

[image] [image]

Sitecore 6.4.1 API
UnitTester Constructor
UnitTester Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UnitTester(Page) | Initializes a new instance of the UnitTester class.
Public method | UnitTester(Page, Boolean) | Initializes a new instance of the UnitTester class.

See Also

UnitTester Class
UnitTester Members
Sitecore.Diagnostics Namespace


UnitTester Constructor (Page)

[image]

Sitecore 6.4.1 API
UnitTester Constructor (Page)
UnitTester Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UnitTester(
    Page page
)
Visual Basic
Public Sub New ( _
    page As Page _
)
Visual C++
public:
UnitTester(
    Page^ page
)

Parameters

page
Type: System.Web.UI..::..Page
The m_page.

See Also

UnitTester Class
UnitTester Overload
Sitecore.Diagnostics Namespace


UnitTester Methods

[image] [image]

Sitecore 6.4.1 API
UnitTester Methods
UnitTester Class See Also Send Feedback

The UnitTester type exposes the following members.

Methods

 | Name | Description
Public method | EndSection | Ends the section.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Initializes this instance.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Out | Write message to output
Public method | ShowStatistics | Show statistics
Public method | StartSection(String) | Starts the section.
Public method | StartSection(String, Boolean) | Starts the section.
Public method | StartTest | Starts a named test.
Public method | Test(Boolean, String) | Tests the specified condition.
Public method | Test(Boolean, String, Boolean) | Tests the specified condition.
Public method | Test(Boolean, String, String) | Tests the specified condition.
Public method | Test(Boolean, String, String, Boolean) | Tests the specified condition.
Public method | TestAssigned | Tests the assigned.
Public method | TestBool | Tests the bool.
Public method | TestCount(Int32, Int32, String) | Tests the count.
Public method | TestCount(Int32, Int32, String, String) | Tests the count.
Public method | TestEnum | Tests the enum.
Public method | TestHead | Tests the head.
Public method | TestIndex | Tests the index.
Public method | TestIterCount(String, Int32, XPathNavigator) | Tests the iter count.
Public method | TestIterCount(String, Int32, XPathNavigator, Int32) | Tests the iter count.
Public method | TestString | Tests the string.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UnitTester Class
Sitecore.Diagnostics Namespace


EndSection Method

[image]

Sitecore 6.4.1 API
UnitTester..::..EndSection Method
UnitTester Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void EndSection(
    Page page
)
Visual Basic
Public Sub EndSection ( _
    page As Page _
)
Visual C++
public:
void EndSection(
    Page^ page
)

Parameters

page
Type: System.Web.UI..::..Page
The m_page.

See Also

UnitTester Class
Sitecore.Diagnostics Namespace


Init Method

[image]

Sitecore 6.4.1 API
UnitTester..::..Init Method
UnitTester Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Init()
Visual Basic
Public Sub Init
Visual C++
public:
void Init()

See Also

UnitTester Class
Sitecore.Diagnostics Namespace


Out Method

[image]

Sitecore 6.4.1 API
UnitTester..::..Out Method
UnitTester Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Out(
    string message
)
Visual Basic
Public Sub Out ( _
    message As String _
)
Visual C++
public:
void Out(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

UnitTester Class
Sitecore.Diagnostics Namespace


StartSection Method

[image] [image]

Sitecore 6.4.1 API
UnitTester..::..StartSection Method
UnitTester Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StartSection(String) | Starts the section.
Public method | StartSection(String, Boolean) | Starts the section.

See Also

UnitTester Class
UnitTester Members
Sitecore.Diagnostics Namespace


StartSection Method (String)

[image]

Sitecore 6.4.1 API
UnitTester..::..StartSection Method (String)
UnitTester Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void StartSection(
    string description
)
Visual Basic
Public Sub StartSection ( _
    description As String _
)
Visual C++
public:
void StartSection(
    String^ description
)

Parameters

description
Type: System..::..String
The description.

See Also

UnitTester Class
StartSection Overload
Sitecore.Diagnostics Namespace


StartSection Method (String, Boolean)

[image]

Sitecore 6.4.1 API
UnitTester..::..StartSection Method (String, Boolean)
UnitTester Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void StartSection(
    string description,
    bool timing
)
Visual Basic
Public Sub StartSection ( _
    description As String, _
    timing As Boolean _
)
Visual C++
public:
void StartSection(
    String^ description,
    bool timing
)

Parameters

description
Type: System..::..String
The description.
timing
Type: System..::..Boolean
if set to true this instance is timing.

See Also

UnitTester Class
StartSection Overload
Sitecore.Diagnostics Namespace


StartTest Method

[image]

Sitecore 6.4.1 API
UnitTester..::..StartTest Method
UnitTester Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void StartTest(
    string description
)
Visual Basic
Public Sub StartTest ( _
    description As String _
)
Visual C++
public:
void StartTest(
    String^ description
)

Parameters

description
Type: System..::..String
The description.

See Also

UnitTester Class
Sitecore.Diagnostics Namespace


Test Method

[image] [image]

Sitecore 6.4.1 API
UnitTester..::..Test Method
UnitTester Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Test(Boolean, String) | Tests the specified condition.
Public method | Test(Boolean, String, Boolean) | Tests the specified condition.
Public method | Test(Boolean, String, String) | Tests the specified condition.
Public method | Test(Boolean, String, String, Boolean) | Tests the specified condition.

See Also

UnitTester Class
UnitTester Members
Sitecore.Diagnostics Namespace


Test Method (Boolean, String)

[image]

Sitecore 6.4.1 API
UnitTester..::..Test Method (Boolean, String)
UnitTester Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Test(
    bool condition,
    string description
)
Visual Basic
Public Sub Test ( _
    condition As Boolean, _
    description As String _
)
Visual C++
public:
void Test(
    bool condition,
    String^ description
)

Parameters

condition
Type: System..::..Boolean
if set to true this instance is condition.
description
Type: System..::..String
The description.

See Also

UnitTester Class
Test Overload
Sitecore.Diagnostics Namespace


Test Method (Boolean, String, Boolean)

[image]

Sitecore 6.4.1 API
UnitTester..::..Test Method (Boolean, String, Boolean)
UnitTester Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Test(
    bool condition,
    string description,
    bool fatal
)
Visual Basic
Public Sub Test ( _
    condition As Boolean, _
    description As String, _
    fatal As Boolean _
)
Visual C++
public:
void Test(
    bool condition,
    String^ description,
    bool fatal
)

Parameters

condition
Type: System..::..Boolean
if set to true this instance is condition.
description
Type: System..::..String
The description.
fatal
Type: System..::..Boolean
if set to true this instance is fatal.

See Also

UnitTester Class
Test Overload
Sitecore.Diagnostics Namespace


Test Method (Boolean, String, String)

[image]

Sitecore 6.4.1 API
UnitTester..::..Test Method (Boolean, String, String)
UnitTester Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Test(
    bool condition,
    string description,
    string timing
)
Visual Basic
Public Sub Test ( _
    condition As Boolean, _
    description As String, _
    timing As String _
)
Visual C++
public:
void Test(
    bool condition,
    String^ description,
    String^ timing
)

Parameters

condition
Type: System..::..Boolean
if set to true this instance is condition.
description
Type: System..::..String
The description.
timing
Type: System..::..String
The timing.

See Also

UnitTester Class
Test Overload
Sitecore.Diagnostics Namespace


TestAssigned Method

[image]

Sitecore 6.4.1 API
UnitTester..::..TestAssigned Method
UnitTester Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void TestAssigned(
    Object obj,
    bool expected,
    string description,
    bool fatal
)
Visual Basic
Public Sub TestAssigned ( _
    obj As Object, _
    expected As Boolean, _
    description As String, _
    fatal As Boolean _
)
Visual C++
public:
void TestAssigned(
    Object^ obj,
    bool expected,
    String^ description,
    bool fatal
)

Parameters

obj
Type: System..::..Object
The object.
expected
Type: System..::..Boolean
if set to true this instance is expected.
description
Type: System..::..String
The description.
fatal
Type: System..::..Boolean
if set to true this instance is fatal.

See Also

UnitTester Class
Sitecore.Diagnostics Namespace


TestBool Method

[image]

Sitecore 6.4.1 API
UnitTester..::..TestBool Method
UnitTester Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void TestBool(
    bool value,
    bool expected,
    string description
)
Visual Basic
Public Sub TestBool ( _
    value As Boolean, _
    expected As Boolean, _
    description As String _
)
Visual C++
public:
void TestBool(
    bool value,
    bool expected,
    String^ description
)

Parameters

value
Type: System..::..Boolean
if set to true this instance is _value.
expected
Type: System..::..Boolean
if set to true this instance is expected.
description
Type: System..::..String
The description.

See Also

UnitTester Class
Sitecore.Diagnostics Namespace


TestCount Method

[image] [image]

Sitecore 6.4.1 API
UnitTester..::..TestCount Method
UnitTester Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TestCount(Int32, Int32, String) | Tests the count.
Public method | TestCount(Int32, Int32, String, String) | Tests the count.

See Also

UnitTester Class
UnitTester Members
Sitecore.Diagnostics Namespace


TestCount Method (Int32, Int32, String)

[image]

Sitecore 6.4.1 API
UnitTester..::..TestCount Method (Int32, Int32, String)
UnitTester Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void TestCount(
    int count,
    int expected,
    string description
)
Visual Basic
Public Sub TestCount ( _
    count As Integer, _
    expected As Integer, _
    description As String _
)
Visual C++
public:
void TestCount(
    int count,
    int expected,
    String^ description
)

Parameters

count
Type: System..::..Int32
The count.
expected
Type: System..::..Int32
The expected.
description
Type: System..::..String
The description.

See Also

UnitTester Class
TestCount Overload
Sitecore.Diagnostics Namespace


TestCount Method (Int32, Int32, String, String)

[image]

Sitecore 6.4.1 API
UnitTester..::..TestCount Method (Int32, Int32, String, String)
UnitTester Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void TestCount(
    int count,
    int expected,
    string description,
    string timing
)
Visual Basic
Public Sub TestCount ( _
    count As Integer, _
    expected As Integer, _
    description As String, _
    timing As String _
)
Visual C++
public:
void TestCount(
    int count,
    int expected,
    String^ description,
    String^ timing
)

Parameters

count
Type: System..::..Int32
The count.
expected
Type: System..::..Int32
The expected.
description
Type: System..::..String
The description.
timing
Type: System..::..String
The timing.

See Also

UnitTester Class
TestCount Overload
Sitecore.Diagnostics Namespace


TestEnum Method

[image]

Sitecore 6.4.1 API
UnitTester..::..TestEnum Method
UnitTester Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void TestEnum(
    Object value,
    Object expected,
    string description
)
Visual Basic
Public Sub TestEnum ( _
    value As Object, _
    expected As Object, _
    description As String _
)
Visual C++
public:
void TestEnum(
    Object^ value,
    Object^ expected,
    String^ description
)

Parameters

value
Type: System..::..Object
The _value.
expected
Type: System..::..Object
The expected.
description
Type: System..::..String
The description.

See Also

UnitTester Class
Sitecore.Diagnostics Namespace


TestIndex Method

[image]

Sitecore 6.4.1 API
UnitTester..::..TestIndex Method
UnitTester Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void TestIndex(
    int index,
    int expected,
    string description
)
Visual Basic
Public Sub TestIndex ( _
    index As Integer, _
    expected As Integer, _
    description As String _
)
Visual C++
public:
void TestIndex(
    int index,
    int expected,
    String^ description
)

Parameters

index
Type: System..::..Int32
The index.
expected
Type: System..::..Int32
The expected.
description
Type: System..::..String
The description.

See Also

UnitTester Class
Sitecore.Diagnostics Namespace


TestIterCount Method

[image] [image]

Sitecore 6.4.1 API
UnitTester..::..TestIterCount Method
UnitTester Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TestIterCount(String, Int32, XPathNavigator) | Tests the iter count.
Public method | TestIterCount(String, Int32, XPathNavigator, Int32) | Tests the iter count.

See Also

UnitTester Class
UnitTester Members
Sitecore.Diagnostics Namespace


TestIterCount Method (String, Int32, XPathNavigator, Int32)

[image]

Sitecore 6.4.1 API
UnitTester..::..TestIterCount Method (String, Int32, XPathNavigator, Int32)
UnitTester Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void TestIterCount(
    string xpath,
    int expected,
    XPathNavigator nav,
    int iterations
)
Visual Basic
Public Sub TestIterCount ( _
    xpath As String, _
    expected As Integer, _
    nav As XPathNavigator, _
    iterations As Integer _
)
Visual C++
public:
void TestIterCount(
    String^ xpath,
    int expected,
    XPathNavigator^ nav,
    int iterations
)

Parameters

xpath
Type: System..::..String
The xpath.
expected
Type: System..::..Int32
The expected.
nav
Type: System.Xml.XPath..::..XPathNavigator
The nav.
iterations
Type: System..::..Int32
The iterations.

See Also

UnitTester Class
TestIterCount Overload
Sitecore.Diagnostics Namespace


TestString Method

[image]

Sitecore 6.4.1 API
UnitTester..::..TestString Method
UnitTester Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void TestString(
    string value,
    string expected,
    string description
)
Visual Basic
Public Sub TestString ( _
    value As String, _
    expected As String, _
    description As String _
)
Visual C++
public:
void TestString(
    String^ value,
    String^ expected,
    String^ description
)

Parameters

value
Type: System..::..String
The _value.
expected
Type: System..::..String
The expected.
description
Type: System..::..String
The description.

See Also

UnitTester Class
Sitecore.Diagnostics Namespace


UnitTester Properties

[image] [image]

Sitecore 6.4.1 API
UnitTester Properties
UnitTester Class See Also Send Feedback

The UnitTester type exposes the following members.

Properties

 | Name | Description
Public property | Silent | Gets or sets a value indicating whether this UnitTester is silent.

See Also

UnitTester Class
Sitecore.Diagnostics Namespace


Silent Property

[image]

Sitecore 6.4.1 API
UnitTester..::..Silent Property
UnitTester Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Silent { get; set; }
Visual Basic
Public Property Silent As Boolean
    Get
    Set
Visual C++
public:
property bool Silent {
    bool get ();
    void set (bool value);
}

Field Value

true if silent; otherwise, false.

See Also

UnitTester Class
Sitecore.Diagnostics Namespace


WebDAV Class

[image]

Sitecore 6.4.1 API
WebDAV Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class WebDAV
Visual Basic
Public NotInheritable Class WebDAV
Visual C++
public ref class WebDAV abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics..::..WebDAV

See Also

WebDAV Members
Sitecore.Diagnostics Namespace


WebDAV Members

[image] [image]

Sitecore 6.4.1 API
WebDAV Members
WebDAV Class Properties See Also Send Feedback

The WebDAV type exposes the following members.

Properties

Name | Description
Log | Gets the logger object.

See Also

WebDAV Class
Sitecore.Diagnostics Namespace


WebDAV Properties

[image] [image]

Sitecore 6.4.1 API
WebDAV Properties
WebDAV Class See Also Send Feedback

The WebDAV type exposes the following members.

Properties

Name | Description
Log | Gets the logger object.

See Also

WebDAV Class
Sitecore.Diagnostics Namespace


Log Property

[image]

Sitecore 6.4.1 API
WebDAV..::..Log Property
WebDAV Class See Also Send Feedback

Namespace: Sitecore.Diagnostics
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ILog Log { get; }
Visual Basic
Public Shared ReadOnly Property Log As ILog
    Get
Visual C++
public:
static property ILog^ Log {
    ILog^ get ();
}

Field Value

The logger.

See Also

WebDAV Class
Sitecore.Diagnostics Namespace


Sitecore.Diagnostics.Events Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Diagnostics.Events Namespace
Send Feedback

Interfaces

 | Interface | Description
Public interface | IEventHandler | Interface for general event handlers.
Public interface | IExceptionEventHandler | Interface for exception event handlers.
Public interface | IItemEventHandler | Interface for item event handlers.
Public interface | IMediaEventHandler | Interface for media event handlers.
Public interface | IPublishingEventHandler | Interface for publishing event handler.
Public interface | ITraceEventHandler | Interface for trace event handlers.


IEventHandler Interface

[image]

Sitecore 6.4.1 API
IEventHandler Interface
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IEventHandler
Visual Basic
Public Interface IEventHandler
Visual C++
public interface class IEventHandler

See Also

IEventHandler Members
Sitecore.Diagnostics.Events Namespace


IEventHandler Members

[image] [image]

Sitecore 6.4.1 API
IEventHandler Members
IEventHandler Interface Methods See Also Send Feedback

The IEventHandler type exposes the following members.

Methods

 | Name | Description
Public method | HandleEvent | Handle an event

See Also

IEventHandler Interface
Sitecore.Diagnostics.Events Namespace


IEventHandler Methods

[image] [image]

Sitecore 6.4.1 API
IEventHandler Methods
IEventHandler Interface See Also Send Feedback

The IEventHandler type exposes the following members.

Methods

 | Name | Description
Public method | HandleEvent | Handle an event

See Also

IEventHandler Interface
Sitecore.Diagnostics.Events Namespace


HandleEvent Method

[image]

Sitecore 6.4.1 API
IEventHandler..::..HandleEvent Method
IEventHandler Interface See Also Send Feedback

Namespace: Sitecore.Diagnostics.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void HandleEvent(
    string name,
    Hashtable additionalInfo,
    NameValueCollection configSettings
)
Visual Basic
Sub HandleEvent ( _
    name As String, _
    additionalInfo As Hashtable, _
    configSettings As NameValueCollection _
)
Visual C++
void HandleEvent(
    String^ name,
    Hashtable^ additionalInfo,
    NameValueCollection^ configSettings
)

Parameters

name
Type: System..::..String
The name.
additionalInfo
Type: System.Collections..::..Hashtable
The additional info.
configSettings
Type: System.Collections.Specialized..::..NameValueCollection
The config settings.

See Also

IEventHandler Interface
Sitecore.Diagnostics.Events Namespace


IExceptionEventHandler Interface

[image]

Sitecore 6.4.1 API
IExceptionEventHandler Interface
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IExceptionEventHandler
Visual Basic
Public Interface IExceptionEventHandler
Visual C++
public interface class IExceptionEventHandler

See Also

IExceptionEventHandler Members
Sitecore.Diagnostics.Events Namespace


IExceptionEventHandler Members

[image] [image]

Sitecore 6.4.1 API
IExceptionEventHandler Members
IExceptionEventHandler Interface Methods See Also Send Feedback

The IExceptionEventHandler type exposes the following members.

Methods

 | Name | Description
Public method | HandleException | Handles an exception.

See Also

IExceptionEventHandler Interface
Sitecore.Diagnostics.Events Namespace


IExceptionEventHandler Methods

[image] [image]

Sitecore 6.4.1 API
IExceptionEventHandler Methods
IExceptionEventHandler Interface See Also Send Feedback

The IExceptionEventHandler type exposes the following members.

Methods

 | Name | Description
Public method | HandleException | Handles an exception.

See Also

IExceptionEventHandler Interface
Sitecore.Diagnostics.Events Namespace


HandleException Method

[image]

Sitecore 6.4.1 API
IExceptionEventHandler..::..HandleException Method
IExceptionEventHandler Interface See Also Send Feedback

Namespace: Sitecore.Diagnostics.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void HandleException(
    Exception ex,
    Hashtable additionalInfo,
    NameValueCollection configSettings
)
Visual Basic
Sub HandleException ( _
    ex As Exception, _
    additionalInfo As Hashtable, _
    configSettings As NameValueCollection _
)
Visual C++
void HandleException(
    Exception^ ex,
    Hashtable^ additionalInfo,
    NameValueCollection^ configSettings
)

Parameters

ex
Type: System..::..Exception
The ex.
additionalInfo
Type: System.Collections..::..Hashtable
The additional info.
configSettings
Type: System.Collections.Specialized..::..NameValueCollection
The config settings.

See Also

IExceptionEventHandler Interface
Sitecore.Diagnostics.Events Namespace


IItemEventHandler Interface

[image]

Sitecore 6.4.1 API
IItemEventHandler Interface
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IItemEventHandler
Visual Basic
Public Interface IItemEventHandler
Visual C++
public interface class IItemEventHandler

See Also

IItemEventHandler Members
Sitecore.Diagnostics.Events Namespace


IItemEventHandler Members

[image] [image]

Sitecore 6.4.1 API
IItemEventHandler Members
IItemEventHandler Interface Methods See Also Send Feedback

The IItemEventHandler type exposes the following members.

Methods

 | Name | Description
Public method | HandleBeforeClientSave | An item is being saved by the client (ie. via a xml fragment)
Public method | HandleCopied | An item has been copied
Public method | HandleCreated | An item has been created
Public method | HandleDeleted | An item has been deleted
Public method | HandleMoved | An item has been moved
Public method | HandleRenamed | An item has been renamed
Public method | HandleSaved | An item has been saved

See Also

IItemEventHandler Interface
Sitecore.Diagnostics.Events Namespace


IItemEventHandler Methods

[image] [image]

Sitecore 6.4.1 API
IItemEventHandler Methods
IItemEventHandler Interface See Also Send Feedback

The IItemEventHandler type exposes the following members.

Methods

 | Name | Description
Public method | HandleBeforeClientSave | An item is being saved by the client (ie. via a xml fragment)
Public method | HandleCopied | An item has been copied
Public method | HandleCreated | An item has been created
Public method | HandleDeleted | An item has been deleted
Public method | HandleMoved | An item has been moved
Public method | HandleRenamed | An item has been renamed
Public method | HandleSaved | An item has been saved

See Also

IItemEventHandler Interface
Sitecore.Diagnostics.Events Namespace


HandleBeforeClientSave Method

[image]

Sitecore 6.4.1 API
IItemEventHandler..::..HandleBeforeClientSave Method
IItemEventHandler Interface See Also Send Feedback

Namespace: Sitecore.Diagnostics.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void HandleBeforeClientSave(
    XmlNode dataNode,
    NameValueCollection configSettings
)
Visual Basic
Sub HandleBeforeClientSave ( _
    dataNode As XmlNode, _
    configSettings As NameValueCollection _
)
Visual C++
void HandleBeforeClientSave(
    XmlNode^ dataNode,
    NameValueCollection^ configSettings
)

Parameters

dataNode
Type: System.Xml..::..XmlNode
The data node.
configSettings
Type: System.Collections.Specialized..::..NameValueCollection
The config settings.

See Also

IItemEventHandler Interface
Sitecore.Diagnostics.Events Namespace


HandleCopied Method

[image]

Sitecore 6.4.1 API
IItemEventHandler..::..HandleCopied Method
IItemEventHandler Interface See Also Send Feedback

Namespace: Sitecore.Diagnostics.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void HandleCopied(
    Item itm,
    Item source,
    NameValueCollection configSettings
)
Visual Basic
Sub HandleCopied ( _
    itm As Item, _
    source As Item, _
    configSettings As NameValueCollection _
)
Visual C++
void HandleCopied(
    Item^ itm,
    Item^ source,
    NameValueCollection^ configSettings
)

Parameters

itm
Type: Sitecore.Data.Items..::..Item
The itm.
source
Type: Sitecore.Data.Items..::..Item
The source.
configSettings
Type: System.Collections.Specialized..::..NameValueCollection
The config settings.

See Also

IItemEventHandler Interface
Sitecore.Diagnostics.Events Namespace


HandleCreated Method

[image]

Sitecore 6.4.1 API
IItemEventHandler..::..HandleCreated Method
IItemEventHandler Interface See Also Send Feedback

Namespace: Sitecore.Diagnostics.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void HandleCreated(
    Item itm,
    NameValueCollection configSettings
)
Visual Basic
Sub HandleCreated ( _
    itm As Item, _
    configSettings As NameValueCollection _
)
Visual C++
void HandleCreated(
    Item^ itm,
    NameValueCollection^ configSettings
)

Parameters

itm
Type: Sitecore.Data.Items..::..Item
The itm.
configSettings
Type: System.Collections.Specialized..::..NameValueCollection
The config settings.

See Also

IItemEventHandler Interface
Sitecore.Diagnostics.Events Namespace


HandleDeleted Method

[image]

Sitecore 6.4.1 API
IItemEventHandler..::..HandleDeleted Method
IItemEventHandler Interface See Also Send Feedback

Namespace: Sitecore.Diagnostics.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void HandleDeleted(
    Item itm,
    Item oldParent,
    NameValueCollection configSettings
)
Visual Basic
Sub HandleDeleted ( _
    itm As Item, _
    oldParent As Item, _
    configSettings As NameValueCollection _
)
Visual C++
void HandleDeleted(
    Item^ itm,
    Item^ oldParent,
    NameValueCollection^ configSettings
)

Parameters

itm
Type: Sitecore.Data.Items..::..Item
The itm.
oldParent
Type: Sitecore.Data.Items..::..Item
The old parent.
configSettings
Type: System.Collections.Specialized..::..NameValueCollection
The config settings.

See Also

IItemEventHandler Interface
Sitecore.Diagnostics.Events Namespace


HandleRenamed Method

[image]

Sitecore 6.4.1 API
IItemEventHandler..::..HandleRenamed Method
IItemEventHandler Interface See Also Send Feedback

Namespace: Sitecore.Diagnostics.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void HandleRenamed(
    Item itm,
    string oldName,
    NameValueCollection configSettings
)
Visual Basic
Sub HandleRenamed ( _
    itm As Item, _
    oldName As String, _
    configSettings As NameValueCollection _
)
Visual C++
void HandleRenamed(
    Item^ itm,
    String^ oldName,
    NameValueCollection^ configSettings
)

Parameters

itm
Type: Sitecore.Data.Items..::..Item
The itm.
oldName
Type: System..::..String
The old name.
configSettings
Type: System.Collections.Specialized..::..NameValueCollection
The config settings.

See Also

IItemEventHandler Interface
Sitecore.Diagnostics.Events Namespace


HandleSaved Method

[image]

Sitecore 6.4.1 API
IItemEventHandler..::..HandleSaved Method
IItemEventHandler Interface See Also Send Feedback

Namespace: Sitecore.Diagnostics.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void HandleSaved(
    Item itm,
    NameValueCollection configSettings
)
Visual Basic
Sub HandleSaved ( _
    itm As Item, _
    configSettings As NameValueCollection _
)
Visual C++
void HandleSaved(
    Item^ itm,
    NameValueCollection^ configSettings
)

Parameters

itm
Type: Sitecore.Data.Items..::..Item
The itm.
configSettings
Type: System.Collections.Specialized..::..NameValueCollection
The config settings.

See Also

IItemEventHandler Interface
Sitecore.Diagnostics.Events Namespace


IMediaEventHandler Members

[image] [image]

Sitecore 6.4.1 API
IMediaEventHandler Members
IMediaEventHandler Interface Methods See Also Send Feedback

The IMediaEventHandler type exposes the following members.

Methods

 | Name | Description
Public method | HandleUploaded | A media item has been uploaded

See Also

IMediaEventHandler Interface
Sitecore.Diagnostics.Events Namespace


IMediaEventHandler Methods

[image] [image]

Sitecore 6.4.1 API
IMediaEventHandler Methods
IMediaEventHandler Interface See Also Send Feedback

The IMediaEventHandler type exposes the following members.

Methods

 | Name | Description
Public method | HandleUploaded | A media item has been uploaded

See Also

IMediaEventHandler Interface
Sitecore.Diagnostics.Events Namespace


HandleUploaded Method

[image]

Sitecore 6.4.1 API
IMediaEventHandler..::..HandleUploaded Method
IMediaEventHandler Interface See Also Send Feedback

Namespace: Sitecore.Diagnostics.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void HandleUploaded(
    Item itm,
    NameValueCollection configSettings
)
Visual Basic
Sub HandleUploaded ( _
    itm As Item, _
    configSettings As NameValueCollection _
)
Visual C++
void HandleUploaded(
    Item^ itm,
    NameValueCollection^ configSettings
)

Parameters

itm
Type: Sitecore.Data.Items..::..Item
The itm.
configSettings
Type: System.Collections.Specialized..::..NameValueCollection
The config settings.

See Also

IMediaEventHandler Interface
Sitecore.Diagnostics.Events Namespace


IPublishingEventHandler Interface

[image]

Sitecore 6.4.1 API
IPublishingEventHandler Interface
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IPublishingEventHandler
Visual Basic
Public Interface IPublishingEventHandler
Visual C++
public interface class IPublishingEventHandler

See Also

IPublishingEventHandler Members
Sitecore.Diagnostics.Events Namespace


IPublishingEventHandler Members

[image] [image]

Sitecore 6.4.1 API
IPublishingEventHandler Members
IPublishingEventHandler Interface Methods See Also Send Feedback

The IPublishingEventHandler type exposes the following members.

Methods

 | Name | Description
Public method | HandlePublishDone | A publishing operation has finished

See Also

IPublishingEventHandler Interface
Sitecore.Diagnostics.Events Namespace


IPublishingEventHandler Methods

[image] [image]

Sitecore 6.4.1 API
IPublishingEventHandler Methods
IPublishingEventHandler Interface See Also Send Feedback

The IPublishingEventHandler type exposes the following members.

Methods

 | Name | Description
Public method | HandlePublishDone | A publishing operation has finished

See Also

IPublishingEventHandler Interface
Sitecore.Diagnostics.Events Namespace


HandlePublishDone Method

[image]

Sitecore 6.4.1 API
IPublishingEventHandler..::..HandlePublishDone Method
IPublishingEventHandler Interface See Also Send Feedback

Namespace: Sitecore.Diagnostics.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void HandlePublishDone(
    IPublishingRequest request,
    NameValueCollection configSettings
)
Visual Basic
Sub HandlePublishDone ( _
    request As IPublishingRequest, _
    configSettings As NameValueCollection _
)
Visual C++
void HandlePublishDone(
    IPublishingRequest^ request,
    NameValueCollection^ configSettings
)

Parameters

request
Type: Sitecore..::..IPublishingRequest
The request.
configSettings
Type: System.Collections.Specialized..::..NameValueCollection
The config settings.

See Also

IPublishingEventHandler Interface
Sitecore.Diagnostics.Events Namespace


ITraceEventHandler Interface

[image]

Sitecore 6.4.1 API
ITraceEventHandler Interface
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface ITraceEventHandler
Visual Basic
Public Interface ITraceEventHandler
Visual C++
public interface class ITraceEventHandler

See Also

ITraceEventHandler Members
Sitecore.Diagnostics.Events Namespace


ITraceEventHandler Members

[image] [image]

Sitecore 6.4.1 API
ITraceEventHandler Members
ITraceEventHandler Interface Methods See Also Send Feedback

The ITraceEventHandler type exposes the following members.

Methods

 | Name | Description
Public method | HandleError | An error message has been traced.
Public method | HandleTrace | A trace message has been traced.
Public method | HandleWarning | A warning message has been traced.

See Also

ITraceEventHandler Interface
Sitecore.Diagnostics.Events Namespace


ITraceEventHandler Methods

[image] [image]

Sitecore 6.4.1 API
ITraceEventHandler Methods
ITraceEventHandler Interface See Also Send Feedback

The ITraceEventHandler type exposes the following members.

Methods

 | Name | Description
Public method | HandleError | An error message has been traced.
Public method | HandleTrace | A trace message has been traced.
Public method | HandleWarning | A warning message has been traced.

See Also

ITraceEventHandler Interface
Sitecore.Diagnostics.Events Namespace


HandleError Method

[image]

Sitecore 6.4.1 API
ITraceEventHandler..::..HandleError Method
ITraceEventHandler Interface See Also Send Feedback

Namespace: Sitecore.Diagnostics.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void HandleError(
    string message,
    Hashtable additionalInfo,
    NameValueCollection configSettings
)
Visual Basic
Sub HandleError ( _
    message As String, _
    additionalInfo As Hashtable, _
    configSettings As NameValueCollection _
)
Visual C++
void HandleError(
    String^ message,
    Hashtable^ additionalInfo,
    NameValueCollection^ configSettings
)

Parameters

message
Type: System..::..String
The message.
additionalInfo
Type: System.Collections..::..Hashtable
The additional info.
configSettings
Type: System.Collections.Specialized..::..NameValueCollection
The config settings.

See Also

ITraceEventHandler Interface
Sitecore.Diagnostics.Events Namespace


HandleTrace Method

[image]

Sitecore 6.4.1 API
ITraceEventHandler..::..HandleTrace Method
ITraceEventHandler Interface See Also Send Feedback

Namespace: Sitecore.Diagnostics.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void HandleTrace(
    string message,
    Hashtable additionalInfo,
    NameValueCollection configSettings
)
Visual Basic
Sub HandleTrace ( _
    message As String, _
    additionalInfo As Hashtable, _
    configSettings As NameValueCollection _
)
Visual C++
void HandleTrace(
    String^ message,
    Hashtable^ additionalInfo,
    NameValueCollection^ configSettings
)

Parameters

message
Type: System..::..String
The message.
additionalInfo
Type: System.Collections..::..Hashtable
The additional info.
configSettings
Type: System.Collections.Specialized..::..NameValueCollection
The config settings.

See Also

ITraceEventHandler Interface
Sitecore.Diagnostics.Events Namespace


HandleWarning Method

[image]

Sitecore 6.4.1 API
ITraceEventHandler..::..HandleWarning Method
ITraceEventHandler Interface See Also Send Feedback

Namespace: Sitecore.Diagnostics.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void HandleWarning(
    string message,
    Hashtable additionalInfo,
    NameValueCollection configSettings
)
Visual Basic
Sub HandleWarning ( _
    message As String, _
    additionalInfo As Hashtable, _
    configSettings As NameValueCollection _
)
Visual C++
void HandleWarning(
    String^ message,
    Hashtable^ additionalInfo,
    NameValueCollection^ configSettings
)

Parameters

message
Type: System..::..String
The message.
additionalInfo
Type: System.Collections..::..Hashtable
The additional info.
configSettings
Type: System.Collections.Specialized..::..NameValueCollection
The config settings.

See Also

ITraceEventHandler Interface
Sitecore.Diagnostics.Events Namespace


Sitecore.Diagnostics.PerformanceCounters Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Diagnostics.PerformanceCounters Namespace
Send Feedback

Classes

 | Class | Description
Public class | CacheCounters | Represents the cache counters.
Public class | Categories |
Public class | ContextCounters | Represents the context counters.
Public class | DataCounters | Represents the data counters.
Public class | EventCounters | Represents the event counters.
Public class | ExceptionCounters | Represents the exception counters.
Public class | GlobalizationCounters | Represents a GlobalizationCounters.
Public class | InstanceNameIsNotAvailableException | Exception for not available Instance name case
Public class | IOCounters | Represents the IO counters.
Public class | JobCounters | Represents the job counters.
Public class | LinkCounters | Represents the link counters.
Public class | LoggingCounters | Represents the logging counters.
Public class | MediaCounters | Represents the pipeline counters.
Public class | PerformanceCounter | Represents a performance counter.
Public class | PipelineCounters | Represents the pipeline counters.
Public class | PublishingCounters | Represents the publishing counters.
Public class | ReflectionCounters | Represents the reflection counters.
Public class | RenderingCounters | Represents the rendering counters.
Public class | SecurityCounters | Represents the security counters.
Public class | ShadowCounters | Represents the shadow counters.
Public class | TaskCounters | Represents the task counters.
Public class | ThreadingCounters | Represents the threading counters.
Public class | WorkflowCounters | Represents a workflow counters.
Public class | XmlCounters | Represents the xml counters.

Enumerations

 | Enumeration | Description
Public enumeration | PerformanceCounterInstanceType | Attribute indicate which category counter belongs to


CacheCounters Class

[image]

Sitecore 6.4.1 API
CacheCounters Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class CacheCounters
Visual Basic
Public NotInheritable Class CacheCounters
Visual C++
public ref class CacheCounters abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics.PerformanceCounters..::..CacheCounters

See Also

CacheCounters Members
Sitecore.Diagnostics.PerformanceCounters Namespace


CacheCounters Members

[image] [image]

Sitecore 6.4.1 API
CacheCounters Members
CacheCounters Class Properties See Also Send Feedback

The CacheCounters type exposes the following members.

Properties

Name | Description
CacheClearings | Gets the total number of times that a Cache has been cleared.
CacheHits | Gets the total number of cache hits for all caches.
CacheMisses | Gets the total number of cache misses for all caches.
DataCacheClearings | Gets the number of times that instances of a DataCache has been cleared.
DataCacheHits | Gets the number of cache hits in a DataCache.
DataCacheMisses | Gets the number of cache misses in a DataCache.
HtmlCacheClearings | Gets the number of times that instances of a HtmlCache has been cleared.
HtmlCacheHits | Gets the number of cache hits in a HtmlCache.
HtmlCacheMisses | Gets the number of cache misses in a HtmlCache.
PathCacheClearings | Gets the number of times that instances of a PathCache has been cleared.
PathCacheHits | Gets the number of cache hits in a PathCache.
PathCacheMisses | Gets the number of cache misses in a PathCache.
RegistryCacheClearings | Gets the number of times that instances of a RegistryCache has been cleared.
RegistryCacheHits | Gets the number of cache hits in a RegistryCache.
RegistryCacheMisses | Gets the number of cache misses in a RegistryCache.
ViewStateCacheClearings | Gets the number of times that instances of a ViewStateCache has been cleared.
ViewStateCacheHits | Gets the number of cache hits in a ViewStateCache.
ViewStateCacheMisses | Gets the number of cache misses in a ViewStateCache.
XslCacheClearings | Gets the number of times that instances of a XslCache has been cleared.
XslCacheHits | Gets the number of cache hits in a XslCache.
XslCacheMisses | Gets the number of cache misses in a XslCache.

See Also

CacheCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


CacheCounters Properties

[image] [image]

Sitecore 6.4.1 API
CacheCounters Properties
CacheCounters Class See Also Send Feedback

The CacheCounters type exposes the following members.

Properties

Name | Description
CacheClearings | Gets the total number of times that a Cache has been cleared.
CacheHits | Gets the total number of cache hits for all caches.
CacheMisses | Gets the total number of cache misses for all caches.
DataCacheClearings | Gets the number of times that instances of a DataCache has been cleared.
DataCacheHits | Gets the number of cache hits in a DataCache.
DataCacheMisses | Gets the number of cache misses in a DataCache.
HtmlCacheClearings | Gets the number of times that instances of a HtmlCache has been cleared.
HtmlCacheHits | Gets the number of cache hits in a HtmlCache.
HtmlCacheMisses | Gets the number of cache misses in a HtmlCache.
PathCacheClearings | Gets the number of times that instances of a PathCache has been cleared.
PathCacheHits | Gets the number of cache hits in a PathCache.
PathCacheMisses | Gets the number of cache misses in a PathCache.
RegistryCacheClearings | Gets the number of times that instances of a RegistryCache has been cleared.
RegistryCacheHits | Gets the number of cache hits in a RegistryCache.
RegistryCacheMisses | Gets the number of cache misses in a RegistryCache.
ViewStateCacheClearings | Gets the number of times that instances of a ViewStateCache has been cleared.
ViewStateCacheHits | Gets the number of cache hits in a ViewStateCache.
ViewStateCacheMisses | Gets the number of cache misses in a ViewStateCache.
XslCacheClearings | Gets the number of times that instances of a XslCache has been cleared.
XslCacheHits | Gets the number of cache hits in a XslCache.
XslCacheMisses | Gets the number of cache misses in a XslCache.

See Also

CacheCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


CacheClearings Property

[image]

Sitecore 6.4.1 API
CacheCounters..::..CacheClearings Property
CacheCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter CacheClearings { get; }
Visual Basic
Public Shared ReadOnly Property CacheClearings As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ CacheClearings {
    PerformanceCounter^ get ();
}

Field Value

The cache clearings.

See Also

CacheCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


CacheHits Property

[image]

Sitecore 6.4.1 API
CacheCounters..::..CacheHits Property
CacheCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter CacheHits { get; }
Visual Basic
Public Shared ReadOnly Property CacheHits As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ CacheHits {
    PerformanceCounter^ get ();
}

Field Value

The cache hits.

See Also

CacheCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


CacheMisses Property

[image]

Sitecore 6.4.1 API
CacheCounters..::..CacheMisses Property
CacheCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter CacheMisses { get; }
Visual Basic
Public Shared ReadOnly Property CacheMisses As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ CacheMisses {
    PerformanceCounter^ get ();
}

Field Value

The cache misses.

See Also

CacheCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


DataCacheClearings Property

[image]

Sitecore 6.4.1 API
CacheCounters..::..DataCacheClearings Property
CacheCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter DataCacheClearings { get; }
Visual Basic
Public Shared ReadOnly Property DataCacheClearings As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ DataCacheClearings {
    PerformanceCounter^ get ();
}

Field Value

The data cache clearings.

See Also

CacheCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


DataCacheHits Property

[image]

Sitecore 6.4.1 API
CacheCounters..::..DataCacheHits Property
CacheCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter DataCacheHits { get; }
Visual Basic
Public Shared ReadOnly Property DataCacheHits As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ DataCacheHits {
    PerformanceCounter^ get ();
}

Field Value

The data cache hits.

See Also

CacheCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


DataCacheMisses Property

[image]

Sitecore 6.4.1 API
CacheCounters..::..DataCacheMisses Property
CacheCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter DataCacheMisses { get; }
Visual Basic
Public Shared ReadOnly Property DataCacheMisses As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ DataCacheMisses {
    PerformanceCounter^ get ();
}

Field Value

The data cache misses.

See Also

CacheCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


HtmlCacheClearings Property

[image]

Sitecore 6.4.1 API
CacheCounters..::..HtmlCacheClearings Property
CacheCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter HtmlCacheClearings { get; }
Visual Basic
Public Shared ReadOnly Property HtmlCacheClearings As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ HtmlCacheClearings {
    PerformanceCounter^ get ();
}

Field Value

The HTML cache clearings.

See Also

CacheCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


HtmlCacheHits Property

[image]

Sitecore 6.4.1 API
CacheCounters..::..HtmlCacheHits Property
CacheCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter HtmlCacheHits { get; }
Visual Basic
Public Shared ReadOnly Property HtmlCacheHits As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ HtmlCacheHits {
    PerformanceCounter^ get ();
}

Field Value

The HTML cache hits.

See Also

CacheCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


HtmlCacheMisses Property

[image]

Sitecore 6.4.1 API
CacheCounters..::..HtmlCacheMisses Property
CacheCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter HtmlCacheMisses { get; }
Visual Basic
Public Shared ReadOnly Property HtmlCacheMisses As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ HtmlCacheMisses {
    PerformanceCounter^ get ();
}

Field Value

The HTML cache misses.

See Also

CacheCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


PathCacheClearings Property

[image]

Sitecore 6.4.1 API
CacheCounters..::..PathCacheClearings Property
CacheCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter PathCacheClearings { get; }
Visual Basic
Public Shared ReadOnly Property PathCacheClearings As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ PathCacheClearings {
    PerformanceCounter^ get ();
}

Field Value

The path cache clearings.

See Also

CacheCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


PathCacheHits Property

[image]

Sitecore 6.4.1 API
CacheCounters..::..PathCacheHits Property
CacheCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter PathCacheHits { get; }
Visual Basic
Public Shared ReadOnly Property PathCacheHits As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ PathCacheHits {
    PerformanceCounter^ get ();
}

Field Value

The path cache hits.

See Also

CacheCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


PathCacheMisses Property

[image]

Sitecore 6.4.1 API
CacheCounters..::..PathCacheMisses Property
CacheCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter PathCacheMisses { get; }
Visual Basic
Public Shared ReadOnly Property PathCacheMisses As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ PathCacheMisses {
    PerformanceCounter^ get ();
}

Field Value

The path cache misses.

See Also

CacheCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


RegistryCacheClearings Property

[image]

Sitecore 6.4.1 API
CacheCounters..::..RegistryCacheClearings Property
CacheCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter RegistryCacheClearings { get; }
Visual Basic
Public Shared ReadOnly Property RegistryCacheClearings As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ RegistryCacheClearings {
    PerformanceCounter^ get ();
}

Field Value

The registry cache clearings.

See Also

CacheCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


RegistryCacheHits Property

[image]

Sitecore 6.4.1 API
CacheCounters..::..RegistryCacheHits Property
CacheCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter RegistryCacheHits { get; }
Visual Basic
Public Shared ReadOnly Property RegistryCacheHits As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ RegistryCacheHits {
    PerformanceCounter^ get ();
}

Field Value

The registry cache hits.

See Also

CacheCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


RegistryCacheMisses Property

[image]

Sitecore 6.4.1 API
CacheCounters..::..RegistryCacheMisses Property
CacheCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter RegistryCacheMisses { get; }
Visual Basic
Public Shared ReadOnly Property RegistryCacheMisses As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ RegistryCacheMisses {
    PerformanceCounter^ get ();
}

Field Value

The registry cache misses.

See Also

CacheCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


ViewStateCacheClearings Property

[image]

Sitecore 6.4.1 API
CacheCounters..::..ViewStateCacheClearings Property
CacheCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter ViewStateCacheClearings { get; }
Visual Basic
Public Shared ReadOnly Property ViewStateCacheClearings As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ ViewStateCacheClearings {
    PerformanceCounter^ get ();
}

Field Value

The view state cache clearings.

See Also

CacheCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


ViewStateCacheMisses Property

[image]

Sitecore 6.4.1 API
CacheCounters..::..ViewStateCacheMisses Property
CacheCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter ViewStateCacheMisses { get; }
Visual Basic
Public Shared ReadOnly Property ViewStateCacheMisses As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ ViewStateCacheMisses {
    PerformanceCounter^ get ();
}

Field Value

The view state cache misses.

See Also

CacheCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


XslCacheClearings Property

[image]

Sitecore 6.4.1 API
CacheCounters..::..XslCacheClearings Property
CacheCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter XslCacheClearings { get; }
Visual Basic
Public Shared ReadOnly Property XslCacheClearings As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ XslCacheClearings {
    PerformanceCounter^ get ();
}

Field Value

The XSL cache clearings.

See Also

CacheCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


XslCacheHits Property

[image]

Sitecore 6.4.1 API
CacheCounters..::..XslCacheHits Property
CacheCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter XslCacheHits { get; }
Visual Basic
Public Shared ReadOnly Property XslCacheHits As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ XslCacheHits {
    PerformanceCounter^ get ();
}

Field Value

The XSL cache hits.

See Also

CacheCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


XslCacheMisses Property

[image]

Sitecore 6.4.1 API
CacheCounters..::..XslCacheMisses Property
CacheCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter XslCacheMisses { get; }
Visual Basic
Public Shared ReadOnly Property XslCacheMisses As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ XslCacheMisses {
    PerformanceCounter^ get ();
}

Field Value

The XSL cache misses.

See Also

CacheCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


Categories Class

[image]

Sitecore 6.4.1 API
Categories Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Categories
Visual Basic
Public Class Categories
Visual C++
public ref class Categories

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics.PerformanceCounters..::..Categories

See Also

Categories Members
Sitecore.Diagnostics.PerformanceCounters Namespace


Categories Members

[image] [image]

Sitecore 6.4.1 API
Categories Members
Categories Class Constructors Methods Fields See Also Send Feedback

The Categories type exposes the following members.

Constructors

 | Name | Description
Public method | Categories | Initializes a new instance of the Categories class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Caching | "Sitecore.Caching"
Data | "Sitecore.Data"
Jobs | "Sitecore.Jobs"
Presentation | "Sitecore.Presentation"
Security | "Sitecore.Security"
System | "Sitecore.System"

See Also

Categories Class
Sitecore.Diagnostics.PerformanceCounters Namespace


Categories Constructor

[image]

Sitecore 6.4.1 API
Categories Constructor
Categories Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Categories()
Visual Basic
Public Sub New
Visual C++
public:
Categories()

See Also

Categories Class
Sitecore.Diagnostics.PerformanceCounters Namespace


Categories Fields

[image] [image]

Sitecore 6.4.1 API
Categories Fields
Categories Class See Also Send Feedback

The Categories type exposes the following members.

Fields

Name | Description
Caching | "Sitecore.Caching"
Data | "Sitecore.Data"
Jobs | "Sitecore.Jobs"
Presentation | "Sitecore.Presentation"
Security | "Sitecore.Security"
System | "Sitecore.System"

See Also

Categories Class
Sitecore.Diagnostics.PerformanceCounters Namespace


Caching Field

[image]

Sitecore 6.4.1 API
Categories..::..Caching Field
Categories Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string Caching
Visual Basic
Public Const Caching As String
Visual C++
public:
literal String^ Caching

See Also

Categories Class
Sitecore.Diagnostics.PerformanceCounters Namespace


Data Field

[image]

Sitecore 6.4.1 API
Categories..::..Data Field
Categories Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string Data
Visual Basic
Public Const Data As String
Visual C++
public:
literal String^ Data

See Also

Categories Class
Sitecore.Diagnostics.PerformanceCounters Namespace


Jobs Field

[image]

Sitecore 6.4.1 API
Categories..::..Jobs Field
Categories Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string Jobs
Visual Basic
Public Const Jobs As String
Visual C++
public:
literal String^ Jobs

See Also

Categories Class
Sitecore.Diagnostics.PerformanceCounters Namespace


Presentation Field

[image]

Sitecore 6.4.1 API
Categories..::..Presentation Field
Categories Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string Presentation
Visual Basic
Public Const Presentation As String
Visual C++
public:
literal String^ Presentation

See Also

Categories Class
Sitecore.Diagnostics.PerformanceCounters Namespace


Security Field

[image]

Sitecore 6.4.1 API
Categories..::..Security Field
Categories Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string Security
Visual Basic
Public Const Security As String
Visual C++
public:
literal String^ Security

See Also

Categories Class
Sitecore.Diagnostics.PerformanceCounters Namespace


System Field

[image]

Sitecore 6.4.1 API
Categories..::..System Field
Categories Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string System
Visual Basic
Public Const System As String
Visual C++
public:
literal String^ System

See Also

Categories Class
Sitecore.Diagnostics.PerformanceCounters Namespace


Categories Methods

[image] [image]

Sitecore 6.4.1 API
Categories Methods
Categories Class See Also Send Feedback

The Categories type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Categories Class
Sitecore.Diagnostics.PerformanceCounters Namespace


ContextCounters Class

[image]

Sitecore 6.4.1 API
ContextCounters Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class ContextCounters
Visual Basic
Public NotInheritable Class ContextCounters
Visual C++
public ref class ContextCounters abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics.PerformanceCounters..::..ContextCounters

See Also

ContextCounters Members
Sitecore.Diagnostics.PerformanceCounters Namespace


ContextCounters Members

[image] [image]

Sitecore 6.4.1 API
ContextCounters Members
ContextCounters Class Properties See Also Send Feedback

The ContextCounters type exposes the following members.

Properties

Name | Description
SiteChanged | Gets the total number of times the active site has been changed by the API.
ThreadDataAccessed | Gets the total number of times the local thread data has been accessed.

See Also

ContextCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


ContextCounters Properties

[image] [image]

Sitecore 6.4.1 API
ContextCounters Properties
ContextCounters Class See Also Send Feedback

The ContextCounters type exposes the following members.

Properties

Name | Description
SiteChanged | Gets the total number of times the active site has been changed by the API.
ThreadDataAccessed | Gets the total number of times the local thread data has been accessed.

See Also

ContextCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


SiteChanged Property

[image]

Sitecore 6.4.1 API
ContextCounters..::..SiteChanged Property
ContextCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter SiteChanged { get; }
Visual Basic
Public Shared ReadOnly Property SiteChanged As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ SiteChanged {
    PerformanceCounter^ get ();
}

Field Value

The site changed.

See Also

ContextCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


ThreadDataAccessed Property

[image]

Sitecore 6.4.1 API
ContextCounters..::..ThreadDataAccessed Property
ContextCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter ThreadDataAccessed { get; }
Visual Basic
Public Shared ReadOnly Property ThreadDataAccessed As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ ThreadDataAccessed {
    PerformanceCounter^ get ();
}

Field Value

The thread data accessed.

See Also

ContextCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


DataCounters Class

[image]

Sitecore 6.4.1 API
DataCounters Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class DataCounters
Visual Basic
Public NotInheritable Class DataCounters
Visual C++
public ref class DataCounters abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics.PerformanceCounters..::..DataCounters

See Also

DataCounters Members
Sitecore.Diagnostics.PerformanceCounters Namespace


DataCounters Members

[image] [image]

Sitecore 6.4.1 API
DataCounters Members
DataCounters Class Properties See Also Send Feedback

The DataCounters type exposes the following members.

Properties

Name | Description
ClientDataReads | Gets the 'client data reads' counter.
ClientDataWrites | Gets the 'client data writes' counter.
ItemsAccessed | Gets the number of items that have been accessed.
PhysicalReads | Gets the number of read operations that have been performed against the physical storage medium (typically a RDBMS).
PhysicalWrites | Gets the number of write operations that have been performed against the physical storage medium (typically a RDBMS).

See Also

DataCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


DataCounters Properties

[image] [image]

Sitecore 6.4.1 API
DataCounters Properties
DataCounters Class See Also Send Feedback

The DataCounters type exposes the following members.

Properties

Name | Description
ClientDataReads | Gets the 'client data reads' counter.
ClientDataWrites | Gets the 'client data writes' counter.
ItemsAccessed | Gets the number of items that have been accessed.
PhysicalReads | Gets the number of read operations that have been performed against the physical storage medium (typically a RDBMS).
PhysicalWrites | Gets the number of write operations that have been performed against the physical storage medium (typically a RDBMS).

See Also

DataCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


ClientDataWrites Property

[image]

Sitecore 6.4.1 API
DataCounters..::..ClientDataWrites Property
DataCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter ClientDataWrites { get; }
Visual Basic
Public Shared ReadOnly Property ClientDataWrites As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ ClientDataWrites {
    PerformanceCounter^ get ();
}

Field Value

The counter.

See Also

DataCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


ItemsAccessed Property

[image]

Sitecore 6.4.1 API
DataCounters..::..ItemsAccessed Property
DataCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter ItemsAccessed { get; }
Visual Basic
Public Shared ReadOnly Property ItemsAccessed As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ ItemsAccessed {
    PerformanceCounter^ get ();
}

Field Value

The items accessed.

See Also

DataCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


PhysicalReads Property

[image]

Sitecore 6.4.1 API
DataCounters..::..PhysicalReads Property
DataCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter PhysicalReads { get; }
Visual Basic
Public Shared ReadOnly Property PhysicalReads As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ PhysicalReads {
    PerformanceCounter^ get ();
}

Field Value

The physical reads.

See Also

DataCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


PhysicalWrites Property

[image]

Sitecore 6.4.1 API
DataCounters..::..PhysicalWrites Property
DataCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter PhysicalWrites { get; }
Visual Basic
Public Shared ReadOnly Property PhysicalWrites As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ PhysicalWrites {
    PerformanceCounter^ get ();
}

Field Value

The physical writes.

See Also

DataCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


EventCounters Class

[image]

Sitecore 6.4.1 API
EventCounters Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class EventCounters
Visual Basic
Public NotInheritable Class EventCounters
Visual C++
public ref class EventCounters abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics.PerformanceCounters..::..EventCounters

See Also

EventCounters Members
Sitecore.Diagnostics.PerformanceCounters Namespace


EventCounters Members

[image] [image]

Sitecore 6.4.1 API
EventCounters Members
EventCounters Class Properties See Also Send Feedback

The EventCounters type exposes the following members.

Properties

Name | Description
EventsRaised | Gets the total number of events that have been raised by the API.

See Also

EventCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


EventCounters Properties

[image] [image]

Sitecore 6.4.1 API
EventCounters Properties
EventCounters Class See Also Send Feedback

The EventCounters type exposes the following members.

Properties

Name | Description
EventsRaised | Gets the total number of events that have been raised by the API.

See Also

EventCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


EventsRaised Property

[image]

Sitecore 6.4.1 API
EventCounters..::..EventsRaised Property
EventCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter EventsRaised { get; }
Visual Basic
Public Shared ReadOnly Property EventsRaised As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ EventsRaised {
    PerformanceCounter^ get ();
}

Field Value

The events raised.

See Also

EventCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


ExceptionCounters Members

[image] [image]

Sitecore 6.4.1 API
ExceptionCounters Members
ExceptionCounters Class Properties See Also Send Feedback

The ExceptionCounters type exposes the following members.

Properties

Name | Description
ExceptionsThrown | Gets the total number of exceptions thrown by the API.

See Also

ExceptionCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


ExceptionsThrown Property

[image]

Sitecore 6.4.1 API
ExceptionCounters..::..ExceptionsThrown Property
ExceptionCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter ExceptionsThrown { get; }
Visual Basic
Public Shared ReadOnly Property ExceptionsThrown As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ ExceptionsThrown {
    PerformanceCounter^ get ();
}

Field Value

The exceptions thrown.

See Also

ExceptionCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


GlobalizationCounters Class

[image]

Sitecore 6.4.1 API
GlobalizationCounters Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class GlobalizationCounters
Visual Basic
Public NotInheritable Class GlobalizationCounters
Visual C++
public ref class GlobalizationCounters abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics.PerformanceCounters..::..GlobalizationCounters

See Also

GlobalizationCounters Members
Sitecore.Diagnostics.PerformanceCounters Namespace


GlobalizationCounters Members

[image] [image]

Sitecore 6.4.1 API
GlobalizationCounters Members
GlobalizationCounters Class Properties See Also Send Feedback

The GlobalizationCounters type exposes the following members.

Properties

Name | Description
TextsTranslated | Gets the total number of texts that have been translated.
TranslateFailed | Gets the total number of times a translate operation has failed (ie. the text was not in the dictionary).

See Also

GlobalizationCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


GlobalizationCounters Properties

[image] [image]

Sitecore 6.4.1 API
GlobalizationCounters Properties
GlobalizationCounters Class See Also Send Feedback

The GlobalizationCounters type exposes the following members.

Properties

Name | Description
TextsTranslated | Gets the total number of texts that have been translated.
TranslateFailed | Gets the total number of times a translate operation has failed (ie. the text was not in the dictionary).

See Also

GlobalizationCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


TextsTranslated Property

[image]

Sitecore 6.4.1 API
GlobalizationCounters..::..TextsTranslated Property
GlobalizationCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter TextsTranslated { get; }
Visual Basic
Public Shared ReadOnly Property TextsTranslated As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ TextsTranslated {
    PerformanceCounter^ get ();
}

Field Value

The texts translated.

See Also

GlobalizationCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


TranslateFailed Property

[image]

Sitecore 6.4.1 API
GlobalizationCounters..::..TranslateFailed Property
GlobalizationCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter TranslateFailed { get; }
Visual Basic
Public Shared ReadOnly Property TranslateFailed As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ TranslateFailed {
    PerformanceCounter^ get ();
}

Field Value

The translate failed.

See Also

GlobalizationCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


InstanceNameIsNotAvailableException Class

[image]

Sitecore 6.4.1 API
InstanceNameIsNotAvailableException Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class InstanceNameIsNotAvailableException : SitecoreException
Visual Basic
Public Class InstanceNameIsNotAvailableException _
    Inherits SitecoreException
Visual C++
public ref class InstanceNameIsNotAvailableException : public SitecoreException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Exceptions..::..SitecoreException
Sitecore.Diagnostics.PerformanceCounters..::..InstanceNameIsNotAvailableException

See Also

InstanceNameIsNotAvailableException Members
Sitecore.Diagnostics.PerformanceCounters Namespace


InstanceNameIsNotAvailableException Members

[image] [image]

Sitecore 6.4.1 API
InstanceNameIsNotAvailableException Members
InstanceNameIsNotAvailableException Class Constructors Methods Properties See Also Send Feedback

The InstanceNameIsNotAvailableException type exposes the following members.

Constructors

 | Name | Description
Public method | InstanceNameIsNotAvailableException | Gets or sets the performance counter.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | PerformanceCounter | Returns performance counter
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InstanceNameIsNotAvailableException Class
Sitecore.Diagnostics.PerformanceCounters Namespace


InstanceNameIsNotAvailableException Constructor

[image]

Sitecore 6.4.1 API
InstanceNameIsNotAvailableException Constructor
InstanceNameIsNotAvailableException Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public InstanceNameIsNotAvailableException(
    PerformanceCounter performanceCounter
)
Visual Basic
Public Sub New ( _
    performanceCounter As PerformanceCounter _
)
Visual C++
public:
InstanceNameIsNotAvailableException(
    PerformanceCounter^ performanceCounter
)

Parameters

performanceCounter
Type: Sitecore.Diagnostics.PerformanceCounters..::..PerformanceCounter

[Missing <param name="performanceCounter"/> documentation for "M:Sitecore.Diagnostics.PerformanceCounters.InstanceNameIsNotAvailableException.#ctor(Sitecore.Diagnostics.PerformanceCounters.PerformanceCounter)"]

Field Value

The performance counter.

See Also

InstanceNameIsNotAvailableException Class
Sitecore.Diagnostics.PerformanceCounters Namespace


InstanceNameIsNotAvailableException Methods

[image] [image]

Sitecore 6.4.1 API
InstanceNameIsNotAvailableException Methods
InstanceNameIsNotAvailableException Class See Also Send Feedback

The InstanceNameIsNotAvailableException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InstanceNameIsNotAvailableException Class
Sitecore.Diagnostics.PerformanceCounters Namespace


InstanceNameIsNotAvailableException Properties

[image] [image]

Sitecore 6.4.1 API
InstanceNameIsNotAvailableException Properties
InstanceNameIsNotAvailableException Class See Also Send Feedback

The InstanceNameIsNotAvailableException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | PerformanceCounter | Returns performance counter
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InstanceNameIsNotAvailableException Class
Sitecore.Diagnostics.PerformanceCounters Namespace


PerformanceCounter Property

[image]

Sitecore 6.4.1 API
InstanceNameIsNotAvailableException..::..PerformanceCounter Property
InstanceNameIsNotAvailableException Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PerformanceCounter PerformanceCounter { get; }
Visual Basic
Public ReadOnly Property PerformanceCounter As PerformanceCounter
    Get
Visual C++
public:
property PerformanceCounter^ PerformanceCounter {
    PerformanceCounter^ get ();
}

See Also

InstanceNameIsNotAvailableException Class
Sitecore.Diagnostics.PerformanceCounters Namespace


IOCounters Class

[image]

Sitecore 6.4.1 API
IOCounters Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class IOCounters
Visual Basic
Public NotInheritable Class IOCounters
Visual C++
public ref class IOCounters abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics.PerformanceCounters..::..IOCounters

See Also

IOCounters Members
Sitecore.Diagnostics.PerformanceCounters Namespace


IOCounters Members

[image] [image]

Sitecore 6.4.1 API
IOCounters Members
IOCounters Class Properties See Also Send Feedback

The IOCounters type exposes the following members.

Properties

Name | Description
FileWatcherEvents | Gets the total number of file watcher events that have been handled by the API.

See Also

IOCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


IOCounters Properties

[image] [image]

Sitecore 6.4.1 API
IOCounters Properties
IOCounters Class See Also Send Feedback

The IOCounters type exposes the following members.

Properties

Name | Description
FileWatcherEvents | Gets the total number of file watcher events that have been handled by the API.

See Also

IOCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


JobCounters Class

[image]

Sitecore 6.4.1 API
JobCounters Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class JobCounters
Visual Basic
Public NotInheritable Class JobCounters
Visual C++
public ref class JobCounters abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics.PerformanceCounters..::..JobCounters

See Also

JobCounters Members
Sitecore.Diagnostics.PerformanceCounters Namespace


JobCounters Members

[image] [image]

Sitecore 6.4.1 API
JobCounters Members
JobCounters Class Properties See Also Send Feedback

The JobCounters type exposes the following members.

Properties

Name | Description
JobsExecuted | Gets the total number of jobs that have been executed.

See Also

JobCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


JobCounters Properties

[image] [image]

Sitecore 6.4.1 API
JobCounters Properties
JobCounters Class See Also Send Feedback

The JobCounters type exposes the following members.

Properties

Name | Description
JobsExecuted | Gets the total number of jobs that have been executed.

See Also

JobCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


JobsExecuted Property

[image]

Sitecore 6.4.1 API
JobCounters..::..JobsExecuted Property
JobCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter JobsExecuted { get; }
Visual Basic
Public Shared ReadOnly Property JobsExecuted As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ JobsExecuted {
    PerformanceCounter^ get ();
}

Field Value

The jobs executed.

See Also

JobCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


LinkCounters Class

[image]

Sitecore 6.4.1 API
LinkCounters Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class LinkCounters
Visual Basic
Public NotInheritable Class LinkCounters
Visual C++
public ref class LinkCounters abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics.PerformanceCounters..::..LinkCounters

See Also

LinkCounters Members
Sitecore.Diagnostics.PerformanceCounters Namespace


LinkCounters Members

[image] [image]

Sitecore 6.4.1 API
LinkCounters Members
LinkCounters Class Properties See Also Send Feedback

The LinkCounters type exposes the following members.

Properties

Name | Description
DataRead | Gets the total number of read operations that have been performed against the link database.
DataUpdated | Gets the total number of update operations that have been performed against the link database.
FieldsExamined | Gets the total number of fields that have been scanned for links.

See Also

LinkCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


LinkCounters Properties

[image] [image]

Sitecore 6.4.1 API
LinkCounters Properties
LinkCounters Class See Also Send Feedback

The LinkCounters type exposes the following members.

Properties

Name | Description
DataRead | Gets the total number of read operations that have been performed against the link database.
DataUpdated | Gets the total number of update operations that have been performed against the link database.
FieldsExamined | Gets the total number of fields that have been scanned for links.

See Also

LinkCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


DataRead Property

[image]

Sitecore 6.4.1 API
LinkCounters..::..DataRead Property
LinkCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter DataRead { get; }
Visual Basic
Public Shared ReadOnly Property DataRead As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ DataRead {
    PerformanceCounter^ get ();
}

Field Value

The data read.

See Also

LinkCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


DataUpdated Property

[image]

Sitecore 6.4.1 API
LinkCounters..::..DataUpdated Property
LinkCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter DataUpdated { get; }
Visual Basic
Public Shared ReadOnly Property DataUpdated As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ DataUpdated {
    PerformanceCounter^ get ();
}

Field Value

The data updated.

See Also

LinkCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


FieldsExamined Property

[image]

Sitecore 6.4.1 API
LinkCounters..::..FieldsExamined Property
LinkCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter FieldsExamined { get; }
Visual Basic
Public Shared ReadOnly Property FieldsExamined As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ FieldsExamined {
    PerformanceCounter^ get ();
}

Field Value

The fields examined.

See Also

LinkCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


LoggingCounters Class

[image]

Sitecore 6.4.1 API
LoggingCounters Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class LoggingCounters
Visual Basic
Public NotInheritable Class LoggingCounters
Visual C++
public ref class LoggingCounters abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics.PerformanceCounters..::..LoggingCounters

See Also

LoggingCounters Members
Sitecore.Diagnostics.PerformanceCounters Namespace


LoggingCounters Members

[image] [image]

Sitecore 6.4.1 API
LoggingCounters Members
LoggingCounters Class Properties See Also Send Feedback

The LoggingCounters type exposes the following members.

Properties

Name | Description
AuditsLogged | Gets the number of audit messages that have been sent to the log.
ErrorsLogged | Gets the number of error messages that have been sent to the log.
FatalsLogged | Gets the number of fatal messages that have been sent to the log.
InformationsLogged | Gets the number of information messages that have been sent to the log.
WarningsLogged | Gets the number of warning messages that have been sent to the log.

See Also

LoggingCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


LoggingCounters Properties

[image] [image]

Sitecore 6.4.1 API
LoggingCounters Properties
LoggingCounters Class See Also Send Feedback

The LoggingCounters type exposes the following members.

Properties

Name | Description
AuditsLogged | Gets the number of audit messages that have been sent to the log.
ErrorsLogged | Gets the number of error messages that have been sent to the log.
FatalsLogged | Gets the number of fatal messages that have been sent to the log.
InformationsLogged | Gets the number of information messages that have been sent to the log.
WarningsLogged | Gets the number of warning messages that have been sent to the log.

See Also

LoggingCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


AuditsLogged Property

[image]

Sitecore 6.4.1 API
LoggingCounters..::..AuditsLogged Property
LoggingCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter AuditsLogged { get; }
Visual Basic
Public Shared ReadOnly Property AuditsLogged As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ AuditsLogged {
    PerformanceCounter^ get ();
}

Field Value

The audits logged.

See Also

LoggingCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


ErrorsLogged Property

[image]

Sitecore 6.4.1 API
LoggingCounters..::..ErrorsLogged Property
LoggingCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter ErrorsLogged { get; }
Visual Basic
Public Shared ReadOnly Property ErrorsLogged As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ ErrorsLogged {
    PerformanceCounter^ get ();
}

Field Value

The errors logged.

See Also

LoggingCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


FatalsLogged Property

[image]

Sitecore 6.4.1 API
LoggingCounters..::..FatalsLogged Property
LoggingCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter FatalsLogged { get; }
Visual Basic
Public Shared ReadOnly Property FatalsLogged As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ FatalsLogged {
    PerformanceCounter^ get ();
}

Field Value

The fatals logged.

See Also

LoggingCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


InformationsLogged Property

[image]

Sitecore 6.4.1 API
LoggingCounters..::..InformationsLogged Property
LoggingCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter InformationsLogged { get; }
Visual Basic
Public Shared ReadOnly Property InformationsLogged As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ InformationsLogged {
    PerformanceCounter^ get ();
}

Field Value

The informations logged.

See Also

LoggingCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


WarningsLogged Property

[image]

Sitecore 6.4.1 API
LoggingCounters..::..WarningsLogged Property
LoggingCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter WarningsLogged { get; }
Visual Basic
Public Shared ReadOnly Property WarningsLogged As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ WarningsLogged {
    PerformanceCounter^ get ();
}

Field Value

The warnings logged.

See Also

LoggingCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


MediaCounters Class

[image]

Sitecore 6.4.1 API
MediaCounters Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class MediaCounters
Visual Basic
Public NotInheritable Class MediaCounters
Visual C++
public ref class MediaCounters abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics.PerformanceCounters..::..MediaCounters

See Also

MediaCounters Members
Sitecore.Diagnostics.PerformanceCounters Namespace


MediaCounters Members

[image] [image]

Sitecore 6.4.1 API
MediaCounters Members
MediaCounters Class Properties See Also Send Feedback

The MediaCounters type exposes the following members.

Properties

Name | Description
FastMediaCacheHits | Obsolete. Gets the number of cache hits in the fast media cache.
FastMediaCacheMisses | Obsolete. Gets the number of cache misses in the fast media cache.
MediaCacheHits | Gets the number of cache hits in the media cache.
MediaCacheMisses | Gets the number of cache misses in the media cache.
StandardMediaCacheHits | Obsolete. Gets the number of cache hits in the standard media cache.
StandardMediaCacheMisses | Obsolete. Gets the number of cache misses in the standard media cache.

See Also

MediaCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


MediaCounters Properties

[image] [image]

Sitecore 6.4.1 API
MediaCounters Properties
MediaCounters Class See Also Send Feedback

The MediaCounters type exposes the following members.

Properties

Name | Description
FastMediaCacheHits | Obsolete. Gets the number of cache hits in the fast media cache.
FastMediaCacheMisses | Obsolete. Gets the number of cache misses in the fast media cache.
MediaCacheHits | Gets the number of cache hits in the media cache.
MediaCacheMisses | Gets the number of cache misses in the media cache.
StandardMediaCacheHits | Obsolete. Gets the number of cache hits in the standard media cache.
StandardMediaCacheMisses | Obsolete. Gets the number of cache misses in the standard media cache.

See Also

MediaCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


FastMediaCacheHits Property

[image]

Sitecore 6.4.1 API
MediaCounters..::..FastMediaCacheHits Property
MediaCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public static PerformanceCounter FastMediaCacheHits { get; }
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Shared ReadOnly Property FastMediaCacheHits As PerformanceCounter
    Get
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public:
static property PerformanceCounter^ FastMediaCacheHits {
    PerformanceCounter^ get ();
}

Field Value

The number of cache hits.

See Also

MediaCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


FastMediaCacheMisses Property

[image]

Sitecore 6.4.1 API
MediaCounters..::..FastMediaCacheMisses Property
MediaCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public static PerformanceCounter FastMediaCacheMisses { get; }
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Shared ReadOnly Property FastMediaCacheMisses As PerformanceCounter
    Get
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public:
static property PerformanceCounter^ FastMediaCacheMisses {
    PerformanceCounter^ get ();
}

Field Value

The number of cache misses.

See Also

MediaCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


MediaCacheHits Property

[image]

Sitecore 6.4.1 API
MediaCounters..::..MediaCacheHits Property
MediaCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter MediaCacheHits { get; }
Visual Basic
Public Shared ReadOnly Property MediaCacheHits As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ MediaCacheHits {
    PerformanceCounter^ get ();
}

Field Value

The number of cache hits.

See Also

MediaCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


MediaCacheMisses Property

[image]

Sitecore 6.4.1 API
MediaCounters..::..MediaCacheMisses Property
MediaCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter MediaCacheMisses { get; }
Visual Basic
Public Shared ReadOnly Property MediaCacheMisses As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ MediaCacheMisses {
    PerformanceCounter^ get ();
}

Field Value

The number of cache misses.

See Also

MediaCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


StandardMediaCacheHits Property

[image]

Sitecore 6.4.1 API
MediaCounters..::..StandardMediaCacheHits Property
MediaCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public static PerformanceCounter StandardMediaCacheHits { get; }
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Shared ReadOnly Property StandardMediaCacheHits As PerformanceCounter
    Get
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public:
static property PerformanceCounter^ StandardMediaCacheHits {
    PerformanceCounter^ get ();
}

Field Value

The number of cache hits.

See Also

MediaCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


StandardMediaCacheMisses Property

[image]

Sitecore 6.4.1 API
MediaCounters..::..StandardMediaCacheMisses Property
MediaCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public static PerformanceCounter StandardMediaCacheMisses { get; }
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Shared ReadOnly Property StandardMediaCacheMisses As PerformanceCounter
    Get
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public:
static property PerformanceCounter^ StandardMediaCacheMisses {
    PerformanceCounter^ get ();
}

Field Value

The number of cache misses.

See Also

MediaCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


PerformanceCounter Class

[image]

Sitecore 6.4.1 API
PerformanceCounter Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PerformanceCounter
Visual Basic
Public Class PerformanceCounter
Visual C++
public ref class PerformanceCounter

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics.PerformanceCounters..::..PerformanceCounter

See Also

PerformanceCounter Members
Sitecore.Diagnostics.PerformanceCounters Namespace


PerformanceCounter Members

[image] [image]

Sitecore 6.4.1 API
PerformanceCounter Members
PerformanceCounter Class Constructors Methods Properties See Also Send Feedback

The PerformanceCounter type exposes the following members.

Constructors

 | Name | Description
Public method | PerformanceCounter(String, String) | Constructs an instance of PerformanceCounter
Public method | PerformanceCounter(String, String, PerformanceCounterInstanceType) | Initializes a new instance of the PerformanceCounter class.
Public method | PerformanceCounter(String, String, Boolean) | Constructs an instance of PerformanceCounter
Public method | PerformanceCounter(String, String, PerformanceCounterInstanceType, String) | Initializes a new instance of the PerformanceCounter class.
Public method | PerformanceCounter(String, String, Boolean, PerformanceCounterInstanceType, String) | Initializes a new instance of the PerformanceCounter class.

Methods

 | Name | Description
Public method | Decrement | Decrements the counter.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInstanceName | Obsolete. Gets the name of the instance.
 | GetRawValue | Obsolete. Gets the raw value of the specified counter.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Increment | Increments this instance.
Public method | IncrementBy | Increments this instance by the specified amount.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Resets this instance.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Category | Gets the category.
Public property | Enabled | Gets a value indicating whether this PerformanceCounter is enabled.
Public property | InstanceName | Gets or sets the name of the instance.
Public property | InstanceType | Gets the type of the instance.
Public property | Name | Gets the name.
Public property | Value | Gets the value.

See Also

PerformanceCounter Class
Sitecore.Diagnostics.PerformanceCounters Namespace


PerformanceCounter Constructor

[image] [image]

Sitecore 6.4.1 API
PerformanceCounter Constructor
PerformanceCounter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformanceCounter(String, String) | Constructs an instance of PerformanceCounter
Public method | PerformanceCounter(String, String, PerformanceCounterInstanceType) | Initializes a new instance of the PerformanceCounter class.
Public method | PerformanceCounter(String, String, Boolean) | Constructs an instance of PerformanceCounter
Public method | PerformanceCounter(String, String, PerformanceCounterInstanceType, String) | Initializes a new instance of the PerformanceCounter class.
Public method | PerformanceCounter(String, String, Boolean, PerformanceCounterInstanceType, String) | Initializes a new instance of the PerformanceCounter class.

See Also

PerformanceCounter Class
PerformanceCounter Members
Sitecore.Diagnostics.PerformanceCounters Namespace


PerformanceCounter Constructor (String, String)

[image]

Sitecore 6.4.1 API
PerformanceCounter Constructor (String, String)
PerformanceCounter Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PerformanceCounter(
    string counterName,
    string category
)
Visual Basic
Public Sub New ( _
    counterName As String, _
    category As String _
)
Visual C++
public:
PerformanceCounter(
    String^ counterName,
    String^ category
)

Parameters

counterName
Type: System..::..String
Name of the counter.
category
Type: System..::..String
The category.

See Also

PerformanceCounter Class
PerformanceCounter Overload
Sitecore.Diagnostics.PerformanceCounters Namespace


PerformanceCounter Constructor (String, String, PerformanceCounterInstanceType)

[image]

Sitecore 6.4.1 API
PerformanceCounter Constructor (String, String, PerformanceCounterInstanceType)
PerformanceCounter Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PerformanceCounter(
    string counterName,
    string category,
    PerformanceCounterInstanceType instanceType
)
Visual Basic
Public Sub New ( _
    counterName As String, _
    category As String, _
    instanceType As PerformanceCounterInstanceType _
)
Visual C++
public:
PerformanceCounter(
    String^ counterName,
    String^ category,
    PerformanceCounterInstanceType instanceType
)

Parameters

counterName
Type: System..::..String
Name of the counter.
category
Type: System..::..String
The category.
instanceType
Type: Sitecore.Diagnostics.PerformanceCounters..::..PerformanceCounterInstanceType
Type of the instance.

See Also

PerformanceCounter Class
PerformanceCounter Overload
Sitecore.Diagnostics.PerformanceCounters Namespace


PerformanceCounter Constructor (String, String, Boolean)

[image]

Sitecore 6.4.1 API
PerformanceCounter Constructor (String, String, Boolean)
PerformanceCounter Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PerformanceCounter(
    string counterName,
    string category,
    bool reset
)
Visual Basic
Public Sub New ( _
    counterName As String, _
    category As String, _
    reset As Boolean _
)
Visual C++
public:
PerformanceCounter(
    String^ counterName,
    String^ category,
    bool reset
)

Parameters

counterName
Type: System..::..String
Name of the counter.
category
Type: System..::..String
The category.
reset
Type: System..::..Boolean
if set to true, the counter will be reset before the first usage.

See Also

PerformanceCounter Class
PerformanceCounter Overload
Sitecore.Diagnostics.PerformanceCounters Namespace


PerformanceCounter Constructor (String, String, PerformanceCounterInstanceType, String)

[image]

Sitecore 6.4.1 API
PerformanceCounter Constructor (String, String, PerformanceCounterInstanceType, String)
PerformanceCounter Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PerformanceCounter(
    string counterName,
    string category,
    PerformanceCounterInstanceType instanceType,
    string instanceName
)
Visual Basic
Public Sub New ( _
    counterName As String, _
    category As String, _
    instanceType As PerformanceCounterInstanceType, _
    instanceName As String _
)
Visual C++
public:
PerformanceCounter(
    String^ counterName,
    String^ category,
    PerformanceCounterInstanceType instanceType,
    String^ instanceName
)

Parameters

counterName
Type: System..::..String
Name of the counter.
category
Type: System..::..String
The category.
instanceType
Type: Sitecore.Diagnostics.PerformanceCounters..::..PerformanceCounterInstanceType
Type of the instance.
instanceName
Type: System..::..String
Name of the instance.

See Also

PerformanceCounter Class
PerformanceCounter Overload
Sitecore.Diagnostics.PerformanceCounters Namespace


PerformanceCounter Constructor (String, String, Boolean, PerformanceCounterInstanceType, String)

[image]

Sitecore 6.4.1 API
PerformanceCounter Constructor (String, String, Boolean, PerformanceCounterInstanceType, String)
PerformanceCounter Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PerformanceCounter(
    string counterName,
    string category,
    bool reset,
    PerformanceCounterInstanceType instanceType,
    string instanceName
)
Visual Basic
Public Sub New ( _
    counterName As String, _
    category As String, _
    reset As Boolean, _
    instanceType As PerformanceCounterInstanceType, _
    instanceName As String _
)
Visual C++
public:
PerformanceCounter(
    String^ counterName,
    String^ category,
    bool reset,
    PerformanceCounterInstanceType instanceType,
    String^ instanceName
)

Parameters

counterName
Type: System..::..String
Name of the counter.
category
Type: System..::..String
The category.
reset
Type: System..::..Boolean
if set to true [reset].
instanceType
Type: Sitecore.Diagnostics.PerformanceCounters..::..PerformanceCounterInstanceType
Type of the instance.
instanceName
Type: System..::..String
Name of the instance.

See Also

PerformanceCounter Class
PerformanceCounter Overload
Sitecore.Diagnostics.PerformanceCounters Namespace


Decrement Method

[image]

Sitecore 6.4.1 API
PerformanceCounter..::..Decrement Method
PerformanceCounter Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long Decrement()
Visual Basic
Public Function Decrement As Long
Visual C++
public:
long long Decrement()

Return Value

[Missing <returns> documentation for "M:Sitecore.Diagnostics.PerformanceCounters.PerformanceCounter.Decrement"]

See Also

PerformanceCounter Class
Sitecore.Diagnostics.PerformanceCounters Namespace


GetInstanceName Method

[image]

Sitecore 6.4.1 API
PerformanceCounter..::..GetInstanceName Method
PerformanceCounter Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use non-static InstanceName instead")]
public static string GetInstanceName()
Visual Basic
<ObsoleteAttribute("Use non-static InstanceName instead")> _
Public Shared Function GetInstanceName As String
Visual C++
[ObsoleteAttribute(L"Use non-static InstanceName instead")]
public:
static String^ GetInstanceName()

Return Value

The instance name.

See Also

PerformanceCounter Class
Sitecore.Diagnostics.PerformanceCounters Namespace


GetRawValue Method

[image]

Sitecore 6.4.1 API
PerformanceCounter..::..GetRawValue Method
PerformanceCounter Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use non-static property Value instead")]
public static long GetRawValue(
    string category,
    string counterName
)
Visual Basic
<ObsoleteAttribute("Use non-static property Value instead")> _
Public Shared Function GetRawValue ( _
    category As String, _
    counterName As String _
) As Long
Visual C++
[ObsoleteAttribute(L"Use non-static property Value instead")]
public:
static long long GetRawValue(
    String^ category,
    String^ counterName
)

Parameters

category
Type: System..::..String
The category.
counterName
Type: System..::..String
Name of the counter.

Return Value

[Missing <returns> documentation for "M:Sitecore.Diagnostics.PerformanceCounters.PerformanceCounter.GetRawValue(System.String,System.String)"]

See Also

PerformanceCounter Class
Sitecore.Diagnostics.PerformanceCounters Namespace


Increment Method

[image]

Sitecore 6.4.1 API
PerformanceCounter..::..Increment Method
PerformanceCounter Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long Increment()
Visual Basic
Public Function Increment As Long
Visual C++
public:
long long Increment()

Return Value

[Missing <returns> documentation for "M:Sitecore.Diagnostics.PerformanceCounters.PerformanceCounter.Increment"]

See Also

PerformanceCounter Class
Sitecore.Diagnostics.PerformanceCounters Namespace


IncrementBy Method

[image]

Sitecore 6.4.1 API
PerformanceCounter..::..IncrementBy Method
PerformanceCounter Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long IncrementBy(
    int amount
)
Visual Basic
Public Function IncrementBy ( _
    amount As Integer _
) As Long
Visual C++
public:
long long IncrementBy(
    int amount
)

Parameters

amount
Type: System..::..Int32
The amount.

Return Value

[Missing <returns> documentation for "M:Sitecore.Diagnostics.PerformanceCounters.PerformanceCounter.IncrementBy(System.Int32)"]

See Also

PerformanceCounter Class
Sitecore.Diagnostics.PerformanceCounters Namespace


Reset Method

[image]

Sitecore 6.4.1 API
PerformanceCounter..::..Reset Method
PerformanceCounter Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset
Visual C++
public:
void Reset()

See Also

PerformanceCounter Class
Sitecore.Diagnostics.PerformanceCounters Namespace


ToString Method

[image]

Sitecore 6.4.1 API
PerformanceCounter..::..ToString Method
PerformanceCounter Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

PerformanceCounter Class
Sitecore.Diagnostics.PerformanceCounters Namespace


PerformanceCounter Properties

[image] [image]

Sitecore 6.4.1 API
PerformanceCounter Properties
PerformanceCounter Class See Also Send Feedback

The PerformanceCounter type exposes the following members.

Properties

 | Name | Description
Public property | Category | Gets the category.
Public property | Enabled | Gets a value indicating whether this PerformanceCounter is enabled.
Public property | InstanceName | Gets or sets the name of the instance.
Public property | InstanceType | Gets the type of the instance.
Public property | Name | Gets the name.
Public property | Value | Gets the value.

See Also

PerformanceCounter Class
Sitecore.Diagnostics.PerformanceCounters Namespace


Category Property

[image]

Sitecore 6.4.1 API
PerformanceCounter..::..Category Property
PerformanceCounter Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Category { get; }
Visual Basic
Public ReadOnly Property Category As String
    Get
Visual C++
public:
property String^ Category {
    String^ get ();
}

Field Value

The category.

See Also

PerformanceCounter Class
Sitecore.Diagnostics.PerformanceCounters Namespace


Enabled Property

[image]

Sitecore 6.4.1 API
PerformanceCounter..::..Enabled Property
PerformanceCounter Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Enabled { get; }
Visual Basic
Public ReadOnly Property Enabled As Boolean
    Get
Visual C++
public:
property bool Enabled {
    bool get ();
}

Field Value

true if enabled; otherwise, false.

See Also

PerformanceCounter Class
Sitecore.Diagnostics.PerformanceCounters Namespace


InstanceName Property

[image]

Sitecore 6.4.1 API
PerformanceCounter..::..InstanceName Property
PerformanceCounter Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string InstanceName { get; }
Visual Basic
Public ReadOnly Property InstanceName As String
    Get
Visual C++
public:
property String^ InstanceName {
    String^ get ();
}

Field Value

The name of the instance.

Exceptions

Exception | Condition
Sitecore.Diagnostics.PerformanceCounters..::..InstanceNameIsNotAvailableException | InstanceNameIsNotAvailableException.

See Also

PerformanceCounter Class
Sitecore.Diagnostics.PerformanceCounters Namespace


InstanceType Property

[image]

Sitecore 6.4.1 API
PerformanceCounter..::..InstanceType Property
PerformanceCounter Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PerformanceCounterInstanceType InstanceType { get; }
Visual Basic
Public ReadOnly Property InstanceType As PerformanceCounterInstanceType
    Get
Visual C++
public:
property PerformanceCounterInstanceType InstanceType {
    PerformanceCounterInstanceType get ();
}

Field Value

The type of the instance.

See Also

PerformanceCounter Class
Sitecore.Diagnostics.PerformanceCounters Namespace


Name Property

[image]

Sitecore 6.4.1 API
PerformanceCounter..::..Name Property
PerformanceCounter Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

PerformanceCounter Class
Sitecore.Diagnostics.PerformanceCounters Namespace


Value Property

[image]

Sitecore 6.4.1 API
PerformanceCounter..::..Value Property
PerformanceCounter Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long Value { get; }
Visual Basic
Public ReadOnly Property Value As Long
    Get
Visual C++
public:
property long long Value {
    long long get ();
}

Field Value

The value.

Exceptions

Exception | Condition
System..::..InvalidOperationException | InvalidOperationException.

See Also

PerformanceCounter Class
Sitecore.Diagnostics.PerformanceCounters Namespace


PipelineCounters Class

[image]

Sitecore 6.4.1 API
PipelineCounters Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class PipelineCounters
Visual Basic
Public NotInheritable Class PipelineCounters
Visual C++
public ref class PipelineCounters abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics.PerformanceCounters..::..PipelineCounters

See Also

PipelineCounters Members
Sitecore.Diagnostics.PerformanceCounters Namespace


PipelineCounters Members

[image] [image]

Sitecore 6.4.1 API
PipelineCounters Members
PipelineCounters Class Properties See Also Send Feedback

The PipelineCounters type exposes the following members.

Properties

Name | Description
PipelinesAborted | Gets the total number of times a pipeline was aborted.
PipelinesExecuted | Gets the total number of times a pipeline was executed.
ProcessorsExecuted | Gets the total number of processors that have been executed.

See Also

PipelineCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


PipelineCounters Properties

[image] [image]

Sitecore 6.4.1 API
PipelineCounters Properties
PipelineCounters Class See Also Send Feedback

The PipelineCounters type exposes the following members.

Properties

Name | Description
PipelinesAborted | Gets the total number of times a pipeline was aborted.
PipelinesExecuted | Gets the total number of times a pipeline was executed.
ProcessorsExecuted | Gets the total number of processors that have been executed.

See Also

PipelineCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


PipelinesAborted Property

[image]

Sitecore 6.4.1 API
PipelineCounters..::..PipelinesAborted Property
PipelineCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter PipelinesAborted { get; }
Visual Basic
Public Shared ReadOnly Property PipelinesAborted As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ PipelinesAborted {
    PerformanceCounter^ get ();
}

Field Value

The pipelines aborted.

See Also

PipelineCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


PipelinesExecuted Property

[image]

Sitecore 6.4.1 API
PipelineCounters..::..PipelinesExecuted Property
PipelineCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter PipelinesExecuted { get; }
Visual Basic
Public Shared ReadOnly Property PipelinesExecuted As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ PipelinesExecuted {
    PerformanceCounter^ get ();
}

Field Value

The pipelines executed.

See Also

PipelineCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


ProcessorsExecuted Property

[image]

Sitecore 6.4.1 API
PipelineCounters..::..ProcessorsExecuted Property
PipelineCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter ProcessorsExecuted { get; }
Visual Basic
Public Shared ReadOnly Property ProcessorsExecuted As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ ProcessorsExecuted {
    PerformanceCounter^ get ();
}

Field Value

The processors executed.

See Also

PipelineCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


PublishingCounters Class

[image]

Sitecore 6.4.1 API
PublishingCounters Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class PublishingCounters
Visual Basic
Public NotInheritable Class PublishingCounters
Visual C++
public ref class PublishingCounters abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics.PerformanceCounters..::..PublishingCounters

See Also

PublishingCounters Members
Sitecore.Diagnostics.PerformanceCounters Namespace


PublishingCounters Members

[image] [image]

Sitecore 6.4.1 API
PublishingCounters Members
PublishingCounters Class Properties See Also Send Feedback

The PublishingCounters type exposes the following members.

Properties

Name | Description
FullPublishings | Gets the total number of times a full publishing operation has been performed.
IncrementalPublishings | Gets the total number of times an incremental publishing operation has been performed.
ItemPublishings | Gets the total number of times an item publishing operation has been performed.
ItemsExamined | Gets the total number of items that have been examined as candidates for publishing.
ItemsPublished | Gets the total number of items that have been published to the web site.
ItemsQueued | Gets the total number of items that have been queued for publishing.
PublishReplacements | Gets the total number of publishing replacement operations that have been performed.
SmartPublishings | Gets the total number of times a smart publishing operation has been performed.
TotalPublishings | Gets the total number of publishings that have been performed.

See Also

PublishingCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


PublishingCounters Properties

[image] [image]

Sitecore 6.4.1 API
PublishingCounters Properties
PublishingCounters Class See Also Send Feedback

The PublishingCounters type exposes the following members.

Properties

Name | Description
FullPublishings | Gets the total number of times a full publishing operation has been performed.
IncrementalPublishings | Gets the total number of times an incremental publishing operation has been performed.
ItemPublishings | Gets the total number of times an item publishing operation has been performed.
ItemsExamined | Gets the total number of items that have been examined as candidates for publishing.
ItemsPublished | Gets the total number of items that have been published to the web site.
ItemsQueued | Gets the total number of items that have been queued for publishing.
PublishReplacements | Gets the total number of publishing replacement operations that have been performed.
SmartPublishings | Gets the total number of times a smart publishing operation has been performed.
TotalPublishings | Gets the total number of publishings that have been performed.

See Also

PublishingCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


FullPublishings Property

[image]

Sitecore 6.4.1 API
PublishingCounters..::..FullPublishings Property
PublishingCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter FullPublishings { get; }
Visual Basic
Public Shared ReadOnly Property FullPublishings As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ FullPublishings {
    PerformanceCounter^ get ();
}

Field Value

The full publishings.

See Also

PublishingCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


IncrementalPublishings Property

[image]

Sitecore 6.4.1 API
PublishingCounters..::..IncrementalPublishings Property
PublishingCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter IncrementalPublishings { get; }
Visual Basic
Public Shared ReadOnly Property IncrementalPublishings As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ IncrementalPublishings {
    PerformanceCounter^ get ();
}

Field Value

The incremental publishings.

See Also

PublishingCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


ItemPublishings Property

[image]

Sitecore 6.4.1 API
PublishingCounters..::..ItemPublishings Property
PublishingCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter ItemPublishings { get; }
Visual Basic
Public Shared ReadOnly Property ItemPublishings As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ ItemPublishings {
    PerformanceCounter^ get ();
}

Field Value

The item publishings.

See Also

PublishingCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


ItemsExamined Property

[image]

Sitecore 6.4.1 API
PublishingCounters..::..ItemsExamined Property
PublishingCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter ItemsExamined { get; }
Visual Basic
Public Shared ReadOnly Property ItemsExamined As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ ItemsExamined {
    PerformanceCounter^ get ();
}

Field Value

The items examined.

See Also

PublishingCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


ItemsPublished Property

[image]

Sitecore 6.4.1 API
PublishingCounters..::..ItemsPublished Property
PublishingCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter ItemsPublished { get; }
Visual Basic
Public Shared ReadOnly Property ItemsPublished As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ ItemsPublished {
    PerformanceCounter^ get ();
}

Field Value

The items published.

See Also

PublishingCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


ItemsQueued Property

[image]

Sitecore 6.4.1 API
PublishingCounters..::..ItemsQueued Property
PublishingCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter ItemsQueued { get; }
Visual Basic
Public Shared ReadOnly Property ItemsQueued As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ ItemsQueued {
    PerformanceCounter^ get ();
}

Field Value

The items queued.

See Also

PublishingCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


PublishReplacements Property

[image]

Sitecore 6.4.1 API
PublishingCounters..::..PublishReplacements Property
PublishingCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter PublishReplacements { get; }
Visual Basic
Public Shared ReadOnly Property PublishReplacements As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ PublishReplacements {
    PerformanceCounter^ get ();
}

Field Value

The publish replacements.

See Also

PublishingCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


TotalPublishings Property

[image]

Sitecore 6.4.1 API
PublishingCounters..::..TotalPublishings Property
PublishingCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter TotalPublishings { get; }
Visual Basic
Public Shared ReadOnly Property TotalPublishings As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ TotalPublishings {
    PerformanceCounter^ get ();
}

Field Value

The total publishings.

See Also

PublishingCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


ReflectionCounters Class

[image]

Sitecore 6.4.1 API
ReflectionCounters Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class ReflectionCounters
Visual Basic
Public NotInheritable Class ReflectionCounters
Visual C++
public ref class ReflectionCounters abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics.PerformanceCounters..::..ReflectionCounters

See Also

ReflectionCounters Members
Sitecore.Diagnostics.PerformanceCounters Namespace


ReflectionCounters Members

[image] [image]

Sitecore 6.4.1 API
ReflectionCounters Members
ReflectionCounters Class Properties See Also Send Feedback

The ReflectionCounters type exposes the following members.

Properties

Name | Description
MethodsInvoked | Gets the total number of methods that have been invoked through reflection.
ObjectsCreated | Gets the total number of objects that have been created using reflection.
ObjectsNotCreated | Gets the total number of objects where the creation through reflection failed (due to unknown types or constructors).
TypesNotResolved | Gets the total number of types where the resolving through reflection failed (due to unknown types or other causes).
TypesResolved | Gets the total number of types that have been resolved using reflection.

See Also

ReflectionCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


ReflectionCounters Properties

[image] [image]

Sitecore 6.4.1 API
ReflectionCounters Properties
ReflectionCounters Class See Also Send Feedback

The ReflectionCounters type exposes the following members.

Properties

Name | Description
MethodsInvoked | Gets the total number of methods that have been invoked through reflection.
ObjectsCreated | Gets the total number of objects that have been created using reflection.
ObjectsNotCreated | Gets the total number of objects where the creation through reflection failed (due to unknown types or constructors).
TypesNotResolved | Gets the total number of types where the resolving through reflection failed (due to unknown types or other causes).
TypesResolved | Gets the total number of types that have been resolved using reflection.

See Also

ReflectionCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


MethodsInvoked Property

[image]

Sitecore 6.4.1 API
ReflectionCounters..::..MethodsInvoked Property
ReflectionCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter MethodsInvoked { get; }
Visual Basic
Public Shared ReadOnly Property MethodsInvoked As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ MethodsInvoked {
    PerformanceCounter^ get ();
}

Field Value

The methods invoked.

See Also

ReflectionCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


ObjectsCreated Property

[image]

Sitecore 6.4.1 API
ReflectionCounters..::..ObjectsCreated Property
ReflectionCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter ObjectsCreated { get; }
Visual Basic
Public Shared ReadOnly Property ObjectsCreated As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ ObjectsCreated {
    PerformanceCounter^ get ();
}

Field Value

The objects created.

See Also

ReflectionCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


ObjectsNotCreated Property

[image]

Sitecore 6.4.1 API
ReflectionCounters..::..ObjectsNotCreated Property
ReflectionCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter ObjectsNotCreated { get; }
Visual Basic
Public Shared ReadOnly Property ObjectsNotCreated As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ ObjectsNotCreated {
    PerformanceCounter^ get ();
}

Field Value

The objects not created.

See Also

ReflectionCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


TypesResolved Property

[image]

Sitecore 6.4.1 API
ReflectionCounters..::..TypesResolved Property
ReflectionCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter TypesResolved { get; }
Visual Basic
Public Shared ReadOnly Property TypesResolved As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ TypesResolved {
    PerformanceCounter^ get ();
}

Field Value

The types resolved.

See Also

ReflectionCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


RenderingCounters Class

[image]

Sitecore 6.4.1 API
RenderingCounters Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class RenderingCounters
Visual Basic
Public NotInheritable Class RenderingCounters
Visual C++
public ref class RenderingCounters abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics.PerformanceCounters..::..RenderingCounters

See Also

RenderingCounters Members
Sitecore.Diagnostics.PerformanceCounters Namespace


RenderingCounters Members

[image] [image]

Sitecore 6.4.1 API
RenderingCounters Members
RenderingCounters Class Properties See Also Send Feedback

The RenderingCounters type exposes the following members.

Properties

Name | Description
ControlsRendered | Gets the total number of Sitecore controls rendered.
ControlsRenderedFromCache | Gets the total number of Sitecore controls rendered from a cache.
PagesGenerated | Gets the total number of web pages generated by Sitecore.
RenderingsRendered | Gets the total number of Renderings rendered.
SublayoutsRendered | Gets the total number of Sublayouts rendered.
XamlControlsCompiled | Gets the total number of XamlControls compiled.
XmlControlsCompiled | Gets the total number of XmlControls compiled.
XslTransformsRendered | Gets the total number of XslTransforms rendered.

See Also

RenderingCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


RenderingCounters Properties

[image] [image]

Sitecore 6.4.1 API
RenderingCounters Properties
RenderingCounters Class See Also Send Feedback

The RenderingCounters type exposes the following members.

Properties

Name | Description
ControlsRendered | Gets the total number of Sitecore controls rendered.
ControlsRenderedFromCache | Gets the total number of Sitecore controls rendered from a cache.
PagesGenerated | Gets the total number of web pages generated by Sitecore.
RenderingsRendered | Gets the total number of Renderings rendered.
SublayoutsRendered | Gets the total number of Sublayouts rendered.
XamlControlsCompiled | Gets the total number of XamlControls compiled.
XmlControlsCompiled | Gets the total number of XmlControls compiled.
XslTransformsRendered | Gets the total number of XslTransforms rendered.

See Also

RenderingCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


ControlsRendered Property

[image]

Sitecore 6.4.1 API
RenderingCounters..::..ControlsRendered Property
RenderingCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter ControlsRendered { get; }
Visual Basic
Public Shared ReadOnly Property ControlsRendered As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ ControlsRendered {
    PerformanceCounter^ get ();
}

Field Value

The controls rendered.

Remarks

Sitecore controls include Renderings, Sublayouts, XmlControls and XslTransforms.

See Also

RenderingCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


ControlsRenderedFromCache Property

[image]

Sitecore 6.4.1 API
RenderingCounters..::..ControlsRenderedFromCache Property
RenderingCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter ControlsRenderedFromCache { get; }
Visual Basic
Public Shared ReadOnly Property ControlsRenderedFromCache As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ ControlsRenderedFromCache {
    PerformanceCounter^ get ();
}

Field Value

The controls rendered from cache.

Remarks

Sitecore controls include Renderings, Sublayouts, XmlControls and XslTransforms.

See Also

RenderingCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


PagesGenerated Property

[image]

Sitecore 6.4.1 API
RenderingCounters..::..PagesGenerated Property
RenderingCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter PagesGenerated { get; }
Visual Basic
Public Shared ReadOnly Property PagesGenerated As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ PagesGenerated {
    PerformanceCounter^ get ();
}

Field Value

The pages generated.

See Also

RenderingCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


RenderingsRendered Property

[image]

Sitecore 6.4.1 API
RenderingCounters..::..RenderingsRendered Property
RenderingCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter RenderingsRendered { get; }
Visual Basic
Public Shared ReadOnly Property RenderingsRendered As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ RenderingsRendered {
    PerformanceCounter^ get ();
}

Field Value

The renderings rendered.

See Also

RenderingCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


SublayoutsRendered Property

[image]

Sitecore 6.4.1 API
RenderingCounters..::..SublayoutsRendered Property
RenderingCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter SublayoutsRendered { get; }
Visual Basic
Public Shared ReadOnly Property SublayoutsRendered As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ SublayoutsRendered {
    PerformanceCounter^ get ();
}

Field Value

The sublayouts rendered.

See Also

RenderingCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


XamlControlsCompiled Property

[image]

Sitecore 6.4.1 API
RenderingCounters..::..XamlControlsCompiled Property
RenderingCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter XamlControlsCompiled { get; }
Visual Basic
Public Shared ReadOnly Property XamlControlsCompiled As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ XamlControlsCompiled {
    PerformanceCounter^ get ();
}

Field Value

The Xaml controls compiled.

See Also

RenderingCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


XmlControlsCompiled Property

[image]

Sitecore 6.4.1 API
RenderingCounters..::..XmlControlsCompiled Property
RenderingCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter XmlControlsCompiled { get; }
Visual Basic
Public Shared ReadOnly Property XmlControlsCompiled As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ XmlControlsCompiled {
    PerformanceCounter^ get ();
}

Field Value

The XML controls compiled.

See Also

RenderingCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


XslTransformsRendered Property

[image]

Sitecore 6.4.1 API
RenderingCounters..::..XslTransformsRendered Property
RenderingCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter XslTransformsRendered { get; }
Visual Basic
Public Shared ReadOnly Property XslTransformsRendered As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ XslTransformsRendered {
    PerformanceCounter^ get ();
}

Field Value

The XSL transforms rendered.

See Also

RenderingCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


SecurityCounters Class

[image]

Sitecore 6.4.1 API
SecurityCounters Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class SecurityCounters
Visual Basic
Public NotInheritable Class SecurityCounters
Visual C++
public ref class SecurityCounters abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics.PerformanceCounters..::..SecurityCounters

See Also

SecurityCounters Members
Sitecore.Diagnostics.PerformanceCounters Namespace


SecurityCounters Members

[image] [image]

Sitecore 6.4.1 API
SecurityCounters Members
SecurityCounters Class Properties See Also Send Feedback

The SecurityCounters type exposes the following members.

Properties

Name | Description
AccessDenied | Gets the total number of access requests that have been denied.
AccessGranted | Gets the total number of access requests that have been granted.
AccessResolved | Gets the total number of access requests that have been resolved.
ModifyRequests | Gets the total number of access requests where the desired access would allow the caller to modify data (ie. update or delete an item).
ProgrammaticDisabling | Gets the total number of times that security has been programmatically disabled (using SecurityDisabler).
ProgrammaticEnabling | Gets the total number of times that security has been programmatically enabled (using SecurityEnabler).
ProgrammaticUserSwitch | Gets the total number of times that the current user has been switched programmatically (using UserSwitcher).
ReadRequests | Gets the total number of access requests where the desired access would allow the caller to read data (ie. reading an item).
ResolvedRoles | Gets the total number of roles that have been resolved.
ResolvedUsers | Gets the total number of users that have been resolved.
VirtualUsersBuilt | Gets the total number of virutal users that have been built.

See Also

SecurityCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


AccessDenied Property

[image]

Sitecore 6.4.1 API
SecurityCounters..::..AccessDenied Property
SecurityCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter AccessDenied { get; }
Visual Basic
Public Shared ReadOnly Property AccessDenied As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ AccessDenied {
    PerformanceCounter^ get ();
}

Field Value

The access denied.

See Also

SecurityCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


AccessGranted Property

[image]

Sitecore 6.4.1 API
SecurityCounters..::..AccessGranted Property
SecurityCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter AccessGranted { get; }
Visual Basic
Public Shared ReadOnly Property AccessGranted As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ AccessGranted {
    PerformanceCounter^ get ();
}

Field Value

The access granted.

See Also

SecurityCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


AccessResolved Property

[image]

Sitecore 6.4.1 API
SecurityCounters..::..AccessResolved Property
SecurityCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter AccessResolved { get; }
Visual Basic
Public Shared ReadOnly Property AccessResolved As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ AccessResolved {
    PerformanceCounter^ get ();
}

Field Value

The access resolved.

See Also

SecurityCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


ModifyRequests Property

[image]

Sitecore 6.4.1 API
SecurityCounters..::..ModifyRequests Property
SecurityCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter ModifyRequests { get; }
Visual Basic
Public Shared ReadOnly Property ModifyRequests As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ ModifyRequests {
    PerformanceCounter^ get ();
}

Field Value

The modify requests.

See Also

SecurityCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


ProgrammaticDisabling Property

[image]

Sitecore 6.4.1 API
SecurityCounters..::..ProgrammaticDisabling Property
SecurityCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter ProgrammaticDisabling { get; }
Visual Basic
Public Shared ReadOnly Property ProgrammaticDisabling As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ ProgrammaticDisabling {
    PerformanceCounter^ get ();
}

Field Value

The programmatic disabling.

See Also

SecurityCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


ProgrammaticEnabling Property

[image]

Sitecore 6.4.1 API
SecurityCounters..::..ProgrammaticEnabling Property
SecurityCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter ProgrammaticEnabling { get; }
Visual Basic
Public Shared ReadOnly Property ProgrammaticEnabling As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ ProgrammaticEnabling {
    PerformanceCounter^ get ();
}

Field Value

The programmatic enabling.

See Also

SecurityCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


ProgrammaticUserSwitch Property

[image]

Sitecore 6.4.1 API
SecurityCounters..::..ProgrammaticUserSwitch Property
SecurityCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter ProgrammaticUserSwitch { get; }
Visual Basic
Public Shared ReadOnly Property ProgrammaticUserSwitch As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ ProgrammaticUserSwitch {
    PerformanceCounter^ get ();
}

Field Value

The programmatic user switch.

See Also

SecurityCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


ReadRequests Property

[image]

Sitecore 6.4.1 API
SecurityCounters..::..ReadRequests Property
SecurityCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter ReadRequests { get; }
Visual Basic
Public Shared ReadOnly Property ReadRequests As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ ReadRequests {
    PerformanceCounter^ get ();
}

Field Value

The read requests.

See Also

SecurityCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


ResolvedUsers Property

[image]

Sitecore 6.4.1 API
SecurityCounters..::..ResolvedUsers Property
SecurityCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter ResolvedUsers { get; }
Visual Basic
Public Shared ReadOnly Property ResolvedUsers As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ ResolvedUsers {
    PerformanceCounter^ get ();
}

Field Value

The resolved users.

See Also

SecurityCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


ShadowCounters Class

[image]

Sitecore 6.4.1 API
ShadowCounters Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class ShadowCounters
Visual Basic
Public NotInheritable Class ShadowCounters
Visual C++
public ref class ShadowCounters abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics.PerformanceCounters..::..ShadowCounters

See Also

ShadowCounters Members
Sitecore.Diagnostics.PerformanceCounters Namespace


ShadowCounters Members

[image] [image]

Sitecore 6.4.1 API
ShadowCounters Members
ShadowCounters Class Properties See Also Send Feedback

The ShadowCounters type exposes the following members.

Properties

Name | Description
DataRead | Gets the total number of read operations that have been performed against the shadows database.
DataUpdated | Gets the total number of update operations that have been performed against the shadows database.

See Also

ShadowCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


ShadowCounters Properties

[image] [image]

Sitecore 6.4.1 API
ShadowCounters Properties
ShadowCounters Class See Also Send Feedback

The ShadowCounters type exposes the following members.

Properties

Name | Description
DataRead | Gets the total number of read operations that have been performed against the shadows database.
DataUpdated | Gets the total number of update operations that have been performed against the shadows database.

See Also

ShadowCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


DataRead Property

[image]

Sitecore 6.4.1 API
ShadowCounters..::..DataRead Property
ShadowCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter DataRead { get; }
Visual Basic
Public Shared ReadOnly Property DataRead As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ DataRead {
    PerformanceCounter^ get ();
}

Field Value

The data read.

See Also

ShadowCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


TaskCounters Class

[image]

Sitecore 6.4.1 API
TaskCounters Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class TaskCounters
Visual Basic
Public NotInheritable Class TaskCounters
Visual C++
public ref class TaskCounters abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics.PerformanceCounters..::..TaskCounters

See Also

TaskCounters Members
Sitecore.Diagnostics.PerformanceCounters Namespace


TaskCounters Members

[image] [image]

Sitecore 6.4.1 API
TaskCounters Members
TaskCounters Class Properties See Also Send Feedback

The TaskCounters type exposes the following members.

Properties

Name | Description
FileCleanups | Gets the total number of times the CleanupAgent task has been run.
HtmlCacheClearings | Gets the total number of times the HtmlCacheClearAgent task has been run.
ItemsArchived | Gets the total number of items that have been archived.
Publishings | Gets the total number of times the PublishAgent task has been run.
RemindersSent | Gets the total number of reminders that have been sent.
TasksExecuted | Gets the total number of tasks that has been run.

See Also

TaskCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


TaskCounters Properties

[image] [image]

Sitecore 6.4.1 API
TaskCounters Properties
TaskCounters Class See Also Send Feedback

The TaskCounters type exposes the following members.

Properties

Name | Description
FileCleanups | Gets the total number of times the CleanupAgent task has been run.
HtmlCacheClearings | Gets the total number of times the HtmlCacheClearAgent task has been run.
ItemsArchived | Gets the total number of items that have been archived.
Publishings | Gets the total number of times the PublishAgent task has been run.
RemindersSent | Gets the total number of reminders that have been sent.
TasksExecuted | Gets the total number of tasks that has been run.

See Also

TaskCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


FileCleanups Property

[image]

Sitecore 6.4.1 API
TaskCounters..::..FileCleanups Property
TaskCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter FileCleanups { get; }
Visual Basic
Public Shared ReadOnly Property FileCleanups As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ FileCleanups {
    PerformanceCounter^ get ();
}

Field Value

The file cleanups.

See Also

TaskCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


HtmlCacheClearings Property

[image]

Sitecore 6.4.1 API
TaskCounters..::..HtmlCacheClearings Property
TaskCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter HtmlCacheClearings { get; }
Visual Basic
Public Shared ReadOnly Property HtmlCacheClearings As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ HtmlCacheClearings {
    PerformanceCounter^ get ();
}

Field Value

The HTML cache clearings.

See Also

TaskCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


ItemsArchived Property

[image]

Sitecore 6.4.1 API
TaskCounters..::..ItemsArchived Property
TaskCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter ItemsArchived { get; }
Visual Basic
Public Shared ReadOnly Property ItemsArchived As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ ItemsArchived {
    PerformanceCounter^ get ();
}

Field Value

The items archived.

See Also

TaskCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


Publishings Property

[image]

Sitecore 6.4.1 API
TaskCounters..::..Publishings Property
TaskCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter Publishings { get; }
Visual Basic
Public Shared ReadOnly Property Publishings As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ Publishings {
    PerformanceCounter^ get ();
}

Field Value

The publishings.

See Also

TaskCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


RemindersSent Property

[image]

Sitecore 6.4.1 API
TaskCounters..::..RemindersSent Property
TaskCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter RemindersSent { get; }
Visual Basic
Public Shared ReadOnly Property RemindersSent As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ RemindersSent {
    PerformanceCounter^ get ();
}

Field Value

The reminders sent.

See Also

TaskCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


TasksExecuted Property

[image]

Sitecore 6.4.1 API
TaskCounters..::..TasksExecuted Property
TaskCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter TasksExecuted { get; }
Visual Basic
Public Shared ReadOnly Property TasksExecuted As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ TasksExecuted {
    PerformanceCounter^ get ();
}

Field Value

The tasks executed.

See Also

TaskCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


ThreadingCounters Class

[image]

Sitecore 6.4.1 API
ThreadingCounters Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class ThreadingCounters
Visual Basic
Public NotInheritable Class ThreadingCounters
Visual C++
public ref class ThreadingCounters abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics.PerformanceCounters..::..ThreadingCounters

See Also

ThreadingCounters Members
Sitecore.Diagnostics.PerformanceCounters Namespace


ThreadingCounters Members

[image] [image]

Sitecore 6.4.1 API
ThreadingCounters Members
ThreadingCounters Class Properties See Also Send Feedback

The ThreadingCounters type exposes the following members.

Properties

Name | Description
BackgroundThreadsStarted | Gets the total number of background threads that have been started by the API.
ThreadDataModified | Gets the total number of times data in a thread local storage (TLS) slot have been modified.
ThreadDataRead | Gets the total number of times data in a thread local storage (TLS) slot have been read.

See Also

ThreadingCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


ThreadingCounters Properties

[image] [image]

Sitecore 6.4.1 API
ThreadingCounters Properties
ThreadingCounters Class See Also Send Feedback

The ThreadingCounters type exposes the following members.

Properties

Name | Description
BackgroundThreadsStarted | Gets the total number of background threads that have been started by the API.
ThreadDataModified | Gets the total number of times data in a thread local storage (TLS) slot have been modified.
ThreadDataRead | Gets the total number of times data in a thread local storage (TLS) slot have been read.

See Also

ThreadingCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


BackgroundThreadsStarted Property

[image]

Sitecore 6.4.1 API
ThreadingCounters..::..BackgroundThreadsStarted Property
ThreadingCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter BackgroundThreadsStarted { get; }
Visual Basic
Public Shared ReadOnly Property BackgroundThreadsStarted As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ BackgroundThreadsStarted {
    PerformanceCounter^ get ();
}

Field Value

The background threads started.

See Also

ThreadingCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


ThreadDataModified Property

[image]

Sitecore 6.4.1 API
ThreadingCounters..::..ThreadDataModified Property
ThreadingCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter ThreadDataModified { get; }
Visual Basic
Public Shared ReadOnly Property ThreadDataModified As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ ThreadDataModified {
    PerformanceCounter^ get ();
}

Field Value

The thread data modified.

See Also

ThreadingCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


ThreadDataRead Property

[image]

Sitecore 6.4.1 API
ThreadingCounters..::..ThreadDataRead Property
ThreadingCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter ThreadDataRead { get; }
Visual Basic
Public Shared ReadOnly Property ThreadDataRead As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ ThreadDataRead {
    PerformanceCounter^ get ();
}

Field Value

The thread data read.

See Also

ThreadingCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


WorkflowCounters Class

[image]

Sitecore 6.4.1 API
WorkflowCounters Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class WorkflowCounters
Visual Basic
Public NotInheritable Class WorkflowCounters
Visual C++
public ref class WorkflowCounters abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics.PerformanceCounters..::..WorkflowCounters

See Also

WorkflowCounters Members
Sitecore.Diagnostics.PerformanceCounters Namespace


WorkflowCounters Members

[image] [image]

Sitecore 6.4.1 API
WorkflowCounters Members
WorkflowCounters Class Properties See Also Send Feedback

The WorkflowCounters type exposes the following members.

Properties

Name | Description
ActionsExecuted | Gets the total number of workflow actions that have been executed.
SecurityResolved | Gets the total number of times the workflow engine has resolved an access request.
StateChanges | Gets the total number of times that a workflow has changed state.

See Also

WorkflowCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


WorkflowCounters Properties

[image] [image]

Sitecore 6.4.1 API
WorkflowCounters Properties
WorkflowCounters Class See Also Send Feedback

The WorkflowCounters type exposes the following members.

Properties

Name | Description
ActionsExecuted | Gets the total number of workflow actions that have been executed.
SecurityResolved | Gets the total number of times the workflow engine has resolved an access request.
StateChanges | Gets the total number of times that a workflow has changed state.

See Also

WorkflowCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


SecurityResolved Property

[image]

Sitecore 6.4.1 API
WorkflowCounters..::..SecurityResolved Property
WorkflowCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter SecurityResolved { get; }
Visual Basic
Public Shared ReadOnly Property SecurityResolved As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ SecurityResolved {
    PerformanceCounter^ get ();
}

Field Value

The security resolved.

See Also

WorkflowCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


StateChanges Property

[image]

Sitecore 6.4.1 API
WorkflowCounters..::..StateChanges Property
WorkflowCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter StateChanges { get; }
Visual Basic
Public Shared ReadOnly Property StateChanges As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ StateChanges {
    PerformanceCounter^ get ();
}

Field Value

The state changes.

See Also

WorkflowCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


XmlCounters Class

[image]

Sitecore 6.4.1 API
XmlCounters Class
Members See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class XmlCounters
Visual Basic
Public NotInheritable Class XmlCounters
Visual C++
public ref class XmlCounters abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Diagnostics.PerformanceCounters..::..XmlCounters

See Also

XmlCounters Members
Sitecore.Diagnostics.PerformanceCounters Namespace


XmlCounters Members

[image] [image]

Sitecore 6.4.1 API
XmlCounters Members
XmlCounters Class Properties See Also Send Feedback

The XmlCounters type exposes the following members.

Properties

Name | Description
ItemNavigatorsCreated | Gets the total number of ItemNavigator instances that have been created.
PacketsCreated | Gets the total number of Packet instances that have been created.

See Also

XmlCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


XmlCounters Properties

[image] [image]

Sitecore 6.4.1 API
XmlCounters Properties
XmlCounters Class See Also Send Feedback

The XmlCounters type exposes the following members.

Properties

Name | Description
ItemNavigatorsCreated | Gets the total number of ItemNavigator instances that have been created.
PacketsCreated | Gets the total number of Packet instances that have been created.

See Also

XmlCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


ItemNavigatorsCreated Property

[image]

Sitecore 6.4.1 API
XmlCounters..::..ItemNavigatorsCreated Property
XmlCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter ItemNavigatorsCreated { get; }
Visual Basic
Public Shared ReadOnly Property ItemNavigatorsCreated As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ ItemNavigatorsCreated {
    PerformanceCounter^ get ();
}

Field Value

The item navigators created.

See Also

XmlCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


PacketsCreated Property

[image]

Sitecore 6.4.1 API
XmlCounters..::..PacketsCreated Property
XmlCounters Class See Also Send Feedback

Namespace: Sitecore.Diagnostics.PerformanceCounters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PerformanceCounter PacketsCreated { get; }
Visual Basic
Public Shared ReadOnly Property PacketsCreated As PerformanceCounter
    Get
Visual C++
public:
static property PerformanceCounter^ PacketsCreated {
    PerformanceCounter^ get ();
}

Field Value

The packets created.

See Also

XmlCounters Class
Sitecore.Diagnostics.PerformanceCounters Namespace


Reader Class

[image]

Sitecore 6.4.1 API
Reader Class
Members See Also Send Feedback

Namespace: Sitecore.Drawing.Exif
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Reader
Visual Basic
Public Class Reader
Visual C++
public ref class Reader

Inheritance Hierarchy

System..::..Object
Sitecore.Drawing.Exif..::..Reader

See Also

Reader Members
Sitecore.Drawing.Exif Namespace


Reader Members

[image] [image]

Sitecore 6.4.1 API
Reader Members
Reader Class Constructors Methods Properties See Also Send Feedback

The Reader type exposes the following members.

Constructors

 | Name | Description
Public method | Reader(Image) | Initializes a new instance of the Reader class.
Public method | Reader(String) | Initializes a new instance of the Reader class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMakeProperty | The manufacturer of the recording equipment. This is the manufacturer of the DSC, scanner, video digitizer or other equipment that generated the image. When the field is left blank it is treated as unknown.
Public method | GetProperty | Gets the property.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasProperty | Determines whether the specified tag id has property.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Parses the specified image.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the count.
Public property | Item | Gets the Property at the specified index.
Public property | Properties | Gets the properties.

See Also

Reader Class
Sitecore.Drawing.Exif Namespace


Reader Constructor (Image)

[image]

Sitecore 6.4.1 API
Reader Constructor (Image)
Reader Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Reader(
    Image image
)
Visual Basic
Public Sub New ( _
    image As Image _
)
Visual C++
public:
Reader(
    Image^ image
)

Parameters

image
Type: System.Drawing..::..Image
The image.

See Also

Reader Class
Reader Overload
Sitecore.Drawing.Exif Namespace


Reader Constructor (String)

[image]

Sitecore 6.4.1 API
Reader Constructor (String)
Reader Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Reader(
    string filename
)
Visual Basic
Public Sub New ( _
    filename As String _
)
Visual C++
public:
Reader(
    String^ filename
)

Parameters

filename
Type: System..::..String
The filename.

See Also

Reader Class
Reader Overload
Sitecore.Drawing.Exif Namespace


Reader Methods

[image] [image]

Sitecore 6.4.1 API
Reader Methods
Reader Class See Also Send Feedback

The Reader type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMakeProperty | The manufacturer of the recording equipment. This is the manufacturer of the DSC, scanner, video digitizer or other equipment that generated the image. When the field is left blank it is treated as unknown.
Public method | GetProperty | Gets the property.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasProperty | Determines whether the specified tag id has property.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Parses the specified image.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reader Class
Sitecore.Drawing.Exif Namespace


HasProperty Method

[image]

Sitecore 6.4.1 API
Reader..::..HasProperty Method
Reader Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool HasProperty(
    int TagId
)
Visual Basic
Public Function HasProperty ( _
    TagId As Integer _
) As Boolean
Visual C++
public:
bool HasProperty(
    int TagId
)

Parameters

TagId
Type: System..::..Int32
The tag id.

Return Value

true if the specified tag id has property; otherwise, false.

See Also

Reader Class
Sitecore.Drawing.Exif Namespace


Parse Method

[image]

Sitecore 6.4.1 API
Reader..::..Parse Method
Reader Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Reader Parse(
    Image image
)
Visual Basic
Public Shared Function Parse ( _
    image As Image _
) As Reader
Visual C++
public:
static Reader^ Parse(
    Image^ image
)

Parameters

image
Type: System.Drawing..::..Image
The image.

Return Value

[Missing <returns> documentation for "M:Sitecore.Drawing.Exif.Reader.Parse(System.Drawing.Image)"]

See Also

Reader Class
Sitecore.Drawing.Exif Namespace


Reader Properties

[image] [image]

Sitecore 6.4.1 API
Reader Properties
Reader Class See Also Send Feedback

The Reader type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the count.
Public property | Item | Gets the Property at the specified index.
Public property | Properties | Gets the properties.

See Also

Reader Class
Sitecore.Drawing.Exif Namespace


Count Property

[image]

Sitecore 6.4.1 API
Reader..::..Count Property
Reader Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
property int Count {
    int get ();
}

Field Value

The count.

See Also

Reader Class
Sitecore.Drawing.Exif Namespace


Item Property

[image]

Sitecore 6.4.1 API
Reader..::..Item Property
Reader Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Property this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    index As Integer _
) As Property
    Get
Visual C++
public:
property Property^ default[int index] {
    Property^ get (int index);
}

Parameters

index
Type: System..::..Int32

Field Value

See Also

Reader Class
Sitecore.Drawing.Exif Namespace


Properties Property

[image]

Sitecore 6.4.1 API
Reader..::..Properties Property
Reader Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public List<Property> Properties { get; }
Visual Basic
Public ReadOnly Property Properties As List(Of Property)
    Get
Visual C++
public:
property List<Property^>^ Properties {
    List<Property^>^ get ();
}

Field Value

The properties.

See Also

Reader Class
Sitecore.Drawing.Exif Namespace


Sitecore.Drawing.Exif.Attributes Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Drawing.Exif.Attributes Namespace
Send Feedback

Classes

 | Class | Description
Public class | TagBitmaskValueNameAttribute |
Public class | TagCategoryAttribute |
Public class | TagCommentAttribute |
Public class | TagDefaultValueAttribute |
Public class | TagUnknownValueNameAttribute |
Public class | TagValueNameAttribute |


TagBitmaskValueNameAttribute Class

[image]

Sitecore 6.4.1 API
TagBitmaskValueNameAttribute Class
Members See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Attributes
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public sealed class TagBitmaskValueNameAttribute : TagValueNameAttribute
Visual Basic
Public NotInheritable Class TagBitmaskValueNameAttribute _
    Inherits TagValueNameAttribute
Visual C++
public ref class TagBitmaskValueNameAttribute sealed : public TagValueNameAttribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Sitecore.Drawing.Exif.Attributes..::..TagValueNameAttribute
Sitecore.Drawing.Exif.Attributes..::..TagBitmaskValueNameAttribute

See Also

TagBitmaskValueNameAttribute Members
Sitecore.Drawing.Exif.Attributes Namespace


TagBitmaskValueNameAttribute Members

[image] [image]

Sitecore 6.4.1 API
TagBitmaskValueNameAttribute Members
TagBitmaskValueNameAttribute Class Constructors Methods Properties See Also Send Feedback

The TagBitmaskValueNameAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | TagBitmaskValueNameAttribute(Int64, Int64, String) | Initializes a new instance of the TagBitmaskValueNameAttribute class.
Public method | TagBitmaskValueNameAttribute(Int64, Int64, String, String) | Initializes a new instance of the TagBitmaskValueNameAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | IsMatch | Determines whether the specified tag value is match. (Overrides TagValueNameAttribute..::..IsMatch(Int64).)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Bitmask | Gets the bitmask.
Public property | Comment | Gets the comment. (Inherited from TagValueNameAttribute.)
Public property | Name | Gets the name. (Inherited from TagValueNameAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | Value | Gets the value. (Inherited from TagValueNameAttribute.)

See Also

TagBitmaskValueNameAttribute Class
Sitecore.Drawing.Exif.Attributes Namespace


TagBitmaskValueNameAttribute Constructor

[image] [image]

Sitecore 6.4.1 API
TagBitmaskValueNameAttribute Constructor
TagBitmaskValueNameAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TagBitmaskValueNameAttribute(Int64, Int64, String) | Initializes a new instance of the TagBitmaskValueNameAttribute class.
Public method | TagBitmaskValueNameAttribute(Int64, Int64, String, String) | Initializes a new instance of the TagBitmaskValueNameAttribute class.

See Also

TagBitmaskValueNameAttribute Class
TagBitmaskValueNameAttribute Members
Sitecore.Drawing.Exif.Attributes Namespace


TagBitmaskValueNameAttribute Constructor (Int64, Int64, String)

[image]

Sitecore 6.4.1 API
TagBitmaskValueNameAttribute Constructor (Int64, Int64, String)
TagBitmaskValueNameAttribute Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Attributes
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TagBitmaskValueNameAttribute(
    long bitmask,
    long value,
    string name
)
Visual Basic
Public Sub New ( _
    bitmask As Long, _
    value As Long, _
    name As String _
)
Visual C++
public:
TagBitmaskValueNameAttribute(
    long long bitmask,
    long long value,
    String^ name
)

Parameters

bitmask
Type: System..::..Int64
The bitmask.
value
Type: System..::..Int64
The value.
name
Type: System..::..String
The name.

See Also

TagBitmaskValueNameAttribute Class
TagBitmaskValueNameAttribute Overload
Sitecore.Drawing.Exif.Attributes Namespace


TagBitmaskValueNameAttribute Constructor (Int64, Int64, String, String)

[image]

Sitecore 6.4.1 API
TagBitmaskValueNameAttribute Constructor (Int64, Int64, String, String)
TagBitmaskValueNameAttribute Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Attributes
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TagBitmaskValueNameAttribute(
    long bitmask,
    long value,
    string name,
    string comment
)
Visual Basic
Public Sub New ( _
    bitmask As Long, _
    value As Long, _
    name As String, _
    comment As String _
)
Visual C++
public:
TagBitmaskValueNameAttribute(
    long long bitmask,
    long long value,
    String^ name,
    String^ comment
)

Parameters

bitmask
Type: System..::..Int64
The bitmask.
value
Type: System..::..Int64
The value.
name
Type: System..::..String
The name.
comment
Type: System..::..String
The comment.

See Also

TagBitmaskValueNameAttribute Class
TagBitmaskValueNameAttribute Overload
Sitecore.Drawing.Exif.Attributes Namespace


TagBitmaskValueNameAttribute Methods

[image] [image]

Sitecore 6.4.1 API
TagBitmaskValueNameAttribute Methods
TagBitmaskValueNameAttribute Class See Also Send Feedback

The TagBitmaskValueNameAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | IsMatch | Determines whether the specified tag value is match. (Overrides TagValueNameAttribute..::..IsMatch(Int64).)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TagBitmaskValueNameAttribute Class
Sitecore.Drawing.Exif.Attributes Namespace


TagBitmaskValueNameAttribute Properties

[image] [image]

Sitecore 6.4.1 API
TagBitmaskValueNameAttribute Properties
TagBitmaskValueNameAttribute Class See Also Send Feedback

The TagBitmaskValueNameAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Bitmask | Gets the bitmask.
Public property | Comment | Gets the comment. (Inherited from TagValueNameAttribute.)
Public property | Name | Gets the name. (Inherited from TagValueNameAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | Value | Gets the value. (Inherited from TagValueNameAttribute.)

See Also

TagBitmaskValueNameAttribute Class
Sitecore.Drawing.Exif.Attributes Namespace


Bitmask Property

[image]

Sitecore 6.4.1 API
TagBitmaskValueNameAttribute..::..Bitmask Property
TagBitmaskValueNameAttribute Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Attributes
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long Bitmask { get; }
Visual Basic
Public ReadOnly Property Bitmask As Long
    Get
Visual C++
public:
property long long Bitmask {
    long long get ();
}

Field Value

The bitmask.

See Also

TagBitmaskValueNameAttribute Class
Sitecore.Drawing.Exif.Attributes Namespace


TagCategoryAttribute Class

[image]

Sitecore 6.4.1 API
TagCategoryAttribute Class
Members See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Attributes
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public sealed class TagCategoryAttribute : Attribute
Visual Basic
Public NotInheritable Class TagCategoryAttribute _
    Inherits Attribute
Visual C++
public ref class TagCategoryAttribute sealed : public Attribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Sitecore.Drawing.Exif.Attributes..::..TagCategoryAttribute

See Also

TagCategoryAttribute Members
Sitecore.Drawing.Exif.Attributes Namespace


TagCategoryAttribute Members

[image] [image]

Sitecore 6.4.1 API
TagCategoryAttribute Members
TagCategoryAttribute Class Constructors Methods Properties See Also Send Feedback

The TagCategoryAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | TagCategoryAttribute | Initializes a new instance of the TagCategoryAttribute class

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Category | Gets the category.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

TagCategoryAttribute Class
Sitecore.Drawing.Exif.Attributes Namespace


TagCategoryAttribute Constructor

[image]

Sitecore 6.4.1 API
TagCategoryAttribute Constructor
TagCategoryAttribute Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Attributes
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TagCategoryAttribute(
    string category
)
Visual Basic
Public Sub New ( _
    category As String _
)
Visual C++
public:
TagCategoryAttribute(
    String^ category
)

Parameters

category
Type: System..::..String

[Missing <param name="category"/> documentation for "M:Sitecore.Drawing.Exif.Attributes.TagCategoryAttribute.#ctor(System.String)"]

See Also

TagCategoryAttribute Class
Sitecore.Drawing.Exif.Attributes Namespace


TagCategoryAttribute Methods

[image] [image]

Sitecore 6.4.1 API
TagCategoryAttribute Methods
TagCategoryAttribute Class See Also Send Feedback

The TagCategoryAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TagCategoryAttribute Class
Sitecore.Drawing.Exif.Attributes Namespace


Category Property

[image]

Sitecore 6.4.1 API
TagCategoryAttribute..::..Category Property
TagCategoryAttribute Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Attributes
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Category { get; }
Visual Basic
Public ReadOnly Property Category As String
    Get
Visual C++
public:
property String^ Category {
    String^ get ();
}

Field Value

The category.

See Also

TagCategoryAttribute Class
Sitecore.Drawing.Exif.Attributes Namespace


TagCommentAttribute Class

[image]

Sitecore 6.4.1 API
TagCommentAttribute Class
Members See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Attributes
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public sealed class TagCommentAttribute : Attribute
Visual Basic
Public NotInheritable Class TagCommentAttribute _
    Inherits Attribute
Visual C++
public ref class TagCommentAttribute sealed : public Attribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Sitecore.Drawing.Exif.Attributes..::..TagCommentAttribute

See Also

TagCommentAttribute Members
Sitecore.Drawing.Exif.Attributes Namespace


TagCommentAttribute Members

[image] [image]

Sitecore 6.4.1 API
TagCommentAttribute Members
TagCommentAttribute Class Constructors Methods Properties See Also Send Feedback

The TagCommentAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | TagCommentAttribute | Initializes a new instance of the TagCommentAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Comment | Gets the comment.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

TagCommentAttribute Class
Sitecore.Drawing.Exif.Attributes Namespace


TagCommentAttribute Constructor

[image]

Sitecore 6.4.1 API
TagCommentAttribute Constructor
TagCommentAttribute Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Attributes
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TagCommentAttribute(
    string comment
)
Visual Basic
Public Sub New ( _
    comment As String _
)
Visual C++
public:
TagCommentAttribute(
    String^ comment
)

Parameters

comment
Type: System..::..String
The comment.

See Also

TagCommentAttribute Class
Sitecore.Drawing.Exif.Attributes Namespace


TagCommentAttribute Methods

[image] [image]

Sitecore 6.4.1 API
TagCommentAttribute Methods
TagCommentAttribute Class See Also Send Feedback

The TagCommentAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TagCommentAttribute Class
Sitecore.Drawing.Exif.Attributes Namespace


TagCommentAttribute Properties

[image] [image]

Sitecore 6.4.1 API
TagCommentAttribute Properties
TagCommentAttribute Class See Also Send Feedback

The TagCommentAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Comment | Gets the comment.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

TagCommentAttribute Class
Sitecore.Drawing.Exif.Attributes Namespace


Comment Property

[image]

Sitecore 6.4.1 API
TagCommentAttribute..::..Comment Property
TagCommentAttribute Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Attributes
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Comment { get; }
Visual Basic
Public ReadOnly Property Comment As String
    Get
Visual C++
public:
property String^ Comment {
    String^ get ();
}

Field Value

The comment.

See Also

TagCommentAttribute Class
Sitecore.Drawing.Exif.Attributes Namespace


TagDefaultValueAttribute Class

[image]

Sitecore 6.4.1 API
TagDefaultValueAttribute Class
Members See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Attributes
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public sealed class TagDefaultValueAttribute : Attribute
Visual Basic
Public NotInheritable Class TagDefaultValueAttribute _
    Inherits Attribute
Visual C++
public ref class TagDefaultValueAttribute sealed : public Attribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Sitecore.Drawing.Exif.Attributes..::..TagDefaultValueAttribute

See Also

TagDefaultValueAttribute Members
Sitecore.Drawing.Exif.Attributes Namespace


TagDefaultValueAttribute Members

[image] [image]

Sitecore 6.4.1 API
TagDefaultValueAttribute Members
TagDefaultValueAttribute Class Constructors Methods Properties See Also Send Feedback

The TagDefaultValueAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | TagDefaultValueAttribute | Initializes a new instance of the TagDefaultValueAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | Value | Gets the value.

See Also

TagDefaultValueAttribute Class
Sitecore.Drawing.Exif.Attributes Namespace


TagDefaultValueAttribute Constructor

[image]

Sitecore 6.4.1 API
TagDefaultValueAttribute Constructor
TagDefaultValueAttribute Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Attributes
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TagDefaultValueAttribute(
    Object value
)
Visual Basic
Public Sub New ( _
    value As Object _
)
Visual C++
public:
TagDefaultValueAttribute(
    Object^ value
)

Parameters

value
Type: System..::..Object
The value.

See Also

TagDefaultValueAttribute Class
Sitecore.Drawing.Exif.Attributes Namespace


TagDefaultValueAttribute Methods

[image] [image]

Sitecore 6.4.1 API
TagDefaultValueAttribute Methods
TagDefaultValueAttribute Class See Also Send Feedback

The TagDefaultValueAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TagDefaultValueAttribute Class
Sitecore.Drawing.Exif.Attributes Namespace


TagDefaultValueAttribute Properties

[image] [image]

Sitecore 6.4.1 API
TagDefaultValueAttribute Properties
TagDefaultValueAttribute Class See Also Send Feedback

The TagDefaultValueAttribute type exposes the following members.

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | Value | Gets the value.

See Also

TagDefaultValueAttribute Class
Sitecore.Drawing.Exif.Attributes Namespace


Value Property

[image]

Sitecore 6.4.1 API
TagDefaultValueAttribute..::..Value Property
TagDefaultValueAttribute Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Attributes
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object Value { get; }
Visual Basic
Public ReadOnly Property Value As Object
    Get
Visual C++
public:
property Object^ Value {
    Object^ get ();
}

Field Value

The value.

See Also

TagDefaultValueAttribute Class
Sitecore.Drawing.Exif.Attributes Namespace


TagUnknownValueNameAttribute Class

[image]

Sitecore 6.4.1 API
TagUnknownValueNameAttribute Class
Members See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Attributes
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public sealed class TagUnknownValueNameAttribute : TagValueNameAttribute
Visual Basic
Public NotInheritable Class TagUnknownValueNameAttribute _
    Inherits TagValueNameAttribute
Visual C++
public ref class TagUnknownValueNameAttribute sealed : public TagValueNameAttribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Sitecore.Drawing.Exif.Attributes..::..TagValueNameAttribute
Sitecore.Drawing.Exif.Attributes..::..TagUnknownValueNameAttribute

See Also

TagUnknownValueNameAttribute Members
Sitecore.Drawing.Exif.Attributes Namespace


TagUnknownValueNameAttribute Members

[image] [image]

Sitecore 6.4.1 API
TagUnknownValueNameAttribute Members
TagUnknownValueNameAttribute Class Constructors Methods Properties See Also Send Feedback

The TagUnknownValueNameAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | TagUnknownValueNameAttribute(String) | Initializes a new instance of the TagUnknownValueNameAttribute class.
Public method | TagUnknownValueNameAttribute(String, String) | Initializes a new instance of the TagUnknownValueNameAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | IsMatch | Determines whether the specified tag value is match. (Overrides TagValueNameAttribute..::..IsMatch(Int64).)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Comment | Gets the comment. (Inherited from TagValueNameAttribute.)
Public property | Name | Gets the name. (Inherited from TagValueNameAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | Value | Gets the value. (Inherited from TagValueNameAttribute.)

See Also

TagUnknownValueNameAttribute Class
Sitecore.Drawing.Exif.Attributes Namespace


TagUnknownValueNameAttribute Constructor

[image] [image]

Sitecore 6.4.1 API
TagUnknownValueNameAttribute Constructor
TagUnknownValueNameAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TagUnknownValueNameAttribute(String) | Initializes a new instance of the TagUnknownValueNameAttribute class.
Public method | TagUnknownValueNameAttribute(String, String) | Initializes a new instance of the TagUnknownValueNameAttribute class.

See Also

TagUnknownValueNameAttribute Class
TagUnknownValueNameAttribute Members
Sitecore.Drawing.Exif.Attributes Namespace


TagUnknownValueNameAttribute Constructor (String)

[image]

Sitecore 6.4.1 API
TagUnknownValueNameAttribute Constructor (String)
TagUnknownValueNameAttribute Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Attributes
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TagUnknownValueNameAttribute(
    string name
)
Visual Basic
Public Sub New ( _
    name As String _
)
Visual C++
public:
TagUnknownValueNameAttribute(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

See Also

TagUnknownValueNameAttribute Class
TagUnknownValueNameAttribute Overload
Sitecore.Drawing.Exif.Attributes Namespace


TagUnknownValueNameAttribute Constructor (String, String)

[image]

Sitecore 6.4.1 API
TagUnknownValueNameAttribute Constructor (String, String)
TagUnknownValueNameAttribute Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Attributes
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TagUnknownValueNameAttribute(
    string name,
    string comment
)
Visual Basic
Public Sub New ( _
    name As String, _
    comment As String _
)
Visual C++
public:
TagUnknownValueNameAttribute(
    String^ name,
    String^ comment
)

Parameters

name
Type: System..::..String
The name.
comment
Type: System..::..String
The comment.

See Also

TagUnknownValueNameAttribute Class
TagUnknownValueNameAttribute Overload
Sitecore.Drawing.Exif.Attributes Namespace


TagUnknownValueNameAttribute Methods

[image] [image]

Sitecore 6.4.1 API
TagUnknownValueNameAttribute Methods
TagUnknownValueNameAttribute Class See Also Send Feedback

The TagUnknownValueNameAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | IsMatch | Determines whether the specified tag value is match. (Overrides TagValueNameAttribute..::..IsMatch(Int64).)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TagUnknownValueNameAttribute Class
Sitecore.Drawing.Exif.Attributes Namespace


IsMatch Method

[image]

Sitecore 6.4.1 API
TagUnknownValueNameAttribute..::..IsMatch Method
TagUnknownValueNameAttribute Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Attributes
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool IsMatch(
    long tagValue
)
Visual Basic
Public Overrides Function IsMatch ( _
    tagValue As Long _
) As Boolean
Visual C++
public:
virtual bool IsMatch(
    long long tagValue
) override

Parameters

tagValue
Type: System..::..Int64
The tag value.

Return Value

true if the specified tag value is match; otherwise, false.

See Also

TagUnknownValueNameAttribute Class
Sitecore.Drawing.Exif.Attributes Namespace


TagUnknownValueNameAttribute Properties

[image] [image]

Sitecore 6.4.1 API
TagUnknownValueNameAttribute Properties
TagUnknownValueNameAttribute Class See Also Send Feedback

The TagUnknownValueNameAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Comment | Gets the comment. (Inherited from TagValueNameAttribute.)
Public property | Name | Gets the name. (Inherited from TagValueNameAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | Value | Gets the value. (Inherited from TagValueNameAttribute.)

See Also

TagUnknownValueNameAttribute Class
Sitecore.Drawing.Exif.Attributes Namespace


TagValueNameAttribute Class

[image]

Sitecore 6.4.1 API
TagValueNameAttribute Class
Members See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Attributes
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class TagValueNameAttribute : Attribute
Visual Basic
Public Class TagValueNameAttribute _
    Inherits Attribute
Visual C++
public ref class TagValueNameAttribute : public Attribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Sitecore.Drawing.Exif.Attributes..::..TagValueNameAttribute
Sitecore.Drawing.Exif.Attributes..::..TagBitmaskValueNameAttribute
Sitecore.Drawing.Exif.Attributes..::..TagUnknownValueNameAttribute

See Also

TagValueNameAttribute Members
Sitecore.Drawing.Exif.Attributes Namespace


TagValueNameAttribute Members

[image] [image]

Sitecore 6.4.1 API
TagValueNameAttribute Members
TagValueNameAttribute Class Constructors Methods Properties See Also Send Feedback

The TagValueNameAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | TagValueNameAttribute(Int64, String) | Initializes a new instance of the TagValueNameAttribute class.
Public method | TagValueNameAttribute(Int64, String, String) | Initializes a new instance of the TagValueNameAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | IsMatch | Determines whether the specified tag value is match.
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Comment | Gets the comment.
Public property | Name | Gets the name.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | Value | Gets the value.

See Also

TagValueNameAttribute Class
Sitecore.Drawing.Exif.Attributes Namespace


TagValueNameAttribute Constructor

[image] [image]

Sitecore 6.4.1 API
TagValueNameAttribute Constructor
TagValueNameAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TagValueNameAttribute(Int64, String) | Initializes a new instance of the TagValueNameAttribute class.
Public method | TagValueNameAttribute(Int64, String, String) | Initializes a new instance of the TagValueNameAttribute class.

See Also

TagValueNameAttribute Class
TagValueNameAttribute Members
Sitecore.Drawing.Exif.Attributes Namespace


TagValueNameAttribute Constructor (Int64, String)

[image]

Sitecore 6.4.1 API
TagValueNameAttribute Constructor (Int64, String)
TagValueNameAttribute Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Attributes
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TagValueNameAttribute(
    long value,
    string name
)
Visual Basic
Public Sub New ( _
    value As Long, _
    name As String _
)
Visual C++
public:
TagValueNameAttribute(
    long long value,
    String^ name
)

Parameters

value
Type: System..::..Int64
The value.
name
Type: System..::..String
The name.

See Also

TagValueNameAttribute Class
TagValueNameAttribute Overload
Sitecore.Drawing.Exif.Attributes Namespace


TagValueNameAttribute Constructor (Int64, String, String)

[image]

Sitecore 6.4.1 API
TagValueNameAttribute Constructor (Int64, String, String)
TagValueNameAttribute Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Attributes
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TagValueNameAttribute(
    long value,
    string name,
    string comment
)
Visual Basic
Public Sub New ( _
    value As Long, _
    name As String, _
    comment As String _
)
Visual C++
public:
TagValueNameAttribute(
    long long value,
    String^ name,
    String^ comment
)

Parameters

value
Type: System..::..Int64
The value.
name
Type: System..::..String
The name.
comment
Type: System..::..String
The comment.

See Also

TagValueNameAttribute Class
TagValueNameAttribute Overload
Sitecore.Drawing.Exif.Attributes Namespace


TagValueNameAttribute Methods

[image] [image]

Sitecore 6.4.1 API
TagValueNameAttribute Methods
TagValueNameAttribute Class See Also Send Feedback

The TagValueNameAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | IsMatch | Determines whether the specified tag value is match.
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TagValueNameAttribute Class
Sitecore.Drawing.Exif.Attributes Namespace


IsMatch Method

[image]

Sitecore 6.4.1 API
TagValueNameAttribute..::..IsMatch Method
TagValueNameAttribute Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Attributes
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool IsMatch(
    long tagValue
)
Visual Basic
Public Overridable Function IsMatch ( _
    tagValue As Long _
) As Boolean
Visual C++
public:
virtual bool IsMatch(
    long long tagValue
)

Parameters

tagValue
Type: System..::..Int64
The tag value.

Return Value

true if the specified tag value is match; otherwise, false.

See Also

TagValueNameAttribute Class
Sitecore.Drawing.Exif.Attributes Namespace


TagValueNameAttribute Properties

[image] [image]

Sitecore 6.4.1 API
TagValueNameAttribute Properties
TagValueNameAttribute Class See Also Send Feedback

The TagValueNameAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Comment | Gets the comment.
Public property | Name | Gets the name.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | Value | Gets the value.

See Also

TagValueNameAttribute Class
Sitecore.Drawing.Exif.Attributes Namespace


Comment Property

[image]

Sitecore 6.4.1 API
TagValueNameAttribute..::..Comment Property
TagValueNameAttribute Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Attributes
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Comment { get; }
Visual Basic
Public ReadOnly Property Comment As String
    Get
Visual C++
public:
property String^ Comment {
    String^ get ();
}

Field Value

The comment.

See Also

TagValueNameAttribute Class
Sitecore.Drawing.Exif.Attributes Namespace


Name Property

[image]

Sitecore 6.4.1 API
TagValueNameAttribute..::..Name Property
TagValueNameAttribute Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Attributes
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

TagValueNameAttribute Class
Sitecore.Drawing.Exif.Attributes Namespace


Value Property

[image]

Sitecore 6.4.1 API
TagValueNameAttribute..::..Value Property
TagValueNameAttribute Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Attributes
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long Value { get; }
Visual Basic
Public ReadOnly Property Value As Long
    Get
Visual C++
public:
property long long Value {
    long long get ();
}

Field Value

The value.

See Also

TagValueNameAttribute Class
Sitecore.Drawing.Exif.Attributes Namespace


Sitecore.Drawing.Exif.Properties Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Drawing.Exif.Properties Namespace
Send Feedback

Classes

 | Class | Description
Public class | ByteProperty |
Public class | CopyrightProperty |
Public class | DateTimeProperty |
Public class | Int32Property |
Public class | IntegerProperty |
Public class | JpegThumbnailProperty |
Public class | Property |
Public class | Rational |
Public class | RationalProperty |
Public class | SignedRationalProperty |
Public class | StringProperty |
Public class | ThumbnailProperty |
Public class | UInt16Property |
Public class | UInt32Property |
Public class | UndefinedProperty |
Public class | UnsignedRationalProperty |

Enumerations

 | Enumeration | Description
Public enumeration | Property..::..DataType |
Public enumeration | Tag |


ByteProperty Class

[image]

Sitecore 6.4.1 API
ByteProperty Class
Members See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ByteProperty : IntegerProperty
Visual Basic
Public Class ByteProperty _
    Inherits IntegerProperty
Visual C++
public ref class ByteProperty : public IntegerProperty

Inheritance Hierarchy

System..::..Object
Sitecore.Drawing.Exif.Properties..::..Property
Sitecore.Drawing.Exif.Properties..::..IntegerProperty
Sitecore.Drawing.Exif.Properties..::..ByteProperty

See Also

ByteProperty Members
Sitecore.Drawing.Exif.Properties Namespace


ByteProperty Members

[image] [image]

Sitecore 6.4.1 API
ByteProperty Members
ByteProperty Class Constructors Methods Properties See Also Send Feedback

The ByteProperty type exposes the following members.

Constructors

 | Name | Description
Public method | ByteProperty | Initializes a new instance of the ByteProperty class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValueComment | Gets the value comment. (Inherited from IntegerProperty.)
Public method | GetValueName | Gets the name of the value. (Inherited from IntegerProperty.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetValues | Sets the values. (Inherited from IntegerProperty.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Property.)

Properties

 | Name | Description
Public property | Category | Gets the category. (Inherited from Property.)
Public property | Comment | Gets the comment. (Inherited from Property.)
Public property | Count | Gets the count. (Inherited from IntegerProperty.)
Public property | Id | Gets the id. (Inherited from Property.)
Public property | Item | Gets the Int64 at the specified index. (Inherited from IntegerProperty.)
Public property | Name | Gets the name. (Inherited from Property.)
Public property | PropertyType | Gets the type of the property. (Inherited from Property.)
Public property | RawBytes | Gets the raw bytes. (Inherited from Property.)
Public property | ValueComments | Gets the value comments. (Inherited from IntegerProperty.)
Public property | ValueNames | Gets the value names. (Inherited from IntegerProperty.)
Public property | Values | Gets the values. (Inherited from IntegerProperty.)

See Also

ByteProperty Class
Sitecore.Drawing.Exif.Properties Namespace


ByteProperty Constructor

[image]

Sitecore 6.4.1 API
ByteProperty Constructor
ByteProperty Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ByteProperty(
    int id,
    byte[] raw
)
Visual Basic
Public Sub New ( _
    id As Integer, _
    raw As Byte() _
)
Visual C++
public:
ByteProperty(
    int id,
    array<unsigned char>^ raw
)

Parameters

id
Type: System..::..Int32
The id.
raw
Type: array< System..::..Byte >[]()[][]
The raw.

See Also

ByteProperty Class
Sitecore.Drawing.Exif.Properties Namespace


ByteProperty Methods

[image] [image]

Sitecore 6.4.1 API
ByteProperty Methods
ByteProperty Class See Also Send Feedback

The ByteProperty type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValueComment | Gets the value comment. (Inherited from IntegerProperty.)
Public method | GetValueName | Gets the name of the value. (Inherited from IntegerProperty.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetValues | Sets the values. (Inherited from IntegerProperty.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Property.)

See Also

ByteProperty Class
Sitecore.Drawing.Exif.Properties Namespace


ByteProperty Properties

[image] [image]

Sitecore 6.4.1 API
ByteProperty Properties
ByteProperty Class See Also Send Feedback

The ByteProperty type exposes the following members.

Properties

 | Name | Description
Public property | Category | Gets the category. (Inherited from Property.)
Public property | Comment | Gets the comment. (Inherited from Property.)
Public property | Count | Gets the count. (Inherited from IntegerProperty.)
Public property | Id | Gets the id. (Inherited from Property.)
Public property | Item | Gets the Int64 at the specified index. (Inherited from IntegerProperty.)
Public property | Name | Gets the name. (Inherited from Property.)
Public property | PropertyType | Gets the type of the property. (Inherited from Property.)
Public property | RawBytes | Gets the raw bytes. (Inherited from Property.)
Public property | ValueComments | Gets the value comments. (Inherited from IntegerProperty.)
Public property | ValueNames | Gets the value names. (Inherited from IntegerProperty.)
Public property | Values | Gets the values. (Inherited from IntegerProperty.)

See Also

ByteProperty Class
Sitecore.Drawing.Exif.Properties Namespace


CopyrightProperty Members

[image] [image]

Sitecore 6.4.1 API
CopyrightProperty Members
CopyrightProperty Class Constructors Methods Properties See Also Send Feedback

The CopyrightProperty type exposes the following members.

Constructors

 | Name | Description
Public method | CopyrightProperty | Initializes a new instance of the CopyrightProperty class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides StringProperty..::..ToString()()()().)

Properties

 | Name | Description
Public property | Category | Gets the category. (Inherited from Property.)
Public property | Comment | Gets the comment. (Inherited from Property.)
Public property | Editor | Gets the editor.
Public property | Id | Gets the id. (Inherited from Property.)
Public property | Name | Gets the name. (Inherited from Property.)
Public property | Photographer | Gets the photographer.
Public property | PropertyType | Gets the type of the property. (Inherited from Property.)
Public property | RawBytes | Gets the raw bytes. (Inherited from Property.)
Public property | Value | Gets the value. (Inherited from StringProperty.)

See Also

CopyrightProperty Class
Sitecore.Drawing.Exif.Properties Namespace


CopyrightProperty Constructor

[image]

Sitecore 6.4.1 API
CopyrightProperty Constructor
CopyrightProperty Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CopyrightProperty(
    int id,
    byte[] raw
)
Visual Basic
Public Sub New ( _
    id As Integer, _
    raw As Byte() _
)
Visual C++
public:
CopyrightProperty(
    int id,
    array<unsigned char>^ raw
)

Parameters

id
Type: System..::..Int32
The id.
raw
Type: array< System..::..Byte >[]()[][]
The raw.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Copyright does not contain a valid copyright message

See Also

CopyrightProperty Class
Sitecore.Drawing.Exif.Properties Namespace


CopyrightProperty Methods

[image] [image]

Sitecore 6.4.1 API
CopyrightProperty Methods
CopyrightProperty Class See Also Send Feedback

The CopyrightProperty type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides StringProperty..::..ToString()()()().)

See Also

CopyrightProperty Class
Sitecore.Drawing.Exif.Properties Namespace


ToString Method

[image]

Sitecore 6.4.1 API
CopyrightProperty..::..ToString Method
CopyrightProperty Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

CopyrightProperty Class
Sitecore.Drawing.Exif.Properties Namespace


CopyrightProperty Properties

[image] [image]

Sitecore 6.4.1 API
CopyrightProperty Properties
CopyrightProperty Class See Also Send Feedback

The CopyrightProperty type exposes the following members.

Properties

 | Name | Description
Public property | Category | Gets the category. (Inherited from Property.)
Public property | Comment | Gets the comment. (Inherited from Property.)
Public property | Editor | Gets the editor.
Public property | Id | Gets the id. (Inherited from Property.)
Public property | Name | Gets the name. (Inherited from Property.)
Public property | Photographer | Gets the photographer.
Public property | PropertyType | Gets the type of the property. (Inherited from Property.)
Public property | RawBytes | Gets the raw bytes. (Inherited from Property.)
Public property | Value | Gets the value. (Inherited from StringProperty.)

See Also

CopyrightProperty Class
Sitecore.Drawing.Exif.Properties Namespace


Editor Property

[image]

Sitecore 6.4.1 API
CopyrightProperty..::..Editor Property
CopyrightProperty Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Editor { get; }
Visual Basic
Public ReadOnly Property Editor As String
    Get
Visual C++
public:
property String^ Editor {
    String^ get ();
}

Field Value

The editor.

See Also

CopyrightProperty Class
Sitecore.Drawing.Exif.Properties Namespace


Photographer Property

[image]

Sitecore 6.4.1 API
CopyrightProperty..::..Photographer Property
CopyrightProperty Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Photographer { get; }
Visual Basic
Public ReadOnly Property Photographer As String
    Get
Visual C++
public:
property String^ Photographer {
    String^ get ();
}

Field Value

The photographer.

See Also

CopyrightProperty Class
Sitecore.Drawing.Exif.Properties Namespace


DateTimeProperty Class

[image]

Sitecore 6.4.1 API
DateTimeProperty Class
Members See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DateTimeProperty : StringProperty
Visual Basic
Public Class DateTimeProperty _
    Inherits StringProperty
Visual C++
public ref class DateTimeProperty : public StringProperty

Inheritance Hierarchy

System..::..Object
Sitecore.Drawing.Exif.Properties..::..Property
Sitecore.Drawing.Exif.Properties..::..StringProperty
Sitecore.Drawing.Exif.Properties..::..DateTimeProperty

See Also

DateTimeProperty Members
Sitecore.Drawing.Exif.Properties Namespace


DateTimeProperty Members

[image] [image]

Sitecore 6.4.1 API
DateTimeProperty Members
DateTimeProperty Class Constructors Methods Properties See Also Send Feedback

The DateTimeProperty type exposes the following members.

Constructors

 | Name | Description
Public method | DateTimeProperty | Initializes a new instance of the DateTimeProperty class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides StringProperty..::..ToString()()()().)

Properties

 | Name | Description
Public property | Category | Gets the category. (Inherited from Property.)
Public property | Comment | Gets the comment. (Inherited from Property.)
Public property | Id | Gets the id. (Inherited from Property.)
Public property | Name | Gets the name. (Inherited from Property.)
Public property | PropertyType | Gets the type of the property. (Inherited from Property.)
Public property | RawBytes | Gets the raw bytes. (Inherited from Property.)
Public property | Value | Gets the value.

See Also

DateTimeProperty Class
Sitecore.Drawing.Exif.Properties Namespace


DateTimeProperty Constructor

[image]

Sitecore 6.4.1 API
DateTimeProperty Constructor
DateTimeProperty Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTimeProperty(
    int id,
    byte[] raw
)
Visual Basic
Public Sub New ( _
    id As Integer, _
    raw As Byte() _
)
Visual C++
public:
DateTimeProperty(
    int id,
    array<unsigned char>^ raw
)

Parameters

id
Type: System..::..Int32
The id.
raw
Type: array< System..::..Byte >[]()[][]
The raw.

See Also

DateTimeProperty Class
Sitecore.Drawing.Exif.Properties Namespace


DateTimeProperty Methods

[image] [image]

Sitecore 6.4.1 API
DateTimeProperty Methods
DateTimeProperty Class See Also Send Feedback

The DateTimeProperty type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides StringProperty..::..ToString()()()().)

See Also

DateTimeProperty Class
Sitecore.Drawing.Exif.Properties Namespace


ToString Method

[image]

Sitecore 6.4.1 API
DateTimeProperty..::..ToString Method
DateTimeProperty Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

DateTimeProperty Class
Sitecore.Drawing.Exif.Properties Namespace


DateTimeProperty Properties

[image] [image]

Sitecore 6.4.1 API
DateTimeProperty Properties
DateTimeProperty Class See Also Send Feedback

The DateTimeProperty type exposes the following members.

Properties

 | Name | Description
Public property | Category | Gets the category. (Inherited from Property.)
Public property | Comment | Gets the comment. (Inherited from Property.)
Public property | Id | Gets the id. (Inherited from Property.)
Public property | Name | Gets the name. (Inherited from Property.)
Public property | PropertyType | Gets the type of the property. (Inherited from Property.)
Public property | RawBytes | Gets the raw bytes. (Inherited from Property.)
Public property | Value | Gets the value.

See Also

DateTimeProperty Class
Sitecore.Drawing.Exif.Properties Namespace


Value Property

[image]

Sitecore 6.4.1 API
DateTimeProperty..::..Value Property
DateTimeProperty Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime Value { get; }
Visual Basic
Public ReadOnly Property Value As DateTime
    Get
Visual C++
public:
property DateTime Value {
    DateTime get ();
}

Field Value

The value.

See Also

DateTimeProperty Class
Sitecore.Drawing.Exif.Properties Namespace


Int32Property Class

[image]

Sitecore 6.4.1 API
Int32Property Class
Members See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Int32Property : IntegerProperty
Visual Basic
Public Class Int32Property _
    Inherits IntegerProperty
Visual C++
public ref class Int32Property : public IntegerProperty

Inheritance Hierarchy

System..::..Object
Sitecore.Drawing.Exif.Properties..::..Property
Sitecore.Drawing.Exif.Properties..::..IntegerProperty
Sitecore.Drawing.Exif.Properties..::..Int32Property

See Also

Int32Property Members
Sitecore.Drawing.Exif.Properties Namespace


Int32Property Members

[image] [image]

Sitecore 6.4.1 API
Int32Property Members
Int32Property Class Constructors Methods Properties See Also Send Feedback

The Int32Property type exposes the following members.

Constructors

 | Name | Description
Public method | Int32Property | Initializes a new instance of the Int32Property class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValueComment | Gets the value comment. (Inherited from IntegerProperty.)
Public method | GetValueName | Gets the name of the value. (Inherited from IntegerProperty.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetValues | Sets the values. (Inherited from IntegerProperty.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Property.)

Properties

 | Name | Description
Public property | Category | Gets the category. (Inherited from Property.)
Public property | Comment | Gets the comment. (Inherited from Property.)
Public property | Count | Gets the count. (Inherited from IntegerProperty.)
Public property | Id | Gets the id. (Inherited from Property.)
Public property | Item | Gets the Int64 at the specified index. (Inherited from IntegerProperty.)
Public property | Name | Gets the name. (Inherited from Property.)
Public property | PropertyType | Gets the type of the property. (Inherited from Property.)
Public property | RawBytes | Gets the raw bytes. (Inherited from Property.)
Public property | ValueComments | Gets the value comments. (Inherited from IntegerProperty.)
Public property | ValueNames | Gets the value names. (Inherited from IntegerProperty.)
Public property | Values | Gets the values. (Inherited from IntegerProperty.)

See Also

Int32Property Class
Sitecore.Drawing.Exif.Properties Namespace


Int32Property Constructor

[image]

Sitecore 6.4.1 API
Int32Property Constructor
Int32Property Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Int32Property(
    int id,
    byte[] raw
)
Visual Basic
Public Sub New ( _
    id As Integer, _
    raw As Byte() _
)
Visual C++
public:
Int32Property(
    int id,
    array<unsigned char>^ raw
)

Parameters

id
Type: System..::..Int32

[Missing <param name="id"/> documentation for "M:Sitecore.Drawing.Exif.Properties.Int32Property.#ctor(System.Int32,System.Byte[])"]

raw
Type: array< System..::..Byte >[]()[][]

[Missing <param name="raw"/> documentation for "M:Sitecore.Drawing.Exif.Properties.Int32Property.#ctor(System.Int32,System.Byte[])"]

See Also

Int32Property Class
Sitecore.Drawing.Exif.Properties Namespace


Int32Property Methods

[image] [image]

Sitecore 6.4.1 API
Int32Property Methods
Int32Property Class See Also Send Feedback

The Int32Property type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValueComment | Gets the value comment. (Inherited from IntegerProperty.)
Public method | GetValueName | Gets the name of the value. (Inherited from IntegerProperty.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetValues | Sets the values. (Inherited from IntegerProperty.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Property.)

See Also

Int32Property Class
Sitecore.Drawing.Exif.Properties Namespace


Int32Property Properties

[image] [image]

Sitecore 6.4.1 API
Int32Property Properties
Int32Property Class See Also Send Feedback

The Int32Property type exposes the following members.

Properties

 | Name | Description
Public property | Category | Gets the category. (Inherited from Property.)
Public property | Comment | Gets the comment. (Inherited from Property.)
Public property | Count | Gets the count. (Inherited from IntegerProperty.)
Public property | Id | Gets the id. (Inherited from Property.)
Public property | Item | Gets the Int64 at the specified index. (Inherited from IntegerProperty.)
Public property | Name | Gets the name. (Inherited from Property.)
Public property | PropertyType | Gets the type of the property. (Inherited from Property.)
Public property | RawBytes | Gets the raw bytes. (Inherited from Property.)
Public property | ValueComments | Gets the value comments. (Inherited from IntegerProperty.)
Public property | ValueNames | Gets the value names. (Inherited from IntegerProperty.)
Public property | Values | Gets the values. (Inherited from IntegerProperty.)

See Also

Int32Property Class
Sitecore.Drawing.Exif.Properties Namespace


IntegerProperty Class

[image]

Sitecore 6.4.1 API
IntegerProperty Class
Members See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class IntegerProperty : Property
Visual Basic
Public Class IntegerProperty _
    Inherits Property
Visual C++
public ref class IntegerProperty : public Property

Inheritance Hierarchy

System..::..Object
Sitecore.Drawing.Exif.Properties..::..Property
Sitecore.Drawing.Exif.Properties..::..IntegerProperty
Sitecore.Drawing.Exif.Properties..::..ByteProperty
Sitecore.Drawing.Exif.Properties..::..Int32Property
Sitecore.Drawing.Exif.Properties..::..UInt16Property
Sitecore.Drawing.Exif.Properties..::..UInt32Property

See Also

IntegerProperty Members
Sitecore.Drawing.Exif.Properties Namespace


IntegerProperty Members

[image] [image]

Sitecore 6.4.1 API
IntegerProperty Members
IntegerProperty Class Constructors Methods Properties See Also Send Feedback

The IntegerProperty type exposes the following members.

Constructors

 | Name | Description
Protected method | IntegerProperty | Initializes a new instance of the IntegerProperty class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValueComment | Gets the value comment.
Public method | GetValueName | Gets the name of the value.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetValues | Sets the values.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Property.)

Properties

 | Name | Description
Public property | Category | Gets the category. (Inherited from Property.)
Public property | Comment | Gets the comment. (Inherited from Property.)
Public property | Count | Gets the count.
Public property | Id | Gets the id. (Inherited from Property.)
Public property | Item | Gets the Int64 at the specified index.
Public property | Name | Gets the name. (Inherited from Property.)
Public property | PropertyType | Gets the type of the property. (Inherited from Property.)
Public property | RawBytes | Gets the raw bytes. (Inherited from Property.)
Public property | ValueComments | Gets the value comments.
Public property | ValueNames | Gets the value names.
Public property | Values | Gets the values.

See Also

IntegerProperty Class
Sitecore.Drawing.Exif.Properties Namespace


IntegerProperty Constructor

[image]

Sitecore 6.4.1 API
IntegerProperty Constructor
IntegerProperty Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected IntegerProperty(
    Property..::..DataType dataType,
    int id,
    byte[] raw
)
Visual Basic
Protected Sub New ( _
    dataType As Property..::..DataType, _
    id As Integer, _
    raw As Byte() _
)
Visual C++
protected:
IntegerProperty(
    Property..::..DataType dataType,
    int id,
    array<unsigned char>^ raw
)

Parameters

dataType
Type: Sitecore.Drawing.Exif.Properties..::..Property..::..DataType
Type of the data.
id
Type: System..::..Int32
The id.
raw
Type: array< System..::..Byte >[]()[][]
The raw.

See Also

IntegerProperty Class
Sitecore.Drawing.Exif.Properties Namespace


IntegerProperty Methods

[image] [image]

Sitecore 6.4.1 API
IntegerProperty Methods
IntegerProperty Class See Also Send Feedback

The IntegerProperty type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValueComment | Gets the value comment.
Public method | GetValueName | Gets the name of the value.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetValues | Sets the values.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Property.)

See Also

IntegerProperty Class
Sitecore.Drawing.Exif.Properties Namespace


GetValueComment Method

[image]

Sitecore 6.4.1 API
IntegerProperty..::..GetValueComment Method
IntegerProperty Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetValueComment(
    long value
)
Visual Basic
Public Function GetValueComment ( _
    value As Long _
) As String
Visual C++
public:
String^ GetValueComment(
    long long value
)

Parameters

value
Type: System..::..Int64
The value.

Return Value

[Missing <returns> documentation for "M:Sitecore.Drawing.Exif.Properties.IntegerProperty.GetValueComment(System.Int64)"]

See Also

IntegerProperty Class
Sitecore.Drawing.Exif.Properties Namespace


GetValueName Method

[image]

Sitecore 6.4.1 API
IntegerProperty..::..GetValueName Method
IntegerProperty Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetValueName(
    long value
)
Visual Basic
Public Function GetValueName ( _
    value As Long _
) As String
Visual C++
public:
String^ GetValueName(
    long long value
)

Parameters

value
Type: System..::..Int64
The value.

Return Value

[Missing <returns> documentation for "M:Sitecore.Drawing.Exif.Properties.IntegerProperty.GetValueName(System.Int64)"]

See Also

IntegerProperty Class
Sitecore.Drawing.Exif.Properties Namespace


SetValues Method

[image]

Sitecore 6.4.1 API
IntegerProperty..::..SetValues Method
IntegerProperty Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void SetValues(
    long[] values
)
Visual Basic
Protected Sub SetValues ( _
    values As Long() _
)
Visual C++
protected:
void SetValues(
    array<long long>^ values
)

Parameters

values
Type: array< System..::..Int64 >[]()[][]
The values.

See Also

IntegerProperty Class
Sitecore.Drawing.Exif.Properties Namespace


IntegerProperty Properties

[image] [image]

Sitecore 6.4.1 API
IntegerProperty Properties
IntegerProperty Class See Also Send Feedback

The IntegerProperty type exposes the following members.

Properties

 | Name | Description
Public property | Category | Gets the category. (Inherited from Property.)
Public property | Comment | Gets the comment. (Inherited from Property.)
Public property | Count | Gets the count.
Public property | Id | Gets the id. (Inherited from Property.)
Public property | Item | Gets the Int64 at the specified index.
Public property | Name | Gets the name. (Inherited from Property.)
Public property | PropertyType | Gets the type of the property. (Inherited from Property.)
Public property | RawBytes | Gets the raw bytes. (Inherited from Property.)
Public property | ValueComments | Gets the value comments.
Public property | ValueNames | Gets the value names.
Public property | Values | Gets the values.

See Also

IntegerProperty Class
Sitecore.Drawing.Exif.Properties Namespace


Count Property

[image]

Sitecore 6.4.1 API
IntegerProperty..::..Count Property
IntegerProperty Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
property int Count {
    int get ();
}

Field Value

The count.

See Also

IntegerProperty Class
Sitecore.Drawing.Exif.Properties Namespace


ValueComments Property

[image]

Sitecore 6.4.1 API
IntegerProperty..::..ValueComments Property
IntegerProperty Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string[] ValueComments { get; }
Visual Basic
Public ReadOnly Property ValueComments As String()
    Get
Visual C++
public:
property array<String^>^ ValueComments {
    array<String^>^ get ();
}

Field Value

The value comments.

See Also

IntegerProperty Class
Sitecore.Drawing.Exif.Properties Namespace


ValueNames Property

[image]

Sitecore 6.4.1 API
IntegerProperty..::..ValueNames Property
IntegerProperty Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string[] ValueNames { get; }
Visual Basic
Public ReadOnly Property ValueNames As String()
    Get
Visual C++
public:
property array<String^>^ ValueNames {
    array<String^>^ get ();
}

Field Value

The value names.

See Also

IntegerProperty Class
Sitecore.Drawing.Exif.Properties Namespace


Values Property

[image]

Sitecore 6.4.1 API
IntegerProperty..::..Values Property
IntegerProperty Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long[] Values { get; }
Visual Basic
Public ReadOnly Property Values As Long()
    Get
Visual C++
public:
property array<long long>^ Values {
    array<long long>^ get ();
}

Field Value

The values.

See Also

IntegerProperty Class
Sitecore.Drawing.Exif.Properties Namespace


JpegThumbnailProperty Class

[image]

Sitecore 6.4.1 API
JpegThumbnailProperty Class
Members See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class JpegThumbnailProperty : ThumbnailProperty
Visual Basic
Public Class JpegThumbnailProperty _
    Inherits ThumbnailProperty
Visual C++
public ref class JpegThumbnailProperty : public ThumbnailProperty

Inheritance Hierarchy

System..::..Object
Sitecore.Drawing.Exif.Properties..::..Property
Sitecore.Drawing.Exif.Properties..::..ThumbnailProperty
Sitecore.Drawing.Exif.Properties..::..JpegThumbnailProperty

See Also

JpegThumbnailProperty Members
Sitecore.Drawing.Exif.Properties Namespace


JpegThumbnailProperty Members

[image] [image]

Sitecore 6.4.1 API
JpegThumbnailProperty Members
JpegThumbnailProperty Class Constructors Methods Properties See Also Send Feedback

The JpegThumbnailProperty type exposes the following members.

Constructors

 | Name | Description
Public method | JpegThumbnailProperty | Initializes a new instance of the JpegThumbnailProperty class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetThumbnail | Sets the thumbnail. (Inherited from ThumbnailProperty.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ThumbnailProperty.)

Properties

 | Name | Description
Public property | Category | Gets the category. (Inherited from Property.)
Public property | Comment | Gets the comment. (Inherited from Property.)
Public property | Id | Gets the id. (Inherited from Property.)
Public property | Name | Gets the name. (Inherited from Property.)
Public property | PropertyType | Gets the type of the property. (Inherited from Property.)
Public property | RawBytes | Gets the raw bytes. (Inherited from Property.)
Public property | Thumbnail | Gets the thumbnail. (Inherited from ThumbnailProperty.)

See Also

JpegThumbnailProperty Class
Sitecore.Drawing.Exif.Properties Namespace


JpegThumbnailProperty Constructor

[image]

Sitecore 6.4.1 API
JpegThumbnailProperty Constructor
JpegThumbnailProperty Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public JpegThumbnailProperty(
    int id,
    byte[] raw
)
Visual Basic
Public Sub New ( _
    id As Integer, _
    raw As Byte() _
)
Visual C++
public:
JpegThumbnailProperty(
    int id,
    array<unsigned char>^ raw
)

Parameters

id
Type: System..::..Int32

[Missing <param name="id"/> documentation for "M:Sitecore.Drawing.Exif.Properties.JpegThumbnailProperty.#ctor(System.Int32,System.Byte[])"]

raw
Type: array< System..::..Byte >[]()[][]

[Missing <param name="raw"/> documentation for "M:Sitecore.Drawing.Exif.Properties.JpegThumbnailProperty.#ctor(System.Int32,System.Byte[])"]

See Also

JpegThumbnailProperty Class
Sitecore.Drawing.Exif.Properties Namespace


JpegThumbnailProperty Methods

[image] [image]

Sitecore 6.4.1 API
JpegThumbnailProperty Methods
JpegThumbnailProperty Class See Also Send Feedback

The JpegThumbnailProperty type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetThumbnail | Sets the thumbnail. (Inherited from ThumbnailProperty.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ThumbnailProperty.)

See Also

JpegThumbnailProperty Class
Sitecore.Drawing.Exif.Properties Namespace


JpegThumbnailProperty Properties

[image] [image]

Sitecore 6.4.1 API
JpegThumbnailProperty Properties
JpegThumbnailProperty Class See Also Send Feedback

The JpegThumbnailProperty type exposes the following members.

Properties

 | Name | Description
Public property | Category | Gets the category. (Inherited from Property.)
Public property | Comment | Gets the comment. (Inherited from Property.)
Public property | Id | Gets the id. (Inherited from Property.)
Public property | Name | Gets the name. (Inherited from Property.)
Public property | PropertyType | Gets the type of the property. (Inherited from Property.)
Public property | RawBytes | Gets the raw bytes. (Inherited from Property.)
Public property | Thumbnail | Gets the thumbnail. (Inherited from ThumbnailProperty.)

See Also

JpegThumbnailProperty Class
Sitecore.Drawing.Exif.Properties Namespace


Property Class

[image]

Sitecore 6.4.1 API
Property Class
Members See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Property
Visual Basic
Public Class Property
Visual C++
public ref class Property

Inheritance Hierarchy

System..::..Object
Sitecore.Drawing.Exif.Properties..::..Property
Sitecore.Drawing.Exif.Properties..::..IntegerProperty
Sitecore.Drawing.Exif.Properties..::..RationalProperty
Sitecore.Drawing.Exif.Properties..::..StringProperty
Sitecore.Drawing.Exif.Properties..::..ThumbnailProperty
Sitecore.Drawing.Exif.Properties..::..UndefinedProperty

See Also

Property Members
Sitecore.Drawing.Exif.Properties Namespace


Property Members

[image] [image]

Sitecore 6.4.1 API
Property Members
Property Class Constructors Methods Properties See Also Send Feedback

The Property type exposes the following members.

Constructors

 | Name | Description
Protected method | Property | Initializes a new instance of the Property class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Category | Gets the category.
Public property | Comment | Gets the comment.
Public property | Id | Gets the id.
Public property | Name | Gets the name.
Public property | PropertyType | Gets the type of the property.
Public property | RawBytes | Gets the raw bytes.

See Also

Property Class
Sitecore.Drawing.Exif.Properties Namespace


Property Constructor

[image]

Sitecore 6.4.1 API
Property Constructor
Property Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Property(
    Property..::..DataType dataType,
    int id,
    byte[] raw
)
Visual Basic
Protected Sub New ( _
    dataType As Property..::..DataType, _
    id As Integer, _
    raw As Byte() _
)
Visual C++
protected:
Property(
    Property..::..DataType dataType,
    int id,
    array<unsigned char>^ raw
)

Parameters

dataType
Type: Sitecore.Drawing.Exif.Properties..::..Property..::..DataType
Type of the data.
id
Type: System..::..Int32
The id.
raw
Type: array< System..::..Byte >[]()[][]
The raw.

See Also

Property Class
Sitecore.Drawing.Exif.Properties Namespace


Property Methods

[image] [image]

Sitecore 6.4.1 API
Property Methods
Property Class See Also Send Feedback

The Property type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

Property Class
Sitecore.Drawing.Exif.Properties Namespace


ToString Method

[image]

Sitecore 6.4.1 API
Property..::..ToString Method
Property Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

Property Class
Sitecore.Drawing.Exif.Properties Namespace


Property Properties

[image] [image]

Sitecore 6.4.1 API
Property Properties
Property Class See Also Send Feedback

The Property type exposes the following members.

Properties

 | Name | Description
Public property | Category | Gets the category.
Public property | Comment | Gets the comment.
Public property | Id | Gets the id.
Public property | Name | Gets the name.
Public property | PropertyType | Gets the type of the property.
Public property | RawBytes | Gets the raw bytes.

See Also

Property Class
Sitecore.Drawing.Exif.Properties Namespace


Category Property

[image]

Sitecore 6.4.1 API
Property..::..Category Property
Property Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Category { get; }
Visual Basic
Public ReadOnly Property Category As String
    Get
Visual C++
public:
property String^ Category {
    String^ get ();
}

Field Value

The category.

See Also

Property Class
Sitecore.Drawing.Exif.Properties Namespace


Comment Property

[image]

Sitecore 6.4.1 API
Property..::..Comment Property
Property Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Comment { get; }
Visual Basic
Public ReadOnly Property Comment As String
    Get
Visual C++
public:
property String^ Comment {
    String^ get ();
}

Field Value

The comment.

See Also

Property Class
Sitecore.Drawing.Exif.Properties Namespace


Id Property

[image]

Sitecore 6.4.1 API
Property..::..Id Property
Property Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Id { get; }
Visual Basic
Public ReadOnly Property Id As Integer
    Get
Visual C++
public:
property int Id {
    int get ();
}

Field Value

The id.

See Also

Property Class
Sitecore.Drawing.Exif.Properties Namespace


Name Property

[image]

Sitecore 6.4.1 API
Property..::..Name Property
Property Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

Property Class
Sitecore.Drawing.Exif.Properties Namespace


RawBytes Property

[image]

Sitecore 6.4.1 API
Property..::..RawBytes Property
Property Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public byte[] RawBytes { get; }
Visual Basic
Public ReadOnly Property RawBytes As Byte()
    Get
Visual C++
public:
property array<unsigned char>^ RawBytes {
    array<unsigned char>^ get ();
}

Field Value

The raw bytes.

See Also

Property Class
Sitecore.Drawing.Exif.Properties Namespace


Property.DataType Enumeration

[image]

Sitecore 6.4.1 API
Property..::..DataType Enumeration
Property Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum DataType
Visual Basic
Public Enumeration DataType
Visual C++
public enum class DataType

Members

Member name | Value | Description
Byte | 1 |
String | 2 |
UInt16 | 3 |
UInt32 | 4 |
Rational | 5 |
Undefined | 7 |
Int32 | 9 |
SRational | 10 |

See Also

Sitecore.Drawing.Exif.Properties Namespace


Rational Class

[image]

Sitecore 6.4.1 API
Rational Class
Members See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Rational
Visual Basic
Public Class Rational
Visual C++
public ref class Rational

Inheritance Hierarchy

System..::..Object
Sitecore.Drawing.Exif.Properties..::..Rational

See Also

Rational Members
Sitecore.Drawing.Exif.Properties Namespace


Rational Members

[image] [image]

Sitecore 6.4.1 API
Rational Members
Rational Class Constructors Methods Properties See Also Send Feedback

The Rational type exposes the following members.

Constructors

 | Name | Description
Public method | Rational | Initializes a new instance of the Rational class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Denominator | Gets the denominator.
Public property | Numerator | Gets the numerator.
Public property | Value | Gets the value.

See Also

Rational Class
Sitecore.Drawing.Exif.Properties Namespace


Rational Constructor

[image]

Sitecore 6.4.1 API
Rational Constructor
Rational Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Rational(
    long numerator,
    long denominator
)
Visual Basic
Public Sub New ( _
    numerator As Long, _
    denominator As Long _
)
Visual C++
public:
Rational(
    long long numerator,
    long long denominator
)

Parameters

numerator
Type: System..::..Int64
The numerator.
denominator
Type: System..::..Int64
The denominator.

See Also

Rational Class
Sitecore.Drawing.Exif.Properties Namespace


Rational Methods

[image] [image]

Sitecore 6.4.1 API
Rational Methods
Rational Class See Also Send Feedback

The Rational type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

Rational Class
Sitecore.Drawing.Exif.Properties Namespace


ToString Method

[image]

Sitecore 6.4.1 API
Rational..::..ToString Method
Rational Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

Rational Class
Sitecore.Drawing.Exif.Properties Namespace


Rational Properties

[image] [image]

Sitecore 6.4.1 API
Rational Properties
Rational Class See Also Send Feedback

The Rational type exposes the following members.

Properties

 | Name | Description
Public property | Denominator | Gets the denominator.
Public property | Numerator | Gets the numerator.
Public property | Value | Gets the value.

See Also

Rational Class
Sitecore.Drawing.Exif.Properties Namespace


Denominator Property

[image]

Sitecore 6.4.1 API
Rational..::..Denominator Property
Rational Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long Denominator { get; }
Visual Basic
Public ReadOnly Property Denominator As Long
    Get
Visual C++
public:
property long long Denominator {
    long long get ();
}

Field Value

The denominator.

See Also

Rational Class
Sitecore.Drawing.Exif.Properties Namespace


Numerator Property

[image]

Sitecore 6.4.1 API
Rational..::..Numerator Property
Rational Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long Numerator { get; }
Visual Basic
Public ReadOnly Property Numerator As Long
    Get
Visual C++
public:
property long long Numerator {
    long long get ();
}

Field Value

The numerator.

See Also

Rational Class
Sitecore.Drawing.Exif.Properties Namespace


RationalProperty Class

[image]

Sitecore 6.4.1 API
RationalProperty Class
Members See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RationalProperty : Property
Visual Basic
Public Class RationalProperty _
    Inherits Property
Visual C++
public ref class RationalProperty : public Property

Inheritance Hierarchy

System..::..Object
Sitecore.Drawing.Exif.Properties..::..Property
Sitecore.Drawing.Exif.Properties..::..RationalProperty
Sitecore.Drawing.Exif.Properties..::..SignedRationalProperty
Sitecore.Drawing.Exif.Properties..::..UnsignedRationalProperty

See Also

RationalProperty Members
Sitecore.Drawing.Exif.Properties Namespace


RationalProperty Members

[image] [image]

Sitecore 6.4.1 API
RationalProperty Members
RationalProperty Class Constructors Methods Properties See Also Send Feedback

The RationalProperty type exposes the following members.

Constructors

 | Name | Description
Public method | RationalProperty | Initializes a new instance of the RationalProperty class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetValues | Sets the values.
Public method | ToString | Returns a String that represents the current Object. (Overrides Property..::..ToString()()()().)

Properties

 | Name | Description
Public property | Category | Gets the category. (Inherited from Property.)
Public property | Comment | Gets the comment. (Inherited from Property.)
Public property | Count | Gets the count.
Public property | Id | Gets the id. (Inherited from Property.)
Public property | Item | Gets the Rational at the specified index.
Public property | Name | Gets the name. (Inherited from Property.)
Public property | PropertyType | Gets the type of the property. (Inherited from Property.)
Public property | RawBytes | Gets the raw bytes. (Inherited from Property.)
Public property | Values | Gets the values.

See Also

RationalProperty Class
Sitecore.Drawing.Exif.Properties Namespace


RationalProperty Constructor

[image]

Sitecore 6.4.1 API
RationalProperty Constructor
RationalProperty Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RationalProperty(
    Property..::..DataType dataType,
    int id,
    byte[] raw
)
Visual Basic
Public Sub New ( _
    dataType As Property..::..DataType, _
    id As Integer, _
    raw As Byte() _
)
Visual C++
public:
RationalProperty(
    Property..::..DataType dataType,
    int id,
    array<unsigned char>^ raw
)

Parameters

dataType
Type: Sitecore.Drawing.Exif.Properties..::..Property..::..DataType
Type of the data.
id
Type: System..::..Int32
The id.
raw
Type: array< System..::..Byte >[]()[][]
The raw.

See Also

RationalProperty Class
Sitecore.Drawing.Exif.Properties Namespace


RationalProperty Methods

[image] [image]

Sitecore 6.4.1 API
RationalProperty Methods
RationalProperty Class See Also Send Feedback

The RationalProperty type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetValues | Sets the values.
Public method | ToString | Returns a String that represents the current Object. (Overrides Property..::..ToString()()()().)

See Also

RationalProperty Class
Sitecore.Drawing.Exif.Properties Namespace


SetValues Method

[image]

Sitecore 6.4.1 API
RationalProperty..::..SetValues Method
RationalProperty Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void SetValues(
    Rational[] values
)
Visual Basic
Protected Sub SetValues ( _
    values As Rational() _
)
Visual C++
protected:
void SetValues(
    array<Rational^>^ values
)

Parameters

values
Type: array< Sitecore.Drawing.Exif.Properties..::..Rational >[]()[][]
The values.

See Also

RationalProperty Class
Sitecore.Drawing.Exif.Properties Namespace


ToString Method

[image]

Sitecore 6.4.1 API
RationalProperty..::..ToString Method
RationalProperty Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

RationalProperty Class
Sitecore.Drawing.Exif.Properties Namespace


RationalProperty Properties

[image] [image]

Sitecore 6.4.1 API
RationalProperty Properties
RationalProperty Class See Also Send Feedback

The RationalProperty type exposes the following members.

Properties

 | Name | Description
Public property | Category | Gets the category. (Inherited from Property.)
Public property | Comment | Gets the comment. (Inherited from Property.)
Public property | Count | Gets the count.
Public property | Id | Gets the id. (Inherited from Property.)
Public property | Item | Gets the Rational at the specified index.
Public property | Name | Gets the name. (Inherited from Property.)
Public property | PropertyType | Gets the type of the property. (Inherited from Property.)
Public property | RawBytes | Gets the raw bytes. (Inherited from Property.)
Public property | Values | Gets the values.

See Also

RationalProperty Class
Sitecore.Drawing.Exif.Properties Namespace


Item Property

[image]

Sitecore 6.4.1 API
RationalProperty..::..Item Property
RationalProperty Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Rational this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    index As Integer _
) As Rational
    Get
Visual C++
public:
property Rational^ default[int index] {
    Rational^ get (int index);
}

Parameters

index
Type: System..::..Int32

Field Value

See Also

RationalProperty Class
Sitecore.Drawing.Exif.Properties Namespace


SignedRationalProperty Class

[image]

Sitecore 6.4.1 API
SignedRationalProperty Class
Members See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SignedRationalProperty : RationalProperty
Visual Basic
Public Class SignedRationalProperty _
    Inherits RationalProperty
Visual C++
public ref class SignedRationalProperty : public RationalProperty

Inheritance Hierarchy

System..::..Object
Sitecore.Drawing.Exif.Properties..::..Property
Sitecore.Drawing.Exif.Properties..::..RationalProperty
Sitecore.Drawing.Exif.Properties..::..SignedRationalProperty

See Also

SignedRationalProperty Members
Sitecore.Drawing.Exif.Properties Namespace


SignedRationalProperty Members

[image] [image]

Sitecore 6.4.1 API
SignedRationalProperty Members
SignedRationalProperty Class Constructors Methods Properties See Also Send Feedback

The SignedRationalProperty type exposes the following members.

Constructors

 | Name | Description
Public method | SignedRationalProperty | Initializes a new instance of the SignedRationalProperty class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetValues | Sets the values. (Inherited from RationalProperty.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from RationalProperty.)

Properties

 | Name | Description
Public property | Category | Gets the category. (Inherited from Property.)
Public property | Comment | Gets the comment. (Inherited from Property.)
Public property | Count | Gets the count. (Inherited from RationalProperty.)
Public property | Id | Gets the id. (Inherited from Property.)
Public property | Item | Gets the Rational at the specified index. (Inherited from RationalProperty.)
Public property | Name | Gets the name. (Inherited from Property.)
Public property | PropertyType | Gets the type of the property. (Inherited from Property.)
Public property | RawBytes | Gets the raw bytes. (Inherited from Property.)
Public property | Values | Gets the values. (Inherited from RationalProperty.)

See Also

SignedRationalProperty Class
Sitecore.Drawing.Exif.Properties Namespace


SignedRationalProperty Constructor

[image]

Sitecore 6.4.1 API
SignedRationalProperty Constructor
SignedRationalProperty Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SignedRationalProperty(
    int id,
    byte[] raw
)
Visual Basic
Public Sub New ( _
    id As Integer, _
    raw As Byte() _
)
Visual C++
public:
SignedRationalProperty(
    int id,
    array<unsigned char>^ raw
)

Parameters

id
Type: System..::..Int32
The id.
raw
Type: array< System..::..Byte >[]()[][]
The raw.

See Also

SignedRationalProperty Class
Sitecore.Drawing.Exif.Properties Namespace


SignedRationalProperty Methods

[image] [image]

Sitecore 6.4.1 API
SignedRationalProperty Methods
SignedRationalProperty Class See Also Send Feedback

The SignedRationalProperty type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetValues | Sets the values. (Inherited from RationalProperty.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from RationalProperty.)

See Also

SignedRationalProperty Class
Sitecore.Drawing.Exif.Properties Namespace


SignedRationalProperty Properties

[image] [image]

Sitecore 6.4.1 API
SignedRationalProperty Properties
SignedRationalProperty Class See Also Send Feedback

The SignedRationalProperty type exposes the following members.

Properties

 | Name | Description
Public property | Category | Gets the category. (Inherited from Property.)
Public property | Comment | Gets the comment. (Inherited from Property.)
Public property | Count | Gets the count. (Inherited from RationalProperty.)
Public property | Id | Gets the id. (Inherited from Property.)
Public property | Item | Gets the Rational at the specified index. (Inherited from RationalProperty.)
Public property | Name | Gets the name. (Inherited from Property.)
Public property | PropertyType | Gets the type of the property. (Inherited from Property.)
Public property | RawBytes | Gets the raw bytes. (Inherited from Property.)
Public property | Values | Gets the values. (Inherited from RationalProperty.)

See Also

SignedRationalProperty Class
Sitecore.Drawing.Exif.Properties Namespace


StringProperty Class

[image]

Sitecore 6.4.1 API
StringProperty Class
Members See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class StringProperty : Property
Visual Basic
Public Class StringProperty _
    Inherits Property
Visual C++
public ref class StringProperty : public Property

Inheritance Hierarchy

System..::..Object
Sitecore.Drawing.Exif.Properties..::..Property
Sitecore.Drawing.Exif.Properties..::..StringProperty
Sitecore.Drawing.Exif.Properties..::..CopyrightProperty
Sitecore.Drawing.Exif.Properties..::..DateTimeProperty

See Also

StringProperty Members
Sitecore.Drawing.Exif.Properties Namespace


StringProperty Members

[image] [image]

Sitecore 6.4.1 API
StringProperty Members
StringProperty Class Constructors Methods Properties See Also Send Feedback

The StringProperty type exposes the following members.

Constructors

 | Name | Description
Public method | StringProperty | Initializes a new instance of the StringProperty class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Property..::..ToString()()()().)

Properties

 | Name | Description
Public property | Category | Gets the category. (Inherited from Property.)
Public property | Comment | Gets the comment. (Inherited from Property.)
Public property | Id | Gets the id. (Inherited from Property.)
Public property | Name | Gets the name. (Inherited from Property.)
Public property | PropertyType | Gets the type of the property. (Inherited from Property.)
Public property | RawBytes | Gets the raw bytes. (Inherited from Property.)
Public property | Value | Gets the value.

See Also

StringProperty Class
Sitecore.Drawing.Exif.Properties Namespace


StringProperty Constructor

[image]

Sitecore 6.4.1 API
StringProperty Constructor
StringProperty Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StringProperty(
    int id,
    byte[] raw
)
Visual Basic
Public Sub New ( _
    id As Integer, _
    raw As Byte() _
)
Visual C++
public:
StringProperty(
    int id,
    array<unsigned char>^ raw
)

Parameters

id
Type: System..::..Int32
The id.
raw
Type: array< System..::..Byte >[]()[][]
The raw.

See Also

StringProperty Class
Sitecore.Drawing.Exif.Properties Namespace


StringProperty Methods

[image] [image]

Sitecore 6.4.1 API
StringProperty Methods
StringProperty Class See Also Send Feedback

The StringProperty type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Property..::..ToString()()()().)

See Also

StringProperty Class
Sitecore.Drawing.Exif.Properties Namespace


ToString Method

[image]

Sitecore 6.4.1 API
StringProperty..::..ToString Method
StringProperty Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

StringProperty Class
Sitecore.Drawing.Exif.Properties Namespace


StringProperty Properties

[image] [image]

Sitecore 6.4.1 API
StringProperty Properties
StringProperty Class See Also Send Feedback

The StringProperty type exposes the following members.

Properties

 | Name | Description
Public property | Category | Gets the category. (Inherited from Property.)
Public property | Comment | Gets the comment. (Inherited from Property.)
Public property | Id | Gets the id. (Inherited from Property.)
Public property | Name | Gets the name. (Inherited from Property.)
Public property | PropertyType | Gets the type of the property. (Inherited from Property.)
Public property | RawBytes | Gets the raw bytes. (Inherited from Property.)
Public property | Value | Gets the value.

See Also

StringProperty Class
Sitecore.Drawing.Exif.Properties Namespace


Value Property

[image]

Sitecore 6.4.1 API
StringProperty..::..Value Property
StringProperty Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Value { get; }
Visual Basic
Public ReadOnly Property Value As String
    Get
Visual C++
public:
property String^ Value {
    String^ get ();
}

Field Value

The value.

See Also

StringProperty Class
Sitecore.Drawing.Exif.Properties Namespace


Tag Enumeration

[image]

Sitecore 6.4.1 API
Tag Enumeration
See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum Tag
Visual Basic
Public Enumeration Tag
Visual C++
public enum class Tag

Members

Member name | Value | Description
ImageWidth | 256 |
ImageLength | 257 |
ImageHeight | 257 |
BitsPerSample | 258 |
CompressionScheme | 259 |
PhotometricInterpretation | 262 |
Orientation | 274 |
SamplesPerPixel | 277 |
PlanarConfiguration | 284 |
YCbCrSubSampling | 530 |
YCbCrPositioning | 531 |
XResolution | 282 |
YResolution | 283 |
ResolutionUnit | 296 |
StripOffsets | 273 |
RowsPerStrip | 278 |
StripByteCounts | 279 |
JPEGInterchangeFormat | 513 |
JPEGInterchangeFormatLength | 514 |
TransferFunction | 301 |
WhitePoint | 318 |
PrimaryChromaticities | 319 |
YCbCrCoefficients | 529 |
ReferenceBlackWhite | 532 |
DateTime | 306 |
ImageDescription | 270 |
Make | 271 |
Model | 272 |
Software | 305 |
Artist | 306 |
Copyright | 33432 |
ExifVersion | 36864 |
FlashpixVersion | 40960 |
ColorSpace | 40961 |
ComponentsConfiguration | 37121 |
CompressedBitsPerPixel | 37122 |
PixelXDimension | 40962 |
PixelYDimension | 40963 |
MakerNote | 37500 |
UserComment | 37510 |
RelatedSoundFile | 40964 |
DateTimeOriginal | 36867 |
DateTimeDigitized | 36868 |
SubSecTime | 37520 |
SubSecTimeOriginal | 37521 |
SubSecTimeDigitized | 37522 |
ExposureTime | 33434 |
FNumber | 33437 |
ExposureProgram | 34850 |
SpectralSensitivity | 34852 |
ISOSpeedRatings | 34855 |
OECF | 34856 |
ShutterSpeedValue | 37377 |
ApertureValue | 37378 |
BrightnessValue | 37379 |
ExposureBiasValue | 37380 |
MaxApertureValue | 37381 |
SubjectDistance | 37382 |
MeteringMode | 37383 |
LightSource | 37384 |
Flash | 37385 |
FocalLength | 37386 |
SubjectArea | 37396 |
FlashEnergy | 41483 |
SpatialFrequencyResponse | 41484 |
FocalPlaneXResolution | 41486 |
FocalPlaneYResolution | 41487 |
FocalPlaneResolutionUnit | 41488 |
SubjectLocation | 41492 |
ExposureIndex | 41493 |
SensingMethod | 41495 |
FileSource | 41728 |
SceneType | 41729 |
CFAPattern | 41730 |
CustomRendered | 41985 |
ExposureMode | 41986 |
WhiteBalance | 41987 |
DigitalZoomRatio | 41988 |
FocalLengthIn35mmFilm | 41989 |
SceneCaptureType | 41990 |
GainControl | 41991 |
Contrast | 41992 |
Saturation | 41993 |
Sharpness | 41994 |
DeviceSettingDescription | 41995 |
SubjectDistanceRange | 41996 |
ImageUniqueID | 42016 |
JpegThumbnail | 20507 |

See Also

Sitecore.Drawing.Exif.Properties Namespace


ThumbnailProperty Class

[image]

Sitecore 6.4.1 API
ThumbnailProperty Class
Members See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ThumbnailProperty : Property
Visual Basic
Public Class ThumbnailProperty _
    Inherits Property
Visual C++
public ref class ThumbnailProperty : public Property

Inheritance Hierarchy

System..::..Object
Sitecore.Drawing.Exif.Properties..::..Property
Sitecore.Drawing.Exif.Properties..::..ThumbnailProperty
Sitecore.Drawing.Exif.Properties..::..JpegThumbnailProperty

See Also

ThumbnailProperty Members
Sitecore.Drawing.Exif.Properties Namespace


ThumbnailProperty Members

[image] [image]

Sitecore 6.4.1 API
ThumbnailProperty Members
ThumbnailProperty Class Constructors Methods Properties See Also Send Feedback

The ThumbnailProperty type exposes the following members.

Constructors

 | Name | Description
Protected method | ThumbnailProperty | Initializes a new instance of the ThumbnailProperty class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetThumbnail | Sets the thumbnail.
Public method | ToString | Returns a String that represents the current Object. (Overrides Property..::..ToString()()()().)

Properties

 | Name | Description
Public property | Category | Gets the category. (Inherited from Property.)
Public property | Comment | Gets the comment. (Inherited from Property.)
Public property | Id | Gets the id. (Inherited from Property.)
Public property | Name | Gets the name. (Inherited from Property.)
Public property | PropertyType | Gets the type of the property. (Inherited from Property.)
Public property | RawBytes | Gets the raw bytes. (Inherited from Property.)
Public property | Thumbnail | Gets the thumbnail.

See Also

ThumbnailProperty Class
Sitecore.Drawing.Exif.Properties Namespace


ThumbnailProperty Constructor

[image]

Sitecore 6.4.1 API
ThumbnailProperty Constructor
ThumbnailProperty Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected ThumbnailProperty(
    Property..::..DataType dataType,
    int id,
    byte[] raw
)
Visual Basic
Protected Sub New ( _
    dataType As Property..::..DataType, _
    id As Integer, _
    raw As Byte() _
)
Visual C++
protected:
ThumbnailProperty(
    Property..::..DataType dataType,
    int id,
    array<unsigned char>^ raw
)

Parameters

dataType
Type: Sitecore.Drawing.Exif.Properties..::..Property..::..DataType
Type of the data.
id
Type: System..::..Int32
The id.
raw
Type: array< System..::..Byte >[]()[][]
The raw.

See Also

ThumbnailProperty Class
Sitecore.Drawing.Exif.Properties Namespace


ThumbnailProperty Methods

[image] [image]

Sitecore 6.4.1 API
ThumbnailProperty Methods
ThumbnailProperty Class See Also Send Feedback

The ThumbnailProperty type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetThumbnail | Sets the thumbnail.
Public method | ToString | Returns a String that represents the current Object. (Overrides Property..::..ToString()()()().)

See Also

ThumbnailProperty Class
Sitecore.Drawing.Exif.Properties Namespace


ToString Method

[image]

Sitecore 6.4.1 API
ThumbnailProperty..::..ToString Method
ThumbnailProperty Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

ThumbnailProperty Class
Sitecore.Drawing.Exif.Properties Namespace


ThumbnailProperty Properties

[image] [image]

Sitecore 6.4.1 API
ThumbnailProperty Properties
ThumbnailProperty Class See Also Send Feedback

The ThumbnailProperty type exposes the following members.

Properties

 | Name | Description
Public property | Category | Gets the category. (Inherited from Property.)
Public property | Comment | Gets the comment. (Inherited from Property.)
Public property | Id | Gets the id. (Inherited from Property.)
Public property | Name | Gets the name. (Inherited from Property.)
Public property | PropertyType | Gets the type of the property. (Inherited from Property.)
Public property | RawBytes | Gets the raw bytes. (Inherited from Property.)
Public property | Thumbnail | Gets the thumbnail.

See Also

ThumbnailProperty Class
Sitecore.Drawing.Exif.Properties Namespace


Thumbnail Property

[image]

Sitecore 6.4.1 API
ThumbnailProperty..::..Thumbnail Property
ThumbnailProperty Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Image Thumbnail { get; }
Visual Basic
Public ReadOnly Property Thumbnail As Image
    Get
Visual C++
public:
property Image^ Thumbnail {
    Image^ get ();
}

Field Value

The thumbnail.

See Also

ThumbnailProperty Class
Sitecore.Drawing.Exif.Properties Namespace


UInt16Property Class

[image]

Sitecore 6.4.1 API
UInt16Property Class
Members See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class UInt16Property : IntegerProperty
Visual Basic
Public Class UInt16Property _
    Inherits IntegerProperty
Visual C++
public ref class UInt16Property : public IntegerProperty

Inheritance Hierarchy

System..::..Object
Sitecore.Drawing.Exif.Properties..::..Property
Sitecore.Drawing.Exif.Properties..::..IntegerProperty
Sitecore.Drawing.Exif.Properties..::..UInt16Property

See Also

UInt16Property Members
Sitecore.Drawing.Exif.Properties Namespace


UInt16Property Members

[image] [image]

Sitecore 6.4.1 API
UInt16Property Members
UInt16Property Class Constructors Methods Properties See Also Send Feedback

The UInt16Property type exposes the following members.

Constructors

 | Name | Description
Public method | UInt16Property | Initializes a new instance of the UInt16Property class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValueComment | Gets the value comment. (Inherited from IntegerProperty.)
Public method | GetValueName | Gets the name of the value. (Inherited from IntegerProperty.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetValues | Sets the values. (Inherited from IntegerProperty.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Property.)

Properties

 | Name | Description
Public property | Category | Gets the category. (Inherited from Property.)
Public property | Comment | Gets the comment. (Inherited from Property.)
Public property | Count | Gets the count. (Inherited from IntegerProperty.)
Public property | Id | Gets the id. (Inherited from Property.)
Public property | Item | Gets the Int64 at the specified index. (Inherited from IntegerProperty.)
Public property | Name | Gets the name. (Inherited from Property.)
Public property | PropertyType | Gets the type of the property. (Inherited from Property.)
Public property | RawBytes | Gets the raw bytes. (Inherited from Property.)
Public property | ValueComments | Gets the value comments. (Inherited from IntegerProperty.)
Public property | ValueNames | Gets the value names. (Inherited from IntegerProperty.)
Public property | Values | Gets the values. (Inherited from IntegerProperty.)

See Also

UInt16Property Class
Sitecore.Drawing.Exif.Properties Namespace


UInt16Property Constructor

[image]

Sitecore 6.4.1 API
UInt16Property Constructor
UInt16Property Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UInt16Property(
    int id,
    byte[] raw
)
Visual Basic
Public Sub New ( _
    id As Integer, _
    raw As Byte() _
)
Visual C++
public:
UInt16Property(
    int id,
    array<unsigned char>^ raw
)

Parameters

id
Type: System..::..Int32
The id.
raw
Type: array< System..::..Byte >[]()[][]
The raw.

See Also

UInt16Property Class
Sitecore.Drawing.Exif.Properties Namespace


UInt16Property Methods

[image] [image]

Sitecore 6.4.1 API
UInt16Property Methods
UInt16Property Class See Also Send Feedback

The UInt16Property type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValueComment | Gets the value comment. (Inherited from IntegerProperty.)
Public method | GetValueName | Gets the name of the value. (Inherited from IntegerProperty.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetValues | Sets the values. (Inherited from IntegerProperty.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Property.)

See Also

UInt16Property Class
Sitecore.Drawing.Exif.Properties Namespace


UInt16Property Properties

[image] [image]

Sitecore 6.4.1 API
UInt16Property Properties
UInt16Property Class See Also Send Feedback

The UInt16Property type exposes the following members.

Properties

 | Name | Description
Public property | Category | Gets the category. (Inherited from Property.)
Public property | Comment | Gets the comment. (Inherited from Property.)
Public property | Count | Gets the count. (Inherited from IntegerProperty.)
Public property | Id | Gets the id. (Inherited from Property.)
Public property | Item | Gets the Int64 at the specified index. (Inherited from IntegerProperty.)
Public property | Name | Gets the name. (Inherited from Property.)
Public property | PropertyType | Gets the type of the property. (Inherited from Property.)
Public property | RawBytes | Gets the raw bytes. (Inherited from Property.)
Public property | ValueComments | Gets the value comments. (Inherited from IntegerProperty.)
Public property | ValueNames | Gets the value names. (Inherited from IntegerProperty.)
Public property | Values | Gets the values. (Inherited from IntegerProperty.)

See Also

UInt16Property Class
Sitecore.Drawing.Exif.Properties Namespace


UInt32Property Class

[image]

Sitecore 6.4.1 API
UInt32Property Class
Members See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class UInt32Property : IntegerProperty
Visual Basic
Public Class UInt32Property _
    Inherits IntegerProperty
Visual C++
public ref class UInt32Property : public IntegerProperty

Inheritance Hierarchy

System..::..Object
Sitecore.Drawing.Exif.Properties..::..Property
Sitecore.Drawing.Exif.Properties..::..IntegerProperty
Sitecore.Drawing.Exif.Properties..::..UInt32Property

See Also

UInt32Property Members
Sitecore.Drawing.Exif.Properties Namespace


UInt32Property Constructor

[image]

Sitecore 6.4.1 API
UInt32Property Constructor
UInt32Property Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UInt32Property(
    int id,
    byte[] raw
)
Visual Basic
Public Sub New ( _
    id As Integer, _
    raw As Byte() _
)
Visual C++
public:
UInt32Property(
    int id,
    array<unsigned char>^ raw
)

Parameters

id
Type: System..::..Int32
The id.
raw
Type: array< System..::..Byte >[]()[][]
The raw.

See Also

UInt32Property Class
Sitecore.Drawing.Exif.Properties Namespace


UInt32Property Methods

[image] [image]

Sitecore 6.4.1 API
UInt32Property Methods
UInt32Property Class See Also Send Feedback

The UInt32Property type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValueComment | Gets the value comment. (Inherited from IntegerProperty.)
Public method | GetValueName | Gets the name of the value. (Inherited from IntegerProperty.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetValues | Sets the values. (Inherited from IntegerProperty.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Property.)

See Also

UInt32Property Class
Sitecore.Drawing.Exif.Properties Namespace


UInt32Property Properties

[image] [image]

Sitecore 6.4.1 API
UInt32Property Properties
UInt32Property Class See Also Send Feedback

The UInt32Property type exposes the following members.

Properties

 | Name | Description
Public property | Category | Gets the category. (Inherited from Property.)
Public property | Comment | Gets the comment. (Inherited from Property.)
Public property | Count | Gets the count. (Inherited from IntegerProperty.)
Public property | Id | Gets the id. (Inherited from Property.)
Public property | Item | Gets the Int64 at the specified index. (Inherited from IntegerProperty.)
Public property | Name | Gets the name. (Inherited from Property.)
Public property | PropertyType | Gets the type of the property. (Inherited from Property.)
Public property | RawBytes | Gets the raw bytes. (Inherited from Property.)
Public property | ValueComments | Gets the value comments. (Inherited from IntegerProperty.)
Public property | ValueNames | Gets the value names. (Inherited from IntegerProperty.)
Public property | Values | Gets the values. (Inherited from IntegerProperty.)

See Also

UInt32Property Class
Sitecore.Drawing.Exif.Properties Namespace


UndefinedProperty Class

[image]

Sitecore 6.4.1 API
UndefinedProperty Class
Members See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class UndefinedProperty : Property
Visual Basic
Public Class UndefinedProperty _
    Inherits Property
Visual C++
public ref class UndefinedProperty : public Property

Inheritance Hierarchy

System..::..Object
Sitecore.Drawing.Exif.Properties..::..Property
Sitecore.Drawing.Exif.Properties..::..UndefinedProperty

See Also

UndefinedProperty Members
Sitecore.Drawing.Exif.Properties Namespace


UndefinedProperty Members

[image] [image]

Sitecore 6.4.1 API
UndefinedProperty Members
UndefinedProperty Class Constructors Methods Properties See Also Send Feedback

The UndefinedProperty type exposes the following members.

Constructors

 | Name | Description
Public method | UndefinedProperty | Initializes a new instance of the UndefinedProperty class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Property.)

Properties

 | Name | Description
Public property | Category | Gets the category. (Inherited from Property.)
Public property | Comment | Gets the comment. (Inherited from Property.)
Public property | Id | Gets the id. (Inherited from Property.)
Public property | Name | Gets the name. (Inherited from Property.)
Public property | PropertyType | Gets the type of the property. (Inherited from Property.)
Public property | RawBytes | Gets the raw bytes. (Inherited from Property.)

See Also

UndefinedProperty Class
Sitecore.Drawing.Exif.Properties Namespace


UndefinedProperty Constructor

[image]

Sitecore 6.4.1 API
UndefinedProperty Constructor
UndefinedProperty Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UndefinedProperty(
    int id,
    byte[] raw
)
Visual Basic
Public Sub New ( _
    id As Integer, _
    raw As Byte() _
)
Visual C++
public:
UndefinedProperty(
    int id,
    array<unsigned char>^ raw
)

Parameters

id
Type: System..::..Int32
The id.
raw
Type: array< System..::..Byte >[]()[][]
The raw.

See Also

UndefinedProperty Class
Sitecore.Drawing.Exif.Properties Namespace


UndefinedProperty Methods

[image] [image]

Sitecore 6.4.1 API
UndefinedProperty Methods
UndefinedProperty Class See Also Send Feedback

The UndefinedProperty type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Property.)

See Also

UndefinedProperty Class
Sitecore.Drawing.Exif.Properties Namespace


UndefinedProperty Properties

[image] [image]

Sitecore 6.4.1 API
UndefinedProperty Properties
UndefinedProperty Class See Also Send Feedback

The UndefinedProperty type exposes the following members.

Properties

 | Name | Description
Public property | Category | Gets the category. (Inherited from Property.)
Public property | Comment | Gets the comment. (Inherited from Property.)
Public property | Id | Gets the id. (Inherited from Property.)
Public property | Name | Gets the name. (Inherited from Property.)
Public property | PropertyType | Gets the type of the property. (Inherited from Property.)
Public property | RawBytes | Gets the raw bytes. (Inherited from Property.)

See Also

UndefinedProperty Class
Sitecore.Drawing.Exif.Properties Namespace


UnsignedRationalProperty Class

[image]

Sitecore 6.4.1 API
UnsignedRationalProperty Class
Members See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class UnsignedRationalProperty : RationalProperty
Visual Basic
Public Class UnsignedRationalProperty _
    Inherits RationalProperty
Visual C++
public ref class UnsignedRationalProperty : public RationalProperty

Inheritance Hierarchy

System..::..Object
Sitecore.Drawing.Exif.Properties..::..Property
Sitecore.Drawing.Exif.Properties..::..RationalProperty
Sitecore.Drawing.Exif.Properties..::..UnsignedRationalProperty

See Also

UnsignedRationalProperty Members
Sitecore.Drawing.Exif.Properties Namespace


UnsignedRationalProperty Members

[image] [image]

Sitecore 6.4.1 API
UnsignedRationalProperty Members
UnsignedRationalProperty Class Constructors Methods Properties See Also Send Feedback

The UnsignedRationalProperty type exposes the following members.

Constructors

 | Name | Description
Public method | UnsignedRationalProperty | Initializes a new instance of the UnsignedRationalProperty class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetValues | Sets the values. (Inherited from RationalProperty.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from RationalProperty.)

Properties

 | Name | Description
Public property | Category | Gets the category. (Inherited from Property.)
Public property | Comment | Gets the comment. (Inherited from Property.)
Public property | Count | Gets the count. (Inherited from RationalProperty.)
Public property | Id | Gets the id. (Inherited from Property.)
Public property | Item | Gets the Rational at the specified index. (Inherited from RationalProperty.)
Public property | Name | Gets the name. (Inherited from Property.)
Public property | PropertyType | Gets the type of the property. (Inherited from Property.)
Public property | RawBytes | Gets the raw bytes. (Inherited from Property.)
Public property | Values | Gets the values. (Inherited from RationalProperty.)

See Also

UnsignedRationalProperty Class
Sitecore.Drawing.Exif.Properties Namespace


UnsignedRationalProperty Constructor

[image]

Sitecore 6.4.1 API
UnsignedRationalProperty Constructor
UnsignedRationalProperty Class See Also Send Feedback

Namespace: Sitecore.Drawing.Exif.Properties
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UnsignedRationalProperty(
    int id,
    byte[] raw
)
Visual Basic
Public Sub New ( _
    id As Integer, _
    raw As Byte() _
)
Visual C++
public:
UnsignedRationalProperty(
    int id,
    array<unsigned char>^ raw
)

Parameters

id
Type: System..::..Int32
The id.
raw
Type: array< System..::..Byte >[]()[][]
The raw.

See Also

UnsignedRationalProperty Class
Sitecore.Drawing.Exif.Properties Namespace


UnsignedRationalProperty Methods

[image] [image]

Sitecore 6.4.1 API
UnsignedRationalProperty Methods
UnsignedRationalProperty Class See Also Send Feedback

The UnsignedRationalProperty type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetValues | Sets the values. (Inherited from RationalProperty.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from RationalProperty.)

See Also

UnsignedRationalProperty Class
Sitecore.Drawing.Exif.Properties Namespace


UnsignedRationalProperty Properties

[image] [image]

Sitecore 6.4.1 API
UnsignedRationalProperty Properties
UnsignedRationalProperty Class See Also Send Feedback

The UnsignedRationalProperty type exposes the following members.

Properties

 | Name | Description
Public property | Category | Gets the category. (Inherited from Property.)
Public property | Comment | Gets the comment. (Inherited from Property.)
Public property | Count | Gets the count. (Inherited from RationalProperty.)
Public property | Id | Gets the id. (Inherited from Property.)
Public property | Item | Gets the Rational at the specified index. (Inherited from RationalProperty.)
Public property | Name | Gets the name. (Inherited from Property.)
Public property | PropertyType | Gets the type of the property. (Inherited from Property.)
Public property | RawBytes | Gets the raw bytes. (Inherited from Property.)
Public property | Values | Gets the values. (Inherited from RationalProperty.)

See Also

UnsignedRationalProperty Class
Sitecore.Drawing.Exif.Properties Namespace


Sitecore.DynamicSerialization Namespace

[image]

Sitecore 6.4.1 API
Sitecore.DynamicSerialization Namespace
Send Feedback

Classes

 | Class | Description
Public class | Deserializer | Represents a deserializer
Public class | Serializer | Represents a serializer
Public class | SilentEvents | Represents a stab object which implements ISerializationEvents interface
Public class | SimpleObjectContext | Represents a simple serialization context
Public class | SmartObjectFactory | Represents an object factory

Interfaces

 | Interface | Description
Public interface | ILogger | Defines basic methods for a logger
Public interface | IObjectFactory | Defines basic methods of an object factory
Public interface | ISerializationContext | Defines basic properties of a serialization context
Public interface | ISerializationEvents | Defines events which can be handled during a deserialization process


Deserializer Class

[image]

Sitecore 6.4.1 API
Deserializer Class
Members See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Deserializer
Visual Basic
Public NotInheritable Class Deserializer
Visual C++
public ref class Deserializer abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.DynamicSerialization..::..Deserializer

See Also

Deserializer Members
Sitecore.DynamicSerialization Namespace


Deserializer Members

[image] [image]

Sitecore 6.4.1 API
Deserializer Members
Deserializer Class Methods Fields See Also Send Feedback

The Deserializer type exposes the following members.

Methods

Name | Description
Deserialize | Deserializes an object from the specified text reader.

Fields

Name | Description
ItemElementName | Item element name
NullElementName | Null element name
PairElementName | Pair element name

See Also

Deserializer Class
Sitecore.DynamicSerialization Namespace


Deserializer Fields

[image] [image]

Sitecore 6.4.1 API
Deserializer Fields
Deserializer Class See Also Send Feedback

The Deserializer type exposes the following members.

Fields

Name | Description
ItemElementName | Item element name
NullElementName | Null element name
PairElementName | Pair element name

See Also

Deserializer Class
Sitecore.DynamicSerialization Namespace


ItemElementName Field

[image]

Sitecore 6.4.1 API
Deserializer..::..ItemElementName Field
Deserializer Class See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly string ItemElementName
Visual Basic
Public Shared ReadOnly ItemElementName As String
Visual C++
public:
static initonly String^ ItemElementName

See Also

Deserializer Class
Sitecore.DynamicSerialization Namespace


NullElementName Field

[image]

Sitecore 6.4.1 API
Deserializer..::..NullElementName Field
Deserializer Class See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly string NullElementName
Visual Basic
Public Shared ReadOnly NullElementName As String
Visual C++
public:
static initonly String^ NullElementName

See Also

Deserializer Class
Sitecore.DynamicSerialization Namespace


PairElementName Field

[image]

Sitecore 6.4.1 API
Deserializer..::..PairElementName Field
Deserializer Class See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly string PairElementName
Visual Basic
Public Shared ReadOnly PairElementName As String
Visual C++
public:
static initonly String^ PairElementName

See Also

Deserializer Class
Sitecore.DynamicSerialization Namespace


Deserializer Methods

[image] [image]

Sitecore 6.4.1 API
Deserializer Methods
Deserializer Class See Also Send Feedback

The Deserializer type exposes the following members.

Methods

Name | Description
Deserialize | Deserializes an object from the specified text reader.

See Also

Deserializer Class
Sitecore.DynamicSerialization Namespace


Deserialize Method

[image]

Sitecore 6.4.1 API
Deserializer..::..Deserialize Method
Deserializer Class See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object Deserialize(
    TextReader reader,
    ISerializationContext context
)
Visual Basic
Public Shared Function Deserialize ( _
    reader As TextReader, _
    context As ISerializationContext _
) As Object
Visual C++
public:
static Object^ Deserialize(
    TextReader^ reader,
    ISerializationContext^ context
)

Parameters

reader
Type: System.IO..::..TextReader
The reader.
context
Type: Sitecore.DynamicSerialization..::..ISerializationContext
The serialization context.

Return Value

The serialized object.

See Also

Deserializer Class
Sitecore.DynamicSerialization Namespace


ILogger Interface

[image]

Sitecore 6.4.1 API
ILogger Interface
Members See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface ILogger
Visual Basic
Public Interface ILogger
Visual C++
public interface class ILogger

See Also

ILogger Members
Sitecore.DynamicSerialization Namespace


ILogger Members

[image] [image]

Sitecore 6.4.1 API
ILogger Members
ILogger Interface Methods See Also Send Feedback

The ILogger type exposes the following members.

Methods

 | Name | Description
Public method | Error | Audits an error
Public method | Info | Audits some information

See Also

ILogger Interface
Sitecore.DynamicSerialization Namespace


ILogger Methods

[image] [image]

Sitecore 6.4.1 API
ILogger Methods
ILogger Interface See Also Send Feedback

The ILogger type exposes the following members.

Methods

 | Name | Description
Public method | Error | Audits an error
Public method | Info | Audits some information

See Also

ILogger Interface
Sitecore.DynamicSerialization Namespace


Error Method

[image]

Sitecore 6.4.1 API
ILogger..::..Error Method
ILogger Interface See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void Error(
    string format,
    params Object[] args
)
Visual Basic
Sub Error ( _
    format As String, _
    ParamArray args As Object() _
)
Visual C++
void Error(
    String^ format,
    ... array<Object^>^ args
)

Parameters

format
Type: System..::..String
The format string.
args
Type: array< System..::..Object >[]()[][]
The arguments.

See Also

ILogger Interface
Sitecore.DynamicSerialization Namespace


Info Method

[image]

Sitecore 6.4.1 API
ILogger..::..Info Method
ILogger Interface See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void Info(
    string format,
    params Object[] args
)
Visual Basic
Sub Info ( _
    format As String, _
    ParamArray args As Object() _
)
Visual C++
void Info(
    String^ format,
    ... array<Object^>^ args
)

Parameters

format
Type: System..::..String
The format string.
args
Type: array< System..::..Object >[]()[][]
The arguments.

See Also

ILogger Interface
Sitecore.DynamicSerialization Namespace


IObjectFactory Interface

[image]

Sitecore 6.4.1 API
IObjectFactory Interface
Members See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IObjectFactory
Visual Basic
Public Interface IObjectFactory
Visual C++
public interface class IObjectFactory

See Also

IObjectFactory Members
Sitecore.DynamicSerialization Namespace


IObjectFactory Members

[image] [image]

Sitecore 6.4.1 API
IObjectFactory Members
IObjectFactory Interface Methods See Also Send Feedback

The IObjectFactory type exposes the following members.

Methods

 | Name | Description
Public method | GetElementName | Gets the name of the element by instance
Public method | GetType | Gets the type by element.
Public method | Register | Registers the specified element.

See Also

IObjectFactory Interface
Sitecore.DynamicSerialization Namespace


GetElementName Method

[image]

Sitecore 6.4.1 API
IObjectFactory..::..GetElementName Method
IObjectFactory Interface See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
string GetElementName(
    Object object
)
Visual Basic
Function GetElementName ( _
    object As Object _
) As String
Visual C++
String^ GetElementName(
    Object^ object
)

Parameters

object
Type: System..::..Object
Instance of type

Return Value

[Missing <returns> documentation for "M:Sitecore.DynamicSerialization.IObjectFactory.GetElementName(System.Object)"]

See Also

IObjectFactory Interface
Sitecore.DynamicSerialization Namespace


GetType Method

[image]

Sitecore 6.4.1 API
IObjectFactory..::..GetType Method
IObjectFactory Interface See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
Type GetType(
    string element
)
Visual Basic
Function GetType ( _
    element As String _
) As Type
Visual C++
Type^ GetType(
    String^ element
)

Parameters

element
Type: System..::..String
The element name

Return Value

The type

See Also

IObjectFactory Interface
Sitecore.DynamicSerialization Namespace


ISerializationContext Interface

[image]

Sitecore 6.4.1 API
ISerializationContext Interface
Members See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface ISerializationContext
Visual Basic
Public Interface ISerializationContext
Visual C++
public interface class ISerializationContext

See Also

ISerializationContext Members
Sitecore.DynamicSerialization Namespace


ISerializationContext Members

[image] [image]

Sitecore 6.4.1 API
ISerializationContext Members
ISerializationContext Interface Properties See Also Send Feedback

The ISerializationContext type exposes the following members.

Properties

 | Name | Description
Public property | Events | Gets the events.
Public property | Factory | Gets the factory.
Public property | Log | Gets the logger.

See Also

ISerializationContext Interface
Sitecore.DynamicSerialization Namespace


ISerializationContext Properties

[image] [image]

Sitecore 6.4.1 API
ISerializationContext Properties
ISerializationContext Interface See Also Send Feedback

The ISerializationContext type exposes the following members.

Properties

 | Name | Description
Public property | Events | Gets the events.
Public property | Factory | Gets the factory.
Public property | Log | Gets the logger.

See Also

ISerializationContext Interface
Sitecore.DynamicSerialization Namespace


Events Property

[image]

Sitecore 6.4.1 API
ISerializationContext..::..Events Property
ISerializationContext Interface See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
ISerializationEvents Events { get; }
Visual Basic
ReadOnly Property Events As ISerializationEvents
    Get
Visual C++
property ISerializationEvents^ Events {
    ISerializationEvents^ get ();
}

Field Value

The events.

See Also

ISerializationContext Interface
Sitecore.DynamicSerialization Namespace


Factory Property

[image]

Sitecore 6.4.1 API
ISerializationContext..::..Factory Property
ISerializationContext Interface See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
IObjectFactory Factory { get; }
Visual Basic
ReadOnly Property Factory As IObjectFactory
    Get
Visual C++
property IObjectFactory^ Factory {
    IObjectFactory^ get ();
}

Field Value

The factory.

See Also

ISerializationContext Interface
Sitecore.DynamicSerialization Namespace


Log Property

[image]

Sitecore 6.4.1 API
ISerializationContext..::..Log Property
ISerializationContext Interface See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
ILogger Log { get; }
Visual Basic
ReadOnly Property Log As ILogger
    Get
Visual C++
property ILogger^ Log {
    ILogger^ get ();
}

Field Value

The logger.

See Also

ISerializationContext Interface
Sitecore.DynamicSerialization Namespace


ISerializationEvents Interface

[image]

Sitecore 6.4.1 API
ISerializationEvents Interface
Members See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface ISerializationEvents
Visual Basic
Public Interface ISerializationEvents
Visual C++
public interface class ISerializationEvents

See Also

ISerializationEvents Members
Sitecore.DynamicSerialization Namespace


ISerializationEvents Members

[image] [image]

Sitecore 6.4.1 API
ISerializationEvents Members
ISerializationEvents Interface Methods See Also Send Feedback

The ISerializationEvents type exposes the following members.

Methods

 | Name | Description
Public method | SuppressedException | Action on suppressing an exception
Public method | UnknownElement | Action on deserializing an unknown element.
Public method | UnsupportedNodeType | Action on parsing an unsupported type of the node.

See Also

ISerializationEvents Interface
Sitecore.DynamicSerialization Namespace


ISerializationEvents Methods

[image] [image]

Sitecore 6.4.1 API
ISerializationEvents Methods
ISerializationEvents Interface See Also Send Feedback

The ISerializationEvents type exposes the following members.

Methods

 | Name | Description
Public method | SuppressedException | Action on suppressing an exception
Public method | UnknownElement | Action on deserializing an unknown element.
Public method | UnsupportedNodeType | Action on parsing an unsupported type of the node.

See Also

ISerializationEvents Interface
Sitecore.DynamicSerialization Namespace


SuppressedException Method

[image]

Sitecore 6.4.1 API
ISerializationEvents..::..SuppressedException Method
ISerializationEvents Interface See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void SuppressedException(
    Exception exception,
    ISerializationContext context
)
Visual Basic
Sub SuppressedException ( _
    exception As Exception, _
    context As ISerializationContext _
)
Visual C++
void SuppressedException(
    Exception^ exception,
    ISerializationContext^ context
)

Parameters

exception
Type: System..::..Exception
The exception.
context
Type: Sitecore.DynamicSerialization..::..ISerializationContext
The context.

See Also

ISerializationEvents Interface
Sitecore.DynamicSerialization Namespace


UnknownElement Method

[image]

Sitecore 6.4.1 API
ISerializationEvents..::..UnknownElement Method
ISerializationEvents Interface See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void UnknownElement(
    string element,
    ISerializationContext context
)
Visual Basic
Sub UnknownElement ( _
    element As String, _
    context As ISerializationContext _
)
Visual C++
void UnknownElement(
    String^ element,
    ISerializationContext^ context
)

Parameters

element
Type: System..::..String
The element.
context
Type: Sitecore.DynamicSerialization..::..ISerializationContext
The context.

See Also

ISerializationEvents Interface
Sitecore.DynamicSerialization Namespace


UnsupportedNodeType Method

[image]

Sitecore 6.4.1 API
ISerializationEvents..::..UnsupportedNodeType Method
ISerializationEvents Interface See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void UnsupportedNodeType(
    XmlReader reader,
    ISerializationContext context
)
Visual Basic
Sub UnsupportedNodeType ( _
    reader As XmlReader, _
    context As ISerializationContext _
)
Visual C++
void UnsupportedNodeType(
    XmlReader^ reader,
    ISerializationContext^ context
)

Parameters

reader
Type: System.Xml..::..XmlReader
The reader.
context
Type: Sitecore.DynamicSerialization..::..ISerializationContext
The context.

See Also

ISerializationEvents Interface
Sitecore.DynamicSerialization Namespace


Serializer Class

[image]

Sitecore 6.4.1 API
Serializer Class
Members See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Serializer
Visual Basic
Public NotInheritable Class Serializer
Visual C++
public ref class Serializer abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.DynamicSerialization..::..Serializer

See Also

Serializer Members
Sitecore.DynamicSerialization Namespace


Serializer Members

[image] [image]

Sitecore 6.4.1 API
Serializer Members
Serializer Class Methods Fields See Also Send Feedback

The Serializer type exposes the following members.

Methods

Name | Description
Deserialize | Deserializes the object from the specified reader.
Serialize(TextWriter, Object, ISerializationContext) | Serializes the object to the specified writer.
Serialize(TextWriter, Formatting, Object, ISerializationContext) | Serializes the object to the specified writer.

Fields

Name | Description
ItemElementName | Item element name
NullElementName | Null element name
PairElementName | Pair element name

See Also

Serializer Class
Sitecore.DynamicSerialization Namespace


Serializer Fields

[image] [image]

Sitecore 6.4.1 API
Serializer Fields
Serializer Class See Also Send Feedback

The Serializer type exposes the following members.

Fields

Name | Description
ItemElementName | Item element name
NullElementName | Null element name
PairElementName | Pair element name

See Also

Serializer Class
Sitecore.DynamicSerialization Namespace


ItemElementName Field

[image]

Sitecore 6.4.1 API
Serializer..::..ItemElementName Field
Serializer Class See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly string ItemElementName
Visual Basic
Public Shared ReadOnly ItemElementName As String
Visual C++
public:
static initonly String^ ItemElementName

See Also

Serializer Class
Sitecore.DynamicSerialization Namespace


NullElementName Field

[image]

Sitecore 6.4.1 API
Serializer..::..NullElementName Field
Serializer Class See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly string NullElementName
Visual Basic
Public Shared ReadOnly NullElementName As String
Visual C++
public:
static initonly String^ NullElementName

See Also

Serializer Class
Sitecore.DynamicSerialization Namespace


PairElementName Field

[image]

Sitecore 6.4.1 API
Serializer..::..PairElementName Field
Serializer Class See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly string PairElementName
Visual Basic
Public Shared ReadOnly PairElementName As String
Visual C++
public:
static initonly String^ PairElementName

See Also

Serializer Class
Sitecore.DynamicSerialization Namespace


Serializer Methods

[image] [image]

Sitecore 6.4.1 API
Serializer Methods
Serializer Class See Also Send Feedback

The Serializer type exposes the following members.

Methods

Name | Description
Deserialize | Deserializes the object from the specified reader.
Serialize(TextWriter, Object, ISerializationContext) | Serializes the object to the specified writer.
Serialize(TextWriter, Formatting, Object, ISerializationContext) | Serializes the object to the specified writer.

See Also

Serializer Class
Sitecore.DynamicSerialization Namespace


Deserialize Method

[image]

Sitecore 6.4.1 API
Serializer..::..Deserialize Method
Serializer Class See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object Deserialize(
    TextReader reader,
    ISerializationContext context
)
Visual Basic
Public Shared Function Deserialize ( _
    reader As TextReader, _
    context As ISerializationContext _
) As Object
Visual C++
public:
static Object^ Deserialize(
    TextReader^ reader,
    ISerializationContext^ context
)

Parameters

reader
Type: System.IO..::..TextReader
The reader.
context
Type: Sitecore.DynamicSerialization..::..ISerializationContext
The serialization context.

Return Value

The serialized object.

See Also

Serializer Class
Sitecore.DynamicSerialization Namespace


Serialize Method

[image] [image]

Sitecore 6.4.1 API
Serializer..::..Serialize Method
Serializer Class See Also Send Feedback

Overload List

Name | Description
Serialize(TextWriter, Object, ISerializationContext) | Serializes the object to the specified writer.
Serialize(TextWriter, Formatting, Object, ISerializationContext) | Serializes the object to the specified writer.

See Also

Serializer Class
Serializer Members
Sitecore.DynamicSerialization Namespace


Serialize Method (TextWriter, Object, ISerializationContext)

[image]

Sitecore 6.4.1 API
Serializer..::..Serialize Method (TextWriter, Object, ISerializationContext)
Serializer Class See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Serialize(
    TextWriter writer,
    Object object,
    ISerializationContext context
)
Visual Basic
Public Shared Sub Serialize ( _
    writer As TextWriter, _
    object As Object, _
    context As ISerializationContext _
)
Visual C++
public:
static void Serialize(
    TextWriter^ writer,
    Object^ object,
    ISerializationContext^ context
)

Parameters

writer
Type: System.IO..::..TextWriter
The text writer.
object
Type: System..::..Object
The object to be serialized.
context
Type: Sitecore.DynamicSerialization..::..ISerializationContext
The serialization context.

See Also

Serializer Class
Serialize Overload
Sitecore.DynamicSerialization Namespace


Serialize Method (TextWriter, Formatting, Object, ISerializationContext)

[image]

Sitecore 6.4.1 API
Serializer..::..Serialize Method (TextWriter, Formatting, Object, ISerializationContext)
Serializer Class See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Serialize(
    TextWriter writer,
    Formatting formatting,
    Object object,
    ISerializationContext context
)
Visual Basic
Public Shared Sub Serialize ( _
    writer As TextWriter, _
    formatting As Formatting, _
    object As Object, _
    context As ISerializationContext _
)
Visual C++
public:
static void Serialize(
    TextWriter^ writer,
    Formatting formatting,
    Object^ object,
    ISerializationContext^ context
)

Parameters

writer
Type: System.IO..::..TextWriter
The text writer.
formatting
Type: System.Xml..::..Formatting
The xml formatting.
object
Type: System..::..Object
The object to be serialized.
context
Type: Sitecore.DynamicSerialization..::..ISerializationContext
The serialization context.

See Also

Serializer Class
Serialize Overload
Sitecore.DynamicSerialization Namespace


SilentEvents Class

[image]

Sitecore 6.4.1 API
SilentEvents Class
Members See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SilentEvents : ISerializationEvents
Visual Basic
Public Class SilentEvents _
    Implements ISerializationEvents
Visual C++
public ref class SilentEvents : ISerializationEvents

Inheritance Hierarchy

System..::..Object
Sitecore.DynamicSerialization..::..SilentEvents

See Also

SilentEvents Members
Sitecore.DynamicSerialization Namespace


SilentEvents Members

[image] [image]

Sitecore 6.4.1 API
SilentEvents Members
SilentEvents Class Constructors Methods See Also Send Feedback

The SilentEvents type exposes the following members.

Constructors

 | Name | Description
Public method | SilentEvents | Initializes a new instance of the SilentEvents class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SuppressedException | Action on suppressing an exception
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UnknownElement | Action on deserializing an unknown element.
Public method | UnsupportedNodeType | Action on parsing an unsupported type of the node.

See Also

SilentEvents Class
Sitecore.DynamicSerialization Namespace


SilentEvents Constructor

[image]

Sitecore 6.4.1 API
SilentEvents Constructor
SilentEvents Class See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SilentEvents()
Visual Basic
Public Sub New
Visual C++
public:
SilentEvents()

See Also

SilentEvents Class
Sitecore.DynamicSerialization Namespace


SilentEvents Methods

[image] [image]

Sitecore 6.4.1 API
SilentEvents Methods
SilentEvents Class See Also Send Feedback

The SilentEvents type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SuppressedException | Action on suppressing an exception
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UnknownElement | Action on deserializing an unknown element.
Public method | UnsupportedNodeType | Action on parsing an unsupported type of the node.

See Also

SilentEvents Class
Sitecore.DynamicSerialization Namespace


SuppressedException Method

[image]

Sitecore 6.4.1 API
SilentEvents..::..SuppressedException Method
SilentEvents Class See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SuppressedException(
    Exception exception,
    ISerializationContext context
)
Visual Basic
Public Sub SuppressedException ( _
    exception As Exception, _
    context As ISerializationContext _
)
Visual C++
public:
virtual void SuppressedException(
    Exception^ exception,
    ISerializationContext^ context
) sealed

Parameters

exception
Type: System..::..Exception
The exception.
context
Type: Sitecore.DynamicSerialization..::..ISerializationContext
The context.

Implements

ISerializationEvents..::..SuppressedException(Exception, ISerializationContext)

See Also

SilentEvents Class
Sitecore.DynamicSerialization Namespace


UnknownElement Method

[image]

Sitecore 6.4.1 API
SilentEvents..::..UnknownElement Method
SilentEvents Class See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void UnknownElement(
    string element,
    ISerializationContext context
)
Visual Basic
Public Sub UnknownElement ( _
    element As String, _
    context As ISerializationContext _
)
Visual C++
public:
virtual void UnknownElement(
    String^ element,
    ISerializationContext^ context
) sealed

Parameters

element
Type: System..::..String
The element.
context
Type: Sitecore.DynamicSerialization..::..ISerializationContext
The context.

Implements

ISerializationEvents..::..UnknownElement(String, ISerializationContext)

See Also

SilentEvents Class
Sitecore.DynamicSerialization Namespace


UnsupportedNodeType Method

[image]

Sitecore 6.4.1 API
SilentEvents..::..UnsupportedNodeType Method
SilentEvents Class See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void UnsupportedNodeType(
    XmlReader reader,
    ISerializationContext context
)
Visual Basic
Public Sub UnsupportedNodeType ( _
    reader As XmlReader, _
    context As ISerializationContext _
)
Visual C++
public:
virtual void UnsupportedNodeType(
    XmlReader^ reader,
    ISerializationContext^ context
) sealed

Parameters

reader
Type: System.Xml..::..XmlReader
The reader.
context
Type: Sitecore.DynamicSerialization..::..ISerializationContext
The context.

Implements

ISerializationEvents..::..UnsupportedNodeType(XmlReader, ISerializationContext)

See Also

SilentEvents Class
Sitecore.DynamicSerialization Namespace


SimpleObjectContext Class

[image]

Sitecore 6.4.1 API
SimpleObjectContext Class
Members See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SimpleObjectContext : ISerializationContext
Visual Basic
Public Class SimpleObjectContext _
    Implements ISerializationContext
Visual C++
public ref class SimpleObjectContext : ISerializationContext

Inheritance Hierarchy

System..::..Object
Sitecore.DynamicSerialization..::..SimpleObjectContext

See Also

SimpleObjectContext Members
Sitecore.DynamicSerialization Namespace


SimpleObjectContext Members

[image] [image]

Sitecore 6.4.1 API
SimpleObjectContext Members
SimpleObjectContext Class Constructors Methods Properties See Also Send Feedback

The SimpleObjectContext type exposes the following members.

Constructors

 | Name | Description
Public method | SimpleObjectContext | Initializes a new instance of the SimpleObjectContext class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Events | Gets or sets the events.
Public property | Factory | Gets or sets the factory.
Public property | Log | Gets or sets the logger.

See Also

SimpleObjectContext Class
Sitecore.DynamicSerialization Namespace


SimpleObjectContext Constructor

[image]

Sitecore 6.4.1 API
SimpleObjectContext Constructor
SimpleObjectContext Class See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SimpleObjectContext(
    IObjectFactory factory,
    ISerializationEvents events,
    ILogger logger
)
Visual Basic
Public Sub New ( _
    factory As IObjectFactory, _
    events As ISerializationEvents, _
    logger As ILogger _
)
Visual C++
public:
SimpleObjectContext(
    IObjectFactory^ factory,
    ISerializationEvents^ events,
    ILogger^ logger
)

Parameters

factory
Type: Sitecore.DynamicSerialization..::..IObjectFactory
The factory.
events
Type: Sitecore.DynamicSerialization..::..ISerializationEvents
The events.
logger
Type: Sitecore.DynamicSerialization..::..ILogger
The logger.

See Also

SimpleObjectContext Class
Sitecore.DynamicSerialization Namespace


SimpleObjectContext Methods

[image] [image]

Sitecore 6.4.1 API
SimpleObjectContext Methods
SimpleObjectContext Class See Also Send Feedback

The SimpleObjectContext type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SimpleObjectContext Class
Sitecore.DynamicSerialization Namespace


SimpleObjectContext Properties

[image] [image]

Sitecore 6.4.1 API
SimpleObjectContext Properties
SimpleObjectContext Class See Also Send Feedback

The SimpleObjectContext type exposes the following members.

Properties

 | Name | Description
Public property | Events | Gets or sets the events.
Public property | Factory | Gets or sets the factory.
Public property | Log | Gets or sets the logger.

See Also

SimpleObjectContext Class
Sitecore.DynamicSerialization Namespace


Events Property

[image]

Sitecore 6.4.1 API
SimpleObjectContext..::..Events Property
SimpleObjectContext Class See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ISerializationEvents Events { get; set; }
Visual Basic
Public Property Events As ISerializationEvents
    Get
    Set
Visual C++
public:
virtual property ISerializationEvents^ Events {
    ISerializationEvents^ get () sealed;
    void set (ISerializationEvents^ value) sealed;
}

Field Value

The events.

Implements

ISerializationContext..::..Events

See Also

SimpleObjectContext Class
Sitecore.DynamicSerialization Namespace


Factory Property

[image]

Sitecore 6.4.1 API
SimpleObjectContext..::..Factory Property
SimpleObjectContext Class See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IObjectFactory Factory { get; set; }
Visual Basic
Public Property Factory As IObjectFactory
    Get
    Set
Visual C++
public:
virtual property IObjectFactory^ Factory {
    IObjectFactory^ get () sealed;
    void set (IObjectFactory^ value) sealed;
}

Field Value

The factory.

Implements

ISerializationContext..::..Factory

See Also

SimpleObjectContext Class
Sitecore.DynamicSerialization Namespace


Log Property

[image]

Sitecore 6.4.1 API
SimpleObjectContext..::..Log Property
SimpleObjectContext Class See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ILogger Log { get; set; }
Visual Basic
Public Property Log As ILogger
    Get
    Set
Visual C++
public:
virtual property ILogger^ Log {
    ILogger^ get () sealed;
    void set (ILogger^ value) sealed;
}

Field Value

The logger.

Implements

ISerializationContext..::..Log

See Also

SimpleObjectContext Class
Sitecore.DynamicSerialization Namespace


SmartObjectFactory Class

[image]

Sitecore 6.4.1 API
SmartObjectFactory Class
Members See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SmartObjectFactory : IObjectFactory
Visual Basic
Public Class SmartObjectFactory _
    Implements IObjectFactory
Visual C++
public ref class SmartObjectFactory : IObjectFactory

Inheritance Hierarchy

System..::..Object
Sitecore.DynamicSerialization..::..SmartObjectFactory

See Also

SmartObjectFactory Members
Sitecore.DynamicSerialization Namespace


SmartObjectFactory Members

[image] [image]

Sitecore 6.4.1 API
SmartObjectFactory Members
SmartObjectFactory Class Constructors Methods See Also Send Feedback

The SmartObjectFactory type exposes the following members.

Constructors

 | Name | Description
Public method | SmartObjectFactory | Initializes a new instance of the SmartObjectFactory class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetElementName | Gets the name of the element by instance
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetType(String) | Gets the type by element.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Register | Registers the specified element.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SmartObjectFactory Class
Sitecore.DynamicSerialization Namespace


SmartObjectFactory Constructor

[image]

Sitecore 6.4.1 API
SmartObjectFactory Constructor
SmartObjectFactory Class See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SmartObjectFactory()
Visual Basic
Public Sub New
Visual C++
public:
SmartObjectFactory()

See Also

SmartObjectFactory Class
Sitecore.DynamicSerialization Namespace


SmartObjectFactory Methods

[image] [image]

Sitecore 6.4.1 API
SmartObjectFactory Methods
SmartObjectFactory Class See Also Send Feedback

The SmartObjectFactory type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetElementName | Gets the name of the element by instance
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetType(String) | Gets the type by element.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Register | Registers the specified element.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SmartObjectFactory Class
Sitecore.DynamicSerialization Namespace


GetElementName Method

[image]

Sitecore 6.4.1 API
SmartObjectFactory..::..GetElementName Method
SmartObjectFactory Class See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetElementName(
    Object object
)
Visual Basic
Public Function GetElementName ( _
    object As Object _
) As String
Visual C++
public:
virtual String^ GetElementName(
    Object^ object
) sealed

Parameters

object
Type: System..::..Object
Instance of type

Return Value

[Missing <returns> documentation for "M:Sitecore.DynamicSerialization.SmartObjectFactory.GetElementName(System.Object)"]

Implements

IObjectFactory..::..GetElementName(Object)

See Also

SmartObjectFactory Class
Sitecore.DynamicSerialization Namespace


GetType Method (String)

[image]

Sitecore 6.4.1 API
SmartObjectFactory..::..GetType Method (String)
SmartObjectFactory Class See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Type GetType(
    string element
)
Visual Basic
Public Function GetType ( _
    element As String _
) As Type
Visual C++
public:
virtual Type^ GetType(
    String^ element
) sealed

Parameters

element
Type: System..::..String
The element name

Return Value

The type

Implements

IObjectFactory..::..GetType(String)

See Also

SmartObjectFactory Class
GetType Overload
Sitecore.DynamicSerialization Namespace


Register Method

[image]

Sitecore 6.4.1 API
SmartObjectFactory..::..Register Method
SmartObjectFactory Class See Also Send Feedback

Namespace: Sitecore.DynamicSerialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Register(
    string element,
    Type type
)
Visual Basic
Public Sub Register ( _
    element As String, _
    type As Type _
)
Visual C++
public:
virtual void Register(
    String^ element,
    Type^ type
) sealed

Parameters

element
Type: System..::..String
The element.
type
Type: System..::..Type
The type.

Implements

IObjectFactory..::..Register(String, Type)

See Also

SmartObjectFactory Class
Sitecore.DynamicSerialization Namespace


EventContext Class

[image]

Sitecore 6.4.1 API
EventContext Class
Members See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class EventContext
Visual Basic
Public Class EventContext
Visual C++
public ref class EventContext

Inheritance Hierarchy

System..::..Object
Sitecore.Eventing..::..EventContext

See Also

EventContext Members
Sitecore.Eventing Namespace


EventContext Members

[image] [image]

Sitecore 6.4.1 API
EventContext Members
EventContext Class Constructors Methods Properties See Also Send Feedback

The EventContext type exposes the following members.

Constructors

 | Name | Description
Public method | EventContext | Initializes a new instance of the EventContext class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsLocal | Gets or sets a value indicating whether this EventContext is local.
Public property | IsRemote | Gets or sets a value indicating whether this EventContext is remote.
 | Local | Gets the local event context.
Public property | Queue | Gets or sets the queue in which event has been present. This is null for locally raised events.

See Also

EventContext Class
Sitecore.Eventing Namespace


EventContext Constructor

[image]

Sitecore 6.4.1 API
EventContext Constructor
EventContext Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public EventContext(
    EventQueue queue
)
Visual Basic
Public Sub New ( _
    queue As EventQueue _
)
Visual C++
public:
EventContext(
    EventQueue^ queue
)

Parameters

queue
Type: Sitecore.Eventing..::..EventQueue
The queue.

See Also

EventContext Class
Sitecore.Eventing Namespace


EventContext Methods

[image] [image]

Sitecore 6.4.1 API
EventContext Methods
EventContext Class See Also Send Feedback

The EventContext type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EventContext Class
Sitecore.Eventing Namespace


EventContext Properties

[image] [image]

Sitecore 6.4.1 API
EventContext Properties
EventContext Class See Also Send Feedback

The EventContext type exposes the following members.

Properties

 | Name | Description
Public property | IsLocal | Gets or sets a value indicating whether this EventContext is local.
Public property | IsRemote | Gets or sets a value indicating whether this EventContext is remote.
 | Local | Gets the local event context.
Public property | Queue | Gets or sets the queue in which event has been present. This is null for locally raised events.

See Also

EventContext Class
Sitecore.Eventing Namespace


IsLocal Property

[image]

Sitecore 6.4.1 API
EventContext..::..IsLocal Property
EventContext Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsLocal { get; }
Visual Basic
Public ReadOnly Property IsLocal As Boolean
    Get
Visual C++
public:
property bool IsLocal {
    bool get ();
}

Field Value

true if local; otherwise, false.

See Also

EventContext Class
Sitecore.Eventing Namespace


IsRemote Property

[image]

Sitecore 6.4.1 API
EventContext..::..IsRemote Property
EventContext Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsRemote { get; private set; }
Visual Basic
Public Property IsRemote As Boolean
    Get
    Private Set
Visual C++
public:
property bool IsRemote {
    bool get ();
    private: void set (bool value);
}

Field Value

true if remote; otherwise, false.

See Also

EventContext Class
Sitecore.Eventing Namespace


Local Property

[image]

Sitecore 6.4.1 API
EventContext..::..Local Property
EventContext Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static EventContext Local { get; }
Visual Basic
Public Shared ReadOnly Property Local As EventContext
    Get
Visual C++
public:
static property EventContext^ Local {
    EventContext^ get ();
}

Field Value

The local.

See Also

EventContext Class
Sitecore.Eventing Namespace


Queue Property

[image]

Sitecore 6.4.1 API
EventContext..::..Queue Property
EventContext Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public EventQueue Queue { get; private set; }
Visual Basic
Public Property Queue As EventQueue
    Get
    Private Set
Visual C++
public:
property EventQueue^ Queue {
    EventQueue^ get ();
    private: void set (EventQueue^ value);
}

Field Value

The source queue.

See Also

EventContext Class
Sitecore.Eventing Namespace


EventManager Class

[image]

Sitecore 6.4.1 API
EventManager Class
Members See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class EventManager
Visual Basic
Public Class EventManager
Visual C++
public ref class EventManager

Inheritance Hierarchy

System..::..Object
Sitecore.Eventing..::..EventManager

See Also

EventManager Members
Sitecore.Eventing Namespace


EventManager Members

[image] [image]

Sitecore 6.4.1 API
EventManager Members
EventManager Class Constructors Methods Properties See Also Send Feedback

The EventManager type exposes the following members.

Constructors

 | Name | Description
Public method | EventManager | Initializes a new instance of the EventManager class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | QueueEvent<(Of <<'(TEvent>)>>)(TEvent) | Queues the event.
 | QueueEvent<(Of <<'(TEvent>)>>)(TEvent, Boolean, Boolean) | Queues the event.
 | RaiseEvent<(Of <<'(TEvent>)>>) | Raises the specified event.
 | RaiseQueuedEvents | Raises the queued events.
 | RemoveQueuedEvents | Removes the queued events matching the criteria specified by the query.
 | Subscribe<(Of <<'(TEvent>)>>)(Action<(Of <<'(TEvent>)>>)) | Subscribes the specified event handler.
 | Subscribe<(Of <<'(TEvent>)>>)(Action<(Of <<'(TEvent, EventContext>)>>)) | Subscribes the specified handler.
 | Subscribe<(Of <<'(TEvent>)>>)(Action<(Of <<'(TEvent>)>>), Predicate<(Of <<'(TEvent>)>>)) | Subscribes the specified event handler.
 | Subscribe<(Of <<'(TEvent>)>>)(Action<(Of <<'(TEvent, EventContext>)>>), Func<(Of <<'(TEvent, EventContext, Boolean>)>>)) | Subscribes the specified handler.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | Unsubscribe | Unsubscribes the specified subscription id.

Properties

Name | Description
CurrentProvider | Gets or sets the current provider.
CurrentProviders | Gets or sets the current providers.
Enabled | Gets a value indicating whether event queuing is enabled.
Provider | Gets the provider.
Providers | Gets the providers.

See Also

EventManager Class
Sitecore.Eventing Namespace


EventManager Constructor

[image]

Sitecore 6.4.1 API
EventManager Constructor
EventManager Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public EventManager()
Visual Basic
Public Sub New
Visual C++
public:
EventManager()

See Also

EventManager Class
Sitecore.Eventing Namespace


EventManager Methods

[image] [image]

Sitecore 6.4.1 API
EventManager Methods
EventManager Class See Also Send Feedback

The EventManager type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | QueueEvent<(Of <<'(TEvent>)>>)(TEvent) | Queues the event.
 | QueueEvent<(Of <<'(TEvent>)>>)(TEvent, Boolean, Boolean) | Queues the event.
 | RaiseEvent<(Of <<'(TEvent>)>>) | Raises the specified event.
 | RaiseQueuedEvents | Raises the queued events.
 | RemoveQueuedEvents | Removes the queued events matching the criteria specified by the query.
 | Subscribe<(Of <<'(TEvent>)>>)(Action<(Of <<'(TEvent>)>>)) | Subscribes the specified event handler.
 | Subscribe<(Of <<'(TEvent>)>>)(Action<(Of <<'(TEvent, EventContext>)>>)) | Subscribes the specified handler.
 | Subscribe<(Of <<'(TEvent>)>>)(Action<(Of <<'(TEvent>)>>), Predicate<(Of <<'(TEvent>)>>)) | Subscribes the specified event handler.
 | Subscribe<(Of <<'(TEvent>)>>)(Action<(Of <<'(TEvent, EventContext>)>>), Func<(Of <<'(TEvent, EventContext, Boolean>)>>)) | Subscribes the specified handler.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | Unsubscribe | Unsubscribes the specified subscription id.

See Also

EventManager Class
Sitecore.Eventing Namespace


QueueEvent Method

[image] [image]

Sitecore 6.4.1 API
EventManager..::..QueueEvent Method
EventManager Class See Also Send Feedback

Overload List

Name | Description
QueueEvent<(Of <<'(TEvent>)>>)(TEvent) | Queues the event.
QueueEvent<(Of <<'(TEvent>)>>)(TEvent, Boolean, Boolean) | Queues the event.

See Also

EventManager Class
EventManager Members
Sitecore.Eventing Namespace


QueueEvent(TEvent) Method (TEvent)

[image]

Sitecore 6.4.1 API
EventManager..::..QueueEvent<(Of <(<'TEvent>)>)> Method (TEvent)
EventManager Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void QueueEvent<TEvent>(
    TEvent event
)
Visual Basic
Public Shared Sub QueueEvent(Of TEvent) ( _
    event As TEvent _
)
Visual C++
public:
generic<typename TEvent>
static void QueueEvent(
    TEvent event
)

Parameters

event
Type: TEvent
The @event.

Type Parameters

TEvent
The type of the event.

See Also

EventManager Class
QueueEvent Overload
Sitecore.Eventing Namespace


QueueEvent(TEvent) Method (TEvent, Boolean, Boolean)

[image]

Sitecore 6.4.1 API
EventManager..::..QueueEvent<(Of <(<'TEvent>)>)> Method (TEvent, Boolean, Boolean)
EventManager Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void QueueEvent<TEvent>(
    TEvent event,
    bool addToGlobalQueue,
    bool addToLocalQueue
)
Visual Basic
Public Shared Sub QueueEvent(Of TEvent) ( _
    event As TEvent, _
    addToGlobalQueue As Boolean, _
    addToLocalQueue As Boolean _
)
Visual C++
public:
generic<typename TEvent>
static void QueueEvent(
    TEvent event,
    bool addToGlobalQueue,
    bool addToLocalQueue
)

Parameters

event
Type: TEvent
The @event.
addToGlobalQueue
Type: System..::..Boolean
if set to true add the event to the global queue.
addToLocalQueue
Type: System..::..Boolean
if set to true add the event to the local queue.

Type Parameters

TEvent
The type of the event.

See Also

EventManager Class
QueueEvent Overload
Sitecore.Eventing Namespace


RaiseEvent(TEvent) Method

[image]

Sitecore 6.4.1 API
EventManager..::..RaiseEvent<(Of <(<'TEvent>)>)> Method
EventManager Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void RaiseEvent<TEvent>(
    TEvent event
)
Visual Basic
Public Shared Sub RaiseEvent(Of TEvent) ( _
    event As TEvent _
)
Visual C++
public:
generic<typename TEvent>
static void RaiseEvent(
    TEvent event
)

Parameters

event
Type: TEvent
The @event.

Type Parameters

TEvent
The type of the event.

See Also

EventManager Class
Sitecore.Eventing Namespace


RemoveQueuedEvents Method

[image]

Sitecore 6.4.1 API
EventManager..::..RemoveQueuedEvents Method
EventManager Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void RemoveQueuedEvents(
    EventQueueQuery query
)
Visual Basic
Public Shared Sub RemoveQueuedEvents ( _
    query As EventQueueQuery _
)
Visual C++
public:
static void RemoveQueuedEvents(
    EventQueueQuery^ query
)

Parameters

query
Type: Sitecore.Eventing..::..EventQueueQuery
The query.

See Also

EventManager Class
Sitecore.Eventing Namespace


Subscribe Method

[image] [image]

Sitecore 6.4.1 API
EventManager..::..Subscribe Method
EventManager Class See Also Send Feedback

Overload List

Name | Description
Subscribe<(Of <<'(TEvent>)>>)(Action<(Of <<'(TEvent>)>>)) | Subscribes the specified event handler.
Subscribe<(Of <<'(TEvent>)>>)(Action<(Of <<'(TEvent, EventContext>)>>)) | Subscribes the specified handler.
Subscribe<(Of <<'(TEvent>)>>)(Action<(Of <<'(TEvent>)>>), Predicate<(Of <<'(TEvent>)>>)) | Subscribes the specified event handler.
Subscribe<(Of <<'(TEvent>)>>)(Action<(Of <<'(TEvent, EventContext>)>>), Func<(Of <<'(TEvent, EventContext, Boolean>)>>)) | Subscribes the specified handler.

See Also

EventManager Class
EventManager Members
Sitecore.Eventing Namespace


Subscribe(TEvent) Method (Action(TEvent))

[image]

Sitecore 6.4.1 API
EventManager..::..Subscribe<(Of <(<'TEvent>)>)> Method (Action<(Of <(<'TEvent>)>)>)
EventManager Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static SubscriptionId Subscribe<TEvent>(
    Action<TEvent> eventHandler
)
Visual Basic
Public Shared Function Subscribe(Of TEvent) ( _
    eventHandler As Action(Of TEvent) _
) As SubscriptionId
Visual C++
public:
generic<typename TEvent>
static SubscriptionId^ Subscribe(
    Action<TEvent>^ eventHandler
)

Parameters

eventHandler
Type: System..::..Action <(Of <(<'TEvent>)>)>
The event handler.

Type Parameters

TEvent
The type of the event.

Return Value

The subscription id.

See Also

EventManager Class
Subscribe Overload
Sitecore.Eventing Namespace


Subscribe(TEvent) Method (Action(TEvent, EventContext))

[image]

Sitecore 6.4.1 API
EventManager..::..Subscribe<(Of <(<'TEvent>)>)> Method (Action<(Of <(<'TEvent, EventContext>)>)>)
EventManager Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static SubscriptionId Subscribe<TEvent>(
    Action<TEvent, EventContext> eventHandler
)
Visual Basic
Public Shared Function Subscribe(Of TEvent) ( _
    eventHandler As Action(Of TEvent, EventContext) _
) As SubscriptionId
Visual C++
public:
generic<typename TEvent>
static SubscriptionId^ Subscribe(
    Action<TEvent, EventContext^>^ eventHandler
)

Parameters

eventHandler
Type: System..::..Action <(Of <(<'TEvent, EventContext >)>)>
The event handler.

Type Parameters

TEvent
The type of the event.

Return Value

The result.

See Also

EventManager Class
Subscribe Overload
Sitecore.Eventing Namespace


Subscribe(TEvent) Method (Action(TEvent, EventContext), Func(TEvent, EventContext, Boolean))

[image]

Sitecore 6.4.1 API
EventManager..::..Subscribe<(Of <(<'TEvent>)>)> Method (Action<(Of <(<'TEvent, EventContext>)>)>, Func<(Of <(<'TEvent, EventContext, Boolean>)>)>)
EventManager Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static SubscriptionId Subscribe<TEvent>(
    Action<TEvent, EventContext> eventHandler,
    Func<TEvent, EventContext, bool> filter
)
Visual Basic
Public Shared Function Subscribe(Of TEvent) ( _
    eventHandler As Action(Of TEvent, EventContext), _
    filter As Func(Of TEvent, EventContext, Boolean) _
) As SubscriptionId
Visual C++
public:
generic<typename TEvent>
static SubscriptionId^ Subscribe(
    Action<TEvent, EventContext^>^ eventHandler,
    Func<TEvent, EventContext^, bool>^ filter
)

Parameters

eventHandler
Type: System..::..Action <(Of <(<'TEvent, EventContext >)>)>
The event handler.
filter
Type: System..::..Func <(Of <(<'TEvent, EventContext, Boolean >)>)>
The filter.

Type Parameters

TEvent
The type of the event.

Return Value

The result.

See Also

EventManager Class
Subscribe Overload
Sitecore.Eventing Namespace


Unsubscribe Method

[image]

Sitecore 6.4.1 API
EventManager..::..Unsubscribe Method
EventManager Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Unsubscribe(
    SubscriptionId subscriptionId
)
Visual Basic
Public Shared Sub Unsubscribe ( _
    subscriptionId As SubscriptionId _
)
Visual C++
public:
static void Unsubscribe(
    SubscriptionId^ subscriptionId
)

Parameters

subscriptionId
Type: Sitecore.Eventing..::..SubscriptionId
The subscription id.

See Also

EventManager Class
Sitecore.Eventing Namespace


EventManager Properties

[image] [image]

Sitecore 6.4.1 API
EventManager Properties
EventManager Class See Also Send Feedback

The EventManager type exposes the following members.

Properties

Name | Description
CurrentProvider | Gets or sets the current provider.
CurrentProviders | Gets or sets the current providers.
Enabled | Gets a value indicating whether event queuing is enabled.
Provider | Gets the provider.
Providers | Gets the providers.

See Also

EventManager Class
Sitecore.Eventing Namespace


CurrentProvider Property

[image]

Sitecore 6.4.1 API
EventManager..::..CurrentProvider Property
EventManager Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected internal static EventProvider CurrentProvider { get; set; }
Visual Basic
Protected Friend Shared Property CurrentProvider As EventProvider
    Get
    Set
Visual C++
protected public:
static property EventProvider^ CurrentProvider {
    EventProvider^ get ();
    void set (EventProvider^ value);
}

Field Value

The current provider.

See Also

EventManager Class
Sitecore.Eventing Namespace


CurrentProviders Property

[image]

Sitecore 6.4.1 API
EventManager..::..CurrentProviders Property
EventManager Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected internal static ProviderCollectionBase<EventProvider> CurrentProviders { get; set; }
Visual Basic
Protected Friend Shared Property CurrentProviders As ProviderCollectionBase(Of EventProvider)
    Get
    Set
Visual C++
protected public:
static property ProviderCollectionBase<EventProvider^>^ CurrentProviders {
    ProviderCollectionBase<EventProvider^>^ get ();
    void set (ProviderCollectionBase<EventProvider^>^ value);
}

Field Value

The current providers.

See Also

EventManager Class
Sitecore.Eventing Namespace


Enabled Property

[image]

Sitecore 6.4.1 API
EventManager..::..Enabled Property
EventManager Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool Enabled { get; }
Visual Basic
Public Shared ReadOnly Property Enabled As Boolean
    Get
Visual C++
public:
static property bool Enabled {
    bool get ();
}

Field Value

true if enabled; otherwise, false.

See Also

EventManager Class
Sitecore.Eventing Namespace


Provider Property

[image]

Sitecore 6.4.1 API
EventManager..::..Provider Property
EventManager Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static EventProvider Provider { get; }
Visual Basic
Public Shared ReadOnly Property Provider As EventProvider
    Get
Visual C++
public:
static property EventProvider^ Provider {
    EventProvider^ get ();
}

Field Value

The provider.

See Also

EventManager Class
Sitecore.Eventing Namespace


Providers Property

[image]

Sitecore 6.4.1 API
EventManager..::..Providers Property
EventManager Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ProviderCollectionBase<EventProvider> Providers { get; }
Visual Basic
Public Shared ReadOnly Property Providers As ProviderCollectionBase(Of EventProvider)
    Get
Visual C++
public:
static property ProviderCollectionBase<EventProvider^>^ Providers {
    ProviderCollectionBase<EventProvider^>^ get ();
}

Field Value

The providers.

See Also

EventManager Class
Sitecore.Eventing Namespace


EventManager.Configuration Class

[image]

Sitecore 6.4.1 API
EventManager..::..Configuration Class
EventManager Class Members See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Configuration
Visual Basic
Public Class Configuration
Visual C++
public ref class Configuration

Inheritance Hierarchy

System..::..Object
Sitecore.Eventing..::..EventManager..::..Configuration

See Also

EventManager..::..Configuration Members
Sitecore.Eventing Namespace


EventManager.Configuration Members

[image] [image]

Sitecore 6.4.1 API
EventManager..::..Configuration Members
EventManager..::..Configuration Class Constructors Methods See Also Send Feedback

Manager class for eventing operations.

The EventManager..::..Configuration type exposes the following members.

Constructors

 | Name | Description
Public method | EventManager..::..Configuration | Initializes a new instance of the EventManager..::..Configuration class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Reset | Resets all internal data.
 | SetProvider(EventProvider) | Sets the (default) provider.
 | SetProvider(EventProvider, String, NameValueCollection) | Sets the (default) provider.
 | SetProviders | Sets the list of provider.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EventManager..::..Configuration Class
Sitecore.Eventing Namespace


EventManager.Configuration Constructor

[image]

Sitecore 6.4.1 API
EventManager..::..Configuration Constructor
EventManager..::..Configuration Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Configuration()
Visual Basic
Public Sub New
Visual C++
public:
Configuration()

See Also

EventManager..::..Configuration Class
Sitecore.Eventing Namespace


EventManager.Configuration Methods

[image] [image]

Sitecore 6.4.1 API
EventManager..::..Configuration Methods
EventManager..::..Configuration Class See Also Send Feedback

The EventManager..::..Configuration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Reset | Resets all internal data.
 | SetProvider(EventProvider) | Sets the (default) provider.
 | SetProvider(EventProvider, String, NameValueCollection) | Sets the (default) provider.
 | SetProviders | Sets the list of provider.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EventManager..::..Configuration Class
Sitecore.Eventing Namespace


Reset Method

[image]

Sitecore 6.4.1 API
EventManager..::..Configuration..::..Reset Method
EventManager..::..Configuration Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Reset()
Visual Basic
Public Shared Sub Reset
Visual C++
public:
static void Reset()

See Also

EventManager..::..Configuration Class
Sitecore.Eventing Namespace


SetProvider Method

[image] [image]

Sitecore 6.4.1 API
EventManager..::..Configuration..::..SetProvider Method
EventManager..::..Configuration Class See Also Send Feedback

Overload List

Name | Description
SetProvider(EventProvider) | Sets the (default) provider.
SetProvider(EventProvider, String, NameValueCollection) | Sets the (default) provider.

See Also

EventManager..::..Configuration Class
EventManager..::..Configuration Members
Sitecore.Eventing Namespace


SetProvider Method (EventProvider)

[image]

Sitecore 6.4.1 API
EventManager..::..Configuration..::..SetProvider Method (EventProvider)
EventManager..::..Configuration Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void SetProvider(
    EventProvider provider
)
Visual Basic
Public Shared Sub SetProvider ( _
    provider As EventProvider _
)
Visual C++
public:
static void SetProvider(
    EventProvider^ provider
)

Parameters

provider
Type: Sitecore.Eventing..::..EventProvider
The provider.

See Also

EventManager..::..Configuration Class
SetProvider Overload
Sitecore.Eventing Namespace


SetProvider Method (EventProvider, String, NameValueCollection)

[image]

Sitecore 6.4.1 API
EventManager..::..Configuration..::..SetProvider Method (EventProvider, String, NameValueCollection)
EventManager..::..Configuration Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void SetProvider(
    EventProvider provider,
    string name,
    NameValueCollection configuration
)
Visual Basic
Public Shared Sub SetProvider ( _
    provider As EventProvider, _
    name As String, _
    configuration As NameValueCollection _
)
Visual C++
public:
static void SetProvider(
    EventProvider^ provider,
    String^ name,
    NameValueCollection^ configuration
)

Parameters

provider
Type: Sitecore.Eventing..::..EventProvider
The provider.
name
Type: System..::..String
The name of the provider.
configuration
Type: System.Collections.Specialized..::..NameValueCollection
The initial configuration.

See Also

EventManager..::..Configuration Class
SetProvider Overload
Sitecore.Eventing Namespace


SetProviders Method

[image]

Sitecore 6.4.1 API
EventManager..::..Configuration..::..SetProviders Method
EventManager..::..Configuration Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void SetProviders(
    ProviderCollectionBase<EventProvider> providers
)
Visual Basic
Public Shared Sub SetProviders ( _
    providers As ProviderCollectionBase(Of EventProvider) _
)
Visual C++
public:
static void SetProviders(
    ProviderCollectionBase<EventProvider^>^ providers
)

Parameters

providers
Type: Sitecore.Configuration.Providers..::..ProviderCollectionBase <(Of <(<' EventProvider >)>)>
The providers.

See Also

EventManager..::..Configuration Class
Sitecore.Eventing Namespace


EventProvider Class

[image]

Sitecore 6.4.1 API
EventProvider Class
Members See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class EventProvider : ProviderBase
Visual Basic
Public Class EventProvider _
    Inherits ProviderBase
Visual C++
public ref class EventProvider : public ProviderBase

Inheritance Hierarchy

System..::..Object
System.Configuration.Provider..::..ProviderBase
Sitecore.Eventing..::..EventProvider

See Also

EventProvider Members
Sitecore.Eventing Namespace


EventProvider Members

[image] [image]

Sitecore 6.4.1 API
EventProvider Members
EventProvider Class Constructors Methods Properties See Also Send Feedback

The EventProvider type exposes the following members.

Constructors

 | Name | Description
Public method | EventProvider | Initializes a new instance of the EventProvider class.

Methods

 | Name | Description
Protected method | AddSubscription | Adds the subscription.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSubscriptions | Gets the subscriptions.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value.
Public method | Initialize | Initializes the provider. (Overrides ProviderBase..::..Initialize(String, NameValueCollection).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | QueueEvent<(Of <<'(TEvent>)>>)(TEvent) | Queues the event.
Public method | QueueEvent<(Of <<'(TEvent>)>>)(TEvent, Boolean, Boolean) | Queues the event.
Protected method | RaiseEvent(Object, Type, EventContext) | Raises the specified event.
Public method | RaiseEvent<(Of <<'(TEvent>)>>)(TEvent) | Raises the specified event.
Public method | RaiseQueuedEvents | Gets the event queue.
Public method | RemoveQueuedEvents | Removes the queued events matching the criteria specified by the query.
Protected method | RemoveSubscription | Removes the subscription.
Public method | Subscribe<(Of <<'(TEvent>)>>) | Subscribes the specified event handler.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unsubscribe | Unsubscribes the specified subscription id.

Properties

 | Name | Description
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | EventMonitor | Gets the event monitor.
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

EventProvider Class
Sitecore.Eventing Namespace


EventProvider Constructor

[image]

Sitecore 6.4.1 API
EventProvider Constructor
EventProvider Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public EventProvider()
Visual Basic
Public Sub New
Visual C++
public:
EventProvider()

See Also

EventProvider Class
Sitecore.Eventing Namespace


EventProvider Methods

[image] [image]

Sitecore 6.4.1 API
EventProvider Methods
EventProvider Class See Also Send Feedback

The EventProvider type exposes the following members.

Methods

 | Name | Description
Protected method | AddSubscription | Adds the subscription.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSubscriptions | Gets the subscriptions.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value.
Public method | Initialize | Initializes the provider. (Overrides ProviderBase..::..Initialize(String, NameValueCollection).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | QueueEvent<(Of <<'(TEvent>)>>)(TEvent) | Queues the event.
Public method | QueueEvent<(Of <<'(TEvent>)>>)(TEvent, Boolean, Boolean) | Queues the event.
Protected method | RaiseEvent(Object, Type, EventContext) | Raises the specified event.
Public method | RaiseEvent<(Of <<'(TEvent>)>>)(TEvent) | Raises the specified event.
Public method | RaiseQueuedEvents | Gets the event queue.
Public method | RemoveQueuedEvents | Removes the queued events matching the criteria specified by the query.
Protected method | RemoveSubscription | Removes the subscription.
Public method | Subscribe<(Of <<'(TEvent>)>>) | Subscribes the specified event handler.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unsubscribe | Unsubscribes the specified subscription id.

See Also

EventProvider Class
Sitecore.Eventing Namespace


GetSubscriptions Method

[image]

Sitecore 6.4.1 API
EventProvider..::..GetSubscriptions Method
EventProvider Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual List<SubscriptionBase> GetSubscriptions(
    Type eventType
)
Visual Basic
Protected Overridable Function GetSubscriptions ( _
    eventType As Type _
) As List(Of SubscriptionBase)
Visual C++
protected:
virtual List<SubscriptionBase^>^ GetSubscriptions(
    Type^ eventType
)

Parameters

eventType
Type: System..::..Type
Type of the event.

Return Value

The subscriptions.

See Also

EventProvider Class
Sitecore.Eventing Namespace


GetValue Method

[image]

Sitecore 6.4.1 API
EventProvider..::..GetValue Method
EventProvider Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected string GetValue(
    string parameterName,
    NameValueCollection config
)
Visual Basic
Protected Function GetValue ( _
    parameterName As String, _
    config As NameValueCollection _
) As String
Visual C++
protected:
String^ GetValue(
    String^ parameterName,
    NameValueCollection^ config
)

Parameters

parameterName
Type: System..::..String
Name of the parameter.
config
Type: System.Collections.Specialized..::..NameValueCollection
The config.

Return Value

The get value.

See Also

EventProvider Class
Sitecore.Eventing Namespace


QueueEvent Method

[image] [image]

Sitecore 6.4.1 API
EventProvider..::..QueueEvent Method
EventProvider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | QueueEvent<(Of <<'(TEvent>)>>)(TEvent) | Queues the event.
Public method | QueueEvent<(Of <<'(TEvent>)>>)(TEvent, Boolean, Boolean) | Queues the event.

See Also

EventProvider Class
EventProvider Members
Sitecore.Eventing Namespace


QueueEvent(TEvent) Method (TEvent)

[image]

Sitecore 6.4.1 API
EventProvider..::..QueueEvent<(Of <(<'TEvent>)>)> Method (TEvent)
EventProvider Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void QueueEvent<TEvent>(
    TEvent event
)
Visual Basic
Public Sub QueueEvent(Of TEvent) ( _
    event As TEvent _
)
Visual C++
public:
generic<typename TEvent>
void QueueEvent(
    TEvent event
)

Parameters

event
Type: TEvent
The @event.

Type Parameters

TEvent
The type of the event.

See Also

EventProvider Class
QueueEvent Overload
Sitecore.Eventing Namespace


QueueEvent(TEvent) Method (TEvent, Boolean, Boolean)

[image]

Sitecore 6.4.1 API
EventProvider..::..QueueEvent<(Of <(<'TEvent>)>)> Method (TEvent, Boolean, Boolean)
EventProvider Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void QueueEvent<TEvent>(
    TEvent event,
    bool addToGlobalQueue,
    bool addToLocalQueue
)
Visual Basic
Public Sub QueueEvent(Of TEvent) ( _
    event As TEvent, _
    addToGlobalQueue As Boolean, _
    addToLocalQueue As Boolean _
)
Visual C++
public:
generic<typename TEvent>
void QueueEvent(
    TEvent event,
    bool addToGlobalQueue,
    bool addToLocalQueue
)

Parameters

event
Type: TEvent
The @event.
addToGlobalQueue
Type: System..::..Boolean
if set to true add the event to the global queue.
addToLocalQueue
Type: System..::..Boolean
if set to true add the event to the local queue.

Type Parameters

TEvent
The type of the event.

See Also

EventProvider Class
QueueEvent Overload
Sitecore.Eventing Namespace


RaiseEvent(TEvent) Method (TEvent)

[image]

Sitecore 6.4.1 API
EventProvider..::..RaiseEvent<(Of <(<'TEvent>)>)> Method (TEvent)
EventProvider Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RaiseEvent<TEvent>(
    TEvent event
)
Visual Basic
Public Sub RaiseEvent(Of TEvent) ( _
    event As TEvent _
)
Visual C++
public:
generic<typename TEvent>
void RaiseEvent(
    TEvent event
)

Parameters

event
Type: TEvent
The @event.

Type Parameters

TEvent
The type of the event.

See Also

EventProvider Class
RaiseEvent Overload
Sitecore.Eventing Namespace


RaiseEvent Method (Object, Type, EventContext)

[image]

Sitecore 6.4.1 API
EventProvider..::..RaiseEvent Method (Object, Type, EventContext)
EventProvider Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void RaiseEvent(
    Object event,
    Type eventType,
    EventContext context
)
Visual Basic
Protected Overridable Sub RaiseEvent ( _
    event As Object, _
    eventType As Type, _
    context As EventContext _
)
Visual C++
protected:
virtual void RaiseEvent(
    Object^ event,
    Type^ eventType,
    EventContext^ context
)

Parameters

event
Type: System..::..Object
The instance.
eventType
Type: System..::..Type
Type of the event.
context
Type: Sitecore.Eventing..::..EventContext
The context.

See Also

EventProvider Class
RaiseEvent Overload
Sitecore.Eventing Namespace


RaiseQueuedEvents Method

[image]

Sitecore 6.4.1 API
EventProvider..::..RaiseQueuedEvents Method
EventProvider Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void RaiseQueuedEvents()
Visual Basic
Public Overridable Sub RaiseQueuedEvents
Visual C++
public:
virtual void RaiseQueuedEvents()

See Also

EventProvider Class
Sitecore.Eventing Namespace


RemoveQueuedEvents Method

[image]

Sitecore 6.4.1 API
EventProvider..::..RemoveQueuedEvents Method
EventProvider Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RemoveQueuedEvents(
    EventQueueQuery query
)
Visual Basic
Public Sub RemoveQueuedEvents ( _
    query As EventQueueQuery _
)
Visual C++
public:
void RemoveQueuedEvents(
    EventQueueQuery^ query
)

Parameters

query
Type: Sitecore.Eventing..::..EventQueueQuery
The query.

See Also

EventProvider Class
Sitecore.Eventing Namespace


RemoveSubscription Method

[image]

Sitecore 6.4.1 API
EventProvider..::..RemoveSubscription Method
EventProvider Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void RemoveSubscription(
    SubscriptionId id
)
Visual Basic
Protected Overridable Sub RemoveSubscription ( _
    id As SubscriptionId _
)
Visual C++
protected:
virtual void RemoveSubscription(
    SubscriptionId^ id
)

Parameters

id
Type: Sitecore.Eventing..::..SubscriptionId
The id.

See Also

EventProvider Class
Sitecore.Eventing Namespace


Subscribe(TEvent) Method

[image]

Sitecore 6.4.1 API
EventProvider..::..Subscribe<(Of <(<'TEvent>)>)> Method
EventProvider Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SubscriptionId Subscribe<TEvent>(
    Action<TEvent, EventContext> eventHandler,
    Func<TEvent, EventContext, bool> filter
)
Visual Basic
Public Function Subscribe(Of TEvent) ( _
    eventHandler As Action(Of TEvent, EventContext), _
    filter As Func(Of TEvent, EventContext, Boolean) _
) As SubscriptionId
Visual C++
public:
generic<typename TEvent>
SubscriptionId^ Subscribe(
    Action<TEvent, EventContext^>^ eventHandler,
    Func<TEvent, EventContext^, bool>^ filter
)

Parameters

eventHandler
Type: System..::..Action <(Of <(<'TEvent, EventContext >)>)>
The event handler.
filter
Type: System..::..Func <(Of <(<'TEvent, EventContext, Boolean >)>)>
The filter.

Type Parameters

TEvent
The type of the event.

Return Value

The result.

See Also

EventProvider Class
Sitecore.Eventing Namespace


Unsubscribe Method

[image]

Sitecore 6.4.1 API
EventProvider..::..Unsubscribe Method
EventProvider Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Unsubscribe(
    SubscriptionId subscriptionId
)
Visual Basic
Public Sub Unsubscribe ( _
    subscriptionId As SubscriptionId _
)
Visual C++
public:
void Unsubscribe(
    SubscriptionId^ subscriptionId
)

Parameters

subscriptionId
Type: Sitecore.Eventing..::..SubscriptionId
The subscription id.

See Also

EventProvider Class
Sitecore.Eventing Namespace


EventProvider Properties

[image] [image]

Sitecore 6.4.1 API
EventProvider Properties
EventProvider Class See Also Send Feedback

The EventProvider type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | EventMonitor | Gets the event monitor.
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

EventProvider Class
Sitecore.Eventing Namespace


EventMonitor Property

[image]

Sitecore 6.4.1 API
EventProvider..::..EventMonitor Property
EventProvider Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public EventQueueMonitor EventMonitor { get; }
Visual Basic
Public ReadOnly Property EventMonitor As EventQueueMonitor
    Get
Visual C++
public:
property EventQueueMonitor^ EventMonitor {
    EventQueueMonitor^ get ();
}

Field Value

The event monitor.

See Also

EventProvider Class
Sitecore.Eventing Namespace


EventQueue Class

[image]

Sitecore 6.4.1 API
EventQueue Class
Members See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class EventQueue
Visual Basic
Public MustInherit Class EventQueue
Visual C++
public ref class EventQueue abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Eventing..::..EventQueue
Sitecore.Data.Eventing..::..SqlEventQueue
Sitecore.Eventing..::..NullEventQueue

See Also

EventQueue Members
Sitecore.Eventing Namespace


EventQueue Constructor

[image]

Sitecore 6.4.1 API
EventQueue Constructor
EventQueue Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected EventQueue(
    Serializer serializer
)
Visual Basic
Protected Sub New ( _
    serializer As Serializer _
)
Visual C++
protected:
EventQueue(
    Serializer^ serializer
)

Parameters

serializer
Type: Sitecore.Common..::..Serializer
The serializer.

See Also

EventQueue Class
Sitecore.Eventing Namespace


EventQueue Fields

[image] [image]

Sitecore 6.4.1 API
EventQueue Fields
EventQueue Class See Also Send Feedback

The EventQueue type exposes the following members.

Fields

Name | Description
TimestampPropertyPrefix | Property prefix used by the event queue stamps.

See Also

EventQueue Class
Sitecore.Eventing Namespace


TimestampPropertyPrefix Field

[image]

Sitecore 6.4.1 API
EventQueue..::..TimestampPropertyPrefix Field
EventQueue Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string TimestampPropertyPrefix
Visual Basic
Public Const TimestampPropertyPrefix As String
Visual C++
public:
literal String^ TimestampPropertyPrefix

See Also

EventQueue Class
Sitecore.Eventing Namespace


EventQueue Methods

[image] [image]

Sitecore 6.4.1 API
EventQueue Methods
EventQueue Class See Also Send Feedback

The EventQueue type exposes the following members.

Methods

 | Name | Description
Public method | Cleanup | Performs cleanup of the event queue.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetQueuedEventCount | Gets the queued event count.
Public method | GetQueuedEvents()()()() | The get queued events.
Public method | GetQueuedEvents(String) | The get queued events.
Public method | GetQueuedEvents(EventQueueQuery) | Gets the queued events.
Protected method | GetTimestampForLastProcessing | Gets the time stamp for last processing.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MarkProcessed | Marks the processed.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessEvents | Processes the events.
Protected method | QueueEvent(QueuedEvent, Boolean, Boolean) | Queues the event.
Public method | QueueEvent<(Of <<'(TEvent>)>>)(TEvent) | Queues the event.
Public method | QueueEvent<(Of <<'(TEvent>)>>)(TEvent, Boolean, Boolean) | Queues the event.
Public method | RemoveQueuedEvents | Removes the queued events matching the criteria specified by the query.
Protected method | SetTimestampForLastProcessing | Sets the timestamp for last processing.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EventQueue Class
Sitecore.Eventing Namespace


Cleanup Method

[image]

Sitecore 6.4.1 API
EventQueue..::..Cleanup Method
EventQueue Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract void Cleanup(
    uint daysToKeep
)
Visual Basic
Public MustOverride Sub Cleanup ( _
    daysToKeep As UInteger _
)
Visual C++
public:
virtual void Cleanup(
    unsigned int daysToKeep
) abstract

Parameters

daysToKeep
Type: System..::..UInt32
Number of days to keep the event queue trail.

See Also

EventQueue Class
Sitecore.Eventing Namespace


GetQueuedEventCount Method

[image]

Sitecore 6.4.1 API
EventQueue..::..GetQueuedEventCount Method
EventQueue Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract long GetQueuedEventCount()
Visual Basic
Public MustOverride Function GetQueuedEventCount As Long
Visual C++
public:
virtual long long GetQueuedEventCount() abstract

Return Value

The result.

See Also

EventQueue Class
Sitecore.Eventing Namespace


GetQueuedEvents Method

[image] [image]

Sitecore 6.4.1 API
EventQueue..::..GetQueuedEvents Method
EventQueue Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetQueuedEvents()()()() | The get queued events.
Public method | GetQueuedEvents(String) | The get queued events.
Public method | GetQueuedEvents(EventQueueQuery) | Gets the queued events.

See Also

EventQueue Class
EventQueue Members
Sitecore.Eventing Namespace


GetQueuedEvents Method

[image]

Sitecore 6.4.1 API
EventQueue..::..GetQueuedEvents Method
EventQueue Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IEnumerable<QueuedEvent> GetQueuedEvents()
Visual Basic
Public Function GetQueuedEvents As IEnumerable(Of QueuedEvent)
Visual C++
public:
IEnumerable<QueuedEvent^>^ GetQueuedEvents()

Return Value

The result.

See Also

EventQueue Class
GetQueuedEvents Overload
Sitecore.Eventing Namespace


GetTimestampForLastProcessing Method

[image]

Sitecore 6.4.1 API
EventQueue..::..GetTimestampForLastProcessing Method
EventQueue Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected abstract EventQueue..::..TimeStamp GetTimestampForLastProcessing()
Visual Basic
Protected MustOverride Function GetTimestampForLastProcessing As EventQueue..::..TimeStamp
Visual C++
protected:
virtual EventQueue..::..TimeStamp^ GetTimestampForLastProcessing() abstract

Return Value

The result.

See Also

EventQueue Class
Sitecore.Eventing Namespace


MarkProcessed Method

[image]

Sitecore 6.4.1 API
EventQueue..::..MarkProcessed Method
EventQueue Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void MarkProcessed(
    QueuedEvent queuedEvent
)
Visual Basic
Protected Overridable Sub MarkProcessed ( _
    queuedEvent As QueuedEvent _
)
Visual C++
protected:
virtual void MarkProcessed(
    QueuedEvent^ queuedEvent
)

Parameters

queuedEvent
Type: Sitecore.Eventing..::..QueuedEvent
The queued event.

See Also

EventQueue Class
Sitecore.Eventing Namespace


ProcessEvents Method

[image]

Sitecore 6.4.1 API
EventQueue..::..ProcessEvents Method
EventQueue Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void ProcessEvents(
    Action<Object, Type> handler
)
Visual Basic
Public Overridable Sub ProcessEvents ( _
    handler As Action(Of Object, Type) _
)
Visual C++
public:
virtual void ProcessEvents(
    Action<Object^, Type^>^ handler
)

Parameters

handler
Type: System..::..Action <(Of <(<' Object, Type >)>)>
The handler.

See Also

EventQueue Class
Sitecore.Eventing Namespace


QueueEvent Method

[image] [image]

Sitecore 6.4.1 API
EventQueue..::..QueueEvent Method
EventQueue Class See Also Send Feedback

Overload List

 | Name | Description
Public method | QueueEvent<(Of <<'(TEvent>)>>)(TEvent) | Queues the event.
Public method | QueueEvent<(Of <<'(TEvent>)>>)(TEvent, Boolean, Boolean) | Queues the event.
Protected method | QueueEvent(QueuedEvent, Boolean, Boolean) | Queues the event.

See Also

EventQueue Class
EventQueue Members
Sitecore.Eventing Namespace


QueueEvent(TEvent) Method (TEvent)

[image]

Sitecore 6.4.1 API
EventQueue..::..QueueEvent<(Of <(<'TEvent>)>)> Method (TEvent)
EventQueue Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void QueueEvent<TEvent>(
    TEvent event
)
Visual Basic
Public Sub QueueEvent(Of TEvent) ( _
    event As TEvent _
)
Visual C++
public:
generic<typename TEvent>
void QueueEvent(
    TEvent event
)

Parameters

event
Type: TEvent
The @event.

Type Parameters

TEvent
The type of the event.

See Also

EventQueue Class
QueueEvent Overload
Sitecore.Eventing Namespace


QueueEvent(TEvent) Method (TEvent, Boolean, Boolean)

[image]

Sitecore 6.4.1 API
EventQueue..::..QueueEvent<(Of <(<'TEvent>)>)> Method (TEvent, Boolean, Boolean)
EventQueue Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void QueueEvent<TEvent>(
    TEvent event,
    bool addToGlobalQueue,
    bool addToLocalQueue
)
Visual Basic
Public Sub QueueEvent(Of TEvent) ( _
    event As TEvent, _
    addToGlobalQueue As Boolean, _
    addToLocalQueue As Boolean _
)
Visual C++
public:
generic<typename TEvent>
void QueueEvent(
    TEvent event,
    bool addToGlobalQueue,
    bool addToLocalQueue
)

Parameters

event
Type: TEvent
The @event.
addToGlobalQueue
Type: System..::..Boolean
if set to true add the event to the global queue.
addToLocalQueue
Type: System..::..Boolean
if set to true add the event to the local queue.

Type Parameters

TEvent
The type of the event.

See Also

EventQueue Class
QueueEvent Overload
Sitecore.Eventing Namespace


QueueEvent Method (QueuedEvent, Boolean, Boolean)

[image]

Sitecore 6.4.1 API
EventQueue..::..QueueEvent Method (QueuedEvent, Boolean, Boolean)
EventQueue Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected abstract void QueueEvent(
    QueuedEvent queuedEvent,
    bool addToGlobalQueue,
    bool addToLocalQueue
)
Visual Basic
Protected MustOverride Sub QueueEvent ( _
    queuedEvent As QueuedEvent, _
    addToGlobalQueue As Boolean, _
    addToLocalQueue As Boolean _
)
Visual C++
protected:
virtual void QueueEvent(
    QueuedEvent^ queuedEvent,
    bool addToGlobalQueue,
    bool addToLocalQueue
) abstract

Parameters

queuedEvent
Type: Sitecore.Eventing..::..QueuedEvent
The queued event.
addToGlobalQueue
Type: System..::..Boolean
if set to true event will be sent to other servers.
addToLocalQueue
Type: System..::..Boolean
if set to true event will be sent to the local server.

See Also

EventQueue Class
QueueEvent Overload
Sitecore.Eventing Namespace


RemoveQueuedEvents Method

[image]

Sitecore 6.4.1 API
EventQueue..::..RemoveQueuedEvents Method
EventQueue Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract void RemoveQueuedEvents(
    EventQueueQuery query
)
Visual Basic
Public MustOverride Sub RemoveQueuedEvents ( _
    query As EventQueueQuery _
)
Visual C++
public:
virtual void RemoveQueuedEvents(
    EventQueueQuery^ query
) abstract

Parameters

query
Type: Sitecore.Eventing..::..EventQueueQuery
The query.

See Also

EventQueue Class
Sitecore.Eventing Namespace


EventQueue Properties

[image] [image]

Sitecore 6.4.1 API
EventQueue Properties
EventQueue Class See Also Send Feedback

The EventQueue type exposes the following members.

Properties

 | Name | Description
Protected property | InstanceName | Gets or sets the name of the instance.
Public property | ListenToRemoteEvents | Gets or sets a value indicating whether this queue will process remote events.
Protected property | PersistentTimestamp | Gets or sets the persistent timestamp.
Protected property | Serializer | Gets or sets the serializer.

See Also

EventQueue Class
Sitecore.Eventing Namespace


InstanceName Property

[image]

Sitecore 6.4.1 API
EventQueue..::..InstanceName Property
EventQueue Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected string InstanceName { get; set; }
Visual Basic
Protected Property InstanceName As String
    Get
    Set
Visual C++
protected:
property String^ InstanceName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the instance.

See Also

EventQueue Class
Sitecore.Eventing Namespace


ListenToRemoteEvents Property

[image]

Sitecore 6.4.1 API
EventQueue..::..ListenToRemoteEvents Property
EventQueue Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ListenToRemoteEvents { get; set; }
Visual Basic
Public Property ListenToRemoteEvents As Boolean
    Get
    Set
Visual C++
public:
property bool ListenToRemoteEvents {
    bool get ();
    void set (bool value);
}

Field Value

true if remote events are processed; otherwise, false.

See Also

EventQueue Class
Sitecore.Eventing Namespace


PersistentTimestamp Property

[image]

Sitecore 6.4.1 API
EventQueue..::..PersistentTimestamp Property
EventQueue Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected EventQueue..::..IPersistentTimestamp PersistentTimestamp { get; set; }
Visual Basic
Protected Property PersistentTimestamp As EventQueue..::..IPersistentTimestamp
    Get
    Set
Visual C++
protected:
property EventQueue..::..IPersistentTimestamp^ PersistentTimestamp {
    EventQueue..::..IPersistentTimestamp^ get ();
    void set (EventQueue..::..IPersistentTimestamp^ value);
}

Field Value

The persistent timestamp.

See Also

EventQueue Class
Sitecore.Eventing Namespace


Serializer Property

[image]

Sitecore 6.4.1 API
EventQueue..::..Serializer Property
EventQueue Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Serializer Serializer { get; set; }
Visual Basic
Protected Property Serializer As Serializer
    Get
    Set
Visual C++
protected:
property Serializer^ Serializer {
    Serializer^ get ();
    void set (Serializer^ value);
}

Field Value

The serializer.

See Also

EventQueue Class
Sitecore.Eventing Namespace


EventQueue.IPersistentTimestamp Interface

[image]

Sitecore 6.4.1 API
EventQueue..::..IPersistentTimestamp Interface
EventQueue Class Members See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected interface IPersistentTimestamp
Visual Basic
Protected Interface IPersistentTimestamp
Visual C++
protected interface class IPersistentTimestamp

See Also

EventQueue..::..IPersistentTimestamp Members
Sitecore.Eventing Namespace


EventQueue.IPersistentTimestamp Members

[image] [image]

Sitecore 6.4.1 API
EventQueue..::..IPersistentTimestamp Members
EventQueue..::..IPersistentTimestamp Interface Methods See Also Send Feedback

Defines the event queue class.

The EventQueue..::..IPersistentTimestamp type exposes the following members.

Methods

 | Name | Description
Public method | RetrieveTimestamp | Retrieves the timestamp. This is used on application start to load the last timestamp value from the persistent storage.
Public method | SaveTimestamp | Saves the timestamp to the persistent storage.

See Also

EventQueue..::..IPersistentTimestamp Interface
Sitecore.Eventing Namespace


RetrieveTimestamp Method

[image]

Sitecore 6.4.1 API
EventQueue..::..IPersistentTimestamp..::..RetrieveTimestamp Method
EventQueue..::..IPersistentTimestamp Interface See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
EventQueue..::..TimeStamp RetrieveTimestamp()
Visual Basic
Function RetrieveTimestamp As EventQueue..::..TimeStamp
Visual C++
EventQueue..::..TimeStamp^ RetrieveTimestamp()

Return Value

Timestamp value or null if the timestamp could not be loaded.

See Also

EventQueue..::..IPersistentTimestamp Interface
Sitecore.Eventing Namespace


SaveTimestamp Method

[image]

Sitecore 6.4.1 API
EventQueue..::..IPersistentTimestamp..::..SaveTimestamp Method
EventQueue..::..IPersistentTimestamp Interface See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void SaveTimestamp(
    EventQueue..::..TimeStamp value
)
Visual Basic
Sub SaveTimestamp ( _
    value As EventQueue..::..TimeStamp _
)
Visual C++
void SaveTimestamp(
    EventQueue..::..TimeStamp^ value
)

Parameters

value
Type: Sitecore.Eventing..::..EventQueue..::..TimeStamp
The value.

See Also

EventQueue..::..IPersistentTimestamp Interface
Sitecore.Eventing Namespace


EventQueue.PropertyTimeStamp Class

[image]

Sitecore 6.4.1 API
EventQueue..::..PropertyTimeStamp Class
EventQueue Class Members See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected class PropertyTimeStamp : EventQueue..::..IPersistentTimestamp
Visual Basic
Protected Class PropertyTimeStamp _
    Implements EventQueue..::..IPersistentTimestamp
Visual C++
protected ref class PropertyTimeStamp : EventQueue..::..IPersistentTimestamp

Inheritance Hierarchy

System..::..Object
Sitecore.Eventing..::..EventQueue..::..PropertyTimeStamp

See Also

EventQueue..::..PropertyTimeStamp Members
Sitecore.Eventing Namespace


EventQueue.PropertyTimeStamp Members

[image] [image]

Sitecore 6.4.1 API
EventQueue..::..PropertyTimeStamp Members
EventQueue..::..PropertyTimeStamp Class Constructors Methods See Also Send Feedback

Defines the event queue class.

The EventQueue..::..PropertyTimeStamp type exposes the following members.

Constructors

 | Name | Description
Public method | EventQueue..::..PropertyTimeStamp | Initializes a new instance of the EventQueue..::..PropertyTimeStamp class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RetrieveTimestamp | Retrieves the timestamp. This is used on application start to load the last timestamp value from the persistent storage.
Public method | SaveTimestamp | Sets the timestamp.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EventQueue..::..PropertyTimeStamp Class
Sitecore.Eventing Namespace


EventQueue.PropertyTimeStamp Constructor

[image]

Sitecore 6.4.1 API
EventQueue..::..PropertyTimeStamp Constructor
EventQueue..::..PropertyTimeStamp Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PropertyTimeStamp(
    Database database
)
Visual Basic
Public Sub New ( _
    database As Database _
)
Visual C++
public:
PropertyTimeStamp(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

See Also

EventQueue..::..PropertyTimeStamp Class
Sitecore.Eventing Namespace


EventQueue.PropertyTimeStamp Methods

[image] [image]

Sitecore 6.4.1 API
EventQueue..::..PropertyTimeStamp Methods
EventQueue..::..PropertyTimeStamp Class See Also Send Feedback

The EventQueue..::..PropertyTimeStamp type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RetrieveTimestamp | Retrieves the timestamp. This is used on application start to load the last timestamp value from the persistent storage.
Public method | SaveTimestamp | Sets the timestamp.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EventQueue..::..PropertyTimeStamp Class
Sitecore.Eventing Namespace


RetrieveTimestamp Method

[image]

Sitecore 6.4.1 API
EventQueue..::..PropertyTimeStamp..::..RetrieveTimestamp Method
EventQueue..::..PropertyTimeStamp Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public EventQueue..::..TimeStamp RetrieveTimestamp()
Visual Basic
Public Function RetrieveTimestamp As EventQueue..::..TimeStamp
Visual C++
public:
virtual EventQueue..::..TimeStamp^ RetrieveTimestamp() sealed

Return Value

Timestamp value or null if the timestamp could not be loaded.

Implements

EventQueue..::..IPersistentTimestamp..::..RetrieveTimestamp()()()()

See Also

EventQueue..::..PropertyTimeStamp Class
Sitecore.Eventing Namespace


SaveTimestamp Method

[image]

Sitecore 6.4.1 API
EventQueue..::..PropertyTimeStamp..::..SaveTimestamp Method
EventQueue..::..PropertyTimeStamp Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SaveTimestamp(
    EventQueue..::..TimeStamp value
)
Visual Basic
Public Sub SaveTimestamp ( _
    value As EventQueue..::..TimeStamp _
)
Visual C++
public:
virtual void SaveTimestamp(
    EventQueue..::..TimeStamp^ value
) sealed

Parameters

value
Type: Sitecore.Eventing..::..EventQueue..::..TimeStamp
The value.

Implements

EventQueue..::..IPersistentTimestamp..::..SaveTimestamp(EventQueue..::..TimeStamp)

See Also

EventQueue..::..PropertyTimeStamp Class
Sitecore.Eventing Namespace


EventQueue.TimeStamp Class

[image]

Sitecore 6.4.1 API
EventQueue..::..TimeStamp Class
EventQueue Class Members See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected class TimeStamp : IComparable<EventQueue..::..TimeStamp>
Visual Basic
Protected Class TimeStamp _
    Implements IComparable(Of EventQueue..::..TimeStamp)
Visual C++
protected ref class TimeStamp : IComparable<EventQueue..::..TimeStamp^>

Inheritance Hierarchy

System..::..Object
Sitecore.Eventing..::..EventQueue..::..TimeStamp

See Also

EventQueue..::..TimeStamp Members
Sitecore.Eventing Namespace


EventQueue.TimeStamp Members

[image] [image]

Sitecore 6.4.1 API
EventQueue..::..TimeStamp Members
EventQueue..::..TimeStamp Class Constructors Methods Properties See Also Send Feedback

Defines the event queue class.

The EventQueue..::..TimeStamp type exposes the following members.

Constructors

 | Name | Description
Public method | EventQueue..::..TimeStamp(Int64) | Initializes a new instance of the EventQueue..::..TimeStamp class.
Public method | EventQueue..::..TimeStamp(DateTime, Int64) | Initializes a new instance of the EventQueue..::..TimeStamp class.

Methods

 | Name | Description
Public method | CompareTo | Compares the current object with another object of the same type.
Public method | Equals | Determines whether the specified Object is equal to this instance. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Parses the specified string into a timestamp.
Public method | ToString | Returns a String that represents this instance. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Date | Gets the date boundary associated with the timestamp. See RetrieveTimestamp()()()() and GetQueuedEvents(String)
 | MinValue | Gets the minimal timestamp value.
Public property | Sequence | Gets or sets the sequence number in the event queue.

See Also

EventQueue..::..TimeStamp Class
Sitecore.Eventing Namespace


EventQueue.TimeStamp Constructor

[image] [image]

Sitecore 6.4.1 API
EventQueue..::..TimeStamp Constructor
EventQueue..::..TimeStamp Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EventQueue..::..TimeStamp(Int64) | Initializes a new instance of the EventQueue..::..TimeStamp class.
Public method | EventQueue..::..TimeStamp(DateTime, Int64) | Initializes a new instance of the EventQueue..::..TimeStamp class.

See Also

EventQueue..::..TimeStamp Class
EventQueue..::..TimeStamp Members
Sitecore.Eventing Namespace


EventQueue.TimeStamp Constructor (Int64)

[image]

Sitecore 6.4.1 API
EventQueue..::..TimeStamp Constructor (Int64)
EventQueue..::..TimeStamp Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TimeStamp(
    long sequence
)
Visual Basic
Public Sub New ( _
    sequence As Long _
)
Visual C++
public:
TimeStamp(
    long long sequence
)

Parameters

sequence
Type: System..::..Int64
The sequence.

See Also

EventQueue..::..TimeStamp Class
EventQueue..::..TimeStamp Overload
Sitecore.Eventing Namespace


EventQueue.TimeStamp Constructor (DateTime, Int64)

[image]

Sitecore 6.4.1 API
EventQueue..::..TimeStamp Constructor (DateTime, Int64)
EventQueue..::..TimeStamp Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TimeStamp(
    DateTime date,
    long sequence
)
Visual Basic
Public Sub New ( _
    date As DateTime, _
    sequence As Long _
)
Visual C++
public:
TimeStamp(
    DateTime date,
    long long sequence
)

Parameters

date
Type: System..::..DateTime
The date.
sequence
Type: System..::..Int64
The sequence.

See Also

EventQueue..::..TimeStamp Class
EventQueue..::..TimeStamp Overload
Sitecore.Eventing Namespace


EventQueue.TimeStamp Methods

[image] [image]

Sitecore 6.4.1 API
EventQueue..::..TimeStamp Methods
EventQueue..::..TimeStamp Class See Also Send Feedback

The EventQueue..::..TimeStamp type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo | Compares the current object with another object of the same type.
Public method | Equals | Determines whether the specified Object is equal to this instance. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Parses the specified string into a timestamp.
Public method | ToString | Returns a String that represents this instance. (Overrides Object..::..ToString()()()().)

See Also

EventQueue..::..TimeStamp Class
Sitecore.Eventing Namespace


CompareTo Method

[image]

Sitecore 6.4.1 API
EventQueue..::..TimeStamp..::..CompareTo Method
EventQueue..::..TimeStamp Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int CompareTo(
    EventQueue..::..TimeStamp other
)
Visual Basic
Public Function CompareTo ( _
    other As EventQueue..::..TimeStamp _
) As Integer
Visual C++
public:
virtual int CompareTo(
    EventQueue..::..TimeStamp^ other
) sealed

Parameters

other
Type: Sitecore.Eventing..::..EventQueue..::..TimeStamp
An object to compare with this object.

Return Value

A 32-bit signed integer that indicates the relative order of the objects being compared. The return value has the following meanings: Value Meaning Less than zero This object is less than the other parameter. Zero This object is equal to other. Greater than zero This object is greater than other.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Uncomparable stamps

See Also

EventQueue..::..TimeStamp Class
Sitecore.Eventing Namespace


GetHashCode Method

[image]

Sitecore 6.4.1 API
EventQueue..::..TimeStamp..::..GetHashCode Method
EventQueue..::..TimeStamp Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.

See Also

EventQueue..::..TimeStamp Class
Sitecore.Eventing Namespace


Parse Method

[image]

Sitecore 6.4.1 API
EventQueue..::..TimeStamp..::..Parse Method
EventQueue..::..TimeStamp Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static EventQueue..::..TimeStamp Parse(
    string value
)
Visual Basic
Public Shared Function Parse ( _
    value As String _
) As EventQueue..::..TimeStamp
Visual C++
public:
static EventQueue..::..TimeStamp^ Parse(
    String^ value
)

Parameters

value
Type: System..::..String
The serialized timestamp.

Return Value

The timestamp.

See Also

EventQueue..::..TimeStamp Class
Sitecore.Eventing Namespace


ToString Method

[image]

Sitecore 6.4.1 API
EventQueue..::..TimeStamp..::..ToString Method
EventQueue..::..TimeStamp Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents this instance.

See Also

EventQueue..::..TimeStamp Class
Sitecore.Eventing Namespace


EventQueue.TimeStamp Properties

[image] [image]

Sitecore 6.4.1 API
EventQueue..::..TimeStamp Properties
EventQueue..::..TimeStamp Class See Also Send Feedback

The EventQueue..::..TimeStamp type exposes the following members.

Properties

 | Name | Description
Public property | Date | Gets the date boundary associated with the timestamp. See RetrieveTimestamp()()()() and GetQueuedEvents(String)
 | MinValue | Gets the minimal timestamp value.
Public property | Sequence | Gets or sets the sequence number in the event queue.

See Also

EventQueue..::..TimeStamp Class
Sitecore.Eventing Namespace


Date Property

[image]

Sitecore 6.4.1 API
EventQueue..::..TimeStamp..::..Date Property
EventQueue..::..TimeStamp Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime Date { get; protected set; }
Visual Basic
Public Property Date As DateTime
    Get
    Protected Set
Visual C++
public:
property DateTime Date {
    DateTime get ();
    protected: void set (DateTime value);
}

Field Value

The date of the event.

See Also

EventQueue..::..TimeStamp Class
Sitecore.Eventing Namespace


MinValue Property

[image]

Sitecore 6.4.1 API
EventQueue..::..TimeStamp..::..MinValue Property
EventQueue..::..TimeStamp Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static EventQueue..::..TimeStamp MinValue { get; }
Visual Basic
Public Shared ReadOnly Property MinValue As EventQueue..::..TimeStamp
    Get
Visual C++
public:
static property EventQueue..::..TimeStamp^ MinValue {
    EventQueue..::..TimeStamp^ get ();
}

Field Value

The minimal timestamp value.

See Also

EventQueue..::..TimeStamp Class
Sitecore.Eventing Namespace


Sequence Property

[image]

Sitecore 6.4.1 API
EventQueue..::..TimeStamp..::..Sequence Property
EventQueue..::..TimeStamp Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long Sequence { get; protected set; }
Visual Basic
Public Property Sequence As Long
    Get
    Protected Set
Visual C++
public:
property long long Sequence {
    long long get ();
    protected: void set (long long value);
}

Field Value

The sequence.

See Also

EventQueue..::..TimeStamp Class
Sitecore.Eventing Namespace


EventQueueQuery Class

[image]

Sitecore 6.4.1 API
EventQueueQuery Class
Members See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class EventQueueQuery
Visual Basic
Public Class EventQueueQuery
Visual C++
public ref class EventQueueQuery

Inheritance Hierarchy

System..::..Object
Sitecore.Eventing..::..EventQueueQuery

See Also

EventQueueQuery Members
Sitecore.Eventing Namespace


EventQueueQuery Members

[image] [image]

Sitecore 6.4.1 API
EventQueueQuery Members
EventQueueQuery Class Constructors Methods Properties See Also Send Feedback

The EventQueueQuery type exposes the following members.

Constructors

 | Name | Description
Public method | EventQueueQuery | Initializes a new instance of the EventQueueQuery class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EventType | Gets or sets the type of the event.
Public property | FromTimestamp | Gets or sets the minimum value of the Timestamp column..
Public property | FromUtcDate | Gets or sets the minimum value of the Created column..
Public property | InstanceType | Gets or sets the type of the instance.
Public property | SourceInstanceName | Gets or sets the name of the source instance.
Public property | TargetInstanceName | Gets or sets the name of the target instance.
Public property | ToTimestamp | Gets or sets the maximum value of the Timestamp column..
Public property | ToUtcDate | Gets or sets the maximum value of the Created column..
Public property | UserName | Gets or sets the name of the user.

See Also

EventQueueQuery Class
Sitecore.Eventing Namespace


EventQueueQuery Constructor

[image]

Sitecore 6.4.1 API
EventQueueQuery Constructor
EventQueueQuery Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public EventQueueQuery()
Visual Basic
Public Sub New
Visual C++
public:
EventQueueQuery()

See Also

EventQueueQuery Class
Sitecore.Eventing Namespace


EventQueueQuery Methods

[image] [image]

Sitecore 6.4.1 API
EventQueueQuery Methods
EventQueueQuery Class See Also Send Feedback

The EventQueueQuery type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EventQueueQuery Class
Sitecore.Eventing Namespace


EventQueueQuery Properties

[image] [image]

Sitecore 6.4.1 API
EventQueueQuery Properties
EventQueueQuery Class See Also Send Feedback

The EventQueueQuery type exposes the following members.

Properties

 | Name | Description
Public property | EventType | Gets or sets the type of the event.
Public property | FromTimestamp | Gets or sets the minimum value of the Timestamp column..
Public property | FromUtcDate | Gets or sets the minimum value of the Created column..
Public property | InstanceType | Gets or sets the type of the instance.
Public property | SourceInstanceName | Gets or sets the name of the source instance.
Public property | TargetInstanceName | Gets or sets the name of the target instance.
Public property | ToTimestamp | Gets or sets the maximum value of the Timestamp column..
Public property | ToUtcDate | Gets or sets the maximum value of the Created column..
Public property | UserName | Gets or sets the name of the user.

See Also

EventQueueQuery Class
Sitecore.Eventing Namespace


EventType Property

[image]

Sitecore 6.4.1 API
EventQueueQuery..::..EventType Property
EventQueueQuery Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Type EventType { get; set; }
Visual Basic
Public Property EventType As Type
    Get
    Set
Visual C++
public:
property Type^ EventType {
    Type^ get ();
    void set (Type^ value);
}

Field Value

The type of the event.

See Also

EventQueueQuery Class
Sitecore.Eventing Namespace


FromTimestamp Property

[image]

Sitecore 6.4.1 API
EventQueueQuery..::..FromTimestamp Property
EventQueueQuery Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Nullable<long> FromTimestamp { get; set; }
Visual Basic
Public Property FromTimestamp As Nullable(Of Long)
    Get
    Set
Visual C++
public:
property Nullable<long long> FromTimestamp {
    Nullable<long long> get ();
    void set (Nullable<long long> value);
}

Field Value

The minimum value of the Timestamp column.

See Also

EventQueueQuery Class
Sitecore.Eventing Namespace


FromUtcDate Property

[image]

Sitecore 6.4.1 API
EventQueueQuery..::..FromUtcDate Property
EventQueueQuery Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Nullable<DateTime> FromUtcDate { get; set; }
Visual Basic
Public Property FromUtcDate As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> FromUtcDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Field Value

The minimum value of the Created column.

See Also

EventQueueQuery Class
Sitecore.Eventing Namespace


InstanceType Property

[image]

Sitecore 6.4.1 API
EventQueueQuery..::..InstanceType Property
EventQueueQuery Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Type InstanceType { get; set; }
Visual Basic
Public Property InstanceType As Type
    Get
    Set
Visual C++
public:
property Type^ InstanceType {
    Type^ get ();
    void set (Type^ value);
}

Field Value

The type of the instance.

See Also

EventQueueQuery Class
Sitecore.Eventing Namespace


SourceInstanceName Property

[image]

Sitecore 6.4.1 API
EventQueueQuery..::..SourceInstanceName Property
EventQueueQuery Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string SourceInstanceName { get; set; }
Visual Basic
Public Property SourceInstanceName As String
    Get
    Set
Visual C++
public:
property String^ SourceInstanceName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the source instance.

See Also

EventQueueQuery Class
Sitecore.Eventing Namespace


TargetInstanceName Property

[image]

Sitecore 6.4.1 API
EventQueueQuery..::..TargetInstanceName Property
EventQueueQuery Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string TargetInstanceName { get; set; }
Visual Basic
Public Property TargetInstanceName As String
    Get
    Set
Visual C++
public:
property String^ TargetInstanceName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the target instance.

See Also

EventQueueQuery Class
Sitecore.Eventing Namespace


ToTimestamp Property

[image]

Sitecore 6.4.1 API
EventQueueQuery..::..ToTimestamp Property
EventQueueQuery Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Nullable<long> ToTimestamp { get; set; }
Visual Basic
Public Property ToTimestamp As Nullable(Of Long)
    Get
    Set
Visual C++
public:
property Nullable<long long> ToTimestamp {
    Nullable<long long> get ();
    void set (Nullable<long long> value);
}

Field Value

The maximum value of the Timestamp column.

See Also

EventQueueQuery Class
Sitecore.Eventing Namespace


ToUtcDate Property

[image]

Sitecore 6.4.1 API
EventQueueQuery..::..ToUtcDate Property
EventQueueQuery Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Nullable<DateTime> ToUtcDate { get; set; }
Visual Basic
Public Property ToUtcDate As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> ToUtcDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Field Value

The maximum value of the Created column.

See Also

EventQueueQuery Class
Sitecore.Eventing Namespace


UserName Property

[image]

Sitecore 6.4.1 API
EventQueueQuery..::..UserName Property
EventQueueQuery Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string UserName { get; set; }
Visual Basic
Public Property UserName As String
    Get
    Set
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the user.

See Also

EventQueueQuery Class
Sitecore.Eventing Namespace


IHasEventName Interface

[image]

Sitecore 6.4.1 API
IHasEventName Interface
Members See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IHasEventName
Visual Basic
Public Interface IHasEventName
Visual C++
public interface class IHasEventName

See Also

IHasEventName Members
Sitecore.Eventing Namespace


IHasEventName Members

[image] [image]

Sitecore 6.4.1 API
IHasEventName Members
IHasEventName Interface Properties See Also Send Feedback

The IHasEventName type exposes the following members.

Properties

 | Name | Description
Public property | EventName | Gets the name of the event.

See Also

IHasEventName Interface
Sitecore.Eventing Namespace


IHasEventName Properties

[image] [image]

Sitecore 6.4.1 API
IHasEventName Properties
IHasEventName Interface See Also Send Feedback

The IHasEventName type exposes the following members.

Properties

 | Name | Description
Public property | EventName | Gets the name of the event.

See Also

IHasEventName Interface
Sitecore.Eventing Namespace


EventName Property

[image]

Sitecore 6.4.1 API
IHasEventName..::..EventName Property
IHasEventName Interface See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
string EventName { get; }
Visual Basic
ReadOnly Property EventName As String
    Get
Visual C++
property String^ EventName {
    String^ get ();
}

Field Value

The name of the event.

See Also

IHasEventName Interface
Sitecore.Eventing Namespace


NullEventQueue Class

[image]

Sitecore 6.4.1 API
NullEventQueue Class
Members See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class NullEventQueue : EventQueue
Visual Basic
Public Class NullEventQueue _
    Inherits EventQueue
Visual C++
public ref class NullEventQueue : public EventQueue

Inheritance Hierarchy

System..::..Object
Sitecore.Eventing..::..EventQueue
Sitecore.Eventing..::..NullEventQueue

See Also

NullEventQueue Members
Sitecore.Eventing Namespace


NullEventQueue Members

[image] [image]

Sitecore 6.4.1 API
NullEventQueue Members
NullEventQueue Class Methods Properties See Also Send Feedback

The NullEventQueue type exposes the following members.

Methods

 | Name | Description
Public method | Cleanup | Performs cleanup of the event queue. (Overrides EventQueue..::..Cleanup(UInt32).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetQueuedEventCount | Gets the queued event count. (Overrides EventQueue..::..GetQueuedEventCount()()()().)
Public method | GetQueuedEvents()()()() | The get queued events. (Inherited from EventQueue.)
Public method | GetQueuedEvents(String) | The get queued events. (Inherited from EventQueue.)
Public method | GetQueuedEvents(EventQueueQuery) | Gets the queued events. (Overrides EventQueue..::..GetQueuedEvents(EventQueueQuery).)
Protected method | GetTimestampForLastProcessing | Gets the time stamp for last processing. (Overrides EventQueue..::..GetTimestampForLastProcessing()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MarkProcessed | Marks the processed. (Overrides EventQueue..::..MarkProcessed(QueuedEvent).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessEvents | Processes the events. (Inherited from EventQueue.)
Protected method | QueueEvent(QueuedEvent, Boolean, Boolean) | Queues the event. (Overrides EventQueue..::..QueueEvent(QueuedEvent, Boolean, Boolean).)
Public method | QueueEvent<(Of <<'(TEvent>)>>)(TEvent) | Queues the event. (Inherited from EventQueue.)
Public method | QueueEvent<(Of <<'(TEvent>)>>)(TEvent, Boolean, Boolean) | Queues the event. (Inherited from EventQueue.)
Public method | RemoveQueuedEvents | Removes the queued events matching the criteria specified by the query. (Overrides EventQueue..::..RemoveQueuedEvents(EventQueueQuery).)
Protected method | SetTimestampForLastProcessing | Sets the timestamp for last processing. (Overrides EventQueue..::..SetTimestampForLastProcessing(EventQueue..::..TimeStamp).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
 | Instance | Gets the instance.
Protected property | InstanceName | Gets or sets the name of the instance. (Inherited from EventQueue.)
Public property | ListenToRemoteEvents | Gets or sets a value indicating whether this queue will process remote events. (Inherited from EventQueue.)
Protected property | PersistentTimestamp | Gets or sets the persistent timestamp. (Inherited from EventQueue.)
Protected property | Serializer | Gets or sets the serializer. (Inherited from EventQueue.)

See Also

NullEventQueue Class
Sitecore.Eventing Namespace


NullEventQueue Methods

[image] [image]

Sitecore 6.4.1 API
NullEventQueue Methods
NullEventQueue Class See Also Send Feedback

The NullEventQueue type exposes the following members.

Methods

 | Name | Description
Public method | Cleanup | Performs cleanup of the event queue. (Overrides EventQueue..::..Cleanup(UInt32).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetQueuedEventCount | Gets the queued event count. (Overrides EventQueue..::..GetQueuedEventCount()()()().)
Public method | GetQueuedEvents()()()() | The get queued events. (Inherited from EventQueue.)
Public method | GetQueuedEvents(String) | The get queued events. (Inherited from EventQueue.)
Public method | GetQueuedEvents(EventQueueQuery) | Gets the queued events. (Overrides EventQueue..::..GetQueuedEvents(EventQueueQuery).)
Protected method | GetTimestampForLastProcessing | Gets the time stamp for last processing. (Overrides EventQueue..::..GetTimestampForLastProcessing()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MarkProcessed | Marks the processed. (Overrides EventQueue..::..MarkProcessed(QueuedEvent).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessEvents | Processes the events. (Inherited from EventQueue.)
Protected method | QueueEvent(QueuedEvent, Boolean, Boolean) | Queues the event. (Overrides EventQueue..::..QueueEvent(QueuedEvent, Boolean, Boolean).)
Public method | QueueEvent<(Of <<'(TEvent>)>>)(TEvent) | Queues the event. (Inherited from EventQueue.)
Public method | QueueEvent<(Of <<'(TEvent>)>>)(TEvent, Boolean, Boolean) | Queues the event. (Inherited from EventQueue.)
Public method | RemoveQueuedEvents | Removes the queued events matching the criteria specified by the query. (Overrides EventQueue..::..RemoveQueuedEvents(EventQueueQuery).)
Protected method | SetTimestampForLastProcessing | Sets the timestamp for last processing. (Overrides EventQueue..::..SetTimestampForLastProcessing(EventQueue..::..TimeStamp).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NullEventQueue Class
Sitecore.Eventing Namespace


Cleanup Method

[image]

Sitecore 6.4.1 API
NullEventQueue..::..Cleanup Method
NullEventQueue Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Cleanup(
    uint daysToKeep
)
Visual Basic
Public Overrides Sub Cleanup ( _
    daysToKeep As UInteger _
)
Visual C++
public:
virtual void Cleanup(
    unsigned int daysToKeep
) override

Parameters

daysToKeep
Type: System..::..UInt32

[Missing <param name="daysToKeep"/> documentation for "M:Sitecore.Eventing.NullEventQueue.Cleanup(System.UInt32)"]

See Also

NullEventQueue Class
Sitecore.Eventing Namespace


GetQueuedEventCount Method

[image]

Sitecore 6.4.1 API
NullEventQueue..::..GetQueuedEventCount Method
NullEventQueue Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override long GetQueuedEventCount()
Visual Basic
Public Overrides Function GetQueuedEventCount As Long
Visual C++
public:
virtual long long GetQueuedEventCount() override

Return Value

The result.

See Also

NullEventQueue Class
Sitecore.Eventing Namespace


GetQueuedEvents Method

[image] [image]

Sitecore 6.4.1 API
NullEventQueue..::..GetQueuedEvents Method
NullEventQueue Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetQueuedEvents()()()() | The get queued events. (Inherited from EventQueue.)
Public method | GetQueuedEvents(String) | The get queued events. (Inherited from EventQueue.)
Public method | GetQueuedEvents(EventQueueQuery) | Gets the queued events. (Overrides EventQueue..::..GetQueuedEvents(EventQueueQuery).)

See Also

NullEventQueue Class
NullEventQueue Members
Sitecore.Eventing Namespace


GetTimestampForLastProcessing Method

[image]

Sitecore 6.4.1 API
NullEventQueue..::..GetTimestampForLastProcessing Method
NullEventQueue Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override EventQueue..::..TimeStamp GetTimestampForLastProcessing()
Visual Basic
Protected Overrides Function GetTimestampForLastProcessing As EventQueue..::..TimeStamp
Visual C++
protected:
virtual EventQueue..::..TimeStamp^ GetTimestampForLastProcessing() override

Return Value

The result.

See Also

NullEventQueue Class
Sitecore.Eventing Namespace


MarkProcessed Method

[image]

Sitecore 6.4.1 API
NullEventQueue..::..MarkProcessed Method
NullEventQueue Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void MarkProcessed(
    QueuedEvent queuedEvent
)
Visual Basic
Protected Overrides Sub MarkProcessed ( _
    queuedEvent As QueuedEvent _
)
Visual C++
protected:
virtual void MarkProcessed(
    QueuedEvent^ queuedEvent
) override

Parameters

queuedEvent
Type: Sitecore.Eventing..::..QueuedEvent
The queued event.

See Also

NullEventQueue Class
Sitecore.Eventing Namespace


QueueEvent Method

[image] [image]

Sitecore 6.4.1 API
NullEventQueue..::..QueueEvent Method
NullEventQueue Class See Also Send Feedback

Overload List

 | Name | Description
Public method | QueueEvent<(Of <<'(TEvent>)>>)(TEvent) | Queues the event. (Inherited from EventQueue.)
Public method | QueueEvent<(Of <<'(TEvent>)>>)(TEvent, Boolean, Boolean) | Queues the event. (Inherited from EventQueue.)
Protected method | QueueEvent(QueuedEvent, Boolean, Boolean) | Queues the event. (Overrides EventQueue..::..QueueEvent(QueuedEvent, Boolean, Boolean).)

See Also

NullEventQueue Class
NullEventQueue Members
Sitecore.Eventing Namespace


RemoveQueuedEvents Method

[image]

Sitecore 6.4.1 API
NullEventQueue..::..RemoveQueuedEvents Method
NullEventQueue Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void RemoveQueuedEvents(
    EventQueueQuery query
)
Visual Basic
Public Overrides Sub RemoveQueuedEvents ( _
    query As EventQueueQuery _
)
Visual C++
public:
virtual void RemoveQueuedEvents(
    EventQueueQuery^ query
) override

Parameters

query
Type: Sitecore.Eventing..::..EventQueueQuery
The query.

See Also

NullEventQueue Class
Sitecore.Eventing Namespace


SetTimestampForLastProcessing Method

[image]

Sitecore 6.4.1 API
NullEventQueue..::..SetTimestampForLastProcessing Method
NullEventQueue Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void SetTimestampForLastProcessing(
    EventQueue..::..TimeStamp timestamp
)
Visual Basic
Protected Overrides Sub SetTimestampForLastProcessing ( _
    timestamp As EventQueue..::..TimeStamp _
)
Visual C++
protected:
virtual void SetTimestampForLastProcessing(
    EventQueue..::..TimeStamp^ timestamp
) override

Parameters

timestamp
Type: Sitecore.Eventing..::..EventQueue..::..TimeStamp
The timestamp.

See Also

NullEventQueue Class
Sitecore.Eventing Namespace


NullEventQueue Properties

[image] [image]

Sitecore 6.4.1 API
NullEventQueue Properties
NullEventQueue Class See Also Send Feedback

The NullEventQueue type exposes the following members.

Properties

 | Name | Description
 | Instance | Gets the instance.
Protected property | InstanceName | Gets or sets the name of the instance. (Inherited from EventQueue.)
Public property | ListenToRemoteEvents | Gets or sets a value indicating whether this queue will process remote events. (Inherited from EventQueue.)
Protected property | PersistentTimestamp | Gets or sets the persistent timestamp. (Inherited from EventQueue.)
Protected property | Serializer | Gets or sets the serializer. (Inherited from EventQueue.)

See Also

NullEventQueue Class
Sitecore.Eventing Namespace


Instance Property

[image]

Sitecore 6.4.1 API
NullEventQueue..::..Instance Property
NullEventQueue Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static EventQueue Instance { get; }
Visual Basic
Public Shared ReadOnly Property Instance As EventQueue
    Get
Visual C++
public:
static property EventQueue^ Instance {
    EventQueue^ get ();
}

Field Value

The instance.

See Also

NullEventQueue Class
Sitecore.Eventing Namespace


QueuedEvent Class

[image]

Sitecore 6.4.1 API
QueuedEvent Class
Members See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class QueuedEvent
Visual Basic
Public Class QueuedEvent
Visual C++
public ref class QueuedEvent

Inheritance Hierarchy

System..::..Object
Sitecore.Eventing..::..QueuedEvent

See Also

QueuedEvent Members
Sitecore.Eventing Namespace


QueuedEvent Members

[image] [image]

Sitecore 6.4.1 API
QueuedEvent Members
QueuedEvent Class Constructors Methods Properties See Also Send Feedback

The QueuedEvent type exposes the following members.

Constructors

 | Name | Description
Public method | QueuedEvent(String, String, String, String, String) | Initializes a new instance of the QueuedEvent class.
Public method | QueuedEvent(String, String, String, String, String, Int64, DateTime) | Initializes a new instance of the QueuedEvent class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Created | Gets or sets the created.
Public property | EventType | Gets or sets the type of the event.
Public property | EventTypeName | Gets or sets the name of the event type.
Public property | InstanceData | Gets or sets the object data.
Public property | InstanceName | Gets or sets the name of the server.
Public property | InstanceType | Gets or sets the type of the object.
Public property | InstanceTypeName | Gets or sets the name of the instance type.
Public property | Timestamp | Gets or sets the timestamp.
Public property | UserName | Gets or sets the name of the user.

See Also

QueuedEvent Class
Sitecore.Eventing Namespace


QueuedEvent Constructor

[image] [image]

Sitecore 6.4.1 API
QueuedEvent Constructor
QueuedEvent Class See Also Send Feedback

Overload List

 | Name | Description
Public method | QueuedEvent(String, String, String, String, String) | Initializes a new instance of the QueuedEvent class.
Public method | QueuedEvent(String, String, String, String, String, Int64, DateTime) | Initializes a new instance of the QueuedEvent class.

See Also

QueuedEvent Class
QueuedEvent Members
Sitecore.Eventing Namespace


QueuedEvent Constructor (String, String, String, String, String)

[image]

Sitecore 6.4.1 API
QueuedEvent Constructor (String, String, String, String, String)
QueuedEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public QueuedEvent(
    string eventTypeName,
    string instanceTypeName,
    string instanceData,
    string instanceName,
    string userName
)
Visual Basic
Public Sub New ( _
    eventTypeName As String, _
    instanceTypeName As String, _
    instanceData As String, _
    instanceName As String, _
    userName As String _
)
Visual C++
public:
QueuedEvent(
    String^ eventTypeName,
    String^ instanceTypeName,
    String^ instanceData,
    String^ instanceName,
    String^ userName
)

Parameters

eventTypeName
Type: System..::..String
Type of the event.
instanceTypeName
Type: System..::..String
Type of the instance.
instanceData
Type: System..::..String
The instance data.
instanceName
Type: System..::..String
The server instance name.
userName
Type: System..::..String
The user Name.

See Also

QueuedEvent Class
QueuedEvent Overload
Sitecore.Eventing Namespace


QueuedEvent Constructor (String, String, String, String, String, Int64, DateTime)

[image]

Sitecore 6.4.1 API
QueuedEvent Constructor (String, String, String, String, String, Int64, DateTime)
QueuedEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public QueuedEvent(
    string eventTypeName,
    string instanceTypeName,
    string instanceData,
    string instanceName,
    string userName,
    long timestamp,
    DateTime created
)
Visual Basic
Public Sub New ( _
    eventTypeName As String, _
    instanceTypeName As String, _
    instanceData As String, _
    instanceName As String, _
    userName As String, _
    timestamp As Long, _
    created As DateTime _
)
Visual C++
public:
QueuedEvent(
    String^ eventTypeName,
    String^ instanceTypeName,
    String^ instanceData,
    String^ instanceName,
    String^ userName,
    long long timestamp,
    DateTime created
)

Parameters

eventTypeName
Type: System..::..String
Type of the event.
instanceTypeName
Type: System..::..String
Type of the instance.
instanceData
Type: System..::..String
The instance data.
instanceName
Type: System..::..String
Name of the instance.
userName
Type: System..::..String
Name of the user.
timestamp
Type: System..::..Int64
The timestamp.
created
Type: System..::..DateTime
The created.

See Also

QueuedEvent Class
QueuedEvent Overload
Sitecore.Eventing Namespace


QueuedEvent Methods

[image] [image]

Sitecore 6.4.1 API
QueuedEvent Methods
QueuedEvent Class See Also Send Feedback

The QueuedEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

QueuedEvent Class
Sitecore.Eventing Namespace


QueuedEvent Properties

[image] [image]

Sitecore 6.4.1 API
QueuedEvent Properties
QueuedEvent Class See Also Send Feedback

The QueuedEvent type exposes the following members.

Properties

 | Name | Description
Public property | Created | Gets or sets the created.
Public property | EventType | Gets or sets the type of the event.
Public property | EventTypeName | Gets or sets the name of the event type.
Public property | InstanceData | Gets or sets the object data.
Public property | InstanceName | Gets or sets the name of the server.
Public property | InstanceType | Gets or sets the type of the object.
Public property | InstanceTypeName | Gets or sets the name of the instance type.
Public property | Timestamp | Gets or sets the timestamp.
Public property | UserName | Gets or sets the name of the user.

See Also

QueuedEvent Class
Sitecore.Eventing Namespace


Created Property

[image]

Sitecore 6.4.1 API
QueuedEvent..::..Created Property
QueuedEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime Created { get; protected set; }
Visual Basic
Public Property Created As DateTime
    Get
    Protected Set
Visual C++
public:
property DateTime Created {
    DateTime get ();
    protected: void set (DateTime value);
}

Field Value

The created.

See Also

QueuedEvent Class
Sitecore.Eventing Namespace


EventType Property

[image]

Sitecore 6.4.1 API
QueuedEvent..::..EventType Property
QueuedEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Type EventType { get; }
Visual Basic
Public ReadOnly Property EventType As Type
    Get
Visual C++
public:
property Type^ EventType {
    Type^ get ();
}

Field Value

The type of the event.

See Also

QueuedEvent Class
Sitecore.Eventing Namespace


EventTypeName Property

[image]

Sitecore 6.4.1 API
QueuedEvent..::..EventTypeName Property
QueuedEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string EventTypeName { get; protected set; }
Visual Basic
Public Property EventTypeName As String
    Get
    Protected Set
Visual C++
public:
property String^ EventTypeName {
    String^ get ();
    protected: void set (String^ value);
}

Field Value

The name of the event type.

See Also

QueuedEvent Class
Sitecore.Eventing Namespace


InstanceData Property

[image]

Sitecore 6.4.1 API
QueuedEvent..::..InstanceData Property
QueuedEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string InstanceData { get; protected set; }
Visual Basic
Public Property InstanceData As String
    Get
    Protected Set
Visual C++
public:
property String^ InstanceData {
    String^ get ();
    protected: void set (String^ value);
}

Field Value

The object data.

See Also

QueuedEvent Class
Sitecore.Eventing Namespace


InstanceName Property

[image]

Sitecore 6.4.1 API
QueuedEvent..::..InstanceName Property
QueuedEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string InstanceName { get; protected set; }
Visual Basic
Public Property InstanceName As String
    Get
    Protected Set
Visual C++
public:
property String^ InstanceName {
    String^ get ();
    protected: void set (String^ value);
}

Field Value

The name of the server.

See Also

QueuedEvent Class
Sitecore.Eventing Namespace


InstanceType Property

[image]

Sitecore 6.4.1 API
QueuedEvent..::..InstanceType Property
QueuedEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Type InstanceType { get; }
Visual Basic
Public ReadOnly Property InstanceType As Type
    Get
Visual C++
public:
property Type^ InstanceType {
    Type^ get ();
}

Field Value

The type of the object.

See Also

QueuedEvent Class
Sitecore.Eventing Namespace


InstanceTypeName Property

[image]

Sitecore 6.4.1 API
QueuedEvent..::..InstanceTypeName Property
QueuedEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string InstanceTypeName { get; protected set; }
Visual Basic
Public Property InstanceTypeName As String
    Get
    Protected Set
Visual C++
public:
property String^ InstanceTypeName {
    String^ get ();
    protected: void set (String^ value);
}

Field Value

The name of the instance type.

See Also

QueuedEvent Class
Sitecore.Eventing Namespace


Timestamp Property

[image]

Sitecore 6.4.1 API
QueuedEvent..::..Timestamp Property
QueuedEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long Timestamp { get; protected set; }
Visual Basic
Public Property Timestamp As Long
    Get
    Protected Set
Visual C++
public:
property long long Timestamp {
    long long get ();
    protected: void set (long long value);
}

Field Value

The timestamp.

See Also

QueuedEvent Class
Sitecore.Eventing Namespace


UserName Property

[image]

Sitecore 6.4.1 API
QueuedEvent..::..UserName Property
QueuedEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string UserName { get; protected set; }
Visual Basic
Public Property UserName As String
    Get
    Protected Set
Visual C++
public:
property String^ UserName {
    String^ get ();
    protected: void set (String^ value);
}

Field Value

The name of the user.

See Also

QueuedEvent Class
Sitecore.Eventing Namespace


Subscription(TEvent) Class

[image]

Sitecore 6.4.1 API
Subscription<(Of <(<'TEvent>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Subscription<TEvent> : SubscriptionBase
Visual Basic
Public Class Subscription(Of TEvent) _
    Inherits SubscriptionBase
Visual C++
generic<typename TEvent>
public ref class Subscription : public SubscriptionBase

Type Parameters

TEvent
The type of data passed to event handlers.

Inheritance Hierarchy

System..::..Object
Sitecore.Eventing..::..SubscriptionBase
Sitecore.Eventing..::..Subscription<(Of <(<'TEvent>)>)>

See Also

Subscription<(Of <(<'TEvent>)>)> Members
Sitecore.Eventing Namespace


Subscription(TEvent) Members

[image] [image]

Sitecore 6.4.1 API
Subscription<(Of <(<'TEvent>)>)> Members
Subscription<(Of <(<'TEvent>)>)> Class Constructors Methods Properties See Also Send Feedback

The Subscription<(Of <(<'TEvent>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | Subscription<(Of <(<'TEvent>)>)> | Initializes a new instance of the Subscription<(Of <(<'TEvent>)>)> class. Initializes a new instance of the Subscription<(Of <(<'TEvent>)>)> class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Invokes the specified instance. (Overrides SubscriptionBase..::..Invoke(Object, EventContext).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Filter | Gets or sets the filter.
Public property | Handler | Gets or sets the handler.
Public property | Id | Gets or sets the id. (Overrides SubscriptionBase..::..Id.)

See Also

Subscription<(Of <(<'TEvent>)>)> Class
Sitecore.Eventing Namespace


Subscription(TEvent) Constructor

[image]

Sitecore 6.4.1 API
Subscription<(Of <(<'TEvent>)>)> Constructor
Subscription<(Of <(<'TEvent>)>)> Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Subscription(
    Action<TEvent, EventContext> handler,
    Func<TEvent, EventContext, bool> filter
)
Visual Basic
Public Sub New ( _
    handler As Action(Of TEvent, EventContext), _
    filter As Func(Of TEvent, EventContext, Boolean) _
)
Visual C++
public:
Subscription(
    Action<TEvent, EventContext^>^ handler,
    Func<TEvent, EventContext^, bool>^ filter
)

Parameters

handler
Type: System..::..Action <(Of <(<' TEvent, EventContext >)>)>
The handler.
filter
Type: System..::..Func <(Of <(<' TEvent, EventContext, Boolean >)>)>
The filter.

See Also

Subscription<(Of <(<'TEvent>)>)> Class
Sitecore.Eventing Namespace


Subscription(TEvent) Methods

[image] [image]

Sitecore 6.4.1 API
Subscription<(Of <(<'TEvent>)>)> Methods
Subscription<(Of <(<'TEvent>)>)> Class See Also Send Feedback

The Subscription<(Of <(<'TEvent>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Invokes the specified instance. (Overrides SubscriptionBase..::..Invoke(Object, EventContext).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Subscription<(Of <(<'TEvent>)>)> Class
Sitecore.Eventing Namespace


Invoke Method

[image]

Sitecore 6.4.1 API
Subscription<(Of <(<'TEvent>)>)>..::..Invoke Method
Subscription<(Of <(<'TEvent>)>)> Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Invoke(
    Object instance,
    EventContext context
)
Visual Basic
Public Overrides Sub Invoke ( _
    instance As Object, _
    context As EventContext _
)
Visual C++
public:
virtual void Invoke(
    Object^ instance,
    EventContext^ context
) override

Parameters

instance
Type: System..::..Object
The instance.
context
Type: Sitecore.Eventing..::..EventContext
The context.

See Also

Subscription<(Of <(<'TEvent>)>)> Class
Sitecore.Eventing Namespace


Subscription(TEvent) Properties

[image] [image]

Sitecore 6.4.1 API
Subscription<(Of <(<'TEvent>)>)> Properties
Subscription<(Of <(<'TEvent>)>)> Class See Also Send Feedback

The Subscription<(Of <(<'TEvent>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Filter | Gets or sets the filter.
Public property | Handler | Gets or sets the handler.
Public property | Id | Gets or sets the id. (Overrides SubscriptionBase..::..Id.)

See Also

Subscription<(Of <(<'TEvent>)>)> Class
Sitecore.Eventing Namespace


Filter Property

[image]

Sitecore 6.4.1 API
Subscription<(Of <(<'TEvent>)>)>..::..Filter Property
Subscription<(Of <(<'TEvent>)>)> Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Func<TEvent, EventContext, bool> Filter { get; protected set; }
Visual Basic
Public Property Filter As Func(Of TEvent, EventContext, Boolean)
    Get
    Protected Set
Visual C++
public:
property Func<TEvent, EventContext^, bool>^ Filter {
    Func<TEvent, EventContext^, bool>^ get ();
    protected: void set (Func<TEvent, EventContext^, bool>^ value);
}

Field Value

The filter.

See Also

Subscription<(Of <(<'TEvent>)>)> Class
Sitecore.Eventing Namespace


Handler Property

[image]

Sitecore 6.4.1 API
Subscription<(Of <(<'TEvent>)>)>..::..Handler Property
Subscription<(Of <(<'TEvent>)>)> Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Action<TEvent, EventContext> Handler { get; protected set; }
Visual Basic
Public Property Handler As Action(Of TEvent, EventContext)
    Get
    Protected Set
Visual C++
public:
property Action<TEvent, EventContext^>^ Handler {
    Action<TEvent, EventContext^>^ get ();
    protected: void set (Action<TEvent, EventContext^>^ value);
}

Field Value

The handler.

See Also

Subscription<(Of <(<'TEvent>)>)> Class
Sitecore.Eventing Namespace


Id Property

[image]

Sitecore 6.4.1 API
Subscription<(Of <(<'TEvent>)>)>..::..Id Property
Subscription<(Of <(<'TEvent>)>)> Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override SubscriptionId Id { get; }
Visual Basic
Public Overrides ReadOnly Property Id As SubscriptionId
    Get
Visual C++
public:
virtual property SubscriptionId^ Id {
    SubscriptionId^ get () override;
}

Field Value

The id.

See Also

Subscription<(Of <(<'TEvent>)>)> Class
Sitecore.Eventing Namespace


SubscriptionBase Class

[image]

Sitecore 6.4.1 API
SubscriptionBase Class
Members See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class SubscriptionBase
Visual Basic
Public MustInherit Class SubscriptionBase
Visual C++
public ref class SubscriptionBase abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Eventing..::..SubscriptionBase
Sitecore.Eventing..::..Subscription<(Of <(<'TEvent>)>)>

See Also

SubscriptionBase Members
Sitecore.Eventing Namespace


SubscriptionBase Members

[image] [image]

Sitecore 6.4.1 API
SubscriptionBase Members
SubscriptionBase Class Constructors Methods Properties See Also Send Feedback

The SubscriptionBase type exposes the following members.

Constructors

 | Name | Description
Protected method | SubscriptionBase | Initializes a new instance of the SubscriptionBase class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Invokes the specified instance.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Id | Gets or sets the id.

See Also

SubscriptionBase Class
Sitecore.Eventing Namespace


SubscriptionBase Constructor

[image]

Sitecore 6.4.1 API
SubscriptionBase Constructor
SubscriptionBase Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected SubscriptionBase()
Visual Basic
Protected Sub New
Visual C++
protected:
SubscriptionBase()

See Also

SubscriptionBase Class
Sitecore.Eventing Namespace


SubscriptionBase Methods

[image] [image]

Sitecore 6.4.1 API
SubscriptionBase Methods
SubscriptionBase Class See Also Send Feedback

The SubscriptionBase type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Invokes the specified instance.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubscriptionBase Class
Sitecore.Eventing Namespace


Invoke Method

[image]

Sitecore 6.4.1 API
SubscriptionBase..::..Invoke Method
SubscriptionBase Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract void Invoke(
    Object instance,
    EventContext context
)
Visual Basic
Public MustOverride Sub Invoke ( _
    instance As Object, _
    context As EventContext _
)
Visual C++
public:
virtual void Invoke(
    Object^ instance,
    EventContext^ context
) abstract

Parameters

instance
Type: System..::..Object
The instance.
context
Type: Sitecore.Eventing..::..EventContext
The context.

See Also

SubscriptionBase Class
Sitecore.Eventing Namespace


SubscriptionBase Properties

[image] [image]

Sitecore 6.4.1 API
SubscriptionBase Properties
SubscriptionBase Class See Also Send Feedback

The SubscriptionBase type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets or sets the id.

See Also

SubscriptionBase Class
Sitecore.Eventing Namespace


Id Property

[image]

Sitecore 6.4.1 API
SubscriptionBase..::..Id Property
SubscriptionBase Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract SubscriptionId Id { get; }
Visual Basic
Public MustOverride ReadOnly Property Id As SubscriptionId
    Get
Visual C++
public:
virtual property SubscriptionId^ Id {
    SubscriptionId^ get () abstract;
}

Field Value

The id.

See Also

SubscriptionBase Class
Sitecore.Eventing Namespace


SubscriptionId Class

[image]

Sitecore 6.4.1 API
SubscriptionId Class
Members See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public sealed class SubscriptionId : IComparable,
    IComparable<SubscriptionId>
Visual Basic
Public NotInheritable Class SubscriptionId _
    Implements IComparable, IComparable(Of SubscriptionId)
Visual C++
public ref class SubscriptionId sealed : IComparable,
    IComparable<SubscriptionId^>

Inheritance Hierarchy

System..::..Object
Sitecore.Eventing..::..SubscriptionId

See Also

SubscriptionId Members
Sitecore.Eventing Namespace


SubscriptionId Members

[image] [image]

Sitecore 6.4.1 API
SubscriptionId Members
SubscriptionId Class Constructors Methods Operators Properties See Also Send Feedback

The SubscriptionId type exposes the following members.

Constructors

 | Name | Description
Public method | SubscriptionId | Initializes a new instance of the SubscriptionId class.

Methods

 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public method | CompareTo(SubscriptionId) | Compares the current object with another object of the same type.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewId | News the id.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Operators

Name | Description
Equality | Implements the operator ==.
Inequality | Implements the operator !=.

Properties

 | Name | Description
Public property | Guid | Gets or sets the GUID.
Public property | Type | Gets the type of the subscription.

See Also

SubscriptionId Class
Sitecore.Eventing Namespace


SubscriptionId Constructor

[image]

Sitecore 6.4.1 API
SubscriptionId Constructor
SubscriptionId Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SubscriptionId(
    Guid guid,
    Type type
)
Visual Basic
Public Sub New ( _
    guid As Guid, _
    type As Type _
)
Visual C++
public:
SubscriptionId(
    Guid guid,
    Type^ type
)

Parameters

guid
Type: System..::..Guid
The GUID.
type
Type: System..::..Type
The type.

See Also

SubscriptionId Class
Sitecore.Eventing Namespace


SubscriptionId Methods

[image] [image]

Sitecore 6.4.1 API
SubscriptionId Methods
SubscriptionId Class See Also Send Feedback

The SubscriptionId type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public method | CompareTo(SubscriptionId) | Compares the current object with another object of the same type.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewId | News the id.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

SubscriptionId Class
Sitecore.Eventing Namespace


CompareTo Method

[image] [image]

Sitecore 6.4.1 API
SubscriptionId..::..CompareTo Method
SubscriptionId Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public method | CompareTo(SubscriptionId) | Compares the current object with another object of the same type.

See Also

SubscriptionId Class
SubscriptionId Members
Sitecore.Eventing Namespace


CompareTo Method (Object)

[image]

Sitecore 6.4.1 API
SubscriptionId..::..CompareTo Method (Object)
SubscriptionId Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic
Public Function CompareTo ( _
    obj As Object _
) As Integer
Visual C++
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: System..::..Object
An object to compare with this instance.

Return Value

A 32-bit signed integer that indicates the relative order of the objects being compared. The return value has these meanings: Value Meaning Less than zero This instance is less than obj. Zero This instance is equal to obj. Greater than zero This instance is greater than obj.

Implements

IComparable..::..CompareTo(Object)

Exceptions

Exception | Condition
System..::..ArgumentException | obj is not the same type as this instance.

See Also

SubscriptionId Class
CompareTo Overload
Sitecore.Eventing Namespace


Equals Method

[image]

Sitecore 6.4.1 API
SubscriptionId..::..Equals Method
SubscriptionId Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Exceptions

Exception | Condition
System..::..NullReferenceException | The obj parameter is null.

See Also

SubscriptionId Class
Sitecore.Eventing Namespace


GetHashCode Method

[image]

Sitecore 6.4.1 API
SubscriptionId..::..GetHashCode Method
SubscriptionId Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A hash code for the current Object.

See Also

SubscriptionId Class
Sitecore.Eventing Namespace


NewId Method

[image]

Sitecore 6.4.1 API
SubscriptionId..::..NewId Method
SubscriptionId Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static SubscriptionId NewId(
    Type type
)
Visual Basic
Public Shared Function NewId ( _
    type As Type _
) As SubscriptionId
Visual C++
public:
static SubscriptionId^ NewId(
    Type^ type
)

Parameters

type
Type: System..::..Type

[Missing <param name="type"/> documentation for "M:Sitecore.Eventing.SubscriptionId.NewId(System.Type)"]

Return Value

The new id.

See Also

SubscriptionId Class
Sitecore.Eventing Namespace


ToString Method

[image]

Sitecore 6.4.1 API
SubscriptionId..::..ToString Method
SubscriptionId Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

SubscriptionId Class
Sitecore.Eventing Namespace


SubscriptionId Operators

[image] [image]

Sitecore 6.4.1 API
SubscriptionId Operators
SubscriptionId Class See Also Send Feedback

The SubscriptionId type exposes the following members.

Operators

Name | Description
Equality | Implements the operator ==.
Inequality | Implements the operator !=.

See Also

SubscriptionId Class
Sitecore.Eventing Namespace


Equality Operator

[image]

Sitecore 6.4.1 API
SubscriptionId..::..Equality Operator
SubscriptionId Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool operator ==(
    SubscriptionId id0,
    SubscriptionId id1
)
Visual Basic
Public Shared Operator = ( _
    id0 As SubscriptionId, _
    id1 As SubscriptionId _
) As Boolean
Visual C++
public:
static bool operator ==(
    SubscriptionId^ id0,
    SubscriptionId^ id1
)

Parameters

id0
Type: Sitecore.Eventing..::..SubscriptionId
The id0.
id1
Type: Sitecore.Eventing..::..SubscriptionId
The id1.

Return Value

The result of the operator.

See Also

SubscriptionId Class
Sitecore.Eventing Namespace


Inequality Operator

[image]

Sitecore 6.4.1 API
SubscriptionId..::..Inequality Operator
SubscriptionId Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool operator !=(
    SubscriptionId id0,
    SubscriptionId id1
)
Visual Basic
Public Shared Operator <> ( _
    id0 As SubscriptionId, _
    id1 As SubscriptionId _
) As Boolean
Visual C++
public:
static bool operator !=(
    SubscriptionId^ id0,
    SubscriptionId^ id1
)

Parameters

id0
Type: Sitecore.Eventing..::..SubscriptionId
The id0.
id1
Type: Sitecore.Eventing..::..SubscriptionId
The id1.

Return Value

The result of the operator.

See Also

SubscriptionId Class
Sitecore.Eventing Namespace


SubscriptionId Properties

[image] [image]

Sitecore 6.4.1 API
SubscriptionId Properties
SubscriptionId Class See Also Send Feedback

The SubscriptionId type exposes the following members.

Properties

 | Name | Description
Public property | Guid | Gets or sets the GUID.
Public property | Type | Gets the type of the subscription.

See Also

SubscriptionId Class
Sitecore.Eventing Namespace


Guid Property

[image]

Sitecore 6.4.1 API
SubscriptionId..::..Guid Property
SubscriptionId Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Guid Guid { get; private set; }
Visual Basic
Public Property Guid As Guid
    Get
    Private Set
Visual C++
public:
property Guid Guid {
    Guid get ();
    private: void set (Guid value);
}

Field Value

The GUID value.

See Also

SubscriptionId Class
Sitecore.Eventing Namespace


Type Property

[image]

Sitecore 6.4.1 API
SubscriptionId..::..Type Property
SubscriptionId Class See Also Send Feedback

Namespace: Sitecore.Eventing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Type Type { get; private set; }
Visual Basic
Public Property Type As Type
    Get
    Private Set
Visual C++
public:
property Type^ Type {
    Type^ get ();
    private: void set (Type^ value);
}

Field Value

The type.

See Also

SubscriptionId Class
Sitecore.Eventing Namespace


ForwardSecurityEvents Class

[image]

Sitecore 6.4.1 API
ForwardSecurityEvents Class
Members See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ForwardSecurityEvents
Visual Basic
Public Class ForwardSecurityEvents
Visual C++
public ref class ForwardSecurityEvents

Inheritance Hierarchy

System..::..Object
Sitecore.Eventing.Remote..::..ForwardSecurityEvents

See Also

ForwardSecurityEvents Members
Sitecore.Eventing.Remote Namespace


ForwardSecurityEvents Members

[image] [image]

Sitecore 6.4.1 API
ForwardSecurityEvents Members
ForwardSecurityEvents Class Constructors Methods Properties See Also Send Feedback

The ForwardSecurityEvents type exposes the following members.

Constructors

 | Name | Description
Public method | ForwardSecurityEvents | Initializes a new instance of the ForwardSecurityEvents class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Implements the pipeline processor interface. This is an entry point to the class.
Protected method | QueueEvent<(Of <<'(T>)>>) | Queues the event.
Protected method | QueueRoleCreated | Queues the RoleCreatedRemoteEvent. Applies the filters.
Protected method | QueueRoleDeleted | Queues the RoleDeletedRemoteEvent. Applies the filters.
Protected method | QueueRoleRelationsRemoved | Queues the RoleRelationsRemovedRemoteEvent. Applies the filters.
Protected method | QueueRolesAddedToRoles | Queues the RolesAddedToRolesRemoteEvent. Applies the filters.
Protected method | QueueRolesRemovedFromRoles | Queues the RolesRemovedFromRolesRemoteEvent. Applies the filters.
Protected method | QueueUserCreated | Queues the UserCreatedRemoteEvent. Applies the filters.
Protected method | QueueUserDeleted | Queues the UserDeletedRemoteEvent. Applies the filters.
Protected method | QueueUsersAddedToRoles | Queues the UsersAddedToRolesRemoteEvent. Applies the filters.
Protected method | QueueUsersRemovedFromRoles | Queues the UsersRemovedFromRolesRemoteEvent. Applies the filters.
Protected method | QueueUserUpdated | Queues the UserUpdatedRemoteEvent. Applies the filters.
Protected method | RoleMatches | Checks if the role matches the Domains.
Protected method | RolesMatch(IEnumerable<(Of <<'(String>)>>)) | Checks if the roles match the Domains.
Protected method | RolesMatch(IEnumerable<(Of <<'(Role>)>>)) | Checks if the roles match the Domains.
Protected method | SubscribeToLocalEvents | Subscribes to local events.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | UserMatches(String) | Checks if the user matches the Domains.
Protected method | UserMatches(MembershipUser) | Checks if the user matches the Domains.
Protected method | UsersMatch | Checks if the users match the Domains.

Properties

 | Name | Description
Public property | Domains | Gets the names of the Sitecore security domains used on the website. Only events for these domains will be forwarded through this bridge.
Public property | Targets | Gets the list of the databases to which security events should be forwarded.

See Also

ForwardSecurityEvents Class
Sitecore.Eventing.Remote Namespace


ForwardSecurityEvents Constructor

[image]

Sitecore 6.4.1 API
ForwardSecurityEvents Constructor
ForwardSecurityEvents Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ForwardSecurityEvents()
Visual Basic
Public Sub New
Visual C++
public:
ForwardSecurityEvents()

See Also

ForwardSecurityEvents Class
Sitecore.Eventing.Remote Namespace


ForwardSecurityEvents Methods

[image] [image]

Sitecore 6.4.1 API
ForwardSecurityEvents Methods
ForwardSecurityEvents Class See Also Send Feedback

The ForwardSecurityEvents type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Implements the pipeline processor interface. This is an entry point to the class.
Protected method | QueueEvent<(Of <<'(T>)>>) | Queues the event.
Protected method | QueueRoleCreated | Queues the RoleCreatedRemoteEvent. Applies the filters.
Protected method | QueueRoleDeleted | Queues the RoleDeletedRemoteEvent. Applies the filters.
Protected method | QueueRoleRelationsRemoved | Queues the RoleRelationsRemovedRemoteEvent. Applies the filters.
Protected method | QueueRolesAddedToRoles | Queues the RolesAddedToRolesRemoteEvent. Applies the filters.
Protected method | QueueRolesRemovedFromRoles | Queues the RolesRemovedFromRolesRemoteEvent. Applies the filters.
Protected method | QueueUserCreated | Queues the UserCreatedRemoteEvent. Applies the filters.
Protected method | QueueUserDeleted | Queues the UserDeletedRemoteEvent. Applies the filters.
Protected method | QueueUsersAddedToRoles | Queues the UsersAddedToRolesRemoteEvent. Applies the filters.
Protected method | QueueUsersRemovedFromRoles | Queues the UsersRemovedFromRolesRemoteEvent. Applies the filters.
Protected method | QueueUserUpdated | Queues the UserUpdatedRemoteEvent. Applies the filters.
Protected method | RoleMatches | Checks if the role matches the Domains.
Protected method | RolesMatch(IEnumerable<(Of <<'(String>)>>)) | Checks if the roles match the Domains.
Protected method | RolesMatch(IEnumerable<(Of <<'(Role>)>>)) | Checks if the roles match the Domains.
Protected method | SubscribeToLocalEvents | Subscribes to local events.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | UserMatches(String) | Checks if the user matches the Domains.
Protected method | UserMatches(MembershipUser) | Checks if the user matches the Domains.
Protected method | UsersMatch | Checks if the users match the Domains.

See Also

ForwardSecurityEvents Class
Sitecore.Eventing.Remote Namespace


Process Method

[image]

Sitecore 6.4.1 API
ForwardSecurityEvents..::..Process Method
ForwardSecurityEvents Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    PipelineArgs pipelineArgs
)
Visual Basic
Public Sub Process ( _
    pipelineArgs As PipelineArgs _
)
Visual C++
public:
void Process(
    PipelineArgs^ pipelineArgs
)

Parameters

pipelineArgs
Type: Sitecore.Pipelines..::..PipelineArgs
The pipeline args.

See Also

ForwardSecurityEvents Class
Sitecore.Eventing.Remote Namespace


QueueEvent(T) Method

[image]

Sitecore 6.4.1 API
ForwardSecurityEvents..::..QueueEvent<(Of <(<'T>)>)> Method
ForwardSecurityEvents Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void QueueEvent<T>(
    T event
)
Visual Basic
Protected Sub QueueEvent(Of T) ( _
    event As T _
)
Visual C++
protected:
generic<typename T>
void QueueEvent(
    T event
)

Parameters

event
Type: T
The event instance.

Type Parameters

T
Type of the event.

See Also

ForwardSecurityEvents Class
Sitecore.Eventing.Remote Namespace


QueueRoleCreated Method

[image]

Sitecore 6.4.1 API
ForwardSecurityEvents..::..QueueRoleCreated Method
ForwardSecurityEvents Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void QueueRoleCreated(
    string name
)
Visual Basic
Protected Sub QueueRoleCreated ( _
    name As String _
)
Visual C++
protected:
void QueueRoleCreated(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

See Also

ForwardSecurityEvents Class
Sitecore.Eventing.Remote Namespace


QueueRoleDeleted Method

[image]

Sitecore 6.4.1 API
ForwardSecurityEvents..::..QueueRoleDeleted Method
ForwardSecurityEvents Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void QueueRoleDeleted(
    string name
)
Visual Basic
Protected Sub QueueRoleDeleted ( _
    name As String _
)
Visual C++
protected:
void QueueRoleDeleted(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

See Also

ForwardSecurityEvents Class
Sitecore.Eventing.Remote Namespace


QueueRolesAddedToRoles Method

[image]

Sitecore 6.4.1 API
ForwardSecurityEvents..::..QueueRolesAddedToRoles Method
ForwardSecurityEvents Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void QueueRolesAddedToRoles(
    IEnumerable<Role> members,
    IEnumerable<Role> targets
)
Visual Basic
Protected Sub QueueRolesAddedToRoles ( _
    members As IEnumerable(Of Role), _
    targets As IEnumerable(Of Role) _
)
Visual C++
protected:
void QueueRolesAddedToRoles(
    IEnumerable<Role^>^ members,
    IEnumerable<Role^>^ targets
)

Parameters

members
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Role >)>)>
The members.
targets
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Role >)>)>
The targets.

See Also

ForwardSecurityEvents Class
Sitecore.Eventing.Remote Namespace


QueueRolesRemovedFromRoles Method

[image]

Sitecore 6.4.1 API
ForwardSecurityEvents..::..QueueRolesRemovedFromRoles Method
ForwardSecurityEvents Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void QueueRolesRemovedFromRoles(
    IEnumerable<Role> members,
    IEnumerable<Role> targets
)
Visual Basic
Protected Sub QueueRolesRemovedFromRoles ( _
    members As IEnumerable(Of Role), _
    targets As IEnumerable(Of Role) _
)
Visual C++
protected:
void QueueRolesRemovedFromRoles(
    IEnumerable<Role^>^ members,
    IEnumerable<Role^>^ targets
)

Parameters

members
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Role >)>)>
The members.
targets
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Role >)>)>
The targets.

See Also

ForwardSecurityEvents Class
Sitecore.Eventing.Remote Namespace


QueueUserCreated Method

[image]

Sitecore 6.4.1 API
ForwardSecurityEvents..::..QueueUserCreated Method
ForwardSecurityEvents Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void QueueUserCreated(
    MembershipUser user
)
Visual Basic
Protected Sub QueueUserCreated ( _
    user As MembershipUser _
)
Visual C++
protected:
void QueueUserCreated(
    MembershipUser^ user
)

Parameters

user
Type: System.Web.Security..::..MembershipUser
The MembershipUser object representing the user.

See Also

ForwardSecurityEvents Class
Sitecore.Eventing.Remote Namespace


QueueUserDeleted Method

[image]

Sitecore 6.4.1 API
ForwardSecurityEvents..::..QueueUserDeleted Method
ForwardSecurityEvents Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void QueueUserDeleted(
    string name
)
Visual Basic
Protected Sub QueueUserDeleted ( _
    name As String _
)
Visual C++
protected:
void QueueUserDeleted(
    String^ name
)

Parameters

name
Type: System..::..String
The name of the user.

See Also

ForwardSecurityEvents Class
Sitecore.Eventing.Remote Namespace


QueueUsersAddedToRoles Method

[image]

Sitecore 6.4.1 API
ForwardSecurityEvents..::..QueueUsersAddedToRoles Method
ForwardSecurityEvents Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void QueueUsersAddedToRoles(
    string[] users,
    string[] roles
)
Visual Basic
Protected Sub QueueUsersAddedToRoles ( _
    users As String(), _
    roles As String() _
)
Visual C++
protected:
void QueueUsersAddedToRoles(
    array<String^>^ users,
    array<String^>^ roles
)

Parameters

users
Type: array< System..::..String >[]()[][]
The users.
roles
Type: array< System..::..String >[]()[][]
The roles.

See Also

ForwardSecurityEvents Class
Sitecore.Eventing.Remote Namespace


QueueUsersRemovedFromRoles Method

[image]

Sitecore 6.4.1 API
ForwardSecurityEvents..::..QueueUsersRemovedFromRoles Method
ForwardSecurityEvents Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void QueueUsersRemovedFromRoles(
    string[] users,
    string[] roles
)
Visual Basic
Protected Sub QueueUsersRemovedFromRoles ( _
    users As String(), _
    roles As String() _
)
Visual C++
protected:
void QueueUsersRemovedFromRoles(
    array<String^>^ users,
    array<String^>^ roles
)

Parameters

users
Type: array< System..::..String >[]()[][]
The collection of user names.
roles
Type: array< System..::..String >[]()[][]
The collection of role names.

See Also

ForwardSecurityEvents Class
Sitecore.Eventing.Remote Namespace


QueueUserUpdated Method

[image]

Sitecore 6.4.1 API
ForwardSecurityEvents..::..QueueUserUpdated Method
ForwardSecurityEvents Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void QueueUserUpdated(
    MembershipUser user
)
Visual Basic
Protected Sub QueueUserUpdated ( _
    user As MembershipUser _
)
Visual C++
protected:
void QueueUserUpdated(
    MembershipUser^ user
)

Parameters

user
Type: System.Web.Security..::..MembershipUser
The MembershipUser representing the user.

See Also

ForwardSecurityEvents Class
Sitecore.Eventing.Remote Namespace


RolesMatch Method

[image] [image]

Sitecore 6.4.1 API
ForwardSecurityEvents..::..RolesMatch Method
ForwardSecurityEvents Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RolesMatch(IEnumerable<(Of <<'(String>)>>)) | Checks if the roles match the Domains.
Protected method | RolesMatch(IEnumerable<(Of <<'(Role>)>>)) | Checks if the roles match the Domains.

See Also

ForwardSecurityEvents Class
ForwardSecurityEvents Members
Sitecore.Eventing.Remote Namespace


RolesMatch Method (IEnumerable(String))

[image]

Sitecore 6.4.1 API
ForwardSecurityEvents..::..RolesMatch Method (IEnumerable<(Of <(<'String>)>)>)
ForwardSecurityEvents Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool RolesMatch(
    IEnumerable<string> roles
)
Visual Basic
Protected Overridable Function RolesMatch ( _
    roles As IEnumerable(Of String) _
) As Boolean
Visual C++
protected:
virtual bool RolesMatch(
    IEnumerable<String^>^ roles
)

Parameters

roles
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' String >)>)>
The collection of role names.

Return Value

true is any of the roles belongs to any of the domains in the Domains list, false otherwise.

See Also

ForwardSecurityEvents Class
RolesMatch Overload
Sitecore.Eventing.Remote Namespace


RolesMatch Method (IEnumerable(Role))

[image]

Sitecore 6.4.1 API
ForwardSecurityEvents..::..RolesMatch Method (IEnumerable<(Of <(<'Role>)>)>)
ForwardSecurityEvents Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool RolesMatch(
    IEnumerable<Role> roles
)
Visual Basic
Protected Overridable Function RolesMatch ( _
    roles As IEnumerable(Of Role) _
) As Boolean
Visual C++
protected:
virtual bool RolesMatch(
    IEnumerable<Role^>^ roles
)

Parameters

roles
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Role >)>)>
The collection of Role objects.

Return Value

true is any of the roles belongs to any of the domains in the Domains list, false otherwise.

See Also

ForwardSecurityEvents Class
RolesMatch Overload
Sitecore.Eventing.Remote Namespace


SubscribeToLocalEvents Method

[image]

Sitecore 6.4.1 API
ForwardSecurityEvents..::..SubscribeToLocalEvents Method
ForwardSecurityEvents Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void SubscribeToLocalEvents()
Visual Basic
Protected Overridable Sub SubscribeToLocalEvents
Visual C++
protected:
virtual void SubscribeToLocalEvents()

See Also

ForwardSecurityEvents Class
Sitecore.Eventing.Remote Namespace


UserMatches Method

[image] [image]

Sitecore 6.4.1 API
ForwardSecurityEvents..::..UserMatches Method
ForwardSecurityEvents Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UserMatches(String) | Checks if the user matches the Domains.
Protected method | UserMatches(MembershipUser) | Checks if the user matches the Domains.

See Also

ForwardSecurityEvents Class
ForwardSecurityEvents Members
Sitecore.Eventing.Remote Namespace


UserMatches Method (MembershipUser)

[image]

Sitecore 6.4.1 API
ForwardSecurityEvents..::..UserMatches Method (MembershipUser)
ForwardSecurityEvents Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool UserMatches(
    MembershipUser user
)
Visual Basic
Protected Overridable Function UserMatches ( _
    user As MembershipUser _
) As Boolean
Visual C++
protected:
virtual bool UserMatches(
    MembershipUser^ user
)

Parameters

user
Type: System.Web.Security..::..MembershipUser
The MembershipUser object representing the user to check.

Return Value

true is the user belongs to any of the domains in the Domains list, false otherwise.

See Also

ForwardSecurityEvents Class
UserMatches Overload
Sitecore.Eventing.Remote Namespace


UsersMatch Method

[image]

Sitecore 6.4.1 API
ForwardSecurityEvents..::..UsersMatch Method
ForwardSecurityEvents Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool UsersMatch(
    IEnumerable<string> users
)
Visual Basic
Protected Overridable Function UsersMatch ( _
    users As IEnumerable(Of String) _
) As Boolean
Visual C++
protected:
virtual bool UsersMatch(
    IEnumerable<String^>^ users
)

Parameters

users
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' String >)>)>
The collection of user names.

Return Value

true is any of the users belongs to any of the domains in the Domains list, false otherwise.

See Also

ForwardSecurityEvents Class
Sitecore.Eventing.Remote Namespace


ForwardSecurityEvents Properties

[image] [image]

Sitecore 6.4.1 API
ForwardSecurityEvents Properties
ForwardSecurityEvents Class See Also Send Feedback

The ForwardSecurityEvents type exposes the following members.

Properties

 | Name | Description
Public property | Domains | Gets the names of the Sitecore security domains used on the website. Only events for these domains will be forwarded through this bridge.
Public property | Targets | Gets the list of the databases to which security events should be forwarded.

See Also

ForwardSecurityEvents Class
Sitecore.Eventing.Remote Namespace


Domains Property

[image]

Sitecore 6.4.1 API
ForwardSecurityEvents..::..Domains Property
ForwardSecurityEvents Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public List<string> Domains { get; }
Visual Basic
Public ReadOnly Property Domains As List(Of String)
    Get
Visual C++
public:
property List<String^>^ Domains {
    List<String^>^ get ();
}

Field Value

The list of names of the Sitecore security domains used on the website.

See Also

ForwardSecurityEvents Class
Sitecore.Eventing.Remote Namespace


Targets Property

[image]

Sitecore 6.4.1 API
ForwardSecurityEvents..::..Targets Property
ForwardSecurityEvents Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public List<string> Targets { get; }
Visual Basic
Public ReadOnly Property Targets As List(Of String)
    Get
Visual C++
public:
property List<String^>^ Targets {
    List<String^>^ get ();
}

Field Value

The list of CD clusters' system databases.

See Also

ForwardSecurityEvents Class
Sitecore.Eventing.Remote Namespace


PublishEndRemoteEvent Class

[image]

Sitecore 6.4.1 API
PublishEndRemoteEvent Class
Members See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PublishEndRemoteEvent
Visual Basic
Public Class PublishEndRemoteEvent
Visual C++
public ref class PublishEndRemoteEvent

Inheritance Hierarchy

System..::..Object
Sitecore.Eventing.Remote..::..PublishEndRemoteEvent

See Also

PublishEndRemoteEvent Members
Sitecore.Eventing.Remote Namespace


PublishEndRemoteEvent Members

[image] [image]

Sitecore 6.4.1 API
PublishEndRemoteEvent Members
PublishEndRemoteEvent Class Constructors Methods Properties See Also Send Feedback

The PublishEndRemoteEvent type exposes the following members.

Constructors

 | Name | Description
Public method | PublishEndRemoteEvent | Initializes a new instance of the PublishEndRemoteEvent class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CompareRevisions | Gets or sets a value indicating whether to compare revisions.
Public property | Deep | Gets or sets a value indicating whether this PublishEndRemoteEvent is deep.
Public property | FromDate | Gets or sets from date.
Public property | LanguageName | Gets or sets the name of the language.
Public property | Mode | Gets or sets the mode.
Public property | PublishDate | Gets or sets the publish date.
Public property | PublishingTargets | Gets or sets the publishing targets.
Public property | RepublishAll | Gets or sets a value indicating whether [republish all].
Public property | RootItemId | Gets or sets the root item id.
Public property | SourceDatabaseName | Gets or sets the name of the source database.
Public property | TargetDatabaseName | Gets or sets the name of the target database.

See Also

PublishEndRemoteEvent Class
Sitecore.Eventing.Remote Namespace


PublishEndRemoteEvent Constructor

[image]

Sitecore 6.4.1 API
PublishEndRemoteEvent Constructor
PublishEndRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PublishEndRemoteEvent(
    Publisher publisher
)
Visual Basic
Public Sub New ( _
    publisher As Publisher _
)
Visual C++
public:
PublishEndRemoteEvent(
    Publisher^ publisher
)

Parameters

publisher
Type: Sitecore.Publishing..::..Publisher
The publisher.

See Also

PublishEndRemoteEvent Class
Sitecore.Eventing.Remote Namespace


PublishEndRemoteEvent Methods

[image] [image]

Sitecore 6.4.1 API
PublishEndRemoteEvent Methods
PublishEndRemoteEvent Class See Also Send Feedback

The PublishEndRemoteEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PublishEndRemoteEvent Class
Sitecore.Eventing.Remote Namespace


PublishEndRemoteEvent Properties

[image] [image]

Sitecore 6.4.1 API
PublishEndRemoteEvent Properties
PublishEndRemoteEvent Class See Also Send Feedback

The PublishEndRemoteEvent type exposes the following members.

Properties

 | Name | Description
Public property | CompareRevisions | Gets or sets a value indicating whether to compare revisions.
Public property | Deep | Gets or sets a value indicating whether this PublishEndRemoteEvent is deep.
Public property | FromDate | Gets or sets from date.
Public property | LanguageName | Gets or sets the name of the language.
Public property | Mode | Gets or sets the mode.
Public property | PublishDate | Gets or sets the publish date.
Public property | PublishingTargets | Gets or sets the publishing targets.
Public property | RepublishAll | Gets or sets a value indicating whether [republish all].
Public property | RootItemId | Gets or sets the root item id.
Public property | SourceDatabaseName | Gets or sets the name of the source database.
Public property | TargetDatabaseName | Gets or sets the name of the target database.

See Also

PublishEndRemoteEvent Class
Sitecore.Eventing.Remote Namespace


CompareRevisions Property

[image]

Sitecore 6.4.1 API
PublishEndRemoteEvent..::..CompareRevisions Property
PublishEndRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool CompareRevisions { get; protected set; }
Visual Basic
Public Property CompareRevisions As Boolean
    Get
    Protected Set
Visual C++
public:
property bool CompareRevisions {
    bool get ();
    protected: void set (bool value);
}

Field Value

true if compare revisions; otherwise, false.

See Also

PublishEndRemoteEvent Class
Sitecore.Eventing.Remote Namespace


FromDate Property

[image]

Sitecore 6.4.1 API
PublishEndRemoteEvent..::..FromDate Property
PublishEndRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime FromDate { get; protected set; }
Visual Basic
Public Property FromDate As DateTime
    Get
    Protected Set
Visual C++
public:
property DateTime FromDate {
    DateTime get ();
    protected: void set (DateTime value);
}

Field Value

From date.

See Also

PublishEndRemoteEvent Class
Sitecore.Eventing.Remote Namespace


LanguageName Property

[image]

Sitecore 6.4.1 API
PublishEndRemoteEvent..::..LanguageName Property
PublishEndRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string LanguageName { get; protected set; }
Visual Basic
Public Property LanguageName As String
    Get
    Protected Set
Visual C++
public:
property String^ LanguageName {
    String^ get ();
    protected: void set (String^ value);
}

Field Value

The name of the language.

See Also

PublishEndRemoteEvent Class
Sitecore.Eventing.Remote Namespace


Mode Property

[image]

Sitecore 6.4.1 API
PublishEndRemoteEvent..::..Mode Property
PublishEndRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PublishMode Mode { get; protected set; }
Visual Basic
Public Property Mode As PublishMode
    Get
    Protected Set
Visual C++
public:
property PublishMode Mode {
    PublishMode get ();
    protected: void set (PublishMode value);
}

Field Value

The mode.

See Also

PublishEndRemoteEvent Class
Sitecore.Eventing.Remote Namespace


PublishDate Property

[image]

Sitecore 6.4.1 API
PublishEndRemoteEvent..::..PublishDate Property
PublishEndRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime PublishDate { get; protected set; }
Visual Basic
Public Property PublishDate As DateTime
    Get
    Protected Set
Visual C++
public:
property DateTime PublishDate {
    DateTime get ();
    protected: void set (DateTime value);
}

Field Value

The publish date.

See Also

PublishEndRemoteEvent Class
Sitecore.Eventing.Remote Namespace


PublishingTargets Property

[image]

Sitecore 6.4.1 API
PublishEndRemoteEvent..::..PublishingTargets Property
PublishEndRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public List<string> PublishingTargets { get; protected set; }
Visual Basic
Public Property PublishingTargets As List(Of String)
    Get
    Protected Set
Visual C++
public:
property List<String^>^ PublishingTargets {
    List<String^>^ get ();
    protected: void set (List<String^>^ value);
}

Field Value

The publishing targets.

See Also

PublishEndRemoteEvent Class
Sitecore.Eventing.Remote Namespace


RepublishAll Property

[image]

Sitecore 6.4.1 API
PublishEndRemoteEvent..::..RepublishAll Property
PublishEndRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool RepublishAll { get; protected set; }
Visual Basic
Public Property RepublishAll As Boolean
    Get
    Protected Set
Visual C++
public:
property bool RepublishAll {
    bool get ();
    protected: void set (bool value);
}

Field Value

true if [republish all]; otherwise, false.

See Also

PublishEndRemoteEvent Class
Sitecore.Eventing.Remote Namespace


RootItemId Property

[image]

Sitecore 6.4.1 API
PublishEndRemoteEvent..::..RootItemId Property
PublishEndRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Guid RootItemId { get; protected set; }
Visual Basic
Public Property RootItemId As Guid
    Get
    Protected Set
Visual C++
public:
property Guid RootItemId {
    Guid get ();
    protected: void set (Guid value);
}

Field Value

The root item id.

See Also

PublishEndRemoteEvent Class
Sitecore.Eventing.Remote Namespace


SourceDatabaseName Property

[image]

Sitecore 6.4.1 API
PublishEndRemoteEvent..::..SourceDatabaseName Property
PublishEndRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string SourceDatabaseName { get; protected set; }
Visual Basic
Public Property SourceDatabaseName As String
    Get
    Protected Set
Visual C++
public:
property String^ SourceDatabaseName {
    String^ get ();
    protected: void set (String^ value);
}

Field Value

The name of the source database.

See Also

PublishEndRemoteEvent Class
Sitecore.Eventing.Remote Namespace


TargetDatabaseName Property

[image]

Sitecore 6.4.1 API
PublishEndRemoteEvent..::..TargetDatabaseName Property
PublishEndRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string TargetDatabaseName { get; protected set; }
Visual Basic
Public Property TargetDatabaseName As String
    Get
    Protected Set
Visual C++
public:
property String^ TargetDatabaseName {
    String^ get ();
    protected: void set (String^ value);
}

Field Value

The name of the target database.

See Also

PublishEndRemoteEvent Class
Sitecore.Eventing.Remote Namespace


RemoteEventMap Class

[image]

Sitecore 6.4.1 API
RemoteEventMap Class
Members See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RemoteEventMap
Visual Basic
Public Class RemoteEventMap
Visual C++
public ref class RemoteEventMap

Inheritance Hierarchy

System..::..Object
Sitecore.Eventing.Remote..::..RemoteEventMap

See Also

RemoteEventMap Members
Sitecore.Eventing.Remote Namespace


RemoteEventMap Members

[image] [image]

Sitecore 6.4.1 API
RemoteEventMap Members
RemoteEventMap Class Constructors Methods See Also Send Feedback

The RemoteEventMap type exposes the following members.

Constructors

 | Name | Description
Public method | RemoteEventMap | Initializes a new instance of the RemoteEventMap class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize | Initializes this instance.
Public method | InitializeFromPipeline | Initializes from pipeline.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RemoteEventMap Class
Sitecore.Eventing.Remote Namespace


RemoteEventMap Constructor

[image]

Sitecore 6.4.1 API
RemoteEventMap Constructor
RemoteEventMap Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RemoteEventMap()
Visual Basic
Public Sub New
Visual C++
public:
RemoteEventMap()

See Also

RemoteEventMap Class
Sitecore.Eventing.Remote Namespace


RemoteEventMap Methods

[image] [image]

Sitecore 6.4.1 API
RemoteEventMap Methods
RemoteEventMap Class See Also Send Feedback

The RemoteEventMap type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize | Initializes this instance.
Public method | InitializeFromPipeline | Initializes from pipeline.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RemoteEventMap Class
Sitecore.Eventing.Remote Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
RemoteEventMap..::..Initialize Method
RemoteEventMap Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Initialize()
Visual Basic
Public Shared Sub Initialize
Visual C++
public:
static void Initialize()

See Also

RemoteEventMap Class
Sitecore.Eventing.Remote Namespace


InitializeFromPipeline Method

[image]

Sitecore 6.4.1 API
RemoteEventMap..::..InitializeFromPipeline Method
RemoteEventMap Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void InitializeFromPipeline(
    PipelineArgs args
)
Visual Basic
Public Sub InitializeFromPipeline ( _
    args As PipelineArgs _
)
Visual C++
public:
void InitializeFromPipeline(
    PipelineArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines..::..PipelineArgs
The pipeline args.

See Also

RemoteEventMap Class
Sitecore.Eventing.Remote Namespace


RoleCreatedRemoteEvent Class

[image]

Sitecore 6.4.1 API
RoleCreatedRemoteEvent Class
Members See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RoleCreatedRemoteEvent
Visual Basic
Public Class RoleCreatedRemoteEvent
Visual C++
public ref class RoleCreatedRemoteEvent

Inheritance Hierarchy

System..::..Object
Sitecore.Eventing.Remote..::..RoleCreatedRemoteEvent

See Also

RoleCreatedRemoteEvent Members
Sitecore.Eventing.Remote Namespace


RoleCreatedRemoteEvent Members

[image] [image]

Sitecore 6.4.1 API
RoleCreatedRemoteEvent Members
RoleCreatedRemoteEvent Class Constructors Methods Properties See Also Send Feedback

The RoleCreatedRemoteEvent type exposes the following members.

Constructors

 | Name | Description
Public method | RoleCreatedRemoteEvent | Initializes a new instance of the RoleCreatedRemoteEvent class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | RoleName | Gets or sets RoleName.

See Also

RoleCreatedRemoteEvent Class
Sitecore.Eventing.Remote Namespace


RoleCreatedRemoteEvent Constructor

[image]

Sitecore 6.4.1 API
RoleCreatedRemoteEvent Constructor
RoleCreatedRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RoleCreatedRemoteEvent(
    string roleName
)
Visual Basic
Public Sub New ( _
    roleName As String _
)
Visual C++
public:
RoleCreatedRemoteEvent(
    String^ roleName
)

Parameters

roleName
Type: System..::..String
Name of the role.

See Also

RoleCreatedRemoteEvent Class
Sitecore.Eventing.Remote Namespace


RoleCreatedRemoteEvent Methods

[image] [image]

Sitecore 6.4.1 API
RoleCreatedRemoteEvent Methods
RoleCreatedRemoteEvent Class See Also Send Feedback

The RoleCreatedRemoteEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoleCreatedRemoteEvent Class
Sitecore.Eventing.Remote Namespace


RoleCreatedRemoteEvent Properties

[image] [image]

Sitecore 6.4.1 API
RoleCreatedRemoteEvent Properties
RoleCreatedRemoteEvent Class See Also Send Feedback

The RoleCreatedRemoteEvent type exposes the following members.

Properties

 | Name | Description
Public property | RoleName | Gets or sets RoleName.

See Also

RoleCreatedRemoteEvent Class
Sitecore.Eventing.Remote Namespace


RoleName Property

[image]

Sitecore 6.4.1 API
RoleCreatedRemoteEvent..::..RoleName Property
RoleCreatedRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string RoleName { get; protected set; }
Visual Basic
Public Property RoleName As String
    Get
    Protected Set
Visual C++
public:
property String^ RoleName {
    String^ get ();
    protected: void set (String^ value);
}

See Also

RoleCreatedRemoteEvent Class
Sitecore.Eventing.Remote Namespace


RoleDeletedRemoteEvent Class

[image]

Sitecore 6.4.1 API
RoleDeletedRemoteEvent Class
Members See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RoleDeletedRemoteEvent
Visual Basic
Public Class RoleDeletedRemoteEvent
Visual C++
public ref class RoleDeletedRemoteEvent

Inheritance Hierarchy

System..::..Object
Sitecore.Eventing.Remote..::..RoleDeletedRemoteEvent

See Also

RoleDeletedRemoteEvent Members
Sitecore.Eventing.Remote Namespace


RoleDeletedRemoteEvent Members

[image] [image]

Sitecore 6.4.1 API
RoleDeletedRemoteEvent Members
RoleDeletedRemoteEvent Class Constructors Methods Properties See Also Send Feedback

The RoleDeletedRemoteEvent type exposes the following members.

Constructors

 | Name | Description
Public method | RoleDeletedRemoteEvent | Initializes a new instance of the RoleDeletedRemoteEvent class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | RoleName | Gets or sets RoleName.

See Also

RoleDeletedRemoteEvent Class
Sitecore.Eventing.Remote Namespace


RoleDeletedRemoteEvent Constructor

[image]

Sitecore 6.4.1 API
RoleDeletedRemoteEvent Constructor
RoleDeletedRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RoleDeletedRemoteEvent(
    string roleName
)
Visual Basic
Public Sub New ( _
    roleName As String _
)
Visual C++
public:
RoleDeletedRemoteEvent(
    String^ roleName
)

Parameters

roleName
Type: System..::..String
The role name.

See Also

RoleDeletedRemoteEvent Class
Sitecore.Eventing.Remote Namespace


RoleDeletedRemoteEvent Methods

[image] [image]

Sitecore 6.4.1 API
RoleDeletedRemoteEvent Methods
RoleDeletedRemoteEvent Class See Also Send Feedback

The RoleDeletedRemoteEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoleDeletedRemoteEvent Class
Sitecore.Eventing.Remote Namespace


RoleDeletedRemoteEvent Properties

[image] [image]

Sitecore 6.4.1 API
RoleDeletedRemoteEvent Properties
RoleDeletedRemoteEvent Class See Also Send Feedback

The RoleDeletedRemoteEvent type exposes the following members.

Properties

 | Name | Description
Public property | RoleName | Gets or sets RoleName.

See Also

RoleDeletedRemoteEvent Class
Sitecore.Eventing.Remote Namespace


RoleName Property

[image]

Sitecore 6.4.1 API
RoleDeletedRemoteEvent..::..RoleName Property
RoleDeletedRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string RoleName { get; protected set; }
Visual Basic
Public Property RoleName As String
    Get
    Protected Set
Visual C++
public:
property String^ RoleName {
    String^ get ();
    protected: void set (String^ value);
}

See Also

RoleDeletedRemoteEvent Class
Sitecore.Eventing.Remote Namespace


RoleRelationsRemovedRemoteEvent Class

[image]

Sitecore 6.4.1 API
RoleRelationsRemovedRemoteEvent Class
Members See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RoleRelationsRemovedRemoteEvent
Visual Basic
Public Class RoleRelationsRemovedRemoteEvent
Visual C++
public ref class RoleRelationsRemovedRemoteEvent

Inheritance Hierarchy

System..::..Object
Sitecore.Eventing.Remote..::..RoleRelationsRemovedRemoteEvent

See Also

RoleRelationsRemovedRemoteEvent Members
Sitecore.Eventing.Remote Namespace


RoleRelationsRemovedRemoteEvent Members

[image] [image]

Sitecore 6.4.1 API
RoleRelationsRemovedRemoteEvent Members
RoleRelationsRemovedRemoteEvent Class Constructors Methods Properties See Also Send Feedback

The RoleRelationsRemovedRemoteEvent type exposes the following members.

Constructors

 | Name | Description
Public method | RoleRelationsRemovedRemoteEvent | Initializes a new instance of the RoleRelationsRemovedRemoteEvent class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | RoleName | Gets or sets RoleName.

See Also

RoleRelationsRemovedRemoteEvent Class
Sitecore.Eventing.Remote Namespace


RoleRelationsRemovedRemoteEvent Constructor

[image]

Sitecore 6.4.1 API
RoleRelationsRemovedRemoteEvent Constructor
RoleRelationsRemovedRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RoleRelationsRemovedRemoteEvent(
    string roleName
)
Visual Basic
Public Sub New ( _
    roleName As String _
)
Visual C++
public:
RoleRelationsRemovedRemoteEvent(
    String^ roleName
)

Parameters

roleName
Type: System..::..String
Name of the role.

See Also

RoleRelationsRemovedRemoteEvent Class
Sitecore.Eventing.Remote Namespace


RoleRelationsRemovedRemoteEvent Properties

[image] [image]

Sitecore 6.4.1 API
RoleRelationsRemovedRemoteEvent Properties
RoleRelationsRemovedRemoteEvent Class See Also Send Feedback

The RoleRelationsRemovedRemoteEvent type exposes the following members.

Properties

 | Name | Description
Public property | RoleName | Gets or sets RoleName.

See Also

RoleRelationsRemovedRemoteEvent Class
Sitecore.Eventing.Remote Namespace


RoleName Property

[image]

Sitecore 6.4.1 API
RoleRelationsRemovedRemoteEvent..::..RoleName Property
RoleRelationsRemovedRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string RoleName { get; protected set; }
Visual Basic
Public Property RoleName As String
    Get
    Protected Set
Visual C++
public:
property String^ RoleName {
    String^ get ();
    protected: void set (String^ value);
}

Field Value

The role name.

See Also

RoleRelationsRemovedRemoteEvent Class
Sitecore.Eventing.Remote Namespace


RolesAddedToRolesRemoteEvent Class

[image]

Sitecore 6.4.1 API
RolesAddedToRolesRemoteEvent Class
Members See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RolesAddedToRolesRemoteEvent
Visual Basic
Public Class RolesAddedToRolesRemoteEvent
Visual C++
public ref class RolesAddedToRolesRemoteEvent

Inheritance Hierarchy

System..::..Object
Sitecore.Eventing.Remote..::..RolesAddedToRolesRemoteEvent

See Also

RolesAddedToRolesRemoteEvent Members
Sitecore.Eventing.Remote Namespace


RolesAddedToRolesRemoteEvent Members

[image] [image]

Sitecore 6.4.1 API
RolesAddedToRolesRemoteEvent Members
RolesAddedToRolesRemoteEvent Class Constructors Methods Properties See Also Send Feedback

The RolesAddedToRolesRemoteEvent type exposes the following members.

Constructors

 | Name | Description
Public method | RolesAddedToRolesRemoteEvent | Initializes a new instance of the RolesAddedToRolesRemoteEvent class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | MemberRoles | Gets or sets the member roles.
Public property | TargetRoles | Gets or sets TargetRoles.

See Also

RolesAddedToRolesRemoteEvent Class
Sitecore.Eventing.Remote Namespace


RolesAddedToRolesRemoteEvent Constructor

[image]

Sitecore 6.4.1 API
RolesAddedToRolesRemoteEvent Constructor
RolesAddedToRolesRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RolesAddedToRolesRemoteEvent(
    IEnumerable<Role> memberRoles,
    IEnumerable<Role> targetRoles
)
Visual Basic
Public Sub New ( _
    memberRoles As IEnumerable(Of Role), _
    targetRoles As IEnumerable(Of Role) _
)
Visual C++
public:
RolesAddedToRolesRemoteEvent(
    IEnumerable<Role^>^ memberRoles,
    IEnumerable<Role^>^ targetRoles
)

Parameters

memberRoles
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Role >)>)>
The member roles.
targetRoles
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Role >)>)>
The target roles.

See Also

RolesAddedToRolesRemoteEvent Class
Sitecore.Eventing.Remote Namespace


RolesAddedToRolesRemoteEvent Methods

[image] [image]

Sitecore 6.4.1 API
RolesAddedToRolesRemoteEvent Methods
RolesAddedToRolesRemoteEvent Class See Also Send Feedback

The RolesAddedToRolesRemoteEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RolesAddedToRolesRemoteEvent Class
Sitecore.Eventing.Remote Namespace


RolesAddedToRolesRemoteEvent Properties

[image] [image]

Sitecore 6.4.1 API
RolesAddedToRolesRemoteEvent Properties
RolesAddedToRolesRemoteEvent Class See Also Send Feedback

The RolesAddedToRolesRemoteEvent type exposes the following members.

Properties

 | Name | Description
Public property | MemberRoles | Gets or sets the member roles.
Public property | TargetRoles | Gets or sets TargetRoles.

See Also

RolesAddedToRolesRemoteEvent Class
Sitecore.Eventing.Remote Namespace


MemberRoles Property

[image]

Sitecore 6.4.1 API
RolesAddedToRolesRemoteEvent..::..MemberRoles Property
RolesAddedToRolesRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string[] MemberRoles { get; protected set; }
Visual Basic
Public Property MemberRoles As String()
    Get
    Protected Set
Visual C++
public:
property array<String^>^ MemberRoles {
    array<String^>^ get ();
    protected: void set (array<String^>^ value);
}

Field Value

The member roles.

See Also

RolesAddedToRolesRemoteEvent Class
Sitecore.Eventing.Remote Namespace


TargetRoles Property

[image]

Sitecore 6.4.1 API
RolesAddedToRolesRemoteEvent..::..TargetRoles Property
RolesAddedToRolesRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string[] TargetRoles { get; protected set; }
Visual Basic
Public Property TargetRoles As String()
    Get
    Protected Set
Visual C++
public:
property array<String^>^ TargetRoles {
    array<String^>^ get ();
    protected: void set (array<String^>^ value);
}

Field Value

The target roles.

See Also

RolesAddedToRolesRemoteEvent Class
Sitecore.Eventing.Remote Namespace


RolesRemovedFromRolesRemoteEvent Class

[image]

Sitecore 6.4.1 API
RolesRemovedFromRolesRemoteEvent Class
Members See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RolesRemovedFromRolesRemoteEvent
Visual Basic
Public Class RolesRemovedFromRolesRemoteEvent
Visual C++
public ref class RolesRemovedFromRolesRemoteEvent

Inheritance Hierarchy

System..::..Object
Sitecore.Eventing.Remote..::..RolesRemovedFromRolesRemoteEvent

See Also

RolesRemovedFromRolesRemoteEvent Members
Sitecore.Eventing.Remote Namespace


RolesRemovedFromRolesRemoteEvent Constructor

[image]

Sitecore 6.4.1 API
RolesRemovedFromRolesRemoteEvent Constructor
RolesRemovedFromRolesRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RolesRemovedFromRolesRemoteEvent(
    IEnumerable<Role> memberRoles,
    IEnumerable<Role> targetRoles
)
Visual Basic
Public Sub New ( _
    memberRoles As IEnumerable(Of Role), _
    targetRoles As IEnumerable(Of Role) _
)
Visual C++
public:
RolesRemovedFromRolesRemoteEvent(
    IEnumerable<Role^>^ memberRoles,
    IEnumerable<Role^>^ targetRoles
)

Parameters

memberRoles
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Role >)>)>
The member roles.
targetRoles
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Role >)>)>
The target roles.

See Also

RolesRemovedFromRolesRemoteEvent Class
Sitecore.Eventing.Remote Namespace


RolesRemovedFromRolesRemoteEvent Methods

[image] [image]

Sitecore 6.4.1 API
RolesRemovedFromRolesRemoteEvent Methods
RolesRemovedFromRolesRemoteEvent Class See Also Send Feedback

The RolesRemovedFromRolesRemoteEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RolesRemovedFromRolesRemoteEvent Class
Sitecore.Eventing.Remote Namespace


MemberRoles Property

[image]

Sitecore 6.4.1 API
RolesRemovedFromRolesRemoteEvent..::..MemberRoles Property
RolesRemovedFromRolesRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string[] MemberRoles { get; protected set; }
Visual Basic
Public Property MemberRoles As String()
    Get
    Protected Set
Visual C++
public:
property array<String^>^ MemberRoles {
    array<String^>^ get ();
    protected: void set (array<String^>^ value);
}

Field Value

The member roles.

See Also

RolesRemovedFromRolesRemoteEvent Class
Sitecore.Eventing.Remote Namespace


TargetRoles Property

[image]

Sitecore 6.4.1 API
RolesRemovedFromRolesRemoteEvent..::..TargetRoles Property
RolesRemovedFromRolesRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string[] TargetRoles { get; protected set; }
Visual Basic
Public Property TargetRoles As String()
    Get
    Protected Set
Visual C++
public:
property array<String^>^ TargetRoles {
    array<String^>^ get ();
    protected: void set (array<String^>^ value);
}

Field Value

The target roles.

See Also

RolesRemovedFromRolesRemoteEvent Class
Sitecore.Eventing.Remote Namespace


SecurableUpdatedRemoteEvent Class

[image]

Sitecore 6.4.1 API
SecurableUpdatedRemoteEvent Class
Members See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SecurableUpdatedRemoteEvent
Visual Basic
Public Class SecurableUpdatedRemoteEvent
Visual C++
public ref class SecurableUpdatedRemoteEvent

Inheritance Hierarchy

System..::..Object
Sitecore.Eventing.Remote..::..SecurableUpdatedRemoteEvent

See Also

SecurableUpdatedRemoteEvent Members
Sitecore.Eventing.Remote Namespace


SecurableUpdatedRemoteEvent Members

[image] [image]

Sitecore 6.4.1 API
SecurableUpdatedRemoteEvent Members
SecurableUpdatedRemoteEvent Class Constructors Methods Properties See Also Send Feedback

The SecurableUpdatedRemoteEvent type exposes the following members.

Constructors

 | Name | Description
Public method | SecurableUpdatedRemoteEvent | Initializes a new instance of the SecurableUpdatedRemoteEvent class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | TypeName | Gets or sets TypeName.
Public property | UniqueId | Gets or sets UniqueId.

See Also

SecurableUpdatedRemoteEvent Class
Sitecore.Eventing.Remote Namespace


SecurableUpdatedRemoteEvent Constructor

[image]

Sitecore 6.4.1 API
SecurableUpdatedRemoteEvent Constructor
SecurableUpdatedRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SecurableUpdatedRemoteEvent(
    ISecurable securable
)
Visual Basic
Public Sub New ( _
    securable As ISecurable _
)
Visual C++
public:
SecurableUpdatedRemoteEvent(
    ISecurable^ securable
)

Parameters

securable
Type: Sitecore.Security.AccessControl..::..ISecurable
The securable.

See Also

SecurableUpdatedRemoteEvent Class
Sitecore.Eventing.Remote Namespace


SecurableUpdatedRemoteEvent Methods

[image] [image]

Sitecore 6.4.1 API
SecurableUpdatedRemoteEvent Methods
SecurableUpdatedRemoteEvent Class See Also Send Feedback

The SecurableUpdatedRemoteEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SecurableUpdatedRemoteEvent Class
Sitecore.Eventing.Remote Namespace


SecurableUpdatedRemoteEvent Properties

[image] [image]

Sitecore 6.4.1 API
SecurableUpdatedRemoteEvent Properties
SecurableUpdatedRemoteEvent Class See Also Send Feedback

The SecurableUpdatedRemoteEvent type exposes the following members.

Properties

 | Name | Description
Public property | TypeName | Gets or sets TypeName.
Public property | UniqueId | Gets or sets UniqueId.

See Also

SecurableUpdatedRemoteEvent Class
Sitecore.Eventing.Remote Namespace


UserCreatedRemoteEvent Class

[image]

Sitecore 6.4.1 API
UserCreatedRemoteEvent Class
Members See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class UserCreatedRemoteEvent
Visual Basic
Public Class UserCreatedRemoteEvent
Visual C++
public ref class UserCreatedRemoteEvent

Inheritance Hierarchy

System..::..Object
Sitecore.Eventing.Remote..::..UserCreatedRemoteEvent

See Also

UserCreatedRemoteEvent Members
Sitecore.Eventing.Remote Namespace


UserCreatedRemoteEvent Members

[image] [image]

Sitecore 6.4.1 API
UserCreatedRemoteEvent Members
UserCreatedRemoteEvent Class Constructors Methods Properties See Also Send Feedback

The UserCreatedRemoteEvent type exposes the following members.

Constructors

 | Name | Description
Public method | UserCreatedRemoteEvent | Initializes a new instance of the UserCreatedRemoteEvent class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | UserName | Gets or sets UserName.

See Also

UserCreatedRemoteEvent Class
Sitecore.Eventing.Remote Namespace


UserCreatedRemoteEvent Constructor

[image]

Sitecore 6.4.1 API
UserCreatedRemoteEvent Constructor
UserCreatedRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UserCreatedRemoteEvent(
    MembershipUser user
)
Visual Basic
Public Sub New ( _
    user As MembershipUser _
)
Visual C++
public:
UserCreatedRemoteEvent(
    MembershipUser^ user
)

Parameters

user
Type: System.Web.Security..::..MembershipUser
The user.

See Also

UserCreatedRemoteEvent Class
Sitecore.Eventing.Remote Namespace


UserCreatedRemoteEvent Properties

[image] [image]

Sitecore 6.4.1 API
UserCreatedRemoteEvent Properties
UserCreatedRemoteEvent Class See Also Send Feedback

The UserCreatedRemoteEvent type exposes the following members.

Properties

 | Name | Description
Public property | UserName | Gets or sets UserName.

See Also

UserCreatedRemoteEvent Class
Sitecore.Eventing.Remote Namespace


UserName Property

[image]

Sitecore 6.4.1 API
UserCreatedRemoteEvent..::..UserName Property
UserCreatedRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string UserName { get; protected set; }
Visual Basic
Public Property UserName As String
    Get
    Protected Set
Visual C++
public:
property String^ UserName {
    String^ get ();
    protected: void set (String^ value);
}

See Also

UserCreatedRemoteEvent Class
Sitecore.Eventing.Remote Namespace


UserDeletedRemoteEvent Class

[image]

Sitecore 6.4.1 API
UserDeletedRemoteEvent Class
Members See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class UserDeletedRemoteEvent
Visual Basic
Public Class UserDeletedRemoteEvent
Visual C++
public ref class UserDeletedRemoteEvent

Inheritance Hierarchy

System..::..Object
Sitecore.Eventing.Remote..::..UserDeletedRemoteEvent

See Also

UserDeletedRemoteEvent Members
Sitecore.Eventing.Remote Namespace


UserDeletedRemoteEvent Members

[image] [image]

Sitecore 6.4.1 API
UserDeletedRemoteEvent Members
UserDeletedRemoteEvent Class Constructors Methods Properties See Also Send Feedback

The UserDeletedRemoteEvent type exposes the following members.

Constructors

 | Name | Description
Public method | UserDeletedRemoteEvent | Initializes a new instance of the UserDeletedRemoteEvent class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | UserName | Gets or sets UserName.

See Also

UserDeletedRemoteEvent Class
Sitecore.Eventing.Remote Namespace


UserDeletedRemoteEvent Constructor

[image]

Sitecore 6.4.1 API
UserDeletedRemoteEvent Constructor
UserDeletedRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UserDeletedRemoteEvent(
    string userName
)
Visual Basic
Public Sub New ( _
    userName As String _
)
Visual C++
public:
UserDeletedRemoteEvent(
    String^ userName
)

Parameters

userName
Type: System..::..String
Name of the user.

See Also

UserDeletedRemoteEvent Class
Sitecore.Eventing.Remote Namespace


UserDeletedRemoteEvent Properties

[image] [image]

Sitecore 6.4.1 API
UserDeletedRemoteEvent Properties
UserDeletedRemoteEvent Class See Also Send Feedback

The UserDeletedRemoteEvent type exposes the following members.

Properties

 | Name | Description
Public property | UserName | Gets or sets UserName.

See Also

UserDeletedRemoteEvent Class
Sitecore.Eventing.Remote Namespace


UserName Property

[image]

Sitecore 6.4.1 API
UserDeletedRemoteEvent..::..UserName Property
UserDeletedRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string UserName { get; protected set; }
Visual Basic
Public Property UserName As String
    Get
    Protected Set
Visual C++
public:
property String^ UserName {
    String^ get ();
    protected: void set (String^ value);
}

See Also

UserDeletedRemoteEvent Class
Sitecore.Eventing.Remote Namespace


UsersAddedToRolesRemoteEvent Class

[image]

Sitecore 6.4.1 API
UsersAddedToRolesRemoteEvent Class
Members See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class UsersAddedToRolesRemoteEvent
Visual Basic
Public Class UsersAddedToRolesRemoteEvent
Visual C++
public ref class UsersAddedToRolesRemoteEvent

Inheritance Hierarchy

System..::..Object
Sitecore.Eventing.Remote..::..UsersAddedToRolesRemoteEvent

See Also

UsersAddedToRolesRemoteEvent Members
Sitecore.Eventing.Remote Namespace


UsersAddedToRolesRemoteEvent Members

[image] [image]

Sitecore 6.4.1 API
UsersAddedToRolesRemoteEvent Members
UsersAddedToRolesRemoteEvent Class Constructors Methods Properties See Also Send Feedback

The UsersAddedToRolesRemoteEvent type exposes the following members.

Constructors

 | Name | Description
Public method | UsersAddedToRolesRemoteEvent | Initializes a new instance of the UsersAddedToRolesRemoteEvent class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | RoleNames | Gets or sets RoleNames.
Public property | UserNames | Gets or sets UserNames.

See Also

UsersAddedToRolesRemoteEvent Class
Sitecore.Eventing.Remote Namespace


UsersAddedToRolesRemoteEvent Constructor

[image]

Sitecore 6.4.1 API
UsersAddedToRolesRemoteEvent Constructor
UsersAddedToRolesRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UsersAddedToRolesRemoteEvent(
    string[] userNames,
    string[] roleNames
)
Visual Basic
Public Sub New ( _
    userNames As String(), _
    roleNames As String() _
)
Visual C++
public:
UsersAddedToRolesRemoteEvent(
    array<String^>^ userNames,
    array<String^>^ roleNames
)

Parameters

userNames
Type: array< System..::..String >[]()[][]
The user names.
roleNames
Type: array< System..::..String >[]()[][]
The role names.

See Also

UsersAddedToRolesRemoteEvent Class
Sitecore.Eventing.Remote Namespace


UsersAddedToRolesRemoteEvent Methods

[image] [image]

Sitecore 6.4.1 API
UsersAddedToRolesRemoteEvent Methods
UsersAddedToRolesRemoteEvent Class See Also Send Feedback

The UsersAddedToRolesRemoteEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UsersAddedToRolesRemoteEvent Class
Sitecore.Eventing.Remote Namespace


RoleNames Property

[image]

Sitecore 6.4.1 API
UsersAddedToRolesRemoteEvent..::..RoleNames Property
UsersAddedToRolesRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string[] RoleNames { get; protected set; }
Visual Basic
Public Property RoleNames As String()
    Get
    Protected Set
Visual C++
public:
property array<String^>^ RoleNames {
    array<String^>^ get ();
    protected: void set (array<String^>^ value);
}

See Also

UsersAddedToRolesRemoteEvent Class
Sitecore.Eventing.Remote Namespace


UserNames Property

[image]

Sitecore 6.4.1 API
UsersAddedToRolesRemoteEvent..::..UserNames Property
UsersAddedToRolesRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string[] UserNames { get; protected set; }
Visual Basic
Public Property UserNames As String()
    Get
    Protected Set
Visual C++
public:
property array<String^>^ UserNames {
    array<String^>^ get ();
    protected: void set (array<String^>^ value);
}

See Also

UsersAddedToRolesRemoteEvent Class
Sitecore.Eventing.Remote Namespace


UsersRemovedFromRolesRemoteEvent Class

[image]

Sitecore 6.4.1 API
UsersRemovedFromRolesRemoteEvent Class
Members See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class UsersRemovedFromRolesRemoteEvent
Visual Basic
Public Class UsersRemovedFromRolesRemoteEvent
Visual C++
public ref class UsersRemovedFromRolesRemoteEvent

Inheritance Hierarchy

System..::..Object
Sitecore.Eventing.Remote..::..UsersRemovedFromRolesRemoteEvent

See Also

UsersRemovedFromRolesRemoteEvent Members
Sitecore.Eventing.Remote Namespace


UsersRemovedFromRolesRemoteEvent Members

[image] [image]

Sitecore 6.4.1 API
UsersRemovedFromRolesRemoteEvent Members
UsersRemovedFromRolesRemoteEvent Class Constructors Methods Properties See Also Send Feedback

The UsersRemovedFromRolesRemoteEvent type exposes the following members.

Constructors

 | Name | Description
Public method | UsersRemovedFromRolesRemoteEvent | Initializes a new instance of the UsersRemovedFromRolesRemoteEvent class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | RoleNames | Gets or sets RoleNames.
Public property | UserNames | Gets or sets UserNames.

See Also

UsersRemovedFromRolesRemoteEvent Class
Sitecore.Eventing.Remote Namespace


UsersRemovedFromRolesRemoteEvent Constructor

[image]

Sitecore 6.4.1 API
UsersRemovedFromRolesRemoteEvent Constructor
UsersRemovedFromRolesRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UsersRemovedFromRolesRemoteEvent(
    string[] userNames,
    string[] roleNames
)
Visual Basic
Public Sub New ( _
    userNames As String(), _
    roleNames As String() _
)
Visual C++
public:
UsersRemovedFromRolesRemoteEvent(
    array<String^>^ userNames,
    array<String^>^ roleNames
)

Parameters

userNames
Type: array< System..::..String >[]()[][]
The user names.
roleNames
Type: array< System..::..String >[]()[][]
The role names.

See Also

UsersRemovedFromRolesRemoteEvent Class
Sitecore.Eventing.Remote Namespace


UsersRemovedFromRolesRemoteEvent Methods

[image] [image]

Sitecore 6.4.1 API
UsersRemovedFromRolesRemoteEvent Methods
UsersRemovedFromRolesRemoteEvent Class See Also Send Feedback

The UsersRemovedFromRolesRemoteEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UsersRemovedFromRolesRemoteEvent Class
Sitecore.Eventing.Remote Namespace


UsersRemovedFromRolesRemoteEvent Properties

[image] [image]

Sitecore 6.4.1 API
UsersRemovedFromRolesRemoteEvent Properties
UsersRemovedFromRolesRemoteEvent Class See Also Send Feedback

The UsersRemovedFromRolesRemoteEvent type exposes the following members.

Properties

 | Name | Description
Public property | RoleNames | Gets or sets RoleNames.
Public property | UserNames | Gets or sets UserNames.

See Also

UsersRemovedFromRolesRemoteEvent Class
Sitecore.Eventing.Remote Namespace


RoleNames Property

[image]

Sitecore 6.4.1 API
UsersRemovedFromRolesRemoteEvent..::..RoleNames Property
UsersRemovedFromRolesRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string[] RoleNames { get; protected set; }
Visual Basic
Public Property RoleNames As String()
    Get
    Protected Set
Visual C++
public:
property array<String^>^ RoleNames {
    array<String^>^ get ();
    protected: void set (array<String^>^ value);
}

See Also

UsersRemovedFromRolesRemoteEvent Class
Sitecore.Eventing.Remote Namespace


UserNames Property

[image]

Sitecore 6.4.1 API
UsersRemovedFromRolesRemoteEvent..::..UserNames Property
UsersRemovedFromRolesRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string[] UserNames { get; protected set; }
Visual Basic
Public Property UserNames As String()
    Get
    Protected Set
Visual C++
public:
property array<String^>^ UserNames {
    array<String^>^ get ();
    protected: void set (array<String^>^ value);
}

See Also

UsersRemovedFromRolesRemoteEvent Class
Sitecore.Eventing.Remote Namespace


UserUpdatedRemoteEvent Members

[image] [image]

Sitecore 6.4.1 API
UserUpdatedRemoteEvent Members
UserUpdatedRemoteEvent Class Constructors Methods Properties See Also Send Feedback

The UserUpdatedRemoteEvent type exposes the following members.

Constructors

 | Name | Description
Public method | UserUpdatedRemoteEvent | Initializes a new instance of the UserUpdatedRemoteEvent class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | UserName | Gets or sets UserName.

See Also

UserUpdatedRemoteEvent Class
Sitecore.Eventing.Remote Namespace


UserUpdatedRemoteEvent Constructor

[image]

Sitecore 6.4.1 API
UserUpdatedRemoteEvent Constructor
UserUpdatedRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Eventing.Remote
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UserUpdatedRemoteEvent(
    MembershipUser user
)
Visual Basic
Public Sub New ( _
    user As MembershipUser _
)
Visual C++
public:
UserUpdatedRemoteEvent(
    MembershipUser^ user
)

Parameters

user
Type: System.Web.Security..::..MembershipUser
The user.

See Also

UserUpdatedRemoteEvent Class
Sitecore.Eventing.Remote Namespace


UserUpdatedRemoteEvent Methods

[image] [image]

Sitecore 6.4.1 API
UserUpdatedRemoteEvent Methods
UserUpdatedRemoteEvent Class See Also Send Feedback

The UserUpdatedRemoteEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UserUpdatedRemoteEvent Class
Sitecore.Eventing.Remote Namespace


UserUpdatedRemoteEvent Properties

[image] [image]

Sitecore 6.4.1 API
UserUpdatedRemoteEvent Properties
UserUpdatedRemoteEvent Class See Also Send Feedback

The UserUpdatedRemoteEvent type exposes the following members.

Properties

 | Name | Description
Public property | UserName | Gets or sets UserName.

See Also

UserUpdatedRemoteEvent Class
Sitecore.Eventing.Remote Namespace


Sitecore.Events Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Events Namespace
Send Feedback

Classes

 | Class | Description
Public class | Event | Represents an event.
Public class | EventResult | Represents an event result.
Public class | EventSubscriber | Represents an event subscriber.
Public class | NotificationContext | NotificationContext
Public class | SitecoreEventArgs | Represents a Sitecore event argument class.
Public class | TemplateUpdatedEventArgs | Represents a template updated event argument class.
Public class | VersionRemovedEventArgs | Defines the arguments passed in a VersionRemoved event.
Public class | WellknownEvents | WellknownEvents

Interfaces

 | Interface | Description
Public interface | IPassNativeEventArgs | Marker interface for EventArgs that should be passed directly to the event handlers of Event


Event Class

[image]

Sitecore 6.4.1 API
Event Class
Members See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Event
Visual Basic
Public NotInheritable Class Event
Visual C++
public ref class Event abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Events..::..Event

See Also

Event Members
Sitecore.Events Namespace


Event Members

[image] [image]

Sitecore 6.4.1 API
Event Members
Event Class Methods See Also Send Feedback

The Event type exposes the following members.

Methods

Name | Description
AddFilter | Adds the filter.
ExtractParameter(EventArgs, Int32) | Extracts the parameter.
ExtractParameter<(Of <<'(T>)>>)(EventArgs, Int32) | Extracts the parameter.
ExtractParameters | Extracts the parameters.
Initialize | Initializes this instance.
RaiseEvent(String, IPassNativeEventArgs) | Raises the event.
RaiseEvent(String, array<Object>[]()[][]) | Raises the event.
RaiseItemCopied | Raises the item copied event.
RaiseItemCreated | Raises the item created event.
RaiseItemCreatedRemote | Raises the item created remote event.
RaiseItemCreating | Raises the item creating event.
RaiseItemDeleted | Raises the item deleted event.
RaiseItemDeleting | Raises the item deleting event.
RaiseItemMoved | Raises the item moved event.
RaiseItemSaved | Raises the item saved event.
RaiseItemSaving | Raises the item saving event.
RemoveFilter | Removes the filter.
Reset | Resets this instance.
Subscribe | Subscribes the specified event name.
Unsubscribe | Unsubscribes the specified event name.

See Also

Event Class
Sitecore.Events Namespace


Event Methods

[image] [image]

Sitecore 6.4.1 API
Event Methods
Event Class See Also Send Feedback

The Event type exposes the following members.

Methods

Name | Description
AddFilter | Adds the filter.
ExtractParameter(EventArgs, Int32) | Extracts the parameter.
ExtractParameter<(Of <<'(T>)>>)(EventArgs, Int32) | Extracts the parameter.
ExtractParameters | Extracts the parameters.
Initialize | Initializes this instance.
RaiseEvent(String, IPassNativeEventArgs) | Raises the event.
RaiseEvent(String, array<Object>[]()[][]) | Raises the event.
RaiseItemCopied | Raises the item copied event.
RaiseItemCreated | Raises the item created event.
RaiseItemCreatedRemote | Raises the item created remote event.
RaiseItemCreating | Raises the item creating event.
RaiseItemDeleted | Raises the item deleted event.
RaiseItemDeleting | Raises the item deleting event.
RaiseItemMoved | Raises the item moved event.
RaiseItemSaved | Raises the item saved event.
RaiseItemSaving | Raises the item saving event.
RemoveFilter | Removes the filter.
Reset | Resets this instance.
Subscribe | Subscribes the specified event name.
Unsubscribe | Unsubscribes the specified event name.

See Also

Event Class
Sitecore.Events Namespace


AddFilter Method

[image]

Sitecore 6.4.1 API
Event..::..AddFilter Method
Event Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void AddFilter(
    string eventName,
    EventHandler handler
)
Visual Basic
Public Shared Sub AddFilter ( _
    eventName As String, _
    handler As EventHandler _
)
Visual C++
public:
static void AddFilter(
    String^ eventName,
    EventHandler^ handler
)

Parameters

eventName
Type: System..::..String
Name of the event.
handler
Type: System..::..EventHandler
The handler.

See Also

Event Class
Sitecore.Events Namespace


ExtractParameter Method

[image] [image]

Sitecore 6.4.1 API
Event..::..ExtractParameter Method
Event Class See Also Send Feedback

Overload List

Name | Description
ExtractParameter<(Of <<'(T>)>>)(EventArgs, Int32) | Extracts the parameter.
ExtractParameter(EventArgs, Int32) | Extracts the parameter.

See Also

Event Class
Event Members
Sitecore.Events Namespace


ExtractParameter(T) Method (EventArgs, Int32)

[image]

Sitecore 6.4.1 API
Event..::..ExtractParameter<(Of <(<'T>)>)> Method (EventArgs, Int32)
Event Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static T ExtractParameter<T>(
    EventArgs args,
    int index
)
where T : class
Visual Basic
Public Shared Function ExtractParameter(Of T As Class) ( _
    args As EventArgs, _
    index As Integer _
) As T
Visual C++
public:
generic<typename T>
where T : ref class
static T ExtractParameter(
    EventArgs^ args,
    int index
)

Parameters

args
Type: System..::..EventArgs
The arguments.
index
Type: System..::..Int32
The index.

Type Parameters

T
Type parameter.

Return Value

The parameter.

See Also

Event Class
ExtractParameter Overload
Sitecore.Events Namespace


ExtractParameter Method (EventArgs, Int32)

[image]

Sitecore 6.4.1 API
Event..::..ExtractParameter Method (EventArgs, Int32)
Event Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object ExtractParameter(
    EventArgs args,
    int index
)
Visual Basic
Public Shared Function ExtractParameter ( _
    args As EventArgs, _
    index As Integer _
) As Object
Visual C++
public:
static Object^ ExtractParameter(
    EventArgs^ args,
    int index
)

Parameters

args
Type: System..::..EventArgs
The arguments.
index
Type: System..::..Int32
The index.

Return Value

The parameter.

See Also

Event Class
ExtractParameter Overload
Sitecore.Events Namespace


ExtractParameters Method

[image]

Sitecore 6.4.1 API
Event..::..ExtractParameters Method
Event Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object[] ExtractParameters(
    EventArgs args
)
Visual Basic
Public Shared Function ExtractParameters ( _
    args As EventArgs _
) As Object()
Visual C++
public:
static array<Object^>^ ExtractParameters(
    EventArgs^ args
)

Parameters

args
Type: System..::..EventArgs
The arguments.

Return Value

The parameters.

See Also

Event Class
Sitecore.Events Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
Event..::..Initialize Method
Event Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Initialize()
Visual Basic
Public Shared Sub Initialize
Visual C++
public:
static void Initialize()

See Also

Event Class
Sitecore.Events Namespace


RaiseEvent Method

[image] [image]

Sitecore 6.4.1 API
Event..::..RaiseEvent Method
Event Class See Also Send Feedback

Overload List

Name | Description
RaiseEvent(String, IPassNativeEventArgs) | Raises the event.
RaiseEvent(String, array<Object>[]()[][]) | Raises the event.

See Also

Event Class
Event Members
Sitecore.Events Namespace


RaiseEvent Method (String, IPassNativeEventArgs)

[image]

Sitecore 6.4.1 API
Event..::..RaiseEvent Method (String, IPassNativeEventArgs)
Event Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void RaiseEvent(
    string eventName,
    IPassNativeEventArgs args
)
Visual Basic
Public Shared Sub RaiseEvent ( _
    eventName As String, _
    args As IPassNativeEventArgs _
)
Visual C++
public:
static void RaiseEvent(
    String^ eventName,
    IPassNativeEventArgs^ args
)

Parameters

eventName
Type: System..::..String
Name of the event.
args
Type: Sitecore.Events..::..IPassNativeEventArgs
The instance containing the event data.

See Also

Event Class
RaiseEvent Overload
Sitecore.Events Namespace


RaiseEvent Method (String, Object[])

[image]

Sitecore 6.4.1 API
Event..::..RaiseEvent Method (String, array<Object>[]()[][])
Event Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static EventResult RaiseEvent(
    string eventName,
    params Object[] parameters
)
Visual Basic
Public Shared Function RaiseEvent ( _
    eventName As String, _
    ParamArray parameters As Object() _
) As EventResult
Visual C++
public:
static EventResult^ RaiseEvent(
    String^ eventName,
    ... array<Object^>^ parameters
)

Parameters

eventName
Type: System..::..String
Name of the event.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.

Return Value

The event.

See Also

Event Class
RaiseEvent Overload
Sitecore.Events Namespace


RaiseItemCopied Method

[image]

Sitecore 6.4.1 API
Event..::..RaiseItemCopied Method
Event Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void RaiseItemCopied(
    Object sender,
    ItemCopiedEventArgs args
)
Visual Basic
Public Shared Sub RaiseItemCopied ( _
    sender As Object, _
    args As ItemCopiedEventArgs _
)
Visual C++
public:
static void RaiseItemCopied(
    Object^ sender,
    ItemCopiedEventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: Sitecore.Data.Events..::..ItemCopiedEventArgs
The ItemCopiedEventArgs instance containing the event data.

See Also

Event Class
Sitecore.Events Namespace


RaiseItemCreated Method

[image]

Sitecore 6.4.1 API
Event..::..RaiseItemCreated Method
Event Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void RaiseItemCreated(
    Object sender,
    ItemCreatedEventArgs args
)
Visual Basic
Public Shared Sub RaiseItemCreated ( _
    sender As Object, _
    args As ItemCreatedEventArgs _
)
Visual C++
public:
static void RaiseItemCreated(
    Object^ sender,
    ItemCreatedEventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: Sitecore.Data.Events..::..ItemCreatedEventArgs
The ItemCreatedEventArgs instance containing the event data.

See Also

Event Class
Sitecore.Events Namespace


RaiseItemCreatedRemote Method

[image]

Sitecore 6.4.1 API
Event..::..RaiseItemCreatedRemote Method
Event Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void RaiseItemCreatedRemote(
    Object sender,
    ItemCreatedRemoteEventArgs args
)
Visual Basic
Public Shared Sub RaiseItemCreatedRemote ( _
    sender As Object, _
    args As ItemCreatedRemoteEventArgs _
)
Visual C++
public:
static void RaiseItemCreatedRemote(
    Object^ sender,
    ItemCreatedRemoteEventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: Sitecore.Data.Events..::..ItemCreatedRemoteEventArgs
The ItemCreatedRemoteEventArgs instance containing the event data.

See Also

Event Class
Sitecore.Events Namespace


RaiseItemCreating Method

[image]

Sitecore 6.4.1 API
Event..::..RaiseItemCreating Method
Event Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void RaiseItemCreating(
    Object sender,
    ItemCreatingEventArgs args
)
Visual Basic
Public Shared Sub RaiseItemCreating ( _
    sender As Object, _
    args As ItemCreatingEventArgs _
)
Visual C++
public:
static void RaiseItemCreating(
    Object^ sender,
    ItemCreatingEventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: Sitecore.Data.Events..::..ItemCreatingEventArgs
The ItemCreatingEventArgs instance containing the event data.

See Also

Event Class
Sitecore.Events Namespace


RaiseItemDeleted Method

[image]

Sitecore 6.4.1 API
Event..::..RaiseItemDeleted Method
Event Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void RaiseItemDeleted(
    Object sender,
    ItemDeletedEventArgs args
)
Visual Basic
Public Shared Sub RaiseItemDeleted ( _
    sender As Object, _
    args As ItemDeletedEventArgs _
)
Visual C++
public:
static void RaiseItemDeleted(
    Object^ sender,
    ItemDeletedEventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: Sitecore.Data.Events..::..ItemDeletedEventArgs
The ItemDeletedEventArgs instance containing the event data.

See Also

Event Class
Sitecore.Events Namespace


RaiseItemDeleting Method

[image]

Sitecore 6.4.1 API
Event..::..RaiseItemDeleting Method
Event Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void RaiseItemDeleting(
    Object sender,
    ItemDeletingEventArgs args
)
Visual Basic
Public Shared Sub RaiseItemDeleting ( _
    sender As Object, _
    args As ItemDeletingEventArgs _
)
Visual C++
public:
static void RaiseItemDeleting(
    Object^ sender,
    ItemDeletingEventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: Sitecore.Data.Events..::..ItemDeletingEventArgs
The ItemDeletingEventArgs instance containing the event data.

See Also

Event Class
Sitecore.Events Namespace


RaiseItemMoved Method

[image]

Sitecore 6.4.1 API
Event..::..RaiseItemMoved Method
Event Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void RaiseItemMoved(
    Object sender,
    ItemMovedEventArgs args
)
Visual Basic
Public Shared Sub RaiseItemMoved ( _
    sender As Object, _
    args As ItemMovedEventArgs _
)
Visual C++
public:
static void RaiseItemMoved(
    Object^ sender,
    ItemMovedEventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: Sitecore.Data.Events..::..ItemMovedEventArgs
The ItemMovedEventArgs instance containing the event data.

See Also

Event Class
Sitecore.Events Namespace


RaiseItemSaving Method

[image]

Sitecore 6.4.1 API
Event..::..RaiseItemSaving Method
Event Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void RaiseItemSaving(
    Object sender,
    ItemSavingEventArgs args
)
Visual Basic
Public Shared Sub RaiseItemSaving ( _
    sender As Object, _
    args As ItemSavingEventArgs _
)
Visual C++
public:
static void RaiseItemSaving(
    Object^ sender,
    ItemSavingEventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: Sitecore.Data.Events..::..ItemSavingEventArgs
The ItemSavingEventArgs instance containing the event data.

See Also

Event Class
Sitecore.Events Namespace


RemoveFilter Method

[image]

Sitecore 6.4.1 API
Event..::..RemoveFilter Method
Event Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void RemoveFilter(
    string eventName,
    EventHandler handler
)
Visual Basic
Public Shared Sub RemoveFilter ( _
    eventName As String, _
    handler As EventHandler _
)
Visual C++
public:
static void RemoveFilter(
    String^ eventName,
    EventHandler^ handler
)

Parameters

eventName
Type: System..::..String
Name of the event.
handler
Type: System..::..EventHandler
The event handler.

See Also

Event Class
Sitecore.Events Namespace


Reset Method

[image]

Sitecore 6.4.1 API
Event..::..Reset Method
Event Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Reset()
Visual Basic
Public Shared Sub Reset
Visual C++
public:
static void Reset()

See Also

Event Class
Sitecore.Events Namespace


Subscribe Method

[image]

Sitecore 6.4.1 API
Event..::..Subscribe Method
Event Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Subscribe(
    string eventName,
    EventHandler handler
)
Visual Basic
Public Shared Sub Subscribe ( _
    eventName As String, _
    handler As EventHandler _
)
Visual C++
public:
static void Subscribe(
    String^ eventName,
    EventHandler^ handler
)

Parameters

eventName
Type: System..::..String
Name of the event.
handler
Type: System..::..EventHandler
The handler.

See Also

Event Class
Sitecore.Events Namespace


Unsubscribe Method

[image]

Sitecore 6.4.1 API
Event..::..Unsubscribe Method
Event Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Unsubscribe(
    string eventName,
    EventHandler handler
)
Visual Basic
Public Shared Sub Unsubscribe ( _
    eventName As String, _
    handler As EventHandler _
)
Visual C++
public:
static void Unsubscribe(
    String^ eventName,
    EventHandler^ handler
)

Parameters

eventName
Type: System..::..String
Name of the event.
handler
Type: System..::..EventHandler
The handler.

See Also

Event Class
Sitecore.Events Namespace


EventResult Class

[image]

Sitecore 6.4.1 API
EventResult Class
Members See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class EventResult
Visual Basic
Public Class EventResult
Visual C++
public ref class EventResult

Inheritance Hierarchy

System..::..Object
Sitecore.Events..::..EventResult

See Also

EventResult Members
Sitecore.Events Namespace


EventResult Members

[image] [image]

Sitecore 6.4.1 API
EventResult Members
EventResult Class Constructors Methods Properties See Also Send Feedback

The EventResult type exposes the following members.

Constructors

 | Name | Description
Public method | EventResult | Initializes a new instance of the EventResult class

Methods

 | Name | Description
 | CreateCancelResult | Creates the cancel result.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether this EventResult is cancelled.
Public property | Messages | Gets the messages.
Public property | ReturnValues | Gets the return values.

See Also

EventResult Class
Sitecore.Events Namespace


EventResult Constructor

[image]

Sitecore 6.4.1 API
EventResult Constructor
EventResult Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public EventResult()
Visual Basic
Public Sub New
Visual C++
public:
EventResult()

See Also

EventResult Class
Sitecore.Events Namespace


EventResult Methods

[image] [image]

Sitecore 6.4.1 API
EventResult Methods
EventResult Class See Also Send Feedback

The EventResult type exposes the following members.

Methods

 | Name | Description
 | CreateCancelResult | Creates the cancel result.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

EventResult Class
Sitecore.Events Namespace


CreateCancelResult Method

[image]

Sitecore 6.4.1 API
EventResult..::..CreateCancelResult Method
EventResult Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static EventResult CreateCancelResult()
Visual Basic
Public Shared Function CreateCancelResult As EventResult
Visual C++
public:
static EventResult^ CreateCancelResult()

Return Value

The EventResult.

See Also

EventResult Class
Sitecore.Events Namespace


ToString Method

[image]

Sitecore 6.4.1 API
EventResult..::..ToString Method
EventResult Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

EventResult Class
Sitecore.Events Namespace


EventResult Properties

[image] [image]

Sitecore 6.4.1 API
EventResult Properties
EventResult Class See Also Send Feedback

The EventResult type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether this EventResult is cancelled.
Public property | Messages | Gets the messages.
Public property | ReturnValues | Gets the return values.

See Also

EventResult Class
Sitecore.Events Namespace


Cancel Property

[image]

Sitecore 6.4.1 API
EventResult..::..Cancel Property
EventResult Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Cancel { get; set; }
Visual Basic
Public Property Cancel As Boolean
    Get
    Set
Visual C++
public:
property bool Cancel {
    bool get ();
    void set (bool value);
}

Field Value

true if cancelled; otherwise, false.

See Also

EventResult Class
Sitecore.Events Namespace


Messages Property

[image]

Sitecore 6.4.1 API
EventResult..::..Messages Property
EventResult Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StringCollection Messages { get; }
Visual Basic
Public ReadOnly Property Messages As StringCollection
    Get
Visual C++
public:
property StringCollection^ Messages {
    StringCollection^ get ();
}

Field Value

The messages.

See Also

EventResult Class
Sitecore.Events Namespace


ReturnValues Property

[image]

Sitecore 6.4.1 API
EventResult..::..ReturnValues Property
EventResult Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ArrayList ReturnValues { get; }
Visual Basic
Public ReadOnly Property ReturnValues As ArrayList
    Get
Visual C++
public:
property ArrayList^ ReturnValues {
    ArrayList^ get ();
}

Field Value

The return values.

See Also

EventResult Class
Sitecore.Events Namespace


EventSubscriber Class

[image]

Sitecore 6.4.1 API
EventSubscriber Class
Members See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class EventSubscriber
Visual Basic
Public Class EventSubscriber
Visual C++
public ref class EventSubscriber

Inheritance Hierarchy

System..::..Object
Sitecore.Events..::..EventSubscriber

See Also

EventSubscriber Members
Sitecore.Events Namespace


EventSubscriber Members

[image] [image]

Sitecore 6.4.1 API
EventSubscriber Members
EventSubscriber Class Constructors Methods See Also Send Feedback

The EventSubscriber type exposes the following members.

Constructors

 | Name | Description
Public method | EventSubscriber | Initializes a new instance of the EventSubscriber class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Invokes the specified parameters.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EventSubscriber Class
Sitecore.Events Namespace


EventSubscriber Constructor

[image]

Sitecore 6.4.1 API
EventSubscriber Constructor
EventSubscriber Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public EventSubscriber(
    Object obj,
    MethodInfo methodInfo
)
Visual Basic
Public Sub New ( _
    obj As Object, _
    methodInfo As MethodInfo _
)
Visual C++
public:
EventSubscriber(
    Object^ obj,
    MethodInfo^ methodInfo
)

Parameters

obj
Type: System..::..Object
The object.
methodInfo
Type: System.Reflection..::..MethodInfo
The method info.

See Also

EventSubscriber Class
Sitecore.Events Namespace


EventSubscriber Methods

[image] [image]

Sitecore 6.4.1 API
EventSubscriber Methods
EventSubscriber Class See Also Send Feedback

The EventSubscriber type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Invokes the specified parameters.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EventSubscriber Class
Sitecore.Events Namespace


Invoke Method

[image]

Sitecore 6.4.1 API
EventSubscriber..::..Invoke Method
EventSubscriber Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Invoke(
    Object[] parameters
)
Visual Basic
Public Sub Invoke ( _
    parameters As Object() _
)
Visual C++
public:
void Invoke(
    array<Object^>^ parameters
)

Parameters

parameters
Type: array< System..::..Object >[]()[][]
The parameters.

See Also

EventSubscriber Class
Sitecore.Events Namespace


IPassNativeEventArgs Interface

[image]

Sitecore 6.4.1 API
IPassNativeEventArgs Interface
See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IPassNativeEventArgs
Visual Basic
Public Interface IPassNativeEventArgs
Visual C++
public interface class IPassNativeEventArgs

See Also

Sitecore.Events Namespace


NotificationContext Class

[image]

Sitecore 6.4.1 API
NotificationContext Class
Members See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class NotificationContext
Visual Basic
Public Class NotificationContext
Visual C++
public ref class NotificationContext

Inheritance Hierarchy

System..::..Object
Sitecore.Events..::..NotificationContext

See Also

NotificationContext Members
Sitecore.Events Namespace


NotificationContext Constructor

[image]

Sitecore 6.4.1 API
NotificationContext Constructor
NotificationContext Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public NotificationContext()
Visual Basic
Public Sub New
Visual C++
public:
NotificationContext()

See Also

NotificationContext Class
Sitecore.Events Namespace


NotificationContext Methods

[image] [image]

Sitecore 6.4.1 API
NotificationContext Methods
NotificationContext Class See Also Send Feedback

The NotificationContext type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RaiseFieldSaved | Raises the field saved event.
Public method | RaiseItemAdded | Obsolete. Raises the item added event.
Public method | RaiseItemChildrenChanged | Raises the item children changed event.
Public method | RaiseItemCopied | Raises the item copied event.
Public method | RaiseItemCreated | Raises the item created event.
Public method | RaiseItemDeleted | Raises the item deleted event.
Public method | RaiseItemMoved | Raises the item moved event.
Public method | RaiseItemRenamed | Raises the item renamed event.
Public method | RaiseItemRenamedRemote | Raises the item renamed remote.
Public method | RaiseItemSaved | Raises the item saved event.
Public method | RaiseItemSavedRemote | Raises the item saved remote.
Public method | RaiseItemSortorderChanged | Raises the item sortorder changed event.
Public method | RaiseItemSortorderChangedRemote | Raises the item sortorder changed remote.
Public method | RaiseVersionAdded | Raises the version added event.
Public method | RaiseVersionRemoved | Raises the version removed event.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NotificationContext Class
Sitecore.Events Namespace


RaiseFieldSaved Method

[image]

Sitecore 6.4.1 API
NotificationContext..::..RaiseFieldSaved Method
NotificationContext Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RaiseFieldSaved(
    Object sender,
    FieldSavedEventArgs args
)
Visual Basic
Public Sub RaiseFieldSaved ( _
    sender As Object, _
    args As FieldSavedEventArgs _
)
Visual C++
public:
void RaiseFieldSaved(
    Object^ sender,
    FieldSavedEventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: Sitecore.Data.Events..::..FieldSavedEventArgs
The arguments.

See Also

NotificationContext Class
Sitecore.Events Namespace


RaiseItemAdded Method

[image]

Sitecore 6.4.1 API
NotificationContext..::..RaiseItemAdded Method
NotificationContext Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use the RaiseItemCreated method instead.", false)]
public void RaiseItemAdded(
    Object sender,
    ItemAddedEventArgs args
)
Visual Basic
<ObsoleteAttribute("Use the RaiseItemCreated method instead.", False)> _
Public Sub RaiseItemAdded ( _
    sender As Object, _
    args As ItemAddedEventArgs _
)
Visual C++
[ObsoleteAttribute(L"Use the RaiseItemCreated method instead.", false)]
public:
void RaiseItemAdded(
    Object^ sender,
    ItemAddedEventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: Sitecore.Data.Events..::..ItemAddedEventArgs
The arguments.

See Also

NotificationContext Class
Sitecore.Events Namespace


RaiseItemChildrenChanged Method

[image]

Sitecore 6.4.1 API
NotificationContext..::..RaiseItemChildrenChanged Method
NotificationContext Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RaiseItemChildrenChanged(
    Object sender,
    ItemChildrenChangedEventArgs args
)
Visual Basic
Public Sub RaiseItemChildrenChanged ( _
    sender As Object, _
    args As ItemChildrenChangedEventArgs _
)
Visual C++
public:
void RaiseItemChildrenChanged(
    Object^ sender,
    ItemChildrenChangedEventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: Sitecore.Data.Events..::..ItemChildrenChangedEventArgs
The arguments.

See Also

NotificationContext Class
Sitecore.Events Namespace


RaiseItemCopied Method

[image]

Sitecore 6.4.1 API
NotificationContext..::..RaiseItemCopied Method
NotificationContext Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RaiseItemCopied(
    Object sender,
    ItemCopiedEventArgs args
)
Visual Basic
Public Sub RaiseItemCopied ( _
    sender As Object, _
    args As ItemCopiedEventArgs _
)
Visual C++
public:
void RaiseItemCopied(
    Object^ sender,
    ItemCopiedEventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: Sitecore.Data.Events..::..ItemCopiedEventArgs
The arguments.

See Also

NotificationContext Class
Sitecore.Events Namespace


RaiseItemCreated Method

[image]

Sitecore 6.4.1 API
NotificationContext..::..RaiseItemCreated Method
NotificationContext Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RaiseItemCreated(
    Object sender,
    ItemCreatedEventArgs args
)
Visual Basic
Public Sub RaiseItemCreated ( _
    sender As Object, _
    args As ItemCreatedEventArgs _
)
Visual C++
public:
void RaiseItemCreated(
    Object^ sender,
    ItemCreatedEventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: Sitecore.Data.Events..::..ItemCreatedEventArgs
The arguments.

See Also

NotificationContext Class
Sitecore.Events Namespace


RaiseItemDeleted Method

[image]

Sitecore 6.4.1 API
NotificationContext..::..RaiseItemDeleted Method
NotificationContext Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RaiseItemDeleted(
    Object sender,
    ItemDeletedEventArgs args
)
Visual Basic
Public Sub RaiseItemDeleted ( _
    sender As Object, _
    args As ItemDeletedEventArgs _
)
Visual C++
public:
void RaiseItemDeleted(
    Object^ sender,
    ItemDeletedEventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: Sitecore.Data.Events..::..ItemDeletedEventArgs
The arguments.

See Also

NotificationContext Class
Sitecore.Events Namespace


RaiseItemMoved Method

[image]

Sitecore 6.4.1 API
NotificationContext..::..RaiseItemMoved Method
NotificationContext Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RaiseItemMoved(
    Object sender,
    ItemMovedEventArgs args
)
Visual Basic
Public Sub RaiseItemMoved ( _
    sender As Object, _
    args As ItemMovedEventArgs _
)
Visual C++
public:
void RaiseItemMoved(
    Object^ sender,
    ItemMovedEventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: Sitecore.Data.Events..::..ItemMovedEventArgs
The arguments.

See Also

NotificationContext Class
Sitecore.Events Namespace


RaiseItemRenamed Method

[image]

Sitecore 6.4.1 API
NotificationContext..::..RaiseItemRenamed Method
NotificationContext Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RaiseItemRenamed(
    Object sender,
    ItemRenamedEventArgs args
)
Visual Basic
Public Sub RaiseItemRenamed ( _
    sender As Object, _
    args As ItemRenamedEventArgs _
)
Visual C++
public:
void RaiseItemRenamed(
    Object^ sender,
    ItemRenamedEventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: Sitecore.Data.Events..::..ItemRenamedEventArgs
The arguments.

See Also

NotificationContext Class
Sitecore.Events Namespace


RaiseItemRenamedRemote Method

[image]

Sitecore 6.4.1 API
NotificationContext..::..RaiseItemRenamedRemote Method
NotificationContext Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RaiseItemRenamedRemote(
    Object sender,
    ItemSavedRemoteEventArgs args
)
Visual Basic
Public Sub RaiseItemRenamedRemote ( _
    sender As Object, _
    args As ItemSavedRemoteEventArgs _
)
Visual C++
public:
void RaiseItemRenamedRemote(
    Object^ sender,
    ItemSavedRemoteEventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: Sitecore.Data.Events..::..ItemSavedRemoteEventArgs
The ItemSavedRemoteEventArgs instance containing the event data.

See Also

NotificationContext Class
Sitecore.Events Namespace


RaiseItemSaved Method

[image]

Sitecore 6.4.1 API
NotificationContext..::..RaiseItemSaved Method
NotificationContext Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RaiseItemSaved(
    Object sender,
    ItemSavedEventArgs args
)
Visual Basic
Public Sub RaiseItemSaved ( _
    sender As Object, _
    args As ItemSavedEventArgs _
)
Visual C++
public:
void RaiseItemSaved(
    Object^ sender,
    ItemSavedEventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: Sitecore.Data.Events..::..ItemSavedEventArgs
The arguments.

See Also

NotificationContext Class
Sitecore.Events Namespace


RaiseItemSavedRemote Method

[image]

Sitecore 6.4.1 API
NotificationContext..::..RaiseItemSavedRemote Method
NotificationContext Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RaiseItemSavedRemote(
    Object sender,
    ItemSavedRemoteEventArgs args
)
Visual Basic
Public Sub RaiseItemSavedRemote ( _
    sender As Object, _
    args As ItemSavedRemoteEventArgs _
)
Visual C++
public:
void RaiseItemSavedRemote(
    Object^ sender,
    ItemSavedRemoteEventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: Sitecore.Data.Events..::..ItemSavedRemoteEventArgs
The ItemSavedRemoteEventArgs instance containing the event data.

See Also

NotificationContext Class
Sitecore.Events Namespace


RaiseItemSortorderChanged Method

[image]

Sitecore 6.4.1 API
NotificationContext..::..RaiseItemSortorderChanged Method
NotificationContext Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RaiseItemSortorderChanged(
    Object sender,
    ItemSortorderChangedEventArgs args
)
Visual Basic
Public Sub RaiseItemSortorderChanged ( _
    sender As Object, _
    args As ItemSortorderChangedEventArgs _
)
Visual C++
public:
void RaiseItemSortorderChanged(
    Object^ sender,
    ItemSortorderChangedEventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: Sitecore.Data.Events..::..ItemSortorderChangedEventArgs
The arguments.

See Also

NotificationContext Class
Sitecore.Events Namespace


RaiseItemSortorderChangedRemote Method

[image]

Sitecore 6.4.1 API
NotificationContext..::..RaiseItemSortorderChangedRemote Method
NotificationContext Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RaiseItemSortorderChangedRemote(
    Object sender,
    ItemSavedRemoteEventArgs args
)
Visual Basic
Public Sub RaiseItemSortorderChangedRemote ( _
    sender As Object, _
    args As ItemSavedRemoteEventArgs _
)
Visual C++
public:
void RaiseItemSortorderChangedRemote(
    Object^ sender,
    ItemSavedRemoteEventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: Sitecore.Data.Events..::..ItemSavedRemoteEventArgs
The ItemSavedRemoteEventArgs instance containing the event data.

See Also

NotificationContext Class
Sitecore.Events Namespace


RaiseVersionAdded Method

[image]

Sitecore 6.4.1 API
NotificationContext..::..RaiseVersionAdded Method
NotificationContext Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RaiseVersionAdded(
    Object sender,
    VersionAddedEventArgs args
)
Visual Basic
Public Sub RaiseVersionAdded ( _
    sender As Object, _
    args As VersionAddedEventArgs _
)
Visual C++
public:
void RaiseVersionAdded(
    Object^ sender,
    VersionAddedEventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: Sitecore.Data.Events..::..VersionAddedEventArgs
The arguments.

See Also

NotificationContext Class
Sitecore.Events Namespace


RaiseVersionRemoved Method

[image]

Sitecore 6.4.1 API
NotificationContext..::..RaiseVersionRemoved Method
NotificationContext Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void RaiseVersionRemoved(
    Object sender,
    VersionRemovedEventArgs args
)
Visual Basic
Public Sub RaiseVersionRemoved ( _
    sender As Object, _
    args As VersionRemovedEventArgs _
)
Visual C++
public:
void RaiseVersionRemoved(
    Object^ sender,
    VersionRemovedEventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: Sitecore.Events..::..VersionRemovedEventArgs
The arguments.

See Also

NotificationContext Class
Sitecore.Events Namespace


NotificationContext Properties

[image] [image]

Sitecore 6.4.1 API
NotificationContext Properties
NotificationContext Class See Also Send Feedback

The NotificationContext type exposes the following members.

Properties

 | Name | Description
Public property | Disabled | Gets or sets a value indicating whether this NotificationContext is disabled.

See Also

NotificationContext Class
Sitecore.Events Namespace


NotificationContext Events

[image] [image]

Sitecore 6.4.1 API
NotificationContext Events
NotificationContext Class See Also Send Feedback

The NotificationContext type exposes the following members.

Events

 | Name | Description
Public event | FieldSaved |
Public event | ItemAdded | Obsolete.
Public event | ItemChildrenChanged |
Public event | ItemCopied |
Public event | ItemCreated |
Public event | ItemDeleted |
Public event | ItemMoved |
Public event | ItemRenamed |
Public event | ItemRenamedRemote |
Public event | ItemSaved |
Public event | ItemSavedRemote |
Public event | ItemSortorderChanged |
Public event | ItemSortorderChangedRemote |
Public event | VersionAdded |
Public event | VersionRemoved |

See Also

NotificationContext Class
Sitecore.Events Namespace


ItemAdded Event

[image]

Sitecore 6.4.1 API
NotificationContext..::..ItemAdded Event
NotificationContext Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use the ItemCreatedDelegate event instead.")]
public event ItemAddedDelegate ItemAdded
Visual Basic
<ObsoleteAttribute("Use the ItemCreatedDelegate event instead.")> _
Public Event ItemAdded As ItemAddedDelegate
Visual C++
[ObsoleteAttribute(L"Use the ItemCreatedDelegate event instead.")]
public:
 event ItemAddedDelegate^ ItemAdded {
    void add (ItemAddedDelegate^ value);
    void remove (ItemAddedDelegate^ value);
}

See Also

NotificationContext Class
Sitecore.Events Namespace


ItemChildrenChanged Event

[image]

Sitecore 6.4.1 API
NotificationContext..::..ItemChildrenChanged Event
NotificationContext Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event ItemChildrenChangedDelegate ItemChildrenChanged
Visual Basic
Public Event ItemChildrenChanged As ItemChildrenChangedDelegate
Visual C++
public:
 event ItemChildrenChangedDelegate^ ItemChildrenChanged {
    void add (ItemChildrenChangedDelegate^ value);
    void remove (ItemChildrenChangedDelegate^ value);
}

See Also

NotificationContext Class
Sitecore.Events Namespace


ItemCopied Event

[image]

Sitecore 6.4.1 API
NotificationContext..::..ItemCopied Event
NotificationContext Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event ItemCopiedDelegate ItemCopied
Visual Basic
Public Event ItemCopied As ItemCopiedDelegate
Visual C++
public:
 event ItemCopiedDelegate^ ItemCopied {
    void add (ItemCopiedDelegate^ value);
    void remove (ItemCopiedDelegate^ value);
}

See Also

NotificationContext Class
Sitecore.Events Namespace


ItemDeleted Event

[image]

Sitecore 6.4.1 API
NotificationContext..::..ItemDeleted Event
NotificationContext Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event ItemDeletedDelegate ItemDeleted
Visual Basic
Public Event ItemDeleted As ItemDeletedDelegate
Visual C++
public:
 event ItemDeletedDelegate^ ItemDeleted {
    void add (ItemDeletedDelegate^ value);
    void remove (ItemDeletedDelegate^ value);
}

See Also

NotificationContext Class
Sitecore.Events Namespace


ItemMoved Event

[image]

Sitecore 6.4.1 API
NotificationContext..::..ItemMoved Event
NotificationContext Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event ItemMovedDelegate ItemMoved
Visual Basic
Public Event ItemMoved As ItemMovedDelegate
Visual C++
public:
 event ItemMovedDelegate^ ItemMoved {
    void add (ItemMovedDelegate^ value);
    void remove (ItemMovedDelegate^ value);
}

See Also

NotificationContext Class
Sitecore.Events Namespace


ItemRenamed Event

[image]

Sitecore 6.4.1 API
NotificationContext..::..ItemRenamed Event
NotificationContext Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event ItemRenamedDelegate ItemRenamed
Visual Basic
Public Event ItemRenamed As ItemRenamedDelegate
Visual C++
public:
 event ItemRenamedDelegate^ ItemRenamed {
    void add (ItemRenamedDelegate^ value);
    void remove (ItemRenamedDelegate^ value);
}

See Also

NotificationContext Class
Sitecore.Events Namespace


ItemRenamedRemote Event

[image]

Sitecore 6.4.1 API
NotificationContext..::..ItemRenamedRemote Event
NotificationContext Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler<ItemSavedRemoteEventArgs> ItemRenamedRemote
Visual Basic
Public Event ItemRenamedRemote As EventHandler(Of ItemSavedRemoteEventArgs)
Visual C++
public:
 event EventHandler<ItemSavedRemoteEventArgs^>^ ItemRenamedRemote {
    void add (EventHandler<ItemSavedRemoteEventArgs^>^ value);
    void remove (EventHandler<ItemSavedRemoteEventArgs^>^ value);
}

See Also

NotificationContext Class
Sitecore.Events Namespace


ItemSaved Event

[image]

Sitecore 6.4.1 API
NotificationContext..::..ItemSaved Event
NotificationContext Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event ItemSavedDelegate ItemSaved
Visual Basic
Public Event ItemSaved As ItemSavedDelegate
Visual C++
public:
 event ItemSavedDelegate^ ItemSaved {
    void add (ItemSavedDelegate^ value);
    void remove (ItemSavedDelegate^ value);
}

See Also

NotificationContext Class
Sitecore.Events Namespace


ItemSavedRemote Event

[image]

Sitecore 6.4.1 API
NotificationContext..::..ItemSavedRemote Event
NotificationContext Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler<ItemSavedRemoteEventArgs> ItemSavedRemote
Visual Basic
Public Event ItemSavedRemote As EventHandler(Of ItemSavedRemoteEventArgs)
Visual C++
public:
 event EventHandler<ItemSavedRemoteEventArgs^>^ ItemSavedRemote {
    void add (EventHandler<ItemSavedRemoteEventArgs^>^ value);
    void remove (EventHandler<ItemSavedRemoteEventArgs^>^ value);
}

See Also

NotificationContext Class
Sitecore.Events Namespace


ItemSortorderChanged Event

[image]

Sitecore 6.4.1 API
NotificationContext..::..ItemSortorderChanged Event
NotificationContext Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event ItemSortorderChangedDelegate ItemSortorderChanged
Visual Basic
Public Event ItemSortorderChanged As ItemSortorderChangedDelegate
Visual C++
public:
 event ItemSortorderChangedDelegate^ ItemSortorderChanged {
    void add (ItemSortorderChangedDelegate^ value);
    void remove (ItemSortorderChangedDelegate^ value);
}

See Also

NotificationContext Class
Sitecore.Events Namespace


ItemSortorderChangedRemote Event

[image]

Sitecore 6.4.1 API
NotificationContext..::..ItemSortorderChangedRemote Event
NotificationContext Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler<ItemSavedRemoteEventArgs> ItemSortorderChangedRemote
Visual Basic
Public Event ItemSortorderChangedRemote As EventHandler(Of ItemSavedRemoteEventArgs)
Visual C++
public:
 event EventHandler<ItemSavedRemoteEventArgs^>^ ItemSortorderChangedRemote {
    void add (EventHandler<ItemSavedRemoteEventArgs^>^ value);
    void remove (EventHandler<ItemSavedRemoteEventArgs^>^ value);
}

See Also

NotificationContext Class
Sitecore.Events Namespace


VersionAdded Event

[image]

Sitecore 6.4.1 API
NotificationContext..::..VersionAdded Event
NotificationContext Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event VersionAddedDelegate VersionAdded
Visual Basic
Public Event VersionAdded As VersionAddedDelegate
Visual C++
public:
 event VersionAddedDelegate^ VersionAdded {
    void add (VersionAddedDelegate^ value);
    void remove (VersionAddedDelegate^ value);
}

See Also

NotificationContext Class
Sitecore.Events Namespace


VersionRemoved Event

[image]

Sitecore 6.4.1 API
NotificationContext..::..VersionRemoved Event
NotificationContext Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event VersionRemovedDelegate VersionRemoved
Visual Basic
Public Event VersionRemoved As VersionRemovedDelegate
Visual C++
public:
 event VersionRemovedDelegate^ VersionRemoved {
    void add (VersionRemovedDelegate^ value);
    void remove (VersionRemovedDelegate^ value);
}

See Also

NotificationContext Class
Sitecore.Events Namespace


SitecoreEventArgs Class

[image]

Sitecore 6.4.1 API
SitecoreEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SitecoreEventArgs : EventArgs
Visual Basic
Public Class SitecoreEventArgs _
    Inherits EventArgs
Visual C++
public ref class SitecoreEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Events..::..SitecoreEventArgs

See Also

SitecoreEventArgs Members
Sitecore.Events Namespace


SitecoreEventArgs Members

[image] [image]

Sitecore 6.4.1 API
SitecoreEventArgs Members
SitecoreEventArgs Class Constructors Methods Properties See Also Send Feedback

The SitecoreEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | SitecoreEventArgs | Initializes a new instance of the SitecoreEventArgs class.

Methods

 | Name | Description
 | Cancel | Cancels this event.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDataManager | Gets the data manager.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID | Gets the ID.
 | GetItem | Gets the item.
 | GetObject | Gets the object.
 | GetString | Gets the string.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EventName | Gets the name of the event.
Public property | Parameters | Gets the parameters.
Public property | Result | Gets the result.

See Also

SitecoreEventArgs Class
Sitecore.Events Namespace


SitecoreEventArgs Constructor

[image]

Sitecore 6.4.1 API
SitecoreEventArgs Constructor
SitecoreEventArgs Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SitecoreEventArgs(
    string eventName,
    Object[] parameters,
    EventResult result
)
Visual Basic
Public Sub New ( _
    eventName As String, _
    parameters As Object(), _
    result As EventResult _
)
Visual C++
public:
SitecoreEventArgs(
    String^ eventName,
    array<Object^>^ parameters,
    EventResult^ result
)

Parameters

eventName
Type: System..::..String
Name of the event.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.
result
Type: Sitecore.Events..::..EventResult
The result.

See Also

SitecoreEventArgs Class
Sitecore.Events Namespace


SitecoreEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
SitecoreEventArgs Methods
SitecoreEventArgs Class See Also Send Feedback

The SitecoreEventArgs type exposes the following members.

Methods

 | Name | Description
 | Cancel | Cancels this event.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDataManager | Gets the data manager.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetID | Gets the ID.
 | GetItem | Gets the item.
 | GetObject | Gets the object.
 | GetString | Gets the string.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SitecoreEventArgs Class
Sitecore.Events Namespace


Cancel Method

[image]

Sitecore 6.4.1 API
SitecoreEventArgs..::..Cancel Method
SitecoreEventArgs Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Cancel(
    EventArgs args
)
Visual Basic
Public Shared Sub Cancel ( _
    args As EventArgs _
)
Visual C++
public:
static void Cancel(
    EventArgs^ args
)

Parameters

args
Type: System..::..EventArgs
The arguments.

See Also

SitecoreEventArgs Class
Sitecore.Events Namespace


GetDataManager Method

[image]

Sitecore 6.4.1 API
SitecoreEventArgs..::..GetDataManager Method
SitecoreEventArgs Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static DataManager GetDataManager(
    EventArgs args,
    int index
)
Visual Basic
Public Shared Function GetDataManager ( _
    args As EventArgs, _
    index As Integer _
) As DataManager
Visual C++
public:
static DataManager^ GetDataManager(
    EventArgs^ args,
    int index
)

Parameters

args
Type: System..::..EventArgs
The arguments.
index
Type: System..::..Int32
The index.

Return Value

The DataManager.

See Also

SitecoreEventArgs Class
Sitecore.Events Namespace


GetItem Method

[image]

Sitecore 6.4.1 API
SitecoreEventArgs..::..GetItem Method
SitecoreEventArgs Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item GetItem(
    EventArgs args,
    int index
)
Visual Basic
Public Shared Function GetItem ( _
    args As EventArgs, _
    index As Integer _
) As Item
Visual C++
public:
static Item^ GetItem(
    EventArgs^ args,
    int index
)

Parameters

args
Type: System..::..EventArgs
The arguments.
index
Type: System..::..Int32
The index.

Return Value

The Item.

See Also

SitecoreEventArgs Class
Sitecore.Events Namespace


GetObject Method

[image]

Sitecore 6.4.1 API
SitecoreEventArgs..::..GetObject Method
SitecoreEventArgs Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object GetObject(
    EventArgs args,
    int index
)
Visual Basic
Public Shared Function GetObject ( _
    args As EventArgs, _
    index As Integer _
) As Object
Visual C++
public:
static Object^ GetObject(
    EventArgs^ args,
    int index
)

Parameters

args
Type: System..::..EventArgs
The arguments.
index
Type: System..::..Int32
The index.

Return Value

The Object.

See Also

SitecoreEventArgs Class
Sitecore.Events Namespace


GetString Method

[image]

Sitecore 6.4.1 API
SitecoreEventArgs..::..GetString Method
SitecoreEventArgs Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetString(
    EventArgs args,
    int index
)
Visual Basic
Public Shared Function GetString ( _
    args As EventArgs, _
    index As Integer _
) As String
Visual C++
public:
static String^ GetString(
    EventArgs^ args,
    int index
)

Parameters

args
Type: System..::..EventArgs
The arguments.
index
Type: System..::..Int32
The index.

Return Value

The String.

See Also

SitecoreEventArgs Class
Sitecore.Events Namespace


SitecoreEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
SitecoreEventArgs Properties
SitecoreEventArgs Class See Also Send Feedback

The SitecoreEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | EventName | Gets the name of the event.
Public property | Parameters | Gets the parameters.
Public property | Result | Gets the result.

See Also

SitecoreEventArgs Class
Sitecore.Events Namespace


EventName Property

[image]

Sitecore 6.4.1 API
SitecoreEventArgs..::..EventName Property
SitecoreEventArgs Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string EventName { get; }
Visual Basic
Public ReadOnly Property EventName As String
    Get
Visual C++
public:
property String^ EventName {
    String^ get ();
}

Field Value

The name of the event.

See Also

SitecoreEventArgs Class
Sitecore.Events Namespace


Parameters Property

[image]

Sitecore 6.4.1 API
SitecoreEventArgs..::..Parameters Property
SitecoreEventArgs Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object[] Parameters { get; }
Visual Basic
Public ReadOnly Property Parameters As Object()
    Get
Visual C++
public:
property array<Object^>^ Parameters {
    array<Object^>^ get ();
}

Field Value

The parameters.

See Also

SitecoreEventArgs Class
Sitecore.Events Namespace


Result Property

[image]

Sitecore 6.4.1 API
SitecoreEventArgs..::..Result Property
SitecoreEventArgs Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public EventResult Result { get; }
Visual Basic
Public ReadOnly Property Result As EventResult
    Get
Visual C++
public:
property EventResult^ Result {
    EventResult^ get ();
}

Field Value

The result.

See Also

SitecoreEventArgs Class
Sitecore.Events Namespace


TemplateUpdatedEventArgs Class

[image]

Sitecore 6.4.1 API
TemplateUpdatedEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class TemplateUpdatedEventArgs : EventArgs
Visual Basic
Public Class TemplateUpdatedEventArgs _
    Inherits EventArgs
Visual C++
public ref class TemplateUpdatedEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Events..::..TemplateUpdatedEventArgs

See Also

TemplateUpdatedEventArgs Members
Sitecore.Events Namespace


TemplateUpdatedEventArgs Members

[image] [image]

Sitecore 6.4.1 API
TemplateUpdatedEventArgs Members
TemplateUpdatedEventArgs Class Constructors Methods Properties See Also Send Feedback

The TemplateUpdatedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | TemplateUpdatedEventArgs | Initializes a new instance of the TemplateUpdatedEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ItemID | Gets the item ID.

See Also

TemplateUpdatedEventArgs Class
Sitecore.Events Namespace


TemplateUpdatedEventArgs Constructor

[image]

Sitecore 6.4.1 API
TemplateUpdatedEventArgs Constructor
TemplateUpdatedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateUpdatedEventArgs(
    ID itemID
)
Visual Basic
Public Sub New ( _
    itemID As ID _
)
Visual C++
public:
TemplateUpdatedEventArgs(
    ID^ itemID
)

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.

See Also

TemplateUpdatedEventArgs Class
Sitecore.Events Namespace


TemplateUpdatedEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
TemplateUpdatedEventArgs Properties
TemplateUpdatedEventArgs Class See Also Send Feedback

The TemplateUpdatedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ItemID | Gets the item ID.

See Also

TemplateUpdatedEventArgs Class
Sitecore.Events Namespace


ItemID Property

[image]

Sitecore 6.4.1 API
TemplateUpdatedEventArgs..::..ItemID Property
TemplateUpdatedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ItemID { get; }
Visual Basic
Public ReadOnly Property ItemID As ID
    Get
Visual C++
public:
property ID^ ItemID {
    ID^ get ();
}

Field Value

The item ID.

See Also

TemplateUpdatedEventArgs Class
Sitecore.Events Namespace


VersionRemovedEventArgs Class

[image]

Sitecore 6.4.1 API
VersionRemovedEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class VersionRemovedEventArgs : CancelEventArgs
Visual Basic
Public Class VersionRemovedEventArgs _
    Inherits CancelEventArgs
Visual C++
public ref class VersionRemovedEventArgs : public CancelEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..CancelEventArgs
Sitecore.Events..::..VersionRemovedEventArgs

See Also

VersionRemovedEventArgs Members
Sitecore.Events Namespace


VersionRemovedEventArgs Members

[image] [image]

Sitecore 6.4.1 API
VersionRemovedEventArgs Members
VersionRemovedEventArgs Class Constructors Methods Properties See Also Send Feedback

The VersionRemovedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | VersionRemovedEventArgs | Creates a new VersionRemovedEventArgs instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | Item | Gets the item.

See Also

VersionRemovedEventArgs Class
Sitecore.Events Namespace


VersionRemovedEventArgs Constructor

[image]

Sitecore 6.4.1 API
VersionRemovedEventArgs Constructor
VersionRemovedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public VersionRemovedEventArgs(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
VersionRemovedEventArgs(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
Item.

See Also

VersionRemovedEventArgs Class
Sitecore.Events Namespace


VersionRemovedEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
VersionRemovedEventArgs Methods
VersionRemovedEventArgs Class See Also Send Feedback

The VersionRemovedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VersionRemovedEventArgs Class
Sitecore.Events Namespace


VersionRemovedEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
VersionRemovedEventArgs Properties
VersionRemovedEventArgs Class See Also Send Feedback

The VersionRemovedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | Item | Gets the item.

See Also

VersionRemovedEventArgs Class
Sitecore.Events Namespace


Item Property

[image]

Sitecore 6.4.1 API
VersionRemovedEventArgs..::..Item Property
VersionRemovedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Item { get; }
Visual Basic
Public ReadOnly Property Item As Item
    Get
Visual C++
public:
property Item^ Item {
    Item^ get ();
}

Field Value

The item.

See Also

VersionRemovedEventArgs Class
Sitecore.Events Namespace


WellknownEvents Class

[image]

Sitecore 6.4.1 API
WellknownEvents Class
Members See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class WellknownEvents
Visual Basic
Public Class WellknownEvents
Visual C++
public ref class WellknownEvents

Inheritance Hierarchy

System..::..Object
Sitecore.Events..::..WellknownEvents

See Also

WellknownEvents Members
Sitecore.Events Namespace


WellknownEvents Members

[image] [image]

Sitecore 6.4.1 API
WellknownEvents Members
WellknownEvents Class Constructors Methods Fields See Also Send Feedback

The WellknownEvents type exposes the following members.

Constructors

 | Name | Description
Public method | WellknownEvents | Initializes a new instance of the WellknownEvents class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ItemTemplateChanged |

See Also

WellknownEvents Class
Sitecore.Events Namespace


WellknownEvents Constructor

[image]

Sitecore 6.4.1 API
WellknownEvents Constructor
WellknownEvents Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WellknownEvents()
Visual Basic
Public Sub New
Visual C++
public:
WellknownEvents()

See Also

WellknownEvents Class
Sitecore.Events Namespace


WellknownEvents Fields

[image] [image]

Sitecore 6.4.1 API
WellknownEvents Fields
WellknownEvents Class See Also Send Feedback

The WellknownEvents type exposes the following members.

Fields

Name | Description
ItemTemplateChanged |

See Also

WellknownEvents Class
Sitecore.Events Namespace


ItemTemplateChanged Field

[image]

Sitecore 6.4.1 API
WellknownEvents..::..ItemTemplateChanged Field
WellknownEvents Class See Also Send Feedback

Namespace: Sitecore.Events
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string ItemTemplateChanged
Visual Basic
Public Const ItemTemplateChanged As String
Visual C++
public:
literal String^ ItemTemplateChanged

See Also

WellknownEvents Class
Sitecore.Events Namespace


WellknownEvents Methods

[image] [image]

Sitecore 6.4.1 API
WellknownEvents Methods
WellknownEvents Class See Also Send Feedback

The WellknownEvents type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WellknownEvents Class
Sitecore.Events Namespace


Sitecore.Events.Hooks Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Events.Hooks Namespace
Send Feedback

Classes

 | Class | Description
Public class | HookManager | Represents a hook manager.

Interfaces

 | Interface | Description
Public interface | IHook | Defines the basic methods of a hook.


HookManager Class

[image]

Sitecore 6.4.1 API
HookManager Class
Members See Also Send Feedback

Namespace: Sitecore.Events.Hooks
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class HookManager
Visual Basic
Public NotInheritable Class HookManager
Visual C++
public ref class HookManager abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Events.Hooks..::..HookManager

See Also

HookManager Members
Sitecore.Events.Hooks Namespace


HookManager Members

[image] [image]

Sitecore 6.4.1 API
HookManager Members
HookManager Class Methods See Also Send Feedback

The HookManager type exposes the following members.

Methods

Name | Description
LoadAll | Loads all.

See Also

HookManager Class
Sitecore.Events.Hooks Namespace


HookManager Methods

[image] [image]

Sitecore 6.4.1 API
HookManager Methods
HookManager Class See Also Send Feedback

The HookManager type exposes the following members.

Methods

Name | Description
LoadAll | Loads all.

See Also

HookManager Class
Sitecore.Events.Hooks Namespace


LoadAll Method

[image]

Sitecore 6.4.1 API
HookManager..::..LoadAll Method
HookManager Class See Also Send Feedback

Namespace: Sitecore.Events.Hooks
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void LoadAll()
Visual Basic
Public Shared Sub LoadAll
Visual C++
public:
static void LoadAll()

See Also

HookManager Class
Sitecore.Events.Hooks Namespace


IHook Interface

[image]

Sitecore 6.4.1 API
IHook Interface
Members See Also Send Feedback

Namespace: Sitecore.Events.Hooks
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IHook
Visual Basic
Public Interface IHook
Visual C++
public interface class IHook

See Also

IHook Members
Sitecore.Events.Hooks Namespace


IHook Members

[image] [image]

Sitecore 6.4.1 API
IHook Members
IHook Interface Methods See Also Send Feedback

The IHook type exposes the following members.

Methods

 | Name | Description
Public method | Initialize | Initializes this instance.

See Also

IHook Interface
Sitecore.Events.Hooks Namespace


IHook Methods

[image] [image]

Sitecore 6.4.1 API
IHook Methods
IHook Interface See Also Send Feedback

The IHook type exposes the following members.

Methods

 | Name | Description
Public method | Initialize | Initializes this instance.

See Also

IHook Interface
Sitecore.Events.Hooks Namespace


Sitecore.Exceptions Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Exceptions Namespace
Send Feedback

Classes

 | Class | Description
Public class | AccessDeniedException | Represents a AccessDenied exception.
Public class | CircularReferenceException | Represents a circular reference exception.
Public class | ClientAlertException | Represents a client alert exception. Throwing such an exception in SheerUI code will display an alert to the user.
Public class | ClientExceptionAttribute | Defines how the exception is displayed in the client.
Public class | ConfigurationException | ConfigurationException
Public class | ControlNotFoundException | Represents a control not found exception.
Public class | CyclicSublayoutException | CyclicSublayoutException
Public class | DatabaseNullException | Represents a item not found exception.
Public class | DomainException | DomainException
Public class | DomainExistsException | DomainExistsException
Public class | EditingNotAllowedException | Represents a editing not allowed exception.
Public class | InvalidItemException | Represents a invalid item exception.
Public class | InvalidItemNameException | Represents a invalid item name exception.
Public class | InvalidStructureException | Represents a invalid structure exception.
Public class | InvalidTypeException | InvalidTypeException
Public class | InvalidValueException | Represents a invalid value exception.
Public class | ItemNotFoundException | Represents a item not found exception.
Public class | ItemNullException | Represents a item not found exception.
Public class | LoadOnlyPropertyException | Represents a load only property exception.
Public class | LookupSourceException | Represents the lookup source exception
Public class | MediaException | General Media Exception.
Public class | MediaIsNotModifiedException | Media is Not modified exception.
Public class | PipelineException | PipelineException class
Public class | ProviderConfigurationException | ProviderConfigurationException
Public class | ProviderIsReadOnlyException | ProviderIsReadOnlyException
Public class | QueryException | Represents a query exception.
Public class | ReflectionException | ReflectionException
Public class | RequiredObjectIsNullException | Represents a required object is null exception.
Public class | SecurityException | Security Exception.
Public class | SitecoreException | Defines the basic properties and functionality of a Sitecore exception.
Public class | SyndicationException | Represents the syndication exception
Public class | SyndicationUrlHashMismatchException | Represents the syndication exception
Public class | TemplateNotFoundException | Represents a template not found exception.
Public class | TicketParseException | Represents a ticket parse exception.
Public class | TodoException | TodoException class
Public class | UnknownDomainException | UnknownDomainException
Public class | UnknownTypeException | Represents a unknown type exception.
Public class | UnsupportedThumbnailImageFormatException | Represents a unsupported thumbnail image format exception.
Public class | WorkflowException | Represents a workflow exception.
Public class | WorkflowInitialStateMissingException | Thrown if worfklow misses an initial state.
Public class | WorkflowStateMissingException | Represents a Workflow State Missing exception.


AccessDeniedException Class

[image]

Sitecore 6.4.1 API
AccessDeniedException Class
Members See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class AccessDeniedException : SitecoreException
Visual Basic
<SerializableAttribute> _
Public Class AccessDeniedException _
    Inherits SitecoreException
Visual C++
[SerializableAttribute]
public ref class AccessDeniedException : public SitecoreException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Exceptions..::..SitecoreException
Sitecore.Exceptions..::..AccessDeniedException

See Also

AccessDeniedException Members
Sitecore.Exceptions Namespace


AccessDeniedException Members

[image] [image]

Sitecore 6.4.1 API
AccessDeniedException Members
AccessDeniedException Class Constructors Methods Properties See Also Send Feedback

The AccessDeniedException type exposes the following members.

Constructors

 | Name | Description
Public method | AccessDeniedException()()()() | Initializes a new instance of the AccessDeniedException class.
Public method | AccessDeniedException(String) | Initializes a new instance of the AccessDeniedException class.
Public method | AccessDeniedException(String, Exception) | Initializes a new instance of the AccessDeniedException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

AccessDeniedException Class
Sitecore.Exceptions Namespace


AccessDeniedException Constructor

[image] [image]

Sitecore 6.4.1 API
AccessDeniedException Constructor
AccessDeniedException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AccessDeniedException()()()() | Initializes a new instance of the AccessDeniedException class.
Public method | AccessDeniedException(String) | Initializes a new instance of the AccessDeniedException class.
Public method | AccessDeniedException(String, Exception) | Initializes a new instance of the AccessDeniedException class.

See Also

AccessDeniedException Class
AccessDeniedException Members
Sitecore.Exceptions Namespace


AccessDeniedException Constructor

[image]

Sitecore 6.4.1 API
AccessDeniedException Constructor
AccessDeniedException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AccessDeniedException()
Visual Basic
Public Sub New
Visual C++
public:
AccessDeniedException()

See Also

AccessDeniedException Class
AccessDeniedException Overload
Sitecore.Exceptions Namespace


AccessDeniedException Constructor (String)

[image]

Sitecore 6.4.1 API
AccessDeniedException Constructor (String)
AccessDeniedException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AccessDeniedException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
AccessDeniedException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

AccessDeniedException Class
AccessDeniedException Overload
Sitecore.Exceptions Namespace


AccessDeniedException Constructor (String, Exception)

[image]

Sitecore 6.4.1 API
AccessDeniedException Constructor (String, Exception)
AccessDeniedException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AccessDeniedException(
    string message,
    Exception innnerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innnerException As Exception _
)
Visual C++
public:
AccessDeniedException(
    String^ message,
    Exception^ innnerException
)

Parameters

message
Type: System..::..String
The message.
innnerException
Type: System..::..Exception
The innner exception.

See Also

AccessDeniedException Class
AccessDeniedException Overload
Sitecore.Exceptions Namespace


AccessDeniedException Methods

[image] [image]

Sitecore 6.4.1 API
AccessDeniedException Methods
AccessDeniedException Class See Also Send Feedback

The AccessDeniedException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

AccessDeniedException Class
Sitecore.Exceptions Namespace


CircularReferenceException Class

[image]

Sitecore 6.4.1 API
CircularReferenceException Class
Members See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class CircularReferenceException : SitecoreException
Visual Basic
<SerializableAttribute> _
Public Class CircularReferenceException _
    Inherits SitecoreException
Visual C++
[SerializableAttribute]
public ref class CircularReferenceException : public SitecoreException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Exceptions..::..SitecoreException
Sitecore.Exceptions..::..CircularReferenceException

See Also

CircularReferenceException Members
Sitecore.Exceptions Namespace


CircularReferenceException Members

[image] [image]

Sitecore 6.4.1 API
CircularReferenceException Members
CircularReferenceException Class Constructors Methods Properties See Also Send Feedback

The CircularReferenceException type exposes the following members.

Constructors

 | Name | Description
Public method | CircularReferenceException()()()() | Initializes a new instance of the CircularReferenceException class.
Public method | CircularReferenceException(String) | Initializes a new instance of the CircularReferenceException class.
Public method | CircularReferenceException(String, Exception) | Initializes a new instance of the CircularReferenceException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CircularReferenceException Class
Sitecore.Exceptions Namespace


CircularReferenceException Constructor

[image] [image]

Sitecore 6.4.1 API
CircularReferenceException Constructor
CircularReferenceException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CircularReferenceException()()()() | Initializes a new instance of the CircularReferenceException class.
Public method | CircularReferenceException(String) | Initializes a new instance of the CircularReferenceException class.
Public method | CircularReferenceException(String, Exception) | Initializes a new instance of the CircularReferenceException class.

See Also

CircularReferenceException Class
CircularReferenceException Members
Sitecore.Exceptions Namespace


CircularReferenceException Constructor

[image]

Sitecore 6.4.1 API
CircularReferenceException Constructor
CircularReferenceException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CircularReferenceException()
Visual Basic
Public Sub New
Visual C++
public:
CircularReferenceException()

See Also

CircularReferenceException Class
CircularReferenceException Overload
Sitecore.Exceptions Namespace


CircularReferenceException Constructor (String)

[image]

Sitecore 6.4.1 API
CircularReferenceException Constructor (String)
CircularReferenceException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CircularReferenceException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
CircularReferenceException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

CircularReferenceException Class
CircularReferenceException Overload
Sitecore.Exceptions Namespace


CircularReferenceException Methods

[image] [image]

Sitecore 6.4.1 API
CircularReferenceException Methods
CircularReferenceException Class See Also Send Feedback

The CircularReferenceException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

CircularReferenceException Class
Sitecore.Exceptions Namespace


CircularReferenceException Properties

[image] [image]

Sitecore 6.4.1 API
CircularReferenceException Properties
CircularReferenceException Class See Also Send Feedback

The CircularReferenceException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CircularReferenceException Class
Sitecore.Exceptions Namespace


ClientAlertException Members

[image] [image]

Sitecore 6.4.1 API
ClientAlertException Members
ClientAlertException Class Constructors Methods Properties See Also Send Feedback

The ClientAlertException type exposes the following members.

Constructors

 | Name | Description
Public method | ClientAlertException | Initializes a new instance of the ClientAlertException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ClientAlertException Class
Sitecore.Exceptions Namespace


ClientAlertException Constructor

[image]

Sitecore 6.4.1 API
ClientAlertException Constructor
ClientAlertException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ClientAlertException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
ClientAlertException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

ClientAlertException Class
Sitecore.Exceptions Namespace


ClientAlertException Methods

[image] [image]

Sitecore 6.4.1 API
ClientAlertException Methods
ClientAlertException Class See Also Send Feedback

The ClientAlertException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ClientAlertException Class
Sitecore.Exceptions Namespace


ClientAlertException Properties

[image] [image]

Sitecore 6.4.1 API
ClientAlertException Properties
ClientAlertException Class See Also Send Feedback

The ClientAlertException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ClientAlertException Class
Sitecore.Exceptions Namespace


ClientExceptionAttribute Class

[image]

Sitecore 6.4.1 API
ClientExceptionAttribute Class
Members See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public sealed class ClientExceptionAttribute : Attribute
Visual Basic
Public NotInheritable Class ClientExceptionAttribute _
    Inherits Attribute
Visual C++
public ref class ClientExceptionAttribute sealed : public Attribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Sitecore.Exceptions..::..ClientExceptionAttribute

See Also

ClientExceptionAttribute Members
Sitecore.Exceptions Namespace


ClientExceptionAttribute Members

[image] [image]

Sitecore 6.4.1 API
ClientExceptionAttribute Members
ClientExceptionAttribute Class Constructors Methods Properties See Also Send Feedback

The ClientExceptionAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | ClientExceptionAttribute()()()() | Initializes a new instance of the ClientExceptionAttribute class.
Public method | ClientExceptionAttribute(Boolean) | Initializes a new instance of the ClientExceptionAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Alert | Gets or sets a value indicating whether this ClientExceptionAttribute is an alert.
Public property | Reload | Gets or sets a value indicating whether this ClientExceptionAttribute causes the client to reload.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

ClientExceptionAttribute Class
Sitecore.Exceptions Namespace


ClientExceptionAttribute Constructor

[image] [image]

Sitecore 6.4.1 API
ClientExceptionAttribute Constructor
ClientExceptionAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ClientExceptionAttribute()()()() | Initializes a new instance of the ClientExceptionAttribute class.
Public method | ClientExceptionAttribute(Boolean) | Initializes a new instance of the ClientExceptionAttribute class.

See Also

ClientExceptionAttribute Class
ClientExceptionAttribute Members
Sitecore.Exceptions Namespace


ClientExceptionAttribute Constructor

[image]

Sitecore 6.4.1 API
ClientExceptionAttribute Constructor
ClientExceptionAttribute Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ClientExceptionAttribute()
Visual Basic
Public Sub New
Visual C++
public:
ClientExceptionAttribute()

See Also

ClientExceptionAttribute Class
ClientExceptionAttribute Overload
Sitecore.Exceptions Namespace


ClientExceptionAttribute Constructor (Boolean)

[image]

Sitecore 6.4.1 API
ClientExceptionAttribute Constructor (Boolean)
ClientExceptionAttribute Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ClientExceptionAttribute(
    bool alert
)
Visual Basic
Public Sub New ( _
    alert As Boolean _
)
Visual C++
public:
ClientExceptionAttribute(
    bool alert
)

Parameters

alert
Type: System..::..Boolean
if set to true this instance is alert.

See Also

ClientExceptionAttribute Class
ClientExceptionAttribute Overload
Sitecore.Exceptions Namespace


ClientExceptionAttribute Methods

[image] [image]

Sitecore 6.4.1 API
ClientExceptionAttribute Methods
ClientExceptionAttribute Class See Also Send Feedback

The ClientExceptionAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ClientExceptionAttribute Class
Sitecore.Exceptions Namespace


ClientExceptionAttribute Properties

[image] [image]

Sitecore 6.4.1 API
ClientExceptionAttribute Properties
ClientExceptionAttribute Class See Also Send Feedback

The ClientExceptionAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Alert | Gets or sets a value indicating whether this ClientExceptionAttribute is an alert.
Public property | Reload | Gets or sets a value indicating whether this ClientExceptionAttribute causes the client to reload.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

ClientExceptionAttribute Class
Sitecore.Exceptions Namespace


Alert Property

[image]

Sitecore 6.4.1 API
ClientExceptionAttribute..::..Alert Property
ClientExceptionAttribute Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Alert { get; set; }
Visual Basic
Public Property Alert As Boolean
    Get
    Set
Visual C++
public:
property bool Alert {
    bool get ();
    void set (bool value);
}

Field Value

true if alert; otherwise, false.

See Also

ClientExceptionAttribute Class
Sitecore.Exceptions Namespace


Reload Property

[image]

Sitecore 6.4.1 API
ClientExceptionAttribute..::..Reload Property
ClientExceptionAttribute Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Reload { get; set; }
Visual Basic
Public Property Reload As Boolean
    Get
    Set
Visual C++
public:
property bool Reload {
    bool get ();
    void set (bool value);
}

Field Value

true if reload; otherwise, false.

See Also

ClientExceptionAttribute Class
Sitecore.Exceptions Namespace


ConfigurationException Class

[image]

Sitecore 6.4.1 API
ConfigurationException Class
Members See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class ConfigurationException : SitecoreException
Visual Basic
<SerializableAttribute> _
Public Class ConfigurationException _
    Inherits SitecoreException
Visual C++
[SerializableAttribute]
public ref class ConfigurationException : public SitecoreException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Exceptions..::..SitecoreException
Sitecore.Exceptions..::..ConfigurationException

See Also

ConfigurationException Members
Sitecore.Exceptions Namespace


ConfigurationException Members

[image] [image]

Sitecore 6.4.1 API
ConfigurationException Members
ConfigurationException Class Constructors Methods Properties See Also Send Feedback

The ConfigurationException type exposes the following members.

Constructors

 | Name | Description
Public method | ConfigurationException(String) | Initializes a new instance of the ConfigurationException class.
Public method | ConfigurationException(String, Exception) | Initializes a new instance of the ConfigurationException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ConfigurationException Class
Sitecore.Exceptions Namespace


ConfigurationException Constructor

[image] [image]

Sitecore 6.4.1 API
ConfigurationException Constructor
ConfigurationException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ConfigurationException(String) | Initializes a new instance of the ConfigurationException class.
Public method | ConfigurationException(String, Exception) | Initializes a new instance of the ConfigurationException class.

See Also

ConfigurationException Class
ConfigurationException Members
Sitecore.Exceptions Namespace


ConfigurationException Constructor (String)

[image]

Sitecore 6.4.1 API
ConfigurationException Constructor (String)
ConfigurationException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ConfigurationException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
ConfigurationException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

ConfigurationException Class
ConfigurationException Overload
Sitecore.Exceptions Namespace


ConfigurationException Constructor (String, Exception)

[image]

Sitecore 6.4.1 API
ConfigurationException Constructor (String, Exception)
ConfigurationException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ConfigurationException(
    string message,
    Exception innnerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innnerException As Exception _
)
Visual C++
public:
ConfigurationException(
    String^ message,
    Exception^ innnerException
)

Parameters

message
Type: System..::..String
The message.
innnerException
Type: System..::..Exception
The innner exception.

See Also

ConfigurationException Class
ConfigurationException Overload
Sitecore.Exceptions Namespace


ConfigurationException Methods

[image] [image]

Sitecore 6.4.1 API
ConfigurationException Methods
ConfigurationException Class See Also Send Feedback

The ConfigurationException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ConfigurationException Class
Sitecore.Exceptions Namespace


ConfigurationException Properties

[image] [image]

Sitecore 6.4.1 API
ConfigurationException Properties
ConfigurationException Class See Also Send Feedback

The ConfigurationException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ConfigurationException Class
Sitecore.Exceptions Namespace


ControlNotFoundException Class

[image]

Sitecore 6.4.1 API
ControlNotFoundException Class
Members See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class ControlNotFoundException : SitecoreException
Visual Basic
<SerializableAttribute> _
Public Class ControlNotFoundException _
    Inherits SitecoreException
Visual C++
[SerializableAttribute]
public ref class ControlNotFoundException : public SitecoreException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Exceptions..::..SitecoreException
Sitecore.Exceptions..::..ControlNotFoundException

See Also

ControlNotFoundException Members
Sitecore.Exceptions Namespace


ControlNotFoundException Members

[image] [image]

Sitecore 6.4.1 API
ControlNotFoundException Members
ControlNotFoundException Class Constructors Methods Properties See Also Send Feedback

The ControlNotFoundException type exposes the following members.

Constructors

 | Name | Description
Public method | ControlNotFoundException | Initializes a new instance of the ControlNotFoundException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ControlNotFoundException Class
Sitecore.Exceptions Namespace


ControlNotFoundException Constructor

[image]

Sitecore 6.4.1 API
ControlNotFoundException Constructor
ControlNotFoundException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ControlNotFoundException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
ControlNotFoundException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

ControlNotFoundException Class
Sitecore.Exceptions Namespace


ControlNotFoundException Properties

[image] [image]

Sitecore 6.4.1 API
ControlNotFoundException Properties
ControlNotFoundException Class See Also Send Feedback

The ControlNotFoundException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ControlNotFoundException Class
Sitecore.Exceptions Namespace


CyclicSublayoutException Class

[image]

Sitecore 6.4.1 API
CyclicSublayoutException Class
Members See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class CyclicSublayoutException : SitecoreException
Visual Basic
<SerializableAttribute> _
Public Class CyclicSublayoutException _
    Inherits SitecoreException
Visual C++
[SerializableAttribute]
public ref class CyclicSublayoutException : public SitecoreException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Exceptions..::..SitecoreException
Sitecore.Exceptions..::..CyclicSublayoutException

See Also

CyclicSublayoutException Members
Sitecore.Exceptions Namespace


CyclicSublayoutException Members

[image] [image]

Sitecore 6.4.1 API
CyclicSublayoutException Members
CyclicSublayoutException Class Constructors Methods Properties See Also Send Feedback

The CyclicSublayoutException type exposes the following members.

Constructors

 | Name | Description
Public method | CyclicSublayoutException | Initializes a new instance of the CyclicSublayoutException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CyclicSublayoutException Class
Sitecore.Exceptions Namespace


CyclicSublayoutException Constructor

[image]

Sitecore 6.4.1 API
CyclicSublayoutException Constructor
CyclicSublayoutException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CyclicSublayoutException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
CyclicSublayoutException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

CyclicSublayoutException Class
Sitecore.Exceptions Namespace


CyclicSublayoutException Methods

[image] [image]

Sitecore 6.4.1 API
CyclicSublayoutException Methods
CyclicSublayoutException Class See Also Send Feedback

The CyclicSublayoutException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

CyclicSublayoutException Class
Sitecore.Exceptions Namespace


CyclicSublayoutException Properties

[image] [image]

Sitecore 6.4.1 API
CyclicSublayoutException Properties
CyclicSublayoutException Class See Also Send Feedback

The CyclicSublayoutException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CyclicSublayoutException Class
Sitecore.Exceptions Namespace


DatabaseNullException Class

[image]

Sitecore 6.4.1 API
DatabaseNullException Class
Members See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class DatabaseNullException : SitecoreException
Visual Basic
<SerializableAttribute> _
Public Class DatabaseNullException _
    Inherits SitecoreException
Visual C++
[SerializableAttribute]
public ref class DatabaseNullException : public SitecoreException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Exceptions..::..SitecoreException
Sitecore.Exceptions..::..DatabaseNullException

See Also

DatabaseNullException Members
Sitecore.Exceptions Namespace


DatabaseNullException Members

[image] [image]

Sitecore 6.4.1 API
DatabaseNullException Members
DatabaseNullException Class Constructors Methods Properties See Also Send Feedback

The DatabaseNullException type exposes the following members.

Constructors

 | Name | Description
Public method | DatabaseNullException()()()() | Initializes a new instance of the ItemNotFoundException class.
Public method | DatabaseNullException(String) | Initializes a new instance of the ItemNotFoundException class.
Public method | DatabaseNullException(String, Exception) | Initializes a new instance of the ItemNotFoundException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DatabaseNullException Class
Sitecore.Exceptions Namespace


DatabaseNullException Constructor

[image] [image]

Sitecore 6.4.1 API
DatabaseNullException Constructor
DatabaseNullException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DatabaseNullException()()()() | Initializes a new instance of the ItemNotFoundException class.
Public method | DatabaseNullException(String) | Initializes a new instance of the ItemNotFoundException class.
Public method | DatabaseNullException(String, Exception) | Initializes a new instance of the ItemNotFoundException class.

See Also

DatabaseNullException Class
DatabaseNullException Members
Sitecore.Exceptions Namespace


DatabaseNullException Constructor

[image]

Sitecore 6.4.1 API
DatabaseNullException Constructor
DatabaseNullException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DatabaseNullException()
Visual Basic
Public Sub New
Visual C++
public:
DatabaseNullException()

See Also

DatabaseNullException Class
DatabaseNullException Overload
Sitecore.Exceptions Namespace


DatabaseNullException Constructor (String)

[image]

Sitecore 6.4.1 API
DatabaseNullException Constructor (String)
DatabaseNullException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DatabaseNullException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
DatabaseNullException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

DatabaseNullException Class
DatabaseNullException Overload
Sitecore.Exceptions Namespace


DatabaseNullException Constructor (String, Exception)

[image]

Sitecore 6.4.1 API
DatabaseNullException Constructor (String, Exception)
DatabaseNullException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DatabaseNullException(
    string message,
    Exception innnerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innnerException As Exception _
)
Visual C++
public:
DatabaseNullException(
    String^ message,
    Exception^ innnerException
)

Parameters

message
Type: System..::..String
The message.
innnerException
Type: System..::..Exception
The innner exception.

See Also

DatabaseNullException Class
DatabaseNullException Overload
Sitecore.Exceptions Namespace


DatabaseNullException Properties

[image] [image]

Sitecore 6.4.1 API
DatabaseNullException Properties
DatabaseNullException Class See Also Send Feedback

The DatabaseNullException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DatabaseNullException Class
Sitecore.Exceptions Namespace


DomainException Class

[image]

Sitecore 6.4.1 API
DomainException Class
Members See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class DomainException : SitecoreException
Visual Basic
<SerializableAttribute> _
Public Class DomainException _
    Inherits SitecoreException
Visual C++
[SerializableAttribute]
public ref class DomainException : public SitecoreException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Exceptions..::..SitecoreException
Sitecore.Exceptions..::..DomainException

See Also

DomainException Members
Sitecore.Exceptions Namespace


DomainException Members

[image] [image]

Sitecore 6.4.1 API
DomainException Members
DomainException Class Constructors Methods Properties See Also Send Feedback

The DomainException type exposes the following members.

Constructors

 | Name | Description
Public method | DomainException(String) | Initializes a new instance of the DomainException class.
Public method | DomainException(String, Exception) | Initializes a new instance of the DomainException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DomainException Class
Sitecore.Exceptions Namespace


DomainException Constructor

[image] [image]

Sitecore 6.4.1 API
DomainException Constructor
DomainException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DomainException(String) | Initializes a new instance of the DomainException class.
Public method | DomainException(String, Exception) | Initializes a new instance of the DomainException class.

See Also

DomainException Class
DomainException Members
Sitecore.Exceptions Namespace


DomainException Constructor (String)

[image]

Sitecore 6.4.1 API
DomainException Constructor (String)
DomainException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DomainException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
DomainException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

DomainException Class
DomainException Overload
Sitecore.Exceptions Namespace


DomainException Constructor (String, Exception)

[image]

Sitecore 6.4.1 API
DomainException Constructor (String, Exception)
DomainException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DomainException(
    string message,
    Exception innnerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innnerException As Exception _
)
Visual C++
public:
DomainException(
    String^ message,
    Exception^ innnerException
)

Parameters

message
Type: System..::..String
The message.
innnerException
Type: System..::..Exception
The innner exception.

See Also

DomainException Class
DomainException Overload
Sitecore.Exceptions Namespace


DomainException Methods

[image] [image]

Sitecore 6.4.1 API
DomainException Methods
DomainException Class See Also Send Feedback

The DomainException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DomainException Class
Sitecore.Exceptions Namespace


DomainException Properties

[image] [image]

Sitecore 6.4.1 API
DomainException Properties
DomainException Class See Also Send Feedback

The DomainException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DomainException Class
Sitecore.Exceptions Namespace


DomainExistsException Class

[image]

Sitecore 6.4.1 API
DomainExistsException Class
Members See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class DomainExistsException : SitecoreException
Visual Basic
<SerializableAttribute> _
Public Class DomainExistsException _
    Inherits SitecoreException
Visual C++
[SerializableAttribute]
public ref class DomainExistsException : public SitecoreException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Exceptions..::..SitecoreException
Sitecore.Exceptions..::..DomainExistsException

See Also

DomainExistsException Members
Sitecore.Exceptions Namespace


DomainExistsException Members

[image] [image]

Sitecore 6.4.1 API
DomainExistsException Members
DomainExistsException Class Constructors Methods Properties See Also Send Feedback

The DomainExistsException type exposes the following members.

Constructors

 | Name | Description
Public method | DomainExistsException(String) | Initializes a new instance of the DomainExistsException class.
Public method | DomainExistsException(String, Exception) | Initializes a new instance of the DomainExistsException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DomainExistsException Class
Sitecore.Exceptions Namespace


DomainExistsException Constructor

[image] [image]

Sitecore 6.4.1 API
DomainExistsException Constructor
DomainExistsException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DomainExistsException(String) | Initializes a new instance of the DomainExistsException class.
Public method | DomainExistsException(String, Exception) | Initializes a new instance of the DomainExistsException class.

See Also

DomainExistsException Class
DomainExistsException Members
Sitecore.Exceptions Namespace


DomainExistsException Constructor (String)

[image]

Sitecore 6.4.1 API
DomainExistsException Constructor (String)
DomainExistsException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DomainExistsException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
DomainExistsException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

DomainExistsException Class
DomainExistsException Overload
Sitecore.Exceptions Namespace


DomainExistsException Constructor (String, Exception)

[image]

Sitecore 6.4.1 API
DomainExistsException Constructor (String, Exception)
DomainExistsException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DomainExistsException(
    string message,
    Exception innnerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innnerException As Exception _
)
Visual C++
public:
DomainExistsException(
    String^ message,
    Exception^ innnerException
)

Parameters

message
Type: System..::..String
The message.
innnerException
Type: System..::..Exception
The innner exception.

See Also

DomainExistsException Class
DomainExistsException Overload
Sitecore.Exceptions Namespace


DomainExistsException Methods

[image] [image]

Sitecore 6.4.1 API
DomainExistsException Methods
DomainExistsException Class See Also Send Feedback

The DomainExistsException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DomainExistsException Class
Sitecore.Exceptions Namespace


EditingNotAllowedException Class

[image]

Sitecore 6.4.1 API
EditingNotAllowedException Class
Members See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class EditingNotAllowedException : SitecoreException
Visual Basic
<SerializableAttribute> _
Public Class EditingNotAllowedException _
    Inherits SitecoreException
Visual C++
[SerializableAttribute]
public ref class EditingNotAllowedException : public SitecoreException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Exceptions..::..SitecoreException
Sitecore.Exceptions..::..EditingNotAllowedException

See Also

EditingNotAllowedException Members
Sitecore.Exceptions Namespace


EditingNotAllowedException Members

[image] [image]

Sitecore 6.4.1 API
EditingNotAllowedException Members
EditingNotAllowedException Class Constructors Methods Properties See Also Send Feedback

The EditingNotAllowedException type exposes the following members.

Constructors

 | Name | Description
Public method | EditingNotAllowedException | Initializes a new instance of the EditingNotAllowedException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

EditingNotAllowedException Class
Sitecore.Exceptions Namespace


EditingNotAllowedException Properties

[image] [image]

Sitecore 6.4.1 API
EditingNotAllowedException Properties
EditingNotAllowedException Class See Also Send Feedback

The EditingNotAllowedException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

EditingNotAllowedException Class
Sitecore.Exceptions Namespace


InvalidItemException Class

[image]

Sitecore 6.4.1 API
InvalidItemException Class
Members See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class InvalidItemException : SitecoreException
Visual Basic
<SerializableAttribute> _
Public Class InvalidItemException _
    Inherits SitecoreException
Visual C++
[SerializableAttribute]
public ref class InvalidItemException : public SitecoreException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Exceptions..::..SitecoreException
Sitecore.Exceptions..::..InvalidItemException

See Also

InvalidItemException Members
Sitecore.Exceptions Namespace


InvalidItemException Members

[image] [image]

Sitecore 6.4.1 API
InvalidItemException Members
InvalidItemException Class Constructors Methods Properties See Also Send Feedback

The InvalidItemException type exposes the following members.

Constructors

 | Name | Description
Public method | InvalidItemException | Initializes a new instance of the InvalidItemException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidItemException Class
Sitecore.Exceptions Namespace


InvalidItemException Constructor

[image]

Sitecore 6.4.1 API
InvalidItemException Constructor
InvalidItemException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public InvalidItemException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
InvalidItemException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

InvalidItemException Class
Sitecore.Exceptions Namespace


InvalidItemException Methods

[image] [image]

Sitecore 6.4.1 API
InvalidItemException Methods
InvalidItemException Class See Also Send Feedback

The InvalidItemException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InvalidItemException Class
Sitecore.Exceptions Namespace


InvalidItemException Properties

[image] [image]

Sitecore 6.4.1 API
InvalidItemException Properties
InvalidItemException Class See Also Send Feedback

The InvalidItemException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidItemException Class
Sitecore.Exceptions Namespace


InvalidItemNameException Class

[image]

Sitecore 6.4.1 API
InvalidItemNameException Class
Members See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class InvalidItemNameException : SitecoreException
Visual Basic
<SerializableAttribute> _
Public Class InvalidItemNameException _
    Inherits SitecoreException
Visual C++
[SerializableAttribute]
public ref class InvalidItemNameException : public SitecoreException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Exceptions..::..SitecoreException
Sitecore.Exceptions..::..InvalidItemNameException

See Also

InvalidItemNameException Members
Sitecore.Exceptions Namespace


InvalidItemNameException Members

[image] [image]

Sitecore 6.4.1 API
InvalidItemNameException Members
InvalidItemNameException Class Constructors Methods Properties See Also Send Feedback

The InvalidItemNameException type exposes the following members.

Constructors

 | Name | Description
Public method | InvalidItemNameException | Initializes a new instance of the InvalidItemNameException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidItemNameException Class
Sitecore.Exceptions Namespace


InvalidItemNameException Methods

[image] [image]

Sitecore 6.4.1 API
InvalidItemNameException Methods
InvalidItemNameException Class See Also Send Feedback

The InvalidItemNameException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InvalidItemNameException Class
Sitecore.Exceptions Namespace


InvalidItemNameException Properties

[image] [image]

Sitecore 6.4.1 API
InvalidItemNameException Properties
InvalidItemNameException Class See Also Send Feedback

The InvalidItemNameException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidItemNameException Class
Sitecore.Exceptions Namespace


InvalidStructureException Class

[image]

Sitecore 6.4.1 API
InvalidStructureException Class
Members See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class InvalidStructureException : SitecoreException
Visual Basic
<SerializableAttribute> _
Public Class InvalidStructureException _
    Inherits SitecoreException
Visual C++
[SerializableAttribute]
public ref class InvalidStructureException : public SitecoreException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Exceptions..::..SitecoreException
Sitecore.Exceptions..::..InvalidStructureException

See Also

InvalidStructureException Members
Sitecore.Exceptions Namespace


InvalidStructureException Members

[image] [image]

Sitecore 6.4.1 API
InvalidStructureException Members
InvalidStructureException Class Constructors Methods Properties See Also Send Feedback

The InvalidStructureException type exposes the following members.

Constructors

 | Name | Description
Public method | InvalidStructureException | Initializes a new instance of the InvalidStructureException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidStructureException Class
Sitecore.Exceptions Namespace


InvalidStructureException Constructor

[image]

Sitecore 6.4.1 API
InvalidStructureException Constructor
InvalidStructureException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public InvalidStructureException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
InvalidStructureException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

InvalidStructureException Class
Sitecore.Exceptions Namespace


InvalidStructureException Methods

[image] [image]

Sitecore 6.4.1 API
InvalidStructureException Methods
InvalidStructureException Class See Also Send Feedback

The InvalidStructureException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InvalidStructureException Class
Sitecore.Exceptions Namespace


InvalidStructureException Properties

[image] [image]

Sitecore 6.4.1 API
InvalidStructureException Properties
InvalidStructureException Class See Also Send Feedback

The InvalidStructureException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidStructureException Class
Sitecore.Exceptions Namespace


InvalidTypeException Class

[image]

Sitecore 6.4.1 API
InvalidTypeException Class
Members See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class InvalidTypeException : SitecoreException
Visual Basic
<SerializableAttribute> _
Public Class InvalidTypeException _
    Inherits SitecoreException
Visual C++
[SerializableAttribute]
public ref class InvalidTypeException : public SitecoreException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Exceptions..::..SitecoreException
Sitecore.Exceptions..::..InvalidTypeException

See Also

InvalidTypeException Members
Sitecore.Exceptions Namespace


InvalidTypeException Members

[image] [image]

Sitecore 6.4.1 API
InvalidTypeException Members
InvalidTypeException Class Constructors Methods Properties See Also Send Feedback

The InvalidTypeException type exposes the following members.

Constructors

 | Name | Description
Public method | InvalidTypeException | Initializes a new instance of the InvalidTypeException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidTypeException Class
Sitecore.Exceptions Namespace


InvalidTypeException Constructor

[image]

Sitecore 6.4.1 API
InvalidTypeException Constructor
InvalidTypeException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public InvalidTypeException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
InvalidTypeException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

InvalidTypeException Class
Sitecore.Exceptions Namespace


InvalidTypeException Methods

[image] [image]

Sitecore 6.4.1 API
InvalidTypeException Methods
InvalidTypeException Class See Also Send Feedback

The InvalidTypeException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InvalidTypeException Class
Sitecore.Exceptions Namespace


InvalidValueException Class

[image]

Sitecore 6.4.1 API
InvalidValueException Class
Members See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class InvalidValueException : SitecoreException
Visual Basic
<SerializableAttribute> _
Public Class InvalidValueException _
    Inherits SitecoreException
Visual C++
[SerializableAttribute]
public ref class InvalidValueException : public SitecoreException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Exceptions..::..SitecoreException
Sitecore.Exceptions..::..InvalidValueException

See Also

InvalidValueException Members
Sitecore.Exceptions Namespace


InvalidValueException Members

[image] [image]

Sitecore 6.4.1 API
InvalidValueException Members
InvalidValueException Class Constructors Methods Properties See Also Send Feedback

The InvalidValueException type exposes the following members.

Constructors

 | Name | Description
Public method | InvalidValueException | Initializes a new instance of the InvalidValueException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidValueException Class
Sitecore.Exceptions Namespace


InvalidValueException Constructor

[image]

Sitecore 6.4.1 API
InvalidValueException Constructor
InvalidValueException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public InvalidValueException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
InvalidValueException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

InvalidValueException Class
Sitecore.Exceptions Namespace


InvalidValueException Methods

[image] [image]

Sitecore 6.4.1 API
InvalidValueException Methods
InvalidValueException Class See Also Send Feedback

The InvalidValueException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InvalidValueException Class
Sitecore.Exceptions Namespace


InvalidValueException Properties

[image] [image]

Sitecore 6.4.1 API
InvalidValueException Properties
InvalidValueException Class See Also Send Feedback

The InvalidValueException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidValueException Class
Sitecore.Exceptions Namespace


ItemNotFoundException Class

[image]

Sitecore 6.4.1 API
ItemNotFoundException Class
Members See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class ItemNotFoundException : SitecoreException
Visual Basic
<SerializableAttribute> _
Public Class ItemNotFoundException _
    Inherits SitecoreException
Visual C++
[SerializableAttribute]
public ref class ItemNotFoundException : public SitecoreException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Exceptions..::..SitecoreException
Sitecore.Exceptions..::..ItemNotFoundException

See Also

ItemNotFoundException Members
Sitecore.Exceptions Namespace


ItemNotFoundException Members

[image] [image]

Sitecore 6.4.1 API
ItemNotFoundException Members
ItemNotFoundException Class Constructors Methods Properties See Also Send Feedback

The ItemNotFoundException type exposes the following members.

Constructors

 | Name | Description
Public method | ItemNotFoundException()()()() | Initializes a new instance of the ItemNotFoundException class.
Public method | ItemNotFoundException(String) | Initializes a new instance of the ItemNotFoundException class.
Public method | ItemNotFoundException(String, Exception) | Initializes a new instance of the ItemNotFoundException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ItemNotFoundException Class
Sitecore.Exceptions Namespace


ItemNotFoundException Constructor

[image]

Sitecore 6.4.1 API
ItemNotFoundException Constructor
ItemNotFoundException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemNotFoundException()
Visual Basic
Public Sub New
Visual C++
public:
ItemNotFoundException()

See Also

ItemNotFoundException Class
ItemNotFoundException Overload
Sitecore.Exceptions Namespace


ItemNotFoundException Constructor (String)

[image]

Sitecore 6.4.1 API
ItemNotFoundException Constructor (String)
ItemNotFoundException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemNotFoundException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
ItemNotFoundException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

ItemNotFoundException Class
ItemNotFoundException Overload
Sitecore.Exceptions Namespace


ItemNotFoundException Constructor (String, Exception)

[image]

Sitecore 6.4.1 API
ItemNotFoundException Constructor (String, Exception)
ItemNotFoundException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemNotFoundException(
    string message,
    Exception innnerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innnerException As Exception _
)
Visual C++
public:
ItemNotFoundException(
    String^ message,
    Exception^ innnerException
)

Parameters

message
Type: System..::..String
The message.
innnerException
Type: System..::..Exception
The innner exception.

See Also

ItemNotFoundException Class
ItemNotFoundException Overload
Sitecore.Exceptions Namespace


ItemNotFoundException Methods

[image] [image]

Sitecore 6.4.1 API
ItemNotFoundException Methods
ItemNotFoundException Class See Also Send Feedback

The ItemNotFoundException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ItemNotFoundException Class
Sitecore.Exceptions Namespace


ItemNotFoundException Properties

[image] [image]

Sitecore 6.4.1 API
ItemNotFoundException Properties
ItemNotFoundException Class See Also Send Feedback

The ItemNotFoundException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ItemNotFoundException Class
Sitecore.Exceptions Namespace


ItemNullException Class

[image]

Sitecore 6.4.1 API
ItemNullException Class
Members See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class ItemNullException : SitecoreException
Visual Basic
<SerializableAttribute> _
Public Class ItemNullException _
    Inherits SitecoreException
Visual C++
[SerializableAttribute]
public ref class ItemNullException : public SitecoreException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Exceptions..::..SitecoreException
Sitecore.Exceptions..::..ItemNullException

See Also

ItemNullException Members
Sitecore.Exceptions Namespace


ItemNullException Members

[image] [image]

Sitecore 6.4.1 API
ItemNullException Members
ItemNullException Class Constructors Methods Properties See Also Send Feedback

The ItemNullException type exposes the following members.

Constructors

 | Name | Description
Public method | ItemNullException()()()() | Initializes a new instance of the ItemNotFoundException class.
Public method | ItemNullException(String) | Initializes a new instance of the ItemNotFoundException class.
Public method | ItemNullException(String, Exception) | Initializes a new instance of the ItemNotFoundException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ItemNullException Class
Sitecore.Exceptions Namespace


ItemNullException Constructor

[image] [image]

Sitecore 6.4.1 API
ItemNullException Constructor
ItemNullException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ItemNullException()()()() | Initializes a new instance of the ItemNotFoundException class.
Public method | ItemNullException(String) | Initializes a new instance of the ItemNotFoundException class.
Public method | ItemNullException(String, Exception) | Initializes a new instance of the ItemNotFoundException class.

See Also

ItemNullException Class
ItemNullException Members
Sitecore.Exceptions Namespace


ItemNullException Constructor

[image]

Sitecore 6.4.1 API
ItemNullException Constructor
ItemNullException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemNullException()
Visual Basic
Public Sub New
Visual C++
public:
ItemNullException()

See Also

ItemNullException Class
ItemNullException Overload
Sitecore.Exceptions Namespace


ItemNullException Constructor (String, Exception)

[image]

Sitecore 6.4.1 API
ItemNullException Constructor (String, Exception)
ItemNullException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemNullException(
    string message,
    Exception innnerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innnerException As Exception _
)
Visual C++
public:
ItemNullException(
    String^ message,
    Exception^ innnerException
)

Parameters

message
Type: System..::..String
The message.
innnerException
Type: System..::..Exception
The innner exception.

See Also

ItemNullException Class
ItemNullException Overload
Sitecore.Exceptions Namespace


ItemNullException Methods

[image] [image]

Sitecore 6.4.1 API
ItemNullException Methods
ItemNullException Class See Also Send Feedback

The ItemNullException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ItemNullException Class
Sitecore.Exceptions Namespace


ItemNullException Properties

[image] [image]

Sitecore 6.4.1 API
ItemNullException Properties
ItemNullException Class See Also Send Feedback

The ItemNullException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ItemNullException Class
Sitecore.Exceptions Namespace


LoadOnlyPropertyException Class

[image]

Sitecore 6.4.1 API
LoadOnlyPropertyException Class
Members See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class LoadOnlyPropertyException : SitecoreException
Visual Basic
<SerializableAttribute> _
Public Class LoadOnlyPropertyException _
    Inherits SitecoreException
Visual C++
[SerializableAttribute]
public ref class LoadOnlyPropertyException : public SitecoreException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Exceptions..::..SitecoreException
Sitecore.Exceptions..::..LoadOnlyPropertyException

See Also

LoadOnlyPropertyException Members
Sitecore.Exceptions Namespace


LoadOnlyPropertyException Members

[image] [image]

Sitecore 6.4.1 API
LoadOnlyPropertyException Members
LoadOnlyPropertyException Class Constructors Methods Properties See Also Send Feedback

The LoadOnlyPropertyException type exposes the following members.

Constructors

 | Name | Description
Public method | LoadOnlyPropertyException | Initializes a new instance of the LoadOnlyPropertyException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

LoadOnlyPropertyException Class
Sitecore.Exceptions Namespace


LoadOnlyPropertyException Constructor

[image]

Sitecore 6.4.1 API
LoadOnlyPropertyException Constructor
LoadOnlyPropertyException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LoadOnlyPropertyException(
    string propertyName
)
Visual Basic
Public Sub New ( _
    propertyName As String _
)
Visual C++
public:
LoadOnlyPropertyException(
    String^ propertyName
)

Parameters

propertyName
Type: System..::..String
Name of the property.

See Also

LoadOnlyPropertyException Class
Sitecore.Exceptions Namespace


LoadOnlyPropertyException Methods

[image] [image]

Sitecore 6.4.1 API
LoadOnlyPropertyException Methods
LoadOnlyPropertyException Class See Also Send Feedback

The LoadOnlyPropertyException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

LoadOnlyPropertyException Class
Sitecore.Exceptions Namespace


LoadOnlyPropertyException Properties

[image] [image]

Sitecore 6.4.1 API
LoadOnlyPropertyException Properties
LoadOnlyPropertyException Class See Also Send Feedback

The LoadOnlyPropertyException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

LoadOnlyPropertyException Class
Sitecore.Exceptions Namespace


LookupSourceException Class

[image]

Sitecore 6.4.1 API
LookupSourceException Class
Members See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class LookupSourceException : SitecoreException
Visual Basic
<SerializableAttribute> _
Public Class LookupSourceException _
    Inherits SitecoreException
Visual C++
[SerializableAttribute]
public ref class LookupSourceException : public SitecoreException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Exceptions..::..SitecoreException
Sitecore.Exceptions..::..LookupSourceException

See Also

LookupSourceException Members
Sitecore.Exceptions Namespace


LookupSourceException Members

[image] [image]

Sitecore 6.4.1 API
LookupSourceException Members
LookupSourceException Class Constructors Methods Properties See Also Send Feedback

The LookupSourceException type exposes the following members.

Constructors

 | Name | Description
Public method | LookupSourceException | Initializes a new instance of the LookupSourceException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | InnerMessage | Gets the inner message.
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

LookupSourceException Class
Sitecore.Exceptions Namespace


LookupSourceException Constructor

[image]

Sitecore 6.4.1 API
LookupSourceException Constructor
LookupSourceException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LookupSourceException(
    string source,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    source As String, _
    innerException As Exception _
)
Visual C++
public:
LookupSourceException(
    String^ source,
    Exception^ innerException
)

Parameters

source
Type: System..::..String
The source.
innerException
Type: System..::..Exception
The inner exception.

See Also

LookupSourceException Class
Sitecore.Exceptions Namespace


LookupSourceException Methods

[image] [image]

Sitecore 6.4.1 API
LookupSourceException Methods
LookupSourceException Class See Also Send Feedback

The LookupSourceException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

LookupSourceException Class
Sitecore.Exceptions Namespace


LookupSourceException Properties

[image] [image]

Sitecore 6.4.1 API
LookupSourceException Properties
LookupSourceException Class See Also Send Feedback

The LookupSourceException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | InnerMessage | Gets the inner message.
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

LookupSourceException Class
Sitecore.Exceptions Namespace


InnerMessage Property

[image]

Sitecore 6.4.1 API
LookupSourceException..::..InnerMessage Property
LookupSourceException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object InnerMessage { get; }
Visual Basic
Public ReadOnly Property InnerMessage As Object
    Get
Visual C++
public:
property Object^ InnerMessage {
    Object^ get ();
}

Field Value

The inner message.

See Also

LookupSourceException Class
Sitecore.Exceptions Namespace


MediaException Class

[image]

Sitecore 6.4.1 API
MediaException Class
Members See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class MediaException : Exception
Visual Basic
Public Class MediaException _
    Inherits Exception
Visual C++
public ref class MediaException : public Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Exceptions..::..MediaException

See Also

MediaException Members
Sitecore.Exceptions Namespace


MediaException Members

[image] [image]

Sitecore 6.4.1 API
MediaException Members
MediaException Class Constructors Methods Properties See Also Send Feedback

The MediaException type exposes the following members.

Constructors

 | Name | Description
Public method | MediaException()()()() | Initializes a new instance of the MediaException class.
Public method | MediaException(String) | Initializes a new instance of the MediaException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MediaException Class
Sitecore.Exceptions Namespace


MediaException Constructor

[image] [image]

Sitecore 6.4.1 API
MediaException Constructor
MediaException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MediaException()()()() | Initializes a new instance of the MediaException class.
Public method | MediaException(String) | Initializes a new instance of the MediaException class.

See Also

MediaException Class
MediaException Members
Sitecore.Exceptions Namespace


MediaException Constructor

[image]

Sitecore 6.4.1 API
MediaException Constructor
MediaException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MediaException()
Visual Basic
Public Sub New
Visual C++
public:
MediaException()

See Also

MediaException Class
MediaException Overload
Sitecore.Exceptions Namespace


MediaException Constructor (String)

[image]

Sitecore 6.4.1 API
MediaException Constructor (String)
MediaException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MediaException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
MediaException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

MediaException Class
MediaException Overload
Sitecore.Exceptions Namespace


MediaException Methods

[image] [image]

Sitecore 6.4.1 API
MediaException Methods
MediaException Class See Also Send Feedback

The MediaException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MediaException Class
Sitecore.Exceptions Namespace


MediaException Properties

[image] [image]

Sitecore 6.4.1 API
MediaException Properties
MediaException Class See Also Send Feedback

The MediaException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MediaException Class
Sitecore.Exceptions Namespace


MediaIsNotModifiedException Class

[image]

Sitecore 6.4.1 API
MediaIsNotModifiedException Class
Members See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class MediaIsNotModifiedException : Exception
Visual Basic
Public Class MediaIsNotModifiedException _
    Inherits Exception
Visual C++
public ref class MediaIsNotModifiedException : public Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Exceptions..::..MediaIsNotModifiedException

See Also

MediaIsNotModifiedException Members
Sitecore.Exceptions Namespace


MediaIsNotModifiedException Members

[image] [image]

Sitecore 6.4.1 API
MediaIsNotModifiedException Members
MediaIsNotModifiedException Class Constructors Methods Properties See Also Send Feedback

The MediaIsNotModifiedException type exposes the following members.

Constructors

 | Name | Description
Public method | MediaIsNotModifiedException | Initializes a new instance of the MediaIsNotModifiedException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MediaIsNotModifiedException Class
Sitecore.Exceptions Namespace


MediaIsNotModifiedException Constructor

[image]

Sitecore 6.4.1 API
MediaIsNotModifiedException Constructor
MediaIsNotModifiedException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MediaIsNotModifiedException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
MediaIsNotModifiedException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

MediaIsNotModifiedException Class
Sitecore.Exceptions Namespace


MediaIsNotModifiedException Methods

[image] [image]

Sitecore 6.4.1 API
MediaIsNotModifiedException Methods
MediaIsNotModifiedException Class See Also Send Feedback

The MediaIsNotModifiedException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MediaIsNotModifiedException Class
Sitecore.Exceptions Namespace


MediaIsNotModifiedException Properties

[image] [image]

Sitecore 6.4.1 API
MediaIsNotModifiedException Properties
MediaIsNotModifiedException Class See Also Send Feedback

The MediaIsNotModifiedException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MediaIsNotModifiedException Class
Sitecore.Exceptions Namespace


PipelineException Class

[image]

Sitecore 6.4.1 API
PipelineException Class
Members See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PipelineException : SitecoreException
Visual Basic
Public Class PipelineException _
    Inherits SitecoreException
Visual C++
public ref class PipelineException : public SitecoreException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Exceptions..::..SitecoreException
Sitecore.Exceptions..::..PipelineException

See Also

PipelineException Members
Sitecore.Exceptions Namespace


PipelineException Members

[image] [image]

Sitecore 6.4.1 API
PipelineException Members
PipelineException Class Constructors Methods Properties See Also Send Feedback

The PipelineException type exposes the following members.

Constructors

 | Name | Description
Public method | PipelineException(String) | Initializes a new instance of the PipelineException class.
Public method | PipelineException(String, Exception) | Initializes a new instance of the PipelineException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

PipelineException Class
Sitecore.Exceptions Namespace


PipelineException Constructor

[image] [image]

Sitecore 6.4.1 API
PipelineException Constructor
PipelineException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PipelineException(String) | Initializes a new instance of the PipelineException class.
Public method | PipelineException(String, Exception) | Initializes a new instance of the PipelineException class.

See Also

PipelineException Class
PipelineException Members
Sitecore.Exceptions Namespace


PipelineException Methods

[image] [image]

Sitecore 6.4.1 API
PipelineException Methods
PipelineException Class See Also Send Feedback

The PipelineException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

PipelineException Class
Sitecore.Exceptions Namespace


PipelineException Properties

[image] [image]

Sitecore 6.4.1 API
PipelineException Properties
PipelineException Class See Also Send Feedback

The PipelineException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

PipelineException Class
Sitecore.Exceptions Namespace


ProviderConfigurationException Class

[image]

Sitecore 6.4.1 API
ProviderConfigurationException Class
Members See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class ProviderConfigurationException : SitecoreException
Visual Basic
<SerializableAttribute> _
Public Class ProviderConfigurationException _
    Inherits SitecoreException
Visual C++
[SerializableAttribute]
public ref class ProviderConfigurationException : public SitecoreException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Exceptions..::..SitecoreException
Sitecore.Exceptions..::..ProviderConfigurationException

See Also

ProviderConfigurationException Members
Sitecore.Exceptions Namespace


ProviderConfigurationException Members

[image] [image]

Sitecore 6.4.1 API
ProviderConfigurationException Members
ProviderConfigurationException Class Constructors Methods Properties See Also Send Feedback

The ProviderConfigurationException type exposes the following members.

Constructors

 | Name | Description
Public method | ProviderConfigurationException(String) | Initializes a new instance of the ProviderConfigurationException class.
Public method | ProviderConfigurationException(String, Exception) | Initializes a new instance of the ProviderConfigurationException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ProviderConfigurationException Class
Sitecore.Exceptions Namespace


ProviderConfigurationException Constructor

[image] [image]

Sitecore 6.4.1 API
ProviderConfigurationException Constructor
ProviderConfigurationException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ProviderConfigurationException(String) | Initializes a new instance of the ProviderConfigurationException class.
Public method | ProviderConfigurationException(String, Exception) | Initializes a new instance of the ProviderConfigurationException class.

See Also

ProviderConfigurationException Class
ProviderConfigurationException Members
Sitecore.Exceptions Namespace


ProviderConfigurationException Constructor (String)

[image]

Sitecore 6.4.1 API
ProviderConfigurationException Constructor (String)
ProviderConfigurationException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ProviderConfigurationException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
ProviderConfigurationException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

ProviderConfigurationException Class
ProviderConfigurationException Overload
Sitecore.Exceptions Namespace


ProviderConfigurationException Constructor (String, Exception)

[image]

Sitecore 6.4.1 API
ProviderConfigurationException Constructor (String, Exception)
ProviderConfigurationException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ProviderConfigurationException(
    string message,
    Exception innnerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innnerException As Exception _
)
Visual C++
public:
ProviderConfigurationException(
    String^ message,
    Exception^ innnerException
)

Parameters

message
Type: System..::..String
The message.
innnerException
Type: System..::..Exception
The innner exception.

See Also

ProviderConfigurationException Class
ProviderConfigurationException Overload
Sitecore.Exceptions Namespace


ProviderConfigurationException Methods

[image] [image]

Sitecore 6.4.1 API
ProviderConfigurationException Methods
ProviderConfigurationException Class See Also Send Feedback

The ProviderConfigurationException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ProviderConfigurationException Class
Sitecore.Exceptions Namespace


ProviderConfigurationException Properties

[image] [image]

Sitecore 6.4.1 API
ProviderConfigurationException Properties
ProviderConfigurationException Class See Also Send Feedback

The ProviderConfigurationException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ProviderConfigurationException Class
Sitecore.Exceptions Namespace


ProviderIsReadOnlyException Constructor

[image] [image]

Sitecore 6.4.1 API
ProviderIsReadOnlyException Constructor
ProviderIsReadOnlyException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ProviderIsReadOnlyException(String) | Initializes a new instance of the ProviderIsReadOnlyException class.
Public method | ProviderIsReadOnlyException(String, Exception) | Initializes a new instance of the ProviderIsReadOnlyException class.

See Also

ProviderIsReadOnlyException Class
ProviderIsReadOnlyException Members
Sitecore.Exceptions Namespace


ProviderIsReadOnlyException Constructor (String)

[image]

Sitecore 6.4.1 API
ProviderIsReadOnlyException Constructor (String)
ProviderIsReadOnlyException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ProviderIsReadOnlyException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
ProviderIsReadOnlyException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

ProviderIsReadOnlyException Class
ProviderIsReadOnlyException Overload
Sitecore.Exceptions Namespace


ProviderIsReadOnlyException Constructor (String, Exception)

[image]

Sitecore 6.4.1 API
ProviderIsReadOnlyException Constructor (String, Exception)
ProviderIsReadOnlyException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ProviderIsReadOnlyException(
    string message,
    Exception innnerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innnerException As Exception _
)
Visual C++
public:
ProviderIsReadOnlyException(
    String^ message,
    Exception^ innnerException
)

Parameters

message
Type: System..::..String
The message.
innnerException
Type: System..::..Exception
The innner exception.

See Also

ProviderIsReadOnlyException Class
ProviderIsReadOnlyException Overload
Sitecore.Exceptions Namespace


ProviderIsReadOnlyException Methods

[image] [image]

Sitecore 6.4.1 API
ProviderIsReadOnlyException Methods
ProviderIsReadOnlyException Class See Also Send Feedback

The ProviderIsReadOnlyException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ProviderIsReadOnlyException Class
Sitecore.Exceptions Namespace


ProviderIsReadOnlyException Properties

[image] [image]

Sitecore 6.4.1 API
ProviderIsReadOnlyException Properties
ProviderIsReadOnlyException Class See Also Send Feedback

The ProviderIsReadOnlyException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ProviderIsReadOnlyException Class
Sitecore.Exceptions Namespace


QueryException Class

[image]

Sitecore 6.4.1 API
QueryException Class
Members See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class QueryException : SitecoreException
Visual Basic
<SerializableAttribute> _
Public Class QueryException _
    Inherits SitecoreException
Visual C++
[SerializableAttribute]
public ref class QueryException : public SitecoreException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Exceptions..::..SitecoreException
Sitecore.Exceptions..::..QueryException

See Also

QueryException Members
Sitecore.Exceptions Namespace


QueryException Constructor

[image] [image]

Sitecore 6.4.1 API
QueryException Constructor
QueryException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | QueryException()()()() | Initializes a new instance of the QueryException class.
Public method | QueryException(String) | Initializes a new instance of the QueryException class.
Public method | QueryException(String, Exception) | Initializes a new instance of the QueryException class.

See Also

QueryException Class
QueryException Members
Sitecore.Exceptions Namespace


QueryException Constructor

[image]

Sitecore 6.4.1 API
QueryException Constructor
QueryException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public QueryException()
Visual Basic
Public Sub New
Visual C++
public:
QueryException()

See Also

QueryException Class
QueryException Overload
Sitecore.Exceptions Namespace


QueryException Constructor (String)

[image]

Sitecore 6.4.1 API
QueryException Constructor (String)
QueryException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public QueryException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
QueryException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

QueryException Class
QueryException Overload
Sitecore.Exceptions Namespace


QueryException Constructor (String, Exception)

[image]

Sitecore 6.4.1 API
QueryException Constructor (String, Exception)
QueryException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public QueryException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
QueryException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

QueryException Class
QueryException Overload
Sitecore.Exceptions Namespace


QueryException Methods

[image] [image]

Sitecore 6.4.1 API
QueryException Methods
QueryException Class See Also Send Feedback

The QueryException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

QueryException Class
Sitecore.Exceptions Namespace


QueryException Properties

[image] [image]

Sitecore 6.4.1 API
QueryException Properties
QueryException Class See Also Send Feedback

The QueryException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

QueryException Class
Sitecore.Exceptions Namespace


ReflectionException Class

[image]

Sitecore 6.4.1 API
ReflectionException Class
Members See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class ReflectionException : SitecoreException
Visual Basic
<SerializableAttribute> _
Public Class ReflectionException _
    Inherits SitecoreException
Visual C++
[SerializableAttribute]
public ref class ReflectionException : public SitecoreException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Exceptions..::..SitecoreException
Sitecore.Exceptions..::..ReflectionException

See Also

ReflectionException Members
Sitecore.Exceptions Namespace


ReflectionException Members

[image] [image]

Sitecore 6.4.1 API
ReflectionException Members
ReflectionException Class Constructors Methods Properties See Also Send Feedback

The ReflectionException type exposes the following members.

Constructors

 | Name | Description
Public method | ReflectionException(String) | Initializes a new instance of the ReflectionException class.
Public method | ReflectionException(String, Exception) | Initializes a new instance of the ReflectionException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ReflectionException Class
Sitecore.Exceptions Namespace


ReflectionException Constructor

[image] [image]

Sitecore 6.4.1 API
ReflectionException Constructor
ReflectionException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReflectionException(String) | Initializes a new instance of the ReflectionException class.
Public method | ReflectionException(String, Exception) | Initializes a new instance of the ReflectionException class.

See Also

ReflectionException Class
ReflectionException Members
Sitecore.Exceptions Namespace


ReflectionException Constructor (String)

[image]

Sitecore 6.4.1 API
ReflectionException Constructor (String)
ReflectionException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ReflectionException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
ReflectionException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

ReflectionException Class
ReflectionException Overload
Sitecore.Exceptions Namespace


ReflectionException Constructor (String, Exception)

[image]

Sitecore 6.4.1 API
ReflectionException Constructor (String, Exception)
ReflectionException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ReflectionException(
    string message,
    Exception innnerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innnerException As Exception _
)
Visual C++
public:
ReflectionException(
    String^ message,
    Exception^ innnerException
)

Parameters

message
Type: System..::..String
The message.
innnerException
Type: System..::..Exception
The innner exception.

See Also

ReflectionException Class
ReflectionException Overload
Sitecore.Exceptions Namespace


ReflectionException Methods

[image] [image]

Sitecore 6.4.1 API
ReflectionException Methods
ReflectionException Class See Also Send Feedback

The ReflectionException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ReflectionException Class
Sitecore.Exceptions Namespace


ReflectionException Properties

[image] [image]

Sitecore 6.4.1 API
ReflectionException Properties
ReflectionException Class See Also Send Feedback

The ReflectionException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ReflectionException Class
Sitecore.Exceptions Namespace


RequiredObjectIsNullException Class

[image]

Sitecore 6.4.1 API
RequiredObjectIsNullException Class
Members See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class RequiredObjectIsNullException : SitecoreException
Visual Basic
<SerializableAttribute> _
Public Class RequiredObjectIsNullException _
    Inherits SitecoreException
Visual C++
[SerializableAttribute]
public ref class RequiredObjectIsNullException : public SitecoreException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Exceptions..::..SitecoreException
Sitecore.Exceptions..::..RequiredObjectIsNullException

See Also

RequiredObjectIsNullException Members
Sitecore.Exceptions Namespace


RequiredObjectIsNullException Members

[image] [image]

Sitecore 6.4.1 API
RequiredObjectIsNullException Members
RequiredObjectIsNullException Class Constructors Methods Properties See Also Send Feedback

The RequiredObjectIsNullException type exposes the following members.

Constructors

 | Name | Description
Public method | RequiredObjectIsNullException | Initializes a new instance of the RequiredObjectIsNullException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

RequiredObjectIsNullException Class
Sitecore.Exceptions Namespace


RequiredObjectIsNullException Constructor

[image]

Sitecore 6.4.1 API
RequiredObjectIsNullException Constructor
RequiredObjectIsNullException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RequiredObjectIsNullException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
RequiredObjectIsNullException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

RequiredObjectIsNullException Class
Sitecore.Exceptions Namespace


RequiredObjectIsNullException Methods

[image] [image]

Sitecore 6.4.1 API
RequiredObjectIsNullException Methods
RequiredObjectIsNullException Class See Also Send Feedback

The RequiredObjectIsNullException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

RequiredObjectIsNullException Class
Sitecore.Exceptions Namespace


RequiredObjectIsNullException Properties

[image] [image]

Sitecore 6.4.1 API
RequiredObjectIsNullException Properties
RequiredObjectIsNullException Class See Also Send Feedback

The RequiredObjectIsNullException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

RequiredObjectIsNullException Class
Sitecore.Exceptions Namespace


SecurityException Class

[image]

Sitecore 6.4.1 API
SecurityException Class
Members See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SecurityException : Exception
Visual Basic
Public Class SecurityException _
    Inherits Exception
Visual C++
public ref class SecurityException : public Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Exceptions..::..SecurityException

See Also

SecurityException Members
Sitecore.Exceptions Namespace


SecurityException Members

[image] [image]

Sitecore 6.4.1 API
SecurityException Members
SecurityException Class Constructors Methods Properties See Also Send Feedback

The SecurityException type exposes the following members.

Constructors

 | Name | Description
Public method | SecurityException | Initializes a new instance of the SecurityException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SecurityException Class
Sitecore.Exceptions Namespace


SecurityException Constructor

[image]

Sitecore 6.4.1 API
SecurityException Constructor
SecurityException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SecurityException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
SecurityException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

SecurityException Class
Sitecore.Exceptions Namespace


SecurityException Methods

[image] [image]

Sitecore 6.4.1 API
SecurityException Methods
SecurityException Class See Also Send Feedback

The SecurityException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

SecurityException Class
Sitecore.Exceptions Namespace


SecurityException Properties

[image] [image]

Sitecore 6.4.1 API
SecurityException Properties
SecurityException Class See Also Send Feedback

The SecurityException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SecurityException Class
Sitecore.Exceptions Namespace


SitecoreException Class

[image]

Sitecore 6.4.1 API
SitecoreException Class
Members See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public abstract class SitecoreException : Exception
Visual Basic
<SerializableAttribute> _
Public MustInherit Class SitecoreException _
    Inherits Exception
Visual C++
[SerializableAttribute]
public ref class SitecoreException abstract : public Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Exceptions..::..SitecoreException
Sitecore.Data.Query..::..ParseException
Sitecore.Diagnostics.PerformanceCounters..::..InstanceNameIsNotAvailableException
Sitecore.Exceptions..::..AccessDeniedException
Sitecore.Exceptions..::..CircularReferenceException
Sitecore.Exceptions..::..ClientAlertException
Sitecore.Exceptions..::..ConfigurationException
Sitecore.Exceptions..::..ControlNotFoundException
Sitecore.Exceptions..::..CyclicSublayoutException
Sitecore.Exceptions..::..DatabaseNullException
Sitecore.Exceptions..::..DomainException
Sitecore.Exceptions..::..DomainExistsException
Sitecore.Exceptions..::..EditingNotAllowedException
Sitecore.Exceptions..::..InvalidItemException
Sitecore.Exceptions..::..InvalidItemNameException
Sitecore.Exceptions..::..InvalidStructureException
Sitecore.Exceptions..::..InvalidTypeException
Sitecore.Exceptions..::..InvalidValueException
Sitecore.Exceptions..::..ItemNotFoundException
Sitecore.Exceptions..::..ItemNullException
Sitecore.Exceptions..::..LoadOnlyPropertyException
Sitecore.Exceptions..::..LookupSourceException
Sitecore.Exceptions..::..PipelineException
Sitecore.Exceptions..::..ProviderConfigurationException
Sitecore.Exceptions..::..ProviderIsReadOnlyException
Sitecore.Exceptions..::..QueryException
Sitecore.Exceptions..::..ReflectionException
Sitecore.Exceptions..::..RequiredObjectIsNullException
Sitecore.Exceptions..::..SyndicationException
Sitecore.Exceptions..::..TemplateNotFoundException
Sitecore.Exceptions..::..TicketParseException
Sitecore.Exceptions..::..UnknownDomainException
Sitecore.Exceptions..::..UnknownTypeException
Sitecore.Exceptions..::..UnsupportedThumbnailImageFormatException
Sitecore.Exceptions..::..WorkflowException
Sitecore.SecurityModel.License..::..LicenseException
Sitecore.Web.UI.XamlSharp..::..ControlException

See Also

SitecoreException Members
Sitecore.Exceptions Namespace


SitecoreException Members

[image] [image]

Sitecore 6.4.1 API
SitecoreException Members
SitecoreException Class Constructors Methods Properties See Also Send Feedback

The SitecoreException type exposes the following members.

Constructors

 | Name | Description
Protected method | SitecoreException()()()() | Initializes a new instance of the SitecoreException class.
Protected method | SitecoreException(String) | Initializes a new instance of the SitecoreException class.
Protected method | SitecoreException(String, Exception) | Initializes a new instance of the SitecoreException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SitecoreException Class
Sitecore.Exceptions Namespace


SitecoreException Constructor

[image]

Sitecore 6.4.1 API
SitecoreException Constructor
SitecoreException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected SitecoreException()
Visual Basic
Protected Sub New
Visual C++
protected:
SitecoreException()

See Also

SitecoreException Class
SitecoreException Overload
Sitecore.Exceptions Namespace


SitecoreException Constructor (String)

[image]

Sitecore 6.4.1 API
SitecoreException Constructor (String)
SitecoreException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected SitecoreException(
    string message
)
Visual Basic
Protected Sub New ( _
    message As String _
)
Visual C++
protected:
SitecoreException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

SitecoreException Class
SitecoreException Overload
Sitecore.Exceptions Namespace


SitecoreException Methods

[image] [image]

Sitecore 6.4.1 API
SitecoreException Methods
SitecoreException Class See Also Send Feedback

The SitecoreException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

SitecoreException Class
Sitecore.Exceptions Namespace


SitecoreException Properties

[image] [image]

Sitecore 6.4.1 API
SitecoreException Properties
SitecoreException Class See Also Send Feedback

The SitecoreException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SitecoreException Class
Sitecore.Exceptions Namespace


SyndicationException Class

[image]

Sitecore 6.4.1 API
SyndicationException Class
Members See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class SyndicationException : SitecoreException
Visual Basic
<SerializableAttribute> _
Public Class SyndicationException _
    Inherits SitecoreException
Visual C++
[SerializableAttribute]
public ref class SyndicationException : public SitecoreException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Exceptions..::..SitecoreException
Sitecore.Exceptions..::..SyndicationException
Sitecore.Exceptions..::..SyndicationUrlHashMismatchException

See Also

SyndicationException Members
Sitecore.Exceptions Namespace


SyndicationException Members

[image] [image]

Sitecore 6.4.1 API
SyndicationException Members
SyndicationException Class Constructors Methods Properties See Also Send Feedback

The SyndicationException type exposes the following members.

Constructors

 | Name | Description
Public method | SyndicationException(String) | Initializes a new instance of the SyndicationException class.
Public method | SyndicationException(String, Exception) | Initializes a new instance of the SyndicationException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SyndicationException Class
Sitecore.Exceptions Namespace


SyndicationException Constructor

[image] [image]

Sitecore 6.4.1 API
SyndicationException Constructor
SyndicationException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SyndicationException(String) | Initializes a new instance of the SyndicationException class.
Public method | SyndicationException(String, Exception) | Initializes a new instance of the SyndicationException class.

See Also

SyndicationException Class
SyndicationException Members
Sitecore.Exceptions Namespace


SyndicationException Constructor (String)

[image]

Sitecore 6.4.1 API
SyndicationException Constructor (String)
SyndicationException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SyndicationException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
SyndicationException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

SyndicationException Class
SyndicationException Overload
Sitecore.Exceptions Namespace


SyndicationException Constructor (String, Exception)

[image]

Sitecore 6.4.1 API
SyndicationException Constructor (String, Exception)
SyndicationException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SyndicationException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
SyndicationException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

SyndicationException Class
SyndicationException Overload
Sitecore.Exceptions Namespace


SyndicationException Methods

[image] [image]

Sitecore 6.4.1 API
SyndicationException Methods
SyndicationException Class See Also Send Feedback

The SyndicationException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

SyndicationException Class
Sitecore.Exceptions Namespace


SyndicationException Properties

[image] [image]

Sitecore 6.4.1 API
SyndicationException Properties
SyndicationException Class See Also Send Feedback

The SyndicationException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SyndicationException Class
Sitecore.Exceptions Namespace


SyndicationUrlHashMismatchException Class

[image]

Sitecore 6.4.1 API
SyndicationUrlHashMismatchException Class
Members See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class SyndicationUrlHashMismatchException : SyndicationException
Visual Basic
<SerializableAttribute> _
Public Class SyndicationUrlHashMismatchException _
    Inherits SyndicationException
Visual C++
[SerializableAttribute]
public ref class SyndicationUrlHashMismatchException : public SyndicationException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Exceptions..::..SitecoreException
Sitecore.Exceptions..::..SyndicationException
Sitecore.Exceptions..::..SyndicationUrlHashMismatchException

See Also

SyndicationUrlHashMismatchException Members
Sitecore.Exceptions Namespace


SyndicationUrlHashMismatchException Members

[image] [image]

Sitecore 6.4.1 API
SyndicationUrlHashMismatchException Members
SyndicationUrlHashMismatchException Class Constructors Methods Properties See Also Send Feedback

The SyndicationUrlHashMismatchException type exposes the following members.

Constructors

 | Name | Description
Public method | SyndicationUrlHashMismatchException | Initializes a new instance of the SyndicationException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SyndicationUrlHashMismatchException Class
Sitecore.Exceptions Namespace


SyndicationUrlHashMismatchException Constructor

[image]

Sitecore 6.4.1 API
SyndicationUrlHashMismatchException Constructor
SyndicationUrlHashMismatchException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SyndicationUrlHashMismatchException()
Visual Basic
Public Sub New
Visual C++
public:
SyndicationUrlHashMismatchException()

See Also

SyndicationUrlHashMismatchException Class
Sitecore.Exceptions Namespace


SyndicationUrlHashMismatchException Methods

[image] [image]

Sitecore 6.4.1 API
SyndicationUrlHashMismatchException Methods
SyndicationUrlHashMismatchException Class See Also Send Feedback

The SyndicationUrlHashMismatchException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

SyndicationUrlHashMismatchException Class
Sitecore.Exceptions Namespace


SyndicationUrlHashMismatchException Properties

[image] [image]

Sitecore 6.4.1 API
SyndicationUrlHashMismatchException Properties
SyndicationUrlHashMismatchException Class See Also Send Feedback

The SyndicationUrlHashMismatchException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SyndicationUrlHashMismatchException Class
Sitecore.Exceptions Namespace


TemplateNotFoundException Members

[image] [image]

Sitecore 6.4.1 API
TemplateNotFoundException Members
TemplateNotFoundException Class Constructors Methods Properties See Also Send Feedback

The TemplateNotFoundException type exposes the following members.

Constructors

 | Name | Description
Public method | TemplateNotFoundException()()()() | Initializes a new instance of the TemplateNotFoundException class.
Public method | TemplateNotFoundException(String) | Initializes a new instance of the TemplateNotFoundException class.
Public method | TemplateNotFoundException(String, Exception) | Initializes a new instance of the TemplateNotFoundException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

TemplateNotFoundException Class
Sitecore.Exceptions Namespace


TemplateNotFoundException Constructor

[image] [image]

Sitecore 6.4.1 API
TemplateNotFoundException Constructor
TemplateNotFoundException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TemplateNotFoundException()()()() | Initializes a new instance of the TemplateNotFoundException class.
Public method | TemplateNotFoundException(String) | Initializes a new instance of the TemplateNotFoundException class.
Public method | TemplateNotFoundException(String, Exception) | Initializes a new instance of the TemplateNotFoundException class.

See Also

TemplateNotFoundException Class
TemplateNotFoundException Members
Sitecore.Exceptions Namespace


TemplateNotFoundException Constructor

[image]

Sitecore 6.4.1 API
TemplateNotFoundException Constructor
TemplateNotFoundException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateNotFoundException()
Visual Basic
Public Sub New
Visual C++
public:
TemplateNotFoundException()

See Also

TemplateNotFoundException Class
TemplateNotFoundException Overload
Sitecore.Exceptions Namespace


TemplateNotFoundException Constructor (String)

[image]

Sitecore 6.4.1 API
TemplateNotFoundException Constructor (String)
TemplateNotFoundException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateNotFoundException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
TemplateNotFoundException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

TemplateNotFoundException Class
TemplateNotFoundException Overload
Sitecore.Exceptions Namespace


TemplateNotFoundException Constructor (String, Exception)

[image]

Sitecore 6.4.1 API
TemplateNotFoundException Constructor (String, Exception)
TemplateNotFoundException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateNotFoundException(
    string message,
    Exception innnerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innnerException As Exception _
)
Visual C++
public:
TemplateNotFoundException(
    String^ message,
    Exception^ innnerException
)

Parameters

message
Type: System..::..String
The message.
innnerException
Type: System..::..Exception
The innner exception.

See Also

TemplateNotFoundException Class
TemplateNotFoundException Overload
Sitecore.Exceptions Namespace


TemplateNotFoundException Methods

[image] [image]

Sitecore 6.4.1 API
TemplateNotFoundException Methods
TemplateNotFoundException Class See Also Send Feedback

The TemplateNotFoundException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

TemplateNotFoundException Class
Sitecore.Exceptions Namespace


TemplateNotFoundException Properties

[image] [image]

Sitecore 6.4.1 API
TemplateNotFoundException Properties
TemplateNotFoundException Class See Also Send Feedback

The TemplateNotFoundException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

TemplateNotFoundException Class
Sitecore.Exceptions Namespace


TicketParseException Class

[image]

Sitecore 6.4.1 API
TicketParseException Class
Members See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class TicketParseException : SitecoreException
Visual Basic
<SerializableAttribute> _
Public Class TicketParseException _
    Inherits SitecoreException
Visual C++
[SerializableAttribute]
public ref class TicketParseException : public SitecoreException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Exceptions..::..SitecoreException
Sitecore.Exceptions..::..TicketParseException

See Also

TicketParseException Members
Sitecore.Exceptions Namespace


TicketParseException Members

[image] [image]

Sitecore 6.4.1 API
TicketParseException Members
TicketParseException Class Constructors Methods Properties See Also Send Feedback

The TicketParseException type exposes the following members.

Constructors

 | Name | Description
Public method | TicketParseException()()()() | Initializes a new instance of the TicketParseException class.
Public method | TicketParseException(String) | Initializes a new instance of the TicketParseException class.
Public method | TicketParseException(String, Exception) | Initializes a new instance of the TicketParseException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

TicketParseException Class
Sitecore.Exceptions Namespace


TicketParseException Constructor

[image] [image]

Sitecore 6.4.1 API
TicketParseException Constructor
TicketParseException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TicketParseException()()()() | Initializes a new instance of the TicketParseException class.
Public method | TicketParseException(String) | Initializes a new instance of the TicketParseException class.
Public method | TicketParseException(String, Exception) | Initializes a new instance of the TicketParseException class.

See Also

TicketParseException Class
TicketParseException Members
Sitecore.Exceptions Namespace


TicketParseException Constructor (String)

[image]

Sitecore 6.4.1 API
TicketParseException Constructor (String)
TicketParseException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TicketParseException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
TicketParseException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

TicketParseException Class
TicketParseException Overload
Sitecore.Exceptions Namespace


TicketParseException Constructor (String, Exception)

[image]

Sitecore 6.4.1 API
TicketParseException Constructor (String, Exception)
TicketParseException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TicketParseException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
TicketParseException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

TicketParseException Class
TicketParseException Overload
Sitecore.Exceptions Namespace


TicketParseException Methods

[image] [image]

Sitecore 6.4.1 API
TicketParseException Methods
TicketParseException Class See Also Send Feedback

The TicketParseException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

TicketParseException Class
Sitecore.Exceptions Namespace


TicketParseException Properties

[image] [image]

Sitecore 6.4.1 API
TicketParseException Properties
TicketParseException Class See Also Send Feedback

The TicketParseException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

TicketParseException Class
Sitecore.Exceptions Namespace


TodoException Class

[image]

Sitecore 6.4.1 API
TodoException Class
Members See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class TodoException : NotImplementedException
Visual Basic
Public Class TodoException _
    Inherits NotImplementedException
Visual C++
public ref class TodoException : public NotImplementedException

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..SystemException
System..::..NotImplementedException
Sitecore.Exceptions..::..TodoException

See Also

TodoException Members
Sitecore.Exceptions Namespace


TodoException Members

[image] [image]

Sitecore 6.4.1 API
TodoException Members
TodoException Class Constructors Methods Properties See Also Send Feedback

The TodoException type exposes the following members.

Constructors

 | Name | Description
Public method | TodoException(String) | Initializes a new instance of the TodoException class.
Public method | TodoException(String, Exception) | Initializes a new instance of the TodoException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

TodoException Class
Sitecore.Exceptions Namespace


TodoException Constructor

[image] [image]

Sitecore 6.4.1 API
TodoException Constructor
TodoException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TodoException(String) | Initializes a new instance of the TodoException class.
Public method | TodoException(String, Exception) | Initializes a new instance of the TodoException class.

See Also

TodoException Class
TodoException Members
Sitecore.Exceptions Namespace


TodoException Constructor (String)

[image]

Sitecore 6.4.1 API
TodoException Constructor (String)
TodoException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TodoException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
TodoException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

TodoException Class
TodoException Overload
Sitecore.Exceptions Namespace


TodoException Constructor (String, Exception)

[image]

Sitecore 6.4.1 API
TodoException Constructor (String, Exception)
TodoException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TodoException(
    string message,
    Exception innnerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innnerException As Exception _
)
Visual C++
public:
TodoException(
    String^ message,
    Exception^ innnerException
)

Parameters

message
Type: System..::..String
The message.
innnerException
Type: System..::..Exception
The innner exception.

See Also

TodoException Class
TodoException Overload
Sitecore.Exceptions Namespace


TodoException Properties

[image] [image]

Sitecore 6.4.1 API
TodoException Properties
TodoException Class See Also Send Feedback

The TodoException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

TodoException Class
Sitecore.Exceptions Namespace


UnknownDomainException Class

[image]

Sitecore 6.4.1 API
UnknownDomainException Class
Members See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class UnknownDomainException : SitecoreException
Visual Basic
<SerializableAttribute> _
Public Class UnknownDomainException _
    Inherits SitecoreException
Visual C++
[SerializableAttribute]
public ref class UnknownDomainException : public SitecoreException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Exceptions..::..SitecoreException
Sitecore.Exceptions..::..UnknownDomainException

See Also

UnknownDomainException Members
Sitecore.Exceptions Namespace


UnknownDomainException Members

[image] [image]

Sitecore 6.4.1 API
UnknownDomainException Members
UnknownDomainException Class Constructors Methods Properties See Also Send Feedback

The UnknownDomainException type exposes the following members.

Constructors

 | Name | Description
Public method | UnknownDomainException(String) | Initializes a new instance of the UnknownDomainException class.
Public method | UnknownDomainException(String, Exception) | Initializes a new instance of the UnknownDomainException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

UnknownDomainException Class
Sitecore.Exceptions Namespace


UnknownDomainException Constructor

[image] [image]

Sitecore 6.4.1 API
UnknownDomainException Constructor
UnknownDomainException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UnknownDomainException(String) | Initializes a new instance of the UnknownDomainException class.
Public method | UnknownDomainException(String, Exception) | Initializes a new instance of the UnknownDomainException class.

See Also

UnknownDomainException Class
UnknownDomainException Members
Sitecore.Exceptions Namespace


UnknownDomainException Constructor (String)

[image]

Sitecore 6.4.1 API
UnknownDomainException Constructor (String)
UnknownDomainException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UnknownDomainException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
UnknownDomainException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

UnknownDomainException Class
UnknownDomainException Overload
Sitecore.Exceptions Namespace


UnknownDomainException Constructor (String, Exception)

[image]

Sitecore 6.4.1 API
UnknownDomainException Constructor (String, Exception)
UnknownDomainException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UnknownDomainException(
    string message,
    Exception innnerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innnerException As Exception _
)
Visual C++
public:
UnknownDomainException(
    String^ message,
    Exception^ innnerException
)

Parameters

message
Type: System..::..String
The message.
innnerException
Type: System..::..Exception
The innner exception.

See Also

UnknownDomainException Class
UnknownDomainException Overload
Sitecore.Exceptions Namespace


UnknownDomainException Methods

[image] [image]

Sitecore 6.4.1 API
UnknownDomainException Methods
UnknownDomainException Class See Also Send Feedback

The UnknownDomainException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

UnknownDomainException Class
Sitecore.Exceptions Namespace


UnknownDomainException Properties

[image] [image]

Sitecore 6.4.1 API
UnknownDomainException Properties
UnknownDomainException Class See Also Send Feedback

The UnknownDomainException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

UnknownDomainException Class
Sitecore.Exceptions Namespace


UnknownTypeException Class

[image]

Sitecore 6.4.1 API
UnknownTypeException Class
Members See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class UnknownTypeException : SitecoreException
Visual Basic
<SerializableAttribute> _
Public Class UnknownTypeException _
    Inherits SitecoreException
Visual C++
[SerializableAttribute]
public ref class UnknownTypeException : public SitecoreException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Exceptions..::..SitecoreException
Sitecore.Exceptions..::..UnknownTypeException

See Also

UnknownTypeException Members
Sitecore.Exceptions Namespace


UnknownTypeException Members

[image] [image]

Sitecore 6.4.1 API
UnknownTypeException Members
UnknownTypeException Class Constructors Methods Properties See Also Send Feedback

The UnknownTypeException type exposes the following members.

Constructors

 | Name | Description
Public method | UnknownTypeException()()()() | Initializes a new instance of the UnknownTypeException class.
Public method | UnknownTypeException(String) | Initializes a new instance of the UnknownTypeException class.
Public method | UnknownTypeException(String, Exception) | Initializes a new instance of the UnknownTypeException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

UnknownTypeException Class
Sitecore.Exceptions Namespace


UnknownTypeException Constructor

[image] [image]

Sitecore 6.4.1 API
UnknownTypeException Constructor
UnknownTypeException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UnknownTypeException()()()() | Initializes a new instance of the UnknownTypeException class.
Public method | UnknownTypeException(String) | Initializes a new instance of the UnknownTypeException class.
Public method | UnknownTypeException(String, Exception) | Initializes a new instance of the UnknownTypeException class.

See Also

UnknownTypeException Class
UnknownTypeException Members
Sitecore.Exceptions Namespace


UnknownTypeException Constructor

[image]

Sitecore 6.4.1 API
UnknownTypeException Constructor
UnknownTypeException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UnknownTypeException()
Visual Basic
Public Sub New
Visual C++
public:
UnknownTypeException()

See Also

UnknownTypeException Class
UnknownTypeException Overload
Sitecore.Exceptions Namespace


UnknownTypeException Constructor (String)

[image]

Sitecore 6.4.1 API
UnknownTypeException Constructor (String)
UnknownTypeException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UnknownTypeException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
UnknownTypeException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

UnknownTypeException Class
UnknownTypeException Overload
Sitecore.Exceptions Namespace


UnknownTypeException Constructor (String, Exception)

[image]

Sitecore 6.4.1 API
UnknownTypeException Constructor (String, Exception)
UnknownTypeException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UnknownTypeException(
    string message,
    Exception innnerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innnerException As Exception _
)
Visual C++
public:
UnknownTypeException(
    String^ message,
    Exception^ innnerException
)

Parameters

message
Type: System..::..String
The message.
innnerException
Type: System..::..Exception
The innner exception.

See Also

UnknownTypeException Class
UnknownTypeException Overload
Sitecore.Exceptions Namespace


UnknownTypeException Properties

[image] [image]

Sitecore 6.4.1 API
UnknownTypeException Properties
UnknownTypeException Class See Also Send Feedback

The UnknownTypeException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

UnknownTypeException Class
Sitecore.Exceptions Namespace


UnsupportedThumbnailImageFormatException Class

[image]

Sitecore 6.4.1 API
UnsupportedThumbnailImageFormatException Class
Members See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class UnsupportedThumbnailImageFormatException : SitecoreException
Visual Basic
<SerializableAttribute> _
Public Class UnsupportedThumbnailImageFormatException _
    Inherits SitecoreException
Visual C++
[SerializableAttribute]
public ref class UnsupportedThumbnailImageFormatException : public SitecoreException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Exceptions..::..SitecoreException
Sitecore.Exceptions..::..UnsupportedThumbnailImageFormatException

See Also

UnsupportedThumbnailImageFormatException Members
Sitecore.Exceptions Namespace


UnsupportedThumbnailImageFormatException Members

[image] [image]

Sitecore 6.4.1 API
UnsupportedThumbnailImageFormatException Members
UnsupportedThumbnailImageFormatException Class Constructors Methods Properties See Also Send Feedback

The UnsupportedThumbnailImageFormatException type exposes the following members.

Constructors

 | Name | Description
Public method | UnsupportedThumbnailImageFormatException()()()() | Initializes a new instance of the UnsupportedThumbnailImageFormatException class.
Public method | UnsupportedThumbnailImageFormatException(String) | Initializes a new instance of the UnsupportedThumbnailImageFormatException class.
Public method | UnsupportedThumbnailImageFormatException(String, Exception) | Initializes a new instance of the UnsupportedThumbnailImageFormatException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

UnsupportedThumbnailImageFormatException Class
Sitecore.Exceptions Namespace


UnsupportedThumbnailImageFormatException Constructor

[image] [image]

Sitecore 6.4.1 API
UnsupportedThumbnailImageFormatException Constructor
UnsupportedThumbnailImageFormatException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UnsupportedThumbnailImageFormatException()()()() | Initializes a new instance of the UnsupportedThumbnailImageFormatException class.
Public method | UnsupportedThumbnailImageFormatException(String) | Initializes a new instance of the UnsupportedThumbnailImageFormatException class.
Public method | UnsupportedThumbnailImageFormatException(String, Exception) | Initializes a new instance of the UnsupportedThumbnailImageFormatException class.

See Also

UnsupportedThumbnailImageFormatException Class
UnsupportedThumbnailImageFormatException Members
Sitecore.Exceptions Namespace


UnsupportedThumbnailImageFormatException Constructor

[image]

Sitecore 6.4.1 API
UnsupportedThumbnailImageFormatException Constructor
UnsupportedThumbnailImageFormatException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UnsupportedThumbnailImageFormatException()
Visual Basic
Public Sub New
Visual C++
public:
UnsupportedThumbnailImageFormatException()

See Also

UnsupportedThumbnailImageFormatException Class
UnsupportedThumbnailImageFormatException Overload
Sitecore.Exceptions Namespace


UnsupportedThumbnailImageFormatException Constructor (String)

[image]

Sitecore 6.4.1 API
UnsupportedThumbnailImageFormatException Constructor (String)
UnsupportedThumbnailImageFormatException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UnsupportedThumbnailImageFormatException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
UnsupportedThumbnailImageFormatException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

UnsupportedThumbnailImageFormatException Class
UnsupportedThumbnailImageFormatException Overload
Sitecore.Exceptions Namespace


UnsupportedThumbnailImageFormatException Constructor (String, Exception)

[image]

Sitecore 6.4.1 API
UnsupportedThumbnailImageFormatException Constructor (String, Exception)
UnsupportedThumbnailImageFormatException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UnsupportedThumbnailImageFormatException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
UnsupportedThumbnailImageFormatException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

UnsupportedThumbnailImageFormatException Class
UnsupportedThumbnailImageFormatException Overload
Sitecore.Exceptions Namespace


UnsupportedThumbnailImageFormatException Methods

[image] [image]

Sitecore 6.4.1 API
UnsupportedThumbnailImageFormatException Methods
UnsupportedThumbnailImageFormatException Class See Also Send Feedback

The UnsupportedThumbnailImageFormatException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

UnsupportedThumbnailImageFormatException Class
Sitecore.Exceptions Namespace


UnsupportedThumbnailImageFormatException Properties

[image] [image]

Sitecore 6.4.1 API
UnsupportedThumbnailImageFormatException Properties
UnsupportedThumbnailImageFormatException Class See Also Send Feedback

The UnsupportedThumbnailImageFormatException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

UnsupportedThumbnailImageFormatException Class
Sitecore.Exceptions Namespace


WorkflowException Class

[image]

Sitecore 6.4.1 API
WorkflowException Class
Members See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class WorkflowException : SitecoreException
Visual Basic
<SerializableAttribute> _
Public Class WorkflowException _
    Inherits SitecoreException
Visual C++
[SerializableAttribute]
public ref class WorkflowException : public SitecoreException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Exceptions..::..SitecoreException
Sitecore.Exceptions..::..WorkflowException
Sitecore.Exceptions..::..WorkflowInitialStateMissingException
Sitecore.Exceptions..::..WorkflowStateMissingException

See Also

WorkflowException Members
Sitecore.Exceptions Namespace


WorkflowException Members

[image] [image]

Sitecore 6.4.1 API
WorkflowException Members
WorkflowException Class Constructors Methods Properties See Also Send Feedback

The WorkflowException type exposes the following members.

Constructors

 | Name | Description
Public method | WorkflowException()()()() | Initializes a new instance of the WorkflowException class.
Public method | WorkflowException(String) | Initializes a new instance of the WorkflowException class.
Public method | WorkflowException(String, Item) | Initializes a new instance of the WorkflowException class.
Public method | WorkflowException(String, Exception) | Initializes a new instance of the WorkflowException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Item | Gets the item.
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

WorkflowException Class
Sitecore.Exceptions Namespace


WorkflowException Constructor

[image] [image]

Sitecore 6.4.1 API
WorkflowException Constructor
WorkflowException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WorkflowException()()()() | Initializes a new instance of the WorkflowException class.
Public method | WorkflowException(String) | Initializes a new instance of the WorkflowException class.
Public method | WorkflowException(String, Item) | Initializes a new instance of the WorkflowException class.
Public method | WorkflowException(String, Exception) | Initializes a new instance of the WorkflowException class.

See Also

WorkflowException Class
WorkflowException Members
Sitecore.Exceptions Namespace


WorkflowException Constructor

[image]

Sitecore 6.4.1 API
WorkflowException Constructor
WorkflowException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WorkflowException()
Visual Basic
Public Sub New
Visual C++
public:
WorkflowException()

See Also

WorkflowException Class
WorkflowException Overload
Sitecore.Exceptions Namespace


WorkflowException Constructor (String)

[image]

Sitecore 6.4.1 API
WorkflowException Constructor (String)
WorkflowException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WorkflowException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
WorkflowException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

WorkflowException Class
WorkflowException Overload
Sitecore.Exceptions Namespace


WorkflowException Constructor (String, Item)

[image]

Sitecore 6.4.1 API
WorkflowException Constructor (String, Item)
WorkflowException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WorkflowException(
    string message,
    Item item
)
Visual Basic
Public Sub New ( _
    message As String, _
    item As Item _
)
Visual C++
public:
WorkflowException(
    String^ message,
    Item^ item
)

Parameters

message
Type: System..::..String
The message.
item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

WorkflowException Class
WorkflowException Overload
Sitecore.Exceptions Namespace


WorkflowException Constructor (String, Exception)

[image]

Sitecore 6.4.1 API
WorkflowException Constructor (String, Exception)
WorkflowException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WorkflowException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
WorkflowException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

WorkflowException Class
WorkflowException Overload
Sitecore.Exceptions Namespace


WorkflowException Methods

[image] [image]

Sitecore 6.4.1 API
WorkflowException Methods
WorkflowException Class See Also Send Feedback

The WorkflowException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

WorkflowException Class
Sitecore.Exceptions Namespace


WorkflowException Properties

[image] [image]

Sitecore 6.4.1 API
WorkflowException Properties
WorkflowException Class See Also Send Feedback

The WorkflowException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Item | Gets the item.
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

WorkflowException Class
Sitecore.Exceptions Namespace


Item Property

[image]

Sitecore 6.4.1 API
WorkflowException..::..Item Property
WorkflowException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Item { get; }
Visual Basic
Public ReadOnly Property Item As Item
    Get
Visual C++
public:
property Item^ Item {
    Item^ get ();
}

Field Value

The item.

See Also

WorkflowException Class
Sitecore.Exceptions Namespace


WorkflowInitialStateMissingException Class

[image]

Sitecore 6.4.1 API
WorkflowInitialStateMissingException Class
Members See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class WorkflowInitialStateMissingException : WorkflowException
Visual Basic
<SerializableAttribute> _
Public Class WorkflowInitialStateMissingException _
    Inherits WorkflowException
Visual C++
[SerializableAttribute]
public ref class WorkflowInitialStateMissingException : public WorkflowException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Exceptions..::..SitecoreException
Sitecore.Exceptions..::..WorkflowException
Sitecore.Exceptions..::..WorkflowInitialStateMissingException

See Also

WorkflowInitialStateMissingException Members
Sitecore.Exceptions Namespace


WorkflowInitialStateMissingException Members

[image] [image]

Sitecore 6.4.1 API
WorkflowInitialStateMissingException Members
WorkflowInitialStateMissingException Class Constructors Methods Properties See Also Send Feedback

The WorkflowInitialStateMissingException type exposes the following members.

Constructors

 | Name | Description
Public method | WorkflowInitialStateMissingException | Initializes a new instance of the WorkflowInitialStateMissingException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Item | Gets the item. (Inherited from WorkflowException.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

WorkflowInitialStateMissingException Class
Sitecore.Exceptions Namespace


WorkflowInitialStateMissingException Constructor

[image]

Sitecore 6.4.1 API
WorkflowInitialStateMissingException Constructor
WorkflowInitialStateMissingException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WorkflowInitialStateMissingException(
    Item item,
    string workflow
)
Visual Basic
Public Sub New ( _
    item As Item, _
    workflow As String _
)
Visual C++
public:
WorkflowInitialStateMissingException(
    Item^ item,
    String^ workflow
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
workflow
Type: System..::..String
The workflow.

See Also

WorkflowInitialStateMissingException Class
Sitecore.Exceptions Namespace


WorkflowInitialStateMissingException Methods

[image] [image]

Sitecore 6.4.1 API
WorkflowInitialStateMissingException Methods
WorkflowInitialStateMissingException Class See Also Send Feedback

The WorkflowInitialStateMissingException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

WorkflowInitialStateMissingException Class
Sitecore.Exceptions Namespace


WorkflowInitialStateMissingException Properties

[image] [image]

Sitecore 6.4.1 API
WorkflowInitialStateMissingException Properties
WorkflowInitialStateMissingException Class See Also Send Feedback

The WorkflowInitialStateMissingException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Item | Gets the item. (Inherited from WorkflowException.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

WorkflowInitialStateMissingException Class
Sitecore.Exceptions Namespace


WorkflowStateMissingException Class

[image]

Sitecore 6.4.1 API
WorkflowStateMissingException Class
Members See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class WorkflowStateMissingException : WorkflowException
Visual Basic
<SerializableAttribute> _
Public Class WorkflowStateMissingException _
    Inherits WorkflowException
Visual C++
[SerializableAttribute]
public ref class WorkflowStateMissingException : public WorkflowException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Exceptions..::..SitecoreException
Sitecore.Exceptions..::..WorkflowException
Sitecore.Exceptions..::..WorkflowStateMissingException

See Also

WorkflowStateMissingException Members
Sitecore.Exceptions Namespace


WorkflowStateMissingException Members

[image] [image]

Sitecore 6.4.1 API
WorkflowStateMissingException Members
WorkflowStateMissingException Class Constructors Methods Properties See Also Send Feedback

The WorkflowStateMissingException type exposes the following members.

Constructors

 | Name | Description
Public method | WorkflowStateMissingException()()()() | Initializes a new instance of the WorkflowStateMissingException class.
Public method | WorkflowStateMissingException(String) | Initializes a new instance of the WorkflowStateMissingException class.
Public method | WorkflowStateMissingException(String, Exception) | Initializes a new instance of the WorkflowStateMissingException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Item | Gets the item. (Inherited from WorkflowException.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

WorkflowStateMissingException Class
Sitecore.Exceptions Namespace


WorkflowStateMissingException Constructor

[image] [image]

Sitecore 6.4.1 API
WorkflowStateMissingException Constructor
WorkflowStateMissingException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WorkflowStateMissingException()()()() | Initializes a new instance of the WorkflowStateMissingException class.
Public method | WorkflowStateMissingException(String) | Initializes a new instance of the WorkflowStateMissingException class.
Public method | WorkflowStateMissingException(String, Exception) | Initializes a new instance of the WorkflowStateMissingException class.

See Also

WorkflowStateMissingException Class
WorkflowStateMissingException Members
Sitecore.Exceptions Namespace


WorkflowStateMissingException Constructor

[image]

Sitecore 6.4.1 API
WorkflowStateMissingException Constructor
WorkflowStateMissingException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WorkflowStateMissingException()
Visual Basic
Public Sub New
Visual C++
public:
WorkflowStateMissingException()

See Also

WorkflowStateMissingException Class
WorkflowStateMissingException Overload
Sitecore.Exceptions Namespace


WorkflowStateMissingException Constructor (String)

[image]

Sitecore 6.4.1 API
WorkflowStateMissingException Constructor (String)
WorkflowStateMissingException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WorkflowStateMissingException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
WorkflowStateMissingException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

WorkflowStateMissingException Class
WorkflowStateMissingException Overload
Sitecore.Exceptions Namespace


WorkflowStateMissingException Constructor (String, Exception)

[image]

Sitecore 6.4.1 API
WorkflowStateMissingException Constructor (String, Exception)
WorkflowStateMissingException Class See Also Send Feedback

Namespace: Sitecore.Exceptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WorkflowStateMissingException(
    string message,
    Exception innnerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innnerException As Exception _
)
Visual C++
public:
WorkflowStateMissingException(
    String^ message,
    Exception^ innnerException
)

Parameters

message
Type: System..::..String
The message.
innnerException
Type: System..::..Exception
The innner exception.

See Also

WorkflowStateMissingException Class
WorkflowStateMissingException Overload
Sitecore.Exceptions Namespace


WorkflowStateMissingException Methods

[image] [image]

Sitecore 6.4.1 API
WorkflowStateMissingException Methods
WorkflowStateMissingException Class See Also Send Feedback

The WorkflowStateMissingException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

WorkflowStateMissingException Class
Sitecore.Exceptions Namespace


WorkflowStateMissingException Properties

[image] [image]

Sitecore 6.4.1 API
WorkflowStateMissingException Properties
WorkflowStateMissingException Class See Also Send Feedback

The WorkflowStateMissingException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Item | Gets the item. (Inherited from WorkflowException.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

WorkflowStateMissingException Class
Sitecore.Exceptions Namespace


Sitecore.Express Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Express Namespace
Send Feedback

Classes

 | Class | Description
Public class | Application | Implements the Application.
Public class | Application..::..ApplicationSettings | Represents a ApplicationSettings.
Public class | ExpressItem |
Public class | Items | Represents a set of Items.


Application Class

[image]

Sitecore 6.4.1 API
Application Class
Members See Also Send Feedback

Namespace: Sitecore.Express
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Application
Visual Basic
Public NotInheritable Class Application
Visual C++
public ref class Application abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Express..::..Application

See Also

Application Members
Sitecore.Express Namespace


Application Methods

[image] [image]

Sitecore 6.4.1 API
Application Methods
Application Class See Also Send Feedback

The Application type exposes the following members.

Methods

Name | Description
Log | Logs the specified text.

See Also

Application Class
Sitecore.Express Namespace


Log Method

[image]

Sitecore 6.4.1 API
Application..::..Log Method
Application Class See Also Send Feedback

Namespace: Sitecore.Express
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Log(
    string text
)
Visual Basic
Public Shared Sub Log ( _
    text As String _
)
Visual C++
public:
static void Log(
    String^ text
)

Parameters

text
Type: System..::..String
The text.

See Also

Application Class
Sitecore.Express Namespace


Application Properties

[image] [image]

Sitecore 6.4.1 API
Application Properties
Application Class See Also Send Feedback

The Application type exposes the following members.

Properties

Name | Description
Language | Gets or sets the language.
Settings | Gets the settings.
Version | Gets the version.

See Also

Application Class
Sitecore.Express Namespace


Language Property

[image]

Sitecore 6.4.1 API
Application..::..Language Property
Application Class See Also Send Feedback

Namespace: Sitecore.Express
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Language { get; set; }
Visual Basic
Public Shared Property Language As String
    Get
    Set
Visual C++
public:
static property String^ Language {
    String^ get ();
    void set (String^ value);
}

Field Value

The language.

See Also

Application Class
Sitecore.Express Namespace


Settings Property

[image]

Sitecore 6.4.1 API
Application..::..Settings Property
Application Class See Also Send Feedback

Namespace: Sitecore.Express
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Application..::..ApplicationSettings Settings { get; }
Visual Basic
Public Shared ReadOnly Property Settings As Application..::..ApplicationSettings
    Get
Visual C++
public:
static property Application..::..ApplicationSettings^ Settings {
    Application..::..ApplicationSettings^ get ();
}

Field Value

The settings.

See Also

Application Class
Sitecore.Express Namespace


Version Property

[image]

Sitecore 6.4.1 API
Application..::..Version Property
Application Class See Also Send Feedback

Namespace: Sitecore.Express
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Version { get; }
Visual Basic
Public Shared ReadOnly Property Version As String
    Get
Visual C++
public:
static property String^ Version {
    String^ get ();
}

Field Value

The version.

See Also

Application Class
Sitecore.Express Namespace


Application.ApplicationSettings Class

[image]

Sitecore 6.4.1 API
Application..::..ApplicationSettings Class
Application Class Members See Also Send Feedback

Namespace: Sitecore.Express
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ApplicationSettings
Visual Basic
Public Class ApplicationSettings
Visual C++
public ref class ApplicationSettings

Inheritance Hierarchy

System..::..Object
Sitecore.Express..::..Application..::..ApplicationSettings

See Also

Application..::..ApplicationSettings Members
Sitecore.Express Namespace


Application.ApplicationSettings Members

[image] [image]

Sitecore 6.4.1 API
Application..::..ApplicationSettings Members
Application..::..ApplicationSettings Class Constructors Methods Properties See Also Send Feedback

Implements the Application.

The Application..::..ApplicationSettings type exposes the following members.

Constructors

 | Name | Description
Public method | Application..::..ApplicationSettings | Initializes a new instance of the Application..::..ApplicationSettings class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item[([( String])]) | Gets the String with the specified name.
Public property | Item[([( String, String])]) | Gets the String with the specified name.

See Also

Application..::..ApplicationSettings Class
Sitecore.Express Namespace


Application.ApplicationSettings Constructor

[image]

Sitecore 6.4.1 API
Application..::..ApplicationSettings Constructor
Application..::..ApplicationSettings Class See Also Send Feedback

Namespace: Sitecore.Express
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ApplicationSettings()
Visual Basic
Public Sub New
Visual C++
public:
ApplicationSettings()

See Also

Application..::..ApplicationSettings Class
Sitecore.Express Namespace


Application.ApplicationSettings Methods

[image] [image]

Sitecore 6.4.1 API
Application..::..ApplicationSettings Methods
Application..::..ApplicationSettings Class See Also Send Feedback

The Application..::..ApplicationSettings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Application..::..ApplicationSettings Class
Sitecore.Express Namespace


Application.ApplicationSettings Properties

[image] [image]

Sitecore 6.4.1 API
Application..::..ApplicationSettings Properties
Application..::..ApplicationSettings Class See Also Send Feedback

Properties

 | Name | Description
Public property | Item[([( String])]) | Gets the String with the specified name.
Public property | Item[([( String, String])]) | Gets the String with the specified name.

See Also

Application..::..ApplicationSettings Class
Sitecore.Express Namespace


Item Property

[image] [image]

Sitecore 6.4.1 API
Application..::..ApplicationSettings..::..Item Property
Application..::..ApplicationSettings Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( String])]) | Gets the String with the specified name.
Public property | Item[([( String, String])]) | Gets the String with the specified name.

See Also

Application..::..ApplicationSettings Class
Application..::..ApplicationSettings Members
Sitecore.Express Namespace


Item Property (String)

[image]

Sitecore 6.4.1 API
Application..::..ApplicationSettings..::..Item Property (String)
Application..::..ApplicationSettings Class See Also Send Feedback

Namespace: Sitecore.Express
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string this[
    string name
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    name As String _
) As String
    Get
Visual C++
public:
property String^ default[String^ name] {
    String^ get (String^ name);
}

Parameters

name
Type: System..::..String

Field Value

The string.

See Also

Application..::..ApplicationSettings Class
Item Overload
Sitecore.Express Namespace


Item Property (String, String)

[image]

Sitecore 6.4.1 API
Application..::..ApplicationSettings..::..Item Property (String, String)
Application..::..ApplicationSettings Class See Also Send Feedback

Namespace: Sitecore.Express
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string this[
    string name,
    string defaultValue
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    name As String, _
    defaultValue As String _
) As String
    Get
Visual C++
public:
property String^ default[String^ name, String^ defaultValue] {
    String^ get (String^ name, String^ defaultValue);
}

Parameters

name
Type: System..::..String
defaultValue
Type: System..::..String

Field Value

The setting.

See Also

Application..::..ApplicationSettings Class
Item Overload
Sitecore.Express Namespace


ExpressItem Members

[image] [image]

Sitecore 6.4.1 API
ExpressItem Members
ExpressItem Class Constructors Methods Operators Properties See Also Send Feedback

The ExpressItem type exposes the following members.

Constructors

 | Name | Description
Public method | ExpressItem | Initializes a new instance of the ExpressItem class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Item to ExpressItem) | Implicit operators the specified item.

Properties

 | Name | Description
Public property | Children | Gets the children.
Public property | ID | Gets the ID.
Public property | InnerItem | Gets the inner item.
Public property | Item | Gets the String with the specified name.
Public property | Name | Gets the name.

See Also

ExpressItem Class
Sitecore.Express Namespace


ExpressItem Constructor

[image]

Sitecore 6.4.1 API
ExpressItem Constructor
ExpressItem Class See Also Send Feedback

Namespace: Sitecore.Express
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ExpressItem(
    Item innerItem
)
Visual Basic
Public Sub New ( _
    innerItem As Item _
)
Visual C++
public:
ExpressItem(
    Item^ innerItem
)

Parameters

innerItem
Type: Sitecore.Data.Items..::..Item
The inner item.

See Also

ExpressItem Class
Sitecore.Express Namespace


ExpressItem Methods

[image] [image]

Sitecore 6.4.1 API
ExpressItem Methods
ExpressItem Class See Also Send Feedback

The ExpressItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExpressItem Class
Sitecore.Express Namespace


Implicit Conversion (Item to ExpressItem)

[image]

Sitecore 6.4.1 API
ExpressItem ImplicitWideningImplicitImplicitImplicit Conversion (Item to ExpressItem)
ExpressItem Class See Also Send Feedback

Namespace: Sitecore.Express
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static implicit operator ExpressItem (
    Item item
)
Visual Basic
Public Shared Widening Operator CType ( _
    item As Item _
) As ExpressItem
Visual C++
static implicit operator ExpressItem^ (
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Express.ExpressItem.op_Implicit(Sitecore.Data.Items.Item)~Sitecore.Express.ExpressItem"]

See Also

ExpressItem Class
Sitecore.Express Namespace


ExpressItem Properties

[image] [image]

Sitecore 6.4.1 API
ExpressItem Properties
ExpressItem Class See Also Send Feedback

The ExpressItem type exposes the following members.

Properties

 | Name | Description
Public property | Children | Gets the children.
Public property | ID | Gets the ID.
Public property | InnerItem | Gets the inner item.
Public property | Item | Gets the String with the specified name.
Public property | Name | Gets the name.

See Also

ExpressItem Class
Sitecore.Express Namespace


ID Property

[image]

Sitecore 6.4.1 API
ExpressItem..::..ID Property
ExpressItem Class See Also Send Feedback

Namespace: Sitecore.Express
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ID { get; }
Visual Basic
Public ReadOnly Property ID As ID
    Get
Visual C++
public:
property ID^ ID {
    ID^ get ();
}

Field Value

The ID.

See Also

ExpressItem Class
Sitecore.Express Namespace


InnerItem Property

[image]

Sitecore 6.4.1 API
ExpressItem..::..InnerItem Property
ExpressItem Class See Also Send Feedback

Namespace: Sitecore.Express
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item InnerItem { get; }
Visual Basic
Public ReadOnly Property InnerItem As Item
    Get
Visual C++
public:
property Item^ InnerItem {
    Item^ get ();
}

Field Value

The inner item.

See Also

ExpressItem Class
Sitecore.Express Namespace


Item Property

[image]

Sitecore 6.4.1 API
ExpressItem..::..Item Property
ExpressItem Class See Also Send Feedback

Namespace: Sitecore.Express
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string this[
    string name
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    name As String _
) As String
    Get
Visual C++
public:
property String^ default[String^ name] {
    String^ get (String^ name);
}

Parameters

name
Type: System..::..String

Field Value

See Also

ExpressItem Class
Sitecore.Express Namespace


Name Property

[image]

Sitecore 6.4.1 API
ExpressItem..::..Name Property
ExpressItem Class See Also Send Feedback

Namespace: Sitecore.Express
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

ExpressItem Class
Sitecore.Express Namespace


Items Class

[image]

Sitecore 6.4.1 API
Items Class
Members See Also Send Feedback

Namespace: Sitecore.Express
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Items
Visual Basic
Public NotInheritable Class Items
Visual C++
public ref class Items abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Express..::..Items

See Also

Items Members
Sitecore.Express Namespace


Items Members

[image] [image]

Sitecore 6.4.1 API
Items Members
Items Class Methods Properties See Also Send Feedback

The Items type exposes the following members.

Methods

Name | Description
AddItem | Adds the item.
DeleteItem | Deletes the item.
Exists | Determines if the item exists.
GetItem | Gets the item.
Publish | Obsolete. Publishes.
PublishItem | Obsolete. Publishes the item.
SelectItems | Selects the items.
SelectSingleItem | Selects the single item.

Properties

Name | Description
CurrentItem | Gets the current item.
Item | Gets the item.

See Also

Items Class
Sitecore.Express Namespace


Items Methods

[image] [image]

Sitecore 6.4.1 API
Items Methods
Items Class See Also Send Feedback

The Items type exposes the following members.

Methods

Name | Description
AddItem | Adds the item.
DeleteItem | Deletes the item.
Exists | Determines if the item exists.
GetItem | Gets the item.
Publish | Obsolete. Publishes.
PublishItem | Obsolete. Publishes the item.
SelectItems | Selects the items.
SelectSingleItem | Selects the single item.

See Also

Items Class
Sitecore.Express Namespace


AddItem Method

[image]

Sitecore 6.4.1 API
Items..::..AddItem Method
Items Class See Also Send Feedback

Namespace: Sitecore.Express
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item AddItem(
    string parent,
    string name,
    string template
)
Visual Basic
Public Shared Function AddItem ( _
    parent As String, _
    name As String, _
    template As String _
) As Item
Visual C++
public:
static Item^ AddItem(
    String^ parent,
    String^ name,
    String^ template
)

Parameters

parent
Type: System..::..String
The parent.
name
Type: System..::..String
The name.
template
Type: System..::..String
The template.

Return Value

[Missing <returns> documentation for "M:Sitecore.Express.Items.AddItem(System.String,System.String,System.String)"]

See Also

Items Class
Sitecore.Express Namespace


DeleteItem Method

[image]

Sitecore 6.4.1 API
Items..::..DeleteItem Method
Items Class See Also Send Feedback

Namespace: Sitecore.Express
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void DeleteItem(
    string id
)
Visual Basic
Public Shared Sub DeleteItem ( _
    id As String _
)
Visual C++
public:
static void DeleteItem(
    String^ id
)

Parameters

id
Type: System..::..String
The id.

See Also

Items Class
Sitecore.Express Namespace


Exists Method

[image]

Sitecore 6.4.1 API
Items..::..Exists Method
Items Class See Also Send Feedback

Namespace: Sitecore.Express
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool Exists(
    ID itemID
)
Visual Basic
Public Shared Function Exists ( _
    itemID As ID _
) As Boolean
Visual C++
public:
static bool Exists(
    ID^ itemID
)

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.

Return Value

[Missing <returns> documentation for "M:Sitecore.Express.Items.Exists(Sitecore.Data.ID)"]

See Also

Items Class
Sitecore.Express Namespace


GetItem Method

[image]

Sitecore 6.4.1 API
Items..::..GetItem Method
Items Class See Also Send Feedback

Namespace: Sitecore.Express
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ExpressItem GetItem(
    string id
)
Visual Basic
Public Shared Function GetItem ( _
    id As String _
) As ExpressItem
Visual C++
public:
static ExpressItem^ GetItem(
    String^ id
)

Parameters

id
Type: System..::..String
The id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Express.Items.GetItem(System.String)"]

See Also

Items Class
Sitecore.Express Namespace


Publish Method

[image]

Sitecore 6.4.1 API
Items..::..Publish Method
Items Class See Also Send Feedback

Namespace: Sitecore.Express
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public static void Publish()
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Shared Sub Publish
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public:
static void Publish()

See Also

Items Class
Sitecore.Express Namespace


PublishItem Method

[image]

Sitecore 6.4.1 API
Items..::..PublishItem Method
Items Class See Also Send Feedback

Namespace: Sitecore.Express
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public static void PublishItem(
    string id
)
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Shared Sub PublishItem ( _
    id As String _
)
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public:
static void PublishItem(
    String^ id
)

Parameters

id
Type: System..::..String
The id.

See Also

Items Class
Sitecore.Express Namespace


SelectItems Method

[image]

Sitecore 6.4.1 API
Items..::..SelectItems Method
Items Class See Also Send Feedback

Namespace: Sitecore.Express
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item[] SelectItems(
    string query
)
Visual Basic
Public Shared Function SelectItems ( _
    query As String _
) As Item()
Visual C++
public:
static array<Item^>^ SelectItems(
    String^ query
)

Parameters

query
Type: System..::..String
The query.

Return Value

[Missing <returns> documentation for "M:Sitecore.Express.Items.SelectItems(System.String)"]

See Also

Items Class
Sitecore.Express Namespace


SelectSingleItem Method

[image]

Sitecore 6.4.1 API
Items..::..SelectSingleItem Method
Items Class See Also Send Feedback

Namespace: Sitecore.Express
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ExpressItem SelectSingleItem(
    string query
)
Visual Basic
Public Shared Function SelectSingleItem ( _
    query As String _
) As ExpressItem
Visual C++
public:
static ExpressItem^ SelectSingleItem(
    String^ query
)

Parameters

query
Type: System..::..String
The query.

Return Value

[Missing <returns> documentation for "M:Sitecore.Express.Items.SelectSingleItem(System.String)"]

See Also

Items Class
Sitecore.Express Namespace


Items Properties

[image] [image]

Sitecore 6.4.1 API
Items Properties
Items Class See Also Send Feedback

The Items type exposes the following members.

Properties

Name | Description
CurrentItem | Gets the current item.
Item | Gets the item.

See Also

Items Class
Sitecore.Express Namespace


CurrentItem Property

[image]

Sitecore 6.4.1 API
Items..::..CurrentItem Property
Items Class See Also Send Feedback

Namespace: Sitecore.Express
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item CurrentItem { get; }
Visual Basic
Public Shared ReadOnly Property CurrentItem As Item
    Get
Visual C++
public:
static property Item^ CurrentItem {
    Item^ get ();
}

Field Value

The current item.

See Also

Items Class
Sitecore.Express Namespace


Item Property

[image]

Sitecore 6.4.1 API
Items..::..Item Property
Items Class See Also Send Feedback

Namespace: Sitecore.Express
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Database..::..DataRecords Item { get; }
Visual Basic
Public Shared ReadOnly Property Item As Database..::..DataRecords
    Get
Visual C++
public:
static property Database..::..DataRecords^ Item {
    Database..::..DataRecords^ get ();
}

Field Value

The item.

See Also

Items Class
Sitecore.Express Namespace


Sitecore.Extensions Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Extensions Namespace
Send Feedback

Classes

 | Class | Description
Public class | CommonExtensions | The common extensions.
Public class | DirectoryExtension | Extensions for Lucene.Net.Store.FSDirectory class.
Public class | ObjectExtensions | ObjectExtensions class.


CommonExtensions Class

[image]

Sitecore 6.4.1 API
CommonExtensions Class
Members See Also Send Feedback

Namespace: Sitecore.Extensions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class CommonExtensions
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class CommonExtensions
Visual C++
[ExtensionAttribute]
public ref class CommonExtensions abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Extensions..::..CommonExtensions

See Also

CommonExtensions Members
Sitecore.Extensions Namespace


CommonExtensions Members

[image] [image]

Sitecore 6.4.1 API
CommonExtensions Members
CommonExtensions Class Methods See Also Send Feedback

The CommonExtensions type exposes the following members.

Methods

Name | Description
LocalizeGrid | Localizes the Component Art grid.

See Also

CommonExtensions Class
Sitecore.Extensions Namespace


CommonExtensions Methods

[image] [image]

Sitecore 6.4.1 API
CommonExtensions Methods
CommonExtensions Class See Also Send Feedback

The CommonExtensions type exposes the following members.

Methods

Name | Description
LocalizeGrid | Localizes the Component Art grid.

See Also

CommonExtensions Class
Sitecore.Extensions Namespace


LocalizeGrid Method

[image]

Sitecore 6.4.1 API
CommonExtensions..::..LocalizeGrid Method
CommonExtensions Class See Also Send Feedback

Namespace: Sitecore.Extensions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void LocalizeGrid(
    this Grid grid
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub LocalizeGrid ( _
    grid As Grid _
)
Visual C++
[ExtensionAttribute]
public:
static void LocalizeGrid(
    Grid^ grid
)

Parameters

grid
Type: Grid
The grid to localize.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Grid. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

CommonExtensions Class
Sitecore.Extensions Namespace


DirectoryExtension Class

[image]

Sitecore 6.4.1 API
DirectoryExtension Class
Members See Also Send Feedback

Namespace: Sitecore.Extensions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class DirectoryExtension
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class DirectoryExtension
Visual C++
[ExtensionAttribute]
public ref class DirectoryExtension abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Extensions..::..DirectoryExtension

See Also

DirectoryExtension Members
Sitecore.Extensions Namespace


DirectoryExtension Methods

[image] [image]

Sitecore 6.4.1 API
DirectoryExtension Methods
DirectoryExtension Class See Also Send Feedback

The DirectoryExtension type exposes the following members.

Methods

Name | Description
Exists | Check if directory exists on file system.
GetPath | Returns path for existing FSDirectory.

See Also

DirectoryExtension Class
Sitecore.Extensions Namespace


Exists Method

[image]

Sitecore 6.4.1 API
DirectoryExtension..::..Exists Method
DirectoryExtension Class See Also Send Feedback

Namespace: Sitecore.Extensions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool Exists(
    this Directory directory
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function Exists ( _
    directory As Directory _
) As Boolean
Visual C++
[ExtensionAttribute]
public:
static bool Exists(
    Directory^ directory
)

Parameters

directory
Type: Directory
Directory object to check.

Return Value

true if directory exists false otherwise

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Directory. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

DirectoryExtension Class
Sitecore.Extensions Namespace


GetPath Method

[image]

Sitecore 6.4.1 API
DirectoryExtension..::..GetPath Method
DirectoryExtension Class See Also Send Feedback

Namespace: Sitecore.Extensions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetPath(
    this Directory directory
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function GetPath ( _
    directory As Directory _
) As String
Visual C++
[ExtensionAttribute]
public:
static String^ GetPath(
    Directory^ directory
)

Parameters

directory
Type: Directory
FSDirectory object.

Return Value

The path.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Directory. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

DirectoryExtension Class
Sitecore.Extensions Namespace


ObjectExtensions Class

[image]

Sitecore 6.4.1 API
ObjectExtensions Class
Members See Also Send Feedback

Namespace: Sitecore.Extensions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class ObjectExtensions
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class ObjectExtensions
Visual C++
[ExtensionAttribute]
public ref class ObjectExtensions abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Extensions..::..ObjectExtensions

See Also

ObjectExtensions Members
Sitecore.Extensions Namespace


ObjectExtensions Members

[image] [image]

Sitecore 6.4.1 API
ObjectExtensions Members
ObjectExtensions Class Methods See Also Send Feedback

The ObjectExtensions type exposes the following members.

Methods

Name | Description
DefaultOr<(Of <<'(TInput, TOutput>)>>) | Defaults the or.
NullOr<(Of <<'(TInput, TOutput>)>>) | Nulls the or.

See Also

ObjectExtensions Class
Sitecore.Extensions Namespace


ObjectExtensions Methods

[image] [image]

Sitecore 6.4.1 API
ObjectExtensions Methods
ObjectExtensions Class See Also Send Feedback

The ObjectExtensions type exposes the following members.

Methods

Name | Description
DefaultOr<(Of <<'(TInput, TOutput>)>>) | Defaults the or.
NullOr<(Of <<'(TInput, TOutput>)>>) | Nulls the or.

See Also

ObjectExtensions Class
Sitecore.Extensions Namespace


DefaultOr(TInput, TOutput) Method

[image]

Sitecore 6.4.1 API
ObjectExtensions..::..DefaultOr<(Of <(<'TInput, TOutput>)>)> Method
ObjectExtensions Class See Also Send Feedback

Namespace: Sitecore.Extensions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TOutput DefaultOr<TInput, TOutput>(
    this TInput value,
    Func<TInput, TOutput> selector
)
where TInput : class
Visual Basic
<ExtensionAttribute> _
Public Shared Function DefaultOr(Of TInput As Class, TOutput) ( _
    value As TInput, _
    selector As Func(Of TInput, TOutput) _
) As TOutput
Visual C++
[ExtensionAttribute]
public:
generic<typename TInput, typename TOutput>
where TInput : ref class
static TOutput DefaultOr(
    TInput value,
    Func<TInput, TOutput>^ selector
)

Parameters

value
Type: TInput
The value.
selector
Type: System..::..Func <(Of <(<'TInput, TOutput>)>)>
The selector.

Type Parameters

TInput
The type of the input.
TOutput
The type of the output.

Return Value

The result.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

ObjectExtensions Class
Sitecore.Extensions Namespace


NullOr(TInput, TOutput) Method

[image]

Sitecore 6.4.1 API
ObjectExtensions..::..NullOr<(Of <(<'TInput, TOutput>)>)> Method
ObjectExtensions Class See Also Send Feedback

Namespace: Sitecore.Extensions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static TOutput NullOr<TInput, TOutput>(
    this TInput value,
    Func<TInput, TOutput> selector
)
where TInput : class
where TOutput : class
Visual Basic
<ExtensionAttribute> _
Public Shared Function NullOr(Of TInput As Class, TOutput As Class) ( _
    value As TInput, _
    selector As Func(Of TInput, TOutput) _
) As TOutput
Visual C++
[ExtensionAttribute]
public:
generic<typename TInput, typename TOutput>
where TInput : ref class
where TOutput : ref class
static TOutput NullOr(
    TInput value,
    Func<TInput, TOutput>^ selector
)

Parameters

value
Type: TInput
The value.
selector
Type: System..::..Func <(Of <(<'TInput, TOutput>)>)>
The selector.

Type Parameters

TInput
The type.
TOutput
The return type.

Return Value

The result.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

ObjectExtensions Class
Sitecore.Extensions Namespace


Sitecore.Extensions.DatabaseExtensions Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Extensions.DatabaseExtensions Namespace
Send Feedback

Classes

 | Class | Description
Public class | DatabaseExtensions | Extensions methods for Database.


DatabaseExtensions Class

[image]

Sitecore 6.4.1 API
DatabaseExtensions Class
Members See Also Send Feedback

Namespace: Sitecore.Extensions.DatabaseExtensions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class DatabaseExtensions
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class DatabaseExtensions
Visual C++
[ExtensionAttribute]
public ref class DatabaseExtensions abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Extensions.DatabaseExtensions..::..DatabaseExtensions

See Also

DatabaseExtensions Members
Sitecore.Extensions.DatabaseExtensions Namespace


DatabaseExtensions Methods

[image] [image]

Sitecore 6.4.1 API
DatabaseExtensions Methods
DatabaseExtensions Class See Also Send Feedback

The DatabaseExtensions type exposes the following members.

Methods

Name | Description
GetKnownItem | Gets the known item.
GetKnownItemId | Gets the leftmost part of a string.

See Also

DatabaseExtensions Class
Sitecore.Extensions.DatabaseExtensions Namespace


GetKnownItem Method

[image]

Sitecore 6.4.1 API
DatabaseExtensions..::..GetKnownItem Method
DatabaseExtensions Class See Also Send Feedback

Namespace: Sitecore.Extensions.DatabaseExtensions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item GetKnownItem(
    this Database database,
    string itemPath
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function GetKnownItem ( _
    database As Database, _
    itemPath As String _
) As Item
Visual C++
[ExtensionAttribute]
public:
static Item^ GetKnownItem(
    Database^ database,
    String^ itemPath
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.
itemPath
Type: System..::..String
The item path.

Return Value

The known item.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Database. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

DatabaseExtensions Class
Sitecore.Extensions.DatabaseExtensions Namespace


GetKnownItemId Method

[image]

Sitecore 6.4.1 API
DatabaseExtensions..::..GetKnownItemId Method
DatabaseExtensions Class See Also Send Feedback

Namespace: Sitecore.Extensions.DatabaseExtensions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID GetKnownItemId(
    this Database database,
    string itemPath
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function GetKnownItemId ( _
    database As Database, _
    itemPath As String _
) As ID
Visual C++
[ExtensionAttribute]
public:
static ID^ GetKnownItemId(
    Database^ database,
    String^ itemPath
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.
itemPath
Type: System..::..String
The item path.

Return Value

The known item id.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Database. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

DatabaseExtensions Class
Sitecore.Extensions.DatabaseExtensions Namespace


Sitecore.Extensions.StringExtensions Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Extensions.StringExtensions Namespace
Send Feedback

Classes

 | Class | Description
Public class | StringExtensions | Extensions methods for string.


StringExtensions Class

[image]

Sitecore 6.4.1 API
StringExtensions Class
Members See Also Send Feedback

Namespace: Sitecore.Extensions.StringExtensions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class StringExtensions
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class StringExtensions
Visual C++
[ExtensionAttribute]
public ref class StringExtensions abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Extensions.StringExtensions..::..StringExtensions

See Also

StringExtensions Members
Sitecore.Extensions.StringExtensions Namespace


StringExtensions Members

[image] [image]

Sitecore 6.4.1 API
StringExtensions Members
StringExtensions Class Methods See Also Send Feedback

The StringExtensions type exposes the following members.

Methods

Name | Description
Left | Gets the leftmost part of a string.
Mid(String, Int32) | Gets the middle part of a string.
Mid(String, Int32, Int32) | Gets the middle part of a string.
Right | Gets the rightmost part of a string.

See Also

StringExtensions Class
Sitecore.Extensions.StringExtensions Namespace


StringExtensions Methods

[image] [image]

Sitecore 6.4.1 API
StringExtensions Methods
StringExtensions Class See Also Send Feedback

The StringExtensions type exposes the following members.

Methods

Name | Description
Left | Gets the leftmost part of a string.
Mid(String, Int32) | Gets the middle part of a string.
Mid(String, Int32, Int32) | Gets the middle part of a string.
Right | Gets the rightmost part of a string.

See Also

StringExtensions Class
Sitecore.Extensions.StringExtensions Namespace


Left Method

[image]

Sitecore 6.4.1 API
StringExtensions..::..Left Method
StringExtensions Class See Also Send Feedback

Namespace: Sitecore.Extensions.StringExtensions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Left(
    this string text,
    int length
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function Left ( _
    text As String, _
    length As Integer _
) As String
Visual C++
[ExtensionAttribute]
public:
static String^ Left(
    String^ text,
    int length
)

Parameters

text
Type: System..::..String
A string
length
Type: System..::..Int32
The number of character to return.

Return Value

The first length characters of the string.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

StringExtensions Class
Sitecore.Extensions.StringExtensions Namespace


Mid Method

[image] [image]

Sitecore 6.4.1 API
StringExtensions..::..Mid Method
StringExtensions Class See Also Send Feedback

Overload List

Name | Description
Mid(String, Int32) | Gets the middle part of a string.
Mid(String, Int32, Int32) | Gets the middle part of a string.

See Also

StringExtensions Class
StringExtensions Members
Sitecore.Extensions.StringExtensions Namespace


Mid Method (String, Int32)

[image]

Sitecore 6.4.1 API
StringExtensions..::..Mid Method (String, Int32)
StringExtensions Class See Also Send Feedback

Namespace: Sitecore.Extensions.StringExtensions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Mid(
    this string text,
    int start
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function Mid ( _
    text As String, _
    start As Integer _
) As String
Visual C++
[ExtensionAttribute]
public:
static String^ Mid(
    String^ text,
    int start
)

Parameters

text
Type: System..::..String
A string.
start
Type: System..::..Int32
The starting index into the string.

Return Value

The rightmost part of the string starting at the start position.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Remarks

If start is greater than the length of the string, the blank is returned.

See Also

StringExtensions Class
Mid Overload
Sitecore.Extensions.StringExtensions Namespace


Mid Method (String, Int32, Int32)

[image]

Sitecore 6.4.1 API
StringExtensions..::..Mid Method (String, Int32, Int32)
StringExtensions Class See Also Send Feedback

Namespace: Sitecore.Extensions.StringExtensions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Mid(
    this string text,
    int start,
    int length
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function Mid ( _
    text As String, _
    start As Integer, _
    length As Integer _
) As String
Visual C++
[ExtensionAttribute]
public:
static String^ Mid(
    String^ text,
    int start,
    int length
)

Parameters

text
Type: System..::..String
A string.
start
Type: System..::..Int32
The starting index into the string.
length
Type: System..::..Int32
The number of returned characters

Return Value

The rightmost part of the string starting at the start position.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

StringExtensions Class
Mid Overload
Sitecore.Extensions.StringExtensions Namespace


Right Method

[image]

Sitecore 6.4.1 API
StringExtensions..::..Right Method
StringExtensions Class See Also Send Feedback

Namespace: Sitecore.Extensions.StringExtensions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Right(
    this string text,
    int length
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function Right ( _
    text As String, _
    length As Integer _
) As String
Visual C++
[ExtensionAttribute]
public:
static String^ Right(
    String^ text,
    int length
)

Parameters

text
Type: System..::..String
A string.
length
Type: System..::..Int32
The number of characters to return.

Return Value

The rightmost length characters.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

StringExtensions Class
Sitecore.Extensions.StringExtensions Namespace


Sitecore.Extensions.XElementExtensions Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Extensions.XElementExtensions Namespace
Send Feedback

Classes

 | Class | Description
Public class | XElementExtensions | Extensions methods for string.


XElementExtensions Class

[image]

Sitecore 6.4.1 API
XElementExtensions Class
Members See Also Send Feedback

Namespace: Sitecore.Extensions.XElementExtensions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class XElementExtensions
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class XElementExtensions
Visual C++
[ExtensionAttribute]
public ref class XElementExtensions abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Extensions.XElementExtensions..::..XElementExtensions

See Also

XElementExtensions Members
Sitecore.Extensions.XElementExtensions Namespace


XElementExtensions Members

[image] [image]

Sitecore 6.4.1 API
XElementExtensions Members
XElementExtensions Class Methods See Also Send Feedback

The XElementExtensions type exposes the following members.

Methods

Name | Description
Element | Elements the specified element.
GetAttributeValue | Gets the attribute value.

See Also

XElementExtensions Class
Sitecore.Extensions.XElementExtensions Namespace


XElementExtensions Methods

[image] [image]

Sitecore 6.4.1 API
XElementExtensions Methods
XElementExtensions Class See Also Send Feedback

The XElementExtensions type exposes the following members.

Methods

Name | Description
Element | Elements the specified element.
GetAttributeValue | Gets the attribute value.

See Also

XElementExtensions Class
Sitecore.Extensions.XElementExtensions Namespace


Element Method

[image]

Sitecore 6.4.1 API
XElementExtensions..::..Element Method
XElementExtensions Class See Also Send Feedback

Namespace: Sitecore.Extensions.XElementExtensions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static XElement Element(
    this XElement element,
    int index
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function Element ( _
    element As XElement, _
    index As Integer _
) As XElement
Visual C++
[ExtensionAttribute]
public:
static XElement^ Element(
    XElement^ element,
    int index
)

Parameters

element
Type: System.Xml.Linq..::..XElement
The element.
index
Type: System..::..Int32
The index.

Return Value

Returns the X element.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type XElement. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

XElementExtensions Class
Sitecore.Extensions.XElementExtensions Namespace


GetAttributeValue Method

[image]

Sitecore 6.4.1 API
XElementExtensions..::..GetAttributeValue Method
XElementExtensions Class See Also Send Feedback

Namespace: Sitecore.Extensions.XElementExtensions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetAttributeValue(
    this XElement element,
    string name
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function GetAttributeValue ( _
    element As XElement, _
    name As String _
) As String
Visual C++
[ExtensionAttribute]
public:
static String^ GetAttributeValue(
    XElement^ element,
    String^ name
)

Parameters

element
Type: System.Xml.Linq..::..XElement
The element.
name
Type: System..::..String
The name of the attribute to get.

Return Value

The attribute value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type XElement. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

XElementExtensions Class
Sitecore.Extensions.XElementExtensions Namespace


Sitecore.Globalization Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Globalization Namespace
Send Feedback

Classes

 | Class | Description
Public class | ItemEventHandler | Monitors for changes to the dictionary and invalidates the translation tables accordingly.
Public class | Language | Represents a language.
Public class | Language..::..Predefined | Obsolete. Provides a class with predefined language structures.
Public class | LanguageDefinition | Defines meta data on a language.
Public class | LanguageDefinitions |
Public class | LanguageOrigin | Identifies the language item that defines a language.
Public class | LanguageService | Helper function for languages
Public class | LanguageSwitcher | Switches to another language temporarily.
Public class | Translate | Implements the localization utility class, which controls the client language.


ItemEventHandler Members

[image] [image]

Sitecore 6.4.1 API
ItemEventHandler Members
ItemEventHandler Class Constructors Methods See Also Send Feedback

The ItemEventHandler type exposes the following members.

Constructors

 | Name | Description
Public method | ItemEventHandler | Initializes a new instance of the ItemEventHandler class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemEventHandler Class
Sitecore.Globalization Namespace


ItemEventHandler Constructor

[image]

Sitecore 6.4.1 API
ItemEventHandler Constructor
ItemEventHandler Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemEventHandler()
Visual Basic
Public Sub New
Visual C++
public:
ItemEventHandler()

See Also

ItemEventHandler Class
Sitecore.Globalization Namespace


ItemEventHandler Methods

[image] [image]

Sitecore 6.4.1 API
ItemEventHandler Methods
ItemEventHandler Class See Also Send Feedback

The ItemEventHandler type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemEventHandler Class
Sitecore.Globalization Namespace


Language Class

[image]

Sitecore 6.4.1 API
Language Class
Members See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class Language : ISerializable, ICacheable
Visual Basic
<SerializableAttribute> _
Public Class Language _
    Implements ISerializable, ICacheable
Visual C++
[SerializableAttribute]
public ref class Language : ISerializable,
    ICacheable

Remarks

The language class is used both for specifying web site languages and Client languages.

The web site languages are typically defined below /sitecore/system/Languages.

Client languages are defined in /sitecore/system/Settings/Client languages.

Inheritance Hierarchy

System..::..Object
Sitecore.Globalization..::..Language

See Also

Language Members
Sitecore.Globalization Namespace


Language Members

[image] [image]

Sitecore 6.4.1 API
Language Members
Language Class Constructors Methods Operators Properties See Also Send Feedback

The Language type exposes the following members.

Constructors

 | Name | Description
Protected method | Language | Obsolete. Constructor used when deserializing.

Methods

 | Name | Description
 | CreateCultureInfo(String) | Creates the culture info. Synchronizes calls to constructor.
 | CreateCultureInfo(String, Boolean) | Creates the culture info. Synchronizes calls to constructor.
 | CreateSpecificCulture | Creates the specific culture. Synchronizes access to constructor
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCharset | Gets the chararacter set for the language.
 | GetCultureInfo | Gets the culture info.
 | GetCultures | Gets the cultures.
Public method | GetDictionary | Gets the dictionary associated with the language in a specific database.
Public method | GetDisplayName()()()() | Gets the display name.
 | GetDisplayName(CultureInfo) | Gets the display name.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Overrides Object..::..GetHashCode()()()().)
Public method | GetIcon | Gets the icon associated with the language in a specific database.
Public method | GetItem | Obsolete. Gets the item.
 | GetLanguages | Obsolete. Gets the list of defined languages in a database.
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetSpellCheckerDictionary | Obsolete. Gets the name of the NetSpell dictionary.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse(Object) | Obsolete. Initializes a language structure from an object.
 | Parse(String) | Initializes a language structure from a string.
 | Parse(String, String) | Obsolete. Initializes a language structure from a string.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)
 | TryParse | Initializes a language structure from a string.

Operators

Name | Description
Equality | Implements the == operator.
Inequality | Implements the != operator.

Properties

 | Name | Description
 | Any | Obsolete. Represents any language.
 | ClientLanguage | Obsolete. Gets or sets the current Client language.
Public property | CultureInfo | Gets a CultureInfo structure for the current language.
 | Current | Gets or sets the current language.
 | DefaultClientLanguage | Obsolete. Gets or sets the current Client language as defined in the web.config.
 | DefaultLanguage | Obsolete. Gets the default language as defined in the web.config.
 | Invariant | Represents the invariant language (culture identifier: 0x007F).
Public property | Name | Gets or sets the name of the language.
Public property | Origin | Gets the id of the item representing the language in a specific database.
Public property | Title | Obsolete. Gets the display name of the language.

See Also

Language Class
Sitecore.Globalization Namespace


Language Constructor

[image]

Sitecore 6.4.1 API
Language Constructor
Language Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Will be made protected in a future version.")]
protected Language(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
<ObsoleteAttribute("Will be made protected in a future version.")> _
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
[ObsoleteAttribute(L"Will be made protected in a future version.")]
protected:
Language(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

Language Class
Sitecore.Globalization Namespace


Language Methods

[image] [image]

Sitecore 6.4.1 API
Language Methods
Language Class See Also Send Feedback

The Language type exposes the following members.

Methods

 | Name | Description
 | CreateCultureInfo(String) | Creates the culture info. Synchronizes calls to constructor.
 | CreateCultureInfo(String, Boolean) | Creates the culture info. Synchronizes calls to constructor.
 | CreateSpecificCulture | Creates the specific culture. Synchronizes access to constructor
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCharset | Gets the chararacter set for the language.
 | GetCultureInfo | Gets the culture info.
 | GetCultures | Gets the cultures.
Public method | GetDictionary | Gets the dictionary associated with the language in a specific database.
Public method | GetDisplayName()()()() | Gets the display name.
 | GetDisplayName(CultureInfo) | Gets the display name.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Overrides Object..::..GetHashCode()()()().)
Public method | GetIcon | Gets the icon associated with the language in a specific database.
Public method | GetItem | Obsolete. Gets the item.
 | GetLanguages | Obsolete. Gets the list of defined languages in a database.
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetSpellCheckerDictionary | Obsolete. Gets the name of the NetSpell dictionary.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse(Object) | Obsolete. Initializes a language structure from an object.
 | Parse(String) | Initializes a language structure from a string.
 | Parse(String, String) | Obsolete. Initializes a language structure from a string.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)
 | TryParse | Initializes a language structure from a string.

See Also

Language Class
Sitecore.Globalization Namespace


CreateCultureInfo Method

[image] [image]

Sitecore 6.4.1 API
Language..::..CreateCultureInfo Method
Language Class See Also Send Feedback

Overload List

Name | Description
CreateCultureInfo(String) | Creates the culture info. Synchronizes calls to constructor.
CreateCultureInfo(String, Boolean) | Creates the culture info. Synchronizes calls to constructor.

See Also

Language Class
Language Members
Sitecore.Globalization Namespace


CreateCultureInfo Method (String)

[image]

Sitecore 6.4.1 API
Language..::..CreateCultureInfo Method (String)
Language Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static CultureInfo CreateCultureInfo(
    string name
)
Visual Basic
Public Shared Function CreateCultureInfo ( _
    name As String _
) As CultureInfo
Visual C++
public:
static CultureInfo^ CreateCultureInfo(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

Return Value

The culture info.

See Also

Language Class
CreateCultureInfo Overload
Sitecore.Globalization Namespace


CreateCultureInfo Method (String, Boolean)

[image]

Sitecore 6.4.1 API
Language..::..CreateCultureInfo Method (String, Boolean)
Language Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static CultureInfo CreateCultureInfo(
    string name,
    bool userOverride
)
Visual Basic
Public Shared Function CreateCultureInfo ( _
    name As String, _
    userOverride As Boolean _
) As CultureInfo
Visual C++
public:
static CultureInfo^ CreateCultureInfo(
    String^ name,
    bool userOverride
)

Parameters

name
Type: System..::..String
The name.
userOverride
Type: System..::..Boolean
if set to true this instance is user override.

Return Value

The culture info.

See Also

Language Class
CreateCultureInfo Overload
Sitecore.Globalization Namespace


CreateSpecificCulture Method

[image]

Sitecore 6.4.1 API
Language..::..CreateSpecificCulture Method
Language Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static CultureInfo CreateSpecificCulture(
    string name
)
Visual Basic
Public Shared Function CreateSpecificCulture ( _
    name As String _
) As CultureInfo
Visual C++
public:
static CultureInfo^ CreateSpecificCulture(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

Return Value

The specific culture.

See Also

Language Class
Sitecore.Globalization Namespace


Equals Method

[image]

Sitecore 6.4.1 API
Language..::..Equals Method
Language Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

See Also

Language Class
Sitecore.Globalization Namespace


GetCharset Method

[image]

Sitecore 6.4.1 API
Language..::..GetCharset Method
Language Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetCharset(
    Database database
)
Visual Basic
Public Function GetCharset ( _
    database As Database _
) As String
Visual C++
public:
String^ GetCharset(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Globalization.Language.GetCharset(Sitecore.Data.Database)"]

See Also

Language Class
Sitecore.Globalization Namespace


GetCultureInfo Method

[image]

Sitecore 6.4.1 API
Language..::..GetCultureInfo Method
Language Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static CultureInfo GetCultureInfo(
    string cultureName
)
Visual Basic
Public Shared Function GetCultureInfo ( _
    cultureName As String _
) As CultureInfo
Visual C++
public:
static CultureInfo^ GetCultureInfo(
    String^ cultureName
)

Parameters

cultureName
Type: System..::..String
Name of the culture.

Return Value

The culture info.

See Also

Language Class
Sitecore.Globalization Namespace


GetCultures Method

[image]

Sitecore 6.4.1 API
Language..::..GetCultures Method
Language Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static CultureInfo[] GetCultures(
    CultureTypes types
)
Visual Basic
Public Shared Function GetCultures ( _
    types As CultureTypes _
) As CultureInfo()
Visual C++
public:
static array<CultureInfo^>^ GetCultures(
    CultureTypes types
)

Parameters

types
Type: System.Globalization..::..CultureTypes
The types.

Return Value

The cultures.

See Also

Language Class
Sitecore.Globalization Namespace


GetDictionary Method

[image]

Sitecore 6.4.1 API
Language..::..GetDictionary Method
Language Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetDictionary(
    Database database
)
Visual Basic
Public Function GetDictionary ( _
    database As Database _
) As String
Visual C++
public:
String^ GetDictionary(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Globalization.Language.GetDictionary(Sitecore.Data.Database)"]

See Also

Language Class
Sitecore.Globalization Namespace


GetDisplayName Method

[image] [image]

Sitecore 6.4.1 API
Language..::..GetDisplayName Method
Language Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDisplayName()()()() | Gets the display name.
 | GetDisplayName(CultureInfo) | Gets the display name.

See Also

Language Class
Language Members
Sitecore.Globalization Namespace


GetDisplayName Method (CultureInfo)

[image]

Sitecore 6.4.1 API
Language..::..GetDisplayName Method (CultureInfo)
Language Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetDisplayName(
    CultureInfo cultureInfo
)
Visual Basic
Public Shared Function GetDisplayName ( _
    cultureInfo As CultureInfo _
) As String
Visual C++
public:
static String^ GetDisplayName(
    CultureInfo^ cultureInfo
)

Parameters

cultureInfo
Type: System.Globalization..::..CultureInfo
The culture info.

Return Value

The display name.

See Also

Language Class
GetDisplayName Overload
Sitecore.Globalization Namespace


GetHashCode Method

[image]

Sitecore 6.4.1 API
Language..::..GetHashCode Method
Language Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A hash code for the current Object.

See Also

Language Class
Sitecore.Globalization Namespace


GetIcon Method

[image]

Sitecore 6.4.1 API
Language..::..GetIcon Method
Language Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetIcon(
    Database database
)
Visual Basic
Public Function GetIcon ( _
    database As Database _
) As String
Visual C++
public:
String^ GetIcon(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

Return Value

The icon.

See Also

Language Class
Sitecore.Globalization Namespace


GetItem Method

[image]

Sitecore 6.4.1 API
Language..::..GetItem Method
Language Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated, use ItemManager.GetItem(Language.LanguageId, database) instead.")]
public Item GetItem(
    Database database
)
Visual Basic
<ObsoleteAttribute("Deprecated, use ItemManager.GetItem(Language.LanguageId, database) instead.")> _
Public Function GetItem ( _
    database As Database _
) As Item
Visual C++
[ObsoleteAttribute(L"Deprecated, use ItemManager.GetItem(Language.LanguageId, database) instead.")]
public:
Item^ GetItem(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Globalization.Language.GetItem(Sitecore.Data.Database)"]

See Also

Language Class
Sitecore.Globalization Namespace


GetLanguages Method

[image]

Sitecore 6.4.1 API
Language..::..GetLanguages Method
Language Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated, use LanguageManager.GetLanguages instead.")]
public static Language[] GetLanguages(
    Database database
)
Visual Basic
<ObsoleteAttribute("Deprecated, use LanguageManager.GetLanguages instead.")> _
Public Shared Function GetLanguages ( _
    database As Database _
) As Language()
Visual C++
[ObsoleteAttribute(L"Deprecated, use LanguageManager.GetLanguages instead.")]
public:
static array<Language^>^ GetLanguages(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Globalization.Language.GetLanguages(Sitecore.Data.Database)"]

See Also

Language Class
Sitecore.Globalization Namespace


GetObjectData Method

[image]

Sitecore 6.4.1 API
Language..::..GetObjectData Method
Language Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System.Security..::..SecurityException | The caller does not have the required permission.

See Also

Language Class
Sitecore.Globalization Namespace


GetSpellCheckerDictionary Method

[image]

Sitecore 6.4.1 API
Language..::..GetSpellCheckerDictionary Method
Language Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated, use GetDictionary(database) instead.")]
public string GetSpellCheckerDictionary(
    Database database
)
Visual Basic
<ObsoleteAttribute("Deprecated, use GetDictionary(database) instead.")> _
Public Function GetSpellCheckerDictionary ( _
    database As Database _
) As String
Visual C++
[ObsoleteAttribute(L"Deprecated, use GetDictionary(database) instead.")]
public:
String^ GetSpellCheckerDictionary(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Globalization.Language.GetSpellCheckerDictionary(Sitecore.Data.Database)"]

See Also

Language Class
Sitecore.Globalization Namespace


Parse Method

[image] [image]

Sitecore 6.4.1 API
Language..::..Parse Method
Language Class See Also Send Feedback

Overload List

Name | Description
Parse(Object) | Obsolete. Initializes a language structure from an object.
Parse(String) | Initializes a language structure from a string.
Parse(String, String) | Obsolete. Initializes a language structure from a string.

See Also

Language Class
Language Members
Sitecore.Globalization Namespace


Parse Method (String)

[image]

Sitecore 6.4.1 API
Language..::..Parse Method (String)
Language Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Language Parse(
    string name
)
Visual Basic
Public Shared Function Parse ( _
    name As String _
) As Language
Visual C++
public:
static Language^ Parse(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

Return Value

[Missing <returns> documentation for "M:Sitecore.Globalization.Language.Parse(System.String)"]

See Also

Language Class
Parse Overload
Sitecore.Globalization Namespace


Parse Method (String, String)

[image]

Sitecore 6.4.1 API
Language..::..Parse Method (String, String)
Language Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated")]
public static Language Parse(
    string value,
    string defaultLanguage
)
Visual Basic
<ObsoleteAttribute("Deprecated")> _
Public Shared Function Parse ( _
    value As String, _
    defaultLanguage As String _
) As Language
Visual C++
[ObsoleteAttribute(L"Deprecated")]
public:
static Language^ Parse(
    String^ value,
    String^ defaultLanguage
)

Parameters

value
Type: System..::..String
The value.
defaultLanguage
Type: System..::..String
The default language.

Return Value

[Missing <returns> documentation for "M:Sitecore.Globalization.Language.Parse(System.String,System.String)"]

Remarks

If the value is empty, defaultLanguage is returned.

See Also

Language Class
Parse Overload
Sitecore.Globalization Namespace


ToString Method

[image]

Sitecore 6.4.1 API
Language..::..ToString Method
Language Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

Language Class
Sitecore.Globalization Namespace


TryParse Method

[image]

Sitecore 6.4.1 API
Language..::..TryParse Method
Language Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool TryParse(
    string name,
    out Language result
)
Visual Basic
Public Shared Function TryParse ( _
    name As String, _
    <OutAttribute> ByRef result As Language _
) As Boolean
Visual C++
public:
static bool TryParse(
    String^ name,
    [OutAttribute] Language^% result
)

Parameters

name
Type: System..::..String
The name.
result
Type: Sitecore.Globalization..::..Language %
The result.

Return Value

[Missing <returns> documentation for "M:Sitecore.Globalization.Language.TryParse(System.String,Sitecore.Globalization.Language@)"]

See Also

Language Class
Sitecore.Globalization Namespace


Language Operators

[image] [image]

Sitecore 6.4.1 API
Language Operators
Language Class See Also Send Feedback

The Language type exposes the following members.

Operators

Name | Description
Equality | Implements the == operator.
Inequality | Implements the != operator.

See Also

Language Class
Sitecore.Globalization Namespace


Equality Operator

[image]

Sitecore 6.4.1 API
Language..::..Equality Operator
Language Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool operator ==(
    Language language1,
    Language language2
)
Visual Basic
Public Shared Operator = ( _
    language1 As Language, _
    language2 As Language _
) As Boolean
Visual C++
public:
static bool operator ==(
    Language^ language1,
    Language^ language2
)

Parameters

language1
Type: Sitecore.Globalization..::..Language
Language1.
language2
Type: Sitecore.Globalization..::..Language
Language2.

Return Value

[Missing <returns> documentation for "M:Sitecore.Globalization.Language.op_Equality(Sitecore.Globalization.Language,Sitecore.Globalization.Language)"]

See Also

Language Class
Sitecore.Globalization Namespace


Inequality Operator

[image]

Sitecore 6.4.1 API
Language..::..Inequality Operator
Language Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool operator !=(
    Language language1,
    Language language2
)
Visual Basic
Public Shared Operator <> ( _
    language1 As Language, _
    language2 As Language _
) As Boolean
Visual C++
public:
static bool operator !=(
    Language^ language1,
    Language^ language2
)

Parameters

language1
Type: Sitecore.Globalization..::..Language
Language1.
language2
Type: Sitecore.Globalization..::..Language
Language2.

Return Value

[Missing <returns> documentation for "M:Sitecore.Globalization.Language.op_Inequality(Sitecore.Globalization.Language,Sitecore.Globalization.Language)"]

See Also

Language Class
Sitecore.Globalization Namespace


Language Properties

[image] [image]

Sitecore 6.4.1 API
Language Properties
Language Class See Also Send Feedback

The Language type exposes the following members.

Properties

 | Name | Description
 | Any | Obsolete. Represents any language.
 | ClientLanguage | Obsolete. Gets or sets the current Client language.
Public property | CultureInfo | Gets a CultureInfo structure for the current language.
 | Current | Gets or sets the current language.
 | DefaultClientLanguage | Obsolete. Gets or sets the current Client language as defined in the web.config.
 | DefaultLanguage | Obsolete. Gets the default language as defined in the web.config.
 | Invariant | Represents the invariant language (culture identifier: 0x007F).
Public property | Name | Gets or sets the name of the language.
Public property | Origin | Gets the id of the item representing the language in a specific database.
Public property | Title | Obsolete. Gets the display name of the language.

See Also

Language Class
Sitecore.Globalization Namespace


Any Property

[image]

Sitecore 6.4.1 API
Language..::..Any Property
Language Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - use Invariant instead.")]
public static Language Any { get; }
Visual Basic
<ObsoleteAttribute("Deprecated - use Invariant instead.")> _
Public Shared ReadOnly Property Any As Language
    Get
Visual C++
[ObsoleteAttribute(L"Deprecated - use Invariant instead.")]
public:
static property Language^ Any {
    Language^ get ();
}

Field Value

Any.

See Also

Language Class
Sitecore.Globalization Namespace


ClientLanguage Property

[image]

Sitecore 6.4.1 API
Language..::..ClientLanguage Property
Language Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated, use State.ClientLanguage instead.")]
public static Language ClientLanguage { get; set; }
Visual Basic
<ObsoleteAttribute("Deprecated, use State.ClientLanguage instead.")> _
Public Shared Property ClientLanguage As Language
    Get
    Set
Visual C++
[ObsoleteAttribute(L"Deprecated, use State.ClientLanguage instead.")]
public:
static property Language^ ClientLanguage {
    Language^ get ();
    void set (Language^ value);
}

Field Value

The client language.

See Also

Language Class
Sitecore.Globalization Namespace


CultureInfo Property

[image]

Sitecore 6.4.1 API
Language..::..CultureInfo Property
Language Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual CultureInfo CultureInfo { get; }
Visual Basic
Public Overridable ReadOnly Property CultureInfo As CultureInfo
    Get
Visual C++
public:
virtual property CultureInfo^ CultureInfo {
    CultureInfo^ get ();
}

Field Value

The culture info.

See Also

Language Class
Sitecore.Globalization Namespace


Current Property

[image]

Sitecore 6.4.1 API
Language..::..Current Property
Language Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Language Current { get; set; }
Visual Basic
Public Shared Property Current As Language
    Get
    Set
Visual C++
public:
static property Language^ Current {
    Language^ get ();
    void set (Language^ value);
}

Field Value

The current.

See Also

Language Class
Sitecore.Globalization Namespace


DefaultClientLanguage Property

[image]

Sitecore 6.4.1 API
Language..::..DefaultClientLanguage Property
Language Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated, use Settings.ClientLanguage instead.")]
public static Language DefaultClientLanguage { get; }
Visual Basic
<ObsoleteAttribute("Deprecated, use Settings.ClientLanguage instead.")> _
Public Shared ReadOnly Property DefaultClientLanguage As Language
    Get
Visual C++
[ObsoleteAttribute(L"Deprecated, use Settings.ClientLanguage instead.")]
public:
static property Language^ DefaultClientLanguage {
    Language^ get ();
}

Field Value

The default client language.

See Also

Language Class
Sitecore.Globalization Namespace


DefaultLanguage Property

[image]

Sitecore 6.4.1 API
Language..::..DefaultLanguage Property
Language Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated, use LanguageManager.DefaultLanguage instead.")]
public static Language DefaultLanguage { get; }
Visual Basic
<ObsoleteAttribute("Deprecated, use LanguageManager.DefaultLanguage instead.")> _
Public Shared ReadOnly Property DefaultLanguage As Language
    Get
Visual C++
[ObsoleteAttribute(L"Deprecated, use LanguageManager.DefaultLanguage instead.")]
public:
static property Language^ DefaultLanguage {
    Language^ get ();
}

Field Value

The default language.

See Also

Language Class
Sitecore.Globalization Namespace


Invariant Property

[image]

Sitecore 6.4.1 API
Language..::..Invariant Property
Language Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Language Invariant { get; }
Visual Basic
Public Shared ReadOnly Property Invariant As Language
    Get
Visual C++
public:
static property Language^ Invariant {
    Language^ get ();
}

Field Value

The invariant language.

See Also

Language Class
Sitecore.Globalization Namespace


Name Property

[image]

Sitecore 6.4.1 API
Language..::..Name Property
Language Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string Name { get; }
Visual Basic
Public Overridable ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

Language Class
Sitecore.Globalization Namespace


Origin Property

[image]

Sitecore 6.4.1 API
Language..::..Origin Property
Language Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LanguageOrigin Origin { get; }
Visual Basic
Public ReadOnly Property Origin As LanguageOrigin
    Get
Visual C++
public:
property LanguageOrigin^ Origin {
    LanguageOrigin^ get ();
}

Field Value

The origin.

See Also

Language Class
Sitecore.Globalization Namespace


Title Property

[image]

Sitecore 6.4.1 API
Language..::..Title Property
Language Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - use CultureInfo.DisplayName instead.")]
public string Title { get; }
Visual Basic
<ObsoleteAttribute("Deprecated - use CultureInfo.DisplayName instead.")> _
Public ReadOnly Property Title As String
    Get
Visual C++
[ObsoleteAttribute(L"Deprecated - use CultureInfo.DisplayName instead.")]
public:
property String^ Title {
    String^ get ();
}

Field Value

The title.

See Also

Language Class
Sitecore.Globalization Namespace


Language.Predefined Class

[image]

Sitecore 6.4.1 API
Language..::..Predefined Class
Language Class Members See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - use the methods of LanguageManager instead.")]
public static class Predefined
Visual Basic
<ObsoleteAttribute("Deprecated - use the methods of LanguageManager instead.")> _
Public NotInheritable Class Predefined
Visual C++
[ObsoleteAttribute(L"Deprecated - use the methods of LanguageManager instead.")]
public ref class Predefined abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Globalization..::..Language..::..Predefined

See Also

Language..::..Predefined Members
Sitecore.Globalization Namespace


Language.Predefined Members

[image] [image]

Sitecore 6.4.1 API
Language..::..Predefined Members
Language..::..Predefined Class Fields See Also Send Feedback

Represents a language.

The Language..::..Predefined type exposes the following members.

Fields

Name | Description
Danish | Represents the Danish language.
English | Represents the English language.
German | Represents the German language.
Norwegian | Represents the Norwegian language.
Spanish | Represents the Spanish language.
Swedish | Represents the Swedish language.

See Also

Language..::..Predefined Class
Sitecore.Globalization Namespace


Language.Predefined Fields

[image] [image]

Sitecore 6.4.1 API
Language..::..Predefined Fields
Language..::..Predefined Class See Also Send Feedback

The Language..::..Predefined type exposes the following members.

Fields

Name | Description
Danish | Represents the Danish language.
English | Represents the English language.
German | Represents the German language.
Norwegian | Represents the Norwegian language.
Spanish | Represents the Spanish language.
Swedish | Represents the Swedish language.

See Also

Language..::..Predefined Class
Sitecore.Globalization Namespace


Danish Field

[image]

Sitecore 6.4.1 API
Language..::..Predefined..::..Danish Field
Language..::..Predefined Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Language Danish
Visual Basic
Public Shared Danish As Language
Visual C++
public:
static Language^ Danish

See Also

Language..::..Predefined Class
Sitecore.Globalization Namespace


English Field

[image]

Sitecore 6.4.1 API
Language..::..Predefined..::..English Field
Language..::..Predefined Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Language English
Visual Basic
Public Shared English As Language
Visual C++
public:
static Language^ English

See Also

Language..::..Predefined Class
Sitecore.Globalization Namespace


German Field

[image]

Sitecore 6.4.1 API
Language..::..Predefined..::..German Field
Language..::..Predefined Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Language German
Visual Basic
Public Shared German As Language
Visual C++
public:
static Language^ German

See Also

Language..::..Predefined Class
Sitecore.Globalization Namespace


Norwegian Field

[image]

Sitecore 6.4.1 API
Language..::..Predefined..::..Norwegian Field
Language..::..Predefined Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Language Norwegian
Visual Basic
Public Shared Norwegian As Language
Visual C++
public:
static Language^ Norwegian

See Also

Language..::..Predefined Class
Sitecore.Globalization Namespace


Spanish Field

[image]

Sitecore 6.4.1 API
Language..::..Predefined..::..Spanish Field
Language..::..Predefined Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Language Spanish
Visual Basic
Public Shared Spanish As Language
Visual C++
public:
static Language^ Spanish

See Also

Language..::..Predefined Class
Sitecore.Globalization Namespace


Swedish Field

[image]

Sitecore 6.4.1 API
Language..::..Predefined..::..Swedish Field
Language..::..Predefined Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Language Swedish
Visual Basic
Public Shared Swedish As Language
Visual C++
public:
static Language^ Swedish

See Also

Language..::..Predefined Class
Sitecore.Globalization Namespace


LanguageDefinition Class

[image]

Sitecore 6.4.1 API
LanguageDefinition Class
Members See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class LanguageDefinition
Visual Basic
Public Class LanguageDefinition
Visual C++
public ref class LanguageDefinition

Inheritance Hierarchy

System..::..Object
Sitecore.Globalization..::..LanguageDefinition

See Also

LanguageDefinition Members
Sitecore.Globalization Namespace


LanguageDefinition Members

[image] [image]

Sitecore 6.4.1 API
LanguageDefinition Members
LanguageDefinition Class Constructors Methods Properties See Also Send Feedback

The LanguageDefinition type exposes the following members.

Constructors

 | Name | Description
Public method | LanguageDefinition | Initializes a new instance of the LanguageDefinition class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CharSet | Gets the charset.
Public property | CodePage | Gets the codepage.
Public property | Encoding | Gets the encoding.
Public property | Icon | Gets the icon.
Public property | Id | Gets the id.
Public property | Name | Gets the name.
Public property | Region | Gets the region.

See Also

LanguageDefinition Class
Sitecore.Globalization Namespace


LanguageDefinition Constructor

[image]

Sitecore 6.4.1 API
LanguageDefinition Constructor
LanguageDefinition Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LanguageDefinition(
    string id,
    string region,
    string codepage,
    string encoding,
    string charset,
    string icon
)
Visual Basic
Public Sub New ( _
    id As String, _
    region As String, _
    codepage As String, _
    encoding As String, _
    charset As String, _
    icon As String _
)
Visual C++
public:
LanguageDefinition(
    String^ id,
    String^ region,
    String^ codepage,
    String^ encoding,
    String^ charset,
    String^ icon
)

Parameters

id
Type: System..::..String
The id.
region
Type: System..::..String
The region.
codepage
Type: System..::..String
The codepage.
encoding
Type: System..::..String
The encoding.
charset
Type: System..::..String
The charset.
icon
Type: System..::..String
The icon.

See Also

LanguageDefinition Class
Sitecore.Globalization Namespace


LanguageDefinition Methods

[image] [image]

Sitecore 6.4.1 API
LanguageDefinition Methods
LanguageDefinition Class See Also Send Feedback

The LanguageDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LanguageDefinition Class
Sitecore.Globalization Namespace


LanguageDefinition Properties

[image] [image]

Sitecore 6.4.1 API
LanguageDefinition Properties
LanguageDefinition Class See Also Send Feedback

The LanguageDefinition type exposes the following members.

Properties

 | Name | Description
Public property | CharSet | Gets the charset.
Public property | CodePage | Gets the codepage.
Public property | Encoding | Gets the encoding.
Public property | Icon | Gets the icon.
Public property | Id | Gets the id.
Public property | Name | Gets the name.
Public property | Region | Gets the region.

See Also

LanguageDefinition Class
Sitecore.Globalization Namespace


CharSet Property

[image]

Sitecore 6.4.1 API
LanguageDefinition..::..CharSet Property
LanguageDefinition Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string CharSet { get; }
Visual Basic
Public ReadOnly Property CharSet As String
    Get
Visual C++
public:
property String^ CharSet {
    String^ get ();
}

Field Value

The charset.

See Also

LanguageDefinition Class
Sitecore.Globalization Namespace


CodePage Property

[image]

Sitecore 6.4.1 API
LanguageDefinition..::..CodePage Property
LanguageDefinition Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string CodePage { get; }
Visual Basic
Public ReadOnly Property CodePage As String
    Get
Visual C++
public:
property String^ CodePage {
    String^ get ();
}

Field Value

The codepage.

See Also

LanguageDefinition Class
Sitecore.Globalization Namespace


Encoding Property

[image]

Sitecore 6.4.1 API
LanguageDefinition..::..Encoding Property
LanguageDefinition Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Encoding { get; }
Visual Basic
Public ReadOnly Property Encoding As String
    Get
Visual C++
public:
property String^ Encoding {
    String^ get ();
}

Field Value

The encoding.

See Also

LanguageDefinition Class
Sitecore.Globalization Namespace


Icon Property

[image]

Sitecore 6.4.1 API
LanguageDefinition..::..Icon Property
LanguageDefinition Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Icon { get; }
Visual Basic
Public ReadOnly Property Icon As String
    Get
Visual C++
public:
property String^ Icon {
    String^ get ();
}

Field Value

The icon.

See Also

LanguageDefinition Class
Sitecore.Globalization Namespace


Id Property

[image]

Sitecore 6.4.1 API
LanguageDefinition..::..Id Property
LanguageDefinition Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get
Visual C++
public:
property String^ Id {
    String^ get ();
}

Field Value

The id.

See Also

LanguageDefinition Class
Sitecore.Globalization Namespace


Name Property

[image]

Sitecore 6.4.1 API
LanguageDefinition..::..Name Property
LanguageDefinition Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

LanguageDefinition Class
Sitecore.Globalization Namespace


Region Property

[image]

Sitecore 6.4.1 API
LanguageDefinition..::..Region Property
LanguageDefinition Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Region { get; }
Visual Basic
Public ReadOnly Property Region As String
    Get
Visual C++
public:
property String^ Region {
    String^ get ();
}

Field Value

The region.

See Also

LanguageDefinition Class
Sitecore.Globalization Namespace


LanguageDefinitions Class

[image]

Sitecore 6.4.1 API
LanguageDefinitions Class
Members See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class LanguageDefinitions
Visual Basic
Public NotInheritable Class LanguageDefinitions
Visual C++
public ref class LanguageDefinitions abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Globalization..::..LanguageDefinitions

See Also

LanguageDefinitions Members
Sitecore.Globalization Namespace


LanguageDefinitions Members

[image] [image]

Sitecore 6.4.1 API
LanguageDefinitions Members
LanguageDefinitions Class Methods Properties See Also Send Feedback

The LanguageDefinitions type exposes the following members.

Methods

Name | Description
GetLanguageDefinition(CultureInfo) | Gets the definition.
GetLanguageDefinition(Language) | Gets the definition.

Properties

Name | Description
Definitions | Gets the language definitions.

See Also

LanguageDefinitions Class
Sitecore.Globalization Namespace


LanguageDefinitions Methods

[image] [image]

Sitecore 6.4.1 API
LanguageDefinitions Methods
LanguageDefinitions Class See Also Send Feedback

Methods

Name | Description
GetLanguageDefinition(CultureInfo) | Gets the definition.
GetLanguageDefinition(Language) | Gets the definition.

See Also

LanguageDefinitions Class
Sitecore.Globalization Namespace


GetLanguageDefinition Method

[image] [image]

Sitecore 6.4.1 API
LanguageDefinitions..::..GetLanguageDefinition Method
LanguageDefinitions Class See Also Send Feedback

Overload List

Name | Description
GetLanguageDefinition(CultureInfo) | Gets the definition.
GetLanguageDefinition(Language) | Gets the definition.

See Also

LanguageDefinitions Class
LanguageDefinitions Members
Sitecore.Globalization Namespace


GetLanguageDefinition Method (CultureInfo)

[image]

Sitecore 6.4.1 API
LanguageDefinitions..::..GetLanguageDefinition Method (CultureInfo)
LanguageDefinitions Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static LanguageDefinition GetLanguageDefinition(
    CultureInfo cultureInfo
)
Visual Basic
Public Shared Function GetLanguageDefinition ( _
    cultureInfo As CultureInfo _
) As LanguageDefinition
Visual C++
public:
static LanguageDefinition^ GetLanguageDefinition(
    CultureInfo^ cultureInfo
)

Parameters

cultureInfo
Type: System.Globalization..::..CultureInfo
The culture info.

Return Value

[Missing <returns> documentation for "M:Sitecore.Globalization.LanguageDefinitions.GetLanguageDefinition(System.Globalization.CultureInfo)"]

See Also

LanguageDefinitions Class
GetLanguageDefinition Overload
Sitecore.Globalization Namespace


GetLanguageDefinition Method (Language)

[image]

Sitecore 6.4.1 API
LanguageDefinitions..::..GetLanguageDefinition Method (Language)
LanguageDefinitions Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static LanguageDefinition GetLanguageDefinition(
    Language language
)
Visual Basic
Public Shared Function GetLanguageDefinition ( _
    language As Language _
) As LanguageDefinition
Visual C++
public:
static LanguageDefinition^ GetLanguageDefinition(
    Language^ language
)

Parameters

language
Type: Sitecore.Globalization..::..Language
The language.

Return Value

The definition.

See Also

LanguageDefinitions Class
GetLanguageDefinition Overload
Sitecore.Globalization Namespace


LanguageDefinitions Properties

[image] [image]

Sitecore 6.4.1 API
LanguageDefinitions Properties
LanguageDefinitions Class See Also Send Feedback

The LanguageDefinitions type exposes the following members.

Properties

Name | Description
Definitions | Gets the language definitions.

See Also

LanguageDefinitions Class
Sitecore.Globalization Namespace


Definitions Property

[image]

Sitecore 6.4.1 API
LanguageDefinitions..::..Definitions Property
LanguageDefinitions Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static List<LanguageDefinition> Definitions { get; }
Visual Basic
Public Shared ReadOnly Property Definitions As List(Of LanguageDefinition)
    Get
Visual C++
public:
static property List<LanguageDefinition^>^ Definitions {
    List<LanguageDefinition^>^ get ();
}

Field Value

The language definitions.

See Also

LanguageDefinitions Class
Sitecore.Globalization Namespace


LanguageOrigin Class

[image]

Sitecore 6.4.1 API
LanguageOrigin Class
Members See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class LanguageOrigin
Visual Basic
Public Class LanguageOrigin
Visual C++
public ref class LanguageOrigin

Inheritance Hierarchy

System..::..Object
Sitecore.Globalization..::..LanguageOrigin

See Also

LanguageOrigin Members
Sitecore.Globalization Namespace


LanguageOrigin Members

[image] [image]

Sitecore 6.4.1 API
LanguageOrigin Members
LanguageOrigin Class Constructors Methods Properties See Also Send Feedback

The LanguageOrigin type exposes the following members.

Constructors

 | Name | Description
Public method | LanguageOrigin | Initializes a new instance of the LanguageOrigin class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ItemId | Gets or sets the item id.

See Also

LanguageOrigin Class
Sitecore.Globalization Namespace


LanguageOrigin Constructor

[image]

Sitecore 6.4.1 API
LanguageOrigin Constructor
LanguageOrigin Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LanguageOrigin()
Visual Basic
Public Sub New
Visual C++
public:
LanguageOrigin()

See Also

LanguageOrigin Class
Sitecore.Globalization Namespace


LanguageOrigin Methods

[image] [image]

Sitecore 6.4.1 API
LanguageOrigin Methods
LanguageOrigin Class See Also Send Feedback

The LanguageOrigin type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LanguageOrigin Class
Sitecore.Globalization Namespace


LanguageOrigin Properties

[image] [image]

Sitecore 6.4.1 API
LanguageOrigin Properties
LanguageOrigin Class See Also Send Feedback

The LanguageOrigin type exposes the following members.

Properties

 | Name | Description
Public property | ItemId | Gets or sets the item id.

See Also

LanguageOrigin Class
Sitecore.Globalization Namespace


ItemId Property

[image]

Sitecore 6.4.1 API
LanguageOrigin..::..ItemId Property
LanguageOrigin Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ItemId { get; set; }
Visual Basic
Public Property ItemId As ID
    Get
    Set
Visual C++
public:
property ID^ ItemId {
    ID^ get ();
    void set (ID^ value);
}

Field Value

The item id.

See Also

LanguageOrigin Class
Sitecore.Globalization Namespace


LanguageService Class

[image]

Sitecore 6.4.1 API
LanguageService Class
Members See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class LanguageService
Visual Basic
Public NotInheritable Class LanguageService
Visual C++
public ref class LanguageService abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Globalization..::..LanguageService

See Also

LanguageService Members
Sitecore.Globalization Namespace


LanguageService Members

[image] [image]

Sitecore 6.4.1 API
LanguageService Members
LanguageService Class Methods See Also Send Feedback

Methods

Name | Description
GetIcon(Item) | Gets the icon.
GetIcon(Language, Database) | Gets the icon.

See Also

LanguageService Class
Sitecore.Globalization Namespace


LanguageService Methods

[image] [image]

Sitecore 6.4.1 API
LanguageService Methods
LanguageService Class See Also Send Feedback

Methods

Name | Description
GetIcon(Item) | Gets the icon.
GetIcon(Language, Database) | Gets the icon.

See Also

LanguageService Class
Sitecore.Globalization Namespace


GetIcon Method

[image] [image]

Sitecore 6.4.1 API
LanguageService..::..GetIcon Method
LanguageService Class See Also Send Feedback

Overload List

Name | Description
GetIcon(Item) | Gets the icon.
GetIcon(Language, Database) | Gets the icon.

See Also

LanguageService Class
LanguageService Members
Sitecore.Globalization Namespace


GetIcon Method (Item)

[image]

Sitecore 6.4.1 API
LanguageService..::..GetIcon Method (Item)
LanguageService Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetIcon(
    Item item
)
Visual Basic
Public Shared Function GetIcon ( _
    item As Item _
) As String
Visual C++
public:
static String^ GetIcon(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

The icon.

See Also

LanguageService Class
GetIcon Overload
Sitecore.Globalization Namespace


LanguageSwitcher Class

[image]

Sitecore 6.4.1 API
LanguageSwitcher Class
Members See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class LanguageSwitcher : IDisposable
Visual Basic
Public Class LanguageSwitcher _
    Implements IDisposable
Visual C++
public ref class LanguageSwitcher : IDisposable

Inheritance Hierarchy

System..::..Object
Sitecore.Globalization..::..LanguageSwitcher

See Also

LanguageSwitcher Members
Sitecore.Globalization Namespace


LanguageSwitcher Constructor

[image] [image]

Sitecore 6.4.1 API
LanguageSwitcher Constructor
LanguageSwitcher Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LanguageSwitcher(String) | Initializes a new instance of the LanguageSwitcher class.
Public method | LanguageSwitcher(Language) | Initializes a new instance of the LanguageSwitcher class.

See Also

LanguageSwitcher Class
LanguageSwitcher Members
Sitecore.Globalization Namespace


LanguageSwitcher Constructor (Language)

[image]

Sitecore 6.4.1 API
LanguageSwitcher Constructor (Language)
LanguageSwitcher Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LanguageSwitcher(
    Language language
)
Visual Basic
Public Sub New ( _
    language As Language _
)
Visual C++
public:
LanguageSwitcher(
    Language^ language
)

Parameters

language
Type: Sitecore.Globalization..::..Language
The language.

See Also

LanguageSwitcher Class
LanguageSwitcher Overload
Sitecore.Globalization Namespace


LanguageSwitcher Methods

[image] [image]

Sitecore 6.4.1 API
LanguageSwitcher Methods
LanguageSwitcher Class See Also Send Feedback

The LanguageSwitcher type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LanguageSwitcher Class
Sitecore.Globalization Namespace


Dispose Method

[image]

Sitecore 6.4.1 API
LanguageSwitcher..::..Dispose Method
LanguageSwitcher Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

LanguageSwitcher Class
Sitecore.Globalization Namespace


Translate Class

[image]

Sitecore 6.4.1 API
Translate Class
Members See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Translate
Visual Basic
Public Class Translate
Visual C++
public ref class Translate

Remarks

The Sitecore.HttpModule class implements a file watcher that responds to new files in the localization folder. When triggered the file watcher clears the language table, thereby forcing a reload of the language files.

Inheritance Hierarchy

System..::..Object
Sitecore.Globalization..::..Translate

See Also

Translate Members
Sitecore.Globalization Namespace


Translate Members

[image] [image]

Sitecore 6.4.1 API
Translate Members
Translate Class Constructors Methods See Also Send Feedback

The Translate type exposes the following members.

Constructors

 | Name | Description
Public method | Translate | Initializes a new instance of the Translate class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Text(String) | Gets a localized string.
 | Text(String, array<Object>[]()[][]) | Gets the localized string for the key.
 | TextByLanguage(String, Language) | Gets a localized string.
 | TextByLanguage(String, Language, String) | Texts the by language no default.
 | TextByLanguage(String, Language, String, array<Object>[]()[][]) | Texts the by language no default.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Translate Class
Sitecore.Globalization Namespace


Translate Constructor

[image]

Sitecore 6.4.1 API
Translate Constructor
Translate Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Translate()
Visual Basic
Public Sub New
Visual C++
public:
Translate()

See Also

Translate Class
Sitecore.Globalization Namespace


Translate Methods

[image] [image]

Sitecore 6.4.1 API
Translate Methods
Translate Class See Also Send Feedback

The Translate type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Text(String) | Gets a localized string.
 | Text(String, array<Object>[]()[][]) | Gets the localized string for the key.
 | TextByLanguage(String, Language) | Gets a localized string.
 | TextByLanguage(String, Language, String) | Texts the by language no default.
 | TextByLanguage(String, Language, String, array<Object>[]()[][]) | Texts the by language no default.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Translate Class
Sitecore.Globalization Namespace


Text Method

[image] [image]

Sitecore 6.4.1 API
Translate..::..Text Method
Translate Class See Also Send Feedback

Overload List

Name | Description
Text(String) | Gets a localized string.
Text(String, array<Object>[]()[][]) | Gets the localized string for the key.

See Also

Translate Class
Translate Members
Sitecore.Globalization Namespace


Text Method (String)

[image]

Sitecore 6.4.1 API
Translate..::..Text Method (String)
Translate Class Example See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Text(
    string key
)
Visual Basic
Public Shared Function Text ( _
    key As String _
) As String
Visual C++
public:
static String^ Text(
    String^ key
)

Parameters

key
Type: System..::..String
The key of the string.

Return Value

The localized string.

Remarks

If the key is not found, the key itself is returned.

Examples

CopyC#
string myText = Localization.ls("My Text");

See Also

Translate Class
Text Overload
Sitecore.Globalization Namespace


Text Method (String, Object[])

[image]

Sitecore 6.4.1 API
Translate..::..Text Method (String, array<Object>[]()[][])
Translate Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Text(
    string key,
    params Object[] parameters
)
Visual Basic
Public Shared Function Text ( _
    key As String, _
    ParamArray parameters As Object() _
) As String
Visual C++
public:
static String^ Text(
    String^ key,
    ... array<Object^>^ parameters
)

Parameters

key
Type: System..::..String
The key.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.

Return Value

[Missing <returns> documentation for "M:Sitecore.Globalization.Translate.Text(System.String,System.Object[])"]

Remarks

The localized string is formatted using String.Format.

See Also

Translate Class
Text Overload
Sitecore.Globalization Namespace


TextByLanguage Method (String, Language)

[image]

Sitecore 6.4.1 API
Translate..::..TextByLanguage Method (String, Language)
Translate Class Example See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string TextByLanguage(
    string key,
    Language language
)
Visual Basic
Public Shared Function TextByLanguage ( _
    key As String, _
    language As Language _
) As String
Visual C++
public:
static String^ TextByLanguage(
    String^ key,
    Language^ language
)

Parameters

key
Type: System..::..String
The key of the string.
language
Type: Sitecore.Globalization..::..Language
The language identifier.

Return Value

The localized string.

Remarks

If the key is not found, the key itself is returned.

Examples

CopyC#
string myText = Translate.Text("My Text", "da");

See Also

Translate Class
TextByLanguage Overload
Sitecore.Globalization Namespace


TextByLanguage Method (String, Language, String)

[image]

Sitecore 6.4.1 API
Translate..::..TextByLanguage Method (String, Language, String)
Translate Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string TextByLanguage(
    string key,
    Language language,
    string defaultValue
)
Visual Basic
Public Shared Function TextByLanguage ( _
    key As String, _
    language As Language, _
    defaultValue As String _
) As String
Visual C++
public:
static String^ TextByLanguage(
    String^ key,
    Language^ language,
    String^ defaultValue
)

Parameters

key
Type: System..::..String
The key.
language
Type: Sitecore.Globalization..::..Language
The language.
defaultValue
Type: System..::..String
The default value.

Return Value

The by language.

See Also

Translate Class
TextByLanguage Overload
Sitecore.Globalization Namespace


TextByLanguage Method (String, Language, String, Object[])

[image]

Sitecore 6.4.1 API
Translate..::..TextByLanguage Method (String, Language, String, array<Object>[]()[][])
Translate Class See Also Send Feedback

Namespace: Sitecore.Globalization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string TextByLanguage(
    string key,
    Language language,
    string defaultValue,
    params Object[] parameters
)
Visual Basic
Public Shared Function TextByLanguage ( _
    key As String, _
    language As Language, _
    defaultValue As String, _
    ParamArray parameters As Object() _
) As String
Visual C++
public:
static String^ TextByLanguage(
    String^ key,
    Language^ language,
    String^ defaultValue,
    ... array<Object^>^ parameters
)

Parameters

key
Type: System..::..String
The key.
language
Type: Sitecore.Globalization..::..Language
The language.
defaultValue
Type: System..::..String
The default value.
parameters
Type: array< System..::..Object >[]()[][]

[Missing <param name="parameters"/> documentation for "M:Sitecore.Globalization.Translate.TextByLanguage(System.String,Sitecore.Globalization.Language,System.String,System.Object[])"]

Return Value

The by language.

See Also

Translate Class
TextByLanguage Overload
Sitecore.Globalization Namespace


ResizeOptions Class

[image]

Sitecore 6.4.1 API
ResizeOptions Class
Members See Also Send Feedback

Namespace: Sitecore.ImageLib
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ResizeOptions
Visual Basic
Public Class ResizeOptions
Visual C++
public ref class ResizeOptions

Inheritance Hierarchy

System..::..Object
Sitecore.ImageLib..::..ResizeOptions

See Also

ResizeOptions Members
Sitecore.ImageLib Namespace


ResizeOptions Members

[image] [image]

Sitecore 6.4.1 API
ResizeOptions Members
ResizeOptions Class Constructors Methods Properties See Also Send Feedback

The ResizeOptions type exposes the following members.

Constructors

 | Name | Description
Public method | ResizeOptions | Initializes a new instance of the ResizeOptions class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllowStretch | Gets a value indicating whether to allow stretching.
Public property | BackgroundColor | Gets the color of the background.
Public property | Format | Gets or sets the image format.
Public property | IsEmpty | Gets a value indicating whether this instance is empty (ie. Size is empty and Scale is 0).
Public property | MaxSize | Gets the max size.
Public property | PreserveResolution | Gets or sets a value indicating whether the ResizeOptions preserves the image resolution. When generating thumbnails, default resolution is used (96dpi), not the original image resolution.
Public property | Scale | Gets the scale.
Public property | Size | Gets the size.

See Also

ResizeOptions Class
Sitecore.ImageLib Namespace


ResizeOptions Constructor

[image]

Sitecore 6.4.1 API
ResizeOptions Constructor
ResizeOptions Class See Also Send Feedback

Namespace: Sitecore.ImageLib
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ResizeOptions()
Visual Basic
Public Sub New
Visual C++
public:
ResizeOptions()

See Also

ResizeOptions Class
Sitecore.ImageLib Namespace


ResizeOptions Methods

[image] [image]

Sitecore 6.4.1 API
ResizeOptions Methods
ResizeOptions Class See Also Send Feedback

The ResizeOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ResizeOptions Class
Sitecore.ImageLib Namespace


ResizeOptions Properties

[image] [image]

Sitecore 6.4.1 API
ResizeOptions Properties
ResizeOptions Class See Also Send Feedback

The ResizeOptions type exposes the following members.

Properties

 | Name | Description
Public property | AllowStretch | Gets a value indicating whether to allow stretching.
Public property | BackgroundColor | Gets the color of the background.
Public property | Format | Gets or sets the image format.
Public property | IsEmpty | Gets a value indicating whether this instance is empty (ie. Size is empty and Scale is 0).
Public property | MaxSize | Gets the max size.
Public property | PreserveResolution | Gets or sets a value indicating whether the ResizeOptions preserves the image resolution. When generating thumbnails, default resolution is used (96dpi), not the original image resolution.
Public property | Scale | Gets the scale.
Public property | Size | Gets the size.

See Also

ResizeOptions Class
Sitecore.ImageLib Namespace


AllowStretch Property

[image]

Sitecore 6.4.1 API
ResizeOptions..::..AllowStretch Property
ResizeOptions Class See Also Send Feedback

Namespace: Sitecore.ImageLib
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool AllowStretch { get; set; }
Visual Basic
Public Property AllowStretch As Boolean
    Get
    Set
Visual C++
public:
property bool AllowStretch {
    bool get ();
    void set (bool value);
}

Field Value

true if stretching is allowed; otherwise, false.

See Also

ResizeOptions Class
Sitecore.ImageLib Namespace


BackgroundColor Property

[image]

Sitecore 6.4.1 API
ResizeOptions..::..BackgroundColor Property
ResizeOptions Class See Also Send Feedback

Namespace: Sitecore.ImageLib
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Color BackgroundColor { get; set; }
Visual Basic
Public Property BackgroundColor As Color
    Get
    Set
Visual C++
public:
property Color BackgroundColor {
    Color get ();
    void set (Color value);
}

Field Value

The color of the background.

See Also

ResizeOptions Class
Sitecore.ImageLib Namespace


Format Property

[image]

Sitecore 6.4.1 API
ResizeOptions..::..Format Property
ResizeOptions Class See Also Send Feedback

Namespace: Sitecore.ImageLib
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ImageFormat Format { get; set; }
Visual Basic
Public Property Format As ImageFormat
    Get
    Set
Visual C++
public:
property ImageFormat^ Format {
    ImageFormat^ get ();
    void set (ImageFormat^ value);
}

Field Value

The format.

See Also

ResizeOptions Class
Sitecore.ImageLib Namespace


IsEmpty Property

[image]

Sitecore 6.4.1 API
ResizeOptions..::..IsEmpty Property
ResizeOptions Class See Also Send Feedback

Namespace: Sitecore.ImageLib
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
property bool IsEmpty {
    bool get ();
}

Field Value

true if this instance is empty; otherwise, false.

See Also

ResizeOptions Class
Sitecore.ImageLib Namespace


MaxSize Property

[image]

Sitecore 6.4.1 API
ResizeOptions..::..MaxSize Property
ResizeOptions Class See Also Send Feedback

Namespace: Sitecore.ImageLib
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Size MaxSize { get; set; }
Visual Basic
Public Property MaxSize As Size
    Get
    Set
Visual C++
public:
property Size MaxSize {
    Size get ();
    void set (Size value);
}

Field Value

The max size.

See Also

ResizeOptions Class
Sitecore.ImageLib Namespace


PreserveResolution Property

[image]

Sitecore 6.4.1 API
ResizeOptions..::..PreserveResolution Property
ResizeOptions Class See Also Send Feedback

Namespace: Sitecore.ImageLib
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool PreserveResolution { get; set; }
Visual Basic
Public Property PreserveResolution As Boolean
    Get
    Set
Visual C++
public:
property bool PreserveResolution {
    bool get ();
    void set (bool value);
}

Field Value

true if the ResizeOptions preserves the resolution; otherwise, false.

See Also

ResizeOptions Class
Sitecore.ImageLib Namespace


Scale Property

[image]

Sitecore 6.4.1 API
ResizeOptions..::..Scale Property
ResizeOptions Class See Also Send Feedback

Namespace: Sitecore.ImageLib
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public float Scale { get; set; }
Visual Basic
Public Property Scale As Single
    Get
    Set
Visual C++
public:
property float Scale {
    float get ();
    void set (float value);
}

Field Value

The scale.

See Also

ResizeOptions Class
Sitecore.ImageLib Namespace


Size Property

[image]

Sitecore 6.4.1 API
ResizeOptions..::..Size Property
ResizeOptions Class See Also Send Feedback

Namespace: Sitecore.ImageLib
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Size Size { get; set; }
Visual Basic
Public Property Size As Size
    Get
    Set
Visual C++
public:
property Size Size {
    Size get ();
    void set (Size value);
}

Field Value

The size.

See Also

ResizeOptions Class
Sitecore.ImageLib Namespace


Resizer Class

[image]

Sitecore 6.4.1 API
Resizer Class
Members See Also Send Feedback

Namespace: Sitecore.ImageLib
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Resizer
Visual Basic
Public Class Resizer
Visual C++
public ref class Resizer

Inheritance Hierarchy

System..::..Object
Sitecore.ImageLib..::..Resizer

See Also

Resizer Members
Sitecore.ImageLib Namespace


Resizer Members

[image] [image]

Sitecore 6.4.1 API
Resizer Members
Resizer Class Constructors Methods See Also Send Feedback

The Resizer type exposes the following members.

Constructors

 | Name | Description
Public method | Resizer | Initializes a new instance of the Resizer class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFrameSize(Bitmap, ResizeOptions) | Gets the size of the output bitmap including any whitespace area.
Public method | GetFrameSize(Bitmap, ResizeOptions, Boolean%) | Gets the size of the output bitmap including any whitespace area.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Resize(Bitmap, ResizeOptions, ImageFormat, InterpolationMode) | Resizes the specified bitmap.
Public method | Resize(Bitmap, Size, Size, Color, ImageFormat, InterpolationMode) | Resizes the specified bitmap.
Public method | Resize(Bitmap, Size, Size, Color, Boolean, ImageFormat, InterpolationMode) | Resizes the specified bitmap.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Resizer Class
Sitecore.ImageLib Namespace


Resizer Constructor

[image]

Sitecore 6.4.1 API
Resizer Constructor
Resizer Class See Also Send Feedback

Namespace: Sitecore.ImageLib
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Resizer()
Visual Basic
Public Sub New
Visual C++
public:
Resizer()

See Also

Resizer Class
Sitecore.ImageLib Namespace


Resizer Methods

[image] [image]

Sitecore 6.4.1 API
Resizer Methods
Resizer Class See Also Send Feedback

The Resizer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFrameSize(Bitmap, ResizeOptions) | Gets the size of the output bitmap including any whitespace area.
Public method | GetFrameSize(Bitmap, ResizeOptions, Boolean%) | Gets the size of the output bitmap including any whitespace area.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Resize(Bitmap, ResizeOptions, ImageFormat, InterpolationMode) | Resizes the specified bitmap.
Public method | Resize(Bitmap, Size, Size, Color, ImageFormat, InterpolationMode) | Resizes the specified bitmap.
Public method | Resize(Bitmap, Size, Size, Color, Boolean, ImageFormat, InterpolationMode) | Resizes the specified bitmap.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Resizer Class
Sitecore.ImageLib Namespace


GetFrameSize Method

[image] [image]

Sitecore 6.4.1 API
Resizer..::..GetFrameSize Method
Resizer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetFrameSize(Bitmap, ResizeOptions) | Gets the size of the output bitmap including any whitespace area.
Public method | GetFrameSize(Bitmap, ResizeOptions, Boolean%) | Gets the size of the output bitmap including any whitespace area.

See Also

Resizer Class
Resizer Members
Sitecore.ImageLib Namespace


GetFrameSize Method (Bitmap, ResizeOptions)

[image]

Sitecore 6.4.1 API
Resizer..::..GetFrameSize Method (Bitmap, ResizeOptions)
Resizer Class See Also Send Feedback

Namespace: Sitecore.ImageLib
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Size GetFrameSize(
    Bitmap image,
    ResizeOptions options
)
Visual Basic
Public Function GetFrameSize ( _
    image As Bitmap, _
    options As ResizeOptions _
) As Size
Visual C++
public:
Size GetFrameSize(
    Bitmap^ image,
    ResizeOptions^ options
)

Parameters

image
Type: System.Drawing..::..Bitmap
The image.
options
Type: Sitecore.ImageLib..::..ResizeOptions
The options.

Return Value

[Missing <returns> documentation for "M:Sitecore.ImageLib.Resizer.GetFrameSize(System.Drawing.Bitmap,Sitecore.ImageLib.ResizeOptions)"]

See Also

Resizer Class
GetFrameSize Overload
Sitecore.ImageLib Namespace


GetFrameSize Method (Bitmap, ResizeOptions, Boolean)

[image]

Sitecore 6.4.1 API
Resizer..::..GetFrameSize Method (Bitmap, ResizeOptions, Boolean%)
Resizer Class See Also Send Feedback

Namespace: Sitecore.ImageLib
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Size GetFrameSize(
    Bitmap image,
    ResizeOptions options,
    out bool proportionsAreSaved
)
Visual Basic
Public Function GetFrameSize ( _
    image As Bitmap, _
    options As ResizeOptions, _
    <OutAttribute> ByRef proportionsAreSaved As Boolean _
) As Size
Visual C++
public:
Size GetFrameSize(
    Bitmap^ image,
    ResizeOptions^ options,
    [OutAttribute] bool% proportionsAreSaved
)

Parameters

image
Type: System.Drawing..::..Bitmap
The image.
options
Type: Sitecore.ImageLib..::..ResizeOptions
The options.
proportionsAreSaved
Type: System..::..Boolean %
if set to true proportions are saved.

Return Value

[Missing <returns> documentation for "M:Sitecore.ImageLib.Resizer.GetFrameSize(System.Drawing.Bitmap,Sitecore.ImageLib.ResizeOptions,System.Boolean@)"]

See Also

Resizer Class
GetFrameSize Overload
Sitecore.ImageLib Namespace


Resize Method

[image] [image]

Sitecore 6.4.1 API
Resizer..::..Resize Method
Resizer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Resize(Bitmap, ResizeOptions, ImageFormat, InterpolationMode) | Resizes the specified bitmap.
Public method | Resize(Bitmap, Size, Size, Color, ImageFormat, InterpolationMode) | Resizes the specified bitmap.
Public method | Resize(Bitmap, Size, Size, Color, Boolean, ImageFormat, InterpolationMode) | Resizes the specified bitmap.

See Also

Resizer Class
Resizer Members
Sitecore.ImageLib Namespace


Resize Method (Bitmap, ResizeOptions, ImageFormat, InterpolationMode)

[image]

Sitecore 6.4.1 API
Resizer..::..Resize Method (Bitmap, ResizeOptions, ImageFormat, InterpolationMode)
Resizer Class See Also Send Feedback

Namespace: Sitecore.ImageLib
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Bitmap Resize(
    Bitmap bitmap,
    ResizeOptions options,
    ImageFormat format,
    InterpolationMode interpolationMode
)
Visual Basic
Public Function Resize ( _
    bitmap As Bitmap, _
    options As ResizeOptions, _
    format As ImageFormat, _
    interpolationMode As InterpolationMode _
) As Bitmap
Visual C++
public:
Bitmap^ Resize(
    Bitmap^ bitmap,
    ResizeOptions^ options,
    ImageFormat^ format,
    InterpolationMode interpolationMode
)

Parameters

bitmap
Type: System.Drawing..::..Bitmap
The bitmap.
options
Type: Sitecore.ImageLib..::..ResizeOptions
The options.
format
Type: System.Drawing.Imaging..::..ImageFormat
The format.
interpolationMode
Type: System.Drawing.Drawing2D..::..InterpolationMode
The interpolation mode.

Return Value

[Missing <returns> documentation for "M:Sitecore.ImageLib.Resizer.Resize(System.Drawing.Bitmap,Sitecore.ImageLib.ResizeOptions,System.Drawing.Imaging.ImageFormat,System.Drawing.Drawing2D.InterpolationMode)"]

See Also

Resizer Class
Resize Overload
Sitecore.ImageLib Namespace


Resize Method (Bitmap, Size, Size, Color, ImageFormat, InterpolationMode)

[image]

Sitecore 6.4.1 API
Resizer..::..Resize Method (Bitmap, Size, Size, Color, ImageFormat, InterpolationMode)
Resizer Class See Also Send Feedback

Namespace: Sitecore.ImageLib
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Bitmap Resize(
    Bitmap bitmap,
    Size imageSize,
    Size frameSize,
    Color frameColor,
    ImageFormat format,
    InterpolationMode interpolationMode
)
Visual Basic
Public Function Resize ( _
    bitmap As Bitmap, _
    imageSize As Size, _
    frameSize As Size, _
    frameColor As Color, _
    format As ImageFormat, _
    interpolationMode As InterpolationMode _
) As Bitmap
Visual C++
public:
Bitmap^ Resize(
    Bitmap^ bitmap,
    Size imageSize,
    Size frameSize,
    Color frameColor,
    ImageFormat^ format,
    InterpolationMode interpolationMode
)

Parameters

bitmap
Type: System.Drawing..::..Bitmap
The bitmap.
imageSize
Type: System.Drawing..::..Size
Size of the image.
frameSize
Type: System.Drawing..::..Size
Size of the frame.
frameColor
Type: System.Drawing..::..Color
Color of the frame.
format
Type: System.Drawing.Imaging..::..ImageFormat
The format.
interpolationMode
Type: System.Drawing.Drawing2D..::..InterpolationMode
The interpolation mode.

Return Value

The resize.

See Also

Resizer Class
Resize Overload
Sitecore.ImageLib Namespace


Resize Method (Bitmap, Size, Size, Color, Boolean, ImageFormat, InterpolationMode)

[image]

Sitecore 6.4.1 API
Resizer..::..Resize Method (Bitmap, Size, Size, Color, Boolean, ImageFormat, InterpolationMode)
Resizer Class See Also Send Feedback

Namespace: Sitecore.ImageLib
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Bitmap Resize(
    Bitmap bitmap,
    Size imageSize,
    Size frameSize,
    Color frameColor,
    bool preserveResolution,
    ImageFormat format,
    InterpolationMode interpolationMode
)
Visual Basic
Public Function Resize ( _
    bitmap As Bitmap, _
    imageSize As Size, _
    frameSize As Size, _
    frameColor As Color, _
    preserveResolution As Boolean, _
    format As ImageFormat, _
    interpolationMode As InterpolationMode _
) As Bitmap
Visual C++
public:
Bitmap^ Resize(
    Bitmap^ bitmap,
    Size imageSize,
    Size frameSize,
    Color frameColor,
    bool preserveResolution,
    ImageFormat^ format,
    InterpolationMode interpolationMode
)

Parameters

bitmap
Type: System.Drawing..::..Bitmap
The bitmap.
imageSize
Type: System.Drawing..::..Size
Size of the image.
frameSize
Type: System.Drawing..::..Size
Size of the frame.
frameColor
Type: System.Drawing..::..Color
Color of the frame.
preserveResolution
Type: System..::..Boolean
if set to true resolution will not be reduced to 96dpi.
format
Type: System.Drawing.Imaging..::..ImageFormat
The format.
interpolationMode
Type: System.Drawing.Drawing2D..::..InterpolationMode
The interpolation mode.

Return Value

The resize.

See Also

Resizer Class
Resize Overload
Sitecore.ImageLib Namespace


ThumbMaker Class

[image]

Sitecore 6.4.1 API
ThumbMaker Class
Members See Also Send Feedback

Namespace: Sitecore.ImageLib
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ThumbMaker
Visual Basic
Public Class ThumbMaker
Visual C++
public ref class ThumbMaker

Inheritance Hierarchy

System..::..Object
Sitecore.ImageLib..::..ThumbMaker

See Also

ThumbMaker Members
Sitecore.ImageLib Namespace


ThumbMaker Members

[image] [image]

Sitecore 6.4.1 API
ThumbMaker Members
ThumbMaker Class Constructors Methods See Also Send Feedback

The ThumbMaker type exposes the following members.

Constructors

 | Name | Description
Public method | ThumbMaker(Bitmap) | Initializes a new instance of the ThumbMaker class.
Public method | ThumbMaker(Stream) | Initializes a new instance of the ThumbMaker class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResizeToGif(Size, Boolean) | Resizes to GIF.
Public method | ResizeToGif(Int32, Int32, String) | Resizes to GIF.
Public method | ResizeToJpeg(Int32, Int32, Stream) | Resizes to JPEG.
Public method | ResizeToJpeg(Int32, Int32, String) | Resizes to JPEG.
Public method | ResizeToJpeg(Int32, Int32, Int64, Stream) | Resizes to JPEG.
Public method | ResizeToJpeg(Int32, Int32, Int64, String) | Resizes to JPEG.
Public method | ResizeToPng(Int32, Int32, Stream) | Resizes to PNG.
Public method | ResizeToPng(Int32, Int32, String) | Resizes to PNG.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ThumbMaker Class
Sitecore.ImageLib Namespace


ThumbMaker Constructor

[image] [image]

Sitecore 6.4.1 API
ThumbMaker Constructor
ThumbMaker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ThumbMaker(Bitmap) | Initializes a new instance of the ThumbMaker class.
Public method | ThumbMaker(Stream) | Initializes a new instance of the ThumbMaker class.

See Also

ThumbMaker Class
ThumbMaker Members
Sitecore.ImageLib Namespace


ThumbMaker Constructor (Bitmap)

[image]

Sitecore 6.4.1 API
ThumbMaker Constructor (Bitmap)
ThumbMaker Class See Also Send Feedback

Namespace: Sitecore.ImageLib
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ThumbMaker(
    Bitmap image
)
Visual Basic
Public Sub New ( _
    image As Bitmap _
)
Visual C++
public:
ThumbMaker(
    Bitmap^ image
)

Parameters

image
Type: System.Drawing..::..Bitmap
The image.

See Also

ThumbMaker Class
ThumbMaker Overload
Sitecore.ImageLib Namespace


ThumbMaker Constructor (Stream)

[image]

Sitecore 6.4.1 API
ThumbMaker Constructor (Stream)
ThumbMaker Class See Also Send Feedback

Namespace: Sitecore.ImageLib
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ThumbMaker(
    Stream stream
)
Visual Basic
Public Sub New ( _
    stream As Stream _
)
Visual C++
public:
ThumbMaker(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::..Stream
The stream.

See Also

ThumbMaker Class
ThumbMaker Overload
Sitecore.ImageLib Namespace


ThumbMaker Methods

[image] [image]

Sitecore 6.4.1 API
ThumbMaker Methods
ThumbMaker Class See Also Send Feedback

The ThumbMaker type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResizeToGif(Size, Boolean) | Resizes to GIF.
Public method | ResizeToGif(Int32, Int32, String) | Resizes to GIF.
Public method | ResizeToJpeg(Int32, Int32, Stream) | Resizes to JPEG.
Public method | ResizeToJpeg(Int32, Int32, String) | Resizes to JPEG.
Public method | ResizeToJpeg(Int32, Int32, Int64, Stream) | Resizes to JPEG.
Public method | ResizeToJpeg(Int32, Int32, Int64, String) | Resizes to JPEG.
Public method | ResizeToPng(Int32, Int32, Stream) | Resizes to PNG.
Public method | ResizeToPng(Int32, Int32, String) | Resizes to PNG.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ThumbMaker Class
Sitecore.ImageLib Namespace


ResizeToGif Method

[image] [image]

Sitecore 6.4.1 API
ThumbMaker..::..ResizeToGif Method
ThumbMaker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResizeToGif(Size, Boolean) | Resizes to GIF.
Public method | ResizeToGif(Int32, Int32, String) | Resizes to GIF.

See Also

ThumbMaker Class
ThumbMaker Members
Sitecore.ImageLib Namespace


ResizeToGif Method (Size, Boolean)

[image]

Sitecore 6.4.1 API
ThumbMaker..::..ResizeToGif Method (Size, Boolean)
ThumbMaker Class See Also Send Feedback

Namespace: Sitecore.ImageLib
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Bitmap ResizeToGif(
    Size size,
    bool preserveResolution
)
Visual Basic
Public Function ResizeToGif ( _
    size As Size, _
    preserveResolution As Boolean _
) As Bitmap
Visual C++
public:
Bitmap^ ResizeToGif(
    Size size,
    bool preserveResolution
)

Parameters

size
Type: System.Drawing..::..Size
The size.
preserveResolution
Type: System..::..Boolean
if set to true output resolution will be the same as input resolution, not reduced to 96dpi.

Return Value

The to GIF.

See Also

ThumbMaker Class
ResizeToGif Overload
Sitecore.ImageLib Namespace


ResizeToGif Method (Int32, Int32, String)

[image]

Sitecore 6.4.1 API
ThumbMaker..::..ResizeToGif Method (Int32, Int32, String)
ThumbMaker Class See Also Send Feedback

Namespace: Sitecore.ImageLib
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void ResizeToGif(
    int xSize,
    int ySize,
    string fileName
)
Visual Basic
Public Sub ResizeToGif ( _
    xSize As Integer, _
    ySize As Integer, _
    fileName As String _
)
Visual C++
public:
void ResizeToGif(
    int xSize,
    int ySize,
    String^ fileName
)

Parameters

xSize
Type: System..::..Int32
Size of the x.
ySize
Type: System..::..Int32
Size of the y.
fileName
Type: System..::..String
Name of the file.

See Also

ThumbMaker Class
ResizeToGif Overload
Sitecore.ImageLib Namespace


ResizeToJpeg Method

[image] [image]

Sitecore 6.4.1 API
ThumbMaker..::..ResizeToJpeg Method
ThumbMaker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResizeToJpeg(Int32, Int32, Stream) | Resizes to JPEG.
Public method | ResizeToJpeg(Int32, Int32, String) | Resizes to JPEG.
Public method | ResizeToJpeg(Int32, Int32, Int64, Stream) | Resizes to JPEG.
Public method | ResizeToJpeg(Int32, Int32, Int64, String) | Resizes to JPEG.

See Also

ThumbMaker Class
ThumbMaker Members
Sitecore.ImageLib Namespace


ResizeToJpeg Method (Int32, Int32, Stream)

[image]

Sitecore 6.4.1 API
ThumbMaker..::..ResizeToJpeg Method (Int32, Int32, Stream)
ThumbMaker Class See Also Send Feedback

Namespace: Sitecore.ImageLib
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void ResizeToJpeg(
    int xSize,
    int ySize,
    Stream stream
)
Visual Basic
Public Sub ResizeToJpeg ( _
    xSize As Integer, _
    ySize As Integer, _
    stream As Stream _
)
Visual C++
public:
void ResizeToJpeg(
    int xSize,
    int ySize,
    Stream^ stream
)

Parameters

xSize
Type: System..::..Int32
Size of the x.
ySize
Type: System..::..Int32
Size of the y.
stream
Type: System.IO..::..Stream
The stream.

See Also

ThumbMaker Class
ResizeToJpeg Overload
Sitecore.ImageLib Namespace


ResizeToJpeg Method (Int32, Int32, String)

[image]

Sitecore 6.4.1 API
ThumbMaker..::..ResizeToJpeg Method (Int32, Int32, String)
ThumbMaker Class See Also Send Feedback

Namespace: Sitecore.ImageLib
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void ResizeToJpeg(
    int xSize,
    int ySize,
    string fileName
)
Visual Basic
Public Sub ResizeToJpeg ( _
    xSize As Integer, _
    ySize As Integer, _
    fileName As String _
)
Visual C++
public:
void ResizeToJpeg(
    int xSize,
    int ySize,
    String^ fileName
)

Parameters

xSize
Type: System..::..Int32
Size of the x.
ySize
Type: System..::..Int32
Size of the y.
fileName
Type: System..::..String
Name of the file.

See Also

ThumbMaker Class
ResizeToJpeg Overload
Sitecore.ImageLib Namespace


ResizeToJpeg Method (Int32, Int32, Int64, String)

[image]

Sitecore 6.4.1 API
ThumbMaker..::..ResizeToJpeg Method (Int32, Int32, Int64, String)
ThumbMaker Class See Also Send Feedback

Namespace: Sitecore.ImageLib
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void ResizeToJpeg(
    int xSize,
    int ySize,
    long jQuality,
    string fileName
)
Visual Basic
Public Sub ResizeToJpeg ( _
    xSize As Integer, _
    ySize As Integer, _
    jQuality As Long, _
    fileName As String _
)
Visual C++
public:
void ResizeToJpeg(
    int xSize,
    int ySize,
    long long jQuality,
    String^ fileName
)

Parameters

xSize
Type: System..::..Int32
Size of the x.
ySize
Type: System..::..Int32
Size of the y.
jQuality
Type: System..::..Int64
The j quality.
fileName
Type: System..::..String
Name of the file.

See Also

ThumbMaker Class
ResizeToJpeg Overload
Sitecore.ImageLib Namespace


ResizeToPng Method (Int32, Int32, Stream)

[image]

Sitecore 6.4.1 API
ThumbMaker..::..ResizeToPng Method (Int32, Int32, Stream)
ThumbMaker Class See Also Send Feedback

Namespace: Sitecore.ImageLib
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void ResizeToPng(
    int xSize,
    int ySize,
    Stream stream
)
Visual Basic
Public Sub ResizeToPng ( _
    xSize As Integer, _
    ySize As Integer, _
    stream As Stream _
)
Visual C++
public:
void ResizeToPng(
    int xSize,
    int ySize,
    Stream^ stream
)

Parameters

xSize
Type: System..::..Int32
Size of the x.
ySize
Type: System..::..Int32
Size of the y.
stream
Type: System.IO..::..Stream
The stream.

See Also

ThumbMaker Class
ResizeToPng Overload
Sitecore.ImageLib Namespace


ResizeToPng Method (Int32, Int32, String)

[image]

Sitecore 6.4.1 API
ThumbMaker..::..ResizeToPng Method (Int32, Int32, String)
ThumbMaker Class See Also Send Feedback

Namespace: Sitecore.ImageLib
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void ResizeToPng(
    int xSize,
    int ySize,
    string fileName
)
Visual Basic
Public Sub ResizeToPng ( _
    xSize As Integer, _
    ySize As Integer, _
    fileName As String _
)
Visual C++
public:
void ResizeToPng(
    int xSize,
    int ySize,
    String^ fileName
)

Parameters

xSize
Type: System..::..Int32
Size of the x.
ySize
Type: System..::..Int32
Size of the y.
fileName
Type: System..::..String
Name of the file.

See Also

ThumbMaker Class
ResizeToPng Overload
Sitecore.ImageLib Namespace


Sitecore.Install Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Install Namespace
Send Feedback

Classes

 | Class | Description
Public class | Constants | Constants
Public class | Installer | Installer class
Public class | PackageGenerator | Package generator
Public class | PackageProject | Package project class
Public class | PackageProject..::..Builder | Represents a sink which is used to build a PackageProject object
Public class | PackageRegistrationFieldIDs | Constains field ids
Public class | PackageUtils | Package utils
Public class | StreamUtil | Stream utility class


Constants Class

[image]

Sitecore 6.4.1 API
Constants Class
Members See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Constants
Visual Basic
Public NotInheritable Class Constants
Visual C++
public ref class Constants abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Install..::..Constants

See Also

Constants Members
Sitecore.Install Namespace


Constants Members

[image] [image]

Sitecore 6.4.1 API
Constants Members
Constants Class Fields Properties See Also Send Feedback

The Constants type exposes the following members.

Fields

Name | Description
ApplicationPath |
BlobDataPrefix |
FilesPrefix |
IDCollisionPrefix |
InstallerObjectTemplate |
InstallerPrefix |
InstallMode |
ItemsPrefix |
KeySeparator |
MediaStreamsFolder |
MergeMode |
MetadataPrefix |
PackageExtension |
PathCollisionPrefix |
ProjectKey |
PropertiesPrefix |
SolutionExtension |
SystemPath |
UnnamedPackage |

Properties

Name | Description
Database | Gets the database.

See Also

Constants Class
Sitecore.Install Namespace


ApplicationPath Field

[image]

Sitecore 6.4.1 API
Constants..::..ApplicationPath Field
Constants Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly string ApplicationPath
Visual Basic
Public Shared ReadOnly ApplicationPath As String
Visual C++
public:
static initonly String^ ApplicationPath

See Also

Constants Class
Sitecore.Install Namespace


BlobDataPrefix Field

[image]

Sitecore 6.4.1 API
Constants..::..BlobDataPrefix Field
Constants Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly string BlobDataPrefix
Visual Basic
Public Shared ReadOnly BlobDataPrefix As String
Visual C++
public:
static initonly String^ BlobDataPrefix

See Also

Constants Class
Sitecore.Install Namespace


FilesPrefix Field

[image]

Sitecore 6.4.1 API
Constants..::..FilesPrefix Field
Constants Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly string FilesPrefix
Visual Basic
Public Shared ReadOnly FilesPrefix As String
Visual C++
public:
static initonly String^ FilesPrefix

See Also

Constants Class
Sitecore.Install Namespace


IDCollisionPrefix Field

[image]

Sitecore 6.4.1 API
Constants..::..IDCollisionPrefix Field
Constants Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly string IDCollisionPrefix
Visual Basic
Public Shared ReadOnly IDCollisionPrefix As String
Visual C++
public:
static initonly String^ IDCollisionPrefix

See Also

Constants Class
Sitecore.Install Namespace


InstallerObjectTemplate Field

[image]

Sitecore 6.4.1 API
Constants..::..InstallerObjectTemplate Field
Constants Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ID InstallerObjectTemplate
Visual Basic
Public Shared InstallerObjectTemplate As ID
Visual C++
public:
static ID^ InstallerObjectTemplate

See Also

Constants Class
Sitecore.Install Namespace


InstallerPrefix Field

[image]

Sitecore 6.4.1 API
Constants..::..InstallerPrefix Field
Constants Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly string InstallerPrefix
Visual Basic
Public Shared ReadOnly InstallerPrefix As String
Visual C++
public:
static initonly String^ InstallerPrefix

See Also

Constants Class
Sitecore.Install Namespace


InstallMode Field

[image]

Sitecore 6.4.1 API
Constants..::..InstallMode Field
Constants Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly string InstallMode
Visual Basic
Public Shared ReadOnly InstallMode As String
Visual C++
public:
static initonly String^ InstallMode

See Also

Constants Class
Sitecore.Install Namespace


ItemsPrefix Field

[image]

Sitecore 6.4.1 API
Constants..::..ItemsPrefix Field
Constants Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly string ItemsPrefix
Visual Basic
Public Shared ReadOnly ItemsPrefix As String
Visual C++
public:
static initonly String^ ItemsPrefix

See Also

Constants Class
Sitecore.Install Namespace


KeySeparator Field

[image]

Sitecore 6.4.1 API
Constants..::..KeySeparator Field
Constants Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly char KeySeparator
Visual Basic
Public Shared ReadOnly KeySeparator As Char
Visual C++
public:
static initonly wchar_t KeySeparator

See Also

Constants Class
Sitecore.Install Namespace


MediaStreamsFolder Field

[image]

Sitecore 6.4.1 API
Constants..::..MediaStreamsFolder Field
Constants Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly string MediaStreamsFolder
Visual Basic
Public Shared ReadOnly MediaStreamsFolder As String
Visual C++
public:
static initonly String^ MediaStreamsFolder

See Also

Constants Class
Sitecore.Install Namespace


MergeMode Field

[image]

Sitecore 6.4.1 API
Constants..::..MergeMode Field
Constants Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly string MergeMode
Visual Basic
Public Shared ReadOnly MergeMode As String
Visual C++
public:
static initonly String^ MergeMode

See Also

Constants Class
Sitecore.Install Namespace


MetadataPrefix Field

[image]

Sitecore 6.4.1 API
Constants..::..MetadataPrefix Field
Constants Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly string MetadataPrefix
Visual Basic
Public Shared ReadOnly MetadataPrefix As String
Visual C++
public:
static initonly String^ MetadataPrefix

See Also

Constants Class
Sitecore.Install Namespace


PackageExtension Field

[image]

Sitecore 6.4.1 API
Constants..::..PackageExtension Field
Constants Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly string PackageExtension
Visual Basic
Public Shared ReadOnly PackageExtension As String
Visual C++
public:
static initonly String^ PackageExtension

See Also

Constants Class
Sitecore.Install Namespace


PathCollisionPrefix Field

[image]

Sitecore 6.4.1 API
Constants..::..PathCollisionPrefix Field
Constants Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly string PathCollisionPrefix
Visual Basic
Public Shared ReadOnly PathCollisionPrefix As String
Visual C++
public:
static initonly String^ PathCollisionPrefix

See Also

Constants Class
Sitecore.Install Namespace


ProjectKey Field

[image]

Sitecore 6.4.1 API
Constants..::..ProjectKey Field
Constants Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly string ProjectKey
Visual Basic
Public Shared ReadOnly ProjectKey As String
Visual C++
public:
static initonly String^ ProjectKey

See Also

Constants Class
Sitecore.Install Namespace


PropertiesPrefix Field

[image]

Sitecore 6.4.1 API
Constants..::..PropertiesPrefix Field
Constants Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly string PropertiesPrefix
Visual Basic
Public Shared ReadOnly PropertiesPrefix As String
Visual C++
public:
static initonly String^ PropertiesPrefix

See Also

Constants Class
Sitecore.Install Namespace


SolutionExtension Field

[image]

Sitecore 6.4.1 API
Constants..::..SolutionExtension Field
Constants Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly string SolutionExtension
Visual Basic
Public Shared ReadOnly SolutionExtension As String
Visual C++
public:
static initonly String^ SolutionExtension

See Also

Constants Class
Sitecore.Install Namespace


SystemPath Field

[image]

Sitecore 6.4.1 API
Constants..::..SystemPath Field
Constants Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly string SystemPath
Visual Basic
Public Shared ReadOnly SystemPath As String
Visual C++
public:
static initonly String^ SystemPath

See Also

Constants Class
Sitecore.Install Namespace


Constants Properties

[image] [image]

Sitecore 6.4.1 API
Constants Properties
Constants Class See Also Send Feedback

The Constants type exposes the following members.

Properties

Name | Description
Database | Gets the database.

See Also

Constants Class
Sitecore.Install Namespace


Database Property

[image]

Sitecore 6.4.1 API
Constants..::..Database Property
Constants Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Database Database { get; }
Visual Basic
Public Shared ReadOnly Property Database As Database
    Get
Visual C++
public:
static property Database^ Database {
    Database^ get ();
}

Field Value

The database.

See Also

Constants Class
Sitecore.Install Namespace


Installer Class

[image]

Sitecore 6.4.1 API
Installer Class
Members See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Installer : MarshalByRefObject
Visual Basic
Public Class Installer _
    Inherits MarshalByRefObject
Visual C++
public ref class Installer : public MarshalByRefObject

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
Sitecore.Install..::..Installer

See Also

Installer Members
Sitecore.Install Namespace


Installer Members

[image] [image]

Sitecore 6.4.1 API
Installer Members
Installer Class Constructors Methods See Also Send Feedback

The Installer type exposes the following members.

Constructors

 | Name | Description
Public method | Installer | Initializes a new instance of the Installer class

Methods

 | Name | Description
 | CreateInstallationContext | Creates the installation context.
 | CreateInstallerSink | Creates an installer sink.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreatePreviewContext | Creates the preview context.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecutePostStep | Executes the post step.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFilename | Gets the filename.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetPostStep | Gets the post step.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | InstallPackage(String) | Installs the package.
Public method | InstallPackage(String, IProcessingContext) | Installs the package.
Public method | InstallPackage(String, ISource<(Of <<'(PackageEntry>)>>)) | Installs the package.
Public method | InstallPackage(String, ISource<(Of <<'(PackageEntry>)>>), IProcessingContext) | Installs the package.
Public method | InstallSecurity(String) | Installs the security accounts from the package.
Public method | InstallSecurity(String, IProcessingContext) | Installs the security accounts from the package.
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | RegisterPackage | Creates an item with information about package installation.
 | RestartServer | Restarts the sitecore server.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Installer Class
Sitecore.Install Namespace


Installer Constructor

[image]

Sitecore 6.4.1 API
Installer Constructor
Installer Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Installer()
Visual Basic
Public Sub New
Visual C++
public:
Installer()

See Also

Installer Class
Sitecore.Install Namespace


Installer Methods

[image] [image]

Sitecore 6.4.1 API
Installer Methods
Installer Class See Also Send Feedback

The Installer type exposes the following members.

Methods

 | Name | Description
 | CreateInstallationContext | Creates the installation context.
 | CreateInstallerSink | Creates an installer sink.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreatePreviewContext | Creates the preview context.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecutePostStep | Executes the post step.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFilename | Gets the filename.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetPostStep | Gets the post step.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | InstallPackage(String) | Installs the package.
Public method | InstallPackage(String, IProcessingContext) | Installs the package.
Public method | InstallPackage(String, ISource<(Of <<'(PackageEntry>)>>)) | Installs the package.
Public method | InstallPackage(String, ISource<(Of <<'(PackageEntry>)>>), IProcessingContext) | Installs the package.
Public method | InstallSecurity(String) | Installs the security accounts from the package.
Public method | InstallSecurity(String, IProcessingContext) | Installs the security accounts from the package.
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | RegisterPackage | Creates an item with information about package installation.
 | RestartServer | Restarts the sitecore server.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Installer Class
Sitecore.Install Namespace


CreateInstallationContext Method

[image]

Sitecore 6.4.1 API
Installer..::..CreateInstallationContext Method
Installer Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static IProcessingContext CreateInstallationContext()
Visual Basic
Public Shared Function CreateInstallationContext As IProcessingContext
Visual C++
public:
static IProcessingContext^ CreateInstallationContext()

Return Value

The installation context.

See Also

Installer Class
Sitecore.Install Namespace


CreateInstallerSink Method

[image]

Sitecore 6.4.1 API
Installer..::..CreateInstallerSink Method
Installer Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ISink<PackageEntry> CreateInstallerSink(
    IProcessingContext context
)
Visual Basic
Public Shared Function CreateInstallerSink ( _
    context As IProcessingContext _
) As ISink(Of PackageEntry)
Visual C++
public:
static ISink<PackageEntry^>^ CreateInstallerSink(
    IProcessingContext^ context
)

Parameters

context
Type: Sitecore.Install.Framework..::..IProcessingContext

[Missing <param name="context"/> documentation for "M:Sitecore.Install.Installer.CreateInstallerSink(Sitecore.Install.Framework.IProcessingContext)"]

Return Value

An installer sink.

See Also

Installer Class
Sitecore.Install Namespace


CreatePreviewContext Method

[image]

Sitecore 6.4.1 API
Installer..::..CreatePreviewContext Method
Installer Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static IProcessingContext CreatePreviewContext()
Visual Basic
Public Shared Function CreatePreviewContext As IProcessingContext
Visual C++
public:
static IProcessingContext^ CreatePreviewContext()

Return Value

The preview context.

See Also

Installer Class
Sitecore.Install Namespace


ExecutePostStep Method

[image]

Sitecore 6.4.1 API
Installer..::..ExecutePostStep Method
Installer Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void ExecutePostStep(
    string action,
    IProcessingContext context
)
Visual Basic
Public Sub ExecutePostStep ( _
    action As String, _
    context As IProcessingContext _
)
Visual C++
public:
void ExecutePostStep(
    String^ action,
    IProcessingContext^ context
)

Parameters

action
Type: System..::..String
The action.
context
Type: Sitecore.Install.Framework..::..IProcessingContext
The context.

See Also

Installer Class
Sitecore.Install Namespace


GetFilename Method

[image]

Sitecore 6.4.1 API
Installer..::..GetFilename Method
Installer Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetFilename(
    string filename
)
Visual Basic
Public Shared Function GetFilename ( _
    filename As String _
) As String
Visual C++
public:
static String^ GetFilename(
    String^ filename
)

Parameters

filename
Type: System..::..String
The filename.

Return Value

The filename.

See Also

Installer Class
Sitecore.Install Namespace


GetPostStep Method

[image]

Sitecore 6.4.1 API
Installer..::..GetPostStep Method
Installer Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetPostStep(
    IProcessingContext context
)
Visual Basic
Public Shared Function GetPostStep ( _
    context As IProcessingContext _
) As String
Visual C++
public:
static String^ GetPostStep(
    IProcessingContext^ context
)

Parameters

context
Type: Sitecore.Install.Framework..::..IProcessingContext
The context.

Return Value

The post step.

See Also

Installer Class
Sitecore.Install Namespace


InstallPackage Method

[image] [image]

Sitecore 6.4.1 API
Installer..::..InstallPackage Method
Installer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InstallPackage(String) | Installs the package.
Public method | InstallPackage(String, IProcessingContext) | Installs the package.
Public method | InstallPackage(String, ISource<(Of <<'(PackageEntry>)>>)) | Installs the package.
Public method | InstallPackage(String, ISource<(Of <<'(PackageEntry>)>>), IProcessingContext) | Installs the package.

See Also

Installer Class
Installer Members
Sitecore.Install Namespace


InstallPackage Method (String)

[image]

Sitecore 6.4.1 API
Installer..::..InstallPackage Method (String)
Installer Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void InstallPackage(
    string path
)
Visual Basic
Public Sub InstallPackage ( _
    path As String _
)
Visual C++
public:
void InstallPackage(
    String^ path
)

Parameters

path
Type: System..::..String
The path.

See Also

Installer Class
InstallPackage Overload
Sitecore.Install Namespace


InstallPackage Method (String, IProcessingContext)

[image]

Sitecore 6.4.1 API
Installer..::..InstallPackage Method (String, IProcessingContext)
Installer Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void InstallPackage(
    string path,
    IProcessingContext context
)
Visual Basic
Public Sub InstallPackage ( _
    path As String, _
    context As IProcessingContext _
)
Visual C++
public:
void InstallPackage(
    String^ path,
    IProcessingContext^ context
)

Parameters

path
Type: System..::..String
The path.
context
Type: Sitecore.Install.Framework..::..IProcessingContext
The processing context.

See Also

Installer Class
InstallPackage Overload
Sitecore.Install Namespace


InstallPackage Method (String, ISource(PackageEntry))

[image]

Sitecore 6.4.1 API
Installer..::..InstallPackage Method (String, ISource<(Of <(<'PackageEntry>)>)>)
Installer Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void InstallPackage(
    string path,
    ISource<PackageEntry> source
)
Visual Basic
Public Sub InstallPackage ( _
    path As String, _
    source As ISource(Of PackageEntry) _
)
Visual C++
public:
void InstallPackage(
    String^ path,
    ISource<PackageEntry^>^ source
)

Parameters

path
Type: System..::..String
The path.
source
Type: Sitecore.Install.Framework..::..ISource <(Of <(<' PackageEntry >)>)>
The source.

See Also

Installer Class
InstallPackage Overload
Sitecore.Install Namespace


InstallPackage Method (String, ISource(PackageEntry), IProcessingContext)

[image]

Sitecore 6.4.1 API
Installer..::..InstallPackage Method (String, ISource<(Of <(<'PackageEntry>)>)>, IProcessingContext)
Installer Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void InstallPackage(
    string path,
    ISource<PackageEntry> source,
    IProcessingContext context
)
Visual Basic
Public Sub InstallPackage ( _
    path As String, _
    source As ISource(Of PackageEntry), _
    context As IProcessingContext _
)
Visual C++
public:
void InstallPackage(
    String^ path,
    ISource<PackageEntry^>^ source,
    IProcessingContext^ context
)

Parameters

path
Type: System..::..String
The path.
source
Type: Sitecore.Install.Framework..::..ISource <(Of <(<' PackageEntry >)>)>
The source.
context
Type: Sitecore.Install.Framework..::..IProcessingContext
The processing context.

See Also

Installer Class
InstallPackage Overload
Sitecore.Install Namespace


InstallSecurity Method

[image] [image]

Sitecore 6.4.1 API
Installer..::..InstallSecurity Method
Installer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InstallSecurity(String) | Installs the security accounts from the package.
Public method | InstallSecurity(String, IProcessingContext) | Installs the security accounts from the package.

See Also

Installer Class
Installer Members
Sitecore.Install Namespace


InstallSecurity Method (String)

[image]

Sitecore 6.4.1 API
Installer..::..InstallSecurity Method (String)
Installer Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void InstallSecurity(
    string path
)
Visual Basic
Public Sub InstallSecurity ( _
    path As String _
)
Visual C++
public:
void InstallSecurity(
    String^ path
)

Parameters

path
Type: System..::..String
The path to the package file.

See Also

Installer Class
InstallSecurity Overload
Sitecore.Install Namespace


InstallSecurity Method (String, IProcessingContext)

[image]

Sitecore 6.4.1 API
Installer..::..InstallSecurity Method (String, IProcessingContext)
Installer Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void InstallSecurity(
    string path,
    IProcessingContext context
)
Visual Basic
Public Sub InstallSecurity ( _
    path As String, _
    context As IProcessingContext _
)
Visual C++
public:
void InstallSecurity(
    String^ path,
    IProcessingContext^ context
)

Parameters

path
Type: System..::..String
The path to the package file.
context
Type: Sitecore.Install.Framework..::..IProcessingContext
The context.

See Also

Installer Class
InstallSecurity Overload
Sitecore.Install Namespace


MemberwiseClone Method

[image] [image]

Sitecore 6.4.1 API
Installer..::..MemberwiseClone Method
Installer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

Installer Class
Installer Members
Sitecore.Install Namespace


RegisterPackage Method

[image]

Sitecore 6.4.1 API
Installer..::..RegisterPackage Method
Installer Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void RegisterPackage(
    IProcessingContext context
)
Visual Basic
Protected Overridable Sub RegisterPackage ( _
    context As IProcessingContext _
)
Visual C++
protected:
virtual void RegisterPackage(
    IProcessingContext^ context
)

Parameters

context
Type: Sitecore.Install.Framework..::..IProcessingContext
The context.

See Also

Installer Class
Sitecore.Install Namespace


RestartServer Method

[image]

Sitecore 6.4.1 API
Installer..::..RestartServer Method
Installer Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void RestartServer()
Visual Basic
Public Shared Sub RestartServer
Visual C++
public:
static void RestartServer()

See Also

Installer Class
Sitecore.Install Namespace


PackageGenerator Class

[image]

Sitecore 6.4.1 API
PackageGenerator Class
Members See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class PackageGenerator
Visual Basic
Public NotInheritable Class PackageGenerator
Visual C++
public ref class PackageGenerator abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Install..::..PackageGenerator

See Also

PackageGenerator Members
Sitecore.Install Namespace


PackageGenerator Members

[image] [image]

Sitecore 6.4.1 API
PackageGenerator Members
PackageGenerator Class Methods See Also Send Feedback

The PackageGenerator type exposes the following members.

Methods

Name | Description
GeneratePackage(PackageProject, ISink<(Of <<'(PackageEntry>)>>)) | Generates the package.
GeneratePackage(String, String, IProcessingContext) | Generates the package.
NewProjectFromPackage | Creates a new project from the package.

See Also

PackageGenerator Class
Sitecore.Install Namespace


PackageGenerator Methods

[image] [image]

Sitecore 6.4.1 API
PackageGenerator Methods
PackageGenerator Class See Also Send Feedback

The PackageGenerator type exposes the following members.

Methods

Name | Description
GeneratePackage(PackageProject, ISink<(Of <<'(PackageEntry>)>>)) | Generates the package.
GeneratePackage(String, String, IProcessingContext) | Generates the package.
NewProjectFromPackage | Creates a new project from the package.

See Also

PackageGenerator Class
Sitecore.Install Namespace


GeneratePackage Method

[image] [image]

Sitecore 6.4.1 API
PackageGenerator..::..GeneratePackage Method
PackageGenerator Class See Also Send Feedback

Overload List

Name | Description
GeneratePackage(PackageProject, ISink<(Of <<'(PackageEntry>)>>)) | Generates the package.
GeneratePackage(String, String, IProcessingContext) | Generates the package.

See Also

PackageGenerator Class
PackageGenerator Members
Sitecore.Install Namespace


GeneratePackage Method (PackageProject, ISink(PackageEntry))

[image]

Sitecore 6.4.1 API
PackageGenerator..::..GeneratePackage Method (PackageProject, ISink<(Of <(<'PackageEntry>)>)>)
PackageGenerator Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void GeneratePackage(
    PackageProject solution,
    ISink<PackageEntry> writer
)
Visual Basic
Public Shared Sub GeneratePackage ( _
    solution As PackageProject, _
    writer As ISink(Of PackageEntry) _
)
Visual C++
public:
static void GeneratePackage(
    PackageProject^ solution,
    ISink<PackageEntry^>^ writer
)

Parameters

solution
Type: Sitecore.Install..::..PackageProject
The solution.
writer
Type: Sitecore.Install.Framework..::..ISink <(Of <(<' PackageEntry >)>)>
The writer. Should be initialized.

See Also

PackageGenerator Class
GeneratePackage Overload
Sitecore.Install Namespace


GeneratePackage Method (String, String, IProcessingContext)

[image]

Sitecore 6.4.1 API
PackageGenerator..::..GeneratePackage Method (String, String, IProcessingContext)
PackageGenerator Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void GeneratePackage(
    string solutionFile,
    string packageFile,
    IProcessingContext context
)
Visual Basic
Public Shared Sub GeneratePackage ( _
    solutionFile As String, _
    packageFile As String, _
    context As IProcessingContext _
)
Visual C++
public:
static void GeneratePackage(
    String^ solutionFile,
    String^ packageFile,
    IProcessingContext^ context
)

Parameters

solutionFile
Type: System..::..String
The solution file.
packageFile
Type: System..::..String
The package file.
context
Type: Sitecore.Install.Framework..::..IProcessingContext
The context.

See Also

PackageGenerator Class
GeneratePackage Overload
Sitecore.Install Namespace


NewProjectFromPackage Method

[image]

Sitecore 6.4.1 API
PackageGenerator..::..NewProjectFromPackage Method
PackageGenerator Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PackageProject NewProjectFromPackage(
    string packageFilename
)
Visual Basic
Public Shared Function NewProjectFromPackage ( _
    packageFilename As String _
) As PackageProject
Visual C++
public:
static PackageProject^ NewProjectFromPackage(
    String^ packageFilename
)

Parameters

packageFilename
Type: System..::..String
The package filename.

Return Value

The project from package.

See Also

PackageGenerator Class
Sitecore.Install Namespace


PackageProject Class

[image]

Sitecore 6.4.1 API
PackageProject Class
Members See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PackageProject : BaseSource<PackageEntry>
Visual Basic
Public Class PackageProject _
    Inherits BaseSource(Of PackageEntry)
Visual C++
public ref class PackageProject : public BaseSource<PackageEntry^>

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..BaseSource <(Of <(<' PackageEntry >)>)>
Sitecore.Install..::..PackageProject

See Also

PackageProject Members
Sitecore.Install Namespace


PackageProject Members

[image] [image]

Sitecore 6.4.1 API
PackageProject Members
PackageProject Class Constructors Methods Properties See Also Send Feedback

The PackageProject type exposes the following members.

Constructors

 | Name | Description
Public method | PackageProject | Initializes a new instance of the PackageProject class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InternalPopulate | Populates the sink with metadata and sources have been set (Overrides BaseSource<(Of <(<'T>)>)>..::..InternalPopulate(ISink<(Of <<'(T>)>>)).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Populates this sourse from the specified sink. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Converter | Gets or sets the converter. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Exclude | Gets the exclude filters. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Include | Gets the include filters. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Metadata | Gets or sets the metadata.
Public property | Name | Gets or sets the name. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | SaveProject | Gets or sets a value indicating whether project should be saved into the package.
Public property | Sources | Gets the sources.

See Also

PackageProject Class
Sitecore.Install Namespace


PackageProject Constructor

[image]

Sitecore 6.4.1 API
PackageProject Constructor
PackageProject Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PackageProject()
Visual Basic
Public Sub New
Visual C++
public:
PackageProject()

See Also

PackageProject Class
Sitecore.Install Namespace


PackageProject Methods

[image] [image]

Sitecore 6.4.1 API
PackageProject Methods
PackageProject Class See Also Send Feedback

The PackageProject type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InternalPopulate | Populates the sink with metadata and sources have been set (Overrides BaseSource<(Of <(<'T>)>)>..::..InternalPopulate(ISink<(Of <<'(T>)>>)).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Populates this sourse from the specified sink. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PackageProject Class
Sitecore.Install Namespace


InternalPopulate Method

[image]

Sitecore 6.4.1 API
PackageProject..::..InternalPopulate Method
PackageProject Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void InternalPopulate(
    ISink<PackageEntry> sink
)
Visual Basic
Protected Overrides Sub InternalPopulate ( _
    sink As ISink(Of PackageEntry) _
)
Visual C++
protected:
virtual void InternalPopulate(
    ISink<PackageEntry^>^ sink
) override

Parameters

sink
Type: Sitecore.Install.Framework..::..ISink <(Of <(<' PackageEntry >)>)>
The sink

See Also

PackageProject Class
Sitecore.Install Namespace


PackageProject Properties

[image] [image]

Sitecore 6.4.1 API
PackageProject Properties
PackageProject Class See Also Send Feedback

The PackageProject type exposes the following members.

Properties

 | Name | Description
Public property | Converter | Gets or sets the converter. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Exclude | Gets the exclude filters. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Include | Gets the include filters. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Metadata | Gets or sets the metadata.
Public property | Name | Gets or sets the name. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | SaveProject | Gets or sets a value indicating whether project should be saved into the package.
Public property | Sources | Gets the sources.

See Also

PackageProject Class
Sitecore.Install Namespace


Metadata Property

[image]

Sitecore 6.4.1 API
PackageProject..::..Metadata Property
PackageProject Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MetadataSource Metadata { get; set; }
Visual Basic
Public Property Metadata As MetadataSource
    Get
    Set
Visual C++
public:
property MetadataSource^ Metadata {
    MetadataSource^ get ();
    void set (MetadataSource^ value);
}

Field Value

The metadata.

See Also

PackageProject Class
Sitecore.Install Namespace


SaveProject Property

[image]

Sitecore 6.4.1 API
PackageProject..::..SaveProject Property
PackageProject Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool SaveProject { get; set; }
Visual Basic
Public Property SaveProject As Boolean
    Get
    Set
Visual C++
public:
property bool SaveProject {
    bool get ();
    void set (bool value);
}

Field Value

true if project should be included into the package; otherwise, false. Default is true

See Also

PackageProject Class
Sitecore.Install Namespace


PackageProject.Builder Class

[image]

Sitecore 6.4.1 API
PackageProject..::..Builder Class
PackageProject Class Members See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Builder : BaseSink<PackageEntry>
Visual Basic
Public Class Builder _
    Inherits BaseSink(Of PackageEntry)
Visual C++
public ref class Builder : public BaseSink<PackageEntry^>

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..BaseSink <(Of <(<' PackageEntry >)>)>
Sitecore.Install..::..PackageProject..::..Builder

See Also

PackageProject..::..Builder Members
Sitecore.Install Namespace


PackageProject.Builder Members

[image] [image]

Sitecore 6.4.1 API
PackageProject..::..Builder Members
PackageProject..::..Builder Class Constructors Methods Fields Properties See Also Send Feedback

Package project class

The PackageProject..::..Builder type exposes the following members.

Constructors

 | Name | Description
Public method | PackageProject..::..Builder | Initializes a new instance of the PackageProject..::..Builder class

Methods

 | Name | Description
Protected method | AssertInit | Asserts the init. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finishes the sink. (Overrides BaseSink<(Of <(<'T>)>)>..::..Finish()()()().)
Public method | Flush | Flushes the sink (Overrides BaseSink<(Of <(<'T>)>)>..::..Flush()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this instance. (Overrides BaseSink<(Of <(<'T>)>)>..::..Initialize(IProcessingContext).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put | Puts the specified entry. (Overrides BaseSink<(Of <(<'T>)>)>..::..Put(T).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _processingContext | (Inherited from BaseSink<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | Source | Gets the source.

See Also

PackageProject..::..Builder Class
Sitecore.Install Namespace


PackageProject.Builder Constructor

[image]

Sitecore 6.4.1 API
PackageProject..::..Builder Constructor
PackageProject..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Builder()
Visual Basic
Public Sub New
Visual C++
public:
Builder()

See Also

PackageProject..::..Builder Class
Sitecore.Install Namespace


PackageProject.Builder Fields

[image] [image]

Sitecore 6.4.1 API
PackageProject..::..Builder Fields
PackageProject..::..Builder Class See Also Send Feedback

The PackageProject..::..Builder type exposes the following members.

Fields

 | Name | Description
Protected field | _processingContext | (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

PackageProject..::..Builder Class
Sitecore.Install Namespace


PackageProject.Builder Methods

[image] [image]

Sitecore 6.4.1 API
PackageProject..::..Builder Methods
PackageProject..::..Builder Class See Also Send Feedback

The PackageProject..::..Builder type exposes the following members.

Methods

 | Name | Description
Protected method | AssertInit | Asserts the init. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finishes the sink. (Overrides BaseSink<(Of <(<'T>)>)>..::..Finish()()()().)
Public method | Flush | Flushes the sink (Overrides BaseSink<(Of <(<'T>)>)>..::..Flush()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this instance. (Overrides BaseSink<(Of <(<'T>)>)>..::..Initialize(IProcessingContext).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put | Puts the specified entry. (Overrides BaseSink<(Of <(<'T>)>)>..::..Put(T).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PackageProject..::..Builder Class
Sitecore.Install Namespace


Finish Method

[image]

Sitecore 6.4.1 API
PackageProject..::..Builder..::..Finish Method
PackageProject..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Finish()
Visual Basic
Public Overrides Sub Finish
Visual C++
public:
virtual void Finish() override

Implements

ISink<(Of <(<'T>)>)>..::..Finish()()()()

See Also

PackageProject..::..Builder Class
Sitecore.Install Namespace


Flush Method

[image]

Sitecore 6.4.1 API
PackageProject..::..Builder..::..Flush Method
PackageProject..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Flush()
Visual Basic
Public Overrides Sub Flush
Visual C++
public:
virtual void Flush() override

Implements

ISink<(Of <(<'T>)>)>..::..Flush()()()()

See Also

PackageProject..::..Builder Class
Sitecore.Install Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
PackageProject..::..Builder..::..Initialize Method
PackageProject..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Initialize(
    IProcessingContext context
)
Visual Basic
Public Overrides Sub Initialize ( _
    context As IProcessingContext _
)
Visual C++
public:
virtual void Initialize(
    IProcessingContext^ context
) override

Parameters

context
Type: Sitecore.Install.Framework..::..IProcessingContext
The context.

Implements

ISink<(Of <(<'T>)>)>..::..Initialize(IProcessingContext)

See Also

PackageProject..::..Builder Class
Sitecore.Install Namespace


Put Method

[image]

Sitecore 6.4.1 API
PackageProject..::..Builder..::..Put Method
PackageProject..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Put(
    PackageEntry entry
)
Visual Basic
Public Overrides Sub Put ( _
    entry As PackageEntry _
)
Visual C++
public:
virtual void Put(
    PackageEntry^ entry
) override

Parameters

entry
Type: Sitecore.Install.Framework..::..PackageEntry
The entry.

Implements

ISink<(Of <(<'T>)>)>..::..Put(T)

See Also

PackageProject..::..Builder Class
Sitecore.Install Namespace


PackageProject.Builder Properties

[image] [image]

Sitecore 6.4.1 API
PackageProject..::..Builder Properties
PackageProject..::..Builder Class See Also Send Feedback

The PackageProject..::..Builder type exposes the following members.

Properties

 | Name | Description
Public property | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | Source | Gets the source.

See Also

PackageProject..::..Builder Class
Sitecore.Install Namespace


Source Property

[image]

Sitecore 6.4.1 API
PackageProject..::..Builder..::..Source Property
PackageProject..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PackageProject Source { get; }
Visual Basic
Public ReadOnly Property Source As PackageProject
    Get
Visual C++
public:
property PackageProject^ Source {
    PackageProject^ get ();
}

Field Value

The source.

See Also

PackageProject..::..Builder Class
Sitecore.Install Namespace


PackageRegistrationFieldIDs Class

[image]

Sitecore 6.4.1 API
PackageRegistrationFieldIDs Class
Members See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class PackageRegistrationFieldIDs
Visual Basic
Public NotInheritable Class PackageRegistrationFieldIDs
Visual C++
public ref class PackageRegistrationFieldIDs abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Install..::..PackageRegistrationFieldIDs

See Also

PackageRegistrationFieldIDs Members
Sitecore.Install Namespace


PackageRegistrationFieldIDs Members

[image] [image]

Sitecore 6.4.1 API
PackageRegistrationFieldIDs Members
PackageRegistrationFieldIDs Class Fields See Also Send Feedback

The PackageRegistrationFieldIDs type exposes the following members.

Fields

Name | Description
PackageAuthor |
PackageID |
PackageName |
PackagePublisher |
PackageReadme |
PackageRevision |
PackageVersion |

See Also

PackageRegistrationFieldIDs Class
Sitecore.Install Namespace


PackageRegistrationFieldIDs Fields

[image] [image]

Sitecore 6.4.1 API
PackageRegistrationFieldIDs Fields
PackageRegistrationFieldIDs Class See Also Send Feedback

The PackageRegistrationFieldIDs type exposes the following members.

Fields

Name | Description
PackageAuthor |
PackageID |
PackageName |
PackagePublisher |
PackageReadme |
PackageRevision |
PackageVersion |

See Also

PackageRegistrationFieldIDs Class
Sitecore.Install Namespace


PackageAuthor Field

[image]

Sitecore 6.4.1 API
PackageRegistrationFieldIDs..::..PackageAuthor Field
PackageRegistrationFieldIDs Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly ID PackageAuthor
Visual Basic
Public Shared ReadOnly PackageAuthor As ID
Visual C++
public:
static initonly ID^ PackageAuthor

See Also

PackageRegistrationFieldIDs Class
Sitecore.Install Namespace


PackageName Field

[image]

Sitecore 6.4.1 API
PackageRegistrationFieldIDs..::..PackageName Field
PackageRegistrationFieldIDs Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly ID PackageName
Visual Basic
Public Shared ReadOnly PackageName As ID
Visual C++
public:
static initonly ID^ PackageName

See Also

PackageRegistrationFieldIDs Class
Sitecore.Install Namespace


PackagePublisher Field

[image]

Sitecore 6.4.1 API
PackageRegistrationFieldIDs..::..PackagePublisher Field
PackageRegistrationFieldIDs Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly ID PackagePublisher
Visual Basic
Public Shared ReadOnly PackagePublisher As ID
Visual C++
public:
static initonly ID^ PackagePublisher

See Also

PackageRegistrationFieldIDs Class
Sitecore.Install Namespace


PackageReadme Field

[image]

Sitecore 6.4.1 API
PackageRegistrationFieldIDs..::..PackageReadme Field
PackageRegistrationFieldIDs Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly ID PackageReadme
Visual Basic
Public Shared ReadOnly PackageReadme As ID
Visual C++
public:
static initonly ID^ PackageReadme

See Also

PackageRegistrationFieldIDs Class
Sitecore.Install Namespace


PackageRevision Field

[image]

Sitecore 6.4.1 API
PackageRegistrationFieldIDs..::..PackageRevision Field
PackageRegistrationFieldIDs Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly ID PackageRevision
Visual Basic
Public Shared ReadOnly PackageRevision As ID
Visual C++
public:
static initonly ID^ PackageRevision

See Also

PackageRegistrationFieldIDs Class
Sitecore.Install Namespace


PackageVersion Field

[image]

Sitecore 6.4.1 API
PackageRegistrationFieldIDs..::..PackageVersion Field
PackageRegistrationFieldIDs Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly ID PackageVersion
Visual Basic
Public Shared ReadOnly PackageVersion As ID
Visual C++
public:
static initonly ID^ PackageVersion

See Also

PackageRegistrationFieldIDs Class
Sitecore.Install Namespace


PackageUtils Class

[image]

Sitecore 6.4.1 API
PackageUtils Class
Members See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class PackageUtils
Visual Basic
Public NotInheritable Class PackageUtils
Visual C++
public ref class PackageUtils abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Install..::..PackageUtils

See Also

PackageUtils Members
Sitecore.Install Namespace


PackageUtils Members

[image] [image]

Sitecore 6.4.1 API
PackageUtils Members
PackageUtils Class Methods See Also Send Feedback

The PackageUtils type exposes the following members.

Methods

Name | Description
CleanupFileName | Generates a valid file name
GetEntryKeyPrefix | Gets the entry key prefix.
GetItemStream | Gets the item stream.
TryGetValue<(Of <<'(K, V>)>>) | Tries the get value from the dictionary.

See Also

PackageUtils Class
Sitecore.Install Namespace


PackageUtils Methods

[image] [image]

Sitecore 6.4.1 API
PackageUtils Methods
PackageUtils Class See Also Send Feedback

The PackageUtils type exposes the following members.

Methods

Name | Description
CleanupFileName | Generates a valid file name
GetEntryKeyPrefix | Gets the entry key prefix.
GetItemStream | Gets the item stream.
TryGetValue<(Of <<'(K, V>)>>) | Tries the get value from the dictionary.

See Also

PackageUtils Class
Sitecore.Install Namespace


CleanupFileName Method

[image]

Sitecore 6.4.1 API
PackageUtils..::..CleanupFileName Method
PackageUtils Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string CleanupFileName(
    string fileName
)
Visual Basic
Public Shared Function CleanupFileName ( _
    fileName As String _
) As String
Visual C++
public:
static String^ CleanupFileName(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
A file name

Return Value

[Missing <returns> documentation for "M:Sitecore.Install.PackageUtils.CleanupFileName(System.String)"]

See Also

PackageUtils Class
Sitecore.Install Namespace


GetEntryKeyPrefix Method

[image]

Sitecore 6.4.1 API
PackageUtils..::..GetEntryKeyPrefix Method
PackageUtils Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetEntryKeyPrefix(
    string key
)
Visual Basic
Public Shared Function GetEntryKeyPrefix ( _
    key As String _
) As String
Visual C++
public:
static String^ GetEntryKeyPrefix(
    String^ key
)

Parameters

key
Type: System..::..String
The key.

Return Value

The entry key prefix.

See Also

PackageUtils Class
Sitecore.Install Namespace


GetItemStream Method

[image]

Sitecore 6.4.1 API
PackageUtils..::..GetItemStream Method
PackageUtils Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Stream GetItemStream(
    Item item
)
Visual Basic
Public Shared Function GetItemStream ( _
    item As Item _
) As Stream
Visual C++
public:
static Stream^ GetItemStream(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

The item stream.

See Also

PackageUtils Class
Sitecore.Install Namespace


TryGetValue(K, V) Method

[image]

Sitecore 6.4.1 API
PackageUtils..::..TryGetValue<(Of <(<'K, V>)>)> Method
PackageUtils Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static V TryGetValue<K, V>(
    IDictionary<K, V> dictionary,
    K key
)
Visual Basic
Public Shared Function TryGetValue(Of K, V) ( _
    dictionary As IDictionary(Of K, V), _
    key As K _
) As V
Visual C++
public:
generic<typename K, typename V>
static V TryGetValue(
    IDictionary<K, V>^ dictionary,
    K key
)

Parameters

dictionary
Type: System.Collections.Generic..::..IDictionary <(Of <(<'K, V>)>)>
The dictionary.
key
Type: K
The key.

Type Parameters

K
Type of the key
V
Type of the value

Return Value

The value.

See Also

PackageUtils Class
Sitecore.Install Namespace


StreamUtil Class

[image]

Sitecore 6.4.1 API
StreamUtil Class
Members See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class StreamUtil
Visual Basic
Public NotInheritable Class StreamUtil
Visual C++
public ref class StreamUtil abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Install..::..StreamUtil

See Also

StreamUtil Members
Sitecore.Install Namespace


StreamUtil Members

[image] [image]

Sitecore 6.4.1 API
StreamUtil Members
StreamUtil Class Methods See Also Send Feedback

The StreamUtil type exposes the following members.

Methods

Name | Description
Copy | Copies one stream to another.
LoadDictionary | Loads the dictionary from the stream.
LoadString | Loads the string from the stream.
SaveDictionary(IDictionary<(Of <<'(String, String>)>>)) | Saves the dictionary to the stream.
SaveDictionary(IDictionary<(Of <<'(String, String>)>>), Stream, Boolean) | Saves the dictionary to the stream.
SaveString | Saves the string to the stream.

See Also

StreamUtil Class
Sitecore.Install Namespace


StreamUtil Methods

[image] [image]

Sitecore 6.4.1 API
StreamUtil Methods
StreamUtil Class See Also Send Feedback

The StreamUtil type exposes the following members.

Methods

Name | Description
Copy | Copies one stream to another.
LoadDictionary | Loads the dictionary from the stream.
LoadString | Loads the string from the stream.
SaveDictionary(IDictionary<(Of <<'(String, String>)>>)) | Saves the dictionary to the stream.
SaveDictionary(IDictionary<(Of <<'(String, String>)>>), Stream, Boolean) | Saves the dictionary to the stream.
SaveString | Saves the string to the stream.

See Also

StreamUtil Class
Sitecore.Install Namespace


Copy Method

[image]

Sitecore 6.4.1 API
StreamUtil..::..Copy Method
StreamUtil Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Copy(
    Stream from,
    Stream to,
    int bufferSize
)
Visual Basic
Public Shared Sub Copy ( _
    from As Stream, _
    to As Stream, _
    bufferSize As Integer _
)
Visual C++
public:
static void Copy(
    Stream^ from,
    Stream^ to,
    int bufferSize
)

Parameters

from
Type: System.IO..::..Stream
From.
to
Type: System.IO..::..Stream
To.
bufferSize
Type: System..::..Int32
Size of the buffer.

See Also

StreamUtil Class
Sitecore.Install Namespace


LoadDictionary Method

[image]

Sitecore 6.4.1 API
StreamUtil..::..LoadDictionary Method
StreamUtil Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void LoadDictionary(
    IDictionary<string, string> dictionary,
    Stream stream
)
Visual Basic
Public Shared Sub LoadDictionary ( _
    dictionary As IDictionary(Of String, String), _
    stream As Stream _
)
Visual C++
public:
static void LoadDictionary(
    IDictionary<String^, String^>^ dictionary,
    Stream^ stream
)

Parameters

dictionary
Type: System.Collections.Generic..::..IDictionary <(Of <(<' String, String >)>)>
The dictionary.
stream
Type: System.IO..::..Stream
The stream.

See Also

StreamUtil Class
Sitecore.Install Namespace


LoadString Method

[image]

Sitecore 6.4.1 API
StreamUtil..::..LoadString Method
StreamUtil Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string LoadString(
    Stream stream
)
Visual Basic
Public Shared Function LoadString ( _
    stream As Stream _
) As String
Visual C++
public:
static String^ LoadString(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::..Stream
The stream.

Return Value

The string.

See Also

StreamUtil Class
Sitecore.Install Namespace


SaveDictionary Method

[image] [image]

Sitecore 6.4.1 API
StreamUtil..::..SaveDictionary Method
StreamUtil Class See Also Send Feedback

Overload List

Name | Description
SaveDictionary(IDictionary<(Of <<'(String, String>)>>)) | Saves the dictionary to the stream.
SaveDictionary(IDictionary<(Of <<'(String, String>)>>), Stream, Boolean) | Saves the dictionary to the stream.

See Also

StreamUtil Class
StreamUtil Members
Sitecore.Install Namespace


SaveDictionary Method (IDictionary(String, String))

[image]

Sitecore 6.4.1 API
StreamUtil..::..SaveDictionary Method (IDictionary<(Of <(<'String, String>)>)>)
StreamUtil Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static MemoryStream SaveDictionary(
    IDictionary<string, string> dictionary
)
Visual Basic
Public Shared Function SaveDictionary ( _
    dictionary As IDictionary(Of String, String) _
) As MemoryStream
Visual C++
public:
static MemoryStream^ SaveDictionary(
    IDictionary<String^, String^>^ dictionary
)

Parameters

dictionary
Type: System.Collections.Generic..::..IDictionary <(Of <(<' String, String >)>)>
The dictionary.

Return Value

[Missing <returns> documentation for "M:Sitecore.Install.StreamUtil.SaveDictionary(System.Collections.Generic.IDictionary{System.String,System.String})"]

See Also

StreamUtil Class
SaveDictionary Overload
Sitecore.Install Namespace


SaveDictionary Method (IDictionary(String, String), Stream, Boolean)

[image]

Sitecore 6.4.1 API
StreamUtil..::..SaveDictionary Method (IDictionary<(Of <(<'String, String>)>)>, Stream, Boolean)
StreamUtil Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void SaveDictionary(
    IDictionary<string, string> dictionary,
    Stream stream,
    bool closeStream
)
Visual Basic
Public Shared Sub SaveDictionary ( _
    dictionary As IDictionary(Of String, String), _
    stream As Stream, _
    closeStream As Boolean _
)
Visual C++
public:
static void SaveDictionary(
    IDictionary<String^, String^>^ dictionary,
    Stream^ stream,
    bool closeStream
)

Parameters

dictionary
Type: System.Collections.Generic..::..IDictionary <(Of <(<' String, String >)>)>
The dictionary.
stream
Type: System.IO..::..Stream
The stream.
closeStream
Type: System..::..Boolean
if set to true closes the stream.

See Also

StreamUtil Class
SaveDictionary Overload
Sitecore.Install Namespace


SaveString Method

[image]

Sitecore 6.4.1 API
StreamUtil..::..SaveString Method
StreamUtil Class See Also Send Feedback

Namespace: Sitecore.Install
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Stream SaveString(
    string s
)
Visual Basic
Public Shared Function SaveString ( _
    s As String _
) As Stream
Visual C++
public:
static Stream^ SaveString(
    String^ s
)

Parameters

s
Type: System..::..String
The string.

Return Value

The string.

See Also

StreamUtil Class
Sitecore.Install Namespace


Sitecore.Install.BlobData Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Install.BlobData Namespace
Send Feedback

Classes

 | Class | Description
Public class | BlobEntryData | BlobEntryData class
Public class | BlobInstaller | Media installer
Public class | BlobInstallerContext | BlobInstallerContext class
Public class | BlobLink | Link to a blob
Public class | FileReference | Represents a reference to a file from media item
Public class | MediaStreamEntryData | MediaStreamEntryData class
Public class | MediaStreamLink | MediaStreamLink class


BlobEntryData Class

[image]

Sitecore 6.4.1 API
BlobEntryData Class
Members See Also Send Feedback

Namespace: Sitecore.Install.BlobData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class BlobEntryData : IEntryData
Visual Basic
Public Class BlobEntryData _
    Implements IEntryData
Visual C++
public ref class BlobEntryData : IEntryData

Inheritance Hierarchy

System..::..Object
Sitecore.Install.BlobData..::..BlobEntryData

See Also

BlobEntryData Members
Sitecore.Install.BlobData Namespace


BlobEntryData Members

[image] [image]

Sitecore 6.4.1 API
BlobEntryData Members
BlobEntryData Class Constructors Methods Properties See Also Send Feedback

The BlobEntryData type exposes the following members.

Constructors

 | Name | Description
Public method | BlobEntryData | Initializes a new instance of the BlobEntryData class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStream | Gets the stream holder.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Key | Gets the key.

See Also

BlobEntryData Class
Sitecore.Install.BlobData Namespace


BlobEntryData Constructor

[image]

Sitecore 6.4.1 API
BlobEntryData Constructor
BlobEntryData Class See Also Send Feedback

Namespace: Sitecore.Install.BlobData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BlobEntryData(
    BlobLink blobLink
)
Visual Basic
Public Sub New ( _
    blobLink As BlobLink _
)
Visual C++
public:
BlobEntryData(
    BlobLink^ blobLink
)

Parameters

blobLink
Type: Sitecore.Install.BlobData..::..BlobLink
The BLOB link.

See Also

BlobEntryData Class
Sitecore.Install.BlobData Namespace


GetStream Method

[image]

Sitecore 6.4.1 API
BlobEntryData..::..GetStream Method
BlobEntryData Class See Also Send Feedback

Namespace: Sitecore.Install.BlobData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IStreamHolder GetStream()
Visual Basic
Public Function GetStream As IStreamHolder
Visual C++
public:
virtual IStreamHolder^ GetStream() sealed

Return Value

The stream holder.

Implements

IEntryData..::..GetStream()()()()

See Also

BlobEntryData Class
Sitecore.Install.BlobData Namespace


BlobEntryData Properties

[image] [image]

Sitecore 6.4.1 API
BlobEntryData Properties
BlobEntryData Class See Also Send Feedback

The BlobEntryData type exposes the following members.

Properties

 | Name | Description
Public property | Key | Gets the key.

See Also

BlobEntryData Class
Sitecore.Install.BlobData Namespace


Key Property

[image]

Sitecore 6.4.1 API
BlobEntryData..::..Key Property
BlobEntryData Class See Also Send Feedback

Namespace: Sitecore.Install.BlobData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Key { get; }
Visual Basic
Public ReadOnly Property Key As String
    Get
Visual C++
public:
virtual property String^ Key {
    String^ get () sealed;
}

Field Value

The key.

Implements

IEntryData..::..Key

See Also

BlobEntryData Class
Sitecore.Install.BlobData Namespace


BlobInstaller Class

[image]

Sitecore 6.4.1 API
BlobInstaller Class
Members See Also Send Feedback

Namespace: Sitecore.Install.BlobData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class BlobInstaller : AdvancedBaseSink<PackageEntry, BlobInstallerContext>
Visual Basic
Public Class BlobInstaller _
    Inherits AdvancedBaseSink(Of PackageEntry, BlobInstallerContext)
Visual C++
public ref class BlobInstaller : public AdvancedBaseSink<PackageEntry^, BlobInstallerContext^>

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..BaseSink <(Of <(<' T >)>)>
Sitecore.Install.Framework..::..AdvancedBaseSink <(Of <(<' PackageEntry, BlobInstallerContext >)>)>
Sitecore.Install.BlobData..::..BlobInstaller

See Also

BlobInstaller Members
Sitecore.Install.BlobData Namespace


BlobInstaller Members

[image] [image]

Sitecore 6.4.1 API
BlobInstaller Members
BlobInstaller Class Constructors Methods Fields Properties See Also Send Feedback

The BlobInstaller type exposes the following members.

Constructors

 | Name | Description
Public method | BlobInstaller | Initializes a new instance of the BlobInstaller class.

Methods

 | Name | Description
Protected method | AssertInit | Asserts the init. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Protected method | CreateContext | Creates the context. (Overrides AdvancedBaseSink<(Of <(<'T, ContextType>)>)>..::..CreateContext()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finishes the sink. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Flush | Flushes the sink (Inherited from BaseSink<(Of <(<'T>)>)>.)
 | FlushData | Flushes the data.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this instance. (Inherited from AdvancedBaseSink<(Of <(<'T, ContextType>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put(T) | Puts the specified entry. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Put(PackageEntry) | Installs blob from the entry.
Protected method | SetupContext | Setups the context. (Inherited from AdvancedBaseSink<(Of <(<'T, ContextType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateBlobData | In Sitecore 5.3 attachment field contains blob value. In Sitecore 6 this field contains guid which is a referense for blob in related table. This method does a convertion for such values. Also the method registers references to blob values. In order not to install unused blobs.

Fields

 | Name | Description
Protected field | _processingContext | (Inherited from BaseSink<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Context | Gets the context. (Inherited from AdvancedBaseSink<(Of <(<'T, ContextType>)>)>.)
Public property | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

BlobInstaller Class
Sitecore.Install.BlobData Namespace


BlobInstaller Constructor

[image]

Sitecore 6.4.1 API
BlobInstaller Constructor
BlobInstaller Class See Also Send Feedback

Namespace: Sitecore.Install.BlobData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BlobInstaller(
    IProcessingContext context
)
Visual Basic
Public Sub New ( _
    context As IProcessingContext _
)
Visual C++
public:
BlobInstaller(
    IProcessingContext^ context
)

Parameters

context
Type: Sitecore.Install.Framework..::..IProcessingContext
The context.

See Also

BlobInstaller Class
Sitecore.Install.BlobData Namespace


BlobInstaller Fields

[image] [image]

Sitecore 6.4.1 API
BlobInstaller Fields
BlobInstaller Class See Also Send Feedback

The BlobInstaller type exposes the following members.

Fields

 | Name | Description
Protected field | _processingContext | (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

BlobInstaller Class
Sitecore.Install.BlobData Namespace


BlobInstaller Methods

[image] [image]

Sitecore 6.4.1 API
BlobInstaller Methods
BlobInstaller Class See Also Send Feedback

The BlobInstaller type exposes the following members.

Methods

 | Name | Description
Protected method | AssertInit | Asserts the init. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Protected method | CreateContext | Creates the context. (Overrides AdvancedBaseSink<(Of <(<'T, ContextType>)>)>..::..CreateContext()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finishes the sink. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Flush | Flushes the sink (Inherited from BaseSink<(Of <(<'T>)>)>.)
 | FlushData | Flushes the data.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this instance. (Inherited from AdvancedBaseSink<(Of <(<'T, ContextType>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put(T) | Puts the specified entry. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Put(PackageEntry) | Installs blob from the entry.
Protected method | SetupContext | Setups the context. (Inherited from AdvancedBaseSink<(Of <(<'T, ContextType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateBlobData | In Sitecore 5.3 attachment field contains blob value. In Sitecore 6 this field contains guid which is a referense for blob in related table. This method does a convertion for such values. Also the method registers references to blob values. In order not to install unused blobs.

See Also

BlobInstaller Class
Sitecore.Install.BlobData Namespace


CreateContext Method

[image]

Sitecore 6.4.1 API
BlobInstaller..::..CreateContext Method
BlobInstaller Class See Also Send Feedback

Namespace: Sitecore.Install.BlobData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override BlobInstallerContext CreateContext()
Visual Basic
Protected Overrides Function CreateContext As BlobInstallerContext
Visual C++
protected:
virtual BlobInstallerContext^ CreateContext() override

Return Value

The context.

See Also

BlobInstaller Class
Sitecore.Install.BlobData Namespace


FlushData Method

[image]

Sitecore 6.4.1 API
BlobInstaller..::..FlushData Method
BlobInstaller Class See Also Send Feedback

Namespace: Sitecore.Install.BlobData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void FlushData(
    IProcessingContext processingContext
)
Visual Basic
Public Shared Sub FlushData ( _
    processingContext As IProcessingContext _
)
Visual C++
public:
static void FlushData(
    IProcessingContext^ processingContext
)

Parameters

processingContext
Type: Sitecore.Install.Framework..::..IProcessingContext
The context.

See Also

BlobInstaller Class
Sitecore.Install.BlobData Namespace


Put Method

[image] [image]

Sitecore 6.4.1 API
BlobInstaller..::..Put Method
BlobInstaller Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Put(T) | Puts the specified entry. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Put(PackageEntry) | Installs blob from the entry.

See Also

BlobInstaller Class
BlobInstaller Members
Sitecore.Install.BlobData Namespace


Put Method (PackageEntry)

[image]

Sitecore 6.4.1 API
BlobInstaller..::..Put Method (PackageEntry)
BlobInstaller Class See Also Send Feedback

Namespace: Sitecore.Install.BlobData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Put(
    PackageEntry entry
)
Visual Basic
Public Overridable Sub Put ( _
    entry As PackageEntry _
)
Visual C++
public:
virtual void Put(
    PackageEntry^ entry
)

Parameters

entry
Type: Sitecore.Install.Framework..::..PackageEntry
The entry.

See Also

BlobInstaller Class
Put Overload
Sitecore.Install.BlobData Namespace


UpdateBlobData Method

[image]

Sitecore 6.4.1 API
BlobInstaller..::..UpdateBlobData Method
BlobInstaller Class See Also Send Feedback

Namespace: Sitecore.Install.BlobData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void UpdateBlobData(
    Item item,
    IProcessingContext context
)
Visual Basic
Public Shared Sub UpdateBlobData ( _
    item As Item, _
    context As IProcessingContext _
)
Visual C++
public:
static void UpdateBlobData(
    Item^ item,
    IProcessingContext^ context
)

Parameters

item
Type: Sitecore.Data.Items..::..Item

[Missing <param name="item"/> documentation for "M:Sitecore.Install.BlobData.BlobInstaller.UpdateBlobData(Sitecore.Data.Items.Item,Sitecore.Install.Framework.IProcessingContext)"]

context
Type: Sitecore.Install.Framework..::..IProcessingContext

[Missing <param name="context"/> documentation for "M:Sitecore.Install.BlobData.BlobInstaller.UpdateBlobData(Sitecore.Data.Items.Item,Sitecore.Install.Framework.IProcessingContext)"]

See Also

BlobInstaller Class
Sitecore.Install.BlobData Namespace


BlobInstaller Properties

[image] [image]

Sitecore 6.4.1 API
BlobInstaller Properties
BlobInstaller Class See Also Send Feedback

The BlobInstaller type exposes the following members.

Properties

 | Name | Description
Public property | Context | Gets the context. (Inherited from AdvancedBaseSink<(Of <(<'T, ContextType>)>)>.)
Public property | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

BlobInstaller Class
Sitecore.Install.BlobData Namespace


BlobInstallerContext Class

[image]

Sitecore 6.4.1 API
BlobInstallerContext Class
Members See Also Send Feedback

Namespace: Sitecore.Install.BlobData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public sealed class BlobInstallerContext
Visual Basic
Public NotInheritable Class BlobInstallerContext
Visual C++
public ref class BlobInstallerContext sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Install.BlobData..::..BlobInstallerContext

See Also

BlobInstallerContext Members
Sitecore.Install.BlobData Namespace


BlobInstallerContext Members

[image] [image]

Sitecore 6.4.1 API
BlobInstallerContext Members
BlobInstallerContext Class Constructors Methods Fields See Also Send Feedback

The BlobInstallerContext type exposes the following members.

Constructors

 | Name | Description
Public method | BlobInstallerContext | Initializes a new instance of the BlobInstallerContext class

Methods

 | Name | Description
Public method | Clear | Clears this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | Entries | Entries to be installed
Public field | FileReferences | Links to files, from the items that have been installed
Public field | ImageCache | Contains list of MD5 stamps for installed images and its guid
Public field | References | Links to blobs, from the items that have been installed

See Also

BlobInstallerContext Class
Sitecore.Install.BlobData Namespace


BlobInstallerContext Constructor

[image]

Sitecore 6.4.1 API
BlobInstallerContext Constructor
BlobInstallerContext Class See Also Send Feedback

Namespace: Sitecore.Install.BlobData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BlobInstallerContext()
Visual Basic
Public Sub New
Visual C++
public:
BlobInstallerContext()

See Also

BlobInstallerContext Class
Sitecore.Install.BlobData Namespace


Entries Field

[image]

Sitecore 6.4.1 API
BlobInstallerContext..::..Entries Field
BlobInstallerContext Class See Also Send Feedback

Namespace: Sitecore.Install.BlobData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public readonly IList<PackageEntry> Entries
Visual Basic
Public ReadOnly Entries As IList(Of PackageEntry)
Visual C++
public:
initonly IList<PackageEntry^>^ Entries

See Also

BlobInstallerContext Class
Sitecore.Install.BlobData Namespace


FileReferences Field

[image]

Sitecore 6.4.1 API
BlobInstallerContext..::..FileReferences Field
BlobInstallerContext Class See Also Send Feedback

Namespace: Sitecore.Install.BlobData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public readonly IList<FileReference> FileReferences
Visual Basic
Public ReadOnly FileReferences As IList(Of FileReference)
Visual C++
public:
initonly IList<FileReference^>^ FileReferences

See Also

BlobInstallerContext Class
Sitecore.Install.BlobData Namespace


ImageCache Field

[image]

Sitecore 6.4.1 API
BlobInstallerContext..::..ImageCache Field
BlobInstallerContext Class See Also Send Feedback

Namespace: Sitecore.Install.BlobData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public readonly IList<Pair<byte[], Guid>> ImageCache
Visual Basic
Public ReadOnly ImageCache As IList(Of Pair(Of Byte(), Guid))
Visual C++
public:
initonly IList<Pair<array<unsigned char>^, Guid>^>^ ImageCache

See Also

BlobInstallerContext Class
Sitecore.Install.BlobData Namespace


References Field

[image]

Sitecore 6.4.1 API
BlobInstallerContext..::..References Field
BlobInstallerContext Class See Also Send Feedback

Namespace: Sitecore.Install.BlobData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public readonly IList<BlobLink> References
Visual Basic
Public ReadOnly References As IList(Of BlobLink)
Visual C++
public:
initonly IList<BlobLink^>^ References

See Also

BlobInstallerContext Class
Sitecore.Install.BlobData Namespace


BlobInstallerContext Methods

[image] [image]

Sitecore 6.4.1 API
BlobInstallerContext Methods
BlobInstallerContext Class See Also Send Feedback

The BlobInstallerContext type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Clears this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BlobInstallerContext Class
Sitecore.Install.BlobData Namespace


Clear Method

[image]

Sitecore 6.4.1 API
BlobInstallerContext..::..Clear Method
BlobInstallerContext Class See Also Send Feedback

Namespace: Sitecore.Install.BlobData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

BlobInstallerContext Class
Sitecore.Install.BlobData Namespace


BlobLink Class

[image]

Sitecore 6.4.1 API
BlobLink Class
Members See Also Send Feedback

Namespace: Sitecore.Install.BlobData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class BlobLink
Visual Basic
Public Class BlobLink
Visual C++
public ref class BlobLink

Inheritance Hierarchy

System..::..Object
Sitecore.Install.BlobData..::..BlobLink

See Also

BlobLink Members
Sitecore.Install.BlobData Namespace


BlobLink Members

[image] [image]

Sitecore 6.4.1 API
BlobLink Members
BlobLink Class Constructors Methods Properties See Also Send Feedback

The BlobLink type exposes the following members.

Constructors

 | Name | Description
Public method | BlobLink(Field) | Initializes a new instance of the BlobLink class.
Public method | BlobLink(String, Guid) | Initializes a new instance of the BlobLink class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DatabaseName | Gets the name of the database.
Public property | Guid | Gets the GUID.

See Also

BlobLink Class
Sitecore.Install.BlobData Namespace


BlobLink Constructor

[image] [image]

Sitecore 6.4.1 API
BlobLink Constructor
BlobLink Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BlobLink(Field) | Initializes a new instance of the BlobLink class.
Public method | BlobLink(String, Guid) | Initializes a new instance of the BlobLink class.

See Also

BlobLink Class
BlobLink Members
Sitecore.Install.BlobData Namespace


BlobLink Constructor (Field)

[image]

Sitecore 6.4.1 API
BlobLink Constructor (Field)
BlobLink Class See Also Send Feedback

Namespace: Sitecore.Install.BlobData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BlobLink(
    Field field
)
Visual Basic
Public Sub New ( _
    field As Field _
)
Visual C++
public:
BlobLink(
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field.

See Also

BlobLink Class
BlobLink Overload
Sitecore.Install.BlobData Namespace


BlobLink Constructor (String, Guid)

[image]

Sitecore 6.4.1 API
BlobLink Constructor (String, Guid)
BlobLink Class See Also Send Feedback

Namespace: Sitecore.Install.BlobData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BlobLink(
    string databaseName,
    Guid guid
)
Visual Basic
Public Sub New ( _
    databaseName As String, _
    guid As Guid _
)
Visual C++
public:
BlobLink(
    String^ databaseName,
    Guid guid
)

Parameters

databaseName
Type: System..::..String
Name of the database.
guid
Type: System..::..Guid
The blob GUID.

See Also

BlobLink Class
BlobLink Overload
Sitecore.Install.BlobData Namespace


BlobLink Methods

[image] [image]

Sitecore 6.4.1 API
BlobLink Methods
BlobLink Class See Also Send Feedback

The BlobLink type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BlobLink Class
Sitecore.Install.BlobData Namespace


BlobLink Properties

[image] [image]

Sitecore 6.4.1 API
BlobLink Properties
BlobLink Class See Also Send Feedback

The BlobLink type exposes the following members.

Properties

 | Name | Description
Public property | DatabaseName | Gets the name of the database.
Public property | Guid | Gets the GUID.

See Also

BlobLink Class
Sitecore.Install.BlobData Namespace


DatabaseName Property

[image]

Sitecore 6.4.1 API
BlobLink..::..DatabaseName Property
BlobLink Class See Also Send Feedback

Namespace: Sitecore.Install.BlobData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string DatabaseName { get; }
Visual Basic
Public ReadOnly Property DatabaseName As String
    Get
Visual C++
public:
property String^ DatabaseName {
    String^ get ();
}

Field Value

The name of the database.

See Also

BlobLink Class
Sitecore.Install.BlobData Namespace


Guid Property

[image]

Sitecore 6.4.1 API
BlobLink..::..Guid Property
BlobLink Class See Also Send Feedback

Namespace: Sitecore.Install.BlobData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Guid Guid { get; }
Visual Basic
Public ReadOnly Property Guid As Guid
    Get
Visual C++
public:
property Guid Guid {
    Guid get ();
}

Field Value

The blob GUID.

See Also

BlobLink Class
Sitecore.Install.BlobData Namespace


FileReference Class

[image]

Sitecore 6.4.1 API
FileReference Class
Members See Also Send Feedback

Namespace: Sitecore.Install.BlobData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FileReference
Visual Basic
Public Class FileReference
Visual C++
public ref class FileReference

Inheritance Hierarchy

System..::..Object
Sitecore.Install.BlobData..::..FileReference

See Also

FileReference Members
Sitecore.Install.BlobData Namespace


FileReference Members

[image] [image]

Sitecore 6.4.1 API
FileReference Members
FileReference Class Constructors Methods Fields See Also Send Feedback

The FileReference type exposes the following members.

Constructors

 | Name | Description
Public method | FileReference | Initializes a new instance of the FileReference class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | FieldID |
Public field | FileName |
Public field | ItemReference |

See Also

FileReference Class
Sitecore.Install.BlobData Namespace


FileReference Constructor

[image]

Sitecore 6.4.1 API
FileReference Constructor
FileReference Class See Also Send Feedback

Namespace: Sitecore.Install.BlobData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FileReference(
    ItemReference itemReference,
    ID fieldId,
    string fileName
)
Visual Basic
Public Sub New ( _
    itemReference As ItemReference, _
    fieldId As ID, _
    fileName As String _
)
Visual C++
public:
FileReference(
    ItemReference^ itemReference,
    ID^ fieldId,
    String^ fileName
)

Parameters

itemReference
Type: Sitecore.Install.Items..::..ItemReference
The item reference.
fieldId
Type: Sitecore.Data..::..ID
The field id.
fileName
Type: System..::..String
Name of the file.

See Also

FileReference Class
Sitecore.Install.BlobData Namespace


FileReference Fields

[image] [image]

Sitecore 6.4.1 API
FileReference Fields
FileReference Class See Also Send Feedback

The FileReference type exposes the following members.

Fields

 | Name | Description
Public field | FieldID |
Public field | FileName |
Public field | ItemReference |

See Also

FileReference Class
Sitecore.Install.BlobData Namespace


FieldID Field

[image]

Sitecore 6.4.1 API
FileReference..::..FieldID Field
FileReference Class See Also Send Feedback

Namespace: Sitecore.Install.BlobData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public readonly ID FieldID
Visual Basic
Public ReadOnly FieldID As ID
Visual C++
public:
initonly ID^ FieldID

See Also

FileReference Class
Sitecore.Install.BlobData Namespace


ItemReference Field

[image]

Sitecore 6.4.1 API
FileReference..::..ItemReference Field
FileReference Class See Also Send Feedback

Namespace: Sitecore.Install.BlobData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public readonly ItemReference ItemReference
Visual Basic
Public ReadOnly ItemReference As ItemReference
Visual C++
public:
initonly ItemReference^ ItemReference

See Also

FileReference Class
Sitecore.Install.BlobData Namespace


FileReference Methods

[image] [image]

Sitecore 6.4.1 API
FileReference Methods
FileReference Class See Also Send Feedback

The FileReference type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileReference Class
Sitecore.Install.BlobData Namespace


MediaStreamEntryData Class

[image]

Sitecore 6.4.1 API
MediaStreamEntryData Class
Members See Also Send Feedback

Namespace: Sitecore.Install.BlobData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class MediaStreamEntryData : IEntryData
Visual Basic
Public Class MediaStreamEntryData _
    Implements IEntryData
Visual C++
public ref class MediaStreamEntryData : IEntryData

Inheritance Hierarchy

System..::..Object
Sitecore.Install.BlobData..::..MediaStreamEntryData

See Also

MediaStreamEntryData Members
Sitecore.Install.BlobData Namespace


MediaStreamEntryData Constructor

[image]

Sitecore 6.4.1 API
MediaStreamEntryData Constructor
MediaStreamEntryData Class See Also Send Feedback

Namespace: Sitecore.Install.BlobData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MediaStreamEntryData(
    MediaStreamLink link
)
Visual Basic
Public Sub New ( _
    link As MediaStreamLink _
)
Visual C++
public:
MediaStreamEntryData(
    MediaStreamLink^ link
)

Parameters

link
Type: Sitecore.Install.BlobData..::..MediaStreamLink
The link.

See Also

MediaStreamEntryData Class
Sitecore.Install.BlobData Namespace


MediaStreamEntryData Methods

[image] [image]

Sitecore 6.4.1 API
MediaStreamEntryData Methods
MediaStreamEntryData Class See Also Send Feedback

The MediaStreamEntryData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStream | Gets the stream holder.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MediaStreamEntryData Class
Sitecore.Install.BlobData Namespace


GetStream Method

[image]

Sitecore 6.4.1 API
MediaStreamEntryData..::..GetStream Method
MediaStreamEntryData Class See Also Send Feedback

Namespace: Sitecore.Install.BlobData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IStreamHolder GetStream()
Visual Basic
Public Function GetStream As IStreamHolder
Visual C++
public:
virtual IStreamHolder^ GetStream() sealed

Return Value

The stream holder.

Implements

IEntryData..::..GetStream()()()()

See Also

MediaStreamEntryData Class
Sitecore.Install.BlobData Namespace


MediaStreamEntryData Properties

[image] [image]

Sitecore 6.4.1 API
MediaStreamEntryData Properties
MediaStreamEntryData Class See Also Send Feedback

The MediaStreamEntryData type exposes the following members.

Properties

 | Name | Description
Public property | Key | Gets the key.

See Also

MediaStreamEntryData Class
Sitecore.Install.BlobData Namespace


Key Property

[image]

Sitecore 6.4.1 API
MediaStreamEntryData..::..Key Property
MediaStreamEntryData Class See Also Send Feedback

Namespace: Sitecore.Install.BlobData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Key { get; }
Visual Basic
Public ReadOnly Property Key As String
    Get
Visual C++
public:
virtual property String^ Key {
    String^ get () sealed;
}

Field Value

The key.

Implements

IEntryData..::..Key

See Also

MediaStreamEntryData Class
Sitecore.Install.BlobData Namespace


MediaStreamLink Class

[image]

Sitecore 6.4.1 API
MediaStreamLink Class
Members See Also Send Feedback

Namespace: Sitecore.Install.BlobData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class MediaStreamLink
Visual Basic
Public Class MediaStreamLink
Visual C++
public ref class MediaStreamLink

Inheritance Hierarchy

System..::..Object
Sitecore.Install.BlobData..::..MediaStreamLink

See Also

MediaStreamLink Members
Sitecore.Install.BlobData Namespace


MediaStreamLink Members

[image] [image]

Sitecore 6.4.1 API
MediaStreamLink Members
MediaStreamLink Class Constructors Methods Properties See Also Send Feedback

The MediaStreamLink type exposes the following members.

Constructors

 | Name | Description
Public method | MediaStreamLink | Initializes a new instance of the MediaStreamLink class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Id | Gets the id.
Public property | Media | Gets the media.

See Also

MediaStreamLink Class
Sitecore.Install.BlobData Namespace


MediaStreamLink Constructor

[image]

Sitecore 6.4.1 API
MediaStreamLink Constructor
MediaStreamLink Class See Also Send Feedback

Namespace: Sitecore.Install.BlobData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MediaStreamLink(
    Media media,
    ID id
)
Visual Basic
Public Sub New ( _
    media As Media, _
    id As ID _
)
Visual C++
public:
MediaStreamLink(
    Media^ media,
    ID^ id
)

Parameters

media
Type: Sitecore.Resources.Media..::..Media
The media.
id
Type: Sitecore.Data..::..ID
The id.

See Also

MediaStreamLink Class
Sitecore.Install.BlobData Namespace


MediaStreamLink Methods

[image] [image]

Sitecore 6.4.1 API
MediaStreamLink Methods
MediaStreamLink Class See Also Send Feedback

The MediaStreamLink type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MediaStreamLink Class
Sitecore.Install.BlobData Namespace


Id Property

[image]

Sitecore 6.4.1 API
MediaStreamLink..::..Id Property
MediaStreamLink Class See Also Send Feedback

Namespace: Sitecore.Install.BlobData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID Id { get; }
Visual Basic
Public ReadOnly Property Id As ID
    Get
Visual C++
public:
property ID^ Id {
    ID^ get ();
}

Field Value

The id.

See Also

MediaStreamLink Class
Sitecore.Install.BlobData Namespace


Media Property

[image]

Sitecore 6.4.1 API
MediaStreamLink..::..Media Property
MediaStreamLink Class See Also Send Feedback

Namespace: Sitecore.Install.BlobData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Media Media { get; }
Visual Basic
Public ReadOnly Property Media As Media
    Get
Visual C++
public:
property Media^ Media {
    Media^ get ();
}

Field Value

The media.

See Also

MediaStreamLink Class
Sitecore.Install.BlobData Namespace


Sitecore.Install.Configuration Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Install.Configuration Namespace
Send Feedback

Classes

 | Class | Description
Public class | InstallerConfigurationTransform | Processor that adds a behaviour options to a package entry
Public class | InstallerObjectFactory | Installer object factory


InstallerConfigurationTransform Class

[image]

Sitecore 6.4.1 API
InstallerConfigurationTransform Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class InstallerConfigurationTransform : IProcessor<PackageEntry>
Visual Basic
Public Class InstallerConfigurationTransform _
    Implements IProcessor(Of PackageEntry)
Visual C++
public ref class InstallerConfigurationTransform : IProcessor<PackageEntry^>

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Configuration..::..InstallerConfigurationTransform

See Also

InstallerConfigurationTransform Members
Sitecore.Install.Configuration Namespace


InstallerConfigurationTransform Constructor

[image] [image]

Sitecore 6.4.1 API
InstallerConfigurationTransform Constructor
InstallerConfigurationTransform Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InstallerConfigurationTransform()()()() | Initializes a new instance of the InstallerConfigurationTransform class.
Public method | InstallerConfigurationTransform(BehaviourOptions) | Initializes a new instance of the InstallerConfigurationTransform class.

See Also

InstallerConfigurationTransform Class
InstallerConfigurationTransform Members
Sitecore.Install.Configuration Namespace


InstallerConfigurationTransform Constructor

[image]

Sitecore 6.4.1 API
InstallerConfigurationTransform Constructor
InstallerConfigurationTransform Class See Also Send Feedback

Namespace: Sitecore.Install.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public InstallerConfigurationTransform()
Visual Basic
Public Sub New
Visual C++
public:
InstallerConfigurationTransform()

See Also

InstallerConfigurationTransform Class
InstallerConfigurationTransform Overload
Sitecore.Install.Configuration Namespace


InstallerConfigurationTransform Constructor (BehaviourOptions)

[image]

Sitecore 6.4.1 API
InstallerConfigurationTransform Constructor (BehaviourOptions)
InstallerConfigurationTransform Class See Also Send Feedback

Namespace: Sitecore.Install.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public InstallerConfigurationTransform(
    BehaviourOptions options
)
Visual Basic
Public Sub New ( _
    options As BehaviourOptions _
)
Visual C++
public:
InstallerConfigurationTransform(
    BehaviourOptions^ options
)

Parameters

options
Type: Sitecore.Install.Utils..::..BehaviourOptions
The options.

See Also

InstallerConfigurationTransform Class
InstallerConfigurationTransform Overload
Sitecore.Install.Configuration Namespace


InstallerConfigurationTransform Methods

[image] [image]

Sitecore 6.4.1 API
InstallerConfigurationTransform Methods
InstallerConfigurationTransform Class See Also Send Feedback

The InstallerConfigurationTransform type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InstallerConfigurationTransform Class
Sitecore.Install.Configuration Namespace


Process Method

[image]

Sitecore 6.4.1 API
InstallerConfigurationTransform..::..Process Method
InstallerConfigurationTransform Class See Also Send Feedback

Namespace: Sitecore.Install.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    PackageEntry entry,
    IProcessingContext context
)
Visual Basic
Public Sub Process ( _
    entry As PackageEntry, _
    context As IProcessingContext _
)
Visual C++
public:
virtual void Process(
    PackageEntry^ entry,
    IProcessingContext^ context
) sealed

Parameters

entry
Type: Sitecore.Install.Framework..::..PackageEntry
The entry.
context
Type: Sitecore.Install.Framework..::..IProcessingContext
The processing context.

Implements

IProcessor<(Of <(<'T>)>)>..::..Process(T, IProcessingContext)

See Also

InstallerConfigurationTransform Class
Sitecore.Install.Configuration Namespace


InstallerConfigurationTransform Properties

[image] [image]

Sitecore 6.4.1 API
InstallerConfigurationTransform Properties
InstallerConfigurationTransform Class See Also Send Feedback

The InstallerConfigurationTransform type exposes the following members.

Properties

 | Name | Description
Public property | Options | Gets or sets the options.

See Also

InstallerConfigurationTransform Class
Sitecore.Install.Configuration Namespace


Options Property

[image]

Sitecore 6.4.1 API
InstallerConfigurationTransform..::..Options Property
InstallerConfigurationTransform Class See Also Send Feedback

Namespace: Sitecore.Install.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BehaviourOptions Options { get; set; }
Visual Basic
Public Property Options As BehaviourOptions
    Get
    Set
Visual C++
public:
property BehaviourOptions^ Options {
    BehaviourOptions^ get ();
    void set (BehaviourOptions^ value);
}

Field Value

The options.

See Also

InstallerConfigurationTransform Class
Sitecore.Install.Configuration Namespace


InstallerObjectFactory Class

[image]

Sitecore 6.4.1 API
InstallerObjectFactory Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class InstallerObjectFactory : IObjectFactory
Visual Basic
Public Class InstallerObjectFactory _
    Implements IObjectFactory
Visual C++
public ref class InstallerObjectFactory : IObjectFactory

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Configuration..::..InstallerObjectFactory

See Also

InstallerObjectFactory Members
Sitecore.Install.Configuration Namespace


InstallerObjectFactory Members

[image] [image]

Sitecore 6.4.1 API
InstallerObjectFactory Members
InstallerObjectFactory Class Methods Properties See Also Send Feedback

The InstallerObjectFactory type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttribute | Gets the attribute.
Public method | GetAttributes | Gets the attributes.
Public method | GetElementName | Gets the name of the element by an instance
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetType(String) | Gets the type by an element.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Instance | Gets the instance.

See Also

InstallerObjectFactory Class
Sitecore.Install.Configuration Namespace


InstallerObjectFactory Methods

[image] [image]

Sitecore 6.4.1 API
InstallerObjectFactory Methods
InstallerObjectFactory Class See Also Send Feedback

The InstallerObjectFactory type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttribute | Gets the attribute.
Public method | GetAttributes | Gets the attributes.
Public method | GetElementName | Gets the name of the element by an instance
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetType(String) | Gets the type by an element.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InstallerObjectFactory Class
Sitecore.Install.Configuration Namespace


GetAttribute Method

[image]

Sitecore 6.4.1 API
InstallerObjectFactory..::..GetAttribute Method
InstallerObjectFactory Class See Also Send Feedback

Namespace: Sitecore.Install.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetAttribute(
    Type type,
    string key
)
Visual Basic
Public Function GetAttribute ( _
    type As Type, _
    key As String _
) As String
Visual C++
public:
String^ GetAttribute(
    Type^ type,
    String^ key
)

Parameters

type
Type: System..::..Type
The type.
key
Type: System..::..String
The key.

Return Value

The attribute.

See Also

InstallerObjectFactory Class
Sitecore.Install.Configuration Namespace


GetAttributes Method

[image]

Sitecore 6.4.1 API
InstallerObjectFactory..::..GetAttributes Method
InstallerObjectFactory Class See Also Send Feedback

Namespace: Sitecore.Install.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IDictionary<string, string> GetAttributes(
    Type type
)
Visual Basic
Public Function GetAttributes ( _
    type As Type _
) As IDictionary(Of String, String)
Visual C++
public:
IDictionary<String^, String^>^ GetAttributes(
    Type^ type
)

Parameters

type
Type: System..::..Type
The type.

Return Value

The attributes.

See Also

InstallerObjectFactory Class
Sitecore.Install.Configuration Namespace


GetElementName Method

[image]

Sitecore 6.4.1 API
InstallerObjectFactory..::..GetElementName Method
InstallerObjectFactory Class See Also Send Feedback

Namespace: Sitecore.Install.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetElementName(
    Object object
)
Visual Basic
Public Function GetElementName ( _
    object As Object _
) As String
Visual C++
public:
virtual String^ GetElementName(
    Object^ object
) sealed

Parameters

object
Type: System..::..Object
Instance of type

Return Value

[Missing <returns> documentation for "M:Sitecore.Install.Configuration.InstallerObjectFactory.GetElementName(System.Object)"]

Implements

IObjectFactory..::..GetElementName(Object)

See Also

InstallerObjectFactory Class
Sitecore.Install.Configuration Namespace


GetType Method

[image] [image]

Sitecore 6.4.1 API
InstallerObjectFactory..::..GetType Method
InstallerObjectFactory Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetType(String) | Gets the type by an element.

See Also

InstallerObjectFactory Class
InstallerObjectFactory Members
Sitecore.Install.Configuration Namespace


GetType Method (String)

[image]

Sitecore 6.4.1 API
InstallerObjectFactory..::..GetType Method (String)
InstallerObjectFactory Class See Also Send Feedback

Namespace: Sitecore.Install.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Type GetType(
    string element
)
Visual Basic
Public Function GetType ( _
    element As String _
) As Type
Visual C++
public:
virtual Type^ GetType(
    String^ element
) sealed

Parameters

element
Type: System..::..String
The element name

Return Value

The type

Implements

IObjectFactory..::..GetType(String)

See Also

InstallerObjectFactory Class
GetType Overload
Sitecore.Install.Configuration Namespace


InstallerObjectFactory Properties

[image] [image]

Sitecore 6.4.1 API
InstallerObjectFactory Properties
InstallerObjectFactory Class See Also Send Feedback

The InstallerObjectFactory type exposes the following members.

Properties

Name | Description
Instance | Gets the instance.

See Also

InstallerObjectFactory Class
Sitecore.Install.Configuration Namespace


Instance Property

[image]

Sitecore 6.4.1 API
InstallerObjectFactory..::..Instance Property
InstallerObjectFactory Class See Also Send Feedback

Namespace: Sitecore.Install.Configuration
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static InstallerObjectFactory Instance { get; }
Visual Basic
Public Shared ReadOnly Property Instance As InstallerObjectFactory
    Get
Visual C++
public:
static property InstallerObjectFactory^ Instance {
    InstallerObjectFactory^ get ();
}

Field Value

The instance.

See Also

InstallerObjectFactory Class
Sitecore.Install.Configuration Namespace


Sitecore.Install.Files Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Install.Files Namespace
Send Feedback

Classes

 | Class | Description
Public class | DefaultFileInstallerEvents | Default implementation of IFileInstallerEvents
Public class | DirectoryEntryData | Directory entry data
Public class | ExplicitFileSource | FileInfo source that accepts Sitecore virtual paths
Public class | ExplicitFileSource..::..Builder | Builder for ExplicitFileSource
Public class | ExplicitFileSystemSource | FileInfo source that accepts raw filesystem paths
Public class | ExplicitFileSystemSource..::..Builder | Builds the ExplicitFileSystemSource object
Public class | FileCopyInfo | Information about a file copying
Public class | FileEntryData | Entry that represents a file
Public class | FileInstaller | Installs files from package entries
Public class | FileInstallerContext | File installer context
Public class | FileSource | FileInfo dynamic source that accepts virtual paths
Public class | FileSystemSource | File system source. Get all files from the Root property and populates a sink whis FileSystemInfo
Public class | FileToEntryConverter | File to entry converter
Public class | MappedFileProvider | Mapped file provider
Public class | PathUtils | Path utils
Public class | RawFileSystemWriter | Installs files from package entries
Public class | RawFileToEntryConverter | Represents a convertor from file to package entry

Interfaces

 | Interface | Description
Public interface | IFileInstallerEvents | Defines basic file installer events


DefaultFileInstallerEvents Class

[image]

Sitecore 6.4.1 API
DefaultFileInstallerEvents Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DefaultFileInstallerEvents : IFileInstallerEvents
Visual Basic
Public Class DefaultFileInstallerEvents _
    Implements IFileInstallerEvents
Visual C++
public ref class DefaultFileInstallerEvents : IFileInstallerEvents

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Files..::..DefaultFileInstallerEvents

See Also

DefaultFileInstallerEvents Members
Sitecore.Install.Files Namespace


DefaultFileInstallerEvents Members

[image] [image]

Sitecore 6.4.1 API
DefaultFileInstallerEvents Members
DefaultFileInstallerEvents Class Constructors Methods See Also Send Feedback

The DefaultFileInstallerEvents type exposes the following members.

Constructors

 | Name | Description
Public method | DefaultFileInstallerEvents | Initializes a new instance of the DefaultFileInstallerEvents class.

Methods

 | Name | Description
Public method | BeforeCommit | Event fired before starting the process of actually installing files to their locations in the site.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RequestOverwrite | Requests calling party for overwrite event
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultFileInstallerEvents Class
Sitecore.Install.Files Namespace


DefaultFileInstallerEvents Constructor

[image]

Sitecore 6.4.1 API
DefaultFileInstallerEvents Constructor
DefaultFileInstallerEvents Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DefaultFileInstallerEvents(
    bool overwrite
)
Visual Basic
Public Sub New ( _
    overwrite As Boolean _
)
Visual C++
public:
DefaultFileInstallerEvents(
    bool overwrite
)

Parameters

overwrite
Type: System..::..Boolean
if set to true the all items will be overwritten during the installation.

See Also

DefaultFileInstallerEvents Class
Sitecore.Install.Files Namespace


DefaultFileInstallerEvents Methods

[image] [image]

Sitecore 6.4.1 API
DefaultFileInstallerEvents Methods
DefaultFileInstallerEvents Class See Also Send Feedback

The DefaultFileInstallerEvents type exposes the following members.

Methods

 | Name | Description
Public method | BeforeCommit | Event fired before starting the process of actually installing files to their locations in the site.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RequestOverwrite | Requests calling party for overwrite event
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultFileInstallerEvents Class
Sitecore.Install.Files Namespace


BeforeCommit Method

[image]

Sitecore 6.4.1 API
DefaultFileInstallerEvents..::..BeforeCommit Method
DefaultFileInstallerEvents Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void BeforeCommit()
Visual Basic
Public Sub BeforeCommit
Visual C++
public:
virtual void BeforeCommit() sealed

Implements

IFileInstallerEvents..::..BeforeCommit()()()()

See Also

DefaultFileInstallerEvents Class
Sitecore.Install.Files Namespace


RequestOverwrite Method

[image]

Sitecore 6.4.1 API
DefaultFileInstallerEvents..::..RequestOverwrite Method
DefaultFileInstallerEvents Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Pair<bool, bool> RequestOverwrite(
    string virtualPath,
    IProcessingContext context
)
Visual Basic
Public Overridable Function RequestOverwrite ( _
    virtualPath As String, _
    context As IProcessingContext _
) As Pair(Of Boolean, Boolean)
Visual C++
public:
virtual Pair<bool, bool>^ RequestOverwrite(
    String^ virtualPath,
    IProcessingContext^ context
)

Parameters

virtualPath
Type: System..::..String
File path which is subject of request
context
Type: Sitecore.Install.Framework..::..IProcessingContext
Processing context

Return Value

A pair of bools:
  • First: Whether overwrite is allowed or not
  • Second: Whether decision should be applied to all subsequent files

Implements

IFileInstallerEvents..::..RequestOverwrite(String, IProcessingContext)

See Also

DefaultFileInstallerEvents Class
Sitecore.Install.Files Namespace


DirectoryEntryData Class

[image]

Sitecore 6.4.1 API
DirectoryEntryData Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DirectoryEntryData : IEntryData
Visual Basic
Public Class DirectoryEntryData _
    Implements IEntryData
Visual C++
public ref class DirectoryEntryData : IEntryData

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Files..::..DirectoryEntryData

See Also

DirectoryEntryData Members
Sitecore.Install.Files Namespace


DirectoryEntryData Members

[image] [image]

Sitecore 6.4.1 API
DirectoryEntryData Members
DirectoryEntryData Class Constructors Methods Properties See Also Send Feedback

The DirectoryEntryData type exposes the following members.

Constructors

 | Name | Description
Public method | DirectoryEntryData | Initializes a new instance of the DirectoryEntryData class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStream | Gets the stream holder.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Key | Gets the key.

See Also

DirectoryEntryData Class
Sitecore.Install.Files Namespace


DirectoryEntryData Constructor

[image]

Sitecore 6.4.1 API
DirectoryEntryData Constructor
DirectoryEntryData Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DirectoryEntryData(
    string path
)
Visual Basic
Public Sub New ( _
    path As String _
)
Visual C++
public:
DirectoryEntryData(
    String^ path
)

Parameters

path
Type: System..::..String
The path.

See Also

DirectoryEntryData Class
Sitecore.Install.Files Namespace


DirectoryEntryData Methods

[image] [image]

Sitecore 6.4.1 API
DirectoryEntryData Methods
DirectoryEntryData Class See Also Send Feedback

The DirectoryEntryData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStream | Gets the stream holder.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DirectoryEntryData Class
Sitecore.Install.Files Namespace


GetStream Method

[image]

Sitecore 6.4.1 API
DirectoryEntryData..::..GetStream Method
DirectoryEntryData Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IStreamHolder GetStream()
Visual Basic
Public Function GetStream As IStreamHolder
Visual C++
public:
virtual IStreamHolder^ GetStream() sealed

Return Value

The stream holder.

Implements

IEntryData..::..GetStream()()()()

See Also

DirectoryEntryData Class
Sitecore.Install.Files Namespace


DirectoryEntryData Properties

[image] [image]

Sitecore 6.4.1 API
DirectoryEntryData Properties
DirectoryEntryData Class See Also Send Feedback

The DirectoryEntryData type exposes the following members.

Properties

 | Name | Description
Public property | Key | Gets the key.

See Also

DirectoryEntryData Class
Sitecore.Install.Files Namespace


Key Property

[image]

Sitecore 6.4.1 API
DirectoryEntryData..::..Key Property
DirectoryEntryData Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Key { get; }
Visual Basic
Public ReadOnly Property Key As String
    Get
Visual C++
public:
virtual property String^ Key {
    String^ get () sealed;
}

Field Value

The key.

Implements

IEntryData..::..Key

See Also

DirectoryEntryData Class
Sitecore.Install.Files Namespace


ExplicitFileSource Class

[image]

Sitecore 6.4.1 API
ExplicitFileSource Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ExplicitFileSource : ExplicitFileSystemSource
Visual Basic
Public Class ExplicitFileSource _
    Inherits ExplicitFileSystemSource
Visual C++
public ref class ExplicitFileSource : public ExplicitFileSystemSource

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..BaseSource <(Of <(<' FileSystemInfo >)>)>
Sitecore.Install.Files..::..ExplicitFileSystemSource
Sitecore.Install.Files..::..ExplicitFileSource

See Also

ExplicitFileSource Members
Sitecore.Install.Files Namespace


ExplicitFileSource Members

[image] [image]

Sitecore 6.4.1 API
ExplicitFileSource Members
ExplicitFileSource Class Constructors Methods Properties See Also Send Feedback

The ExplicitFileSource type exposes the following members.

Constructors

 | Name | Description
Public method | ExplicitFileSource | Initializes a new instance of the ExplicitFileSource class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetList | Gets the list of paths. (Inherited from ExplicitFileSystemSource.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InternalPopulate | Converts the list of the pathes to the FileSystemInfo objects and populates the sink with it (Inherited from ExplicitFileSystemSource.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Populates this sourse from the specified sink. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public method | ResolveKey | Resolves the key. (Inherited from ExplicitFileSystemSource.)
Protected method | ResolvePath | Resolves the path. (Overrides ExplicitFileSystemSource..::..ResolvePath(String).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Converter | Gets or sets the converter. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Entries | Gets the entries. (Inherited from ExplicitFileSystemSource.)
Public property | Exclude | Gets the exclude filters. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Include | Gets the include filters. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Name | Gets or sets the name. (Inherited from BaseSource<(Of <(<'T>)>)>.)

See Also

ExplicitFileSource Class
Sitecore.Install.Files Namespace


ExplicitFileSource Constructor

[image]

Sitecore 6.4.1 API
ExplicitFileSource Constructor
ExplicitFileSource Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ExplicitFileSource()
Visual Basic
Public Sub New
Visual C++
public:
ExplicitFileSource()

See Also

ExplicitFileSource Class
Sitecore.Install.Files Namespace


ExplicitFileSource Methods

[image] [image]

Sitecore 6.4.1 API
ExplicitFileSource Methods
ExplicitFileSource Class See Also Send Feedback

The ExplicitFileSource type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetList | Gets the list of paths. (Inherited from ExplicitFileSystemSource.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InternalPopulate | Converts the list of the pathes to the FileSystemInfo objects and populates the sink with it (Inherited from ExplicitFileSystemSource.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Populates this sourse from the specified sink. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public method | ResolveKey | Resolves the key. (Inherited from ExplicitFileSystemSource.)
Protected method | ResolvePath | Resolves the path. (Overrides ExplicitFileSystemSource..::..ResolvePath(String).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExplicitFileSource Class
Sitecore.Install.Files Namespace


ResolvePath Method

[image]

Sitecore 6.4.1 API
ExplicitFileSource..::..ResolvePath Method
ExplicitFileSource Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override string ResolvePath(
    string path
)
Visual Basic
Protected Overrides Function ResolvePath ( _
    path As String _
) As String
Visual C++
protected:
virtual String^ ResolvePath(
    String^ path
) override

Parameters

path
Type: System..::..String
The path.

Return Value

The path.

See Also

ExplicitFileSource Class
Sitecore.Install.Files Namespace


ExplicitFileSource Properties

[image] [image]

Sitecore 6.4.1 API
ExplicitFileSource Properties
ExplicitFileSource Class See Also Send Feedback

The ExplicitFileSource type exposes the following members.

Properties

 | Name | Description
Public property | Converter | Gets or sets the converter. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Entries | Gets the entries. (Inherited from ExplicitFileSystemSource.)
Public property | Exclude | Gets the exclude filters. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Include | Gets the include filters. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Name | Gets or sets the name. (Inherited from BaseSource<(Of <(<'T>)>)>.)

See Also

ExplicitFileSource Class
Sitecore.Install.Files Namespace


ExplicitFileSource.Builder Class

[image]

Sitecore 6.4.1 API
ExplicitFileSource..::..Builder Class
ExplicitFileSource Class Members See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Builder : ExplicitFileSystemSource..::..Builder
Visual Basic
Public Class Builder _
    Inherits ExplicitFileSystemSource..::..Builder
Visual C++
public ref class Builder : public ExplicitFileSystemSource..::..Builder

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..BaseSink <(Of <(<' PackageEntry >)>)>
Sitecore.Install.Files..::..ExplicitFileSystemSource..::..Builder
Sitecore.Install.Files..::..ExplicitFileSource..::..Builder

See Also

ExplicitFileSource..::..Builder Members
Sitecore.Install.Files Namespace


ExplicitFileSource.Builder Constructor

[image] [image]

Sitecore 6.4.1 API
ExplicitFileSource..::..Builder Constructor
ExplicitFileSource..::..Builder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExplicitFileSource..::..Builder()()()() | Initializes a new instance of the ExplicitFileSource..::..Builder class.
Public method | ExplicitFileSource..::..Builder(ExplicitFileSource) | Initializes a new instance of the ExplicitFileSource..::..Builder class.

See Also

ExplicitFileSource..::..Builder Class
ExplicitFileSource..::..Builder Members
Sitecore.Install.Files Namespace


ExplicitFileSource.Builder Constructor

[image]

Sitecore 6.4.1 API
ExplicitFileSource..::..Builder Constructor
ExplicitFileSource..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Builder()
Visual Basic
Public Sub New
Visual C++
public:
Builder()

See Also

ExplicitFileSource..::..Builder Class
ExplicitFileSource..::..Builder Overload
Sitecore.Install.Files Namespace


ExplicitFileSource.Builder Constructor (ExplicitFileSource)

[image]

Sitecore 6.4.1 API
ExplicitFileSource..::..Builder Constructor (ExplicitFileSource)
ExplicitFileSource..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Builder(
    ExplicitFileSource source
)
Visual Basic
Public Sub New ( _
    source As ExplicitFileSource _
)
Visual C++
public:
Builder(
    ExplicitFileSource^ source
)

Parameters

source
Type: Sitecore.Install.Files..::..ExplicitFileSource
The source.

See Also

ExplicitFileSource..::..Builder Class
ExplicitFileSource..::..Builder Overload
Sitecore.Install.Files Namespace


ExplicitFileSource.Builder Fields

[image] [image]

Sitecore 6.4.1 API
ExplicitFileSource..::..Builder Fields
ExplicitFileSource..::..Builder Class See Also Send Feedback

The ExplicitFileSource..::..Builder type exposes the following members.

Fields

 | Name | Description
Protected field | _processingContext | (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

ExplicitFileSource..::..Builder Class
Sitecore.Install.Files Namespace


ExplicitFileSource.Builder Methods

[image] [image]

Sitecore 6.4.1 API
ExplicitFileSource..::..Builder Methods
ExplicitFileSource..::..Builder Class See Also Send Feedback

The ExplicitFileSource..::..Builder type exposes the following members.

Methods

 | Name | Description
Protected method | AssertInit | Asserts the init. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finishes the sink. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Flush | Flushes the sink (Inherited from BaseSink<(Of <(<'T>)>)>.)
Protected method | GetDefaultRoot | Gets the default root. (Overrides ExplicitFileSystemSource..::..Builder..::..GetDefaultRoot()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this instance. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put | Puts the specified entry. (Inherited from ExplicitFileSystemSource..::..Builder.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExplicitFileSource..::..Builder Class
Sitecore.Install.Files Namespace


GetDefaultRoot Method

[image]

Sitecore 6.4.1 API
ExplicitFileSource..::..Builder..::..GetDefaultRoot Method
ExplicitFileSource..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override string GetDefaultRoot()
Visual Basic
Protected Overrides Function GetDefaultRoot As String
Visual C++
protected:
virtual String^ GetDefaultRoot() override

Return Value

The default root.

See Also

ExplicitFileSource..::..Builder Class
Sitecore.Install.Files Namespace


ExplicitFileSource.Builder Properties

[image] [image]

Sitecore 6.4.1 API
ExplicitFileSource..::..Builder Properties
ExplicitFileSource..::..Builder Class See Also Send Feedback

The ExplicitFileSource..::..Builder type exposes the following members.

Properties

 | Name | Description
Public property | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | Root | Gets or sets the root. (Inherited from ExplicitFileSystemSource..::..Builder.)
Public property | Source | Gets the source.

See Also

ExplicitFileSource..::..Builder Class
Sitecore.Install.Files Namespace


Source Property

[image]

Sitecore 6.4.1 API
ExplicitFileSource..::..Builder..::..Source Property
ExplicitFileSource..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ExplicitFileSource Source { get; }
Visual Basic
Public ReadOnly Property Source As ExplicitFileSource
    Get
Visual C++
public:
property ExplicitFileSource^ Source {
    ExplicitFileSource^ get ();
}

Field Value

The source.

See Also

ExplicitFileSource..::..Builder Class
Sitecore.Install.Files Namespace


ExplicitFileSystemSource Class

[image]

Sitecore 6.4.1 API
ExplicitFileSystemSource Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ExplicitFileSystemSource : BaseSource<FileSystemInfo>,
    IExplicitSource, IKeyResolver
Visual Basic
Public Class ExplicitFileSystemSource _
    Inherits BaseSource(Of FileSystemInfo) _
    Implements IExplicitSource, IKeyResolver
Visual C++
public ref class ExplicitFileSystemSource : public BaseSource<FileSystemInfo^>,
    IExplicitSource, IKeyResolver

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..BaseSource <(Of <(<' FileSystemInfo >)>)>
Sitecore.Install.Files..::..ExplicitFileSystemSource
Sitecore.Install.Files..::..ExplicitFileSource

See Also

ExplicitFileSystemSource Members
Sitecore.Install.Files Namespace


ExplicitFileSystemSource Members

[image] [image]

Sitecore 6.4.1 API
ExplicitFileSystemSource Members
ExplicitFileSystemSource Class Constructors Methods Properties See Also Send Feedback

The ExplicitFileSystemSource type exposes the following members.

Constructors

 | Name | Description
Public method | ExplicitFileSystemSource | Initializes a new instance of the ExplicitFileSystemSource class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetList | Gets the list of paths.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InternalPopulate | Converts the list of the pathes to the FileSystemInfo objects and populates the sink with it (Overrides BaseSource<(Of <(<'T>)>)>..::..InternalPopulate(ISink<(Of <<'(T>)>>)).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Populates this sourse from the specified sink. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public method | ResolveKey | Resolves the key.
Protected method | ResolvePath | Resolves the path.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Converter | Gets or sets the converter. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Entries | Gets the entries.
Public property | Exclude | Gets the exclude filters. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Include | Gets the include filters. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Name | Gets or sets the name. (Inherited from BaseSource<(Of <(<'T>)>)>.)

See Also

ExplicitFileSystemSource Class
Sitecore.Install.Files Namespace


ExplicitFileSystemSource Constructor

[image]

Sitecore 6.4.1 API
ExplicitFileSystemSource Constructor
ExplicitFileSystemSource Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ExplicitFileSystemSource()
Visual Basic
Public Sub New
Visual C++
public:
ExplicitFileSystemSource()

See Also

ExplicitFileSystemSource Class
Sitecore.Install.Files Namespace


ExplicitFileSystemSource Methods

[image] [image]

Sitecore 6.4.1 API
ExplicitFileSystemSource Methods
ExplicitFileSystemSource Class See Also Send Feedback

The ExplicitFileSystemSource type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetList | Gets the list of paths.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InternalPopulate | Converts the list of the pathes to the FileSystemInfo objects and populates the sink with it (Overrides BaseSource<(Of <(<'T>)>)>..::..InternalPopulate(ISink<(Of <<'(T>)>>)).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Populates this sourse from the specified sink. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public method | ResolveKey | Resolves the key.
Protected method | ResolvePath | Resolves the path.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExplicitFileSystemSource Class
Sitecore.Install.Files Namespace


GetList Method

[image]

Sitecore 6.4.1 API
ExplicitFileSystemSource..::..GetList Method
ExplicitFileSystemSource Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IList<string> GetList()
Visual Basic
Public Function GetList As IList(Of String)
Visual C++
public:
IList<String^>^ GetList()

Return Value

The list.

See Also

ExplicitFileSystemSource Class
Sitecore.Install.Files Namespace


InternalPopulate Method

[image]

Sitecore 6.4.1 API
ExplicitFileSystemSource..::..InternalPopulate Method
ExplicitFileSystemSource Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void InternalPopulate(
    ISink<FileSystemInfo> sink
)
Visual Basic
Protected Overrides Sub InternalPopulate ( _
    sink As ISink(Of FileSystemInfo) _
)
Visual C++
protected:
virtual void InternalPopulate(
    ISink<FileSystemInfo^>^ sink
) override

Parameters

sink
Type: Sitecore.Install.Framework..::..ISink <(Of <(<' FileSystemInfo >)>)>
The sink

See Also

ExplicitFileSystemSource Class
Sitecore.Install.Files Namespace


ResolveKey Method

[image]

Sitecore 6.4.1 API
ExplicitFileSystemSource..::..ResolveKey Method
ExplicitFileSystemSource Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object ResolveKey(
    string key
)
Visual Basic
Public Function ResolveKey ( _
    key As String _
) As Object
Visual C++
public:
virtual Object^ ResolveKey(
    String^ key
) sealed

Parameters

key
Type: System..::..String
The key.

Return Value

The object.

Implements

IKeyResolver..::..ResolveKey(String)

See Also

ExplicitFileSystemSource Class
Sitecore.Install.Files Namespace


ResolvePath Method

[image]

Sitecore 6.4.1 API
ExplicitFileSystemSource..::..ResolvePath Method
ExplicitFileSystemSource Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string ResolvePath(
    string path
)
Visual Basic
Protected Overridable Function ResolvePath ( _
    path As String _
) As String
Visual C++
protected:
virtual String^ ResolvePath(
    String^ path
)

Parameters

path
Type: System..::..String
The path.

Return Value

The path.

See Also

ExplicitFileSystemSource Class
Sitecore.Install.Files Namespace


ExplicitFileSystemSource Properties

[image] [image]

Sitecore 6.4.1 API
ExplicitFileSystemSource Properties
ExplicitFileSystemSource Class See Also Send Feedback

The ExplicitFileSystemSource type exposes the following members.

Properties

 | Name | Description
Public property | Converter | Gets or sets the converter. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Entries | Gets the entries.
Public property | Exclude | Gets the exclude filters. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Include | Gets the include filters. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Name | Gets or sets the name. (Inherited from BaseSource<(Of <(<'T>)>)>.)

See Also

ExplicitFileSystemSource Class
Sitecore.Install.Files Namespace


Entries Property

[image]

Sitecore 6.4.1 API
ExplicitFileSystemSource..::..Entries Property
ExplicitFileSystemSource Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IList<string> Entries { get; }
Visual Basic
Public ReadOnly Property Entries As IList(Of String)
    Get
Visual C++
public:
virtual property IList<String^>^ Entries {
    IList<String^>^ get () sealed;
}

Field Value

The entries.

Implements

IExplicitSource..::..Entries

See Also

ExplicitFileSystemSource Class
Sitecore.Install.Files Namespace


ExplicitFileSystemSource.Builder Class

[image]

Sitecore 6.4.1 API
ExplicitFileSystemSource..::..Builder Class
ExplicitFileSystemSource Class Members See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Builder : BaseSink<PackageEntry>
Visual Basic
Public Class Builder _
    Inherits BaseSink(Of PackageEntry)
Visual C++
public ref class Builder : public BaseSink<PackageEntry^>

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..BaseSink <(Of <(<' PackageEntry >)>)>
Sitecore.Install.Files..::..ExplicitFileSystemSource..::..Builder
Sitecore.Install.Files..::..ExplicitFileSource..::..Builder

See Also

ExplicitFileSystemSource..::..Builder Members
Sitecore.Install.Files Namespace


ExplicitFileSystemSource.Builder Members

[image] [image]

Sitecore 6.4.1 API
ExplicitFileSystemSource..::..Builder Members
ExplicitFileSystemSource..::..Builder Class Constructors Methods Fields Properties See Also Send Feedback

FileInfo source that accepts raw filesystem paths

The ExplicitFileSystemSource..::..Builder type exposes the following members.

Constructors

 | Name | Description
Public method | ExplicitFileSystemSource..::..Builder()()()() | Initializes a new instance of the ExplicitFileSystemSource..::..Builder class.
Public method | ExplicitFileSystemSource..::..Builder(ExplicitFileSystemSource) | Initializes a new instance of the ExplicitFileSystemSource..::..Builder class.

Methods

 | Name | Description
Protected method | AssertInit | Asserts the init. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finishes the sink. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Flush | Flushes the sink (Inherited from BaseSink<(Of <(<'T>)>)>.)
Protected method | GetDefaultRoot | Gets the default root.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this instance. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put | Puts the specified entry. (Overrides BaseSink<(Of <(<'T>)>)>..::..Put(T).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _processingContext | (Inherited from BaseSink<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | Root | Gets or sets the root.
Public property | Source | Gets the source.

See Also

ExplicitFileSystemSource..::..Builder Class
Sitecore.Install.Files Namespace


ExplicitFileSystemSource.Builder Constructor

[image] [image]

Sitecore 6.4.1 API
ExplicitFileSystemSource..::..Builder Constructor
ExplicitFileSystemSource..::..Builder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExplicitFileSystemSource..::..Builder()()()() | Initializes a new instance of the ExplicitFileSystemSource..::..Builder class.
Public method | ExplicitFileSystemSource..::..Builder(ExplicitFileSystemSource) | Initializes a new instance of the ExplicitFileSystemSource..::..Builder class.

See Also

ExplicitFileSystemSource..::..Builder Class
ExplicitFileSystemSource..::..Builder Members
Sitecore.Install.Files Namespace


ExplicitFileSystemSource.Builder Constructor

[image]

Sitecore 6.4.1 API
ExplicitFileSystemSource..::..Builder Constructor
ExplicitFileSystemSource..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Builder()
Visual Basic
Public Sub New
Visual C++
public:
Builder()

See Also

ExplicitFileSystemSource..::..Builder Class
ExplicitFileSystemSource..::..Builder Overload
Sitecore.Install.Files Namespace


ExplicitFileSystemSource.Builder Constructor (ExplicitFileSystemSource)

[image]

Sitecore 6.4.1 API
ExplicitFileSystemSource..::..Builder Constructor (ExplicitFileSystemSource)
ExplicitFileSystemSource..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Builder(
    ExplicitFileSystemSource source
)
Visual Basic
Public Sub New ( _
    source As ExplicitFileSystemSource _
)
Visual C++
public:
Builder(
    ExplicitFileSystemSource^ source
)

Parameters

source
Type: Sitecore.Install.Files..::..ExplicitFileSystemSource
The source.

See Also

ExplicitFileSystemSource..::..Builder Class
ExplicitFileSystemSource..::..Builder Overload
Sitecore.Install.Files Namespace


ExplicitFileSystemSource.Builder Fields

[image] [image]

Sitecore 6.4.1 API
ExplicitFileSystemSource..::..Builder Fields
ExplicitFileSystemSource..::..Builder Class See Also Send Feedback

The ExplicitFileSystemSource..::..Builder type exposes the following members.

Fields

 | Name | Description
Protected field | _processingContext | (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

ExplicitFileSystemSource..::..Builder Class
Sitecore.Install.Files Namespace


ExplicitFileSystemSource.Builder Methods

[image] [image]

Sitecore 6.4.1 API
ExplicitFileSystemSource..::..Builder Methods
ExplicitFileSystemSource..::..Builder Class See Also Send Feedback

The ExplicitFileSystemSource..::..Builder type exposes the following members.

Methods

 | Name | Description
Protected method | AssertInit | Asserts the init. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finishes the sink. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Flush | Flushes the sink (Inherited from BaseSink<(Of <(<'T>)>)>.)
Protected method | GetDefaultRoot | Gets the default root.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this instance. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put | Puts the specified entry. (Overrides BaseSink<(Of <(<'T>)>)>..::..Put(T).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExplicitFileSystemSource..::..Builder Class
Sitecore.Install.Files Namespace


GetDefaultRoot Method

[image]

Sitecore 6.4.1 API
ExplicitFileSystemSource..::..Builder..::..GetDefaultRoot Method
ExplicitFileSystemSource..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string GetDefaultRoot()
Visual Basic
Protected Overridable Function GetDefaultRoot As String
Visual C++
protected:
virtual String^ GetDefaultRoot()

Return Value

The default root.

See Also

ExplicitFileSystemSource..::..Builder Class
Sitecore.Install.Files Namespace


Put Method

[image]

Sitecore 6.4.1 API
ExplicitFileSystemSource..::..Builder..::..Put Method
ExplicitFileSystemSource..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Put(
    PackageEntry entry
)
Visual Basic
Public Overrides Sub Put ( _
    entry As PackageEntry _
)
Visual C++
public:
virtual void Put(
    PackageEntry^ entry
) override

Parameters

entry
Type: Sitecore.Install.Framework..::..PackageEntry
The entry.

Implements

ISink<(Of <(<'T>)>)>..::..Put(T)

See Also

ExplicitFileSystemSource..::..Builder Class
Sitecore.Install.Files Namespace


ExplicitFileSystemSource.Builder Properties

[image] [image]

Sitecore 6.4.1 API
ExplicitFileSystemSource..::..Builder Properties
ExplicitFileSystemSource..::..Builder Class See Also Send Feedback

The ExplicitFileSystemSource..::..Builder type exposes the following members.

Properties

 | Name | Description
Public property | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | Root | Gets or sets the root.
Public property | Source | Gets the source.

See Also

ExplicitFileSystemSource..::..Builder Class
Sitecore.Install.Files Namespace


Root Property

[image]

Sitecore 6.4.1 API
ExplicitFileSystemSource..::..Builder..::..Root Property
ExplicitFileSystemSource..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Root { get; set; }
Visual Basic
Public Property Root As String
    Get
    Set
Visual C++
public:
property String^ Root {
    String^ get ();
    void set (String^ value);
}

Field Value

The root.

See Also

ExplicitFileSystemSource..::..Builder Class
Sitecore.Install.Files Namespace


Source Property

[image]

Sitecore 6.4.1 API
ExplicitFileSystemSource..::..Builder..::..Source Property
ExplicitFileSystemSource..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ExplicitFileSystemSource Source { get; }
Visual Basic
Public ReadOnly Property Source As ExplicitFileSystemSource
    Get
Visual C++
public:
property ExplicitFileSystemSource^ Source {
    ExplicitFileSystemSource^ get ();
}

Field Value

The source.

See Also

ExplicitFileSystemSource..::..Builder Class
Sitecore.Install.Files Namespace


FileCopyInfo Class

[image]

Sitecore 6.4.1 API
FileCopyInfo Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FileCopyInfo
Visual Basic
Public Class FileCopyInfo
Visual C++
public ref class FileCopyInfo

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Files..::..FileCopyInfo

See Also

FileCopyInfo Members
Sitecore.Install.Files Namespace


FileCopyInfo Members

[image] [image]

Sitecore 6.4.1 API
FileCopyInfo Members
FileCopyInfo Class Constructors Methods Fields See Also Send Feedback

The FileCopyInfo type exposes the following members.

Constructors

 | Name | Description
Public method | FileCopyInfo | Initializes a new instance of the FileCopyInfo class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | SourcePath |
Public field | TargetPath |

See Also

FileCopyInfo Class
Sitecore.Install.Files Namespace


FileCopyInfo Constructor

[image]

Sitecore 6.4.1 API
FileCopyInfo Constructor
FileCopyInfo Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FileCopyInfo(
    string sourcePath,
    string targetPath
)
Visual Basic
Public Sub New ( _
    sourcePath As String, _
    targetPath As String _
)
Visual C++
public:
FileCopyInfo(
    String^ sourcePath,
    String^ targetPath
)

Parameters

sourcePath
Type: System..::..String
The source path.
targetPath
Type: System..::..String
The target path.

See Also

FileCopyInfo Class
Sitecore.Install.Files Namespace


FileCopyInfo Fields

[image] [image]

Sitecore 6.4.1 API
FileCopyInfo Fields
FileCopyInfo Class See Also Send Feedback

The FileCopyInfo type exposes the following members.

Fields

 | Name | Description
Public field | SourcePath |
Public field | TargetPath |

See Also

FileCopyInfo Class
Sitecore.Install.Files Namespace


TargetPath Field

[image]

Sitecore 6.4.1 API
FileCopyInfo..::..TargetPath Field
FileCopyInfo Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public readonly string TargetPath
Visual Basic
Public ReadOnly TargetPath As String
Visual C++
public:
initonly String^ TargetPath

See Also

FileCopyInfo Class
Sitecore.Install.Files Namespace


FileCopyInfo Methods

[image] [image]

Sitecore 6.4.1 API
FileCopyInfo Methods
FileCopyInfo Class See Also Send Feedback

The FileCopyInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileCopyInfo Class
Sitecore.Install.Files Namespace


FileEntryData Members

[image] [image]

Sitecore 6.4.1 API
FileEntryData Members
FileEntryData Class Constructors Methods Properties See Also Send Feedback

The FileEntryData type exposes the following members.

Constructors

 | Name | Description
Public method | FileEntryData | Initializes a new instance of the FileEntryData class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetKey | Gets the key.
Public method | GetStream | Gets the stream holder.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Key | Gets the key.

See Also

FileEntryData Class
Sitecore.Install.Files Namespace


FileEntryData Constructor

[image]

Sitecore 6.4.1 API
FileEntryData Constructor
FileEntryData Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FileEntryData(
    string path,
    FileInfo info
)
Visual Basic
Public Sub New ( _
    path As String, _
    info As FileInfo _
)
Visual C++
public:
FileEntryData(
    String^ path,
    FileInfo^ info
)

Parameters

path
Type: System..::..String
The file path.
info
Type: System.IO..::..FileInfo
The file info.

See Also

FileEntryData Class
Sitecore.Install.Files Namespace


FileEntryData Methods

[image] [image]

Sitecore 6.4.1 API
FileEntryData Methods
FileEntryData Class See Also Send Feedback

The FileEntryData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetKey | Gets the key.
Public method | GetStream | Gets the stream holder.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileEntryData Class
Sitecore.Install.Files Namespace


GetKey Method

[image]

Sitecore 6.4.1 API
FileEntryData..::..GetKey Method
FileEntryData Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetKey(
    string path
)
Visual Basic
Public Shared Function GetKey ( _
    path As String _
) As String
Visual C++
public:
static String^ GetKey(
    String^ path
)

Parameters

path
Type: System..::..String
The file path.

Return Value

The key.

See Also

FileEntryData Class
Sitecore.Install.Files Namespace


GetStream Method

[image]

Sitecore 6.4.1 API
FileEntryData..::..GetStream Method
FileEntryData Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IStreamHolder GetStream()
Visual Basic
Public Function GetStream As IStreamHolder
Visual C++
public:
virtual IStreamHolder^ GetStream() sealed

Return Value

The stream holder.

Implements

IEntryData..::..GetStream()()()()

See Also

FileEntryData Class
Sitecore.Install.Files Namespace


FileEntryData Properties

[image] [image]

Sitecore 6.4.1 API
FileEntryData Properties
FileEntryData Class See Also Send Feedback

The FileEntryData type exposes the following members.

Properties

 | Name | Description
Public property | Key | Gets the key.

See Also

FileEntryData Class
Sitecore.Install.Files Namespace


Key Property

[image]

Sitecore 6.4.1 API
FileEntryData..::..Key Property
FileEntryData Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Key { get; }
Visual Basic
Public ReadOnly Property Key As String
    Get
Visual C++
public:
virtual property String^ Key {
    String^ get () sealed;
}

Field Value

The key.

Implements

IEntryData..::..Key

See Also

FileEntryData Class
Sitecore.Install.Files Namespace


FileInstaller Class

[image]

Sitecore 6.4.1 API
FileInstaller Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public sealed class FileInstaller : AdvancedBaseSink<PackageEntry, FileInstallerContext>
Visual Basic
Public NotInheritable Class FileInstaller _
    Inherits AdvancedBaseSink(Of PackageEntry, FileInstallerContext)
Visual C++
public ref class FileInstaller sealed : public AdvancedBaseSink<PackageEntry^, FileInstallerContext^>

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..BaseSink <(Of <(<' T >)>)>
Sitecore.Install.Framework..::..AdvancedBaseSink <(Of <(<' PackageEntry, FileInstallerContext >)>)>
Sitecore.Install.Files..::..FileInstaller

See Also

FileInstaller Members
Sitecore.Install.Files Namespace


FileInstaller Members

[image] [image]

Sitecore 6.4.1 API
FileInstaller Members
FileInstaller Class Constructors Methods Fields Properties See Also Send Feedback

The FileInstaller type exposes the following members.

Constructors

 | Name | Description
Public method | FileInstaller | Initializes a new instance of the FileInstaller class.

Methods

 | Name | Description
Protected method | AssertInit | Asserts the init. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Protected method | CreateContext | Creates the context. (Overrides AdvancedBaseSink<(Of <(<'T, ContextType>)>)>..::..CreateContext()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finishes the sink. (Overrides BaseSink<(Of <(<'T>)>)>..::..Finish()()()().)
Public method | Flush | Flushes the sink (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetStatusFileName | Gets the name of the status file for file installer and its background worker.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this instance. (Inherited from AdvancedBaseSink<(Of <(<'T, ContextType>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put(T) | Puts the specified entry. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Put(PackageEntry) | If an entry contains file or directory it will be installed.
Protected method | SetupContext | Setups the context. (Inherited from AdvancedBaseSink<(Of <(<'T, ContextType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _processingContext | (Inherited from BaseSink<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Context | Gets the context. (Inherited from AdvancedBaseSink<(Of <(<'T, ContextType>)>)>.)
Public property | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

FileInstaller Class
Sitecore.Install.Files Namespace


FileInstaller Constructor

[image]

Sitecore 6.4.1 API
FileInstaller Constructor
FileInstaller Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FileInstaller(
    IProcessingContext processingContext
)
Visual Basic
Public Sub New ( _
    processingContext As IProcessingContext _
)
Visual C++
public:
FileInstaller(
    IProcessingContext^ processingContext
)

Parameters

processingContext
Type: Sitecore.Install.Framework..::..IProcessingContext
The processing context.

See Also

FileInstaller Class
Sitecore.Install.Files Namespace


FileInstaller Fields

[image] [image]

Sitecore 6.4.1 API
FileInstaller Fields
FileInstaller Class See Also Send Feedback

The FileInstaller type exposes the following members.

Fields

 | Name | Description
Protected field | _processingContext | (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

FileInstaller Class
Sitecore.Install.Files Namespace


FileInstaller Methods

[image] [image]

Sitecore 6.4.1 API
FileInstaller Methods
FileInstaller Class See Also Send Feedback

The FileInstaller type exposes the following members.

Methods

 | Name | Description
Protected method | AssertInit | Asserts the init. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Protected method | CreateContext | Creates the context. (Overrides AdvancedBaseSink<(Of <(<'T, ContextType>)>)>..::..CreateContext()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finishes the sink. (Overrides BaseSink<(Of <(<'T>)>)>..::..Finish()()()().)
Public method | Flush | Flushes the sink (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetStatusFileName | Gets the name of the status file for file installer and its background worker.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this instance. (Inherited from AdvancedBaseSink<(Of <(<'T, ContextType>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put(T) | Puts the specified entry. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Put(PackageEntry) | If an entry contains file or directory it will be installed.
Protected method | SetupContext | Setups the context. (Inherited from AdvancedBaseSink<(Of <(<'T, ContextType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileInstaller Class
Sitecore.Install.Files Namespace


CreateContext Method

[image]

Sitecore 6.4.1 API
FileInstaller..::..CreateContext Method
FileInstaller Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override FileInstallerContext CreateContext()
Visual Basic
Protected Overrides Function CreateContext As FileInstallerContext
Visual C++
protected:
virtual FileInstallerContext^ CreateContext() override

Return Value

The context.

See Also

FileInstaller Class
Sitecore.Install.Files Namespace


Finish Method

[image]

Sitecore 6.4.1 API
FileInstaller..::..Finish Method
FileInstaller Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Finish()
Visual Basic
Public Overrides Sub Finish
Visual C++
public:
virtual void Finish() override

Implements

ISink<(Of <(<'T>)>)>..::..Finish()()()()

See Also

FileInstaller Class
Sitecore.Install.Files Namespace


GetStatusFileName Method

[image]

Sitecore 6.4.1 API
FileInstaller..::..GetStatusFileName Method
FileInstaller Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetStatusFileName(
    string taskID
)
Visual Basic
Public Shared Function GetStatusFileName ( _
    taskID As String _
) As String
Visual C++
public:
static String^ GetStatusFileName(
    String^ taskID
)

Parameters

taskID
Type: System..::..String
The task ID.

Return Value

The status file name.

See Also

FileInstaller Class
Sitecore.Install.Files Namespace


Put Method

[image] [image]

Sitecore 6.4.1 API
FileInstaller..::..Put Method
FileInstaller Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Put(T) | Puts the specified entry. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Put(PackageEntry) | If an entry contains file or directory it will be installed.

See Also

FileInstaller Class
FileInstaller Members
Sitecore.Install.Files Namespace


Put Method (PackageEntry)

[image]

Sitecore 6.4.1 API
FileInstaller..::..Put Method (PackageEntry)
FileInstaller Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Put(
    PackageEntry entry
)
Visual Basic
Public Overridable Sub Put ( _
    entry As PackageEntry _
)
Visual C++
public:
virtual void Put(
    PackageEntry^ entry
)

Parameters

entry
Type: Sitecore.Install.Framework..::..PackageEntry
The entry.

See Also

FileInstaller Class
Put Overload
Sitecore.Install.Files Namespace


FileInstaller Properties

[image] [image]

Sitecore 6.4.1 API
FileInstaller Properties
FileInstaller Class See Also Send Feedback

The FileInstaller type exposes the following members.

Properties

 | Name | Description
Public property | Context | Gets the context. (Inherited from AdvancedBaseSink<(Of <(<'T, ContextType>)>)>.)
Public property | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

FileInstaller Class
Sitecore.Install.Files Namespace


FileInstallerContext Class

[image]

Sitecore 6.4.1 API
FileInstallerContext Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FileInstallerContext
Visual Basic
Public Class FileInstallerContext
Visual C++
public ref class FileInstallerContext

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Files..::..FileInstallerContext

See Also

FileInstallerContext Members
Sitecore.Install.Files Namespace


FileInstallerContext Members

[image] [image]

Sitecore 6.4.1 API
FileInstallerContext Members
FileInstallerContext Class Constructors Methods Fields See Also Send Feedback

The FileInstallerContext type exposes the following members.

Constructors

 | Name | Description
Public method | FileInstallerContext | Initializes a new instance of the FileInstallerContext class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | ApplyToAll |
Public field | Events |
 | FileInstallerContextKey |
Public field | Overwrite | Defines whether files should be overwritten when collision
Public field | Transaction |

See Also

FileInstallerContext Class
Sitecore.Install.Files Namespace


FileInstallerContext Constructor

[image]

Sitecore 6.4.1 API
FileInstallerContext Constructor
FileInstallerContext Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FileInstallerContext(
    IFileInstallerEvents events
)
Visual Basic
Public Sub New ( _
    events As IFileInstallerEvents _
)
Visual C++
public:
FileInstallerContext(
    IFileInstallerEvents^ events
)

Parameters

events
Type: Sitecore.Install.Files..::..IFileInstallerEvents
The events.

See Also

FileInstallerContext Class
Sitecore.Install.Files Namespace


FileInstallerContext Fields

[image] [image]

Sitecore 6.4.1 API
FileInstallerContext Fields
FileInstallerContext Class See Also Send Feedback

The FileInstallerContext type exposes the following members.

Fields

 | Name | Description
Public field | ApplyToAll |
Public field | Events |
 | FileInstallerContextKey |
Public field | Overwrite | Defines whether files should be overwritten when collision
Public field | Transaction |

See Also

FileInstallerContext Class
Sitecore.Install.Files Namespace


ApplyToAll Field

[image]

Sitecore 6.4.1 API
FileInstallerContext..::..ApplyToAll Field
FileInstallerContext Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ApplyToAll
Visual Basic
Public ApplyToAll As Boolean
Visual C++
public:
bool ApplyToAll

See Also

FileInstallerContext Class
Sitecore.Install.Files Namespace


Events Field

[image]

Sitecore 6.4.1 API
FileInstallerContext..::..Events Field
FileInstallerContext Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public readonly IFileInstallerEvents Events
Visual Basic
Public ReadOnly Events As IFileInstallerEvents
Visual C++
public:
initonly IFileInstallerEvents^ Events

See Also

FileInstallerContext Class
Sitecore.Install.Files Namespace


FileInstallerContextKey Field

[image]

Sitecore 6.4.1 API
FileInstallerContext..::..FileInstallerContextKey Field
FileInstallerContext Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly string FileInstallerContextKey
Visual Basic
Public Shared ReadOnly FileInstallerContextKey As String
Visual C++
public:
static initonly String^ FileInstallerContextKey

See Also

FileInstallerContext Class
Sitecore.Install.Files Namespace


Overwrite Field

[image]

Sitecore 6.4.1 API
FileInstallerContext..::..Overwrite Field
FileInstallerContext Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Overwrite
Visual Basic
Public Overwrite As Boolean
Visual C++
public:
bool Overwrite

See Also

FileInstallerContext Class
Sitecore.Install.Files Namespace


Transaction Field

[image]

Sitecore 6.4.1 API
FileInstallerContext..::..Transaction Field
FileInstallerContext Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public List<FileCopyInfo> Transaction
Visual Basic
Public Transaction As List(Of FileCopyInfo)
Visual C++
public:
List<FileCopyInfo^>^ Transaction

See Also

FileInstallerContext Class
Sitecore.Install.Files Namespace


FileInstallerContext Methods

[image] [image]

Sitecore 6.4.1 API
FileInstallerContext Methods
FileInstallerContext Class See Also Send Feedback

The FileInstallerContext type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileInstallerContext Class
Sitecore.Install.Files Namespace


FileSource Class

[image]

Sitecore 6.4.1 API
FileSource Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FileSource : FileSystemSource
Visual Basic
Public Class FileSource _
    Inherits FileSystemSource
Visual C++
public ref class FileSource : public FileSystemSource

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..BaseSource <(Of <(<' FileSystemInfo >)>)>
Sitecore.Install.Files..::..FileSystemSource
Sitecore.Install.Files..::..FileSource

See Also

FileSource Members
Sitecore.Install.Files Namespace


FileSource Members

[image] [image]

Sitecore 6.4.1 API
FileSource Members
FileSource Class Constructors Methods Properties See Also Send Feedback

The FileSource type exposes the following members.

Constructors

 | Name | Description
Public method | FileSource | Initializes a new instance of the FileSource class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InternalPopulate | Puts a file or a directory to the sink. (Inherited from FileSystemSource.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Populates this sourse from the specified sink. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Protected method | ResolvePath | Resolves the path. (Overrides FileSystemSource..::..ResolvePath(String).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Converter | Gets or sets the converter. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Exclude | Gets the exclude filters. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Include | Gets the include filters. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Name | Gets or sets the name. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Root | Gets or sets the root. (Inherited from FileSystemSource.)

See Also

FileSource Class
Sitecore.Install.Files Namespace


FileSource Constructor

[image]

Sitecore 6.4.1 API
FileSource Constructor
FileSource Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FileSource()
Visual Basic
Public Sub New
Visual C++
public:
FileSource()

See Also

FileSource Class
Sitecore.Install.Files Namespace


FileSource Methods

[image] [image]

Sitecore 6.4.1 API
FileSource Methods
FileSource Class See Also Send Feedback

The FileSource type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InternalPopulate | Puts a file or a directory to the sink. (Inherited from FileSystemSource.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Populates this sourse from the specified sink. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Protected method | ResolvePath | Resolves the path. (Overrides FileSystemSource..::..ResolvePath(String).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileSource Class
Sitecore.Install.Files Namespace


ResolvePath Method

[image]

Sitecore 6.4.1 API
FileSource..::..ResolvePath Method
FileSource Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override string ResolvePath(
    string path
)
Visual Basic
Protected Overrides Function ResolvePath ( _
    path As String _
) As String
Visual C++
protected:
virtual String^ ResolvePath(
    String^ path
) override

Parameters

path
Type: System..::..String
The path.

Return Value

The path.

See Also

FileSource Class
Sitecore.Install.Files Namespace


FileSource Properties

[image] [image]

Sitecore 6.4.1 API
FileSource Properties
FileSource Class See Also Send Feedback

The FileSource type exposes the following members.

Properties

 | Name | Description
Public property | Converter | Gets or sets the converter. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Exclude | Gets the exclude filters. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Include | Gets the include filters. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Name | Gets or sets the name. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Root | Gets or sets the root. (Inherited from FileSystemSource.)

See Also

FileSource Class
Sitecore.Install.Files Namespace


FileSystemSource Class

[image]

Sitecore 6.4.1 API
FileSystemSource Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FileSystemSource : BaseSource<FileSystemInfo>
Visual Basic
Public Class FileSystemSource _
    Inherits BaseSource(Of FileSystemInfo)
Visual C++
public ref class FileSystemSource : public BaseSource<FileSystemInfo^>

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..BaseSource <(Of <(<' FileSystemInfo >)>)>
Sitecore.Install.Files..::..FileSystemSource
Sitecore.Install.Files..::..FileSource

See Also

FileSystemSource Members
Sitecore.Install.Files Namespace


FileSystemSource Members

[image] [image]

Sitecore 6.4.1 API
FileSystemSource Members
FileSystemSource Class Constructors Methods Properties See Also Send Feedback

The FileSystemSource type exposes the following members.

Constructors

 | Name | Description
Public method | FileSystemSource()()()() | Initializes a new instance of the FileSystemSource class.
Public method | FileSystemSource(String) | Initializes a new instance of the FileSystemSource class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InternalPopulate | Puts a file or a directory to the sink. (Overrides BaseSource<(Of <(<'T>)>)>..::..InternalPopulate(ISink<(Of <<'(T>)>>)).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Populates this sourse from the specified sink. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Protected method | ResolvePath | Resolves the path.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Converter | Gets or sets the converter. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Exclude | Gets the exclude filters. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Include | Gets the include filters. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Name | Gets or sets the name. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Root | Gets or sets the root.

See Also

FileSystemSource Class
Sitecore.Install.Files Namespace


FileSystemSource Constructor

[image] [image]

Sitecore 6.4.1 API
FileSystemSource Constructor
FileSystemSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FileSystemSource()()()() | Initializes a new instance of the FileSystemSource class.
Public method | FileSystemSource(String) | Initializes a new instance of the FileSystemSource class.

See Also

FileSystemSource Class
FileSystemSource Members
Sitecore.Install.Files Namespace


FileSystemSource Constructor

[image]

Sitecore 6.4.1 API
FileSystemSource Constructor
FileSystemSource Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FileSystemSource()
Visual Basic
Public Sub New
Visual C++
public:
FileSystemSource()

See Also

FileSystemSource Class
FileSystemSource Overload
Sitecore.Install.Files Namespace


FileSystemSource Constructor (String)

[image]

Sitecore 6.4.1 API
FileSystemSource Constructor (String)
FileSystemSource Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FileSystemSource(
    string root
)
Visual Basic
Public Sub New ( _
    root As String _
)
Visual C++
public:
FileSystemSource(
    String^ root
)

Parameters

root
Type: System..::..String
The root.

See Also

FileSystemSource Class
FileSystemSource Overload
Sitecore.Install.Files Namespace


FileSystemSource Methods

[image] [image]

Sitecore 6.4.1 API
FileSystemSource Methods
FileSystemSource Class See Also Send Feedback

The FileSystemSource type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InternalPopulate | Puts a file or a directory to the sink. (Overrides BaseSource<(Of <(<'T>)>)>..::..InternalPopulate(ISink<(Of <<'(T>)>>)).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Populates this sourse from the specified sink. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Protected method | ResolvePath | Resolves the path.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileSystemSource Class
Sitecore.Install.Files Namespace


InternalPopulate Method

[image]

Sitecore 6.4.1 API
FileSystemSource..::..InternalPopulate Method
FileSystemSource Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void InternalPopulate(
    ISink<FileSystemInfo> sink
)
Visual Basic
Protected Overrides Sub InternalPopulate ( _
    sink As ISink(Of FileSystemInfo) _
)
Visual C++
protected:
virtual void InternalPopulate(
    ISink<FileSystemInfo^>^ sink
) override

Parameters

sink
Type: Sitecore.Install.Framework..::..ISink <(Of <(<' FileSystemInfo >)>)>
The sink

See Also

FileSystemSource Class
Sitecore.Install.Files Namespace


ResolvePath Method

[image]

Sitecore 6.4.1 API
FileSystemSource..::..ResolvePath Method
FileSystemSource Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string ResolvePath(
    string path
)
Visual Basic
Protected Overridable Function ResolvePath ( _
    path As String _
) As String
Visual C++
protected:
virtual String^ ResolvePath(
    String^ path
)

Parameters

path
Type: System..::..String
The path.

Return Value

The path.

See Also

FileSystemSource Class
Sitecore.Install.Files Namespace


FileSystemSource Properties

[image] [image]

Sitecore 6.4.1 API
FileSystemSource Properties
FileSystemSource Class See Also Send Feedback

The FileSystemSource type exposes the following members.

Properties

 | Name | Description
Public property | Converter | Gets or sets the converter. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Exclude | Gets the exclude filters. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Include | Gets the include filters. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Name | Gets or sets the name. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Root | Gets or sets the root.

See Also

FileSystemSource Class
Sitecore.Install.Files Namespace


Root Property

[image]

Sitecore 6.4.1 API
FileSystemSource..::..Root Property
FileSystemSource Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Root { get; set; }
Visual Basic
Public Property Root As String
    Get
    Set
Visual C++
public:
property String^ Root {
    String^ get ();
    void set (String^ value);
}

Field Value

The root.

See Also

FileSystemSource Class
Sitecore.Install.Files Namespace


FileToEntryConverter Class

[image]

Sitecore 6.4.1 API
FileToEntryConverter Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FileToEntryConverter : RawFileToEntryConverter
Visual Basic
Public Class FileToEntryConverter _
    Inherits RawFileToEntryConverter
Visual C++
public ref class FileToEntryConverter : public RawFileToEntryConverter

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..BaseConverter <(Of <(<' FileSystemInfo >)>)>
Sitecore.Install.Files..::..RawFileToEntryConverter
Sitecore.Install.Files..::..FileToEntryConverter

See Also

FileToEntryConverter Members
Sitecore.Install.Files Namespace


FileToEntryConverter Members

[image] [image]

Sitecore 6.4.1 API
FileToEntryConverter Members
FileToEntryConverter Class Constructors Methods Properties See Also Send Feedback

The FileToEntryConverter type exposes the following members.

Constructors

 | Name | Description
Public method | FileToEntryConverter | Initializes a new instance of the FileToEntryConverter class.

Methods

 | Name | Description
Protected method | ApplyTransforms(PackageEntry, IProcessingContext) | Applies the transform. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public method | Convert | Converts the specified entry. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttribute | Gets the value of the attribute. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InternalConvert | Converts a file into package entry. (Inherited from RawFileToEntryConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReducePath | Reduces the path. (Inherited from RawFileToEntryConverter.)
Protected method | ResolvePath | Resolves the path. (Overrides RawFileToEntryConverter..::..ResolvePath(String).)
Public method | SetAttribute | Sets the value of the attribute. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Protected property | AutoApplyTransforms | Gets a value indicating whether the BaseConverter<(Of <(<'T>)>)> converter transforms should be applied by BaseConverter, not the derived class. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public property | Root | Gets or sets the root. (Inherited from RawFileToEntryConverter.)
Public property | Transforms | Gets the transforms. (Inherited from BaseConverter<(Of <(<'T>)>)>.)

See Also

FileToEntryConverter Class
Sitecore.Install.Files Namespace


FileToEntryConverter Constructor

[image]

Sitecore 6.4.1 API
FileToEntryConverter Constructor
FileToEntryConverter Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FileToEntryConverter()
Visual Basic
Public Sub New
Visual C++
public:
FileToEntryConverter()

See Also

FileToEntryConverter Class
Sitecore.Install.Files Namespace


ResolvePath Method

[image]

Sitecore 6.4.1 API
FileToEntryConverter..::..ResolvePath Method
FileToEntryConverter Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override string ResolvePath(
    string path
)
Visual Basic
Protected Overrides Function ResolvePath ( _
    path As String _
) As String
Visual C++
protected:
virtual String^ ResolvePath(
    String^ path
) override

Parameters

path
Type: System..::..String
The path.

Return Value

The resolved path.

See Also

FileToEntryConverter Class
Sitecore.Install.Files Namespace


FileToEntryConverter Properties

[image] [image]

Sitecore 6.4.1 API
FileToEntryConverter Properties
FileToEntryConverter Class See Also Send Feedback

The FileToEntryConverter type exposes the following members.

Properties

 | Name | Description
Protected property | AutoApplyTransforms | Gets a value indicating whether the BaseConverter<(Of <(<'T>)>)> converter transforms should be applied by BaseConverter, not the derived class. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public property | Root | Gets or sets the root. (Inherited from RawFileToEntryConverter.)
Public property | Transforms | Gets the transforms. (Inherited from BaseConverter<(Of <(<'T>)>)>.)

See Also

FileToEntryConverter Class
Sitecore.Install.Files Namespace


IFileInstallerEvents Interface

[image]

Sitecore 6.4.1 API
IFileInstallerEvents Interface
Members See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IFileInstallerEvents
Visual Basic
Public Interface IFileInstallerEvents
Visual C++
public interface class IFileInstallerEvents

See Also

IFileInstallerEvents Members
Sitecore.Install.Files Namespace


IFileInstallerEvents Members

[image] [image]

Sitecore 6.4.1 API
IFileInstallerEvents Members
IFileInstallerEvents Interface Methods See Also Send Feedback

The IFileInstallerEvents type exposes the following members.

Methods

 | Name | Description
Public method | BeforeCommit | Event fired before starting the process of actually installing files to their locations in the site.
Public method | RequestOverwrite | Requests calling party for overwrite event

See Also

IFileInstallerEvents Interface
Sitecore.Install.Files Namespace


IFileInstallerEvents Methods

[image] [image]

Sitecore 6.4.1 API
IFileInstallerEvents Methods
IFileInstallerEvents Interface See Also Send Feedback

The IFileInstallerEvents type exposes the following members.

Methods

 | Name | Description
Public method | BeforeCommit | Event fired before starting the process of actually installing files to their locations in the site.
Public method | RequestOverwrite | Requests calling party for overwrite event

See Also

IFileInstallerEvents Interface
Sitecore.Install.Files Namespace


RequestOverwrite Method

[image]

Sitecore 6.4.1 API
IFileInstallerEvents..::..RequestOverwrite Method
IFileInstallerEvents Interface See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
Pair<bool, bool> RequestOverwrite(
    string virtualPath,
    IProcessingContext context
)
Visual Basic
Function RequestOverwrite ( _
    virtualPath As String, _
    context As IProcessingContext _
) As Pair(Of Boolean, Boolean)
Visual C++
Pair<bool, bool>^ RequestOverwrite(
    String^ virtualPath,
    IProcessingContext^ context
)

Parameters

virtualPath
Type: System..::..String
File path which is subject of request
context
Type: Sitecore.Install.Framework..::..IProcessingContext
Processing context

Return Value

A pair of bools:
  • First: Whether overwrite is allowed or not
  • Second: Whether decision should be applied to all subsequent files

See Also

IFileInstallerEvents Interface
Sitecore.Install.Files Namespace


MappedFileProvider Class

[image]

Sitecore 6.4.1 API
MappedFileProvider Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class MappedFileProvider : IStreamProvider
Visual Basic
Public Class MappedFileProvider _
    Implements IStreamProvider
Visual C++
public ref class MappedFileProvider : IStreamProvider

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Files..::..MappedFileProvider

See Also

MappedFileProvider Members
Sitecore.Install.Files Namespace


MappedFileProvider Members

[image] [image]

Sitecore 6.4.1 API
MappedFileProvider Members
MappedFileProvider Class Constructors Methods See Also Send Feedback

The MappedFileProvider type exposes the following members.

Constructors

 | Name | Description
Public method | MappedFileProvider | Initializes a new instance of the MappedFileProvider class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStream | Gets the stream from a file by file name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MappedFileProvider Class
Sitecore.Install.Files Namespace


MappedFileProvider Constructor

[image]

Sitecore 6.4.1 API
MappedFileProvider Constructor
MappedFileProvider Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MappedFileProvider()
Visual Basic
Public Sub New
Visual C++
public:
MappedFileProvider()

See Also

MappedFileProvider Class
Sitecore.Install.Files Namespace


GetStream Method

[image]

Sitecore 6.4.1 API
MappedFileProvider..::..GetStream Method
MappedFileProvider Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Stream GetStream(
    string name
)
Visual Basic
Public Function GetStream ( _
    name As String _
) As Stream
Visual C++
public:
virtual Stream^ GetStream(
    String^ name
) sealed

Parameters

name
Type: System..::..String
File name.

Return Value

The stream.

Implements

IStreamProvider..::..GetStream(String)

See Also

MappedFileProvider Class
Sitecore.Install.Files Namespace


PathUtils Class

[image]

Sitecore 6.4.1 API
PathUtils Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class PathUtils
Visual Basic
Public NotInheritable Class PathUtils
Visual C++
public ref class PathUtils abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Files..::..PathUtils

See Also

PathUtils Members
Sitecore.Install.Files Namespace


PathUtils Members

[image] [image]

Sitecore 6.4.1 API
PathUtils Members
PathUtils Class Methods Fields Properties See Also Send Feedback

The PathUtils type exposes the following members.

Methods

Name | Description
DemangleDirectoryPath | Demangles the directory path.
IsDirectoryPath | Determines whether [is directory path] [the specified path].
MangleDirectoryPath | Mangles the directory path.
MapPath | Maps the path.
ReducePath | Reduces the path.
UnifyPath | Unifies the path.
UnifyPathSeparators | Unifies the path separators.
Unmap | Unmaps the specified path.

Fields

Name | Description
DirectorySuffix | Directory suffix

Properties

Name | Description
SiteRoot | Gets the site root.

See Also

PathUtils Class
Sitecore.Install.Files Namespace


PathUtils Fields

[image] [image]

Sitecore 6.4.1 API
PathUtils Fields
PathUtils Class See Also Send Feedback

The PathUtils type exposes the following members.

Fields

Name | Description
DirectorySuffix | Directory suffix

See Also

PathUtils Class
Sitecore.Install.Files Namespace


PathUtils Methods

[image] [image]

Sitecore 6.4.1 API
PathUtils Methods
PathUtils Class See Also Send Feedback

The PathUtils type exposes the following members.

Methods

Name | Description
DemangleDirectoryPath | Demangles the directory path.
IsDirectoryPath | Determines whether [is directory path] [the specified path].
MangleDirectoryPath | Mangles the directory path.
MapPath | Maps the path.
ReducePath | Reduces the path.
UnifyPath | Unifies the path.
UnifyPathSeparators | Unifies the path separators.
Unmap | Unmaps the specified path.

See Also

PathUtils Class
Sitecore.Install.Files Namespace


DemangleDirectoryPath Method

[image]

Sitecore 6.4.1 API
PathUtils..::..DemangleDirectoryPath Method
PathUtils Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string DemangleDirectoryPath(
    string path
)
Visual Basic
Public Shared Function DemangleDirectoryPath ( _
    path As String _
) As String
Visual C++
public:
static String^ DemangleDirectoryPath(
    String^ path
)

Parameters

path
Type: System..::..String
The path.

Return Value

The directory path.

See Also

PathUtils Class
Sitecore.Install.Files Namespace


IsDirectoryPath Method

[image]

Sitecore 6.4.1 API
PathUtils..::..IsDirectoryPath Method
PathUtils Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsDirectoryPath(
    string path
)
Visual Basic
Public Shared Function IsDirectoryPath ( _
    path As String _
) As Boolean
Visual C++
public:
static bool IsDirectoryPath(
    String^ path
)

Parameters

path
Type: System..::..String
The path.

Return Value

true if [is directory path] [the specified path]; otherwise, false.

See Also

PathUtils Class
Sitecore.Install.Files Namespace


MangleDirectoryPath Method

[image]

Sitecore 6.4.1 API
PathUtils..::..MangleDirectoryPath Method
PathUtils Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string MangleDirectoryPath(
    string path
)
Visual Basic
Public Shared Function MangleDirectoryPath ( _
    path As String _
) As String
Visual C++
public:
static String^ MangleDirectoryPath(
    String^ path
)

Parameters

path
Type: System..::..String
The path.

Return Value

The directory path.

See Also

PathUtils Class
Sitecore.Install.Files Namespace


MapPath Method

[image]

Sitecore 6.4.1 API
PathUtils..::..MapPath Method
PathUtils Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string MapPath(
    string path
)
Visual Basic
Public Shared Function MapPath ( _
    path As String _
) As String
Visual C++
public:
static String^ MapPath(
    String^ path
)

Parameters

path
Type: System..::..String
The path.

Return Value

The path.

See Also

PathUtils Class
Sitecore.Install.Files Namespace


ReducePath Method

[image]

Sitecore 6.4.1 API
PathUtils..::..ReducePath Method
PathUtils Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ReducePath(
    string root,
    string fullname
)
Visual Basic
Public Shared Function ReducePath ( _
    root As String, _
    fullname As String _
) As String
Visual C++
public:
static String^ ReducePath(
    String^ root,
    String^ fullname
)

Parameters

root
Type: System..::..String
The root.
fullname
Type: System..::..String
The fullname.

Return Value

The path.

See Also

PathUtils Class
Sitecore.Install.Files Namespace


UnifyPath Method

[image]

Sitecore 6.4.1 API
PathUtils..::..UnifyPath Method
PathUtils Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string UnifyPath(
    string path
)
Visual Basic
Public Shared Function UnifyPath ( _
    path As String _
) As String
Visual C++
public:
static String^ UnifyPath(
    String^ path
)

Parameters

path
Type: System..::..String
The path.

Return Value

The path.

See Also

PathUtils Class
Sitecore.Install.Files Namespace


UnifyPathSeparators Method

[image]

Sitecore 6.4.1 API
PathUtils..::..UnifyPathSeparators Method
PathUtils Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string UnifyPathSeparators(
    string path
)
Visual Basic
Public Shared Function UnifyPathSeparators ( _
    path As String _
) As String
Visual C++
public:
static String^ UnifyPathSeparators(
    String^ path
)

Parameters

path
Type: System..::..String
The path.

Return Value

The unified path.

See Also

PathUtils Class
Sitecore.Install.Files Namespace


SiteRoot Property

[image]

Sitecore 6.4.1 API
PathUtils..::..SiteRoot Property
PathUtils Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string SiteRoot { get; }
Visual Basic
Public Shared ReadOnly Property SiteRoot As String
    Get
Visual C++
public:
static property String^ SiteRoot {
    String^ get ();
}

Field Value

The site root.

See Also

PathUtils Class
Sitecore.Install.Files Namespace


RawFileSystemWriter Class

[image]

Sitecore 6.4.1 API
RawFileSystemWriter Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RawFileSystemWriter : BaseSink<PackageEntry>
Visual Basic
Public Class RawFileSystemWriter _
    Inherits BaseSink(Of PackageEntry)
Visual C++
public ref class RawFileSystemWriter : public BaseSink<PackageEntry^>

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..BaseSink <(Of <(<' PackageEntry >)>)>
Sitecore.Install.Files..::..RawFileSystemWriter

See Also

RawFileSystemWriter Members
Sitecore.Install.Files Namespace


RawFileSystemWriter Constructor

[image] [image]

Sitecore 6.4.1 API
RawFileSystemWriter Constructor
RawFileSystemWriter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RawFileSystemWriter()()()() | Initializes a new instance of the RawFileSystemWriter class.
Public method | RawFileSystemWriter(String) | Initializes a new instance of the RawFileSystemWriter class.

See Also

RawFileSystemWriter Class
RawFileSystemWriter Members
Sitecore.Install.Files Namespace


RawFileSystemWriter Constructor

[image]

Sitecore 6.4.1 API
RawFileSystemWriter Constructor
RawFileSystemWriter Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RawFileSystemWriter()
Visual Basic
Public Sub New
Visual C++
public:
RawFileSystemWriter()

See Also

RawFileSystemWriter Class
RawFileSystemWriter Overload
Sitecore.Install.Files Namespace


RawFileSystemWriter Constructor (String)

[image]

Sitecore 6.4.1 API
RawFileSystemWriter Constructor (String)
RawFileSystemWriter Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RawFileSystemWriter(
    string root
)
Visual Basic
Public Sub New ( _
    root As String _
)
Visual C++
public:
RawFileSystemWriter(
    String^ root
)

Parameters

root
Type: System..::..String
The root.

See Also

RawFileSystemWriter Class
RawFileSystemWriter Overload
Sitecore.Install.Files Namespace


RawFileSystemWriter Methods

[image] [image]

Sitecore 6.4.1 API
RawFileSystemWriter Methods
RawFileSystemWriter Class See Also Send Feedback

The RawFileSystemWriter type exposes the following members.

Methods

 | Name | Description
Protected method | AssertInit | Asserts the init. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finishes the sink. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Flush | Flushes the sink (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this instance. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put | Install a file from a package entry. (Overrides BaseSink<(Of <(<'T>)>)>..::..Put(T).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RawFileSystemWriter Class
Sitecore.Install.Files Namespace


Put Method

[image]

Sitecore 6.4.1 API
RawFileSystemWriter..::..Put Method
RawFileSystemWriter Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Put(
    PackageEntry entry
)
Visual Basic
Public Overrides Sub Put ( _
    entry As PackageEntry _
)
Visual C++
public:
virtual void Put(
    PackageEntry^ entry
) override

Parameters

entry
Type: Sitecore.Install.Framework..::..PackageEntry
The entry.

Implements

ISink<(Of <(<'T>)>)>..::..Put(T)

See Also

RawFileSystemWriter Class
Sitecore.Install.Files Namespace


RawFileSystemWriter Properties

[image] [image]

Sitecore 6.4.1 API
RawFileSystemWriter Properties
RawFileSystemWriter Class See Also Send Feedback

The RawFileSystemWriter type exposes the following members.

Properties

 | Name | Description
Public property | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | Root | Gets or sets the root.

See Also

RawFileSystemWriter Class
Sitecore.Install.Files Namespace


Root Property

[image]

Sitecore 6.4.1 API
RawFileSystemWriter..::..Root Property
RawFileSystemWriter Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Root { get; set; }
Visual Basic
Public Property Root As String
    Get
    Set
Visual C++
public:
property String^ Root {
    String^ get ();
    void set (String^ value);
}

Field Value

The root.

See Also

RawFileSystemWriter Class
Sitecore.Install.Files Namespace


RawFileToEntryConverter Class

[image]

Sitecore 6.4.1 API
RawFileToEntryConverter Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RawFileToEntryConverter : BaseConverter<FileSystemInfo>
Visual Basic
Public Class RawFileToEntryConverter _
    Inherits BaseConverter(Of FileSystemInfo)
Visual C++
public ref class RawFileToEntryConverter : public BaseConverter<FileSystemInfo^>

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..BaseConverter <(Of <(<' FileSystemInfo >)>)>
Sitecore.Install.Files..::..RawFileToEntryConverter
Sitecore.Install.Files..::..FileToEntryConverter

See Also

RawFileToEntryConverter Members
Sitecore.Install.Files Namespace


RawFileToEntryConverter Members

[image] [image]

Sitecore 6.4.1 API
RawFileToEntryConverter Members
RawFileToEntryConverter Class Constructors Methods Properties See Also Send Feedback

The RawFileToEntryConverter type exposes the following members.

Constructors

 | Name | Description
Public method | RawFileToEntryConverter()()()() | Initializes a new instance of the RawFileToEntryConverter class.
Public method | RawFileToEntryConverter(String, String) | Initializes a new instance of the RawFileToEntryConverter class.

Methods

 | Name | Description
Protected method | ApplyTransforms(PackageEntry, IProcessingContext) | Applies the transform. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public method | Convert | Converts the specified entry. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttribute | Gets the value of the attribute. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InternalConvert | Converts a file into package entry. (Overrides BaseConverter<(Of <(<'T>)>)>..::..InternalConvert(T, IProcessingContext).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReducePath | Reduces the path.
Protected method | ResolvePath | Resolves the path.
Public method | SetAttribute | Sets the value of the attribute. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Protected property | AutoApplyTransforms | Gets a value indicating whether the BaseConverter<(Of <(<'T>)>)> converter transforms should be applied by BaseConverter, not the derived class. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public property | Root | Gets or sets the root.
Public property | Transforms | Gets the transforms. (Inherited from BaseConverter<(Of <(<'T>)>)>.)

See Also

RawFileToEntryConverter Class
Sitecore.Install.Files Namespace


RawFileToEntryConverter Constructor

[image] [image]

Sitecore 6.4.1 API
RawFileToEntryConverter Constructor
RawFileToEntryConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RawFileToEntryConverter()()()() | Initializes a new instance of the RawFileToEntryConverter class.
Public method | RawFileToEntryConverter(String, String) | Initializes a new instance of the RawFileToEntryConverter class.

See Also

RawFileToEntryConverter Class
RawFileToEntryConverter Members
Sitecore.Install.Files Namespace


RawFileToEntryConverter Constructor

[image]

Sitecore 6.4.1 API
RawFileToEntryConverter Constructor
RawFileToEntryConverter Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RawFileToEntryConverter()
Visual Basic
Public Sub New
Visual C++
public:
RawFileToEntryConverter()

See Also

RawFileToEntryConverter Class
RawFileToEntryConverter Overload
Sitecore.Install.Files Namespace


RawFileToEntryConverter Constructor (String, String)

[image]

Sitecore 6.4.1 API
RawFileToEntryConverter Constructor (String, String)
RawFileToEntryConverter Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RawFileToEntryConverter(
    string root,
    string prefix
)
Visual Basic
Public Sub New ( _
    root As String, _
    prefix As String _
)
Visual C++
public:
RawFileToEntryConverter(
    String^ root,
    String^ prefix
)

Parameters

root
Type: System..::..String
The root.
prefix
Type: System..::..String
The prefix.

See Also

RawFileToEntryConverter Class
RawFileToEntryConverter Overload
Sitecore.Install.Files Namespace


RawFileToEntryConverter Methods

[image] [image]

Sitecore 6.4.1 API
RawFileToEntryConverter Methods
RawFileToEntryConverter Class See Also Send Feedback

The RawFileToEntryConverter type exposes the following members.

Methods

 | Name | Description
Protected method | ApplyTransforms(PackageEntry, IProcessingContext) | Applies the transform. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public method | Convert | Converts the specified entry. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttribute | Gets the value of the attribute. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InternalConvert | Converts a file into package entry. (Overrides BaseConverter<(Of <(<'T>)>)>..::..InternalConvert(T, IProcessingContext).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReducePath | Reduces the path.
Protected method | ResolvePath | Resolves the path.
Public method | SetAttribute | Sets the value of the attribute. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RawFileToEntryConverter Class
Sitecore.Install.Files Namespace


ResolvePath Method

[image]

Sitecore 6.4.1 API
RawFileToEntryConverter..::..ResolvePath Method
RawFileToEntryConverter Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string ResolvePath(
    string path
)
Visual Basic
Protected Overridable Function ResolvePath ( _
    path As String _
) As String
Visual C++
protected:
virtual String^ ResolvePath(
    String^ path
)

Parameters

path
Type: System..::..String
The path.

Return Value

The resolved path.

See Also

RawFileToEntryConverter Class
Sitecore.Install.Files Namespace


RawFileToEntryConverter Properties

[image] [image]

Sitecore 6.4.1 API
RawFileToEntryConverter Properties
RawFileToEntryConverter Class See Also Send Feedback

The RawFileToEntryConverter type exposes the following members.

Properties

 | Name | Description
Protected property | AutoApplyTransforms | Gets a value indicating whether the BaseConverter<(Of <(<'T>)>)> converter transforms should be applied by BaseConverter, not the derived class. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public property | Root | Gets or sets the root.
Public property | Transforms | Gets the transforms. (Inherited from BaseConverter<(Of <(<'T>)>)>.)

See Also

RawFileToEntryConverter Class
Sitecore.Install.Files Namespace


Root Property

[image]

Sitecore 6.4.1 API
RawFileToEntryConverter..::..Root Property
RawFileToEntryConverter Class See Also Send Feedback

Namespace: Sitecore.Install.Files
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Root { get; set; }
Visual Basic
Public Property Root As String
    Get
    Set
Visual C++
public:
property String^ Root {
    String^ get ();
    void set (String^ value);
}

Field Value

The root.

See Also

RawFileToEntryConverter Class
Sitecore.Install.Files Namespace


ExplicitKeyFilter Class

[image]

Sitecore 6.4.1 API
ExplicitKeyFilter Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ExplicitKeyFilter : IFilter
Visual Basic
Public Class ExplicitKeyFilter _
    Implements IFilter
Visual C++
public ref class ExplicitKeyFilter : IFilter

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Filters..::..ExplicitKeyFilter

See Also

ExplicitKeyFilter Members
Sitecore.Install.Filters Namespace


ExplicitKeyFilter Members

[image] [image]

Sitecore 6.4.1 API
ExplicitKeyFilter Members
ExplicitKeyFilter Class Constructors Methods Properties See Also Send Feedback

The ExplicitKeyFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ExplicitKeyFilter | Initializes a new instance of the ExplicitKeyFilter class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Qualify | Qualifies the specified instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | Keys | Gets the keys.

See Also

ExplicitKeyFilter Class
Sitecore.Install.Filters Namespace


ExplicitKeyFilter Constructor

[image]

Sitecore 6.4.1 API
ExplicitKeyFilter Constructor
ExplicitKeyFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ExplicitKeyFilter()
Visual Basic
Public Sub New
Visual C++
public:
ExplicitKeyFilter()

See Also

ExplicitKeyFilter Class
Sitecore.Install.Filters Namespace


ExplicitKeyFilter Methods

[image] [image]

Sitecore 6.4.1 API
ExplicitKeyFilter Methods
ExplicitKeyFilter Class See Also Send Feedback

The ExplicitKeyFilter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Qualify | Qualifies the specified instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExplicitKeyFilter Class
Sitecore.Install.Filters Namespace


Qualify Method

[image]

Sitecore 6.4.1 API
ExplicitKeyFilter..::..Qualify Method
ExplicitKeyFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Qualify(
    Object instance,
    IProcessingContext context
)
Visual Basic
Public Function Qualify ( _
    instance As Object, _
    context As IProcessingContext _
) As Boolean
Visual C++
public:
virtual bool Qualify(
    Object^ instance,
    IProcessingContext^ context
) sealed

Parameters

instance
Type: System..::..Object
The instance.
context
Type: Sitecore.Install.Framework..::..IProcessingContext
The processing context.

Return Value

Qualification result.

Implements

IFilter..::..Qualify(Object, IProcessingContext)

See Also

ExplicitKeyFilter Class
Sitecore.Install.Filters Namespace


ExplicitKeyFilter Properties

[image] [image]

Sitecore 6.4.1 API
ExplicitKeyFilter Properties
ExplicitKeyFilter Class See Also Send Feedback

The ExplicitKeyFilter type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | Keys | Gets the keys.

See Also

ExplicitKeyFilter Class
Sitecore.Install.Filters Namespace


IsEmpty Property

[image]

Sitecore 6.4.1 API
ExplicitKeyFilter..::..IsEmpty Property
ExplicitKeyFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get () sealed;
}

Field Value

true if this instance is empty; otherwise, false.

Implements

IFilter..::..IsEmpty

See Also

ExplicitKeyFilter Class
Sitecore.Install.Filters Namespace


FileDateFilter Class

[image]

Sitecore 6.4.1 API
FileDateFilter Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FileDateFilter : IFilter
Visual Basic
Public Class FileDateFilter _
    Implements IFilter
Visual C++
public ref class FileDateFilter : IFilter

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Filters..::..FileDateFilter

See Also

FileDateFilter Members
Sitecore.Install.Filters Namespace


FileDateFilter Members

[image] [image]

Sitecore 6.4.1 API
FileDateFilter Members
FileDateFilter Class Constructors Methods Fields Properties See Also Send Feedback

The FileDateFilter type exposes the following members.

Constructors

 | Name | Description
Public method | FileDateFilter()()()() | Initializes a new instance of the FileDateFilter class.
Public method | FileDateFilter(FileDateFilter..::..FileDateFilterType) | Initializes a new instance of the FileDateFilter class.
Public method | FileDateFilter(String, String, FileDateFilter..::..FileDateFilterType) | Initializes a new instance of the FileDateFilter class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Qualify | Qualifies the specified instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
NoValue |

Properties

 | Name | Description
Public property | ActionDateFrom | Gets or sets the action date from.
Public property | ActionDateTo | Gets or sets the action date to.
Public property | FilterType | Gets or sets the type of the filter.
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | NotOlderThan | Gets or sets the value that indicates time pariod, calculated in days.

See Also

FileDateFilter Class
Sitecore.Install.Filters Namespace


FileDateFilter Constructor

[image] [image]

Sitecore 6.4.1 API
FileDateFilter Constructor
FileDateFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FileDateFilter()()()() | Initializes a new instance of the FileDateFilter class.
Public method | FileDateFilter(FileDateFilter..::..FileDateFilterType) | Initializes a new instance of the FileDateFilter class.
Public method | FileDateFilter(String, String, FileDateFilter..::..FileDateFilterType) | Initializes a new instance of the FileDateFilter class.

See Also

FileDateFilter Class
FileDateFilter Members
Sitecore.Install.Filters Namespace


FileDateFilter Constructor

[image]

Sitecore 6.4.1 API
FileDateFilter Constructor
FileDateFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FileDateFilter()
Visual Basic
Public Sub New
Visual C++
public:
FileDateFilter()

See Also

FileDateFilter Class
FileDateFilter Overload
Sitecore.Install.Filters Namespace


FileDateFilter Constructor (FileDateFilter.FileDateFilterType)

[image]

Sitecore 6.4.1 API
FileDateFilter Constructor (FileDateFilter..::..FileDateFilterType)
FileDateFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FileDateFilter(
    FileDateFilter..::..FileDateFilterType filterType
)
Visual Basic
Public Sub New ( _
    filterType As FileDateFilter..::..FileDateFilterType _
)
Visual C++
public:
FileDateFilter(
    FileDateFilter..::..FileDateFilterType filterType
)

Parameters

filterType
Type: Sitecore.Install.Filters..::..FileDateFilter..::..FileDateFilterType
Type of the filter.

See Also

FileDateFilter Class
FileDateFilter Overload
Sitecore.Install.Filters Namespace


FileDateFilter Constructor (String, String, FileDateFilter.FileDateFilterType)

[image]

Sitecore 6.4.1 API
FileDateFilter Constructor (String, String, FileDateFilter..::..FileDateFilterType)
FileDateFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FileDateFilter(
    string actionDateFrom,
    string actionDateTo,
    FileDateFilter..::..FileDateFilterType filterType
)
Visual Basic
Public Sub New ( _
    actionDateFrom As String, _
    actionDateTo As String, _
    filterType As FileDateFilter..::..FileDateFilterType _
)
Visual C++
public:
FileDateFilter(
    String^ actionDateFrom,
    String^ actionDateTo,
    FileDateFilter..::..FileDateFilterType filterType
)

Parameters

actionDateFrom
Type: System..::..String
The action date from.
actionDateTo
Type: System..::..String
The action date to.
filterType
Type: Sitecore.Install.Filters..::..FileDateFilter..::..FileDateFilterType
Type of the filter.

See Also

FileDateFilter Class
FileDateFilter Overload
Sitecore.Install.Filters Namespace


FileDateFilter Fields

[image] [image]

Sitecore 6.4.1 API
FileDateFilter Fields
FileDateFilter Class See Also Send Feedback

The FileDateFilter type exposes the following members.

Fields

Name | Description
NoValue |

See Also

FileDateFilter Class
Sitecore.Install.Filters Namespace


NoValue Field

[image]

Sitecore 6.4.1 API
FileDateFilter..::..NoValue Field
FileDateFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string NoValue
Visual Basic
Public Shared NoValue As String
Visual C++
public:
static String^ NoValue

See Also

FileDateFilter Class
Sitecore.Install.Filters Namespace


FileDateFilter Methods

[image] [image]

Sitecore 6.4.1 API
FileDateFilter Methods
FileDateFilter Class See Also Send Feedback

The FileDateFilter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Qualify | Qualifies the specified instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileDateFilter Class
Sitecore.Install.Filters Namespace


Qualify Method

[image]

Sitecore 6.4.1 API
FileDateFilter..::..Qualify Method
FileDateFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Qualify(
    Object instance,
    IProcessingContext context
)
Visual Basic
Public Function Qualify ( _
    instance As Object, _
    context As IProcessingContext _
) As Boolean
Visual C++
public:
virtual bool Qualify(
    Object^ instance,
    IProcessingContext^ context
) sealed

Parameters

instance
Type: System..::..Object
The instance.
context
Type: Sitecore.Install.Framework..::..IProcessingContext
The processing context.

Return Value

Qualification result.

Implements

IFilter..::..Qualify(Object, IProcessingContext)

See Also

FileDateFilter Class
Sitecore.Install.Filters Namespace


FileDateFilter Properties

[image] [image]

Sitecore 6.4.1 API
FileDateFilter Properties
FileDateFilter Class See Also Send Feedback

The FileDateFilter type exposes the following members.

Properties

 | Name | Description
Public property | ActionDateFrom | Gets or sets the action date from.
Public property | ActionDateTo | Gets or sets the action date to.
Public property | FilterType | Gets or sets the type of the filter.
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | NotOlderThan | Gets or sets the value that indicates time pariod, calculated in days.

See Also

FileDateFilter Class
Sitecore.Install.Filters Namespace


ActionDateFrom Property

[image]

Sitecore 6.4.1 API
FileDateFilter..::..ActionDateFrom Property
FileDateFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ActionDateFrom { get; set; }
Visual Basic
Public Property ActionDateFrom As String
    Get
    Set
Visual C++
public:
property String^ ActionDateFrom {
    String^ get ();
    void set (String^ value);
}

Field Value

The action date from.

See Also

FileDateFilter Class
Sitecore.Install.Filters Namespace


ActionDateTo Property

[image]

Sitecore 6.4.1 API
FileDateFilter..::..ActionDateTo Property
FileDateFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ActionDateTo { get; set; }
Visual Basic
Public Property ActionDateTo As String
    Get
    Set
Visual C++
public:
property String^ ActionDateTo {
    String^ get ();
    void set (String^ value);
}

Field Value

The action date to.

See Also

FileDateFilter Class
Sitecore.Install.Filters Namespace


FilterType Property

[image]

Sitecore 6.4.1 API
FileDateFilter..::..FilterType Property
FileDateFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FileDateFilter..::..FileDateFilterType FilterType { get; set; }
Visual Basic
Public Property FilterType As FileDateFilter..::..FileDateFilterType
    Get
    Set
Visual C++
public:
property FileDateFilter..::..FileDateFilterType FilterType {
    FileDateFilter..::..FileDateFilterType get ();
    void set (FileDateFilter..::..FileDateFilterType value);
}

Field Value

The type of the filter.

See Also

FileDateFilter Class
Sitecore.Install.Filters Namespace


IsEmpty Property

[image]

Sitecore 6.4.1 API
FileDateFilter..::..IsEmpty Property
FileDateFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get () sealed;
}

Field Value

true if this instance is empty; otherwise, false.

Implements

IFilter..::..IsEmpty

See Also

FileDateFilter Class
Sitecore.Install.Filters Namespace


NotOlderThan Property

[image]

Sitecore 6.4.1 API
FileDateFilter..::..NotOlderThan Property
FileDateFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string NotOlderThan { get; set; }
Visual Basic
Public Property NotOlderThan As String
    Get
    Set
Visual C++
public:
property String^ NotOlderThan {
    String^ get ();
    void set (String^ value);
}

Field Value

Indicates time pariod, calculated in days.

See Also

FileDateFilter Class
Sitecore.Install.Filters Namespace


FileDateFilter.FileDateFilterType Enumeration

[image]

Sitecore 6.4.1 API
FileDateFilter..::..FileDateFilterType Enumeration
FileDateFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum FileDateFilterType
Visual Basic
Public Enumeration FileDateFilterType
Visual C++
public enum class FileDateFilterType

Members

Member name | Value | Description
CreatedFilter | 0 | Filter will be checking the date of the creation
ModifiedFilter | 1 | Filter will be checking the date of the modification

See Also

Sitecore.Install.Filters Namespace


FileNameFilter Class

[image]

Sitecore 6.4.1 API
FileNameFilter Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FileNameFilter : IFilter
Visual Basic
Public Class FileNameFilter _
    Implements IFilter
Visual C++
public ref class FileNameFilter : IFilter

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Filters..::..FileNameFilter

See Also

FileNameFilter Members
Sitecore.Install.Filters Namespace


FileNameFilter Members

[image] [image]

Sitecore 6.4.1 API
FileNameFilter Members
FileNameFilter Class Constructors Methods Properties See Also Send Feedback

The FileNameFilter type exposes the following members.

Constructors

 | Name | Description
Public method | FileNameFilter()()()() | Initializes a new instance of the FileNameFilter class.
Public method | FileNameFilter(String) | Initializes a new instance of the FileNameFilter class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateRegex | Generates the regex.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Qualify | Qualifies the specified instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AcceptDirectories | Always accept directories regardless of name pattern match
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | Pattern | Gets or sets the pattern.
Public property | RegexPattern | Gets the regex pattern.

See Also

FileNameFilter Class
Sitecore.Install.Filters Namespace


FileNameFilter Constructor

[image] [image]

Sitecore 6.4.1 API
FileNameFilter Constructor
FileNameFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FileNameFilter()()()() | Initializes a new instance of the FileNameFilter class.
Public method | FileNameFilter(String) | Initializes a new instance of the FileNameFilter class.

See Also

FileNameFilter Class
FileNameFilter Members
Sitecore.Install.Filters Namespace


FileNameFilter Constructor

[image]

Sitecore 6.4.1 API
FileNameFilter Constructor
FileNameFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FileNameFilter()
Visual Basic
Public Sub New
Visual C++
public:
FileNameFilter()

See Also

FileNameFilter Class
FileNameFilter Overload
Sitecore.Install.Filters Namespace


FileNameFilter Constructor (String)

[image]

Sitecore 6.4.1 API
FileNameFilter Constructor (String)
FileNameFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FileNameFilter(
    string pattern
)
Visual Basic
Public Sub New ( _
    pattern As String _
)
Visual C++
public:
FileNameFilter(
    String^ pattern
)

Parameters

pattern
Type: System..::..String
The pattern.

See Also

FileNameFilter Class
FileNameFilter Overload
Sitecore.Install.Filters Namespace


FileNameFilter Methods

[image] [image]

Sitecore 6.4.1 API
FileNameFilter Methods
FileNameFilter Class See Also Send Feedback

The FileNameFilter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateRegex | Generates the regex.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Qualify | Qualifies the specified instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileNameFilter Class
Sitecore.Install.Filters Namespace


GenerateRegex Method

[image]

Sitecore 6.4.1 API
FileNameFilter..::..GenerateRegex Method
FileNameFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GenerateRegex(
    string pattern
)
Visual Basic
Public Function GenerateRegex ( _
    pattern As String _
) As String
Visual C++
public:
String^ GenerateRegex(
    String^ pattern
)

Parameters

pattern
Type: System..::..String
The pattern.

Return Value

The regex.

See Also

FileNameFilter Class
Sitecore.Install.Filters Namespace


Qualify Method

[image]

Sitecore 6.4.1 API
FileNameFilter..::..Qualify Method
FileNameFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Qualify(
    Object instance,
    IProcessingContext context
)
Visual Basic
Public Function Qualify ( _
    instance As Object, _
    context As IProcessingContext _
) As Boolean
Visual C++
public:
virtual bool Qualify(
    Object^ instance,
    IProcessingContext^ context
) sealed

Parameters

instance
Type: System..::..Object
The instance.
context
Type: Sitecore.Install.Framework..::..IProcessingContext
The processing context.

Return Value

Qualification result.

Implements

IFilter..::..Qualify(Object, IProcessingContext)

See Also

FileNameFilter Class
Sitecore.Install.Filters Namespace


FileNameFilter Properties

[image] [image]

Sitecore 6.4.1 API
FileNameFilter Properties
FileNameFilter Class See Also Send Feedback

The FileNameFilter type exposes the following members.

Properties

 | Name | Description
Public property | AcceptDirectories | Always accept directories regardless of name pattern match
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | Pattern | Gets or sets the pattern.
Public property | RegexPattern | Gets the regex pattern.

See Also

FileNameFilter Class
Sitecore.Install.Filters Namespace


AcceptDirectories Property

[image]

Sitecore 6.4.1 API
FileNameFilter..::..AcceptDirectories Property
FileNameFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool AcceptDirectories { get; set; }
Visual Basic
Public Property AcceptDirectories As Boolean
    Get
    Set
Visual C++
public:
property bool AcceptDirectories {
    bool get ();
    void set (bool value);
}

See Also

FileNameFilter Class
Sitecore.Install.Filters Namespace


IsEmpty Property

[image]

Sitecore 6.4.1 API
FileNameFilter..::..IsEmpty Property
FileNameFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get () sealed;
}

Field Value

true if this instance is empty; otherwise, false.

Implements

IFilter..::..IsEmpty

See Also

FileNameFilter Class
Sitecore.Install.Filters Namespace


Pattern Property

[image]

Sitecore 6.4.1 API
FileNameFilter..::..Pattern Property
FileNameFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Pattern { get; set; }
Visual Basic
Public Property Pattern As String
    Get
    Set
Visual C++
public:
property String^ Pattern {
    String^ get ();
    void set (String^ value);
}

Field Value

The pattern.

See Also

FileNameFilter Class
Sitecore.Install.Filters Namespace


RegexPattern Property

[image]

Sitecore 6.4.1 API
FileNameFilter..::..RegexPattern Property
FileNameFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string RegexPattern { get; }
Visual Basic
Public ReadOnly Property RegexPattern As String
    Get
Visual C++
public:
property String^ RegexPattern {
    String^ get ();
}

Field Value

The regex pattern.

See Also

FileNameFilter Class
Sitecore.Install.Filters Namespace


FileSizeFilter Members

[image] [image]

Sitecore 6.4.1 API
FileSizeFilter Members
FileSizeFilter Class Constructors Methods Fields Properties See Also Send Feedback

The FileSizeFilter type exposes the following members.

Constructors

 | Name | Description
Public method | FileSizeFilter()()()() | Initializes a new instance of the FileSizeFilter class.
Public method | FileSizeFilter(Int32, Int32) | Initializes a new instance of the FileSizeFilter class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Qualify | Qualifies the specified instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
NoValue |

Properties

 | Name | Description
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | MaximumSize | Gets or sets the maximum size.
Public property | MinimumSize | Gets or sets the minimum size.

See Also

FileSizeFilter Class
Sitecore.Install.Filters Namespace


FileSizeFilter Constructor

[image] [image]

Sitecore 6.4.1 API
FileSizeFilter Constructor
FileSizeFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FileSizeFilter()()()() | Initializes a new instance of the FileSizeFilter class.
Public method | FileSizeFilter(Int32, Int32) | Initializes a new instance of the FileSizeFilter class.

See Also

FileSizeFilter Class
FileSizeFilter Members
Sitecore.Install.Filters Namespace


FileSizeFilter Constructor

[image]

Sitecore 6.4.1 API
FileSizeFilter Constructor
FileSizeFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FileSizeFilter()
Visual Basic
Public Sub New
Visual C++
public:
FileSizeFilter()

See Also

FileSizeFilter Class
FileSizeFilter Overload
Sitecore.Install.Filters Namespace


FileSizeFilter Constructor (Int32, Int32)

[image]

Sitecore 6.4.1 API
FileSizeFilter Constructor (Int32, Int32)
FileSizeFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FileSizeFilter(
    int minimumSize,
    int maximumSize
)
Visual Basic
Public Sub New ( _
    minimumSize As Integer, _
    maximumSize As Integer _
)
Visual C++
public:
FileSizeFilter(
    int minimumSize,
    int maximumSize
)

Parameters

minimumSize
Type: System..::..Int32
The minimum size.
maximumSize
Type: System..::..Int32
The maximum size.

See Also

FileSizeFilter Class
FileSizeFilter Overload
Sitecore.Install.Filters Namespace


FileSizeFilter Fields

[image] [image]

Sitecore 6.4.1 API
FileSizeFilter Fields
FileSizeFilter Class See Also Send Feedback

The FileSizeFilter type exposes the following members.

Fields

Name | Description
NoValue |

See Also

FileSizeFilter Class
Sitecore.Install.Filters Namespace


FileSizeFilter Methods

[image] [image]

Sitecore 6.4.1 API
FileSizeFilter Methods
FileSizeFilter Class See Also Send Feedback

The FileSizeFilter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Qualify | Qualifies the specified instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileSizeFilter Class
Sitecore.Install.Filters Namespace


Qualify Method

[image]

Sitecore 6.4.1 API
FileSizeFilter..::..Qualify Method
FileSizeFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Qualify(
    Object instance,
    IProcessingContext context
)
Visual Basic
Public Function Qualify ( _
    instance As Object, _
    context As IProcessingContext _
) As Boolean
Visual C++
public:
virtual bool Qualify(
    Object^ instance,
    IProcessingContext^ context
) sealed

Parameters

instance
Type: System..::..Object
The instance.
context
Type: Sitecore.Install.Framework..::..IProcessingContext
The processing context.

Return Value

Qualification result.

Implements

IFilter..::..Qualify(Object, IProcessingContext)

See Also

FileSizeFilter Class
Sitecore.Install.Filters Namespace


FileSizeFilter Properties

[image] [image]

Sitecore 6.4.1 API
FileSizeFilter Properties
FileSizeFilter Class See Also Send Feedback

The FileSizeFilter type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | MaximumSize | Gets or sets the maximum size.
Public property | MinimumSize | Gets or sets the minimum size.

See Also

FileSizeFilter Class
Sitecore.Install.Filters Namespace


IsEmpty Property

[image]

Sitecore 6.4.1 API
FileSizeFilter..::..IsEmpty Property
FileSizeFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get () sealed;
}

Field Value

true if this instance is empty; otherwise, false.

Implements

IFilter..::..IsEmpty

See Also

FileSizeFilter Class
Sitecore.Install.Filters Namespace


MaximumSize Property

[image]

Sitecore 6.4.1 API
FileSizeFilter..::..MaximumSize Property
FileSizeFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int MaximumSize { get; set; }
Visual Basic
Public Property MaximumSize As Integer
    Get
    Set
Visual C++
public:
property int MaximumSize {
    int get ();
    void set (int value);
}

Field Value

The maximum size.

See Also

FileSizeFilter Class
Sitecore.Install.Filters Namespace


MinimumSize Property

[image]

Sitecore 6.4.1 API
FileSizeFilter..::..MinimumSize Property
FileSizeFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int MinimumSize { get; set; }
Visual Basic
Public Property MinimumSize As Integer
    Get
    Set
Visual C++
public:
property int MinimumSize {
    int get ();
    void set (int value);
}

Field Value

The minimum size.

See Also

FileSizeFilter Class
Sitecore.Install.Filters Namespace


ItemDateFilter Class

[image]

Sitecore 6.4.1 API
ItemDateFilter Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemDateFilter : IFilter
Visual Basic
Public Class ItemDateFilter _
    Implements IFilter
Visual C++
public ref class ItemDateFilter : IFilter

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Filters..::..ItemDateFilter

See Also

ItemDateFilter Members
Sitecore.Install.Filters Namespace


ItemDateFilter Members

[image] [image]

Sitecore 6.4.1 API
ItemDateFilter Members
ItemDateFilter Class Constructors Methods Fields Properties See Also Send Feedback

The ItemDateFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ItemDateFilter()()()() | Initializes a new instance of the ItemDateFilter class.
Public method | ItemDateFilter(ItemDateFilter..::..ItemDateFilterType) | Initializes a new instance of the ItemDateFilter class.
Public method | ItemDateFilter(Int32, ItemDateFilter..::..ItemDateFilterType) | Initializes a new instance of the ItemDateFilter class.
Public method | ItemDateFilter(String, String, ItemDateFilter..::..ItemDateFilterType) | Initializes a new instance of the ItemDateFilter class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Qualify | Qualifies the specified instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
NoValue |

Properties

 | Name | Description
Public property | ActionDateFrom | Gets or sets the action date from.
Public property | ActionDateTo | Gets or sets the action date to.
Public property | FilterType | Gets or sets the type of the filter.
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | NotOlderThan | Gets or sets the value that indicates time pariod, calculated in days.

See Also

ItemDateFilter Class
Sitecore.Install.Filters Namespace


ItemDateFilter Constructor

[image] [image]

Sitecore 6.4.1 API
ItemDateFilter Constructor
ItemDateFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ItemDateFilter()()()() | Initializes a new instance of the ItemDateFilter class.
Public method | ItemDateFilter(ItemDateFilter..::..ItemDateFilterType) | Initializes a new instance of the ItemDateFilter class.
Public method | ItemDateFilter(Int32, ItemDateFilter..::..ItemDateFilterType) | Initializes a new instance of the ItemDateFilter class.
Public method | ItemDateFilter(String, String, ItemDateFilter..::..ItemDateFilterType) | Initializes a new instance of the ItemDateFilter class.

See Also

ItemDateFilter Class
ItemDateFilter Members
Sitecore.Install.Filters Namespace


ItemDateFilter Constructor

[image]

Sitecore 6.4.1 API
ItemDateFilter Constructor
ItemDateFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemDateFilter()
Visual Basic
Public Sub New
Visual C++
public:
ItemDateFilter()

See Also

ItemDateFilter Class
ItemDateFilter Overload
Sitecore.Install.Filters Namespace


ItemDateFilter Constructor (ItemDateFilter.ItemDateFilterType)

[image]

Sitecore 6.4.1 API
ItemDateFilter Constructor (ItemDateFilter..::..ItemDateFilterType)
ItemDateFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemDateFilter(
    ItemDateFilter..::..ItemDateFilterType filterType
)
Visual Basic
Public Sub New ( _
    filterType As ItemDateFilter..::..ItemDateFilterType _
)
Visual C++
public:
ItemDateFilter(
    ItemDateFilter..::..ItemDateFilterType filterType
)

Parameters

filterType
Type: Sitecore.Install.Filters..::..ItemDateFilter..::..ItemDateFilterType
Type of the filter.

See Also

ItemDateFilter Class
ItemDateFilter Overload
Sitecore.Install.Filters Namespace


ItemDateFilter Constructor (Int32, ItemDateFilter.ItemDateFilterType)

[image]

Sitecore 6.4.1 API
ItemDateFilter Constructor (Int32, ItemDateFilter..::..ItemDateFilterType)
ItemDateFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemDateFilter(
    int days,
    ItemDateFilter..::..ItemDateFilterType filterType
)
Visual Basic
Public Sub New ( _
    days As Integer, _
    filterType As ItemDateFilter..::..ItemDateFilterType _
)
Visual C++
public:
ItemDateFilter(
    int days,
    ItemDateFilter..::..ItemDateFilterType filterType
)

Parameters

days
Type: System..::..Int32
Defines time period, in days.
filterType
Type: Sitecore.Install.Filters..::..ItemDateFilter..::..ItemDateFilterType
Type of the filter.

See Also

ItemDateFilter Class
ItemDateFilter Overload
Sitecore.Install.Filters Namespace


ItemDateFilter Constructor (String, String, ItemDateFilter.ItemDateFilterType)

[image]

Sitecore 6.4.1 API
ItemDateFilter Constructor (String, String, ItemDateFilter..::..ItemDateFilterType)
ItemDateFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemDateFilter(
    string actionDateFrom,
    string actionDateTo,
    ItemDateFilter..::..ItemDateFilterType filterType
)
Visual Basic
Public Sub New ( _
    actionDateFrom As String, _
    actionDateTo As String, _
    filterType As ItemDateFilter..::..ItemDateFilterType _
)
Visual C++
public:
ItemDateFilter(
    String^ actionDateFrom,
    String^ actionDateTo,
    ItemDateFilter..::..ItemDateFilterType filterType
)

Parameters

actionDateFrom
Type: System..::..String
The action date from.
actionDateTo
Type: System..::..String
The action date to.
filterType
Type: Sitecore.Install.Filters..::..ItemDateFilter..::..ItemDateFilterType
Type of the filter.

See Also

ItemDateFilter Class
ItemDateFilter Overload
Sitecore.Install.Filters Namespace


ItemDateFilter Fields

[image] [image]

Sitecore 6.4.1 API
ItemDateFilter Fields
ItemDateFilter Class See Also Send Feedback

The ItemDateFilter type exposes the following members.

Fields

Name | Description
NoValue |

See Also

ItemDateFilter Class
Sitecore.Install.Filters Namespace


NoValue Field

[image]

Sitecore 6.4.1 API
ItemDateFilter..::..NoValue Field
ItemDateFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string NoValue
Visual Basic
Public Shared NoValue As String
Visual C++
public:
static String^ NoValue

See Also

ItemDateFilter Class
Sitecore.Install.Filters Namespace


ItemDateFilter Methods

[image] [image]

Sitecore 6.4.1 API
ItemDateFilter Methods
ItemDateFilter Class See Also Send Feedback

The ItemDateFilter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Qualify | Qualifies the specified instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemDateFilter Class
Sitecore.Install.Filters Namespace


Qualify Method

[image]

Sitecore 6.4.1 API
ItemDateFilter..::..Qualify Method
ItemDateFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Qualify(
    Object instance,
    IProcessingContext context
)
Visual Basic
Public Function Qualify ( _
    instance As Object, _
    context As IProcessingContext _
) As Boolean
Visual C++
public:
virtual bool Qualify(
    Object^ instance,
    IProcessingContext^ context
) sealed

Parameters

instance
Type: System..::..Object
The instance.
context
Type: Sitecore.Install.Framework..::..IProcessingContext
The processing context.

Return Value

Qualification result.

Implements

IFilter..::..Qualify(Object, IProcessingContext)

See Also

ItemDateFilter Class
Sitecore.Install.Filters Namespace


ItemDateFilter Properties

[image] [image]

Sitecore 6.4.1 API
ItemDateFilter Properties
ItemDateFilter Class See Also Send Feedback

The ItemDateFilter type exposes the following members.

Properties

 | Name | Description
Public property | ActionDateFrom | Gets or sets the action date from.
Public property | ActionDateTo | Gets or sets the action date to.
Public property | FilterType | Gets or sets the type of the filter.
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | NotOlderThan | Gets or sets the value that indicates time pariod, calculated in days.

See Also

ItemDateFilter Class
Sitecore.Install.Filters Namespace


ActionDateFrom Property

[image]

Sitecore 6.4.1 API
ItemDateFilter..::..ActionDateFrom Property
ItemDateFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ActionDateFrom { get; set; }
Visual Basic
Public Property ActionDateFrom As String
    Get
    Set
Visual C++
public:
property String^ ActionDateFrom {
    String^ get ();
    void set (String^ value);
}

Field Value

The action date from.

See Also

ItemDateFilter Class
Sitecore.Install.Filters Namespace


FilterType Property

[image]

Sitecore 6.4.1 API
ItemDateFilter..::..FilterType Property
ItemDateFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemDateFilter..::..ItemDateFilterType FilterType { get; set; }
Visual Basic
Public Property FilterType As ItemDateFilter..::..ItemDateFilterType
    Get
    Set
Visual C++
public:
property ItemDateFilter..::..ItemDateFilterType FilterType {
    ItemDateFilter..::..ItemDateFilterType get ();
    void set (ItemDateFilter..::..ItemDateFilterType value);
}

Field Value

The type of the filter.

See Also

ItemDateFilter Class
Sitecore.Install.Filters Namespace


NotOlderThan Property

[image]

Sitecore 6.4.1 API
ItemDateFilter..::..NotOlderThan Property
ItemDateFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string NotOlderThan { get; set; }
Visual Basic
Public Property NotOlderThan As String
    Get
    Set
Visual C++
public:
property String^ NotOlderThan {
    String^ get ();
    void set (String^ value);
}

Field Value

Indicates time pariod, calculated in days.

See Also

ItemDateFilter Class
Sitecore.Install.Filters Namespace


ItemLanguageFilter Class

[image]

Sitecore 6.4.1 API
ItemLanguageFilter Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemLanguageFilter : IFilter
Visual Basic
Public Class ItemLanguageFilter _
    Implements IFilter
Visual C++
public ref class ItemLanguageFilter : IFilter

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Filters..::..ItemLanguageFilter

See Also

ItemLanguageFilter Members
Sitecore.Install.Filters Namespace


ItemLanguageFilter Members

[image] [image]

Sitecore 6.4.1 API
ItemLanguageFilter Members
ItemLanguageFilter Class Constructors Methods Properties See Also Send Feedback

The ItemLanguageFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ItemLanguageFilter | Initializes a new instance of the ItemLanguageFilter class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Qualify | Qualifies the specified instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | Languages | Gets or sets the languages.

See Also

ItemLanguageFilter Class
Sitecore.Install.Filters Namespace


ItemLanguageFilter Constructor

[image]

Sitecore 6.4.1 API
ItemLanguageFilter Constructor
ItemLanguageFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemLanguageFilter()
Visual Basic
Public Sub New
Visual C++
public:
ItemLanguageFilter()

See Also

ItemLanguageFilter Class
Sitecore.Install.Filters Namespace


ItemLanguageFilter Methods

[image] [image]

Sitecore 6.4.1 API
ItemLanguageFilter Methods
ItemLanguageFilter Class See Also Send Feedback

The ItemLanguageFilter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Qualify | Qualifies the specified instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemLanguageFilter Class
Sitecore.Install.Filters Namespace


Qualify Method

[image]

Sitecore 6.4.1 API
ItemLanguageFilter..::..Qualify Method
ItemLanguageFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Qualify(
    Object instance,
    IProcessingContext context
)
Visual Basic
Public Function Qualify ( _
    instance As Object, _
    context As IProcessingContext _
) As Boolean
Visual C++
public:
virtual bool Qualify(
    Object^ instance,
    IProcessingContext^ context
) sealed

Parameters

instance
Type: System..::..Object
The instance.
context
Type: Sitecore.Install.Framework..::..IProcessingContext
The processing context.

Return Value

Qualification result.

Implements

IFilter..::..Qualify(Object, IProcessingContext)

See Also

ItemLanguageFilter Class
Sitecore.Install.Filters Namespace


ItemLanguageFilter Properties

[image] [image]

Sitecore 6.4.1 API
ItemLanguageFilter Properties
ItemLanguageFilter Class See Also Send Feedback

The ItemLanguageFilter type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | Languages | Gets or sets the languages.

See Also

ItemLanguageFilter Class
Sitecore.Install.Filters Namespace


IsEmpty Property

[image]

Sitecore 6.4.1 API
ItemLanguageFilter..::..IsEmpty Property
ItemLanguageFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get () sealed;
}

Field Value

true if this instance is empty; otherwise, false.

Implements

IFilter..::..IsEmpty

See Also

ItemLanguageFilter Class
Sitecore.Install.Filters Namespace


Languages Property

[image]

Sitecore 6.4.1 API
ItemLanguageFilter..::..Languages Property
ItemLanguageFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Languages { get; set; }
Visual Basic
Public Property Languages As String
    Get
    Set
Visual C++
public:
property String^ Languages {
    String^ get ();
    void set (String^ value);
}

Field Value

The languages.

See Also

ItemLanguageFilter Class
Sitecore.Install.Filters Namespace


ItemMasterFilter Class

[image]

Sitecore 6.4.1 API
ItemMasterFilter Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated")]
public class ItemMasterFilter : IFilter
Visual Basic
<ObsoleteAttribute("Deprecated")> _
Public Class ItemMasterFilter _
    Implements IFilter
Visual C++
[ObsoleteAttribute(L"Deprecated")]
public ref class ItemMasterFilter : IFilter

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Filters..::..ItemMasterFilter

See Also

ItemMasterFilter Members
Sitecore.Install.Filters Namespace


ItemMasterFilter Constructor

[image]

Sitecore 6.4.1 API
ItemMasterFilter Constructor
ItemMasterFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemMasterFilter()
Visual Basic
Public Sub New
Visual C++
public:
ItemMasterFilter()

See Also

ItemMasterFilter Class
Sitecore.Install.Filters Namespace


ItemMasterFilter Methods

[image] [image]

Sitecore 6.4.1 API
ItemMasterFilter Methods
ItemMasterFilter Class See Also Send Feedback

The ItemMasterFilter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Qualify | Qualifies the specified instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemMasterFilter Class
Sitecore.Install.Filters Namespace


Qualify Method

[image]

Sitecore 6.4.1 API
ItemMasterFilter..::..Qualify Method
ItemMasterFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Qualify(
    Object instance,
    IProcessingContext context
)
Visual Basic
Public Function Qualify ( _
    instance As Object, _
    context As IProcessingContext _
) As Boolean
Visual C++
public:
virtual bool Qualify(
    Object^ instance,
    IProcessingContext^ context
) sealed

Parameters

instance
Type: System..::..Object
The instance.
context
Type: Sitecore.Install.Framework..::..IProcessingContext
The processing context.

Return Value

Qualification result.

Implements

IFilter..::..Qualify(Object, IProcessingContext)

See Also

ItemMasterFilter Class
Sitecore.Install.Filters Namespace


ItemMasterFilter Properties

[image] [image]

Sitecore 6.4.1 API
ItemMasterFilter Properties
ItemMasterFilter Class See Also Send Feedback

The ItemMasterFilter type exposes the following members.

Properties

 | Name | Description
Public property | ExcludeWithoutMaster | Gets or sets a value indicating whether the ItemMasterFilter excludes without master(s).
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | Masters | Gets or sets the masters.

See Also

ItemMasterFilter Class
Sitecore.Install.Filters Namespace


ExcludeWithoutMaster Property

[image]

Sitecore 6.4.1 API
ItemMasterFilter..::..ExcludeWithoutMaster Property
ItemMasterFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ExcludeWithoutMaster { get; set; }
Visual Basic
Public Property ExcludeWithoutMaster As Boolean
    Get
    Set
Visual C++
public:
property bool ExcludeWithoutMaster {
    bool get ();
    void set (bool value);
}

Field Value

true if the ItemMasterFilter excludes without master(s); otherwise, false.

See Also

ItemMasterFilter Class
Sitecore.Install.Filters Namespace


Masters Property

[image]

Sitecore 6.4.1 API
ItemMasterFilter..::..Masters Property
ItemMasterFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Masters { get; set; }
Visual Basic
Public Property Masters As String
    Get
    Set
Visual C++
public:
property String^ Masters {
    String^ get ();
    void set (String^ value);
}

Field Value

The masters.

See Also

ItemMasterFilter Class
Sitecore.Install.Filters Namespace


ItemNameFilter Class

[image]

Sitecore 6.4.1 API
ItemNameFilter Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemNameFilter : IFilter
Visual Basic
Public Class ItemNameFilter _
    Implements IFilter
Visual C++
public ref class ItemNameFilter : IFilter

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Filters..::..ItemNameFilter

See Also

ItemNameFilter Members
Sitecore.Install.Filters Namespace


ItemNameFilter Members

[image] [image]

Sitecore 6.4.1 API
ItemNameFilter Members
ItemNameFilter Class Constructors Methods Properties See Also Send Feedback

The ItemNameFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ItemNameFilter()()()() | Initializes a new instance of the ItemNameFilter class.
Public method | ItemNameFilter(String) | Initializes a new instance of the ItemNameFilter class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Qualify | Qualifies the specified instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FilterSearchType | Gets or sets the type of the filter search.
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | Pattern | Gets or sets the pattern.

See Also

ItemNameFilter Class
Sitecore.Install.Filters Namespace


ItemNameFilter Constructor

[image] [image]

Sitecore 6.4.1 API
ItemNameFilter Constructor
ItemNameFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ItemNameFilter()()()() | Initializes a new instance of the ItemNameFilter class.
Public method | ItemNameFilter(String) | Initializes a new instance of the ItemNameFilter class.

See Also

ItemNameFilter Class
ItemNameFilter Members
Sitecore.Install.Filters Namespace


ItemNameFilter Constructor

[image]

Sitecore 6.4.1 API
ItemNameFilter Constructor
ItemNameFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemNameFilter()
Visual Basic
Public Sub New
Visual C++
public:
ItemNameFilter()

See Also

ItemNameFilter Class
ItemNameFilter Overload
Sitecore.Install.Filters Namespace


ItemNameFilter Methods

[image] [image]

Sitecore 6.4.1 API
ItemNameFilter Methods
ItemNameFilter Class See Also Send Feedback

The ItemNameFilter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Qualify | Qualifies the specified instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemNameFilter Class
Sitecore.Install.Filters Namespace


ItemNameFilter Properties

[image] [image]

Sitecore 6.4.1 API
ItemNameFilter Properties
ItemNameFilter Class See Also Send Feedback

The ItemNameFilter type exposes the following members.

Properties

 | Name | Description
Public property | FilterSearchType | Gets or sets the type of the filter search.
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | Pattern | Gets or sets the pattern.

See Also

ItemNameFilter Class
Sitecore.Install.Filters Namespace


FilterSearchType Property

[image]

Sitecore 6.4.1 API
ItemNameFilter..::..FilterSearchType Property
ItemNameFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemNameFilter..::..SearchType FilterSearchType { get; set; }
Visual Basic
Public Property FilterSearchType As ItemNameFilter..::..SearchType
    Get
    Set
Visual C++
public:
property ItemNameFilter..::..SearchType FilterSearchType {
    ItemNameFilter..::..SearchType get ();
    void set (ItemNameFilter..::..SearchType value);
}

Field Value

The type of the filter search.

See Also

ItemNameFilter Class
Sitecore.Install.Filters Namespace


IsEmpty Property

[image]

Sitecore 6.4.1 API
ItemNameFilter..::..IsEmpty Property
ItemNameFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get () sealed;
}

Field Value

true if this instance is empty; otherwise, false.

Implements

IFilter..::..IsEmpty

See Also

ItemNameFilter Class
Sitecore.Install.Filters Namespace


Pattern Property

[image]

Sitecore 6.4.1 API
ItemNameFilter..::..Pattern Property
ItemNameFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Pattern { get; set; }
Visual Basic
Public Property Pattern As String
    Get
    Set
Visual C++
public:
property String^ Pattern {
    String^ get ();
    void set (String^ value);
}

Field Value

The pattern.

See Also

ItemNameFilter Class
Sitecore.Install.Filters Namespace


ItemNameFilter.SearchType Enumeration

[image]

Sitecore 6.4.1 API
ItemNameFilter..::..SearchType Enumeration
ItemNameFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum SearchType
Visual Basic
Public Enumeration SearchType
Visual C++
public enum class SearchType

Members

Member name | Value | Description
Simple | 0 | Simple search
Regex | 1 | Searching by a regual expression
Wildcards | 2 | Searching by an expression with some wildcards

See Also

Sitecore.Install.Filters Namespace


ItemPublishFilter Members

[image] [image]

Sitecore 6.4.1 API
ItemPublishFilter Members
ItemPublishFilter Class Constructors Methods Properties See Also Send Feedback

The ItemPublishFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ItemPublishFilter | Initializes a new instance of the ItemPublishFilter class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Qualify | Qualifies the specified instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CheckWorkflow | Gets or sets a value indicating whether the ItemPublishFilter checks the workflow.
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | PublishDate | Gets or sets the publish date.

See Also

ItemPublishFilter Class
Sitecore.Install.Filters Namespace


ItemPublishFilter Constructor

[image]

Sitecore 6.4.1 API
ItemPublishFilter Constructor
ItemPublishFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemPublishFilter()
Visual Basic
Public Sub New
Visual C++
public:
ItemPublishFilter()

See Also

ItemPublishFilter Class
Sitecore.Install.Filters Namespace


ItemPublishFilter Methods

[image] [image]

Sitecore 6.4.1 API
ItemPublishFilter Methods
ItemPublishFilter Class See Also Send Feedback

The ItemPublishFilter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Qualify | Qualifies the specified instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemPublishFilter Class
Sitecore.Install.Filters Namespace


Qualify Method

[image]

Sitecore 6.4.1 API
ItemPublishFilter..::..Qualify Method
ItemPublishFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Qualify(
    Object instance,
    IProcessingContext context
)
Visual Basic
Public Function Qualify ( _
    instance As Object, _
    context As IProcessingContext _
) As Boolean
Visual C++
public:
virtual bool Qualify(
    Object^ instance,
    IProcessingContext^ context
) sealed

Parameters

instance
Type: System..::..Object
The instance.
context
Type: Sitecore.Install.Framework..::..IProcessingContext
The processing context.

Return Value

Qualification result.

Implements

IFilter..::..Qualify(Object, IProcessingContext)

See Also

ItemPublishFilter Class
Sitecore.Install.Filters Namespace


ItemPublishFilter Properties

[image] [image]

Sitecore 6.4.1 API
ItemPublishFilter Properties
ItemPublishFilter Class See Also Send Feedback

The ItemPublishFilter type exposes the following members.

Properties

 | Name | Description
Public property | CheckWorkflow | Gets or sets a value indicating whether the ItemPublishFilter checks the workflow.
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | PublishDate | Gets or sets the publish date.

See Also

ItemPublishFilter Class
Sitecore.Install.Filters Namespace


CheckWorkflow Property

[image]

Sitecore 6.4.1 API
ItemPublishFilter..::..CheckWorkflow Property
ItemPublishFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool CheckWorkflow { get; set; }
Visual Basic
Public Property CheckWorkflow As Boolean
    Get
    Set
Visual C++
public:
property bool CheckWorkflow {
    bool get ();
    void set (bool value);
}

Field Value

true if the ItemPublishFilter checks the workflow; otherwise, false.

See Also

ItemPublishFilter Class
Sitecore.Install.Filters Namespace


IsEmpty Property

[image]

Sitecore 6.4.1 API
ItemPublishFilter..::..IsEmpty Property
ItemPublishFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get () sealed;
}

Field Value

true if this instance is empty; otherwise, false.

Implements

IFilter..::..IsEmpty

See Also

ItemPublishFilter Class
Sitecore.Install.Filters Namespace


PublishDate Property

[image]

Sitecore 6.4.1 API
ItemPublishFilter..::..PublishDate Property
ItemPublishFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string PublishDate { get; set; }
Visual Basic
Public Property PublishDate As String
    Get
    Set
Visual C++
public:
property String^ PublishDate {
    String^ get ();
    void set (String^ value);
}

Field Value

The publish date.

See Also

ItemPublishFilter Class
Sitecore.Install.Filters Namespace


ItemRoleFilter Class

[image]

Sitecore 6.4.1 API
ItemRoleFilter Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemRoleFilter : IFilter
Visual Basic
Public Class ItemRoleFilter _
    Implements IFilter
Visual C++
public ref class ItemRoleFilter : IFilter

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Filters..::..ItemRoleFilter

See Also

ItemRoleFilter Members
Sitecore.Install.Filters Namespace


ItemRoleFilter Members

[image] [image]

Sitecore 6.4.1 API
ItemRoleFilter Members
ItemRoleFilter Class Constructors Methods Properties See Also Send Feedback

The ItemRoleFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ItemRoleFilter | Initializes a new instance of the ItemRoleFilter class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Qualify | Qualifies the specified instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FilterType | Gets or sets the type of the filter.
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | Roles | Gets or sets the roles.

See Also

ItemRoleFilter Class
Sitecore.Install.Filters Namespace


ItemRoleFilter Constructor

[image]

Sitecore 6.4.1 API
ItemRoleFilter Constructor
ItemRoleFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemRoleFilter()
Visual Basic
Public Sub New
Visual C++
public:
ItemRoleFilter()

See Also

ItemRoleFilter Class
Sitecore.Install.Filters Namespace


ItemRoleFilter Methods

[image] [image]

Sitecore 6.4.1 API
ItemRoleFilter Methods
ItemRoleFilter Class See Also Send Feedback

The ItemRoleFilter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Qualify | Qualifies the specified instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemRoleFilter Class
Sitecore.Install.Filters Namespace


Qualify Method

[image]

Sitecore 6.4.1 API
ItemRoleFilter..::..Qualify Method
ItemRoleFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Qualify(
    Object instance,
    IProcessingContext context
)
Visual Basic
Public Function Qualify ( _
    instance As Object, _
    context As IProcessingContext _
) As Boolean
Visual C++
public:
virtual bool Qualify(
    Object^ instance,
    IProcessingContext^ context
) sealed

Parameters

instance
Type: System..::..Object
The instance.
context
Type: Sitecore.Install.Framework..::..IProcessingContext
The processing context.

Return Value

Qualification result.

Implements

IFilter..::..Qualify(Object, IProcessingContext)

See Also

ItemRoleFilter Class
Sitecore.Install.Filters Namespace


ItemRoleFilter Properties

[image] [image]

Sitecore 6.4.1 API
ItemRoleFilter Properties
ItemRoleFilter Class See Also Send Feedback

The ItemRoleFilter type exposes the following members.

Properties

 | Name | Description
Public property | FilterType | Gets or sets the type of the filter.
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | Roles | Gets or sets the roles.

See Also

ItemRoleFilter Class
Sitecore.Install.Filters Namespace


FilterType Property

[image]

Sitecore 6.4.1 API
ItemRoleFilter..::..FilterType Property
ItemRoleFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemRoleFilter..::..ItemRoleFilterType FilterType { get; set; }
Visual Basic
Public Property FilterType As ItemRoleFilter..::..ItemRoleFilterType
    Get
    Set
Visual C++
public:
property ItemRoleFilter..::..ItemRoleFilterType FilterType {
    ItemRoleFilter..::..ItemRoleFilterType get ();
    void set (ItemRoleFilter..::..ItemRoleFilterType value);
}

Field Value

The type of the filter.

See Also

ItemRoleFilter Class
Sitecore.Install.Filters Namespace


IsEmpty Property

[image]

Sitecore 6.4.1 API
ItemRoleFilter..::..IsEmpty Property
ItemRoleFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get () sealed;
}

Field Value

true if this instance is empty; otherwise, false.

Implements

IFilter..::..IsEmpty

See Also

ItemRoleFilter Class
Sitecore.Install.Filters Namespace


Roles Property

[image]

Sitecore 6.4.1 API
ItemRoleFilter..::..Roles Property
ItemRoleFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Roles { get; set; }
Visual Basic
Public Property Roles As String
    Get
    Set
Visual C++
public:
property String^ Roles {
    String^ get ();
    void set (String^ value);
}

Field Value

The roles.

See Also

ItemRoleFilter Class
Sitecore.Install.Filters Namespace


ItemRoleFilter.ItemRoleFilterType Enumeration

[image]

Sitecore 6.4.1 API
ItemRoleFilter..::..ItemRoleFilterType Enumeration
ItemRoleFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum ItemRoleFilterType
Visual Basic
Public Enumeration ItemRoleFilterType
Visual C++
public enum class ItemRoleFilterType

Members

Member name | Value | Description
Created | 0 | "Created by" field will be used
Modified | 1 | "Modified by" field will be used

See Also

Sitecore.Install.Filters Namespace


ItemTemplateFilter Class

[image]

Sitecore 6.4.1 API
ItemTemplateFilter Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemTemplateFilter : IFilter
Visual Basic
Public Class ItemTemplateFilter _
    Implements IFilter
Visual C++
public ref class ItemTemplateFilter : IFilter

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Filters..::..ItemTemplateFilter

See Also

ItemTemplateFilter Members
Sitecore.Install.Filters Namespace


ItemTemplateFilter Members

[image] [image]

Sitecore 6.4.1 API
ItemTemplateFilter Members
ItemTemplateFilter Class Constructors Methods Properties See Also Send Feedback

The ItemTemplateFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ItemTemplateFilter()()()() | Initializes a new instance of the ItemTemplateFilter class.
Public method | ItemTemplateFilter(String) | Initializes a new instance of the ItemTemplateFilter class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Qualify | Qualifies the specified instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | Templates | Gets or sets the templates.

See Also

ItemTemplateFilter Class
Sitecore.Install.Filters Namespace


ItemTemplateFilter Constructor

[image] [image]

Sitecore 6.4.1 API
ItemTemplateFilter Constructor
ItemTemplateFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ItemTemplateFilter()()()() | Initializes a new instance of the ItemTemplateFilter class.
Public method | ItemTemplateFilter(String) | Initializes a new instance of the ItemTemplateFilter class.

See Also

ItemTemplateFilter Class
ItemTemplateFilter Members
Sitecore.Install.Filters Namespace


ItemTemplateFilter Constructor

[image]

Sitecore 6.4.1 API
ItemTemplateFilter Constructor
ItemTemplateFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemTemplateFilter()
Visual Basic
Public Sub New
Visual C++
public:
ItemTemplateFilter()

See Also

ItemTemplateFilter Class
ItemTemplateFilter Overload
Sitecore.Install.Filters Namespace


ItemTemplateFilter Constructor (String)

[image]

Sitecore 6.4.1 API
ItemTemplateFilter Constructor (String)
ItemTemplateFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemTemplateFilter(
    string templates
)
Visual Basic
Public Sub New ( _
    templates As String _
)
Visual C++
public:
ItemTemplateFilter(
    String^ templates
)

Parameters

templates
Type: System..::..String
The templates.

See Also

ItemTemplateFilter Class
ItemTemplateFilter Overload
Sitecore.Install.Filters Namespace


ItemTemplateFilter Methods

[image] [image]

Sitecore 6.4.1 API
ItemTemplateFilter Methods
ItemTemplateFilter Class See Also Send Feedback

The ItemTemplateFilter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Qualify | Qualifies the specified instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemTemplateFilter Class
Sitecore.Install.Filters Namespace


Qualify Method

[image]

Sitecore 6.4.1 API
ItemTemplateFilter..::..Qualify Method
ItemTemplateFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Qualify(
    Object instance,
    IProcessingContext context
)
Visual Basic
Public Function Qualify ( _
    instance As Object, _
    context As IProcessingContext _
) As Boolean
Visual C++
public:
virtual bool Qualify(
    Object^ instance,
    IProcessingContext^ context
) sealed

Parameters

instance
Type: System..::..Object
The instance.
context
Type: Sitecore.Install.Framework..::..IProcessingContext
The processing context.

Return Value

Qualification result.

Implements

IFilter..::..Qualify(Object, IProcessingContext)

See Also

ItemTemplateFilter Class
Sitecore.Install.Filters Namespace


ItemTemplateFilter Properties

[image] [image]

Sitecore 6.4.1 API
ItemTemplateFilter Properties
ItemTemplateFilter Class See Also Send Feedback

The ItemTemplateFilter type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | Templates | Gets or sets the templates.

See Also

ItemTemplateFilter Class
Sitecore.Install.Filters Namespace


IsEmpty Property

[image]

Sitecore 6.4.1 API
ItemTemplateFilter..::..IsEmpty Property
ItemTemplateFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get () sealed;
}

Field Value

true if this instance is empty; otherwise, false.

Implements

IFilter..::..IsEmpty

See Also

ItemTemplateFilter Class
Sitecore.Install.Filters Namespace


Templates Property

[image]

Sitecore 6.4.1 API
ItemTemplateFilter..::..Templates Property
ItemTemplateFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Templates { get; set; }
Visual Basic
Public Property Templates As String
    Get
    Set
Visual C++
public:
property String^ Templates {
    String^ get ();
    void set (String^ value);
}

Field Value

The templates.

See Also

ItemTemplateFilter Class
Sitecore.Install.Filters Namespace


ItemUserFilter Class

[image]

Sitecore 6.4.1 API
ItemUserFilter Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemUserFilter : IFilter
Visual Basic
Public Class ItemUserFilter _
    Implements IFilter
Visual C++
public ref class ItemUserFilter : IFilter

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Filters..::..ItemUserFilter

See Also

ItemUserFilter Members
Sitecore.Install.Filters Namespace


ItemUserFilter Members

[image] [image]

Sitecore 6.4.1 API
ItemUserFilter Members
ItemUserFilter Class Constructors Methods Properties See Also Send Feedback

The ItemUserFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ItemUserFilter | Initializes a new instance of the ItemUserFilter class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Qualify | Qualifies the specified instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Accounts | Gets or sets the accounts.
Public property | FilterType | Gets or sets the type of the filter.
Public property | IsEmpty | Gets a value indicating whether this instance is empty.

See Also

ItemUserFilter Class
Sitecore.Install.Filters Namespace


ItemUserFilter Constructor

[image]

Sitecore 6.4.1 API
ItemUserFilter Constructor
ItemUserFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemUserFilter()
Visual Basic
Public Sub New
Visual C++
public:
ItemUserFilter()

See Also

ItemUserFilter Class
Sitecore.Install.Filters Namespace


ItemUserFilter Methods

[image] [image]

Sitecore 6.4.1 API
ItemUserFilter Methods
ItemUserFilter Class See Also Send Feedback

The ItemUserFilter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Qualify | Qualifies the specified instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemUserFilter Class
Sitecore.Install.Filters Namespace


Qualify Method

[image]

Sitecore 6.4.1 API
ItemUserFilter..::..Qualify Method
ItemUserFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Qualify(
    Object instance,
    IProcessingContext context
)
Visual Basic
Public Function Qualify ( _
    instance As Object, _
    context As IProcessingContext _
) As Boolean
Visual C++
public:
virtual bool Qualify(
    Object^ instance,
    IProcessingContext^ context
) sealed

Parameters

instance
Type: System..::..Object
The instance.
context
Type: Sitecore.Install.Framework..::..IProcessingContext
The processing context.

Return Value

Qualification result.

Implements

IFilter..::..Qualify(Object, IProcessingContext)

See Also

ItemUserFilter Class
Sitecore.Install.Filters Namespace


ItemUserFilter Properties

[image] [image]

Sitecore 6.4.1 API
ItemUserFilter Properties
ItemUserFilter Class See Also Send Feedback

The ItemUserFilter type exposes the following members.

Properties

 | Name | Description
Public property | Accounts | Gets or sets the accounts.
Public property | FilterType | Gets or sets the type of the filter.
Public property | IsEmpty | Gets a value indicating whether this instance is empty.

See Also

ItemUserFilter Class
Sitecore.Install.Filters Namespace


Accounts Property

[image]

Sitecore 6.4.1 API
ItemUserFilter..::..Accounts Property
ItemUserFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Accounts { get; set; }
Visual Basic
Public Property Accounts As String
    Get
    Set
Visual C++
public:
property String^ Accounts {
    String^ get ();
    void set (String^ value);
}

Field Value

The accounts.

See Also

ItemUserFilter Class
Sitecore.Install.Filters Namespace


FilterType Property

[image]

Sitecore 6.4.1 API
ItemUserFilter..::..FilterType Property
ItemUserFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemUserFilter..::..ItemUserFilterType FilterType { get; set; }
Visual Basic
Public Property FilterType As ItemUserFilter..::..ItemUserFilterType
    Get
    Set
Visual C++
public:
property ItemUserFilter..::..ItemUserFilterType FilterType {
    ItemUserFilter..::..ItemUserFilterType get ();
    void set (ItemUserFilter..::..ItemUserFilterType value);
}

Field Value

The type of the filter.

See Also

ItemUserFilter Class
Sitecore.Install.Filters Namespace


IsEmpty Property

[image]

Sitecore 6.4.1 API
ItemUserFilter..::..IsEmpty Property
ItemUserFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get () sealed;
}

Field Value

true if this instance is empty; otherwise, false.

Implements

IFilter..::..IsEmpty

See Also

ItemUserFilter Class
Sitecore.Install.Filters Namespace


ItemUserFilter.ItemUserFilterType Enumeration

[image]

Sitecore 6.4.1 API
ItemUserFilter..::..ItemUserFilterType Enumeration
ItemUserFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum ItemUserFilterType
Visual Basic
Public Enumeration ItemUserFilterType
Visual C++
public enum class ItemUserFilterType

Members

Member name | Value | Description
Created | 0 | "Created by" field will be used
Modified | 1 | "Modified by" field will be used

See Also

Sitecore.Install.Filters Namespace


PackageEntryKeyFilter Class

[image]

Sitecore 6.4.1 API
PackageEntryKeyFilter Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PackageEntryKeyFilter : IFilter
Visual Basic
Public Class PackageEntryKeyFilter _
    Implements IFilter
Visual C++
public ref class PackageEntryKeyFilter : IFilter

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Filters..::..PackageEntryKeyFilter

See Also

PackageEntryKeyFilter Members
Sitecore.Install.Filters Namespace


PackageEntryKeyFilter Members

[image] [image]

Sitecore 6.4.1 API
PackageEntryKeyFilter Members
PackageEntryKeyFilter Class Constructors Methods Properties See Also Send Feedback

The PackageEntryKeyFilter type exposes the following members.

Constructors

 | Name | Description
Public method | PackageEntryKeyFilter()()()() | Initializes a new instance of the PackageEntryKeyFilter class.
Public method | PackageEntryKeyFilter(String) | Initializes a new instance of the PackageEntryKeyFilter class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Qualify | Qualifies the specified instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | Pattern | Gets or sets the regular expression pattern.

See Also

PackageEntryKeyFilter Class
Sitecore.Install.Filters Namespace


PackageEntryKeyFilter Constructor

[image] [image]

Sitecore 6.4.1 API
PackageEntryKeyFilter Constructor
PackageEntryKeyFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PackageEntryKeyFilter()()()() | Initializes a new instance of the PackageEntryKeyFilter class.
Public method | PackageEntryKeyFilter(String) | Initializes a new instance of the PackageEntryKeyFilter class.

See Also

PackageEntryKeyFilter Class
PackageEntryKeyFilter Members
Sitecore.Install.Filters Namespace


PackageEntryKeyFilter Constructor

[image]

Sitecore 6.4.1 API
PackageEntryKeyFilter Constructor
PackageEntryKeyFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PackageEntryKeyFilter()
Visual Basic
Public Sub New
Visual C++
public:
PackageEntryKeyFilter()

See Also

PackageEntryKeyFilter Class
PackageEntryKeyFilter Overload
Sitecore.Install.Filters Namespace


PackageEntryKeyFilter Constructor (String)

[image]

Sitecore 6.4.1 API
PackageEntryKeyFilter Constructor (String)
PackageEntryKeyFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PackageEntryKeyFilter(
    string pattern
)
Visual Basic
Public Sub New ( _
    pattern As String _
)
Visual C++
public:
PackageEntryKeyFilter(
    String^ pattern
)

Parameters

pattern
Type: System..::..String
The pattern.

See Also

PackageEntryKeyFilter Class
PackageEntryKeyFilter Overload
Sitecore.Install.Filters Namespace


PackageEntryKeyFilter Methods

[image] [image]

Sitecore 6.4.1 API
PackageEntryKeyFilter Methods
PackageEntryKeyFilter Class See Also Send Feedback

The PackageEntryKeyFilter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Qualify | Qualifies the specified instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PackageEntryKeyFilter Class
Sitecore.Install.Filters Namespace


Qualify Method

[image]

Sitecore 6.4.1 API
PackageEntryKeyFilter..::..Qualify Method
PackageEntryKeyFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Qualify(
    Object instance,
    IProcessingContext context
)
Visual Basic
Public Function Qualify ( _
    instance As Object, _
    context As IProcessingContext _
) As Boolean
Visual C++
public:
virtual bool Qualify(
    Object^ instance,
    IProcessingContext^ context
) sealed

Parameters

instance
Type: System..::..Object
The instance.
context
Type: Sitecore.Install.Framework..::..IProcessingContext
The processing context.

Return Value

Qualification result.

Implements

IFilter..::..Qualify(Object, IProcessingContext)

See Also

PackageEntryKeyFilter Class
Sitecore.Install.Filters Namespace


PackageEntryKeyFilter Properties

[image] [image]

Sitecore 6.4.1 API
PackageEntryKeyFilter Properties
PackageEntryKeyFilter Class See Also Send Feedback

The PackageEntryKeyFilter type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | Pattern | Gets or sets the regular expression pattern.

See Also

PackageEntryKeyFilter Class
Sitecore.Install.Filters Namespace


Pattern Property

[image]

Sitecore 6.4.1 API
PackageEntryKeyFilter..::..Pattern Property
PackageEntryKeyFilter Class See Also Send Feedback

Namespace: Sitecore.Install.Filters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Pattern { get; set; }
Visual Basic
Public Property Pattern As String
    Get
    Set
Visual C++
public:
property String^ Pattern {
    String^ get ();
    void set (String^ value);
}

Field Value

The pattern.

See Also

PackageEntryKeyFilter Class
Sitecore.Install.Filters Namespace


Sitecore.Install.Framework Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Install.Framework Namespace
Send Feedback

Classes

 | Class | Description
Public class | AdvancedBaseSink<(Of <(<'T, ContextType>)>)> | AdvancedBaseSink
Public class | AspectBase | Base implementation of IAspectContainer
Public class | BaseConverter<(Of <(<'T>)>)> | Implements basic functionality of "to Entry" convertor
Public class | BaseSink<(Of <(<'T>)>)> | BaseSink class
Public class | BaseSource<(Of <(<'T>)>)> | Implements basic source functionality
Protected class | BaseSource<(Of <(<'T>)>)>..::..InternalSink | Internal sink implementation
Public class | DefaultOutput | Default output
Public class | EntryBuilder | Converts an IEntryData object to PackageEntry object and populates the internal sink with that package entry
Public class | FilteringSink<(Of <(<'T>)>)> | A sink that applies filters and populates the result entries to wrapped sink
Public class | NullOutput | A "stab" task output
Public class | PackageEntry | Represents a package entry
Public class | PropertySetter | Represents a processor which is setting the properties of entries
Public class | SimpleKeyProvider | Simple key provider
Public class | SimpleProcessingContext | Simple processing context
Public class | SinkDispatcher | Represents a sink that use one of internal sinks to populate depends on the prefix of the name of the entry
Public class | SortingKey | Sorting key
Public class | SourceCollection<(Of <(<'T>)>)> | An aggregation of sources
Public class | SourceInverter<(Of <(<'T>)>)> | Adapts ISource into an IEnumerable (inverts from PUSH to PULL model)
Public class | TrivialConverter | "Stub" converter. As a result of any conversion we will have the input object.

Interfaces

 | Interface | Description
Public interface | IAspectContainer | IAspectContainer interface
Public interface | IConverter<(Of <(<'T, K>)>)> | Defines a method to transorm some objects
Public interface | IEntryData | Basic methods and properties for an entry
Public interface | IExplicitSource | Defines basic properties of an explicit source
Public interface | IFilter | Defines basic methods and properties for a filer
Public interface | IKeyResolver | Defines a basic methods of a key resolver
Public interface | INamedObject | Defines a "name" property
Public interface | IPostStep | Mefines a basic method of a post step
Public interface | IProcessingContext | Defines basic methods and properties of a processing context
Public interface | IProcessor<(Of <(<'T>)>)> | Defines basic methods of a processor
Public interface | ISink<(Of <(<'T>)>)> | Defines basic methods for a sink
Public interface | ISortingKeyProvider | Defines basic methods of sorting key provider
Public interface | ISource<(Of <(<'T>)>)> | Defines basic methods for a source
Public interface | IStreamHolder | Defines a property to get a stream
Public interface | IStreamProvider | Defines basic methods of a stream provider
Public interface | ISupportsAttributes | Defines methods to get/set attributes
Public interface | ISupportsFiltering | Defines properties to get filters
Public interface | ISupportsTransforms<(Of <(<'T>)>)> | Defines a property to get transforms
Public interface | ITaskOutput | Defines basic methods to work with UI in another thread

Enumerations

 | Enumeration | Description
Public enumeration | InstallPolicy | Define what to do with the item collision


AdvancedBaseSink(T, ContextType) Class

[image]

Sitecore 6.4.1 API
AdvancedBaseSink<(Of <(<'T, ContextType>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class AdvancedBaseSink<T, ContextType> : BaseSink<T>
where ContextType : class
Visual Basic
Public MustInherit Class AdvancedBaseSink(Of T, ContextType As Class) _
    Inherits BaseSink(Of T)
Visual C++
generic<typename T, typename ContextType>
where ContextType : ref class
public ref class AdvancedBaseSink abstract : public BaseSink<T>

Type Parameters

T
Entry type
ContextType
Context Type

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..BaseSink <(Of <(<' T >)>)>
Sitecore.Install.Framework..::..AdvancedBaseSink<(Of <(<'T, ContextType>)>)>
Sitecore.Install.BlobData..::..BlobInstaller
Sitecore.Install.Files..::..FileInstaller
Sitecore.Install.Items..::..ItemInstaller

See Also

AdvancedBaseSink<(Of <(<'T, ContextType>)>)> Members
Sitecore.Install.Framework Namespace


AdvancedBaseSink(T, ContextType) Members

[image] [image]

Sitecore 6.4.1 API
AdvancedBaseSink<(Of <(<'T, ContextType>)>)> Members
AdvancedBaseSink<(Of <(<'T, ContextType>)>)> Class Constructors Methods Fields Properties See Also Send Feedback

The AdvancedBaseSink<(Of <(<'T, ContextType>)>)> type exposes the following members.

Constructors

 | Name | Description
Protected method | AdvancedBaseSink<(Of <(<'T, ContextType>)>)> | Initializes a new instance of the AdvancedBaseSink<(Of <(<'T, ContextType>)>)> class

Methods

 | Name | Description
Protected method | AssertInit | Asserts the init. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Protected method | CreateContext | Creates the context.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finishes the sink. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Flush | Flushes the sink (Inherited from BaseSink<(Of <(<'T>)>)>.)
 | GetContext | Gets the context.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | HasContext | Determines whether the specified processing context has context.
Public method | Initialize | Initializes this instance. (Overrides BaseSink<(Of <(<'T>)>)>..::..Initialize(IProcessingContext).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put | Puts the specified entry. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Protected method | SetupContext | Setups the context.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _processingContext | (Inherited from BaseSink<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Context | Gets the context.
Public property | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

AdvancedBaseSink<(Of <(<'T, ContextType>)>)> Class
Sitecore.Install.Framework Namespace


AdvancedBaseSink(T, ContextType) Constructor

[image]

Sitecore 6.4.1 API
AdvancedBaseSink<(Of <(<'T, ContextType>)>)> Constructor
AdvancedBaseSink<(Of <(<'T, ContextType>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected AdvancedBaseSink()
Visual Basic
Protected Sub New
Visual C++
protected:
AdvancedBaseSink()

See Also

AdvancedBaseSink<(Of <(<'T, ContextType>)>)> Class
Sitecore.Install.Framework Namespace


AdvancedBaseSink(T, ContextType) Fields

[image] [image]

Sitecore 6.4.1 API
AdvancedBaseSink<(Of <(<'T, ContextType>)>)> Fields
AdvancedBaseSink<(Of <(<'T, ContextType>)>)> Class See Also Send Feedback

The AdvancedBaseSink<(Of <(<'T, ContextType>)>)> type exposes the following members.

Fields

 | Name | Description
Protected field | _processingContext | (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

AdvancedBaseSink<(Of <(<'T, ContextType>)>)> Class
Sitecore.Install.Framework Namespace


AdvancedBaseSink(T, ContextType) Methods

[image] [image]

Sitecore 6.4.1 API
AdvancedBaseSink<(Of <(<'T, ContextType>)>)> Methods
AdvancedBaseSink<(Of <(<'T, ContextType>)>)> Class See Also Send Feedback

The AdvancedBaseSink<(Of <(<'T, ContextType>)>)> type exposes the following members.

Methods

 | Name | Description
Protected method | AssertInit | Asserts the init. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Protected method | CreateContext | Creates the context.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finishes the sink. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Flush | Flushes the sink (Inherited from BaseSink<(Of <(<'T>)>)>.)
 | GetContext | Gets the context.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | HasContext | Determines whether the specified processing context has context.
Public method | Initialize | Initializes this instance. (Overrides BaseSink<(Of <(<'T>)>)>..::..Initialize(IProcessingContext).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put | Puts the specified entry. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Protected method | SetupContext | Setups the context.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AdvancedBaseSink<(Of <(<'T, ContextType>)>)> Class
Sitecore.Install.Framework Namespace


HasContext Method

[image]

Sitecore 6.4.1 API
AdvancedBaseSink<(Of <(<'T, ContextType>)>)>..::..HasContext Method
AdvancedBaseSink<(Of <(<'T, ContextType>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected static bool HasContext(
    IProcessingContext processingContext
)
Visual Basic
Protected Shared Function HasContext ( _
    processingContext As IProcessingContext _
) As Boolean
Visual C++
protected:
static bool HasContext(
    IProcessingContext^ processingContext
)

Parameters

processingContext
Type: Sitecore.Install.Framework..::..IProcessingContext
The processing context.

Return Value

true if the specified processing context has context; otherwise, false.

See Also

AdvancedBaseSink<(Of <(<'T, ContextType>)>)> Class
Sitecore.Install.Framework Namespace


SetupContext Method

[image]

Sitecore 6.4.1 API
AdvancedBaseSink<(Of <(<'T, ContextType>)>)>..::..SetupContext Method
AdvancedBaseSink<(Of <(<'T, ContextType>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void SetupContext(
    ContextType context
)
Visual Basic
Protected Sub SetupContext ( _
    context As ContextType _
)
Visual C++
protected:
void SetupContext(
    ContextType context
)

Parameters

context
Type: ContextType
The context.

See Also

AdvancedBaseSink<(Of <(<'T, ContextType>)>)> Class
Sitecore.Install.Framework Namespace


AdvancedBaseSink(T, ContextType) Properties

[image] [image]

Sitecore 6.4.1 API
AdvancedBaseSink<(Of <(<'T, ContextType>)>)> Properties
AdvancedBaseSink<(Of <(<'T, ContextType>)>)> Class See Also Send Feedback

The AdvancedBaseSink<(Of <(<'T, ContextType>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Context | Gets the context.
Public property | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

AdvancedBaseSink<(Of <(<'T, ContextType>)>)> Class
Sitecore.Install.Framework Namespace


Context Property

[image]

Sitecore 6.4.1 API
AdvancedBaseSink<(Of <(<'T, ContextType>)>)>..::..Context Property
AdvancedBaseSink<(Of <(<'T, ContextType>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ContextType Context { get; }
Visual Basic
Public ReadOnly Property Context As ContextType
    Get
Visual C++
public:
property ContextType Context {
    ContextType get ();
}

Field Value

The context.

See Also

AdvancedBaseSink<(Of <(<'T, ContextType>)>)> Class
Sitecore.Install.Framework Namespace


AspectBase Class

[image]

Sitecore 6.4.1 API
AspectBase Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class AspectBase : IAspectContainer
Visual Basic
Public Class AspectBase _
    Implements IAspectContainer
Visual C++
public ref class AspectBase : IAspectContainer

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..AspectBase
Sitecore.Install.Framework..::..SimpleProcessingContext

See Also

AspectBase Members
Sitecore.Install.Framework Namespace


AspectBase Members

[image] [image]

Sitecore 6.4.1 API
AspectBase Members
AspectBase Class Constructors Methods See Also Send Feedback

The AspectBase type exposes the following members.

Constructors

 | Name | Description
Public method | AspectBase | Initializes a new instance of the AspectBase class

Methods

 | Name | Description
Public method | AddAspect<(Of <<'(T>)>>) | Adds the aspect.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAspect<(Of <<'(T>)>>) | Gets the aspect.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAspect<(Of <<'(T>)>>) | Determines whether this instance has aspect.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AspectBase Class
Sitecore.Install.Framework Namespace


AspectBase Constructor

[image]

Sitecore 6.4.1 API
AspectBase Constructor
AspectBase Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AspectBase()
Visual Basic
Public Sub New
Visual C++
public:
AspectBase()

See Also

AspectBase Class
Sitecore.Install.Framework Namespace


AspectBase Methods

[image] [image]

Sitecore 6.4.1 API
AspectBase Methods
AspectBase Class See Also Send Feedback

The AspectBase type exposes the following members.

Methods

 | Name | Description
Public method | AddAspect<(Of <<'(T>)>>) | Adds the aspect.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAspect<(Of <<'(T>)>>) | Gets the aspect.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAspect<(Of <<'(T>)>>) | Determines whether this instance has aspect.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AspectBase Class
Sitecore.Install.Framework Namespace


AddAspect(T) Method

[image]

Sitecore 6.4.1 API
AspectBase..::..AddAspect<(Of <(<'T>)>)> Method
AspectBase Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddAspect<T>(
    T instance
)
where T : class
Visual Basic
Public Sub AddAspect(Of T As Class) ( _
    instance As T _
)
Visual C++
public:
generic<typename T>
where T : ref class
virtual void AddAspect(
    T instance
) sealed

Parameters

instance
Type: T
The instance.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Sitecore.Install.Framework.AspectBase.AddAspect``1(``0)"]

Implements

IAspectContainer..::..AddAspect<(Of <<'(T>)>>)(T)

See Also

AspectBase Class
Sitecore.Install.Framework Namespace


GetAspect(T) Method

[image]

Sitecore 6.4.1 API
AspectBase..::..GetAspect<(Of <(<'T>)>)> Method
AspectBase Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public T GetAspect<T>()
where T : class
Visual Basic
Public Function GetAspect(Of T As Class) As T
Visual C++
public:
generic<typename T>
where T : ref class
virtual T GetAspect() sealed

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Sitecore.Install.Framework.AspectBase.GetAspect``1"]

Return Value

The aspect.

See Also

AspectBase Class
Sitecore.Install.Framework Namespace


HasAspect(T) Method

[image]

Sitecore 6.4.1 API
AspectBase..::..HasAspect<(Of <(<'T>)>)> Method
AspectBase Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool HasAspect<T>()
where T : class
Visual Basic
Public Function HasAspect(Of T As Class) As Boolean
Visual C++
public:
generic<typename T>
where T : ref class
virtual bool HasAspect() sealed

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Sitecore.Install.Framework.AspectBase.HasAspect``1"]

Return Value

true if this instance has aspect; otherwise, false.

Implements

IAspectContainer..::..HasAspect<(Of <<'(T>)>>)()()()()

See Also

AspectBase Class
Sitecore.Install.Framework Namespace


BaseConverter(T) Class

[image]

Sitecore 6.4.1 API
BaseConverter<(Of <(<'T>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class BaseConverter<T> : IConverter<T, PackageEntry>,
    ISupportsTransforms<PackageEntry>, ISupportsAttributes
Visual Basic
Public MustInherit Class BaseConverter(Of T) _
    Implements IConverter(Of T, PackageEntry), ISupportsTransforms(Of PackageEntry),  _
    ISupportsAttributes
Visual C++
generic<typename T>
public ref class BaseConverter abstract : IConverter<T, PackageEntry^>,
    ISupportsTransforms<PackageEntry^>, ISupportsAttributes

Type Parameters

T
Source type

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..BaseConverter<(Of <(<'T>)>)>
Sitecore.Install.Files..::..RawFileToEntryConverter
Sitecore.Install.Framework..::..TrivialConverter
Sitecore.Install.Items..::..ItemToEntryConverter
Sitecore.Install.Security..::..AccountToEntryConverter

See Also

BaseConverter<(Of <(<'T>)>)> Members
Sitecore.Install.Framework Namespace


BaseConverter(T) Members

[image] [image]

Sitecore 6.4.1 API
BaseConverter<(Of <(<'T>)>)> Members
BaseConverter<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The BaseConverter<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Protected method | BaseConverter<(Of <(<'T>)>)> | Initializes a new instance of the BaseConverter<(Of <(<'T>)>)> class

Methods

 | Name | Description
Protected method | ApplyTransforms(PackageEntry, IProcessingContext) | Applies the transform.
Protected method | ApplyTransforms<(Of <<'(C>)>>)(C, IProcessingContext) | Applies the transform.
Public method | Convert | Converts the specified entry.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttribute | Gets the value of the attribute.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InternalConvert | Conversion method. Should be overriden.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetAttribute | Sets the value of the attribute.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Protected property | AutoApplyTransforms | Gets a value indicating whether the BaseConverter<(Of <(<'T>)>)> converter transforms should be applied by BaseConverter, not the derived class.
Public property | Transforms | Gets the transforms.

See Also

BaseConverter<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


BaseConverter(T) Constructor

[image]

Sitecore 6.4.1 API
BaseConverter<(Of <(<'T>)>)> Constructor
BaseConverter<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected BaseConverter()
Visual Basic
Protected Sub New
Visual C++
protected:
BaseConverter()

See Also

BaseConverter<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


BaseConverter(T) Methods

[image] [image]

Sitecore 6.4.1 API
BaseConverter<(Of <(<'T>)>)> Methods
BaseConverter<(Of <(<'T>)>)> Class See Also Send Feedback

The BaseConverter<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Protected method | ApplyTransforms(PackageEntry, IProcessingContext) | Applies the transform.
Protected method | ApplyTransforms<(Of <<'(C>)>>)(C, IProcessingContext) | Applies the transform.
Public method | Convert | Converts the specified entry.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttribute | Gets the value of the attribute.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InternalConvert | Conversion method. Should be overriden.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetAttribute | Sets the value of the attribute.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BaseConverter<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


ApplyTransforms Method

[image] [image]

Sitecore 6.4.1 API
BaseConverter<(Of <(<'T>)>)>..::..ApplyTransforms Method
BaseConverter<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | ApplyTransforms<(Of <<'(C>)>>)(C, IProcessingContext) | Applies the transform.
Protected method | ApplyTransforms(PackageEntry, IProcessingContext) | Applies the transform.

See Also

BaseConverter<(Of <(<'T>)>)> Class
BaseConverter<(Of <(<'T>)>)> Members
Sitecore.Install.Framework Namespace


ApplyTransforms(C) Method (C, IProcessingContext)

[image]

Sitecore 6.4.1 API
BaseConverter<(Of <(<'T>)>)>..::..ApplyTransforms<(Of <(<'C>)>)> Method (C, IProcessingContext)
BaseConverter<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected C ApplyTransforms<C>(
    C entries,
    IProcessingContext context
)
where C : Object, IEnumerable<PackageEntry>
Visual Basic
Protected Function ApplyTransforms(Of C As {Object, IEnumerable(Of PackageEntry)}) ( _
    entries As C, _
    context As IProcessingContext _
) As C
Visual C++
protected:
generic<typename C>
where C : Object, IEnumerable<PackageEntry^>
C ApplyTransforms(
    C entries,
    IProcessingContext^ context
)

Parameters

entries
Type: C
The entries.
context
Type: Sitecore.Install.Framework..::..IProcessingContext
The context.

Type Parameters

C

[Missing <typeparam name="C"/> documentation for "M:Sitecore.Install.Framework.BaseConverter`1.ApplyTransforms``1(``0,Sitecore.Install.Framework.IProcessingContext)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Install.Framework.BaseConverter`1.ApplyTransforms``1(``0,Sitecore.Install.Framework.IProcessingContext)"]

See Also

BaseConverter<(Of <(<'T>)>)> Class
ApplyTransforms Overload
Sitecore.Install.Framework Namespace


ApplyTransforms Method (PackageEntry, IProcessingContext)

[image]

Sitecore 6.4.1 API
BaseConverter<(Of <(<'T>)>)>..::..ApplyTransforms Method (PackageEntry, IProcessingContext)
BaseConverter<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected PackageEntry ApplyTransforms(
    PackageEntry entry,
    IProcessingContext context
)
Visual Basic
Protected Function ApplyTransforms ( _
    entry As PackageEntry, _
    context As IProcessingContext _
) As PackageEntry
Visual C++
protected:
PackageEntry^ ApplyTransforms(
    PackageEntry^ entry,
    IProcessingContext^ context
)

Parameters

entry
Type: Sitecore.Install.Framework..::..PackageEntry
The entry.
context
Type: Sitecore.Install.Framework..::..IProcessingContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Install.Framework.BaseConverter`1.ApplyTransforms(Sitecore.Install.Framework.PackageEntry,Sitecore.Install.Framework.IProcessingContext)"]

See Also

BaseConverter<(Of <(<'T>)>)> Class
ApplyTransforms Overload
Sitecore.Install.Framework Namespace


Convert Method

[image]

Sitecore 6.4.1 API
BaseConverter<(Of <(<'T>)>)>..::..Convert Method
BaseConverter<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PackageEntry[] Convert(
    T entry,
    IProcessingContext context
)
Visual Basic
Public Function Convert ( _
    entry As T, _
    context As IProcessingContext _
) As PackageEntry()
Visual C++
public:
virtual array<PackageEntry^>^ Convert(
    T entry,
    IProcessingContext^ context
) sealed

Parameters

entry
Type: T
The entry.
context
Type: Sitecore.Install.Framework..::..IProcessingContext
The processing context.

Return Value

The conversion result.

Implements

IConverter<(Of <(<'T, K>)>)>..::..Convert(T, IProcessingContext)

See Also

BaseConverter<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


GetAttribute Method

[image]

Sitecore 6.4.1 API
BaseConverter<(Of <(<'T>)>)>..::..GetAttribute Method
BaseConverter<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object GetAttribute(
    string name
)
Visual Basic
Public Function GetAttribute ( _
    name As String _
) As Object
Visual C++
public:
virtual Object^ GetAttribute(
    String^ name
) sealed

Parameters

name
Type: System..::..String
The attribute name.

Return Value

The value of the attribute.

Implements

ISupportsAttributes..::..GetAttribute(String)

See Also

BaseConverter<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


InternalConvert Method

[image]

Sitecore 6.4.1 API
BaseConverter<(Of <(<'T>)>)>..::..InternalConvert Method
BaseConverter<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected abstract PackageEntry[] InternalConvert(
    T entry,
    IProcessingContext context
)
Visual Basic
Protected MustOverride Function InternalConvert ( _
    entry As T, _
    context As IProcessingContext _
) As PackageEntry()
Visual C++
protected:
virtual array<PackageEntry^>^ InternalConvert(
    T entry,
    IProcessingContext^ context
) abstract

Parameters

entry
Type: T
The entry.
context
Type: Sitecore.Install.Framework..::..IProcessingContext
The processing context.

Return Value

The conversion result.

See Also

BaseConverter<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


BaseConverter(T) Properties

[image] [image]

Sitecore 6.4.1 API
BaseConverter<(Of <(<'T>)>)> Properties
BaseConverter<(Of <(<'T>)>)> Class See Also Send Feedback

The BaseConverter<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Protected property | AutoApplyTransforms | Gets a value indicating whether the BaseConverter<(Of <(<'T>)>)> converter transforms should be applied by BaseConverter, not the derived class.
Public property | Transforms | Gets the transforms.

See Also

BaseConverter<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


AutoApplyTransforms Property

[image]

Sitecore 6.4.1 API
BaseConverter<(Of <(<'T>)>)>..::..AutoApplyTransforms Property
BaseConverter<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool AutoApplyTransforms { get; }
Visual Basic
Protected Overridable ReadOnly Property AutoApplyTransforms As Boolean
    Get
Visual C++
protected:
virtual property bool AutoApplyTransforms {
    bool get ();
}

Field Value

true if the BaseConverter<(Of <(<'T>)>)> transforms should be applied by BaseConverter implicitly; otherwise, false.

See Also

BaseConverter<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


Transforms Property

[image]

Sitecore 6.4.1 API
BaseConverter<(Of <(<'T>)>)>..::..Transforms Property
BaseConverter<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IList<IProcessor<PackageEntry>> Transforms { get; }
Visual Basic
Public ReadOnly Property Transforms As IList(Of IProcessor(Of PackageEntry))
    Get
Visual C++
public:
virtual property IList<IProcessor<PackageEntry^>^>^ Transforms {
    IList<IProcessor<PackageEntry^>^>^ get () sealed;
}

Field Value

The transforms.

Implements

ISupportsTransforms<(Of <(<'T>)>)>..::..Transforms

See Also

BaseConverter<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


BaseSink(T) Members

[image] [image]

Sitecore 6.4.1 API
BaseSink<(Of <(<'T>)>)> Members
BaseSink<(Of <(<'T>)>)> Class Constructors Methods Fields Properties See Also Send Feedback

The BaseSink<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Protected method | BaseSink<(Of <(<'T>)>)> | Initializes a new instance of the BaseSink<(Of <(<'T>)>)> class

Methods

 | Name | Description
Protected method | AssertInit | Asserts the init.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finishes the sink.
Public method | Flush | Flushes the sink
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this instance.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put | Puts the specified entry.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _processingContext |

Properties

 | Name | Description
Public property | IsInitialized | Gets a value indicating whether this instance is initialized.
Public property | ProcessingContext | Gets the processing context.

See Also

BaseSink<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


BaseSink(T) Constructor

[image]

Sitecore 6.4.1 API
BaseSink<(Of <(<'T>)>)> Constructor
BaseSink<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected BaseSink()
Visual Basic
Protected Sub New
Visual C++
protected:
BaseSink()

See Also

BaseSink<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


BaseSink(T) Fields

[image] [image]

Sitecore 6.4.1 API
BaseSink<(Of <(<'T>)>)> Fields
BaseSink<(Of <(<'T>)>)> Class See Also Send Feedback

The BaseSink<(Of <(<'T>)>)> type exposes the following members.

Fields

 | Name | Description
Protected field | _processingContext |

See Also

BaseSink<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


_processingContext Field

[image]

Sitecore 6.4.1 API
BaseSink<(Of <(<'T>)>)>..::.._processingContext Field
BaseSink<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected IProcessingContext _processingContext
Visual Basic
Protected _processingContext As IProcessingContext
Visual C++
protected:
IProcessingContext^ _processingContext

See Also

BaseSink<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


BaseSink(T) Methods

[image] [image]

Sitecore 6.4.1 API
BaseSink<(Of <(<'T>)>)> Methods
BaseSink<(Of <(<'T>)>)> Class See Also Send Feedback

The BaseSink<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Protected method | AssertInit | Asserts the init.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finishes the sink.
Public method | Flush | Flushes the sink
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this instance.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put | Puts the specified entry.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BaseSink<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


AssertInit Method

[image]

Sitecore 6.4.1 API
BaseSink<(Of <(<'T>)>)>..::..AssertInit Method
BaseSink<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void AssertInit()
Visual Basic
Protected Sub AssertInit
Visual C++
protected:
void AssertInit()

See Also

BaseSink<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


Finish Method

[image]

Sitecore 6.4.1 API
BaseSink<(Of <(<'T>)>)>..::..Finish Method
BaseSink<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Finish()
Visual Basic
Public Overridable Sub Finish
Visual C++
public:
virtual void Finish()

Implements

ISink<(Of <(<'T>)>)>..::..Finish()()()()

See Also

BaseSink<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


Flush Method

[image]

Sitecore 6.4.1 API
BaseSink<(Of <(<'T>)>)>..::..Flush Method
BaseSink<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Flush()
Visual Basic
Public Overridable Sub Flush
Visual C++
public:
virtual void Flush()

Implements

ISink<(Of <(<'T>)>)>..::..Flush()()()()

See Also

BaseSink<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
BaseSink<(Of <(<'T>)>)>..::..Initialize Method
BaseSink<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Initialize(
    IProcessingContext context
)
Visual Basic
Public Overridable Sub Initialize ( _
    context As IProcessingContext _
)
Visual C++
public:
virtual void Initialize(
    IProcessingContext^ context
)

Parameters

context
Type: Sitecore.Install.Framework..::..IProcessingContext
The context.

Implements

ISink<(Of <(<'T>)>)>..::..Initialize(IProcessingContext)

See Also

BaseSink<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


Put Method

[image]

Sitecore 6.4.1 API
BaseSink<(Of <(<'T>)>)>..::..Put Method
BaseSink<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract void Put(
    T entry
)
Visual Basic
Public MustOverride Sub Put ( _
    entry As T _
)
Visual C++
public:
virtual void Put(
    T entry
) abstract

Parameters

entry
Type: T
The entry.

Implements

ISink<(Of <(<'T>)>)>..::..Put(T)

See Also

BaseSink<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


BaseSink(T) Properties

[image] [image]

Sitecore 6.4.1 API
BaseSink<(Of <(<'T>)>)> Properties
BaseSink<(Of <(<'T>)>)> Class See Also Send Feedback

The BaseSink<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | IsInitialized | Gets a value indicating whether this instance is initialized.
Public property | ProcessingContext | Gets the processing context.

See Also

BaseSink<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


IsInitialized Property

[image]

Sitecore 6.4.1 API
BaseSink<(Of <(<'T>)>)>..::..IsInitialized Property
BaseSink<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsInitialized { get; }
Visual Basic
Public ReadOnly Property IsInitialized As Boolean
    Get
Visual C++
public:
virtual property bool IsInitialized {
    bool get () sealed;
}

Field Value

true if this instance is initialized; otherwise, false.

Implements

ISink<(Of <(<'T>)>)>..::..IsInitialized

See Also

BaseSink<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


ProcessingContext Property

[image]

Sitecore 6.4.1 API
BaseSink<(Of <(<'T>)>)>..::..ProcessingContext Property
BaseSink<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IProcessingContext ProcessingContext { get; }
Visual Basic
Public ReadOnly Property ProcessingContext As IProcessingContext
    Get
Visual C++
public:
virtual property IProcessingContext^ ProcessingContext {
    IProcessingContext^ get () sealed;
}

Field Value

The processing context.

Implements

ISink<(Of <(<'T>)>)>..::..ProcessingContext

See Also

BaseSink<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


BaseSource(T) Class

[image]

Sitecore 6.4.1 API
BaseSource<(Of <(<'T>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class BaseSource<T> : ISource<PackageEntry>,
    INamedObject, ISupportsFiltering, ISupportsTransforms<PackageEntry>
Visual Basic
Public MustInherit Class BaseSource(Of T) _
    Implements ISource(Of PackageEntry), INamedObject,  _
    ISupportsFiltering, ISupportsTransforms(Of PackageEntry)
Visual C++
generic<typename T>
public ref class BaseSource abstract : ISource<PackageEntry^>,
    INamedObject, ISupportsFiltering, ISupportsTransforms<PackageEntry^>

Type Parameters

T
Entry type

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..BaseSource<(Of <(<'T>)>)>
Sitecore.Install.Files..::..ExplicitFileSystemSource
Sitecore.Install.Files..::..FileSystemSource
Sitecore.Install.Items..::..ExplicitItemSource
Sitecore.Install.Items..::..ItemSource
Sitecore.Install..::..PackageProject
Sitecore.Install.Security..::..SecuritySource

See Also

BaseSource<(Of <(<'T>)>)> Members
Sitecore.Install.Framework Namespace


BaseSource(T) Members

[image] [image]

Sitecore 6.4.1 API
BaseSource<(Of <(<'T>)>)> Members
BaseSource<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The BaseSource<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Protected method | BaseSource<(Of <(<'T>)>)> | Initializes a new instance of the BaseSource<(Of <(<'T>)>)> class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InternalPopulate | To be overridden in descendants
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Populates this sourse from the specified sink.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Converter | Gets or sets the converter.
Public property | Exclude | Gets the exclude filters.
Public property | Include | Gets the include filters.
Public property | Name | Gets or sets the name.

See Also

BaseSource<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


BaseSource(T) Constructor

[image]

Sitecore 6.4.1 API
BaseSource<(Of <(<'T>)>)> Constructor
BaseSource<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected BaseSource()
Visual Basic
Protected Sub New
Visual C++
protected:
BaseSource()

See Also

BaseSource<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


BaseSource(T) Methods

[image] [image]

Sitecore 6.4.1 API
BaseSource<(Of <(<'T>)>)> Methods
BaseSource<(Of <(<'T>)>)> Class See Also Send Feedback

The BaseSource<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InternalPopulate | To be overridden in descendants
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Populates this sourse from the specified sink.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BaseSource<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


BaseSource(T) Properties

[image] [image]

Sitecore 6.4.1 API
BaseSource<(Of <(<'T>)>)> Properties
BaseSource<(Of <(<'T>)>)> Class See Also Send Feedback

The BaseSource<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Converter | Gets or sets the converter.
Public property | Exclude | Gets the exclude filters.
Public property | Include | Gets the include filters.
Public property | Name | Gets or sets the name.

See Also

BaseSource<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


Converter Property

[image]

Sitecore 6.4.1 API
BaseSource<(Of <(<'T>)>)>..::..Converter Property
BaseSource<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IConverter<T, PackageEntry> Converter { get; set; }
Visual Basic
Public Property Converter As IConverter(Of T, PackageEntry)
    Get
    Set
Visual C++
public:
property IConverter<T, PackageEntry^>^ Converter {
    IConverter<T, PackageEntry^>^ get ();
    void set (IConverter<T, PackageEntry^>^ value);
}

Field Value

The converter.

See Also

BaseSource<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


Exclude Property

[image]

Sitecore 6.4.1 API
BaseSource<(Of <(<'T>)>)>..::..Exclude Property
BaseSource<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IList<IFilter> Exclude { get; }
Visual Basic
Public ReadOnly Property Exclude As IList(Of IFilter)
    Get
Visual C++
public:
virtual property IList<IFilter^>^ Exclude {
    IList<IFilter^>^ get () sealed;
}

Field Value

The exclude filters.

Implements

ISupportsFiltering..::..Exclude

See Also

BaseSource<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


Include Property

[image]

Sitecore 6.4.1 API
BaseSource<(Of <(<'T>)>)>..::..Include Property
BaseSource<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IList<IFilter> Include { get; }
Visual Basic
Public ReadOnly Property Include As IList(Of IFilter)
    Get
Visual C++
public:
virtual property IList<IFilter^>^ Include {
    IList<IFilter^>^ get () sealed;
}

Field Value

The include filters.

Implements

ISupportsFiltering..::..Include

See Also

BaseSource<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


Name Property

[image]

Sitecore 6.4.1 API
BaseSource<(Of <(<'T>)>)>..::..Name Property
BaseSource<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Field Value

The name.

Implements

INamedObject..::..Name

See Also

BaseSource<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


BaseSource(T).InternalSink Class

[image]

Sitecore 6.4.1 API
BaseSource<(Of <(<'T>)>)>..::..InternalSink Class
BaseSource<(Of <(<'T>)>)> Class Members See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected class InternalSink : BaseSink<T>
Visual Basic
Protected Class InternalSink _
    Inherits BaseSink(Of T)
Visual C++
protected ref class InternalSink : public BaseSink<T>

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..BaseSink <(Of <(<' T >)>)>
Sitecore.Install.Framework..::..BaseSource<(Of <(<'T>)>)>..::..InternalSink

See Also

BaseSource<(Of <(<'T>)>)>..::..InternalSink Members
Sitecore.Install.Framework Namespace


BaseSource(T).InternalSink Fields

[image] [image]

Sitecore 6.4.1 API
BaseSource<(Of <(<'T>)>)>..::..InternalSink Fields
BaseSource<(Of <(<'T>)>)>..::..InternalSink Class See Also Send Feedback

The BaseSource<(Of <(<'T>)>)>..::..InternalSink generic type exposes the following members.

Fields

 | Name | Description
Protected field | _processingContext | (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

BaseSource<(Of <(<'T>)>)>..::..InternalSink Class
Sitecore.Install.Framework Namespace


BaseSource(T).InternalSink Methods

[image] [image]

Sitecore 6.4.1 API
BaseSource<(Of <(<'T>)>)>..::..InternalSink Methods
BaseSource<(Of <(<'T>)>)>..::..InternalSink Class See Also Send Feedback

The BaseSource<(Of <(<'T>)>)>..::..InternalSink generic type exposes the following members.

Methods

 | Name | Description
Protected method | AssertInit | Asserts the init. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finishes the sink. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Flush | Flushes the sink (Overrides BaseSink<(Of <(<'T>)>)>..::..Flush()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this instance. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put | Puts the specified entry. (Overrides BaseSink<(Of <(<'T>)>)>..::..Put(T).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BaseSource<(Of <(<'T>)>)>..::..InternalSink Class
Sitecore.Install.Framework Namespace


Flush Method

[image]

Sitecore 6.4.1 API
BaseSource<(Of <(<'T>)>)>..::..InternalSink..::..Flush Method
BaseSource<(Of <(<'T>)>)>..::..InternalSink Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Flush()
Visual Basic
Public Overrides Sub Flush
Visual C++
public:
virtual void Flush() override

Implements

ISink<(Of <(<'T>)>)>..::..Flush()()()()

See Also

BaseSource<(Of <(<'T>)>)>..::..InternalSink Class
Sitecore.Install.Framework Namespace


Put Method

[image]

Sitecore 6.4.1 API
BaseSource<(Of <(<'T>)>)>..::..InternalSink..::..Put Method
BaseSource<(Of <(<'T>)>)>..::..InternalSink Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Put(
    T entry
)
Visual Basic
Public Overrides Sub Put ( _
    entry As T _
)
Visual C++
public:
virtual void Put(
    T entry
) override

Parameters

entry
Type: T
The entry.

Implements

ISink<(Of <(<'T>)>)>..::..Put(T)

See Also

BaseSource<(Of <(<'T>)>)>..::..InternalSink Class
Sitecore.Install.Framework Namespace


BaseSource(T).InternalSink Properties

[image] [image]

Sitecore 6.4.1 API
BaseSource<(Of <(<'T>)>)>..::..InternalSink Properties
BaseSource<(Of <(<'T>)>)>..::..InternalSink Class See Also Send Feedback

The BaseSource<(Of <(<'T>)>)>..::..InternalSink generic type exposes the following members.

Properties

 | Name | Description
Public property | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

BaseSource<(Of <(<'T>)>)>..::..InternalSink Class
Sitecore.Install.Framework Namespace


DefaultOutput Class

[image]

Sitecore 6.4.1 API
DefaultOutput Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DefaultOutput : ITaskOutput
Visual Basic
Public Class DefaultOutput _
    Implements ITaskOutput
Visual C++
public ref class DefaultOutput : ITaskOutput

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..DefaultOutput

See Also

DefaultOutput Members
Sitecore.Install.Framework Namespace


DefaultOutput Members

[image] [image]

Sitecore 6.4.1 API
DefaultOutput Members
DefaultOutput Class Constructors Methods See Also Send Feedback

The DefaultOutput type exposes the following members.

Constructors

 | Name | Description
Public method | DefaultOutput | Initializes a new instance of the DefaultOutput class

Methods

 | Name | Description
Public method | Alert | Shows an alert form.
Public method | Confirm | Shows the confirmation dialog.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute(ThreadStart) | Executes the callback asynchronuosly
Public method | Execute(Callback) | Executes the specified callback.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RunPipeline | Executes the specified pipeline callback.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultOutput Class
Sitecore.Install.Framework Namespace


DefaultOutput Constructor

[image]

Sitecore 6.4.1 API
DefaultOutput Constructor
DefaultOutput Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DefaultOutput()
Visual Basic
Public Sub New
Visual C++
public:
DefaultOutput()

See Also

DefaultOutput Class
Sitecore.Install.Framework Namespace


DefaultOutput Methods

[image] [image]

Sitecore 6.4.1 API
DefaultOutput Methods
DefaultOutput Class See Also Send Feedback

The DefaultOutput type exposes the following members.

Methods

 | Name | Description
Public method | Alert | Shows an alert form.
Public method | Confirm | Shows the confirmation dialog.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute(ThreadStart) | Executes the callback asynchronuosly
Public method | Execute(Callback) | Executes the specified callback.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RunPipeline | Executes the specified pipeline callback.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultOutput Class
Sitecore.Install.Framework Namespace


Alert Method

[image]

Sitecore 6.4.1 API
DefaultOutput..::..Alert Method
DefaultOutput Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Alert(
    string message
)
Visual Basic
Public Sub Alert ( _
    message As String _
)
Visual C++
public:
virtual void Alert(
    String^ message
) sealed

Parameters

message
Type: System..::..String
The message.

Implements

ITaskOutput..::..Alert(String)

See Also

DefaultOutput Class
Sitecore.Install.Framework Namespace


Confirm Method

[image]

Sitecore 6.4.1 API
DefaultOutput..::..Confirm Method
DefaultOutput Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Confirm(
    string message
)
Visual Basic
Public Function Confirm ( _
    message As String _
) As String
Visual C++
public:
virtual String^ Confirm(
    String^ message
) sealed

Parameters

message
Type: System..::..String
The message.

Return Value

The confirmation result.

Implements

ITaskOutput..::..Confirm(String)

See Also

DefaultOutput Class
Sitecore.Install.Framework Namespace


Execute Method

[image] [image]

Sitecore 6.4.1 API
DefaultOutput..::..Execute Method
DefaultOutput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Execute(ThreadStart) | Executes the callback asynchronuosly
Public method | Execute(Callback) | Executes the specified callback.

See Also

DefaultOutput Class
DefaultOutput Members
Sitecore.Install.Framework Namespace


Execute Method (ThreadStart)

[image]

Sitecore 6.4.1 API
DefaultOutput..::..Execute Method (ThreadStart)
DefaultOutput Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Execute(
    ThreadStart callback
)
Visual Basic
Public Sub Execute ( _
    callback As ThreadStart _
)
Visual C++
public:
virtual void Execute(
    ThreadStart^ callback
) sealed

Parameters

callback
Type: System.Threading..::..ThreadStart
The callback.

Implements

ITaskOutput..::..Execute(ThreadStart)

See Also

DefaultOutput Class
Execute Overload
Sitecore.Install.Framework Namespace


Execute Method (Callback)

[image]

Sitecore 6.4.1 API
DefaultOutput..::..Execute Method (Callback)
DefaultOutput Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object Execute(
    Callback callback
)
Visual Basic
Public Function Execute ( _
    callback As Callback _
) As Object
Visual C++
public:
virtual Object^ Execute(
    Callback^ callback
) sealed

Parameters

callback
Type: Sitecore.Jobs.AsyncUI..::..Callback
The callback.

Return Value

The execute.

Implements

ITaskOutput..::..Execute(Callback)

See Also

DefaultOutput Class
Execute Overload
Sitecore.Install.Framework Namespace


RunPipeline Method

[image]

Sitecore 6.4.1 API
DefaultOutput..::..RunPipeline Method
DefaultOutput Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object RunPipeline(
    PipelineCallback callback
)
Visual Basic
Public Function RunPipeline ( _
    callback As PipelineCallback _
) As Object
Visual C++
public:
virtual Object^ RunPipeline(
    PipelineCallback^ callback
) sealed

Parameters

callback
Type: Sitecore.Jobs.AsyncUI..::..PipelineCallback
The callback.

Return Value

The execute.

Implements

ITaskOutput..::..RunPipeline(PipelineCallback)

See Also

DefaultOutput Class
Sitecore.Install.Framework Namespace


EntryBuilder Class

[image]

Sitecore 6.4.1 API
EntryBuilder Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class EntryBuilder : BaseSink<IEntryData>
Visual Basic
Public Class EntryBuilder _
    Inherits BaseSink(Of IEntryData)
Visual C++
public ref class EntryBuilder : public BaseSink<IEntryData^>

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..BaseSink <(Of <(<' IEntryData >)>)>
Sitecore.Install.Framework..::..EntryBuilder

See Also

EntryBuilder Members
Sitecore.Install.Framework Namespace


EntryBuilder Members

[image] [image]

Sitecore 6.4.1 API
EntryBuilder Members
EntryBuilder Class Constructors Methods Fields Properties See Also Send Feedback

The EntryBuilder type exposes the following members.

Constructors

 | Name | Description
Public method | EntryBuilder | Initializes a new instance of the EntryBuilder class.

Methods

 | Name | Description
Protected method | AssertInit | Asserts the init. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finishes the sink. (Overrides BaseSink<(Of <(<'T>)>)>..::..Finish()()()().)
Public method | Flush | Flushes the sink (Overrides BaseSink<(Of <(<'T>)>)>..::..Flush()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this instance. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put | Puts the specified entry. (Overrides BaseSink<(Of <(<'T>)>)>..::..Put(T).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _processingContext | (Inherited from BaseSink<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

EntryBuilder Class
Sitecore.Install.Framework Namespace


EntryBuilder Constructor

[image]

Sitecore 6.4.1 API
EntryBuilder Constructor
EntryBuilder Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public EntryBuilder(
    ISink<PackageEntry> sink
)
Visual Basic
Public Sub New ( _
    sink As ISink(Of PackageEntry) _
)
Visual C++
public:
EntryBuilder(
    ISink<PackageEntry^>^ sink
)

Parameters

sink
Type: Sitecore.Install.Framework..::..ISink <(Of <(<' PackageEntry >)>)>
The sink.

See Also

EntryBuilder Class
Sitecore.Install.Framework Namespace


EntryBuilder Fields

[image] [image]

Sitecore 6.4.1 API
EntryBuilder Fields
EntryBuilder Class See Also Send Feedback

The EntryBuilder type exposes the following members.

Fields

 | Name | Description
Protected field | _processingContext | (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

EntryBuilder Class
Sitecore.Install.Framework Namespace


EntryBuilder Methods

[image] [image]

Sitecore 6.4.1 API
EntryBuilder Methods
EntryBuilder Class See Also Send Feedback

The EntryBuilder type exposes the following members.

Methods

 | Name | Description
Protected method | AssertInit | Asserts the init. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finishes the sink. (Overrides BaseSink<(Of <(<'T>)>)>..::..Finish()()()().)
Public method | Flush | Flushes the sink (Overrides BaseSink<(Of <(<'T>)>)>..::..Flush()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this instance. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put | Puts the specified entry. (Overrides BaseSink<(Of <(<'T>)>)>..::..Put(T).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EntryBuilder Class
Sitecore.Install.Framework Namespace


Flush Method

[image]

Sitecore 6.4.1 API
EntryBuilder..::..Flush Method
EntryBuilder Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Flush()
Visual Basic
Public Overrides Sub Flush
Visual C++
public:
virtual void Flush() override

Implements

ISink<(Of <(<'T>)>)>..::..Flush()()()()

See Also

EntryBuilder Class
Sitecore.Install.Framework Namespace


Put Method

[image]

Sitecore 6.4.1 API
EntryBuilder..::..Put Method
EntryBuilder Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Put(
    IEntryData entry
)
Visual Basic
Public Overrides Sub Put ( _
    entry As IEntryData _
)
Visual C++
public:
virtual void Put(
    IEntryData^ entry
) override

Parameters

entry
Type: Sitecore.Install.Framework..::..IEntryData
The entry.

Implements

ISink<(Of <(<'T>)>)>..::..Put(T)

See Also

EntryBuilder Class
Sitecore.Install.Framework Namespace


EntryBuilder Properties

[image] [image]

Sitecore 6.4.1 API
EntryBuilder Properties
EntryBuilder Class See Also Send Feedback

The EntryBuilder type exposes the following members.

Properties

 | Name | Description
Public property | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

EntryBuilder Class
Sitecore.Install.Framework Namespace


FilteringSink(T) Class

[image]

Sitecore 6.4.1 API
FilteringSink<(Of <(<'T>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FilteringSink<T> : BaseSink<T>,
    ISupportsFiltering
Visual Basic
Public Class FilteringSink(Of T) _
    Inherits BaseSink(Of T) _
    Implements ISupportsFiltering
Visual C++
generic<typename T>
public ref class FilteringSink : public BaseSink<T>,
    ISupportsFiltering

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Sitecore.Install.Framework.FilteringSink`1"]

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..BaseSink <(Of <(<' T >)>)>
Sitecore.Install.Framework..::..FilteringSink<(Of <(<'T>)>)>

See Also

FilteringSink<(Of <(<'T>)>)> Members
Sitecore.Install.Framework Namespace


FilteringSink(T) Members

[image] [image]

Sitecore 6.4.1 API
FilteringSink<(Of <(<'T>)>)> Members
FilteringSink<(Of <(<'T>)>)> Class Constructors Methods Fields Properties See Also Send Feedback

The FilteringSink<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | FilteringSink<(Of <(<'T>)>)>(ISink<(Of <<'(T>)>>)) | Initializes a new instance of the FilteringSink<(Of <(<'T>)>)> class.
Public method | FilteringSink<(Of <(<'T>)>)>(ISink<(Of <<'(T>)>>), IList<(Of <<'(IFilter>)>>), IList<(Of <<'(IFilter>)>>)) | Initializes a new instance of the FilteringSink<(Of <(<'T>)>)> class.

Methods

 | Name | Description
Protected method | AssertInit | Asserts the init. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finishes the sink. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Flush | Flushes the sink (Overrides BaseSink<(Of <(<'T>)>)>..::..Flush()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this instance. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put(T) | Puts the specified entry. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Put(T) | Puts the specified entry to the sink if the entry satisfies the filters.
Protected method | Qualify | Qualifies the specified entry.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _processingContext | (Inherited from BaseSink<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Exclude | Gets the exclude filters.
Public property | Include | Gets the include filters.
Public property | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

FilteringSink<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


FilteringSink(T) Constructor

[image] [image]

Sitecore 6.4.1 API
FilteringSink<(Of <(<'T>)>)> Constructor
FilteringSink<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FilteringSink<(Of <(<'T>)>)>(ISink<(Of <<'(T>)>>)) | Initializes a new instance of the FilteringSink<(Of <(<'T>)>)> class.
Public method | FilteringSink<(Of <(<'T>)>)>(ISink<(Of <<'(T>)>>), IList<(Of <<'(IFilter>)>>), IList<(Of <<'(IFilter>)>>)) | Initializes a new instance of the FilteringSink<(Of <(<'T>)>)> class.

See Also

FilteringSink<(Of <(<'T>)>)> Class
FilteringSink<(Of <(<'T>)>)> Members
Sitecore.Install.Framework Namespace


FilteringSink(T) Constructor (ISink(T))

[image]

Sitecore 6.4.1 API
FilteringSink<(Of <(<'T>)>)> Constructor (ISink<(Of <(<'T>)>)>)
FilteringSink<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FilteringSink(
    ISink<T> sink
)
Visual Basic
Public Sub New ( _
    sink As ISink(Of T) _
)
Visual C++
public:
FilteringSink(
    ISink<T>^ sink
)

Parameters

sink
Type: Sitecore.Install.Framework..::..ISink <(Of <(<' T >)>)>
The inner sink.

See Also

FilteringSink<(Of <(<'T>)>)> Class
FilteringSink<(Of <(<'T>)>)> Overload
Sitecore.Install.Framework Namespace


FilteringSink(T) Constructor (ISink(T), IList(IFilter), IList(IFilter))

[image]

Sitecore 6.4.1 API
FilteringSink<(Of <(<'T>)>)> Constructor (ISink<(Of <(<'T>)>)>, IList<(Of <(<'IFilter>)>)>, IList<(Of <(<'IFilter>)>)>)
FilteringSink<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FilteringSink(
    ISink<T> sink,
    IList<IFilter> include,
    IList<IFilter> exclude
)
Visual Basic
Public Sub New ( _
    sink As ISink(Of T), _
    include As IList(Of IFilter), _
    exclude As IList(Of IFilter) _
)
Visual C++
public:
FilteringSink(
    ISink<T>^ sink,
    IList<IFilter^>^ include,
    IList<IFilter^>^ exclude
)

Parameters

sink
Type: Sitecore.Install.Framework..::..ISink <(Of <(<' T >)>)>
The inner sink.
include
Type: System.Collections.Generic..::..IList <(Of <(<' IFilter >)>)>
The include filters.
exclude
Type: System.Collections.Generic..::..IList <(Of <(<' IFilter >)>)>
The exclude filters.

See Also

FilteringSink<(Of <(<'T>)>)> Class
FilteringSink<(Of <(<'T>)>)> Overload
Sitecore.Install.Framework Namespace


FilteringSink(T) Fields

[image] [image]

Sitecore 6.4.1 API
FilteringSink<(Of <(<'T>)>)> Fields
FilteringSink<(Of <(<'T>)>)> Class See Also Send Feedback

The FilteringSink<(Of <(<'T>)>)> type exposes the following members.

Fields

 | Name | Description
Protected field | _processingContext | (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

FilteringSink<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


FilteringSink(T) Methods

[image] [image]

Sitecore 6.4.1 API
FilteringSink<(Of <(<'T>)>)> Methods
FilteringSink<(Of <(<'T>)>)> Class See Also Send Feedback

The FilteringSink<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Protected method | AssertInit | Asserts the init. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finishes the sink. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Flush | Flushes the sink (Overrides BaseSink<(Of <(<'T>)>)>..::..Flush()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this instance. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put(T) | Puts the specified entry. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Put(T) | Puts the specified entry to the sink if the entry satisfies the filters.
Protected method | Qualify | Qualifies the specified entry.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilteringSink<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


Flush Method

[image]

Sitecore 6.4.1 API
FilteringSink<(Of <(<'T>)>)>..::..Flush Method
FilteringSink<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Flush()
Visual Basic
Public Overrides Sub Flush
Visual C++
public:
virtual void Flush() override

Implements

ISink<(Of <(<'T>)>)>..::..Flush()()()()

See Also

FilteringSink<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


Put Method

[image] [image]

Sitecore 6.4.1 API
FilteringSink<(Of <(<'T>)>)>..::..Put Method
FilteringSink<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Put(T) | Puts the specified entry. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Put(T) | Puts the specified entry to the sink if the entry satisfies the filters.

See Also

FilteringSink<(Of <(<'T>)>)> Class
FilteringSink<(Of <(<'T>)>)> Members
Sitecore.Install.Framework Namespace


Put Method (T)

[image]

Sitecore 6.4.1 API
FilteringSink<(Of <(<'T>)>)>..::..Put Method (T)
FilteringSink<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Put(
    T entry
)
Visual Basic
Public Overridable Sub Put ( _
    entry As T _
)
Visual C++
public:
virtual void Put(
    T entry
)

Parameters

entry
Type: T
The entry.

See Also

FilteringSink<(Of <(<'T>)>)> Class
Put Overload
Sitecore.Install.Framework Namespace


Qualify Method

[image]

Sitecore 6.4.1 API
FilteringSink<(Of <(<'T>)>)>..::..Qualify Method
FilteringSink<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool Qualify(
    T entry
)
Visual Basic
Protected Overridable Function Qualify ( _
    entry As T _
) As Boolean
Visual C++
protected:
virtual bool Qualify(
    T entry
)

Parameters

entry
Type: T
The entry.

Return Value

The qualify.

See Also

FilteringSink<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


FilteringSink(T) Properties

[image] [image]

Sitecore 6.4.1 API
FilteringSink<(Of <(<'T>)>)> Properties
FilteringSink<(Of <(<'T>)>)> Class See Also Send Feedback

The FilteringSink<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Exclude | Gets the exclude filters.
Public property | Include | Gets the include filters.
Public property | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

FilteringSink<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


Exclude Property

[image]

Sitecore 6.4.1 API
FilteringSink<(Of <(<'T>)>)>..::..Exclude Property
FilteringSink<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IList<IFilter> Exclude { get; }
Visual Basic
Public ReadOnly Property Exclude As IList(Of IFilter)
    Get
Visual C++
public:
virtual property IList<IFilter^>^ Exclude {
    IList<IFilter^>^ get () sealed;
}

Field Value

The exclude filters.

Implements

ISupportsFiltering..::..Exclude

See Also

FilteringSink<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


Include Property

[image]

Sitecore 6.4.1 API
FilteringSink<(Of <(<'T>)>)>..::..Include Property
FilteringSink<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IList<IFilter> Include { get; }
Visual Basic
Public ReadOnly Property Include As IList(Of IFilter)
    Get
Visual C++
public:
virtual property IList<IFilter^>^ Include {
    IList<IFilter^>^ get () sealed;
}

Field Value

The include filters.

Implements

ISupportsFiltering..::..Include

See Also

FilteringSink<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


IAspectContainer Interface

[image]

Sitecore 6.4.1 API
IAspectContainer Interface
Members See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IAspectContainer
Visual Basic
Public Interface IAspectContainer
Visual C++
public interface class IAspectContainer

See Also

IAspectContainer Members
Sitecore.Install.Framework Namespace


IAspectContainer Members

[image] [image]

Sitecore 6.4.1 API
IAspectContainer Members
IAspectContainer Interface Methods See Also Send Feedback

The IAspectContainer type exposes the following members.

Methods

 | Name | Description
Public method | AddAspect<(Of <<'(T>)>>) | Adds the aspect.
Public method | GetAspect<(Of <<'(T>)>>) | Gets the aspect.
Public method | HasAspect<(Of <<'(T>)>>) | Determines whether this instance has aspect.

See Also

IAspectContainer Interface
Sitecore.Install.Framework Namespace


IAspectContainer Methods

[image] [image]

Sitecore 6.4.1 API
IAspectContainer Methods
IAspectContainer Interface See Also Send Feedback

The IAspectContainer type exposes the following members.

Methods

 | Name | Description
Public method | AddAspect<(Of <<'(T>)>>) | Adds the aspect.
Public method | GetAspect<(Of <<'(T>)>>) | Gets the aspect.
Public method | HasAspect<(Of <<'(T>)>>) | Determines whether this instance has aspect.

See Also

IAspectContainer Interface
Sitecore.Install.Framework Namespace


AddAspect(T) Method

[image]

Sitecore 6.4.1 API
IAspectContainer..::..AddAspect<(Of <(<'T>)>)> Method
IAspectContainer Interface See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void AddAspect<T>(
    T instance
)
where T : class
Visual Basic
Sub AddAspect(Of T As Class) ( _
    instance As T _
)
Visual C++
generic<typename T>
where T : ref class
void AddAspect(
    T instance
)

Parameters

instance
Type: T
The instance.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Sitecore.Install.Framework.IAspectContainer.AddAspect``1(``0)"]

See Also

IAspectContainer Interface
Sitecore.Install.Framework Namespace


HasAspect(T) Method

[image]

Sitecore 6.4.1 API
IAspectContainer..::..HasAspect<(Of <(<'T>)>)> Method
IAspectContainer Interface See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
bool HasAspect<T>()
where T : class
Visual Basic
Function HasAspect(Of T As Class) As Boolean
Visual C++
generic<typename T>
where T : ref class
bool HasAspect()

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Sitecore.Install.Framework.IAspectContainer.HasAspect``1"]

Return Value

true if this instance has aspect; otherwise, false.

See Also

IAspectContainer Interface
Sitecore.Install.Framework Namespace


IConverter(T, K) Members

[image] [image]

Sitecore 6.4.1 API
IConverter<(Of <(<'T, K>)>)> Members
IConverter<(Of <(<'T, K>)>)> Interface Methods Properties See Also Send Feedback

The IConverter<(Of <(<'T, K>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts the specified entry.
Public method | GetAttribute | Gets the value of the attribute. (Inherited from ISupportsAttributes.)
Public method | SetAttribute | Sets the value of the attribute. (Inherited from ISupportsAttributes.)

Properties

 | Name | Description
Public property | Transforms | Gets the transforms. (Inherited from ISupportsTransforms<(Of <(<'T>)>)>.)

See Also

IConverter<(Of <(<'T, K>)>)> Interface
Sitecore.Install.Framework Namespace


IConverter(T, K) Methods

[image] [image]

Sitecore 6.4.1 API
IConverter<(Of <(<'T, K>)>)> Methods
IConverter<(Of <(<'T, K>)>)> Interface See Also Send Feedback

The IConverter<(Of <(<'T, K>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts the specified entry.
Public method | GetAttribute | Gets the value of the attribute. (Inherited from ISupportsAttributes.)
Public method | SetAttribute | Sets the value of the attribute. (Inherited from ISupportsAttributes.)

See Also

IConverter<(Of <(<'T, K>)>)> Interface
Sitecore.Install.Framework Namespace


Convert Method

[image]

Sitecore 6.4.1 API
IConverter<(Of <(<'T, K>)>)>..::..Convert Method
IConverter<(Of <(<'T, K>)>)> Interface See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
K[] Convert(
    T entry,
    IProcessingContext context
)
Visual Basic
Function Convert ( _
    entry As T, _
    context As IProcessingContext _
) As K()
Visual C++
array<K>^ Convert(
    T entry,
    IProcessingContext^ context
)

Parameters

entry
Type: T
The entry.
context
Type: Sitecore.Install.Framework..::..IProcessingContext
The processing context.

Return Value

The conversion result.

See Also

IConverter<(Of <(<'T, K>)>)> Interface
Sitecore.Install.Framework Namespace


IConverter(T, K) Properties

[image] [image]

Sitecore 6.4.1 API
IConverter<(Of <(<'T, K>)>)> Properties
IConverter<(Of <(<'T, K>)>)> Interface See Also Send Feedback

The IConverter<(Of <(<'T, K>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Transforms | Gets the transforms. (Inherited from ISupportsTransforms<(Of <(<'T>)>)>.)

See Also

IConverter<(Of <(<'T, K>)>)> Interface
Sitecore.Install.Framework Namespace


IEntryData Members

[image] [image]

Sitecore 6.4.1 API
IEntryData Members
IEntryData Interface Methods Properties See Also Send Feedback

The IEntryData type exposes the following members.

Methods

 | Name | Description
Public method | GetStream | Gets the stream holder.

Properties

 | Name | Description
Public property | Key | Gets the key.

See Also

IEntryData Interface
Sitecore.Install.Framework Namespace


GetStream Method

[image]

Sitecore 6.4.1 API
IEntryData..::..GetStream Method
IEntryData Interface See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
IStreamHolder GetStream()
Visual Basic
Function GetStream As IStreamHolder
Visual C++
IStreamHolder^ GetStream()

Return Value

The stream holder.

See Also

IEntryData Interface
Sitecore.Install.Framework Namespace


IEntryData Properties

[image] [image]

Sitecore 6.4.1 API
IEntryData Properties
IEntryData Interface See Also Send Feedback

The IEntryData type exposes the following members.

Properties

 | Name | Description
Public property | Key | Gets the key.

See Also

IEntryData Interface
Sitecore.Install.Framework Namespace


Key Property

[image]

Sitecore 6.4.1 API
IEntryData..::..Key Property
IEntryData Interface See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
string Key { get; }
Visual Basic
ReadOnly Property Key As String
    Get
Visual C++
property String^ Key {
    String^ get ();
}

Field Value

The key.

See Also

IEntryData Interface
Sitecore.Install.Framework Namespace


IExplicitSource Interface

[image]

Sitecore 6.4.1 API
IExplicitSource Interface
Members See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IExplicitSource : IKeyResolver
Visual Basic
Public Interface IExplicitSource _
    Inherits IKeyResolver
Visual C++
public interface class IExplicitSource : IKeyResolver

See Also

IExplicitSource Members
Sitecore.Install.Framework Namespace


IExplicitSource Members

[image] [image]

Sitecore 6.4.1 API
IExplicitSource Members
IExplicitSource Interface Methods Properties See Also Send Feedback

The IExplicitSource type exposes the following members.

Methods

 | Name | Description
Public method | ResolveKey | Resolves the key. (Inherited from IKeyResolver.)

Properties

 | Name | Description
Public property | Entries | Gets the entries.

See Also

IExplicitSource Interface
Sitecore.Install.Framework Namespace


IExplicitSource Methods

[image] [image]

Sitecore 6.4.1 API
IExplicitSource Methods
IExplicitSource Interface See Also Send Feedback

The IExplicitSource type exposes the following members.

Methods

 | Name | Description
Public method | ResolveKey | Resolves the key. (Inherited from IKeyResolver.)

See Also

IExplicitSource Interface
Sitecore.Install.Framework Namespace


Entries Property

[image]

Sitecore 6.4.1 API
IExplicitSource..::..Entries Property
IExplicitSource Interface See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
IList<string> Entries { get; }
Visual Basic
ReadOnly Property Entries As IList(Of String)
    Get
Visual C++
property IList<String^>^ Entries {
    IList<String^>^ get ();
}

Field Value

The entries.

See Also

IExplicitSource Interface
Sitecore.Install.Framework Namespace


IFilter Interface

[image]

Sitecore 6.4.1 API
IFilter Interface
Members See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IFilter
Visual Basic
Public Interface IFilter
Visual C++
public interface class IFilter

See Also

IFilter Members
Sitecore.Install.Framework Namespace


IFilter Members

[image] [image]

Sitecore 6.4.1 API
IFilter Members
IFilter Interface Methods Properties See Also Send Feedback

The IFilter type exposes the following members.

Methods

 | Name | Description
Public method | Qualify | Qualifies the specified instance.

Properties

 | Name | Description
Public property | IsEmpty | Gets a value indicating whether this instance is empty.

See Also

IFilter Interface
Sitecore.Install.Framework Namespace


IFilter Methods

[image] [image]

Sitecore 6.4.1 API
IFilter Methods
IFilter Interface See Also Send Feedback

The IFilter type exposes the following members.

Methods

 | Name | Description
Public method | Qualify | Qualifies the specified instance.

See Also

IFilter Interface
Sitecore.Install.Framework Namespace


IFilter Properties

[image] [image]

Sitecore 6.4.1 API
IFilter Properties
IFilter Interface See Also Send Feedback

The IFilter type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Gets a value indicating whether this instance is empty.

See Also

IFilter Interface
Sitecore.Install.Framework Namespace


IsEmpty Property

[image]

Sitecore 6.4.1 API
IFilter..::..IsEmpty Property
IFilter Interface See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
bool IsEmpty { get; }
Visual Basic
ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
property bool IsEmpty {
    bool get ();
}

Field Value

true if this instance is empty; otherwise, false.

See Also

IFilter Interface
Sitecore.Install.Framework Namespace


IKeyResolver Members

[image] [image]

Sitecore 6.4.1 API
IKeyResolver Members
IKeyResolver Interface Methods See Also Send Feedback

The IKeyResolver type exposes the following members.

Methods

 | Name | Description
Public method | ResolveKey | Resolves the key.

See Also

IKeyResolver Interface
Sitecore.Install.Framework Namespace


IKeyResolver Methods

[image] [image]

Sitecore 6.4.1 API
IKeyResolver Methods
IKeyResolver Interface See Also Send Feedback

The IKeyResolver type exposes the following members.

Methods

 | Name | Description
Public method | ResolveKey | Resolves the key.

See Also

IKeyResolver Interface
Sitecore.Install.Framework Namespace


ResolveKey Method

[image]

Sitecore 6.4.1 API
IKeyResolver..::..ResolveKey Method
IKeyResolver Interface See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
Object ResolveKey(
    string key
)
Visual Basic
Function ResolveKey ( _
    key As String _
) As Object
Visual C++
Object^ ResolveKey(
    String^ key
)

Parameters

key
Type: System..::..String
The key.

Return Value

The object.

See Also

IKeyResolver Interface
Sitecore.Install.Framework Namespace


INamedObject Interface

[image]

Sitecore 6.4.1 API
INamedObject Interface
Members See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface INamedObject
Visual Basic
Public Interface INamedObject
Visual C++
public interface class INamedObject

See Also

INamedObject Members
Sitecore.Install.Framework Namespace


INamedObject Members

[image] [image]

Sitecore 6.4.1 API
INamedObject Members
INamedObject Interface Properties See Also Send Feedback

The INamedObject type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets or sets the name.

See Also

INamedObject Interface
Sitecore.Install.Framework Namespace


INamedObject Properties

[image] [image]

Sitecore 6.4.1 API
INamedObject Properties
INamedObject Interface See Also Send Feedback

The INamedObject type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets or sets the name.

See Also

INamedObject Interface
Sitecore.Install.Framework Namespace


Name Property

[image]

Sitecore 6.4.1 API
INamedObject..::..Name Property
INamedObject Interface See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
string Name { get; set; }
Visual Basic
Property Name As String
    Get
    Set
Visual C++
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Field Value

The name.

See Also

INamedObject Interface
Sitecore.Install.Framework Namespace


InstallPolicy Enumeration

[image]

Sitecore 6.4.1 API
InstallPolicy Enumeration
See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[FlagsAttribute]
public enum InstallPolicy
Visual Basic
<FlagsAttribute> _
Public Enumeration InstallPolicy
Visual C++
[FlagsAttribute]
public enum class InstallPolicy

Members

Member name | Value | Description
Overwrite | 0 | Item should be overwritten
Append | 1 | A verstion should be append
Skip | 2 | A version should be skipped

See Also

Sitecore.Install.Framework Namespace


IPostStep Interface

[image]

Sitecore 6.4.1 API
IPostStep Interface
Members See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IPostStep
Visual Basic
Public Interface IPostStep
Visual C++
public interface class IPostStep

See Also

IPostStep Members
Sitecore.Install.Framework Namespace


IPostStep Members

[image] [image]

Sitecore 6.4.1 API
IPostStep Members
IPostStep Interface Methods See Also Send Feedback

The IPostStep type exposes the following members.

Methods

 | Name | Description
Public method | Run | Runs this post step

See Also

IPostStep Interface
Sitecore.Install.Framework Namespace


IPostStep Methods

[image] [image]

Sitecore 6.4.1 API
IPostStep Methods
IPostStep Interface See Also Send Feedback

The IPostStep type exposes the following members.

Methods

 | Name | Description
Public method | Run | Runs this post step

See Also

IPostStep Interface
Sitecore.Install.Framework Namespace


Run Method

[image]

Sitecore 6.4.1 API
IPostStep..::..Run Method
IPostStep Interface See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void Run(
    ITaskOutput output,
    NameValueCollection metaData
)
Visual Basic
Sub Run ( _
    output As ITaskOutput, _
    metaData As NameValueCollection _
)
Visual C++
void Run(
    ITaskOutput^ output,
    NameValueCollection^ metaData
)

Parameters

output
Type: Sitecore.Install.Framework..::..ITaskOutput
The output.
metaData
Type: System.Collections.Specialized..::..NameValueCollection
The meta data.

See Also

IPostStep Interface
Sitecore.Install.Framework Namespace


IProcessingContext Interface

[image]

Sitecore 6.4.1 API
IProcessingContext Interface
Members See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IProcessingContext : IAspectContainer
Visual Basic
Public Interface IProcessingContext _
    Inherits IAspectContainer
Visual C++
public interface class IProcessingContext : IAspectContainer

See Also

IProcessingContext Members
Sitecore.Install.Framework Namespace


IProcessingContext Members

[image] [image]

Sitecore 6.4.1 API
IProcessingContext Members
IProcessingContext Interface Methods Properties See Also Send Feedback

The IProcessingContext type exposes the following members.

Methods

 | Name | Description
Public method | AddAspect<(Of <<'(T>)>>) | Adds the aspect. (Inherited from IAspectContainer.)
Public method | GetAspect<(Of <<'(T>)>>) | Gets the aspect. (Inherited from IAspectContainer.)
Public method | HasAspect<(Of <<'(T>)>>) | Determines whether this instance has aspect. (Inherited from IAspectContainer.)
Public method | MapDatabase | Return the mapped database for the specified database.
Public method | ObjectNotFound | Actions to perform when source cannot add an find the object to add to the package.

Properties

 | Name | Description
Public property | Data | Gets the data.
Public property | Log | Gets the logger.
Public property | Output | Gets the output.
Public property | PostActions | Gets the post actions.
Public property | ShowSourceInfo | Gets or sets a value indicating whether the IProcessingContext shows the source info.
Public property | SkipCompression | Gets or sets a value indicating whether the IProcessingContext skips the compression.
Public property | SkipData | Gets or sets a value indicating whether the IProcessingContext skips the data.
Public property | SkipProperties | Gets or sets a value indicating whether the IProcessingContext skips the properties.
Public property | TaskID | Gets the unique task ID. Can be used in workers to derive task-specific object names.

See Also

IProcessingContext Interface
Sitecore.Install.Framework Namespace


IProcessingContext Methods

[image] [image]

Sitecore 6.4.1 API
IProcessingContext Methods
IProcessingContext Interface See Also Send Feedback

The IProcessingContext type exposes the following members.

Methods

 | Name | Description
Public method | AddAspect<(Of <<'(T>)>>) | Adds the aspect. (Inherited from IAspectContainer.)
Public method | GetAspect<(Of <<'(T>)>>) | Gets the aspect. (Inherited from IAspectContainer.)
Public method | HasAspect<(Of <<'(T>)>>) | Determines whether this instance has aspect. (Inherited from IAspectContainer.)
Public method | MapDatabase | Return the mapped database for the specified database.
Public method | ObjectNotFound | Actions to perform when source cannot add an find the object to add to the package.

See Also

IProcessingContext Interface
Sitecore.Install.Framework Namespace


MapDatabase Method

[image]

Sitecore 6.4.1 API
IProcessingContext..::..MapDatabase Method
IProcessingContext Interface See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
string MapDatabase(
    string database
)
Visual Basic
Function MapDatabase ( _
    database As String _
) As String
Visual C++
String^ MapDatabase(
    String^ database
)

Parameters

database
Type: System..::..String
The database.

Return Value

The mapped database.

See Also

IProcessingContext Interface
Sitecore.Install.Framework Namespace


Data Property

[image]

Sitecore 6.4.1 API
IProcessingContext..::..Data Property
IProcessingContext Interface See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
IDictionary<string, Object> Data { get; }
Visual Basic
ReadOnly Property Data As IDictionary(Of String, Object)
    Get
Visual C++
property IDictionary<String^, Object^>^ Data {
    IDictionary<String^, Object^>^ get ();
}

Field Value

The data.

See Also

IProcessingContext Interface
Sitecore.Install.Framework Namespace


Log Property

[image]

Sitecore 6.4.1 API
IProcessingContext..::..Log Property
IProcessingContext Interface See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
ILogger Log { get; }
Visual Basic
ReadOnly Property Log As ILogger
    Get
Visual C++
property ILogger^ Log {
    ILogger^ get ();
}

Field Value

The logger.

See Also

IProcessingContext Interface
Sitecore.Install.Framework Namespace


Output Property

[image]

Sitecore 6.4.1 API
IProcessingContext..::..Output Property
IProcessingContext Interface See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
ITaskOutput Output { get; }
Visual Basic
ReadOnly Property Output As ITaskOutput
    Get
Visual C++
property ITaskOutput^ Output {
    ITaskOutput^ get ();
}

Field Value

The output.

See Also

IProcessingContext Interface
Sitecore.Install.Framework Namespace


PostActions Property

[image]

Sitecore 6.4.1 API
IProcessingContext..::..PostActions Property
IProcessingContext Interface See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
IList<IProcessor<IProcessingContext>> PostActions { get; }
Visual Basic
ReadOnly Property PostActions As IList(Of IProcessor(Of IProcessingContext))
    Get
Visual C++
property IList<IProcessor<IProcessingContext^>^>^ PostActions {
    IList<IProcessor<IProcessingContext^>^>^ get ();
}

Field Value

The post actions.

See Also

IProcessingContext Interface
Sitecore.Install.Framework Namespace


ShowSourceInfo Property

[image]

Sitecore 6.4.1 API
IProcessingContext..::..ShowSourceInfo Property
IProcessingContext Interface See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
bool ShowSourceInfo { get; set; }
Visual Basic
Property ShowSourceInfo As Boolean
    Get
    Set
Visual C++
property bool ShowSourceInfo {
    bool get ();
    void set (bool value);
}

Field Value

true if the IProcessingContext shows the source info; otherwise, false.

See Also

IProcessingContext Interface
Sitecore.Install.Framework Namespace


SkipCompression Property

[image]

Sitecore 6.4.1 API
IProcessingContext..::..SkipCompression Property
IProcessingContext Interface See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
bool SkipCompression { get; set; }
Visual Basic
Property SkipCompression As Boolean
    Get
    Set
Visual C++
property bool SkipCompression {
    bool get ();
    void set (bool value);
}

Field Value

true if the IProcessingContext skips the compression; otherwise, false.

See Also

IProcessingContext Interface
Sitecore.Install.Framework Namespace


SkipData Property

[image]

Sitecore 6.4.1 API
IProcessingContext..::..SkipData Property
IProcessingContext Interface See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
bool SkipData { get; set; }
Visual Basic
Property SkipData As Boolean
    Get
    Set
Visual C++
property bool SkipData {
    bool get ();
    void set (bool value);
}

Field Value

true if the IProcessingContext skips the data; otherwise, false.

See Also

IProcessingContext Interface
Sitecore.Install.Framework Namespace


SkipProperties Property

[image]

Sitecore 6.4.1 API
IProcessingContext..::..SkipProperties Property
IProcessingContext Interface See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
bool SkipProperties { get; set; }
Visual Basic
Property SkipProperties As Boolean
    Get
    Set
Visual C++
property bool SkipProperties {
    bool get ();
    void set (bool value);
}

Field Value

true if the IProcessingContext skips the properties; otherwise, false.

See Also

IProcessingContext Interface
Sitecore.Install.Framework Namespace


TaskID Property

[image]

Sitecore 6.4.1 API
IProcessingContext..::..TaskID Property
IProcessingContext Interface See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
string TaskID { get; }
Visual Basic
ReadOnly Property TaskID As String
    Get
Visual C++
property String^ TaskID {
    String^ get ();
}

Field Value

The task ID.

See Also

IProcessingContext Interface
Sitecore.Install.Framework Namespace


IProcessor(T) Interface

[image]

Sitecore 6.4.1 API
IProcessor<(Of <(<'T>)>)> Interface
Members See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IProcessor<T>
Visual Basic
Public Interface IProcessor(Of T)
Visual C++
generic<typename T>
public interface class IProcessor

Type Parameters

T
Entry type

See Also

IProcessor<(Of <(<'T>)>)> Members
Sitecore.Install.Framework Namespace


IProcessor(T) Members

[image] [image]

Sitecore 6.4.1 API
IProcessor<(Of <(<'T>)>)> Members
IProcessor<(Of <(<'T>)>)> Interface Methods See Also Send Feedback

The IProcessor<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Process | Runs the processor.

See Also

IProcessor<(Of <(<'T>)>)> Interface
Sitecore.Install.Framework Namespace


IProcessor(T) Methods

[image] [image]

Sitecore 6.4.1 API
IProcessor<(Of <(<'T>)>)> Methods
IProcessor<(Of <(<'T>)>)> Interface See Also Send Feedback

The IProcessor<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Process | Runs the processor.

See Also

IProcessor<(Of <(<'T>)>)> Interface
Sitecore.Install.Framework Namespace


Process Method

[image]

Sitecore 6.4.1 API
IProcessor<(Of <(<'T>)>)>..::..Process Method
IProcessor<(Of <(<'T>)>)> Interface See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void Process(
    T entry,
    IProcessingContext context
)
Visual Basic
Sub Process ( _
    entry As T, _
    context As IProcessingContext _
)
Visual C++
void Process(
    T entry,
    IProcessingContext^ context
)

Parameters

entry
Type: T
The entry.
context
Type: Sitecore.Install.Framework..::..IProcessingContext
The processing context.

See Also

IProcessor<(Of <(<'T>)>)> Interface
Sitecore.Install.Framework Namespace


ISink(T) Interface

[image]

Sitecore 6.4.1 API
ISink<(Of <(<'T>)>)> Interface
Members See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface ISink<T>
Visual Basic
Public Interface ISink(Of T)
Visual C++
generic<typename T>
public interface class ISink

Type Parameters

T
Type of entry

See Also

ISink<(Of <(<'T>)>)> Members
Sitecore.Install.Framework Namespace


ISink(T) Members

[image] [image]

Sitecore 6.4.1 API
ISink<(Of <(<'T>)>)> Members
ISink<(Of <(<'T>)>)> Interface Methods Properties See Also Send Feedback

The ISink<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Finish | Finishes the sink.
Public method | Flush | Flushes the sink
Public method | Initialize | Initializes the specified context.
Public method | Put | Puts the specified entry.

Properties

 | Name | Description
Public property | IsInitialized | Gets a value indicating whether this instance is initialized.
Public property | ProcessingContext | Gets the processing context.

See Also

ISink<(Of <(<'T>)>)> Interface
Sitecore.Install.Framework Namespace


ISink(T) Methods

[image] [image]

Sitecore 6.4.1 API
ISink<(Of <(<'T>)>)> Methods
ISink<(Of <(<'T>)>)> Interface See Also Send Feedback

The ISink<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Finish | Finishes the sink.
Public method | Flush | Flushes the sink
Public method | Initialize | Initializes the specified context.
Public method | Put | Puts the specified entry.

See Also

ISink<(Of <(<'T>)>)> Interface
Sitecore.Install.Framework Namespace


Finish Method

[image]

Sitecore 6.4.1 API
ISink<(Of <(<'T>)>)>..::..Finish Method
ISink<(Of <(<'T>)>)> Interface See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void Finish()
Visual Basic
Sub Finish
Visual C++
void Finish()

See Also

ISink<(Of <(<'T>)>)> Interface
Sitecore.Install.Framework Namespace


Flush Method

[image]

Sitecore 6.4.1 API
ISink<(Of <(<'T>)>)>..::..Flush Method
ISink<(Of <(<'T>)>)> Interface See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void Flush()
Visual Basic
Sub Flush
Visual C++
void Flush()

See Also

ISink<(Of <(<'T>)>)> Interface
Sitecore.Install.Framework Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
ISink<(Of <(<'T>)>)>..::..Initialize Method
ISink<(Of <(<'T>)>)> Interface See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void Initialize(
    IProcessingContext context
)
Visual Basic
Sub Initialize ( _
    context As IProcessingContext _
)
Visual C++
void Initialize(
    IProcessingContext^ context
)

Parameters

context
Type: Sitecore.Install.Framework..::..IProcessingContext
The context.

See Also

ISink<(Of <(<'T>)>)> Interface
Sitecore.Install.Framework Namespace


ISink(T) Properties

[image] [image]

Sitecore 6.4.1 API
ISink<(Of <(<'T>)>)> Properties
ISink<(Of <(<'T>)>)> Interface See Also Send Feedback

The ISink<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | IsInitialized | Gets a value indicating whether this instance is initialized.
Public property | ProcessingContext | Gets the processing context.

See Also

ISink<(Of <(<'T>)>)> Interface
Sitecore.Install.Framework Namespace


IsInitialized Property

[image]

Sitecore 6.4.1 API
ISink<(Of <(<'T>)>)>..::..IsInitialized Property
ISink<(Of <(<'T>)>)> Interface See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
bool IsInitialized { get; }
Visual Basic
ReadOnly Property IsInitialized As Boolean
    Get
Visual C++
property bool IsInitialized {
    bool get ();
}

Field Value

true if this instance is initialized; otherwise, false.

See Also

ISink<(Of <(<'T>)>)> Interface
Sitecore.Install.Framework Namespace


ProcessingContext Property

[image]

Sitecore 6.4.1 API
ISink<(Of <(<'T>)>)>..::..ProcessingContext Property
ISink<(Of <(<'T>)>)> Interface See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
IProcessingContext ProcessingContext { get; }
Visual Basic
ReadOnly Property ProcessingContext As IProcessingContext
    Get
Visual C++
property IProcessingContext^ ProcessingContext {
    IProcessingContext^ get ();
}

Field Value

The processing context.

See Also

ISink<(Of <(<'T>)>)> Interface
Sitecore.Install.Framework Namespace


ISortingKeyProvider Interface

[image]

Sitecore 6.4.1 API
ISortingKeyProvider Interface
Members See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface ISortingKeyProvider
Visual Basic
Public Interface ISortingKeyProvider
Visual C++
public interface class ISortingKeyProvider

See Also

ISortingKeyProvider Members
Sitecore.Install.Framework Namespace


ISortingKeyProvider Members

[image] [image]

Sitecore 6.4.1 API
ISortingKeyProvider Members
ISortingKeyProvider Interface Methods See Also Send Feedback

The ISortingKeyProvider type exposes the following members.

Methods

 | Name | Description
Public method | GetKey | Gets the key.

See Also

ISortingKeyProvider Interface
Sitecore.Install.Framework Namespace


ISortingKeyProvider Methods

[image] [image]

Sitecore 6.4.1 API
ISortingKeyProvider Methods
ISortingKeyProvider Interface See Also Send Feedback

The ISortingKeyProvider type exposes the following members.

Methods

 | Name | Description
Public method | GetKey | Gets the key.

See Also

ISortingKeyProvider Interface
Sitecore.Install.Framework Namespace


GetKey Method

[image]

Sitecore 6.4.1 API
ISortingKeyProvider..::..GetKey Method
ISortingKeyProvider Interface See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
SortingKey GetKey(
    string key
)
Visual Basic
Function GetKey ( _
    key As String _
) As SortingKey
Visual C++
SortingKey^ GetKey(
    String^ key
)

Parameters

key
Type: System..::..String
The key.

Return Value

The key.

See Also

ISortingKeyProvider Interface
Sitecore.Install.Framework Namespace


ISource(T) Interface

[image]

Sitecore 6.4.1 API
ISource<(Of <(<'T>)>)> Interface
Members See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface ISource<T>
Visual Basic
Public Interface ISource(Of T)
Visual C++
generic<typename T>
public interface class ISource

Type Parameters

T
Entry type

See Also

ISource<(Of <(<'T>)>)> Members
Sitecore.Install.Framework Namespace


ISource(T) Members

[image] [image]

Sitecore 6.4.1 API
ISource<(Of <(<'T>)>)> Members
ISource<(Of <(<'T>)>)> Interface Methods See Also Send Feedback

The ISource<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Populate | Populates specified sink from this sourse.

See Also

ISource<(Of <(<'T>)>)> Interface
Sitecore.Install.Framework Namespace


ISource(T) Methods

[image] [image]

Sitecore 6.4.1 API
ISource<(Of <(<'T>)>)> Methods
ISource<(Of <(<'T>)>)> Interface See Also Send Feedback

The ISource<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Populate | Populates specified sink from this sourse.

See Also

ISource<(Of <(<'T>)>)> Interface
Sitecore.Install.Framework Namespace


IStreamHolder Interface

[image]

Sitecore 6.4.1 API
IStreamHolder Interface
Members See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IStreamHolder : IDisposable
Visual Basic
Public Interface IStreamHolder _
    Inherits IDisposable
Visual C++
public interface class IStreamHolder : IDisposable

See Also

IStreamHolder Members
Sitecore.Install.Framework Namespace


IStreamHolder Members

[image] [image]

Sitecore 6.4.1 API
IStreamHolder Members
IStreamHolder Interface Methods Properties See Also Send Feedback

The IStreamHolder type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)

Properties

 | Name | Description
Public property | Stream | Gets the stream.

See Also

IStreamHolder Interface
Sitecore.Install.Framework Namespace


IStreamHolder Methods

[image] [image]

Sitecore 6.4.1 API
IStreamHolder Methods
IStreamHolder Interface See Also Send Feedback

The IStreamHolder type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)

See Also

IStreamHolder Interface
Sitecore.Install.Framework Namespace


IStreamHolder Properties

[image] [image]

Sitecore 6.4.1 API
IStreamHolder Properties
IStreamHolder Interface See Also Send Feedback

The IStreamHolder type exposes the following members.

Properties

 | Name | Description
Public property | Stream | Gets the stream.

See Also

IStreamHolder Interface
Sitecore.Install.Framework Namespace


Stream Property

[image]

Sitecore 6.4.1 API
IStreamHolder..::..Stream Property
IStreamHolder Interface See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
Stream Stream { get; }
Visual Basic
ReadOnly Property Stream As Stream
    Get
Visual C++
property Stream^ Stream {
    Stream^ get ();
}

Field Value

The stream.

See Also

IStreamHolder Interface
Sitecore.Install.Framework Namespace


IStreamProvider Interface

[image]

Sitecore 6.4.1 API
IStreamProvider Interface
Members See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IStreamProvider
Visual Basic
Public Interface IStreamProvider
Visual C++
public interface class IStreamProvider

See Also

IStreamProvider Members
Sitecore.Install.Framework Namespace


IStreamProvider Members

[image] [image]

Sitecore 6.4.1 API
IStreamProvider Members
IStreamProvider Interface Methods See Also Send Feedback

The IStreamProvider type exposes the following members.

Methods

 | Name | Description
Public method | GetStream | Gets the stream by its name.

See Also

IStreamProvider Interface
Sitecore.Install.Framework Namespace


IStreamProvider Methods

[image] [image]

Sitecore 6.4.1 API
IStreamProvider Methods
IStreamProvider Interface See Also Send Feedback

The IStreamProvider type exposes the following members.

Methods

 | Name | Description
Public method | GetStream | Gets the stream by its name.

See Also

IStreamProvider Interface
Sitecore.Install.Framework Namespace


ISupportsAttributes Interface

[image]

Sitecore 6.4.1 API
ISupportsAttributes Interface
Members See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface ISupportsAttributes
Visual Basic
Public Interface ISupportsAttributes
Visual C++
public interface class ISupportsAttributes

See Also

ISupportsAttributes Members
Sitecore.Install.Framework Namespace


ISupportsAttributes Members

[image] [image]

Sitecore 6.4.1 API
ISupportsAttributes Members
ISupportsAttributes Interface Methods See Also Send Feedback

The ISupportsAttributes type exposes the following members.

Methods

 | Name | Description
Public method | GetAttribute | Gets the value of the attribute.
Public method | SetAttribute | Sets the value of the attribute.

See Also

ISupportsAttributes Interface
Sitecore.Install.Framework Namespace


ISupportsAttributes Methods

[image] [image]

Sitecore 6.4.1 API
ISupportsAttributes Methods
ISupportsAttributes Interface See Also Send Feedback

The ISupportsAttributes type exposes the following members.

Methods

 | Name | Description
Public method | GetAttribute | Gets the value of the attribute.
Public method | SetAttribute | Sets the value of the attribute.

See Also

ISupportsAttributes Interface
Sitecore.Install.Framework Namespace


GetAttribute Method

[image]

Sitecore 6.4.1 API
ISupportsAttributes..::..GetAttribute Method
ISupportsAttributes Interface See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
Object GetAttribute(
    string name
)
Visual Basic
Function GetAttribute ( _
    name As String _
) As Object
Visual C++
Object^ GetAttribute(
    String^ name
)

Parameters

name
Type: System..::..String
The attribute name.

Return Value

The value of the attribute.

See Also

ISupportsAttributes Interface
Sitecore.Install.Framework Namespace


SetAttribute Method

[image]

Sitecore 6.4.1 API
ISupportsAttributes..::..SetAttribute Method
ISupportsAttributes Interface See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void SetAttribute(
    string name,
    Object value
)
Visual Basic
Sub SetAttribute ( _
    name As String, _
    value As Object _
)
Visual C++
void SetAttribute(
    String^ name,
    Object^ value
)

Parameters

name
Type: System..::..String
The attribute name.
value
Type: System..::..Object
The value.

See Also

ISupportsAttributes Interface
Sitecore.Install.Framework Namespace


ISupportsFiltering Interface

[image]

Sitecore 6.4.1 API
ISupportsFiltering Interface
Members See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface ISupportsFiltering
Visual Basic
Public Interface ISupportsFiltering
Visual C++
public interface class ISupportsFiltering

See Also

ISupportsFiltering Members
Sitecore.Install.Framework Namespace


ISupportsFiltering Members

[image] [image]

Sitecore 6.4.1 API
ISupportsFiltering Members
ISupportsFiltering Interface Properties See Also Send Feedback

The ISupportsFiltering type exposes the following members.

Properties

 | Name | Description
Public property | Exclude | Gets the exclude filters.
Public property | Include | Gets the include filters.

See Also

ISupportsFiltering Interface
Sitecore.Install.Framework Namespace


ISupportsFiltering Properties

[image] [image]

Sitecore 6.4.1 API
ISupportsFiltering Properties
ISupportsFiltering Interface See Also Send Feedback

The ISupportsFiltering type exposes the following members.

Properties

 | Name | Description
Public property | Exclude | Gets the exclude filters.
Public property | Include | Gets the include filters.

See Also

ISupportsFiltering Interface
Sitecore.Install.Framework Namespace


Exclude Property

[image]

Sitecore 6.4.1 API
ISupportsFiltering..::..Exclude Property
ISupportsFiltering Interface See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
IList<IFilter> Exclude { get; }
Visual Basic
ReadOnly Property Exclude As IList(Of IFilter)
    Get
Visual C++
property IList<IFilter^>^ Exclude {
    IList<IFilter^>^ get ();
}

Field Value

The exclude filters.

See Also

ISupportsFiltering Interface
Sitecore.Install.Framework Namespace


Include Property

[image]

Sitecore 6.4.1 API
ISupportsFiltering..::..Include Property
ISupportsFiltering Interface See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
IList<IFilter> Include { get; }
Visual Basic
ReadOnly Property Include As IList(Of IFilter)
    Get
Visual C++
property IList<IFilter^>^ Include {
    IList<IFilter^>^ get ();
}

Field Value

The include filters.

See Also

ISupportsFiltering Interface
Sitecore.Install.Framework Namespace


ISupportsTransforms(T) Interface

[image]

Sitecore 6.4.1 API
ISupportsTransforms<(Of <(<'T>)>)> Interface
Members See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface ISupportsTransforms<T>
Visual Basic
Public Interface ISupportsTransforms(Of T)
Visual C++
generic<typename T>
public interface class ISupportsTransforms

Type Parameters

T
Type of object to be processed

See Also

ISupportsTransforms<(Of <(<'T>)>)> Members
Sitecore.Install.Framework Namespace


ISupportsTransforms(T) Members

[image] [image]

Sitecore 6.4.1 API
ISupportsTransforms<(Of <(<'T>)>)> Members
ISupportsTransforms<(Of <(<'T>)>)> Interface Properties See Also Send Feedback

The ISupportsTransforms<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Transforms | Gets the transforms.

See Also

ISupportsTransforms<(Of <(<'T>)>)> Interface
Sitecore.Install.Framework Namespace


ISupportsTransforms(T) Properties

[image] [image]

Sitecore 6.4.1 API
ISupportsTransforms<(Of <(<'T>)>)> Properties
ISupportsTransforms<(Of <(<'T>)>)> Interface See Also Send Feedback

The ISupportsTransforms<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Transforms | Gets the transforms.

See Also

ISupportsTransforms<(Of <(<'T>)>)> Interface
Sitecore.Install.Framework Namespace


Transforms Property

[image]

Sitecore 6.4.1 API
ISupportsTransforms<(Of <(<'T>)>)>..::..Transforms Property
ISupportsTransforms<(Of <(<'T>)>)> Interface See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
IList<IProcessor<T>> Transforms { get; }
Visual Basic
ReadOnly Property Transforms As IList(Of IProcessor(Of T))
    Get
Visual C++
property IList<IProcessor<T>^>^ Transforms {
    IList<IProcessor<T>^>^ get ();
}

Field Value

The transforms.

See Also

ISupportsTransforms<(Of <(<'T>)>)> Interface
Sitecore.Install.Framework Namespace


ITaskOutput Interface

[image]

Sitecore 6.4.1 API
ITaskOutput Interface
Members See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface ITaskOutput
Visual Basic
Public Interface ITaskOutput
Visual C++
public interface class ITaskOutput

See Also

ITaskOutput Members
Sitecore.Install.Framework Namespace


ITaskOutput Members

[image] [image]

Sitecore 6.4.1 API
ITaskOutput Members
ITaskOutput Interface Methods See Also Send Feedback

The ITaskOutput type exposes the following members.

Methods

 | Name | Description
Public method | Alert | Shows an alert form.
Public method | Confirm | Shows the confirmation dialog.
Public method | Execute(ThreadStart) | Executes the callback asynchronuosly
Public method | Execute(Callback) | Executes the specified callback.
Public method | RunPipeline | Executes the specified pipeline callback.

See Also

ITaskOutput Interface
Sitecore.Install.Framework Namespace


ITaskOutput Methods

[image] [image]

Sitecore 6.4.1 API
ITaskOutput Methods
ITaskOutput Interface See Also Send Feedback

The ITaskOutput type exposes the following members.

Methods

 | Name | Description
Public method | Alert | Shows an alert form.
Public method | Confirm | Shows the confirmation dialog.
Public method | Execute(ThreadStart) | Executes the callback asynchronuosly
Public method | Execute(Callback) | Executes the specified callback.
Public method | RunPipeline | Executes the specified pipeline callback.

See Also

ITaskOutput Interface
Sitecore.Install.Framework Namespace


Alert Method

[image]

Sitecore 6.4.1 API
ITaskOutput..::..Alert Method
ITaskOutput Interface See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void Alert(
    string message
)
Visual Basic
Sub Alert ( _
    message As String _
)
Visual C++
void Alert(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

ITaskOutput Interface
Sitecore.Install.Framework Namespace


Confirm Method

[image]

Sitecore 6.4.1 API
ITaskOutput..::..Confirm Method
ITaskOutput Interface See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
string Confirm(
    string message
)
Visual Basic
Function Confirm ( _
    message As String _
) As String
Visual C++
String^ Confirm(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

Return Value

The confirmation result.

See Also

ITaskOutput Interface
Sitecore.Install.Framework Namespace


Execute Method

[image] [image]

Sitecore 6.4.1 API
ITaskOutput..::..Execute Method
ITaskOutput Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | Execute(ThreadStart) | Executes the callback asynchronuosly
Public method | Execute(Callback) | Executes the specified callback.

See Also

ITaskOutput Interface
ITaskOutput Members
Sitecore.Install.Framework Namespace


Execute Method (ThreadStart)

[image]

Sitecore 6.4.1 API
ITaskOutput..::..Execute Method (ThreadStart)
ITaskOutput Interface See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void Execute(
    ThreadStart callback
)
Visual Basic
Sub Execute ( _
    callback As ThreadStart _
)
Visual C++
void Execute(
    ThreadStart^ callback
)

Parameters

callback
Type: System.Threading..::..ThreadStart
The callback.

See Also

ITaskOutput Interface
Execute Overload
Sitecore.Install.Framework Namespace


Execute Method (Callback)

[image]

Sitecore 6.4.1 API
ITaskOutput..::..Execute Method (Callback)
ITaskOutput Interface See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
Object Execute(
    Callback callback
)
Visual Basic
Function Execute ( _
    callback As Callback _
) As Object
Visual C++
Object^ Execute(
    Callback^ callback
)

Parameters

callback
Type: Sitecore.Jobs.AsyncUI..::..Callback
The callback.

Return Value

The execute.

See Also

ITaskOutput Interface
Execute Overload
Sitecore.Install.Framework Namespace


RunPipeline Method

[image]

Sitecore 6.4.1 API
ITaskOutput..::..RunPipeline Method
ITaskOutput Interface See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
Object RunPipeline(
    PipelineCallback callback
)
Visual Basic
Function RunPipeline ( _
    callback As PipelineCallback _
) As Object
Visual C++
Object^ RunPipeline(
    PipelineCallback^ callback
)

Parameters

callback
Type: Sitecore.Jobs.AsyncUI..::..PipelineCallback
The callback.

Return Value

The execute.

See Also

ITaskOutput Interface
Sitecore.Install.Framework Namespace


NullOutput Class

[image]

Sitecore 6.4.1 API
NullOutput Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class NullOutput : ITaskOutput
Visual Basic
Public Class NullOutput _
    Implements ITaskOutput
Visual C++
public ref class NullOutput : ITaskOutput

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..NullOutput

See Also

NullOutput Members
Sitecore.Install.Framework Namespace


NullOutput Constructor

[image]

Sitecore 6.4.1 API
NullOutput Constructor
NullOutput Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public NullOutput()
Visual Basic
Public Sub New
Visual C++
public:
NullOutput()

See Also

NullOutput Class
Sitecore.Install.Framework Namespace


NullOutput Methods

[image] [image]

Sitecore 6.4.1 API
NullOutput Methods
NullOutput Class See Also Send Feedback

The NullOutput type exposes the following members.

Methods

 | Name | Description
Public method | Alert | Shows an alert form.
Public method | Confirm | Shows the confirmation dialog.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute(ThreadStart) | Executes the callback asynchronuosly
Public method | Execute(Callback) | Executes the specified callback.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PutMessage | Puts the message.
Public method | RunPipeline | Executes the specified pipeline callback.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NullOutput Class
Sitecore.Install.Framework Namespace


Alert Method

[image]

Sitecore 6.4.1 API
NullOutput..::..Alert Method
NullOutput Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Alert(
    string message
)
Visual Basic
Public Sub Alert ( _
    message As String _
)
Visual C++
public:
virtual void Alert(
    String^ message
) sealed

Parameters

message
Type: System..::..String
The message.

Implements

ITaskOutput..::..Alert(String)

See Also

NullOutput Class
Sitecore.Install.Framework Namespace


Confirm Method

[image]

Sitecore 6.4.1 API
NullOutput..::..Confirm Method
NullOutput Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Confirm(
    string message
)
Visual Basic
Public Function Confirm ( _
    message As String _
) As String
Visual C++
public:
virtual String^ Confirm(
    String^ message
) sealed

Parameters

message
Type: System..::..String
The message.

Return Value

The confirmation result.

Implements

ITaskOutput..::..Confirm(String)

See Also

NullOutput Class
Sitecore.Install.Framework Namespace


Execute Method (ThreadStart)

[image]

Sitecore 6.4.1 API
NullOutput..::..Execute Method (ThreadStart)
NullOutput Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Execute(
    ThreadStart callback
)
Visual Basic
Public Sub Execute ( _
    callback As ThreadStart _
)
Visual C++
public:
virtual void Execute(
    ThreadStart^ callback
) sealed

Parameters

callback
Type: System.Threading..::..ThreadStart
The callback.

Implements

ITaskOutput..::..Execute(ThreadStart)

See Also

NullOutput Class
Execute Overload
Sitecore.Install.Framework Namespace


Execute Method (Callback)

[image]

Sitecore 6.4.1 API
NullOutput..::..Execute Method (Callback)
NullOutput Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object Execute(
    Callback callback
)
Visual Basic
Public Function Execute ( _
    callback As Callback _
) As Object
Visual C++
public:
virtual Object^ Execute(
    Callback^ callback
) sealed

Parameters

callback
Type: Sitecore.Jobs.AsyncUI..::..Callback
The callback.

Return Value

The execute.

Implements

ITaskOutput..::..Execute(Callback)

See Also

NullOutput Class
Execute Overload
Sitecore.Install.Framework Namespace


PutMessage Method

[image]

Sitecore 6.4.1 API
NullOutput..::..PutMessage Method
NullOutput Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void PutMessage(
    string message,
    params Object[] args
)
Visual Basic
Public Sub PutMessage ( _
    message As String, _
    ParamArray args As Object() _
)
Visual C++
public:
void PutMessage(
    String^ message,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::..String
The message.
args
Type: array< System..::..Object >[]()[][]
The arguments.

See Also

NullOutput Class
Sitecore.Install.Framework Namespace


PackageEntry Class

[image]

Sitecore 6.4.1 API
PackageEntry Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PackageEntry
Visual Basic
Public Class PackageEntry
Visual C++
public ref class PackageEntry

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..PackageEntry

See Also

PackageEntry Members
Sitecore.Install.Framework Namespace


PackageEntry Members

[image] [image]

Sitecore 6.4.1 API
PackageEntry Members
PackageEntry Class Constructors Methods Properties See Also Send Feedback

The PackageEntry type exposes the following members.

Constructors

 | Name | Description
Public method | PackageEntry(IEntryData) | Initializes a new instance of the PackageEntry class.
Public method | PackageEntry(IEntryData, IDictionary<(Of <<'(String, String>)>>), IDictionary<(Of <<'(String, String>)>>)) | Initializes a new instance of the PackageEntry class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStream | Gets the stream holder.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Attributes | Volatile values, handled by objects in the current processing session
Public property | Key | Gets the key.
Public property | Properties | Persistent values, stored along the entry in package file

See Also

PackageEntry Class
Sitecore.Install.Framework Namespace


PackageEntry Constructor

[image] [image]

Sitecore 6.4.1 API
PackageEntry Constructor
PackageEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PackageEntry(IEntryData) | Initializes a new instance of the PackageEntry class.
Public method | PackageEntry(IEntryData, IDictionary<(Of <<'(String, String>)>>), IDictionary<(Of <<'(String, String>)>>)) | Initializes a new instance of the PackageEntry class.

See Also

PackageEntry Class
PackageEntry Members
Sitecore.Install.Framework Namespace


PackageEntry Constructor (IEntryData)

[image]

Sitecore 6.4.1 API
PackageEntry Constructor (IEntryData)
PackageEntry Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PackageEntry(
    IEntryData data
)
Visual Basic
Public Sub New ( _
    data As IEntryData _
)
Visual C++
public:
PackageEntry(
    IEntryData^ data
)

Parameters

data
Type: Sitecore.Install.Framework..::..IEntryData
The data.

See Also

PackageEntry Class
PackageEntry Overload
Sitecore.Install.Framework Namespace


PackageEntry Constructor (IEntryData, IDictionary(String, String), IDictionary(String, String))

[image]

Sitecore 6.4.1 API
PackageEntry Constructor (IEntryData, IDictionary<(Of <(<'String, String>)>)>, IDictionary<(Of <(<'String, String>)>)>)
PackageEntry Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PackageEntry(
    IEntryData data,
    IDictionary<string, string> attributes,
    IDictionary<string, string> properties
)
Visual Basic
Public Sub New ( _
    data As IEntryData, _
    attributes As IDictionary(Of String, String), _
    properties As IDictionary(Of String, String) _
)
Visual C++
public:
PackageEntry(
    IEntryData^ data,
    IDictionary<String^, String^>^ attributes,
    IDictionary<String^, String^>^ properties
)

Parameters

data
Type: Sitecore.Install.Framework..::..IEntryData
The entry data.
attributes
Type: System.Collections.Generic..::..IDictionary <(Of <(<' String, String >)>)>
The attributes.
properties
Type: System.Collections.Generic..::..IDictionary <(Of <(<' String, String >)>)>
The properties.

See Also

PackageEntry Class
PackageEntry Overload
Sitecore.Install.Framework Namespace


PackageEntry Methods

[image] [image]

Sitecore 6.4.1 API
PackageEntry Methods
PackageEntry Class See Also Send Feedback

The PackageEntry type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStream | Gets the stream holder.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PackageEntry Class
Sitecore.Install.Framework Namespace


GetStream Method

[image]

Sitecore 6.4.1 API
PackageEntry..::..GetStream Method
PackageEntry Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IStreamHolder GetStream()
Visual Basic
Public Function GetStream As IStreamHolder
Visual C++
public:
IStreamHolder^ GetStream()

Return Value

The stream holder.

See Also

PackageEntry Class
Sitecore.Install.Framework Namespace


PackageEntry Properties

[image] [image]

Sitecore 6.4.1 API
PackageEntry Properties
PackageEntry Class See Also Send Feedback

The PackageEntry type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Volatile values, handled by objects in the current processing session
Public property | Key | Gets the key.
Public property | Properties | Persistent values, stored along the entry in package file

See Also

PackageEntry Class
Sitecore.Install.Framework Namespace


Attributes Property

[image]

Sitecore 6.4.1 API
PackageEntry..::..Attributes Property
PackageEntry Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IDictionary<string, string> Attributes { get; }
Visual Basic
Public ReadOnly Property Attributes As IDictionary(Of String, String)
    Get
Visual C++
public:
property IDictionary<String^, String^>^ Attributes {
    IDictionary<String^, String^>^ get ();
}

See Also

PackageEntry Class
Sitecore.Install.Framework Namespace


Properties Property

[image]

Sitecore 6.4.1 API
PackageEntry..::..Properties Property
PackageEntry Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IDictionary<string, string> Properties { get; }
Visual Basic
Public ReadOnly Property Properties As IDictionary(Of String, String)
    Get
Visual C++
public:
property IDictionary<String^, String^>^ Properties {
    IDictionary<String^, String^>^ get ();
}

See Also

PackageEntry Class
Sitecore.Install.Framework Namespace


PropertySetter Class

[image]

Sitecore 6.4.1 API
PropertySetter Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PropertySetter : IProcessor<PackageEntry>
Visual Basic
Public Class PropertySetter _
    Implements IProcessor(Of PackageEntry)
Visual C++
public ref class PropertySetter : IProcessor<PackageEntry^>

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..PropertySetter

See Also

PropertySetter Members
Sitecore.Install.Framework Namespace


PropertySetter Constructor

[image]

Sitecore 6.4.1 API
PropertySetter Constructor
PropertySetter Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PropertySetter()
Visual Basic
Public Sub New
Visual C++
public:
PropertySetter()

See Also

PropertySetter Class
Sitecore.Install.Framework Namespace


PropertySetter Methods

[image] [image]

Sitecore 6.4.1 API
PropertySetter Methods
PropertySetter Class See Also Send Feedback

The PropertySetter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PropertySetter Class
Sitecore.Install.Framework Namespace


Process Method

[image]

Sitecore 6.4.1 API
PropertySetter..::..Process Method
PropertySetter Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    PackageEntry entry,
    IProcessingContext context
)
Visual Basic
Public Sub Process ( _
    entry As PackageEntry, _
    context As IProcessingContext _
)
Visual C++
public:
virtual void Process(
    PackageEntry^ entry,
    IProcessingContext^ context
) sealed

Parameters

entry
Type: Sitecore.Install.Framework..::..PackageEntry
The entry.
context
Type: Sitecore.Install.Framework..::..IProcessingContext
The processing context.

Implements

IProcessor<(Of <(<'T>)>)>..::..Process(T, IProcessingContext)

See Also

PropertySetter Class
Sitecore.Install.Framework Namespace


PropertySetter Properties

[image] [image]

Sitecore 6.4.1 API
PropertySetter Properties
PropertySetter Class See Also Send Feedback

The PropertySetter type exposes the following members.

Properties

 | Name | Description
Public property | Properties | Gets the properties.

See Also

PropertySetter Class
Sitecore.Install.Framework Namespace


Properties Property

[image]

Sitecore 6.4.1 API
PropertySetter..::..Properties Property
PropertySetter Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IDictionary Properties { get; }
Visual Basic
Public ReadOnly Property Properties As IDictionary
    Get
Visual C++
public:
property IDictionary^ Properties {
    IDictionary^ get ();
}

Field Value

The properties.

See Also

PropertySetter Class
Sitecore.Install.Framework Namespace


SimpleKeyProvider Members

[image] [image]

Sitecore 6.4.1 API
SimpleKeyProvider Members
SimpleKeyProvider Class Constructors Methods See Also Send Feedback

The SimpleKeyProvider type exposes the following members.

Constructors

 | Name | Description
Public method | SimpleKeyProvider | Initializes a new instance of the SimpleKeyProvider class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKey | Gets the key.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SimpleKeyProvider Class
Sitecore.Install.Framework Namespace


SimpleKeyProvider Constructor

[image]

Sitecore 6.4.1 API
SimpleKeyProvider Constructor
SimpleKeyProvider Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SimpleKeyProvider()
Visual Basic
Public Sub New
Visual C++
public:
SimpleKeyProvider()

See Also

SimpleKeyProvider Class
Sitecore.Install.Framework Namespace


GetKey Method

[image]

Sitecore 6.4.1 API
SimpleKeyProvider..::..GetKey Method
SimpleKeyProvider Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SortingKey GetKey(
    string key
)
Visual Basic
Public Function GetKey ( _
    key As String _
) As SortingKey
Visual C++
public:
virtual SortingKey^ GetKey(
    String^ key
) sealed

Parameters

key
Type: System..::..String
The key.

Return Value

The key.

Implements

ISortingKeyProvider..::..GetKey(String)

See Also

SimpleKeyProvider Class
Sitecore.Install.Framework Namespace


SimpleProcessingContext Class

[image]

Sitecore 6.4.1 API
SimpleProcessingContext Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SimpleProcessingContext : AspectBase,
    IProcessingContext, IAspectContainer
Visual Basic
Public Class SimpleProcessingContext _
    Inherits AspectBase _
    Implements IProcessingContext, IAspectContainer
Visual C++
public ref class SimpleProcessingContext : public AspectBase,
    IProcessingContext, IAspectContainer

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..AspectBase
Sitecore.Install.Framework..::..SimpleProcessingContext

See Also

SimpleProcessingContext Members
Sitecore.Install.Framework Namespace


SimpleProcessingContext Members

[image] [image]

Sitecore 6.4.1 API
SimpleProcessingContext Members
SimpleProcessingContext Class Constructors Methods Properties See Also Send Feedback

The SimpleProcessingContext type exposes the following members.

Constructors

 | Name | Description
Public method | SimpleProcessingContext()()()() | Initializes a new instance of the SimpleProcessingContext class.
Public method | SimpleProcessingContext(ITaskOutput) | Initializes a new instance of the SimpleProcessingContext class.

Methods

 | Name | Description
Public method | AddAspect<(Of <<'(T>)>>) | Adds the aspect. (Inherited from AspectBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAspect<(Of <<'(T>)>>) | Gets the aspect. (Inherited from AspectBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAspect<(Of <<'(T>)>>) | Determines whether this instance has aspect. (Inherited from AspectBase.)
Public method | MapDatabase | Returns the mapped database for the specified database.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ObjectNotFound | An action on objects the not found.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Data | Gets the data.
Public property | Log | Gets the logger.
Public property | Output | Gets the output.
Public property | PostActions | Gets the post actions.
Public property | ShowSourceInfo | Gets or sets a value indicating whether the IProcessingContext shows the source info.
Public property | SkipCompression | Gets or sets a value indicating whether the IProcessingContext skips the compression.
Public property | SkipData | Gets or sets a value indicating whether the IProcessingContext skips the data.
Public property | SkipErrors | Gets or sets a value indicating whether error should be skipped.
Public property | SkipProperties | Gets or sets a value indicating whether the IProcessingContext skips the properties.
Public property | TaskID | Gets the unique task ID. Can be used in workers to derive task-specific object names.

See Also

SimpleProcessingContext Class
Sitecore.Install.Framework Namespace


SimpleProcessingContext Constructor

[image] [image]

Sitecore 6.4.1 API
SimpleProcessingContext Constructor
SimpleProcessingContext Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SimpleProcessingContext()()()() | Initializes a new instance of the SimpleProcessingContext class.
Public method | SimpleProcessingContext(ITaskOutput) | Initializes a new instance of the SimpleProcessingContext class.

See Also

SimpleProcessingContext Class
SimpleProcessingContext Members
Sitecore.Install.Framework Namespace


SimpleProcessingContext Constructor

[image]

Sitecore 6.4.1 API
SimpleProcessingContext Constructor
SimpleProcessingContext Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SimpleProcessingContext()
Visual Basic
Public Sub New
Visual C++
public:
SimpleProcessingContext()

See Also

SimpleProcessingContext Class
SimpleProcessingContext Overload
Sitecore.Install.Framework Namespace


SimpleProcessingContext Constructor (ITaskOutput)

[image]

Sitecore 6.4.1 API
SimpleProcessingContext Constructor (ITaskOutput)
SimpleProcessingContext Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SimpleProcessingContext(
    ITaskOutput output
)
Visual Basic
Public Sub New ( _
    output As ITaskOutput _
)
Visual C++
public:
SimpleProcessingContext(
    ITaskOutput^ output
)

Parameters

output
Type: Sitecore.Install.Framework..::..ITaskOutput
The task output.

See Also

SimpleProcessingContext Class
SimpleProcessingContext Overload
Sitecore.Install.Framework Namespace


SimpleProcessingContext Methods

[image] [image]

Sitecore 6.4.1 API
SimpleProcessingContext Methods
SimpleProcessingContext Class See Also Send Feedback

The SimpleProcessingContext type exposes the following members.

Methods

 | Name | Description
Public method | AddAspect<(Of <<'(T>)>>) | Adds the aspect. (Inherited from AspectBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAspect<(Of <<'(T>)>>) | Gets the aspect. (Inherited from AspectBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAspect<(Of <<'(T>)>>) | Determines whether this instance has aspect. (Inherited from AspectBase.)
Public method | MapDatabase | Returns the mapped database for the specified database.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ObjectNotFound | An action on objects the not found.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SimpleProcessingContext Class
Sitecore.Install.Framework Namespace


MapDatabase Method

[image]

Sitecore 6.4.1 API
SimpleProcessingContext..::..MapDatabase Method
SimpleProcessingContext Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string MapDatabase(
    string database
)
Visual Basic
Public Overridable Function MapDatabase ( _
    database As String _
) As String
Visual C++
public:
virtual String^ MapDatabase(
    String^ database
)

Parameters

database
Type: System..::..String
The database.

Return Value

The mapped database.

Implements

IProcessingContext..::..MapDatabase(String)

See Also

SimpleProcessingContext Class
Sitecore.Install.Framework Namespace


ObjectNotFound Method

[image]

Sitecore 6.4.1 API
SimpleProcessingContext..::..ObjectNotFound Method
SimpleProcessingContext Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void ObjectNotFound(
    string key,
    string description
)
Visual Basic
Public Sub ObjectNotFound ( _
    key As String, _
    description As String _
)
Visual C++
public:
virtual void ObjectNotFound(
    String^ key,
    String^ description
) sealed

Parameters

key
Type: System..::..String
The key.
description
Type: System..::..String
The description.

Implements

IProcessingContext..::..ObjectNotFound(String, String)

See Also

SimpleProcessingContext Class
Sitecore.Install.Framework Namespace


SimpleProcessingContext Properties

[image] [image]

Sitecore 6.4.1 API
SimpleProcessingContext Properties
SimpleProcessingContext Class See Also Send Feedback

The SimpleProcessingContext type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets the data.
Public property | Log | Gets the logger.
Public property | Output | Gets the output.
Public property | PostActions | Gets the post actions.
Public property | ShowSourceInfo | Gets or sets a value indicating whether the IProcessingContext shows the source info.
Public property | SkipCompression | Gets or sets a value indicating whether the IProcessingContext skips the compression.
Public property | SkipData | Gets or sets a value indicating whether the IProcessingContext skips the data.
Public property | SkipErrors | Gets or sets a value indicating whether error should be skipped.
Public property | SkipProperties | Gets or sets a value indicating whether the IProcessingContext skips the properties.
Public property | TaskID | Gets the unique task ID. Can be used in workers to derive task-specific object names.

See Also

SimpleProcessingContext Class
Sitecore.Install.Framework Namespace


Data Property

[image]

Sitecore 6.4.1 API
SimpleProcessingContext..::..Data Property
SimpleProcessingContext Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IDictionary<string, Object> Data { get; }
Visual Basic
Public ReadOnly Property Data As IDictionary(Of String, Object)
    Get
Visual C++
public:
virtual property IDictionary<String^, Object^>^ Data {
    IDictionary<String^, Object^>^ get () sealed;
}

Field Value

The data.

Implements

IProcessingContext..::..Data

See Also

SimpleProcessingContext Class
Sitecore.Install.Framework Namespace


Log Property

[image]

Sitecore 6.4.1 API
SimpleProcessingContext..::..Log Property
SimpleProcessingContext Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ILogger Log { get; }
Visual Basic
Public ReadOnly Property Log As ILogger
    Get
Visual C++
public:
virtual property ILogger^ Log {
    ILogger^ get () sealed;
}

Field Value

The logger.

Implements

IProcessingContext..::..Log

See Also

SimpleProcessingContext Class
Sitecore.Install.Framework Namespace


PostActions Property

[image]

Sitecore 6.4.1 API
SimpleProcessingContext..::..PostActions Property
SimpleProcessingContext Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IList<IProcessor<IProcessingContext>> PostActions { get; }
Visual Basic
Public ReadOnly Property PostActions As IList(Of IProcessor(Of IProcessingContext))
    Get
Visual C++
public:
virtual property IList<IProcessor<IProcessingContext^>^>^ PostActions {
    IList<IProcessor<IProcessingContext^>^>^ get () sealed;
}

Field Value

The post actions.

Implements

IProcessingContext..::..PostActions

See Also

SimpleProcessingContext Class
Sitecore.Install.Framework Namespace


SkipCompression Property

[image]

Sitecore 6.4.1 API
SimpleProcessingContext..::..SkipCompression Property
SimpleProcessingContext Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool SkipCompression { get; set; }
Visual Basic
Public Property SkipCompression As Boolean
    Get
    Set
Visual C++
public:
virtual property bool SkipCompression {
    bool get () sealed;
    void set (bool value) sealed;
}

Field Value

true if the IProcessingContext skips the compression; otherwise, false.

Implements

IProcessingContext..::..SkipCompression

See Also

SimpleProcessingContext Class
Sitecore.Install.Framework Namespace


SkipData Property

[image]

Sitecore 6.4.1 API
SimpleProcessingContext..::..SkipData Property
SimpleProcessingContext Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool SkipData { get; set; }
Visual Basic
Public Property SkipData As Boolean
    Get
    Set
Visual C++
public:
virtual property bool SkipData {
    bool get () sealed;
    void set (bool value) sealed;
}

Field Value

true if the IProcessingContext skips the data; otherwise, false.

Implements

IProcessingContext..::..SkipData

See Also

SimpleProcessingContext Class
Sitecore.Install.Framework Namespace


SkipErrors Property

[image]

Sitecore 6.4.1 API
SimpleProcessingContext..::..SkipErrors Property
SimpleProcessingContext Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool SkipErrors { get; set; }
Visual Basic
Public Property SkipErrors As Boolean
    Get
    Set
Visual C++
public:
property bool SkipErrors {
    bool get ();
    void set (bool value);
}

Field Value

true if [skip errors]; otherwise, false.

See Also

SimpleProcessingContext Class
Sitecore.Install.Framework Namespace


SkipProperties Property

[image]

Sitecore 6.4.1 API
SimpleProcessingContext..::..SkipProperties Property
SimpleProcessingContext Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool SkipProperties { get; set; }
Visual Basic
Public Property SkipProperties As Boolean
    Get
    Set
Visual C++
public:
virtual property bool SkipProperties {
    bool get () sealed;
    void set (bool value) sealed;
}

Field Value

true if the IProcessingContext skips the properties; otherwise, false.

Implements

IProcessingContext..::..SkipProperties

See Also

SimpleProcessingContext Class
Sitecore.Install.Framework Namespace


TaskID Property

[image]

Sitecore 6.4.1 API
SimpleProcessingContext..::..TaskID Property
SimpleProcessingContext Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string TaskID { get; }
Visual Basic
Public ReadOnly Property TaskID As String
    Get
Visual C++
public:
virtual property String^ TaskID {
    String^ get () sealed;
}

Field Value

The task ID.

Implements

IProcessingContext..::..TaskID

See Also

SimpleProcessingContext Class
Sitecore.Install.Framework Namespace


SinkDispatcher Class

[image]

Sitecore 6.4.1 API
SinkDispatcher Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SinkDispatcher : BaseSink<PackageEntry>,
    IDisposable
Visual Basic
Public Class SinkDispatcher _
    Inherits BaseSink(Of PackageEntry) _
    Implements IDisposable
Visual C++
public ref class SinkDispatcher : public BaseSink<PackageEntry^>,
    IDisposable

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..BaseSink <(Of <(<' PackageEntry >)>)>
Sitecore.Install.Framework..::..SinkDispatcher

See Also

SinkDispatcher Members
Sitecore.Install.Framework Namespace


SinkDispatcher Members

[image] [image]

Sitecore 6.4.1 API
SinkDispatcher Members
SinkDispatcher Class Constructors Methods Fields Properties See Also Send Feedback

The SinkDispatcher type exposes the following members.

Constructors

 | Name | Description
Public method | SinkDispatcher | Initializes a new instance of the SinkDispatcher class.

Methods

 | Name | Description
Public method | AddSink | Adds the sink.
Protected method | AssertInit | Asserts the init. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finishes the sink. (Overrides BaseSink<(Of <(<'T>)>)>..::..Finish()()()().)
Public method | Flush | Flushes the sink (Overrides BaseSink<(Of <(<'T>)>)>..::..Flush()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this instance. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put | Puts the specified entry. (Overrides BaseSink<(Of <(<'T>)>)>..::..Put(T).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _processingContext | (Inherited from BaseSink<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

SinkDispatcher Class
Sitecore.Install.Framework Namespace


SinkDispatcher Constructor

[image]

Sitecore 6.4.1 API
SinkDispatcher Constructor
SinkDispatcher Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SinkDispatcher(
    IProcessingContext context
)
Visual Basic
Public Sub New ( _
    context As IProcessingContext _
)
Visual C++
public:
SinkDispatcher(
    IProcessingContext^ context
)

Parameters

context
Type: Sitecore.Install.Framework..::..IProcessingContext
The context.

See Also

SinkDispatcher Class
Sitecore.Install.Framework Namespace


SinkDispatcher Fields

[image] [image]

Sitecore 6.4.1 API
SinkDispatcher Fields
SinkDispatcher Class See Also Send Feedback

The SinkDispatcher type exposes the following members.

Fields

 | Name | Description
Protected field | _processingContext | (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

SinkDispatcher Class
Sitecore.Install.Framework Namespace


SinkDispatcher Methods

[image] [image]

Sitecore 6.4.1 API
SinkDispatcher Methods
SinkDispatcher Class See Also Send Feedback

The SinkDispatcher type exposes the following members.

Methods

 | Name | Description
Public method | AddSink | Adds the sink.
Protected method | AssertInit | Asserts the init. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finishes the sink. (Overrides BaseSink<(Of <(<'T>)>)>..::..Finish()()()().)
Public method | Flush | Flushes the sink (Overrides BaseSink<(Of <(<'T>)>)>..::..Flush()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this instance. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put | Puts the specified entry. (Overrides BaseSink<(Of <(<'T>)>)>..::..Put(T).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SinkDispatcher Class
Sitecore.Install.Framework Namespace


AddSink Method

[image]

Sitecore 6.4.1 API
SinkDispatcher..::..AddSink Method
SinkDispatcher Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddSink(
    string prefix,
    ISink<PackageEntry> sink
)
Visual Basic
Public Sub AddSink ( _
    prefix As String, _
    sink As ISink(Of PackageEntry) _
)
Visual C++
public:
void AddSink(
    String^ prefix,
    ISink<PackageEntry^>^ sink
)

Parameters

prefix
Type: System..::..String
The prefix.
sink
Type: Sitecore.Install.Framework..::..ISink <(Of <(<' PackageEntry >)>)>
The sink.

See Also

SinkDispatcher Class
Sitecore.Install.Framework Namespace


Dispose Method

[image]

Sitecore 6.4.1 API
SinkDispatcher..::..Dispose Method
SinkDispatcher Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

SinkDispatcher Class
Sitecore.Install.Framework Namespace


Finish Method

[image]

Sitecore 6.4.1 API
SinkDispatcher..::..Finish Method
SinkDispatcher Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Finish()
Visual Basic
Public Overrides Sub Finish
Visual C++
public:
virtual void Finish() override

Implements

ISink<(Of <(<'T>)>)>..::..Finish()()()()

See Also

SinkDispatcher Class
Sitecore.Install.Framework Namespace


Flush Method

[image]

Sitecore 6.4.1 API
SinkDispatcher..::..Flush Method
SinkDispatcher Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Flush()
Visual Basic
Public Overrides Sub Flush
Visual C++
public:
virtual void Flush() override

Implements

ISink<(Of <(<'T>)>)>..::..Flush()()()()

See Also

SinkDispatcher Class
Sitecore.Install.Framework Namespace


Put Method

[image]

Sitecore 6.4.1 API
SinkDispatcher..::..Put Method
SinkDispatcher Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Put(
    PackageEntry entry
)
Visual Basic
Public Overrides Sub Put ( _
    entry As PackageEntry _
)
Visual C++
public:
virtual void Put(
    PackageEntry^ entry
) override

Parameters

entry
Type: Sitecore.Install.Framework..::..PackageEntry
The entry.

Implements

ISink<(Of <(<'T>)>)>..::..Put(T)

See Also

SinkDispatcher Class
Sitecore.Install.Framework Namespace


SinkDispatcher Properties

[image] [image]

Sitecore 6.4.1 API
SinkDispatcher Properties
SinkDispatcher Class See Also Send Feedback

The SinkDispatcher type exposes the following members.

Properties

 | Name | Description
Public property | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

SinkDispatcher Class
Sitecore.Install.Framework Namespace


SortingKey Class

[image]

Sitecore 6.4.1 API
SortingKey Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SortingKey : IComparable<SortingKey>
Visual Basic
Public Class SortingKey _
    Implements IComparable(Of SortingKey)
Visual C++
public ref class SortingKey : IComparable<SortingKey^>

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..SortingKey

See Also

SortingKey Members
Sitecore.Install.Framework Namespace


SortingKey Members

[image] [image]

Sitecore 6.4.1 API
SortingKey Members
SortingKey Class Constructors Methods Properties See Also Send Feedback

The SortingKey type exposes the following members.

Constructors

 | Name | Description
Public method | SortingKey()()()() | Initializes a new instance of the SortingKey class.
Public method | SortingKey(String, String) | Initializes a new instance of the SortingKey class.
Public method | SortingKey(String, String, String, String) | Initializes a new instance of the SortingKey class.

Methods

 | Name | Description
 | Compare | Compares two keys.
Protected method | CompareIDs | Compares the IDs.
Protected method | CompareLanguages | Compares the languages.
Protected method | ComparePaths | Compares the paths.
Protected method | ComparePrefixes | Compares the prefixes.
Public method | CompareTo | Compares the current object with another object of the same type.
Protected method | CompareVersions | Compares the versions.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Path | Gets or sets the path.
Public property | Prefix | Gets or sets the prefix.
Public property | UniqueID | Gets or sets the unique ID.
Public property | Version | Gets or sets the version.

See Also

SortingKey Class
Sitecore.Install.Framework Namespace


SortingKey Constructor

[image] [image]

Sitecore 6.4.1 API
SortingKey Constructor
SortingKey Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SortingKey()()()() | Initializes a new instance of the SortingKey class.
Public method | SortingKey(String, String) | Initializes a new instance of the SortingKey class.
Public method | SortingKey(String, String, String, String) | Initializes a new instance of the SortingKey class.

See Also

SortingKey Class
SortingKey Members
Sitecore.Install.Framework Namespace


SortingKey Constructor

[image]

Sitecore 6.4.1 API
SortingKey Constructor
SortingKey Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SortingKey()
Visual Basic
Public Sub New
Visual C++
public:
SortingKey()

See Also

SortingKey Class
SortingKey Overload
Sitecore.Install.Framework Namespace


SortingKey Constructor (String, String)

[image]

Sitecore 6.4.1 API
SortingKey Constructor (String, String)
SortingKey Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SortingKey(
    string prefix,
    string path
)
Visual Basic
Public Sub New ( _
    prefix As String, _
    path As String _
)
Visual C++
public:
SortingKey(
    String^ prefix,
    String^ path
)

Parameters

prefix
Type: System..::..String
The prefix.
path
Type: System..::..String
The path.

See Also

SortingKey Class
SortingKey Overload
Sitecore.Install.Framework Namespace


SortingKey Constructor (String, String, String, String)

[image]

Sitecore 6.4.1 API
SortingKey Constructor (String, String, String, String)
SortingKey Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SortingKey(
    string prefix,
    string path,
    string uniqueid,
    string version
)
Visual Basic
Public Sub New ( _
    prefix As String, _
    path As String, _
    uniqueid As String, _
    version As String _
)
Visual C++
public:
SortingKey(
    String^ prefix,
    String^ path,
    String^ uniqueid,
    String^ version
)

Parameters

prefix
Type: System..::..String
The prefix.
path
Type: System..::..String
The path.
uniqueid
Type: System..::..String
The unique id.
version
Type: System..::..String
The version.

See Also

SortingKey Class
SortingKey Overload
Sitecore.Install.Framework Namespace


SortingKey Methods

[image] [image]

Sitecore 6.4.1 API
SortingKey Methods
SortingKey Class See Also Send Feedback

The SortingKey type exposes the following members.

Methods

 | Name | Description
 | Compare | Compares two keys.
Protected method | CompareIDs | Compares the IDs.
Protected method | CompareLanguages | Compares the languages.
Protected method | ComparePaths | Compares the paths.
Protected method | ComparePrefixes | Compares the prefixes.
Public method | CompareTo | Compares the current object with another object of the same type.
Protected method | CompareVersions | Compares the versions.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SortingKey Class
Sitecore.Install.Framework Namespace


Compare Method

[image]

Sitecore 6.4.1 API
SortingKey..::..Compare Method
SortingKey Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int Compare(
    SortingKey left,
    SortingKey right
)
Visual Basic
Public Shared Function Compare ( _
    left As SortingKey, _
    right As SortingKey _
) As Integer
Visual C++
public:
static int Compare(
    SortingKey^ left,
    SortingKey^ right
)

Parameters

left
Type: Sitecore.Install.Framework..::..SortingKey
The left key.
right
Type: Sitecore.Install.Framework..::..SortingKey
The right key.

Return Value

Comparsion result.

See Also

SortingKey Class
Sitecore.Install.Framework Namespace


CompareIDs Method

[image]

Sitecore 6.4.1 API
SortingKey..::..CompareIDs Method
SortingKey Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual int CompareIDs(
    SortingKey left,
    SortingKey right
)
Visual Basic
Protected Overridable Function CompareIDs ( _
    left As SortingKey, _
    right As SortingKey _
) As Integer
Visual C++
protected:
virtual int CompareIDs(
    SortingKey^ left,
    SortingKey^ right
)

Parameters

left
Type: Sitecore.Install.Framework..::..SortingKey
The left.
right
Type: Sitecore.Install.Framework..::..SortingKey
The right.

Return Value

[Missing <returns> documentation for "M:Sitecore.Install.Framework.SortingKey.CompareIDs(Sitecore.Install.Framework.SortingKey,Sitecore.Install.Framework.SortingKey)"]

See Also

SortingKey Class
Sitecore.Install.Framework Namespace


CompareLanguages Method

[image]

Sitecore 6.4.1 API
SortingKey..::..CompareLanguages Method
SortingKey Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual int CompareLanguages(
    SortingKey left,
    SortingKey right
)
Visual Basic
Protected Overridable Function CompareLanguages ( _
    left As SortingKey, _
    right As SortingKey _
) As Integer
Visual C++
protected:
virtual int CompareLanguages(
    SortingKey^ left,
    SortingKey^ right
)

Parameters

left
Type: Sitecore.Install.Framework..::..SortingKey
The left.
right
Type: Sitecore.Install.Framework..::..SortingKey
The right.

Return Value

[Missing <returns> documentation for "M:Sitecore.Install.Framework.SortingKey.CompareLanguages(Sitecore.Install.Framework.SortingKey,Sitecore.Install.Framework.SortingKey)"]

See Also

SortingKey Class
Sitecore.Install.Framework Namespace


ComparePaths Method

[image]

Sitecore 6.4.1 API
SortingKey..::..ComparePaths Method
SortingKey Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual int ComparePaths(
    SortingKey left,
    SortingKey right
)
Visual Basic
Protected Overridable Function ComparePaths ( _
    left As SortingKey, _
    right As SortingKey _
) As Integer
Visual C++
protected:
virtual int ComparePaths(
    SortingKey^ left,
    SortingKey^ right
)

Parameters

left
Type: Sitecore.Install.Framework..::..SortingKey
The left.
right
Type: Sitecore.Install.Framework..::..SortingKey
The right.

Return Value

[Missing <returns> documentation for "M:Sitecore.Install.Framework.SortingKey.ComparePaths(Sitecore.Install.Framework.SortingKey,Sitecore.Install.Framework.SortingKey)"]

See Also

SortingKey Class
Sitecore.Install.Framework Namespace


ComparePrefixes Method

[image]

Sitecore 6.4.1 API
SortingKey..::..ComparePrefixes Method
SortingKey Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual int ComparePrefixes(
    SortingKey left,
    SortingKey right
)
Visual Basic
Protected Overridable Function ComparePrefixes ( _
    left As SortingKey, _
    right As SortingKey _
) As Integer
Visual C++
protected:
virtual int ComparePrefixes(
    SortingKey^ left,
    SortingKey^ right
)

Parameters

left
Type: Sitecore.Install.Framework..::..SortingKey
The left.
right
Type: Sitecore.Install.Framework..::..SortingKey
The right.

Return Value

[Missing <returns> documentation for "M:Sitecore.Install.Framework.SortingKey.ComparePrefixes(Sitecore.Install.Framework.SortingKey,Sitecore.Install.Framework.SortingKey)"]

See Also

SortingKey Class
Sitecore.Install.Framework Namespace


CompareTo Method

[image]

Sitecore 6.4.1 API
SortingKey..::..CompareTo Method
SortingKey Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual int CompareTo(
    SortingKey other
)
Visual Basic
Public Overridable Function CompareTo ( _
    other As SortingKey _
) As Integer
Visual C++
public:
virtual int CompareTo(
    SortingKey^ other
)

Parameters

other
Type: Sitecore.Install.Framework..::..SortingKey
An object to compare with this object.

Return Value

A 32-bit signed integer that indicates the relative order of the objects being compared. The return value has the following meanings: Value Meaning Less than zero This object is less than the other parameter.Zero This object is equal to other. Greater than zero This object is greater than other.

Implements

IComparable<(Of <(<'T>)>)>..::..CompareTo(T)

See Also

SortingKey Class
Sitecore.Install.Framework Namespace


CompareVersions Method

[image]

Sitecore 6.4.1 API
SortingKey..::..CompareVersions Method
SortingKey Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual int CompareVersions(
    SortingKey left,
    SortingKey right
)
Visual Basic
Protected Overridable Function CompareVersions ( _
    left As SortingKey, _
    right As SortingKey _
) As Integer
Visual C++
protected:
virtual int CompareVersions(
    SortingKey^ left,
    SortingKey^ right
)

Parameters

left
Type: Sitecore.Install.Framework..::..SortingKey
The left.
right
Type: Sitecore.Install.Framework..::..SortingKey
The right.

Return Value

[Missing <returns> documentation for "M:Sitecore.Install.Framework.SortingKey.CompareVersions(Sitecore.Install.Framework.SortingKey,Sitecore.Install.Framework.SortingKey)"]

See Also

SortingKey Class
Sitecore.Install.Framework Namespace


SortingKey Properties

[image] [image]

Sitecore 6.4.1 API
SortingKey Properties
SortingKey Class See Also Send Feedback

The SortingKey type exposes the following members.

Properties

 | Name | Description
Public property | Path | Gets or sets the path.
Public property | Prefix | Gets or sets the prefix.
Public property | UniqueID | Gets or sets the unique ID.
Public property | Version | Gets or sets the version.

See Also

SortingKey Class
Sitecore.Install.Framework Namespace


Path Property

[image]

Sitecore 6.4.1 API
SortingKey..::..Path Property
SortingKey Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Path { get; set; }
Visual Basic
Public Property Path As String
    Get
    Set
Visual C++
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}

Field Value

The path.

See Also

SortingKey Class
Sitecore.Install.Framework Namespace


Prefix Property

[image]

Sitecore 6.4.1 API
SortingKey..::..Prefix Property
SortingKey Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Prefix { get; set; }
Visual Basic
Public Property Prefix As String
    Get
    Set
Visual C++
public:
property String^ Prefix {
    String^ get ();
    void set (String^ value);
}

Field Value

The prefix.

See Also

SortingKey Class
Sitecore.Install.Framework Namespace


UniqueID Property

[image]

Sitecore 6.4.1 API
SortingKey..::..UniqueID Property
SortingKey Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string UniqueID { get; set; }
Visual Basic
Public Property UniqueID As String
    Get
    Set
Visual C++
public:
property String^ UniqueID {
    String^ get ();
    void set (String^ value);
}

Field Value

The unique ID.

See Also

SortingKey Class
Sitecore.Install.Framework Namespace


SourceCollection(T) Members

[image] [image]

Sitecore 6.4.1 API
SourceCollection<(Of <(<'T>)>)> Members
SourceCollection<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The SourceCollection<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | SourceCollection<(Of <(<'T>)>)> | Initializes a new instance of the SourceCollection<(Of <(<'T>)>)> class

Methods

 | Name | Description
Public method | Add | Adds the specified source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Populates specified sink with sources.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Sources | Gets the sources.

See Also

SourceCollection<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


SourceCollection(T) Constructor

[image]

Sitecore 6.4.1 API
SourceCollection<(Of <(<'T>)>)> Constructor
SourceCollection<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SourceCollection()
Visual Basic
Public Sub New
Visual C++
public:
SourceCollection()

See Also

SourceCollection<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


SourceCollection(T) Methods

[image] [image]

Sitecore 6.4.1 API
SourceCollection<(Of <(<'T>)>)> Methods
SourceCollection<(Of <(<'T>)>)> Class See Also Send Feedback

The SourceCollection<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Populates specified sink with sources.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SourceCollection<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


Add Method

[image]

Sitecore 6.4.1 API
SourceCollection<(Of <(<'T>)>)>..::..Add Method
SourceCollection<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Add(
    ISource<T> source
)
Visual Basic
Public Sub Add ( _
    source As ISource(Of T) _
)
Visual C++
public:
void Add(
    ISource<T>^ source
)

Parameters

source
Type: Sitecore.Install.Framework..::..ISource <(Of <(<' T >)>)>
The source.

See Also

SourceCollection<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


Populate Method

[image]

Sitecore 6.4.1 API
SourceCollection<(Of <(<'T>)>)>..::..Populate Method
SourceCollection<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Populate(
    ISink<T> sink
)
Visual Basic
Public Sub Populate ( _
    sink As ISink(Of T) _
)
Visual C++
public:
virtual void Populate(
    ISink<T>^ sink
) sealed

Parameters

sink
Type: Sitecore.Install.Framework..::..ISink <(Of <(<' T >)>)>
The sink.

Implements

ISource<(Of <(<'T>)>)>..::..Populate(ISink<(Of <<'(T>)>>))

See Also

SourceCollection<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


SourceCollection(T) Properties

[image] [image]

Sitecore 6.4.1 API
SourceCollection<(Of <(<'T>)>)> Properties
SourceCollection<(Of <(<'T>)>)> Class See Also Send Feedback

The SourceCollection<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Sources | Gets the sources.

See Also

SourceCollection<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


Sources Property

[image]

Sitecore 6.4.1 API
SourceCollection<(Of <(<'T>)>)>..::..Sources Property
SourceCollection<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ICollection<ISource<T>> Sources { get; }
Visual Basic
Public ReadOnly Property Sources As ICollection(Of ISource(Of T))
    Get
Visual C++
public:
property ICollection<ISource<T>^>^ Sources {
    ICollection<ISource<T>^>^ get ();
}

Field Value

The sources.

See Also

SourceCollection<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


SourceInverter(T) Class

[image]

Sitecore 6.4.1 API
SourceInverter<(Of <(<'T>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SourceInverter<T> : IEnumerable<T>,
    IEnumerable, IEnumerator<TElement>, IDisposable, IEnumerator
Visual Basic
Public Class SourceInverter(Of T) _
    Implements IEnumerable(Of T), IEnumerable, IEnumerator(Of TElement),  _
    IDisposable, IEnumerator
Visual C++
generic<typename T>
public ref class SourceInverter : IEnumerable<T>,
    IEnumerable, IEnumerator<TElement>, IDisposable, IEnumerator

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Sitecore.Install.Framework.SourceInverter`1"]

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..SourceInverter<(Of <(<'T>)>)>

See Also

SourceInverter<(Of <(<'T>)>)> Members
Sitecore.Install.Framework Namespace


SourceInverter(T) Constructor

[image]

Sitecore 6.4.1 API
SourceInverter<(Of <(<'T>)>)> Constructor
SourceInverter<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SourceInverter(
    ISource<T> source,
    IProcessingContext context
)
Visual Basic
Public Sub New ( _
    source As ISource(Of T), _
    context As IProcessingContext _
)
Visual C++
public:
SourceInverter(
    ISource<T>^ source,
    IProcessingContext^ context
)

Parameters

source
Type: Sitecore.Install.Framework..::..ISource <(Of <(<' T >)>)>
The source.
context
Type: Sitecore.Install.Framework..::..IProcessingContext
The processing context.

See Also

SourceInverter<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


SourceInverter(T) Methods

[image] [image]

Sitecore 6.4.1 API
SourceInverter<(Of <(<'T>)>)> Methods
SourceInverter<(Of <(<'T>)>)> Class See Also Send Feedback

The SourceInverter<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext | Advances the enumerator to the next element of the collection.
Public method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | Convert<(Of <<'(T, TTo>)>>) | Converts this instance. (Defined by EnumerableExtensions.)
Public Extension Method | StringConcatenate<(Of <<'(T>)>>) | Concatenate strings (Defined by IEnumerableExtensions.)

See Also

SourceInverter<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


Dispose Method

[image]

Sitecore 6.4.1 API
SourceInverter<(Of <(<'T>)>)>..::..Dispose Method
SourceInverter<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

SourceInverter<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


GetEnumerator Method

[image]

Sitecore 6.4.1 API
SourceInverter<(Of <(<'T>)>)>..::..GetEnumerator Method
SourceInverter<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IEnumerator<T> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of T)
Visual C++
public:
virtual IEnumerator<T>^ GetEnumerator() sealed

Return Value

A IEnumerator<(Of <(<'T>)>)> that can be used to iterate through the collection.

See Also

SourceInverter<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


MoveNext Method

[image]

Sitecore 6.4.1 API
SourceInverter<(Of <(<'T>)>)>..::..MoveNext Method
SourceInverter<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool MoveNext()
Visual Basic
Public Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext() sealed

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Implements

IEnumerator..::..MoveNext()()()()

Exceptions

Exception | Condition
System..::..InvalidOperationException | The collection was modified after the enumerator was created.

See Also

SourceInverter<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


Reset Method

[image]

Sitecore 6.4.1 API
SourceInverter<(Of <(<'T>)>)>..::..Reset Method
SourceInverter<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset
Visual C++
public:
virtual void Reset() sealed

Implements

IEnumerator..::..Reset()()()()

Exceptions

Exception | Condition
System..::..InvalidOperationException | The collection was modified after the enumerator was created.

See Also

SourceInverter<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


SourceInverter(T) Properties

[image] [image]

Sitecore 6.4.1 API
SourceInverter<(Of <(<'T>)>)> Properties
SourceInverter<(Of <(<'T>)>)> Class See Also Send Feedback

The SourceInverter<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Current | Gets the element in the collection at the current position of the enumerator.

See Also

SourceInverter<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


Current Property

[image]

Sitecore 6.4.1 API
SourceInverter<(Of <(<'T>)>)>..::..Current Property
SourceInverter<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public T Current { get; }
Visual Basic
Public ReadOnly Property Current As T
    Get
Visual C++
public:
virtual property T Current {
    T get () sealed;
}

Field Value

Return Value

The element in the collection at the current position of the enumerator.

See Also

SourceInverter<(Of <(<'T>)>)> Class
Sitecore.Install.Framework Namespace


TrivialConverter Class

[image]

Sitecore 6.4.1 API
TrivialConverter Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class TrivialConverter : BaseConverter<PackageEntry>
Visual Basic
Public Class TrivialConverter _
    Inherits BaseConverter(Of PackageEntry)
Visual C++
public ref class TrivialConverter : public BaseConverter<PackageEntry^>

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..BaseConverter <(Of <(<' PackageEntry >)>)>
Sitecore.Install.Framework..::..TrivialConverter

See Also

TrivialConverter Members
Sitecore.Install.Framework Namespace


TrivialConverter Members

[image] [image]

Sitecore 6.4.1 API
TrivialConverter Members
TrivialConverter Class Constructors Methods Properties See Also Send Feedback

The TrivialConverter type exposes the following members.

Constructors

 | Name | Description
Public method | TrivialConverter | Initializes a new instance of the TrivialConverter class

Methods

 | Name | Description
Protected method | ApplyTransforms(PackageEntry, IProcessingContext) | Applies the transform. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public method | Convert | Converts the specified entry. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttribute | Gets the value of the attribute. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InternalConvert | Returns the entry. (Overrides BaseConverter<(Of <(<'T>)>)>..::..InternalConvert(T, IProcessingContext).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetAttribute | Sets the value of the attribute. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Protected property | AutoApplyTransforms | Gets a value indicating whether the BaseConverter<(Of <(<'T>)>)> converter transforms should be applied by BaseConverter, not the derived class. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public property | Transforms | Gets the transforms. (Inherited from BaseConverter<(Of <(<'T>)>)>.)

See Also

TrivialConverter Class
Sitecore.Install.Framework Namespace


TrivialConverter Constructor

[image]

Sitecore 6.4.1 API
TrivialConverter Constructor
TrivialConverter Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TrivialConverter()
Visual Basic
Public Sub New
Visual C++
public:
TrivialConverter()

See Also

TrivialConverter Class
Sitecore.Install.Framework Namespace


TrivialConverter Methods

[image] [image]

Sitecore 6.4.1 API
TrivialConverter Methods
TrivialConverter Class See Also Send Feedback

The TrivialConverter type exposes the following members.

Methods

 | Name | Description
Protected method | ApplyTransforms(PackageEntry, IProcessingContext) | Applies the transform. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public method | Convert | Converts the specified entry. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttribute | Gets the value of the attribute. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InternalConvert | Returns the entry. (Overrides BaseConverter<(Of <(<'T>)>)>..::..InternalConvert(T, IProcessingContext).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetAttribute | Sets the value of the attribute. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TrivialConverter Class
Sitecore.Install.Framework Namespace


InternalConvert Method

[image]

Sitecore 6.4.1 API
TrivialConverter..::..InternalConvert Method
TrivialConverter Class See Also Send Feedback

Namespace: Sitecore.Install.Framework
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override PackageEntry[] InternalConvert(
    PackageEntry entry,
    IProcessingContext context
)
Visual Basic
Protected Overrides Function InternalConvert ( _
    entry As PackageEntry, _
    context As IProcessingContext _
) As PackageEntry()
Visual C++
protected:
virtual array<PackageEntry^>^ InternalConvert(
    PackageEntry^ entry,
    IProcessingContext^ context
) override

Parameters

entry
Type: Sitecore.Install.Framework..::..PackageEntry
The entry.
context
Type: Sitecore.Install.Framework..::..IProcessingContext
The processing context.

Return Value

The conversion result.

See Also

TrivialConverter Class
Sitecore.Install.Framework Namespace


TrivialConverter Properties

[image] [image]

Sitecore 6.4.1 API
TrivialConverter Properties
TrivialConverter Class See Also Send Feedback

The TrivialConverter type exposes the following members.

Properties

 | Name | Description
Protected property | AutoApplyTransforms | Gets a value indicating whether the BaseConverter<(Of <(<'T>)>)> converter transforms should be applied by BaseConverter, not the derived class. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public property | Transforms | Gets the transforms. (Inherited from BaseConverter<(Of <(<'T>)>)>.)

See Also

TrivialConverter Class
Sitecore.Install.Framework Namespace


Sitecore.Install.Items Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Install.Items Namespace
Send Feedback

Classes

 | Class | Description
Public class | DefaultItemInstallerEvents | Default implementation of IItemInstallerEvents
Public class | ExplicitItemSource | Explicit item source
Public class | ExplicitItemSource..::..Builder | Builds an ExplicitItemSource object
Public class | ItemEntryData | Item entry data
Public class | ItemFieldsProperties | ItemFieldsProperties class. Used by packager and UPT.
Public class | ItemInstaller | Item installer
Public class | ItemInstaller..::..VersionInstaller | Version installer
Public class | ItemInstallerContext | Item installer context
Public class | ItemKeyProvider | Item key provider
Public class | ItemKeyUtils | Item key utils
Public class | ItemReference | Item reference
Public class | ItemSource | Item source
Public class | ItemToEntryConverter | Item to entry converter
Public class | ItemUninstaller | Item uninstaller
Public class | LegacyItemUnpacker | Legacy item unpacker

Interfaces

 | Interface | Description
Public interface | IItemInstallerEvents | Defines basic event of an item installer

Enumerations

 | Enumeration | Description
Public enumeration | VersionInstallMode | Version install mode


DefaultItemInstallerEvents Class

[image]

Sitecore 6.4.1 API
DefaultItemInstallerEvents Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DefaultItemInstallerEvents : IItemInstallerEvents
Visual Basic
Public Class DefaultItemInstallerEvents _
    Implements IItemInstallerEvents
Visual C++
public ref class DefaultItemInstallerEvents : IItemInstallerEvents

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Items..::..DefaultItemInstallerEvents

See Also

DefaultItemInstallerEvents Members
Sitecore.Install.Items Namespace


DefaultItemInstallerEvents Members

[image] [image]

Sitecore 6.4.1 API
DefaultItemInstallerEvents Members
DefaultItemInstallerEvents Class Constructors Methods See Also Send Feedback

The DefaultItemInstallerEvents type exposes the following members.

Constructors

 | Name | Description
Public method | DefaultItemInstallerEvents | Initializes a new instance of the DefaultItemInstallerEvents class.

Methods

 | Name | Description
Public method | AskUser | Returns the behavour options was specified in the constructor
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultItemInstallerEvents Class
Sitecore.Install.Items Namespace


DefaultItemInstallerEvents Constructor

[image]

Sitecore 6.4.1 API
DefaultItemInstallerEvents Constructor
DefaultItemInstallerEvents Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DefaultItemInstallerEvents(
    BehaviourOptions options
)
Visual Basic
Public Sub New ( _
    options As BehaviourOptions _
)
Visual C++
public:
DefaultItemInstallerEvents(
    BehaviourOptions^ options
)

Parameters

options
Type: Sitecore.Install.Utils..::..BehaviourOptions
The options.

See Also

DefaultItemInstallerEvents Class
Sitecore.Install.Items Namespace


DefaultItemInstallerEvents Methods

[image] [image]

Sitecore 6.4.1 API
DefaultItemInstallerEvents Methods
DefaultItemInstallerEvents Class See Also Send Feedback

The DefaultItemInstallerEvents type exposes the following members.

Methods

 | Name | Description
Public method | AskUser | Returns the behavour options was specified in the constructor
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultItemInstallerEvents Class
Sitecore.Install.Items Namespace


AskUser Method

[image]

Sitecore 6.4.1 API
DefaultItemInstallerEvents..::..AskUser Method
DefaultItemInstallerEvents Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Pair<BehaviourOptions, bool> AskUser(
    ItemInfo databaseItem,
    ItemInfo packageItem,
    IProcessingContext context
)
Visual Basic
Public Function AskUser ( _
    databaseItem As ItemInfo, _
    packageItem As ItemInfo, _
    context As IProcessingContext _
) As Pair(Of BehaviourOptions, Boolean)
Visual C++
public:
virtual Pair<BehaviourOptions^, bool>^ AskUser(
    ItemInfo^ databaseItem,
    ItemInfo^ packageItem,
    IProcessingContext^ context
) sealed

Parameters

databaseItem
Type: Sitecore.Install.Utils..::..ItemInfo
The database item.
packageItem
Type: Sitecore.Install.Utils..::..ItemInfo
The package item.
context
Type: Sitecore.Install.Framework..::..IProcessingContext
The context.

Return Value

The user.

Implements

IItemInstallerEvents..::..AskUser(ItemInfo, ItemInfo, IProcessingContext)

See Also

DefaultItemInstallerEvents Class
Sitecore.Install.Items Namespace


ExplicitItemSource Class

[image]

Sitecore 6.4.1 API
ExplicitItemSource Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ExplicitItemSource : BaseSource<Item>,
    IExplicitSource, IKeyResolver
Visual Basic
Public Class ExplicitItemSource _
    Inherits BaseSource(Of Item) _
    Implements IExplicitSource, IKeyResolver
Visual C++
public ref class ExplicitItemSource : public BaseSource<Item^>,
    IExplicitSource, IKeyResolver

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..BaseSource <(Of <(<' Item >)>)>
Sitecore.Install.Items..::..ExplicitItemSource

See Also

ExplicitItemSource Members
Sitecore.Install.Items Namespace


ExplicitItemSource Members

[image] [image]

Sitecore 6.4.1 API
ExplicitItemSource Members
ExplicitItemSource Class Constructors Methods Properties See Also Send Feedback

The ExplicitItemSource type exposes the following members.

Constructors

 | Name | Description
Public method | ExplicitItemSource | Initializes a new instance of the ExplicitItemSource class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InternalPopulate | To be overridden in descendants (Overrides BaseSource<(Of <(<'T>)>)>..::..InternalPopulate(ISink<(Of <<'(T>)>>)).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Populates this sourse from the specified sink. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public method | ResolveKey | Resolves the key.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Converter | Gets or sets the converter. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Entries | Gets the entries.
Public property | Exclude | Gets the exclude filters. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Include | Gets the include filters. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Name | Gets or sets the name. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | SkipVersions | Gets or sets a value indicating whether the ExplicitItemSource skips the versions.

See Also

ExplicitItemSource Class
Sitecore.Install.Items Namespace


ExplicitItemSource Constructor

[image]

Sitecore 6.4.1 API
ExplicitItemSource Constructor
ExplicitItemSource Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ExplicitItemSource()
Visual Basic
Public Sub New
Visual C++
public:
ExplicitItemSource()

See Also

ExplicitItemSource Class
Sitecore.Install.Items Namespace


ExplicitItemSource Methods

[image] [image]

Sitecore 6.4.1 API
ExplicitItemSource Methods
ExplicitItemSource Class See Also Send Feedback

The ExplicitItemSource type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InternalPopulate | To be overridden in descendants (Overrides BaseSource<(Of <(<'T>)>)>..::..InternalPopulate(ISink<(Of <<'(T>)>>)).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Populates this sourse from the specified sink. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public method | ResolveKey | Resolves the key.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExplicitItemSource Class
Sitecore.Install.Items Namespace


InternalPopulate Method

[image]

Sitecore 6.4.1 API
ExplicitItemSource..::..InternalPopulate Method
ExplicitItemSource Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void InternalPopulate(
    ISink<Item> sink
)
Visual Basic
Protected Overrides Sub InternalPopulate ( _
    sink As ISink(Of Item) _
)
Visual C++
protected:
virtual void InternalPopulate(
    ISink<Item^>^ sink
) override

Parameters

sink
Type: Sitecore.Install.Framework..::..ISink <(Of <(<' Item >)>)>
The sink

See Also

ExplicitItemSource Class
Sitecore.Install.Items Namespace


ResolveKey Method

[image]

Sitecore 6.4.1 API
ExplicitItemSource..::..ResolveKey Method
ExplicitItemSource Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object ResolveKey(
    string key
)
Visual Basic
Public Function ResolveKey ( _
    key As String _
) As Object
Visual C++
public:
virtual Object^ ResolveKey(
    String^ key
) sealed

Parameters

key
Type: System..::..String
The key.

Return Value

The object.

Implements

IKeyResolver..::..ResolveKey(String)

See Also

ExplicitItemSource Class
Sitecore.Install.Items Namespace


ExplicitItemSource Properties

[image] [image]

Sitecore 6.4.1 API
ExplicitItemSource Properties
ExplicitItemSource Class See Also Send Feedback

The ExplicitItemSource type exposes the following members.

Properties

 | Name | Description
Public property | Converter | Gets or sets the converter. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Entries | Gets the entries.
Public property | Exclude | Gets the exclude filters. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Include | Gets the include filters. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Name | Gets or sets the name. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | SkipVersions | Gets or sets a value indicating whether the ExplicitItemSource skips the versions.

See Also

ExplicitItemSource Class
Sitecore.Install.Items Namespace


Entries Property

[image]

Sitecore 6.4.1 API
ExplicitItemSource..::..Entries Property
ExplicitItemSource Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IList<string> Entries { get; }
Visual Basic
Public ReadOnly Property Entries As IList(Of String)
    Get
Visual C++
public:
virtual property IList<String^>^ Entries {
    IList<String^>^ get () sealed;
}

Field Value

The entries.

Implements

IExplicitSource..::..Entries

See Also

ExplicitItemSource Class
Sitecore.Install.Items Namespace


SkipVersions Property

[image]

Sitecore 6.4.1 API
ExplicitItemSource..::..SkipVersions Property
ExplicitItemSource Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool SkipVersions { get; set; }
Visual Basic
Public Property SkipVersions As Boolean
    Get
    Set
Visual C++
public:
property bool SkipVersions {
    bool get ();
    void set (bool value);
}

Field Value

true if the ExplicitItemSource skips the versions; otherwise, false.

See Also

ExplicitItemSource Class
Sitecore.Install.Items Namespace


ExplicitItemSource.Builder Class

[image]

Sitecore 6.4.1 API
ExplicitItemSource..::..Builder Class
ExplicitItemSource Class Members See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Builder : BaseSink<PackageEntry>
Visual Basic
Public Class Builder _
    Inherits BaseSink(Of PackageEntry)
Visual C++
public ref class Builder : public BaseSink<PackageEntry^>

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..BaseSink <(Of <(<' PackageEntry >)>)>
Sitecore.Install.Items..::..ExplicitItemSource..::..Builder

See Also

ExplicitItemSource..::..Builder Members
Sitecore.Install.Items Namespace


ExplicitItemSource.Builder Members

[image] [image]

Sitecore 6.4.1 API
ExplicitItemSource..::..Builder Members
ExplicitItemSource..::..Builder Class Constructors Methods Fields Properties See Also Send Feedback

Explicit item source

The ExplicitItemSource..::..Builder type exposes the following members.

Constructors

 | Name | Description
Public method | ExplicitItemSource..::..Builder()()()() | Initializes a new instance of the ExplicitItemSource..::..Builder class.
Public method | ExplicitItemSource..::..Builder(ExplicitItemSource) | Initializes a new instance of the ExplicitItemSource..::..Builder class.

Methods

 | Name | Description
Protected method | AssertInit | Asserts the init. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finishes the sink. (Overrides BaseSink<(Of <(<'T>)>)>..::..Finish()()()().)
Public method | Flush | Flushes the sink (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this instance. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put | Puts the specified entry. (Overrides BaseSink<(Of <(<'T>)>)>..::..Put(T).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _processingContext | (Inherited from BaseSink<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | ExpectExactReferences | Gets or sets a value indicating whether the ExplicitItemSource..::..Builder expects the exact references.
Public property | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | Source | Gets or sets the source.

See Also

ExplicitItemSource..::..Builder Class
Sitecore.Install.Items Namespace


ExplicitItemSource.Builder Constructor

[image] [image]

Sitecore 6.4.1 API
ExplicitItemSource..::..Builder Constructor
ExplicitItemSource..::..Builder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExplicitItemSource..::..Builder()()()() | Initializes a new instance of the ExplicitItemSource..::..Builder class.
Public method | ExplicitItemSource..::..Builder(ExplicitItemSource) | Initializes a new instance of the ExplicitItemSource..::..Builder class.

See Also

ExplicitItemSource..::..Builder Class
ExplicitItemSource..::..Builder Members
Sitecore.Install.Items Namespace


ExplicitItemSource.Builder Constructor

[image]

Sitecore 6.4.1 API
ExplicitItemSource..::..Builder Constructor
ExplicitItemSource..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Builder()
Visual Basic
Public Sub New
Visual C++
public:
Builder()

See Also

ExplicitItemSource..::..Builder Class
ExplicitItemSource..::..Builder Overload
Sitecore.Install.Items Namespace


ExplicitItemSource.Builder Constructor (ExplicitItemSource)

[image]

Sitecore 6.4.1 API
ExplicitItemSource..::..Builder Constructor (ExplicitItemSource)
ExplicitItemSource..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Builder(
    ExplicitItemSource source
)
Visual Basic
Public Sub New ( _
    source As ExplicitItemSource _
)
Visual C++
public:
Builder(
    ExplicitItemSource^ source
)

Parameters

source
Type: Sitecore.Install.Items..::..ExplicitItemSource
The source.

See Also

ExplicitItemSource..::..Builder Class
ExplicitItemSource..::..Builder Overload
Sitecore.Install.Items Namespace


ExplicitItemSource.Builder Fields

[image] [image]

Sitecore 6.4.1 API
ExplicitItemSource..::..Builder Fields
ExplicitItemSource..::..Builder Class See Also Send Feedback

The ExplicitItemSource..::..Builder type exposes the following members.

Fields

 | Name | Description
Protected field | _processingContext | (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

ExplicitItemSource..::..Builder Class
Sitecore.Install.Items Namespace


ExplicitItemSource.Builder Methods

[image] [image]

Sitecore 6.4.1 API
ExplicitItemSource..::..Builder Methods
ExplicitItemSource..::..Builder Class See Also Send Feedback

The ExplicitItemSource..::..Builder type exposes the following members.

Methods

 | Name | Description
Protected method | AssertInit | Asserts the init. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finishes the sink. (Overrides BaseSink<(Of <(<'T>)>)>..::..Finish()()()().)
Public method | Flush | Flushes the sink (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this instance. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put | Puts the specified entry. (Overrides BaseSink<(Of <(<'T>)>)>..::..Put(T).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExplicitItemSource..::..Builder Class
Sitecore.Install.Items Namespace


Put Method

[image]

Sitecore 6.4.1 API
ExplicitItemSource..::..Builder..::..Put Method
ExplicitItemSource..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Put(
    PackageEntry entry
)
Visual Basic
Public Overrides Sub Put ( _
    entry As PackageEntry _
)
Visual C++
public:
virtual void Put(
    PackageEntry^ entry
) override

Parameters

entry
Type: Sitecore.Install.Framework..::..PackageEntry
The entry.

Implements

ISink<(Of <(<'T>)>)>..::..Put(T)

See Also

ExplicitItemSource..::..Builder Class
Sitecore.Install.Items Namespace


ExplicitItemSource.Builder Properties

[image] [image]

Sitecore 6.4.1 API
ExplicitItemSource..::..Builder Properties
ExplicitItemSource..::..Builder Class See Also Send Feedback

The ExplicitItemSource..::..Builder type exposes the following members.

Properties

 | Name | Description
Public property | ExpectExactReferences | Gets or sets a value indicating whether the ExplicitItemSource..::..Builder expects the exact references.
Public property | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | Source | Gets or sets the source.

See Also

ExplicitItemSource..::..Builder Class
Sitecore.Install.Items Namespace


ExpectExactReferences Property

[image]

Sitecore 6.4.1 API
ExplicitItemSource..::..Builder..::..ExpectExactReferences Property
ExplicitItemSource..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ExpectExactReferences { get; set; }
Visual Basic
Public Property ExpectExactReferences As Boolean
    Get
    Set
Visual C++
public:
property bool ExpectExactReferences {
    bool get ();
    void set (bool value);
}

Field Value

true if the ExplicitItemSource..::..Builder expects the exact references; otherwise, false.

See Also

ExplicitItemSource..::..Builder Class
Sitecore.Install.Items Namespace


Source Property

[image]

Sitecore 6.4.1 API
ExplicitItemSource..::..Builder..::..Source Property
ExplicitItemSource..::..Builder Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ExplicitItemSource Source { get; set; }
Visual Basic
Public Property Source As ExplicitItemSource
    Get
    Set
Visual C++
public:
property ExplicitItemSource^ Source {
    ExplicitItemSource^ get ();
    void set (ExplicitItemSource^ value);
}

Field Value

The source.

See Also

ExplicitItemSource..::..Builder Class
Sitecore.Install.Items Namespace


IItemInstallerEvents Interface

[image]

Sitecore 6.4.1 API
IItemInstallerEvents Interface
Members See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IItemInstallerEvents
Visual Basic
Public Interface IItemInstallerEvents
Visual C++
public interface class IItemInstallerEvents

See Also

IItemInstallerEvents Members
Sitecore.Install.Items Namespace


IItemInstallerEvents Members

[image] [image]

Sitecore 6.4.1 API
IItemInstallerEvents Members
IItemInstallerEvents Interface Methods See Also Send Feedback

The IItemInstallerEvents type exposes the following members.

Methods

 | Name | Description
Public method | AskUser | Asks the user what to do when we have an item collision.

See Also

IItemInstallerEvents Interface
Sitecore.Install.Items Namespace


IItemInstallerEvents Methods

[image] [image]

Sitecore 6.4.1 API
IItemInstallerEvents Methods
IItemInstallerEvents Interface See Also Send Feedback

The IItemInstallerEvents type exposes the following members.

Methods

 | Name | Description
Public method | AskUser | Asks the user what to do when we have an item collision.

See Also

IItemInstallerEvents Interface
Sitecore.Install.Items Namespace


AskUser Method

[image]

Sitecore 6.4.1 API
IItemInstallerEvents..::..AskUser Method
IItemInstallerEvents Interface See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
Pair<BehaviourOptions, bool> AskUser(
    ItemInfo databaseItem,
    ItemInfo packageItem,
    IProcessingContext context
)
Visual Basic
Function AskUser ( _
    databaseItem As ItemInfo, _
    packageItem As ItemInfo, _
    context As IProcessingContext _
) As Pair(Of BehaviourOptions, Boolean)
Visual C++
Pair<BehaviourOptions^, bool>^ AskUser(
    ItemInfo^ databaseItem,
    ItemInfo^ packageItem,
    IProcessingContext^ context
)

Parameters

databaseItem
Type: Sitecore.Install.Utils..::..ItemInfo
The database item.
packageItem
Type: Sitecore.Install.Utils..::..ItemInfo
The package item.
context
Type: Sitecore.Install.Framework..::..IProcessingContext
The context.

Return Value

The user.

See Also

IItemInstallerEvents Interface
Sitecore.Install.Items Namespace


ItemEntryData Class

[image]

Sitecore 6.4.1 API
ItemEntryData Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemEntryData : IEntryData
Visual Basic
Public Class ItemEntryData _
    Implements IEntryData
Visual C++
public ref class ItemEntryData : IEntryData

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Items..::..ItemEntryData

See Also

ItemEntryData Members
Sitecore.Install.Items Namespace


ItemEntryData Members

[image] [image]

Sitecore 6.4.1 API
ItemEntryData Members
ItemEntryData Class Constructors Methods Properties See Also Send Feedback

The ItemEntryData type exposes the following members.

Constructors

 | Name | Description
Public method | ItemEntryData | Initializes a new instance of the ItemEntryData class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStream | Gets the stream holder.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Key | Gets the key.

See Also

ItemEntryData Class
Sitecore.Install.Items Namespace


ItemEntryData Constructor

[image]

Sitecore 6.4.1 API
ItemEntryData Constructor
ItemEntryData Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemEntryData(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
ItemEntryData(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

ItemEntryData Class
Sitecore.Install.Items Namespace


ItemEntryData Methods

[image] [image]

Sitecore 6.4.1 API
ItemEntryData Methods
ItemEntryData Class See Also Send Feedback

The ItemEntryData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStream | Gets the stream holder.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemEntryData Class
Sitecore.Install.Items Namespace


GetStream Method

[image]

Sitecore 6.4.1 API
ItemEntryData..::..GetStream Method
ItemEntryData Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IStreamHolder GetStream()
Visual Basic
Public Function GetStream As IStreamHolder
Visual C++
public:
virtual IStreamHolder^ GetStream() sealed

Return Value

The stream holder.

Implements

IEntryData..::..GetStream()()()()

See Also

ItemEntryData Class
Sitecore.Install.Items Namespace


ItemEntryData Properties

[image] [image]

Sitecore 6.4.1 API
ItemEntryData Properties
ItemEntryData Class See Also Send Feedback

The ItemEntryData type exposes the following members.

Properties

 | Name | Description
Public property | Key | Gets the key.

See Also

ItemEntryData Class
Sitecore.Install.Items Namespace


Key Property

[image]

Sitecore 6.4.1 API
ItemEntryData..::..Key Property
ItemEntryData Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Key { get; }
Visual Basic
Public ReadOnly Property Key As String
    Get
Visual C++
public:
virtual property String^ Key {
    String^ get () sealed;
}

Field Value

The key.

Implements

IEntryData..::..Key

See Also

ItemEntryData Class
Sitecore.Install.Items Namespace


ItemFieldsProperties Class

[image]

Sitecore 6.4.1 API
ItemFieldsProperties Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemFieldsProperties
Visual Basic
Public Class ItemFieldsProperties
Visual C++
public ref class ItemFieldsProperties

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Items..::..ItemFieldsProperties

See Also

ItemFieldsProperties Members
Sitecore.Install.Items Namespace


ItemFieldsProperties Members

[image] [image]

Sitecore 6.4.1 API
ItemFieldsProperties Members
ItemFieldsProperties Class Methods Properties See Also Send Feedback

The ItemFieldsProperties type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFieldsProperties | Performs serialization of fields with sharing type.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetSharingType | Gets sharing type of the template
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | TryParse | Try to parse string in order to get ItemFieldsProperties object.

Properties

 | Name | Description
Public property | Properties | Gets Properties.

See Also

ItemFieldsProperties Class
Sitecore.Install.Items Namespace


ItemFieldsProperties Methods

[image] [image]

Sitecore 6.4.1 API
ItemFieldsProperties Methods
ItemFieldsProperties Class See Also Send Feedback

The ItemFieldsProperties type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFieldsProperties | Performs serialization of fields with sharing type.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetSharingType | Gets sharing type of the template
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | TryParse | Try to parse string in order to get ItemFieldsProperties object.

See Also

ItemFieldsProperties Class
Sitecore.Install.Items Namespace


GetFieldsProperties Method

[image]

Sitecore 6.4.1 API
ItemFieldsProperties..::..GetFieldsProperties Method
ItemFieldsProperties Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetFieldsProperties(
    Item item
)
Visual Basic
Public Shared Function GetFieldsProperties ( _
    item As Item _
) As String
Visual C++
public:
static String^ GetFieldsProperties(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item to serialize

Return Value

String representation of object.

See Also

ItemFieldsProperties Class
Sitecore.Install.Items Namespace


GetSharingType Method

[image]

Sitecore 6.4.1 API
ItemFieldsProperties..::..GetSharingType Method
ItemFieldsProperties Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static DefaultFieldSharing..::..SharingType GetSharingType(
    Field field
)
Visual Basic
Public Shared Function GetSharingType ( _
    field As Field _
) As DefaultFieldSharing..::..SharingType
Visual C++
public:
static DefaultFieldSharing..::..SharingType GetSharingType(
    Field^ field
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
TemplateField object

Return Value

DefaultFieldSharing.SharingType enum

See Also

ItemFieldsProperties Class
Sitecore.Install.Items Namespace


TryParse Method

[image]

Sitecore 6.4.1 API
ItemFieldsProperties..::..TryParse Method
ItemFieldsProperties Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool TryParse(
    string data,
    out ItemFieldsProperties itemFieldsProperties
)
Visual Basic
Public Shared Function TryParse ( _
    data As String, _
    <OutAttribute> ByRef itemFieldsProperties As ItemFieldsProperties _
) As Boolean
Visual C++
public:
static bool TryParse(
    String^ data,
    [OutAttribute] ItemFieldsProperties^% itemFieldsProperties
)

Parameters

data
Type: System..::..String
The data.
itemFieldsProperties
Type: Sitecore.Install.Items..::..ItemFieldsProperties %
The item fields properties.

Return Value

true if parse was successful; false otherwise

See Also

ItemFieldsProperties Class
Sitecore.Install.Items Namespace


ItemFieldsProperties Properties

[image] [image]

Sitecore 6.4.1 API
ItemFieldsProperties Properties
ItemFieldsProperties Class See Also Send Feedback

The ItemFieldsProperties type exposes the following members.

Properties

 | Name | Description
Public property | Properties | Gets Properties.

See Also

ItemFieldsProperties Class
Sitecore.Install.Items Namespace


Properties Property

[image]

Sitecore 6.4.1 API
ItemFieldsProperties..::..Properties Property
ItemFieldsProperties Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Dictionary<ID, DefaultFieldSharing..::..SharingType> Properties { get; }
Visual Basic
Public ReadOnly Property Properties As Dictionary(Of ID, DefaultFieldSharing..::..SharingType)
    Get
Visual C++
public:
property Dictionary<ID^, DefaultFieldSharing..::..SharingType>^ Properties {
    Dictionary<ID^, DefaultFieldSharing..::..SharingType>^ get ();
}

Field Value

The properties.

See Also

ItemFieldsProperties Class
Sitecore.Install.Items Namespace


ItemInstaller Class

[image]

Sitecore 6.4.1 API
ItemInstaller Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemInstaller : AdvancedBaseSink<PackageEntry, ItemInstallerContext>
Visual Basic
Public Class ItemInstaller _
    Inherits AdvancedBaseSink(Of PackageEntry, ItemInstallerContext)
Visual C++
public ref class ItemInstaller : public AdvancedBaseSink<PackageEntry^, ItemInstallerContext^>

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..BaseSink <(Of <(<' T >)>)>
Sitecore.Install.Framework..::..AdvancedBaseSink <(Of <(<' PackageEntry, ItemInstallerContext >)>)>
Sitecore.Install.Items..::..ItemInstaller

See Also

ItemInstaller Members
Sitecore.Install.Items Namespace


ItemInstaller Members

[image] [image]

Sitecore 6.4.1 API
ItemInstaller Members
ItemInstaller Class Constructors Methods Fields Properties See Also Send Feedback

The ItemInstaller type exposes the following members.

Constructors

 | Name | Description
Public method | ItemInstaller | Initializes a new instance of the ItemInstaller class.

Methods

 | Name | Description
Protected method | AssertInit | Asserts the init. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Protected method | CreateContext | Creates the context. (Overrides AdvancedBaseSink<(Of <(<'T, ContextType>)>)>..::..CreateContext()()()().)
 | CreateLightweightItem | Creates the lightweight item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finishes the sink. (Overrides BaseSink<(Of <(<'T>)>)>..::..Finish()()()().)
Public method | Flush | Flushes the sink (Overrides BaseSink<(Of <(<'T>)>)>..::..Flush()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetItemInstallOptions | Gets the item install options.
 | GetPrefix | Gets the prefix.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this instance. (Inherited from AdvancedBaseSink<(Of <(<'T, ContextType>)>)>.)
Protected method | InstallItem | Installs the item.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put(T) | Puts the specified entry. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Put(PackageEntry) | If an entry contains an item than that item will be added to the installation queue.
 | RemoveVersions | Removes the versions.
Protected method | SetupContext | Setups the context. (Inherited from AdvancedBaseSink<(Of <(<'T, ContextType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _processingContext | (Inherited from BaseSink<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Context | Gets the context. (Inherited from AdvancedBaseSink<(Of <(<'T, ContextType>)>)>.)
Public property | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | PendingDeleteItems | Gets the pended to be deleted items.
Public property | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

ItemInstaller Class
Sitecore.Install.Items Namespace


ItemInstaller Constructor

[image]

Sitecore 6.4.1 API
ItemInstaller Constructor
ItemInstaller Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemInstaller(
    IProcessingContext context
)
Visual Basic
Public Sub New ( _
    context As IProcessingContext _
)
Visual C++
public:
ItemInstaller(
    IProcessingContext^ context
)

Parameters

context
Type: Sitecore.Install.Framework..::..IProcessingContext
The context.

See Also

ItemInstaller Class
Sitecore.Install.Items Namespace


ItemInstaller Fields

[image] [image]

Sitecore 6.4.1 API
ItemInstaller Fields
ItemInstaller Class See Also Send Feedback

The ItemInstaller type exposes the following members.

Fields

 | Name | Description
Protected field | _processingContext | (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

ItemInstaller Class
Sitecore.Install.Items Namespace


ItemInstaller Methods

[image] [image]

Sitecore 6.4.1 API
ItemInstaller Methods
ItemInstaller Class See Also Send Feedback

The ItemInstaller type exposes the following members.

Methods

 | Name | Description
Protected method | AssertInit | Asserts the init. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Protected method | CreateContext | Creates the context. (Overrides AdvancedBaseSink<(Of <(<'T, ContextType>)>)>..::..CreateContext()()()().)
 | CreateLightweightItem | Creates the lightweight item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finishes the sink. (Overrides BaseSink<(Of <(<'T>)>)>..::..Finish()()()().)
Public method | Flush | Flushes the sink (Overrides BaseSink<(Of <(<'T>)>)>..::..Flush()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetItemInstallOptions | Gets the item install options.
 | GetPrefix | Gets the prefix.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this instance. (Inherited from AdvancedBaseSink<(Of <(<'T, ContextType>)>)>.)
Protected method | InstallItem | Installs the item.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put(T) | Puts the specified entry. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Put(PackageEntry) | If an entry contains an item than that item will be added to the installation queue.
 | RemoveVersions | Removes the versions.
Protected method | SetupContext | Setups the context. (Inherited from AdvancedBaseSink<(Of <(<'T, ContextType>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemInstaller Class
Sitecore.Install.Items Namespace


CreateContext Method

[image]

Sitecore 6.4.1 API
ItemInstaller..::..CreateContext Method
ItemInstaller Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ItemInstallerContext CreateContext()
Visual Basic
Protected Overrides Function CreateContext As ItemInstallerContext
Visual C++
protected:
virtual ItemInstallerContext^ CreateContext() override

Return Value

The context.

See Also

ItemInstaller Class
Sitecore.Install.Items Namespace


CreateLightweightItem Method

[image]

Sitecore 6.4.1 API
ItemInstaller..::..CreateLightweightItem Method
ItemInstaller Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected static Item CreateLightweightItem(
    ItemReference item,
    XmlVersionParser parser
)
Visual Basic
Protected Shared Function CreateLightweightItem ( _
    item As ItemReference, _
    parser As XmlVersionParser _
) As Item
Visual C++
protected:
static Item^ CreateLightweightItem(
    ItemReference^ item,
    XmlVersionParser^ parser
)

Parameters

item
Type: Sitecore.Install.Items..::..ItemReference
The item.
parser
Type: Sitecore.Install.Utils..::..XmlVersionParser
The parser.

Return Value

The lightweight item.

See Also

ItemInstaller Class
Sitecore.Install.Items Namespace


Finish Method

[image]

Sitecore 6.4.1 API
ItemInstaller..::..Finish Method
ItemInstaller Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Finish()
Visual Basic
Public Overrides Sub Finish
Visual C++
public:
virtual void Finish() override

Implements

ISink<(Of <(<'T>)>)>..::..Finish()()()()

See Also

ItemInstaller Class
Sitecore.Install.Items Namespace


Flush Method

[image]

Sitecore 6.4.1 API
ItemInstaller..::..Flush Method
ItemInstaller Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Flush()
Visual Basic
Public Overrides Sub Flush
Visual C++
public:
virtual void Flush() override

Implements

ISink<(Of <(<'T>)>)>..::..Flush()()()()

See Also

ItemInstaller Class
Sitecore.Install.Items Namespace


GetItemInstallOptions Method

[image]

Sitecore 6.4.1 API
ItemInstaller..::..GetItemInstallOptions Method
ItemInstaller Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual BehaviourOptions GetItemInstallOptions(
    PackageEntry entry,
    ItemInstallerContext context,
    string prefix
)
Visual Basic
Protected Overridable Function GetItemInstallOptions ( _
    entry As PackageEntry, _
    context As ItemInstallerContext, _
    prefix As String _
) As BehaviourOptions
Visual C++
protected:
virtual BehaviourOptions^ GetItemInstallOptions(
    PackageEntry^ entry,
    ItemInstallerContext^ context,
    String^ prefix
)

Parameters

entry
Type: Sitecore.Install.Framework..::..PackageEntry
The entry.
context
Type: Sitecore.Install.Items..::..ItemInstallerContext
The context.
prefix
Type: System..::..String
The prefix.

Return Value

The item install options.

See Also

ItemInstaller Class
Sitecore.Install.Items Namespace


GetPrefix Method

[image]

Sitecore 6.4.1 API
ItemInstaller..::..GetPrefix Method
ItemInstaller Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected static string GetPrefix(
    ItemInfo installedItem,
    ItemInfo newItem
)
Visual Basic
Protected Shared Function GetPrefix ( _
    installedItem As ItemInfo, _
    newItem As ItemInfo _
) As String
Visual C++
protected:
static String^ GetPrefix(
    ItemInfo^ installedItem,
    ItemInfo^ newItem
)

Parameters

installedItem
Type: Sitecore.Install.Utils..::..ItemInfo
The installed item.
newItem
Type: Sitecore.Install.Utils..::..ItemInfo
The new item.

Return Value

The prefix.

See Also

ItemInstaller Class
Sitecore.Install.Items Namespace


Put Method

[image] [image]

Sitecore 6.4.1 API
ItemInstaller..::..Put Method
ItemInstaller Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Put(T) | Puts the specified entry. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Put(PackageEntry) | If an entry contains an item than that item will be added to the installation queue.

See Also

ItemInstaller Class
ItemInstaller Members
Sitecore.Install.Items Namespace


Put Method (PackageEntry)

[image]

Sitecore 6.4.1 API
ItemInstaller..::..Put Method (PackageEntry)
ItemInstaller Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Put(
    PackageEntry entry
)
Visual Basic
Public Overridable Sub Put ( _
    entry As PackageEntry _
)
Visual C++
public:
virtual void Put(
    PackageEntry^ entry
)

Parameters

entry
Type: Sitecore.Install.Framework..::..PackageEntry
The entry.

See Also

ItemInstaller Class
Put Overload
Sitecore.Install.Items Namespace


RemoveVersions Method

[image]

Sitecore 6.4.1 API
ItemInstaller..::..RemoveVersions Method
ItemInstaller Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected static void RemoveVersions(
    Item targetItem,
    bool removeSharedData
)
Visual Basic
Protected Shared Sub RemoveVersions ( _
    targetItem As Item, _
    removeSharedData As Boolean _
)
Visual C++
protected:
static void RemoveVersions(
    Item^ targetItem,
    bool removeSharedData
)

Parameters

targetItem
Type: Sitecore.Data.Items..::..Item
The target item.
removeSharedData
Type: System..::..Boolean
if set to true the shared data will be removed.

See Also

ItemInstaller Class
Sitecore.Install.Items Namespace


ItemInstaller Properties

[image] [image]

Sitecore 6.4.1 API
ItemInstaller Properties
ItemInstaller Class See Also Send Feedback

The ItemInstaller type exposes the following members.

Properties

 | Name | Description
Public property | Context | Gets the context. (Inherited from AdvancedBaseSink<(Of <(<'T, ContextType>)>)>.)
Public property | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | PendingDeleteItems | Gets the pended to be deleted items.
Public property | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

ItemInstaller Class
Sitecore.Install.Items Namespace


PendingDeleteItems Property

[image]

Sitecore 6.4.1 API
ItemInstaller..::..PendingDeleteItems Property
ItemInstaller Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IList<KeyValuePair<string, string>> PendingDeleteItems { get; }
Visual Basic
Public ReadOnly Property PendingDeleteItems As IList(Of KeyValuePair(Of String, String))
    Get
Visual C++
public:
property IList<KeyValuePair<String^, String^>>^ PendingDeleteItems {
    IList<KeyValuePair<String^, String^>>^ get ();
}

Field Value

The pending delete items.

See Also

ItemInstaller Class
Sitecore.Install.Items Namespace


ItemInstaller.VersionInstaller Class

[image]

Sitecore 6.4.1 API
ItemInstaller..::..VersionInstaller Class
ItemInstaller Class Members See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class VersionInstaller
Visual Basic
Public NotInheritable Class VersionInstaller
Visual C++
public ref class VersionInstaller abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Items..::..ItemInstaller..::..VersionInstaller

See Also

ItemInstaller..::..VersionInstaller Members
Sitecore.Install.Items Namespace


ItemInstaller.VersionInstaller Members

[image] [image]

Sitecore 6.4.1 API
ItemInstaller..::..VersionInstaller Members
ItemInstaller..::..VersionInstaller Class Methods See Also Send Feedback

Item installer

The ItemInstaller..::..VersionInstaller type exposes the following members.

Methods

Name | Description
ParseItemVersion | Parses the item version.
PasteVersion | Pastes the version.

See Also

ItemInstaller..::..VersionInstaller Class
Sitecore.Install.Items Namespace


ItemInstaller.VersionInstaller Methods

[image] [image]

Sitecore 6.4.1 API
ItemInstaller..::..VersionInstaller Methods
ItemInstaller..::..VersionInstaller Class See Also Send Feedback

The ItemInstaller..::..VersionInstaller type exposes the following members.

Methods

Name | Description
ParseItemVersion | Parses the item version.
PasteVersion | Pastes the version.

See Also

ItemInstaller..::..VersionInstaller Class
Sitecore.Install.Items Namespace


ParseItemVersion Method

[image]

Sitecore 6.4.1 API
ItemInstaller..::..VersionInstaller..::..ParseItemVersion Method
ItemInstaller..::..VersionInstaller Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item ParseItemVersion(
    XmlNode versionNode,
    Item target,
    VersionInstallMode mode
)
Visual Basic
Public Shared Function ParseItemVersion ( _
    versionNode As XmlNode, _
    target As Item, _
    mode As VersionInstallMode _
) As Item
Visual C++
public:
static Item^ ParseItemVersion(
    XmlNode^ versionNode,
    Item^ target,
    VersionInstallMode mode
)

Parameters

versionNode
Type: System.Xml..::..XmlNode
The version node.
target
Type: Sitecore.Data.Items..::..Item
The target item.
mode
Type: Sitecore.Install.Items..::..VersionInstallMode
The version install mode.

Return Value

The item version.

See Also

ItemInstaller..::..VersionInstaller Class
Sitecore.Install.Items Namespace


ItemInstallerContext Class

[image]

Sitecore 6.4.1 API
ItemInstallerContext Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemInstallerContext
Visual Basic
Public Class ItemInstallerContext
Visual C++
public ref class ItemInstallerContext

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Items..::..ItemInstallerContext

See Also

ItemInstallerContext Members
Sitecore.Install.Items Namespace


ItemInstallerContext Members

[image] [image]

Sitecore 6.4.1 API
ItemInstallerContext Members
ItemInstallerContext Class Constructors Methods Fields See Also Send Feedback

The ItemInstallerContext type exposes the following members.

Constructors

 | Name | Description
Public method | ItemInstallerContext | Initializes a new instance of the ItemInstallerContext class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInstallOptions | Gets the install options.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplyToAll | Determines whether behavior should be applied for all entries whit the specified prefix
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | ApplyToAll |
Public field | CurrentItemID |
Public field | Events |
Public field | VersionInstallMode |

See Also

ItemInstallerContext Class
Sitecore.Install.Items Namespace


ItemInstallerContext Constructor

[image]

Sitecore 6.4.1 API
ItemInstallerContext Constructor
ItemInstallerContext Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemInstallerContext(
    IItemInstallerEvents events
)
Visual Basic
Public Sub New ( _
    events As IItemInstallerEvents _
)
Visual C++
public:
ItemInstallerContext(
    IItemInstallerEvents^ events
)

Parameters

events
Type: Sitecore.Install.Items..::..IItemInstallerEvents
The events.

See Also

ItemInstallerContext Class
Sitecore.Install.Items Namespace


ItemInstallerContext Fields

[image] [image]

Sitecore 6.4.1 API
ItemInstallerContext Fields
ItemInstallerContext Class See Also Send Feedback

The ItemInstallerContext type exposes the following members.

Fields

 | Name | Description
Public field | ApplyToAll |
Public field | CurrentItemID |
Public field | Events |
Public field | VersionInstallMode |

See Also

ItemInstallerContext Class
Sitecore.Install.Items Namespace


ApplyToAll Field

[image]

Sitecore 6.4.1 API
ItemInstallerContext..::..ApplyToAll Field
ItemInstallerContext Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Dictionary<string, bool> ApplyToAll
Visual Basic
Public ApplyToAll As Dictionary(Of String, Boolean)
Visual C++
public:
Dictionary<String^, bool>^ ApplyToAll

See Also

ItemInstallerContext Class
Sitecore.Install.Items Namespace


CurrentItemID Field

[image]

Sitecore 6.4.1 API
ItemInstallerContext..::..CurrentItemID Field
ItemInstallerContext Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string CurrentItemID
Visual Basic
Public CurrentItemID As String
Visual C++
public:
String^ CurrentItemID

See Also

ItemInstallerContext Class
Sitecore.Install.Items Namespace


Events Field

[image]

Sitecore 6.4.1 API
ItemInstallerContext..::..Events Field
ItemInstallerContext Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IItemInstallerEvents Events
Visual Basic
Public Events As IItemInstallerEvents
Visual C++
public:
IItemInstallerEvents^ Events

See Also

ItemInstallerContext Class
Sitecore.Install.Items Namespace


VersionInstallMode Field

[image]

Sitecore 6.4.1 API
ItemInstallerContext..::..VersionInstallMode Field
ItemInstallerContext Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public VersionInstallMode VersionInstallMode
Visual Basic
Public VersionInstallMode As VersionInstallMode
Visual C++
public:
VersionInstallMode VersionInstallMode

See Also

ItemInstallerContext Class
Sitecore.Install.Items Namespace


ItemInstallerContext Methods

[image] [image]

Sitecore 6.4.1 API
ItemInstallerContext Methods
ItemInstallerContext Class See Also Send Feedback

The ItemInstallerContext type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInstallOptions | Gets the install options.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplyToAll | Determines whether behavior should be applied for all entries whit the specified prefix
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemInstallerContext Class
Sitecore.Install.Items Namespace


IsApplyToAll Method

[image]

Sitecore 6.4.1 API
ItemInstallerContext..::..IsApplyToAll Method
ItemInstallerContext Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsApplyToAll(
    string prefix
)
Visual Basic
Public Function IsApplyToAll ( _
    prefix As String _
) As Boolean
Visual C++
public:
bool IsApplyToAll(
    String^ prefix
)

Parameters

prefix
Type: System..::..String
The prefix.

Return Value

[Missing <returns> documentation for "M:Sitecore.Install.Items.ItemInstallerContext.IsApplyToAll(System.String)"]

See Also

ItemInstallerContext Class
Sitecore.Install.Items Namespace


ItemKeyProvider Class

[image]

Sitecore 6.4.1 API
ItemKeyProvider Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemKeyProvider : ISortingKeyProvider
Visual Basic
Public Class ItemKeyProvider _
    Implements ISortingKeyProvider
Visual C++
public ref class ItemKeyProvider : ISortingKeyProvider

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Items..::..ItemKeyProvider

See Also

ItemKeyProvider Members
Sitecore.Install.Items Namespace


ItemKeyProvider Members

[image] [image]

Sitecore 6.4.1 API
ItemKeyProvider Members
ItemKeyProvider Class Constructors Methods See Also Send Feedback

The ItemKeyProvider type exposes the following members.

Constructors

 | Name | Description
Public method | ItemKeyProvider | Initializes a new instance of the ItemKeyProvider class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKey | Gets the key.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemKeyProvider Class
Sitecore.Install.Items Namespace


ItemKeyProvider Constructor

[image]

Sitecore 6.4.1 API
ItemKeyProvider Constructor
ItemKeyProvider Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemKeyProvider()
Visual Basic
Public Sub New
Visual C++
public:
ItemKeyProvider()

See Also

ItemKeyProvider Class
Sitecore.Install.Items Namespace


ItemKeyProvider Methods

[image] [image]

Sitecore 6.4.1 API
ItemKeyProvider Methods
ItemKeyProvider Class See Also Send Feedback

The ItemKeyProvider type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKey | Gets the key.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemKeyProvider Class
Sitecore.Install.Items Namespace


GetKey Method

[image]

Sitecore 6.4.1 API
ItemKeyProvider..::..GetKey Method
ItemKeyProvider Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SortingKey GetKey(
    string key
)
Visual Basic
Public Function GetKey ( _
    key As String _
) As SortingKey
Visual C++
public:
virtual SortingKey^ GetKey(
    String^ key
) sealed

Parameters

key
Type: System..::..String
The key.

Return Value

The key.

Implements

ISortingKeyProvider..::..GetKey(String)

See Also

ItemKeyProvider Class
Sitecore.Install.Items Namespace


ItemKeyUtils Class

[image]

Sitecore 6.4.1 API
ItemKeyUtils Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class ItemKeyUtils
Visual Basic
Public NotInheritable Class ItemKeyUtils
Visual C++
public ref class ItemKeyUtils abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Items..::..ItemKeyUtils

See Also

ItemKeyUtils Members
Sitecore.Install.Items Namespace


ItemKeyUtils Members

[image] [image]

Sitecore 6.4.1 API
ItemKeyUtils Members
ItemKeyUtils Class Methods See Also Send Feedback

The ItemKeyUtils type exposes the following members.

Methods

Name | Description
GetKey(Item) | Gets the key.
GetKey(ItemReference) | Gets the key.
GetReference | Gets the reference.
Resolve | Gets an item by the reference.

See Also

ItemKeyUtils Class
Sitecore.Install.Items Namespace


ItemKeyUtils Methods

[image] [image]

Sitecore 6.4.1 API
ItemKeyUtils Methods
ItemKeyUtils Class See Also Send Feedback

The ItemKeyUtils type exposes the following members.

Methods

Name | Description
GetKey(Item) | Gets the key.
GetKey(ItemReference) | Gets the key.
GetReference | Gets the reference.
Resolve | Gets an item by the reference.

See Also

ItemKeyUtils Class
Sitecore.Install.Items Namespace


GetKey Method

[image] [image]

Sitecore 6.4.1 API
ItemKeyUtils..::..GetKey Method
ItemKeyUtils Class See Also Send Feedback

Overload List

Name | Description
GetKey(Item) | Gets the key.
GetKey(ItemReference) | Gets the key.

See Also

ItemKeyUtils Class
ItemKeyUtils Members
Sitecore.Install.Items Namespace


GetKey Method (Item)

[image]

Sitecore 6.4.1 API
ItemKeyUtils..::..GetKey Method (Item)
ItemKeyUtils Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetKey(
    Item item
)
Visual Basic
Public Shared Function GetKey ( _
    item As Item _
) As String
Visual C++
public:
static String^ GetKey(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

The key.

See Also

ItemKeyUtils Class
GetKey Overload
Sitecore.Install.Items Namespace


GetKey Method (ItemReference)

[image]

Sitecore 6.4.1 API
ItemKeyUtils..::..GetKey Method (ItemReference)
ItemKeyUtils Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetKey(
    ItemReference reference
)
Visual Basic
Public Shared Function GetKey ( _
    reference As ItemReference _
) As String
Visual C++
public:
static String^ GetKey(
    ItemReference^ reference
)

Parameters

reference
Type: Sitecore.Install.Items..::..ItemReference
The reference.

Return Value

The key.

See Also

ItemKeyUtils Class
GetKey Overload
Sitecore.Install.Items Namespace


GetReference Method

[image]

Sitecore 6.4.1 API
ItemKeyUtils..::..GetReference Method
ItemKeyUtils Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ItemReference GetReference(
    string key
)
Visual Basic
Public Shared Function GetReference ( _
    key As String _
) As ItemReference
Visual C++
public:
static ItemReference^ GetReference(
    String^ key
)

Parameters

key
Type: System..::..String
The key.

Return Value

The reference.

See Also

ItemKeyUtils Class
Sitecore.Install.Items Namespace


Resolve Method

[image]

Sitecore 6.4.1 API
ItemKeyUtils..::..Resolve Method
ItemKeyUtils Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Item Resolve(
    string key
)
Visual Basic
Public Shared Function Resolve ( _
    key As String _
) As Item
Visual C++
public:
static Item^ Resolve(
    String^ key
)

Parameters

key
Type: System..::..String
The reference.

Return Value

The resolved item.

See Also

ItemKeyUtils Class
Sitecore.Install.Items Namespace


ItemReference Class

[image]

Sitecore 6.4.1 API
ItemReference Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class ItemReference
Visual Basic
<SerializableAttribute> _
Public Class ItemReference
Visual C++
[SerializableAttribute]
public ref class ItemReference

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Items..::..ItemReference

See Also

ItemReference Members
Sitecore.Install.Items Namespace


ItemReference Members

[image] [image]

Sitecore 6.4.1 API
ItemReference Members
ItemReference Class Constructors Methods Properties See Also Send Feedback

The ItemReference type exposes the following members.

Constructors

 | Name | Description
Public method | ItemReference(Item) | Initializes a new instance of the ItemReference class.
Public method | ItemReference(ItemUri, Boolean) | Initializes a new instance of the ItemReference class.
Public method | ItemReference(String, String, ID, Language, Version) | Initializes a new instance of the ItemReference class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItem | Gets the item.
Public method | GetItems | Gets the items.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Parses the specified reference.
Public method | Reduce | Gets the reduced reference
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Database | Gets the database.
Public property | DatabaseName | Gets or sets the name of the database.
Public property | ID | Gets or sets the ID.
Public property | IsLanguageInvariant | Gets a value indicating whether this instance is language invariant.
Public property | IsStrong | Gets a value indicating whether this instance is strong.
Public property | IsVersionInvariant | Gets a value indicating whether this instance is version invariant.
Public property | Language | Gets or sets the language.
Public property | Path | Gets or sets the path.
Public property | Version | Gets or sets the version.

See Also

ItemReference Class
Sitecore.Install.Items Namespace


ItemReference Constructor

[image] [image]

Sitecore 6.4.1 API
ItemReference Constructor
ItemReference Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ItemReference(Item) | Initializes a new instance of the ItemReference class.
Public method | ItemReference(ItemUri, Boolean) | Initializes a new instance of the ItemReference class.
Public method | ItemReference(String, String, ID, Language, Version) | Initializes a new instance of the ItemReference class.

See Also

ItemReference Class
ItemReference Members
Sitecore.Install.Items Namespace


ItemReference Constructor (Item)

[image]

Sitecore 6.4.1 API
ItemReference Constructor (Item)
ItemReference Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemReference(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
ItemReference(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

ItemReference Class
ItemReference Overload
Sitecore.Install.Items Namespace


ItemReference Constructor (ItemUri, Boolean)

[image]

Sitecore 6.4.1 API
ItemReference Constructor (ItemUri, Boolean)
ItemReference Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemReference(
    ItemUri uri,
    bool exact
)
Visual Basic
Public Sub New ( _
    uri As ItemUri, _
    exact As Boolean _
)
Visual C++
public:
ItemReference(
    ItemUri^ uri,
    bool exact
)

Parameters

uri
Type: Sitecore.Data..::..ItemUri
The URI.
exact
Type: System..::..Boolean
if set to true this instance is exact.

See Also

ItemReference Class
ItemReference Overload
Sitecore.Install.Items Namespace


ItemReference Constructor (String, String, ID, Language, Version)

[image]

Sitecore 6.4.1 API
ItemReference Constructor (String, String, ID, Language, Version)
ItemReference Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemReference(
    string database,
    string path,
    ID id,
    Language language,
    Version version
)
Visual Basic
Public Sub New ( _
    database As String, _
    path As String, _
    id As ID, _
    language As Language, _
    version As Version _
)
Visual C++
public:
ItemReference(
    String^ database,
    String^ path,
    ID^ id,
    Language^ language,
    Version^ version
)

Parameters

database
Type: System..::..String
The database.
path
Type: System..::..String
The path.
id
Type: Sitecore.Data..::..ID
The id.
language
Type: Sitecore.Globalization..::..Language
The language.
version
Type: Sitecore.Data..::..Version
The version.

See Also

ItemReference Class
ItemReference Overload
Sitecore.Install.Items Namespace


ItemReference Methods

[image] [image]

Sitecore 6.4.1 API
ItemReference Methods
ItemReference Class See Also Send Feedback

The ItemReference type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItem | Gets the item.
Public method | GetItems | Gets the items.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Parses the specified reference.
Public method | Reduce | Gets the reduced reference
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ItemReference Class
Sitecore.Install.Items Namespace


GetItem Method

[image]

Sitecore 6.4.1 API
ItemReference..::..GetItem Method
ItemReference Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetItem()
Visual Basic
Public Function GetItem As Item
Visual C++
public:
Item^ GetItem()

Return Value

The item.

See Also

ItemReference Class
Sitecore.Install.Items Namespace


GetItems Method

[image]

Sitecore 6.4.1 API
ItemReference..::..GetItems Method
ItemReference Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IList<Item> GetItems()
Visual Basic
Public Function GetItems As IList(Of Item)
Visual C++
public:
IList<Item^>^ GetItems()

Return Value

The items.

See Also

ItemReference Class
Sitecore.Install.Items Namespace


Parse Method

[image]

Sitecore 6.4.1 API
ItemReference..::..Parse Method
ItemReference Class Example See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ItemReference Parse(
    string reference
)
Visual Basic
Public Shared Function Parse ( _
    reference As String _
) As ItemReference
Visual C++
public:
static ItemReference^ Parse(
    String^ reference
)

Parameters

reference
Type: System..::..String
The reference.

Return Value

The item refecence.

Examples

ItemReference.Parse("/master/sitecore/content/home/{}/en/1");

See Also

ItemReference Class
Sitecore.Install.Items Namespace


Reduce Method

[image]

Sitecore 6.4.1 API
ItemReference..::..Reduce Method
ItemReference Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemReference Reduce()
Visual Basic
Public Function Reduce As ItemReference
Visual C++
public:
ItemReference^ Reduce()

Return Value

[Missing <returns> documentation for "M:Sitecore.Install.Items.ItemReference.Reduce"]

See Also

ItemReference Class
Sitecore.Install.Items Namespace


ToString Method

[image]

Sitecore 6.4.1 API
ItemReference..::..ToString Method
ItemReference Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

ItemReference Class
Sitecore.Install.Items Namespace


ItemReference Properties

[image] [image]

Sitecore 6.4.1 API
ItemReference Properties
ItemReference Class See Also Send Feedback

The ItemReference type exposes the following members.

Properties

 | Name | Description
Public property | Database | Gets the database.
Public property | DatabaseName | Gets or sets the name of the database.
Public property | ID | Gets or sets the ID.
Public property | IsLanguageInvariant | Gets a value indicating whether this instance is language invariant.
Public property | IsStrong | Gets a value indicating whether this instance is strong.
Public property | IsVersionInvariant | Gets a value indicating whether this instance is version invariant.
Public property | Language | Gets or sets the language.
Public property | Path | Gets or sets the path.
Public property | Version | Gets or sets the version.

See Also

ItemReference Class
Sitecore.Install.Items Namespace


DatabaseName Property

[image]

Sitecore 6.4.1 API
ItemReference..::..DatabaseName Property
ItemReference Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string DatabaseName { get; set; }
Visual Basic
Public Property DatabaseName As String
    Get
    Set
Visual C++
public:
property String^ DatabaseName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the database.

See Also

ItemReference Class
Sitecore.Install.Items Namespace


ID Property

[image]

Sitecore 6.4.1 API
ItemReference..::..ID Property
ItemReference Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ID { get; set; }
Visual Basic
Public Property ID As ID
    Get
    Set
Visual C++
public:
property ID^ ID {
    ID^ get ();
    void set (ID^ value);
}

Field Value

The ID.

See Also

ItemReference Class
Sitecore.Install.Items Namespace


IsLanguageInvariant Property

[image]

Sitecore 6.4.1 API
ItemReference..::..IsLanguageInvariant Property
ItemReference Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsLanguageInvariant { get; }
Visual Basic
Public ReadOnly Property IsLanguageInvariant As Boolean
    Get
Visual C++
public:
property bool IsLanguageInvariant {
    bool get ();
}

Field Value

true if this instance is language invariant; otherwise, false.

See Also

ItemReference Class
Sitecore.Install.Items Namespace


IsStrong Property

[image]

Sitecore 6.4.1 API
ItemReference..::..IsStrong Property
ItemReference Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsStrong { get; }
Visual Basic
Public ReadOnly Property IsStrong As Boolean
    Get
Visual C++
public:
property bool IsStrong {
    bool get ();
}

Field Value

true if this instance is strong; otherwise, false.

See Also

ItemReference Class
Sitecore.Install.Items Namespace


IsVersionInvariant Property

[image]

Sitecore 6.4.1 API
ItemReference..::..IsVersionInvariant Property
ItemReference Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsVersionInvariant { get; }
Visual Basic
Public ReadOnly Property IsVersionInvariant As Boolean
    Get
Visual C++
public:
property bool IsVersionInvariant {
    bool get ();
}

Field Value

true if this instance is version invariant; otherwise, false.

See Also

ItemReference Class
Sitecore.Install.Items Namespace


Language Property

[image]

Sitecore 6.4.1 API
ItemReference..::..Language Property
ItemReference Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Language Language { get; set; }
Visual Basic
Public Property Language As Language
    Get
    Set
Visual C++
public:
property Language^ Language {
    Language^ get ();
    void set (Language^ value);
}

Field Value

The language.

See Also

ItemReference Class
Sitecore.Install.Items Namespace


Path Property

[image]

Sitecore 6.4.1 API
ItemReference..::..Path Property
ItemReference Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Path { get; set; }
Visual Basic
Public Property Path As String
    Get
    Set
Visual C++
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}

Field Value

The path.

See Also

ItemReference Class
Sitecore.Install.Items Namespace


Version Property

[image]

Sitecore 6.4.1 API
ItemReference..::..Version Property
ItemReference Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Version Version { get; set; }
Visual Basic
Public Property Version As Version
    Get
    Set
Visual C++
public:
property Version^ Version {
    Version^ get ();
    void set (Version^ value);
}

Field Value

The version.

See Also

ItemReference Class
Sitecore.Install.Items Namespace


ItemSource Class

[image]

Sitecore 6.4.1 API
ItemSource Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemSource : BaseSource<Item>
Visual Basic
Public Class ItemSource _
    Inherits BaseSource(Of Item)
Visual C++
public ref class ItemSource : public BaseSource<Item^>

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..BaseSource <(Of <(<' Item >)>)>
Sitecore.Install.Items..::..ItemSource

See Also

ItemSource Members
Sitecore.Install.Items Namespace


ItemSource Members

[image] [image]

Sitecore 6.4.1 API
ItemSource Members
ItemSource Class Constructors Methods Properties See Also Send Feedback

The ItemSource type exposes the following members.

Constructors

 | Name | Description
Public method | ItemSource | Initializes a new instance of the ItemSource class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InternalPopulate | Populates the specified sink with the item and its subitems) (Overrides BaseSource<(Of <(<'T>)>)>..::..InternalPopulate(ISink<(Of <<'(T>)>>)).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Populates this sourse from the specified sink. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Converter | Gets or sets the converter. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Database | Gets or sets the database.
Public property | Exclude | Gets the exclude filters. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Include | Gets the include filters. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Name | Gets or sets the name. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Root | Gets or sets the root.
Public property | SkipVersions | Gets or sets a value indicating whether the ItemSource skips the versions.

See Also

ItemSource Class
Sitecore.Install.Items Namespace


ItemSource Constructor

[image]

Sitecore 6.4.1 API
ItemSource Constructor
ItemSource Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemSource()
Visual Basic
Public Sub New
Visual C++
public:
ItemSource()

See Also

ItemSource Class
Sitecore.Install.Items Namespace


ItemSource Methods

[image] [image]

Sitecore 6.4.1 API
ItemSource Methods
ItemSource Class See Also Send Feedback

The ItemSource type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InternalPopulate | Populates the specified sink with the item and its subitems) (Overrides BaseSource<(Of <(<'T>)>)>..::..InternalPopulate(ISink<(Of <<'(T>)>>)).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Populates this sourse from the specified sink. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemSource Class
Sitecore.Install.Items Namespace


InternalPopulate Method

[image]

Sitecore 6.4.1 API
ItemSource..::..InternalPopulate Method
ItemSource Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void InternalPopulate(
    ISink<Item> sink
)
Visual Basic
Protected Overrides Sub InternalPopulate ( _
    sink As ISink(Of Item) _
)
Visual C++
protected:
virtual void InternalPopulate(
    ISink<Item^>^ sink
) override

Parameters

sink
Type: Sitecore.Install.Framework..::..ISink <(Of <(<' Item >)>)>
The sink

See Also

ItemSource Class
Sitecore.Install.Items Namespace


Database Property

[image]

Sitecore 6.4.1 API
ItemSource..::..Database Property
ItemSource Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Database { get; set; }
Visual Basic
Public Property Database As String
    Get
    Set
Visual C++
public:
property String^ Database {
    String^ get ();
    void set (String^ value);
}

Field Value

The database.

See Also

ItemSource Class
Sitecore.Install.Items Namespace


Root Property

[image]

Sitecore 6.4.1 API
ItemSource..::..Root Property
ItemSource Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Root { get; set; }
Visual Basic
Public Property Root As String
    Get
    Set
Visual C++
public:
property String^ Root {
    String^ get ();
    void set (String^ value);
}

Field Value

The root.

See Also

ItemSource Class
Sitecore.Install.Items Namespace


SkipVersions Property

[image]

Sitecore 6.4.1 API
ItemSource..::..SkipVersions Property
ItemSource Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool SkipVersions { get; set; }
Visual Basic
Public Property SkipVersions As Boolean
    Get
    Set
Visual C++
public:
property bool SkipVersions {
    bool get ();
    void set (bool value);
}

Field Value

true if the ItemSource skips the versions; otherwise, false.

See Also

ItemSource Class
Sitecore.Install.Items Namespace


ItemToEntryConverter Class

[image]

Sitecore 6.4.1 API
ItemToEntryConverter Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemToEntryConverter : BaseConverter<Item>
Visual Basic
Public Class ItemToEntryConverter _
    Inherits BaseConverter(Of Item)
Visual C++
public ref class ItemToEntryConverter : public BaseConverter<Item^>

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..BaseConverter <(Of <(<' Item >)>)>
Sitecore.Install.Items..::..ItemToEntryConverter

See Also

ItemToEntryConverter Members
Sitecore.Install.Items Namespace


ItemToEntryConverter Members

[image] [image]

Sitecore 6.4.1 API
ItemToEntryConverter Members
ItemToEntryConverter Class Constructors Methods Properties See Also Send Feedback

The ItemToEntryConverter type exposes the following members.

Constructors

 | Name | Description
Public method | ItemToEntryConverter | Initializes a new instance of the ItemToEntryConverter class

Methods

 | Name | Description
Protected method | ApplyTransforms(PackageEntry, IProcessingContext) | Applies the transform. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public method | Convert | Converts the specified entry. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttribute | Gets the value of the attribute. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InternalConvert | Convert the item to an entry. (Overrides BaseConverter<(Of <(<'T>)>)>..::..InternalConvert(T, IProcessingContext).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetAttribute | Sets the value of the attribute. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Protected property | AutoApplyTransforms | Gets a value indicating whether the BaseConverter<(Of <(<'T>)>)> converter transforms should be applied by BaseConverter, not the derived class. (Overrides BaseConverter<(Of <(<'T>)>)>..::..AutoApplyTransforms.)
Public property | Transforms | Gets the transforms. (Inherited from BaseConverter<(Of <(<'T>)>)>.)

See Also

ItemToEntryConverter Class
Sitecore.Install.Items Namespace


ItemToEntryConverter Constructor

[image]

Sitecore 6.4.1 API
ItemToEntryConverter Constructor
ItemToEntryConverter Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemToEntryConverter()
Visual Basic
Public Sub New
Visual C++
public:
ItemToEntryConverter()

See Also

ItemToEntryConverter Class
Sitecore.Install.Items Namespace


ItemToEntryConverter Methods

[image] [image]

Sitecore 6.4.1 API
ItemToEntryConverter Methods
ItemToEntryConverter Class See Also Send Feedback

The ItemToEntryConverter type exposes the following members.

Methods

 | Name | Description
Protected method | ApplyTransforms(PackageEntry, IProcessingContext) | Applies the transform. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public method | Convert | Converts the specified entry. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttribute | Gets the value of the attribute. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InternalConvert | Convert the item to an entry. (Overrides BaseConverter<(Of <(<'T>)>)>..::..InternalConvert(T, IProcessingContext).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetAttribute | Sets the value of the attribute. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemToEntryConverter Class
Sitecore.Install.Items Namespace


InternalConvert Method

[image]

Sitecore 6.4.1 API
ItemToEntryConverter..::..InternalConvert Method
ItemToEntryConverter Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override PackageEntry[] InternalConvert(
    Item item,
    IProcessingContext context
)
Visual Basic
Protected Overrides Function InternalConvert ( _
    item As Item, _
    context As IProcessingContext _
) As PackageEntry()
Visual C++
protected:
virtual array<PackageEntry^>^ InternalConvert(
    Item^ item,
    IProcessingContext^ context
) override

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
context
Type: Sitecore.Install.Framework..::..IProcessingContext
The context.

Return Value

The convert.

See Also

ItemToEntryConverter Class
Sitecore.Install.Items Namespace


ItemToEntryConverter Properties

[image] [image]

Sitecore 6.4.1 API
ItemToEntryConverter Properties
ItemToEntryConverter Class See Also Send Feedback

The ItemToEntryConverter type exposes the following members.

Properties

 | Name | Description
Protected property | AutoApplyTransforms | Gets a value indicating whether the BaseConverter<(Of <(<'T>)>)> converter transforms should be applied by BaseConverter, not the derived class. (Overrides BaseConverter<(Of <(<'T>)>)>..::..AutoApplyTransforms.)
Public property | Transforms | Gets the transforms. (Inherited from BaseConverter<(Of <(<'T>)>)>.)

See Also

ItemToEntryConverter Class
Sitecore.Install.Items Namespace


AutoApplyTransforms Property

[image]

Sitecore 6.4.1 API
ItemToEntryConverter..::..AutoApplyTransforms Property
ItemToEntryConverter Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override bool AutoApplyTransforms { get; }
Visual Basic
Protected Overrides ReadOnly Property AutoApplyTransforms As Boolean
    Get
Visual C++
protected:
virtual property bool AutoApplyTransforms {
    bool get () override;
}

Field Value

true if the BaseConverter<(Of <(<'T>)>)> transforms should be applied by BaseConverter implicitly; otherwise, false.

See Also

ItemToEntryConverter Class
Sitecore.Install.Items Namespace


ItemUninstaller Class

[image]

Sitecore 6.4.1 API
ItemUninstaller Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemUninstaller : BaseSink<PackageEntry>
Visual Basic
Public Class ItemUninstaller _
    Inherits BaseSink(Of PackageEntry)
Visual C++
public ref class ItemUninstaller : public BaseSink<PackageEntry^>

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..BaseSink <(Of <(<' PackageEntry >)>)>
Sitecore.Install.Items..::..ItemUninstaller

See Also

ItemUninstaller Members
Sitecore.Install.Items Namespace


ItemUninstaller Members

[image] [image]

Sitecore 6.4.1 API
ItemUninstaller Members
ItemUninstaller Class Constructors Methods Fields Properties See Also Send Feedback

The ItemUninstaller type exposes the following members.

Constructors

 | Name | Description
Public method | ItemUninstaller | Initializes a new instance of the ItemUninstaller class

Methods

 | Name | Description
Protected method | AssertInit | Asserts the init. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finishes the sink. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Flush | Flushes the sink (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this instance. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put | Puts the specified entry. (Overrides BaseSink<(Of <(<'T>)>)>..::..Put(T).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _processingContext | (Inherited from BaseSink<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

ItemUninstaller Class
Sitecore.Install.Items Namespace


ItemUninstaller Constructor

[image]

Sitecore 6.4.1 API
ItemUninstaller Constructor
ItemUninstaller Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemUninstaller()
Visual Basic
Public Sub New
Visual C++
public:
ItemUninstaller()

See Also

ItemUninstaller Class
Sitecore.Install.Items Namespace


ItemUninstaller Fields

[image] [image]

Sitecore 6.4.1 API
ItemUninstaller Fields
ItemUninstaller Class See Also Send Feedback

The ItemUninstaller type exposes the following members.

Fields

 | Name | Description
Protected field | _processingContext | (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

ItemUninstaller Class
Sitecore.Install.Items Namespace


ItemUninstaller Methods

[image] [image]

Sitecore 6.4.1 API
ItemUninstaller Methods
ItemUninstaller Class See Also Send Feedback

The ItemUninstaller type exposes the following members.

Methods

 | Name | Description
Protected method | AssertInit | Asserts the init. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finishes the sink. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Flush | Flushes the sink (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this instance. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put | Puts the specified entry. (Overrides BaseSink<(Of <(<'T>)>)>..::..Put(T).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemUninstaller Class
Sitecore.Install.Items Namespace


Put Method

[image]

Sitecore 6.4.1 API
ItemUninstaller..::..Put Method
ItemUninstaller Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Put(
    PackageEntry entry
)
Visual Basic
Public Overrides Sub Put ( _
    entry As PackageEntry _
)
Visual C++
public:
virtual void Put(
    PackageEntry^ entry
) override

Parameters

entry
Type: Sitecore.Install.Framework..::..PackageEntry
The entry.

Implements

ISink<(Of <(<'T>)>)>..::..Put(T)

See Also

ItemUninstaller Class
Sitecore.Install.Items Namespace


ItemUninstaller Properties

[image] [image]

Sitecore 6.4.1 API
ItemUninstaller Properties
ItemUninstaller Class See Also Send Feedback

The ItemUninstaller type exposes the following members.

Properties

 | Name | Description
Public property | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

ItemUninstaller Class
Sitecore.Install.Items Namespace


LegacyItemUnpacker Class

[image]

Sitecore 6.4.1 API
LegacyItemUnpacker Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class LegacyItemUnpacker : BaseSink<PackageEntry>
Visual Basic
Public Class LegacyItemUnpacker _
    Inherits BaseSink(Of PackageEntry)
Visual C++
public ref class LegacyItemUnpacker : public BaseSink<PackageEntry^>

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..BaseSink <(Of <(<' PackageEntry >)>)>
Sitecore.Install.Items..::..LegacyItemUnpacker

See Also

LegacyItemUnpacker Members
Sitecore.Install.Items Namespace


LegacyItemUnpacker Members

[image] [image]

Sitecore 6.4.1 API
LegacyItemUnpacker Members
LegacyItemUnpacker Class Constructors Methods Fields Properties See Also Send Feedback

The LegacyItemUnpacker type exposes the following members.

Constructors

 | Name | Description
Public method | LegacyItemUnpacker | Initializes a new instance of the LegacyItemUnpacker class.

Methods

 | Name | Description
Protected method | AssertInit | Asserts the init. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finishes the sink. (Overrides BaseSink<(Of <(<'T>)>)>..::..Finish()()()().)
Public method | Flush | Flushes the sink (Overrides BaseSink<(Of <(<'T>)>)>..::..Flush()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this instance. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put | If the entry is in the old format this method "splits" this entry to several entries for each item version (Overrides BaseSink<(Of <(<'T>)>)>..::..Put(T).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _processingContext | (Inherited from BaseSink<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

LegacyItemUnpacker Class
Sitecore.Install.Items Namespace


LegacyItemUnpacker Constructor

[image]

Sitecore 6.4.1 API
LegacyItemUnpacker Constructor
LegacyItemUnpacker Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LegacyItemUnpacker(
    ISink<PackageEntry> owner
)
Visual Basic
Public Sub New ( _
    owner As ISink(Of PackageEntry) _
)
Visual C++
public:
LegacyItemUnpacker(
    ISink<PackageEntry^>^ owner
)

Parameters

owner
Type: Sitecore.Install.Framework..::..ISink <(Of <(<' PackageEntry >)>)>
The owner.

See Also

LegacyItemUnpacker Class
Sitecore.Install.Items Namespace


LegacyItemUnpacker Fields

[image] [image]

Sitecore 6.4.1 API
LegacyItemUnpacker Fields
LegacyItemUnpacker Class See Also Send Feedback

The LegacyItemUnpacker type exposes the following members.

Fields

 | Name | Description
Protected field | _processingContext | (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

LegacyItemUnpacker Class
Sitecore.Install.Items Namespace


LegacyItemUnpacker Methods

[image] [image]

Sitecore 6.4.1 API
LegacyItemUnpacker Methods
LegacyItemUnpacker Class See Also Send Feedback

The LegacyItemUnpacker type exposes the following members.

Methods

 | Name | Description
Protected method | AssertInit | Asserts the init. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finishes the sink. (Overrides BaseSink<(Of <(<'T>)>)>..::..Finish()()()().)
Public method | Flush | Flushes the sink (Overrides BaseSink<(Of <(<'T>)>)>..::..Flush()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this instance. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put | If the entry is in the old format this method "splits" this entry to several entries for each item version (Overrides BaseSink<(Of <(<'T>)>)>..::..Put(T).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LegacyItemUnpacker Class
Sitecore.Install.Items Namespace


Finish Method

[image]

Sitecore 6.4.1 API
LegacyItemUnpacker..::..Finish Method
LegacyItemUnpacker Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Finish()
Visual Basic
Public Overrides Sub Finish
Visual C++
public:
virtual void Finish() override

Implements

ISink<(Of <(<'T>)>)>..::..Finish()()()()

See Also

LegacyItemUnpacker Class
Sitecore.Install.Items Namespace


Flush Method

[image]

Sitecore 6.4.1 API
LegacyItemUnpacker..::..Flush Method
LegacyItemUnpacker Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Flush()
Visual Basic
Public Overrides Sub Flush
Visual C++
public:
virtual void Flush() override

Implements

ISink<(Of <(<'T>)>)>..::..Flush()()()()

See Also

LegacyItemUnpacker Class
Sitecore.Install.Items Namespace


Put Method

[image]

Sitecore 6.4.1 API
LegacyItemUnpacker..::..Put Method
LegacyItemUnpacker Class See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Put(
    PackageEntry entry
)
Visual Basic
Public Overrides Sub Put ( _
    entry As PackageEntry _
)
Visual C++
public:
virtual void Put(
    PackageEntry^ entry
) override

Parameters

entry
Type: Sitecore.Install.Framework..::..PackageEntry
The entry.

Implements

ISink<(Of <(<'T>)>)>..::..Put(T)

See Also

LegacyItemUnpacker Class
Sitecore.Install.Items Namespace


LegacyItemUnpacker Properties

[image] [image]

Sitecore 6.4.1 API
LegacyItemUnpacker Properties
LegacyItemUnpacker Class See Also Send Feedback

The LegacyItemUnpacker type exposes the following members.

Properties

 | Name | Description
Public property | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

LegacyItemUnpacker Class
Sitecore.Install.Items Namespace


VersionInstallMode Enumeration

[image]

Sitecore 6.4.1 API
VersionInstallMode Enumeration
See Also Send Feedback

Namespace: Sitecore.Install.Items
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum VersionInstallMode
Visual Basic
Public Enumeration VersionInstallMode
Visual C++
public enum class VersionInstallMode

Members

Member name | Value | Description
Merge | 0 | Merge versions by version number
Append | 1 | Append version if version with same revision number is not exists
Skip | 2 | Don't install version
Undefined | 3 | Undefined

See Also

Sitecore.Install.Items Namespace


Sitecore.Install.Metadata Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Install.Metadata Namespace
Send Feedback

Classes

 | Class | Description
Public class | MetadataSink | Reads metadata from a package entry.
Public class | MetadataSource | Represents metadata as a source for package entries
Public class | MetadataView | Represents the metadata part of a package


MetadataSink Class

[image]

Sitecore 6.4.1 API
MetadataSink Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Metadata
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class MetadataSink : BaseSink<PackageEntry>
Visual Basic
Public Class MetadataSink _
    Inherits BaseSink(Of PackageEntry)
Visual C++
public ref class MetadataSink : public BaseSink<PackageEntry^>

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..BaseSink <(Of <(<' PackageEntry >)>)>
Sitecore.Install.Metadata..::..MetadataSink

See Also

MetadataSink Members
Sitecore.Install.Metadata Namespace


MetadataSink Members

[image] [image]

Sitecore 6.4.1 API
MetadataSink Members
MetadataSink Class Constructors Methods Fields Properties See Also Send Feedback

The MetadataSink type exposes the following members.

Constructors

 | Name | Description
Public method | MetadataSink(IProcessingContext) | Initializes a new instance of the MetadataSink class.
Public method | MetadataSink(MetadataView) | Initializes a new instance of the MetadataSink class.

Methods

 | Name | Description
Protected method | AssertInit | Asserts the init. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finishes the sink. (Overrides BaseSink<(Of <(<'T>)>)>..::..Finish()()()().)
Public method | Flush | Flushes the sink (Overrides BaseSink<(Of <(<'T>)>)>..::..Flush()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this instance. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put | Reads metadata from a package entry. If the entry contains it (Overrides BaseSink<(Of <(<'T>)>)>..::..Put(T).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _processingContext | (Inherited from BaseSink<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

MetadataSink Class
Sitecore.Install.Metadata Namespace


MetadataSink Constructor

[image] [image]

Sitecore 6.4.1 API
MetadataSink Constructor
MetadataSink Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MetadataSink(IProcessingContext) | Initializes a new instance of the MetadataSink class.
Public method | MetadataSink(MetadataView) | Initializes a new instance of the MetadataSink class.

See Also

MetadataSink Class
MetadataSink Members
Sitecore.Install.Metadata Namespace


MetadataSink Constructor (IProcessingContext)

[image]

Sitecore 6.4.1 API
MetadataSink Constructor (IProcessingContext)
MetadataSink Class See Also Send Feedback

Namespace: Sitecore.Install.Metadata
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MetadataSink(
    IProcessingContext context
)
Visual Basic
Public Sub New ( _
    context As IProcessingContext _
)
Visual C++
public:
MetadataSink(
    IProcessingContext^ context
)

Parameters

context
Type: Sitecore.Install.Framework..::..IProcessingContext

[Missing <param name="context"/> documentation for "M:Sitecore.Install.Metadata.MetadataSink.#ctor(Sitecore.Install.Framework.IProcessingContext)"]

See Also

MetadataSink Class
MetadataSink Overload
Sitecore.Install.Metadata Namespace


MetadataSink Constructor (MetadataView)

[image]

Sitecore 6.4.1 API
MetadataSink Constructor (MetadataView)
MetadataSink Class See Also Send Feedback

Namespace: Sitecore.Install.Metadata
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MetadataSink(
    MetadataView view
)
Visual Basic
Public Sub New ( _
    view As MetadataView _
)
Visual C++
public:
MetadataSink(
    MetadataView^ view
)

Parameters

view
Type: Sitecore.Install.Metadata..::..MetadataView
The view.

See Also

MetadataSink Class
MetadataSink Overload
Sitecore.Install.Metadata Namespace


MetadataSink Fields

[image] [image]

Sitecore 6.4.1 API
MetadataSink Fields
MetadataSink Class See Also Send Feedback

The MetadataSink type exposes the following members.

Fields

 | Name | Description
Protected field | _processingContext | (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

MetadataSink Class
Sitecore.Install.Metadata Namespace


Finish Method

[image]

Sitecore 6.4.1 API
MetadataSink..::..Finish Method
MetadataSink Class See Also Send Feedback

Namespace: Sitecore.Install.Metadata
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Finish()
Visual Basic
Public Overrides Sub Finish
Visual C++
public:
virtual void Finish() override

Implements

ISink<(Of <(<'T>)>)>..::..Finish()()()()

See Also

MetadataSink Class
Sitecore.Install.Metadata Namespace


Flush Method

[image]

Sitecore 6.4.1 API
MetadataSink..::..Flush Method
MetadataSink Class See Also Send Feedback

Namespace: Sitecore.Install.Metadata
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Flush()
Visual Basic
Public Overrides Sub Flush
Visual C++
public:
virtual void Flush() override

Implements

ISink<(Of <(<'T>)>)>..::..Flush()()()()

See Also

MetadataSink Class
Sitecore.Install.Metadata Namespace


Put Method

[image]

Sitecore 6.4.1 API
MetadataSink..::..Put Method
MetadataSink Class See Also Send Feedback

Namespace: Sitecore.Install.Metadata
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Put(
    PackageEntry entry
)
Visual Basic
Public Overrides Sub Put ( _
    entry As PackageEntry _
)
Visual C++
public:
virtual void Put(
    PackageEntry^ entry
) override

Parameters

entry
Type: Sitecore.Install.Framework..::..PackageEntry
The entry.

Implements

ISink<(Of <(<'T>)>)>..::..Put(T)

See Also

MetadataSink Class
Sitecore.Install.Metadata Namespace


MetadataSink Properties

[image] [image]

Sitecore 6.4.1 API
MetadataSink Properties
MetadataSink Class See Also Send Feedback

The MetadataSink type exposes the following members.

Properties

 | Name | Description
Public property | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

MetadataSink Class
Sitecore.Install.Metadata Namespace


MetadataSource Class

[image]

Sitecore 6.4.1 API
MetadataSource Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Metadata
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class MetadataSource : MetadataView,
    ISource<PackageEntry>
Visual Basic
Public Class MetadataSource _
    Inherits MetadataView _
    Implements ISource(Of PackageEntry)
Visual C++
public ref class MetadataSource : public MetadataView,
    ISource<PackageEntry^>

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Metadata..::..MetadataView
Sitecore.Install.Metadata..::..MetadataSource

See Also

MetadataSource Members
Sitecore.Install.Metadata Namespace


MetadataSource Members

[image] [image]

Sitecore 6.4.1 API
MetadataSource Members
MetadataSource Class Constructors Methods Properties See Also Send Feedback

The MetadataSource type exposes the following members.

Constructors

 | Name | Description
Public method | MetadataSource | Initializes a new instance of the MetadataSource class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDictionary | Gets the dictionary. (Inherited from MetadataView.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from MetadataView.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Populates specified sink from this sourse.
Protected method | SetValue | Sets the value. (Inherited from MetadataView.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Attributes | Gets or sets the attributes. (Inherited from MetadataView.)
Public property | Author | Gets or sets the author. (Inherited from MetadataView.)
Public property | Comment | Gets or sets the comment. (Inherited from MetadataView.)
Public property | License | Gets or sets the license. (Inherited from MetadataView.)
Public property | Metadata | Gets the metadata as a NameValueCollection. (Inherited from MetadataView.)
Public property | PackageID | Gets or sets the package ID. (Inherited from MetadataView.)
Public property | PackageName | Gets or sets the name of the package. (Inherited from MetadataView.)
Public property | PostStep | Gets or sets the post step. (Inherited from MetadataView.)
Public property | Publisher | Gets or sets the publisher. (Inherited from MetadataView.)
Public property | Readme | Gets or sets the readme. (Inherited from MetadataView.)
Public property | Revision | Gets or sets the revision. (Inherited from MetadataView.)
Public property | Version | Gets or sets the version. (Inherited from MetadataView.)

See Also

MetadataSource Class
Sitecore.Install.Metadata Namespace


MetadataSource Constructor

[image]

Sitecore 6.4.1 API
MetadataSource Constructor
MetadataSource Class See Also Send Feedback

Namespace: Sitecore.Install.Metadata
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MetadataSource()
Visual Basic
Public Sub New
Visual C++
public:
MetadataSource()

See Also

MetadataSource Class
Sitecore.Install.Metadata Namespace


MetadataSource Methods

[image] [image]

Sitecore 6.4.1 API
MetadataSource Methods
MetadataSource Class See Also Send Feedback

The MetadataSource type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDictionary | Gets the dictionary. (Inherited from MetadataView.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value. (Inherited from MetadataView.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Populates specified sink from this sourse.
Protected method | SetValue | Sets the value. (Inherited from MetadataView.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MetadataSource Class
Sitecore.Install.Metadata Namespace


Populate Method

[image]

Sitecore 6.4.1 API
MetadataSource..::..Populate Method
MetadataSource Class See Also Send Feedback

Namespace: Sitecore.Install.Metadata
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Populate(
    ISink<PackageEntry> sink
)
Visual Basic
Public Sub Populate ( _
    sink As ISink(Of PackageEntry) _
)
Visual C++
public:
virtual void Populate(
    ISink<PackageEntry^>^ sink
) sealed

Parameters

sink
Type: Sitecore.Install.Framework..::..ISink <(Of <(<' PackageEntry >)>)>
The sink.

Implements

ISource<(Of <(<'T>)>)>..::..Populate(ISink<(Of <<'(T>)>>))

See Also

MetadataSource Class
Sitecore.Install.Metadata Namespace


MetadataSource Properties

[image] [image]

Sitecore 6.4.1 API
MetadataSource Properties
MetadataSource Class See Also Send Feedback

The MetadataSource type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets or sets the attributes. (Inherited from MetadataView.)
Public property | Author | Gets or sets the author. (Inherited from MetadataView.)
Public property | Comment | Gets or sets the comment. (Inherited from MetadataView.)
Public property | License | Gets or sets the license. (Inherited from MetadataView.)
Public property | Metadata | Gets the metadata as a NameValueCollection. (Inherited from MetadataView.)
Public property | PackageID | Gets or sets the package ID. (Inherited from MetadataView.)
Public property | PackageName | Gets or sets the name of the package. (Inherited from MetadataView.)
Public property | PostStep | Gets or sets the post step. (Inherited from MetadataView.)
Public property | Publisher | Gets or sets the publisher. (Inherited from MetadataView.)
Public property | Readme | Gets or sets the readme. (Inherited from MetadataView.)
Public property | Revision | Gets or sets the revision. (Inherited from MetadataView.)
Public property | Version | Gets or sets the version. (Inherited from MetadataView.)

See Also

MetadataSource Class
Sitecore.Install.Metadata Namespace


MetadataView Class

[image]

Sitecore 6.4.1 API
MetadataView Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Metadata
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class MetadataView
Visual Basic
Public Class MetadataView
Visual C++
public ref class MetadataView

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Metadata..::..MetadataView
Sitecore.Install.Metadata..::..MetadataSource

See Also

MetadataView Members
Sitecore.Install.Metadata Namespace


MetadataView Members

[image] [image]

Sitecore 6.4.1 API
MetadataView Members
MetadataView Class Constructors Methods Properties See Also Send Feedback

The MetadataView type exposes the following members.

Constructors

 | Name | Description
Public method | MetadataView(IDictionary<(Of <<'(String, String>)>>)) | Initializes a new instance of the MetadataView class.
Public method | MetadataView(IProcessingContext) | Initializes a new instance of the MetadataView class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDictionary | Gets the dictionary.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetValue | Sets the value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Attributes | Gets or sets the attributes.
Public property | Author | Gets or sets the author.
Public property | Comment | Gets or sets the comment.
Public property | License | Gets or sets the license.
Public property | Metadata | Gets the metadata as a NameValueCollection.
Public property | PackageID | Gets or sets the package ID.
Public property | PackageName | Gets or sets the name of the package.
Public property | PostStep | Gets or sets the post step.
Public property | Publisher | Gets or sets the publisher.
Public property | Readme | Gets or sets the readme.
Public property | Revision | Gets or sets the revision.
Public property | Version | Gets or sets the version.

See Also

MetadataView Class
Sitecore.Install.Metadata Namespace


MetadataView Constructor

[image] [image]

Sitecore 6.4.1 API
MetadataView Constructor
MetadataView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MetadataView(IDictionary<(Of <<'(String, String>)>>)) | Initializes a new instance of the MetadataView class.
Public method | MetadataView(IProcessingContext) | Initializes a new instance of the MetadataView class.

See Also

MetadataView Class
MetadataView Members
Sitecore.Install.Metadata Namespace


MetadataView Constructor (IDictionary(String, String))

[image]

Sitecore 6.4.1 API
MetadataView Constructor (IDictionary<(Of <(<'String, String>)>)>)
MetadataView Class See Also Send Feedback

Namespace: Sitecore.Install.Metadata
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MetadataView(
    IDictionary<string, string> data
)
Visual Basic
Public Sub New ( _
    data As IDictionary(Of String, String) _
)
Visual C++
public:
MetadataView(
    IDictionary<String^, String^>^ data
)

Parameters

data
Type: System.Collections.Generic..::..IDictionary <(Of <(<' String, String >)>)>
The data.

See Also

MetadataView Class
MetadataView Overload
Sitecore.Install.Metadata Namespace


MetadataView Constructor (IProcessingContext)

[image]

Sitecore 6.4.1 API
MetadataView Constructor (IProcessingContext)
MetadataView Class See Also Send Feedback

Namespace: Sitecore.Install.Metadata
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MetadataView(
    IProcessingContext context
)
Visual Basic
Public Sub New ( _
    context As IProcessingContext _
)
Visual C++
public:
MetadataView(
    IProcessingContext^ context
)

Parameters

context
Type: Sitecore.Install.Framework..::..IProcessingContext
The context.

See Also

MetadataView Class
MetadataView Overload
Sitecore.Install.Metadata Namespace


MetadataView Methods

[image] [image]

Sitecore 6.4.1 API
MetadataView Methods
MetadataView Class See Also Send Feedback

The MetadataView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDictionary | Gets the dictionary.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValue | Gets the value.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetValue | Sets the value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MetadataView Class
Sitecore.Install.Metadata Namespace


GetDictionary Method

[image]

Sitecore 6.4.1 API
MetadataView..::..GetDictionary Method
MetadataView Class See Also Send Feedback

Namespace: Sitecore.Install.Metadata
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IDictionary<string, string> GetDictionary()
Visual Basic
Public Function GetDictionary As IDictionary(Of String, String)
Visual C++
public:
IDictionary<String^, String^>^ GetDictionary()

Return Value

The dictionary.

See Also

MetadataView Class
Sitecore.Install.Metadata Namespace


GetValue Method

[image]

Sitecore 6.4.1 API
MetadataView..::..GetValue Method
MetadataView Class See Also Send Feedback

Namespace: Sitecore.Install.Metadata
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string GetValue(
    string key
)
Visual Basic
Protected Overridable Function GetValue ( _
    key As String _
) As String
Visual C++
protected:
virtual String^ GetValue(
    String^ key
)

Parameters

key
Type: System..::..String
The key.

Return Value

The value.

See Also

MetadataView Class
Sitecore.Install.Metadata Namespace


SetValue Method

[image]

Sitecore 6.4.1 API
MetadataView..::..SetValue Method
MetadataView Class See Also Send Feedback

Namespace: Sitecore.Install.Metadata
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void SetValue(
    string key,
    string value
)
Visual Basic
Protected Overridable Sub SetValue ( _
    key As String, _
    value As String _
)
Visual C++
protected:
virtual void SetValue(
    String^ key,
    String^ value
)

Parameters

key
Type: System..::..String
The key.
value
Type: System..::..String
The value.

See Also

MetadataView Class
Sitecore.Install.Metadata Namespace


MetadataView Properties

[image] [image]

Sitecore 6.4.1 API
MetadataView Properties
MetadataView Class See Also Send Feedback

The MetadataView type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets or sets the attributes.
Public property | Author | Gets or sets the author.
Public property | Comment | Gets or sets the comment.
Public property | License | Gets or sets the license.
Public property | Metadata | Gets the metadata as a NameValueCollection.
Public property | PackageID | Gets or sets the package ID.
Public property | PackageName | Gets or sets the name of the package.
Public property | PostStep | Gets or sets the post step.
Public property | Publisher | Gets or sets the publisher.
Public property | Readme | Gets or sets the readme.
Public property | Revision | Gets or sets the revision.
Public property | Version | Gets or sets the version.

See Also

MetadataView Class
Sitecore.Install.Metadata Namespace


Attributes Property

[image]

Sitecore 6.4.1 API
MetadataView..::..Attributes Property
MetadataView Class See Also Send Feedback

Namespace: Sitecore.Install.Metadata
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Attributes { get; set; }
Visual Basic
Public Property Attributes As String
    Get
    Set
Visual C++
public:
property String^ Attributes {
    String^ get ();
    void set (String^ value);
}

Field Value

The attributes.

See Also

MetadataView Class
Sitecore.Install.Metadata Namespace


Author Property

[image]

Sitecore 6.4.1 API
MetadataView..::..Author Property
MetadataView Class See Also Send Feedback

Namespace: Sitecore.Install.Metadata
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Author { get; set; }
Visual Basic
Public Property Author As String
    Get
    Set
Visual C++
public:
property String^ Author {
    String^ get ();
    void set (String^ value);
}

Field Value

The author.

See Also

MetadataView Class
Sitecore.Install.Metadata Namespace


Comment Property

[image]

Sitecore 6.4.1 API
MetadataView..::..Comment Property
MetadataView Class See Also Send Feedback

Namespace: Sitecore.Install.Metadata
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Comment { get; set; }
Visual Basic
Public Property Comment As String
    Get
    Set
Visual C++
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}

Field Value

The comment.

See Also

MetadataView Class
Sitecore.Install.Metadata Namespace


License Property

[image]

Sitecore 6.4.1 API
MetadataView..::..License Property
MetadataView Class See Also Send Feedback

Namespace: Sitecore.Install.Metadata
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string License { get; set; }
Visual Basic
Public Property License As String
    Get
    Set
Visual C++
public:
property String^ License {
    String^ get ();
    void set (String^ value);
}

Field Value

The license.

See Also

MetadataView Class
Sitecore.Install.Metadata Namespace


Metadata Property

[image]

Sitecore 6.4.1 API
MetadataView..::..Metadata Property
MetadataView Class See Also Send Feedback

Namespace: Sitecore.Install.Metadata
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual NameValueCollection Metadata { get; }
Visual Basic
Public Overridable ReadOnly Property Metadata As NameValueCollection
    Get
Visual C++
public:
virtual property NameValueCollection^ Metadata {
    NameValueCollection^ get ();
}

Field Value

The metadata.

See Also

MetadataView Class
Sitecore.Install.Metadata Namespace


PackageID Property

[image]

Sitecore 6.4.1 API
MetadataView..::..PackageID Property
MetadataView Class See Also Send Feedback

Namespace: Sitecore.Install.Metadata
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string PackageID { get; set; }
Visual Basic
Public Property PackageID As String
    Get
    Set
Visual C++
public:
property String^ PackageID {
    String^ get ();
    void set (String^ value);
}

Field Value

The package ID.

See Also

MetadataView Class
Sitecore.Install.Metadata Namespace


PackageName Property

[image]

Sitecore 6.4.1 API
MetadataView..::..PackageName Property
MetadataView Class See Also Send Feedback

Namespace: Sitecore.Install.Metadata
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string PackageName { get; set; }
Visual Basic
Public Property PackageName As String
    Get
    Set
Visual C++
public:
property String^ PackageName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the package.

See Also

MetadataView Class
Sitecore.Install.Metadata Namespace


PostStep Property

[image]

Sitecore 6.4.1 API
MetadataView..::..PostStep Property
MetadataView Class See Also Send Feedback

Namespace: Sitecore.Install.Metadata
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string PostStep { get; set; }
Visual Basic
Public Property PostStep As String
    Get
    Set
Visual C++
public:
property String^ PostStep {
    String^ get ();
    void set (String^ value);
}

Field Value

The post step.

See Also

MetadataView Class
Sitecore.Install.Metadata Namespace


Publisher Property

[image]

Sitecore 6.4.1 API
MetadataView..::..Publisher Property
MetadataView Class See Also Send Feedback

Namespace: Sitecore.Install.Metadata
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Publisher { get; set; }
Visual Basic
Public Property Publisher As String
    Get
    Set
Visual C++
public:
property String^ Publisher {
    String^ get ();
    void set (String^ value);
}

Field Value

The publisher.

See Also

MetadataView Class
Sitecore.Install.Metadata Namespace


Readme Property

[image]

Sitecore 6.4.1 API
MetadataView..::..Readme Property
MetadataView Class See Also Send Feedback

Namespace: Sitecore.Install.Metadata
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Readme { get; set; }
Visual Basic
Public Property Readme As String
    Get
    Set
Visual C++
public:
property String^ Readme {
    String^ get ();
    void set (String^ value);
}

Field Value

The readme.

See Also

MetadataView Class
Sitecore.Install.Metadata Namespace


Revision Property

[image]

Sitecore 6.4.1 API
MetadataView..::..Revision Property
MetadataView Class See Also Send Feedback

Namespace: Sitecore.Install.Metadata
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Revision { get; set; }
Visual Basic
Public Property Revision As String
    Get
    Set
Visual C++
public:
property String^ Revision {
    String^ get ();
    void set (String^ value);
}

Field Value

The revision.

See Also

MetadataView Class
Sitecore.Install.Metadata Namespace


Version Property

[image]

Sitecore 6.4.1 API
MetadataView..::..Version Property
MetadataView Class See Also Send Feedback

Namespace: Sitecore.Install.Metadata
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Version { get; set; }
Visual Basic
Public Property Version As String
    Get
    Set
Visual C++
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}

Field Value

The version.

See Also

MetadataView Class
Sitecore.Install.Metadata Namespace


Sitecore.Install.Security Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Install.Security Namespace
Send Feedback

Classes

 | Class | Description
Public class | AccountInstaller | Account installer
Public class | AccountToEntryConverter | UserToEntryConverter class
Public class | SecuritySource | SecuritySource class

Interfaces

 | Interface | Description
Public interface | IAccountInstallerEvents | Define an interface for working with UI to be used in AccountInstaller


AccountInstaller Class

[image]

Sitecore 6.4.1 API
AccountInstaller Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Security
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class AccountInstaller : BaseSink<PackageEntry>
Visual Basic
Public Class AccountInstaller _
    Inherits BaseSink(Of PackageEntry)
Visual C++
public ref class AccountInstaller : public BaseSink<PackageEntry^>

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..BaseSink <(Of <(<' PackageEntry >)>)>
Sitecore.Install.Security..::..AccountInstaller

See Also

AccountInstaller Members
Sitecore.Install.Security Namespace


AccountInstaller Members

[image] [image]

Sitecore 6.4.1 API
AccountInstaller Members
AccountInstaller Class Constructors Methods Fields Properties See Also Send Feedback

The AccountInstaller type exposes the following members.

Constructors

 | Name | Description
Public method | AccountInstaller | Initializes a new instance of the AccountInstaller class

Methods

 | Name | Description
Protected method | AssertInit | Asserts the init. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finishes the sink. (Overrides BaseSink<(Of <(<'T>)>)>..::..Finish()()()().)
Public method | Flush | Flushes the sink (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this instance. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Protected method | InstallRole | Installs the role.
Protected method | InstallUser | Installs the user.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put | Installs the entry (Overrides BaseSink<(Of <(<'T>)>)>..::..Put(T).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _processingContext | (Inherited from BaseSink<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

AccountInstaller Class
Sitecore.Install.Security Namespace


AccountInstaller Constructor

[image]

Sitecore 6.4.1 API
AccountInstaller Constructor
AccountInstaller Class See Also Send Feedback

Namespace: Sitecore.Install.Security
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AccountInstaller()
Visual Basic
Public Sub New
Visual C++
public:
AccountInstaller()

See Also

AccountInstaller Class
Sitecore.Install.Security Namespace


AccountInstaller Fields

[image] [image]

Sitecore 6.4.1 API
AccountInstaller Fields
AccountInstaller Class See Also Send Feedback

The AccountInstaller type exposes the following members.

Fields

 | Name | Description
Protected field | _processingContext | (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

AccountInstaller Class
Sitecore.Install.Security Namespace


AccountInstaller Methods

[image] [image]

Sitecore 6.4.1 API
AccountInstaller Methods
AccountInstaller Class See Also Send Feedback

The AccountInstaller type exposes the following members.

Methods

 | Name | Description
Protected method | AssertInit | Asserts the init. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finishes the sink. (Overrides BaseSink<(Of <(<'T>)>)>..::..Finish()()()().)
Public method | Flush | Flushes the sink (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this instance. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Protected method | InstallRole | Installs the role.
Protected method | InstallUser | Installs the user.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put | Installs the entry (Overrides BaseSink<(Of <(<'T>)>)>..::..Put(T).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AccountInstaller Class
Sitecore.Install.Security Namespace


Finish Method

[image]

Sitecore 6.4.1 API
AccountInstaller..::..Finish Method
AccountInstaller Class See Also Send Feedback

Namespace: Sitecore.Install.Security
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Finish()
Visual Basic
Public Overrides Sub Finish
Visual C++
public:
virtual void Finish() override

Implements

ISink<(Of <(<'T>)>)>..::..Finish()()()()

See Also

AccountInstaller Class
Sitecore.Install.Security Namespace


InstallRole Method

[image]

Sitecore 6.4.1 API
AccountInstaller..::..InstallRole Method
AccountInstaller Class See Also Send Feedback

Namespace: Sitecore.Install.Security
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void InstallRole(
    PackageEntry entry
)
Visual Basic
Protected Sub InstallRole ( _
    entry As PackageEntry _
)
Visual C++
protected:
void InstallRole(
    PackageEntry^ entry
)

Parameters

entry
Type: Sitecore.Install.Framework..::..PackageEntry
The entry.

See Also

AccountInstaller Class
Sitecore.Install.Security Namespace


InstallUser Method

[image]

Sitecore 6.4.1 API
AccountInstaller..::..InstallUser Method
AccountInstaller Class See Also Send Feedback

Namespace: Sitecore.Install.Security
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void InstallUser(
    PackageEntry entry
)
Visual Basic
Protected Sub InstallUser ( _
    entry As PackageEntry _
)
Visual C++
protected:
void InstallUser(
    PackageEntry^ entry
)

Parameters

entry
Type: Sitecore.Install.Framework..::..PackageEntry
The entry.

See Also

AccountInstaller Class
Sitecore.Install.Security Namespace


Put Method

[image]

Sitecore 6.4.1 API
AccountInstaller..::..Put Method
AccountInstaller Class See Also Send Feedback

Namespace: Sitecore.Install.Security
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Put(
    PackageEntry entry
)
Visual Basic
Public Overrides Sub Put ( _
    entry As PackageEntry _
)
Visual C++
public:
virtual void Put(
    PackageEntry^ entry
) override

Parameters

entry
Type: Sitecore.Install.Framework..::..PackageEntry
entry

Implements

ISink<(Of <(<'T>)>)>..::..Put(T)

See Also

AccountInstaller Class
Sitecore.Install.Security Namespace


AccountInstaller Properties

[image] [image]

Sitecore 6.4.1 API
AccountInstaller Properties
AccountInstaller Class See Also Send Feedback

The AccountInstaller type exposes the following members.

Properties

 | Name | Description
Public property | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

AccountInstaller Class
Sitecore.Install.Security Namespace


AccountToEntryConverter Class

[image]

Sitecore 6.4.1 API
AccountToEntryConverter Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Security
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class AccountToEntryConverter : BaseConverter<string>
Visual Basic
Public Class AccountToEntryConverter _
    Inherits BaseConverter(Of String)
Visual C++
public ref class AccountToEntryConverter : public BaseConverter<String^>

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..BaseConverter <(Of <(<' String >)>)>
Sitecore.Install.Security..::..AccountToEntryConverter

See Also

AccountToEntryConverter Members
Sitecore.Install.Security Namespace


AccountToEntryConverter Members

[image] [image]

Sitecore 6.4.1 API
AccountToEntryConverter Members
AccountToEntryConverter Class Constructors Methods Properties See Also Send Feedback

The AccountToEntryConverter type exposes the following members.

Constructors

 | Name | Description
Public method | AccountToEntryConverter | Initializes a new instance of the AccountToEntryConverter class

Methods

 | Name | Description
Protected method | ApplyTransforms(PackageEntry, IProcessingContext) | Applies the transform. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public method | Convert | Converts the specified entry. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
 | CreateRoleEntry | Creates the role entry.
 | CreateUserEntry | Creates the user entry.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttribute | Gets the value of the attribute. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InternalConvert | Creates a package entry by user name. (Overrides BaseConverter<(Of <(<'T>)>)>..::..InternalConvert(T, IProcessingContext).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SaveUserProfile | Saves the user profile.
 | SaveUserProperties | Saves the user properties.
 | SaveUserRoles | Saves the user roles.
Public method | SetAttribute | Sets the value of the attribute. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | WriteProperty | Writes the property.

Properties

 | Name | Description
Protected property | AutoApplyTransforms | Gets a value indicating whether the BaseConverter<(Of <(<'T>)>)> converter transforms should be applied by BaseConverter, not the derived class. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public property | Transforms | Gets the transforms. (Inherited from BaseConverter<(Of <(<'T>)>)>.)

See Also

AccountToEntryConverter Class
Sitecore.Install.Security Namespace


AccountToEntryConverter Constructor

[image]

Sitecore 6.4.1 API
AccountToEntryConverter Constructor
AccountToEntryConverter Class See Also Send Feedback

Namespace: Sitecore.Install.Security
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AccountToEntryConverter()
Visual Basic
Public Sub New
Visual C++
public:
AccountToEntryConverter()

See Also

AccountToEntryConverter Class
Sitecore.Install.Security Namespace


AccountToEntryConverter Methods

[image] [image]

Sitecore 6.4.1 API
AccountToEntryConverter Methods
AccountToEntryConverter Class See Also Send Feedback

The AccountToEntryConverter type exposes the following members.

Methods

 | Name | Description
Protected method | ApplyTransforms(PackageEntry, IProcessingContext) | Applies the transform. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public method | Convert | Converts the specified entry. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
 | CreateRoleEntry | Creates the role entry.
 | CreateUserEntry | Creates the user entry.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttribute | Gets the value of the attribute. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InternalConvert | Creates a package entry by user name. (Overrides BaseConverter<(Of <(<'T>)>)>..::..InternalConvert(T, IProcessingContext).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SaveUserProfile | Saves the user profile.
 | SaveUserProperties | Saves the user properties.
 | SaveUserRoles | Saves the user roles.
Public method | SetAttribute | Sets the value of the attribute. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | WriteProperty | Writes the property.

See Also

AccountToEntryConverter Class
Sitecore.Install.Security Namespace


CreateRoleEntry Method

[image]

Sitecore 6.4.1 API
AccountToEntryConverter..::..CreateRoleEntry Method
AccountToEntryConverter Class See Also Send Feedback

Namespace: Sitecore.Install.Security
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected static PackageEntry[] CreateRoleEntry(
    string roleName
)
Visual Basic
Protected Shared Function CreateRoleEntry ( _
    roleName As String _
) As PackageEntry()
Visual C++
protected:
static array<PackageEntry^>^ CreateRoleEntry(
    String^ roleName
)

Parameters

roleName
Type: System..::..String
Name of the role.

Return Value

[Missing <returns> documentation for "M:Sitecore.Install.Security.AccountToEntryConverter.CreateRoleEntry(System.String)"]

See Also

AccountToEntryConverter Class
Sitecore.Install.Security Namespace


CreateUserEntry Method

[image]

Sitecore 6.4.1 API
AccountToEntryConverter..::..CreateUserEntry Method
AccountToEntryConverter Class See Also Send Feedback

Namespace: Sitecore.Install.Security
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected static PackageEntry[] CreateUserEntry(
    string userName
)
Visual Basic
Protected Shared Function CreateUserEntry ( _
    userName As String _
) As PackageEntry()
Visual C++
protected:
static array<PackageEntry^>^ CreateUserEntry(
    String^ userName
)

Parameters

userName
Type: System..::..String
Name of the user.

Return Value

[Missing <returns> documentation for "M:Sitecore.Install.Security.AccountToEntryConverter.CreateUserEntry(System.String)"]

See Also

AccountToEntryConverter Class
Sitecore.Install.Security Namespace


InternalConvert Method

[image]

Sitecore 6.4.1 API
AccountToEntryConverter..::..InternalConvert Method
AccountToEntryConverter Class See Also Send Feedback

Namespace: Sitecore.Install.Security
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override PackageEntry[] InternalConvert(
    string accountName,
    IProcessingContext context
)
Visual Basic
Protected Overrides Function InternalConvert ( _
    accountName As String, _
    context As IProcessingContext _
) As PackageEntry()
Visual C++
protected:
virtual array<PackageEntry^>^ InternalConvert(
    String^ accountName,
    IProcessingContext^ context
) override

Parameters

accountName
Type: System..::..String
Name of the account.
context
Type: Sitecore.Install.Framework..::..IProcessingContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Install.Security.AccountToEntryConverter.InternalConvert(System.String,Sitecore.Install.Framework.IProcessingContext)"]

See Also

AccountToEntryConverter Class
Sitecore.Install.Security Namespace


SaveUserProfile Method

[image]

Sitecore 6.4.1 API
AccountToEntryConverter..::..SaveUserProfile Method
AccountToEntryConverter Class See Also Send Feedback

Namespace: Sitecore.Install.Security
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected static void SaveUserProfile(
    User user,
    XmlWriter writer
)
Visual Basic
Protected Shared Sub SaveUserProfile ( _
    user As User, _
    writer As XmlWriter _
)
Visual C++
protected:
static void SaveUserProfile(
    User^ user,
    XmlWriter^ writer
)

Parameters

user
Type: Sitecore.Security.Accounts..::..User
The user.
writer
Type: System.Xml..::..XmlWriter
The writer.

See Also

AccountToEntryConverter Class
Sitecore.Install.Security Namespace


SaveUserProperties Method

[image]

Sitecore 6.4.1 API
AccountToEntryConverter..::..SaveUserProperties Method
AccountToEntryConverter Class See Also Send Feedback

Namespace: Sitecore.Install.Security
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected static void SaveUserProperties(
    User user,
    XmlWriter writer
)
Visual Basic
Protected Shared Sub SaveUserProperties ( _
    user As User, _
    writer As XmlWriter _
)
Visual C++
protected:
static void SaveUserProperties(
    User^ user,
    XmlWriter^ writer
)

Parameters

user
Type: Sitecore.Security.Accounts..::..User
The user.
writer
Type: System.Xml..::..XmlWriter
The writer.

See Also

AccountToEntryConverter Class
Sitecore.Install.Security Namespace


SaveUserRoles Method

[image]

Sitecore 6.4.1 API
AccountToEntryConverter..::..SaveUserRoles Method
AccountToEntryConverter Class See Also Send Feedback

Namespace: Sitecore.Install.Security
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected static void SaveUserRoles(
    User user,
    XmlWriter writer
)
Visual Basic
Protected Shared Sub SaveUserRoles ( _
    user As User, _
    writer As XmlWriter _
)
Visual C++
protected:
static void SaveUserRoles(
    User^ user,
    XmlWriter^ writer
)

Parameters

user
Type: Sitecore.Security.Accounts..::..User
The user.
writer
Type: System.Xml..::..XmlWriter
The writer.

See Also

AccountToEntryConverter Class
Sitecore.Install.Security Namespace


WriteProperty Method

[image]

Sitecore 6.4.1 API
AccountToEntryConverter..::..WriteProperty Method
AccountToEntryConverter Class See Also Send Feedback

Namespace: Sitecore.Install.Security
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected static void WriteProperty(
    string name,
    Object value,
    XmlWriter writer
)
Visual Basic
Protected Shared Sub WriteProperty ( _
    name As String, _
    value As Object, _
    writer As XmlWriter _
)
Visual C++
protected:
static void WriteProperty(
    String^ name,
    Object^ value,
    XmlWriter^ writer
)

Parameters

name
Type: System..::..String
The name.
value
Type: System..::..Object
The value.
writer
Type: System.Xml..::..XmlWriter
The writer.

See Also

AccountToEntryConverter Class
Sitecore.Install.Security Namespace


AccountToEntryConverter Properties

[image] [image]

Sitecore 6.4.1 API
AccountToEntryConverter Properties
AccountToEntryConverter Class See Also Send Feedback

The AccountToEntryConverter type exposes the following members.

Properties

 | Name | Description
Protected property | AutoApplyTransforms | Gets a value indicating whether the BaseConverter<(Of <(<'T>)>)> converter transforms should be applied by BaseConverter, not the derived class. (Inherited from BaseConverter<(Of <(<'T>)>)>.)
Public property | Transforms | Gets the transforms. (Inherited from BaseConverter<(Of <(<'T>)>)>.)

See Also

AccountToEntryConverter Class
Sitecore.Install.Security Namespace


IAccountInstallerEvents Interface

[image]

Sitecore 6.4.1 API
IAccountInstallerEvents Interface
Members See Also Send Feedback

Namespace: Sitecore.Install.Security
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IAccountInstallerEvents
Visual Basic
Public Interface IAccountInstallerEvents
Visual C++
public interface class IAccountInstallerEvents

See Also

IAccountInstallerEvents Members
Sitecore.Install.Security Namespace


IAccountInstallerEvents Members

[image] [image]

Sitecore 6.4.1 API
IAccountInstallerEvents Members
IAccountInstallerEvents Interface Methods See Also Send Feedback

The IAccountInstallerEvents type exposes the following members.

Methods

 | Name | Description
Public method | ShowWarning | Shows the warning.

See Also

IAccountInstallerEvents Interface
Sitecore.Install.Security Namespace


IAccountInstallerEvents Methods

[image] [image]

Sitecore 6.4.1 API
IAccountInstallerEvents Methods
IAccountInstallerEvents Interface See Also Send Feedback

The IAccountInstallerEvents type exposes the following members.

Methods

 | Name | Description
Public method | ShowWarning | Shows the warning.

See Also

IAccountInstallerEvents Interface
Sitecore.Install.Security Namespace


ShowWarning Method

[image]

Sitecore 6.4.1 API
IAccountInstallerEvents..::..ShowWarning Method
IAccountInstallerEvents Interface See Also Send Feedback

Namespace: Sitecore.Install.Security
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void ShowWarning(
    string message,
    string warningType
)
Visual Basic
Sub ShowWarning ( _
    message As String, _
    warningType As String _
)
Visual C++
void ShowWarning(
    String^ message,
    String^ warningType
)

Parameters

message
Type: System..::..String
The message.
warningType
Type: System..::..String
Type of the warning. Meaning is that message of one type can be ignored.

See Also

IAccountInstallerEvents Interface
Sitecore.Install.Security Namespace


SecuritySource Class

[image]

Sitecore 6.4.1 API
SecuritySource Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Security
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SecuritySource : BaseSource<string>,
    IExplicitSource, IKeyResolver
Visual Basic
Public Class SecuritySource _
    Inherits BaseSource(Of String) _
    Implements IExplicitSource, IKeyResolver
Visual C++
public ref class SecuritySource : public BaseSource<String^>,
    IExplicitSource, IKeyResolver

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..BaseSource <(Of <(<' String >)>)>
Sitecore.Install.Security..::..SecuritySource

See Also

SecuritySource Members
Sitecore.Install.Security Namespace


SecuritySource Members

[image] [image]

Sitecore 6.4.1 API
SecuritySource Members
SecuritySource Class Constructors Methods Properties See Also Send Feedback

The SecuritySource type exposes the following members.

Constructors

 | Name | Description
Public method | SecuritySource | Initializes a new instance of the SecuritySource class.

Methods

 | Name | Description
Public method | AddAccount | Adds the account.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InternalPopulate | Populates internal sink (Overrides BaseSource<(Of <(<'T>)>)>..::..InternalPopulate(ISink<(Of <<'(T>)>>)).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Populates this sourse from the specified sink. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public method | ResolveKey | Returns string.Empty if the account exists, otherwice returns null
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Converter | Gets or sets the converter. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Entries | Gets the entries.
Public property | Exclude | Gets the exclude filters. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Include | Gets the include filters. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Name | Gets or sets the name. (Inherited from BaseSource<(Of <(<'T>)>)>.)

See Also

SecuritySource Class
Sitecore.Install.Security Namespace


SecuritySource Constructor

[image]

Sitecore 6.4.1 API
SecuritySource Constructor
SecuritySource Class See Also Send Feedback

Namespace: Sitecore.Install.Security
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SecuritySource()
Visual Basic
Public Sub New
Visual C++
public:
SecuritySource()

See Also

SecuritySource Class
Sitecore.Install.Security Namespace


InternalPopulate Method

[image]

Sitecore 6.4.1 API
SecuritySource..::..InternalPopulate Method
SecuritySource Class See Also Send Feedback

Namespace: Sitecore.Install.Security
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void InternalPopulate(
    ISink<string> sink
)
Visual Basic
Protected Overrides Sub InternalPopulate ( _
    sink As ISink(Of String) _
)
Visual C++
protected:
virtual void InternalPopulate(
    ISink<String^>^ sink
) override

Parameters

sink
Type: Sitecore.Install.Framework..::..ISink <(Of <(<' String >)>)>
The sink

See Also

SecuritySource Class
Sitecore.Install.Security Namespace


SecuritySource Properties

[image] [image]

Sitecore 6.4.1 API
SecuritySource Properties
SecuritySource Class See Also Send Feedback

The SecuritySource type exposes the following members.

Properties

 | Name | Description
Public property | Converter | Gets or sets the converter. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Entries | Gets the entries.
Public property | Exclude | Gets the exclude filters. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Include | Gets the include filters. (Inherited from BaseSource<(Of <(<'T>)>)>.)
Public property | Name | Gets or sets the name. (Inherited from BaseSource<(Of <(<'T>)>)>.)

See Also

SecuritySource Class
Sitecore.Install.Security Namespace


Entries Property

[image]

Sitecore 6.4.1 API
SecuritySource..::..Entries Property
SecuritySource Class See Also Send Feedback

Namespace: Sitecore.Install.Security
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IList<string> Entries { get; }
Visual Basic
Public ReadOnly Property Entries As IList(Of String)
    Get
Visual C++
public:
virtual property IList<String^>^ Entries {
    IList<String^>^ get () sealed;
}

Field Value

The entries.

Implements

IExplicitSource..::..Entries

See Also

SecuritySource Class
Sitecore.Install.Security Namespace


IOUtils Class

[image]

Sitecore 6.4.1 API
IOUtils Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class IOUtils
Visual Basic
Public NotInheritable Class IOUtils
Visual C++
public ref class IOUtils abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Serialization..::..IOUtils

See Also

IOUtils Members
Sitecore.Install.Serialization Namespace


IOUtils Members

[image] [image]

Sitecore 6.4.1 API
IOUtils Members
IOUtils Class Methods Properties See Also Send Feedback

The IOUtils type exposes the following members.

Methods

Name | Description
LoadObject | Deserializes an object from string.
LoadSolution | Deseliaziles a solution from string.
StoreObject(Object) | Serializes the object to a string.
StoreObject(Object, Formatting) | Serializes the specifyed object to a string. The string will contain an xml code.
StoreSolution | Serializes the solution to a string.

Properties

Name | Description
SerializationContext | Gets the serialization context.

See Also

IOUtils Class
Sitecore.Install.Serialization Namespace


IOUtils Methods

[image] [image]

Sitecore 6.4.1 API
IOUtils Methods
IOUtils Class See Also Send Feedback

The IOUtils type exposes the following members.

Methods

Name | Description
LoadObject | Deserializes an object from string.
LoadSolution | Deseliaziles a solution from string.
StoreObject(Object) | Serializes the object to a string.
StoreObject(Object, Formatting) | Serializes the specifyed object to a string. The string will contain an xml code.
StoreSolution | Serializes the solution to a string.

See Also

IOUtils Class
Sitecore.Install.Serialization Namespace


LoadObject Method

[image]

Sitecore 6.4.1 API
IOUtils..::..LoadObject Method
IOUtils Class See Also Send Feedback

Namespace: Sitecore.Install.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object LoadObject(
    string stream
)
Visual Basic
Public Shared Function LoadObject ( _
    stream As String _
) As Object
Visual C++
public:
static Object^ LoadObject(
    String^ stream
)

Parameters

stream
Type: System..::..String
The stream.

Return Value

The deserialized object.

See Also

IOUtils Class
Sitecore.Install.Serialization Namespace


LoadSolution Method

[image]

Sitecore 6.4.1 API
IOUtils..::..LoadSolution Method
IOUtils Class See Also Send Feedback

Namespace: Sitecore.Install.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PackageProject LoadSolution(
    string stream
)
Visual Basic
Public Shared Function LoadSolution ( _
    stream As String _
) As PackageProject
Visual C++
public:
static PackageProject^ LoadSolution(
    String^ stream
)

Parameters

stream
Type: System..::..String
The stream with a serialized solution.

Return Value

The solution.

See Also

IOUtils Class
Sitecore.Install.Serialization Namespace


StoreObject Method

[image] [image]

Sitecore 6.4.1 API
IOUtils..::..StoreObject Method
IOUtils Class See Also Send Feedback

Overload List

Name | Description
StoreObject(Object) | Serializes the object to a string.
StoreObject(Object, Formatting) | Serializes the specifyed object to a string. The string will contain an xml code.

See Also

IOUtils Class
IOUtils Members
Sitecore.Install.Serialization Namespace


StoreObject Method (Object)

[image]

Sitecore 6.4.1 API
IOUtils..::..StoreObject Method (Object)
IOUtils Class See Also Send Feedback

Namespace: Sitecore.Install.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string StoreObject(
    Object instance
)
Visual Basic
Public Shared Function StoreObject ( _
    instance As Object _
) As String
Visual C++
public:
static String^ StoreObject(
    Object^ instance
)

Parameters

instance
Type: System..::..Object
The instance.

Return Value

The object.

See Also

IOUtils Class
StoreObject Overload
Sitecore.Install.Serialization Namespace


StoreObject Method (Object, Formatting)

[image]

Sitecore 6.4.1 API
IOUtils..::..StoreObject Method (Object, Formatting)
IOUtils Class See Also Send Feedback

Namespace: Sitecore.Install.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string StoreObject(
    Object instance,
    Formatting formatting
)
Visual Basic
Public Shared Function StoreObject ( _
    instance As Object, _
    formatting As Formatting _
) As String
Visual C++
public:
static String^ StoreObject(
    Object^ instance,
    Formatting formatting
)

Parameters

instance
Type: System..::..Object
The instance.
formatting
Type: System.Xml..::..Formatting
The xml formatting to be used.

Return Value

The object serialized into a string.

See Also

IOUtils Class
StoreObject Overload
Sitecore.Install.Serialization Namespace


StoreSolution Method

[image]

Sitecore 6.4.1 API
IOUtils..::..StoreSolution Method
IOUtils Class See Also Send Feedback

Namespace: Sitecore.Install.Serialization
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string StoreSolution(
    PackageProject solution
)
Visual Basic
Public Shared Function StoreSolution ( _
    solution As PackageProject _
) As String
Visual C++
public:
static String^ StoreSolution(
    PackageProject^ solution
)

Parameters

solution
Type: Sitecore.Install..::..PackageProject
The solution.

Return Value

The serialized solution.

See Also

IOUtils Class
Sitecore.Install.Serialization Namespace


IOUtils Properties

[image] [image]

Sitecore 6.4.1 API
IOUtils Properties
IOUtils Class See Also Send Feedback

The IOUtils type exposes the following members.

Properties

Name | Description
SerializationContext | Gets the serialization context.

See Also

IOUtils Class
Sitecore.Install.Serialization Namespace


Sitecore.Install.Utils Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Install.Utils Namespace
Send Feedback

Classes

 | Class | Description
Public class | BehaviourOptions | Defines behavior answering what to do with collision
Public class | EntrySorter | Entry sorter
Public class | Files | Utility to work with files
Public class | InstallationException | An installation error.
Public class | InstallerMarker | Add an entry with a installer version to a sink
Public class | InstallerVersion | Contains methods to work with versions of the instraller
Public class | ItemInfo | Item iformation
Public class | SitecoreLogger | Wrapper for Sitecore.Diagnostics.Log class
Public class | StatusFile | Wrapper around a file-based one-way communication channel.
Public class | StatusFile..::..StatusInfo | Encapsulates status information passed from packaground worker.
Public class | StringEntryData | String entry data
Public class | StrongStreamHolder | Strong stream holder.
Public class | Uniq | Strips adjacent duplicate entries in the package
Public class | WeakStreamHolder | Weak stream holder. Contains a reference to one stream
Public class | XmlVersionParser | Xml version parser

Enumerations

 | Enumeration | Description
Public enumeration | InstallMode | Defines what to do with an item in collision
Public enumeration | MergeMode | Defines item merge mode
Public enumeration | PackageUser | Package user type
Public enumeration | StatusFile..::..Status | Represents status of the operation.


BehaviourOptions Class

[image]

Sitecore 6.4.1 API
BehaviourOptions Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class BehaviourOptions
Visual Basic
Public Class BehaviourOptions
Visual C++
public ref class BehaviourOptions

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Utils..::..BehaviourOptions

See Also

BehaviourOptions Members
Sitecore.Install.Utils Namespace


BehaviourOptions Members

[image] [image]

Sitecore 6.4.1 API
BehaviourOptions Members
BehaviourOptions Class Constructors Methods Properties See Also Send Feedback

The BehaviourOptions type exposes the following members.

Constructors

 | Name | Description
Public method | BehaviourOptions()()()() | Initializes a new instance of the BehaviourOptions class.
Public method | BehaviourOptions(IDictionary<(Of <<'(String, String>)>>), String) | Initializes a new instance of the BehaviourOptions class.
Public method | BehaviourOptions(InstallMode, MergeMode) | Initializes a new instance of the BehaviourOptions class.

Methods

 | Name | Description
Public method | Assign | Assigns the specified options.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersionInstallMode | Gets the version install mode.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsDefined | Gets a value indicating whether merge mode is defined.
Public property | ItemMergeMode | Gets or sets the item merge mode.
Public property | ItemMode | Gets or sets the item mode.

See Also

BehaviourOptions Class
Sitecore.Install.Utils Namespace


BehaviourOptions Constructor

[image] [image]

Sitecore 6.4.1 API
BehaviourOptions Constructor
BehaviourOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BehaviourOptions()()()() | Initializes a new instance of the BehaviourOptions class.
Public method | BehaviourOptions(IDictionary<(Of <<'(String, String>)>>), String) | Initializes a new instance of the BehaviourOptions class.
Public method | BehaviourOptions(InstallMode, MergeMode) | Initializes a new instance of the BehaviourOptions class.

See Also

BehaviourOptions Class
BehaviourOptions Members
Sitecore.Install.Utils Namespace


BehaviourOptions Constructor

[image]

Sitecore 6.4.1 API
BehaviourOptions Constructor
BehaviourOptions Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BehaviourOptions()
Visual Basic
Public Sub New
Visual C++
public:
BehaviourOptions()

See Also

BehaviourOptions Class
BehaviourOptions Overload
Sitecore.Install.Utils Namespace


BehaviourOptions Constructor (InstallMode, MergeMode)

[image]

Sitecore 6.4.1 API
BehaviourOptions Constructor (InstallMode, MergeMode)
BehaviourOptions Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BehaviourOptions(
    InstallMode installMode,
    MergeMode mergeMode
)
Visual Basic
Public Sub New ( _
    installMode As InstallMode, _
    mergeMode As MergeMode _
)
Visual C++
public:
BehaviourOptions(
    InstallMode installMode,
    MergeMode mergeMode
)

Parameters

installMode
Type: Sitecore.Install.Utils..::..InstallMode
The install mode.
mergeMode
Type: Sitecore.Install.Utils..::..MergeMode
The merge mode.

See Also

BehaviourOptions Class
BehaviourOptions Overload
Sitecore.Install.Utils Namespace


BehaviourOptions Methods

[image] [image]

Sitecore 6.4.1 API
BehaviourOptions Methods
BehaviourOptions Class See Also Send Feedback

The BehaviourOptions type exposes the following members.

Methods

 | Name | Description
Public method | Assign | Assigns the specified options.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersionInstallMode | Gets the version install mode.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BehaviourOptions Class
Sitecore.Install.Utils Namespace


Assign Method

[image]

Sitecore 6.4.1 API
BehaviourOptions..::..Assign Method
BehaviourOptions Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Assign(
    BehaviourOptions options
)
Visual Basic
Public Sub Assign ( _
    options As BehaviourOptions _
)
Visual C++
public:
void Assign(
    BehaviourOptions^ options
)

Parameters

options
Type: Sitecore.Install.Utils..::..BehaviourOptions
The options.

See Also

BehaviourOptions Class
Sitecore.Install.Utils Namespace


GetVersionInstallMode Method

[image]

Sitecore 6.4.1 API
BehaviourOptions..::..GetVersionInstallMode Method
BehaviourOptions Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public VersionInstallMode GetVersionInstallMode()
Visual Basic
Public Function GetVersionInstallMode As VersionInstallMode
Visual C++
public:
VersionInstallMode GetVersionInstallMode()

Return Value

The version install mode.

See Also

BehaviourOptions Class
Sitecore.Install.Utils Namespace


BehaviourOptions Properties

[image] [image]

Sitecore 6.4.1 API
BehaviourOptions Properties
BehaviourOptions Class See Also Send Feedback

The BehaviourOptions type exposes the following members.

Properties

 | Name | Description
Public property | IsDefined | Gets a value indicating whether merge mode is defined.
Public property | ItemMergeMode | Gets or sets the item merge mode.
Public property | ItemMode | Gets or sets the item mode.

See Also

BehaviourOptions Class
Sitecore.Install.Utils Namespace


IsDefined Property

[image]

Sitecore 6.4.1 API
BehaviourOptions..::..IsDefined Property
BehaviourOptions Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsDefined { get; }
Visual Basic
Public ReadOnly Property IsDefined As Boolean
    Get
Visual C++
public:
property bool IsDefined {
    bool get ();
}

Field Value

true if this merge mode is defined; otherwise, false.

See Also

BehaviourOptions Class
Sitecore.Install.Utils Namespace


ItemMergeMode Property

[image]

Sitecore 6.4.1 API
BehaviourOptions..::..ItemMergeMode Property
BehaviourOptions Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MergeMode ItemMergeMode { get; set; }
Visual Basic
Public Property ItemMergeMode As MergeMode
    Get
    Set
Visual C++
public:
property MergeMode ItemMergeMode {
    MergeMode get ();
    void set (MergeMode value);
}

Field Value

The item merge mode.

See Also

BehaviourOptions Class
Sitecore.Install.Utils Namespace


ItemMode Property

[image]

Sitecore 6.4.1 API
BehaviourOptions..::..ItemMode Property
BehaviourOptions Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public InstallMode ItemMode { get; set; }
Visual Basic
Public Property ItemMode As InstallMode
    Get
    Set
Visual C++
public:
property InstallMode ItemMode {
    InstallMode get ();
    void set (InstallMode value);
}

Field Value

The item mode.

See Also

BehaviourOptions Class
Sitecore.Install.Utils Namespace


EntrySorter Members

[image] [image]

Sitecore 6.4.1 API
EntrySorter Members
EntrySorter Class Constructors Methods Fields Properties See Also Send Feedback

The EntrySorter type exposes the following members.

Constructors

 | Name | Description
Public method | EntrySorter | Initializes a new instance of the EntrySorter class.

Methods

 | Name | Description
Protected method | AssertInit | Asserts the init. (Inherited from BaseSink<(Of <(<'T>)>)>.)
 | ClearCache | Clears the cache.
 | CompareEntries | Compares the entries.
 | CompareKeys | Compares the keys.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finishes the sink. (Overrides BaseSink<(Of <(<'T>)>)>..::..Finish()()()().)
Public method | Flush | Flushes the sink (Overrides BaseSink<(Of <(<'T>)>)>..::..Flush()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this instance. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Populates specified sink from this sourse.
Public method | Put | Puts the specified entry. (Overrides BaseSink<(Of <(<'T>)>)>..::..Put(T).)
 | SetKeyProvider | Sets the key provider.
 | SetSectionOrder | Sets the section order.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _processingContext | (Inherited from BaseSink<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(<'T>)>)>.)
 | KeyCache | Gets the key cache.
Public property | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

EntrySorter Class
Sitecore.Install.Utils Namespace


EntrySorter Constructor

[image]

Sitecore 6.4.1 API
EntrySorter Constructor
EntrySorter Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public EntrySorter(
    ISource<PackageEntry> baseSource
)
Visual Basic
Public Sub New ( _
    baseSource As ISource(Of PackageEntry) _
)
Visual C++
public:
EntrySorter(
    ISource<PackageEntry^>^ baseSource
)

Parameters

baseSource
Type: Sitecore.Install.Framework..::..ISource <(Of <(<' PackageEntry >)>)>
The base source.

See Also

EntrySorter Class
Sitecore.Install.Utils Namespace


EntrySorter Fields

[image] [image]

Sitecore 6.4.1 API
EntrySorter Fields
EntrySorter Class See Also Send Feedback

The EntrySorter type exposes the following members.

Fields

 | Name | Description
Protected field | _processingContext | (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

EntrySorter Class
Sitecore.Install.Utils Namespace


EntrySorter Methods

[image] [image]

Sitecore 6.4.1 API
EntrySorter Methods
EntrySorter Class See Also Send Feedback

The EntrySorter type exposes the following members.

Methods

 | Name | Description
Protected method | AssertInit | Asserts the init. (Inherited from BaseSink<(Of <(<'T>)>)>.)
 | ClearCache | Clears the cache.
 | CompareEntries | Compares the entries.
 | CompareKeys | Compares the keys.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finishes the sink. (Overrides BaseSink<(Of <(<'T>)>)>..::..Finish()()()().)
Public method | Flush | Flushes the sink (Overrides BaseSink<(Of <(<'T>)>)>..::..Flush()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this instance. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Populates specified sink from this sourse.
Public method | Put | Puts the specified entry. (Overrides BaseSink<(Of <(<'T>)>)>..::..Put(T).)
 | SetKeyProvider | Sets the key provider.
 | SetSectionOrder | Sets the section order.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EntrySorter Class
Sitecore.Install.Utils Namespace


ClearCache Method

[image]

Sitecore 6.4.1 API
EntrySorter..::..ClearCache Method
EntrySorter Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void ClearCache()
Visual Basic
Public Shared Sub ClearCache
Visual C++
public:
static void ClearCache()

See Also

EntrySorter Class
Sitecore.Install.Utils Namespace


CompareEntries Method

[image]

Sitecore 6.4.1 API
EntrySorter..::..CompareEntries Method
EntrySorter Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int CompareEntries(
    PackageEntry left,
    PackageEntry right
)
Visual Basic
Public Shared Function CompareEntries ( _
    left As PackageEntry, _
    right As PackageEntry _
) As Integer
Visual C++
public:
static int CompareEntries(
    PackageEntry^ left,
    PackageEntry^ right
)

Parameters

left
Type: Sitecore.Install.Framework..::..PackageEntry
The left.
right
Type: Sitecore.Install.Framework..::..PackageEntry
The right.

Return Value

[Missing <returns> documentation for "M:Sitecore.Install.Utils.EntrySorter.CompareEntries(Sitecore.Install.Framework.PackageEntry,Sitecore.Install.Framework.PackageEntry)"]

See Also

EntrySorter Class
Sitecore.Install.Utils Namespace


CompareKeys Method

[image]

Sitecore 6.4.1 API
EntrySorter..::..CompareKeys Method
EntrySorter Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int CompareKeys(
    string left,
    string right
)
Visual Basic
Public Shared Function CompareKeys ( _
    left As String, _
    right As String _
) As Integer
Visual C++
public:
static int CompareKeys(
    String^ left,
    String^ right
)

Parameters

left
Type: System..::..String
The left.
right
Type: System..::..String
The right.

Return Value

[Missing <returns> documentation for "M:Sitecore.Install.Utils.EntrySorter.CompareKeys(System.String,System.String)"]

See Also

EntrySorter Class
Sitecore.Install.Utils Namespace


Finish Method

[image]

Sitecore 6.4.1 API
EntrySorter..::..Finish Method
EntrySorter Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Finish()
Visual Basic
Public Overrides Sub Finish
Visual C++
public:
virtual void Finish() override

Implements

ISink<(Of <(<'T>)>)>..::..Finish()()()()

See Also

EntrySorter Class
Sitecore.Install.Utils Namespace


Flush Method

[image]

Sitecore 6.4.1 API
EntrySorter..::..Flush Method
EntrySorter Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Flush()
Visual Basic
Public Overrides Sub Flush
Visual C++
public:
virtual void Flush() override

Implements

ISink<(Of <(<'T>)>)>..::..Flush()()()()

See Also

EntrySorter Class
Sitecore.Install.Utils Namespace


Populate Method

[image]

Sitecore 6.4.1 API
EntrySorter..::..Populate Method
EntrySorter Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Populate(
    ISink<PackageEntry> sink
)
Visual Basic
Public Sub Populate ( _
    sink As ISink(Of PackageEntry) _
)
Visual C++
public:
virtual void Populate(
    ISink<PackageEntry^>^ sink
) sealed

Parameters

sink
Type: Sitecore.Install.Framework..::..ISink <(Of <(<' PackageEntry >)>)>
The sink.

Implements

ISource<(Of <(<'T>)>)>..::..Populate(ISink<(Of <<'(T>)>>))

See Also

EntrySorter Class
Sitecore.Install.Utils Namespace


Put Method

[image]

Sitecore 6.4.1 API
EntrySorter..::..Put Method
EntrySorter Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Put(
    PackageEntry entry
)
Visual Basic
Public Overrides Sub Put ( _
    entry As PackageEntry _
)
Visual C++
public:
virtual void Put(
    PackageEntry^ entry
) override

Parameters

entry
Type: Sitecore.Install.Framework..::..PackageEntry
The entry.

Implements

ISink<(Of <(<'T>)>)>..::..Put(T)

See Also

EntrySorter Class
Sitecore.Install.Utils Namespace


SetKeyProvider Method

[image]

Sitecore 6.4.1 API
EntrySorter..::..SetKeyProvider Method
EntrySorter Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void SetKeyProvider(
    string key,
    ISortingKeyProvider provider
)
Visual Basic
Public Shared Sub SetKeyProvider ( _
    key As String, _
    provider As ISortingKeyProvider _
)
Visual C++
public:
static void SetKeyProvider(
    String^ key,
    ISortingKeyProvider^ provider
)

Parameters

key
Type: System..::..String
The key.
provider
Type: Sitecore.Install.Framework..::..ISortingKeyProvider
The provider.

See Also

EntrySorter Class
Sitecore.Install.Utils Namespace


SetSectionOrder Method

[image]

Sitecore 6.4.1 API
EntrySorter..::..SetSectionOrder Method
EntrySorter Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void SetSectionOrder(
    string sectionName,
    string order
)
Visual Basic
Public Shared Sub SetSectionOrder ( _
    sectionName As String, _
    order As String _
)
Visual C++
public:
static void SetSectionOrder(
    String^ sectionName,
    String^ order
)

Parameters

sectionName
Type: System..::..String
Name of the section.
order
Type: System..::..String
The order.

See Also

EntrySorter Class
Sitecore.Install.Utils Namespace


EntrySorter Properties

[image] [image]

Sitecore 6.4.1 API
EntrySorter Properties
EntrySorter Class See Also Send Feedback

The EntrySorter type exposes the following members.

Properties

 | Name | Description
Public property | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(<'T>)>)>.)
 | KeyCache | Gets the key cache.
Public property | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

EntrySorter Class
Sitecore.Install.Utils Namespace


KeyCache Property

[image]

Sitecore 6.4.1 API
EntrySorter..::..KeyCache Property
EntrySorter Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected static Dictionary<string, SortingKey> KeyCache { get; }
Visual Basic
Protected Shared ReadOnly Property KeyCache As Dictionary(Of String, SortingKey)
    Get
Visual C++
protected:
static property Dictionary<String^, SortingKey^>^ KeyCache {
    Dictionary<String^, SortingKey^>^ get ();
}

Field Value

The key cache.

See Also

EntrySorter Class
Sitecore.Install.Utils Namespace


Files Class

[image]

Sitecore 6.4.1 API
Files Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Files
Visual Basic
Public NotInheritable Class Files
Visual C++
public ref class Files abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Utils..::..Files

See Also

Files Members
Sitecore.Install.Utils Namespace


Files Members

[image] [image]

Sitecore 6.4.1 API
Files Members
Files Class Methods See Also Send Feedback

The Files type exposes the following members.

Methods

Name | Description
OpenFile | Opens the file wiht FileBrowser application.
UploadToDirectory | Shows "upload to directory" dialog.

See Also

Files Class
Sitecore.Install.Utils Namespace


Files Methods

[image] [image]

Sitecore 6.4.1 API
Files Methods
Files Class See Also Send Feedback

The Files type exposes the following members.

Methods

Name | Description
OpenFile | Opens the file wiht FileBrowser application.
UploadToDirectory | Shows "upload to directory" dialog.

See Also

Files Class
Sitecore.Install.Utils Namespace


OpenFile Method

[image]

Sitecore 6.4.1 API
Files..::..OpenFile Method
Files Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void OpenFile(
    string header,
    string text,
    string icon,
    string button,
    string root,
    string directory,
    string selected,
    string filter
)
Visual Basic
Public Shared Sub OpenFile ( _
    header As String, _
    text As String, _
    icon As String, _
    button As String, _
    root As String, _
    directory As String, _
    selected As String, _
    filter As String _
)
Visual C++
public:
static void OpenFile(
    String^ header,
    String^ text,
    String^ icon,
    String^ button,
    String^ root,
    String^ directory,
    String^ selected,
    String^ filter
)

Parameters

header
Type: System..::..String
The header.
text
Type: System..::..String
The text.
icon
Type: System..::..String
The icon.
button
Type: System..::..String
The button.
root
Type: System..::..String
The root.
directory
Type: System..::..String
The directory.
selected
Type: System..::..String
The selected.
filter
Type: System..::..String
The filter.

See Also

Files Class
Sitecore.Install.Utils Namespace


UploadToDirectory Method

[image]

Sitecore 6.4.1 API
Files..::..UploadToDirectory Method
Files Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void UploadToDirectory(
    string directory
)
Visual Basic
Public Shared Sub UploadToDirectory ( _
    directory As String _
)
Visual C++
public:
static void UploadToDirectory(
    String^ directory
)

Parameters

directory
Type: System..::..String
The directory.

See Also

Files Class
Sitecore.Install.Utils Namespace


InstallationException Class

[image]

Sitecore 6.4.1 API
InstallationException Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class InstallationException : Exception
Visual Basic
Public Class InstallationException _
    Inherits Exception
Visual C++
public ref class InstallationException : public Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
Sitecore.Install.Utils..::..InstallationException

See Also

InstallationException Members
Sitecore.Install.Utils Namespace


InstallationException Members

[image] [image]

Sitecore 6.4.1 API
InstallationException Members
InstallationException Class Constructors Methods Properties See Also Send Feedback

The InstallationException type exposes the following members.

Constructors

 | Name | Description
Public method | InstallationException(String) | Initializes a new instance of the InstallationException class.
Public method | InstallationException(String, Exception) | Initializes a new instance of the InstallationException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InstallationException Class
Sitecore.Install.Utils Namespace


InstallationException Constructor

[image] [image]

Sitecore 6.4.1 API
InstallationException Constructor
InstallationException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InstallationException(String) | Initializes a new instance of the InstallationException class.
Public method | InstallationException(String, Exception) | Initializes a new instance of the InstallationException class.

See Also

InstallationException Class
InstallationException Members
Sitecore.Install.Utils Namespace


InstallationException Constructor (String)

[image]

Sitecore 6.4.1 API
InstallationException Constructor (String)
InstallationException Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public InstallationException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
InstallationException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

InstallationException Class
InstallationException Overload
Sitecore.Install.Utils Namespace


InstallationException Constructor (String, Exception)

[image]

Sitecore 6.4.1 API
InstallationException Constructor (String, Exception)
InstallationException Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public InstallationException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
InstallationException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

InstallationException Class
InstallationException Overload
Sitecore.Install.Utils Namespace


InstallationException Methods

[image] [image]

Sitecore 6.4.1 API
InstallationException Methods
InstallationException Class See Also Send Feedback

The InstallationException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InstallationException Class
Sitecore.Install.Utils Namespace


InstallationException Properties

[image] [image]

Sitecore 6.4.1 API
InstallationException Properties
InstallationException Class See Also Send Feedback

The InstallationException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InstallationException Class
Sitecore.Install.Utils Namespace


InstallerMarker Class

[image]

Sitecore 6.4.1 API
InstallerMarker Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class InstallerMarker : ISource<PackageEntry>
Visual Basic
Public Class InstallerMarker _
    Implements ISource(Of PackageEntry)
Visual C++
public ref class InstallerMarker : ISource<PackageEntry^>

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Utils..::..InstallerMarker

See Also

InstallerMarker Members
Sitecore.Install.Utils Namespace


InstallerMarker Members

[image] [image]

Sitecore 6.4.1 API
InstallerMarker Members
InstallerMarker Class Constructors Methods See Also Send Feedback

The InstallerMarker type exposes the following members.

Constructors

 | Name | Description
Public method | InstallerMarker | Initializes a new instance of the InstallerMarker class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Add an entry with a installer version to a sink.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InstallerMarker Class
Sitecore.Install.Utils Namespace


InstallerMarker Constructor

[image]

Sitecore 6.4.1 API
InstallerMarker Constructor
InstallerMarker Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public InstallerMarker()
Visual Basic
Public Sub New
Visual C++
public:
InstallerMarker()

See Also

InstallerMarker Class
Sitecore.Install.Utils Namespace


InstallerMarker Methods

[image] [image]

Sitecore 6.4.1 API
InstallerMarker Methods
InstallerMarker Class See Also Send Feedback

The InstallerMarker type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Add an entry with a installer version to a sink.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InstallerMarker Class
Sitecore.Install.Utils Namespace


Populate Method

[image]

Sitecore 6.4.1 API
InstallerMarker..::..Populate Method
InstallerMarker Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Populate(
    ISink<PackageEntry> sink
)
Visual Basic
Public Sub Populate ( _
    sink As ISink(Of PackageEntry) _
)
Visual C++
public:
virtual void Populate(
    ISink<PackageEntry^>^ sink
) sealed

Parameters

sink
Type: Sitecore.Install.Framework..::..ISink <(Of <(<' PackageEntry >)>)>
The sink.

Implements

ISource<(Of <(<'T>)>)>..::..Populate(ISink<(Of <<'(T>)>>))

See Also

InstallerMarker Class
Sitecore.Install.Utils Namespace


InstallerVersion Class

[image]

Sitecore 6.4.1 API
InstallerVersion Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class InstallerVersion
Visual Basic
Public NotInheritable Class InstallerVersion
Visual C++
public ref class InstallerVersion abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Utils..::..InstallerVersion

See Also

InstallerVersion Members
Sitecore.Install.Utils Namespace


InstallerVersion Members

[image] [image]

Sitecore 6.4.1 API
InstallerVersion Members
InstallerVersion Class Methods See Also Send Feedback

The InstallerVersion type exposes the following members.

Methods

Name | Description
CanHandleVersion | Determines whether this version of packager can handle the specified package version.
GetInstallerVersion | Gets the installer version.

See Also

InstallerVersion Class
Sitecore.Install.Utils Namespace


InstallerVersion Methods

[image] [image]

Sitecore 6.4.1 API
InstallerVersion Methods
InstallerVersion Class See Also Send Feedback

The InstallerVersion type exposes the following members.

Methods

Name | Description
CanHandleVersion | Determines whether this version of packager can handle the specified package version.
GetInstallerVersion | Gets the installer version.

See Also

InstallerVersion Class
Sitecore.Install.Utils Namespace


CanHandleVersion Method

[image]

Sitecore 6.4.1 API
InstallerVersion..::..CanHandleVersion Method
InstallerVersion Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool CanHandleVersion(
    string packageVersion
)
Visual Basic
Public Shared Function CanHandleVersion ( _
    packageVersion As String _
) As Boolean
Visual C++
public:
static bool CanHandleVersion(
    String^ packageVersion
)

Parameters

packageVersion
Type: System..::..String
The package version.

Return Value

[Missing <returns> documentation for "M:Sitecore.Install.Utils.InstallerVersion.CanHandleVersion(System.String)"]

See Also

InstallerVersion Class
Sitecore.Install.Utils Namespace


GetInstallerVersion Method

[image]

Sitecore 6.4.1 API
InstallerVersion..::..GetInstallerVersion Method
InstallerVersion Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetInstallerVersion()
Visual Basic
Public Shared Function GetInstallerVersion As String
Visual C++
public:
static String^ GetInstallerVersion()

Return Value

The installer version.

See Also

InstallerVersion Class
Sitecore.Install.Utils Namespace


InstallMode Enumeration

[image]

Sitecore 6.4.1 API
InstallMode Enumeration
See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum InstallMode
Visual Basic
Public Enumeration InstallMode
Visual C++
public enum class InstallMode

Members

Member name | Value | Description
Overwrite | 1 | Delete item -> add item from template -> append versions
Merge | 2 | See ItemMergeVersionMode acions
Skip | 3 | Skips item
SideBySide | 4 | Installs new item with same path but different ID (for path collision only)
Undefined | 0 |

See Also

Sitecore.Install.Utils Namespace


ItemInfo Class

[image]

Sitecore 6.4.1 API
ItemInfo Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemInfo
Visual Basic
Public Class ItemInfo
Visual C++
public ref class ItemInfo

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Utils..::..ItemInfo

See Also

ItemInfo Members
Sitecore.Install.Utils Namespace


ItemInfo Members

[image] [image]

Sitecore 6.4.1 API
ItemInfo Members
ItemInfo Class Constructors Methods Properties See Also Send Feedback

The ItemInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ItemInfo(Item) | Initializes a new instance of the ItemInfo class.
Public method | ItemInfo(ItemReference, XmlVersionParser) | Initializes a new instance of the ItemInfo class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ID | Gets the ID.
Public property | Path | Gets the path.
Public property | TemplateID | Gets the template ID.

See Also

ItemInfo Class
Sitecore.Install.Utils Namespace


ItemInfo Constructor

[image] [image]

Sitecore 6.4.1 API
ItemInfo Constructor
ItemInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ItemInfo(Item) | Initializes a new instance of the ItemInfo class.
Public method | ItemInfo(ItemReference, XmlVersionParser) | Initializes a new instance of the ItemInfo class.

See Also

ItemInfo Class
ItemInfo Members
Sitecore.Install.Utils Namespace


ItemInfo Constructor (Item)

[image]

Sitecore 6.4.1 API
ItemInfo Constructor (Item)
ItemInfo Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemInfo(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
ItemInfo(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

ItemInfo Class
ItemInfo Overload
Sitecore.Install.Utils Namespace


ItemInfo Constructor (ItemReference, XmlVersionParser)

[image]

Sitecore 6.4.1 API
ItemInfo Constructor (ItemReference, XmlVersionParser)
ItemInfo Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemInfo(
    ItemReference reference,
    XmlVersionParser parser
)
Visual Basic
Public Sub New ( _
    reference As ItemReference, _
    parser As XmlVersionParser _
)
Visual C++
public:
ItemInfo(
    ItemReference^ reference,
    XmlVersionParser^ parser
)

Parameters

reference
Type: Sitecore.Install.Items..::..ItemReference
The reference.
parser
Type: Sitecore.Install.Utils..::..XmlVersionParser
The parser.

See Also

ItemInfo Class
ItemInfo Overload
Sitecore.Install.Utils Namespace


ItemInfo Methods

[image] [image]

Sitecore 6.4.1 API
ItemInfo Methods
ItemInfo Class See Also Send Feedback

The ItemInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemInfo Class
Sitecore.Install.Utils Namespace


ItemInfo Properties

[image] [image]

Sitecore 6.4.1 API
ItemInfo Properties
ItemInfo Class See Also Send Feedback

The ItemInfo type exposes the following members.

Properties

 | Name | Description
Public property | ID | Gets the ID.
Public property | Path | Gets the path.
Public property | TemplateID | Gets the template ID.

See Also

ItemInfo Class
Sitecore.Install.Utils Namespace


ID Property

[image]

Sitecore 6.4.1 API
ItemInfo..::..ID Property
ItemInfo Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ID { get; }
Visual Basic
Public ReadOnly Property ID As String
    Get
Visual C++
public:
property String^ ID {
    String^ get ();
}

Field Value

The ID.

See Also

ItemInfo Class
Sitecore.Install.Utils Namespace


Path Property

[image]

Sitecore 6.4.1 API
ItemInfo..::..Path Property
ItemInfo Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Path { get; }
Visual Basic
Public ReadOnly Property Path As String
    Get
Visual C++
public:
property String^ Path {
    String^ get ();
}

Field Value

The path.

See Also

ItemInfo Class
Sitecore.Install.Utils Namespace


TemplateID Property

[image]

Sitecore 6.4.1 API
ItemInfo..::..TemplateID Property
ItemInfo Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string TemplateID { get; }
Visual Basic
Public ReadOnly Property TemplateID As String
    Get
Visual C++
public:
property String^ TemplateID {
    String^ get ();
}

Field Value

The template ID.

See Also

ItemInfo Class
Sitecore.Install.Utils Namespace


MergeMode Enumeration

[image]

Sitecore 6.4.1 API
MergeMode Enumeration
See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum MergeMode
Visual Basic
Public Enumeration MergeMode
Visual C++
public enum class MergeMode

Members

Member name | Value | Description
Clear | 1 | Delete versions -> Append versions
Append | 2 | Append versions
Merge | 3 | Merge versions by versions number
Undefined | 0 |

See Also

Sitecore.Install.Utils Namespace


PackageUser Enumeration

[image]

Sitecore 6.4.1 API
PackageUser Enumeration
See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum PackageUser
Visual Basic
Public Enumeration PackageUser
Visual C++
public enum class PackageUser

Members

Member name | Value | Description
Developer | 0 |
EndUser | 1 |

See Also

Sitecore.Install.Utils Namespace


SitecoreLogger Class

[image]

Sitecore 6.4.1 API
SitecoreLogger Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SitecoreLogger : ILogger
Visual Basic
Public Class SitecoreLogger _
    Implements ILogger
Visual C++
public ref class SitecoreLogger : ILogger

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Utils..::..SitecoreLogger

See Also

SitecoreLogger Members
Sitecore.Install.Utils Namespace


SitecoreLogger Constructor

[image] [image]

Sitecore 6.4.1 API
SitecoreLogger Constructor
SitecoreLogger Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SitecoreLogger()()()() | Initializes a new instance of the SitecoreLogger class.
Public method | SitecoreLogger(Object) | Initializes a new instance of the SitecoreLogger class.

See Also

SitecoreLogger Class
SitecoreLogger Members
Sitecore.Install.Utils Namespace


SitecoreLogger Constructor

[image]

Sitecore 6.4.1 API
SitecoreLogger Constructor
SitecoreLogger Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SitecoreLogger()
Visual Basic
Public Sub New
Visual C++
public:
SitecoreLogger()

See Also

SitecoreLogger Class
SitecoreLogger Overload
Sitecore.Install.Utils Namespace


SitecoreLogger Constructor (Object)

[image]

Sitecore 6.4.1 API
SitecoreLogger Constructor (Object)
SitecoreLogger Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SitecoreLogger(
    Object source
)
Visual Basic
Public Sub New ( _
    source As Object _
)
Visual C++
public:
SitecoreLogger(
    Object^ source
)

Parameters

source
Type: System..::..Object
The source.

See Also

SitecoreLogger Class
SitecoreLogger Overload
Sitecore.Install.Utils Namespace


SitecoreLogger Methods

[image] [image]

Sitecore 6.4.1 API
SitecoreLogger Methods
SitecoreLogger Class See Also Send Feedback

The SitecoreLogger type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Error | Audits an error
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Info | Audits some information
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SitecoreLogger Class
Sitecore.Install.Utils Namespace


Error Method

[image]

Sitecore 6.4.1 API
SitecoreLogger..::..Error Method
SitecoreLogger Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Error(
    string format,
    params Object[] args
)
Visual Basic
Public Sub Error ( _
    format As String, _
    ParamArray args As Object() _
)
Visual C++
public:
virtual void Error(
    String^ format,
    ... array<Object^>^ args
) sealed

Parameters

format
Type: System..::..String
The format string.
args
Type: array< System..::..Object >[]()[][]
The arguments.

Implements

ILogger..::..Error(String, array<Object>[]()[][])

See Also

SitecoreLogger Class
Sitecore.Install.Utils Namespace


Info Method

[image]

Sitecore 6.4.1 API
SitecoreLogger..::..Info Method
SitecoreLogger Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Info(
    string format,
    params Object[] args
)
Visual Basic
Public Sub Info ( _
    format As String, _
    ParamArray args As Object() _
)
Visual C++
public:
virtual void Info(
    String^ format,
    ... array<Object^>^ args
) sealed

Parameters

format
Type: System..::..String
The format string.
args
Type: array< System..::..Object >[]()[][]
The arguments.

Implements

ILogger..::..Info(String, array<Object>[]()[][])

See Also

SitecoreLogger Class
Sitecore.Install.Utils Namespace


StatusFile Class

[image]

Sitecore 6.4.1 API
StatusFile Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class StatusFile
Visual Basic
Public Class StatusFile
Visual C++
public ref class StatusFile

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Utils..::..StatusFile

See Also

StatusFile Members
Sitecore.Install.Utils Namespace


StatusFile Members

[image] [image]

Sitecore 6.4.1 API
StatusFile Members
StatusFile Class Constructors Methods Properties See Also Send Feedback

The StatusFile type exposes the following members.

Constructors

 | Name | Description
Public method | StatusFile | Initializes a new instance of the StatusFile class.

Methods

 | Name | Description
 | CreateStatusInfo | Creates the status info.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadStatus | Gets the status.
Public method | ReportError | Reports the error.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteFinished | Writes the finished.
Public method | WriteWorking | Sets the status.

Properties

 | Name | Description
Public property | FileName | Gets the name of the file.

See Also

StatusFile Class
Sitecore.Install.Utils Namespace


StatusFile Methods

[image] [image]

Sitecore 6.4.1 API
StatusFile Methods
StatusFile Class See Also Send Feedback

The StatusFile type exposes the following members.

Methods

 | Name | Description
 | CreateStatusInfo | Creates the status info.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadStatus | Gets the status.
Public method | ReportError | Reports the error.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteFinished | Writes the finished.
Public method | WriteWorking | Sets the status.

See Also

StatusFile Class
Sitecore.Install.Utils Namespace


CreateStatusInfo Method

[image]

Sitecore 6.4.1 API
StatusFile..::..CreateStatusInfo Method
StatusFile Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected static StatusFile..::..StatusInfo CreateStatusInfo(
    StatusFile..::..Status status,
    string message,
    Object[] args
)
Visual Basic
Protected Shared Function CreateStatusInfo ( _
    status As StatusFile..::..Status, _
    message As String, _
    args As Object() _
) As StatusFile..::..StatusInfo
Visual C++
protected:
static StatusFile..::..StatusInfo^ CreateStatusInfo(
    StatusFile..::..Status status,
    String^ message,
    array<Object^>^ args
)

Parameters

status
Type: Sitecore.Install.Utils..::..StatusFile..::..Status
The status.
message
Type: System..::..String
The message.
args
Type: array< System..::..Object >[]()[][]
The arguments.

Return Value

The status info.

See Also

StatusFile Class
Sitecore.Install.Utils Namespace


ReadStatus Method

[image]

Sitecore 6.4.1 API
StatusFile..::..ReadStatus Method
StatusFile Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StatusFile..::..StatusInfo ReadStatus()
Visual Basic
Public Function ReadStatus As StatusFile..::..StatusInfo
Visual C++
public:
StatusFile..::..StatusInfo^ ReadStatus()

Return Value

The status.

See Also

StatusFile Class
Sitecore.Install.Utils Namespace


ReportError Method

[image]

Sitecore 6.4.1 API
StatusFile..::..ReportError Method
StatusFile Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void ReportError(
    Exception exception,
    params Object[] args
)
Visual Basic
Public Sub ReportError ( _
    exception As Exception, _
    ParamArray args As Object() _
)
Visual C++
public:
void ReportError(
    Exception^ exception,
    ... array<Object^>^ args
)

Parameters

exception
Type: System..::..Exception
The exception.
args
Type: array< System..::..Object >[]()[][]
1 Optional data parameter.

See Also

StatusFile Class
Sitecore.Install.Utils Namespace


WriteFinished Method

[image]

Sitecore 6.4.1 API
StatusFile..::..WriteFinished Method
StatusFile Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void WriteFinished(
    string message,
    params Object[] args
)
Visual Basic
Public Sub WriteFinished ( _
    message As String, _
    ParamArray args As Object() _
)
Visual C++
public:
void WriteFinished(
    String^ message,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::..String
The message.
args
Type: array< System..::..Object >[]()[][]
1 Optional data parameter.

See Also

StatusFile Class
Sitecore.Install.Utils Namespace


WriteWorking Method

[image]

Sitecore 6.4.1 API
StatusFile..::..WriteWorking Method
StatusFile Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void WriteWorking(
    string message,
    params Object[] args
)
Visual Basic
Public Sub WriteWorking ( _
    message As String, _
    ParamArray args As Object() _
)
Visual C++
public:
void WriteWorking(
    String^ message,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::..String
The message.
args
Type: array< System..::..Object >[]()[][]
Optional data parameter.

See Also

StatusFile Class
Sitecore.Install.Utils Namespace


StatusFile Properties

[image] [image]

Sitecore 6.4.1 API
StatusFile Properties
StatusFile Class See Also Send Feedback

The StatusFile type exposes the following members.

Properties

 | Name | Description
Public property | FileName | Gets the name of the file.

See Also

StatusFile Class
Sitecore.Install.Utils Namespace


FileName Property

[image]

Sitecore 6.4.1 API
StatusFile..::..FileName Property
StatusFile Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string FileName { get; }
Visual Basic
Public ReadOnly Property FileName As String
    Get
Visual C++
public:
property String^ FileName {
    String^ get ();
}

Field Value

The name of the file.

See Also

StatusFile Class
Sitecore.Install.Utils Namespace


StatusFile.Status Enumeration

[image]

Sitecore 6.4.1 API
StatusFile..::..Status Enumeration
StatusFile Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public enum Status
Visual Basic
<SerializableAttribute> _
Public Enumeration Status
Visual C++
[SerializableAttribute]
public enum class Status

Members

Member name | Value | Description
Working | 0 | Background process is still working.
Finished | 1 | Background process has finished successfully.
Failed | 2 | Background process has failed with exception.

See Also

Sitecore.Install.Utils Namespace


StatusFile.StatusInfo Class

[image]

Sitecore 6.4.1 API
StatusFile..::..StatusInfo Class
StatusFile Class Members See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class StatusInfo
Visual Basic
<SerializableAttribute> _
Public Class StatusInfo
Visual C++
[SerializableAttribute]
public ref class StatusInfo

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Utils..::..StatusFile..::..StatusInfo

See Also

StatusFile..::..StatusInfo Members
Sitecore.Install.Utils Namespace


StatusFile.StatusInfo Members

[image] [image]

Sitecore 6.4.1 API
StatusFile..::..StatusInfo Members
StatusFile..::..StatusInfo Class Constructors Methods Properties See Also Send Feedback

Wrapper around a file-based one-way communication channel.

The StatusFile..::..StatusInfo type exposes the following members.

Constructors

 | Name | Description
Public method | StatusFile..::..StatusInfo(StatusFile..::..Status, Exception) | Initializes a new instance of the StatusFile..::..StatusInfo class.
Public method | StatusFile..::..StatusInfo(StatusFile..::..Status, String) | Initializes a new instance of the StatusFile..::..StatusInfo class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Data | Gets the data.
Public property | Exception | Gets the exception.
Public property | Message | Gets the message.
Public property | Status | Gets the status.

See Also

StatusFile..::..StatusInfo Class
Sitecore.Install.Utils Namespace


StatusFile.StatusInfo Constructor

[image] [image]

Sitecore 6.4.1 API
StatusFile..::..StatusInfo Constructor
StatusFile..::..StatusInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StatusFile..::..StatusInfo(StatusFile..::..Status, Exception) | Initializes a new instance of the StatusFile..::..StatusInfo class.
Public method | StatusFile..::..StatusInfo(StatusFile..::..Status, String) | Initializes a new instance of the StatusFile..::..StatusInfo class.

See Also

StatusFile..::..StatusInfo Class
StatusFile..::..StatusInfo Members
Sitecore.Install.Utils Namespace


StatusFile.StatusInfo Constructor (StatusFile.Status, Exception)

[image]

Sitecore 6.4.1 API
StatusFile..::..StatusInfo Constructor (StatusFile..::..Status, Exception)
StatusFile..::..StatusInfo Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StatusInfo(
    StatusFile..::..Status status,
    Exception exception
)
Visual Basic
Public Sub New ( _
    status As StatusFile..::..Status, _
    exception As Exception _
)
Visual C++
public:
StatusInfo(
    StatusFile..::..Status status,
    Exception^ exception
)

Parameters

status
Type: Sitecore.Install.Utils..::..StatusFile..::..Status
The status.
exception
Type: System..::..Exception
The exception.

See Also

StatusFile..::..StatusInfo Class
StatusFile..::..StatusInfo Overload
Sitecore.Install.Utils Namespace


StatusFile.StatusInfo Constructor (StatusFile.Status, String)

[image]

Sitecore 6.4.1 API
StatusFile..::..StatusInfo Constructor (StatusFile..::..Status, String)
StatusFile..::..StatusInfo Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StatusInfo(
    StatusFile..::..Status status,
    string message
)
Visual Basic
Public Sub New ( _
    status As StatusFile..::..Status, _
    message As String _
)
Visual C++
public:
StatusInfo(
    StatusFile..::..Status status,
    String^ message
)

Parameters

status
Type: Sitecore.Install.Utils..::..StatusFile..::..Status
The status.
message
Type: System..::..String
The message.

See Also

StatusFile..::..StatusInfo Class
StatusFile..::..StatusInfo Overload
Sitecore.Install.Utils Namespace


StatusFile.StatusInfo Methods

[image] [image]

Sitecore 6.4.1 API
StatusFile..::..StatusInfo Methods
StatusFile..::..StatusInfo Class See Also Send Feedback

The StatusFile..::..StatusInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StatusFile..::..StatusInfo Class
Sitecore.Install.Utils Namespace


StatusFile.StatusInfo Properties

[image] [image]

Sitecore 6.4.1 API
StatusFile..::..StatusInfo Properties
StatusFile..::..StatusInfo Class See Also Send Feedback

The StatusFile..::..StatusInfo type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets the data.
Public property | Exception | Gets the exception.
Public property | Message | Gets the message.
Public property | Status | Gets the status.

See Also

StatusFile..::..StatusInfo Class
Sitecore.Install.Utils Namespace


Data Property

[image]

Sitecore 6.4.1 API
StatusFile..::..StatusInfo..::..Data Property
StatusFile..::..StatusInfo Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object Data { get; set; }
Visual Basic
Public Property Data As Object
    Get
    Set
Visual C++
public:
property Object^ Data {
    Object^ get ();
    void set (Object^ value);
}

Field Value

The data.

See Also

StatusFile..::..StatusInfo Class
Sitecore.Install.Utils Namespace


Exception Property

[image]

Sitecore 6.4.1 API
StatusFile..::..StatusInfo..::..Exception Property
StatusFile..::..StatusInfo Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Exception Exception { get; set; }
Visual Basic
Public Property Exception As Exception
    Get
    Set
Visual C++
public:
property Exception^ Exception {
    Exception^ get ();
    void set (Exception^ value);
}

Field Value

The exception.

See Also

StatusFile..::..StatusInfo Class
Sitecore.Install.Utils Namespace


Message Property

[image]

Sitecore 6.4.1 API
StatusFile..::..StatusInfo..::..Message Property
StatusFile..::..StatusInfo Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Message { get; set; }
Visual Basic
Public Property Message As String
    Get
    Set
Visual C++
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}

Field Value

The message.

See Also

StatusFile..::..StatusInfo Class
Sitecore.Install.Utils Namespace


Status Property

[image]

Sitecore 6.4.1 API
StatusFile..::..StatusInfo..::..Status Property
StatusFile..::..StatusInfo Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StatusFile..::..Status Status { get; set; }
Visual Basic
Public Property Status As StatusFile..::..Status
    Get
    Set
Visual C++
public:
property StatusFile..::..Status Status {
    StatusFile..::..Status get ();
    void set (StatusFile..::..Status value);
}

Field Value

The status.

See Also

StatusFile..::..StatusInfo Class
Sitecore.Install.Utils Namespace


StringEntryData Class

[image]

Sitecore 6.4.1 API
StringEntryData Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class StringEntryData : IEntryData
Visual Basic
Public Class StringEntryData _
    Implements IEntryData
Visual C++
public ref class StringEntryData : IEntryData

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Utils..::..StringEntryData

See Also

StringEntryData Members
Sitecore.Install.Utils Namespace


StringEntryData Members

[image] [image]

Sitecore 6.4.1 API
StringEntryData Members
StringEntryData Class Constructors Methods Properties See Also Send Feedback

The StringEntryData type exposes the following members.

Constructors

 | Name | Description
Public method | StringEntryData(String, String) | Initializes a new instance of the StringEntryData class.
Public method | StringEntryData(String, String, Encoding) | Initializes a new instance of the StringEntryData class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStream | Gets the stream holder.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Key | Gets the key.

See Also

StringEntryData Class
Sitecore.Install.Utils Namespace


StringEntryData Constructor

[image] [image]

Sitecore 6.4.1 API
StringEntryData Constructor
StringEntryData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StringEntryData(String, String) | Initializes a new instance of the StringEntryData class.
Public method | StringEntryData(String, String, Encoding) | Initializes a new instance of the StringEntryData class.

See Also

StringEntryData Class
StringEntryData Members
Sitecore.Install.Utils Namespace


StringEntryData Constructor (String, String)

[image]

Sitecore 6.4.1 API
StringEntryData Constructor (String, String)
StringEntryData Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StringEntryData(
    string key,
    string content
)
Visual Basic
Public Sub New ( _
    key As String, _
    content As String _
)
Visual C++
public:
StringEntryData(
    String^ key,
    String^ content
)

Parameters

key
Type: System..::..String
The key.
content
Type: System..::..String
The content.

See Also

StringEntryData Class
StringEntryData Overload
Sitecore.Install.Utils Namespace


StringEntryData Constructor (String, String, Encoding)

[image]

Sitecore 6.4.1 API
StringEntryData Constructor (String, String, Encoding)
StringEntryData Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StringEntryData(
    string key,
    string content,
    Encoding encoding
)
Visual Basic
Public Sub New ( _
    key As String, _
    content As String, _
    encoding As Encoding _
)
Visual C++
public:
StringEntryData(
    String^ key,
    String^ content,
    Encoding^ encoding
)

Parameters

key
Type: System..::..String
The key.
content
Type: System..::..String
The content.
encoding
Type: System.Text..::..Encoding
The encoding.

See Also

StringEntryData Class
StringEntryData Overload
Sitecore.Install.Utils Namespace


StringEntryData Methods

[image] [image]

Sitecore 6.4.1 API
StringEntryData Methods
StringEntryData Class See Also Send Feedback

The StringEntryData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStream | Gets the stream holder.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StringEntryData Class
Sitecore.Install.Utils Namespace


GetStream Method

[image]

Sitecore 6.4.1 API
StringEntryData..::..GetStream Method
StringEntryData Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IStreamHolder GetStream()
Visual Basic
Public Function GetStream As IStreamHolder
Visual C++
public:
virtual IStreamHolder^ GetStream() sealed

Return Value

The stream holder.

Implements

IEntryData..::..GetStream()()()()

See Also

StringEntryData Class
Sitecore.Install.Utils Namespace


StringEntryData Properties

[image] [image]

Sitecore 6.4.1 API
StringEntryData Properties
StringEntryData Class See Also Send Feedback

The StringEntryData type exposes the following members.

Properties

 | Name | Description
Public property | Key | Gets the key.

See Also

StringEntryData Class
Sitecore.Install.Utils Namespace


StrongStreamHolder Class

[image]

Sitecore 6.4.1 API
StrongStreamHolder Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class StrongStreamHolder : IStreamHolder,
    IDisposable
Visual Basic
Public Class StrongStreamHolder _
    Implements IStreamHolder, IDisposable
Visual C++
public ref class StrongStreamHolder : IStreamHolder,
    IDisposable

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Utils..::..StrongStreamHolder

See Also

StrongStreamHolder Members
Sitecore.Install.Utils Namespace


StrongStreamHolder Members

[image] [image]

Sitecore 6.4.1 API
StrongStreamHolder Members
StrongStreamHolder Class Constructors Methods Properties See Also Send Feedback

The StrongStreamHolder type exposes the following members.

Constructors

 | Name | Description
Public method | StrongStreamHolder | Initializes a new instance of the StrongStreamHolder class.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Stream | Gets the stream.

See Also

StrongStreamHolder Class
Sitecore.Install.Utils Namespace


StrongStreamHolder Constructor

[image]

Sitecore 6.4.1 API
StrongStreamHolder Constructor
StrongStreamHolder Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StrongStreamHolder(
    Stream stream
)
Visual Basic
Public Sub New ( _
    stream As Stream _
)
Visual C++
public:
StrongStreamHolder(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::..Stream
The stream.

See Also

StrongStreamHolder Class
Sitecore.Install.Utils Namespace


StrongStreamHolder Methods

[image] [image]

Sitecore 6.4.1 API
StrongStreamHolder Methods
StrongStreamHolder Class See Also Send Feedback

The StrongStreamHolder type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StrongStreamHolder Class
Sitecore.Install.Utils Namespace


Dispose Method

[image]

Sitecore 6.4.1 API
StrongStreamHolder..::..Dispose Method
StrongStreamHolder Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

StrongStreamHolder Class
Sitecore.Install.Utils Namespace


StrongStreamHolder Properties

[image] [image]

Sitecore 6.4.1 API
StrongStreamHolder Properties
StrongStreamHolder Class See Also Send Feedback

The StrongStreamHolder type exposes the following members.

Properties

 | Name | Description
Public property | Stream | Gets the stream.

See Also

StrongStreamHolder Class
Sitecore.Install.Utils Namespace


Stream Property

[image]

Sitecore 6.4.1 API
StrongStreamHolder..::..Stream Property
StrongStreamHolder Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Stream Stream { get; }
Visual Basic
Public ReadOnly Property Stream As Stream
    Get
Visual C++
public:
virtual property Stream^ Stream {
    Stream^ get () sealed;
}

Field Value

The stream.

Implements

IStreamHolder..::..Stream

See Also

StrongStreamHolder Class
Sitecore.Install.Utils Namespace


Uniq Class

[image]

Sitecore 6.4.1 API
Uniq Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Uniq : BaseSink<PackageEntry>
Visual Basic
Public Class Uniq _
    Inherits BaseSink(Of PackageEntry)
Visual C++
public ref class Uniq : public BaseSink<PackageEntry^>

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..BaseSink <(Of <(<' PackageEntry >)>)>
Sitecore.Install.Utils..::..Uniq

See Also

Uniq Members
Sitecore.Install.Utils Namespace


Uniq Constructor

[image]

Sitecore 6.4.1 API
Uniq Constructor
Uniq Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Uniq(
    ISink<PackageEntry> sink
)
Visual Basic
Public Sub New ( _
    sink As ISink(Of PackageEntry) _
)
Visual C++
public:
Uniq(
    ISink<PackageEntry^>^ sink
)

Parameters

sink
Type: Sitecore.Install.Framework..::..ISink <(Of <(<' PackageEntry >)>)>
The sink.

See Also

Uniq Class
Sitecore.Install.Utils Namespace


Uniq Fields

[image] [image]

Sitecore 6.4.1 API
Uniq Fields
Uniq Class See Also Send Feedback

The Uniq type exposes the following members.

Fields

 | Name | Description
Protected field | _processingContext | (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

Uniq Class
Sitecore.Install.Utils Namespace


Uniq Methods

[image] [image]

Sitecore 6.4.1 API
Uniq Methods
Uniq Class See Also Send Feedback

The Uniq type exposes the following members.

Methods

 | Name | Description
Protected method | AssertInit | Asserts the init. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finishes the sink. (Overrides BaseSink<(Of <(<'T>)>)>..::..Finish()()()().)
Public method | Flush | Flushes the sink (Overrides BaseSink<(Of <(<'T>)>)>..::..Flush()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this instance. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put | Puts the specified entry if its key is different from the last parsed key. (Overrides BaseSink<(Of <(<'T>)>)>..::..Put(T).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Uniq Class
Sitecore.Install.Utils Namespace


Finish Method

[image]

Sitecore 6.4.1 API
Uniq..::..Finish Method
Uniq Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Finish()
Visual Basic
Public Overrides Sub Finish
Visual C++
public:
virtual void Finish() override

Implements

ISink<(Of <(<'T>)>)>..::..Finish()()()()

See Also

Uniq Class
Sitecore.Install.Utils Namespace


Flush Method

[image]

Sitecore 6.4.1 API
Uniq..::..Flush Method
Uniq Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Flush()
Visual Basic
Public Overrides Sub Flush
Visual C++
public:
virtual void Flush() override

Implements

ISink<(Of <(<'T>)>)>..::..Flush()()()()

See Also

Uniq Class
Sitecore.Install.Utils Namespace


Put Method

[image]

Sitecore 6.4.1 API
Uniq..::..Put Method
Uniq Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Put(
    PackageEntry entry
)
Visual Basic
Public Overrides Sub Put ( _
    entry As PackageEntry _
)
Visual C++
public:
virtual void Put(
    PackageEntry^ entry
) override

Parameters

entry
Type: Sitecore.Install.Framework..::..PackageEntry
The entry.

Implements

ISink<(Of <(<'T>)>)>..::..Put(T)

See Also

Uniq Class
Sitecore.Install.Utils Namespace


Uniq Properties

[image] [image]

Sitecore 6.4.1 API
Uniq Properties
Uniq Class See Also Send Feedback

The Uniq type exposes the following members.

Properties

 | Name | Description
Public property | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

Uniq Class
Sitecore.Install.Utils Namespace


WeakStreamHolder Class

[image]

Sitecore 6.4.1 API
WeakStreamHolder Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class WeakStreamHolder : IStreamHolder,
    IDisposable
Visual Basic
Public Class WeakStreamHolder _
    Implements IStreamHolder, IDisposable
Visual C++
public ref class WeakStreamHolder : IStreamHolder,
    IDisposable

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Utils..::..WeakStreamHolder

See Also

WeakStreamHolder Members
Sitecore.Install.Utils Namespace


WeakStreamHolder Members

[image] [image]

Sitecore 6.4.1 API
WeakStreamHolder Members
WeakStreamHolder Class Constructors Methods Properties See Also Send Feedback

The WeakStreamHolder type exposes the following members.

Constructors

 | Name | Description
Public method | WeakStreamHolder | Initializes a new instance of the WeakStreamHolder class.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Stream | Gets the stream.

See Also

WeakStreamHolder Class
Sitecore.Install.Utils Namespace


WeakStreamHolder Constructor

[image]

Sitecore 6.4.1 API
WeakStreamHolder Constructor
WeakStreamHolder Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WeakStreamHolder(
    Stream stream
)
Visual Basic
Public Sub New ( _
    stream As Stream _
)
Visual C++
public:
WeakStreamHolder(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::..Stream
The stream.

See Also

WeakStreamHolder Class
Sitecore.Install.Utils Namespace


WeakStreamHolder Methods

[image] [image]

Sitecore 6.4.1 API
WeakStreamHolder Methods
WeakStreamHolder Class See Also Send Feedback

The WeakStreamHolder type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WeakStreamHolder Class
Sitecore.Install.Utils Namespace


Dispose Method

[image]

Sitecore 6.4.1 API
WeakStreamHolder..::..Dispose Method
WeakStreamHolder Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

WeakStreamHolder Class
Sitecore.Install.Utils Namespace


WeakStreamHolder Properties

[image] [image]

Sitecore 6.4.1 API
WeakStreamHolder Properties
WeakStreamHolder Class See Also Send Feedback

The WeakStreamHolder type exposes the following members.

Properties

 | Name | Description
Public property | Stream | Gets the stream.

See Also

WeakStreamHolder Class
Sitecore.Install.Utils Namespace


Stream Property

[image]

Sitecore 6.4.1 API
WeakStreamHolder..::..Stream Property
WeakStreamHolder Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Stream Stream { get; }
Visual Basic
Public ReadOnly Property Stream As Stream
    Get
Visual C++
public:
virtual property Stream^ Stream {
    Stream^ get () sealed;
}

Field Value

The stream.

Implements

IStreamHolder..::..Stream

See Also

WeakStreamHolder Class
Sitecore.Install.Utils Namespace


XmlVersionParser Class

[image]

Sitecore 6.4.1 API
XmlVersionParser Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class XmlVersionParser
Visual Basic
Public Class XmlVersionParser
Visual C++
public ref class XmlVersionParser

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Utils..::..XmlVersionParser

See Also

XmlVersionParser Members
Sitecore.Install.Utils Namespace


XmlVersionParser Members

[image] [image]

Sitecore 6.4.1 API
XmlVersionParser Members
XmlVersionParser Class Constructors Methods Properties See Also Send Feedback

The XmlVersionParser type exposes the following members.

Constructors

 | Name | Description
Public method | XmlVersionParser | Initializes a new instance of the XmlVersionParser class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | Gets the name.
Public property | ParentID | Gets the parent ID.
Public property | TemplateID | Gets the template ID.
Public property | Xml | Gets the XML.

See Also

XmlVersionParser Class
Sitecore.Install.Utils Namespace


XmlVersionParser Constructor

[image]

Sitecore 6.4.1 API
XmlVersionParser Constructor
XmlVersionParser Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public XmlVersionParser(
    PackageEntry entry
)
Visual Basic
Public Sub New ( _
    entry As PackageEntry _
)
Visual C++
public:
XmlVersionParser(
    PackageEntry^ entry
)

Parameters

entry
Type: Sitecore.Install.Framework..::..PackageEntry
The entry.

See Also

XmlVersionParser Class
Sitecore.Install.Utils Namespace


XmlVersionParser Methods

[image] [image]

Sitecore 6.4.1 API
XmlVersionParser Methods
XmlVersionParser Class See Also Send Feedback

The XmlVersionParser type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

XmlVersionParser Class
Sitecore.Install.Utils Namespace


XmlVersionParser Properties

[image] [image]

Sitecore 6.4.1 API
XmlVersionParser Properties
XmlVersionParser Class See Also Send Feedback

The XmlVersionParser type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the name.
Public property | ParentID | Gets the parent ID.
Public property | TemplateID | Gets the template ID.
Public property | Xml | Gets the XML.

See Also

XmlVersionParser Class
Sitecore.Install.Utils Namespace


Name Property

[image]

Sitecore 6.4.1 API
XmlVersionParser..::..Name Property
XmlVersionParser Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

XmlVersionParser Class
Sitecore.Install.Utils Namespace


TemplateID Property

[image]

Sitecore 6.4.1 API
XmlVersionParser..::..TemplateID Property
XmlVersionParser Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID TemplateID { get; }
Visual Basic
Public ReadOnly Property TemplateID As ID
    Get
Visual C++
public:
property ID^ TemplateID {
    ID^ get ();
}

Field Value

The template ID.

See Also

XmlVersionParser Class
Sitecore.Install.Utils Namespace


Xml Property

[image]

Sitecore 6.4.1 API
XmlVersionParser..::..Xml Property
XmlVersionParser Class See Also Send Feedback

Namespace: Sitecore.Install.Utils
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public XmlDocument Xml { get; }
Visual Basic
Public ReadOnly Property Xml As XmlDocument
    Get
Visual C++
public:
property XmlDocument^ Xml {
    XmlDocument^ get ();
}

Field Value

The XML.

See Also

XmlVersionParser Class
Sitecore.Install.Utils Namespace


Sitecore.Install.Zip Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Install.Zip Namespace
Send Feedback

Classes

 | Class | Description
Public class | PackageReader | Reads zip as a source of package entries
Public class | PackageWriter | Sink for PackageEntry that creates result zip file
Public class | ZipEntryData | Zip entry data


PackageReader Members

[image] [image]

Sitecore 6.4.1 API
PackageReader Members
PackageReader Class Constructors Methods Properties See Also Send Feedback

The PackageReader type exposes the following members.

Constructors

 | Name | Description
Public method | PackageReader()()()() | Initializes a new instance of the PackageReader class. Should be used only during deserialization
Public method | PackageReader(String) | Initializes a new instance of the PackageReader class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Populates specified sink with package entiries from the file.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FileName | Gets or sets the name of the file.

See Also

PackageReader Class
Sitecore.Install.Zip Namespace


PackageReader Constructor

[image] [image]

Sitecore 6.4.1 API
PackageReader Constructor
PackageReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PackageReader()()()() | Initializes a new instance of the PackageReader class. Should be used only during deserialization
Public method | PackageReader(String) | Initializes a new instance of the PackageReader class.

See Also

PackageReader Class
PackageReader Members
Sitecore.Install.Zip Namespace


PackageReader Constructor

[image]

Sitecore 6.4.1 API
PackageReader Constructor
PackageReader Class See Also Send Feedback

Namespace: Sitecore.Install.Zip
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PackageReader()
Visual Basic
Public Sub New
Visual C++
public:
PackageReader()

See Also

PackageReader Class
PackageReader Overload
Sitecore.Install.Zip Namespace


PackageReader Methods

[image] [image]

Sitecore 6.4.1 API
PackageReader Methods
PackageReader Class See Also Send Feedback

The PackageReader type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Populates specified sink with package entiries from the file.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PackageReader Class
Sitecore.Install.Zip Namespace


PackageReader Properties

[image] [image]

Sitecore 6.4.1 API
PackageReader Properties
PackageReader Class See Also Send Feedback

The PackageReader type exposes the following members.

Properties

 | Name | Description
Public property | FileName | Gets or sets the name of the file.

See Also

PackageReader Class
Sitecore.Install.Zip Namespace


FileName Property

[image]

Sitecore 6.4.1 API
PackageReader..::..FileName Property
PackageReader Class See Also Send Feedback

Namespace: Sitecore.Install.Zip
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string FileName { get; set; }
Visual Basic
Public Property FileName As String
    Get
    Set
Visual C++
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the file.

See Also

PackageReader Class
Sitecore.Install.Zip Namespace


PackageWriter Class

[image]

Sitecore 6.4.1 API
PackageWriter Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Zip
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PackageWriter : BaseSink<PackageEntry>,
    IDisposable
Visual Basic
Public Class PackageWriter _
    Inherits BaseSink(Of PackageEntry) _
    Implements IDisposable
Visual C++
public ref class PackageWriter : public BaseSink<PackageEntry^>,
    IDisposable

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Framework..::..BaseSink <(Of <(<' PackageEntry >)>)>
Sitecore.Install.Zip..::..PackageWriter

See Also

PackageWriter Members
Sitecore.Install.Zip Namespace


PackageWriter Constructor

[image] [image]

Sitecore 6.4.1 API
PackageWriter Constructor
PackageWriter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PackageWriter()()()() | Initializes a new instance of the PackageWriter class.
Public method | PackageWriter(String) | Initializes a new instance of the PackageWriter class.

See Also

PackageWriter Class
PackageWriter Members
Sitecore.Install.Zip Namespace


PackageWriter Constructor

[image]

Sitecore 6.4.1 API
PackageWriter Constructor
PackageWriter Class See Also Send Feedback

Namespace: Sitecore.Install.Zip
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PackageWriter()
Visual Basic
Public Sub New
Visual C++
public:
PackageWriter()

See Also

PackageWriter Class
PackageWriter Overload
Sitecore.Install.Zip Namespace


PackageWriter Constructor (String)

[image]

Sitecore 6.4.1 API
PackageWriter Constructor (String)
PackageWriter Class See Also Send Feedback

Namespace: Sitecore.Install.Zip
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PackageWriter(
    string filename
)
Visual Basic
Public Sub New ( _
    filename As String _
)
Visual C++
public:
PackageWriter(
    String^ filename
)

Parameters

filename
Type: System..::..String
The filename.

See Also

PackageWriter Class
PackageWriter Overload
Sitecore.Install.Zip Namespace


PackageWriter Fields

[image] [image]

Sitecore 6.4.1 API
PackageWriter Fields
PackageWriter Class See Also Send Feedback

The PackageWriter type exposes the following members.

Fields

 | Name | Description
Protected field | _processingContext | (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

PackageWriter Class
Sitecore.Install.Zip Namespace


PackageWriter Methods

[image] [image]

Sitecore 6.4.1 API
PackageWriter Methods
PackageWriter Class See Also Send Feedback

The PackageWriter type exposes the following members.

Methods

 | Name | Description
Protected method | AssertInit | Asserts the init. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Finishes the sink. (Overrides BaseSink<(Of <(<'T>)>)>..::..Finish()()()().)
Public method | Flush | Flushes the sink (Overrides BaseSink<(Of <(<'T>)>)>..::..Flush()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize()()()() | Initializes this instance.
Public method | Initialize(IProcessingContext) | Initializes this instance. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put | Puts the specified entry to file. (Overrides BaseSink<(Of <(<'T>)>)>..::..Put(T).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | WriterClosed | Throws an exception.

See Also

PackageWriter Class
Sitecore.Install.Zip Namespace


Finish Method

[image]

Sitecore 6.4.1 API
PackageWriter..::..Finish Method
PackageWriter Class See Also Send Feedback

Namespace: Sitecore.Install.Zip
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Finish()
Visual Basic
Public Overrides Sub Finish
Visual C++
public:
virtual void Finish() override

Implements

ISink<(Of <(<'T>)>)>..::..Finish()()()()

See Also

PackageWriter Class
Sitecore.Install.Zip Namespace


Flush Method

[image]

Sitecore 6.4.1 API
PackageWriter..::..Flush Method
PackageWriter Class See Also Send Feedback

Namespace: Sitecore.Install.Zip
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Flush()
Visual Basic
Public Overrides Sub Flush
Visual C++
public:
virtual void Flush() override

Implements

ISink<(Of <(<'T>)>)>..::..Flush()()()()

See Also

PackageWriter Class
Sitecore.Install.Zip Namespace


Initialize Method

[image] [image]

Sitecore 6.4.1 API
PackageWriter..::..Initialize Method
PackageWriter Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Initialize()()()() | Initializes this instance.
Public method | Initialize(IProcessingContext) | Initializes this instance. (Inherited from BaseSink<(Of <(<'T>)>)>.)

See Also

PackageWriter Class
PackageWriter Members
Sitecore.Install.Zip Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
PackageWriter..::..Initialize Method
PackageWriter Class See Also Send Feedback

Namespace: Sitecore.Install.Zip
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void Initialize()
Visual Basic
Protected Overridable Sub Initialize
Visual C++
protected:
virtual void Initialize()

See Also

PackageWriter Class
Initialize Overload
Sitecore.Install.Zip Namespace


Put Method

[image]

Sitecore 6.4.1 API
PackageWriter..::..Put Method
PackageWriter Class See Also Send Feedback

Namespace: Sitecore.Install.Zip
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Put(
    PackageEntry entry
)
Visual Basic
Public Overrides Sub Put ( _
    entry As PackageEntry _
)
Visual C++
public:
virtual void Put(
    PackageEntry^ entry
) override

Parameters

entry
Type: Sitecore.Install.Framework..::..PackageEntry
The entry.

Implements

ISink<(Of <(<'T>)>)>..::..Put(T)

See Also

PackageWriter Class
Sitecore.Install.Zip Namespace


WriterClosed Method

[image]

Sitecore 6.4.1 API
PackageWriter..::..WriterClosed Method
PackageWriter Class See Also Send Feedback

Namespace: Sitecore.Install.Zip
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void WriterClosed()
Visual Basic
Protected Overridable Sub WriterClosed
Visual C++
protected:
virtual void WriterClosed()

See Also

PackageWriter Class
Sitecore.Install.Zip Namespace


PackageWriter Properties

[image] [image]

Sitecore 6.4.1 API
PackageWriter Properties
PackageWriter Class See Also Send Feedback

The PackageWriter type exposes the following members.

Properties

 | Name | Description
Protected property | InnerWriter | Gets or sets the inner writer.
Public property | IsInitialized | Gets a value indicating whether this instance is initialized. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Public property | PackagePath | Gets or sets the package path.
Public property | ProcessingContext | Gets the processing context. (Inherited from BaseSink<(Of <(<'T>)>)>.)
Protected property | TempPath | Gets or sets the tempopary package path.

See Also

PackageWriter Class
Sitecore.Install.Zip Namespace


InnerWriter Property

[image]

Sitecore 6.4.1 API
PackageWriter..::..InnerWriter Property
PackageWriter Class See Also Send Feedback

Namespace: Sitecore.Install.Zip
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected ZipWriter InnerWriter { get; set; }
Visual Basic
Protected Property InnerWriter As ZipWriter
    Get
    Set
Visual C++
protected:
property ZipWriter^ InnerWriter {
    ZipWriter^ get ();
    void set (ZipWriter^ value);
}

Field Value

The inner writer.

See Also

PackageWriter Class
Sitecore.Install.Zip Namespace


PackagePath Property

[image]

Sitecore 6.4.1 API
PackageWriter..::..PackagePath Property
PackageWriter Class See Also Send Feedback

Namespace: Sitecore.Install.Zip
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string PackagePath { get; set; }
Visual Basic
Public Property PackagePath As String
    Get
    Set
Visual C++
public:
property String^ PackagePath {
    String^ get ();
    void set (String^ value);
}

Field Value

The package path.

See Also

PackageWriter Class
Sitecore.Install.Zip Namespace


TempPath Property

[image]

Sitecore 6.4.1 API
PackageWriter..::..TempPath Property
PackageWriter Class See Also Send Feedback

Namespace: Sitecore.Install.Zip
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected string TempPath { get; set; }
Visual Basic
Protected Property TempPath As String
    Get
    Set
Visual C++
protected:
property String^ TempPath {
    String^ get ();
    void set (String^ value);
}

Field Value

The temporary package path.

See Also

PackageWriter Class
Sitecore.Install.Zip Namespace


ZipEntryData Class

[image]

Sitecore 6.4.1 API
ZipEntryData Class
Members See Also Send Feedback

Namespace: Sitecore.Install.Zip
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ZipEntryData : IEntryData
Visual Basic
Public Class ZipEntryData _
    Implements IEntryData
Visual C++
public ref class ZipEntryData : IEntryData

Inheritance Hierarchy

System..::..Object
Sitecore.Install.Zip..::..ZipEntryData

See Also

ZipEntryData Members
Sitecore.Install.Zip Namespace


ZipEntryData Members

[image] [image]

Sitecore 6.4.1 API
ZipEntryData Members
ZipEntryData Class Constructors Methods Properties See Also Send Feedback

The ZipEntryData type exposes the following members.

Constructors

 | Name | Description
Public method | ZipEntryData | Initializes a new instance of the ZipEntryData class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStream | Gets the stream holder.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Key | Gets the key.

See Also

ZipEntryData Class
Sitecore.Install.Zip Namespace


ZipEntryData Constructor

[image]

Sitecore 6.4.1 API
ZipEntryData Constructor
ZipEntryData Class See Also Send Feedback

Namespace: Sitecore.Install.Zip
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ZipEntryData(
    ZipEntry entry
)
Visual Basic
Public Sub New ( _
    entry As ZipEntry _
)
Visual C++
public:
ZipEntryData(
    ZipEntry^ entry
)

Parameters

entry
Type: ZipEntry
The entry.

See Also

ZipEntryData Class
Sitecore.Install.Zip Namespace


ZipEntryData Methods

[image] [image]

Sitecore 6.4.1 API
ZipEntryData Methods
ZipEntryData Class See Also Send Feedback

The ZipEntryData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStream | Gets the stream holder.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ZipEntryData Class
Sitecore.Install.Zip Namespace


GetStream Method

[image]

Sitecore 6.4.1 API
ZipEntryData..::..GetStream Method
ZipEntryData Class See Also Send Feedback

Namespace: Sitecore.Install.Zip
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IStreamHolder GetStream()
Visual Basic
Public Function GetStream As IStreamHolder
Visual C++
public:
virtual IStreamHolder^ GetStream() sealed

Return Value

The stream holder.

Implements

IEntryData..::..GetStream()()()()

See Also

ZipEntryData Class
Sitecore.Install.Zip Namespace


ZipEntryData Properties

[image] [image]

Sitecore 6.4.1 API
ZipEntryData Properties
ZipEntryData Class See Also Send Feedback

The ZipEntryData type exposes the following members.

Properties

 | Name | Description
Public property | Key | Gets the key.

See Also

ZipEntryData Class
Sitecore.Install.Zip Namespace


Key Property

[image]

Sitecore 6.4.1 API
ZipEntryData..::..Key Property
ZipEntryData Class See Also Send Feedback

Namespace: Sitecore.Install.Zip
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Key { get; }
Visual Basic
Public ReadOnly Property Key As String
    Get
Visual C++
public:
virtual property String^ Key {
    String^ get () sealed;
}

Field Value

The key.

Implements

IEntryData..::..Key

See Also

ZipEntryData Class
Sitecore.Install.Zip Namespace


Sitecore.IntegratedSessionFix Namespace

[image]

Sitecore 6.4.1 API
Sitecore.IntegratedSessionFix Namespace
Send Feedback

Classes

 | Class | Description
Public class | Handler | Obsolete. Handler that used for fix of problem with empty session on IIS7 in integrated mode
Public class | Module | Obsolete. Module that fixes problem with empty session on IIS7 in integrated mode


Handler Class

[image]

Sitecore 6.4.1 API
Handler Class
Members See Also Send Feedback

Namespace: Sitecore.IntegratedSessionFix
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute]
public class Handler : IHttpHandler, IReadOnlySessionState,
    IRequiresSessionState
Visual Basic
<ObsoleteAttribute> _
Public Class Handler _
    Implements IHttpHandler, IReadOnlySessionState, IRequiresSessionState
Visual C++
[ObsoleteAttribute]
public ref class Handler : IHttpHandler,
    IReadOnlySessionState, IRequiresSessionState

Inheritance Hierarchy

System..::..Object
Sitecore.IntegratedSessionFix..::..Handler

See Also

Handler Members
Sitecore.IntegratedSessionFix Namespace


Handler Members

[image] [image]

Sitecore 6.4.1 API
Handler Members
Handler Class Constructors Methods Properties See Also Send Feedback

The Handler type exposes the following members.

Constructors

 | Name | Description
Public method | Handler | Initializes a new instance of the Handler class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessRequest | Enables processing of HTTP Web requests by a custom HttpHandler that implements the IHttpHandler interface.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReusable | Gets a value indicating whether another request can use the IHttpHandler instance.

See Also

Handler Class
Sitecore.IntegratedSessionFix Namespace


Handler Constructor

[image]

Sitecore 6.4.1 API
Handler Constructor
Handler Class See Also Send Feedback

Namespace: Sitecore.IntegratedSessionFix
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Handler()
Visual Basic
Public Sub New
Visual C++
public:
Handler()

See Also

Handler Class
Sitecore.IntegratedSessionFix Namespace


Handler Methods

[image] [image]

Sitecore 6.4.1 API
Handler Methods
Handler Class See Also Send Feedback

The Handler type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessRequest | Enables processing of HTTP Web requests by a custom HttpHandler that implements the IHttpHandler interface.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Handler Class
Sitecore.IntegratedSessionFix Namespace


ProcessRequest Method

[image]

Sitecore 6.4.1 API
Handler..::..ProcessRequest Method
Handler Class See Also Send Feedback

Namespace: Sitecore.IntegratedSessionFix
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void ProcessRequest(
    HttpContext context
)
Visual Basic
Public Sub ProcessRequest ( _
    context As HttpContext _
)
Visual C++
public:
virtual void ProcessRequest(
    HttpContext^ context
) sealed

Parameters

context
Type: System.Web..::..HttpContext
An HttpContext object that provides references to the intrinsic server objects (for example, Request, Response, Session, and Server) used to service HTTP requests.

Implements

IHttpHandler..::..ProcessRequest(HttpContext)

See Also

Handler Class
Sitecore.IntegratedSessionFix Namespace


Handler Properties

[image] [image]

Sitecore 6.4.1 API
Handler Properties
Handler Class See Also Send Feedback

The Handler type exposes the following members.

Properties

 | Name | Description
Public property | IsReusable | Gets a value indicating whether another request can use the IHttpHandler instance.

See Also

Handler Class
Sitecore.IntegratedSessionFix Namespace


IsReusable Property

[image]

Sitecore 6.4.1 API
Handler..::..IsReusable Property
Handler Class See Also Send Feedback

Namespace: Sitecore.IntegratedSessionFix
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsReusable { get; }
Visual Basic
Public ReadOnly Property IsReusable As Boolean
    Get
Visual C++
public:
virtual property bool IsReusable {
    bool get () sealed;
}

Field Value

Return Value

true if the IHttpHandler instance is reusable; otherwise, false.

Implements

IHttpHandler..::..IsReusable

See Also

Handler Class
Sitecore.IntegratedSessionFix Namespace


Module Class

[image]

Sitecore 6.4.1 API
Module Class
Members See Also Send Feedback

Namespace: Sitecore.IntegratedSessionFix
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute]
public class Module : IHttpModule
Visual Basic
<ObsoleteAttribute> _
Public Class Module _
    Implements IHttpModule
Visual C++
[ObsoleteAttribute]
public ref class Module : IHttpModule

Inheritance Hierarchy

System..::..Object
Sitecore.IntegratedSessionFix..::..Module

See Also

Module Members
Sitecore.IntegratedSessionFix Namespace


Module Members

[image] [image]

Sitecore 6.4.1 API
Module Members
Module Class Constructors Methods See Also Send Feedback

The Module type exposes the following members.

Constructors

 | Name | Description
Public method | Module | Initializes a new instance of the Module class

Methods

 | Name | Description
Public method | Dispose | Disposes of the resources (other than memory) used by the module that implements IHttpModule.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Initializes a module and prepares it to handle requests.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Module Class
Sitecore.IntegratedSessionFix Namespace


Module Constructor

[image]

Sitecore 6.4.1 API
Module Constructor
Module Class See Also Send Feedback

Namespace: Sitecore.IntegratedSessionFix
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Module()
Visual Basic
Public Sub New
Visual C++
public:
Module()

See Also

Module Class
Sitecore.IntegratedSessionFix Namespace


Module Methods

[image] [image]

Sitecore 6.4.1 API
Module Methods
Module Class See Also Send Feedback

The Module type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Disposes of the resources (other than memory) used by the module that implements IHttpModule.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Initializes a module and prepares it to handle requests.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Module Class
Sitecore.IntegratedSessionFix Namespace


Dispose Method

[image]

Sitecore 6.4.1 API
Module..::..Dispose Method
Module Class See Also Send Feedback

Namespace: Sitecore.IntegratedSessionFix
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IHttpModule..::..Dispose()()()()

See Also

Module Class
Sitecore.IntegratedSessionFix Namespace


Init Method

[image]

Sitecore 6.4.1 API
Module..::..Init Method
Module Class See Also Send Feedback

Namespace: Sitecore.IntegratedSessionFix
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Init(
    HttpApplication context
)
Visual Basic
Public Sub Init ( _
    context As HttpApplication _
)
Visual C++
public:
virtual void Init(
    HttpApplication^ context
) sealed

Parameters

context
Type: System.Web..::..HttpApplication
An HttpApplication that provides access to the methods, properties, and events common to all application objects within an ASP.NET application

Implements

IHttpModule..::..Init(HttpApplication)

See Also

Module Class
Sitecore.IntegratedSessionFix Namespace


Sitecore.IO Namespace

[image]

Sitecore 6.4.1 API
Sitecore.IO Namespace
Send Feedback

Classes

 | Class | Description
Public class | Compression | Implements compression for Lucene
Public class | Crc | Calculates Cycling Redundancy Check values.
Public class | Crc64 | Implementation of Crc64 hashing algorithm
Public class | FileUtil | Implements a utility class for manipulating files.
Public class | FileWatcher | Monitors a folder for changes to files.
Public class | LayoutWatcher | Implements a file watcher that looks for changes in the /Layout folder.
Public class | SingleFileWatcher | Defines the single file watcher class.
Public class | StreamSharer | StreamSharer.MetaStream class
Public class | StreamSharer..::..MetaStream | StreamSharer.MetaStream class
Public class | TempFolder | Represents the temporary folder.
Public class | UploadFile | Implements a class for simplifing upload of files from a HTML form.
Public class | XslWatcher | Implements a file watcher that monitors changes in the /Xsl folder.

Enumerations

 | Enumeration | Description
Public enumeration | SpecialFolder | Identifies special folders.


Compression Class

[image]

Sitecore 6.4.1 API
Compression Class
Members See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Compression : ICompressionAdapter
Visual Basic
Public Class Compression _
    Implements ICompressionAdapter
Visual C++
public ref class Compression : ICompressionAdapter

Inheritance Hierarchy

System..::..Object
Sitecore.IO..::..Compression

See Also

Compression Members
Sitecore.IO Namespace


Compression Members

[image] [image]

Sitecore 6.4.1 API
Compression Members
Compression Class Constructors Methods See Also Send Feedback

The Compression type exposes the following members.

Constructors

 | Name | Description
Public method | Compression | Initializes a new instance of the Compression class

Methods

 | Name | Description
Public method | Compress | Compresses the specified input.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Uncompress | Uncompresses the specified input.

See Also

Compression Class
Sitecore.IO Namespace


Compression Constructor

[image]

Sitecore 6.4.1 API
Compression Constructor
Compression Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Compression()
Visual Basic
Public Sub New
Visual C++
public:
Compression()

See Also

Compression Class
Sitecore.IO Namespace


Compression Methods

[image] [image]

Sitecore 6.4.1 API
Compression Methods
Compression Class See Also Send Feedback

The Compression type exposes the following members.

Methods

 | Name | Description
Public method | Compress | Compresses the specified input.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Uncompress | Uncompresses the specified input.

See Also

Compression Class
Sitecore.IO Namespace


Compress Method

[image]

Sitecore 6.4.1 API
Compression..::..Compress Method
Compression Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public byte[] Compress(
    byte[] input
)
Visual Basic
Public Function Compress ( _
    input As Byte() _
) As Byte()
Visual C++
public:
virtual array<unsigned char>^ Compress(
    array<unsigned char>^ input
) sealed

Parameters

input
Type: array< System..::..Byte >[]()[][]
The input.

Return Value

[Missing <returns> documentation for "M:Sitecore.IO.Compression.Compress(System.Byte[])"]

See Also

Compression Class
Sitecore.IO Namespace


Uncompress Method

[image]

Sitecore 6.4.1 API
Compression..::..Uncompress Method
Compression Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public byte[] Uncompress(
    byte[] input
)
Visual Basic
Public Function Uncompress ( _
    input As Byte() _
) As Byte()
Visual C++
public:
virtual array<unsigned char>^ Uncompress(
    array<unsigned char>^ input
) sealed

Parameters

input
Type: array< System..::..Byte >[]()[][]
The input.

Return Value

[Missing <returns> documentation for "M:Sitecore.IO.Compression.Uncompress(System.Byte[])"]

See Also

Compression Class
Sitecore.IO Namespace


Crc Class

[image]

Sitecore 6.4.1 API
Crc Class
Members See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Crc
Visual Basic
Public NotInheritable Class Crc
Visual C++
public ref class Crc abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.IO..::..Crc

See Also

Crc Members
Sitecore.IO Namespace


Crc Members

[image] [image]

Sitecore 6.4.1 API
Crc Members
Crc Class Methods See Also Send Feedback

Methods

Name | Description
CRC(array<Byte>[]()[][]) | Calculates the Crc value of the specified byte array.
CRC(Stream) | Calculates the Crc value of the specified stream.
CRC(String) | Calculates the Crc value of the specified string.
CRC(Stream, Int64, Int64) | Calculates the Crc value of the specified stream.

See Also

Crc Class
Sitecore.IO Namespace


Crc Methods

[image] [image]

Sitecore 6.4.1 API
Crc Methods
Crc Class See Also Send Feedback

Methods

Name | Description
CRC(array<Byte>[]()[][]) | Calculates the Crc value of the specified byte array.
CRC(Stream) | Calculates the Crc value of the specified stream.
CRC(String) | Calculates the Crc value of the specified string.
CRC(Stream, Int64, Int64) | Calculates the Crc value of the specified stream.

See Also

Crc Class
Sitecore.IO Namespace


CRC Method

[image] [image]

Sitecore 6.4.1 API
Crc..::..CRC Method
Crc Class See Also Send Feedback

Overload List

Name | Description
CRC(array<Byte>[]()[][]) | Calculates the Crc value of the specified byte array.
CRC(Stream) | Calculates the Crc value of the specified stream.
CRC(String) | Calculates the Crc value of the specified string.
CRC(Stream, Int64, Int64) | Calculates the Crc value of the specified stream.

See Also

Crc Class
Crc Members
Sitecore.IO Namespace


CRC Method (Byte[])

[image]

Sitecore 6.4.1 API
Crc..::..CRC Method (array<Byte>[]()[][])
Crc Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long CRC(
    byte[] bytes
)
Visual Basic
Public Shared Function CRC ( _
    bytes As Byte() _
) As Long
Visual C++
public:
static long long CRC(
    array<unsigned char>^ bytes
)

Parameters

bytes
Type: array< System..::..Byte >[]()[][]
The bytes.

Return Value

The Crc value

See Also

Crc Class
CRC Overload
Sitecore.IO Namespace


CRC Method (Stream)

[image]

Sitecore 6.4.1 API
Crc..::..CRC Method (Stream)
Crc Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long CRC(
    Stream stream
)
Visual Basic
Public Shared Function CRC ( _
    stream As Stream _
) As Long
Visual C++
public:
static long long CRC(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::..Stream
The stream.

Return Value

The Crc value

See Also

Crc Class
CRC Overload
Sitecore.IO Namespace


CRC Method (String)

[image]

Sitecore 6.4.1 API
Crc..::..CRC Method (String)
Crc Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long CRC(
    string text
)
Visual Basic
Public Shared Function CRC ( _
    text As String _
) As Long
Visual C++
public:
static long long CRC(
    String^ text
)

Parameters

text
Type: System..::..String
The text.

Return Value

The Crc value

See Also

Crc Class
CRC Overload
Sitecore.IO Namespace


CRC Method (Stream, Int64, Int64)

[image]

Sitecore 6.4.1 API
Crc..::..CRC Method (Stream, Int64, Int64)
Crc Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long CRC(
    Stream stream,
    long offset,
    long length
)
Visual Basic
Public Shared Function CRC ( _
    stream As Stream, _
    offset As Long, _
    length As Long _
) As Long
Visual C++
public:
static long long CRC(
    Stream^ stream,
    long long offset,
    long long length
)

Parameters

stream
Type: System.IO..::..Stream
The stream.
offset
Type: System..::..Int64
The offset.
length
Type: System..::..Int64
The length.

Return Value

The Crc value

See Also

Crc Class
CRC Overload
Sitecore.IO Namespace


Crc64 Class

[image]

Sitecore 6.4.1 API
Crc64 Class
Members See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Crc64 : HashAlgorithm
Visual Basic
Public Class Crc64 _
    Inherits HashAlgorithm
Visual C++
public ref class Crc64 : public HashAlgorithm

Inheritance Hierarchy

System..::..Object
System.Security.Cryptography..::..HashAlgorithm
Sitecore.IO..::..Crc64

See Also

Crc64 Members
Sitecore.IO Namespace


Crc64 Members

[image] [image]

Sitecore 6.4.1 API
Crc64 Members
Crc64 Class Constructors Methods Fields Properties See Also Send Feedback

The Crc64 type exposes the following members.

Constructors

 | Name | Description
Public method | Crc64()()()() | Initializes a new instance of the Crc64 class.
Public method | Crc64(UInt64) | Initializes a new instance of the Crc64 class.

Methods

 | Name | Description
Public method | Clear | Releases all resources used by the HashAlgorithm class. (Inherited from HashAlgorithm.)
 | Compute | Computes hash for the specified buffer.
Public method | ComputeHash(Stream) | Computes the hash value for the specified Stream object. (Inherited from HashAlgorithm.)
Public method | ComputeHash(array<Byte>[]()[][]) | Computes the hash value for the specified byte array. (Inherited from HashAlgorithm.)
Public method | ComputeHash(array<Byte>[]()[][], Int32, Int32) | Computes the hash value for the specified region of the specified byte array. (Inherited from HashAlgorithm.)
Protected method | Dispose | Releases the unmanaged resources used by the HashAlgorithm and optionally releases the managed resources. (Inherited from HashAlgorithm.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HashCore | Computes hash. (Overrides HashAlgorithm..::..HashCore(array<Byte>[]()[][], Int32, Int32).)
Protected method | HashFinal | When overridden in a derived class, finalizes the hash computation after the last data is processed by the cryptographic stream object. (Overrides HashAlgorithm..::..HashFinal()()()().)
Public method | Initialize | Initializes an implementation of the HashAlgorithm class. (Overrides HashAlgorithm..::..Initialize()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformBlock | Computes the hash value for the specified region of the input byte array and copies the resulting hash value to the specified region of the output byte array. (Inherited from HashAlgorithm.)
Public method | TransformFinalBlock | Computes the hash value for the specified region of the specified byte array. (Inherited from HashAlgorithm.)

Fields

 | Name | Description
 | DefaultSeed | Default seed
Protected field | HashSizeValue | Represents the size, in bits, of the computed hash code. (Inherited from HashAlgorithm.)
Protected field | HashValue | Represents the value of the computed hash code. (Inherited from HashAlgorithm.)
Protected field | State | Represents the state of the hash computation. (Inherited from HashAlgorithm.)

Properties

 | Name | Description
Public property | CanReuseTransform | Gets a value indicating whether the current transform can be reused. (Inherited from HashAlgorithm.)
Public property | CanTransformMultipleBlocks | When overridden in a derived class, gets a value indicating whether multiple blocks can be transformed. (Inherited from HashAlgorithm.)
Public property | Hash | Gets the value of the computed hash code. (Inherited from HashAlgorithm.)
Public property | HashSize | Gets the size, in bits, of the computed hash code. (Overrides HashAlgorithm..::..HashSize.)
Public property | InputBlockSize | When overridden in a derived class, gets the input block size. (Inherited from HashAlgorithm.)
Public property | OutputBlockSize | When overridden in a derived class, gets the output block size. (Inherited from HashAlgorithm.)

See Also

Crc64 Class
Sitecore.IO Namespace


Crc64 Constructor

[image] [image]

Sitecore 6.4.1 API
Crc64 Constructor
Crc64 Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Crc64()()()() | Initializes a new instance of the Crc64 class.
Public method | Crc64(UInt64) | Initializes a new instance of the Crc64 class.

See Also

Crc64 Class
Crc64 Members
Sitecore.IO Namespace


Crc64 Constructor

[image]

Sitecore 6.4.1 API
Crc64 Constructor
Crc64 Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Crc64()
Visual Basic
Public Sub New
Visual C++
public:
Crc64()

See Also

Crc64 Class
Crc64 Overload
Sitecore.IO Namespace


Crc64 Constructor (UInt64)

[image]

Sitecore 6.4.1 API
Crc64 Constructor (UInt64)
Crc64 Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Crc64(
    ulong seed
)
Visual Basic
Public Sub New ( _
    seed As ULong _
)
Visual C++
public:
Crc64(
    unsigned long long seed
)

Parameters

seed
Type: System..::..UInt64
The seed.

See Also

Crc64 Class
Crc64 Overload
Sitecore.IO Namespace


Crc64 Fields

[image] [image]

Sitecore 6.4.1 API
Crc64 Fields
Crc64 Class See Also Send Feedback

The Crc64 type exposes the following members.

Fields

 | Name | Description
 | DefaultSeed | Default seed
Protected field | HashSizeValue | Represents the size, in bits, of the computed hash code. (Inherited from HashAlgorithm.)
Protected field | HashValue | Represents the value of the computed hash code. (Inherited from HashAlgorithm.)
Protected field | State | Represents the state of the hash computation. (Inherited from HashAlgorithm.)

See Also

Crc64 Class
Sitecore.IO Namespace


DefaultSeed Field

[image]

Sitecore 6.4.1 API
Crc64..::..DefaultSeed Field
Crc64 Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const ulong DefaultSeed
Visual Basic
Public Const DefaultSeed As ULong
Visual C++
public:
literal unsigned long long DefaultSeed

See Also

Crc64 Class
Sitecore.IO Namespace


Crc64 Methods

[image] [image]

Sitecore 6.4.1 API
Crc64 Methods
Crc64 Class See Also Send Feedback

The Crc64 type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Releases all resources used by the HashAlgorithm class. (Inherited from HashAlgorithm.)
 | Compute | Computes hash for the specified buffer.
Public method | ComputeHash(Stream) | Computes the hash value for the specified Stream object. (Inherited from HashAlgorithm.)
Public method | ComputeHash(array<Byte>[]()[][]) | Computes the hash value for the specified byte array. (Inherited from HashAlgorithm.)
Public method | ComputeHash(array<Byte>[]()[][], Int32, Int32) | Computes the hash value for the specified region of the specified byte array. (Inherited from HashAlgorithm.)
Protected method | Dispose | Releases the unmanaged resources used by the HashAlgorithm and optionally releases the managed resources. (Inherited from HashAlgorithm.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HashCore | Computes hash. (Overrides HashAlgorithm..::..HashCore(array<Byte>[]()[][], Int32, Int32).)
Protected method | HashFinal | When overridden in a derived class, finalizes the hash computation after the last data is processed by the cryptographic stream object. (Overrides HashAlgorithm..::..HashFinal()()()().)
Public method | Initialize | Initializes an implementation of the HashAlgorithm class. (Overrides HashAlgorithm..::..Initialize()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformBlock | Computes the hash value for the specified region of the input byte array and copies the resulting hash value to the specified region of the output byte array. (Inherited from HashAlgorithm.)
Public method | TransformFinalBlock | Computes the hash value for the specified region of the specified byte array. (Inherited from HashAlgorithm.)

See Also

Crc64 Class
Sitecore.IO Namespace


Compute Method

[image]

Sitecore 6.4.1 API
Crc64..::..Compute Method
Crc64 Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ulong Compute(
    ulong seed,
    byte[] buffer
)
Visual Basic
Public Shared Function Compute ( _
    seed As ULong, _
    buffer As Byte() _
) As ULong
Visual C++
public:
static unsigned long long Compute(
    unsigned long long seed,
    array<unsigned char>^ buffer
)

Parameters

seed
Type: System..::..UInt64
The seed.
buffer
Type: array< System..::..Byte >[]()[][]
The buffer.

Return Value

[Missing <returns> documentation for "M:Sitecore.IO.Crc64.Compute(System.UInt64,System.Byte[])"]

See Also

Crc64 Class
Sitecore.IO Namespace


ComputeHash Method

[image] [image]

Sitecore 6.4.1 API
Crc64..::..ComputeHash Method
Crc64 Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ComputeHash(Stream) | Computes the hash value for the specified Stream object. (Inherited from HashAlgorithm.)
Public method | ComputeHash(array<Byte>[]()[][]) | Computes the hash value for the specified byte array. (Inherited from HashAlgorithm.)
Public method | ComputeHash(array<Byte>[]()[][], Int32, Int32) | Computes the hash value for the specified region of the specified byte array. (Inherited from HashAlgorithm.)

See Also

Crc64 Class
Crc64 Members
Sitecore.IO Namespace


HashCore Method

[image]

Sitecore 6.4.1 API
Crc64..::..HashCore Method
Crc64 Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void HashCore(
    byte[] buffer,
    int start,
    int length
)
Visual Basic
Protected Overrides Sub HashCore ( _
    buffer As Byte(), _
    start As Integer, _
    length As Integer _
)
Visual C++
protected:
virtual void HashCore(
    array<unsigned char>^ buffer,
    int start,
    int length
) override

Parameters

buffer
Type: array< System..::..Byte >[]()[][]
The buffer.
start
Type: System..::..Int32
The start.
length
Type: System..::..Int32
The length.

See Also

Crc64 Class
Sitecore.IO Namespace


HashFinal Method

[image]

Sitecore 6.4.1 API
Crc64..::..HashFinal Method
Crc64 Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override byte[] HashFinal()
Visual Basic
Protected Overrides Function HashFinal As Byte()
Visual C++
protected:
virtual array<unsigned char>^ HashFinal() override

Return Value

The computed hash code.

See Also

Crc64 Class
Sitecore.IO Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
Crc64..::..Initialize Method
Crc64 Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Initialize()
Visual Basic
Public Overrides Sub Initialize
Visual C++
public:
virtual void Initialize() override

See Also

Crc64 Class
Sitecore.IO Namespace


HashSize Property

[image]

Sitecore 6.4.1 API
Crc64..::..HashSize Property
Crc64 Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override int HashSize { get; }
Visual Basic
Public Overrides ReadOnly Property HashSize As Integer
    Get
Visual C++
public:
virtual property int HashSize {
    int get () override;
}

Field Value

Return Value

The size, in bits, of the computed hash code.

See Also

Crc64 Class
Sitecore.IO Namespace


FileUtil Members

[image] [image]

Sitecore 6.4.1 API
FileUtil Members
FileUtil Class Methods See Also Send Feedback

The FileUtil type exposes the following members.

Methods

Name | Description
AppendToFile | Appends the text to a file.
Backup | Makes a backup file from an XML document.
BackupFile | Copies a file to a file with a ".bak" extension.
BackupFilename | Generates a backup filename with an ".bak" extension.
CloseFileStream | Closes a file stream.
CloseStream | Closes a stream.
CopyStream(Stream, Stream) | Copies one stream to another.
CopyStream(Stream, Stream, Int32) | Copies one stream to another.
CopyTextFile | Copies the text file.
CreateFile | Creates the file.
CreateFolder | Create a folder (if it does not exist).
Delete(String) | Deletes a file.
Delete(String, Boolean) | Deletes a file.
DeleteDirectory(String) | Deletes a directory.
DeleteDirectory(String, Boolean) | Deletes a directory.
EmptyDirectory | Deletes all files in the specified directory and all its subdirectories.
EnsureFileFolder | Ensures that the folder part of a file path exists.
EnsureFolder | Ensures that the folder part of a path exists.
Exists | Checks if a file or folder exists.
FileExists | Checks if a file exists.
FolderExists | Checks if a folder exists.
GetBackupFilename(String) | Gets a filename for a backup file.
GetBackupFilename(String, String, String) | Gets a filename for a backup file.
GetExtension | Gets the file extension of a path (without a leading dot).
GetFileLock | Gets file specific lock object.
GetFileName | Gets the name of the file.
GetFilePathFromFileUri | Converts the file URI to a file path.
GetFiles | Gets the files matching a pattern.
GetFileSize | Gets the size if a file.
GetFileTime | Gets the last modified time of a file.
GetFileWriteTime | Gets the last modified time of a file.
GetParentPath | Gets the parent path.
GetPathSeparator | Determines the separator used in a filename path.
GetSpecialFolder | Gets the special folder.
GetUniqueFilename | Gets a unique filename.
GetValidFilePath | Gets a valid filename from a proposed path (ie. strip invalid chars).
GetWorkFilename | Gets a unique filename.
IsAspxFile | Check if a path denotes an aspx file.
IsFile | Determines whether the specified path is an existing file.
IsFolder | Determines whether the specified path is an existing folder.
IsFullyQualified | Determines whether the filename is fully qualified.
IsReadOnly | Determines whether the specified file is read only.
IsWritable | Determines whether the specified file is writable.
LoadHashtable | Loads a hashtable from a file.
LoadObject | Loads the object from a file.
MakePath(String, String) | Makes a path from two filename parts.
MakePath(String, String, Char) | Makes a path from two filename parts.
MapDataFilePath | Maps a filename to a physical filename in the data folder.
MapPath | Maps a virtual file path to a physical file path.
MatchPattern | Checks whether the value matches the pattern.
NormalizeWebPath | Normalizes the web path by replacing all backslashes (\) with forward slashes (/).
OpenCreate | Creates a new file and opens it in read/write mode.
OpenFileStream | Opens the file stream.
OpenRead | Opens a file in read mode.
OpenWrite | Opens a file in write mode.
ReadBinaryFile | Reads the binary file.
ReadFromFile | Reads a text file.
ReadUTF8File | Reads the file in UTF8 encoding.
ReplaceVariables | Replaces variables in a filename.
Save | Saves an XML document to a file.
SaveHashtable | Saves a hashtable to a file.
SaveObject | Saves an object to a file.
SaveToTemporaryFile | Saves the Media Item's MediaStream to a temporary file and returns the path to that file.
SubtractPath | Subtracts one path from another.
UnmapPath(String) | Maps a physical path to a virtual path.
UnmapPath(String, Boolean) | Maps a physical path to a virtual path.
WriteToFile(String, array<Byte>[]()[][]%) | Writes a byte array to a file.
WriteToFile(String, String) | Writes a string to a file.
WriteToFile(String, String, Boolean) | Write or appends a atring to a file.
WriteToStream | Writes one stream to another stream.
WriteUTF8File | Writes the file in UTF8 encoding.
ZipFiles | Zips a list of files.

See Also

FileUtil Class
Sitecore.IO Namespace


FileUtil Methods

[image] [image]

Sitecore 6.4.1 API
FileUtil Methods
FileUtil Class See Also Send Feedback

The FileUtil type exposes the following members.

Methods

Name | Description
AppendToFile | Appends the text to a file.
Backup | Makes a backup file from an XML document.
BackupFile | Copies a file to a file with a ".bak" extension.
BackupFilename | Generates a backup filename with an ".bak" extension.
CloseFileStream | Closes a file stream.
CloseStream | Closes a stream.
CopyStream(Stream, Stream) | Copies one stream to another.
CopyStream(Stream, Stream, Int32) | Copies one stream to another.
CopyTextFile | Copies the text file.
CreateFile | Creates the file.
CreateFolder | Create a folder (if it does not exist).
Delete(String) | Deletes a file.
Delete(String, Boolean) | Deletes a file.
DeleteDirectory(String) | Deletes a directory.
DeleteDirectory(String, Boolean) | Deletes a directory.
EmptyDirectory | Deletes all files in the specified directory and all its subdirectories.
EnsureFileFolder | Ensures that the folder part of a file path exists.
EnsureFolder | Ensures that the folder part of a path exists.
Exists | Checks if a file or folder exists.
FileExists | Checks if a file exists.
FolderExists | Checks if a folder exists.
GetBackupFilename(String) | Gets a filename for a backup file.
GetBackupFilename(String, String, String) | Gets a filename for a backup file.
GetExtension | Gets the file extension of a path (without a leading dot).
GetFileLock | Gets file specific lock object.
GetFileName | Gets the name of the file.
GetFilePathFromFileUri | Converts the file URI to a file path.
GetFiles | Gets the files matching a pattern.
GetFileSize | Gets the size if a file.
GetFileTime | Gets the last modified time of a file.
GetFileWriteTime | Gets the last modified time of a file.
GetParentPath | Gets the parent path.
GetPathSeparator | Determines the separator used in a filename path.
GetSpecialFolder | Gets the special folder.
GetUniqueFilename | Gets a unique filename.
GetValidFilePath | Gets a valid filename from a proposed path (ie. strip invalid chars).
GetWorkFilename | Gets a unique filename.
IsAspxFile | Check if a path denotes an aspx file.
IsFile | Determines whether the specified path is an existing file.
IsFolder | Determines whether the specified path is an existing folder.
IsFullyQualified | Determines whether the filename is fully qualified.
IsReadOnly | Determines whether the specified file is read only.
IsWritable | Determines whether the specified file is writable.
LoadHashtable | Loads a hashtable from a file.
LoadObject | Loads the object from a file.
MakePath(String, String) | Makes a path from two filename parts.
MakePath(String, String, Char) | Makes a path from two filename parts.
MapDataFilePath | Maps a filename to a physical filename in the data folder.
MapPath | Maps a virtual file path to a physical file path.
MatchPattern | Checks whether the value matches the pattern.
NormalizeWebPath | Normalizes the web path by replacing all backslashes (\) with forward slashes (/).
OpenCreate | Creates a new file and opens it in read/write mode.
OpenFileStream | Opens the file stream.
OpenRead | Opens a file in read mode.
OpenWrite | Opens a file in write mode.
ReadBinaryFile | Reads the binary file.
ReadFromFile | Reads a text file.
ReadUTF8File | Reads the file in UTF8 encoding.
ReplaceVariables | Replaces variables in a filename.
Save | Saves an XML document to a file.
SaveHashtable | Saves a hashtable to a file.
SaveObject | Saves an object to a file.
SaveToTemporaryFile | Saves the Media Item's MediaStream to a temporary file and returns the path to that file.
SubtractPath | Subtracts one path from another.
UnmapPath(String) | Maps a physical path to a virtual path.
UnmapPath(String, Boolean) | Maps a physical path to a virtual path.
WriteToFile(String, array<Byte>[]()[][]%) | Writes a byte array to a file.
WriteToFile(String, String) | Writes a string to a file.
WriteToFile(String, String, Boolean) | Write or appends a atring to a file.
WriteToStream | Writes one stream to another stream.
WriteUTF8File | Writes the file in UTF8 encoding.
ZipFiles | Zips a list of files.

See Also

FileUtil Class
Sitecore.IO Namespace


AppendToFile Method

[image]

Sitecore 6.4.1 API
FileUtil..::..AppendToFile Method
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void AppendToFile(
    string filename,
    string text
)
Visual Basic
Public Shared Sub AppendToFile ( _
    filename As String, _
    text As String _
)
Visual C++
public:
static void AppendToFile(
    String^ filename,
    String^ text
)

Parameters

filename
Type: System..::..String
The filename.
text
Type: System..::..String
The text.

See Also

FileUtil Class
Sitecore.IO Namespace


Backup Method

[image]

Sitecore 6.4.1 API
FileUtil..::..Backup Method
FileUtil Class Example See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Backup(
    XmlDocument doc,
    string baseFilename
)
Visual Basic
Public Shared Sub Backup ( _
    doc As XmlDocument, _
    baseFilename As String _
)
Visual C++
public:
static void Backup(
    XmlDocument^ doc,
    String^ baseFilename
)

Parameters

doc
Type: System.Xml..::..XmlDocument
An XML document which will be placed in the backup file.
baseFilename
Type: System..::..String
The base filename of the backup file. This name will be extended to make it unique within the backup folder.

Remarks

An exception is thrown if the XML document is null or the filename is blank.

Examples

The following example takes a backup of an XML document.
CopyC#
XmlDocument doc = new XmlDocument();
doc.LoadXml(myXmlString);
FileUtil.Backup(doc, "MyXml.xml");

See Also

FileUtil Class
Sitecore.IO Namespace


BackupFile Method

[image]

Sitecore 6.4.1 API
FileUtil..::..BackupFile Method
FileUtil Class Example See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string BackupFile(
    string filename
)
Visual Basic
Public Shared Function BackupFile ( _
    filename As String _
) As String
Visual C++
public:
static String^ BackupFile(
    String^ filename
)

Parameters

filename
Type: System..::..String
The filename of the file which will be copied.

Return Value

The filename of the backup file.

Remarks

If the file does not exist, no file is copied and blank is returned.

Examples

The following example takes a backup of the robots.txt file in the root folder of the website. Afterwards there will be a robots.bak in the root folder.
CopyC#
string filename = MainUtil.MapPath("robots.txt");
FileUtil.BackupFile(filename);

See Also

FileUtil Class
Sitecore.IO Namespace


BackupFilename Method

[image]

Sitecore 6.4.1 API
FileUtil..::..BackupFilename Method
FileUtil Class Example See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string BackupFilename(
    string filename
)
Visual Basic
Public Shared Function BackupFilename ( _
    filename As String _
) As String
Visual C++
public:
static String^ BackupFilename(
    String^ filename
)

Parameters

filename
Type: System..::..String
A filename.

Return Value

The filename with the a new extension ".bak".

Examples

The following example generates a backup filename.
CopyC#
string filename = "MyXml.xml";
string backupname = FileUtil.BackupFilename(filename);
 The filename variable is "MyXml.bak" afterwards.

See Also

FileUtil Class
Sitecore.IO Namespace


CloseFileStream Method

[image]

Sitecore 6.4.1 API
FileUtil..::..CloseFileStream Method
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void CloseFileStream(
    FileStream stream
)
Visual Basic
Public Shared Sub CloseFileStream ( _
    stream As FileStream _
)
Visual C++
public:
static void CloseFileStream(
    FileStream^ stream
)

Parameters

stream
Type: System.IO..::..FileStream
The file.

See Also

FileUtil Class
Sitecore.IO Namespace


CloseStream Method

[image]

Sitecore 6.4.1 API
FileUtil..::..CloseStream Method
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void CloseStream(
    Stream stream
)
Visual Basic
Public Shared Sub CloseStream ( _
    stream As Stream _
)
Visual C++
public:
static void CloseStream(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::..Stream
The stream.

See Also

FileUtil Class
Sitecore.IO Namespace


CopyStream Method

[image] [image]

Sitecore 6.4.1 API
FileUtil..::..CopyStream Method
FileUtil Class See Also Send Feedback

Overload List

Name | Description
CopyStream(Stream, Stream) | Copies one stream to another.
CopyStream(Stream, Stream, Int32) | Copies one stream to another.

See Also

FileUtil Class
FileUtil Members
Sitecore.IO Namespace


CopyStream Method (Stream, Stream)

[image]

Sitecore 6.4.1 API
FileUtil..::..CopyStream Method (Stream, Stream)
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void CopyStream(
    Stream from,
    Stream to
)
Visual Basic
Public Shared Sub CopyStream ( _
    from As Stream, _
    to As Stream _
)
Visual C++
public:
static void CopyStream(
    Stream^ from,
    Stream^ to
)

Parameters

from
Type: System.IO..::..Stream
From.
to
Type: System.IO..::..Stream
To.

See Also

FileUtil Class
CopyStream Overload
Sitecore.IO Namespace


CopyStream Method (Stream, Stream, Int32)

[image]

Sitecore 6.4.1 API
FileUtil..::..CopyStream Method (Stream, Stream, Int32)
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void CopyStream(
    Stream from,
    Stream to,
    int bufferSize
)
Visual Basic
Public Shared Sub CopyStream ( _
    from As Stream, _
    to As Stream, _
    bufferSize As Integer _
)
Visual C++
public:
static void CopyStream(
    Stream^ from,
    Stream^ to,
    int bufferSize
)

Parameters

from
Type: System.IO..::..Stream
From.
to
Type: System.IO..::..Stream
To.
bufferSize
Type: System..::..Int32
Size of the buffer.

See Also

FileUtil Class
CopyStream Overload
Sitecore.IO Namespace


CopyTextFile Method

[image]

Sitecore 6.4.1 API
FileUtil..::..CopyTextFile Method
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void CopyTextFile(
    string destination,
    string source
)
Visual Basic
Public Shared Sub CopyTextFile ( _
    destination As String, _
    source As String _
)
Visual C++
public:
static void CopyTextFile(
    String^ destination,
    String^ source
)

Parameters

destination
Type: System..::..String
The destination.
source
Type: System..::..String
The source.

Remarks

The file is saved in UTF8 encoding.

See Also

FileUtil Class
Sitecore.IO Namespace


CreateFile Method

[image]

Sitecore 6.4.1 API
FileUtil..::..CreateFile Method
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void CreateFile(
    string filePath,
    Stream inputStream,
    bool closeStream
)
Visual Basic
Public Shared Sub CreateFile ( _
    filePath As String, _
    inputStream As Stream, _
    closeStream As Boolean _
)
Visual C++
public:
static void CreateFile(
    String^ filePath,
    Stream^ inputStream,
    bool closeStream
)

Parameters

filePath
Type: System..::..String
The file path.
inputStream
Type: System.IO..::..Stream
The input stream.
closeStream
Type: System..::..Boolean
if set to true the input stream will be closed.

See Also

FileUtil Class
Sitecore.IO Namespace


CreateFolder Method

[image]

Sitecore 6.4.1 API
FileUtil..::..CreateFolder Method
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool CreateFolder(
    string folder
)
Visual Basic
Public Shared Function CreateFolder ( _
    folder As String _
) As Boolean
Visual C++
public:
static bool CreateFolder(
    String^ folder
)

Parameters

folder
Type: System..::..String
The path.

Return Value

[Missing <returns> documentation for "M:Sitecore.IO.FileUtil.CreateFolder(System.String)"]

See Also

FileUtil Class
Sitecore.IO Namespace


Delete Method

[image] [image]

Sitecore 6.4.1 API
FileUtil..::..Delete Method
FileUtil Class See Also Send Feedback

Overload List

Name | Description
Delete(String) | Deletes a file.
Delete(String, Boolean) | Deletes a file.

See Also

FileUtil Class
FileUtil Members
Sitecore.IO Namespace


Delete Method (String)

[image]

Sitecore 6.4.1 API
FileUtil..::..Delete Method (String)
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Delete(
    string fileName
)
Visual Basic
Public Shared Sub Delete ( _
    fileName As String _
)
Visual C++
public:
static void Delete(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
The path of the file.

See Also

FileUtil Class
Delete Overload
Sitecore.IO Namespace


Delete Method (String, Boolean)

[image]

Sitecore 6.4.1 API
FileUtil..::..Delete Method (String, Boolean)
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Delete(
    string path,
    bool includeDirectories
)
Visual Basic
Public Shared Sub Delete ( _
    path As String, _
    includeDirectories As Boolean _
)
Visual C++
public:
static void Delete(
    String^ path,
    bool includeDirectories
)

Parameters

path
Type: System..::..String
The path of the file.
includeDirectories
Type: System..::..Boolean
if set to true this instance includes directories.

See Also

FileUtil Class
Delete Overload
Sitecore.IO Namespace


DeleteDirectory Method

[image] [image]

Sitecore 6.4.1 API
FileUtil..::..DeleteDirectory Method
FileUtil Class See Also Send Feedback

Overload List

Name | Description
DeleteDirectory(String) | Deletes a directory.
DeleteDirectory(String, Boolean) | Deletes a directory.

See Also

FileUtil Class
FileUtil Members
Sitecore.IO Namespace


DeleteDirectory Method (String)

[image]

Sitecore 6.4.1 API
FileUtil..::..DeleteDirectory Method (String)
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void DeleteDirectory(
    string folder
)
Visual Basic
Public Shared Sub DeleteDirectory ( _
    folder As String _
)
Visual C++
public:
static void DeleteDirectory(
    String^ folder
)

Parameters

folder
Type: System..::..String
The path of the directory.

See Also

FileUtil Class
DeleteDirectory Overload
Sitecore.IO Namespace


DeleteDirectory Method (String, Boolean)

[image]

Sitecore 6.4.1 API
FileUtil..::..DeleteDirectory Method (String, Boolean)
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void DeleteDirectory(
    string folder,
    bool recursive
)
Visual Basic
Public Shared Sub DeleteDirectory ( _
    folder As String, _
    recursive As Boolean _
)
Visual C++
public:
static void DeleteDirectory(
    String^ folder,
    bool recursive
)

Parameters

folder
Type: System..::..String
The path of the directory.
recursive
Type: System..::..Boolean
if set to true the action is recursive.

See Also

FileUtil Class
DeleteDirectory Overload
Sitecore.IO Namespace


EmptyDirectory Method

[image]

Sitecore 6.4.1 API
FileUtil..::..EmptyDirectory Method
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void EmptyDirectory(
    string folder
)
Visual Basic
Public Shared Sub EmptyDirectory ( _
    folder As String _
)
Visual C++
public:
static void EmptyDirectory(
    String^ folder
)

Parameters

folder
Type: System..::..String

[Missing <param name="folder"/> documentation for "M:Sitecore.IO.FileUtil.EmptyDirectory(System.String)"]

See Also

FileUtil Class
Sitecore.IO Namespace


EnsureFileFolder Method

[image]

Sitecore 6.4.1 API
FileUtil..::..EnsureFileFolder Method
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void EnsureFileFolder(
    string filePath
)
Visual Basic
Public Shared Sub EnsureFileFolder ( _
    filePath As String _
)
Visual C++
public:
static void EnsureFileFolder(
    String^ filePath
)

Parameters

filePath
Type: System..::..String
The file path.

Remarks

For example, given the file path:

/images/new/image.jpg

the method will ensure that the folder '/images/new' is created if it does not exist.

See Also

FileUtil Class
Sitecore.IO Namespace


EnsureFolder Method

[image]

Sitecore 6.4.1 API
FileUtil..::..EnsureFolder Method
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void EnsureFolder(
    string path
)
Visual Basic
Public Shared Sub EnsureFolder ( _
    path As String _
)
Visual C++
public:
static void EnsureFolder(
    String^ path
)

Parameters

path
Type: System..::..String
The path.

See Also

FileUtil Class
Sitecore.IO Namespace


FileExists Method

[image]

Sitecore 6.4.1 API
FileUtil..::..FileExists Method
FileUtil Class Example See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool FileExists(
    string filename
)
Visual Basic
Public Shared Function FileExists ( _
    filename As String _
) As Boolean
Visual C++
public:
static bool FileExists(
    String^ filename
)

Parameters

filename
Type: System..::..String
The name of the file.

Return Value

True, if the file exists, otherwise false.

Examples

The following example checks if the robots.txt file exists and if it does make a backup of it.
CopyC#
string filename = MainUtil.MapPath("robots.txt");
if (FileUtil.FileExists(filename)) {
FileUtil.BackupFile(filename);
}

See Also

FileUtil Class
Sitecore.IO Namespace


FolderExists Method

[image]

Sitecore 6.4.1 API
FileUtil..::..FolderExists Method
FileUtil Class Example See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool FolderExists(
    string folder
)
Visual Basic
Public Shared Function FolderExists ( _
    folder As String _
) As Boolean
Visual C++
public:
static bool FolderExists(
    String^ folder
)

Parameters

folder
Type: System..::..String
The name of the folder.

Return Value

True, if the folder exists, otherwise false.

Examples

The following example checks if the data folder exists.
CopyC#
string folderPath = MainUtil.MapPath("/data");
if (FileUtil.FolderExists(folderPath)) {
MainUtil.Out("Folder exists: " + folderPath);
}

See Also

FileUtil Class
Sitecore.IO Namespace


GetBackupFilename Method

[image] [image]

Sitecore 6.4.1 API
FileUtil..::..GetBackupFilename Method
FileUtil Class See Also Send Feedback

Overload List

Name | Description
GetBackupFilename(String) | Gets a filename for a backup file.
GetBackupFilename(String, String, String) | Gets a filename for a backup file.

See Also

FileUtil Class
FileUtil Members
Sitecore.IO Namespace


GetBackupFilename Method (String)

[image]

Sitecore 6.4.1 API
FileUtil..::..GetBackupFilename Method (String)
FileUtil Class Example See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetBackupFilename(
    string baseFilename
)
Visual Basic
Public Shared Function GetBackupFilename ( _
    baseFilename As String _
) As String
Visual C++
public:
static String^ GetBackupFilename(
    String^ baseFilename
)

Parameters

baseFilename
Type: System..::..String
The base filename.

Return Value

A unique filename.

Remarks

The filename is made unique by inserting a timestamp in the filename. The timestamp is a ISO formatted date/time string. The date/time string is formatted as "yyyyMMddTHHmmss".

Examples

The following example finds the backup filename for the robots.txt. Afterwards the backupname variable holds a name like "c:\inetpub\wwwroot\default website\robots_20030101T120000.txt".
CopyC#
string filename = MainUtil.MapPath("robots.txt");
string backupname = FileUtil.GetBackupFilename(filename);

See Also

FileUtil Class
GetBackupFilename Overload
Sitecore.IO Namespace


GetBackupFilename Method (String, String, String)

[image]

Sitecore 6.4.1 API
FileUtil..::..GetBackupFilename Method (String, String, String)
FileUtil Class Example See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetBackupFilename(
    string folder,
    string prefix,
    string extension
)
Visual Basic
Public Shared Function GetBackupFilename ( _
    folder As String, _
    prefix As String, _
    extension As String _
) As String
Visual C++
public:
static String^ GetBackupFilename(
    String^ folder,
    String^ prefix,
    String^ extension
)

Parameters

folder
Type: System..::..String
The folder of a file.
prefix
Type: System..::..String
The file prefix of a file (usually the filename itself).
extension
Type: System..::..String
The extension of a file.

Return Value

A unique filename.

Remarks

The filename is made unique by inserting a timestamp in the filename. The timestamp is a ISO formatted date/time string. The date/time string is formatted as "yyyyMMddTHHmmss".

Examples

The following example finds the backup filename for the robots.txt. Afterwards the backupname variable holds a name like "c:\inetpub\wwwroot\default website\robots_20030101T120000.txt".
CopyC#
string backupname = FileUtil.GetBackupFilename(@"c:\inetpub\wwwroot\default website", "robots", "txt");

See Also

FileUtil Class
GetBackupFilename Overload
Sitecore.IO Namespace


GetExtension Method

[image]

Sitecore 6.4.1 API
FileUtil..::..GetExtension Method
FileUtil Class Example See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetExtension(
    string path
)
Visual Basic
Public Shared Function GetExtension ( _
    path As String _
) As String
Visual C++
public:
static String^ GetExtension(
    String^ path
)

Parameters

path
Type: System..::..String
The path.

Return Value

[Missing <returns> documentation for "M:Sitecore.IO.FileUtil.GetExtension(System.String)"]

Examples

CopyC#
string extension = FileUtil.GetExtension("/temp/document.txt");  // returns 'txt'

See Also

FileUtil Class
Sitecore.IO Namespace


GetFileLock Method

[image]

Sitecore 6.4.1 API
FileUtil..::..GetFileLock Method
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object GetFileLock(
    string path
)
Visual Basic
Public Shared Function GetFileLock ( _
    path As String _
) As Object
Visual C++
public:
static Object^ GetFileLock(
    String^ path
)

Parameters

path
Type: System..::..String
A filename path.

Return Value

The lock object.

See Also

FileUtil Class
Sitecore.IO Namespace


GetFileName Method

[image]

Sitecore 6.4.1 API
FileUtil..::..GetFileName Method
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetFileName(
    string filename
)
Visual Basic
Public Shared Function GetFileName ( _
    filename As String _
) As String
Visual C++
public:
static String^ GetFileName(
    String^ filename
)

Parameters

filename
Type: System..::..String
The path.

Return Value

[Missing <returns> documentation for "M:Sitecore.IO.FileUtil.GetFileName(System.String)"]

See Also

FileUtil Class
Sitecore.IO Namespace


GetFilePathFromFileUri Method

[image]

Sitecore 6.4.1 API
FileUtil..::..GetFilePathFromFileUri Method
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetFilePathFromFileUri(
    string fileUri
)
Visual Basic
Public Shared Function GetFilePathFromFileUri ( _
    fileUri As String _
) As String
Visual C++
public:
static String^ GetFilePathFromFileUri(
    String^ fileUri
)

Parameters

fileUri
Type: System..::..String
The file URI.

Return Value

The file path corresponding to the URI.

See Also

FileUtil Class
Sitecore.IO Namespace


GetFiles Method

[image]

Sitecore 6.4.1 API
FileUtil..::..GetFiles Method
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static StringList GetFiles(
    string folder,
    string pattern,
    bool mapResult
)
Visual Basic
Public Shared Function GetFiles ( _
    folder As String, _
    pattern As String, _
    mapResult As Boolean _
) As StringList
Visual C++
public:
static StringList^ GetFiles(
    String^ folder,
    String^ pattern,
    bool mapResult
)

Parameters

folder
Type: System..::..String
The folder.
pattern
Type: System..::..String
The pattern.
mapResult
Type: System..::..Boolean
If set to true the resulting file paths will be mapped (using MapPath(String)).

Return Value

[Missing <returns> documentation for "M:Sitecore.IO.FileUtil.GetFiles(System.String,System.String,System.Boolean)"]

See Also

FileUtil Class
Sitecore.IO Namespace


GetFileSize Method

[image]

Sitecore 6.4.1 API
FileUtil..::..GetFileSize Method
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long GetFileSize(
    string filePath
)
Visual Basic
Public Shared Function GetFileSize ( _
    filePath As String _
) As Long
Visual C++
public:
static long long GetFileSize(
    String^ filePath
)

Parameters

filePath
Type: System..::..String
A filename (including path).

Return Value

The size of the file in bytes. If the file does not exist, -1 is returned.

See Also

FileUtil Class
Sitecore.IO Namespace


GetFileTime Method

[image]

Sitecore 6.4.1 API
FileUtil..::..GetFileTime Method
FileUtil Class Example See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetFileTime(
    string filename
)
Visual Basic
Public Shared Function GetFileTime ( _
    filename As String _
) As String
Visual C++
public:
static String^ GetFileTime(
    String^ filename
)

Parameters

filename
Type: System..::..String
A filename path.

Return Value

The last modified time of the file as a string.

Remarks

If the file does not have a last modified time, blank is returned.

Examples

CopyC#
string lastModified = FileUtil.GetFileTime("/robots.txt");

See Also

FileUtil Class
Sitecore.IO Namespace


GetFileWriteTime Method

[image]

Sitecore 6.4.1 API
FileUtil..::..GetFileWriteTime Method
FileUtil Class Example See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static DateTime GetFileWriteTime(
    string filename
)
Visual Basic
Public Shared Function GetFileWriteTime ( _
    filename As String _
) As DateTime
Visual C++
public:
static DateTime GetFileWriteTime(
    String^ filename
)

Parameters

filename
Type: System..::..String
A filename path.

Return Value

The last modified time of the file as a date/time.

Remarks

If the file does not have a last modified time, DateTime.MinValue is returned.

Examples

CopyC#
DateTime lastModified = FileUtil.GetFileWriteTime("/robots.txt");

See Also

FileUtil Class
Sitecore.IO Namespace


GetParentPath Method

[image]

Sitecore 6.4.1 API
FileUtil..::..GetParentPath Method
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetParentPath(
    string path
)
Visual Basic
Public Shared Function GetParentPath ( _
    path As String _
) As String
Visual C++
public:
static String^ GetParentPath(
    String^ path
)

Parameters

path
Type: System..::..String
The path.

Return Value

[Missing <returns> documentation for "M:Sitecore.IO.FileUtil.GetParentPath(System.String)"]

See Also

FileUtil Class
Sitecore.IO Namespace


GetPathSeparator Method

[image]

Sitecore 6.4.1 API
FileUtil..::..GetPathSeparator Method
FileUtil Class Example See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static char GetPathSeparator(
    string path
)
Visual Basic
Public Shared Function GetPathSeparator ( _
    path As String _
) As Char
Visual C++
public:
static wchar_t GetPathSeparator(
    String^ path
)

Parameters

path
Type: System..::..String
A filename path.

Return Value

The separator character (slash (/) or backslash (\)).

Remarks

In paths with mixed separators, the backslash (\) takes precedens over the slash. If the filename path is blank, slash (/) is returned.

Examples

CopyC#
char s1 = FileUtil.GetPathSeparator("/sitecore/data/masterdata.xml"); // returns /
char s2 = FileUtil.GetPathSeparator(@"c:\inetpub\wwwroot\default site"); // returns \
char s3 = FileUtil.GetPathSeparator(@"c:\inetpub\wwwroot\default site/sitecore/data/masterdata.xml"); // returns \

See Also

FileUtil Class
Sitecore.IO Namespace


GetSpecialFolder Method

[image]

Sitecore 6.4.1 API
FileUtil..::..GetSpecialFolder Method
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetSpecialFolder(
    SpecialFolder folder
)
Visual Basic
Public Shared Function GetSpecialFolder ( _
    folder As SpecialFolder _
) As String
Visual C++
public:
static String^ GetSpecialFolder(
    SpecialFolder folder
)

Parameters

folder
Type: Sitecore.IO..::..SpecialFolder
The folder.

Return Value

[Missing <returns> documentation for "M:Sitecore.IO.FileUtil.GetSpecialFolder(Sitecore.IO.SpecialFolder)"]

See Also

FileUtil Class
Sitecore.IO Namespace


GetUniqueFilename Method

[image]

Sitecore 6.4.1 API
FileUtil..::..GetUniqueFilename Method
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetUniqueFilename(
    string filePath
)
Visual Basic
Public Shared Function GetUniqueFilename ( _
    filePath As String _
) As String
Visual C++
public:
static String^ GetUniqueFilename(
    String^ filePath
)

Parameters

filePath
Type: System..::..String
The file path.

Return Value

[Missing <returns> documentation for "M:Sitecore.IO.FileUtil.GetUniqueFilename(System.String)"]

See Also

FileUtil Class
Sitecore.IO Namespace


GetValidFilePath Method

[image]

Sitecore 6.4.1 API
FileUtil..::..GetValidFilePath Method
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetValidFilePath(
    string proposedPath
)
Visual Basic
Public Shared Function GetValidFilePath ( _
    proposedPath As String _
) As String
Visual C++
public:
static String^ GetValidFilePath(
    String^ proposedPath
)

Parameters

proposedPath
Type: System..::..String
The proposed path.

Return Value

[Missing <returns> documentation for "M:Sitecore.IO.FileUtil.GetValidFilePath(System.String)"]

See Also

FileUtil Class
Sitecore.IO Namespace


GetWorkFilename Method

[image]

Sitecore 6.4.1 API
FileUtil..::..GetWorkFilename Method
FileUtil Class Example See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetWorkFilename(
    string folder,
    string prefix,
    string extension
)
Visual Basic
Public Shared Function GetWorkFilename ( _
    folder As String, _
    prefix As String, _
    extension As String _
) As String
Visual C++
public:
static String^ GetWorkFilename(
    String^ folder,
    String^ prefix,
    String^ extension
)

Parameters

folder
Type: System..::..String
The folder of a file.
prefix
Type: System..::..String
The file prefix of a file (usually the filename itself).
extension
Type: System..::..String
The extension of a file.

Return Value

The unique filename.

Remarks

The filename is made unique by inserting a running serial number into it.

Examples

The following example gets a unique filename for the robots.txt file. Afterwards the backupname variable holds a name like "c:\inetpub\wwwroot\default website\robots_00001.txt".
CopyC#
string backupname = FileUtil.GetWorkFilename(@"c:\inetpub\wwwroot\default website", "robots", "txt");

See Also

FileUtil Class
Sitecore.IO Namespace


IsAspxFile Method

[image]

Sitecore 6.4.1 API
FileUtil..::..IsAspxFile Method
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsAspxFile(
    string filename
)
Visual Basic
Public Shared Function IsAspxFile ( _
    filename As String _
) As Boolean
Visual C++
public:
static bool IsAspxFile(
    String^ filename
)

Parameters

filename
Type: System..::..String
The path.

Return Value

true if the file is an aspx file; otherwise, false.

See Also

FileUtil Class
Sitecore.IO Namespace


IsFile Method

[image]

Sitecore 6.4.1 API
FileUtil..::..IsFile Method
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsFile(
    string filename
)
Visual Basic
Public Shared Function IsFile ( _
    filename As String _
) As Boolean
Visual C++
public:
static bool IsFile(
    String^ filename
)

Parameters

filename
Type: System..::..String
The path.

Return Value

true if the specified path is an existing file; otherwise, false.

See Also

FileUtil Class
Sitecore.IO Namespace


IsFolder Method

[image]

Sitecore 6.4.1 API
FileUtil..::..IsFolder Method
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsFolder(
    string folder
)
Visual Basic
Public Shared Function IsFolder ( _
    folder As String _
) As Boolean
Visual C++
public:
static bool IsFolder(
    String^ folder
)

Parameters

folder
Type: System..::..String
The path.

Return Value

true if the specified path is an existing folder; otherwise, false.

See Also

FileUtil Class
Sitecore.IO Namespace


IsFullyQualified Method

[image]

Sitecore 6.4.1 API
FileUtil..::..IsFullyQualified Method
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsFullyQualified(
    string filename
)
Visual Basic
Public Shared Function IsFullyQualified ( _
    filename As String _
) As Boolean
Visual C++
public:
static bool IsFullyQualified(
    String^ filename
)

Parameters

filename
Type: System..::..String
The filename.

Return Value

true if the filename is fully qualified; otherwise, false.

See Also

FileUtil Class
Sitecore.IO Namespace


IsReadOnly Method

[image]

Sitecore 6.4.1 API
FileUtil..::..IsReadOnly Method
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsReadOnly(
    string filename
)
Visual Basic
Public Shared Function IsReadOnly ( _
    filename As String _
) As Boolean
Visual C++
public:
static bool IsReadOnly(
    String^ filename
)

Parameters

filename
Type: System..::..String
The filename.

Return Value

true if the specified file is read only; otherwise, false.

See Also

FileUtil Class
Sitecore.IO Namespace


LoadHashtable Method

[image]

Sitecore 6.4.1 API
FileUtil..::..LoadHashtable Method
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Hashtable LoadHashtable(
    string filename
)
Visual Basic
Public Shared Function LoadHashtable ( _
    filename As String _
) As Hashtable
Visual C++
public:
static Hashtable^ LoadHashtable(
    String^ filename
)

Parameters

filename
Type: System..::..String
The filename.

Return Value

[Missing <returns> documentation for "M:Sitecore.IO.FileUtil.LoadHashtable(System.String)"]

See Also

FileUtil Class
Sitecore.IO Namespace


LoadObject Method

[image]

Sitecore 6.4.1 API
FileUtil..::..LoadObject Method
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object LoadObject(
    string filename
)
Visual Basic
Public Shared Function LoadObject ( _
    filename As String _
) As Object
Visual C++
public:
static Object^ LoadObject(
    String^ filename
)

Parameters

filename
Type: System..::..String
The filename.

Return Value

[Missing <returns> documentation for "M:Sitecore.IO.FileUtil.LoadObject(System.String)"]

See Also

FileUtil Class
Sitecore.IO Namespace


MakePath Method

[image] [image]

Sitecore 6.4.1 API
FileUtil..::..MakePath Method
FileUtil Class See Also Send Feedback

Overload List

Name | Description
MakePath(String, String) | Makes a path from two filename parts.
MakePath(String, String, Char) | Makes a path from two filename parts.

See Also

FileUtil Class
FileUtil Members
Sitecore.IO Namespace


MakePath Method (String, String)

[image]

Sitecore 6.4.1 API
FileUtil..::..MakePath Method (String, String)
FileUtil Class Example See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string MakePath(
    string part1,
    string part2
)
Visual Basic
Public Shared Function MakePath ( _
    part1 As String, _
    part2 As String _
) As String
Visual C++
public:
static String^ MakePath(
    String^ part1,
    String^ part2
)

Parameters

part1
Type: System..::..String
The first part of the filename.
part2
Type: System..::..String
The second part of the filename.

Return Value

The two parts concatenated with a separator in between.

Remarks

The parts are seperated by the separator used in the first part.

Examples

The following example joins "c:\inetpub\wwwroot\default website" and "robots.txt" into a single string seperated by a backslash (\).
CopyC#
string filename = FileUtil.MakePath(@"c:\inetpub\wwwroot\default website", "robots");

See Also

FileUtil Class
MakePath Overload
Sitecore.IO Namespace


MakePath Method (String, String, Char)

[image]

Sitecore 6.4.1 API
FileUtil..::..MakePath Method (String, String, Char)
FileUtil Class Example See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string MakePath(
    string part1,
    string part2,
    char separator
)
Visual Basic
Public Shared Function MakePath ( _
    part1 As String, _
    part2 As String, _
    separator As Char _
) As String
Visual C++
public:
static String^ MakePath(
    String^ part1,
    String^ part2,
    wchar_t separator
)

Parameters

part1
Type: System..::..String
The first part of the filename.
part2
Type: System..::..String
The second part of the filename.
separator
Type: System..::..Char
A separator character.

Return Value

The two parts concatenated with the separator in between.

Examples

The following example joins "c:\inetpub\wwwroot\default website" and "robots.txt" into a single string seperated by a backslash (\).
CopyC#
string filename = FileUtil.MakePath(@"c:\inetpub\wwwroot\default website", "robots", "\\");

See Also

FileUtil Class
MakePath Overload
Sitecore.IO Namespace


MapDataFilePath Method

[image]

Sitecore 6.4.1 API
FileUtil..::..MapDataFilePath Method
FileUtil Class Example See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string MapDataFilePath(
    string path
)
Visual Basic
Public Shared Function MapDataFilePath ( _
    path As String _
) As String
Visual C++
public:
static String^ MapDataFilePath(
    String^ path
)

Parameters

path
Type: System..::..String
A filename path.

Return Value

A filename in the data folder.

Remarks

If the path does not contain any folder information, the file is assumed to be located in the data folder. The data folder is specified by the Settings.DataFolder setting.

Examples

The following example returns the filename of the mydata.xml file in the data folder. Afterwards the filename variable holds a value like "c:\inetpub\wwwroot\default website\sitecore\data\mydata.xml".
CopyC#
string filename = FileUtil.MapDataFilePath("mydata.xml");

See Also

FileUtil Class
Sitecore.IO Namespace


MapPath Method

[image]

Sitecore 6.4.1 API
FileUtil..::..MapPath Method
FileUtil Class Example See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string MapPath(
    string path
)
Visual Basic
Public Shared Function MapPath ( _
    path As String _
) As String
Visual C++
public:
static String^ MapPath(
    String^ path
)

Parameters

path
Type: System..::..String
A virtual file path.

Return Value

The physical file path.

Remarks

If the file path is blank, contains a backslash (\) or contains the string "://" the path itself is returned.

Examples

The following example returns the physical filename of the mydata.xml file in the data folder. Afterwards the filename variable holds a value like "c:\inetpub\wwwroot\default website\sitecore\data\mydata.xml".
CopyC#
string filename = FileUtil.MapPath("/sitecore/data/mydata.xml");

See Also

FileUtil Class
Sitecore.IO Namespace


MatchPattern Method

[image]

Sitecore 6.4.1 API
FileUtil..::..MatchPattern Method
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool MatchPattern(
    string value,
    string pattern
)
Visual Basic
Public Shared Function MatchPattern ( _
    value As String, _
    pattern As String _
) As Boolean
Visual C++
public:
static bool MatchPattern(
    String^ value,
    String^ pattern
)

Parameters

value
Type: System..::..String
The value.
pattern
Type: System..::..String
The pattern.

Return Value

[Missing <returns> documentation for "M:Sitecore.IO.FileUtil.MatchPattern(System.String,System.String)"]

See Also

FileUtil Class
Sitecore.IO Namespace


NormalizeWebPath Method

[image]

Sitecore 6.4.1 API
FileUtil..::..NormalizeWebPath Method
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string NormalizeWebPath(
    string path
)
Visual Basic
Public Shared Function NormalizeWebPath ( _
    path As String _
) As String
Visual C++
public:
static String^ NormalizeWebPath(
    String^ path
)

Parameters

path
Type: System..::..String
The path.

Return Value

[Missing <returns> documentation for "M:Sitecore.IO.FileUtil.NormalizeWebPath(System.String)"]

See Also

FileUtil Class
Sitecore.IO Namespace


OpenCreate Method

[image]

Sitecore 6.4.1 API
FileUtil..::..OpenCreate Method
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static FileStream OpenCreate(
    string filePath
)
Visual Basic
Public Shared Function OpenCreate ( _
    filePath As String _
) As FileStream
Visual C++
public:
static FileStream^ OpenCreate(
    String^ filePath
)

Parameters

filePath
Type: System..::..String
The file path.

Return Value

[Missing <returns> documentation for "M:Sitecore.IO.FileUtil.OpenCreate(System.String)"]

See Also

FileUtil Class
Sitecore.IO Namespace


OpenFileStream Method

[image]

Sitecore 6.4.1 API
FileUtil..::..OpenFileStream Method
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static FileStream OpenFileStream(
    string filePath,
    FileMode mode,
    FileAccess access,
    FileShare share,
    bool createFolder,
    bool logErrors
)
Visual Basic
Public Shared Function OpenFileStream ( _
    filePath As String, _
    mode As FileMode, _
    access As FileAccess, _
    share As FileShare, _
    createFolder As Boolean, _
    logErrors As Boolean _
) As FileStream
Visual C++
public:
static FileStream^ OpenFileStream(
    String^ filePath,
    FileMode mode,
    FileAccess access,
    FileShare share,
    bool createFolder,
    bool logErrors
)

Parameters

filePath
Type: System..::..String
The filename.
mode
Type: System.IO..::..FileMode
The mode.
access
Type: System.IO..::..FileAccess
The access.
share
Type: System.IO..::..FileShare
The share.
createFolder
Type: System..::..Boolean
if set to true this instance is create folder.
logErrors
Type: System..::..Boolean
if set to true this instance is log errors.

Return Value

[Missing <returns> documentation for "M:Sitecore.IO.FileUtil.OpenFileStream(System.String,System.IO.FileMode,System.IO.FileAccess,System.IO.FileShare,System.Boolean,System.Boolean)"]

See Also

FileUtil Class
Sitecore.IO Namespace


OpenRead Method

[image]

Sitecore 6.4.1 API
FileUtil..::..OpenRead Method
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static FileStream OpenRead(
    string filePath
)
Visual Basic
Public Shared Function OpenRead ( _
    filePath As String _
) As FileStream
Visual C++
public:
static FileStream^ OpenRead(
    String^ filePath
)

Parameters

filePath
Type: System..::..String
The file path.

Return Value

[Missing <returns> documentation for "M:Sitecore.IO.FileUtil.OpenRead(System.String)"]

See Also

FileUtil Class
Sitecore.IO Namespace


ReadBinaryFile Method

[image]

Sitecore 6.4.1 API
FileUtil..::..ReadBinaryFile Method
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static byte[] ReadBinaryFile(
    string filename
)
Visual Basic
Public Shared Function ReadBinaryFile ( _
    filename As String _
) As Byte()
Visual C++
public:
static array<unsigned char>^ ReadBinaryFile(
    String^ filename
)

Parameters

filename
Type: System..::..String
Name of the file.

Return Value

[Missing <returns> documentation for "M:Sitecore.IO.FileUtil.ReadBinaryFile(System.String)"]

See Also

FileUtil Class
Sitecore.IO Namespace


ReadFromFile Method

[image]

Sitecore 6.4.1 API
FileUtil..::..ReadFromFile Method
FileUtil Class Example See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ReadFromFile(
    string path
)
Visual Basic
Public Shared Function ReadFromFile ( _
    path As String _
) As String
Visual C++
public:
static String^ ReadFromFile(
    String^ path
)

Parameters

path
Type: System..::..String
A file name.

Return Value

The content of the file.

Remarks

If the file is not found, an exception is written to the trace file and blank is returned.

Examples

CopyC#
string text = MainUtil.ReadFromFile("/robots.txt");

See Also

FileUtil Class
Sitecore.IO Namespace


ReadUTF8File Method

[image]

Sitecore 6.4.1 API
FileUtil..::..ReadUTF8File Method
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ReadUTF8File(
    string filename
)
Visual Basic
Public Shared Function ReadUTF8File ( _
    filename As String _
) As String
Visual C++
public:
static String^ ReadUTF8File(
    String^ filename
)

Parameters

filename
Type: System..::..String
The filename.

Return Value

[Missing <returns> documentation for "M:Sitecore.IO.FileUtil.ReadUTF8File(System.String)"]

See Also

FileUtil Class
Sitecore.IO Namespace


ReplaceVariables Method

[image]

Sitecore 6.4.1 API
FileUtil..::..ReplaceVariables Method
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ReplaceVariables(
    string filename
)
Visual Basic
Public Shared Function ReplaceVariables ( _
    filename As String _
) As String
Visual C++
public:
static String^ ReplaceVariables(
    String^ filename
)

Parameters

filename
Type: System..::..String
The filename.

Return Value

[Missing <returns> documentation for "M:Sitecore.IO.FileUtil.ReplaceVariables(System.String)"]

Remarks

Currently only {$date} is supported.

See Also

FileUtil Class
Sitecore.IO Namespace


Save Method

[image]

Sitecore 6.4.1 API
FileUtil..::..Save Method
FileUtil Class Example See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Save(
    XmlDocument doc,
    string filename
)
Visual Basic
Public Shared Sub Save ( _
    doc As XmlDocument, _
    filename As String _
)
Visual C++
public:
static void Save(
    XmlDocument^ doc,
    String^ filename
)

Parameters

doc
Type: System.Xml..::..XmlDocument
An XML document to be saved.
filename
Type: System..::..String
A filename.

Remarks

The XML document is first saved to a temporary file, then the temporary file is renamed to the name of the original file.

Examples

The following example saves the XML document in the xml variable to a file
CopyC#
string filename = FileUtil.MapPath("/sitecore/data/mydata.xml");
FileUtil.Save(xml, filename);

See Also

FileUtil Class
Sitecore.IO Namespace


SaveHashtable Method

[image]

Sitecore 6.4.1 API
FileUtil..::..SaveHashtable Method
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void SaveHashtable(
    string filename,
    Hashtable data
)
Visual Basic
Public Shared Sub SaveHashtable ( _
    filename As String, _
    data As Hashtable _
)
Visual C++
public:
static void SaveHashtable(
    String^ filename,
    Hashtable^ data
)

Parameters

filename
Type: System..::..String
The filename.
data
Type: System.Collections..::..Hashtable
The data.

See Also

FileUtil Class
Sitecore.IO Namespace


SaveToTemporaryFile Method

[image]

Sitecore 6.4.1 API
FileUtil..::..SaveToTemporaryFile Method
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string SaveToTemporaryFile(
    MediaItem item
)
Visual Basic
Public Shared Function SaveToTemporaryFile ( _
    item As MediaItem _
) As String
Visual C++
public:
static String^ SaveToTemporaryFile(
    MediaItem^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..MediaItem
The MediaItem

Return Value

The path to the generated temporary file.

See Also

FileUtil Class
Sitecore.IO Namespace


SubtractPath Method

[image]

Sitecore 6.4.1 API
FileUtil..::..SubtractPath Method
FileUtil Class Example See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string SubtractPath(
    string fullPath,
    string subtract
)
Visual Basic
Public Shared Function SubtractPath ( _
    fullPath As String, _
    subtract As String _
) As String
Visual C++
public:
static String^ SubtractPath(
    String^ fullPath,
    String^ subtract
)

Parameters

fullPath
Type: System..::..String
The full path.
subtract
Type: System..::..String
The path to subtract.

Return Value

[Missing <returns> documentation for "M:Sitecore.IO.FileUtil.SubtractPath(System.String,System.String)"]

Examples

CopyC#
string path = FileUtil.SubtractPath("/layouts/hola.aspx", "/layouts/"); // hola.aspx
string path = FileUtil.SubtractPath("c:\website\layouts\hola.aspx", "/layouts/"); // hola.aspx (assuming the web site )
string path = FileUtil.SubtractPath("/layouts/hola.aspx", "/temp/"); // null

See Also

FileUtil Class
Sitecore.IO Namespace


UnmapPath Method (String)

[image]

Sitecore 6.4.1 API
FileUtil..::..UnmapPath Method (String)
FileUtil Class Example See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string UnmapPath(
    string path
)
Visual Basic
Public Shared Function UnmapPath ( _
    path As String _
) As String
Visual C++
public:
static String^ UnmapPath(
    String^ path
)

Parameters

path
Type: System..::..String
A path.

Return Value

A virtual path.

Remarks

If the path cannot be made into a virtual path, the physical path is returned.

Examples

CopyC#
string path = MainUtil.UnmapPath(@"c:\inetpub\wwwroot\default side\sitecore\images\blank.gif");
// "/sitecore/images/blank.gif"

See Also

FileUtil Class
UnmapPath Overload
Sitecore.IO Namespace
FileUtil..::..MapPath(String)


UnmapPath Method (String, Boolean)

[image]

Sitecore 6.4.1 API
FileUtil..::..UnmapPath Method (String, Boolean)
FileUtil Class Example See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string UnmapPath(
    string path,
    bool toLower
)
Visual Basic
Public Shared Function UnmapPath ( _
    path As String, _
    toLower As Boolean _
) As String
Visual C++
public:
static String^ UnmapPath(
    String^ path,
    bool toLower
)

Parameters

path
Type: System..::..String
A path.
toLower
Type: System..::..Boolean
Indicated whether result should be converded to lower case

Return Value

A virtual path.

Remarks

If the path cannot be made into a virtual path, the physical path is returned.

Examples

CopyC#
string path = MainUtil.UnmapPath(@"c:\Inetpub\wwwroot\Default side\Sitecore\Images\blank.gif", false);
// "/Sitecore/Images/blank.gif"

See Also

FileUtil Class
UnmapPath Overload
Sitecore.IO Namespace
FileUtil..::..MapPath(String)


WriteToFile Method

[image] [image]

Sitecore 6.4.1 API
FileUtil..::..WriteToFile Method
FileUtil Class See Also Send Feedback

Overload List

Name | Description
WriteToFile(String, array<Byte>[]()[][]%) | Writes a byte array to a file.
WriteToFile(String, String) | Writes a string to a file.
WriteToFile(String, String, Boolean) | Write or appends a atring to a file.

See Also

FileUtil Class
FileUtil Members
Sitecore.IO Namespace


WriteToFile Method (String, Byte[])

[image]

Sitecore 6.4.1 API
FileUtil..::..WriteToFile Method (String, array<Byte>[]()[][]%)
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void WriteToFile(
    string path,
    ref byte[] data
)
Visual Basic
Public Shared Sub WriteToFile ( _
    path As String, _
    ByRef data As Byte() _
)
Visual C++
public:
static void WriteToFile(
    String^ path,
    array<unsigned char>^% data
)

Parameters

path
Type: System..::..String
A file name path.
data
Type: array< System..::..Byte >[]()[][]%
A byte array of data.

See Also

FileUtil Class
WriteToFile Overload
Sitecore.IO Namespace


WriteToFile Method (String, String)

[image]

Sitecore 6.4.1 API
FileUtil..::..WriteToFile Method (String, String)
FileUtil Class Example See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void WriteToFile(
    string path,
    string text
)
Visual Basic
Public Shared Sub WriteToFile ( _
    path As String, _
    text As String _
)
Visual C++
public:
static void WriteToFile(
    String^ path,
    String^ text
)

Parameters

path
Type: System..::..String
A file name path.
text
Type: System..::..String
A string.

Examples

CopyC#
MainUtil.WriteToString("/my.txt", "Hello world");

See Also

FileUtil Class
WriteToFile Overload
Sitecore.IO Namespace


WriteToFile Method (String, String, Boolean)

[image]

Sitecore 6.4.1 API
FileUtil..::..WriteToFile Method (String, String, Boolean)
FileUtil Class Example See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void WriteToFile(
    string path,
    string text,
    bool append
)
Visual Basic
Public Shared Sub WriteToFile ( _
    path As String, _
    text As String, _
    append As Boolean _
)
Visual C++
public:
static void WriteToFile(
    String^ path,
    String^ text,
    bool append
)

Parameters

path
Type: System..::..String
A file name path.
text
Type: System..::..String
A string.
append
Type: System..::..Boolean
Indicates if the string is appended to the file.

Examples

CopyC#
MainUtil.WriteToString("/my.txt", "Hello world", true);

See Also

FileUtil Class
WriteToFile Overload
Sitecore.IO Namespace


WriteToStream Method

[image]

Sitecore 6.4.1 API
FileUtil..::..WriteToStream Method
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void WriteToStream(
    Stream inputStream,
    int blockSize,
    Stream outputStream
)
Visual Basic
Public Shared Sub WriteToStream ( _
    inputStream As Stream, _
    blockSize As Integer, _
    outputStream As Stream _
)
Visual C++
public:
static void WriteToStream(
    Stream^ inputStream,
    int blockSize,
    Stream^ outputStream
)

Parameters

inputStream
Type: System.IO..::..Stream
The stream to read data from.
blockSize
Type: System..::..Int32
Size of each block being read.
outputStream
Type: System.IO..::..Stream
The stream to write data to.

See Also

FileUtil Class
Sitecore.IO Namespace


WriteUTF8File Method

[image]

Sitecore 6.4.1 API
FileUtil..::..WriteUTF8File Method
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void WriteUTF8File(
    string filename,
    string data
)
Visual Basic
Public Shared Sub WriteUTF8File ( _
    filename As String, _
    data As String _
)
Visual C++
public:
static void WriteUTF8File(
    String^ filename,
    String^ data
)

Parameters

filename
Type: System..::..String
The filename.
data
Type: System..::..String
The data.

See Also

FileUtil Class
Sitecore.IO Namespace


ZipFiles Method

[image]

Sitecore 6.4.1 API
FileUtil..::..ZipFiles Method
FileUtil Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ZipFiles(
    string zipfile,
    string[] files
)
Visual Basic
Public Shared Function ZipFiles ( _
    zipfile As String, _
    files As String() _
) As String
Visual C++
public:
static String^ ZipFiles(
    String^ zipfile,
    array<String^>^ files
)

Parameters

zipfile
Type: System..::..String
The zipfile.
files
Type: array< System..::..String >[]()[][]
The files.

Return Value

[Missing <returns> documentation for "M:Sitecore.IO.FileUtil.ZipFiles(System.String,System.String[])"]

See Also

FileUtil Class
Sitecore.IO Namespace


FileWatcher Class

[image]

Sitecore 6.4.1 API
FileWatcher Class
Members See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class FileWatcher : IHttpModule
Visual Basic
Public MustInherit Class FileWatcher _
    Implements IHttpModule
Visual C++
public ref class FileWatcher abstract : IHttpModule

Inheritance Hierarchy

System..::..Object
Sitecore.IO..::..FileWatcher
Sitecore.Configuration..::..ConfigWatcher
Sitecore.IO..::..LayoutWatcher
Sitecore.IO..::..XslWatcher
Sitecore.Resources.Media..::..UploadWatcher
Sitecore.SecurityModel.License..::..LicenseWatcher

See Also

FileWatcher Members
Sitecore.IO Namespace


FileWatcher Members

[image] [image]

Sitecore 6.4.1 API
FileWatcher Members
FileWatcher Class Constructors Methods Properties See Also Send Feedback

The FileWatcher type exposes the following members.

Constructors

 | Name | Description
Protected method | FileWatcher()()()() | Initializes a new instance of the FileWatcher class.
Protected method | FileWatcher(String) | Initializes a new instance of the FileWatcher class.
Protected method | FileWatcher(String, String) | Initializes a new instance of the FileWatcher class.

Methods

 | Name | Description
Protected method | Created | Called when a file has been created.
Protected method | Deleted | Called when a file has been deleted.
Public method | Dispose | Application shutdown handler
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Application startup handler
Protected method | InitializeWatcher | Initializes a file watcher.
Protected method | InitializeWorker | Initializes the worker.
Protected method | MapPathToSiteCore | Maps the path to a Sitecore path.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnFileCreated | File has been created.
Protected method | OnFileDeleted | File has been deleted.
Protected method | OnFileRenamed | File has been renamed.
Protected method | PathShouldBeIngnored | Checks whether the pathes the should be ingnored.
 | ProcessPending | Processes all pending operations for all file watchers.
Protected method | Renamed | Called when a file has been renamed.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Protected property | Folder | Gets the path to the monitored folder.

See Also

FileWatcher Class
Sitecore.IO Namespace


FileWatcher Methods

[image] [image]

Sitecore 6.4.1 API
FileWatcher Methods
FileWatcher Class See Also Send Feedback

The FileWatcher type exposes the following members.

Methods

 | Name | Description
Protected method | Created | Called when a file has been created.
Protected method | Deleted | Called when a file has been deleted.
Public method | Dispose | Application shutdown handler
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Application startup handler
Protected method | InitializeWatcher | Initializes a file watcher.
Protected method | InitializeWorker | Initializes the worker.
Protected method | MapPathToSiteCore | Maps the path to a Sitecore path.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnFileCreated | File has been created.
Protected method | OnFileDeleted | File has been deleted.
Protected method | OnFileRenamed | File has been renamed.
Protected method | PathShouldBeIngnored | Checks whether the pathes the should be ingnored.
 | ProcessPending | Processes all pending operations for all file watchers.
Protected method | Renamed | Called when a file has been renamed.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileWatcher Class
Sitecore.IO Namespace


Created Method

[image]

Sitecore 6.4.1 API
FileWatcher..::..Created Method
FileWatcher Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected abstract void Created(
    string fullPath
)
Visual Basic
Protected MustOverride Sub Created ( _
    fullPath As String _
)
Visual C++
protected:
virtual void Created(
    String^ fullPath
) abstract

Parameters

fullPath
Type: System..::..String
The full path.

See Also

FileWatcher Class
Sitecore.IO Namespace


Deleted Method

[image]

Sitecore 6.4.1 API
FileWatcher..::..Deleted Method
FileWatcher Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected abstract void Deleted(
    string filePath
)
Visual Basic
Protected MustOverride Sub Deleted ( _
    filePath As String _
)
Visual C++
protected:
virtual void Deleted(
    String^ filePath
) abstract

Parameters

filePath
Type: System..::..String
The full path.

See Also

FileWatcher Class
Sitecore.IO Namespace


Dispose Method

[image]

Sitecore 6.4.1 API
FileWatcher..::..Dispose Method
FileWatcher Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IHttpModule..::..Dispose()()()()

See Also

FileWatcher Class
Sitecore.IO Namespace


Init Method

[image]

Sitecore 6.4.1 API
FileWatcher..::..Init Method
FileWatcher Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Init(
    HttpApplication context
)
Visual Basic
Public Sub Init ( _
    context As HttpApplication _
)
Visual C++
public:
virtual void Init(
    HttpApplication^ context
) sealed

Parameters

context
Type: System.Web..::..HttpApplication
An HttpApplication that provides access to the methods, properties, and events common to all application objects within an ASP.NET application

Implements

IHttpModule..::..Init(HttpApplication)

See Also

FileWatcher Class
Sitecore.IO Namespace


InitializeWatcher Method

[image]

Sitecore 6.4.1 API
FileWatcher..::..InitializeWatcher Method
FileWatcher Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void InitializeWatcher(
    string filter,
    string folder
)
Visual Basic
Protected Sub InitializeWatcher ( _
    filter As String, _
    folder As String _
)
Visual C++
protected:
void InitializeWatcher(
    String^ filter,
    String^ folder
)

Parameters

filter
Type: System..::..String
The filter.
folder
Type: System..::..String
The folder.

See Also

FileWatcher Class
Sitecore.IO Namespace


InitializeWorker Method

[image]

Sitecore 6.4.1 API
FileWatcher..::..InitializeWorker Method
FileWatcher Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void InitializeWorker()
Visual Basic
Protected Sub InitializeWorker
Visual C++
protected:
void InitializeWorker()

See Also

FileWatcher Class
Sitecore.IO Namespace


MapPathToSiteCore Method

[image]

Sitecore 6.4.1 API
FileWatcher..::..MapPathToSiteCore Method
FileWatcher Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected string MapPathToSiteCore(
    string fullPath,
    string directory,
    string id
)
Visual Basic
Protected Function MapPathToSiteCore ( _
    fullPath As String, _
    directory As String, _
    id As String _
) As String
Visual C++
protected:
String^ MapPathToSiteCore(
    String^ fullPath,
    String^ directory,
    String^ id
)

Parameters

fullPath
Type: System..::..String
The full path.
directory
Type: System..::..String
The directory.
id
Type: System..::..String
The id.

Return Value

[Missing <returns> documentation for "M:Sitecore.IO.FileWatcher.MapPathToSiteCore(System.String,System.String,System.String)"]

See Also

FileWatcher Class
Sitecore.IO Namespace


OnFileCreated Method

[image]

Sitecore 6.4.1 API
FileWatcher..::..OnFileCreated Method
FileWatcher Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void OnFileCreated(
    Object o,
    FileSystemEventArgs args
)
Visual Basic
Protected Sub OnFileCreated ( _
    o As Object, _
    args As FileSystemEventArgs _
)
Visual C++
protected:
void OnFileCreated(
    Object^ o,
    FileSystemEventArgs^ args
)

Parameters

o
Type: System..::..Object
The object.
args
Type: System.IO..::..FileSystemEventArgs
The arguments.

See Also

FileWatcher Class
Sitecore.IO Namespace


OnFileDeleted Method

[image]

Sitecore 6.4.1 API
FileWatcher..::..OnFileDeleted Method
FileWatcher Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void OnFileDeleted(
    Object o,
    FileSystemEventArgs args
)
Visual Basic
Protected Sub OnFileDeleted ( _
    o As Object, _
    args As FileSystemEventArgs _
)
Visual C++
protected:
void OnFileDeleted(
    Object^ o,
    FileSystemEventArgs^ args
)

Parameters

o
Type: System..::..Object
The object.
args
Type: System.IO..::..FileSystemEventArgs
The arguments.

See Also

FileWatcher Class
Sitecore.IO Namespace


OnFileRenamed Method

[image]

Sitecore 6.4.1 API
FileWatcher..::..OnFileRenamed Method
FileWatcher Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void OnFileRenamed(
    Object o,
    RenamedEventArgs args
)
Visual Basic
Protected Sub OnFileRenamed ( _
    o As Object, _
    args As RenamedEventArgs _
)
Visual C++
protected:
void OnFileRenamed(
    Object^ o,
    RenamedEventArgs^ args
)

Parameters

o
Type: System..::..Object
The object.
args
Type: System.IO..::..RenamedEventArgs
The arguments.

See Also

FileWatcher Class
Sitecore.IO Namespace


PathShouldBeIngnored Method

[image]

Sitecore 6.4.1 API
FileWatcher..::..PathShouldBeIngnored Method
FileWatcher Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool PathShouldBeIngnored(
    string path
)
Visual Basic
Protected Overridable Function PathShouldBeIngnored ( _
    path As String _
) As Boolean
Visual C++
protected:
virtual bool PathShouldBeIngnored(
    String^ path
)

Parameters

path
Type: System..::..String
The path.

Return Value

[Missing <returns> documentation for "M:Sitecore.IO.FileWatcher.PathShouldBeIngnored(System.String)"]

See Also

FileWatcher Class
Sitecore.IO Namespace


Renamed Method

[image]

Sitecore 6.4.1 API
FileWatcher..::..Renamed Method
FileWatcher Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected abstract void Renamed(
    string filePath,
    string oldFilePath
)
Visual Basic
Protected MustOverride Sub Renamed ( _
    filePath As String, _
    oldFilePath As String _
)
Visual C++
protected:
virtual void Renamed(
    String^ filePath,
    String^ oldFilePath
) abstract

Parameters

filePath
Type: System..::..String
The full path.
oldFilePath
Type: System..::..String
The old full path.

See Also

FileWatcher Class
Sitecore.IO Namespace


FileWatcher Properties

[image] [image]

Sitecore 6.4.1 API
FileWatcher Properties
FileWatcher Class See Also Send Feedback

The FileWatcher type exposes the following members.

Properties

 | Name | Description
Protected property | Folder | Gets the path to the monitored folder.

See Also

FileWatcher Class
Sitecore.IO Namespace


Folder Property

[image]

Sitecore 6.4.1 API
FileWatcher..::..Folder Property
FileWatcher Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected string Folder { get; }
Visual Basic
Protected ReadOnly Property Folder As String
    Get
Visual C++
protected:
property String^ Folder {
    String^ get ();
}

Field Value

The path to the folder monitored by this FileWatcher.

See Also

FileWatcher Class
Sitecore.IO Namespace


LayoutWatcher Class

[image]

Sitecore 6.4.1 API
LayoutWatcher Class
Members See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class LayoutWatcher : FileWatcher
Visual Basic
Public Class LayoutWatcher _
    Inherits FileWatcher
Visual C++
public ref class LayoutWatcher : public FileWatcher

Inheritance Hierarchy

System..::..Object
Sitecore.IO..::..FileWatcher
Sitecore.IO..::..LayoutWatcher

See Also

LayoutWatcher Members
Sitecore.IO Namespace


LayoutWatcher Members

[image] [image]

Sitecore 6.4.1 API
LayoutWatcher Members
LayoutWatcher Class Constructors Methods Properties See Also Send Feedback

The LayoutWatcher type exposes the following members.

Constructors

 | Name | Description
Public method | LayoutWatcher | Initializes a new instance of the LayoutWatcher class.

Methods

 | Name | Description
Protected method | Created | Called when a file has been created. (Overrides FileWatcher..::..Created(String).)
Protected method | Deleted | Called when a file has been deleted. (Overrides FileWatcher..::..Deleted(String).)
Public method | Dispose | Application shutdown handler (Inherited from FileWatcher.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Application startup handler (Inherited from FileWatcher.)
Protected method | InitializeWatcher | Initializes a file watcher. (Inherited from FileWatcher.)
Protected method | InitializeWorker | Initializes the worker. (Inherited from FileWatcher.)
Protected method | MapPathToSiteCore | Maps the path to a Sitecore path. (Inherited from FileWatcher.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnFileCreated | File has been created. (Inherited from FileWatcher.)
Protected method | OnFileDeleted | File has been deleted. (Inherited from FileWatcher.)
Protected method | OnFileRenamed | File has been renamed. (Inherited from FileWatcher.)
Protected method | PathShouldBeIngnored | Checks whether the pathes the should be ingnored. (Inherited from FileWatcher.)
Protected method | Renamed | Called when a file has been renamed. (Overrides FileWatcher..::..Renamed(String, String).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Protected property | Folder | Gets the path to the monitored folder. (Inherited from FileWatcher.)

See Also

LayoutWatcher Class
Sitecore.IO Namespace


LayoutWatcher Constructor

[image]

Sitecore 6.4.1 API
LayoutWatcher Constructor
LayoutWatcher Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LayoutWatcher()
Visual Basic
Public Sub New
Visual C++
public:
LayoutWatcher()

See Also

LayoutWatcher Class
Sitecore.IO Namespace


LayoutWatcher Methods

[image] [image]

Sitecore 6.4.1 API
LayoutWatcher Methods
LayoutWatcher Class See Also Send Feedback

The LayoutWatcher type exposes the following members.

Methods

 | Name | Description
Protected method | Created | Called when a file has been created. (Overrides FileWatcher..::..Created(String).)
Protected method | Deleted | Called when a file has been deleted. (Overrides FileWatcher..::..Deleted(String).)
Public method | Dispose | Application shutdown handler (Inherited from FileWatcher.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Application startup handler (Inherited from FileWatcher.)
Protected method | InitializeWatcher | Initializes a file watcher. (Inherited from FileWatcher.)
Protected method | InitializeWorker | Initializes the worker. (Inherited from FileWatcher.)
Protected method | MapPathToSiteCore | Maps the path to a Sitecore path. (Inherited from FileWatcher.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnFileCreated | File has been created. (Inherited from FileWatcher.)
Protected method | OnFileDeleted | File has been deleted. (Inherited from FileWatcher.)
Protected method | OnFileRenamed | File has been renamed. (Inherited from FileWatcher.)
Protected method | PathShouldBeIngnored | Checks whether the pathes the should be ingnored. (Inherited from FileWatcher.)
Protected method | Renamed | Called when a file has been renamed. (Overrides FileWatcher..::..Renamed(String, String).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LayoutWatcher Class
Sitecore.IO Namespace


Created Method

[image]

Sitecore 6.4.1 API
LayoutWatcher..::..Created Method
LayoutWatcher Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void Created(
    string fullPath
)
Visual Basic
Protected Overrides Sub Created ( _
    fullPath As String _
)
Visual C++
protected:
virtual void Created(
    String^ fullPath
) override

Parameters

fullPath
Type: System..::..String
The full path.

See Also

LayoutWatcher Class
Sitecore.IO Namespace


Deleted Method

[image]

Sitecore 6.4.1 API
LayoutWatcher..::..Deleted Method
LayoutWatcher Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void Deleted(
    string filePath
)
Visual Basic
Protected Overrides Sub Deleted ( _
    filePath As String _
)
Visual C++
protected:
virtual void Deleted(
    String^ filePath
) override

Parameters

filePath
Type: System..::..String
The full path.

See Also

LayoutWatcher Class
Sitecore.IO Namespace


Renamed Method

[image]

Sitecore 6.4.1 API
LayoutWatcher..::..Renamed Method
LayoutWatcher Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void Renamed(
    string filePath,
    string oldFilePath
)
Visual Basic
Protected Overrides Sub Renamed ( _
    filePath As String, _
    oldFilePath As String _
)
Visual C++
protected:
virtual void Renamed(
    String^ filePath,
    String^ oldFilePath
) override

Parameters

filePath
Type: System..::..String
The full path.
oldFilePath
Type: System..::..String
The old full path.

See Also

LayoutWatcher Class
Sitecore.IO Namespace


LayoutWatcher Properties

[image] [image]

Sitecore 6.4.1 API
LayoutWatcher Properties
LayoutWatcher Class See Also Send Feedback

The LayoutWatcher type exposes the following members.

Properties

 | Name | Description
Protected property | Folder | Gets the path to the monitored folder. (Inherited from FileWatcher.)

See Also

LayoutWatcher Class
Sitecore.IO Namespace


SingleFileWatcher Class

[image]

Sitecore 6.4.1 API
SingleFileWatcher Class
Members See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SingleFileWatcher : IDisposable
Visual Basic
Public Class SingleFileWatcher _
    Implements IDisposable
Visual C++
public ref class SingleFileWatcher : IDisposable

Inheritance Hierarchy

System..::..Object
Sitecore.IO..::..SingleFileWatcher

See Also

SingleFileWatcher Members
Sitecore.IO Namespace


SingleFileWatcher Members

[image] [image]

Sitecore 6.4.1 API
SingleFileWatcher Members
SingleFileWatcher Class Constructors Methods Fields See Also Send Feedback

The SingleFileWatcher type exposes the following members.

Constructors

 | Name | Description
Public method | SingleFileWatcher | Initializes a new instance of the SingleFileWatcher class.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | Changed | Occurs when the target file is changed.
Public field | Created | Ocrcurs when a new file is created in place of the target file.
Public field | Deleted | Occurs when the target file is deleted.
Public field | Renamed | Occurse when the target file is renamed.

See Also

SingleFileWatcher Class
Sitecore.IO Namespace


SingleFileWatcher Constructor

[image]

Sitecore 6.4.1 API
SingleFileWatcher Constructor
SingleFileWatcher Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SingleFileWatcher(
    string path
)
Visual Basic
Public Sub New ( _
    path As String _
)
Visual C++
public:
SingleFileWatcher(
    String^ path
)

Parameters

path
Type: System..::..String
The path to the file to monitor.

See Also

SingleFileWatcher Class
Sitecore.IO Namespace


Changed Field

[image]

Sitecore 6.4.1 API
SingleFileWatcher..::..Changed Field
SingleFileWatcher Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FileSystemEventHandler Changed
Visual Basic
Public Changed As FileSystemEventHandler
Visual C++
public:
FileSystemEventHandler^ Changed

See Also

SingleFileWatcher Class
Sitecore.IO Namespace


Created Field

[image]

Sitecore 6.4.1 API
SingleFileWatcher..::..Created Field
SingleFileWatcher Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FileSystemEventHandler Created
Visual Basic
Public Created As FileSystemEventHandler
Visual C++
public:
FileSystemEventHandler^ Created

See Also

SingleFileWatcher Class
Sitecore.IO Namespace


Deleted Field

[image]

Sitecore 6.4.1 API
SingleFileWatcher..::..Deleted Field
SingleFileWatcher Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FileSystemEventHandler Deleted
Visual Basic
Public Deleted As FileSystemEventHandler
Visual C++
public:
FileSystemEventHandler^ Deleted

See Also

SingleFileWatcher Class
Sitecore.IO Namespace


Renamed Field

[image]

Sitecore 6.4.1 API
SingleFileWatcher..::..Renamed Field
SingleFileWatcher Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenamedEventHandler Renamed
Visual Basic
Public Renamed As RenamedEventHandler
Visual C++
public:
RenamedEventHandler^ Renamed

See Also

SingleFileWatcher Class
Sitecore.IO Namespace


SingleFileWatcher Methods

[image] [image]

Sitecore 6.4.1 API
SingleFileWatcher Methods
SingleFileWatcher Class See Also Send Feedback

The SingleFileWatcher type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SingleFileWatcher Class
Sitecore.IO Namespace


Dispose Method

[image]

Sitecore 6.4.1 API
SingleFileWatcher..::..Dispose Method
SingleFileWatcher Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

SingleFileWatcher Class
Sitecore.IO Namespace


SpecialFolder Enumeration

[image]

Sitecore 6.4.1 API
SpecialFolder Enumeration
See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum SpecialFolder
Visual Basic
Public Enumeration SpecialFolder
Visual C++
public enum class SpecialFolder

Members

Member name | Value | Description
IndexRoot | 0 | Index root.
TempDiagnostics | 1 | Temporary folder for diagnostics.

See Also

Sitecore.IO Namespace


StreamSharer Class

[image]

Sitecore 6.4.1 API
StreamSharer Class
Members See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class StreamSharer : IDisposable
Visual Basic
Public Class StreamSharer _
    Implements IDisposable
Visual C++
public ref class StreamSharer : IDisposable

Inheritance Hierarchy

System..::..Object
Sitecore.IO..::..StreamSharer

See Also

StreamSharer Members
Sitecore.IO Namespace


StreamSharer Members

[image] [image]

Sitecore 6.4.1 API
StreamSharer Members
StreamSharer Class Constructors Methods Properties See Also Send Feedback

The StreamSharer type exposes the following members.

Constructors

 | Name | Description
Public method | StreamSharer | Initializes a new instance of the StreamSharer class.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenStream | Opens a new instance of the stream.
Public method | PrepareRead | Prepares the master buffer file for a specific read operation.
Public method | Read | Reads data from the stream.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | StreamLength | Gets the length of the stream.

See Also

StreamSharer Class
Sitecore.IO Namespace


StreamSharer Constructor

[image]

Sitecore 6.4.1 API
StreamSharer Constructor
StreamSharer Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StreamSharer(
    Stream masterStream,
    string bufferFilePath
)
Visual Basic
Public Sub New ( _
    masterStream As Stream, _
    bufferFilePath As String _
)
Visual C++
public:
StreamSharer(
    Stream^ masterStream,
    String^ bufferFilePath
)

Parameters

masterStream
Type: System.IO..::..Stream
The master stream.
bufferFilePath
Type: System..::..String
The buffer file path.

See Also

StreamSharer Class
Sitecore.IO Namespace


StreamSharer Methods

[image] [image]

Sitecore 6.4.1 API
StreamSharer Methods
StreamSharer Class See Also Send Feedback

The StreamSharer type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenStream | Opens a new instance of the stream.
Public method | PrepareRead | Prepares the master buffer file for a specific read operation.
Public method | Read | Reads data from the stream.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StreamSharer Class
Sitecore.IO Namespace


OpenStream Method

[image]

Sitecore 6.4.1 API
StreamSharer..::..OpenStream Method
StreamSharer Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Stream OpenStream()
Visual Basic
Public Function OpenStream As Stream
Visual C++
public:
Stream^ OpenStream()

Return Value

[Missing <returns> documentation for "M:Sitecore.IO.StreamSharer.OpenStream"]

See Also

StreamSharer Class
Sitecore.IO Namespace


Read Method

[image]

Sitecore 6.4.1 API
StreamSharer..::..Read Method
StreamSharer Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Read(
    long position,
    byte[] buffer,
    int offset,
    int count
)
Visual Basic
Public Function Read ( _
    position As Long, _
    buffer As Byte(), _
    offset As Integer, _
    count As Integer _
) As Integer
Visual C++
public:
int Read(
    long long position,
    array<unsigned char>^ buffer,
    int offset,
    int count
)

Parameters

position
Type: System..::..Int64
The position that will be read.
buffer
Type: array< System..::..Byte >[]()[][]
The buffer.
offset
Type: System..::..Int32
The offset.
count
Type: System..::..Int32
The number of bytes that will be read.

Return Value

[Missing <returns> documentation for "M:Sitecore.IO.StreamSharer.Read(System.Int64,System.Byte[],System.Int32,System.Int32)"]

See Also

StreamSharer Class
Sitecore.IO Namespace


StreamSharer Properties

[image] [image]

Sitecore 6.4.1 API
StreamSharer Properties
StreamSharer Class See Also Send Feedback

The StreamSharer type exposes the following members.

Properties

 | Name | Description
Public property | StreamLength | Gets the length of the stream.

See Also

StreamSharer Class
Sitecore.IO Namespace


StreamLength Property

[image]

Sitecore 6.4.1 API
StreamSharer..::..StreamLength Property
StreamSharer Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long StreamLength { get; }
Visual Basic
Public ReadOnly Property StreamLength As Long
    Get
Visual C++
public:
property long long StreamLength {
    long long get ();
}

Return Value

See Also

StreamSharer Class
Sitecore.IO Namespace


StreamSharer.MetaStream Class

[image]

Sitecore 6.4.1 API
StreamSharer..::..MetaStream Class
StreamSharer Class Members See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class MetaStream : Stream
Visual Basic
Public Class MetaStream _
    Inherits Stream
Visual C++
public ref class MetaStream : public Stream

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.IO..::..Stream
Sitecore.IO..::..StreamSharer..::..MetaStream

See Also

StreamSharer..::..MetaStream Members
Sitecore.IO Namespace


StreamSharer.MetaStream Members

[image] [image]

Sitecore 6.4.1 API
StreamSharer..::..MetaStream Members
StreamSharer..::..MetaStream Class Constructors Methods Properties See Also Send Feedback

StreamSharer.MetaStream class
StreamSharer class

The StreamSharer..::..MetaStream type exposes the following members.

Constructors

 | Name | Description
Public method | StreamSharer..::..MetaStream | Initializes a new instance of the StreamSharer..::..MetaStream class.

Methods

 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Inherited from Stream.)
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose()()()() | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources. (Inherited from Stream.)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Overrides Stream..::..Flush()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Read | When overridden in a derived class, reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Overrides Stream..::..Read(array<Byte>[]()[][], Int32, Int32).)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Public method | Seek | When overridden in a derived class, sets the position within the current stream. (Overrides Stream..::..Seek(Int64, SeekOrigin).)
Public method | SetLength | When overridden in a derived class, sets the length of the current stream. (Overrides Stream..::..SetLength(Int64).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Write | When overridden in a derived class, writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Overrides Stream..::..Write(array<Byte>[]()[][], Int32, Int32).)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)

Properties

 | Name | Description
Public property | CanRead | When overridden in a derived class, gets a value indicating whether the current stream supports reading. (Overrides Stream..::..CanRead.)
Public property | CanSeek | When overridden in a derived class, gets a value indicating whether the current stream supports seeking. (Overrides Stream..::..CanSeek.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | When overridden in a derived class, gets a value indicating whether the current stream supports writing. (Overrides Stream..::..CanWrite.)
Public property | Length | When overridden in a derived class, gets the length in bytes of the stream. (Overrides Stream..::..Length.)
Public property | Position | When overridden in a derived class, gets or sets the position within the current stream. (Overrides Stream..::..Position.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)

See Also

StreamSharer..::..MetaStream Class
Sitecore.IO Namespace


StreamSharer.MetaStream Constructor

[image]

Sitecore 6.4.1 API
StreamSharer..::..MetaStream Constructor
StreamSharer..::..MetaStream Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MetaStream(
    StreamSharer streamSharer
)
Visual Basic
Public Sub New ( _
    streamSharer As StreamSharer _
)
Visual C++
public:
MetaStream(
    StreamSharer^ streamSharer
)

Parameters

streamSharer
Type: Sitecore.IO..::..StreamSharer
The stream sharer.

See Also

StreamSharer..::..MetaStream Class
Sitecore.IO Namespace


StreamSharer.MetaStream Methods

[image] [image]

Sitecore 6.4.1 API
StreamSharer..::..MetaStream Methods
StreamSharer..::..MetaStream Class See Also Send Feedback

The StreamSharer..::..MetaStream type exposes the following members.

Methods

 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Inherited from Stream.)
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose()()()() | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources. (Inherited from Stream.)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Overrides Stream..::..Flush()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Read | When overridden in a derived class, reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Overrides Stream..::..Read(array<Byte>[]()[][], Int32, Int32).)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Public method | Seek | When overridden in a derived class, sets the position within the current stream. (Overrides Stream..::..Seek(Int64, SeekOrigin).)
Public method | SetLength | When overridden in a derived class, sets the length of the current stream. (Overrides Stream..::..SetLength(Int64).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Write | When overridden in a derived class, writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Overrides Stream..::..Write(array<Byte>[]()[][], Int32, Int32).)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)

See Also

StreamSharer..::..MetaStream Class
Sitecore.IO Namespace


Flush Method

[image]

Sitecore 6.4.1 API
StreamSharer..::..MetaStream..::..Flush Method
StreamSharer..::..MetaStream Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Flush()
Visual Basic
Public Overrides Sub Flush
Visual C++
public:
virtual void Flush() override

Exceptions

Exception | Condition
System.IO..::..IOException | An I/O error occurs.

See Also

StreamSharer..::..MetaStream Class
Sitecore.IO Namespace


MemberwiseClone Method

[image] [image]

Sitecore 6.4.1 API
MetaStream..::..MemberwiseClone Method
StreamSharer..::..MetaStream Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

StreamSharer..::..MetaStream Class
StreamSharer..::..MetaStream Members
Sitecore.IO Namespace


Read Method

[image]

Sitecore 6.4.1 API
StreamSharer..::..MetaStream..::..Read Method
StreamSharer..::..MetaStream Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
Visual Basic
Public Overrides Function Read ( _
    buffer As Byte(), _
    offset As Integer, _
    count As Integer _
) As Integer
Visual C++
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override

Parameters

buffer
Type: array< System..::..Byte >[]()[][]
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the bytes read from the current source.
offset
Type: System..::..Int32
The zero-based byte offset in buffer at which to begin storing the data read from the current stream.
count
Type: System..::..Int32
The maximum number of bytes to be read from the current stream.

Return Value

The total number of bytes read into the buffer. This can be less than the number of bytes requested if that many bytes are not currently available, or zero (0) if the end of the stream has been reached.

Exceptions

Exception | Condition
System..::..ArgumentException | The sum of offset and count is larger than the buffer length.
System..::..ArgumentNullException | buffer is null.
System..::..ArgumentOutOfRangeException | offset or count is negative.
System.IO..::..IOException | An I/O error occurs.
System..::..NotSupportedException | The stream does not support reading.
System..::..ObjectDisposedException | Methods were called after the stream was closed.

See Also

StreamSharer..::..MetaStream Class
Sitecore.IO Namespace


SetLength Method

[image]

Sitecore 6.4.1 API
StreamSharer..::..MetaStream..::..SetLength Method
StreamSharer..::..MetaStream Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void SetLength(
    long value
)
Visual Basic
Public Overrides Sub SetLength ( _
    value As Long _
)
Visual C++
public:
virtual void SetLength(
    long long value
) override

Parameters

value
Type: System..::..Int64
The desired length of the current stream in bytes.

Exceptions

Exception | Condition
System.IO..::..IOException | An I/O error occurs.
System..::..NotSupportedException | The stream does not support both writing and seeking, such as if the stream is constructed from a pipe or console output.
System..::..ObjectDisposedException | Methods were called after the stream was closed.

See Also

StreamSharer..::..MetaStream Class
Sitecore.IO Namespace


Write Method

[image]

Sitecore 6.4.1 API
StreamSharer..::..MetaStream..::..Write Method
StreamSharer..::..MetaStream Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
Visual Basic
Public Overrides Sub Write ( _
    buffer As Byte(), _
    offset As Integer, _
    count As Integer _
)
Visual C++
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override

Parameters

buffer
Type: array< System..::..Byte >[]()[][]
An array of bytes. This method copies count bytes from buffer to the current stream.
offset
Type: System..::..Int32
The zero-based byte offset in buffer at which to begin copying bytes to the current stream.
count
Type: System..::..Int32
The number of bytes to be written to the current stream.

Exceptions

Exception | Condition
System..::..ArgumentException | The sum of offset and count is greater than the buffer length.
System..::..ArgumentNullException | buffer is null.
System..::..ArgumentOutOfRangeException | offset or count is negative.
System.IO..::..IOException | An I/O error occurs.
System..::..NotSupportedException | The stream does not support writing.
System..::..ObjectDisposedException | Methods were called after the stream was closed.

See Also

StreamSharer..::..MetaStream Class
Sitecore.IO Namespace


StreamSharer.MetaStream Properties

[image] [image]

Sitecore 6.4.1 API
StreamSharer..::..MetaStream Properties
StreamSharer..::..MetaStream Class See Also Send Feedback

The StreamSharer..::..MetaStream type exposes the following members.

Properties

 | Name | Description
Public property | CanRead | When overridden in a derived class, gets a value indicating whether the current stream supports reading. (Overrides Stream..::..CanRead.)
Public property | CanSeek | When overridden in a derived class, gets a value indicating whether the current stream supports seeking. (Overrides Stream..::..CanSeek.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | When overridden in a derived class, gets a value indicating whether the current stream supports writing. (Overrides Stream..::..CanWrite.)
Public property | Length | When overridden in a derived class, gets the length in bytes of the stream. (Overrides Stream..::..Length.)
Public property | Position | When overridden in a derived class, gets or sets the position within the current stream. (Overrides Stream..::..Position.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)

See Also

StreamSharer..::..MetaStream Class
Sitecore.IO Namespace


CanRead Property

[image]

Sitecore 6.4.1 API
StreamSharer..::..MetaStream..::..CanRead Property
StreamSharer..::..MetaStream Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool CanRead { get; }
Visual Basic
Public Overrides ReadOnly Property CanRead As Boolean
    Get
Visual C++
public:
virtual property bool CanRead {
    bool get () override;
}

Field Value

Return Value

true if the stream supports reading; otherwise, false.

See Also

StreamSharer..::..MetaStream Class
Sitecore.IO Namespace


CanSeek Property

[image]

Sitecore 6.4.1 API
StreamSharer..::..MetaStream..::..CanSeek Property
StreamSharer..::..MetaStream Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool CanSeek { get; }
Visual Basic
Public Overrides ReadOnly Property CanSeek As Boolean
    Get
Visual C++
public:
virtual property bool CanSeek {
    bool get () override;
}

Field Value

Return Value

true if the stream supports seeking; otherwise, false.

See Also

StreamSharer..::..MetaStream Class
Sitecore.IO Namespace


CanWrite Property

[image]

Sitecore 6.4.1 API
StreamSharer..::..MetaStream..::..CanWrite Property
StreamSharer..::..MetaStream Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool CanWrite { get; }
Visual Basic
Public Overrides ReadOnly Property CanWrite As Boolean
    Get
Visual C++
public:
virtual property bool CanWrite {
    bool get () override;
}

Field Value

Return Value

true if the stream supports writing; otherwise, false.

See Also

StreamSharer..::..MetaStream Class
Sitecore.IO Namespace


Length Property

[image]

Sitecore 6.4.1 API
StreamSharer..::..MetaStream..::..Length Property
StreamSharer..::..MetaStream Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override long Length { get; }
Visual Basic
Public Overrides ReadOnly Property Length As Long
    Get
Visual C++
public:
virtual property long long Length {
    long long get () override;
}

Field Value

Return Value

A long value representing the length of the stream in bytes.

Exceptions

Exception | Condition
System..::..NotSupportedException | A class derived from Stream does not support seeking.
System..::..ObjectDisposedException | Methods were called after the stream was closed.

See Also

StreamSharer..::..MetaStream Class
Sitecore.IO Namespace


TempFolder Class

[image]

Sitecore 6.4.1 API
TempFolder Class
Members See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class TempFolder
Visual Basic
Public NotInheritable Class TempFolder
Visual C++
public ref class TempFolder abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.IO..::..TempFolder

See Also

TempFolder Members
Sitecore.IO Namespace


TempFolder Members

[image] [image]

Sitecore 6.4.1 API
TempFolder Members
TempFolder Class Methods Properties See Also Send Feedback

The TempFolder type exposes the following members.

Methods

Name | Description
CreateTempFile | Creates the temp file.
Ensure | Obsolete. Ensures that the Temp folder exists on the physical disk.
EnsureFolder | Ensures that the Temp folder exists on the physical disk.
GetFilename()()()() | Gets the filename.
GetFilename(String) | Gets the filename.

Properties

Name | Description
Folder | Gets the folder.

See Also

TempFolder Class
Sitecore.IO Namespace


TempFolder Methods

[image] [image]

Sitecore 6.4.1 API
TempFolder Methods
TempFolder Class See Also Send Feedback

The TempFolder type exposes the following members.

Methods

Name | Description
CreateTempFile | Creates the temp file.
Ensure | Obsolete. Ensures that the Temp folder exists on the physical disk.
EnsureFolder | Ensures that the Temp folder exists on the physical disk.
GetFilename()()()() | Gets the filename.
GetFilename(String) | Gets the filename.

See Also

TempFolder Class
Sitecore.IO Namespace


CreateTempFile Method

[image]

Sitecore 6.4.1 API
TempFolder..::..CreateTempFile Method
TempFolder Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string CreateTempFile(
    string filename
)
Visual Basic
Public Shared Function CreateTempFile ( _
    filename As String _
) As String
Visual C++
public:
static String^ CreateTempFile(
    String^ filename
)

Parameters

filename
Type: System..::..String
The filename.

Return Value

[Missing <returns> documentation for "M:Sitecore.IO.TempFolder.CreateTempFile(System.String)"]

See Also

TempFolder Class
Sitecore.IO Namespace


Ensure Method

[image]

Sitecore 6.4.1 API
TempFolder..::..Ensure Method
TempFolder Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use EnsureFolder instead")]
public static void Ensure()
Visual Basic
<ObsoleteAttribute("Use EnsureFolder instead")> _
Public Shared Sub Ensure
Visual C++
[ObsoleteAttribute(L"Use EnsureFolder instead")]
public:
static void Ensure()

See Also

TempFolder Class
Sitecore.IO Namespace


EnsureFolder Method

[image]

Sitecore 6.4.1 API
TempFolder..::..EnsureFolder Method
TempFolder Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void EnsureFolder()
Visual Basic
Public Shared Sub EnsureFolder
Visual C++
public:
static void EnsureFolder()

See Also

TempFolder Class
Sitecore.IO Namespace


GetFilename Method

[image] [image]

Sitecore 6.4.1 API
TempFolder..::..GetFilename Method
TempFolder Class See Also Send Feedback

Overload List

Name | Description
GetFilename()()()() | Gets the filename.
GetFilename(String) | Gets the filename.

See Also

TempFolder Class
TempFolder Members
Sitecore.IO Namespace


GetFilename Method

[image]

Sitecore 6.4.1 API
TempFolder..::..GetFilename Method
TempFolder Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetFilename()
Visual Basic
Public Shared Function GetFilename As String
Visual C++
public:
static String^ GetFilename()

Return Value

[Missing <returns> documentation for "M:Sitecore.IO.TempFolder.GetFilename"]

See Also

TempFolder Class
GetFilename Overload
Sitecore.IO Namespace


GetFilename Method (String)

[image]

Sitecore 6.4.1 API
TempFolder..::..GetFilename Method (String)
TempFolder Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetFilename(
    string filename
)
Visual Basic
Public Shared Function GetFilename ( _
    filename As String _
) As String
Visual C++
public:
static String^ GetFilename(
    String^ filename
)

Parameters

filename
Type: System..::..String
The filename.

Return Value

[Missing <returns> documentation for "M:Sitecore.IO.TempFolder.GetFilename(System.String)"]

See Also

TempFolder Class
GetFilename Overload
Sitecore.IO Namespace


TempFolder Properties

[image] [image]

Sitecore 6.4.1 API
TempFolder Properties
TempFolder Class See Also Send Feedback

The TempFolder type exposes the following members.

Properties

Name | Description
Folder | Gets the folder.

See Also

TempFolder Class
Sitecore.IO Namespace


Folder Property

[image]

Sitecore 6.4.1 API
TempFolder..::..Folder Property
TempFolder Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Folder { get; }
Visual Basic
Public Shared ReadOnly Property Folder As String
    Get
Visual C++
public:
static property String^ Folder {
    String^ get ();
}

Field Value

The folder.

See Also

TempFolder Class
Sitecore.IO Namespace


UploadFile Class

[image]

Sitecore 6.4.1 API
UploadFile Class
Members See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class UploadFile
Visual Basic
Public Class UploadFile
Visual C++
public ref class UploadFile

Remarks

This is an internal class for uploaing files and should not be used.

Inheritance Hierarchy

System..::..Object
Sitecore.IO..::..UploadFile

See Also

UploadFile Members
Sitecore.IO Namespace


UploadFile Members

[image] [image]

Sitecore 6.4.1 API
UploadFile Members
UploadFile Class Constructors Methods Properties See Also Send Feedback

The UploadFile type exposes the following members.

Constructors

 | Name | Description
Public method | UploadFile | Initializes a new instance of the UploadFile class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MakeThumbnail | Makes a thumbnail of the file.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveToFolder | Saves the file to a folder.
Protected method | ThumbnailAborter | Implements a thumbnail aborter delegate.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValid | Checks if the file object is valid.

See Also

UploadFile Class
Sitecore.IO Namespace


UploadFile Constructor

[image]

Sitecore 6.4.1 API
UploadFile Constructor
UploadFile Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UploadFile(
    HtmlInputFile file
)
Visual Basic
Public Sub New ( _
    file As HtmlInputFile _
)
Visual C++
public:
UploadFile(
    HtmlInputFile^ file
)

Parameters

file
Type: System.Web.UI.HtmlControls..::..HtmlInputFile
A file from a HTML form.

See Also

UploadFile Class
Sitecore.IO Namespace


UploadFile Methods

[image] [image]

Sitecore 6.4.1 API
UploadFile Methods
UploadFile Class See Also Send Feedback

The UploadFile type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MakeThumbnail | Makes a thumbnail of the file.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveToFolder | Saves the file to a folder.
Protected method | ThumbnailAborter | Implements a thumbnail aborter delegate.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UploadFile Class
Sitecore.IO Namespace


MakeThumbnail Method

[image]

Sitecore 6.4.1 API
UploadFile..::..MakeThumbnail Method
UploadFile Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected bool MakeThumbnail(
    string sFile,
    int nWidth,
    int nHeight
)
Visual Basic
Protected Function MakeThumbnail ( _
    sFile As String, _
    nWidth As Integer, _
    nHeight As Integer _
) As Boolean
Visual C++
protected:
bool MakeThumbnail(
    String^ sFile,
    int nWidth,
    int nHeight
)

Parameters

sFile
Type: System..::..String
A file name.
nWidth
Type: System..::..Int32
Width of thumbnail.
nHeight
Type: System..::..Int32
Height of thumbnail.

Return Value

True, if a thumbnail was generated, otherwise false.

Remarks

The function looks for an extension of .gif or .jpg.

See Also

UploadFile Class
Sitecore.IO Namespace


SaveToFolder Method

[image]

Sitecore 6.4.1 API
UploadFile..::..SaveToFolder Method
UploadFile Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string SaveToFolder(
    string sFolder,
    bool bUniqueName
)
Visual Basic
Public Function SaveToFolder ( _
    sFolder As String, _
    bUniqueName As Boolean _
) As String
Visual C++
public:
String^ SaveToFolder(
    String^ sFolder,
    bool bUniqueName
)

Parameters

sFolder
Type: System..::..String
A folder file name.
bUniqueName
Type: System..::..Boolean
A boolean indicating if the name should unique within the folder.

Return Value

The filename of the file.

Remarks

If the file is not valid, blank is returned.

See Also

UploadFile Class
Sitecore.IO Namespace


ThumbnailAborter Method

[image]

Sitecore 6.4.1 API
UploadFile..::..ThumbnailAborter Method
UploadFile Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected bool ThumbnailAborter()
Visual Basic
Protected Function ThumbnailAborter As Boolean
Visual C++
protected:
bool ThumbnailAborter()

Return Value

Always false.

Remarks

Always returns false.

See Also

UploadFile Class
Sitecore.IO Namespace


IsValid Property

[image]

Sitecore 6.4.1 API
UploadFile..::..IsValid Property
UploadFile Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsValid { get; }
Visual Basic
Public ReadOnly Property IsValid As Boolean
    Get
Visual C++
public:
property bool IsValid {
    bool get ();
}

Field Value

True, if the file object contains a value, otherwise false.

Remarks

A file object is valid if it contains a value.

See Also

UploadFile Class
Sitecore.IO Namespace


XslWatcher Class

[image]

Sitecore 6.4.1 API
XslWatcher Class
Members See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class XslWatcher : FileWatcher
Visual Basic
Public Class XslWatcher _
    Inherits FileWatcher
Visual C++
public ref class XslWatcher : public FileWatcher

Inheritance Hierarchy

System..::..Object
Sitecore.IO..::..FileWatcher
Sitecore.IO..::..XslWatcher

See Also

XslWatcher Members
Sitecore.IO Namespace


XslWatcher Members

[image] [image]

Sitecore 6.4.1 API
XslWatcher Members
XslWatcher Class Constructors Methods Properties See Also Send Feedback

The XslWatcher type exposes the following members.

Constructors

 | Name | Description
Public method | XslWatcher | Initializes a new instance of the XslWatcher class.

Methods

 | Name | Description
Protected method | Created | Called when a file has been created. (Overrides FileWatcher..::..Created(String).)
Protected method | Deleted | Called when a file has been deleted. (Overrides FileWatcher..::..Deleted(String).)
Public method | Dispose | Application shutdown handler (Inherited from FileWatcher.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Application startup handler (Inherited from FileWatcher.)
Protected method | InitializeWatcher | Initializes a file watcher. (Inherited from FileWatcher.)
Protected method | InitializeWorker | Initializes the worker. (Inherited from FileWatcher.)
Protected method | MapPathToSiteCore | Maps the path to a Sitecore path. (Inherited from FileWatcher.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnFileCreated | File has been created. (Inherited from FileWatcher.)
Protected method | OnFileDeleted | File has been deleted. (Inherited from FileWatcher.)
Protected method | OnFileRenamed | File has been renamed. (Inherited from FileWatcher.)
Protected method | PathShouldBeIngnored | Checks whether the pathes the should be ingnored. (Inherited from FileWatcher.)
Protected method | Renamed | Called when a file has been renamed. (Overrides FileWatcher..::..Renamed(String, String).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Protected property | Folder | Gets the path to the monitored folder. (Inherited from FileWatcher.)

See Also

XslWatcher Class
Sitecore.IO Namespace


XslWatcher Constructor

[image]

Sitecore 6.4.1 API
XslWatcher Constructor
XslWatcher Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public XslWatcher()
Visual Basic
Public Sub New
Visual C++
public:
XslWatcher()

See Also

XslWatcher Class
Sitecore.IO Namespace


XslWatcher Methods

[image] [image]

Sitecore 6.4.1 API
XslWatcher Methods
XslWatcher Class See Also Send Feedback

The XslWatcher type exposes the following members.

Methods

 | Name | Description
Protected method | Created | Called when a file has been created. (Overrides FileWatcher..::..Created(String).)
Protected method | Deleted | Called when a file has been deleted. (Overrides FileWatcher..::..Deleted(String).)
Public method | Dispose | Application shutdown handler (Inherited from FileWatcher.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Application startup handler (Inherited from FileWatcher.)
Protected method | InitializeWatcher | Initializes a file watcher. (Inherited from FileWatcher.)
Protected method | InitializeWorker | Initializes the worker. (Inherited from FileWatcher.)
Protected method | MapPathToSiteCore | Maps the path to a Sitecore path. (Inherited from FileWatcher.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnFileCreated | File has been created. (Inherited from FileWatcher.)
Protected method | OnFileDeleted | File has been deleted. (Inherited from FileWatcher.)
Protected method | OnFileRenamed | File has been renamed. (Inherited from FileWatcher.)
Protected method | PathShouldBeIngnored | Checks whether the pathes the should be ingnored. (Inherited from FileWatcher.)
Protected method | Renamed | Called when a file has been renamed. (Overrides FileWatcher..::..Renamed(String, String).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

XslWatcher Class
Sitecore.IO Namespace


Created Method

[image]

Sitecore 6.4.1 API
XslWatcher..::..Created Method
XslWatcher Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void Created(
    string fullPath
)
Visual Basic
Protected Overrides Sub Created ( _
    fullPath As String _
)
Visual C++
protected:
virtual void Created(
    String^ fullPath
) override

Parameters

fullPath
Type: System..::..String
The full path.

See Also

XslWatcher Class
Sitecore.IO Namespace


Deleted Method

[image]

Sitecore 6.4.1 API
XslWatcher..::..Deleted Method
XslWatcher Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void Deleted(
    string filePath
)
Visual Basic
Protected Overrides Sub Deleted ( _
    filePath As String _
)
Visual C++
protected:
virtual void Deleted(
    String^ filePath
) override

Parameters

filePath
Type: System..::..String
The full path.

See Also

XslWatcher Class
Sitecore.IO Namespace


Renamed Method

[image]

Sitecore 6.4.1 API
XslWatcher..::..Renamed Method
XslWatcher Class See Also Send Feedback

Namespace: Sitecore.IO
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void Renamed(
    string filePath,
    string oldFilePath
)
Visual Basic
Protected Overrides Sub Renamed ( _
    filePath As String, _
    oldFilePath As String _
)
Visual C++
protected:
virtual void Renamed(
    String^ filePath,
    String^ oldFilePath
) override

Parameters

filePath
Type: System..::..String
The full path.
oldFilePath
Type: System..::..String
The old full path.

See Also

XslWatcher Class
Sitecore.IO Namespace


XslWatcher Properties

[image] [image]

Sitecore 6.4.1 API
XslWatcher Properties
XslWatcher Class See Also Send Feedback

The XslWatcher type exposes the following members.

Properties

 | Name | Description
Protected property | Folder | Gets the path to the monitored folder. (Inherited from FileWatcher.)

See Also

XslWatcher Class
Sitecore.IO Namespace


Sitecore.Jobs Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Jobs Namespace
Send Feedback

Classes

 | Class | Description
Public class | Job | Represents a job.
Public class | JobArgs | Represents the arguments for a Job.
Public class | JobFinishedEventArgs | Represents the arguments for a job finished event.
Public class | JobManager | Represents the job manager.
Public class | JobOptions | Represents the options for a Job.
Public class | JobRunner | Represents a Job runner.
Public class | JobStatus | Represents the status of a Job.

Enumerations

 | Enumeration | Description
Public enumeration | JobState | Represents the state of a Job.


Job Class

[image]

Sitecore 6.4.1 API
Job Class
Members See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Job
Visual Basic
Public Class Job
Visual C++
public ref class Job

Inheritance Hierarchy

System..::..Object
Sitecore.Jobs..::..Job

See Also

Job Members
Sitecore.Jobs Namespace


Job Members

[image] [image]

Sitecore 6.4.1 API
Job Members
Job Class Constructors Methods Properties Events See Also Send Feedback

The Job type exposes the following members.

Constructors

 | Name | Description
Public method | Job | Initializes a new instance of the Job class.

Methods

 | Name | Description
 | AddMessage | Adds the status message to the context job. If there is no job, the message is ignored.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Start | Starts this job.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Wait()()()() | Waits.
Public method | Wait(Int32) | Waits the specified milliseconds.

Properties

 | Name | Description
Public property | Category | Gets the category.
Public property | Handle | Gets the handle.
Public property | IsDone | Gets a value indicating whether this job is done.
Public property | MessageQueue | Gets the message queue.
Public property | Name | Gets the name.
Public property | Options | Gets the options.
 | Processed | Gets or sets the processed counter of the context job. If there is no job, the operation is ignored.
Public property | QueueTime | Gets or sets the queue time.
Public property | Status | Gets the status.
 | Total | Gets or sets the total counter of the context job. If there is no job, the operation is ignored.
Public property | WaitHandle | Gets the wait handle.

Events

 | Name | Description
Public event | Finished |

See Also

Job Class
Sitecore.Jobs Namespace


Job Constructor

[image]

Sitecore 6.4.1 API
Job Constructor
Job Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Job(
    JobOptions options
)
Visual Basic
Public Sub New ( _
    options As JobOptions _
)
Visual C++
public:
Job(
    JobOptions^ options
)

Parameters

options
Type: Sitecore.Jobs..::..JobOptions
The options.

See Also

Job Class
Sitecore.Jobs Namespace


Job Methods

[image] [image]

Sitecore 6.4.1 API
Job Methods
Job Class See Also Send Feedback

The Job type exposes the following members.

Methods

 | Name | Description
 | AddMessage | Adds the status message to the context job. If there is no job, the message is ignored.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Start | Starts this job.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Wait()()()() | Waits.
Public method | Wait(Int32) | Waits the specified milliseconds.

See Also

Job Class
Sitecore.Jobs Namespace


AddMessage Method

[image]

Sitecore 6.4.1 API
Job..::..AddMessage Method
Job Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void AddMessage(
    string message,
    params Object[] args
)
Visual Basic
Public Shared Sub AddMessage ( _
    message As String, _
    ParamArray args As Object() _
)
Visual C++
public:
static void AddMessage(
    String^ message,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::..String
The message.
args
Type: array< System..::..Object >[]()[][]
The args.

See Also

Job Class
Sitecore.Jobs Namespace


Start Method

[image]

Sitecore 6.4.1 API
Job..::..Start Method
Job Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Start()
Visual Basic
Public Sub Start
Visual C++
public:
void Start()

See Also

Job Class
Sitecore.Jobs Namespace


Wait Method

[image] [image]

Sitecore 6.4.1 API
Job..::..Wait Method
Job Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Wait()()()() | Waits.
Public method | Wait(Int32) | Waits the specified milliseconds.

See Also

Job Class
Job Members
Sitecore.Jobs Namespace


Wait Method

[image]

Sitecore 6.4.1 API
Job..::..Wait Method
Job Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Wait()
Visual Basic
Public Function Wait As Boolean
Visual C++
public:
bool Wait()

Return Value

[Missing <returns> documentation for "M:Sitecore.Jobs.Job.Wait"]

See Also

Job Class
Wait Overload
Sitecore.Jobs Namespace


Wait Method (Int32)

[image]

Sitecore 6.4.1 API
Job..::..Wait Method (Int32)
Job Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Wait(
    int milliseconds
)
Visual Basic
Public Function Wait ( _
    milliseconds As Integer _
) As Boolean
Visual C++
public:
bool Wait(
    int milliseconds
)

Parameters

milliseconds
Type: System..::..Int32
The milliseconds.

Return Value

[Missing <returns> documentation for "M:Sitecore.Jobs.Job.Wait(System.Int32)"]

See Also

Job Class
Wait Overload
Sitecore.Jobs Namespace


Job Properties

[image] [image]

Sitecore 6.4.1 API
Job Properties
Job Class See Also Send Feedback

The Job type exposes the following members.

Properties

 | Name | Description
Public property | Category | Gets the category.
Public property | Handle | Gets the handle.
Public property | IsDone | Gets a value indicating whether this job is done.
Public property | MessageQueue | Gets the message queue.
Public property | Name | Gets the name.
Public property | Options | Gets the options.
 | Processed | Gets or sets the processed counter of the context job. If there is no job, the operation is ignored.
Public property | QueueTime | Gets or sets the queue time.
Public property | Status | Gets the status.
 | Total | Gets or sets the total counter of the context job. If there is no job, the operation is ignored.
Public property | WaitHandle | Gets the wait handle.

See Also

Job Class
Sitecore.Jobs Namespace


Category Property

[image]

Sitecore 6.4.1 API
Job..::..Category Property
Job Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Category { get; }
Visual Basic
Public ReadOnly Property Category As String
    Get
Visual C++
public:
property String^ Category {
    String^ get ();
}

Field Value

The category.

See Also

Job Class
Sitecore.Jobs Namespace


Handle Property

[image]

Sitecore 6.4.1 API
Job..::..Handle Property
Job Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Handle Handle { get; }
Visual Basic
Public ReadOnly Property Handle As Handle
    Get
Visual C++
public:
property Handle^ Handle {
    Handle^ get ();
}

Field Value

The handle.

See Also

Job Class
Sitecore.Jobs Namespace


IsDone Property

[image]

Sitecore 6.4.1 API
Job..::..IsDone Property
Job Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsDone { get; }
Visual Basic
Public ReadOnly Property IsDone As Boolean
    Get
Visual C++
public:
property bool IsDone {
    bool get ();
}

Field Value

true if this job is done; otherwise, false.

See Also

Job Class
Sitecore.Jobs Namespace


MessageQueue Property

[image]

Sitecore 6.4.1 API
Job..::..MessageQueue Property
Job Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MessageQueue MessageQueue { get; }
Visual Basic
Public ReadOnly Property MessageQueue As MessageQueue
    Get
Visual C++
public:
property MessageQueue^ MessageQueue {
    MessageQueue^ get ();
}

Field Value

The message queue.

See Also

Job Class
Sitecore.Jobs Namespace


Name Property

[image]

Sitecore 6.4.1 API
Job..::..Name Property
Job Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

Job Class
Sitecore.Jobs Namespace


Options Property

[image]

Sitecore 6.4.1 API
Job..::..Options Property
Job Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public JobOptions Options { get; }
Visual Basic
Public ReadOnly Property Options As JobOptions
    Get
Visual C++
public:
property JobOptions^ Options {
    JobOptions^ get ();
}

Field Value

The options.

See Also

Job Class
Sitecore.Jobs Namespace


QueueTime Property

[image]

Sitecore 6.4.1 API
Job..::..QueueTime Property
Job Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime QueueTime { get; set; }
Visual Basic
Public Property QueueTime As DateTime
    Get
    Set
Visual C++
public:
property DateTime QueueTime {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The queue time.

See Also

Job Class
Sitecore.Jobs Namespace


Status Property

[image]

Sitecore 6.4.1 API
Job..::..Status Property
Job Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public JobStatus Status { get; }
Visual Basic
Public ReadOnly Property Status As JobStatus
    Get
Visual C++
public:
property JobStatus^ Status {
    JobStatus^ get ();
}

Field Value

The status.

See Also

Job Class
Sitecore.Jobs Namespace


Total Property

[image]

Sitecore 6.4.1 API
Job..::..Total Property
Job Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long Total { get; set; }
Visual Basic
Public Shared Property Total As Long
    Get
    Set
Visual C++
public:
static property long long Total {
    long long get ();
    void set (long long value);
}

Field Value

The total.

See Also

Job Class
Sitecore.Jobs Namespace


Job Events

[image] [image]

Sitecore 6.4.1 API
Job Events
Job Class See Also Send Feedback

The Job type exposes the following members.

Events

 | Name | Description
Public event | Finished |

See Also

Job Class
Sitecore.Jobs Namespace


Finished Event

[image]

Sitecore 6.4.1 API
Job..::..Finished Event
Job Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler<JobFinishedEventArgs> Finished
Visual Basic
Public Event Finished As EventHandler(Of JobFinishedEventArgs)
Visual C++
public:
 event EventHandler<JobFinishedEventArgs^>^ Finished {
    void add (EventHandler<JobFinishedEventArgs^>^ value);
    void remove (EventHandler<JobFinishedEventArgs^>^ value);
}

See Also

Job Class
Sitecore.Jobs Namespace


JobArgs Members

[image] [image]

Sitecore 6.4.1 API
JobArgs Members
JobArgs Class Constructors Methods Properties See Also Send Feedback

The JobArgs type exposes the following members.

Constructors

 | Name | Description
Public method | JobArgs(Job) | Initializes a new instance of the JobArgs class.
Protected method | JobArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the JobArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Job | Gets the job.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Result | Gets or sets the result.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

JobArgs Class
Sitecore.Jobs Namespace


JobArgs Constructor

[image] [image]

Sitecore 6.4.1 API
JobArgs Constructor
JobArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | JobArgs(Job) | Initializes a new instance of the JobArgs class.
Protected method | JobArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the JobArgs class.

See Also

JobArgs Class
JobArgs Members
Sitecore.Jobs Namespace


JobArgs Constructor (Job)

[image]

Sitecore 6.4.1 API
JobArgs Constructor (Job)
JobArgs Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public JobArgs(
    Job job
)
Visual Basic
Public Sub New ( _
    job As Job _
)
Visual C++
public:
JobArgs(
    Job^ job
)

Parameters

job
Type: Sitecore.Jobs..::..Job
The job.

See Also

JobArgs Class
JobArgs Overload
Sitecore.Jobs Namespace


JobArgs Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
JobArgs Constructor (SerializationInfo, StreamingContext)
JobArgs Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected JobArgs(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
JobArgs(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

JobArgs Class
JobArgs Overload
Sitecore.Jobs Namespace


JobArgs Methods

[image] [image]

Sitecore 6.4.1 API
JobArgs Methods
JobArgs Class See Also Send Feedback

The JobArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

JobArgs Class
Sitecore.Jobs Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
JobArgs..::..AddMessage Method
JobArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

JobArgs Class
JobArgs Members
Sitecore.Jobs Namespace


GetObjectData Method

[image]

Sitecore 6.4.1 API
JobArgs..::..GetObjectData Method
JobArgs Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System.Security..::..SecurityException | The caller does not have the required permission.

See Also

JobArgs Class
Sitecore.Jobs Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
JobArgs..::..Suspend Method
JobArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

JobArgs Class
JobArgs Members
Sitecore.Jobs Namespace


JobArgs Properties

[image] [image]

Sitecore 6.4.1 API
JobArgs Properties
JobArgs Class See Also Send Feedback

The JobArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Job | Gets the job.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Result | Gets or sets the result.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

JobArgs Class
Sitecore.Jobs Namespace


Job Property

[image]

Sitecore 6.4.1 API
JobArgs..::..Job Property
JobArgs Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Job Job { get; }
Visual Basic
Public ReadOnly Property Job As Job
    Get
Visual C++
public:
property Job^ Job {
    Job^ get ();
}

Field Value

The job.

See Also

JobArgs Class
Sitecore.Jobs Namespace


Result Property

[image]

Sitecore 6.4.1 API
JobArgs..::..Result Property
JobArgs Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object Result { get; set; }
Visual Basic
Public Property Result As Object
    Get
    Set
Visual C++
public:
property Object^ Result {
    Object^ get ();
    void set (Object^ value);
}

Field Value

The result.

See Also

JobArgs Class
Sitecore.Jobs Namespace


JobFinishedEventArgs Class

[image]

Sitecore 6.4.1 API
JobFinishedEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class JobFinishedEventArgs : EventArgs
Visual Basic
Public Class JobFinishedEventArgs _
    Inherits EventArgs
Visual C++
public ref class JobFinishedEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Jobs..::..JobFinishedEventArgs

See Also

JobFinishedEventArgs Members
Sitecore.Jobs Namespace


JobFinishedEventArgs Members

[image] [image]

Sitecore 6.4.1 API
JobFinishedEventArgs Members
JobFinishedEventArgs Class Constructors Methods Properties See Also Send Feedback

The JobFinishedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | JobFinishedEventArgs | Initializes a new instance of the JobFinishedEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Job | Gets the Job associated with the event.

See Also

JobFinishedEventArgs Class
Sitecore.Jobs Namespace


JobFinishedEventArgs Constructor

[image]

Sitecore 6.4.1 API
JobFinishedEventArgs Constructor
JobFinishedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public JobFinishedEventArgs(
    Job job
)
Visual Basic
Public Sub New ( _
    job As Job _
)
Visual C++
public:
JobFinishedEventArgs(
    Job^ job
)

Parameters

job
Type: Sitecore.Jobs..::..Job
The job.

See Also

JobFinishedEventArgs Class
Sitecore.Jobs Namespace


JobFinishedEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
JobFinishedEventArgs Methods
JobFinishedEventArgs Class See Also Send Feedback

The JobFinishedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

JobFinishedEventArgs Class
Sitecore.Jobs Namespace


JobFinishedEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
JobFinishedEventArgs Properties
JobFinishedEventArgs Class See Also Send Feedback

The JobFinishedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Job | Gets the Job associated with the event.

See Also

JobFinishedEventArgs Class
Sitecore.Jobs Namespace


Job Property

[image]

Sitecore 6.4.1 API
JobFinishedEventArgs..::..Job Property
JobFinishedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Job Job { get; }
Visual Basic
Public ReadOnly Property Job As Job
    Get
Visual C++
public:
property Job^ Job {
    Job^ get ();
}

Field Value

The job.

See Also

JobFinishedEventArgs Class
Sitecore.Jobs Namespace


JobManager Class

[image]

Sitecore 6.4.1 API
JobManager Class
Members See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class JobManager
Visual Basic
Public NotInheritable Class JobManager
Visual C++
public ref class JobManager abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Jobs..::..JobManager

See Also

JobManager Members
Sitecore.Jobs Namespace


JobManager Members

[image] [image]

Sitecore 6.4.1 API
JobManager Members
JobManager Class Methods See Also Send Feedback

The JobManager type exposes the following members.

Methods

Name | Description
GetJob(String) | Gets a job.
GetJob(Handle) | Gets the job.
GetJobs | Gets the jobs.
IsJobActive | Obsolete. Determines whether a job is running.
IsJobQueued | Determines whether a job is queued.
IsJobRunning | Determines whether a job is running.
RemoveJob | Obsolete. Removes the job.
Start(Job) | Starts the specified job.
Start(JobOptions) | Starts the specified options.

See Also

JobManager Class
Sitecore.Jobs Namespace


JobManager Methods

[image] [image]

Sitecore 6.4.1 API
JobManager Methods
JobManager Class See Also Send Feedback

The JobManager type exposes the following members.

Methods

Name | Description
GetJob(String) | Gets a job.
GetJob(Handle) | Gets the job.
GetJobs | Gets the jobs.
IsJobActive | Obsolete. Determines whether a job is running.
IsJobQueued | Determines whether a job is queued.
IsJobRunning | Determines whether a job is running.
RemoveJob | Obsolete. Removes the job.
Start(Job) | Starts the specified job.
Start(JobOptions) | Starts the specified options.

See Also

JobManager Class
Sitecore.Jobs Namespace


GetJob Method

[image] [image]

Sitecore 6.4.1 API
JobManager..::..GetJob Method
JobManager Class See Also Send Feedback

Overload List

Name | Description
GetJob(String) | Gets a job.
GetJob(Handle) | Gets the job.

See Also

JobManager Class
JobManager Members
Sitecore.Jobs Namespace


GetJob Method (String)

[image]

Sitecore 6.4.1 API
JobManager..::..GetJob Method (String)
JobManager Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Job GetJob(
    string jobName
)
Visual Basic
Public Shared Function GetJob ( _
    jobName As String _
) As Job
Visual C++
public:
static Job^ GetJob(
    String^ jobName
)

Parameters

jobName
Type: System..::..String

[Missing <param name="jobName"/> documentation for "M:Sitecore.Jobs.JobManager.GetJob(System.String)"]

Return Value

The Job.

See Also

JobManager Class
GetJob Overload
Sitecore.Jobs Namespace


GetJob Method (Handle)

[image]

Sitecore 6.4.1 API
JobManager..::..GetJob Method (Handle)
JobManager Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Job GetJob(
    Handle handle
)
Visual Basic
Public Shared Function GetJob ( _
    handle As Handle _
) As Job
Visual C++
public:
static Job^ GetJob(
    Handle^ handle
)

Parameters

handle
Type: Sitecore..::..Handle
The handle.

Return Value

The Job.

See Also

JobManager Class
GetJob Overload
Sitecore.Jobs Namespace


GetJobs Method

[image]

Sitecore 6.4.1 API
JobManager..::..GetJobs Method
JobManager Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Job[] GetJobs()
Visual Basic
Public Shared Function GetJobs As Job()
Visual C++
public:
static array<Job^>^ GetJobs()

Return Value

The Job.

See Also

JobManager Class
Sitecore.Jobs Namespace


IsJobActive Method

[image]

Sitecore 6.4.1 API
JobManager..::..IsJobActive Method
JobManager Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use IsJobRunning instead")]
public static bool IsJobActive(
    string jobName
)
Visual Basic
<ObsoleteAttribute("Use IsJobRunning instead")> _
Public Shared Function IsJobActive ( _
    jobName As String _
) As Boolean
Visual C++
[ObsoleteAttribute(L"Use IsJobRunning instead")]
public:
static bool IsJobActive(
    String^ jobName
)

Parameters

jobName
Type: System..::..String
Name of the job.

Return Value

true if a job with the specified job name is running; otherwise, false.

See Also

JobManager Class
Sitecore.Jobs Namespace


RemoveJob Method

[image]

Sitecore 6.4.1 API
JobManager..::..RemoveJob Method
JobManager Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated")]
public static void RemoveJob(
    Handle handle
)
Visual Basic
<ObsoleteAttribute("Deprecated")> _
Public Shared Sub RemoveJob ( _
    handle As Handle _
)
Visual C++
[ObsoleteAttribute(L"Deprecated")]
public:
static void RemoveJob(
    Handle^ handle
)

Parameters

handle
Type: Sitecore..::..Handle
The handle.

See Also

JobManager Class
Sitecore.Jobs Namespace


Start Method

[image] [image]

Sitecore 6.4.1 API
JobManager..::..Start Method
JobManager Class See Also Send Feedback

Overload List

Name | Description
Start(Job) | Starts the specified job.
Start(JobOptions) | Starts the specified options.

See Also

JobManager Class
JobManager Members
Sitecore.Jobs Namespace


Start Method (Job)

[image]

Sitecore 6.4.1 API
JobManager..::..Start Method (Job)
JobManager Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Start(
    Job job
)
Visual Basic
Public Shared Sub Start ( _
    job As Job _
)
Visual C++
public:
static void Start(
    Job^ job
)

Parameters

job
Type: Sitecore.Jobs..::..Job
The job.

See Also

JobManager Class
Start Overload
Sitecore.Jobs Namespace


Start Method (JobOptions)

[image]

Sitecore 6.4.1 API
JobManager..::..Start Method (JobOptions)
JobManager Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Job Start(
    JobOptions options
)
Visual Basic
Public Shared Function Start ( _
    options As JobOptions _
) As Job
Visual C++
public:
static Job^ Start(
    JobOptions^ options
)

Parameters

options
Type: Sitecore.Jobs..::..JobOptions
The options.

Return Value

The Job.

See Also

JobManager Class
Start Overload
Sitecore.Jobs Namespace


JobOptions Class

[image]

Sitecore 6.4.1 API
JobOptions Class
Members See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class JobOptions
Visual Basic
Public Class JobOptions
Visual C++
public ref class JobOptions

Inheritance Hierarchy

System..::..Object
Sitecore.Jobs..::..JobOptions

See Also

JobOptions Members
Sitecore.Jobs Namespace


JobOptions Members

[image] [image]

Sitecore 6.4.1 API
JobOptions Members
JobOptions Class Constructors Methods Properties See Also Send Feedback

The JobOptions type exposes the following members.

Constructors

 | Name | Description
Public method | JobOptions(String, String, String, Object, String) | Initializes a new instance of the JobOptions class.
Public method | JobOptions(String, String, String, Object, String, array<Object>[]()[][]) | Initializes a new instance of the JobOptions class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AfterLife | Gets or sets the after life.
Public property | AtomicExecution | Gets or sets a value indicating whether the JobOptions has atomic execution.
Public property | Category | Gets the category.
Public property | ClientLanguage | Gets or sets the client language. Used for translations.
Public property | ContextUser | Gets or sets the context user.
Public property | CustomData | Gets or sets the custom data.
Public property | EnableSecurity | Gets or sets a value indicating whether the JobOptions enables security.
Public property | InitialDelay | Gets or sets the initial delay.
Public property | Item | Gets or sets the item.
Public property | JobName | Gets the name of the job.
Public property | Method | Gets the method.
Public property | Parameters | Gets the parameters.
Public property | PipelineDomain | Gets or sets the pipeline domain.
Public property | PipelineName | Gets or sets the name of the pipeline.
Public property | Priority | Gets or sets the priority.
Public property | SiteName | Gets or sets the name of the site.
Public property | WriteToLog | Gets or sets a value indicating whether the JobOptions writes the to log.

See Also

JobOptions Class
Sitecore.Jobs Namespace


JobOptions Constructor

[image] [image]

Sitecore 6.4.1 API
JobOptions Constructor
JobOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | JobOptions(String, String, String, Object, String) | Initializes a new instance of the JobOptions class.
Public method | JobOptions(String, String, String, Object, String, array<Object>[]()[][]) | Initializes a new instance of the JobOptions class.

See Also

JobOptions Class
JobOptions Members
Sitecore.Jobs Namespace


JobOptions Constructor (String, String, String, Object, String)

[image]

Sitecore 6.4.1 API
JobOptions Constructor (String, String, String, Object, String)
JobOptions Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public JobOptions(
    string jobName,
    string category,
    string siteName,
    Object obj,
    string methodName
)
Visual Basic
Public Sub New ( _
    jobName As String, _
    category As String, _
    siteName As String, _
    obj As Object, _
    methodName As String _
)
Visual C++
public:
JobOptions(
    String^ jobName,
    String^ category,
    String^ siteName,
    Object^ obj,
    String^ methodName
)

Parameters

jobName
Type: System..::..String
Name of the job.
category
Type: System..::..String
The category.
siteName
Type: System..::..String
Name of the site.
obj
Type: System..::..Object
The object.
methodName
Type: System..::..String
Name of the method.

See Also

JobOptions Class
JobOptions Overload
Sitecore.Jobs Namespace


JobOptions Constructor (String, String, String, Object, String, Object[])

[image]

Sitecore 6.4.1 API
JobOptions Constructor (String, String, String, Object, String, array<Object>[]()[][])
JobOptions Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public JobOptions(
    string jobName,
    string category,
    string siteName,
    Object obj,
    string methodName,
    Object[] parameters
)
Visual Basic
Public Sub New ( _
    jobName As String, _
    category As String, _
    siteName As String, _
    obj As Object, _
    methodName As String, _
    parameters As Object() _
)
Visual C++
public:
JobOptions(
    String^ jobName,
    String^ category,
    String^ siteName,
    Object^ obj,
    String^ methodName,
    array<Object^>^ parameters
)

Parameters

jobName
Type: System..::..String
Name of the job.
category
Type: System..::..String
The category.
siteName
Type: System..::..String
Name of the site.
obj
Type: System..::..Object
The object.
methodName
Type: System..::..String
Name of the method.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.

See Also

JobOptions Class
JobOptions Overload
Sitecore.Jobs Namespace


JobOptions Methods

[image] [image]

Sitecore 6.4.1 API
JobOptions Methods
JobOptions Class See Also Send Feedback

The JobOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

JobOptions Class
Sitecore.Jobs Namespace


JobOptions Properties

[image] [image]

Sitecore 6.4.1 API
JobOptions Properties
JobOptions Class See Also Send Feedback

The JobOptions type exposes the following members.

Properties

 | Name | Description
Public property | AfterLife | Gets or sets the after life.
Public property | AtomicExecution | Gets or sets a value indicating whether the JobOptions has atomic execution.
Public property | Category | Gets the category.
Public property | ClientLanguage | Gets or sets the client language. Used for translations.
Public property | ContextUser | Gets or sets the context user.
Public property | CustomData | Gets or sets the custom data.
Public property | EnableSecurity | Gets or sets a value indicating whether the JobOptions enables security.
Public property | InitialDelay | Gets or sets the initial delay.
Public property | Item | Gets or sets the item.
Public property | JobName | Gets the name of the job.
Public property | Method | Gets the method.
Public property | Parameters | Gets the parameters.
Public property | PipelineDomain | Gets or sets the pipeline domain.
Public property | PipelineName | Gets or sets the name of the pipeline.
Public property | Priority | Gets or sets the priority.
Public property | SiteName | Gets or sets the name of the site.
Public property | WriteToLog | Gets or sets a value indicating whether the JobOptions writes the to log.

See Also

JobOptions Class
Sitecore.Jobs Namespace


AfterLife Property

[image]

Sitecore 6.4.1 API
JobOptions..::..AfterLife Property
JobOptions Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TimeSpan AfterLife { get; set; }
Visual Basic
Public Property AfterLife As TimeSpan
    Get
    Set
Visual C++
public:
property TimeSpan AfterLife {
    TimeSpan get ();
    void set (TimeSpan value);
}

Field Value

The after life.

See Also

JobOptions Class
Sitecore.Jobs Namespace


AtomicExecution Property

[image]

Sitecore 6.4.1 API
JobOptions..::..AtomicExecution Property
JobOptions Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool AtomicExecution { get; set; }
Visual Basic
Public Property AtomicExecution As Boolean
    Get
    Set
Visual C++
public:
property bool AtomicExecution {
    bool get ();
    void set (bool value);
}

Field Value

true if the JobOptions has atomic execution; otherwise, false.

See Also

JobOptions Class
Sitecore.Jobs Namespace


Category Property

[image]

Sitecore 6.4.1 API
JobOptions..::..Category Property
JobOptions Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Category { get; }
Visual Basic
Public ReadOnly Property Category As String
    Get
Visual C++
public:
property String^ Category {
    String^ get ();
}

Field Value

The category.

See Also

JobOptions Class
Sitecore.Jobs Namespace


ClientLanguage Property

[image]

Sitecore 6.4.1 API
JobOptions..::..ClientLanguage Property
JobOptions Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Language ClientLanguage { get; set; }
Visual Basic
Public Property ClientLanguage As Language
    Get
    Set
Visual C++
public:
property Language^ ClientLanguage {
    Language^ get ();
    void set (Language^ value);
}

Field Value

The Language.

See Also

JobOptions Class
Sitecore.Jobs Namespace


ContextUser Property

[image]

Sitecore 6.4.1 API
JobOptions..::..ContextUser Property
JobOptions Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public User ContextUser { get; set; }
Visual Basic
Public Property ContextUser As User
    Get
    Set
Visual C++
public:
property User^ ContextUser {
    User^ get ();
    void set (User^ value);
}

Field Value

The context user.

See Also

JobOptions Class
Sitecore.Jobs Namespace


CustomData Property

[image]

Sitecore 6.4.1 API
JobOptions..::..CustomData Property
JobOptions Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object CustomData { get; set; }
Visual Basic
Public Property CustomData As Object
    Get
    Set
Visual C++
public:
property Object^ CustomData {
    Object^ get ();
    void set (Object^ value);
}

Field Value

The custom data.

See Also

JobOptions Class
Sitecore.Jobs Namespace


EnableSecurity Property

[image]

Sitecore 6.4.1 API
JobOptions..::..EnableSecurity Property
JobOptions Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool EnableSecurity { get; set; }
Visual Basic
Public Property EnableSecurity As Boolean
    Get
    Set
Visual C++
public:
property bool EnableSecurity {
    bool get ();
    void set (bool value);
}

Field Value

true if the JobOptions enables security; otherwise, false.

See Also

JobOptions Class
Sitecore.Jobs Namespace


InitialDelay Property

[image]

Sitecore 6.4.1 API
JobOptions..::..InitialDelay Property
JobOptions Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TimeSpan InitialDelay { get; set; }
Visual Basic
Public Property InitialDelay As TimeSpan
    Get
    Set
Visual C++
public:
property TimeSpan InitialDelay {
    TimeSpan get ();
    void set (TimeSpan value);
}

Field Value

The initial delay.

Remarks

The job will sleep for this period before executing.

See Also

JobOptions Class
Sitecore.Jobs Namespace


Item Property

[image]

Sitecore 6.4.1 API
JobOptions..::..Item Property
JobOptions Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Item { get; set; }
Visual Basic
Public Property Item As Item
    Get
    Set
Visual C++
public:
property Item^ Item {
    Item^ get ();
    void set (Item^ value);
}

Field Value

The item.

See Also

JobOptions Class
Sitecore.Jobs Namespace


JobName Property

[image]

Sitecore 6.4.1 API
JobOptions..::..JobName Property
JobOptions Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string JobName { get; }
Visual Basic
Public ReadOnly Property JobName As String
    Get
Visual C++
public:
property String^ JobName {
    String^ get ();
}

Field Value

The name of the job.

See Also

JobOptions Class
Sitecore.Jobs Namespace


Method Property

[image]

Sitecore 6.4.1 API
JobOptions..::..Method Property
JobOptions Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MethodInstance Method { get; }
Visual Basic
Public ReadOnly Property Method As MethodInstance
    Get
Visual C++
public:
property MethodInstance^ Method {
    MethodInstance^ get ();
}

Field Value

The method.

See Also

JobOptions Class
Sitecore.Jobs Namespace


Parameters Property

[image]

Sitecore 6.4.1 API
JobOptions..::..Parameters Property
JobOptions Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object[] Parameters { get; }
Visual Basic
Public ReadOnly Property Parameters As Object()
    Get
Visual C++
public:
property array<Object^>^ Parameters {
    array<Object^>^ get ();
}

Field Value

The parameters.

See Also

JobOptions Class
Sitecore.Jobs Namespace


PipelineDomain Property

[image]

Sitecore 6.4.1 API
JobOptions..::..PipelineDomain Property
JobOptions Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string PipelineDomain { get; set; }
Visual Basic
Public Property PipelineDomain As String
    Get
    Set
Visual C++
public:
property String^ PipelineDomain {
    String^ get ();
    void set (String^ value);
}

Field Value

The pipeline domain.

See Also

JobOptions Class
Sitecore.Jobs Namespace


PipelineName Property

[image]

Sitecore 6.4.1 API
JobOptions..::..PipelineName Property
JobOptions Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string PipelineName { get; set; }
Visual Basic
Public Property PipelineName As String
    Get
    Set
Visual C++
public:
property String^ PipelineName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the pipeline.

See Also

JobOptions Class
Sitecore.Jobs Namespace


Priority Property

[image]

Sitecore 6.4.1 API
JobOptions..::..Priority Property
JobOptions Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ThreadPriority Priority { get; set; }
Visual Basic
Public Property Priority As ThreadPriority
    Get
    Set
Visual C++
public:
property ThreadPriority Priority {
    ThreadPriority get ();
    void set (ThreadPriority value);
}

Field Value

The priority.

See Also

JobOptions Class
Sitecore.Jobs Namespace


SiteName Property

[image]

Sitecore 6.4.1 API
JobOptions..::..SiteName Property
JobOptions Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string SiteName { get; set; }
Visual Basic
Public Property SiteName As String
    Get
    Set
Visual C++
public:
property String^ SiteName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the site.

See Also

JobOptions Class
Sitecore.Jobs Namespace


WriteToLog Property

[image]

Sitecore 6.4.1 API
JobOptions..::..WriteToLog Property
JobOptions Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool WriteToLog { get; set; }
Visual Basic
Public Property WriteToLog As Boolean
    Get
    Set
Visual C++
public:
property bool WriteToLog {
    bool get ();
    void set (bool value);
}

Field Value

true if the JobOptions writes the to log; otherwise, false.

See Also

JobOptions Class
Sitecore.Jobs Namespace


JobRunner Class

[image]

Sitecore 6.4.1 API
JobRunner Class
Members See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class JobRunner
Visual Basic
Public Class JobRunner
Visual C++
public ref class JobRunner

Inheritance Hierarchy

System..::..Object
Sitecore.Jobs..::..JobRunner

See Also

JobRunner Members
Sitecore.Jobs Namespace


JobRunner Members

[image] [image]

Sitecore 6.4.1 API
JobRunner Members
JobRunner Class Constructors Methods See Also Send Feedback

The JobRunner type exposes the following members.

Constructors

 | Name | Description
Public method | JobRunner | Initializes a new instance of the JobRunner class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeContext | Initializes the context.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ResetSecurity | Resets the security.
 | RunMethod | Runs the method.
 | SetContextUser | Sets the context user.
 | SetPriority | Sets the priority.
 | SetSecurity | Sets the security.
 | SignalEnd | Signals the end.
 | SignalStart | Signals the start.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

JobRunner Class
Sitecore.Jobs Namespace


JobRunner Constructor

[image]

Sitecore 6.4.1 API
JobRunner Constructor
JobRunner Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public JobRunner()
Visual Basic
Public Sub New
Visual C++
public:
JobRunner()

See Also

JobRunner Class
Sitecore.Jobs Namespace


JobRunner Methods

[image] [image]

Sitecore 6.4.1 API
JobRunner Methods
JobRunner Class See Also Send Feedback

The JobRunner type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeContext | Initializes the context.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ResetSecurity | Resets the security.
 | RunMethod | Runs the method.
 | SetContextUser | Sets the context user.
 | SetPriority | Sets the priority.
 | SetSecurity | Sets the security.
 | SignalEnd | Signals the end.
 | SignalStart | Signals the start.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

JobRunner Class
Sitecore.Jobs Namespace


InitializeContext Method

[image]

Sitecore 6.4.1 API
JobRunner..::..InitializeContext Method
JobRunner Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void InitializeContext(
    JobArgs args
)
Visual Basic
Public Shared Sub InitializeContext ( _
    args As JobArgs _
)
Visual C++
public:
static void InitializeContext(
    JobArgs^ args
)

Parameters

args
Type: Sitecore.Jobs..::..JobArgs
The arguments.

See Also

JobRunner Class
Sitecore.Jobs Namespace


ResetSecurity Method

[image]

Sitecore 6.4.1 API
JobRunner..::..ResetSecurity Method
JobRunner Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void ResetSecurity(
    JobArgs args
)
Visual Basic
Public Shared Sub ResetSecurity ( _
    args As JobArgs _
)
Visual C++
public:
static void ResetSecurity(
    JobArgs^ args
)

Parameters

args
Type: Sitecore.Jobs..::..JobArgs
The arguments.

See Also

JobRunner Class
Sitecore.Jobs Namespace


RunMethod Method

[image]

Sitecore 6.4.1 API
JobRunner..::..RunMethod Method
JobRunner Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void RunMethod(
    JobArgs args
)
Visual Basic
Public Shared Sub RunMethod ( _
    args As JobArgs _
)
Visual C++
public:
static void RunMethod(
    JobArgs^ args
)

Parameters

args
Type: Sitecore.Jobs..::..JobArgs
The arguments.

See Also

JobRunner Class
Sitecore.Jobs Namespace


SetContextUser Method

[image]

Sitecore 6.4.1 API
JobRunner..::..SetContextUser Method
JobRunner Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void SetContextUser(
    JobArgs args
)
Visual Basic
Public Shared Sub SetContextUser ( _
    args As JobArgs _
)
Visual C++
public:
static void SetContextUser(
    JobArgs^ args
)

Parameters

args
Type: Sitecore.Jobs..::..JobArgs
The arguments.

See Also

JobRunner Class
Sitecore.Jobs Namespace


SetPriority Method

[image]

Sitecore 6.4.1 API
JobRunner..::..SetPriority Method
JobRunner Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void SetPriority(
    JobArgs args
)
Visual Basic
Public Shared Sub SetPriority ( _
    args As JobArgs _
)
Visual C++
public:
static void SetPriority(
    JobArgs^ args
)

Parameters

args
Type: Sitecore.Jobs..::..JobArgs
The arguments.

See Also

JobRunner Class
Sitecore.Jobs Namespace


SetSecurity Method

[image]

Sitecore 6.4.1 API
JobRunner..::..SetSecurity Method
JobRunner Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void SetSecurity(
    JobArgs args
)
Visual Basic
Public Shared Sub SetSecurity ( _
    args As JobArgs _
)
Visual C++
public:
static void SetSecurity(
    JobArgs^ args
)

Parameters

args
Type: Sitecore.Jobs..::..JobArgs
The arguments.

See Also

JobRunner Class
Sitecore.Jobs Namespace


SignalEnd Method

[image]

Sitecore 6.4.1 API
JobRunner..::..SignalEnd Method
JobRunner Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void SignalEnd(
    JobArgs args
)
Visual Basic
Public Shared Sub SignalEnd ( _
    args As JobArgs _
)
Visual C++
public:
static void SignalEnd(
    JobArgs^ args
)

Parameters

args
Type: Sitecore.Jobs..::..JobArgs
The arguments.

See Also

JobRunner Class
Sitecore.Jobs Namespace


SignalStart Method

[image]

Sitecore 6.4.1 API
JobRunner..::..SignalStart Method
JobRunner Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void SignalStart(
    JobArgs args
)
Visual Basic
Public Shared Sub SignalStart ( _
    args As JobArgs _
)
Visual C++
public:
static void SignalStart(
    JobArgs^ args
)

Parameters

args
Type: Sitecore.Jobs..::..JobArgs
The arguments.

See Also

JobRunner Class
Sitecore.Jobs Namespace


JobStatus Class

[image]

Sitecore 6.4.1 API
JobStatus Class
Members See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class JobStatus
Visual Basic
Public Class JobStatus
Visual C++
public ref class JobStatus

Inheritance Hierarchy

System..::..Object
Sitecore.Jobs..::..JobStatus

See Also

JobStatus Members
Sitecore.Jobs Namespace


JobStatus Members

[image] [image]

Sitecore 6.4.1 API
JobStatus Members
JobStatus Class Constructors Methods Properties See Also Send Feedback

The JobStatus type exposes the following members.

Constructors

 | Name | Description
Public method | JobStatus | Initializes a new instance of the JobStatus class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCounter | Obsolete. Gets the counter.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LogError | Logs the error.
Public method | LogException | Logs the exception.
Public method | LogInfo(String) | Logs the info.
Public method | LogInfo(String, array<Object>[]()[][]) | Logs the info by english, then the template message will be translated by ui locale and saved to message collection
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Expiry | Gets or sets the expiry.
Public property | Failed | Gets or sets a value indicating whether this JobStatus is failed.
Public property | Job | Gets the job.
Public property | Messages | Gets the messages.
Public property | Processed | Gets or sets the number of processed units.
Public property | Result | Gets or sets the result.
Public property | State | Gets or sets the state.
Public property | Total | Gets or sets the total.

See Also

JobStatus Class
Sitecore.Jobs Namespace


JobStatus Constructor

[image]

Sitecore 6.4.1 API
JobStatus Constructor
JobStatus Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public JobStatus(
    Job job
)
Visual Basic
Public Sub New ( _
    job As Job _
)
Visual C++
public:
JobStatus(
    Job^ job
)

Parameters

job
Type: Sitecore.Jobs..::..Job
The job.

See Also

JobStatus Class
Sitecore.Jobs Namespace


JobStatus Methods

[image] [image]

Sitecore 6.4.1 API
JobStatus Methods
JobStatus Class See Also Send Feedback

The JobStatus type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCounter | Obsolete. Gets the counter.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LogError | Logs the error.
Public method | LogException | Logs the exception.
Public method | LogInfo(String) | Logs the info.
Public method | LogInfo(String, array<Object>[]()[][]) | Logs the info by english, then the template message will be translated by ui locale and saved to message collection
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

JobStatus Class
Sitecore.Jobs Namespace


GetCounter Method

[image]

Sitecore 6.4.1 API
JobStatus..::..GetCounter Method
JobStatus Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated")]
public CounterData GetCounter(
    string name
)
Visual Basic
<ObsoleteAttribute("Deprecated")> _
Public Function GetCounter ( _
    name As String _
) As CounterData
Visual C++
[ObsoleteAttribute(L"Deprecated")]
public:
CounterData^ GetCounter(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

Return Value

The CounterData.

See Also

JobStatus Class
Sitecore.Jobs Namespace


LogError Method

[image]

Sitecore 6.4.1 API
JobStatus..::..LogError Method
JobStatus Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void LogError(
    string message
)
Visual Basic
Public Sub LogError ( _
    message As String _
)
Visual C++
public:
void LogError(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

JobStatus Class
Sitecore.Jobs Namespace


LogException Method

[image]

Sitecore 6.4.1 API
JobStatus..::..LogException Method
JobStatus Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void LogException(
    Exception ex
)
Visual Basic
Public Sub LogException ( _
    ex As Exception _
)
Visual C++
public:
void LogException(
    Exception^ ex
)

Parameters

ex
Type: System..::..Exception
The ex.

See Also

JobStatus Class
Sitecore.Jobs Namespace


LogInfo Method

[image] [image]

Sitecore 6.4.1 API
JobStatus..::..LogInfo Method
JobStatus Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LogInfo(String) | Logs the info.
Public method | LogInfo(String, array<Object>[]()[][]) | Logs the info by english, then the template message will be translated by ui locale and saved to message collection

See Also

JobStatus Class
JobStatus Members
Sitecore.Jobs Namespace


LogInfo Method (String)

[image]

Sitecore 6.4.1 API
JobStatus..::..LogInfo Method (String)
JobStatus Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void LogInfo(
    string message
)
Visual Basic
Public Sub LogInfo ( _
    message As String _
)
Visual C++
public:
void LogInfo(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

JobStatus Class
LogInfo Overload
Sitecore.Jobs Namespace


LogInfo Method (String, Object[])

[image]

Sitecore 6.4.1 API
JobStatus..::..LogInfo Method (String, array<Object>[]()[][])
JobStatus Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void LogInfo(
    string message,
    params Object[] args
)
Visual Basic
Public Sub LogInfo ( _
    message As String, _
    ParamArray args As Object() _
)
Visual C++
public:
void LogInfo(
    String^ message,
    ... array<Object^>^ args
)

Parameters

message
Type: System..::..String
The message.
args
Type: array< System..::..Object >[]()[][]
The arguments.

See Also

JobStatus Class
LogInfo Overload
Sitecore.Jobs Namespace


JobStatus Properties

[image] [image]

Sitecore 6.4.1 API
JobStatus Properties
JobStatus Class See Also Send Feedback

The JobStatus type exposes the following members.

Properties

 | Name | Description
Public property | Expiry | Gets or sets the expiry.
Public property | Failed | Gets or sets a value indicating whether this JobStatus is failed.
Public property | Job | Gets the job.
Public property | Messages | Gets the messages.
Public property | Processed | Gets or sets the number of processed units.
Public property | Result | Gets or sets the result.
Public property | State | Gets or sets the state.
Public property | Total | Gets or sets the total.

See Also

JobStatus Class
Sitecore.Jobs Namespace


Expiry Property

[image]

Sitecore 6.4.1 API
JobStatus..::..Expiry Property
JobStatus Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime Expiry { get; set; }
Visual Basic
Public Property Expiry As DateTime
    Get
    Set
Visual C++
public:
property DateTime Expiry {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The expiry.

See Also

JobStatus Class
Sitecore.Jobs Namespace


Failed Property

[image]

Sitecore 6.4.1 API
JobStatus..::..Failed Property
JobStatus Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Failed { get; set; }
Visual Basic
Public Property Failed As Boolean
    Get
    Set
Visual C++
public:
property bool Failed {
    bool get ();
    void set (bool value);
}

Field Value

true if failed; otherwise, false.

See Also

JobStatus Class
Sitecore.Jobs Namespace


Job Property

[image]

Sitecore 6.4.1 API
JobStatus..::..Job Property
JobStatus Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Job Job { get; }
Visual Basic
Public ReadOnly Property Job As Job
    Get
Visual C++
public:
property Job^ Job {
    Job^ get ();
}

Field Value

The job.

See Also

JobStatus Class
Sitecore.Jobs Namespace


Messages Property

[image]

Sitecore 6.4.1 API
JobStatus..::..Messages Property
JobStatus Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StringCollection Messages { get; }
Visual Basic
Public ReadOnly Property Messages As StringCollection
    Get
Visual C++
public:
property StringCollection^ Messages {
    StringCollection^ get ();
}

Field Value

The messages.

See Also

JobStatus Class
Sitecore.Jobs Namespace


Processed Property

[image]

Sitecore 6.4.1 API
JobStatus..::..Processed Property
JobStatus Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long Processed { get; set; }
Visual Basic
Public Property Processed As Long
    Get
    Set
Visual C++
public:
property long long Processed {
    long long get ();
    void set (long long value);
}

Field Value

The number of processed units.

See Also

JobStatus Class
Sitecore.Jobs Namespace


Result Property

[image]

Sitecore 6.4.1 API
JobStatus..::..Result Property
JobStatus Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object Result { get; set; }
Visual Basic
Public Property Result As Object
    Get
    Set
Visual C++
public:
property Object^ Result {
    Object^ get ();
    void set (Object^ value);
}

Field Value

The result.

See Also

JobStatus Class
Sitecore.Jobs Namespace


State Property

[image]

Sitecore 6.4.1 API
JobStatus..::..State Property
JobStatus Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public JobState State { get; set; }
Visual Basic
Public Property State As JobState
    Get
    Set
Visual C++
public:
property JobState State {
    JobState get ();
    void set (JobState value);
}

Field Value

The state.

See Also

JobStatus Class
Sitecore.Jobs Namespace


Total Property

[image]

Sitecore 6.4.1 API
JobStatus..::..Total Property
JobStatus Class See Also Send Feedback

Namespace: Sitecore.Jobs
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long Total { get; set; }
Visual Basic
Public Property Total As Long
    Get
    Set
Visual C++
public:
property long long Total {
    long long get ();
    void set (long long value);
}

Field Value

The total.

See Also

JobStatus Class
Sitecore.Jobs Namespace


Sitecore.Jobs.AsyncUI Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Jobs.AsyncUI Namespace
Send Feedback

Classes

 | Class | Description
Public class | AlertMessage | Message to show an alert
Public class | BasePipelineMessage | A base class for a pipeline message
Public class | ConfirmMessage | Confirmation message
Public class | ExecuteMessage | Execute message
Public class | ExecuteMessage..::..PipelineRunner | Pipeline callback
Public class | FlushMessage | Flush message
Public class | InvalidContextException | InvalidContextException class
Public class | JobContext | Task context
Public class | JobMonitor | Controls which is checking the TaskInfo and executing scheduled callbacks
Public class | JobMonitor..::..TaskRunner | Adaptor from ThreadStart to job API
Public class | MessageQueue | Message queue
Public class | SendMessageMessage | SendMessage Message
Public class | ShowModalDialogMessage | Show modal dialog message
Public class | SyncBoolean | A wrapper for AutoResetEvent class to use as a boolean

Interfaces

 | Interface | Description
Public interface | IMessage | Defines basic methods for a message

Delegates

 | Delegate | Description
Public delegate | Callback | Callback
Public delegate | PipelineCallback | Pipeline callback


AlertMessage Class

[image]

Sitecore 6.4.1 API
AlertMessage Class
Members See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class AlertMessage : IMessage
Visual Basic
<SerializableAttribute> _
Public Class AlertMessage _
    Implements IMessage
Visual C++
[SerializableAttribute]
public ref class AlertMessage : IMessage

Inheritance Hierarchy

System..::..Object
Sitecore.Jobs.AsyncUI..::..AlertMessage

See Also

AlertMessage Members
Sitecore.Jobs.AsyncUI Namespace


AlertMessage Members

[image] [image]

Sitecore 6.4.1 API
AlertMessage Members
AlertMessage Class Constructors Methods See Also Send Feedback

The AlertMessage type exposes the following members.

Constructors

 | Name | Description
Public method | AlertMessage | Initializes a new instance of the AlertMessage class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Shows an alert message.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AlertMessage Class
Sitecore.Jobs.AsyncUI Namespace


AlertMessage Constructor

[image]

Sitecore 6.4.1 API
AlertMessage Constructor
AlertMessage Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AlertMessage(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
AlertMessage(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

AlertMessage Class
Sitecore.Jobs.AsyncUI Namespace


AlertMessage Methods

[image] [image]

Sitecore 6.4.1 API
AlertMessage Methods
AlertMessage Class See Also Send Feedback

The AlertMessage type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Shows an alert message.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AlertMessage Class
Sitecore.Jobs.AsyncUI Namespace


Execute Method

[image]

Sitecore 6.4.1 API
AlertMessage..::..Execute Method
AlertMessage Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Execute()
Visual Basic
Public Sub Execute
Visual C++
public:
virtual void Execute() sealed

Implements

IMessage..::..Execute()()()()

See Also

AlertMessage Class
Sitecore.Jobs.AsyncUI Namespace


BasePipelineMessage Members

[image] [image]

Sitecore 6.4.1 API
BasePipelineMessage Members
BasePipelineMessage Class Constructors Methods See Also Send Feedback

The BasePipelineMessage type exposes the following members.

Constructors

 | Name | Description
Protected method | BasePipelineMessage | Initializes a new instance of the BasePipelineMessage class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Starts the pipeline.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Pipeline | Entry point for a pipeline.
Protected method | ShowUI | Abstract method to show the UI.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BasePipelineMessage Class
Sitecore.Jobs.AsyncUI Namespace


BasePipelineMessage Constructor

[image]

Sitecore 6.4.1 API
BasePipelineMessage Constructor
BasePipelineMessage Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected BasePipelineMessage()
Visual Basic
Protected Sub New
Visual C++
protected:
BasePipelineMessage()

See Also

BasePipelineMessage Class
Sitecore.Jobs.AsyncUI Namespace


BasePipelineMessage Methods

[image] [image]

Sitecore 6.4.1 API
BasePipelineMessage Methods
BasePipelineMessage Class See Also Send Feedback

The BasePipelineMessage type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Starts the pipeline.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Pipeline | Entry point for a pipeline.
Protected method | ShowUI | Abstract method to show the UI.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BasePipelineMessage Class
Sitecore.Jobs.AsyncUI Namespace


Execute Method

[image]

Sitecore 6.4.1 API
BasePipelineMessage..::..Execute Method
BasePipelineMessage Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Execute()
Visual Basic
Public Sub Execute
Visual C++
public:
virtual void Execute() sealed

Implements

IMessage..::..Execute()()()()

See Also

BasePipelineMessage Class
Sitecore.Jobs.AsyncUI Namespace


Pipeline Method

[image]

Sitecore 6.4.1 API
BasePipelineMessage..::..Pipeline Method
BasePipelineMessage Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Pipeline(
    ClientPipelineArgs args
)
Visual Basic
Public Sub Pipeline ( _
    args As ClientPipelineArgs _
)
Visual C++
public:
void Pipeline(
    ClientPipelineArgs^ args
)

Parameters

args
Type: Sitecore.Web.UI.Sheer..::..ClientPipelineArgs
The arguments.

See Also

BasePipelineMessage Class
Sitecore.Jobs.AsyncUI Namespace


ShowUI Method

[image]

Sitecore 6.4.1 API
BasePipelineMessage..::..ShowUI Method
BasePipelineMessage Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected abstract void ShowUI()
Visual Basic
Protected MustOverride Sub ShowUI
Visual C++
protected:
virtual void ShowUI() abstract

See Also

BasePipelineMessage Class
Sitecore.Jobs.AsyncUI Namespace


Callback Delegate

[image]

Sitecore 6.4.1 API
Callback Delegate
See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public delegate Object Callback()
Visual Basic
Public Delegate Function Callback As Object
Visual C++
public delegate Object^ Callback()

See Also

Sitecore.Jobs.AsyncUI Namespace


ConfirmMessage Class

[image]

Sitecore 6.4.1 API
ConfirmMessage Class
Members See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class ConfirmMessage : BasePipelineMessage
Visual Basic
<SerializableAttribute> _
Public Class ConfirmMessage _
    Inherits BasePipelineMessage
Visual C++
[SerializableAttribute]
public ref class ConfirmMessage : public BasePipelineMessage

Inheritance Hierarchy

System..::..Object
Sitecore.Jobs.AsyncUI..::..BasePipelineMessage
Sitecore.Jobs.AsyncUI..::..ConfirmMessage

See Also

ConfirmMessage Members
Sitecore.Jobs.AsyncUI Namespace


ConfirmMessage Members

[image] [image]

Sitecore 6.4.1 API
ConfirmMessage Members
ConfirmMessage Class Constructors Methods See Also Send Feedback

The ConfirmMessage type exposes the following members.

Constructors

 | Name | Description
Public method | ConfirmMessage | Initializes a new instance of the ConfirmMessage class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Starts the pipeline. (Inherited from BasePipelineMessage.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Pipeline | Entry point for a pipeline. (Inherited from BasePipelineMessage.)
Protected method | ShowUI | Shows a confirmation dialog. (Overrides BasePipelineMessage..::..ShowUI()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConfirmMessage Class
Sitecore.Jobs.AsyncUI Namespace


ConfirmMessage Constructor

[image]

Sitecore 6.4.1 API
ConfirmMessage Constructor
ConfirmMessage Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ConfirmMessage(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
ConfirmMessage(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

ConfirmMessage Class
Sitecore.Jobs.AsyncUI Namespace


ConfirmMessage Methods

[image] [image]

Sitecore 6.4.1 API
ConfirmMessage Methods
ConfirmMessage Class See Also Send Feedback

The ConfirmMessage type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Starts the pipeline. (Inherited from BasePipelineMessage.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Pipeline | Entry point for a pipeline. (Inherited from BasePipelineMessage.)
Protected method | ShowUI | Shows a confirmation dialog. (Overrides BasePipelineMessage..::..ShowUI()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConfirmMessage Class
Sitecore.Jobs.AsyncUI Namespace


ShowUI Method

[image]

Sitecore 6.4.1 API
ConfirmMessage..::..ShowUI Method
ConfirmMessage Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void ShowUI()
Visual Basic
Protected Overrides Sub ShowUI
Visual C++
protected:
virtual void ShowUI() override

See Also

ConfirmMessage Class
Sitecore.Jobs.AsyncUI Namespace


ExecuteMessage Class

[image]

Sitecore 6.4.1 API
ExecuteMessage Class
Members See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ExecuteMessage : IMessage
Visual Basic
Public Class ExecuteMessage _
    Implements IMessage
Visual C++
public ref class ExecuteMessage : IMessage

Inheritance Hierarchy

System..::..Object
Sitecore.Jobs.AsyncUI..::..ExecuteMessage

See Also

ExecuteMessage Members
Sitecore.Jobs.AsyncUI Namespace


ExecuteMessage Members

[image] [image]

Sitecore 6.4.1 API
ExecuteMessage Members
ExecuteMessage Class Constructors Methods See Also Send Feedback

The ExecuteMessage type exposes the following members.

Constructors

 | Name | Description
Public method | ExecuteMessage | Initializes a new instance of the ExecuteMessage class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the callback.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExecuteMessage Class
Sitecore.Jobs.AsyncUI Namespace


ExecuteMessage Constructor

[image]

Sitecore 6.4.1 API
ExecuteMessage Constructor
ExecuteMessage Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ExecuteMessage(
    Delegate callback
)
Visual Basic
Public Sub New ( _
    callback As Delegate _
)
Visual C++
public:
ExecuteMessage(
    Delegate^ callback
)

Parameters

callback
Type: System..::..Delegate
The callback.

See Also

ExecuteMessage Class
Sitecore.Jobs.AsyncUI Namespace


ExecuteMessage Methods

[image] [image]

Sitecore 6.4.1 API
ExecuteMessage Methods
ExecuteMessage Class See Also Send Feedback

The ExecuteMessage type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes the callback.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExecuteMessage Class
Sitecore.Jobs.AsyncUI Namespace


Execute Method

[image]

Sitecore 6.4.1 API
ExecuteMessage..::..Execute Method
ExecuteMessage Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Execute()
Visual Basic
Public Sub Execute
Visual C++
public:
virtual void Execute() sealed

Implements

IMessage..::..Execute()()()()

See Also

ExecuteMessage Class
Sitecore.Jobs.AsyncUI Namespace


ExecuteMessage.PipelineRunner Class

[image]

Sitecore 6.4.1 API
ExecuteMessage..::..PipelineRunner Class
ExecuteMessage Class Members See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class PipelineRunner
Visual Basic
<SerializableAttribute> _
Public Class PipelineRunner
Visual C++
[SerializableAttribute]
public ref class PipelineRunner

Inheritance Hierarchy

System..::..Object
Sitecore.Jobs.AsyncUI..::..ExecuteMessage..::..PipelineRunner

See Also

ExecuteMessage..::..PipelineRunner Members
Sitecore.Jobs.AsyncUI Namespace


ExecuteMessage.PipelineRunner Members

[image] [image]

Sitecore 6.4.1 API
ExecuteMessage..::..PipelineRunner Members
ExecuteMessage..::..PipelineRunner Class Constructors Methods See Also Send Feedback

Execute message

The ExecuteMessage..::..PipelineRunner type exposes the following members.

Constructors

 | Name | Description
Public method | ExecuteMessage..::..PipelineRunner | Initializes a new instance of the ExecuteMessage..::..PipelineRunner class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Pipeline | Pipeline function.
Public method | Start | Starts this instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExecuteMessage..::..PipelineRunner Class
Sitecore.Jobs.AsyncUI Namespace


ExecuteMessage.PipelineRunner Constructor

[image]

Sitecore 6.4.1 API
ExecuteMessage..::..PipelineRunner Constructor
ExecuteMessage..::..PipelineRunner Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PipelineRunner(
    PipelineCallback callback,
    Handle jobHandle
)
Visual Basic
Public Sub New ( _
    callback As PipelineCallback, _
    jobHandle As Handle _
)
Visual C++
public:
PipelineRunner(
    PipelineCallback^ callback,
    Handle^ jobHandle
)

Parameters

callback
Type: Sitecore.Jobs.AsyncUI..::..PipelineCallback
The callback.
jobHandle
Type: Sitecore..::..Handle
The taskid.

See Also

ExecuteMessage..::..PipelineRunner Class
Sitecore.Jobs.AsyncUI Namespace


ExecuteMessage.PipelineRunner Methods

[image] [image]

Sitecore 6.4.1 API
ExecuteMessage..::..PipelineRunner Methods
ExecuteMessage..::..PipelineRunner Class See Also Send Feedback

The ExecuteMessage..::..PipelineRunner type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Pipeline | Pipeline function.
Public method | Start | Starts this instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExecuteMessage..::..PipelineRunner Class
Sitecore.Jobs.AsyncUI Namespace


Pipeline Method

[image]

Sitecore 6.4.1 API
ExecuteMessage..::..PipelineRunner..::..Pipeline Method
ExecuteMessage..::..PipelineRunner Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Pipeline(
    ClientPipelineArgs args
)
Visual Basic
Public Sub Pipeline ( _
    args As ClientPipelineArgs _
)
Visual C++
public:
void Pipeline(
    ClientPipelineArgs^ args
)

Parameters

args
Type: Sitecore.Web.UI.Sheer..::..ClientPipelineArgs
The arguments.

See Also

ExecuteMessage..::..PipelineRunner Class
Sitecore.Jobs.AsyncUI Namespace


Start Method

[image]

Sitecore 6.4.1 API
ExecuteMessage..::..PipelineRunner..::..Start Method
ExecuteMessage..::..PipelineRunner Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Start()
Visual Basic
Public Sub Start
Visual C++
public:
void Start()

See Also

ExecuteMessage..::..PipelineRunner Class
Sitecore.Jobs.AsyncUI Namespace


FlushMessage Class

[image]

Sitecore 6.4.1 API
FlushMessage Class
Members See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FlushMessage : IMessage
Visual Basic
Public Class FlushMessage _
    Implements IMessage
Visual C++
public ref class FlushMessage : IMessage

Inheritance Hierarchy

System..::..Object
Sitecore.Jobs.AsyncUI..::..FlushMessage

See Also

FlushMessage Members
Sitecore.Jobs.AsyncUI Namespace


FlushMessage Members

[image] [image]

Sitecore 6.4.1 API
FlushMessage Members
FlushMessage Class Constructors Methods See Also Send Feedback

The FlushMessage type exposes the following members.

Constructors

 | Name | Description
Public method | FlushMessage | Initializes a new instance of the FlushMessage class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Put bool(true) value to the result
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlushMessage Class
Sitecore.Jobs.AsyncUI Namespace


FlushMessage Constructor

[image]

Sitecore 6.4.1 API
FlushMessage Constructor
FlushMessage Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FlushMessage()
Visual Basic
Public Sub New
Visual C++
public:
FlushMessage()

See Also

FlushMessage Class
Sitecore.Jobs.AsyncUI Namespace


FlushMessage Methods

[image] [image]

Sitecore 6.4.1 API
FlushMessage Methods
FlushMessage Class See Also Send Feedback

The FlushMessage type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Put bool(true) value to the result
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlushMessage Class
Sitecore.Jobs.AsyncUI Namespace


IMessage Interface

[image]

Sitecore 6.4.1 API
IMessage Interface
Members See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IMessage
Visual Basic
Public Interface IMessage
Visual C++
public interface class IMessage

See Also

IMessage Members
Sitecore.Jobs.AsyncUI Namespace


IMessage Methods

[image] [image]

Sitecore 6.4.1 API
IMessage Methods
IMessage Interface See Also Send Feedback

The IMessage type exposes the following members.

Methods

 | Name | Description
Public method | Execute | Executes message action.

See Also

IMessage Interface
Sitecore.Jobs.AsyncUI Namespace


Execute Method

[image]

Sitecore 6.4.1 API
IMessage..::..Execute Method
IMessage Interface See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void Execute()
Visual Basic
Sub Execute
Visual C++
void Execute()

See Also

IMessage Interface
Sitecore.Jobs.AsyncUI Namespace


InvalidContextException Class

[image]

Sitecore 6.4.1 API
InvalidContextException Class
Members See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class InvalidContextException : InvalidOperationException
Visual Basic
<SerializableAttribute> _
Public Class InvalidContextException _
    Inherits InvalidOperationException
Visual C++
[SerializableAttribute]
public ref class InvalidContextException : public InvalidOperationException

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..SystemException
System..::..InvalidOperationException
Sitecore.Jobs.AsyncUI..::..InvalidContextException

See Also

InvalidContextException Members
Sitecore.Jobs.AsyncUI Namespace


InvalidContextException Members

[image] [image]

Sitecore 6.4.1 API
InvalidContextException Members
InvalidContextException Class Constructors Methods Properties See Also Send Feedback

The InvalidContextException type exposes the following members.

Constructors

 | Name | Description
Public method | InvalidContextException()()()() | Initializes a new instance of the InvalidContextException class.
Public method | InvalidContextException(String) | Initializes a new instance of the InvalidContextException class.
Public method | InvalidContextException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidContextException class.
Public method | InvalidContextException(String, Exception) | Initializes a new instance of the InvalidContextException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidContextException Class
Sitecore.Jobs.AsyncUI Namespace


InvalidContextException Constructor

[image] [image]

Sitecore 6.4.1 API
InvalidContextException Constructor
InvalidContextException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvalidContextException()()()() | Initializes a new instance of the InvalidContextException class.
Public method | InvalidContextException(String) | Initializes a new instance of the InvalidContextException class.
Public method | InvalidContextException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidContextException class.
Public method | InvalidContextException(String, Exception) | Initializes a new instance of the InvalidContextException class.

See Also

InvalidContextException Class
InvalidContextException Members
Sitecore.Jobs.AsyncUI Namespace


InvalidContextException Constructor

[image]

Sitecore 6.4.1 API
InvalidContextException Constructor
InvalidContextException Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public InvalidContextException()
Visual Basic
Public Sub New
Visual C++
public:
InvalidContextException()

See Also

InvalidContextException Class
InvalidContextException Overload
Sitecore.Jobs.AsyncUI Namespace


InvalidContextException Constructor (String)

[image]

Sitecore 6.4.1 API
InvalidContextException Constructor (String)
InvalidContextException Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public InvalidContextException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
InvalidContextException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

InvalidContextException Class
InvalidContextException Overload
Sitecore.Jobs.AsyncUI Namespace


InvalidContextException Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
InvalidContextException Constructor (SerializationInfo, StreamingContext)
InvalidContextException Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public InvalidContextException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
InvalidContextException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The object that holds the serialized object data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The contextual information about the source or destination.

See Also

InvalidContextException Class
InvalidContextException Overload
Sitecore.Jobs.AsyncUI Namespace


InvalidContextException Constructor (String, Exception)

[image]

Sitecore 6.4.1 API
InvalidContextException Constructor (String, Exception)
InvalidContextException Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public InvalidContextException(
    string message,
    Exception inner
)
Visual Basic
Public Sub New ( _
    message As String, _
    inner As Exception _
)
Visual C++
public:
InvalidContextException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::..String
The message.
inner
Type: System..::..Exception
The inner.

See Also

InvalidContextException Class
InvalidContextException Overload
Sitecore.Jobs.AsyncUI Namespace


InvalidContextException Methods

[image] [image]

Sitecore 6.4.1 API
InvalidContextException Methods
InvalidContextException Class See Also Send Feedback

The InvalidContextException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InvalidContextException Class
Sitecore.Jobs.AsyncUI Namespace


InvalidContextException Properties

[image] [image]

Sitecore 6.4.1 API
InvalidContextException Properties
InvalidContextException Class See Also Send Feedback

The InvalidContextException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidContextException Class
Sitecore.Jobs.AsyncUI Namespace


JobContext Class

[image]

Sitecore 6.4.1 API
JobContext Class
Members See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class JobContext
Visual Basic
Public NotInheritable Class JobContext
Visual C++
public ref class JobContext abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Jobs.AsyncUI..::..JobContext

See Also

JobContext Members
Sitecore.Jobs.AsyncUI Namespace


JobContext Members

[image] [image]

Sitecore 6.4.1 API
JobContext Members
JobContext Class Methods Properties See Also Send Feedback

The JobContext type exposes the following members.

Methods

Name | Description
Alert | Shows an alert dialog.
Confirm | Runs a confirm dialog.
Execute(ThreadStart) | Executes the specified callback asynchroniously.
Execute(Callback) | Executes the specified callback.
Execute(PipelineCallback) | Executes the specified pipeline callback.
Flush | Makes sure monitor processes all outstanding messages.
PostMessage(String) | Posts the message to the page without waiting for result.
PostMessage(Message) | Posts the message to the page without waiting fo result.
SendMessage(String) | Sends the message and waits for result.
SendMessage(Message) | Sends the message and waits for result.
ShowModalDialog(String) | Shows the modal dialog.
ShowModalDialog(String, String, String) | Shows the modal dialog.
ShowModalDialog(Hashtable, String, String, String) | Shows the modal dialog.
ShowModalDialog(String, String, String, String) | Shows the modal dialog.

Properties

Name | Description
IsJob | Gets a value indicating whether current thread contains a task.
Job | Gets the job.
JobHandle | Gets the task ID.
MessageQueue | Gets the message queue for the current job.

See Also

JobContext Class
Sitecore.Jobs.AsyncUI Namespace


JobContext Methods

[image] [image]

Sitecore 6.4.1 API
JobContext Methods
JobContext Class See Also Send Feedback

The JobContext type exposes the following members.

Methods

Name | Description
Alert | Shows an alert dialog.
Confirm | Runs a confirm dialog.
Execute(ThreadStart) | Executes the specified callback asynchroniously.
Execute(Callback) | Executes the specified callback.
Execute(PipelineCallback) | Executes the specified pipeline callback.
Flush | Makes sure monitor processes all outstanding messages.
PostMessage(String) | Posts the message to the page without waiting for result.
PostMessage(Message) | Posts the message to the page without waiting fo result.
SendMessage(String) | Sends the message and waits for result.
SendMessage(Message) | Sends the message and waits for result.
ShowModalDialog(String) | Shows the modal dialog.
ShowModalDialog(String, String, String) | Shows the modal dialog.
ShowModalDialog(Hashtable, String, String, String) | Shows the modal dialog.
ShowModalDialog(String, String, String, String) | Shows the modal dialog.

See Also

JobContext Class
Sitecore.Jobs.AsyncUI Namespace


Alert Method

[image]

Sitecore 6.4.1 API
JobContext..::..Alert Method
JobContext Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Alert(
    string message
)
Visual Basic
Public Shared Sub Alert ( _
    message As String _
)
Visual C++
public:
static void Alert(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

JobContext Class
Sitecore.Jobs.AsyncUI Namespace


Confirm Method

[image]

Sitecore 6.4.1 API
JobContext..::..Confirm Method
JobContext Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Confirm(
    string message
)
Visual Basic
Public Shared Function Confirm ( _
    message As String _
) As String
Visual C++
public:
static String^ Confirm(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

Return Value

The confirmation result.

See Also

JobContext Class
Sitecore.Jobs.AsyncUI Namespace


Execute Method (ThreadStart)

[image]

Sitecore 6.4.1 API
JobContext..::..Execute Method (ThreadStart)
JobContext Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Execute(
    ThreadStart callback
)
Visual Basic
Public Shared Sub Execute ( _
    callback As ThreadStart _
)
Visual C++
public:
static void Execute(
    ThreadStart^ callback
)

Parameters

callback
Type: System.Threading..::..ThreadStart
The callback.

Return Value

Callback result.

See Also

JobContext Class
Execute Overload
Sitecore.Jobs.AsyncUI Namespace


Execute Method (Callback)

[image]

Sitecore 6.4.1 API
JobContext..::..Execute Method (Callback)
JobContext Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object Execute(
    Callback callback
)
Visual Basic
Public Shared Function Execute ( _
    callback As Callback _
) As Object
Visual C++
public:
static Object^ Execute(
    Callback^ callback
)

Parameters

callback
Type: Sitecore.Jobs.AsyncUI..::..Callback
The callback.

Return Value

Callback result.

See Also

JobContext Class
Execute Overload
Sitecore.Jobs.AsyncUI Namespace


Execute Method (PipelineCallback)

[image]

Sitecore 6.4.1 API
JobContext..::..Execute Method (PipelineCallback)
JobContext Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object Execute(
    PipelineCallback callback
)
Visual Basic
Public Shared Function Execute ( _
    callback As PipelineCallback _
) As Object
Visual C++
public:
static Object^ Execute(
    PipelineCallback^ callback
)

Parameters

callback
Type: Sitecore.Jobs.AsyncUI..::..PipelineCallback
The callback.

Return Value

Callback result.

See Also

JobContext Class
Execute Overload
Sitecore.Jobs.AsyncUI Namespace


Flush Method

[image]

Sitecore 6.4.1 API
JobContext..::..Flush Method
JobContext Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Flush()
Visual Basic
Public Shared Sub Flush
Visual C++
public:
static void Flush()

See Also

JobContext Class
Sitecore.Jobs.AsyncUI Namespace


PostMessage Method

[image] [image]

Sitecore 6.4.1 API
JobContext..::..PostMessage Method
JobContext Class See Also Send Feedback

Overload List

Name | Description
PostMessage(String) | Posts the message to the page without waiting for result.
PostMessage(Message) | Posts the message to the page without waiting fo result.

See Also

JobContext Class
JobContext Members
Sitecore.Jobs.AsyncUI Namespace


PostMessage Method (String)

[image]

Sitecore 6.4.1 API
JobContext..::..PostMessage Method (String)
JobContext Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void PostMessage(
    string message
)
Visual Basic
Public Shared Sub PostMessage ( _
    message As String _
)
Visual C++
public:
static void PostMessage(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

JobContext Class
PostMessage Overload
Sitecore.Jobs.AsyncUI Namespace


PostMessage Method (Message)

[image]

Sitecore 6.4.1 API
JobContext..::..PostMessage Method (Message)
JobContext Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void PostMessage(
    Message message
)
Visual Basic
Public Shared Sub PostMessage ( _
    message As Message _
)
Visual C++
public:
static void PostMessage(
    Message^ message
)

Parameters

message
Type: Sitecore.Web.UI.Sheer..::..Message
The message.

See Also

JobContext Class
PostMessage Overload
Sitecore.Jobs.AsyncUI Namespace


SendMessage Method

[image] [image]

Sitecore 6.4.1 API
JobContext..::..SendMessage Method
JobContext Class See Also Send Feedback

Overload List

Name | Description
SendMessage(String) | Sends the message and waits for result.
SendMessage(Message) | Sends the message and waits for result.

See Also

JobContext Class
JobContext Members
Sitecore.Jobs.AsyncUI Namespace


SendMessage Method (String)

[image]

Sitecore 6.4.1 API
JobContext..::..SendMessage Method (String)
JobContext Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object SendMessage(
    string message
)
Visual Basic
Public Shared Function SendMessage ( _
    message As String _
) As Object
Visual C++
public:
static Object^ SendMessage(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

Return Value

[Missing <returns> documentation for "M:Sitecore.Jobs.AsyncUI.JobContext.SendMessage(System.String)"]

See Also

JobContext Class
SendMessage Overload
Sitecore.Jobs.AsyncUI Namespace


SendMessage Method (Message)

[image]

Sitecore 6.4.1 API
JobContext..::..SendMessage Method (Message)
JobContext Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object SendMessage(
    Message message
)
Visual Basic
Public Shared Function SendMessage ( _
    message As Message _
) As Object
Visual C++
public:
static Object^ SendMessage(
    Message^ message
)

Parameters

message
Type: Sitecore.Web.UI.Sheer..::..Message
The message.

Return Value

[Missing <returns> documentation for "M:Sitecore.Jobs.AsyncUI.JobContext.SendMessage(Sitecore.Web.UI.Sheer.Message)"]

See Also

JobContext Class
SendMessage Overload
Sitecore.Jobs.AsyncUI Namespace


ShowModalDialog Method

[image] [image]

Sitecore 6.4.1 API
JobContext..::..ShowModalDialog Method
JobContext Class See Also Send Feedback

Overload List

Name | Description
ShowModalDialog(String) | Shows the modal dialog.
ShowModalDialog(String, String, String) | Shows the modal dialog.
ShowModalDialog(Hashtable, String, String, String) | Shows the modal dialog.
ShowModalDialog(String, String, String, String) | Shows the modal dialog.

See Also

JobContext Class
JobContext Members
Sitecore.Jobs.AsyncUI Namespace


ShowModalDialog Method (String)

[image]

Sitecore 6.4.1 API
JobContext..::..ShowModalDialog Method (String)
JobContext Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ShowModalDialog(
    string url
)
Visual Basic
Public Shared Function ShowModalDialog ( _
    url As String _
) As String
Visual C++
public:
static String^ ShowModalDialog(
    String^ url
)

Parameters

url
Type: System..::..String
The URL.

Return Value

Dialog result.

See Also

JobContext Class
ShowModalDialog Overload
Sitecore.Jobs.AsyncUI Namespace


ShowModalDialog Method (String, String, String)

[image]

Sitecore 6.4.1 API
JobContext..::..ShowModalDialog Method (String, String, String)
JobContext Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ShowModalDialog(
    string url,
    string width,
    string height
)
Visual Basic
Public Shared Function ShowModalDialog ( _
    url As String, _
    width As String, _
    height As String _
) As String
Visual C++
public:
static String^ ShowModalDialog(
    String^ url,
    String^ width,
    String^ height
)

Parameters

url
Type: System..::..String
The URL.
width
Type: System..::..String
The width.
height
Type: System..::..String
The height.

Return Value

Dialog result.

See Also

JobContext Class
ShowModalDialog Overload
Sitecore.Jobs.AsyncUI Namespace


ShowModalDialog Method (Hashtable, String, String, String)

[image]

Sitecore 6.4.1 API
JobContext..::..ShowModalDialog Method (Hashtable, String, String, String)
JobContext Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ShowModalDialog(
    Hashtable parameters,
    string controlName,
    string width,
    string height
)
Visual Basic
Public Shared Function ShowModalDialog ( _
    parameters As Hashtable, _
    controlName As String, _
    width As String, _
    height As String _
) As String
Visual C++
public:
static String^ ShowModalDialog(
    Hashtable^ parameters,
    String^ controlName,
    String^ width,
    String^ height
)

Parameters

parameters
Type: System.Collections..::..Hashtable
The parameters.
controlName
Type: System..::..String
Name of the control.
width
Type: System..::..String
The width.
height
Type: System..::..String
The height.

Return Value

Dialog result.

See Also

JobContext Class
ShowModalDialog Overload
Sitecore.Jobs.AsyncUI Namespace


ShowModalDialog Method (String, String, String, String)

[image]

Sitecore 6.4.1 API
JobContext..::..ShowModalDialog Method (String, String, String, String)
JobContext Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ShowModalDialog(
    string title,
    string controlName,
    string width,
    string height
)
Visual Basic
Public Shared Function ShowModalDialog ( _
    title As String, _
    controlName As String, _
    width As String, _
    height As String _
) As String
Visual C++
public:
static String^ ShowModalDialog(
    String^ title,
    String^ controlName,
    String^ width,
    String^ height
)

Parameters

title
Type: System..::..String
The message.
controlName
Type: System..::..String
Name of the control.
width
Type: System..::..String
The width.
height
Type: System..::..String
The height.

Return Value

Dialog result.

See Also

JobContext Class
ShowModalDialog Overload
Sitecore.Jobs.AsyncUI Namespace


JobContext Properties

[image] [image]

Sitecore 6.4.1 API
JobContext Properties
JobContext Class See Also Send Feedback

The JobContext type exposes the following members.

Properties

Name | Description
IsJob | Gets a value indicating whether current thread contains a task.
Job | Gets the job.
JobHandle | Gets the task ID.
MessageQueue | Gets the message queue for the current job.

See Also

JobContext Class
Sitecore.Jobs.AsyncUI Namespace


Job Property

[image]

Sitecore 6.4.1 API
JobContext..::..Job Property
JobContext Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Job Job { get; }
Visual Basic
Public Shared ReadOnly Property Job As Job
    Get
Visual C++
public:
static property Job^ Job {
    Job^ get ();
}

Field Value

The job.

Exceptions

Exception | Condition
Sitecore.Jobs.AsyncUI..::..InvalidContextException | InvalidContextException.

See Also

JobContext Class
Sitecore.Jobs.AsyncUI Namespace


JobHandle Property

[image]

Sitecore 6.4.1 API
JobContext..::..JobHandle Property
JobContext Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Handle JobHandle { get; }
Visual Basic
Public Shared ReadOnly Property JobHandle As Handle
    Get
Visual C++
public:
static property Handle^ JobHandle {
    Handle^ get ();
}

Field Value

The task ID.

See Also

JobContext Class
Sitecore.Jobs.AsyncUI Namespace


MessageQueue Property

[image]

Sitecore 6.4.1 API
JobContext..::..MessageQueue Property
JobContext Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static MessageQueue MessageQueue { get; }
Visual Basic
Public Shared ReadOnly Property MessageQueue As MessageQueue
    Get
Visual C++
public:
static property MessageQueue^ MessageQueue {
    MessageQueue^ get ();
}

Field Value

The message queue.

See Also

JobContext Class
Sitecore.Jobs.AsyncUI Namespace


JobMonitor Class

[image]

Sitecore 6.4.1 API
JobMonitor Class
Members See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class JobMonitor : Control
Visual Basic
Public Class JobMonitor _
    Inherits Control
Visual C++
public ref class JobMonitor : public Control

Inheritance Hierarchy

System..::..Object
System.Web.UI..::..Control
System.Web.UI.WebControls..::..WebControl
Sitecore.Web.UI..::..WebControl
Sitecore.Web.UI.HtmlControls..::..Component
Sitecore.Web.UI.HtmlControls..::..Control
Sitecore.Jobs.AsyncUI..::..JobMonitor

See Also

JobMonitor Members
Sitecore.Jobs.AsyncUI Namespace


JobMonitor Members

[image] [image]

Sitecore 6.4.1 API
JobMonitor Members
JobMonitor Class Constructors Methods Properties Events See Also Send Feedback

The JobMonitor type exposes the following members.

Constructors

 | Name | Description
Public method | JobMonitor | Initializes a new instance of the JobMonitor class

Methods

 | Name | Description
Protected method | AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | AddDebugValue | Adds the debug value. (Inherited from WebControl.)
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Protected method | AddToCache | Adds to cache. (Inherited from WebControl.)
Protected method | AfterRender | Executes afters the control has been rendered. (Inherited from WebControl.)
Public method | ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | AssertLoadOnlyProperty | Asserts the load only property. (Inherited from Component.)
Protected method | BeforeRender | Executes befores the control is rendered. (Inherited from WebControl.)
Protected method | BuildEvents | Builds the events. (Inherited from Control.)
Protected method | BuildFont | Builds the font. (Inherited from Control.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Protected method | CollectDebugInformation | Collects the debug information. (Inherited from WebControl.)
Public method | CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Protected method | CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
Protected method | DoActivate | Executes the activate event. (Inherited from Control.)
Protected method | DoContextmenu | Executes the contextmenu event. (Inherited from Control.)
Protected method | DoDeactivate | Executes the deactivate event. (Inherited from Control.)
Protected method | DoKeydown | Executes the keydown event. (Inherited from Control.)
Protected method | DoRender | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Component.)
Protected method | EmitRenderingInfoScript | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | FormatAttribute | Formats the attribute. (Inherited from Component.)
Protected method | GetAncestorItem | Gets the ancestor item. (Inherited from WebControl.)
Protected method | GetCachedHtml | Gets the cached HTML. (Inherited from WebControl.)
Public method | GetCacheKey | Gets the cache key. (Inherited from WebControl.)
Protected method | GetCachingID | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
Protected method | GetContentItemFromQueryString | Gets the content item from query string. (Inherited from Component.)
Public method | GetContextItem | Gets the context item. (Inherited from WebControl.)
Protected method | GetControlAttributes | Gets the control attributes. (Inherited from Control.)
Public method | GetDatabase | Gets the database to use. (Inherited from WebControl.)
Protected method | GetDataContext | Gets the data context. (Inherited from Control.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Public method | GetDesignTimeHtml | Gets the design time HTML. (Inherited from WebControl.)
Public method | GetExtensibleProperties | Gets the extensible properties. (Inherited from WebControl.)
Public method | GetExtensibleProperty | Gets the extensible property. (Inherited from WebControl.)
Protected method | GetFieldValue | Get field value from current data source. (Inherited from WebControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetID | Gets the ID. (Inherited from Component.)
Protected method | GetItem | Gets the item. (Inherited from WebControl.)
Protected method | GetItemFromQueryString | Gets the item from query string. (Inherited from Component.)
Public method | GetTraceName | Gets the text used when tracing. (Inherited from WebControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
Protected method | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
Protected method | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
Protected method | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
Protected method | GetViewStateProperty | Gets the view state property. (Inherited from Component.)
Protected method | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
Protected method | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
Public method | HandleMessage | Handles the message. (Overrides Control..::..HandleMessage(Message).)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
Protected method | LoadPostData(String) | Loads the post data. (Inherited from Component.)
Public method | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
Protected method | LoadViewState | Restores view-state information from a previous request that was saved with the SaveViewState()()()() method. (Inherited from WebControl.)
Protected method | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
Protected method | MakeEditable(HtmlControl, String, WebControl..::..ContentGetter) | Makes the control editable. (Inherited from WebControl.)
Protected method | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | MoveExtensibleProperties | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
Protected method | OnActionChanged | Called when an action has changed. (Inherited from Control.)
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnDataContextChanged | Called when the data context changed. (Inherited from Control.)
Protected method | OnInit | Raises the Init event. (Inherited from Control.)
Protected method | OnItemAdded | Called when the item has added. (Inherited from Control.)
Protected method | OnItemDeleted | Called when the item has deleted. (Inherited from Control.)
Protected method | OnItemRenamed | Called when the item has renamed. (Inherited from Control.)
Protected method | OnItemSaved | Called when the item has saved. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Control.)
Protected method | OnPreRender | Raises the PreRender event. (Inherited from Control.)
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Public method | RaisePostDataChangedEvent | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
Protected method | RegisterDebugScript | Registers the debug script. (Inherited from WebControl.)
Protected method | RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Protected method | Render | Renders the control to the specified HTML writer. (Inherited from WebControl.)
Public method | RenderAsText | Renders the control as text. (Inherited from WebControl.)
Public method | RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Protected method | RenderContents | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Public method | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Protected method | RenderControlAttributes | Renders the control attributes. (Inherited from Control.)
Public method | RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
Public method | RenderError(String, String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
Protected method | RenderFromCache | Renders the control from cached Html. (Inherited from WebControl.)
Public method | RenderXml | Renders the XML. (Inherited from WebControl.)
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SaveViewState | Saves any state that was modified after the TrackViewState()()()() method was invoked. (Inherited from WebControl.)
Public method | SetControlAttribute | Sets the control attribute. (Inherited from WebControl.)
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetExtensibleProperty | Sets the extensible property. (Inherited from WebControl.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Protected method | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
Protected method | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
Protected method | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
Protected method | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
Protected method | SetViewStateProperty | Sets the view state property. (Inherited from Component.)
Protected method | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
Protected method | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
Protected method | SetWidthAndHeightAttributes | Sets the width and height attributes. (Inherited from Control.)
Protected method | SetWidthAndHeightStyle | Sets the width and height style. (Inherited from Control.)
Protected method | SkipCaching | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
Public method | Start | Starts the specified task.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
Protected method | TransferAttributes | Transfers the attributes to another control. (Inherited from WebControl.)

Properties

 | Name | Description
Public property | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Public property | Action | Gets or sets the action. (Inherited from Control.)
Public property | Activate | Gets or sets the activate message. (Inherited from Control.)
Public property | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
Public property | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
Public property | Background | Gets or sets the background style. (Inherited from Control.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | Border | Gets or sets the border style. (Inherited from WebControl.)
Public property | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
Public property | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
Public property | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
Public property | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
Public property | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
Public property | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
Public property | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
Public property | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | Class | Gets or sets the CSS class name. (Inherited from Control.)
Public property | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
Public property | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
Public property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Protected property | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
Public property | ControlAttributes | Gets the control attributes. (Inherited from Control.)
Public property | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
Public property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
Public property | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
Public property | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
Public property | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
Public property | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
Public property | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
Public property | DataContext | Gets or sets the data context. (Inherited from Control.)
Public property | DataSource | Gets or sets the data source. (Inherited from WebControl.)
Public property | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
Public property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
Public property | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
Public property | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
Public property | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
Public property | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
Public property | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
Public property | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
Public property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
Public property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Public property | Float | Gets or sets the float style property. (Inherited from WebControl.)
Public property | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
Public property | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
Public property | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
Public property | FontName | Gets or sets the name of the font. (Inherited from Control.)
Public property | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the font. (Inherited from Control.)
Public property | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
Public property | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
Public property | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
Public property | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Public property | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
Public property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
Protected property | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Protected property | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Public property | JobHandle | Gets or sets the task.
Public property | KeyDown | Gets or sets the key down. (Inherited from Control.)
Public property | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
Public property | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Public property | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
Public property | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
Public property | Name | Gets or sets the name. (Inherited from Control.)
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Public property | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
Public property | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
Public property | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
Public property | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
Public property | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
Public property | ServerProperties | Gets the server properties. (Inherited from Component.)
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
Public property | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
Public property | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
Public property | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
Public property | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
Protected property | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Protected property | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
Public property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
Public property | Value | Gets or sets the value. (Inherited from Control.)
Public property | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
Public property | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
Public property | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
Public property | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
Public property | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
Public property | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
Public property | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)

Events

 | Name | Description
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | JobDisappeared | Occurs when check message received without current task.
Public event | JobFinished | Occurs when the task is finished.
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | OnActivate | (Inherited from Control.)
Public event | OnContextMenu | (Inherited from Control.)
Public event | OnDeactivate | (Inherited from Control.)
Public event | OnKeyDown | (Inherited from Control.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

See Also

JobMonitor Class
Sitecore.Jobs.AsyncUI Namespace


JobMonitor Constructor

[image]

Sitecore 6.4.1 API
JobMonitor Constructor
JobMonitor Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public JobMonitor()
Visual Basic
Public Sub New
Visual C++
public:
JobMonitor()

See Also

JobMonitor Class
Sitecore.Jobs.AsyncUI Namespace


JobMonitor Methods

[image] [image]

Sitecore 6.4.1 API
JobMonitor Methods
JobMonitor Class See Also Send Feedback

The JobMonitor type exposes the following members.

Methods

 | Name | Description
Protected method | AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | AddDebugValue | Adds the debug value. (Inherited from WebControl.)
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Protected method | AddToCache | Adds to cache. (Inherited from WebControl.)
Protected method | AfterRender | Executes afters the control has been rendered. (Inherited from WebControl.)
Public method | ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | AssertLoadOnlyProperty | Asserts the load only property. (Inherited from Component.)
Protected method | BeforeRender | Executes befores the control is rendered. (Inherited from WebControl.)
Protected method | BuildEvents | Builds the events. (Inherited from Control.)
Protected method | BuildFont | Builds the font. (Inherited from Control.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Protected method | CollectDebugInformation | Collects the debug information. (Inherited from WebControl.)
Public method | CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Protected method | CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
Protected method | DoActivate | Executes the activate event. (Inherited from Control.)
Protected method | DoContextmenu | Executes the contextmenu event. (Inherited from Control.)
Protected method | DoDeactivate | Executes the deactivate event. (Inherited from Control.)
Protected method | DoKeydown | Executes the keydown event. (Inherited from Control.)
Protected method | DoRender | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Component.)
Protected method | EmitRenderingInfoScript | Obsolete. Emits the rendering info script. (Inherited from WebControl.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | FormatAttribute | Formats the attribute. (Inherited from Component.)
Protected method | GetAncestorItem | Gets the ancestor item. (Inherited from WebControl.)
Protected method | GetCachedHtml | Gets the cached HTML. (Inherited from WebControl.)
Public method | GetCacheKey | Gets the cache key. (Inherited from WebControl.)
Protected method | GetCachingID | Get caching identifier. Must be implemented by controls that supports caching. (Inherited from WebControl.)
Protected method | GetContentItemFromQueryString | Gets the content item from query string. (Inherited from Component.)
Public method | GetContextItem | Gets the context item. (Inherited from WebControl.)
Protected method | GetControlAttributes | Gets the control attributes. (Inherited from Control.)
Public method | GetDatabase | Gets the database to use. (Inherited from WebControl.)
Protected method | GetDataContext | Gets the data context. (Inherited from Control.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Public method | GetDesignTimeHtml | Gets the design time HTML. (Inherited from WebControl.)
Public method | GetExtensibleProperties | Gets the extensible properties. (Inherited from WebControl.)
Public method | GetExtensibleProperty | Gets the extensible property. (Inherited from WebControl.)
Protected method | GetFieldValue | Get field value from current data source. (Inherited from WebControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetID | Gets the ID. (Inherited from Component.)
Protected method | GetItem | Gets the item. (Inherited from WebControl.)
Protected method | GetItemFromQueryString | Gets the item from query string. (Inherited from Component.)
Public method | GetTraceName | Gets the text used when tracing. (Inherited from WebControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
Protected method | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)
Protected method | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
Protected method | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)
Protected method | GetViewStateProperty | Gets the view state property. (Inherited from Component.)
Protected method | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
Protected method | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)
Public method | HandleMessage | Handles the message. (Overrides Control..::..HandleMessage(Message).)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
Protected method | LoadPostData(String) | Loads the post data. (Inherited from Component.)
Public method | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)
Protected method | LoadViewState | Restores view-state information from a previous request that was saved with the SaveViewState()()()() method. (Inherited from WebControl.)
Protected method | MakeEditable(HtmlControl, String) | Makes the control editable. (Inherited from WebControl.)
Protected method | MakeEditable(HtmlControl, String, WebControl..::..ContentGetter) | Makes the control editable. (Inherited from WebControl.)
Protected method | MakeEditable(HtmlControl, String, String) | Makes the control editable. (Inherited from WebControl.)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | MoveExtensibleProperties | Moves the extensible properties set on one control to another. (Inherited from WebControl.)
Protected method | OnActionChanged | Called when an action has changed. (Inherited from Control.)
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnDataContextChanged | Called when the data context changed. (Inherited from Control.)
Protected method | OnInit | Raises the Init event. (Inherited from Control.)
Protected method | OnItemAdded | Called when the item has added. (Inherited from Control.)
Protected method | OnItemDeleted | Called when the item has deleted. (Inherited from Control.)
Protected method | OnItemRenamed | Called when the item has renamed. (Inherited from Control.)
Protected method | OnItemSaved | Called when the item has saved. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Control.)
Protected method | OnPreRender | Raises the PreRender event. (Inherited from Control.)
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Public method | RaisePostDataChangedEvent | When implemented by a class, signals the server control to notify the ASP.NET application that the state of the control has changed. (Inherited from Component.)
Protected method | RegisterDebugScript | Registers the debug script. (Inherited from WebControl.)
Protected method | RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Protected method | Render | Renders the control to the specified HTML writer. (Inherited from WebControl.)
Public method | RenderAsText | Renders the control as text. (Inherited from WebControl.)
Public method | RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Protected method | RenderContents | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Public method | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Protected method | RenderControlAttributes | Renders the control attributes. (Inherited from Control.)
Public method | RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
Public method | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
Public method | RenderError(String, String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
Protected method | RenderFromCache | Renders the control from cached Html. (Inherited from WebControl.)
Public method | RenderXml | Renders the XML. (Inherited from WebControl.)
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SaveViewState | Saves any state that was modified after the TrackViewState()()()() method was invoked. (Inherited from WebControl.)
Public method | SetControlAttribute | Sets the control attribute. (Inherited from WebControl.)
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetExtensibleProperty | Sets the extensible property. (Inherited from WebControl.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Protected method | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
Protected method | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)
Protected method | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
Protected method | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)
Protected method | SetViewStateProperty | Sets the view state property. (Inherited from Component.)
Protected method | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
Protected method | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)
Protected method | SetWidthAndHeightAttributes | Sets the width and height attributes. (Inherited from Control.)
Protected method | SetWidthAndHeightStyle | Sets the width and height style. (Inherited from Control.)
Protected method | SkipCaching | Flags control to skip caching based on rendering context. (Inherited from WebControl.)
Public method | Start | Starts the specified task.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
Protected method | TransferAttributes | Transfers the attributes to another control. (Inherited from WebControl.)

See Also

JobMonitor Class
Sitecore.Jobs.AsyncUI Namespace


DataBind Method

[image] [image]

Sitecore 6.4.1 API
JobMonitor..::..DataBind Method
JobMonitor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)

See Also

JobMonitor Class
JobMonitor Members
Sitecore.Jobs.AsyncUI Namespace


FindControl Method

[image] [image]

Sitecore 6.4.1 API
JobMonitor..::..FindControl Method
JobMonitor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)

See Also

JobMonitor Class
JobMonitor Members
Sitecore.Jobs.AsyncUI Namespace


GetViewStateBool Method

[image] [image]

Sitecore 6.4.1 API
JobMonitor..::..GetViewStateBool Method
JobMonitor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetViewStateBool(String) | Gets the view state boolean. (Inherited from Component.)
Protected method | GetViewStateBool(String, Boolean) | Gets the view state boolean. (Inherited from Component.)

See Also

JobMonitor Class
JobMonitor Members
Sitecore.Jobs.AsyncUI Namespace


GetViewStateInt Method

[image] [image]

Sitecore 6.4.1 API
JobMonitor..::..GetViewStateInt Method
JobMonitor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetViewStateInt(String) | Gets the view state integer. (Inherited from Component.)
Protected method | GetViewStateInt(String, Int32) | Gets the view state integer. (Inherited from Component.)

See Also

JobMonitor Class
JobMonitor Members
Sitecore.Jobs.AsyncUI Namespace


GetViewStateString Method

[image] [image]

Sitecore 6.4.1 API
JobMonitor..::..GetViewStateString Method
JobMonitor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetViewStateString(String) | Gets the view state string. (Inherited from Component.)
Protected method | GetViewStateString(String, String) | Gets the view state string. (Inherited from Component.)

See Also

JobMonitor Class
JobMonitor Members
Sitecore.Jobs.AsyncUI Namespace


HandleMessage Method

[image]

Sitecore 6.4.1 API
JobMonitor..::..HandleMessage Method
JobMonitor Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void HandleMessage(
    Message message
)
Visual Basic
Public Overrides Sub HandleMessage ( _
    message As Message _
)
Visual C++
public:
virtual void HandleMessage(
    Message^ message
) override

Parameters

message
Type: Sitecore.Web.UI.Sheer..::..Message
The message.

Implements

IMessageHandler..::..HandleMessage(Message)

See Also

JobMonitor Class
Sitecore.Jobs.AsyncUI Namespace


LoadPostData Method

[image] [image]

Sitecore 6.4.1 API
JobMonitor..::..LoadPostData Method
JobMonitor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | LoadPostData(String) | Loads the post data. (Inherited from Component.)
Public method | LoadPostData(String, NameValueCollection) | When implemented by a class, processes postback data for an ASP.NET server control. (Inherited from Component.)

See Also

JobMonitor Class
JobMonitor Members
Sitecore.Jobs.AsyncUI Namespace


RenderControl Method

[image] [image]

Sitecore 6.4.1 API
JobMonitor..::..RenderControl Method
JobMonitor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Public method | RenderControl(XmlNode) | Renders the control. (Inherited from WebControl.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)

See Also

JobMonitor Class
JobMonitor Members
Sitecore.Jobs.AsyncUI Namespace


RenderError Method

[image] [image]

Sitecore 6.4.1 API
JobMonitor..::..RenderError Method
JobMonitor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RenderError(String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)
Public method | RenderError(String, String, String, HtmlTextWriter) | Renders the error. (Inherited from WebControl.)

See Also

JobMonitor Class
JobMonitor Members
Sitecore.Jobs.AsyncUI Namespace


SetViewStateBool Method

[image] [image]

Sitecore 6.4.1 API
JobMonitor..::..SetViewStateBool Method
JobMonitor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SetViewStateBool(String, Boolean) | Sets the view state boolean. (Inherited from Component.)
Protected method | SetViewStateBool(String, Boolean, Boolean) | Sets the view state boolean. (Inherited from Component.)

See Also

JobMonitor Class
JobMonitor Members
Sitecore.Jobs.AsyncUI Namespace


SetViewStateInt Method

[image] [image]

Sitecore 6.4.1 API
JobMonitor..::..SetViewStateInt Method
JobMonitor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SetViewStateInt(String, Int32) | Sets the view state integer. (Inherited from Component.)
Protected method | SetViewStateInt(String, Int32, Int32) | Sets the view state int. (Inherited from Component.)

See Also

JobMonitor Class
JobMonitor Members
Sitecore.Jobs.AsyncUI Namespace


SetViewStateString Method

[image] [image]

Sitecore 6.4.1 API
JobMonitor..::..SetViewStateString Method
JobMonitor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SetViewStateString(String, String) | Sets the view state string. (Inherited from Component.)
Protected method | SetViewStateString(String, String, String) | Sets the view state string. (Inherited from Component.)

See Also

JobMonitor Class
JobMonitor Members
Sitecore.Jobs.AsyncUI Namespace


Start Method

[image]

Sitecore 6.4.1 API
JobMonitor..::..Start Method
JobMonitor Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Start(
    string name,
    string category,
    ThreadStart task
)
Visual Basic
Public Sub Start ( _
    name As String, _
    category As String, _
    task As ThreadStart _
)
Visual C++
public:
void Start(
    String^ name,
    String^ category,
    ThreadStart^ task
)

Parameters

name
Type: System..::..String
The name.
category
Type: System..::..String
The category.
task
Type: System.Threading..::..ThreadStart
The entry.

See Also

JobMonitor Class
Sitecore.Jobs.AsyncUI Namespace


JobMonitor Properties

[image] [image]

Sitecore 6.4.1 API
JobMonitor Properties
JobMonitor Class See Also Send Feedback

The JobMonitor type exposes the following members.

Properties

 | Name | Description
Public property | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Public property | Action | Gets or sets the action. (Inherited from Control.)
Public property | Activate | Gets or sets the activate message. (Inherited from Control.)
Public property | Activation | Gets or sets a value indicating whether this Control supports activation. (Inherited from Control.)
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
Public property | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
Public property | Background | Gets or sets the background style. (Inherited from Control.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | Border | Gets or sets the border style. (Inherited from WebControl.)
Public property | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
Public property | Bordered | Gets or sets a value indicating whether this WebControl is bordered. (Inherited from WebControl.)
Public property | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
Public property | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
Public property | Cacheable | Gets or sets a value indicating whether this WebControl is cacheable. (Inherited from WebControl.)
Public property | CacheKey | Caching identifier (used in key generation) (Inherited from WebControl.)
Public property | CacheTimeout | Caching identifier (used in key generation) (Inherited from WebControl.)
Public property | CachingID | Caching identifier (used in key generation) (Inherited from WebControl.)
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | Class | Gets or sets the CSS class name. (Inherited from Control.)
Public property | ClassAttribute | Css class attribute for use in tags (Inherited from WebControl.)
Public property | Clear | Gets or sets the clear style property. (Inherited from WebControl.)
Public property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Protected property | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the context menu. (Inherited from Control.)
Public property | ControlAttributes | Gets the control attributes. (Inherited from Control.)
Public property | ControlInfo | Obsolete. Control info (for use in explaindots) (Inherited from WebControl.)
Public property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
Public property | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
Public property | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
Public property | CssStyle | Gets or sets the CSS style. (Inherited from WebControl.)
Public property | Cursor | Gets or sets the cursor style. (Inherited from WebControl.)
Public property | Database | Gets or sets the name of the database to be used for rendering the control. (Inherited from WebControl.)
Public property | DataContext | Gets or sets the data context. (Inherited from Control.)
Public property | DataSource | Gets or sets the data source. (Inherited from WebControl.)
Public property | Deactivate | Gets or sets the deactivate message. (Inherited from Control.)
Public property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from WebControl.)
Public property | Disabled | Gets or sets a value indicating whether this Control is disabled. (Inherited from Control.)
Public property | DisableDebug | Gets or sets a value indicating whether the WebControl disables debugging. (Inherited from WebControl.)
Public property | DisableDots | Gets or sets a value indicating whether the WebControl disables the dots. (Inherited from WebControl.)
Public property | DisableSecurity | Gets or sets a value indicating whether the WebControl disables the security. (Inherited from WebControl.)
Public property | DrawDots | Gets a value indicating whether the WebControl draws the dots. (Inherited from WebControl.)
Public property | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
Public property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
Public property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Public property | Float | Gets or sets the float style property. (Inherited from WebControl.)
Public property | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
Public property | FontBold | Gets or sets a value indicating whether the Control uses bold font. (Inherited from Control.)
Public property | FontItalic | Gets or sets a value indicating whether the Control uses italics font. (Inherited from Control.)
Public property | FontName | Gets or sets the name of the font. (Inherited from Control.)
Public property | FontOverline | Gets or sets a value indicating whether the Control uses overline font. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the font. (Inherited from Control.)
Public property | FontStrikeout | Gets or sets a value indicating whether the Control uses strikeout font. (Inherited from Control.)
Public property | FontUnderline | Gets or sets a value indicating whether the Control uses underline font. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
Public property | Foreground | Gets or sets the foreground color style. (Inherited from WebControl.)
Public property | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Public property | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
Public property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
Protected property | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Protected property | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Public property | JobHandle | Gets or sets the task.
Public property | KeyDown | Gets or sets the key down. (Inherited from Control.)
Public property | KeyFilter | Gets or sets the key filter. (Inherited from Control.)
Public property | LiveDisplay | Gets or sets a value indicating whether the WebControl displays in live mode at design time. (Inherited from WebControl.)
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Public property | LoginRendering | Name or id of rendering/sublayout to show for protected items (when not logged in) (Inherited from WebControl.)
Public property | Margin | Gets or sets the margin style property. (Inherited from WebControl.)
Public property | Name | Gets or sets the name. (Inherited from Control.)
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Public property | Padding | Gets or sets the padding style property. (Inherited from WebControl.)
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | Parameters | Gets or sets the parameters. (Inherited from WebControl.)
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
Public property | RenderAs | Determines how the control is optimized by Sheer UI. (Inherited from WebControl.)
Public property | RenderingID | Gets or sets the rendering ID. (Inherited from WebControl.)
Public property | RenderingName | Gets or sets the name of the rendering. (Inherited from WebControl.)
Public property | RollOver | Gets or sets a value indicating whether the control has a roll over effect. (Inherited from Control.)
Public property | ServerProperties | Gets the server properties. (Inherited from Component.)
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
Public property | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
Public property | StyleAttribute | Gets the style attribute. (Inherited from WebControl.)
Public property | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
Public property | TabStop | Gets or sets a value indicating whether this control is a tab stop. (Inherited from Control.)
Protected property | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
Protected property | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
Public property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
Public property | Value | Gets or sets the value. (Inherited from Control.)
Public property | VaryByData | Gets or sets a value indicating whether the WebControl varies by data. (Inherited from WebControl.)
Public property | VaryByDevice | Gets or sets a value indicating whether the WebControl varies by device. (Inherited from WebControl.)
Public property | VaryByLogin | Gets or sets a value indicating whether the WebControl variess by login. (Inherited from WebControl.)
Public property | VaryByParm | Gets or sets a value indicating whether the WebControl varies by parameters. (Inherited from WebControl.)
Public property | VaryByQueryString | Gets or sets a value indicating whether the WebControl variess by query string. (Inherited from WebControl.)
Public property | VaryByUser | Gets or sets a value indicating whether the WebControl variess by user. (Inherited from WebControl.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
Public property | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)

See Also

JobMonitor Class
Sitecore.Jobs.AsyncUI Namespace


JobHandle Property

[image]

Sitecore 6.4.1 API
JobMonitor..::..JobHandle Property
JobMonitor Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Handle JobHandle { get; set; }
Visual Basic
Public Property JobHandle As Handle
    Get
    Set
Visual C++
public:
property Handle^ JobHandle {
    Handle^ get ();
    void set (Handle^ value);
}

Field Value

The task.

See Also

JobMonitor Class
Sitecore.Jobs.AsyncUI Namespace


JobMonitor Events

[image] [image]

Sitecore 6.4.1 API
JobMonitor Events
JobMonitor Class See Also Send Feedback

The JobMonitor type exposes the following members.

Events

 | Name | Description
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | JobDisappeared | Occurs when check message received without current task.
Public event | JobFinished | Occurs when the task is finished.
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | OnActivate | (Inherited from Control.)
Public event | OnContextMenu | (Inherited from Control.)
Public event | OnDeactivate | (Inherited from Control.)
Public event | OnKeyDown | (Inherited from Control.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

See Also

JobMonitor Class
Sitecore.Jobs.AsyncUI Namespace


JobDisappeared Event

[image]

Sitecore 6.4.1 API
JobMonitor..::..JobDisappeared Event
JobMonitor Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler JobDisappeared
Visual Basic
Public Event JobDisappeared As EventHandler
Visual C++
public:
 event EventHandler^ JobDisappeared {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

JobMonitor Class
Sitecore.Jobs.AsyncUI Namespace


JobFinished Event

[image]

Sitecore 6.4.1 API
JobMonitor..::..JobFinished Event
JobMonitor Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public event EventHandler JobFinished
Visual Basic
Public Event JobFinished As EventHandler
Visual C++
public:
 event EventHandler^ JobFinished {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

JobMonitor Class
Sitecore.Jobs.AsyncUI Namespace


JobMonitor.TaskRunner Class

[image]

Sitecore 6.4.1 API
JobMonitor..::..TaskRunner Class
JobMonitor Class Members See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class TaskRunner
Visual Basic
Public Class TaskRunner
Visual C++
public ref class TaskRunner

Inheritance Hierarchy

System..::..Object
Sitecore.Jobs.AsyncUI..::..JobMonitor..::..TaskRunner

See Also

JobMonitor..::..TaskRunner Members
Sitecore.Jobs.AsyncUI Namespace


JobMonitor.TaskRunner Members

[image] [image]

Sitecore 6.4.1 API
JobMonitor..::..TaskRunner Members
JobMonitor..::..TaskRunner Class Constructors Methods See Also Send Feedback

Controls which is checking the TaskInfo and executing scheduled callbacks

The JobMonitor..::..TaskRunner type exposes the following members.

Constructors

 | Name | Description
Public method | JobMonitor..::..TaskRunner | Initializes a new instance of the JobMonitor..::..TaskRunner class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Run | Runs the task inside the job.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

JobMonitor..::..TaskRunner Class
Sitecore.Jobs.AsyncUI Namespace


JobMonitor.TaskRunner Constructor

[image]

Sitecore 6.4.1 API
JobMonitor..::..TaskRunner Constructor
JobMonitor..::..TaskRunner Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TaskRunner(
    ThreadStart task
)
Visual Basic
Public Sub New ( _
    task As ThreadStart _
)
Visual C++
public:
TaskRunner(
    ThreadStart^ task
)

Parameters

task
Type: System.Threading..::..ThreadStart
The task.

See Also

JobMonitor..::..TaskRunner Class
Sitecore.Jobs.AsyncUI Namespace


JobMonitor.TaskRunner Methods

[image] [image]

Sitecore 6.4.1 API
JobMonitor..::..TaskRunner Methods
JobMonitor..::..TaskRunner Class See Also Send Feedback

The JobMonitor..::..TaskRunner type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Run | Runs the task inside the job.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

JobMonitor..::..TaskRunner Class
Sitecore.Jobs.AsyncUI Namespace


Run Method

[image]

Sitecore 6.4.1 API
JobMonitor..::..TaskRunner..::..Run Method
JobMonitor..::..TaskRunner Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Run()
Visual Basic
Public Sub Run
Visual C++
public:
void Run()

See Also

JobMonitor..::..TaskRunner Class
Sitecore.Jobs.AsyncUI Namespace


MessageQueue Members

[image] [image]

Sitecore 6.4.1 API
MessageQueue Members
MessageQueue Class Constructors Methods See Also Send Feedback

The MessageQueue type exposes the following members.

Constructors

 | Name | Description
Public method | MessageQueue | Initializes a new instance of the MessageQueue class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessage | Gets the message from the queue.
Public method | GetResult | Gets the result.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PutMessage | Puts the message to the queue.
Public method | PutResult | Puts the result to the queue.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MessageQueue Class
Sitecore.Jobs.AsyncUI Namespace


MessageQueue Constructor

[image]

Sitecore 6.4.1 API
MessageQueue Constructor
MessageQueue Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MessageQueue()
Visual Basic
Public Sub New
Visual C++
public:
MessageQueue()

See Also

MessageQueue Class
Sitecore.Jobs.AsyncUI Namespace


MessageQueue Methods

[image] [image]

Sitecore 6.4.1 API
MessageQueue Methods
MessageQueue Class See Also Send Feedback

The MessageQueue type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessage | Gets the message from the queue.
Public method | GetResult | Gets the result.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PutMessage | Puts the message to the queue.
Public method | PutResult | Puts the result to the queue.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MessageQueue Class
Sitecore.Jobs.AsyncUI Namespace


GetMessage Method

[image]

Sitecore 6.4.1 API
MessageQueue..::..GetMessage Method
MessageQueue Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool GetMessage(
    out IMessage message
)
Visual Basic
Public Function GetMessage ( _
    <OutAttribute> ByRef message As IMessage _
) As Boolean
Visual C++
public:
bool GetMessage(
    [OutAttribute] IMessage^% message
)

Parameters

message
Type: Sitecore.Jobs.AsyncUI..::..IMessage %
The message.

Return Value

False if the queue was empty

See Also

MessageQueue Class
Sitecore.Jobs.AsyncUI Namespace


GetResult Method

[image]

Sitecore 6.4.1 API
MessageQueue..::..GetResult Method
MessageQueue Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object GetResult()
Visual Basic
Public Function GetResult As Object
Visual C++
public:
Object^ GetResult()

Return Value

The result.

See Also

MessageQueue Class
Sitecore.Jobs.AsyncUI Namespace


PutMessage Method

[image]

Sitecore 6.4.1 API
MessageQueue..::..PutMessage Method
MessageQueue Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void PutMessage(
    IMessage message
)
Visual Basic
Public Sub PutMessage ( _
    message As IMessage _
)
Visual C++
public:
void PutMessage(
    IMessage^ message
)

Parameters

message
Type: Sitecore.Jobs.AsyncUI..::..IMessage
The message.

See Also

MessageQueue Class
Sitecore.Jobs.AsyncUI Namespace


PutResult Method

[image]

Sitecore 6.4.1 API
MessageQueue..::..PutResult Method
MessageQueue Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void PutResult(
    Object result
)
Visual Basic
Public Sub PutResult ( _
    result As Object _
)
Visual C++
public:
void PutResult(
    Object^ result
)

Parameters

result
Type: System..::..Object
The result.

See Also

MessageQueue Class
Sitecore.Jobs.AsyncUI Namespace


PipelineCallback Delegate

[image]

Sitecore 6.4.1 API
PipelineCallback Delegate
See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public delegate Object PipelineCallback(
    ClientPipelineArgs args
)
Visual Basic
Public Delegate Function PipelineCallback ( _
    args As ClientPipelineArgs _
) As Object
Visual C++
public delegate Object^ PipelineCallback(
    ClientPipelineArgs^ args
)

Parameters

args
Type: Sitecore.Web.UI.Sheer..::..ClientPipelineArgs

See Also

Sitecore.Jobs.AsyncUI Namespace


SendMessageMessage Class

[image]

Sitecore 6.4.1 API
SendMessageMessage Class
Members See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SendMessageMessage : IMessage
Visual Basic
Public Class SendMessageMessage _
    Implements IMessage
Visual C++
public ref class SendMessageMessage : IMessage

Inheritance Hierarchy

System..::..Object
Sitecore.Jobs.AsyncUI..::..SendMessageMessage

See Also

SendMessageMessage Members
Sitecore.Jobs.AsyncUI Namespace


SendMessageMessage Members

[image] [image]

Sitecore 6.4.1 API
SendMessageMessage Members
SendMessageMessage Class Constructors Methods See Also Send Feedback

The SendMessageMessage type exposes the following members.

Constructors

 | Name | Description
Public method | SendMessageMessage(String, Boolean) | Initializes a new instance of the SendMessageMessage class.
Public method | SendMessageMessage(Message, Boolean) | Initializes a new instance of the SendMessageMessage class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Sends a message.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SendMessageMessage Class
Sitecore.Jobs.AsyncUI Namespace


SendMessageMessage Constructor

[image] [image]

Sitecore 6.4.1 API
SendMessageMessage Constructor
SendMessageMessage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SendMessageMessage(String, Boolean) | Initializes a new instance of the SendMessageMessage class.
Public method | SendMessageMessage(Message, Boolean) | Initializes a new instance of the SendMessageMessage class.

See Also

SendMessageMessage Class
SendMessageMessage Members
Sitecore.Jobs.AsyncUI Namespace


SendMessageMessage Constructor (String, Boolean)

[image]

Sitecore 6.4.1 API
SendMessageMessage Constructor (String, Boolean)
SendMessageMessage Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SendMessageMessage(
    string message,
    bool postBack
)
Visual Basic
Public Sub New ( _
    message As String, _
    postBack As Boolean _
)
Visual C++
public:
SendMessageMessage(
    String^ message,
    bool postBack
)

Parameters

message
Type: System..::..String
The message.
postBack
Type: System..::..Boolean
if set to true the result should be put to the queue.

See Also

SendMessageMessage Class
SendMessageMessage Overload
Sitecore.Jobs.AsyncUI Namespace


SendMessageMessage Methods

[image] [image]

Sitecore 6.4.1 API
SendMessageMessage Methods
SendMessageMessage Class See Also Send Feedback

The SendMessageMessage type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Sends a message.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SendMessageMessage Class
Sitecore.Jobs.AsyncUI Namespace


Execute Method

[image]

Sitecore 6.4.1 API
SendMessageMessage..::..Execute Method
SendMessageMessage Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Execute()
Visual Basic
Public Sub Execute
Visual C++
public:
virtual void Execute() sealed

Implements

IMessage..::..Execute()()()()

See Also

SendMessageMessage Class
Sitecore.Jobs.AsyncUI Namespace


ShowModalDialogMessage Class

[image]

Sitecore 6.4.1 API
ShowModalDialogMessage Class
Members See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class ShowModalDialogMessage : BasePipelineMessage
Visual Basic
<SerializableAttribute> _
Public Class ShowModalDialogMessage _
    Inherits BasePipelineMessage
Visual C++
[SerializableAttribute]
public ref class ShowModalDialogMessage : public BasePipelineMessage

Inheritance Hierarchy

System..::..Object
Sitecore.Jobs.AsyncUI..::..BasePipelineMessage
Sitecore.Jobs.AsyncUI..::..ShowModalDialogMessage

See Also

ShowModalDialogMessage Members
Sitecore.Jobs.AsyncUI Namespace


ShowModalDialogMessage Members

[image] [image]

Sitecore 6.4.1 API
ShowModalDialogMessage Members
ShowModalDialogMessage Class Constructors Methods See Also Send Feedback

The ShowModalDialogMessage type exposes the following members.

Constructors

 | Name | Description
Public method | ShowModalDialogMessage(String) | Initializes a new instance of the ShowModalDialogMessage class.
Public method | ShowModalDialogMessage(String, String, String) | Initializes a new instance of the ShowModalDialogMessage class.
Public method | ShowModalDialogMessage(String, String, String, String) | Initializes a new instance of the ShowModalDialogMessage class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Starts the pipeline. (Inherited from BasePipelineMessage.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Pipeline | Entry point for a pipeline. (Inherited from BasePipelineMessage.)
Protected method | ShowUI | Shows the dialog. (Overrides BasePipelineMessage..::..ShowUI()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShowModalDialogMessage Class
Sitecore.Jobs.AsyncUI Namespace


ShowModalDialogMessage Constructor

[image] [image]

Sitecore 6.4.1 API
ShowModalDialogMessage Constructor
ShowModalDialogMessage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ShowModalDialogMessage(String) | Initializes a new instance of the ShowModalDialogMessage class.
Public method | ShowModalDialogMessage(String, String, String) | Initializes a new instance of the ShowModalDialogMessage class.
Public method | ShowModalDialogMessage(String, String, String, String) | Initializes a new instance of the ShowModalDialogMessage class.

See Also

ShowModalDialogMessage Class
ShowModalDialogMessage Members
Sitecore.Jobs.AsyncUI Namespace


ShowModalDialogMessage Constructor (String)

[image]

Sitecore 6.4.1 API
ShowModalDialogMessage Constructor (String)
ShowModalDialogMessage Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ShowModalDialogMessage(
    string url
)
Visual Basic
Public Sub New ( _
    url As String _
)
Visual C++
public:
ShowModalDialogMessage(
    String^ url
)

Parameters

url
Type: System..::..String
The URL.

See Also

ShowModalDialogMessage Class
ShowModalDialogMessage Overload
Sitecore.Jobs.AsyncUI Namespace


ShowModalDialogMessage Constructor (String, String, String)

[image]

Sitecore 6.4.1 API
ShowModalDialogMessage Constructor (String, String, String)
ShowModalDialogMessage Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ShowModalDialogMessage(
    string url,
    string width,
    string height
)
Visual Basic
Public Sub New ( _
    url As String, _
    width As String, _
    height As String _
)
Visual C++
public:
ShowModalDialogMessage(
    String^ url,
    String^ width,
    String^ height
)

Parameters

url
Type: System..::..String
The URL.
width
Type: System..::..String
The width.
height
Type: System..::..String
The height.

See Also

ShowModalDialogMessage Class
ShowModalDialogMessage Overload
Sitecore.Jobs.AsyncUI Namespace


ShowModalDialogMessage Constructor (String, String, String, String)

[image]

Sitecore 6.4.1 API
ShowModalDialogMessage Constructor (String, String, String, String)
ShowModalDialogMessage Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ShowModalDialogMessage(
    string url,
    string width,
    string height,
    string message
)
Visual Basic
Public Sub New ( _
    url As String, _
    width As String, _
    height As String, _
    message As String _
)
Visual C++
public:
ShowModalDialogMessage(
    String^ url,
    String^ width,
    String^ height,
    String^ message
)

Parameters

url
Type: System..::..String
The URL.
width
Type: System..::..String
The width.
height
Type: System..::..String
The height.
message
Type: System..::..String
The message.

See Also

ShowModalDialogMessage Class
ShowModalDialogMessage Overload
Sitecore.Jobs.AsyncUI Namespace


ShowModalDialogMessage Methods

[image] [image]

Sitecore 6.4.1 API
ShowModalDialogMessage Methods
ShowModalDialogMessage Class See Also Send Feedback

The ShowModalDialogMessage type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Starts the pipeline. (Inherited from BasePipelineMessage.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Pipeline | Entry point for a pipeline. (Inherited from BasePipelineMessage.)
Protected method | ShowUI | Shows the dialog. (Overrides BasePipelineMessage..::..ShowUI()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShowModalDialogMessage Class
Sitecore.Jobs.AsyncUI Namespace


ShowUI Method

[image]

Sitecore 6.4.1 API
ShowModalDialogMessage..::..ShowUI Method
ShowModalDialogMessage Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void ShowUI()
Visual Basic
Protected Overrides Sub ShowUI
Visual C++
protected:
virtual void ShowUI() override

See Also

ShowModalDialogMessage Class
Sitecore.Jobs.AsyncUI Namespace


SyncBoolean Class

[image]

Sitecore 6.4.1 API
SyncBoolean Class
Members See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SyncBoolean
Visual Basic
Public Class SyncBoolean
Visual C++
public ref class SyncBoolean

Inheritance Hierarchy

System..::..Object
Sitecore.Jobs.AsyncUI..::..SyncBoolean

See Also

SyncBoolean Members
Sitecore.Jobs.AsyncUI Namespace


SyncBoolean Members

[image] [image]

Sitecore 6.4.1 API
SyncBoolean Members
SyncBoolean Class Constructors Methods Properties See Also Send Feedback

The SyncBoolean type exposes the following members.

Constructors

 | Name | Description
Public method | SyncBoolean()()()() | Initializes a new instance of the SyncBoolean class.
Public method | SyncBoolean(Boolean) | Initializes a new instance of the SyncBoolean class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WaitFor | Waits for when this instance will have specifyed value

Properties

 | Name | Description
Public property | Timeout | Gets or sets the timeout.
Public property | Value | Gets or sets a value of this instance.

See Also

SyncBoolean Class
Sitecore.Jobs.AsyncUI Namespace


SyncBoolean Constructor

[image] [image]

Sitecore 6.4.1 API
SyncBoolean Constructor
SyncBoolean Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SyncBoolean()()()() | Initializes a new instance of the SyncBoolean class.
Public method | SyncBoolean(Boolean) | Initializes a new instance of the SyncBoolean class.

See Also

SyncBoolean Class
SyncBoolean Members
Sitecore.Jobs.AsyncUI Namespace


SyncBoolean Constructor

[image]

Sitecore 6.4.1 API
SyncBoolean Constructor
SyncBoolean Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SyncBoolean()
Visual Basic
Public Sub New
Visual C++
public:
SyncBoolean()

See Also

SyncBoolean Class
SyncBoolean Overload
Sitecore.Jobs.AsyncUI Namespace


SyncBoolean Constructor (Boolean)

[image]

Sitecore 6.4.1 API
SyncBoolean Constructor (Boolean)
SyncBoolean Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SyncBoolean(
    bool initialValue
)
Visual Basic
Public Sub New ( _
    initialValue As Boolean _
)
Visual C++
public:
SyncBoolean(
    bool initialValue
)

Parameters

initialValue
Type: System..::..Boolean
if set to true this instance is initial value.

See Also

SyncBoolean Class
SyncBoolean Overload
Sitecore.Jobs.AsyncUI Namespace


SyncBoolean Methods

[image] [image]

Sitecore 6.4.1 API
SyncBoolean Methods
SyncBoolean Class See Also Send Feedback

The SyncBoolean type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WaitFor | Waits for when this instance will have specifyed value

See Also

SyncBoolean Class
Sitecore.Jobs.AsyncUI Namespace


WaitFor Method

[image]

Sitecore 6.4.1 API
SyncBoolean..::..WaitFor Method
SyncBoolean Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void WaitFor(
    bool value
)
Visual Basic
Public Sub WaitFor ( _
    value As Boolean _
)
Visual C++
public:
void WaitFor(
    bool value
)

Parameters

value
Type: System..::..Boolean
if set to true this instance is value.

See Also

SyncBoolean Class
Sitecore.Jobs.AsyncUI Namespace


SyncBoolean Properties

[image] [image]

Sitecore 6.4.1 API
SyncBoolean Properties
SyncBoolean Class See Also Send Feedback

The SyncBoolean type exposes the following members.

Properties

 | Name | Description
Public property | Timeout | Gets or sets the timeout.
Public property | Value | Gets or sets a value of this instance.

See Also

SyncBoolean Class
Sitecore.Jobs.AsyncUI Namespace


Timeout Property

[image]

Sitecore 6.4.1 API
SyncBoolean..::..Timeout Property
SyncBoolean Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TimeSpan Timeout { get; set; }
Visual Basic
Public Property Timeout As TimeSpan
    Get
    Set
Visual C++
public:
property TimeSpan Timeout {
    TimeSpan get ();
    void set (TimeSpan value);
}

Field Value

The timeout.

See Also

SyncBoolean Class
Sitecore.Jobs.AsyncUI Namespace


Value Property

[image]

Sitecore 6.4.1 API
SyncBoolean..::..Value Property
SyncBoolean Class See Also Send Feedback

Namespace: Sitecore.Jobs.AsyncUI
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Value { get; set; }
Visual Basic
Public Property Value As Boolean
    Get
    Set
Visual C++
public:
property bool Value {
    bool get ();
    void set (bool value);
}

Field Value

Boolean value

See Also

SyncBoolean Class
Sitecore.Jobs.AsyncUI Namespace


Sitecore.Layouts Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Layouts Namespace
Send Feedback

Classes

 | Class | Description
Public class | CachedXmlUrlResolver |
Public class | ControlFactory | Creates controls for layouts.
Public class | Converter | Converts HTML from runtime to designtime and back.
Public class | DesignTimeHtml | Converts HTML from runtime to designtime and back.
Public class | DesignTimeHtml..::..ControlOptions | Rendering node parameters
Public class | DeviceDefinition | Represents a device.
Public class | HtmlParts | Represents html document parsed into header / body / footer.
Public class | LayoutDefinition | Represents a layout.
Public class | PageContext | Nested type: Expander
Public class | PlaceholderDefinition | Represents a placeholder.
Public class | RenderingCaching | Represents caching information for a rendering.
Public class | RenderingDefinition | Represents a rendering.
Public class | RenderingReference | Represents a reference to a rendering.
Public class | RenderingReferenceList | Represents a list of rendering references
Public class | RenderingSettings | Represents a set of rendering settings.
Public class | RuntimeHtml | Converts HTML from runtime to designtime and back.
Public class | XHtml | Defines the XHTML helper class.
Public class | XHtmlValidator |
Public class | XHtmlValidatorError |

Interfaces

 | Interface | Description
Public interface | IExpandable |


CachedXmlUrlResolver Class

[image]

Sitecore 6.4.1 API
CachedXmlUrlResolver Class
Members See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CachedXmlUrlResolver : XmlUrlResolver
Visual Basic
Public Class CachedXmlUrlResolver _
    Inherits XmlUrlResolver
Visual C++
public ref class CachedXmlUrlResolver : public XmlUrlResolver

Inheritance Hierarchy

System..::..Object
System.Xml..::..XmlResolver
System.Xml..::..XmlUrlResolver
Sitecore.Layouts..::..CachedXmlUrlResolver

See Also

CachedXmlUrlResolver Members
Sitecore.Layouts Namespace


CachedXmlUrlResolver Members

[image] [image]

Sitecore 6.4.1 API
CachedXmlUrlResolver Members
CachedXmlUrlResolver Class Constructors Methods Properties See Also Send Feedback

The CachedXmlUrlResolver type exposes the following members.

Constructors

 | Name | Description
Public method | CachedXmlUrlResolver | Initializes a new instance of the CachedXmlUrlResolver class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEntity | Maps a URI to an object containing the actual resource. (Overrides XmlUrlResolver..::..GetEntity(Uri, String, Type).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResolveUri | Resolves the absolute URI from the base and relative URIs. (Inherited from XmlUrlResolver.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Credentials | Sets credentials used to authenticate Web requests. (Inherited from XmlUrlResolver.)

See Also

CachedXmlUrlResolver Class
Sitecore.Layouts Namespace


CachedXmlUrlResolver Constructor

[image]

Sitecore 6.4.1 API
CachedXmlUrlResolver Constructor
CachedXmlUrlResolver Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CachedXmlUrlResolver()
Visual Basic
Public Sub New
Visual C++
public:
CachedXmlUrlResolver()

See Also

CachedXmlUrlResolver Class
Sitecore.Layouts Namespace


CachedXmlUrlResolver Methods

[image] [image]

Sitecore 6.4.1 API
CachedXmlUrlResolver Methods
CachedXmlUrlResolver Class See Also Send Feedback

The CachedXmlUrlResolver type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEntity | Maps a URI to an object containing the actual resource. (Overrides XmlUrlResolver..::..GetEntity(Uri, String, Type).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResolveUri | Resolves the absolute URI from the base and relative URIs. (Inherited from XmlUrlResolver.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CachedXmlUrlResolver Class
Sitecore.Layouts Namespace


GetEntity Method

[image]

Sitecore 6.4.1 API
CachedXmlUrlResolver..::..GetEntity Method
CachedXmlUrlResolver Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Object GetEntity(
    Uri absoluteUri,
    string role,
    Type ofObjectToReturn
)
Visual Basic
Public Overrides Function GetEntity ( _
    absoluteUri As Uri, _
    role As String, _
    ofObjectToReturn As Type _
) As Object
Visual C++
public:
virtual Object^ GetEntity(
    Uri^ absoluteUri,
    String^ role,
    Type^ ofObjectToReturn
) override

Parameters

absoluteUri
Type: System..::..Uri
The URI returned from ResolveUri(Uri, String)
role
Type: System..::..String
The current implementation does not use this parameter when resolving URIs. This is provided for future extensibility purposes. For example, this can be mapped to the xlink:role and used as an implementation specific argument in other scenarios.
ofObjectToReturn
Type: System..::..Type
The type of object to return. The current implementation only returns System.IO.Stream objects.

Return Value

A System.IO.Stream object or null if a type other than stream is specified.

Exceptions

Exception | Condition
System.Xml..::..XmlException | ofObjectToReturn is neither null nor a Stream type.
System..::..UriFormatException | The specified URI is not an absolute URI.
System..::..NullReferenceException | absoluteUri is null.
System..::..Exception | There is a runtime error (for example, an interrupted server connection).

See Also

CachedXmlUrlResolver Class
Sitecore.Layouts Namespace


CachedXmlUrlResolver Properties

[image] [image]

Sitecore 6.4.1 API
CachedXmlUrlResolver Properties
CachedXmlUrlResolver Class See Also Send Feedback

The CachedXmlUrlResolver type exposes the following members.

Properties

 | Name | Description
Public property | Credentials | Sets credentials used to authenticate Web requests. (Inherited from XmlUrlResolver.)

See Also

CachedXmlUrlResolver Class
Sitecore.Layouts Namespace


ControlFactory Class

[image]

Sitecore 6.4.1 API
ControlFactory Class
Members See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class ControlFactory
Visual Basic
Public NotInheritable Class ControlFactory
Visual C++
public ref class ControlFactory abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Layouts..::..ControlFactory

See Also

ControlFactory Members
Sitecore.Layouts Namespace


ControlFactory Members

[image] [image]

Sitecore 6.4.1 API
ControlFactory Members
ControlFactory Class Methods See Also Send Feedback

The ControlFactory type exposes the following members.

Methods

Name | Description
GetLoginControl | Gets the login control.
GetRenderingControl | Gets the rendering control.

See Also

ControlFactory Class
Sitecore.Layouts Namespace


ControlFactory Methods

[image] [image]

Sitecore 6.4.1 API
ControlFactory Methods
ControlFactory Class See Also Send Feedback

The ControlFactory type exposes the following members.

Methods

Name | Description
GetLoginControl | Gets the login control.
GetRenderingControl | Gets the rendering control.

See Also

ControlFactory Class
Sitecore.Layouts Namespace


GetLoginControl Method

[image]

Sitecore 6.4.1 API
ControlFactory..::..GetLoginControl Method
ControlFactory Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Control GetLoginControl(
    WebControl control,
    bool assert
)
Visual Basic
Public Shared Function GetLoginControl ( _
    control As WebControl, _
    assert As Boolean _
) As Control
Visual C++
public:
static Control^ GetLoginControl(
    WebControl^ control,
    bool assert
)

Parameters

control
Type: Sitecore.Web.UI..::..WebControl
The control.
assert
Type: System..::..Boolean
if set to true this instance is assert.

Return Value

[Missing <returns> documentation for "M:Sitecore.Layouts.ControlFactory.GetLoginControl(Sitecore.Web.UI.WebControl,System.Boolean)"]

See Also

ControlFactory Class
Sitecore.Layouts Namespace


GetRenderingControl Method

[image]

Sitecore 6.4.1 API
ControlFactory..::..GetRenderingControl Method
ControlFactory Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Control GetRenderingControl(
    string renderingPath,
    bool assert
)
Visual Basic
Public Shared Function GetRenderingControl ( _
    renderingPath As String, _
    assert As Boolean _
) As Control
Visual C++
public:
static Control^ GetRenderingControl(
    String^ renderingPath,
    bool assert
)

Parameters

renderingPath
Type: System..::..String
The rendering path.
assert
Type: System..::..Boolean
if set to true this instance is assert.

Return Value

[Missing <returns> documentation for "M:Sitecore.Layouts.ControlFactory.GetRenderingControl(System.String,System.Boolean)"]

See Also

ControlFactory Class
Sitecore.Layouts Namespace


Converter Class

[image]

Sitecore 6.4.1 API
Converter Class
Members See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Converter
Visual Basic
Public NotInheritable Class Converter
Visual C++
public ref class Converter abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Layouts..::..Converter

See Also

Converter Members
Sitecore.Layouts Namespace


Converter Methods

[image] [image]

Sitecore 6.4.1 API
Converter Methods
Converter Class See Also Send Feedback

The Converter type exposes the following members.

Methods

Name | Description
Convert | Obsolete. Converts to XHtml.
ConvertToDesignTime(String, String) | Obsolete. Converts to design time.
ConvertToDesignTime(String, String, NameValueCollection) | Obsolete. Converts to design time.
ConvertToDesignTime(String, String, NameValueCollection, Boolean) | Obsolete. Converts to design time.
ConvertToRuntime | Obsolete. Converts to runtime.
ConvertToXml | Obsolete. Converts to XML.
FixBullets | Obsolete. Fixes the bullets.
GetLayoutObject(HtmlDocument, String, String, String, String, String, String, NameValueCollection) | Obsolete. Gets the layout object.
GetLayoutObject(HtmlDocument, String, String, String, String, String, String, NameValueCollection, Boolean) | Obsolete. Gets the layout object.
Parse | Obsolete. Parses the specified HTML.

See Also

Converter Class
Sitecore.Layouts Namespace


ConvertToDesignTime Method

[image] [image]

Sitecore 6.4.1 API
Converter..::..ConvertToDesignTime Method
Converter Class See Also Send Feedback

Overload List

Name | Description
ConvertToDesignTime(String, String) | Obsolete. Converts to design time.
ConvertToDesignTime(String, String, NameValueCollection) | Obsolete. Converts to design time.
ConvertToDesignTime(String, String, NameValueCollection, Boolean) | Obsolete. Converts to design time.

See Also

Converter Class
Converter Members
Sitecore.Layouts Namespace


ConvertToDesignTime Method (String, String, NameValueCollection)

[image]

Sitecore 6.4.1 API
Converter..::..ConvertToDesignTime Method (String, String, NameValueCollection)
Converter Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use DesignTimeHtml.Convert instead.")]
public static string ConvertToDesignTime(
    string body,
    string controlName,
    NameValueCollection querystring
)
Visual Basic
<ObsoleteAttribute("Deprecated - Use DesignTimeHtml.Convert instead.")> _
Public Shared Function ConvertToDesignTime ( _
    body As String, _
    controlName As String, _
    querystring As NameValueCollection _
) As String
Visual C++
[ObsoleteAttribute(L"Deprecated - Use DesignTimeHtml.Convert instead.")]
public:
static String^ ConvertToDesignTime(
    String^ body,
    String^ controlName,
    NameValueCollection^ querystring
)

Parameters

body
Type: System..::..String
The body.
controlName
Type: System..::..String
Name of the control.
querystring
Type: System.Collections.Specialized..::..NameValueCollection
The querystring.

Return Value

The to design time Html.

See Also

Converter Class
ConvertToDesignTime Overload
Sitecore.Layouts Namespace


ConvertToDesignTime Method (String, String, NameValueCollection, Boolean)

[image]

Sitecore 6.4.1 API
Converter..::..ConvertToDesignTime Method (String, String, NameValueCollection, Boolean)
Converter Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use DesignTimeHtml.Convert instead.")]
public static string ConvertToDesignTime(
    string body,
    string controlName,
    NameValueCollection querystring,
    bool inlineControls
)
Visual Basic
<ObsoleteAttribute("Deprecated - Use DesignTimeHtml.Convert instead.")> _
Public Shared Function ConvertToDesignTime ( _
    body As String, _
    controlName As String, _
    querystring As NameValueCollection, _
    inlineControls As Boolean _
) As String
Visual C++
[ObsoleteAttribute(L"Deprecated - Use DesignTimeHtml.Convert instead.")]
public:
static String^ ConvertToDesignTime(
    String^ body,
    String^ controlName,
    NameValueCollection^ querystring,
    bool inlineControls
)

Parameters

body
Type: System..::..String
The body.
controlName
Type: System..::..String
Name of the control.
querystring
Type: System.Collections.Specialized..::..NameValueCollection
The querystring.
inlineControls
Type: System..::..Boolean
if set to true this instance generates inline controls.

Return Value

The to design time Html.

See Also

Converter Class
ConvertToDesignTime Overload
Sitecore.Layouts Namespace


ConvertToRuntime Method

[image]

Sitecore 6.4.1 API
Converter..::..ConvertToRuntime Method
Converter Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use RuntimeHtml.Convert instead.")]
public static string ConvertToRuntime(
    string body
)
Visual Basic
<ObsoleteAttribute("Deprecated - Use RuntimeHtml.Convert instead.")> _
Public Shared Function ConvertToRuntime ( _
    body As String _
) As String
Visual C++
[ObsoleteAttribute(L"Deprecated - Use RuntimeHtml.Convert instead.")]
public:
static String^ ConvertToRuntime(
    String^ body
)

Parameters

body
Type: System..::..String
The body.

Return Value

[Missing <returns> documentation for "M:Sitecore.Layouts.Converter.ConvertToRuntime(System.String)"]

See Also

Converter Class
Sitecore.Layouts Namespace


ConvertToXml Method

[image]

Sitecore 6.4.1 API
Converter..::..ConvertToXml Method
Converter Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use XHtml.ConvertToXml instead.")]
public static string ConvertToXml(
    string body
)
Visual Basic
<ObsoleteAttribute("Deprecated - Use XHtml.ConvertToXml instead.")> _
Public Shared Function ConvertToXml ( _
    body As String _
) As String
Visual C++
[ObsoleteAttribute(L"Deprecated - Use XHtml.ConvertToXml instead.")]
public:
static String^ ConvertToXml(
    String^ body
)

Parameters

body
Type: System..::..String
The body.

Return Value

[Missing <returns> documentation for "M:Sitecore.Layouts.Converter.ConvertToXml(System.String)"]

See Also

Converter Class
Sitecore.Layouts Namespace


FixBullets Method

[image]

Sitecore 6.4.1 API
Converter..::..FixBullets Method
Converter Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use RuntimeHtml.FixBullets instead.")]
public static void FixBullets(
    HtmlDocument document
)
Visual Basic
<ObsoleteAttribute("Deprecated - Use RuntimeHtml.FixBullets instead.")> _
Public Shared Sub FixBullets ( _
    document As HtmlDocument _
)
Visual C++
[ObsoleteAttribute(L"Deprecated - Use RuntimeHtml.FixBullets instead.")]
public:
static void FixBullets(
    HtmlDocument^ document
)

Parameters

document
Type: HtmlDocument
The document.

See Also

Converter Class
Sitecore.Layouts Namespace


GetLayoutObject Method

[image] [image]

Sitecore 6.4.1 API
Converter..::..GetLayoutObject Method
Converter Class See Also Send Feedback

Overload List

Name | Description
GetLayoutObject(HtmlDocument, String, String, String, String, String, String, NameValueCollection) | Obsolete. Gets the layout object.
GetLayoutObject(HtmlDocument, String, String, String, String, String, String, NameValueCollection, Boolean) | Obsolete. Gets the layout object.

See Also

Converter Class
Converter Members
Sitecore.Layouts Namespace


GetLayoutObject Method (, String, String, String, String, String, String, NameValueCollection)

[image]

Sitecore 6.4.1 API
Converter..::..GetLayoutObject Method (, String, String, String, String, String, String, NameValueCollection)
Converter Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use DesignTimeHtml.GetRenderingNode instead.")]
public static HtmlNode GetLayoutObject(
    HtmlDocument document,
    string id,
    string tagPrefix,
    string tagName,
    string parameters,
    string renderingID,
    string controlName,
    NameValueCollection querystring
)
Visual Basic
<ObsoleteAttribute("Deprecated - Use DesignTimeHtml.GetRenderingNode instead.")> _
Public Shared Function GetLayoutObject ( _
    document As HtmlDocument, _
    id As String, _
    tagPrefix As String, _
    tagName As String, _
    parameters As String, _
    renderingID As String, _
    controlName As String, _
    querystring As NameValueCollection _
) As HtmlNode
Visual C++
[ObsoleteAttribute(L"Deprecated - Use DesignTimeHtml.GetRenderingNode instead.")]
public:
static HtmlNode^ GetLayoutObject(
    HtmlDocument^ document,
    String^ id,
    String^ tagPrefix,
    String^ tagName,
    String^ parameters,
    String^ renderingID,
    String^ controlName,
    NameValueCollection^ querystring
)

Parameters

document
Type: HtmlDocument
The document.
id
Type: System..::..String
The id.
tagPrefix
Type: System..::..String
The tag prefix.
tagName
Type: System..::..String
Name of the tag.
parameters
Type: System..::..String
The parameters.
renderingID
Type: System..::..String
The rendering ID.
controlName
Type: System..::..String
Name of the control.
querystring
Type: System.Collections.Specialized..::..NameValueCollection
The querystring.

Return Value

The layout object.

See Also

Converter Class
GetLayoutObject Overload
Sitecore.Layouts Namespace


GetLayoutObject Method (, String, String, String, String, String, String, NameValueCollection, Boolean)

[image]

Sitecore 6.4.1 API
Converter..::..GetLayoutObject Method (, String, String, String, String, String, String, NameValueCollection, Boolean)
Converter Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use DesignTimeHtml.GetRenderingNode instead.")]
public static HtmlNode GetLayoutObject(
    HtmlDocument document,
    string id,
    string tagPrefix,
    string tagName,
    string parameters,
    string renderingID,
    string controlName,
    NameValueCollection querystring,
    bool inlineControls
)
Visual Basic
<ObsoleteAttribute("Deprecated - Use DesignTimeHtml.GetRenderingNode instead.")> _
Public Shared Function GetLayoutObject ( _
    document As HtmlDocument, _
    id As String, _
    tagPrefix As String, _
    tagName As String, _
    parameters As String, _
    renderingID As String, _
    controlName As String, _
    querystring As NameValueCollection, _
    inlineControls As Boolean _
) As HtmlNode
Visual C++
[ObsoleteAttribute(L"Deprecated - Use DesignTimeHtml.GetRenderingNode instead.")]
public:
static HtmlNode^ GetLayoutObject(
    HtmlDocument^ document,
    String^ id,
    String^ tagPrefix,
    String^ tagName,
    String^ parameters,
    String^ renderingID,
    String^ controlName,
    NameValueCollection^ querystring,
    bool inlineControls
)

Parameters

document
Type: HtmlDocument
The document.
id
Type: System..::..String
The id.
tagPrefix
Type: System..::..String
The tag prefix.
tagName
Type: System..::..String
Name of the tag.
parameters
Type: System..::..String
The parameters.
renderingID
Type: System..::..String
The rendering ID.
controlName
Type: System..::..String
Name of the control.
querystring
Type: System.Collections.Specialized..::..NameValueCollection
The querystring.
inlineControls
Type: System..::..Boolean
if set to true this instance is inline controls.

Return Value

The layout object.

See Also

Converter Class
GetLayoutObject Overload
Sitecore.Layouts Namespace


Parse Method

[image]

Sitecore 6.4.1 API
Converter..::..Parse Method
Converter Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use RuntimeHtml.Parse instead.")]
public static void Parse(
    string html,
    out string header,
    out string body,
    out string footer
)
Visual Basic
<ObsoleteAttribute("Deprecated - Use RuntimeHtml.Parse instead.")> _
Public Shared Sub Parse ( _
    html As String, _
    <OutAttribute> ByRef header As String, _
    <OutAttribute> ByRef body As String, _
    <OutAttribute> ByRef footer As String _
)
Visual C++
[ObsoleteAttribute(L"Deprecated - Use RuntimeHtml.Parse instead.")]
public:
static void Parse(
    String^ html,
    [OutAttribute] String^% header,
    [OutAttribute] String^% body,
    [OutAttribute] String^% footer
)

Parameters

html
Type: System..::..String
The HTML.
header
Type: System..::..String %
The header.
body
Type: System..::..String %
The body.
footer
Type: System..::..String %
The footer.

See Also

Converter Class
Sitecore.Layouts Namespace


DesignTimeHtml Class

[image]

Sitecore 6.4.1 API
DesignTimeHtml Class
Members See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class DesignTimeHtml
Visual Basic
Public NotInheritable Class DesignTimeHtml
Visual C++
public ref class DesignTimeHtml abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Layouts..::..DesignTimeHtml

See Also

DesignTimeHtml Members
Sitecore.Layouts Namespace


DesignTimeHtml Members

[image] [image]

Sitecore 6.4.1 API
DesignTimeHtml Members
DesignTimeHtml Class Methods See Also Send Feedback

The DesignTimeHtml type exposes the following members.

Methods

Name | Description
Convert(String, String) | Obsolete. Converts to design time.
Convert(String, String, NameValueCollection) | Converts to design time.
Convert(String, String, NameValueCollection, Boolean) | Converts to design time.
FixBullets | Fixes the bullets.
FixSelectOptions | Fixes the select options.
GetRenderingNode(HtmlDocument, DesignTimeHtml..::..ControlOptions) | Gets the layout object.
GetRenderingNode(HtmlDocument, RenderingItem, String, String%) | Gets the rendering node.

See Also

DesignTimeHtml Class
Sitecore.Layouts Namespace


DesignTimeHtml Methods

[image] [image]

Sitecore 6.4.1 API
DesignTimeHtml Methods
DesignTimeHtml Class See Also Send Feedback

The DesignTimeHtml type exposes the following members.

Methods

Name | Description
Convert(String, String) | Obsolete. Converts to design time.
Convert(String, String, NameValueCollection) | Converts to design time.
Convert(String, String, NameValueCollection, Boolean) | Converts to design time.
FixBullets | Fixes the bullets.
FixSelectOptions | Fixes the select options.
GetRenderingNode(HtmlDocument, DesignTimeHtml..::..ControlOptions) | Gets the layout object.
GetRenderingNode(HtmlDocument, RenderingItem, String, String%) | Gets the rendering node.

See Also

DesignTimeHtml Class
Sitecore.Layouts Namespace


Convert Method

[image] [image]

Sitecore 6.4.1 API
DesignTimeHtml..::..Convert Method
DesignTimeHtml Class See Also Send Feedback

Overload List

Name | Description
Convert(String, String) | Obsolete. Converts to design time.
Convert(String, String, NameValueCollection) | Converts to design time.
Convert(String, String, NameValueCollection, Boolean) | Converts to design time.

See Also

DesignTimeHtml Class
DesignTimeHtml Members
Sitecore.Layouts Namespace


Convert Method (String, String)

[image]

Sitecore 6.4.1 API
DesignTimeHtml..::..Convert Method (String, String)
DesignTimeHtml Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use Convert(string, string, NameValueCollection) instead.")]
public static string Convert(
    string body,
    string controlName
)
Visual Basic
<ObsoleteAttribute("Deprecated - Use Convert(string, string, NameValueCollection) instead.")> _
Public Shared Function Convert ( _
    body As String, _
    controlName As String _
) As String
Visual C++
[ObsoleteAttribute(L"Deprecated - Use Convert(string, string, NameValueCollection) instead.")]
public:
static String^ Convert(
    String^ body,
    String^ controlName
)

Parameters

body
Type: System..::..String
The body.
controlName
Type: System..::..String
Name of the control.

Return Value

The design time html.

See Also

DesignTimeHtml Class
Convert Overload
Sitecore.Layouts Namespace


Convert Method (String, String, NameValueCollection)

[image]

Sitecore 6.4.1 API
DesignTimeHtml..::..Convert Method (String, String, NameValueCollection)
DesignTimeHtml Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Convert(
    string body,
    string controlName,
    NameValueCollection querystring
)
Visual Basic
Public Shared Function Convert ( _
    body As String, _
    controlName As String, _
    querystring As NameValueCollection _
) As String
Visual C++
public:
static String^ Convert(
    String^ body,
    String^ controlName,
    NameValueCollection^ querystring
)

Parameters

body
Type: System..::..String
The body.
controlName
Type: System..::..String
Name of the control.
querystring
Type: System.Collections.Specialized..::..NameValueCollection
The querystring.

Return Value

The to design time Html.

See Also

DesignTimeHtml Class
Convert Overload
Sitecore.Layouts Namespace


Convert Method (String, String, NameValueCollection, Boolean)

[image]

Sitecore 6.4.1 API
DesignTimeHtml..::..Convert Method (String, String, NameValueCollection, Boolean)
DesignTimeHtml Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Convert(
    string body,
    string controlName,
    NameValueCollection querystring,
    bool inlineControls
)
Visual Basic
Public Shared Function Convert ( _
    body As String, _
    controlName As String, _
    querystring As NameValueCollection, _
    inlineControls As Boolean _
) As String
Visual C++
public:
static String^ Convert(
    String^ body,
    String^ controlName,
    NameValueCollection^ querystring,
    bool inlineControls
)

Parameters

body
Type: System..::..String
The body.
controlName
Type: System..::..String
Name of the control.
querystring
Type: System.Collections.Specialized..::..NameValueCollection
The querystring.
inlineControls
Type: System..::..Boolean
if set to true this instance generates inline controls.

Return Value

The to design time Html.

See Also

DesignTimeHtml Class
Convert Overload
Sitecore.Layouts Namespace


FixBullets Method

[image]

Sitecore 6.4.1 API
DesignTimeHtml..::..FixBullets Method
DesignTimeHtml Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void FixBullets(
    HtmlDocument document
)
Visual Basic
Public Shared Sub FixBullets ( _
    document As HtmlDocument _
)
Visual C++
public:
static void FixBullets(
    HtmlDocument^ document
)

Parameters

document
Type: HtmlDocument
The document.

See Also

DesignTimeHtml Class
Sitecore.Layouts Namespace


GetRenderingNode Method (, DesignTimeHtml.ControlOptions)

[image]

Sitecore 6.4.1 API
DesignTimeHtml..::..GetRenderingNode Method (, DesignTimeHtml..::..ControlOptions)
DesignTimeHtml Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static HtmlNode GetRenderingNode(
    HtmlDocument document,
    DesignTimeHtml..::..ControlOptions options
)
Visual Basic
Public Shared Function GetRenderingNode ( _
    document As HtmlDocument, _
    options As DesignTimeHtml..::..ControlOptions _
) As HtmlNode
Visual C++
public:
static HtmlNode^ GetRenderingNode(
    HtmlDocument^ document,
    DesignTimeHtml..::..ControlOptions^ options
)

Parameters

document
Type: HtmlDocument
The document.
options
Type: Sitecore.Layouts..::..DesignTimeHtml..::..ControlOptions
The rendering node params.

Return Value

The layout object.

See Also

DesignTimeHtml Class
GetRenderingNode Overload
Sitecore.Layouts Namespace


DesignTimeHtml.ControlOptions Class

[image]

Sitecore 6.4.1 API
DesignTimeHtml..::..ControlOptions Class
DesignTimeHtml Class Members See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ControlOptions
Visual Basic
Public Class ControlOptions
Visual C++
public ref class ControlOptions

Inheritance Hierarchy

System..::..Object
Sitecore.Layouts..::..DesignTimeHtml..::..ControlOptions

See Also

DesignTimeHtml..::..ControlOptions Members
Sitecore.Layouts Namespace


DesignTimeHtml.ControlOptions Members

[image] [image]

Sitecore 6.4.1 API
DesignTimeHtml..::..ControlOptions Members
DesignTimeHtml..::..ControlOptions Class Constructors Methods Properties See Also Send Feedback

Converts HTML from runtime to designtime and back.

The DesignTimeHtml..::..ControlOptions type exposes the following members.

Constructors

 | Name | Description
Public method | DesignTimeHtml..::..ControlOptions | Initializes a new instance of the DesignTimeHtml..::..ControlOptions class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ControlName | Gets or sets the name of the control.
Public property | ID | Gets or sets the ID.
Public property | InlineControls | Gets or sets a value indicating whether the DesignTimeHtml..::..ControlOptions inlines the controls.
Public property | Parameters | Gets or sets the parameters.
Public property | Querystring | Gets the querystring.
Public property | RenderingID | Gets or sets the rendering ID.
Public property | TagName | Gets or sets the name of the tag.
Public property | TagPrefix | Gets or sets the tag prefix.
Public property | Tooltip | Gets or sets the tooltip.

See Also

DesignTimeHtml..::..ControlOptions Class
Sitecore.Layouts Namespace


DesignTimeHtml.ControlOptions Constructor

[image]

Sitecore 6.4.1 API
DesignTimeHtml..::..ControlOptions Constructor
DesignTimeHtml..::..ControlOptions Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ControlOptions()
Visual Basic
Public Sub New
Visual C++
public:
ControlOptions()

See Also

DesignTimeHtml..::..ControlOptions Class
Sitecore.Layouts Namespace


DesignTimeHtml.ControlOptions Methods

[image] [image]

Sitecore 6.4.1 API
DesignTimeHtml..::..ControlOptions Methods
DesignTimeHtml..::..ControlOptions Class See Also Send Feedback

The DesignTimeHtml..::..ControlOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DesignTimeHtml..::..ControlOptions Class
Sitecore.Layouts Namespace


DesignTimeHtml.ControlOptions Properties

[image] [image]

Sitecore 6.4.1 API
DesignTimeHtml..::..ControlOptions Properties
DesignTimeHtml..::..ControlOptions Class See Also Send Feedback

The DesignTimeHtml..::..ControlOptions type exposes the following members.

Properties

 | Name | Description
Public property | ControlName | Gets or sets the name of the control.
Public property | ID | Gets or sets the ID.
Public property | InlineControls | Gets or sets a value indicating whether the DesignTimeHtml..::..ControlOptions inlines the controls.
Public property | Parameters | Gets or sets the parameters.
Public property | Querystring | Gets the querystring.
Public property | RenderingID | Gets or sets the rendering ID.
Public property | TagName | Gets or sets the name of the tag.
Public property | TagPrefix | Gets or sets the tag prefix.
Public property | Tooltip | Gets or sets the tooltip.

See Also

DesignTimeHtml..::..ControlOptions Class
Sitecore.Layouts Namespace


ControlName Property

[image]

Sitecore 6.4.1 API
DesignTimeHtml..::..ControlOptions..::..ControlName Property
DesignTimeHtml..::..ControlOptions Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ControlName { get; set; }
Visual Basic
Public Property ControlName As String
    Get
    Set
Visual C++
public:
property String^ ControlName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the control.

See Also

DesignTimeHtml..::..ControlOptions Class
Sitecore.Layouts Namespace


ID Property

[image]

Sitecore 6.4.1 API
DesignTimeHtml..::..ControlOptions..::..ID Property
DesignTimeHtml..::..ControlOptions Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ID { get; set; }
Visual Basic
Public Property ID As String
    Get
    Set
Visual C++
public:
property String^ ID {
    String^ get ();
    void set (String^ value);
}

Field Value

The ID.

See Also

DesignTimeHtml..::..ControlOptions Class
Sitecore.Layouts Namespace


InlineControls Property

[image]

Sitecore 6.4.1 API
DesignTimeHtml..::..ControlOptions..::..InlineControls Property
DesignTimeHtml..::..ControlOptions Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool InlineControls { get; set; }
Visual Basic
Public Property InlineControls As Boolean
    Get
    Set
Visual C++
public:
property bool InlineControls {
    bool get ();
    void set (bool value);
}

Field Value

true if the DesignTimeHtml..::..ControlOptions inlines the controls; otherwise, false.

See Also

DesignTimeHtml..::..ControlOptions Class
Sitecore.Layouts Namespace


Parameters Property

[image]

Sitecore 6.4.1 API
DesignTimeHtml..::..ControlOptions..::..Parameters Property
DesignTimeHtml..::..ControlOptions Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Parameters { get; set; }
Visual Basic
Public Property Parameters As String
    Get
    Set
Visual C++
public:
property String^ Parameters {
    String^ get ();
    void set (String^ value);
}

Field Value

The parameters.

See Also

DesignTimeHtml..::..ControlOptions Class
Sitecore.Layouts Namespace


Querystring Property

[image]

Sitecore 6.4.1 API
DesignTimeHtml..::..ControlOptions..::..Querystring Property
DesignTimeHtml..::..ControlOptions Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public NameValueCollection Querystring { get; set; }
Visual Basic
Public Property Querystring As NameValueCollection
    Get
    Set
Visual C++
public:
property NameValueCollection^ Querystring {
    NameValueCollection^ get ();
    void set (NameValueCollection^ value);
}

Field Value

The querystring.

See Also

DesignTimeHtml..::..ControlOptions Class
Sitecore.Layouts Namespace


RenderingID Property

[image]

Sitecore 6.4.1 API
DesignTimeHtml..::..ControlOptions..::..RenderingID Property
DesignTimeHtml..::..ControlOptions Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string RenderingID { get; set; }
Visual Basic
Public Property RenderingID As String
    Get
    Set
Visual C++
public:
property String^ RenderingID {
    String^ get ();
    void set (String^ value);
}

Field Value

The rendering ID.

See Also

DesignTimeHtml..::..ControlOptions Class
Sitecore.Layouts Namespace


TagName Property

[image]

Sitecore 6.4.1 API
DesignTimeHtml..::..ControlOptions..::..TagName Property
DesignTimeHtml..::..ControlOptions Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string TagName { get; set; }
Visual Basic
Public Property TagName As String
    Get
    Set
Visual C++
public:
property String^ TagName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the tag.

See Also

DesignTimeHtml..::..ControlOptions Class
Sitecore.Layouts Namespace


TagPrefix Property

[image]

Sitecore 6.4.1 API
DesignTimeHtml..::..ControlOptions..::..TagPrefix Property
DesignTimeHtml..::..ControlOptions Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string TagPrefix { get; set; }
Visual Basic
Public Property TagPrefix As String
    Get
    Set
Visual C++
public:
property String^ TagPrefix {
    String^ get ();
    void set (String^ value);
}

Field Value

The tag prefix.

See Also

DesignTimeHtml..::..ControlOptions Class
Sitecore.Layouts Namespace


Tooltip Property

[image]

Sitecore 6.4.1 API
DesignTimeHtml..::..ControlOptions..::..Tooltip Property
DesignTimeHtml..::..ControlOptions Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Tooltip { get; set; }
Visual Basic
Public Property Tooltip As String
    Get
    Set
Visual C++
public:
property String^ Tooltip {
    String^ get ();
    void set (String^ value);
}

Field Value

The tooltip.

See Also

DesignTimeHtml..::..ControlOptions Class
Sitecore.Layouts Namespace


DeviceDefinition Class

[image]

Sitecore 6.4.1 API
DeviceDefinition Class
Members See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DeviceDefinition : XmlSerializable
Visual Basic
Public Class DeviceDefinition _
    Inherits XmlSerializable
Visual C++
public ref class DeviceDefinition : public XmlSerializable

Inheritance Hierarchy

System..::..Object
Sitecore.Xml.Serialization..::..XmlSerializable
Sitecore.Layouts..::..DeviceDefinition

See Also

DeviceDefinition Members
Sitecore.Layouts Namespace


DeviceDefinition Constructor

[image]

Sitecore 6.4.1 API
DeviceDefinition Constructor
DeviceDefinition Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DeviceDefinition()
Visual Basic
Public Sub New
Visual C++
public:
DeviceDefinition()

See Also

DeviceDefinition Class
Sitecore.Layouts Namespace


DeviceDefinition Methods

[image] [image]

Sitecore 6.4.1 API
DeviceDefinition Methods
DeviceDefinition Class See Also Send Feedback

The DeviceDefinition type exposes the following members.

Methods

 | Name | Description
Public method | AddPlaceholder | Adds the placeholder.
Public method | AddRendering | Adds the rendering.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | Gets the index.
Public method | GetPlaceholder | Gets the placeholder.
Public method | GetRendering | Gets the rendering.
Public method | GetRenderingByUniqueId | Gets the rendering by unique id.
Public method | GetRenderings | Gets all renderings with a specific id.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Inserts the specified index.
Public method | LoadXml(String) | Creates an object represenation of the string xml given as parameter. (Inherited from XmlSerializable.)
Public method | LoadXml(String, String) | Creates a object representation of the xml transformed using the xslt style sheed whos path is given as argument. (Inherited from XmlSerializable.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveRendering | Obsolete. Removes the rendering.
Public method | SaveAsXml | Saves this object representated as xml to a file. (Inherited from XmlSerializable.)
Public method | SortRenderingNext | Obsolete. Sorts the rendering next.
Public method | SortRenderingPrior | Obsolete. Sorts the rendering prior.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToXml()()()() | Creates a string xml representation of this object. Note that cycles are not allowed. (Inherited from XmlSerializable.)
Public method | ToXml(String) | Creates a xml string representation, and transforms that xml using the xslt file given at the location of the path given as parameter. (Inherited from XmlSerializable.)

See Also

DeviceDefinition Class
Sitecore.Layouts Namespace


AddPlaceholder Method

[image]

Sitecore 6.4.1 API
DeviceDefinition..::..AddPlaceholder Method
DeviceDefinition Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddPlaceholder(
    PlaceholderDefinition placeholderDefinition
)
Visual Basic
Public Sub AddPlaceholder ( _
    placeholderDefinition As PlaceholderDefinition _
)
Visual C++
public:
void AddPlaceholder(
    PlaceholderDefinition^ placeholderDefinition
)

Parameters

placeholderDefinition
Type: Sitecore.Layouts..::..PlaceholderDefinition
The placeholder definition.

See Also

DeviceDefinition Class
Sitecore.Layouts Namespace


AddRendering Method

[image]

Sitecore 6.4.1 API
DeviceDefinition..::..AddRendering Method
DeviceDefinition Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddRendering(
    RenderingDefinition renderingDefinition
)
Visual Basic
Public Sub AddRendering ( _
    renderingDefinition As RenderingDefinition _
)
Visual C++
public:
void AddRendering(
    RenderingDefinition^ renderingDefinition
)

Parameters

renderingDefinition
Type: Sitecore.Layouts..::..RenderingDefinition
The rendering definition.

See Also

DeviceDefinition Class
Sitecore.Layouts Namespace


GetIndex Method

[image]

Sitecore 6.4.1 API
DeviceDefinition..::..GetIndex Method
DeviceDefinition Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int GetIndex(
    string uniqueId
)
Visual Basic
Public Function GetIndex ( _
    uniqueId As String _
) As Integer
Visual C++
public:
int GetIndex(
    String^ uniqueId
)

Parameters

uniqueId
Type: System..::..String
The unique id.

Return Value

The index.

See Also

DeviceDefinition Class
Sitecore.Layouts Namespace


GetPlaceholder Method

[image]

Sitecore 6.4.1 API
DeviceDefinition..::..GetPlaceholder Method
DeviceDefinition Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PlaceholderDefinition GetPlaceholder(
    string uniqueID
)
Visual Basic
Public Function GetPlaceholder ( _
    uniqueID As String _
) As PlaceholderDefinition
Visual C++
public:
PlaceholderDefinition^ GetPlaceholder(
    String^ uniqueID
)

Parameters

uniqueID
Type: System..::..String
The unique ID.

Return Value

The placeholder.

See Also

DeviceDefinition Class
Sitecore.Layouts Namespace


GetRendering Method

[image]

Sitecore 6.4.1 API
DeviceDefinition..::..GetRendering Method
DeviceDefinition Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderingDefinition GetRendering(
    string renderingItemId
)
Visual Basic
Public Function GetRendering ( _
    renderingItemId As String _
) As RenderingDefinition
Visual C++
public:
RenderingDefinition^ GetRendering(
    String^ renderingItemId
)

Parameters

renderingItemId
Type: System..::..String
The rendering item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Layouts.DeviceDefinition.GetRendering(System.String)"]

See Also

DeviceDefinition Class
Sitecore.Layouts Namespace


GetRenderingByUniqueId Method

[image]

Sitecore 6.4.1 API
DeviceDefinition..::..GetRenderingByUniqueId Method
DeviceDefinition Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderingDefinition GetRenderingByUniqueId(
    string uniqueId
)
Visual Basic
Public Function GetRenderingByUniqueId ( _
    uniqueId As String _
) As RenderingDefinition
Visual C++
public:
RenderingDefinition^ GetRenderingByUniqueId(
    String^ uniqueId
)

Parameters

uniqueId
Type: System..::..String
The unique id.

Return Value

The rendering by unique id.

See Also

DeviceDefinition Class
Sitecore.Layouts Namespace


GetRenderings Method

[image]

Sitecore 6.4.1 API
DeviceDefinition..::..GetRenderings Method
DeviceDefinition Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public List<RenderingDefinition> GetRenderings(
    string id
)
Visual Basic
Public Function GetRenderings ( _
    id As String _
) As List(Of RenderingDefinition)
Visual C++
public:
List<RenderingDefinition^>^ GetRenderings(
    String^ id
)

Parameters

id
Type: System..::..String
The id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Layouts.DeviceDefinition.GetRenderings(System.String)"]

See Also

DeviceDefinition Class
Sitecore.Layouts Namespace


Insert Method

[image]

Sitecore 6.4.1 API
DeviceDefinition..::..Insert Method
DeviceDefinition Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Insert(
    int index,
    RenderingDefinition renderingDefinition
)
Visual Basic
Public Sub Insert ( _
    index As Integer, _
    renderingDefinition As RenderingDefinition _
)
Visual C++
public:
void Insert(
    int index,
    RenderingDefinition^ renderingDefinition
)

Parameters

index
Type: System..::..Int32
The index.
renderingDefinition
Type: Sitecore.Layouts..::..RenderingDefinition
The rendering definition.

See Also

DeviceDefinition Class
Sitecore.Layouts Namespace


LoadXml Method

[image] [image]

Sitecore 6.4.1 API
DeviceDefinition..::..LoadXml Method
DeviceDefinition Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LoadXml(String) | Creates an object represenation of the string xml given as parameter. (Inherited from XmlSerializable.)
Public method | LoadXml(String, String) | Creates a object representation of the xml transformed using the xslt style sheed whos path is given as argument. (Inherited from XmlSerializable.)

See Also

DeviceDefinition Class
DeviceDefinition Members
Sitecore.Layouts Namespace


RemoveRendering Method

[image]

Sitecore 6.4.1 API
DeviceDefinition..::..RemoveRendering Method
DeviceDefinition Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public void RemoveRendering(
    ID device,
    ID rendering
)
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Sub RemoveRendering ( _
    device As ID, _
    rendering As ID _
)
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public:
void RemoveRendering(
    ID^ device,
    ID^ rendering
)

Parameters

device
Type: Sitecore.Data..::..ID
The device.
rendering
Type: Sitecore.Data..::..ID
The rendering.

See Also

DeviceDefinition Class
Sitecore.Layouts Namespace


ToXml Method

[image] [image]

Sitecore 6.4.1 API
DeviceDefinition..::..ToXml Method
DeviceDefinition Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToXml()()()() | Creates a string xml representation of this object. Note that cycles are not allowed. (Inherited from XmlSerializable.)
Public method | ToXml(String) | Creates a xml string representation, and transforms that xml using the xslt file given at the location of the path given as parameter. (Inherited from XmlSerializable.)

See Also

DeviceDefinition Class
DeviceDefinition Members
Sitecore.Layouts Namespace


DeviceDefinition Properties

[image] [image]

Sitecore 6.4.1 API
DeviceDefinition Properties
DeviceDefinition Class See Also Send Feedback

The DeviceDefinition type exposes the following members.

Properties

 | Name | Description
Public property | ID | Gets or sets the ID.
Public property | Layout | Gets or sets the layout.
Public property | Placeholders | Gets or sets the placeholders.
Public property | Renderings | Gets or sets the renderings.

See Also

DeviceDefinition Class
Sitecore.Layouts Namespace


ID Property

[image]

Sitecore 6.4.1 API
DeviceDefinition..::..ID Property
DeviceDefinition Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ID { get; set; }
Visual Basic
Public Property ID As String
    Get
    Set
Visual C++
public:
property String^ ID {
    String^ get ();
    void set (String^ value);
}

Field Value

The ID.

See Also

DeviceDefinition Class
Sitecore.Layouts Namespace


Placeholders Property

[image]

Sitecore 6.4.1 API
DeviceDefinition..::..Placeholders Property
DeviceDefinition Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ArrayList Placeholders { get; set; }
Visual Basic
Public Property Placeholders As ArrayList
    Get
    Set
Visual C++
public:
property ArrayList^ Placeholders {
    ArrayList^ get ();
    void set (ArrayList^ value);
}

Field Value

The placeholders.

See Also

DeviceDefinition Class
Sitecore.Layouts Namespace


Renderings Property

[image]

Sitecore 6.4.1 API
DeviceDefinition..::..Renderings Property
DeviceDefinition Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ArrayList Renderings { get; set; }
Visual Basic
Public Property Renderings As ArrayList
    Get
    Set
Visual C++
public:
property ArrayList^ Renderings {
    ArrayList^ get ();
    void set (ArrayList^ value);
}

Field Value

The renderings.

See Also

DeviceDefinition Class
Sitecore.Layouts Namespace


HtmlParts Class

[image]

Sitecore 6.4.1 API
HtmlParts Class
Members See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class HtmlParts
Visual Basic
<SerializableAttribute> _
Public Class HtmlParts
Visual C++
[SerializableAttribute]
public ref class HtmlParts

Inheritance Hierarchy

System..::..Object
Sitecore.Layouts..::..HtmlParts

See Also

HtmlParts Members
Sitecore.Layouts Namespace


HtmlParts Members

[image] [image]

Sitecore 6.4.1 API
HtmlParts Members
HtmlParts Class Constructors Methods Properties See Also Send Feedback

The HtmlParts type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlParts | Initializes a new instance of the HtmlParts class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Body | Gets or sets the body.
Public property | Footer | Gets or sets the footer.
Public property | Header | Gets or sets the header.

See Also

HtmlParts Class
Sitecore.Layouts Namespace


HtmlParts Constructor

[image]

Sitecore 6.4.1 API
HtmlParts Constructor
HtmlParts Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HtmlParts()
Visual Basic
Public Sub New
Visual C++
public:
HtmlParts()

See Also

HtmlParts Class
Sitecore.Layouts Namespace


HtmlParts Methods

[image] [image]

Sitecore 6.4.1 API
HtmlParts Methods
HtmlParts Class See Also Send Feedback

The HtmlParts type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HtmlParts Class
Sitecore.Layouts Namespace


HtmlParts Properties

[image] [image]

Sitecore 6.4.1 API
HtmlParts Properties
HtmlParts Class See Also Send Feedback

The HtmlParts type exposes the following members.

Properties

 | Name | Description
Public property | Body | Gets or sets the body.
Public property | Footer | Gets or sets the footer.
Public property | Header | Gets or sets the header.

See Also

HtmlParts Class
Sitecore.Layouts Namespace


Body Property

[image]

Sitecore 6.4.1 API
HtmlParts..::..Body Property
HtmlParts Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Body { get; set; }
Visual Basic
Public Property Body As String
    Get
    Set
Visual C++
public:
property String^ Body {
    String^ get ();
    void set (String^ value);
}

Field Value

The body.

See Also

HtmlParts Class
Sitecore.Layouts Namespace


Footer Property

[image]

Sitecore 6.4.1 API
HtmlParts..::..Footer Property
HtmlParts Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Footer { get; set; }
Visual Basic
Public Property Footer As String
    Get
    Set
Visual C++
public:
property String^ Footer {
    String^ get ();
    void set (String^ value);
}

Field Value

The footer.

See Also

HtmlParts Class
Sitecore.Layouts Namespace


Header Property

[image]

Sitecore 6.4.1 API
HtmlParts..::..Header Property
HtmlParts Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Header { get; set; }
Visual Basic
Public Property Header As String
    Get
    Set
Visual C++
public:
property String^ Header {
    String^ get ();
    void set (String^ value);
}

Field Value

The header.

See Also

HtmlParts Class
Sitecore.Layouts Namespace


IExpandable Members

[image] [image]

Sitecore 6.4.1 API
IExpandable Members
IExpandable Interface Methods See Also Send Feedback

The IExpandable type exposes the following members.

Methods

 | Name | Description
Public method | Expand | Expands this instance.

See Also

IExpandable Interface
Sitecore.Layouts Namespace


Expand Method

[image]

Sitecore 6.4.1 API
IExpandable..::..Expand Method
IExpandable Interface See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void Expand()
Visual Basic
Sub Expand
Visual C++
void Expand()

See Also

IExpandable Interface
Sitecore.Layouts Namespace


LayoutDefinition Class

[image]

Sitecore 6.4.1 API
LayoutDefinition Class
Members See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class LayoutDefinition : XmlSerializable
Visual Basic
Public Class LayoutDefinition _
    Inherits XmlSerializable
Visual C++
public ref class LayoutDefinition : public XmlSerializable

Inheritance Hierarchy

System..::..Object
Sitecore.Xml.Serialization..::..XmlSerializable
Sitecore.Layouts..::..LayoutDefinition

See Also

LayoutDefinition Members
Sitecore.Layouts Namespace


LayoutDefinition Members

[image] [image]

Sitecore 6.4.1 API
LayoutDefinition Members
LayoutDefinition Class Constructors Methods Properties See Also Send Feedback

The LayoutDefinition type exposes the following members.

Constructors

 | Name | Description
Public method | LayoutDefinition | Initializes a new instance of the LayoutDefinition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDevice | Gets the device.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadXml(String) | Creates an object represenation of the string xml given as parameter. (Inherited from XmlSerializable.)
Public method | LoadXml(String, String) | Creates a object representation of the xml transformed using the xslt style sheed whos path is given as argument. (Inherited from XmlSerializable.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Parses the specified XML.
Public method | SaveAsXml | Saves this object representated as xml to a file. (Inherited from XmlSerializable.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToXml()()()() | Creates a string xml representation of this object. Note that cycles are not allowed. (Inherited from XmlSerializable.)
Public method | ToXml(String) | Creates a xml string representation, and transforms that xml using the xslt file given at the location of the path given as parameter. (Inherited from XmlSerializable.)

Properties

 | Name | Description
Public property | Devices | Gets or sets the devices.

See Also

LayoutDefinition Class
Sitecore.Layouts Namespace


LayoutDefinition Constructor

[image]

Sitecore 6.4.1 API
LayoutDefinition Constructor
LayoutDefinition Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LayoutDefinition()
Visual Basic
Public Sub New
Visual C++
public:
LayoutDefinition()

See Also

LayoutDefinition Class
Sitecore.Layouts Namespace


LayoutDefinition Methods

[image] [image]

Sitecore 6.4.1 API
LayoutDefinition Methods
LayoutDefinition Class See Also Send Feedback

The LayoutDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDevice | Gets the device.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadXml(String) | Creates an object represenation of the string xml given as parameter. (Inherited from XmlSerializable.)
Public method | LoadXml(String, String) | Creates a object representation of the xml transformed using the xslt style sheed whos path is given as argument. (Inherited from XmlSerializable.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Parses the specified XML.
Public method | SaveAsXml | Saves this object representated as xml to a file. (Inherited from XmlSerializable.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToXml()()()() | Creates a string xml representation of this object. Note that cycles are not allowed. (Inherited from XmlSerializable.)
Public method | ToXml(String) | Creates a xml string representation, and transforms that xml using the xslt file given at the location of the path given as parameter. (Inherited from XmlSerializable.)

See Also

LayoutDefinition Class
Sitecore.Layouts Namespace


LoadXml Method

[image] [image]

Sitecore 6.4.1 API
LayoutDefinition..::..LoadXml Method
LayoutDefinition Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LoadXml(String) | Creates an object represenation of the string xml given as parameter. (Inherited from XmlSerializable.)
Public method | LoadXml(String, String) | Creates a object representation of the xml transformed using the xslt style sheed whos path is given as argument. (Inherited from XmlSerializable.)

See Also

LayoutDefinition Class
LayoutDefinition Members
Sitecore.Layouts Namespace


Parse Method

[image]

Sitecore 6.4.1 API
LayoutDefinition..::..Parse Method
LayoutDefinition Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static LayoutDefinition Parse(
    string xml
)
Visual Basic
Public Shared Function Parse ( _
    xml As String _
) As LayoutDefinition
Visual C++
public:
static LayoutDefinition^ Parse(
    String^ xml
)

Parameters

xml
Type: System..::..String
The XML.

Return Value

[Missing <returns> documentation for "M:Sitecore.Layouts.LayoutDefinition.Parse(System.String)"]

See Also

LayoutDefinition Class
Sitecore.Layouts Namespace


ToXml Method

[image] [image]

Sitecore 6.4.1 API
LayoutDefinition..::..ToXml Method
LayoutDefinition Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToXml()()()() | Creates a string xml representation of this object. Note that cycles are not allowed. (Inherited from XmlSerializable.)
Public method | ToXml(String) | Creates a xml string representation, and transforms that xml using the xslt file given at the location of the path given as parameter. (Inherited from XmlSerializable.)

See Also

LayoutDefinition Class
LayoutDefinition Members
Sitecore.Layouts Namespace


LayoutDefinition Properties

[image] [image]

Sitecore 6.4.1 API
LayoutDefinition Properties
LayoutDefinition Class See Also Send Feedback

The LayoutDefinition type exposes the following members.

Properties

 | Name | Description
Public property | Devices | Gets or sets the devices.

See Also

LayoutDefinition Class
Sitecore.Layouts Namespace


Devices Property

[image]

Sitecore 6.4.1 API
LayoutDefinition..::..Devices Property
LayoutDefinition Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ArrayList Devices { get; set; }
Visual Basic
Public Property Devices As ArrayList
    Get
    Set
Visual C++
public:
property ArrayList^ Devices {
    ArrayList^ get ();
    void set (ArrayList^ value);
}

Field Value

The devices.

See Also

LayoutDefinition Class
Sitecore.Layouts Namespace


PageContext Class

[image]

Sitecore 6.4.1 API
PageContext Class
Members See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PageContext
Visual Basic
Public Class PageContext
Visual C++
public ref class PageContext

Inheritance Hierarchy

System..::..Object
Sitecore.Layouts..::..PageContext

See Also

PageContext Members
Sitecore.Layouts Namespace


PageContext Members

[image] [image]

Sitecore 6.4.1 API
PageContext Members
PageContext Class Constructors Methods Properties See Also Send Feedback

The PageContext type exposes the following members.

Constructors

 | Name | Description
Public method | PageContext | Initializes a new instance of the PageContext class

Methods

 | Name | Description
Public method | AddRendering | Adds the rendering.
Public method | Build | Builds this page.
Public method | ClearRenderings | Clears the renderings.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Expand | Expands the specified control.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPlaceholder | Gets the placeholder.
Public method | GetPlaceholderDefinition | Gets the placeholder definition.
Public method | GetPlaceholderItem(String, Database) | Gets the placeholder item.
Public method | GetPlaceholderItem(Placeholder, Database) | Gets the placeholder item.
Public method | GetPlaceholderItem(String, Database, String) | Gets the placeholder item.
Public method | GetRenderingReference | Gets the rendering reference corresponding to the control.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertDebugger | Obsolete. Inserts the debugger.
Public method | InsertPreviewMenu | Obsolete. Inserts the preview menu.
Public method | InsertSystemControls | Inserts the system controls.
Public method | InsertUnusedControls | Traces all unused renderings.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetLayout | Obsolete. Sets the layout.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Device | Gets or sets the device.
Public property | FilePath | Gets or sets the file path.
Public property | Page | Gets the page.
Public property | Placeholders | Gets the placeholders.
Public property | Renderings | Gets the renderings.

See Also

PageContext Class
Sitecore.Layouts Namespace


PageContext Constructor

[image]

Sitecore 6.4.1 API
PageContext Constructor
PageContext Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PageContext()
Visual Basic
Public Sub New
Visual C++
public:
PageContext()

See Also

PageContext Class
Sitecore.Layouts Namespace


PageContext Methods

[image] [image]

Sitecore 6.4.1 API
PageContext Methods
PageContext Class See Also Send Feedback

The PageContext type exposes the following members.

Methods

 | Name | Description
Public method | AddRendering | Adds the rendering.
Public method | Build | Builds this page.
Public method | ClearRenderings | Clears the renderings.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Expand | Expands the specified control.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPlaceholder | Gets the placeholder.
Public method | GetPlaceholderDefinition | Gets the placeholder definition.
Public method | GetPlaceholderItem(String, Database) | Gets the placeholder item.
Public method | GetPlaceholderItem(Placeholder, Database) | Gets the placeholder item.
Public method | GetPlaceholderItem(String, Database, String) | Gets the placeholder item.
Public method | GetRenderingReference | Gets the rendering reference corresponding to the control.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertDebugger | Obsolete. Inserts the debugger.
Public method | InsertPreviewMenu | Obsolete. Inserts the preview menu.
Public method | InsertSystemControls | Inserts the system controls.
Public method | InsertUnusedControls | Traces all unused renderings.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetLayout | Obsolete. Sets the layout.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PageContext Class
Sitecore.Layouts Namespace


AddRendering Method

[image]

Sitecore 6.4.1 API
PageContext..::..AddRendering Method
PageContext Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddRendering(
    RenderingReference reference
)
Visual Basic
Public Sub AddRendering ( _
    reference As RenderingReference _
)
Visual C++
public:
void AddRendering(
    RenderingReference^ reference
)

Parameters

reference
Type: Sitecore.Layouts..::..RenderingReference
The reference.

See Also

PageContext Class
Sitecore.Layouts Namespace


Build Method

[image]

Sitecore 6.4.1 API
PageContext..::..Build Method
PageContext Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Build()
Visual Basic
Public Sub Build
Visual C++
public:
void Build()

See Also

PageContext Class
Sitecore.Layouts Namespace


ClearRenderings Method

[image]

Sitecore 6.4.1 API
PageContext..::..ClearRenderings Method
PageContext Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void ClearRenderings()
Visual Basic
Public Sub ClearRenderings
Visual C++
public:
void ClearRenderings()

See Also

PageContext Class
Sitecore.Layouts Namespace


Expand Method

[image]

Sitecore 6.4.1 API
PageContext..::..Expand Method
PageContext Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Expand(
    Control control
)
Visual Basic
Public Sub Expand ( _
    control As Control _
)
Visual C++
public:
void Expand(
    Control^ control
)

Parameters

control
Type: System.Web.UI..::..Control
The control.

See Also

PageContext Class
Sitecore.Layouts Namespace


GetPlaceholder Method

[image]

Sitecore 6.4.1 API
PageContext..::..GetPlaceholder Method
PageContext Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Placeholder GetPlaceholder(
    string key
)
Visual Basic
Public Function GetPlaceholder ( _
    key As String _
) As Placeholder
Visual C++
public:
Placeholder^ GetPlaceholder(
    String^ key
)

Parameters

key
Type: System..::..String
The key.

Return Value

The placeholder.

See Also

PageContext Class
Sitecore.Layouts Namespace


GetPlaceholderItem Method

[image] [image]

Sitecore 6.4.1 API
PageContext..::..GetPlaceholderItem Method
PageContext Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPlaceholderItem(String, Database) | Gets the placeholder item.
Public method | GetPlaceholderItem(Placeholder, Database) | Gets the placeholder item.
Public method | GetPlaceholderItem(String, Database, String) | Gets the placeholder item.

See Also

PageContext Class
PageContext Members
Sitecore.Layouts Namespace


GetPlaceholderItem Method (String, Database)

[image]

Sitecore 6.4.1 API
PageContext..::..GetPlaceholderItem Method (String, Database)
PageContext Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetPlaceholderItem(
    string placeholderKey,
    Database database
)
Visual Basic
Public Function GetPlaceholderItem ( _
    placeholderKey As String, _
    database As Database _
) As Item
Visual C++
public:
Item^ GetPlaceholderItem(
    String^ placeholderKey,
    Database^ database
)

Parameters

placeholderKey
Type: System..::..String
The placeholder key.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

The placeholder item.

See Also

PageContext Class
GetPlaceholderItem Overload
Sitecore.Layouts Namespace


GetPlaceholderItem Method (Placeholder, Database)

[image]

Sitecore 6.4.1 API
PageContext..::..GetPlaceholderItem Method (Placeholder, Database)
PageContext Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetPlaceholderItem(
    Placeholder placeholder,
    Database database
)
Visual Basic
Public Function GetPlaceholderItem ( _
    placeholder As Placeholder, _
    database As Database _
) As Item
Visual C++
public:
Item^ GetPlaceholderItem(
    Placeholder^ placeholder,
    Database^ database
)

Parameters

placeholder
Type: Sitecore.Web.UI.WebControls..::..Placeholder
The placeholder.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

The placeholder item.

See Also

PageContext Class
GetPlaceholderItem Overload
Sitecore.Layouts Namespace


GetPlaceholderItem Method (String, Database, String)

[image]

Sitecore 6.4.1 API
PageContext..::..GetPlaceholderItem Method (String, Database, String)
PageContext Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetPlaceholderItem(
    string placeholderKey,
    Database database,
    string layoutDefinition
)
Visual Basic
Public Function GetPlaceholderItem ( _
    placeholderKey As String, _
    database As Database, _
    layoutDefinition As String _
) As Item
Visual C++
public:
Item^ GetPlaceholderItem(
    String^ placeholderKey,
    Database^ database,
    String^ layoutDefinition
)

Parameters

placeholderKey
Type: System..::..String
The placeholder key.
database
Type: Sitecore.Data..::..Database
The database.
layoutDefinition
Type: System..::..String
The layout definition.

Return Value

The placeholder item.

See Also

PageContext Class
GetPlaceholderItem Overload
Sitecore.Layouts Namespace


GetRenderingReference Method

[image]

Sitecore 6.4.1 API
PageContext..::..GetRenderingReference Method
PageContext Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderingReference GetRenderingReference(
    Control control
)
Visual Basic
Public Function GetRenderingReference ( _
    control As Control _
) As RenderingReference
Visual C++
public:
RenderingReference^ GetRenderingReference(
    Control^ control
)

Parameters

control
Type: System.Web.UI..::..Control
The control.

Return Value

The rendering reference.

See Also

PageContext Class
Sitecore.Layouts Namespace


InsertDebugger Method

[image]

Sitecore 6.4.1 API
PageContext..::..InsertDebugger Method
PageContext Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("This method has been deprecated.")]
public void InsertDebugger()
Visual Basic
<ObsoleteAttribute("This method has been deprecated.")> _
Public Sub InsertDebugger
Visual C++
[ObsoleteAttribute(L"This method has been deprecated.")]
public:
void InsertDebugger()

See Also

PageContext Class
Sitecore.Layouts Namespace


InsertPreviewMenu Method

[image]

Sitecore 6.4.1 API
PageContext..::..InsertPreviewMenu Method
PageContext Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("This method has been deprecated.")]
public void InsertPreviewMenu()
Visual Basic
<ObsoleteAttribute("This method has been deprecated.")> _
Public Sub InsertPreviewMenu
Visual C++
[ObsoleteAttribute(L"This method has been deprecated.")]
public:
void InsertPreviewMenu()

See Also

PageContext Class
Sitecore.Layouts Namespace


InsertSystemControls Method

[image]

Sitecore 6.4.1 API
PageContext..::..InsertSystemControls Method
PageContext Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void InsertSystemControls()
Visual Basic
Public Sub InsertSystemControls
Visual C++
public:
void InsertSystemControls()

See Also

PageContext Class
Sitecore.Layouts Namespace


InsertUnusedControls Method

[image]

Sitecore 6.4.1 API
PageContext..::..InsertUnusedControls Method
PageContext Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void InsertUnusedControls()
Visual Basic
Public Overridable Sub InsertUnusedControls
Visual C++
public:
virtual void InsertUnusedControls()

See Also

PageContext Class
Sitecore.Layouts Namespace


SetLayout Method

[image]

Sitecore 6.4.1 API
PageContext..::..SetLayout Method
PageContext Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated. Use FilePath instead.")]
public void SetLayout(
    LayoutItem layout
)
Visual Basic
<ObsoleteAttribute("Deprecated. Use FilePath instead.")> _
Public Sub SetLayout ( _
    layout As LayoutItem _
)
Visual C++
[ObsoleteAttribute(L"Deprecated. Use FilePath instead.")]
public:
void SetLayout(
    LayoutItem^ layout
)

Parameters

layout
Type: Sitecore.Data.Items..::..LayoutItem
The layout.

See Also

PageContext Class
Sitecore.Layouts Namespace


PageContext Properties

[image] [image]

Sitecore 6.4.1 API
PageContext Properties
PageContext Class See Also Send Feedback

The PageContext type exposes the following members.

Properties

 | Name | Description
Public property | Device | Gets or sets the device.
Public property | FilePath | Gets or sets the file path.
Public property | Page | Gets the page.
Public property | Placeholders | Gets the placeholders.
Public property | Renderings | Gets the renderings.

See Also

PageContext Class
Sitecore.Layouts Namespace


Device Property

[image]

Sitecore 6.4.1 API
PageContext..::..Device Property
PageContext Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DeviceItem Device { get; set; }
Visual Basic
Public Property Device As DeviceItem
    Get
    Set
Visual C++
public:
property DeviceItem^ Device {
    DeviceItem^ get ();
    void set (DeviceItem^ value);
}

Field Value

The device.

See Also

PageContext Class
Sitecore.Layouts Namespace


FilePath Property

[image]

Sitecore 6.4.1 API
PageContext..::..FilePath Property
PageContext Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string FilePath { get; set; }
Visual Basic
Public Property FilePath As String
    Get
    Set
Visual C++
public:
property String^ FilePath {
    String^ get ();
    void set (String^ value);
}

Field Value

The file path.

See Also

PageContext Class
Sitecore.Layouts Namespace


Page Property

[image]

Sitecore 6.4.1 API
PageContext..::..Page Property
PageContext Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Page Page { get; }
Visual Basic
Public ReadOnly Property Page As Page
    Get
Visual C++
public:
property Page^ Page {
    Page^ get ();
}

Field Value

The page.

See Also

PageContext Class
Sitecore.Layouts Namespace


Placeholders Property

[image]

Sitecore 6.4.1 API
PageContext..::..Placeholders Property
PageContext Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PlaceholderList Placeholders { get; }
Visual Basic
Public ReadOnly Property Placeholders As PlaceholderList
    Get
Visual C++
public:
property PlaceholderList^ Placeholders {
    PlaceholderList^ get ();
}

Field Value

The placeholders.

See Also

PageContext Class
Sitecore.Layouts Namespace


Renderings Property

[image]

Sitecore 6.4.1 API
PageContext..::..Renderings Property
PageContext Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderingReferenceList Renderings { get; }
Visual Basic
Public ReadOnly Property Renderings As RenderingReferenceList
    Get
Visual C++
public:
property RenderingReferenceList^ Renderings {
    RenderingReferenceList^ get ();
}

Field Value

The renderings.

See Also

PageContext Class
Sitecore.Layouts Namespace


PlaceholderDefinition Class

[image]

Sitecore 6.4.1 API
PlaceholderDefinition Class
Members See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PlaceholderDefinition : XmlSerializable
Visual Basic
Public Class PlaceholderDefinition _
    Inherits XmlSerializable
Visual C++
public ref class PlaceholderDefinition : public XmlSerializable

Inheritance Hierarchy

System..::..Object
Sitecore.Xml.Serialization..::..XmlSerializable
Sitecore.Layouts..::..PlaceholderDefinition

See Also

PlaceholderDefinition Members
Sitecore.Layouts Namespace


PlaceholderDefinition Constructor

[image]

Sitecore 6.4.1 API
PlaceholderDefinition Constructor
PlaceholderDefinition Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PlaceholderDefinition()
Visual Basic
Public Sub New
Visual C++
public:
PlaceholderDefinition()

See Also

PlaceholderDefinition Class
Sitecore.Layouts Namespace


PlaceholderDefinition Methods

[image] [image]

Sitecore 6.4.1 API
PlaceholderDefinition Methods
PlaceholderDefinition Class See Also Send Feedback

The PlaceholderDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadXml(String) | Creates an object represenation of the string xml given as parameter. (Inherited from XmlSerializable.)
Public method | LoadXml(String, String) | Creates a object representation of the xml transformed using the xslt style sheed whos path is given as argument. (Inherited from XmlSerializable.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveAsXml | Saves this object representated as xml to a file. (Inherited from XmlSerializable.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToXml()()()() | Creates a string xml representation of this object. Note that cycles are not allowed. (Inherited from XmlSerializable.)
Public method | ToXml(String) | Creates a xml string representation, and transforms that xml using the xslt file given at the location of the path given as parameter. (Inherited from XmlSerializable.)

See Also

PlaceholderDefinition Class
Sitecore.Layouts Namespace


LoadXml Method

[image] [image]

Sitecore 6.4.1 API
PlaceholderDefinition..::..LoadXml Method
PlaceholderDefinition Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LoadXml(String) | Creates an object represenation of the string xml given as parameter. (Inherited from XmlSerializable.)
Public method | LoadXml(String, String) | Creates a object representation of the xml transformed using the xslt style sheed whos path is given as argument. (Inherited from XmlSerializable.)

See Also

PlaceholderDefinition Class
PlaceholderDefinition Members
Sitecore.Layouts Namespace


ToXml Method

[image] [image]

Sitecore 6.4.1 API
PlaceholderDefinition..::..ToXml Method
PlaceholderDefinition Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToXml()()()() | Creates a string xml representation of this object. Note that cycles are not allowed. (Inherited from XmlSerializable.)
Public method | ToXml(String) | Creates a xml string representation, and transforms that xml using the xslt file given at the location of the path given as parameter. (Inherited from XmlSerializable.)

See Also

PlaceholderDefinition Class
PlaceholderDefinition Members
Sitecore.Layouts Namespace


PlaceholderDefinition Properties

[image] [image]

Sitecore 6.4.1 API
PlaceholderDefinition Properties
PlaceholderDefinition Class See Also Send Feedback

The PlaceholderDefinition type exposes the following members.

Properties

 | Name | Description
Public property | Key | Gets or sets the name.
Public property | MetaDataItemId | Gets or sets the meta data item id.
Public property | UniqueId | Gets or sets the id.

See Also

PlaceholderDefinition Class
Sitecore.Layouts Namespace


Key Property

[image]

Sitecore 6.4.1 API
PlaceholderDefinition..::..Key Property
PlaceholderDefinition Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Key { get; set; }
Visual Basic
Public Property Key As String
    Get
    Set
Visual C++
public:
property String^ Key {
    String^ get ();
    void set (String^ value);
}

Field Value

The name.

See Also

PlaceholderDefinition Class
Sitecore.Layouts Namespace


MetaDataItemId Property

[image]

Sitecore 6.4.1 API
PlaceholderDefinition..::..MetaDataItemId Property
PlaceholderDefinition Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string MetaDataItemId { get; set; }
Visual Basic
Public Property MetaDataItemId As String
    Get
    Set
Visual C++
public:
property String^ MetaDataItemId {
    String^ get ();
    void set (String^ value);
}

Field Value

The meta data item id.

See Also

PlaceholderDefinition Class
Sitecore.Layouts Namespace


UniqueId Property

[image]

Sitecore 6.4.1 API
PlaceholderDefinition..::..UniqueId Property
PlaceholderDefinition Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string UniqueId { get; set; }
Visual Basic
Public Property UniqueId As String
    Get
    Set
Visual C++
public:
property String^ UniqueId {
    String^ get ();
    void set (String^ value);
}

Field Value

The id.

See Also

PlaceholderDefinition Class
Sitecore.Layouts Namespace


RenderingCaching Class

[image]

Sitecore 6.4.1 API
RenderingCaching Class
Members See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RenderingCaching
Visual Basic
Public Class RenderingCaching
Visual C++
public ref class RenderingCaching

Inheritance Hierarchy

System..::..Object
Sitecore.Layouts..::..RenderingCaching

See Also

RenderingCaching Members
Sitecore.Layouts Namespace


RenderingCaching Members

[image] [image]

Sitecore 6.4.1 API
RenderingCaching Members
RenderingCaching Class Constructors Methods Properties See Also Send Feedback

The RenderingCaching type exposes the following members.

Constructors

 | Name | Description
Public method | RenderingCaching | Initializes a new instance of the RenderingCaching class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse(XmlNode) | Parses the specified config node.
 | Parse(Item) | Parses the specified item.
 | Parse(RenderingDefinition) | Parses the specified item.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cacheable | Gets or sets a value indicating whether this RenderingCaching is cacheable.
Public property | VaryByData | Gets or sets a value indicating whether the RenderingCaching varies by the data.
Public property | VaryByDevice | Gets or sets a value indicating whether the RenderingCaching varies by the device.
Public property | VaryByLogin | Gets or sets a value indicating whether the RenderingCaching varies by the login.
Public property | VaryByParm | Gets or sets a value indicating whether the RenderingCaching varies by the parameters.
Public property | VaryByQueryString | Gets or sets a value indicating whether the RenderingCaching varies by the query string.
Public property | VaryByUser | Gets or sets a value indicating whether the RenderingCaching varies by the user.

See Also

RenderingCaching Class
Sitecore.Layouts Namespace


RenderingCaching Constructor

[image]

Sitecore 6.4.1 API
RenderingCaching Constructor
RenderingCaching Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderingCaching()
Visual Basic
Public Sub New
Visual C++
public:
RenderingCaching()

See Also

RenderingCaching Class
Sitecore.Layouts Namespace


RenderingCaching Methods

[image] [image]

Sitecore 6.4.1 API
RenderingCaching Methods
RenderingCaching Class See Also Send Feedback

The RenderingCaching type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse(XmlNode) | Parses the specified config node.
 | Parse(Item) | Parses the specified item.
 | Parse(RenderingDefinition) | Parses the specified item.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenderingCaching Class
Sitecore.Layouts Namespace


Parse Method

[image] [image]

Sitecore 6.4.1 API
RenderingCaching..::..Parse Method
RenderingCaching Class See Also Send Feedback

Overload List

Name | Description
Parse(XmlNode) | Parses the specified config node.
Parse(Item) | Parses the specified item.
Parse(RenderingDefinition) | Parses the specified item.

See Also

RenderingCaching Class
RenderingCaching Members
Sitecore.Layouts Namespace


Parse Method (XmlNode)

[image]

Sitecore 6.4.1 API
RenderingCaching..::..Parse Method (XmlNode)
RenderingCaching Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static RenderingCaching Parse(
    XmlNode configNode
)
Visual Basic
Public Shared Function Parse ( _
    configNode As XmlNode _
) As RenderingCaching
Visual C++
public:
static RenderingCaching^ Parse(
    XmlNode^ configNode
)

Parameters

configNode
Type: System.Xml..::..XmlNode
The config node.

Return Value

[Missing <returns> documentation for "M:Sitecore.Layouts.RenderingCaching.Parse(System.Xml.XmlNode)"]

See Also

RenderingCaching Class
Parse Overload
Sitecore.Layouts Namespace


Parse Method (Item)

[image]

Sitecore 6.4.1 API
RenderingCaching..::..Parse Method (Item)
RenderingCaching Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static RenderingCaching Parse(
    Item item
)
Visual Basic
Public Shared Function Parse ( _
    item As Item _
) As RenderingCaching
Visual C++
public:
static RenderingCaching^ Parse(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Layouts.RenderingCaching.Parse(Sitecore.Data.Items.Item)"]

See Also

RenderingCaching Class
Parse Overload
Sitecore.Layouts Namespace


Parse Method (RenderingDefinition)

[image]

Sitecore 6.4.1 API
RenderingCaching..::..Parse Method (RenderingDefinition)
RenderingCaching Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static RenderingCaching Parse(
    RenderingDefinition definition
)
Visual Basic
Public Shared Function Parse ( _
    definition As RenderingDefinition _
) As RenderingCaching
Visual C++
public:
static RenderingCaching^ Parse(
    RenderingDefinition^ definition
)

Parameters

definition
Type: Sitecore.Layouts..::..RenderingDefinition
The definition.

Return Value

The parse.

See Also

RenderingCaching Class
Parse Overload
Sitecore.Layouts Namespace


RenderingCaching Properties

[image] [image]

Sitecore 6.4.1 API
RenderingCaching Properties
RenderingCaching Class See Also Send Feedback

The RenderingCaching type exposes the following members.

Properties

 | Name | Description
Public property | Cacheable | Gets or sets a value indicating whether this RenderingCaching is cacheable.
Public property | VaryByData | Gets or sets a value indicating whether the RenderingCaching varies by the data.
Public property | VaryByDevice | Gets or sets a value indicating whether the RenderingCaching varies by the device.
Public property | VaryByLogin | Gets or sets a value indicating whether the RenderingCaching varies by the login.
Public property | VaryByParm | Gets or sets a value indicating whether the RenderingCaching varies by the parameters.
Public property | VaryByQueryString | Gets or sets a value indicating whether the RenderingCaching varies by the query string.
Public property | VaryByUser | Gets or sets a value indicating whether the RenderingCaching varies by the user.

See Also

RenderingCaching Class
Sitecore.Layouts Namespace


Cacheable Property

[image]

Sitecore 6.4.1 API
RenderingCaching..::..Cacheable Property
RenderingCaching Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Cacheable { get; set; }
Visual Basic
Public Property Cacheable As Boolean
    Get
    Set
Visual C++
public:
property bool Cacheable {
    bool get ();
    void set (bool value);
}

Field Value

true if cacheable; otherwise, false.

See Also

RenderingCaching Class
Sitecore.Layouts Namespace


VaryByData Property

[image]

Sitecore 6.4.1 API
RenderingCaching..::..VaryByData Property
RenderingCaching Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool VaryByData { get; set; }
Visual Basic
Public Property VaryByData As Boolean
    Get
    Set
Visual C++
public:
property bool VaryByData {
    bool get ();
    void set (bool value);
}

Field Value

true if the RenderingCaching variess by the data; otherwise, false.

See Also

RenderingCaching Class
Sitecore.Layouts Namespace


VaryByDevice Property

[image]

Sitecore 6.4.1 API
RenderingCaching..::..VaryByDevice Property
RenderingCaching Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool VaryByDevice { get; set; }
Visual Basic
Public Property VaryByDevice As Boolean
    Get
    Set
Visual C++
public:
property bool VaryByDevice {
    bool get ();
    void set (bool value);
}

Field Value

true if the RenderingCaching varies by the device; otherwise, false.

See Also

RenderingCaching Class
Sitecore.Layouts Namespace


VaryByLogin Property

[image]

Sitecore 6.4.1 API
RenderingCaching..::..VaryByLogin Property
RenderingCaching Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool VaryByLogin { get; set; }
Visual Basic
Public Property VaryByLogin As Boolean
    Get
    Set
Visual C++
public:
property bool VaryByLogin {
    bool get ();
    void set (bool value);
}

Field Value

true if the RenderingCaching varies by the login; otherwise, false.

See Also

RenderingCaching Class
Sitecore.Layouts Namespace


VaryByParm Property

[image]

Sitecore 6.4.1 API
RenderingCaching..::..VaryByParm Property
RenderingCaching Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool VaryByParm { get; set; }
Visual Basic
Public Property VaryByParm As Boolean
    Get
    Set
Visual C++
public:
property bool VaryByParm {
    bool get ();
    void set (bool value);
}

Field Value

true if the RenderingCaching varies by the parameters; otherwise, false.

See Also

RenderingCaching Class
Sitecore.Layouts Namespace


VaryByQueryString Property

[image]

Sitecore 6.4.1 API
RenderingCaching..::..VaryByQueryString Property
RenderingCaching Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool VaryByQueryString { get; set; }
Visual Basic
Public Property VaryByQueryString As Boolean
    Get
    Set
Visual C++
public:
property bool VaryByQueryString {
    bool get ();
    void set (bool value);
}

Field Value

true if the RenderingCaching varies by the query string; otherwise, false.

See Also

RenderingCaching Class
Sitecore.Layouts Namespace


VaryByUser Property

[image]

Sitecore 6.4.1 API
RenderingCaching..::..VaryByUser Property
RenderingCaching Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool VaryByUser { get; set; }
Visual Basic
Public Property VaryByUser As Boolean
    Get
    Set
Visual C++
public:
property bool VaryByUser {
    bool get ();
    void set (bool value);
}

Field Value

true if the RenderingCaching varies by the user; otherwise, false.

See Also

RenderingCaching Class
Sitecore.Layouts Namespace


RenderingDefinition Class

[image]

Sitecore 6.4.1 API
RenderingDefinition Class
Members See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RenderingDefinition : XmlSerializable
Visual Basic
Public Class RenderingDefinition _
    Inherits XmlSerializable
Visual C++
public ref class RenderingDefinition : public XmlSerializable

Inheritance Hierarchy

System..::..Object
Sitecore.Xml.Serialization..::..XmlSerializable
Sitecore.Layouts..::..RenderingDefinition

See Also

RenderingDefinition Members
Sitecore.Layouts Namespace


RenderingDefinition Members

[image] [image]

Sitecore 6.4.1 API
RenderingDefinition Members
RenderingDefinition Class Constructors Methods Properties See Also Send Feedback

The RenderingDefinition type exposes the following members.

Constructors

 | Name | Description
Public method | RenderingDefinition | Initializes a new instance of the RenderingDefinition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadXml(String) | Creates an object represenation of the string xml given as parameter. (Inherited from XmlSerializable.)
Public method | LoadXml(String, String) | Creates a object representation of the xml transformed using the xslt style sheed whos path is given as argument. (Inherited from XmlSerializable.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveAsXml | Saves this object representated as xml to a file. (Inherited from XmlSerializable.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToXml()()()() | Creates a string xml representation of this object. Note that cycles are not allowed. (Inherited from XmlSerializable.)
Public method | ToXml(String) | Creates a xml string representation, and transforms that xml using the xslt file given at the location of the path given as parameter. (Inherited from XmlSerializable.)

Properties

 | Name | Description
Public property | Cachable | Gets or sets the cachable flag.
Public property | Conditions | Gets or sets the conditions.
Public property | Datasource | Gets or sets the datasource.
Public property | ItemID | Gets or sets the item ID.
Public property | MultiVariateTest | Gets or sets the multi variate test.
Public property | Parameters | Gets or sets the parameters.
Public property | Placeholder | Gets or sets the placeholder.
Public property | UniqueId | Gets or sets the unique id.
Public property | VaryByData | Gets or sets the vary by data.
Public property | VaryByDevice | Gets or sets the vary by device.
Public property | VaryByLogin | Gets or sets the vary by login.
Public property | VaryByParameters | Gets or sets the vary by parameters.
Public property | VaryByQueryString | Gets or sets the vary by query string.
Public property | VaryByUser | Gets or sets the vary by user.

See Also

RenderingDefinition Class
Sitecore.Layouts Namespace


RenderingDefinition Constructor

[image]

Sitecore 6.4.1 API
RenderingDefinition Constructor
RenderingDefinition Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderingDefinition()
Visual Basic
Public Sub New
Visual C++
public:
RenderingDefinition()

See Also

RenderingDefinition Class
Sitecore.Layouts Namespace


RenderingDefinition Methods

[image] [image]

Sitecore 6.4.1 API
RenderingDefinition Methods
RenderingDefinition Class See Also Send Feedback

The RenderingDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadXml(String) | Creates an object represenation of the string xml given as parameter. (Inherited from XmlSerializable.)
Public method | LoadXml(String, String) | Creates a object representation of the xml transformed using the xslt style sheed whos path is given as argument. (Inherited from XmlSerializable.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveAsXml | Saves this object representated as xml to a file. (Inherited from XmlSerializable.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToXml()()()() | Creates a string xml representation of this object. Note that cycles are not allowed. (Inherited from XmlSerializable.)
Public method | ToXml(String) | Creates a xml string representation, and transforms that xml using the xslt file given at the location of the path given as parameter. (Inherited from XmlSerializable.)

See Also

RenderingDefinition Class
Sitecore.Layouts Namespace


ToXml Method

[image] [image]

Sitecore 6.4.1 API
RenderingDefinition..::..ToXml Method
RenderingDefinition Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToXml()()()() | Creates a string xml representation of this object. Note that cycles are not allowed. (Inherited from XmlSerializable.)
Public method | ToXml(String) | Creates a xml string representation, and transforms that xml using the xslt file given at the location of the path given as parameter. (Inherited from XmlSerializable.)

See Also

RenderingDefinition Class
RenderingDefinition Members
Sitecore.Layouts Namespace


Cachable Property

[image]

Sitecore 6.4.1 API
RenderingDefinition..::..Cachable Property
RenderingDefinition Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Cachable { get; set; }
Visual Basic
Public Property Cachable As String
    Get
    Set
Visual C++
public:
property String^ Cachable {
    String^ get ();
    void set (String^ value);
}

Field Value

The cachable flag.

See Also

RenderingDefinition Class
Sitecore.Layouts Namespace


Conditions Property

[image]

Sitecore 6.4.1 API
RenderingDefinition..::..Conditions Property
RenderingDefinition Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Conditions { get; set; }
Visual Basic
Public Property Conditions As String
    Get
    Set
Visual C++
public:
property String^ Conditions {
    String^ get ();
    void set (String^ value);
}

Field Value

The conditions.

See Also

RenderingDefinition Class
Sitecore.Layouts Namespace


Datasource Property

[image]

Sitecore 6.4.1 API
RenderingDefinition..::..Datasource Property
RenderingDefinition Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Datasource { get; set; }
Visual Basic
Public Property Datasource As String
    Get
    Set
Visual C++
public:
property String^ Datasource {
    String^ get ();
    void set (String^ value);
}

Field Value

The datasource.

See Also

RenderingDefinition Class
Sitecore.Layouts Namespace


ItemID Property

[image]

Sitecore 6.4.1 API
RenderingDefinition..::..ItemID Property
RenderingDefinition Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ItemID { get; set; }
Visual Basic
Public Property ItemID As String
    Get
    Set
Visual C++
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}

Field Value

The item ID.

See Also

RenderingDefinition Class
Sitecore.Layouts Namespace


MultiVariateTest Property

[image]

Sitecore 6.4.1 API
RenderingDefinition..::..MultiVariateTest Property
RenderingDefinition Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string MultiVariateTest { get; set; }
Visual Basic
Public Property MultiVariateTest As String
    Get
    Set
Visual C++
public:
property String^ MultiVariateTest {
    String^ get ();
    void set (String^ value);
}

Field Value

The multi variate test.

See Also

RenderingDefinition Class
Sitecore.Layouts Namespace


Parameters Property

[image]

Sitecore 6.4.1 API
RenderingDefinition..::..Parameters Property
RenderingDefinition Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Parameters { get; set; }
Visual Basic
Public Property Parameters As String
    Get
    Set
Visual C++
public:
property String^ Parameters {
    String^ get ();
    void set (String^ value);
}

Field Value

The parameters.

See Also

RenderingDefinition Class
Sitecore.Layouts Namespace


Placeholder Property

[image]

Sitecore 6.4.1 API
RenderingDefinition..::..Placeholder Property
RenderingDefinition Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Placeholder { get; set; }
Visual Basic
Public Property Placeholder As String
    Get
    Set
Visual C++
public:
property String^ Placeholder {
    String^ get ();
    void set (String^ value);
}

Field Value

The placeholder.

See Also

RenderingDefinition Class
Sitecore.Layouts Namespace


UniqueId Property

[image]

Sitecore 6.4.1 API
RenderingDefinition..::..UniqueId Property
RenderingDefinition Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string UniqueId { get; set; }
Visual Basic
Public Property UniqueId As String
    Get
    Set
Visual C++
public:
property String^ UniqueId {
    String^ get ();
    void set (String^ value);
}

Field Value

The unique id.

See Also

RenderingDefinition Class
Sitecore.Layouts Namespace


VaryByData Property

[image]

Sitecore 6.4.1 API
RenderingDefinition..::..VaryByData Property
RenderingDefinition Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string VaryByData { get; set; }
Visual Basic
Public Property VaryByData As String
    Get
    Set
Visual C++
public:
property String^ VaryByData {
    String^ get ();
    void set (String^ value);
}

Field Value

The vary by data.

See Also

RenderingDefinition Class
Sitecore.Layouts Namespace


VaryByDevice Property

[image]

Sitecore 6.4.1 API
RenderingDefinition..::..VaryByDevice Property
RenderingDefinition Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string VaryByDevice { get; set; }
Visual Basic
Public Property VaryByDevice As String
    Get
    Set
Visual C++
public:
property String^ VaryByDevice {
    String^ get ();
    void set (String^ value);
}

Field Value

The vary by device.

See Also

RenderingDefinition Class
Sitecore.Layouts Namespace


VaryByLogin Property

[image]

Sitecore 6.4.1 API
RenderingDefinition..::..VaryByLogin Property
RenderingDefinition Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string VaryByLogin { get; set; }
Visual Basic
Public Property VaryByLogin As String
    Get
    Set
Visual C++
public:
property String^ VaryByLogin {
    String^ get ();
    void set (String^ value);
}

Field Value

The vary by login.

See Also

RenderingDefinition Class
Sitecore.Layouts Namespace


VaryByParameters Property

[image]

Sitecore 6.4.1 API
RenderingDefinition..::..VaryByParameters Property
RenderingDefinition Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string VaryByParameters { get; set; }
Visual Basic
Public Property VaryByParameters As String
    Get
    Set
Visual C++
public:
property String^ VaryByParameters {
    String^ get ();
    void set (String^ value);
}

Field Value

The vary by parameters.

See Also

RenderingDefinition Class
Sitecore.Layouts Namespace


VaryByQueryString Property

[image]

Sitecore 6.4.1 API
RenderingDefinition..::..VaryByQueryString Property
RenderingDefinition Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string VaryByQueryString { get; set; }
Visual Basic
Public Property VaryByQueryString As String
    Get
    Set
Visual C++
public:
property String^ VaryByQueryString {
    String^ get ();
    void set (String^ value);
}

Field Value

The vary by query string.

See Also

RenderingDefinition Class
Sitecore.Layouts Namespace


VaryByUser Property

[image]

Sitecore 6.4.1 API
RenderingDefinition..::..VaryByUser Property
RenderingDefinition Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string VaryByUser { get; set; }
Visual Basic
Public Property VaryByUser As String
    Get
    Set
Visual C++
public:
property String^ VaryByUser {
    String^ get ();
    void set (String^ value);
}

Field Value

The vary by user.

See Also

RenderingDefinition Class
Sitecore.Layouts Namespace


RenderingReference Class

[image]

Sitecore 6.4.1 API
RenderingReference Class
Members See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RenderingReference
Visual Basic
Public Class RenderingReference
Visual C++
public ref class RenderingReference

Inheritance Hierarchy

System..::..Object
Sitecore.Layouts..::..RenderingReference

See Also

RenderingReference Members
Sitecore.Layouts Namespace


RenderingReference Members

[image] [image]

Sitecore 6.4.1 API
RenderingReference Members
RenderingReference Class Constructors Methods Properties See Also Send Feedback

The RenderingReference type exposes the following members.

Constructors

 | Name | Description
Public method | RenderingReference(Control) | Initializes a new instance of the RenderingReference class.
Public method | RenderingReference(RenderingItem) | Initializes a new instance of the RenderingReference class.
Public method | RenderingReference(XmlNode, Language, Database) | Initializes a new instance of the RenderingReference class.
Public method | RenderingReference(RenderingDefinition, Language, Database) | Initializes a new instance of the RenderingReference class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControl | Gets the control.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetControl | Sets the control.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AddedToPage | Gets or sets a value indicating whether the rendering has been added to a page.
Public property | AddToFormIfUnused | Gets or sets a value indicating whether the RenderingReference adds the to form if unused.
Public property | Database | Gets the database.
Public property | FailureReason | Gets the failure reason.
Public property | Language | Gets the language.
Public property | Placeholder | Gets the placeholder.
Public property | RenderingID | Gets the rendering ID.
Public property | RenderingItem | Gets the rendering item.
Public property | Settings | Gets the settings.
Public property | UniqueId | Gets the unique ID.

See Also

RenderingReference Class
Sitecore.Layouts Namespace


RenderingReference Constructor

[image] [image]

Sitecore 6.4.1 API
RenderingReference Constructor
RenderingReference Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RenderingReference(Control) | Initializes a new instance of the RenderingReference class.
Public method | RenderingReference(RenderingItem) | Initializes a new instance of the RenderingReference class.
Public method | RenderingReference(XmlNode, Language, Database) | Initializes a new instance of the RenderingReference class.
Public method | RenderingReference(RenderingDefinition, Language, Database) | Initializes a new instance of the RenderingReference class.

See Also

RenderingReference Class
RenderingReference Members
Sitecore.Layouts Namespace


RenderingReference Constructor (Control)

[image]

Sitecore 6.4.1 API
RenderingReference Constructor (Control)
RenderingReference Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderingReference(
    Control control
)
Visual Basic
Public Sub New ( _
    control As Control _
)
Visual C++
public:
RenderingReference(
    Control^ control
)

Parameters

control
Type: System.Web.UI..::..Control
The control.

See Also

RenderingReference Class
RenderingReference Overload
Sitecore.Layouts Namespace


RenderingReference Constructor (RenderingItem)

[image]

Sitecore 6.4.1 API
RenderingReference Constructor (RenderingItem)
RenderingReference Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderingReference(
    RenderingItem renderingItem
)
Visual Basic
Public Sub New ( _
    renderingItem As RenderingItem _
)
Visual C++
public:
RenderingReference(
    RenderingItem^ renderingItem
)

Parameters

renderingItem
Type: Sitecore.Data.Items..::..RenderingItem
The rendering item.

See Also

RenderingReference Class
RenderingReference Overload
Sitecore.Layouts Namespace


RenderingReference Constructor (XmlNode, Language, Database)

[image]

Sitecore 6.4.1 API
RenderingReference Constructor (XmlNode, Language, Database)
RenderingReference Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderingReference(
    XmlNode configNode,
    Language language,
    Database database
)
Visual Basic
Public Sub New ( _
    configNode As XmlNode, _
    language As Language, _
    database As Database _
)
Visual C++
public:
RenderingReference(
    XmlNode^ configNode,
    Language^ language,
    Database^ database
)

Parameters

configNode
Type: System.Xml..::..XmlNode
The config node.
language
Type: Sitecore.Globalization..::..Language
The language.
database
Type: Sitecore.Data..::..Database
The database.

See Also

RenderingReference Class
RenderingReference Overload
Sitecore.Layouts Namespace


RenderingReference Constructor (RenderingDefinition, Language, Database)

[image]

Sitecore 6.4.1 API
RenderingReference Constructor (RenderingDefinition, Language, Database)
RenderingReference Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderingReference(
    RenderingDefinition renderingDefinition,
    Language language,
    Database database
)
Visual Basic
Public Sub New ( _
    renderingDefinition As RenderingDefinition, _
    language As Language, _
    database As Database _
)
Visual C++
public:
RenderingReference(
    RenderingDefinition^ renderingDefinition,
    Language^ language,
    Database^ database
)

Parameters

renderingDefinition
Type: Sitecore.Layouts..::..RenderingDefinition
The rendering definition.
language
Type: Sitecore.Globalization..::..Language
The language.
database
Type: Sitecore.Data..::..Database
The database.

See Also

RenderingReference Class
RenderingReference Overload
Sitecore.Layouts Namespace


RenderingReference Methods

[image] [image]

Sitecore 6.4.1 API
RenderingReference Methods
RenderingReference Class See Also Send Feedback

The RenderingReference type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControl | Gets the control.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetControl | Sets the control.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenderingReference Class
Sitecore.Layouts Namespace


GetControl Method

[image]

Sitecore 6.4.1 API
RenderingReference..::..GetControl Method
RenderingReference Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Control GetControl()
Visual Basic
Public Function GetControl As Control
Visual C++
public:
Control^ GetControl()

Return Value

[Missing <returns> documentation for "M:Sitecore.Layouts.RenderingReference.GetControl"]

See Also

RenderingReference Class
Sitecore.Layouts Namespace


SetControl Method

[image]

Sitecore 6.4.1 API
RenderingReference..::..SetControl Method
RenderingReference Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetControl(
    Control control
)
Visual Basic
Public Sub SetControl ( _
    control As Control _
)
Visual C++
public:
void SetControl(
    Control^ control
)

Parameters

control
Type: System.Web.UI..::..Control
The control.

See Also

RenderingReference Class
Sitecore.Layouts Namespace


RenderingReference Properties

[image] [image]

Sitecore 6.4.1 API
RenderingReference Properties
RenderingReference Class See Also Send Feedback

The RenderingReference type exposes the following members.

Properties

 | Name | Description
Public property | AddedToPage | Gets or sets a value indicating whether the rendering has been added to a page.
Public property | AddToFormIfUnused | Gets or sets a value indicating whether the RenderingReference adds the to form if unused.
Public property | Database | Gets the database.
Public property | FailureReason | Gets the failure reason.
Public property | Language | Gets the language.
Public property | Placeholder | Gets the placeholder.
Public property | RenderingID | Gets the rendering ID.
Public property | RenderingItem | Gets the rendering item.
Public property | Settings | Gets the settings.
Public property | UniqueId | Gets the unique ID.

See Also

RenderingReference Class
Sitecore.Layouts Namespace


AddedToPage Property

[image]

Sitecore 6.4.1 API
RenderingReference..::..AddedToPage Property
RenderingReference Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool AddedToPage { get; set; }
Visual Basic
Public Property AddedToPage As Boolean
    Get
    Set
Visual C++
public:
property bool AddedToPage {
    bool get ();
    void set (bool value);
}

Field Value

true if [the rendering was added to a page; otherwise, false.

See Also

RenderingReference Class
Sitecore.Layouts Namespace


AddToFormIfUnused Property

[image]

Sitecore 6.4.1 API
RenderingReference..::..AddToFormIfUnused Property
RenderingReference Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool AddToFormIfUnused { get; set; }
Visual Basic
Public Property AddToFormIfUnused As Boolean
    Get
    Set
Visual C++
public:
property bool AddToFormIfUnused {
    bool get ();
    void set (bool value);
}

Field Value

true if the RenderingReference adds the to form if unused; otherwise, false.

See Also

RenderingReference Class
Sitecore.Layouts Namespace


Database Property

[image]

Sitecore 6.4.1 API
RenderingReference..::..Database Property
RenderingReference Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database Database { get; }
Visual Basic
Public ReadOnly Property Database As Database
    Get
Visual C++
public:
property Database^ Database {
    Database^ get ();
}

Field Value

The database.

See Also

RenderingReference Class
Sitecore.Layouts Namespace


FailureReason Property

[image]

Sitecore 6.4.1 API
RenderingReference..::..FailureReason Property
RenderingReference Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FailureReason FailureReason { get; }
Visual Basic
Public ReadOnly Property FailureReason As FailureReason
    Get
Visual C++
public:
property FailureReason FailureReason {
    FailureReason get ();
}

Field Value

The failure reason.

See Also

RenderingReference Class
Sitecore.Layouts Namespace


Language Property

[image]

Sitecore 6.4.1 API
RenderingReference..::..Language Property
RenderingReference Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Language Language { get; }
Visual Basic
Public ReadOnly Property Language As Language
    Get
Visual C++
public:
property Language^ Language {
    Language^ get ();
}

Field Value

The language.

See Also

RenderingReference Class
Sitecore.Layouts Namespace


Placeholder Property

[image]

Sitecore 6.4.1 API
RenderingReference..::..Placeholder Property
RenderingReference Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Placeholder { get; set; }
Visual Basic
Public Property Placeholder As String
    Get
    Set
Visual C++
public:
property String^ Placeholder {
    String^ get ();
    void set (String^ value);
}

Field Value

The placeholder.

See Also

RenderingReference Class
Sitecore.Layouts Namespace


RenderingID Property

[image]

Sitecore 6.4.1 API
RenderingReference..::..RenderingID Property
RenderingReference Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID RenderingID { get; }
Visual Basic
Public ReadOnly Property RenderingID As ID
    Get
Visual C++
public:
property ID^ RenderingID {
    ID^ get ();
}

Field Value

The rendering ID.

See Also

RenderingReference Class
Sitecore.Layouts Namespace


RenderingItem Property

[image]

Sitecore 6.4.1 API
RenderingReference..::..RenderingItem Property
RenderingReference Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderingItem RenderingItem { get; }
Visual Basic
Public ReadOnly Property RenderingItem As RenderingItem
    Get
Visual C++
public:
property RenderingItem^ RenderingItem {
    RenderingItem^ get ();
}

Field Value

The rendering item.

See Also

RenderingReference Class
Sitecore.Layouts Namespace


Settings Property

[image]

Sitecore 6.4.1 API
RenderingReference..::..Settings Property
RenderingReference Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderingSettings Settings { get; }
Visual Basic
Public ReadOnly Property Settings As RenderingSettings
    Get
Visual C++
public:
property RenderingSettings^ Settings {
    RenderingSettings^ get ();
}

Field Value

The settings.

See Also

RenderingReference Class
Sitecore.Layouts Namespace


UniqueId Property

[image]

Sitecore 6.4.1 API
RenderingReference..::..UniqueId Property
RenderingReference Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string UniqueId { get; set; }
Visual Basic
Public Property UniqueId As String
    Get
    Set
Visual C++
public:
property String^ UniqueId {
    String^ get ();
    void set (String^ value);
}

Field Value

The unique ID.

See Also

RenderingReference Class
Sitecore.Layouts Namespace


RenderingReferenceList Class

[image]

Sitecore 6.4.1 API
RenderingReferenceList Class
Members See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RenderingReferenceList : ReadOnlyList<RenderingReference>
Visual Basic
Public Class RenderingReferenceList _
    Inherits ReadOnlyList(Of RenderingReference)
Visual C++
public ref class RenderingReferenceList : public ReadOnlyList<RenderingReference^>

Inheritance Hierarchy

System..::..Object
Sitecore.Collections..::..ReadOnlyList <(Of <(<' RenderingReference >)>)>
Sitecore.Layouts..::..RenderingReferenceList

See Also

RenderingReferenceList Members
Sitecore.Layouts Namespace


RenderingReferenceList Members

[image] [image]

Sitecore 6.4.1 API
RenderingReferenceList Members
RenderingReferenceList Class Constructors Methods Properties See Also Send Feedback

The RenderingReferenceList type exposes the following members.

Constructors

 | Name | Description
Public method | RenderingReferenceList()()()() | Initializes a new instance of the RenderingReferenceList class.
Public method | RenderingReferenceList(IEnumerable<(Of <<'(RenderingReference>)>>)) | Initializes a new instance of the RenderingReferenceList class.

Methods

 | Name | Description
Public method | Contains | Determines whether the list contains the specified element. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToArray | Converts the list to an array. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of entries in the list. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public property | Item | Gets the element at the specified index. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)

See Also

RenderingReferenceList Class
Sitecore.Layouts Namespace


RenderingReferenceList Constructor

[image]

Sitecore 6.4.1 API
RenderingReferenceList Constructor
RenderingReferenceList Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderingReferenceList()
Visual Basic
Public Sub New
Visual C++
public:
RenderingReferenceList()

See Also

RenderingReferenceList Class
RenderingReferenceList Overload
Sitecore.Layouts Namespace


RenderingReferenceList Constructor (IEnumerable(RenderingReference))

[image]

Sitecore 6.4.1 API
RenderingReferenceList Constructor (IEnumerable<(Of <(<'RenderingReference>)>)>)
RenderingReferenceList Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderingReferenceList(
    IEnumerable<RenderingReference> entries
)
Visual Basic
Public Sub New ( _
    entries As IEnumerable(Of RenderingReference) _
)
Visual C++
public:
RenderingReferenceList(
    IEnumerable<RenderingReference^>^ entries
)

Parameters

entries
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' RenderingReference >)>)>
The entries.

See Also

RenderingReferenceList Class
RenderingReferenceList Overload
Sitecore.Layouts Namespace


RenderingReferenceList Methods

[image] [image]

Sitecore 6.4.1 API
RenderingReferenceList Methods
RenderingReferenceList Class See Also Send Feedback

The RenderingReferenceList type exposes the following members.

Methods

 | Name | Description
Public method | Contains | Determines whether the list contains the specified element. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToArray | Converts the list to an array. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenderingReferenceList Class
Sitecore.Layouts Namespace


RenderingReferenceList Properties

[image] [image]

Sitecore 6.4.1 API
RenderingReferenceList Properties
RenderingReferenceList Class See Also Send Feedback

The RenderingReferenceList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of entries in the list. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)
Public property | Item | Gets the element at the specified index. (Inherited from ReadOnlyList<(Of <(<'TElement>)>)>.)

See Also

RenderingReferenceList Class
Sitecore.Layouts Namespace


RenderingSettings Class

[image]

Sitecore 6.4.1 API
RenderingSettings Class
Members See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RenderingSettings
Visual Basic
Public Class RenderingSettings
Visual C++
public ref class RenderingSettings

Inheritance Hierarchy

System..::..Object
Sitecore.Layouts..::..RenderingSettings

See Also

RenderingSettings Members
Sitecore.Layouts Namespace


RenderingSettings Constructor

[image]

Sitecore 6.4.1 API
RenderingSettings Constructor
RenderingSettings Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderingSettings()
Visual Basic
Public Sub New
Visual C++
public:
RenderingSettings()

See Also

RenderingSettings Class
Sitecore.Layouts Namespace


RenderingSettings Methods

[image] [image]

Sitecore 6.4.1 API
RenderingSettings Methods
RenderingSettings Class See Also Send Feedback

The RenderingSettings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenderingSettings Class
Sitecore.Layouts Namespace


RenderingSettings Properties

[image] [image]

Sitecore 6.4.1 API
RenderingSettings Properties
RenderingSettings Class See Also Send Feedback

The RenderingSettings type exposes the following members.

Properties

 | Name | Description
Public property | Caching | Gets or sets the caching information.
Public property | Conditions | Gets or sets the m_conditions.
Public property | DataSource | Gets or sets the data source.
Public property | MultiVariateTest | Gets or sets the multi variate test.
Public property | Parameters | Gets or sets the parameters.
Public property | Placeholder | Gets or sets the placeholder.

See Also

RenderingSettings Class
Sitecore.Layouts Namespace


Caching Property

[image]

Sitecore 6.4.1 API
RenderingSettings..::..Caching Property
RenderingSettings Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderingCaching Caching { get; set; }
Visual Basic
Public Property Caching As RenderingCaching
    Get
    Set
Visual C++
public:
property RenderingCaching^ Caching {
    RenderingCaching^ get ();
    void set (RenderingCaching^ value);
}

Field Value

The caching information.

See Also

RenderingSettings Class
Sitecore.Layouts Namespace


Conditions Property

[image]

Sitecore 6.4.1 API
RenderingSettings..::..Conditions Property
RenderingSettings Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Conditions { get; set; }
Visual Basic
Public Property Conditions As String
    Get
    Set
Visual C++
public:
property String^ Conditions {
    String^ get ();
    void set (String^ value);
}

Field Value

The m_conditions.

See Also

RenderingSettings Class
Sitecore.Layouts Namespace


DataSource Property

[image]

Sitecore 6.4.1 API
RenderingSettings..::..DataSource Property
RenderingSettings Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string DataSource { get; set; }
Visual Basic
Public Property DataSource As String
    Get
    Set
Visual C++
public:
property String^ DataSource {
    String^ get ();
    void set (String^ value);
}

Field Value

The data source.

See Also

RenderingSettings Class
Sitecore.Layouts Namespace


MultiVariateTest Property

[image]

Sitecore 6.4.1 API
RenderingSettings..::..MultiVariateTest Property
RenderingSettings Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string MultiVariateTest { get; set; }
Visual Basic
Public Property MultiVariateTest As String
    Get
    Set
Visual C++
public:
property String^ MultiVariateTest {
    String^ get ();
    void set (String^ value);
}

Field Value

The multi variate test.

See Also

RenderingSettings Class
Sitecore.Layouts Namespace


Parameters Property

[image]

Sitecore 6.4.1 API
RenderingSettings..::..Parameters Property
RenderingSettings Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Parameters { get; set; }
Visual Basic
Public Property Parameters As String
    Get
    Set
Visual C++
public:
property String^ Parameters {
    String^ get ();
    void set (String^ value);
}

Field Value

The parameters.

See Also

RenderingSettings Class
Sitecore.Layouts Namespace


Placeholder Property

[image]

Sitecore 6.4.1 API
RenderingSettings..::..Placeholder Property
RenderingSettings Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Placeholder { get; set; }
Visual Basic
Public Property Placeholder As String
    Get
    Set
Visual C++
public:
property String^ Placeholder {
    String^ get ();
    void set (String^ value);
}

Field Value

The placeholder.

See Also

RenderingSettings Class
Sitecore.Layouts Namespace


RuntimeHtml Class

[image]

Sitecore 6.4.1 API
RuntimeHtml Class
Members See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class RuntimeHtml
Visual Basic
Public NotInheritable Class RuntimeHtml
Visual C++
public ref class RuntimeHtml abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Layouts..::..RuntimeHtml

See Also

RuntimeHtml Members
Sitecore.Layouts Namespace


RuntimeHtml Members

[image] [image]

Sitecore 6.4.1 API
RuntimeHtml Members
RuntimeHtml Class Methods See Also Send Feedback

The RuntimeHtml type exposes the following members.

Methods

Name | Description
Convert(String) | Converts to runtime.
Convert(String, Boolean) | Converts to runtime.
FixBullets | Fixes the bullets.
FixSelectOptions | Fixes the select options.
Parse | Parses the specified HTML.

See Also

RuntimeHtml Class
Sitecore.Layouts Namespace


RuntimeHtml Methods

[image] [image]

Sitecore 6.4.1 API
RuntimeHtml Methods
RuntimeHtml Class See Also Send Feedback

The RuntimeHtml type exposes the following members.

Methods

Name | Description
Convert(String) | Converts to runtime.
Convert(String, Boolean) | Converts to runtime.
FixBullets | Fixes the bullets.
FixSelectOptions | Fixes the select options.
Parse | Parses the specified HTML.

See Also

RuntimeHtml Class
Sitecore.Layouts Namespace


Convert Method

[image] [image]

Sitecore 6.4.1 API
RuntimeHtml..::..Convert Method
RuntimeHtml Class See Also Send Feedback

Overload List

Name | Description
Convert(String) | Converts to runtime.
Convert(String, Boolean) | Converts to runtime.

See Also

RuntimeHtml Class
RuntimeHtml Members
Sitecore.Layouts Namespace


Convert Method (String)

[image]

Sitecore 6.4.1 API
RuntimeHtml..::..Convert Method (String)
RuntimeHtml Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Convert(
    string body
)
Visual Basic
Public Shared Function Convert ( _
    body As String _
) As String
Visual C++
public:
static String^ Convert(
    String^ body
)

Parameters

body
Type: System..::..String
The body.

Return Value

The runtime html.

See Also

RuntimeHtml Class
Convert Overload
Sitecore.Layouts Namespace


Convert Method (String, Boolean)

[image]

Sitecore 6.4.1 API
RuntimeHtml..::..Convert Method (String, Boolean)
RuntimeHtml Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Convert(
    string body,
    bool convertWebControls
)
Visual Basic
Public Shared Function Convert ( _
    body As String, _
    convertWebControls As Boolean _
) As String
Visual C++
public:
static String^ Convert(
    String^ body,
    bool convertWebControls
)

Parameters

body
Type: System..::..String
The body.
convertWebControls
Type: System..::..Boolean
if set to true this instance is convert web controls.

Return Value

The runtime html.

See Also

RuntimeHtml Class
Convert Overload
Sitecore.Layouts Namespace


FixBullets Method

[image]

Sitecore 6.4.1 API
RuntimeHtml..::..FixBullets Method
RuntimeHtml Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void FixBullets(
    HtmlDocument document
)
Visual Basic
Public Shared Sub FixBullets ( _
    document As HtmlDocument _
)
Visual C++
public:
static void FixBullets(
    HtmlDocument^ document
)

Parameters

document
Type: HtmlDocument
The document.

See Also

RuntimeHtml Class
Sitecore.Layouts Namespace


FixSelectOptions Method

[image]

Sitecore 6.4.1 API
RuntimeHtml..::..FixSelectOptions Method
RuntimeHtml Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void FixSelectOptions(
    HtmlDocument document
)
Visual Basic
Public Shared Sub FixSelectOptions ( _
    document As HtmlDocument _
)
Visual C++
public:
static void FixSelectOptions(
    HtmlDocument^ document
)

Parameters

document
Type: HtmlDocument
The document.

See Also

RuntimeHtml Class
Sitecore.Layouts Namespace


Parse Method

[image]

Sitecore 6.4.1 API
RuntimeHtml..::..Parse Method
RuntimeHtml Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Parse(
    string html,
    out string header,
    out string body,
    out string footer
)
Visual Basic
Public Shared Sub Parse ( _
    html As String, _
    <OutAttribute> ByRef header As String, _
    <OutAttribute> ByRef body As String, _
    <OutAttribute> ByRef footer As String _
)
Visual C++
public:
static void Parse(
    String^ html,
    [OutAttribute] String^% header,
    [OutAttribute] String^% body,
    [OutAttribute] String^% footer
)

Parameters

html
Type: System..::..String
The HTML.
header
Type: System..::..String %
The header.
body
Type: System..::..String %
The body.
footer
Type: System..::..String %
The footer.

See Also

RuntimeHtml Class
Sitecore.Layouts Namespace


XHtml Class

[image]

Sitecore 6.4.1 API
XHtml Class
Members See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class XHtml
Visual Basic
Public NotInheritable Class XHtml
Visual C++
public ref class XHtml abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Layouts..::..XHtml

See Also

XHtml Members
Sitecore.Layouts Namespace


XHtml Members

[image] [image]

Sitecore 6.4.1 API
XHtml Members
XHtml Class Methods See Also Send Feedback

The XHtml type exposes the following members.

Methods

Name | Description
Convert | Converts to XHtml.
ConvertToXml | Converts to XML.
Format(HtmlDocument) | Formats the specified HTML document.
Format(String) | Formats the specified HTML.
GetBody | Gets the body.
GetHtml | Gets the HTML.
GetInnerHtml | Returns inner HTML for item provided by xpath.
LoadHtmlDocument(String) | Loads the HTML document.
LoadHtmlDocument(String, Boolean) | Loads the HTML document.
MakeDocument(String) | Makes the XHTML document.
MakeDocument(String, Boolean) | Makes the XHTML document.
PrepareHtml | Prepares the HTML.
Validate | Validates the specified XHTML.

See Also

XHtml Class
Sitecore.Layouts Namespace


XHtml Methods

[image] [image]

Sitecore 6.4.1 API
XHtml Methods
XHtml Class See Also Send Feedback

The XHtml type exposes the following members.

Methods

Name | Description
Convert | Converts to XHtml.
ConvertToXml | Converts to XML.
Format(HtmlDocument) | Formats the specified HTML document.
Format(String) | Formats the specified HTML.
GetBody | Gets the body.
GetHtml | Gets the HTML.
GetInnerHtml | Returns inner HTML for item provided by xpath.
LoadHtmlDocument(String) | Loads the HTML document.
LoadHtmlDocument(String, Boolean) | Loads the HTML document.
MakeDocument(String) | Makes the XHTML document.
MakeDocument(String, Boolean) | Makes the XHTML document.
PrepareHtml | Prepares the HTML.
Validate | Validates the specified XHTML.

See Also

XHtml Class
Sitecore.Layouts Namespace


Convert Method

[image]

Sitecore 6.4.1 API
XHtml..::..Convert Method
XHtml Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Convert(
    string body
)
Visual Basic
Public Shared Function Convert ( _
    body As String _
) As String
Visual C++
public:
static String^ Convert(
    String^ body
)

Parameters

body
Type: System..::..String
The body.

Return Value

The convert body.

See Also

XHtml Class
Sitecore.Layouts Namespace


ConvertToXml Method

[image]

Sitecore 6.4.1 API
XHtml..::..ConvertToXml Method
XHtml Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ConvertToXml(
    string body
)
Visual Basic
Public Shared Function ConvertToXml ( _
    body As String _
) As String
Visual C++
public:
static String^ ConvertToXml(
    String^ body
)

Parameters

body
Type: System..::..String
The body.

Return Value

the body in Xml format.

See Also

XHtml Class
Sitecore.Layouts Namespace


Format Method

[image] [image]

Sitecore 6.4.1 API
XHtml..::..Format Method
XHtml Class See Also Send Feedback

Overload List

Name | Description
Format(HtmlDocument) | Formats the specified HTML document.
Format(String) | Formats the specified HTML.

See Also

XHtml Class
XHtml Members
Sitecore.Layouts Namespace


Format Method ()

[image]

Sitecore 6.4.1 API
XHtml..::..Format Method ()
XHtml Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Format(
    HtmlDocument htmlDocument
)
Visual Basic
Public Shared Function Format ( _
    htmlDocument As HtmlDocument _
) As String
Visual C++
public:
static String^ Format(
    HtmlDocument^ htmlDocument
)

Parameters

htmlDocument
Type: HtmlDocument
The HTML document.

Return Value

The format.

See Also

XHtml Class
Format Overload
Sitecore.Layouts Namespace


Format Method (String)

[image]

Sitecore 6.4.1 API
XHtml..::..Format Method (String)
XHtml Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Format(
    string html
)
Visual Basic
Public Shared Function Format ( _
    html As String _
) As String
Visual C++
public:
static String^ Format(
    String^ html
)

Parameters

html
Type: System..::..String
The HTML.

Return Value

The formatted HTML.

Exceptions

Exception | Condition
System.Xml..::..XmlException | The Html is valid valid Xml.
System..::..ArgumentNullException |

See Also

XHtml Class
Format Overload
Sitecore.Layouts Namespace


GetBody Method

[image]

Sitecore 6.4.1 API
XHtml..::..GetBody Method
XHtml Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetBody(
    string html
)
Visual Basic
Public Shared Function GetBody ( _
    html As String _
) As String
Visual C++
public:
static String^ GetBody(
    String^ html
)

Parameters

html
Type: System..::..String
The HTML.

Return Value

The body

See Also

XHtml Class
Sitecore.Layouts Namespace


GetHtml Method

[image]

Sitecore 6.4.1 API
XHtml..::..GetHtml Method
XHtml Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetHtml(
    HtmlDocument htmlDocument
)
Visual Basic
Public Shared Function GetHtml ( _
    htmlDocument As HtmlDocument _
) As String
Visual C++
public:
static String^ GetHtml(
    HtmlDocument^ htmlDocument
)

Parameters

htmlDocument
Type: HtmlDocument
The HTML document.

Return Value

The HTML.

See Also

XHtml Class
Sitecore.Layouts Namespace


GetInnerHtml Method

[image]

Sitecore 6.4.1 API
XHtml..::..GetInnerHtml Method
XHtml Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetInnerHtml(
    string document,
    string xpath
)
Visual Basic
Public Shared Function GetInnerHtml ( _
    document As String, _
    xpath As String _
) As String
Visual C++
public:
static String^ GetInnerHtml(
    String^ document,
    String^ xpath
)

Parameters

document
Type: System..::..String
The document.
xpath
Type: System..::..String
The xpath.

Return Value

Html from the node.

See Also

XHtml Class
Sitecore.Layouts Namespace


LoadHtmlDocument Method

[image] [image]

Sitecore 6.4.1 API
XHtml..::..LoadHtmlDocument Method
XHtml Class See Also Send Feedback

Overload List

Name | Description
LoadHtmlDocument(String) | Loads the HTML document.
LoadHtmlDocument(String, Boolean) | Loads the HTML document.

See Also

XHtml Class
XHtml Members
Sitecore.Layouts Namespace


LoadHtmlDocument Method (String)

[image]

Sitecore 6.4.1 API
XHtml..::..LoadHtmlDocument Method (String)
XHtml Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static HtmlDocument LoadHtmlDocument(
    string html
)
Visual Basic
Public Shared Function LoadHtmlDocument ( _
    html As String _
) As HtmlDocument
Visual C++
public:
static HtmlDocument^ LoadHtmlDocument(
    String^ html
)

Parameters

html
Type: System..::..String
The HTML.

Return Value

The HTML document.

See Also

XHtml Class
LoadHtmlDocument Overload
Sitecore.Layouts Namespace


LoadHtmlDocument Method (String, Boolean)

[image]

Sitecore 6.4.1 API
XHtml..::..LoadHtmlDocument Method (String, Boolean)
XHtml Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static HtmlDocument LoadHtmlDocument(
    string html,
    bool isXml
)
Visual Basic
Public Shared Function LoadHtmlDocument ( _
    html As String, _
    isXml As Boolean _
) As HtmlDocument
Visual C++
public:
static HtmlDocument^ LoadHtmlDocument(
    String^ html,
    bool isXml
)

Parameters

html
Type: System..::..String
The HTML.
isXml
Type: System..::..Boolean
if set to true [is XML].

Return Value

The HTML document.

See Also

XHtml Class
LoadHtmlDocument Overload
Sitecore.Layouts Namespace


MakeDocument Method

[image] [image]

Sitecore 6.4.1 API
XHtml..::..MakeDocument Method
XHtml Class See Also Send Feedback

Overload List

Name | Description
MakeDocument(String) | Makes the XHTML document.
MakeDocument(String, Boolean) | Makes the XHTML document.

See Also

XHtml Class
XHtml Members
Sitecore.Layouts Namespace


MakeDocument Method (String)

[image]

Sitecore 6.4.1 API
XHtml..::..MakeDocument Method (String)
XHtml Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string MakeDocument(
    string body
)
Visual Basic
Public Shared Function MakeDocument ( _
    body As String _
) As String
Visual C++
public:
static String^ MakeDocument(
    String^ body
)

Parameters

body
Type: System..::..String
The body.

Return Value

The XHTML document.

See Also

XHtml Class
MakeDocument Overload
Sitecore.Layouts Namespace


PrepareHtml Method

[image]

Sitecore 6.4.1 API
XHtml..::..PrepareHtml Method
XHtml Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string PrepareHtml(
    string html
)
Visual Basic
Public Shared Function PrepareHtml ( _
    html As String _
) As String
Visual C++
public:
static String^ PrepareHtml(
    String^ html
)

Parameters

html
Type: System..::..String
The HTML.

Return Value

The prepared HTML.

Exceptions

Exception | Condition
System..::..ArgumentNullException |

See Also

XHtml Class
Sitecore.Layouts Namespace


Validate Method

[image]

Sitecore 6.4.1 API
XHtml..::..Validate Method
XHtml Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Collection<XHtmlValidatorError> Validate(
    string xhtml
)
Visual Basic
Public Shared Function Validate ( _
    xhtml As String _
) As Collection(Of XHtmlValidatorError)
Visual C++
public:
static Collection<XHtmlValidatorError^>^ Validate(
    String^ xhtml
)

Parameters

xhtml
Type: System..::..String
The XHTML.

Return Value

The validation errors.

See Also

XHtml Class
Sitecore.Layouts Namespace


XHtmlValidator Class

[image]

Sitecore 6.4.1 API
XHtmlValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class XHtmlValidator
Visual Basic
Public Class XHtmlValidator
Visual C++
public ref class XHtmlValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Layouts..::..XHtmlValidator

See Also

XHtmlValidator Members
Sitecore.Layouts Namespace


XHtmlValidator Members

[image] [image]

Sitecore 6.4.1 API
XHtmlValidator Members
XHtmlValidator Class Constructors Methods Properties See Also Send Feedback

The XHtmlValidator type exposes the following members.

Constructors

 | Name | Description
Public method | XHtmlValidator | XHTMLs the validator.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Validate | Validates this instance.

Properties

 | Name | Description
Public property | ReportWarnings | Gets or sets a value indicating whether the XHtmlValidator reports the warnings.

See Also

XHtmlValidator Class
Sitecore.Layouts Namespace


XHtmlValidator Constructor

[image]

Sitecore 6.4.1 API
XHtmlValidator Constructor
XHtmlValidator Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public XHtmlValidator(
    string document
)
Visual Basic
Public Sub New ( _
    document As String _
)
Visual C++
public:
XHtmlValidator(
    String^ document
)

Parameters

document
Type: System..::..String
The input.

See Also

XHtmlValidator Class
Sitecore.Layouts Namespace


XHtmlValidator Methods

[image] [image]

Sitecore 6.4.1 API
XHtmlValidator Methods
XHtmlValidator Class See Also Send Feedback

The XHtmlValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Validate | Validates this instance.

See Also

XHtmlValidator Class
Sitecore.Layouts Namespace


Validate Method

[image]

Sitecore 6.4.1 API
XHtmlValidator..::..Validate Method
XHtmlValidator Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Collection<XHtmlValidatorError> Validate()
Visual Basic
Public Function Validate As Collection(Of XHtmlValidatorError)
Visual C++
public:
Collection<XHtmlValidatorError^>^ Validate()

Return Value

The validate.

See Also

XHtmlValidator Class
Sitecore.Layouts Namespace


XHtmlValidator Properties

[image] [image]

Sitecore 6.4.1 API
XHtmlValidator Properties
XHtmlValidator Class See Also Send Feedback

The XHtmlValidator type exposes the following members.

Properties

 | Name | Description
Public property | ReportWarnings | Gets or sets a value indicating whether the XHtmlValidator reports the warnings.

See Also

XHtmlValidator Class
Sitecore.Layouts Namespace


ReportWarnings Property

[image]

Sitecore 6.4.1 API
XHtmlValidator..::..ReportWarnings Property
XHtmlValidator Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ReportWarnings { get; set; }
Visual Basic
Public Property ReportWarnings As Boolean
    Get
    Set
Visual C++
public:
property bool ReportWarnings {
    bool get ();
    void set (bool value);
}

Field Value

true if the XHtmlValidator reports the warnings; otherwise, false.

See Also

XHtmlValidator Class
Sitecore.Layouts Namespace


XHtmlValidatorError Class

[image]

Sitecore 6.4.1 API
XHtmlValidatorError Class
Members See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class XHtmlValidatorError
Visual Basic
Public Class XHtmlValidatorError
Visual C++
public ref class XHtmlValidatorError

Inheritance Hierarchy

System..::..Object
Sitecore.Layouts..::..XHtmlValidatorError

See Also

XHtmlValidatorError Members
Sitecore.Layouts Namespace


XHtmlValidatorError Members

[image] [image]

Sitecore 6.4.1 API
XHtmlValidatorError Members
XHtmlValidatorError Class Constructors Methods Properties See Also Send Feedback

The XHtmlValidatorError type exposes the following members.

Constructors

 | Name | Description
Public method | XHtmlValidatorError(ValidationEventArgs) | Initializes a new instance of the XHtmlValidatorError class.
Public method | XHtmlValidatorError(XmlException) | Initializes a new instance of the XHtmlValidatorError class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | LineNumber | Gets the line number.
Public property | LinePosition | Gets the line position.
Public property | Message | Gets the message.
Public property | Severity | Gets the severity.

See Also

XHtmlValidatorError Class
Sitecore.Layouts Namespace


XHtmlValidatorError Constructor

[image] [image]

Sitecore 6.4.1 API
XHtmlValidatorError Constructor
XHtmlValidatorError Class See Also Send Feedback

Overload List

 | Name | Description
Public method | XHtmlValidatorError(ValidationEventArgs) | Initializes a new instance of the XHtmlValidatorError class.
Public method | XHtmlValidatorError(XmlException) | Initializes a new instance of the XHtmlValidatorError class.

See Also

XHtmlValidatorError Class
XHtmlValidatorError Members
Sitecore.Layouts Namespace


XHtmlValidatorError Constructor (ValidationEventArgs)

[image]

Sitecore 6.4.1 API
XHtmlValidatorError Constructor (ValidationEventArgs)
XHtmlValidatorError Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public XHtmlValidatorError(
    ValidationEventArgs args
)
Visual Basic
Public Sub New ( _
    args As ValidationEventArgs _
)
Visual C++
public:
XHtmlValidatorError(
    ValidationEventArgs^ args
)

Parameters

args
Type: System.Xml.Schema..::..ValidationEventArgs
The arguments.

See Also

XHtmlValidatorError Class
XHtmlValidatorError Overload
Sitecore.Layouts Namespace


XHtmlValidatorError Constructor (XmlException)

[image]

Sitecore 6.4.1 API
XHtmlValidatorError Constructor (XmlException)
XHtmlValidatorError Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public XHtmlValidatorError(
    XmlException exception
)
Visual Basic
Public Sub New ( _
    exception As XmlException _
)
Visual C++
public:
XHtmlValidatorError(
    XmlException^ exception
)

Parameters

exception
Type: System.Xml..::..XmlException
The XML exc.

See Also

XHtmlValidatorError Class
XHtmlValidatorError Overload
Sitecore.Layouts Namespace


XHtmlValidatorError Methods

[image] [image]

Sitecore 6.4.1 API
XHtmlValidatorError Methods
XHtmlValidatorError Class See Also Send Feedback

The XHtmlValidatorError type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

XHtmlValidatorError Class
Sitecore.Layouts Namespace


ToString Method

[image]

Sitecore 6.4.1 API
XHtmlValidatorError..::..ToString Method
XHtmlValidatorError Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

XHtmlValidatorError Class
Sitecore.Layouts Namespace


XHtmlValidatorError Properties

[image] [image]

Sitecore 6.4.1 API
XHtmlValidatorError Properties
XHtmlValidatorError Class See Also Send Feedback

The XHtmlValidatorError type exposes the following members.

Properties

 | Name | Description
Public property | LineNumber | Gets the line number.
Public property | LinePosition | Gets the line position.
Public property | Message | Gets the message.
Public property | Severity | Gets the severity.

See Also

XHtmlValidatorError Class
Sitecore.Layouts Namespace


LineNumber Property

[image]

Sitecore 6.4.1 API
XHtmlValidatorError..::..LineNumber Property
XHtmlValidatorError Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int LineNumber { get; }
Visual Basic
Public ReadOnly Property LineNumber As Integer
    Get
Visual C++
public:
property int LineNumber {
    int get ();
}

Field Value

The line number.

See Also

XHtmlValidatorError Class
Sitecore.Layouts Namespace


LinePosition Property

[image]

Sitecore 6.4.1 API
XHtmlValidatorError..::..LinePosition Property
XHtmlValidatorError Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int LinePosition { get; }
Visual Basic
Public ReadOnly Property LinePosition As Integer
    Get
Visual C++
public:
property int LinePosition {
    int get ();
}

Field Value

The line position.

See Also

XHtmlValidatorError Class
Sitecore.Layouts Namespace


Message Property

[image]

Sitecore 6.4.1 API
XHtmlValidatorError..::..Message Property
XHtmlValidatorError Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Message { get; }
Visual Basic
Public ReadOnly Property Message As String
    Get
Visual C++
public:
property String^ Message {
    String^ get ();
}

Field Value

The message.

See Also

XHtmlValidatorError Class
Sitecore.Layouts Namespace


Severity Property

[image]

Sitecore 6.4.1 API
XHtmlValidatorError..::..Severity Property
XHtmlValidatorError Class See Also Send Feedback

Namespace: Sitecore.Layouts
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public XmlSeverityType Severity { get; }
Visual Basic
Public ReadOnly Property Severity As XmlSeverityType
    Get
Visual C++
public:
property XmlSeverityType Severity {
    XmlSeverityType get ();
}

Field Value

The severity.

See Also

XHtmlValidatorError Class
Sitecore.Layouts Namespace


Sitecore.Layouts.PageExtenders Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Layouts.PageExtenders Namespace
Send Feedback

Classes

 | Class | Description
Public class | DebuggerPageExtender | The page debugger.
Public class | PageExtender | Defines the basic properties and functionality of a page extender.
Public class | PreviewPageExtender | Preview page extender.
Public class | WebEditPageExtender | WebEdit page extender.


DebuggerPageExtender Class

[image]

Sitecore 6.4.1 API
DebuggerPageExtender Class
Members See Also Send Feedback

Namespace: Sitecore.Layouts.PageExtenders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DebuggerPageExtender : PageExtender
Visual Basic
Public Class DebuggerPageExtender _
    Inherits PageExtender
Visual C++
public ref class DebuggerPageExtender : public PageExtender

Inheritance Hierarchy

System..::..Object
Sitecore.Layouts.PageExtenders..::..PageExtender
Sitecore.Layouts.PageExtenders..::..DebuggerPageExtender

See Also

DebuggerPageExtender Members
Sitecore.Layouts.PageExtenders Namespace


DebuggerPageExtender Members

[image] [image]

Sitecore 6.4.1 API
DebuggerPageExtender Members
DebuggerPageExtender Class Constructors Methods See Also Send Feedback

The DebuggerPageExtender type exposes the following members.

Constructors

 | Name | Description
Public method | DebuggerPageExtender | Initializes a new instance of the DebuggerPageExtender class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Inserts the page extender into the page. (Overrides PageExtender..::..Insert()()()().)
Protected method | InsertControl | Inserts the control. (Inherited from PageExtender.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DebuggerPageExtender Class
Sitecore.Layouts.PageExtenders Namespace


DebuggerPageExtender Constructor

[image]

Sitecore 6.4.1 API
DebuggerPageExtender Constructor
DebuggerPageExtender Class See Also Send Feedback

Namespace: Sitecore.Layouts.PageExtenders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DebuggerPageExtender()
Visual Basic
Public Sub New
Visual C++
public:
DebuggerPageExtender()

See Also

DebuggerPageExtender Class
Sitecore.Layouts.PageExtenders Namespace


DebuggerPageExtender Methods

[image] [image]

Sitecore 6.4.1 API
DebuggerPageExtender Methods
DebuggerPageExtender Class See Also Send Feedback

The DebuggerPageExtender type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Inserts the page extender into the page. (Overrides PageExtender..::..Insert()()()().)
Protected method | InsertControl | Inserts the control. (Inherited from PageExtender.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DebuggerPageExtender Class
Sitecore.Layouts.PageExtenders Namespace


Insert Method

[image]

Sitecore 6.4.1 API
DebuggerPageExtender..::..Insert Method
DebuggerPageExtender Class See Also Send Feedback

Namespace: Sitecore.Layouts.PageExtenders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Insert()
Visual Basic
Public Overrides Sub Insert
Visual C++
public:
virtual void Insert() override

See Also

DebuggerPageExtender Class
Sitecore.Layouts.PageExtenders Namespace


PageExtender Class

[image]

Sitecore 6.4.1 API
PageExtender Class
Members See Also Send Feedback

Namespace: Sitecore.Layouts.PageExtenders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class PageExtender
Visual Basic
Public MustInherit Class PageExtender
Visual C++
public ref class PageExtender abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Layouts.PageExtenders..::..PageExtender
Sitecore.Layouts.PageExtenders..::..DebuggerPageExtender
Sitecore.Layouts.PageExtenders..::..PreviewPageExtender
Sitecore.Layouts.PageExtenders..::..WebEditPageExtender

See Also

PageExtender Members
Sitecore.Layouts.PageExtenders Namespace


PageExtender Members

[image] [image]

Sitecore 6.4.1 API
PageExtender Members
PageExtender Class Constructors Methods See Also Send Feedback

The PageExtender type exposes the following members.

Constructors

 | Name | Description
Protected method | PageExtender | Initializes a new instance of the PageExtender class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Inserts the page extender into the page.
Protected method | InsertControl | Inserts the control.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PageExtender Class
Sitecore.Layouts.PageExtenders Namespace


PageExtender Constructor

[image]

Sitecore 6.4.1 API
PageExtender Constructor
PageExtender Class See Also Send Feedback

Namespace: Sitecore.Layouts.PageExtenders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected PageExtender()
Visual Basic
Protected Sub New
Visual C++
protected:
PageExtender()

See Also

PageExtender Class
Sitecore.Layouts.PageExtenders Namespace


PageExtender Methods

[image] [image]

Sitecore 6.4.1 API
PageExtender Methods
PageExtender Class See Also Send Feedback

The PageExtender type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Inserts the page extender into the page.
Protected method | InsertControl | Inserts the control.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PageExtender Class
Sitecore.Layouts.PageExtenders Namespace


Insert Method

[image]

Sitecore 6.4.1 API
PageExtender..::..Insert Method
PageExtender Class See Also Send Feedback

Namespace: Sitecore.Layouts.PageExtenders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract void Insert()
Visual Basic
Public MustOverride Sub Insert
Visual C++
public:
virtual void Insert() abstract

See Also

PageExtender Class
Sitecore.Layouts.PageExtenders Namespace


InsertControl Method

[image]

Sitecore 6.4.1 API
PageExtender..::..InsertControl Method
PageExtender Class See Also Send Feedback

Namespace: Sitecore.Layouts.PageExtenders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void InsertControl(
    Control control
)
Visual Basic
Protected Sub InsertControl ( _
    control As Control _
)
Visual C++
protected:
void InsertControl(
    Control^ control
)

Parameters

control
Type: System.Web.UI..::..Control
The control.

See Also

PageExtender Class
Sitecore.Layouts.PageExtenders Namespace


PreviewPageExtender Class

[image]

Sitecore 6.4.1 API
PreviewPageExtender Class
Members See Also Send Feedback

Namespace: Sitecore.Layouts.PageExtenders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PreviewPageExtender : PageExtender
Visual Basic
Public Class PreviewPageExtender _
    Inherits PageExtender
Visual C++
public ref class PreviewPageExtender : public PageExtender

Inheritance Hierarchy

System..::..Object
Sitecore.Layouts.PageExtenders..::..PageExtender
Sitecore.Layouts.PageExtenders..::..PreviewPageExtender

See Also

PreviewPageExtender Members
Sitecore.Layouts.PageExtenders Namespace


PreviewPageExtender Members

[image] [image]

Sitecore 6.4.1 API
PreviewPageExtender Members
PreviewPageExtender Class Constructors Methods See Also Send Feedback

The PreviewPageExtender type exposes the following members.

Constructors

 | Name | Description
Public method | PreviewPageExtender | Initializes a new instance of the PreviewPageExtender class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Inserts the page extender into the page. (Overrides PageExtender..::..Insert()()()().)
Protected method | InsertControl | Inserts the control. (Inherited from PageExtender.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PreviewPageExtender Class
Sitecore.Layouts.PageExtenders Namespace


PreviewPageExtender Constructor

[image]

Sitecore 6.4.1 API
PreviewPageExtender Constructor
PreviewPageExtender Class See Also Send Feedback

Namespace: Sitecore.Layouts.PageExtenders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PreviewPageExtender()
Visual Basic
Public Sub New
Visual C++
public:
PreviewPageExtender()

See Also

PreviewPageExtender Class
Sitecore.Layouts.PageExtenders Namespace


PreviewPageExtender Methods

[image] [image]

Sitecore 6.4.1 API
PreviewPageExtender Methods
PreviewPageExtender Class See Also Send Feedback

The PreviewPageExtender type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Inserts the page extender into the page. (Overrides PageExtender..::..Insert()()()().)
Protected method | InsertControl | Inserts the control. (Inherited from PageExtender.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PreviewPageExtender Class
Sitecore.Layouts.PageExtenders Namespace


Insert Method

[image]

Sitecore 6.4.1 API
PreviewPageExtender..::..Insert Method
PreviewPageExtender Class See Also Send Feedback

Namespace: Sitecore.Layouts.PageExtenders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Insert()
Visual Basic
Public Overrides Sub Insert
Visual C++
public:
virtual void Insert() override

See Also

PreviewPageExtender Class
Sitecore.Layouts.PageExtenders Namespace


WebEditPageExtender Class

[image]

Sitecore 6.4.1 API
WebEditPageExtender Class
Members See Also Send Feedback

Namespace: Sitecore.Layouts.PageExtenders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class WebEditPageExtender : PageExtender
Visual Basic
Public Class WebEditPageExtender _
    Inherits PageExtender
Visual C++
public ref class WebEditPageExtender : public PageExtender

Inheritance Hierarchy

System..::..Object
Sitecore.Layouts.PageExtenders..::..PageExtender
Sitecore.Layouts.PageExtenders..::..WebEditPageExtender

See Also

WebEditPageExtender Members
Sitecore.Layouts.PageExtenders Namespace


WebEditPageExtender Members

[image] [image]

Sitecore 6.4.1 API
WebEditPageExtender Members
WebEditPageExtender Class Constructors Methods See Also Send Feedback

The WebEditPageExtender type exposes the following members.

Constructors

 | Name | Description
Public method | WebEditPageExtender | Initializes a new instance of the WebEditPageExtender class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Inserts the page extender into the page. (Overrides PageExtender..::..Insert()()()().)
Protected method | InsertControl | Inserts the control. (Inherited from PageExtender.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WebEditPageExtender Class
Sitecore.Layouts.PageExtenders Namespace


WebEditPageExtender Constructor

[image]

Sitecore 6.4.1 API
WebEditPageExtender Constructor
WebEditPageExtender Class See Also Send Feedback

Namespace: Sitecore.Layouts.PageExtenders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WebEditPageExtender()
Visual Basic
Public Sub New
Visual C++
public:
WebEditPageExtender()

See Also

WebEditPageExtender Class
Sitecore.Layouts.PageExtenders Namespace


WebEditPageExtender Methods

[image] [image]

Sitecore 6.4.1 API
WebEditPageExtender Methods
WebEditPageExtender Class See Also Send Feedback

The WebEditPageExtender type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Inserts the page extender into the page. (Overrides PageExtender..::..Insert()()()().)
Protected method | InsertControl | Inserts the control. (Inherited from PageExtender.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WebEditPageExtender Class
Sitecore.Layouts.PageExtenders Namespace


Insert Method

[image]

Sitecore 6.4.1 API
WebEditPageExtender..::..Insert Method
WebEditPageExtender Class See Also Send Feedback

Namespace: Sitecore.Layouts.PageExtenders
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Insert()
Visual Basic
Public Overrides Sub Insert
Visual C++
public:
virtual void Insert() override

See Also

WebEditPageExtender Class
Sitecore.Layouts.PageExtenders Namespace


Sitecore.layouts.testing Namespace

[image]

Sitecore 6.4.1 API
Sitecore.layouts.testing Namespace
Send Feedback

Classes

 | Class | Description
Public class | test |


test Class

[image]

Sitecore 6.4.1 API
test Class
Members See Also Send Feedback

Namespace: Sitecore.layouts.testing
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class test : Page
Visual Basic
Public Class test _
    Inherits Page
Visual C++
public ref class test : public Page

Remarks

Auto-generated class.

Inheritance Hierarchy

System..::..Object
System.Web.UI..::..Control
System.Web.UI..::..TemplateControl
System.Web.UI..::..Page
Sitecore.layouts.testing..::..test

See Also

test Members
Sitecore.layouts.testing Namespace


test Members

[image] [image]

Sitecore 6.4.1 API
test Members
test Class Constructors Methods Fields Properties Events See Also Send Feedback

The test type exposes the following members.

Constructors

 | Name | Description
Public method | test | Initializes a new instance of the test class

Methods

 | Name | Description
Protected method | AccountTest | Accounts the test.
Protected method | AddContentTemplate | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Public method | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
Public method | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Protected method | AddWrappedFileDependencies | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | ArchiveTest | Tests this instance.
Protected method | AspCompatBeginProcessRequest | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
Protected method | AspCompatEndProcessRequest | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
Protected method | AsyncPageBeginProcessRequest | Begins processing an asynchronous page request. (Inherited from Page.)
Protected method | AsyncPageEndProcessRequest | Ends processing an asynchronous page request. (Inherited from Page.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Protected method | Construct | Performs design-time logic. (Inherited from TemplateControl.)
Protected method | CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Protected method | CreateHtmlTextWriter | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
Protected method | CreateResourceBasedLiteralControl | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Public method | DesignerInitialize | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
Protected method | DeterminePostBackMode | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
Protected method | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
Public method | ExecuteRegisteredAsyncTasks | Starts the execution of an asynchronous task. (Inherited from Page.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | FrameworkInitialize | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
Public method | GetDataItem | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Protected method | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
Protected method | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
Protected method | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
Public method | GetPostBackClientEvent | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
Public method | GetPostBackClientHyperlink | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
Public method | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
Public method | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeHashCode | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
Public method | GetValidators | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
Protected method | GetWrappedFileDependencies | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
Protected method | goButtonClick | Goes the button click.
Protected method | goButtonClick2 | Goes the button click.
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Protected method | InitializeCulture | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
Protected method | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
Protected method | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
Protected method | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
Public method | IsClientScriptBlockRegistered | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Public method | IsStartupScriptRegistered | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
Public method | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
Public method | LoadControl(Type, array<Object>[]()[][]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
Protected method | LoadPageStateFromPersistenceMedium | Loads any saved view-state information to the Page object. (Inherited from Page.)
Public method | LoadTemplate | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
Protected method | LoadViewState | Restores view-state information from a previous page request that was saved by the SaveViewState()()()() method. (Inherited from Control.)
Public method | MapPath | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | old_goButtonClick | Goes the button click.
Protected method | OnAbortTransaction | Raises the AbortTransaction event. (Inherited from TemplateControl.)
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnCommitTransaction | Raises the CommitTransaction event. (Inherited from TemplateControl.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnError | Raises the Error event. (Inherited from TemplateControl.)
Protected method | OnInit | Raises the Init event to initialize the page. (Inherited from Page.)
Protected method | OnInitComplete | Raises the InitComplete event after page initialization. (Inherited from Page.)
Protected method | OnLoad | Raises the Load event. (Inherited from Control.)
Protected method | OnLoadComplete | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
Protected method | OnPreInit | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
Protected method | OnPreLoad | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
Protected method | OnPreRender | Raises the PreRender event. (Inherited from Control.)
Protected method | OnPreRenderComplete | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
Protected method | OnSaveStateComplete | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Public method | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
Public method | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
Public method | ProcessRequest | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Protected method | RaisePostBackEvent | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
Public method | ReadStringResource | Reads a string resource. The ReadStringResource()()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | RegisterArrayDeclaration | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
Public method | RegisterAsyncTask | Registers a new asynchronous task with the page. (Inherited from Page.)
Public method | RegisterClientScriptBlock | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
Public method | RegisterHiddenField | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
Public method | RegisterOnSubmitStatement | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
Public method | RegisterRequiresControlState | Registers a control as one whose control state must be persisted. (Inherited from Page.)
Public method | RegisterRequiresPostBack | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
Public method | RegisterRequiresRaiseEvent | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
Public method | RegisterRequiresViewStateEncryption | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
Public method | RegisterStartupScript | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
Public method | RegisterViewStateHandler | Causes page view state to be persisted, if called. (Inherited from Page.)
Protected method | RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Protected method | Render | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Public method | RequiresControlState | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SavePageStateToPersistenceMedium | Saves any view-state and control-state information for the page. (Inherited from Page.)
Protected method | SaveViewState | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
Public method | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Protected method | SetStringResourcePointer | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | TestDeviceFilter | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
Protected method | TestLinkParser | Tests the link parser.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TrackViewState | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
Public method | UnregisterRequiresControlState | Stops persistence of control state for the specified control. (Inherited from Page.)
Public method | Validate()()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
Public method | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
Public method | VerifyRenderingInServerForm | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
Protected method | WriteUTF8ResourceString | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
Protected method | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
Protected method | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
Protected method | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
Protected method | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
Protected method | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Protected method | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)

Fields

 | Name | Description
Protected field | form1 | form1 control.
Protected field | goButton | goButton control.

Properties

 | Name | Description
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
Protected property | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
Protected property | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
Public property | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
Protected property | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
Public property | AutoPostBackControl | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
Public property | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Public property | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
Public property | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
Public property | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
Public property | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
Public property | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
Protected property | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
Public property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
Public property | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Public property | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
Public property | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
Public property | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
Public property | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
Public property | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Protected property | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
Public property | Form | Gets the HTML form for the page. (Inherited from Page.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Public property | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
Public property | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
Public property | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
Public property | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
Public property | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Public property | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
Public property | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
Public property | IsPostBackEventControlRegistered | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
Public property | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Public property | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Public property | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
Public property | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Public property | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
Public property | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
Public property | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
Public property | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
Protected property | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
Public property | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
Public property | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
Public property | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
Public property | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
Public property | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
Public property | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
Public property | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
Public property | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
Protected property | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
Public property | Title | Gets or sets the title for the page. (Inherited from Page.)
Public property | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
Public property | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
Public property | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
Protected property | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
Public property | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
Protected property | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
Public property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
Public property | User | Gets information about the user making the page request. (Inherited from Page.)
Public property | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Public property | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
Public property | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)

Events

 | Name | Description
Public event | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
Public event | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
Public event | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
Public event | PreLoad | Occurs before the page Load event. (Inherited from Page.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
Public event | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

See Also

test Class
Sitecore.layouts.testing Namespace


test Constructor

[image]

Sitecore 6.4.1 API
test Constructor
test Class See Also Send Feedback

Namespace: Sitecore.layouts.testing
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public test()
Visual Basic
Public Sub New
Visual C++
public:
test()

See Also

test Class
Sitecore.layouts.testing Namespace


test Fields

[image] [image]

Sitecore 6.4.1 API
test Fields
test Class See Also Send Feedback

The test type exposes the following members.

Fields

 | Name | Description
Protected field | form1 | form1 control.
Protected field | goButton | goButton control.

See Also

test Class
Sitecore.layouts.testing Namespace


form1 Field

[image]

Sitecore 6.4.1 API
test..::..form1 Field
test Class See Also Send Feedback

Namespace: Sitecore.layouts.testing
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected HtmlForm form1
Visual Basic
Protected form1 As HtmlForm
Visual C++
protected:
HtmlForm^ form1

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

test Class
Sitecore.layouts.testing Namespace


goButton Field

[image]

Sitecore 6.4.1 API
test..::..goButton Field
test Class See Also Send Feedback

Namespace: Sitecore.layouts.testing
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Button goButton
Visual Basic
Protected goButton As Button
Visual C++
protected:
Button^ goButton

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

test Class
Sitecore.layouts.testing Namespace


test Methods

[image] [image]

Sitecore 6.4.1 API
test Methods
test Class See Also Send Feedback

The test type exposes the following members.

Methods

 | Name | Description
Protected method | AccountTest | Accounts the test.
Protected method | AddContentTemplate | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Public method | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
Public method | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Protected method | AddWrappedFileDependencies | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | ArchiveTest | Tests this instance.
Protected method | AspCompatBeginProcessRequest | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
Protected method | AspCompatEndProcessRequest | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
Protected method | AsyncPageBeginProcessRequest | Begins processing an asynchronous page request. (Inherited from Page.)
Protected method | AsyncPageEndProcessRequest | Ends processing an asynchronous page request. (Inherited from Page.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Protected method | Construct | Performs design-time logic. (Inherited from TemplateControl.)
Protected method | CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Protected method | CreateHtmlTextWriter | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
Protected method | CreateResourceBasedLiteralControl | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Public method | DesignerInitialize | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
Protected method | DeterminePostBackMode | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
Protected method | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
Public method | ExecuteRegisteredAsyncTasks | Starts the execution of an asynchronous task. (Inherited from Page.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | FrameworkInitialize | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
Public method | GetDataItem | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Protected method | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
Protected method | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
Protected method | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
Public method | GetPostBackClientEvent | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
Public method | GetPostBackClientHyperlink | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
Public method | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
Public method | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeHashCode | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
Public method | GetValidators | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
Protected method | GetWrappedFileDependencies | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
Protected method | goButtonClick | Goes the button click.
Protected method | goButtonClick2 | Goes the button click.
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Protected method | InitializeCulture | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
Protected method | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
Protected method | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
Protected method | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
Public method | IsClientScriptBlockRegistered | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Public method | IsStartupScriptRegistered | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
Public method | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
Public method | LoadControl(Type, array<Object>[]()[][]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
Protected method | LoadPageStateFromPersistenceMedium | Loads any saved view-state information to the Page object. (Inherited from Page.)
Public method | LoadTemplate | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
Protected method | LoadViewState | Restores view-state information from a previous page request that was saved by the SaveViewState()()()() method. (Inherited from Control.)
Public method | MapPath | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | old_goButtonClick | Goes the button click.
Protected method | OnAbortTransaction | Raises the AbortTransaction event. (Inherited from TemplateControl.)
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnCommitTransaction | Raises the CommitTransaction event. (Inherited from TemplateControl.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnError | Raises the Error event. (Inherited from TemplateControl.)
Protected method | OnInit | Raises the Init event to initialize the page. (Inherited from Page.)
Protected method | OnInitComplete | Raises the InitComplete event after page initialization. (Inherited from Page.)
Protected method | OnLoad | Raises the Load event. (Inherited from Control.)
Protected method | OnLoadComplete | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
Protected method | OnPreInit | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
Protected method | OnPreLoad | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
Protected method | OnPreRender | Raises the PreRender event. (Inherited from Control.)
Protected method | OnPreRenderComplete | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
Protected method | OnSaveStateComplete | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Public method | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
Public method | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
Public method | ProcessRequest | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Protected method | RaisePostBackEvent | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
Public method | ReadStringResource | Reads a string resource. The ReadStringResource()()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | RegisterArrayDeclaration | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
Public method | RegisterAsyncTask | Registers a new asynchronous task with the page. (Inherited from Page.)
Public method | RegisterClientScriptBlock | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
Public method | RegisterHiddenField | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
Public method | RegisterOnSubmitStatement | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
Public method | RegisterRequiresControlState | Registers a control as one whose control state must be persisted. (Inherited from Page.)
Public method | RegisterRequiresPostBack | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
Public method | RegisterRequiresRaiseEvent | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
Public method | RegisterRequiresViewStateEncryption | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
Public method | RegisterStartupScript | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
Public method | RegisterViewStateHandler | Causes page view state to be persisted, if called. (Inherited from Page.)
Protected method | RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Protected method | Render | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Public method | RequiresControlState | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SavePageStateToPersistenceMedium | Saves any view-state and control-state information for the page. (Inherited from Page.)
Protected method | SaveViewState | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
Public method | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Protected method | SetStringResourcePointer | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | TestDeviceFilter | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
Protected method | TestLinkParser | Tests the link parser.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TrackViewState | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
Public method | UnregisterRequiresControlState | Stops persistence of control state for the specified control. (Inherited from Page.)
Public method | Validate()()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
Public method | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
Public method | VerifyRenderingInServerForm | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
Protected method | WriteUTF8ResourceString | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
Protected method | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
Protected method | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
Protected method | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
Protected method | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
Protected method | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Protected method | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)

See Also

test Class
Sitecore.layouts.testing Namespace


AccountTest Method

[image]

Sitecore 6.4.1 API
test..::..AccountTest Method
test Class See Also Send Feedback

Namespace: Sitecore.layouts.testing
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void AccountTest()
Visual Basic
Protected Sub AccountTest
Visual C++
protected:
void AccountTest()

See Also

test Class
Sitecore.layouts.testing Namespace


DataBind Method

[image] [image]

Sitecore 6.4.1 API
test..::..DataBind Method
test Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)

See Also

test Class
test Members
Sitecore.layouts.testing Namespace


Eval Method

[image] [image]

Sitecore 6.4.1 API
test..::..Eval Method
test Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
Protected method | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)

See Also

test Class
test Members
Sitecore.layouts.testing Namespace


FindControl Method

[image] [image]

Sitecore 6.4.1 API
test..::..FindControl Method
test Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)

See Also

test Class
test Members
Sitecore.layouts.testing Namespace


GetGlobalResourceObject Method

[image] [image]

Sitecore 6.4.1 API
test..::..GetGlobalResourceObject Method
test Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
Protected method | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)

See Also

test Class
test Members
Sitecore.layouts.testing Namespace


GetLocalResourceObject Method

[image] [image]

Sitecore 6.4.1 API
test..::..GetLocalResourceObject Method
test Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
Protected method | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)

See Also

test Class
test Members
Sitecore.layouts.testing Namespace


GetPostBackEventReference Method

[image] [image]

Sitecore 6.4.1 API
test..::..GetPostBackEventReference Method
test Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
Public method | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)

See Also

test Class
test Members
Sitecore.layouts.testing Namespace


goButtonClick Method

[image]

Sitecore 6.4.1 API
test..::..goButtonClick Method
test Class See Also Send Feedback

Namespace: Sitecore.layouts.testing
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void goButtonClick(
    Object sender,
    EventArgs e
)
Visual Basic
Protected Sub goButtonClick ( _
    sender As Object, _
    e As EventArgs _
)
Visual C++
protected:
void goButtonClick(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: System..::..Object
The sender.
e
Type: System..::..EventArgs
The EventArgs instance containing the event data.

See Also

test Class
Sitecore.layouts.testing Namespace


goButtonClick2 Method

[image]

Sitecore 6.4.1 API
test..::..goButtonClick2 Method
test Class See Also Send Feedback

Namespace: Sitecore.layouts.testing
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void goButtonClick2(
    Object sender,
    EventArgs e
)
Visual Basic
Protected Sub goButtonClick2 ( _
    sender As Object, _
    e As EventArgs _
)
Visual C++
protected:
void goButtonClick2(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: System..::..Object
The sender.
e
Type: System..::..EventArgs
The EventArgs instance containing the event data.

See Also

test Class
Sitecore.layouts.testing Namespace


InitOutputCache Method

[image] [image]

Sitecore 6.4.1 API
test..::..InitOutputCache Method
test Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
Protected method | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
Protected method | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)

See Also

test Class
test Members
Sitecore.layouts.testing Namespace


LoadControl Method

[image] [image]

Sitecore 6.4.1 API
test..::..LoadControl Method
test Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
Public method | LoadControl(Type, array<Object>[]()[][]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)

See Also

test Class
test Members
Sitecore.layouts.testing Namespace


old_goButtonClick Method

[image]

Sitecore 6.4.1 API
test..::..old_goButtonClick Method
test Class See Also Send Feedback

Namespace: Sitecore.layouts.testing
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void old_goButtonClick(
    Object sender,
    EventArgs e
)
Visual Basic
Protected Sub old_goButtonClick ( _
    sender As Object, _
    e As EventArgs _
)
Visual C++
protected:
void old_goButtonClick(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: System..::..Object
The sender.
e
Type: System..::..EventArgs
The EventArgs instance containing the event data.

See Also

test Class
Sitecore.layouts.testing Namespace


ParseControl Method

[image] [image]

Sitecore 6.4.1 API
test..::..ParseControl Method
test Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
Public method | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)

See Also

test Class
test Members
Sitecore.layouts.testing Namespace


RenderControl Method

[image] [image]

Sitecore 6.4.1 API
test..::..RenderControl Method
test Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)

See Also

test Class
test Members
Sitecore.layouts.testing Namespace


SetFocus Method

[image] [image]

Sitecore 6.4.1 API
test..::..SetFocus Method
test Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
Public method | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)

See Also

test Class
test Members
Sitecore.layouts.testing Namespace


TestLinkParser Method

[image]

Sitecore 6.4.1 API
test..::..TestLinkParser Method
test Class See Also Send Feedback

Namespace: Sitecore.layouts.testing
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void TestLinkParser()
Visual Basic
Protected Sub TestLinkParser
Visual C++
protected:
void TestLinkParser()

See Also

test Class
Sitecore.layouts.testing Namespace


Validate Method

[image] [image]

Sitecore 6.4.1 API
test..::..Validate Method
test Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Validate()()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
Public method | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)

See Also

test Class
test Members
Sitecore.layouts.testing Namespace


XPath Method

[image] [image]

Sitecore 6.4.1 API
test..::..XPath Method
test Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
Protected method | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
Protected method | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
Protected method | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)

See Also

test Class
test Members
Sitecore.layouts.testing Namespace


test Properties

[image] [image]

Sitecore 6.4.1 API
test Properties
test Class See Also Send Feedback

The test type exposes the following members.

Properties

 | Name | Description
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
Protected property | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
Protected property | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
Public property | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
Protected property | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
Public property | AutoPostBackControl | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
Public property | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Public property | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
Public property | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
Public property | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
Public property | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
Public property | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
Protected property | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
Public property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
Public property | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Public property | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
Public property | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
Public property | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
Public property | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
Public property | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Protected property | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
Public property | Form | Gets the HTML form for the page. (Inherited from Page.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Public property | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
Public property | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
Public property | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
Public property | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
Public property | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Public property | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
Public property | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
Public property | IsPostBackEventControlRegistered | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
Public property | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Public property | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Public property | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
Public property | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Public property | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
Public property | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
Public property | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
Public property | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
Protected property | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
Public property | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
Public property | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
Public property | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
Public property | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
Public property | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
Public property | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
Public property | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
Public property | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
Protected property | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
Public property | Title | Gets or sets the title for the page. (Inherited from Page.)
Public property | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
Public property | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
Public property | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
Protected property | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
Public property | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
Protected property | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
Public property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
Public property | User | Gets information about the user making the page request. (Inherited from Page.)
Public property | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Public property | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
Public property | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)

See Also

test Class
Sitecore.layouts.testing Namespace


test Events

[image] [image]

Sitecore 6.4.1 API
test Events
test Class See Also Send Feedback

The test type exposes the following members.

Events

 | Name | Description
Public event | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
Public event | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
Public event | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
Public event | PreLoad | Occurs before the page Load event. (Inherited from Page.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
Public event | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

See Also

test Class
Sitecore.layouts.testing Namespace


Sitecore.Links Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Links Namespace
Send Feedback

Classes

 | Class | Description
Public class | DynamicLink | DynamicLink
Public class | ItemEventHandler | Represents an item event handler.
Public class | ItemLink | Represents a item link.
Public class | ItemLinks | Represents the item links.
Public class | LinkDatabase | Defines that basic methods and properties of a link database.
Public class | LinkDatabaseHelper | The link database helper.
Public class | LinkDatabaseProxy | Represents a link database proxy.
Public class | LinkDisabler | EventDisabler class
Public class | LinkManager | LinkManager
Public class | LinkProvider | LinkProvider class
Public class | LinkProvider..::..LinkBuilder | LinkBuilder
Public class | LinkProvider..::..LinkParser | LinkParser
Public class | LinkProviderCollection | LinkProviderCollection class
Public class | LinksValidationResult | Represents a Links Validation Result.
Public class | LinkUpdaterJob |
Public class | LinkUrlOptions | Contains options for generating an Url from an item that is linked to.
Public class | SqlLinkDatabase | SqlLinkDatabase class
Public class | UrlOptions | UrlOptions

Enumerations

 | Enumeration | Description
Public enumeration | ItemLinkState | Represents the state of an item link.
Public enumeration | LanguageEmbedding | Language embedding options
Public enumeration | LanguageLocation | LanguageLocation enumeration
Public enumeration | LinkDisablerState |


DynamicLink Class

[image]

Sitecore 6.4.1 API
DynamicLink Class
Members See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DynamicLink
Visual Basic
Public Class DynamicLink
Visual C++
public ref class DynamicLink

Inheritance Hierarchy

System..::..Object
Sitecore.Links..::..DynamicLink

See Also

DynamicLink Members
Sitecore.Links Namespace


DynamicLink Members

[image] [image]

Sitecore 6.4.1 API
DynamicLink Members
DynamicLink Class Constructors Methods Fields Properties See Also Send Feedback

The DynamicLink type exposes the following members.

Constructors

 | Name | Description
Public method | DynamicLink | Initializes a new instance of the DynamicLink class

Methods

 | Name | Description
Protected method | BuildItemUrl | Builds the item URL.
Protected method | BuildMediaUrl | Builds the media URL.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExpandLinks(String) | Expands the links.
 | ExpandLinks(String, Boolean) | Expands the links.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUrl | Gets a full URL.
Public method | Initialize | Initializes this instance.
Public method | IsMediaLink | Determines whether the item being pointed to is a media item.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Parses the link.
Protected method | ParseLinkText | Parses the link text.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | TryParse | Tries the parse.

Fields

Name | Description
ITEM_LINK_ID_KEY |
ITEM_LINK_LANGUAGE_KEY |
ITEM_LINK_SITE_KEY |
ITEM_LINK_TERMINATOR_KEY |
ITEM_LINK_TYPE_KEY |
MEDIA_LINK_DATABASE_KEY |
MEDIA_LINK_LANGUAGE_KEY |

Properties

 | Name | Description
Public property | ItemId | Gets the item id.
Public property | Language | Gets the language.
Public property | LinkText | Gets the link text.
Public property | LinkType | Gets the type of the link.
Public property | Parameters | Gets the parameters.
Public property | Site | Gets the site.

See Also

DynamicLink Class
Sitecore.Links Namespace


DynamicLink Constructor

[image]

Sitecore 6.4.1 API
DynamicLink Constructor
DynamicLink Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DynamicLink()
Visual Basic
Public Sub New
Visual C++
public:
DynamicLink()

See Also

DynamicLink Class
Sitecore.Links Namespace


DynamicLink Fields

[image] [image]

Sitecore 6.4.1 API
DynamicLink Fields
DynamicLink Class See Also Send Feedback

The DynamicLink type exposes the following members.

Fields

Name | Description
ITEM_LINK_ID_KEY |
ITEM_LINK_LANGUAGE_KEY |
ITEM_LINK_SITE_KEY |
ITEM_LINK_TERMINATOR_KEY |
ITEM_LINK_TYPE_KEY |
MEDIA_LINK_DATABASE_KEY |
MEDIA_LINK_LANGUAGE_KEY |

See Also

DynamicLink Class
Sitecore.Links Namespace


ITEM_LINK_ID_KEY Field

[image]

Sitecore 6.4.1 API
DynamicLink..::..ITEM_LINK_ID_KEY Field
DynamicLink Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string ITEM_LINK_ID_KEY
Visual Basic
Public Const ITEM_LINK_ID_KEY As String
Visual C++
public:
literal String^ ITEM_LINK_ID_KEY

See Also

DynamicLink Class
Sitecore.Links Namespace


ITEM_LINK_LANGUAGE_KEY Field

[image]

Sitecore 6.4.1 API
DynamicLink..::..ITEM_LINK_LANGUAGE_KEY Field
DynamicLink Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string ITEM_LINK_LANGUAGE_KEY
Visual Basic
Public Const ITEM_LINK_LANGUAGE_KEY As String
Visual C++
public:
literal String^ ITEM_LINK_LANGUAGE_KEY

See Also

DynamicLink Class
Sitecore.Links Namespace


ITEM_LINK_SITE_KEY Field

[image]

Sitecore 6.4.1 API
DynamicLink..::..ITEM_LINK_SITE_KEY Field
DynamicLink Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string ITEM_LINK_SITE_KEY
Visual Basic
Public Const ITEM_LINK_SITE_KEY As String
Visual C++
public:
literal String^ ITEM_LINK_SITE_KEY

See Also

DynamicLink Class
Sitecore.Links Namespace


ITEM_LINK_TERMINATOR_KEY Field

[image]

Sitecore 6.4.1 API
DynamicLink..::..ITEM_LINK_TERMINATOR_KEY Field
DynamicLink Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string ITEM_LINK_TERMINATOR_KEY
Visual Basic
Public Const ITEM_LINK_TERMINATOR_KEY As String
Visual C++
public:
literal String^ ITEM_LINK_TERMINATOR_KEY

See Also

DynamicLink Class
Sitecore.Links Namespace


ITEM_LINK_TYPE_KEY Field

[image]

Sitecore 6.4.1 API
DynamicLink..::..ITEM_LINK_TYPE_KEY Field
DynamicLink Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string ITEM_LINK_TYPE_KEY
Visual Basic
Public Const ITEM_LINK_TYPE_KEY As String
Visual C++
public:
literal String^ ITEM_LINK_TYPE_KEY

See Also

DynamicLink Class
Sitecore.Links Namespace


MEDIA_LINK_DATABASE_KEY Field

[image]

Sitecore 6.4.1 API
DynamicLink..::..MEDIA_LINK_DATABASE_KEY Field
DynamicLink Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string MEDIA_LINK_DATABASE_KEY
Visual Basic
Public Const MEDIA_LINK_DATABASE_KEY As String
Visual C++
public:
literal String^ MEDIA_LINK_DATABASE_KEY

See Also

DynamicLink Class
Sitecore.Links Namespace


MEDIA_LINK_LANGUAGE_KEY Field

[image]

Sitecore 6.4.1 API
DynamicLink..::..MEDIA_LINK_LANGUAGE_KEY Field
DynamicLink Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string MEDIA_LINK_LANGUAGE_KEY
Visual Basic
Public Const MEDIA_LINK_LANGUAGE_KEY As String
Visual C++
public:
literal String^ MEDIA_LINK_LANGUAGE_KEY

See Also

DynamicLink Class
Sitecore.Links Namespace


DynamicLink Methods

[image] [image]

Sitecore 6.4.1 API
DynamicLink Methods
DynamicLink Class See Also Send Feedback

The DynamicLink type exposes the following members.

Methods

 | Name | Description
Protected method | BuildItemUrl | Builds the item URL.
Protected method | BuildMediaUrl | Builds the media URL.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExpandLinks(String) | Expands the links.
 | ExpandLinks(String, Boolean) | Expands the links.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUrl | Gets a full URL.
Public method | Initialize | Initializes this instance.
Public method | IsMediaLink | Determines whether the item being pointed to is a media item.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Parses the link.
Protected method | ParseLinkText | Parses the link text.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | TryParse | Tries the parse.

See Also

DynamicLink Class
Sitecore.Links Namespace


BuildItemUrl Method

[image]

Sitecore 6.4.1 API
DynamicLink..::..BuildItemUrl Method
DynamicLink Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string BuildItemUrl(
    UrlOptions options
)
Visual Basic
Protected Overridable Function BuildItemUrl ( _
    options As UrlOptions _
) As String
Visual C++
protected:
virtual String^ BuildItemUrl(
    UrlOptions^ options
)

Parameters

options
Type: Sitecore.Links..::..UrlOptions

[Missing <param name="options"/> documentation for "M:Sitecore.Links.DynamicLink.BuildItemUrl(Sitecore.Links.UrlOptions)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Links.DynamicLink.BuildItemUrl(Sitecore.Links.UrlOptions)"]

See Also

DynamicLink Class
Sitecore.Links Namespace


BuildMediaUrl Method

[image]

Sitecore 6.4.1 API
DynamicLink..::..BuildMediaUrl Method
DynamicLink Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string BuildMediaUrl(
    UrlOptions options
)
Visual Basic
Protected Overridable Function BuildMediaUrl ( _
    options As UrlOptions _
) As String
Visual C++
protected:
virtual String^ BuildMediaUrl(
    UrlOptions^ options
)

Parameters

options
Type: Sitecore.Links..::..UrlOptions

[Missing <param name="options"/> documentation for "M:Sitecore.Links.DynamicLink.BuildMediaUrl(Sitecore.Links.UrlOptions)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Links.DynamicLink.BuildMediaUrl(Sitecore.Links.UrlOptions)"]

See Also

DynamicLink Class
Sitecore.Links Namespace


ExpandLinks Method (String)

[image]

Sitecore 6.4.1 API
DynamicLink..::..ExpandLinks Method (String)
DynamicLink Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ExpandLinks(
    string text
)
Visual Basic
Public Shared Function ExpandLinks ( _
    text As String _
) As String
Visual C++
public:
static String^ ExpandLinks(
    String^ text
)

Parameters

text
Type: System..::..String
The text.

Return Value

[Missing <returns> documentation for "M:Sitecore.Links.DynamicLink.ExpandLinks(System.String)"]

See Also

DynamicLink Class
ExpandLinks Overload
Sitecore.Links Namespace


ExpandLinks Method (String, Boolean)

[image]

Sitecore 6.4.1 API
DynamicLink..::..ExpandLinks Method (String, Boolean)
DynamicLink Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ExpandLinks(
    string text,
    bool resolveSites
)
Visual Basic
Public Shared Function ExpandLinks ( _
    text As String, _
    resolveSites As Boolean _
) As String
Visual C++
public:
static String^ ExpandLinks(
    String^ text,
    bool resolveSites
)

Parameters

text
Type: System..::..String
The text.
resolveSites
Type: System..::..Boolean
Set this to true to resolve site information when expanding dynamic links.

Return Value

[Missing <returns> documentation for "M:Sitecore.Links.DynamicLink.ExpandLinks(System.String,System.Boolean)"]

See Also

DynamicLink Class
ExpandLinks Overload
Sitecore.Links Namespace


IsMediaLink Method

[image]

Sitecore 6.4.1 API
DynamicLink..::..IsMediaLink Method
DynamicLink Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool IsMediaLink()
Visual Basic
Public Overridable Function IsMediaLink As Boolean
Visual C++
public:
virtual bool IsMediaLink()

Return Value

true if it is a media item; otherwise, false.

See Also

DynamicLink Class
Sitecore.Links Namespace


Parse Method

[image]

Sitecore 6.4.1 API
DynamicLink..::..Parse Method
DynamicLink Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static DynamicLink Parse(
    string linkText
)
Visual Basic
Public Shared Function Parse ( _
    linkText As String _
) As DynamicLink
Visual C++
public:
static DynamicLink^ Parse(
    String^ linkText
)

Parameters

linkText
Type: System..::..String
The link text.

Return Value

[Missing <returns> documentation for "M:Sitecore.Links.DynamicLink.Parse(System.String)"]

See Also

DynamicLink Class
Sitecore.Links Namespace


ParseLinkText Method

[image]

Sitecore 6.4.1 API
DynamicLink..::..ParseLinkText Method
DynamicLink Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void ParseLinkText(
    string linkText
)
Visual Basic
Protected Overridable Sub ParseLinkText ( _
    linkText As String _
)
Visual C++
protected:
virtual void ParseLinkText(
    String^ linkText
)

Parameters

linkText
Type: System..::..String
The link text.

Return Value

Exceptions

Exception | Condition
Sitecore.Web..::..InvalidLinkFormatException | InvalidLinkFormatException.

See Also

DynamicLink Class
Sitecore.Links Namespace


ItemId Property

[image]

Sitecore 6.4.1 API
DynamicLink..::..ItemId Property
DynamicLink Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ID ItemId { get; protected set; }
Visual Basic
Public Overridable Property ItemId As ID
    Get
    Protected Set
Visual C++
public:
virtual property ID^ ItemId {
    ID^ get ();
    protected: void set (ID^ value);
}

Field Value

The item id.

See Also

DynamicLink Class
Sitecore.Links Namespace


Language Property

[image]

Sitecore 6.4.1 API
DynamicLink..::..Language Property
DynamicLink Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Language Language { get; protected set; }
Visual Basic
Public Overridable Property Language As Language
    Get
    Protected Set
Visual C++
public:
virtual property Language^ Language {
    Language^ get ();
    protected: void set (Language^ value);
}

Field Value

The language.

See Also

DynamicLink Class
Sitecore.Links Namespace


LinkText Property

[image]

Sitecore 6.4.1 API
DynamicLink..::..LinkText Property
DynamicLink Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string LinkText { get; protected set; }
Visual Basic
Public Overridable Property LinkText As String
    Get
    Protected Set
Visual C++
public:
virtual property String^ LinkText {
    String^ get ();
    protected: void set (String^ value);
}

Field Value

The link text.

See Also

DynamicLink Class
Sitecore.Links Namespace


LinkType Property

[image]

Sitecore 6.4.1 API
DynamicLink..::..LinkType Property
DynamicLink Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string LinkType { get; protected set; }
Visual Basic
Public Overridable Property LinkType As String
    Get
    Protected Set
Visual C++
public:
virtual property String^ LinkType {
    String^ get ();
    protected: void set (String^ value);
}

Field Value

The type of the link.

See Also

DynamicLink Class
Sitecore.Links Namespace


Site Property

[image]

Sitecore 6.4.1 API
DynamicLink..::..Site Property
DynamicLink Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual SiteContext Site { get; protected set; }
Visual Basic
Public Overridable Property Site As SiteContext
    Get
    Protected Set
Visual C++
public:
virtual property SiteContext^ Site {
    SiteContext^ get ();
    protected: void set (SiteContext^ value);
}

Field Value

The site.

See Also

DynamicLink Class
Sitecore.Links Namespace


ItemEventHandler Class

[image]

Sitecore 6.4.1 API
ItemEventHandler Class
Members See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemEventHandler
Visual Basic
Public Class ItemEventHandler
Visual C++
public ref class ItemEventHandler

Inheritance Hierarchy

System..::..Object
Sitecore.Links..::..ItemEventHandler

See Also

ItemEventHandler Members
Sitecore.Links Namespace


ItemEventHandler Constructor

[image]

Sitecore 6.4.1 API
ItemEventHandler Constructor
ItemEventHandler Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemEventHandler()
Visual Basic
Public Sub New
Visual C++
public:
ItemEventHandler()

See Also

ItemEventHandler Class
Sitecore.Links Namespace


ItemEventHandler Methods

[image] [image]

Sitecore 6.4.1 API
ItemEventHandler Methods
ItemEventHandler Class See Also Send Feedback

The ItemEventHandler type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnItemDeleted | Called when the item has been deleted.
Protected method | OnItemSaved | Called when the item has saved.
Protected method | OnVersionRemoved | Called when the version has been removed.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemEventHandler Class
Sitecore.Links Namespace


OnItemDeleted Method

[image]

Sitecore 6.4.1 API
ItemEventHandler..::..OnItemDeleted Method
ItemEventHandler Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void OnItemDeleted(
    Object sender,
    EventArgs args
)
Visual Basic
Protected Sub OnItemDeleted ( _
    sender As Object, _
    args As EventArgs _
)
Visual C++
protected:
void OnItemDeleted(
    Object^ sender,
    EventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: System..::..EventArgs
The arguments.

See Also

ItemEventHandler Class
Sitecore.Links Namespace


OnItemSaved Method

[image]

Sitecore 6.4.1 API
ItemEventHandler..::..OnItemSaved Method
ItemEventHandler Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void OnItemSaved(
    Object sender,
    EventArgs args
)
Visual Basic
Protected Sub OnItemSaved ( _
    sender As Object, _
    args As EventArgs _
)
Visual C++
protected:
void OnItemSaved(
    Object^ sender,
    EventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: System..::..EventArgs
The arguments.

See Also

ItemEventHandler Class
Sitecore.Links Namespace


OnVersionRemoved Method

[image]

Sitecore 6.4.1 API
ItemEventHandler..::..OnVersionRemoved Method
ItemEventHandler Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void OnVersionRemoved(
    Object sender,
    EventArgs args
)
Visual Basic
Protected Sub OnVersionRemoved ( _
    sender As Object, _
    args As EventArgs _
)
Visual C++
protected:
void OnVersionRemoved(
    Object^ sender,
    EventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: System..::..EventArgs
The arguments.

See Also

ItemEventHandler Class
Sitecore.Links Namespace


ItemLink Class

[image]

Sitecore 6.4.1 API
ItemLink Class
Members See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemLink
Visual Basic
Public Class ItemLink
Visual C++
public ref class ItemLink

Inheritance Hierarchy

System..::..Object
Sitecore.Links..::..ItemLink

See Also

ItemLink Members
Sitecore.Links Namespace


ItemLink Members

[image] [image]

Sitecore 6.4.1 API
ItemLink Members
ItemLink Class Constructors Methods Properties See Also Send Feedback

The ItemLink type exposes the following members.

Constructors

 | Name | Description
Public method | ItemLink(Item, ID, Item, String) | Initializes a new instance of the ItemLink class.
Public method | ItemLink(String, ID, ID, String, ID, String) | Initializes a new instance of the ItemLink class.
Public method | ItemLink(Item, ID, String, ID, Language, Version, String) | Initializes a new instance of the ItemLink class.
Public method | ItemLink(String, ID, Language, Version, ID, String, ID, Language, Version, String) | Initializes a new instance of the ItemLink class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSourceItem | Gets the source item.
Public method | GetTargetItem | Gets the target item.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | SourceDatabaseName | Gets the name of the source database.
Public property | SourceFieldID | Gets the source field ID.
Public property | SourceItemID | Gets the source item ID.
Public property | SourceItemLanguage | Gets the source item language.
Public property | SourceItemVersion | Gets the source item version.
Public property | TargetDatabaseName | Gets the name of the target database.
Public property | TargetItemID | Gets the target item ID.
Public property | TargetItemLanguage | Gets the target item language.
Public property | TargetItemVersion | Gets the target item version.
Public property | TargetPath | Gets the target path.

See Also

ItemLink Class
Sitecore.Links Namespace


ItemLink Constructor

[image] [image]

Sitecore 6.4.1 API
ItemLink Constructor
ItemLink Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ItemLink(Item, ID, Item, String) | Initializes a new instance of the ItemLink class.
Public method | ItemLink(String, ID, ID, String, ID, String) | Initializes a new instance of the ItemLink class.
Public method | ItemLink(Item, ID, String, ID, Language, Version, String) | Initializes a new instance of the ItemLink class.
Public method | ItemLink(String, ID, Language, Version, ID, String, ID, Language, Version, String) | Initializes a new instance of the ItemLink class.

See Also

ItemLink Class
ItemLink Members
Sitecore.Links Namespace


ItemLink Constructor (Item, ID, Item, String)

[image]

Sitecore 6.4.1 API
ItemLink Constructor (Item, ID, Item, String)
ItemLink Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemLink(
    Item sourceItem,
    ID sourceFieldID,
    Item targetItem,
    string targetPath
)
Visual Basic
Public Sub New ( _
    sourceItem As Item, _
    sourceFieldID As ID, _
    targetItem As Item, _
    targetPath As String _
)
Visual C++
public:
ItemLink(
    Item^ sourceItem,
    ID^ sourceFieldID,
    Item^ targetItem,
    String^ targetPath
)

Parameters

sourceItem
Type: Sitecore.Data.Items..::..Item
The source item.
sourceFieldID
Type: Sitecore.Data..::..ID
The source field ID.
targetItem
Type: Sitecore.Data.Items..::..Item
The target item.
targetPath
Type: System..::..String
The target path.

See Also

ItemLink Class
ItemLink Overload
Sitecore.Links Namespace


ItemLink Constructor (String, ID, ID, String, ID, String)

[image]

Sitecore 6.4.1 API
ItemLink Constructor (String, ID, ID, String, ID, String)
ItemLink Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemLink(
    string sourceDatabase,
    ID sourceItemID,
    ID sourceFieldID,
    string targetDatabase,
    ID targetItemID,
    string targetPath
)
Visual Basic
Public Sub New ( _
    sourceDatabase As String, _
    sourceItemID As ID, _
    sourceFieldID As ID, _
    targetDatabase As String, _
    targetItemID As ID, _
    targetPath As String _
)
Visual C++
public:
ItemLink(
    String^ sourceDatabase,
    ID^ sourceItemID,
    ID^ sourceFieldID,
    String^ targetDatabase,
    ID^ targetItemID,
    String^ targetPath
)

Parameters

sourceDatabase
Type: System..::..String
The source database.
sourceItemID
Type: Sitecore.Data..::..ID
The source item ID.
sourceFieldID
Type: Sitecore.Data..::..ID
The source field ID.
targetDatabase
Type: System..::..String
The target database.
targetItemID
Type: Sitecore.Data..::..ID
The target item ID.
targetPath
Type: System..::..String
The target path.

See Also

ItemLink Class
ItemLink Overload
Sitecore.Links Namespace


ItemLink Constructor (Item, ID, String, ID, Language, Version, String)

[image]

Sitecore 6.4.1 API
ItemLink Constructor (Item, ID, String, ID, Language, Version, String)
ItemLink Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemLink(
    Item sourceItem,
    ID sourceFieldID,
    string targetDatabase,
    ID targetItemID,
    Language targetItemLanguage,
    Version targetItemVersion,
    string targetPath
)
Visual Basic
Public Sub New ( _
    sourceItem As Item, _
    sourceFieldID As ID, _
    targetDatabase As String, _
    targetItemID As ID, _
    targetItemLanguage As Language, _
    targetItemVersion As Version, _
    targetPath As String _
)
Visual C++
public:
ItemLink(
    Item^ sourceItem,
    ID^ sourceFieldID,
    String^ targetDatabase,
    ID^ targetItemID,
    Language^ targetItemLanguage,
    Version^ targetItemVersion,
    String^ targetPath
)

Parameters

sourceItem
Type: Sitecore.Data.Items..::..Item
The source item.
sourceFieldID
Type: Sitecore.Data..::..ID
The source field ID.
targetDatabase
Type: System..::..String
The target database.
targetItemID
Type: Sitecore.Data..::..ID
The target item ID.
targetItemLanguage
Type: Sitecore.Globalization..::..Language
The target item language.
targetItemVersion
Type: Sitecore.Data..::..Version
The target item version.
targetPath
Type: System..::..String
The target path.

See Also

ItemLink Class
ItemLink Overload
Sitecore.Links Namespace


ItemLink Constructor (String, ID, Language, Version, ID, String, ID, Language, Version, String)

[image]

Sitecore 6.4.1 API
ItemLink Constructor (String, ID, Language, Version, ID, String, ID, Language, Version, String)
ItemLink Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemLink(
    string sourceDatabase,
    ID sourceItemID,
    Language sourceItemLanguage,
    Version sourceItemVersion,
    ID sourceFieldID,
    string targetDatabase,
    ID targetItemID,
    Language targetItemLanguage,
    Version targetItemVersion,
    string targetPath
)
Visual Basic
Public Sub New ( _
    sourceDatabase As String, _
    sourceItemID As ID, _
    sourceItemLanguage As Language, _
    sourceItemVersion As Version, _
    sourceFieldID As ID, _
    targetDatabase As String, _
    targetItemID As ID, _
    targetItemLanguage As Language, _
    targetItemVersion As Version, _
    targetPath As String _
)
Visual C++
public:
ItemLink(
    String^ sourceDatabase,
    ID^ sourceItemID,
    Language^ sourceItemLanguage,
    Version^ sourceItemVersion,
    ID^ sourceFieldID,
    String^ targetDatabase,
    ID^ targetItemID,
    Language^ targetItemLanguage,
    Version^ targetItemVersion,
    String^ targetPath
)

Parameters

sourceDatabase
Type: System..::..String
The source database.
sourceItemID
Type: Sitecore.Data..::..ID
The source item ID.
sourceItemLanguage
Type: Sitecore.Globalization..::..Language
The source item language.
sourceItemVersion
Type: Sitecore.Data..::..Version
The source item version.
sourceFieldID
Type: Sitecore.Data..::..ID
The source field ID.
targetDatabase
Type: System..::..String
The target database.
targetItemID
Type: Sitecore.Data..::..ID
The target item ID.
targetItemLanguage
Type: Sitecore.Globalization..::..Language
The target item L anguage.
targetItemVersion
Type: Sitecore.Data..::..Version
The target item version.
targetPath
Type: System..::..String
The target path.

See Also

ItemLink Class
ItemLink Overload
Sitecore.Links Namespace


ItemLink Methods

[image] [image]

Sitecore 6.4.1 API
ItemLink Methods
ItemLink Class See Also Send Feedback

The ItemLink type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSourceItem | Gets the source item.
Public method | GetTargetItem | Gets the target item.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemLink Class
Sitecore.Links Namespace


GetSourceItem Method

[image]

Sitecore 6.4.1 API
ItemLink..::..GetSourceItem Method
ItemLink Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetSourceItem()
Visual Basic
Public Function GetSourceItem As Item
Visual C++
public:
Item^ GetSourceItem()

Return Value

The source item.

See Also

ItemLink Class
Sitecore.Links Namespace


GetTargetItem Method

[image]

Sitecore 6.4.1 API
ItemLink..::..GetTargetItem Method
ItemLink Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetTargetItem()
Visual Basic
Public Function GetTargetItem As Item
Visual C++
public:
Item^ GetTargetItem()

Return Value

The target item.

See Also

ItemLink Class
Sitecore.Links Namespace


SourceDatabaseName Property

[image]

Sitecore 6.4.1 API
ItemLink..::..SourceDatabaseName Property
ItemLink Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string SourceDatabaseName { get; }
Visual Basic
Public ReadOnly Property SourceDatabaseName As String
    Get
Visual C++
public:
property String^ SourceDatabaseName {
    String^ get ();
}

Field Value

The name of the source database.

See Also

ItemLink Class
Sitecore.Links Namespace


SourceFieldID Property

[image]

Sitecore 6.4.1 API
ItemLink..::..SourceFieldID Property
ItemLink Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID SourceFieldID { get; }
Visual Basic
Public ReadOnly Property SourceFieldID As ID
    Get
Visual C++
public:
property ID^ SourceFieldID {
    ID^ get ();
}

Field Value

The source field ID.

See Also

ItemLink Class
Sitecore.Links Namespace


SourceItemLanguage Property

[image]

Sitecore 6.4.1 API
ItemLink..::..SourceItemLanguage Property
ItemLink Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Language SourceItemLanguage { get; }
Visual Basic
Public ReadOnly Property SourceItemLanguage As Language
    Get
Visual C++
public:
property Language^ SourceItemLanguage {
    Language^ get ();
}

Field Value

The source item language.

See Also

ItemLink Class
Sitecore.Links Namespace


SourceItemVersion Property

[image]

Sitecore 6.4.1 API
ItemLink..::..SourceItemVersion Property
ItemLink Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Version SourceItemVersion { get; }
Visual Basic
Public ReadOnly Property SourceItemVersion As Version
    Get
Visual C++
public:
property Version^ SourceItemVersion {
    Version^ get ();
}

Field Value

The source item version.

See Also

ItemLink Class
Sitecore.Links Namespace


TargetDatabaseName Property

[image]

Sitecore 6.4.1 API
ItemLink..::..TargetDatabaseName Property
ItemLink Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string TargetDatabaseName { get; }
Visual Basic
Public ReadOnly Property TargetDatabaseName As String
    Get
Visual C++
public:
property String^ TargetDatabaseName {
    String^ get ();
}

Field Value

The name of the target database.

See Also

ItemLink Class
Sitecore.Links Namespace


TargetItemLanguage Property

[image]

Sitecore 6.4.1 API
ItemLink..::..TargetItemLanguage Property
ItemLink Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Language TargetItemLanguage { get; }
Visual Basic
Public ReadOnly Property TargetItemLanguage As Language
    Get
Visual C++
public:
property Language^ TargetItemLanguage {
    Language^ get ();
}

Field Value

The target item language.

See Also

ItemLink Class
Sitecore.Links Namespace


TargetItemVersion Property

[image]

Sitecore 6.4.1 API
ItemLink..::..TargetItemVersion Property
ItemLink Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Version TargetItemVersion { get; }
Visual Basic
Public ReadOnly Property TargetItemVersion As Version
    Get
Visual C++
public:
property Version^ TargetItemVersion {
    Version^ get ();
}

Field Value

The target item version.

See Also

ItemLink Class
Sitecore.Links Namespace


TargetPath Property

[image]

Sitecore 6.4.1 API
ItemLink..::..TargetPath Property
ItemLink Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string TargetPath { get; }
Visual Basic
Public ReadOnly Property TargetPath As String
    Get
Visual C++
public:
property String^ TargetPath {
    String^ get ();
}

Field Value

The target path.

See Also

ItemLink Class
Sitecore.Links Namespace


ItemLinks Class

[image]

Sitecore 6.4.1 API
ItemLinks Class
Members See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemLinks
Visual Basic
Public Class ItemLinks
Visual C++
public ref class ItemLinks

Inheritance Hierarchy

System..::..Object
Sitecore.Links..::..ItemLinks

See Also

ItemLinks Members
Sitecore.Links Namespace


ItemLinks Members

[image] [image]

Sitecore 6.4.1 API
ItemLinks Members
ItemLinks Class Constructors Methods Properties See Also Send Feedback

The ItemLinks type exposes the following members.

Constructors

 | Name | Description
Public method | ItemLinks | Initializes a new instance of the ItemLinks class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAllLinks()()()() | Gets all links.
Public method | GetAllLinks(Boolean) | Gets all links.
Public method | GetBrokenLinks()()()() | Gets the broken links.
Public method | GetBrokenLinks(Boolean) | Gets the broken links.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidLinks()()()() | Gets the valid links.
Public method | GetValidLinks(Boolean) | Gets the valid links.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Database | Gets the database.
Public property | Item | Gets the item.

See Also

ItemLinks Class
Sitecore.Links Namespace


ItemLinks Constructor

[image]

Sitecore 6.4.1 API
ItemLinks Constructor
ItemLinks Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemLinks(
    Item ownerItem
)
Visual Basic
Public Sub New ( _
    ownerItem As Item _
)
Visual C++
public:
ItemLinks(
    Item^ ownerItem
)

Parameters

ownerItem
Type: Sitecore.Data.Items..::..Item
The owner item.

See Also

ItemLinks Class
Sitecore.Links Namespace


ItemLinks Methods

[image] [image]

Sitecore 6.4.1 API
ItemLinks Methods
ItemLinks Class See Also Send Feedback

The ItemLinks type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAllLinks()()()() | Gets all links.
Public method | GetAllLinks(Boolean) | Gets all links.
Public method | GetBrokenLinks()()()() | Gets the broken links.
Public method | GetBrokenLinks(Boolean) | Gets the broken links.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidLinks()()()() | Gets the valid links.
Public method | GetValidLinks(Boolean) | Gets the valid links.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemLinks Class
Sitecore.Links Namespace


GetAllLinks Method

[image] [image]

Sitecore 6.4.1 API
ItemLinks..::..GetAllLinks Method
ItemLinks Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetAllLinks()()()() | Gets all links.
Public method | GetAllLinks(Boolean) | Gets all links.

See Also

ItemLinks Class
ItemLinks Members
Sitecore.Links Namespace


GetAllLinks Method

[image]

Sitecore 6.4.1 API
ItemLinks..::..GetAllLinks Method
ItemLinks Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemLink[] GetAllLinks()
Visual Basic
Public Function GetAllLinks As ItemLink()
Visual C++
public:
array<ItemLink^>^ GetAllLinks()

Return Value

The all links.

See Also

ItemLinks Class
GetAllLinks Overload
Sitecore.Links Namespace


GetAllLinks Method (Boolean)

[image]

Sitecore 6.4.1 API
ItemLinks..::..GetAllLinks Method (Boolean)
ItemLinks Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemLink[] GetAllLinks(
    bool allVersions
)
Visual Basic
Public Function GetAllLinks ( _
    allVersions As Boolean _
) As ItemLink()
Visual C++
public:
array<ItemLink^>^ GetAllLinks(
    bool allVersions
)

Parameters

allVersions
Type: System..::..Boolean
The all Versions.

Return Value

The array of ItemLink.

See Also

ItemLinks Class
GetAllLinks Overload
Sitecore.Links Namespace


GetBrokenLinks Method

[image] [image]

Sitecore 6.4.1 API
ItemLinks..::..GetBrokenLinks Method
ItemLinks Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetBrokenLinks()()()() | Gets the broken links.
Public method | GetBrokenLinks(Boolean) | Gets the broken links.

See Also

ItemLinks Class
ItemLinks Members
Sitecore.Links Namespace


GetBrokenLinks Method

[image]

Sitecore 6.4.1 API
ItemLinks..::..GetBrokenLinks Method
ItemLinks Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemLink[] GetBrokenLinks()
Visual Basic
Public Function GetBrokenLinks As ItemLink()
Visual C++
public:
array<ItemLink^>^ GetBrokenLinks()

Return Value

The array of ItemLink.

See Also

ItemLinks Class
GetBrokenLinks Overload
Sitecore.Links Namespace


GetBrokenLinks Method (Boolean)

[image]

Sitecore 6.4.1 API
ItemLinks..::..GetBrokenLinks Method (Boolean)
ItemLinks Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemLink[] GetBrokenLinks(
    bool allVersions
)
Visual Basic
Public Function GetBrokenLinks ( _
    allVersions As Boolean _
) As ItemLink()
Visual C++
public:
array<ItemLink^>^ GetBrokenLinks(
    bool allVersions
)

Parameters

allVersions
Type: System..::..Boolean
if set to true this instance is all versions.

Return Value

The broken links.

See Also

ItemLinks Class
GetBrokenLinks Overload
Sitecore.Links Namespace


GetValidLinks Method

[image] [image]

Sitecore 6.4.1 API
ItemLinks..::..GetValidLinks Method
ItemLinks Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValidLinks()()()() | Gets the valid links.
Public method | GetValidLinks(Boolean) | Gets the valid links.

See Also

ItemLinks Class
ItemLinks Members
Sitecore.Links Namespace


GetValidLinks Method

[image]

Sitecore 6.4.1 API
ItemLinks..::..GetValidLinks Method
ItemLinks Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemLink[] GetValidLinks()
Visual Basic
Public Function GetValidLinks As ItemLink()
Visual C++
public:
array<ItemLink^>^ GetValidLinks()

Return Value

The array of ItemLink.

See Also

ItemLinks Class
GetValidLinks Overload
Sitecore.Links Namespace


GetValidLinks Method (Boolean)

[image]

Sitecore 6.4.1 API
ItemLinks..::..GetValidLinks Method (Boolean)
ItemLinks Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemLink[] GetValidLinks(
    bool allVersions
)
Visual Basic
Public Function GetValidLinks ( _
    allVersions As Boolean _
) As ItemLink()
Visual C++
public:
array<ItemLink^>^ GetValidLinks(
    bool allVersions
)

Parameters

allVersions
Type: System..::..Boolean
The all Versions.

Return Value

The array of ItemLink.

See Also

ItemLinks Class
GetValidLinks Overload
Sitecore.Links Namespace


ItemLinks Properties

[image] [image]

Sitecore 6.4.1 API
ItemLinks Properties
ItemLinks Class See Also Send Feedback

The ItemLinks type exposes the following members.

Properties

 | Name | Description
Public property | Database | Gets the database.
Public property | Item | Gets the item.

See Also

ItemLinks Class
Sitecore.Links Namespace


Database Property

[image]

Sitecore 6.4.1 API
ItemLinks..::..Database Property
ItemLinks Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database Database { get; }
Visual Basic
Public ReadOnly Property Database As Database
    Get
Visual C++
public:
property Database^ Database {
    Database^ get ();
}

Field Value

The database.

See Also

ItemLinks Class
Sitecore.Links Namespace


Item Property

[image]

Sitecore 6.4.1 API
ItemLinks..::..Item Property
ItemLinks Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Item { get; }
Visual Basic
Public ReadOnly Property Item As Item
    Get
Visual C++
public:
property Item^ Item {
    Item^ get ();
}

Field Value

The Sitecore item.

See Also

ItemLinks Class
Sitecore.Links Namespace


ItemLinkState Enumeration

[image]

Sitecore 6.4.1 API
ItemLinkState Enumeration
See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum ItemLinkState
Visual Basic
Public Enumeration ItemLinkState
Visual C++
public enum class ItemLinkState

Members

Member name | Value | Description
Any | 0 | Any.
Broken | 1 | Broken.
Valid | 2 | Valid.

See Also

Sitecore.Links Namespace


LanguageEmbedding Enumeration

[image]

Sitecore 6.4.1 API
LanguageEmbedding Enumeration
See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum LanguageEmbedding
Visual Basic
Public Enumeration LanguageEmbedding
Visual C++
public enum class LanguageEmbedding

Members

Member name | Value | Description
AsNeeded | 0 | Only embed languages if the linked-to language differs from the context language.
Always | 1 | Always embed languages.
Never | 2 | Never embed languages.

See Also

Sitecore.Links Namespace


LanguageLocation Enumeration

[image]

Sitecore 6.4.1 API
LanguageLocation Enumeration
See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum LanguageLocation
Visual Basic
Public Enumeration LanguageLocation
Visual C++
public enum class LanguageLocation

Members

Member name | Value | Description
FilePath | 0 | Embed the language in the file path of the link/URL.
QueryString | 1 | Embed the language in the query string of the link/URL.

See Also

Sitecore.Links Namespace


LinkDatabase Class

[image]

Sitecore 6.4.1 API
LinkDatabase Class
Members See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class LinkDatabase
Visual Basic
Public MustInherit Class LinkDatabase
Visual C++
public ref class LinkDatabase abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Links..::..LinkDatabase
Sitecore.Links..::..SqlLinkDatabase

See Also

LinkDatabase Members
Sitecore.Links Namespace


LinkDatabase Members

[image] [image]

Sitecore 6.4.1 API
LinkDatabase Members
LinkDatabase Class Constructors Methods See Also Send Feedback

The LinkDatabase type exposes the following members.

Constructors

 | Name | Description
Protected method | LinkDatabase | Initializes a new instance of the LinkDatabase class

Methods

 | Name | Description
Public method | Compact | Compacts the specified database.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBrokenLinks | Gets the broken links.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemVersionReferrers | Gets the item version referrers.
Public method | GetReferenceCount | Gets the reference count.
Public method | GetReferences | Gets the references.
Public method | GetRefererCount | Obsolete. Gets the referrer count.
Public method | GetReferers | Obsolete. Gets the referrers.
Public method | GetReferrerCount | Gets the referrer count.
Public method | GetReferrers(Item) | Gets the referrers.
Public method | GetReferrers(Item, Boolean) | Obsolete. Gets the referrers.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasExternalReferers | Obsolete. Determines whether the specified item has external referrers.
Public method | HasExternalReferrers | Determines whether the specified item has external referrers.
Protected method | ItemExists | Targets the exists.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rebuild | Rebuilds the specified database.
Public method | RemoveReferences | Removes the references.
Protected method | TargetExists | Determines if the target exists.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | UpdateItemVersionLinks | Updates the item version links.
Public method | UpdateItemVersionReferences | The update item version references.
Protected method | UpdateLinks | Updates the links.
Public method | UpdateReferences | Updates the references.

See Also

LinkDatabase Class
Sitecore.Links Namespace


LinkDatabase Constructor

[image]

Sitecore 6.4.1 API
LinkDatabase Constructor
LinkDatabase Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected LinkDatabase()
Visual Basic
Protected Sub New
Visual C++
protected:
LinkDatabase()

See Also

LinkDatabase Class
Sitecore.Links Namespace


LinkDatabase Methods

[image] [image]

Sitecore 6.4.1 API
LinkDatabase Methods
LinkDatabase Class See Also Send Feedback

The LinkDatabase type exposes the following members.

Methods

 | Name | Description
Public method | Compact | Compacts the specified database.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBrokenLinks | Gets the broken links.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemVersionReferrers | Gets the item version referrers.
Public method | GetReferenceCount | Gets the reference count.
Public method | GetReferences | Gets the references.
Public method | GetRefererCount | Obsolete. Gets the referrer count.
Public method | GetReferers | Obsolete. Gets the referrers.
Public method | GetReferrerCount | Gets the referrer count.
Public method | GetReferrers(Item) | Gets the referrers.
Public method | GetReferrers(Item, Boolean) | Obsolete. Gets the referrers.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasExternalReferers | Obsolete. Determines whether the specified item has external referrers.
Public method | HasExternalReferrers | Determines whether the specified item has external referrers.
Protected method | ItemExists | Targets the exists.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rebuild | Rebuilds the specified database.
Public method | RemoveReferences | Removes the references.
Protected method | TargetExists | Determines if the target exists.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | UpdateItemVersionLinks | Updates the item version links.
Public method | UpdateItemVersionReferences | The update item version references.
Protected method | UpdateLinks | Updates the links.
Public method | UpdateReferences | Updates the references.

See Also

LinkDatabase Class
Sitecore.Links Namespace


Compact Method

[image]

Sitecore 6.4.1 API
LinkDatabase..::..Compact Method
LinkDatabase Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract void Compact(
    Database database
)
Visual Basic
Public MustOverride Sub Compact ( _
    database As Database _
)
Visual C++
public:
virtual void Compact(
    Database^ database
) abstract

Parameters

database
Type: Sitecore.Data..::..Database
The database.

See Also

LinkDatabase Class
Sitecore.Links Namespace


GetItemVersionReferrers Method

[image]

Sitecore 6.4.1 API
LinkDatabase..::..GetItemVersionReferrers Method
LinkDatabase Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ItemLink[] GetItemVersionReferrers(
    Item version
)
Visual Basic
Public Overridable Function GetItemVersionReferrers ( _
    version As Item _
) As ItemLink()
Visual C++
public:
virtual array<ItemLink^>^ GetItemVersionReferrers(
    Item^ version
)

Parameters

version
Type: Sitecore.Data.Items..::..Item
The item version.

Return Value

The list of referrers to the item version.

See Also

LinkDatabase Class
Sitecore.Links Namespace


GetReferenceCount Method

[image]

Sitecore 6.4.1 API
LinkDatabase..::..GetReferenceCount Method
LinkDatabase Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract int GetReferenceCount(
    Item item
)
Visual Basic
Public MustOverride Function GetReferenceCount ( _
    item As Item _
) As Integer
Visual C++
public:
virtual int GetReferenceCount(
    Item^ item
) abstract

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item to calculate the references.

Return Value

The count.

See Also

LinkDatabase Class
Sitecore.Links Namespace


GetReferences Method

[image]

Sitecore 6.4.1 API
LinkDatabase..::..GetReferences Method
LinkDatabase Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract ItemLink[] GetReferences(
    Item item
)
Visual Basic
Public MustOverride Function GetReferences ( _
    item As Item _
) As ItemLink()
Visual C++
public:
virtual array<ItemLink^>^ GetReferences(
    Item^ item
) abstract

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item to get the references for.

Return Value

The references.

See Also

LinkDatabase Class
Sitecore.Links Namespace


GetRefererCount Method

[image]

Sitecore 6.4.1 API
LinkDatabase..::..GetRefererCount Method
LinkDatabase Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use GetReferrerCount instead.")]
public int GetRefererCount(
    Item item
)
Visual Basic
<ObsoleteAttribute("Deprecated - Use GetReferrerCount instead.")> _
Public Function GetRefererCount ( _
    item As Item _
) As Integer
Visual C++
[ObsoleteAttribute(L"Deprecated - Use GetReferrerCount instead.")]
public:
int GetRefererCount(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item to calculate the referres.

Return Value

The referrer count.

See Also

LinkDatabase Class
Sitecore.Links Namespace


GetReferers Method

[image]

Sitecore 6.4.1 API
LinkDatabase..::..GetReferers Method
LinkDatabase Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use GetReferrers instead.")]
public ItemLink[] GetReferers(
    Item item
)
Visual Basic
<ObsoleteAttribute("Deprecated - Use GetReferrers instead.")> _
Public Function GetReferers ( _
    item As Item _
) As ItemLink()
Visual C++
[ObsoleteAttribute(L"Deprecated - Use GetReferrers instead.")]
public:
array<ItemLink^>^ GetReferers(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item to get the referrers for.

Return Value

The referrers.

See Also

LinkDatabase Class
Sitecore.Links Namespace


GetReferrerCount Method

[image]

Sitecore 6.4.1 API
LinkDatabase..::..GetReferrerCount Method
LinkDatabase Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract int GetReferrerCount(
    Item item
)
Visual Basic
Public MustOverride Function GetReferrerCount ( _
    item As Item _
) As Integer
Visual C++
public:
virtual int GetReferrerCount(
    Item^ item
) abstract

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item to calculate the referrers for.

Return Value

The referrer count.

See Also

LinkDatabase Class
Sitecore.Links Namespace


GetReferrers Method

[image] [image]

Sitecore 6.4.1 API
LinkDatabase..::..GetReferrers Method
LinkDatabase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetReferrers(Item) | Gets the referrers.
Public method | GetReferrers(Item, Boolean) | Obsolete. Gets the referrers.

See Also

LinkDatabase Class
LinkDatabase Members
Sitecore.Links Namespace


GetReferrers Method (Item, Boolean)

[image]

Sitecore 6.4.1 API
LinkDatabase..::..GetReferrers Method (Item, Boolean)
LinkDatabase Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use GetReferrers(item) instead.")]
public abstract ItemLink[] GetReferrers(
    Item item,
    bool deep
)
Visual Basic
<ObsoleteAttribute("Deprecated - Use GetReferrers(item) instead.")> _
Public MustOverride Function GetReferrers ( _
    item As Item, _
    deep As Boolean _
) As ItemLink()
Visual C++
[ObsoleteAttribute(L"Deprecated - Use GetReferrers(item) instead.")]
public:
virtual array<ItemLink^>^ GetReferrers(
    Item^ item,
    bool deep
) abstract

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item to get the referrers for.
deep
Type: System..::..Boolean
if set to true this instance is deep.

Return Value

The referrers.

See Also

LinkDatabase Class
GetReferrers Overload
Sitecore.Links Namespace


HasExternalReferers Method

[image]

Sitecore 6.4.1 API
LinkDatabase..::..HasExternalReferers Method
LinkDatabase Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use HasExternalReferrers instead.")]
public bool HasExternalReferers(
    Item item,
    bool deep
)
Visual Basic
<ObsoleteAttribute("Deprecated - Use HasExternalReferrers instead.")> _
Public Function HasExternalReferers ( _
    item As Item, _
    deep As Boolean _
) As Boolean
Visual C++
[ObsoleteAttribute(L"Deprecated - Use HasExternalReferrers instead.")]
public:
bool HasExternalReferers(
    Item^ item,
    bool deep
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item to check.
deep
Type: System..::..Boolean
if set to true this instance is deep.

Return Value

true if the specified item has external referrers; otherwise, false.

See Also

LinkDatabase Class
Sitecore.Links Namespace


HasExternalReferrers Method

[image]

Sitecore 6.4.1 API
LinkDatabase..::..HasExternalReferrers Method
LinkDatabase Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool HasExternalReferrers(
    Item item,
    bool deep
)
Visual Basic
Public Overridable Function HasExternalReferrers ( _
    item As Item, _
    deep As Boolean _
) As Boolean
Visual C++
public:
virtual bool HasExternalReferrers(
    Item^ item,
    bool deep
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item.
deep
Type: System..::..Boolean
if set to true this instance is deep.

Return Value

true if the specified item has external referrers; otherwise, false.

See Also

LinkDatabase Class
Sitecore.Links Namespace


ItemExists Method

[image]

Sitecore 6.4.1 API
LinkDatabase..::..ItemExists Method
LinkDatabase Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool ItemExists(
    ID itemId,
    string itemPath,
    Language itemLanguage,
    Version itemVersion,
    Database database
)
Visual Basic
Protected Overridable Function ItemExists ( _
    itemId As ID, _
    itemPath As String, _
    itemLanguage As Language, _
    itemVersion As Version, _
    database As Database _
) As Boolean
Visual C++
protected:
virtual bool ItemExists(
    ID^ itemId,
    String^ itemPath,
    Language^ itemLanguage,
    Version^ itemVersion,
    Database^ database
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item ID.
itemPath
Type: System..::..String
The item path.
itemLanguage
Type: Sitecore.Globalization..::..Language
The item language.
itemVersion
Type: Sitecore.Data..::..Version
The item version.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

true if item with specified ID, language and version exists.

See Also

LinkDatabase Class
Sitecore.Links Namespace


Rebuild Method

[image]

Sitecore 6.4.1 API
LinkDatabase..::..Rebuild Method
LinkDatabase Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Rebuild(
    Database database
)
Visual Basic
Public Overridable Sub Rebuild ( _
    database As Database _
)
Visual C++
public:
virtual void Rebuild(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

See Also

LinkDatabase Class
Sitecore.Links Namespace


RemoveReferences Method

[image]

Sitecore 6.4.1 API
LinkDatabase..::..RemoveReferences Method
LinkDatabase Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract void RemoveReferences(
    Item item
)
Visual Basic
Public MustOverride Sub RemoveReferences ( _
    item As Item _
)
Visual C++
public:
virtual void RemoveReferences(
    Item^ item
) abstract

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item.

See Also

LinkDatabase Class
Sitecore.Links Namespace


TargetExists Method

[image]

Sitecore 6.4.1 API
LinkDatabase..::..TargetExists Method
LinkDatabase Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool TargetExists(
    ID targetID,
    string targetPath,
    Database database
)
Visual Basic
Protected Overridable Function TargetExists ( _
    targetID As ID, _
    targetPath As String, _
    database As Database _
) As Boolean
Visual C++
protected:
virtual bool TargetExists(
    ID^ targetID,
    String^ targetPath,
    Database^ database
)

Parameters

targetID
Type: Sitecore.Data..::..ID
The target ID.
targetPath
Type: System..::..String
The target path.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

true if the target exists, otherwise false.

See Also

LinkDatabase Class
Sitecore.Links Namespace


UpdateItemVersionLinks Method

[image]

Sitecore 6.4.1 API
LinkDatabase..::..UpdateItemVersionLinks Method
LinkDatabase Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void UpdateItemVersionLinks(
    Item item,
    ItemLink[] links
)
Visual Basic
Protected Overridable Sub UpdateItemVersionLinks ( _
    item As Item, _
    links As ItemLink() _
)
Visual C++
protected:
virtual void UpdateItemVersionLinks(
    Item^ item,
    array<ItemLink^>^ links
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item version.
links
Type: array< Sitecore.Links..::..ItemLink >[]()[][]
The links.

See Also

LinkDatabase Class
Sitecore.Links Namespace


UpdateItemVersionReferences Method

[image]

Sitecore 6.4.1 API
LinkDatabase..::..UpdateItemVersionReferences Method
LinkDatabase Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void UpdateItemVersionReferences(
    Item item
)
Visual Basic
Public Overridable Sub UpdateItemVersionReferences ( _
    item As Item _
)
Visual C++
public:
virtual void UpdateItemVersionReferences(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item.

See Also

LinkDatabase Class
Sitecore.Links Namespace


UpdateLinks Method

[image]

Sitecore 6.4.1 API
LinkDatabase..::..UpdateLinks Method
LinkDatabase Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected abstract void UpdateLinks(
    Item item,
    ItemLink[] links
)
Visual Basic
Protected MustOverride Sub UpdateLinks ( _
    item As Item, _
    links As ItemLink() _
)
Visual C++
protected:
virtual void UpdateLinks(
    Item^ item,
    array<ItemLink^>^ links
) abstract

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item.
links
Type: array< Sitecore.Links..::..ItemLink >[]()[][]
The links.

See Also

LinkDatabase Class
Sitecore.Links Namespace


UpdateReferences Method

[image]

Sitecore 6.4.1 API
LinkDatabase..::..UpdateReferences Method
LinkDatabase Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void UpdateReferences(
    Item item
)
Visual Basic
Public Overridable Sub UpdateReferences ( _
    item As Item _
)
Visual C++
public:
virtual void UpdateReferences(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item.

See Also

LinkDatabase Class
Sitecore.Links Namespace


LinkDatabaseHelper Class

[image]

Sitecore 6.4.1 API
LinkDatabaseHelper Class
Members See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class LinkDatabaseHelper
Visual Basic
Public NotInheritable Class LinkDatabaseHelper
Visual C++
public ref class LinkDatabaseHelper abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Links..::..LinkDatabaseHelper

See Also

LinkDatabaseHelper Members
Sitecore.Links Namespace


LinkDatabaseHelper Methods

[image] [image]

Sitecore 6.4.1 API
LinkDatabaseHelper Methods
LinkDatabaseHelper Class See Also Send Feedback

Methods

Name | Description
UpdateLink(Item) | Updates the links.
UpdateLink(Item, List<(Of <<'(ItemUri>)>>)) | Updates the link.

See Also

LinkDatabaseHelper Class
Sitecore.Links Namespace


UpdateLink Method

[image] [image]

Sitecore 6.4.1 API
LinkDatabaseHelper..::..UpdateLink Method
LinkDatabaseHelper Class See Also Send Feedback

Overload List

Name | Description
UpdateLink(Item) | Updates the links.
UpdateLink(Item, List<(Of <<'(ItemUri>)>>)) | Updates the link.

See Also

LinkDatabaseHelper Class
LinkDatabaseHelper Members
Sitecore.Links Namespace


UpdateLink Method (Item)

[image]

Sitecore 6.4.1 API
LinkDatabaseHelper..::..UpdateLink Method (Item)
LinkDatabaseHelper Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void UpdateLink(
    Item item
)
Visual Basic
Public Shared Sub UpdateLink ( _
    item As Item _
)
Visual C++
public:
static void UpdateLink(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

LinkDatabaseHelper Class
UpdateLink Overload
Sitecore.Links Namespace


UpdateLink Method (Item, List(ItemUri))

[image]

Sitecore 6.4.1 API
LinkDatabaseHelper..::..UpdateLink Method (Item, List<(Of <(<'ItemUri>)>)>)
LinkDatabaseHelper Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void UpdateLink(
    Item item,
    List<ItemUri> list
)
Visual Basic
Public Shared Sub UpdateLink ( _
    item As Item, _
    list As List(Of ItemUri) _
)
Visual C++
public:
static void UpdateLink(
    Item^ item,
    List<ItemUri^>^ list
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
list
Type: System.Collections.Generic..::..List <(Of <(<' ItemUri >)>)>
The list of items that was updated.

See Also

LinkDatabaseHelper Class
UpdateLink Overload
Sitecore.Links Namespace


LinkDatabaseProxy Class

[image]

Sitecore 6.4.1 API
LinkDatabaseProxy Class
Members See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class LinkDatabaseProxy
Visual Basic
Public NotInheritable Class LinkDatabaseProxy
Visual C++
public ref class LinkDatabaseProxy abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Links..::..LinkDatabaseProxy

See Also

LinkDatabaseProxy Members
Sitecore.Links Namespace


LinkDatabaseProxy Members

[image] [image]

Sitecore 6.4.1 API
LinkDatabaseProxy Members
LinkDatabaseProxy Class Methods See Also Send Feedback

The LinkDatabaseProxy type exposes the following members.

Methods

Name | Description
GetBrokenLinks | Gets the broken links.
GetStatus | Gets the status.

See Also

LinkDatabaseProxy Class
Sitecore.Links Namespace


LinkDatabaseProxy Methods

[image] [image]

Sitecore 6.4.1 API
LinkDatabaseProxy Methods
LinkDatabaseProxy Class See Also Send Feedback

The LinkDatabaseProxy type exposes the following members.

Methods

Name | Description
GetBrokenLinks | Gets the broken links.
GetStatus | Gets the status.

See Also

LinkDatabaseProxy Class
Sitecore.Links Namespace


GetBrokenLinks Method

[image]

Sitecore 6.4.1 API
LinkDatabaseProxy..::..GetBrokenLinks Method
LinkDatabaseProxy Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Handle GetBrokenLinks(
    Database database
)
Visual Basic
Public Shared Function GetBrokenLinks ( _
    database As Database _
) As Handle
Visual C++
public:
static Handle^ GetBrokenLinks(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

Return Value

The broken links.

See Also

LinkDatabaseProxy Class
Sitecore.Links Namespace


GetStatus Method

[image]

Sitecore 6.4.1 API
LinkDatabaseProxy..::..GetStatus Method
LinkDatabaseProxy Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static JobStatus GetStatus(
    Handle handle
)
Visual Basic
Public Shared Function GetStatus ( _
    handle As Handle _
) As JobStatus
Visual C++
public:
static JobStatus^ GetStatus(
    Handle^ handle
)

Parameters

handle
Type: Sitecore..::..Handle
The handle.

Return Value

The status.

See Also

LinkDatabaseProxy Class
Sitecore.Links Namespace


LinkDisabler Class

[image]

Sitecore 6.4.1 API
LinkDisabler Class
Members See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public sealed class LinkDisabler : Switcher<LinkDisablerState, LinkDisabler>
Visual Basic
Public NotInheritable Class LinkDisabler _
    Inherits Switcher(Of LinkDisablerState, LinkDisabler)
Visual C++
public ref class LinkDisabler sealed : public Switcher<LinkDisablerState, LinkDisabler^>

Inheritance Hierarchy

System..::..Object
Sitecore.Common..::..Switcher <(Of <(<' LinkDisablerState, LinkDisabler>)>)>
Sitecore.Links..::..LinkDisabler

See Also

LinkDisabler Members
Sitecore.Links Namespace


LinkDisabler Members

[image] [image]

Sitecore 6.4.1 API
LinkDisabler Members
LinkDisabler Class Constructors Methods Properties Events See Also Send Feedback

The LinkDisabler type exposes the following members.

Constructors

 | Name | Description
Public method | LinkDisabler | Initializes a new instance of the LinkDisabler class.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Switcher<(Of <(<'TValue, TSwitchType>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsActive | Gets a value indicating whether this instance is active.

Events

 | Name | Description
Protected event | Disposed | Occurs when the object has been disposed. (Inherited from Switcher<(Of <(<'TValue, TSwitchType>)>)>.)

See Also

LinkDisabler Class
Sitecore.Links Namespace


LinkDisabler Constructor

[image]

Sitecore 6.4.1 API
LinkDisabler Constructor
LinkDisabler Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LinkDisabler()
Visual Basic
Public Sub New
Visual C++
public:
LinkDisabler()

See Also

LinkDisabler Class
Sitecore.Links Namespace


LinkDisabler Methods

[image] [image]

Sitecore 6.4.1 API
LinkDisabler Methods
LinkDisabler Class See Also Send Feedback

The LinkDisabler type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Switcher<(Of <(<'TValue, TSwitchType>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LinkDisabler Class
Sitecore.Links Namespace


LinkDisabler Properties

[image] [image]

Sitecore 6.4.1 API
LinkDisabler Properties
LinkDisabler Class See Also Send Feedback

The LinkDisabler type exposes the following members.

Properties

Name | Description
IsActive | Gets a value indicating whether this instance is active.

See Also

LinkDisabler Class
Sitecore.Links Namespace


IsActive Property

[image]

Sitecore 6.4.1 API
LinkDisabler..::..IsActive Property
LinkDisabler Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsActive { get; }
Visual Basic
Public Shared ReadOnly Property IsActive As Boolean
    Get
Visual C++
public:
static property bool IsActive {
    bool get ();
}

Field Value

true if this instance is active; otherwise, false.

See Also

LinkDisabler Class
Sitecore.Links Namespace


LinkDisabler Events

[image] [image]

Sitecore 6.4.1 API
LinkDisabler Events
LinkDisabler Class See Also Send Feedback

The LinkDisabler type exposes the following members.

Events

 | Name | Description
Protected event | Disposed | Occurs when the object has been disposed. (Inherited from Switcher<(Of <(<'TValue, TSwitchType>)>)>.)

See Also

LinkDisabler Class
Sitecore.Links Namespace


LinkDisablerState Enumeration

[image]

Sitecore 6.4.1 API
LinkDisablerState Enumeration
See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum LinkDisablerState
Visual Basic
Public Enumeration LinkDisablerState
Visual C++
public enum class LinkDisablerState

Members

Member name | Value | Description
Disabled | 0 |
Enabled | 1 |

See Also

Sitecore.Links Namespace


LinkManager Class

[image]

Sitecore 6.4.1 API
LinkManager Class
Members See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class LinkManager
Visual Basic
Public NotInheritable Class LinkManager
Visual C++
public ref class LinkManager abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Links..::..LinkManager

See Also

LinkManager Members
Sitecore.Links Namespace


LinkManager Members

[image] [image]

Sitecore 6.4.1 API
LinkManager Members
LinkManager Class Methods Properties See Also Send Feedback

The LinkManager type exposes the following members.

Methods

Name | Description
ExpandDynamicLinks(String) | Expands all dynamic links embedded in a text.
ExpandDynamicLinks(String, Boolean) | Expands all dynamic links embedded in a text.
GetDefaultUrlOptions | Gets (a clone of) the default URL options.
GetDynamicUrl(Item) | Gets the dynamic URL for an item.
GetDynamicUrl(Item, LinkUrlOptions) | Gets the dynamic URL for an item.
GetItemUrl(Item) | Gets the (friendly) URL of an item.
GetItemUrl(Item, UrlOptions) | Gets the (friendly) URL of an item.
IsDynamicLink | Determines whether the specified link text represents a dynamic link.
ParseDynamicLink | Parses a dynamic link.
ParseRequestUrl | Parses a request URL.

Properties

Name | Description
AddAspxExtension | Gets a value indicating whether to add the 'aspx' extension to generated URLs.
AlwaysIncludeServerUrl | Gets a value indicating whether to always add the current server URL to generated URLs.
LanguageEmbedding | Gets a value controlling if and how to embed language in the URL.
LanguageLocation | Gets the language location.
Provider | Gets the provider.
Providers | Gets the providers.
ShortenUrls | Gets a value indicating whether to shorten generated URLs.
UseDisplayName | Gets a value indicating whether to use the DisplayName of items when generating URLs.

See Also

LinkManager Class
Sitecore.Links Namespace


LinkManager Methods

[image] [image]

Sitecore 6.4.1 API
LinkManager Methods
LinkManager Class See Also Send Feedback

The LinkManager type exposes the following members.

Methods

Name | Description
ExpandDynamicLinks(String) | Expands all dynamic links embedded in a text.
ExpandDynamicLinks(String, Boolean) | Expands all dynamic links embedded in a text.
GetDefaultUrlOptions | Gets (a clone of) the default URL options.
GetDynamicUrl(Item) | Gets the dynamic URL for an item.
GetDynamicUrl(Item, LinkUrlOptions) | Gets the dynamic URL for an item.
GetItemUrl(Item) | Gets the (friendly) URL of an item.
GetItemUrl(Item, UrlOptions) | Gets the (friendly) URL of an item.
IsDynamicLink | Determines whether the specified link text represents a dynamic link.
ParseDynamicLink | Parses a dynamic link.
ParseRequestUrl | Parses a request URL.

See Also

LinkManager Class
Sitecore.Links Namespace


ExpandDynamicLinks Method

[image] [image]

Sitecore 6.4.1 API
LinkManager..::..ExpandDynamicLinks Method
LinkManager Class See Also Send Feedback

Overload List

Name | Description
ExpandDynamicLinks(String) | Expands all dynamic links embedded in a text.
ExpandDynamicLinks(String, Boolean) | Expands all dynamic links embedded in a text.

See Also

LinkManager Class
LinkManager Members
Sitecore.Links Namespace


ExpandDynamicLinks Method (String)

[image]

Sitecore 6.4.1 API
LinkManager..::..ExpandDynamicLinks Method (String)
LinkManager Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ExpandDynamicLinks(
    string text
)
Visual Basic
Public Shared Function ExpandDynamicLinks ( _
    text As String _
) As String
Visual C++
public:
static String^ ExpandDynamicLinks(
    String^ text
)

Parameters

text
Type: System..::..String
The text.

Return Value

[Missing <returns> documentation for "M:Sitecore.Links.LinkManager.ExpandDynamicLinks(System.String)"]

See Also

LinkManager Class
ExpandDynamicLinks Overload
Sitecore.Links Namespace


ExpandDynamicLinks Method (String, Boolean)

[image]

Sitecore 6.4.1 API
LinkManager..::..ExpandDynamicLinks Method (String, Boolean)
LinkManager Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ExpandDynamicLinks(
    string text,
    bool resolveSites
)
Visual Basic
Public Shared Function ExpandDynamicLinks ( _
    text As String, _
    resolveSites As Boolean _
) As String
Visual C++
public:
static String^ ExpandDynamicLinks(
    String^ text,
    bool resolveSites
)

Parameters

text
Type: System..::..String
The text.
resolveSites
Type: System..::..Boolean
Set this to true to resolve site information when expanding dynamic links.

Return Value

[Missing <returns> documentation for "M:Sitecore.Links.LinkManager.ExpandDynamicLinks(System.String,System.Boolean)"]

See Also

LinkManager Class
ExpandDynamicLinks Overload
Sitecore.Links Namespace


GetDefaultUrlOptions Method

[image]

Sitecore 6.4.1 API
LinkManager..::..GetDefaultUrlOptions Method
LinkManager Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static UrlOptions GetDefaultUrlOptions()
Visual Basic
Public Shared Function GetDefaultUrlOptions As UrlOptions
Visual C++
public:
static UrlOptions^ GetDefaultUrlOptions()

Return Value

[Missing <returns> documentation for "M:Sitecore.Links.LinkManager.GetDefaultUrlOptions"]

See Also

LinkManager Class
Sitecore.Links Namespace


GetDynamicUrl Method

[image] [image]

Sitecore 6.4.1 API
LinkManager..::..GetDynamicUrl Method
LinkManager Class See Also Send Feedback

Overload List

Name | Description
GetDynamicUrl(Item) | Gets the dynamic URL for an item.
GetDynamicUrl(Item, LinkUrlOptions) | Gets the dynamic URL for an item.

See Also

LinkManager Class
LinkManager Members
Sitecore.Links Namespace


GetDynamicUrl Method (Item)

[image]

Sitecore 6.4.1 API
LinkManager..::..GetDynamicUrl Method (Item)
LinkManager Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetDynamicUrl(
    Item item
)
Visual Basic
Public Shared Function GetDynamicUrl ( _
    item As Item _
) As String
Visual C++
public:
static String^ GetDynamicUrl(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item to create an URL to.

Return Value

[Missing <returns> documentation for "M:Sitecore.Links.LinkManager.GetDynamicUrl(Sitecore.Data.Items.Item)"]

See Also

LinkManager Class
GetDynamicUrl Overload
Sitecore.Links Namespace


GetDynamicUrl Method (Item, LinkUrlOptions)

[image]

Sitecore 6.4.1 API
LinkManager..::..GetDynamicUrl Method (Item, LinkUrlOptions)
LinkManager Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetDynamicUrl(
    Item item,
    LinkUrlOptions options
)
Visual Basic
Public Shared Function GetDynamicUrl ( _
    item As Item, _
    options As LinkUrlOptions _
) As String
Visual C++
public:
static String^ GetDynamicUrl(
    Item^ item,
    LinkUrlOptions^ options
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item to create an URL to.
options
Type: Sitecore.Links..::..LinkUrlOptions
The options.

Return Value

[Missing <returns> documentation for "M:Sitecore.Links.LinkManager.GetDynamicUrl(Sitecore.Data.Items.Item,Sitecore.Links.LinkUrlOptions)"]

See Also

LinkManager Class
GetDynamicUrl Overload
Sitecore.Links Namespace


GetItemUrl Method

[image] [image]

Sitecore 6.4.1 API
LinkManager..::..GetItemUrl Method
LinkManager Class See Also Send Feedback

Overload List

Name | Description
GetItemUrl(Item) | Gets the (friendly) URL of an item.
GetItemUrl(Item, UrlOptions) | Gets the (friendly) URL of an item.

See Also

LinkManager Class
LinkManager Members
Sitecore.Links Namespace


GetItemUrl Method (Item)

[image]

Sitecore 6.4.1 API
LinkManager..::..GetItemUrl Method (Item)
LinkManager Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetItemUrl(
    Item item
)
Visual Basic
Public Shared Function GetItemUrl ( _
    item As Item _
) As String
Visual C++
public:
static String^ GetItemUrl(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Links.LinkManager.GetItemUrl(Sitecore.Data.Items.Item)"]

See Also

LinkManager Class
GetItemUrl Overload
Sitecore.Links Namespace


GetItemUrl Method (Item, UrlOptions)

[image]

Sitecore 6.4.1 API
LinkManager..::..GetItemUrl Method (Item, UrlOptions)
LinkManager Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetItemUrl(
    Item item,
    UrlOptions options
)
Visual Basic
Public Shared Function GetItemUrl ( _
    item As Item, _
    options As UrlOptions _
) As String
Visual C++
public:
static String^ GetItemUrl(
    Item^ item,
    UrlOptions^ options
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
options
Type: Sitecore.Links..::..UrlOptions
The options.

Return Value

[Missing <returns> documentation for "M:Sitecore.Links.LinkManager.GetItemUrl(Sitecore.Data.Items.Item,Sitecore.Links.UrlOptions)"]

See Also

LinkManager Class
GetItemUrl Overload
Sitecore.Links Namespace


IsDynamicLink Method

[image]

Sitecore 6.4.1 API
LinkManager..::..IsDynamicLink Method
LinkManager Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsDynamicLink(
    string linkText
)
Visual Basic
Public Shared Function IsDynamicLink ( _
    linkText As String _
) As Boolean
Visual C++
public:
static bool IsDynamicLink(
    String^ linkText
)

Parameters

linkText
Type: System..::..String
The link text.

Return Value

true if [is dynamic link] [the specified link text]; otherwise, false.

See Also

LinkManager Class
Sitecore.Links Namespace


ParseDynamicLink Method

[image]

Sitecore 6.4.1 API
LinkManager..::..ParseDynamicLink Method
LinkManager Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static DynamicLink ParseDynamicLink(
    string linkText
)
Visual Basic
Public Shared Function ParseDynamicLink ( _
    linkText As String _
) As DynamicLink
Visual C++
public:
static DynamicLink^ ParseDynamicLink(
    String^ linkText
)

Parameters

linkText
Type: System..::..String
The link text.

Return Value

[Missing <returns> documentation for "M:Sitecore.Links.LinkManager.ParseDynamicLink(System.String)"]

See Also

LinkManager Class
Sitecore.Links Namespace


ParseRequestUrl Method

[image]

Sitecore 6.4.1 API
LinkManager..::..ParseRequestUrl Method
LinkManager Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static RequestUrl ParseRequestUrl(
    HttpRequest request
)
Visual Basic
Public Shared Function ParseRequestUrl ( _
    request As HttpRequest _
) As RequestUrl
Visual C++
public:
static RequestUrl^ ParseRequestUrl(
    HttpRequest^ request
)

Parameters

request
Type: System.Web..::..HttpRequest
The request.

Return Value

[Missing <returns> documentation for "M:Sitecore.Links.LinkManager.ParseRequestUrl(System.Web.HttpRequest)"]

See Also

LinkManager Class
Sitecore.Links Namespace


LinkManager Properties

[image] [image]

Sitecore 6.4.1 API
LinkManager Properties
LinkManager Class See Also Send Feedback

The LinkManager type exposes the following members.

Properties

Name | Description
AddAspxExtension | Gets a value indicating whether to add the 'aspx' extension to generated URLs.
AlwaysIncludeServerUrl | Gets a value indicating whether to always add the current server URL to generated URLs.
LanguageEmbedding | Gets a value controlling if and how to embed language in the URL.
LanguageLocation | Gets the language location.
Provider | Gets the provider.
Providers | Gets the providers.
ShortenUrls | Gets a value indicating whether to shorten generated URLs.
UseDisplayName | Gets a value indicating whether to use the DisplayName of items when generating URLs.

See Also

LinkManager Class
Sitecore.Links Namespace


AddAspxExtension Property

[image]

Sitecore 6.4.1 API
LinkManager..::..AddAspxExtension Property
LinkManager Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool AddAspxExtension { get; }
Visual Basic
Public Shared ReadOnly Property AddAspxExtension As Boolean
    Get
Visual C++
public:
static property bool AddAspxExtension {
    bool get ();
}

Field Value

true if the 'aspx' extension should be added to generated URLs; otherwise, false.

See Also

LinkManager Class
Sitecore.Links Namespace


AlwaysIncludeServerUrl Property

[image]

Sitecore 6.4.1 API
LinkManager..::..AlwaysIncludeServerUrl Property
LinkManager Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool AlwaysIncludeServerUrl { get; }
Visual Basic
Public Shared ReadOnly Property AlwaysIncludeServerUrl As Boolean
    Get
Visual C++
public:
static property bool AlwaysIncludeServerUrl {
    bool get ();
}

Field Value

true if the server URL should always be added to generated URLs; otherwise, false.

See Also

LinkManager Class
Sitecore.Links Namespace


Provider Property

[image]

Sitecore 6.4.1 API
LinkManager..::..Provider Property
LinkManager Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static LinkProvider Provider { get; }
Visual Basic
Public Shared ReadOnly Property Provider As LinkProvider
    Get
Visual C++
public:
static property LinkProvider^ Provider {
    LinkProvider^ get ();
}

Field Value

The provider.

See Also

LinkManager Class
Sitecore.Links Namespace


Providers Property

[image]

Sitecore 6.4.1 API
LinkManager..::..Providers Property
LinkManager Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static LinkProviderCollection Providers { get; }
Visual Basic
Public Shared ReadOnly Property Providers As LinkProviderCollection
    Get
Visual C++
public:
static property LinkProviderCollection^ Providers {
    LinkProviderCollection^ get ();
}

Field Value

The provider.

See Also

LinkManager Class
Sitecore.Links Namespace


ShortenUrls Property

[image]

Sitecore 6.4.1 API
LinkManager..::..ShortenUrls Property
LinkManager Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool ShortenUrls { get; }
Visual Basic
Public Shared ReadOnly Property ShortenUrls As Boolean
    Get
Visual C++
public:
static property bool ShortenUrls {
    bool get ();
}

Field Value

true if URLs should be shortened; otherwise, false.

See Also

LinkManager Class
Sitecore.Links Namespace


UseDisplayName Property

[image]

Sitecore 6.4.1 API
LinkManager..::..UseDisplayName Property
LinkManager Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool UseDisplayName { get; }
Visual Basic
Public Shared ReadOnly Property UseDisplayName As Boolean
    Get
Visual C++
public:
static property bool UseDisplayName {
    bool get ();
}

Field Value

true if display names should be used; otherwise, false.

See Also

LinkManager Class
Sitecore.Links Namespace


LinkProvider Class

[image]

Sitecore 6.4.1 API
LinkProvider Class
Members See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class LinkProvider : ProviderBase
Visual Basic
Public Class LinkProvider _
    Inherits ProviderBase
Visual C++
public ref class LinkProvider : public ProviderBase

Inheritance Hierarchy

System..::..Object
System.Configuration.Provider..::..ProviderBase
Sitecore.Links..::..LinkProvider

See Also

LinkProvider Members
Sitecore.Links Namespace


LinkProvider Members

[image] [image]

Sitecore 6.4.1 API
LinkProvider Members
LinkProvider Class Constructors Methods Properties See Also Send Feedback

The LinkProvider type exposes the following members.

Constructors

 | Name | Description
Public method | LinkProvider | Initializes a new instance of the LinkProvider class

Methods

 | Name | Description
Protected method | CreateLinkBuilder | Creates a link builder.
Protected method | CreateLinkParser | Creates a link parser.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExpandDynamicLinks(String) | Obsolete. Expands all dynamic links embedded in a text.
Public method | ExpandDynamicLinks(String, Boolean) | Expands the dynamic links.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDefaultUrlOptions | Gets (a clone of) the default URL options.
Public method | GetDynamicUrl | Gets the dynamic URL for an item.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemUrl | Gets the (friendly) URL of an item.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the provider. (Overrides ProviderBase..::..Initialize(String, NameValueCollection).)
Public method | IsDynamicLink | Determines whether the specified link text represents a dynamic link.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseDynamicLink | Parses a dynamic link.
Public method | ParseRequestUrl | Parses a request URL.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AddAspxExtension | Gets a value indicating whether to add the 'aspx' extension to generated URLs.
Public property | AlwaysIncludeServerUrl | Gets a value indicating whether to always add the current server URL to generated URLs.
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | EncodeNames | Gets or sets a value indicating whether to encode the names making up the URL of the link.
Public property | LanguageEmbedding | Gets a value controlling if and how to embed language in the URL.
Public property | LanguageLocation | Gets the language location.
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
Public property | ShortenUrls | Gets a value indicating whether to shorten generated URLs.
Public property | UseDisplayName | Gets a value indicating whether to use the DisplayName of items when generating URLs.

See Also

LinkProvider Class
Sitecore.Links Namespace


LinkProvider Constructor

[image]

Sitecore 6.4.1 API
LinkProvider Constructor
LinkProvider Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LinkProvider()
Visual Basic
Public Sub New
Visual C++
public:
LinkProvider()

See Also

LinkProvider Class
Sitecore.Links Namespace


LinkProvider Methods

[image] [image]

Sitecore 6.4.1 API
LinkProvider Methods
LinkProvider Class See Also Send Feedback

The LinkProvider type exposes the following members.

Methods

 | Name | Description
Protected method | CreateLinkBuilder | Creates a link builder.
Protected method | CreateLinkParser | Creates a link parser.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExpandDynamicLinks(String) | Obsolete. Expands all dynamic links embedded in a text.
Public method | ExpandDynamicLinks(String, Boolean) | Expands the dynamic links.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDefaultUrlOptions | Gets (a clone of) the default URL options.
Public method | GetDynamicUrl | Gets the dynamic URL for an item.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemUrl | Gets the (friendly) URL of an item.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the provider. (Overrides ProviderBase..::..Initialize(String, NameValueCollection).)
Public method | IsDynamicLink | Determines whether the specified link text represents a dynamic link.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseDynamicLink | Parses a dynamic link.
Public method | ParseRequestUrl | Parses a request URL.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LinkProvider Class
Sitecore.Links Namespace


CreateLinkBuilder Method

[image]

Sitecore 6.4.1 API
LinkProvider..::..CreateLinkBuilder Method
LinkProvider Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual LinkProvider..::..LinkBuilder CreateLinkBuilder(
    UrlOptions options
)
Visual Basic
Protected Overridable Function CreateLinkBuilder ( _
    options As UrlOptions _
) As LinkProvider..::..LinkBuilder
Visual C++
protected:
virtual LinkProvider..::..LinkBuilder^ CreateLinkBuilder(
    UrlOptions^ options
)

Parameters

options
Type: Sitecore.Links..::..UrlOptions
The options.

Return Value

[Missing <returns> documentation for "M:Sitecore.Links.LinkProvider.CreateLinkBuilder(Sitecore.Links.UrlOptions)"]

See Also

LinkProvider Class
Sitecore.Links Namespace


CreateLinkParser Method

[image]

Sitecore 6.4.1 API
LinkProvider..::..CreateLinkParser Method
LinkProvider Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual LinkProvider..::..LinkParser CreateLinkParser()
Visual Basic
Protected Overridable Function CreateLinkParser As LinkProvider..::..LinkParser
Visual C++
protected:
virtual LinkProvider..::..LinkParser^ CreateLinkParser()

Return Value

[Missing <returns> documentation for "M:Sitecore.Links.LinkProvider.CreateLinkParser"]

See Also

LinkProvider Class
Sitecore.Links Namespace


ExpandDynamicLinks Method

[image] [image]

Sitecore 6.4.1 API
LinkProvider..::..ExpandDynamicLinks Method
LinkProvider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExpandDynamicLinks(String) | Obsolete. Expands all dynamic links embedded in a text.
Public method | ExpandDynamicLinks(String, Boolean) | Expands the dynamic links.

See Also

LinkProvider Class
LinkProvider Members
Sitecore.Links Namespace


ExpandDynamicLinks Method (String)

[image]

Sitecore 6.4.1 API
LinkProvider..::..ExpandDynamicLinks Method (String)
LinkProvider Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("This method is never called by LinkManager. Implement ExpandDynamicLinks(string text, bool resolveSites) instead.")]
public virtual string ExpandDynamicLinks(
    string text
)
Visual Basic
<ObsoleteAttribute("This method is never called by LinkManager. Implement ExpandDynamicLinks(string text, bool resolveSites) instead.")> _
Public Overridable Function ExpandDynamicLinks ( _
    text As String _
) As String
Visual C++
[ObsoleteAttribute(L"This method is never called by LinkManager. Implement ExpandDynamicLinks(string text, bool resolveSites) instead.")]
public:
virtual String^ ExpandDynamicLinks(
    String^ text
)

Parameters

text
Type: System..::..String
The text.

Return Value

[Missing <returns> documentation for "M:Sitecore.Links.LinkProvider.ExpandDynamicLinks(System.String)"]

See Also

LinkProvider Class
ExpandDynamicLinks Overload
Sitecore.Links Namespace


ExpandDynamicLinks Method (String, Boolean)

[image]

Sitecore 6.4.1 API
LinkProvider..::..ExpandDynamicLinks Method (String, Boolean)
LinkProvider Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string ExpandDynamicLinks(
    string text,
    bool resolveSites
)
Visual Basic
Public Overridable Function ExpandDynamicLinks ( _
    text As String, _
    resolveSites As Boolean _
) As String
Visual C++
public:
virtual String^ ExpandDynamicLinks(
    String^ text,
    bool resolveSites
)

Parameters

text
Type: System..::..String
The text.
resolveSites
Type: System..::..Boolean
Set this to true to resolve site information when expanding dynamic links.

Return Value

[Missing <returns> documentation for "M:Sitecore.Links.LinkProvider.ExpandDynamicLinks(System.String,System.Boolean)"]

See Also

LinkProvider Class
ExpandDynamicLinks Overload
Sitecore.Links Namespace


GetDefaultUrlOptions Method

[image]

Sitecore 6.4.1 API
LinkProvider..::..GetDefaultUrlOptions Method
LinkProvider Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual UrlOptions GetDefaultUrlOptions()
Visual Basic
Public Overridable Function GetDefaultUrlOptions As UrlOptions
Visual C++
public:
virtual UrlOptions^ GetDefaultUrlOptions()

Return Value

[Missing <returns> documentation for "M:Sitecore.Links.LinkProvider.GetDefaultUrlOptions"]

See Also

LinkProvider Class
Sitecore.Links Namespace


GetDynamicUrl Method

[image]

Sitecore 6.4.1 API
LinkProvider..::..GetDynamicUrl Method
LinkProvider Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string GetDynamicUrl(
    Item item,
    LinkUrlOptions options
)
Visual Basic
Public Overridable Function GetDynamicUrl ( _
    item As Item, _
    options As LinkUrlOptions _
) As String
Visual C++
public:
virtual String^ GetDynamicUrl(
    Item^ item,
    LinkUrlOptions^ options
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item to create an URL to.
options
Type: Sitecore.Links..::..LinkUrlOptions
The options.

Return Value

[Missing <returns> documentation for "M:Sitecore.Links.LinkProvider.GetDynamicUrl(Sitecore.Data.Items.Item,Sitecore.Links.LinkUrlOptions)"]

See Also

LinkProvider Class
Sitecore.Links Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
LinkProvider..::..Initialize Method
LinkProvider Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Initialize(
    string name,
    NameValueCollection config
)
Visual Basic
Public Overrides Sub Initialize ( _
    name As String, _
    config As NameValueCollection _
)
Visual C++
public:
virtual void Initialize(
    String^ name,
    NameValueCollection^ config
) override

Parameters

name
Type: System..::..String
The friendly name of the provider.
config
Type: System.Collections.Specialized..::..NameValueCollection
A collection of the name/value pairs representing the provider-specific attributes specified in the configuration for this provider.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The name of the provider is null.
System..::..ArgumentException | The name of the provider has a length of zero.
System..::..InvalidOperationException | An attempt is made to call Initialize(String, NameValueCollection) on a provider after the provider has already been initialized.

See Also

LinkProvider Class
Sitecore.Links Namespace


IsDynamicLink Method

[image]

Sitecore 6.4.1 API
LinkProvider..::..IsDynamicLink Method
LinkProvider Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool IsDynamicLink(
    string linkText
)
Visual Basic
Public Overridable Function IsDynamicLink ( _
    linkText As String _
) As Boolean
Visual C++
public:
virtual bool IsDynamicLink(
    String^ linkText
)

Parameters

linkText
Type: System..::..String
The link text.

Return Value

true if [is dynamic link] [the specified link text]; otherwise, false.

See Also

LinkProvider Class
Sitecore.Links Namespace


ParseDynamicLink Method

[image]

Sitecore 6.4.1 API
LinkProvider..::..ParseDynamicLink Method
LinkProvider Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual DynamicLink ParseDynamicLink(
    string linkText
)
Visual Basic
Public Overridable Function ParseDynamicLink ( _
    linkText As String _
) As DynamicLink
Visual C++
public:
virtual DynamicLink^ ParseDynamicLink(
    String^ linkText
)

Parameters

linkText
Type: System..::..String
The link text.

Return Value

[Missing <returns> documentation for "M:Sitecore.Links.LinkProvider.ParseDynamicLink(System.String)"]

See Also

LinkProvider Class
Sitecore.Links Namespace


LinkProvider Properties

[image] [image]

Sitecore 6.4.1 API
LinkProvider Properties
LinkProvider Class See Also Send Feedback

The LinkProvider type exposes the following members.

Properties

 | Name | Description
Public property | AddAspxExtension | Gets a value indicating whether to add the 'aspx' extension to generated URLs.
Public property | AlwaysIncludeServerUrl | Gets a value indicating whether to always add the current server URL to generated URLs.
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | EncodeNames | Gets or sets a value indicating whether to encode the names making up the URL of the link.
Public property | LanguageEmbedding | Gets a value controlling if and how to embed language in the URL.
Public property | LanguageLocation | Gets the language location.
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
Public property | ShortenUrls | Gets a value indicating whether to shorten generated URLs.
Public property | UseDisplayName | Gets a value indicating whether to use the DisplayName of items when generating URLs.

See Also

LinkProvider Class
Sitecore.Links Namespace


AddAspxExtension Property

[image]

Sitecore 6.4.1 API
LinkProvider..::..AddAspxExtension Property
LinkProvider Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool AddAspxExtension { get; }
Visual Basic
Public Overridable ReadOnly Property AddAspxExtension As Boolean
    Get
Visual C++
public:
virtual property bool AddAspxExtension {
    bool get ();
}

Field Value

true if the 'aspx' extension should be added to generated URLs; otherwise, false.

See Also

LinkProvider Class
Sitecore.Links Namespace


AlwaysIncludeServerUrl Property

[image]

Sitecore 6.4.1 API
LinkProvider..::..AlwaysIncludeServerUrl Property
LinkProvider Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool AlwaysIncludeServerUrl { get; }
Visual Basic
Public Overridable ReadOnly Property AlwaysIncludeServerUrl As Boolean
    Get
Visual C++
public:
virtual property bool AlwaysIncludeServerUrl {
    bool get ();
}

Field Value

true if the server URL should always be added to generated URLs; otherwise, false.

See Also

LinkProvider Class
Sitecore.Links Namespace


EncodeNames Property

[image]

Sitecore 6.4.1 API
LinkProvider..::..EncodeNames Property
LinkProvider Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool EncodeNames { get; }
Visual Basic
Public Overridable ReadOnly Property EncodeNames As Boolean
    Get
Visual C++
public:
virtual property bool EncodeNames {
    bool get ();
}

Field Value

true if encode names; otherwise, false.

See Also

LinkProvider Class
Sitecore.Links Namespace


LanguageEmbedding Property

[image]

Sitecore 6.4.1 API
LinkProvider..::..LanguageEmbedding Property
LinkProvider Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual LanguageEmbedding LanguageEmbedding { get; }
Visual Basic
Public Overridable ReadOnly Property LanguageEmbedding As LanguageEmbedding
    Get
Visual C++
public:
virtual property LanguageEmbedding LanguageEmbedding {
    LanguageEmbedding get ();
}

Field Value

The embed language option.

See Also

LinkProvider Class
Sitecore.Links Namespace


LanguageLocation Property

[image]

Sitecore 6.4.1 API
LinkProvider..::..LanguageLocation Property
LinkProvider Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual LanguageLocation LanguageLocation { get; }
Visual Basic
Public Overridable ReadOnly Property LanguageLocation As LanguageLocation
    Get
Visual C++
public:
virtual property LanguageLocation LanguageLocation {
    LanguageLocation get ();
}

Field Value

The location within the URL where the language should be added.

See Also

LinkProvider Class
Sitecore.Links Namespace


ShortenUrls Property

[image]

Sitecore 6.4.1 API
LinkProvider..::..ShortenUrls Property
LinkProvider Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool ShortenUrls { get; }
Visual Basic
Public Overridable ReadOnly Property ShortenUrls As Boolean
    Get
Visual C++
public:
virtual property bool ShortenUrls {
    bool get ();
}

Field Value

true if URLs should be shortened; otherwise, false.

See Also

LinkProvider Class
Sitecore.Links Namespace


UseDisplayName Property

[image]

Sitecore 6.4.1 API
LinkProvider..::..UseDisplayName Property
LinkProvider Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool UseDisplayName { get; }
Visual Basic
Public Overridable ReadOnly Property UseDisplayName As Boolean
    Get
Visual C++
public:
virtual property bool UseDisplayName {
    bool get ();
}

Field Value

true if display names should be used; otherwise, false.

See Also

LinkProvider Class
Sitecore.Links Namespace


LinkProvider.LinkBuilder Class

[image]

Sitecore 6.4.1 API
LinkProvider..::..LinkBuilder Class
LinkProvider Class Members See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class LinkBuilder
Visual Basic
Public Class LinkBuilder
Visual C++
public ref class LinkBuilder

Inheritance Hierarchy

System..::..Object
Sitecore.Links..::..LinkProvider..::..LinkBuilder

See Also

LinkProvider..::..LinkBuilder Members
Sitecore.Links Namespace


LinkProvider.LinkBuilder Members

[image] [image]

Sitecore 6.4.1 API
LinkProvider..::..LinkBuilder Members
LinkProvider..::..LinkBuilder Class Constructors Methods See Also Send Feedback

LinkProvider class
LinkProvider
LinkProvider

The LinkProvider..::..LinkBuilder type exposes the following members.

Constructors

 | Name | Description
Public method | LinkProvider..::..LinkBuilder | Initializes a new instance of the LinkProvider..::..LinkBuilder class.

Methods

 | Name | Description
Protected method | BuildItemUrl | Builds the item URL.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemUrl | Gets the URL.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ResolveTargetSite | Resolves the target site.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LinkProvider..::..LinkBuilder Class
Sitecore.Links Namespace


LinkProvider.LinkBuilder Constructor

[image]

Sitecore 6.4.1 API
LinkProvider..::..LinkBuilder Constructor
LinkProvider..::..LinkBuilder Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LinkBuilder(
    UrlOptions options
)
Visual Basic
Public Sub New ( _
    options As UrlOptions _
)
Visual C++
public:
LinkBuilder(
    UrlOptions^ options
)

Parameters

options
Type: Sitecore.Links..::..UrlOptions
The URL options.

See Also

LinkProvider..::..LinkBuilder Class
Sitecore.Links Namespace


LinkProvider.LinkBuilder Methods

[image] [image]

Sitecore 6.4.1 API
LinkProvider..::..LinkBuilder Methods
LinkProvider..::..LinkBuilder Class See Also Send Feedback

The LinkProvider..::..LinkBuilder type exposes the following members.

Methods

 | Name | Description
Protected method | BuildItemUrl | Builds the item URL.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemUrl | Gets the URL.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ResolveTargetSite | Resolves the target site.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LinkProvider..::..LinkBuilder Class
Sitecore.Links Namespace


BuildItemUrl Method

[image]

Sitecore 6.4.1 API
LinkProvider..::..LinkBuilder..::..BuildItemUrl Method
LinkProvider..::..LinkBuilder Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string BuildItemUrl(
    Item item
)
Visual Basic
Protected Overridable Function BuildItemUrl ( _
    item As Item _
) As String
Visual C++
protected:
virtual String^ BuildItemUrl(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Links.LinkProvider.LinkBuilder.BuildItemUrl(Sitecore.Data.Items.Item)"]

See Also

LinkProvider..::..LinkBuilder Class
Sitecore.Links Namespace


GetItemUrl Method

[image]

Sitecore 6.4.1 API
LinkProvider..::..LinkBuilder..::..GetItemUrl Method
LinkProvider..::..LinkBuilder Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetItemUrl(
    Item item
)
Visual Basic
Public Function GetItemUrl ( _
    item As Item _
) As String
Visual C++
public:
String^ GetItemUrl(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Links.LinkProvider.LinkBuilder.GetItemUrl(Sitecore.Data.Items.Item)"]

See Also

LinkProvider..::..LinkBuilder Class
Sitecore.Links Namespace


ResolveTargetSite Method

[image]

Sitecore 6.4.1 API
LinkProvider..::..LinkBuilder..::..ResolveTargetSite Method
LinkProvider..::..LinkBuilder Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual SiteInfo ResolveTargetSite(
    Item item
)
Visual Basic
Protected Overridable Function ResolveTargetSite ( _
    item As Item _
) As SiteInfo
Visual C++
protected:
virtual SiteInfo^ ResolveTargetSite(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Links.LinkProvider.LinkBuilder.ResolveTargetSite(Sitecore.Data.Items.Item)"]

See Also

LinkProvider..::..LinkBuilder Class
Sitecore.Links Namespace


LinkProvider.LinkParser Class

[image]

Sitecore 6.4.1 API
LinkProvider..::..LinkParser Class
LinkProvider Class Members See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class LinkParser
Visual Basic
Public Class LinkParser
Visual C++
public ref class LinkParser

Inheritance Hierarchy

System..::..Object
Sitecore.Links..::..LinkProvider..::..LinkParser

See Also

LinkProvider..::..LinkParser Members
Sitecore.Links Namespace


LinkProvider.LinkParser Members

[image] [image]

Sitecore 6.4.1 API
LinkProvider..::..LinkParser Members
LinkProvider..::..LinkParser Class Constructors Methods See Also Send Feedback

LinkProvider class
LinkProvider
LinkProvider

The LinkProvider..::..LinkParser type exposes the following members.

Constructors

 | Name | Description
Public method | LinkProvider..::..LinkParser | Initializes a new instance of the LinkProvider..::..LinkParser class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExpandDynamicLinks | Expands the dynamic links embedded in the text and returns the result.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LinkProvider..::..LinkParser Class
Sitecore.Links Namespace


LinkProvider.LinkParser Constructor

[image]

Sitecore 6.4.1 API
LinkProvider..::..LinkParser Constructor
LinkProvider..::..LinkParser Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LinkParser()
Visual Basic
Public Sub New
Visual C++
public:
LinkParser()

See Also

LinkProvider..::..LinkParser Class
Sitecore.Links Namespace


LinkProvider.LinkParser Methods

[image] [image]

Sitecore 6.4.1 API
LinkProvider..::..LinkParser Methods
LinkProvider..::..LinkParser Class See Also Send Feedback

The LinkProvider..::..LinkParser type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExpandDynamicLinks | Expands the dynamic links embedded in the text and returns the result.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LinkProvider..::..LinkParser Class
Sitecore.Links Namespace


ExpandDynamicLinks Method

[image]

Sitecore 6.4.1 API
LinkProvider..::..LinkParser..::..ExpandDynamicLinks Method
LinkProvider..::..LinkParser Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ExpandDynamicLinks(
    string text,
    UrlOptions options
)
Visual Basic
Public Function ExpandDynamicLinks ( _
    text As String, _
    options As UrlOptions _
) As String
Visual C++
public:
String^ ExpandDynamicLinks(
    String^ text,
    UrlOptions^ options
)

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Sitecore.Links.LinkProvider.LinkParser.ExpandDynamicLinks(System.String,Sitecore.Links.UrlOptions)"]

options
Type: Sitecore.Links..::..UrlOptions

[Missing <param name="options"/> documentation for "M:Sitecore.Links.LinkProvider.LinkParser.ExpandDynamicLinks(System.String,Sitecore.Links.UrlOptions)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Links.LinkProvider.LinkParser.ExpandDynamicLinks(System.String,Sitecore.Links.UrlOptions)"]

See Also

LinkProvider..::..LinkParser Class
Sitecore.Links Namespace


LinkProviderCollection Class

[image]

Sitecore 6.4.1 API
LinkProviderCollection Class
Members See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class LinkProviderCollection : ProviderCollection
Visual Basic
Public Class LinkProviderCollection _
    Inherits ProviderCollection
Visual C++
public ref class LinkProviderCollection : public ProviderCollection

Inheritance Hierarchy

System..::..Object
System.Configuration.Provider..::..ProviderCollection
Sitecore.Links..::..LinkProviderCollection

See Also

LinkProviderCollection Members
Sitecore.Links Namespace


LinkProviderCollection Members

[image] [image]

Sitecore 6.4.1 API
LinkProviderCollection Members
LinkProviderCollection Class Constructors Methods Properties See Also Send Feedback

The LinkProviderCollection type exposes the following members.

Constructors

 | Name | Description
Public method | LinkProviderCollection | Initializes a new instance of the LinkProviderCollection class

Methods

 | Name | Description
Public method | Add | Adds a provider to the collection. (Inherited from ProviderCollection.)
Public method | Clear | Removes all items from the collection. (Inherited from ProviderCollection.)
Public method | CopyTo | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a provider from the collection. (Inherited from ProviderCollection.)
Public method | SetReadOnly | Sets the collection to be read-only. (Inherited from ProviderCollection.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
Public property | Item | Gets the LinkProvider with the specified name.
Public property | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)

See Also

LinkProviderCollection Class
Sitecore.Links Namespace


LinkProviderCollection Methods

[image] [image]

Sitecore 6.4.1 API
LinkProviderCollection Methods
LinkProviderCollection Class See Also Send Feedback

The LinkProviderCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds a provider to the collection. (Inherited from ProviderCollection.)
Public method | Clear | Removes all items from the collection. (Inherited from ProviderCollection.)
Public method | CopyTo | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a provider from the collection. (Inherited from ProviderCollection.)
Public method | SetReadOnly | Sets the collection to be read-only. (Inherited from ProviderCollection.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LinkProviderCollection Class
Sitecore.Links Namespace


LinkProviderCollection Properties

[image] [image]

Sitecore 6.4.1 API
LinkProviderCollection Properties
LinkProviderCollection Class See Also Send Feedback

The LinkProviderCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
Public property | Item | Gets the LinkProvider with the specified name.
Public property | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)

See Also

LinkProviderCollection Class
Sitecore.Links Namespace


Item Property

[image]

Sitecore 6.4.1 API
LinkProviderCollection..::..Item Property
LinkProviderCollection Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LinkProvider this[
    string name
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    name As String _
) As LinkProvider
    Get
Visual C++
public:
property LinkProvider^ default[String^ name] {
    LinkProvider^ get (String^ name);
}

Parameters

name
Type: System..::..String

Field Value

See Also

LinkProviderCollection Class
Sitecore.Links Namespace


LinksValidationResult Class

[image]

Sitecore 6.4.1 API
LinksValidationResult Class
Members See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class LinksValidationResult
Visual Basic
Public Class LinksValidationResult
Visual C++
public ref class LinksValidationResult

Inheritance Hierarchy

System..::..Object
Sitecore.Links..::..LinksValidationResult

See Also

LinksValidationResult Members
Sitecore.Links Namespace


LinksValidationResult Members

[image] [image]

Sitecore 6.4.1 API
LinksValidationResult Members
LinksValidationResult Class Constructors Methods Properties See Also Send Feedback

The LinksValidationResult type exposes the following members.

Constructors

 | Name | Description
Public method | LinksValidationResult | Initializes a new instance of the LinksValidationResult class.

Methods

 | Name | Description
Public method | AddBrokenLink | Adds the broken link.
Public method | AddValidLink | Adds the valid link.
Public method | AddVersionedBrokenLink | Adds the broken link to the item version.
Public method | AddVersionedValidLink | Adds the valid link to item version.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | Links | Gets the links.

See Also

LinksValidationResult Class
Sitecore.Links Namespace


LinksValidationResult Constructor

[image]

Sitecore 6.4.1 API
LinksValidationResult Constructor
LinksValidationResult Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LinksValidationResult(
    Field field,
    ItemLinkState linkState
)
Visual Basic
Public Sub New ( _
    field As Field, _
    linkState As ItemLinkState _
)
Visual C++
public:
LinksValidationResult(
    Field^ field,
    ItemLinkState linkState
)

Parameters

field
Type: Sitecore.Data.Fields..::..Field
The field to validate.
linkState
Type: Sitecore.Links..::..ItemLinkState
State of the link.

See Also

LinksValidationResult Class
Sitecore.Links Namespace


LinksValidationResult Methods

[image] [image]

Sitecore 6.4.1 API
LinksValidationResult Methods
LinksValidationResult Class See Also Send Feedback

The LinksValidationResult type exposes the following members.

Methods

 | Name | Description
Public method | AddBrokenLink | Adds the broken link.
Public method | AddValidLink | Adds the valid link.
Public method | AddVersionedBrokenLink | Adds the broken link to the item version.
Public method | AddVersionedValidLink | Adds the valid link to item version.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LinksValidationResult Class
Sitecore.Links Namespace


AddBrokenLink Method

[image]

Sitecore 6.4.1 API
LinksValidationResult..::..AddBrokenLink Method
LinksValidationResult Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemLink AddBrokenLink(
    string targetPath
)
Visual Basic
Public Function AddBrokenLink ( _
    targetPath As String _
) As ItemLink
Visual C++
public:
ItemLink^ AddBrokenLink(
    String^ targetPath
)

Parameters

targetPath
Type: System..::..String
The target path.

Return Value

The link object.

See Also

LinksValidationResult Class
Sitecore.Links Namespace


AddValidLink Method

[image]

Sitecore 6.4.1 API
LinksValidationResult..::..AddValidLink Method
LinksValidationResult Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemLink AddValidLink(
    Item targetItem,
    string targetPath
)
Visual Basic
Public Function AddValidLink ( _
    targetItem As Item, _
    targetPath As String _
) As ItemLink
Visual C++
public:
ItemLink^ AddValidLink(
    Item^ targetItem,
    String^ targetPath
)

Parameters

targetItem
Type: Sitecore.Data.Items..::..Item
The target item.
targetPath
Type: System..::..String
The target path.

Return Value

The valid link.

See Also

LinksValidationResult Class
Sitecore.Links Namespace


AddVersionedBrokenLink Method

[image]

Sitecore 6.4.1 API
LinksValidationResult..::..AddVersionedBrokenLink Method
LinksValidationResult Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemLink AddVersionedBrokenLink(
    ItemUri targetItemUri,
    string targetPath
)
Visual Basic
Public Function AddVersionedBrokenLink ( _
    targetItemUri As ItemUri, _
    targetPath As String _
) As ItemLink
Visual C++
public:
ItemLink^ AddVersionedBrokenLink(
    ItemUri^ targetItemUri,
    String^ targetPath
)

Parameters

targetItemUri
Type: Sitecore.Data..::..ItemUri
The target item URI.
targetPath
Type: System..::..String
The target path.

Return Value

The item link.

See Also

LinksValidationResult Class
Sitecore.Links Namespace


AddVersionedValidLink Method

[image]

Sitecore 6.4.1 API
LinksValidationResult..::..AddVersionedValidLink Method
LinksValidationResult Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemLink AddVersionedValidLink(
    Item targetItem,
    string targetPath
)
Visual Basic
Public Function AddVersionedValidLink ( _
    targetItem As Item, _
    targetPath As String _
) As ItemLink
Visual C++
public:
ItemLink^ AddVersionedValidLink(
    Item^ targetItem,
    String^ targetPath
)

Parameters

targetItem
Type: Sitecore.Data.Items..::..Item
The target item.
targetPath
Type: System..::..String
The target path.

Return Value

The valid link.

See Also

LinksValidationResult Class
Sitecore.Links Namespace


LinksValidationResult Properties

[image] [image]

Sitecore 6.4.1 API
LinksValidationResult Properties
LinksValidationResult Class See Also Send Feedback

The LinksValidationResult type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | Links | Gets the links.

See Also

LinksValidationResult Class
Sitecore.Links Namespace


Links Property

[image]

Sitecore 6.4.1 API
LinksValidationResult..::..Links Property
LinksValidationResult Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public List<ItemLink> Links { get; }
Visual Basic
Public ReadOnly Property Links As List(Of ItemLink)
    Get
Visual C++
public:
property List<ItemLink^>^ Links {
    List<ItemLink^>^ get ();
}

Field Value

The links.

See Also

LinksValidationResult Class
Sitecore.Links Namespace


LinkUpdaterJob Class

[image]

Sitecore 6.4.1 API
LinkUpdaterJob Class
Members See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class LinkUpdaterJob
Visual Basic
Public Class LinkUpdaterJob
Visual C++
public ref class LinkUpdaterJob

Inheritance Hierarchy

System..::..Object
Sitecore.Links..::..LinkUpdaterJob

See Also

LinkUpdaterJob Members
Sitecore.Links Namespace


LinkUpdaterJob Members

[image] [image]

Sitecore 6.4.1 API
LinkUpdaterJob Members
LinkUpdaterJob Class Constructors Methods See Also Send Feedback

The LinkUpdaterJob type exposes the following members.

Constructors

 | Name | Description
Public method | LinkUpdaterJob | Initializes a new instance of the LinkUpdaterJob class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | Update | Updates this instance.

See Also

LinkUpdaterJob Class
Sitecore.Links Namespace


LinkUpdaterJob Constructor

[image]

Sitecore 6.4.1 API
LinkUpdaterJob Constructor
LinkUpdaterJob Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LinkUpdaterJob(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
LinkUpdaterJob(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item

[Missing <param name="item"/> documentation for "M:Sitecore.Links.LinkUpdaterJob.#ctor(Sitecore.Data.Items.Item)"]

See Also

LinkUpdaterJob Class
Sitecore.Links Namespace


LinkUpdaterJob Methods

[image] [image]

Sitecore 6.4.1 API
LinkUpdaterJob Methods
LinkUpdaterJob Class See Also Send Feedback

The LinkUpdaterJob type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | Update | Updates this instance.

See Also

LinkUpdaterJob Class
Sitecore.Links Namespace


Update Method

[image]

Sitecore 6.4.1 API
LinkUpdaterJob..::..Update Method
LinkUpdaterJob Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void Update()
Visual Basic
Protected Sub Update
Visual C++
protected:
void Update()

See Also

LinkUpdaterJob Class
Sitecore.Links Namespace


LinkUrlOptions Class

[image]

Sitecore 6.4.1 API
LinkUrlOptions Class
Members See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class LinkUrlOptions
Visual Basic
Public Class LinkUrlOptions
Visual C++
public ref class LinkUrlOptions

Inheritance Hierarchy

System..::..Object
Sitecore.Links..::..LinkUrlOptions

See Also

LinkUrlOptions Members
Sitecore.Links Namespace


LinkUrlOptions Members

[image] [image]

Sitecore 6.4.1 API
LinkUrlOptions Members
LinkUrlOptions Class Constructors Methods Properties See Also Send Feedback

The LinkUrlOptions type exposes the following members.

Constructors

 | Name | Description
Public method | LinkUrlOptions | Initializes a new instance of the LinkUrlOptions class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
 | Empty | Gets the empty.
Public property | Language | Gets or sets the language.
Public property | Site | Gets or sets the site.

See Also

LinkUrlOptions Class
Sitecore.Links Namespace


LinkUrlOptions Constructor

[image]

Sitecore 6.4.1 API
LinkUrlOptions Constructor
LinkUrlOptions Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LinkUrlOptions()
Visual Basic
Public Sub New
Visual C++
public:
LinkUrlOptions()

See Also

LinkUrlOptions Class
Sitecore.Links Namespace


LinkUrlOptions Methods

[image] [image]

Sitecore 6.4.1 API
LinkUrlOptions Methods
LinkUrlOptions Class See Also Send Feedback

The LinkUrlOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LinkUrlOptions Class
Sitecore.Links Namespace


LinkUrlOptions Properties

[image] [image]

Sitecore 6.4.1 API
LinkUrlOptions Properties
LinkUrlOptions Class See Also Send Feedback

The LinkUrlOptions type exposes the following members.

Properties

 | Name | Description
 | Empty | Gets the empty.
Public property | Language | Gets or sets the language.
Public property | Site | Gets or sets the site.

See Also

LinkUrlOptions Class
Sitecore.Links Namespace


Empty Property

[image]

Sitecore 6.4.1 API
LinkUrlOptions..::..Empty Property
LinkUrlOptions Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static LinkUrlOptions Empty { get; }
Visual Basic
Public Shared ReadOnly Property Empty As LinkUrlOptions
    Get
Visual C++
public:
static property LinkUrlOptions^ Empty {
    LinkUrlOptions^ get ();
}

Field Value

The empty.

See Also

LinkUrlOptions Class
Sitecore.Links Namespace


Language Property

[image]

Sitecore 6.4.1 API
LinkUrlOptions..::..Language Property
LinkUrlOptions Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Language Language { get; set; }
Visual Basic
Public Property Language As Language
    Get
    Set
Visual C++
public:
property Language^ Language {
    Language^ get ();
    void set (Language^ value);
}

Field Value

The language.

See Also

LinkUrlOptions Class
Sitecore.Links Namespace


SqlLinkDatabase Class

[image]

Sitecore 6.4.1 API
SqlLinkDatabase Class
Members See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SqlLinkDatabase : LinkDatabase
Visual Basic
Public Class SqlLinkDatabase _
    Inherits LinkDatabase
Visual C++
public ref class SqlLinkDatabase : public LinkDatabase

Inheritance Hierarchy

System..::..Object
Sitecore.Links..::..LinkDatabase
Sitecore.Links..::..SqlLinkDatabase
Sitecore.Data.SqlServer..::..SqlServerLinkDatabase

See Also

SqlLinkDatabase Members
Sitecore.Links Namespace


SqlLinkDatabase Members

[image] [image]

Sitecore 6.4.1 API
SqlLinkDatabase Members
SqlLinkDatabase Class Constructors Methods Fields Properties See Also Send Feedback

The SqlLinkDatabase type exposes the following members.

Constructors

 | Name | Description
Public method | SqlLinkDatabase | Initializes a new instance of the SqlLinkDatabase class.

Methods

 | Name | Description
Protected method | AddLink | Adds the link.
Public method | Compact | Compacts the specified database. (Overrides LinkDatabase..::..Compact(Database).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBrokenLinks | Gets the broken links. (Overrides LinkDatabase..::..GetBrokenLinks(Database).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemVersionReferrers | Gets the item version referrers. (Overrides LinkDatabase..::..GetItemVersionReferrers(Item).)
Public method | GetReferenceCount | Gets the reference count. (Overrides LinkDatabase..::..GetReferenceCount(Item).)
Public method | GetReferences | Gets the references. (Overrides LinkDatabase..::..GetReferences(Item).)
Public method | GetRefererCount | Obsolete. Gets the referrer count. (Inherited from LinkDatabase.)
Public method | GetReferers | Obsolete. Gets the referrers. (Inherited from LinkDatabase.)
Public method | GetReferrerCount | Gets the referrer count. (Overrides LinkDatabase..::..GetReferrerCount(Item).)
Public method | GetReferrers(Item) | Gets the referrers. (Overrides LinkDatabase..::..GetReferrers(Item).)
Public method | GetReferrers(Item, Boolean) | Obsolete. Gets the referrers. (Overrides LinkDatabase..::..GetReferrers(Item, Boolean).)
Protected method | GetString | Gets a string.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasExternalReferers | Obsolete. Determines whether the specified item has external referrers. (Inherited from LinkDatabase.)
Public method | HasExternalReferrers | Determines whether the specified item has external referrers. (Inherited from LinkDatabase.)
Protected method | ItemExists | Targets the exists. (Inherited from LinkDatabase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rebuild | Rebuilds the specified database. (Inherited from LinkDatabase.)
Protected method | RemoveItemVersionLinks | Removes the links.
Protected method | RemoveLinks | Removes the links.
Public method | RemoveReferences | Removes the references. (Overrides LinkDatabase..::..RemoveReferences(Item).)
Protected method | TargetExists | Determines if the target exists. (Inherited from LinkDatabase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | UpdateItemVersionLinks | Updates the links. (Overrides LinkDatabase..::..UpdateItemVersionLinks(Item, array<ItemLink>[]()[][]).)
Public method | UpdateItemVersionReferences | The update item version references. (Inherited from LinkDatabase.)
Protected method | UpdateLinks | Updates the links. (Overrides LinkDatabase..::..UpdateLinks(Item, array<ItemLink>[]()[][]).)
Public method | UpdateReferences | Updates the references. (Inherited from LinkDatabase.)

Fields

 | Name | Description
Protected field | _dataApi | Obsolete. data API

Properties

 | Name | Description
Protected property | DataApi | Gets the data API.

See Also

SqlLinkDatabase Class
Sitecore.Links Namespace


SqlLinkDatabase Constructor

[image]

Sitecore 6.4.1 API
SqlLinkDatabase Constructor
SqlLinkDatabase Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SqlLinkDatabase(
    SqlDataApi dataApi
)
Visual Basic
Public Sub New ( _
    dataApi As SqlDataApi _
)
Visual C++
public:
SqlLinkDatabase(
    SqlDataApi^ dataApi
)

Parameters

dataApi
Type: Sitecore.Data.DataProviders.Sql..::..SqlDataApi
The data API.

See Also

SqlLinkDatabase Class
Sitecore.Links Namespace


SqlLinkDatabase Fields

[image] [image]

Sitecore 6.4.1 API
SqlLinkDatabase Fields
SqlLinkDatabase Class See Also Send Feedback

The SqlLinkDatabase type exposes the following members.

Fields

 | Name | Description
Protected field | _dataApi | Obsolete. data API

See Also

SqlLinkDatabase Class
Sitecore.Links Namespace


_dataApi Field

[image]

Sitecore 6.4.1 API
SqlLinkDatabase..::.._dataApi Field
SqlLinkDatabase Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use protected DataApi property instead. Field is going to be made private.")]
protected readonly SqlDataApi _dataApi
Visual Basic
<ObsoleteAttribute("Deprecated - Use protected DataApi property instead. Field is going to be made private.")> _
Protected ReadOnly _dataApi As SqlDataApi
Visual C++
[ObsoleteAttribute(L"Deprecated - Use protected DataApi property instead. Field is going to be made private.")]
protected:
initonly SqlDataApi^ _dataApi

See Also

SqlLinkDatabase Class
Sitecore.Links Namespace


SqlLinkDatabase Methods

[image] [image]

Sitecore 6.4.1 API
SqlLinkDatabase Methods
SqlLinkDatabase Class See Also Send Feedback

The SqlLinkDatabase type exposes the following members.

Methods

 | Name | Description
Protected method | AddLink | Adds the link.
Public method | Compact | Compacts the specified database. (Overrides LinkDatabase..::..Compact(Database).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBrokenLinks | Gets the broken links. (Overrides LinkDatabase..::..GetBrokenLinks(Database).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemVersionReferrers | Gets the item version referrers. (Overrides LinkDatabase..::..GetItemVersionReferrers(Item).)
Public method | GetReferenceCount | Gets the reference count. (Overrides LinkDatabase..::..GetReferenceCount(Item).)
Public method | GetReferences | Gets the references. (Overrides LinkDatabase..::..GetReferences(Item).)
Public method | GetRefererCount | Obsolete. Gets the referrer count. (Inherited from LinkDatabase.)
Public method | GetReferers | Obsolete. Gets the referrers. (Inherited from LinkDatabase.)
Public method | GetReferrerCount | Gets the referrer count. (Overrides LinkDatabase..::..GetReferrerCount(Item).)
Public method | GetReferrers(Item) | Gets the referrers. (Overrides LinkDatabase..::..GetReferrers(Item).)
Public method | GetReferrers(Item, Boolean) | Obsolete. Gets the referrers. (Overrides LinkDatabase..::..GetReferrers(Item, Boolean).)
Protected method | GetString | Gets a string.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasExternalReferers | Obsolete. Determines whether the specified item has external referrers. (Inherited from LinkDatabase.)
Public method | HasExternalReferrers | Determines whether the specified item has external referrers. (Inherited from LinkDatabase.)
Protected method | ItemExists | Targets the exists. (Inherited from LinkDatabase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rebuild | Rebuilds the specified database. (Inherited from LinkDatabase.)
Protected method | RemoveItemVersionLinks | Removes the links.
Protected method | RemoveLinks | Removes the links.
Public method | RemoveReferences | Removes the references. (Overrides LinkDatabase..::..RemoveReferences(Item).)
Protected method | TargetExists | Determines if the target exists. (Inherited from LinkDatabase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | UpdateItemVersionLinks | Updates the links. (Overrides LinkDatabase..::..UpdateItemVersionLinks(Item, array<ItemLink>[]()[][]).)
Public method | UpdateItemVersionReferences | The update item version references. (Inherited from LinkDatabase.)
Protected method | UpdateLinks | Updates the links. (Overrides LinkDatabase..::..UpdateLinks(Item, array<ItemLink>[]()[][]).)
Public method | UpdateReferences | Updates the references. (Inherited from LinkDatabase.)

See Also

SqlLinkDatabase Class
Sitecore.Links Namespace


Compact Method

[image]

Sitecore 6.4.1 API
SqlLinkDatabase..::..Compact Method
SqlLinkDatabase Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Compact(
    Database database
)
Visual Basic
Public Overrides Sub Compact ( _
    database As Database _
)
Visual C++
public:
virtual void Compact(
    Database^ database
) override

Parameters

database
Type: Sitecore.Data..::..Database
The database.

See Also

SqlLinkDatabase Class
Sitecore.Links Namespace


GetBrokenLinks Method

[image]

Sitecore 6.4.1 API
SqlLinkDatabase..::..GetBrokenLinks Method
SqlLinkDatabase Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override ItemLink[] GetBrokenLinks(
    Database database
)
Visual Basic
Public Overrides Function GetBrokenLinks ( _
    database As Database _
) As ItemLink()
Visual C++
public:
virtual array<ItemLink^>^ GetBrokenLinks(
    Database^ database
) override

Parameters

database
Type: Sitecore.Data..::..Database
The database.

Return Value

The broken links.

See Also

SqlLinkDatabase Class
Sitecore.Links Namespace


GetItemVersionReferrers Method

[image]

Sitecore 6.4.1 API
SqlLinkDatabase..::..GetItemVersionReferrers Method
SqlLinkDatabase Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override ItemLink[] GetItemVersionReferrers(
    Item version
)
Visual Basic
Public Overrides Function GetItemVersionReferrers ( _
    version As Item _
) As ItemLink()
Visual C++
public:
virtual array<ItemLink^>^ GetItemVersionReferrers(
    Item^ version
) override

Parameters

version
Type: Sitecore.Data.Items..::..Item
The item version.

Return Value

The list of referrers to the item version.

See Also

SqlLinkDatabase Class
Sitecore.Links Namespace


GetReferenceCount Method

[image]

Sitecore 6.4.1 API
SqlLinkDatabase..::..GetReferenceCount Method
SqlLinkDatabase Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override int GetReferenceCount(
    Item item
)
Visual Basic
Public Overrides Function GetReferenceCount ( _
    item As Item _
) As Integer
Visual C++
public:
virtual int GetReferenceCount(
    Item^ item
) override

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item.

Return Value

The count.

See Also

SqlLinkDatabase Class
Sitecore.Links Namespace


GetReferences Method

[image]

Sitecore 6.4.1 API
SqlLinkDatabase..::..GetReferences Method
SqlLinkDatabase Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override ItemLink[] GetReferences(
    Item item
)
Visual Basic
Public Overrides Function GetReferences ( _
    item As Item _
) As ItemLink()
Visual C++
public:
virtual array<ItemLink^>^ GetReferences(
    Item^ item
) override

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item.

Return Value

The references.

See Also

SqlLinkDatabase Class
Sitecore.Links Namespace


GetReferrerCount Method

[image]

Sitecore 6.4.1 API
SqlLinkDatabase..::..GetReferrerCount Method
SqlLinkDatabase Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override int GetReferrerCount(
    Item item
)
Visual Basic
Public Overrides Function GetReferrerCount ( _
    item As Item _
) As Integer
Visual C++
public:
virtual int GetReferrerCount(
    Item^ item
) override

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item.

Return Value

The referrer count.

See Also

SqlLinkDatabase Class
Sitecore.Links Namespace


GetReferrers Method

[image] [image]

Sitecore 6.4.1 API
SqlLinkDatabase..::..GetReferrers Method
SqlLinkDatabase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetReferrers(Item) | Gets the referrers. (Overrides LinkDatabase..::..GetReferrers(Item).)
Public method | GetReferrers(Item, Boolean) | Obsolete. Gets the referrers. (Overrides LinkDatabase..::..GetReferrers(Item, Boolean).)

See Also

SqlLinkDatabase Class
SqlLinkDatabase Members
Sitecore.Links Namespace


GetReferrers Method (Item)

[image]

Sitecore 6.4.1 API
SqlLinkDatabase..::..GetReferrers Method (Item)
SqlLinkDatabase Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override ItemLink[] GetReferrers(
    Item item
)
Visual Basic
Public Overrides Function GetReferrers ( _
    item As Item _
) As ItemLink()
Visual C++
public:
virtual array<ItemLink^>^ GetReferrers(
    Item^ item
) override

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item.

Return Value

The referrers.

See Also

SqlLinkDatabase Class
GetReferrers Overload
Sitecore.Links Namespace


GetReferrers Method (Item, Boolean)

[image]

Sitecore 6.4.1 API
SqlLinkDatabase..::..GetReferrers Method (Item, Boolean)
SqlLinkDatabase Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use GetReferers(Item) instead.")]
public override ItemLink[] GetReferrers(
    Item item,
    bool deep
)
Visual Basic
<ObsoleteAttribute("Deprecated - Use GetReferers(Item) instead.")> _
Public Overrides Function GetReferrers ( _
    item As Item, _
    deep As Boolean _
) As ItemLink()
Visual C++
[ObsoleteAttribute(L"Deprecated - Use GetReferers(Item) instead.")]
public:
virtual array<ItemLink^>^ GetReferrers(
    Item^ item,
    bool deep
) override

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item.
deep
Type: System..::..Boolean
if set to true this instance is deep.

Return Value

The referrers.

See Also

SqlLinkDatabase Class
GetReferrers Overload
Sitecore.Links Namespace


GetString Method

[image]

Sitecore 6.4.1 API
SqlLinkDatabase..::..GetString Method
SqlLinkDatabase Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string GetString(
    string value,
    int maxLength
)
Visual Basic
Protected Overridable Function GetString ( _
    value As String, _
    maxLength As Integer _
) As String
Visual C++
protected:
virtual String^ GetString(
    String^ value,
    int maxLength
)

Parameters

value
Type: System..::..String
The value.
maxLength
Type: System..::..Int32
The maximum allowed length.

Return Value

The get string.

See Also

SqlLinkDatabase Class
Sitecore.Links Namespace


RemoveItemVersionLinks Method

[image]

Sitecore 6.4.1 API
SqlLinkDatabase..::..RemoveItemVersionLinks Method
SqlLinkDatabase Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void RemoveItemVersionLinks(
    Item item
)
Visual Basic
Protected Overridable Sub RemoveItemVersionLinks ( _
    item As Item _
)
Visual C++
protected:
virtual void RemoveItemVersionLinks(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item.

See Also

SqlLinkDatabase Class
Sitecore.Links Namespace


RemoveReferences Method

[image]

Sitecore 6.4.1 API
SqlLinkDatabase..::..RemoveReferences Method
SqlLinkDatabase Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void RemoveReferences(
    Item item
)
Visual Basic
Public Overrides Sub RemoveReferences ( _
    item As Item _
)
Visual C++
public:
virtual void RemoveReferences(
    Item^ item
) override

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item.

See Also

SqlLinkDatabase Class
Sitecore.Links Namespace


UpdateItemVersionLinks Method

[image]

Sitecore 6.4.1 API
SqlLinkDatabase..::..UpdateItemVersionLinks Method
SqlLinkDatabase Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void UpdateItemVersionLinks(
    Item item,
    ItemLink[] links
)
Visual Basic
Protected Overrides Sub UpdateItemVersionLinks ( _
    item As Item, _
    links As ItemLink() _
)
Visual C++
protected:
virtual void UpdateItemVersionLinks(
    Item^ item,
    array<ItemLink^>^ links
) override

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item.
links
Type: array< Sitecore.Links..::..ItemLink >[]()[][]
The links.

See Also

SqlLinkDatabase Class
Sitecore.Links Namespace


UpdateLinks Method

[image]

Sitecore 6.4.1 API
SqlLinkDatabase..::..UpdateLinks Method
SqlLinkDatabase Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void UpdateLinks(
    Item item,
    ItemLink[] links
)
Visual Basic
Protected Overrides Sub UpdateLinks ( _
    item As Item, _
    links As ItemLink() _
)
Visual C++
protected:
virtual void UpdateLinks(
    Item^ item,
    array<ItemLink^>^ links
) override

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item.
links
Type: array< Sitecore.Links..::..ItemLink >[]()[][]
The links.

See Also

SqlLinkDatabase Class
Sitecore.Links Namespace


SqlLinkDatabase Properties

[image] [image]

Sitecore 6.4.1 API
SqlLinkDatabase Properties
SqlLinkDatabase Class See Also Send Feedback

The SqlLinkDatabase type exposes the following members.

Properties

 | Name | Description
Protected property | DataApi | Gets the data API.

See Also

SqlLinkDatabase Class
Sitecore.Links Namespace


DataApi Property

[image]

Sitecore 6.4.1 API
SqlLinkDatabase..::..DataApi Property
SqlLinkDatabase Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected SqlDataApi DataApi { get; }
Visual Basic
Protected ReadOnly Property DataApi As SqlDataApi
    Get
Visual C++
protected:
property SqlDataApi^ DataApi {
    SqlDataApi^ get ();
}

Field Value

The data API.

See Also

SqlLinkDatabase Class
Sitecore.Links Namespace


UrlOptions Class

[image]

Sitecore 6.4.1 API
UrlOptions Class
Members See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class UrlOptions : ICloneable
Visual Basic
Public Class UrlOptions _
    Implements ICloneable
Visual C++
public ref class UrlOptions : ICloneable

Inheritance Hierarchy

System..::..Object
Sitecore.Links..::..UrlOptions

See Also

UrlOptions Members
Sitecore.Links Namespace


UrlOptions Members

[image] [image]

Sitecore 6.4.1 API
UrlOptions Members
UrlOptions Class Constructors Methods Properties See Also Send Feedback

The UrlOptions type exposes the following members.

Constructors

 | Name | Description
Public method | UrlOptions | Initializes a new instance of the UrlOptions class

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | EmbedLanguage | Returns a value indicating whether to embed the specified language.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AddAspxExtension | Gets a value indicating whether [add aspx extension].
Public property | AlwaysIncludeServerUrl | Gets or sets a value indicating whether to always include the server URL.
 | DefaultOptions | Gets (a clone of) the default options.
Public property | EncodeNames | Gets or sets a value indicating whether to encode the names making up the URL of the link.
Public property | Language | Gets or sets the language.
Public property | LanguageEmbedding | Gets or sets a value controlling if and how to embed language in the URL.
Public property | LanguageLocation | Gets or sets the language location.
Public property | ShortenUrls | Gets or sets a value indicating whether to shorten URLs according to the site.
Public property | Site | Gets or sets the site.
Public property | SiteResolving | Gets or sets a value indicating whether site resolving is enabled.
Public property | UseDisplayName | Gets or sets a value indicating whether to use the display name for urls.

See Also

UrlOptions Class
Sitecore.Links Namespace


UrlOptions Methods

[image] [image]

Sitecore 6.4.1 API
UrlOptions Methods
UrlOptions Class See Also Send Feedback

The UrlOptions type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | EmbedLanguage | Returns a value indicating whether to embed the specified language.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UrlOptions Class
Sitecore.Links Namespace


Clone Method

[image]

Sitecore 6.4.1 API
UrlOptions..::..Clone Method
UrlOptions Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Object Clone()
Visual Basic
Public Overridable Function Clone As Object
Visual C++
public:
virtual Object^ Clone()

Return Value

A new object that is a copy of this instance.

Implements

ICloneable..::..Clone()()()()

See Also

UrlOptions Class
Sitecore.Links Namespace


EmbedLanguage Method

[image]

Sitecore 6.4.1 API
UrlOptions..::..EmbedLanguage Method
UrlOptions Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool EmbedLanguage(
    Language language
)
Visual Basic
Public Overridable Function EmbedLanguage ( _
    language As Language _
) As Boolean
Visual C++
public:
virtual bool EmbedLanguage(
    Language^ language
)

Parameters

language
Type: Sitecore.Globalization..::..Language
The language.

Return Value

[Missing <returns> documentation for "M:Sitecore.Links.UrlOptions.EmbedLanguage(Sitecore.Globalization.Language)"]

See Also

UrlOptions Class
Sitecore.Links Namespace


AlwaysIncludeServerUrl Property

[image]

Sitecore 6.4.1 API
UrlOptions..::..AlwaysIncludeServerUrl Property
UrlOptions Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool AlwaysIncludeServerUrl { get; set; }
Visual Basic
Public Overridable Property AlwaysIncludeServerUrl As Boolean
    Get
    Set
Visual C++
public:
virtual property bool AlwaysIncludeServerUrl {
    bool get ();
    void set (bool value);
}

Field Value

true if [always include server URL]; otherwise, false.

See Also

UrlOptions Class
Sitecore.Links Namespace


DefaultOptions Property

[image]

Sitecore 6.4.1 API
UrlOptions..::..DefaultOptions Property
UrlOptions Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static UrlOptions DefaultOptions { get; }
Visual Basic
Public Shared ReadOnly Property DefaultOptions As UrlOptions
    Get
Visual C++
public:
static property UrlOptions^ DefaultOptions {
    UrlOptions^ get ();
}

Field Value

The default options.

See Also

UrlOptions Class
Sitecore.Links Namespace


Language Property

[image]

Sitecore 6.4.1 API
UrlOptions..::..Language Property
UrlOptions Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Language Language { get; set; }
Visual Basic
Public Overridable Property Language As Language
    Get
    Set
Visual C++
public:
virtual property Language^ Language {
    Language^ get ();
    void set (Language^ value);
}

Field Value

The language.

See Also

UrlOptions Class
Sitecore.Links Namespace


LanguageEmbedding Property

[image]

Sitecore 6.4.1 API
UrlOptions..::..LanguageEmbedding Property
UrlOptions Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual LanguageEmbedding LanguageEmbedding { get; set; }
Visual Basic
Public Overridable Property LanguageEmbedding As LanguageEmbedding
    Get
    Set
Visual C++
public:
virtual property LanguageEmbedding LanguageEmbedding {
    LanguageEmbedding get ();
    void set (LanguageEmbedding value);
}

Field Value

The embed language option.

See Also

UrlOptions Class
Sitecore.Links Namespace


ShortenUrls Property

[image]

Sitecore 6.4.1 API
UrlOptions..::..ShortenUrls Property
UrlOptions Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool ShortenUrls { get; set; }
Visual Basic
Public Overridable Property ShortenUrls As Boolean
    Get
    Set
Visual C++
public:
virtual property bool ShortenUrls {
    bool get ();
    void set (bool value);
}

Field Value

true if shorten; otherwise, false.

See Also

UrlOptions Class
Sitecore.Links Namespace


Site Property

[image]

Sitecore 6.4.1 API
UrlOptions..::..Site Property
UrlOptions Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual SiteContext Site { get; set; }
Visual Basic
Public Overridable Property Site As SiteContext
    Get
    Set
Visual C++
public:
virtual property SiteContext^ Site {
    SiteContext^ get ();
    void set (SiteContext^ value);
}

Field Value

The site.

See Also

UrlOptions Class
Sitecore.Links Namespace


SiteResolving Property

[image]

Sitecore 6.4.1 API
UrlOptions..::..SiteResolving Property
UrlOptions Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool SiteResolving { get; set; }
Visual Basic
Public Property SiteResolving As Boolean
    Get
    Set
Visual C++
public:
property bool SiteResolving {
    bool get ();
    void set (bool value);
}

Field Value

true if site resolving is enabled; otherwise, false.

See Also

UrlOptions Class
Sitecore.Links Namespace


UseDisplayName Property

[image]

Sitecore 6.4.1 API
UrlOptions..::..UseDisplayName Property
UrlOptions Class See Also Send Feedback

Namespace: Sitecore.Links
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool UseDisplayName { get; set; }
Visual Basic
Public Overridable Property UseDisplayName As Boolean
    Get
    Set
Visual C++
public:
virtual property bool UseDisplayName {
    bool get ();
    void set (bool value);
}

Field Value

true if use display name; otherwise, false.

See Also

UrlOptions Class
Sitecore.Links Namespace


Sitecore.Login Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Login Namespace
Send Feedback

Classes

 | Class | Description
Public class | ChangePasswordPage | Defines the change password page class.
Public class | PasswordRecoveryPage | Defines the password recovery page class.


ChangePasswordPage Class

[image]

Sitecore 6.4.1 API
ChangePasswordPage Class
Members See Also Send Feedback

Namespace: Sitecore.Login
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ChangePasswordPage : Page
Visual Basic
Public Class ChangePasswordPage _
    Inherits Page
Visual C++
public ref class ChangePasswordPage : public Page

Inheritance Hierarchy

System..::..Object
System.Web.UI..::..Control
System.Web.UI..::..TemplateControl
System.Web.UI..::..Page
Sitecore.Web.UI.HtmlControls..::..Page
Sitecore.Login..::..ChangePasswordPage

See Also

ChangePasswordPage Members
Sitecore.Login Namespace


ChangePasswordPage Members

[image] [image]

Sitecore 6.4.1 API
ChangePasswordPage Members
ChangePasswordPage Class Constructors Methods Fields Properties Events See Also Send Feedback

The ChangePasswordPage type exposes the following members.

Constructors

 | Name | Description
Public method | ChangePasswordPage | Initializes a new instance of the ChangePasswordPage class

Methods

 | Name | Description
Protected method | AddContentTemplate | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Public method | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
Public method | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Protected method | AddWrappedFileDependencies | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | AspCompatBeginProcessRequest | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
Protected method | AspCompatEndProcessRequest | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
Protected method | AsyncPageBeginProcessRequest | Begins processing an asynchronous page request. (Inherited from Page.)
Protected method | AsyncPageEndProcessRequest | Ends processing an asynchronous page request. (Inherited from Page.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Protected method | Construct | Performs design-time logic. (Inherited from TemplateControl.)
Protected method | CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Protected method | CreateHtmlTextWriter | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
Protected method | CreateResourceBasedLiteralControl | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Public method | DesignerInitialize | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
Protected method | DeterminePostBackMode | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
Protected method | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
Public method | ExecuteRegisteredAsyncTasks | Starts the execution of an asynchronous task. (Inherited from Page.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | FrameworkInitialize | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
Public method | GetDataItem | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Protected method | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
Protected method | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
Protected method | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
Public method | GetPostBackClientEvent | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
Public method | GetPostBackClientHyperlink | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
Public method | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
Public method | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeHashCode | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
Public method | GetValidators | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
Protected method | GetWrappedFileDependencies | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Protected method | InitializeCulture | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
Protected method | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
Protected method | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
Protected method | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
Public method | IsClientScriptBlockRegistered | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Public method | IsStartupScriptRegistered | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
Public method | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
Public method | LoadControl(Type, array<Object>[]()[][]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
Protected method | LoadPageStateFromPersistenceMedium | Loads any saved view-state information to the Page object. (Inherited from Page.)
Public method | LoadTemplate | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
Protected method | LoadViewState | Restores view-state information from a previous page request that was saved by the SaveViewState()()()() method. (Inherited from Control.)
Public method | MapPath | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAbortTransaction | Raises the AbortTransaction event. (Inherited from TemplateControl.)
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnCommitTransaction | Raises the CommitTransaction event. (Inherited from TemplateControl.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnError | Raises the Error event. (Inherited from TemplateControl.)
Protected method | OnInit | Raises the Init event to initialize the page. (Inherited from Page.)
Protected method | OnInitComplete | Raises the InitComplete event after page initialization. (Inherited from Page.)
Protected method | OnLoad | Raises the Load event. (Overrides Control..::..OnLoad(EventArgs).)
Protected method | OnLoadComplete | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
Protected method | OnPreInit | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
Protected method | OnPreLoad | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
Protected method | OnPreRender | Raises the PreRender event. (Inherited from Page.)
Protected method | OnPreRenderComplete | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
Protected method | OnSaveStateComplete | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Public method | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
Public method | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
Public method | ProcessRequest | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Protected method | RaisePostBackEvent | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
Public method | ReadStringResource | Reads a string resource. The ReadStringResource()()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | RegisterArrayDeclaration | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
Public method | RegisterAsyncTask | Registers a new asynchronous task with the page. (Inherited from Page.)
Public method | RegisterClientScriptBlock | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
Public method | RegisterHiddenField | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
Public method | RegisterOnSubmitStatement | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
Public method | RegisterRequiresControlState | Registers a control as one whose control state must be persisted. (Inherited from Page.)
Public method | RegisterRequiresPostBack | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
Public method | RegisterRequiresRaiseEvent | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
Public method | RegisterRequiresViewStateEncryption | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
Public method | RegisterStartupScript | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
Public method | RegisterViewStateHandler | Causes page view state to be persisted, if called. (Inherited from Page.)
Protected method | RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Protected method | Render | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Public method | RequiresControlState | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SavePageStateToPersistenceMedium | Saves any view-state and control-state information for the page. (Inherited from Page.)
Protected method | SaveViewState | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
Public method | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Protected method | SetStringResourcePointer | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | TestDeviceFilter | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TrackViewState | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
Public method | UnregisterRequiresControlState | Stops persistence of control state for the specified control. (Inherited from Page.)
Public method | Validate()()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
Public method | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
Public method | VerifyRenderingInServerForm | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
Protected method | WriteUTF8ResourceString | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
Protected method | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
Protected method | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
Protected method | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
Protected method | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
Protected method | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Protected method | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)

Fields

 | Name | Description
Protected field | ChangePassword | ChangePassword control.
Protected field | ChangePasswordDisabledLabel | ChangePasswordDisabledLabel control.
Protected field | LoginForm | LoginForm control.
Protected field | PartnerLogo | PartnerLogo control.

Properties

 | Name | Description
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
Protected property | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
Protected property | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
Public property | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
Protected property | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
Public property | AutoPostBackControl | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
Public property | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Public property | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
Public property | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
Public property | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
Public property | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
Public property | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
Protected property | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
Public property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
Public property | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Public property | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
Public property | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
Public property | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
Public property | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
Public property | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Protected property | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
Public property | Form | Gets the HTML form for the page. (Inherited from Page.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Public property | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
Public property | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
Public property | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
Public property | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
Public property | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Public property | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
Public property | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
Public property | IsPostBackEventControlRegistered | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
Public property | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Public property | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Public property | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
Public property | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Public property | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
Public property | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
Public property | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
Public property | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
Public property | PageScriptManager | Gets the page script manager. (Inherited from Page.)
Protected property | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
Public property | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
Public property | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
Public property | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
Public property | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
Public property | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
Public property | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
Public property | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
Public property | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
Protected property | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
Public property | Title | Gets or sets the title for the page. (Inherited from Page.)
Public property | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
Public property | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
Public property | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
Protected property | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
Public property | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
Protected property | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
Public property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
Public property | User | Gets information about the user making the page request. (Inherited from Page.)
Public property | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Public property | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
Public property | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)

Events

 | Name | Description
Public event | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
Public event | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
Public event | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
Public event | PreLoad | Occurs before the page Load event. (Inherited from Page.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
Public event | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

See Also

ChangePasswordPage Class
Sitecore.Login Namespace


ChangePasswordPage Constructor

[image]

Sitecore 6.4.1 API
ChangePasswordPage Constructor
ChangePasswordPage Class See Also Send Feedback

Namespace: Sitecore.Login
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ChangePasswordPage()
Visual Basic
Public Sub New
Visual C++
public:
ChangePasswordPage()

See Also

ChangePasswordPage Class
Sitecore.Login Namespace


ChangePasswordPage Fields

[image] [image]

Sitecore 6.4.1 API
ChangePasswordPage Fields
ChangePasswordPage Class See Also Send Feedback

The ChangePasswordPage type exposes the following members.

Fields

 | Name | Description
Protected field | ChangePassword | ChangePassword control.
Protected field | ChangePasswordDisabledLabel | ChangePasswordDisabledLabel control.
Protected field | LoginForm | LoginForm control.
Protected field | PartnerLogo | PartnerLogo control.

See Also

ChangePasswordPage Class
Sitecore.Login Namespace


ChangePassword Field

[image]

Sitecore 6.4.1 API
ChangePasswordPage..::..ChangePassword Field
ChangePasswordPage Class See Also Send Feedback

Namespace: Sitecore.Login
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected ChangePassword ChangePassword
Visual Basic
Protected ChangePassword As ChangePassword
Visual C++
protected:
ChangePassword^ ChangePassword

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

ChangePasswordPage Class
Sitecore.Login Namespace


ChangePasswordDisabledLabel Field

[image]

Sitecore 6.4.1 API
ChangePasswordPage..::..ChangePasswordDisabledLabel Field
ChangePasswordPage Class See Also Send Feedback

Namespace: Sitecore.Login
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Literal ChangePasswordDisabledLabel
Visual Basic
Protected ChangePasswordDisabledLabel As Literal
Visual C++
protected:
Literal^ ChangePasswordDisabledLabel

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

ChangePasswordPage Class
Sitecore.Login Namespace


LoginForm Field

[image]

Sitecore 6.4.1 API
ChangePasswordPage..::..LoginForm Field
ChangePasswordPage Class See Also Send Feedback

Namespace: Sitecore.Login
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected HtmlForm LoginForm
Visual Basic
Protected LoginForm As HtmlForm
Visual C++
protected:
HtmlForm^ LoginForm

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

ChangePasswordPage Class
Sitecore.Login Namespace


PartnerLogo Field

[image]

Sitecore 6.4.1 API
ChangePasswordPage..::..PartnerLogo Field
ChangePasswordPage Class See Also Send Feedback

Namespace: Sitecore.Login
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected PlaceHolder PartnerLogo
Visual Basic
Protected PartnerLogo As PlaceHolder
Visual C++
protected:
PlaceHolder^ PartnerLogo

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

ChangePasswordPage Class
Sitecore.Login Namespace


ChangePasswordPage Methods

[image] [image]

Sitecore 6.4.1 API
ChangePasswordPage Methods
ChangePasswordPage Class See Also Send Feedback

The ChangePasswordPage type exposes the following members.

Methods

 | Name | Description
Protected method | AddContentTemplate | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Public method | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
Public method | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Protected method | AddWrappedFileDependencies | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | AspCompatBeginProcessRequest | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
Protected method | AspCompatEndProcessRequest | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
Protected method | AsyncPageBeginProcessRequest | Begins processing an asynchronous page request. (Inherited from Page.)
Protected method | AsyncPageEndProcessRequest | Ends processing an asynchronous page request. (Inherited from Page.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Protected method | Construct | Performs design-time logic. (Inherited from TemplateControl.)
Protected method | CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Protected method | CreateHtmlTextWriter | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
Protected method | CreateResourceBasedLiteralControl | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Public method | DesignerInitialize | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
Protected method | DeterminePostBackMode | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
Protected method | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
Public method | ExecuteRegisteredAsyncTasks | Starts the execution of an asynchronous task. (Inherited from Page.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | FrameworkInitialize | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
Public method | GetDataItem | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Protected method | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
Protected method | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
Protected method | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
Public method | GetPostBackClientEvent | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
Public method | GetPostBackClientHyperlink | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
Public method | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
Public method | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeHashCode | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
Public method | GetValidators | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
Protected method | GetWrappedFileDependencies | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Protected method | InitializeCulture | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
Protected method | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
Protected method | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
Protected method | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
Public method | IsClientScriptBlockRegistered | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Public method | IsStartupScriptRegistered | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
Public method | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
Public method | LoadControl(Type, array<Object>[]()[][]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
Protected method | LoadPageStateFromPersistenceMedium | Loads any saved view-state information to the Page object. (Inherited from Page.)
Public method | LoadTemplate | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
Protected method | LoadViewState | Restores view-state information from a previous page request that was saved by the SaveViewState()()()() method. (Inherited from Control.)
Public method | MapPath | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAbortTransaction | Raises the AbortTransaction event. (Inherited from TemplateControl.)
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnCommitTransaction | Raises the CommitTransaction event. (Inherited from TemplateControl.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnError | Raises the Error event. (Inherited from TemplateControl.)
Protected method | OnInit | Raises the Init event to initialize the page. (Inherited from Page.)
Protected method | OnInitComplete | Raises the InitComplete event after page initialization. (Inherited from Page.)
Protected method | OnLoad | Raises the Load event. (Overrides Control..::..OnLoad(EventArgs).)
Protected method | OnLoadComplete | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
Protected method | OnPreInit | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
Protected method | OnPreLoad | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
Protected method | OnPreRender | Raises the PreRender event. (Inherited from Page.)
Protected method | OnPreRenderComplete | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
Protected method | OnSaveStateComplete | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Public method | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
Public method | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
Public method | ProcessRequest | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Protected method | RaisePostBackEvent | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
Public method | ReadStringResource | Reads a string resource. The ReadStringResource()()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | RegisterArrayDeclaration | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
Public method | RegisterAsyncTask | Registers a new asynchronous task with the page. (Inherited from Page.)
Public method | RegisterClientScriptBlock | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
Public method | RegisterHiddenField | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
Public method | RegisterOnSubmitStatement | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
Public method | RegisterRequiresControlState | Registers a control as one whose control state must be persisted. (Inherited from Page.)
Public method | RegisterRequiresPostBack | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
Public method | RegisterRequiresRaiseEvent | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
Public method | RegisterRequiresViewStateEncryption | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
Public method | RegisterStartupScript | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
Public method | RegisterViewStateHandler | Causes page view state to be persisted, if called. (Inherited from Page.)
Protected method | RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Protected method | Render | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Public method | RequiresControlState | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SavePageStateToPersistenceMedium | Saves any view-state and control-state information for the page. (Inherited from Page.)
Protected method | SaveViewState | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
Public method | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Protected method | SetStringResourcePointer | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | TestDeviceFilter | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TrackViewState | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
Public method | UnregisterRequiresControlState | Stops persistence of control state for the specified control. (Inherited from Page.)
Public method | Validate()()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
Public method | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
Public method | VerifyRenderingInServerForm | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
Protected method | WriteUTF8ResourceString | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
Protected method | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
Protected method | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
Protected method | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
Protected method | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
Protected method | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Protected method | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)

See Also

ChangePasswordPage Class
Sitecore.Login Namespace


AddOnPreRenderCompleteAsync Method

[image] [image]

Sitecore 6.4.1 API
ChangePasswordPage..::..AddOnPreRenderCompleteAsync Method
ChangePasswordPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
Public method | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)

See Also

ChangePasswordPage Class
ChangePasswordPage Members
Sitecore.Login Namespace


DataBind Method

[image] [image]

Sitecore 6.4.1 API
ChangePasswordPage..::..DataBind Method
ChangePasswordPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)

See Also

ChangePasswordPage Class
ChangePasswordPage Members
Sitecore.Login Namespace


Eval Method

[image] [image]

Sitecore 6.4.1 API
ChangePasswordPage..::..Eval Method
ChangePasswordPage Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
Protected method | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)

See Also

ChangePasswordPage Class
ChangePasswordPage Members
Sitecore.Login Namespace


GetGlobalResourceObject Method

[image] [image]

Sitecore 6.4.1 API
ChangePasswordPage..::..GetGlobalResourceObject Method
ChangePasswordPage Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
Protected method | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)

See Also

ChangePasswordPage Class
ChangePasswordPage Members
Sitecore.Login Namespace


GetLocalResourceObject Method

[image] [image]

Sitecore 6.4.1 API
ChangePasswordPage..::..GetLocalResourceObject Method
ChangePasswordPage Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
Protected method | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)

See Also

ChangePasswordPage Class
ChangePasswordPage Members
Sitecore.Login Namespace


GetPostBackEventReference Method

[image] [image]

Sitecore 6.4.1 API
ChangePasswordPage..::..GetPostBackEventReference Method
ChangePasswordPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
Public method | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)

See Also

ChangePasswordPage Class
ChangePasswordPage Members
Sitecore.Login Namespace


InitOutputCache Method

[image] [image]

Sitecore 6.4.1 API
ChangePasswordPage..::..InitOutputCache Method
ChangePasswordPage Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
Protected method | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
Protected method | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)

See Also

ChangePasswordPage Class
ChangePasswordPage Members
Sitecore.Login Namespace


LoadControl Method

[image] [image]

Sitecore 6.4.1 API
ChangePasswordPage..::..LoadControl Method
ChangePasswordPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
Public method | LoadControl(Type, array<Object>[]()[][]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)

See Also

ChangePasswordPage Class
ChangePasswordPage Members
Sitecore.Login Namespace


OnLoad Method

[image]

Sitecore 6.4.1 API
ChangePasswordPage..::..OnLoad Method
ChangePasswordPage Class See Also Send Feedback

Namespace: Sitecore.Login
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void OnLoad(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnLoad ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLoad(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
The EventArgs object that contains the event data.

See Also

ChangePasswordPage Class
Sitecore.Login Namespace


ParseControl Method

[image] [image]

Sitecore 6.4.1 API
ChangePasswordPage..::..ParseControl Method
ChangePasswordPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
Public method | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)

See Also

ChangePasswordPage Class
ChangePasswordPage Members
Sitecore.Login Namespace


SetFocus Method

[image] [image]

Sitecore 6.4.1 API
ChangePasswordPage..::..SetFocus Method
ChangePasswordPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
Public method | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)

See Also

ChangePasswordPage Class
ChangePasswordPage Members
Sitecore.Login Namespace


Validate Method

[image] [image]

Sitecore 6.4.1 API
ChangePasswordPage..::..Validate Method
ChangePasswordPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Validate()()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
Public method | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)

See Also

ChangePasswordPage Class
ChangePasswordPage Members
Sitecore.Login Namespace


XPath Method

[image] [image]

Sitecore 6.4.1 API
ChangePasswordPage..::..XPath Method
ChangePasswordPage Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
Protected method | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
Protected method | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
Protected method | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)

See Also

ChangePasswordPage Class
ChangePasswordPage Members
Sitecore.Login Namespace


XPathSelect Method

[image] [image]

Sitecore 6.4.1 API
ChangePasswordPage..::..XPathSelect Method
ChangePasswordPage Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Protected method | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)

See Also

ChangePasswordPage Class
ChangePasswordPage Members
Sitecore.Login Namespace


ChangePasswordPage Events

[image] [image]

Sitecore 6.4.1 API
ChangePasswordPage Events
ChangePasswordPage Class See Also Send Feedback

The ChangePasswordPage type exposes the following members.

Events

 | Name | Description
Public event | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
Public event | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
Public event | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
Public event | PreLoad | Occurs before the page Load event. (Inherited from Page.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
Public event | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

See Also

ChangePasswordPage Class
Sitecore.Login Namespace


PasswordRecoveryPage Class

[image]

Sitecore 6.4.1 API
PasswordRecoveryPage Class
Members See Also Send Feedback

Namespace: Sitecore.Login
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PasswordRecoveryPage : Page
Visual Basic
Public Class PasswordRecoveryPage _
    Inherits Page
Visual C++
public ref class PasswordRecoveryPage : public Page

Inheritance Hierarchy

System..::..Object
System.Web.UI..::..Control
System.Web.UI..::..TemplateControl
System.Web.UI..::..Page
Sitecore.Web.UI.HtmlControls..::..Page
Sitecore.Login..::..PasswordRecoveryPage

See Also

PasswordRecoveryPage Members
Sitecore.Login Namespace


PasswordRecoveryPage Members

[image] [image]

Sitecore 6.4.1 API
PasswordRecoveryPage Members
PasswordRecoveryPage Class Constructors Methods Fields Properties Events See Also Send Feedback

The PasswordRecoveryPage type exposes the following members.

Constructors

 | Name | Description
Public method | PasswordRecoveryPage | Initializes a new instance of the PasswordRecoveryPage class

Methods

 | Name | Description
Protected method | AddContentTemplate | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Public method | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
Public method | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Protected method | AddWrappedFileDependencies | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | AspCompatBeginProcessRequest | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
Protected method | AspCompatEndProcessRequest | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
Protected method | AsyncPageBeginProcessRequest | Begins processing an asynchronous page request. (Inherited from Page.)
Protected method | AsyncPageEndProcessRequest | Ends processing an asynchronous page request. (Inherited from Page.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Protected method | Construct | Performs design-time logic. (Inherited from TemplateControl.)
Protected method | CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Protected method | CreateHtmlTextWriter | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
Protected method | CreateResourceBasedLiteralControl | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Public method | DesignerInitialize | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
Protected method | DeterminePostBackMode | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
Protected method | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
Public method | ExecuteRegisteredAsyncTasks | Starts the execution of an asynchronous task. (Inherited from Page.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | FrameworkInitialize | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
Public method | GetDataItem | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Protected method | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
Protected method | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
Protected method | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
Public method | GetPostBackClientEvent | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
Public method | GetPostBackClientHyperlink | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
Public method | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
Public method | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeHashCode | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
Public method | GetValidators | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
Protected method | GetWrappedFileDependencies | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Protected method | InitializeCulture | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
Protected method | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
Protected method | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
Protected method | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
Public method | IsClientScriptBlockRegistered | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Public method | IsStartupScriptRegistered | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
Public method | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
Public method | LoadControl(Type, array<Object>[]()[][]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
Protected method | LoadPageStateFromPersistenceMedium | Loads any saved view-state information to the Page object. (Inherited from Page.)
Public method | LoadTemplate | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
Protected method | LoadViewState | Restores view-state information from a previous page request that was saved by the SaveViewState()()()() method. (Inherited from Control.)
Public method | MapPath | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAbortTransaction | Raises the AbortTransaction event. (Inherited from TemplateControl.)
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnCommitTransaction | Raises the CommitTransaction event. (Inherited from TemplateControl.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnError | Raises the Error event. (Inherited from TemplateControl.)
Protected method | OnInit | Raises the Init event to initialize the page. (Inherited from Page.)
Protected method | OnInitComplete | Raises the InitComplete event after page initialization. (Inherited from Page.)
Protected method | OnLoad | Raises the Load event. (Overrides Control..::..OnLoad(EventArgs).)
Protected method | OnLoadComplete | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
Protected method | OnPreInit | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
Protected method | OnPreLoad | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
Protected method | OnPreRender | Raises the PreRender event. (Inherited from Page.)
Protected method | OnPreRenderComplete | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
Protected method | OnSaveStateComplete | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Public method | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
Public method | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
Public method | ProcessRequest | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Protected method | RaisePostBackEvent | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
Public method | ReadStringResource | Reads a string resource. The ReadStringResource()()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | RegisterArrayDeclaration | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
Public method | RegisterAsyncTask | Registers a new asynchronous task with the page. (Inherited from Page.)
Public method | RegisterClientScriptBlock | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
Public method | RegisterHiddenField | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
Public method | RegisterOnSubmitStatement | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
Public method | RegisterRequiresControlState | Registers a control as one whose control state must be persisted. (Inherited from Page.)
Public method | RegisterRequiresPostBack | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
Public method | RegisterRequiresRaiseEvent | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
Public method | RegisterRequiresViewStateEncryption | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
Public method | RegisterStartupScript | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
Public method | RegisterViewStateHandler | Causes page view state to be persisted, if called. (Inherited from Page.)
Protected method | RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Protected method | Render | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Public method | RequiresControlState | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SavePageStateToPersistenceMedium | Saves any view-state and control-state information for the page. (Inherited from Page.)
Protected method | SaveViewState | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SendEmail | Sends the email.
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
Public method | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Protected method | SetStringResourcePointer | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | TestDeviceFilter | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TrackViewState | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
Public method | UnregisterRequiresControlState | Stops persistence of control state for the specified control. (Inherited from Page.)
Public method | Validate()()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
Public method | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
Protected method | VerifyingUser | Verifyings the user.
Public method | VerifyRenderingInServerForm | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
Protected method | WriteUTF8ResourceString | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
Protected method | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
Protected method | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
Protected method | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
Protected method | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
Protected method | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Protected method | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)

Fields

 | Name | Description
Protected field | ForgotPasswordDisabledLabel | ForgotPasswordDisabledLabel control.
Protected field | LoginForm | LoginForm control.
Protected field | PartnerLogo | PartnerLogo control.
Protected field | PasswordRecovery | PasswordRecovery control.

Properties

 | Name | Description
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
Protected property | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
Protected property | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
Public property | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
Protected property | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
Public property | AutoPostBackControl | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
Public property | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Public property | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
Public property | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
Public property | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
Public property | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
Public property | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
Protected property | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
Public property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
Public property | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Public property | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
Public property | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
Public property | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
Public property | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
Public property | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Protected property | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
Public property | Form | Gets the HTML form for the page. (Inherited from Page.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Public property | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
Public property | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
Public property | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
Public property | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
Public property | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Public property | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
Public property | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
Public property | IsPostBackEventControlRegistered | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
Public property | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Public property | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Public property | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
Public property | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Public property | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
Public property | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
Public property | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
Public property | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
Public property | PageScriptManager | Gets the page script manager. (Inherited from Page.)
Protected property | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
Public property | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
Public property | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
Public property | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
Public property | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
Public property | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
Public property | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
Public property | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
Public property | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
Protected property | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
Public property | Title | Gets or sets the title for the page. (Inherited from Page.)
Public property | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
Public property | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
Public property | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
Protected property | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
Public property | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
Protected property | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
Public property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
Public property | User | Gets information about the user making the page request. (Inherited from Page.)
Public property | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Public property | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
Public property | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)

Events

 | Name | Description
Public event | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
Public event | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
Public event | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
Public event | PreLoad | Occurs before the page Load event. (Inherited from Page.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
Public event | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

See Also

PasswordRecoveryPage Class
Sitecore.Login Namespace


PasswordRecoveryPage Constructor

[image]

Sitecore 6.4.1 API
PasswordRecoveryPage Constructor
PasswordRecoveryPage Class See Also Send Feedback

Namespace: Sitecore.Login
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PasswordRecoveryPage()
Visual Basic
Public Sub New
Visual C++
public:
PasswordRecoveryPage()

See Also

PasswordRecoveryPage Class
Sitecore.Login Namespace


PasswordRecoveryPage Fields

[image] [image]

Sitecore 6.4.1 API
PasswordRecoveryPage Fields
PasswordRecoveryPage Class See Also Send Feedback

The PasswordRecoveryPage type exposes the following members.

Fields

 | Name | Description
Protected field | ForgotPasswordDisabledLabel | ForgotPasswordDisabledLabel control.
Protected field | LoginForm | LoginForm control.
Protected field | PartnerLogo | PartnerLogo control.
Protected field | PasswordRecovery | PasswordRecovery control.

See Also

PasswordRecoveryPage Class
Sitecore.Login Namespace


ForgotPasswordDisabledLabel Field

[image]

Sitecore 6.4.1 API
PasswordRecoveryPage..::..ForgotPasswordDisabledLabel Field
PasswordRecoveryPage Class See Also Send Feedback

Namespace: Sitecore.Login
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Literal ForgotPasswordDisabledLabel
Visual Basic
Protected ForgotPasswordDisabledLabel As Literal
Visual C++
protected:
Literal^ ForgotPasswordDisabledLabel

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

PasswordRecoveryPage Class
Sitecore.Login Namespace


LoginForm Field

[image]

Sitecore 6.4.1 API
PasswordRecoveryPage..::..LoginForm Field
PasswordRecoveryPage Class See Also Send Feedback

Namespace: Sitecore.Login
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected HtmlForm LoginForm
Visual Basic
Protected LoginForm As HtmlForm
Visual C++
protected:
HtmlForm^ LoginForm

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

PasswordRecoveryPage Class
Sitecore.Login Namespace


PartnerLogo Field

[image]

Sitecore 6.4.1 API
PasswordRecoveryPage..::..PartnerLogo Field
PasswordRecoveryPage Class See Also Send Feedback

Namespace: Sitecore.Login
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected PlaceHolder PartnerLogo
Visual Basic
Protected PartnerLogo As PlaceHolder
Visual C++
protected:
PlaceHolder^ PartnerLogo

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

PasswordRecoveryPage Class
Sitecore.Login Namespace


PasswordRecovery Field

[image]

Sitecore 6.4.1 API
PasswordRecoveryPage..::..PasswordRecovery Field
PasswordRecoveryPage Class See Also Send Feedback

Namespace: Sitecore.Login
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected PasswordRecovery PasswordRecovery
Visual Basic
Protected PasswordRecovery As PasswordRecovery
Visual C++
protected:
PasswordRecovery^ PasswordRecovery

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

PasswordRecoveryPage Class
Sitecore.Login Namespace


PasswordRecoveryPage Methods

[image] [image]

Sitecore 6.4.1 API
PasswordRecoveryPage Methods
PasswordRecoveryPage Class See Also Send Feedback

The PasswordRecoveryPage type exposes the following members.

Methods

 | Name | Description
Protected method | AddContentTemplate | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Public method | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
Public method | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Protected method | AddWrappedFileDependencies | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | AspCompatBeginProcessRequest | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
Protected method | AspCompatEndProcessRequest | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
Protected method | AsyncPageBeginProcessRequest | Begins processing an asynchronous page request. (Inherited from Page.)
Protected method | AsyncPageEndProcessRequest | Ends processing an asynchronous page request. (Inherited from Page.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Protected method | Construct | Performs design-time logic. (Inherited from TemplateControl.)
Protected method | CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Protected method | CreateHtmlTextWriter | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
Protected method | CreateResourceBasedLiteralControl | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Public method | DesignerInitialize | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
Protected method | DeterminePostBackMode | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
Protected method | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
Public method | ExecuteRegisteredAsyncTasks | Starts the execution of an asynchronous task. (Inherited from Page.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | FrameworkInitialize | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
Public method | GetDataItem | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Protected method | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
Protected method | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
Protected method | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
Public method | GetPostBackClientEvent | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
Public method | GetPostBackClientHyperlink | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
Public method | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
Public method | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeHashCode | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
Public method | GetValidators | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
Protected method | GetWrappedFileDependencies | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Protected method | InitializeCulture | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
Protected method | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
Protected method | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
Protected method | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
Public method | IsClientScriptBlockRegistered | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Public method | IsStartupScriptRegistered | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
Public method | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
Public method | LoadControl(Type, array<Object>[]()[][]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
Protected method | LoadPageStateFromPersistenceMedium | Loads any saved view-state information to the Page object. (Inherited from Page.)
Public method | LoadTemplate | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
Protected method | LoadViewState | Restores view-state information from a previous page request that was saved by the SaveViewState()()()() method. (Inherited from Control.)
Public method | MapPath | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAbortTransaction | Raises the AbortTransaction event. (Inherited from TemplateControl.)
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnCommitTransaction | Raises the CommitTransaction event. (Inherited from TemplateControl.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnError | Raises the Error event. (Inherited from TemplateControl.)
Protected method | OnInit | Raises the Init event to initialize the page. (Inherited from Page.)
Protected method | OnInitComplete | Raises the InitComplete event after page initialization. (Inherited from Page.)
Protected method | OnLoad | Raises the Load event. (Overrides Control..::..OnLoad(EventArgs).)
Protected method | OnLoadComplete | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
Protected method | OnPreInit | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
Protected method | OnPreLoad | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
Protected method | OnPreRender | Raises the PreRender event. (Inherited from Page.)
Protected method | OnPreRenderComplete | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
Protected method | OnSaveStateComplete | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Public method | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
Public method | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
Public method | ProcessRequest | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Protected method | RaisePostBackEvent | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
Public method | ReadStringResource | Reads a string resource. The ReadStringResource()()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | RegisterArrayDeclaration | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
Public method | RegisterAsyncTask | Registers a new asynchronous task with the page. (Inherited from Page.)
Public method | RegisterClientScriptBlock | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
Public method | RegisterHiddenField | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
Public method | RegisterOnSubmitStatement | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
Public method | RegisterRequiresControlState | Registers a control as one whose control state must be persisted. (Inherited from Page.)
Public method | RegisterRequiresPostBack | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
Public method | RegisterRequiresRaiseEvent | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
Public method | RegisterRequiresViewStateEncryption | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
Public method | RegisterStartupScript | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
Public method | RegisterViewStateHandler | Causes page view state to be persisted, if called. (Inherited from Page.)
Protected method | RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Protected method | Render | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Public method | RequiresControlState | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SavePageStateToPersistenceMedium | Saves any view-state and control-state information for the page. (Inherited from Page.)
Protected method | SaveViewState | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SendEmail | Sends the email.
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
Public method | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Protected method | SetStringResourcePointer | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | TestDeviceFilter | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TrackViewState | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
Public method | UnregisterRequiresControlState | Stops persistence of control state for the specified control. (Inherited from Page.)
Public method | Validate()()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
Public method | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
Protected method | VerifyingUser | Verifyings the user.
Public method | VerifyRenderingInServerForm | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
Protected method | WriteUTF8ResourceString | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
Protected method | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
Protected method | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
Protected method | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
Protected method | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
Protected method | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Protected method | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)

See Also

PasswordRecoveryPage Class
Sitecore.Login Namespace


AddOnPreRenderCompleteAsync Method

[image] [image]

Sitecore 6.4.1 API
PasswordRecoveryPage..::..AddOnPreRenderCompleteAsync Method
PasswordRecoveryPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
Public method | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)

See Also

PasswordRecoveryPage Class
PasswordRecoveryPage Members
Sitecore.Login Namespace


DataBind Method

[image] [image]

Sitecore 6.4.1 API
PasswordRecoveryPage..::..DataBind Method
PasswordRecoveryPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)

See Also

PasswordRecoveryPage Class
PasswordRecoveryPage Members
Sitecore.Login Namespace


Eval Method

[image] [image]

Sitecore 6.4.1 API
PasswordRecoveryPage..::..Eval Method
PasswordRecoveryPage Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
Protected method | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)

See Also

PasswordRecoveryPage Class
PasswordRecoveryPage Members
Sitecore.Login Namespace


FindControl Method

[image] [image]

Sitecore 6.4.1 API
PasswordRecoveryPage..::..FindControl Method
PasswordRecoveryPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)

See Also

PasswordRecoveryPage Class
PasswordRecoveryPage Members
Sitecore.Login Namespace


GetLocalResourceObject Method

[image] [image]

Sitecore 6.4.1 API
PasswordRecoveryPage..::..GetLocalResourceObject Method
PasswordRecoveryPage Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
Protected method | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)

See Also

PasswordRecoveryPage Class
PasswordRecoveryPage Members
Sitecore.Login Namespace


GetPostBackEventReference Method

[image] [image]

Sitecore 6.4.1 API
PasswordRecoveryPage..::..GetPostBackEventReference Method
PasswordRecoveryPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
Public method | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)

See Also

PasswordRecoveryPage Class
PasswordRecoveryPage Members
Sitecore.Login Namespace


InitOutputCache Method

[image] [image]

Sitecore 6.4.1 API
PasswordRecoveryPage..::..InitOutputCache Method
PasswordRecoveryPage Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
Protected method | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
Protected method | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)

See Also

PasswordRecoveryPage Class
PasswordRecoveryPage Members
Sitecore.Login Namespace


LoadControl Method

[image] [image]

Sitecore 6.4.1 API
PasswordRecoveryPage..::..LoadControl Method
PasswordRecoveryPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
Public method | LoadControl(Type, array<Object>[]()[][]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)

See Also

PasswordRecoveryPage Class
PasswordRecoveryPage Members
Sitecore.Login Namespace


OnLoad Method

[image]

Sitecore 6.4.1 API
PasswordRecoveryPage..::..OnLoad Method
PasswordRecoveryPage Class See Also Send Feedback

Namespace: Sitecore.Login
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void OnLoad(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnLoad ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLoad(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs
The EventArgs object that contains the event data.

See Also

PasswordRecoveryPage Class
Sitecore.Login Namespace


ParseControl Method

[image] [image]

Sitecore 6.4.1 API
PasswordRecoveryPage..::..ParseControl Method
PasswordRecoveryPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
Public method | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)

See Also

PasswordRecoveryPage Class
PasswordRecoveryPage Members
Sitecore.Login Namespace


RenderControl Method

[image] [image]

Sitecore 6.4.1 API
PasswordRecoveryPage..::..RenderControl Method
PasswordRecoveryPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)

See Also

PasswordRecoveryPage Class
PasswordRecoveryPage Members
Sitecore.Login Namespace


SendEmail Method

[image]

Sitecore 6.4.1 API
PasswordRecoveryPage..::..SendEmail Method
PasswordRecoveryPage Class See Also Send Feedback

Namespace: Sitecore.Login
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void SendEmail(
    Object sender,
    MailMessageEventArgs e
)
Visual Basic
Protected Sub SendEmail ( _
    sender As Object, _
    e As MailMessageEventArgs _
)
Visual C++
protected:
void SendEmail(
    Object^ sender,
    MailMessageEventArgs^ e
)

Parameters

sender
Type: System..::..Object
The sender.
e
Type: System.Web.UI.WebControls..::..MailMessageEventArgs
The MailMessageEventArgs instance containing the event data.

See Also

PasswordRecoveryPage Class
Sitecore.Login Namespace


SetFocus Method

[image] [image]

Sitecore 6.4.1 API
PasswordRecoveryPage..::..SetFocus Method
PasswordRecoveryPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
Public method | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)

See Also

PasswordRecoveryPage Class
PasswordRecoveryPage Members
Sitecore.Login Namespace


Validate Method

[image] [image]

Sitecore 6.4.1 API
PasswordRecoveryPage..::..Validate Method
PasswordRecoveryPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Validate()()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
Public method | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)

See Also

PasswordRecoveryPage Class
PasswordRecoveryPage Members
Sitecore.Login Namespace


VerifyingUser Method

[image]

Sitecore 6.4.1 API
PasswordRecoveryPage..::..VerifyingUser Method
PasswordRecoveryPage Class See Also Send Feedback

Namespace: Sitecore.Login
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void VerifyingUser(
    Object sender,
    LoginCancelEventArgs e
)
Visual Basic
Protected Sub VerifyingUser ( _
    sender As Object, _
    e As LoginCancelEventArgs _
)
Visual C++
protected:
void VerifyingUser(
    Object^ sender,
    LoginCancelEventArgs^ e
)

Parameters

sender
Type: System..::..Object
The sender.
e
Type: System.Web.UI.WebControls..::..LoginCancelEventArgs
The LoginCancelEventArgs instance containing the event data.

See Also

PasswordRecoveryPage Class
Sitecore.Login Namespace


XPath Method

[image] [image]

Sitecore 6.4.1 API
PasswordRecoveryPage..::..XPath Method
PasswordRecoveryPage Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
Protected method | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
Protected method | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
Protected method | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)

See Also

PasswordRecoveryPage Class
PasswordRecoveryPage Members
Sitecore.Login Namespace


XPathSelect Method

[image] [image]

Sitecore 6.4.1 API
PasswordRecoveryPage..::..XPathSelect Method
PasswordRecoveryPage Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Protected method | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)

See Also

PasswordRecoveryPage Class
PasswordRecoveryPage Members
Sitecore.Login Namespace


PasswordRecoveryPage Properties

[image] [image]

Sitecore 6.4.1 API
PasswordRecoveryPage Properties
PasswordRecoveryPage Class See Also Send Feedback

The PasswordRecoveryPage type exposes the following members.

Properties

 | Name | Description
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
Protected property | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
Protected property | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
Public property | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
Protected property | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
Public property | AutoPostBackControl | Gets or sets the control of the page that is used to postback to the server. (Inherited from Page.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
Public property | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Public property | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
Public property | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
Public property | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
Public property | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
Public property | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
Protected property | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
Public property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
Public property | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Public property | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
Public property | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
Public property | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
Public property | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
Public property | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Protected property | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
Public property | Form | Gets the HTML form for the page. (Inherited from Page.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Public property | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
Public property | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
Public property | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
Public property | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
Public property | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Public property | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
Public property | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
Public property | IsPostBackEventControlRegistered | Gets a value indicating whether the control of the page that submits a postback is registered. (Inherited from Page.)
Public property | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Public property | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Public property | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
Public property | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Public property | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
Public property | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
Public property | MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
Public property | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
Public property | PageScriptManager | Gets the page script manager. (Inherited from Page.)
Protected property | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
Public property | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
Public property | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
Public property | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
Public property | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
Public property | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
Public property | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
Public property | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
Public property | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
Protected property | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
Public property | Title | Gets or sets the title for the page. (Inherited from Page.)
Public property | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
Public property | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
Public property | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
Protected property | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
Public property | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
Protected property | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
Public property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
Public property | User | Gets information about the user making the page request. (Inherited from Page.)
Public property | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Public property | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
Public property | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)

See Also

PasswordRecoveryPage Class
Sitecore.Login Namespace


PasswordRecoveryPage Events

[image] [image]

Sitecore 6.4.1 API
PasswordRecoveryPage Events
PasswordRecoveryPage Class See Also Send Feedback

The PasswordRecoveryPage type exposes the following members.

Events

 | Name | Description
Public event | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
Public event | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
Public event | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
Public event | PreLoad | Occurs before the page Load event. (Inherited from Page.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
Public event | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

See Also

PasswordRecoveryPage Class
Sitecore.Login Namespace


Sitecore.Pipelines Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines Namespace
Send Feedback

Classes

 | Class | Description
Public class | CorePipeline | Represents a core pipeline.
Public class | CorePipelineFactory | Represents the pipeline factory (2).
Public class | CoreProcessor | Represents a processor (2).
Public class | ItemLinksPipelineArgs | Obsolete. Argument class for processor Item links.
Public class | Pipeline | Represents a pipeline.
Public class | PipelineArgs | Base argument class for processor implementations
Public class | PipelineFactory | Factory for instantiating processors defined in the web.config.
Public class | PipelineGroup | Represents a pipeline group.
Public class | PipelineMessage | Represents a pipeline message.
Public class | PipelineMethod | Represents a pipeline method.
Public class | Processor | Represents a single step in a pipeline.
Public class | ProcessorObject | Represents a processor object.

Enumerations

 | Enumeration | Description
Public enumeration | ObjectScope | Represents an object scope.
Public enumeration | Pipeline..::..PipelineType | Represents the type of a pipeline.
Public enumeration | PipelineMessageFilter | Represents the filter for a pipeline message.
Public enumeration | PipelineMessageType | Represents the type of a pipeline message.


CorePipeline Class

[image]

Sitecore 6.4.1 API
CorePipeline Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CorePipeline
Visual Basic
Public Class CorePipeline
Visual C++
public ref class CorePipeline

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines..::..CorePipeline

See Also

CorePipeline Members
Sitecore.Pipelines Namespace


CorePipeline Members

[image] [image]

Sitecore 6.4.1 API
CorePipeline Members
CorePipeline Class Constructors Methods Properties See Also Send Feedback

The CorePipeline type exposes the following members.

Constructors

 | Name | Description
Public method | CorePipeline | Initializes a new instance of the CorePipeline class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the pipeline from a config node.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Run(PipelineArgs) | Runs the pipeline.
 | Run(String, PipelineArgs) | Runs the specified pipeline.
 | Run(String, PipelineArgs, Boolean) | Runs the specified pipeline.
 | Run(String, PipelineArgs, String) | Runs the specified pipeline.
 | Run(String, PipelineArgs, String, Boolean) | Runs the specified pipeline name.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Gets a value indicating whether this pipeline is empty.
Public property | Name | Gets the name.

See Also

CorePipeline Class
Sitecore.Pipelines Namespace


CorePipeline Constructor

[image]

Sitecore 6.4.1 API
CorePipeline Constructor
CorePipeline Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CorePipeline(
    string pipelineName
)
Visual Basic
Public Sub New ( _
    pipelineName As String _
)
Visual C++
public:
CorePipeline(
    String^ pipelineName
)

Parameters

pipelineName
Type: System..::..String
Name of the pipeline.

See Also

CorePipeline Class
Sitecore.Pipelines Namespace


CorePipeline Methods

[image] [image]

Sitecore 6.4.1 API
CorePipeline Methods
CorePipeline Class See Also Send Feedback

The CorePipeline type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the pipeline from a config node.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Run(PipelineArgs) | Runs the pipeline.
 | Run(String, PipelineArgs) | Runs the specified pipeline.
 | Run(String, PipelineArgs, Boolean) | Runs the specified pipeline.
 | Run(String, PipelineArgs, String) | Runs the specified pipeline.
 | Run(String, PipelineArgs, String, Boolean) | Runs the specified pipeline name.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CorePipeline Class
Sitecore.Pipelines Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
CorePipeline..::..Initialize Method
CorePipeline Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Initialize(
    XmlNode configNode
)
Visual Basic
Public Sub Initialize ( _
    configNode As XmlNode _
)
Visual C++
public:
void Initialize(
    XmlNode^ configNode
)

Parameters

configNode
Type: System.Xml..::..XmlNode
The config node.

See Also

CorePipeline Class
Sitecore.Pipelines Namespace


Run Method

[image] [image]

Sitecore 6.4.1 API
CorePipeline..::..Run Method
CorePipeline Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Run(PipelineArgs) | Runs the pipeline.
 | Run(String, PipelineArgs) | Runs the specified pipeline.
 | Run(String, PipelineArgs, Boolean) | Runs the specified pipeline.
 | Run(String, PipelineArgs, String) | Runs the specified pipeline.
 | Run(String, PipelineArgs, String, Boolean) | Runs the specified pipeline name.

See Also

CorePipeline Class
CorePipeline Members
Sitecore.Pipelines Namespace


Run Method (PipelineArgs)

[image]

Sitecore 6.4.1 API
CorePipeline..::..Run Method (PipelineArgs)
CorePipeline Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Run(
    PipelineArgs args
)
Visual Basic
Public Sub Run ( _
    args As PipelineArgs _
)
Visual C++
public:
void Run(
    PipelineArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines..::..PipelineArgs
The args.

See Also

CorePipeline Class
Run Overload
Sitecore.Pipelines Namespace


Run Method (String, PipelineArgs, Boolean)

[image]

Sitecore 6.4.1 API
CorePipeline..::..Run Method (String, PipelineArgs, Boolean)
CorePipeline Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Run(
    string pipelineName,
    PipelineArgs args,
    bool failIfNotExists
)
Visual Basic
Public Shared Sub Run ( _
    pipelineName As String, _
    args As PipelineArgs, _
    failIfNotExists As Boolean _
)
Visual C++
public:
static void Run(
    String^ pipelineName,
    PipelineArgs^ args,
    bool failIfNotExists
)

Parameters

pipelineName
Type: System..::..String
Name of the pipeline.
args
Type: Sitecore.Pipelines..::..PipelineArgs
The args.
failIfNotExists
Type: System..::..Boolean
if set to true the code will throw an exception if pipeline not found.

See Also

CorePipeline Class
Run Overload
Sitecore.Pipelines Namespace


Run Method (String, PipelineArgs, String)

[image]

Sitecore 6.4.1 API
CorePipeline..::..Run Method (String, PipelineArgs, String)
CorePipeline Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Run(
    string pipelineName,
    PipelineArgs args,
    string pipelineDomain
)
Visual Basic
Public Shared Sub Run ( _
    pipelineName As String, _
    args As PipelineArgs, _
    pipelineDomain As String _
)
Visual C++
public:
static void Run(
    String^ pipelineName,
    PipelineArgs^ args,
    String^ pipelineDomain
)

Parameters

pipelineName
Type: System..::..String
Name of the pipeline.
args
Type: Sitecore.Pipelines..::..PipelineArgs
The arguments.
pipelineDomain
Type: System..::..String
The pipeline domain.

See Also

CorePipeline Class
Run Overload
Sitecore.Pipelines Namespace


Run Method (String, PipelineArgs, String, Boolean)

[image]

Sitecore 6.4.1 API
CorePipeline..::..Run Method (String, PipelineArgs, String, Boolean)
CorePipeline Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Run(
    string pipelineName,
    PipelineArgs args,
    string pipelineDomain,
    bool failIfNotExists
)
Visual Basic
Public Shared Sub Run ( _
    pipelineName As String, _
    args As PipelineArgs, _
    pipelineDomain As String, _
    failIfNotExists As Boolean _
)
Visual C++
public:
static void Run(
    String^ pipelineName,
    PipelineArgs^ args,
    String^ pipelineDomain,
    bool failIfNotExists
)

Parameters

pipelineName
Type: System..::..String
Name of the pipeline.
args
Type: Sitecore.Pipelines..::..PipelineArgs
The arguments.
pipelineDomain
Type: System..::..String
The pipeline domain.
failIfNotExists
Type: System..::..Boolean
if set to true the code will throw an exception if pipeline not found.

See Also

CorePipeline Class
Run Overload
Sitecore.Pipelines Namespace


IsEmpty Property

[image]

Sitecore 6.4.1 API
CorePipeline..::..IsEmpty Property
CorePipeline Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
property bool IsEmpty {
    bool get ();
}

Field Value

true if this pipeline is empty; otherwise, false.

See Also

CorePipeline Class
Sitecore.Pipelines Namespace


Name Property

[image]

Sitecore 6.4.1 API
CorePipeline..::..Name Property
CorePipeline Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

CorePipeline Class
Sitecore.Pipelines Namespace


CorePipelineFactory Class

[image]

Sitecore 6.4.1 API
CorePipelineFactory Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class CorePipelineFactory
Visual Basic
Public NotInheritable Class CorePipelineFactory
Visual C++
public ref class CorePipelineFactory abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines..::..CorePipelineFactory

See Also

CorePipelineFactory Members
Sitecore.Pipelines Namespace


CorePipelineFactory Members

[image] [image]

Sitecore 6.4.1 API
CorePipelineFactory Members
CorePipelineFactory Class Methods See Also Send Feedback

The CorePipelineFactory type exposes the following members.

Methods

Name | Description
ClearCache | Clears the cache.
GetPipeline | Gets the pipeline.

See Also

CorePipelineFactory Class
Sitecore.Pipelines Namespace


CorePipelineFactory Methods

[image] [image]

Sitecore 6.4.1 API
CorePipelineFactory Methods
CorePipelineFactory Class See Also Send Feedback

The CorePipelineFactory type exposes the following members.

Methods

Name | Description
ClearCache | Clears the cache.
GetPipeline | Gets the pipeline.

See Also

CorePipelineFactory Class
Sitecore.Pipelines Namespace


ClearCache Method

[image]

Sitecore 6.4.1 API
CorePipelineFactory..::..ClearCache Method
CorePipelineFactory Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void ClearCache()
Visual Basic
Public Shared Sub ClearCache
Visual C++
public:
static void ClearCache()

See Also

CorePipelineFactory Class
Sitecore.Pipelines Namespace


GetPipeline Method

[image]

Sitecore 6.4.1 API
CorePipelineFactory..::..GetPipeline Method
CorePipelineFactory Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static CorePipeline GetPipeline(
    string pipelineName,
    string pipelineGroup
)
Visual Basic
Public Shared Function GetPipeline ( _
    pipelineName As String, _
    pipelineGroup As String _
) As CorePipeline
Visual C++
public:
static CorePipeline^ GetPipeline(
    String^ pipelineName,
    String^ pipelineGroup
)

Parameters

pipelineName
Type: System..::..String
Name of the pipeline.
pipelineGroup
Type: System..::..String
The pipeline group.

Return Value

The pipeline.

See Also

CorePipelineFactory Class
Sitecore.Pipelines Namespace


CoreProcessor Class

[image]

Sitecore 6.4.1 API
CoreProcessor Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CoreProcessor
Visual Basic
Public Class CoreProcessor
Visual C++
public ref class CoreProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines..::..CoreProcessor

See Also

CoreProcessor Members
Sitecore.Pipelines Namespace


CoreProcessor Members

[image] [image]

Sitecore 6.4.1 API
CoreProcessor Members
CoreProcessor Class Constructors Methods Properties See Also Send Feedback

The CoreProcessor type exposes the following members.

Constructors

 | Name | Description
Public method | CoreProcessor | Initializes a new instance of the CoreProcessor class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the processor.
Public method | Invoke | Invokes the method.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | Gets the name.
Public property | RunIfAborted | Gets a value indicating whether to run the processor even if the pipeline has been aborted.

See Also

CoreProcessor Class
Sitecore.Pipelines Namespace


CoreProcessor Constructor

[image]

Sitecore 6.4.1 API
CoreProcessor Constructor
CoreProcessor Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CoreProcessor()
Visual Basic
Public Sub New
Visual C++
public:
CoreProcessor()

See Also

CoreProcessor Class
Sitecore.Pipelines Namespace


CoreProcessor Methods

[image] [image]

Sitecore 6.4.1 API
CoreProcessor Methods
CoreProcessor Class See Also Send Feedback

The CoreProcessor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the processor.
Public method | Invoke | Invokes the method.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CoreProcessor Class
Sitecore.Pipelines Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
CoreProcessor..::..Initialize Method
CoreProcessor Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Initialize(
    XmlNode configNode
)
Visual Basic
Public Sub Initialize ( _
    configNode As XmlNode _
)
Visual C++
public:
void Initialize(
    XmlNode^ configNode
)

Parameters

configNode
Type: System.Xml..::..XmlNode
The config node.

See Also

CoreProcessor Class
Sitecore.Pipelines Namespace


Invoke Method

[image]

Sitecore 6.4.1 API
CoreProcessor..::..Invoke Method
CoreProcessor Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Invoke(
    Object[] parameters
)
Visual Basic
Public Sub Invoke ( _
    parameters As Object() _
)
Visual C++
public:
void Invoke(
    array<Object^>^ parameters
)

Parameters

parameters
Type: array< System..::..Object >[]()[][]
The parameters.

See Also

CoreProcessor Class
Sitecore.Pipelines Namespace


CoreProcessor Properties

[image] [image]

Sitecore 6.4.1 API
CoreProcessor Properties
CoreProcessor Class See Also Send Feedback

The CoreProcessor type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the name.
Public property | RunIfAborted | Gets a value indicating whether to run the processor even if the pipeline has been aborted.

See Also

CoreProcessor Class
Sitecore.Pipelines Namespace


Name Property

[image]

Sitecore 6.4.1 API
CoreProcessor..::..Name Property
CoreProcessor Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

CoreProcessor Class
Sitecore.Pipelines Namespace


RunIfAborted Property

[image]

Sitecore 6.4.1 API
CoreProcessor..::..RunIfAborted Property
CoreProcessor Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool RunIfAborted { get; }
Visual Basic
Public ReadOnly Property RunIfAborted As Boolean
    Get
Visual C++
public:
property bool RunIfAborted {
    bool get ();
}

Field Value

true if the processor should be run; otherwise, false.

See Also

CoreProcessor Class
Sitecore.Pipelines Namespace


ItemLinksPipelineArgs Class

[image]

Sitecore 6.4.1 API
ItemLinksPipelineArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
[ObsoleteAttribute("Deprecated.")]
public class ItemLinksPipelineArgs : ClientPipelineArgs,
    ISerializable
Visual Basic
<SerializableAttribute> _
<ObsoleteAttribute("Deprecated.")> _
Public Class ItemLinksPipelineArgs _
    Inherits ClientPipelineArgs _
    Implements ISerializable
Visual C++
[SerializableAttribute]
[ObsoleteAttribute(L"Deprecated.")]
public ref class ItemLinksPipelineArgs : public ClientPipelineArgs,
    ISerializable

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Web.UI.Sheer..::..ClientPipelineArgs
Sitecore.Pipelines..::..ItemLinksPipelineArgs

See Also

ItemLinksPipelineArgs Members
Sitecore.Pipelines Namespace


ItemLinksPipelineArgs Members

[image] [image]

Sitecore 6.4.1 API
ItemLinksPipelineArgs Members
ItemLinksPipelineArgs Class Constructors Methods Properties See Also Send Feedback

The ItemLinksPipelineArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ItemLinksPipelineArgs()()()() | Initializes a new instance of the ItemLinksPipelineArgs class.
Protected method | ItemLinksPipelineArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the ItemLinksPipelineArgs class from a serialization context.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ClientPipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from ClientPipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WaitForPostBack()()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Public method | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CarryResultToNextProcessor | Gets or sets a value indicating whether the ClientPipelineArgs carries the result to next processor. (Inherited from ClientPipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | HasResult | Gets a value indicating whether this instance has a result. (Inherited from ClientPipelineArgs.)
Public property | IsPostBack | Gets or sets a value that indicates if the processor was invoked as part of a user response. (Inherited from ClientPipelineArgs.)
Public property | ItemLinks | Gets or sets the links that are to be transfered between method invocations.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Parameters | Gets or sets the parameters. (Inherited from ClientPipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Properties | Gets the properties. (Inherited from ClientPipelineArgs.)
Public property | Result | Gets or sets the value that was posted as part of a Sheer response. (Inherited from ClientPipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

ItemLinksPipelineArgs Class
Sitecore.Pipelines Namespace


ItemLinksPipelineArgs Constructor

[image]

Sitecore 6.4.1 API
ItemLinksPipelineArgs Constructor
ItemLinksPipelineArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemLinksPipelineArgs()
Visual Basic
Public Sub New
Visual C++
public:
ItemLinksPipelineArgs()

See Also

ItemLinksPipelineArgs Class
ItemLinksPipelineArgs Overload
Sitecore.Pipelines Namespace


ItemLinksPipelineArgs Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
ItemLinksPipelineArgs Constructor (SerializationInfo, StreamingContext)
ItemLinksPipelineArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected ItemLinksPipelineArgs(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
ItemLinksPipelineArgs(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The serialized data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

ItemLinksPipelineArgs Class
ItemLinksPipelineArgs Overload
Sitecore.Pipelines Namespace


ItemLinksPipelineArgs Methods

[image] [image]

Sitecore 6.4.1 API
ItemLinksPipelineArgs Methods
ItemLinksPipelineArgs Class See Also Send Feedback

The ItemLinksPipelineArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ClientPipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from ClientPipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WaitForPostBack()()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Public method | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)

See Also

ItemLinksPipelineArgs Class
Sitecore.Pipelines Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
ItemLinksPipelineArgs..::..AddMessage Method
ItemLinksPipelineArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

ItemLinksPipelineArgs Class
ItemLinksPipelineArgs Members
Sitecore.Pipelines Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
ItemLinksPipelineArgs..::..GetMessages Method
ItemLinksPipelineArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

ItemLinksPipelineArgs Class
ItemLinksPipelineArgs Members
Sitecore.Pipelines Namespace


GetObjectData Method

[image]

Sitecore 6.4.1 API
ItemLinksPipelineArgs..::..GetObjectData Method
ItemLinksPipelineArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System.Security..::..SecurityException | The caller does not have the required permission.

See Also

ItemLinksPipelineArgs Class
Sitecore.Pipelines Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
ItemLinksPipelineArgs..::..Suspend Method
ItemLinksPipelineArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

ItemLinksPipelineArgs Class
ItemLinksPipelineArgs Members
Sitecore.Pipelines Namespace


WaitForPostBack Method

[image] [image]

Sitecore 6.4.1 API
ItemLinksPipelineArgs..::..WaitForPostBack Method
ItemLinksPipelineArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaitForPostBack()()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Public method | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)

See Also

ItemLinksPipelineArgs Class
ItemLinksPipelineArgs Members
Sitecore.Pipelines Namespace


ItemLinksPipelineArgs Properties

[image] [image]

Sitecore 6.4.1 API
ItemLinksPipelineArgs Properties
ItemLinksPipelineArgs Class See Also Send Feedback

The ItemLinksPipelineArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CarryResultToNextProcessor | Gets or sets a value indicating whether the ClientPipelineArgs carries the result to next processor. (Inherited from ClientPipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | HasResult | Gets a value indicating whether this instance has a result. (Inherited from ClientPipelineArgs.)
Public property | IsPostBack | Gets or sets a value that indicates if the processor was invoked as part of a user response. (Inherited from ClientPipelineArgs.)
Public property | ItemLinks | Gets or sets the links that are to be transfered between method invocations.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Parameters | Gets or sets the parameters. (Inherited from ClientPipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Properties | Gets the properties. (Inherited from ClientPipelineArgs.)
Public property | Result | Gets or sets the value that was posted as part of a Sheer response. (Inherited from ClientPipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

ItemLinksPipelineArgs Class
Sitecore.Pipelines Namespace


ItemLinks Property

[image]

Sitecore 6.4.1 API
ItemLinksPipelineArgs..::..ItemLinks Property
ItemLinksPipelineArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemLink[] ItemLinks { get; set; }
Visual Basic
Public Property ItemLinks As ItemLink()
    Get
    Set
Visual C++
public:
property array<ItemLink^>^ ItemLinks {
    array<ItemLink^>^ get ();
    void set (array<ItemLink^>^ value);
}

Field Value

The item links.

See Also

ItemLinksPipelineArgs Class
Sitecore.Pipelines Namespace


ObjectScope Enumeration

[image]

Sitecore 6.4.1 API
ObjectScope Enumeration
See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum ObjectScope
Visual Basic
Public Enumeration ObjectScope
Visual C++
public enum class ObjectScope

Members

Member name | Value | Description
Invocation | 0 | Invocation.
Processor | 1 | Processor.
Pipeline | 2 | Pipeline.
Group | 3 | Group.

See Also

Sitecore.Pipelines Namespace


Pipeline Class

[image]

Sitecore 6.4.1 API
Pipeline Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class Pipeline : ISerializable
Visual Basic
<SerializableAttribute> _
Public Class Pipeline _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class Pipeline : ISerializable

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines..::..Pipeline

See Also

Pipeline Members
Sitecore.Pipelines Namespace


Pipeline Members

[image] [image]

Sitecore 6.4.1 API
Pipeline Members
Pipeline Class Constructors Methods Properties See Also Send Feedback

The Pipeline type exposes the following members.

Constructors

 | Name | Description
Protected method | Pipeline(SerializationInfo, StreamingContext) | Initializes a new instance of the Pipeline class from a serialization context.
Public method | Pipeline(String, ArrayList) | Obsolete. Initializes a new instance of the Pipeline class.
Public method | Pipeline(String, ArrayList, Pipeline..::..PipelineType) | Initializes a new instance of the Pipeline class.

Methods

 | Name | Description
Public method | Add | Adds the specified processor.
Public method | AddAt | Adds the specified processor at the index.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetProcessorByName | Gets the name of the processor by name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the specified processor.
Public method | Resume | Runs the processors of a specific type.
Public method | Start(PipelineArgs) | Starts the pipeline using the specified argumentss.
 | Start(String, PipelineArgs) | Starts the pipeline with the specified name.
 | Start(Item, PipelineArgs) | Starts the pipeline with the specified owner item.
Public method | Start(PipelineArgs, Boolean) | Starts the pipeline using the specified argumentss.
 | Start(String, PipelineArgs, Boolean) | Starts the pipeline with the specified name.
 | Start(Item, PipelineArgs, Boolean) | Starts the pipeline with the specified owner item.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Args | Gets the arguments.
Public property | CurrentProcessor | Gets or sets the current processor.
Public property | ID | Gets or sets the ID.
Public property | Name | Gets the name.
Public property | NextProcessor | Gets or sets the next processor.
Public property | Processors | Gets the processors.

See Also

Pipeline Class
Sitecore.Pipelines Namespace


Pipeline Constructor

[image] [image]

Sitecore 6.4.1 API
Pipeline Constructor
Pipeline Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Pipeline(SerializationInfo, StreamingContext) | Initializes a new instance of the Pipeline class from a serialization context.
Public method | Pipeline(String, ArrayList) | Obsolete. Initializes a new instance of the Pipeline class.
Public method | Pipeline(String, ArrayList, Pipeline..::..PipelineType) | Initializes a new instance of the Pipeline class.

See Also

Pipeline Class
Pipeline Members
Sitecore.Pipelines Namespace


Pipeline Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
Pipeline Constructor (SerializationInfo, StreamingContext)
Pipeline Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Pipeline(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
Pipeline(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The serialized data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

Pipeline Class
Pipeline Overload
Sitecore.Pipelines Namespace


Pipeline Constructor (String, ArrayList)

[image]

Sitecore 6.4.1 API
Pipeline Constructor (String, ArrayList)
Pipeline Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use Pipeline(name, processors, type) instead.")]
public Pipeline(
    string name,
    ArrayList processors
)
Visual Basic
<ObsoleteAttribute("Deprecated - Use Pipeline(name, processors, type) instead.")> _
Public Sub New ( _
    name As String, _
    processors As ArrayList _
)
Visual C++
[ObsoleteAttribute(L"Deprecated - Use Pipeline(name, processors, type) instead.")]
public:
Pipeline(
    String^ name,
    ArrayList^ processors
)

Parameters

name
Type: System..::..String
The name.
processors
Type: System.Collections..::..ArrayList
The processors.

See Also

Pipeline Class
Pipeline Overload
Sitecore.Pipelines Namespace


Pipeline Constructor (String, ArrayList, Pipeline.PipelineType)

[image]

Sitecore 6.4.1 API
Pipeline Constructor (String, ArrayList, Pipeline..::..PipelineType)
Pipeline Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Pipeline(
    string name,
    ArrayList processors,
    Pipeline..::..PipelineType type
)
Visual Basic
Public Sub New ( _
    name As String, _
    processors As ArrayList, _
    type As Pipeline..::..PipelineType _
)
Visual C++
public:
Pipeline(
    String^ name,
    ArrayList^ processors,
    Pipeline..::..PipelineType type
)

Parameters

name
Type: System..::..String
The name.
processors
Type: System.Collections..::..ArrayList
The processors.
type
Type: Sitecore.Pipelines..::..Pipeline..::..PipelineType
The type.

See Also

Pipeline Class
Pipeline Overload
Sitecore.Pipelines Namespace


Pipeline Methods

[image] [image]

Sitecore 6.4.1 API
Pipeline Methods
Pipeline Class See Also Send Feedback

The Pipeline type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified processor.
Public method | AddAt | Adds the specified processor at the index.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetProcessorByName | Gets the name of the processor by name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the specified processor.
Public method | Resume | Runs the processors of a specific type.
Public method | Start(PipelineArgs) | Starts the pipeline using the specified argumentss.
 | Start(String, PipelineArgs) | Starts the pipeline with the specified name.
 | Start(Item, PipelineArgs) | Starts the pipeline with the specified owner item.
Public method | Start(PipelineArgs, Boolean) | Starts the pipeline using the specified argumentss.
 | Start(String, PipelineArgs, Boolean) | Starts the pipeline with the specified name.
 | Start(Item, PipelineArgs, Boolean) | Starts the pipeline with the specified owner item.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Pipeline Class
Sitecore.Pipelines Namespace


Add Method

[image]

Sitecore 6.4.1 API
Pipeline..::..Add Method
Pipeline Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Add(
    Processor processor
)
Visual Basic
Public Sub Add ( _
    processor As Processor _
)
Visual C++
public:
void Add(
    Processor^ processor
)

Parameters

processor
Type: Sitecore.Pipelines..::..Processor
The processor.

See Also

Pipeline Class
Sitecore.Pipelines Namespace


AddAt Method

[image]

Sitecore 6.4.1 API
Pipeline..::..AddAt Method
Pipeline Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddAt(
    int index,
    Processor processor
)
Visual Basic
Public Sub AddAt ( _
    index As Integer, _
    processor As Processor _
)
Visual C++
public:
void AddAt(
    int index,
    Processor^ processor
)

Parameters

index
Type: System..::..Int32
The index.
processor
Type: Sitecore.Pipelines..::..Processor
The processor.

See Also

Pipeline Class
Sitecore.Pipelines Namespace


GetObjectData Method

[image]

Sitecore 6.4.1 API
Pipeline..::..GetObjectData Method
Pipeline Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System.Security..::..SecurityException | The caller does not have the required permission.

See Also

Pipeline Class
Sitecore.Pipelines Namespace


GetProcessorByName Method

[image]

Sitecore 6.4.1 API
Pipeline..::..GetProcessorByName Method
Pipeline Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Processor GetProcessorByName(
    string name
)
Visual Basic
Public Function GetProcessorByName ( _
    name As String _
) As Processor
Visual C++
public:
Processor^ GetProcessorByName(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

Return Value

The Processor.

See Also

Pipeline Class
Sitecore.Pipelines Namespace


Remove Method

[image]

Sitecore 6.4.1 API
Pipeline..::..Remove Method
Pipeline Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Remove(
    Processor processor
)
Visual Basic
Public Sub Remove ( _
    processor As Processor _
)
Visual C++
public:
void Remove(
    Processor^ processor
)

Parameters

processor
Type: Sitecore.Pipelines..::..Processor
The processor.

See Also

Pipeline Class
Sitecore.Pipelines Namespace


Resume Method

[image]

Sitecore 6.4.1 API
Pipeline..::..Resume Method
Pipeline Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Resume()
Visual Basic
Public Sub Resume
Visual C++
public:
void Resume()

See Also

Pipeline Class
Sitecore.Pipelines Namespace


Start Method

[image] [image]

Sitecore 6.4.1 API
Pipeline..::..Start Method
Pipeline Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Start(PipelineArgs) | Starts the pipeline using the specified argumentss.
 | Start(String, PipelineArgs) | Starts the pipeline with the specified name.
 | Start(Item, PipelineArgs) | Starts the pipeline with the specified owner item.
Public method | Start(PipelineArgs, Boolean) | Starts the pipeline using the specified argumentss.
 | Start(String, PipelineArgs, Boolean) | Starts the pipeline with the specified name.
 | Start(Item, PipelineArgs, Boolean) | Starts the pipeline with the specified owner item.

See Also

Pipeline Class
Pipeline Members
Sitecore.Pipelines Namespace


Start Method (PipelineArgs)

[image]

Sitecore 6.4.1 API
Pipeline..::..Start Method (PipelineArgs)
Pipeline Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Start(
    PipelineArgs args
)
Visual Basic
Public Sub Start ( _
    args As PipelineArgs _
)
Visual C++
public:
void Start(
    PipelineArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines..::..PipelineArgs
The arguments.

See Also

Pipeline Class
Start Overload
Sitecore.Pipelines Namespace


Start Method (String, PipelineArgs)

[image]

Sitecore 6.4.1 API
Pipeline..::..Start Method (String, PipelineArgs)
Pipeline Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Pipeline Start(
    string pipelineName,
    PipelineArgs args
)
Visual Basic
Public Shared Function Start ( _
    pipelineName As String, _
    args As PipelineArgs _
) As Pipeline
Visual C++
public:
static Pipeline^ Start(
    String^ pipelineName,
    PipelineArgs^ args
)

Parameters

pipelineName
Type: System..::..String
Name of the pipeline.
args
Type: Sitecore.Pipelines..::..PipelineArgs
The arguments.

Return Value

The Pipeline.

See Also

Pipeline Class
Start Overload
Sitecore.Pipelines Namespace


Start Method (Item, PipelineArgs)

[image]

Sitecore 6.4.1 API
Pipeline..::..Start Method (Item, PipelineArgs)
Pipeline Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Pipeline Start(
    Item ownerItem,
    PipelineArgs args
)
Visual Basic
Public Shared Function Start ( _
    ownerItem As Item, _
    args As PipelineArgs _
) As Pipeline
Visual C++
public:
static Pipeline^ Start(
    Item^ ownerItem,
    PipelineArgs^ args
)

Parameters

ownerItem
Type: Sitecore.Data.Items..::..Item
The owner item.
args
Type: Sitecore.Pipelines..::..PipelineArgs
The arguments.

Return Value

The Pipeline.

See Also

Pipeline Class
Start Overload
Sitecore.Pipelines Namespace


Start Method (PipelineArgs, Boolean)

[image]

Sitecore 6.4.1 API
Pipeline..::..Start Method (PipelineArgs, Boolean)
Pipeline Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Start(
    PipelineArgs args,
    bool atomic
)
Visual Basic
Public Sub Start ( _
    args As PipelineArgs, _
    atomic As Boolean _
)
Visual C++
public:
void Start(
    PipelineArgs^ args,
    bool atomic
)

Parameters

args
Type: Sitecore.Pipelines..::..PipelineArgs
The arguments.
atomic
Type: System..::..Boolean
if set to true this instance is atomic.

See Also

Pipeline Class
Start Overload
Sitecore.Pipelines Namespace


Start Method (String, PipelineArgs, Boolean)

[image]

Sitecore 6.4.1 API
Pipeline..::..Start Method (String, PipelineArgs, Boolean)
Pipeline Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Pipeline Start(
    string pipelineName,
    PipelineArgs args,
    bool atomic
)
Visual Basic
Public Shared Function Start ( _
    pipelineName As String, _
    args As PipelineArgs, _
    atomic As Boolean _
) As Pipeline
Visual C++
public:
static Pipeline^ Start(
    String^ pipelineName,
    PipelineArgs^ args,
    bool atomic
)

Parameters

pipelineName
Type: System..::..String
Name of the pipeline.
args
Type: Sitecore.Pipelines..::..PipelineArgs
The arguments.
atomic
Type: System..::..Boolean
if set to true this instance is atomic.

Return Value

The Pipeline.

See Also

Pipeline Class
Start Overload
Sitecore.Pipelines Namespace


Start Method (Item, PipelineArgs, Boolean)

[image]

Sitecore 6.4.1 API
Pipeline..::..Start Method (Item, PipelineArgs, Boolean)
Pipeline Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Pipeline Start(
    Item ownerItem,
    PipelineArgs args,
    bool atomic
)
Visual Basic
Public Shared Function Start ( _
    ownerItem As Item, _
    args As PipelineArgs, _
    atomic As Boolean _
) As Pipeline
Visual C++
public:
static Pipeline^ Start(
    Item^ ownerItem,
    PipelineArgs^ args,
    bool atomic
)

Parameters

ownerItem
Type: Sitecore.Data.Items..::..Item
The owner item.
args
Type: Sitecore.Pipelines..::..PipelineArgs
The arguments.
atomic
Type: System..::..Boolean
if set to true this instance is atomic.

Return Value

The Pipeline.

See Also

Pipeline Class
Start Overload
Sitecore.Pipelines Namespace


Pipeline Properties

[image] [image]

Sitecore 6.4.1 API
Pipeline Properties
Pipeline Class See Also Send Feedback

The Pipeline type exposes the following members.

Properties

 | Name | Description
Public property | Args | Gets the arguments.
Public property | CurrentProcessor | Gets or sets the current processor.
Public property | ID | Gets or sets the ID.
Public property | Name | Gets the name.
Public property | NextProcessor | Gets or sets the next processor.
Public property | Processors | Gets the processors.

See Also

Pipeline Class
Sitecore.Pipelines Namespace


Args Property

[image]

Sitecore 6.4.1 API
Pipeline..::..Args Property
Pipeline Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PipelineArgs Args { get; }
Visual Basic
Public ReadOnly Property Args As PipelineArgs
    Get
Visual C++
public:
property PipelineArgs^ Args {
    PipelineArgs^ get ();
}

Field Value

The arguments.

See Also

Pipeline Class
Sitecore.Pipelines Namespace


CurrentProcessor Property

[image]

Sitecore 6.4.1 API
Pipeline..::..CurrentProcessor Property
Pipeline Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Processor CurrentProcessor { get; set; }
Visual Basic
Public Property CurrentProcessor As Processor
    Get
    Set
Visual C++
public:
property Processor^ CurrentProcessor {
    Processor^ get ();
    void set (Processor^ value);
}

Field Value

The current processor.

See Also

Pipeline Class
Sitecore.Pipelines Namespace


ID Property

[image]

Sitecore 6.4.1 API
Pipeline..::..ID Property
Pipeline Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ID { get; set; }
Visual Basic
Public Property ID As String
    Get
    Set
Visual C++
public:
property String^ ID {
    String^ get ();
    void set (String^ value);
}

Field Value

The ID.

See Also

Pipeline Class
Sitecore.Pipelines Namespace


Name Property

[image]

Sitecore 6.4.1 API
Pipeline..::..Name Property
Pipeline Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

Pipeline Class
Sitecore.Pipelines Namespace


Processors Property

[image]

Sitecore 6.4.1 API
Pipeline..::..Processors Property
Pipeline Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IList Processors { get; }
Visual Basic
Public ReadOnly Property Processors As IList
    Get
Visual C++
public:
property IList^ Processors {
    IList^ get ();
}

Field Value

The processors.

See Also

Pipeline Class
Sitecore.Pipelines Namespace


Pipeline.PipelineType Enumeration

[image]

Sitecore 6.4.1 API
Pipeline..::..PipelineType Enumeration
Pipeline Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum PipelineType
Visual Basic
Public Enumeration PipelineType
Visual C++
public enum class PipelineType

Members

Member name | Value | Description
Unknown | 0 | Unknown.
Predefined | 1 | Predefined.
ItemBased | 2 | Item based.
Dynamic | 3 | Dynamic.

See Also

Sitecore.Pipelines Namespace


PipelineArgs Class

[image]

Sitecore 6.4.1 API
PipelineArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class PipelineArgs : EventArgs,
    ISerializable
Visual Basic
<SerializableAttribute> _
Public Class PipelineArgs _
    Inherits EventArgs _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class PipelineArgs : public EventArgs,
    ISerializable

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Analytics.Pipelines.CreateSession..::..CreateSessionArgs
Sitecore.Analytics.Pipelines.EvaluateConditionals..::..EvaluateConditionalsArgs
Sitecore.Analytics.Pipelines.ExcludeRobots..::..ExcludeRobotsArgs
Sitecore.Analytics.Pipelines.ParseReferrer..::..ParseReferrerArgs
Sitecore.Analytics.Pipelines.RenderingConditions..::..RenderingConditionArgs
Sitecore.Analytics.Pipelines.StartTracking..::..StartTrackingArgs
Sitecore.Analytics.Pipelines.Submit..::..SubmitArgs
Sitecore.Analytics.Pipelines.SubmitPage..::..SubmitPageArgs
Sitecore.Analytics.Pipelines.SubmitTests..::..SubmitTestsArgs
Sitecore.Jobs..::..JobArgs
Sitecore.Pipelines.Attach..::..AttachArgs
Sitecore.Pipelines.ConvertToDesignTimeHtml..::..ConvertToDesignTimeHtmlArgs
Sitecore.Pipelines.ConvertToRuntimeHtml..::..ConvertToRuntimeHtmlArgs
Sitecore.Pipelines.ExpandBranchItemName..::..ExpandBranchItemNameArgs
Sitecore.Pipelines.ExpandInitialFieldValue..::..ExpandInitialFieldValueArgs
Sitecore.Pipelines.FilterItem..::..FilterItemPipelineArgs
Sitecore.Pipelines.FixXHtml..::..FixXHtmlArgs
Sitecore.Pipelines.GetAboutInformation..::..GetAboutInformationArgs
Sitecore.Pipelines.GetChromeData..::..GetChromeDataArgs
Sitecore.Pipelines.GetContentEditorWarnings..::..GetContentEditorWarningsArgs
Sitecore.Pipelines.GetLookupSourceItems..::..GetLookupSourceItemsArgs
Sitecore.Pipelines.GetLookupSourceItems..::..ProcessDefaultSource
Sitecore.Pipelines.GetMediaCreatorOptions..::..GetMediaCreatorOptionsArgs
Sitecore.Pipelines.GetPlaceholderRenderings..::..GetPlaceholderRenderingsArgs
Sitecore.Pipelines.GetQueryState..::..GetQueryStateArgs
Sitecore.Pipelines.GetRenderingDatasource..::..GetRenderingDatasourceArgs
Sitecore.Pipelines.GetRenderingPreview..::..GetRenderingPreviewArgs
Sitecore.Pipelines.GetSyndicationWarnings..::..GetSyndicationWarningsArgs
Sitecore.Pipelines.HttpRequest..::..HttpRequestArgs
Sitecore.Pipelines.InsertRenderings..::..InsertRenderingsArgs
Sitecore.Pipelines.LoggedIn..::..LoggedInArgs
Sitecore.Pipelines.LoggingIn..::..LoggingInArgs
Sitecore.Pipelines.Login..::..LoginArgs
Sitecore.Pipelines.ParseDocx..::..ParseDocxArgs
Sitecore.Pipelines.PreprocessRequest..::..PreprocessRequestArgs
Sitecore.Pipelines.RenderDocx..::..RenderDocxArgs
Sitecore.Pipelines.RenderField..::..RenderFieldArgs
Sitecore.Pipelines.RenderItemTile..::..RenderItemTileArgs
Sitecore.Pipelines.RenderLayout..::..RenderLayoutArgs
Sitecore.Pipelines.Search..::..SearchArgs
Sitecore.Pipelines.SessionEnd..::..SessionEndArgs
Sitecore.Pipelines.SetupEditFrame..::..SetupEditFrameArgs
Sitecore.Pipelines.WebDAV..::..WebDAVPipelineArgs<(Of <(<'T>)>)>
Sitecore.Publishing.Pipelines.Publish..::..PublishContext
Sitecore.Publishing.Pipelines.PublishItem..::..PublishItemContext
Sitecore.Resources.Media..::..GetMediaStreamPipelineArgs
Sitecore.Shell.Controls.RichTextEditor.Pipelines.LoadRichTextContent..::..LoadRichTextContentArgs
Sitecore.Shell.Controls.RichTextEditor.Pipelines.SaveRichTextContent..::..SaveRichTextContentArgs
Sitecore.Web.UI.Sheer..::..ClientPipelineArgs
Sitecore.Workflows.Simple..::..WorkflowPipelineArgs

See Also

PipelineArgs Members
Sitecore.Pipelines Namespace


PipelineArgs Members

[image] [image]

Sitecore 6.4.1 API
PipelineArgs Members
PipelineArgs Class Constructors Methods Properties See Also Send Feedback

The PipelineArgs type exposes the following members.

Constructors

 | Name | Description
Public method | PipelineArgs()()()() | Initializes a new instance of the PipelineArgs class.
Protected method | PipelineArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the PipelineArgs class from a serialization context.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline.
Public method | AbortPipeline | Aborts this pipeline.
Public method | AddMessage(String) | Adds the message.
Public method | AddMessage(String, PipelineMessageType) | Adds the message.
Protected method | Dispose | Disposes this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages.
Public method | GetMessages(PipelineMessageFilter) | Gets the messages.
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done.
Protected method | Resume | Resumes a processor.
Public method | Suspend()()()() | Suspends this instance.
Public method | Suspend(Boolean) | Suspends the specified resume last processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted.
Public property | CustomData | Gets the custom data.
Public property | Data | Obsolete. Gets or sets the data.
Public property | Message | Gets the message.
Public property | ProcessorItem | Gets or sets the processor item.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended.

See Also

PipelineArgs Class
Sitecore.Pipelines Namespace


PipelineArgs Constructor

[image] [image]

Sitecore 6.4.1 API
PipelineArgs Constructor
PipelineArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PipelineArgs()()()() | Initializes a new instance of the PipelineArgs class.
Protected method | PipelineArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the PipelineArgs class from a serialization context.

See Also

PipelineArgs Class
PipelineArgs Members
Sitecore.Pipelines Namespace


PipelineArgs Constructor

[image]

Sitecore 6.4.1 API
PipelineArgs Constructor
PipelineArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PipelineArgs()
Visual Basic
Public Sub New
Visual C++
public:
PipelineArgs()

See Also

PipelineArgs Class
PipelineArgs Overload
Sitecore.Pipelines Namespace


PipelineArgs Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
PipelineArgs Constructor (SerializationInfo, StreamingContext)
PipelineArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected PipelineArgs(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
PipelineArgs(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The serialized data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

PipelineArgs Class
PipelineArgs Overload
Sitecore.Pipelines Namespace


PipelineArgs Methods

[image] [image]

Sitecore 6.4.1 API
PipelineArgs Methods
PipelineArgs Class See Also Send Feedback

The PipelineArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline.
Public method | AbortPipeline | Aborts this pipeline.
Public method | AddMessage(String) | Adds the message.
Public method | AddMessage(String, PipelineMessageType) | Adds the message.
Protected method | Dispose | Disposes this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages.
Public method | GetMessages(PipelineMessageFilter) | Gets the messages.
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done.
Protected method | Resume | Resumes a processor.
Public method | Suspend()()()() | Suspends this instance.
Public method | Suspend(Boolean) | Suspends the specified resume last processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PipelineArgs Class
Sitecore.Pipelines Namespace


Abort Method

[image]

Sitecore 6.4.1 API
PipelineArgs..::..Abort Method
PipelineArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated - Use AbortPipeline instead.")]
public void Abort()
Visual Basic
<ObsoleteAttribute("Deprecated - Use AbortPipeline instead.")> _
Public Sub Abort
Visual C++
[ObsoleteAttribute(L"Deprecated - Use AbortPipeline instead.")]
public:
void Abort()

See Also

PipelineArgs Class
Sitecore.Pipelines Namespace


AbortPipeline Method

[image]

Sitecore 6.4.1 API
PipelineArgs..::..AbortPipeline Method
PipelineArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AbortPipeline()
Visual Basic
Public Sub AbortPipeline
Visual C++
public:
void AbortPipeline()

See Also

PipelineArgs Class
Sitecore.Pipelines Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
PipelineArgs..::..AddMessage Method
PipelineArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message.
Public method | AddMessage(String, PipelineMessageType) | Adds the message.

See Also

PipelineArgs Class
PipelineArgs Members
Sitecore.Pipelines Namespace


AddMessage Method (String)

[image]

Sitecore 6.4.1 API
PipelineArgs..::..AddMessage Method (String)
PipelineArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PipelineMessage AddMessage(
    string text
)
Visual Basic
Public Function AddMessage ( _
    text As String _
) As PipelineMessage
Visual C++
public:
PipelineMessage^ AddMessage(
    String^ text
)

Parameters

text
Type: System..::..String
The text.

Return Value

[Missing <returns> documentation for "M:Sitecore.Pipelines.PipelineArgs.AddMessage(System.String)"]

Exceptions

Exception | Condition
System..::..NotSupportedException |

See Also

PipelineArgs Class
AddMessage Overload
Sitecore.Pipelines Namespace


AddMessage Method (String, PipelineMessageType)

[image]

Sitecore 6.4.1 API
PipelineArgs..::..AddMessage Method (String, PipelineMessageType)
PipelineArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PipelineMessage AddMessage(
    string text,
    PipelineMessageType type
)
Visual Basic
Public Function AddMessage ( _
    text As String, _
    type As PipelineMessageType _
) As PipelineMessage
Visual C++
public:
PipelineMessage^ AddMessage(
    String^ text,
    PipelineMessageType type
)

Parameters

text
Type: System..::..String
The text.
type
Type: Sitecore.Pipelines..::..PipelineMessageType
The type.

Return Value

The message.

Exceptions

Exception | Condition
System..::..NotSupportedException |

See Also

PipelineArgs Class
AddMessage Overload
Sitecore.Pipelines Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
PipelineArgs..::..GetMessages Method
PipelineArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages.
Public method | GetMessages(PipelineMessageFilter) | Gets the messages.

See Also

PipelineArgs Class
PipelineArgs Members
Sitecore.Pipelines Namespace


GetMessages Method

[image]

Sitecore 6.4.1 API
PipelineArgs..::..GetMessages Method
PipelineArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PipelineMessage[] GetMessages()
Visual Basic
Public Function GetMessages As PipelineMessage()
Visual C++
public:
array<PipelineMessage^>^ GetMessages()

Return Value

The messages.

See Also

PipelineArgs Class
GetMessages Overload
Sitecore.Pipelines Namespace


GetMessages Method (PipelineMessageFilter)

[image]

Sitecore 6.4.1 API
PipelineArgs..::..GetMessages Method (PipelineMessageFilter)
PipelineArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PipelineMessage[] GetMessages(
    PipelineMessageFilter filter
)
Visual Basic
Public Function GetMessages ( _
    filter As PipelineMessageFilter _
) As PipelineMessage()
Visual C++
public:
array<PipelineMessage^>^ GetMessages(
    PipelineMessageFilter filter
)

Parameters

filter
Type: Sitecore.Pipelines..::..PipelineMessageFilter
The filter.

Return Value

[Missing <returns> documentation for "M:Sitecore.Pipelines.PipelineArgs.GetMessages(Sitecore.Pipelines.PipelineMessageFilter)"]

Exceptions

Exception | Condition
System..::..ArgumentNullException |
System..::..InvalidCastException |

See Also

PipelineArgs Class
GetMessages Overload
Sitecore.Pipelines Namespace


GetObjectData Method

[image]

Sitecore 6.4.1 API
PipelineArgs..::..GetObjectData Method
PipelineArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System.Security..::..SecurityException | The caller does not have the required permission.

See Also

PipelineArgs Class
Sitecore.Pipelines Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
PipelineArgs..::..Initialize Method
PipelineArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected internal virtual void Initialize()
Visual Basic
Protected Friend Overridable Sub Initialize
Visual C++
protected public:
virtual void Initialize()

See Also

PipelineArgs Class
Sitecore.Pipelines Namespace


ProcessorDone Method

[image]

Sitecore 6.4.1 API
PipelineArgs..::..ProcessorDone Method
PipelineArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected internal virtual void ProcessorDone()
Visual Basic
Protected Friend Overridable Sub ProcessorDone
Visual C++
protected public:
virtual void ProcessorDone()

See Also

PipelineArgs Class
Sitecore.Pipelines Namespace


Resume Method

[image]

Sitecore 6.4.1 API
PipelineArgs..::..Resume Method
PipelineArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected internal virtual void Resume()
Visual Basic
Protected Friend Overridable Sub Resume
Visual C++
protected public:
virtual void Resume()

See Also

PipelineArgs Class
Sitecore.Pipelines Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
PipelineArgs..::..Suspend Method
PipelineArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance.
Public method | Suspend(Boolean) | Suspends the specified resume last processor.

See Also

PipelineArgs Class
PipelineArgs Members
Sitecore.Pipelines Namespace


Suspend Method

[image]

Sitecore 6.4.1 API
PipelineArgs..::..Suspend Method
PipelineArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Suspend()
Visual Basic
Public Sub Suspend
Visual C++
public:
void Suspend()

See Also

PipelineArgs Class
Suspend Overload
Sitecore.Pipelines Namespace


Suspend Method (Boolean)

[image]

Sitecore 6.4.1 API
PipelineArgs..::..Suspend Method (Boolean)
PipelineArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Suspend(
    bool resumeLastProcessor
)
Visual Basic
Public Sub Suspend ( _
    resumeLastProcessor As Boolean _
)
Visual C++
public:
void Suspend(
    bool resumeLastProcessor
)

Parameters

resumeLastProcessor
Type: System..::..Boolean
if set to true this instance is resume last processor.

See Also

PipelineArgs Class
Suspend Overload
Sitecore.Pipelines Namespace


PipelineArgs Properties

[image] [image]

Sitecore 6.4.1 API
PipelineArgs Properties
PipelineArgs Class See Also Send Feedback

The PipelineArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted.
Public property | CustomData | Gets the custom data.
Public property | Data | Obsolete. Gets or sets the data.
Public property | Message | Gets the message.
Public property | ProcessorItem | Gets or sets the processor item.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended.

See Also

PipelineArgs Class
Sitecore.Pipelines Namespace


Aborted Property

[image]

Sitecore 6.4.1 API
PipelineArgs..::..Aborted Property
PipelineArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Aborted { get; }
Visual Basic
Public ReadOnly Property Aborted As Boolean
    Get
Visual C++
public:
property bool Aborted {
    bool get ();
}

Field Value

true if aborted; otherwise, false.

See Also

PipelineArgs Class
Sitecore.Pipelines Namespace


CustomData Property

[image]

Sitecore 6.4.1 API
PipelineArgs..::..CustomData Property
PipelineArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SafeDictionary<string, Object> CustomData { get; }
Visual Basic
Public ReadOnly Property CustomData As SafeDictionary(Of String, Object)
    Get
Visual C++
public:
property SafeDictionary<String^, Object^>^ CustomData {
    SafeDictionary<String^, Object^>^ get ();
}

Field Value

The custom data.

See Also

PipelineArgs Class
Sitecore.Pipelines Namespace


Data Property

[image]

Sitecore 6.4.1 API
PipelineArgs..::..Data Property
PipelineArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("The Data property has been deprecated.")]
public Object Data { get; set; }
Visual Basic
<ObsoleteAttribute("The Data property has been deprecated.")> _
Public Property Data As Object
    Get
    Set
Visual C++
[ObsoleteAttribute(L"The Data property has been deprecated.")]
public:
property Object^ Data {
    Object^ get ();
    void set (Object^ value);
}

Field Value

The data.

See Also

PipelineArgs Class
Sitecore.Pipelines Namespace


Message Property

[image]

Sitecore 6.4.1 API
PipelineArgs..::..Message Property
PipelineArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Message { get; }
Visual Basic
Public ReadOnly Property Message As String
    Get
Visual C++
public:
property String^ Message {
    String^ get ();
}

Field Value

The message.

See Also

PipelineArgs Class
Sitecore.Pipelines Namespace


ProcessorItem Property

[image]

Sitecore 6.4.1 API
PipelineArgs..::..ProcessorItem Property
PipelineArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ProcessorItem ProcessorItem { get; set; }
Visual Basic
Public Property ProcessorItem As ProcessorItem
    Get
    Set
Visual C++
public:
property ProcessorItem^ ProcessorItem {
    ProcessorItem^ get ();
    void set (ProcessorItem^ value);
}

Field Value

The processor item.

See Also

PipelineArgs Class
Sitecore.Pipelines Namespace


Suspended Property

[image]

Sitecore 6.4.1 API
PipelineArgs..::..Suspended Property
PipelineArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Suspended { get; }
Visual Basic
Public ReadOnly Property Suspended As Boolean
    Get
Visual C++
public:
property bool Suspended {
    bool get ();
}

Field Value

true if suspended; otherwise, false.

See Also

PipelineArgs Class
Sitecore.Pipelines Namespace


PipelineFactory Class

[image]

Sitecore 6.4.1 API
PipelineFactory Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class PipelineFactory
Visual Basic
Public NotInheritable Class PipelineFactory
Visual C++
public ref class PipelineFactory abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines..::..PipelineFactory

See Also

PipelineFactory Members
Sitecore.Pipelines Namespace


PipelineFactory Members

[image] [image]

Sitecore 6.4.1 API
PipelineFactory Members
PipelineFactory Class Methods Properties See Also Send Feedback

The PipelineFactory type exposes the following members.

Methods

Name | Description
CreatePipeline | Creates the pipeline.
GetPipeline(String) | Gets the pipeline.
GetPipeline(Item) | Gets the pipeline.
GetProcessors | Gets the processors of a specific type.
GetSuspendedPipeline | Gets the suspended pipeline.
GetSuspendedPipelines | Gets the suspended pipelines.

Properties

Name | Description
UseCaching | Get processors of a specific type

See Also

PipelineFactory Class
Sitecore.Pipelines Namespace


PipelineFactory Methods

[image] [image]

Sitecore 6.4.1 API
PipelineFactory Methods
PipelineFactory Class See Also Send Feedback

The PipelineFactory type exposes the following members.

Methods

Name | Description
CreatePipeline | Creates the pipeline.
GetPipeline(String) | Gets the pipeline.
GetPipeline(Item) | Gets the pipeline.
GetProcessors | Gets the processors of a specific type.
GetSuspendedPipeline | Gets the suspended pipeline.
GetSuspendedPipelines | Gets the suspended pipelines.

See Also

PipelineFactory Class
Sitecore.Pipelines Namespace


CreatePipeline Method

[image]

Sitecore 6.4.1 API
PipelineFactory..::..CreatePipeline Method
PipelineFactory Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Pipeline CreatePipeline(
    string pipelineName
)
Visual Basic
Public Shared Function CreatePipeline ( _
    pipelineName As String _
) As Pipeline
Visual C++
public:
static Pipeline^ CreatePipeline(
    String^ pipelineName
)

Parameters

pipelineName
Type: System..::..String
Name of the pipeline.

Return Value

The pipeline.

See Also

PipelineFactory Class
Sitecore.Pipelines Namespace


GetPipeline Method

[image] [image]

Sitecore 6.4.1 API
PipelineFactory..::..GetPipeline Method
PipelineFactory Class See Also Send Feedback

Overload List

Name | Description
GetPipeline(String) | Gets the pipeline.
GetPipeline(Item) | Gets the pipeline.

See Also

PipelineFactory Class
PipelineFactory Members
Sitecore.Pipelines Namespace


GetPipeline Method (String)

[image]

Sitecore 6.4.1 API
PipelineFactory..::..GetPipeline Method (String)
PipelineFactory Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Pipeline GetPipeline(
    string pipelineName
)
Visual Basic
Public Shared Function GetPipeline ( _
    pipelineName As String _
) As Pipeline
Visual C++
public:
static Pipeline^ GetPipeline(
    String^ pipelineName
)

Parameters

pipelineName
Type: System..::..String
Name of the pipeline.

Return Value

The pipeline.

See Also

PipelineFactory Class
GetPipeline Overload
Sitecore.Pipelines Namespace


GetPipeline Method (Item)

[image]

Sitecore 6.4.1 API
PipelineFactory..::..GetPipeline Method (Item)
PipelineFactory Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Pipeline GetPipeline(
    Item ownerItem
)
Visual Basic
Public Shared Function GetPipeline ( _
    ownerItem As Item _
) As Pipeline
Visual C++
public:
static Pipeline^ GetPipeline(
    Item^ ownerItem
)

Parameters

ownerItem
Type: Sitecore.Data.Items..::..Item
The owner item.

Return Value

The pipeline.

See Also

PipelineFactory Class
GetPipeline Overload
Sitecore.Pipelines Namespace


GetProcessors Method

[image]

Sitecore 6.4.1 API
PipelineFactory..::..GetProcessors Method
PipelineFactory Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ArrayList GetProcessors(
    string pipelineName
)
Visual Basic
Public Shared Function GetProcessors ( _
    pipelineName As String _
) As ArrayList
Visual C++
public:
static ArrayList^ GetProcessors(
    String^ pipelineName
)

Parameters

pipelineName
Type: System..::..String
Name of the pipeline.

Return Value

The processors.

See Also

PipelineFactory Class
Sitecore.Pipelines Namespace


GetSuspendedPipeline Method

[image]

Sitecore 6.4.1 API
PipelineFactory..::..GetSuspendedPipeline Method
PipelineFactory Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Pipeline GetSuspendedPipeline(
    string pipelineID
)
Visual Basic
Public Shared Function GetSuspendedPipeline ( _
    pipelineID As String _
) As Pipeline
Visual C++
public:
static Pipeline^ GetSuspendedPipeline(
    String^ pipelineID
)

Parameters

pipelineID
Type: System..::..String
The pipeline ID.

Return Value

The suspended pipeline.

See Also

PipelineFactory Class
Sitecore.Pipelines Namespace


GetSuspendedPipelines Method

[image]

Sitecore 6.4.1 API
PipelineFactory..::..GetSuspendedPipelines Method
PipelineFactory Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Hashtable GetSuspendedPipelines()
Visual Basic
Public Shared Function GetSuspendedPipelines As Hashtable
Visual C++
public:
static Hashtable^ GetSuspendedPipelines()

Return Value

The suspended pipelines.

See Also

PipelineFactory Class
Sitecore.Pipelines Namespace


PipelineFactory Properties

[image] [image]

Sitecore 6.4.1 API
PipelineFactory Properties
PipelineFactory Class See Also Send Feedback

The PipelineFactory type exposes the following members.

Properties

Name | Description
UseCaching | Get processors of a specific type

See Also

PipelineFactory Class
Sitecore.Pipelines Namespace


UseCaching Property

[image]

Sitecore 6.4.1 API
PipelineFactory..::..UseCaching Property
PipelineFactory Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool UseCaching { get; set; }
Visual Basic
Public Shared Property UseCaching As Boolean
    Get
    Set
Visual C++
public:
static property bool UseCaching {
    bool get ();
    void set (bool value);
}

Field Value

true if the PipelineFactory uses the caching; otherwise, false.

See Also

PipelineFactory Class
Sitecore.Pipelines Namespace


PipelineGroup Class

[image]

Sitecore 6.4.1 API
PipelineGroup Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PipelineGroup
Visual Basic
Public Class PipelineGroup
Visual C++
public ref class PipelineGroup

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines..::..PipelineGroup

See Also

PipelineGroup Members
Sitecore.Pipelines Namespace


PipelineGroup Members

[image] [image]

Sitecore 6.4.1 API
PipelineGroup Members
PipelineGroup Class Constructors Methods Properties See Also Send Feedback

The PipelineGroup type exposes the following members.

Constructors

 | Name | Description
Public method | PipelineGroup | Initializes a new instance of the PipelineGroup class.

Methods

 | Name | Description
Public method | AddPipeline | Adds the pipeline.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPipeline | Gets the pipeline.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | Gets the name.

See Also

PipelineGroup Class
Sitecore.Pipelines Namespace


PipelineGroup Methods

[image] [image]

Sitecore 6.4.1 API
PipelineGroup Methods
PipelineGroup Class See Also Send Feedback

The PipelineGroup type exposes the following members.

Methods

 | Name | Description
Public method | AddPipeline | Adds the pipeline.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPipeline | Gets the pipeline.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PipelineGroup Class
Sitecore.Pipelines Namespace


AddPipeline Method

[image]

Sitecore 6.4.1 API
PipelineGroup..::..AddPipeline Method
PipelineGroup Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddPipeline(
    CorePipeline pipeline
)
Visual Basic
Public Sub AddPipeline ( _
    pipeline As CorePipeline _
)
Visual C++
public:
void AddPipeline(
    CorePipeline^ pipeline
)

Parameters

pipeline
Type: Sitecore.Pipelines..::..CorePipeline
The pipeline.

See Also

PipelineGroup Class
Sitecore.Pipelines Namespace


GetPipeline Method

[image]

Sitecore 6.4.1 API
PipelineGroup..::..GetPipeline Method
PipelineGroup Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CorePipeline GetPipeline(
    string name
)
Visual Basic
Public Function GetPipeline ( _
    name As String _
) As CorePipeline
Visual C++
public:
CorePipeline^ GetPipeline(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

Return Value

The pipeline.

See Also

PipelineGroup Class
Sitecore.Pipelines Namespace


PipelineGroup Properties

[image] [image]

Sitecore 6.4.1 API
PipelineGroup Properties
PipelineGroup Class See Also Send Feedback

The PipelineGroup type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the name.

See Also

PipelineGroup Class
Sitecore.Pipelines Namespace


Name Property

[image]

Sitecore 6.4.1 API
PipelineGroup..::..Name Property
PipelineGroup Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

PipelineGroup Class
Sitecore.Pipelines Namespace


PipelineMessage Class

[image]

Sitecore 6.4.1 API
PipelineMessage Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PipelineMessage
Visual Basic
Public Class PipelineMessage
Visual C++
public ref class PipelineMessage

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines..::..PipelineMessage

See Also

PipelineMessage Members
Sitecore.Pipelines Namespace


PipelineMessage Members

[image] [image]

Sitecore 6.4.1 API
PipelineMessage Members
PipelineMessage Class Constructors Methods Properties See Also Send Feedback

The PipelineMessage type exposes the following members.

Constructors

 | Name | Description
Public method | PipelineMessage | Initializes a new instance of the PipelineMessage class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsMatch | Determines whether the specified filter is matched.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Text | Gets the text.
Public property | Type | Gets the type.

See Also

PipelineMessage Class
Sitecore.Pipelines Namespace


PipelineMessage Constructor

[image]

Sitecore 6.4.1 API
PipelineMessage Constructor
PipelineMessage Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PipelineMessage(
    string text,
    PipelineMessageType type
)
Visual Basic
Public Sub New ( _
    text As String, _
    type As PipelineMessageType _
)
Visual C++
public:
PipelineMessage(
    String^ text,
    PipelineMessageType type
)

Parameters

text
Type: System..::..String
The text.
type
Type: Sitecore.Pipelines..::..PipelineMessageType
The type.

See Also

PipelineMessage Class
Sitecore.Pipelines Namespace


PipelineMessage Methods

[image] [image]

Sitecore 6.4.1 API
PipelineMessage Methods
PipelineMessage Class See Also Send Feedback

The PipelineMessage type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsMatch | Determines whether the specified filter is matched.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PipelineMessage Class
Sitecore.Pipelines Namespace


IsMatch Method

[image]

Sitecore 6.4.1 API
PipelineMessage..::..IsMatch Method
PipelineMessage Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsMatch(
    PipelineMessageFilter filter
)
Visual Basic
Public Function IsMatch ( _
    filter As PipelineMessageFilter _
) As Boolean
Visual C++
public:
bool IsMatch(
    PipelineMessageFilter filter
)

Parameters

filter
Type: Sitecore.Pipelines..::..PipelineMessageFilter
The filter.

Return Value

true if the specified filter is matched; otherwise, false.

See Also

PipelineMessage Class
Sitecore.Pipelines Namespace


PipelineMessage Properties

[image] [image]

Sitecore 6.4.1 API
PipelineMessage Properties
PipelineMessage Class See Also Send Feedback

The PipelineMessage type exposes the following members.

Properties

 | Name | Description
Public property | Text | Gets the text.
Public property | Type | Gets the type.

See Also

PipelineMessage Class
Sitecore.Pipelines Namespace


Text Property

[image]

Sitecore 6.4.1 API
PipelineMessage..::..Text Property
PipelineMessage Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Text { get; }
Visual Basic
Public ReadOnly Property Text As String
    Get
Visual C++
public:
property String^ Text {
    String^ get ();
}

Field Value

The text.

See Also

PipelineMessage Class
Sitecore.Pipelines Namespace


Type Property

[image]

Sitecore 6.4.1 API
PipelineMessage..::..Type Property
PipelineMessage Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PipelineMessageType Type { get; }
Visual Basic
Public ReadOnly Property Type As PipelineMessageType
    Get
Visual C++
public:
property PipelineMessageType Type {
    PipelineMessageType get ();
}

Field Value

The type.

See Also

PipelineMessage Class
Sitecore.Pipelines Namespace


PipelineMessageFilter Enumeration

[image]

Sitecore 6.4.1 API
PipelineMessageFilter Enumeration
See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[FlagsAttribute]
public enum PipelineMessageFilter
Visual Basic
<FlagsAttribute> _
Public Enumeration PipelineMessageFilter
Visual C++
[FlagsAttribute]
public enum class PipelineMessageFilter

Members

Member name | Value | Description
Informations | 1 | Informations.
Warnings | 2 | Warnings.
Errors | 4 | Errors.
All | 7 | All.

See Also

Sitecore.Pipelines Namespace


PipelineMessageType Enumeration

[image]

Sitecore 6.4.1 API
PipelineMessageType Enumeration
See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum PipelineMessageType
Visual Basic
Public Enumeration PipelineMessageType
Visual C++
public enum class PipelineMessageType

Members

Member name | Value | Description
Information | 1 | Information.
Warning | 2 | Warning.
Error | 4 | Error.

See Also

Sitecore.Pipelines Namespace


PipelineMethod Members

[image] [image]

Sitecore 6.4.1 API
PipelineMethod Members
PipelineMethod Class Constructors Methods See Also Send Feedback

The PipelineMethod type exposes the following members.

Constructors

 | Name | Description
Public method | PipelineMethod | Initializes a new instance of the PipelineMethod class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Invokes the method with the specified parameters.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PipelineMethod Class
Sitecore.Pipelines Namespace


PipelineMethod Constructor

[image]

Sitecore 6.4.1 API
PipelineMethod Constructor
PipelineMethod Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PipelineMethod(
    Object obj,
    MethodInfo method
)
Visual Basic
Public Sub New ( _
    obj As Object, _
    method As MethodInfo _
)
Visual C++
public:
PipelineMethod(
    Object^ obj,
    MethodInfo^ method
)

Parameters

obj
Type: System..::..Object
The object.
method
Type: System.Reflection..::..MethodInfo
The method.

See Also

PipelineMethod Class
Sitecore.Pipelines Namespace


PipelineMethod Methods

[image] [image]

Sitecore 6.4.1 API
PipelineMethod Methods
PipelineMethod Class See Also Send Feedback

The PipelineMethod type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Invokes the method with the specified parameters.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PipelineMethod Class
Sitecore.Pipelines Namespace


Invoke Method

[image]

Sitecore 6.4.1 API
PipelineMethod..::..Invoke Method
PipelineMethod Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Invoke(
    Object[] parameters
)
Visual Basic
Public Sub Invoke ( _
    parameters As Object() _
)
Visual C++
public:
void Invoke(
    array<Object^>^ parameters
)

Parameters

parameters
Type: array< System..::..Object >[]()[][]
The parameters.

See Also

PipelineMethod Class
Sitecore.Pipelines Namespace


Processor Class

[image]

Sitecore 6.4.1 API
Processor Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class Processor : ISerializable
Visual Basic
<SerializableAttribute> _
Public Class Processor _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class Processor : ISerializable

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines..::..Processor

See Also

Processor Members
Sitecore.Pipelines Namespace


Processor Members

[image] [image]

Sitecore 6.4.1 API
Processor Members
Processor Class Constructors Methods Properties See Also Send Feedback

The Processor type exposes the following members.

Constructors

 | Name | Description
Protected method | Processor(ProcessorItem) | Initializes a new instance of the Processor class.
Protected method | Processor(SerializationInfo, StreamingContext) | Initializes a new instance of the Processor class from a serialization context.
Protected method | Processor(String, String) | Initializes a new instance of the Processor class.
Public method | Processor(String, Object, String) | Initializes a new instance of the Processor class.
Public method | Processor(String, String, String) | Initializes a new instance of the Processor class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetObject | Gets the object.
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Invokes this processor with the specified arguments.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse(XmlNode) | Parses the specified node.
 | Parse(ProcessorItem) | Parses the specified item.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | Gets the item.
Public property | Name | Gets the name.

See Also

Processor Class
Sitecore.Pipelines Namespace


Processor Constructor

[image] [image]

Sitecore 6.4.1 API
Processor Constructor
Processor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Processor(ProcessorItem) | Initializes a new instance of the Processor class.
Protected method | Processor(SerializationInfo, StreamingContext) | Initializes a new instance of the Processor class from a serialization context.
Protected method | Processor(String, String) | Initializes a new instance of the Processor class.
Public method | Processor(String, Object, String) | Initializes a new instance of the Processor class.
Public method | Processor(String, String, String) | Initializes a new instance of the Processor class.

See Also

Processor Class
Processor Members
Sitecore.Pipelines Namespace


Processor Constructor (ProcessorItem)

[image]

Sitecore 6.4.1 API
Processor Constructor (ProcessorItem)
Processor Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Processor(
    ProcessorItem item
)
Visual Basic
Protected Sub New ( _
    item As ProcessorItem _
)
Visual C++
protected:
Processor(
    ProcessorItem^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..ProcessorItem
The item.

See Also

Processor Class
Processor Overload
Sitecore.Pipelines Namespace


Processor Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
Processor Constructor (SerializationInfo, StreamingContext)
Processor Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Processor(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
Processor(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The serialized data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

Processor Class
Processor Overload
Sitecore.Pipelines Namespace


Processor Constructor (String, String)

[image]

Sitecore 6.4.1 API
Processor Constructor (String, String)
Processor Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected Processor(
    string name,
    string methodName
)
Visual Basic
Protected Sub New ( _
    name As String, _
    methodName As String _
)
Visual C++
protected:
Processor(
    String^ name,
    String^ methodName
)

Parameters

name
Type: System..::..String
The name.
methodName
Type: System..::..String
Name of the method.

See Also

Processor Class
Processor Overload
Sitecore.Pipelines Namespace


Processor Constructor (String, Object, String)

[image]

Sitecore 6.4.1 API
Processor Constructor (String, Object, String)
Processor Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Processor(
    string name,
    Object obj,
    string methodName
)
Visual Basic
Public Sub New ( _
    name As String, _
    obj As Object, _
    methodName As String _
)
Visual C++
public:
Processor(
    String^ name,
    Object^ obj,
    String^ methodName
)

Parameters

name
Type: System..::..String
The name.
obj
Type: System..::..Object
The object.
methodName
Type: System..::..String
Name of the method.

See Also

Processor Class
Processor Overload
Sitecore.Pipelines Namespace


Processor Constructor (String, String, String)

[image]

Sitecore 6.4.1 API
Processor Constructor (String, String, String)
Processor Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Processor(
    string name,
    string type,
    string methodName
)
Visual Basic
Public Sub New ( _
    name As String, _
    type As String, _
    methodName As String _
)
Visual C++
public:
Processor(
    String^ name,
    String^ type,
    String^ methodName
)

Parameters

name
Type: System..::..String
The name.
type
Type: System..::..String
The type.
methodName
Type: System..::..String
Name of the method.

See Also

Processor Class
Processor Overload
Sitecore.Pipelines Namespace


Processor Methods

[image] [image]

Sitecore 6.4.1 API
Processor Methods
Processor Class See Also Send Feedback

The Processor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetObject | Gets the object.
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Invokes this processor with the specified arguments.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse(XmlNode) | Parses the specified node.
 | Parse(ProcessorItem) | Parses the specified item.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Processor Class
Sitecore.Pipelines Namespace


GetObject Method

[image]

Sitecore 6.4.1 API
Processor..::..GetObject Method
Processor Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual Object GetObject()
Visual Basic
Protected Overridable Function GetObject As Object
Visual C++
protected:
virtual Object^ GetObject()

Return Value

The object upon which the processor is run.

See Also

Processor Class
Sitecore.Pipelines Namespace


GetObjectData Method

[image]

Sitecore 6.4.1 API
Processor..::..GetObjectData Method
Processor Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System.Security..::..SecurityException | The caller does not have the required permission.

See Also

Processor Class
Sitecore.Pipelines Namespace


Invoke Method

[image]

Sitecore 6.4.1 API
Processor..::..Invoke Method
Processor Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Invoke(
    PipelineArgs args
)
Visual Basic
Public Overridable Sub Invoke ( _
    args As PipelineArgs _
)
Visual C++
public:
virtual void Invoke(
    PipelineArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines..::..PipelineArgs
The arguments.

See Also

Processor Class
Sitecore.Pipelines Namespace


Parse Method

[image] [image]

Sitecore 6.4.1 API
Processor..::..Parse Method
Processor Class See Also Send Feedback

Overload List

Name | Description
Parse(XmlNode) | Parses the specified node.
Parse(ProcessorItem) | Parses the specified item.

See Also

Processor Class
Processor Members
Sitecore.Pipelines Namespace


Parse Method (XmlNode)

[image]

Sitecore 6.4.1 API
Processor..::..Parse Method (XmlNode)
Processor Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Processor Parse(
    XmlNode node
)
Visual Basic
Public Shared Function Parse ( _
    node As XmlNode _
) As Processor
Visual C++
public:
static Processor^ Parse(
    XmlNode^ node
)

Parameters

node
Type: System.Xml..::..XmlNode
The node.

Return Value

[Missing <returns> documentation for "M:Sitecore.Pipelines.Processor.Parse(System.Xml.XmlNode)"]

See Also

Processor Class
Parse Overload
Sitecore.Pipelines Namespace


Parse Method (ProcessorItem)

[image]

Sitecore 6.4.1 API
Processor..::..Parse Method (ProcessorItem)
Processor Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Processor Parse(
    ProcessorItem item
)
Visual Basic
Public Shared Function Parse ( _
    item As ProcessorItem _
) As Processor
Visual C++
public:
static Processor^ Parse(
    ProcessorItem^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..ProcessorItem
The item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Pipelines.Processor.Parse(Sitecore.Data.Items.ProcessorItem)"]

See Also

Processor Class
Parse Overload
Sitecore.Pipelines Namespace


Processor Properties

[image] [image]

Sitecore 6.4.1 API
Processor Properties
Processor Class See Also Send Feedback

The Processor type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets the item.
Public property | Name | Gets the name.

See Also

Processor Class
Sitecore.Pipelines Namespace


Item Property

[image]

Sitecore 6.4.1 API
Processor..::..Item Property
Processor Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ProcessorItem Item { get; }
Visual Basic
Public Overridable ReadOnly Property Item As ProcessorItem
    Get
Visual C++
public:
virtual property ProcessorItem^ Item {
    ProcessorItem^ get ();
}

Field Value

The item.

See Also

Processor Class
Sitecore.Pipelines Namespace


Name Property

[image]

Sitecore 6.4.1 API
Processor..::..Name Property
Processor Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

Processor Class
Sitecore.Pipelines Namespace


ProcessorObject Class

[image]

Sitecore 6.4.1 API
ProcessorObject Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ProcessorObject
Visual Basic
Public Class ProcessorObject
Visual C++
public ref class ProcessorObject

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines..::..ProcessorObject

See Also

ProcessorObject Members
Sitecore.Pipelines Namespace


ProcessorObject Members

[image] [image]

Sitecore 6.4.1 API
ProcessorObject Members
ProcessorObject Class Constructors Methods Properties See Also Send Feedback

The ProcessorObject type exposes the following members.

Constructors

 | Name | Description
Public method | ProcessorObject | Initializes a new instance of the ProcessorObject class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Object | Gets the object.
Public property | Scope | Gets the scope.

See Also

ProcessorObject Class
Sitecore.Pipelines Namespace


ProcessorObject Constructor

[image]

Sitecore 6.4.1 API
ProcessorObject Constructor
ProcessorObject Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ProcessorObject(
    Object obj,
    ObjectScope scope
)
Visual Basic
Public Sub New ( _
    obj As Object, _
    scope As ObjectScope _
)
Visual C++
public:
ProcessorObject(
    Object^ obj,
    ObjectScope scope
)

Parameters

obj
Type: System..::..Object
The object.
scope
Type: Sitecore.Pipelines..::..ObjectScope
The scope.

See Also

ProcessorObject Class
Sitecore.Pipelines Namespace


ProcessorObject Methods

[image] [image]

Sitecore 6.4.1 API
ProcessorObject Methods
ProcessorObject Class See Also Send Feedback

The ProcessorObject type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProcessorObject Class
Sitecore.Pipelines Namespace


ProcessorObject Properties

[image] [image]

Sitecore 6.4.1 API
ProcessorObject Properties
ProcessorObject Class See Also Send Feedback

The ProcessorObject type exposes the following members.

Properties

 | Name | Description
Public property | Object | Gets the object.
Public property | Scope | Gets the scope.

See Also

ProcessorObject Class
Sitecore.Pipelines Namespace


Object Property

[image]

Sitecore 6.4.1 API
ProcessorObject..::..Object Property
ProcessorObject Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object Object { get; }
Visual Basic
Public ReadOnly Property Object As Object
    Get
Visual C++
public:
property Object^ Object {
    Object^ get ();
}

Field Value

The object.

See Also

ProcessorObject Class
Sitecore.Pipelines Namespace


Scope Property

[image]

Sitecore 6.4.1 API
ProcessorObject..::..Scope Property
ProcessorObject Class See Also Send Feedback

Namespace: Sitecore.Pipelines
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ObjectScope Scope { get; }
Visual Basic
Public ReadOnly Property Scope As ObjectScope
    Get
Visual C++
public:
property ObjectScope Scope {
    ObjectScope get ();
}

Field Value

The scope.

See Also

ProcessorObject Class
Sitecore.Pipelines Namespace


Sitecore.Pipelines.Attach Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.Attach Namespace
Send Feedback

Classes

 | Class | Description
Public class | AttachArgs | Argument class for "attach" pipeline
Public class | CheckSize | CheckSize class
Public class | Save | Processor that is responsable for saving media stream
Public class | UpdatePath | UpdatePath class


AttachArgs Members

[image] [image]

Sitecore 6.4.1 API
AttachArgs Members
AttachArgs Class Constructors Methods Fields Properties See Also Send Feedback

The AttachArgs type exposes the following members.

Constructors

 | Name | Description
Public method | AttachArgs | Initializes a new instance of the AttachArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _file |
Protected field | _mediaItem |

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | File | Gets or sets the file.
Public property | MediaItem | Gets or sets the media item.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

AttachArgs Class
Sitecore.Pipelines.Attach Namespace


AttachArgs Constructor

[image]

Sitecore 6.4.1 API
AttachArgs Constructor
AttachArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Attach
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AttachArgs(
    HttpPostedFile file,
    MediaItem mediaItem
)
Visual Basic
Public Sub New ( _
    file As HttpPostedFile, _
    mediaItem As MediaItem _
)
Visual C++
public:
AttachArgs(
    HttpPostedFile^ file,
    MediaItem^ mediaItem
)

Parameters

file
Type: System.Web..::..HttpPostedFile
The file.
mediaItem
Type: Sitecore.Data.Items..::..MediaItem
The media item.

See Also

AttachArgs Class
Sitecore.Pipelines.Attach Namespace


AttachArgs Fields

[image] [image]

Sitecore 6.4.1 API
AttachArgs Fields
AttachArgs Class See Also Send Feedback

The AttachArgs type exposes the following members.

Fields

 | Name | Description
Protected field | _file |
Protected field | _mediaItem |

See Also

AttachArgs Class
Sitecore.Pipelines.Attach Namespace


_file Field

[image]

Sitecore 6.4.1 API
AttachArgs..::.._file Field
AttachArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Attach
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected HttpPostedFile _file
Visual Basic
Protected _file As HttpPostedFile
Visual C++
protected:
HttpPostedFile^ _file

See Also

AttachArgs Class
Sitecore.Pipelines.Attach Namespace


_mediaItem Field

[image]

Sitecore 6.4.1 API
AttachArgs..::.._mediaItem Field
AttachArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Attach
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected MediaItem _mediaItem
Visual Basic
Protected _mediaItem As MediaItem
Visual C++
protected:
MediaItem^ _mediaItem

See Also

AttachArgs Class
Sitecore.Pipelines.Attach Namespace


AttachArgs Methods

[image] [image]

Sitecore 6.4.1 API
AttachArgs Methods
AttachArgs Class See Also Send Feedback

The AttachArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AttachArgs Class
Sitecore.Pipelines.Attach Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
AttachArgs..::..AddMessage Method
AttachArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

AttachArgs Class
AttachArgs Members
Sitecore.Pipelines.Attach Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
AttachArgs..::..GetMessages Method
AttachArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

AttachArgs Class
AttachArgs Members
Sitecore.Pipelines.Attach Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
AttachArgs..::..Suspend Method
AttachArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

AttachArgs Class
AttachArgs Members
Sitecore.Pipelines.Attach Namespace


AttachArgs Properties

[image] [image]

Sitecore 6.4.1 API
AttachArgs Properties
AttachArgs Class See Also Send Feedback

The AttachArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | File | Gets or sets the file.
Public property | MediaItem | Gets or sets the media item.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

AttachArgs Class
Sitecore.Pipelines.Attach Namespace


File Property

[image]

Sitecore 6.4.1 API
AttachArgs..::..File Property
AttachArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Attach
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual HttpPostedFile File { get; set; }
Visual Basic
Public Overridable Property File As HttpPostedFile
    Get
    Set
Visual C++
public:
virtual property HttpPostedFile^ File {
    HttpPostedFile^ get ();
    void set (HttpPostedFile^ value);
}

Field Value

The file.

See Also

AttachArgs Class
Sitecore.Pipelines.Attach Namespace


MediaItem Property

[image]

Sitecore 6.4.1 API
AttachArgs..::..MediaItem Property
AttachArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Attach
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual MediaItem MediaItem { get; set; }
Visual Basic
Public Overridable Property MediaItem As MediaItem
    Get
    Set
Visual C++
public:
virtual property MediaItem^ MediaItem {
    MediaItem^ get ();
    void set (MediaItem^ value);
}

Field Value

The media item.

See Also

AttachArgs Class
Sitecore.Pipelines.Attach Namespace


CheckSize Class

[image]

Sitecore 6.4.1 API
CheckSize Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Attach
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CheckSize
Visual Basic
Public Class CheckSize
Visual C++
public ref class CheckSize

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Attach..::..CheckSize

See Also

CheckSize Members
Sitecore.Pipelines.Attach Namespace


CheckSize Members

[image] [image]

Sitecore 6.4.1 API
CheckSize Members
CheckSize Class Constructors Methods See Also Send Feedback

The CheckSize type exposes the following members.

Constructors

 | Name | Description
Public method | CheckSize | Initializes a new instance of the CheckSize class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckSize Class
Sitecore.Pipelines.Attach Namespace


CheckSize Methods

[image] [image]

Sitecore 6.4.1 API
CheckSize Methods
CheckSize Class See Also Send Feedback

The CheckSize type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckSize Class
Sitecore.Pipelines.Attach Namespace


Process Method

[image]

Sitecore 6.4.1 API
CheckSize..::..Process Method
CheckSize Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Attach
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    AttachArgs args
)
Visual Basic
Public Sub Process ( _
    args As AttachArgs _
)
Visual C++
public:
void Process(
    AttachArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Attach..::..AttachArgs
The args.

See Also

CheckSize Class
Sitecore.Pipelines.Attach Namespace


Save Class

[image]

Sitecore 6.4.1 API
Save Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Attach
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Save
Visual Basic
Public Class Save
Visual C++
public ref class Save

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Attach..::..Save

See Also

Save Members
Sitecore.Pipelines.Attach Namespace


Save Members

[image] [image]

Sitecore 6.4.1 API
Save Members
Save Class Constructors Methods See Also Send Feedback

The Save type exposes the following members.

Constructors

 | Name | Description
Public method | Save | Initializes a new instance of the Save class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Save Class
Sitecore.Pipelines.Attach Namespace


Save Methods

[image] [image]

Sitecore 6.4.1 API
Save Methods
Save Class See Also Send Feedback

The Save type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Save Class
Sitecore.Pipelines.Attach Namespace


Process Method

[image]

Sitecore 6.4.1 API
Save..::..Process Method
Save Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Attach
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    AttachArgs args
)
Visual Basic
Public Sub Process ( _
    args As AttachArgs _
)
Visual C++
public:
void Process(
    AttachArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Attach..::..AttachArgs
The args.

See Also

Save Class
Sitecore.Pipelines.Attach Namespace


UpdatePath Class

[image]

Sitecore 6.4.1 API
UpdatePath Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Attach
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class UpdatePath
Visual Basic
Public Class UpdatePath
Visual C++
public ref class UpdatePath

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Attach..::..UpdatePath

See Also

UpdatePath Members
Sitecore.Pipelines.Attach Namespace


UpdatePath Members

[image] [image]

Sitecore 6.4.1 API
UpdatePath Members
UpdatePath Class Constructors Methods See Also Send Feedback

The UpdatePath type exposes the following members.

Constructors

 | Name | Description
Public method | UpdatePath | Initializes a new instance of the UpdatePath class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UpdatePath Class
Sitecore.Pipelines.Attach Namespace


UpdatePath Constructor

[image]

Sitecore 6.4.1 API
UpdatePath Constructor
UpdatePath Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Attach
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UpdatePath()
Visual Basic
Public Sub New
Visual C++
public:
UpdatePath()

See Also

UpdatePath Class
Sitecore.Pipelines.Attach Namespace


UpdatePath Methods

[image] [image]

Sitecore 6.4.1 API
UpdatePath Methods
UpdatePath Class See Also Send Feedback

The UpdatePath type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UpdatePath Class
Sitecore.Pipelines.Attach Namespace


Process Method

[image]

Sitecore 6.4.1 API
UpdatePath..::..Process Method
UpdatePath Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Attach
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    AttachArgs args
)
Visual Basic
Public Sub Process ( _
    args As AttachArgs _
)
Visual C++
public:
void Process(
    AttachArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Attach..::..AttachArgs
The args.

See Also

UpdatePath Class
Sitecore.Pipelines.Attach Namespace


Sitecore.Pipelines.ConvertToDesignTimeHtml Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.ConvertToDesignTimeHtml Namespace
Send Feedback

Classes

 | Class | Description
Public class | ConvertToDesignTimeHtmlArgs | Implements the RenderField.
Public class | ConvertWebControls | Implements the ConvertWebControls.
Public class | FinalizeHtml | Implements the ShortenLinks.
Public class | FixBullets | Implements the FixBullets processor.
Public class | PrepareHtml | Implements the ShortenLinks.


ConvertToDesignTimeHtmlArgs Class

[image]

Sitecore 6.4.1 API
ConvertToDesignTimeHtmlArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToDesignTimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class ConvertToDesignTimeHtmlArgs : PipelineArgs
Visual Basic
<SerializableAttribute> _
Public Class ConvertToDesignTimeHtmlArgs _
    Inherits PipelineArgs
Visual C++
[SerializableAttribute]
public ref class ConvertToDesignTimeHtmlArgs : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Pipelines.ConvertToDesignTimeHtml..::..ConvertToDesignTimeHtmlArgs

See Also

ConvertToDesignTimeHtmlArgs Members
Sitecore.Pipelines.ConvertToDesignTimeHtml Namespace


ConvertToDesignTimeHtmlArgs Members

[image] [image]

Sitecore 6.4.1 API
ConvertToDesignTimeHtmlArgs Members
ConvertToDesignTimeHtmlArgs Class Constructors Methods Properties See Also Send Feedback

The ConvertToDesignTimeHtmlArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ConvertToDesignTimeHtmlArgs()()()() | Initializes a new instance of the ConvertToDesignTimeHtmlArgs class.
Protected method | ConvertToDesignTimeHtmlArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the ConvertToDesignTimeHtmlArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FinalizeProcessing | Finalizes the processing.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | ControlName | Gets or sets the name of the control.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Html | Gets or sets the HTML.
Public property | HtmlDocument | Gets the HTML document.
Public property | InlineControls | Gets or sets a value indicating whether the pipeline generates inline controls.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | QueryString | Gets or sets the query string.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

ConvertToDesignTimeHtmlArgs Class
Sitecore.Pipelines.ConvertToDesignTimeHtml Namespace


ConvertToDesignTimeHtmlArgs Constructor

[image] [image]

Sitecore 6.4.1 API
ConvertToDesignTimeHtmlArgs Constructor
ConvertToDesignTimeHtmlArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ConvertToDesignTimeHtmlArgs()()()() | Initializes a new instance of the ConvertToDesignTimeHtmlArgs class.
Protected method | ConvertToDesignTimeHtmlArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the ConvertToDesignTimeHtmlArgs class.

See Also

ConvertToDesignTimeHtmlArgs Class
ConvertToDesignTimeHtmlArgs Members
Sitecore.Pipelines.ConvertToDesignTimeHtml Namespace


ConvertToDesignTimeHtmlArgs Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
ConvertToDesignTimeHtmlArgs Constructor (SerializationInfo, StreamingContext)
ConvertToDesignTimeHtmlArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToDesignTimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected ConvertToDesignTimeHtmlArgs(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
ConvertToDesignTimeHtmlArgs(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

ConvertToDesignTimeHtmlArgs Class
ConvertToDesignTimeHtmlArgs Overload
Sitecore.Pipelines.ConvertToDesignTimeHtml Namespace


ConvertToDesignTimeHtmlArgs Methods

[image] [image]

Sitecore 6.4.1 API
ConvertToDesignTimeHtmlArgs Methods
ConvertToDesignTimeHtmlArgs Class See Also Send Feedback

The ConvertToDesignTimeHtmlArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FinalizeProcessing | Finalizes the processing.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConvertToDesignTimeHtmlArgs Class
Sitecore.Pipelines.ConvertToDesignTimeHtml Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
ConvertToDesignTimeHtmlArgs..::..AddMessage Method
ConvertToDesignTimeHtmlArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

ConvertToDesignTimeHtmlArgs Class
ConvertToDesignTimeHtmlArgs Members
Sitecore.Pipelines.ConvertToDesignTimeHtml Namespace


FinalizeProcessing Method

[image]

Sitecore 6.4.1 API
ConvertToDesignTimeHtmlArgs..::..FinalizeProcessing Method
ConvertToDesignTimeHtmlArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToDesignTimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void FinalizeProcessing()
Visual Basic
Public Sub FinalizeProcessing
Visual C++
public:
void FinalizeProcessing()

Return Value

The processing.

See Also

ConvertToDesignTimeHtmlArgs Class
Sitecore.Pipelines.ConvertToDesignTimeHtml Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
ConvertToDesignTimeHtmlArgs..::..GetMessages Method
ConvertToDesignTimeHtmlArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

ConvertToDesignTimeHtmlArgs Class
ConvertToDesignTimeHtmlArgs Members
Sitecore.Pipelines.ConvertToDesignTimeHtml Namespace


GetObjectData Method

[image]

Sitecore 6.4.1 API
ConvertToDesignTimeHtmlArgs..::..GetObjectData Method
ConvertToDesignTimeHtmlArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToDesignTimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System.Security..::..SecurityException | The caller does not have the required permission.

See Also

ConvertToDesignTimeHtmlArgs Class
Sitecore.Pipelines.ConvertToDesignTimeHtml Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
ConvertToDesignTimeHtmlArgs..::..Suspend Method
ConvertToDesignTimeHtmlArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

ConvertToDesignTimeHtmlArgs Class
ConvertToDesignTimeHtmlArgs Members
Sitecore.Pipelines.ConvertToDesignTimeHtml Namespace


ConvertToDesignTimeHtmlArgs Properties

[image] [image]

Sitecore 6.4.1 API
ConvertToDesignTimeHtmlArgs Properties
ConvertToDesignTimeHtmlArgs Class See Also Send Feedback

The ConvertToDesignTimeHtmlArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | ControlName | Gets or sets the name of the control.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Html | Gets or sets the HTML.
Public property | HtmlDocument | Gets the HTML document.
Public property | InlineControls | Gets or sets a value indicating whether the pipeline generates inline controls.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | QueryString | Gets or sets the query string.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

ConvertToDesignTimeHtmlArgs Class
Sitecore.Pipelines.ConvertToDesignTimeHtml Namespace


ControlName Property

[image]

Sitecore 6.4.1 API
ConvertToDesignTimeHtmlArgs..::..ControlName Property
ConvertToDesignTimeHtmlArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToDesignTimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ControlName { get; set; }
Visual Basic
Public Property ControlName As String
    Get
    Set
Visual C++
public:
property String^ ControlName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the control.

See Also

ConvertToDesignTimeHtmlArgs Class
Sitecore.Pipelines.ConvertToDesignTimeHtml Namespace


HtmlDocument Property

[image]

Sitecore 6.4.1 API
ConvertToDesignTimeHtmlArgs..::..HtmlDocument Property
ConvertToDesignTimeHtmlArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToDesignTimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HtmlDocument HtmlDocument { get; }
Visual Basic
Public ReadOnly Property HtmlDocument As HtmlDocument
    Get
Visual C++
public:
property HtmlDocument^ HtmlDocument {
    HtmlDocument^ get ();
}

Field Value

The HTML document.

See Also

ConvertToDesignTimeHtmlArgs Class
Sitecore.Pipelines.ConvertToDesignTimeHtml Namespace


InlineControls Property

[image]

Sitecore 6.4.1 API
ConvertToDesignTimeHtmlArgs..::..InlineControls Property
ConvertToDesignTimeHtmlArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToDesignTimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool InlineControls { get; set; }
Visual Basic
Public Property InlineControls As Boolean
    Get
    Set
Visual C++
public:
property bool InlineControls {
    bool get ();
    void set (bool value);
}

Field Value

true if the pipeline generates inline controls; otherwise, false.

See Also

ConvertToDesignTimeHtmlArgs Class
Sitecore.Pipelines.ConvertToDesignTimeHtml Namespace


QueryString Property

[image]

Sitecore 6.4.1 API
ConvertToDesignTimeHtmlArgs..::..QueryString Property
ConvertToDesignTimeHtmlArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToDesignTimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public NameValueCollection QueryString { get; set; }
Visual Basic
Public Property QueryString As NameValueCollection
    Get
    Set
Visual C++
public:
property NameValueCollection^ QueryString {
    NameValueCollection^ get ();
    void set (NameValueCollection^ value);
}

Field Value

The query string.

See Also

ConvertToDesignTimeHtmlArgs Class
Sitecore.Pipelines.ConvertToDesignTimeHtml Namespace


ConvertWebControls Class

[image]

Sitecore 6.4.1 API
ConvertWebControls Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToDesignTimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ConvertWebControls
Visual Basic
Public Class ConvertWebControls
Visual C++
public ref class ConvertWebControls

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.ConvertToDesignTimeHtml..::..ConvertWebControls

See Also

ConvertWebControls Members
Sitecore.Pipelines.ConvertToDesignTimeHtml Namespace


ConvertWebControls Members

[image] [image]

Sitecore 6.4.1 API
ConvertWebControls Members
ConvertWebControls Class Constructors Methods See Also Send Feedback

The ConvertWebControls type exposes the following members.

Constructors

 | Name | Description
Public method | ConvertWebControls | Initializes a new instance of the ConvertWebControls class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConvertWebControls Class
Sitecore.Pipelines.ConvertToDesignTimeHtml Namespace


ConvertWebControls Constructor

[image]

Sitecore 6.4.1 API
ConvertWebControls Constructor
ConvertWebControls Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToDesignTimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ConvertWebControls()
Visual Basic
Public Sub New
Visual C++
public:
ConvertWebControls()

See Also

ConvertWebControls Class
Sitecore.Pipelines.ConvertToDesignTimeHtml Namespace


ConvertWebControls Methods

[image] [image]

Sitecore 6.4.1 API
ConvertWebControls Methods
ConvertWebControls Class See Also Send Feedback

The ConvertWebControls type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConvertWebControls Class
Sitecore.Pipelines.ConvertToDesignTimeHtml Namespace


Process Method

[image]

Sitecore 6.4.1 API
ConvertWebControls..::..Process Method
ConvertWebControls Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToDesignTimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    ConvertToDesignTimeHtmlArgs args
)
Visual Basic
Public Sub Process ( _
    args As ConvertToDesignTimeHtmlArgs _
)
Visual C++
public:
void Process(
    ConvertToDesignTimeHtmlArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.ConvertToDesignTimeHtml..::..ConvertToDesignTimeHtmlArgs
The arguments.

See Also

ConvertWebControls Class
Sitecore.Pipelines.ConvertToDesignTimeHtml Namespace


FinalizeHtml Class

[image]

Sitecore 6.4.1 API
FinalizeHtml Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToDesignTimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FinalizeHtml
Visual Basic
Public Class FinalizeHtml
Visual C++
public ref class FinalizeHtml

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.ConvertToDesignTimeHtml..::..FinalizeHtml

See Also

FinalizeHtml Members
Sitecore.Pipelines.ConvertToDesignTimeHtml Namespace


FinalizeHtml Members

[image] [image]

Sitecore 6.4.1 API
FinalizeHtml Members
FinalizeHtml Class Constructors Methods See Also Send Feedback

The FinalizeHtml type exposes the following members.

Constructors

 | Name | Description
Public method | FinalizeHtml | Initializes a new instance of the FinalizeHtml class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FinalizeHtml Class
Sitecore.Pipelines.ConvertToDesignTimeHtml Namespace


FinalizeHtml Constructor

[image]

Sitecore 6.4.1 API
FinalizeHtml Constructor
FinalizeHtml Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToDesignTimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FinalizeHtml()
Visual Basic
Public Sub New
Visual C++
public:
FinalizeHtml()

See Also

FinalizeHtml Class
Sitecore.Pipelines.ConvertToDesignTimeHtml Namespace


FinalizeHtml Methods

[image] [image]

Sitecore 6.4.1 API
FinalizeHtml Methods
FinalizeHtml Class See Also Send Feedback

The FinalizeHtml type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FinalizeHtml Class
Sitecore.Pipelines.ConvertToDesignTimeHtml Namespace


Process Method

[image]

Sitecore 6.4.1 API
FinalizeHtml..::..Process Method
FinalizeHtml Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToDesignTimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    ConvertToDesignTimeHtmlArgs args
)
Visual Basic
Public Sub Process ( _
    args As ConvertToDesignTimeHtmlArgs _
)
Visual C++
public:
void Process(
    ConvertToDesignTimeHtmlArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.ConvertToDesignTimeHtml..::..ConvertToDesignTimeHtmlArgs
The arguments.

See Also

FinalizeHtml Class
Sitecore.Pipelines.ConvertToDesignTimeHtml Namespace


FixBullets Class

[image]

Sitecore 6.4.1 API
FixBullets Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToDesignTimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FixBullets
Visual Basic
Public Class FixBullets
Visual C++
public ref class FixBullets

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.ConvertToDesignTimeHtml..::..FixBullets

See Also

FixBullets Members
Sitecore.Pipelines.ConvertToDesignTimeHtml Namespace


FixBullets Members

[image] [image]

Sitecore 6.4.1 API
FixBullets Members
FixBullets Class Constructors Methods See Also Send Feedback

The FixBullets type exposes the following members.

Constructors

 | Name | Description
Public method | FixBullets | Initializes a new instance of the FixBullets class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FixBullets Class
Sitecore.Pipelines.ConvertToDesignTimeHtml Namespace


FixBullets Methods

[image] [image]

Sitecore 6.4.1 API
FixBullets Methods
FixBullets Class See Also Send Feedback

The FixBullets type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FixBullets Class
Sitecore.Pipelines.ConvertToDesignTimeHtml Namespace


Process Method

[image]

Sitecore 6.4.1 API
FixBullets..::..Process Method
FixBullets Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToDesignTimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    ConvertToDesignTimeHtmlArgs args
)
Visual Basic
Public Sub Process ( _
    args As ConvertToDesignTimeHtmlArgs _
)
Visual C++
public:
void Process(
    ConvertToDesignTimeHtmlArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.ConvertToDesignTimeHtml..::..ConvertToDesignTimeHtmlArgs
The arguments.

See Also

FixBullets Class
Sitecore.Pipelines.ConvertToDesignTimeHtml Namespace


PrepareHtml Class

[image]

Sitecore 6.4.1 API
PrepareHtml Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToDesignTimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PrepareHtml
Visual Basic
Public Class PrepareHtml
Visual C++
public ref class PrepareHtml

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.ConvertToDesignTimeHtml..::..PrepareHtml

See Also

PrepareHtml Members
Sitecore.Pipelines.ConvertToDesignTimeHtml Namespace


PrepareHtml Members

[image] [image]

Sitecore 6.4.1 API
PrepareHtml Members
PrepareHtml Class Constructors Methods See Also Send Feedback

The PrepareHtml type exposes the following members.

Constructors

 | Name | Description
Public method | PrepareHtml | Initializes a new instance of the PrepareHtml class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PrepareHtml Class
Sitecore.Pipelines.ConvertToDesignTimeHtml Namespace


PrepareHtml Constructor

[image]

Sitecore 6.4.1 API
PrepareHtml Constructor
PrepareHtml Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToDesignTimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PrepareHtml()
Visual Basic
Public Sub New
Visual C++
public:
PrepareHtml()

See Also

PrepareHtml Class
Sitecore.Pipelines.ConvertToDesignTimeHtml Namespace


PrepareHtml Methods

[image] [image]

Sitecore 6.4.1 API
PrepareHtml Methods
PrepareHtml Class See Also Send Feedback

The PrepareHtml type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PrepareHtml Class
Sitecore.Pipelines.ConvertToDesignTimeHtml Namespace


Process Method

[image]

Sitecore 6.4.1 API
PrepareHtml..::..Process Method
PrepareHtml Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToDesignTimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    ConvertToDesignTimeHtmlArgs args
)
Visual Basic
Public Sub Process ( _
    args As ConvertToDesignTimeHtmlArgs _
)
Visual C++
public:
void Process(
    ConvertToDesignTimeHtmlArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.ConvertToDesignTimeHtml..::..ConvertToDesignTimeHtmlArgs
The arguments.

See Also

PrepareHtml Class
Sitecore.Pipelines.ConvertToDesignTimeHtml Namespace


Sitecore.Pipelines.ConvertToRuntimeHtml Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace
Send Feedback

Classes

 | Class | Description
Public class | ConvertToRuntimeHtmlArgs | Implements the convert to runtime Html arguments.
Public class | ConvertWebControls | Implements the ShortenLinks.
Public class | FinalizeHtml | Implements the ShortenLinks.
Public class | FixBullets | Implements the ShortenLinks.
Public class | PrepareHtml | Implements the ShortenLinks.
Public class | SetImageSizes | Implements the ShortenLinks.
Public class | ShortenLinks | Implements the ShortenLinks.


ConvertToRuntimeHtmlArgs Class

[image]

Sitecore 6.4.1 API
ConvertToRuntimeHtmlArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToRuntimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class ConvertToRuntimeHtmlArgs : PipelineArgs
Visual Basic
<SerializableAttribute> _
Public Class ConvertToRuntimeHtmlArgs _
    Inherits PipelineArgs
Visual C++
[SerializableAttribute]
public ref class ConvertToRuntimeHtmlArgs : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Pipelines.ConvertToRuntimeHtml..::..ConvertToRuntimeHtmlArgs

See Also

ConvertToRuntimeHtmlArgs Members
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace


ConvertToRuntimeHtmlArgs Members

[image] [image]

Sitecore 6.4.1 API
ConvertToRuntimeHtmlArgs Members
ConvertToRuntimeHtmlArgs Class Constructors Methods Properties See Also Send Feedback

The ConvertToRuntimeHtmlArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ConvertToRuntimeHtmlArgs()()()() | Initializes a new instance of the ConvertToRuntimeHtmlArgs class.
Protected method | ConvertToRuntimeHtmlArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the ConvertToRuntimeHtmlArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FinalizeProcessing | Finalizes the processing.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | ConvertWebControls | Gets or sets a value indicating whether the pipeline converts the web controls.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Html | Gets or sets the HTML.
Public property | HtmlDocument | Gets the HTML document.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

ConvertToRuntimeHtmlArgs Class
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace


ConvertToRuntimeHtmlArgs Constructor

[image] [image]

Sitecore 6.4.1 API
ConvertToRuntimeHtmlArgs Constructor
ConvertToRuntimeHtmlArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ConvertToRuntimeHtmlArgs()()()() | Initializes a new instance of the ConvertToRuntimeHtmlArgs class.
Protected method | ConvertToRuntimeHtmlArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the ConvertToRuntimeHtmlArgs class.

See Also

ConvertToRuntimeHtmlArgs Class
ConvertToRuntimeHtmlArgs Members
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace


ConvertToRuntimeHtmlArgs Constructor

[image]

Sitecore 6.4.1 API
ConvertToRuntimeHtmlArgs Constructor
ConvertToRuntimeHtmlArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToRuntimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ConvertToRuntimeHtmlArgs()
Visual Basic
Public Sub New
Visual C++
public:
ConvertToRuntimeHtmlArgs()

See Also

ConvertToRuntimeHtmlArgs Class
ConvertToRuntimeHtmlArgs Overload
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace


ConvertToRuntimeHtmlArgs Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
ConvertToRuntimeHtmlArgs Constructor (SerializationInfo, StreamingContext)
ConvertToRuntimeHtmlArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToRuntimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected ConvertToRuntimeHtmlArgs(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
ConvertToRuntimeHtmlArgs(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

ConvertToRuntimeHtmlArgs Class
ConvertToRuntimeHtmlArgs Overload
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace


ConvertToRuntimeHtmlArgs Methods

[image] [image]

Sitecore 6.4.1 API
ConvertToRuntimeHtmlArgs Methods
ConvertToRuntimeHtmlArgs Class See Also Send Feedback

The ConvertToRuntimeHtmlArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FinalizeProcessing | Finalizes the processing.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConvertToRuntimeHtmlArgs Class
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
ConvertToRuntimeHtmlArgs..::..AddMessage Method
ConvertToRuntimeHtmlArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

ConvertToRuntimeHtmlArgs Class
ConvertToRuntimeHtmlArgs Members
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace


FinalizeProcessing Method

[image]

Sitecore 6.4.1 API
ConvertToRuntimeHtmlArgs..::..FinalizeProcessing Method
ConvertToRuntimeHtmlArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToRuntimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void FinalizeProcessing()
Visual Basic
Public Sub FinalizeProcessing
Visual C++
public:
void FinalizeProcessing()

Return Value

The processing.

See Also

ConvertToRuntimeHtmlArgs Class
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
ConvertToRuntimeHtmlArgs..::..GetMessages Method
ConvertToRuntimeHtmlArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

ConvertToRuntimeHtmlArgs Class
ConvertToRuntimeHtmlArgs Members
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
ConvertToRuntimeHtmlArgs..::..Suspend Method
ConvertToRuntimeHtmlArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

ConvertToRuntimeHtmlArgs Class
ConvertToRuntimeHtmlArgs Members
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace


ConvertWebControls Property

[image]

Sitecore 6.4.1 API
ConvertToRuntimeHtmlArgs..::..ConvertWebControls Property
ConvertToRuntimeHtmlArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToRuntimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ConvertWebControls { get; set; }
Visual Basic
Public Property ConvertWebControls As Boolean
    Get
    Set
Visual C++
public:
property bool ConvertWebControls {
    bool get ();
    void set (bool value);
}

Field Value

true if the pipeline converts the web controls; otherwise, false.

See Also

ConvertToRuntimeHtmlArgs Class
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace


Html Property

[image]

Sitecore 6.4.1 API
ConvertToRuntimeHtmlArgs..::..Html Property
ConvertToRuntimeHtmlArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToRuntimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Html { get; set; }
Visual Basic
Public Property Html As String
    Get
    Set
Visual C++
public:
property String^ Html {
    String^ get ();
    void set (String^ value);
}

Field Value

The HTML.

See Also

ConvertToRuntimeHtmlArgs Class
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace


ConvertWebControls Class

[image]

Sitecore 6.4.1 API
ConvertWebControls Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToRuntimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ConvertWebControls
Visual Basic
Public Class ConvertWebControls
Visual C++
public ref class ConvertWebControls

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.ConvertToRuntimeHtml..::..ConvertWebControls

See Also

ConvertWebControls Members
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace


ConvertWebControls Members

[image] [image]

Sitecore 6.4.1 API
ConvertWebControls Members
ConvertWebControls Class Constructors Methods See Also Send Feedback

The ConvertWebControls type exposes the following members.

Constructors

 | Name | Description
Public method | ConvertWebControls | Initializes a new instance of the ConvertWebControls class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConvertWebControls Class
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace


ConvertWebControls Methods

[image] [image]

Sitecore 6.4.1 API
ConvertWebControls Methods
ConvertWebControls Class See Also Send Feedback

The ConvertWebControls type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConvertWebControls Class
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace


Process Method

[image]

Sitecore 6.4.1 API
ConvertWebControls..::..Process Method
ConvertWebControls Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToRuntimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    ConvertToRuntimeHtmlArgs args
)
Visual Basic
Public Sub Process ( _
    args As ConvertToRuntimeHtmlArgs _
)
Visual C++
public:
void Process(
    ConvertToRuntimeHtmlArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.ConvertToRuntimeHtml..::..ConvertToRuntimeHtmlArgs
The arguments.

See Also

ConvertWebControls Class
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace


FinalizeHtml Class

[image]

Sitecore 6.4.1 API
FinalizeHtml Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToRuntimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FinalizeHtml
Visual Basic
Public Class FinalizeHtml
Visual C++
public ref class FinalizeHtml

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.ConvertToRuntimeHtml..::..FinalizeHtml

See Also

FinalizeHtml Members
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace


FinalizeHtml Members

[image] [image]

Sitecore 6.4.1 API
FinalizeHtml Members
FinalizeHtml Class Constructors Methods See Also Send Feedback

The FinalizeHtml type exposes the following members.

Constructors

 | Name | Description
Public method | FinalizeHtml | Initializes a new instance of the FinalizeHtml class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FinalizeHtml Class
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace


FinalizeHtml Constructor

[image]

Sitecore 6.4.1 API
FinalizeHtml Constructor
FinalizeHtml Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToRuntimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FinalizeHtml()
Visual Basic
Public Sub New
Visual C++
public:
FinalizeHtml()

See Also

FinalizeHtml Class
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace


FinalizeHtml Methods

[image] [image]

Sitecore 6.4.1 API
FinalizeHtml Methods
FinalizeHtml Class See Also Send Feedback

The FinalizeHtml type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FinalizeHtml Class
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace


Process Method

[image]

Sitecore 6.4.1 API
FinalizeHtml..::..Process Method
FinalizeHtml Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToRuntimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    ConvertToRuntimeHtmlArgs args
)
Visual Basic
Public Sub Process ( _
    args As ConvertToRuntimeHtmlArgs _
)
Visual C++
public:
void Process(
    ConvertToRuntimeHtmlArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.ConvertToRuntimeHtml..::..ConvertToRuntimeHtmlArgs
The arguments.

See Also

FinalizeHtml Class
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace


FixBullets Members

[image] [image]

Sitecore 6.4.1 API
FixBullets Members
FixBullets Class Constructors Methods See Also Send Feedback

The FixBullets type exposes the following members.

Constructors

 | Name | Description
Public method | FixBullets | Initializes a new instance of the FixBullets class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FixBullets Class
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace


FixBullets Constructor

[image]

Sitecore 6.4.1 API
FixBullets Constructor
FixBullets Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToRuntimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FixBullets()
Visual Basic
Public Sub New
Visual C++
public:
FixBullets()

See Also

FixBullets Class
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace


FixBullets Methods

[image] [image]

Sitecore 6.4.1 API
FixBullets Methods
FixBullets Class See Also Send Feedback

The FixBullets type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FixBullets Class
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace


Process Method

[image]

Sitecore 6.4.1 API
FixBullets..::..Process Method
FixBullets Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToRuntimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    ConvertToRuntimeHtmlArgs args
)
Visual Basic
Public Sub Process ( _
    args As ConvertToRuntimeHtmlArgs _
)
Visual C++
public:
void Process(
    ConvertToRuntimeHtmlArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.ConvertToRuntimeHtml..::..ConvertToRuntimeHtmlArgs
The arguments.

See Also

FixBullets Class
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace


PrepareHtml Class

[image]

Sitecore 6.4.1 API
PrepareHtml Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToRuntimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PrepareHtml
Visual Basic
Public Class PrepareHtml
Visual C++
public ref class PrepareHtml

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.ConvertToRuntimeHtml..::..PrepareHtml

See Also

PrepareHtml Members
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace


PrepareHtml Members

[image] [image]

Sitecore 6.4.1 API
PrepareHtml Members
PrepareHtml Class Constructors Methods See Also Send Feedback

The PrepareHtml type exposes the following members.

Constructors

 | Name | Description
Public method | PrepareHtml | Initializes a new instance of the PrepareHtml class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PrepareHtml Class
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace


PrepareHtml Constructor

[image]

Sitecore 6.4.1 API
PrepareHtml Constructor
PrepareHtml Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToRuntimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PrepareHtml()
Visual Basic
Public Sub New
Visual C++
public:
PrepareHtml()

See Also

PrepareHtml Class
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace


PrepareHtml Methods

[image] [image]

Sitecore 6.4.1 API
PrepareHtml Methods
PrepareHtml Class See Also Send Feedback

The PrepareHtml type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PrepareHtml Class
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace


Process Method

[image]

Sitecore 6.4.1 API
PrepareHtml..::..Process Method
PrepareHtml Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToRuntimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    ConvertToRuntimeHtmlArgs args
)
Visual Basic
Public Sub Process ( _
    args As ConvertToRuntimeHtmlArgs _
)
Visual C++
public:
void Process(
    ConvertToRuntimeHtmlArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.ConvertToRuntimeHtml..::..ConvertToRuntimeHtmlArgs
The arguments.

See Also

PrepareHtml Class
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace


SetImageSizes Members

[image] [image]

Sitecore 6.4.1 API
SetImageSizes Members
SetImageSizes Class Constructors Methods See Also Send Feedback

The SetImageSizes type exposes the following members.

Constructors

 | Name | Description
Public method | SetImageSizes | Initializes a new instance of the SetImageSizes class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SetImageSizes Class
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace


SetImageSizes Constructor

[image]

Sitecore 6.4.1 API
SetImageSizes Constructor
SetImageSizes Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToRuntimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SetImageSizes()
Visual Basic
Public Sub New
Visual C++
public:
SetImageSizes()

See Also

SetImageSizes Class
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace


SetImageSizes Methods

[image] [image]

Sitecore 6.4.1 API
SetImageSizes Methods
SetImageSizes Class See Also Send Feedback

The SetImageSizes type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SetImageSizes Class
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace


Process Method

[image]

Sitecore 6.4.1 API
SetImageSizes..::..Process Method
SetImageSizes Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToRuntimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    ConvertToRuntimeHtmlArgs args
)
Visual Basic
Public Sub Process ( _
    args As ConvertToRuntimeHtmlArgs _
)
Visual C++
public:
void Process(
    ConvertToRuntimeHtmlArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.ConvertToRuntimeHtml..::..ConvertToRuntimeHtmlArgs
The arguments.

See Also

SetImageSizes Class
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace


ShortenLinks Class

[image]

Sitecore 6.4.1 API
ShortenLinks Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToRuntimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ShortenLinks
Visual Basic
Public Class ShortenLinks
Visual C++
public ref class ShortenLinks

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.ConvertToRuntimeHtml..::..ShortenLinks

See Also

ShortenLinks Members
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace


ShortenLinks Members

[image] [image]

Sitecore 6.4.1 API
ShortenLinks Members
ShortenLinks Class Constructors Methods See Also Send Feedback

The ShortenLinks type exposes the following members.

Constructors

 | Name | Description
Public method | ShortenLinks | Initializes a new instance of the ShortenLinks class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShortenLinks Class
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace


ShortenLinks Constructor

[image]

Sitecore 6.4.1 API
ShortenLinks Constructor
ShortenLinks Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToRuntimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ShortenLinks()
Visual Basic
Public Sub New
Visual C++
public:
ShortenLinks()

See Also

ShortenLinks Class
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace


ShortenLinks Methods

[image] [image]

Sitecore 6.4.1 API
ShortenLinks Methods
ShortenLinks Class See Also Send Feedback

The ShortenLinks type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShortenLinks Class
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace


Process Method

[image]

Sitecore 6.4.1 API
ShortenLinks..::..Process Method
ShortenLinks Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ConvertToRuntimeHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    ConvertToRuntimeHtmlArgs args
)
Visual Basic
Public Sub Process ( _
    args As ConvertToRuntimeHtmlArgs _
)
Visual C++
public:
void Process(
    ConvertToRuntimeHtmlArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.ConvertToRuntimeHtml..::..ConvertToRuntimeHtmlArgs
The arguments.

See Also

ShortenLinks Class
Sitecore.Pipelines.ConvertToRuntimeHtml Namespace


Sitecore.Pipelines.Dispatch Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.Dispatch Namespace
Send Feedback

Classes

 | Class | Description
Public class | DispatchArgs | Argument class for Dispatch implementations.


DispatchArgs Class

[image]

Sitecore 6.4.1 API
DispatchArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Dispatch
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class DispatchArgs : ClientPipelineArgs,
    ISerializable
Visual Basic
<SerializableAttribute> _
Public Class DispatchArgs _
    Inherits ClientPipelineArgs _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class DispatchArgs : public ClientPipelineArgs,
    ISerializable

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Web.UI.Sheer..::..ClientPipelineArgs
Sitecore.Pipelines.Dispatch..::..DispatchArgs

See Also

DispatchArgs Members
Sitecore.Pipelines.Dispatch Namespace


DispatchArgs Members

[image] [image]

Sitecore 6.4.1 API
DispatchArgs Members
DispatchArgs Class Constructors Methods Properties See Also Send Feedback

The DispatchArgs type exposes the following members.

Constructors

 | Name | Description
Public method | DispatchArgs(Message) | Initializes a new instance of the DispatchArgs class.
Protected method | DispatchArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the DispatchArgs class from a serialization context.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ClientPipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | A processor is done. (Overrides ClientPipelineArgs..::..ProcessorDone()()()().)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WaitForPostBack()()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Public method | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CancelBubble | Gets or sets a value indicating whether the DispatchArgs cancels the bubble.
Public property | CarryResultToNextProcessor | Gets or sets a value indicating whether the ClientPipelineArgs carries the result to next processor. (Inherited from ClientPipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | HasResult | Gets a value indicating whether this instance has a result. (Inherited from ClientPipelineArgs.)
Public property | InnerMessage | Gets the inner message.
Public property | IsPostBack | Gets or sets a value that indicates if the processor was invoked as part of a user response. (Inherited from ClientPipelineArgs.)
Public property | Item | Gets the String with the specified key.
Public property | Items | Gets or sets the items.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Name | Gets the name.
Public property | Parameters | Gets or sets the parameters. (Inherited from ClientPipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Properties | Gets the properties. (Inherited from ClientPipelineArgs.)
Public property | Result | Gets or sets the value that was posted as part of a Sheer response. (Inherited from ClientPipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

DispatchArgs Class
Sitecore.Pipelines.Dispatch Namespace


DispatchArgs Constructor

[image] [image]

Sitecore 6.4.1 API
DispatchArgs Constructor
DispatchArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DispatchArgs(Message) | Initializes a new instance of the DispatchArgs class.
Protected method | DispatchArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the DispatchArgs class from a serialization context.

See Also

DispatchArgs Class
DispatchArgs Members
Sitecore.Pipelines.Dispatch Namespace


DispatchArgs Constructor (Message)

[image]

Sitecore 6.4.1 API
DispatchArgs Constructor (Message)
DispatchArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Dispatch
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DispatchArgs(
    Message message
)
Visual Basic
Public Sub New ( _
    message As Message _
)
Visual C++
public:
DispatchArgs(
    Message^ message
)

Parameters

message
Type: Sitecore.Web.UI.Sheer..::..Message
The message.

See Also

DispatchArgs Class
DispatchArgs Overload
Sitecore.Pipelines.Dispatch Namespace


DispatchArgs Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
DispatchArgs Constructor (SerializationInfo, StreamingContext)
DispatchArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Dispatch
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected DispatchArgs(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
DispatchArgs(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The serialized data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

DispatchArgs Class
DispatchArgs Overload
Sitecore.Pipelines.Dispatch Namespace


DispatchArgs Methods

[image] [image]

Sitecore 6.4.1 API
DispatchArgs Methods
DispatchArgs Class See Also Send Feedback

The DispatchArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ClientPipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | A processor is done. (Overrides ClientPipelineArgs..::..ProcessorDone()()()().)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WaitForPostBack()()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Public method | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)

See Also

DispatchArgs Class
Sitecore.Pipelines.Dispatch Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
DispatchArgs..::..AddMessage Method
DispatchArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

DispatchArgs Class
DispatchArgs Members
Sitecore.Pipelines.Dispatch Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
DispatchArgs..::..GetMessages Method
DispatchArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

DispatchArgs Class
DispatchArgs Members
Sitecore.Pipelines.Dispatch Namespace


GetObjectData Method

[image]

Sitecore 6.4.1 API
DispatchArgs..::..GetObjectData Method
DispatchArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Dispatch
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System.Security..::..SecurityException | The caller does not have the required permission.

See Also

DispatchArgs Class
Sitecore.Pipelines.Dispatch Namespace


ProcessorDone Method

[image]

Sitecore 6.4.1 API
DispatchArgs..::..ProcessorDone Method
DispatchArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Dispatch
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected internal override void ProcessorDone()
Visual Basic
Protected Friend Overrides Sub ProcessorDone
Visual C++
protected public:
virtual void ProcessorDone() override

See Also

DispatchArgs Class
Sitecore.Pipelines.Dispatch Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
DispatchArgs..::..Suspend Method
DispatchArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

DispatchArgs Class
DispatchArgs Members
Sitecore.Pipelines.Dispatch Namespace


WaitForPostBack Method

[image] [image]

Sitecore 6.4.1 API
DispatchArgs..::..WaitForPostBack Method
DispatchArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaitForPostBack()()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Public method | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)

See Also

DispatchArgs Class
DispatchArgs Members
Sitecore.Pipelines.Dispatch Namespace


DispatchArgs Properties

[image] [image]

Sitecore 6.4.1 API
DispatchArgs Properties
DispatchArgs Class See Also Send Feedback

The DispatchArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CancelBubble | Gets or sets a value indicating whether the DispatchArgs cancels the bubble.
Public property | CarryResultToNextProcessor | Gets or sets a value indicating whether the ClientPipelineArgs carries the result to next processor. (Inherited from ClientPipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | HasResult | Gets a value indicating whether this instance has a result. (Inherited from ClientPipelineArgs.)
Public property | InnerMessage | Gets the inner message.
Public property | IsPostBack | Gets or sets a value that indicates if the processor was invoked as part of a user response. (Inherited from ClientPipelineArgs.)
Public property | Item | Gets the String with the specified key.
Public property | Items | Gets or sets the items.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Name | Gets the name.
Public property | Parameters | Gets or sets the parameters. (Inherited from ClientPipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Properties | Gets the properties. (Inherited from ClientPipelineArgs.)
Public property | Result | Gets or sets the value that was posted as part of a Sheer response. (Inherited from ClientPipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

DispatchArgs Class
Sitecore.Pipelines.Dispatch Namespace


CancelBubble Property

[image]

Sitecore 6.4.1 API
DispatchArgs..::..CancelBubble Property
DispatchArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Dispatch
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool CancelBubble { get; set; }
Visual Basic
Public Property CancelBubble As Boolean
    Get
    Set
Visual C++
public:
property bool CancelBubble {
    bool get ();
    void set (bool value);
}

Field Value

true if the DispatchArgs cancels the bubble; otherwise, false.

See Also

DispatchArgs Class
Sitecore.Pipelines.Dispatch Namespace


InnerMessage Property

[image]

Sitecore 6.4.1 API
DispatchArgs..::..InnerMessage Property
DispatchArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Dispatch
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Message InnerMessage { get; }
Visual Basic
Public ReadOnly Property InnerMessage As Message
    Get
Visual C++
public:
property Message^ InnerMessage {
    Message^ get ();
}

Field Value

The inner message.

See Also

DispatchArgs Class
Sitecore.Pipelines.Dispatch Namespace


Item Property

[image]

Sitecore 6.4.1 API
DispatchArgs..::..Item Property
DispatchArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Dispatch
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string this[
    string key
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    key As String _
) As String
    Get
Visual C++
public:
property String^ default[String^ key] {
    String^ get (String^ key);
}

Parameters

key
Type: System..::..String

Field Value

The String.

See Also

DispatchArgs Class
Sitecore.Pipelines.Dispatch Namespace


Items Property

[image]

Sitecore 6.4.1 API
DispatchArgs..::..Items Property
DispatchArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Dispatch
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item[] Items { get; set; }
Visual Basic
Public Property Items As Item()
    Get
    Set
Visual C++
public:
property array<Item^>^ Items {
    array<Item^>^ get ();
    void set (array<Item^>^ value);
}

Field Value

The items.

See Also

DispatchArgs Class
Sitecore.Pipelines.Dispatch Namespace


Name Property

[image]

Sitecore 6.4.1 API
DispatchArgs..::..Name Property
DispatchArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Dispatch
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

DispatchArgs Class
Sitecore.Pipelines.Dispatch Namespace


Sitecore.Pipelines.ExpandBranchItemName Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.ExpandBranchItemName Namespace
Send Feedback

Classes

 | Class | Description
Public class | ExpandBranchItemNameArgs | ExpandBranchItemNameArgs
Public class | ExpandBranchItemNameProcessor | ExpandBranchItemNameProcessor class
Public class | ReplaceVariables | ReplaceVariables


ExpandBranchItemNameArgs Class

[image]

Sitecore 6.4.1 API
ExpandBranchItemNameArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.ExpandBranchItemName
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class ExpandBranchItemNameArgs : PipelineArgs
Visual Basic
<SerializableAttribute> _
Public Class ExpandBranchItemNameArgs _
    Inherits PipelineArgs
Visual C++
[SerializableAttribute]
public ref class ExpandBranchItemNameArgs : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Pipelines.ExpandBranchItemName..::..ExpandBranchItemNameArgs

See Also

ExpandBranchItemNameArgs Members
Sitecore.Pipelines.ExpandBranchItemName Namespace


ExpandBranchItemNameArgs Members

[image] [image]

Sitecore 6.4.1 API
ExpandBranchItemNameArgs Members
ExpandBranchItemNameArgs Class Constructors Methods Properties See Also Send Feedback

The ExpandBranchItemNameArgs type exposes the following members.

Constructors

 | Name | Description
Protected method | ExpandBranchItemNameArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the ExpandBranchItemNameArgs class.
Public method | ExpandBranchItemNameArgs(Item, String) | Initializes a new instance of the ExpandBranchItemNameArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | BranchTemplateItem | Gets the item.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Result | Gets or sets the result.
Public property | ResultModified | Gets a value indicating whether [result modified].
Public property | RootItemName | Gets the name of the item.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

ExpandBranchItemNameArgs Class
Sitecore.Pipelines.ExpandBranchItemName Namespace


ExpandBranchItemNameArgs Constructor

[image] [image]

Sitecore 6.4.1 API
ExpandBranchItemNameArgs Constructor
ExpandBranchItemNameArgs Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | ExpandBranchItemNameArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the ExpandBranchItemNameArgs class.
Public method | ExpandBranchItemNameArgs(Item, String) | Initializes a new instance of the ExpandBranchItemNameArgs class.

See Also

ExpandBranchItemNameArgs Class
ExpandBranchItemNameArgs Members
Sitecore.Pipelines.ExpandBranchItemName Namespace


ExpandBranchItemNameArgs Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
ExpandBranchItemNameArgs Constructor (SerializationInfo, StreamingContext)
ExpandBranchItemNameArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ExpandBranchItemName
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected ExpandBranchItemNameArgs(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
ExpandBranchItemNameArgs(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

ExpandBranchItemNameArgs Class
ExpandBranchItemNameArgs Overload
Sitecore.Pipelines.ExpandBranchItemName Namespace


ExpandBranchItemNameArgs Constructor (Item, String)

[image]

Sitecore 6.4.1 API
ExpandBranchItemNameArgs Constructor (Item, String)
ExpandBranchItemNameArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ExpandBranchItemName
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ExpandBranchItemNameArgs(
    Item branchTemplateItem,
    string rootItemName
)
Visual Basic
Public Sub New ( _
    branchTemplateItem As Item, _
    rootItemName As String _
)
Visual C++
public:
ExpandBranchItemNameArgs(
    Item^ branchTemplateItem,
    String^ rootItemName
)

Parameters

branchTemplateItem
Type: Sitecore.Data.Items..::..Item
The branch template item.
rootItemName
Type: System..::..String
Name of the root item.

See Also

ExpandBranchItemNameArgs Class
ExpandBranchItemNameArgs Overload
Sitecore.Pipelines.ExpandBranchItemName Namespace


ExpandBranchItemNameArgs Methods

[image] [image]

Sitecore 6.4.1 API
ExpandBranchItemNameArgs Methods
ExpandBranchItemNameArgs Class See Also Send Feedback

The ExpandBranchItemNameArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExpandBranchItemNameArgs Class
Sitecore.Pipelines.ExpandBranchItemName Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
ExpandBranchItemNameArgs..::..AddMessage Method
ExpandBranchItemNameArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

ExpandBranchItemNameArgs Class
ExpandBranchItemNameArgs Members
Sitecore.Pipelines.ExpandBranchItemName Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
ExpandBranchItemNameArgs..::..GetMessages Method
ExpandBranchItemNameArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

ExpandBranchItemNameArgs Class
ExpandBranchItemNameArgs Members
Sitecore.Pipelines.ExpandBranchItemName Namespace


GetObjectData Method

[image]

Sitecore 6.4.1 API
ExpandBranchItemNameArgs..::..GetObjectData Method
ExpandBranchItemNameArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ExpandBranchItemName
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System.Security..::..SecurityException | The caller does not have the required permission.

See Also

ExpandBranchItemNameArgs Class
Sitecore.Pipelines.ExpandBranchItemName Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
ExpandBranchItemNameArgs..::..Suspend Method
ExpandBranchItemNameArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

ExpandBranchItemNameArgs Class
ExpandBranchItemNameArgs Members
Sitecore.Pipelines.ExpandBranchItemName Namespace


ExpandBranchItemNameArgs Properties

[image] [image]

Sitecore 6.4.1 API
ExpandBranchItemNameArgs Properties
ExpandBranchItemNameArgs Class See Also Send Feedback

The ExpandBranchItemNameArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | BranchTemplateItem | Gets the item.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Result | Gets or sets the result.
Public property | ResultModified | Gets a value indicating whether [result modified].
Public property | RootItemName | Gets the name of the item.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

ExpandBranchItemNameArgs Class
Sitecore.Pipelines.ExpandBranchItemName Namespace


BranchTemplateItem Property

[image]

Sitecore 6.4.1 API
ExpandBranchItemNameArgs..::..BranchTemplateItem Property
ExpandBranchItemNameArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ExpandBranchItemName
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item BranchTemplateItem { get; }
Visual Basic
Public ReadOnly Property BranchTemplateItem As Item
    Get
Visual C++
public:
property Item^ BranchTemplateItem {
    Item^ get ();
}

Field Value

The item.

See Also

ExpandBranchItemNameArgs Class
Sitecore.Pipelines.ExpandBranchItemName Namespace


ResultModified Property

[image]

Sitecore 6.4.1 API
ExpandBranchItemNameArgs..::..ResultModified Property
ExpandBranchItemNameArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ExpandBranchItemName
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ResultModified { get; }
Visual Basic
Public ReadOnly Property ResultModified As Boolean
    Get
Visual C++
public:
property bool ResultModified {
    bool get ();
}

Field Value

true if [result modified]; otherwise, false.

See Also

ExpandBranchItemNameArgs Class
Sitecore.Pipelines.ExpandBranchItemName Namespace


RootItemName Property

[image]

Sitecore 6.4.1 API
ExpandBranchItemNameArgs..::..RootItemName Property
ExpandBranchItemNameArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ExpandBranchItemName
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string RootItemName { get; }
Visual Basic
Public ReadOnly Property RootItemName As String
    Get
Visual C++
public:
property String^ RootItemName {
    String^ get ();
}

Field Value

The name of the item.

See Also

ExpandBranchItemNameArgs Class
Sitecore.Pipelines.ExpandBranchItemName Namespace


ExpandBranchItemNameProcessor Class

[image]

Sitecore 6.4.1 API
ExpandBranchItemNameProcessor Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.ExpandBranchItemName
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class ExpandBranchItemNameProcessor
Visual Basic
Public MustInherit Class ExpandBranchItemNameProcessor
Visual C++
public ref class ExpandBranchItemNameProcessor abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.ExpandBranchItemName..::..ExpandBranchItemNameProcessor
Sitecore.Pipelines.ExpandBranchItemName..::..ReplaceVariables

See Also

ExpandBranchItemNameProcessor Members
Sitecore.Pipelines.ExpandBranchItemName Namespace


ExpandBranchItemNameProcessor Members

[image] [image]

Sitecore 6.4.1 API
ExpandBranchItemNameProcessor Members
ExpandBranchItemNameProcessor Class Constructors Methods See Also Send Feedback

The ExpandBranchItemNameProcessor type exposes the following members.

Constructors

 | Name | Description
Protected method | ExpandBranchItemNameProcessor | Initializes a new instance of the ExpandBranchItemNameProcessor class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExpandBranchItemNameProcessor Class
Sitecore.Pipelines.ExpandBranchItemName Namespace


ExpandBranchItemNameProcessor Constructor

[image]

Sitecore 6.4.1 API
ExpandBranchItemNameProcessor Constructor
ExpandBranchItemNameProcessor Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ExpandBranchItemName
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected ExpandBranchItemNameProcessor()
Visual Basic
Protected Sub New
Visual C++
protected:
ExpandBranchItemNameProcessor()

See Also

ExpandBranchItemNameProcessor Class
Sitecore.Pipelines.ExpandBranchItemName Namespace


ExpandBranchItemNameProcessor Methods

[image] [image]

Sitecore 6.4.1 API
ExpandBranchItemNameProcessor Methods
ExpandBranchItemNameProcessor Class See Also Send Feedback

The ExpandBranchItemNameProcessor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExpandBranchItemNameProcessor Class
Sitecore.Pipelines.ExpandBranchItemName Namespace


Process Method

[image]

Sitecore 6.4.1 API
ExpandBranchItemNameProcessor..::..Process Method
ExpandBranchItemNameProcessor Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ExpandBranchItemName
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract void Process(
    ExpandBranchItemNameArgs args
)
Visual Basic
Public MustOverride Sub Process ( _
    args As ExpandBranchItemNameArgs _
)
Visual C++
public:
virtual void Process(
    ExpandBranchItemNameArgs^ args
) abstract

Parameters

args
Type: Sitecore.Pipelines.ExpandBranchItemName..::..ExpandBranchItemNameArgs
The args.

See Also

ExpandBranchItemNameProcessor Class
Sitecore.Pipelines.ExpandBranchItemName Namespace


ReplaceVariables Class

[image]

Sitecore 6.4.1 API
ReplaceVariables Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.ExpandBranchItemName
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ReplaceVariables : ExpandBranchItemNameProcessor
Visual Basic
Public Class ReplaceVariables _
    Inherits ExpandBranchItemNameProcessor
Visual C++
public ref class ReplaceVariables : public ExpandBranchItemNameProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.ExpandBranchItemName..::..ExpandBranchItemNameProcessor
Sitecore.Pipelines.ExpandBranchItemName..::..ReplaceVariables

See Also

ReplaceVariables Members
Sitecore.Pipelines.ExpandBranchItemName Namespace


ReplaceVariables Members

[image] [image]

Sitecore 6.4.1 API
ReplaceVariables Members
ReplaceVariables Class Constructors Methods See Also Send Feedback

The ReplaceVariables type exposes the following members.

Constructors

 | Name | Description
Public method | ReplaceVariables | Initializes a new instance of the ReplaceVariables class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides ExpandBranchItemNameProcessor..::..Process(ExpandBranchItemNameArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReplaceVariables Class
Sitecore.Pipelines.ExpandBranchItemName Namespace


ReplaceVariables Constructor

[image]

Sitecore 6.4.1 API
ReplaceVariables Constructor
ReplaceVariables Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ExpandBranchItemName
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ReplaceVariables()
Visual Basic
Public Sub New
Visual C++
public:
ReplaceVariables()

See Also

ReplaceVariables Class
Sitecore.Pipelines.ExpandBranchItemName Namespace


ReplaceVariables Methods

[image] [image]

Sitecore 6.4.1 API
ReplaceVariables Methods
ReplaceVariables Class See Also Send Feedback

The ReplaceVariables type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides ExpandBranchItemNameProcessor..::..Process(ExpandBranchItemNameArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReplaceVariables Class
Sitecore.Pipelines.ExpandBranchItemName Namespace


Process Method

[image]

Sitecore 6.4.1 API
ReplaceVariables..::..Process Method
ReplaceVariables Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ExpandBranchItemName
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    ExpandBranchItemNameArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As ExpandBranchItemNameArgs _
)
Visual C++
public:
virtual void Process(
    ExpandBranchItemNameArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.ExpandBranchItemName..::..ExpandBranchItemNameArgs
The args.

See Also

ReplaceVariables Class
Sitecore.Pipelines.ExpandBranchItemName Namespace


Sitecore.Pipelines.ExpandInitialFieldValue Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.ExpandInitialFieldValue Namespace
Send Feedback

Classes

 | Class | Description
Public class | ExpandInitialFieldValueArgs | InitializeFieldValuesArgs
Public class | ExpandInitialFieldValueProcessor | ExpandInitialFieldValueProcessor class
Public class | ReplaceVariables | ReplaceVariables
Public class | SkipStandardValueItems | SkipStandardValueItems class


ExpandInitialFieldValueArgs Class

[image]

Sitecore 6.4.1 API
ExpandInitialFieldValueArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.ExpandInitialFieldValue
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class ExpandInitialFieldValueArgs : PipelineArgs
Visual Basic
<SerializableAttribute> _
Public Class ExpandInitialFieldValueArgs _
    Inherits PipelineArgs
Visual C++
[SerializableAttribute]
public ref class ExpandInitialFieldValueArgs : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Pipelines.ExpandInitialFieldValue..::..ExpandInitialFieldValueArgs

See Also

ExpandInitialFieldValueArgs Members
Sitecore.Pipelines.ExpandInitialFieldValue Namespace


ExpandInitialFieldValueArgs Members

[image] [image]

Sitecore 6.4.1 API
ExpandInitialFieldValueArgs Members
ExpandInitialFieldValueArgs Class Constructors Methods Properties See Also Send Feedback

The ExpandInitialFieldValueArgs type exposes the following members.

Constructors

 | Name | Description
Protected method | ExpandInitialFieldValueArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the ExpandInitialFieldValueArgs class.
Public method | ExpandInitialFieldValueArgs(Field, Item) | Initializes a new instance of the ExpandInitialFieldValueArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Result | Gets or sets the result.
Public property | ResultModified | Gets a value indicating whether [result modified].
Public property | SourceField | Gets the source field.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
Public property | TargetItem | Gets the target item.

See Also

ExpandInitialFieldValueArgs Class
Sitecore.Pipelines.ExpandInitialFieldValue Namespace


ExpandInitialFieldValueArgs Constructor

[image] [image]

Sitecore 6.4.1 API
ExpandInitialFieldValueArgs Constructor
ExpandInitialFieldValueArgs Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | ExpandInitialFieldValueArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the ExpandInitialFieldValueArgs class.
Public method | ExpandInitialFieldValueArgs(Field, Item) | Initializes a new instance of the ExpandInitialFieldValueArgs class.

See Also

ExpandInitialFieldValueArgs Class
ExpandInitialFieldValueArgs Members
Sitecore.Pipelines.ExpandInitialFieldValue Namespace


ExpandInitialFieldValueArgs Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
ExpandInitialFieldValueArgs Constructor (SerializationInfo, StreamingContext)
ExpandInitialFieldValueArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ExpandInitialFieldValue
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected ExpandInitialFieldValueArgs(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
ExpandInitialFieldValueArgs(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

ExpandInitialFieldValueArgs Class
ExpandInitialFieldValueArgs Overload
Sitecore.Pipelines.ExpandInitialFieldValue Namespace


ExpandInitialFieldValueArgs Constructor (Field, Item)

[image]

Sitecore 6.4.1 API
ExpandInitialFieldValueArgs Constructor (Field, Item)
ExpandInitialFieldValueArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ExpandInitialFieldValue
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ExpandInitialFieldValueArgs(
    Field sourceField,
    Item targetItem
)
Visual Basic
Public Sub New ( _
    sourceField As Field, _
    targetItem As Item _
)
Visual C++
public:
ExpandInitialFieldValueArgs(
    Field^ sourceField,
    Item^ targetItem
)

Parameters

sourceField
Type: Sitecore.Data.Fields..::..Field
The source field.
targetItem
Type: Sitecore.Data.Items..::..Item
The target item.

See Also

ExpandInitialFieldValueArgs Class
ExpandInitialFieldValueArgs Overload
Sitecore.Pipelines.ExpandInitialFieldValue Namespace


ExpandInitialFieldValueArgs Methods

[image] [image]

Sitecore 6.4.1 API
ExpandInitialFieldValueArgs Methods
ExpandInitialFieldValueArgs Class See Also Send Feedback

The ExpandInitialFieldValueArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExpandInitialFieldValueArgs Class
Sitecore.Pipelines.ExpandInitialFieldValue Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
ExpandInitialFieldValueArgs..::..GetMessages Method
ExpandInitialFieldValueArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

ExpandInitialFieldValueArgs Class
ExpandInitialFieldValueArgs Members
Sitecore.Pipelines.ExpandInitialFieldValue Namespace


GetObjectData Method

[image]

Sitecore 6.4.1 API
ExpandInitialFieldValueArgs..::..GetObjectData Method
ExpandInitialFieldValueArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ExpandInitialFieldValue
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System.Security..::..SecurityException | The caller does not have the required permission.

See Also

ExpandInitialFieldValueArgs Class
Sitecore.Pipelines.ExpandInitialFieldValue Namespace


ExpandInitialFieldValueArgs Properties

[image] [image]

Sitecore 6.4.1 API
ExpandInitialFieldValueArgs Properties
ExpandInitialFieldValueArgs Class See Also Send Feedback

The ExpandInitialFieldValueArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Result | Gets or sets the result.
Public property | ResultModified | Gets a value indicating whether [result modified].
Public property | SourceField | Gets the source field.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
Public property | TargetItem | Gets the target item.

See Also

ExpandInitialFieldValueArgs Class
Sitecore.Pipelines.ExpandInitialFieldValue Namespace


Result Property

[image]

Sitecore 6.4.1 API
ExpandInitialFieldValueArgs..::..Result Property
ExpandInitialFieldValueArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ExpandInitialFieldValue
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Result { get; set; }
Visual Basic
Public Property Result As String
    Get
    Set
Visual C++
public:
property String^ Result {
    String^ get ();
    void set (String^ value);
}

Field Value

The result.

See Also

ExpandInitialFieldValueArgs Class
Sitecore.Pipelines.ExpandInitialFieldValue Namespace


ResultModified Property

[image]

Sitecore 6.4.1 API
ExpandInitialFieldValueArgs..::..ResultModified Property
ExpandInitialFieldValueArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ExpandInitialFieldValue
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ResultModified { get; }
Visual Basic
Public ReadOnly Property ResultModified As Boolean
    Get
Visual C++
public:
property bool ResultModified {
    bool get ();
}

Field Value

true if [result modified]; otherwise, false.

See Also

ExpandInitialFieldValueArgs Class
Sitecore.Pipelines.ExpandInitialFieldValue Namespace


SourceField Property

[image]

Sitecore 6.4.1 API
ExpandInitialFieldValueArgs..::..SourceField Property
ExpandInitialFieldValueArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ExpandInitialFieldValue
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Field SourceField { get; }
Visual Basic
Public ReadOnly Property SourceField As Field
    Get
Visual C++
public:
property Field^ SourceField {
    Field^ get ();
}

Field Value

The source field.

See Also

ExpandInitialFieldValueArgs Class
Sitecore.Pipelines.ExpandInitialFieldValue Namespace


TargetItem Property

[image]

Sitecore 6.4.1 API
ExpandInitialFieldValueArgs..::..TargetItem Property
ExpandInitialFieldValueArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ExpandInitialFieldValue
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item TargetItem { get; }
Visual Basic
Public ReadOnly Property TargetItem As Item
    Get
Visual C++
public:
property Item^ TargetItem {
    Item^ get ();
}

Field Value

The target item.

See Also

ExpandInitialFieldValueArgs Class
Sitecore.Pipelines.ExpandInitialFieldValue Namespace


ExpandInitialFieldValueProcessor Class

[image]

Sitecore 6.4.1 API
ExpandInitialFieldValueProcessor Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.ExpandInitialFieldValue
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class ExpandInitialFieldValueProcessor
Visual Basic
Public MustInherit Class ExpandInitialFieldValueProcessor
Visual C++
public ref class ExpandInitialFieldValueProcessor abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.ExpandInitialFieldValue..::..ExpandInitialFieldValueProcessor
Sitecore.Pipelines.ExpandInitialFieldValue..::..ReplaceVariables
Sitecore.Pipelines.ExpandInitialFieldValue..::..SkipStandardValueItems

See Also

ExpandInitialFieldValueProcessor Members
Sitecore.Pipelines.ExpandInitialFieldValue Namespace


ExpandInitialFieldValueProcessor Members

[image] [image]

Sitecore 6.4.1 API
ExpandInitialFieldValueProcessor Members
ExpandInitialFieldValueProcessor Class Constructors Methods See Also Send Feedback

The ExpandInitialFieldValueProcessor type exposes the following members.

Constructors

 | Name | Description
Protected method | ExpandInitialFieldValueProcessor | Initializes a new instance of the ExpandInitialFieldValueProcessor class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExpandInitialFieldValueProcessor Class
Sitecore.Pipelines.ExpandInitialFieldValue Namespace


ExpandInitialFieldValueProcessor Constructor

[image]

Sitecore 6.4.1 API
ExpandInitialFieldValueProcessor Constructor
ExpandInitialFieldValueProcessor Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ExpandInitialFieldValue
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected ExpandInitialFieldValueProcessor()
Visual Basic
Protected Sub New
Visual C++
protected:
ExpandInitialFieldValueProcessor()

See Also

ExpandInitialFieldValueProcessor Class
Sitecore.Pipelines.ExpandInitialFieldValue Namespace


ExpandInitialFieldValueProcessor Methods

[image] [image]

Sitecore 6.4.1 API
ExpandInitialFieldValueProcessor Methods
ExpandInitialFieldValueProcessor Class See Also Send Feedback

The ExpandInitialFieldValueProcessor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExpandInitialFieldValueProcessor Class
Sitecore.Pipelines.ExpandInitialFieldValue Namespace


Process Method

[image]

Sitecore 6.4.1 API
ExpandInitialFieldValueProcessor..::..Process Method
ExpandInitialFieldValueProcessor Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ExpandInitialFieldValue
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract void Process(
    ExpandInitialFieldValueArgs args
)
Visual Basic
Public MustOverride Sub Process ( _
    args As ExpandInitialFieldValueArgs _
)
Visual C++
public:
virtual void Process(
    ExpandInitialFieldValueArgs^ args
) abstract

Parameters

args
Type: Sitecore.Pipelines.ExpandInitialFieldValue..::..ExpandInitialFieldValueArgs
The args.

See Also

ExpandInitialFieldValueProcessor Class
Sitecore.Pipelines.ExpandInitialFieldValue Namespace


ReplaceVariables Class

[image]

Sitecore 6.4.1 API
ReplaceVariables Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.ExpandInitialFieldValue
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ReplaceVariables : ExpandInitialFieldValueProcessor
Visual Basic
Public Class ReplaceVariables _
    Inherits ExpandInitialFieldValueProcessor
Visual C++
public ref class ReplaceVariables : public ExpandInitialFieldValueProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.ExpandInitialFieldValue..::..ExpandInitialFieldValueProcessor
Sitecore.Pipelines.ExpandInitialFieldValue..::..ReplaceVariables

See Also

ReplaceVariables Members
Sitecore.Pipelines.ExpandInitialFieldValue Namespace


ReplaceVariables Members

[image] [image]

Sitecore 6.4.1 API
ReplaceVariables Members
ReplaceVariables Class Constructors Methods See Also Send Feedback

The ReplaceVariables type exposes the following members.

Constructors

 | Name | Description
Public method | ReplaceVariables | Initializes a new instance of the ReplaceVariables class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides ExpandInitialFieldValueProcessor..::..Process(ExpandInitialFieldValueArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReplaceVariables Class
Sitecore.Pipelines.ExpandInitialFieldValue Namespace


ReplaceVariables Constructor

[image]

Sitecore 6.4.1 API
ReplaceVariables Constructor
ReplaceVariables Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ExpandInitialFieldValue
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ReplaceVariables()
Visual Basic
Public Sub New
Visual C++
public:
ReplaceVariables()

See Also

ReplaceVariables Class
Sitecore.Pipelines.ExpandInitialFieldValue Namespace


ReplaceVariables Methods

[image] [image]

Sitecore 6.4.1 API
ReplaceVariables Methods
ReplaceVariables Class See Also Send Feedback

The ReplaceVariables type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides ExpandInitialFieldValueProcessor..::..Process(ExpandInitialFieldValueArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReplaceVariables Class
Sitecore.Pipelines.ExpandInitialFieldValue Namespace


Process Method

[image]

Sitecore 6.4.1 API
ReplaceVariables..::..Process Method
ReplaceVariables Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ExpandInitialFieldValue
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    ExpandInitialFieldValueArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As ExpandInitialFieldValueArgs _
)
Visual C++
public:
virtual void Process(
    ExpandInitialFieldValueArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.ExpandInitialFieldValue..::..ExpandInitialFieldValueArgs
The args.

See Also

ReplaceVariables Class
Sitecore.Pipelines.ExpandInitialFieldValue Namespace


SkipStandardValueItems Class

[image]

Sitecore 6.4.1 API
SkipStandardValueItems Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.ExpandInitialFieldValue
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SkipStandardValueItems : ExpandInitialFieldValueProcessor
Visual Basic
Public Class SkipStandardValueItems _
    Inherits ExpandInitialFieldValueProcessor
Visual C++
public ref class SkipStandardValueItems : public ExpandInitialFieldValueProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.ExpandInitialFieldValue..::..ExpandInitialFieldValueProcessor
Sitecore.Pipelines.ExpandInitialFieldValue..::..SkipStandardValueItems

See Also

SkipStandardValueItems Members
Sitecore.Pipelines.ExpandInitialFieldValue Namespace


SkipStandardValueItems Members

[image] [image]

Sitecore 6.4.1 API
SkipStandardValueItems Members
SkipStandardValueItems Class Constructors Methods See Also Send Feedback

The SkipStandardValueItems type exposes the following members.

Constructors

 | Name | Description
Public method | SkipStandardValueItems | Initializes a new instance of the SkipStandardValueItems class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides ExpandInitialFieldValueProcessor..::..Process(ExpandInitialFieldValueArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SkipStandardValueItems Class
Sitecore.Pipelines.ExpandInitialFieldValue Namespace


SkipStandardValueItems Constructor

[image]

Sitecore 6.4.1 API
SkipStandardValueItems Constructor
SkipStandardValueItems Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ExpandInitialFieldValue
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SkipStandardValueItems()
Visual Basic
Public Sub New
Visual C++
public:
SkipStandardValueItems()

See Also

SkipStandardValueItems Class
Sitecore.Pipelines.ExpandInitialFieldValue Namespace


SkipStandardValueItems Methods

[image] [image]

Sitecore 6.4.1 API
SkipStandardValueItems Methods
SkipStandardValueItems Class See Also Send Feedback

The SkipStandardValueItems type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides ExpandInitialFieldValueProcessor..::..Process(ExpandInitialFieldValueArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SkipStandardValueItems Class
Sitecore.Pipelines.ExpandInitialFieldValue Namespace


Process Method

[image]

Sitecore 6.4.1 API
SkipStandardValueItems..::..Process Method
SkipStandardValueItems Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ExpandInitialFieldValue
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    ExpandInitialFieldValueArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As ExpandInitialFieldValueArgs _
)
Visual C++
public:
virtual void Process(
    ExpandInitialFieldValueArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.ExpandInitialFieldValue..::..ExpandInitialFieldValueArgs
The args.

See Also

SkipStandardValueItems Class
Sitecore.Pipelines.ExpandInitialFieldValue Namespace


Sitecore.Pipelines.FilterItem Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.FilterItem Namespace
Send Feedback

Classes

 | Class | Description
Public class | FilterItemPipelineArgs | The filter item pipline args.


FilterItemPipelineArgs Class

[image]

Sitecore 6.4.1 API
FilterItemPipelineArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.FilterItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FilterItemPipelineArgs : PipelineArgs
Visual Basic
Public Class FilterItemPipelineArgs _
    Inherits PipelineArgs
Visual C++
public ref class FilterItemPipelineArgs : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Pipelines.FilterItem..::..FilterItemPipelineArgs

See Also

FilterItemPipelineArgs Members
Sitecore.Pipelines.FilterItem Namespace


FilterItemPipelineArgs Members

[image] [image]

Sitecore 6.4.1 API
FilterItemPipelineArgs Members
FilterItemPipelineArgs Class Constructors Methods Properties See Also Send Feedback

The FilterItemPipelineArgs type exposes the following members.

Constructors

 | Name | Description
Public method | FilterItemPipelineArgs | Initializes a new instance of the FilterItemPipelineArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | FilteredItem | Gets or sets the filtered item (i.e. the result of processing).
Public property | Item | Gets or sets the item.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | RequestedVersion | Gets or sets the requested version.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

FilterItemPipelineArgs Class
Sitecore.Pipelines.FilterItem Namespace


FilterItemPipelineArgs Constructor

[image]

Sitecore 6.4.1 API
FilterItemPipelineArgs Constructor
FilterItemPipelineArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.FilterItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FilterItemPipelineArgs(
    Item item,
    Version requestedVersion
)
Visual Basic
Public Sub New ( _
    item As Item, _
    requestedVersion As Version _
)
Visual C++
public:
FilterItemPipelineArgs(
    Item^ item,
    Version^ requestedVersion
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
requestedVersion
Type: Sitecore.Data..::..Version
The requested version.

See Also

FilterItemPipelineArgs Class
Sitecore.Pipelines.FilterItem Namespace


FilterItemPipelineArgs Methods

[image] [image]

Sitecore 6.4.1 API
FilterItemPipelineArgs Methods
FilterItemPipelineArgs Class See Also Send Feedback

The FilterItemPipelineArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterItemPipelineArgs Class
Sitecore.Pipelines.FilterItem Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
FilterItemPipelineArgs..::..GetMessages Method
FilterItemPipelineArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

FilterItemPipelineArgs Class
FilterItemPipelineArgs Members
Sitecore.Pipelines.FilterItem Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
FilterItemPipelineArgs..::..Suspend Method
FilterItemPipelineArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

FilterItemPipelineArgs Class
FilterItemPipelineArgs Members
Sitecore.Pipelines.FilterItem Namespace


FilterItemPipelineArgs Properties

[image] [image]

Sitecore 6.4.1 API
FilterItemPipelineArgs Properties
FilterItemPipelineArgs Class See Also Send Feedback

The FilterItemPipelineArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | FilteredItem | Gets or sets the filtered item (i.e. the result of processing).
Public property | Item | Gets or sets the item.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | RequestedVersion | Gets or sets the requested version.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

FilterItemPipelineArgs Class
Sitecore.Pipelines.FilterItem Namespace


FilteredItem Property

[image]

Sitecore 6.4.1 API
FilterItemPipelineArgs..::..FilteredItem Property
FilterItemPipelineArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.FilterItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item FilteredItem { get; set; }
Visual Basic
Public Property FilteredItem As Item
    Get
    Set
Visual C++
public:
property Item^ FilteredItem {
    Item^ get ();
    void set (Item^ value);
}

Field Value

The filtered item.

See Also

FilterItemPipelineArgs Class
Sitecore.Pipelines.FilterItem Namespace


Item Property

[image]

Sitecore 6.4.1 API
FilterItemPipelineArgs..::..Item Property
FilterItemPipelineArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.FilterItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Item { get; protected set; }
Visual Basic
Public Property Item As Item
    Get
    Protected Set
Visual C++
public:
property Item^ Item {
    Item^ get ();
    protected: void set (Item^ value);
}

Field Value

The item.

See Also

FilterItemPipelineArgs Class
Sitecore.Pipelines.FilterItem Namespace


RequestedVersion Property

[image]

Sitecore 6.4.1 API
FilterItemPipelineArgs..::..RequestedVersion Property
FilterItemPipelineArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.FilterItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Version RequestedVersion { get; protected set; }
Visual Basic
Public Property RequestedVersion As Version
    Get
    Protected Set
Visual C++
public:
property Version^ RequestedVersion {
    Version^ get ();
    protected: void set (Version^ value);
}

Field Value

The requested version.

See Also

FilterItemPipelineArgs Class
Sitecore.Pipelines.FilterItem Namespace


Sitecore.Pipelines.FixXHtml Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.FixXHtml Namespace
Send Feedback

Classes

 | Class | Description
Public class | CheckSchema | Implements the ShortenLinks.
Public class | ConvertToXHtml |
Public class | FixXHtmlArgs | Implements the RenderField.
Public class | FixXHtmlProcessor | Implements the RenderField.
Public class | PrepareHtml | Implements the ShortenLinks.
Public class | RemoveEmptySpans | Implements the ShortenLinks.


CheckSchema Class

[image]

Sitecore 6.4.1 API
CheckSchema Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.FixXHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CheckSchema : FixXHtmlProcessor
Visual Basic
Public Class CheckSchema _
    Inherits FixXHtmlProcessor
Visual C++
public ref class CheckSchema : public FixXHtmlProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.FixXHtml..::..FixXHtmlProcessor
Sitecore.Pipelines.FixXHtml..::..CheckSchema

See Also

CheckSchema Members
Sitecore.Pipelines.FixXHtml Namespace


CheckSchema Members

[image] [image]

Sitecore 6.4.1 API
CheckSchema Members
CheckSchema Class Constructors Methods See Also Send Feedback

The CheckSchema type exposes the following members.

Constructors

 | Name | Description
Public method | CheckSchema | Initializes a new instance of the CheckSchema class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides FixXHtmlProcessor..::..Process(FixXHtmlArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckSchema Class
Sitecore.Pipelines.FixXHtml Namespace


CheckSchema Constructor

[image]

Sitecore 6.4.1 API
CheckSchema Constructor
CheckSchema Class See Also Send Feedback

Namespace: Sitecore.Pipelines.FixXHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CheckSchema()
Visual Basic
Public Sub New
Visual C++
public:
CheckSchema()

See Also

CheckSchema Class
Sitecore.Pipelines.FixXHtml Namespace


CheckSchema Methods

[image] [image]

Sitecore 6.4.1 API
CheckSchema Methods
CheckSchema Class See Also Send Feedback

The CheckSchema type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides FixXHtmlProcessor..::..Process(FixXHtmlArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckSchema Class
Sitecore.Pipelines.FixXHtml Namespace


Process Method

[image]

Sitecore 6.4.1 API
CheckSchema..::..Process Method
CheckSchema Class See Also Send Feedback

Namespace: Sitecore.Pipelines.FixXHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    FixXHtmlArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As FixXHtmlArgs _
)
Visual C++
public:
virtual void Process(
    FixXHtmlArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.FixXHtml..::..FixXHtmlArgs
The arguments.

See Also

CheckSchema Class
Sitecore.Pipelines.FixXHtml Namespace


ConvertToXHtml Class

[image]

Sitecore 6.4.1 API
ConvertToXHtml Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.FixXHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ConvertToXHtml : FixXHtmlProcessor
Visual Basic
Public Class ConvertToXHtml _
    Inherits FixXHtmlProcessor
Visual C++
public ref class ConvertToXHtml : public FixXHtmlProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.FixXHtml..::..FixXHtmlProcessor
Sitecore.Pipelines.FixXHtml..::..ConvertToXHtml

See Also

ConvertToXHtml Members
Sitecore.Pipelines.FixXHtml Namespace


ConvertToXHtml Members

[image] [image]

Sitecore 6.4.1 API
ConvertToXHtml Members
ConvertToXHtml Class Constructors Methods See Also Send Feedback

The ConvertToXHtml type exposes the following members.

Constructors

 | Name | Description
Public method | ConvertToXHtml | Initializes a new instance of the ConvertToXHtml class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides FixXHtmlProcessor..::..Process(FixXHtmlArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConvertToXHtml Class
Sitecore.Pipelines.FixXHtml Namespace


ConvertToXHtml Constructor

[image]

Sitecore 6.4.1 API
ConvertToXHtml Constructor
ConvertToXHtml Class See Also Send Feedback

Namespace: Sitecore.Pipelines.FixXHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ConvertToXHtml()
Visual Basic
Public Sub New
Visual C++
public:
ConvertToXHtml()

See Also

ConvertToXHtml Class
Sitecore.Pipelines.FixXHtml Namespace


ConvertToXHtml Methods

[image] [image]

Sitecore 6.4.1 API
ConvertToXHtml Methods
ConvertToXHtml Class See Also Send Feedback

The ConvertToXHtml type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides FixXHtmlProcessor..::..Process(FixXHtmlArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConvertToXHtml Class
Sitecore.Pipelines.FixXHtml Namespace


Process Method

[image]

Sitecore 6.4.1 API
ConvertToXHtml..::..Process Method
ConvertToXHtml Class See Also Send Feedback

Namespace: Sitecore.Pipelines.FixXHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    FixXHtmlArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As FixXHtmlArgs _
)
Visual C++
public:
virtual void Process(
    FixXHtmlArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.FixXHtml..::..FixXHtmlArgs
The arguments.

See Also

ConvertToXHtml Class
Sitecore.Pipelines.FixXHtml Namespace


FixXHtmlArgs Class

[image]

Sitecore 6.4.1 API
FixXHtmlArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.FixXHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class FixXHtmlArgs : PipelineArgs
Visual Basic
<SerializableAttribute> _
Public Class FixXHtmlArgs _
    Inherits PipelineArgs
Visual C++
[SerializableAttribute]
public ref class FixXHtmlArgs : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Pipelines.FixXHtml..::..FixXHtmlArgs

See Also

FixXHtmlArgs Members
Sitecore.Pipelines.FixXHtml Namespace


FixXHtmlArgs Constructor

[image] [image]

Sitecore 6.4.1 API
FixXHtmlArgs Constructor
FixXHtmlArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FixXHtmlArgs(String) | Initializes a new instance of the RenderItemTileArgs class.
Protected method | FixXHtmlArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the FixXHtmlArgs class.

See Also

FixXHtmlArgs Class
FixXHtmlArgs Members
Sitecore.Pipelines.FixXHtml Namespace


FixXHtmlArgs Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
FixXHtmlArgs Constructor (SerializationInfo, StreamingContext)
FixXHtmlArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.FixXHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected FixXHtmlArgs(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
FixXHtmlArgs(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

FixXHtmlArgs Class
FixXHtmlArgs Overload
Sitecore.Pipelines.FixXHtml Namespace


FixXHtmlArgs Methods

[image] [image]

Sitecore 6.4.1 API
FixXHtmlArgs Methods
FixXHtmlArgs Class See Also Send Feedback

The FixXHtmlArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FixXHtmlArgs Class
Sitecore.Pipelines.FixXHtml Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
FixXHtmlArgs..::..AddMessage Method
FixXHtmlArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

FixXHtmlArgs Class
FixXHtmlArgs Members
Sitecore.Pipelines.FixXHtml Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
FixXHtmlArgs..::..GetMessages Method
FixXHtmlArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

FixXHtmlArgs Class
FixXHtmlArgs Members
Sitecore.Pipelines.FixXHtml Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
FixXHtmlArgs..::..Suspend Method
FixXHtmlArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

FixXHtmlArgs Class
FixXHtmlArgs Members
Sitecore.Pipelines.FixXHtml Namespace


FixXHtmlArgs Properties

[image] [image]

Sitecore 6.4.1 API
FixXHtmlArgs Properties
FixXHtmlArgs Class See Also Send Feedback

The FixXHtmlArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Html | Gets or sets the HTML.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

FixXHtmlArgs Class
Sitecore.Pipelines.FixXHtml Namespace


Html Property

[image]

Sitecore 6.4.1 API
FixXHtmlArgs..::..Html Property
FixXHtmlArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.FixXHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Html { get; set; }
Visual Basic
Public Property Html As String
    Get
    Set
Visual C++
public:
property String^ Html {
    String^ get ();
    void set (String^ value);
}

Field Value

The HTML.

See Also

FixXHtmlArgs Class
Sitecore.Pipelines.FixXHtml Namespace


FixXHtmlProcessor Class

[image]

Sitecore 6.4.1 API
FixXHtmlProcessor Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.FixXHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class FixXHtmlProcessor
Visual Basic
Public MustInherit Class FixXHtmlProcessor
Visual C++
public ref class FixXHtmlProcessor abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.FixXHtml..::..FixXHtmlProcessor
Sitecore.Pipelines.FixXHtml..::..CheckSchema
Sitecore.Pipelines.FixXHtml..::..ConvertToXHtml
Sitecore.Pipelines.FixXHtml..::..PrepareHtml
Sitecore.Pipelines.FixXHtml..::..RemoveEmptySpans

See Also

FixXHtmlProcessor Members
Sitecore.Pipelines.FixXHtml Namespace


FixXHtmlProcessor Members

[image] [image]

Sitecore 6.4.1 API
FixXHtmlProcessor Members
FixXHtmlProcessor Class Constructors Methods See Also Send Feedback

The FixXHtmlProcessor type exposes the following members.

Constructors

 | Name | Description
Protected method | FixXHtmlProcessor | Initializes a new instance of the FixXHtmlProcessor class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FixXHtmlProcessor Class
Sitecore.Pipelines.FixXHtml Namespace


FixXHtmlProcessor Constructor

[image]

Sitecore 6.4.1 API
FixXHtmlProcessor Constructor
FixXHtmlProcessor Class See Also Send Feedback

Namespace: Sitecore.Pipelines.FixXHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected FixXHtmlProcessor()
Visual Basic
Protected Sub New
Visual C++
protected:
FixXHtmlProcessor()

See Also

FixXHtmlProcessor Class
Sitecore.Pipelines.FixXHtml Namespace


FixXHtmlProcessor Methods

[image] [image]

Sitecore 6.4.1 API
FixXHtmlProcessor Methods
FixXHtmlProcessor Class See Also Send Feedback

The FixXHtmlProcessor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FixXHtmlProcessor Class
Sitecore.Pipelines.FixXHtml Namespace


Process Method

[image]

Sitecore 6.4.1 API
FixXHtmlProcessor..::..Process Method
FixXHtmlProcessor Class See Also Send Feedback

Namespace: Sitecore.Pipelines.FixXHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract void Process(
    FixXHtmlArgs args
)
Visual Basic
Public MustOverride Sub Process ( _
    args As FixXHtmlArgs _
)
Visual C++
public:
virtual void Process(
    FixXHtmlArgs^ args
) abstract

Parameters

args
Type: Sitecore.Pipelines.FixXHtml..::..FixXHtmlArgs
The arguments.

See Also

FixXHtmlProcessor Class
Sitecore.Pipelines.FixXHtml Namespace


PrepareHtml Members

[image] [image]

Sitecore 6.4.1 API
PrepareHtml Members
PrepareHtml Class Constructors Methods See Also Send Feedback

The PrepareHtml type exposes the following members.

Constructors

 | Name | Description
Public method | PrepareHtml | Initializes a new instance of the PrepareHtml class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides FixXHtmlProcessor..::..Process(FixXHtmlArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PrepareHtml Class
Sitecore.Pipelines.FixXHtml Namespace


PrepareHtml Constructor

[image]

Sitecore 6.4.1 API
PrepareHtml Constructor
PrepareHtml Class See Also Send Feedback

Namespace: Sitecore.Pipelines.FixXHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PrepareHtml()
Visual Basic
Public Sub New
Visual C++
public:
PrepareHtml()

See Also

PrepareHtml Class
Sitecore.Pipelines.FixXHtml Namespace


PrepareHtml Methods

[image] [image]

Sitecore 6.4.1 API
PrepareHtml Methods
PrepareHtml Class See Also Send Feedback

The PrepareHtml type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides FixXHtmlProcessor..::..Process(FixXHtmlArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PrepareHtml Class
Sitecore.Pipelines.FixXHtml Namespace


Process Method

[image]

Sitecore 6.4.1 API
PrepareHtml..::..Process Method
PrepareHtml Class See Also Send Feedback

Namespace: Sitecore.Pipelines.FixXHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    FixXHtmlArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As FixXHtmlArgs _
)
Visual C++
public:
virtual void Process(
    FixXHtmlArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.FixXHtml..::..FixXHtmlArgs
The arguments.

See Also

PrepareHtml Class
Sitecore.Pipelines.FixXHtml Namespace


RemoveEmptySpans Class

[image]

Sitecore 6.4.1 API
RemoveEmptySpans Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.FixXHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RemoveEmptySpans : FixXHtmlProcessor
Visual Basic
Public Class RemoveEmptySpans _
    Inherits FixXHtmlProcessor
Visual C++
public ref class RemoveEmptySpans : public FixXHtmlProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.FixXHtml..::..FixXHtmlProcessor
Sitecore.Pipelines.FixXHtml..::..RemoveEmptySpans

See Also

RemoveEmptySpans Members
Sitecore.Pipelines.FixXHtml Namespace


RemoveEmptySpans Members

[image] [image]

Sitecore 6.4.1 API
RemoveEmptySpans Members
RemoveEmptySpans Class Constructors Methods See Also Send Feedback

The RemoveEmptySpans type exposes the following members.

Constructors

 | Name | Description
Public method | RemoveEmptySpans | Initializes a new instance of the RemoveEmptySpans class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides FixXHtmlProcessor..::..Process(FixXHtmlArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RemoveEmptySpans Class
Sitecore.Pipelines.FixXHtml Namespace


RemoveEmptySpans Constructor

[image]

Sitecore 6.4.1 API
RemoveEmptySpans Constructor
RemoveEmptySpans Class See Also Send Feedback

Namespace: Sitecore.Pipelines.FixXHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RemoveEmptySpans()
Visual Basic
Public Sub New
Visual C++
public:
RemoveEmptySpans()

See Also

RemoveEmptySpans Class
Sitecore.Pipelines.FixXHtml Namespace


RemoveEmptySpans Methods

[image] [image]

Sitecore 6.4.1 API
RemoveEmptySpans Methods
RemoveEmptySpans Class See Also Send Feedback

The RemoveEmptySpans type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides FixXHtmlProcessor..::..Process(FixXHtmlArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RemoveEmptySpans Class
Sitecore.Pipelines.FixXHtml Namespace


Process Method

[image]

Sitecore 6.4.1 API
RemoveEmptySpans..::..Process Method
RemoveEmptySpans Class See Also Send Feedback

Namespace: Sitecore.Pipelines.FixXHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    FixXHtmlArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As FixXHtmlArgs _
)
Visual C++
public:
virtual void Process(
    FixXHtmlArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.FixXHtml..::..FixXHtmlArgs
The arguments.

See Also

RemoveEmptySpans Class
Sitecore.Pipelines.FixXHtml Namespace


Sitecore.Pipelines.GetAboutInformation Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.GetAboutInformation Namespace
Send Feedback

Classes

 | Class | Description
Public class | GetAboutInformationArgs | Pipeline arguments for getAboutInformation pipeline.


GetAboutInformationArgs Class

[image]

Sitecore 6.4.1 API
GetAboutInformationArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetAboutInformation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetAboutInformationArgs : PipelineArgs
Visual Basic
Public Class GetAboutInformationArgs _
    Inherits PipelineArgs
Visual C++
public ref class GetAboutInformationArgs : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Pipelines.GetAboutInformation..::..GetAboutInformationArgs

See Also

GetAboutInformationArgs Members
Sitecore.Pipelines.GetAboutInformation Namespace


GetAboutInformationArgs Members

[image] [image]

Sitecore 6.4.1 API
GetAboutInformationArgs Members
GetAboutInformationArgs Class Constructors Methods Properties See Also Send Feedback

The GetAboutInformationArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GetAboutInformationArgs | Initializes a new instance of the GetAboutInformationArgs class

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | AboutText | Gets or sets the about text.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | LoginPageText | Gets or sets the login screen text.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

GetAboutInformationArgs Class
Sitecore.Pipelines.GetAboutInformation Namespace


GetAboutInformationArgs Constructor

[image]

Sitecore 6.4.1 API
GetAboutInformationArgs Constructor
GetAboutInformationArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetAboutInformation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetAboutInformationArgs()
Visual Basic
Public Sub New
Visual C++
public:
GetAboutInformationArgs()

See Also

GetAboutInformationArgs Class
Sitecore.Pipelines.GetAboutInformation Namespace


GetAboutInformationArgs Methods

[image] [image]

Sitecore 6.4.1 API
GetAboutInformationArgs Methods
GetAboutInformationArgs Class See Also Send Feedback

The GetAboutInformationArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetAboutInformationArgs Class
Sitecore.Pipelines.GetAboutInformation Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
GetAboutInformationArgs..::..AddMessage Method
GetAboutInformationArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

GetAboutInformationArgs Class
GetAboutInformationArgs Members
Sitecore.Pipelines.GetAboutInformation Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
GetAboutInformationArgs..::..GetMessages Method
GetAboutInformationArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

GetAboutInformationArgs Class
GetAboutInformationArgs Members
Sitecore.Pipelines.GetAboutInformation Namespace


GetAboutInformationArgs Properties

[image] [image]

Sitecore 6.4.1 API
GetAboutInformationArgs Properties
GetAboutInformationArgs Class See Also Send Feedback

The GetAboutInformationArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | AboutText | Gets or sets the about text.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | LoginPageText | Gets or sets the login screen text.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

GetAboutInformationArgs Class
Sitecore.Pipelines.GetAboutInformation Namespace


AboutText Property

[image]

Sitecore 6.4.1 API
GetAboutInformationArgs..::..AboutText Property
GetAboutInformationArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetAboutInformation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string AboutText { get; set; }
Visual Basic
Public Property AboutText As String
    Get
    Set
Visual C++
public:
property String^ AboutText {
    String^ get ();
    void set (String^ value);
}

Field Value

The about text.

See Also

GetAboutInformationArgs Class
Sitecore.Pipelines.GetAboutInformation Namespace


LoginPageText Property

[image]

Sitecore 6.4.1 API
GetAboutInformationArgs..::..LoginPageText Property
GetAboutInformationArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetAboutInformation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string LoginPageText { get; set; }
Visual Basic
Public Property LoginPageText As String
    Get
    Set
Visual C++
public:
property String^ LoginPageText {
    String^ get ();
    void set (String^ value);
}

Field Value

The login screen text.

See Also

GetAboutInformationArgs Class
Sitecore.Pipelines.GetAboutInformation Namespace


Sitecore.Pipelines.GetChromeData Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.GetChromeData Namespace
Send Feedback

Classes

 | Class | Description
Public class | GetChromeDataArgs | The populate chrome data args.
Public class | GetChromeDataPipeline | The getChromeData pipeline
Public class | GetChromeDataProcessor | The populate chrome data processor.
Public class | GetEditFrameChromeData | The get edit frame chrome data processor.
Public class | GetFieldChromeData | The get field chrome data processor.
Public class | GetPlaceholderChromeData | The placeholder chrome data processor.
Public class | GetRenderingChromeData | The get rendering chrome data processor.
Public class | GetWordFieldChromeData | The get word field webedit buttons.
Public class | Setup | The setup.


GetChromeDataArgs Class

[image]

Sitecore 6.4.1 API
GetChromeDataArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetChromeDataArgs : PipelineArgs
Visual Basic
Public Class GetChromeDataArgs _
    Inherits PipelineArgs
Visual C++
public ref class GetChromeDataArgs : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Pipelines.GetChromeData..::..GetChromeDataArgs

See Also

GetChromeDataArgs Members
Sitecore.Pipelines.GetChromeData Namespace


GetChromeDataArgs Members

[image] [image]

Sitecore 6.4.1 API
GetChromeDataArgs Members
GetChromeDataArgs Class Constructors Methods Properties See Also Send Feedback

The GetChromeDataArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GetChromeDataArgs(String) | Initializes a new instance of the GetChromeDataArgs class.
Public method | GetChromeDataArgs(String, Item) | Initializes a new instance of the GetChromeDataArgs class.
Public method | GetChromeDataArgs(String, Item, SafeDictionary<(Of <<'(String>)>>)) | Initializes a new instance of the GetChromeDataArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | ChromeData | Gets or sets ChromeData.
Public property | ChromeType | Gets ChromeType.
Public property | CommandContext | Gets or sets command context
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Item | Gets or sets the Sitecore item
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

GetChromeDataArgs Class
Sitecore.Pipelines.GetChromeData Namespace


GetChromeDataArgs Constructor

[image] [image]

Sitecore 6.4.1 API
GetChromeDataArgs Constructor
GetChromeDataArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChromeDataArgs(String) | Initializes a new instance of the GetChromeDataArgs class.
Public method | GetChromeDataArgs(String, Item) | Initializes a new instance of the GetChromeDataArgs class.
Public method | GetChromeDataArgs(String, Item, SafeDictionary<(Of <<'(String>)>>)) | Initializes a new instance of the GetChromeDataArgs class.

See Also

GetChromeDataArgs Class
GetChromeDataArgs Members
Sitecore.Pipelines.GetChromeData Namespace


GetChromeDataArgs Constructor (String)

[image]

Sitecore 6.4.1 API
GetChromeDataArgs Constructor (String)
GetChromeDataArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetChromeDataArgs(
    string chromeType
)
Visual Basic
Public Sub New ( _
    chromeType As String _
)
Visual C++
public:
GetChromeDataArgs(
    String^ chromeType
)

Parameters

chromeType
Type: System..::..String
The chrome type.

See Also

GetChromeDataArgs Class
GetChromeDataArgs Overload
Sitecore.Pipelines.GetChromeData Namespace


GetChromeDataArgs Constructor (String, Item)

[image]

Sitecore 6.4.1 API
GetChromeDataArgs Constructor (String, Item)
GetChromeDataArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetChromeDataArgs(
    string chromeType,
    Item item
)
Visual Basic
Public Sub New ( _
    chromeType As String, _
    item As Item _
)
Visual C++
public:
GetChromeDataArgs(
    String^ chromeType,
    Item^ item
)

Parameters

chromeType
Type: System..::..String
The chrome type.
item
Type: Sitecore.Data.Items..::..Item
The item

See Also

GetChromeDataArgs Class
GetChromeDataArgs Overload
Sitecore.Pipelines.GetChromeData Namespace


GetChromeDataArgs Constructor (String, Item, SafeDictionary(String))

[image]

Sitecore 6.4.1 API
GetChromeDataArgs Constructor (String, Item, SafeDictionary<(Of <(<'String>)>)>)
GetChromeDataArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetChromeDataArgs(
    string chromeType,
    Item item,
    SafeDictionary<string> parameters
)
Visual Basic
Public Sub New ( _
    chromeType As String, _
    item As Item, _
    parameters As SafeDictionary(Of String) _
)
Visual C++
public:
GetChromeDataArgs(
    String^ chromeType,
    Item^ item,
    SafeDictionary<String^>^ parameters
)

Parameters

chromeType
Type: System..::..String
The chrome type.
item
Type: Sitecore.Data.Items..::..Item
The item
parameters
Type: Sitecore.Collections..::..SafeDictionary <(Of <(<' String >)>)>
The parameters

See Also

GetChromeDataArgs Class
GetChromeDataArgs Overload
Sitecore.Pipelines.GetChromeData Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
GetChromeDataArgs..::..AddMessage Method
GetChromeDataArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

GetChromeDataArgs Class
GetChromeDataArgs Members
Sitecore.Pipelines.GetChromeData Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
GetChromeDataArgs..::..Suspend Method
GetChromeDataArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

GetChromeDataArgs Class
GetChromeDataArgs Members
Sitecore.Pipelines.GetChromeData Namespace


GetChromeDataArgs Properties

[image] [image]

Sitecore 6.4.1 API
GetChromeDataArgs Properties
GetChromeDataArgs Class See Also Send Feedback

The GetChromeDataArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | ChromeData | Gets or sets ChromeData.
Public property | ChromeType | Gets ChromeType.
Public property | CommandContext | Gets or sets command context
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Item | Gets or sets the Sitecore item
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

GetChromeDataArgs Class
Sitecore.Pipelines.GetChromeData Namespace


ChromeData Property

[image]

Sitecore 6.4.1 API
GetChromeDataArgs..::..ChromeData Property
GetChromeDataArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ChromeData ChromeData { get; set; }
Visual Basic
Public Property ChromeData As ChromeData
    Get
    Set
Visual C++
public:
property ChromeData^ ChromeData {
    ChromeData^ get ();
    void set (ChromeData^ value);
}

See Also

GetChromeDataArgs Class
Sitecore.Pipelines.GetChromeData Namespace


ChromeType Property

[image]

Sitecore 6.4.1 API
GetChromeDataArgs..::..ChromeType Property
GetChromeDataArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ChromeType { get; }
Visual Basic
Public ReadOnly Property ChromeType As String
    Get
Visual C++
public:
property String^ ChromeType {
    String^ get ();
}

See Also

GetChromeDataArgs Class
Sitecore.Pipelines.GetChromeData Namespace


CommandContext Property

[image]

Sitecore 6.4.1 API
GetChromeDataArgs..::..CommandContext Property
GetChromeDataArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CommandContext CommandContext { get; protected set; }
Visual Basic
Public Property CommandContext As CommandContext
    Get
    Protected Set
Visual C++
public:
property CommandContext^ CommandContext {
    CommandContext^ get ();
    protected: void set (CommandContext^ value);
}

See Also

GetChromeDataArgs Class
Sitecore.Pipelines.GetChromeData Namespace


GetChromeDataPipeline Class

[image]

Sitecore 6.4.1 API
GetChromeDataPipeline Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetChromeDataPipeline
Visual Basic
Public Class GetChromeDataPipeline
Visual C++
public ref class GetChromeDataPipeline

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetChromeData..::..GetChromeDataPipeline

See Also

GetChromeDataPipeline Members
Sitecore.Pipelines.GetChromeData Namespace


GetChromeDataPipeline Members

[image] [image]

Sitecore 6.4.1 API
GetChromeDataPipeline Members
GetChromeDataPipeline Class Constructors Methods See Also Send Feedback

The GetChromeDataPipeline type exposes the following members.

Constructors

 | Name | Description
Public method | GetChromeDataPipeline | Initializes a new instance of the GetChromeDataPipeline class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run | Runs the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetChromeDataPipeline Class
Sitecore.Pipelines.GetChromeData Namespace


GetChromeDataPipeline Constructor

[image]

Sitecore 6.4.1 API
GetChromeDataPipeline Constructor
GetChromeDataPipeline Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetChromeDataPipeline()
Visual Basic
Public Sub New
Visual C++
public:
GetChromeDataPipeline()

See Also

GetChromeDataPipeline Class
Sitecore.Pipelines.GetChromeData Namespace


Run Method

[image]

Sitecore 6.4.1 API
GetChromeDataPipeline..::..Run Method
GetChromeDataPipeline Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Run(
    GetChromeDataArgs args
)
Visual Basic
Public Shared Sub Run ( _
    args As GetChromeDataArgs _
)
Visual C++
public:
static void Run(
    GetChromeDataArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.GetChromeData..::..GetChromeDataArgs
The arguments.

See Also

GetChromeDataPipeline Class
Sitecore.Pipelines.GetChromeData Namespace


GetChromeDataProcessor Class

[image]

Sitecore 6.4.1 API
GetChromeDataProcessor Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class GetChromeDataProcessor
Visual Basic
Public MustInherit Class GetChromeDataProcessor
Visual C++
public ref class GetChromeDataProcessor abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetChromeData..::..GetChromeDataProcessor
Sitecore.Pipelines.GetChromeData..::..GetEditFrameChromeData
Sitecore.Pipelines.GetChromeData..::..GetFieldChromeData
Sitecore.Pipelines.GetChromeData..::..GetPlaceholderChromeData
Sitecore.Pipelines.GetChromeData..::..GetRenderingChromeData
Sitecore.Pipelines.GetChromeData..::..GetWordFieldChromeData
Sitecore.Pipelines.GetChromeData..::..Setup

See Also

GetChromeDataProcessor Members
Sitecore.Pipelines.GetChromeData Namespace


GetChromeDataProcessor Members

[image] [image]

Sitecore 6.4.1 API
GetChromeDataProcessor Members
GetChromeDataProcessor Class Constructors Methods Fields See Also Send Feedback

The GetChromeDataProcessor type exposes the following members.

Constructors

 | Name | Description
Protected method | GetChromeDataProcessor | Initializes a new instance of the GetChromeDataProcessor class

Methods

 | Name | Description
Protected method | AddButtonsToChromeData | Adds the buttons to chrome data.
Protected method | AddButtonToChromeData(WebEditButton, GetChromeDataArgs) | Adds the button to chrome data.
Protected method | AddButtonToChromeData(IEnumerable<(Of <<'(WebEditButton>)>>), GetChromeDataArgs) | Obsolete. Adds the buttons to chrome data.
Protected method | ConvertToWebEditButton | Converts button item to Web Edit Button
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetButtons(String) | Gets buttons under the specified root
Protected method | GetButtons(Item) | Gets buttons under the specified root
Protected method | GetFieldEditorButton | Gets the field editor button.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSmallButton | Gets the small button.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetWebEditButton | Gets the web edit button.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Protected method | QueryButtonState(WebEditButton, CommandContext) | Queries the state of the button.
Protected method | QueryButtonState(WebEditButton, CommandContext, String) | Queries the state of the button.
Protected method | QueryChromeButtonState | Queries the state of the chrome button.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
editFrameSmallButtonTemplateID | EditFrameSmallButton template ID
fieldEditorButtonTemplateID | FieldEditorButton template ID
webEditButtonTemplateID | WebEditButton template ID

See Also

GetChromeDataProcessor Class
Sitecore.Pipelines.GetChromeData Namespace


GetChromeDataProcessor Constructor

[image]

Sitecore 6.4.1 API
GetChromeDataProcessor Constructor
GetChromeDataProcessor Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected GetChromeDataProcessor()
Visual Basic
Protected Sub New
Visual C++
protected:
GetChromeDataProcessor()

See Also

GetChromeDataProcessor Class
Sitecore.Pipelines.GetChromeData Namespace


GetChromeDataProcessor Fields

[image] [image]

Sitecore 6.4.1 API
GetChromeDataProcessor Fields
GetChromeDataProcessor Class See Also Send Feedback

The GetChromeDataProcessor type exposes the following members.

Fields

Name | Description
editFrameSmallButtonTemplateID | EditFrameSmallButton template ID
fieldEditorButtonTemplateID | FieldEditorButton template ID
webEditButtonTemplateID | WebEditButton template ID

See Also

GetChromeDataProcessor Class
Sitecore.Pipelines.GetChromeData Namespace


fieldEditorButtonTemplateID Field

[image]

Sitecore 6.4.1 API
GetChromeDataProcessor..::..fieldEditorButtonTemplateID Field
GetChromeDataProcessor Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected static readonly ID fieldEditorButtonTemplateID
Visual Basic
Protected Shared ReadOnly fieldEditorButtonTemplateID As ID
Visual C++
protected:
static initonly ID^ fieldEditorButtonTemplateID

See Also

GetChromeDataProcessor Class
Sitecore.Pipelines.GetChromeData Namespace


webEditButtonTemplateID Field

[image]

Sitecore 6.4.1 API
GetChromeDataProcessor..::..webEditButtonTemplateID Field
GetChromeDataProcessor Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected static readonly ID webEditButtonTemplateID
Visual Basic
Protected Shared ReadOnly webEditButtonTemplateID As ID
Visual C++
protected:
static initonly ID^ webEditButtonTemplateID

See Also

GetChromeDataProcessor Class
Sitecore.Pipelines.GetChromeData Namespace


GetChromeDataProcessor Methods

[image] [image]

Sitecore 6.4.1 API
GetChromeDataProcessor Methods
GetChromeDataProcessor Class See Also Send Feedback

The GetChromeDataProcessor type exposes the following members.

Methods

 | Name | Description
Protected method | AddButtonsToChromeData | Adds the buttons to chrome data.
Protected method | AddButtonToChromeData(WebEditButton, GetChromeDataArgs) | Adds the button to chrome data.
Protected method | AddButtonToChromeData(IEnumerable<(Of <<'(WebEditButton>)>>), GetChromeDataArgs) | Obsolete. Adds the buttons to chrome data.
Protected method | ConvertToWebEditButton | Converts button item to Web Edit Button
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetButtons(String) | Gets buttons under the specified root
Protected method | GetButtons(Item) | Gets buttons under the specified root
Protected method | GetFieldEditorButton | Gets the field editor button.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSmallButton | Gets the small button.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetWebEditButton | Gets the web edit button.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Protected method | QueryButtonState(WebEditButton, CommandContext) | Queries the state of the button.
Protected method | QueryButtonState(WebEditButton, CommandContext, String) | Queries the state of the button.
Protected method | QueryChromeButtonState | Queries the state of the chrome button.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetChromeDataProcessor Class
Sitecore.Pipelines.GetChromeData Namespace


AddButtonsToChromeData Method

[image]

Sitecore 6.4.1 API
GetChromeDataProcessor..::..AddButtonsToChromeData Method
GetChromeDataProcessor Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void AddButtonsToChromeData(
    IEnumerable<WebEditButton> buttons,
    GetChromeDataArgs args
)
Visual Basic
Protected Sub AddButtonsToChromeData ( _
    buttons As IEnumerable(Of WebEditButton), _
    args As GetChromeDataArgs _
)
Visual C++
protected:
void AddButtonsToChromeData(
    IEnumerable<WebEditButton^>^ buttons,
    GetChromeDataArgs^ args
)

Parameters

buttons
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' WebEditButton >)>)>
The buttons.
args
Type: Sitecore.Pipelines.GetChromeData..::..GetChromeDataArgs
The arguments.

Remarks

Use this command intead of adding the button to ChromeData.Commands collection

See Also

GetChromeDataProcessor Class
Sitecore.Pipelines.GetChromeData Namespace


AddButtonToChromeData Method

[image] [image]

Sitecore 6.4.1 API
GetChromeDataProcessor..::..AddButtonToChromeData Method
GetChromeDataProcessor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AddButtonToChromeData(WebEditButton, GetChromeDataArgs) | Adds the button to chrome data.
Protected method | AddButtonToChromeData(IEnumerable<(Of <<'(WebEditButton>)>>), GetChromeDataArgs) | Obsolete. Adds the buttons to chrome data.

See Also

GetChromeDataProcessor Class
GetChromeDataProcessor Members
Sitecore.Pipelines.GetChromeData Namespace


AddButtonToChromeData Method (WebEditButton, GetChromeDataArgs)

[image]

Sitecore 6.4.1 API
GetChromeDataProcessor..::..AddButtonToChromeData Method (WebEditButton, GetChromeDataArgs)
GetChromeDataProcessor Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void AddButtonToChromeData(
    WebEditButton button,
    GetChromeDataArgs args
)
Visual Basic
Protected Overridable Sub AddButtonToChromeData ( _
    button As WebEditButton, _
    args As GetChromeDataArgs _
)
Visual C++
protected:
virtual void AddButtonToChromeData(
    WebEditButton^ button,
    GetChromeDataArgs^ args
)

Parameters

button
Type: Sitecore.Data.Fields..::..WebEditButton
The button.
args
Type: Sitecore.Pipelines.GetChromeData..::..GetChromeDataArgs
The arguments.

Remarks

Use this command intead of adding the button to ChromeData.Commands collection

See Also

GetChromeDataProcessor Class
AddButtonToChromeData Overload
Sitecore.Pipelines.GetChromeData Namespace


AddButtonToChromeData Method (IEnumerable(WebEditButton), GetChromeDataArgs)

[image]

Sitecore 6.4.1 API
GetChromeDataProcessor..::..AddButtonToChromeData Method (IEnumerable<(Of <(<'WebEditButton>)>)>, GetChromeDataArgs)
GetChromeDataProcessor Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use AddButtonsToChromeData(IEnumerable<WebEditButton> buttons, [NotNull] GetChromeDataArgs args) instead ")]
protected void AddButtonToChromeData(
    IEnumerable<WebEditButton> buttons,
    GetChromeDataArgs args
)
Visual Basic
<ObsoleteAttribute("Use AddButtonsToChromeData(IEnumerable<WebEditButton> buttons, [NotNull] GetChromeDataArgs args) instead ")> _
Protected Sub AddButtonToChromeData ( _
    buttons As IEnumerable(Of WebEditButton), _
    args As GetChromeDataArgs _
)
Visual C++
[ObsoleteAttribute(L"Use AddButtonsToChromeData(IEnumerable<WebEditButton> buttons, [NotNull] GetChromeDataArgs args) instead ")]
protected:
void AddButtonToChromeData(
    IEnumerable<WebEditButton^>^ buttons,
    GetChromeDataArgs^ args
)

Parameters

buttons
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' WebEditButton >)>)>
The buttons.
args
Type: Sitecore.Pipelines.GetChromeData..::..GetChromeDataArgs
The arguments.

Remarks

Use this command intead of adding the button to ChromeData.Commands collection

See Also

GetChromeDataProcessor Class
AddButtonToChromeData Overload
Sitecore.Pipelines.GetChromeData Namespace


ConvertToWebEditButton Method

[image]

Sitecore 6.4.1 API
GetChromeDataProcessor..::..ConvertToWebEditButton Method
GetChromeDataProcessor Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual WebEditButton ConvertToWebEditButton(
    Item buttonItem
)
Visual Basic
Protected Overridable Function ConvertToWebEditButton ( _
    buttonItem As Item _
) As WebEditButton
Visual C++
protected:
virtual WebEditButton^ ConvertToWebEditButton(
    Item^ buttonItem
)

Parameters

buttonItem
Type: Sitecore.Data.Items..::..Item
Item representing a button

Return Value

The Web Edit Button

See Also

GetChromeDataProcessor Class
Sitecore.Pipelines.GetChromeData Namespace


GetButtons Method

[image] [image]

Sitecore 6.4.1 API
GetChromeDataProcessor..::..GetButtons Method
GetChromeDataProcessor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetButtons(String) | Gets buttons under the specified root
Protected method | GetButtons(Item) | Gets buttons under the specified root

See Also

GetChromeDataProcessor Class
GetChromeDataProcessor Members
Sitecore.Pipelines.GetChromeData Namespace


GetButtons Method (String)

[image]

Sitecore 6.4.1 API
GetChromeDataProcessor..::..GetButtons Method (String)
GetChromeDataProcessor Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual List<WebEditButton> GetButtons(
    string rootPath
)
Visual Basic
Protected Overridable Function GetButtons ( _
    rootPath As String _
) As List(Of WebEditButton)
Visual C++
protected:
virtual List<WebEditButton^>^ GetButtons(
    String^ rootPath
)

Parameters

rootPath
Type: System..::..String
The path to the root item

Return Value

Web edit buttons

See Also

GetChromeDataProcessor Class
GetButtons Overload
Sitecore.Pipelines.GetChromeData Namespace


GetButtons Method (Item)

[image]

Sitecore 6.4.1 API
GetChromeDataProcessor..::..GetButtons Method (Item)
GetChromeDataProcessor Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual List<WebEditButton> GetButtons(
    Item rootItem
)
Visual Basic
Protected Overridable Function GetButtons ( _
    rootItem As Item _
) As List(Of WebEditButton)
Visual C++
protected:
virtual List<WebEditButton^>^ GetButtons(
    Item^ rootItem
)

Parameters

rootItem
Type: Sitecore.Data.Items..::..Item
The root item

Return Value

Web edit buttons

See Also

GetChromeDataProcessor Class
GetButtons Overload
Sitecore.Pipelines.GetChromeData Namespace


GetFieldEditorButton Method

[image]

Sitecore 6.4.1 API
GetChromeDataProcessor..::..GetFieldEditorButton Method
GetChromeDataProcessor Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual WebEditButton GetFieldEditorButton(
    Item item
)
Visual Basic
Protected Overridable Function GetFieldEditorButton ( _
    item As Item _
) As WebEditButton
Visual C++
protected:
virtual WebEditButton^ GetFieldEditorButton(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item

Return Value

The field editor button.

See Also

GetChromeDataProcessor Class
Sitecore.Pipelines.GetChromeData Namespace


GetSmallButton Method

[image]

Sitecore 6.4.1 API
GetChromeDataProcessor..::..GetSmallButton Method
GetChromeDataProcessor Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual WebEditButton GetSmallButton(
    Item item
)
Visual Basic
Protected Overridable Function GetSmallButton ( _
    item As Item _
) As WebEditButton
Visual C++
protected:
virtual WebEditButton^ GetSmallButton(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item

Return Value

The small button.

See Also

GetChromeDataProcessor Class
Sitecore.Pipelines.GetChromeData Namespace


GetWebEditButton Method

[image]

Sitecore 6.4.1 API
GetChromeDataProcessor..::..GetWebEditButton Method
GetChromeDataProcessor Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual WebEditButton GetWebEditButton(
    Item item
)
Visual Basic
Protected Overridable Function GetWebEditButton ( _
    item As Item _
) As WebEditButton
Visual C++
protected:
virtual WebEditButton^ GetWebEditButton(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item

Return Value

The web edit button.

See Also

GetChromeDataProcessor Class
Sitecore.Pipelines.GetChromeData Namespace


Process Method

[image]

Sitecore 6.4.1 API
GetChromeDataProcessor..::..Process Method
GetChromeDataProcessor Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract void Process(
    GetChromeDataArgs args
)
Visual Basic
Public MustOverride Sub Process ( _
    args As GetChromeDataArgs _
)
Visual C++
public:
virtual void Process(
    GetChromeDataArgs^ args
) abstract

Parameters

args
Type: Sitecore.Pipelines.GetChromeData..::..GetChromeDataArgs
The args.

See Also

GetChromeDataProcessor Class
Sitecore.Pipelines.GetChromeData Namespace


QueryButtonState Method

[image] [image]

Sitecore 6.4.1 API
GetChromeDataProcessor..::..QueryButtonState Method
GetChromeDataProcessor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | QueryButtonState(WebEditButton, CommandContext) | Queries the state of the button.
Protected method | QueryButtonState(WebEditButton, CommandContext, String) | Queries the state of the button.

See Also

GetChromeDataProcessor Class
GetChromeDataProcessor Members
Sitecore.Pipelines.GetChromeData Namespace


QueryChromeButtonState Method

[image]

Sitecore 6.4.1 API
GetChromeDataProcessor..::..QueryChromeButtonState Method
GetChromeDataProcessor Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool QueryChromeButtonState(
    WebEditButton button,
    CommandContext context
)
Visual Basic
Protected Overridable Function QueryChromeButtonState ( _
    button As WebEditButton, _
    context As CommandContext _
) As Boolean
Visual C++
protected:
virtual bool QueryChromeButtonState(
    WebEditButton^ button,
    CommandContext^ context
)

Parameters

button
Type: Sitecore.Data.Fields..::..WebEditButton
The button.
context
Type: Sitecore.Shell.Framework.Commands..::..CommandContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Pipelines.GetChromeData.GetChromeDataProcessor.QueryChromeButtonState(Sitecore.Data.Fields.WebEditButton,Sitecore.Shell.Framework.Commands.CommandContext)"]

See Also

GetChromeDataProcessor Class
Sitecore.Pipelines.GetChromeData Namespace


GetEditFrameChromeData Class

[image]

Sitecore 6.4.1 API
GetEditFrameChromeData Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetEditFrameChromeData : GetChromeDataProcessor
Visual Basic
Public Class GetEditFrameChromeData _
    Inherits GetChromeDataProcessor
Visual C++
public ref class GetEditFrameChromeData : public GetChromeDataProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetChromeData..::..GetChromeDataProcessor
Sitecore.Pipelines.GetChromeData..::..GetEditFrameChromeData

See Also

GetEditFrameChromeData Members
Sitecore.Pipelines.GetChromeData Namespace


GetEditFrameChromeData Members

[image] [image]

Sitecore 6.4.1 API
GetEditFrameChromeData Members
GetEditFrameChromeData Class Constructors Methods Fields See Also Send Feedback

The GetEditFrameChromeData type exposes the following members.

Constructors

 | Name | Description
Public method | GetEditFrameChromeData | Initializes a new instance of the GetEditFrameChromeData class

Methods

 | Name | Description
Protected method | AddButtonsToChromeData | Adds the buttons to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | AddButtonToChromeData(WebEditButton, GetChromeDataArgs) | Adds the button to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | AddButtonToChromeData(IEnumerable<(Of <<'(WebEditButton>)>>), GetChromeDataArgs) | Obsolete. Adds the buttons to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | ConvertToWebEditButton | Converts button item to Web Edit Button (Inherited from GetChromeDataProcessor.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetButtons(String) | Gets buttons under the specified root (Inherited from GetChromeDataProcessor.)
Protected method | GetButtons(Item) | Gets buttons under the specified root (Inherited from GetChromeDataProcessor.)
Protected method | GetFieldEditorButton | Gets the field editor button. (Inherited from GetChromeDataProcessor.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSmallButton | Gets the small button. (Inherited from GetChromeDataProcessor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetWebEditButton | Gets the web edit button. (Inherited from GetChromeDataProcessor.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | The process. (Overrides GetChromeDataProcessor..::..Process(GetChromeDataArgs).)
Protected method | QueryButtonState(WebEditButton, CommandContext) | Queries the state of the button. (Inherited from GetChromeDataProcessor.)
Protected method | QueryButtonState(WebEditButton, CommandContext, String) | Queries the state of the button. (Inherited from GetChromeDataProcessor.)
Protected method | QueryChromeButtonState | Queries the state of the chrome button. (Inherited from GetChromeDataProcessor.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ButtonsPathKey | The key of the buttons path in CustomData dictionary.
ChromeType | The chrome type.

See Also

GetEditFrameChromeData Class
Sitecore.Pipelines.GetChromeData Namespace


GetEditFrameChromeData Constructor

[image]

Sitecore 6.4.1 API
GetEditFrameChromeData Constructor
GetEditFrameChromeData Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetEditFrameChromeData()
Visual Basic
Public Sub New
Visual C++
public:
GetEditFrameChromeData()

See Also

GetEditFrameChromeData Class
Sitecore.Pipelines.GetChromeData Namespace


GetEditFrameChromeData Fields

[image] [image]

Sitecore 6.4.1 API
GetEditFrameChromeData Fields
GetEditFrameChromeData Class See Also Send Feedback

The GetEditFrameChromeData type exposes the following members.

Fields

Name | Description
ButtonsPathKey | The key of the buttons path in CustomData dictionary.
ChromeType | The chrome type.

See Also

GetEditFrameChromeData Class
Sitecore.Pipelines.GetChromeData Namespace


ButtonsPathKey Field

[image]

Sitecore 6.4.1 API
GetEditFrameChromeData..::..ButtonsPathKey Field
GetEditFrameChromeData Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string ButtonsPathKey
Visual Basic
Public Const ButtonsPathKey As String
Visual C++
public:
literal String^ ButtonsPathKey

See Also

GetEditFrameChromeData Class
Sitecore.Pipelines.GetChromeData Namespace


ChromeType Field

[image]

Sitecore 6.4.1 API
GetEditFrameChromeData..::..ChromeType Field
GetEditFrameChromeData Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string ChromeType
Visual Basic
Public Const ChromeType As String
Visual C++
public:
literal String^ ChromeType

See Also

GetEditFrameChromeData Class
Sitecore.Pipelines.GetChromeData Namespace


GetEditFrameChromeData Methods

[image] [image]

Sitecore 6.4.1 API
GetEditFrameChromeData Methods
GetEditFrameChromeData Class See Also Send Feedback

The GetEditFrameChromeData type exposes the following members.

Methods

 | Name | Description
Protected method | AddButtonsToChromeData | Adds the buttons to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | AddButtonToChromeData(WebEditButton, GetChromeDataArgs) | Adds the button to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | AddButtonToChromeData(IEnumerable<(Of <<'(WebEditButton>)>>), GetChromeDataArgs) | Obsolete. Adds the buttons to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | ConvertToWebEditButton | Converts button item to Web Edit Button (Inherited from GetChromeDataProcessor.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetButtons(String) | Gets buttons under the specified root (Inherited from GetChromeDataProcessor.)
Protected method | GetButtons(Item) | Gets buttons under the specified root (Inherited from GetChromeDataProcessor.)
Protected method | GetFieldEditorButton | Gets the field editor button. (Inherited from GetChromeDataProcessor.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSmallButton | Gets the small button. (Inherited from GetChromeDataProcessor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetWebEditButton | Gets the web edit button. (Inherited from GetChromeDataProcessor.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | The process. (Overrides GetChromeDataProcessor..::..Process(GetChromeDataArgs).)
Protected method | QueryButtonState(WebEditButton, CommandContext) | Queries the state of the button. (Inherited from GetChromeDataProcessor.)
Protected method | QueryButtonState(WebEditButton, CommandContext, String) | Queries the state of the button. (Inherited from GetChromeDataProcessor.)
Protected method | QueryChromeButtonState | Queries the state of the chrome button. (Inherited from GetChromeDataProcessor.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetEditFrameChromeData Class
Sitecore.Pipelines.GetChromeData Namespace


AddButtonToChromeData Method

[image] [image]

Sitecore 6.4.1 API
GetEditFrameChromeData..::..AddButtonToChromeData Method
GetEditFrameChromeData Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AddButtonToChromeData(WebEditButton, GetChromeDataArgs) | Adds the button to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | AddButtonToChromeData(IEnumerable<(Of <<'(WebEditButton>)>>), GetChromeDataArgs) | Obsolete. Adds the buttons to chrome data. (Inherited from GetChromeDataProcessor.)

See Also

GetEditFrameChromeData Class
GetEditFrameChromeData Members
Sitecore.Pipelines.GetChromeData Namespace


GetButtons Method

[image] [image]

Sitecore 6.4.1 API
GetEditFrameChromeData..::..GetButtons Method
GetEditFrameChromeData Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetButtons(String) | Gets buttons under the specified root (Inherited from GetChromeDataProcessor.)
Protected method | GetButtons(Item) | Gets buttons under the specified root (Inherited from GetChromeDataProcessor.)

See Also

GetEditFrameChromeData Class
GetEditFrameChromeData Members
Sitecore.Pipelines.GetChromeData Namespace


Process Method

[image]

Sitecore 6.4.1 API
GetEditFrameChromeData..::..Process Method
GetEditFrameChromeData Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    GetChromeDataArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As GetChromeDataArgs _
)
Visual C++
public:
virtual void Process(
    GetChromeDataArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.GetChromeData..::..GetChromeDataArgs
The pipeline args.

See Also

GetEditFrameChromeData Class
Sitecore.Pipelines.GetChromeData Namespace


QueryButtonState Method

[image] [image]

Sitecore 6.4.1 API
GetEditFrameChromeData..::..QueryButtonState Method
GetEditFrameChromeData Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | QueryButtonState(WebEditButton, CommandContext) | Queries the state of the button. (Inherited from GetChromeDataProcessor.)
Protected method | QueryButtonState(WebEditButton, CommandContext, String) | Queries the state of the button. (Inherited from GetChromeDataProcessor.)

See Also

GetEditFrameChromeData Class
GetEditFrameChromeData Members
Sitecore.Pipelines.GetChromeData Namespace


GetFieldChromeData Class

[image]

Sitecore 6.4.1 API
GetFieldChromeData Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetFieldChromeData : GetChromeDataProcessor
Visual Basic
Public Class GetFieldChromeData _
    Inherits GetChromeDataProcessor
Visual C++
public ref class GetFieldChromeData : public GetChromeDataProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetChromeData..::..GetChromeDataProcessor
Sitecore.Pipelines.GetChromeData..::..GetFieldChromeData

See Also

GetFieldChromeData Members
Sitecore.Pipelines.GetChromeData Namespace


GetFieldChromeData Members

[image] [image]

Sitecore 6.4.1 API
GetFieldChromeData Members
GetFieldChromeData Class Constructors Methods Fields See Also Send Feedback

The GetFieldChromeData type exposes the following members.

Constructors

 | Name | Description
Public method | GetFieldChromeData | Initializes a new instance of the GetFieldChromeData class

Methods

 | Name | Description
Protected method | AddButtonsToChromeData | Adds the buttons to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | AddButtonToChromeData(WebEditButton, GetChromeDataArgs) | Adds the button to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | AddButtonToChromeData(IEnumerable<(Of <<'(WebEditButton>)>>), GetChromeDataArgs) | Obsolete. Adds the buttons to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | ConvertToWebEditButton | Converts button item to Web Edit Button (Inherited from GetChromeDataProcessor.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetButtons(String) | Gets buttons under the specified root (Inherited from GetChromeDataProcessor.)
Protected method | GetButtons(Item) | Gets buttons under the specified root (Inherited from GetChromeDataProcessor.)
Protected method | GetFieldEditorButton | Gets the field editor button. (Inherited from GetChromeDataProcessor.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSmallButton | Gets the small button. (Inherited from GetChromeDataProcessor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetWebEditButton | Gets the web edit button. (Inherited from GetChromeDataProcessor.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides GetChromeDataProcessor..::..Process(GetChromeDataArgs).)
Protected method | QueryButtonState(WebEditButton, CommandContext) | Queries the state of the button. (Inherited from GetChromeDataProcessor.)
Protected method | QueryButtonState(WebEditButton, CommandContext, String) | Queries the state of the button. (Inherited from GetChromeDataProcessor.)
Protected method | QueryChromeButtonState | Queries the state of the chrome button. (Inherited from GetChromeDataProcessor.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ChromeType | The chrome type.
FieldKey | The key of the Field instance in CustomData dictionary.

See Also

GetFieldChromeData Class
Sitecore.Pipelines.GetChromeData Namespace


GetFieldChromeData Constructor

[image]

Sitecore 6.4.1 API
GetFieldChromeData Constructor
GetFieldChromeData Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetFieldChromeData()
Visual Basic
Public Sub New
Visual C++
public:
GetFieldChromeData()

See Also

GetFieldChromeData Class
Sitecore.Pipelines.GetChromeData Namespace


GetFieldChromeData Fields

[image] [image]

Sitecore 6.4.1 API
GetFieldChromeData Fields
GetFieldChromeData Class See Also Send Feedback

The GetFieldChromeData type exposes the following members.

Fields

Name | Description
ChromeType | The chrome type.
FieldKey | The key of the Field instance in CustomData dictionary.

See Also

GetFieldChromeData Class
Sitecore.Pipelines.GetChromeData Namespace


ChromeType Field

[image]

Sitecore 6.4.1 API
GetFieldChromeData..::..ChromeType Field
GetFieldChromeData Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string ChromeType
Visual Basic
Public Const ChromeType As String
Visual C++
public:
literal String^ ChromeType

See Also

GetFieldChromeData Class
Sitecore.Pipelines.GetChromeData Namespace


FieldKey Field

[image]

Sitecore 6.4.1 API
GetFieldChromeData..::..FieldKey Field
GetFieldChromeData Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string FieldKey
Visual Basic
Public Const FieldKey As String
Visual C++
public:
literal String^ FieldKey

See Also

GetFieldChromeData Class
Sitecore.Pipelines.GetChromeData Namespace


GetFieldChromeData Methods

[image] [image]

Sitecore 6.4.1 API
GetFieldChromeData Methods
GetFieldChromeData Class See Also Send Feedback

The GetFieldChromeData type exposes the following members.

Methods

 | Name | Description
Protected method | AddButtonsToChromeData | Adds the buttons to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | AddButtonToChromeData(WebEditButton, GetChromeDataArgs) | Adds the button to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | AddButtonToChromeData(IEnumerable<(Of <<'(WebEditButton>)>>), GetChromeDataArgs) | Obsolete. Adds the buttons to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | ConvertToWebEditButton | Converts button item to Web Edit Button (Inherited from GetChromeDataProcessor.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetButtons(String) | Gets buttons under the specified root (Inherited from GetChromeDataProcessor.)
Protected method | GetButtons(Item) | Gets buttons under the specified root (Inherited from GetChromeDataProcessor.)
Protected method | GetFieldEditorButton | Gets the field editor button. (Inherited from GetChromeDataProcessor.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSmallButton | Gets the small button. (Inherited from GetChromeDataProcessor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetWebEditButton | Gets the web edit button. (Inherited from GetChromeDataProcessor.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides GetChromeDataProcessor..::..Process(GetChromeDataArgs).)
Protected method | QueryButtonState(WebEditButton, CommandContext) | Queries the state of the button. (Inherited from GetChromeDataProcessor.)
Protected method | QueryButtonState(WebEditButton, CommandContext, String) | Queries the state of the button. (Inherited from GetChromeDataProcessor.)
Protected method | QueryChromeButtonState | Queries the state of the chrome button. (Inherited from GetChromeDataProcessor.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetFieldChromeData Class
Sitecore.Pipelines.GetChromeData Namespace


AddButtonToChromeData Method

[image] [image]

Sitecore 6.4.1 API
GetFieldChromeData..::..AddButtonToChromeData Method
GetFieldChromeData Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AddButtonToChromeData(WebEditButton, GetChromeDataArgs) | Adds the button to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | AddButtonToChromeData(IEnumerable<(Of <<'(WebEditButton>)>>), GetChromeDataArgs) | Obsolete. Adds the buttons to chrome data. (Inherited from GetChromeDataProcessor.)

See Also

GetFieldChromeData Class
GetFieldChromeData Members
Sitecore.Pipelines.GetChromeData Namespace


GetButtons Method

[image] [image]

Sitecore 6.4.1 API
GetFieldChromeData..::..GetButtons Method
GetFieldChromeData Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetButtons(String) | Gets buttons under the specified root (Inherited from GetChromeDataProcessor.)
Protected method | GetButtons(Item) | Gets buttons under the specified root (Inherited from GetChromeDataProcessor.)

See Also

GetFieldChromeData Class
GetFieldChromeData Members
Sitecore.Pipelines.GetChromeData Namespace


Process Method

[image]

Sitecore 6.4.1 API
GetFieldChromeData..::..Process Method
GetFieldChromeData Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    GetChromeDataArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As GetChromeDataArgs _
)
Visual C++
public:
virtual void Process(
    GetChromeDataArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.GetChromeData..::..GetChromeDataArgs
The pipeline args.

See Also

GetFieldChromeData Class
Sitecore.Pipelines.GetChromeData Namespace


GetPlaceholderChromeData Class

[image]

Sitecore 6.4.1 API
GetPlaceholderChromeData Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetPlaceholderChromeData : GetChromeDataProcessor
Visual Basic
Public Class GetPlaceholderChromeData _
    Inherits GetChromeDataProcessor
Visual C++
public ref class GetPlaceholderChromeData : public GetChromeDataProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetChromeData..::..GetChromeDataProcessor
Sitecore.Pipelines.GetChromeData..::..GetPlaceholderChromeData

See Also

GetPlaceholderChromeData Members
Sitecore.Pipelines.GetChromeData Namespace


GetPlaceholderChromeData Members

[image] [image]

Sitecore 6.4.1 API
GetPlaceholderChromeData Members
GetPlaceholderChromeData Class Constructors Methods Fields See Also Send Feedback

The GetPlaceholderChromeData type exposes the following members.

Constructors

 | Name | Description
Public method | GetPlaceholderChromeData | Initializes a new instance of the GetPlaceholderChromeData class

Methods

 | Name | Description
Protected method | AddButtonsToChromeData | Adds the buttons to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | AddButtonToChromeData(WebEditButton, GetChromeDataArgs) | Adds the button to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | AddButtonToChromeData(IEnumerable<(Of <<'(WebEditButton>)>>), GetChromeDataArgs) | Obsolete. Adds the buttons to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | ConvertToWebEditButton | Converts button item to Web Edit Button (Inherited from GetChromeDataProcessor.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetButtons(String) | Gets buttons under the specified root (Inherited from GetChromeDataProcessor.)
Protected method | GetButtons(Item) | Gets buttons under the specified root (Inherited from GetChromeDataProcessor.)
Protected method | GetFieldEditorButton | Gets the field editor button. (Inherited from GetChromeDataProcessor.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSmallButton | Gets the small button. (Inherited from GetChromeDataProcessor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetWebEditButton | Gets the web edit button. (Inherited from GetChromeDataProcessor.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | The process. (Overrides GetChromeDataProcessor..::..Process(GetChromeDataArgs).)
Protected method | QueryButtonState(WebEditButton, CommandContext) | Queries the state of the button. (Inherited from GetChromeDataProcessor.)
Protected method | QueryButtonState(WebEditButton, CommandContext, String) | Queries the state of the button. (Inherited from GetChromeDataProcessor.)
Protected method | QueryChromeButtonState | Queries the state of the chrome button. (Inherited from GetChromeDataProcessor.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ChromeType | The chrome type.
PlaceholderKey | The key of the placeholderkey in CustomData dictionary.

See Also

GetPlaceholderChromeData Class
Sitecore.Pipelines.GetChromeData Namespace


GetPlaceholderChromeData Constructor

[image]

Sitecore 6.4.1 API
GetPlaceholderChromeData Constructor
GetPlaceholderChromeData Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetPlaceholderChromeData()
Visual Basic
Public Sub New
Visual C++
public:
GetPlaceholderChromeData()

See Also

GetPlaceholderChromeData Class
Sitecore.Pipelines.GetChromeData Namespace


GetPlaceholderChromeData Fields

[image] [image]

Sitecore 6.4.1 API
GetPlaceholderChromeData Fields
GetPlaceholderChromeData Class See Also Send Feedback

The GetPlaceholderChromeData type exposes the following members.

Fields

Name | Description
ChromeType | The chrome type.
PlaceholderKey | The key of the placeholderkey in CustomData dictionary.

See Also

GetPlaceholderChromeData Class
Sitecore.Pipelines.GetChromeData Namespace


PlaceholderKey Field

[image]

Sitecore 6.4.1 API
GetPlaceholderChromeData..::..PlaceholderKey Field
GetPlaceholderChromeData Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string PlaceholderKey
Visual Basic
Public Const PlaceholderKey As String
Visual C++
public:
literal String^ PlaceholderKey

See Also

GetPlaceholderChromeData Class
Sitecore.Pipelines.GetChromeData Namespace


GetPlaceholderChromeData Methods

[image] [image]

Sitecore 6.4.1 API
GetPlaceholderChromeData Methods
GetPlaceholderChromeData Class See Also Send Feedback

The GetPlaceholderChromeData type exposes the following members.

Methods

 | Name | Description
Protected method | AddButtonsToChromeData | Adds the buttons to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | AddButtonToChromeData(WebEditButton, GetChromeDataArgs) | Adds the button to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | AddButtonToChromeData(IEnumerable<(Of <<'(WebEditButton>)>>), GetChromeDataArgs) | Obsolete. Adds the buttons to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | ConvertToWebEditButton | Converts button item to Web Edit Button (Inherited from GetChromeDataProcessor.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetButtons(String) | Gets buttons under the specified root (Inherited from GetChromeDataProcessor.)
Protected method | GetButtons(Item) | Gets buttons under the specified root (Inherited from GetChromeDataProcessor.)
Protected method | GetFieldEditorButton | Gets the field editor button. (Inherited from GetChromeDataProcessor.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSmallButton | Gets the small button. (Inherited from GetChromeDataProcessor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetWebEditButton | Gets the web edit button. (Inherited from GetChromeDataProcessor.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | The process. (Overrides GetChromeDataProcessor..::..Process(GetChromeDataArgs).)
Protected method | QueryButtonState(WebEditButton, CommandContext) | Queries the state of the button. (Inherited from GetChromeDataProcessor.)
Protected method | QueryButtonState(WebEditButton, CommandContext, String) | Queries the state of the button. (Inherited from GetChromeDataProcessor.)
Protected method | QueryChromeButtonState | Queries the state of the chrome button. (Inherited from GetChromeDataProcessor.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetPlaceholderChromeData Class
Sitecore.Pipelines.GetChromeData Namespace


AddButtonToChromeData Method

[image] [image]

Sitecore 6.4.1 API
GetPlaceholderChromeData..::..AddButtonToChromeData Method
GetPlaceholderChromeData Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AddButtonToChromeData(WebEditButton, GetChromeDataArgs) | Adds the button to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | AddButtonToChromeData(IEnumerable<(Of <<'(WebEditButton>)>>), GetChromeDataArgs) | Obsolete. Adds the buttons to chrome data. (Inherited from GetChromeDataProcessor.)

See Also

GetPlaceholderChromeData Class
GetPlaceholderChromeData Members
Sitecore.Pipelines.GetChromeData Namespace


GetButtons Method

[image] [image]

Sitecore 6.4.1 API
GetPlaceholderChromeData..::..GetButtons Method
GetPlaceholderChromeData Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetButtons(String) | Gets buttons under the specified root (Inherited from GetChromeDataProcessor.)
Protected method | GetButtons(Item) | Gets buttons under the specified root (Inherited from GetChromeDataProcessor.)

See Also

GetPlaceholderChromeData Class
GetPlaceholderChromeData Members
Sitecore.Pipelines.GetChromeData Namespace


Process Method

[image]

Sitecore 6.4.1 API
GetPlaceholderChromeData..::..Process Method
GetPlaceholderChromeData Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    GetChromeDataArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As GetChromeDataArgs _
)
Visual C++
public:
virtual void Process(
    GetChromeDataArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.GetChromeData..::..GetChromeDataArgs
The pipeline args.

See Also

GetPlaceholderChromeData Class
Sitecore.Pipelines.GetChromeData Namespace


QueryButtonState Method

[image] [image]

Sitecore 6.4.1 API
GetPlaceholderChromeData..::..QueryButtonState Method
GetPlaceholderChromeData Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | QueryButtonState(WebEditButton, CommandContext) | Queries the state of the button. (Inherited from GetChromeDataProcessor.)
Protected method | QueryButtonState(WebEditButton, CommandContext, String) | Queries the state of the button. (Inherited from GetChromeDataProcessor.)

See Also

GetPlaceholderChromeData Class
GetPlaceholderChromeData Members
Sitecore.Pipelines.GetChromeData Namespace


GetRenderingChromeData Class

[image]

Sitecore 6.4.1 API
GetRenderingChromeData Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetRenderingChromeData : GetChromeDataProcessor
Visual Basic
Public Class GetRenderingChromeData _
    Inherits GetChromeDataProcessor
Visual C++
public ref class GetRenderingChromeData : public GetChromeDataProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetChromeData..::..GetChromeDataProcessor
Sitecore.Pipelines.GetChromeData..::..GetRenderingChromeData

See Also

GetRenderingChromeData Members
Sitecore.Pipelines.GetChromeData Namespace


GetRenderingChromeData Members

[image] [image]

Sitecore 6.4.1 API
GetRenderingChromeData Members
GetRenderingChromeData Class Constructors Methods Fields See Also Send Feedback

The GetRenderingChromeData type exposes the following members.

Constructors

 | Name | Description
Public method | GetRenderingChromeData | Initializes a new instance of the GetRenderingChromeData class

Methods

 | Name | Description
Protected method | AddButtonsToChromeData | Adds the buttons to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | AddButtonToChromeData(WebEditButton, GetChromeDataArgs) | Adds the button to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | AddButtonToChromeData(IEnumerable<(Of <<'(WebEditButton>)>>), GetChromeDataArgs) | Obsolete. Adds the buttons to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | ConvertToWebEditButton | Converts button item to Web Edit Button (Inherited from GetChromeDataProcessor.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetButtons(String) | Gets buttons under the specified root (Inherited from GetChromeDataProcessor.)
Protected method | GetButtons(Item) | Gets buttons under the specified root (Inherited from GetChromeDataProcessor.)
Protected method | GetFieldEditorButton | Gets the field editor button. (Inherited from GetChromeDataProcessor.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSmallButton | Gets the small button. (Inherited from GetChromeDataProcessor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetWebEditButton | Gets the web edit button. (Inherited from GetChromeDataProcessor.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides GetChromeDataProcessor..::..Process(GetChromeDataArgs).)
Protected method | QueryButtonState(WebEditButton, CommandContext) | Queries the state of the button. (Inherited from GetChromeDataProcessor.)
Protected method | QueryButtonState(WebEditButton, CommandContext, String) | Queries the state of the button. (Inherited from GetChromeDataProcessor.)
Protected method | QueryChromeButtonState | Queries the state of the chrome button. (Inherited from GetChromeDataProcessor.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ChromeType | The chrome type.
RenderingReferenceKey | The key of the Field instance in CustomData dictionary.

See Also

GetRenderingChromeData Class
Sitecore.Pipelines.GetChromeData Namespace


GetRenderingChromeData Constructor

[image]

Sitecore 6.4.1 API
GetRenderingChromeData Constructor
GetRenderingChromeData Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetRenderingChromeData()
Visual Basic
Public Sub New
Visual C++
public:
GetRenderingChromeData()

See Also

GetRenderingChromeData Class
Sitecore.Pipelines.GetChromeData Namespace


GetRenderingChromeData Fields

[image] [image]

Sitecore 6.4.1 API
GetRenderingChromeData Fields
GetRenderingChromeData Class See Also Send Feedback

The GetRenderingChromeData type exposes the following members.

Fields

Name | Description
ChromeType | The chrome type.
RenderingReferenceKey | The key of the Field instance in CustomData dictionary.

See Also

GetRenderingChromeData Class
Sitecore.Pipelines.GetChromeData Namespace


ChromeType Field

[image]

Sitecore 6.4.1 API
GetRenderingChromeData..::..ChromeType Field
GetRenderingChromeData Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string ChromeType
Visual Basic
Public Const ChromeType As String
Visual C++
public:
literal String^ ChromeType

See Also

GetRenderingChromeData Class
Sitecore.Pipelines.GetChromeData Namespace


RenderingReferenceKey Field

[image]

Sitecore 6.4.1 API
GetRenderingChromeData..::..RenderingReferenceKey Field
GetRenderingChromeData Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public const string RenderingReferenceKey
Visual Basic
Public Const RenderingReferenceKey As String
Visual C++
public:
literal String^ RenderingReferenceKey

See Also

GetRenderingChromeData Class
Sitecore.Pipelines.GetChromeData Namespace


GetRenderingChromeData Methods

[image] [image]

Sitecore 6.4.1 API
GetRenderingChromeData Methods
GetRenderingChromeData Class See Also Send Feedback

The GetRenderingChromeData type exposes the following members.

Methods

 | Name | Description
Protected method | AddButtonsToChromeData | Adds the buttons to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | AddButtonToChromeData(WebEditButton, GetChromeDataArgs) | Adds the button to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | AddButtonToChromeData(IEnumerable<(Of <<'(WebEditButton>)>>), GetChromeDataArgs) | Obsolete. Adds the buttons to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | ConvertToWebEditButton | Converts button item to Web Edit Button (Inherited from GetChromeDataProcessor.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetButtons(String) | Gets buttons under the specified root (Inherited from GetChromeDataProcessor.)
Protected method | GetButtons(Item) | Gets buttons under the specified root (Inherited from GetChromeDataProcessor.)
Protected method | GetFieldEditorButton | Gets the field editor button. (Inherited from GetChromeDataProcessor.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSmallButton | Gets the small button. (Inherited from GetChromeDataProcessor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetWebEditButton | Gets the web edit button. (Inherited from GetChromeDataProcessor.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides GetChromeDataProcessor..::..Process(GetChromeDataArgs).)
Protected method | QueryButtonState(WebEditButton, CommandContext) | Queries the state of the button. (Inherited from GetChromeDataProcessor.)
Protected method | QueryButtonState(WebEditButton, CommandContext, String) | Queries the state of the button. (Inherited from GetChromeDataProcessor.)
Protected method | QueryChromeButtonState | Queries the state of the chrome button. (Inherited from GetChromeDataProcessor.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetRenderingChromeData Class
Sitecore.Pipelines.GetChromeData Namespace


AddButtonToChromeData Method

[image] [image]

Sitecore 6.4.1 API
GetRenderingChromeData..::..AddButtonToChromeData Method
GetRenderingChromeData Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AddButtonToChromeData(WebEditButton, GetChromeDataArgs) | Adds the button to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | AddButtonToChromeData(IEnumerable<(Of <<'(WebEditButton>)>>), GetChromeDataArgs) | Obsolete. Adds the buttons to chrome data. (Inherited from GetChromeDataProcessor.)

See Also

GetRenderingChromeData Class
GetRenderingChromeData Members
Sitecore.Pipelines.GetChromeData Namespace


GetButtons Method

[image] [image]

Sitecore 6.4.1 API
GetRenderingChromeData..::..GetButtons Method
GetRenderingChromeData Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetButtons(String) | Gets buttons under the specified root (Inherited from GetChromeDataProcessor.)
Protected method | GetButtons(Item) | Gets buttons under the specified root (Inherited from GetChromeDataProcessor.)

See Also

GetRenderingChromeData Class
GetRenderingChromeData Members
Sitecore.Pipelines.GetChromeData Namespace


Process Method

[image]

Sitecore 6.4.1 API
GetRenderingChromeData..::..Process Method
GetRenderingChromeData Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    GetChromeDataArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As GetChromeDataArgs _
)
Visual C++
public:
virtual void Process(
    GetChromeDataArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.GetChromeData..::..GetChromeDataArgs
The args.

See Also

GetRenderingChromeData Class
Sitecore.Pipelines.GetChromeData Namespace


QueryButtonState Method

[image] [image]

Sitecore 6.4.1 API
GetRenderingChromeData..::..QueryButtonState Method
GetRenderingChromeData Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | QueryButtonState(WebEditButton, CommandContext) | Queries the state of the button. (Inherited from GetChromeDataProcessor.)
Protected method | QueryButtonState(WebEditButton, CommandContext, String) | Queries the state of the button. (Inherited from GetChromeDataProcessor.)

See Also

GetRenderingChromeData Class
GetRenderingChromeData Members
Sitecore.Pipelines.GetChromeData Namespace


GetWordFieldChromeData Class

[image]

Sitecore 6.4.1 API
GetWordFieldChromeData Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetWordFieldChromeData : GetChromeDataProcessor
Visual Basic
Public Class GetWordFieldChromeData _
    Inherits GetChromeDataProcessor
Visual C++
public ref class GetWordFieldChromeData : public GetChromeDataProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetChromeData..::..GetChromeDataProcessor
Sitecore.Pipelines.GetChromeData..::..GetWordFieldChromeData

See Also

GetWordFieldChromeData Members
Sitecore.Pipelines.GetChromeData Namespace


GetWordFieldChromeData Members

[image] [image]

Sitecore 6.4.1 API
GetWordFieldChromeData Members
GetWordFieldChromeData Class Constructors Methods See Also Send Feedback

The GetWordFieldChromeData type exposes the following members.

Constructors

 | Name | Description
Public method | GetWordFieldChromeData | Initializes a new instance of the GetWordFieldChromeData class

Methods

 | Name | Description
Protected method | AddButtonsToChromeData | Adds the buttons to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | AddButtonToChromeData(WebEditButton, GetChromeDataArgs) | Adds the button to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | AddButtonToChromeData(IEnumerable<(Of <<'(WebEditButton>)>>), GetChromeDataArgs) | Obsolete. Adds the buttons to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | ConvertToWebEditButton | Converts button item to Web Edit Button (Inherited from GetChromeDataProcessor.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetButtons(String) | Gets buttons under the specified root (Inherited from GetChromeDataProcessor.)
Protected method | GetButtons(Item) | Gets buttons under the specified root (Inherited from GetChromeDataProcessor.)
Protected method | GetFieldEditorButton | Gets the field editor button. (Inherited from GetChromeDataProcessor.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSmallButton | Gets the small button. (Inherited from GetChromeDataProcessor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetWebEditButton | Gets the web edit button. (Inherited from GetChromeDataProcessor.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides GetChromeDataProcessor..::..Process(GetChromeDataArgs).)
Protected method | QueryButtonState(WebEditButton, CommandContext) | Queries the state of the button. (Inherited from GetChromeDataProcessor.)
Protected method | QueryButtonState(WebEditButton, CommandContext, String) | Queries the state of the button. (Inherited from GetChromeDataProcessor.)
Protected method | QueryChromeButtonState | Queries the state of the chrome button. (Inherited from GetChromeDataProcessor.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetWordFieldChromeData Class
Sitecore.Pipelines.GetChromeData Namespace


GetWordFieldChromeData Constructor

[image]

Sitecore 6.4.1 API
GetWordFieldChromeData Constructor
GetWordFieldChromeData Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetWordFieldChromeData()
Visual Basic
Public Sub New
Visual C++
public:
GetWordFieldChromeData()

See Also

GetWordFieldChromeData Class
Sitecore.Pipelines.GetChromeData Namespace


GetWordFieldChromeData Methods

[image] [image]

Sitecore 6.4.1 API
GetWordFieldChromeData Methods
GetWordFieldChromeData Class See Also Send Feedback

The GetWordFieldChromeData type exposes the following members.

Methods

 | Name | Description
Protected method | AddButtonsToChromeData | Adds the buttons to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | AddButtonToChromeData(WebEditButton, GetChromeDataArgs) | Adds the button to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | AddButtonToChromeData(IEnumerable<(Of <<'(WebEditButton>)>>), GetChromeDataArgs) | Obsolete. Adds the buttons to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | ConvertToWebEditButton | Converts button item to Web Edit Button (Inherited from GetChromeDataProcessor.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetButtons(String) | Gets buttons under the specified root (Inherited from GetChromeDataProcessor.)
Protected method | GetButtons(Item) | Gets buttons under the specified root (Inherited from GetChromeDataProcessor.)
Protected method | GetFieldEditorButton | Gets the field editor button. (Inherited from GetChromeDataProcessor.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSmallButton | Gets the small button. (Inherited from GetChromeDataProcessor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetWebEditButton | Gets the web edit button. (Inherited from GetChromeDataProcessor.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides GetChromeDataProcessor..::..Process(GetChromeDataArgs).)
Protected method | QueryButtonState(WebEditButton, CommandContext) | Queries the state of the button. (Inherited from GetChromeDataProcessor.)
Protected method | QueryButtonState(WebEditButton, CommandContext, String) | Queries the state of the button. (Inherited from GetChromeDataProcessor.)
Protected method | QueryChromeButtonState | Queries the state of the chrome button. (Inherited from GetChromeDataProcessor.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetWordFieldChromeData Class
Sitecore.Pipelines.GetChromeData Namespace


AddButtonToChromeData Method

[image] [image]

Sitecore 6.4.1 API
GetWordFieldChromeData..::..AddButtonToChromeData Method
GetWordFieldChromeData Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AddButtonToChromeData(WebEditButton, GetChromeDataArgs) | Adds the button to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | AddButtonToChromeData(IEnumerable<(Of <<'(WebEditButton>)>>), GetChromeDataArgs) | Obsolete. Adds the buttons to chrome data. (Inherited from GetChromeDataProcessor.)

See Also

GetWordFieldChromeData Class
GetWordFieldChromeData Members
Sitecore.Pipelines.GetChromeData Namespace


GetButtons Method

[image] [image]

Sitecore 6.4.1 API
GetWordFieldChromeData..::..GetButtons Method
GetWordFieldChromeData Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetButtons(String) | Gets buttons under the specified root (Inherited from GetChromeDataProcessor.)
Protected method | GetButtons(Item) | Gets buttons under the specified root (Inherited from GetChromeDataProcessor.)

See Also

GetWordFieldChromeData Class
GetWordFieldChromeData Members
Sitecore.Pipelines.GetChromeData Namespace


QueryButtonState Method

[image] [image]

Sitecore 6.4.1 API
GetWordFieldChromeData..::..QueryButtonState Method
GetWordFieldChromeData Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | QueryButtonState(WebEditButton, CommandContext) | Queries the state of the button. (Inherited from GetChromeDataProcessor.)
Protected method | QueryButtonState(WebEditButton, CommandContext, String) | Queries the state of the button. (Inherited from GetChromeDataProcessor.)

See Also

GetWordFieldChromeData Class
GetWordFieldChromeData Members
Sitecore.Pipelines.GetChromeData Namespace


Setup Class

[image]

Sitecore 6.4.1 API
Setup Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Setup : GetChromeDataProcessor
Visual Basic
Public Class Setup _
    Inherits GetChromeDataProcessor
Visual C++
public ref class Setup : public GetChromeDataProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetChromeData..::..GetChromeDataProcessor
Sitecore.Pipelines.GetChromeData..::..Setup

See Also

Setup Members
Sitecore.Pipelines.GetChromeData Namespace


Setup Members

[image] [image]

Sitecore 6.4.1 API
Setup Members
Setup Class Constructors Methods See Also Send Feedback

The Setup type exposes the following members.

Constructors

 | Name | Description
Public method | Setup | Initializes a new instance of the Setup class

Methods

 | Name | Description
Protected method | AddButtonsToChromeData | Adds the buttons to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | AddButtonToChromeData(WebEditButton, GetChromeDataArgs) | Adds the button to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | AddButtonToChromeData(IEnumerable<(Of <<'(WebEditButton>)>>), GetChromeDataArgs) | Obsolete. Adds the buttons to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | ConvertToWebEditButton | Converts button item to Web Edit Button (Inherited from GetChromeDataProcessor.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetButtons(String) | Gets buttons under the specified root (Inherited from GetChromeDataProcessor.)
Protected method | GetButtons(Item) | Gets buttons under the specified root (Inherited from GetChromeDataProcessor.)
Protected method | GetFieldEditorButton | Gets the field editor button. (Inherited from GetChromeDataProcessor.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSmallButton | Gets the small button. (Inherited from GetChromeDataProcessor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetWebEditButton | Gets the web edit button. (Inherited from GetChromeDataProcessor.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides GetChromeDataProcessor..::..Process(GetChromeDataArgs).)
Protected method | QueryButtonState(WebEditButton, CommandContext) | Queries the state of the button. (Inherited from GetChromeDataProcessor.)
Protected method | QueryButtonState(WebEditButton, CommandContext, String) | Queries the state of the button. (Inherited from GetChromeDataProcessor.)
Protected method | QueryChromeButtonState | Queries the state of the chrome button. (Inherited from GetChromeDataProcessor.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Setup Class
Sitecore.Pipelines.GetChromeData Namespace


Setup Constructor

[image]

Sitecore 6.4.1 API
Setup Constructor
Setup Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Setup()
Visual Basic
Public Sub New
Visual C++
public:
Setup()

See Also

Setup Class
Sitecore.Pipelines.GetChromeData Namespace


Setup Methods

[image] [image]

Sitecore 6.4.1 API
Setup Methods
Setup Class See Also Send Feedback

The Setup type exposes the following members.

Methods

 | Name | Description
Protected method | AddButtonsToChromeData | Adds the buttons to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | AddButtonToChromeData(WebEditButton, GetChromeDataArgs) | Adds the button to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | AddButtonToChromeData(IEnumerable<(Of <<'(WebEditButton>)>>), GetChromeDataArgs) | Obsolete. Adds the buttons to chrome data. (Inherited from GetChromeDataProcessor.)
Protected method | ConvertToWebEditButton | Converts button item to Web Edit Button (Inherited from GetChromeDataProcessor.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetButtons(String) | Gets buttons under the specified root (Inherited from GetChromeDataProcessor.)
Protected method | GetButtons(Item) | Gets buttons under the specified root (Inherited from GetChromeDataProcessor.)
Protected method | GetFieldEditorButton | Gets the field editor button. (Inherited from GetChromeDataProcessor.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSmallButton | Gets the small button. (Inherited from GetChromeDataProcessor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetWebEditButton | Gets the web edit button. (Inherited from GetChromeDataProcessor.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides GetChromeDataProcessor..::..Process(GetChromeDataArgs).)
Protected method | QueryButtonState(WebEditButton, CommandContext) | Queries the state of the button. (Inherited from GetChromeDataProcessor.)
Protected method | QueryButtonState(WebEditButton, CommandContext, String) | Queries the state of the button. (Inherited from GetChromeDataProcessor.)
Protected method | QueryChromeButtonState | Queries the state of the chrome button. (Inherited from GetChromeDataProcessor.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Setup Class
Sitecore.Pipelines.GetChromeData Namespace


GetButtons Method

[image] [image]

Sitecore 6.4.1 API
Setup..::..GetButtons Method
Setup Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetButtons(String) | Gets buttons under the specified root (Inherited from GetChromeDataProcessor.)
Protected method | GetButtons(Item) | Gets buttons under the specified root (Inherited from GetChromeDataProcessor.)

See Also

Setup Class
Setup Members
Sitecore.Pipelines.GetChromeData Namespace


Process Method

[image]

Sitecore 6.4.1 API
Setup..::..Process Method
Setup Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetChromeData
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    GetChromeDataArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As GetChromeDataArgs _
)
Visual C++
public:
virtual void Process(
    GetChromeDataArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.GetChromeData..::..GetChromeDataArgs
The args.

See Also

Setup Class
Sitecore.Pipelines.GetChromeData Namespace


QueryButtonState Method

[image] [image]

Sitecore 6.4.1 API
Setup..::..QueryButtonState Method
Setup Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | QueryButtonState(WebEditButton, CommandContext) | Queries the state of the button. (Inherited from GetChromeDataProcessor.)
Protected method | QueryButtonState(WebEditButton, CommandContext, String) | Queries the state of the button. (Inherited from GetChromeDataProcessor.)

See Also

Setup Class
Setup Members
Sitecore.Pipelines.GetChromeData Namespace


Sitecore.Pipelines.GetContentEditorWarnings Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.GetContentEditorWarnings Namespace
Send Feedback

Classes

 | Class | Description
Public class | CanReadLanguage | Implements the RenderField.
Public class | CanWrite | Implements the RenderField.
Public class | CanWriteLanguage | Implements the RenderField.
Public class | CanWriteWorkflow | Implements the RenderField.
Public class | FeedIsEmpty | Defines the feed is empty class.
Public class | GetContentEditorWarningsArgs | Implements the RenderField.
Public class | GetContentEditorWarningsArgs..::..ContentEditorWarning |
Public class | HasNoFields | Implements the RenderField.
Public class | HasNoVersions | Implements the RenderField.
Public class | IsLocked | Implements the RenderField.
Public class | IsReadOnly | Implements the RenderField.
Public class | ItemNotFound | Implements the RenderField.
Public class | ItemPublishingRestricted | Implements the RenderField.
Public class | LanguageNotFound | Implements the RenderField.
Public class | MissingMarketingProfiles | Defines the missing marketing profiles class.
Public class | NeverPublish | Implements the RenderField.
Public class | RunRules | Implements the RenderField.
Public class | ShowingInputBoxes | Implements the RenderField.
Public class | VersionPublishingRestricted | Implements the RenderField.


CanReadLanguage Class

[image]

Sitecore 6.4.1 API
CanReadLanguage Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CanReadLanguage
Visual Basic
Public Class CanReadLanguage
Visual C++
public ref class CanReadLanguage

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetContentEditorWarnings..::..CanReadLanguage

See Also

CanReadLanguage Members
Sitecore.Pipelines.GetContentEditorWarnings Namespace


CanReadLanguage Members

[image] [image]

Sitecore 6.4.1 API
CanReadLanguage Members
CanReadLanguage Class Constructors Methods See Also Send Feedback

The CanReadLanguage type exposes the following members.

Constructors

 | Name | Description
Public method | CanReadLanguage | Initializes a new instance of the CanReadLanguage class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CanReadLanguage Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


CanReadLanguage Constructor

[image]

Sitecore 6.4.1 API
CanReadLanguage Constructor
CanReadLanguage Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CanReadLanguage()
Visual Basic
Public Sub New
Visual C++
public:
CanReadLanguage()

See Also

CanReadLanguage Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


CanReadLanguage Methods

[image] [image]

Sitecore 6.4.1 API
CanReadLanguage Methods
CanReadLanguage Class See Also Send Feedback

The CanReadLanguage type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CanReadLanguage Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


Process Method

[image]

Sitecore 6.4.1 API
CanReadLanguage..::..Process Method
CanReadLanguage Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    GetContentEditorWarningsArgs args
)
Visual Basic
Public Sub Process ( _
    args As GetContentEditorWarningsArgs _
)
Visual C++
public:
void Process(
    GetContentEditorWarningsArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.GetContentEditorWarnings..::..GetContentEditorWarningsArgs
The arguments.

See Also

CanReadLanguage Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


CanWrite Class

[image]

Sitecore 6.4.1 API
CanWrite Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CanWrite
Visual Basic
Public Class CanWrite
Visual C++
public ref class CanWrite

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetContentEditorWarnings..::..CanWrite

See Also

CanWrite Members
Sitecore.Pipelines.GetContentEditorWarnings Namespace


CanWrite Constructor

[image]

Sitecore 6.4.1 API
CanWrite Constructor
CanWrite Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CanWrite()
Visual Basic
Public Sub New
Visual C++
public:
CanWrite()

See Also

CanWrite Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


CanWrite Methods

[image] [image]

Sitecore 6.4.1 API
CanWrite Methods
CanWrite Class See Also Send Feedback

The CanWrite type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CanWrite Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


Process Method

[image]

Sitecore 6.4.1 API
CanWrite..::..Process Method
CanWrite Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    GetContentEditorWarningsArgs args
)
Visual Basic
Public Sub Process ( _
    args As GetContentEditorWarningsArgs _
)
Visual C++
public:
void Process(
    GetContentEditorWarningsArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.GetContentEditorWarnings..::..GetContentEditorWarningsArgs
The arguments.

See Also

CanWrite Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


CanWriteLanguage Class

[image]

Sitecore 6.4.1 API
CanWriteLanguage Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CanWriteLanguage
Visual Basic
Public Class CanWriteLanguage
Visual C++
public ref class CanWriteLanguage

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetContentEditorWarnings..::..CanWriteLanguage

See Also

CanWriteLanguage Members
Sitecore.Pipelines.GetContentEditorWarnings Namespace


CanWriteLanguage Members

[image] [image]

Sitecore 6.4.1 API
CanWriteLanguage Members
CanWriteLanguage Class Constructors Methods See Also Send Feedback

The CanWriteLanguage type exposes the following members.

Constructors

 | Name | Description
Public method | CanWriteLanguage | Initializes a new instance of the CanWriteLanguage class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CanWriteLanguage Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


CanWriteLanguage Constructor

[image]

Sitecore 6.4.1 API
CanWriteLanguage Constructor
CanWriteLanguage Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CanWriteLanguage()
Visual Basic
Public Sub New
Visual C++
public:
CanWriteLanguage()

See Also

CanWriteLanguage Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


CanWriteLanguage Methods

[image] [image]

Sitecore 6.4.1 API
CanWriteLanguage Methods
CanWriteLanguage Class See Also Send Feedback

The CanWriteLanguage type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CanWriteLanguage Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


CanWriteWorkflow Class

[image]

Sitecore 6.4.1 API
CanWriteWorkflow Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CanWriteWorkflow
Visual Basic
Public Class CanWriteWorkflow
Visual C++
public ref class CanWriteWorkflow

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetContentEditorWarnings..::..CanWriteWorkflow

See Also

CanWriteWorkflow Members
Sitecore.Pipelines.GetContentEditorWarnings Namespace


CanWriteWorkflow Members

[image] [image]

Sitecore 6.4.1 API
CanWriteWorkflow Members
CanWriteWorkflow Class Constructors Methods See Also Send Feedback

The CanWriteWorkflow type exposes the following members.

Constructors

 | Name | Description
Public method | CanWriteWorkflow | Initializes a new instance of the CanWriteWorkflow class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CanWriteWorkflow Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


CanWriteWorkflow Constructor

[image]

Sitecore 6.4.1 API
CanWriteWorkflow Constructor
CanWriteWorkflow Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CanWriteWorkflow()
Visual Basic
Public Sub New
Visual C++
public:
CanWriteWorkflow()

See Also

CanWriteWorkflow Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


CanWriteWorkflow Methods

[image] [image]

Sitecore 6.4.1 API
CanWriteWorkflow Methods
CanWriteWorkflow Class See Also Send Feedback

The CanWriteWorkflow type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CanWriteWorkflow Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


Process Method

[image]

Sitecore 6.4.1 API
CanWriteWorkflow..::..Process Method
CanWriteWorkflow Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    GetContentEditorWarningsArgs args
)
Visual Basic
Public Sub Process ( _
    args As GetContentEditorWarningsArgs _
)
Visual C++
public:
void Process(
    GetContentEditorWarningsArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.GetContentEditorWarnings..::..GetContentEditorWarningsArgs
The arguments.

See Also

CanWriteWorkflow Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


FeedIsEmpty Class

[image]

Sitecore 6.4.1 API
FeedIsEmpty Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FeedIsEmpty
Visual Basic
Public Class FeedIsEmpty
Visual C++
public ref class FeedIsEmpty

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetContentEditorWarnings..::..FeedIsEmpty

See Also

FeedIsEmpty Members
Sitecore.Pipelines.GetContentEditorWarnings Namespace


FeedIsEmpty Members

[image] [image]

Sitecore 6.4.1 API
FeedIsEmpty Members
FeedIsEmpty Class Constructors Methods See Also Send Feedback

The FeedIsEmpty type exposes the following members.

Constructors

 | Name | Description
Public method | FeedIsEmpty | Initializes a new instance of the FeedIsEmpty class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FeedIsEmpty Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


FeedIsEmpty Constructor

[image]

Sitecore 6.4.1 API
FeedIsEmpty Constructor
FeedIsEmpty Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FeedIsEmpty()
Visual Basic
Public Sub New
Visual C++
public:
FeedIsEmpty()

See Also

FeedIsEmpty Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


FeedIsEmpty Methods

[image] [image]

Sitecore 6.4.1 API
FeedIsEmpty Methods
FeedIsEmpty Class See Also Send Feedback

The FeedIsEmpty type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FeedIsEmpty Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


Process Method

[image]

Sitecore 6.4.1 API
FeedIsEmpty..::..Process Method
FeedIsEmpty Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    GetContentEditorWarningsArgs args
)
Visual Basic
Public Sub Process ( _
    args As GetContentEditorWarningsArgs _
)
Visual C++
public:
void Process(
    GetContentEditorWarningsArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.GetContentEditorWarnings..::..GetContentEditorWarningsArgs
The arguments.

See Also

FeedIsEmpty Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


GetContentEditorWarningsArgs Class

[image]

Sitecore 6.4.1 API
GetContentEditorWarningsArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class GetContentEditorWarningsArgs : PipelineArgs
Visual Basic
<SerializableAttribute> _
Public Class GetContentEditorWarningsArgs _
    Inherits PipelineArgs
Visual C++
[SerializableAttribute]
public ref class GetContentEditorWarningsArgs : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Pipelines.GetContentEditorWarnings..::..GetContentEditorWarningsArgs

See Also

GetContentEditorWarningsArgs Members
Sitecore.Pipelines.GetContentEditorWarnings Namespace


GetContentEditorWarningsArgs Members

[image] [image]

Sitecore 6.4.1 API
GetContentEditorWarningsArgs Members
GetContentEditorWarningsArgs Class Constructors Methods Properties See Also Send Feedback

The GetContentEditorWarningsArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GetContentEditorWarningsArgs(Item) | Initializes a new instance of the GetContentEditorWarningsArgs class.
Protected method | GetContentEditorWarningsArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the GetContentEditorWarningsArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | Add()()()() | Adds this instance.
Public method | Add(String, String) | Adds the specified title.
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasFullscreenWarnings | Determines whether there is a fullscreen warning.
Public method | HideFields | Determines whether there is a fullscreen warning.
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Empty | Gets the empty.
Public property | HasSections | Gets or sets a value indicating whether this instance has sections.
Public property | Item | Gets the item.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | ShowInputBoxes | Gets or sets a value indicating whether the GetContentEditorWarningsArgs shows the input boxes.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
Public property | Warnings | Gets the warnings.

See Also

GetContentEditorWarningsArgs Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


GetContentEditorWarningsArgs Constructor

[image] [image]

Sitecore 6.4.1 API
GetContentEditorWarningsArgs Constructor
GetContentEditorWarningsArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetContentEditorWarningsArgs(Item) | Initializes a new instance of the GetContentEditorWarningsArgs class.
Protected method | GetContentEditorWarningsArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the GetContentEditorWarningsArgs class.

See Also

GetContentEditorWarningsArgs Class
GetContentEditorWarningsArgs Members
Sitecore.Pipelines.GetContentEditorWarnings Namespace


GetContentEditorWarningsArgs Constructor (Item)

[image]

Sitecore 6.4.1 API
GetContentEditorWarningsArgs Constructor (Item)
GetContentEditorWarningsArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetContentEditorWarningsArgs(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
GetContentEditorWarningsArgs(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

GetContentEditorWarningsArgs Class
GetContentEditorWarningsArgs Overload
Sitecore.Pipelines.GetContentEditorWarnings Namespace


GetContentEditorWarningsArgs Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
GetContentEditorWarningsArgs Constructor (SerializationInfo, StreamingContext)
GetContentEditorWarningsArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected GetContentEditorWarningsArgs(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
GetContentEditorWarningsArgs(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

GetContentEditorWarningsArgs Class
GetContentEditorWarningsArgs Overload
Sitecore.Pipelines.GetContentEditorWarnings Namespace


GetContentEditorWarningsArgs Methods

[image] [image]

Sitecore 6.4.1 API
GetContentEditorWarningsArgs Methods
GetContentEditorWarningsArgs Class See Also Send Feedback

The GetContentEditorWarningsArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | Add()()()() | Adds this instance.
Public method | Add(String, String) | Adds the specified title.
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasFullscreenWarnings | Determines whether there is a fullscreen warning.
Public method | HideFields | Determines whether there is a fullscreen warning.
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetContentEditorWarningsArgs Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


Add Method

[image] [image]

Sitecore 6.4.1 API
GetContentEditorWarningsArgs..::..Add Method
GetContentEditorWarningsArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add()()()() | Adds this instance.
Public method | Add(String, String) | Adds the specified title.

See Also

GetContentEditorWarningsArgs Class
GetContentEditorWarningsArgs Members
Sitecore.Pipelines.GetContentEditorWarnings Namespace


Add Method

[image]

Sitecore 6.4.1 API
GetContentEditorWarningsArgs..::..Add Method
GetContentEditorWarningsArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetContentEditorWarningsArgs..::..ContentEditorWarning Add()
Visual Basic
Public Function Add As GetContentEditorWarningsArgs..::..ContentEditorWarning
Visual C++
public:
GetContentEditorWarningsArgs..::..ContentEditorWarning^ Add()

Return Value

The add.

See Also

GetContentEditorWarningsArgs Class
Add Overload
Sitecore.Pipelines.GetContentEditorWarnings Namespace


Add Method (String, String)

[image]

Sitecore 6.4.1 API
GetContentEditorWarningsArgs..::..Add Method (String, String)
GetContentEditorWarningsArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Add(
    string title,
    string text
)
Visual Basic
Public Sub Add ( _
    title As String, _
    text As String _
)
Visual C++
public:
void Add(
    String^ title,
    String^ text
)

Parameters

title
Type: System..::..String
The title.
text
Type: System..::..String
The text.

See Also

GetContentEditorWarningsArgs Class
Add Overload
Sitecore.Pipelines.GetContentEditorWarnings Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
GetContentEditorWarningsArgs..::..AddMessage Method
GetContentEditorWarningsArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

GetContentEditorWarningsArgs Class
GetContentEditorWarningsArgs Members
Sitecore.Pipelines.GetContentEditorWarnings Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
GetContentEditorWarningsArgs..::..GetMessages Method
GetContentEditorWarningsArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

GetContentEditorWarningsArgs Class
GetContentEditorWarningsArgs Members
Sitecore.Pipelines.GetContentEditorWarnings Namespace


GetObjectData Method

[image]

Sitecore 6.4.1 API
GetContentEditorWarningsArgs..::..GetObjectData Method
GetContentEditorWarningsArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System.Security..::..SecurityException | The caller does not have the required permission.

See Also

GetContentEditorWarningsArgs Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


HasFullscreenWarnings Method

[image]

Sitecore 6.4.1 API
GetContentEditorWarningsArgs..::..HasFullscreenWarnings Method
GetContentEditorWarningsArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool HasFullscreenWarnings()
Visual Basic
Public Function HasFullscreenWarnings As Boolean
Visual C++
public:
bool HasFullscreenWarnings()

Return Value

true if there is a fullscreen warning; otherwise, false.

See Also

GetContentEditorWarningsArgs Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
GetContentEditorWarningsArgs..::..Suspend Method
GetContentEditorWarningsArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

GetContentEditorWarningsArgs Class
GetContentEditorWarningsArgs Members
Sitecore.Pipelines.GetContentEditorWarnings Namespace


GetContentEditorWarningsArgs Properties

[image] [image]

Sitecore 6.4.1 API
GetContentEditorWarningsArgs Properties
GetContentEditorWarningsArgs Class See Also Send Feedback

The GetContentEditorWarningsArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
 | Empty | Gets the empty.
Public property | HasSections | Gets or sets a value indicating whether this instance has sections.
Public property | Item | Gets the item.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | ShowInputBoxes | Gets or sets a value indicating whether the GetContentEditorWarningsArgs shows the input boxes.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
Public property | Warnings | Gets the warnings.

See Also

GetContentEditorWarningsArgs Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


Empty Property

[image]

Sitecore 6.4.1 API
GetContentEditorWarningsArgs..::..Empty Property
GetContentEditorWarningsArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static GetContentEditorWarningsArgs Empty { get; }
Visual Basic
Public Shared ReadOnly Property Empty As GetContentEditorWarningsArgs
    Get
Visual C++
public:
static property GetContentEditorWarningsArgs^ Empty {
    GetContentEditorWarningsArgs^ get ();
}

Field Value

The empty.

See Also

GetContentEditorWarningsArgs Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


HasSections Property

[image]

Sitecore 6.4.1 API
GetContentEditorWarningsArgs..::..HasSections Property
GetContentEditorWarningsArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool HasSections { get; set; }
Visual Basic
Public Property HasSections As Boolean
    Get
    Set
Visual C++
public:
property bool HasSections {
    bool get ();
    void set (bool value);
}

Field Value

true if this instance has sections; otherwise, false.

See Also

GetContentEditorWarningsArgs Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


ShowInputBoxes Property

[image]

Sitecore 6.4.1 API
GetContentEditorWarningsArgs..::..ShowInputBoxes Property
GetContentEditorWarningsArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ShowInputBoxes { get; set; }
Visual Basic
Public Property ShowInputBoxes As Boolean
    Get
    Set
Visual C++
public:
property bool ShowInputBoxes {
    bool get ();
    void set (bool value);
}

Field Value

true if the GetContentEditorWarningsArgs shows the input boxes; otherwise, false.

See Also

GetContentEditorWarningsArgs Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


Warnings Property

[image]

Sitecore 6.4.1 API
GetContentEditorWarningsArgs..::..Warnings Property
GetContentEditorWarningsArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public List<GetContentEditorWarningsArgs..::..ContentEditorWarning> Warnings { get; }
Visual Basic
Public ReadOnly Property Warnings As List(Of GetContentEditorWarningsArgs..::..ContentEditorWarning)
    Get
Visual C++
public:
property List<GetContentEditorWarningsArgs..::..ContentEditorWarning^>^ Warnings {
    List<GetContentEditorWarningsArgs..::..ContentEditorWarning^>^ get ();
}

Field Value

The warnings.

See Also

GetContentEditorWarningsArgs Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


GetContentEditorWarningsArgs.ContentEditorWarning Class

[image]

Sitecore 6.4.1 API
GetContentEditorWarningsArgs..::..ContentEditorWarning Class
GetContentEditorWarningsArgs Class Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ContentEditorWarning
Visual Basic
Public Class ContentEditorWarning
Visual C++
public ref class ContentEditorWarning

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetContentEditorWarnings..::..GetContentEditorWarningsArgs..::..ContentEditorWarning

See Also

GetContentEditorWarningsArgs..::..ContentEditorWarning Members
Sitecore.Pipelines.GetContentEditorWarnings Namespace


GetContentEditorWarningsArgs.ContentEditorWarning Members

[image] [image]

Sitecore 6.4.1 API
GetContentEditorWarningsArgs..::..ContentEditorWarning Members
GetContentEditorWarningsArgs..::..ContentEditorWarning Class Constructors Methods Properties See Also Send Feedback

Implements the RenderField.

The GetContentEditorWarningsArgs..::..ContentEditorWarning type exposes the following members.

Constructors

 | Name | Description
Public method | GetContentEditorWarningsArgs..::..ContentEditorWarning | Initializes a new instance of the GetContentEditorWarningsArgs..::..ContentEditorWarning class

Methods

 | Name | Description
Public method | AddOption | Adds the option.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | HideFields | Gets or sets a value indicating whether the GetContentEditorWarningsArgs..::..ContentEditorWarning hides the fields.
Public property | Icon | Gets or sets the icon.
Public property | IsExclusive | Gets or sets a value indicating whether this GetContentEditorWarningsArgs..::..ContentEditorWarning is exclusive.
Public property | IsFullscreen | Gets or sets a value indicating whether this GetContentEditorWarningsArgs..::..ContentEditorWarning is fullscreen.
Public property | Options | Gets the options.
Public property | Text | Gets or sets the text.
Public property | Title | Gets or sets the title.

See Also

GetContentEditorWarningsArgs..::..ContentEditorWarning Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


GetContentEditorWarningsArgs.ContentEditorWarning Constructor

[image]

Sitecore 6.4.1 API
GetContentEditorWarningsArgs..::..ContentEditorWarning Constructor
GetContentEditorWarningsArgs..::..ContentEditorWarning Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ContentEditorWarning()
Visual Basic
Public Sub New
Visual C++
public:
ContentEditorWarning()

See Also

GetContentEditorWarningsArgs..::..ContentEditorWarning Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


GetContentEditorWarningsArgs.ContentEditorWarning Methods

[image] [image]

Sitecore 6.4.1 API
GetContentEditorWarningsArgs..::..ContentEditorWarning Methods
GetContentEditorWarningsArgs..::..ContentEditorWarning Class See Also Send Feedback

The GetContentEditorWarningsArgs..::..ContentEditorWarning type exposes the following members.

Methods

 | Name | Description
Public method | AddOption | Adds the option.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetContentEditorWarningsArgs..::..ContentEditorWarning Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


AddOption Method

[image]

Sitecore 6.4.1 API
GetContentEditorWarningsArgs..::..ContentEditorWarning..::..AddOption Method
GetContentEditorWarningsArgs..::..ContentEditorWarning Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddOption(
    string header,
    string command
)
Visual Basic
Public Sub AddOption ( _
    header As String, _
    command As String _
)
Visual C++
public:
void AddOption(
    String^ header,
    String^ command
)

Parameters

header
Type: System..::..String
The header.
command
Type: System..::..String
The command.

See Also

GetContentEditorWarningsArgs..::..ContentEditorWarning Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


GetContentEditorWarningsArgs.ContentEditorWarning Properties

[image] [image]

Sitecore 6.4.1 API
GetContentEditorWarningsArgs..::..ContentEditorWarning Properties
GetContentEditorWarningsArgs..::..ContentEditorWarning Class See Also Send Feedback

The GetContentEditorWarningsArgs..::..ContentEditorWarning type exposes the following members.

Properties

 | Name | Description
Public property | HideFields | Gets or sets a value indicating whether the GetContentEditorWarningsArgs..::..ContentEditorWarning hides the fields.
Public property | Icon | Gets or sets the icon.
Public property | IsExclusive | Gets or sets a value indicating whether this GetContentEditorWarningsArgs..::..ContentEditorWarning is exclusive.
Public property | IsFullscreen | Gets or sets a value indicating whether this GetContentEditorWarningsArgs..::..ContentEditorWarning is fullscreen.
Public property | Options | Gets the options.
Public property | Text | Gets or sets the text.
Public property | Title | Gets or sets the title.

See Also

GetContentEditorWarningsArgs..::..ContentEditorWarning Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


Icon Property

[image]

Sitecore 6.4.1 API
GetContentEditorWarningsArgs..::..ContentEditorWarning..::..Icon Property
GetContentEditorWarningsArgs..::..ContentEditorWarning Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Icon { get; set; }
Visual Basic
Public Property Icon As String
    Get
    Set
Visual C++
public:
property String^ Icon {
    String^ get ();
    void set (String^ value);
}

Field Value

The icon.

See Also

GetContentEditorWarningsArgs..::..ContentEditorWarning Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


IsExclusive Property

[image]

Sitecore 6.4.1 API
GetContentEditorWarningsArgs..::..ContentEditorWarning..::..IsExclusive Property
GetContentEditorWarningsArgs..::..ContentEditorWarning Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsExclusive { get; set; }
Visual Basic
Public Property IsExclusive As Boolean
    Get
    Set
Visual C++
public:
property bool IsExclusive {
    bool get ();
    void set (bool value);
}

Field Value

true if exclusive; otherwise, false.

See Also

GetContentEditorWarningsArgs..::..ContentEditorWarning Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


IsFullscreen Property

[image]

Sitecore 6.4.1 API
GetContentEditorWarningsArgs..::..ContentEditorWarning..::..IsFullscreen Property
GetContentEditorWarningsArgs..::..ContentEditorWarning Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsFullscreen { get; set; }
Visual Basic
Public Property IsFullscreen As Boolean
    Get
    Set
Visual C++
public:
property bool IsFullscreen {
    bool get ();
    void set (bool value);
}

Field Value

true if fullscreen; otherwise, false.

See Also

GetContentEditorWarningsArgs..::..ContentEditorWarning Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


Options Property

[image]

Sitecore 6.4.1 API
GetContentEditorWarningsArgs..::..ContentEditorWarning..::..Options Property
GetContentEditorWarningsArgs..::..ContentEditorWarning Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public List<Pair<string, string>> Options { get; }
Visual Basic
Public ReadOnly Property Options As List(Of Pair(Of String, String))
    Get
Visual C++
public:
property List<Pair<String^, String^>^>^ Options {
    List<Pair<String^, String^>^>^ get ();
}

Field Value

The options.

See Also

GetContentEditorWarningsArgs..::..ContentEditorWarning Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


Title Property

[image]

Sitecore 6.4.1 API
GetContentEditorWarningsArgs..::..ContentEditorWarning..::..Title Property
GetContentEditorWarningsArgs..::..ContentEditorWarning Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Title { get; set; }
Visual Basic
Public Property Title As String
    Get
    Set
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

Field Value

The title.

See Also

GetContentEditorWarningsArgs..::..ContentEditorWarning Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


HasNoFields Class

[image]

Sitecore 6.4.1 API
HasNoFields Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class HasNoFields
Visual Basic
Public Class HasNoFields
Visual C++
public ref class HasNoFields

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetContentEditorWarnings..::..HasNoFields

See Also

HasNoFields Members
Sitecore.Pipelines.GetContentEditorWarnings Namespace


HasNoFields Members

[image] [image]

Sitecore 6.4.1 API
HasNoFields Members
HasNoFields Class Constructors Methods See Also Send Feedback

The HasNoFields type exposes the following members.

Constructors

 | Name | Description
Public method | HasNoFields | Initializes a new instance of the HasNoFields class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HasNoFields Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


HasNoFields Constructor

[image]

Sitecore 6.4.1 API
HasNoFields Constructor
HasNoFields Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HasNoFields()
Visual Basic
Public Sub New
Visual C++
public:
HasNoFields()

See Also

HasNoFields Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


HasNoFields Methods

[image] [image]

Sitecore 6.4.1 API
HasNoFields Methods
HasNoFields Class See Also Send Feedback

The HasNoFields type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HasNoFields Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


Process Method

[image]

Sitecore 6.4.1 API
HasNoFields..::..Process Method
HasNoFields Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    GetContentEditorWarningsArgs args
)
Visual Basic
Public Sub Process ( _
    args As GetContentEditorWarningsArgs _
)
Visual C++
public:
void Process(
    GetContentEditorWarningsArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.GetContentEditorWarnings..::..GetContentEditorWarningsArgs
The arguments.

See Also

HasNoFields Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


HasNoVersions Class

[image]

Sitecore 6.4.1 API
HasNoVersions Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class HasNoVersions
Visual Basic
Public Class HasNoVersions
Visual C++
public ref class HasNoVersions

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetContentEditorWarnings..::..HasNoVersions

See Also

HasNoVersions Members
Sitecore.Pipelines.GetContentEditorWarnings Namespace


HasNoVersions Members

[image] [image]

Sitecore 6.4.1 API
HasNoVersions Members
HasNoVersions Class Constructors Methods See Also Send Feedback

The HasNoVersions type exposes the following members.

Constructors

 | Name | Description
Public method | HasNoVersions | Initializes a new instance of the HasNoVersions class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HasNoVersions Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


HasNoVersions Constructor

[image]

Sitecore 6.4.1 API
HasNoVersions Constructor
HasNoVersions Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HasNoVersions()
Visual Basic
Public Sub New
Visual C++
public:
HasNoVersions()

See Also

HasNoVersions Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


HasNoVersions Methods

[image] [image]

Sitecore 6.4.1 API
HasNoVersions Methods
HasNoVersions Class See Also Send Feedback

The HasNoVersions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HasNoVersions Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


Process Method

[image]

Sitecore 6.4.1 API
HasNoVersions..::..Process Method
HasNoVersions Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    GetContentEditorWarningsArgs args
)
Visual Basic
Public Sub Process ( _
    args As GetContentEditorWarningsArgs _
)
Visual C++
public:
void Process(
    GetContentEditorWarningsArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.GetContentEditorWarnings..::..GetContentEditorWarningsArgs
The arguments.

See Also

HasNoVersions Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


IsLocked Class

[image]

Sitecore 6.4.1 API
IsLocked Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class IsLocked
Visual Basic
Public Class IsLocked
Visual C++
public ref class IsLocked

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetContentEditorWarnings..::..IsLocked

See Also

IsLocked Members
Sitecore.Pipelines.GetContentEditorWarnings Namespace


IsLocked Members

[image] [image]

Sitecore 6.4.1 API
IsLocked Members
IsLocked Class Constructors Methods See Also Send Feedback

The IsLocked type exposes the following members.

Constructors

 | Name | Description
Public method | IsLocked | Initializes a new instance of the IsLocked class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IsLocked Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


IsLocked Constructor

[image]

Sitecore 6.4.1 API
IsLocked Constructor
IsLocked Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IsLocked()
Visual Basic
Public Sub New
Visual C++
public:
IsLocked()

See Also

IsLocked Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


IsLocked Methods

[image] [image]

Sitecore 6.4.1 API
IsLocked Methods
IsLocked Class See Also Send Feedback

The IsLocked type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IsLocked Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


Process Method

[image]

Sitecore 6.4.1 API
IsLocked..::..Process Method
IsLocked Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    GetContentEditorWarningsArgs args
)
Visual Basic
Public Sub Process ( _
    args As GetContentEditorWarningsArgs _
)
Visual C++
public:
void Process(
    GetContentEditorWarningsArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.GetContentEditorWarnings..::..GetContentEditorWarningsArgs
The arguments.

See Also

IsLocked Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


IsReadOnly Class

[image]

Sitecore 6.4.1 API
IsReadOnly Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class IsReadOnly
Visual Basic
Public Class IsReadOnly
Visual C++
public ref class IsReadOnly

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetContentEditorWarnings..::..IsReadOnly

See Also

IsReadOnly Members
Sitecore.Pipelines.GetContentEditorWarnings Namespace


IsReadOnly Members

[image] [image]

Sitecore 6.4.1 API
IsReadOnly Members
IsReadOnly Class Constructors Methods See Also Send Feedback

The IsReadOnly type exposes the following members.

Constructors

 | Name | Description
Public method | IsReadOnly | Initializes a new instance of the IsReadOnly class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IsReadOnly Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


IsReadOnly Constructor

[image]

Sitecore 6.4.1 API
IsReadOnly Constructor
IsReadOnly Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IsReadOnly()
Visual Basic
Public Sub New
Visual C++
public:
IsReadOnly()

See Also

IsReadOnly Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


IsReadOnly Methods

[image] [image]

Sitecore 6.4.1 API
IsReadOnly Methods
IsReadOnly Class See Also Send Feedback

The IsReadOnly type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IsReadOnly Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


Process Method

[image]

Sitecore 6.4.1 API
IsReadOnly..::..Process Method
IsReadOnly Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    GetContentEditorWarningsArgs args
)
Visual Basic
Public Sub Process ( _
    args As GetContentEditorWarningsArgs _
)
Visual C++
public:
void Process(
    GetContentEditorWarningsArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.GetContentEditorWarnings..::..GetContentEditorWarningsArgs
The arguments.

See Also

IsReadOnly Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


ItemNotFound Class

[image]

Sitecore 6.4.1 API
ItemNotFound Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemNotFound
Visual Basic
Public Class ItemNotFound
Visual C++
public ref class ItemNotFound

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetContentEditorWarnings..::..ItemNotFound

See Also

ItemNotFound Members
Sitecore.Pipelines.GetContentEditorWarnings Namespace


ItemNotFound Members

[image] [image]

Sitecore 6.4.1 API
ItemNotFound Members
ItemNotFound Class Constructors Methods See Also Send Feedback

The ItemNotFound type exposes the following members.

Constructors

 | Name | Description
Public method | ItemNotFound | Initializes a new instance of the ItemNotFound class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemNotFound Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


ItemNotFound Constructor

[image]

Sitecore 6.4.1 API
ItemNotFound Constructor
ItemNotFound Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemNotFound()
Visual Basic
Public Sub New
Visual C++
public:
ItemNotFound()

See Also

ItemNotFound Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


ItemNotFound Methods

[image] [image]

Sitecore 6.4.1 API
ItemNotFound Methods
ItemNotFound Class See Also Send Feedback

The ItemNotFound type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemNotFound Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


Process Method

[image]

Sitecore 6.4.1 API
ItemNotFound..::..Process Method
ItemNotFound Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    GetContentEditorWarningsArgs args
)
Visual Basic
Public Sub Process ( _
    args As GetContentEditorWarningsArgs _
)
Visual C++
public:
void Process(
    GetContentEditorWarningsArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.GetContentEditorWarnings..::..GetContentEditorWarningsArgs
The arguments.

See Also

ItemNotFound Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


ItemPublishingRestricted Class

[image]

Sitecore 6.4.1 API
ItemPublishingRestricted Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemPublishingRestricted
Visual Basic
Public Class ItemPublishingRestricted
Visual C++
public ref class ItemPublishingRestricted

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetContentEditorWarnings..::..ItemPublishingRestricted

See Also

ItemPublishingRestricted Members
Sitecore.Pipelines.GetContentEditorWarnings Namespace


ItemPublishingRestricted Members

[image] [image]

Sitecore 6.4.1 API
ItemPublishingRestricted Members
ItemPublishingRestricted Class Constructors Methods See Also Send Feedback

The ItemPublishingRestricted type exposes the following members.

Constructors

 | Name | Description
Public method | ItemPublishingRestricted | Initializes a new instance of the ItemPublishingRestricted class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsPublishRestricted | Determines whether publish is restricted for the specified item.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemPublishingRestricted Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


ItemPublishingRestricted Constructor

[image]

Sitecore 6.4.1 API
ItemPublishingRestricted Constructor
ItemPublishingRestricted Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemPublishingRestricted()
Visual Basic
Public Sub New
Visual C++
public:
ItemPublishingRestricted()

See Also

ItemPublishingRestricted Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


IsPublishRestricted Method

[image]

Sitecore 6.4.1 API
ItemPublishingRestricted..::..IsPublishRestricted Method
ItemPublishingRestricted Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsPublishRestricted(
    Item item
)
Visual Basic
Public Shared Function IsPublishRestricted ( _
    item As Item _
) As Boolean
Visual C++
public:
static bool IsPublishRestricted(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

true if publish is restricted for the specified item; otherwise, false.

See Also

ItemPublishingRestricted Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


Process Method

[image]

Sitecore 6.4.1 API
ItemPublishingRestricted..::..Process Method
ItemPublishingRestricted Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    GetContentEditorWarningsArgs args
)
Visual Basic
Public Sub Process ( _
    args As GetContentEditorWarningsArgs _
)
Visual C++
public:
void Process(
    GetContentEditorWarningsArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.GetContentEditorWarnings..::..GetContentEditorWarningsArgs
The arguments.

See Also

ItemPublishingRestricted Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


LanguageNotFound Class

[image]

Sitecore 6.4.1 API
LanguageNotFound Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class LanguageNotFound
Visual Basic
Public Class LanguageNotFound
Visual C++
public ref class LanguageNotFound

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetContentEditorWarnings..::..LanguageNotFound

See Also

LanguageNotFound Members
Sitecore.Pipelines.GetContentEditorWarnings Namespace


LanguageNotFound Members

[image] [image]

Sitecore 6.4.1 API
LanguageNotFound Members
LanguageNotFound Class Constructors Methods See Also Send Feedback

The LanguageNotFound type exposes the following members.

Constructors

 | Name | Description
Public method | LanguageNotFound | Initializes a new instance of the LanguageNotFound class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LanguageNotFound Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


LanguageNotFound Constructor

[image]

Sitecore 6.4.1 API
LanguageNotFound Constructor
LanguageNotFound Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LanguageNotFound()
Visual Basic
Public Sub New
Visual C++
public:
LanguageNotFound()

See Also

LanguageNotFound Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


LanguageNotFound Methods

[image] [image]

Sitecore 6.4.1 API
LanguageNotFound Methods
LanguageNotFound Class See Also Send Feedback

The LanguageNotFound type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LanguageNotFound Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


Process Method

[image]

Sitecore 6.4.1 API
LanguageNotFound..::..Process Method
LanguageNotFound Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    GetContentEditorWarningsArgs args
)
Visual Basic
Public Sub Process ( _
    args As GetContentEditorWarningsArgs _
)
Visual C++
public:
void Process(
    GetContentEditorWarningsArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.GetContentEditorWarnings..::..GetContentEditorWarningsArgs
The arguments.

See Also

LanguageNotFound Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


MissingMarketingProfiles Class

[image]

Sitecore 6.4.1 API
MissingMarketingProfiles Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class MissingMarketingProfiles
Visual Basic
Public Class MissingMarketingProfiles
Visual C++
public ref class MissingMarketingProfiles

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetContentEditorWarnings..::..MissingMarketingProfiles

See Also

MissingMarketingProfiles Members
Sitecore.Pipelines.GetContentEditorWarnings Namespace


MissingMarketingProfiles Members

[image] [image]

Sitecore 6.4.1 API
MissingMarketingProfiles Members
MissingMarketingProfiles Class Constructors Methods See Also Send Feedback

The MissingMarketingProfiles type exposes the following members.

Constructors

 | Name | Description
Public method | MissingMarketingProfiles | Initializes a new instance of the MissingMarketingProfiles class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MissingMarketingProfiles Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


MissingMarketingProfiles Constructor

[image]

Sitecore 6.4.1 API
MissingMarketingProfiles Constructor
MissingMarketingProfiles Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MissingMarketingProfiles()
Visual Basic
Public Sub New
Visual C++
public:
MissingMarketingProfiles()

See Also

MissingMarketingProfiles Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


Process Method

[image]

Sitecore 6.4.1 API
MissingMarketingProfiles..::..Process Method
MissingMarketingProfiles Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    GetContentEditorWarningsArgs args
)
Visual Basic
Public Sub Process ( _
    args As GetContentEditorWarningsArgs _
)
Visual C++
public:
void Process(
    GetContentEditorWarningsArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.GetContentEditorWarnings..::..GetContentEditorWarningsArgs
The arguments.

See Also

MissingMarketingProfiles Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


NeverPublish Members

[image] [image]

Sitecore 6.4.1 API
NeverPublish Members
NeverPublish Class Constructors Methods See Also Send Feedback

The NeverPublish type exposes the following members.

Constructors

 | Name | Description
Public method | NeverPublish | Initializes a new instance of the NeverPublish class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NeverPublish Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


NeverPublish Constructor

[image]

Sitecore 6.4.1 API
NeverPublish Constructor
NeverPublish Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public NeverPublish()
Visual Basic
Public Sub New
Visual C++
public:
NeverPublish()

See Also

NeverPublish Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


NeverPublish Methods

[image] [image]

Sitecore 6.4.1 API
NeverPublish Methods
NeverPublish Class See Also Send Feedback

The NeverPublish type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NeverPublish Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


Process Method

[image]

Sitecore 6.4.1 API
NeverPublish..::..Process Method
NeverPublish Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    GetContentEditorWarningsArgs args
)
Visual Basic
Public Sub Process ( _
    args As GetContentEditorWarningsArgs _
)
Visual C++
public:
void Process(
    GetContentEditorWarningsArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.GetContentEditorWarnings..::..GetContentEditorWarningsArgs
The arguments.

See Also

NeverPublish Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


RunRules Class

[image]

Sitecore 6.4.1 API
RunRules Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RunRules
Visual Basic
Public Class RunRules
Visual C++
public ref class RunRules

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetContentEditorWarnings..::..RunRules

See Also

RunRules Members
Sitecore.Pipelines.GetContentEditorWarnings Namespace


RunRules Members

[image] [image]

Sitecore 6.4.1 API
RunRules Members
RunRules Class Constructors Methods See Also Send Feedback

The RunRules type exposes the following members.

Constructors

 | Name | Description
Public method | RunRules | Initializes a new instance of the RunRules class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RunRules Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


RunRules Methods

[image] [image]

Sitecore 6.4.1 API
RunRules Methods
RunRules Class See Also Send Feedback

The RunRules type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RunRules Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


ShowingInputBoxes Class

[image]

Sitecore 6.4.1 API
ShowingInputBoxes Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ShowingInputBoxes
Visual Basic
Public Class ShowingInputBoxes
Visual C++
public ref class ShowingInputBoxes

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetContentEditorWarnings..::..ShowingInputBoxes

See Also

ShowingInputBoxes Members
Sitecore.Pipelines.GetContentEditorWarnings Namespace


ShowingInputBoxes Members

[image] [image]

Sitecore 6.4.1 API
ShowingInputBoxes Members
ShowingInputBoxes Class Constructors Methods See Also Send Feedback

The ShowingInputBoxes type exposes the following members.

Constructors

 | Name | Description
Public method | ShowingInputBoxes | Initializes a new instance of the ShowingInputBoxes class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShowingInputBoxes Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


ShowingInputBoxes Constructor

[image]

Sitecore 6.4.1 API
ShowingInputBoxes Constructor
ShowingInputBoxes Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ShowingInputBoxes()
Visual Basic
Public Sub New
Visual C++
public:
ShowingInputBoxes()

See Also

ShowingInputBoxes Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


ShowingInputBoxes Methods

[image] [image]

Sitecore 6.4.1 API
ShowingInputBoxes Methods
ShowingInputBoxes Class See Also Send Feedback

The ShowingInputBoxes type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShowingInputBoxes Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


Process Method

[image]

Sitecore 6.4.1 API
ShowingInputBoxes..::..Process Method
ShowingInputBoxes Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    GetContentEditorWarningsArgs args
)
Visual Basic
Public Sub Process ( _
    args As GetContentEditorWarningsArgs _
)
Visual C++
public:
void Process(
    GetContentEditorWarningsArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.GetContentEditorWarnings..::..GetContentEditorWarningsArgs
The arguments.

See Also

ShowingInputBoxes Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


VersionPublishingRestricted Class

[image]

Sitecore 6.4.1 API
VersionPublishingRestricted Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class VersionPublishingRestricted
Visual Basic
Public Class VersionPublishingRestricted
Visual C++
public ref class VersionPublishingRestricted

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetContentEditorWarnings..::..VersionPublishingRestricted

See Also

VersionPublishingRestricted Members
Sitecore.Pipelines.GetContentEditorWarnings Namespace


VersionPublishingRestricted Members

[image] [image]

Sitecore 6.4.1 API
VersionPublishingRestricted Members
VersionPublishingRestricted Class Constructors Methods See Also Send Feedback

The VersionPublishingRestricted type exposes the following members.

Constructors

 | Name | Description
Public method | VersionPublishingRestricted | Initializes a new instance of the VersionPublishingRestricted class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VersionPublishingRestricted Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


VersionPublishingRestricted Constructor

[image]

Sitecore 6.4.1 API
VersionPublishingRestricted Constructor
VersionPublishingRestricted Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public VersionPublishingRestricted()
Visual Basic
Public Sub New
Visual C++
public:
VersionPublishingRestricted()

See Also

VersionPublishingRestricted Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


VersionPublishingRestricted Methods

[image] [image]

Sitecore 6.4.1 API
VersionPublishingRestricted Methods
VersionPublishingRestricted Class See Also Send Feedback

The VersionPublishingRestricted type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VersionPublishingRestricted Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


Process Method

[image]

Sitecore 6.4.1 API
VersionPublishingRestricted..::..Process Method
VersionPublishingRestricted Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetContentEditorWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    GetContentEditorWarningsArgs args
)
Visual Basic
Public Sub Process ( _
    args As GetContentEditorWarningsArgs _
)
Visual C++
public:
void Process(
    GetContentEditorWarningsArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.GetContentEditorWarnings..::..GetContentEditorWarningsArgs
The arguments.

See Also

VersionPublishingRestricted Class
Sitecore.Pipelines.GetContentEditorWarnings Namespace


Sitecore.Pipelines.GetLookupSourceItems Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.GetLookupSourceItems Namespace
Send Feedback

Classes

 | Class | Description
Public class | GetLookupSourceItemsArgs | Argument class for getLookupSourceItems pipeline.
Public class | ProcessDefaultSource | Processes common query sources without well-known prefixes
Public class | ProcessQuerySource | Processes query sources that start with 'query:' prefix


GetLookupSourceItemsArgs Class

[image]

Sitecore 6.4.1 API
GetLookupSourceItemsArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetLookupSourceItems
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetLookupSourceItemsArgs : PipelineArgs
Visual Basic
Public Class GetLookupSourceItemsArgs _
    Inherits PipelineArgs
Visual C++
public ref class GetLookupSourceItemsArgs : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Pipelines.GetLookupSourceItems..::..GetLookupSourceItemsArgs

See Also

GetLookupSourceItemsArgs Members
Sitecore.Pipelines.GetLookupSourceItems Namespace


GetLookupSourceItemsArgs Members

[image] [image]

Sitecore 6.4.1 API
GetLookupSourceItemsArgs Members
GetLookupSourceItemsArgs Class Constructors Methods Properties See Also Send Feedback

The GetLookupSourceItemsArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GetLookupSourceItemsArgs | Initializes a new instance of the GetLookupSourceItemsArgs class

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Item | Gets or sets the item.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Result | Gets the result.
Public property | Source | Gets or sets the source.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

GetLookupSourceItemsArgs Class
Sitecore.Pipelines.GetLookupSourceItems Namespace


GetLookupSourceItemsArgs Methods

[image] [image]

Sitecore 6.4.1 API
GetLookupSourceItemsArgs Methods
GetLookupSourceItemsArgs Class See Also Send Feedback

The GetLookupSourceItemsArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetLookupSourceItemsArgs Class
Sitecore.Pipelines.GetLookupSourceItems Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
GetLookupSourceItemsArgs..::..AddMessage Method
GetLookupSourceItemsArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

GetLookupSourceItemsArgs Class
GetLookupSourceItemsArgs Members
Sitecore.Pipelines.GetLookupSourceItems Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
GetLookupSourceItemsArgs..::..GetMessages Method
GetLookupSourceItemsArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

GetLookupSourceItemsArgs Class
GetLookupSourceItemsArgs Members
Sitecore.Pipelines.GetLookupSourceItems Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
GetLookupSourceItemsArgs..::..Suspend Method
GetLookupSourceItemsArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

GetLookupSourceItemsArgs Class
GetLookupSourceItemsArgs Members
Sitecore.Pipelines.GetLookupSourceItems Namespace


GetLookupSourceItemsArgs Properties

[image] [image]

Sitecore 6.4.1 API
GetLookupSourceItemsArgs Properties
GetLookupSourceItemsArgs Class See Also Send Feedback

The GetLookupSourceItemsArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Item | Gets or sets the item.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Result | Gets the result.
Public property | Source | Gets or sets the source.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

GetLookupSourceItemsArgs Class
Sitecore.Pipelines.GetLookupSourceItems Namespace


Item Property

[image]

Sitecore 6.4.1 API
GetLookupSourceItemsArgs..::..Item Property
GetLookupSourceItemsArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetLookupSourceItems
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Item { get; set; }
Visual Basic
Public Property Item As Item
    Get
    Set
Visual C++
public:
property Item^ Item {
    Item^ get ();
    void set (Item^ value);
}

Field Value

The item.

See Also

GetLookupSourceItemsArgs Class
Sitecore.Pipelines.GetLookupSourceItems Namespace


Result Property

[image]

Sitecore 6.4.1 API
GetLookupSourceItemsArgs..::..Result Property
GetLookupSourceItemsArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetLookupSourceItems
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemCollection Result { get; }
Visual Basic
Public ReadOnly Property Result As ItemCollection
    Get
Visual C++
public:
property ItemCollection^ Result {
    ItemCollection^ get ();
}

Field Value

The result.

See Also

GetLookupSourceItemsArgs Class
Sitecore.Pipelines.GetLookupSourceItems Namespace


Source Property

[image]

Sitecore 6.4.1 API
GetLookupSourceItemsArgs..::..Source Property
GetLookupSourceItemsArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetLookupSourceItems
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Source { get; set; }
Visual Basic
Public Property Source As String
    Get
    Set
Visual C++
public:
property String^ Source {
    String^ get ();
    void set (String^ value);
}

Field Value

The source.

See Also

GetLookupSourceItemsArgs Class
Sitecore.Pipelines.GetLookupSourceItems Namespace


ProcessDefaultSource Class

[image]

Sitecore 6.4.1 API
ProcessDefaultSource Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetLookupSourceItems
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ProcessDefaultSource : PipelineArgs
Visual Basic
Public Class ProcessDefaultSource _
    Inherits PipelineArgs
Visual C++
public ref class ProcessDefaultSource : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Pipelines.GetLookupSourceItems..::..ProcessDefaultSource

See Also

ProcessDefaultSource Members
Sitecore.Pipelines.GetLookupSourceItems Namespace


ProcessDefaultSource Members

[image] [image]

Sitecore 6.4.1 API
ProcessDefaultSource Members
ProcessDefaultSource Class Constructors Methods Properties See Also Send Feedback

The ProcessDefaultSource type exposes the following members.

Constructors

 | Name | Description
Public method | ProcessDefaultSource | Initializes a new instance of the ProcessDefaultSource class

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | IsComplex | Determines whether [is complex source] [the specified source].
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

ProcessDefaultSource Class
Sitecore.Pipelines.GetLookupSourceItems Namespace


ProcessDefaultSource Constructor

[image]

Sitecore 6.4.1 API
ProcessDefaultSource Constructor
ProcessDefaultSource Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetLookupSourceItems
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ProcessDefaultSource()
Visual Basic
Public Sub New
Visual C++
public:
ProcessDefaultSource()

See Also

ProcessDefaultSource Class
Sitecore.Pipelines.GetLookupSourceItems Namespace


ProcessDefaultSource Methods

[image] [image]

Sitecore 6.4.1 API
ProcessDefaultSource Methods
ProcessDefaultSource Class See Also Send Feedback

The ProcessDefaultSource type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | IsComplex | Determines whether [is complex source] [the specified source].
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProcessDefaultSource Class
Sitecore.Pipelines.GetLookupSourceItems Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
ProcessDefaultSource..::..AddMessage Method
ProcessDefaultSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

ProcessDefaultSource Class
ProcessDefaultSource Members
Sitecore.Pipelines.GetLookupSourceItems Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
ProcessDefaultSource..::..GetMessages Method
ProcessDefaultSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

ProcessDefaultSource Class
ProcessDefaultSource Members
Sitecore.Pipelines.GetLookupSourceItems Namespace


IsComplex Method

[image]

Sitecore 6.4.1 API
ProcessDefaultSource..::..IsComplex Method
ProcessDefaultSource Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetLookupSourceItems
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool IsComplex(
    string source
)
Visual Basic
Protected Overridable Function IsComplex ( _
    source As String _
) As Boolean
Visual C++
protected:
virtual bool IsComplex(
    String^ source
)

Parameters

source
Type: System..::..String
The source.

Return Value

true if [is complex source] [the specified source]; otherwise, false.

See Also

ProcessDefaultSource Class
Sitecore.Pipelines.GetLookupSourceItems Namespace


Process Method

[image]

Sitecore 6.4.1 API
ProcessDefaultSource..::..Process Method
ProcessDefaultSource Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetLookupSourceItems
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    GetLookupSourceItemsArgs args
)
Visual Basic
Public Sub Process ( _
    args As GetLookupSourceItemsArgs _
)
Visual C++
public:
void Process(
    GetLookupSourceItemsArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.GetLookupSourceItems..::..GetLookupSourceItemsArgs
The arguments.

See Also

ProcessDefaultSource Class
Sitecore.Pipelines.GetLookupSourceItems Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
ProcessDefaultSource..::..Suspend Method
ProcessDefaultSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

ProcessDefaultSource Class
ProcessDefaultSource Members
Sitecore.Pipelines.GetLookupSourceItems Namespace


ProcessDefaultSource Properties

[image] [image]

Sitecore 6.4.1 API
ProcessDefaultSource Properties
ProcessDefaultSource Class See Also Send Feedback

The ProcessDefaultSource type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

ProcessDefaultSource Class
Sitecore.Pipelines.GetLookupSourceItems Namespace


ProcessQuerySource Class

[image]

Sitecore 6.4.1 API
ProcessQuerySource Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetLookupSourceItems
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ProcessQuerySource
Visual Basic
Public Class ProcessQuerySource
Visual C++
public ref class ProcessQuerySource

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetLookupSourceItems..::..ProcessQuerySource

See Also

ProcessQuerySource Members
Sitecore.Pipelines.GetLookupSourceItems Namespace


ProcessQuerySource Members

[image] [image]

Sitecore 6.4.1 API
ProcessQuerySource Members
ProcessQuerySource Class Constructors Methods See Also Send Feedback

The ProcessQuerySource type exposes the following members.

Constructors

 | Name | Description
Public method | ProcessQuerySource | Initializes a new instance of the ProcessQuerySource class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProcessQuerySource Class
Sitecore.Pipelines.GetLookupSourceItems Namespace


ProcessQuerySource Constructor

[image]

Sitecore 6.4.1 API
ProcessQuerySource Constructor
ProcessQuerySource Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetLookupSourceItems
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ProcessQuerySource()
Visual Basic
Public Sub New
Visual C++
public:
ProcessQuerySource()

See Also

ProcessQuerySource Class
Sitecore.Pipelines.GetLookupSourceItems Namespace


Process Method

[image]

Sitecore 6.4.1 API
ProcessQuerySource..::..Process Method
ProcessQuerySource Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetLookupSourceItems
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    GetLookupSourceItemsArgs args
)
Visual Basic
Public Sub Process ( _
    args As GetLookupSourceItemsArgs _
)
Visual C++
public:
void Process(
    GetLookupSourceItemsArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.GetLookupSourceItems..::..GetLookupSourceItemsArgs
The arguments.

See Also

ProcessQuerySource Class
Sitecore.Pipelines.GetLookupSourceItems Namespace


Sitecore.Pipelines.GetMasters Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.GetMasters Namespace
Send Feedback

Classes

 | Class | Description
Public class | CheckSecurity | Upload has finished.
Public class | GetInsertRules | Upload has finished.
Public class | GetItemMasters | Upload has finished.
Public class | GetMastersArgs | Argument class for the Upload pipeline.
Public class | RunRules | Upload has finished.


CheckSecurity Class

[image]

Sitecore 6.4.1 API
CheckSecurity Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetMasters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CheckSecurity
Visual Basic
Public Class CheckSecurity
Visual C++
public ref class CheckSecurity

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetMasters..::..CheckSecurity

See Also

CheckSecurity Members
Sitecore.Pipelines.GetMasters Namespace


CheckSecurity Members

[image] [image]

Sitecore 6.4.1 API
CheckSecurity Members
CheckSecurity Class Constructors Methods See Also Send Feedback

The CheckSecurity type exposes the following members.

Constructors

 | Name | Description
Public method | CheckSecurity | Initializes a new instance of the CheckSecurity class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckSecurity Class
Sitecore.Pipelines.GetMasters Namespace


CheckSecurity Constructor

[image]

Sitecore 6.4.1 API
CheckSecurity Constructor
CheckSecurity Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetMasters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CheckSecurity()
Visual Basic
Public Sub New
Visual C++
public:
CheckSecurity()

See Also

CheckSecurity Class
Sitecore.Pipelines.GetMasters Namespace


CheckSecurity Methods

[image] [image]

Sitecore 6.4.1 API
CheckSecurity Methods
CheckSecurity Class See Also Send Feedback

The CheckSecurity type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckSecurity Class
Sitecore.Pipelines.GetMasters Namespace


Process Method

[image]

Sitecore 6.4.1 API
CheckSecurity..::..Process Method
CheckSecurity Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetMasters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    GetMastersArgs args
)
Visual Basic
Public Sub Process ( _
    args As GetMastersArgs _
)
Visual C++
public:
void Process(
    GetMastersArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.GetMasters..::..GetMastersArgs
The arguments.

See Also

CheckSecurity Class
Sitecore.Pipelines.GetMasters Namespace


GetInsertRules Members

[image] [image]

Sitecore 6.4.1 API
GetInsertRules Members
GetInsertRules Class Constructors Methods See Also Send Feedback

The GetInsertRules type exposes the following members.

Constructors

 | Name | Description
Public method | GetInsertRules | Initializes a new instance of the GetInsertRules class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetInsertRules Class
Sitecore.Pipelines.GetMasters Namespace


GetInsertRules Constructor

[image]

Sitecore 6.4.1 API
GetInsertRules Constructor
GetInsertRules Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetMasters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetInsertRules()
Visual Basic
Public Sub New
Visual C++
public:
GetInsertRules()

See Also

GetInsertRules Class
Sitecore.Pipelines.GetMasters Namespace


GetInsertRules Methods

[image] [image]

Sitecore 6.4.1 API
GetInsertRules Methods
GetInsertRules Class See Also Send Feedback

The GetInsertRules type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetInsertRules Class
Sitecore.Pipelines.GetMasters Namespace


Process Method

[image]

Sitecore 6.4.1 API
GetInsertRules..::..Process Method
GetInsertRules Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetMasters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    GetMastersArgs args
)
Visual Basic
Public Sub Process ( _
    args As GetMastersArgs _
)
Visual C++
public:
void Process(
    GetMastersArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.GetMasters..::..GetMastersArgs
The arguments.

See Also

GetInsertRules Class
Sitecore.Pipelines.GetMasters Namespace


GetItemMasters Class

[image]

Sitecore 6.4.1 API
GetItemMasters Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetMasters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetItemMasters
Visual Basic
Public Class GetItemMasters
Visual C++
public ref class GetItemMasters

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetMasters..::..GetItemMasters

See Also

GetItemMasters Members
Sitecore.Pipelines.GetMasters Namespace


GetItemMasters Members

[image] [image]

Sitecore 6.4.1 API
GetItemMasters Members
GetItemMasters Class Constructors Methods See Also Send Feedback

The GetItemMasters type exposes the following members.

Constructors

 | Name | Description
Public method | GetItemMasters | Initializes a new instance of the GetItemMasters class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetItemMasters Class
Sitecore.Pipelines.GetMasters Namespace


GetItemMasters Constructor

[image]

Sitecore 6.4.1 API
GetItemMasters Constructor
GetItemMasters Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetMasters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetItemMasters()
Visual Basic
Public Sub New
Visual C++
public:
GetItemMasters()

See Also

GetItemMasters Class
Sitecore.Pipelines.GetMasters Namespace


GetItemMasters Methods

[image] [image]

Sitecore 6.4.1 API
GetItemMasters Methods
GetItemMasters Class See Also Send Feedback

The GetItemMasters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetItemMasters Class
Sitecore.Pipelines.GetMasters Namespace


Process Method

[image]

Sitecore 6.4.1 API
GetItemMasters..::..Process Method
GetItemMasters Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetMasters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    GetMastersArgs args
)
Visual Basic
Public Sub Process ( _
    args As GetMastersArgs _
)
Visual C++
public:
void Process(
    GetMastersArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.GetMasters..::..GetMastersArgs
The arguments.

See Also

GetItemMasters Class
Sitecore.Pipelines.GetMasters Namespace


GetMastersArgs Class

[image]

Sitecore 6.4.1 API
GetMastersArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetMasters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class GetMastersArgs : ClientPipelineArgs
Visual Basic
<SerializableAttribute> _
Public Class GetMastersArgs _
    Inherits ClientPipelineArgs
Visual C++
[SerializableAttribute]
public ref class GetMastersArgs : public ClientPipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Web.UI.Sheer..::..ClientPipelineArgs
Sitecore.Pipelines.GetMasters..::..GetMastersArgs

See Also

GetMastersArgs Members
Sitecore.Pipelines.GetMasters Namespace


GetMastersArgs Members

[image] [image]

Sitecore 6.4.1 API
GetMastersArgs Members
GetMastersArgs Class Constructors Methods Properties See Also Send Feedback

The GetMastersArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GetMastersArgs()()()() | Initializes a new instance of the GetMastersArgs class.
Protected method | GetMastersArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the GetMastersArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ClientPipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from ClientPipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WaitForPostBack()()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Public method | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CarryResultToNextProcessor | Gets or sets a value indicating whether the ClientPipelineArgs carries the result to next processor. (Inherited from ClientPipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | HasResult | Gets a value indicating whether this instance has a result. (Inherited from ClientPipelineArgs.)
Public property | IsPostBack | Gets or sets a value that indicates if the processor was invoked as part of a user response. (Inherited from ClientPipelineArgs.)
Public property | Item | Gets the item.
Public property | Masters | Gets the masters.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Parameters | Gets or sets the parameters. (Inherited from ClientPipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Properties | Gets the properties. (Inherited from ClientPipelineArgs.)
Public property | Result | Gets or sets the value that was posted as part of a Sheer response. (Inherited from ClientPipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

GetMastersArgs Class
Sitecore.Pipelines.GetMasters Namespace


GetMastersArgs Constructor

[image] [image]

Sitecore 6.4.1 API
GetMastersArgs Constructor
GetMastersArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMastersArgs()()()() | Initializes a new instance of the GetMastersArgs class.
Protected method | GetMastersArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the GetMastersArgs class.

See Also

GetMastersArgs Class
GetMastersArgs Members
Sitecore.Pipelines.GetMasters Namespace


GetMastersArgs Constructor

[image]

Sitecore 6.4.1 API
GetMastersArgs Constructor
GetMastersArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetMasters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetMastersArgs()
Visual Basic
Public Sub New
Visual C++
public:
GetMastersArgs()

See Also

GetMastersArgs Class
GetMastersArgs Overload
Sitecore.Pipelines.GetMasters Namespace


GetMastersArgs Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
GetMastersArgs Constructor (SerializationInfo, StreamingContext)
GetMastersArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetMasters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected GetMastersArgs(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
GetMastersArgs(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

GetMastersArgs Class
GetMastersArgs Overload
Sitecore.Pipelines.GetMasters Namespace


GetMastersArgs Methods

[image] [image]

Sitecore 6.4.1 API
GetMastersArgs Methods
GetMastersArgs Class See Also Send Feedback

The GetMastersArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ClientPipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from ClientPipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WaitForPostBack()()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Public method | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)

See Also

GetMastersArgs Class
Sitecore.Pipelines.GetMasters Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
GetMastersArgs..::..AddMessage Method
GetMastersArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

GetMastersArgs Class
GetMastersArgs Members
Sitecore.Pipelines.GetMasters Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
GetMastersArgs..::..GetMessages Method
GetMastersArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

GetMastersArgs Class
GetMastersArgs Members
Sitecore.Pipelines.GetMasters Namespace


GetObjectData Method

[image]

Sitecore 6.4.1 API
GetMastersArgs..::..GetObjectData Method
GetMastersArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetMasters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System.Security..::..SecurityException | The caller does not have the required permission.

See Also

GetMastersArgs Class
Sitecore.Pipelines.GetMasters Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
GetMastersArgs..::..Suspend Method
GetMastersArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

GetMastersArgs Class
GetMastersArgs Members
Sitecore.Pipelines.GetMasters Namespace


GetMastersArgs Properties

[image] [image]

Sitecore 6.4.1 API
GetMastersArgs Properties
GetMastersArgs Class See Also Send Feedback

The GetMastersArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CarryResultToNextProcessor | Gets or sets a value indicating whether the ClientPipelineArgs carries the result to next processor. (Inherited from ClientPipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | HasResult | Gets a value indicating whether this instance has a result. (Inherited from ClientPipelineArgs.)
Public property | IsPostBack | Gets or sets a value that indicates if the processor was invoked as part of a user response. (Inherited from ClientPipelineArgs.)
Public property | Item | Gets the item.
Public property | Masters | Gets the masters.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Parameters | Gets or sets the parameters. (Inherited from ClientPipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Properties | Gets the properties. (Inherited from ClientPipelineArgs.)
Public property | Result | Gets or sets the value that was posted as part of a Sheer response. (Inherited from ClientPipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

GetMastersArgs Class
Sitecore.Pipelines.GetMasters Namespace


Masters Property

[image]

Sitecore 6.4.1 API
GetMastersArgs..::..Masters Property
GetMastersArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetMasters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public List<Item> Masters { get; }
Visual Basic
Public ReadOnly Property Masters As List(Of Item)
    Get
Visual C++
public:
property List<Item^>^ Masters {
    List<Item^>^ get ();
}

Field Value

The masters.

See Also

GetMastersArgs Class
Sitecore.Pipelines.GetMasters Namespace


RunRules Class

[image]

Sitecore 6.4.1 API
RunRules Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetMasters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RunRules
Visual Basic
Public Class RunRules
Visual C++
public ref class RunRules

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetMasters..::..RunRules

See Also

RunRules Members
Sitecore.Pipelines.GetMasters Namespace


RunRules Constructor

[image]

Sitecore 6.4.1 API
RunRules Constructor
RunRules Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetMasters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RunRules()
Visual Basic
Public Sub New
Visual C++
public:
RunRules()

See Also

RunRules Class
Sitecore.Pipelines.GetMasters Namespace


RunRules Methods

[image] [image]

Sitecore 6.4.1 API
RunRules Methods
RunRules Class See Also Send Feedback

The RunRules type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RunRules Class
Sitecore.Pipelines.GetMasters Namespace


Process Method

[image]

Sitecore 6.4.1 API
RunRules..::..Process Method
RunRules Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetMasters
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    GetMastersArgs args
)
Visual Basic
Public Sub Process ( _
    args As GetMastersArgs _
)
Visual C++
public:
void Process(
    GetMastersArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.GetMasters..::..GetMastersArgs
The arguments.

See Also

RunRules Class
Sitecore.Pipelines.GetMasters Namespace


Sitecore.Pipelines.GetMediaCreatorOptions Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.GetMediaCreatorOptions Namespace
Send Feedback

Classes

 | Class | Description
Public class | GetMediaCreatorOptionsArgs | Arguments from GetMediaCreatorOptions pipeline.


GetMediaCreatorOptionsArgs Class

[image]

Sitecore 6.4.1 API
GetMediaCreatorOptionsArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetMediaCreatorOptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetMediaCreatorOptionsArgs : PipelineArgs
Visual Basic
Public Class GetMediaCreatorOptionsArgs _
    Inherits PipelineArgs
Visual C++
public ref class GetMediaCreatorOptionsArgs : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Pipelines.GetMediaCreatorOptions..::..GetMediaCreatorOptionsArgs

See Also

GetMediaCreatorOptionsArgs Members
Sitecore.Pipelines.GetMediaCreatorOptions Namespace


GetMediaCreatorOptionsArgs Members

[image] [image]

Sitecore 6.4.1 API
GetMediaCreatorOptionsArgs Members
GetMediaCreatorOptionsArgs Class Constructors Methods Fields Properties See Also Send Feedback

The GetMediaCreatorOptionsArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GetMediaCreatorOptionsArgs | Initializes a new instance of the GetMediaCreatorOptionsArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
FileBasedContext | The cretion from phisical file context.
UploadContext | The uploading context.
WebDAVContext | The name of WebDAV context.
WordFieldContext | The name of WebDAV context.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Options | Gets the media creator options.
Public property | PipelineContext | Gets the Media Creator Type.
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

GetMediaCreatorOptionsArgs Class
Sitecore.Pipelines.GetMediaCreatorOptions Namespace


GetMediaCreatorOptionsArgs Constructor

[image]

Sitecore 6.4.1 API
GetMediaCreatorOptionsArgs Constructor
GetMediaCreatorOptionsArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetMediaCreatorOptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetMediaCreatorOptionsArgs(
    MediaCreatorOptions options,
    string pipelineContext
)
Visual Basic
Public Sub New ( _
    options As MediaCreatorOptions, _
    pipelineContext As String _
)
Visual C++
public:
GetMediaCreatorOptionsArgs(
    MediaCreatorOptions^ options,
    String^ pipelineContext
)

Parameters

options
Type: Sitecore.Resources.Media..::..MediaCreatorOptions
The options.
pipelineContext
Type: System..::..String
Type of the media creator.

See Also

GetMediaCreatorOptionsArgs Class
Sitecore.Pipelines.GetMediaCreatorOptions Namespace


GetMediaCreatorOptionsArgs Fields

[image] [image]

Sitecore 6.4.1 API
GetMediaCreatorOptionsArgs Fields
GetMediaCreatorOptionsArgs Class See Also Send Feedback

The GetMediaCreatorOptionsArgs type exposes the following members.

Fields

Name | Description
FileBasedContext | The cretion from phisical file context.
UploadContext | The uploading context.
WebDAVContext | The name of WebDAV context.
WordFieldContext | The name of WebDAV context.

See Also

GetMediaCreatorOptionsArgs Class
Sitecore.Pipelines.GetMediaCreatorOptions Namespace


FileBasedContext Field

[image]

Sitecore 6.4.1 API
GetMediaCreatorOptionsArgs..::..FileBasedContext Field
GetMediaCreatorOptionsArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetMediaCreatorOptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly string FileBasedContext
Visual Basic
Public Shared ReadOnly FileBasedContext As String
Visual C++
public:
static initonly String^ FileBasedContext

See Also

GetMediaCreatorOptionsArgs Class
Sitecore.Pipelines.GetMediaCreatorOptions Namespace


UploadContext Field

[image]

Sitecore 6.4.1 API
GetMediaCreatorOptionsArgs..::..UploadContext Field
GetMediaCreatorOptionsArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetMediaCreatorOptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly string UploadContext
Visual Basic
Public Shared ReadOnly UploadContext As String
Visual C++
public:
static initonly String^ UploadContext

See Also

GetMediaCreatorOptionsArgs Class
Sitecore.Pipelines.GetMediaCreatorOptions Namespace


WebDAVContext Field

[image]

Sitecore 6.4.1 API
GetMediaCreatorOptionsArgs..::..WebDAVContext Field
GetMediaCreatorOptionsArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetMediaCreatorOptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly string WebDAVContext
Visual Basic
Public Shared ReadOnly WebDAVContext As String
Visual C++
public:
static initonly String^ WebDAVContext

See Also

GetMediaCreatorOptionsArgs Class
Sitecore.Pipelines.GetMediaCreatorOptions Namespace


WordFieldContext Field

[image]

Sitecore 6.4.1 API
GetMediaCreatorOptionsArgs..::..WordFieldContext Field
GetMediaCreatorOptionsArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetMediaCreatorOptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static readonly string WordFieldContext
Visual Basic
Public Shared ReadOnly WordFieldContext As String
Visual C++
public:
static initonly String^ WordFieldContext

See Also

GetMediaCreatorOptionsArgs Class
Sitecore.Pipelines.GetMediaCreatorOptions Namespace


GetMediaCreatorOptionsArgs Methods

[image] [image]

Sitecore 6.4.1 API
GetMediaCreatorOptionsArgs Methods
GetMediaCreatorOptionsArgs Class See Also Send Feedback

The GetMediaCreatorOptionsArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetMediaCreatorOptionsArgs Class
Sitecore.Pipelines.GetMediaCreatorOptions Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
GetMediaCreatorOptionsArgs..::..AddMessage Method
GetMediaCreatorOptionsArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

GetMediaCreatorOptionsArgs Class
GetMediaCreatorOptionsArgs Members
Sitecore.Pipelines.GetMediaCreatorOptions Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
GetMediaCreatorOptionsArgs..::..GetMessages Method
GetMediaCreatorOptionsArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

GetMediaCreatorOptionsArgs Class
GetMediaCreatorOptionsArgs Members
Sitecore.Pipelines.GetMediaCreatorOptions Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
GetMediaCreatorOptionsArgs..::..Suspend Method
GetMediaCreatorOptionsArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

GetMediaCreatorOptionsArgs Class
GetMediaCreatorOptionsArgs Members
Sitecore.Pipelines.GetMediaCreatorOptions Namespace


GetMediaCreatorOptionsArgs Properties

[image] [image]

Sitecore 6.4.1 API
GetMediaCreatorOptionsArgs Properties
GetMediaCreatorOptionsArgs Class See Also Send Feedback

The GetMediaCreatorOptionsArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Options | Gets the media creator options.
Public property | PipelineContext | Gets the Media Creator Type.
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

GetMediaCreatorOptionsArgs Class
Sitecore.Pipelines.GetMediaCreatorOptions Namespace


Options Property

[image]

Sitecore 6.4.1 API
GetMediaCreatorOptionsArgs..::..Options Property
GetMediaCreatorOptionsArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetMediaCreatorOptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MediaCreatorOptions Options { get; }
Visual Basic
Public ReadOnly Property Options As MediaCreatorOptions
    Get
Visual C++
public:
property MediaCreatorOptions^ Options {
    MediaCreatorOptions^ get ();
}

Field Value

The media creator options.

See Also

GetMediaCreatorOptionsArgs Class
Sitecore.Pipelines.GetMediaCreatorOptions Namespace


PipelineContext Property

[image]

Sitecore 6.4.1 API
GetMediaCreatorOptionsArgs..::..PipelineContext Property
GetMediaCreatorOptionsArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetMediaCreatorOptions
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string PipelineContext { get; }
Visual Basic
Public ReadOnly Property PipelineContext As String
    Get
Visual C++
public:
property String^ PipelineContext {
    String^ get ();
}

Field Value

The media creator type.

See Also

GetMediaCreatorOptionsArgs Class
Sitecore.Pipelines.GetMediaCreatorOptions Namespace


Sitecore.Pipelines.GetPlaceholderRenderings Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.GetPlaceholderRenderings Namespace
Send Feedback

Classes

 | Class | Description
Public class | GetAllowedRenderings | Fills placeholder renderings list.
Public class | GetPlaceholderRenderingsArgs | Arguments for GetPleceholderRenderings pipeline.
Public class | GetPlaceholderRenderingsDialogUrl | Chooses appropriate Dialog for selecting associated renderings.
Public class | GetPredefinedRenderings | Fills placeholder renderings with predefined renderings list.


GetAllowedRenderings Class

[image]

Sitecore 6.4.1 API
GetAllowedRenderings Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetPlaceholderRenderings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetAllowedRenderings
Visual Basic
Public Class GetAllowedRenderings
Visual C++
public ref class GetAllowedRenderings

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetPlaceholderRenderings..::..GetAllowedRenderings

See Also

GetAllowedRenderings Members
Sitecore.Pipelines.GetPlaceholderRenderings Namespace


GetAllowedRenderings Members

[image] [image]

Sitecore 6.4.1 API
GetAllowedRenderings Members
GetAllowedRenderings Class Constructors Methods See Also Send Feedback

The GetAllowedRenderings type exposes the following members.

Constructors

 | Name | Description
Public method | GetAllowedRenderings | Initializes a new instance of the GetAllowedRenderings class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRenderings | Gets the allowed renderings.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Fills placeholder renderings list.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetAllowedRenderings Class
Sitecore.Pipelines.GetPlaceholderRenderings Namespace


GetAllowedRenderings Constructor

[image]

Sitecore 6.4.1 API
GetAllowedRenderings Constructor
GetAllowedRenderings Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetPlaceholderRenderings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetAllowedRenderings()
Visual Basic
Public Sub New
Visual C++
public:
GetAllowedRenderings()

See Also

GetAllowedRenderings Class
Sitecore.Pipelines.GetPlaceholderRenderings Namespace


GetRenderings Method

[image]

Sitecore 6.4.1 API
GetAllowedRenderings..::..GetRenderings Method
GetAllowedRenderings Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetPlaceholderRenderings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual List<Item> GetRenderings(
    string placeholderKey,
    string layoutDefinition,
    Database contentDatabase
)
Visual Basic
Protected Overridable Function GetRenderings ( _
    placeholderKey As String, _
    layoutDefinition As String, _
    contentDatabase As Database _
) As List(Of Item)
Visual C++
protected:
virtual List<Item^>^ GetRenderings(
    String^ placeholderKey,
    String^ layoutDefinition,
    Database^ contentDatabase
)

Parameters

placeholderKey
Type: System..::..String
The placeholder key.
layoutDefinition
Type: System..::..String
The layout definition.
contentDatabase
Type: Sitecore.Data..::..Database
The content database.

Return Value

The allowed renderings.

See Also

GetAllowedRenderings Class
Sitecore.Pipelines.GetPlaceholderRenderings Namespace


Process Method

[image]

Sitecore 6.4.1 API
GetAllowedRenderings..::..Process Method
GetAllowedRenderings Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetPlaceholderRenderings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    GetPlaceholderRenderingsArgs args
)
Visual Basic
Public Sub Process ( _
    args As GetPlaceholderRenderingsArgs _
)
Visual C++
public:
void Process(
    GetPlaceholderRenderingsArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.GetPlaceholderRenderings..::..GetPlaceholderRenderingsArgs
The arguments.

See Also

GetAllowedRenderings Class
Sitecore.Pipelines.GetPlaceholderRenderings Namespace


GetPlaceholderRenderingsArgs Class

[image]

Sitecore 6.4.1 API
GetPlaceholderRenderingsArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetPlaceholderRenderings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetPlaceholderRenderingsArgs : PipelineArgs
Visual Basic
Public Class GetPlaceholderRenderingsArgs _
    Inherits PipelineArgs
Visual C++
public ref class GetPlaceholderRenderingsArgs : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Pipelines.GetPlaceholderRenderings..::..GetPlaceholderRenderingsArgs

See Also

GetPlaceholderRenderingsArgs Members
Sitecore.Pipelines.GetPlaceholderRenderings Namespace


GetPlaceholderRenderingsArgs Members

[image] [image]

Sitecore 6.4.1 API
GetPlaceholderRenderingsArgs Members
GetPlaceholderRenderingsArgs Class Constructors Methods Properties See Also Send Feedback

The GetPlaceholderRenderingsArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GetPlaceholderRenderingsArgs | Initializes a new instance of the GetPlaceholderRenderingsArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | ContentDatabase | Gets the content database.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | DialogURL | Gets or sets the dialog URL.
Public property | LayoutDefinition | Gets the layout definition.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | PlaceholderKey | Gets the placeholder key.
Public property | PlaceholderRenderings | Gets or sets the rendering list that are allowed to be assigned to the placeholder.
Public property | PredefinedRenderingIds | Gets or sets the predefined renderings IDs.
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

GetPlaceholderRenderingsArgs Class
Sitecore.Pipelines.GetPlaceholderRenderings Namespace


GetPlaceholderRenderingsArgs Constructor

[image]

Sitecore 6.4.1 API
GetPlaceholderRenderingsArgs Constructor
GetPlaceholderRenderingsArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetPlaceholderRenderings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetPlaceholderRenderingsArgs(
    string placeholderKey,
    string layoutDefinition,
    Database contentDatabase
)
Visual Basic
Public Sub New ( _
    placeholderKey As String, _
    layoutDefinition As String, _
    contentDatabase As Database _
)
Visual C++
public:
GetPlaceholderRenderingsArgs(
    String^ placeholderKey,
    String^ layoutDefinition,
    Database^ contentDatabase
)

Parameters

placeholderKey
Type: System..::..String
The placeholder key.
layoutDefinition
Type: System..::..String
The layout definition.
contentDatabase
Type: Sitecore.Data..::..Database
The content database.

See Also

GetPlaceholderRenderingsArgs Class
Sitecore.Pipelines.GetPlaceholderRenderings Namespace


GetPlaceholderRenderingsArgs Methods

[image] [image]

Sitecore 6.4.1 API
GetPlaceholderRenderingsArgs Methods
GetPlaceholderRenderingsArgs Class See Also Send Feedback

The GetPlaceholderRenderingsArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetPlaceholderRenderingsArgs Class
Sitecore.Pipelines.GetPlaceholderRenderings Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
GetPlaceholderRenderingsArgs..::..AddMessage Method
GetPlaceholderRenderingsArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

GetPlaceholderRenderingsArgs Class
GetPlaceholderRenderingsArgs Members
Sitecore.Pipelines.GetPlaceholderRenderings Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
GetPlaceholderRenderingsArgs..::..GetMessages Method
GetPlaceholderRenderingsArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

GetPlaceholderRenderingsArgs Class
GetPlaceholderRenderingsArgs Members
Sitecore.Pipelines.GetPlaceholderRenderings Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
GetPlaceholderRenderingsArgs..::..Suspend Method
GetPlaceholderRenderingsArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

GetPlaceholderRenderingsArgs Class
GetPlaceholderRenderingsArgs Members
Sitecore.Pipelines.GetPlaceholderRenderings Namespace


GetPlaceholderRenderingsArgs Properties

[image] [image]

Sitecore 6.4.1 API
GetPlaceholderRenderingsArgs Properties
GetPlaceholderRenderingsArgs Class See Also Send Feedback

The GetPlaceholderRenderingsArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | ContentDatabase | Gets the content database.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | DialogURL | Gets or sets the dialog URL.
Public property | LayoutDefinition | Gets the layout definition.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | PlaceholderKey | Gets the placeholder key.
Public property | PlaceholderRenderings | Gets or sets the rendering list that are allowed to be assigned to the placeholder.
Public property | PredefinedRenderingIds | Gets or sets the predefined renderings IDs.
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

GetPlaceholderRenderingsArgs Class
Sitecore.Pipelines.GetPlaceholderRenderings Namespace


ContentDatabase Property

[image]

Sitecore 6.4.1 API
GetPlaceholderRenderingsArgs..::..ContentDatabase Property
GetPlaceholderRenderingsArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetPlaceholderRenderings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database ContentDatabase { get; }
Visual Basic
Public ReadOnly Property ContentDatabase As Database
    Get
Visual C++
public:
property Database^ ContentDatabase {
    Database^ get ();
}

Field Value

The content database.

See Also

GetPlaceholderRenderingsArgs Class
Sitecore.Pipelines.GetPlaceholderRenderings Namespace


DialogURL Property

[image]

Sitecore 6.4.1 API
GetPlaceholderRenderingsArgs..::..DialogURL Property
GetPlaceholderRenderingsArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetPlaceholderRenderings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string DialogURL { get; set; }
Visual Basic
Public Property DialogURL As String
    Get
    Set
Visual C++
public:
property String^ DialogURL {
    String^ get ();
    void set (String^ value);
}

Field Value

The dialog URL.

See Also

GetPlaceholderRenderingsArgs Class
Sitecore.Pipelines.GetPlaceholderRenderings Namespace


LayoutDefinition Property

[image]

Sitecore 6.4.1 API
GetPlaceholderRenderingsArgs..::..LayoutDefinition Property
GetPlaceholderRenderingsArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetPlaceholderRenderings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string LayoutDefinition { get; }
Visual Basic
Public ReadOnly Property LayoutDefinition As String
    Get
Visual C++
public:
property String^ LayoutDefinition {
    String^ get ();
}

Field Value

The layout definition.

See Also

GetPlaceholderRenderingsArgs Class
Sitecore.Pipelines.GetPlaceholderRenderings Namespace


PlaceholderKey Property

[image]

Sitecore 6.4.1 API
GetPlaceholderRenderingsArgs..::..PlaceholderKey Property
GetPlaceholderRenderingsArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetPlaceholderRenderings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string PlaceholderKey { get; }
Visual Basic
Public ReadOnly Property PlaceholderKey As String
    Get
Visual C++
public:
property String^ PlaceholderKey {
    String^ get ();
}

Field Value

The placeholder key.

See Also

GetPlaceholderRenderingsArgs Class
Sitecore.Pipelines.GetPlaceholderRenderings Namespace


PlaceholderRenderings Property

[image]

Sitecore 6.4.1 API
GetPlaceholderRenderingsArgs..::..PlaceholderRenderings Property
GetPlaceholderRenderingsArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetPlaceholderRenderings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public List<Item> PlaceholderRenderings { get; set; }
Visual Basic
Public Property PlaceholderRenderings As List(Of Item)
    Get
    Set
Visual C++
public:
property List<Item^>^ PlaceholderRenderings {
    List<Item^>^ get ();
    void set (List<Item^>^ value);
}

Field Value

The placeholder renderings.

See Also

GetPlaceholderRenderingsArgs Class
Sitecore.Pipelines.GetPlaceholderRenderings Namespace


PredefinedRenderingIds Property

[image]

Sitecore 6.4.1 API
GetPlaceholderRenderingsArgs..::..PredefinedRenderingIds Property
GetPlaceholderRenderingsArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetPlaceholderRenderings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public List<ID> PredefinedRenderingIds { get; set; }
Visual Basic
Public Property PredefinedRenderingIds As List(Of ID)
    Get
    Set
Visual C++
public:
property List<ID^>^ PredefinedRenderingIds {
    List<ID^>^ get ();
    void set (List<ID^>^ value);
}

See Also

GetPlaceholderRenderingsArgs Class
Sitecore.Pipelines.GetPlaceholderRenderings Namespace


GetPlaceholderRenderingsDialogUrl Class

[image]

Sitecore 6.4.1 API
GetPlaceholderRenderingsDialogUrl Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetPlaceholderRenderings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetPlaceholderRenderingsDialogUrl
Visual Basic
Public Class GetPlaceholderRenderingsDialogUrl
Visual C++
public ref class GetPlaceholderRenderingsDialogUrl

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetPlaceholderRenderings..::..GetPlaceholderRenderingsDialogUrl

See Also

GetPlaceholderRenderingsDialogUrl Members
Sitecore.Pipelines.GetPlaceholderRenderings Namespace


GetPlaceholderRenderingsDialogUrl Members

[image] [image]

Sitecore 6.4.1 API
GetPlaceholderRenderingsDialogUrl Members
GetPlaceholderRenderingsDialogUrl Class Constructors Methods See Also Send Feedback

The GetPlaceholderRenderingsDialogUrl type exposes the following members.

Constructors

 | Name | Description
Public method | GetPlaceholderRenderingsDialogUrl | Initializes a new instance of the GetPlaceholderRenderingsDialogUrl class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Chooses appropriate Dialog for selecting associated renderings
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetPlaceholderRenderingsDialogUrl Class
Sitecore.Pipelines.GetPlaceholderRenderings Namespace


GetPlaceholderRenderingsDialogUrl Constructor

[image]

Sitecore 6.4.1 API
GetPlaceholderRenderingsDialogUrl Constructor
GetPlaceholderRenderingsDialogUrl Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetPlaceholderRenderings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetPlaceholderRenderingsDialogUrl()
Visual Basic
Public Sub New
Visual C++
public:
GetPlaceholderRenderingsDialogUrl()

See Also

GetPlaceholderRenderingsDialogUrl Class
Sitecore.Pipelines.GetPlaceholderRenderings Namespace


GetPlaceholderRenderingsDialogUrl Methods

[image] [image]

Sitecore 6.4.1 API
GetPlaceholderRenderingsDialogUrl Methods
GetPlaceholderRenderingsDialogUrl Class See Also Send Feedback

The GetPlaceholderRenderingsDialogUrl type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Chooses appropriate Dialog for selecting associated renderings
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetPlaceholderRenderingsDialogUrl Class
Sitecore.Pipelines.GetPlaceholderRenderings Namespace


Process Method

[image]

Sitecore 6.4.1 API
GetPlaceholderRenderingsDialogUrl..::..Process Method
GetPlaceholderRenderingsDialogUrl Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetPlaceholderRenderings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    GetPlaceholderRenderingsArgs args
)
Visual Basic
Public Sub Process ( _
    args As GetPlaceholderRenderingsArgs _
)
Visual C++
public:
void Process(
    GetPlaceholderRenderingsArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.GetPlaceholderRenderings..::..GetPlaceholderRenderingsArgs
The arguments.

See Also

GetPlaceholderRenderingsDialogUrl Class
Sitecore.Pipelines.GetPlaceholderRenderings Namespace


GetPredefinedRenderings Class

[image]

Sitecore 6.4.1 API
GetPredefinedRenderings Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetPlaceholderRenderings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetPredefinedRenderings
Visual Basic
Public Class GetPredefinedRenderings
Visual C++
public ref class GetPredefinedRenderings

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetPlaceholderRenderings..::..GetPredefinedRenderings

See Also

GetPredefinedRenderings Members
Sitecore.Pipelines.GetPlaceholderRenderings Namespace


GetPredefinedRenderings Members

[image] [image]

Sitecore 6.4.1 API
GetPredefinedRenderings Members
GetPredefinedRenderings Class Constructors Methods See Also Send Feedback

The GetPredefinedRenderings type exposes the following members.

Constructors

 | Name | Description
Public method | GetPredefinedRenderings | Initializes a new instance of the GetPredefinedRenderings class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Fills placeholder renderings with predefined renderings list.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetPredefinedRenderings Class
Sitecore.Pipelines.GetPlaceholderRenderings Namespace


GetPredefinedRenderings Constructor

[image]

Sitecore 6.4.1 API
GetPredefinedRenderings Constructor
GetPredefinedRenderings Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetPlaceholderRenderings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetPredefinedRenderings()
Visual Basic
Public Sub New
Visual C++
public:
GetPredefinedRenderings()

See Also

GetPredefinedRenderings Class
Sitecore.Pipelines.GetPlaceholderRenderings Namespace


GetPredefinedRenderings Methods

[image] [image]

Sitecore 6.4.1 API
GetPredefinedRenderings Methods
GetPredefinedRenderings Class See Also Send Feedback

The GetPredefinedRenderings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Fills placeholder renderings with predefined renderings list.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetPredefinedRenderings Class
Sitecore.Pipelines.GetPlaceholderRenderings Namespace


Process Method

[image]

Sitecore 6.4.1 API
GetPredefinedRenderings..::..Process Method
GetPredefinedRenderings Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetPlaceholderRenderings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    GetPlaceholderRenderingsArgs args
)
Visual Basic
Public Sub Process ( _
    args As GetPlaceholderRenderingsArgs _
)
Visual C++
public:
void Process(
    GetPlaceholderRenderingsArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.GetPlaceholderRenderings..::..GetPlaceholderRenderingsArgs
The arguments.

See Also

GetPredefinedRenderings Class
Sitecore.Pipelines.GetPlaceholderRenderings Namespace


Sitecore.Pipelines.GetQueryState Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.GetQueryState Namespace
Send Feedback

Classes

 | Class | Description
Public class | GetQueryStateArgs | Arguments for GetQueryState processors.


GetQueryStateArgs Class

[image]

Sitecore 6.4.1 API
GetQueryStateArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetQueryState
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetQueryStateArgs : PipelineArgs
Visual Basic
Public Class GetQueryStateArgs _
    Inherits PipelineArgs
Visual C++
public ref class GetQueryStateArgs : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Pipelines.GetQueryState..::..GetQueryStateArgs

See Also

GetQueryStateArgs Members
Sitecore.Pipelines.GetQueryState Namespace


GetQueryStateArgs Members

[image] [image]

Sitecore 6.4.1 API
GetQueryStateArgs Members
GetQueryStateArgs Class Constructors Methods Properties See Also Send Feedback

The GetQueryStateArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GetQueryStateArgs | Initializes a new instance of the GetQueryStateArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | Button | Gets the Command button, e.g. for Pannels.
Public property | CommandContext | Gets the command context.
Public property | CommandName | Gets the name of the command.
Public property | CommandState | Gets or sets the state of the command.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

GetQueryStateArgs Class
Sitecore.Pipelines.GetQueryState Namespace


GetQueryStateArgs Constructor

[image]

Sitecore 6.4.1 API
GetQueryStateArgs Constructor
GetQueryStateArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetQueryState
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetQueryStateArgs(
    string commandName,
    Item button,
    CommandState state,
    CommandContext context
)
Visual Basic
Public Sub New ( _
    commandName As String, _
    button As Item, _
    state As CommandState, _
    context As CommandContext _
)
Visual C++
public:
GetQueryStateArgs(
    String^ commandName,
    Item^ button,
    CommandState state,
    CommandContext^ context
)

Parameters

commandName
Type: System..::..String
Name of the command.
button
Type: Sitecore.Data.Items..::..Item
The Command button.
state
Type: Sitecore.Shell.Framework.Commands..::..CommandState
State of the command.
context
Type: Sitecore.Shell.Framework.Commands..::..CommandContext
Command context.

See Also

GetQueryStateArgs Class
Sitecore.Pipelines.GetQueryState Namespace


GetQueryStateArgs Methods

[image] [image]

Sitecore 6.4.1 API
GetQueryStateArgs Methods
GetQueryStateArgs Class See Also Send Feedback

The GetQueryStateArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetQueryStateArgs Class
Sitecore.Pipelines.GetQueryState Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
GetQueryStateArgs..::..AddMessage Method
GetQueryStateArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

GetQueryStateArgs Class
GetQueryStateArgs Members
Sitecore.Pipelines.GetQueryState Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
GetQueryStateArgs..::..GetMessages Method
GetQueryStateArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

GetQueryStateArgs Class
GetQueryStateArgs Members
Sitecore.Pipelines.GetQueryState Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
GetQueryStateArgs..::..Suspend Method
GetQueryStateArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

GetQueryStateArgs Class
GetQueryStateArgs Members
Sitecore.Pipelines.GetQueryState Namespace


GetQueryStateArgs Properties

[image] [image]

Sitecore 6.4.1 API
GetQueryStateArgs Properties
GetQueryStateArgs Class See Also Send Feedback

The GetQueryStateArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | Button | Gets the Command button, e.g. for Pannels.
Public property | CommandContext | Gets the command context.
Public property | CommandName | Gets the name of the command.
Public property | CommandState | Gets or sets the state of the command.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

GetQueryStateArgs Class
Sitecore.Pipelines.GetQueryState Namespace


Button Property

[image]

Sitecore 6.4.1 API
GetQueryStateArgs..::..Button Property
GetQueryStateArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetQueryState
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Button { get; }
Visual Basic
Public ReadOnly Property Button As Item
    Get
Visual C++
public:
property Item^ Button {
    Item^ get ();
}

Field Value

The Command button.

See Also

GetQueryStateArgs Class
Sitecore.Pipelines.GetQueryState Namespace


CommandName Property

[image]

Sitecore 6.4.1 API
GetQueryStateArgs..::..CommandName Property
GetQueryStateArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetQueryState
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string CommandName { get; }
Visual Basic
Public ReadOnly Property CommandName As String
    Get
Visual C++
public:
property String^ CommandName {
    String^ get ();
}

Field Value

The name of the command.

See Also

GetQueryStateArgs Class
Sitecore.Pipelines.GetQueryState Namespace


CommandState Property

[image]

Sitecore 6.4.1 API
GetQueryStateArgs..::..CommandState Property
GetQueryStateArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetQueryState
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CommandState CommandState { get; set; }
Visual Basic
Public Property CommandState As CommandState
    Get
    Set
Visual C++
public:
property CommandState CommandState {
    CommandState get ();
    void set (CommandState value);
}

Field Value

The state of the command.

See Also

GetQueryStateArgs Class
Sitecore.Pipelines.GetQueryState Namespace


Sitecore.Pipelines.GetRenderingDatasource Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.GetRenderingDatasource Namespace
Send Feedback

Classes

 | Class | Description
Public class | CheckDialogState | Checks if the select rendering datasource dialog should be shown
Public class | GetDatasourceLocation | Defines the datasource location root item
Public class | GetDatasourceTemplate | Get datasource template
Public class | GetDialogUrl | Get datasource dialog url
Public class | GetRenderingDatasourceArgs | The GetRenderingDatasourcArgs


CheckDialogState Class

[image]

Sitecore 6.4.1 API
CheckDialogState Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingDatasource
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CheckDialogState
Visual Basic
Public Class CheckDialogState
Visual C++
public ref class CheckDialogState

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetRenderingDatasource..::..CheckDialogState

See Also

CheckDialogState Members
Sitecore.Pipelines.GetRenderingDatasource Namespace


CheckDialogState Members

[image] [image]

Sitecore 6.4.1 API
CheckDialogState Members
CheckDialogState Class Constructors Methods See Also Send Feedback

The CheckDialogState type exposes the following members.

Constructors

 | Name | Description
Public method | CheckDialogState | Initializes a new instance of the CheckDialogState class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckDialogState Class
Sitecore.Pipelines.GetRenderingDatasource Namespace


CheckDialogState Constructor

[image]

Sitecore 6.4.1 API
CheckDialogState Constructor
CheckDialogState Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingDatasource
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CheckDialogState()
Visual Basic
Public Sub New
Visual C++
public:
CheckDialogState()

See Also

CheckDialogState Class
Sitecore.Pipelines.GetRenderingDatasource Namespace


CheckDialogState Methods

[image] [image]

Sitecore 6.4.1 API
CheckDialogState Methods
CheckDialogState Class See Also Send Feedback

The CheckDialogState type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckDialogState Class
Sitecore.Pipelines.GetRenderingDatasource Namespace


Process Method

[image]

Sitecore 6.4.1 API
CheckDialogState..::..Process Method
CheckDialogState Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingDatasource
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    GetRenderingDatasourceArgs args
)
Visual Basic
Public Sub Process ( _
    args As GetRenderingDatasourceArgs _
)
Visual C++
public:
void Process(
    GetRenderingDatasourceArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.GetRenderingDatasource..::..GetRenderingDatasourceArgs
The arguments.

See Also

CheckDialogState Class
Sitecore.Pipelines.GetRenderingDatasource Namespace


GetDatasourceLocation Class

[image]

Sitecore 6.4.1 API
GetDatasourceLocation Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingDatasource
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetDatasourceLocation
Visual Basic
Public Class GetDatasourceLocation
Visual C++
public ref class GetDatasourceLocation

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetRenderingDatasource..::..GetDatasourceLocation

See Also

GetDatasourceLocation Members
Sitecore.Pipelines.GetRenderingDatasource Namespace


GetDatasourceLocation Members

[image] [image]

Sitecore 6.4.1 API
GetDatasourceLocation Members
GetDatasourceLocation Class Constructors Methods See Also Send Feedback

The GetDatasourceLocation type exposes the following members.

Constructors

 | Name | Description
Public method | GetDatasourceLocation | Initializes a new instance of the GetDatasourceLocation class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetDatasourceLocation Class
Sitecore.Pipelines.GetRenderingDatasource Namespace


GetDatasourceLocation Methods

[image] [image]

Sitecore 6.4.1 API
GetDatasourceLocation Methods
GetDatasourceLocation Class See Also Send Feedback

The GetDatasourceLocation type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetDatasourceLocation Class
Sitecore.Pipelines.GetRenderingDatasource Namespace


Process Method

[image]

Sitecore 6.4.1 API
GetDatasourceLocation..::..Process Method
GetDatasourceLocation Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingDatasource
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    GetRenderingDatasourceArgs args
)
Visual Basic
Public Sub Process ( _
    args As GetRenderingDatasourceArgs _
)
Visual C++
public:
void Process(
    GetRenderingDatasourceArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.GetRenderingDatasource..::..GetRenderingDatasourceArgs
The arguments.

See Also

GetDatasourceLocation Class
Sitecore.Pipelines.GetRenderingDatasource Namespace


GetDatasourceTemplate Class

[image]

Sitecore 6.4.1 API
GetDatasourceTemplate Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingDatasource
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetDatasourceTemplate
Visual Basic
Public Class GetDatasourceTemplate
Visual C++
public ref class GetDatasourceTemplate

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetRenderingDatasource..::..GetDatasourceTemplate

See Also

GetDatasourceTemplate Members
Sitecore.Pipelines.GetRenderingDatasource Namespace


GetDatasourceTemplate Members

[image] [image]

Sitecore 6.4.1 API
GetDatasourceTemplate Members
GetDatasourceTemplate Class Constructors Methods See Also Send Feedback

The GetDatasourceTemplate type exposes the following members.

Constructors

 | Name | Description
Public method | GetDatasourceTemplate | Initializes a new instance of the GetDatasourceTemplate class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetDatasourceTemplate Class
Sitecore.Pipelines.GetRenderingDatasource Namespace


GetDatasourceTemplate Constructor

[image]

Sitecore 6.4.1 API
GetDatasourceTemplate Constructor
GetDatasourceTemplate Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingDatasource
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetDatasourceTemplate()
Visual Basic
Public Sub New
Visual C++
public:
GetDatasourceTemplate()

See Also

GetDatasourceTemplate Class
Sitecore.Pipelines.GetRenderingDatasource Namespace


GetDatasourceTemplate Methods

[image] [image]

Sitecore 6.4.1 API
GetDatasourceTemplate Methods
GetDatasourceTemplate Class See Also Send Feedback

The GetDatasourceTemplate type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetDatasourceTemplate Class
Sitecore.Pipelines.GetRenderingDatasource Namespace


Process Method

[image]

Sitecore 6.4.1 API
GetDatasourceTemplate..::..Process Method
GetDatasourceTemplate Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingDatasource
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    GetRenderingDatasourceArgs args
)
Visual Basic
Public Sub Process ( _
    args As GetRenderingDatasourceArgs _
)
Visual C++
public:
void Process(
    GetRenderingDatasourceArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.GetRenderingDatasource..::..GetRenderingDatasourceArgs
The arguments.

See Also

GetDatasourceTemplate Class
Sitecore.Pipelines.GetRenderingDatasource Namespace


GetDialogUrl Class

[image]

Sitecore 6.4.1 API
GetDialogUrl Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingDatasource
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetDialogUrl
Visual Basic
Public Class GetDialogUrl
Visual C++
public ref class GetDialogUrl

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetRenderingDatasource..::..GetDialogUrl

See Also

GetDialogUrl Members
Sitecore.Pipelines.GetRenderingDatasource Namespace


GetDialogUrl Members

[image] [image]

Sitecore 6.4.1 API
GetDialogUrl Members
GetDialogUrl Class Constructors Methods See Also Send Feedback

The GetDialogUrl type exposes the following members.

Constructors

 | Name | Description
Public method | GetDialogUrl | Initializes a new instance of the GetDialogUrl class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetDialogUrl Class
Sitecore.Pipelines.GetRenderingDatasource Namespace


GetDialogUrl Methods

[image] [image]

Sitecore 6.4.1 API
GetDialogUrl Methods
GetDialogUrl Class See Also Send Feedback

The GetDialogUrl type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetDialogUrl Class
Sitecore.Pipelines.GetRenderingDatasource Namespace


Process Method

[image]

Sitecore 6.4.1 API
GetDialogUrl..::..Process Method
GetDialogUrl Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingDatasource
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    GetRenderingDatasourceArgs args
)
Visual Basic
Public Sub Process ( _
    args As GetRenderingDatasourceArgs _
)
Visual C++
public:
void Process(
    GetRenderingDatasourceArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.GetRenderingDatasource..::..GetRenderingDatasourceArgs
The arguments.

See Also

GetDialogUrl Class
Sitecore.Pipelines.GetRenderingDatasource Namespace


GetRenderingDatasourceArgs Class

[image]

Sitecore 6.4.1 API
GetRenderingDatasourceArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingDatasource
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetRenderingDatasourceArgs : PipelineArgs
Visual Basic
Public Class GetRenderingDatasourceArgs _
    Inherits PipelineArgs
Visual C++
public ref class GetRenderingDatasourceArgs : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Pipelines.GetRenderingDatasource..::..GetRenderingDatasourceArgs

See Also

GetRenderingDatasourceArgs Members
Sitecore.Pipelines.GetRenderingDatasource Namespace


GetRenderingDatasourceArgs Members

[image] [image]

Sitecore 6.4.1 API
GetRenderingDatasourceArgs Members
GetRenderingDatasourceArgs Class Constructors Methods Properties See Also Send Feedback

The GetRenderingDatasourceArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GetRenderingDatasourceArgs(Item) | Creates a new instance of GetRenderingDatasourceArgs
Public method | GetRenderingDatasourceArgs(Item, Database) | Creates a new instance of GetRenderingDatasourceArgs

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | ContentDatabase | The Content Database.
Public property | ContextItemPath | Gets or sets the context item full path
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | DatasourceRoot | Gets or sets the datasource root item
Public property | DialogUrl | Gets or sets the dialog url
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Prototype | Gets or sets the template or branch that will be used to create new data sources.
Public property | RenderingItem | Gets or sets rendering item
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

GetRenderingDatasourceArgs Class
Sitecore.Pipelines.GetRenderingDatasource Namespace


GetRenderingDatasourceArgs Constructor

[image] [image]

Sitecore 6.4.1 API
GetRenderingDatasourceArgs Constructor
GetRenderingDatasourceArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRenderingDatasourceArgs(Item) | Creates a new instance of GetRenderingDatasourceArgs
Public method | GetRenderingDatasourceArgs(Item, Database) | Creates a new instance of GetRenderingDatasourceArgs

See Also

GetRenderingDatasourceArgs Class
GetRenderingDatasourceArgs Members
Sitecore.Pipelines.GetRenderingDatasource Namespace


GetRenderingDatasourceArgs Constructor (Item)

[image]

Sitecore 6.4.1 API
GetRenderingDatasourceArgs Constructor (Item)
GetRenderingDatasourceArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingDatasource
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetRenderingDatasourceArgs(
    Item renderingItem
)
Visual Basic
Public Sub New ( _
    renderingItem As Item _
)
Visual C++
public:
GetRenderingDatasourceArgs(
    Item^ renderingItem
)

Parameters

renderingItem
Type: Sitecore.Data.Items..::..Item
The rendering item

See Also

GetRenderingDatasourceArgs Class
GetRenderingDatasourceArgs Overload
Sitecore.Pipelines.GetRenderingDatasource Namespace


GetRenderingDatasourceArgs Constructor (Item, Database)

[image]

Sitecore 6.4.1 API
GetRenderingDatasourceArgs Constructor (Item, Database)
GetRenderingDatasourceArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingDatasource
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetRenderingDatasourceArgs(
    Item renderingItem,
    Database contentDatabase
)
Visual Basic
Public Sub New ( _
    renderingItem As Item, _
    contentDatabase As Database _
)
Visual C++
public:
GetRenderingDatasourceArgs(
    Item^ renderingItem,
    Database^ contentDatabase
)

Parameters

renderingItem
Type: Sitecore.Data.Items..::..Item
The rendering item
contentDatabase
Type: Sitecore.Data..::..Database
The content database

See Also

GetRenderingDatasourceArgs Class
GetRenderingDatasourceArgs Overload
Sitecore.Pipelines.GetRenderingDatasource Namespace


GetRenderingDatasourceArgs Methods

[image] [image]

Sitecore 6.4.1 API
GetRenderingDatasourceArgs Methods
GetRenderingDatasourceArgs Class See Also Send Feedback

The GetRenderingDatasourceArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetRenderingDatasourceArgs Class
Sitecore.Pipelines.GetRenderingDatasource Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
GetRenderingDatasourceArgs..::..AddMessage Method
GetRenderingDatasourceArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

GetRenderingDatasourceArgs Class
GetRenderingDatasourceArgs Members
Sitecore.Pipelines.GetRenderingDatasource Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
GetRenderingDatasourceArgs..::..GetMessages Method
GetRenderingDatasourceArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

GetRenderingDatasourceArgs Class
GetRenderingDatasourceArgs Members
Sitecore.Pipelines.GetRenderingDatasource Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
GetRenderingDatasourceArgs..::..Suspend Method
GetRenderingDatasourceArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

GetRenderingDatasourceArgs Class
GetRenderingDatasourceArgs Members
Sitecore.Pipelines.GetRenderingDatasource Namespace


ContentDatabase Property

[image]

Sitecore 6.4.1 API
GetRenderingDatasourceArgs..::..ContentDatabase Property
GetRenderingDatasourceArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingDatasource
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database ContentDatabase { get; protected set; }
Visual Basic
Public Property ContentDatabase As Database
    Get
    Protected Set
Visual C++
public:
property Database^ ContentDatabase {
    Database^ get ();
    protected: void set (Database^ value);
}

See Also

GetRenderingDatasourceArgs Class
Sitecore.Pipelines.GetRenderingDatasource Namespace


ContextItemPath Property

[image]

Sitecore 6.4.1 API
GetRenderingDatasourceArgs..::..ContextItemPath Property
GetRenderingDatasourceArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingDatasource
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ContextItemPath { get; set; }
Visual Basic
Public Property ContextItemPath As String
    Get
    Set
Visual C++
public:
property String^ ContextItemPath {
    String^ get ();
    void set (String^ value);
}

See Also

GetRenderingDatasourceArgs Class
Sitecore.Pipelines.GetRenderingDatasource Namespace


DatasourceRoot Property

[image]

Sitecore 6.4.1 API
GetRenderingDatasourceArgs..::..DatasourceRoot Property
GetRenderingDatasourceArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingDatasource
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item DatasourceRoot { get; set; }
Visual Basic
Public Property DatasourceRoot As Item
    Get
    Set
Visual C++
public:
property Item^ DatasourceRoot {
    Item^ get ();
    void set (Item^ value);
}

See Also

GetRenderingDatasourceArgs Class
Sitecore.Pipelines.GetRenderingDatasource Namespace


DialogUrl Property

[image]

Sitecore 6.4.1 API
GetRenderingDatasourceArgs..::..DialogUrl Property
GetRenderingDatasourceArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingDatasource
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string DialogUrl { get; set; }
Visual Basic
Public Property DialogUrl As String
    Get
    Set
Visual C++
public:
property String^ DialogUrl {
    String^ get ();
    void set (String^ value);
}

See Also

GetRenderingDatasourceArgs Class
Sitecore.Pipelines.GetRenderingDatasource Namespace


Prototype Property

[image]

Sitecore 6.4.1 API
GetRenderingDatasourceArgs..::..Prototype Property
GetRenderingDatasourceArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingDatasource
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Prototype { get; set; }
Visual Basic
Public Property Prototype As Item
    Get
    Set
Visual C++
public:
property Item^ Prototype {
    Item^ get ();
    void set (Item^ value);
}

See Also

GetRenderingDatasourceArgs Class
Sitecore.Pipelines.GetRenderingDatasource Namespace


RenderingItem Property

[image]

Sitecore 6.4.1 API
GetRenderingDatasourceArgs..::..RenderingItem Property
GetRenderingDatasourceArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingDatasource
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item RenderingItem { get; protected set; }
Visual Basic
Public Property RenderingItem As Item
    Get
    Protected Set
Visual C++
public:
property Item^ RenderingItem {
    Item^ get ();
    protected: void set (Item^ value);
}

See Also

GetRenderingDatasourceArgs Class
Sitecore.Pipelines.GetRenderingDatasource Namespace


Sitecore.Pipelines.GetRenderingPreview Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.GetRenderingPreview Namespace
Send Feedback

Classes

 | Class | Description
Public class | GetDefaultRenderingPreview | Get Rendering Preview Field.
Public class | GetRenderingPreviewArgs | The arguments for the Get Rendering Preview Pipeline
Public class | GetRenderingPreviewField | Get Rendering Preview Field.
Public class | GetRenderingPreviewProcessor | ExpandInitialFieldValueProcessor class
Public class | GetRenderingPreviewRunner | Runs the Get Rendering Preview Pipeline.
Public class | GetXslRenderingPreview | Get Rendering Preview Field.
Public class | TryRenderControl | Get Rendering Preview Field.


GetDefaultRenderingPreview Class

[image]

Sitecore 6.4.1 API
GetDefaultRenderingPreview Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingPreview
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetDefaultRenderingPreview : GetRenderingPreviewProcessor
Visual Basic
Public Class GetDefaultRenderingPreview _
    Inherits GetRenderingPreviewProcessor
Visual C++
public ref class GetDefaultRenderingPreview : public GetRenderingPreviewProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetRenderingPreview..::..GetRenderingPreviewProcessor
Sitecore.Pipelines.GetRenderingPreview..::..GetDefaultRenderingPreview

See Also

GetDefaultRenderingPreview Members
Sitecore.Pipelines.GetRenderingPreview Namespace


GetDefaultRenderingPreview Members

[image] [image]

Sitecore 6.4.1 API
GetDefaultRenderingPreview Members
GetDefaultRenderingPreview Class Constructors Methods See Also Send Feedback

The GetDefaultRenderingPreview type exposes the following members.

Constructors

 | Name | Description
Public method | GetDefaultRenderingPreview | Initializes a new instance of the GetDefaultRenderingPreview class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides GetRenderingPreviewProcessor..::..Process(GetRenderingPreviewArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetDefaultRenderingPreview Class
Sitecore.Pipelines.GetRenderingPreview Namespace


GetDefaultRenderingPreview Constructor

[image]

Sitecore 6.4.1 API
GetDefaultRenderingPreview Constructor
GetDefaultRenderingPreview Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingPreview
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetDefaultRenderingPreview()
Visual Basic
Public Sub New
Visual C++
public:
GetDefaultRenderingPreview()

See Also

GetDefaultRenderingPreview Class
Sitecore.Pipelines.GetRenderingPreview Namespace


GetDefaultRenderingPreview Methods

[image] [image]

Sitecore 6.4.1 API
GetDefaultRenderingPreview Methods
GetDefaultRenderingPreview Class See Also Send Feedback

The GetDefaultRenderingPreview type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides GetRenderingPreviewProcessor..::..Process(GetRenderingPreviewArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetDefaultRenderingPreview Class
Sitecore.Pipelines.GetRenderingPreview Namespace


Process Method

[image]

Sitecore 6.4.1 API
GetDefaultRenderingPreview..::..Process Method
GetDefaultRenderingPreview Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingPreview
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    GetRenderingPreviewArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As GetRenderingPreviewArgs _
)
Visual C++
public:
virtual void Process(
    GetRenderingPreviewArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.GetRenderingPreview..::..GetRenderingPreviewArgs
The arguments.

See Also

GetDefaultRenderingPreview Class
Sitecore.Pipelines.GetRenderingPreview Namespace


GetRenderingPreviewArgs Class

[image]

Sitecore 6.4.1 API
GetRenderingPreviewArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingPreview
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class GetRenderingPreviewArgs : PipelineArgs
Visual Basic
<SerializableAttribute> _
Public Class GetRenderingPreviewArgs _
    Inherits PipelineArgs
Visual C++
[SerializableAttribute]
public ref class GetRenderingPreviewArgs : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Pipelines.GetRenderingPreview..::..GetRenderingPreviewArgs

See Also

GetRenderingPreviewArgs Members
Sitecore.Pipelines.GetRenderingPreview Namespace


GetRenderingPreviewArgs Members

[image] [image]

Sitecore 6.4.1 API
GetRenderingPreviewArgs Members
GetRenderingPreviewArgs Class Constructors Methods Properties See Also Send Feedback

The GetRenderingPreviewArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GetRenderingPreviewArgs(RenderingReference) | Initializes a new instance of the GetRenderingPreviewArgs class.
Protected method | GetRenderingPreviewArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the GetRenderingPreviewArgs class.
Public method | GetRenderingPreviewArgs(Item, Item) | Initializes a new instance of the GetRenderingPreviewArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | RenderingItem | Gets the source item.
Public property | RenderingReference | Gets the rendering reference.
Public property | Result | Gets or sets the result.
Public property | SourceItem | Gets the source item.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

GetRenderingPreviewArgs Class
Sitecore.Pipelines.GetRenderingPreview Namespace


GetRenderingPreviewArgs Constructor

[image] [image]

Sitecore 6.4.1 API
GetRenderingPreviewArgs Constructor
GetRenderingPreviewArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRenderingPreviewArgs(RenderingReference) | Initializes a new instance of the GetRenderingPreviewArgs class.
Protected method | GetRenderingPreviewArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the GetRenderingPreviewArgs class.
Public method | GetRenderingPreviewArgs(Item, Item) | Initializes a new instance of the GetRenderingPreviewArgs class.

See Also

GetRenderingPreviewArgs Class
GetRenderingPreviewArgs Members
Sitecore.Pipelines.GetRenderingPreview Namespace


GetRenderingPreviewArgs Constructor (RenderingReference)

[image]

Sitecore 6.4.1 API
GetRenderingPreviewArgs Constructor (RenderingReference)
GetRenderingPreviewArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingPreview
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetRenderingPreviewArgs(
    RenderingReference reference
)
Visual Basic
Public Sub New ( _
    reference As RenderingReference _
)
Visual C++
public:
GetRenderingPreviewArgs(
    RenderingReference^ reference
)

Parameters

reference
Type: Sitecore.Layouts..::..RenderingReference
The reference.

See Also

GetRenderingPreviewArgs Class
GetRenderingPreviewArgs Overload
Sitecore.Pipelines.GetRenderingPreview Namespace


GetRenderingPreviewArgs Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
GetRenderingPreviewArgs Constructor (SerializationInfo, StreamingContext)
GetRenderingPreviewArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingPreview
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected GetRenderingPreviewArgs(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
GetRenderingPreviewArgs(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

GetRenderingPreviewArgs Class
GetRenderingPreviewArgs Overload
Sitecore.Pipelines.GetRenderingPreview Namespace


GetRenderingPreviewArgs Constructor (Item, Item)

[image]

Sitecore 6.4.1 API
GetRenderingPreviewArgs Constructor (Item, Item)
GetRenderingPreviewArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingPreview
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetRenderingPreviewArgs(
    Item renderingItem,
    Item sourceItem
)
Visual Basic
Public Sub New ( _
    renderingItem As Item, _
    sourceItem As Item _
)
Visual C++
public:
GetRenderingPreviewArgs(
    Item^ renderingItem,
    Item^ sourceItem
)

Parameters

renderingItem
Type: Sitecore.Data.Items..::..Item
The rendering item.
sourceItem
Type: Sitecore.Data.Items..::..Item
The source item.

See Also

GetRenderingPreviewArgs Class
GetRenderingPreviewArgs Overload
Sitecore.Pipelines.GetRenderingPreview Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
GetRenderingPreviewArgs..::..AddMessage Method
GetRenderingPreviewArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

GetRenderingPreviewArgs Class
GetRenderingPreviewArgs Members
Sitecore.Pipelines.GetRenderingPreview Namespace


GetObjectData Method

[image]

Sitecore 6.4.1 API
GetRenderingPreviewArgs..::..GetObjectData Method
GetRenderingPreviewArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingPreview
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System.Security..::..SecurityException | The caller does not have the required permission.

See Also

GetRenderingPreviewArgs Class
Sitecore.Pipelines.GetRenderingPreview Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
GetRenderingPreviewArgs..::..Suspend Method
GetRenderingPreviewArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

GetRenderingPreviewArgs Class
GetRenderingPreviewArgs Members
Sitecore.Pipelines.GetRenderingPreview Namespace


RenderingItem Property

[image]

Sitecore 6.4.1 API
GetRenderingPreviewArgs..::..RenderingItem Property
GetRenderingPreviewArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingPreview
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item RenderingItem { get; }
Visual Basic
Public ReadOnly Property RenderingItem As Item
    Get
Visual C++
public:
property Item^ RenderingItem {
    Item^ get ();
}

Field Value

The source item.

See Also

GetRenderingPreviewArgs Class
Sitecore.Pipelines.GetRenderingPreview Namespace


RenderingReference Property

[image]

Sitecore 6.4.1 API
GetRenderingPreviewArgs..::..RenderingReference Property
GetRenderingPreviewArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingPreview
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderingReference RenderingReference { get; }
Visual Basic
Public ReadOnly Property RenderingReference As RenderingReference
    Get
Visual C++
public:
property RenderingReference^ RenderingReference {
    RenderingReference^ get ();
}

Field Value

The rendering reference.

See Also

GetRenderingPreviewArgs Class
Sitecore.Pipelines.GetRenderingPreview Namespace


Result Property

[image]

Sitecore 6.4.1 API
GetRenderingPreviewArgs..::..Result Property
GetRenderingPreviewArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingPreview
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Result { get; set; }
Visual Basic
Public Property Result As String
    Get
    Set
Visual C++
public:
property String^ Result {
    String^ get ();
    void set (String^ value);
}

Field Value

The result.

See Also

GetRenderingPreviewArgs Class
Sitecore.Pipelines.GetRenderingPreview Namespace


SourceItem Property

[image]

Sitecore 6.4.1 API
GetRenderingPreviewArgs..::..SourceItem Property
GetRenderingPreviewArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingPreview
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item SourceItem { get; }
Visual Basic
Public ReadOnly Property SourceItem As Item
    Get
Visual C++
public:
property Item^ SourceItem {
    Item^ get ();
}

Field Value

The source item.

See Also

GetRenderingPreviewArgs Class
Sitecore.Pipelines.GetRenderingPreview Namespace


GetRenderingPreviewField Class

[image]

Sitecore 6.4.1 API
GetRenderingPreviewField Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingPreview
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetRenderingPreviewField : GetRenderingPreviewProcessor
Visual Basic
Public Class GetRenderingPreviewField _
    Inherits GetRenderingPreviewProcessor
Visual C++
public ref class GetRenderingPreviewField : public GetRenderingPreviewProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetRenderingPreview..::..GetRenderingPreviewProcessor
Sitecore.Pipelines.GetRenderingPreview..::..GetRenderingPreviewField

See Also

GetRenderingPreviewField Members
Sitecore.Pipelines.GetRenderingPreview Namespace


GetRenderingPreviewField Members

[image] [image]

Sitecore 6.4.1 API
GetRenderingPreviewField Members
GetRenderingPreviewField Class Constructors Methods See Also Send Feedback

The GetRenderingPreviewField type exposes the following members.

Constructors

 | Name | Description
Public method | GetRenderingPreviewField | Initializes a new instance of the GetRenderingPreviewField class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides GetRenderingPreviewProcessor..::..Process(GetRenderingPreviewArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetRenderingPreviewField Class
Sitecore.Pipelines.GetRenderingPreview Namespace


GetRenderingPreviewField Constructor

[image]

Sitecore 6.4.1 API
GetRenderingPreviewField Constructor
GetRenderingPreviewField Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingPreview
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetRenderingPreviewField()
Visual Basic
Public Sub New
Visual C++
public:
GetRenderingPreviewField()

See Also

GetRenderingPreviewField Class
Sitecore.Pipelines.GetRenderingPreview Namespace


GetRenderingPreviewField Methods

[image] [image]

Sitecore 6.4.1 API
GetRenderingPreviewField Methods
GetRenderingPreviewField Class See Also Send Feedback

The GetRenderingPreviewField type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides GetRenderingPreviewProcessor..::..Process(GetRenderingPreviewArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetRenderingPreviewField Class
Sitecore.Pipelines.GetRenderingPreview Namespace


Process Method

[image]

Sitecore 6.4.1 API
GetRenderingPreviewField..::..Process Method
GetRenderingPreviewField Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingPreview
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    GetRenderingPreviewArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As GetRenderingPreviewArgs _
)
Visual C++
public:
virtual void Process(
    GetRenderingPreviewArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.GetRenderingPreview..::..GetRenderingPreviewArgs
The pipeline args.

See Also

GetRenderingPreviewField Class
Sitecore.Pipelines.GetRenderingPreview Namespace


GetRenderingPreviewProcessor Class

[image]

Sitecore 6.4.1 API
GetRenderingPreviewProcessor Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingPreview
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class GetRenderingPreviewProcessor
Visual Basic
Public MustInherit Class GetRenderingPreviewProcessor
Visual C++
public ref class GetRenderingPreviewProcessor abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetRenderingPreview..::..GetRenderingPreviewProcessor
Sitecore.Pipelines.GetRenderingPreview..::..GetDefaultRenderingPreview
Sitecore.Pipelines.GetRenderingPreview..::..GetRenderingPreviewField
Sitecore.Pipelines.GetRenderingPreview..::..GetXslRenderingPreview
Sitecore.Pipelines.GetRenderingPreview..::..TryRenderControl

See Also

GetRenderingPreviewProcessor Members
Sitecore.Pipelines.GetRenderingPreview Namespace


GetRenderingPreviewProcessor Members

[image] [image]

Sitecore 6.4.1 API
GetRenderingPreviewProcessor Members
GetRenderingPreviewProcessor Class Constructors Methods See Also Send Feedback

The GetRenderingPreviewProcessor type exposes the following members.

Constructors

 | Name | Description
Protected method | GetRenderingPreviewProcessor | Initializes a new instance of the GetRenderingPreviewProcessor class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetRenderingPreviewProcessor Class
Sitecore.Pipelines.GetRenderingPreview Namespace


GetRenderingPreviewProcessor Methods

[image] [image]

Sitecore 6.4.1 API
GetRenderingPreviewProcessor Methods
GetRenderingPreviewProcessor Class See Also Send Feedback

The GetRenderingPreviewProcessor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetRenderingPreviewProcessor Class
Sitecore.Pipelines.GetRenderingPreview Namespace


Process Method

[image]

Sitecore 6.4.1 API
GetRenderingPreviewProcessor..::..Process Method
GetRenderingPreviewProcessor Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingPreview
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract void Process(
    GetRenderingPreviewArgs args
)
Visual Basic
Public MustOverride Sub Process ( _
    args As GetRenderingPreviewArgs _
)
Visual C++
public:
virtual void Process(
    GetRenderingPreviewArgs^ args
) abstract

Parameters

args
Type: Sitecore.Pipelines.GetRenderingPreview..::..GetRenderingPreviewArgs
The args.

See Also

GetRenderingPreviewProcessor Class
Sitecore.Pipelines.GetRenderingPreview Namespace


GetRenderingPreviewRunner Class

[image]

Sitecore 6.4.1 API
GetRenderingPreviewRunner Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingPreview
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class GetRenderingPreviewRunner
Visual Basic
Public NotInheritable Class GetRenderingPreviewRunner
Visual C++
public ref class GetRenderingPreviewRunner abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetRenderingPreview..::..GetRenderingPreviewRunner

See Also

GetRenderingPreviewRunner Members
Sitecore.Pipelines.GetRenderingPreview Namespace


GetRenderingPreviewRunner Members

[image] [image]

Sitecore 6.4.1 API
GetRenderingPreviewRunner Members
GetRenderingPreviewRunner Class Methods See Also Send Feedback

Methods

Name | Description
Run(Item) | Runs the specified rendering item.
Run(RenderingReference) | Runs the specified reference.
Run(Item, Item) | Runs the specified rendering item.

See Also

GetRenderingPreviewRunner Class
Sitecore.Pipelines.GetRenderingPreview Namespace


GetRenderingPreviewRunner Methods

[image] [image]

Sitecore 6.4.1 API
GetRenderingPreviewRunner Methods
GetRenderingPreviewRunner Class See Also Send Feedback

Methods

Name | Description
Run(Item) | Runs the specified rendering item.
Run(RenderingReference) | Runs the specified reference.
Run(Item, Item) | Runs the specified rendering item.

See Also

GetRenderingPreviewRunner Class
Sitecore.Pipelines.GetRenderingPreview Namespace


Run Method

[image] [image]

Sitecore 6.4.1 API
GetRenderingPreviewRunner..::..Run Method
GetRenderingPreviewRunner Class See Also Send Feedback

Overload List

Name | Description
Run(Item) | Runs the specified rendering item.
Run(RenderingReference) | Runs the specified reference.
Run(Item, Item) | Runs the specified rendering item.

See Also

GetRenderingPreviewRunner Class
GetRenderingPreviewRunner Members
Sitecore.Pipelines.GetRenderingPreview Namespace


Run Method (Item)

[image]

Sitecore 6.4.1 API
GetRenderingPreviewRunner..::..Run Method (Item)
GetRenderingPreviewRunner Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingPreview
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Run(
    Item renderingItem
)
Visual Basic
Public Shared Function Run ( _
    renderingItem As Item _
) As String
Visual C++
public:
static String^ Run(
    Item^ renderingItem
)

Parameters

renderingItem
Type: Sitecore.Data.Items..::..Item
The rendering item.

Return Value

The result of the run.

See Also

GetRenderingPreviewRunner Class
Run Overload
Sitecore.Pipelines.GetRenderingPreview Namespace


Run Method (RenderingReference)

[image]

Sitecore 6.4.1 API
GetRenderingPreviewRunner..::..Run Method (RenderingReference)
GetRenderingPreviewRunner Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingPreview
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Run(
    RenderingReference reference
)
Visual Basic
Public Shared Function Run ( _
    reference As RenderingReference _
) As String
Visual C++
public:
static String^ Run(
    RenderingReference^ reference
)

Parameters

reference
Type: Sitecore.Layouts..::..RenderingReference
The reference.

Return Value

The string.

See Also

GetRenderingPreviewRunner Class
Run Overload
Sitecore.Pipelines.GetRenderingPreview Namespace


Run Method (Item, Item)

[image]

Sitecore 6.4.1 API
GetRenderingPreviewRunner..::..Run Method (Item, Item)
GetRenderingPreviewRunner Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingPreview
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Run(
    Item renderingItem,
    Item sourceItem
)
Visual Basic
Public Shared Function Run ( _
    renderingItem As Item, _
    sourceItem As Item _
) As String
Visual C++
public:
static String^ Run(
    Item^ renderingItem,
    Item^ sourceItem
)

Parameters

renderingItem
Type: Sitecore.Data.Items..::..Item
The rendering item.
sourceItem
Type: Sitecore.Data.Items..::..Item
The source item.

Return Value

The result of the run.

See Also

GetRenderingPreviewRunner Class
Run Overload
Sitecore.Pipelines.GetRenderingPreview Namespace


GetXslRenderingPreview Class

[image]

Sitecore 6.4.1 API
GetXslRenderingPreview Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingPreview
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetXslRenderingPreview : GetRenderingPreviewProcessor
Visual Basic
Public Class GetXslRenderingPreview _
    Inherits GetRenderingPreviewProcessor
Visual C++
public ref class GetXslRenderingPreview : public GetRenderingPreviewProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetRenderingPreview..::..GetRenderingPreviewProcessor
Sitecore.Pipelines.GetRenderingPreview..::..GetXslRenderingPreview

See Also

GetXslRenderingPreview Members
Sitecore.Pipelines.GetRenderingPreview Namespace


GetXslRenderingPreview Members

[image] [image]

Sitecore 6.4.1 API
GetXslRenderingPreview Members
GetXslRenderingPreview Class Constructors Methods See Also Send Feedback

The GetXslRenderingPreview type exposes the following members.

Constructors

 | Name | Description
Public method | GetXslRenderingPreview | Initializes a new instance of the GetXslRenderingPreview class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides GetRenderingPreviewProcessor..::..Process(GetRenderingPreviewArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetXslRenderingPreview Class
Sitecore.Pipelines.GetRenderingPreview Namespace


GetXslRenderingPreview Constructor

[image]

Sitecore 6.4.1 API
GetXslRenderingPreview Constructor
GetXslRenderingPreview Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingPreview
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetXslRenderingPreview()
Visual Basic
Public Sub New
Visual C++
public:
GetXslRenderingPreview()

See Also

GetXslRenderingPreview Class
Sitecore.Pipelines.GetRenderingPreview Namespace


GetXslRenderingPreview Methods

[image] [image]

Sitecore 6.4.1 API
GetXslRenderingPreview Methods
GetXslRenderingPreview Class See Also Send Feedback

The GetXslRenderingPreview type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides GetRenderingPreviewProcessor..::..Process(GetRenderingPreviewArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetXslRenderingPreview Class
Sitecore.Pipelines.GetRenderingPreview Namespace


Process Method

[image]

Sitecore 6.4.1 API
GetXslRenderingPreview..::..Process Method
GetXslRenderingPreview Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingPreview
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    GetRenderingPreviewArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As GetRenderingPreviewArgs _
)
Visual C++
public:
virtual void Process(
    GetRenderingPreviewArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.GetRenderingPreview..::..GetRenderingPreviewArgs
The pipeline args.

See Also

GetXslRenderingPreview Class
Sitecore.Pipelines.GetRenderingPreview Namespace


TryRenderControl Members

[image] [image]

Sitecore 6.4.1 API
TryRenderControl Members
TryRenderControl Class Constructors Methods See Also Send Feedback

The TryRenderControl type exposes the following members.

Constructors

 | Name | Description
Public method | TryRenderControl | Initializes a new instance of the TryRenderControl class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides GetRenderingPreviewProcessor..::..Process(GetRenderingPreviewArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TryRenderControl Class
Sitecore.Pipelines.GetRenderingPreview Namespace


TryRenderControl Constructor

[image]

Sitecore 6.4.1 API
TryRenderControl Constructor
TryRenderControl Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingPreview
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TryRenderControl()
Visual Basic
Public Sub New
Visual C++
public:
TryRenderControl()

See Also

TryRenderControl Class
Sitecore.Pipelines.GetRenderingPreview Namespace


TryRenderControl Methods

[image] [image]

Sitecore 6.4.1 API
TryRenderControl Methods
TryRenderControl Class See Also Send Feedback

The TryRenderControl type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides GetRenderingPreviewProcessor..::..Process(GetRenderingPreviewArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TryRenderControl Class
Sitecore.Pipelines.GetRenderingPreview Namespace


Process Method

[image]

Sitecore 6.4.1 API
TryRenderControl..::..Process Method
TryRenderControl Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetRenderingPreview
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    GetRenderingPreviewArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As GetRenderingPreviewArgs _
)
Visual C++
public:
virtual void Process(
    GetRenderingPreviewArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.GetRenderingPreview..::..GetRenderingPreviewArgs
The pipeline args.

See Also

TryRenderControl Class
Sitecore.Pipelines.GetRenderingPreview Namespace


Sitecore.Pipelines.GetSyndicationWarnings Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.GetSyndicationWarnings Namespace
Send Feedback

Classes

 | Class | Description
Public class | CantWrite | Defines the cant write class.
Public class | GetSyndicationWarningsArgs | Defines the get syndication warnings args class.
Public class | IsLocked | Defines the is readonly class.
Public class | IsReadOnly | Defines the is readonly class.
Public class | SyndicationWarning | Defines the syndication warning class.


CantWrite Class

[image]

Sitecore 6.4.1 API
CantWrite Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetSyndicationWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CantWrite
Visual Basic
Public Class CantWrite
Visual C++
public ref class CantWrite

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetSyndicationWarnings..::..CantWrite

See Also

CantWrite Members
Sitecore.Pipelines.GetSyndicationWarnings Namespace


CantWrite Members

[image] [image]

Sitecore 6.4.1 API
CantWrite Members
CantWrite Class Constructors Methods See Also Send Feedback

The CantWrite type exposes the following members.

Constructors

 | Name | Description
Public method | CantWrite | Initializes a new instance of the CantWrite class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CantWrite Class
Sitecore.Pipelines.GetSyndicationWarnings Namespace


CantWrite Constructor

[image]

Sitecore 6.4.1 API
CantWrite Constructor
CantWrite Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetSyndicationWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CantWrite()
Visual Basic
Public Sub New
Visual C++
public:
CantWrite()

See Also

CantWrite Class
Sitecore.Pipelines.GetSyndicationWarnings Namespace


CantWrite Methods

[image] [image]

Sitecore 6.4.1 API
CantWrite Methods
CantWrite Class See Also Send Feedback

The CantWrite type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CantWrite Class
Sitecore.Pipelines.GetSyndicationWarnings Namespace


Process Method

[image]

Sitecore 6.4.1 API
CantWrite..::..Process Method
CantWrite Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetSyndicationWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    GetSyndicationWarningsArgs args
)
Visual Basic
Public Sub Process ( _
    args As GetSyndicationWarningsArgs _
)
Visual C++
public:
void Process(
    GetSyndicationWarningsArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.GetSyndicationWarnings..::..GetSyndicationWarningsArgs
The arguments.

See Also

CantWrite Class
Sitecore.Pipelines.GetSyndicationWarnings Namespace


GetSyndicationWarningsArgs Class

[image]

Sitecore 6.4.1 API
GetSyndicationWarningsArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetSyndicationWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetSyndicationWarningsArgs : PipelineArgs
Visual Basic
Public Class GetSyndicationWarningsArgs _
    Inherits PipelineArgs
Visual C++
public ref class GetSyndicationWarningsArgs : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Pipelines.GetSyndicationWarnings..::..GetSyndicationWarningsArgs

See Also

GetSyndicationWarningsArgs Members
Sitecore.Pipelines.GetSyndicationWarnings Namespace


GetSyndicationWarningsArgs Members

[image] [image]

Sitecore 6.4.1 API
GetSyndicationWarningsArgs Members
GetSyndicationWarningsArgs Class Constructors Methods Properties See Also Send Feedback

The GetSyndicationWarningsArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GetSyndicationWarningsArgs | Initializes a new instance of the GetSyndicationWarningsArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Item | Gets the item.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
Public property | Warnings | Gets the warnings.

See Also

GetSyndicationWarningsArgs Class
Sitecore.Pipelines.GetSyndicationWarnings Namespace


GetSyndicationWarningsArgs Constructor

[image]

Sitecore 6.4.1 API
GetSyndicationWarningsArgs Constructor
GetSyndicationWarningsArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetSyndicationWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetSyndicationWarningsArgs(
    Item item
)
Visual Basic
Public Sub New ( _
    item As Item _
)
Visual C++
public:
GetSyndicationWarningsArgs(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The Sitecore item

See Also

GetSyndicationWarningsArgs Class
Sitecore.Pipelines.GetSyndicationWarnings Namespace


GetSyndicationWarningsArgs Methods

[image] [image]

Sitecore 6.4.1 API
GetSyndicationWarningsArgs Methods
GetSyndicationWarningsArgs Class See Also Send Feedback

The GetSyndicationWarningsArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetSyndicationWarningsArgs Class
Sitecore.Pipelines.GetSyndicationWarnings Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
GetSyndicationWarningsArgs..::..AddMessage Method
GetSyndicationWarningsArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

GetSyndicationWarningsArgs Class
GetSyndicationWarningsArgs Members
Sitecore.Pipelines.GetSyndicationWarnings Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
GetSyndicationWarningsArgs..::..GetMessages Method
GetSyndicationWarningsArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

GetSyndicationWarningsArgs Class
GetSyndicationWarningsArgs Members
Sitecore.Pipelines.GetSyndicationWarnings Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
GetSyndicationWarningsArgs..::..Suspend Method
GetSyndicationWarningsArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

GetSyndicationWarningsArgs Class
GetSyndicationWarningsArgs Members
Sitecore.Pipelines.GetSyndicationWarnings Namespace


GetSyndicationWarningsArgs Properties

[image] [image]

Sitecore 6.4.1 API
GetSyndicationWarningsArgs Properties
GetSyndicationWarningsArgs Class See Also Send Feedback

The GetSyndicationWarningsArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Item | Gets the item.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
Public property | Warnings | Gets the warnings.

See Also

GetSyndicationWarningsArgs Class
Sitecore.Pipelines.GetSyndicationWarnings Namespace


Item Property

[image]

Sitecore 6.4.1 API
GetSyndicationWarningsArgs..::..Item Property
GetSyndicationWarningsArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetSyndicationWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Item { get; }
Visual Basic
Public ReadOnly Property Item As Item
    Get
Visual C++
public:
property Item^ Item {
    Item^ get ();
}

Field Value

The Sitecore item.

See Also

GetSyndicationWarningsArgs Class
Sitecore.Pipelines.GetSyndicationWarnings Namespace


Warnings Property

[image]

Sitecore 6.4.1 API
GetSyndicationWarningsArgs..::..Warnings Property
GetSyndicationWarningsArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetSyndicationWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public List<SyndicationWarning> Warnings { get; }
Visual Basic
Public ReadOnly Property Warnings As List(Of SyndicationWarning)
    Get
Visual C++
public:
property List<SyndicationWarning^>^ Warnings {
    List<SyndicationWarning^>^ get ();
}

Field Value

The warnings.

See Also

GetSyndicationWarningsArgs Class
Sitecore.Pipelines.GetSyndicationWarnings Namespace


IsLocked Class

[image]

Sitecore 6.4.1 API
IsLocked Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetSyndicationWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class IsLocked
Visual Basic
Public Class IsLocked
Visual C++
public ref class IsLocked

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetSyndicationWarnings..::..IsLocked

See Also

IsLocked Members
Sitecore.Pipelines.GetSyndicationWarnings Namespace


IsLocked Members

[image] [image]

Sitecore 6.4.1 API
IsLocked Members
IsLocked Class Constructors Methods See Also Send Feedback

The IsLocked type exposes the following members.

Constructors

 | Name | Description
Public method | IsLocked | Initializes a new instance of the IsLocked class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IsLocked Class
Sitecore.Pipelines.GetSyndicationWarnings Namespace


IsLocked Constructor

[image]

Sitecore 6.4.1 API
IsLocked Constructor
IsLocked Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetSyndicationWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IsLocked()
Visual Basic
Public Sub New
Visual C++
public:
IsLocked()

See Also

IsLocked Class
Sitecore.Pipelines.GetSyndicationWarnings Namespace


IsLocked Methods

[image] [image]

Sitecore 6.4.1 API
IsLocked Methods
IsLocked Class See Also Send Feedback

The IsLocked type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IsLocked Class
Sitecore.Pipelines.GetSyndicationWarnings Namespace


Process Method

[image]

Sitecore 6.4.1 API
IsLocked..::..Process Method
IsLocked Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetSyndicationWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    GetSyndicationWarningsArgs args
)
Visual Basic
Public Sub Process ( _
    args As GetSyndicationWarningsArgs _
)
Visual C++
public:
void Process(
    GetSyndicationWarningsArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.GetSyndicationWarnings..::..GetSyndicationWarningsArgs
The arguments.

See Also

IsLocked Class
Sitecore.Pipelines.GetSyndicationWarnings Namespace


IsReadOnly Class

[image]

Sitecore 6.4.1 API
IsReadOnly Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetSyndicationWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class IsReadOnly
Visual Basic
Public Class IsReadOnly
Visual C++
public ref class IsReadOnly

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetSyndicationWarnings..::..IsReadOnly

See Also

IsReadOnly Members
Sitecore.Pipelines.GetSyndicationWarnings Namespace


IsReadOnly Members

[image] [image]

Sitecore 6.4.1 API
IsReadOnly Members
IsReadOnly Class Constructors Methods See Also Send Feedback

The IsReadOnly type exposes the following members.

Constructors

 | Name | Description
Public method | IsReadOnly | Initializes a new instance of the IsReadOnly class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IsReadOnly Class
Sitecore.Pipelines.GetSyndicationWarnings Namespace


IsReadOnly Constructor

[image]

Sitecore 6.4.1 API
IsReadOnly Constructor
IsReadOnly Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetSyndicationWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IsReadOnly()
Visual Basic
Public Sub New
Visual C++
public:
IsReadOnly()

See Also

IsReadOnly Class
Sitecore.Pipelines.GetSyndicationWarnings Namespace


IsReadOnly Methods

[image] [image]

Sitecore 6.4.1 API
IsReadOnly Methods
IsReadOnly Class See Also Send Feedback

The IsReadOnly type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IsReadOnly Class
Sitecore.Pipelines.GetSyndicationWarnings Namespace


Process Method

[image]

Sitecore 6.4.1 API
IsReadOnly..::..Process Method
IsReadOnly Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetSyndicationWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    GetSyndicationWarningsArgs args
)
Visual Basic
Public Sub Process ( _
    args As GetSyndicationWarningsArgs _
)
Visual C++
public:
void Process(
    GetSyndicationWarningsArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.GetSyndicationWarnings..::..GetSyndicationWarningsArgs
The arguments.

See Also

IsReadOnly Class
Sitecore.Pipelines.GetSyndicationWarnings Namespace


SyndicationWarning Class

[image]

Sitecore 6.4.1 API
SyndicationWarning Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.GetSyndicationWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SyndicationWarning
Visual Basic
Public Class SyndicationWarning
Visual C++
public ref class SyndicationWarning

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.GetSyndicationWarnings..::..SyndicationWarning

See Also

SyndicationWarning Members
Sitecore.Pipelines.GetSyndicationWarnings Namespace


SyndicationWarning Members

[image] [image]

Sitecore 6.4.1 API
SyndicationWarning Members
SyndicationWarning Class Constructors Methods Properties See Also Send Feedback

The SyndicationWarning type exposes the following members.

Constructors

 | Name | Description
Public method | SyndicationWarning | Initializes a new instance of the SyndicationWarning class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Title | Gets or sets the title.

See Also

SyndicationWarning Class
Sitecore.Pipelines.GetSyndicationWarnings Namespace


SyndicationWarning Constructor

[image]

Sitecore 6.4.1 API
SyndicationWarning Constructor
SyndicationWarning Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetSyndicationWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SyndicationWarning(
    string title
)
Visual Basic
Public Sub New ( _
    title As String _
)
Visual C++
public:
SyndicationWarning(
    String^ title
)

Parameters

title
Type: System..::..String
The title.

See Also

SyndicationWarning Class
Sitecore.Pipelines.GetSyndicationWarnings Namespace


SyndicationWarning Methods

[image] [image]

Sitecore 6.4.1 API
SyndicationWarning Methods
SyndicationWarning Class See Also Send Feedback

The SyndicationWarning type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SyndicationWarning Class
Sitecore.Pipelines.GetSyndicationWarnings Namespace


SyndicationWarning Properties

[image] [image]

Sitecore 6.4.1 API
SyndicationWarning Properties
SyndicationWarning Class See Also Send Feedback

The SyndicationWarning type exposes the following members.

Properties

 | Name | Description
Public property | Title | Gets or sets the title.

See Also

SyndicationWarning Class
Sitecore.Pipelines.GetSyndicationWarnings Namespace


Title Property

[image]

Sitecore 6.4.1 API
SyndicationWarning..::..Title Property
SyndicationWarning Class See Also Send Feedback

Namespace: Sitecore.Pipelines.GetSyndicationWarnings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Title { get; set; }
Visual Basic
Public Property Title As String
    Get
    Set
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

Field Value

The title.

See Also

SyndicationWarning Class
Sitecore.Pipelines.GetSyndicationWarnings Namespace


Sitecore.Pipelines.HealthMonitor Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.HealthMonitor Namespace
Send Feedback

Classes

 | Class | Description
Public class | HealthMonitor | Main processor container for the HealthMonitor pipeline.


HealthMonitor Class

[image]

Sitecore 6.4.1 API
HealthMonitor Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.HealthMonitor
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class HealthMonitor
Visual Basic
Public Class HealthMonitor
Visual C++
public ref class HealthMonitor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.HealthMonitor..::..HealthMonitor

See Also

HealthMonitor Members
Sitecore.Pipelines.HealthMonitor Namespace


HealthMonitor Members

[image] [image]

Sitecore 6.4.1 API
HealthMonitor Members
HealthMonitor Class Constructors Methods See Also Send Feedback

The HealthMonitor type exposes the following members.

Constructors

 | Name | Description
Public method | HealthMonitor | Initializes a new instance of the HealthMonitor class

Methods

 | Name | Description
Public method | AddCounter | Adds the counter.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LogCacheStatus | Logs the cache status.
Public method | LogCounterStatus | Logs the counter status.
Public method | LogMemoryStatus | Logs the memory status.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HealthMonitor Class
Sitecore.Pipelines.HealthMonitor Namespace


HealthMonitor Constructor

[image]

Sitecore 6.4.1 API
HealthMonitor Constructor
HealthMonitor Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HealthMonitor
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HealthMonitor()
Visual Basic
Public Sub New
Visual C++
public:
HealthMonitor()

See Also

HealthMonitor Class
Sitecore.Pipelines.HealthMonitor Namespace


AddCounter Method

[image]

Sitecore 6.4.1 API
HealthMonitor..::..AddCounter Method
HealthMonitor Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HealthMonitor
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void AddCounter(
    XmlNode configNode
)
Visual Basic
Public Overridable Sub AddCounter ( _
    configNode As XmlNode _
)
Visual C++
public:
virtual void AddCounter(
    XmlNode^ configNode
)

Parameters

configNode
Type: System.Xml..::..XmlNode
The config node.

See Also

HealthMonitor Class
Sitecore.Pipelines.HealthMonitor Namespace


LogCacheStatus Method

[image]

Sitecore 6.4.1 API
HealthMonitor..::..LogCacheStatus Method
HealthMonitor Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HealthMonitor
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void LogCacheStatus(
    PipelineArgs args
)
Visual Basic
Public Overridable Sub LogCacheStatus ( _
    args As PipelineArgs _
)
Visual C++
public:
virtual void LogCacheStatus(
    PipelineArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines..::..PipelineArgs
The pipeline args.

See Also

HealthMonitor Class
Sitecore.Pipelines.HealthMonitor Namespace


LogCounterStatus Method

[image]

Sitecore 6.4.1 API
HealthMonitor..::..LogCounterStatus Method
HealthMonitor Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HealthMonitor
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void LogCounterStatus(
    PipelineArgs args
)
Visual Basic
Public Overridable Sub LogCounterStatus ( _
    args As PipelineArgs _
)
Visual C++
public:
virtual void LogCounterStatus(
    PipelineArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines..::..PipelineArgs
The args.

See Also

HealthMonitor Class
Sitecore.Pipelines.HealthMonitor Namespace


LogMemoryStatus Method

[image]

Sitecore 6.4.1 API
HealthMonitor..::..LogMemoryStatus Method
HealthMonitor Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HealthMonitor
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void LogMemoryStatus(
    PipelineArgs args
)
Visual Basic
Public Overridable Sub LogMemoryStatus ( _
    args As PipelineArgs _
)
Visual C++
public:
virtual void LogMemoryStatus(
    PipelineArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines..::..PipelineArgs
The pipeline args.

See Also

HealthMonitor Class
Sitecore.Pipelines.HealthMonitor Namespace


Sitecore.Pipelines.HttpRequest Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.HttpRequest Namespace
Send Feedback

Classes

 | Class | Description
Public class | AliasResolver | Resolves aliases.
Public class | BeginDiagnostics | Starts the diagnostics tools.
Public class | CustomHandlers | Filters Url extensions.
Public class | DatabaseResolver | Resolves the database.
Public class | DefaultResolver | Resolves the default item.
Public class | DeviceResolver | Resolves the device.
Public class | DynamicLinkResolver | DynamicLinkResolver class
Public class | EndDiagnostics | Ends the diagnostics tools.
Public class | ExecuteRequest | Executes the request.
Public class | FileResolver | Resolves files
Public class | FilterUrlExtensions | Obsolete. Filters Url extensions. Obsolete.
Public class | HttpRequestArgs | Argument class for HttpRequest pipeline
Public class | HttpRequestProcessor | HttpRequestProcessor class
Public class | IgnoreList | Determines if the Url is ignored by Sitecore.
Public class | ItemResolver | Resolves the current item from the query string path.
Public class | LanguageResolver | Resolves the language.
Public class | LayoutResolver | Resolves the layout corresponding to the Url.
Public class | QueryStringResolver | Resolves the query string.
Public class | ResizePicture | Resizes the image.
Public class | SaveFormAction | Saves the form action.
Public class | SiteResolver | Resolves the current site.
Public class | StartMeasurements | Processor used for initiating timing of HTTP requests.
Public class | StopMeasurements | Processor used for stopping and evaluating timing of HTTP requests.
Public class | UserResolver | Resolves the database.

Enumerations

 | Enumeration | Description
Public enumeration | HttpRequestType | Defines the phase of the Http request.


AliasResolver Class

[image]

Sitecore 6.4.1 API
AliasResolver Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class AliasResolver : HttpRequestProcessor
Visual Basic
Public Class AliasResolver _
    Inherits HttpRequestProcessor
Visual C++
public ref class AliasResolver : public HttpRequestProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.HttpRequest..::..HttpRequestProcessor
Sitecore.Pipelines.HttpRequest..::..AliasResolver

See Also

AliasResolver Members
Sitecore.Pipelines.HttpRequest Namespace


AliasResolver Members

[image] [image]

Sitecore 6.4.1 API
AliasResolver Members
AliasResolver Class Constructors Methods See Also Send Feedback

The AliasResolver type exposes the following members.

Constructors

 | Name | Description
Public method | AliasResolver | Initializes a new instance of the AliasResolver class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AliasResolver Class
Sitecore.Pipelines.HttpRequest Namespace


AliasResolver Constructor

[image]

Sitecore 6.4.1 API
AliasResolver Constructor
AliasResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AliasResolver()
Visual Basic
Public Sub New
Visual C++
public:
AliasResolver()

See Also

AliasResolver Class
Sitecore.Pipelines.HttpRequest Namespace


AliasResolver Methods

[image] [image]

Sitecore 6.4.1 API
AliasResolver Methods
AliasResolver Class See Also Send Feedback

The AliasResolver type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AliasResolver Class
Sitecore.Pipelines.HttpRequest Namespace


Process Method

[image]

Sitecore 6.4.1 API
AliasResolver..::..Process Method
AliasResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    HttpRequestArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As HttpRequestArgs _
)
Visual C++
public:
virtual void Process(
    HttpRequestArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.HttpRequest..::..HttpRequestArgs
The arguments.

See Also

AliasResolver Class
Sitecore.Pipelines.HttpRequest Namespace


BeginDiagnostics Class

[image]

Sitecore 6.4.1 API
BeginDiagnostics Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class BeginDiagnostics : HttpRequestProcessor
Visual Basic
Public Class BeginDiagnostics _
    Inherits HttpRequestProcessor
Visual C++
public ref class BeginDiagnostics : public HttpRequestProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.HttpRequest..::..HttpRequestProcessor
Sitecore.Pipelines.HttpRequest..::..BeginDiagnostics

See Also

BeginDiagnostics Members
Sitecore.Pipelines.HttpRequest Namespace


BeginDiagnostics Members

[image] [image]

Sitecore 6.4.1 API
BeginDiagnostics Members
BeginDiagnostics Class Constructors Methods See Also Send Feedback

The BeginDiagnostics type exposes the following members.

Constructors

 | Name | Description
Public method | BeginDiagnostics | Initializes a new instance of the BeginDiagnostics class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeginDiagnostics Class
Sitecore.Pipelines.HttpRequest Namespace


BeginDiagnostics Constructor

[image]

Sitecore 6.4.1 API
BeginDiagnostics Constructor
BeginDiagnostics Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BeginDiagnostics()
Visual Basic
Public Sub New
Visual C++
public:
BeginDiagnostics()

See Also

BeginDiagnostics Class
Sitecore.Pipelines.HttpRequest Namespace


Process Method

[image]

Sitecore 6.4.1 API
BeginDiagnostics..::..Process Method
BeginDiagnostics Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    HttpRequestArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As HttpRequestArgs _
)
Visual C++
public:
virtual void Process(
    HttpRequestArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.HttpRequest..::..HttpRequestArgs
The args.

See Also

BeginDiagnostics Class
Sitecore.Pipelines.HttpRequest Namespace


CustomHandlers Class

[image]

Sitecore 6.4.1 API
CustomHandlers Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CustomHandlers : HttpRequestProcessor
Visual Basic
Public Class CustomHandlers _
    Inherits HttpRequestProcessor
Visual C++
public ref class CustomHandlers : public HttpRequestProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.HttpRequest..::..HttpRequestProcessor
Sitecore.Pipelines.HttpRequest..::..CustomHandlers

See Also

CustomHandlers Members
Sitecore.Pipelines.HttpRequest Namespace


CustomHandlers Members

[image] [image]

Sitecore 6.4.1 API
CustomHandlers Members
CustomHandlers Class Constructors Methods See Also Send Feedback

The CustomHandlers type exposes the following members.

Constructors

 | Name | Description
Public method | CustomHandlers | Initializes a new instance of the CustomHandlers class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IsHandlerResolved | Determines whether handler is already resolved for current request.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomHandlers Class
Sitecore.Pipelines.HttpRequest Namespace


CustomHandlers Constructor

[image]

Sitecore 6.4.1 API
CustomHandlers Constructor
CustomHandlers Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CustomHandlers()
Visual Basic
Public Sub New
Visual C++
public:
CustomHandlers()

See Also

CustomHandlers Class
Sitecore.Pipelines.HttpRequest Namespace


CustomHandlers Methods

[image] [image]

Sitecore 6.4.1 API
CustomHandlers Methods
CustomHandlers Class See Also Send Feedback

The CustomHandlers type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IsHandlerResolved | Determines whether handler is already resolved for current request.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomHandlers Class
Sitecore.Pipelines.HttpRequest Namespace


IsHandlerResolved Method

[image]

Sitecore 6.4.1 API
CustomHandlers..::..IsHandlerResolved Method
CustomHandlers Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected bool IsHandlerResolved(
    HttpRequestArgs args
)
Visual Basic
Protected Function IsHandlerResolved ( _
    args As HttpRequestArgs _
) As Boolean
Visual C++
protected:
bool IsHandlerResolved(
    HttpRequestArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.HttpRequest..::..HttpRequestArgs
The arguments.

Return Value

true if handler is already resolved for current request; otherwise, false.

See Also

CustomHandlers Class
Sitecore.Pipelines.HttpRequest Namespace


Process Method

[image]

Sitecore 6.4.1 API
CustomHandlers..::..Process Method
CustomHandlers Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    HttpRequestArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As HttpRequestArgs _
)
Visual C++
public:
virtual void Process(
    HttpRequestArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.HttpRequest..::..HttpRequestArgs
The arguments.

See Also

CustomHandlers Class
Sitecore.Pipelines.HttpRequest Namespace


DatabaseResolver Class

[image]

Sitecore 6.4.1 API
DatabaseResolver Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DatabaseResolver : HttpRequestProcessor
Visual Basic
Public Class DatabaseResolver _
    Inherits HttpRequestProcessor
Visual C++
public ref class DatabaseResolver : public HttpRequestProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.HttpRequest..::..HttpRequestProcessor
Sitecore.Pipelines.HttpRequest..::..DatabaseResolver

See Also

DatabaseResolver Members
Sitecore.Pipelines.HttpRequest Namespace


DatabaseResolver Members

[image] [image]

Sitecore 6.4.1 API
DatabaseResolver Members
DatabaseResolver Class Constructors Methods See Also Send Feedback

The DatabaseResolver type exposes the following members.

Constructors

 | Name | Description
Public method | DatabaseResolver | Initializes a new instance of the DatabaseResolver class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DatabaseResolver Class
Sitecore.Pipelines.HttpRequest Namespace


DatabaseResolver Methods

[image] [image]

Sitecore 6.4.1 API
DatabaseResolver Methods
DatabaseResolver Class See Also Send Feedback

The DatabaseResolver type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DatabaseResolver Class
Sitecore.Pipelines.HttpRequest Namespace


Process Method

[image]

Sitecore 6.4.1 API
DatabaseResolver..::..Process Method
DatabaseResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    HttpRequestArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As HttpRequestArgs _
)
Visual C++
public:
virtual void Process(
    HttpRequestArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.HttpRequest..::..HttpRequestArgs
The arguments.

See Also

DatabaseResolver Class
Sitecore.Pipelines.HttpRequest Namespace


DefaultResolver Class

[image]

Sitecore 6.4.1 API
DefaultResolver Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DefaultResolver : HttpRequestProcessor
Visual Basic
Public Class DefaultResolver _
    Inherits HttpRequestProcessor
Visual C++
public ref class DefaultResolver : public HttpRequestProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.HttpRequest..::..HttpRequestProcessor
Sitecore.Pipelines.HttpRequest..::..DefaultResolver

See Also

DefaultResolver Members
Sitecore.Pipelines.HttpRequest Namespace


DefaultResolver Members

[image] [image]

Sitecore 6.4.1 API
DefaultResolver Members
DefaultResolver Class Constructors Methods See Also Send Feedback

The DefaultResolver type exposes the following members.

Constructors

 | Name | Description
Public method | DefaultResolver | Initializes a new instance of the DefaultResolver class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultResolver Class
Sitecore.Pipelines.HttpRequest Namespace


DefaultResolver Constructor

[image]

Sitecore 6.4.1 API
DefaultResolver Constructor
DefaultResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DefaultResolver()
Visual Basic
Public Sub New
Visual C++
public:
DefaultResolver()

See Also

DefaultResolver Class
Sitecore.Pipelines.HttpRequest Namespace


DefaultResolver Methods

[image] [image]

Sitecore 6.4.1 API
DefaultResolver Methods
DefaultResolver Class See Also Send Feedback

The DefaultResolver type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultResolver Class
Sitecore.Pipelines.HttpRequest Namespace


Process Method

[image]

Sitecore 6.4.1 API
DefaultResolver..::..Process Method
DefaultResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    HttpRequestArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As HttpRequestArgs _
)
Visual C++
public:
virtual void Process(
    HttpRequestArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.HttpRequest..::..HttpRequestArgs
The arguments.

See Also

DefaultResolver Class
Sitecore.Pipelines.HttpRequest Namespace


DeviceResolver Class

[image]

Sitecore 6.4.1 API
DeviceResolver Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DeviceResolver : HttpRequestProcessor
Visual Basic
Public Class DeviceResolver _
    Inherits HttpRequestProcessor
Visual C++
public ref class DeviceResolver : public HttpRequestProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.HttpRequest..::..HttpRequestProcessor
Sitecore.Pipelines.HttpRequest..::..DeviceResolver

See Also

DeviceResolver Members
Sitecore.Pipelines.HttpRequest Namespace


DeviceResolver Members

[image] [image]

Sitecore 6.4.1 API
DeviceResolver Members
DeviceResolver Class Constructors Methods See Also Send Feedback

The DeviceResolver type exposes the following members.

Constructors

 | Name | Description
Public method | DeviceResolver | Initializes a new instance of the DeviceResolver class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DeviceResolver Class
Sitecore.Pipelines.HttpRequest Namespace


DeviceResolver Constructor

[image]

Sitecore 6.4.1 API
DeviceResolver Constructor
DeviceResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DeviceResolver()
Visual Basic
Public Sub New
Visual C++
public:
DeviceResolver()

See Also

DeviceResolver Class
Sitecore.Pipelines.HttpRequest Namespace


DeviceResolver Methods

[image] [image]

Sitecore 6.4.1 API
DeviceResolver Methods
DeviceResolver Class See Also Send Feedback

The DeviceResolver type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DeviceResolver Class
Sitecore.Pipelines.HttpRequest Namespace


Process Method

[image]

Sitecore 6.4.1 API
DeviceResolver..::..Process Method
DeviceResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    HttpRequestArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As HttpRequestArgs _
)
Visual C++
public:
virtual void Process(
    HttpRequestArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.HttpRequest..::..HttpRequestArgs
The args.

See Also

DeviceResolver Class
Sitecore.Pipelines.HttpRequest Namespace


DynamicLinkResolver Class

[image]

Sitecore 6.4.1 API
DynamicLinkResolver Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DynamicLinkResolver : HttpRequestProcessor
Visual Basic
Public Class DynamicLinkResolver _
    Inherits HttpRequestProcessor
Visual C++
public ref class DynamicLinkResolver : public HttpRequestProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.HttpRequest..::..HttpRequestProcessor
Sitecore.Pipelines.HttpRequest..::..DynamicLinkResolver

See Also

DynamicLinkResolver Members
Sitecore.Pipelines.HttpRequest Namespace


DynamicLinkResolver Members

[image] [image]

Sitecore 6.4.1 API
DynamicLinkResolver Members
DynamicLinkResolver Class Constructors Methods See Also Send Feedback

The DynamicLinkResolver type exposes the following members.

Constructors

 | Name | Description
Public method | DynamicLinkResolver | Initializes a new instance of the DynamicLinkResolver class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DynamicLinkResolver Class
Sitecore.Pipelines.HttpRequest Namespace


DynamicLinkResolver Constructor

[image]

Sitecore 6.4.1 API
DynamicLinkResolver Constructor
DynamicLinkResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DynamicLinkResolver()
Visual Basic
Public Sub New
Visual C++
public:
DynamicLinkResolver()

See Also

DynamicLinkResolver Class
Sitecore.Pipelines.HttpRequest Namespace


DynamicLinkResolver Methods

[image] [image]

Sitecore 6.4.1 API
DynamicLinkResolver Methods
DynamicLinkResolver Class See Also Send Feedback

The DynamicLinkResolver type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DynamicLinkResolver Class
Sitecore.Pipelines.HttpRequest Namespace


Process Method

[image]

Sitecore 6.4.1 API
DynamicLinkResolver..::..Process Method
DynamicLinkResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    HttpRequestArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As HttpRequestArgs _
)
Visual C++
public:
virtual void Process(
    HttpRequestArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.HttpRequest..::..HttpRequestArgs
The arguments.

See Also

DynamicLinkResolver Class
Sitecore.Pipelines.HttpRequest Namespace


EndDiagnostics Class

[image]

Sitecore 6.4.1 API
EndDiagnostics Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class EndDiagnostics : HttpRequestProcessor
Visual Basic
Public Class EndDiagnostics _
    Inherits HttpRequestProcessor
Visual C++
public ref class EndDiagnostics : public HttpRequestProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.HttpRequest..::..HttpRequestProcessor
Sitecore.Pipelines.HttpRequest..::..EndDiagnostics

See Also

EndDiagnostics Members
Sitecore.Pipelines.HttpRequest Namespace


EndDiagnostics Members

[image] [image]

Sitecore 6.4.1 API
EndDiagnostics Members
EndDiagnostics Class Constructors Methods See Also Send Feedback

The EndDiagnostics type exposes the following members.

Constructors

 | Name | Description
Public method | EndDiagnostics | Initializes a new instance of the EndDiagnostics class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EndDiagnostics Class
Sitecore.Pipelines.HttpRequest Namespace


EndDiagnostics Constructor

[image]

Sitecore 6.4.1 API
EndDiagnostics Constructor
EndDiagnostics Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public EndDiagnostics()
Visual Basic
Public Sub New
Visual C++
public:
EndDiagnostics()

See Also

EndDiagnostics Class
Sitecore.Pipelines.HttpRequest Namespace


EndDiagnostics Methods

[image] [image]

Sitecore 6.4.1 API
EndDiagnostics Methods
EndDiagnostics Class See Also Send Feedback

The EndDiagnostics type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EndDiagnostics Class
Sitecore.Pipelines.HttpRequest Namespace


Process Method

[image]

Sitecore 6.4.1 API
EndDiagnostics..::..Process Method
EndDiagnostics Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    HttpRequestArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As HttpRequestArgs _
)
Visual C++
public:
virtual void Process(
    HttpRequestArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.HttpRequest..::..HttpRequestArgs
The arguments.

See Also

EndDiagnostics Class
Sitecore.Pipelines.HttpRequest Namespace


ExecuteRequest Class

[image]

Sitecore 6.4.1 API
ExecuteRequest Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ExecuteRequest : HttpRequestProcessor
Visual Basic
Public Class ExecuteRequest _
    Inherits HttpRequestProcessor
Visual C++
public ref class ExecuteRequest : public HttpRequestProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.HttpRequest..::..HttpRequestProcessor
Sitecore.Pipelines.HttpRequest..::..ExecuteRequest

See Also

ExecuteRequest Members
Sitecore.Pipelines.HttpRequest Namespace


ExecuteRequest Constructor

[image]

Sitecore 6.4.1 API
ExecuteRequest Constructor
ExecuteRequest Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ExecuteRequest()
Visual Basic
Public Sub New
Visual C++
public:
ExecuteRequest()

See Also

ExecuteRequest Class
Sitecore.Pipelines.HttpRequest Namespace


ExecuteRequest Methods

[image] [image]

Sitecore 6.4.1 API
ExecuteRequest Methods
ExecuteRequest Class See Also Send Feedback

The ExecuteRequest type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PerformRedirect | Redirects request to the specified URL.
Public method | Process | Runs the processor. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Protected method | RedirectOnItemNotFound | Preforms redirect on 'item not found' condition.
Protected method | RedirectOnLayoutNotFound | Redirects on 'layout not found' condition.
Protected method | RedirectOnNoAccess | Redirects on 'no access' condition.
Protected method | RedirectOnSiteAccessDenied | Redirects the on 'site access denied' condition.
Protected method | RedirectToLoginPage | Redirects to login page.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExecuteRequest Class
Sitecore.Pipelines.HttpRequest Namespace


PerformRedirect Method

[image]

Sitecore 6.4.1 API
ExecuteRequest..::..PerformRedirect Method
ExecuteRequest Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void PerformRedirect(
    string url
)
Visual Basic
Protected Overridable Sub PerformRedirect ( _
    url As String _
)
Visual C++
protected:
virtual void PerformRedirect(
    String^ url
)

Parameters

url
Type: System..::..String
The URL.

See Also

ExecuteRequest Class
Sitecore.Pipelines.HttpRequest Namespace


Process Method

[image]

Sitecore 6.4.1 API
ExecuteRequest..::..Process Method
ExecuteRequest Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    HttpRequestArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As HttpRequestArgs _
)
Visual C++
public:
virtual void Process(
    HttpRequestArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.HttpRequest..::..HttpRequestArgs
The arguments.

See Also

ExecuteRequest Class
Sitecore.Pipelines.HttpRequest Namespace


RedirectOnItemNotFound Method

[image]

Sitecore 6.4.1 API
ExecuteRequest..::..RedirectOnItemNotFound Method
ExecuteRequest Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void RedirectOnItemNotFound(
    string url
)
Visual Basic
Protected Overridable Sub RedirectOnItemNotFound ( _
    url As String _
)
Visual C++
protected:
virtual void RedirectOnItemNotFound(
    String^ url
)

Parameters

url
Type: System..::..String
The URL.

See Also

ExecuteRequest Class
Sitecore.Pipelines.HttpRequest Namespace


RedirectOnLayoutNotFound Method

[image]

Sitecore 6.4.1 API
ExecuteRequest..::..RedirectOnLayoutNotFound Method
ExecuteRequest Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void RedirectOnLayoutNotFound(
    string url
)
Visual Basic
Protected Overridable Sub RedirectOnLayoutNotFound ( _
    url As String _
)
Visual C++
protected:
virtual void RedirectOnLayoutNotFound(
    String^ url
)

Parameters

url
Type: System..::..String
The URL.

See Also

ExecuteRequest Class
Sitecore.Pipelines.HttpRequest Namespace


RedirectOnNoAccess Method

[image]

Sitecore 6.4.1 API
ExecuteRequest..::..RedirectOnNoAccess Method
ExecuteRequest Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void RedirectOnNoAccess(
    string url
)
Visual Basic
Protected Overridable Sub RedirectOnNoAccess ( _
    url As String _
)
Visual C++
protected:
virtual void RedirectOnNoAccess(
    String^ url
)

Parameters

url
Type: System..::..String
The URL.

See Also

ExecuteRequest Class
Sitecore.Pipelines.HttpRequest Namespace


RedirectOnSiteAccessDenied Method

[image]

Sitecore 6.4.1 API
ExecuteRequest..::..RedirectOnSiteAccessDenied Method
ExecuteRequest Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void RedirectOnSiteAccessDenied(
    string url
)
Visual Basic
Protected Overridable Sub RedirectOnSiteAccessDenied ( _
    url As String _
)
Visual C++
protected:
virtual void RedirectOnSiteAccessDenied(
    String^ url
)

Parameters

url
Type: System..::..String
The URL.

See Also

ExecuteRequest Class
Sitecore.Pipelines.HttpRequest Namespace


RedirectToLoginPage Method

[image]

Sitecore 6.4.1 API
ExecuteRequest..::..RedirectToLoginPage Method
ExecuteRequest Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void RedirectToLoginPage(
    string url
)
Visual Basic
Protected Overridable Sub RedirectToLoginPage ( _
    url As String _
)
Visual C++
protected:
virtual void RedirectToLoginPage(
    String^ url
)

Parameters

url
Type: System..::..String
The URL.

See Also

ExecuteRequest Class
Sitecore.Pipelines.HttpRequest Namespace


FileResolver Class

[image]

Sitecore 6.4.1 API
FileResolver Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FileResolver : HttpRequestProcessor
Visual Basic
Public Class FileResolver _
    Inherits HttpRequestProcessor
Visual C++
public ref class FileResolver : public HttpRequestProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.HttpRequest..::..HttpRequestProcessor
Sitecore.Pipelines.HttpRequest..::..FileResolver

See Also

FileResolver Members
Sitecore.Pipelines.HttpRequest Namespace


FileResolver Members

[image] [image]

Sitecore 6.4.1 API
FileResolver Members
FileResolver Class Constructors Methods See Also Send Feedback

The FileResolver type exposes the following members.

Constructors

 | Name | Description
Public method | FileResolver | Initializes a new instance of the FileResolver class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileResolver Class
Sitecore.Pipelines.HttpRequest Namespace


FileResolver Constructor

[image]

Sitecore 6.4.1 API
FileResolver Constructor
FileResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FileResolver()
Visual Basic
Public Sub New
Visual C++
public:
FileResolver()

See Also

FileResolver Class
Sitecore.Pipelines.HttpRequest Namespace


FileResolver Methods

[image] [image]

Sitecore 6.4.1 API
FileResolver Methods
FileResolver Class See Also Send Feedback

The FileResolver type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileResolver Class
Sitecore.Pipelines.HttpRequest Namespace


Process Method

[image]

Sitecore 6.4.1 API
FileResolver..::..Process Method
FileResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    HttpRequestArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As HttpRequestArgs _
)
Visual C++
public:
virtual void Process(
    HttpRequestArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.HttpRequest..::..HttpRequestArgs
The arguments.

See Also

FileResolver Class
Sitecore.Pipelines.HttpRequest Namespace


FilterUrlExtensions Class

[image]

Sitecore 6.4.1 API
FilterUrlExtensions Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public class FilterUrlExtensions : HttpRequestProcessor
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Class FilterUrlExtensions _
    Inherits HttpRequestProcessor
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public ref class FilterUrlExtensions : public HttpRequestProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.HttpRequest..::..HttpRequestProcessor
Sitecore.Pipelines.HttpRequest..::..FilterUrlExtensions

See Also

FilterUrlExtensions Members
Sitecore.Pipelines.HttpRequest Namespace


FilterUrlExtensions Members

[image] [image]

Sitecore 6.4.1 API
FilterUrlExtensions Members
FilterUrlExtensions Class Constructors Methods See Also Send Feedback

The FilterUrlExtensions type exposes the following members.

Constructors

 | Name | Description
Public method | FilterUrlExtensions | Initializes a new instance of the FilterUrlExtensions class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. Obsolete method. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterUrlExtensions Class
Sitecore.Pipelines.HttpRequest Namespace


FilterUrlExtensions Constructor

[image]

Sitecore 6.4.1 API
FilterUrlExtensions Constructor
FilterUrlExtensions Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FilterUrlExtensions(
    string allowed,
    string blocked,
    string streamFiles,
    string doNotStreamFiles
)
Visual Basic
Public Sub New ( _
    allowed As String, _
    blocked As String, _
    streamFiles As String, _
    doNotStreamFiles As String _
)
Visual C++
public:
FilterUrlExtensions(
    String^ allowed,
    String^ blocked,
    String^ streamFiles,
    String^ doNotStreamFiles
)

Parameters

allowed
Type: System..::..String

[Missing <param name="allowed"/> documentation for "M:Sitecore.Pipelines.HttpRequest.FilterUrlExtensions.#ctor(System.String,System.String,System.String,System.String)"]

blocked
Type: System..::..String

[Missing <param name="blocked"/> documentation for "M:Sitecore.Pipelines.HttpRequest.FilterUrlExtensions.#ctor(System.String,System.String,System.String,System.String)"]

streamFiles
Type: System..::..String

[Missing <param name="streamFiles"/> documentation for "M:Sitecore.Pipelines.HttpRequest.FilterUrlExtensions.#ctor(System.String,System.String,System.String,System.String)"]

doNotStreamFiles
Type: System..::..String

[Missing <param name="doNotStreamFiles"/> documentation for "M:Sitecore.Pipelines.HttpRequest.FilterUrlExtensions.#ctor(System.String,System.String,System.String,System.String)"]

See Also

FilterUrlExtensions Class
Sitecore.Pipelines.HttpRequest Namespace


FilterUrlExtensions Methods

[image] [image]

Sitecore 6.4.1 API
FilterUrlExtensions Methods
FilterUrlExtensions Class See Also Send Feedback

The FilterUrlExtensions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. Obsolete method. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterUrlExtensions Class
Sitecore.Pipelines.HttpRequest Namespace


Process Method

[image]

Sitecore 6.4.1 API
FilterUrlExtensions..::..Process Method
FilterUrlExtensions Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    HttpRequestArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As HttpRequestArgs _
)
Visual C++
public:
virtual void Process(
    HttpRequestArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.HttpRequest..::..HttpRequestArgs
The args.

See Also

FilterUrlExtensions Class
Sitecore.Pipelines.HttpRequest Namespace


HttpRequestArgs Class

[image]

Sitecore 6.4.1 API
HttpRequestArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class HttpRequestArgs : PipelineArgs
Visual Basic
<SerializableAttribute> _
Public Class HttpRequestArgs _
    Inherits PipelineArgs
Visual C++
[SerializableAttribute]
public ref class HttpRequestArgs : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Pipelines.HttpRequest..::..HttpRequestArgs

See Also

HttpRequestArgs Members
Sitecore.Pipelines.HttpRequest Namespace


HttpRequestArgs Members

[image] [image]

Sitecore 6.4.1 API
HttpRequestArgs Members
HttpRequestArgs Class Constructors Methods Properties See Also Send Feedback

The HttpRequestArgs type exposes the following members.

Constructors

 | Name | Description
Protected method | HttpRequestArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the HttpRequestArgs class.
Public method | HttpRequestArgs(HttpContext, HttpRequestType) | Initializes a new instance of the HttpRequestArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Public method | ApplySecurity | Applies the security.
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItem(String) | Gets the item.
Public method | GetItem(ID) | Gets the item.
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initialize. (Overrides PipelineArgs..::..Initialize()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | Context | Gets the context.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | LocalPath | Gets the local path.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | PermissionDenied | Gets or sets a value indicating whether [permission denied].
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | RequestType | Is this a BeginRequest event? If not, it is an EndRequest event
Public property | StartPath | Gets or sets the start path.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
Public property | Url | Gets the request URL.
Public property | UseSiteStartPath | Gets a value indicating whether the ItemResolver should use the site start path if no item where resolved.

See Also

HttpRequestArgs Class
Sitecore.Pipelines.HttpRequest Namespace


HttpRequestArgs Constructor

[image] [image]

Sitecore 6.4.1 API
HttpRequestArgs Constructor
HttpRequestArgs Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | HttpRequestArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the HttpRequestArgs class.
Public method | HttpRequestArgs(HttpContext, HttpRequestType) | Initializes a new instance of the HttpRequestArgs class.

See Also

HttpRequestArgs Class
HttpRequestArgs Members
Sitecore.Pipelines.HttpRequest Namespace


HttpRequestArgs Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
HttpRequestArgs Constructor (SerializationInfo, StreamingContext)
HttpRequestArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected HttpRequestArgs(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
HttpRequestArgs(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

HttpRequestArgs Class
HttpRequestArgs Overload
Sitecore.Pipelines.HttpRequest Namespace


HttpRequestArgs Constructor (HttpContext, HttpRequestType)

[image]

Sitecore 6.4.1 API
HttpRequestArgs Constructor (HttpContext, HttpRequestType)
HttpRequestArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HttpRequestArgs(
    HttpContext context,
    HttpRequestType requestType
)
Visual Basic
Public Sub New ( _
    context As HttpContext, _
    requestType As HttpRequestType _
)
Visual C++
public:
HttpRequestArgs(
    HttpContext^ context,
    HttpRequestType requestType
)

Parameters

context
Type: System.Web..::..HttpContext
The context.
requestType
Type: Sitecore.Pipelines.HttpRequest..::..HttpRequestType
Type of the request.

See Also

HttpRequestArgs Class
HttpRequestArgs Overload
Sitecore.Pipelines.HttpRequest Namespace


HttpRequestArgs Methods

[image] [image]

Sitecore 6.4.1 API
HttpRequestArgs Methods
HttpRequestArgs Class See Also Send Feedback

The HttpRequestArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Public method | ApplySecurity | Applies the security.
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItem(String) | Gets the item.
Public method | GetItem(ID) | Gets the item.
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initialize. (Overrides PipelineArgs..::..Initialize()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HttpRequestArgs Class
Sitecore.Pipelines.HttpRequest Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
HttpRequestArgs..::..AddMessage Method
HttpRequestArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

HttpRequestArgs Class
HttpRequestArgs Members
Sitecore.Pipelines.HttpRequest Namespace


ApplySecurity Method

[image]

Sitecore 6.4.1 API
HttpRequestArgs..::..ApplySecurity Method
HttpRequestArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item ApplySecurity(
    Item item
)
Visual Basic
Public Function ApplySecurity ( _
    item As Item _
) As Item
Visual C++
public:
Item^ ApplySecurity(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Pipelines.HttpRequest.HttpRequestArgs.ApplySecurity(Sitecore.Data.Items.Item)"]

See Also

HttpRequestArgs Class
Sitecore.Pipelines.HttpRequest Namespace


GetItem Method (String)

[image]

Sitecore 6.4.1 API
HttpRequestArgs..::..GetItem Method (String)
HttpRequestArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetItem(
    string path
)
Visual Basic
Public Function GetItem ( _
    path As String _
) As Item
Visual C++
public:
Item^ GetItem(
    String^ path
)

Parameters

path
Type: System..::..String
The path.

Return Value

[Missing <returns> documentation for "M:Sitecore.Pipelines.HttpRequest.HttpRequestArgs.GetItem(System.String)"]

See Also

HttpRequestArgs Class
GetItem Overload
Sitecore.Pipelines.HttpRequest Namespace


GetItem Method (ID)

[image]

Sitecore 6.4.1 API
HttpRequestArgs..::..GetItem Method (ID)
HttpRequestArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetItem(
    ID itemID
)
Visual Basic
Public Function GetItem ( _
    itemID As ID _
) As Item
Visual C++
public:
Item^ GetItem(
    ID^ itemID
)

Parameters

itemID
Type: Sitecore.Data..::..ID
The item ID.

Return Value

[Missing <returns> documentation for "M:Sitecore.Pipelines.HttpRequest.HttpRequestArgs.GetItem(Sitecore.Data.ID)"]

See Also

HttpRequestArgs Class
GetItem Overload
Sitecore.Pipelines.HttpRequest Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
HttpRequestArgs..::..GetMessages Method
HttpRequestArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

HttpRequestArgs Class
HttpRequestArgs Members
Sitecore.Pipelines.HttpRequest Namespace


GetObjectData Method

[image]

Sitecore 6.4.1 API
HttpRequestArgs..::..GetObjectData Method
HttpRequestArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System.Security..::..SecurityException | The caller does not have the required permission.

See Also

HttpRequestArgs Class
Sitecore.Pipelines.HttpRequest Namespace


HttpRequestArgs Properties

[image] [image]

Sitecore 6.4.1 API
HttpRequestArgs Properties
HttpRequestArgs Class See Also Send Feedback

The HttpRequestArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | Context | Gets the context.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | LocalPath | Gets the local path.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | PermissionDenied | Gets or sets a value indicating whether [permission denied].
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | RequestType | Is this a BeginRequest event? If not, it is an EndRequest event
Public property | StartPath | Gets or sets the start path.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
Public property | Url | Gets the request URL.
Public property | UseSiteStartPath | Gets a value indicating whether the ItemResolver should use the site start path if no item where resolved.

See Also

HttpRequestArgs Class
Sitecore.Pipelines.HttpRequest Namespace


Context Property

[image]

Sitecore 6.4.1 API
HttpRequestArgs..::..Context Property
HttpRequestArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HttpContext Context { get; }
Visual Basic
Public ReadOnly Property Context As HttpContext
    Get
Visual C++
public:
property HttpContext^ Context {
    HttpContext^ get ();
}

Field Value

The context.

See Also

HttpRequestArgs Class
Sitecore.Pipelines.HttpRequest Namespace


LocalPath Property

[image]

Sitecore 6.4.1 API
HttpRequestArgs..::..LocalPath Property
HttpRequestArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string LocalPath { get; }
Visual Basic
Public ReadOnly Property LocalPath As String
    Get
Visual C++
public:
property String^ LocalPath {
    String^ get ();
}

Field Value

The local path.

See Also

HttpRequestArgs Class
Sitecore.Pipelines.HttpRequest Namespace


PermissionDenied Property

[image]

Sitecore 6.4.1 API
HttpRequestArgs..::..PermissionDenied Property
HttpRequestArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool PermissionDenied { get; set; }
Visual Basic
Public Property PermissionDenied As Boolean
    Get
    Set
Visual C++
public:
property bool PermissionDenied {
    bool get ();
    void set (bool value);
}

Field Value

true if [permission denied]; otherwise, false.

See Also

HttpRequestArgs Class
Sitecore.Pipelines.HttpRequest Namespace


RequestType Property

[image]

Sitecore 6.4.1 API
HttpRequestArgs..::..RequestType Property
HttpRequestArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HttpRequestType RequestType { get; }
Visual Basic
Public ReadOnly Property RequestType As HttpRequestType
    Get
Visual C++
public:
property HttpRequestType RequestType {
    HttpRequestType get ();
}

Field Value

The type of the request.

See Also

HttpRequestArgs Class
Sitecore.Pipelines.HttpRequest Namespace


StartPath Property

[image]

Sitecore 6.4.1 API
HttpRequestArgs..::..StartPath Property
HttpRequestArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string StartPath { get; set; }
Visual Basic
Public Property StartPath As String
    Get
    Set
Visual C++
public:
property String^ StartPath {
    String^ get ();
    void set (String^ value);
}

Field Value

The start path.

See Also

HttpRequestArgs Class
Sitecore.Pipelines.HttpRequest Namespace


Url Property

[image]

Sitecore 6.4.1 API
HttpRequestArgs..::..Url Property
HttpRequestArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RequestUrl Url { get; }
Visual Basic
Public ReadOnly Property Url As RequestUrl
    Get
Visual C++
public:
property RequestUrl^ Url {
    RequestUrl^ get ();
}

Field Value

The URL.

See Also

HttpRequestArgs Class
Sitecore.Pipelines.HttpRequest Namespace


UseSiteStartPath Property

[image]

Sitecore 6.4.1 API
HttpRequestArgs..::..UseSiteStartPath Property
HttpRequestArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool UseSiteStartPath { get; }
Visual Basic
Public ReadOnly Property UseSiteStartPath As Boolean
    Get
Visual C++
public:
property bool UseSiteStartPath {
    bool get ();
}

Field Value

true if the ItemResolver should use the site start path if no item where resolved; otherwise, false.

See Also

HttpRequestArgs Class
Sitecore.Pipelines.HttpRequest Namespace


HttpRequestProcessor Class

[image]

Sitecore 6.4.1 API
HttpRequestProcessor Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class HttpRequestProcessor
Visual Basic
Public MustInherit Class HttpRequestProcessor
Visual C++
public ref class HttpRequestProcessor abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.HttpRequest..::..HttpRequestProcessor
Sitecore.Analytics.Pipelines.HttpRequest..::..EndAnalytics
Sitecore.Analytics.Pipelines.HttpRequest..::..StartDiagnostics
Sitecore.Pipelines.HttpRequest..::..AliasResolver
Sitecore.Pipelines.HttpRequest..::..BeginDiagnostics
Sitecore.Pipelines.HttpRequest..::..CustomHandlers
Sitecore.Pipelines.HttpRequest..::..DatabaseResolver
Sitecore.Pipelines.HttpRequest..::..DefaultResolver
Sitecore.Pipelines.HttpRequest..::..DeviceResolver
Sitecore.Pipelines.HttpRequest..::..DynamicLinkResolver
Sitecore.Pipelines.HttpRequest..::..EndDiagnostics
Sitecore.Pipelines.HttpRequest..::..ExecuteRequest
Sitecore.Pipelines.HttpRequest..::..FileResolver
Sitecore.Pipelines.HttpRequest..::..FilterUrlExtensions
Sitecore.Pipelines.HttpRequest..::..IgnoreList
Sitecore.Pipelines.HttpRequest..::..ItemResolver
Sitecore.Pipelines.HttpRequest..::..LanguageResolver
Sitecore.Pipelines.HttpRequest..::..LayoutResolver
Sitecore.Pipelines.HttpRequest..::..QueryStringResolver
Sitecore.Pipelines.HttpRequest..::..ResizePicture
Sitecore.Pipelines.HttpRequest..::..SaveFormAction
Sitecore.Pipelines.HttpRequest..::..SiteResolver
Sitecore.Pipelines.HttpRequest..::..StartMeasurements
Sitecore.Pipelines.HttpRequest..::..StopMeasurements
Sitecore.Pipelines.HttpRequest..::..UserResolver

See Also

HttpRequestProcessor Members
Sitecore.Pipelines.HttpRequest Namespace


HttpRequestProcessor Members

[image] [image]

Sitecore 6.4.1 API
HttpRequestProcessor Members
HttpRequestProcessor Class Constructors Methods See Also Send Feedback

The HttpRequestProcessor type exposes the following members.

Constructors

 | Name | Description
Protected method | HttpRequestProcessor | Initializes a new instance of the HttpRequestProcessor class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HttpRequestProcessor Class
Sitecore.Pipelines.HttpRequest Namespace


HttpRequestProcessor Constructor

[image]

Sitecore 6.4.1 API
HttpRequestProcessor Constructor
HttpRequestProcessor Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected HttpRequestProcessor()
Visual Basic
Protected Sub New
Visual C++
protected:
HttpRequestProcessor()

See Also

HttpRequestProcessor Class
Sitecore.Pipelines.HttpRequest Namespace


HttpRequestProcessor Methods

[image] [image]

Sitecore 6.4.1 API
HttpRequestProcessor Methods
HttpRequestProcessor Class See Also Send Feedback

The HttpRequestProcessor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HttpRequestProcessor Class
Sitecore.Pipelines.HttpRequest Namespace


Process Method

[image]

Sitecore 6.4.1 API
HttpRequestProcessor..::..Process Method
HttpRequestProcessor Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract void Process(
    HttpRequestArgs args
)
Visual Basic
Public MustOverride Sub Process ( _
    args As HttpRequestArgs _
)
Visual C++
public:
virtual void Process(
    HttpRequestArgs^ args
) abstract

Parameters

args
Type: Sitecore.Pipelines.HttpRequest..::..HttpRequestArgs
The args.

See Also

HttpRequestProcessor Class
Sitecore.Pipelines.HttpRequest Namespace


IgnoreList Class

[image]

Sitecore 6.4.1 API
IgnoreList Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class IgnoreList : HttpRequestProcessor
Visual Basic
Public Class IgnoreList _
    Inherits HttpRequestProcessor
Visual C++
public ref class IgnoreList : public HttpRequestProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.HttpRequest..::..HttpRequestProcessor
Sitecore.Pipelines.HttpRequest..::..IgnoreList

See Also

IgnoreList Members
Sitecore.Pipelines.HttpRequest Namespace


IgnoreList Members

[image] [image]

Sitecore 6.4.1 API
IgnoreList Members
IgnoreList Class Constructors Methods See Also Send Feedback

The IgnoreList type exposes the following members.

Constructors

 | Name | Description
Public method | IgnoreList | Initializes a new instance of the IgnoreList class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IgnoreList Class
Sitecore.Pipelines.HttpRequest Namespace


IgnoreList Constructor

[image]

Sitecore 6.4.1 API
IgnoreList Constructor
IgnoreList Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IgnoreList()
Visual Basic
Public Sub New
Visual C++
public:
IgnoreList()

See Also

IgnoreList Class
Sitecore.Pipelines.HttpRequest Namespace


IgnoreList Methods

[image] [image]

Sitecore 6.4.1 API
IgnoreList Methods
IgnoreList Class See Also Send Feedback

The IgnoreList type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IgnoreList Class
Sitecore.Pipelines.HttpRequest Namespace


Process Method

[image]

Sitecore 6.4.1 API
IgnoreList..::..Process Method
IgnoreList Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    HttpRequestArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As HttpRequestArgs _
)
Visual C++
public:
virtual void Process(
    HttpRequestArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.HttpRequest..::..HttpRequestArgs
The arguments.

See Also

IgnoreList Class
Sitecore.Pipelines.HttpRequest Namespace


ItemResolver Class

[image]

Sitecore 6.4.1 API
ItemResolver Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemResolver : HttpRequestProcessor
Visual Basic
Public Class ItemResolver _
    Inherits HttpRequestProcessor
Visual C++
public ref class ItemResolver : public HttpRequestProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.HttpRequest..::..HttpRequestProcessor
Sitecore.Pipelines.HttpRequest..::..ItemResolver

See Also

ItemResolver Members
Sitecore.Pipelines.HttpRequest Namespace


ItemResolver Members

[image] [image]

Sitecore 6.4.1 API
ItemResolver Members
ItemResolver Class Constructors Methods See Also Send Feedback

The ItemResolver type exposes the following members.

Constructors

 | Name | Description
Public method | ItemResolver | Initializes a new instance of the ItemResolver class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemResolver Class
Sitecore.Pipelines.HttpRequest Namespace


ItemResolver Methods

[image] [image]

Sitecore 6.4.1 API
ItemResolver Methods
ItemResolver Class See Also Send Feedback

The ItemResolver type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemResolver Class
Sitecore.Pipelines.HttpRequest Namespace


Process Method

[image]

Sitecore 6.4.1 API
ItemResolver..::..Process Method
ItemResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    HttpRequestArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As HttpRequestArgs _
)
Visual C++
public:
virtual void Process(
    HttpRequestArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.HttpRequest..::..HttpRequestArgs
The arguments.

See Also

ItemResolver Class
Sitecore.Pipelines.HttpRequest Namespace


LanguageResolver Class

[image]

Sitecore 6.4.1 API
LanguageResolver Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class LanguageResolver : HttpRequestProcessor
Visual Basic
Public Class LanguageResolver _
    Inherits HttpRequestProcessor
Visual C++
public ref class LanguageResolver : public HttpRequestProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.HttpRequest..::..HttpRequestProcessor
Sitecore.Pipelines.HttpRequest..::..LanguageResolver

See Also

LanguageResolver Members
Sitecore.Pipelines.HttpRequest Namespace


LanguageResolver Members

[image] [image]

Sitecore 6.4.1 API
LanguageResolver Members
LanguageResolver Class Constructors Methods See Also Send Feedback

The LanguageResolver type exposes the following members.

Constructors

 | Name | Description
Public method | LanguageResolver | Initializes a new instance of the LanguageResolver class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LanguageResolver Class
Sitecore.Pipelines.HttpRequest Namespace


LanguageResolver Constructor

[image]

Sitecore 6.4.1 API
LanguageResolver Constructor
LanguageResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LanguageResolver()
Visual Basic
Public Sub New
Visual C++
public:
LanguageResolver()

See Also

LanguageResolver Class
Sitecore.Pipelines.HttpRequest Namespace


LanguageResolver Methods

[image] [image]

Sitecore 6.4.1 API
LanguageResolver Methods
LanguageResolver Class See Also Send Feedback

The LanguageResolver type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LanguageResolver Class
Sitecore.Pipelines.HttpRequest Namespace


Process Method

[image]

Sitecore 6.4.1 API
LanguageResolver..::..Process Method
LanguageResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    HttpRequestArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As HttpRequestArgs _
)
Visual C++
public:
virtual void Process(
    HttpRequestArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.HttpRequest..::..HttpRequestArgs
The arguments.

See Also

LanguageResolver Class
Sitecore.Pipelines.HttpRequest Namespace


LayoutResolver Class

[image]

Sitecore 6.4.1 API
LayoutResolver Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class LayoutResolver : HttpRequestProcessor
Visual Basic
Public Class LayoutResolver _
    Inherits HttpRequestProcessor
Visual C++
public ref class LayoutResolver : public HttpRequestProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.HttpRequest..::..HttpRequestProcessor
Sitecore.Pipelines.HttpRequest..::..LayoutResolver

See Also

LayoutResolver Members
Sitecore.Pipelines.HttpRequest Namespace


LayoutResolver Members

[image] [image]

Sitecore 6.4.1 API
LayoutResolver Members
LayoutResolver Class Constructors Methods See Also Send Feedback

The LayoutResolver type exposes the following members.

Constructors

 | Name | Description
Public method | LayoutResolver | Initializes a new instance of the LayoutResolver class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LayoutResolver Class
Sitecore.Pipelines.HttpRequest Namespace


LayoutResolver Constructor

[image]

Sitecore 6.4.1 API
LayoutResolver Constructor
LayoutResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LayoutResolver()
Visual Basic
Public Sub New
Visual C++
public:
LayoutResolver()

See Also

LayoutResolver Class
Sitecore.Pipelines.HttpRequest Namespace


LayoutResolver Methods

[image] [image]

Sitecore 6.4.1 API
LayoutResolver Methods
LayoutResolver Class See Also Send Feedback

The LayoutResolver type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LayoutResolver Class
Sitecore.Pipelines.HttpRequest Namespace


Process Method

[image]

Sitecore 6.4.1 API
LayoutResolver..::..Process Method
LayoutResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    HttpRequestArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As HttpRequestArgs _
)
Visual C++
public:
virtual void Process(
    HttpRequestArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.HttpRequest..::..HttpRequestArgs
The arguments.

See Also

LayoutResolver Class
Sitecore.Pipelines.HttpRequest Namespace


QueryStringResolver Class

[image]

Sitecore 6.4.1 API
QueryStringResolver Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class QueryStringResolver : HttpRequestProcessor
Visual Basic
Public Class QueryStringResolver _
    Inherits HttpRequestProcessor
Visual C++
public ref class QueryStringResolver : public HttpRequestProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.HttpRequest..::..HttpRequestProcessor
Sitecore.Pipelines.HttpRequest..::..QueryStringResolver

See Also

QueryStringResolver Members
Sitecore.Pipelines.HttpRequest Namespace


QueryStringResolver Members

[image] [image]

Sitecore 6.4.1 API
QueryStringResolver Members
QueryStringResolver Class Constructors Methods See Also Send Feedback

The QueryStringResolver type exposes the following members.

Constructors

 | Name | Description
Public method | QueryStringResolver | Initializes a new instance of the QueryStringResolver class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

QueryStringResolver Class
Sitecore.Pipelines.HttpRequest Namespace


QueryStringResolver Constructor

[image]

Sitecore 6.4.1 API
QueryStringResolver Constructor
QueryStringResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public QueryStringResolver()
Visual Basic
Public Sub New
Visual C++
public:
QueryStringResolver()

See Also

QueryStringResolver Class
Sitecore.Pipelines.HttpRequest Namespace


QueryStringResolver Methods

[image] [image]

Sitecore 6.4.1 API
QueryStringResolver Methods
QueryStringResolver Class See Also Send Feedback

The QueryStringResolver type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

QueryStringResolver Class
Sitecore.Pipelines.HttpRequest Namespace


Process Method

[image]

Sitecore 6.4.1 API
QueryStringResolver..::..Process Method
QueryStringResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    HttpRequestArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As HttpRequestArgs _
)
Visual C++
public:
virtual void Process(
    HttpRequestArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.HttpRequest..::..HttpRequestArgs
The arguments.

See Also

QueryStringResolver Class
Sitecore.Pipelines.HttpRequest Namespace


ResizePicture Constructor

[image]

Sitecore 6.4.1 API
ResizePicture Constructor
ResizePicture Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ResizePicture()
Visual Basic
Public Sub New
Visual C++
public:
ResizePicture()

See Also

ResizePicture Class
Sitecore.Pipelines.HttpRequest Namespace


ResizePicture Methods

[image] [image]

Sitecore 6.4.1 API
ResizePicture Methods
ResizePicture Class See Also Send Feedback

The ResizePicture type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ResizePicture Class
Sitecore.Pipelines.HttpRequest Namespace


Process Method

[image]

Sitecore 6.4.1 API
ResizePicture..::..Process Method
ResizePicture Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    HttpRequestArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As HttpRequestArgs _
)
Visual C++
public:
virtual void Process(
    HttpRequestArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.HttpRequest..::..HttpRequestArgs
The arguments.

See Also

ResizePicture Class
Sitecore.Pipelines.HttpRequest Namespace


SaveFormAction Class

[image]

Sitecore 6.4.1 API
SaveFormAction Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SaveFormAction : HttpRequestProcessor
Visual Basic
Public Class SaveFormAction _
    Inherits HttpRequestProcessor
Visual C++
public ref class SaveFormAction : public HttpRequestProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.HttpRequest..::..HttpRequestProcessor
Sitecore.Pipelines.HttpRequest..::..SaveFormAction

See Also

SaveFormAction Members
Sitecore.Pipelines.HttpRequest Namespace


SaveFormAction Members

[image] [image]

Sitecore 6.4.1 API
SaveFormAction Members
SaveFormAction Class Constructors Methods See Also Send Feedback

The SaveFormAction type exposes the following members.

Constructors

 | Name | Description
Public method | SaveFormAction | Initializes a new instance of the SaveFormAction class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SaveFormAction Class
Sitecore.Pipelines.HttpRequest Namespace


SaveFormAction Constructor

[image]

Sitecore 6.4.1 API
SaveFormAction Constructor
SaveFormAction Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SaveFormAction()
Visual Basic
Public Sub New
Visual C++
public:
SaveFormAction()

See Also

SaveFormAction Class
Sitecore.Pipelines.HttpRequest Namespace


SaveFormAction Methods

[image] [image]

Sitecore 6.4.1 API
SaveFormAction Methods
SaveFormAction Class See Also Send Feedback

The SaveFormAction type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SaveFormAction Class
Sitecore.Pipelines.HttpRequest Namespace


Process Method

[image]

Sitecore 6.4.1 API
SaveFormAction..::..Process Method
SaveFormAction Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    HttpRequestArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As HttpRequestArgs _
)
Visual C++
public:
virtual void Process(
    HttpRequestArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.HttpRequest..::..HttpRequestArgs
The args.

See Also

SaveFormAction Class
Sitecore.Pipelines.HttpRequest Namespace


SiteResolver Class

[image]

Sitecore 6.4.1 API
SiteResolver Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SiteResolver : HttpRequestProcessor
Visual Basic
Public Class SiteResolver _
    Inherits HttpRequestProcessor
Visual C++
public ref class SiteResolver : public HttpRequestProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.HttpRequest..::..HttpRequestProcessor
Sitecore.Pipelines.HttpRequest..::..SiteResolver

See Also

SiteResolver Members
Sitecore.Pipelines.HttpRequest Namespace


SiteResolver Members

[image] [image]

Sitecore 6.4.1 API
SiteResolver Members
SiteResolver Class Constructors Methods See Also Send Feedback

The SiteResolver type exposes the following members.

Constructors

 | Name | Description
Public method | SiteResolver | Initializes a new instance of the SiteResolver class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetFilePath | Gets the file path.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetItemPath | Gets the item path.
Protected method | GetPath | Gets the path.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Protected method | ResolveSiteContext | Resolves the site context.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | UpdatePaths | Updates the paths.

See Also

SiteResolver Class
Sitecore.Pipelines.HttpRequest Namespace


SiteResolver Constructor

[image]

Sitecore 6.4.1 API
SiteResolver Constructor
SiteResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SiteResolver()
Visual Basic
Public Sub New
Visual C++
public:
SiteResolver()

See Also

SiteResolver Class
Sitecore.Pipelines.HttpRequest Namespace


SiteResolver Methods

[image] [image]

Sitecore 6.4.1 API
SiteResolver Methods
SiteResolver Class See Also Send Feedback

The SiteResolver type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetFilePath | Gets the file path.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetItemPath | Gets the item path.
Protected method | GetPath | Gets the path.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Protected method | ResolveSiteContext | Resolves the site context.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | UpdatePaths | Updates the paths.

See Also

SiteResolver Class
Sitecore.Pipelines.HttpRequest Namespace


GetFilePath Method

[image]

Sitecore 6.4.1 API
SiteResolver..::..GetFilePath Method
SiteResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected string GetFilePath(
    HttpRequestArgs args,
    SiteContext context
)
Visual Basic
Protected Function GetFilePath ( _
    args As HttpRequestArgs, _
    context As SiteContext _
) As String
Visual C++
protected:
String^ GetFilePath(
    HttpRequestArgs^ args,
    SiteContext^ context
)

Parameters

args
Type: Sitecore.Pipelines.HttpRequest..::..HttpRequestArgs
The args.
context
Type: Sitecore.Sites..::..SiteContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Pipelines.HttpRequest.SiteResolver.GetFilePath(Sitecore.Pipelines.HttpRequest.HttpRequestArgs,Sitecore.Sites.SiteContext)"]

See Also

SiteResolver Class
Sitecore.Pipelines.HttpRequest Namespace


GetPath Method

[image]

Sitecore 6.4.1 API
SiteResolver..::..GetPath Method
SiteResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected string GetPath(
    string basePath,
    string path,
    SiteContext context
)
Visual Basic
Protected Function GetPath ( _
    basePath As String, _
    path As String, _
    context As SiteContext _
) As String
Visual C++
protected:
String^ GetPath(
    String^ basePath,
    String^ path,
    SiteContext^ context
)

Parameters

basePath
Type: System..::..String
The base path.
path
Type: System..::..String
The path.
context
Type: Sitecore.Sites..::..SiteContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Pipelines.HttpRequest.SiteResolver.GetPath(System.String,System.String,Sitecore.Sites.SiteContext)"]

See Also

SiteResolver Class
Sitecore.Pipelines.HttpRequest Namespace


Process Method

[image]

Sitecore 6.4.1 API
SiteResolver..::..Process Method
SiteResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    HttpRequestArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As HttpRequestArgs _
)
Visual C++
public:
virtual void Process(
    HttpRequestArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.HttpRequest..::..HttpRequestArgs
The args.

See Also

SiteResolver Class
Sitecore.Pipelines.HttpRequest Namespace


ResolveSiteContext Method

[image]

Sitecore 6.4.1 API
SiteResolver..::..ResolveSiteContext Method
SiteResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual SiteContext ResolveSiteContext(
    HttpRequestArgs args
)
Visual Basic
Protected Overridable Function ResolveSiteContext ( _
    args As HttpRequestArgs _
) As SiteContext
Visual C++
protected:
virtual SiteContext^ ResolveSiteContext(
    HttpRequestArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.HttpRequest..::..HttpRequestArgs
The args.

Return Value

[Missing <returns> documentation for "M:Sitecore.Pipelines.HttpRequest.SiteResolver.ResolveSiteContext(Sitecore.Pipelines.HttpRequest.HttpRequestArgs)"]

See Also

SiteResolver Class
Sitecore.Pipelines.HttpRequest Namespace


UpdatePaths Method

[image]

Sitecore 6.4.1 API
SiteResolver..::..UpdatePaths Method
SiteResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void UpdatePaths(
    HttpRequestArgs args,
    SiteContext site
)
Visual Basic
Protected Overridable Sub UpdatePaths ( _
    args As HttpRequestArgs, _
    site As SiteContext _
)
Visual C++
protected:
virtual void UpdatePaths(
    HttpRequestArgs^ args,
    SiteContext^ site
)

Parameters

args
Type: Sitecore.Pipelines.HttpRequest..::..HttpRequestArgs
The args.
site
Type: Sitecore.Sites..::..SiteContext
The site.

See Also

SiteResolver Class
Sitecore.Pipelines.HttpRequest Namespace


StartMeasurements Members

[image] [image]

Sitecore 6.4.1 API
StartMeasurements Members
StartMeasurements Class Constructors Methods See Also Send Feedback

The StartMeasurements type exposes the following members.

Constructors

 | Name | Description
Public method | StartMeasurements | Initializes a new instance of the StartMeasurements class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Process method that starts the timer. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StartMeasurements Class
Sitecore.Pipelines.HttpRequest Namespace


StartMeasurements Constructor

[image]

Sitecore 6.4.1 API
StartMeasurements Constructor
StartMeasurements Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StartMeasurements()
Visual Basic
Public Sub New
Visual C++
public:
StartMeasurements()

See Also

StartMeasurements Class
Sitecore.Pipelines.HttpRequest Namespace


StartMeasurements Methods

[image] [image]

Sitecore 6.4.1 API
StartMeasurements Methods
StartMeasurements Class See Also Send Feedback

The StartMeasurements type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Process method that starts the timer. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StartMeasurements Class
Sitecore.Pipelines.HttpRequest Namespace


Process Method

[image]

Sitecore 6.4.1 API
StartMeasurements..::..Process Method
StartMeasurements Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    HttpRequestArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As HttpRequestArgs _
)
Visual C++
public:
virtual void Process(
    HttpRequestArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.HttpRequest..::..HttpRequestArgs
The args.

See Also

StartMeasurements Class
Sitecore.Pipelines.HttpRequest Namespace


StopMeasurements Members

[image] [image]

Sitecore 6.4.1 API
StopMeasurements Members
StopMeasurements Class Constructors Methods Properties See Also Send Feedback

The StopMeasurements type exposes the following members.

Constructors

 | Name | Description
Public method | StopMeasurements | Initializes a new instance of the StopMeasurements class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Process method that starts the timer. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ItemThreshold | Gets or sets the 'no. of items' threshold.
Public property | MemoryThreshold | Gets or sets the 'memory used' threshold.
Public property | ShowThresholdWarnings | Gets or sets a value indicating whether [show threshold warnings].
Public property | TimingThreshold | Gets or sets the timing threshold.

See Also

StopMeasurements Class
Sitecore.Pipelines.HttpRequest Namespace


StopMeasurements Constructor

[image]

Sitecore 6.4.1 API
StopMeasurements Constructor
StopMeasurements Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StopMeasurements()
Visual Basic
Public Sub New
Visual C++
public:
StopMeasurements()

See Also

StopMeasurements Class
Sitecore.Pipelines.HttpRequest Namespace


StopMeasurements Methods

[image] [image]

Sitecore 6.4.1 API
StopMeasurements Methods
StopMeasurements Class See Also Send Feedback

The StopMeasurements type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Process method that starts the timer. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StopMeasurements Class
Sitecore.Pipelines.HttpRequest Namespace


Process Method

[image]

Sitecore 6.4.1 API
StopMeasurements..::..Process Method
StopMeasurements Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    HttpRequestArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As HttpRequestArgs _
)
Visual C++
public:
virtual void Process(
    HttpRequestArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.HttpRequest..::..HttpRequestArgs
The args.

See Also

StopMeasurements Class
Sitecore.Pipelines.HttpRequest Namespace


StopMeasurements Properties

[image] [image]

Sitecore 6.4.1 API
StopMeasurements Properties
StopMeasurements Class See Also Send Feedback

The StopMeasurements type exposes the following members.

Properties

 | Name | Description
Public property | ItemThreshold | Gets or sets the 'no. of items' threshold.
Public property | MemoryThreshold | Gets or sets the 'memory used' threshold.
Public property | ShowThresholdWarnings | Gets or sets a value indicating whether [show threshold warnings].
Public property | TimingThreshold | Gets or sets the timing threshold.

See Also

StopMeasurements Class
Sitecore.Pipelines.HttpRequest Namespace


ItemThreshold Property

[image]

Sitecore 6.4.1 API
StopMeasurements..::..ItemThreshold Property
StopMeasurements Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long ItemThreshold { get; set; }
Visual Basic
Public Property ItemThreshold As Long
    Get
    Set
Visual C++
public:
property long long ItemThreshold {
    long long get ();
    void set (long long value);
}

Field Value

The 'no. of items' threshold.

See Also

StopMeasurements Class
Sitecore.Pipelines.HttpRequest Namespace


MemoryThreshold Property

[image]

Sitecore 6.4.1 API
StopMeasurements..::..MemoryThreshold Property
StopMeasurements Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long MemoryThreshold { get; set; }
Visual Basic
Public Property MemoryThreshold As Long
    Get
    Set
Visual C++
public:
property long long MemoryThreshold {
    long long get ();
    void set (long long value);
}

Field Value

The 'memory used' threshold.

See Also

StopMeasurements Class
Sitecore.Pipelines.HttpRequest Namespace


ShowThresholdWarnings Property

[image]

Sitecore 6.4.1 API
StopMeasurements..::..ShowThresholdWarnings Property
StopMeasurements Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ShowThresholdWarnings { get; set; }
Visual Basic
Public Property ShowThresholdWarnings As Boolean
    Get
    Set
Visual C++
public:
property bool ShowThresholdWarnings {
    bool get ();
    void set (bool value);
}

Field Value

true if [show threshold warnings]; otherwise, false.

See Also

StopMeasurements Class
Sitecore.Pipelines.HttpRequest Namespace


TimingThreshold Property

[image]

Sitecore 6.4.1 API
StopMeasurements..::..TimingThreshold Property
StopMeasurements Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long TimingThreshold { get; set; }
Visual Basic
Public Property TimingThreshold As Long
    Get
    Set
Visual C++
public:
property long long TimingThreshold {
    long long get ();
    void set (long long value);
}

Field Value

The timing threshold.

See Also

StopMeasurements Class
Sitecore.Pipelines.HttpRequest Namespace


UserResolver Class

[image]

Sitecore 6.4.1 API
UserResolver Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class UserResolver : HttpRequestProcessor
Visual Basic
Public Class UserResolver _
    Inherits HttpRequestProcessor
Visual C++
public ref class UserResolver : public HttpRequestProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.HttpRequest..::..HttpRequestProcessor
Sitecore.Pipelines.HttpRequest..::..UserResolver

See Also

UserResolver Members
Sitecore.Pipelines.HttpRequest Namespace


UserResolver Members

[image] [image]

Sitecore 6.4.1 API
UserResolver Members
UserResolver Class Constructors Methods See Also Send Feedback

The UserResolver type exposes the following members.

Constructors

 | Name | Description
Public method | UserResolver | Initializes a new instance of the UserResolver class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UserResolver Class
Sitecore.Pipelines.HttpRequest Namespace


UserResolver Constructor

[image]

Sitecore 6.4.1 API
UserResolver Constructor
UserResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UserResolver()
Visual Basic
Public Sub New
Visual C++
public:
UserResolver()

See Also

UserResolver Class
Sitecore.Pipelines.HttpRequest Namespace


UserResolver Methods

[image] [image]

Sitecore 6.4.1 API
UserResolver Methods
UserResolver Class See Also Send Feedback

The UserResolver type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides HttpRequestProcessor..::..Process(HttpRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UserResolver Class
Sitecore.Pipelines.HttpRequest Namespace


Process Method

[image]

Sitecore 6.4.1 API
UserResolver..::..Process Method
UserResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.HttpRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    HttpRequestArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As HttpRequestArgs _
)
Visual C++
public:
virtual void Process(
    HttpRequestArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.HttpRequest..::..HttpRequestArgs
The arguments.

See Also

UserResolver Class
Sitecore.Pipelines.HttpRequest Namespace


Sitecore.Pipelines.InsertRenderings Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.InsertRenderings Namespace
Send Feedback

Classes

 | Class | Description
Public class | InsertRenderingsArgs | Argument class for IRenderLayoutProcessor implementations.
Public class | InsertRenderingsProcessor | Defines the insert renderings processor class.


InsertRenderingsArgs Class

[image]

Sitecore 6.4.1 API
InsertRenderingsArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.InsertRenderings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class InsertRenderingsArgs : PipelineArgs
Visual Basic
<SerializableAttribute> _
Public Class InsertRenderingsArgs _
    Inherits PipelineArgs
Visual C++
[SerializableAttribute]
public ref class InsertRenderingsArgs : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Pipelines.InsertRenderings..::..InsertRenderingsArgs

See Also

InsertRenderingsArgs Members
Sitecore.Pipelines.InsertRenderings Namespace


InsertRenderingsArgs Members

[image] [image]

Sitecore 6.4.1 API
InsertRenderingsArgs Members
InsertRenderingsArgs Class Constructors Methods Properties See Also Send Feedback

The InsertRenderingsArgs type exposes the following members.

Constructors

 | Name | Description
Public method | InsertRenderingsArgs()()()() | Initializes a new instance of the InsertRenderingsArgs class.
Protected method | InsertRenderingsArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the InsertRenderingsArgs class. Initializes a new instance of the RenderLayoutArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | ContextItem | Gets or sets the context item.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | EvaluateConditions | Gets or sets a value indicating whether [evaluate conditions].
Public property | HasRenderings | Gets or sets a value indicating whether [add renderings].
Public property | IsDesigning | Gets or sets a value indicating whether this instance is designing.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Renderings | Gets the renderings.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

InsertRenderingsArgs Class
Sitecore.Pipelines.InsertRenderings Namespace


InsertRenderingsArgs Constructor

[image] [image]

Sitecore 6.4.1 API
InsertRenderingsArgs Constructor
InsertRenderingsArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertRenderingsArgs()()()() | Initializes a new instance of the InsertRenderingsArgs class.
Protected method | InsertRenderingsArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the InsertRenderingsArgs class. Initializes a new instance of the RenderLayoutArgs class.

See Also

InsertRenderingsArgs Class
InsertRenderingsArgs Members
Sitecore.Pipelines.InsertRenderings Namespace


InsertRenderingsArgs Constructor

[image]

Sitecore 6.4.1 API
InsertRenderingsArgs Constructor
InsertRenderingsArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.InsertRenderings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public InsertRenderingsArgs()
Visual Basic
Public Sub New
Visual C++
public:
InsertRenderingsArgs()

See Also

InsertRenderingsArgs Class
InsertRenderingsArgs Overload
Sitecore.Pipelines.InsertRenderings Namespace


InsertRenderingsArgs Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
InsertRenderingsArgs Constructor (SerializationInfo, StreamingContext)
InsertRenderingsArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.InsertRenderings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected InsertRenderingsArgs(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
InsertRenderingsArgs(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

InsertRenderingsArgs Class
InsertRenderingsArgs Overload
Sitecore.Pipelines.InsertRenderings Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
InsertRenderingsArgs..::..AddMessage Method
InsertRenderingsArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

InsertRenderingsArgs Class
InsertRenderingsArgs Members
Sitecore.Pipelines.InsertRenderings Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
InsertRenderingsArgs..::..GetMessages Method
InsertRenderingsArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

InsertRenderingsArgs Class
InsertRenderingsArgs Members
Sitecore.Pipelines.InsertRenderings Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
InsertRenderingsArgs..::..Suspend Method
InsertRenderingsArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

InsertRenderingsArgs Class
InsertRenderingsArgs Members
Sitecore.Pipelines.InsertRenderings Namespace


InsertRenderingsArgs Properties

[image] [image]

Sitecore 6.4.1 API
InsertRenderingsArgs Properties
InsertRenderingsArgs Class See Also Send Feedback

The InsertRenderingsArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | ContextItem | Gets or sets the context item.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | EvaluateConditions | Gets or sets a value indicating whether [evaluate conditions].
Public property | HasRenderings | Gets or sets a value indicating whether [add renderings].
Public property | IsDesigning | Gets or sets a value indicating whether this instance is designing.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Renderings | Gets the renderings.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

InsertRenderingsArgs Class
Sitecore.Pipelines.InsertRenderings Namespace


ContextItem Property

[image]

Sitecore 6.4.1 API
InsertRenderingsArgs..::..ContextItem Property
InsertRenderingsArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.InsertRenderings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item ContextItem { get; set; }
Visual Basic
Public Property ContextItem As Item
    Get
    Set
Visual C++
public:
property Item^ ContextItem {
    Item^ get ();
    void set (Item^ value);
}

Field Value

The context item.

See Also

InsertRenderingsArgs Class
Sitecore.Pipelines.InsertRenderings Namespace


EvaluateConditions Property

[image]

Sitecore 6.4.1 API
InsertRenderingsArgs..::..EvaluateConditions Property
InsertRenderingsArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.InsertRenderings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool EvaluateConditions { get; set; }
Visual Basic
Public Property EvaluateConditions As Boolean
    Get
    Set
Visual C++
public:
property bool EvaluateConditions {
    bool get ();
    void set (bool value);
}

Field Value

true if [evaluate conditions]; otherwise, false.

See Also

InsertRenderingsArgs Class
Sitecore.Pipelines.InsertRenderings Namespace


HasRenderings Property

[image]

Sitecore 6.4.1 API
InsertRenderingsArgs..::..HasRenderings Property
InsertRenderingsArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.InsertRenderings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool HasRenderings { get; set; }
Visual Basic
Public Property HasRenderings As Boolean
    Get
    Set
Visual C++
public:
property bool HasRenderings {
    bool get ();
    void set (bool value);
}

Field Value

true if [add renderings]; otherwise, false.

See Also

InsertRenderingsArgs Class
Sitecore.Pipelines.InsertRenderings Namespace


IsDesigning Property

[image]

Sitecore 6.4.1 API
InsertRenderingsArgs..::..IsDesigning Property
InsertRenderingsArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.InsertRenderings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsDesigning { get; set; }
Visual Basic
Public Property IsDesigning As Boolean
    Get
    Set
Visual C++
public:
property bool IsDesigning {
    bool get ();
    void set (bool value);
}

Field Value

true if this instance is designing; otherwise, false.

See Also

InsertRenderingsArgs Class
Sitecore.Pipelines.InsertRenderings Namespace


Renderings Property

[image]

Sitecore 6.4.1 API
InsertRenderingsArgs..::..Renderings Property
InsertRenderingsArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.InsertRenderings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public List<RenderingReference> Renderings { get; private set; }
Visual Basic
Public Property Renderings As List(Of RenderingReference)
    Get
    Private Set
Visual C++
public:
property List<RenderingReference^>^ Renderings {
    List<RenderingReference^>^ get ();
    private: void set (List<RenderingReference^>^ value);
}

Field Value

The renderings.

See Also

InsertRenderingsArgs Class
Sitecore.Pipelines.InsertRenderings Namespace


InsertRenderingsProcessor Class

[image]

Sitecore 6.4.1 API
InsertRenderingsProcessor Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.InsertRenderings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class InsertRenderingsProcessor
Visual Basic
Public MustInherit Class InsertRenderingsProcessor
Visual C++
public ref class InsertRenderingsProcessor abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.InsertRenderings..::..InsertRenderingsProcessor
Sitecore.Pipelines.InsertRenderings.Processors..::..AddPageDesignerRenderings
Sitecore.Pipelines.InsertRenderings.Processors..::..AddRenderings
Sitecore.Pipelines.InsertRenderings.Processors..::..EvaluateConditions
Sitecore.Pipelines.InsertRenderings.Processors..::..GetItem

See Also

InsertRenderingsProcessor Members
Sitecore.Pipelines.InsertRenderings Namespace


InsertRenderingsProcessor Members

[image] [image]

Sitecore 6.4.1 API
InsertRenderingsProcessor Members
InsertRenderingsProcessor Class Constructors Methods See Also Send Feedback

The InsertRenderingsProcessor type exposes the following members.

Constructors

 | Name | Description
Protected method | InsertRenderingsProcessor | Initializes a new instance of the InsertRenderingsProcessor class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InsertRenderingsProcessor Class
Sitecore.Pipelines.InsertRenderings Namespace


InsertRenderingsProcessor Constructor

[image]

Sitecore 6.4.1 API
InsertRenderingsProcessor Constructor
InsertRenderingsProcessor Class See Also Send Feedback

Namespace: Sitecore.Pipelines.InsertRenderings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected InsertRenderingsProcessor()
Visual Basic
Protected Sub New
Visual C++
protected:
InsertRenderingsProcessor()

See Also

InsertRenderingsProcessor Class
Sitecore.Pipelines.InsertRenderings Namespace


InsertRenderingsProcessor Methods

[image] [image]

Sitecore 6.4.1 API
InsertRenderingsProcessor Methods
InsertRenderingsProcessor Class See Also Send Feedback

The InsertRenderingsProcessor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InsertRenderingsProcessor Class
Sitecore.Pipelines.InsertRenderings Namespace


Process Method

[image]

Sitecore 6.4.1 API
InsertRenderingsProcessor..::..Process Method
InsertRenderingsProcessor Class See Also Send Feedback

Namespace: Sitecore.Pipelines.InsertRenderings
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract void Process(
    InsertRenderingsArgs args
)
Visual Basic
Public MustOverride Sub Process ( _
    args As InsertRenderingsArgs _
)
Visual C++
public:
virtual void Process(
    InsertRenderingsArgs^ args
) abstract

Parameters

args
Type: Sitecore.Pipelines.InsertRenderings..::..InsertRenderingsArgs
The argumentss.

See Also

InsertRenderingsProcessor Class
Sitecore.Pipelines.InsertRenderings Namespace


Sitecore.Pipelines.InsertRenderings.Processors Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.InsertRenderings.Processors Namespace
Send Feedback

Classes

 | Class | Description
Public class | AddPageDesignerRenderings | Defines the get item class.
Public class | AddRenderings | Defines the get item class.
Public class | EvaluateConditions | Defines the get item class.
Public class | GetItem | Defines the get item class.


AddPageDesignerRenderings Class

[image]

Sitecore 6.4.1 API
AddPageDesignerRenderings Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.InsertRenderings.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class AddPageDesignerRenderings : InsertRenderingsProcessor
Visual Basic
Public Class AddPageDesignerRenderings _
    Inherits InsertRenderingsProcessor
Visual C++
public ref class AddPageDesignerRenderings : public InsertRenderingsProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.InsertRenderings..::..InsertRenderingsProcessor
Sitecore.Pipelines.InsertRenderings.Processors..::..AddPageDesignerRenderings

See Also

AddPageDesignerRenderings Members
Sitecore.Pipelines.InsertRenderings.Processors Namespace


AddPageDesignerRenderings Members

[image] [image]

Sitecore 6.4.1 API
AddPageDesignerRenderings Members
AddPageDesignerRenderings Class Constructors Methods See Also Send Feedback

The AddPageDesignerRenderings type exposes the following members.

Constructors

 | Name | Description
Public method | AddPageDesignerRenderings | Initializes a new instance of the AddPageDesignerRenderings class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRenderings | Gets the renderings.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides InsertRenderingsProcessor..::..Process(InsertRenderingsArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddPageDesignerRenderings Class
Sitecore.Pipelines.InsertRenderings.Processors Namespace


AddPageDesignerRenderings Constructor

[image]

Sitecore 6.4.1 API
AddPageDesignerRenderings Constructor
AddPageDesignerRenderings Class See Also Send Feedback

Namespace: Sitecore.Pipelines.InsertRenderings.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AddPageDesignerRenderings()
Visual Basic
Public Sub New
Visual C++
public:
AddPageDesignerRenderings()

See Also

AddPageDesignerRenderings Class
Sitecore.Pipelines.InsertRenderings.Processors Namespace


AddPageDesignerRenderings Methods

[image] [image]

Sitecore 6.4.1 API
AddPageDesignerRenderings Methods
AddPageDesignerRenderings Class See Also Send Feedback

The AddPageDesignerRenderings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRenderings | Gets the renderings.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides InsertRenderingsProcessor..::..Process(InsertRenderingsArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddPageDesignerRenderings Class
Sitecore.Pipelines.InsertRenderings.Processors Namespace


GetRenderings Method

[image]

Sitecore 6.4.1 API
AddPageDesignerRenderings..::..GetRenderings Method
AddPageDesignerRenderings Class See Also Send Feedback

Namespace: Sitecore.Pipelines.InsertRenderings.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool GetRenderings(
    InsertRenderingsArgs args
)
Visual Basic
Protected Overridable Function GetRenderings ( _
    args As InsertRenderingsArgs _
) As Boolean
Visual C++
protected:
virtual bool GetRenderings(
    InsertRenderingsArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.InsertRenderings..::..InsertRenderingsArgs
The args.

Return Value

Returns the renderings.

See Also

AddPageDesignerRenderings Class
Sitecore.Pipelines.InsertRenderings.Processors Namespace


Process Method

[image]

Sitecore 6.4.1 API
AddPageDesignerRenderings..::..Process Method
AddPageDesignerRenderings Class See Also Send Feedback

Namespace: Sitecore.Pipelines.InsertRenderings.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    InsertRenderingsArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As InsertRenderingsArgs _
)
Visual C++
public:
virtual void Process(
    InsertRenderingsArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.InsertRenderings..::..InsertRenderingsArgs
The argumentss.

See Also

AddPageDesignerRenderings Class
Sitecore.Pipelines.InsertRenderings.Processors Namespace


AddRenderings Class

[image]

Sitecore 6.4.1 API
AddRenderings Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.InsertRenderings.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class AddRenderings : InsertRenderingsProcessor
Visual Basic
Public Class AddRenderings _
    Inherits InsertRenderingsProcessor
Visual C++
public ref class AddRenderings : public InsertRenderingsProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.InsertRenderings..::..InsertRenderingsProcessor
Sitecore.Pipelines.InsertRenderings.Processors..::..AddRenderings

See Also

AddRenderings Members
Sitecore.Pipelines.InsertRenderings.Processors Namespace


AddRenderings Members

[image] [image]

Sitecore 6.4.1 API
AddRenderings Members
AddRenderings Class Constructors Methods See Also Send Feedback

The AddRenderings type exposes the following members.

Constructors

 | Name | Description
Public method | AddRenderings | Initializes a new instance of the AddRenderings class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides InsertRenderingsProcessor..::..Process(InsertRenderingsArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddRenderings Class
Sitecore.Pipelines.InsertRenderings.Processors Namespace


AddRenderings Constructor

[image]

Sitecore 6.4.1 API
AddRenderings Constructor
AddRenderings Class See Also Send Feedback

Namespace: Sitecore.Pipelines.InsertRenderings.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AddRenderings()
Visual Basic
Public Sub New
Visual C++
public:
AddRenderings()

See Also

AddRenderings Class
Sitecore.Pipelines.InsertRenderings.Processors Namespace


AddRenderings Methods

[image] [image]

Sitecore 6.4.1 API
AddRenderings Methods
AddRenderings Class See Also Send Feedback

The AddRenderings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides InsertRenderingsProcessor..::..Process(InsertRenderingsArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddRenderings Class
Sitecore.Pipelines.InsertRenderings.Processors Namespace


Process Method

[image]

Sitecore 6.4.1 API
AddRenderings..::..Process Method
AddRenderings Class See Also Send Feedback

Namespace: Sitecore.Pipelines.InsertRenderings.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    InsertRenderingsArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As InsertRenderingsArgs _
)
Visual C++
public:
virtual void Process(
    InsertRenderingsArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.InsertRenderings..::..InsertRenderingsArgs
The argumentss.

See Also

AddRenderings Class
Sitecore.Pipelines.InsertRenderings.Processors Namespace


EvaluateConditions Class

[image]

Sitecore 6.4.1 API
EvaluateConditions Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.InsertRenderings.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class EvaluateConditions : InsertRenderingsProcessor
Visual Basic
Public Class EvaluateConditions _
    Inherits InsertRenderingsProcessor
Visual C++
public ref class EvaluateConditions : public InsertRenderingsProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.InsertRenderings..::..InsertRenderingsProcessor
Sitecore.Pipelines.InsertRenderings.Processors..::..EvaluateConditions

See Also

EvaluateConditions Members
Sitecore.Pipelines.InsertRenderings.Processors Namespace


EvaluateConditions Members

[image] [image]

Sitecore 6.4.1 API
EvaluateConditions Members
EvaluateConditions Class Constructors Methods See Also Send Feedback

The EvaluateConditions type exposes the following members.

Constructors

 | Name | Description
Public method | EvaluateConditions | Initializes a new instance of the EvaluateConditions class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | Evaluates the specified args.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConditionItems | Gets the condition items.
Protected method | GetGlobalRules | Gets the global rule set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides InsertRenderingsProcessor..::..Process(InsertRenderingsArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EvaluateConditions Class
Sitecore.Pipelines.InsertRenderings.Processors Namespace


EvaluateConditions Constructor

[image]

Sitecore 6.4.1 API
EvaluateConditions Constructor
EvaluateConditions Class See Also Send Feedback

Namespace: Sitecore.Pipelines.InsertRenderings.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public EvaluateConditions()
Visual Basic
Public Sub New
Visual C++
public:
EvaluateConditions()

See Also

EvaluateConditions Class
Sitecore.Pipelines.InsertRenderings.Processors Namespace


EvaluateConditions Methods

[image] [image]

Sitecore 6.4.1 API
EvaluateConditions Methods
EvaluateConditions Class See Also Send Feedback

The EvaluateConditions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | Evaluates the specified args.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConditionItems | Gets the condition items.
Protected method | GetGlobalRules | Gets the global rule set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides InsertRenderingsProcessor..::..Process(InsertRenderingsArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EvaluateConditions Class
Sitecore.Pipelines.InsertRenderings.Processors Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
EvaluateConditions..::..Evaluate Method
EvaluateConditions Class See Also Send Feedback

Namespace: Sitecore.Pipelines.InsertRenderings.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void Evaluate(
    InsertRenderingsArgs args,
    Item item
)
Visual Basic
Protected Overridable Sub Evaluate ( _
    args As InsertRenderingsArgs, _
    item As Item _
)
Visual C++
protected:
virtual void Evaluate(
    InsertRenderingsArgs^ args,
    Item^ item
)

Parameters

args
Type: Sitecore.Pipelines.InsertRenderings..::..InsertRenderingsArgs
The args.
item
Type: Sitecore.Data.Items..::..Item
The item.

See Also

EvaluateConditions Class
Sitecore.Pipelines.InsertRenderings.Processors Namespace


GetConditionItems Method

[image]

Sitecore 6.4.1 API
EvaluateConditions..::..GetConditionItems Method
EvaluateConditions Class See Also Send Feedback

Namespace: Sitecore.Pipelines.InsertRenderings.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual List<Item> GetConditionItems(
    Database database,
    string conditions
)
Visual Basic
Protected Overridable Function GetConditionItems ( _
    database As Database, _
    conditions As String _
) As List(Of Item)
Visual C++
protected:
virtual List<Item^>^ GetConditionItems(
    Database^ database,
    String^ conditions
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.
conditions
Type: System..::..String
The conditions.

Return Value

The condition items.

See Also

EvaluateConditions Class
Sitecore.Pipelines.InsertRenderings.Processors Namespace


GetGlobalRules Method

[image]

Sitecore 6.4.1 API
EvaluateConditions..::..GetGlobalRules Method
EvaluateConditions Class See Also Send Feedback

Namespace: Sitecore.Pipelines.InsertRenderings.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual RuleList<ConditionalRenderingsRuleContext> GetGlobalRules(
    Item item
)
Visual Basic
Protected Overridable Function GetGlobalRules ( _
    item As Item _
) As RuleList(Of ConditionalRenderingsRuleContext)
Visual C++
protected:
virtual RuleList<ConditionalRenderingsRuleContext^>^ GetGlobalRules(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The source item.

Return Value

The global rule set.

See Also

EvaluateConditions Class
Sitecore.Pipelines.InsertRenderings.Processors Namespace


Process Method

[image]

Sitecore 6.4.1 API
EvaluateConditions..::..Process Method
EvaluateConditions Class See Also Send Feedback

Namespace: Sitecore.Pipelines.InsertRenderings.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    InsertRenderingsArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As InsertRenderingsArgs _
)
Visual C++
public:
virtual void Process(
    InsertRenderingsArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.InsertRenderings..::..InsertRenderingsArgs
The argumentss.

See Also

EvaluateConditions Class
Sitecore.Pipelines.InsertRenderings.Processors Namespace


GetItem Class

[image]

Sitecore 6.4.1 API
GetItem Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.InsertRenderings.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetItem : InsertRenderingsProcessor
Visual Basic
Public Class GetItem _
    Inherits InsertRenderingsProcessor
Visual C++
public ref class GetItem : public InsertRenderingsProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.InsertRenderings..::..InsertRenderingsProcessor
Sitecore.Pipelines.InsertRenderings.Processors..::..GetItem

See Also

GetItem Members
Sitecore.Pipelines.InsertRenderings.Processors Namespace


GetItem Members

[image] [image]

Sitecore 6.4.1 API
GetItem Members
GetItem Class Constructors Methods See Also Send Feedback

The GetItem type exposes the following members.

Constructors

 | Name | Description
Public method | GetItem | Initializes a new instance of the GetItem class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides InsertRenderingsProcessor..::..Process(InsertRenderingsArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetItem Class
Sitecore.Pipelines.InsertRenderings.Processors Namespace


GetItem Constructor

[image]

Sitecore 6.4.1 API
GetItem Constructor
GetItem Class See Also Send Feedback

Namespace: Sitecore.Pipelines.InsertRenderings.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetItem()
Visual Basic
Public Sub New
Visual C++
public:
GetItem()

See Also

GetItem Class
Sitecore.Pipelines.InsertRenderings.Processors Namespace


GetItem Methods

[image] [image]

Sitecore 6.4.1 API
GetItem Methods
GetItem Class See Also Send Feedback

The GetItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides InsertRenderingsProcessor..::..Process(InsertRenderingsArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetItem Class
Sitecore.Pipelines.InsertRenderings.Processors Namespace


Process Method

[image]

Sitecore 6.4.1 API
GetItem..::..Process Method
GetItem Class See Also Send Feedback

Namespace: Sitecore.Pipelines.InsertRenderings.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    InsertRenderingsArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As InsertRenderingsArgs _
)
Visual C++
public:
virtual void Process(
    InsertRenderingsArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.InsertRenderings..::..InsertRenderingsArgs
The argumentss.

See Also

GetItem Class
Sitecore.Pipelines.InsertRenderings.Processors Namespace


Sitecore.Pipelines.Loader Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.Loader Namespace
Send Feedback

Classes

 | Class | Description
Public class | CheckWebDAVConfiguration | Checks the WebDAV configuration.
Public class | EnsureAnonymousUsers | EnsureAnonymousUsers class
Public class | InitializeAgilityPack | Initializes the html agility pack, setting the default settings.
Public class | InitializeHeartbeat | Initializes the heartbeat.
Public class | InitializeManagers | Processor used for initializing static manager classes.
Public class | InitializeScheduler | Initializes the scheduler.
Public class | Loader | Sitecore loader.
Public class | LoadHooks | Loads hooks.
Public class | SetGlobals | Loads the global settings.
Public class | ShowHistory | Shows the history in the log file.
Public class | ShowVersion | Shows the version in the log file.


CheckWebDAVConfiguration Class

[image]

Sitecore 6.4.1 API
CheckWebDAVConfiguration Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Loader
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CheckWebDAVConfiguration
Visual Basic
Public Class CheckWebDAVConfiguration
Visual C++
public ref class CheckWebDAVConfiguration

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Loader..::..CheckWebDAVConfiguration

See Also

CheckWebDAVConfiguration Members
Sitecore.Pipelines.Loader Namespace


CheckWebDAVConfiguration Members

[image] [image]

Sitecore 6.4.1 API
CheckWebDAVConfiguration Members
CheckWebDAVConfiguration Class Constructors Methods See Also Send Feedback

The CheckWebDAVConfiguration type exposes the following members.

Constructors

 | Name | Description
Public method | CheckWebDAVConfiguration | Initializes a new instance of the CheckWebDAVConfiguration class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetWebDAVFolder | Gets the web DAV folder.
Protected method | GetWebsiteRoot | Gets the website root.
Protected method | HasWebDAVMapping | Determines whether specified IIS directory has web DAV mapping.
Protected method | IsIISConfigured | Determines whether IIS is configured for WebDAV feature.
Protected method | IsWebDAVFolderExists | Determines whether WebDAV folder exists.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckWebDAVConfiguration Class
Sitecore.Pipelines.Loader Namespace


CheckWebDAVConfiguration Constructor

[image]

Sitecore 6.4.1 API
CheckWebDAVConfiguration Constructor
CheckWebDAVConfiguration Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Loader
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CheckWebDAVConfiguration()
Visual Basic
Public Sub New
Visual C++
public:
CheckWebDAVConfiguration()

See Also

CheckWebDAVConfiguration Class
Sitecore.Pipelines.Loader Namespace


CheckWebDAVConfiguration Methods

[image] [image]

Sitecore 6.4.1 API
CheckWebDAVConfiguration Methods
CheckWebDAVConfiguration Class See Also Send Feedback

The CheckWebDAVConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetWebDAVFolder | Gets the web DAV folder.
Protected method | GetWebsiteRoot | Gets the website root.
Protected method | HasWebDAVMapping | Determines whether specified IIS directory has web DAV mapping.
Protected method | IsIISConfigured | Determines whether IIS is configured for WebDAV feature.
Protected method | IsWebDAVFolderExists | Determines whether WebDAV folder exists.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckWebDAVConfiguration Class
Sitecore.Pipelines.Loader Namespace


GetWebsiteRoot Method

[image]

Sitecore 6.4.1 API
CheckWebDAVConfiguration..::..GetWebsiteRoot Method
CheckWebDAVConfiguration Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Loader
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected DirectoryEntry GetWebsiteRoot()
Visual Basic
Protected Function GetWebsiteRoot As DirectoryEntry
Visual C++
protected:
DirectoryEntry^ GetWebsiteRoot()

Return Value

The Web Site root.

See Also

CheckWebDAVConfiguration Class
Sitecore.Pipelines.Loader Namespace


HasWebDAVMapping Method

[image]

Sitecore 6.4.1 API
CheckWebDAVConfiguration..::..HasWebDAVMapping Method
CheckWebDAVConfiguration Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Loader
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected bool HasWebDAVMapping(
    DirectoryEntry entry,
    string[] verbs
)
Visual Basic
Protected Function HasWebDAVMapping ( _
    entry As DirectoryEntry, _
    verbs As String() _
) As Boolean
Visual C++
protected:
bool HasWebDAVMapping(
    DirectoryEntry^ entry,
    array<String^>^ verbs
)

Parameters

entry
Type: System.DirectoryServices..::..DirectoryEntry
The IIS directory entry.
verbs
Type: array< System..::..String >[]()[][]
The verbs.

Return Value

true if specified IIS directory has web DAV mapping; otherwise, false.

See Also

CheckWebDAVConfiguration Class
Sitecore.Pipelines.Loader Namespace


IsIISConfigured Method

[image]

Sitecore 6.4.1 API
CheckWebDAVConfiguration..::..IsIISConfigured Method
CheckWebDAVConfiguration Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Loader
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected bool IsIISConfigured()
Visual Basic
Protected Function IsIISConfigured As Boolean
Visual C++
protected:
bool IsIISConfigured()

Return Value

true if IIS is configured correctly for WebDAV feature; otherwise, false.

See Also

CheckWebDAVConfiguration Class
Sitecore.Pipelines.Loader Namespace


Process Method

[image]

Sitecore 6.4.1 API
CheckWebDAVConfiguration..::..Process Method
CheckWebDAVConfiguration Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Loader
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    PipelineArgs args
)
Visual Basic
Public Sub Process ( _
    args As PipelineArgs _
)
Visual C++
public:
void Process(
    PipelineArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines..::..PipelineArgs
The arguments.

See Also

CheckWebDAVConfiguration Class
Sitecore.Pipelines.Loader Namespace


EnsureAnonymousUsers Class

[image]

Sitecore 6.4.1 API
EnsureAnonymousUsers Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Loader
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class EnsureAnonymousUsers
Visual Basic
Public Class EnsureAnonymousUsers
Visual C++
public ref class EnsureAnonymousUsers

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Loader..::..EnsureAnonymousUsers

See Also

EnsureAnonymousUsers Members
Sitecore.Pipelines.Loader Namespace


EnsureAnonymousUsers Members

[image] [image]

Sitecore 6.4.1 API
EnsureAnonymousUsers Members
EnsureAnonymousUsers Class Constructors Methods See Also Send Feedback

The EnsureAnonymousUsers type exposes the following members.

Constructors

 | Name | Description
Public method | EnsureAnonymousUsers | Initializes a new instance of the EnsureAnonymousUsers class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EnsureAnonymousUsers Class
Sitecore.Pipelines.Loader Namespace


EnsureAnonymousUsers Constructor

[image]

Sitecore 6.4.1 API
EnsureAnonymousUsers Constructor
EnsureAnonymousUsers Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Loader
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public EnsureAnonymousUsers()
Visual Basic
Public Sub New
Visual C++
public:
EnsureAnonymousUsers()

See Also

EnsureAnonymousUsers Class
Sitecore.Pipelines.Loader Namespace


EnsureAnonymousUsers Methods

[image] [image]

Sitecore 6.4.1 API
EnsureAnonymousUsers Methods
EnsureAnonymousUsers Class See Also Send Feedback

The EnsureAnonymousUsers type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EnsureAnonymousUsers Class
Sitecore.Pipelines.Loader Namespace


Process Method

[image]

Sitecore 6.4.1 API
EnsureAnonymousUsers..::..Process Method
EnsureAnonymousUsers Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Loader
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    PipelineArgs args
)
Visual Basic
Public Sub Process ( _
    args As PipelineArgs _
)
Visual C++
public:
void Process(
    PipelineArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines..::..PipelineArgs
The arguments.

See Also

EnsureAnonymousUsers Class
Sitecore.Pipelines.Loader Namespace


InitializeAgilityPack Class

[image]

Sitecore 6.4.1 API
InitializeAgilityPack Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Loader
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class InitializeAgilityPack
Visual Basic
Public Class InitializeAgilityPack
Visual C++
public ref class InitializeAgilityPack

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Loader..::..InitializeAgilityPack

See Also

InitializeAgilityPack Members
Sitecore.Pipelines.Loader Namespace


InitializeAgilityPack Members

[image] [image]

Sitecore 6.4.1 API
InitializeAgilityPack Members
InitializeAgilityPack Class Constructors Methods See Also Send Feedback

The InitializeAgilityPack type exposes the following members.

Constructors

 | Name | Description
Public method | InitializeAgilityPack | Initializes a new instance of the InitializeAgilityPack class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InitializeAgilityPack Class
Sitecore.Pipelines.Loader Namespace


InitializeAgilityPack Constructor

[image]

Sitecore 6.4.1 API
InitializeAgilityPack Constructor
InitializeAgilityPack Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Loader
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public InitializeAgilityPack()
Visual Basic
Public Sub New
Visual C++
public:
InitializeAgilityPack()

See Also

InitializeAgilityPack Class
Sitecore.Pipelines.Loader Namespace


InitializeAgilityPack Methods

[image] [image]

Sitecore 6.4.1 API
InitializeAgilityPack Methods
InitializeAgilityPack Class See Also Send Feedback

The InitializeAgilityPack type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InitializeAgilityPack Class
Sitecore.Pipelines.Loader Namespace


InitializeHeartbeat Class

[image]

Sitecore 6.4.1 API
InitializeHeartbeat Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Loader
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class InitializeHeartbeat
Visual Basic
Public Class InitializeHeartbeat
Visual C++
public ref class InitializeHeartbeat

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Loader..::..InitializeHeartbeat

See Also

InitializeHeartbeat Members
Sitecore.Pipelines.Loader Namespace


InitializeHeartbeat Members

[image] [image]

Sitecore 6.4.1 API
InitializeHeartbeat Members
InitializeHeartbeat Class Constructors Methods See Also Send Feedback

The InitializeHeartbeat type exposes the following members.

Constructors

 | Name | Description
Public method | InitializeHeartbeat | Initializes a new instance of the InitializeHeartbeat class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InitializeHeartbeat Class
Sitecore.Pipelines.Loader Namespace


InitializeHeartbeat Constructor

[image]

Sitecore 6.4.1 API
InitializeHeartbeat Constructor
InitializeHeartbeat Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Loader
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public InitializeHeartbeat()
Visual Basic
Public Sub New
Visual C++
public:
InitializeHeartbeat()

See Also

InitializeHeartbeat Class
Sitecore.Pipelines.Loader Namespace


InitializeHeartbeat Methods

[image] [image]

Sitecore 6.4.1 API
InitializeHeartbeat Methods
InitializeHeartbeat Class See Also Send Feedback

The InitializeHeartbeat type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InitializeHeartbeat Class
Sitecore.Pipelines.Loader Namespace


Process Method

[image]

Sitecore 6.4.1 API
InitializeHeartbeat..::..Process Method
InitializeHeartbeat Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Loader
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    PipelineArgs args
)
Visual Basic
Public Sub Process ( _
    args As PipelineArgs _
)
Visual C++
public:
void Process(
    PipelineArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines..::..PipelineArgs
The arguments.

See Also

InitializeHeartbeat Class
Sitecore.Pipelines.Loader Namespace


InitializeManagers Class

[image]

Sitecore 6.4.1 API
InitializeManagers Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Loader
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class InitializeManagers
Visual Basic
Public Class InitializeManagers
Visual C++
public ref class InitializeManagers

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Loader..::..InitializeManagers

See Also

InitializeManagers Members
Sitecore.Pipelines.Loader Namespace


InitializeManagers Constructor

[image]

Sitecore 6.4.1 API
InitializeManagers Constructor
InitializeManagers Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Loader
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public InitializeManagers()
Visual Basic
Public Sub New
Visual C++
public:
InitializeManagers()

See Also

InitializeManagers Class
Sitecore.Pipelines.Loader Namespace


InitializeManagers Methods

[image] [image]

Sitecore 6.4.1 API
InitializeManagers Methods
InitializeManagers Class See Also Send Feedback

The InitializeManagers type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Initializes static manager classes.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InitializeManagers Class
Sitecore.Pipelines.Loader Namespace


Process Method

[image]

Sitecore 6.4.1 API
InitializeManagers..::..Process Method
InitializeManagers Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Loader
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    PipelineArgs args
)
Visual Basic
Public Sub Process ( _
    args As PipelineArgs _
)
Visual C++
public:
void Process(
    PipelineArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines..::..PipelineArgs
The arguments.

See Also

InitializeManagers Class
Sitecore.Pipelines.Loader Namespace


InitializeScheduler Class

[image]

Sitecore 6.4.1 API
InitializeScheduler Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Loader
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class InitializeScheduler
Visual Basic
Public Class InitializeScheduler
Visual C++
public ref class InitializeScheduler

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Loader..::..InitializeScheduler

See Also

InitializeScheduler Members
Sitecore.Pipelines.Loader Namespace


InitializeScheduler Members

[image] [image]

Sitecore 6.4.1 API
InitializeScheduler Members
InitializeScheduler Class Constructors Methods See Also Send Feedback

The InitializeScheduler type exposes the following members.

Constructors

 | Name | Description
Public method | InitializeScheduler | Initializes a new instance of the InitializeScheduler class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InitializeScheduler Class
Sitecore.Pipelines.Loader Namespace


InitializeScheduler Constructor

[image]

Sitecore 6.4.1 API
InitializeScheduler Constructor
InitializeScheduler Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Loader
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public InitializeScheduler()
Visual Basic
Public Sub New
Visual C++
public:
InitializeScheduler()

See Also

InitializeScheduler Class
Sitecore.Pipelines.Loader Namespace


InitializeScheduler Methods

[image] [image]

Sitecore 6.4.1 API
InitializeScheduler Methods
InitializeScheduler Class See Also Send Feedback

The InitializeScheduler type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InitializeScheduler Class
Sitecore.Pipelines.Loader Namespace


Process Method

[image]

Sitecore 6.4.1 API
InitializeScheduler..::..Process Method
InitializeScheduler Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Loader
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    PipelineArgs args
)
Visual Basic
Public Sub Process ( _
    args As PipelineArgs _
)
Visual C++
public:
void Process(
    PipelineArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines..::..PipelineArgs
The arguments.

See Also

InitializeScheduler Class
Sitecore.Pipelines.Loader Namespace


Loader Class

[image]

Sitecore 6.4.1 API
Loader Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Loader
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public sealed class Loader
Visual Basic
Public NotInheritable Class Loader
Visual C++
public ref class Loader sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Loader..::..Loader

See Also

Loader Members
Sitecore.Pipelines.Loader Namespace


Loader Members

[image] [image]

Sitecore 6.4.1 API
Loader Members
Loader Class Constructors Methods See Also Send Feedback

The Loader type exposes the following members.

Constructors

 | Name | Description
Public method | Loader | Initializes a new instance of the Loader class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeSitecore | Obsolete. Initializes the sitecore.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Loader Class
Sitecore.Pipelines.Loader Namespace


Loader Constructor

[image]

Sitecore 6.4.1 API
Loader Constructor
Loader Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Loader
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Loader()
Visual Basic
Public Sub New
Visual C++
public:
Loader()

See Also

Loader Class
Sitecore.Pipelines.Loader Namespace


Loader Methods

[image] [image]

Sitecore 6.4.1 API
Loader Methods
Loader Class See Also Send Feedback

The Loader type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeSitecore | Obsolete. Initializes the sitecore.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Loader Class
Sitecore.Pipelines.Loader Namespace


InitializeSitecore Method

[image]

Sitecore 6.4.1 API
Loader..::..InitializeSitecore Method
Loader Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Loader
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated")]
public static void InitializeSitecore()
Visual Basic
<ObsoleteAttribute("Deprecated")> _
Public Shared Sub InitializeSitecore
Visual C++
[ObsoleteAttribute(L"Deprecated")]
public:
static void InitializeSitecore()

See Also

Loader Class
Sitecore.Pipelines.Loader Namespace


LoadHooks Class

[image]

Sitecore 6.4.1 API
LoadHooks Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Loader
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class LoadHooks
Visual Basic
Public Class LoadHooks
Visual C++
public ref class LoadHooks

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Loader..::..LoadHooks

See Also

LoadHooks Members
Sitecore.Pipelines.Loader Namespace


LoadHooks Members

[image] [image]

Sitecore 6.4.1 API
LoadHooks Members
LoadHooks Class Constructors Methods See Also Send Feedback

The LoadHooks type exposes the following members.

Constructors

 | Name | Description
Public method | LoadHooks | Initializes a new instance of the LoadHooks class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadHooks Class
Sitecore.Pipelines.Loader Namespace


LoadHooks Constructor

[image]

Sitecore 6.4.1 API
LoadHooks Constructor
LoadHooks Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Loader
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LoadHooks()
Visual Basic
Public Sub New
Visual C++
public:
LoadHooks()

See Also

LoadHooks Class
Sitecore.Pipelines.Loader Namespace


LoadHooks Methods

[image] [image]

Sitecore 6.4.1 API
LoadHooks Methods
LoadHooks Class See Also Send Feedback

The LoadHooks type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadHooks Class
Sitecore.Pipelines.Loader Namespace


Process Method

[image]

Sitecore 6.4.1 API
LoadHooks..::..Process Method
LoadHooks Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Loader
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    PipelineArgs args
)
Visual Basic
Public Sub Process ( _
    args As PipelineArgs _
)
Visual C++
public:
void Process(
    PipelineArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines..::..PipelineArgs
The arguments.

See Also

LoadHooks Class
Sitecore.Pipelines.Loader Namespace


SetGlobals Class

[image]

Sitecore 6.4.1 API
SetGlobals Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Loader
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SetGlobals
Visual Basic
Public Class SetGlobals
Visual C++
public ref class SetGlobals

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Loader..::..SetGlobals

See Also

SetGlobals Members
Sitecore.Pipelines.Loader Namespace


SetGlobals Members

[image] [image]

Sitecore 6.4.1 API
SetGlobals Members
SetGlobals Class Constructors Methods See Also Send Feedback

The SetGlobals type exposes the following members.

Constructors

 | Name | Description
Public method | SetGlobals | Initializes a new instance of the SetGlobals class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SetGlobals Class
Sitecore.Pipelines.Loader Namespace


SetGlobals Constructor

[image]

Sitecore 6.4.1 API
SetGlobals Constructor
SetGlobals Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Loader
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SetGlobals()
Visual Basic
Public Sub New
Visual C++
public:
SetGlobals()

See Also

SetGlobals Class
Sitecore.Pipelines.Loader Namespace


SetGlobals Methods

[image] [image]

Sitecore 6.4.1 API
SetGlobals Methods
SetGlobals Class See Also Send Feedback

The SetGlobals type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SetGlobals Class
Sitecore.Pipelines.Loader Namespace


Process Method

[image]

Sitecore 6.4.1 API
SetGlobals..::..Process Method
SetGlobals Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Loader
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    PipelineArgs args
)
Visual Basic
Public Sub Process ( _
    args As PipelineArgs _
)
Visual C++
public:
void Process(
    PipelineArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines..::..PipelineArgs
The arguments.

See Also

SetGlobals Class
Sitecore.Pipelines.Loader Namespace


ShowHistory Members

[image] [image]

Sitecore 6.4.1 API
ShowHistory Members
ShowHistory Class Constructors Methods See Also Send Feedback

The ShowHistory type exposes the following members.

Constructors

 | Name | Description
Public method | ShowHistory | Initializes a new instance of the ShowHistory class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShowHistory Class
Sitecore.Pipelines.Loader Namespace


ShowHistory Constructor

[image]

Sitecore 6.4.1 API
ShowHistory Constructor
ShowHistory Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Loader
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ShowHistory()
Visual Basic
Public Sub New
Visual C++
public:
ShowHistory()

See Also

ShowHistory Class
Sitecore.Pipelines.Loader Namespace


ShowHistory Methods

[image] [image]

Sitecore 6.4.1 API
ShowHistory Methods
ShowHistory Class See Also Send Feedback

The ShowHistory type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShowHistory Class
Sitecore.Pipelines.Loader Namespace


Process Method

[image]

Sitecore 6.4.1 API
ShowHistory..::..Process Method
ShowHistory Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Loader
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    PipelineArgs args
)
Visual Basic
Public Sub Process ( _
    args As PipelineArgs _
)
Visual C++
public:
void Process(
    PipelineArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines..::..PipelineArgs
The arguments.

See Also

ShowHistory Class
Sitecore.Pipelines.Loader Namespace


ShowVersion Class

[image]

Sitecore 6.4.1 API
ShowVersion Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Loader
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ShowVersion
Visual Basic
Public Class ShowVersion
Visual C++
public ref class ShowVersion

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Loader..::..ShowVersion

See Also

ShowVersion Members
Sitecore.Pipelines.Loader Namespace


ShowVersion Constructor

[image]

Sitecore 6.4.1 API
ShowVersion Constructor
ShowVersion Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Loader
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ShowVersion()
Visual Basic
Public Sub New
Visual C++
public:
ShowVersion()

See Also

ShowVersion Class
Sitecore.Pipelines.Loader Namespace


ShowVersion Methods

[image] [image]

Sitecore 6.4.1 API
ShowVersion Methods
ShowVersion Class See Also Send Feedback

The ShowVersion type exposes the following members.

Methods

 | Name | Description
Public method | AddAssembly | Adds the assembly.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShowVersion Class
Sitecore.Pipelines.Loader Namespace


AddAssembly Method

[image]

Sitecore 6.4.1 API
ShowVersion..::..AddAssembly Method
ShowVersion Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Loader
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddAssembly(
    string filename
)
Visual Basic
Public Sub AddAssembly ( _
    filename As String _
)
Visual C++
public:
void AddAssembly(
    String^ filename
)

Parameters

filename
Type: System..::..String
The filename.

See Also

ShowVersion Class
Sitecore.Pipelines.Loader Namespace


Process Method

[image]

Sitecore 6.4.1 API
ShowVersion..::..Process Method
ShowVersion Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Loader
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    PipelineArgs args
)
Visual Basic
Public Sub Process ( _
    args As PipelineArgs _
)
Visual C++
public:
void Process(
    PipelineArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines..::..PipelineArgs
The arguments.

See Also

ShowVersion Class
Sitecore.Pipelines.Loader Namespace


ShowDatabases Property

[image]

Sitecore 6.4.1 API
ShowVersion..::..ShowDatabases Property
ShowVersion Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Loader
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ShowDatabases { get; set; }
Visual Basic
Public Property ShowDatabases As Boolean
    Get
    Set
Visual C++
public:
property bool ShowDatabases {
    bool get ();
    void set (bool value);
}

Field Value

true if the ShowVersion shows the databases; otherwise, false.

See Also

ShowVersion Class
Sitecore.Pipelines.Loader Namespace


ShowDebugWarning Property

[image]

Sitecore 6.4.1 API
ShowVersion..::..ShowDebugWarning Property
ShowVersion Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Loader
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ShowDebugWarning { get; set; }
Visual Basic
Public Property ShowDebugWarning As Boolean
    Get
    Set
Visual C++
public:
property bool ShowDebugWarning {
    bool get ();
    void set (bool value);
}

Field Value

true if debug warning is enabled; otherwise, false.

See Also

ShowVersion Class
Sitecore.Pipelines.Loader Namespace


ShowDomains Property

[image]

Sitecore 6.4.1 API
ShowVersion..::..ShowDomains Property
ShowVersion Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Loader
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ShowDomains { get; set; }
Visual Basic
Public Property ShowDomains As Boolean
    Get
    Set
Visual C++
public:
property bool ShowDomains {
    bool get ();
    void set (bool value);
}

Field Value

true if the ShowVersion shows the domains; otherwise, false.

See Also

ShowVersion Class
Sitecore.Pipelines.Loader Namespace


Sitecore.Pipelines.LoadHtml Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.LoadHtml Namespace
Send Feedback

Classes

 | Class | Description
Public class | ConvertToDesignTime | Obsolete. Converts the Html to design time Html.
Public class | LoadHtmlArgs | Argument class for the Load Html pipeline.
Public class | Parse | Obsolete. Parses the Html into Header, Body and Footer.


ConvertToDesignTime Class

[image]

Sitecore 6.4.1 API
ConvertToDesignTime Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute]
public class ConvertToDesignTime
Visual Basic
<ObsoleteAttribute> _
Public Class ConvertToDesignTime
Visual C++
[ObsoleteAttribute]
public ref class ConvertToDesignTime

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.LoadHtml..::..ConvertToDesignTime

See Also

ConvertToDesignTime Members
Sitecore.Pipelines.LoadHtml Namespace


ConvertToDesignTime Members

[image] [image]

Sitecore 6.4.1 API
ConvertToDesignTime Members
ConvertToDesignTime Class Constructors Methods See Also Send Feedback

The ConvertToDesignTime type exposes the following members.

Constructors

 | Name | Description
Public method | ConvertToDesignTime | Initializes a new instance of the ConvertToDesignTime class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConvertToDesignTime Class
Sitecore.Pipelines.LoadHtml Namespace


ConvertToDesignTime Constructor

[image]

Sitecore 6.4.1 API
ConvertToDesignTime Constructor
ConvertToDesignTime Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ConvertToDesignTime()
Visual Basic
Public Sub New
Visual C++
public:
ConvertToDesignTime()

See Also

ConvertToDesignTime Class
Sitecore.Pipelines.LoadHtml Namespace


ConvertToDesignTime Methods

[image] [image]

Sitecore 6.4.1 API
ConvertToDesignTime Methods
ConvertToDesignTime Class See Also Send Feedback

The ConvertToDesignTime type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConvertToDesignTime Class
Sitecore.Pipelines.LoadHtml Namespace


Process Method

[image]

Sitecore 6.4.1 API
ConvertToDesignTime..::..Process Method
ConvertToDesignTime Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    LoadHtmlArgs args
)
Visual Basic
Public Sub Process ( _
    args As LoadHtmlArgs _
)
Visual C++
public:
void Process(
    LoadHtmlArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.LoadHtml..::..LoadHtmlArgs
The arguments.

See Also

ConvertToDesignTime Class
Sitecore.Pipelines.LoadHtml Namespace


LoadHtmlArgs Members

[image] [image]

Sitecore 6.4.1 API
LoadHtmlArgs Members
LoadHtmlArgs Class Constructors Methods Properties See Also Send Feedback

The LoadHtmlArgs type exposes the following members.

Constructors

 | Name | Description
Protected method | LoadHtmlArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the LoadHtmlArgs class.
Public method | LoadHtmlArgs(String, String) | Initializes a new instance of the LoadHtmlArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ClientPipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | A processor is done. (Overrides ClientPipelineArgs..::..ProcessorDone()()()().)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WaitForPostBack()()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Public method | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | Body | Gets or sets the body.
Public property | CarryResultToNextProcessor | Gets or sets a value indicating whether the ClientPipelineArgs carries the result to next processor. (Inherited from ClientPipelineArgs.)
Public property | ControlName | Gets the name of the control.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Footer | Gets or sets the footer.
Public property | HasResult | Gets a value indicating whether this instance has a result. (Inherited from ClientPipelineArgs.)
Public property | Header | Gets or sets the header.
Public property | Html | Gets or sets the HTML.
Public property | IsPostBack | Gets or sets a value that indicates if the processor was invoked as part of a user response. (Inherited from ClientPipelineArgs.)
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Parameters | Gets or sets the parameters. (Inherited from ClientPipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Properties | Gets the properties. (Inherited from ClientPipelineArgs.)
Public property | RawBody | Gets or sets the raw body.
Public property | Result | Gets or sets the value that was posted as part of a Sheer response. (Inherited from ClientPipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

LoadHtmlArgs Class
Sitecore.Pipelines.LoadHtml Namespace


LoadHtmlArgs Constructor

[image] [image]

Sitecore 6.4.1 API
LoadHtmlArgs Constructor
LoadHtmlArgs Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | LoadHtmlArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the LoadHtmlArgs class.
Public method | LoadHtmlArgs(String, String) | Initializes a new instance of the LoadHtmlArgs class.

See Also

LoadHtmlArgs Class
LoadHtmlArgs Members
Sitecore.Pipelines.LoadHtml Namespace


LoadHtmlArgs Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
LoadHtmlArgs Constructor (SerializationInfo, StreamingContext)
LoadHtmlArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected LoadHtmlArgs(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
LoadHtmlArgs(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

LoadHtmlArgs Class
LoadHtmlArgs Overload
Sitecore.Pipelines.LoadHtml Namespace


LoadHtmlArgs Constructor (String, String)

[image]

Sitecore 6.4.1 API
LoadHtmlArgs Constructor (String, String)
LoadHtmlArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LoadHtmlArgs(
    string html,
    string controlName
)
Visual Basic
Public Sub New ( _
    html As String, _
    controlName As String _
)
Visual C++
public:
LoadHtmlArgs(
    String^ html,
    String^ controlName
)

Parameters

html
Type: System..::..String
The HTML.
controlName
Type: System..::..String
Name of the control.

See Also

LoadHtmlArgs Class
LoadHtmlArgs Overload
Sitecore.Pipelines.LoadHtml Namespace


LoadHtmlArgs Methods

[image] [image]

Sitecore 6.4.1 API
LoadHtmlArgs Methods
LoadHtmlArgs Class See Also Send Feedback

The LoadHtmlArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ClientPipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | A processor is done. (Overrides ClientPipelineArgs..::..ProcessorDone()()()().)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WaitForPostBack()()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Public method | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)

See Also

LoadHtmlArgs Class
Sitecore.Pipelines.LoadHtml Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
LoadHtmlArgs..::..AddMessage Method
LoadHtmlArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

LoadHtmlArgs Class
LoadHtmlArgs Members
Sitecore.Pipelines.LoadHtml Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
LoadHtmlArgs..::..GetMessages Method
LoadHtmlArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

LoadHtmlArgs Class
LoadHtmlArgs Members
Sitecore.Pipelines.LoadHtml Namespace


GetObjectData Method

[image]

Sitecore 6.4.1 API
LoadHtmlArgs..::..GetObjectData Method
LoadHtmlArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System.Security..::..SecurityException | The caller does not have the required permission.

See Also

LoadHtmlArgs Class
Sitecore.Pipelines.LoadHtml Namespace


ProcessorDone Method

[image]

Sitecore 6.4.1 API
LoadHtmlArgs..::..ProcessorDone Method
LoadHtmlArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected internal override void ProcessorDone()
Visual Basic
Protected Friend Overrides Sub ProcessorDone
Visual C++
protected public:
virtual void ProcessorDone() override

See Also

LoadHtmlArgs Class
Sitecore.Pipelines.LoadHtml Namespace


LoadHtmlArgs Properties

[image] [image]

Sitecore 6.4.1 API
LoadHtmlArgs Properties
LoadHtmlArgs Class See Also Send Feedback

The LoadHtmlArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | Body | Gets or sets the body.
Public property | CarryResultToNextProcessor | Gets or sets a value indicating whether the ClientPipelineArgs carries the result to next processor. (Inherited from ClientPipelineArgs.)
Public property | ControlName | Gets the name of the control.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Footer | Gets or sets the footer.
Public property | HasResult | Gets a value indicating whether this instance has a result. (Inherited from ClientPipelineArgs.)
Public property | Header | Gets or sets the header.
Public property | Html | Gets or sets the HTML.
Public property | IsPostBack | Gets or sets a value that indicates if the processor was invoked as part of a user response. (Inherited from ClientPipelineArgs.)
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Parameters | Gets or sets the parameters. (Inherited from ClientPipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Properties | Gets the properties. (Inherited from ClientPipelineArgs.)
Public property | RawBody | Gets or sets the raw body.
Public property | Result | Gets or sets the value that was posted as part of a Sheer response. (Inherited from ClientPipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

LoadHtmlArgs Class
Sitecore.Pipelines.LoadHtml Namespace


Body Property

[image]

Sitecore 6.4.1 API
LoadHtmlArgs..::..Body Property
LoadHtmlArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Body { get; set; }
Visual Basic
Public Property Body As String
    Get
    Set
Visual C++
public:
property String^ Body {
    String^ get ();
    void set (String^ value);
}

Field Value

The body.

See Also

LoadHtmlArgs Class
Sitecore.Pipelines.LoadHtml Namespace


ControlName Property

[image]

Sitecore 6.4.1 API
LoadHtmlArgs..::..ControlName Property
LoadHtmlArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ControlName { get; }
Visual Basic
Public ReadOnly Property ControlName As String
    Get
Visual C++
public:
property String^ ControlName {
    String^ get ();
}

Field Value

The name of the control.

See Also

LoadHtmlArgs Class
Sitecore.Pipelines.LoadHtml Namespace


Footer Property

[image]

Sitecore 6.4.1 API
LoadHtmlArgs..::..Footer Property
LoadHtmlArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Footer { get; set; }
Visual Basic
Public Property Footer As String
    Get
    Set
Visual C++
public:
property String^ Footer {
    String^ get ();
    void set (String^ value);
}

Field Value

The footer.

See Also

LoadHtmlArgs Class
Sitecore.Pipelines.LoadHtml Namespace


Header Property

[image]

Sitecore 6.4.1 API
LoadHtmlArgs..::..Header Property
LoadHtmlArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Header { get; set; }
Visual Basic
Public Property Header As String
    Get
    Set
Visual C++
public:
property String^ Header {
    String^ get ();
    void set (String^ value);
}

Field Value

The header.

See Also

LoadHtmlArgs Class
Sitecore.Pipelines.LoadHtml Namespace


Html Property

[image]

Sitecore 6.4.1 API
LoadHtmlArgs..::..Html Property
LoadHtmlArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Html { get; set; }
Visual Basic
Public Property Html As String
    Get
    Set
Visual C++
public:
property String^ Html {
    String^ get ();
    void set (String^ value);
}

Field Value

The HTML.

See Also

LoadHtmlArgs Class
Sitecore.Pipelines.LoadHtml Namespace


RawBody Property

[image]

Sitecore 6.4.1 API
LoadHtmlArgs..::..RawBody Property
LoadHtmlArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string RawBody { get; set; }
Visual Basic
Public Property RawBody As String
    Get
    Set
Visual C++
public:
property String^ RawBody {
    String^ get ();
    void set (String^ value);
}

Field Value

The raw body.

See Also

LoadHtmlArgs Class
Sitecore.Pipelines.LoadHtml Namespace


Parse Class

[image]

Sitecore 6.4.1 API
Parse Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute]
public class Parse
Visual Basic
<ObsoleteAttribute> _
Public Class Parse
Visual C++
[ObsoleteAttribute]
public ref class Parse

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.LoadHtml..::..Parse

See Also

Parse Members
Sitecore.Pipelines.LoadHtml Namespace


Parse Members

[image] [image]

Sitecore 6.4.1 API
Parse Members
Parse Class Constructors Methods See Also Send Feedback

The Parse type exposes the following members.

Constructors

 | Name | Description
Public method | Parse | Initializes a new instance of the Parse class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Parse Class
Sitecore.Pipelines.LoadHtml Namespace


Parse Constructor

[image]

Sitecore 6.4.1 API
Parse Constructor
Parse Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Parse()
Visual Basic
Public Sub New
Visual C++
public:
Parse()

See Also

Parse Class
Sitecore.Pipelines.LoadHtml Namespace


Parse Methods

[image] [image]

Sitecore 6.4.1 API
Parse Methods
Parse Class See Also Send Feedback

The Parse type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Parse Class
Sitecore.Pipelines.LoadHtml Namespace


Process Method

[image]

Sitecore 6.4.1 API
Parse..::..Process Method
Parse Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    LoadHtmlArgs args
)
Visual Basic
Public Sub Process ( _
    args As LoadHtmlArgs _
)
Visual C++
public:
void Process(
    LoadHtmlArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.LoadHtml..::..LoadHtmlArgs
The arguments.

See Also

Parse Class
Sitecore.Pipelines.LoadHtml Namespace


Sitecore.Pipelines.LoadLayout Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.LoadLayout Namespace
Send Feedback

Classes

 | Class | Description
Public class | ConvertToDesignTime | Converts the Html to design time Html.
Public class | Load | Loads the layout from the file.
Public class | LoadLayoutArgs | Argument class for Load Layout pipeline.
Public class | Parse | Parses the layout into Header, Body and Footer.

Enumerations

 | Enumeration | Description
Public enumeration | LoadLayoutArgs..::..LayoutType | Defines the layout type.


ConvertToDesignTime Class

[image]

Sitecore 6.4.1 API
ConvertToDesignTime Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ConvertToDesignTime
Visual Basic
Public Class ConvertToDesignTime
Visual C++
public ref class ConvertToDesignTime

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.LoadLayout..::..ConvertToDesignTime

See Also

ConvertToDesignTime Members
Sitecore.Pipelines.LoadLayout Namespace


ConvertToDesignTime Members

[image] [image]

Sitecore 6.4.1 API
ConvertToDesignTime Members
ConvertToDesignTime Class Constructors Methods See Also Send Feedback

The ConvertToDesignTime type exposes the following members.

Constructors

 | Name | Description
Public method | ConvertToDesignTime | Initializes a new instance of the ConvertToDesignTime class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConvertToDesignTime Class
Sitecore.Pipelines.LoadLayout Namespace


ConvertToDesignTime Constructor

[image]

Sitecore 6.4.1 API
ConvertToDesignTime Constructor
ConvertToDesignTime Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ConvertToDesignTime()
Visual Basic
Public Sub New
Visual C++
public:
ConvertToDesignTime()

See Also

ConvertToDesignTime Class
Sitecore.Pipelines.LoadLayout Namespace


ConvertToDesignTime Methods

[image] [image]

Sitecore 6.4.1 API
ConvertToDesignTime Methods
ConvertToDesignTime Class See Also Send Feedback

The ConvertToDesignTime type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConvertToDesignTime Class
Sitecore.Pipelines.LoadLayout Namespace


Process Method

[image]

Sitecore 6.4.1 API
ConvertToDesignTime..::..Process Method
ConvertToDesignTime Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    LoadLayoutArgs args
)
Visual Basic
Public Sub Process ( _
    args As LoadLayoutArgs _
)
Visual C++
public:
void Process(
    LoadLayoutArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.LoadLayout..::..LoadLayoutArgs
The arguments.

See Also

ConvertToDesignTime Class
Sitecore.Pipelines.LoadLayout Namespace


Load Class

[image]

Sitecore 6.4.1 API
Load Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Load
Visual Basic
Public Class Load
Visual C++
public ref class Load

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.LoadLayout..::..Load

See Also

Load Members
Sitecore.Pipelines.LoadLayout Namespace


Load Members

[image] [image]

Sitecore 6.4.1 API
Load Members
Load Class Constructors Methods See Also Send Feedback

The Load type exposes the following members.

Constructors

 | Name | Description
Public method | Load | Initializes a new instance of the Load class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Load Class
Sitecore.Pipelines.LoadLayout Namespace


Load Constructor

[image]

Sitecore 6.4.1 API
Load Constructor
Load Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Load()
Visual Basic
Public Sub New
Visual C++
public:
Load()

See Also

Load Class
Sitecore.Pipelines.LoadLayout Namespace


Load Methods

[image] [image]

Sitecore 6.4.1 API
Load Methods
Load Class See Also Send Feedback

The Load type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Load Class
Sitecore.Pipelines.LoadLayout Namespace


LoadLayoutArgs Class

[image]

Sitecore 6.4.1 API
LoadLayoutArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class LoadLayoutArgs : ClientPipelineArgs
Visual Basic
<SerializableAttribute> _
Public Class LoadLayoutArgs _
    Inherits ClientPipelineArgs
Visual C++
[SerializableAttribute]
public ref class LoadLayoutArgs : public ClientPipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Web.UI.Sheer..::..ClientPipelineArgs
Sitecore.Pipelines.LoadLayout..::..LoadLayoutArgs

See Also

LoadLayoutArgs Members
Sitecore.Pipelines.LoadLayout Namespace


LoadLayoutArgs Members

[image] [image]

Sitecore 6.4.1 API
LoadLayoutArgs Members
LoadLayoutArgs Class Constructors Methods Properties See Also Send Feedback

The LoadLayoutArgs type exposes the following members.

Constructors

 | Name | Description
Public method | LoadLayoutArgs(String) | Initializes a new instance of the LoadLayoutArgs class.
Protected method | LoadLayoutArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the LoadLayoutArgs class from a serialization context.
Public method | LoadLayoutArgs(String, String) | Initializes a new instance of the LoadLayoutArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ClientPipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | A processor is done. (Overrides ClientPipelineArgs..::..ProcessorDone()()()().)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WaitForPostBack()()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Public method | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | Body | Gets or sets the body.
Public property | CarryResultToNextProcessor | Gets or sets a value indicating whether the ClientPipelineArgs carries the result to next processor. (Inherited from ClientPipelineArgs.)
Public property | ControlName | Gets the name of the control.
Public property | Create | Gets or sets a value indicating whether this LoadLayoutArgs is create.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Filename | Gets the filename.
Public property | FileTemplate | Gets or sets the file template.
Public property | Footer | Gets or sets the footer.
Public property | HasResult | Gets a value indicating whether this instance has a result. (Inherited from ClientPipelineArgs.)
Public property | Header | Gets or sets the header.
Public property | Html | Gets or sets the HTML.
Public property | InlineControls | Gets a value indicating whether controls are generated as inline or in an iframe.
Public property | IsPostBack | Gets or sets a value that indicates if the processor was invoked as part of a user response. (Inherited from ClientPipelineArgs.)
Public property | LastWriteTime | Gets or sets the last write time.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Parameters | Gets or sets the parameters. (Inherited from ClientPipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Properties | Gets the properties. (Inherited from ClientPipelineArgs.)
Public property | RawBody | Gets or sets the raw body.
Public property | Result | Gets or sets the value that was posted as part of a Sheer response. (Inherited from ClientPipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
Public property | Type | Gets or sets the type.

See Also

LoadLayoutArgs Class
Sitecore.Pipelines.LoadLayout Namespace


LoadLayoutArgs Constructor

[image] [image]

Sitecore 6.4.1 API
LoadLayoutArgs Constructor
LoadLayoutArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LoadLayoutArgs(String) | Initializes a new instance of the LoadLayoutArgs class.
Protected method | LoadLayoutArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the LoadLayoutArgs class from a serialization context.
Public method | LoadLayoutArgs(String, String) | Initializes a new instance of the LoadLayoutArgs class.

See Also

LoadLayoutArgs Class
LoadLayoutArgs Members
Sitecore.Pipelines.LoadLayout Namespace


LoadLayoutArgs Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
LoadLayoutArgs Constructor (SerializationInfo, StreamingContext)
LoadLayoutArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected LoadLayoutArgs(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
LoadLayoutArgs(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The serialized data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

LoadLayoutArgs Class
LoadLayoutArgs Overload
Sitecore.Pipelines.LoadLayout Namespace


LoadLayoutArgs Constructor (String, String)

[image]

Sitecore 6.4.1 API
LoadLayoutArgs Constructor (String, String)
LoadLayoutArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LoadLayoutArgs(
    string filename,
    string controlName
)
Visual Basic
Public Sub New ( _
    filename As String, _
    controlName As String _
)
Visual C++
public:
LoadLayoutArgs(
    String^ filename,
    String^ controlName
)

Parameters

filename
Type: System..::..String
The filename.
controlName
Type: System..::..String
Name of the control.

See Also

LoadLayoutArgs Class
LoadLayoutArgs Overload
Sitecore.Pipelines.LoadLayout Namespace


LoadLayoutArgs Methods

[image] [image]

Sitecore 6.4.1 API
LoadLayoutArgs Methods
LoadLayoutArgs Class See Also Send Feedback

The LoadLayoutArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ClientPipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | A processor is done. (Overrides ClientPipelineArgs..::..ProcessorDone()()()().)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WaitForPostBack()()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Public method | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)

See Also

LoadLayoutArgs Class
Sitecore.Pipelines.LoadLayout Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
LoadLayoutArgs..::..AddMessage Method
LoadLayoutArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

LoadLayoutArgs Class
LoadLayoutArgs Members
Sitecore.Pipelines.LoadLayout Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
LoadLayoutArgs..::..GetMessages Method
LoadLayoutArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

LoadLayoutArgs Class
LoadLayoutArgs Members
Sitecore.Pipelines.LoadLayout Namespace


GetObjectData Method

[image]

Sitecore 6.4.1 API
LoadLayoutArgs..::..GetObjectData Method
LoadLayoutArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System.Security..::..SecurityException | The caller does not have the required permission.

See Also

LoadLayoutArgs Class
Sitecore.Pipelines.LoadLayout Namespace


ProcessorDone Method

[image]

Sitecore 6.4.1 API
LoadLayoutArgs..::..ProcessorDone Method
LoadLayoutArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected internal override void ProcessorDone()
Visual Basic
Protected Friend Overrides Sub ProcessorDone
Visual C++
protected public:
virtual void ProcessorDone() override

See Also

LoadLayoutArgs Class
Sitecore.Pipelines.LoadLayout Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
LoadLayoutArgs..::..Suspend Method
LoadLayoutArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

LoadLayoutArgs Class
LoadLayoutArgs Members
Sitecore.Pipelines.LoadLayout Namespace


WaitForPostBack Method

[image] [image]

Sitecore 6.4.1 API
LoadLayoutArgs..::..WaitForPostBack Method
LoadLayoutArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaitForPostBack()()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Public method | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)

See Also

LoadLayoutArgs Class
LoadLayoutArgs Members
Sitecore.Pipelines.LoadLayout Namespace


LoadLayoutArgs Properties

[image] [image]

Sitecore 6.4.1 API
LoadLayoutArgs Properties
LoadLayoutArgs Class See Also Send Feedback

The LoadLayoutArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | Body | Gets or sets the body.
Public property | CarryResultToNextProcessor | Gets or sets a value indicating whether the ClientPipelineArgs carries the result to next processor. (Inherited from ClientPipelineArgs.)
Public property | ControlName | Gets the name of the control.
Public property | Create | Gets or sets a value indicating whether this LoadLayoutArgs is create.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Filename | Gets the filename.
Public property | FileTemplate | Gets or sets the file template.
Public property | Footer | Gets or sets the footer.
Public property | HasResult | Gets a value indicating whether this instance has a result. (Inherited from ClientPipelineArgs.)
Public property | Header | Gets or sets the header.
Public property | Html | Gets or sets the HTML.
Public property | InlineControls | Gets a value indicating whether controls are generated as inline or in an iframe.
Public property | IsPostBack | Gets or sets a value that indicates if the processor was invoked as part of a user response. (Inherited from ClientPipelineArgs.)
Public property | LastWriteTime | Gets or sets the last write time.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Parameters | Gets or sets the parameters. (Inherited from ClientPipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Properties | Gets the properties. (Inherited from ClientPipelineArgs.)
Public property | RawBody | Gets or sets the raw body.
Public property | Result | Gets or sets the value that was posted as part of a Sheer response. (Inherited from ClientPipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
Public property | Type | Gets or sets the type.

See Also

LoadLayoutArgs Class
Sitecore.Pipelines.LoadLayout Namespace


Body Property

[image]

Sitecore 6.4.1 API
LoadLayoutArgs..::..Body Property
LoadLayoutArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Body { get; set; }
Visual Basic
Public Property Body As String
    Get
    Set
Visual C++
public:
property String^ Body {
    String^ get ();
    void set (String^ value);
}

Field Value

The body.

See Also

LoadLayoutArgs Class
Sitecore.Pipelines.LoadLayout Namespace


ControlName Property

[image]

Sitecore 6.4.1 API
LoadLayoutArgs..::..ControlName Property
LoadLayoutArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ControlName { get; set; }
Visual Basic
Public Property ControlName As String
    Get
    Set
Visual C++
public:
property String^ ControlName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the control.

See Also

LoadLayoutArgs Class
Sitecore.Pipelines.LoadLayout Namespace


Create Property

[image]

Sitecore 6.4.1 API
LoadLayoutArgs..::..Create Property
LoadLayoutArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Create { get; set; }
Visual Basic
Public Property Create As Boolean
    Get
    Set
Visual C++
public:
property bool Create {
    bool get ();
    void set (bool value);
}

Field Value

true if create; otherwise, false.

See Also

LoadLayoutArgs Class
Sitecore.Pipelines.LoadLayout Namespace


Filename Property

[image]

Sitecore 6.4.1 API
LoadLayoutArgs..::..Filename Property
LoadLayoutArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Filename { get; private set; }
Visual Basic
Public Property Filename As String
    Get
    Private Set
Visual C++
public:
property String^ Filename {
    String^ get ();
    private: void set (String^ value);
}

Field Value

The filename.

See Also

LoadLayoutArgs Class
Sitecore.Pipelines.LoadLayout Namespace


FileTemplate Property

[image]

Sitecore 6.4.1 API
LoadLayoutArgs..::..FileTemplate Property
LoadLayoutArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string FileTemplate { get; set; }
Visual Basic
Public Property FileTemplate As String
    Get
    Set
Visual C++
public:
property String^ FileTemplate {
    String^ get ();
    void set (String^ value);
}

Field Value

The file template.

Remarks

This is only used if Create is true.

See Also

LoadLayoutArgs Class
Sitecore.Pipelines.LoadLayout Namespace


Header Property

[image]

Sitecore 6.4.1 API
LoadLayoutArgs..::..Header Property
LoadLayoutArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Header { get; set; }
Visual Basic
Public Property Header As String
    Get
    Set
Visual C++
public:
property String^ Header {
    String^ get ();
    void set (String^ value);
}

Field Value

The header.

See Also

LoadLayoutArgs Class
Sitecore.Pipelines.LoadLayout Namespace


Html Property

[image]

Sitecore 6.4.1 API
LoadLayoutArgs..::..Html Property
LoadLayoutArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Html { get; set; }
Visual Basic
Public Property Html As String
    Get
    Set
Visual C++
public:
property String^ Html {
    String^ get ();
    void set (String^ value);
}

Field Value

The HTML.

See Also

LoadLayoutArgs Class
Sitecore.Pipelines.LoadLayout Namespace


InlineControls Property

[image]

Sitecore 6.4.1 API
LoadLayoutArgs..::..InlineControls Property
LoadLayoutArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool InlineControls { get; set; }
Visual Basic
Public Property InlineControls As Boolean
    Get
    Set
Visual C++
public:
property bool InlineControls {
    bool get ();
    void set (bool value);
}

Field Value

true if inline; otherwise, false.

See Also

LoadLayoutArgs Class
Sitecore.Pipelines.LoadLayout Namespace


LastWriteTime Property

[image]

Sitecore 6.4.1 API
LoadLayoutArgs..::..LastWriteTime Property
LoadLayoutArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime LastWriteTime { get; set; }
Visual Basic
Public Property LastWriteTime As DateTime
    Get
    Set
Visual C++
public:
property DateTime LastWriteTime {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The last write time.

See Also

LoadLayoutArgs Class
Sitecore.Pipelines.LoadLayout Namespace


RawBody Property

[image]

Sitecore 6.4.1 API
LoadLayoutArgs..::..RawBody Property
LoadLayoutArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string RawBody { get; set; }
Visual Basic
Public Property RawBody As String
    Get
    Set
Visual C++
public:
property String^ RawBody {
    String^ get ();
    void set (String^ value);
}

Field Value

The raw body.

See Also

LoadLayoutArgs Class
Sitecore.Pipelines.LoadLayout Namespace


Type Property

[image]

Sitecore 6.4.1 API
LoadLayoutArgs..::..Type Property
LoadLayoutArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LoadLayoutArgs..::..LayoutType Type { get; set; }
Visual Basic
Public Property Type As LoadLayoutArgs..::..LayoutType
    Get
    Set
Visual C++
public:
property LoadLayoutArgs..::..LayoutType Type {
    LoadLayoutArgs..::..LayoutType get ();
    void set (LoadLayoutArgs..::..LayoutType value);
}

Field Value

The type.

See Also

LoadLayoutArgs Class
Sitecore.Pipelines.LoadLayout Namespace


LoadLayoutArgs.LayoutType Enumeration

[image]

Sitecore 6.4.1 API
LoadLayoutArgs..::..LayoutType Enumeration
LoadLayoutArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum LayoutType
Visual Basic
Public Enumeration LayoutType
Visual C++
public enum class LayoutType

Members

Member name | Value | Description
Layout | 0 | Layout.
Sublayout | 1 | Sublayout.

See Also

Sitecore.Pipelines.LoadLayout Namespace


Parse Class

[image]

Sitecore 6.4.1 API
Parse Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Parse
Visual Basic
Public Class Parse
Visual C++
public ref class Parse

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.LoadLayout..::..Parse

See Also

Parse Members
Sitecore.Pipelines.LoadLayout Namespace


Parse Members

[image] [image]

Sitecore 6.4.1 API
Parse Members
Parse Class Constructors Methods See Also Send Feedback

The Parse type exposes the following members.

Constructors

 | Name | Description
Public method | Parse | Initializes a new instance of the Parse class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Parse Class
Sitecore.Pipelines.LoadLayout Namespace


Parse Constructor

[image]

Sitecore 6.4.1 API
Parse Constructor
Parse Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Parse()
Visual Basic
Public Sub New
Visual C++
public:
Parse()

See Also

Parse Class
Sitecore.Pipelines.LoadLayout Namespace


Parse Methods

[image] [image]

Sitecore 6.4.1 API
Parse Methods
Parse Class See Also Send Feedback

The Parse type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Parse Class
Sitecore.Pipelines.LoadLayout Namespace


Process Method

[image]

Sitecore 6.4.1 API
Parse..::..Process Method
Parse Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoadLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    LoadLayoutArgs args
)
Visual Basic
Public Sub Process ( _
    args As LoadLayoutArgs _
)
Visual C++
public:
void Process(
    LoadLayoutArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.LoadLayout..::..LoadLayoutArgs
The arguments.

See Also

Parse Class
Sitecore.Pipelines.LoadLayout Namespace


Sitecore.Pipelines.LoggedIn Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.LoggedIn Namespace
Send Feedback

Classes

 | Class | Description
Public class | LoggedInArgs | Argument class for ILoginProcessor implementations
Public class | LoggedInProcessor | LoggedInProcessor class
Public class | Ticket | Processor for storing a ticket.


LoggedInArgs Class

[image]

Sitecore 6.4.1 API
LoggedInArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.LoggedIn
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class LoggedInArgs : PipelineArgs
Visual Basic
<SerializableAttribute> _
Public Class LoggedInArgs _
    Inherits PipelineArgs
Visual C++
[SerializableAttribute]
public ref class LoggedInArgs : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Pipelines.LoggedIn..::..LoggedInArgs

See Also

LoggedInArgs Members
Sitecore.Pipelines.LoggedIn Namespace


LoggedInArgs Members

[image] [image]

Sitecore 6.4.1 API
LoggedInArgs Members
LoggedInArgs Class Constructors Methods Properties See Also Send Feedback

The LoggedInArgs type exposes the following members.

Constructors

 | Name | Description
Public method | LoggedInArgs()()()() | Initializes a new instance of the LoggedInArgs class.
Protected method | LoggedInArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the LoggedInArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Persist | Gets or sets a value indicating whether this LoggedInArgs is persist.
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | StartUrl | Gets or sets the start URL.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
Public property | Username | Gets or sets the username.

See Also

LoggedInArgs Class
Sitecore.Pipelines.LoggedIn Namespace


LoggedInArgs Constructor

[image] [image]

Sitecore 6.4.1 API
LoggedInArgs Constructor
LoggedInArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LoggedInArgs()()()() | Initializes a new instance of the LoggedInArgs class.
Protected method | LoggedInArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the LoggedInArgs class.

See Also

LoggedInArgs Class
LoggedInArgs Members
Sitecore.Pipelines.LoggedIn Namespace


LoggedInArgs Constructor

[image]

Sitecore 6.4.1 API
LoggedInArgs Constructor
LoggedInArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoggedIn
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LoggedInArgs()
Visual Basic
Public Sub New
Visual C++
public:
LoggedInArgs()

See Also

LoggedInArgs Class
LoggedInArgs Overload
Sitecore.Pipelines.LoggedIn Namespace


LoggedInArgs Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
LoggedInArgs Constructor (SerializationInfo, StreamingContext)
LoggedInArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoggedIn
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected LoggedInArgs(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
LoggedInArgs(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

LoggedInArgs Class
LoggedInArgs Overload
Sitecore.Pipelines.LoggedIn Namespace


LoggedInArgs Methods

[image] [image]

Sitecore 6.4.1 API
LoggedInArgs Methods
LoggedInArgs Class See Also Send Feedback

The LoggedInArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoggedInArgs Class
Sitecore.Pipelines.LoggedIn Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
LoggedInArgs..::..AddMessage Method
LoggedInArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

LoggedInArgs Class
LoggedInArgs Members
Sitecore.Pipelines.LoggedIn Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
LoggedInArgs..::..GetMessages Method
LoggedInArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

LoggedInArgs Class
LoggedInArgs Members
Sitecore.Pipelines.LoggedIn Namespace


GetObjectData Method

[image]

Sitecore 6.4.1 API
LoggedInArgs..::..GetObjectData Method
LoggedInArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoggedIn
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System.Security..::..SecurityException | The caller does not have the required permission.

See Also

LoggedInArgs Class
Sitecore.Pipelines.LoggedIn Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
LoggedInArgs..::..Suspend Method
LoggedInArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

LoggedInArgs Class
LoggedInArgs Members
Sitecore.Pipelines.LoggedIn Namespace


LoggedInArgs Properties

[image] [image]

Sitecore 6.4.1 API
LoggedInArgs Properties
LoggedInArgs Class See Also Send Feedback

The LoggedInArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Persist | Gets or sets a value indicating whether this LoggedInArgs is persist.
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | StartUrl | Gets or sets the start URL.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
Public property | Username | Gets or sets the username.

See Also

LoggedInArgs Class
Sitecore.Pipelines.LoggedIn Namespace


Persist Property

[image]

Sitecore 6.4.1 API
LoggedInArgs..::..Persist Property
LoggedInArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoggedIn
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Persist { get; set; }
Visual Basic
Public Property Persist As Boolean
    Get
    Set
Visual C++
public:
property bool Persist {
    bool get ();
    void set (bool value);
}

Field Value

true if persist; otherwise, false.

See Also

LoggedInArgs Class
Sitecore.Pipelines.LoggedIn Namespace


StartUrl Property

[image]

Sitecore 6.4.1 API
LoggedInArgs..::..StartUrl Property
LoggedInArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoggedIn
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string StartUrl { get; set; }
Visual Basic
Public Property StartUrl As String
    Get
    Set
Visual C++
public:
property String^ StartUrl {
    String^ get ();
    void set (String^ value);
}

Field Value

The start URL.

See Also

LoggedInArgs Class
Sitecore.Pipelines.LoggedIn Namespace


Username Property

[image]

Sitecore 6.4.1 API
LoggedInArgs..::..Username Property
LoggedInArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoggedIn
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Username { get; set; }
Visual Basic
Public Property Username As String
    Get
    Set
Visual C++
public:
property String^ Username {
    String^ get ();
    void set (String^ value);
}

Field Value

The username.

See Also

LoggedInArgs Class
Sitecore.Pipelines.LoggedIn Namespace


LoggedInProcessor Members

[image] [image]

Sitecore 6.4.1 API
LoggedInProcessor Members
LoggedInProcessor Class Constructors Methods See Also Send Feedback

The LoggedInProcessor type exposes the following members.

Constructors

 | Name | Description
Protected method | LoggedInProcessor | Initializes a new instance of the LoggedInProcessor class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoggedInProcessor Class
Sitecore.Pipelines.LoggedIn Namespace


LoggedInProcessor Constructor

[image]

Sitecore 6.4.1 API
LoggedInProcessor Constructor
LoggedInProcessor Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoggedIn
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected LoggedInProcessor()
Visual Basic
Protected Sub New
Visual C++
protected:
LoggedInProcessor()

See Also

LoggedInProcessor Class
Sitecore.Pipelines.LoggedIn Namespace


LoggedInProcessor Methods

[image] [image]

Sitecore 6.4.1 API
LoggedInProcessor Methods
LoggedInProcessor Class See Also Send Feedback

The LoggedInProcessor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoggedInProcessor Class
Sitecore.Pipelines.LoggedIn Namespace


Process Method

[image]

Sitecore 6.4.1 API
LoggedInProcessor..::..Process Method
LoggedInProcessor Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoggedIn
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract void Process(
    LoggedInArgs args
)
Visual Basic
Public MustOverride Sub Process ( _
    args As LoggedInArgs _
)
Visual C++
public:
virtual void Process(
    LoggedInArgs^ args
) abstract

Parameters

args
Type: Sitecore.Pipelines.LoggedIn..::..LoggedInArgs
The args.

See Also

LoggedInProcessor Class
Sitecore.Pipelines.LoggedIn Namespace


Ticket Class

[image]

Sitecore 6.4.1 API
Ticket Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.LoggedIn
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Ticket : LoggedInProcessor
Visual Basic
Public Class Ticket _
    Inherits LoggedInProcessor
Visual C++
public ref class Ticket : public LoggedInProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.LoggedIn..::..LoggedInProcessor
Sitecore.Pipelines.LoggedIn..::..Ticket

See Also

Ticket Members
Sitecore.Pipelines.LoggedIn Namespace


Ticket Members

[image] [image]

Sitecore 6.4.1 API
Ticket Members
Ticket Class Constructors Methods See Also Send Feedback

The Ticket type exposes the following members.

Constructors

 | Name | Description
Public method | Ticket | Initializes a new instance of the Ticket class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides LoggedInProcessor..::..Process(LoggedInArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Ticket Class
Sitecore.Pipelines.LoggedIn Namespace


Ticket Constructor

[image]

Sitecore 6.4.1 API
Ticket Constructor
Ticket Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoggedIn
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Ticket()
Visual Basic
Public Sub New
Visual C++
public:
Ticket()

See Also

Ticket Class
Sitecore.Pipelines.LoggedIn Namespace


Ticket Methods

[image] [image]

Sitecore 6.4.1 API
Ticket Methods
Ticket Class See Also Send Feedback

The Ticket type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides LoggedInProcessor..::..Process(LoggedInArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Ticket Class
Sitecore.Pipelines.LoggedIn Namespace


Process Method

[image]

Sitecore 6.4.1 API
Ticket..::..Process Method
Ticket Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoggedIn
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    LoggedInArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As LoggedInArgs _
)
Visual C++
public:
virtual void Process(
    LoggedInArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.LoggedIn..::..LoggedInArgs
The arguments.

See Also

Ticket Class
Sitecore.Pipelines.LoggedIn Namespace


Sitecore.Pipelines.LoggingIn Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.LoggingIn Namespace
Send Feedback

Classes

 | Class | Description
Public class | CheckClientUser | Validates that the user has access to the start page.
Public class | CheckStartPage | Validates that the user has access to the start page.
Public class | ClearCache | Performs clear cache
Public class | LoggingInArgs | Argument class for ILoginProcessor implementations


CheckClientUser Class

[image]

Sitecore 6.4.1 API
CheckClientUser Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.LoggingIn
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CheckClientUser
Visual Basic
Public Class CheckClientUser
Visual C++
public ref class CheckClientUser

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.LoggingIn..::..CheckClientUser

See Also

CheckClientUser Members
Sitecore.Pipelines.LoggingIn Namespace


CheckClientUser Members

[image] [image]

Sitecore 6.4.1 API
CheckClientUser Members
CheckClientUser Class Constructors Methods See Also Send Feedback

The CheckClientUser type exposes the following members.

Constructors

 | Name | Description
Public method | CheckClientUser | Initializes a new instance of the CheckClientUser class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckClientUser Class
Sitecore.Pipelines.LoggingIn Namespace


CheckClientUser Constructor

[image]

Sitecore 6.4.1 API
CheckClientUser Constructor
CheckClientUser Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoggingIn
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CheckClientUser()
Visual Basic
Public Sub New
Visual C++
public:
CheckClientUser()

See Also

CheckClientUser Class
Sitecore.Pipelines.LoggingIn Namespace


CheckClientUser Methods

[image] [image]

Sitecore 6.4.1 API
CheckClientUser Methods
CheckClientUser Class See Also Send Feedback

The CheckClientUser type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckClientUser Class
Sitecore.Pipelines.LoggingIn Namespace


Process Method

[image]

Sitecore 6.4.1 API
CheckClientUser..::..Process Method
CheckClientUser Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoggingIn
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    LoggingInArgs args
)
Visual Basic
Public Sub Process ( _
    args As LoggingInArgs _
)
Visual C++
public:
void Process(
    LoggingInArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.LoggingIn..::..LoggingInArgs
The arguments.

See Also

CheckClientUser Class
Sitecore.Pipelines.LoggingIn Namespace


CheckStartPage Members

[image] [image]

Sitecore 6.4.1 API
CheckStartPage Members
CheckStartPage Class Constructors Methods See Also Send Feedback

The CheckStartPage type exposes the following members.

Constructors

 | Name | Description
Public method | CheckStartPage | Initializes a new instance of the CheckStartPage class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckStartPage Class
Sitecore.Pipelines.LoggingIn Namespace


Process Method

[image]

Sitecore 6.4.1 API
CheckStartPage..::..Process Method
CheckStartPage Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoggingIn
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    LoggingInArgs args
)
Visual Basic
Public Sub Process ( _
    args As LoggingInArgs _
)
Visual C++
public:
void Process(
    LoggingInArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.LoggingIn..::..LoggingInArgs
The arguments.

See Also

CheckStartPage Class
Sitecore.Pipelines.LoggingIn Namespace


ClearCache Class

[image]

Sitecore 6.4.1 API
ClearCache Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.LoggingIn
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ClearCache
Visual Basic
Public Class ClearCache
Visual C++
public ref class ClearCache

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.LoggingIn..::..ClearCache

See Also

ClearCache Members
Sitecore.Pipelines.LoggingIn Namespace


ClearCache Members

[image] [image]

Sitecore 6.4.1 API
ClearCache Members
ClearCache Class Constructors Methods See Also Send Feedback

The ClearCache type exposes the following members.

Constructors

 | Name | Description
Public method | ClearCache | Initializes a new instance of the ClearCache class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ClearCache Class
Sitecore.Pipelines.LoggingIn Namespace


ClearCache Constructor

[image]

Sitecore 6.4.1 API
ClearCache Constructor
ClearCache Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoggingIn
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ClearCache()
Visual Basic
Public Sub New
Visual C++
public:
ClearCache()

See Also

ClearCache Class
Sitecore.Pipelines.LoggingIn Namespace


ClearCache Methods

[image] [image]

Sitecore 6.4.1 API
ClearCache Methods
ClearCache Class See Also Send Feedback

The ClearCache type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ClearCache Class
Sitecore.Pipelines.LoggingIn Namespace


LoggingInArgs Class

[image]

Sitecore 6.4.1 API
LoggingInArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.LoggingIn
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class LoggingInArgs : PipelineArgs
Visual Basic
<SerializableAttribute> _
Public Class LoggingInArgs _
    Inherits PipelineArgs
Visual C++
[SerializableAttribute]
public ref class LoggingInArgs : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Pipelines.LoggingIn..::..LoggingInArgs

See Also

LoggingInArgs Members
Sitecore.Pipelines.LoggingIn Namespace


LoggingInArgs Members

[image] [image]

Sitecore 6.4.1 API
LoggingInArgs Members
LoggingInArgs Class Constructors Methods Properties See Also Send Feedback

The LoggingInArgs type exposes the following members.

Constructors

 | Name | Description
Public method | LoggingInArgs()()()() | Initializes a new instance of the LoggingInArgs class.
Protected method | LoggingInArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the LoggingInArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Password | Gets or sets the password.
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | StartUrl | Gets or sets the start URL.
Public property | Success | Gets or sets a value indicating whether this LoggingInArgs is success.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
Public property | Username | Gets or sets the username.

See Also

LoggingInArgs Class
Sitecore.Pipelines.LoggingIn Namespace


LoggingInArgs Constructor

[image] [image]

Sitecore 6.4.1 API
LoggingInArgs Constructor
LoggingInArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LoggingInArgs()()()() | Initializes a new instance of the LoggingInArgs class.
Protected method | LoggingInArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the LoggingInArgs class.

See Also

LoggingInArgs Class
LoggingInArgs Members
Sitecore.Pipelines.LoggingIn Namespace


LoggingInArgs Constructor

[image]

Sitecore 6.4.1 API
LoggingInArgs Constructor
LoggingInArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoggingIn
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LoggingInArgs()
Visual Basic
Public Sub New
Visual C++
public:
LoggingInArgs()

See Also

LoggingInArgs Class
LoggingInArgs Overload
Sitecore.Pipelines.LoggingIn Namespace


LoggingInArgs Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
LoggingInArgs Constructor (SerializationInfo, StreamingContext)
LoggingInArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoggingIn
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected LoggingInArgs(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
LoggingInArgs(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

LoggingInArgs Class
LoggingInArgs Overload
Sitecore.Pipelines.LoggingIn Namespace


LoggingInArgs Methods

[image] [image]

Sitecore 6.4.1 API
LoggingInArgs Methods
LoggingInArgs Class See Also Send Feedback

The LoggingInArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoggingInArgs Class
Sitecore.Pipelines.LoggingIn Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
LoggingInArgs..::..AddMessage Method
LoggingInArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

LoggingInArgs Class
LoggingInArgs Members
Sitecore.Pipelines.LoggingIn Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
LoggingInArgs..::..GetMessages Method
LoggingInArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

LoggingInArgs Class
LoggingInArgs Members
Sitecore.Pipelines.LoggingIn Namespace


GetObjectData Method

[image]

Sitecore 6.4.1 API
LoggingInArgs..::..GetObjectData Method
LoggingInArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoggingIn
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System.Security..::..SecurityException | The caller does not have the required permission.

See Also

LoggingInArgs Class
Sitecore.Pipelines.LoggingIn Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
LoggingInArgs..::..Suspend Method
LoggingInArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

LoggingInArgs Class
LoggingInArgs Members
Sitecore.Pipelines.LoggingIn Namespace


LoggingInArgs Properties

[image] [image]

Sitecore 6.4.1 API
LoggingInArgs Properties
LoggingInArgs Class See Also Send Feedback

The LoggingInArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Password | Gets or sets the password.
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | StartUrl | Gets or sets the start URL.
Public property | Success | Gets or sets a value indicating whether this LoggingInArgs is success.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
Public property | Username | Gets or sets the username.

See Also

LoggingInArgs Class
Sitecore.Pipelines.LoggingIn Namespace


Password Property

[image]

Sitecore 6.4.1 API
LoggingInArgs..::..Password Property
LoggingInArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoggingIn
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Password { get; set; }
Visual Basic
Public Property Password As String
    Get
    Set
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

Field Value

The password.

See Also

LoggingInArgs Class
Sitecore.Pipelines.LoggingIn Namespace


StartUrl Property

[image]

Sitecore 6.4.1 API
LoggingInArgs..::..StartUrl Property
LoggingInArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoggingIn
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string StartUrl { get; set; }
Visual Basic
Public Property StartUrl As String
    Get
    Set
Visual C++
public:
property String^ StartUrl {
    String^ get ();
    void set (String^ value);
}

Field Value

The start URL.

See Also

LoggingInArgs Class
Sitecore.Pipelines.LoggingIn Namespace


Username Property

[image]

Sitecore 6.4.1 API
LoggingInArgs..::..Username Property
LoggingInArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.LoggingIn
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Username { get; set; }
Visual Basic
Public Property Username As String
    Get
    Set
Visual C++
public:
property String^ Username {
    String^ get ();
    void set (String^ value);
}

Field Value

The username.

See Also

LoggingInArgs Class
Sitecore.Pipelines.LoggingIn Namespace


Sitecore.Pipelines.Login Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.Login Namespace
Send Feedback

Classes

 | Class | Description
Public class | CheckStartPage | Obsolete. Validates that the user has access to the start page.
Public class | Login | Obsolete. Logins the user into the system.
Public class | LoginArgs | Obsolete. Argument class for ILoginProcessor implementations
Public class | LoginCookie | Obsolete. Stores login information is a cookie.
Public class | Settings | Obsolete. Loads the user settings.
Public class | Ticket | Obsolete. Processor for storing a ticket.


CheckStartPage Class

[image]

Sitecore 6.4.1 API
CheckStartPage Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Login
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public class CheckStartPage
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Class CheckStartPage
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public ref class CheckStartPage

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Login..::..CheckStartPage

See Also

CheckStartPage Members
Sitecore.Pipelines.Login Namespace


CheckStartPage Members

[image] [image]

Sitecore 6.4.1 API
CheckStartPage Members
CheckStartPage Class Constructors Methods See Also Send Feedback

The CheckStartPage type exposes the following members.

Constructors

 | Name | Description
Public method | CheckStartPage | Initializes a new instance of the CheckStartPage class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckStartPage Class
Sitecore.Pipelines.Login Namespace


CheckStartPage Constructor

[image]

Sitecore 6.4.1 API
CheckStartPage Constructor
CheckStartPage Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Login
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CheckStartPage()
Visual Basic
Public Sub New
Visual C++
public:
CheckStartPage()

See Also

CheckStartPage Class
Sitecore.Pipelines.Login Namespace


CheckStartPage Methods

[image] [image]

Sitecore 6.4.1 API
CheckStartPage Methods
CheckStartPage Class See Also Send Feedback

The CheckStartPage type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckStartPage Class
Sitecore.Pipelines.Login Namespace


Process Method

[image]

Sitecore 6.4.1 API
CheckStartPage..::..Process Method
CheckStartPage Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Login
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    LoginArgs args
)
Visual Basic
Public Sub Process ( _
    args As LoginArgs _
)
Visual C++
public:
void Process(
    LoginArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Login..::..LoginArgs
The arguments.

See Also

CheckStartPage Class
Sitecore.Pipelines.Login Namespace


Login Class

[image]

Sitecore 6.4.1 API
Login Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Login
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public class Login
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Class Login
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public ref class Login

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Login..::..Login

See Also

Login Members
Sitecore.Pipelines.Login Namespace


Login Members

[image] [image]

Sitecore 6.4.1 API
Login Members
Login Class Constructors Methods See Also Send Feedback

The Login type exposes the following members.

Constructors

 | Name | Description
Public method | Login | Initializes a new instance of the Login class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Login Class
Sitecore.Pipelines.Login Namespace


Login Constructor

[image]

Sitecore 6.4.1 API
Login Constructor
Login Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Login
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Login()
Visual Basic
Public Sub New
Visual C++
public:
Login()

See Also

Login Class
Sitecore.Pipelines.Login Namespace


Login Methods

[image] [image]

Sitecore 6.4.1 API
Login Methods
Login Class See Also Send Feedback

The Login type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Login Class
Sitecore.Pipelines.Login Namespace


Process Method

[image]

Sitecore 6.4.1 API
Login..::..Process Method
Login Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Login
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    LoginArgs args
)
Visual Basic
Public Sub Process ( _
    args As LoginArgs _
)
Visual C++
public:
void Process(
    LoginArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Login..::..LoginArgs
The arguments.

See Also

Login Class
Sitecore.Pipelines.Login Namespace


LoginArgs Class

[image]

Sitecore 6.4.1 API
LoginArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Login
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
[ObsoleteAttribute("Deprecated - Use LoggingInArgs or LoggedInArgs instead.")]
public class LoginArgs : PipelineArgs
Visual Basic
<SerializableAttribute> _
<ObsoleteAttribute("Deprecated - Use LoggingInArgs or LoggedInArgs instead.")> _
Public Class LoginArgs _
    Inherits PipelineArgs
Visual C++
[SerializableAttribute]
[ObsoleteAttribute(L"Deprecated - Use LoggingInArgs or LoggedInArgs instead.")]
public ref class LoginArgs : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Pipelines.Login..::..LoginArgs

See Also

LoginArgs Members
Sitecore.Pipelines.Login Namespace


LoginArgs Members

[image] [image]

Sitecore 6.4.1 API
LoginArgs Members
LoginArgs Class Constructors Methods Properties See Also Send Feedback

The LoginArgs type exposes the following members.

Constructors

 | Name | Description
Protected method | LoginArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the LoginArgs class.
Public method | LoginArgs(String, String, String, String, Boolean) | Initializes a new instance of the LoginArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | DisplayMode | Gets or sets the display mode.
Public property | Error | Gets or sets the error.
Public property | IsPostBack | Gets a value indicating whether this instance is a post back.
Public property | IsRelogin | Gets or sets a value indicating whether this LoginArgs is relogin.
Public property | Language | Gets or sets the language.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Password | Gets or sets the password.
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Redirect | Gets or sets the redirect URL.
Public property | StartUrl | Gets or sets the start URL.
Public property | Success | Gets or sets a value indicating whether this LoginArgs is success.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
Public property | Username | Gets or sets the username.
Public property | Warning | Gets or sets the warning.

See Also

LoginArgs Class
Sitecore.Pipelines.Login Namespace


LoginArgs Constructor

[image] [image]

Sitecore 6.4.1 API
LoginArgs Constructor
LoginArgs Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | LoginArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the LoginArgs class.
Public method | LoginArgs(String, String, String, String, Boolean) | Initializes a new instance of the LoginArgs class.

See Also

LoginArgs Class
LoginArgs Members
Sitecore.Pipelines.Login Namespace


LoginArgs Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
LoginArgs Constructor (SerializationInfo, StreamingContext)
LoginArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Login
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected LoginArgs(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
LoginArgs(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

LoginArgs Class
LoginArgs Overload
Sitecore.Pipelines.Login Namespace


LoginArgs Constructor (String, String, String, String, Boolean)

[image]

Sitecore 6.4.1 API
LoginArgs Constructor (String, String, String, String, Boolean)
LoginArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Login
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LoginArgs(
    string username,
    string password,
    string language,
    string startUrl,
    bool isPostBack
)
Visual Basic
Public Sub New ( _
    username As String, _
    password As String, _
    language As String, _
    startUrl As String, _
    isPostBack As Boolean _
)
Visual C++
public:
LoginArgs(
    String^ username,
    String^ password,
    String^ language,
    String^ startUrl,
    bool isPostBack
)

Parameters

username
Type: System..::..String
The username.
password
Type: System..::..String
The password.
language
Type: System..::..String
The language.
startUrl
Type: System..::..String
The start URL.
isPostBack
Type: System..::..Boolean
if set to true this instance is a post back.

See Also

LoginArgs Class
LoginArgs Overload
Sitecore.Pipelines.Login Namespace


LoginArgs Methods

[image] [image]

Sitecore 6.4.1 API
LoginArgs Methods
LoginArgs Class See Also Send Feedback

The LoginArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoginArgs Class
Sitecore.Pipelines.Login Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
LoginArgs..::..AddMessage Method
LoginArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

LoginArgs Class
LoginArgs Members
Sitecore.Pipelines.Login Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
LoginArgs..::..GetMessages Method
LoginArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

LoginArgs Class
LoginArgs Members
Sitecore.Pipelines.Login Namespace


GetObjectData Method

[image]

Sitecore 6.4.1 API
LoginArgs..::..GetObjectData Method
LoginArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Login
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System.Security..::..SecurityException | The caller does not have the required permission.

See Also

LoginArgs Class
Sitecore.Pipelines.Login Namespace


LoginArgs Properties

[image] [image]

Sitecore 6.4.1 API
LoginArgs Properties
LoginArgs Class See Also Send Feedback

The LoginArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | DisplayMode | Gets or sets the display mode.
Public property | Error | Gets or sets the error.
Public property | IsPostBack | Gets a value indicating whether this instance is a post back.
Public property | IsRelogin | Gets or sets a value indicating whether this LoginArgs is relogin.
Public property | Language | Gets or sets the language.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Password | Gets or sets the password.
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Redirect | Gets or sets the redirect URL.
Public property | StartUrl | Gets or sets the start URL.
Public property | Success | Gets or sets a value indicating whether this LoginArgs is success.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
Public property | Username | Gets or sets the username.
Public property | Warning | Gets or sets the warning.

See Also

LoginArgs Class
Sitecore.Pipelines.Login Namespace


DisplayMode Property

[image]

Sitecore 6.4.1 API
LoginArgs..::..DisplayMode Property
LoginArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Login
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string DisplayMode { get; set; }
Visual Basic
Public Property DisplayMode As String
    Get
    Set
Visual C++
public:
property String^ DisplayMode {
    String^ get ();
    void set (String^ value);
}

Field Value

The display mode.

See Also

LoginArgs Class
Sitecore.Pipelines.Login Namespace


Error Property

[image]

Sitecore 6.4.1 API
LoginArgs..::..Error Property
LoginArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Login
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Error { get; set; }
Visual Basic
Public Property Error As String
    Get
    Set
Visual C++
public:
property String^ Error {
    String^ get ();
    void set (String^ value);
}

Field Value

The error.

See Also

LoginArgs Class
Sitecore.Pipelines.Login Namespace


IsRelogin Property

[image]

Sitecore 6.4.1 API
LoginArgs..::..IsRelogin Property
LoginArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Login
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsRelogin { get; set; }
Visual Basic
Public Property IsRelogin As Boolean
    Get
    Set
Visual C++
public:
property bool IsRelogin {
    bool get ();
    void set (bool value);
}

Field Value

true if relogin; otherwise, false.

See Also

LoginArgs Class
Sitecore.Pipelines.Login Namespace


Language Property

[image]

Sitecore 6.4.1 API
LoginArgs..::..Language Property
LoginArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Login
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Language { get; set; }
Visual Basic
Public Property Language As String
    Get
    Set
Visual C++
public:
property String^ Language {
    String^ get ();
    void set (String^ value);
}

Field Value

The language.

See Also

LoginArgs Class
Sitecore.Pipelines.Login Namespace


Password Property

[image]

Sitecore 6.4.1 API
LoginArgs..::..Password Property
LoginArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Login
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Password { get; set; }
Visual Basic
Public Property Password As String
    Get
    Set
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

Field Value

The password.

See Also

LoginArgs Class
Sitecore.Pipelines.Login Namespace


Redirect Property

[image]

Sitecore 6.4.1 API
LoginArgs..::..Redirect Property
LoginArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Login
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Redirect { get; set; }
Visual Basic
Public Property Redirect As String
    Get
    Set
Visual C++
public:
property String^ Redirect {
    String^ get ();
    void set (String^ value);
}

Field Value

The redirect URL.

See Also

LoginArgs Class
Sitecore.Pipelines.Login Namespace


StartUrl Property

[image]

Sitecore 6.4.1 API
LoginArgs..::..StartUrl Property
LoginArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Login
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string StartUrl { get; set; }
Visual Basic
Public Property StartUrl As String
    Get
    Set
Visual C++
public:
property String^ StartUrl {
    String^ get ();
    void set (String^ value);
}

Field Value

The start URL.

See Also

LoginArgs Class
Sitecore.Pipelines.Login Namespace


Success Property

[image]

Sitecore 6.4.1 API
LoginArgs..::..Success Property
LoginArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Login
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Success { get; set; }
Visual Basic
Public Property Success As Boolean
    Get
    Set
Visual C++
public:
property bool Success {
    bool get ();
    void set (bool value);
}

Field Value

true if success; otherwise, false.

See Also

LoginArgs Class
Sitecore.Pipelines.Login Namespace


Username Property

[image]

Sitecore 6.4.1 API
LoginArgs..::..Username Property
LoginArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Login
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Username { get; set; }
Visual Basic
Public Property Username As String
    Get
    Set
Visual C++
public:
property String^ Username {
    String^ get ();
    void set (String^ value);
}

Field Value

The username.

See Also

LoginArgs Class
Sitecore.Pipelines.Login Namespace


LoginCookie Class

[image]

Sitecore 6.4.1 API
LoginCookie Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Login
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public class LoginCookie
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Class LoginCookie
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public ref class LoginCookie

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Login..::..LoginCookie

See Also

LoginCookie Members
Sitecore.Pipelines.Login Namespace


LoginCookie Members

[image] [image]

Sitecore 6.4.1 API
LoginCookie Members
LoginCookie Class Constructors Methods See Also Send Feedback

The LoginCookie type exposes the following members.

Constructors

 | Name | Description
Public method | LoginCookie | Initializes a new instance of the LoginCookie class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoginCookie Class
Sitecore.Pipelines.Login Namespace


LoginCookie Constructor

[image]

Sitecore 6.4.1 API
LoginCookie Constructor
LoginCookie Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Login
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LoginCookie()
Visual Basic
Public Sub New
Visual C++
public:
LoginCookie()

See Also

LoginCookie Class
Sitecore.Pipelines.Login Namespace


LoginCookie Methods

[image] [image]

Sitecore 6.4.1 API
LoginCookie Methods
LoginCookie Class See Also Send Feedback

The LoginCookie type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoginCookie Class
Sitecore.Pipelines.Login Namespace


Process Method

[image]

Sitecore 6.4.1 API
LoginCookie..::..Process Method
LoginCookie Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Login
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    LoginArgs args
)
Visual Basic
Public Sub Process ( _
    args As LoginArgs _
)
Visual C++
public:
void Process(
    LoginArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Login..::..LoginArgs
The arguments.

See Also

LoginCookie Class
Sitecore.Pipelines.Login Namespace


Settings Class

[image]

Sitecore 6.4.1 API
Settings Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Login
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public class Settings
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Class Settings
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public ref class Settings

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Login..::..Settings

See Also

Settings Members
Sitecore.Pipelines.Login Namespace


Settings Members

[image] [image]

Sitecore 6.4.1 API
Settings Members
Settings Class Constructors Methods See Also Send Feedback

The Settings type exposes the following members.

Constructors

 | Name | Description
Public method | Settings | Initializes a new instance of the Settings class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Settings Class
Sitecore.Pipelines.Login Namespace


Settings Constructor

[image]

Sitecore 6.4.1 API
Settings Constructor
Settings Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Login
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Settings()
Visual Basic
Public Sub New
Visual C++
public:
Settings()

See Also

Settings Class
Sitecore.Pipelines.Login Namespace


Settings Methods

[image] [image]

Sitecore 6.4.1 API
Settings Methods
Settings Class See Also Send Feedback

The Settings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Settings Class
Sitecore.Pipelines.Login Namespace


Process Method

[image]

Sitecore 6.4.1 API
Settings..::..Process Method
Settings Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Login
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    LoginArgs args
)
Visual Basic
Public Sub Process ( _
    args As LoginArgs _
)
Visual C++
public:
void Process(
    LoginArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Login..::..LoginArgs
The arguments.

See Also

Settings Class
Sitecore.Pipelines.Login Namespace


Ticket Class

[image]

Sitecore 6.4.1 API
Ticket Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Login
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public class Ticket
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Class Ticket
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public ref class Ticket

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Login..::..Ticket

See Also

Ticket Members
Sitecore.Pipelines.Login Namespace


Ticket Members

[image] [image]

Sitecore 6.4.1 API
Ticket Members
Ticket Class Constructors Methods See Also Send Feedback

The Ticket type exposes the following members.

Constructors

 | Name | Description
Public method | Ticket | Initializes a new instance of the Ticket class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Ticket Class
Sitecore.Pipelines.Login Namespace


Ticket Constructor

[image]

Sitecore 6.4.1 API
Ticket Constructor
Ticket Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Login
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Ticket()
Visual Basic
Public Sub New
Visual C++
public:
Ticket()

See Also

Ticket Class
Sitecore.Pipelines.Login Namespace


Ticket Methods

[image] [image]

Sitecore 6.4.1 API
Ticket Methods
Ticket Class See Also Send Feedback

The Ticket type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Ticket Class
Sitecore.Pipelines.Login Namespace


Process Method

[image]

Sitecore 6.4.1 API
Ticket..::..Process Method
Ticket Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Login
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    LoginArgs args
)
Visual Basic
Public Sub Process ( _
    args As LoginArgs _
)
Visual C++
public:
void Process(
    LoginArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Login..::..LoginArgs
The arguments.

See Also

Ticket Class
Sitecore.Pipelines.Login Namespace


Sitecore.Pipelines.Logout Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.Logout Namespace
Send Feedback

Classes

 | Class | Description
Public class | CheckModified | Check for modified flag in Sheer.
Public class | ClearCache | Performs clear cache related to user
Public class | ClearSession | Clears the session.
Public class | GotoLogin | Redirects the browser to the login page.
Public class | LogoutArgs | Argument class for the Logout pipeline.
Public class | RemoveTicket | Removes a login ticket.


CheckModified Class

[image]

Sitecore 6.4.1 API
CheckModified Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Logout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CheckModified
Visual Basic
Public Class CheckModified
Visual C++
public ref class CheckModified

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Logout..::..CheckModified

See Also

CheckModified Members
Sitecore.Pipelines.Logout Namespace


CheckModified Members

[image] [image]

Sitecore 6.4.1 API
CheckModified Members
CheckModified Class Constructors Methods See Also Send Feedback

The CheckModified type exposes the following members.

Constructors

 | Name | Description
Public method | CheckModified | Initializes a new instance of the CheckModified class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckModified Class
Sitecore.Pipelines.Logout Namespace


CheckModified Constructor

[image]

Sitecore 6.4.1 API
CheckModified Constructor
CheckModified Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Logout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CheckModified()
Visual Basic
Public Sub New
Visual C++
public:
CheckModified()

See Also

CheckModified Class
Sitecore.Pipelines.Logout Namespace


CheckModified Methods

[image] [image]

Sitecore 6.4.1 API
CheckModified Methods
CheckModified Class See Also Send Feedback

The CheckModified type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckModified Class
Sitecore.Pipelines.Logout Namespace


Process Method

[image]

Sitecore 6.4.1 API
CheckModified..::..Process Method
CheckModified Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Logout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    LogoutArgs args
)
Visual Basic
Public Sub Process ( _
    args As LogoutArgs _
)
Visual C++
public:
void Process(
    LogoutArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Logout..::..LogoutArgs
The arguments.

See Also

CheckModified Class
Sitecore.Pipelines.Logout Namespace


ClearCache Class

[image]

Sitecore 6.4.1 API
ClearCache Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Logout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ClearCache
Visual Basic
Public Class ClearCache
Visual C++
public ref class ClearCache

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Logout..::..ClearCache

See Also

ClearCache Members
Sitecore.Pipelines.Logout Namespace


ClearCache Members

[image] [image]

Sitecore 6.4.1 API
ClearCache Members
ClearCache Class Constructors Methods See Also Send Feedback

The ClearCache type exposes the following members.

Constructors

 | Name | Description
Public method | ClearCache | Initializes a new instance of the ClearCache class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ClearCache Class
Sitecore.Pipelines.Logout Namespace


ClearCache Constructor

[image]

Sitecore 6.4.1 API
ClearCache Constructor
ClearCache Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Logout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ClearCache()
Visual Basic
Public Sub New
Visual C++
public:
ClearCache()

See Also

ClearCache Class
Sitecore.Pipelines.Logout Namespace


ClearCache Methods

[image] [image]

Sitecore 6.4.1 API
ClearCache Methods
ClearCache Class See Also Send Feedback

The ClearCache type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ClearCache Class
Sitecore.Pipelines.Logout Namespace


Process Method

[image]

Sitecore 6.4.1 API
ClearCache..::..Process Method
ClearCache Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Logout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    LogoutArgs args
)
Visual Basic
Public Sub Process ( _
    args As LogoutArgs _
)
Visual C++
public:
void Process(
    LogoutArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Logout..::..LogoutArgs
The args.

See Also

ClearCache Class
Sitecore.Pipelines.Logout Namespace


ClearSession Class

[image]

Sitecore 6.4.1 API
ClearSession Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Logout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ClearSession
Visual Basic
Public Class ClearSession
Visual C++
public ref class ClearSession

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Logout..::..ClearSession

See Also

ClearSession Members
Sitecore.Pipelines.Logout Namespace


ClearSession Members

[image] [image]

Sitecore 6.4.1 API
ClearSession Members
ClearSession Class Constructors Methods See Also Send Feedback

The ClearSession type exposes the following members.

Constructors

 | Name | Description
Public method | ClearSession | Initializes a new instance of the ClearSession class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ClearSession Class
Sitecore.Pipelines.Logout Namespace


ClearSession Constructor

[image]

Sitecore 6.4.1 API
ClearSession Constructor
ClearSession Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Logout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ClearSession()
Visual Basic
Public Sub New
Visual C++
public:
ClearSession()

See Also

ClearSession Class
Sitecore.Pipelines.Logout Namespace


ClearSession Methods

[image] [image]

Sitecore 6.4.1 API
ClearSession Methods
ClearSession Class See Also Send Feedback

The ClearSession type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ClearSession Class
Sitecore.Pipelines.Logout Namespace


Process Method

[image]

Sitecore 6.4.1 API
ClearSession..::..Process Method
ClearSession Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Logout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    LogoutArgs args
)
Visual Basic
Public Sub Process ( _
    args As LogoutArgs _
)
Visual C++
public:
void Process(
    LogoutArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Logout..::..LogoutArgs
The arguments.

See Also

ClearSession Class
Sitecore.Pipelines.Logout Namespace


GotoLogin Class

[image]

Sitecore 6.4.1 API
GotoLogin Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Logout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GotoLogin
Visual Basic
Public Class GotoLogin
Visual C++
public ref class GotoLogin

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Logout..::..GotoLogin

See Also

GotoLogin Members
Sitecore.Pipelines.Logout Namespace


GotoLogin Members

[image] [image]

Sitecore 6.4.1 API
GotoLogin Members
GotoLogin Class Constructors Methods See Also Send Feedback

The GotoLogin type exposes the following members.

Constructors

 | Name | Description
Public method | GotoLogin | Initializes a new instance of the GotoLogin class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GotoLogin Class
Sitecore.Pipelines.Logout Namespace


GotoLogin Constructor

[image]

Sitecore 6.4.1 API
GotoLogin Constructor
GotoLogin Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Logout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GotoLogin()
Visual Basic
Public Sub New
Visual C++
public:
GotoLogin()

See Also

GotoLogin Class
Sitecore.Pipelines.Logout Namespace


GotoLogin Methods

[image] [image]

Sitecore 6.4.1 API
GotoLogin Methods
GotoLogin Class See Also Send Feedback

The GotoLogin type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GotoLogin Class
Sitecore.Pipelines.Logout Namespace


Process Method

[image]

Sitecore 6.4.1 API
GotoLogin..::..Process Method
GotoLogin Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Logout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    LogoutArgs args
)
Visual Basic
Public Sub Process ( _
    args As LogoutArgs _
)
Visual C++
public:
void Process(
    LogoutArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Logout..::..LogoutArgs
The arguments.

See Also

GotoLogin Class
Sitecore.Pipelines.Logout Namespace


LogoutArgs Class

[image]

Sitecore 6.4.1 API
LogoutArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Logout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class LogoutArgs : ClientPipelineArgs, ISerializable
Visual Basic
<SerializableAttribute> _
Public Class LogoutArgs _
    Inherits ClientPipelineArgs _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class LogoutArgs : public ClientPipelineArgs,
    ISerializable

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Web.UI.Sheer..::..ClientPipelineArgs
Sitecore.Pipelines.Logout..::..LogoutArgs

See Also

LogoutArgs Members
Sitecore.Pipelines.Logout Namespace


LogoutArgs Members

[image] [image]

Sitecore 6.4.1 API
LogoutArgs Members
LogoutArgs Class Constructors Methods Properties See Also Send Feedback

The LogoutArgs type exposes the following members.

Constructors

 | Name | Description
Public method | LogoutArgs()()()() | Initializes a new instance of the LogoutArgs class.
Protected method | LogoutArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the LogoutArgs class from a serialization context.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ClientPipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from ClientPipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WaitForPostBack()()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Public method | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CarryResultToNextProcessor | Gets or sets a value indicating whether the ClientPipelineArgs carries the result to next processor. (Inherited from ClientPipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | HasResult | Gets a value indicating whether this instance has a result. (Inherited from ClientPipelineArgs.)
Public property | IsFullscreen | Gets a value indicating whether this session is fullscreen.
Public property | IsPostBack | Gets or sets a value that indicates if the processor was invoked as part of a user response. (Inherited from ClientPipelineArgs.)
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Parameters | Gets or sets the parameters. (Inherited from ClientPipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Properties | Gets the properties. (Inherited from ClientPipelineArgs.)
Public property | RedirectUrl | Gets or sets the redirect URL.
Public property | Result | Gets or sets the value that was posted as part of a Sheer response. (Inherited from ClientPipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

LogoutArgs Class
Sitecore.Pipelines.Logout Namespace


LogoutArgs Constructor

[image] [image]

Sitecore 6.4.1 API
LogoutArgs Constructor
LogoutArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LogoutArgs()()()() | Initializes a new instance of the LogoutArgs class.
Protected method | LogoutArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the LogoutArgs class from a serialization context.

See Also

LogoutArgs Class
LogoutArgs Members
Sitecore.Pipelines.Logout Namespace


LogoutArgs Constructor

[image]

Sitecore 6.4.1 API
LogoutArgs Constructor
LogoutArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Logout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LogoutArgs()
Visual Basic
Public Sub New
Visual C++
public:
LogoutArgs()

See Also

LogoutArgs Class
LogoutArgs Overload
Sitecore.Pipelines.Logout Namespace


LogoutArgs Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
LogoutArgs Constructor (SerializationInfo, StreamingContext)
LogoutArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Logout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected LogoutArgs(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
LogoutArgs(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The serialized data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

LogoutArgs Class
LogoutArgs Overload
Sitecore.Pipelines.Logout Namespace


LogoutArgs Methods

[image] [image]

Sitecore 6.4.1 API
LogoutArgs Methods
LogoutArgs Class See Also Send Feedback

The LogoutArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ClientPipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from ClientPipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WaitForPostBack()()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Public method | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)

See Also

LogoutArgs Class
Sitecore.Pipelines.Logout Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
LogoutArgs..::..AddMessage Method
LogoutArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

LogoutArgs Class
LogoutArgs Members
Sitecore.Pipelines.Logout Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
LogoutArgs..::..GetMessages Method
LogoutArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

LogoutArgs Class
LogoutArgs Members
Sitecore.Pipelines.Logout Namespace


GetObjectData Method

[image]

Sitecore 6.4.1 API
LogoutArgs..::..GetObjectData Method
LogoutArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Logout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System.Security..::..SecurityException | The caller does not have the required permission.

See Also

LogoutArgs Class
Sitecore.Pipelines.Logout Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
LogoutArgs..::..Suspend Method
LogoutArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

LogoutArgs Class
LogoutArgs Members
Sitecore.Pipelines.Logout Namespace


WaitForPostBack Method

[image] [image]

Sitecore 6.4.1 API
LogoutArgs..::..WaitForPostBack Method
LogoutArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaitForPostBack()()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Public method | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)

See Also

LogoutArgs Class
LogoutArgs Members
Sitecore.Pipelines.Logout Namespace


LogoutArgs Properties

[image] [image]

Sitecore 6.4.1 API
LogoutArgs Properties
LogoutArgs Class See Also Send Feedback

The LogoutArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CarryResultToNextProcessor | Gets or sets a value indicating whether the ClientPipelineArgs carries the result to next processor. (Inherited from ClientPipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | HasResult | Gets a value indicating whether this instance has a result. (Inherited from ClientPipelineArgs.)
Public property | IsFullscreen | Gets a value indicating whether this session is fullscreen.
Public property | IsPostBack | Gets or sets a value that indicates if the processor was invoked as part of a user response. (Inherited from ClientPipelineArgs.)
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Parameters | Gets or sets the parameters. (Inherited from ClientPipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Properties | Gets the properties. (Inherited from ClientPipelineArgs.)
Public property | RedirectUrl | Gets or sets the redirect URL.
Public property | Result | Gets or sets the value that was posted as part of a Sheer response. (Inherited from ClientPipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

LogoutArgs Class
Sitecore.Pipelines.Logout Namespace


IsFullscreen Property

[image]

Sitecore 6.4.1 API
LogoutArgs..::..IsFullscreen Property
LogoutArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Logout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsFullscreen { get; }
Visual Basic
Public ReadOnly Property IsFullscreen As Boolean
    Get
Visual C++
public:
property bool IsFullscreen {
    bool get ();
}

Field Value

true if this session is fullscreen; otherwise, false.

See Also

LogoutArgs Class
Sitecore.Pipelines.Logout Namespace


RedirectUrl Property

[image]

Sitecore 6.4.1 API
LogoutArgs..::..RedirectUrl Property
LogoutArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Logout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UrlString RedirectUrl { get; set; }
Visual Basic
Public Property RedirectUrl As UrlString
    Get
    Set
Visual C++
public:
property UrlString^ RedirectUrl {
    UrlString^ get ();
    void set (UrlString^ value);
}

Field Value

The redirect URL.

See Also

LogoutArgs Class
Sitecore.Pipelines.Logout Namespace


RemoveTicket Class

[image]

Sitecore 6.4.1 API
RemoveTicket Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Logout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RemoveTicket
Visual Basic
Public Class RemoveTicket
Visual C++
public ref class RemoveTicket

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Logout..::..RemoveTicket

See Also

RemoveTicket Members
Sitecore.Pipelines.Logout Namespace


RemoveTicket Constructor

[image]

Sitecore 6.4.1 API
RemoveTicket Constructor
RemoveTicket Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Logout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RemoveTicket()
Visual Basic
Public Sub New
Visual C++
public:
RemoveTicket()

See Also

RemoveTicket Class
Sitecore.Pipelines.Logout Namespace


RemoveTicket Methods

[image] [image]

Sitecore 6.4.1 API
RemoveTicket Methods
RemoveTicket Class See Also Send Feedback

The RemoveTicket type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RemoveTicket Class
Sitecore.Pipelines.Logout Namespace


Process Method

[image]

Sitecore 6.4.1 API
RemoveTicket..::..Process Method
RemoveTicket Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Logout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    LogoutArgs args
)
Visual Basic
Public Sub Process ( _
    args As LogoutArgs _
)
Visual C++
public:
void Process(
    LogoutArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Logout..::..LogoutArgs
The arguments.

See Also

RemoveTicket Class
Sitecore.Pipelines.Logout Namespace


ConvertToXHtml Class

[image]

Sitecore 6.4.1 API
ConvertToXHtml Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.ParseDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ConvertToXHtml
Visual Basic
Public Class ConvertToXHtml
Visual C++
public ref class ConvertToXHtml

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.ParseDocx..::..ConvertToXHtml

See Also

ConvertToXHtml Members
Sitecore.Pipelines.ParseDocx Namespace


ConvertToXHtml Members

[image] [image]

Sitecore 6.4.1 API
ConvertToXHtml Members
ConvertToXHtml Class Constructors Methods See Also Send Feedback

The ConvertToXHtml type exposes the following members.

Constructors

 | Name | Description
Public method | ConvertToXHtml | Initializes a new instance of the ConvertToXHtml class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConvertToXHtml Class
Sitecore.Pipelines.ParseDocx Namespace


ConvertToXHtml Constructor

[image]

Sitecore 6.4.1 API
ConvertToXHtml Constructor
ConvertToXHtml Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ParseDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ConvertToXHtml()
Visual Basic
Public Sub New
Visual C++
public:
ConvertToXHtml()

See Also

ConvertToXHtml Class
Sitecore.Pipelines.ParseDocx Namespace


ConvertToXHtml Methods

[image] [image]

Sitecore 6.4.1 API
ConvertToXHtml Methods
ConvertToXHtml Class See Also Send Feedback

The ConvertToXHtml type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConvertToXHtml Class
Sitecore.Pipelines.ParseDocx Namespace


Process Method

[image]

Sitecore 6.4.1 API
ConvertToXHtml..::..Process Method
ConvertToXHtml Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ParseDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    ParseDocxArgs args
)
Visual Basic
Public Sub Process ( _
    args As ParseDocxArgs _
)
Visual C++
public:
void Process(
    ParseDocxArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.ParseDocx..::..ParseDocxArgs
The args.

See Also

ConvertToXHtml Class
Sitecore.Pipelines.ParseDocx Namespace


ExtractEmbeddedImages Class

[image]

Sitecore 6.4.1 API
ExtractEmbeddedImages Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.ParseDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ExtractEmbeddedImages
Visual Basic
Public Class ExtractEmbeddedImages
Visual C++
public ref class ExtractEmbeddedImages

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.ParseDocx..::..ExtractEmbeddedImages

See Also

ExtractEmbeddedImages Members
Sitecore.Pipelines.ParseDocx Namespace


ExtractEmbeddedImages Members

[image] [image]

Sitecore 6.4.1 API
ExtractEmbeddedImages Members
ExtractEmbeddedImages Class Constructors Methods See Also Send Feedback

The ExtractEmbeddedImages type exposes the following members.

Constructors

 | Name | Description
Public method | ExtractEmbeddedImages | Initializes a new instance of the ExtractEmbeddedImages class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetKey | Gets the key.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExtractEmbeddedImages Class
Sitecore.Pipelines.ParseDocx Namespace


ExtractEmbeddedImages Constructor

[image]

Sitecore 6.4.1 API
ExtractEmbeddedImages Constructor
ExtractEmbeddedImages Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ParseDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ExtractEmbeddedImages()
Visual Basic
Public Sub New
Visual C++
public:
ExtractEmbeddedImages()

See Also

ExtractEmbeddedImages Class
Sitecore.Pipelines.ParseDocx Namespace


ExtractEmbeddedImages Methods

[image] [image]

Sitecore 6.4.1 API
ExtractEmbeddedImages Methods
ExtractEmbeddedImages Class See Also Send Feedback

The ExtractEmbeddedImages type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetKey | Gets the key.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExtractEmbeddedImages Class
Sitecore.Pipelines.ParseDocx Namespace


GetKey Method

[image]

Sitecore 6.4.1 API
ExtractEmbeddedImages..::..GetKey Method
ExtractEmbeddedImages Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ParseDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string GetKey(
    byte[] crc
)
Visual Basic
Protected Overridable Function GetKey ( _
    crc As Byte() _
) As String
Visual C++
protected:
virtual String^ GetKey(
    array<unsigned char>^ crc
)

Parameters

crc
Type: array< System..::..Byte >[]()[][]
The CRC.

Return Value

[Missing <returns> documentation for "M:Sitecore.Pipelines.ParseDocx.ExtractEmbeddedImages.GetKey(System.Byte[])"]

See Also

ExtractEmbeddedImages Class
Sitecore.Pipelines.ParseDocx Namespace


Process Method

[image]

Sitecore 6.4.1 API
ExtractEmbeddedImages..::..Process Method
ExtractEmbeddedImages Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ParseDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    ParseDocxArgs args
)
Visual Basic
Public Sub Process ( _
    args As ParseDocxArgs _
)
Visual C++
public:
void Process(
    ParseDocxArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.ParseDocx..::..ParseDocxArgs
The args.

See Also

ExtractEmbeddedImages Class
Sitecore.Pipelines.ParseDocx Namespace


FixImageLinks Class

[image]

Sitecore 6.4.1 API
FixImageLinks Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.ParseDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FixImageLinks
Visual Basic
Public Class FixImageLinks
Visual C++
public ref class FixImageLinks

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.ParseDocx..::..FixImageLinks

See Also

FixImageLinks Members
Sitecore.Pipelines.ParseDocx Namespace


FixImageLinks Members

[image] [image]

Sitecore 6.4.1 API
FixImageLinks Members
FixImageLinks Class Constructors Methods See Also Send Feedback

The FixImageLinks type exposes the following members.

Constructors

 | Name | Description
Public method | FixImageLinks | Initializes a new instance of the FixImageLinks class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FixImageLinks Class
Sitecore.Pipelines.ParseDocx Namespace


FixImageLinks Constructor

[image]

Sitecore 6.4.1 API
FixImageLinks Constructor
FixImageLinks Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ParseDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FixImageLinks()
Visual Basic
Public Sub New
Visual C++
public:
FixImageLinks()

See Also

FixImageLinks Class
Sitecore.Pipelines.ParseDocx Namespace


FixImageLinks Methods

[image] [image]

Sitecore 6.4.1 API
FixImageLinks Methods
FixImageLinks Class See Also Send Feedback

The FixImageLinks type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FixImageLinks Class
Sitecore.Pipelines.ParseDocx Namespace


Process Method

[image]

Sitecore 6.4.1 API
FixImageLinks..::..Process Method
FixImageLinks Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ParseDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    ParseDocxArgs args
)
Visual Basic
Public Sub Process ( _
    args As ParseDocxArgs _
)
Visual C++
public:
void Process(
    ParseDocxArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.ParseDocx..::..ParseDocxArgs
The args.

See Also

FixImageLinks Class
Sitecore.Pipelines.ParseDocx Namespace


FixLinks Class

[image]

Sitecore 6.4.1 API
FixLinks Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.ParseDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FixLinks
Visual Basic
Public Class FixLinks
Visual C++
public ref class FixLinks

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.ParseDocx..::..FixLinks

See Also

FixLinks Members
Sitecore.Pipelines.ParseDocx Namespace


FixLinks Members

[image] [image]

Sitecore 6.4.1 API
FixLinks Members
FixLinks Class Constructors Methods See Also Send Feedback

The FixLinks type exposes the following members.

Constructors

 | Name | Description
Public method | FixLinks | Initializes a new instance of the FixLinks class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FixLinks Class
Sitecore.Pipelines.ParseDocx Namespace


FixLinks Methods

[image] [image]

Sitecore 6.4.1 API
FixLinks Methods
FixLinks Class See Also Send Feedback

The FixLinks type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FixLinks Class
Sitecore.Pipelines.ParseDocx Namespace


Process Method

[image]

Sitecore 6.4.1 API
FixLinks..::..Process Method
FixLinks Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ParseDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    ParseDocxArgs args
)
Visual Basic
Public Sub Process ( _
    args As ParseDocxArgs _
)
Visual C++
public:
void Process(
    ParseDocxArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.ParseDocx..::..ParseDocxArgs
The args.

See Also

FixLinks Class
Sitecore.Pipelines.ParseDocx Namespace


FixStyles Class

[image]

Sitecore 6.4.1 API
FixStyles Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.ParseDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FixStyles
Visual Basic
Public Class FixStyles
Visual C++
public ref class FixStyles

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.ParseDocx..::..FixStyles

See Also

FixStyles Members
Sitecore.Pipelines.ParseDocx Namespace


FixStyles Members

[image] [image]

Sitecore 6.4.1 API
FixStyles Members
FixStyles Class Constructors Methods See Also Send Feedback

The FixStyles type exposes the following members.

Constructors

 | Name | Description
Public method | FixStyles | Initializes a new instance of the FixStyles class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FixStyles Class
Sitecore.Pipelines.ParseDocx Namespace


FixStyles Constructor

[image]

Sitecore 6.4.1 API
FixStyles Constructor
FixStyles Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ParseDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FixStyles()
Visual Basic
Public Sub New
Visual C++
public:
FixStyles()

See Also

FixStyles Class
Sitecore.Pipelines.ParseDocx Namespace


FixStyles Methods

[image] [image]

Sitecore 6.4.1 API
FixStyles Methods
FixStyles Class See Also Send Feedback

The FixStyles type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FixStyles Class
Sitecore.Pipelines.ParseDocx Namespace


Process Method

[image]

Sitecore 6.4.1 API
FixStyles..::..Process Method
FixStyles Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ParseDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    ParseDocxArgs args
)
Visual Basic
Public Sub Process ( _
    args As ParseDocxArgs _
)
Visual C++
public:
void Process(
    ParseDocxArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.ParseDocx..::..ParseDocxArgs
The args.

See Also

FixStyles Class
Sitecore.Pipelines.ParseDocx Namespace


ParseDocxArgs Class

[image]

Sitecore 6.4.1 API
ParseDocxArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.ParseDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ParseDocxArgs : PipelineArgs
Visual Basic
Public Class ParseDocxArgs _
    Inherits PipelineArgs
Visual C++
public ref class ParseDocxArgs : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Pipelines.ParseDocx..::..ParseDocxArgs

See Also

ParseDocxArgs Members
Sitecore.Pipelines.ParseDocx Namespace


ParseDocxArgs Members

[image] [image]

Sitecore 6.4.1 API
ParseDocxArgs Members
ParseDocxArgs Class Constructors Methods Properties See Also Send Feedback

The ParseDocxArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ParseDocxArgs | Initializes a new instance of the ParseDocxArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | BlobId | Gets or sets the BLOB id.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Database | Gets the database.
Public property | FieldValue | Gets or sets the field value.
Public property | Files | Gets the files.
Public property | Html | Gets or sets the HTML.
Public property | HtmlDocument | Gets or sets the HTML document.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | PictureMapping | Contains mapping between internal docx part id (that contains an image) and ID of the related item in media library.
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

ParseDocxArgs Class
Sitecore.Pipelines.ParseDocx Namespace


ParseDocxArgs Constructor

[image]

Sitecore 6.4.1 API
ParseDocxArgs Constructor
ParseDocxArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ParseDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ParseDocxArgs(
    HttpFileCollection files,
    Database database,
    ID blobId
)
Visual Basic
Public Sub New ( _
    files As HttpFileCollection, _
    database As Database, _
    blobId As ID _
)
Visual C++
public:
ParseDocxArgs(
    HttpFileCollection^ files,
    Database^ database,
    ID^ blobId
)

Parameters

files
Type: System.Web..::..HttpFileCollection
The uploaded files.
database
Type: Sitecore.Data..::..Database
The database.
blobId
Type: Sitecore.Data..::..ID
The BLOB id.

See Also

ParseDocxArgs Class
Sitecore.Pipelines.ParseDocx Namespace


ParseDocxArgs Methods

[image] [image]

Sitecore 6.4.1 API
ParseDocxArgs Methods
ParseDocxArgs Class See Also Send Feedback

The ParseDocxArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParseDocxArgs Class
Sitecore.Pipelines.ParseDocx Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
ParseDocxArgs..::..AddMessage Method
ParseDocxArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

ParseDocxArgs Class
ParseDocxArgs Members
Sitecore.Pipelines.ParseDocx Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
ParseDocxArgs..::..GetMessages Method
ParseDocxArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

ParseDocxArgs Class
ParseDocxArgs Members
Sitecore.Pipelines.ParseDocx Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
ParseDocxArgs..::..Suspend Method
ParseDocxArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

ParseDocxArgs Class
ParseDocxArgs Members
Sitecore.Pipelines.ParseDocx Namespace


ParseDocxArgs Properties

[image] [image]

Sitecore 6.4.1 API
ParseDocxArgs Properties
ParseDocxArgs Class See Also Send Feedback

The ParseDocxArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | BlobId | Gets or sets the BLOB id.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Database | Gets the database.
Public property | FieldValue | Gets or sets the field value.
Public property | Files | Gets the files.
Public property | Html | Gets or sets the HTML.
Public property | HtmlDocument | Gets or sets the HTML document.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | PictureMapping | Contains mapping between internal docx part id (that contains an image) and ID of the related item in media library.
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

ParseDocxArgs Class
Sitecore.Pipelines.ParseDocx Namespace


BlobId Property

[image]

Sitecore 6.4.1 API
ParseDocxArgs..::..BlobId Property
ParseDocxArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ParseDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID BlobId { get; set; }
Visual Basic
Public Property BlobId As ID
    Get
    Set
Visual C++
public:
property ID^ BlobId {
    ID^ get ();
    void set (ID^ value);
}

Field Value

The BLOB id.

See Also

ParseDocxArgs Class
Sitecore.Pipelines.ParseDocx Namespace


Database Property

[image]

Sitecore 6.4.1 API
ParseDocxArgs..::..Database Property
ParseDocxArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ParseDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database Database { get; }
Visual Basic
Public ReadOnly Property Database As Database
    Get
Visual C++
public:
property Database^ Database {
    Database^ get ();
}

Field Value

The database.

See Also

ParseDocxArgs Class
Sitecore.Pipelines.ParseDocx Namespace


FieldValue Property

[image]

Sitecore 6.4.1 API
ParseDocxArgs..::..FieldValue Property
ParseDocxArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ParseDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string FieldValue { get; set; }
Visual Basic
Public Property FieldValue As String
    Get
    Set
Visual C++
public:
property String^ FieldValue {
    String^ get ();
    void set (String^ value);
}

Field Value

The field value.

See Also

ParseDocxArgs Class
Sitecore.Pipelines.ParseDocx Namespace


Files Property

[image]

Sitecore 6.4.1 API
ParseDocxArgs..::..Files Property
ParseDocxArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ParseDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HttpFileCollection Files { get; }
Visual Basic
Public ReadOnly Property Files As HttpFileCollection
    Get
Visual C++
public:
property HttpFileCollection^ Files {
    HttpFileCollection^ get ();
}

Field Value

The files.

See Also

ParseDocxArgs Class
Sitecore.Pipelines.ParseDocx Namespace


Html Property

[image]

Sitecore 6.4.1 API
ParseDocxArgs..::..Html Property
ParseDocxArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ParseDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Html { get; set; }
Visual Basic
Public Property Html As String
    Get
    Set
Visual C++
public:
property String^ Html {
    String^ get ();
    void set (String^ value);
}

Field Value

The HTML.

See Also

ParseDocxArgs Class
Sitecore.Pipelines.ParseDocx Namespace


HtmlDocument Property

[image]

Sitecore 6.4.1 API
ParseDocxArgs..::..HtmlDocument Property
ParseDocxArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ParseDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HtmlDocument HtmlDocument { get; set; }
Visual Basic
Public Property HtmlDocument As HtmlDocument
    Get
    Set
Visual C++
public:
property HtmlDocument^ HtmlDocument {
    HtmlDocument^ get ();
    void set (HtmlDocument^ value);
}

Field Value

The HTML document.

See Also

ParseDocxArgs Class
Sitecore.Pipelines.ParseDocx Namespace


PictureMapping Property

[image]

Sitecore 6.4.1 API
ParseDocxArgs..::..PictureMapping Property
ParseDocxArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ParseDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Dictionary<string, ID> PictureMapping { get; }
Visual Basic
Public ReadOnly Property PictureMapping As Dictionary(Of String, ID)
    Get
Visual C++
public:
property Dictionary<String^, ID^>^ PictureMapping {
    Dictionary<String^, ID^>^ get ();
}

Field Value

The picture mapping.

See Also

ParseDocxArgs Class
Sitecore.Pipelines.ParseDocx Namespace


RemoveJavascript Class

[image]

Sitecore 6.4.1 API
RemoveJavascript Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.ParseDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RemoveJavascript
Visual Basic
Public Class RemoveJavascript
Visual C++
public ref class RemoveJavascript

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.ParseDocx..::..RemoveJavascript

See Also

RemoveJavascript Members
Sitecore.Pipelines.ParseDocx Namespace


RemoveJavascript Members

[image] [image]

Sitecore 6.4.1 API
RemoveJavascript Members
RemoveJavascript Class Constructors Methods See Also Send Feedback

The RemoveJavascript type exposes the following members.

Constructors

 | Name | Description
Public method | RemoveJavascript | Initializes a new instance of the RemoveJavascript class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RemoveJavascript Class
Sitecore.Pipelines.ParseDocx Namespace


RemoveJavascript Constructor

[image]

Sitecore 6.4.1 API
RemoveJavascript Constructor
RemoveJavascript Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ParseDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RemoveJavascript()
Visual Basic
Public Sub New
Visual C++
public:
RemoveJavascript()

See Also

RemoveJavascript Class
Sitecore.Pipelines.ParseDocx Namespace


RemoveJavascript Methods

[image] [image]

Sitecore 6.4.1 API
RemoveJavascript Methods
RemoveJavascript Class See Also Send Feedback

The RemoveJavascript type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RemoveJavascript Class
Sitecore.Pipelines.ParseDocx Namespace


Process Method

[image]

Sitecore 6.4.1 API
RemoveJavascript..::..Process Method
RemoveJavascript Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ParseDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    ParseDocxArgs args
)
Visual Basic
Public Sub Process ( _
    args As ParseDocxArgs _
)
Visual C++
public:
void Process(
    ParseDocxArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.ParseDocx..::..ParseDocxArgs
The arguments.

See Also

RemoveJavascript Class
Sitecore.Pipelines.ParseDocx Namespace


SetFieldValue Class

[image]

Sitecore 6.4.1 API
SetFieldValue Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.ParseDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SetFieldValue
Visual Basic
Public Class SetFieldValue
Visual C++
public ref class SetFieldValue

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.ParseDocx..::..SetFieldValue

See Also

SetFieldValue Members
Sitecore.Pipelines.ParseDocx Namespace


SetFieldValue Members

[image] [image]

Sitecore 6.4.1 API
SetFieldValue Members
SetFieldValue Class Constructors Methods See Also Send Feedback

The SetFieldValue type exposes the following members.

Constructors

 | Name | Description
Public method | SetFieldValue | Initializes a new instance of the SetFieldValue class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SetFieldValue Class
Sitecore.Pipelines.ParseDocx Namespace


SetFieldValue Constructor

[image]

Sitecore 6.4.1 API
SetFieldValue Constructor
SetFieldValue Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ParseDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SetFieldValue()
Visual Basic
Public Sub New
Visual C++
public:
SetFieldValue()

See Also

SetFieldValue Class
Sitecore.Pipelines.ParseDocx Namespace


SetFieldValue Methods

[image] [image]

Sitecore 6.4.1 API
SetFieldValue Methods
SetFieldValue Class See Also Send Feedback

The SetFieldValue type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SetFieldValue Class
Sitecore.Pipelines.ParseDocx Namespace


Process Method

[image]

Sitecore 6.4.1 API
SetFieldValue..::..Process Method
SetFieldValue Class See Also Send Feedback

Namespace: Sitecore.Pipelines.ParseDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    ParseDocxArgs args
)
Visual Basic
Public Sub Process ( _
    args As ParseDocxArgs _
)
Visual C++
public:
void Process(
    ParseDocxArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.ParseDocx..::..ParseDocxArgs
The args.

See Also

SetFieldValue Class
Sitecore.Pipelines.ParseDocx Namespace


Sitecore.Pipelines.PreprocessRequest Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.PreprocessRequest Namespace
Send Feedback

Classes

 | Class | Description
Public class | CheckIgnoreFlag | Check wherever to ignore whole pipeline
Public class | FilterUrlExtensions | Filters Url extensions.
Public class | IIS404Handler | IIS404Handler
Public class | NormalizeRawUrl | NormalizeRawUrl
Public class | PreprocessRequestArgs | PreprocessRequestPipelineArgs
Public class | PreprocessRequestPipeline | PreprocessRequestPipeline class
Public class | PreprocessRequestProcessor | PreprocessRequestProcessor
Public class | StripLanguage | The strip language.
Public class | SuppressFormValidation | The suppress form validation.
Public class | WebDAVCustomHandler | Handles Web DAV requests.


CheckIgnoreFlag Class

[image]

Sitecore 6.4.1 API
CheckIgnoreFlag Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.PreprocessRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CheckIgnoreFlag : PreprocessRequestProcessor
Visual Basic
Public Class CheckIgnoreFlag _
    Inherits PreprocessRequestProcessor
Visual C++
public ref class CheckIgnoreFlag : public PreprocessRequestProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.PreprocessRequest..::..PreprocessRequestProcessor
Sitecore.Pipelines.PreprocessRequest..::..CheckIgnoreFlag

See Also

CheckIgnoreFlag Members
Sitecore.Pipelines.PreprocessRequest Namespace


CheckIgnoreFlag Members

[image] [image]

Sitecore 6.4.1 API
CheckIgnoreFlag Members
CheckIgnoreFlag Class Constructors Methods Properties See Also Send Feedback

The CheckIgnoreFlag type exposes the following members.

Constructors

 | Name | Description
Public method | CheckIgnoreFlag | Initializes a new instance of the CheckIgnoreFlag class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process(PipelineArgs) | Processes the specified args.
Public method | Process(PreprocessRequestArgs) | Processes the specified args. (Overrides PreprocessRequestProcessor..::..Process(PreprocessRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Protected property | ignoreFlagName | Gets the name of the ignore key.

See Also

CheckIgnoreFlag Class
Sitecore.Pipelines.PreprocessRequest Namespace


CheckIgnoreFlag Constructor

[image]

Sitecore 6.4.1 API
CheckIgnoreFlag Constructor
CheckIgnoreFlag Class See Also Send Feedback

Namespace: Sitecore.Pipelines.PreprocessRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CheckIgnoreFlag()
Visual Basic
Public Sub New
Visual C++
public:
CheckIgnoreFlag()

See Also

CheckIgnoreFlag Class
Sitecore.Pipelines.PreprocessRequest Namespace


CheckIgnoreFlag Methods

[image] [image]

Sitecore 6.4.1 API
CheckIgnoreFlag Methods
CheckIgnoreFlag Class See Also Send Feedback

The CheckIgnoreFlag type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process(PipelineArgs) | Processes the specified args.
Public method | Process(PreprocessRequestArgs) | Processes the specified args. (Overrides PreprocessRequestProcessor..::..Process(PreprocessRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckIgnoreFlag Class
Sitecore.Pipelines.PreprocessRequest Namespace


Process Method

[image] [image]

Sitecore 6.4.1 API
CheckIgnoreFlag..::..Process Method
CheckIgnoreFlag Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Process(PipelineArgs) | Processes the specified args.
Public method | Process(PreprocessRequestArgs) | Processes the specified args. (Overrides PreprocessRequestProcessor..::..Process(PreprocessRequestArgs).)

See Also

CheckIgnoreFlag Class
CheckIgnoreFlag Members
Sitecore.Pipelines.PreprocessRequest Namespace


Process Method (PipelineArgs)

[image]

Sitecore 6.4.1 API
CheckIgnoreFlag..::..Process Method (PipelineArgs)
CheckIgnoreFlag Class See Also Send Feedback

Namespace: Sitecore.Pipelines.PreprocessRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    PipelineArgs args
)
Visual Basic
Public Sub Process ( _
    args As PipelineArgs _
)
Visual C++
public:
void Process(
    PipelineArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines..::..PipelineArgs
The args.

See Also

CheckIgnoreFlag Class
Process Overload
Sitecore.Pipelines.PreprocessRequest Namespace


Process Method (PreprocessRequestArgs)

[image]

Sitecore 6.4.1 API
CheckIgnoreFlag..::..Process Method (PreprocessRequestArgs)
CheckIgnoreFlag Class See Also Send Feedback

Namespace: Sitecore.Pipelines.PreprocessRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    PreprocessRequestArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As PreprocessRequestArgs _
)
Visual C++
public:
virtual void Process(
    PreprocessRequestArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.PreprocessRequest..::..PreprocessRequestArgs
The args.

See Also

CheckIgnoreFlag Class
Process Overload
Sitecore.Pipelines.PreprocessRequest Namespace


ignoreFlagName Property

[image]

Sitecore 6.4.1 API
CheckIgnoreFlag..::..ignoreFlagName Property
CheckIgnoreFlag Class See Also Send Feedback

Namespace: Sitecore.Pipelines.PreprocessRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string ignoreFlagName { get; }
Visual Basic
Protected Overridable ReadOnly Property ignoreFlagName As String
    Get
Visual C++
protected:
virtual property String^ ignoreFlagName {
    String^ get ();
}

Field Value

The name of the ignore key.

See Also

CheckIgnoreFlag Class
Sitecore.Pipelines.PreprocessRequest Namespace


FilterUrlExtensions Class

[image]

Sitecore 6.4.1 API
FilterUrlExtensions Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.PreprocessRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class FilterUrlExtensions : PreprocessRequestProcessor
Visual Basic
Public Class FilterUrlExtensions _
    Inherits PreprocessRequestProcessor
Visual C++
public ref class FilterUrlExtensions : public PreprocessRequestProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.PreprocessRequest..::..PreprocessRequestProcessor
Sitecore.Pipelines.PreprocessRequest..::..FilterUrlExtensions

See Also

FilterUrlExtensions Members
Sitecore.Pipelines.PreprocessRequest Namespace


FilterUrlExtensions Members

[image] [image]

Sitecore 6.4.1 API
FilterUrlExtensions Members
FilterUrlExtensions Class Constructors Methods See Also Send Feedback

The FilterUrlExtensions type exposes the following members.

Constructors

 | Name | Description
Public method | FilterUrlExtensions | Initializes a new instance of the FilterUrlExtensions class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides PreprocessRequestProcessor..::..Process(PreprocessRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterUrlExtensions Class
Sitecore.Pipelines.PreprocessRequest Namespace


FilterUrlExtensions Constructor

[image]

Sitecore 6.4.1 API
FilterUrlExtensions Constructor
FilterUrlExtensions Class See Also Send Feedback

Namespace: Sitecore.Pipelines.PreprocessRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FilterUrlExtensions(
    string allowed,
    string blocked,
    string streamFiles,
    string doNotStreamFiles
)
Visual Basic
Public Sub New ( _
    allowed As String, _
    blocked As String, _
    streamFiles As String, _
    doNotStreamFiles As String _
)
Visual C++
public:
FilterUrlExtensions(
    String^ allowed,
    String^ blocked,
    String^ streamFiles,
    String^ doNotStreamFiles
)

Parameters

allowed
Type: System..::..String

[Missing <param name="allowed"/> documentation for "M:Sitecore.Pipelines.PreprocessRequest.FilterUrlExtensions.#ctor(System.String,System.String,System.String,System.String)"]

blocked
Type: System..::..String

[Missing <param name="blocked"/> documentation for "M:Sitecore.Pipelines.PreprocessRequest.FilterUrlExtensions.#ctor(System.String,System.String,System.String,System.String)"]

streamFiles
Type: System..::..String

[Missing <param name="streamFiles"/> documentation for "M:Sitecore.Pipelines.PreprocessRequest.FilterUrlExtensions.#ctor(System.String,System.String,System.String,System.String)"]

doNotStreamFiles
Type: System..::..String

[Missing <param name="doNotStreamFiles"/> documentation for "M:Sitecore.Pipelines.PreprocessRequest.FilterUrlExtensions.#ctor(System.String,System.String,System.String,System.String)"]

See Also

FilterUrlExtensions Class
Sitecore.Pipelines.PreprocessRequest Namespace


FilterUrlExtensions Methods

[image] [image]

Sitecore 6.4.1 API
FilterUrlExtensions Methods
FilterUrlExtensions Class See Also Send Feedback

The FilterUrlExtensions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides PreprocessRequestProcessor..::..Process(PreprocessRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterUrlExtensions Class
Sitecore.Pipelines.PreprocessRequest Namespace


Process Method

[image]

Sitecore 6.4.1 API
FilterUrlExtensions..::..Process Method
FilterUrlExtensions Class See Also Send Feedback

Namespace: Sitecore.Pipelines.PreprocessRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    PreprocessRequestArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As PreprocessRequestArgs _
)
Visual C++
public:
virtual void Process(
    PreprocessRequestArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.PreprocessRequest..::..PreprocessRequestArgs
The args.

See Also

FilterUrlExtensions Class
Sitecore.Pipelines.PreprocessRequest Namespace


IIS404Handler Class

[image]

Sitecore 6.4.1 API
IIS404Handler Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.PreprocessRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class IIS404Handler : PreprocessRequestProcessor
Visual Basic
Public Class IIS404Handler _
    Inherits PreprocessRequestProcessor
Visual C++
public ref class IIS404Handler : public PreprocessRequestProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.PreprocessRequest..::..PreprocessRequestProcessor
Sitecore.Pipelines.PreprocessRequest..::..IIS404Handler

See Also

IIS404Handler Members
Sitecore.Pipelines.PreprocessRequest Namespace


IIS404Handler Members

[image] [image]

Sitecore 6.4.1 API
IIS404Handler Members
IIS404Handler Class Constructors Methods See Also Send Feedback

The IIS404Handler type exposes the following members.

Constructors

 | Name | Description
Public method | IIS404Handler | Initializes a new instance of the IIS404Handler class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides PreprocessRequestProcessor..::..Process(PreprocessRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IIS404Handler Class
Sitecore.Pipelines.PreprocessRequest Namespace


IIS404Handler Methods

[image] [image]

Sitecore 6.4.1 API
IIS404Handler Methods
IIS404Handler Class See Also Send Feedback

The IIS404Handler type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes this instance. (Overrides PreprocessRequestProcessor..::..Process(PreprocessRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IIS404Handler Class
Sitecore.Pipelines.PreprocessRequest Namespace


Process Method

[image]

Sitecore 6.4.1 API
IIS404Handler..::..Process Method
IIS404Handler Class See Also Send Feedback

Namespace: Sitecore.Pipelines.PreprocessRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    PreprocessRequestArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As PreprocessRequestArgs _
)
Visual C++
public:
virtual void Process(
    PreprocessRequestArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.PreprocessRequest..::..PreprocessRequestArgs

[Missing <param name="args"/> documentation for "M:Sitecore.Pipelines.PreprocessRequest.IIS404Handler.Process(Sitecore.Pipelines.PreprocessRequest.PreprocessRequestArgs)"]

See Also

IIS404Handler Class
Sitecore.Pipelines.PreprocessRequest Namespace


NormalizeRawUrl Class

[image]

Sitecore 6.4.1 API
NormalizeRawUrl Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.PreprocessRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class NormalizeRawUrl : PreprocessRequestProcessor
Visual Basic
Public Class NormalizeRawUrl _
    Inherits PreprocessRequestProcessor
Visual C++
public ref class NormalizeRawUrl : public PreprocessRequestProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.PreprocessRequest..::..PreprocessRequestProcessor
Sitecore.Pipelines.PreprocessRequest..::..NormalizeRawUrl

See Also

NormalizeRawUrl Members
Sitecore.Pipelines.PreprocessRequest Namespace


NormalizeRawUrl Members

[image] [image]

Sitecore 6.4.1 API
NormalizeRawUrl Members
NormalizeRawUrl Class Constructors Methods See Also Send Feedback

The NormalizeRawUrl type exposes the following members.

Constructors

 | Name | Description
Public method | NormalizeRawUrl | Initializes a new instance of the NormalizeRawUrl class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides PreprocessRequestProcessor..::..Process(PreprocessRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NormalizeRawUrl Class
Sitecore.Pipelines.PreprocessRequest Namespace


NormalizeRawUrl Constructor

[image]

Sitecore 6.4.1 API
NormalizeRawUrl Constructor
NormalizeRawUrl Class See Also Send Feedback

Namespace: Sitecore.Pipelines.PreprocessRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public NormalizeRawUrl()
Visual Basic
Public Sub New
Visual C++
public:
NormalizeRawUrl()

See Also

NormalizeRawUrl Class
Sitecore.Pipelines.PreprocessRequest Namespace


NormalizeRawUrl Methods

[image] [image]

Sitecore 6.4.1 API
NormalizeRawUrl Methods
NormalizeRawUrl Class See Also Send Feedback

The NormalizeRawUrl type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides PreprocessRequestProcessor..::..Process(PreprocessRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NormalizeRawUrl Class
Sitecore.Pipelines.PreprocessRequest Namespace


Process Method

[image]

Sitecore 6.4.1 API
NormalizeRawUrl..::..Process Method
NormalizeRawUrl Class See Also Send Feedback

Namespace: Sitecore.Pipelines.PreprocessRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    PreprocessRequestArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As PreprocessRequestArgs _
)
Visual C++
public:
virtual void Process(
    PreprocessRequestArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.PreprocessRequest..::..PreprocessRequestArgs
The args.

See Also

NormalizeRawUrl Class
Sitecore.Pipelines.PreprocessRequest Namespace


PreprocessRequestArgs Class

[image]

Sitecore 6.4.1 API
PreprocessRequestArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.PreprocessRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class PreprocessRequestArgs : PipelineArgs
Visual Basic
<SerializableAttribute> _
Public Class PreprocessRequestArgs _
    Inherits PipelineArgs
Visual C++
[SerializableAttribute]
public ref class PreprocessRequestArgs : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Pipelines.PreprocessRequest..::..PreprocessRequestArgs

See Also

PreprocessRequestArgs Members
Sitecore.Pipelines.PreprocessRequest Namespace


PreprocessRequestArgs Members

[image] [image]

Sitecore 6.4.1 API
PreprocessRequestArgs Members
PreprocessRequestArgs Class Constructors Methods Properties See Also Send Feedback

The PreprocessRequestArgs type exposes the following members.

Constructors

 | Name | Description
Public method | PreprocessRequestArgs(HttpContext) | Initializes a new instance of the PreprocessRequestArgs class.
Protected method | PreprocessRequestArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the PreprocessRequestArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | Context | Gets the HTTP context.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

PreprocessRequestArgs Class
Sitecore.Pipelines.PreprocessRequest Namespace


PreprocessRequestArgs Constructor (HttpContext)

[image]

Sitecore 6.4.1 API
PreprocessRequestArgs Constructor (HttpContext)
PreprocessRequestArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.PreprocessRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PreprocessRequestArgs(
    HttpContext context
)
Visual Basic
Public Sub New ( _
    context As HttpContext _
)
Visual C++
public:
PreprocessRequestArgs(
    HttpContext^ context
)

Parameters

context
Type: System.Web..::..HttpContext

[Missing <param name="context"/> documentation for "M:Sitecore.Pipelines.PreprocessRequest.PreprocessRequestArgs.#ctor(System.Web.HttpContext)"]

See Also

PreprocessRequestArgs Class
PreprocessRequestArgs Overload
Sitecore.Pipelines.PreprocessRequest Namespace


PreprocessRequestArgs Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
PreprocessRequestArgs Constructor (SerializationInfo, StreamingContext)
PreprocessRequestArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.PreprocessRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected PreprocessRequestArgs(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
PreprocessRequestArgs(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

PreprocessRequestArgs Class
PreprocessRequestArgs Overload
Sitecore.Pipelines.PreprocessRequest Namespace


PreprocessRequestArgs Methods

[image] [image]

Sitecore 6.4.1 API
PreprocessRequestArgs Methods
PreprocessRequestArgs Class See Also Send Feedback

The PreprocessRequestArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PreprocessRequestArgs Class
Sitecore.Pipelines.PreprocessRequest Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
PreprocessRequestArgs..::..AddMessage Method
PreprocessRequestArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

PreprocessRequestArgs Class
PreprocessRequestArgs Members
Sitecore.Pipelines.PreprocessRequest Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
PreprocessRequestArgs..::..GetMessages Method
PreprocessRequestArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

PreprocessRequestArgs Class
PreprocessRequestArgs Members
Sitecore.Pipelines.PreprocessRequest Namespace


PreprocessRequestArgs Properties

[image] [image]

Sitecore 6.4.1 API
PreprocessRequestArgs Properties
PreprocessRequestArgs Class See Also Send Feedback

The PreprocessRequestArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | Context | Gets the HTTP context.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

PreprocessRequestArgs Class
Sitecore.Pipelines.PreprocessRequest Namespace


PreprocessRequestPipeline Members

[image] [image]

Sitecore 6.4.1 API
PreprocessRequestPipeline Members
PreprocessRequestPipeline Class Constructors Methods See Also Send Feedback

The PreprocessRequestPipeline type exposes the following members.

Constructors

 | Name | Description
Public method | PreprocessRequestPipeline | Initializes a new instance of the PreprocessRequestPipeline class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run | Runs the 'publish' pipeline with specified arguments.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PreprocessRequestPipeline Class
Sitecore.Pipelines.PreprocessRequest Namespace


PreprocessRequestPipeline Constructor

[image]

Sitecore 6.4.1 API
PreprocessRequestPipeline Constructor
PreprocessRequestPipeline Class See Also Send Feedback

Namespace: Sitecore.Pipelines.PreprocessRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PreprocessRequestPipeline()
Visual Basic
Public Sub New
Visual C++
public:
PreprocessRequestPipeline()

See Also

PreprocessRequestPipeline Class
Sitecore.Pipelines.PreprocessRequest Namespace


PreprocessRequestPipeline Methods

[image] [image]

Sitecore 6.4.1 API
PreprocessRequestPipeline Methods
PreprocessRequestPipeline Class See Also Send Feedback

The PreprocessRequestPipeline type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run | Runs the 'publish' pipeline with specified arguments.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PreprocessRequestPipeline Class
Sitecore.Pipelines.PreprocessRequest Namespace


Run Method

[image]

Sitecore 6.4.1 API
PreprocessRequestPipeline..::..Run Method
PreprocessRequestPipeline Class See Also Send Feedback

Namespace: Sitecore.Pipelines.PreprocessRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Run(
    PreprocessRequestArgs args
)
Visual Basic
Public Shared Sub Run ( _
    args As PreprocessRequestArgs _
)
Visual C++
public:
static void Run(
    PreprocessRequestArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.PreprocessRequest..::..PreprocessRequestArgs
The args.

See Also

PreprocessRequestPipeline Class
Sitecore.Pipelines.PreprocessRequest Namespace


PreprocessRequestProcessor Class

[image]

Sitecore 6.4.1 API
PreprocessRequestProcessor Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.PreprocessRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class PreprocessRequestProcessor
Visual Basic
Public MustInherit Class PreprocessRequestProcessor
Visual C++
public ref class PreprocessRequestProcessor abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.PreprocessRequest..::..PreprocessRequestProcessor
Sitecore.Pipelines.PreprocessRequest..::..CheckIgnoreFlag
Sitecore.Pipelines.PreprocessRequest..::..FilterUrlExtensions
Sitecore.Pipelines.PreprocessRequest..::..IIS404Handler
Sitecore.Pipelines.PreprocessRequest..::..NormalizeRawUrl
Sitecore.Pipelines.PreprocessRequest..::..StripLanguage
Sitecore.Pipelines.PreprocessRequest..::..SuppressFormValidation
Sitecore.Pipelines.PreprocessRequest..::..WebDAVCustomHandler

See Also

PreprocessRequestProcessor Members
Sitecore.Pipelines.PreprocessRequest Namespace


PreprocessRequestProcessor Members

[image] [image]

Sitecore 6.4.1 API
PreprocessRequestProcessor Members
PreprocessRequestProcessor Class Constructors Methods See Also Send Feedback

The PreprocessRequestProcessor type exposes the following members.

Constructors

 | Name | Description
Protected method | PreprocessRequestProcessor | Initializes a new instance of the PreprocessRequestProcessor class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PreprocessRequestProcessor Class
Sitecore.Pipelines.PreprocessRequest Namespace


PreprocessRequestProcessor Constructor

[image]

Sitecore 6.4.1 API
PreprocessRequestProcessor Constructor
PreprocessRequestProcessor Class See Also Send Feedback

Namespace: Sitecore.Pipelines.PreprocessRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected PreprocessRequestProcessor()
Visual Basic
Protected Sub New
Visual C++
protected:
PreprocessRequestProcessor()

See Also

PreprocessRequestProcessor Class
Sitecore.Pipelines.PreprocessRequest Namespace


PreprocessRequestProcessor Methods

[image] [image]

Sitecore 6.4.1 API
PreprocessRequestProcessor Methods
PreprocessRequestProcessor Class See Also Send Feedback

The PreprocessRequestProcessor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PreprocessRequestProcessor Class
Sitecore.Pipelines.PreprocessRequest Namespace


Process Method

[image]

Sitecore 6.4.1 API
PreprocessRequestProcessor..::..Process Method
PreprocessRequestProcessor Class See Also Send Feedback

Namespace: Sitecore.Pipelines.PreprocessRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract void Process(
    PreprocessRequestArgs args
)
Visual Basic
Public MustOverride Sub Process ( _
    args As PreprocessRequestArgs _
)
Visual C++
public:
virtual void Process(
    PreprocessRequestArgs^ args
) abstract

Parameters

args
Type: Sitecore.Pipelines.PreprocessRequest..::..PreprocessRequestArgs
The args.

See Also

PreprocessRequestProcessor Class
Sitecore.Pipelines.PreprocessRequest Namespace


StripLanguage Class

[image]

Sitecore 6.4.1 API
StripLanguage Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.PreprocessRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class StripLanguage : PreprocessRequestProcessor
Visual Basic
Public Class StripLanguage _
    Inherits PreprocessRequestProcessor
Visual C++
public ref class StripLanguage : public PreprocessRequestProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.PreprocessRequest..::..PreprocessRequestProcessor
Sitecore.Pipelines.PreprocessRequest..::..StripLanguage

See Also

StripLanguage Members
Sitecore.Pipelines.PreprocessRequest Namespace


StripLanguage Members

[image] [image]

Sitecore 6.4.1 API
StripLanguage Members
StripLanguage Class Constructors Methods See Also Send Feedback

The StripLanguage type exposes the following members.

Constructors

 | Name | Description
Public method | StripLanguage | Initializes a new instance of the StripLanguage class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified arguments. (Overrides PreprocessRequestProcessor..::..Process(PreprocessRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StripLanguage Class
Sitecore.Pipelines.PreprocessRequest Namespace


StripLanguage Constructor

[image]

Sitecore 6.4.1 API
StripLanguage Constructor
StripLanguage Class See Also Send Feedback

Namespace: Sitecore.Pipelines.PreprocessRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StripLanguage()
Visual Basic
Public Sub New
Visual C++
public:
StripLanguage()

See Also

StripLanguage Class
Sitecore.Pipelines.PreprocessRequest Namespace


Process Method

[image]

Sitecore 6.4.1 API
StripLanguage..::..Process Method
StripLanguage Class See Also Send Feedback

Namespace: Sitecore.Pipelines.PreprocessRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    PreprocessRequestArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As PreprocessRequestArgs _
)
Visual C++
public:
virtual void Process(
    PreprocessRequestArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.PreprocessRequest..::..PreprocessRequestArgs
The arguments.

See Also

StripLanguage Class
Sitecore.Pipelines.PreprocessRequest Namespace


SuppressFormValidation Class

[image]

Sitecore 6.4.1 API
SuppressFormValidation Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.PreprocessRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SuppressFormValidation : PreprocessRequestProcessor
Visual Basic
Public Class SuppressFormValidation _
    Inherits PreprocessRequestProcessor
Visual C++
public ref class SuppressFormValidation : public PreprocessRequestProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.PreprocessRequest..::..PreprocessRequestProcessor
Sitecore.Pipelines.PreprocessRequest..::..SuppressFormValidation

See Also

SuppressFormValidation Members
Sitecore.Pipelines.PreprocessRequest Namespace


SuppressFormValidation Members

[image] [image]

Sitecore 6.4.1 API
SuppressFormValidation Members
SuppressFormValidation Class Constructors Methods See Also Send Feedback

The SuppressFormValidation type exposes the following members.

Constructors

 | Name | Description
Public method | SuppressFormValidation | Initializes a new instance of the SuppressFormValidation class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Suppresses the form validation excheption that has been introduced in .NET 4.0 for Sitecore backend. (Overrides PreprocessRequestProcessor..::..Process(PreprocessRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SuppressFormValidation Class
Sitecore.Pipelines.PreprocessRequest Namespace


SuppressFormValidation Constructor

[image]

Sitecore 6.4.1 API
SuppressFormValidation Constructor
SuppressFormValidation Class See Also Send Feedback

Namespace: Sitecore.Pipelines.PreprocessRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SuppressFormValidation()
Visual Basic
Public Sub New
Visual C++
public:
SuppressFormValidation()

See Also

SuppressFormValidation Class
Sitecore.Pipelines.PreprocessRequest Namespace


SuppressFormValidation Methods

[image] [image]

Sitecore 6.4.1 API
SuppressFormValidation Methods
SuppressFormValidation Class See Also Send Feedback

The SuppressFormValidation type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Suppresses the form validation excheption that has been introduced in .NET 4.0 for Sitecore backend. (Overrides PreprocessRequestProcessor..::..Process(PreprocessRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SuppressFormValidation Class
Sitecore.Pipelines.PreprocessRequest Namespace


Process Method

[image]

Sitecore 6.4.1 API
SuppressFormValidation..::..Process Method
SuppressFormValidation Class See Also Send Feedback

Namespace: Sitecore.Pipelines.PreprocessRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    PreprocessRequestArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As PreprocessRequestArgs _
)
Visual C++
public:
virtual void Process(
    PreprocessRequestArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.PreprocessRequest..::..PreprocessRequestArgs
The pipeline arguments.

See Also

SuppressFormValidation Class
Sitecore.Pipelines.PreprocessRequest Namespace


WebDAVCustomHandler Class

[image]

Sitecore 6.4.1 API
WebDAVCustomHandler Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.PreprocessRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class WebDAVCustomHandler : PreprocessRequestProcessor
Visual Basic
Public Class WebDAVCustomHandler _
    Inherits PreprocessRequestProcessor
Visual C++
public ref class WebDAVCustomHandler : public PreprocessRequestProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.PreprocessRequest..::..PreprocessRequestProcessor
Sitecore.Pipelines.PreprocessRequest..::..WebDAVCustomHandler

See Also

WebDAVCustomHandler Members
Sitecore.Pipelines.PreprocessRequest Namespace


WebDAVCustomHandler Members

[image] [image]

Sitecore 6.4.1 API
WebDAVCustomHandler Members
WebDAVCustomHandler Class Constructors Methods See Also Send Feedback

The WebDAVCustomHandler type exposes the following members.

Constructors

 | Name | Description
Public method | WebDAVCustomHandler | Initializes a new instance of the WebDAVCustomHandler class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides PreprocessRequestProcessor..::..Process(PreprocessRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WebDAVCustomHandler Class
Sitecore.Pipelines.PreprocessRequest Namespace


WebDAVCustomHandler Methods

[image] [image]

Sitecore 6.4.1 API
WebDAVCustomHandler Methods
WebDAVCustomHandler Class See Also Send Feedback

The WebDAVCustomHandler type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides PreprocessRequestProcessor..::..Process(PreprocessRequestArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WebDAVCustomHandler Class
Sitecore.Pipelines.PreprocessRequest Namespace


Process Method

[image]

Sitecore 6.4.1 API
WebDAVCustomHandler..::..Process Method
WebDAVCustomHandler Class See Also Send Feedback

Namespace: Sitecore.Pipelines.PreprocessRequest
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    PreprocessRequestArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As PreprocessRequestArgs _
)
Visual C++
public:
virtual void Process(
    PreprocessRequestArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.PreprocessRequest..::..PreprocessRequestArgs
The arguments.

See Also

WebDAVCustomHandler Class
Sitecore.Pipelines.PreprocessRequest Namespace


Sitecore.Pipelines.RenderDocx Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.RenderDocx Namespace
Send Feedback

Classes

 | Class | Description
Public class | ExpandLinks | A pipeline step that expands dynamic links
Public class | GetHtmlFromField | Gets the html from field value
Public class | RenderDocxArgs | Defineas an argument from "renderHtml" pipeline.


ExpandLinks Class

[image]

Sitecore 6.4.1 API
ExpandLinks Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ExpandLinks
Visual Basic
Public Class ExpandLinks
Visual C++
public ref class ExpandLinks

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.RenderDocx..::..ExpandLinks

See Also

ExpandLinks Members
Sitecore.Pipelines.RenderDocx Namespace


ExpandLinks Members

[image] [image]

Sitecore 6.4.1 API
ExpandLinks Members
ExpandLinks Class Constructors Methods See Also Send Feedback

The ExpandLinks type exposes the following members.

Constructors

 | Name | Description
Public method | ExpandLinks | Initializes a new instance of the ExpandLinks class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExpandLinks Class
Sitecore.Pipelines.RenderDocx Namespace


ExpandLinks Constructor

[image]

Sitecore 6.4.1 API
ExpandLinks Constructor
ExpandLinks Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ExpandLinks()
Visual Basic
Public Sub New
Visual C++
public:
ExpandLinks()

See Also

ExpandLinks Class
Sitecore.Pipelines.RenderDocx Namespace


ExpandLinks Methods

[image] [image]

Sitecore 6.4.1 API
ExpandLinks Methods
ExpandLinks Class See Also Send Feedback

The ExpandLinks type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExpandLinks Class
Sitecore.Pipelines.RenderDocx Namespace


Process Method

[image]

Sitecore 6.4.1 API
ExpandLinks..::..Process Method
ExpandLinks Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    RenderDocxArgs args
)
Visual Basic
Public Sub Process ( _
    args As RenderDocxArgs _
)
Visual C++
public:
void Process(
    RenderDocxArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.RenderDocx..::..RenderDocxArgs
The args.

See Also

ExpandLinks Class
Sitecore.Pipelines.RenderDocx Namespace


GetHtmlFromField Class

[image]

Sitecore 6.4.1 API
GetHtmlFromField Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetHtmlFromField
Visual Basic
Public Class GetHtmlFromField
Visual C++
public ref class GetHtmlFromField

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.RenderDocx..::..GetHtmlFromField

See Also

GetHtmlFromField Members
Sitecore.Pipelines.RenderDocx Namespace


GetHtmlFromField Members

[image] [image]

Sitecore 6.4.1 API
GetHtmlFromField Members
GetHtmlFromField Class Constructors Methods See Also Send Feedback

The GetHtmlFromField type exposes the following members.

Constructors

 | Name | Description
Public method | GetHtmlFromField | Initializes a new instance of the GetHtmlFromField class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetHtmlFromField Class
Sitecore.Pipelines.RenderDocx Namespace


GetHtmlFromField Constructor

[image]

Sitecore 6.4.1 API
GetHtmlFromField Constructor
GetHtmlFromField Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetHtmlFromField()
Visual Basic
Public Sub New
Visual C++
public:
GetHtmlFromField()

See Also

GetHtmlFromField Class
Sitecore.Pipelines.RenderDocx Namespace


GetHtmlFromField Methods

[image] [image]

Sitecore 6.4.1 API
GetHtmlFromField Methods
GetHtmlFromField Class See Also Send Feedback

The GetHtmlFromField type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetHtmlFromField Class
Sitecore.Pipelines.RenderDocx Namespace


Process Method

[image]

Sitecore 6.4.1 API
GetHtmlFromField..::..Process Method
GetHtmlFromField Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    RenderDocxArgs args
)
Visual Basic
Public Sub Process ( _
    args As RenderDocxArgs _
)
Visual C++
public:
void Process(
    RenderDocxArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.RenderDocx..::..RenderDocxArgs
The args.

See Also

GetHtmlFromField Class
Sitecore.Pipelines.RenderDocx Namespace


RenderDocxArgs Class

[image]

Sitecore 6.4.1 API
RenderDocxArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RenderDocxArgs : PipelineArgs
Visual Basic
Public Class RenderDocxArgs _
    Inherits PipelineArgs
Visual C++
public ref class RenderDocxArgs : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Pipelines.RenderDocx..::..RenderDocxArgs

See Also

RenderDocxArgs Members
Sitecore.Pipelines.RenderDocx Namespace


RenderDocxArgs Members

[image] [image]

Sitecore 6.4.1 API
RenderDocxArgs Members
RenderDocxArgs Class Constructors Methods Properties See Also Send Feedback

The RenderDocxArgs type exposes the following members.

Constructors

 | Name | Description
Public method | RenderDocxArgs | Initializes a new instance of the RenderDocxArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Database | Gets the database.
Public property | DisableLinks | Gets or sets a value indicating whether the pipelie should disables the links in Html document.
Public property | FieldValue | Gets the field value.
Public property | Html | Gets or sets the HTML.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | ResolveDynamicLinks | Gets or sets the resolve dynamic links.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

RenderDocxArgs Class
Sitecore.Pipelines.RenderDocx Namespace


RenderDocxArgs Methods

[image] [image]

Sitecore 6.4.1 API
RenderDocxArgs Methods
RenderDocxArgs Class See Also Send Feedback

The RenderDocxArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenderDocxArgs Class
Sitecore.Pipelines.RenderDocx Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
RenderDocxArgs..::..AddMessage Method
RenderDocxArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

RenderDocxArgs Class
RenderDocxArgs Members
Sitecore.Pipelines.RenderDocx Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
RenderDocxArgs..::..GetMessages Method
RenderDocxArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

RenderDocxArgs Class
RenderDocxArgs Members
Sitecore.Pipelines.RenderDocx Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
RenderDocxArgs..::..Suspend Method
RenderDocxArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

RenderDocxArgs Class
RenderDocxArgs Members
Sitecore.Pipelines.RenderDocx Namespace


RenderDocxArgs Properties

[image] [image]

Sitecore 6.4.1 API
RenderDocxArgs Properties
RenderDocxArgs Class See Also Send Feedback

The RenderDocxArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Database | Gets the database.
Public property | DisableLinks | Gets or sets a value indicating whether the pipelie should disables the links in Html document.
Public property | FieldValue | Gets the field value.
Public property | Html | Gets or sets the HTML.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | ResolveDynamicLinks | Gets or sets the resolve dynamic links.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

RenderDocxArgs Class
Sitecore.Pipelines.RenderDocx Namespace


Database Property

[image]

Sitecore 6.4.1 API
RenderDocxArgs..::..Database Property
RenderDocxArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database Database { get; }
Visual Basic
Public ReadOnly Property Database As Database
    Get
Visual C++
public:
property Database^ Database {
    Database^ get ();
}

Field Value

The database.

See Also

RenderDocxArgs Class
Sitecore.Pipelines.RenderDocx Namespace


DisableLinks Property

[image]

Sitecore 6.4.1 API
RenderDocxArgs..::..DisableLinks Property
RenderDocxArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool DisableLinks { get; set; }
Visual Basic
Public Property DisableLinks As Boolean
    Get
    Set
Visual C++
public:
property bool DisableLinks {
    bool get ();
    void set (bool value);
}

Field Value

true if the RenderDocxArgs disables the links; otherwise, false.

See Also

RenderDocxArgs Class
Sitecore.Pipelines.RenderDocx Namespace


FieldValue Property

[image]

Sitecore 6.4.1 API
RenderDocxArgs..::..FieldValue Property
RenderDocxArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string FieldValue { get; }
Visual Basic
Public ReadOnly Property FieldValue As String
    Get
Visual C++
public:
property String^ FieldValue {
    String^ get ();
}

Field Value

The field value.

See Also

RenderDocxArgs Class
Sitecore.Pipelines.RenderDocx Namespace


Html Property

[image]

Sitecore 6.4.1 API
RenderDocxArgs..::..Html Property
RenderDocxArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Html { get; set; }
Visual Basic
Public Property Html As String
    Get
    Set
Visual C++
public:
property String^ Html {
    String^ get ();
    void set (String^ value);
}

Field Value

The HTML.

See Also

RenderDocxArgs Class
Sitecore.Pipelines.RenderDocx Namespace


ResolveDynamicLinks Property

[image]

Sitecore 6.4.1 API
RenderDocxArgs..::..ResolveDynamicLinks Property
RenderDocxArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderDocx
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ResolveDynamicLinks { get; set; }
Visual Basic
Public Property ResolveDynamicLinks As Boolean
    Get
    Set
Visual C++
public:
property bool ResolveDynamicLinks {
    bool get ();
    void set (bool value);
}

Field Value

The resolve dynamic links.

See Also

RenderDocxArgs Class
Sitecore.Pipelines.RenderDocx Namespace


Sitecore.Pipelines.RenderField Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.RenderField Namespace
Send Feedback

Classes

 | Class | Description
Public class | AddBeforeAndAfterValues | Adds the before, after and enclosing tag.
Public class | ExpandLinks | ExpandLinks
Public class | GetDateFieldValue | Gets the value of date fields.
Public class | GetDocxFieldValue | A step for 'renderField' pipeline
Public class | GetFieldValue | Implements the RenderField.
Public class | GetImageFieldValue | Implements the RenderField.
Public class | GetInternalLinkFieldValue | Implements the GetLinkFieldValue.
Public class | GetLinkFieldValue | Implements the GetLinkFieldValue.
Public class | GetMemoFieldValue | Implements the RenderField.
Public class | RenderFieldArgs | Implements the RenderField.
Public class | RenderWebEditing | Implements the Render Field pipeline processor for WebEdit.
Public class | SetParameters | Sets the renderField parameters.


AddBeforeAndAfterValues Class

[image]

Sitecore 6.4.1 API
AddBeforeAndAfterValues Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class AddBeforeAndAfterValues
Visual Basic
Public Class AddBeforeAndAfterValues
Visual C++
public ref class AddBeforeAndAfterValues

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.RenderField..::..AddBeforeAndAfterValues

See Also

AddBeforeAndAfterValues Members
Sitecore.Pipelines.RenderField Namespace


AddBeforeAndAfterValues Members

[image] [image]

Sitecore 6.4.1 API
AddBeforeAndAfterValues Members
AddBeforeAndAfterValues Class Constructors Methods See Also Send Feedback

The AddBeforeAndAfterValues type exposes the following members.

Constructors

 | Name | Description
Public method | AddBeforeAndAfterValues | Initializes a new instance of the AddBeforeAndAfterValues class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddBeforeAndAfterValues Class
Sitecore.Pipelines.RenderField Namespace


AddBeforeAndAfterValues Constructor

[image]

Sitecore 6.4.1 API
AddBeforeAndAfterValues Constructor
AddBeforeAndAfterValues Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AddBeforeAndAfterValues()
Visual Basic
Public Sub New
Visual C++
public:
AddBeforeAndAfterValues()

See Also

AddBeforeAndAfterValues Class
Sitecore.Pipelines.RenderField Namespace


AddBeforeAndAfterValues Methods

[image] [image]

Sitecore 6.4.1 API
AddBeforeAndAfterValues Methods
AddBeforeAndAfterValues Class See Also Send Feedback

The AddBeforeAndAfterValues type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddBeforeAndAfterValues Class
Sitecore.Pipelines.RenderField Namespace


Process Method

[image]

Sitecore 6.4.1 API
AddBeforeAndAfterValues..::..Process Method
AddBeforeAndAfterValues Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    RenderFieldArgs args
)
Visual Basic
Public Sub Process ( _
    args As RenderFieldArgs _
)
Visual C++
public:
void Process(
    RenderFieldArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.RenderField..::..RenderFieldArgs
The arguments.

See Also

AddBeforeAndAfterValues Class
Sitecore.Pipelines.RenderField Namespace


ExpandLinks Class

[image]

Sitecore 6.4.1 API
ExpandLinks Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ExpandLinks
Visual Basic
Public Class ExpandLinks
Visual C++
public ref class ExpandLinks

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.RenderField..::..ExpandLinks

See Also

ExpandLinks Members
Sitecore.Pipelines.RenderField Namespace


ExpandLinks Members

[image] [image]

Sitecore 6.4.1 API
ExpandLinks Members
ExpandLinks Class Constructors Methods See Also Send Feedback

The ExpandLinks type exposes the following members.

Constructors

 | Name | Description
Public method | ExpandLinks | Initializes a new instance of the ExpandLinks class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExpandLinks Class
Sitecore.Pipelines.RenderField Namespace


ExpandLinks Constructor

[image]

Sitecore 6.4.1 API
ExpandLinks Constructor
ExpandLinks Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ExpandLinks()
Visual Basic
Public Sub New
Visual C++
public:
ExpandLinks()

See Also

ExpandLinks Class
Sitecore.Pipelines.RenderField Namespace


ExpandLinks Methods

[image] [image]

Sitecore 6.4.1 API
ExpandLinks Methods
ExpandLinks Class See Also Send Feedback

The ExpandLinks type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExpandLinks Class
Sitecore.Pipelines.RenderField Namespace


Process Method

[image]

Sitecore 6.4.1 API
ExpandLinks..::..Process Method
ExpandLinks Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Process(
    RenderFieldArgs args
)
Visual Basic
Public Overridable Sub Process ( _
    args As RenderFieldArgs _
)
Visual C++
public:
virtual void Process(
    RenderFieldArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.RenderField..::..RenderFieldArgs
The arguments.

See Also

ExpandLinks Class
Sitecore.Pipelines.RenderField Namespace


GetDateFieldValue Class

[image]

Sitecore 6.4.1 API
GetDateFieldValue Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetDateFieldValue
Visual Basic
Public Class GetDateFieldValue
Visual C++
public ref class GetDateFieldValue

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.RenderField..::..GetDateFieldValue

See Also

GetDateFieldValue Members
Sitecore.Pipelines.RenderField Namespace


GetDateFieldValue Members

[image] [image]

Sitecore 6.4.1 API
GetDateFieldValue Members
GetDateFieldValue Class Constructors Methods See Also Send Feedback

The GetDateFieldValue type exposes the following members.

Constructors

 | Name | Description
Public method | GetDateFieldValue | Initializes a new instance of the GetDateFieldValue class

Methods

 | Name | Description
Protected method | CreateRenderer | Creates the renderer.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetDateFieldValue Class
Sitecore.Pipelines.RenderField Namespace


GetDateFieldValue Constructor

[image]

Sitecore 6.4.1 API
GetDateFieldValue Constructor
GetDateFieldValue Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetDateFieldValue()
Visual Basic
Public Sub New
Visual C++
public:
GetDateFieldValue()

See Also

GetDateFieldValue Class
Sitecore.Pipelines.RenderField Namespace


GetDateFieldValue Methods

[image] [image]

Sitecore 6.4.1 API
GetDateFieldValue Methods
GetDateFieldValue Class See Also Send Feedback

The GetDateFieldValue type exposes the following members.

Methods

 | Name | Description
Protected method | CreateRenderer | Creates the renderer.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetDateFieldValue Class
Sitecore.Pipelines.RenderField Namespace


CreateRenderer Method

[image]

Sitecore 6.4.1 API
GetDateFieldValue..::..CreateRenderer Method
GetDateFieldValue Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual DateRenderer CreateRenderer()
Visual Basic
Protected Overridable Function CreateRenderer As DateRenderer
Visual C++
protected:
virtual DateRenderer^ CreateRenderer()

Return Value

The renderer.

See Also

GetDateFieldValue Class
Sitecore.Pipelines.RenderField Namespace


Process Method

[image]

Sitecore 6.4.1 API
GetDateFieldValue..::..Process Method
GetDateFieldValue Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    RenderFieldArgs args
)
Visual Basic
Public Sub Process ( _
    args As RenderFieldArgs _
)
Visual C++
public:
void Process(
    RenderFieldArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.RenderField..::..RenderFieldArgs
The arguments.

See Also

GetDateFieldValue Class
Sitecore.Pipelines.RenderField Namespace


GetDocxFieldValue Class

[image]

Sitecore 6.4.1 API
GetDocxFieldValue Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetDocxFieldValue
Visual Basic
Public Class GetDocxFieldValue
Visual C++
public ref class GetDocxFieldValue

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.RenderField..::..GetDocxFieldValue

See Also

GetDocxFieldValue Members
Sitecore.Pipelines.RenderField Namespace


GetDocxFieldValue Members

[image] [image]

Sitecore 6.4.1 API
GetDocxFieldValue Members
GetDocxFieldValue Class Constructors Methods See Also Send Feedback

The GetDocxFieldValue type exposes the following members.

Constructors

 | Name | Description
Public method | GetDocxFieldValue | Initializes a new instance of the GetDocxFieldValue class

Methods

 | Name | Description
Protected method | AddWebEditButtons | Obsolete. Adds the web edit buttons.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFileValueControlId | Gets the file value control id.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IsInWebEditingMode | Determines whether the site is in the web editing mode.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Protected method | RenderHtml | Renders the HTML.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetDocxFieldValue Class
Sitecore.Pipelines.RenderField Namespace


GetDocxFieldValue Constructor

[image]

Sitecore 6.4.1 API
GetDocxFieldValue Constructor
GetDocxFieldValue Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetDocxFieldValue()
Visual Basic
Public Sub New
Visual C++
public:
GetDocxFieldValue()

See Also

GetDocxFieldValue Class
Sitecore.Pipelines.RenderField Namespace


GetDocxFieldValue Methods

[image] [image]

Sitecore 6.4.1 API
GetDocxFieldValue Methods
GetDocxFieldValue Class See Also Send Feedback

The GetDocxFieldValue type exposes the following members.

Methods

 | Name | Description
Protected method | AddWebEditButtons | Obsolete. Adds the web edit buttons.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFileValueControlId | Gets the file value control id.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IsInWebEditingMode | Determines whether the site is in the web editing mode.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Protected method | RenderHtml | Renders the HTML.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetDocxFieldValue Class
Sitecore.Pipelines.RenderField Namespace


AddWebEditButtons Method

[image]

Sitecore 6.4.1 API
GetDocxFieldValue..::..AddWebEditButtons Method
GetDocxFieldValue Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("This method is deprecated")]
protected virtual void AddWebEditButtons(
    RenderFieldArgs args,
    bool isInlineMode
)
Visual Basic
<ObsoleteAttribute("This method is deprecated")> _
Protected Overridable Sub AddWebEditButtons ( _
    args As RenderFieldArgs, _
    isInlineMode As Boolean _
)
Visual C++
[ObsoleteAttribute(L"This method is deprecated")]
protected:
virtual void AddWebEditButtons(
    RenderFieldArgs^ args,
    bool isInlineMode
)

Parameters

args
Type: Sitecore.Pipelines.RenderField..::..RenderFieldArgs
The args.
isInlineMode
Type: System..::..Boolean
if set to true [is inline mode].

See Also

GetDocxFieldValue Class
Sitecore.Pipelines.RenderField Namespace


GetFileValueControlId Method

[image]

Sitecore 6.4.1 API
GetDocxFieldValue..::..GetFileValueControlId Method
GetDocxFieldValue Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected static string GetFileValueControlId(
    RenderFieldArgs args
)
Visual Basic
Protected Shared Function GetFileValueControlId ( _
    args As RenderFieldArgs _
) As String
Visual C++
protected:
static String^ GetFileValueControlId(
    RenderFieldArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.RenderField..::..RenderFieldArgs
The args.

Return Value

The get file value control id.

See Also

GetDocxFieldValue Class
Sitecore.Pipelines.RenderField Namespace


IsInWebEditingMode Method

[image]

Sitecore 6.4.1 API
GetDocxFieldValue..::..IsInWebEditingMode Method
GetDocxFieldValue Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool IsInWebEditingMode(
    RenderFieldArgs args
)
Visual Basic
Protected Overridable Function IsInWebEditingMode ( _
    args As RenderFieldArgs _
) As Boolean
Visual C++
protected:
virtual bool IsInWebEditingMode(
    RenderFieldArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.RenderField..::..RenderFieldArgs
The args.

Return Value

true if [is in web editing mode] [the specified args]; otherwise, false.

See Also

GetDocxFieldValue Class
Sitecore.Pipelines.RenderField Namespace


RenderHtml Method

[image]

Sitecore 6.4.1 API
GetDocxFieldValue..::..RenderHtml Method
GetDocxFieldValue Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string RenderHtml(
    RenderFieldArgs args,
    bool disableLinks
)
Visual Basic
Protected Overridable Function RenderHtml ( _
    args As RenderFieldArgs, _
    disableLinks As Boolean _
) As String
Visual C++
protected:
virtual String^ RenderHtml(
    RenderFieldArgs^ args,
    bool disableLinks
)

Parameters

args
Type: Sitecore.Pipelines.RenderField..::..RenderFieldArgs
The args.
disableLinks
Type: System..::..Boolean
if set to true this instance is disable links.

Return Value

The HTML.

See Also

GetDocxFieldValue Class
Sitecore.Pipelines.RenderField Namespace


GetFieldValue Class

[image]

Sitecore 6.4.1 API
GetFieldValue Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetFieldValue
Visual Basic
Public Class GetFieldValue
Visual C++
public ref class GetFieldValue

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.RenderField..::..GetFieldValue

See Also

GetFieldValue Members
Sitecore.Pipelines.RenderField Namespace


GetFieldValue Members

[image] [image]

Sitecore 6.4.1 API
GetFieldValue Members
GetFieldValue Class Constructors Methods See Also Send Feedback

The GetFieldValue type exposes the following members.

Constructors

 | Name | Description
Public method | GetFieldValue | Initializes a new instance of the GetFieldValue class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetFieldValue Class
Sitecore.Pipelines.RenderField Namespace


GetFieldValue Constructor

[image]

Sitecore 6.4.1 API
GetFieldValue Constructor
GetFieldValue Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetFieldValue()
Visual Basic
Public Sub New
Visual C++
public:
GetFieldValue()

See Also

GetFieldValue Class
Sitecore.Pipelines.RenderField Namespace


GetFieldValue Methods

[image] [image]

Sitecore 6.4.1 API
GetFieldValue Methods
GetFieldValue Class See Also Send Feedback

The GetFieldValue type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetFieldValue Class
Sitecore.Pipelines.RenderField Namespace


Process Method

[image]

Sitecore 6.4.1 API
GetFieldValue..::..Process Method
GetFieldValue Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    RenderFieldArgs args
)
Visual Basic
Public Sub Process ( _
    args As RenderFieldArgs _
)
Visual C++
public:
void Process(
    RenderFieldArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.RenderField..::..RenderFieldArgs
The arguments.

See Also

GetFieldValue Class
Sitecore.Pipelines.RenderField Namespace


GetImageFieldValue Class

[image]

Sitecore 6.4.1 API
GetImageFieldValue Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetImageFieldValue
Visual Basic
Public Class GetImageFieldValue
Visual C++
public ref class GetImageFieldValue

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.RenderField..::..GetImageFieldValue

See Also

GetImageFieldValue Members
Sitecore.Pipelines.RenderField Namespace


GetImageFieldValue Members

[image] [image]

Sitecore 6.4.1 API
GetImageFieldValue Members
GetImageFieldValue Class Constructors Methods See Also Send Feedback

The GetImageFieldValue type exposes the following members.

Constructors

 | Name | Description
Public method | GetImageFieldValue | Initializes a new instance of the GetImageFieldValue class

Methods

 | Name | Description
Protected method | CreateRenderer | Creates the renderer.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetImageFieldValue Class
Sitecore.Pipelines.RenderField Namespace


GetImageFieldValue Constructor

[image]

Sitecore 6.4.1 API
GetImageFieldValue Constructor
GetImageFieldValue Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetImageFieldValue()
Visual Basic
Public Sub New
Visual C++
public:
GetImageFieldValue()

See Also

GetImageFieldValue Class
Sitecore.Pipelines.RenderField Namespace


GetImageFieldValue Methods

[image] [image]

Sitecore 6.4.1 API
GetImageFieldValue Methods
GetImageFieldValue Class See Also Send Feedback

The GetImageFieldValue type exposes the following members.

Methods

 | Name | Description
Protected method | CreateRenderer | Creates the renderer.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetImageFieldValue Class
Sitecore.Pipelines.RenderField Namespace


CreateRenderer Method

[image]

Sitecore 6.4.1 API
GetImageFieldValue..::..CreateRenderer Method
GetImageFieldValue Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual ImageRenderer CreateRenderer()
Visual Basic
Protected Overridable Function CreateRenderer As ImageRenderer
Visual C++
protected:
virtual ImageRenderer^ CreateRenderer()

Return Value

The renderer.

See Also

GetImageFieldValue Class
Sitecore.Pipelines.RenderField Namespace


Process Method

[image]

Sitecore 6.4.1 API
GetImageFieldValue..::..Process Method
GetImageFieldValue Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    RenderFieldArgs args
)
Visual Basic
Public Sub Process ( _
    args As RenderFieldArgs _
)
Visual C++
public:
void Process(
    RenderFieldArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.RenderField..::..RenderFieldArgs
The arguments.

See Also

GetImageFieldValue Class
Sitecore.Pipelines.RenderField Namespace


GetInternalLinkFieldValue Class

[image]

Sitecore 6.4.1 API
GetInternalLinkFieldValue Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetInternalLinkFieldValue
Visual Basic
Public Class GetInternalLinkFieldValue
Visual C++
public ref class GetInternalLinkFieldValue

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.RenderField..::..GetInternalLinkFieldValue

See Also

GetInternalLinkFieldValue Members
Sitecore.Pipelines.RenderField Namespace


GetInternalLinkFieldValue Members

[image] [image]

Sitecore 6.4.1 API
GetInternalLinkFieldValue Members
GetInternalLinkFieldValue Class Constructors Methods See Also Send Feedback

The GetInternalLinkFieldValue type exposes the following members.

Constructors

 | Name | Description
Public method | GetInternalLinkFieldValue | Initializes a new instance of the GetInternalLinkFieldValue class

Methods

 | Name | Description
Protected method | CreateRenderer | Creates the renderer.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetInternalLinkFieldValue Class
Sitecore.Pipelines.RenderField Namespace


GetInternalLinkFieldValue Constructor

[image]

Sitecore 6.4.1 API
GetInternalLinkFieldValue Constructor
GetInternalLinkFieldValue Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetInternalLinkFieldValue()
Visual Basic
Public Sub New
Visual C++
public:
GetInternalLinkFieldValue()

See Also

GetInternalLinkFieldValue Class
Sitecore.Pipelines.RenderField Namespace


GetInternalLinkFieldValue Methods

[image] [image]

Sitecore 6.4.1 API
GetInternalLinkFieldValue Methods
GetInternalLinkFieldValue Class See Also Send Feedback

The GetInternalLinkFieldValue type exposes the following members.

Methods

 | Name | Description
Protected method | CreateRenderer | Creates the renderer.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetInternalLinkFieldValue Class
Sitecore.Pipelines.RenderField Namespace


CreateRenderer Method

[image]

Sitecore 6.4.1 API
GetInternalLinkFieldValue..::..CreateRenderer Method
GetInternalLinkFieldValue Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual InternalLinkRenderer CreateRenderer()
Visual Basic
Protected Overridable Function CreateRenderer As InternalLinkRenderer
Visual C++
protected:
virtual InternalLinkRenderer^ CreateRenderer()

Return Value

The renderer.

See Also

GetInternalLinkFieldValue Class
Sitecore.Pipelines.RenderField Namespace


Process Method

[image]

Sitecore 6.4.1 API
GetInternalLinkFieldValue..::..Process Method
GetInternalLinkFieldValue Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    RenderFieldArgs args
)
Visual Basic
Public Sub Process ( _
    args As RenderFieldArgs _
)
Visual C++
public:
void Process(
    RenderFieldArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.RenderField..::..RenderFieldArgs
The arguments.

See Also

GetInternalLinkFieldValue Class
Sitecore.Pipelines.RenderField Namespace


GetLinkFieldValue Class

[image]

Sitecore 6.4.1 API
GetLinkFieldValue Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetLinkFieldValue
Visual Basic
Public Class GetLinkFieldValue
Visual C++
public ref class GetLinkFieldValue

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.RenderField..::..GetLinkFieldValue

See Also

GetLinkFieldValue Members
Sitecore.Pipelines.RenderField Namespace


GetLinkFieldValue Members

[image] [image]

Sitecore 6.4.1 API
GetLinkFieldValue Members
GetLinkFieldValue Class Constructors Methods See Also Send Feedback

The GetLinkFieldValue type exposes the following members.

Constructors

 | Name | Description
Public method | GetLinkFieldValue | Initializes a new instance of the GetLinkFieldValue class

Methods

 | Name | Description
Protected method | CreateRenderer | Creates the renderer.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetLinkFieldValue Class
Sitecore.Pipelines.RenderField Namespace


GetLinkFieldValue Constructor

[image]

Sitecore 6.4.1 API
GetLinkFieldValue Constructor
GetLinkFieldValue Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetLinkFieldValue()
Visual Basic
Public Sub New
Visual C++
public:
GetLinkFieldValue()

See Also

GetLinkFieldValue Class
Sitecore.Pipelines.RenderField Namespace


GetLinkFieldValue Methods

[image] [image]

Sitecore 6.4.1 API
GetLinkFieldValue Methods
GetLinkFieldValue Class See Also Send Feedback

The GetLinkFieldValue type exposes the following members.

Methods

 | Name | Description
Protected method | CreateRenderer | Creates the renderer.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetLinkFieldValue Class
Sitecore.Pipelines.RenderField Namespace


CreateRenderer Method

[image]

Sitecore 6.4.1 API
GetLinkFieldValue..::..CreateRenderer Method
GetLinkFieldValue Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual LinkRenderer CreateRenderer(
    Item item
)
Visual Basic
Protected Overridable Function CreateRenderer ( _
    item As Item _
) As LinkRenderer
Visual C++
protected:
virtual LinkRenderer^ CreateRenderer(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

The renderer.

See Also

GetLinkFieldValue Class
Sitecore.Pipelines.RenderField Namespace


Process Method

[image]

Sitecore 6.4.1 API
GetLinkFieldValue..::..Process Method
GetLinkFieldValue Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    RenderFieldArgs args
)
Visual Basic
Public Sub Process ( _
    args As RenderFieldArgs _
)
Visual C++
public:
void Process(
    RenderFieldArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.RenderField..::..RenderFieldArgs
The arguments.

See Also

GetLinkFieldValue Class
Sitecore.Pipelines.RenderField Namespace


GetMemoFieldValue Class

[image]

Sitecore 6.4.1 API
GetMemoFieldValue Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GetMemoFieldValue
Visual Basic
Public Class GetMemoFieldValue
Visual C++
public ref class GetMemoFieldValue

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.RenderField..::..GetMemoFieldValue

See Also

GetMemoFieldValue Members
Sitecore.Pipelines.RenderField Namespace


GetMemoFieldValue Members

[image] [image]

Sitecore 6.4.1 API
GetMemoFieldValue Members
GetMemoFieldValue Class Constructors Methods See Also Send Feedback

The GetMemoFieldValue type exposes the following members.

Constructors

 | Name | Description
Public method | GetMemoFieldValue | Initializes a new instance of the GetMemoFieldValue class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetMemoFieldValue Class
Sitecore.Pipelines.RenderField Namespace


GetMemoFieldValue Constructor

[image]

Sitecore 6.4.1 API
GetMemoFieldValue Constructor
GetMemoFieldValue Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetMemoFieldValue()
Visual Basic
Public Sub New
Visual C++
public:
GetMemoFieldValue()

See Also

GetMemoFieldValue Class
Sitecore.Pipelines.RenderField Namespace


GetMemoFieldValue Methods

[image] [image]

Sitecore 6.4.1 API
GetMemoFieldValue Methods
GetMemoFieldValue Class See Also Send Feedback

The GetMemoFieldValue type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetMemoFieldValue Class
Sitecore.Pipelines.RenderField Namespace


Process Method

[image]

Sitecore 6.4.1 API
GetMemoFieldValue..::..Process Method
GetMemoFieldValue Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    RenderFieldArgs args
)
Visual Basic
Public Sub Process ( _
    args As RenderFieldArgs _
)
Visual C++
public:
void Process(
    RenderFieldArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.RenderField..::..RenderFieldArgs
The arguments.

See Also

GetMemoFieldValue Class
Sitecore.Pipelines.RenderField Namespace


RenderFieldArgs Class

[image]

Sitecore 6.4.1 API
RenderFieldArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class RenderFieldArgs : PipelineArgs
Visual Basic
<SerializableAttribute> _
Public Class RenderFieldArgs _
    Inherits PipelineArgs
Visual C++
[SerializableAttribute]
public ref class RenderFieldArgs : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Pipelines.RenderField..::..RenderFieldArgs

See Also

RenderFieldArgs Members
Sitecore.Pipelines.RenderField Namespace


RenderFieldArgs Members

[image] [image]

Sitecore 6.4.1 API
RenderFieldArgs Members
RenderFieldArgs Class Constructors Methods Properties See Also Send Feedback

The RenderFieldArgs type exposes the following members.

Constructors

 | Name | Description
Public method | RenderFieldArgs()()()() | Initializes a new instance of the RenderFieldArgs class.
Protected method | RenderFieldArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the RenderFieldArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetField | Gets the field.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | After | Gets or sets the after.
Public property | Before | Gets or sets the before.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | DisableWebEdit | Gets or sets a value indicating whether the RenderFieldArgs disables the web editing.
Public property | DisableWebEditContentEditing | Gets or sets a value indicating whether the RenderFieldArgs disables the web edit content editing.
Public property | DisableWebEditContentSelecting | Gets or sets a value indicating whether the RenderFieldArgs disables the web edit content selecting.
Public property | EnclosingTag | Gets or sets the enclosing tag.
Public property | FieldName | Gets or sets the name of the field.
Public property | FieldTypeKey | Gets the type of the field.
Public property | FieldValue | Gets or sets the field value.
Public property | Item | Gets or sets the item.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Parameters | Gets the parameters.
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | RawParameters | Gets or sets the raw parameters.
Public property | RenderParameters | Gets render parameters. Render parameters are used to control renderer logic, but are not output themselves
Public property | Result | Gets or sets the result.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
Public property | WebEditButtons | Gets or sets the web edit buttons.
Public property | WebEditClick | Gets or sets the web edit click.
Public property | WebEditParameters | The web edit parameters allow passing arbitrary data to web editing commands. This allows the commands to re-render the field using the same parameters that were used by the original rendering logic without a full page refresh.

See Also

RenderFieldArgs Class
Sitecore.Pipelines.RenderField Namespace


RenderFieldArgs Constructor

[image] [image]

Sitecore 6.4.1 API
RenderFieldArgs Constructor
RenderFieldArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RenderFieldArgs()()()() | Initializes a new instance of the RenderFieldArgs class.
Protected method | RenderFieldArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the RenderFieldArgs class.

See Also

RenderFieldArgs Class
RenderFieldArgs Members
Sitecore.Pipelines.RenderField Namespace


RenderFieldArgs Constructor

[image]

Sitecore 6.4.1 API
RenderFieldArgs Constructor
RenderFieldArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderFieldArgs()
Visual Basic
Public Sub New
Visual C++
public:
RenderFieldArgs()

See Also

RenderFieldArgs Class
RenderFieldArgs Overload
Sitecore.Pipelines.RenderField Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
RenderFieldArgs..::..AddMessage Method
RenderFieldArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

RenderFieldArgs Class
RenderFieldArgs Members
Sitecore.Pipelines.RenderField Namespace


GetField Method

[image]

Sitecore 6.4.1 API
RenderFieldArgs..::..GetField Method
RenderFieldArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Field GetField()
Visual Basic
Public Function GetField As Field
Visual C++
public:
Field^ GetField()

Return Value

The field.

See Also

RenderFieldArgs Class
Sitecore.Pipelines.RenderField Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
RenderFieldArgs..::..GetMessages Method
RenderFieldArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

RenderFieldArgs Class
RenderFieldArgs Members
Sitecore.Pipelines.RenderField Namespace


GetObjectData Method

[image]

Sitecore 6.4.1 API
RenderFieldArgs..::..GetObjectData Method
RenderFieldArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System.Security..::..SecurityException | The caller does not have the required permission.

See Also

RenderFieldArgs Class
Sitecore.Pipelines.RenderField Namespace


RenderFieldArgs Properties

[image] [image]

Sitecore 6.4.1 API
RenderFieldArgs Properties
RenderFieldArgs Class See Also Send Feedback

The RenderFieldArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | After | Gets or sets the after.
Public property | Before | Gets or sets the before.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | DisableWebEdit | Gets or sets a value indicating whether the RenderFieldArgs disables the web editing.
Public property | DisableWebEditContentEditing | Gets or sets a value indicating whether the RenderFieldArgs disables the web edit content editing.
Public property | DisableWebEditContentSelecting | Gets or sets a value indicating whether the RenderFieldArgs disables the web edit content selecting.
Public property | EnclosingTag | Gets or sets the enclosing tag.
Public property | FieldName | Gets or sets the name of the field.
Public property | FieldTypeKey | Gets the type of the field.
Public property | FieldValue | Gets or sets the field value.
Public property | Item | Gets or sets the item.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Parameters | Gets the parameters.
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | RawParameters | Gets or sets the raw parameters.
Public property | RenderParameters | Gets render parameters. Render parameters are used to control renderer logic, but are not output themselves
Public property | Result | Gets or sets the result.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
Public property | WebEditButtons | Gets or sets the web edit buttons.
Public property | WebEditClick | Gets or sets the web edit click.
Public property | WebEditParameters | The web edit parameters allow passing arbitrary data to web editing commands. This allows the commands to re-render the field using the same parameters that were used by the original rendering logic without a full page refresh.

See Also

RenderFieldArgs Class
Sitecore.Pipelines.RenderField Namespace


After Property

[image]

Sitecore 6.4.1 API
RenderFieldArgs..::..After Property
RenderFieldArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string After { get; set; }
Visual Basic
Public Property After As String
    Get
    Set
Visual C++
public:
property String^ After {
    String^ get ();
    void set (String^ value);
}

Field Value

The after.

See Also

RenderFieldArgs Class
Sitecore.Pipelines.RenderField Namespace


Before Property

[image]

Sitecore 6.4.1 API
RenderFieldArgs..::..Before Property
RenderFieldArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Before { get; set; }
Visual Basic
Public Property Before As String
    Get
    Set
Visual C++
public:
property String^ Before {
    String^ get ();
    void set (String^ value);
}

Field Value

The before.

See Also

RenderFieldArgs Class
Sitecore.Pipelines.RenderField Namespace


DisableWebEdit Property

[image]

Sitecore 6.4.1 API
RenderFieldArgs..::..DisableWebEdit Property
RenderFieldArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool DisableWebEdit { get; set; }
Visual Basic
Public Property DisableWebEdit As Boolean
    Get
    Set
Visual C++
public:
property bool DisableWebEdit {
    bool get ();
    void set (bool value);
}

Field Value

true if the RenderFieldArgs disables the web editing; otherwise, false.

See Also

RenderFieldArgs Class
Sitecore.Pipelines.RenderField Namespace


DisableWebEditContentEditing Property

[image]

Sitecore 6.4.1 API
RenderFieldArgs..::..DisableWebEditContentEditing Property
RenderFieldArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool DisableWebEditContentEditing { get; set; }
Visual Basic
Public Property DisableWebEditContentEditing As Boolean
    Get
    Set
Visual C++
public:
property bool DisableWebEditContentEditing {
    bool get ();
    void set (bool value);
}

Field Value

true if the RenderFieldArgs disables the web edit content editing; otherwise, false.

See Also

RenderFieldArgs Class
Sitecore.Pipelines.RenderField Namespace


DisableWebEditContentSelecting Property

[image]

Sitecore 6.4.1 API
RenderFieldArgs..::..DisableWebEditContentSelecting Property
RenderFieldArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool DisableWebEditContentSelecting { get; set; }
Visual Basic
Public Property DisableWebEditContentSelecting As Boolean
    Get
    Set
Visual C++
public:
property bool DisableWebEditContentSelecting {
    bool get ();
    void set (bool value);
}

Field Value

true if the RenderFieldArgs disables the web edit content selecting; otherwise, false.

See Also

RenderFieldArgs Class
Sitecore.Pipelines.RenderField Namespace


EnclosingTag Property

[image]

Sitecore 6.4.1 API
RenderFieldArgs..::..EnclosingTag Property
RenderFieldArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string EnclosingTag { get; set; }
Visual Basic
Public Property EnclosingTag As String
    Get
    Set
Visual C++
public:
property String^ EnclosingTag {
    String^ get ();
    void set (String^ value);
}

Field Value

The enclosing tag.

See Also

RenderFieldArgs Class
Sitecore.Pipelines.RenderField Namespace


FieldName Property

[image]

Sitecore 6.4.1 API
RenderFieldArgs..::..FieldName Property
RenderFieldArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string FieldName { get; set; }
Visual Basic
Public Property FieldName As String
    Get
    Set
Visual C++
public:
property String^ FieldName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the field.

See Also

RenderFieldArgs Class
Sitecore.Pipelines.RenderField Namespace


FieldTypeKey Property

[image]

Sitecore 6.4.1 API
RenderFieldArgs..::..FieldTypeKey Property
RenderFieldArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string FieldTypeKey { get; }
Visual Basic
Public ReadOnly Property FieldTypeKey As String
    Get
Visual C++
public:
property String^ FieldTypeKey {
    String^ get ();
}

Field Value

The type of the field.

See Also

RenderFieldArgs Class
Sitecore.Pipelines.RenderField Namespace


FieldValue Property

[image]

Sitecore 6.4.1 API
RenderFieldArgs..::..FieldValue Property
RenderFieldArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string FieldValue { get; internal set; }
Visual Basic
Public Property FieldValue As String
    Get
    Friend Set
Visual C++
public:
property String^ FieldValue {
    String^ get ();
    internal: void set (String^ value);
}

Field Value

The field value.

See Also

RenderFieldArgs Class
Sitecore.Pipelines.RenderField Namespace


Parameters Property

[image]

Sitecore 6.4.1 API
RenderFieldArgs..::..Parameters Property
RenderFieldArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SafeDictionary<string> Parameters { get; set; }
Visual Basic
Public Property Parameters As SafeDictionary(Of String)
    Get
    Set
Visual C++
public:
property SafeDictionary<String^>^ Parameters {
    SafeDictionary<String^>^ get ();
    void set (SafeDictionary<String^>^ value);
}

Field Value

The parameters.

See Also

RenderFieldArgs Class
Sitecore.Pipelines.RenderField Namespace


RawParameters Property

[image]

Sitecore 6.4.1 API
RenderFieldArgs..::..RawParameters Property
RenderFieldArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string RawParameters { get; set; }
Visual Basic
Public Property RawParameters As String
    Get
    Set
Visual C++
public:
property String^ RawParameters {
    String^ get ();
    void set (String^ value);
}

Field Value

The raw parameters.

See Also

RenderFieldArgs Class
Sitecore.Pipelines.RenderField Namespace


Result Property

[image]

Sitecore 6.4.1 API
RenderFieldArgs..::..Result Property
RenderFieldArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderFieldResult Result { get; set; }
Visual Basic
Public Property Result As RenderFieldResult
    Get
    Set
Visual C++
public:
property RenderFieldResult^ Result {
    RenderFieldResult^ get ();
    void set (RenderFieldResult^ value);
}

Field Value

The result.

See Also

RenderFieldArgs Class
Sitecore.Pipelines.RenderField Namespace


WebEditButtons Property

[image]

Sitecore 6.4.1 API
RenderFieldArgs..::..WebEditButtons Property
RenderFieldArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public List<WebEditButton> WebEditButtons { get; set; }
Visual Basic
Public Property WebEditButtons As List(Of WebEditButton)
    Get
    Set
Visual C++
public:
property List<WebEditButton^>^ WebEditButtons {
    List<WebEditButton^>^ get ();
    void set (List<WebEditButton^>^ value);
}

Field Value

The web edit buttons.

See Also

RenderFieldArgs Class
Sitecore.Pipelines.RenderField Namespace


WebEditClick Property

[image]

Sitecore 6.4.1 API
RenderFieldArgs..::..WebEditClick Property
RenderFieldArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string WebEditClick { get; set; }
Visual Basic
Public Property WebEditClick As String
    Get
    Set
Visual C++
public:
property String^ WebEditClick {
    String^ get ();
    void set (String^ value);
}

Field Value

The web edit click.

See Also

RenderFieldArgs Class
Sitecore.Pipelines.RenderField Namespace


WebEditParameters Property

[image]

Sitecore 6.4.1 API
RenderFieldArgs..::..WebEditParameters Property
RenderFieldArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SafeDictionary<string> WebEditParameters { get; set; }
Visual Basic
Public Property WebEditParameters As SafeDictionary(Of String)
    Get
    Set
Visual C++
public:
property SafeDictionary<String^>^ WebEditParameters {
    SafeDictionary<String^>^ get ();
    void set (SafeDictionary<String^>^ value);
}

Field Value

The web edit parameters.

See Also

RenderFieldArgs Class
Sitecore.Pipelines.RenderField Namespace


RenderWebEditing Class

[image]

Sitecore 6.4.1 API
RenderWebEditing Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RenderWebEditing
Visual Basic
Public Class RenderWebEditing
Visual C++
public ref class RenderWebEditing

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.RenderField..::..RenderWebEditing

See Also

RenderWebEditing Members
Sitecore.Pipelines.RenderField Namespace


RenderWebEditing Members

[image] [image]

Sitecore 6.4.1 API
RenderWebEditing Members
RenderWebEditing Class Constructors Methods See Also Send Feedback

The RenderWebEditing type exposes the following members.

Constructors

 | Name | Description
Public method | RenderWebEditing | Initializes a new instance of the RenderWebEditing class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenderWebEditing Class
Sitecore.Pipelines.RenderField Namespace


RenderWebEditing Constructor

[image]

Sitecore 6.4.1 API
RenderWebEditing Constructor
RenderWebEditing Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderWebEditing()
Visual Basic
Public Sub New
Visual C++
public:
RenderWebEditing()

See Also

RenderWebEditing Class
Sitecore.Pipelines.RenderField Namespace


RenderWebEditing Methods

[image] [image]

Sitecore 6.4.1 API
RenderWebEditing Methods
RenderWebEditing Class See Also Send Feedback

The RenderWebEditing type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Gets the field value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenderWebEditing Class
Sitecore.Pipelines.RenderField Namespace


Process Method

[image]

Sitecore 6.4.1 API
RenderWebEditing..::..Process Method
RenderWebEditing Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    RenderFieldArgs args
)
Visual Basic
Public Sub Process ( _
    args As RenderFieldArgs _
)
Visual C++
public:
void Process(
    RenderFieldArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.RenderField..::..RenderFieldArgs
The arguments.

See Also

RenderWebEditing Class
Sitecore.Pipelines.RenderField Namespace


SetParameters Class

[image]

Sitecore 6.4.1 API
SetParameters Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SetParameters
Visual Basic
Public Class SetParameters
Visual C++
public ref class SetParameters

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.RenderField..::..SetParameters

See Also

SetParameters Members
Sitecore.Pipelines.RenderField Namespace


SetParameters Members

[image] [image]

Sitecore 6.4.1 API
SetParameters Members
SetParameters Class Constructors Methods See Also Send Feedback

The SetParameters type exposes the following members.

Constructors

 | Name | Description
Public method | SetParameters | Initializes a new instance of the SetParameters class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SetParameters Class
Sitecore.Pipelines.RenderField Namespace


SetParameters Constructor

[image]

Sitecore 6.4.1 API
SetParameters Constructor
SetParameters Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SetParameters()
Visual Basic
Public Sub New
Visual C++
public:
SetParameters()

See Also

SetParameters Class
Sitecore.Pipelines.RenderField Namespace


SetParameters Methods

[image] [image]

Sitecore 6.4.1 API
SetParameters Methods
SetParameters Class See Also Send Feedback

The SetParameters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SetParameters Class
Sitecore.Pipelines.RenderField Namespace


Process Method

[image]

Sitecore 6.4.1 API
SetParameters..::..Process Method
SetParameters Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderField
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    RenderFieldArgs args
)
Visual Basic
Public Sub Process ( _
    args As RenderFieldArgs _
)
Visual C++
public:
void Process(
    RenderFieldArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.RenderField..::..RenderFieldArgs
The arguments.

See Also

SetParameters Class
Sitecore.Pipelines.RenderField Namespace


Sitecore.Pipelines.RenderItemTile Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.RenderItemTile Namespace
Send Feedback

Classes

 | Class | Description
Public class | RenderDefaultTile | Implements the ShortenLinks.
Public class | RenderFolderTile |
Public class | RenderItemTileArgs | Implements the RenderField.
Public class | RenderTemplateTile | Implements the ShortenLinks.
Public class | RenderTileBase | Implements the ShortenLinks.


RenderDefaultTile Class

[image]

Sitecore 6.4.1 API
RenderDefaultTile Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderItemTile
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RenderDefaultTile : RenderTileBase
Visual Basic
Public Class RenderDefaultTile _
    Inherits RenderTileBase
Visual C++
public ref class RenderDefaultTile : public RenderTileBase

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.RenderItemTile..::..RenderTileBase
Sitecore.Pipelines.RenderItemTile..::..RenderDefaultTile

See Also

RenderDefaultTile Members
Sitecore.Pipelines.RenderItemTile Namespace


RenderDefaultTile Members

[image] [image]

Sitecore 6.4.1 API
RenderDefaultTile Members
RenderDefaultTile Class Constructors Methods See Also Send Feedback

The RenderDefaultTile type exposes the following members.

Constructors

 | Name | Description
Public method | RenderDefaultTile | Initializes a new instance of the RenderDefaultTile class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Inherited from RenderTileBase.)
Protected method | RenderIcon | Renders the icon. (Inherited from RenderTileBase.)
Protected method | RenderIconOnly | Renders the list. (Inherited from RenderTileBase.)
Protected method | RenderList | Renders the list. (Inherited from RenderTileBase.)
Protected method | RenderThumbnail | Renders the thumbnail. (Inherited from RenderTileBase.)
Protected method | RenderTile | Renders the tile. (Inherited from RenderTileBase.)
Protected method | RenderTileDetails | Renders the tile details. (Inherited from RenderTileBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenderDefaultTile Class
Sitecore.Pipelines.RenderItemTile Namespace


RenderDefaultTile Constructor

[image]

Sitecore 6.4.1 API
RenderDefaultTile Constructor
RenderDefaultTile Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderItemTile
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderDefaultTile()
Visual Basic
Public Sub New
Visual C++
public:
RenderDefaultTile()

See Also

RenderDefaultTile Class
Sitecore.Pipelines.RenderItemTile Namespace


RenderDefaultTile Methods

[image] [image]

Sitecore 6.4.1 API
RenderDefaultTile Methods
RenderDefaultTile Class See Also Send Feedback

The RenderDefaultTile type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Inherited from RenderTileBase.)
Protected method | RenderIcon | Renders the icon. (Inherited from RenderTileBase.)
Protected method | RenderIconOnly | Renders the list. (Inherited from RenderTileBase.)
Protected method | RenderList | Renders the list. (Inherited from RenderTileBase.)
Protected method | RenderThumbnail | Renders the thumbnail. (Inherited from RenderTileBase.)
Protected method | RenderTile | Renders the tile. (Inherited from RenderTileBase.)
Protected method | RenderTileDetails | Renders the tile details. (Inherited from RenderTileBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenderDefaultTile Class
Sitecore.Pipelines.RenderItemTile Namespace


RenderFolderTile Class

[image]

Sitecore 6.4.1 API
RenderFolderTile Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderItemTile
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RenderFolderTile : RenderTileBase
Visual Basic
Public Class RenderFolderTile _
    Inherits RenderTileBase
Visual C++
public ref class RenderFolderTile : public RenderTileBase

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.RenderItemTile..::..RenderTileBase
Sitecore.Pipelines.RenderItemTile..::..RenderFolderTile

See Also

RenderFolderTile Members
Sitecore.Pipelines.RenderItemTile Namespace


RenderFolderTile Members

[image] [image]

Sitecore 6.4.1 API
RenderFolderTile Members
RenderFolderTile Class Constructors Methods See Also Send Feedback

The RenderFolderTile type exposes the following members.

Constructors

 | Name | Description
Public method | RenderFolderTile | Initializes a new instance of the RenderFolderTile class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides RenderTileBase..::..Process(RenderItemTileArgs).)
Protected method | RenderIcon | Renders the icon. (Inherited from RenderTileBase.)
Protected method | RenderIconOnly | Renders the list. (Inherited from RenderTileBase.)
Protected method | RenderList | Renders the list. (Inherited from RenderTileBase.)
Protected method | RenderThumbnail | Renders the thumbnail. (Inherited from RenderTileBase.)
Protected method | RenderTile | Renders the tile. (Inherited from RenderTileBase.)
Protected method | RenderTileDetails | Renders the tile details. (Overrides RenderTileBase..::..RenderTileDetails(HtmlTextWriter, RenderItemTileArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenderFolderTile Class
Sitecore.Pipelines.RenderItemTile Namespace


RenderFolderTile Constructor

[image]

Sitecore 6.4.1 API
RenderFolderTile Constructor
RenderFolderTile Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderItemTile
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderFolderTile()
Visual Basic
Public Sub New
Visual C++
public:
RenderFolderTile()

See Also

RenderFolderTile Class
Sitecore.Pipelines.RenderItemTile Namespace


RenderFolderTile Methods

[image] [image]

Sitecore 6.4.1 API
RenderFolderTile Methods
RenderFolderTile Class See Also Send Feedback

The RenderFolderTile type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides RenderTileBase..::..Process(RenderItemTileArgs).)
Protected method | RenderIcon | Renders the icon. (Inherited from RenderTileBase.)
Protected method | RenderIconOnly | Renders the list. (Inherited from RenderTileBase.)
Protected method | RenderList | Renders the list. (Inherited from RenderTileBase.)
Protected method | RenderThumbnail | Renders the thumbnail. (Inherited from RenderTileBase.)
Protected method | RenderTile | Renders the tile. (Inherited from RenderTileBase.)
Protected method | RenderTileDetails | Renders the tile details. (Overrides RenderTileBase..::..RenderTileDetails(HtmlTextWriter, RenderItemTileArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenderFolderTile Class
Sitecore.Pipelines.RenderItemTile Namespace


Process Method

[image]

Sitecore 6.4.1 API
RenderFolderTile..::..Process Method
RenderFolderTile Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderItemTile
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    RenderItemTileArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As RenderItemTileArgs _
)
Visual C++
public:
virtual void Process(
    RenderItemTileArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.RenderItemTile..::..RenderItemTileArgs
The arguments.

See Also

RenderFolderTile Class
Sitecore.Pipelines.RenderItemTile Namespace


RenderTileDetails Method

[image]

Sitecore 6.4.1 API
RenderFolderTile..::..RenderTileDetails Method
RenderFolderTile Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderItemTile
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void RenderTileDetails(
    HtmlTextWriter output,
    RenderItemTileArgs args
)
Visual Basic
Protected Overrides Sub RenderTileDetails ( _
    output As HtmlTextWriter, _
    args As RenderItemTileArgs _
)
Visual C++
protected:
virtual void RenderTileDetails(
    HtmlTextWriter^ output,
    RenderItemTileArgs^ args
) override

Parameters

output
Type: System.Web.UI..::..HtmlTextWriter
The output.
args
Type: Sitecore.Pipelines.RenderItemTile..::..RenderItemTileArgs
The arguments.

See Also

RenderFolderTile Class
Sitecore.Pipelines.RenderItemTile Namespace


RenderItemTileArgs Class

[image]

Sitecore 6.4.1 API
RenderItemTileArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderItemTile
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class RenderItemTileArgs : PipelineArgs
Visual Basic
<SerializableAttribute> _
Public Class RenderItemTileArgs _
    Inherits PipelineArgs
Visual C++
[SerializableAttribute]
public ref class RenderItemTileArgs : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Pipelines.RenderItemTile..::..RenderItemTileArgs

See Also

RenderItemTileArgs Members
Sitecore.Pipelines.RenderItemTile Namespace


RenderItemTileArgs Members

[image] [image]

Sitecore 6.4.1 API
RenderItemTileArgs Members
RenderItemTileArgs Class Constructors Methods Properties See Also Send Feedback

The RenderItemTileArgs type exposes the following members.

Constructors

 | Name | Description
Protected method | RenderItemTileArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the RenderItemTileArgs class.
Public method | RenderItemTileArgs(Item, TileView, ImageDimension, String) | Initializes a new instance of the RenderItemTileArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | Click | Gets the Click event.
Public property | CssClass | Gets or sets the CSS class.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | DoubleClick | Gets or sets the double click.
Public property | ImageDimension | Gets the image dimension.
Public property | Item | Gets the item.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
Public property | Tile | Gets or sets the tile.
Public property | View | Gets the view.

See Also

RenderItemTileArgs Class
Sitecore.Pipelines.RenderItemTile Namespace


RenderItemTileArgs Constructor

[image] [image]

Sitecore 6.4.1 API
RenderItemTileArgs Constructor
RenderItemTileArgs Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RenderItemTileArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the RenderItemTileArgs class.
Public method | RenderItemTileArgs(Item, TileView, ImageDimension, String) | Initializes a new instance of the RenderItemTileArgs class.

See Also

RenderItemTileArgs Class
RenderItemTileArgs Members
Sitecore.Pipelines.RenderItemTile Namespace


RenderItemTileArgs Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
RenderItemTileArgs Constructor (SerializationInfo, StreamingContext)
RenderItemTileArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderItemTile
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected RenderItemTileArgs(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
RenderItemTileArgs(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

RenderItemTileArgs Class
RenderItemTileArgs Overload
Sitecore.Pipelines.RenderItemTile Namespace


RenderItemTileArgs Constructor (Item, TileView, ImageDimension, String)

[image]

Sitecore 6.4.1 API
RenderItemTileArgs Constructor (Item, TileView, ImageDimension, String)
RenderItemTileArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderItemTile
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderItemTileArgs(
    Item item,
    TileView view,
    ImageDimension imageDimension,
    string click
)
Visual Basic
Public Sub New ( _
    item As Item, _
    view As TileView, _
    imageDimension As ImageDimension, _
    click As String _
)
Visual C++
public:
RenderItemTileArgs(
    Item^ item,
    TileView view,
    ImageDimension imageDimension,
    String^ click
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
view
Type: Sitecore.Shell.Web.UI..::..TileView
The view.
imageDimension
Type: Sitecore.Web.UI..::..ImageDimension
The image dimension.
click
Type: System..::..String
The click.

See Also

RenderItemTileArgs Class
RenderItemTileArgs Overload
Sitecore.Pipelines.RenderItemTile Namespace


RenderItemTileArgs Methods

[image] [image]

Sitecore 6.4.1 API
RenderItemTileArgs Methods
RenderItemTileArgs Class See Also Send Feedback

The RenderItemTileArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenderItemTileArgs Class
Sitecore.Pipelines.RenderItemTile Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
RenderItemTileArgs..::..AddMessage Method
RenderItemTileArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

RenderItemTileArgs Class
RenderItemTileArgs Members
Sitecore.Pipelines.RenderItemTile Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
RenderItemTileArgs..::..GetMessages Method
RenderItemTileArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

RenderItemTileArgs Class
RenderItemTileArgs Members
Sitecore.Pipelines.RenderItemTile Namespace


GetObjectData Method

[image]

Sitecore 6.4.1 API
RenderItemTileArgs..::..GetObjectData Method
RenderItemTileArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderItemTile
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System.Security..::..SecurityException | The caller does not have the required permission.

See Also

RenderItemTileArgs Class
Sitecore.Pipelines.RenderItemTile Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
RenderItemTileArgs..::..Suspend Method
RenderItemTileArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

RenderItemTileArgs Class
RenderItemTileArgs Members
Sitecore.Pipelines.RenderItemTile Namespace


RenderItemTileArgs Properties

[image] [image]

Sitecore 6.4.1 API
RenderItemTileArgs Properties
RenderItemTileArgs Class See Also Send Feedback

The RenderItemTileArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | Click | Gets the Click event.
Public property | CssClass | Gets or sets the CSS class.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | DoubleClick | Gets or sets the double click.
Public property | ImageDimension | Gets the image dimension.
Public property | Item | Gets the item.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
Public property | Tile | Gets or sets the tile.
Public property | View | Gets the view.

See Also

RenderItemTileArgs Class
Sitecore.Pipelines.RenderItemTile Namespace


Click Property

[image]

Sitecore 6.4.1 API
RenderItemTileArgs..::..Click Property
RenderItemTileArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderItemTile
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Click { get; }
Visual Basic
Public ReadOnly Property Click As String
    Get
Visual C++
public:
property String^ Click {
    String^ get ();
}

Field Value

The event to be executed.

See Also

RenderItemTileArgs Class
Sitecore.Pipelines.RenderItemTile Namespace


CssClass Property

[image]

Sitecore 6.4.1 API
RenderItemTileArgs..::..CssClass Property
RenderItemTileArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderItemTile
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string CssClass { get; set; }
Visual Basic
Public Property CssClass As String
    Get
    Set
Visual C++
public:
property String^ CssClass {
    String^ get ();
    void set (String^ value);
}

Field Value

The CSS class.

See Also

RenderItemTileArgs Class
Sitecore.Pipelines.RenderItemTile Namespace


DoubleClick Property

[image]

Sitecore 6.4.1 API
RenderItemTileArgs..::..DoubleClick Property
RenderItemTileArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderItemTile
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string DoubleClick { get; set; }
Visual Basic
Public Property DoubleClick As String
    Get
    Set
Visual C++
public:
property String^ DoubleClick {
    String^ get ();
    void set (String^ value);
}

Field Value

The double click.

See Also

RenderItemTileArgs Class
Sitecore.Pipelines.RenderItemTile Namespace


ImageDimension Property

[image]

Sitecore 6.4.1 API
RenderItemTileArgs..::..ImageDimension Property
RenderItemTileArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderItemTile
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ImageDimension ImageDimension { get; }
Visual Basic
Public ReadOnly Property ImageDimension As ImageDimension
    Get
Visual C++
public:
property ImageDimension ImageDimension {
    ImageDimension get ();
}

Field Value

The image dimension.

See Also

RenderItemTileArgs Class
Sitecore.Pipelines.RenderItemTile Namespace


Item Property

[image]

Sitecore 6.4.1 API
RenderItemTileArgs..::..Item Property
RenderItemTileArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderItemTile
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Item { get; }
Visual Basic
Public ReadOnly Property Item As Item
    Get
Visual C++
public:
property Item^ Item {
    Item^ get ();
}

Field Value

The item.

See Also

RenderItemTileArgs Class
Sitecore.Pipelines.RenderItemTile Namespace


RenderTemplateTile Class

[image]

Sitecore 6.4.1 API
RenderTemplateTile Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderItemTile
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RenderTemplateTile : RenderTileBase
Visual Basic
Public Class RenderTemplateTile _
    Inherits RenderTileBase
Visual C++
public ref class RenderTemplateTile : public RenderTileBase

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.RenderItemTile..::..RenderTileBase
Sitecore.Pipelines.RenderItemTile..::..RenderTemplateTile

See Also

RenderTemplateTile Members
Sitecore.Pipelines.RenderItemTile Namespace


RenderTemplateTile Members

[image] [image]

Sitecore 6.4.1 API
RenderTemplateTile Members
RenderTemplateTile Class Constructors Methods See Also Send Feedback

The RenderTemplateTile type exposes the following members.

Constructors

 | Name | Description
Public method | RenderTemplateTile | Initializes a new instance of the RenderTemplateTile class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides RenderTileBase..::..Process(RenderItemTileArgs).)
Protected method | RenderIcon | Renders the icon. (Inherited from RenderTileBase.)
Protected method | RenderIconOnly | Renders the list. (Inherited from RenderTileBase.)
Protected method | RenderList | Renders the list. (Inherited from RenderTileBase.)
Protected method | RenderThumbnail | Renders the thumbnail. (Inherited from RenderTileBase.)
Protected method | RenderTile | Renders the tile. (Inherited from RenderTileBase.)
Protected method | RenderTileDetails | Renders the tile details. (Overrides RenderTileBase..::..RenderTileDetails(HtmlTextWriter, RenderItemTileArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenderTemplateTile Class
Sitecore.Pipelines.RenderItemTile Namespace


RenderTemplateTile Constructor

[image]

Sitecore 6.4.1 API
RenderTemplateTile Constructor
RenderTemplateTile Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderItemTile
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderTemplateTile()
Visual Basic
Public Sub New
Visual C++
public:
RenderTemplateTile()

See Also

RenderTemplateTile Class
Sitecore.Pipelines.RenderItemTile Namespace


RenderTemplateTile Methods

[image] [image]

Sitecore 6.4.1 API
RenderTemplateTile Methods
RenderTemplateTile Class See Also Send Feedback

The RenderTemplateTile type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides RenderTileBase..::..Process(RenderItemTileArgs).)
Protected method | RenderIcon | Renders the icon. (Inherited from RenderTileBase.)
Protected method | RenderIconOnly | Renders the list. (Inherited from RenderTileBase.)
Protected method | RenderList | Renders the list. (Inherited from RenderTileBase.)
Protected method | RenderThumbnail | Renders the thumbnail. (Inherited from RenderTileBase.)
Protected method | RenderTile | Renders the tile. (Inherited from RenderTileBase.)
Protected method | RenderTileDetails | Renders the tile details. (Overrides RenderTileBase..::..RenderTileDetails(HtmlTextWriter, RenderItemTileArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenderTemplateTile Class
Sitecore.Pipelines.RenderItemTile Namespace


Process Method

[image]

Sitecore 6.4.1 API
RenderTemplateTile..::..Process Method
RenderTemplateTile Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderItemTile
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    RenderItemTileArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As RenderItemTileArgs _
)
Visual C++
public:
virtual void Process(
    RenderItemTileArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.RenderItemTile..::..RenderItemTileArgs
The arguments.

See Also

RenderTemplateTile Class
Sitecore.Pipelines.RenderItemTile Namespace


RenderTileDetails Method

[image]

Sitecore 6.4.1 API
RenderTemplateTile..::..RenderTileDetails Method
RenderTemplateTile Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderItemTile
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void RenderTileDetails(
    HtmlTextWriter output,
    RenderItemTileArgs args
)
Visual Basic
Protected Overrides Sub RenderTileDetails ( _
    output As HtmlTextWriter, _
    args As RenderItemTileArgs _
)
Visual C++
protected:
virtual void RenderTileDetails(
    HtmlTextWriter^ output,
    RenderItemTileArgs^ args
) override

Parameters

output
Type: System.Web.UI..::..HtmlTextWriter
The output.
args
Type: Sitecore.Pipelines.RenderItemTile..::..RenderItemTileArgs
The arguments.

See Also

RenderTemplateTile Class
Sitecore.Pipelines.RenderItemTile Namespace


RenderTileBase Class

[image]

Sitecore 6.4.1 API
RenderTileBase Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderItemTile
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class RenderTileBase
Visual Basic
Public MustInherit Class RenderTileBase
Visual C++
public ref class RenderTileBase abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.RenderItemTile..::..RenderTileBase
Sitecore.Pipelines.RenderItemTile..::..RenderDefaultTile
Sitecore.Pipelines.RenderItemTile..::..RenderFolderTile
Sitecore.Pipelines.RenderItemTile..::..RenderTemplateTile

See Also

RenderTileBase Members
Sitecore.Pipelines.RenderItemTile Namespace


RenderTileBase Members

[image] [image]

Sitecore 6.4.1 API
RenderTileBase Members
RenderTileBase Class Constructors Methods See Also Send Feedback

The RenderTileBase type exposes the following members.

Constructors

 | Name | Description
Protected method | RenderTileBase | Initializes a new instance of the RenderTileBase class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Protected method | RenderIcon | Renders the icon.
Protected method | RenderIconOnly | Renders the list.
Protected method | RenderList | Renders the list.
Protected method | RenderThumbnail | Renders the thumbnail.
Protected method | RenderTile | Renders the tile.
Protected method | RenderTileDetails | Renders the tile details.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenderTileBase Class
Sitecore.Pipelines.RenderItemTile Namespace


RenderTileBase Constructor

[image]

Sitecore 6.4.1 API
RenderTileBase Constructor
RenderTileBase Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderItemTile
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected RenderTileBase()
Visual Basic
Protected Sub New
Visual C++
protected:
RenderTileBase()

See Also

RenderTileBase Class
Sitecore.Pipelines.RenderItemTile Namespace


RenderTileBase Methods

[image] [image]

Sitecore 6.4.1 API
RenderTileBase Methods
RenderTileBase Class See Also Send Feedback

The RenderTileBase type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Protected method | RenderIcon | Renders the icon.
Protected method | RenderIconOnly | Renders the list.
Protected method | RenderList | Renders the list.
Protected method | RenderThumbnail | Renders the thumbnail.
Protected method | RenderTile | Renders the tile.
Protected method | RenderTileDetails | Renders the tile details.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenderTileBase Class
Sitecore.Pipelines.RenderItemTile Namespace


Process Method

[image]

Sitecore 6.4.1 API
RenderTileBase..::..Process Method
RenderTileBase Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderItemTile
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Process(
    RenderItemTileArgs args
)
Visual Basic
Public Overridable Sub Process ( _
    args As RenderItemTileArgs _
)
Visual C++
public:
virtual void Process(
    RenderItemTileArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.RenderItemTile..::..RenderItemTileArgs
The arguments.

See Also

RenderTileBase Class
Sitecore.Pipelines.RenderItemTile Namespace


RenderIcon Method

[image]

Sitecore 6.4.1 API
RenderTileBase..::..RenderIcon Method
RenderTileBase Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderItemTile
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void RenderIcon(
    RenderItemTileArgs args
)
Visual Basic
Protected Overridable Sub RenderIcon ( _
    args As RenderItemTileArgs _
)
Visual C++
protected:
virtual void RenderIcon(
    RenderItemTileArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.RenderItemTile..::..RenderItemTileArgs
The arguments.

Exceptions

Exception | Condition
System..::..ArgumentNullException |
System..::..FormatException |

See Also

RenderTileBase Class
Sitecore.Pipelines.RenderItemTile Namespace


RenderIconOnly Method

[image]

Sitecore 6.4.1 API
RenderTileBase..::..RenderIconOnly Method
RenderTileBase Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderItemTile
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void RenderIconOnly(
    RenderItemTileArgs args
)
Visual Basic
Protected Overridable Sub RenderIconOnly ( _
    args As RenderItemTileArgs _
)
Visual C++
protected:
virtual void RenderIconOnly(
    RenderItemTileArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.RenderItemTile..::..RenderItemTileArgs
The arguments.

See Also

RenderTileBase Class
Sitecore.Pipelines.RenderItemTile Namespace


RenderList Method

[image]

Sitecore 6.4.1 API
RenderTileBase..::..RenderList Method
RenderTileBase Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderItemTile
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void RenderList(
    RenderItemTileArgs args
)
Visual Basic
Protected Overridable Sub RenderList ( _
    args As RenderItemTileArgs _
)
Visual C++
protected:
virtual void RenderList(
    RenderItemTileArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.RenderItemTile..::..RenderItemTileArgs
The arguments.

See Also

RenderTileBase Class
Sitecore.Pipelines.RenderItemTile Namespace


RenderThumbnail Method

[image]

Sitecore 6.4.1 API
RenderTileBase..::..RenderThumbnail Method
RenderTileBase Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderItemTile
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void RenderThumbnail(
    RenderItemTileArgs args
)
Visual Basic
Protected Overridable Sub RenderThumbnail ( _
    args As RenderItemTileArgs _
)
Visual C++
protected:
virtual void RenderThumbnail(
    RenderItemTileArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.RenderItemTile..::..RenderItemTileArgs
The arguments.

See Also

RenderTileBase Class
Sitecore.Pipelines.RenderItemTile Namespace


RenderTile Method

[image]

Sitecore 6.4.1 API
RenderTileBase..::..RenderTile Method
RenderTileBase Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderItemTile
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void RenderTile(
    RenderItemTileArgs args
)
Visual Basic
Protected Overridable Sub RenderTile ( _
    args As RenderItemTileArgs _
)
Visual C++
protected:
virtual void RenderTile(
    RenderItemTileArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.RenderItemTile..::..RenderItemTileArgs
The arguments.

See Also

RenderTileBase Class
Sitecore.Pipelines.RenderItemTile Namespace


RenderTileDetails Method

[image]

Sitecore 6.4.1 API
RenderTileBase..::..RenderTileDetails Method
RenderTileBase Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderItemTile
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void RenderTileDetails(
    HtmlTextWriter output,
    RenderItemTileArgs args
)
Visual Basic
Protected Overridable Sub RenderTileDetails ( _
    output As HtmlTextWriter, _
    args As RenderItemTileArgs _
)
Visual C++
protected:
virtual void RenderTileDetails(
    HtmlTextWriter^ output,
    RenderItemTileArgs^ args
)

Parameters

output
Type: System.Web.UI..::..HtmlTextWriter
The output.
args
Type: Sitecore.Pipelines.RenderItemTile..::..RenderItemTileArgs
The arguments.

See Also

RenderTileBase Class
Sitecore.Pipelines.RenderItemTile Namespace


Sitecore.Pipelines.RenderLayout Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.RenderLayout Namespace
Send Feedback

Classes

 | Class | Description
Public class | BrowserCaching | Sets the browser caching.
Public class | BuildTree | BuildTree
Public class | InsertRenderings | Inserts renderings.
Public class | InsertSystemControls | InsertSystemControls class
Public class | InsertUnusedControls | InsertUnusedControls class
Public class | PageExtenders | Inserts page extenders.
Public class | PageHandlers | Inserts page handlers.
Public class | RenderLayoutArgs | Argument class for IRenderLayoutProcessor implementations.
Public class | RenderLayoutProcessor | RenderLayoutProcessor class
Public class | SecurityCheck | Checks for security settings.


BrowserCaching Class

[image]

Sitecore 6.4.1 API
BrowserCaching Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class BrowserCaching : RenderLayoutProcessor
Visual Basic
Public Class BrowserCaching _
    Inherits RenderLayoutProcessor
Visual C++
public ref class BrowserCaching : public RenderLayoutProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.RenderLayout..::..RenderLayoutProcessor
Sitecore.Pipelines.RenderLayout..::..BrowserCaching

See Also

BrowserCaching Members
Sitecore.Pipelines.RenderLayout Namespace


BrowserCaching Members

[image] [image]

Sitecore 6.4.1 API
BrowserCaching Members
BrowserCaching Class Constructors Methods See Also Send Feedback

The BrowserCaching type exposes the following members.

Constructors

 | Name | Description
Public method | BrowserCaching | Initializes a new instance of the BrowserCaching class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Set browser caching headers. (Overrides RenderLayoutProcessor..::..Process(RenderLayoutArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BrowserCaching Class
Sitecore.Pipelines.RenderLayout Namespace


BrowserCaching Constructor

[image]

Sitecore 6.4.1 API
BrowserCaching Constructor
BrowserCaching Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BrowserCaching()
Visual Basic
Public Sub New
Visual C++
public:
BrowserCaching()

See Also

BrowserCaching Class
Sitecore.Pipelines.RenderLayout Namespace


BrowserCaching Methods

[image] [image]

Sitecore 6.4.1 API
BrowserCaching Methods
BrowserCaching Class See Also Send Feedback

The BrowserCaching type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Set browser caching headers. (Overrides RenderLayoutProcessor..::..Process(RenderLayoutArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BrowserCaching Class
Sitecore.Pipelines.RenderLayout Namespace


Process Method

[image]

Sitecore 6.4.1 API
BrowserCaching..::..Process Method
BrowserCaching Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    RenderLayoutArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As RenderLayoutArgs _
)
Visual C++
public:
virtual void Process(
    RenderLayoutArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.RenderLayout..::..RenderLayoutArgs
The arguments.

See Also

BrowserCaching Class
Sitecore.Pipelines.RenderLayout Namespace


BuildTree Class

[image]

Sitecore 6.4.1 API
BuildTree Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class BuildTree : RenderLayoutProcessor
Visual Basic
Public Class BuildTree _
    Inherits RenderLayoutProcessor
Visual C++
public ref class BuildTree : public RenderLayoutProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.RenderLayout..::..RenderLayoutProcessor
Sitecore.Pipelines.RenderLayout..::..BuildTree

See Also

BuildTree Members
Sitecore.Pipelines.RenderLayout Namespace


BuildTree Members

[image] [image]

Sitecore 6.4.1 API
BuildTree Members
BuildTree Class Constructors Methods See Also Send Feedback

The BuildTree type exposes the following members.

Constructors

 | Name | Description
Public method | BuildTree | Initializes a new instance of the BuildTree class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides RenderLayoutProcessor..::..Process(RenderLayoutArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BuildTree Class
Sitecore.Pipelines.RenderLayout Namespace


BuildTree Constructor

[image]

Sitecore 6.4.1 API
BuildTree Constructor
BuildTree Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BuildTree()
Visual Basic
Public Sub New
Visual C++
public:
BuildTree()

See Also

BuildTree Class
Sitecore.Pipelines.RenderLayout Namespace


BuildTree Methods

[image] [image]

Sitecore 6.4.1 API
BuildTree Methods
BuildTree Class See Also Send Feedback

The BuildTree type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides RenderLayoutProcessor..::..Process(RenderLayoutArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BuildTree Class
Sitecore.Pipelines.RenderLayout Namespace


Process Method

[image]

Sitecore 6.4.1 API
BuildTree..::..Process Method
BuildTree Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    RenderLayoutArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As RenderLayoutArgs _
)
Visual C++
public:
virtual void Process(
    RenderLayoutArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.RenderLayout..::..RenderLayoutArgs
The arguments.

See Also

BuildTree Class
Sitecore.Pipelines.RenderLayout Namespace


InsertRenderings Class

[image]

Sitecore 6.4.1 API
InsertRenderings Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class InsertRenderings : RenderLayoutProcessor
Visual Basic
Public Class InsertRenderings _
    Inherits RenderLayoutProcessor
Visual C++
public ref class InsertRenderings : public RenderLayoutProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.RenderLayout..::..RenderLayoutProcessor
Sitecore.Pipelines.RenderLayout..::..InsertRenderings

See Also

InsertRenderings Members
Sitecore.Pipelines.RenderLayout Namespace


InsertRenderings Members

[image] [image]

Sitecore 6.4.1 API
InsertRenderings Members
InsertRenderings Class Constructors Methods See Also Send Feedback

The InsertRenderings type exposes the following members.

Constructors

 | Name | Description
Public method | InsertRenderings | Initializes a new instance of the InsertRenderings class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides RenderLayoutProcessor..::..Process(RenderLayoutArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InsertRenderings Class
Sitecore.Pipelines.RenderLayout Namespace


InsertRenderings Methods

[image] [image]

Sitecore 6.4.1 API
InsertRenderings Methods
InsertRenderings Class See Also Send Feedback

The InsertRenderings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides RenderLayoutProcessor..::..Process(RenderLayoutArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InsertRenderings Class
Sitecore.Pipelines.RenderLayout Namespace


Process Method

[image]

Sitecore 6.4.1 API
InsertRenderings..::..Process Method
InsertRenderings Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    RenderLayoutArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As RenderLayoutArgs _
)
Visual C++
public:
virtual void Process(
    RenderLayoutArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.RenderLayout..::..RenderLayoutArgs
The arguments.

See Also

InsertRenderings Class
Sitecore.Pipelines.RenderLayout Namespace


InsertSystemControls Class

[image]

Sitecore 6.4.1 API
InsertSystemControls Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class InsertSystemControls : RenderLayoutProcessor
Visual Basic
Public Class InsertSystemControls _
    Inherits RenderLayoutProcessor
Visual C++
public ref class InsertSystemControls : public RenderLayoutProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.RenderLayout..::..RenderLayoutProcessor
Sitecore.Pipelines.RenderLayout..::..InsertSystemControls

See Also

InsertSystemControls Members
Sitecore.Pipelines.RenderLayout Namespace


InsertSystemControls Members

[image] [image]

Sitecore 6.4.1 API
InsertSystemControls Members
InsertSystemControls Class Constructors Methods See Also Send Feedback

The InsertSystemControls type exposes the following members.

Constructors

 | Name | Description
Public method | InsertSystemControls | Initializes a new instance of the InsertSystemControls class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides RenderLayoutProcessor..::..Process(RenderLayoutArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InsertSystemControls Class
Sitecore.Pipelines.RenderLayout Namespace


InsertSystemControls Constructor

[image]

Sitecore 6.4.1 API
InsertSystemControls Constructor
InsertSystemControls Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public InsertSystemControls()
Visual Basic
Public Sub New
Visual C++
public:
InsertSystemControls()

See Also

InsertSystemControls Class
Sitecore.Pipelines.RenderLayout Namespace


InsertSystemControls Methods

[image] [image]

Sitecore 6.4.1 API
InsertSystemControls Methods
InsertSystemControls Class See Also Send Feedback

The InsertSystemControls type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides RenderLayoutProcessor..::..Process(RenderLayoutArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InsertSystemControls Class
Sitecore.Pipelines.RenderLayout Namespace


Process Method

[image]

Sitecore 6.4.1 API
InsertSystemControls..::..Process Method
InsertSystemControls Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    RenderLayoutArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As RenderLayoutArgs _
)
Visual C++
public:
virtual void Process(
    RenderLayoutArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.RenderLayout..::..RenderLayoutArgs
The args.

See Also

InsertSystemControls Class
Sitecore.Pipelines.RenderLayout Namespace


InsertUnusedControls Members

[image] [image]

Sitecore 6.4.1 API
InsertUnusedControls Members
InsertUnusedControls Class Constructors Methods See Also Send Feedback

The InsertUnusedControls type exposes the following members.

Constructors

 | Name | Description
Public method | InsertUnusedControls | Initializes a new instance of the InsertUnusedControls class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides RenderLayoutProcessor..::..Process(RenderLayoutArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InsertUnusedControls Class
Sitecore.Pipelines.RenderLayout Namespace


InsertUnusedControls Methods

[image] [image]

Sitecore 6.4.1 API
InsertUnusedControls Methods
InsertUnusedControls Class See Also Send Feedback

The InsertUnusedControls type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides RenderLayoutProcessor..::..Process(RenderLayoutArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InsertUnusedControls Class
Sitecore.Pipelines.RenderLayout Namespace


Process Method

[image]

Sitecore 6.4.1 API
InsertUnusedControls..::..Process Method
InsertUnusedControls Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    RenderLayoutArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As RenderLayoutArgs _
)
Visual C++
public:
virtual void Process(
    RenderLayoutArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.RenderLayout..::..RenderLayoutArgs
The args.

See Also

InsertUnusedControls Class
Sitecore.Pipelines.RenderLayout Namespace


PageExtenders Class

[image]

Sitecore 6.4.1 API
PageExtenders Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PageExtenders : RenderLayoutProcessor
Visual Basic
Public Class PageExtenders _
    Inherits RenderLayoutProcessor
Visual C++
public ref class PageExtenders : public RenderLayoutProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.RenderLayout..::..RenderLayoutProcessor
Sitecore.Pipelines.RenderLayout..::..PageExtenders

See Also

PageExtenders Members
Sitecore.Pipelines.RenderLayout Namespace


PageExtenders Members

[image] [image]

Sitecore 6.4.1 API
PageExtenders Members
PageExtenders Class Constructors Methods See Also Send Feedback

The PageExtenders type exposes the following members.

Constructors

 | Name | Description
Public method | PageExtenders | Initializes a new instance of the PageExtenders class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides RenderLayoutProcessor..::..Process(RenderLayoutArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PageExtenders Class
Sitecore.Pipelines.RenderLayout Namespace


PageExtenders Constructor

[image]

Sitecore 6.4.1 API
PageExtenders Constructor
PageExtenders Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PageExtenders()
Visual Basic
Public Sub New
Visual C++
public:
PageExtenders()

See Also

PageExtenders Class
Sitecore.Pipelines.RenderLayout Namespace


PageExtenders Methods

[image] [image]

Sitecore 6.4.1 API
PageExtenders Methods
PageExtenders Class See Also Send Feedback

The PageExtenders type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor. (Overrides RenderLayoutProcessor..::..Process(RenderLayoutArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PageExtenders Class
Sitecore.Pipelines.RenderLayout Namespace


Process Method

[image]

Sitecore 6.4.1 API
PageExtenders..::..Process Method
PageExtenders Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    RenderLayoutArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As RenderLayoutArgs _
)
Visual C++
public:
virtual void Process(
    RenderLayoutArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.RenderLayout..::..RenderLayoutArgs
The arguments.

See Also

PageExtenders Class
Sitecore.Pipelines.RenderLayout Namespace


PageHandlers Class

[image]

Sitecore 6.4.1 API
PageHandlers Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PageHandlers : RenderLayoutProcessor
Visual Basic
Public Class PageHandlers _
    Inherits RenderLayoutProcessor
Visual C++
public ref class PageHandlers : public RenderLayoutProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.RenderLayout..::..RenderLayoutProcessor
Sitecore.Pipelines.RenderLayout..::..PageHandlers

See Also

PageHandlers Members
Sitecore.Pipelines.RenderLayout Namespace


PageHandlers Members

[image] [image]

Sitecore 6.4.1 API
PageHandlers Members
PageHandlers Class Constructors Methods See Also Send Feedback

The PageHandlers type exposes the following members.

Constructors

 | Name | Description
Public method | PageHandlers | Initializes a new instance of the PageHandlers class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Call custom page handlers. (Overrides RenderLayoutProcessor..::..Process(RenderLayoutArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PageHandlers Class
Sitecore.Pipelines.RenderLayout Namespace


PageHandlers Constructor

[image]

Sitecore 6.4.1 API
PageHandlers Constructor
PageHandlers Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PageHandlers()
Visual Basic
Public Sub New
Visual C++
public:
PageHandlers()

See Also

PageHandlers Class
Sitecore.Pipelines.RenderLayout Namespace


PageHandlers Methods

[image] [image]

Sitecore 6.4.1 API
PageHandlers Methods
PageHandlers Class See Also Send Feedback

The PageHandlers type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Call custom page handlers. (Overrides RenderLayoutProcessor..::..Process(RenderLayoutArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PageHandlers Class
Sitecore.Pipelines.RenderLayout Namespace


RenderLayoutArgs Members

[image] [image]

Sitecore 6.4.1 API
RenderLayoutArgs Members
RenderLayoutArgs Class Constructors Methods Properties See Also Send Feedback

The RenderLayoutArgs type exposes the following members.

Constructors

 | Name | Description
Protected method | RenderLayoutArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the RenderLayoutArgs class.
Public method | RenderLayoutArgs(Page, Item) | Initializes a new instance of the RenderLayoutArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

RenderLayoutArgs Class
Sitecore.Pipelines.RenderLayout Namespace


RenderLayoutArgs Constructor

[image] [image]

Sitecore 6.4.1 API
RenderLayoutArgs Constructor
RenderLayoutArgs Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RenderLayoutArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the RenderLayoutArgs class.
Public method | RenderLayoutArgs(Page, Item) | Initializes a new instance of the RenderLayoutArgs class.

See Also

RenderLayoutArgs Class
RenderLayoutArgs Members
Sitecore.Pipelines.RenderLayout Namespace


RenderLayoutArgs Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
RenderLayoutArgs Constructor (SerializationInfo, StreamingContext)
RenderLayoutArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected RenderLayoutArgs(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
RenderLayoutArgs(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

RenderLayoutArgs Class
RenderLayoutArgs Overload
Sitecore.Pipelines.RenderLayout Namespace


RenderLayoutArgs Constructor (Page, Item)

[image]

Sitecore 6.4.1 API
RenderLayoutArgs Constructor (Page, Item)
RenderLayoutArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderLayoutArgs(
    Page page,
    Item currentItem
)
Visual Basic
Public Sub New ( _
    page As Page, _
    currentItem As Item _
)
Visual C++
public:
RenderLayoutArgs(
    Page^ page,
    Item^ currentItem
)

Parameters

page
Type: System.Web.UI..::..Page
The page.
currentItem
Type: Sitecore.Data.Items..::..Item
The current item.

See Also

RenderLayoutArgs Class
RenderLayoutArgs Overload
Sitecore.Pipelines.RenderLayout Namespace


RenderLayoutArgs Methods

[image] [image]

Sitecore 6.4.1 API
RenderLayoutArgs Methods
RenderLayoutArgs Class See Also Send Feedback

The RenderLayoutArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenderLayoutArgs Class
Sitecore.Pipelines.RenderLayout Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
RenderLayoutArgs..::..AddMessage Method
RenderLayoutArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

RenderLayoutArgs Class
RenderLayoutArgs Members
Sitecore.Pipelines.RenderLayout Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
RenderLayoutArgs..::..GetMessages Method
RenderLayoutArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

RenderLayoutArgs Class
RenderLayoutArgs Members
Sitecore.Pipelines.RenderLayout Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
RenderLayoutArgs..::..Suspend Method
RenderLayoutArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

RenderLayoutArgs Class
RenderLayoutArgs Members
Sitecore.Pipelines.RenderLayout Namespace


RenderLayoutArgs Properties

[image] [image]

Sitecore 6.4.1 API
RenderLayoutArgs Properties
RenderLayoutArgs Class See Also Send Feedback

The RenderLayoutArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

RenderLayoutArgs Class
Sitecore.Pipelines.RenderLayout Namespace


RenderLayoutProcessor Class

[image]

Sitecore 6.4.1 API
RenderLayoutProcessor Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class RenderLayoutProcessor
Visual Basic
Public MustInherit Class RenderLayoutProcessor
Visual C++
public ref class RenderLayoutProcessor abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.RenderLayout..::..RenderLayoutProcessor
Sitecore.Pipelines.RenderLayout..::..BrowserCaching
Sitecore.Pipelines.RenderLayout..::..BuildTree
Sitecore.Pipelines.RenderLayout..::..InsertRenderings
Sitecore.Pipelines.RenderLayout..::..InsertSystemControls
Sitecore.Pipelines.RenderLayout..::..InsertUnusedControls
Sitecore.Pipelines.RenderLayout..::..PageExtenders
Sitecore.Pipelines.RenderLayout..::..PageHandlers
Sitecore.Pipelines.RenderLayout..::..SecurityCheck

See Also

RenderLayoutProcessor Members
Sitecore.Pipelines.RenderLayout Namespace


RenderLayoutProcessor Members

[image] [image]

Sitecore 6.4.1 API
RenderLayoutProcessor Members
RenderLayoutProcessor Class Constructors Methods See Also Send Feedback

The RenderLayoutProcessor type exposes the following members.

Constructors

 | Name | Description
Protected method | RenderLayoutProcessor | Initializes a new instance of the RenderLayoutProcessor class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenderLayoutProcessor Class
Sitecore.Pipelines.RenderLayout Namespace


RenderLayoutProcessor Constructor

[image]

Sitecore 6.4.1 API
RenderLayoutProcessor Constructor
RenderLayoutProcessor Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected RenderLayoutProcessor()
Visual Basic
Protected Sub New
Visual C++
protected:
RenderLayoutProcessor()

See Also

RenderLayoutProcessor Class
Sitecore.Pipelines.RenderLayout Namespace


RenderLayoutProcessor Methods

[image] [image]

Sitecore 6.4.1 API
RenderLayoutProcessor Methods
RenderLayoutProcessor Class See Also Send Feedback

The RenderLayoutProcessor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenderLayoutProcessor Class
Sitecore.Pipelines.RenderLayout Namespace


Process Method

[image]

Sitecore 6.4.1 API
RenderLayoutProcessor..::..Process Method
RenderLayoutProcessor Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract void Process(
    RenderLayoutArgs args
)
Visual Basic
Public MustOverride Sub Process ( _
    args As RenderLayoutArgs _
)
Visual C++
public:
virtual void Process(
    RenderLayoutArgs^ args
) abstract

Parameters

args
Type: Sitecore.Pipelines.RenderLayout..::..RenderLayoutArgs
The args.

See Also

RenderLayoutProcessor Class
Sitecore.Pipelines.RenderLayout Namespace


SecurityCheck Class

[image]

Sitecore 6.4.1 API
SecurityCheck Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SecurityCheck : RenderLayoutProcessor
Visual Basic
Public Class SecurityCheck _
    Inherits RenderLayoutProcessor
Visual C++
public ref class SecurityCheck : public RenderLayoutProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.RenderLayout..::..RenderLayoutProcessor
Sitecore.Pipelines.RenderLayout..::..SecurityCheck

See Also

SecurityCheck Members
Sitecore.Pipelines.RenderLayout Namespace


SecurityCheck Members

[image] [image]

Sitecore 6.4.1 API
SecurityCheck Members
SecurityCheck Class Constructors Methods See Also Send Feedback

The SecurityCheck type exposes the following members.

Constructors

 | Name | Description
Public method | SecurityCheck | Initializes a new instance of the SecurityCheck class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLoginPage | Gets the login page.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasAccess | Check credentials.
Protected method | IsLoginPageRequest | Determines whether current request addresses the login page of the site.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Process query string. (Overrides RenderLayoutProcessor..::..Process(RenderLayoutArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SecurityCheck Class
Sitecore.Pipelines.RenderLayout Namespace


SecurityCheck Constructor

[image]

Sitecore 6.4.1 API
SecurityCheck Constructor
SecurityCheck Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SecurityCheck()
Visual Basic
Public Sub New
Visual C++
public:
SecurityCheck()

See Also

SecurityCheck Class
Sitecore.Pipelines.RenderLayout Namespace


SecurityCheck Methods

[image] [image]

Sitecore 6.4.1 API
SecurityCheck Methods
SecurityCheck Class See Also Send Feedback

The SecurityCheck type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLoginPage | Gets the login page.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasAccess | Check credentials.
Protected method | IsLoginPageRequest | Determines whether current request addresses the login page of the site.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Process query string. (Overrides RenderLayoutProcessor..::..Process(RenderLayoutArgs).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SecurityCheck Class
Sitecore.Pipelines.RenderLayout Namespace


GetLoginPage Method

[image]

Sitecore 6.4.1 API
SecurityCheck..::..GetLoginPage Method
SecurityCheck Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string GetLoginPage(
    SiteContext site
)
Visual Basic
Protected Overridable Function GetLoginPage ( _
    site As SiteContext _
) As String
Visual C++
protected:
virtual String^ GetLoginPage(
    SiteContext^ site
)

Parameters

site
Type: Sitecore.Sites..::..SiteContext
The site.

Return Value

[Missing <returns> documentation for "M:Sitecore.Pipelines.RenderLayout.SecurityCheck.GetLoginPage(Sitecore.Sites.SiteContext)"]

See Also

SecurityCheck Class
Sitecore.Pipelines.RenderLayout Namespace


HasAccess Method

[image]

Sitecore 6.4.1 API
SecurityCheck..::..HasAccess Method
SecurityCheck Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool HasAccess()
Visual Basic
Protected Overridable Function HasAccess As Boolean
Visual C++
protected:
virtual bool HasAccess()

Return Value

true if this instance has access; otherwise, false.

See Also

SecurityCheck Class
Sitecore.Pipelines.RenderLayout Namespace


IsLoginPageRequest Method

[image]

Sitecore 6.4.1 API
SecurityCheck..::..IsLoginPageRequest Method
SecurityCheck Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool IsLoginPageRequest()
Visual Basic
Protected Overridable Function IsLoginPageRequest As Boolean
Visual C++
protected:
virtual bool IsLoginPageRequest()

Return Value

true if current request addresses the login page of the site; otherwise, false.

See Also

SecurityCheck Class
Sitecore.Pipelines.RenderLayout Namespace


Process Method

[image]

Sitecore 6.4.1 API
SecurityCheck..::..Process Method
SecurityCheck Class See Also Send Feedback

Namespace: Sitecore.Pipelines.RenderLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    RenderLayoutArgs args
)
Visual Basic
Public Overrides Sub Process ( _
    args As RenderLayoutArgs _
)
Visual C++
public:
virtual void Process(
    RenderLayoutArgs^ args
) override

Parameters

args
Type: Sitecore.Pipelines.RenderLayout..::..RenderLayoutArgs
The arguments.

See Also

SecurityCheck Class
Sitecore.Pipelines.RenderLayout Namespace


Sitecore.Pipelines.Save Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.Save Namespace
Send Feedback

Classes

 | Class | Description
Public class | BeforeSaveEvent | Fires the before save event.
Public class | CheckItemLock | Checks whether items to be saved are locked and if they are it aborts the pipeline.
Public class | CheckLinks | Checks for broken links.
Public class | CheckLock | Checks locking.
Public class | CheckRevision | Parses the Xml into the data structure.
Public class | CheckTemplateFieldChange | Checks for broken links.
Public class | ConvertLayoutField | Processor for saving data.
Public class | ConvertToXHtml | Obsolete. Represents a ConvertToXHtml processor.
Public class | HasWritePermission | Checks write permissions.
Public class | Lock | Locks the item.
Public class | NewVersion | Creates a new version if needed.
Public class | ParseXml | Parses the Xml into the data structure.
Public class | PostAction | Dispatches the post action message.
Public class | RenderingHack | Ugly hack.
Public class | Save | Processor for saving data.
Public class | SaveArgs | Argument class for Save pipeline.
Public class | SaveArgs..::..SaveField | Holds a field for saving.
Public class | SaveArgs..::..SaveItem | Holds an item for saving.
Public class | TightenRelativeImageLinks | Processor for saving Html image links.
Public class | Unlock | Unlocks the item.
Public class | ValidateFields | Validates the fields.
Public class | Validators | Validates the fields.
Public class | WorkflowSaveCommand | Unlocks the item.


BeforeSaveEvent Members

[image] [image]

Sitecore 6.4.1 API
BeforeSaveEvent Members
BeforeSaveEvent Class Constructors Methods See Also Send Feedback

The BeforeSaveEvent type exposes the following members.

Constructors

 | Name | Description
Public method | BeforeSaveEvent | Initializes a new instance of the BeforeSaveEvent class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeforeSaveEvent Class
Sitecore.Pipelines.Save Namespace


BeforeSaveEvent Constructor

[image]

Sitecore 6.4.1 API
BeforeSaveEvent Constructor
BeforeSaveEvent Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public BeforeSaveEvent()
Visual Basic
Public Sub New
Visual C++
public:
BeforeSaveEvent()

See Also

BeforeSaveEvent Class
Sitecore.Pipelines.Save Namespace


BeforeSaveEvent Methods

[image] [image]

Sitecore 6.4.1 API
BeforeSaveEvent Methods
BeforeSaveEvent Class See Also Send Feedback

The BeforeSaveEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeforeSaveEvent Class
Sitecore.Pipelines.Save Namespace


Process Method

[image]

Sitecore 6.4.1 API
BeforeSaveEvent..::..Process Method
BeforeSaveEvent Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    SaveArgs args
)
Visual Basic
Public Sub Process ( _
    args As SaveArgs _
)
Visual C++
public:
void Process(
    SaveArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Save..::..SaveArgs
The arguments.

See Also

BeforeSaveEvent Class
Sitecore.Pipelines.Save Namespace


CheckItemLock Class

[image]

Sitecore 6.4.1 API
CheckItemLock Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CheckItemLock
Visual Basic
Public Class CheckItemLock
Visual C++
public ref class CheckItemLock

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Save..::..CheckItemLock

See Also

CheckItemLock Members
Sitecore.Pipelines.Save Namespace


CheckItemLock Members

[image] [image]

Sitecore 6.4.1 API
CheckItemLock Members
CheckItemLock Class Constructors Methods See Also Send Feedback

The CheckItemLock type exposes the following members.

Constructors

 | Name | Description
Public method | CheckItemLock | Initializes a new instance of the CheckItemLock class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckItemLock Class
Sitecore.Pipelines.Save Namespace


CheckItemLock Methods

[image] [image]

Sitecore 6.4.1 API
CheckItemLock Methods
CheckItemLock Class See Also Send Feedback

The CheckItemLock type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckItemLock Class
Sitecore.Pipelines.Save Namespace


Process Method

[image]

Sitecore 6.4.1 API
CheckItemLock..::..Process Method
CheckItemLock Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    SaveArgs args
)
Visual Basic
Public Sub Process ( _
    args As SaveArgs _
)
Visual C++
public:
void Process(
    SaveArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Save..::..SaveArgs
The arguments.

See Also

CheckItemLock Class
Sitecore.Pipelines.Save Namespace


CheckLinks Class

[image]

Sitecore 6.4.1 API
CheckLinks Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CheckLinks
Visual Basic
Public Class CheckLinks
Visual C++
public ref class CheckLinks

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Save..::..CheckLinks

See Also

CheckLinks Members
Sitecore.Pipelines.Save Namespace


CheckLinks Members

[image] [image]

Sitecore 6.4.1 API
CheckLinks Members
CheckLinks Class Constructors Methods See Also Send Feedback

The CheckLinks type exposes the following members.

Constructors

 | Name | Description
Public method | CheckLinks | Initializes a new instance of the CheckLinks class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckLinks Class
Sitecore.Pipelines.Save Namespace


CheckLinks Constructor

[image]

Sitecore 6.4.1 API
CheckLinks Constructor
CheckLinks Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CheckLinks()
Visual Basic
Public Sub New
Visual C++
public:
CheckLinks()

See Also

CheckLinks Class
Sitecore.Pipelines.Save Namespace


CheckLinks Methods

[image] [image]

Sitecore 6.4.1 API
CheckLinks Methods
CheckLinks Class See Also Send Feedback

The CheckLinks type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckLinks Class
Sitecore.Pipelines.Save Namespace


Process Method

[image]

Sitecore 6.4.1 API
CheckLinks..::..Process Method
CheckLinks Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    SaveArgs args
)
Visual Basic
Public Sub Process ( _
    args As SaveArgs _
)
Visual C++
public:
void Process(
    SaveArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Save..::..SaveArgs
The arguments.

See Also

CheckLinks Class
Sitecore.Pipelines.Save Namespace


CheckLock Class

[image]

Sitecore 6.4.1 API
CheckLock Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CheckLock
Visual Basic
Public Class CheckLock
Visual C++
public ref class CheckLock

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Save..::..CheckLock

See Also

CheckLock Members
Sitecore.Pipelines.Save Namespace


CheckLock Members

[image] [image]

Sitecore 6.4.1 API
CheckLock Members
CheckLock Class Constructors Methods See Also Send Feedback

The CheckLock type exposes the following members.

Constructors

 | Name | Description
Public method | CheckLock | Initializes a new instance of the CheckLock class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckLock Class
Sitecore.Pipelines.Save Namespace


CheckLock Constructor

[image]

Sitecore 6.4.1 API
CheckLock Constructor
CheckLock Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CheckLock()
Visual Basic
Public Sub New
Visual C++
public:
CheckLock()

See Also

CheckLock Class
Sitecore.Pipelines.Save Namespace


CheckLock Methods

[image] [image]

Sitecore 6.4.1 API
CheckLock Methods
CheckLock Class See Also Send Feedback

The CheckLock type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckLock Class
Sitecore.Pipelines.Save Namespace


Process Method

[image]

Sitecore 6.4.1 API
CheckLock..::..Process Method
CheckLock Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    SaveArgs args
)
Visual Basic
Public Sub Process ( _
    args As SaveArgs _
)
Visual C++
public:
void Process(
    SaveArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Save..::..SaveArgs
The arguments.

See Also

CheckLock Class
Sitecore.Pipelines.Save Namespace


CheckRevision Class

[image]

Sitecore 6.4.1 API
CheckRevision Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CheckRevision
Visual Basic
Public Class CheckRevision
Visual C++
public ref class CheckRevision

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Save..::..CheckRevision

See Also

CheckRevision Members
Sitecore.Pipelines.Save Namespace


CheckRevision Members

[image] [image]

Sitecore 6.4.1 API
CheckRevision Members
CheckRevision Class Constructors Methods See Also Send Feedback

The CheckRevision type exposes the following members.

Constructors

 | Name | Description
Public method | CheckRevision | Initializes a new instance of the CheckRevision class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckRevision Class
Sitecore.Pipelines.Save Namespace


CheckRevision Constructor

[image]

Sitecore 6.4.1 API
CheckRevision Constructor
CheckRevision Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CheckRevision()
Visual Basic
Public Sub New
Visual C++
public:
CheckRevision()

See Also

CheckRevision Class
Sitecore.Pipelines.Save Namespace


CheckRevision Methods

[image] [image]

Sitecore 6.4.1 API
CheckRevision Methods
CheckRevision Class See Also Send Feedback

The CheckRevision type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckRevision Class
Sitecore.Pipelines.Save Namespace


Process Method

[image]

Sitecore 6.4.1 API
CheckRevision..::..Process Method
CheckRevision Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    SaveArgs args
)
Visual Basic
Public Sub Process ( _
    args As SaveArgs _
)
Visual C++
public:
void Process(
    SaveArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Save..::..SaveArgs
The arguments.

See Also

CheckRevision Class
Sitecore.Pipelines.Save Namespace


CheckTemplateFieldChange Class

[image]

Sitecore 6.4.1 API
CheckTemplateFieldChange Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CheckTemplateFieldChange
Visual Basic
Public Class CheckTemplateFieldChange
Visual C++
public ref class CheckTemplateFieldChange

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Save..::..CheckTemplateFieldChange

See Also

CheckTemplateFieldChange Members
Sitecore.Pipelines.Save Namespace


CheckTemplateFieldChange Constructor

[image]

Sitecore 6.4.1 API
CheckTemplateFieldChange Constructor
CheckTemplateFieldChange Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CheckTemplateFieldChange()
Visual Basic
Public Sub New
Visual C++
public:
CheckTemplateFieldChange()

See Also

CheckTemplateFieldChange Class
Sitecore.Pipelines.Save Namespace


CheckTemplateFieldChange Methods

[image] [image]

Sitecore 6.4.1 API
CheckTemplateFieldChange Methods
CheckTemplateFieldChange Class See Also Send Feedback

The CheckTemplateFieldChange type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckTemplateFieldChange Class
Sitecore.Pipelines.Save Namespace


Process Method

[image]

Sitecore 6.4.1 API
CheckTemplateFieldChange..::..Process Method
CheckTemplateFieldChange Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    SaveArgs args
)
Visual Basic
Public Sub Process ( _
    args As SaveArgs _
)
Visual C++
public:
void Process(
    SaveArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Save..::..SaveArgs
The arguments.

See Also

CheckTemplateFieldChange Class
Sitecore.Pipelines.Save Namespace


ConvertLayoutField Class

[image]

Sitecore 6.4.1 API
ConvertLayoutField Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ConvertLayoutField
Visual Basic
Public Class ConvertLayoutField
Visual C++
public ref class ConvertLayoutField

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Save..::..ConvertLayoutField

See Also

ConvertLayoutField Members
Sitecore.Pipelines.Save Namespace


ConvertLayoutField Members

[image] [image]

Sitecore 6.4.1 API
ConvertLayoutField Members
ConvertLayoutField Class Constructors Methods See Also Send Feedback

The ConvertLayoutField type exposes the following members.

Constructors

 | Name | Description
Public method | ConvertLayoutField | Initializes a new instance of the ConvertLayoutField class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConvertLayoutField Class
Sitecore.Pipelines.Save Namespace


ConvertLayoutField Constructor

[image]

Sitecore 6.4.1 API
ConvertLayoutField Constructor
ConvertLayoutField Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ConvertLayoutField()
Visual Basic
Public Sub New
Visual C++
public:
ConvertLayoutField()

See Also

ConvertLayoutField Class
Sitecore.Pipelines.Save Namespace


ConvertLayoutField Methods

[image] [image]

Sitecore 6.4.1 API
ConvertLayoutField Methods
ConvertLayoutField Class See Also Send Feedback

The ConvertLayoutField type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConvertLayoutField Class
Sitecore.Pipelines.Save Namespace


ConvertToXHtml Class

[image]

Sitecore 6.4.1 API
ConvertToXHtml Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("This processor is no longer used by Sitecore.")]
public class ConvertToXHtml
Visual Basic
<ObsoleteAttribute("This processor is no longer used by Sitecore.")> _
Public Class ConvertToXHtml
Visual C++
[ObsoleteAttribute(L"This processor is no longer used by Sitecore.")]
public ref class ConvertToXHtml

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Save..::..ConvertToXHtml

See Also

ConvertToXHtml Members
Sitecore.Pipelines.Save Namespace


ConvertToXHtml Members

[image] [image]

Sitecore 6.4.1 API
ConvertToXHtml Members
ConvertToXHtml Class Constructors Methods See Also Send Feedback

The ConvertToXHtml type exposes the following members.

Constructors

 | Name | Description
Public method | ConvertToXHtml | Initializes a new instance of the ConvertToXHtml class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConvertToXHtml Class
Sitecore.Pipelines.Save Namespace


ConvertToXHtml Constructor

[image]

Sitecore 6.4.1 API
ConvertToXHtml Constructor
ConvertToXHtml Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ConvertToXHtml()
Visual Basic
Public Sub New
Visual C++
public:
ConvertToXHtml()

See Also

ConvertToXHtml Class
Sitecore.Pipelines.Save Namespace


ConvertToXHtml Methods

[image] [image]

Sitecore 6.4.1 API
ConvertToXHtml Methods
ConvertToXHtml Class See Also Send Feedback

The ConvertToXHtml type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConvertToXHtml Class
Sitecore.Pipelines.Save Namespace


Process Method

[image]

Sitecore 6.4.1 API
ConvertToXHtml..::..Process Method
ConvertToXHtml Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    SaveArgs args
)
Visual Basic
Public Sub Process ( _
    args As SaveArgs _
)
Visual C++
public:
void Process(
    SaveArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Save..::..SaveArgs
The arguments.

See Also

ConvertToXHtml Class
Sitecore.Pipelines.Save Namespace


HasWritePermission Class

[image]

Sitecore 6.4.1 API
HasWritePermission Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class HasWritePermission
Visual Basic
Public Class HasWritePermission
Visual C++
public ref class HasWritePermission

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Save..::..HasWritePermission

See Also

HasWritePermission Members
Sitecore.Pipelines.Save Namespace


HasWritePermission Members

[image] [image]

Sitecore 6.4.1 API
HasWritePermission Members
HasWritePermission Class Constructors Methods See Also Send Feedback

The HasWritePermission type exposes the following members.

Constructors

 | Name | Description
Public method | HasWritePermission | Initializes a new instance of the HasWritePermission class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HasWritePermission Class
Sitecore.Pipelines.Save Namespace


HasWritePermission Constructor

[image]

Sitecore 6.4.1 API
HasWritePermission Constructor
HasWritePermission Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HasWritePermission()
Visual Basic
Public Sub New
Visual C++
public:
HasWritePermission()

See Also

HasWritePermission Class
Sitecore.Pipelines.Save Namespace


HasWritePermission Methods

[image] [image]

Sitecore 6.4.1 API
HasWritePermission Methods
HasWritePermission Class See Also Send Feedback

The HasWritePermission type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HasWritePermission Class
Sitecore.Pipelines.Save Namespace


Lock Class

[image]

Sitecore 6.4.1 API
Lock Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Lock
Visual Basic
Public Class Lock
Visual C++
public ref class Lock

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Save..::..Lock

See Also

Lock Members
Sitecore.Pipelines.Save Namespace


Lock Members

[image] [image]

Sitecore 6.4.1 API
Lock Members
Lock Class Constructors Methods See Also Send Feedback

The Lock type exposes the following members.

Constructors

 | Name | Description
Public method | Lock | Initializes a new instance of the Lock class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetField | Gets the field.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Lock Class
Sitecore.Pipelines.Save Namespace


Lock Constructor

[image]

Sitecore 6.4.1 API
Lock Constructor
Lock Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Lock()
Visual Basic
Public Sub New
Visual C++
public:
Lock()

See Also

Lock Class
Sitecore.Pipelines.Save Namespace


Lock Methods

[image] [image]

Sitecore 6.4.1 API
Lock Methods
Lock Class See Also Send Feedback

The Lock type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetField | Gets the field.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Lock Class
Sitecore.Pipelines.Save Namespace


GetField Method

[image]

Sitecore 6.4.1 API
Lock..::..GetField Method
Lock Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual SaveArgs..::..SaveField GetField(
    SaveArgs..::..SaveItem item,
    ID fieldID
)
Visual Basic
Protected Overridable Function GetField ( _
    item As SaveArgs..::..SaveItem, _
    fieldID As ID _
) As SaveArgs..::..SaveField
Visual C++
protected:
virtual SaveArgs..::..SaveField^ GetField(
    SaveArgs..::..SaveItem^ item,
    ID^ fieldID
)

Parameters

item
Type: Sitecore.Pipelines.Save..::..SaveArgs..::..SaveItem
The item.
fieldID
Type: Sitecore.Data..::..ID
The field ID.

Return Value

[Missing <returns> documentation for "M:Sitecore.Pipelines.Save.Lock.GetField(Sitecore.Pipelines.Save.SaveArgs.SaveItem,Sitecore.Data.ID)"]

See Also

Lock Class
Sitecore.Pipelines.Save Namespace


Process Method

[image]

Sitecore 6.4.1 API
Lock..::..Process Method
Lock Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    SaveArgs args
)
Visual Basic
Public Sub Process ( _
    args As SaveArgs _
)
Visual C++
public:
void Process(
    SaveArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Save..::..SaveArgs
The arguments.

See Also

Lock Class
Sitecore.Pipelines.Save Namespace


NewVersion Class

[image]

Sitecore 6.4.1 API
NewVersion Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class NewVersion
Visual Basic
Public Class NewVersion
Visual C++
public ref class NewVersion

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Save..::..NewVersion

See Also

NewVersion Members
Sitecore.Pipelines.Save Namespace


NewVersion Members

[image] [image]

Sitecore 6.4.1 API
NewVersion Members
NewVersion Class Constructors Methods See Also Send Feedback

The NewVersion type exposes the following members.

Constructors

 | Name | Description
Public method | NewVersion | Initializes a new instance of the NewVersion class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NewVersion Class
Sitecore.Pipelines.Save Namespace


NewVersion Constructor

[image]

Sitecore 6.4.1 API
NewVersion Constructor
NewVersion Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public NewVersion()
Visual Basic
Public Sub New
Visual C++
public:
NewVersion()

See Also

NewVersion Class
Sitecore.Pipelines.Save Namespace


NewVersion Methods

[image] [image]

Sitecore 6.4.1 API
NewVersion Methods
NewVersion Class See Also Send Feedback

The NewVersion type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NewVersion Class
Sitecore.Pipelines.Save Namespace


Process Method

[image]

Sitecore 6.4.1 API
NewVersion..::..Process Method
NewVersion Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    SaveArgs args
)
Visual Basic
Public Sub Process ( _
    args As SaveArgs _
)
Visual C++
public:
void Process(
    SaveArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Save..::..SaveArgs
The arguments.

See Also

NewVersion Class
Sitecore.Pipelines.Save Namespace


ParseXml Class

[image]

Sitecore 6.4.1 API
ParseXml Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ParseXml
Visual Basic
Public Class ParseXml
Visual C++
public ref class ParseXml

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Save..::..ParseXml

See Also

ParseXml Members
Sitecore.Pipelines.Save Namespace


ParseXml Members

[image] [image]

Sitecore 6.4.1 API
ParseXml Members
ParseXml Class Constructors Methods See Also Send Feedback

The ParseXml type exposes the following members.

Constructors

 | Name | Description
Public method | ParseXml | Initializes a new instance of the ParseXml class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParseXml Class
Sitecore.Pipelines.Save Namespace


ParseXml Constructor

[image]

Sitecore 6.4.1 API
ParseXml Constructor
ParseXml Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ParseXml()
Visual Basic
Public Sub New
Visual C++
public:
ParseXml()

See Also

ParseXml Class
Sitecore.Pipelines.Save Namespace


ParseXml Methods

[image] [image]

Sitecore 6.4.1 API
ParseXml Methods
ParseXml Class See Also Send Feedback

The ParseXml type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParseXml Class
Sitecore.Pipelines.Save Namespace


Process Method

[image]

Sitecore 6.4.1 API
ParseXml..::..Process Method
ParseXml Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    SaveArgs args
)
Visual Basic
Public Sub Process ( _
    args As SaveArgs _
)
Visual C++
public:
void Process(
    SaveArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Save..::..SaveArgs
The arguments.

See Also

ParseXml Class
Sitecore.Pipelines.Save Namespace


PostAction Class

[image]

Sitecore 6.4.1 API
PostAction Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PostAction
Visual Basic
Public Class PostAction
Visual C++
public ref class PostAction

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Save..::..PostAction

See Also

PostAction Members
Sitecore.Pipelines.Save Namespace


PostAction Members

[image] [image]

Sitecore 6.4.1 API
PostAction Members
PostAction Class Constructors Methods See Also Send Feedback

The PostAction type exposes the following members.

Constructors

 | Name | Description
Public method | PostAction | Initializes a new instance of the PostAction class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PostAction Class
Sitecore.Pipelines.Save Namespace


PostAction Constructor

[image]

Sitecore 6.4.1 API
PostAction Constructor
PostAction Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PostAction()
Visual Basic
Public Sub New
Visual C++
public:
PostAction()

See Also

PostAction Class
Sitecore.Pipelines.Save Namespace


PostAction Methods

[image] [image]

Sitecore 6.4.1 API
PostAction Methods
PostAction Class See Also Send Feedback

The PostAction type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PostAction Class
Sitecore.Pipelines.Save Namespace


Process Method

[image]

Sitecore 6.4.1 API
PostAction..::..Process Method
PostAction Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    SaveArgs args
)
Visual Basic
Public Sub Process ( _
    args As SaveArgs _
)
Visual C++
public:
void Process(
    SaveArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Save..::..SaveArgs
The arguments.

See Also

PostAction Class
Sitecore.Pipelines.Save Namespace


RenderingHack Class

[image]

Sitecore 6.4.1 API
RenderingHack Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RenderingHack
Visual Basic
Public Class RenderingHack
Visual C++
public ref class RenderingHack

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Save..::..RenderingHack

See Also

RenderingHack Members
Sitecore.Pipelines.Save Namespace


RenderingHack Members

[image] [image]

Sitecore 6.4.1 API
RenderingHack Members
RenderingHack Class Constructors Methods See Also Send Feedback

The RenderingHack type exposes the following members.

Constructors

 | Name | Description
Public method | RenderingHack | Initializes a new instance of the RenderingHack class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenderingHack Class
Sitecore.Pipelines.Save Namespace


RenderingHack Constructor

[image]

Sitecore 6.4.1 API
RenderingHack Constructor
RenderingHack Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderingHack()
Visual Basic
Public Sub New
Visual C++
public:
RenderingHack()

See Also

RenderingHack Class
Sitecore.Pipelines.Save Namespace


RenderingHack Methods

[image] [image]

Sitecore 6.4.1 API
RenderingHack Methods
RenderingHack Class See Also Send Feedback

The RenderingHack type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenderingHack Class
Sitecore.Pipelines.Save Namespace


Process Method

[image]

Sitecore 6.4.1 API
RenderingHack..::..Process Method
RenderingHack Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    SaveArgs args
)
Visual Basic
Public Sub Process ( _
    args As SaveArgs _
)
Visual C++
public:
void Process(
    SaveArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Save..::..SaveArgs
The arguments.

See Also

RenderingHack Class
Sitecore.Pipelines.Save Namespace


Save Class

[image]

Sitecore 6.4.1 API
Save Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Save
Visual Basic
Public Class Save
Visual C++
public ref class Save

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Save..::..Save

See Also

Save Members
Sitecore.Pipelines.Save Namespace


Save Members

[image] [image]

Sitecore 6.4.1 API
Save Members
Save Class Constructors Methods See Also Send Feedback

The Save type exposes the following members.

Constructors

 | Name | Description
Public method | Save | Initializes a new instance of the Save class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Save Class
Sitecore.Pipelines.Save Namespace


Save Constructor

[image]

Sitecore 6.4.1 API
Save Constructor
Save Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Save()
Visual Basic
Public Sub New
Visual C++
public:
Save()

See Also

Save Class
Sitecore.Pipelines.Save Namespace


Save Methods

[image] [image]

Sitecore 6.4.1 API
Save Methods
Save Class See Also Send Feedback

The Save type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Save Class
Sitecore.Pipelines.Save Namespace


Process Method

[image]

Sitecore 6.4.1 API
Save..::..Process Method
Save Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    SaveArgs args
)
Visual Basic
Public Sub Process ( _
    args As SaveArgs _
)
Visual C++
public:
void Process(
    SaveArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Save..::..SaveArgs
The arguments.

See Also

Save Class
Sitecore.Pipelines.Save Namespace


SaveArgs Class

[image]

Sitecore 6.4.1 API
SaveArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class SaveArgs : ClientPipelineArgs
Visual Basic
<SerializableAttribute> _
Public Class SaveArgs _
    Inherits ClientPipelineArgs
Visual C++
[SerializableAttribute]
public ref class SaveArgs : public ClientPipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Web.UI.Sheer..::..ClientPipelineArgs
Sitecore.Pipelines.Save..::..SaveArgs

See Also

SaveArgs Members
Sitecore.Pipelines.Save Namespace


SaveArgs Members

[image] [image]

Sitecore 6.4.1 API
SaveArgs Members
SaveArgs Class Constructors Methods Properties See Also Send Feedback

The SaveArgs type exposes the following members.

Constructors

 | Name | Description
Public method | SaveArgs(XmlDocument) | Initializes a new instance of the SaveArgs class.
Protected method | SaveArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the SaveArgs class from a serialization context.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ClientPipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | A processor is done. (Overrides ClientPipelineArgs..::..ProcessorDone()()()().)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WaitForPostBack()()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Public method | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CarryResultToNextProcessor | Gets or sets a value indicating whether the ClientPipelineArgs carries the result to next processor. (Inherited from ClientPipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Error | Gets or sets the error.
Public property | HasResult | Gets a value indicating whether this instance has a result. (Inherited from ClientPipelineArgs.)
Public property | HasSheerUI | Gets or sets a value indicating whether this instance has sheer UI.
Public property | IsPostBack | Gets or sets a value that indicates if the processor was invoked as part of a user response. (Inherited from ClientPipelineArgs.)
Public property | Items | Gets or sets the items.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Parameters | Gets or sets the parameters. (Inherited from ClientPipelineArgs.)
Public property | PolicyBasedLocking | Gets or sets a value indicating whether [policy based check in].
Public property | PostAction | Gets or sets the post action.
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Properties | Gets the properties. (Inherited from ClientPipelineArgs.)
Public property | Result | Gets or sets the value that was posted as part of a Sheer response. (Inherited from ClientPipelineArgs.)
Public property | SaveAnimation | Gets or sets a value indicating whether [save animation].
Public property | SavedItems | Gets the saved items.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
Public property | Xml | Gets or sets the XML.

See Also

SaveArgs Class
Sitecore.Pipelines.Save Namespace


SaveArgs Constructor

[image] [image]

Sitecore 6.4.1 API
SaveArgs Constructor
SaveArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SaveArgs(XmlDocument) | Initializes a new instance of the SaveArgs class.
Protected method | SaveArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the SaveArgs class from a serialization context.

See Also

SaveArgs Class
SaveArgs Members
Sitecore.Pipelines.Save Namespace


SaveArgs Constructor (XmlDocument)

[image]

Sitecore 6.4.1 API
SaveArgs Constructor (XmlDocument)
SaveArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SaveArgs(
    XmlDocument xml
)
Visual Basic
Public Sub New ( _
    xml As XmlDocument _
)
Visual C++
public:
SaveArgs(
    XmlDocument^ xml
)

Parameters

xml
Type: System.Xml..::..XmlDocument
The XML.

See Also

SaveArgs Class
SaveArgs Overload
Sitecore.Pipelines.Save Namespace


SaveArgs Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
SaveArgs Constructor (SerializationInfo, StreamingContext)
SaveArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected SaveArgs(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
SaveArgs(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The serialized data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

SaveArgs Class
SaveArgs Overload
Sitecore.Pipelines.Save Namespace


SaveArgs Methods

[image] [image]

Sitecore 6.4.1 API
SaveArgs Methods
SaveArgs Class See Also Send Feedback

The SaveArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ClientPipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | A processor is done. (Overrides ClientPipelineArgs..::..ProcessorDone()()()().)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WaitForPostBack()()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Public method | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)

See Also

SaveArgs Class
Sitecore.Pipelines.Save Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
SaveArgs..::..AddMessage Method
SaveArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

SaveArgs Class
SaveArgs Members
Sitecore.Pipelines.Save Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
SaveArgs..::..GetMessages Method
SaveArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

SaveArgs Class
SaveArgs Members
Sitecore.Pipelines.Save Namespace


GetObjectData Method

[image]

Sitecore 6.4.1 API
SaveArgs..::..GetObjectData Method
SaveArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System.Security..::..SecurityException | The caller does not have the required permission.

See Also

SaveArgs Class
Sitecore.Pipelines.Save Namespace


ProcessorDone Method

[image]

Sitecore 6.4.1 API
SaveArgs..::..ProcessorDone Method
SaveArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected internal override void ProcessorDone()
Visual Basic
Protected Friend Overrides Sub ProcessorDone
Visual C++
protected public:
virtual void ProcessorDone() override

See Also

SaveArgs Class
Sitecore.Pipelines.Save Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
SaveArgs..::..Suspend Method
SaveArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

SaveArgs Class
SaveArgs Members
Sitecore.Pipelines.Save Namespace


WaitForPostBack Method

[image] [image]

Sitecore 6.4.1 API
SaveArgs..::..WaitForPostBack Method
SaveArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaitForPostBack()()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Public method | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)

See Also

SaveArgs Class
SaveArgs Members
Sitecore.Pipelines.Save Namespace


Error Property

[image]

Sitecore 6.4.1 API
SaveArgs..::..Error Property
SaveArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Error { get; set; }
Visual Basic
Public Property Error As String
    Get
    Set
Visual C++
public:
property String^ Error {
    String^ get ();
    void set (String^ value);
}

Field Value

The error.

See Also

SaveArgs Class
Sitecore.Pipelines.Save Namespace


Items Property

[image]

Sitecore 6.4.1 API
SaveArgs..::..Items Property
SaveArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SaveArgs..::..SaveItem[] Items { get; set; }
Visual Basic
Public Property Items As SaveArgs..::..SaveItem()
    Get
    Set
Visual C++
public:
property array<SaveArgs..::..SaveItem^>^ Items {
    array<SaveArgs..::..SaveItem^>^ get ();
    void set (array<SaveArgs..::..SaveItem^>^ value);
}

Field Value

The items.

See Also

SaveArgs Class
Sitecore.Pipelines.Save Namespace


PolicyBasedLocking Property

[image]

Sitecore 6.4.1 API
SaveArgs..::..PolicyBasedLocking Property
SaveArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool PolicyBasedLocking { get; set; }
Visual Basic
Public Property PolicyBasedLocking As Boolean
    Get
    Set
Visual C++
public:
property bool PolicyBasedLocking {
    bool get ();
    void set (bool value);
}

Field Value

true if [policy based check in]; otherwise, false.

See Also

SaveArgs Class
Sitecore.Pipelines.Save Namespace


PostAction Property

[image]

Sitecore 6.4.1 API
SaveArgs..::..PostAction Property
SaveArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string PostAction { get; set; }
Visual Basic
Public Property PostAction As String
    Get
    Set
Visual C++
public:
property String^ PostAction {
    String^ get ();
    void set (String^ value);
}

Field Value

The post action.

See Also

SaveArgs Class
Sitecore.Pipelines.Save Namespace


SaveAnimation Property

[image]

Sitecore 6.4.1 API
SaveArgs..::..SaveAnimation Property
SaveArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool SaveAnimation { get; set; }
Visual Basic
Public Property SaveAnimation As Boolean
    Get
    Set
Visual C++
public:
property bool SaveAnimation {
    bool get ();
    void set (bool value);
}

Field Value

true if [save animation]; otherwise, false.

See Also

SaveArgs Class
Sitecore.Pipelines.Save Namespace


SavedItems Property

[image]

Sitecore 6.4.1 API
SaveArgs..::..SavedItems Property
SaveArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ArrayList SavedItems { get; }
Visual Basic
Public ReadOnly Property SavedItems As ArrayList
    Get
Visual C++
public:
property ArrayList^ SavedItems {
    ArrayList^ get ();
}

Field Value

The saved items.

See Also

SaveArgs Class
Sitecore.Pipelines.Save Namespace


Xml Property

[image]

Sitecore 6.4.1 API
SaveArgs..::..Xml Property
SaveArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public XmlDocument Xml { get; set; }
Visual Basic
Public Property Xml As XmlDocument
    Get
    Set
Visual C++
public:
property XmlDocument^ Xml {
    XmlDocument^ get ();
    void set (XmlDocument^ value);
}

Field Value

The XML.

See Also

SaveArgs Class
Sitecore.Pipelines.Save Namespace


SaveArgs.SaveField Class

[image]

Sitecore 6.4.1 API
SaveArgs..::..SaveField Class
SaveArgs Class Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class SaveField
Visual Basic
<SerializableAttribute> _
Public Class SaveField
Visual C++
[SerializableAttribute]
public ref class SaveField

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Save..::..SaveArgs..::..SaveField

See Also

SaveArgs..::..SaveField Members
Sitecore.Pipelines.Save Namespace


SaveArgs.SaveField Members

[image] [image]

Sitecore 6.4.1 API
SaveArgs..::..SaveField Members
SaveArgs..::..SaveField Class Constructors Methods Properties See Also Send Feedback

Argument class for Save pipeline.
Argument class for Save pipeline.
Argument class for Save pipeline.

The SaveArgs..::..SaveField type exposes the following members.

Constructors

 | Name | Description
Public method | SaveArgs..::..SaveField | Initializes a new instance of the SaveArgs..::..SaveField class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ID | The ID.
Public property | OriginalValue | The value.
Public property | Value | The value.

See Also

SaveArgs..::..SaveField Class
Sitecore.Pipelines.Save Namespace


SaveArgs.SaveField Constructor

[image]

Sitecore 6.4.1 API
SaveArgs..::..SaveField Constructor
SaveArgs..::..SaveField Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SaveField()
Visual Basic
Public Sub New
Visual C++
public:
SaveField()

See Also

SaveArgs..::..SaveField Class
Sitecore.Pipelines.Save Namespace


SaveArgs.SaveField Methods

[image] [image]

Sitecore 6.4.1 API
SaveArgs..::..SaveField Methods
SaveArgs..::..SaveField Class See Also Send Feedback

The SaveArgs..::..SaveField type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SaveArgs..::..SaveField Class
Sitecore.Pipelines.Save Namespace


SaveArgs.SaveField Properties

[image] [image]

Sitecore 6.4.1 API
SaveArgs..::..SaveField Properties
SaveArgs..::..SaveField Class See Also Send Feedback

The SaveArgs..::..SaveField type exposes the following members.

Properties

 | Name | Description
Public property | ID | The ID.
Public property | OriginalValue | The value.
Public property | Value | The value.

See Also

SaveArgs..::..SaveField Class
Sitecore.Pipelines.Save Namespace


ID Property

[image]

Sitecore 6.4.1 API
SaveArgs..::..SaveField..::..ID Property
SaveArgs..::..SaveField Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ID { get; set; }
Visual Basic
Public Property ID As ID
    Get
    Set
Visual C++
public:
property ID^ ID {
    ID^ get ();
    void set (ID^ value);
}

Field Value

The id.

See Also

SaveArgs..::..SaveField Class
Sitecore.Pipelines.Save Namespace


OriginalValue Property

[image]

Sitecore 6.4.1 API
SaveArgs..::..SaveField..::..OriginalValue Property
SaveArgs..::..SaveField Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string OriginalValue { get; set; }
Visual Basic
Public Property OriginalValue As String
    Get
    Set
Visual C++
public:
property String^ OriginalValue {
    String^ get ();
    void set (String^ value);
}

Field Value

The original value.

See Also

SaveArgs..::..SaveField Class
Sitecore.Pipelines.Save Namespace


SaveArgs.SaveItem Class

[image]

Sitecore 6.4.1 API
SaveArgs..::..SaveItem Class
SaveArgs Class Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class SaveItem
Visual Basic
<SerializableAttribute> _
Public Class SaveItem
Visual C++
[SerializableAttribute]
public ref class SaveItem

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Save..::..SaveArgs..::..SaveItem

See Also

SaveArgs..::..SaveItem Members
Sitecore.Pipelines.Save Namespace


SaveArgs.SaveItem Members

[image] [image]

Sitecore 6.4.1 API
SaveArgs..::..SaveItem Members
SaveArgs..::..SaveItem Class Constructors Methods Properties See Also Send Feedback

Argument class for Save pipeline.
Argument class for Save pipeline.
Argument class for Save pipeline.

The SaveArgs..::..SaveItem type exposes the following members.

Constructors

 | Name | Description
Public method | SaveArgs..::..SaveItem | Initializes a new instance of the SaveArgs..::..SaveItem class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Fields | The fields.
Public property | ID | The ID.
Public property | Language | The language.
Public property | Revision | Gets or sets the revision.
Public property | Version | The version.

See Also

SaveArgs..::..SaveItem Class
Sitecore.Pipelines.Save Namespace


SaveArgs.SaveItem Constructor

[image]

Sitecore 6.4.1 API
SaveArgs..::..SaveItem Constructor
SaveArgs..::..SaveItem Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SaveItem()
Visual Basic
Public Sub New
Visual C++
public:
SaveItem()

See Also

SaveArgs..::..SaveItem Class
Sitecore.Pipelines.Save Namespace


SaveArgs.SaveItem Methods

[image] [image]

Sitecore 6.4.1 API
SaveArgs..::..SaveItem Methods
SaveArgs..::..SaveItem Class See Also Send Feedback

The SaveArgs..::..SaveItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SaveArgs..::..SaveItem Class
Sitecore.Pipelines.Save Namespace


SaveArgs.SaveItem Properties

[image] [image]

Sitecore 6.4.1 API
SaveArgs..::..SaveItem Properties
SaveArgs..::..SaveItem Class See Also Send Feedback

The SaveArgs..::..SaveItem type exposes the following members.

Properties

 | Name | Description
Public property | Fields | The fields.
Public property | ID | The ID.
Public property | Language | The language.
Public property | Revision | Gets or sets the revision.
Public property | Version | The version.

See Also

SaveArgs..::..SaveItem Class
Sitecore.Pipelines.Save Namespace


Fields Property

[image]

Sitecore 6.4.1 API
SaveArgs..::..SaveItem..::..Fields Property
SaveArgs..::..SaveItem Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SaveArgs..::..SaveField[] Fields { get; set; }
Visual Basic
Public Property Fields As SaveArgs..::..SaveField()
    Get
    Set
Visual C++
public:
property array<SaveArgs..::..SaveField^>^ Fields {
    array<SaveArgs..::..SaveField^>^ get ();
    void set (array<SaveArgs..::..SaveField^>^ value);
}

Field Value

The fields.

See Also

SaveArgs..::..SaveItem Class
Sitecore.Pipelines.Save Namespace


ID Property

[image]

Sitecore 6.4.1 API
SaveArgs..::..SaveItem..::..ID Property
SaveArgs..::..SaveItem Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ID { get; set; }
Visual Basic
Public Property ID As ID
    Get
    Set
Visual C++
public:
property ID^ ID {
    ID^ get ();
    void set (ID^ value);
}

Field Value

The id.

See Also

SaveArgs..::..SaveItem Class
Sitecore.Pipelines.Save Namespace


Language Property

[image]

Sitecore 6.4.1 API
SaveArgs..::..SaveItem..::..Language Property
SaveArgs..::..SaveItem Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Language Language { get; set; }
Visual Basic
Public Property Language As Language
    Get
    Set
Visual C++
public:
property Language^ Language {
    Language^ get ();
    void set (Language^ value);
}

Field Value

The language.

See Also

SaveArgs..::..SaveItem Class
Sitecore.Pipelines.Save Namespace


Revision Property

[image]

Sitecore 6.4.1 API
SaveArgs..::..SaveItem..::..Revision Property
SaveArgs..::..SaveItem Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Revision { get; set; }
Visual Basic
Public Property Revision As String
    Get
    Set
Visual C++
public:
property String^ Revision {
    String^ get ();
    void set (String^ value);
}

Field Value

The revision.

See Also

SaveArgs..::..SaveItem Class
Sitecore.Pipelines.Save Namespace


Version Property

[image]

Sitecore 6.4.1 API
SaveArgs..::..SaveItem..::..Version Property
SaveArgs..::..SaveItem Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Version Version { get; set; }
Visual Basic
Public Property Version As Version
    Get
    Set
Visual C++
public:
property Version^ Version {
    Version^ get ();
    void set (Version^ value);
}

Field Value

The version.

See Also

SaveArgs..::..SaveItem Class
Sitecore.Pipelines.Save Namespace


TightenRelativeImageLinks Class

[image]

Sitecore 6.4.1 API
TightenRelativeImageLinks Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class TightenRelativeImageLinks
Visual Basic
Public Class TightenRelativeImageLinks
Visual C++
public ref class TightenRelativeImageLinks

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Save..::..TightenRelativeImageLinks

See Also

TightenRelativeImageLinks Members
Sitecore.Pipelines.Save Namespace


TightenRelativeImageLinks Members

[image] [image]

Sitecore 6.4.1 API
TightenRelativeImageLinks Members
TightenRelativeImageLinks Class Constructors Methods See Also Send Feedback

The TightenRelativeImageLinks type exposes the following members.

Constructors

 | Name | Description
Public method | TightenRelativeImageLinks | Initializes a new instance of the TightenRelativeImageLinks class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TightenRelativeImageLinks Class
Sitecore.Pipelines.Save Namespace


TightenRelativeImageLinks Methods

[image] [image]

Sitecore 6.4.1 API
TightenRelativeImageLinks Methods
TightenRelativeImageLinks Class See Also Send Feedback

The TightenRelativeImageLinks type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TightenRelativeImageLinks Class
Sitecore.Pipelines.Save Namespace


Unlock Class

[image]

Sitecore 6.4.1 API
Unlock Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Unlock
Visual Basic
Public Class Unlock
Visual C++
public ref class Unlock

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Save..::..Unlock

See Also

Unlock Members
Sitecore.Pipelines.Save Namespace


Unlock Members

[image] [image]

Sitecore 6.4.1 API
Unlock Members
Unlock Class Constructors Methods See Also Send Feedback

The Unlock type exposes the following members.

Constructors

 | Name | Description
Public method | Unlock | Initializes a new instance of the Unlock class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Unlock Class
Sitecore.Pipelines.Save Namespace


Unlock Constructor

[image]

Sitecore 6.4.1 API
Unlock Constructor
Unlock Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Unlock()
Visual Basic
Public Sub New
Visual C++
public:
Unlock()

See Also

Unlock Class
Sitecore.Pipelines.Save Namespace


Unlock Methods

[image] [image]

Sitecore 6.4.1 API
Unlock Methods
Unlock Class See Also Send Feedback

The Unlock type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Unlock Class
Sitecore.Pipelines.Save Namespace


Process Method

[image]

Sitecore 6.4.1 API
Unlock..::..Process Method
Unlock Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    SaveArgs args
)
Visual Basic
Public Sub Process ( _
    args As SaveArgs _
)
Visual C++
public:
void Process(
    SaveArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Save..::..SaveArgs
The arguments.

See Also

Unlock Class
Sitecore.Pipelines.Save Namespace


ValidateFields Class

[image]

Sitecore 6.4.1 API
ValidateFields Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ValidateFields
Visual Basic
Public Class ValidateFields
Visual C++
public ref class ValidateFields

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Save..::..ValidateFields

See Also

ValidateFields Members
Sitecore.Pipelines.Save Namespace


ValidateFields Members

[image] [image]

Sitecore 6.4.1 API
ValidateFields Members
ValidateFields Class Constructors Methods See Also Send Feedback

The ValidateFields type exposes the following members.

Constructors

 | Name | Description
Public method | ValidateFields | Initializes a new instance of the ValidateFields class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ValidateFields Class
Sitecore.Pipelines.Save Namespace


ValidateFields Constructor

[image]

Sitecore 6.4.1 API
ValidateFields Constructor
ValidateFields Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ValidateFields()
Visual Basic
Public Sub New
Visual C++
public:
ValidateFields()

See Also

ValidateFields Class
Sitecore.Pipelines.Save Namespace


ValidateFields Methods

[image] [image]

Sitecore 6.4.1 API
ValidateFields Methods
ValidateFields Class See Also Send Feedback

The ValidateFields type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ValidateFields Class
Sitecore.Pipelines.Save Namespace


Process Method

[image]

Sitecore 6.4.1 API
ValidateFields..::..Process Method
ValidateFields Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    SaveArgs args
)
Visual Basic
Public Sub Process ( _
    args As SaveArgs _
)
Visual C++
public:
void Process(
    SaveArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Save..::..SaveArgs
The arguments.

See Also

ValidateFields Class
Sitecore.Pipelines.Save Namespace


Validators Class

[image]

Sitecore 6.4.1 API
Validators Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Validators
Visual Basic
Public Class Validators
Visual C++
public ref class Validators

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Save..::..Validators

See Also

Validators Members
Sitecore.Pipelines.Save Namespace


Validators Members

[image] [image]

Sitecore 6.4.1 API
Validators Members
Validators Class Constructors Methods See Also Send Feedback

The Validators type exposes the following members.

Constructors

 | Name | Description
Public method | Validators | Initializes a new instance of the Validators class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Protected method | ProcessInternal | Processes the internal.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Validators Class
Sitecore.Pipelines.Save Namespace


Validators Constructor

[image]

Sitecore 6.4.1 API
Validators Constructor
Validators Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Validators()
Visual Basic
Public Sub New
Visual C++
public:
Validators()

See Also

Validators Class
Sitecore.Pipelines.Save Namespace


Validators Methods

[image] [image]

Sitecore 6.4.1 API
Validators Methods
Validators Class See Also Send Feedback

The Validators type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Protected method | ProcessInternal | Processes the internal.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Validators Class
Sitecore.Pipelines.Save Namespace


Process Method

[image]

Sitecore 6.4.1 API
Validators..::..Process Method
Validators Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    SaveArgs args
)
Visual Basic
Public Sub Process ( _
    args As SaveArgs _
)
Visual C++
public:
void Process(
    SaveArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Save..::..SaveArgs
The arguments.

See Also

Validators Class
Sitecore.Pipelines.Save Namespace


ProcessInternal Method

[image]

Sitecore 6.4.1 API
Validators..::..ProcessInternal Method
Validators Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void ProcessInternal(
    ClientPipelineArgs args
)
Visual Basic
Protected Sub ProcessInternal ( _
    args As ClientPipelineArgs _
)
Visual C++
protected:
void ProcessInternal(
    ClientPipelineArgs^ args
)

Parameters

args
Type: Sitecore.Web.UI.Sheer..::..ClientPipelineArgs
The arguments.

See Also

Validators Class
Sitecore.Pipelines.Save Namespace


WorkflowSaveCommand Class

[image]

Sitecore 6.4.1 API
WorkflowSaveCommand Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class WorkflowSaveCommand
Visual Basic
Public Class WorkflowSaveCommand
Visual C++
public ref class WorkflowSaveCommand

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Save..::..WorkflowSaveCommand

See Also

WorkflowSaveCommand Members
Sitecore.Pipelines.Save Namespace


WorkflowSaveCommand Members

[image] [image]

Sitecore 6.4.1 API
WorkflowSaveCommand Members
WorkflowSaveCommand Class Constructors Methods See Also Send Feedback

The WorkflowSaveCommand type exposes the following members.

Constructors

 | Name | Description
Public method | WorkflowSaveCommand | Initializes a new instance of the WorkflowSaveCommand class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WorkflowSaveCommand Class
Sitecore.Pipelines.Save Namespace


WorkflowSaveCommand Constructor

[image]

Sitecore 6.4.1 API
WorkflowSaveCommand Constructor
WorkflowSaveCommand Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WorkflowSaveCommand()
Visual Basic
Public Sub New
Visual C++
public:
WorkflowSaveCommand()

See Also

WorkflowSaveCommand Class
Sitecore.Pipelines.Save Namespace


WorkflowSaveCommand Methods

[image] [image]

Sitecore 6.4.1 API
WorkflowSaveCommand Methods
WorkflowSaveCommand Class See Also Send Feedback

The WorkflowSaveCommand type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WorkflowSaveCommand Class
Sitecore.Pipelines.Save Namespace


Process Method

[image]

Sitecore 6.4.1 API
WorkflowSaveCommand..::..Process Method
WorkflowSaveCommand Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Save
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    SaveArgs args
)
Visual Basic
Public Sub Process ( _
    args As SaveArgs _
)
Visual C++
public:
void Process(
    SaveArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Save..::..SaveArgs
The arguments.

See Also

WorkflowSaveCommand Class
Sitecore.Pipelines.Save Namespace


Sitecore.Pipelines.SaveHtml Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.SaveHtml Namespace
Send Feedback

Classes

 | Class | Description
Public class | Accept | Obsolete. Asks the user to accept.
Public class | ConvertToDesignTime | Obsolete. Converts the Html to design time Html.
Public class | SaveHtmlArgs | Argument class for the Save Html pipeline.


Accept Class

[image]

Sitecore 6.4.1 API
Accept Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute]
public class Accept
Visual Basic
<ObsoleteAttribute> _
Public Class Accept
Visual C++
[ObsoleteAttribute]
public ref class Accept

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.SaveHtml..::..Accept

See Also

Accept Members
Sitecore.Pipelines.SaveHtml Namespace


Accept Members

[image] [image]

Sitecore 6.4.1 API
Accept Members
Accept Class Constructors Methods See Also Send Feedback

The Accept type exposes the following members.

Constructors

 | Name | Description
Public method | Accept | Initializes a new instance of the Accept class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Accept Class
Sitecore.Pipelines.SaveHtml Namespace


Accept Methods

[image] [image]

Sitecore 6.4.1 API
Accept Methods
Accept Class See Also Send Feedback

The Accept type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Accept Class
Sitecore.Pipelines.SaveHtml Namespace


Process Method

[image]

Sitecore 6.4.1 API
Accept..::..Process Method
Accept Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    SaveHtmlArgs args
)
Visual Basic
Public Sub Process ( _
    args As SaveHtmlArgs _
)
Visual C++
public:
void Process(
    SaveHtmlArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.SaveHtml..::..SaveHtmlArgs
The arguments.

See Also

Accept Class
Sitecore.Pipelines.SaveHtml Namespace


ConvertToDesignTime Class

[image]

Sitecore 6.4.1 API
ConvertToDesignTime Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute]
public class ConvertToDesignTime
Visual Basic
<ObsoleteAttribute> _
Public Class ConvertToDesignTime
Visual C++
[ObsoleteAttribute]
public ref class ConvertToDesignTime

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.SaveHtml..::..ConvertToDesignTime

See Also

ConvertToDesignTime Members
Sitecore.Pipelines.SaveHtml Namespace


ConvertToDesignTime Members

[image] [image]

Sitecore 6.4.1 API
ConvertToDesignTime Members
ConvertToDesignTime Class Constructors Methods See Also Send Feedback

The ConvertToDesignTime type exposes the following members.

Constructors

 | Name | Description
Public method | ConvertToDesignTime | Initializes a new instance of the ConvertToDesignTime class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConvertToDesignTime Class
Sitecore.Pipelines.SaveHtml Namespace


ConvertToDesignTime Constructor

[image]

Sitecore 6.4.1 API
ConvertToDesignTime Constructor
ConvertToDesignTime Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ConvertToDesignTime()
Visual Basic
Public Sub New
Visual C++
public:
ConvertToDesignTime()

See Also

ConvertToDesignTime Class
Sitecore.Pipelines.SaveHtml Namespace


Process Method

[image]

Sitecore 6.4.1 API
ConvertToDesignTime..::..Process Method
ConvertToDesignTime Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    SaveHtmlArgs args
)
Visual Basic
Public Sub Process ( _
    args As SaveHtmlArgs _
)
Visual C++
public:
void Process(
    SaveHtmlArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.SaveHtml..::..SaveHtmlArgs
The arguments.

See Also

ConvertToDesignTime Class
Sitecore.Pipelines.SaveHtml Namespace


SaveHtmlArgs Class

[image]

Sitecore 6.4.1 API
SaveHtmlArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class SaveHtmlArgs : ClientPipelineArgs
Visual Basic
<SerializableAttribute> _
Public Class SaveHtmlArgs _
    Inherits ClientPipelineArgs
Visual C++
[SerializableAttribute]
public ref class SaveHtmlArgs : public ClientPipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Web.UI.Sheer..::..ClientPipelineArgs
Sitecore.Pipelines.SaveHtml..::..SaveHtmlArgs

See Also

SaveHtmlArgs Members
Sitecore.Pipelines.SaveHtml Namespace


SaveHtmlArgs Members

[image] [image]

Sitecore 6.4.1 API
SaveHtmlArgs Members
SaveHtmlArgs Class Constructors Methods Properties See Also Send Feedback

The SaveHtmlArgs type exposes the following members.

Constructors

 | Name | Description
Public method | SaveHtmlArgs()()()() | Initializes a new instance of the SaveHtmlArgs class.
Public method | SaveHtmlArgs(NameValueCollection) | Initializes a new instance of the SaveHtmlArgs class.
Protected method | SaveHtmlArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the SaveHtmlArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ClientPipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | A processor is done. (Overrides ClientPipelineArgs..::..ProcessorDone()()()().)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WaitForPostBack()()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Public method | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | Body | Gets or sets the body.
Public property | CarryResultToNextProcessor | Gets or sets a value indicating whether the ClientPipelineArgs carries the result to next processor. (Inherited from ClientPipelineArgs.)
Public property | Code | Gets or sets the code.
Public property | CodeFilename | Gets or sets the code filename.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Footer | Gets or sets the footer.
Public property | HasResult | Gets a value indicating whether this instance has a result. (Inherited from ClientPipelineArgs.)
Public property | Header | Gets or sets the header.
Public property | IsPostBack | Gets or sets a value that indicates if the processor was invoked as part of a user response. (Inherited from ClientPipelineArgs.)
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Parameters | Gets or sets the parameters. (Inherited from ClientPipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Properties | Gets the properties. (Inherited from ClientPipelineArgs.)
Public property | Result | Gets or sets the value that was posted as part of a Sheer response. (Inherited from ClientPipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

SaveHtmlArgs Class
Sitecore.Pipelines.SaveHtml Namespace


SaveHtmlArgs Constructor

[image] [image]

Sitecore 6.4.1 API
SaveHtmlArgs Constructor
SaveHtmlArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SaveHtmlArgs()()()() | Initializes a new instance of the SaveHtmlArgs class.
Public method | SaveHtmlArgs(NameValueCollection) | Initializes a new instance of the SaveHtmlArgs class.
Protected method | SaveHtmlArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the SaveHtmlArgs class.

See Also

SaveHtmlArgs Class
SaveHtmlArgs Members
Sitecore.Pipelines.SaveHtml Namespace


SaveHtmlArgs Constructor

[image]

Sitecore 6.4.1 API
SaveHtmlArgs Constructor
SaveHtmlArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SaveHtmlArgs()
Visual Basic
Public Sub New
Visual C++
public:
SaveHtmlArgs()

See Also

SaveHtmlArgs Class
SaveHtmlArgs Overload
Sitecore.Pipelines.SaveHtml Namespace


SaveHtmlArgs Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
SaveHtmlArgs Constructor (SerializationInfo, StreamingContext)
SaveHtmlArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected SaveHtmlArgs(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
SaveHtmlArgs(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

SaveHtmlArgs Class
SaveHtmlArgs Overload
Sitecore.Pipelines.SaveHtml Namespace


SaveHtmlArgs Methods

[image] [image]

Sitecore 6.4.1 API
SaveHtmlArgs Methods
SaveHtmlArgs Class See Also Send Feedback

The SaveHtmlArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ClientPipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | A processor is done. (Overrides ClientPipelineArgs..::..ProcessorDone()()()().)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WaitForPostBack()()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Public method | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)

See Also

SaveHtmlArgs Class
Sitecore.Pipelines.SaveHtml Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
SaveHtmlArgs..::..AddMessage Method
SaveHtmlArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

SaveHtmlArgs Class
SaveHtmlArgs Members
Sitecore.Pipelines.SaveHtml Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
SaveHtmlArgs..::..GetMessages Method
SaveHtmlArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

SaveHtmlArgs Class
SaveHtmlArgs Members
Sitecore.Pipelines.SaveHtml Namespace


GetObjectData Method

[image]

Sitecore 6.4.1 API
SaveHtmlArgs..::..GetObjectData Method
SaveHtmlArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System.Security..::..SecurityException | The caller does not have the required permission.

See Also

SaveHtmlArgs Class
Sitecore.Pipelines.SaveHtml Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
SaveHtmlArgs..::..Suspend Method
SaveHtmlArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

SaveHtmlArgs Class
SaveHtmlArgs Members
Sitecore.Pipelines.SaveHtml Namespace


WaitForPostBack Method

[image] [image]

Sitecore 6.4.1 API
SaveHtmlArgs..::..WaitForPostBack Method
SaveHtmlArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaitForPostBack()()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Public method | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)

See Also

SaveHtmlArgs Class
SaveHtmlArgs Members
Sitecore.Pipelines.SaveHtml Namespace


SaveHtmlArgs Properties

[image] [image]

Sitecore 6.4.1 API
SaveHtmlArgs Properties
SaveHtmlArgs Class See Also Send Feedback

The SaveHtmlArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | Body | Gets or sets the body.
Public property | CarryResultToNextProcessor | Gets or sets a value indicating whether the ClientPipelineArgs carries the result to next processor. (Inherited from ClientPipelineArgs.)
Public property | Code | Gets or sets the code.
Public property | CodeFilename | Gets or sets the code filename.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Footer | Gets or sets the footer.
Public property | HasResult | Gets a value indicating whether this instance has a result. (Inherited from ClientPipelineArgs.)
Public property | Header | Gets or sets the header.
Public property | IsPostBack | Gets or sets a value that indicates if the processor was invoked as part of a user response. (Inherited from ClientPipelineArgs.)
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Parameters | Gets or sets the parameters. (Inherited from ClientPipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Properties | Gets the properties. (Inherited from ClientPipelineArgs.)
Public property | Result | Gets or sets the value that was posted as part of a Sheer response. (Inherited from ClientPipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

SaveHtmlArgs Class
Sitecore.Pipelines.SaveHtml Namespace


Body Property

[image]

Sitecore 6.4.1 API
SaveHtmlArgs..::..Body Property
SaveHtmlArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Body { get; set; }
Visual Basic
Public Property Body As String
    Get
    Set
Visual C++
public:
property String^ Body {
    String^ get ();
    void set (String^ value);
}

Field Value

The body.

See Also

SaveHtmlArgs Class
Sitecore.Pipelines.SaveHtml Namespace


CodeFilename Property

[image]

Sitecore 6.4.1 API
SaveHtmlArgs..::..CodeFilename Property
SaveHtmlArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string CodeFilename { get; set; }
Visual Basic
Public Property CodeFilename As String
    Get
    Set
Visual C++
public:
property String^ CodeFilename {
    String^ get ();
    void set (String^ value);
}

Field Value

The code filename.

See Also

SaveHtmlArgs Class
Sitecore.Pipelines.SaveHtml Namespace


Footer Property

[image]

Sitecore 6.4.1 API
SaveHtmlArgs..::..Footer Property
SaveHtmlArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Footer { get; set; }
Visual Basic
Public Property Footer As String
    Get
    Set
Visual C++
public:
property String^ Footer {
    String^ get ();
    void set (String^ value);
}

Field Value

The footer.

See Also

SaveHtmlArgs Class
Sitecore.Pipelines.SaveHtml Namespace


Header Property

[image]

Sitecore 6.4.1 API
SaveHtmlArgs..::..Header Property
SaveHtmlArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveHtml
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Header { get; set; }
Visual Basic
Public Property Header As String
    Get
    Set
Visual C++
public:
property String^ Header {
    String^ get ();
    void set (String^ value);
}

Field Value

The header.

See Also

SaveHtmlArgs Class
Sitecore.Pipelines.SaveHtml Namespace


Sitecore.Pipelines.SaveLayout Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.SaveLayout Namespace
Send Feedback

Classes

 | Class | Description
Public class | ConvertToRuntime | Represents a ConvertToRuntime processor.
Public class | ConvertToXHtml | Converts the body to XHtml.
Public class | NewFile | Creates a new file.
Public class | Overwrite | Overwrites and existing file.
Public class | Save | Saves the layout.
Public class | SaveLayoutArgs | Argument class for ILoginProcessor implementations

Enumerations

 | Enumeration | Description
Public enumeration | SaveLayoutArgs..::..LayoutType | Defines the type of layout.


ConvertToRuntime Class

[image]

Sitecore 6.4.1 API
ConvertToRuntime Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ConvertToRuntime
Visual Basic
Public Class ConvertToRuntime
Visual C++
public ref class ConvertToRuntime

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.SaveLayout..::..ConvertToRuntime

See Also

ConvertToRuntime Members
Sitecore.Pipelines.SaveLayout Namespace


ConvertToRuntime Members

[image] [image]

Sitecore 6.4.1 API
ConvertToRuntime Members
ConvertToRuntime Class Constructors Methods See Also Send Feedback

The ConvertToRuntime type exposes the following members.

Constructors

 | Name | Description
Public method | ConvertToRuntime | Initializes a new instance of the ConvertToRuntime class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConvertToRuntime Class
Sitecore.Pipelines.SaveLayout Namespace


ConvertToRuntime Methods

[image] [image]

Sitecore 6.4.1 API
ConvertToRuntime Methods
ConvertToRuntime Class See Also Send Feedback

The ConvertToRuntime type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConvertToRuntime Class
Sitecore.Pipelines.SaveLayout Namespace


Process Method

[image]

Sitecore 6.4.1 API
ConvertToRuntime..::..Process Method
ConvertToRuntime Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    SaveLayoutArgs args
)
Visual Basic
Public Sub Process ( _
    args As SaveLayoutArgs _
)
Visual C++
public:
void Process(
    SaveLayoutArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.SaveLayout..::..SaveLayoutArgs
The arguments.

See Also

ConvertToRuntime Class
Sitecore.Pipelines.SaveLayout Namespace


ConvertToXHtml Class

[image]

Sitecore 6.4.1 API
ConvertToXHtml Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ConvertToXHtml
Visual Basic
Public Class ConvertToXHtml
Visual C++
public ref class ConvertToXHtml

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.SaveLayout..::..ConvertToXHtml

See Also

ConvertToXHtml Members
Sitecore.Pipelines.SaveLayout Namespace


ConvertToXHtml Members

[image] [image]

Sitecore 6.4.1 API
ConvertToXHtml Members
ConvertToXHtml Class Constructors Methods See Also Send Feedback

The ConvertToXHtml type exposes the following members.

Constructors

 | Name | Description
Public method | ConvertToXHtml | Initializes a new instance of the ConvertToXHtml class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConvertToXHtml Class
Sitecore.Pipelines.SaveLayout Namespace


ConvertToXHtml Constructor

[image]

Sitecore 6.4.1 API
ConvertToXHtml Constructor
ConvertToXHtml Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ConvertToXHtml()
Visual Basic
Public Sub New
Visual C++
public:
ConvertToXHtml()

See Also

ConvertToXHtml Class
Sitecore.Pipelines.SaveLayout Namespace


ConvertToXHtml Methods

[image] [image]

Sitecore 6.4.1 API
ConvertToXHtml Methods
ConvertToXHtml Class See Also Send Feedback

The ConvertToXHtml type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConvertToXHtml Class
Sitecore.Pipelines.SaveLayout Namespace


Process Method

[image]

Sitecore 6.4.1 API
ConvertToXHtml..::..Process Method
ConvertToXHtml Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    SaveLayoutArgs args
)
Visual Basic
Public Sub Process ( _
    args As SaveLayoutArgs _
)
Visual C++
public:
void Process(
    SaveLayoutArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.SaveLayout..::..SaveLayoutArgs
The arguments.

See Also

ConvertToXHtml Class
Sitecore.Pipelines.SaveLayout Namespace


NewFile Class

[image]

Sitecore 6.4.1 API
NewFile Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class NewFile
Visual Basic
Public Class NewFile
Visual C++
public ref class NewFile

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.SaveLayout..::..NewFile

See Also

NewFile Members
Sitecore.Pipelines.SaveLayout Namespace


NewFile Members

[image] [image]

Sitecore 6.4.1 API
NewFile Members
NewFile Class Constructors Methods See Also Send Feedback

The NewFile type exposes the following members.

Constructors

 | Name | Description
Public method | NewFile | Initializes a new instance of the NewFile class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NewFile Class
Sitecore.Pipelines.SaveLayout Namespace


NewFile Constructor

[image]

Sitecore 6.4.1 API
NewFile Constructor
NewFile Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public NewFile()
Visual Basic
Public Sub New
Visual C++
public:
NewFile()

See Also

NewFile Class
Sitecore.Pipelines.SaveLayout Namespace


NewFile Methods

[image] [image]

Sitecore 6.4.1 API
NewFile Methods
NewFile Class See Also Send Feedback

The NewFile type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NewFile Class
Sitecore.Pipelines.SaveLayout Namespace


Process Method

[image]

Sitecore 6.4.1 API
NewFile..::..Process Method
NewFile Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    SaveLayoutArgs args
)
Visual Basic
Public Sub Process ( _
    args As SaveLayoutArgs _
)
Visual C++
public:
void Process(
    SaveLayoutArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.SaveLayout..::..SaveLayoutArgs
The arguments.

See Also

NewFile Class
Sitecore.Pipelines.SaveLayout Namespace


Overwrite Class

[image]

Sitecore 6.4.1 API
Overwrite Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Overwrite
Visual Basic
Public Class Overwrite
Visual C++
public ref class Overwrite

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.SaveLayout..::..Overwrite

See Also

Overwrite Members
Sitecore.Pipelines.SaveLayout Namespace


Overwrite Members

[image] [image]

Sitecore 6.4.1 API
Overwrite Members
Overwrite Class Constructors Methods See Also Send Feedback

The Overwrite type exposes the following members.

Constructors

 | Name | Description
Public method | Overwrite | Initializes a new instance of the Overwrite class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Overwrite Class
Sitecore.Pipelines.SaveLayout Namespace


Overwrite Constructor

[image]

Sitecore 6.4.1 API
Overwrite Constructor
Overwrite Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Overwrite()
Visual Basic
Public Sub New
Visual C++
public:
Overwrite()

See Also

Overwrite Class
Sitecore.Pipelines.SaveLayout Namespace


Overwrite Methods

[image] [image]

Sitecore 6.4.1 API
Overwrite Methods
Overwrite Class See Also Send Feedback

The Overwrite type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Overwrite Class
Sitecore.Pipelines.SaveLayout Namespace


Process Method

[image]

Sitecore 6.4.1 API
Overwrite..::..Process Method
Overwrite Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    SaveLayoutArgs args
)
Visual Basic
Public Sub Process ( _
    args As SaveLayoutArgs _
)
Visual C++
public:
void Process(
    SaveLayoutArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.SaveLayout..::..SaveLayoutArgs
The arguments.

See Also

Overwrite Class
Sitecore.Pipelines.SaveLayout Namespace


Save Class

[image]

Sitecore 6.4.1 API
Save Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Save
Visual Basic
Public Class Save
Visual C++
public ref class Save

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.SaveLayout..::..Save

See Also

Save Members
Sitecore.Pipelines.SaveLayout Namespace


Save Members

[image] [image]

Sitecore 6.4.1 API
Save Members
Save Class Constructors Methods See Also Send Feedback

The Save type exposes the following members.

Constructors

 | Name | Description
Public method | Save | Initializes a new instance of the Save class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Save Class
Sitecore.Pipelines.SaveLayout Namespace


Save Constructor

[image]

Sitecore 6.4.1 API
Save Constructor
Save Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Save()
Visual Basic
Public Sub New
Visual C++
public:
Save()

See Also

Save Class
Sitecore.Pipelines.SaveLayout Namespace


Save Methods

[image] [image]

Sitecore 6.4.1 API
Save Methods
Save Class See Also Send Feedback

The Save type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Save Class
Sitecore.Pipelines.SaveLayout Namespace


Process Method

[image]

Sitecore 6.4.1 API
Save..::..Process Method
Save Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    SaveLayoutArgs args
)
Visual Basic
Public Sub Process ( _
    args As SaveLayoutArgs _
)
Visual C++
public:
void Process(
    SaveLayoutArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.SaveLayout..::..SaveLayoutArgs
The arguments.

See Also

Save Class
Sitecore.Pipelines.SaveLayout Namespace


SaveLayoutArgs Class

[image]

Sitecore 6.4.1 API
SaveLayoutArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class SaveLayoutArgs : ClientPipelineArgs
Visual Basic
<SerializableAttribute> _
Public Class SaveLayoutArgs _
    Inherits ClientPipelineArgs
Visual C++
[SerializableAttribute]
public ref class SaveLayoutArgs : public ClientPipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Web.UI.Sheer..::..ClientPipelineArgs
Sitecore.Pipelines.SaveLayout..::..SaveLayoutArgs

See Also

SaveLayoutArgs Members
Sitecore.Pipelines.SaveLayout Namespace


SaveLayoutArgs Members

[image] [image]

Sitecore 6.4.1 API
SaveLayoutArgs Members
SaveLayoutArgs Class Constructors Methods Properties See Also Send Feedback

The SaveLayoutArgs type exposes the following members.

Constructors

 | Name | Description
Public method | SaveLayoutArgs()()()() | Initializes a new instance of the SaveLayoutArgs class.
Protected method | SaveLayoutArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the SaveLayoutArgs class from a serialization context.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ClientPipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | A processor is done. (Overrides ClientPipelineArgs..::..ProcessorDone()()()().)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WaitForPostBack()()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Public method | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | Body | Gets or sets the body.
Public property | CarryResultToNextProcessor | Gets or sets a value indicating whether the ClientPipelineArgs carries the result to next processor. (Inherited from ClientPipelineArgs.)
Public property | Code | Gets or sets the code.
Public property | CodeFilename | Gets or sets the code filename.
Public property | ConvertToRuntime | Gets or sets a value indicating whether the layout should be converted to runtime HTML.
Public property | ConvertToXHtml | Gets or sets a value indicating whether the layout is converted to XHTML.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Filename | Gets or sets the filename.
Public property | Footer | Gets or sets the footer.
Public property | HasResult | Gets a value indicating whether this instance has a result. (Inherited from ClientPipelineArgs.)
Public property | Header | Gets or sets the header.
Public property | IsPostBack | Gets or sets a value that indicates if the processor was invoked as part of a user response. (Inherited from ClientPipelineArgs.)
Public property | LastWriteTime | Gets or sets the last write time.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Parameters | Gets or sets the parameters. (Inherited from ClientPipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Properties | Gets the properties. (Inherited from ClientPipelineArgs.)
Public property | Result | Gets or sets the value that was posted as part of a Sheer response. (Inherited from ClientPipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
Public property | Type | Gets or sets the type.

See Also

SaveLayoutArgs Class
Sitecore.Pipelines.SaveLayout Namespace


SaveLayoutArgs Constructor

[image] [image]

Sitecore 6.4.1 API
SaveLayoutArgs Constructor
SaveLayoutArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SaveLayoutArgs()()()() | Initializes a new instance of the SaveLayoutArgs class.
Protected method | SaveLayoutArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the SaveLayoutArgs class from a serialization context.

See Also

SaveLayoutArgs Class
SaveLayoutArgs Members
Sitecore.Pipelines.SaveLayout Namespace


SaveLayoutArgs Constructor

[image]

Sitecore 6.4.1 API
SaveLayoutArgs Constructor
SaveLayoutArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SaveLayoutArgs()
Visual Basic
Public Sub New
Visual C++
public:
SaveLayoutArgs()

See Also

SaveLayoutArgs Class
SaveLayoutArgs Overload
Sitecore.Pipelines.SaveLayout Namespace


SaveLayoutArgs Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
SaveLayoutArgs Constructor (SerializationInfo, StreamingContext)
SaveLayoutArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected SaveLayoutArgs(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
SaveLayoutArgs(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The serialized data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

SaveLayoutArgs Class
SaveLayoutArgs Overload
Sitecore.Pipelines.SaveLayout Namespace


SaveLayoutArgs Methods

[image] [image]

Sitecore 6.4.1 API
SaveLayoutArgs Methods
SaveLayoutArgs Class See Also Send Feedback

The SaveLayoutArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ClientPipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | A processor is done. (Overrides ClientPipelineArgs..::..ProcessorDone()()()().)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WaitForPostBack()()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Public method | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)

See Also

SaveLayoutArgs Class
Sitecore.Pipelines.SaveLayout Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
SaveLayoutArgs..::..AddMessage Method
SaveLayoutArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

SaveLayoutArgs Class
SaveLayoutArgs Members
Sitecore.Pipelines.SaveLayout Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
SaveLayoutArgs..::..GetMessages Method
SaveLayoutArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

SaveLayoutArgs Class
SaveLayoutArgs Members
Sitecore.Pipelines.SaveLayout Namespace


GetObjectData Method

[image]

Sitecore 6.4.1 API
SaveLayoutArgs..::..GetObjectData Method
SaveLayoutArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System.Security..::..SecurityException | The caller does not have the required permission.

See Also

SaveLayoutArgs Class
Sitecore.Pipelines.SaveLayout Namespace


ProcessorDone Method

[image]

Sitecore 6.4.1 API
SaveLayoutArgs..::..ProcessorDone Method
SaveLayoutArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected internal override void ProcessorDone()
Visual Basic
Protected Friend Overrides Sub ProcessorDone
Visual C++
protected public:
virtual void ProcessorDone() override

See Also

SaveLayoutArgs Class
Sitecore.Pipelines.SaveLayout Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
SaveLayoutArgs..::..Suspend Method
SaveLayoutArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

SaveLayoutArgs Class
SaveLayoutArgs Members
Sitecore.Pipelines.SaveLayout Namespace


SaveLayoutArgs Properties

[image] [image]

Sitecore 6.4.1 API
SaveLayoutArgs Properties
SaveLayoutArgs Class See Also Send Feedback

The SaveLayoutArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | Body | Gets or sets the body.
Public property | CarryResultToNextProcessor | Gets or sets a value indicating whether the ClientPipelineArgs carries the result to next processor. (Inherited from ClientPipelineArgs.)
Public property | Code | Gets or sets the code.
Public property | CodeFilename | Gets or sets the code filename.
Public property | ConvertToRuntime | Gets or sets a value indicating whether the layout should be converted to runtime HTML.
Public property | ConvertToXHtml | Gets or sets a value indicating whether the layout is converted to XHTML.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Filename | Gets or sets the filename.
Public property | Footer | Gets or sets the footer.
Public property | HasResult | Gets a value indicating whether this instance has a result. (Inherited from ClientPipelineArgs.)
Public property | Header | Gets or sets the header.
Public property | IsPostBack | Gets or sets a value that indicates if the processor was invoked as part of a user response. (Inherited from ClientPipelineArgs.)
Public property | LastWriteTime | Gets or sets the last write time.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Parameters | Gets or sets the parameters. (Inherited from ClientPipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Properties | Gets the properties. (Inherited from ClientPipelineArgs.)
Public property | Result | Gets or sets the value that was posted as part of a Sheer response. (Inherited from ClientPipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
Public property | Type | Gets or sets the type.

See Also

SaveLayoutArgs Class
Sitecore.Pipelines.SaveLayout Namespace


Body Property

[image]

Sitecore 6.4.1 API
SaveLayoutArgs..::..Body Property
SaveLayoutArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Body { get; set; }
Visual Basic
Public Property Body As String
    Get
    Set
Visual C++
public:
property String^ Body {
    String^ get ();
    void set (String^ value);
}

Field Value

The body.

See Also

SaveLayoutArgs Class
Sitecore.Pipelines.SaveLayout Namespace


Code Property

[image]

Sitecore 6.4.1 API
SaveLayoutArgs..::..Code Property
SaveLayoutArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Code { get; set; }
Visual Basic
Public Property Code As String
    Get
    Set
Visual C++
public:
property String^ Code {
    String^ get ();
    void set (String^ value);
}

Field Value

The code.

See Also

SaveLayoutArgs Class
Sitecore.Pipelines.SaveLayout Namespace


CodeFilename Property

[image]

Sitecore 6.4.1 API
SaveLayoutArgs..::..CodeFilename Property
SaveLayoutArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string CodeFilename { get; set; }
Visual Basic
Public Property CodeFilename As String
    Get
    Set
Visual C++
public:
property String^ CodeFilename {
    String^ get ();
    void set (String^ value);
}

Field Value

The code filename.

See Also

SaveLayoutArgs Class
Sitecore.Pipelines.SaveLayout Namespace


ConvertToRuntime Property

[image]

Sitecore 6.4.1 API
SaveLayoutArgs..::..ConvertToRuntime Property
SaveLayoutArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ConvertToRuntime { get; set; }
Visual Basic
Public Property ConvertToRuntime As Boolean
    Get
    Set
Visual C++
public:
property bool ConvertToRuntime {
    bool get ();
    void set (bool value);
}

Field Value

true if the layout should be converted to runtime HTML; otherwise, false.

See Also

SaveLayoutArgs Class
Sitecore.Pipelines.SaveLayout Namespace


ConvertToXHtml Property

[image]

Sitecore 6.4.1 API
SaveLayoutArgs..::..ConvertToXHtml Property
SaveLayoutArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool ConvertToXHtml { get; set; }
Visual Basic
Public Property ConvertToXHtml As Boolean
    Get
    Set
Visual C++
public:
property bool ConvertToXHtml {
    bool get ();
    void set (bool value);
}

Field Value

true if the layout is converted to XHTML; otherwise, false.

See Also

SaveLayoutArgs Class
Sitecore.Pipelines.SaveLayout Namespace


Footer Property

[image]

Sitecore 6.4.1 API
SaveLayoutArgs..::..Footer Property
SaveLayoutArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Footer { get; set; }
Visual Basic
Public Property Footer As String
    Get
    Set
Visual C++
public:
property String^ Footer {
    String^ get ();
    void set (String^ value);
}

Field Value

The footer.

See Also

SaveLayoutArgs Class
Sitecore.Pipelines.SaveLayout Namespace


Header Property

[image]

Sitecore 6.4.1 API
SaveLayoutArgs..::..Header Property
SaveLayoutArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Header { get; set; }
Visual Basic
Public Property Header As String
    Get
    Set
Visual C++
public:
property String^ Header {
    String^ get ();
    void set (String^ value);
}

Field Value

The header.

See Also

SaveLayoutArgs Class
Sitecore.Pipelines.SaveLayout Namespace


LastWriteTime Property

[image]

Sitecore 6.4.1 API
SaveLayoutArgs..::..LastWriteTime Property
SaveLayoutArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime LastWriteTime { get; set; }
Visual Basic
Public Property LastWriteTime As DateTime
    Get
    Set
Visual C++
public:
property DateTime LastWriteTime {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The last write time.

See Also

SaveLayoutArgs Class
Sitecore.Pipelines.SaveLayout Namespace


Type Property

[image]

Sitecore 6.4.1 API
SaveLayoutArgs..::..Type Property
SaveLayoutArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SaveLayoutArgs..::..LayoutType Type { get; set; }
Visual Basic
Public Property Type As SaveLayoutArgs..::..LayoutType
    Get
    Set
Visual C++
public:
property SaveLayoutArgs..::..LayoutType Type {
    SaveLayoutArgs..::..LayoutType get ();
    void set (SaveLayoutArgs..::..LayoutType value);
}

Field Value

The type.

See Also

SaveLayoutArgs Class
Sitecore.Pipelines.SaveLayout Namespace


SaveLayoutArgs.LayoutType Enumeration

[image]

Sitecore 6.4.1 API
SaveLayoutArgs..::..LayoutType Enumeration
SaveLayoutArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SaveLayout
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum LayoutType
Visual Basic
Public Enumeration LayoutType
Visual C++
public enum class LayoutType

Members

Member name | Value | Description
Layout | 0 | Layout.
Sublayout | 1 | Sublayout.
Other | 2 | Other.

See Also

Sitecore.Pipelines.SaveLayout Namespace


Sitecore.Pipelines.Search Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.Search Namespace
Send Feedback

Classes

 | Class | Description
Public class | AddInstantOptions | Adds the instant search options.
Public class | CategorizeResults | Categorizes the results.
Public class | CategorizeResults..::..Categorizer | Categorizes search results.
Public class | CategorizeResults..::..Category | Represents a search result category
Public class | CategorizeResults..::..PathCategory | Represents a path based category
Public class | CategorizeResults..::..TemplateCategory | Represents a template based category.
Public class | DatabaseResolver | Allows database switching in instant searches.
Public class | IDResolver | Resolves id searches.
Public class | PathResolver | Resolves path searches
Public class | SearchArgs | Arguments for search pipeline.
Public class | SearchSystemIndex | Searches the system index.
Public class | SecurityResolver | Resolves the security based searches, such as users and roles.
Public class | UrlResolver | Resolves url searchers.


AddInstantOptions Class

[image]

Sitecore 6.4.1 API
AddInstantOptions Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class AddInstantOptions
Visual Basic
Public Class AddInstantOptions
Visual C++
public ref class AddInstantOptions

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Search..::..AddInstantOptions

See Also

AddInstantOptions Members
Sitecore.Pipelines.Search Namespace


AddInstantOptions Members

[image] [image]

Sitecore 6.4.1 API
AddInstantOptions Members
AddInstantOptions Class Constructors Methods See Also Send Feedback

The AddInstantOptions type exposes the following members.

Constructors

 | Name | Description
Public method | AddInstantOptions | Initializes a new instance of the AddInstantOptions class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddInstantOptions Class
Sitecore.Pipelines.Search Namespace


AddInstantOptions Constructor

[image]

Sitecore 6.4.1 API
AddInstantOptions Constructor
AddInstantOptions Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AddInstantOptions()
Visual Basic
Public Sub New
Visual C++
public:
AddInstantOptions()

See Also

AddInstantOptions Class
Sitecore.Pipelines.Search Namespace


AddInstantOptions Methods

[image] [image]

Sitecore 6.4.1 API
AddInstantOptions Methods
AddInstantOptions Class See Also Send Feedback

The AddInstantOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddInstantOptions Class
Sitecore.Pipelines.Search Namespace


Process Method

[image]

Sitecore 6.4.1 API
AddInstantOptions..::..Process Method
AddInstantOptions Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    SearchArgs args
)
Visual Basic
Public Sub Process ( _
    args As SearchArgs _
)
Visual C++
public:
void Process(
    SearchArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Search..::..SearchArgs
The arguments.

See Also

AddInstantOptions Class
Sitecore.Pipelines.Search Namespace


CategorizeResults Class

[image]

Sitecore 6.4.1 API
CategorizeResults Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CategorizeResults
Visual Basic
Public Class CategorizeResults
Visual C++
public ref class CategorizeResults

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Search..::..CategorizeResults

See Also

CategorizeResults Members
Sitecore.Pipelines.Search Namespace


CategorizeResults Members

[image] [image]

Sitecore 6.4.1 API
CategorizeResults Members
CategorizeResults Class Constructors Methods See Also Send Feedback

The CategorizeResults type exposes the following members.

Constructors

 | Name | Description
Public method | CategorizeResults | Initializes a new instance of the CategorizeResults class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CategorizeResults Class
Sitecore.Pipelines.Search Namespace


CategorizeResults Methods

[image] [image]

Sitecore 6.4.1 API
CategorizeResults Methods
CategorizeResults Class See Also Send Feedback

The CategorizeResults type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CategorizeResults Class
Sitecore.Pipelines.Search Namespace


Process Method

[image]

Sitecore 6.4.1 API
CategorizeResults..::..Process Method
CategorizeResults Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    SearchArgs args
)
Visual Basic
Public Sub Process ( _
    args As SearchArgs _
)
Visual C++
public:
void Process(
    SearchArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Search..::..SearchArgs
The arguments.

See Also

CategorizeResults Class
Sitecore.Pipelines.Search Namespace


CategorizeResults.Categorizer Class

[image]

Sitecore 6.4.1 API
CategorizeResults..::..Categorizer Class
CategorizeResults Class Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Categorizer
Visual Basic
Public Class Categorizer
Visual C++
public ref class Categorizer

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Search..::..CategorizeResults..::..Categorizer

See Also

CategorizeResults..::..Categorizer Members
Sitecore.Pipelines.Search Namespace


CategorizeResults.Categorizer Members

[image] [image]

Sitecore 6.4.1 API
CategorizeResults..::..Categorizer Members
CategorizeResults..::..Categorizer Class Constructors Methods See Also Send Feedback

Categorizes the results.
Categorizes the results.
Categorizes the results.
Categorizes the results.
Categorizes the results.

The CategorizeResults..::..Categorizer type exposes the following members.

Constructors

 | Name | Description
Public method | CategorizeResults..::..Categorizer | Initializes a new instance of the CategorizeResults..::..Categorizer class

Methods

 | Name | Description
Public method | AddCategory(CategorizeResults..::..Category) | Adds the category.
Public method | AddCategory(CategorizeResults..::..Category, Int32) | Adds the category.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCategory | Gets the category.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CategorizeResults..::..Categorizer Class
Sitecore.Pipelines.Search Namespace


CategorizeResults.Categorizer Constructor

[image]

Sitecore 6.4.1 API
CategorizeResults..::..Categorizer Constructor
CategorizeResults..::..Categorizer Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Categorizer()
Visual Basic
Public Sub New
Visual C++
public:
Categorizer()

See Also

CategorizeResults..::..Categorizer Class
Sitecore.Pipelines.Search Namespace


CategorizeResults.Categorizer Methods

[image] [image]

Sitecore 6.4.1 API
CategorizeResults..::..Categorizer Methods
CategorizeResults..::..Categorizer Class See Also Send Feedback

The CategorizeResults..::..Categorizer type exposes the following members.

Methods

 | Name | Description
Public method | AddCategory(CategorizeResults..::..Category) | Adds the category.
Public method | AddCategory(CategorizeResults..::..Category, Int32) | Adds the category.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCategory | Gets the category.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CategorizeResults..::..Categorizer Class
Sitecore.Pipelines.Search Namespace


AddCategory Method

[image] [image]

Sitecore 6.4.1 API
CategorizeResults..::..Categorizer..::..AddCategory Method
CategorizeResults..::..Categorizer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddCategory(CategorizeResults..::..Category) | Adds the category.
Public method | AddCategory(CategorizeResults..::..Category, Int32) | Adds the category.

See Also

CategorizeResults..::..Categorizer Class
CategorizeResults..::..Categorizer Members
Sitecore.Pipelines.Search Namespace


AddCategory Method (CategorizeResults.Category, Int32)

[image]

Sitecore 6.4.1 API
CategorizeResults..::..Categorizer..::..AddCategory Method (CategorizeResults..::..Category, Int32)
CategorizeResults..::..Categorizer Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddCategory(
    CategorizeResults..::..Category category,
    int index
)
Visual Basic
Public Sub AddCategory ( _
    category As CategorizeResults..::..Category, _
    index As Integer _
)
Visual C++
public:
void AddCategory(
    CategorizeResults..::..Category^ category,
    int index
)

Parameters

category
Type: Sitecore.Pipelines.Search..::..CategorizeResults..::..Category
The item.
index
Type: System..::..Int32
The index.

See Also

CategorizeResults..::..Categorizer Class
AddCategory Overload
Sitecore.Pipelines.Search Namespace


CategorizeResults.Category Class

[image]

Sitecore 6.4.1 API
CategorizeResults..::..Category Class
CategorizeResults Class Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class Category
Visual Basic
Public MustInherit Class Category
Visual C++
public ref class Category abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Search..::..CategorizeResults..::..Category
Sitecore.Pipelines.Search..::..CategorizeResults..::..PathCategory
Sitecore.Pipelines.Search..::..CategorizeResults..::..TemplateCategory

See Also

CategorizeResults..::..Category Members
Sitecore.Pipelines.Search Namespace


CategorizeResults.Category Members

[image] [image]

Sitecore 6.4.1 API
CategorizeResults..::..Category Members
CategorizeResults..::..Category Class Constructors Methods Properties See Also Send Feedback

Categorizes the results.
Categorizes the results.
Categorizes the results.
Categorizes the results.
Categorizes the results.

The CategorizeResults..::..Category type exposes the following members.

Constructors

 | Name | Description
Public method | CategorizeResults..::..Category()()()() | Initializes a new instance of the CategorizeResults..::..Category class.
Public method | CategorizeResults..::..Category(String) | Initializes a new instance of the CategorizeResults..::..Category class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetAutoDisplayName | Gets the display name of the auto.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Matches | Matcheses the specified item.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DisplayName | Gets or sets the display name.

See Also

CategorizeResults..::..Category Class
Sitecore.Pipelines.Search Namespace


CategorizeResults.Category Constructor

[image] [image]

Sitecore 6.4.1 API
CategorizeResults..::..Category Constructor
CategorizeResults..::..Category Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CategorizeResults..::..Category()()()() | Initializes a new instance of the CategorizeResults..::..Category class.
Public method | CategorizeResults..::..Category(String) | Initializes a new instance of the CategorizeResults..::..Category class.

See Also

CategorizeResults..::..Category Class
CategorizeResults..::..Category Members
Sitecore.Pipelines.Search Namespace


CategorizeResults.Category Constructor

[image]

Sitecore 6.4.1 API
CategorizeResults..::..Category Constructor
CategorizeResults..::..Category Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Category()
Visual Basic
Public Sub New
Visual C++
public:
Category()

See Also

CategorizeResults..::..Category Class
CategorizeResults..::..Category Overload
Sitecore.Pipelines.Search Namespace


GetAutoDisplayName Method

[image]

Sitecore 6.4.1 API
CategorizeResults..::..Category..::..GetAutoDisplayName Method
CategorizeResults..::..Category Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string GetAutoDisplayName()
Visual Basic
Protected Overridable Function GetAutoDisplayName As String
Visual C++
protected:
virtual String^ GetAutoDisplayName()

Return Value

The auto display name.

See Also

CategorizeResults..::..Category Class
Sitecore.Pipelines.Search Namespace


Matches Method

[image]

Sitecore 6.4.1 API
CategorizeResults..::..Category..::..Matches Method
CategorizeResults..::..Category Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract bool Matches(
    Item item
)
Visual Basic
Public MustOverride Function Matches ( _
    item As Item _
) As Boolean
Visual C++
public:
virtual bool Matches(
    Item^ item
) abstract

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

The matches.

See Also

CategorizeResults..::..Category Class
Sitecore.Pipelines.Search Namespace


CategorizeResults.Category Properties

[image] [image]

Sitecore 6.4.1 API
CategorizeResults..::..Category Properties
CategorizeResults..::..Category Class See Also Send Feedback

The CategorizeResults..::..Category type exposes the following members.

Properties

 | Name | Description
Public property | DisplayName | Gets or sets the display name.

See Also

CategorizeResults..::..Category Class
Sitecore.Pipelines.Search Namespace


DisplayName Property

[image]

Sitecore 6.4.1 API
CategorizeResults..::..Category..::..DisplayName Property
CategorizeResults..::..Category Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string DisplayName { get; set; }
Visual Basic
Public Property DisplayName As String
    Get
    Set
Visual C++
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}

Field Value

The display name.

See Also

CategorizeResults..::..Category Class
Sitecore.Pipelines.Search Namespace


CategorizeResults.PathCategory Class

[image]

Sitecore 6.4.1 API
CategorizeResults..::..PathCategory Class
CategorizeResults Class Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PathCategory : CategorizeResults..::..Category
Visual Basic
Public Class PathCategory _
    Inherits CategorizeResults..::..Category
Visual C++
public ref class PathCategory : public CategorizeResults..::..Category

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Search..::..CategorizeResults..::..Category
Sitecore.Pipelines.Search..::..CategorizeResults..::..PathCategory

See Also

CategorizeResults..::..PathCategory Members
Sitecore.Pipelines.Search Namespace


CategorizeResults.PathCategory Members

[image] [image]

Sitecore 6.4.1 API
CategorizeResults..::..PathCategory Members
CategorizeResults..::..PathCategory Class Constructors Methods Properties See Also Send Feedback

Categorizes the results.
Categorizes the results.
Categorizes the results.
Categorizes the results.
Categorizes the results.

The CategorizeResults..::..PathCategory type exposes the following members.

Constructors

 | Name | Description
Public method | CategorizeResults..::..PathCategory | Initializes a new instance of the CategorizeResults..::..PathCategory class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetAutoDisplayName | Gets the display name of the auto. (Overrides CategorizeResults..::..Category..::..GetAutoDisplayName()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Matches | Matcheses the specified item. (Overrides CategorizeResults..::..Category..::..Matches(Item).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DisplayName | Gets or sets the display name. (Inherited from CategorizeResults..::..Category.)
Public property | Root | Gets or sets the root.

See Also

CategorizeResults..::..PathCategory Class
Sitecore.Pipelines.Search Namespace


CategorizeResults.PathCategory Constructor

[image]

Sitecore 6.4.1 API
CategorizeResults..::..PathCategory Constructor
CategorizeResults..::..PathCategory Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PathCategory(
    Item root,
    string displayName
)
Visual Basic
Public Sub New ( _
    root As Item, _
    displayName As String _
)
Visual C++
public:
PathCategory(
    Item^ root,
    String^ displayName
)

Parameters

root
Type: Sitecore.Data.Items..::..Item
The root.
displayName
Type: System..::..String
The display name.

See Also

CategorizeResults..::..PathCategory Class
Sitecore.Pipelines.Search Namespace


CategorizeResults.PathCategory Methods

[image] [image]

Sitecore 6.4.1 API
CategorizeResults..::..PathCategory Methods
CategorizeResults..::..PathCategory Class See Also Send Feedback

The CategorizeResults..::..PathCategory type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetAutoDisplayName | Gets the display name of the auto. (Overrides CategorizeResults..::..Category..::..GetAutoDisplayName()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Matches | Matcheses the specified item. (Overrides CategorizeResults..::..Category..::..Matches(Item).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CategorizeResults..::..PathCategory Class
Sitecore.Pipelines.Search Namespace


GetAutoDisplayName Method

[image]

Sitecore 6.4.1 API
CategorizeResults..::..PathCategory..::..GetAutoDisplayName Method
CategorizeResults..::..PathCategory Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override string GetAutoDisplayName()
Visual Basic
Protected Overrides Function GetAutoDisplayName As String
Visual C++
protected:
virtual String^ GetAutoDisplayName() override

Return Value

The auto display name.

See Also

CategorizeResults..::..PathCategory Class
Sitecore.Pipelines.Search Namespace


Matches Method

[image]

Sitecore 6.4.1 API
CategorizeResults..::..PathCategory..::..Matches Method
CategorizeResults..::..PathCategory Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool Matches(
    Item item
)
Visual Basic
Public Overrides Function Matches ( _
    item As Item _
) As Boolean
Visual C++
public:
virtual bool Matches(
    Item^ item
) override

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

The matches.

See Also

CategorizeResults..::..PathCategory Class
Sitecore.Pipelines.Search Namespace


CategorizeResults.PathCategory Properties

[image] [image]

Sitecore 6.4.1 API
CategorizeResults..::..PathCategory Properties
CategorizeResults..::..PathCategory Class See Also Send Feedback

The CategorizeResults..::..PathCategory type exposes the following members.

Properties

 | Name | Description
Public property | DisplayName | Gets or sets the display name. (Inherited from CategorizeResults..::..Category.)
Public property | Root | Gets or sets the root.

See Also

CategorizeResults..::..PathCategory Class
Sitecore.Pipelines.Search Namespace


CategorizeResults.TemplateCategory Class

[image]

Sitecore 6.4.1 API
CategorizeResults..::..TemplateCategory Class
CategorizeResults Class Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class TemplateCategory : CategorizeResults..::..Category
Visual Basic
Public Class TemplateCategory _
    Inherits CategorizeResults..::..Category
Visual C++
public ref class TemplateCategory : public CategorizeResults..::..Category

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Search..::..CategorizeResults..::..Category
Sitecore.Pipelines.Search..::..CategorizeResults..::..TemplateCategory

See Also

CategorizeResults..::..TemplateCategory Members
Sitecore.Pipelines.Search Namespace


CategorizeResults.TemplateCategory Members

[image] [image]

Sitecore 6.4.1 API
CategorizeResults..::..TemplateCategory Members
CategorizeResults..::..TemplateCategory Class Constructors Methods Properties See Also Send Feedback

Categorizes the results.
Categorizes the results.
Categorizes the results.
Categorizes the results.
Categorizes the results.

The CategorizeResults..::..TemplateCategory type exposes the following members.

Constructors

 | Name | Description
Public method | CategorizeResults..::..TemplateCategory | Initializes a new instance of the CategorizeResults..::..TemplateCategory class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetAutoDisplayName | Gets the display name of the auto. (Inherited from CategorizeResults..::..Category.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Matches | Matcheses the specified item. (Overrides CategorizeResults..::..Category..::..Matches(Item).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DisplayName | Gets or sets the display name. (Inherited from CategorizeResults..::..Category.)
Public property | TemplateIDs | Gets the template ID.

See Also

CategorizeResults..::..TemplateCategory Class
Sitecore.Pipelines.Search Namespace


CategorizeResults.TemplateCategory Constructor

[image]

Sitecore 6.4.1 API
CategorizeResults..::..TemplateCategory Constructor
CategorizeResults..::..TemplateCategory Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public TemplateCategory(
    IList<ID> templateIDs,
    string displayName
)
Visual Basic
Public Sub New ( _
    templateIDs As IList(Of ID), _
    displayName As String _
)
Visual C++
public:
TemplateCategory(
    IList<ID^>^ templateIDs,
    String^ displayName
)

Parameters

templateIDs
Type: System.Collections.Generic..::..IList <(Of <(<' ID >)>)>
The _template ID.
displayName
Type: System..::..String
The display name.

See Also

CategorizeResults..::..TemplateCategory Class
Sitecore.Pipelines.Search Namespace


CategorizeResults.TemplateCategory Methods

[image] [image]

Sitecore 6.4.1 API
CategorizeResults..::..TemplateCategory Methods
CategorizeResults..::..TemplateCategory Class See Also Send Feedback

The CategorizeResults..::..TemplateCategory type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetAutoDisplayName | Gets the display name of the auto. (Inherited from CategorizeResults..::..Category.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Matches | Matcheses the specified item. (Overrides CategorizeResults..::..Category..::..Matches(Item).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CategorizeResults..::..TemplateCategory Class
Sitecore.Pipelines.Search Namespace


Matches Method

[image]

Sitecore 6.4.1 API
CategorizeResults..::..TemplateCategory..::..Matches Method
CategorizeResults..::..TemplateCategory Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override bool Matches(
    Item item
)
Visual Basic
Public Overrides Function Matches ( _
    item As Item _
) As Boolean
Visual C++
public:
virtual bool Matches(
    Item^ item
) override

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

The matches.

See Also

CategorizeResults..::..TemplateCategory Class
Sitecore.Pipelines.Search Namespace


CategorizeResults.TemplateCategory Properties

[image] [image]

Sitecore 6.4.1 API
CategorizeResults..::..TemplateCategory Properties
CategorizeResults..::..TemplateCategory Class See Also Send Feedback

The CategorizeResults..::..TemplateCategory type exposes the following members.

Properties

 | Name | Description
Public property | DisplayName | Gets or sets the display name. (Inherited from CategorizeResults..::..Category.)
Public property | TemplateIDs | Gets the template ID.

See Also

CategorizeResults..::..TemplateCategory Class
Sitecore.Pipelines.Search Namespace


TemplateIDs Property

[image]

Sitecore 6.4.1 API
CategorizeResults..::..TemplateCategory..::..TemplateIDs Property
CategorizeResults..::..TemplateCategory Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IList<ID> TemplateIDs { get; }
Visual Basic
Public ReadOnly Property TemplateIDs As IList(Of ID)
    Get
Visual C++
public:
property IList<ID^>^ TemplateIDs {
    IList<ID^>^ get ();
}

Field Value

The template ID.

See Also

CategorizeResults..::..TemplateCategory Class
Sitecore.Pipelines.Search Namespace


DatabaseResolver Class

[image]

Sitecore 6.4.1 API
DatabaseResolver Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DatabaseResolver
Visual Basic
Public Class DatabaseResolver
Visual C++
public ref class DatabaseResolver

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Search..::..DatabaseResolver

See Also

DatabaseResolver Members
Sitecore.Pipelines.Search Namespace


DatabaseResolver Members

[image] [image]

Sitecore 6.4.1 API
DatabaseResolver Members
DatabaseResolver Class Constructors Methods See Also Send Feedback

The DatabaseResolver type exposes the following members.

Constructors

 | Name | Description
Public method | DatabaseResolver | Initializes a new instance of the DatabaseResolver class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DatabaseResolver Class
Sitecore.Pipelines.Search Namespace


DatabaseResolver Constructor

[image]

Sitecore 6.4.1 API
DatabaseResolver Constructor
DatabaseResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DatabaseResolver()
Visual Basic
Public Sub New
Visual C++
public:
DatabaseResolver()

See Also

DatabaseResolver Class
Sitecore.Pipelines.Search Namespace


Process Method

[image]

Sitecore 6.4.1 API
DatabaseResolver..::..Process Method
DatabaseResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    SearchArgs args
)
Visual Basic
Public Sub Process ( _
    args As SearchArgs _
)
Visual C++
public:
void Process(
    SearchArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Search..::..SearchArgs
The arguments.

See Also

DatabaseResolver Class
Sitecore.Pipelines.Search Namespace


IDResolver Class

[image]

Sitecore 6.4.1 API
IDResolver Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class IDResolver
Visual Basic
Public Class IDResolver
Visual C++
public ref class IDResolver

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Search..::..IDResolver

See Also

IDResolver Members
Sitecore.Pipelines.Search Namespace


IDResolver Members

[image] [image]

Sitecore 6.4.1 API
IDResolver Members
IDResolver Class Constructors Methods See Also Send Feedback

The IDResolver type exposes the following members.

Constructors

 | Name | Description
Public method | IDResolver | Initializes a new instance of the IDResolver class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IDResolver Class
Sitecore.Pipelines.Search Namespace


IDResolver Constructor

[image]

Sitecore 6.4.1 API
IDResolver Constructor
IDResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IDResolver()
Visual Basic
Public Sub New
Visual C++
public:
IDResolver()

See Also

IDResolver Class
Sitecore.Pipelines.Search Namespace


IDResolver Methods

[image] [image]

Sitecore 6.4.1 API
IDResolver Methods
IDResolver Class See Also Send Feedback

The IDResolver type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IDResolver Class
Sitecore.Pipelines.Search Namespace


Process Method

[image]

Sitecore 6.4.1 API
IDResolver..::..Process Method
IDResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    SearchArgs args
)
Visual Basic
Public Sub Process ( _
    args As SearchArgs _
)
Visual C++
public:
void Process(
    SearchArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Search..::..SearchArgs
The arguments.

See Also

IDResolver Class
Sitecore.Pipelines.Search Namespace


PathResolver Class

[image]

Sitecore 6.4.1 API
PathResolver Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PathResolver
Visual Basic
Public Class PathResolver
Visual C++
public ref class PathResolver

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Search..::..PathResolver

See Also

PathResolver Members
Sitecore.Pipelines.Search Namespace


PathResolver Members

[image] [image]

Sitecore 6.4.1 API
PathResolver Members
PathResolver Class Constructors Methods See Also Send Feedback

The PathResolver type exposes the following members.

Constructors

 | Name | Description
Public method | PathResolver | Initializes a new instance of the PathResolver class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PathResolver Class
Sitecore.Pipelines.Search Namespace


PathResolver Constructor

[image]

Sitecore 6.4.1 API
PathResolver Constructor
PathResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PathResolver()
Visual Basic
Public Sub New
Visual C++
public:
PathResolver()

See Also

PathResolver Class
Sitecore.Pipelines.Search Namespace


PathResolver Methods

[image] [image]

Sitecore 6.4.1 API
PathResolver Methods
PathResolver Class See Also Send Feedback

The PathResolver type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PathResolver Class
Sitecore.Pipelines.Search Namespace


Process Method

[image]

Sitecore 6.4.1 API
PathResolver..::..Process Method
PathResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    SearchArgs args
)
Visual Basic
Public Sub Process ( _
    args As SearchArgs _
)
Visual C++
public:
void Process(
    SearchArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Search..::..SearchArgs
The arguments.

See Also

PathResolver Class
Sitecore.Pipelines.Search Namespace


SearchArgs Members

[image] [image]

Sitecore 6.4.1 API
SearchArgs Members
SearchArgs Class Constructors Methods Properties See Also Send Feedback

The SearchArgs type exposes the following members.

Constructors

 | Name | Description
Public method | SearchArgs(String) | Initializes a new instance of the SearchArgs class.
Public method | SearchArgs(QueryBase) | Initializes a new instance of the SearchArgs class.
Protected method | SearchArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the SearchArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Database | Gets or sets the database.
Public property | Limit | Gets or sets the limit.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Query | Gets or sets the query.
Public property | Result | Gets or sets the results.
Public property | Root | Gets or sets the root.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
Public property | TextQuery | Gets or sets the query.
Public property | Type | Gets or sets the type.

See Also

SearchArgs Class
Sitecore.Pipelines.Search Namespace


SearchArgs Constructor

[image] [image]

Sitecore 6.4.1 API
SearchArgs Constructor
SearchArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SearchArgs(String) | Initializes a new instance of the SearchArgs class.
Public method | SearchArgs(QueryBase) | Initializes a new instance of the SearchArgs class.
Protected method | SearchArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the SearchArgs class.

See Also

SearchArgs Class
SearchArgs Members
Sitecore.Pipelines.Search Namespace


SearchArgs Constructor (String)

[image]

Sitecore 6.4.1 API
SearchArgs Constructor (String)
SearchArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SearchArgs(
    string query
)
Visual Basic
Public Sub New ( _
    query As String _
)
Visual C++
public:
SearchArgs(
    String^ query
)

Parameters

query
Type: System..::..String
The query.

See Also

SearchArgs Class
SearchArgs Overload
Sitecore.Pipelines.Search Namespace


SearchArgs Constructor (QueryBase)

[image]

Sitecore 6.4.1 API
SearchArgs Constructor (QueryBase)
SearchArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SearchArgs(
    QueryBase query
)
Visual Basic
Public Sub New ( _
    query As QueryBase _
)
Visual C++
public:
SearchArgs(
    QueryBase^ query
)

Parameters

query
Type: Sitecore.Search..::..QueryBase
The query.

See Also

SearchArgs Class
SearchArgs Overload
Sitecore.Pipelines.Search Namespace


SearchArgs Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
SearchArgs Constructor (SerializationInfo, StreamingContext)
SearchArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected SearchArgs(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
SearchArgs(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

SearchArgs Class
SearchArgs Overload
Sitecore.Pipelines.Search Namespace


SearchArgs Methods

[image] [image]

Sitecore 6.4.1 API
SearchArgs Methods
SearchArgs Class See Also Send Feedback

The SearchArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SearchArgs Class
Sitecore.Pipelines.Search Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
SearchArgs..::..AddMessage Method
SearchArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

SearchArgs Class
SearchArgs Members
Sitecore.Pipelines.Search Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
SearchArgs..::..GetMessages Method
SearchArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

SearchArgs Class
SearchArgs Members
Sitecore.Pipelines.Search Namespace


GetObjectData Method

[image]

Sitecore 6.4.1 API
SearchArgs..::..GetObjectData Method
SearchArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System.Security..::..SecurityException | The caller does not have the required permission.

See Also

SearchArgs Class
Sitecore.Pipelines.Search Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
SearchArgs..::..Suspend Method
SearchArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

SearchArgs Class
SearchArgs Members
Sitecore.Pipelines.Search Namespace


SearchArgs Properties

[image] [image]

Sitecore 6.4.1 API
SearchArgs Properties
SearchArgs Class See Also Send Feedback

The SearchArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Database | Gets or sets the database.
Public property | Limit | Gets or sets the limit.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Query | Gets or sets the query.
Public property | Result | Gets or sets the results.
Public property | Root | Gets or sets the root.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
Public property | TextQuery | Gets or sets the query.
Public property | Type | Gets or sets the type.

See Also

SearchArgs Class
Sitecore.Pipelines.Search Namespace


Database Property

[image]

Sitecore 6.4.1 API
SearchArgs..::..Database Property
SearchArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database Database { get; set; }
Visual Basic
Public Property Database As Database
    Get
    Set
Visual C++
public:
property Database^ Database {
    Database^ get ();
    void set (Database^ value);
}

Field Value

The database.

See Also

SearchArgs Class
Sitecore.Pipelines.Search Namespace


Limit Property

[image]

Sitecore 6.4.1 API
SearchArgs..::..Limit Property
SearchArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Limit { get; set; }
Visual Basic
Public Property Limit As Integer
    Get
    Set
Visual C++
public:
property int Limit {
    int get ();
    void set (int value);
}

Field Value

The limit.

See Also

SearchArgs Class
Sitecore.Pipelines.Search Namespace


Query Property

[image]

Sitecore 6.4.1 API
SearchArgs..::..Query Property
SearchArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public QueryBase Query { get; set; }
Visual Basic
Public Property Query As QueryBase
    Get
    Set
Visual C++
public:
property QueryBase^ Query {
    QueryBase^ get ();
    void set (QueryBase^ value);
}

Field Value

The query.

See Also

SearchArgs Class
Sitecore.Pipelines.Search Namespace


Result Property

[image]

Sitecore 6.4.1 API
SearchArgs..::..Result Property
SearchArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SearchResultCollection Result { get; set; }
Visual Basic
Public Property Result As SearchResultCollection
    Get
    Set
Visual C++
public:
property SearchResultCollection^ Result {
    SearchResultCollection^ get ();
    void set (SearchResultCollection^ value);
}

Field Value

The results.

See Also

SearchArgs Class
Sitecore.Pipelines.Search Namespace


Root Property

[image]

Sitecore 6.4.1 API
SearchArgs..::..Root Property
SearchArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Root { get; set; }
Visual Basic
Public Property Root As Item
    Get
    Set
Visual C++
public:
property Item^ Root {
    Item^ get ();
    void set (Item^ value);
}

Field Value

The root.

See Also

SearchArgs Class
Sitecore.Pipelines.Search Namespace


Type Property

[image]

Sitecore 6.4.1 API
SearchArgs..::..Type Property
SearchArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SearchType Type { get; set; }
Visual Basic
Public Property Type As SearchType
    Get
    Set
Visual C++
public:
property SearchType Type {
    SearchType get ();
    void set (SearchType value);
}

Field Value

The type.

See Also

SearchArgs Class
Sitecore.Pipelines.Search Namespace


SearchSystemIndex Class

[image]

Sitecore 6.4.1 API
SearchSystemIndex Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SearchSystemIndex
Visual Basic
Public Class SearchSystemIndex
Visual C++
public ref class SearchSystemIndex

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Search..::..SearchSystemIndex

See Also

SearchSystemIndex Members
Sitecore.Pipelines.Search Namespace


SearchSystemIndex Members

[image] [image]

Sitecore 6.4.1 API
SearchSystemIndex Members
SearchSystemIndex Class Constructors Methods See Also Send Feedback

The SearchSystemIndex type exposes the following members.

Constructors

 | Name | Description
Public method | SearchSystemIndex | Initializes a new instance of the SearchSystemIndex class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SearchSystemIndex Class
Sitecore.Pipelines.Search Namespace


SearchSystemIndex Constructor

[image]

Sitecore 6.4.1 API
SearchSystemIndex Constructor
SearchSystemIndex Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SearchSystemIndex()
Visual Basic
Public Sub New
Visual C++
public:
SearchSystemIndex()

See Also

SearchSystemIndex Class
Sitecore.Pipelines.Search Namespace


SearchSystemIndex Methods

[image] [image]

Sitecore 6.4.1 API
SearchSystemIndex Methods
SearchSystemIndex Class See Also Send Feedback

The SearchSystemIndex type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SearchSystemIndex Class
Sitecore.Pipelines.Search Namespace


Process Method

[image]

Sitecore 6.4.1 API
SearchSystemIndex..::..Process Method
SearchSystemIndex Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    SearchArgs args
)
Visual Basic
Public Sub Process ( _
    args As SearchArgs _
)
Visual C++
public:
void Process(
    SearchArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Search..::..SearchArgs
The arguments.

See Also

SearchSystemIndex Class
Sitecore.Pipelines.Search Namespace


SecurityResolver Class

[image]

Sitecore 6.4.1 API
SecurityResolver Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SecurityResolver
Visual Basic
Public Class SecurityResolver
Visual C++
public ref class SecurityResolver

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Search..::..SecurityResolver

See Also

SecurityResolver Members
Sitecore.Pipelines.Search Namespace


SecurityResolver Members

[image] [image]

Sitecore 6.4.1 API
SecurityResolver Members
SecurityResolver Class Constructors Methods See Also Send Feedback

The SecurityResolver type exposes the following members.

Constructors

 | Name | Description
Public method | SecurityResolver | Initializes a new instance of the SecurityResolver class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SecurityResolver Class
Sitecore.Pipelines.Search Namespace


SecurityResolver Constructor

[image]

Sitecore 6.4.1 API
SecurityResolver Constructor
SecurityResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SecurityResolver()
Visual Basic
Public Sub New
Visual C++
public:
SecurityResolver()

See Also

SecurityResolver Class
Sitecore.Pipelines.Search Namespace


SecurityResolver Methods

[image] [image]

Sitecore 6.4.1 API
SecurityResolver Methods
SecurityResolver Class See Also Send Feedback

The SecurityResolver type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SecurityResolver Class
Sitecore.Pipelines.Search Namespace


UrlResolver Class

[image]

Sitecore 6.4.1 API
UrlResolver Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class UrlResolver
Visual Basic
Public Class UrlResolver
Visual C++
public ref class UrlResolver

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Search..::..UrlResolver

See Also

UrlResolver Members
Sitecore.Pipelines.Search Namespace


UrlResolver Members

[image] [image]

Sitecore 6.4.1 API
UrlResolver Members
UrlResolver Class Constructors Methods See Also Send Feedback

The UrlResolver type exposes the following members.

Constructors

 | Name | Description
Public method | UrlResolver | Initializes a new instance of the UrlResolver class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UrlResolver Class
Sitecore.Pipelines.Search Namespace


UrlResolver Constructor

[image]

Sitecore 6.4.1 API
UrlResolver Constructor
UrlResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UrlResolver()
Visual Basic
Public Sub New
Visual C++
public:
UrlResolver()

See Also

UrlResolver Class
Sitecore.Pipelines.Search Namespace


UrlResolver Methods

[image] [image]

Sitecore 6.4.1 API
UrlResolver Methods
UrlResolver Class See Also Send Feedback

The UrlResolver type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UrlResolver Class
Sitecore.Pipelines.Search Namespace


Process Method

[image]

Sitecore 6.4.1 API
UrlResolver..::..Process Method
UrlResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Search
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    SearchArgs args
)
Visual Basic
Public Sub Process ( _
    args As SearchArgs _
)
Visual C++
public:
void Process(
    SearchArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Search..::..SearchArgs
The arguments.

See Also

UrlResolver Class
Sitecore.Pipelines.Search Namespace


Sitecore.Pipelines.SessionEnd Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.SessionEnd Namespace
Send Feedback

Classes

 | Class | Description
Public class | SaveRecentDocuments | Saves the recent documents.
Public class | SessionEndArgs | Argument class for Session End pipeline.


SaveRecentDocuments Class

[image]

Sitecore 6.4.1 API
SaveRecentDocuments Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.SessionEnd
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class SaveRecentDocuments
Visual Basic
Public Class SaveRecentDocuments
Visual C++
public ref class SaveRecentDocuments

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.SessionEnd..::..SaveRecentDocuments

See Also

SaveRecentDocuments Members
Sitecore.Pipelines.SessionEnd Namespace


SaveRecentDocuments Constructor

[image]

Sitecore 6.4.1 API
SaveRecentDocuments Constructor
SaveRecentDocuments Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SessionEnd
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SaveRecentDocuments()
Visual Basic
Public Sub New
Visual C++
public:
SaveRecentDocuments()

See Also

SaveRecentDocuments Class
Sitecore.Pipelines.SessionEnd Namespace


SaveRecentDocuments Methods

[image] [image]

Sitecore 6.4.1 API
SaveRecentDocuments Methods
SaveRecentDocuments Class See Also Send Feedback

The SaveRecentDocuments type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SaveRecentDocuments Class
Sitecore.Pipelines.SessionEnd Namespace


Process Method

[image]

Sitecore 6.4.1 API
SaveRecentDocuments..::..Process Method
SaveRecentDocuments Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SessionEnd
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    SessionEndArgs endArgs
)
Visual Basic
Public Sub Process ( _
    endArgs As SessionEndArgs _
)
Visual C++
public:
void Process(
    SessionEndArgs^ endArgs
)

Parameters

endArgs
Type: Sitecore.Pipelines.SessionEnd..::..SessionEndArgs
The end args.

See Also

SaveRecentDocuments Class
Sitecore.Pipelines.SessionEnd Namespace


SessionEndArgs Class

[image]

Sitecore 6.4.1 API
SessionEndArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.SessionEnd
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class SessionEndArgs : PipelineArgs
Visual Basic
<SerializableAttribute> _
Public Class SessionEndArgs _
    Inherits PipelineArgs
Visual C++
[SerializableAttribute]
public ref class SessionEndArgs : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Pipelines.SessionEnd..::..SessionEndArgs

See Also

SessionEndArgs Members
Sitecore.Pipelines.SessionEnd Namespace


SessionEndArgs Members

[image] [image]

Sitecore 6.4.1 API
SessionEndArgs Members
SessionEndArgs Class Constructors Methods Properties See Also Send Feedback

The SessionEndArgs type exposes the following members.

Constructors

 | Name | Description
Public method | SessionEndArgs(HttpContext) | Initializes a new instance of the SessionEndArgs class.
Protected method | SessionEndArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the SessionEndArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | Context | Gets the context.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

SessionEndArgs Class
Sitecore.Pipelines.SessionEnd Namespace


SessionEndArgs Constructor

[image] [image]

Sitecore 6.4.1 API
SessionEndArgs Constructor
SessionEndArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SessionEndArgs(HttpContext) | Initializes a new instance of the SessionEndArgs class.
Protected method | SessionEndArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the SessionEndArgs class.

See Also

SessionEndArgs Class
SessionEndArgs Members
Sitecore.Pipelines.SessionEnd Namespace


SessionEndArgs Constructor (HttpContext)

[image]

Sitecore 6.4.1 API
SessionEndArgs Constructor (HttpContext)
SessionEndArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SessionEnd
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SessionEndArgs(
    HttpContext context
)
Visual Basic
Public Sub New ( _
    context As HttpContext _
)
Visual C++
public:
SessionEndArgs(
    HttpContext^ context
)

Parameters

context
Type: System.Web..::..HttpContext
The context.

See Also

SessionEndArgs Class
SessionEndArgs Overload
Sitecore.Pipelines.SessionEnd Namespace


SessionEndArgs Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
SessionEndArgs Constructor (SerializationInfo, StreamingContext)
SessionEndArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SessionEnd
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected SessionEndArgs(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
SessionEndArgs(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

SessionEndArgs Class
SessionEndArgs Overload
Sitecore.Pipelines.SessionEnd Namespace


SessionEndArgs Methods

[image] [image]

Sitecore 6.4.1 API
SessionEndArgs Methods
SessionEndArgs Class See Also Send Feedback

The SessionEndArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SessionEndArgs Class
Sitecore.Pipelines.SessionEnd Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
SessionEndArgs..::..AddMessage Method
SessionEndArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

SessionEndArgs Class
SessionEndArgs Members
Sitecore.Pipelines.SessionEnd Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
SessionEndArgs..::..GetMessages Method
SessionEndArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

SessionEndArgs Class
SessionEndArgs Members
Sitecore.Pipelines.SessionEnd Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
SessionEndArgs..::..Suspend Method
SessionEndArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

SessionEndArgs Class
SessionEndArgs Members
Sitecore.Pipelines.SessionEnd Namespace


SessionEndArgs Properties

[image] [image]

Sitecore 6.4.1 API
SessionEndArgs Properties
SessionEndArgs Class See Also Send Feedback

The SessionEndArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | Context | Gets the context.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

SessionEndArgs Class
Sitecore.Pipelines.SessionEnd Namespace


Context Property

[image]

Sitecore 6.4.1 API
SessionEndArgs..::..Context Property
SessionEndArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SessionEnd
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HttpContext Context { get; }
Visual Basic
Public ReadOnly Property Context As HttpContext
    Get
Visual C++
public:
property HttpContext^ Context {
    HttpContext^ get ();
}

Field Value

The context.

See Also

SessionEndArgs Class
Sitecore.Pipelines.SessionEnd Namespace


Sitecore.Pipelines.SetupEditFrame Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.SetupEditFrame Namespace
Send Feedback

Classes

 | Class | Description
Public class | GetButtonRoot | Obsolete. Defines the get button root class.
Public class | GetFrameParameters | Obsolete. Defines the get button root class.
Public class | SetupEditFrameArgs | Obsolete. Defines the render edit frame menu item args class.


GetButtonRoot Class

[image]

Sitecore 6.4.1 API
GetButtonRoot Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.SetupEditFrame
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute]
public class GetButtonRoot
Visual Basic
<ObsoleteAttribute> _
Public Class GetButtonRoot
Visual C++
[ObsoleteAttribute]
public ref class GetButtonRoot

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.SetupEditFrame..::..GetButtonRoot

See Also

GetButtonRoot Members
Sitecore.Pipelines.SetupEditFrame Namespace


GetButtonRoot Members

[image] [image]

Sitecore 6.4.1 API
GetButtonRoot Members
GetButtonRoot Class Constructors Methods See Also Send Feedback

The GetButtonRoot type exposes the following members.

Constructors

 | Name | Description
Public method | GetButtonRoot | Initializes a new instance of the GetButtonRoot class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetButtonRoot Class
Sitecore.Pipelines.SetupEditFrame Namespace


GetButtonRoot Constructor

[image]

Sitecore 6.4.1 API
GetButtonRoot Constructor
GetButtonRoot Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SetupEditFrame
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetButtonRoot()
Visual Basic
Public Sub New
Visual C++
public:
GetButtonRoot()

See Also

GetButtonRoot Class
Sitecore.Pipelines.SetupEditFrame Namespace


GetButtonRoot Methods

[image] [image]

Sitecore 6.4.1 API
GetButtonRoot Methods
GetButtonRoot Class See Also Send Feedback

The GetButtonRoot type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetButtonRoot Class
Sitecore.Pipelines.SetupEditFrame Namespace


Process Method

[image]

Sitecore 6.4.1 API
GetButtonRoot..::..Process Method
GetButtonRoot Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SetupEditFrame
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    SetupEditFrameArgs args
)
Visual Basic
Public Sub Process ( _
    args As SetupEditFrameArgs _
)
Visual C++
public:
void Process(
    SetupEditFrameArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.SetupEditFrame..::..SetupEditFrameArgs
The arguments.

See Also

GetButtonRoot Class
Sitecore.Pipelines.SetupEditFrame Namespace


GetFrameParameters Class

[image]

Sitecore 6.4.1 API
GetFrameParameters Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.SetupEditFrame
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute]
public class GetFrameParameters
Visual Basic
<ObsoleteAttribute> _
Public Class GetFrameParameters
Visual C++
[ObsoleteAttribute]
public ref class GetFrameParameters

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.SetupEditFrame..::..GetFrameParameters

See Also

GetFrameParameters Members
Sitecore.Pipelines.SetupEditFrame Namespace


GetFrameParameters Members

[image] [image]

Sitecore 6.4.1 API
GetFrameParameters Members
GetFrameParameters Class Constructors Methods See Also Send Feedback

The GetFrameParameters type exposes the following members.

Constructors

 | Name | Description
Public method | GetFrameParameters | Initializes a new instance of the GetFrameParameters class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetFrameParameters Class
Sitecore.Pipelines.SetupEditFrame Namespace


GetFrameParameters Constructor

[image]

Sitecore 6.4.1 API
GetFrameParameters Constructor
GetFrameParameters Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SetupEditFrame
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetFrameParameters()
Visual Basic
Public Sub New
Visual C++
public:
GetFrameParameters()

See Also

GetFrameParameters Class
Sitecore.Pipelines.SetupEditFrame Namespace


GetFrameParameters Methods

[image] [image]

Sitecore 6.4.1 API
GetFrameParameters Methods
GetFrameParameters Class See Also Send Feedback

The GetFrameParameters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetFrameParameters Class
Sitecore.Pipelines.SetupEditFrame Namespace


Process Method

[image]

Sitecore 6.4.1 API
GetFrameParameters..::..Process Method
GetFrameParameters Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SetupEditFrame
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    SetupEditFrameArgs args
)
Visual Basic
Public Sub Process ( _
    args As SetupEditFrameArgs _
)
Visual C++
public:
void Process(
    SetupEditFrameArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.SetupEditFrame..::..SetupEditFrameArgs
The arguments.

See Also

GetFrameParameters Class
Sitecore.Pipelines.SetupEditFrame Namespace


SetupEditFrameArgs Class

[image]

Sitecore 6.4.1 API
SetupEditFrameArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.SetupEditFrame
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute]
public class SetupEditFrameArgs : PipelineArgs
Visual Basic
<ObsoleteAttribute> _
Public Class SetupEditFrameArgs _
    Inherits PipelineArgs
Visual C++
[ObsoleteAttribute]
public ref class SetupEditFrameArgs : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Pipelines.SetupEditFrame..::..SetupEditFrameArgs

See Also

SetupEditFrameArgs Members
Sitecore.Pipelines.SetupEditFrame Namespace


SetupEditFrameArgs Members

[image] [image]

Sitecore 6.4.1 API
SetupEditFrameArgs Members
SetupEditFrameArgs Class Constructors Methods Properties See Also Send Feedback

The SetupEditFrameArgs type exposes the following members.

Constructors

 | Name | Description
Public method | SetupEditFrameArgs | Initializes a new instance of the SetupEditFrameArgs class

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | ButtonRoot | Gets or sets the button root.
Public property | ButtonsPath | Gets or sets the buttons path.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | MenuItems | Gets or sets the menu items.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
Public property | Title | Gets or sets the title.
Public property | ToolTip | Gets or sets the tooltip.

See Also

SetupEditFrameArgs Class
Sitecore.Pipelines.SetupEditFrame Namespace


SetupEditFrameArgs Constructor

[image]

Sitecore 6.4.1 API
SetupEditFrameArgs Constructor
SetupEditFrameArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SetupEditFrame
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SetupEditFrameArgs()
Visual Basic
Public Sub New
Visual C++
public:
SetupEditFrameArgs()

See Also

SetupEditFrameArgs Class
Sitecore.Pipelines.SetupEditFrame Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
SetupEditFrameArgs..::..AddMessage Method
SetupEditFrameArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

SetupEditFrameArgs Class
SetupEditFrameArgs Members
Sitecore.Pipelines.SetupEditFrame Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
SetupEditFrameArgs..::..GetMessages Method
SetupEditFrameArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

SetupEditFrameArgs Class
SetupEditFrameArgs Members
Sitecore.Pipelines.SetupEditFrame Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
SetupEditFrameArgs..::..Suspend Method
SetupEditFrameArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

SetupEditFrameArgs Class
SetupEditFrameArgs Members
Sitecore.Pipelines.SetupEditFrame Namespace


SetupEditFrameArgs Properties

[image] [image]

Sitecore 6.4.1 API
SetupEditFrameArgs Properties
SetupEditFrameArgs Class See Also Send Feedback

The SetupEditFrameArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | ButtonRoot | Gets or sets the button root.
Public property | ButtonsPath | Gets or sets the buttons path.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | MenuItems | Gets or sets the menu items.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
Public property | Title | Gets or sets the title.
Public property | ToolTip | Gets or sets the tooltip.

See Also

SetupEditFrameArgs Class
Sitecore.Pipelines.SetupEditFrame Namespace


ButtonRoot Property

[image]

Sitecore 6.4.1 API
SetupEditFrameArgs..::..ButtonRoot Property
SetupEditFrameArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SetupEditFrame
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item ButtonRoot { get; set; }
Visual Basic
Public Property ButtonRoot As Item
    Get
    Set
Visual C++
public:
property Item^ ButtonRoot {
    Item^ get ();
    void set (Item^ value);
}

Field Value

The button root.

See Also

SetupEditFrameArgs Class
Sitecore.Pipelines.SetupEditFrame Namespace


ButtonsPath Property

[image]

Sitecore 6.4.1 API
SetupEditFrameArgs..::..ButtonsPath Property
SetupEditFrameArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SetupEditFrame
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ButtonsPath { get; set; }
Visual Basic
Public Property ButtonsPath As String
    Get
    Set
Visual C++
public:
property String^ ButtonsPath {
    String^ get ();
    void set (String^ value);
}

Field Value

The buttons path.

See Also

SetupEditFrameArgs Class
Sitecore.Pipelines.SetupEditFrame Namespace


MenuItems Property

[image]

Sitecore 6.4.1 API
SetupEditFrameArgs..::..MenuItems Property
SetupEditFrameArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SetupEditFrame
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ICollection<IEditFrameMenuItem> MenuItems { get; }
Visual Basic
Public ReadOnly Property MenuItems As ICollection(Of IEditFrameMenuItem)
    Get
Visual C++
public:
property ICollection<IEditFrameMenuItem^>^ MenuItems {
    ICollection<IEditFrameMenuItem^>^ get ();
}

Field Value

The menu items.

See Also

SetupEditFrameArgs Class
Sitecore.Pipelines.SetupEditFrame Namespace


Title Property

[image]

Sitecore 6.4.1 API
SetupEditFrameArgs..::..Title Property
SetupEditFrameArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SetupEditFrame
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Title { get; set; }
Visual Basic
Public Property Title As String
    Get
    Set
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

Field Value

The title.

See Also

SetupEditFrameArgs Class
Sitecore.Pipelines.SetupEditFrame Namespace


ToolTip Property

[image]

Sitecore 6.4.1 API
SetupEditFrameArgs..::..ToolTip Property
SetupEditFrameArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.SetupEditFrame
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ToolTip { get; set; }
Visual Basic
Public Property ToolTip As String
    Get
    Set
Visual C++
public:
property String^ ToolTip {
    String^ get ();
    void set (String^ value);
}

Field Value

The tooltip.

See Also

SetupEditFrameArgs Class
Sitecore.Pipelines.SetupEditFrame Namespace


Sitecore.Pipelines.Shutdown Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.Shutdown Namespace
Send Feedback

Classes

 | Class | Description
Public class | ShowReason | Show the reason for shutdown.


ShowReason Class

[image]

Sitecore 6.4.1 API
ShowReason Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Shutdown
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ShowReason
Visual Basic
Public Class ShowReason
Visual C++
public ref class ShowReason

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Shutdown..::..ShowReason

See Also

ShowReason Members
Sitecore.Pipelines.Shutdown Namespace


ShowReason Members

[image] [image]

Sitecore 6.4.1 API
ShowReason Members
ShowReason Class Constructors Methods See Also Send Feedback

The ShowReason type exposes the following members.

Constructors

 | Name | Description
Public method | ShowReason | Initializes a new instance of the ShowReason class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShowReason Class
Sitecore.Pipelines.Shutdown Namespace


ShowReason Constructor

[image]

Sitecore 6.4.1 API
ShowReason Constructor
ShowReason Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Shutdown
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ShowReason()
Visual Basic
Public Sub New
Visual C++
public:
ShowReason()

See Also

ShowReason Class
Sitecore.Pipelines.Shutdown Namespace


ShowReason Methods

[image] [image]

Sitecore 6.4.1 API
ShowReason Methods
ShowReason Class See Also Send Feedback

The ShowReason type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShowReason Class
Sitecore.Pipelines.Shutdown Namespace


Process Method

[image]

Sitecore 6.4.1 API
ShowReason..::..Process Method
ShowReason Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Shutdown
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    PipelineArgs args
)
Visual Basic
Public Sub Process ( _
    args As PipelineArgs _
)
Visual C++
public:
void Process(
    PipelineArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines..::..PipelineArgs
The args.

See Also

ShowReason Class
Sitecore.Pipelines.Shutdown Namespace


Sitecore.Pipelines.Upload Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.Upload Namespace
Send Feedback

Classes

 | Class | Description
Public class | CheckSize | Resolves the folder.
Public class | Done | Upload has finished.
Public class | ResolveFolder | Resolves the folder.
Public class | Save | Saves the uploaded files.
Public class | Unzip | Obsolete. Unzips the files.
Public class | UploadArgs | Argument class for the Upload pipeline.
Public class | UploadProcessor | Represents a UploadProcessor.

Enumerations

 | Enumeration | Description
Public enumeration | UploadDestination | Specifies the destination for the upload operation.


CheckSize Class

[image]

Sitecore 6.4.1 API
CheckSize Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CheckSize : UploadProcessor
Visual Basic
Public Class CheckSize _
    Inherits UploadProcessor
Visual C++
public ref class CheckSize : public UploadProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Upload..::..UploadProcessor
Sitecore.Pipelines.Upload..::..CheckSize

See Also

CheckSize Members
Sitecore.Pipelines.Upload Namespace


CheckSize Members

[image] [image]

Sitecore 6.4.1 API
CheckSize Members
CheckSize Class Constructors Methods See Also Send Feedback

The CheckSize type exposes the following members.

Constructors

 | Name | Description
Public method | CheckSize | Initializes a new instance of the CheckSize class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckSize Class
Sitecore.Pipelines.Upload Namespace


CheckSize Constructor

[image]

Sitecore 6.4.1 API
CheckSize Constructor
CheckSize Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CheckSize()
Visual Basic
Public Sub New
Visual C++
public:
CheckSize()

See Also

CheckSize Class
Sitecore.Pipelines.Upload Namespace


CheckSize Methods

[image] [image]

Sitecore 6.4.1 API
CheckSize Methods
CheckSize Class See Also Send Feedback

The CheckSize type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckSize Class
Sitecore.Pipelines.Upload Namespace


Process Method

[image]

Sitecore 6.4.1 API
CheckSize..::..Process Method
CheckSize Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    UploadArgs args
)
Visual Basic
Public Sub Process ( _
    args As UploadArgs _
)
Visual C++
public:
void Process(
    UploadArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Upload..::..UploadArgs
The arguments.

See Also

CheckSize Class
Sitecore.Pipelines.Upload Namespace


Done Class

[image]

Sitecore 6.4.1 API
Done Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Done
Visual Basic
Public Class Done
Visual C++
public ref class Done

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Upload..::..Done

See Also

Done Members
Sitecore.Pipelines.Upload Namespace


Done Members

[image] [image]

Sitecore 6.4.1 API
Done Members
Done Class Constructors Methods See Also Send Feedback

The Done type exposes the following members.

Constructors

 | Name | Description
Public method | Done | Initializes a new instance of the Done class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Done Class
Sitecore.Pipelines.Upload Namespace


Done Constructor

[image]

Sitecore 6.4.1 API
Done Constructor
Done Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Done()
Visual Basic
Public Sub New
Visual C++
public:
Done()

See Also

Done Class
Sitecore.Pipelines.Upload Namespace


Process Method

[image]

Sitecore 6.4.1 API
Done..::..Process Method
Done Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    UploadArgs args
)
Visual Basic
Public Sub Process ( _
    args As UploadArgs _
)
Visual C++
public:
void Process(
    UploadArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Upload..::..UploadArgs
The arguments.

See Also

Done Class
Sitecore.Pipelines.Upload Namespace


ResolveFolder Class

[image]

Sitecore 6.4.1 API
ResolveFolder Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ResolveFolder
Visual Basic
Public Class ResolveFolder
Visual C++
public ref class ResolveFolder

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Upload..::..ResolveFolder

See Also

ResolveFolder Members
Sitecore.Pipelines.Upload Namespace


ResolveFolder Members

[image] [image]

Sitecore 6.4.1 API
ResolveFolder Members
ResolveFolder Class Constructors Methods See Also Send Feedback

The ResolveFolder type exposes the following members.

Constructors

 | Name | Description
Public method | ResolveFolder | Initializes a new instance of the ResolveFolder class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ResolveFolder Class
Sitecore.Pipelines.Upload Namespace


ResolveFolder Constructor

[image]

Sitecore 6.4.1 API
ResolveFolder Constructor
ResolveFolder Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ResolveFolder()
Visual Basic
Public Sub New
Visual C++
public:
ResolveFolder()

See Also

ResolveFolder Class
Sitecore.Pipelines.Upload Namespace


ResolveFolder Methods

[image] [image]

Sitecore 6.4.1 API
ResolveFolder Methods
ResolveFolder Class See Also Send Feedback

The ResolveFolder type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ResolveFolder Class
Sitecore.Pipelines.Upload Namespace


Process Method

[image]

Sitecore 6.4.1 API
ResolveFolder..::..Process Method
ResolveFolder Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    UploadArgs args
)
Visual Basic
Public Sub Process ( _
    args As UploadArgs _
)
Visual C++
public:
void Process(
    UploadArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Upload..::..UploadArgs
The arguments.

See Also

ResolveFolder Class
Sitecore.Pipelines.Upload Namespace


Save Class

[image]

Sitecore 6.4.1 API
Save Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Save : UploadProcessor
Visual Basic
Public Class Save _
    Inherits UploadProcessor
Visual C++
public ref class Save : public UploadProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Upload..::..UploadProcessor
Sitecore.Pipelines.Upload..::..Save

See Also

Save Members
Sitecore.Pipelines.Upload Namespace


Save Members

[image] [image]

Sitecore 6.4.1 API
Save Members
Save Class Constructors Methods See Also Send Feedback

The Save type exposes the following members.

Constructors

 | Name | Description
Public method | Save | Initializes a new instance of the Save class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Save Class
Sitecore.Pipelines.Upload Namespace


Save Constructor

[image]

Sitecore 6.4.1 API
Save Constructor
Save Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Save()
Visual Basic
Public Sub New
Visual C++
public:
Save()

See Also

Save Class
Sitecore.Pipelines.Upload Namespace


Save Methods

[image] [image]

Sitecore 6.4.1 API
Save Methods
Save Class See Also Send Feedback

The Save type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Save Class
Sitecore.Pipelines.Upload Namespace


Process Method

[image]

Sitecore 6.4.1 API
Save..::..Process Method
Save Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    UploadArgs args
)
Visual Basic
Public Sub Process ( _
    args As UploadArgs _
)
Visual C++
public:
void Process(
    UploadArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Upload..::..UploadArgs
The arguments.

Exceptions

Exception | Condition
System..::..Exception | Exception.

See Also

Save Class
Sitecore.Pipelines.Upload Namespace


Unzip Class

[image]

Sitecore 6.4.1 API
Unzip Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated. Unpacking is handled by the save processor")]
public class Unzip
Visual Basic
<ObsoleteAttribute("Deprecated. Unpacking is handled by the save processor")> _
Public Class Unzip
Visual C++
[ObsoleteAttribute(L"Deprecated. Unpacking is handled by the save processor")]
public ref class Unzip

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Upload..::..Unzip

See Also

Unzip Members
Sitecore.Pipelines.Upload Namespace


Unzip Members

[image] [image]

Sitecore 6.4.1 API
Unzip Members
Unzip Class Constructors Methods See Also Send Feedback

The Unzip type exposes the following members.

Constructors

 | Name | Description
Public method | Unzip | Initializes a new instance of the Unzip class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UnzipFiles | Unzips the files.
Public method | UnZipMediaItem | Unzips a media item.

See Also

Unzip Class
Sitecore.Pipelines.Upload Namespace


Unzip Constructor

[image]

Sitecore 6.4.1 API
Unzip Constructor
Unzip Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Unzip()
Visual Basic
Public Sub New
Visual C++
public:
Unzip()

See Also

Unzip Class
Sitecore.Pipelines.Upload Namespace


Unzip Methods

[image] [image]

Sitecore 6.4.1 API
Unzip Methods
Unzip Class See Also Send Feedback

The Unzip type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UnzipFiles | Unzips the files.
Public method | UnZipMediaItem | Unzips a media item.

See Also

Unzip Class
Sitecore.Pipelines.Upload Namespace


Process Method

[image]

Sitecore 6.4.1 API
Unzip..::..Process Method
Unzip Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    UploadArgs args
)
Visual Basic
Public Sub Process ( _
    args As UploadArgs _
)
Visual C++
public:
void Process(
    UploadArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.Upload..::..UploadArgs
The arguments.

See Also

Unzip Class
Sitecore.Pipelines.Upload Namespace


UnzipFiles Method

[image]

Sitecore 6.4.1 API
Unzip..::..UnzipFiles Method
Unzip Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void UnzipFiles(
    string zipFilename,
    bool overwrite
)
Visual Basic
Public Sub UnzipFiles ( _
    zipFilename As String, _
    overwrite As Boolean _
)
Visual C++
public:
void UnzipFiles(
    String^ zipFilename,
    bool overwrite
)

Parameters

zipFilename
Type: System..::..String
The zip filename.
overwrite
Type: System..::..Boolean
if set to true this instance is overwrite.

See Also

Unzip Class
Sitecore.Pipelines.Upload Namespace


UnZipMediaItem Method

[image]

Sitecore 6.4.1 API
Unzip..::..UnZipMediaItem Method
Unzip Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void UnZipMediaItem(
    string zipFilename,
    bool overwrite,
    UploadArgs args
)
Visual Basic
Public Sub UnZipMediaItem ( _
    zipFilename As String, _
    overwrite As Boolean, _
    args As UploadArgs _
)
Visual C++
public:
void UnZipMediaItem(
    String^ zipFilename,
    bool overwrite,
    UploadArgs^ args
)

Parameters

zipFilename
Type: System..::..String
The zip filename.
overwrite
Type: System..::..Boolean
if set to true this instance is overwrite.
args
Type: Sitecore.Pipelines.Upload..::..UploadArgs
The arguments.

See Also

Unzip Class
Sitecore.Pipelines.Upload Namespace


UploadArgs Class

[image]

Sitecore 6.4.1 API
UploadArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class UploadArgs : ClientPipelineArgs
Visual Basic
<SerializableAttribute> _
Public Class UploadArgs _
    Inherits ClientPipelineArgs
Visual C++
[SerializableAttribute]
public ref class UploadArgs : public ClientPipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Web.UI.Sheer..::..ClientPipelineArgs
Sitecore.Pipelines.Upload..::..UploadArgs

See Also

UploadArgs Members
Sitecore.Pipelines.Upload Namespace


UploadArgs Members

[image] [image]

Sitecore 6.4.1 API
UploadArgs Members
UploadArgs Class Constructors Methods Properties See Also Send Feedback

The UploadArgs type exposes the following members.

Constructors

 | Name | Description
Public method | UploadArgs()()()() | Initializes a new instance of the UploadArgs class.
Protected method | UploadArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the UploadArgs class.
Public method | UploadArgs(HttpFileCollection, String, String, Boolean, Boolean) | Obsolete. Initializes a new instance of the UploadArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortUpload | Aborts the upload.
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFileParameter | Gets the file parameter.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ClientPipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | A processor is done. (Overrides ClientPipelineArgs..::..ProcessorDone()()()().)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | SetFileParameter | Sets the file parameter.
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WaitForPostBack()()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Public method | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CarryResultToNextProcessor | Gets or sets a value indicating whether the ClientPipelineArgs carries the result to next processor. (Inherited from ClientPipelineArgs.)
Public property | CloseDialogOnEnd | Gets or sets a value indicating whether the pipeline closes the dialog on end.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Destination | Gets or sets the destination.
Public property | ErrorText | Gets or sets the error text.
Public property | FileOnly | Gets or sets a value indicating whether the UploadArgs files the only.
Public property | Files | Gets the files.
Public property | Folder | Gets or sets the folder.
Public property | HasResult | Gets a value indicating whether this instance has a result. (Inherited from ClientPipelineArgs.)
Public property | ID | Obsolete. Gets or sets the ID.
Public property | IsPostBack | Gets or sets a value that indicates if the processor was invoked as part of a user response. (Inherited from ClientPipelineArgs.)
Public property | Language | Gets or sets the language.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Overwrite | Gets or sets a value indicating whether this UploadArgs is overwrite.
Public property | Parameters | Gets or sets the parameters. (Inherited from ClientPipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Properties | Gets the properties. (Inherited from ClientPipelineArgs.)
Public property | Result | Gets or sets the value that was posted as part of a Sheer response. (Inherited from ClientPipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
Public property | Unpack | Gets or sets a value indicating whether ZIP archives are unpacked.
Public property | Unzip | Obsolete. Gets or sets a value indicating whether this UploadArgs is unzip.
Public property | UploadedItems | Gets the items.
Public property | Versioned | Gets or sets a value indicating whether this UploadArgs is versioned.

See Also

UploadArgs Class
Sitecore.Pipelines.Upload Namespace


UploadArgs Constructor

[image] [image]

Sitecore 6.4.1 API
UploadArgs Constructor
UploadArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UploadArgs()()()() | Initializes a new instance of the UploadArgs class.
Protected method | UploadArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the UploadArgs class.
Public method | UploadArgs(HttpFileCollection, String, String, Boolean, Boolean) | Obsolete. Initializes a new instance of the UploadArgs class.

See Also

UploadArgs Class
UploadArgs Members
Sitecore.Pipelines.Upload Namespace


UploadArgs Constructor

[image]

Sitecore 6.4.1 API
UploadArgs Constructor
UploadArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UploadArgs()
Visual Basic
Public Sub New
Visual C++
public:
UploadArgs()

See Also

UploadArgs Class
UploadArgs Overload
Sitecore.Pipelines.Upload Namespace


UploadArgs Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
UploadArgs Constructor (SerializationInfo, StreamingContext)
UploadArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected UploadArgs(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
UploadArgs(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

UploadArgs Class
UploadArgs Overload
Sitecore.Pipelines.Upload Namespace


UploadArgs Constructor (HttpFileCollection, String, String, Boolean, Boolean)

[image]

Sitecore 6.4.1 API
UploadArgs Constructor (HttpFileCollection, String, String, Boolean, Boolean)
UploadArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Obsolete - use the parameterless constructor instead")]
public UploadArgs(
    HttpFileCollection files,
    string folder,
    string id,
    bool overwrite,
    bool unpack
)
Visual Basic
<ObsoleteAttribute("Obsolete - use the parameterless constructor instead")> _
Public Sub New ( _
    files As HttpFileCollection, _
    folder As String, _
    id As String, _
    overwrite As Boolean, _
    unpack As Boolean _
)
Visual C++
[ObsoleteAttribute(L"Obsolete - use the parameterless constructor instead")]
public:
UploadArgs(
    HttpFileCollection^ files,
    String^ folder,
    String^ id,
    bool overwrite,
    bool unpack
)

Parameters

files
Type: System.Web..::..HttpFileCollection
The files.
folder
Type: System..::..String
The folder.
id
Type: System..::..String
The id.
overwrite
Type: System..::..Boolean
if set to true this instance is overwrite.
unpack
Type: System..::..Boolean
if set to true this ZIP archives are unpacked.

See Also

UploadArgs Class
UploadArgs Overload
Sitecore.Pipelines.Upload Namespace


UploadArgs Methods

[image] [image]

Sitecore 6.4.1 API
UploadArgs Methods
UploadArgs Class See Also Send Feedback

The UploadArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortUpload | Aborts the upload.
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFileParameter | Gets the file parameter.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ClientPipelineArgs..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | A processor is done. (Overrides ClientPipelineArgs..::..ProcessorDone()()()().)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | SetFileParameter | Sets the file parameter.
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WaitForPostBack()()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Public method | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)

See Also

UploadArgs Class
Sitecore.Pipelines.Upload Namespace


AbortUpload Method

[image]

Sitecore 6.4.1 API
UploadArgs..::..AbortUpload Method
UploadArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AbortUpload(
    string abortUploadReason
)
Visual Basic
Public Sub AbortUpload ( _
    abortUploadReason As String _
)
Visual C++
public:
void AbortUpload(
    String^ abortUploadReason
)

Parameters

abortUploadReason
Type: System..::..String
The abort upload reason.

See Also

UploadArgs Class
Sitecore.Pipelines.Upload Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
UploadArgs..::..AddMessage Method
UploadArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

UploadArgs Class
UploadArgs Members
Sitecore.Pipelines.Upload Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
UploadArgs..::..GetMessages Method
UploadArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

UploadArgs Class
UploadArgs Members
Sitecore.Pipelines.Upload Namespace


GetObjectData Method

[image]

Sitecore 6.4.1 API
UploadArgs..::..GetObjectData Method
UploadArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System.Security..::..SecurityException | The caller does not have the required permission.

See Also

UploadArgs Class
Sitecore.Pipelines.Upload Namespace


ProcessorDone Method

[image]

Sitecore 6.4.1 API
UploadArgs..::..ProcessorDone Method
UploadArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected internal override void ProcessorDone()
Visual Basic
Protected Friend Overrides Sub ProcessorDone
Visual C++
protected public:
virtual void ProcessorDone() override

See Also

UploadArgs Class
Sitecore.Pipelines.Upload Namespace


WaitForPostBack Method

[image] [image]

Sitecore 6.4.1 API
UploadArgs..::..WaitForPostBack Method
UploadArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaitForPostBack()()()() | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)
Public method | WaitForPostBack(Boolean) | Suspends the pipeline after the current processor has completed. (Inherited from ClientPipelineArgs.)

See Also

UploadArgs Class
UploadArgs Members
Sitecore.Pipelines.Upload Namespace


UploadArgs Properties

[image] [image]

Sitecore 6.4.1 API
UploadArgs Properties
UploadArgs Class See Also Send Feedback

The UploadArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CarryResultToNextProcessor | Gets or sets a value indicating whether the ClientPipelineArgs carries the result to next processor. (Inherited from ClientPipelineArgs.)
Public property | CloseDialogOnEnd | Gets or sets a value indicating whether the pipeline closes the dialog on end.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Destination | Gets or sets the destination.
Public property | ErrorText | Gets or sets the error text.
Public property | FileOnly | Gets or sets a value indicating whether the UploadArgs files the only.
Public property | Files | Gets the files.
Public property | Folder | Gets or sets the folder.
Public property | HasResult | Gets a value indicating whether this instance has a result. (Inherited from ClientPipelineArgs.)
Public property | ID | Obsolete. Gets or sets the ID.
Public property | IsPostBack | Gets or sets a value that indicates if the processor was invoked as part of a user response. (Inherited from ClientPipelineArgs.)
Public property | Language | Gets or sets the language.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Overwrite | Gets or sets a value indicating whether this UploadArgs is overwrite.
Public property | Parameters | Gets or sets the parameters. (Inherited from ClientPipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Properties | Gets the properties. (Inherited from ClientPipelineArgs.)
Public property | Result | Gets or sets the value that was posted as part of a Sheer response. (Inherited from ClientPipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
Public property | Unpack | Gets or sets a value indicating whether ZIP archives are unpacked.
Public property | Unzip | Obsolete. Gets or sets a value indicating whether this UploadArgs is unzip.
Public property | UploadedItems | Gets the items.
Public property | Versioned | Gets or sets a value indicating whether this UploadArgs is versioned.

See Also

UploadArgs Class
Sitecore.Pipelines.Upload Namespace


CloseDialogOnEnd Property

[image]

Sitecore 6.4.1 API
UploadArgs..::..CloseDialogOnEnd Property
UploadArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool CloseDialogOnEnd { get; set; }
Visual Basic
Public Property CloseDialogOnEnd As Boolean
    Get
    Set
Visual C++
public:
property bool CloseDialogOnEnd {
    bool get ();
    void set (bool value);
}

Field Value

true if the pipeline closes the dialog on end; otherwise, false.

See Also

UploadArgs Class
Sitecore.Pipelines.Upload Namespace


Destination Property

[image]

Sitecore 6.4.1 API
UploadArgs..::..Destination Property
UploadArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UploadDestination Destination { get; set; }
Visual Basic
Public Property Destination As UploadDestination
    Get
    Set
Visual C++
public:
property UploadDestination Destination {
    UploadDestination get ();
    void set (UploadDestination value);
}

Field Value

The destination.

See Also

UploadArgs Class
Sitecore.Pipelines.Upload Namespace


ErrorText Property

[image]

Sitecore 6.4.1 API
UploadArgs..::..ErrorText Property
UploadArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ErrorText { get; set; }
Visual Basic
Public Property ErrorText As String
    Get
    Set
Visual C++
public:
property String^ ErrorText {
    String^ get ();
    void set (String^ value);
}

Field Value

The error text.

See Also

UploadArgs Class
Sitecore.Pipelines.Upload Namespace


FileOnly Property

[image]

Sitecore 6.4.1 API
UploadArgs..::..FileOnly Property
UploadArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool FileOnly { get; set; }
Visual Basic
Public Property FileOnly As Boolean
    Get
    Set
Visual C++
public:
property bool FileOnly {
    bool get ();
    void set (bool value);
}

Field Value

true if the UploadArgs files the only; otherwise, false.

See Also

UploadArgs Class
Sitecore.Pipelines.Upload Namespace


Files Property

[image]

Sitecore 6.4.1 API
UploadArgs..::..Files Property
UploadArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HttpFileCollection Files { get; set; }
Visual Basic
Public Property Files As HttpFileCollection
    Get
    Set
Visual C++
public:
property HttpFileCollection^ Files {
    HttpFileCollection^ get ();
    void set (HttpFileCollection^ value);
}

Field Value

The files.

See Also

UploadArgs Class
Sitecore.Pipelines.Upload Namespace


Folder Property

[image]

Sitecore 6.4.1 API
UploadArgs..::..Folder Property
UploadArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Folder { get; set; }
Visual Basic
Public Property Folder As String
    Get
    Set
Visual C++
public:
property String^ Folder {
    String^ get ();
    void set (String^ value);
}

Field Value

The folder.

See Also

UploadArgs Class
Sitecore.Pipelines.Upload Namespace


ID Property

[image]

Sitecore 6.4.1 API
UploadArgs..::..ID Property
UploadArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public string ID { get; set; }
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Property ID As String
    Get
    Set
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public:
property String^ ID {
    String^ get ();
    void set (String^ value);
}

Field Value

The ID.

See Also

UploadArgs Class
Sitecore.Pipelines.Upload Namespace


Language Property

[image]

Sitecore 6.4.1 API
UploadArgs..::..Language Property
UploadArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Language Language { get; set; }
Visual Basic
Public Property Language As Language
    Get
    Set
Visual C++
public:
property Language^ Language {
    Language^ get ();
    void set (Language^ value);
}

Field Value

The language.

See Also

UploadArgs Class
Sitecore.Pipelines.Upload Namespace


Overwrite Property

[image]

Sitecore 6.4.1 API
UploadArgs..::..Overwrite Property
UploadArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Overwrite { get; set; }
Visual Basic
Public Property Overwrite As Boolean
    Get
    Set
Visual C++
public:
property bool Overwrite {
    bool get ();
    void set (bool value);
}

Field Value

true if overwrite; otherwise, false.

See Also

UploadArgs Class
Sitecore.Pipelines.Upload Namespace


Unpack Property

[image]

Sitecore 6.4.1 API
UploadArgs..::..Unpack Property
UploadArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Unpack { get; set; }
Visual Basic
Public Property Unpack As Boolean
    Get
    Set
Visual C++
public:
property bool Unpack {
    bool get ();
    void set (bool value);
}

Field Value

true if ZIP archives are unpacked; otherwise, false.

See Also

UploadArgs Class
Sitecore.Pipelines.Upload Namespace


Unzip Property

[image]

Sitecore 6.4.1 API
UploadArgs..::..Unzip Property
UploadArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Obsolete - use the Unpack property instead")]
public bool Unzip { get; set; }
Visual Basic
<ObsoleteAttribute("Obsolete - use the Unpack property instead")> _
Public Property Unzip As Boolean
    Get
    Set
Visual C++
[ObsoleteAttribute(L"Obsolete - use the Unpack property instead")]
public:
property bool Unzip {
    bool get ();
    void set (bool value);
}

Field Value

true if unzip; otherwise, false.

See Also

UploadArgs Class
Sitecore.Pipelines.Upload Namespace


UploadedItems Property

[image]

Sitecore 6.4.1 API
UploadArgs..::..UploadedItems Property
UploadArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public List<Item> UploadedItems { get; }
Visual Basic
Public ReadOnly Property UploadedItems As List(Of Item)
    Get
Visual C++
public:
property List<Item^>^ UploadedItems {
    List<Item^>^ get ();
}

Field Value

The items.

See Also

UploadArgs Class
Sitecore.Pipelines.Upload Namespace


Versioned Property

[image]

Sitecore 6.4.1 API
UploadArgs..::..Versioned Property
UploadArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Versioned { get; set; }
Visual Basic
Public Property Versioned As Boolean
    Get
    Set
Visual C++
public:
property bool Versioned {
    bool get ();
    void set (bool value);
}

Field Value

true if versioned; otherwise, false.

See Also

UploadArgs Class
Sitecore.Pipelines.Upload Namespace


UploadDestination Enumeration

[image]

Sitecore 6.4.1 API
UploadDestination Enumeration
See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum UploadDestination
Visual Basic
Public Enumeration UploadDestination
Visual C++
public enum class UploadDestination

Members

Member name | Value | Description
Database | 0 | Database.
File | 1 | File

See Also

Sitecore.Pipelines.Upload Namespace


UploadProcessor Class

[image]

Sitecore 6.4.1 API
UploadProcessor Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class UploadProcessor
Visual Basic
Public MustInherit Class UploadProcessor
Visual C++
public ref class UploadProcessor abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.Upload..::..UploadProcessor
Sitecore.Pipelines.Upload..::..CheckSize
Sitecore.Pipelines.Upload..::..Save

See Also

UploadProcessor Members
Sitecore.Pipelines.Upload Namespace


UploadProcessor Members

[image] [image]

Sitecore 6.4.1 API
UploadProcessor Members
UploadProcessor Class Constructors Methods See Also Send Feedback

The UploadProcessor type exposes the following members.

Constructors

 | Name | Description
Protected method | UploadProcessor | Initializes a new instance of the UploadProcessor class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsUnpack | Determines whether the specified args is zip.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UploadProcessor Class
Sitecore.Pipelines.Upload Namespace


UploadProcessor Constructor

[image]

Sitecore 6.4.1 API
UploadProcessor Constructor
UploadProcessor Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected UploadProcessor()
Visual Basic
Protected Sub New
Visual C++
protected:
UploadProcessor()

See Also

UploadProcessor Class
Sitecore.Pipelines.Upload Namespace


UploadProcessor Methods

[image] [image]

Sitecore 6.4.1 API
UploadProcessor Methods
UploadProcessor Class See Also Send Feedback

The UploadProcessor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsUnpack | Determines whether the specified args is zip.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UploadProcessor Class
Sitecore.Pipelines.Upload Namespace


IsUnpack Method

[image]

Sitecore 6.4.1 API
UploadProcessor..::..IsUnpack Method
UploadProcessor Class See Also Send Feedback

Namespace: Sitecore.Pipelines.Upload
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected static bool IsUnpack(
    UploadArgs args,
    HttpPostedFile file
)
Visual Basic
Protected Shared Function IsUnpack ( _
    args As UploadArgs, _
    file As HttpPostedFile _
) As Boolean
Visual C++
protected:
static bool IsUnpack(
    UploadArgs^ args,
    HttpPostedFile^ file
)

Parameters

args
Type: Sitecore.Pipelines.Upload..::..UploadArgs
The arguments.
file
Type: System.Web..::..HttpPostedFile
The file.

Return Value

true if the specified args is zip; otherwise, false.

See Also

UploadProcessor Class
Sitecore.Pipelines.Upload Namespace


Sitecore.Pipelines.WebDAV Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Pipelines.WebDAV Namespace
Send Feedback

Classes

 | Class | Description
Public class | ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)> | Pipeline arguments for validating Web DAV operation.
Public class | WebDAVPipelineArgs<(Of <(<'T>)>)> | Args for Web DAV view resolving pipeline.
Public class | WebDAVProcessPropertiesPipelineArgs | Processor arguments for Update Propery operation.
Public class | WebDAVPropertiesPipelineArgs | Processor arguments for collecting DAV properties.


ValidateWebDAVOperationPipelineArgs(T) Class

[image]

Sitecore 6.4.1 API
ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ValidateWebDAVOperationPipelineArgs<T> : WebDAVPipelineArgs<T>
Visual Basic
Public Class ValidateWebDAVOperationPipelineArgs(Of T) _
    Inherits WebDAVPipelineArgs(Of T)
Visual C++
generic<typename T>
public ref class ValidateWebDAVOperationPipelineArgs : public WebDAVPipelineArgs<T>

Type Parameters

T
The Return Type.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Pipelines.WebDAV..::..WebDAVPipelineArgs <(Of <(<'T>)>)>
Sitecore.Pipelines.WebDAV..::..ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)>

See Also

ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)> Members
Sitecore.Pipelines.WebDAV Namespace


ValidateWebDAVOperationPipelineArgs(T) Members

[image] [image]

Sitecore 6.4.1 API
ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)> Members
ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)> | Initializes a new instance of the ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)> class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | Context | Gets the context. (Inherited from WebDAVPipelineArgs<(Of <(<'T>)>)>.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Item | Gets the item.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Operation | Gets the operation.
Public property | Options | Gets the Web DAV options. (Inherited from WebDAVPipelineArgs<(Of <(<'T>)>)>.)
Public property | Parameters | Gets the parameters.
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Result | Gets or sets the view. (Inherited from WebDAVPipelineArgs<(Of <(<'T>)>)>.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)> Class
Sitecore.Pipelines.WebDAV Namespace


ValidateWebDAVOperationPipelineArgs(T) Constructor

[image]

Sitecore 6.4.1 API
ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)> Constructor
ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ValidateWebDAVOperationPipelineArgs(
    HttpContext context,
    WebDAVOptions options,
    WebDAVOperation operation,
    Item item,
    params Object[] parameters
)
Visual Basic
Public Sub New ( _
    context As HttpContext, _
    options As WebDAVOptions, _
    operation As WebDAVOperation, _
    item As Item, _
    ParamArray parameters As Object() _
)
Visual C++
public:
ValidateWebDAVOperationPipelineArgs(
    HttpContext^ context,
    WebDAVOptions^ options,
    WebDAVOperation operation,
    Item^ item,
    ... array<Object^>^ parameters
)

Parameters

context
Type: System.Web..::..HttpContext
The context.
options
Type: Sitecore.Configuration..::..WebDAVOptions
The options.
operation
Type: Sitecore.Data.Items..::..WebDAVOperation
The operation.
item
Type: Sitecore.Data.Items..::..Item
The Sitecore item.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.

See Also

ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)> Class
Sitecore.Pipelines.WebDAV Namespace


ValidateWebDAVOperationPipelineArgs(T) Methods

[image] [image]

Sitecore 6.4.1 API
ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)> Methods
ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)> Class See Also Send Feedback

The ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)> Class
Sitecore.Pipelines.WebDAV Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)>..::..AddMessage Method
ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)> Class
ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)> Members
Sitecore.Pipelines.WebDAV Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)>..::..GetMessages Method
ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)> Class
ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)> Members
Sitecore.Pipelines.WebDAV Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)>..::..Suspend Method
ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)> Class
ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)> Members
Sitecore.Pipelines.WebDAV Namespace


ValidateWebDAVOperationPipelineArgs(T) Properties

[image] [image]

Sitecore 6.4.1 API
ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)> Properties
ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)> Class See Also Send Feedback

The ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | Context | Gets the context. (Inherited from WebDAVPipelineArgs<(Of <(<'T>)>)>.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Item | Gets the item.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Operation | Gets the operation.
Public property | Options | Gets the Web DAV options. (Inherited from WebDAVPipelineArgs<(Of <(<'T>)>)>.)
Public property | Parameters | Gets the parameters.
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Result | Gets or sets the view. (Inherited from WebDAVPipelineArgs<(Of <(<'T>)>)>.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)> Class
Sitecore.Pipelines.WebDAV Namespace


Item Property

[image]

Sitecore 6.4.1 API
ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)>..::..Item Property
ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Item { get; }
Visual Basic
Public ReadOnly Property Item As Item
    Get
Visual C++
public:
property Item^ Item {
    Item^ get ();
}

Field Value

The DAV item.

See Also

ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)> Class
Sitecore.Pipelines.WebDAV Namespace


Parameters Property

[image]

Sitecore 6.4.1 API
ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)>..::..Parameters Property
ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object[] Parameters { get; }
Visual Basic
Public ReadOnly Property Parameters As Object()
    Get
Visual C++
public:
property array<Object^>^ Parameters {
    array<Object^>^ get ();
}

Field Value

The parameters.

See Also

ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)> Class
Sitecore.Pipelines.WebDAV Namespace


WebDAVPipelineArgs(T) Class

[image]

Sitecore 6.4.1 API
WebDAVPipelineArgs<(Of <(<'T>)>)> Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class WebDAVPipelineArgs<T> : PipelineArgs
Visual Basic
Public Class WebDAVPipelineArgs(Of T) _
    Inherits PipelineArgs
Visual C++
generic<typename T>
public ref class WebDAVPipelineArgs : public PipelineArgs

Type Parameters

T
Type of object to be resolved.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Pipelines.WebDAV..::..WebDAVPipelineArgs<(Of <(<'T>)>)>
Sitecore.Pipelines.WebDAV..::..ValidateWebDAVOperationPipelineArgs<(Of <(<'T>)>)>
Sitecore.Pipelines.WebDAV..::..WebDAVProcessPropertiesPipelineArgs
Sitecore.Pipelines.WebDAV..::..WebDAVPropertiesPipelineArgs

See Also

WebDAVPipelineArgs<(Of <(<'T>)>)> Members
Sitecore.Pipelines.WebDAV Namespace


WebDAVPipelineArgs(T) Members

[image] [image]

Sitecore 6.4.1 API
WebDAVPipelineArgs<(Of <(<'T>)>)> Members
WebDAVPipelineArgs<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The WebDAVPipelineArgs<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | WebDAVPipelineArgs<(Of <(<'T>)>)> | Initializes a new instance of the WebDAVPipelineArgs<(Of <(<'T>)>)> class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | Context | Gets the context.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Options | Gets the Web DAV options.
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Result | Gets or sets the view.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

WebDAVPipelineArgs<(Of <(<'T>)>)> Class
Sitecore.Pipelines.WebDAV Namespace


WebDAVPipelineArgs(T) Constructor

[image]

Sitecore 6.4.1 API
WebDAVPipelineArgs<(Of <(<'T>)>)> Constructor
WebDAVPipelineArgs<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WebDAVPipelineArgs(
    HttpContext context,
    WebDAVOptions options
)
Visual Basic
Public Sub New ( _
    context As HttpContext, _
    options As WebDAVOptions _
)
Visual C++
public:
WebDAVPipelineArgs(
    HttpContext^ context,
    WebDAVOptions^ options
)

Parameters

context
Type: System.Web..::..HttpContext
The context.
options
Type: Sitecore.Configuration..::..WebDAVOptions
The options.

See Also

WebDAVPipelineArgs<(Of <(<'T>)>)> Class
Sitecore.Pipelines.WebDAV Namespace


WebDAVPipelineArgs(T) Methods

[image] [image]

Sitecore 6.4.1 API
WebDAVPipelineArgs<(Of <(<'T>)>)> Methods
WebDAVPipelineArgs<(Of <(<'T>)>)> Class See Also Send Feedback

The WebDAVPipelineArgs<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WebDAVPipelineArgs<(Of <(<'T>)>)> Class
Sitecore.Pipelines.WebDAV Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
WebDAVPipelineArgs<(Of <(<'T>)>)>..::..AddMessage Method
WebDAVPipelineArgs<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

WebDAVPipelineArgs<(Of <(<'T>)>)> Class
WebDAVPipelineArgs<(Of <(<'T>)>)> Members
Sitecore.Pipelines.WebDAV Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
WebDAVPipelineArgs<(Of <(<'T>)>)>..::..GetMessages Method
WebDAVPipelineArgs<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

WebDAVPipelineArgs<(Of <(<'T>)>)> Class
WebDAVPipelineArgs<(Of <(<'T>)>)> Members
Sitecore.Pipelines.WebDAV Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
WebDAVPipelineArgs<(Of <(<'T>)>)>..::..Suspend Method
WebDAVPipelineArgs<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

WebDAVPipelineArgs<(Of <(<'T>)>)> Class
WebDAVPipelineArgs<(Of <(<'T>)>)> Members
Sitecore.Pipelines.WebDAV Namespace


WebDAVPipelineArgs(T) Properties

[image] [image]

Sitecore 6.4.1 API
WebDAVPipelineArgs<(Of <(<'T>)>)> Properties
WebDAVPipelineArgs<(Of <(<'T>)>)> Class See Also Send Feedback

The WebDAVPipelineArgs<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | Context | Gets the context.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Options | Gets the Web DAV options.
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Result | Gets or sets the view.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

WebDAVPipelineArgs<(Of <(<'T>)>)> Class
Sitecore.Pipelines.WebDAV Namespace


Options Property

[image]

Sitecore 6.4.1 API
WebDAVPipelineArgs<(Of <(<'T>)>)>..::..Options Property
WebDAVPipelineArgs<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WebDAVOptions Options { get; }
Visual Basic
Public ReadOnly Property Options As WebDAVOptions
    Get
Visual C++
public:
property WebDAVOptions^ Options {
    WebDAVOptions^ get ();
}

Field Value

The Web DAV options.

See Also

WebDAVPipelineArgs<(Of <(<'T>)>)> Class
Sitecore.Pipelines.WebDAV Namespace


Result Property

[image]

Sitecore 6.4.1 API
WebDAVPipelineArgs<(Of <(<'T>)>)>..::..Result Property
WebDAVPipelineArgs<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public T Result { get; set; }
Visual Basic
Public Property Result As T
    Get
    Set
Visual C++
public:
property T Result {
    T get ();
    void set (T value);
}

Field Value

The Web DAV view.

See Also

WebDAVPipelineArgs<(Of <(<'T>)>)> Class
Sitecore.Pipelines.WebDAV Namespace


WebDAVProcessPropertiesPipelineArgs Class

[image]

Sitecore 6.4.1 API
WebDAVProcessPropertiesPipelineArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class WebDAVProcessPropertiesPipelineArgs : WebDAVPipelineArgs<WebDAVResponse>
Visual Basic
Public Class WebDAVProcessPropertiesPipelineArgs _
    Inherits WebDAVPipelineArgs(Of WebDAVResponse)
Visual C++
public ref class WebDAVProcessPropertiesPipelineArgs : public WebDAVPipelineArgs<WebDAVResponse^>

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Pipelines.WebDAV..::..WebDAVPipelineArgs <(Of <(<'WebDAVResponse>)>)>
Sitecore.Pipelines.WebDAV..::..WebDAVProcessPropertiesPipelineArgs

See Also

WebDAVProcessPropertiesPipelineArgs Members
Sitecore.Pipelines.WebDAV Namespace


WebDAVProcessPropertiesPipelineArgs Members

[image] [image]

Sitecore 6.4.1 API
WebDAVProcessPropertiesPipelineArgs Members
WebDAVProcessPropertiesPipelineArgs Class Constructors Methods Properties See Also Send Feedback

The WebDAVProcessPropertiesPipelineArgs type exposes the following members.

Constructors

 | Name | Description
Public method | WebDAVProcessPropertiesPipelineArgs | Initializes a new instance of the WebDAVProcessPropertiesPipelineArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | Context | Gets the context. (Inherited from WebDAVPipelineArgs<(Of <(<'T>)>)>.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | DeleteProperties | Gets the delete properties.
Public property | Item | Gets the item.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Options | Gets the Web DAV options. (Inherited from WebDAVPipelineArgs<(Of <(<'T>)>)>.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Result | Gets or sets the view. (Inherited from WebDAVPipelineArgs<(Of <(<'T>)>)>.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
Public property | UpdateProperties | Gets the update properties.

See Also

WebDAVProcessPropertiesPipelineArgs Class
Sitecore.Pipelines.WebDAV Namespace


WebDAVProcessPropertiesPipelineArgs Constructor

[image]

Sitecore 6.4.1 API
WebDAVProcessPropertiesPipelineArgs Constructor
WebDAVProcessPropertiesPipelineArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WebDAVProcessPropertiesPipelineArgs(
    HttpContext context,
    WebDAVOptions options,
    Item item,
    Property[] updateProperties,
    Property[] deleteProperties
)
Visual Basic
Public Sub New ( _
    context As HttpContext, _
    options As WebDAVOptions, _
    item As Item, _
    updateProperties As Property(), _
    deleteProperties As Property() _
)
Visual C++
public:
WebDAVProcessPropertiesPipelineArgs(
    HttpContext^ context,
    WebDAVOptions^ options,
    Item^ item,
    array<Property>^ updateProperties,
    array<Property>^ deleteProperties
)

Parameters

context
Type: System.Web..::..HttpContext
The context.
options
Type: Sitecore.Configuration..::..WebDAVOptions
The options.
item
Type: Sitecore.Data.Items..::..Item
The Sitecore item.
updateProperties
Type: array<Property>[]()[][]
The update properties.
deleteProperties
Type: array<Property>[]()[][]
The delete properties.

See Also

WebDAVProcessPropertiesPipelineArgs Class
Sitecore.Pipelines.WebDAV Namespace


WebDAVProcessPropertiesPipelineArgs Methods

[image] [image]

Sitecore 6.4.1 API
WebDAVProcessPropertiesPipelineArgs Methods
WebDAVProcessPropertiesPipelineArgs Class See Also Send Feedback

The WebDAVProcessPropertiesPipelineArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WebDAVProcessPropertiesPipelineArgs Class
Sitecore.Pipelines.WebDAV Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
WebDAVProcessPropertiesPipelineArgs..::..AddMessage Method
WebDAVProcessPropertiesPipelineArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

WebDAVProcessPropertiesPipelineArgs Class
WebDAVProcessPropertiesPipelineArgs Members
Sitecore.Pipelines.WebDAV Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
WebDAVProcessPropertiesPipelineArgs..::..GetMessages Method
WebDAVProcessPropertiesPipelineArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

WebDAVProcessPropertiesPipelineArgs Class
WebDAVProcessPropertiesPipelineArgs Members
Sitecore.Pipelines.WebDAV Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
WebDAVProcessPropertiesPipelineArgs..::..Suspend Method
WebDAVProcessPropertiesPipelineArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

WebDAVProcessPropertiesPipelineArgs Class
WebDAVProcessPropertiesPipelineArgs Members
Sitecore.Pipelines.WebDAV Namespace


WebDAVProcessPropertiesPipelineArgs Properties

[image] [image]

Sitecore 6.4.1 API
WebDAVProcessPropertiesPipelineArgs Properties
WebDAVProcessPropertiesPipelineArgs Class See Also Send Feedback

The WebDAVProcessPropertiesPipelineArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | Context | Gets the context. (Inherited from WebDAVPipelineArgs<(Of <(<'T>)>)>.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | DeleteProperties | Gets the delete properties.
Public property | Item | Gets the item.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Options | Gets the Web DAV options. (Inherited from WebDAVPipelineArgs<(Of <(<'T>)>)>.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Result | Gets or sets the view. (Inherited from WebDAVPipelineArgs<(Of <(<'T>)>)>.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
Public property | UpdateProperties | Gets the update properties.

See Also

WebDAVProcessPropertiesPipelineArgs Class
Sitecore.Pipelines.WebDAV Namespace


DeleteProperties Property

[image]

Sitecore 6.4.1 API
WebDAVProcessPropertiesPipelineArgs..::..DeleteProperties Property
WebDAVProcessPropertiesPipelineArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public List<Property> DeleteProperties { get; }
Visual Basic
Public ReadOnly Property DeleteProperties As List(Of Property)
    Get
Visual C++
public:
property List<Property>^ DeleteProperties {
    List<Property>^ get ();
}

Field Value

The delete properties.

See Also

WebDAVProcessPropertiesPipelineArgs Class
Sitecore.Pipelines.WebDAV Namespace


Item Property

[image]

Sitecore 6.4.1 API
WebDAVProcessPropertiesPipelineArgs..::..Item Property
WebDAVProcessPropertiesPipelineArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Item { get; }
Visual Basic
Public ReadOnly Property Item As Item
    Get
Visual C++
public:
property Item^ Item {
    Item^ get ();
}

Field Value

The Sitecore item.

See Also

WebDAVProcessPropertiesPipelineArgs Class
Sitecore.Pipelines.WebDAV Namespace


UpdateProperties Property

[image]

Sitecore 6.4.1 API
WebDAVProcessPropertiesPipelineArgs..::..UpdateProperties Property
WebDAVProcessPropertiesPipelineArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public List<Property> UpdateProperties { get; }
Visual Basic
Public ReadOnly Property UpdateProperties As List(Of Property)
    Get
Visual C++
public:
property List<Property>^ UpdateProperties {
    List<Property>^ get ();
}

Field Value

The update properties.

See Also

WebDAVProcessPropertiesPipelineArgs Class
Sitecore.Pipelines.WebDAV Namespace


WebDAVPropertiesPipelineArgs Class

[image]

Sitecore 6.4.1 API
WebDAVPropertiesPipelineArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class WebDAVPropertiesPipelineArgs : WebDAVPipelineArgs<List<Property>>
Visual Basic
Public Class WebDAVPropertiesPipelineArgs _
    Inherits WebDAVPipelineArgs(Of List(Of Property))
Visual C++
public ref class WebDAVPropertiesPipelineArgs : public WebDAVPipelineArgs<List<Property>^>

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Pipelines.WebDAV..::..WebDAVPipelineArgs <(Of <(<' List <(Of <(<'Property>)>)>>)>)>
Sitecore.Pipelines.WebDAV..::..WebDAVPropertiesPipelineArgs

See Also

WebDAVPropertiesPipelineArgs Members
Sitecore.Pipelines.WebDAV Namespace


WebDAVPropertiesPipelineArgs Members

[image] [image]

Sitecore 6.4.1 API
WebDAVPropertiesPipelineArgs Members
WebDAVPropertiesPipelineArgs Class Constructors Methods Properties See Also Send Feedback

The WebDAVPropertiesPipelineArgs type exposes the following members.

Constructors

 | Name | Description
Public method | WebDAVPropertiesPipelineArgs | Initializes a new instance of the WebDAVPropertiesPipelineArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | Context | Gets the context. (Inherited from WebDAVPipelineArgs<(Of <(<'T>)>)>.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Item | Gets the item.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Options | Gets the Web DAV options. (Inherited from WebDAVPipelineArgs<(Of <(<'T>)>)>.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Result | Gets or sets the view. (Inherited from WebDAVPipelineArgs<(Of <(<'T>)>)>.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

WebDAVPropertiesPipelineArgs Class
Sitecore.Pipelines.WebDAV Namespace


WebDAVPropertiesPipelineArgs Constructor

[image]

Sitecore 6.4.1 API
WebDAVPropertiesPipelineArgs Constructor
WebDAVPropertiesPipelineArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public WebDAVPropertiesPipelineArgs(
    HttpContext context,
    WebDAVOptions options,
    Item item,
    Property[] props
)
Visual Basic
Public Sub New ( _
    context As HttpContext, _
    options As WebDAVOptions, _
    item As Item, _
    props As Property() _
)
Visual C++
public:
WebDAVPropertiesPipelineArgs(
    HttpContext^ context,
    WebDAVOptions^ options,
    Item^ item,
    array<Property>^ props
)

Parameters

context
Type: System.Web..::..HttpContext
The context.
options
Type: Sitecore.Configuration..::..WebDAVOptions
The options.
item
Type: Sitecore.Data.Items..::..Item
The Sitecore item.
props
Type: array<Property>[]()[][]
The properties.

See Also

WebDAVPropertiesPipelineArgs Class
Sitecore.Pipelines.WebDAV Namespace


WebDAVPropertiesPipelineArgs Methods

[image] [image]

Sitecore 6.4.1 API
WebDAVPropertiesPipelineArgs Methods
WebDAVPropertiesPipelineArgs Class See Also Send Feedback

The WebDAVPropertiesPipelineArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WebDAVPropertiesPipelineArgs Class
Sitecore.Pipelines.WebDAV Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
WebDAVPropertiesPipelineArgs..::..GetMessages Method
WebDAVPropertiesPipelineArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

WebDAVPropertiesPipelineArgs Class
WebDAVPropertiesPipelineArgs Members
Sitecore.Pipelines.WebDAV Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
WebDAVPropertiesPipelineArgs..::..Suspend Method
WebDAVPropertiesPipelineArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

WebDAVPropertiesPipelineArgs Class
WebDAVPropertiesPipelineArgs Members
Sitecore.Pipelines.WebDAV Namespace


WebDAVPropertiesPipelineArgs Properties

[image] [image]

Sitecore 6.4.1 API
WebDAVPropertiesPipelineArgs Properties
WebDAVPropertiesPipelineArgs Class See Also Send Feedback

The WebDAVPropertiesPipelineArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | Context | Gets the context. (Inherited from WebDAVPipelineArgs<(Of <(<'T>)>)>.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Item | Gets the item.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Options | Gets the Web DAV options. (Inherited from WebDAVPipelineArgs<(Of <(<'T>)>)>.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Result | Gets or sets the view. (Inherited from WebDAVPipelineArgs<(Of <(<'T>)>)>.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

WebDAVPropertiesPipelineArgs Class
Sitecore.Pipelines.WebDAV Namespace


Item Property

[image]

Sitecore 6.4.1 API
WebDAVPropertiesPipelineArgs..::..Item Property
WebDAVPropertiesPipelineArgs Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item Item { get; }
Visual Basic
Public ReadOnly Property Item As Item
    Get
Visual C++
public:
property Item^ Item {
    Item^ get ();
}

Field Value

The Sitecore item.

See Also

WebDAVPropertiesPipelineArgs Class
Sitecore.Pipelines.WebDAV Namespace


DefaultAutogenerateVersionsResolver Class

[image]

Sitecore 6.4.1 API
DefaultAutogenerateVersionsResolver Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DefaultAutogenerateVersionsResolver
Visual Basic
Public Class DefaultAutogenerateVersionsResolver
Visual C++
public ref class DefaultAutogenerateVersionsResolver

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.WebDAV.Processors..::..DefaultAutogenerateVersionsResolver

See Also

DefaultAutogenerateVersionsResolver Members
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultAutogenerateVersionsResolver Members

[image] [image]

Sitecore 6.4.1 API
DefaultAutogenerateVersionsResolver Members
DefaultAutogenerateVersionsResolver Class Constructors Methods See Also Send Feedback

The DefaultAutogenerateVersionsResolver type exposes the following members.

Constructors

 | Name | Description
Public method | DefaultAutogenerateVersionsResolver | Initializes a new instance of the DefaultAutogenerateVersionsResolver class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultAutogenerateVersionsResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultAutogenerateVersionsResolver Methods

[image] [image]

Sitecore 6.4.1 API
DefaultAutogenerateVersionsResolver Methods
DefaultAutogenerateVersionsResolver Class See Also Send Feedback

The DefaultAutogenerateVersionsResolver type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultAutogenerateVersionsResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


Process Method

[image]

Sitecore 6.4.1 API
DefaultAutogenerateVersionsResolver..::..Process Method
DefaultAutogenerateVersionsResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    WebDAVPipelineArgs<Tristate> args
)
Visual Basic
Public Sub Process ( _
    args As WebDAVPipelineArgs(Of Tristate) _
)
Visual C++
public:
void Process(
    WebDAVPipelineArgs<Tristate>^ args
)

Parameters

args
Type: Sitecore.Pipelines.WebDAV..::..WebDAVPipelineArgs <(Of <(<' Tristate >)>)>
The arguments.

See Also

DefaultAutogenerateVersionsResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultDatabaseResolver Class

[image]

Sitecore 6.4.1 API
DefaultDatabaseResolver Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DefaultDatabaseResolver
Visual Basic
Public Class DefaultDatabaseResolver
Visual C++
public ref class DefaultDatabaseResolver

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.WebDAV.Processors..::..DefaultDatabaseResolver

See Also

DefaultDatabaseResolver Members
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultDatabaseResolver Members

[image] [image]

Sitecore 6.4.1 API
DefaultDatabaseResolver Members
DefaultDatabaseResolver Class Constructors Methods See Also Send Feedback

The DefaultDatabaseResolver type exposes the following members.

Constructors

 | Name | Description
Public method | DefaultDatabaseResolver | Initializes a new instance of the DefaultDatabaseResolver class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultDatabaseResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultDatabaseResolver Constructor

[image]

Sitecore 6.4.1 API
DefaultDatabaseResolver Constructor
DefaultDatabaseResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DefaultDatabaseResolver()
Visual Basic
Public Sub New
Visual C++
public:
DefaultDatabaseResolver()

See Also

DefaultDatabaseResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultDatabaseResolver Methods

[image] [image]

Sitecore 6.4.1 API
DefaultDatabaseResolver Methods
DefaultDatabaseResolver Class See Also Send Feedback

The DefaultDatabaseResolver type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultDatabaseResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


Process Method

[image]

Sitecore 6.4.1 API
DefaultDatabaseResolver..::..Process Method
DefaultDatabaseResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    WebDAVPipelineArgs<Database> args
)
Visual Basic
Public Sub Process ( _
    args As WebDAVPipelineArgs(Of Database) _
)
Visual C++
public:
void Process(
    WebDAVPipelineArgs<Database^>^ args
)

Parameters

args
Type: Sitecore.Pipelines.WebDAV..::..WebDAVPipelineArgs <(Of <(<' Database >)>)>
The arguments.

See Also

DefaultDatabaseResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultModeResolver Members

[image] [image]

Sitecore 6.4.1 API
DefaultModeResolver Members
DefaultModeResolver Class Constructors Methods See Also Send Feedback

The DefaultModeResolver type exposes the following members.

Constructors

 | Name | Description
Public method | DefaultModeResolver | Initializes a new instance of the DefaultModeResolver class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultModeResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultModeResolver Constructor

[image]

Sitecore 6.4.1 API
DefaultModeResolver Constructor
DefaultModeResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DefaultModeResolver()
Visual Basic
Public Sub New
Visual C++
public:
DefaultModeResolver()

See Also

DefaultModeResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


Process Method

[image]

Sitecore 6.4.1 API
DefaultModeResolver..::..Process Method
DefaultModeResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    WebDAVPipelineArgs<WebDAVConfiguration..::..WebDAVMode> args
)
Visual Basic
Public Sub Process ( _
    args As WebDAVPipelineArgs(Of WebDAVConfiguration..::..WebDAVMode) _
)
Visual C++
public:
void Process(
    WebDAVPipelineArgs<WebDAVConfiguration..::..WebDAVMode>^ args
)

Parameters

args
Type: Sitecore.Pipelines.WebDAV..::..WebDAVPipelineArgs <(Of <(<' WebDAVConfiguration..::..WebDAVMode >)>)>
The arguments.

See Also

DefaultModeResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultOperationValidator Class

[image]

Sitecore 6.4.1 API
DefaultOperationValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DefaultOperationValidator
Visual Basic
Public Class DefaultOperationValidator
Visual C++
public ref class DefaultOperationValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.WebDAV.Processors..::..DefaultOperationValidator

See Also

DefaultOperationValidator Members
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultOperationValidator Members

[image] [image]

Sitecore 6.4.1 API
DefaultOperationValidator Members
DefaultOperationValidator Class Constructors Methods See Also Send Feedback

The DefaultOperationValidator type exposes the following members.

Constructors

 | Name | Description
Public method | DefaultOperationValidator | Initializes a new instance of the DefaultOperationValidator class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultOperationValidator Class
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultOperationValidator Constructor

[image]

Sitecore 6.4.1 API
DefaultOperationValidator Constructor
DefaultOperationValidator Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DefaultOperationValidator()
Visual Basic
Public Sub New
Visual C++
public:
DefaultOperationValidator()

See Also

DefaultOperationValidator Class
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultOperationValidator Methods

[image] [image]

Sitecore 6.4.1 API
DefaultOperationValidator Methods
DefaultOperationValidator Class See Also Send Feedback

The DefaultOperationValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultOperationValidator Class
Sitecore.Pipelines.WebDAV.Processors Namespace


Process Method

[image]

Sitecore 6.4.1 API
DefaultOperationValidator..::..Process Method
DefaultOperationValidator Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    ValidateWebDAVOperationPipelineArgs<Tristate> args
)
Visual Basic
Public Sub Process ( _
    args As ValidateWebDAVOperationPipelineArgs(Of Tristate) _
)
Visual C++
public:
void Process(
    ValidateWebDAVOperationPipelineArgs<Tristate>^ args
)

Parameters

args
Type: Sitecore.Pipelines.WebDAV..::..ValidateWebDAVOperationPipelineArgs <(Of <(<' Tristate >)>)>
The arguments.

See Also

DefaultOperationValidator Class
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultPropertiesResolver Members

[image] [image]

Sitecore 6.4.1 API
DefaultPropertiesResolver Members
DefaultPropertiesResolver Class Constructors Methods See Also Send Feedback

The DefaultPropertiesResolver type exposes the following members.

Constructors

 | Name | Description
Public method | DefaultPropertiesResolver | Initializes a new instance of the DefaultPropertiesResolver class

Methods

 | Name | Description
Public method | AddPropertyMapping | Loads the property mapping.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | Evaluates the specified nVelocity template.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultPropertiesResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultPropertiesResolver Constructor

[image]

Sitecore 6.4.1 API
DefaultPropertiesResolver Constructor
DefaultPropertiesResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DefaultPropertiesResolver()
Visual Basic
Public Sub New
Visual C++
public:
DefaultPropertiesResolver()

See Also

DefaultPropertiesResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultPropertiesResolver Methods

[image] [image]

Sitecore 6.4.1 API
DefaultPropertiesResolver Methods
DefaultPropertiesResolver Class See Also Send Feedback

The DefaultPropertiesResolver type exposes the following members.

Methods

 | Name | Description
Public method | AddPropertyMapping | Loads the property mapping.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Evaluate | Evaluates the specified nVelocity template.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultPropertiesResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


AddPropertyMapping Method

[image]

Sitecore 6.4.1 API
DefaultPropertiesResolver..::..AddPropertyMapping Method
DefaultPropertiesResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void AddPropertyMapping(
    XmlNode configNode
)
Visual Basic
Public Sub AddPropertyMapping ( _
    configNode As XmlNode _
)
Visual C++
public:
void AddPropertyMapping(
    XmlNode^ configNode
)

Parameters

configNode
Type: System.Xml..::..XmlNode
The configuration node.

See Also

DefaultPropertiesResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


Evaluate Method

[image]

Sitecore 6.4.1 API
DefaultPropertiesResolver..::..Evaluate Method
DefaultPropertiesResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual string Evaluate(
    Item item,
    string template
)
Visual Basic
Protected Overridable Function Evaluate ( _
    item As Item, _
    template As String _
) As String
Visual C++
protected:
virtual String^ Evaluate(
    Item^ item,
    String^ template
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The current item.
template
Type: System..::..String
The nVelocity template.

Return Value

The property value.

See Also

DefaultPropertiesResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


Process Method

[image]

Sitecore 6.4.1 API
DefaultPropertiesResolver..::..Process Method
DefaultPropertiesResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    WebDAVPropertiesPipelineArgs args
)
Visual Basic
Public Sub Process ( _
    args As WebDAVPropertiesPipelineArgs _
)
Visual C++
public:
void Process(
    WebDAVPropertiesPipelineArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.WebDAV..::..WebDAVPropertiesPipelineArgs
The arguments.

See Also

DefaultPropertiesResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultRequireAuthenticationResolver Class

[image]

Sitecore 6.4.1 API
DefaultRequireAuthenticationResolver Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DefaultRequireAuthenticationResolver
Visual Basic
Public Class DefaultRequireAuthenticationResolver
Visual C++
public ref class DefaultRequireAuthenticationResolver

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.WebDAV.Processors..::..DefaultRequireAuthenticationResolver

See Also

DefaultRequireAuthenticationResolver Members
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultRequireAuthenticationResolver Members

[image] [image]

Sitecore 6.4.1 API
DefaultRequireAuthenticationResolver Members
DefaultRequireAuthenticationResolver Class Constructors Methods See Also Send Feedback

The DefaultRequireAuthenticationResolver type exposes the following members.

Constructors

 | Name | Description
Public method | DefaultRequireAuthenticationResolver | Initializes a new instance of the DefaultRequireAuthenticationResolver class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultRequireAuthenticationResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultRequireAuthenticationResolver Constructor

[image]

Sitecore 6.4.1 API
DefaultRequireAuthenticationResolver Constructor
DefaultRequireAuthenticationResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DefaultRequireAuthenticationResolver()
Visual Basic
Public Sub New
Visual C++
public:
DefaultRequireAuthenticationResolver()

See Also

DefaultRequireAuthenticationResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultRequireAuthenticationResolver Methods

[image] [image]

Sitecore 6.4.1 API
DefaultRequireAuthenticationResolver Methods
DefaultRequireAuthenticationResolver Class See Also Send Feedback

The DefaultRequireAuthenticationResolver type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultRequireAuthenticationResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultResolveWebDAVState Class

[image]

Sitecore 6.4.1 API
DefaultResolveWebDAVState Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DefaultResolveWebDAVState
Visual Basic
Public Class DefaultResolveWebDAVState
Visual C++
public ref class DefaultResolveWebDAVState

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.WebDAV.Processors..::..DefaultResolveWebDAVState

See Also

DefaultResolveWebDAVState Members
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultResolveWebDAVState Members

[image] [image]

Sitecore 6.4.1 API
DefaultResolveWebDAVState Members
DefaultResolveWebDAVState Class Constructors Methods See Also Send Feedback

The DefaultResolveWebDAVState type exposes the following members.

Constructors

 | Name | Description
Public method | DefaultResolveWebDAVState | Initializes a new instance of the DefaultResolveWebDAVState class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultResolveWebDAVState Class
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultResolveWebDAVState Constructor

[image]

Sitecore 6.4.1 API
DefaultResolveWebDAVState Constructor
DefaultResolveWebDAVState Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DefaultResolveWebDAVState()
Visual Basic
Public Sub New
Visual C++
public:
DefaultResolveWebDAVState()

See Also

DefaultResolveWebDAVState Class
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultResolveWebDAVState Methods

[image] [image]

Sitecore 6.4.1 API
DefaultResolveWebDAVState Methods
DefaultResolveWebDAVState Class See Also Send Feedback

The DefaultResolveWebDAVState type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultResolveWebDAVState Class
Sitecore.Pipelines.WebDAV.Processors Namespace


Process Method

[image]

Sitecore 6.4.1 API
DefaultResolveWebDAVState..::..Process Method
DefaultResolveWebDAVState Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    WebDAVPipelineArgs<FeatureState> args
)
Visual Basic
Public Sub Process ( _
    args As WebDAVPipelineArgs(Of FeatureState) _
)
Visual C++
public:
void Process(
    WebDAVPipelineArgs<FeatureState>^ args
)

Parameters

args
Type: Sitecore.Pipelines.WebDAV..::..WebDAVPipelineArgs <(Of <(<' FeatureState >)>)>
The processor arguments.

See Also

DefaultResolveWebDAVState Class
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultRootItemResolver Class

[image]

Sitecore 6.4.1 API
DefaultRootItemResolver Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DefaultRootItemResolver
Visual Basic
Public Class DefaultRootItemResolver
Visual C++
public ref class DefaultRootItemResolver

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.WebDAV.Processors..::..DefaultRootItemResolver

See Also

DefaultRootItemResolver Members
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultRootItemResolver Members

[image] [image]

Sitecore 6.4.1 API
DefaultRootItemResolver Members
DefaultRootItemResolver Class Constructors Methods See Also Send Feedback

The DefaultRootItemResolver type exposes the following members.

Constructors

 | Name | Description
Public method | DefaultRootItemResolver | Initializes a new instance of the DefaultRootItemResolver class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultRootItemResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultRootItemResolver Constructor

[image]

Sitecore 6.4.1 API
DefaultRootItemResolver Constructor
DefaultRootItemResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DefaultRootItemResolver()
Visual Basic
Public Sub New
Visual C++
public:
DefaultRootItemResolver()

See Also

DefaultRootItemResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultRootItemResolver Methods

[image] [image]

Sitecore 6.4.1 API
DefaultRootItemResolver Methods
DefaultRootItemResolver Class See Also Send Feedback

The DefaultRootItemResolver type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultRootItemResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


Process Method

[image]

Sitecore 6.4.1 API
DefaultRootItemResolver..::..Process Method
DefaultRootItemResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    WebDAVPipelineArgs<Item> args
)
Visual Basic
Public Sub Process ( _
    args As WebDAVPipelineArgs(Of Item) _
)
Visual C++
public:
void Process(
    WebDAVPipelineArgs<Item^>^ args
)

Parameters

args
Type: Sitecore.Pipelines.WebDAV..::..WebDAVPipelineArgs <(Of <(<' Item >)>)>
The arguments.

See Also

DefaultRootItemResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultSiteResolver Class

[image]

Sitecore 6.4.1 API
DefaultSiteResolver Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DefaultSiteResolver
Visual Basic
Public Class DefaultSiteResolver
Visual C++
public ref class DefaultSiteResolver

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.WebDAV.Processors..::..DefaultSiteResolver

See Also

DefaultSiteResolver Members
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultSiteResolver Members

[image] [image]

Sitecore 6.4.1 API
DefaultSiteResolver Members
DefaultSiteResolver Class Constructors Methods See Also Send Feedback

The DefaultSiteResolver type exposes the following members.

Constructors

 | Name | Description
Public method | DefaultSiteResolver | Initializes a new instance of the DefaultSiteResolver class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultSiteResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultSiteResolver Constructor

[image]

Sitecore 6.4.1 API
DefaultSiteResolver Constructor
DefaultSiteResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DefaultSiteResolver()
Visual Basic
Public Sub New
Visual C++
public:
DefaultSiteResolver()

See Also

DefaultSiteResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultSiteResolver Methods

[image] [image]

Sitecore 6.4.1 API
DefaultSiteResolver Methods
DefaultSiteResolver Class See Also Send Feedback

The DefaultSiteResolver type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultSiteResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


Process Method

[image]

Sitecore 6.4.1 API
DefaultSiteResolver..::..Process Method
DefaultSiteResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    WebDAVPipelineArgs<string> args
)
Visual Basic
Public Sub Process ( _
    args As WebDAVPipelineArgs(Of String) _
)
Visual C++
public:
void Process(
    WebDAVPipelineArgs<String^>^ args
)

Parameters

args
Type: Sitecore.Pipelines.WebDAV..::..WebDAVPipelineArgs <(Of <(<' String >)>)>
The arguments.

See Also

DefaultSiteResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultSupportWebDAVUrlResolver Members

[image] [image]

Sitecore 6.4.1 API
DefaultSupportWebDAVUrlResolver Members
DefaultSupportWebDAVUrlResolver Class Constructors Methods See Also Send Feedback

The DefaultSupportWebDAVUrlResolver type exposes the following members.

Constructors

 | Name | Description
Public method | DefaultSupportWebDAVUrlResolver | Initializes a new instance of the DefaultSupportWebDAVUrlResolver class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultSupportWebDAVUrlResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultSupportWebDAVUrlResolver Constructor

[image]

Sitecore 6.4.1 API
DefaultSupportWebDAVUrlResolver Constructor
DefaultSupportWebDAVUrlResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DefaultSupportWebDAVUrlResolver()
Visual Basic
Public Sub New
Visual C++
public:
DefaultSupportWebDAVUrlResolver()

See Also

DefaultSupportWebDAVUrlResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultSupportWebDAVUrlResolver Methods

[image] [image]

Sitecore 6.4.1 API
DefaultSupportWebDAVUrlResolver Methods
DefaultSupportWebDAVUrlResolver Class See Also Send Feedback

The DefaultSupportWebDAVUrlResolver type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultSupportWebDAVUrlResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


Process Method

[image]

Sitecore 6.4.1 API
DefaultSupportWebDAVUrlResolver..::..Process Method
DefaultSupportWebDAVUrlResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    WebDAVPipelineArgs<Tristate> args
)
Visual Basic
Public Sub Process ( _
    args As WebDAVPipelineArgs(Of Tristate) _
)
Visual C++
public:
void Process(
    WebDAVPipelineArgs<Tristate>^ args
)

Parameters

args
Type: Sitecore.Pipelines.WebDAV..::..WebDAVPipelineArgs <(Of <(<' Tristate >)>)>
The processor arguments.

See Also

DefaultSupportWebDAVUrlResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultUpdatePropertiesHandler Members

[image] [image]

Sitecore 6.4.1 API
DefaultUpdatePropertiesHandler Members
DefaultUpdatePropertiesHandler Class Constructors Methods See Also Send Feedback

The DefaultUpdatePropertiesHandler type exposes the following members.

Constructors

 | Name | Description
Public method | DefaultUpdatePropertiesHandler | Initializes a new instance of the DefaultUpdatePropertiesHandler class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultUpdatePropertiesHandler Class
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultUpdatePropertiesHandler Constructor

[image]

Sitecore 6.4.1 API
DefaultUpdatePropertiesHandler Constructor
DefaultUpdatePropertiesHandler Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DefaultUpdatePropertiesHandler()
Visual Basic
Public Sub New
Visual C++
public:
DefaultUpdatePropertiesHandler()

See Also

DefaultUpdatePropertiesHandler Class
Sitecore.Pipelines.WebDAV.Processors Namespace


Process Method

[image]

Sitecore 6.4.1 API
DefaultUpdatePropertiesHandler..::..Process Method
DefaultUpdatePropertiesHandler Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    WebDAVProcessPropertiesPipelineArgs args
)
Visual Basic
Public Sub Process ( _
    args As WebDAVProcessPropertiesPipelineArgs _
)
Visual C++
public:
void Process(
    WebDAVProcessPropertiesPipelineArgs^ args
)

Parameters

args
Type: Sitecore.Pipelines.WebDAV..::..WebDAVProcessPropertiesPipelineArgs
The arguments.

See Also

DefaultUpdatePropertiesHandler Class
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultUserResolver Members

[image] [image]

Sitecore 6.4.1 API
DefaultUserResolver Members
DefaultUserResolver Class Constructors Methods See Also Send Feedback

The DefaultUserResolver type exposes the following members.

Constructors

 | Name | Description
Public method | DefaultUserResolver | Initializes a new instance of the DefaultUserResolver class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the User Resolver processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultUserResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultUserResolver Constructor

[image]

Sitecore 6.4.1 API
DefaultUserResolver Constructor
DefaultUserResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DefaultUserResolver()
Visual Basic
Public Sub New
Visual C++
public:
DefaultUserResolver()

See Also

DefaultUserResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultUserResolver Methods

[image] [image]

Sitecore 6.4.1 API
DefaultUserResolver Methods
DefaultUserResolver Class See Also Send Feedback

The DefaultUserResolver type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the User Resolver processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultUserResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


Process Method

[image]

Sitecore 6.4.1 API
DefaultUserResolver..::..Process Method
DefaultUserResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    WebDAVPipelineArgs<User> args
)
Visual Basic
Public Sub Process ( _
    args As WebDAVPipelineArgs(Of User) _
)
Visual C++
public:
void Process(
    WebDAVPipelineArgs<User^>^ args
)

Parameters

args
Type: Sitecore.Pipelines.WebDAV..::..WebDAVPipelineArgs <(Of <(<' User >)>)>
The processor arguments.

See Also

DefaultUserResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultViewResolver Class

[image]

Sitecore 6.4.1 API
DefaultViewResolver Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DefaultViewResolver
Visual Basic
Public Class DefaultViewResolver
Visual C++
public ref class DefaultViewResolver

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.WebDAV.Processors..::..DefaultViewResolver

See Also

DefaultViewResolver Members
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultViewResolver Members

[image] [image]

Sitecore 6.4.1 API
DefaultViewResolver Members
DefaultViewResolver Class Constructors Methods See Also Send Feedback

The DefaultViewResolver type exposes the following members.

Constructors

 | Name | Description
Public method | DefaultViewResolver | Initializes a new instance of the DefaultViewResolver class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultViewResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultViewResolver Constructor

[image]

Sitecore 6.4.1 API
DefaultViewResolver Constructor
DefaultViewResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DefaultViewResolver()
Visual Basic
Public Sub New
Visual C++
public:
DefaultViewResolver()

See Also

DefaultViewResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


DefaultViewResolver Methods

[image] [image]

Sitecore 6.4.1 API
DefaultViewResolver Methods
DefaultViewResolver Class See Also Send Feedback

The DefaultViewResolver type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultViewResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


Process Method

[image]

Sitecore 6.4.1 API
DefaultViewResolver..::..Process Method
DefaultViewResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    WebDAVPipelineArgs<WebDAVView> args
)
Visual Basic
Public Sub Process ( _
    args As WebDAVPipelineArgs(Of WebDAVView) _
)
Visual C++
public:
void Process(
    WebDAVPipelineArgs<WebDAVView^>^ args
)

Parameters

args
Type: Sitecore.Pipelines.WebDAV..::..WebDAVPipelineArgs <(Of <(<' WebDAVView >)>)>
The arguments.

See Also

DefaultViewResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


OptionsDatabaseResolver Class

[image]

Sitecore 6.4.1 API
OptionsDatabaseResolver Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class OptionsDatabaseResolver
Visual Basic
Public Class OptionsDatabaseResolver
Visual C++
public ref class OptionsDatabaseResolver

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.WebDAV.Processors..::..OptionsDatabaseResolver

See Also

OptionsDatabaseResolver Members
Sitecore.Pipelines.WebDAV.Processors Namespace


OptionsDatabaseResolver Members

[image] [image]

Sitecore 6.4.1 API
OptionsDatabaseResolver Members
OptionsDatabaseResolver Class Constructors Methods See Also Send Feedback

The OptionsDatabaseResolver type exposes the following members.

Constructors

 | Name | Description
Public method | OptionsDatabaseResolver | Initializes a new instance of the OptionsDatabaseResolver class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OptionsDatabaseResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


OptionsDatabaseResolver Constructor

[image]

Sitecore 6.4.1 API
OptionsDatabaseResolver Constructor
OptionsDatabaseResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public OptionsDatabaseResolver()
Visual Basic
Public Sub New
Visual C++
public:
OptionsDatabaseResolver()

See Also

OptionsDatabaseResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


OptionsDatabaseResolver Methods

[image] [image]

Sitecore 6.4.1 API
OptionsDatabaseResolver Methods
OptionsDatabaseResolver Class See Also Send Feedback

The OptionsDatabaseResolver type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OptionsDatabaseResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


Process Method

[image]

Sitecore 6.4.1 API
OptionsDatabaseResolver..::..Process Method
OptionsDatabaseResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    WebDAVPipelineArgs<Database> args
)
Visual Basic
Public Sub Process ( _
    args As WebDAVPipelineArgs(Of Database) _
)
Visual C++
public:
void Process(
    WebDAVPipelineArgs<Database^>^ args
)

Parameters

args
Type: Sitecore.Pipelines.WebDAV..::..WebDAVPipelineArgs <(Of <(<' Database >)>)>
The arguments.

See Also

OptionsDatabaseResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


OptionsRequireAuthenticationResolver Members

[image] [image]

Sitecore 6.4.1 API
OptionsRequireAuthenticationResolver Members
OptionsRequireAuthenticationResolver Class Constructors Methods See Also Send Feedback

The OptionsRequireAuthenticationResolver type exposes the following members.

Constructors

 | Name | Description
Public method | OptionsRequireAuthenticationResolver | Initializes a new instance of the OptionsRequireAuthenticationResolver class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OptionsRequireAuthenticationResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


OptionsRequireAuthenticationResolver Constructor

[image]

Sitecore 6.4.1 API
OptionsRequireAuthenticationResolver Constructor
OptionsRequireAuthenticationResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public OptionsRequireAuthenticationResolver()
Visual Basic
Public Sub New
Visual C++
public:
OptionsRequireAuthenticationResolver()

See Also

OptionsRequireAuthenticationResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


OptionsRequireAuthenticationResolver Methods

[image] [image]

Sitecore 6.4.1 API
OptionsRequireAuthenticationResolver Methods
OptionsRequireAuthenticationResolver Class See Also Send Feedback

The OptionsRequireAuthenticationResolver type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OptionsRequireAuthenticationResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


Process Method

[image]

Sitecore 6.4.1 API
OptionsRequireAuthenticationResolver..::..Process Method
OptionsRequireAuthenticationResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    WebDAVPipelineArgs<Tristate> args
)
Visual Basic
Public Sub Process ( _
    args As WebDAVPipelineArgs(Of Tristate) _
)
Visual C++
public:
void Process(
    WebDAVPipelineArgs<Tristate>^ args
)

Parameters

args
Type: Sitecore.Pipelines.WebDAV..::..WebDAVPipelineArgs <(Of <(<' Tristate >)>)>
The processor arguments.

See Also

OptionsRequireAuthenticationResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


OptionsRootItemResolver Class

[image]

Sitecore 6.4.1 API
OptionsRootItemResolver Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class OptionsRootItemResolver
Visual Basic
Public Class OptionsRootItemResolver
Visual C++
public ref class OptionsRootItemResolver

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.WebDAV.Processors..::..OptionsRootItemResolver

See Also

OptionsRootItemResolver Members
Sitecore.Pipelines.WebDAV.Processors Namespace


OptionsRootItemResolver Members

[image] [image]

Sitecore 6.4.1 API
OptionsRootItemResolver Members
OptionsRootItemResolver Class Constructors Methods See Also Send Feedback

The OptionsRootItemResolver type exposes the following members.

Constructors

 | Name | Description
Public method | OptionsRootItemResolver | Initializes a new instance of the OptionsRootItemResolver class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OptionsRootItemResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


OptionsRootItemResolver Constructor

[image]

Sitecore 6.4.1 API
OptionsRootItemResolver Constructor
OptionsRootItemResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public OptionsRootItemResolver()
Visual Basic
Public Sub New
Visual C++
public:
OptionsRootItemResolver()

See Also

OptionsRootItemResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


OptionsRootItemResolver Methods

[image] [image]

Sitecore 6.4.1 API
OptionsRootItemResolver Methods
OptionsRootItemResolver Class See Also Send Feedback

The OptionsRootItemResolver type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OptionsRootItemResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


OptionsSiteResolver Class

[image]

Sitecore 6.4.1 API
OptionsSiteResolver Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class OptionsSiteResolver
Visual Basic
Public Class OptionsSiteResolver
Visual C++
public ref class OptionsSiteResolver

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.WebDAV.Processors..::..OptionsSiteResolver

See Also

OptionsSiteResolver Members
Sitecore.Pipelines.WebDAV.Processors Namespace


OptionsSiteResolver Members

[image] [image]

Sitecore 6.4.1 API
OptionsSiteResolver Members
OptionsSiteResolver Class Constructors Methods See Also Send Feedback

The OptionsSiteResolver type exposes the following members.

Constructors

 | Name | Description
Public method | OptionsSiteResolver | Initializes a new instance of the OptionsSiteResolver class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OptionsSiteResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


OptionsSiteResolver Constructor

[image]

Sitecore 6.4.1 API
OptionsSiteResolver Constructor
OptionsSiteResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public OptionsSiteResolver()
Visual Basic
Public Sub New
Visual C++
public:
OptionsSiteResolver()

See Also

OptionsSiteResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


OptionsSiteResolver Methods

[image] [image]

Sitecore 6.4.1 API
OptionsSiteResolver Methods
OptionsSiteResolver Class See Also Send Feedback

The OptionsSiteResolver type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OptionsSiteResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


Process Method

[image]

Sitecore 6.4.1 API
OptionsSiteResolver..::..Process Method
OptionsSiteResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    WebDAVPipelineArgs<string> args
)
Visual Basic
Public Sub Process ( _
    args As WebDAVPipelineArgs(Of String) _
)
Visual C++
public:
void Process(
    WebDAVPipelineArgs<String^>^ args
)

Parameters

args
Type: Sitecore.Pipelines.WebDAV..::..WebDAVPipelineArgs <(Of <(<' String >)>)>
The arguments.

See Also

OptionsSiteResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


OptionsUserResolver Class

[image]

Sitecore 6.4.1 API
OptionsUserResolver Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class OptionsUserResolver
Visual Basic
Public Class OptionsUserResolver
Visual C++
public ref class OptionsUserResolver

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.WebDAV.Processors..::..OptionsUserResolver

See Also

OptionsUserResolver Members
Sitecore.Pipelines.WebDAV.Processors Namespace


OptionsUserResolver Members

[image] [image]

Sitecore 6.4.1 API
OptionsUserResolver Members
OptionsUserResolver Class Constructors Methods See Also Send Feedback

The OptionsUserResolver type exposes the following members.

Constructors

 | Name | Description
Public method | OptionsUserResolver | Initializes a new instance of the OptionsUserResolver class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OptionsUserResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


OptionsUserResolver Constructor

[image]

Sitecore 6.4.1 API
OptionsUserResolver Constructor
OptionsUserResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public OptionsUserResolver()
Visual Basic
Public Sub New
Visual C++
public:
OptionsUserResolver()

See Also

OptionsUserResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


OptionsUserResolver Methods

[image] [image]

Sitecore 6.4.1 API
OptionsUserResolver Methods
OptionsUserResolver Class See Also Send Feedback

The OptionsUserResolver type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OptionsUserResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


Process Method

[image]

Sitecore 6.4.1 API
OptionsUserResolver..::..Process Method
OptionsUserResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    WebDAVPipelineArgs<User> args
)
Visual Basic
Public Sub Process ( _
    args As WebDAVPipelineArgs(Of User) _
)
Visual C++
public:
void Process(
    WebDAVPipelineArgs<User^>^ args
)

Parameters

args
Type: Sitecore.Pipelines.WebDAV..::..WebDAVPipelineArgs <(Of <(<' User >)>)>
The arguments.

See Also

OptionsUserResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


OptionsViewResolver Class

[image]

Sitecore 6.4.1 API
OptionsViewResolver Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class OptionsViewResolver
Visual Basic
Public Class OptionsViewResolver
Visual C++
public ref class OptionsViewResolver

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.WebDAV.Processors..::..OptionsViewResolver

See Also

OptionsViewResolver Members
Sitecore.Pipelines.WebDAV.Processors Namespace


OptionsViewResolver Members

[image] [image]

Sitecore 6.4.1 API
OptionsViewResolver Members
OptionsViewResolver Class Constructors Methods See Also Send Feedback

The OptionsViewResolver type exposes the following members.

Constructors

 | Name | Description
Public method | OptionsViewResolver | Initializes a new instance of the OptionsViewResolver class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OptionsViewResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


OptionsViewResolver Constructor

[image]

Sitecore 6.4.1 API
OptionsViewResolver Constructor
OptionsViewResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public OptionsViewResolver()
Visual Basic
Public Sub New
Visual C++
public:
OptionsViewResolver()

See Also

OptionsViewResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


OptionsViewResolver Methods

[image] [image]

Sitecore 6.4.1 API
OptionsViewResolver Methods
OptionsViewResolver Class See Also Send Feedback

The OptionsViewResolver type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OptionsViewResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


Process Method

[image]

Sitecore 6.4.1 API
OptionsViewResolver..::..Process Method
OptionsViewResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    WebDAVPipelineArgs<WebDAVView> args
)
Visual Basic
Public Sub Process ( _
    args As WebDAVPipelineArgs(Of WebDAVView) _
)
Visual C++
public:
void Process(
    WebDAVPipelineArgs<WebDAVView^>^ args
)

Parameters

args
Type: Sitecore.Pipelines.WebDAV..::..WebDAVPipelineArgs <(Of <(<' WebDAVView >)>)>
The arguments.

See Also

OptionsViewResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


OptionsWebDAVModeResolver Class

[image]

Sitecore 6.4.1 API
OptionsWebDAVModeResolver Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class OptionsWebDAVModeResolver
Visual Basic
Public Class OptionsWebDAVModeResolver
Visual C++
public ref class OptionsWebDAVModeResolver

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.WebDAV.Processors..::..OptionsWebDAVModeResolver

See Also

OptionsWebDAVModeResolver Members
Sitecore.Pipelines.WebDAV.Processors Namespace


OptionsWebDAVModeResolver Members

[image] [image]

Sitecore 6.4.1 API
OptionsWebDAVModeResolver Members
OptionsWebDAVModeResolver Class Constructors Methods See Also Send Feedback

The OptionsWebDAVModeResolver type exposes the following members.

Constructors

 | Name | Description
Public method | OptionsWebDAVModeResolver | Initializes a new instance of the OptionsWebDAVModeResolver class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OptionsWebDAVModeResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


OptionsWebDAVModeResolver Methods

[image] [image]

Sitecore 6.4.1 API
OptionsWebDAVModeResolver Methods
OptionsWebDAVModeResolver Class See Also Send Feedback

The OptionsWebDAVModeResolver type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OptionsWebDAVModeResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


Process Method

[image]

Sitecore 6.4.1 API
OptionsWebDAVModeResolver..::..Process Method
OptionsWebDAVModeResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    WebDAVPipelineArgs<WebDAVConfiguration..::..WebDAVMode> args
)
Visual Basic
Public Sub Process ( _
    args As WebDAVPipelineArgs(Of WebDAVConfiguration..::..WebDAVMode) _
)
Visual C++
public:
void Process(
    WebDAVPipelineArgs<WebDAVConfiguration..::..WebDAVMode>^ args
)

Parameters

args
Type: Sitecore.Pipelines.WebDAV..::..WebDAVPipelineArgs <(Of <(<' WebDAVConfiguration..::..WebDAVMode >)>)>
The arguments.

See Also

OptionsWebDAVModeResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


ReadOnlyModeValidator Class

[image]

Sitecore 6.4.1 API
ReadOnlyModeValidator Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ReadOnlyModeValidator
Visual Basic
Public Class ReadOnlyModeValidator
Visual C++
public ref class ReadOnlyModeValidator

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.WebDAV.Processors..::..ReadOnlyModeValidator

See Also

ReadOnlyModeValidator Members
Sitecore.Pipelines.WebDAV.Processors Namespace


ReadOnlyModeValidator Members

[image] [image]

Sitecore 6.4.1 API
ReadOnlyModeValidator Members
ReadOnlyModeValidator Class Constructors Methods See Also Send Feedback

The ReadOnlyModeValidator type exposes the following members.

Constructors

 | Name | Description
Public method | ReadOnlyModeValidator | Initializes a new instance of the ReadOnlyModeValidator class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReadOnlyModeValidator Class
Sitecore.Pipelines.WebDAV.Processors Namespace


ReadOnlyModeValidator Constructor

[image]

Sitecore 6.4.1 API
ReadOnlyModeValidator Constructor
ReadOnlyModeValidator Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ReadOnlyModeValidator()
Visual Basic
Public Sub New
Visual C++
public:
ReadOnlyModeValidator()

See Also

ReadOnlyModeValidator Class
Sitecore.Pipelines.WebDAV.Processors Namespace


ReadOnlyModeValidator Methods

[image] [image]

Sitecore 6.4.1 API
ReadOnlyModeValidator Methods
ReadOnlyModeValidator Class See Also Send Feedback

The ReadOnlyModeValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReadOnlyModeValidator Class
Sitecore.Pipelines.WebDAV.Processors Namespace


Process Method

[image]

Sitecore 6.4.1 API
ReadOnlyModeValidator..::..Process Method
ReadOnlyModeValidator Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    ValidateWebDAVOperationPipelineArgs<Tristate> args
)
Visual Basic
Public Sub Process ( _
    args As ValidateWebDAVOperationPipelineArgs(Of Tristate) _
)
Visual C++
public:
void Process(
    ValidateWebDAVOperationPipelineArgs<Tristate>^ args
)

Parameters

args
Type: Sitecore.Pipelines.WebDAV..::..ValidateWebDAVOperationPipelineArgs <(Of <(<' Tristate >)>)>
The arguments.

See Also

ReadOnlyModeValidator Class
Sitecore.Pipelines.WebDAV.Processors Namespace


RequestRequireauthenticationResolver Class

[image]

Sitecore 6.4.1 API
RequestRequireauthenticationResolver Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RequestRequireauthenticationResolver
Visual Basic
Public Class RequestRequireauthenticationResolver
Visual C++
public ref class RequestRequireauthenticationResolver

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.WebDAV.Processors..::..RequestRequireauthenticationResolver

See Also

RequestRequireauthenticationResolver Members
Sitecore.Pipelines.WebDAV.Processors Namespace


RequestRequireauthenticationResolver Members

[image] [image]

Sitecore 6.4.1 API
RequestRequireauthenticationResolver Members
RequestRequireauthenticationResolver Class Constructors Methods See Also Send Feedback

The RequestRequireauthenticationResolver type exposes the following members.

Constructors

 | Name | Description
Public method | RequestRequireauthenticationResolver | Initializes a new instance of the RequestRequireauthenticationResolver class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RequestRequireauthenticationResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


RequestRequireauthenticationResolver Constructor

[image]

Sitecore 6.4.1 API
RequestRequireauthenticationResolver Constructor
RequestRequireauthenticationResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RequestRequireauthenticationResolver()
Visual Basic
Public Sub New
Visual C++
public:
RequestRequireauthenticationResolver()

See Also

RequestRequireauthenticationResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


RequestRequireauthenticationResolver Methods

[image] [image]

Sitecore 6.4.1 API
RequestRequireauthenticationResolver Methods
RequestRequireauthenticationResolver Class See Also Send Feedback

The RequestRequireauthenticationResolver type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RequestRequireauthenticationResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


Process Method

[image]

Sitecore 6.4.1 API
RequestRequireauthenticationResolver..::..Process Method
RequestRequireauthenticationResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    WebDAVPipelineArgs<Tristate> args
)
Visual Basic
Public Sub Process ( _
    args As WebDAVPipelineArgs(Of Tristate) _
)
Visual C++
public:
void Process(
    WebDAVPipelineArgs<Tristate>^ args
)

Parameters

args
Type: Sitecore.Pipelines.WebDAV..::..WebDAVPipelineArgs <(Of <(<' Tristate >)>)>
The processor arguments.

See Also

RequestRequireauthenticationResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


UseDefaultLinkSetting Class

[image]

Sitecore 6.4.1 API
UseDefaultLinkSetting Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class UseDefaultLinkSetting
Visual Basic
Public Class UseDefaultLinkSetting
Visual C++
public ref class UseDefaultLinkSetting

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.WebDAV.Processors..::..UseDefaultLinkSetting

See Also

UseDefaultLinkSetting Members
Sitecore.Pipelines.WebDAV.Processors Namespace


UseDefaultLinkSetting Members

[image] [image]

Sitecore 6.4.1 API
UseDefaultLinkSetting Members
UseDefaultLinkSetting Class Constructors Methods See Also Send Feedback

The UseDefaultLinkSetting type exposes the following members.

Constructors

 | Name | Description
Public method | UseDefaultLinkSetting | Initializes a new instance of the UseDefaultLinkSetting class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UseDefaultLinkSetting Class
Sitecore.Pipelines.WebDAV.Processors Namespace


UseDefaultLinkSetting Constructor

[image]

Sitecore 6.4.1 API
UseDefaultLinkSetting Constructor
UseDefaultLinkSetting Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UseDefaultLinkSetting()
Visual Basic
Public Sub New
Visual C++
public:
UseDefaultLinkSetting()

See Also

UseDefaultLinkSetting Class
Sitecore.Pipelines.WebDAV.Processors Namespace


UseDefaultLinkSetting Methods

[image] [image]

Sitecore 6.4.1 API
UseDefaultLinkSetting Methods
UseDefaultLinkSetting Class See Also Send Feedback

The UseDefaultLinkSetting type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UseDefaultLinkSetting Class
Sitecore.Pipelines.WebDAV.Processors Namespace


Process Method

[image]

Sitecore 6.4.1 API
UseDefaultLinkSetting..::..Process Method
UseDefaultLinkSetting Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    WebDAVPipelineArgs<Tristate> args
)
Visual Basic
Public Sub Process ( _
    args As WebDAVPipelineArgs(Of Tristate) _
)
Visual C++
public:
void Process(
    WebDAVPipelineArgs<Tristate>^ args
)

Parameters

args
Type: Sitecore.Pipelines.WebDAV..::..WebDAVPipelineArgs <(Of <(<' Tristate >)>)>
The processor arguments.

See Also

UseDefaultLinkSetting Class
Sitecore.Pipelines.WebDAV.Processors Namespace


UseLinkBasedOnOS Class

[image]

Sitecore 6.4.1 API
UseLinkBasedOnOS Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class UseLinkBasedOnOS
Visual Basic
Public Class UseLinkBasedOnOS
Visual C++
public ref class UseLinkBasedOnOS

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.WebDAV.Processors..::..UseLinkBasedOnOS

See Also

UseLinkBasedOnOS Members
Sitecore.Pipelines.WebDAV.Processors Namespace


UseLinkBasedOnOS Members

[image] [image]

Sitecore 6.4.1 API
UseLinkBasedOnOS Members
UseLinkBasedOnOS Class Constructors Methods See Also Send Feedback

The UseLinkBasedOnOS type exposes the following members.

Constructors

 | Name | Description
Public method | UseLinkBasedOnOS | Initializes a new instance of the UseLinkBasedOnOS class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UseLinkBasedOnOS Class
Sitecore.Pipelines.WebDAV.Processors Namespace


UseLinkBasedOnOS Constructor

[image]

Sitecore 6.4.1 API
UseLinkBasedOnOS Constructor
UseLinkBasedOnOS Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UseLinkBasedOnOS()
Visual Basic
Public Sub New
Visual C++
public:
UseLinkBasedOnOS()

See Also

UseLinkBasedOnOS Class
Sitecore.Pipelines.WebDAV.Processors Namespace


UseLinkBasedOnOS Methods

[image] [image]

Sitecore 6.4.1 API
UseLinkBasedOnOS Methods
UseLinkBasedOnOS Class See Also Send Feedback

The UseLinkBasedOnOS type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UseLinkBasedOnOS Class
Sitecore.Pipelines.WebDAV.Processors Namespace


Process Method

[image]

Sitecore 6.4.1 API
UseLinkBasedOnOS..::..Process Method
UseLinkBasedOnOS Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    WebDAVPipelineArgs<Tristate> args
)
Visual Basic
Public Sub Process ( _
    args As WebDAVPipelineArgs(Of Tristate) _
)
Visual C++
public:
void Process(
    WebDAVPipelineArgs<Tristate>^ args
)

Parameters

args
Type: Sitecore.Pipelines.WebDAV..::..WebDAVPipelineArgs <(Of <(<' Tristate >)>)>
The processor arguments.

See Also

UseLinkBasedOnOS Class
Sitecore.Pipelines.WebDAV.Processors Namespace


UserOptionsViewResolver Class

[image]

Sitecore 6.4.1 API
UserOptionsViewResolver Class
Members See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class UserOptionsViewResolver
Visual Basic
Public Class UserOptionsViewResolver
Visual C++
public ref class UserOptionsViewResolver

Inheritance Hierarchy

System..::..Object
Sitecore.Pipelines.WebDAV.Processors..::..UserOptionsViewResolver

See Also

UserOptionsViewResolver Members
Sitecore.Pipelines.WebDAV.Processors Namespace


UserOptionsViewResolver Members

[image] [image]

Sitecore 6.4.1 API
UserOptionsViewResolver Members
UserOptionsViewResolver Class Constructors Methods See Also Send Feedback

The UserOptionsViewResolver type exposes the following members.

Constructors

 | Name | Description
Public method | UserOptionsViewResolver | Initializes a new instance of the UserOptionsViewResolver class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UserOptionsViewResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


UserOptionsViewResolver Constructor

[image]

Sitecore 6.4.1 API
UserOptionsViewResolver Constructor
UserOptionsViewResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UserOptionsViewResolver()
Visual Basic
Public Sub New
Visual C++
public:
UserOptionsViewResolver()

See Also

UserOptionsViewResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


UserOptionsViewResolver Methods

[image] [image]

Sitecore 6.4.1 API
UserOptionsViewResolver Methods
UserOptionsViewResolver Class See Also Send Feedback

The UserOptionsViewResolver type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UserOptionsViewResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


Process Method

[image]

Sitecore 6.4.1 API
UserOptionsViewResolver..::..Process Method
UserOptionsViewResolver Class See Also Send Feedback

Namespace: Sitecore.Pipelines.WebDAV.Processors
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    WebDAVPipelineArgs<WebDAVView> args
)
Visual Basic
Public Sub Process ( _
    args As WebDAVPipelineArgs(Of WebDAVView) _
)
Visual C++
public:
void Process(
    WebDAVPipelineArgs<WebDAVView^>^ args
)

Parameters

args
Type: Sitecore.Pipelines.WebDAV..::..WebDAVPipelineArgs <(Of <(<' WebDAVView >)>)>
The arguments.

See Also

UserOptionsViewResolver Class
Sitecore.Pipelines.WebDAV.Processors Namespace


Sitecore.Platform Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Platform Namespace
Send Feedback

Classes

 | Class | Description
Public class | Gdi32 | Represents the Gdi32 DLL.
Public class | Kernel32 | Represents a the Kernel dll.
Public class | Psapi | Represents the Shlwapi DLL.
Public class | Psapi..::..PROCESS_MEMORY_COUNTERS | Win32 memory struct.
Public class | Shell32 | Represents the Shell32 DLL.
Public class | Shlwapi | Represents the Shlwapi DLL.

Structures

 | Structure | Description
Public structure | Shell32..::..SHFILEINFO |
Public structure | Shell32..::..SIZE |
Public structure | Shell32..::..STRRET_ANY |
Public structure | Shell32..::..STRRET_CSTR |

Interfaces

 | Interface | Description
Public interface | Shell32..::..IEnumIDList |
Public interface | Shell32..::..IExtractImage |
Public interface | Shell32..::..IMalloc |
Public interface | Shell32..::..IShellFolder |
Public interface | Shell32..::..IUnknown |

Enumerations

 | Enumeration | Description
Public enumeration | Shell32..::..EIEIFLAG |
Public enumeration | Shell32..::..ESFGAO |
Public enumeration | Shell32..::..ESHCONTF |
Public enumeration | Shell32..::..ESHGDN |
Public enumeration | Shell32..::..ESTRRET |
Public enumeration | Shell32..::..SHGFI |


Gdi32 Class

[image]

Sitecore 6.4.1 API
Gdi32 Class
See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Gdi32
Visual Basic
Public NotInheritable Class Gdi32
Visual C++
public ref class Gdi32 abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Platform..::..Gdi32

See Also

Sitecore.Platform Namespace


Kernel32 Class

[image]

Sitecore 6.4.1 API
Kernel32 Class
Members See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Kernel32
Visual Basic
Public NotInheritable Class Kernel32
Visual C++
public ref class Kernel32 abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Platform..::..Kernel32

See Also

Kernel32 Members
Sitecore.Platform Namespace


Kernel32 Members

[image] [image]

Sitecore 6.4.1 API
Kernel32 Members
Kernel32 Class Methods See Also Send Feedback

The Kernel32 type exposes the following members.

Methods

Name | Description
GetCurrentProcessId | Gets the current process id.
GetCurrentThreadId | Gets the current thread id.
GetTickCount | Gets the tick count.
QueryPerformanceCounter | Queries the performance counter.
QueryPerformanceFrequency | Queries the performance frequency.
SetEnvironmentVariable | Sets the environment variable.

See Also

Kernel32 Class
Sitecore.Platform Namespace


GetCurrentThreadId Method

[image]

Sitecore 6.4.1 API
Kernel32..::..GetCurrentThreadId Method
Kernel32 Class See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int GetCurrentThreadId()
Visual Basic
Public Shared Function GetCurrentThreadId As Integer
Visual C++
public:
static int GetCurrentThreadId()

Return Value

[Missing <returns> documentation for "M:Sitecore.Platform.Kernel32.GetCurrentThreadId"]

See Also

Kernel32 Class
Sitecore.Platform Namespace


GetTickCount Method

[image]

Sitecore 6.4.1 API
Kernel32..::..GetTickCount Method
Kernel32 Class See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static long GetTickCount()
Visual Basic
Public Shared Function GetTickCount As Long
Visual C++
public:
static long long GetTickCount()

Return Value

[Missing <returns> documentation for "M:Sitecore.Platform.Kernel32.GetTickCount"]

See Also

Kernel32 Class
Sitecore.Platform Namespace


QueryPerformanceCounter Method

[image]

Sitecore 6.4.1 API
Kernel32..::..QueryPerformanceCounter Method
Kernel32 Class See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static short QueryPerformanceCounter(
    ref long x
)
Visual Basic
Public Shared Function QueryPerformanceCounter ( _
    ByRef x As Long _
) As Short
Visual C++
public:
static short QueryPerformanceCounter(
    long long% x
)

Parameters

x
Type: System..::..Int64 %
The x.

Return Value

[Missing <returns> documentation for "M:Sitecore.Platform.Kernel32.QueryPerformanceCounter(System.Int64@)"]

See Also

Kernel32 Class
Sitecore.Platform Namespace


QueryPerformanceFrequency Method

[image]

Sitecore 6.4.1 API
Kernel32..::..QueryPerformanceFrequency Method
Kernel32 Class See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static short QueryPerformanceFrequency(
    ref long x
)
Visual Basic
Public Shared Function QueryPerformanceFrequency ( _
    ByRef x As Long _
) As Short
Visual C++
public:
static short QueryPerformanceFrequency(
    long long% x
)

Parameters

x
Type: System..::..Int64 %
The x.

Return Value

[Missing <returns> documentation for "M:Sitecore.Platform.Kernel32.QueryPerformanceFrequency(System.Int64@)"]

See Also

Kernel32 Class
Sitecore.Platform Namespace


SetEnvironmentVariable Method

[image]

Sitecore 6.4.1 API
Kernel32..::..SetEnvironmentVariable Method
Kernel32 Class See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool SetEnvironmentVariable(
    string name,
    string value
)
Visual Basic
Public Shared Function SetEnvironmentVariable ( _
    name As String, _
    value As String _
) As Boolean
Visual C++
public:
static bool SetEnvironmentVariable(
    String^ name,
    String^ value
)

Parameters

name
Type: System..::..String
The name.
value
Type: System..::..String
The value.

Return Value

[Missing <returns> documentation for "M:Sitecore.Platform.Kernel32.SetEnvironmentVariable(System.String,System.String)"]

See Also

Kernel32 Class
Sitecore.Platform Namespace


Psapi Class

[image]

Sitecore 6.4.1 API
Psapi Class
Members See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Psapi
Visual Basic
Public NotInheritable Class Psapi
Visual C++
public ref class Psapi abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Platform..::..Psapi

See Also

Psapi Members
Sitecore.Platform Namespace


Psapi Members

[image] [image]

Sitecore 6.4.1 API
Psapi Members
Psapi Class Methods See Also Send Feedback

The Psapi type exposes the following members.

Methods

Name | Description
GetProcessMemoryInfo | Gets the process memory info.

See Also

Psapi Class
Sitecore.Platform Namespace


Psapi Methods

[image] [image]

Sitecore 6.4.1 API
Psapi Methods
Psapi Class See Also Send Feedback

The Psapi type exposes the following members.

Methods

Name | Description
GetProcessMemoryInfo | Gets the process memory info.

See Also

Psapi Class
Sitecore.Platform Namespace


GetProcessMemoryInfo Method

[image]

Sitecore 6.4.1 API
Psapi..::..GetProcessMemoryInfo Method
Psapi Class See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int GetProcessMemoryInfo(
    int hProcess,
    Psapi..::..PROCESS_MEMORY_COUNTERS counters,
    int size
)
Visual Basic
Public Shared Function GetProcessMemoryInfo ( _
    hProcess As Integer, _
    <OutAttribute> counters As Psapi..::..PROCESS_MEMORY_COUNTERS, _
    size As Integer _
) As Integer
Visual C++
public:
static int GetProcessMemoryInfo(
    int hProcess,
    [OutAttribute] Psapi..::..PROCESS_MEMORY_COUNTERS^ counters,
    int size
)

Parameters

hProcess
Type: System..::..Int32
The h process.
counters
Type: Sitecore.Platform..::..Psapi..::..PROCESS_MEMORY_COUNTERS
The counters.
size
Type: System..::..Int32
The size.

Return Value

[Missing <returns> documentation for "M:Sitecore.Platform.Psapi.GetProcessMemoryInfo(System.Int32,Sitecore.Platform.Psapi.PROCESS_MEMORY_COUNTERS,System.Int32)"]

See Also

Psapi Class
Sitecore.Platform Namespace


Psapi.PROCESS_MEMORY_COUNTERS Constructor

[image]

Sitecore 6.4.1 API
Psapi..::..PROCESS_MEMORY_COUNTERS Constructor
Psapi..::..PROCESS_MEMORY_COUNTERS Class See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PROCESS_MEMORY_COUNTERS()
Visual Basic
Public Sub New
Visual C++
public:
PROCESS_MEMORY_COUNTERS()

See Also

Psapi..::..PROCESS_MEMORY_COUNTERS Class
Sitecore.Platform Namespace


Psapi.PROCESS_MEMORY_COUNTERS Fields

[image] [image]

Sitecore 6.4.1 API
Psapi..::..PROCESS_MEMORY_COUNTERS Fields
Psapi..::..PROCESS_MEMORY_COUNTERS Class See Also Send Feedback

The Psapi..::..PROCESS_MEMORY_COUNTERS type exposes the following members.

Fields

 | Name | Description
Public field | cb | cb
Public field | PageFaultCount | PageFaultCount
Public field | PagefileUsage | PagefileUsage
Public field | PeakPagefileUsage | PeakPagefileUsage
Public field | PeakWorkingSetSize | PeakWorkingSetSize
Public field | QuotaNonPagedPoolUsage | QuotaNonPagedPoolUsage
Public field | QuotaPagedPoolUsage | QuotaPagedPoolUsage
Public field | QuotaPeakNonPagedPoolUsage | QuotaPeakNonPagedPoolUsage
Public field | QuotaPeakPagedPoolUsage | QuotaPeakPagedPoolUsage
Public field | WorkingSetSize | WorkingSetSize

See Also

Psapi..::..PROCESS_MEMORY_COUNTERS Class
Sitecore.Platform Namespace


cb Field

[image]

Sitecore 6.4.1 API
Psapi..::..PROCESS_MEMORY_COUNTERS..::..cb Field
Psapi..::..PROCESS_MEMORY_COUNTERS Class See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int cb
Visual Basic
Public cb As Integer
Visual C++
public:
int cb

See Also

Psapi..::..PROCESS_MEMORY_COUNTERS Class
Sitecore.Platform Namespace


PageFaultCount Field

[image]

Sitecore 6.4.1 API
Psapi..::..PROCESS_MEMORY_COUNTERS..::..PageFaultCount Field
Psapi..::..PROCESS_MEMORY_COUNTERS Class See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int PageFaultCount
Visual Basic
Public PageFaultCount As Integer
Visual C++
public:
int PageFaultCount

See Also

Psapi..::..PROCESS_MEMORY_COUNTERS Class
Sitecore.Platform Namespace


PagefileUsage Field

[image]

Sitecore 6.4.1 API
Psapi..::..PROCESS_MEMORY_COUNTERS..::..PagefileUsage Field
Psapi..::..PROCESS_MEMORY_COUNTERS Class See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int PagefileUsage
Visual Basic
Public PagefileUsage As Integer
Visual C++
public:
int PagefileUsage

See Also

Psapi..::..PROCESS_MEMORY_COUNTERS Class
Sitecore.Platform Namespace


PeakPagefileUsage Field

[image]

Sitecore 6.4.1 API
Psapi..::..PROCESS_MEMORY_COUNTERS..::..PeakPagefileUsage Field
Psapi..::..PROCESS_MEMORY_COUNTERS Class See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int PeakPagefileUsage
Visual Basic
Public PeakPagefileUsage As Integer
Visual C++
public:
int PeakPagefileUsage

See Also

Psapi..::..PROCESS_MEMORY_COUNTERS Class
Sitecore.Platform Namespace


PeakWorkingSetSize Field

[image]

Sitecore 6.4.1 API
Psapi..::..PROCESS_MEMORY_COUNTERS..::..PeakWorkingSetSize Field
Psapi..::..PROCESS_MEMORY_COUNTERS Class See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int PeakWorkingSetSize
Visual Basic
Public PeakWorkingSetSize As Integer
Visual C++
public:
int PeakWorkingSetSize

See Also

Psapi..::..PROCESS_MEMORY_COUNTERS Class
Sitecore.Platform Namespace


QuotaNonPagedPoolUsage Field

[image]

Sitecore 6.4.1 API
Psapi..::..PROCESS_MEMORY_COUNTERS..::..QuotaNonPagedPoolUsage Field
Psapi..::..PROCESS_MEMORY_COUNTERS Class See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int QuotaNonPagedPoolUsage
Visual Basic
Public QuotaNonPagedPoolUsage As Integer
Visual C++
public:
int QuotaNonPagedPoolUsage

See Also

Psapi..::..PROCESS_MEMORY_COUNTERS Class
Sitecore.Platform Namespace


QuotaPagedPoolUsage Field

[image]

Sitecore 6.4.1 API
Psapi..::..PROCESS_MEMORY_COUNTERS..::..QuotaPagedPoolUsage Field
Psapi..::..PROCESS_MEMORY_COUNTERS Class See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int QuotaPagedPoolUsage
Visual Basic
Public QuotaPagedPoolUsage As Integer
Visual C++
public:
int QuotaPagedPoolUsage

See Also

Psapi..::..PROCESS_MEMORY_COUNTERS Class
Sitecore.Platform Namespace


QuotaPeakNonPagedPoolUsage Field

[image]

Sitecore 6.4.1 API
Psapi..::..PROCESS_MEMORY_COUNTERS..::..QuotaPeakNonPagedPoolUsage Field
Psapi..::..PROCESS_MEMORY_COUNTERS Class See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int QuotaPeakNonPagedPoolUsage
Visual Basic
Public QuotaPeakNonPagedPoolUsage As Integer
Visual C++
public:
int QuotaPeakNonPagedPoolUsage

See Also

Psapi..::..PROCESS_MEMORY_COUNTERS Class
Sitecore.Platform Namespace


QuotaPeakPagedPoolUsage Field

[image]

Sitecore 6.4.1 API
Psapi..::..PROCESS_MEMORY_COUNTERS..::..QuotaPeakPagedPoolUsage Field
Psapi..::..PROCESS_MEMORY_COUNTERS Class See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int QuotaPeakPagedPoolUsage
Visual Basic
Public QuotaPeakPagedPoolUsage As Integer
Visual C++
public:
int QuotaPeakPagedPoolUsage

See Also

Psapi..::..PROCESS_MEMORY_COUNTERS Class
Sitecore.Platform Namespace


WorkingSetSize Field

[image]

Sitecore 6.4.1 API
Psapi..::..PROCESS_MEMORY_COUNTERS..::..WorkingSetSize Field
Psapi..::..PROCESS_MEMORY_COUNTERS Class See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int WorkingSetSize
Visual Basic
Public WorkingSetSize As Integer
Visual C++
public:
int WorkingSetSize

See Also

Psapi..::..PROCESS_MEMORY_COUNTERS Class
Sitecore.Platform Namespace


Psapi.PROCESS_MEMORY_COUNTERS Methods

[image] [image]

Sitecore 6.4.1 API
Psapi..::..PROCESS_MEMORY_COUNTERS Methods
Psapi..::..PROCESS_MEMORY_COUNTERS Class See Also Send Feedback

The Psapi..::..PROCESS_MEMORY_COUNTERS type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Psapi..::..PROCESS_MEMORY_COUNTERS Class
Sitecore.Platform Namespace


Shell32 Class

[image]

Sitecore 6.4.1 API
Shell32 Class
Members See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Shell32
Visual Basic
Public NotInheritable Class Shell32
Visual C++
public ref class Shell32 abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Platform..::..Shell32

See Also

Shell32 Members
Sitecore.Platform Namespace


Shell32 Members

[image] [image]

Sitecore 6.4.1 API
Shell32 Members
Shell32 Class Methods See Also Send Feedback

The Shell32 type exposes the following members.

Methods

Name | Description
SHGetFileInfo | SHs the get file info.

See Also

Shell32 Class
Sitecore.Platform Namespace


Shell32 Methods

[image] [image]

Sitecore 6.4.1 API
Shell32 Methods
Shell32 Class See Also Send Feedback

The Shell32 type exposes the following members.

Methods

Name | Description
SHGetFileInfo | SHs the get file info.

See Also

Shell32 Class
Sitecore.Platform Namespace


SHGetFileInfo Method

[image]

Sitecore 6.4.1 API
Shell32..::..SHGetFileInfo Method
Shell32 Class See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int SHGetFileInfo(
    string pszPath,
    int dwFileAttributes,
    out Shell32..::..SHFILEINFO psfi,
    uint cbfileInfo,
    Shell32..::..SHGFI uFlags
)
Visual Basic
Public Shared Function SHGetFileInfo ( _
    pszPath As String, _
    dwFileAttributes As Integer, _
    <OutAttribute> ByRef psfi As Shell32..::..SHFILEINFO, _
    cbfileInfo As UInteger, _
    uFlags As Shell32..::..SHGFI _
) As Integer
Visual C++
public:
static int SHGetFileInfo(
    String^ pszPath,
    int dwFileAttributes,
    [OutAttribute] Shell32..::..SHFILEINFO% psfi,
    unsigned int cbfileInfo,
    Shell32..::..SHGFI uFlags
)

Parameters

pszPath
Type: System..::..String
The PSZ path.
dwFileAttributes
Type: System..::..Int32
The dw file attributes.
psfi
Type: Sitecore.Platform..::..Shell32..::..SHFILEINFO %
The psfi.
cbfileInfo
Type: System..::..UInt32
The cbfile info.
uFlags
Type: Sitecore.Platform..::..Shell32..::..SHGFI
The u flags.

Return Value

[Missing <returns> documentation for "M:Sitecore.Platform.Shell32.SHGetFileInfo(System.String,System.Int32,Sitecore.Platform.Shell32.SHFILEINFO@,System.UInt32,Sitecore.Platform.Shell32.SHGFI)"]

See Also

Shell32 Class
Sitecore.Platform Namespace


Shell32.EIEIFLAG Enumeration

[image]

Sitecore 6.4.1 API
Shell32..::..EIEIFLAG Enumeration
Shell32 Class See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum EIEIFLAG
Visual Basic
Public Enumeration EIEIFLAG
Visual C++
public enum class EIEIFLAG

Members

Member name | Value | Description
IEIFLAG_ASYNC | 1 |
IEIFLAG_CACHE | 2 |
IEIFLAG_ASPECT | 4 |
IEIFLAG_OFFLINE | 8 |
IEIFLAG_GLEAM | 16 |
IEIFLAG_SCREEN | 32 |
IEIFLAG_ORIGSIZE | 64 |
IEIFLAG_NOSTAMP | 128 |
IEIFLAG_NOBORDER | 256 |
IEIFLAG_QUALITY | 512 |

See Also

Sitecore.Platform Namespace


Shell32.ESFGAO Enumeration

[image]

Sitecore 6.4.1 API
Shell32..::..ESFGAO Enumeration
Shell32 Class See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[FlagsAttribute]
public enum ESFGAO
Visual Basic
<FlagsAttribute> _
Public Enumeration ESFGAO
Visual C++
[FlagsAttribute]
public enum class ESFGAO

Members

Member name | Value | Description
SFGAO_CANCOPY | 1 |
SFGAO_CANMOVE | 2 |
SFGAO_CANLINK | 4 |
SFGAO_CANRENAME | 16 |
SFGAO_CANDELETE | 32 |
SFGAO_HASPROPSHEET | 64 |
SFGAO_DROPTARGET | 256 |
SFGAO_CAPABILITYMASK | 375 |
SFGAO_LINK | 65536 |
SFGAO_SHARE | 131072 |
SFGAO_READONLY | 262144 |
SFGAO_GHOSTED | 524288 |
SFGAO_DISPLAYATTRMASK | 983040 |
SFGAO_FILESYSANCESTOR | 268435456 |
SFGAO_FOLDER | 536870912 |
SFGAO_FILESYSTEM | 1073741824 |
SFGAO_HASSUBFOLDER | -2147483648 |
SFGAO_CONTENTSMASK | -2147483648 |
SFGAO_VALIDATE | 16777216 |
SFGAO_REMOVABLE | 33554432 |
SFGAO_COMPRESSED | 67108864 |

See Also

Sitecore.Platform Namespace


Shell32.ESHCONTF Enumeration

[image]

Sitecore 6.4.1 API
Shell32..::..ESHCONTF Enumeration
Shell32 Class See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[FlagsAttribute]
public enum ESHCONTF
Visual Basic
<FlagsAttribute> _
Public Enumeration ESHCONTF
Visual C++
[FlagsAttribute]
public enum class ESHCONTF

Members

Member name | Value | Description
SHCONTF_FOLDERS | 32 |
SHCONTF_NONFOLDERS | 64 |
SHCONTF_INCLUDEHIDDEN | 128 |

See Also

Sitecore.Platform Namespace


Shell32.ESHGDN Enumeration

[image]

Sitecore 6.4.1 API
Shell32..::..ESHGDN Enumeration
Shell32 Class See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[FlagsAttribute]
public enum ESHGDN
Visual Basic
<FlagsAttribute> _
Public Enumeration ESHGDN
Visual C++
[FlagsAttribute]
public enum class ESHGDN

Members

Member name | Value | Description
SHGDN_NORMAL | 0 |
SHGDN_INFOLDER | 1 |
SHGDN_FORADDRESSBAR | 16384 |
SHGDN_FORPARSING | 32768 |

See Also

Sitecore.Platform Namespace


Shell32.ESTRRET Enumeration

[image]

Sitecore 6.4.1 API
Shell32..::..ESTRRET Enumeration
Shell32 Class See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[FlagsAttribute]
public enum ESTRRET
Visual Basic
<FlagsAttribute> _
Public Enumeration ESTRRET
Visual C++
[FlagsAttribute]
public enum class ESTRRET

Members

Member name | Value | Description
STRRET_WSTR | 0 |
STRRET_OFFSET | 1 |
STRRET_CSTR | 2 |

See Also

Sitecore.Platform Namespace


Shell32.IEnumIDList Interface

[image]

Sitecore 6.4.1 API
Shell32..::..IEnumIDList Interface
Shell32 Class Members See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IEnumIDList
Visual Basic
Public Interface IEnumIDList
Visual C++
public interface class IEnumIDList

See Also

Shell32..::..IEnumIDList Members
Sitecore.Platform Namespace


Shell32.IEnumIDList Members

[image] [image]

Sitecore 6.4.1 API
Shell32..::..IEnumIDList Members
Shell32..::..IEnumIDList Interface Methods See Also Send Feedback

Represents the Shell32 DLL.

The Shell32..::..IEnumIDList type exposes the following members.

Methods

 | Name | Description
Public method | Clone |
Public method | Next |
Public method | Reset |
Public method | Skip |

See Also

Shell32..::..IEnumIDList Interface
Sitecore.Platform Namespace


Shell32.IEnumIDList Methods

[image] [image]

Sitecore 6.4.1 API
Shell32..::..IEnumIDList Methods
Shell32..::..IEnumIDList Interface See Also Send Feedback

The Shell32..::..IEnumIDList type exposes the following members.

Methods

 | Name | Description
Public method | Clone |
Public method | Next |
Public method | Reset |
Public method | Skip |

See Also

Shell32..::..IEnumIDList Interface
Sitecore.Platform Namespace


Clone Method

[image]

Sitecore 6.4.1 API
Shell32..::..IEnumIDList..::..Clone Method
Shell32..::..IEnumIDList Interface See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void Clone(
    ref Shell32..::..IEnumIDList ppenum
)
Visual Basic
Sub Clone ( _
    ByRef ppenum As Shell32..::..IEnumIDList _
)
Visual C++
void Clone(
    Shell32..::..IEnumIDList^% ppenum
)

Parameters

ppenum
Type: Sitecore.Platform..::..Shell32..::..IEnumIDList %

[Missing <param name="ppenum"/> documentation for "M:Sitecore.Platform.Shell32.IEnumIDList.Clone(Sitecore.Platform.Shell32.IEnumIDList@)"]

See Also

Shell32..::..IEnumIDList Interface
Sitecore.Platform Namespace


Next Method

[image]

Sitecore 6.4.1 API
Shell32..::..IEnumIDList..::..Next Method
Shell32..::..IEnumIDList Interface See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
int Next(
    int celt,
    ref IntPtr rgelt,
    out int pceltFetched
)
Visual Basic
Function Next ( _
    celt As Integer, _
    ByRef rgelt As IntPtr, _
    <OutAttribute> ByRef pceltFetched As Integer _
) As Integer
Visual C++
int Next(
    int celt,
    IntPtr% rgelt,
    [OutAttribute] int% pceltFetched
)

Parameters

celt
Type: System..::..Int32

[Missing <param name="celt"/> documentation for "M:Sitecore.Platform.Shell32.IEnumIDList.Next(System.Int32,System.IntPtr@,System.Int32@)"]

rgelt
Type: System..::..IntPtr %

[Missing <param name="rgelt"/> documentation for "M:Sitecore.Platform.Shell32.IEnumIDList.Next(System.Int32,System.IntPtr@,System.Int32@)"]

pceltFetched
Type: System..::..Int32 %

[Missing <param name="pceltFetched"/> documentation for "M:Sitecore.Platform.Shell32.IEnumIDList.Next(System.Int32,System.IntPtr@,System.Int32@)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Platform.Shell32.IEnumIDList.Next(System.Int32,System.IntPtr@,System.Int32@)"]

See Also

Shell32..::..IEnumIDList Interface
Sitecore.Platform Namespace


Reset Method

[image]

Sitecore 6.4.1 API
Shell32..::..IEnumIDList..::..Reset Method
Shell32..::..IEnumIDList Interface See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void Reset()
Visual Basic
Sub Reset
Visual C++
void Reset()

See Also

Shell32..::..IEnumIDList Interface
Sitecore.Platform Namespace


Skip Method

[image]

Sitecore 6.4.1 API
Shell32..::..IEnumIDList..::..Skip Method
Shell32..::..IEnumIDList Interface See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void Skip(
    int celt
)
Visual Basic
Sub Skip ( _
    celt As Integer _
)
Visual C++
void Skip(
    int celt
)

Parameters

celt
Type: System..::..Int32

[Missing <param name="celt"/> documentation for "M:Sitecore.Platform.Shell32.IEnumIDList.Skip(System.Int32)"]

See Also

Shell32..::..IEnumIDList Interface
Sitecore.Platform Namespace


Shell32.IExtractImage Interface

[image]

Sitecore 6.4.1 API
Shell32..::..IExtractImage Interface
Shell32 Class Members See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IExtractImage
Visual Basic
Public Interface IExtractImage
Visual C++
public interface class IExtractImage

See Also

Shell32..::..IExtractImage Members
Sitecore.Platform Namespace


Shell32.IExtractImage Members

[image] [image]

Sitecore 6.4.1 API
Shell32..::..IExtractImage Members
Shell32..::..IExtractImage Interface Methods See Also Send Feedback

Represents the Shell32 DLL.

The Shell32..::..IExtractImage type exposes the following members.

Methods

 | Name | Description
Public method | Extract |
Public method | GetLocation |

See Also

Shell32..::..IExtractImage Interface
Sitecore.Platform Namespace


Shell32.IExtractImage Methods

[image] [image]

Sitecore 6.4.1 API
Shell32..::..IExtractImage Methods
Shell32..::..IExtractImage Interface See Also Send Feedback

The Shell32..::..IExtractImage type exposes the following members.

Methods

 | Name | Description
Public method | Extract |
Public method | GetLocation |

See Also

Shell32..::..IExtractImage Interface
Sitecore.Platform Namespace


Extract Method

[image]

Sitecore 6.4.1 API
Shell32..::..IExtractImage..::..Extract Method
Shell32..::..IExtractImage Interface See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void Extract(
    out IntPtr phBmpThumbnail
)
Visual Basic
Sub Extract ( _
    <OutAttribute> ByRef phBmpThumbnail As IntPtr _
)
Visual C++
void Extract(
    [OutAttribute] IntPtr% phBmpThumbnail
)

Parameters

phBmpThumbnail
Type: System..::..IntPtr %

[Missing <param name="phBmpThumbnail"/> documentation for "M:Sitecore.Platform.Shell32.IExtractImage.Extract(System.IntPtr@)"]

See Also

Shell32..::..IExtractImage Interface
Sitecore.Platform Namespace


GetLocation Method

[image]

Sitecore 6.4.1 API
Shell32..::..IExtractImage..::..GetLocation Method
Shell32..::..IExtractImage Interface See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void GetLocation(
    StringBuilder pszPathBuffer,
    int cch,
    ref int pdwPriority,
    ref Shell32..::..SIZE prgSize,
    int dwRecClrDepth,
    ref int pdwFlags
)
Visual Basic
Sub GetLocation ( _
    <OutAttribute> pszPathBuffer As StringBuilder, _
    cch As Integer, _
    ByRef pdwPriority As Integer, _
    ByRef prgSize As Shell32..::..SIZE, _
    dwRecClrDepth As Integer, _
    ByRef pdwFlags As Integer _
)
Visual C++
void GetLocation(
    [OutAttribute] StringBuilder^ pszPathBuffer,
    int cch,
    int% pdwPriority,
    Shell32..::..SIZE% prgSize,
    int dwRecClrDepth,
    int% pdwFlags
)

Parameters

pszPathBuffer
Type: System.Text..::..StringBuilder

[Missing <param name="pszPathBuffer"/> documentation for "M:Sitecore.Platform.Shell32.IExtractImage.GetLocation(System.Text.StringBuilder,System.Int32,System.Int32@,Sitecore.Platform.Shell32.SIZE@,System.Int32,System.Int32@)"]

cch
Type: System..::..Int32

[Missing <param name="cch"/> documentation for "M:Sitecore.Platform.Shell32.IExtractImage.GetLocation(System.Text.StringBuilder,System.Int32,System.Int32@,Sitecore.Platform.Shell32.SIZE@,System.Int32,System.Int32@)"]

pdwPriority
Type: System..::..Int32 %

[Missing <param name="pdwPriority"/> documentation for "M:Sitecore.Platform.Shell32.IExtractImage.GetLocation(System.Text.StringBuilder,System.Int32,System.Int32@,Sitecore.Platform.Shell32.SIZE@,System.Int32,System.Int32@)"]

prgSize
Type: Sitecore.Platform..::..Shell32..::..SIZE %

[Missing <param name="prgSize"/> documentation for "M:Sitecore.Platform.Shell32.IExtractImage.GetLocation(System.Text.StringBuilder,System.Int32,System.Int32@,Sitecore.Platform.Shell32.SIZE@,System.Int32,System.Int32@)"]

dwRecClrDepth
Type: System..::..Int32

[Missing <param name="dwRecClrDepth"/> documentation for "M:Sitecore.Platform.Shell32.IExtractImage.GetLocation(System.Text.StringBuilder,System.Int32,System.Int32@,Sitecore.Platform.Shell32.SIZE@,System.Int32,System.Int32@)"]

pdwFlags
Type: System..::..Int32 %

[Missing <param name="pdwFlags"/> documentation for "M:Sitecore.Platform.Shell32.IExtractImage.GetLocation(System.Text.StringBuilder,System.Int32,System.Int32@,Sitecore.Platform.Shell32.SIZE@,System.Int32,System.Int32@)"]

See Also

Shell32..::..IExtractImage Interface
Sitecore.Platform Namespace


Shell32.IMalloc Interface

[image]

Sitecore 6.4.1 API
Shell32..::..IMalloc Interface
Shell32 Class Members See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IMalloc
Visual Basic
Public Interface IMalloc
Visual C++
public interface class IMalloc

See Also

Shell32..::..IMalloc Members
Sitecore.Platform Namespace


Shell32.IMalloc Methods

[image] [image]

Sitecore 6.4.1 API
Shell32..::..IMalloc Methods
Shell32..::..IMalloc Interface See Also Send Feedback

The Shell32..::..IMalloc type exposes the following members.

Methods

 | Name | Description
Public method | Alloc |
Public method | DidAlloc |
Public method | Free |
Public method | GetSize |
Public method | HeapMinimize |
Public method | Realloc |

See Also

Shell32..::..IMalloc Interface
Sitecore.Platform Namespace


Alloc Method

[image]

Sitecore 6.4.1 API
Shell32..::..IMalloc..::..Alloc Method
Shell32..::..IMalloc Interface See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
IntPtr Alloc(
    int cb
)
Visual Basic
Function Alloc ( _
    cb As Integer _
) As IntPtr
Visual C++
IntPtr Alloc(
    int cb
)

Parameters

cb
Type: System..::..Int32

[Missing <param name="cb"/> documentation for "M:Sitecore.Platform.Shell32.IMalloc.Alloc(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Platform.Shell32.IMalloc.Alloc(System.Int32)"]

See Also

Shell32..::..IMalloc Interface
Sitecore.Platform Namespace


DidAlloc Method

[image]

Sitecore 6.4.1 API
Shell32..::..IMalloc..::..DidAlloc Method
Shell32..::..IMalloc Interface See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
int DidAlloc(
    IntPtr pv
)
Visual Basic
Function DidAlloc ( _
    pv As IntPtr _
) As Integer
Visual C++
int DidAlloc(
    IntPtr pv
)

Parameters

pv
Type: System..::..IntPtr

[Missing <param name="pv"/> documentation for "M:Sitecore.Platform.Shell32.IMalloc.DidAlloc(System.IntPtr)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Platform.Shell32.IMalloc.DidAlloc(System.IntPtr)"]

See Also

Shell32..::..IMalloc Interface
Sitecore.Platform Namespace


Free Method

[image]

Sitecore 6.4.1 API
Shell32..::..IMalloc..::..Free Method
Shell32..::..IMalloc Interface See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void Free(
    IntPtr pv
)
Visual Basic
Sub Free ( _
    pv As IntPtr _
)
Visual C++
void Free(
    IntPtr pv
)

Parameters

pv
Type: System..::..IntPtr

[Missing <param name="pv"/> documentation for "M:Sitecore.Platform.Shell32.IMalloc.Free(System.IntPtr)"]

See Also

Shell32..::..IMalloc Interface
Sitecore.Platform Namespace


GetSize Method

[image]

Sitecore 6.4.1 API
Shell32..::..IMalloc..::..GetSize Method
Shell32..::..IMalloc Interface See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
int GetSize(
    IntPtr pv
)
Visual Basic
Function GetSize ( _
    pv As IntPtr _
) As Integer
Visual C++
int GetSize(
    IntPtr pv
)

Parameters

pv
Type: System..::..IntPtr

[Missing <param name="pv"/> documentation for "M:Sitecore.Platform.Shell32.IMalloc.GetSize(System.IntPtr)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Platform.Shell32.IMalloc.GetSize(System.IntPtr)"]

See Also

Shell32..::..IMalloc Interface
Sitecore.Platform Namespace


HeapMinimize Method

[image]

Sitecore 6.4.1 API
Shell32..::..IMalloc..::..HeapMinimize Method
Shell32..::..IMalloc Interface See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void HeapMinimize()
Visual Basic
Sub HeapMinimize
Visual C++
void HeapMinimize()

See Also

Shell32..::..IMalloc Interface
Sitecore.Platform Namespace


Realloc Method

[image]

Sitecore 6.4.1 API
Shell32..::..IMalloc..::..Realloc Method
Shell32..::..IMalloc Interface See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
IntPtr Realloc(
    IntPtr pv,
    int cb
)
Visual Basic
Function Realloc ( _
    pv As IntPtr, _
    cb As Integer _
) As IntPtr
Visual C++
IntPtr Realloc(
    IntPtr pv,
    int cb
)

Parameters

pv
Type: System..::..IntPtr

[Missing <param name="pv"/> documentation for "M:Sitecore.Platform.Shell32.IMalloc.Realloc(System.IntPtr,System.Int32)"]

cb
Type: System..::..Int32

[Missing <param name="cb"/> documentation for "M:Sitecore.Platform.Shell32.IMalloc.Realloc(System.IntPtr,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Platform.Shell32.IMalloc.Realloc(System.IntPtr,System.Int32)"]

See Also

Shell32..::..IMalloc Interface
Sitecore.Platform Namespace


Shell32.IShellFolder Interface

[image]

Sitecore 6.4.1 API
Shell32..::..IShellFolder Interface
Shell32 Class Members See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IShellFolder
Visual Basic
Public Interface IShellFolder
Visual C++
public interface class IShellFolder

See Also

Shell32..::..IShellFolder Members
Sitecore.Platform Namespace


Shell32.IShellFolder Members

[image] [image]

Sitecore 6.4.1 API
Shell32..::..IShellFolder Members
Shell32..::..IShellFolder Interface Methods See Also Send Feedback

Represents the Shell32 DLL.

The Shell32..::..IShellFolder type exposes the following members.

Methods

 | Name | Description
Public method | BindToObject |
Public method | BindToStorage |
Public method | CompareIDs |
Public method | CreateViewObject |
Public method | EnumObjects |
Public method | GetAttributesOf |
Public method | GetDisplayNameOf |
Public method | GetUIObjectOf |
Public method | ParseDisplayName |
Public method | SetNameOf |

See Also

Shell32..::..IShellFolder Interface
Sitecore.Platform Namespace


Shell32.IShellFolder Methods

[image] [image]

Sitecore 6.4.1 API
Shell32..::..IShellFolder Methods
Shell32..::..IShellFolder Interface See Also Send Feedback

The Shell32..::..IShellFolder type exposes the following members.

Methods

 | Name | Description
Public method | BindToObject |
Public method | BindToStorage |
Public method | CompareIDs |
Public method | CreateViewObject |
Public method | EnumObjects |
Public method | GetAttributesOf |
Public method | GetDisplayNameOf |
Public method | GetUIObjectOf |
Public method | ParseDisplayName |
Public method | SetNameOf |

See Also

Shell32..::..IShellFolder Interface
Sitecore.Platform Namespace


BindToObject Method

[image]

Sitecore 6.4.1 API
Shell32..::..IShellFolder..::..BindToObject Method
Shell32..::..IShellFolder Interface See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void BindToObject(
    IntPtr pidl,
    IntPtr pbcReserved,
    ref Guid riid,
    ref Shell32..::..IShellFolder ppvOut
)
Visual Basic
Sub BindToObject ( _
    pidl As IntPtr, _
    pbcReserved As IntPtr, _
    ByRef riid As Guid, _
    ByRef ppvOut As Shell32..::..IShellFolder _
)
Visual C++
void BindToObject(
    IntPtr pidl,
    IntPtr pbcReserved,
    Guid% riid,
    Shell32..::..IShellFolder^% ppvOut
)

Parameters

pidl
Type: System..::..IntPtr

[Missing <param name="pidl"/> documentation for "M:Sitecore.Platform.Shell32.IShellFolder.BindToObject(System.IntPtr,System.IntPtr,System.Guid@,Sitecore.Platform.Shell32.IShellFolder@)"]

pbcReserved
Type: System..::..IntPtr

[Missing <param name="pbcReserved"/> documentation for "M:Sitecore.Platform.Shell32.IShellFolder.BindToObject(System.IntPtr,System.IntPtr,System.Guid@,Sitecore.Platform.Shell32.IShellFolder@)"]

riid
Type: System..::..Guid %

[Missing <param name="riid"/> documentation for "M:Sitecore.Platform.Shell32.IShellFolder.BindToObject(System.IntPtr,System.IntPtr,System.Guid@,Sitecore.Platform.Shell32.IShellFolder@)"]

ppvOut
Type: Sitecore.Platform..::..Shell32..::..IShellFolder %

[Missing <param name="ppvOut"/> documentation for "M:Sitecore.Platform.Shell32.IShellFolder.BindToObject(System.IntPtr,System.IntPtr,System.Guid@,Sitecore.Platform.Shell32.IShellFolder@)"]

See Also

Shell32..::..IShellFolder Interface
Sitecore.Platform Namespace


BindToStorage Method

[image]

Sitecore 6.4.1 API
Shell32..::..IShellFolder..::..BindToStorage Method
Shell32..::..IShellFolder Interface See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void BindToStorage(
    IntPtr pidl,
    IntPtr pbcReserved,
    ref Guid riid,
    IntPtr ppvObj
)
Visual Basic
Sub BindToStorage ( _
    pidl As IntPtr, _
    pbcReserved As IntPtr, _
    ByRef riid As Guid, _
    ppvObj As IntPtr _
)
Visual C++
void BindToStorage(
    IntPtr pidl,
    IntPtr pbcReserved,
    Guid% riid,
    IntPtr ppvObj
)

Parameters

pidl
Type: System..::..IntPtr

[Missing <param name="pidl"/> documentation for "M:Sitecore.Platform.Shell32.IShellFolder.BindToStorage(System.IntPtr,System.IntPtr,System.Guid@,System.IntPtr)"]

pbcReserved
Type: System..::..IntPtr

[Missing <param name="pbcReserved"/> documentation for "M:Sitecore.Platform.Shell32.IShellFolder.BindToStorage(System.IntPtr,System.IntPtr,System.Guid@,System.IntPtr)"]

riid
Type: System..::..Guid %

[Missing <param name="riid"/> documentation for "M:Sitecore.Platform.Shell32.IShellFolder.BindToStorage(System.IntPtr,System.IntPtr,System.Guid@,System.IntPtr)"]

ppvObj
Type: System..::..IntPtr

[Missing <param name="ppvObj"/> documentation for "M:Sitecore.Platform.Shell32.IShellFolder.BindToStorage(System.IntPtr,System.IntPtr,System.Guid@,System.IntPtr)"]

See Also

Shell32..::..IShellFolder Interface
Sitecore.Platform Namespace


CompareIDs Method

[image]

Sitecore 6.4.1 API
Shell32..::..IShellFolder..::..CompareIDs Method
Shell32..::..IShellFolder Interface See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
int CompareIDs(
    IntPtr lParam,
    IntPtr pidl1,
    IntPtr pidl2
)
Visual Basic
Function CompareIDs ( _
    lParam As IntPtr, _
    pidl1 As IntPtr, _
    pidl2 As IntPtr _
) As Integer
Visual C++
int CompareIDs(
    IntPtr lParam,
    IntPtr pidl1,
    IntPtr pidl2
)

Parameters

lParam
Type: System..::..IntPtr

[Missing <param name="lParam"/> documentation for "M:Sitecore.Platform.Shell32.IShellFolder.CompareIDs(System.IntPtr,System.IntPtr,System.IntPtr)"]

pidl1
Type: System..::..IntPtr

[Missing <param name="pidl1"/> documentation for "M:Sitecore.Platform.Shell32.IShellFolder.CompareIDs(System.IntPtr,System.IntPtr,System.IntPtr)"]

pidl2
Type: System..::..IntPtr

[Missing <param name="pidl2"/> documentation for "M:Sitecore.Platform.Shell32.IShellFolder.CompareIDs(System.IntPtr,System.IntPtr,System.IntPtr)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Platform.Shell32.IShellFolder.CompareIDs(System.IntPtr,System.IntPtr,System.IntPtr)"]

See Also

Shell32..::..IShellFolder Interface
Sitecore.Platform Namespace


EnumObjects Method

[image]

Sitecore 6.4.1 API
Shell32..::..IShellFolder..::..EnumObjects Method
Shell32..::..IShellFolder Interface See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void EnumObjects(
    IntPtr hwndOwner,
    Shell32..::..ESHCONTF grfFlags,
    ref Shell32..::..IEnumIDList ppenumIDList
)
Visual Basic
Sub EnumObjects ( _
    hwndOwner As IntPtr, _
    grfFlags As Shell32..::..ESHCONTF, _
    ByRef ppenumIDList As Shell32..::..IEnumIDList _
)
Visual C++
void EnumObjects(
    IntPtr hwndOwner,
    Shell32..::..ESHCONTF grfFlags,
    Shell32..::..IEnumIDList^% ppenumIDList
)

Parameters

hwndOwner
Type: System..::..IntPtr

[Missing <param name="hwndOwner"/> documentation for "M:Sitecore.Platform.Shell32.IShellFolder.EnumObjects(System.IntPtr,Sitecore.Platform.Shell32.ESHCONTF,Sitecore.Platform.Shell32.IEnumIDList@)"]

grfFlags
Type: Sitecore.Platform..::..Shell32..::..ESHCONTF

[Missing <param name="grfFlags"/> documentation for "M:Sitecore.Platform.Shell32.IShellFolder.EnumObjects(System.IntPtr,Sitecore.Platform.Shell32.ESHCONTF,Sitecore.Platform.Shell32.IEnumIDList@)"]

ppenumIDList
Type: Sitecore.Platform..::..Shell32..::..IEnumIDList %

[Missing <param name="ppenumIDList"/> documentation for "M:Sitecore.Platform.Shell32.IShellFolder.EnumObjects(System.IntPtr,Sitecore.Platform.Shell32.ESHCONTF,Sitecore.Platform.Shell32.IEnumIDList@)"]

See Also

Shell32..::..IShellFolder Interface
Sitecore.Platform Namespace


GetDisplayNameOf Method

[image]

Sitecore 6.4.1 API
Shell32..::..IShellFolder..::..GetDisplayNameOf Method
Shell32..::..IShellFolder Interface See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void GetDisplayNameOf(
    IntPtr pidl,
    Shell32..::..ESHGDN uFlags,
    ref Shell32..::..STRRET_CSTR lpName
)
Visual Basic
Sub GetDisplayNameOf ( _
    pidl As IntPtr, _
    uFlags As Shell32..::..ESHGDN, _
    ByRef lpName As Shell32..::..STRRET_CSTR _
)
Visual C++
void GetDisplayNameOf(
    IntPtr pidl,
    Shell32..::..ESHGDN uFlags,
    Shell32..::..STRRET_CSTR% lpName
)

Parameters

pidl
Type: System..::..IntPtr

[Missing <param name="pidl"/> documentation for "M:Sitecore.Platform.Shell32.IShellFolder.GetDisplayNameOf(System.IntPtr,Sitecore.Platform.Shell32.ESHGDN,Sitecore.Platform.Shell32.STRRET_CSTR@)"]

uFlags
Type: Sitecore.Platform..::..Shell32..::..ESHGDN

[Missing <param name="uFlags"/> documentation for "M:Sitecore.Platform.Shell32.IShellFolder.GetDisplayNameOf(System.IntPtr,Sitecore.Platform.Shell32.ESHGDN,Sitecore.Platform.Shell32.STRRET_CSTR@)"]

lpName
Type: Sitecore.Platform..::..Shell32..::..STRRET_CSTR %

[Missing <param name="lpName"/> documentation for "M:Sitecore.Platform.Shell32.IShellFolder.GetDisplayNameOf(System.IntPtr,Sitecore.Platform.Shell32.ESHGDN,Sitecore.Platform.Shell32.STRRET_CSTR@)"]

See Also

Shell32..::..IShellFolder Interface
Sitecore.Platform Namespace


GetUIObjectOf Method

[image]

Sitecore 6.4.1 API
Shell32..::..IShellFolder..::..GetUIObjectOf Method
Shell32..::..IShellFolder Interface See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void GetUIObjectOf(
    IntPtr hwndOwner,
    int cidl,
    ref IntPtr apidl,
    ref Guid riid,
    out int prgfInOut,
    ref Shell32..::..IUnknown ppvOut
)
Visual Basic
Sub GetUIObjectOf ( _
    hwndOwner As IntPtr, _
    cidl As Integer, _
    ByRef apidl As IntPtr, _
    ByRef riid As Guid, _
    <OutAttribute> ByRef prgfInOut As Integer, _
    ByRef ppvOut As Shell32..::..IUnknown _
)
Visual C++
void GetUIObjectOf(
    IntPtr hwndOwner,
    int cidl,
    IntPtr% apidl,
    Guid% riid,
    [OutAttribute] int% prgfInOut,
    Shell32..::..IUnknown^% ppvOut
)

Parameters

hwndOwner
Type: System..::..IntPtr

[Missing <param name="hwndOwner"/> documentation for "M:Sitecore.Platform.Shell32.IShellFolder.GetUIObjectOf(System.IntPtr,System.Int32,System.IntPtr@,System.Guid@,System.Int32@,Sitecore.Platform.Shell32.IUnknown@)"]

cidl
Type: System..::..Int32

[Missing <param name="cidl"/> documentation for "M:Sitecore.Platform.Shell32.IShellFolder.GetUIObjectOf(System.IntPtr,System.Int32,System.IntPtr@,System.Guid@,System.Int32@,Sitecore.Platform.Shell32.IUnknown@)"]

apidl
Type: System..::..IntPtr %

[Missing <param name="apidl"/> documentation for "M:Sitecore.Platform.Shell32.IShellFolder.GetUIObjectOf(System.IntPtr,System.Int32,System.IntPtr@,System.Guid@,System.Int32@,Sitecore.Platform.Shell32.IUnknown@)"]

riid
Type: System..::..Guid %

[Missing <param name="riid"/> documentation for "M:Sitecore.Platform.Shell32.IShellFolder.GetUIObjectOf(System.IntPtr,System.Int32,System.IntPtr@,System.Guid@,System.Int32@,Sitecore.Platform.Shell32.IUnknown@)"]

prgfInOut
Type: System..::..Int32 %

[Missing <param name="prgfInOut"/> documentation for "M:Sitecore.Platform.Shell32.IShellFolder.GetUIObjectOf(System.IntPtr,System.Int32,System.IntPtr@,System.Guid@,System.Int32@,Sitecore.Platform.Shell32.IUnknown@)"]

ppvOut
Type: Sitecore.Platform..::..Shell32..::..IUnknown %

[Missing <param name="ppvOut"/> documentation for "M:Sitecore.Platform.Shell32.IShellFolder.GetUIObjectOf(System.IntPtr,System.Int32,System.IntPtr@,System.Guid@,System.Int32@,Sitecore.Platform.Shell32.IUnknown@)"]

See Also

Shell32..::..IShellFolder Interface
Sitecore.Platform Namespace


ParseDisplayName Method

[image]

Sitecore 6.4.1 API
Shell32..::..IShellFolder..::..ParseDisplayName Method
Shell32..::..IShellFolder Interface See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void ParseDisplayName(
    IntPtr hwndOwner,
    IntPtr pbcReserved,
    string lpszDisplayName,
    out int pchEaten,
    out IntPtr ppidl,
    out int pdwAttributes
)
Visual Basic
Sub ParseDisplayName ( _
    hwndOwner As IntPtr, _
    pbcReserved As IntPtr, _
    lpszDisplayName As String, _
    <OutAttribute> ByRef pchEaten As Integer, _
    <OutAttribute> ByRef ppidl As IntPtr, _
    <OutAttribute> ByRef pdwAttributes As Integer _
)
Visual C++
void ParseDisplayName(
    IntPtr hwndOwner,
    IntPtr pbcReserved,
    String^ lpszDisplayName,
    [OutAttribute] int% pchEaten,
    [OutAttribute] IntPtr% ppidl,
    [OutAttribute] int% pdwAttributes
)

Parameters

hwndOwner
Type: System..::..IntPtr

[Missing <param name="hwndOwner"/> documentation for "M:Sitecore.Platform.Shell32.IShellFolder.ParseDisplayName(System.IntPtr,System.IntPtr,System.String,System.Int32@,System.IntPtr@,System.Int32@)"]

pbcReserved
Type: System..::..IntPtr

[Missing <param name="pbcReserved"/> documentation for "M:Sitecore.Platform.Shell32.IShellFolder.ParseDisplayName(System.IntPtr,System.IntPtr,System.String,System.Int32@,System.IntPtr@,System.Int32@)"]

lpszDisplayName
Type: System..::..String

[Missing <param name="lpszDisplayName"/> documentation for "M:Sitecore.Platform.Shell32.IShellFolder.ParseDisplayName(System.IntPtr,System.IntPtr,System.String,System.Int32@,System.IntPtr@,System.Int32@)"]

pchEaten
Type: System..::..Int32 %

[Missing <param name="pchEaten"/> documentation for "M:Sitecore.Platform.Shell32.IShellFolder.ParseDisplayName(System.IntPtr,System.IntPtr,System.String,System.Int32@,System.IntPtr@,System.Int32@)"]

ppidl
Type: System..::..IntPtr %

[Missing <param name="ppidl"/> documentation for "M:Sitecore.Platform.Shell32.IShellFolder.ParseDisplayName(System.IntPtr,System.IntPtr,System.String,System.Int32@,System.IntPtr@,System.Int32@)"]

pdwAttributes
Type: System..::..Int32 %

[Missing <param name="pdwAttributes"/> documentation for "M:Sitecore.Platform.Shell32.IShellFolder.ParseDisplayName(System.IntPtr,System.IntPtr,System.String,System.Int32@,System.IntPtr@,System.Int32@)"]

See Also

Shell32..::..IShellFolder Interface
Sitecore.Platform Namespace


SetNameOf Method

[image]

Sitecore 6.4.1 API
Shell32..::..IShellFolder..::..SetNameOf Method
Shell32..::..IShellFolder Interface See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void SetNameOf(
    IntPtr hwndOwner,
    IntPtr pidl,
    string lpszName,
    Shell32..::..ESHCONTF uFlags,
    ref IntPtr ppidlOut
)
Visual Basic
Sub SetNameOf ( _
    hwndOwner As IntPtr, _
    pidl As IntPtr, _
    lpszName As String, _
    uFlags As Shell32..::..ESHCONTF, _
    ByRef ppidlOut As IntPtr _
)
Visual C++
void SetNameOf(
    IntPtr hwndOwner,
    IntPtr pidl,
    String^ lpszName,
    Shell32..::..ESHCONTF uFlags,
    IntPtr% ppidlOut
)

Parameters

hwndOwner
Type: System..::..IntPtr

[Missing <param name="hwndOwner"/> documentation for "M:Sitecore.Platform.Shell32.IShellFolder.SetNameOf(System.IntPtr,System.IntPtr,System.String,Sitecore.Platform.Shell32.ESHCONTF,System.IntPtr@)"]

pidl
Type: System..::..IntPtr

[Missing <param name="pidl"/> documentation for "M:Sitecore.Platform.Shell32.IShellFolder.SetNameOf(System.IntPtr,System.IntPtr,System.String,Sitecore.Platform.Shell32.ESHCONTF,System.IntPtr@)"]

lpszName
Type: System..::..String

[Missing <param name="lpszName"/> documentation for "M:Sitecore.Platform.Shell32.IShellFolder.SetNameOf(System.IntPtr,System.IntPtr,System.String,Sitecore.Platform.Shell32.ESHCONTF,System.IntPtr@)"]

uFlags
Type: Sitecore.Platform..::..Shell32..::..ESHCONTF

[Missing <param name="uFlags"/> documentation for "M:Sitecore.Platform.Shell32.IShellFolder.SetNameOf(System.IntPtr,System.IntPtr,System.String,Sitecore.Platform.Shell32.ESHCONTF,System.IntPtr@)"]

ppidlOut
Type: System..::..IntPtr %

[Missing <param name="ppidlOut"/> documentation for "M:Sitecore.Platform.Shell32.IShellFolder.SetNameOf(System.IntPtr,System.IntPtr,System.String,Sitecore.Platform.Shell32.ESHCONTF,System.IntPtr@)"]

See Also

Shell32..::..IShellFolder Interface
Sitecore.Platform Namespace


Shell32.IUnknown Interface

[image]

Sitecore 6.4.1 API
Shell32..::..IUnknown Interface
Shell32 Class Members See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IUnknown
Visual Basic
Public Interface IUnknown
Visual C++
public interface class IUnknown

See Also

Shell32..::..IUnknown Members
Sitecore.Platform Namespace


Shell32.IUnknown Methods

[image] [image]

Sitecore 6.4.1 API
Shell32..::..IUnknown Methods
Shell32..::..IUnknown Interface See Also Send Feedback

The Shell32..::..IUnknown type exposes the following members.

Methods

 | Name | Description
Public method | AddRef |
Public method | QueryInterface |
Public method | Release |

See Also

Shell32..::..IUnknown Interface
Sitecore.Platform Namespace


AddRef Method

[image]

Sitecore 6.4.1 API
Shell32..::..IUnknown..::..AddRef Method
Shell32..::..IUnknown Interface See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
IntPtr AddRef()
Visual Basic
Function AddRef As IntPtr
Visual C++
IntPtr AddRef()

Return Value

[Missing <returns> documentation for "M:Sitecore.Platform.Shell32.IUnknown.AddRef"]

See Also

Shell32..::..IUnknown Interface
Sitecore.Platform Namespace


QueryInterface Method

[image]

Sitecore 6.4.1 API
Shell32..::..IUnknown..::..QueryInterface Method
Shell32..::..IUnknown Interface See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
IntPtr QueryInterface(
    ref Guid riid,
    out IntPtr pVoid
)
Visual Basic
Function QueryInterface ( _
    ByRef riid As Guid, _
    <OutAttribute> ByRef pVoid As IntPtr _
) As IntPtr
Visual C++
IntPtr QueryInterface(
    Guid% riid,
    [OutAttribute] IntPtr% pVoid
)

Parameters

riid
Type: System..::..Guid %

[Missing <param name="riid"/> documentation for "M:Sitecore.Platform.Shell32.IUnknown.QueryInterface(System.Guid@,System.IntPtr@)"]

pVoid
Type: System..::..IntPtr %

[Missing <param name="pVoid"/> documentation for "M:Sitecore.Platform.Shell32.IUnknown.QueryInterface(System.Guid@,System.IntPtr@)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Platform.Shell32.IUnknown.QueryInterface(System.Guid@,System.IntPtr@)"]

See Also

Shell32..::..IUnknown Interface
Sitecore.Platform Namespace


Release Method

[image]

Sitecore 6.4.1 API
Shell32..::..IUnknown..::..Release Method
Shell32..::..IUnknown Interface See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
IntPtr Release()
Visual Basic
Function Release As IntPtr
Visual C++
IntPtr Release()

Return Value

[Missing <returns> documentation for "M:Sitecore.Platform.Shell32.IUnknown.Release"]

See Also

Shell32..::..IUnknown Interface
Sitecore.Platform Namespace


Shell32.SHFILEINFO Structure

[image]

Sitecore 6.4.1 API
Shell32..::..SHFILEINFO Structure
Shell32 Class Members See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public struct SHFILEINFO
Visual Basic
Public Structure SHFILEINFO
Visual C++
public value class SHFILEINFO

See Also

Shell32..::..SHFILEINFO Members
Sitecore.Platform Namespace


Shell32.SHFILEINFO Members

[image] [image]

Sitecore 6.4.1 API
Shell32..::..SHFILEINFO Members
Shell32..::..SHFILEINFO Structure Constructors Methods Fields See Also Send Feedback

Represents the Shell32 DLL.

The Shell32..::..SHFILEINFO type exposes the following members.

Constructors

 | Name | Description
Public method | Shell32..::..SHFILEINFO | Initializes a new instance of the Shell32..::..SHFILEINFO class

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | dwAttributes |
Public field | hIcon |
Public field | iIcon |
Public field | szDisplayName |
Public field | szTypeName |

See Also

Shell32..::..SHFILEINFO Structure
Sitecore.Platform Namespace


Shell32.SHFILEINFO Constructor

[image]

Sitecore 6.4.1 API
Shell32..::..SHFILEINFO Constructor
Shell32..::..SHFILEINFO Structure See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SHFILEINFO(
    bool b
)
Visual Basic
Public Sub New ( _
    b As Boolean _
)
Visual C++
public:
SHFILEINFO(
    bool b
)

Parameters

b
Type: System..::..Boolean

[Missing <param name="b"/> documentation for "M:Sitecore.Platform.Shell32.SHFILEINFO.#ctor(System.Boolean)"]

See Also

Shell32..::..SHFILEINFO Structure
Sitecore.Platform Namespace


Shell32.SHFILEINFO Fields

[image] [image]

Sitecore 6.4.1 API
Shell32..::..SHFILEINFO Fields
Shell32..::..SHFILEINFO Structure See Also Send Feedback

The Shell32..::..SHFILEINFO type exposes the following members.

Fields

 | Name | Description
Public field | dwAttributes |
Public field | hIcon |
Public field | iIcon |
Public field | szDisplayName |
Public field | szTypeName |

See Also

Shell32..::..SHFILEINFO Structure
Sitecore.Platform Namespace


dwAttributes Field

[image]

Sitecore 6.4.1 API
Shell32..::..SHFILEINFO..::..dwAttributes Field
Shell32..::..SHFILEINFO Structure See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public uint dwAttributes
Visual Basic
Public dwAttributes As UInteger
Visual C++
public:
unsigned int dwAttributes

See Also

Shell32..::..SHFILEINFO Structure
Sitecore.Platform Namespace


hIcon Field

[image]

Sitecore 6.4.1 API
Shell32..::..SHFILEINFO..::..hIcon Field
Shell32..::..SHFILEINFO Structure See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IntPtr hIcon
Visual Basic
Public hIcon As IntPtr
Visual C++
public:
IntPtr hIcon

See Also

Shell32..::..SHFILEINFO Structure
Sitecore.Platform Namespace


iIcon Field

[image]

Sitecore 6.4.1 API
Shell32..::..SHFILEINFO..::..iIcon Field
Shell32..::..SHFILEINFO Structure See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int iIcon
Visual Basic
Public iIcon As Integer
Visual C++
public:
int iIcon

See Also

Shell32..::..SHFILEINFO Structure
Sitecore.Platform Namespace


szDisplayName Field

[image]

Sitecore 6.4.1 API
Shell32..::..SHFILEINFO..::..szDisplayName Field
Shell32..::..SHFILEINFO Structure See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string szDisplayName
Visual Basic
Public szDisplayName As String
Visual C++
public:
String^ szDisplayName

See Also

Shell32..::..SHFILEINFO Structure
Sitecore.Platform Namespace


szTypeName Field

[image]

Sitecore 6.4.1 API
Shell32..::..SHFILEINFO..::..szTypeName Field
Shell32..::..SHFILEINFO Structure See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string szTypeName
Visual Basic
Public szTypeName As String
Visual C++
public:
String^ szTypeName

See Also

Shell32..::..SHFILEINFO Structure
Sitecore.Platform Namespace


Shell32.SHFILEINFO Methods

[image] [image]

Sitecore 6.4.1 API
Shell32..::..SHFILEINFO Methods
Shell32..::..SHFILEINFO Structure See Also Send Feedback

The Shell32..::..SHFILEINFO type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

Shell32..::..SHFILEINFO Structure
Sitecore.Platform Namespace


Shell32.SHGFI Enumeration

[image]

Sitecore 6.4.1 API
Shell32..::..SHGFI Enumeration
Shell32 Class See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[FlagsAttribute]
public enum SHGFI
Visual Basic
<FlagsAttribute> _
Public Enumeration SHGFI
Visual C++
[FlagsAttribute]
public enum class SHGFI

Members

Member name | Value | Description
Icon | 256 | get icon
DisplayName | 512 | get display name
TypeName | 1024 | get type name
Attributes | 2048 | get attributes
IconLocation | 4096 | get icon location
ExeType | 8192 | return exe type
SysIconIndex | 16384 | get system icon index
LinkOverlay | 32768 | put a link overlay on icon
Selected | 65536 | show icon in selected state
Attr_Specified | 131072 | get only specified attributes
LargeIcon | 0 | get large icon
SmallIcon | 1 | get small icon
OpenIcon | 2 | get open icon
ShellIconize | 4 | get shell size icon
PIDL | 8 | pszPath is a pidl
UseFileAttributes | 16 | use passed dwFileAttribute
AddOverlays | 32 | apply the appropriate overlays
OverlayIndex | 64 | Get the index of the overlay in the upper 8 bits of the iIcon

See Also

Sitecore.Platform Namespace


Shell32.SIZE Structure

[image]

Sitecore 6.4.1 API
Shell32..::..SIZE Structure
Shell32 Class Members See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public struct SIZE
Visual Basic
Public Structure SIZE
Visual C++
public value class SIZE

See Also

Shell32..::..SIZE Members
Sitecore.Platform Namespace


Shell32.SIZE Fields

[image] [image]

Sitecore 6.4.1 API
Shell32..::..SIZE Fields
Shell32..::..SIZE Structure See Also Send Feedback

The Shell32..::..SIZE type exposes the following members.

Fields

 | Name | Description
Public field | cx |
Public field | cy |

See Also

Shell32..::..SIZE Structure
Sitecore.Platform Namespace


cx Field

[image]

Sitecore 6.4.1 API
Shell32..::..SIZE..::..cx Field
Shell32..::..SIZE Structure See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int cx
Visual Basic
Public cx As Integer
Visual C++
public:
int cx

See Also

Shell32..::..SIZE Structure
Sitecore.Platform Namespace


cy Field

[image]

Sitecore 6.4.1 API
Shell32..::..SIZE..::..cy Field
Shell32..::..SIZE Structure See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int cy
Visual Basic
Public cy As Integer
Visual C++
public:
int cy

See Also

Shell32..::..SIZE Structure
Sitecore.Platform Namespace


Shell32.SIZE Methods

[image] [image]

Sitecore 6.4.1 API
Shell32..::..SIZE Methods
Shell32..::..SIZE Structure See Also Send Feedback

The Shell32..::..SIZE type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

Shell32..::..SIZE Structure
Sitecore.Platform Namespace


Shell32.STRRET_ANY Structure

[image]

Sitecore 6.4.1 API
Shell32..::..STRRET_ANY Structure
Shell32 Class Members See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public struct STRRET_ANY
Visual Basic
Public Structure STRRET_ANY
Visual C++
public value class STRRET_ANY

See Also

Shell32..::..STRRET_ANY Members
Sitecore.Platform Namespace


Shell32.STRRET_ANY Members

[image] [image]

Sitecore 6.4.1 API
Shell32..::..STRRET_ANY Members
Shell32..::..STRRET_ANY Structure Methods Fields See Also Send Feedback

Represents the Shell32 DLL.

The Shell32..::..STRRET_ANY type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | pOLEString |
Public field | uType |

See Also

Shell32..::..STRRET_ANY Structure
Sitecore.Platform Namespace


Shell32.STRRET_ANY Fields

[image] [image]

Sitecore 6.4.1 API
Shell32..::..STRRET_ANY Fields
Shell32..::..STRRET_ANY Structure See Also Send Feedback

The Shell32..::..STRRET_ANY type exposes the following members.

Fields

 | Name | Description
Public field | pOLEString |
Public field | uType |

See Also

Shell32..::..STRRET_ANY Structure
Sitecore.Platform Namespace


pOLEString Field

[image]

Sitecore 6.4.1 API
Shell32..::..STRRET_ANY..::..pOLEString Field
Shell32..::..STRRET_ANY Structure See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IntPtr pOLEString
Visual Basic
Public pOLEString As IntPtr
Visual C++
public:
IntPtr pOLEString

See Also

Shell32..::..STRRET_ANY Structure
Sitecore.Platform Namespace


uType Field

[image]

Sitecore 6.4.1 API
Shell32..::..STRRET_ANY..::..uType Field
Shell32..::..STRRET_ANY Structure See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Shell32..::..ESTRRET uType
Visual Basic
Public uType As Shell32..::..ESTRRET
Visual C++
public:
Shell32..::..ESTRRET uType

See Also

Shell32..::..STRRET_ANY Structure
Sitecore.Platform Namespace


Shell32.STRRET_ANY Methods

[image] [image]

Sitecore 6.4.1 API
Shell32..::..STRRET_ANY Methods
Shell32..::..STRRET_ANY Structure See Also Send Feedback

The Shell32..::..STRRET_ANY type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

Shell32..::..STRRET_ANY Structure
Sitecore.Platform Namespace


Shell32.STRRET_CSTR Structure

[image]

Sitecore 6.4.1 API
Shell32..::..STRRET_CSTR Structure
Shell32 Class Members See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public struct STRRET_CSTR
Visual Basic
Public Structure STRRET_CSTR
Visual C++
public value class STRRET_CSTR

See Also

Shell32..::..STRRET_CSTR Members
Sitecore.Platform Namespace


Shell32.STRRET_CSTR Members

[image] [image]

Sitecore 6.4.1 API
Shell32..::..STRRET_CSTR Members
Shell32..::..STRRET_CSTR Structure Methods Fields See Also Send Feedback

Represents the Shell32 DLL.

The Shell32..::..STRRET_CSTR type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | cStr |
Public field | uType |

See Also

Shell32..::..STRRET_CSTR Structure
Sitecore.Platform Namespace


Shell32.STRRET_CSTR Fields

[image] [image]

Sitecore 6.4.1 API
Shell32..::..STRRET_CSTR Fields
Shell32..::..STRRET_CSTR Structure See Also Send Feedback

The Shell32..::..STRRET_CSTR type exposes the following members.

Fields

 | Name | Description
Public field | cStr |
Public field | uType |

See Also

Shell32..::..STRRET_CSTR Structure
Sitecore.Platform Namespace


uType Field

[image]

Sitecore 6.4.1 API
Shell32..::..STRRET_CSTR..::..uType Field
Shell32..::..STRRET_CSTR Structure See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Shell32..::..ESTRRET uType
Visual Basic
Public uType As Shell32..::..ESTRRET
Visual C++
public:
Shell32..::..ESTRRET uType

See Also

Shell32..::..STRRET_CSTR Structure
Sitecore.Platform Namespace


Shell32.STRRET_CSTR Methods

[image] [image]

Sitecore 6.4.1 API
Shell32..::..STRRET_CSTR Methods
Shell32..::..STRRET_CSTR Structure See Also Send Feedback

The Shell32..::..STRRET_CSTR type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

Shell32..::..STRRET_CSTR Structure
Sitecore.Platform Namespace


Shlwapi Class

[image]

Sitecore 6.4.1 API
Shlwapi Class
Members See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Shlwapi
Visual Basic
Public NotInheritable Class Shlwapi
Visual C++
public ref class Shlwapi abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Platform..::..Shlwapi

See Also

Shlwapi Members
Sitecore.Platform Namespace


Shlwapi Methods

[image] [image]

Sitecore 6.4.1 API
Shlwapi Methods
Shlwapi Class See Also Send Feedback

The Shlwapi type exposes the following members.

Methods

Name | Description
StrCmpLogicalW | STRs the CMP logical W.

See Also

Shlwapi Class
Sitecore.Platform Namespace


StrCmpLogicalW Method

[image]

Sitecore 6.4.1 API
Shlwapi..::..StrCmpLogicalW Method
Shlwapi Class See Also Send Feedback

Namespace: Sitecore.Platform
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int StrCmpLogicalW(
    string strA,
    string strB
)
Visual Basic
Public Shared Function StrCmpLogicalW ( _
    strA As String, _
    strB As String _
) As Integer
Visual C++
public:
static int StrCmpLogicalW(
    String^ strA,
    String^ strB
)

Parameters

strA
Type: System..::..String
The STR A.
strB
Type: System..::..String
The STR B.

Return Value

[Missing <returns> documentation for "M:Sitecore.Platform.Shlwapi.StrCmpLogicalW(System.String,System.String)"]

See Also

Shlwapi Class
Sitecore.Platform Namespace


Sitecore.Presentation Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Presentation Namespace
Send Feedback

Classes

 | Class | Description
Public class | ControlManager | ControlManager
Public class | ControlProvider | ControlProvider
Public class | ControlProviderCollection | ControlProviderCollection class
Public class | ControlUriParser | ControlUriParser
Public class | ItemPresentation | ItemPresentation class
Public class | PresentationManager | PresentationManager
Public class | PresentationProvider | PresentationProvider
Public class | PresentationProviderCollection | PresentationProviderCollection class
Public class | XslControlUriParser | XslControlUriParser class


ControlManager Class

[image]

Sitecore 6.4.1 API
ControlManager Class
Members See Also Send Feedback

Namespace: Sitecore.Presentation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class ControlManager
Visual Basic
Public NotInheritable Class ControlManager
Visual C++
public ref class ControlManager abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Presentation..::..ControlManager

See Also

ControlManager Members
Sitecore.Presentation Namespace


ControlManager Members

[image] [image]

Sitecore 6.4.1 API
ControlManager Members
ControlManager Class Methods Properties See Also Send Feedback

The ControlManager type exposes the following members.

Methods

Name | Description
GetControl | Gets a control matching the specified uri.

Properties

Name | Description
Provider | Gets the provider.
Providers | Gets the providers.

See Also

ControlManager Class
Sitecore.Presentation Namespace


ControlManager Methods

[image] [image]

Sitecore 6.4.1 API
ControlManager Methods
ControlManager Class See Also Send Feedback

The ControlManager type exposes the following members.

Methods

Name | Description
GetControl | Gets a control matching the specified uri.

See Also

ControlManager Class
Sitecore.Presentation Namespace


GetControl Method

[image]

Sitecore 6.4.1 API
ControlManager..::..GetControl Method
ControlManager Class See Also Send Feedback

Namespace: Sitecore.Presentation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static IWebControl GetControl(
    string controlUri,
    Dictionary<string, string> parameters
)
Visual Basic
Public Shared Function GetControl ( _
    controlUri As String, _
    parameters As Dictionary(Of String, String) _
) As IWebControl
Visual C++
public:
static IWebControl^ GetControl(
    String^ controlUri,
    Dictionary<String^, String^>^ parameters
)

Parameters

controlUri
Type: System..::..String
The control URI.
parameters
Type: System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
The parameters.

Return Value

[Missing <returns> documentation for "M:Sitecore.Presentation.ControlManager.GetControl(System.String,System.Collections.Generic.Dictionary{System.String,System.String})"]

See Also

ControlManager Class
Sitecore.Presentation Namespace


ControlManager Properties

[image] [image]

Sitecore 6.4.1 API
ControlManager Properties
ControlManager Class See Also Send Feedback

The ControlManager type exposes the following members.

Properties

Name | Description
Provider | Gets the provider.
Providers | Gets the providers.

See Also

ControlManager Class
Sitecore.Presentation Namespace


Provider Property

[image]

Sitecore 6.4.1 API
ControlManager..::..Provider Property
ControlManager Class See Also Send Feedback

Namespace: Sitecore.Presentation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ControlProvider Provider { get; }
Visual Basic
Public Shared ReadOnly Property Provider As ControlProvider
    Get
Visual C++
public:
static property ControlProvider^ Provider {
    ControlProvider^ get ();
}

Field Value

The provider.

See Also

ControlManager Class
Sitecore.Presentation Namespace


Providers Property

[image]

Sitecore 6.4.1 API
ControlManager..::..Providers Property
ControlManager Class See Also Send Feedback

Namespace: Sitecore.Presentation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ControlProviderCollection Providers { get; }
Visual Basic
Public Shared ReadOnly Property Providers As ControlProviderCollection
    Get
Visual C++
public:
static property ControlProviderCollection^ Providers {
    ControlProviderCollection^ get ();
}

Field Value

The provider.

See Also

ControlManager Class
Sitecore.Presentation Namespace


ControlProvider Class

[image]

Sitecore 6.4.1 API
ControlProvider Class
Members See Also Send Feedback

Namespace: Sitecore.Presentation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ControlProvider : ProviderBase
Visual Basic
Public Class ControlProvider _
    Inherits ProviderBase
Visual C++
public ref class ControlProvider : public ProviderBase

Inheritance Hierarchy

System..::..Object
System.Configuration.Provider..::..ProviderBase
Sitecore.Presentation..::..ControlProvider

See Also

ControlProvider Members
Sitecore.Presentation Namespace


ControlProvider Members

[image] [image]

Sitecore 6.4.1 API
ControlProvider Members
ControlProvider Class Constructors Methods Properties See Also Send Feedback

The ControlProvider type exposes the following members.

Constructors

 | Name | Description
Public method | ControlProvider | Initializes a new instance of the ControlProvider class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControl | Gets a control matching the specified uri.
Protected method | GetControlUriParser | Gets the control URI parser.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the provider. (Inherited from ProviderBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

ControlProvider Class
Sitecore.Presentation Namespace


ControlProvider Constructor

[image]

Sitecore 6.4.1 API
ControlProvider Constructor
ControlProvider Class See Also Send Feedback

Namespace: Sitecore.Presentation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ControlProvider()
Visual Basic
Public Sub New
Visual C++
public:
ControlProvider()

See Also

ControlProvider Class
Sitecore.Presentation Namespace


ControlProvider Methods

[image] [image]

Sitecore 6.4.1 API
ControlProvider Methods
ControlProvider Class See Also Send Feedback

The ControlProvider type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControl | Gets a control matching the specified uri.
Protected method | GetControlUriParser | Gets the control URI parser.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the provider. (Inherited from ProviderBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ControlProvider Class
Sitecore.Presentation Namespace


GetControl Method

[image]

Sitecore 6.4.1 API
ControlProvider..::..GetControl Method
ControlProvider Class See Also Send Feedback

Namespace: Sitecore.Presentation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual IWebControl GetControl(
    string controlUri,
    Dictionary<string, string> parameters
)
Visual Basic
Public Overridable Function GetControl ( _
    controlUri As String, _
    parameters As Dictionary(Of String, String) _
) As IWebControl
Visual C++
public:
virtual IWebControl^ GetControl(
    String^ controlUri,
    Dictionary<String^, String^>^ parameters
)

Parameters

controlUri
Type: System..::..String
The control URI.
parameters
Type: System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
The parameters.

Return Value

[Missing <returns> documentation for "M:Sitecore.Presentation.ControlProvider.GetControl(System.String,System.Collections.Generic.Dictionary{System.String,System.String})"]

See Also

ControlProvider Class
Sitecore.Presentation Namespace


GetControlUriParser Method

[image]

Sitecore 6.4.1 API
ControlProvider..::..GetControlUriParser Method
ControlProvider Class See Also Send Feedback

Namespace: Sitecore.Presentation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual ControlUriParser GetControlUriParser(
    string controlUri,
    Dictionary<string, string> parameters
)
Visual Basic
Protected Overridable Function GetControlUriParser ( _
    controlUri As String, _
    parameters As Dictionary(Of String, String) _
) As ControlUriParser
Visual C++
protected:
virtual ControlUriParser^ GetControlUriParser(
    String^ controlUri,
    Dictionary<String^, String^>^ parameters
)

Parameters

controlUri
Type: System..::..String
The control URI.
parameters
Type: System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
The parameters.

Return Value

[Missing <returns> documentation for "M:Sitecore.Presentation.ControlProvider.GetControlUriParser(System.String,System.Collections.Generic.Dictionary{System.String,System.String})"]

See Also

ControlProvider Class
Sitecore.Presentation Namespace


ControlProvider Properties

[image] [image]

Sitecore 6.4.1 API
ControlProvider Properties
ControlProvider Class See Also Send Feedback

The ControlProvider type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

ControlProvider Class
Sitecore.Presentation Namespace


ControlProviderCollection Class

[image]

Sitecore 6.4.1 API
ControlProviderCollection Class
Members See Also Send Feedback

Namespace: Sitecore.Presentation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ControlProviderCollection : ProviderCollection
Visual Basic
Public Class ControlProviderCollection _
    Inherits ProviderCollection
Visual C++
public ref class ControlProviderCollection : public ProviderCollection

Inheritance Hierarchy

System..::..Object
System.Configuration.Provider..::..ProviderCollection
Sitecore.Presentation..::..ControlProviderCollection

See Also

ControlProviderCollection Members
Sitecore.Presentation Namespace


ControlProviderCollection Members

[image] [image]

Sitecore 6.4.1 API
ControlProviderCollection Members
ControlProviderCollection Class Constructors Methods Properties See Also Send Feedback

The ControlProviderCollection type exposes the following members.

Constructors

 | Name | Description
Public method | ControlProviderCollection | Initializes a new instance of the ControlProviderCollection class

Methods

 | Name | Description
Public method | Add | Adds a provider to the collection. (Inherited from ProviderCollection.)
Public method | Clear | Removes all items from the collection. (Inherited from ProviderCollection.)
Public method | CopyTo | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a provider from the collection. (Inherited from ProviderCollection.)
Public method | SetReadOnly | Sets the collection to be read-only. (Inherited from ProviderCollection.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
Public property | Item | Gets the ControlProvider with the specified name.
Public property | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)

See Also

ControlProviderCollection Class
Sitecore.Presentation Namespace


ControlProviderCollection Constructor

[image]

Sitecore 6.4.1 API
ControlProviderCollection Constructor
ControlProviderCollection Class See Also Send Feedback

Namespace: Sitecore.Presentation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ControlProviderCollection()
Visual Basic
Public Sub New
Visual C++
public:
ControlProviderCollection()

See Also

ControlProviderCollection Class
Sitecore.Presentation Namespace


ControlProviderCollection Methods

[image] [image]

Sitecore 6.4.1 API
ControlProviderCollection Methods
ControlProviderCollection Class See Also Send Feedback

The ControlProviderCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds a provider to the collection. (Inherited from ProviderCollection.)
Public method | Clear | Removes all items from the collection. (Inherited from ProviderCollection.)
Public method | CopyTo | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a provider from the collection. (Inherited from ProviderCollection.)
Public method | SetReadOnly | Sets the collection to be read-only. (Inherited from ProviderCollection.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ControlProviderCollection Class
Sitecore.Presentation Namespace


ControlProviderCollection Properties

[image] [image]

Sitecore 6.4.1 API
ControlProviderCollection Properties
ControlProviderCollection Class See Also Send Feedback

The ControlProviderCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
Public property | Item | Gets the ControlProvider with the specified name.
Public property | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)

See Also

ControlProviderCollection Class
Sitecore.Presentation Namespace


Item Property

[image]

Sitecore 6.4.1 API
ControlProviderCollection..::..Item Property
ControlProviderCollection Class See Also Send Feedback

Namespace: Sitecore.Presentation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ControlProvider this[
    string name
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    name As String _
) As ControlProvider
    Get
Visual C++
public:
property ControlProvider^ default[String^ name] {
    ControlProvider^ get (String^ name);
}

Parameters

name
Type: System..::..String

Field Value

See Also

ControlProviderCollection Class
Sitecore.Presentation Namespace


ControlUriParser Class

[image]

Sitecore 6.4.1 API
ControlUriParser Class
Members See Also Send Feedback

Namespace: Sitecore.Presentation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class ControlUriParser
Visual Basic
Public MustInherit Class ControlUriParser
Visual C++
public ref class ControlUriParser abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Presentation..::..ControlUriParser
Sitecore.Presentation..::..XslControlUriParser

See Also

ControlUriParser Members
Sitecore.Presentation Namespace


ControlUriParser Members

[image] [image]

Sitecore 6.4.1 API
ControlUriParser Members
ControlUriParser Class Constructors Methods See Also Send Feedback

The ControlUriParser type exposes the following members.

Constructors

 | Name | Description
Protected method | ControlUriParser | Initializes a new instance of the ControlUriParser class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControl | Gets the control represented by the uri.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ControlUriParser Class
Sitecore.Presentation Namespace


ControlUriParser Constructor

[image]

Sitecore 6.4.1 API
ControlUriParser Constructor
ControlUriParser Class See Also Send Feedback

Namespace: Sitecore.Presentation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected ControlUriParser()
Visual Basic
Protected Sub New
Visual C++
protected:
ControlUriParser()

See Also

ControlUriParser Class
Sitecore.Presentation Namespace


ControlUriParser Methods

[image] [image]

Sitecore 6.4.1 API
ControlUriParser Methods
ControlUriParser Class See Also Send Feedback

The ControlUriParser type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControl | Gets the control represented by the uri.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ControlUriParser Class
Sitecore.Presentation Namespace


GetControl Method

[image]

Sitecore 6.4.1 API
ControlUriParser..::..GetControl Method
ControlUriParser Class See Also Send Feedback

Namespace: Sitecore.Presentation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract IWebControl GetControl()
Visual Basic
Public MustOverride Function GetControl As IWebControl
Visual C++
public:
virtual IWebControl^ GetControl() abstract

Return Value

[Missing <returns> documentation for "M:Sitecore.Presentation.ControlUriParser.GetControl"]

See Also

ControlUriParser Class
Sitecore.Presentation Namespace


ItemPresentation Class

[image]

Sitecore 6.4.1 API
ItemPresentation Class
Members See Also Send Feedback

Namespace: Sitecore.Presentation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemPresentation
Visual Basic
Public Class ItemPresentation
Visual C++
public ref class ItemPresentation

Inheritance Hierarchy

System..::..Object
Sitecore.Presentation..::..ItemPresentation

See Also

ItemPresentation Members
Sitecore.Presentation Namespace


ItemPresentation Members

[image] [image]

Sitecore 6.4.1 API
ItemPresentation Members
ItemPresentation Class Constructors Methods Properties See Also Send Feedback

The ItemPresentation type exposes the following members.

Constructors

 | Name | Description
Public method | ItemPresentation | Initializes a new instance of the ItemPresentation class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControl | Gets the control used to render the presentation.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Render | Renders this instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ControlUri | Gets or sets the control URI.
Public property | IsDefault | Gets a value indicating whether this instance is the default.
Public property | Name | Gets or sets the name.
Public property | Parameters | Gets or sets the parameters.

See Also

ItemPresentation Class
Sitecore.Presentation Namespace


ItemPresentation Constructor

[image]

Sitecore 6.4.1 API
ItemPresentation Constructor
ItemPresentation Class See Also Send Feedback

Namespace: Sitecore.Presentation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemPresentation()
Visual Basic
Public Sub New
Visual C++
public:
ItemPresentation()

See Also

ItemPresentation Class
Sitecore.Presentation Namespace


ItemPresentation Methods

[image] [image]

Sitecore 6.4.1 API
ItemPresentation Methods
ItemPresentation Class See Also Send Feedback

The ItemPresentation type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControl | Gets the control used to render the presentation.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Render | Renders this instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemPresentation Class
Sitecore.Presentation Namespace


GetControl Method

[image]

Sitecore 6.4.1 API
ItemPresentation..::..GetControl Method
ItemPresentation Class See Also Send Feedback

Namespace: Sitecore.Presentation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual IWebControl GetControl()
Visual Basic
Public Overridable Function GetControl As IWebControl
Visual C++
public:
virtual IWebControl^ GetControl()

Return Value

[Missing <returns> documentation for "M:Sitecore.Presentation.ItemPresentation.GetControl"]

See Also

ItemPresentation Class
Sitecore.Presentation Namespace


Render Method

[image]

Sitecore 6.4.1 API
ItemPresentation..::..Render Method
ItemPresentation Class See Also Send Feedback

Namespace: Sitecore.Presentation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string Render()
Visual Basic
Public Overridable Function Render As String
Visual C++
public:
virtual String^ Render()

Return Value

[Missing <returns> documentation for "M:Sitecore.Presentation.ItemPresentation.Render"]

See Also

ItemPresentation Class
Sitecore.Presentation Namespace


ItemPresentation Properties

[image] [image]

Sitecore 6.4.1 API
ItemPresentation Properties
ItemPresentation Class See Also Send Feedback

The ItemPresentation type exposes the following members.

Properties

 | Name | Description
Public property | ControlUri | Gets or sets the control URI.
Public property | IsDefault | Gets a value indicating whether this instance is the default.
Public property | Name | Gets or sets the name.
Public property | Parameters | Gets or sets the parameters.

See Also

ItemPresentation Class
Sitecore.Presentation Namespace


ControlUri Property

[image]

Sitecore 6.4.1 API
ItemPresentation..::..ControlUri Property
ItemPresentation Class Example See Also Send Feedback

Namespace: Sitecore.Presentation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ControlUri { get; set; }
Visual Basic
Public Property ControlUri As String
    Get
    Set
Visual C++
public:
property String^ ControlUri {
    String^ get ();
    void set (String^ value);
}

Field Value

The control URI.

Examples

xsl:/xsl/document.xslt

ascx:/layouts/document.ascx

rendering:{A5F6A...} (guid of rendering)

rendering:document (name of rendering)

type:Sitecore.WebControls.Text, Sitecore.Kernel

xml:<header/><document/><footer/>

pipeline:renderItem

See Also

ItemPresentation Class
Sitecore.Presentation Namespace


IsDefault Property

[image]

Sitecore 6.4.1 API
ItemPresentation..::..IsDefault Property
ItemPresentation Class See Also Send Feedback

Namespace: Sitecore.Presentation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsDefault { get; set; }
Visual Basic
Public Property IsDefault As Boolean
    Get
    Set
Visual C++
public:
property bool IsDefault {
    bool get ();
    void set (bool value);
}

Field Value

true if this instance is the default; otherwise, false.

See Also

ItemPresentation Class
Sitecore.Presentation Namespace


Name Property

[image]

Sitecore 6.4.1 API
ItemPresentation..::..Name Property
ItemPresentation Class See Also Send Feedback

Namespace: Sitecore.Presentation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Field Value

The name.

See Also

ItemPresentation Class
Sitecore.Presentation Namespace


Parameters Property

[image]

Sitecore 6.4.1 API
ItemPresentation..::..Parameters Property
ItemPresentation Class See Also Send Feedback

Namespace: Sitecore.Presentation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Dictionary<string, string> Parameters { get; set; }
Visual Basic
Public Property Parameters As Dictionary(Of String, String)
    Get
    Set
Visual C++
public:
property Dictionary<String^, String^>^ Parameters {
    Dictionary<String^, String^>^ get ();
    void set (Dictionary<String^, String^>^ value);
}

Field Value

The parameters.

See Also

ItemPresentation Class
Sitecore.Presentation Namespace


PresentationManager Class

[image]

Sitecore 6.4.1 API
PresentationManager Class
Members See Also Send Feedback

Namespace: Sitecore.Presentation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class PresentationManager
Visual Basic
Public NotInheritable Class PresentationManager
Visual C++
public ref class PresentationManager abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Presentation..::..PresentationManager

See Also

PresentationManager Members
Sitecore.Presentation Namespace


PresentationManager Members

[image] [image]

Sitecore 6.4.1 API
PresentationManager Members
PresentationManager Class Methods Properties See Also Send Feedback

The PresentationManager type exposes the following members.

Methods

Name | Description
GetPresentation(Item) | Gets the presentation of the specified item.
GetPresentation(Item, String) | Gets a named presentation for the specified item.

Properties

Name | Description
Provider | Gets the provider.
Providers | Gets the providers.

See Also

PresentationManager Class
Sitecore.Presentation Namespace


PresentationManager Methods

[image] [image]

Sitecore 6.4.1 API
PresentationManager Methods
PresentationManager Class See Also Send Feedback

Methods

Name | Description
GetPresentation(Item) | Gets the presentation of the specified item.
GetPresentation(Item, String) | Gets a named presentation for the specified item.

See Also

PresentationManager Class
Sitecore.Presentation Namespace


GetPresentation Method

[image] [image]

Sitecore 6.4.1 API
PresentationManager..::..GetPresentation Method
PresentationManager Class See Also Send Feedback

Overload List

Name | Description
GetPresentation(Item) | Gets the presentation of the specified item.
GetPresentation(Item, String) | Gets a named presentation for the specified item.

See Also

PresentationManager Class
PresentationManager Members
Sitecore.Presentation Namespace


GetPresentation Method (Item)

[image]

Sitecore 6.4.1 API
PresentationManager..::..GetPresentation Method (Item)
PresentationManager Class See Also Send Feedback

Namespace: Sitecore.Presentation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ItemPresentation GetPresentation(
    Item item
)
Visual Basic
Public Shared Function GetPresentation ( _
    item As Item _
) As ItemPresentation
Visual C++
public:
static ItemPresentation^ GetPresentation(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Presentation.PresentationManager.GetPresentation(Sitecore.Data.Items.Item)"]

See Also

PresentationManager Class
GetPresentation Overload
Sitecore.Presentation Namespace


GetPresentation Method (Item, String)

[image]

Sitecore 6.4.1 API
PresentationManager..::..GetPresentation Method (Item, String)
PresentationManager Class See Also Send Feedback

Namespace: Sitecore.Presentation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ItemPresentation GetPresentation(
    Item item,
    string presentationName
)
Visual Basic
Public Shared Function GetPresentation ( _
    item As Item, _
    presentationName As String _
) As ItemPresentation
Visual C++
public:
static ItemPresentation^ GetPresentation(
    Item^ item,
    String^ presentationName
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
presentationName
Type: System..::..String
Name of the presentation (empty string => default presentation).

Return Value

[Missing <returns> documentation for "M:Sitecore.Presentation.PresentationManager.GetPresentation(Sitecore.Data.Items.Item,System.String)"]

See Also

PresentationManager Class
GetPresentation Overload
Sitecore.Presentation Namespace


PresentationManager Properties

[image] [image]

Sitecore 6.4.1 API
PresentationManager Properties
PresentationManager Class See Also Send Feedback

The PresentationManager type exposes the following members.

Properties

Name | Description
Provider | Gets the provider.
Providers | Gets the providers.

See Also

PresentationManager Class
Sitecore.Presentation Namespace


Provider Property

[image]

Sitecore 6.4.1 API
PresentationManager..::..Provider Property
PresentationManager Class See Also Send Feedback

Namespace: Sitecore.Presentation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PresentationProvider Provider { get; }
Visual Basic
Public Shared ReadOnly Property Provider As PresentationProvider
    Get
Visual C++
public:
static property PresentationProvider^ Provider {
    PresentationProvider^ get ();
}

Field Value

The provider.

See Also

PresentationManager Class
Sitecore.Presentation Namespace


Providers Property

[image]

Sitecore 6.4.1 API
PresentationManager..::..Providers Property
PresentationManager Class See Also Send Feedback

Namespace: Sitecore.Presentation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PresentationProviderCollection Providers { get; }
Visual Basic
Public Shared ReadOnly Property Providers As PresentationProviderCollection
    Get
Visual C++
public:
static property PresentationProviderCollection^ Providers {
    PresentationProviderCollection^ get ();
}

Field Value

The provider.

See Also

PresentationManager Class
Sitecore.Presentation Namespace


PresentationProvider Class

[image]

Sitecore 6.4.1 API
PresentationProvider Class
Members See Also Send Feedback

Namespace: Sitecore.Presentation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PresentationProvider : ProviderBase
Visual Basic
Public Class PresentationProvider _
    Inherits ProviderBase
Visual C++
public ref class PresentationProvider : public ProviderBase

Inheritance Hierarchy

System..::..Object
System.Configuration.Provider..::..ProviderBase
Sitecore.Presentation..::..PresentationProvider

See Also

PresentationProvider Members
Sitecore.Presentation Namespace


PresentationProvider Members

[image] [image]

Sitecore 6.4.1 API
PresentationProvider Members
PresentationProvider Class Constructors Methods Properties See Also Send Feedback

The PresentationProvider type exposes the following members.

Constructors

 | Name | Description
Public method | PresentationProvider | Initializes a new instance of the PresentationProvider class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPresentation(Item, String) | Gets the presentation.
Protected method | GetPresentation(Item, String, List<(Of <<'(ItemPresentation>)>>)) | Gets the presentation.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the provider. (Inherited from ProviderBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

PresentationProvider Class
Sitecore.Presentation Namespace


PresentationProvider Constructor

[image]

Sitecore 6.4.1 API
PresentationProvider Constructor
PresentationProvider Class See Also Send Feedback

Namespace: Sitecore.Presentation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PresentationProvider()
Visual Basic
Public Sub New
Visual C++
public:
PresentationProvider()

See Also

PresentationProvider Class
Sitecore.Presentation Namespace


PresentationProvider Methods

[image] [image]

Sitecore 6.4.1 API
PresentationProvider Methods
PresentationProvider Class See Also Send Feedback

The PresentationProvider type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPresentation(Item, String) | Gets the presentation.
Protected method | GetPresentation(Item, String, List<(Of <<'(ItemPresentation>)>>)) | Gets the presentation.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the provider. (Inherited from ProviderBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PresentationProvider Class
Sitecore.Presentation Namespace


GetPresentation Method

[image] [image]

Sitecore 6.4.1 API
PresentationProvider..::..GetPresentation Method
PresentationProvider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPresentation(Item, String) | Gets the presentation.
Protected method | GetPresentation(Item, String, List<(Of <<'(ItemPresentation>)>>)) | Gets the presentation.

See Also

PresentationProvider Class
PresentationProvider Members
Sitecore.Presentation Namespace


GetPresentation Method (Item, String)

[image]

Sitecore 6.4.1 API
PresentationProvider..::..GetPresentation Method (Item, String)
PresentationProvider Class See Also Send Feedback

Namespace: Sitecore.Presentation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ItemPresentation GetPresentation(
    Item item,
    string presentationName
)
Visual Basic
Public Overridable Function GetPresentation ( _
    item As Item, _
    presentationName As String _
) As ItemPresentation
Visual C++
public:
virtual ItemPresentation^ GetPresentation(
    Item^ item,
    String^ presentationName
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
presentationName
Type: System..::..String
Name of the presentation (empty string => default presentation).

Return Value

[Missing <returns> documentation for "M:Sitecore.Presentation.PresentationProvider.GetPresentation(Sitecore.Data.Items.Item,System.String)"]

See Also

PresentationProvider Class
GetPresentation Overload
Sitecore.Presentation Namespace


GetPresentation Method (Item, String, List(ItemPresentation))

[image]

Sitecore 6.4.1 API
PresentationProvider..::..GetPresentation Method (Item, String, List<(Of <(<'ItemPresentation>)>)>)
PresentationProvider Class See Also Send Feedback

Namespace: Sitecore.Presentation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual ItemPresentation GetPresentation(
    Item item,
    string presentationName,
    List<ItemPresentation> presentations
)
Visual Basic
Protected Overridable Function GetPresentation ( _
    item As Item, _
    presentationName As String, _
    presentations As List(Of ItemPresentation) _
) As ItemPresentation
Visual C++
protected:
virtual ItemPresentation^ GetPresentation(
    Item^ item,
    String^ presentationName,
    List<ItemPresentation^>^ presentations
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
presentationName
Type: System..::..String
Name of the presentation.
presentations
Type: System.Collections.Generic..::..List <(Of <(<' ItemPresentation >)>)>
The presentations.

Return Value

[Missing <returns> documentation for "M:Sitecore.Presentation.PresentationProvider.GetPresentation(Sitecore.Data.Items.Item,System.String,System.Collections.Generic.List{Sitecore.Presentation.ItemPresentation})"]

See Also

PresentationProvider Class
GetPresentation Overload
Sitecore.Presentation Namespace


PresentationProvider Properties

[image] [image]

Sitecore 6.4.1 API
PresentationProvider Properties
PresentationProvider Class See Also Send Feedback

The PresentationProvider type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

PresentationProvider Class
Sitecore.Presentation Namespace


PresentationProviderCollection Class

[image]

Sitecore 6.4.1 API
PresentationProviderCollection Class
Members See Also Send Feedback

Namespace: Sitecore.Presentation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PresentationProviderCollection : ProviderCollection
Visual Basic
Public Class PresentationProviderCollection _
    Inherits ProviderCollection
Visual C++
public ref class PresentationProviderCollection : public ProviderCollection

Inheritance Hierarchy

System..::..Object
System.Configuration.Provider..::..ProviderCollection
Sitecore.Presentation..::..PresentationProviderCollection

See Also

PresentationProviderCollection Members
Sitecore.Presentation Namespace


PresentationProviderCollection Members

[image] [image]

Sitecore 6.4.1 API
PresentationProviderCollection Members
PresentationProviderCollection Class Constructors Methods Properties See Also Send Feedback

The PresentationProviderCollection type exposes the following members.

Constructors

 | Name | Description
Public method | PresentationProviderCollection | Initializes a new instance of the PresentationProviderCollection class

Methods

 | Name | Description
Public method | Add | Adds a provider to the collection. (Inherited from ProviderCollection.)
Public method | Clear | Removes all items from the collection. (Inherited from ProviderCollection.)
Public method | CopyTo | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a provider from the collection. (Inherited from ProviderCollection.)
Public method | SetReadOnly | Sets the collection to be read-only. (Inherited from ProviderCollection.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
Public property | Item | Gets the PresentationProvider with the specified name.
Public property | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)

See Also

PresentationProviderCollection Class
Sitecore.Presentation Namespace


PresentationProviderCollection Constructor

[image]

Sitecore 6.4.1 API
PresentationProviderCollection Constructor
PresentationProviderCollection Class See Also Send Feedback

Namespace: Sitecore.Presentation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PresentationProviderCollection()
Visual Basic
Public Sub New
Visual C++
public:
PresentationProviderCollection()

See Also

PresentationProviderCollection Class
Sitecore.Presentation Namespace


PresentationProviderCollection Methods

[image] [image]

Sitecore 6.4.1 API
PresentationProviderCollection Methods
PresentationProviderCollection Class See Also Send Feedback

The PresentationProviderCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds a provider to the collection. (Inherited from ProviderCollection.)
Public method | Clear | Removes all items from the collection. (Inherited from ProviderCollection.)
Public method | CopyTo | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a provider from the collection. (Inherited from ProviderCollection.)
Public method | SetReadOnly | Sets the collection to be read-only. (Inherited from ProviderCollection.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PresentationProviderCollection Class
Sitecore.Presentation Namespace


PresentationProviderCollection Properties

[image] [image]

Sitecore 6.4.1 API
PresentationProviderCollection Properties
PresentationProviderCollection Class See Also Send Feedback

The PresentationProviderCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
Public property | Item | Gets the PresentationProvider with the specified name.
Public property | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)

See Also

PresentationProviderCollection Class
Sitecore.Presentation Namespace


Item Property

[image]

Sitecore 6.4.1 API
PresentationProviderCollection..::..Item Property
PresentationProviderCollection Class See Also Send Feedback

Namespace: Sitecore.Presentation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PresentationProvider this[
    string name
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    name As String _
) As PresentationProvider
    Get
Visual C++
public:
property PresentationProvider^ default[String^ name] {
    PresentationProvider^ get (String^ name);
}

Parameters

name
Type: System..::..String

Field Value

See Also

PresentationProviderCollection Class
Sitecore.Presentation Namespace


XslControlUriParser Members

[image] [image]

Sitecore 6.4.1 API
XslControlUriParser Members
XslControlUriParser Class Constructors Methods See Also Send Feedback

The XslControlUriParser type exposes the following members.

Constructors

 | Name | Description
Public method | XslControlUriParser | Initializes a new instance of the XslControlUriParser class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControl | Gets the control represented by the uri. (Overrides ControlUriParser..::..GetControl()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

XslControlUriParser Class
Sitecore.Presentation Namespace


XslControlUriParser Constructor

[image]

Sitecore 6.4.1 API
XslControlUriParser Constructor
XslControlUriParser Class See Also Send Feedback

Namespace: Sitecore.Presentation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public XslControlUriParser(
    string controlUri,
    Dictionary<string, string> parameters
)
Visual Basic
Public Sub New ( _
    controlUri As String, _
    parameters As Dictionary(Of String, String) _
)
Visual C++
public:
XslControlUriParser(
    String^ controlUri,
    Dictionary<String^, String^>^ parameters
)

Parameters

controlUri
Type: System..::..String
The control URI.
parameters
Type: System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
The parameters.

See Also

XslControlUriParser Class
Sitecore.Presentation Namespace


XslControlUriParser Methods

[image] [image]

Sitecore 6.4.1 API
XslControlUriParser Methods
XslControlUriParser Class See Also Send Feedback

The XslControlUriParser type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControl | Gets the control represented by the uri. (Overrides ControlUriParser..::..GetControl()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

XslControlUriParser Class
Sitecore.Presentation Namespace


GetControl Method

[image]

Sitecore 6.4.1 API
XslControlUriParser..::..GetControl Method
XslControlUriParser Class See Also Send Feedback

Namespace: Sitecore.Presentation
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override IWebControl GetControl()
Visual Basic
Public Overrides Function GetControl As IWebControl
Visual C++
public:
virtual IWebControl^ GetControl() override

Return Value

[Missing <returns> documentation for "M:Sitecore.Presentation.XslControlUriParser.GetControl"]

See Also

XslControlUriParser Class
Sitecore.Presentation Namespace


DistributedPublishingManager Class

[image]

Sitecore 6.4.1 API
DistributedPublishingManager Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DistributedPublishingManager
Visual Basic
Public Class DistributedPublishingManager
Visual C++
public ref class DistributedPublishingManager

Inheritance Hierarchy

System..::..Object
Sitecore.Publishing..::..DistributedPublishingManager

See Also

DistributedPublishingManager Members
Sitecore.Publishing Namespace


DistributedPublishingManager Members

[image] [image]

Sitecore 6.4.1 API
DistributedPublishingManager Members
DistributedPublishingManager Class Constructors Methods Properties See Also Send Feedback

The DistributedPublishingManager type exposes the following members.

Constructors

 | Name | Description
Public method | DistributedPublishingManager | Initializes a new instance of the DistributedPublishingManager class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetStatus | Gets the status.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | QueuePublish(array<PublishOptions>[]()[][]) | Queue a publish operation using the specified options.
 | QueuePublish(array<PublishOptions>[]()[][], Language) | Queue a publish operation using the specified options.
 | StartPublishing | Called on the "Start publishing remote event".
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdatePublishStatus()()()() | Updates the publish status for all running jobs.
 | UpdatePublishStatus(PublishStatusUpdatedRemoteEvent) | Updates the publish status.

Properties

Name | Description
AlarmClock | Gets or sets the alarm clock.
Lock | Gets or sets the lock.
PublishRegistrations | Gets or sets the publishing operations.

See Also

DistributedPublishingManager Class
Sitecore.Publishing Namespace


DistributedPublishingManager Constructor

[image]

Sitecore 6.4.1 API
DistributedPublishingManager Constructor
DistributedPublishingManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DistributedPublishingManager()
Visual Basic
Public Sub New
Visual C++
public:
DistributedPublishingManager()

See Also

DistributedPublishingManager Class
Sitecore.Publishing Namespace


DistributedPublishingManager Methods

[image] [image]

Sitecore 6.4.1 API
DistributedPublishingManager Methods
DistributedPublishingManager Class See Also Send Feedback

The DistributedPublishingManager type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetStatus | Gets the status.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | QueuePublish(array<PublishOptions>[]()[][]) | Queue a publish operation using the specified options.
 | QueuePublish(array<PublishOptions>[]()[][], Language) | Queue a publish operation using the specified options.
 | StartPublishing | Called on the "Start publishing remote event".
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdatePublishStatus()()()() | Updates the publish status for all running jobs.
 | UpdatePublishStatus(PublishStatusUpdatedRemoteEvent) | Updates the publish status.

See Also

DistributedPublishingManager Class
Sitecore.Publishing Namespace


GetStatus Method

[image]

Sitecore 6.4.1 API
DistributedPublishingManager..::..GetStatus Method
DistributedPublishingManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PublishStatus GetStatus(
    Handle statusHandle
)
Visual Basic
Public Shared Function GetStatus ( _
    statusHandle As Handle _
) As PublishStatus
Visual C++
public:
static PublishStatus^ GetStatus(
    Handle^ statusHandle
)

Parameters

statusHandle
Type: Sitecore..::..Handle
The status handle.

Return Value

The result.

See Also

DistributedPublishingManager Class
Sitecore.Publishing Namespace


QueuePublish Method

[image] [image]

Sitecore 6.4.1 API
DistributedPublishingManager..::..QueuePublish Method
DistributedPublishingManager Class See Also Send Feedback

Overload List

Name | Description
QueuePublish(array<PublishOptions>[]()[][]) | Queue a publish operation using the specified options.
QueuePublish(array<PublishOptions>[]()[][], Language) | Queue a publish operation using the specified options.

See Also

DistributedPublishingManager Class
DistributedPublishingManager Members
Sitecore.Publishing Namespace


QueuePublish Method (PublishOptions[])

[image]

Sitecore 6.4.1 API
DistributedPublishingManager..::..QueuePublish Method (array<PublishOptions>[]()[][])
DistributedPublishingManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Handle QueuePublish(
    PublishOptions[] options
)
Visual Basic
Public Shared Function QueuePublish ( _
    options As PublishOptions() _
) As Handle
Visual C++
public:
static Handle^ QueuePublish(
    array<PublishOptions^>^ options
)

Parameters

options
Type: array< Sitecore.Publishing..::..PublishOptions >[]()[][]
The options.

Return Value

The result.

See Also

DistributedPublishingManager Class
QueuePublish Overload
Sitecore.Publishing Namespace


QueuePublish Method (PublishOptions[], Language)

[image]

Sitecore 6.4.1 API
DistributedPublishingManager..::..QueuePublish Method (array<PublishOptions>[]()[][], Language)
DistributedPublishingManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Handle QueuePublish(
    PublishOptions[] options,
    Language clientLanguage
)
Visual Basic
Public Shared Function QueuePublish ( _
    options As PublishOptions(), _
    clientLanguage As Language _
) As Handle
Visual C++
public:
static Handle^ QueuePublish(
    array<PublishOptions^>^ options,
    Language^ clientLanguage
)

Parameters

options
Type: array< Sitecore.Publishing..::..PublishOptions >[]()[][]
The options.
clientLanguage
Type: Sitecore.Globalization..::..Language
The client language.

Return Value

The result.

See Also

DistributedPublishingManager Class
QueuePublish Overload
Sitecore.Publishing Namespace


StartPublishing Method

[image]

Sitecore 6.4.1 API
DistributedPublishingManager..::..StartPublishing Method
DistributedPublishingManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void StartPublishing(
    StartPublishingRemoteEvent event
)
Visual Basic
Public Shared Sub StartPublishing ( _
    event As StartPublishingRemoteEvent _
)
Visual C++
public:
static void StartPublishing(
    StartPublishingRemoteEvent^ event
)

Parameters

event
Type: Sitecore.Publishing..::..StartPublishingRemoteEvent
The @event.

See Also

DistributedPublishingManager Class
Sitecore.Publishing Namespace


UpdatePublishStatus Method

[image] [image]

Sitecore 6.4.1 API
DistributedPublishingManager..::..UpdatePublishStatus Method
DistributedPublishingManager Class See Also Send Feedback

Overload List

Name | Description
UpdatePublishStatus()()()() | Updates the publish status for all running jobs.
UpdatePublishStatus(PublishStatusUpdatedRemoteEvent) | Updates the publish status.

See Also

DistributedPublishingManager Class
DistributedPublishingManager Members
Sitecore.Publishing Namespace


UpdatePublishStatus Method

[image]

Sitecore 6.4.1 API
DistributedPublishingManager..::..UpdatePublishStatus Method
DistributedPublishingManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void UpdatePublishStatus()
Visual Basic
Public Shared Sub UpdatePublishStatus
Visual C++
public:
static void UpdatePublishStatus()

See Also

DistributedPublishingManager Class
UpdatePublishStatus Overload
Sitecore.Publishing Namespace


UpdatePublishStatus Method (PublishStatusUpdatedRemoteEvent)

[image]

Sitecore 6.4.1 API
DistributedPublishingManager..::..UpdatePublishStatus Method (PublishStatusUpdatedRemoteEvent)
DistributedPublishingManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void UpdatePublishStatus(
    PublishStatusUpdatedRemoteEvent event
)
Visual Basic
Public Shared Sub UpdatePublishStatus ( _
    event As PublishStatusUpdatedRemoteEvent _
)
Visual C++
public:
static void UpdatePublishStatus(
    PublishStatusUpdatedRemoteEvent^ event
)

Parameters

event
Type: Sitecore.Publishing..::..PublishStatusUpdatedRemoteEvent
The @event.

See Also

DistributedPublishingManager Class
UpdatePublishStatus Overload
Sitecore.Publishing Namespace


DistributedPublishingManager Properties

[image] [image]

Sitecore 6.4.1 API
DistributedPublishingManager Properties
DistributedPublishingManager Class See Also Send Feedback

The DistributedPublishingManager type exposes the following members.

Properties

Name | Description
AlarmClock | Gets or sets the alarm clock.
Lock | Gets or sets the lock.
PublishRegistrations | Gets or sets the publishing operations.

See Also

DistributedPublishingManager Class
Sitecore.Publishing Namespace


AlarmClock Property

[image]

Sitecore 6.4.1 API
DistributedPublishingManager..::..AlarmClock Property
DistributedPublishingManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected static AlarmClock AlarmClock { get; set; }
Visual Basic
Protected Shared Property AlarmClock As AlarmClock
    Get
    Set
Visual C++
protected:
static property AlarmClock^ AlarmClock {
    AlarmClock^ get ();
    void set (AlarmClock^ value);
}

Field Value

The alarm clock.

See Also

DistributedPublishingManager Class
Sitecore.Publishing Namespace


Lock Property

[image]

Sitecore 6.4.1 API
DistributedPublishingManager..::..Lock Property
DistributedPublishingManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected static Object Lock { get; set; }
Visual Basic
Protected Shared Property Lock As Object
    Get
    Set
Visual C++
protected:
static property Object^ Lock {
    Object^ get ();
    void set (Object^ value);
}

Field Value

The lock.

See Also

DistributedPublishingManager Class
Sitecore.Publishing Namespace


PublishRegistrations Property

[image]

Sitecore 6.4.1 API
DistributedPublishingManager..::..PublishRegistrations Property
DistributedPublishingManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected static List<PublishRegistration> PublishRegistrations { get; set; }
Visual Basic
Protected Shared Property PublishRegistrations As List(Of PublishRegistration)
    Get
    Set
Visual C++
protected:
static property List<PublishRegistration^>^ PublishRegistrations {
    List<PublishRegistration^>^ get ();
    void set (List<PublishRegistration^>^ value);
}

Field Value

The publishing operations.

See Also

DistributedPublishingManager Class
Sitecore.Publishing Namespace


DistributedPublishOptions Class

[image]

Sitecore 6.4.1 API
DistributedPublishOptions Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DistributedPublishOptions
Visual Basic
Public Class DistributedPublishOptions
Visual C++
public ref class DistributedPublishOptions

Inheritance Hierarchy

System..::..Object
Sitecore.Publishing..::..DistributedPublishOptions

See Also

DistributedPublishOptions Members
Sitecore.Publishing Namespace


DistributedPublishOptions Members

[image] [image]

Sitecore 6.4.1 API
DistributedPublishOptions Members
DistributedPublishOptions Class Constructors Methods Properties See Also Send Feedback

The DistributedPublishOptions type exposes the following members.

Constructors

 | Name | Description
Public method | DistributedPublishOptions | Initializes a new instance of the DistributedPublishOptions class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CompareRevisions | Gets or sets a value indicating whether to compare revisions.
Public property | Deep | Gets or sets a value indicating whether this DistributedPublishOptions is deep.
Public property | FromDate | Gets or sets from date.
Public property | LanguageName | Gets or sets the name of the language.
Public property | Mode | Gets or sets the mode.
Public property | PublishDate | Gets or sets the publish date.
Public property | PublishingTargets | Gets or sets the publishing targets.
Public property | RepublishAll | Gets or sets a value indicating whether to republish all.
Public property | RootItemId | Gets or sets the root item id.
Public property | SourceDatabaseName | Gets or sets the name of the source database.
Public property | TargetDatabaseName | Gets or sets the name of the target database.

See Also

DistributedPublishOptions Class
Sitecore.Publishing Namespace


DistributedPublishOptions Constructor

[image]

Sitecore 6.4.1 API
DistributedPublishOptions Constructor
DistributedPublishOptions Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DistributedPublishOptions(
    PublishOptions options
)
Visual Basic
Public Sub New ( _
    options As PublishOptions _
)
Visual C++
public:
DistributedPublishOptions(
    PublishOptions^ options
)

Parameters

options
Type: Sitecore.Publishing..::..PublishOptions
The options.

See Also

DistributedPublishOptions Class
Sitecore.Publishing Namespace


DistributedPublishOptions Methods

[image] [image]

Sitecore 6.4.1 API
DistributedPublishOptions Methods
DistributedPublishOptions Class See Also Send Feedback

The DistributedPublishOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DistributedPublishOptions Class
Sitecore.Publishing Namespace


CompareRevisions Property

[image]

Sitecore 6.4.1 API
DistributedPublishOptions..::..CompareRevisions Property
DistributedPublishOptions Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool CompareRevisions { get; protected set; }
Visual Basic
Public Property CompareRevisions As Boolean
    Get
    Protected Set
Visual C++
public:
property bool CompareRevisions {
    bool get ();
    protected: void set (bool value);
}

Field Value

true if compare revisions; otherwise, false.

See Also

DistributedPublishOptions Class
Sitecore.Publishing Namespace


FromDate Property

[image]

Sitecore 6.4.1 API
DistributedPublishOptions..::..FromDate Property
DistributedPublishOptions Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime FromDate { get; protected set; }
Visual Basic
Public Property FromDate As DateTime
    Get
    Protected Set
Visual C++
public:
property DateTime FromDate {
    DateTime get ();
    protected: void set (DateTime value);
}

Field Value

From date.

See Also

DistributedPublishOptions Class
Sitecore.Publishing Namespace


LanguageName Property

[image]

Sitecore 6.4.1 API
DistributedPublishOptions..::..LanguageName Property
DistributedPublishOptions Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string LanguageName { get; protected set; }
Visual Basic
Public Property LanguageName As String
    Get
    Protected Set
Visual C++
public:
property String^ LanguageName {
    String^ get ();
    protected: void set (String^ value);
}

Field Value

The name of the language.

See Also

DistributedPublishOptions Class
Sitecore.Publishing Namespace


Mode Property

[image]

Sitecore 6.4.1 API
DistributedPublishOptions..::..Mode Property
DistributedPublishOptions Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PublishMode Mode { get; protected set; }
Visual Basic
Public Property Mode As PublishMode
    Get
    Protected Set
Visual C++
public:
property PublishMode Mode {
    PublishMode get ();
    protected: void set (PublishMode value);
}

Field Value

The mode.

See Also

DistributedPublishOptions Class
Sitecore.Publishing Namespace


PublishDate Property

[image]

Sitecore 6.4.1 API
DistributedPublishOptions..::..PublishDate Property
DistributedPublishOptions Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime PublishDate { get; protected set; }
Visual Basic
Public Property PublishDate As DateTime
    Get
    Protected Set
Visual C++
public:
property DateTime PublishDate {
    DateTime get ();
    protected: void set (DateTime value);
}

Field Value

The publish date.

See Also

DistributedPublishOptions Class
Sitecore.Publishing Namespace


PublishingTargets Property

[image]

Sitecore 6.4.1 API
DistributedPublishOptions..::..PublishingTargets Property
DistributedPublishOptions Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string[] PublishingTargets { get; protected set; }
Visual Basic
Public Property PublishingTargets As String()
    Get
    Protected Set
Visual C++
public:
property array<String^>^ PublishingTargets {
    array<String^>^ get ();
    protected: void set (array<String^>^ value);
}

Field Value

The publishing targets.

See Also

DistributedPublishOptions Class
Sitecore.Publishing Namespace


RepublishAll Property

[image]

Sitecore 6.4.1 API
DistributedPublishOptions..::..RepublishAll Property
DistributedPublishOptions Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool RepublishAll { get; protected set; }
Visual Basic
Public Property RepublishAll As Boolean
    Get
    Protected Set
Visual C++
public:
property bool RepublishAll {
    bool get ();
    protected: void set (bool value);
}

Field Value

true if republish all; otherwise, false.

See Also

DistributedPublishOptions Class
Sitecore.Publishing Namespace


RootItemId Property

[image]

Sitecore 6.4.1 API
DistributedPublishOptions..::..RootItemId Property
DistributedPublishOptions Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Guid RootItemId { get; protected set; }
Visual Basic
Public Property RootItemId As Guid
    Get
    Protected Set
Visual C++
public:
property Guid RootItemId {
    Guid get ();
    protected: void set (Guid value);
}

Field Value

The root item id.

See Also

DistributedPublishOptions Class
Sitecore.Publishing Namespace


SourceDatabaseName Property

[image]

Sitecore 6.4.1 API
DistributedPublishOptions..::..SourceDatabaseName Property
DistributedPublishOptions Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string SourceDatabaseName { get; protected set; }
Visual Basic
Public Property SourceDatabaseName As String
    Get
    Protected Set
Visual C++
public:
property String^ SourceDatabaseName {
    String^ get ();
    protected: void set (String^ value);
}

Field Value

The name of the source database.

See Also

DistributedPublishOptions Class
Sitecore.Publishing Namespace


DistributedPublishStatus Class

[image]

Sitecore 6.4.1 API
DistributedPublishStatus Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DistributedPublishStatus
Visual Basic
Public Class DistributedPublishStatus
Visual C++
public ref class DistributedPublishStatus

Inheritance Hierarchy

System..::..Object
Sitecore.Publishing..::..DistributedPublishStatus

See Also

DistributedPublishStatus Members
Sitecore.Publishing Namespace


DistributedPublishStatus Members

[image] [image]

Sitecore 6.4.1 API
DistributedPublishStatus Members
DistributedPublishStatus Class Constructors Methods Properties See Also Send Feedback

The DistributedPublishStatus type exposes the following members.

Constructors

 | Name | Description
Public method | DistributedPublishStatus | Initializes a new instance of the DistributedPublishStatus class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CurrentLanguageName | Gets or sets the name of the current language.
Public property | CurrentTargetName | Gets or sets the name of the current target.
Public property | Expired | Gets or sets a value indicating whether this DistributedPublishStatus is expired.
Public property | Failed | Gets or sets a value indicating whether this DistributedPublishStatus is failed.
Public property | IsDone | Gets or sets a value indicating whether this instance is done.
Public property | Messages | Gets or sets the messages.
Public property | Processed | Gets or sets the processed.
Public property | State | Gets or sets the state.

See Also

DistributedPublishStatus Class
Sitecore.Publishing Namespace


DistributedPublishStatus Constructor

[image]

Sitecore 6.4.1 API
DistributedPublishStatus Constructor
DistributedPublishStatus Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DistributedPublishStatus(
    PublishStatus status
)
Visual Basic
Public Sub New ( _
    status As PublishStatus _
)
Visual C++
public:
DistributedPublishStatus(
    PublishStatus^ status
)

Parameters

status
Type: Sitecore.Publishing..::..PublishStatus
The status.

See Also

DistributedPublishStatus Class
Sitecore.Publishing Namespace


DistributedPublishStatus Properties

[image] [image]

Sitecore 6.4.1 API
DistributedPublishStatus Properties
DistributedPublishStatus Class See Also Send Feedback

The DistributedPublishStatus type exposes the following members.

Properties

 | Name | Description
Public property | CurrentLanguageName | Gets or sets the name of the current language.
Public property | CurrentTargetName | Gets or sets the name of the current target.
Public property | Expired | Gets or sets a value indicating whether this DistributedPublishStatus is expired.
Public property | Failed | Gets or sets a value indicating whether this DistributedPublishStatus is failed.
Public property | IsDone | Gets or sets a value indicating whether this instance is done.
Public property | Messages | Gets or sets the messages.
Public property | Processed | Gets or sets the processed.
Public property | State | Gets or sets the state.

See Also

DistributedPublishStatus Class
Sitecore.Publishing Namespace


CurrentLanguageName Property

[image]

Sitecore 6.4.1 API
DistributedPublishStatus..::..CurrentLanguageName Property
DistributedPublishStatus Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string CurrentLanguageName { get; protected set; }
Visual Basic
Public Property CurrentLanguageName As String
    Get
    Protected Set
Visual C++
public:
property String^ CurrentLanguageName {
    String^ get ();
    protected: void set (String^ value);
}

Field Value

The name of the current language.

See Also

DistributedPublishStatus Class
Sitecore.Publishing Namespace


CurrentTargetName Property

[image]

Sitecore 6.4.1 API
DistributedPublishStatus..::..CurrentTargetName Property
DistributedPublishStatus Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string CurrentTargetName { get; protected set; }
Visual Basic
Public Property CurrentTargetName As String
    Get
    Protected Set
Visual C++
public:
property String^ CurrentTargetName {
    String^ get ();
    protected: void set (String^ value);
}

Field Value

The name of the current target.

See Also

DistributedPublishStatus Class
Sitecore.Publishing Namespace


Expired Property

[image]

Sitecore 6.4.1 API
DistributedPublishStatus..::..Expired Property
DistributedPublishStatus Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Expired { get; protected set; }
Visual Basic
Public Property Expired As Boolean
    Get
    Protected Set
Visual C++
public:
property bool Expired {
    bool get ();
    protected: void set (bool value);
}

Field Value

true if expired; otherwise, false.

See Also

DistributedPublishStatus Class
Sitecore.Publishing Namespace


Failed Property

[image]

Sitecore 6.4.1 API
DistributedPublishStatus..::..Failed Property
DistributedPublishStatus Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Failed { get; protected set; }
Visual Basic
Public Property Failed As Boolean
    Get
    Protected Set
Visual C++
public:
property bool Failed {
    bool get ();
    protected: void set (bool value);
}

Field Value

true if failed; otherwise, false.

See Also

DistributedPublishStatus Class
Sitecore.Publishing Namespace


Messages Property

[image]

Sitecore 6.4.1 API
DistributedPublishStatus..::..Messages Property
DistributedPublishStatus Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public List<string> Messages { get; protected set; }
Visual Basic
Public Property Messages As List(Of String)
    Get
    Protected Set
Visual C++
public:
property List<String^>^ Messages {
    List<String^>^ get ();
    protected: void set (List<String^>^ value);
}

Field Value

The messages.

See Also

DistributedPublishStatus Class
Sitecore.Publishing Namespace


Processed Property

[image]

Sitecore 6.4.1 API
DistributedPublishStatus..::..Processed Property
DistributedPublishStatus Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long Processed { get; protected set; }
Visual Basic
Public Property Processed As Long
    Get
    Protected Set
Visual C++
public:
property long long Processed {
    long long get ();
    protected: void set (long long value);
}

Field Value

The processed.

See Also

DistributedPublishStatus Class
Sitecore.Publishing Namespace


State Property

[image]

Sitecore 6.4.1 API
DistributedPublishStatus..::..State Property
DistributedPublishStatus Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public JobState State { get; protected set; }
Visual Basic
Public Property State As JobState
    Get
    Protected Set
Visual C++
public:
property JobState State {
    JobState get ();
    protected: void set (JobState value);
}

Field Value

The state.

See Also

DistributedPublishStatus Class
Sitecore.Publishing Namespace


HtmlCacheClearer Members

[image] [image]

Sitecore 6.4.1 API
HtmlCacheClearer Members
HtmlCacheClearer Class Constructors Methods Properties See Also Send Feedback

The HtmlCacheClearer type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlCacheClearer | Initializes a new instance of the HtmlCacheClearer class

Methods

 | Name | Description
Public method | ClearCache | Clears the cache.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Sites | Gets the sites.

See Also

HtmlCacheClearer Class
Sitecore.Publishing Namespace


HtmlCacheClearer Constructor

[image]

Sitecore 6.4.1 API
HtmlCacheClearer Constructor
HtmlCacheClearer Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public HtmlCacheClearer()
Visual Basic
Public Sub New
Visual C++
public:
HtmlCacheClearer()

See Also

HtmlCacheClearer Class
Sitecore.Publishing Namespace


HtmlCacheClearer Methods

[image] [image]

Sitecore 6.4.1 API
HtmlCacheClearer Methods
HtmlCacheClearer Class See Also Send Feedback

The HtmlCacheClearer type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clears the cache.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HtmlCacheClearer Class
Sitecore.Publishing Namespace


ClearCache Method

[image]

Sitecore 6.4.1 API
HtmlCacheClearer..::..ClearCache Method
HtmlCacheClearer Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void ClearCache(
    Object sender,
    EventArgs args
)
Visual Basic
Public Sub ClearCache ( _
    sender As Object, _
    args As EventArgs _
)
Visual C++
public:
void ClearCache(
    Object^ sender,
    EventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: System..::..EventArgs
The arguments.

See Also

HtmlCacheClearer Class
Sitecore.Publishing Namespace


HtmlCacheClearer Properties

[image] [image]

Sitecore 6.4.1 API
HtmlCacheClearer Properties
HtmlCacheClearer Class See Also Send Feedback

The HtmlCacheClearer type exposes the following members.

Properties

 | Name | Description
Public property | Sites | Gets the sites.

See Also

HtmlCacheClearer Class
Sitecore.Publishing Namespace


Sites Property

[image]

Sitecore 6.4.1 API
HtmlCacheClearer..::..Sites Property
HtmlCacheClearer Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ArrayList Sites { get; }
Visual Basic
Public ReadOnly Property Sites As ArrayList
    Get
Visual C++
public:
property ArrayList^ Sites {
    ArrayList^ get ();
}

Field Value

The sites.

See Also

HtmlCacheClearer Class
Sitecore.Publishing Namespace


PipelinePublishProvider Class

[image]

Sitecore 6.4.1 API
PipelinePublishProvider Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PipelinePublishProvider : PublishProvider
Visual Basic
Public Class PipelinePublishProvider _
    Inherits PublishProvider
Visual C++
public ref class PipelinePublishProvider : public PublishProvider

Inheritance Hierarchy

System..::..Object
System.Configuration.Provider..::..ProviderBase
Sitecore.Publishing..::..PublishProvider
Sitecore.Publishing..::..PipelinePublishProvider

See Also

PipelinePublishProvider Members
Sitecore.Publishing Namespace


PipelinePublishProvider Members

[image] [image]

Sitecore 6.4.1 API
PipelinePublishProvider Members
PipelinePublishProvider Class Constructors Methods Properties See Also Send Feedback

The PipelinePublishProvider type exposes the following members.

Constructors

 | Name | Description
Public method | PipelinePublishProvider | Initializes a new instance of the PipelinePublishProvider class

Methods

 | Name | Description
Public method | CreatePublishContext | Creates a context object for use in the PublishPipeline. (Inherited from PublishProvider.)
Public method | CreatePublishHelper | Creates a publish helper instance. (Inherited from PublishProvider.)
Public method | CreatePublishItemContext | Creates a context object for use in the PublishItemPipeline. (Inherited from PublishProvider.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the provider. (Inherited from ProviderBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Publish | Performs a publish operation with the specified options. (Overrides PublishProvider..::..Publish(PublishOptions).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

PipelinePublishProvider Class
Sitecore.Publishing Namespace


PipelinePublishProvider Constructor

[image]

Sitecore 6.4.1 API
PipelinePublishProvider Constructor
PipelinePublishProvider Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PipelinePublishProvider()
Visual Basic
Public Sub New
Visual C++
public:
PipelinePublishProvider()

See Also

PipelinePublishProvider Class
Sitecore.Publishing Namespace


PipelinePublishProvider Methods

[image] [image]

Sitecore 6.4.1 API
PipelinePublishProvider Methods
PipelinePublishProvider Class See Also Send Feedback

The PipelinePublishProvider type exposes the following members.

Methods

 | Name | Description
Public method | CreatePublishContext | Creates a context object for use in the PublishPipeline. (Inherited from PublishProvider.)
Public method | CreatePublishHelper | Creates a publish helper instance. (Inherited from PublishProvider.)
Public method | CreatePublishItemContext | Creates a context object for use in the PublishItemPipeline. (Inherited from PublishProvider.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the provider. (Inherited from ProviderBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Publish | Performs a publish operation with the specified options. (Overrides PublishProvider..::..Publish(PublishOptions).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PipelinePublishProvider Class
Sitecore.Publishing Namespace


Publish Method

[image]

Sitecore 6.4.1 API
PipelinePublishProvider..::..Publish Method
PipelinePublishProvider Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Publish(
    PublishOptions options
)
Visual Basic
Public Overrides Sub Publish ( _
    options As PublishOptions _
)
Visual C++
public:
virtual void Publish(
    PublishOptions^ options
) override

Parameters

options
Type: Sitecore.Publishing..::..PublishOptions
The options.

See Also

PipelinePublishProvider Class
Sitecore.Publishing Namespace


PipelinePublishProvider Properties

[image] [image]

Sitecore 6.4.1 API
PipelinePublishProvider Properties
PipelinePublishProvider Class See Also Send Feedback

The PipelinePublishProvider type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

PipelinePublishProvider Class
Sitecore.Publishing Namespace


PreviewManager Class

[image]

Sitecore 6.4.1 API
PreviewManager Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class PreviewManager
Visual Basic
Public NotInheritable Class PreviewManager
Visual C++
public ref class PreviewManager abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Publishing..::..PreviewManager

See Also

PreviewManager Members
Sitecore.Publishing Namespace


PreviewManager Methods

[image] [image]

Sitecore 6.4.1 API
PreviewManager Methods
PreviewManager Class See Also Send Feedback

The PreviewManager type exposes the following members.

Methods

Name | Description
GetShellUser | Gets the current shell user.
ResetShellUser | Resets the current shell user (i.e. removes the cookie).
RestoreUser | Restores the previous user.
SetUserContext | Sets up the user context for the current request.
StoreShellUser()()()() | Stores the current shell user in preparation for switching to preview mode.
StoreShellUser(Boolean) | Stores the current shell user in preparation for switching to preview mode.

See Also

PreviewManager Class
Sitecore.Publishing Namespace


GetShellUser Method

[image]

Sitecore 6.4.1 API
PreviewManager..::..GetShellUser Method
PreviewManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetShellUser()
Visual Basic
Public Shared Function GetShellUser As String
Visual C++
public:
static String^ GetShellUser()

Return Value

[Missing <returns> documentation for "M:Sitecore.Publishing.PreviewManager.GetShellUser"]

Remarks

This user will be used when accessing the shell site during preview.

See Also

PreviewManager Class
Sitecore.Publishing Namespace


ResetShellUser Method

[image]

Sitecore 6.4.1 API
PreviewManager..::..ResetShellUser Method
PreviewManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void ResetShellUser()
Visual Basic
Public Shared Sub ResetShellUser
Visual C++
public:
static void ResetShellUser()

See Also

PreviewManager Class
Sitecore.Publishing Namespace


RestoreUser Method

[image]

Sitecore 6.4.1 API
PreviewManager..::..RestoreUser Method
PreviewManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void RestoreUser()
Visual Basic
Public Shared Sub RestoreUser
Visual C++
public:
static void RestoreUser()

See Also

PreviewManager Class
Sitecore.Publishing Namespace


SetUserContext Method

[image]

Sitecore 6.4.1 API
PreviewManager..::..SetUserContext Method
PreviewManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void SetUserContext()
Visual Basic
Public Shared Sub SetUserContext
Visual C++
public:
static void SetUserContext()

See Also

PreviewManager Class
Sitecore.Publishing Namespace


StoreShellUser Method

[image] [image]

Sitecore 6.4.1 API
PreviewManager..::..StoreShellUser Method
PreviewManager Class See Also Send Feedback

Overload List

Name | Description
StoreShellUser()()()() | Stores the current shell user in preparation for switching to preview mode.
StoreShellUser(Boolean) | Stores the current shell user in preparation for switching to preview mode.

See Also

PreviewManager Class
PreviewManager Members
Sitecore.Publishing Namespace


StoreShellUser Method

[image]

Sitecore 6.4.1 API
PreviewManager..::..StoreShellUser Method
PreviewManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void StoreShellUser()
Visual Basic
Public Shared Sub StoreShellUser
Visual C++
public:
static void StoreShellUser()

Remarks

The user will be used when accessing the shell site during preview.

See Also

PreviewManager Class
StoreShellUser Overload
Sitecore.Publishing Namespace


PreviewManager Properties

[image] [image]

Sitecore 6.4.1 API
PreviewManager Properties
PreviewManager Class See Also Send Feedback

The PreviewManager type exposes the following members.

Properties

Name | Description
Previewing | Gets a value indicating whether the system is in previewing mode.
Provider | Gets the provider.
Providers | Gets the providers.

See Also

PreviewManager Class
Sitecore.Publishing Namespace


Previewing Property

[image]

Sitecore 6.4.1 API
PreviewManager..::..Previewing Property
PreviewManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool Previewing { get; }
Visual Basic
Public Shared ReadOnly Property Previewing As Boolean
    Get
Visual C++
public:
static property bool Previewing {
    bool get ();
}

Field Value

true if previewing; otherwise, false.

See Also

PreviewManager Class
Sitecore.Publishing Namespace


Provider Property

[image]

Sitecore 6.4.1 API
PreviewManager..::..Provider Property
PreviewManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PreviewProvider Provider { get; }
Visual Basic
Public Shared ReadOnly Property Provider As PreviewProvider
    Get
Visual C++
public:
static property PreviewProvider^ Provider {
    PreviewProvider^ get ();
}

Field Value

The provider.

See Also

PreviewManager Class
Sitecore.Publishing Namespace


Providers Property

[image]

Sitecore 6.4.1 API
PreviewManager..::..Providers Property
PreviewManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PreviewProviderCollection Providers { get; }
Visual Basic
Public Shared ReadOnly Property Providers As PreviewProviderCollection
    Get
Visual C++
public:
static property PreviewProviderCollection^ Providers {
    PreviewProviderCollection^ get ();
}

Field Value

The provider.

See Also

PreviewManager Class
Sitecore.Publishing Namespace


PreviewProvider Class

[image]

Sitecore 6.4.1 API
PreviewProvider Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PreviewProvider : ProviderBase
Visual Basic
Public Class PreviewProvider _
    Inherits ProviderBase
Visual C++
public ref class PreviewProvider : public ProviderBase

Inheritance Hierarchy

System..::..Object
System.Configuration.Provider..::..ProviderBase
Sitecore.Publishing..::..PreviewProvider

See Also

PreviewProvider Members
Sitecore.Publishing Namespace


PreviewProvider Members

[image] [image]

Sitecore 6.4.1 API
PreviewProvider Members
PreviewProvider Class Constructors Methods Properties See Also Send Feedback

The PreviewProvider type exposes the following members.

Constructors

 | Name | Description
Public method | PreviewProvider | Initializes a new instance of the PreviewProvider class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetShellUser | Gets the current shell user.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the provider. (Inherited from ProviderBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResetShellUser | Resets the current shell user (i.e. removes the cookie).
Public method | RestoreUser | Restores the previous user.
Public method | SetUserContext | Sets up the user context for the current request.
Public method | StoreShellUser()()()() | Stores the current user in preparation for switching to preview mode.
Public method | StoreShellUser(Boolean) | Stores the current user in preparation for switching to preview mode.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
Public property | Previewing | Gets a value indicating whether the system is in previewing mode.

See Also

PreviewProvider Class
Sitecore.Publishing Namespace


PreviewProvider Constructor

[image]

Sitecore 6.4.1 API
PreviewProvider Constructor
PreviewProvider Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PreviewProvider()
Visual Basic
Public Sub New
Visual C++
public:
PreviewProvider()

See Also

PreviewProvider Class
Sitecore.Publishing Namespace


PreviewProvider Methods

[image] [image]

Sitecore 6.4.1 API
PreviewProvider Methods
PreviewProvider Class See Also Send Feedback

The PreviewProvider type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetShellUser | Gets the current shell user.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the provider. (Inherited from ProviderBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResetShellUser | Resets the current shell user (i.e. removes the cookie).
Public method | RestoreUser | Restores the previous user.
Public method | SetUserContext | Sets up the user context for the current request.
Public method | StoreShellUser()()()() | Stores the current user in preparation for switching to preview mode.
Public method | StoreShellUser(Boolean) | Stores the current user in preparation for switching to preview mode.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PreviewProvider Class
Sitecore.Publishing Namespace


ResetShellUser Method

[image]

Sitecore 6.4.1 API
PreviewProvider..::..ResetShellUser Method
PreviewProvider Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void ResetShellUser()
Visual Basic
Public Overridable Sub ResetShellUser
Visual C++
public:
virtual void ResetShellUser()

See Also

PreviewProvider Class
Sitecore.Publishing Namespace


SetUserContext Method

[image]

Sitecore 6.4.1 API
PreviewProvider..::..SetUserContext Method
PreviewProvider Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void SetUserContext()
Visual Basic
Public Overridable Sub SetUserContext
Visual C++
public:
virtual void SetUserContext()

See Also

PreviewProvider Class
Sitecore.Publishing Namespace


StoreShellUser Method

[image] [image]

Sitecore 6.4.1 API
PreviewProvider..::..StoreShellUser Method
PreviewProvider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StoreShellUser()()()() | Stores the current user in preparation for switching to preview mode.
Public method | StoreShellUser(Boolean) | Stores the current user in preparation for switching to preview mode.

See Also

PreviewProvider Class
PreviewProvider Members
Sitecore.Publishing Namespace


StoreShellUser Method

[image]

Sitecore 6.4.1 API
PreviewProvider..::..StoreShellUser Method
PreviewProvider Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void StoreShellUser()
Visual Basic
Public Overridable Sub StoreShellUser
Visual C++
public:
virtual void StoreShellUser()

Remarks

The user will be used when accessing the shell site during preview.

See Also

PreviewProvider Class
StoreShellUser Overload
Sitecore.Publishing Namespace


StoreShellUser Method (Boolean)

[image]

Sitecore 6.4.1 API
PreviewProvider..::..StoreShellUser Method (Boolean)
PreviewProvider Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void StoreShellUser(
    bool forceLogout
)
Visual Basic
Public Sub StoreShellUser ( _
    forceLogout As Boolean _
)
Visual C++
public:
void StoreShellUser(
    bool forceLogout
)

Parameters

forceLogout
Type: System..::..Boolean
Force current user to logout.

Remarks

The user will be used when accessing the shell site during preview.

See Also

PreviewProvider Class
StoreShellUser Overload
Sitecore.Publishing Namespace


PreviewProvider Properties

[image] [image]

Sitecore 6.4.1 API
PreviewProvider Properties
PreviewProvider Class See Also Send Feedback

The PreviewProvider type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)
Public property | Previewing | Gets a value indicating whether the system is in previewing mode.

See Also

PreviewProvider Class
Sitecore.Publishing Namespace


Previewing Property

[image]

Sitecore 6.4.1 API
PreviewProvider..::..Previewing Property
PreviewProvider Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool Previewing { get; }
Visual Basic
Public Overridable ReadOnly Property Previewing As Boolean
    Get
Visual C++
public:
virtual property bool Previewing {
    bool get ();
}

Field Value

true if previewing; otherwise, false.

See Also

PreviewProvider Class
Sitecore.Publishing Namespace


PreviewProviderCollection Class

[image]

Sitecore 6.4.1 API
PreviewProviderCollection Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PreviewProviderCollection : ProviderCollection
Visual Basic
Public Class PreviewProviderCollection _
    Inherits ProviderCollection
Visual C++
public ref class PreviewProviderCollection : public ProviderCollection

Inheritance Hierarchy

System..::..Object
System.Configuration.Provider..::..ProviderCollection
Sitecore.Publishing..::..PreviewProviderCollection

See Also

PreviewProviderCollection Members
Sitecore.Publishing Namespace


PreviewProviderCollection Members

[image] [image]

Sitecore 6.4.1 API
PreviewProviderCollection Members
PreviewProviderCollection Class Constructors Methods Properties See Also Send Feedback

The PreviewProviderCollection type exposes the following members.

Constructors

 | Name | Description
Public method | PreviewProviderCollection | Initializes a new instance of the PreviewProviderCollection class

Methods

 | Name | Description
Public method | Add | Adds a provider to the collection. (Inherited from ProviderCollection.)
Public method | Clear | Removes all items from the collection. (Inherited from ProviderCollection.)
Public method | CopyTo | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a provider from the collection. (Inherited from ProviderCollection.)
Public method | SetReadOnly | Sets the collection to be read-only. (Inherited from ProviderCollection.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
Public property | Item | Gets the PreviewProvider with the specified name.
Public property | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)

See Also

PreviewProviderCollection Class
Sitecore.Publishing Namespace


PreviewProviderCollection Constructor

[image]

Sitecore 6.4.1 API
PreviewProviderCollection Constructor
PreviewProviderCollection Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PreviewProviderCollection()
Visual Basic
Public Sub New
Visual C++
public:
PreviewProviderCollection()

See Also

PreviewProviderCollection Class
Sitecore.Publishing Namespace


PreviewProviderCollection Methods

[image] [image]

Sitecore 6.4.1 API
PreviewProviderCollection Methods
PreviewProviderCollection Class See Also Send Feedback

The PreviewProviderCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds a provider to the collection. (Inherited from ProviderCollection.)
Public method | Clear | Removes all items from the collection. (Inherited from ProviderCollection.)
Public method | CopyTo | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a provider from the collection. (Inherited from ProviderCollection.)
Public method | SetReadOnly | Sets the collection to be read-only. (Inherited from ProviderCollection.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PreviewProviderCollection Class
Sitecore.Publishing Namespace


PreviewProviderCollection Properties

[image] [image]

Sitecore 6.4.1 API
PreviewProviderCollection Properties
PreviewProviderCollection Class See Also Send Feedback

The PreviewProviderCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
Public property | Item | Gets the PreviewProvider with the specified name.
Public property | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)

See Also

PreviewProviderCollection Class
Sitecore.Publishing Namespace


Item Property

[image]

Sitecore 6.4.1 API
PreviewProviderCollection..::..Item Property
PreviewProviderCollection Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PreviewProvider this[
    string name
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    name As String _
) As PreviewProvider
    Get
Visual C++
public:
property PreviewProvider^ default[String^ name] {
    PreviewProvider^ get (String^ name);
}

Parameters

name
Type: System..::..String

Field Value

See Also

PreviewProviderCollection Class
Sitecore.Publishing Namespace


PublishAction Enumeration

[image]

Sitecore 6.4.1 API
PublishAction Enumeration
See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum PublishAction
Visual Basic
Public Enumeration PublishAction
Visual C++
public enum class PublishAction

Members

Member name | Value | Description
None | 0 | Action type has not been set.
DeleteTargetItem | 1 | Delete the target item.
PublishSharedFields | 2 | Publish only shared fields. All versions in the publishing language will be deleted from the target item.
PublishVersion | 3 | Publish a version of the item.

See Also

Sitecore.Publishing Namespace


PublishChildAction Enumeration

[image]

Sitecore 6.4.1 API
PublishChildAction Enumeration
See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum PublishChildAction
Visual Basic
Public Enumeration PublishChildAction
Visual C++
public enum class PublishChildAction

Members

Member name | Value | Description
Skip | 0 | Do not publish the children.
Allow | 1 | Allow the children to be published.
Force | 2 | Force publishing of the children.

See Also

Sitecore.Publishing Namespace


PublishChildComparer Class

[image]

Sitecore 6.4.1 API
PublishChildComparer Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PublishChildComparer : IComparer<Item>
Visual Basic
Public Class PublishChildComparer _
    Implements IComparer(Of Item)
Visual C++
public ref class PublishChildComparer : IComparer<Item^>

Inheritance Hierarchy

System..::..Object
Sitecore.Publishing..::..PublishChildComparer

See Also

PublishChildComparer Members
Sitecore.Publishing Namespace


PublishChildComparer Members

[image] [image]

Sitecore 6.4.1 API
PublishChildComparer Members
PublishChildComparer Class Constructors Methods See Also Send Feedback

The PublishChildComparer type exposes the following members.

Constructors

 | Name | Description
Public method | PublishChildComparer | Initializes a new instance of the PublishChildComparer class

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. Templates are always less than regular Items Items with short paths are lesser than Items with long paths.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PublishChildComparer Class
Sitecore.Publishing Namespace


PublishChildComparer Constructor

[image]

Sitecore 6.4.1 API
PublishChildComparer Constructor
PublishChildComparer Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PublishChildComparer()
Visual Basic
Public Sub New
Visual C++
public:
PublishChildComparer()

See Also

PublishChildComparer Class
Sitecore.Publishing Namespace


PublishChildComparer Methods

[image] [image]

Sitecore 6.4.1 API
PublishChildComparer Methods
PublishChildComparer Class See Also Send Feedback

The PublishChildComparer type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. Templates are always less than regular Items Items with short paths are lesser than Items with long paths.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PublishChildComparer Class
Sitecore.Publishing Namespace


Compare Method

[image]

Sitecore 6.4.1 API
PublishChildComparer..::..Compare Method
PublishChildComparer Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Compare(
    Item itemX,
    Item itemY
)
Visual Basic
Public Function Compare ( _
    itemX As Item, _
    itemY As Item _
) As Integer
Visual C++
public:
virtual int Compare(
    Item^ itemX,
    Item^ itemY
) sealed

Parameters

itemX
Type: Sitecore.Data.Items..::..Item
The first item to compare.
itemY
Type: Sitecore.Data.Items..::..Item
The second item to compare.

Return Value

Value Condition: Less than zero if itemX is 'less' than itemY. Zero if itemX 'equals' itemY. Greater than zero if itemX is 'greater' than itemY.

Implements

IComparer<(Of <(<'T>)>)>..::..Compare(T, T)

Exceptions

Exception | Condition
System..::..ArgumentException | Neither x nor y implements the IComparable interface.-or- x and y are of different types and neither one can handle comparisons with the other.

See Also

PublishChildComparer Class
Sitecore.Publishing Namespace


Publisher Class

[image]

Sitecore 6.4.1 API
Publisher Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Publisher
Visual Basic
Public Class Publisher
Visual C++
public ref class Publisher

Inheritance Hierarchy

System..::..Object
Sitecore.Publishing..::..Publisher

See Also

Publisher Members
Sitecore.Publishing Namespace


Publisher Members

[image] [image]

Sitecore 6.4.1 API
Publisher Members
Publisher Class Constructors Methods Properties See Also Send Feedback

The Publisher type exposes the following members.

Constructors

 | Name | Description
Public method | Publisher | Initializes a new instance of the Publisher class.

Methods

 | Name | Description
Protected method | AssertState | Asserts the state.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetJobName | Gets the name of the job that will be used when publishing is run asynchronously.
Protected method | GetPublishLock | Gets a publish lock.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotifyBegin | Notifies the begin.
Protected method | NotifyEnd | Notifies the end.
Protected method | NotifyFailure | Notifies the failure.
Protected method | PerformPublish | Executes the publish event.
Public method | Publish | Publishes this instance.
Public method | PublishAsync | Performs publishing asynchronously.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | UpdateLastPublish | Updates the last publish.

Properties

 | Name | Description
Public property | Options | Gets the options.
Public property | WillBeQueued | Gets a value indicating whether the Publisher wills the be queued.

See Also

Publisher Class
Sitecore.Publishing Namespace


Publisher Constructor

[image]

Sitecore 6.4.1 API
Publisher Constructor
Publisher Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Publisher(
    PublishOptions options
)
Visual Basic
Public Sub New ( _
    options As PublishOptions _
)
Visual C++
public:
Publisher(
    PublishOptions^ options
)

Parameters

options
Type: Sitecore.Publishing..::..PublishOptions
The options.

See Also

Publisher Class
Sitecore.Publishing Namespace


Publisher Methods

[image] [image]

Sitecore 6.4.1 API
Publisher Methods
Publisher Class See Also Send Feedback

The Publisher type exposes the following members.

Methods

 | Name | Description
Protected method | AssertState | Asserts the state.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetJobName | Gets the name of the job that will be used when publishing is run asynchronously.
Protected method | GetPublishLock | Gets a publish lock.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotifyBegin | Notifies the begin.
Protected method | NotifyEnd | Notifies the end.
Protected method | NotifyFailure | Notifies the failure.
Protected method | PerformPublish | Executes the publish event.
Public method | Publish | Publishes this instance.
Public method | PublishAsync | Performs publishing asynchronously.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | UpdateLastPublish | Updates the last publish.

See Also

Publisher Class
Sitecore.Publishing Namespace


AssertState Method

[image]

Sitecore 6.4.1 API
Publisher..::..AssertState Method
Publisher Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void AssertState()
Visual Basic
Protected Overridable Sub AssertState
Visual C++
protected:
virtual void AssertState()

Exceptions

Exception | Condition
System..::..InvalidOperationException | Throws a InvalidOperationException if the Mode is unknown.

See Also

Publisher Class
Sitecore.Publishing Namespace


GetJobName Method

[image]

Sitecore 6.4.1 API
Publisher..::..GetJobName Method
Publisher Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string GetJobName()
Visual Basic
Public Overridable Function GetJobName As String
Visual C++
public:
virtual String^ GetJobName()

Return Value

[Missing <returns> documentation for "M:Sitecore.Publishing.Publisher.GetJobName"]

See Also

Publisher Class
Sitecore.Publishing Namespace


GetPublishLock Method

[image]

Sitecore 6.4.1 API
Publisher..::..GetPublishLock Method
Publisher Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual Object GetPublishLock()
Visual Basic
Protected Overridable Function GetPublishLock As Object
Visual C++
protected:
virtual Object^ GetPublishLock()

Return Value

[Missing <returns> documentation for "M:Sitecore.Publishing.Publisher.GetPublishLock"]

See Also

Publisher Class
Sitecore.Publishing Namespace


NotifyBegin Method

[image]

Sitecore 6.4.1 API
Publisher..::..NotifyBegin Method
Publisher Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void NotifyBegin()
Visual Basic
Protected Overridable Sub NotifyBegin
Visual C++
protected:
virtual void NotifyBegin()

See Also

Publisher Class
Sitecore.Publishing Namespace


NotifyEnd Method

[image]

Sitecore 6.4.1 API
Publisher..::..NotifyEnd Method
Publisher Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void NotifyEnd()
Visual Basic
Protected Overridable Sub NotifyEnd
Visual C++
protected:
virtual void NotifyEnd()

See Also

Publisher Class
Sitecore.Publishing Namespace


NotifyFailure Method

[image]

Sitecore 6.4.1 API
Publisher..::..NotifyFailure Method
Publisher Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void NotifyFailure(
    Exception ex
)
Visual Basic
Protected Overridable Sub NotifyFailure ( _
    ex As Exception _
)
Visual C++
protected:
virtual void NotifyFailure(
    Exception^ ex
)

Parameters

ex
Type: System..::..Exception
The ex.

See Also

Publisher Class
Sitecore.Publishing Namespace


PerformPublish Method

[image]

Sitecore 6.4.1 API
Publisher..::..PerformPublish Method
Publisher Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void PerformPublish()
Visual Basic
Protected Overridable Sub PerformPublish
Visual C++
protected:
virtual void PerformPublish()

See Also

Publisher Class
Sitecore.Publishing Namespace


Publish Method

[image]

Sitecore 6.4.1 API
Publisher..::..Publish Method
Publisher Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void Publish()
Visual Basic
Public Overridable Sub Publish
Visual C++
public:
virtual void Publish()

Exceptions

Exception | Condition
System..::..Exception | Exception.

See Also

Publisher Class
Sitecore.Publishing Namespace


PublishAsync Method

[image]

Sitecore 6.4.1 API
Publisher..::..PublishAsync Method
Publisher Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Job PublishAsync()
Visual Basic
Public Overridable Function PublishAsync As Job
Visual C++
public:
virtual Job^ PublishAsync()

Return Value

[Missing <returns> documentation for "M:Sitecore.Publishing.Publisher.PublishAsync"]

See Also

Publisher Class
Sitecore.Publishing Namespace


UpdateLastPublish Method

[image]

Sitecore 6.4.1 API
Publisher..::..UpdateLastPublish Method
Publisher Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void UpdateLastPublish()
Visual Basic
Protected Overridable Sub UpdateLastPublish
Visual C++
protected:
virtual void UpdateLastPublish()

See Also

Publisher Class
Sitecore.Publishing Namespace


Publisher Properties

[image] [image]

Sitecore 6.4.1 API
Publisher Properties
Publisher Class See Also Send Feedback

The Publisher type exposes the following members.

Properties

 | Name | Description
Public property | Options | Gets the options.
Public property | WillBeQueued | Gets a value indicating whether the Publisher wills the be queued.

See Also

Publisher Class
Sitecore.Publishing Namespace


Options Property

[image]

Sitecore 6.4.1 API
Publisher..::..Options Property
Publisher Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual PublishOptions Options { get; }
Visual Basic
Public Overridable ReadOnly Property Options As PublishOptions
    Get
Visual C++
public:
virtual property PublishOptions^ Options {
    PublishOptions^ get ();
}

Field Value

The options.

See Also

Publisher Class
Sitecore.Publishing Namespace


WillBeQueued Property

[image]

Sitecore 6.4.1 API
Publisher..::..WillBeQueued Property
Publisher Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool WillBeQueued { get; }
Visual Basic
Public Overridable ReadOnly Property WillBeQueued As Boolean
    Get
Visual C++
public:
virtual property bool WillBeQueued {
    bool get ();
}

Field Value

true if the Publisher wills the be queued; otherwise, false.

See Also

Publisher Class
Sitecore.Publishing Namespace


PublishHelper Constructor

[image]

Sitecore 6.4.1 API
PublishHelper Constructor
PublishHelper Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PublishHelper(
    PublishOptions options
)
Visual Basic
Public Sub New ( _
    options As PublishOptions _
)
Visual C++
public:
PublishHelper(
    PublishOptions^ options
)

Parameters

options
Type: Sitecore.Publishing..::..PublishOptions
The options.

See Also

PublishHelper Class
Sitecore.Publishing Namespace


PublishHelper Methods

[image] [image]

Sitecore 6.4.1 API
PublishHelper Methods
PublishHelper Class See Also Send Feedback

The PublishHelper type exposes the following members.

Methods

 | Name | Description
Public method | CanPublish | Determines whether a user can publish the specified item id.
Protected method | CopyToTarget | Copies the specified source version to the target.
Public method | DeleteTargetItem | Deletes the specified target item (if it exists).
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemToPublish | Gets the item to publish.
Public method | GetSourceItem | Gets the source item.
Public method | GetTargetItem | Gets the target item.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUnknownChildIds | Gets the unknown child ids (children that are in the target but not in the source).
Public method | GetVersionToPublish | Gets the version to publish.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PublishSharedFields | Publishes the shared fields.
Public method | PublishVersion | Publishes the version.
Public method | SourceItemExists | Determines if a source item exists.
Public method | TargetItemExists | Determines if a target item exists.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PublishHelper Class
Sitecore.Publishing Namespace


CanPublish Method

[image]

Sitecore 6.4.1 API
PublishHelper..::..CanPublish Method
PublishHelper Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool CanPublish(
    ID itemId,
    User user,
    ref string explanation
)
Visual Basic
Public Function CanPublish ( _
    itemId As ID, _
    user As User, _
    ByRef explanation As String _
) As Boolean
Visual C++
public:
bool CanPublish(
    ID^ itemId,
    User^ user,
    String^% explanation
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
user
Type: Sitecore.Security.Accounts..::..User
The user.
explanation
Type: System..::..String %
A message explaining why the user can not publish the item.

Return Value

true if the user can publish the specified item id; otherwise, false.

See Also

PublishHelper Class
Sitecore.Publishing Namespace


CopyToTarget Method

[image]

Sitecore 6.4.1 API
PublishHelper..::..CopyToTarget Method
PublishHelper Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void CopyToTarget(
    Item sourceVersion
)
Visual Basic
Protected Overridable Sub CopyToTarget ( _
    sourceVersion As Item _
)
Visual C++
protected:
virtual void CopyToTarget(
    Item^ sourceVersion
)

Parameters

sourceVersion
Type: Sitecore.Data.Items..::..Item
The source version.

See Also

PublishHelper Class
Sitecore.Publishing Namespace


DeleteTargetItem Method

[image]

Sitecore 6.4.1 API
PublishHelper..::..DeleteTargetItem Method
PublishHelper Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual PublishItemResult DeleteTargetItem(
    ID itemId
)
Visual Basic
Public Overridable Function DeleteTargetItem ( _
    itemId As ID _
) As PublishItemResult
Visual C++
public:
virtual PublishItemResult^ DeleteTargetItem(
    ID^ itemId
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Publishing.PublishHelper.DeleteTargetItem(Sitecore.Data.ID)"]

See Also

PublishHelper Class
Sitecore.Publishing Namespace


GetItemToPublish Method

[image]

Sitecore 6.4.1 API
PublishHelper..::..GetItemToPublish Method
PublishHelper Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item GetItemToPublish(
    ID itemId
)
Visual Basic
Public Function GetItemToPublish ( _
    itemId As ID _
) As Item
Visual C++
public:
Item^ GetItemToPublish(
    ID^ itemId
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Publishing.PublishHelper.GetItemToPublish(Sitecore.Data.ID)"]

Remarks

This might not be the exact version that is to be published. This is found by calling GetVersionToPublish(Item).

See Also

PublishHelper Class
Sitecore.Publishing Namespace


GetSourceItem Method

[image]

Sitecore 6.4.1 API
PublishHelper..::..GetSourceItem Method
PublishHelper Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Item GetSourceItem(
    ID itemId
)
Visual Basic
Public Overridable Function GetSourceItem ( _
    itemId As ID _
) As Item
Visual C++
public:
virtual Item^ GetSourceItem(
    ID^ itemId
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item Id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Publishing.PublishHelper.GetSourceItem(Sitecore.Data.ID)"]

See Also

PublishHelper Class
Sitecore.Publishing Namespace


GetUnknownChildIds Method

[image]

Sitecore 6.4.1 API
PublishHelper..::..GetUnknownChildIds Method
PublishHelper Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual IEnumerable<ID> GetUnknownChildIds(
    ID itemId
)
Visual Basic
Public Overridable Function GetUnknownChildIds ( _
    itemId As ID _
) As IEnumerable(Of ID)
Visual C++
public:
virtual IEnumerable<ID^>^ GetUnknownChildIds(
    ID^ itemId
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The source item id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Publishing.PublishHelper.GetUnknownChildIds(Sitecore.Data.ID)"]

See Also

PublishHelper Class
Sitecore.Publishing Namespace


GetVersionToPublish Method

[image]

Sitecore 6.4.1 API
PublishHelper..::..GetVersionToPublish Method
PublishHelper Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Item GetVersionToPublish(
    Item sourceItem
)
Visual Basic
Public Overridable Function GetVersionToPublish ( _
    sourceItem As Item _
) As Item
Visual C++
public:
virtual Item^ GetVersionToPublish(
    Item^ sourceItem
)

Parameters

sourceItem
Type: Sitecore.Data.Items..::..Item
The source item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Publishing.PublishHelper.GetVersionToPublish(Sitecore.Data.Items.Item)"]

See Also

PublishHelper Class
Sitecore.Publishing Namespace


PublishSharedFields Method

[image]

Sitecore 6.4.1 API
PublishHelper..::..PublishSharedFields Method
PublishHelper Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PublishItemResult PublishSharedFields(
    Item sourceItem
)
Visual Basic
Public Function PublishSharedFields ( _
    sourceItem As Item _
) As PublishItemResult
Visual C++
public:
PublishItemResult^ PublishSharedFields(
    Item^ sourceItem
)

Parameters

sourceItem
Type: Sitecore.Data.Items..::..Item
The source item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Publishing.PublishHelper.PublishSharedFields(Sitecore.Data.Items.Item)"]

See Also

PublishHelper Class
Sitecore.Publishing Namespace


PublishVersion Method

[image]

Sitecore 6.4.1 API
PublishHelper..::..PublishVersion Method
PublishHelper Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PublishItemResult PublishVersion(
    Item sourceVersion
)
Visual Basic
Public Function PublishVersion ( _
    sourceVersion As Item _
) As PublishItemResult
Visual C++
public:
PublishItemResult^ PublishVersion(
    Item^ sourceVersion
)

Parameters

sourceVersion
Type: Sitecore.Data.Items..::..Item
The source version.

Return Value

[Missing <returns> documentation for "M:Sitecore.Publishing.PublishHelper.PublishVersion(Sitecore.Data.Items.Item)"]

See Also

PublishHelper Class
Sitecore.Publishing Namespace


SourceItemExists Method

[image]

Sitecore 6.4.1 API
PublishHelper..::..SourceItemExists Method
PublishHelper Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool SourceItemExists(
    ID itemId
)
Visual Basic
Public Function SourceItemExists ( _
    itemId As ID _
) As Boolean
Visual C++
public:
bool SourceItemExists(
    ID^ itemId
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.

Return Value

The source item exists.

See Also

PublishHelper Class
Sitecore.Publishing Namespace


Options Property

[image]

Sitecore 6.4.1 API
PublishHelper..::..Options Property
PublishHelper Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual PublishOptions Options { get; }
Visual Basic
Public Overridable ReadOnly Property Options As PublishOptions
    Get
Visual C++
public:
virtual property PublishOptions^ Options {
    PublishOptions^ get ();
}

Field Value

The options.

See Also

PublishHelper Class
Sitecore.Publishing Namespace


PublishManager Class

[image]

Sitecore 6.4.1 API
PublishManager Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PublishManager
Visual Basic
Public Class PublishManager
Visual C++
public ref class PublishManager

Inheritance Hierarchy

System..::..Object
Sitecore.Publishing..::..PublishManager

See Also

PublishManager Members
Sitecore.Publishing Namespace


PublishManager Members

[image] [image]

Sitecore 6.4.1 API
PublishManager Members
PublishManager Class Constructors Methods Properties See Also Send Feedback

The PublishManager type exposes the following members.

Constructors

 | Name | Description
Public method | PublishManager | Initializes a new instance of the PublishManager class

Methods

 | Name | Description
 | AddToPublishQueue(Item, ItemUpdateType) | Updates the publish queue.
 | AddToPublishQueue(Item, ItemUpdateType, DateTime) | Updates the publish queue.
 | AddToPublishQueue(Item, String, DateTime) | Adds an item to the publish queue.
 | CleanupPublishQueue | Cleans up the publish queue.
 | ClearPublishQueue | Clears the publish queue.
 | CreatePublishContext | Creates a context object for use in the PublishPipeline.
 | CreatePublishHelper | Gets a publish Helper.
 | CreatePublishItemContext | Creates a context object for use in the PublishItemPipeline.
Protected method | DoPublish | Executes the publish event.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPublishingTargets | Gets the publishing targets defined in a specific database.
 | GetPublishQueue(Database) | Gets the publish queue.
 | GetPublishQueue(DateTime, DateTime, Database) | Gets the publish queue.
 | GetStatus | Gets the status.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize | Initializes event handlers.
 | IsSmartPublishScheduled | Checks if a smart publish is scheduled.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Publish(PublishOptions) | Obsolete. Publishes with specified options.
 | Publish(array<PublishOptions>[]()[][]) | Publishes with specified options.
 | Publish(array<PublishOptions>[]()[][], Language) | Publishes with specified options.
 | PublishIncremental(Database, array<Database>[]()[][], array<Language>[]()[][]) | Publishes in incremental mode.
 | PublishIncremental(Database, array<Database>[]()[][], array<Language>[]()[][], Language) | Publishes in incremental mode.
 | PublishItem | Publishes an item.
 | PublishSmart(Database, array<Database>[]()[][], array<Language>[]()[][]) | Publishes in smart mode.
 | PublishSmart(Database, array<Database>[]()[][], array<Language>[]()[][], Language) | Publishes in smart mode.
 | RebuildDatabase | Rebuilds the database.
 | Republish(Database, array<Database>[]()[][], array<Language>[]()[][]) | Republishes the specified source.
 | Republish(Database, array<Database>[]()[][], array<Language>[]()[][], Language) | Republishes the specified source.
 | ScheduleSmartPublish(Database) | Schedules a smart publish for all targets and languages in a database.
 | ScheduleSmartPublish(Database, String, Language) | Schedules a smart publish.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | UnscheduleSmartPublish | Unschedules a smart publish.
 | WaitFor | Waits for the specified handle.

Properties

Name | Description
Provider | Gets the provider.
Providers | Gets the providers.
PublishStrategy | Gets the publish strategy.

See Also

PublishManager Class
Sitecore.Publishing Namespace


PublishManager Constructor

[image]

Sitecore 6.4.1 API
PublishManager Constructor
PublishManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PublishManager()
Visual Basic
Public Sub New
Visual C++
public:
PublishManager()

See Also

PublishManager Class
Sitecore.Publishing Namespace


PublishManager Methods

[image] [image]

Sitecore 6.4.1 API
PublishManager Methods
PublishManager Class See Also Send Feedback

The PublishManager type exposes the following members.

Methods

 | Name | Description
 | AddToPublishQueue(Item, ItemUpdateType) | Updates the publish queue.
 | AddToPublishQueue(Item, ItemUpdateType, DateTime) | Updates the publish queue.
 | AddToPublishQueue(Item, String, DateTime) | Adds an item to the publish queue.
 | CleanupPublishQueue | Cleans up the publish queue.
 | ClearPublishQueue | Clears the publish queue.
 | CreatePublishContext | Creates a context object for use in the PublishPipeline.
 | CreatePublishHelper | Gets a publish Helper.
 | CreatePublishItemContext | Creates a context object for use in the PublishItemPipeline.
Protected method | DoPublish | Executes the publish event.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPublishingTargets | Gets the publishing targets defined in a specific database.
 | GetPublishQueue(Database) | Gets the publish queue.
 | GetPublishQueue(DateTime, DateTime, Database) | Gets the publish queue.
 | GetStatus | Gets the status.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize | Initializes event handlers.
 | IsSmartPublishScheduled | Checks if a smart publish is scheduled.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Publish(PublishOptions) | Obsolete. Publishes with specified options.
 | Publish(array<PublishOptions>[]()[][]) | Publishes with specified options.
 | Publish(array<PublishOptions>[]()[][], Language) | Publishes with specified options.
 | PublishIncremental(Database, array<Database>[]()[][], array<Language>[]()[][]) | Publishes in incremental mode.
 | PublishIncremental(Database, array<Database>[]()[][], array<Language>[]()[][], Language) | Publishes in incremental mode.
 | PublishItem | Publishes an item.
 | PublishSmart(Database, array<Database>[]()[][], array<Language>[]()[][]) | Publishes in smart mode.
 | PublishSmart(Database, array<Database>[]()[][], array<Language>[]()[][], Language) | Publishes in smart mode.
 | RebuildDatabase | Rebuilds the database.
 | Republish(Database, array<Database>[]()[][], array<Language>[]()[][]) | Republishes the specified source.
 | Republish(Database, array<Database>[]()[][], array<Language>[]()[][], Language) | Republishes the specified source.
 | ScheduleSmartPublish(Database) | Schedules a smart publish for all targets and languages in a database.
 | ScheduleSmartPublish(Database, String, Language) | Schedules a smart publish.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | UnscheduleSmartPublish | Unschedules a smart publish.
 | WaitFor | Waits for the specified handle.

See Also

PublishManager Class
Sitecore.Publishing Namespace


AddToPublishQueue Method

[image] [image]

Sitecore 6.4.1 API
PublishManager..::..AddToPublishQueue Method
PublishManager Class See Also Send Feedback

Overload List

Name | Description
AddToPublishQueue(Item, ItemUpdateType) | Updates the publish queue.
AddToPublishQueue(Item, ItemUpdateType, DateTime) | Updates the publish queue.
AddToPublishQueue(Item, String, DateTime) | Adds an item to the publish queue.

See Also

PublishManager Class
PublishManager Members
Sitecore.Publishing Namespace


AddToPublishQueue Method (Item, ItemUpdateType)

[image]

Sitecore 6.4.1 API
PublishManager..::..AddToPublishQueue Method (Item, ItemUpdateType)
PublishManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void AddToPublishQueue(
    Item item,
    ItemUpdateType updateType
)
Visual Basic
Public Shared Sub AddToPublishQueue ( _
    item As Item, _
    updateType As ItemUpdateType _
)
Visual C++
public:
static void AddToPublishQueue(
    Item^ item,
    ItemUpdateType updateType
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item that should be added.
updateType
Type: Sitecore.Data.Items..::..ItemUpdateType
Type of the update.

See Also

PublishManager Class
AddToPublishQueue Overload
Sitecore.Publishing Namespace


AddToPublishQueue Method (Item, String, DateTime)

[image]

Sitecore 6.4.1 API
PublishManager..::..AddToPublishQueue Method (Item, String, DateTime)
PublishManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool AddToPublishQueue(
    Item item,
    string action,
    DateTime date
)
Visual Basic
Public Shared Function AddToPublishQueue ( _
    item As Item, _
    action As String, _
    date As DateTime _
) As Boolean
Visual C++
public:
static bool AddToPublishQueue(
    Item^ item,
    String^ action,
    DateTime date
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item to publish.
action
Type: System..::..String
The action.
date
Type: System..::..DateTime
The publish date.

Return Value

The add to publish queue.

See Also

PublishManager Class
AddToPublishQueue Overload
Sitecore.Publishing Namespace


CleanupPublishQueue Method

[image]

Sitecore 6.4.1 API
PublishManager..::..CleanupPublishQueue Method
PublishManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool CleanupPublishQueue(
    DateTime to,
    Database database
)
Visual Basic
Public Shared Function CleanupPublishQueue ( _
    to As DateTime, _
    database As Database _
) As Boolean
Visual C++
public:
static bool CleanupPublishQueue(
    DateTime to,
    Database^ database
)

Parameters

to
Type: System..::..DateTime
Publish to date.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

The cleanup publish queue.

See Also

PublishManager Class
Sitecore.Publishing Namespace


ClearPublishQueue Method

[image]

Sitecore 6.4.1 API
PublishManager..::..ClearPublishQueue Method
PublishManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void ClearPublishQueue(
    Database database
)
Visual Basic
Public Shared Sub ClearPublishQueue ( _
    database As Database _
)
Visual C++
public:
static void ClearPublishQueue(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

See Also

PublishManager Class
Sitecore.Publishing Namespace


CreatePublishContext Method

[image]

Sitecore 6.4.1 API
PublishManager..::..CreatePublishContext Method
PublishManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PublishContext CreatePublishContext(
    PublishOptions options
)
Visual Basic
Public Shared Function CreatePublishContext ( _
    options As PublishOptions _
) As PublishContext
Visual C++
public:
static PublishContext^ CreatePublishContext(
    PublishOptions^ options
)

Parameters

options
Type: Sitecore.Publishing..::..PublishOptions
The options.

Return Value

Publish context object

See Also

PublishManager Class
Sitecore.Publishing Namespace


CreatePublishHelper Method

[image]

Sitecore 6.4.1 API
PublishManager..::..CreatePublishHelper Method
PublishManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PublishHelper CreatePublishHelper(
    PublishOptions options
)
Visual Basic
Public Shared Function CreatePublishHelper ( _
    options As PublishOptions _
) As PublishHelper
Visual C++
public:
static PublishHelper^ CreatePublishHelper(
    PublishOptions^ options
)

Parameters

options
Type: Sitecore.Publishing..::..PublishOptions
The options.

Return Value

PublishHelper object

See Also

PublishManager Class
Sitecore.Publishing Namespace


CreatePublishItemContext Method

[image]

Sitecore 6.4.1 API
PublishManager..::..CreatePublishItemContext Method
PublishManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PublishItemContext CreatePublishItemContext(
    ID itemId,
    PublishOptions options
)
Visual Basic
Public Shared Function CreatePublishItemContext ( _
    itemId As ID, _
    options As PublishOptions _
) As PublishItemContext
Visual C++
public:
static PublishItemContext^ CreatePublishItemContext(
    ID^ itemId,
    PublishOptions^ options
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The id of the item to publish.
options
Type: Sitecore.Publishing..::..PublishOptions
The options.

Return Value

PublishItemContext object.

See Also

PublishManager Class
Sitecore.Publishing Namespace


DoPublish Method

[image]

Sitecore 6.4.1 API
PublishManager..::..DoPublish Method
PublishManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected void DoPublish(
    PublishOptions[] options,
    PublishStatus status
)
Visual Basic
Protected Sub DoPublish ( _
    options As PublishOptions(), _
    status As PublishStatus _
)
Visual C++
protected:
void DoPublish(
    array<PublishOptions^>^ options,
    PublishStatus^ status
)

Parameters

options
Type: array< Sitecore.Publishing..::..PublishOptions >[]()[][]
The options.
status
Type: Sitecore.Publishing..::..PublishStatus
The status.

See Also

PublishManager Class
Sitecore.Publishing Namespace


GetPublishingTargets Method

[image]

Sitecore 6.4.1 API
PublishManager..::..GetPublishingTargets Method
PublishManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ItemList GetPublishingTargets(
    Database database
)
Visual Basic
Public Shared Function GetPublishingTargets ( _
    database As Database _
) As ItemList
Visual C++
public:
static ItemList^ GetPublishingTargets(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

Return Value

The targets.

See Also

PublishManager Class
Sitecore.Publishing Namespace


GetPublishQueue Method

[image] [image]

Sitecore 6.4.1 API
PublishManager..::..GetPublishQueue Method
PublishManager Class See Also Send Feedback

Overload List

Name | Description
GetPublishQueue(Database) | Gets the publish queue.
GetPublishQueue(DateTime, DateTime, Database) | Gets the publish queue.

See Also

PublishManager Class
PublishManager Members
Sitecore.Publishing Namespace


GetPublishQueue Method (Database)

[image]

Sitecore 6.4.1 API
PublishManager..::..GetPublishQueue Method (Database)
PublishManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PublishQueue GetPublishQueue(
    Database database
)
Visual Basic
Public Shared Function GetPublishQueue ( _
    database As Database _
) As PublishQueue
Visual C++
public:
static PublishQueue^ GetPublishQueue(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

Return Value

PublishQueue object.

See Also

PublishManager Class
GetPublishQueue Overload
Sitecore.Publishing Namespace


GetPublishQueue Method (DateTime, DateTime, Database)

[image]

Sitecore 6.4.1 API
PublishManager..::..GetPublishQueue Method (DateTime, DateTime, Database)
PublishManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static IdList GetPublishQueue(
    DateTime from,
    DateTime to,
    Database database
)
Visual Basic
Public Shared Function GetPublishQueue ( _
    from As DateTime, _
    to As DateTime, _
    database As Database _
) As IdList
Visual C++
public:
static IdList^ GetPublishQueue(
    DateTime from,
    DateTime to,
    Database^ database
)

Parameters

from
Type: System..::..DateTime
From date to get objects from Queue.
to
Type: System..::..DateTime
To date to get objects from Queue.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

IdList object.

See Also

PublishManager Class
GetPublishQueue Overload
Sitecore.Publishing Namespace


GetStatus Method

[image]

Sitecore 6.4.1 API
PublishManager..::..GetStatus Method
PublishManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PublishStatus GetStatus(
    Handle handle
)
Visual Basic
Public Shared Function GetStatus ( _
    handle As Handle _
) As PublishStatus
Visual C++
public:
static PublishStatus^ GetStatus(
    Handle^ handle
)

Parameters

handle
Type: Sitecore..::..Handle
The handle.

Return Value

PublishStatus object.

See Also

PublishManager Class
Sitecore.Publishing Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
PublishManager..::..Initialize Method
PublishManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void Initialize()
Visual Basic
Public Shared Sub Initialize
Visual C++
public:
static void Initialize()

See Also

PublishManager Class
Sitecore.Publishing Namespace


IsSmartPublishScheduled Method

[image]

Sitecore 6.4.1 API
PublishManager..::..IsSmartPublishScheduled Method
PublishManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool IsSmartPublishScheduled(
    Database database,
    string targetDatabaseName,
    Language language
)
Visual Basic
Public Shared Function IsSmartPublishScheduled ( _
    database As Database, _
    targetDatabaseName As String, _
    language As Language _
) As Boolean
Visual C++
public:
static bool IsSmartPublishScheduled(
    Database^ database,
    String^ targetDatabaseName,
    Language^ language
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.
targetDatabaseName
Type: System..::..String
Name of the target database.
language
Type: Sitecore.Globalization..::..Language
The language.

Return Value

true if smart publish is scheduled for the specified target database; otherwise, false.

See Also

PublishManager Class
Sitecore.Publishing Namespace


Publish Method

[image] [image]

Sitecore 6.4.1 API
PublishManager..::..Publish Method
PublishManager Class See Also Send Feedback

Overload List

Name | Description
Publish(PublishOptions) | Obsolete. Publishes with specified options.
Publish(array<PublishOptions>[]()[][]) | Publishes with specified options.
Publish(array<PublishOptions>[]()[][], Language) | Publishes with specified options.

See Also

PublishManager Class
PublishManager Members
Sitecore.Publishing Namespace


Publish Method (PublishOptions)

[image]

Sitecore 6.4.1 API
PublishManager..::..Publish Method (PublishOptions)
PublishManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use Publish([NotNull] PublishOptions[] options) method instead")]
public static void Publish(
    PublishOptions options
)
Visual Basic
<ObsoleteAttribute("Use Publish([NotNull] PublishOptions[] options) method instead")> _
Public Shared Sub Publish ( _
    options As PublishOptions _
)
Visual C++
[ObsoleteAttribute(L"Use Publish([NotNull] PublishOptions[] options) method instead")]
public:
static void Publish(
    PublishOptions^ options
)

Parameters

options
Type: Sitecore.Publishing..::..PublishOptions
The options.

See Also

PublishManager Class
Publish Overload
Sitecore.Publishing Namespace


Publish Method (PublishOptions[], Language)

[image]

Sitecore 6.4.1 API
PublishManager..::..Publish Method (array<PublishOptions>[]()[][], Language)
PublishManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Handle Publish(
    PublishOptions[] options,
    Language clientLanguage
)
Visual Basic
Public Shared Function Publish ( _
    options As PublishOptions(), _
    clientLanguage As Language _
) As Handle
Visual C++
public:
static Handle^ Publish(
    array<PublishOptions^>^ options,
    Language^ clientLanguage
)

Parameters

options
Type: array< Sitecore.Publishing..::..PublishOptions >[]()[][]
The options.
clientLanguage
Type: Sitecore.Globalization..::..Language
The client Language.

Return Value

Publish process Handle object.

See Also

PublishManager Class
Publish Overload
Sitecore.Publishing Namespace


PublishIncremental Method

[image] [image]

Sitecore 6.4.1 API
PublishManager..::..PublishIncremental Method
PublishManager Class See Also Send Feedback

Overload List

Name | Description
PublishIncremental(Database, array<Database>[]()[][], array<Language>[]()[][]) | Publishes in incremental mode.
PublishIncremental(Database, array<Database>[]()[][], array<Language>[]()[][], Language) | Publishes in incremental mode.

See Also

PublishManager Class
PublishManager Members
Sitecore.Publishing Namespace


PublishIncremental Method (Database, Database[], Language[])

[image]

Sitecore 6.4.1 API
PublishManager..::..PublishIncremental Method (Database, array<Database>[]()[][], array<Language>[]()[][])
PublishManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Handle PublishIncremental(
    Database source,
    Database[] targets,
    Language[] languages
)
Visual Basic
Public Shared Function PublishIncremental ( _
    source As Database, _
    targets As Database(), _
    languages As Language() _
) As Handle
Visual C++
public:
static Handle^ PublishIncremental(
    Database^ source,
    array<Database^>^ targets,
    array<Language^>^ languages
)

Parameters

source
Type: Sitecore.Data..::..Database
The source.
targets
Type: array< Sitecore.Data..::..Database >[]()[][]
The targets.
languages
Type: array< Sitecore.Globalization..::..Language >[]()[][]
The languages.

Return Value

Publish process Handle object.

See Also

PublishManager Class
PublishIncremental Overload
Sitecore.Publishing Namespace


PublishIncremental Method (Database, Database[], Language[], Language)

[image]

Sitecore 6.4.1 API
PublishManager..::..PublishIncremental Method (Database, array<Database>[]()[][], array<Language>[]()[][], Language)
PublishManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Handle PublishIncremental(
    Database source,
    Database[] targets,
    Language[] languages,
    Language clientLanguage
)
Visual Basic
Public Shared Function PublishIncremental ( _
    source As Database, _
    targets As Database(), _
    languages As Language(), _
    clientLanguage As Language _
) As Handle
Visual C++
public:
static Handle^ PublishIncremental(
    Database^ source,
    array<Database^>^ targets,
    array<Language^>^ languages,
    Language^ clientLanguage
)

Parameters

source
Type: Sitecore.Data..::..Database
The source.
targets
Type: array< Sitecore.Data..::..Database >[]()[][]
The targets.
languages
Type: array< Sitecore.Globalization..::..Language >[]()[][]
The languages.
clientLanguage
Type: Sitecore.Globalization..::..Language
The Client language.

Return Value

Publish process Handle object.

See Also

PublishManager Class
PublishIncremental Overload
Sitecore.Publishing Namespace


PublishItem Method

[image]

Sitecore 6.4.1 API
PublishManager..::..PublishItem Method
PublishManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Handle PublishItem(
    Item item,
    Database[] targets,
    Language[] languages,
    bool deep,
    bool compareRevisions
)
Visual Basic
Public Shared Function PublishItem ( _
    item As Item, _
    targets As Database(), _
    languages As Language(), _
    deep As Boolean, _
    compareRevisions As Boolean _
) As Handle
Visual C++
public:
static Handle^ PublishItem(
    Item^ item,
    array<Database^>^ targets,
    array<Language^>^ languages,
    bool deep,
    bool compareRevisions
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item to publish.
targets
Type: array< Sitecore.Data..::..Database >[]()[][]
The targets.
languages
Type: array< Sitecore.Globalization..::..Language >[]()[][]
The languages.
deep
Type: System..::..Boolean
if set to true this instance is deep.
compareRevisions
Type: System..::..Boolean
if set to true this instance is compare revisions.

Return Value

Publish process Handle object.

See Also

PublishManager Class
Sitecore.Publishing Namespace


PublishSmart Method

[image] [image]

Sitecore 6.4.1 API
PublishManager..::..PublishSmart Method
PublishManager Class See Also Send Feedback

Overload List

Name | Description
PublishSmart(Database, array<Database>[]()[][], array<Language>[]()[][]) | Publishes in smart mode.
PublishSmart(Database, array<Database>[]()[][], array<Language>[]()[][], Language) | Publishes in smart mode.

See Also

PublishManager Class
PublishManager Members
Sitecore.Publishing Namespace


PublishSmart Method (Database, Database[], Language[])

[image]

Sitecore 6.4.1 API
PublishManager..::..PublishSmart Method (Database, array<Database>[]()[][], array<Language>[]()[][])
PublishManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Handle PublishSmart(
    Database source,
    Database[] targets,
    Language[] languages
)
Visual Basic
Public Shared Function PublishSmart ( _
    source As Database, _
    targets As Database(), _
    languages As Language() _
) As Handle
Visual C++
public:
static Handle^ PublishSmart(
    Database^ source,
    array<Database^>^ targets,
    array<Language^>^ languages
)

Parameters

source
Type: Sitecore.Data..::..Database
The source.
targets
Type: array< Sitecore.Data..::..Database >[]()[][]
The targets.
languages
Type: array< Sitecore.Globalization..::..Language >[]()[][]
The languages.

Return Value

Publish process Handle object.

See Also

PublishManager Class
PublishSmart Overload
Sitecore.Publishing Namespace


PublishSmart Method (Database, Database[], Language[], Language)

[image]

Sitecore 6.4.1 API
PublishManager..::..PublishSmart Method (Database, array<Database>[]()[][], array<Language>[]()[][], Language)
PublishManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Handle PublishSmart(
    Database source,
    Database[] targets,
    Language[] languages,
    Language clientLanguage
)
Visual Basic
Public Shared Function PublishSmart ( _
    source As Database, _
    targets As Database(), _
    languages As Language(), _
    clientLanguage As Language _
) As Handle
Visual C++
public:
static Handle^ PublishSmart(
    Database^ source,
    array<Database^>^ targets,
    array<Language^>^ languages,
    Language^ clientLanguage
)

Parameters

source
Type: Sitecore.Data..::..Database
The source.
targets
Type: array< Sitecore.Data..::..Database >[]()[][]
The targets.
languages
Type: array< Sitecore.Globalization..::..Language >[]()[][]
The languages.
clientLanguage
Type: Sitecore.Globalization..::..Language
The client language.

Return Value

Publish process Handle object.

See Also

PublishManager Class
PublishSmart Overload
Sitecore.Publishing Namespace


RebuildDatabase Method

[image]

Sitecore 6.4.1 API
PublishManager..::..RebuildDatabase Method
PublishManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Handle RebuildDatabase(
    Database source,
    Database[] targets
)
Visual Basic
Public Shared Function RebuildDatabase ( _
    source As Database, _
    targets As Database() _
) As Handle
Visual C++
public:
static Handle^ RebuildDatabase(
    Database^ source,
    array<Database^>^ targets
)

Parameters

source
Type: Sitecore.Data..::..Database
The source.
targets
Type: array< Sitecore.Data..::..Database >[]()[][]
The targets.

Return Value

The database.

See Also

PublishManager Class
Sitecore.Publishing Namespace


Republish Method

[image] [image]

Sitecore 6.4.1 API
PublishManager..::..Republish Method
PublishManager Class See Also Send Feedback

Overload List

Name | Description
Republish(Database, array<Database>[]()[][], array<Language>[]()[][]) | Republishes the specified source.
Republish(Database, array<Database>[]()[][], array<Language>[]()[][], Language) | Republishes the specified source.

See Also

PublishManager Class
PublishManager Members
Sitecore.Publishing Namespace


Republish Method (Database, Database[], Language[])

[image]

Sitecore 6.4.1 API
PublishManager..::..Republish Method (Database, array<Database>[]()[][], array<Language>[]()[][])
PublishManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Handle Republish(
    Database source,
    Database[] targets,
    Language[] languages
)
Visual Basic
Public Shared Function Republish ( _
    source As Database, _
    targets As Database(), _
    languages As Language() _
) As Handle
Visual C++
public:
static Handle^ Republish(
    Database^ source,
    array<Database^>^ targets,
    array<Language^>^ languages
)

Parameters

source
Type: Sitecore.Data..::..Database
The source.
targets
Type: array< Sitecore.Data..::..Database >[]()[][]
The targets.
languages
Type: array< Sitecore.Globalization..::..Language >[]()[][]
The languages.

Return Value

Publish process Handle object.

See Also

PublishManager Class
Republish Overload
Sitecore.Publishing Namespace


Republish Method (Database, Database[], Language[], Language)

[image]

Sitecore 6.4.1 API
PublishManager..::..Republish Method (Database, array<Database>[]()[][], array<Language>[]()[][], Language)
PublishManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Handle Republish(
    Database source,
    Database[] targets,
    Language[] languages,
    Language clientLanguage
)
Visual Basic
Public Shared Function Republish ( _
    source As Database, _
    targets As Database(), _
    languages As Language(), _
    clientLanguage As Language _
) As Handle
Visual C++
public:
static Handle^ Republish(
    Database^ source,
    array<Database^>^ targets,
    array<Language^>^ languages,
    Language^ clientLanguage
)

Parameters

source
Type: Sitecore.Data..::..Database
The source.
targets
Type: array< Sitecore.Data..::..Database >[]()[][]
The targets.
languages
Type: array< Sitecore.Globalization..::..Language >[]()[][]
The languages.
clientLanguage
Type: Sitecore.Globalization..::..Language
The client language.

Return Value

Publish process Handle object.

See Also

PublishManager Class
Republish Overload
Sitecore.Publishing Namespace


ScheduleSmartPublish Method

[image] [image]

Sitecore 6.4.1 API
PublishManager..::..ScheduleSmartPublish Method
PublishManager Class See Also Send Feedback

Overload List

Name | Description
ScheduleSmartPublish(Database) | Schedules a smart publish for all targets and languages in a database.
ScheduleSmartPublish(Database, String, Language) | Schedules a smart publish.

See Also

PublishManager Class
PublishManager Members
Sitecore.Publishing Namespace


ScheduleSmartPublish Method (Database)

[image]

Sitecore 6.4.1 API
PublishManager..::..ScheduleSmartPublish Method (Database)
PublishManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void ScheduleSmartPublish(
    Database database
)
Visual Basic
Public Shared Sub ScheduleSmartPublish ( _
    database As Database _
)
Visual C++
public:
static void ScheduleSmartPublish(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

See Also

PublishManager Class
ScheduleSmartPublish Overload
Sitecore.Publishing Namespace


ScheduleSmartPublish Method (Database, String, Language)

[image]

Sitecore 6.4.1 API
PublishManager..::..ScheduleSmartPublish Method (Database, String, Language)
PublishManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void ScheduleSmartPublish(
    Database database,
    string targetName,
    Language language
)
Visual Basic
Public Shared Sub ScheduleSmartPublish ( _
    database As Database, _
    targetName As String, _
    language As Language _
)
Visual C++
public:
static void ScheduleSmartPublish(
    Database^ database,
    String^ targetName,
    Language^ language
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.
targetName
Type: System..::..String
Name of the target database.
language
Type: Sitecore.Globalization..::..Language
The language.

See Also

PublishManager Class
ScheduleSmartPublish Overload
Sitecore.Publishing Namespace


UnscheduleSmartPublish Method

[image]

Sitecore 6.4.1 API
PublishManager..::..UnscheduleSmartPublish Method
PublishManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void UnscheduleSmartPublish(
    Database database,
    string targetName,
    Language language
)
Visual Basic
Public Shared Sub UnscheduleSmartPublish ( _
    database As Database, _
    targetName As String, _
    language As Language _
)
Visual C++
public:
static void UnscheduleSmartPublish(
    Database^ database,
    String^ targetName,
    Language^ language
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.
targetName
Type: System..::..String
Name of the target database.
language
Type: Sitecore.Globalization..::..Language
The language.

See Also

PublishManager Class
Sitecore.Publishing Namespace


WaitFor Method

[image]

Sitecore 6.4.1 API
PublishManager..::..WaitFor Method
PublishManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool WaitFor(
    Handle handle
)
Visual Basic
Public Shared Function WaitFor ( _
    handle As Handle _
) As Boolean
Visual C++
public:
static bool WaitFor(
    Handle^ handle
)

Parameters

handle
Type: Sitecore..::..Handle
The handle.

Return Value

The wait for.

See Also

PublishManager Class
Sitecore.Publishing Namespace


Provider Property

[image]

Sitecore 6.4.1 API
PublishManager..::..Provider Property
PublishManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PublishProvider Provider { get; }
Visual Basic
Public Shared ReadOnly Property Provider As PublishProvider
    Get
Visual C++
public:
static property PublishProvider^ Provider {
    PublishProvider^ get ();
}

Field Value

The provider.

See Also

PublishManager Class
Sitecore.Publishing Namespace


Providers Property

[image]

Sitecore 6.4.1 API
PublishManager..::..Providers Property
PublishManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PublishProviderCollection Providers { get; }
Visual Basic
Public Shared ReadOnly Property Providers As PublishProviderCollection
    Get
Visual C++
public:
static property PublishProviderCollection^ Providers {
    PublishProviderCollection^ get ();
}

Field Value

The provider.

See Also

PublishManager Class
Sitecore.Publishing Namespace


PublishStrategy Property

[image]

Sitecore 6.4.1 API
PublishManager..::..PublishStrategy Property
PublishManager Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected static PublishStrategy PublishStrategy { get; }
Visual Basic
Protected Shared ReadOnly Property PublishStrategy As PublishStrategy
    Get
Visual C++
protected:
static property PublishStrategy^ PublishStrategy {
    PublishStrategy^ get ();
}

Field Value

The publish strategy.

See Also

PublishManager Class
Sitecore.Publishing Namespace


PublishMode Enumeration

[image]

Sitecore 6.4.1 API
PublishMode Enumeration
See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum PublishMode
Visual Basic
Public Enumeration PublishMode
Visual C++
public enum class PublishMode

Members

Member name | Value | Description
Unknown | 0 | Unknown.
Full | 1 | Full.
Incremental | 2 | Incremental.
SingleItem | 3 | Single item.
Smart | 4 | Smart.

See Also

Sitecore.Publishing Namespace


PublishOperation Enumeration

[image]

Sitecore 6.4.1 API
PublishOperation Enumeration
See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public enum PublishOperation
Visual Basic
Public Enumeration PublishOperation
Visual C++
public enum class PublishOperation

Members

Member name | Value | Description
None | 0 | Action type has not been set.
Skipped | 1 | Left the target item as it was.
Created | 2 | Created the target item.
Updated | 3 | Update the target item.
Deleted | 4 | Delete the target item.

See Also

Sitecore.Publishing Namespace


PublishOptions Class

[image]

Sitecore 6.4.1 API
PublishOptions Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PublishOptions
Visual Basic
Public Class PublishOptions
Visual C++
public ref class PublishOptions

Inheritance Hierarchy

System..::..Object
Sitecore.Publishing..::..PublishOptions

See Also

PublishOptions Members
Sitecore.Publishing Namespace


PublishOptions Members

[image] [image]

Sitecore 6.4.1 API
PublishOptions Members
PublishOptions Class Constructors Methods Properties See Also Send Feedback

The PublishOptions type exposes the following members.

Constructors

 | Name | Description
Public method | PublishOptions | Initializes a new instance of the PublishOptions class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ChildComparer | Gets or sets the child comparer.
Public property | CompareRevisions | Gets or sets a value indicating whether the PublishOptions compares the revisions.
Public property | Deep | Gets or sets a value indicating whether this PublishOptions is deep.
Public property | FromDate | Gets or sets from date.
Public property | Language | Gets or sets the language.
Public property | Mode | Gets or sets the mode.
Public property | PublishDate | Gets or sets the publish date.
Public property | PublishingTargets | The list of publishing targets selected for the current publish operation.
Public property | Replacer | Gets or sets the replacer.
Public property | RepublishAll | Gets a value indicating whether all data in all languages will be published.
Public property | RootItem | Gets or sets the root item.
Public property | SourceDatabase | Gets or sets the source database.
Public property | TargetDatabase | Gets or sets the target database.

See Also

PublishOptions Class
Sitecore.Publishing Namespace


PublishOptions Constructor

[image]

Sitecore 6.4.1 API
PublishOptions Constructor
PublishOptions Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PublishOptions(
    Database sourceDatabase,
    Database targetDatabase,
    PublishMode mode,
    Language language,
    DateTime publishDate
)
Visual Basic
Public Sub New ( _
    sourceDatabase As Database, _
    targetDatabase As Database, _
    mode As PublishMode, _
    language As Language, _
    publishDate As DateTime _
)
Visual C++
public:
PublishOptions(
    Database^ sourceDatabase,
    Database^ targetDatabase,
    PublishMode mode,
    Language^ language,
    DateTime publishDate
)

Parameters

sourceDatabase
Type: Sitecore.Data..::..Database
The source database.
targetDatabase
Type: Sitecore.Data..::..Database
The target database.
mode
Type: Sitecore.Publishing..::..PublishMode
The mode.
language
Type: Sitecore.Globalization..::..Language
The language.
publishDate
Type: System..::..DateTime
The publish date.

See Also

PublishOptions Class
Sitecore.Publishing Namespace


PublishOptions Methods

[image] [image]

Sitecore 6.4.1 API
PublishOptions Methods
PublishOptions Class See Also Send Feedback

The PublishOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PublishOptions Class
Sitecore.Publishing Namespace


PublishOptions Properties

[image] [image]

Sitecore 6.4.1 API
PublishOptions Properties
PublishOptions Class See Also Send Feedback

The PublishOptions type exposes the following members.

Properties

 | Name | Description
Public property | ChildComparer | Gets or sets the child comparer.
Public property | CompareRevisions | Gets or sets a value indicating whether the PublishOptions compares the revisions.
Public property | Deep | Gets or sets a value indicating whether this PublishOptions is deep.
Public property | FromDate | Gets or sets from date.
Public property | Language | Gets or sets the language.
Public property | Mode | Gets or sets the mode.
Public property | PublishDate | Gets or sets the publish date.
Public property | PublishingTargets | The list of publishing targets selected for the current publish operation.
Public property | Replacer | Gets or sets the replacer.
Public property | RepublishAll | Gets a value indicating whether all data in all languages will be published.
Public property | RootItem | Gets or sets the root item.
Public property | SourceDatabase | Gets or sets the source database.
Public property | TargetDatabase | Gets or sets the target database.

See Also

PublishOptions Class
Sitecore.Publishing Namespace


ChildComparer Property

[image]

Sitecore 6.4.1 API
PublishOptions..::..ChildComparer Property
PublishOptions Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IComparer<Item> ChildComparer { get; set; }
Visual Basic
Public Property ChildComparer As IComparer(Of Item)
    Get
    Set
Visual C++
public:
property IComparer<Item^>^ ChildComparer {
    IComparer<Item^>^ get ();
    void set (IComparer<Item^>^ value);
}

Field Value

The child comparer.

See Also

PublishOptions Class
Sitecore.Publishing Namespace


CompareRevisions Property

[image]

Sitecore 6.4.1 API
PublishOptions..::..CompareRevisions Property
PublishOptions Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool CompareRevisions { get; set; }
Visual Basic
Public Property CompareRevisions As Boolean
    Get
    Set
Visual C++
public:
property bool CompareRevisions {
    bool get ();
    void set (bool value);
}

Field Value

true if the PublishOptions compares the revisions; otherwise, false.

See Also

PublishOptions Class
Sitecore.Publishing Namespace


Deep Property

[image]

Sitecore 6.4.1 API
PublishOptions..::..Deep Property
PublishOptions Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Deep { get; set; }
Visual Basic
Public Property Deep As Boolean
    Get
    Set
Visual C++
public:
property bool Deep {
    bool get ();
    void set (bool value);
}

Field Value

true if deep; otherwise, false.

See Also

PublishOptions Class
Sitecore.Publishing Namespace


FromDate Property

[image]

Sitecore 6.4.1 API
PublishOptions..::..FromDate Property
PublishOptions Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime FromDate { get; set; }
Visual Basic
Public Property FromDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime FromDate {
    DateTime get ();
    void set (DateTime value);
}

Field Value

From date.

See Also

PublishOptions Class
Sitecore.Publishing Namespace


Language Property

[image]

Sitecore 6.4.1 API
PublishOptions..::..Language Property
PublishOptions Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Language Language { get; set; }
Visual Basic
Public Property Language As Language
    Get
    Set
Visual C++
public:
property Language^ Language {
    Language^ get ();
    void set (Language^ value);
}

Field Value

The language.

See Also

PublishOptions Class
Sitecore.Publishing Namespace


Mode Property

[image]

Sitecore 6.4.1 API
PublishOptions..::..Mode Property
PublishOptions Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PublishMode Mode { get; set; }
Visual Basic
Public Property Mode As PublishMode
    Get
    Set
Visual C++
public:
property PublishMode Mode {
    PublishMode get ();
    void set (PublishMode value);
}

Field Value

The mode.

See Also

PublishOptions Class
Sitecore.Publishing Namespace


PublishDate Property

[image]

Sitecore 6.4.1 API
PublishOptions..::..PublishDate Property
PublishOptions Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DateTime PublishDate { get; set; }
Visual Basic
Public Property PublishDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime PublishDate {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The publish date.

See Also

PublishOptions Class
Sitecore.Publishing Namespace


PublishingTargets Property

[image]

Sitecore 6.4.1 API
PublishOptions..::..PublishingTargets Property
PublishOptions Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public List<string> PublishingTargets { get; }
Visual Basic
Public ReadOnly Property PublishingTargets As List(Of String)
    Get
Visual C++
public:
property List<String^>^ PublishingTargets {
    List<String^>^ get ();
}

See Also

PublishOptions Class
Sitecore.Publishing Namespace


Replacer Property

[image]

Sitecore 6.4.1 API
PublishOptions..::..Replacer Property
PublishOptions Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Replacer Replacer { get; set; }
Visual Basic
Public Property Replacer As Replacer
    Get
    Set
Visual C++
public:
property Replacer^ Replacer {
    Replacer^ get ();
    void set (Replacer^ value);
}

Field Value

The replacer.

See Also

PublishOptions Class
Sitecore.Publishing Namespace


RepublishAll Property

[image]

Sitecore 6.4.1 API
PublishOptions..::..RepublishAll Property
PublishOptions Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool RepublishAll { get; set; }
Visual Basic
Public Property RepublishAll As Boolean
    Get
    Set
Visual C++
public:
property bool RepublishAll {
    bool get ();
    void set (bool value);
}

Field Value

true if all languages will be published; otherwise, false.

Remarks

This is a special mode of publishing used for completely rebuilding a web database.

See Also

PublishOptions Class
Sitecore.Publishing Namespace


RootItem Property

[image]

Sitecore 6.4.1 API
PublishOptions..::..RootItem Property
PublishOptions Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Item RootItem { get; set; }
Visual Basic
Public Property RootItem As Item
    Get
    Set
Visual C++
public:
property Item^ RootItem {
    Item^ get ();
    void set (Item^ value);
}

Field Value

The root item.

See Also

PublishOptions Class
Sitecore.Publishing Namespace


SourceDatabase Property

[image]

Sitecore 6.4.1 API
PublishOptions..::..SourceDatabase Property
PublishOptions Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database SourceDatabase { get; }
Visual Basic
Public ReadOnly Property SourceDatabase As Database
    Get
Visual C++
public:
property Database^ SourceDatabase {
    Database^ get ();
}

Field Value

The source database.

See Also

PublishOptions Class
Sitecore.Publishing Namespace


TargetDatabase Property

[image]

Sitecore 6.4.1 API
PublishOptions..::..TargetDatabase Property
PublishOptions Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database TargetDatabase { get; }
Visual Basic
Public ReadOnly Property TargetDatabase As Database
    Get
Visual C++
public:
property Database^ TargetDatabase {
    Database^ get ();
}

Field Value

The target database.

See Also

PublishOptions Class
Sitecore.Publishing Namespace


PublishProvider Class

[image]

Sitecore 6.4.1 API
PublishProvider Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class PublishProvider : ProviderBase
Visual Basic
Public MustInherit Class PublishProvider _
    Inherits ProviderBase
Visual C++
public ref class PublishProvider abstract : public ProviderBase

Inheritance Hierarchy

System..::..Object
System.Configuration.Provider..::..ProviderBase
Sitecore.Publishing..::..PublishProvider
Sitecore.Publishing..::..PipelinePublishProvider

See Also

PublishProvider Members
Sitecore.Publishing Namespace


PublishProvider Members

[image] [image]

Sitecore 6.4.1 API
PublishProvider Members
PublishProvider Class Constructors Methods Properties See Also Send Feedback

The PublishProvider type exposes the following members.

Constructors

 | Name | Description
Protected method | PublishProvider | Initializes a new instance of the PublishProvider class

Methods

 | Name | Description
Public method | CreatePublishContext | Creates a context object for use in the PublishPipeline.
Public method | CreatePublishHelper | Creates a publish helper instance.
Public method | CreatePublishItemContext | Creates a context object for use in the PublishItemPipeline.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the provider. (Inherited from ProviderBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Publish | Performs a publish operation with the specified options.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

PublishProvider Class
Sitecore.Publishing Namespace


PublishProvider Constructor

[image]

Sitecore 6.4.1 API
PublishProvider Constructor
PublishProvider Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected PublishProvider()
Visual Basic
Protected Sub New
Visual C++
protected:
PublishProvider()

See Also

PublishProvider Class
Sitecore.Publishing Namespace


PublishProvider Methods

[image] [image]

Sitecore 6.4.1 API
PublishProvider Methods
PublishProvider Class See Also Send Feedback

The PublishProvider type exposes the following members.

Methods

 | Name | Description
Public method | CreatePublishContext | Creates a context object for use in the PublishPipeline.
Public method | CreatePublishHelper | Creates a publish helper instance.
Public method | CreatePublishItemContext | Creates a context object for use in the PublishItemPipeline.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the provider. (Inherited from ProviderBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Publish | Performs a publish operation with the specified options.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PublishProvider Class
Sitecore.Publishing Namespace


CreatePublishContext Method

[image]

Sitecore 6.4.1 API
PublishProvider..::..CreatePublishContext Method
PublishProvider Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual PublishContext CreatePublishContext(
    PublishOptions options
)
Visual Basic
Public Overridable Function CreatePublishContext ( _
    options As PublishOptions _
) As PublishContext
Visual C++
public:
virtual PublishContext^ CreatePublishContext(
    PublishOptions^ options
)

Parameters

options
Type: Sitecore.Publishing..::..PublishOptions
The options.

Return Value

[Missing <returns> documentation for "M:Sitecore.Publishing.PublishProvider.CreatePublishContext(Sitecore.Publishing.PublishOptions)"]

See Also

PublishProvider Class
Sitecore.Publishing Namespace


CreatePublishHelper Method

[image]

Sitecore 6.4.1 API
PublishProvider..::..CreatePublishHelper Method
PublishProvider Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual PublishHelper CreatePublishHelper(
    PublishOptions options
)
Visual Basic
Public Overridable Function CreatePublishHelper ( _
    options As PublishOptions _
) As PublishHelper
Visual C++
public:
virtual PublishHelper^ CreatePublishHelper(
    PublishOptions^ options
)

Parameters

options
Type: Sitecore.Publishing..::..PublishOptions
The options.

Return Value

[Missing <returns> documentation for "M:Sitecore.Publishing.PublishProvider.CreatePublishHelper(Sitecore.Publishing.PublishOptions)"]

See Also

PublishProvider Class
Sitecore.Publishing Namespace


CreatePublishItemContext Method

[image]

Sitecore 6.4.1 API
PublishProvider..::..CreatePublishItemContext Method
PublishProvider Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual PublishItemContext CreatePublishItemContext(
    ID itemId,
    PublishOptions options
)
Visual Basic
Public Overridable Function CreatePublishItemContext ( _
    itemId As ID, _
    options As PublishOptions _
) As PublishItemContext
Visual C++
public:
virtual PublishItemContext^ CreatePublishItemContext(
    ID^ itemId,
    PublishOptions^ options
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The id of the item to publish.
options
Type: Sitecore.Publishing..::..PublishOptions
The options.

Return Value

[Missing <returns> documentation for "M:Sitecore.Publishing.PublishProvider.CreatePublishItemContext(Sitecore.Data.ID,Sitecore.Publishing.PublishOptions)"]

See Also

PublishProvider Class
Sitecore.Publishing Namespace


Publish Method

[image]

Sitecore 6.4.1 API
PublishProvider..::..Publish Method
PublishProvider Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract void Publish(
    PublishOptions options
)
Visual Basic
Public MustOverride Sub Publish ( _
    options As PublishOptions _
)
Visual C++
public:
virtual void Publish(
    PublishOptions^ options
) abstract

Parameters

options
Type: Sitecore.Publishing..::..PublishOptions
The options.

See Also

PublishProvider Class
Sitecore.Publishing Namespace


PublishProvider Properties

[image] [image]

Sitecore 6.4.1 API
PublishProvider Properties
PublishProvider Class See Also Send Feedback

The PublishProvider type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets a brief, friendly description suitable for display in administrative tools or other user interfaces (UIs). (Inherited from ProviderBase.)
Public property | Name | Gets the friendly name used to refer to the provider during configuration. (Inherited from ProviderBase.)

See Also

PublishProvider Class
Sitecore.Publishing Namespace


PublishProviderCollection Class

[image]

Sitecore 6.4.1 API
PublishProviderCollection Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PublishProviderCollection : ProviderCollection
Visual Basic
Public Class PublishProviderCollection _
    Inherits ProviderCollection
Visual C++
public ref class PublishProviderCollection : public ProviderCollection

Inheritance Hierarchy

System..::..Object
System.Configuration.Provider..::..ProviderCollection
Sitecore.Publishing..::..PublishProviderCollection

See Also

PublishProviderCollection Members
Sitecore.Publishing Namespace


PublishProviderCollection Members

[image] [image]

Sitecore 6.4.1 API
PublishProviderCollection Members
PublishProviderCollection Class Constructors Methods Properties See Also Send Feedback

The PublishProviderCollection type exposes the following members.

Constructors

 | Name | Description
Public method | PublishProviderCollection | Initializes a new instance of the PublishProviderCollection class

Methods

 | Name | Description
Public method | Add | Adds a provider to the collection. (Inherited from ProviderCollection.)
Public method | Clear | Removes all items from the collection. (Inherited from ProviderCollection.)
Public method | CopyTo | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a provider from the collection. (Inherited from ProviderCollection.)
Public method | SetReadOnly | Sets the collection to be read-only. (Inherited from ProviderCollection.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
Public property | Item | Gets the PublishProvider with the specified name.
Public property | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)

See Also

PublishProviderCollection Class
Sitecore.Publishing Namespace


PublishProviderCollection Constructor

[image]

Sitecore 6.4.1 API
PublishProviderCollection Constructor
PublishProviderCollection Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PublishProviderCollection()
Visual Basic
Public Sub New
Visual C++
public:
PublishProviderCollection()

See Also

PublishProviderCollection Class
Sitecore.Publishing Namespace


PublishProviderCollection Methods

[image] [image]

Sitecore 6.4.1 API
PublishProviderCollection Methods
PublishProviderCollection Class See Also Send Feedback

The PublishProviderCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds a provider to the collection. (Inherited from ProviderCollection.)
Public method | Clear | Removes all items from the collection. (Inherited from ProviderCollection.)
Public method | CopyTo | Copies the contents of the collection to the given array starting at the specified index. (Inherited from ProviderCollection.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an object that implements the IEnumerator interface to iterate through the collection. (Inherited from ProviderCollection.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a provider from the collection. (Inherited from ProviderCollection.)
Public method | SetReadOnly | Sets the collection to be read-only. (Inherited from ProviderCollection.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PublishProviderCollection Class
Sitecore.Publishing Namespace


PublishProviderCollection Properties

[image] [image]

Sitecore 6.4.1 API
PublishProviderCollection Properties
PublishProviderCollection Class See Also Send Feedback

The PublishProviderCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of providers in the collection. (Inherited from ProviderCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ProviderCollection.)
Public property | Item | Gets the PublishProvider with the specified name.
Public property | SyncRoot | Gets the current object. (Inherited from ProviderCollection.)

See Also

PublishProviderCollection Class
Sitecore.Publishing Namespace


Item Property

[image]

Sitecore 6.4.1 API
PublishProviderCollection..::..Item Property
PublishProviderCollection Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PublishProvider this[
    string name
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    name As String _
) As PublishProvider
    Get
Visual C++
public:
property PublishProvider^ default[String^ name] {
    PublishProvider^ get (String^ name);
}

Parameters

name
Type: System..::..String

Field Value

See Also

PublishProviderCollection Class
Sitecore.Publishing Namespace


PublishRegistration Class

[image]

Sitecore 6.4.1 API
PublishRegistration Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PublishRegistration
Visual Basic
Public Class PublishRegistration
Visual C++
public ref class PublishRegistration

Inheritance Hierarchy

System..::..Object
Sitecore.Publishing..::..PublishRegistration

See Also

PublishRegistration Members
Sitecore.Publishing Namespace


PublishRegistration Members

[image] [image]

Sitecore 6.4.1 API
PublishRegistration Members
PublishRegistration Class Constructors Methods Properties See Also Send Feedback

The PublishRegistration type exposes the following members.

Constructors

 | Name | Description
Public method | PublishRegistration(Handle) | Initializes a new instance of the PublishRegistration class.
Public method | PublishRegistration(Handle, Handle, Handle, PublishStatus) | Initializes a new instance of the PublishRegistration class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetStatus | Sets the status.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Protected property | Created | Gets or sets the created.
Public property | Expired | Gets a value indicating whether this PublishRegistration is expired.
Public property | JobHandle | Gets or sets the job handle.
Public property | OriginatorHandle | Gets or sets the originator handle.
Public property | Status | Gets or sets the status.
Public property | StatusHandle | Gets or sets the status handle.
Public property | StatusRevision | Gets or sets the status revision.

See Also

PublishRegistration Class
Sitecore.Publishing Namespace


PublishRegistration Constructor

[image] [image]

Sitecore 6.4.1 API
PublishRegistration Constructor
PublishRegistration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PublishRegistration(Handle) | Initializes a new instance of the PublishRegistration class.
Public method | PublishRegistration(Handle, Handle, Handle, PublishStatus) | Initializes a new instance of the PublishRegistration class.

See Also

PublishRegistration Class
PublishRegistration Members
Sitecore.Publishing Namespace


PublishRegistration Constructor (Handle)

[image]

Sitecore 6.4.1 API
PublishRegistration Constructor (Handle)
PublishRegistration Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PublishRegistration(
    Handle statusHandle
)
Visual Basic
Public Sub New ( _
    statusHandle As Handle _
)
Visual C++
public:
PublishRegistration(
    Handle^ statusHandle
)

Parameters

statusHandle
Type: Sitecore..::..Handle
The status handle.

See Also

PublishRegistration Class
PublishRegistration Overload
Sitecore.Publishing Namespace


PublishRegistration Constructor (Handle, Handle, Handle, PublishStatus)

[image]

Sitecore 6.4.1 API
PublishRegistration Constructor (Handle, Handle, Handle, PublishStatus)
PublishRegistration Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PublishRegistration(
    Handle statusHandle,
    Handle jobHandle,
    Handle originatorHandle,
    PublishStatus status
)
Visual Basic
Public Sub New ( _
    statusHandle As Handle, _
    jobHandle As Handle, _
    originatorHandle As Handle, _
    status As PublishStatus _
)
Visual C++
public:
PublishRegistration(
    Handle^ statusHandle,
    Handle^ jobHandle,
    Handle^ originatorHandle,
    PublishStatus^ status
)

Parameters

statusHandle
Type: Sitecore..::..Handle
The status handle.
jobHandle
Type: Sitecore..::..Handle
The job handle.
originatorHandle
Type: Sitecore..::..Handle
The originator handle.
status
Type: Sitecore.Publishing..::..PublishStatus
The status.

See Also

PublishRegistration Class
PublishRegistration Overload
Sitecore.Publishing Namespace


PublishRegistration Methods

[image] [image]

Sitecore 6.4.1 API
PublishRegistration Methods
PublishRegistration Class See Also Send Feedback

The PublishRegistration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetStatus | Sets the status.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PublishRegistration Class
Sitecore.Publishing Namespace


SetStatus Method

[image]

Sitecore 6.4.1 API
PublishRegistration..::..SetStatus Method
PublishRegistration Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetStatus(
    PublishStatus status
)
Visual Basic
Public Sub SetStatus ( _
    status As PublishStatus _
)
Visual C++
public:
void SetStatus(
    PublishStatus^ status
)

Parameters

status
Type: Sitecore.Publishing..::..PublishStatus
The status.

See Also

PublishRegistration Class
Sitecore.Publishing Namespace


PublishRegistration Properties

[image] [image]

Sitecore 6.4.1 API
PublishRegistration Properties
PublishRegistration Class See Also Send Feedback

The PublishRegistration type exposes the following members.

Properties

 | Name | Description
Protected property | Created | Gets or sets the created.
Public property | Expired | Gets a value indicating whether this PublishRegistration is expired.
Public property | JobHandle | Gets or sets the job handle.
Public property | OriginatorHandle | Gets or sets the originator handle.
Public property | Status | Gets or sets the status.
Public property | StatusHandle | Gets or sets the status handle.
Public property | StatusRevision | Gets or sets the status revision.

See Also

PublishRegistration Class
Sitecore.Publishing Namespace


Created Property

[image]

Sitecore 6.4.1 API
PublishRegistration..::..Created Property
PublishRegistration Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected DateTime Created { get; set; }
Visual Basic
Protected Property Created As DateTime
    Get
    Set
Visual C++
protected:
property DateTime Created {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The created.

See Also

PublishRegistration Class
Sitecore.Publishing Namespace


Expired Property

[image]

Sitecore 6.4.1 API
PublishRegistration..::..Expired Property
PublishRegistration Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Expired { get; }
Visual Basic
Public ReadOnly Property Expired As Boolean
    Get
Visual C++
public:
property bool Expired {
    bool get ();
}

Field Value

true if expired; otherwise, false.

See Also

PublishRegistration Class
Sitecore.Publishing Namespace


JobHandle Property

[image]

Sitecore 6.4.1 API
PublishRegistration..::..JobHandle Property
PublishRegistration Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Handle JobHandle { get; protected set; }
Visual Basic
Public Property JobHandle As Handle
    Get
    Protected Set
Visual C++
public:
property Handle^ JobHandle {
    Handle^ get ();
    protected: void set (Handle^ value);
}

Field Value

The job handle.

See Also

PublishRegistration Class
Sitecore.Publishing Namespace


OriginatorHandle Property

[image]

Sitecore 6.4.1 API
PublishRegistration..::..OriginatorHandle Property
PublishRegistration Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Handle OriginatorHandle { get; protected set; }
Visual Basic
Public Property OriginatorHandle As Handle
    Get
    Protected Set
Visual C++
public:
property Handle^ OriginatorHandle {
    Handle^ get ();
    protected: void set (Handle^ value);
}

Field Value

The originator handle.

See Also

PublishRegistration Class
Sitecore.Publishing Namespace


Status Property

[image]

Sitecore 6.4.1 API
PublishRegistration..::..Status Property
PublishRegistration Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PublishStatus Status { get; protected set; }
Visual Basic
Public Property Status As PublishStatus
    Get
    Protected Set
Visual C++
public:
property PublishStatus^ Status {
    PublishStatus^ get ();
    protected: void set (PublishStatus^ value);
}

Field Value

The status.

See Also

PublishRegistration Class
Sitecore.Publishing Namespace


StatusRevision Property

[image]

Sitecore 6.4.1 API
PublishRegistration..::..StatusRevision Property
PublishRegistration Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long StatusRevision { get; set; }
Visual Basic
Public Property StatusRevision As Long
    Get
    Set
Visual C++
public:
property long long StatusRevision {
    long long get ();
    void set (long long value);
}

Field Value

The status revision.

See Also

PublishRegistration Class
Sitecore.Publishing Namespace


PublishStatistics Class

[image]

Sitecore 6.4.1 API
PublishStatistics Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PublishStatistics
Visual Basic
Public Class PublishStatistics
Visual C++
public ref class PublishStatistics

Inheritance Hierarchy

System..::..Object
Sitecore.Publishing..::..PublishStatistics

See Also

PublishStatistics Members
Sitecore.Publishing Namespace


PublishStatistics Members

[image] [image]

Sitecore 6.4.1 API
PublishStatistics Members
PublishStatistics Class Constructors Methods Properties See Also Send Feedback

The PublishStatistics type exposes the following members.

Constructors

 | Name | Description
Public method | PublishStatistics | Initializes a new instance of the PublishStatistics class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Created | Gets or sets the number of created items.
Public property | Deleted | Gets or sets the number of deleted items.
Public property | Skipped | Gets or sets the number of skipped items.
Public property | Updated | Gets or sets the number of updated items.

See Also

PublishStatistics Class
Sitecore.Publishing Namespace


PublishStatistics Constructor

[image]

Sitecore 6.4.1 API
PublishStatistics Constructor
PublishStatistics Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PublishStatistics()
Visual Basic
Public Sub New
Visual C++
public:
PublishStatistics()

See Also

PublishStatistics Class
Sitecore.Publishing Namespace


PublishStatistics Methods

[image] [image]

Sitecore 6.4.1 API
PublishStatistics Methods
PublishStatistics Class See Also Send Feedback

The PublishStatistics type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PublishStatistics Class
Sitecore.Publishing Namespace


PublishStatistics Properties

[image] [image]

Sitecore 6.4.1 API
PublishStatistics Properties
PublishStatistics Class See Also Send Feedback

The PublishStatistics type exposes the following members.

Properties

 | Name | Description
Public property | Created | Gets or sets the number of created items.
Public property | Deleted | Gets or sets the number of deleted items.
Public property | Skipped | Gets or sets the number of skipped items.
Public property | Updated | Gets or sets the number of updated items.

See Also

PublishStatistics Class
Sitecore.Publishing Namespace


Created Property

[image]

Sitecore 6.4.1 API
PublishStatistics..::..Created Property
PublishStatistics Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Created { get; set; }
Visual Basic
Public Property Created As Integer
    Get
    Set
Visual C++
public:
property int Created {
    int get ();
    void set (int value);
}

Field Value

The created.

See Also

PublishStatistics Class
Sitecore.Publishing Namespace


Deleted Property

[image]

Sitecore 6.4.1 API
PublishStatistics..::..Deleted Property
PublishStatistics Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Deleted { get; set; }
Visual Basic
Public Property Deleted As Integer
    Get
    Set
Visual C++
public:
property int Deleted {
    int get ();
    void set (int value);
}

Field Value

The deleted.

See Also

PublishStatistics Class
Sitecore.Publishing Namespace


Skipped Property

[image]

Sitecore 6.4.1 API
PublishStatistics..::..Skipped Property
PublishStatistics Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Skipped { get; set; }
Visual Basic
Public Property Skipped As Integer
    Get
    Set
Visual C++
public:
property int Skipped {
    int get ();
    void set (int value);
}

Field Value

The skipped.

See Also

PublishStatistics Class
Sitecore.Publishing Namespace


Updated Property

[image]

Sitecore 6.4.1 API
PublishStatistics..::..Updated Property
PublishStatistics Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Updated { get; set; }
Visual Basic
Public Property Updated As Integer
    Get
    Set
Visual C++
public:
property int Updated {
    int get ();
    void set (int value);
}

Field Value

The updated.

See Also

PublishStatistics Class
Sitecore.Publishing Namespace


PublishStatus Class

[image]

Sitecore 6.4.1 API
PublishStatus Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PublishStatus
Visual Basic
Public Class PublishStatus
Visual C++
public ref class PublishStatus

Inheritance Hierarchy

System..::..Object
Sitecore.Publishing..::..PublishStatus

See Also

PublishStatus Members
Sitecore.Publishing Namespace


PublishStatus Members

[image] [image]

Sitecore 6.4.1 API
PublishStatus Members
PublishStatus Class Constructors Methods Properties See Also Send Feedback

The PublishStatus type exposes the following members.

Constructors

 | Name | Description
Public method | PublishStatus | Initializes a new instance of the PublishStatus class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetCurrentLanguage | Sets the current language.
Public method | SetCurrentTarget | Sets the current target.
Public method | SetExpired | Sets the expired status.
Public method | SetFailed | Sets the failed.
Public method | SetProcessed | Sets the processed.
Public method | SetState | Sets the state.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CurrentLanguage | Gets the current language.
Public property | CurrentTarget | Gets the current target.
Public property | Expired | Gets or sets a value indicating whether this instance is expired.
Public property | Failed | Gets a value indicating whether this PublishStatus is failed.
Public property | IsDone | Gets a value indicating whether this instance is done.
Public property | Messages | Gets the messages.
Public property | Processed | Gets the processed.
Public property | Revision | Gets or sets the revision.
Public property | State | Gets the state.
Public property | WaitHandle | Gets the wait handle.

See Also

PublishStatus Class
Sitecore.Publishing Namespace


PublishStatus Constructor

[image]

Sitecore 6.4.1 API
PublishStatus Constructor
PublishStatus Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PublishStatus()
Visual Basic
Public Sub New
Visual C++
public:
PublishStatus()

See Also

PublishStatus Class
Sitecore.Publishing Namespace


PublishStatus Methods

[image] [image]

Sitecore 6.4.1 API
PublishStatus Methods
PublishStatus Class See Also Send Feedback

The PublishStatus type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetCurrentLanguage | Sets the current language.
Public method | SetCurrentTarget | Sets the current target.
Public method | SetExpired | Sets the expired status.
Public method | SetFailed | Sets the failed.
Public method | SetProcessed | Sets the processed.
Public method | SetState | Sets the state.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PublishStatus Class
Sitecore.Publishing Namespace


SetCurrentLanguage Method

[image]

Sitecore 6.4.1 API
PublishStatus..::..SetCurrentLanguage Method
PublishStatus Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetCurrentLanguage(
    Language language
)
Visual Basic
Public Sub SetCurrentLanguage ( _
    language As Language _
)
Visual C++
public:
void SetCurrentLanguage(
    Language^ language
)

Parameters

language
Type: Sitecore.Globalization..::..Language
The language.

See Also

PublishStatus Class
Sitecore.Publishing Namespace


SetCurrentTarget Method

[image]

Sitecore 6.4.1 API
PublishStatus..::..SetCurrentTarget Method
PublishStatus Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetCurrentTarget(
    Database target
)
Visual Basic
Public Sub SetCurrentTarget ( _
    target As Database _
)
Visual C++
public:
void SetCurrentTarget(
    Database^ target
)

Parameters

target
Type: Sitecore.Data..::..Database
The target.

See Also

PublishStatus Class
Sitecore.Publishing Namespace


SetExpired Method

[image]

Sitecore 6.4.1 API
PublishStatus..::..SetExpired Method
PublishStatus Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetExpired(
    bool expired
)
Visual Basic
Public Sub SetExpired ( _
    expired As Boolean _
)
Visual C++
public:
void SetExpired(
    bool expired
)

Parameters

expired
Type: System..::..Boolean
if set to true [expired].

See Also

PublishStatus Class
Sitecore.Publishing Namespace


SetFailed Method

[image]

Sitecore 6.4.1 API
PublishStatus..::..SetFailed Method
PublishStatus Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetFailed(
    bool failed
)
Visual Basic
Public Sub SetFailed ( _
    failed As Boolean _
)
Visual C++
public:
void SetFailed(
    bool failed
)

Parameters

failed
Type: System..::..Boolean
if set to true this instance is failed.

See Also

PublishStatus Class
Sitecore.Publishing Namespace


SetState Method

[image]

Sitecore 6.4.1 API
PublishStatus..::..SetState Method
PublishStatus Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void SetState(
    JobState state
)
Visual Basic
Public Sub SetState ( _
    state As JobState _
)
Visual C++
public:
void SetState(
    JobState state
)

Parameters

state
Type: Sitecore.Jobs..::..JobState
The state.

See Also

PublishStatus Class
Sitecore.Publishing Namespace


PublishStatus Properties

[image] [image]

Sitecore 6.4.1 API
PublishStatus Properties
PublishStatus Class See Also Send Feedback

The PublishStatus type exposes the following members.

Properties

 | Name | Description
Public property | CurrentLanguage | Gets the current language.
Public property | CurrentTarget | Gets the current target.
Public property | Expired | Gets or sets a value indicating whether this instance is expired.
Public property | Failed | Gets a value indicating whether this PublishStatus is failed.
Public property | IsDone | Gets a value indicating whether this instance is done.
Public property | Messages | Gets the messages.
Public property | Processed | Gets the processed.
Public property | Revision | Gets or sets the revision.
Public property | State | Gets the state.
Public property | WaitHandle | Gets the wait handle.

See Also

PublishStatus Class
Sitecore.Publishing Namespace


CurrentLanguage Property

[image]

Sitecore 6.4.1 API
PublishStatus..::..CurrentLanguage Property
PublishStatus Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Language CurrentLanguage { get; }
Visual Basic
Public ReadOnly Property CurrentLanguage As Language
    Get
Visual C++
public:
property Language^ CurrentLanguage {
    Language^ get ();
}

Field Value

The current language.

See Also

PublishStatus Class
Sitecore.Publishing Namespace


CurrentTarget Property

[image]

Sitecore 6.4.1 API
PublishStatus..::..CurrentTarget Property
PublishStatus Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Database CurrentTarget { get; }
Visual Basic
Public ReadOnly Property CurrentTarget As Database
    Get
Visual C++
public:
property Database^ CurrentTarget {
    Database^ get ();
}

Field Value

The current target.

See Also

PublishStatus Class
Sitecore.Publishing Namespace


Expired Property

[image]

Sitecore 6.4.1 API
PublishStatus..::..Expired Property
PublishStatus Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Expired { get; protected set; }
Visual Basic
Public Property Expired As Boolean
    Get
    Protected Set
Visual C++
public:
property bool Expired {
    bool get ();
    protected: void set (bool value);
}

Field Value

true if this instance is expired; otherwise, false.

See Also

PublishStatus Class
Sitecore.Publishing Namespace


Failed Property

[image]

Sitecore 6.4.1 API
PublishStatus..::..Failed Property
PublishStatus Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Failed { get; }
Visual Basic
Public ReadOnly Property Failed As Boolean
    Get
Visual C++
public:
property bool Failed {
    bool get ();
}

Field Value

true if failed; otherwise, false.

See Also

PublishStatus Class
Sitecore.Publishing Namespace


IsDone Property

[image]

Sitecore 6.4.1 API
PublishStatus..::..IsDone Property
PublishStatus Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsDone { get; }
Visual Basic
Public ReadOnly Property IsDone As Boolean
    Get
Visual C++
public:
property bool IsDone {
    bool get ();
}

Field Value

true if this instance is done; otherwise, false.

See Also

PublishStatus Class
Sitecore.Publishing Namespace


Messages Property

[image]

Sitecore 6.4.1 API
PublishStatus..::..Messages Property
PublishStatus Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StringCollection Messages { get; }
Visual Basic
Public ReadOnly Property Messages As StringCollection
    Get
Visual C++
public:
property StringCollection^ Messages {
    StringCollection^ get ();
}

Field Value

The messages.

See Also

PublishStatus Class
Sitecore.Publishing Namespace


Processed Property

[image]

Sitecore 6.4.1 API
PublishStatus..::..Processed Property
PublishStatus Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long Processed { get; }
Visual Basic
Public ReadOnly Property Processed As Long
    Get
Visual C++
public:
property long long Processed {
    long long get ();
}

Field Value

The processed.

See Also

PublishStatus Class
Sitecore.Publishing Namespace


Revision Property

[image]

Sitecore 6.4.1 API
PublishStatus..::..Revision Property
PublishStatus Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public long Revision { get; protected set; }
Visual Basic
Public Property Revision As Long
    Get
    Protected Set
Visual C++
public:
property long long Revision {
    long long get ();
    protected: void set (long long value);
}

Field Value

The revision.

See Also

PublishStatus Class
Sitecore.Publishing Namespace


State Property

[image]

Sitecore 6.4.1 API
PublishStatus..::..State Property
PublishStatus Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public JobState State { get; }
Visual Basic
Public ReadOnly Property State As JobState
    Get
Visual C++
public:
property JobState State {
    JobState get ();
}

Field Value

The state.

See Also

PublishStatus Class
Sitecore.Publishing Namespace


WaitHandle Property

[image]

Sitecore 6.4.1 API
PublishStatus..::..WaitHandle Property
PublishStatus Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ManualResetEvent WaitHandle { get; }
Visual Basic
Public ReadOnly Property WaitHandle As ManualResetEvent
    Get
Visual C++
public:
property ManualResetEvent^ WaitHandle {
    ManualResetEvent^ get ();
}

Field Value

The wait handle.

See Also

PublishStatus Class
Sitecore.Publishing Namespace


PublishStatusUpdatedRemoteEvent Class

[image]

Sitecore 6.4.1 API
PublishStatusUpdatedRemoteEvent Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PublishStatusUpdatedRemoteEvent : IHasEventName
Visual Basic
Public Class PublishStatusUpdatedRemoteEvent _
    Implements IHasEventName
Visual C++
public ref class PublishStatusUpdatedRemoteEvent : IHasEventName

Inheritance Hierarchy

System..::..Object
Sitecore.Publishing..::..PublishStatusUpdatedRemoteEvent

See Also

PublishStatusUpdatedRemoteEvent Members
Sitecore.Publishing Namespace


PublishStatusUpdatedRemoteEvent Members

[image] [image]

Sitecore 6.4.1 API
PublishStatusUpdatedRemoteEvent Members
PublishStatusUpdatedRemoteEvent Class Constructors Methods Properties See Also Send Feedback

The PublishStatusUpdatedRemoteEvent type exposes the following members.

Constructors

 | Name | Description
Public method | PublishStatusUpdatedRemoteEvent | Initializes a new instance of the PublishStatusUpdatedRemoteEvent class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EventName | Gets or sets the name of the event.
Public property | Status | Gets or sets Status.
Public property | StatusHandle | Gets or sets StatusHandle.

See Also

PublishStatusUpdatedRemoteEvent Class
Sitecore.Publishing Namespace


PublishStatusUpdatedRemoteEvent Constructor

[image]

Sitecore 6.4.1 API
PublishStatusUpdatedRemoteEvent Constructor
PublishStatusUpdatedRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PublishStatusUpdatedRemoteEvent(
    DistributedPublishStatus status,
    Handle statusHandle
)
Visual Basic
Public Sub New ( _
    status As DistributedPublishStatus, _
    statusHandle As Handle _
)
Visual C++
public:
PublishStatusUpdatedRemoteEvent(
    DistributedPublishStatus^ status,
    Handle^ statusHandle
)

Parameters

status
Type: Sitecore.Publishing..::..DistributedPublishStatus
The status.
statusHandle
Type: Sitecore..::..Handle
The status handle.

See Also

PublishStatusUpdatedRemoteEvent Class
Sitecore.Publishing Namespace


PublishStatusUpdatedRemoteEvent Methods

[image] [image]

Sitecore 6.4.1 API
PublishStatusUpdatedRemoteEvent Methods
PublishStatusUpdatedRemoteEvent Class See Also Send Feedback

The PublishStatusUpdatedRemoteEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PublishStatusUpdatedRemoteEvent Class
Sitecore.Publishing Namespace


PublishStatusUpdatedRemoteEvent Properties

[image] [image]

Sitecore 6.4.1 API
PublishStatusUpdatedRemoteEvent Properties
PublishStatusUpdatedRemoteEvent Class See Also Send Feedback

The PublishStatusUpdatedRemoteEvent type exposes the following members.

Properties

 | Name | Description
Public property | EventName | Gets or sets the name of the event.
Public property | Status | Gets or sets Status.
Public property | StatusHandle | Gets or sets StatusHandle.

See Also

PublishStatusUpdatedRemoteEvent Class
Sitecore.Publishing Namespace


EventName Property

[image]

Sitecore 6.4.1 API
PublishStatusUpdatedRemoteEvent..::..EventName Property
PublishStatusUpdatedRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string EventName { get; protected set; }
Visual Basic
Public Property EventName As String
    Get
    Protected Set
Visual C++
public:
virtual property String^ EventName {
    String^ get () sealed;
    protected: void set (String^ value) sealed;
}

Field Value

The name of the event.

Implements

IHasEventName..::..EventName

See Also

PublishStatusUpdatedRemoteEvent Class
Sitecore.Publishing Namespace


Status Property

[image]

Sitecore 6.4.1 API
PublishStatusUpdatedRemoteEvent..::..Status Property
PublishStatusUpdatedRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DistributedPublishStatus Status { get; protected set; }
Visual Basic
Public Property Status As DistributedPublishStatus
    Get
    Protected Set
Visual C++
public:
property DistributedPublishStatus^ Status {
    DistributedPublishStatus^ get ();
    protected: void set (DistributedPublishStatus^ value);
}

See Also

PublishStatusUpdatedRemoteEvent Class
Sitecore.Publishing Namespace


StatusHandle Property

[image]

Sitecore 6.4.1 API
PublishStatusUpdatedRemoteEvent..::..StatusHandle Property
PublishStatusUpdatedRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Handle StatusHandle { get; protected set; }
Visual Basic
Public Property StatusHandle As Handle
    Get
    Protected Set
Visual C++
public:
property Handle^ StatusHandle {
    Handle^ get ();
    protected: void set (Handle^ value);
}

See Also

PublishStatusUpdatedRemoteEvent Class
Sitecore.Publishing Namespace


PublishStrategy Class

[image]

Sitecore 6.4.1 API
PublishStrategy Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PublishStrategy
Visual Basic
Public Class PublishStrategy
Visual C++
public ref class PublishStrategy

Inheritance Hierarchy

System..::..Object
Sitecore.Publishing..::..PublishStrategy
Sitecore.Publishing..::..RemotePublishStrategy

See Also

PublishStrategy Members
Sitecore.Publishing Namespace


PublishStrategy Members

[image] [image]

Sitecore 6.4.1 API
PublishStrategy Members
PublishStrategy Class Constructors Methods See Also Send Feedback

The PublishStrategy type exposes the following members.

Constructors

 | Name | Description
Public method | PublishStrategy | Initializes a new instance of the PublishStrategy class

Methods

 | Name | Description
Protected method | CheckSecurity | Checks the security.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStatus | Gets the status.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Publish(array<PublishOptions>[]()[][]) | Publishes using the specified options.
Public method | Publish(array<PublishOptions>[]()[][], Language) | Publishes using the specified options.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdatePublishStatus | Updates the publish status.

See Also

PublishStrategy Class
Sitecore.Publishing Namespace


PublishStrategy Constructor

[image]

Sitecore 6.4.1 API
PublishStrategy Constructor
PublishStrategy Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PublishStrategy()
Visual Basic
Public Sub New
Visual C++
public:
PublishStrategy()

See Also

PublishStrategy Class
Sitecore.Publishing Namespace


PublishStrategy Methods

[image] [image]

Sitecore 6.4.1 API
PublishStrategy Methods
PublishStrategy Class See Also Send Feedback

The PublishStrategy type exposes the following members.

Methods

 | Name | Description
Protected method | CheckSecurity | Checks the security.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStatus | Gets the status.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Publish(array<PublishOptions>[]()[][]) | Publishes using the specified options.
Public method | Publish(array<PublishOptions>[]()[][], Language) | Publishes using the specified options.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdatePublishStatus | Updates the publish status.

See Also

PublishStrategy Class
Sitecore.Publishing Namespace


CheckSecurity Method

[image]

Sitecore 6.4.1 API
PublishStrategy..::..CheckSecurity Method
PublishStrategy Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void CheckSecurity(
    PublishOptions[] options
)
Visual Basic
Protected Overridable Sub CheckSecurity ( _
    options As PublishOptions() _
)
Visual C++
protected:
virtual void CheckSecurity(
    array<PublishOptions^>^ options
)

Parameters

options
Type: array< Sitecore.Publishing..::..PublishOptions >[]()[][]
The options.

See Also

PublishStrategy Class
Sitecore.Publishing Namespace


GetStatus Method

[image]

Sitecore 6.4.1 API
PublishStrategy..::..GetStatus Method
PublishStrategy Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual PublishStatus GetStatus(
    Handle handle
)
Visual Basic
Public Overridable Function GetStatus ( _
    handle As Handle _
) As PublishStatus
Visual C++
public:
virtual PublishStatus^ GetStatus(
    Handle^ handle
)

Parameters

handle
Type: Sitecore..::..Handle
The handle.

Return Value

PublishStatus object.

See Also

PublishStrategy Class
Sitecore.Publishing Namespace


Publish Method

[image] [image]

Sitecore 6.4.1 API
PublishStrategy..::..Publish Method
PublishStrategy Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Publish(array<PublishOptions>[]()[][]) | Publishes using the specified options.
Public method | Publish(array<PublishOptions>[]()[][], Language) | Publishes using the specified options.

See Also

PublishStrategy Class
PublishStrategy Members
Sitecore.Publishing Namespace


Publish Method (PublishOptions[])

[image]

Sitecore 6.4.1 API
PublishStrategy..::..Publish Method (array<PublishOptions>[]()[][])
PublishStrategy Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Handle Publish(
    PublishOptions[] options
)
Visual Basic
Public Overridable Function Publish ( _
    options As PublishOptions() _
) As Handle
Visual C++
public:
virtual Handle^ Publish(
    array<PublishOptions^>^ options
)

Parameters

options
Type: array< Sitecore.Publishing..::..PublishOptions >[]()[][]
The options.

Return Value

The handle.

See Also

PublishStrategy Class
Publish Overload
Sitecore.Publishing Namespace


Publish Method (PublishOptions[], Language)

[image]

Sitecore 6.4.1 API
PublishStrategy..::..Publish Method (array<PublishOptions>[]()[][], Language)
PublishStrategy Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Handle Publish(
    PublishOptions[] options,
    Language clientLanguage
)
Visual Basic
Public Overridable Function Publish ( _
    options As PublishOptions(), _
    clientLanguage As Language _
) As Handle
Visual C++
public:
virtual Handle^ Publish(
    array<PublishOptions^>^ options,
    Language^ clientLanguage
)

Parameters

options
Type: array< Sitecore.Publishing..::..PublishOptions >[]()[][]
The options.
clientLanguage
Type: Sitecore.Globalization..::..Language
The client Language.

Return Value

The handle.

See Also

PublishStrategy Class
Publish Overload
Sitecore.Publishing Namespace


UpdatePublishStatus Method

[image]

Sitecore 6.4.1 API
PublishStrategy..::..UpdatePublishStatus Method
PublishStrategy Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void UpdatePublishStatus()
Visual Basic
Public Overridable Sub UpdatePublishStatus
Visual C++
public:
virtual void UpdatePublishStatus()

See Also

PublishStrategy Class
Sitecore.Publishing Namespace


RemotePublishingEventHandler Members

[image] [image]

Sitecore 6.4.1 API
RemotePublishingEventHandler Members
RemotePublishingEventHandler Class Constructors Methods See Also Send Feedback

The RemotePublishingEventHandler type exposes the following members.

Constructors

 | Name | Description
Public method | RemotePublishingEventHandler | Initializes a new instance of the RemotePublishingEventHandler class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IsPublishingServer | Determines whether this is the publishing server.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnStartPublishing | Processes the specified event.
Public method | OnStatusUpdated | Called when [status updated].
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RemotePublishingEventHandler Class
Sitecore.Publishing Namespace


RemotePublishingEventHandler Constructor

[image]

Sitecore 6.4.1 API
RemotePublishingEventHandler Constructor
RemotePublishingEventHandler Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RemotePublishingEventHandler()
Visual Basic
Public Sub New
Visual C++
public:
RemotePublishingEventHandler()

See Also

RemotePublishingEventHandler Class
Sitecore.Publishing Namespace


RemotePublishingEventHandler Methods

[image] [image]

Sitecore 6.4.1 API
RemotePublishingEventHandler Methods
RemotePublishingEventHandler Class See Also Send Feedback

The RemotePublishingEventHandler type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IsPublishingServer | Determines whether this is the publishing server.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnStartPublishing | Processes the specified event.
Public method | OnStatusUpdated | Called when [status updated].
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RemotePublishingEventHandler Class
Sitecore.Publishing Namespace


IsPublishingServer Method

[image]

Sitecore 6.4.1 API
RemotePublishingEventHandler..::..IsPublishingServer Method
RemotePublishingEventHandler Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool IsPublishingServer(
    StartPublishingRemoteEvent event
)
Visual Basic
Protected Overridable Function IsPublishingServer ( _
    event As StartPublishingRemoteEvent _
) As Boolean
Visual C++
protected:
virtual bool IsPublishingServer(
    StartPublishingRemoteEvent^ event
)

Parameters

event
Type: Sitecore.Publishing..::..StartPublishingRemoteEvent
The @event.

Return Value

true if this is the publishing server; otherwise, false.

See Also

RemotePublishingEventHandler Class
Sitecore.Publishing Namespace


OnStartPublishing Method

[image]

Sitecore 6.4.1 API
RemotePublishingEventHandler..::..OnStartPublishing Method
RemotePublishingEventHandler Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void OnStartPublishing(
    Object sender,
    EventArgs args
)
Visual Basic
Public Overridable Sub OnStartPublishing ( _
    sender As Object, _
    args As EventArgs _
)
Visual C++
public:
virtual void OnStartPublishing(
    Object^ sender,
    EventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: System..::..EventArgs
The EventArgs instance containing the event data.

See Also

RemotePublishingEventHandler Class
Sitecore.Publishing Namespace


OnStatusUpdated Method

[image]

Sitecore 6.4.1 API
RemotePublishingEventHandler..::..OnStatusUpdated Method
RemotePublishingEventHandler Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void OnStatusUpdated(
    Object sender,
    EventArgs args
)
Visual Basic
Public Overridable Sub OnStatusUpdated ( _
    sender As Object, _
    args As EventArgs _
)
Visual C++
public:
virtual void OnStatusUpdated(
    Object^ sender,
    EventArgs^ args
)

Parameters

sender
Type: System..::..Object
The sender.
args
Type: System..::..EventArgs
The EventArgs instance containing the event data.

See Also

RemotePublishingEventHandler Class
Sitecore.Publishing Namespace


RemotePublishStrategy Class

[image]

Sitecore 6.4.1 API
RemotePublishStrategy Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RemotePublishStrategy : PublishStrategy
Visual Basic
Public Class RemotePublishStrategy _
    Inherits PublishStrategy
Visual C++
public ref class RemotePublishStrategy : public PublishStrategy

Inheritance Hierarchy

System..::..Object
Sitecore.Publishing..::..PublishStrategy
Sitecore.Publishing..::..RemotePublishStrategy

See Also

RemotePublishStrategy Members
Sitecore.Publishing Namespace


RemotePublishStrategy Members

[image] [image]

Sitecore 6.4.1 API
RemotePublishStrategy Members
RemotePublishStrategy Class Constructors Methods See Also Send Feedback

The RemotePublishStrategy type exposes the following members.

Constructors

 | Name | Description
Public method | RemotePublishStrategy | Initializes a new instance of the RemotePublishStrategy class

Methods

 | Name | Description
Protected method | CheckSecurity | Checks the security. (Inherited from PublishStrategy.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStatus | Gets the status. (Overrides PublishStrategy..::..GetStatus(Handle).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Publish(array<PublishOptions>[]()[][]) | Publishes using the specified options. (Overrides PublishStrategy..::..Publish(array<PublishOptions>[]()[][]).)
Public method | Publish(array<PublishOptions>[]()[][], Language) | Publishes using the specified options. (Overrides PublishStrategy..::..Publish(array<PublishOptions>[]()[][], Language).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdatePublishStatus | Updates the publish status. (Overrides PublishStrategy..::..UpdatePublishStatus()()()().)

See Also

RemotePublishStrategy Class
Sitecore.Publishing Namespace


RemotePublishStrategy Constructor

[image]

Sitecore 6.4.1 API
RemotePublishStrategy Constructor
RemotePublishStrategy Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RemotePublishStrategy()
Visual Basic
Public Sub New
Visual C++
public:
RemotePublishStrategy()

See Also

RemotePublishStrategy Class
Sitecore.Publishing Namespace


RemotePublishStrategy Methods

[image] [image]

Sitecore 6.4.1 API
RemotePublishStrategy Methods
RemotePublishStrategy Class See Also Send Feedback

The RemotePublishStrategy type exposes the following members.

Methods

 | Name | Description
Protected method | CheckSecurity | Checks the security. (Inherited from PublishStrategy.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStatus | Gets the status. (Overrides PublishStrategy..::..GetStatus(Handle).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Publish(array<PublishOptions>[]()[][]) | Publishes using the specified options. (Overrides PublishStrategy..::..Publish(array<PublishOptions>[]()[][]).)
Public method | Publish(array<PublishOptions>[]()[][], Language) | Publishes using the specified options. (Overrides PublishStrategy..::..Publish(array<PublishOptions>[]()[][], Language).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdatePublishStatus | Updates the publish status. (Overrides PublishStrategy..::..UpdatePublishStatus()()()().)

See Also

RemotePublishStrategy Class
Sitecore.Publishing Namespace


GetStatus Method

[image]

Sitecore 6.4.1 API
RemotePublishStrategy..::..GetStatus Method
RemotePublishStrategy Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override PublishStatus GetStatus(
    Handle handle
)
Visual Basic
Public Overrides Function GetStatus ( _
    handle As Handle _
) As PublishStatus
Visual C++
public:
virtual PublishStatus^ GetStatus(
    Handle^ handle
) override

Parameters

handle
Type: Sitecore..::..Handle
The handle.

Return Value

PublishStatus object.

See Also

RemotePublishStrategy Class
Sitecore.Publishing Namespace


Publish Method

[image] [image]

Sitecore 6.4.1 API
RemotePublishStrategy..::..Publish Method
RemotePublishStrategy Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Publish(array<PublishOptions>[]()[][]) | Publishes using the specified options. (Overrides PublishStrategy..::..Publish(array<PublishOptions>[]()[][]).)
Public method | Publish(array<PublishOptions>[]()[][], Language) | Publishes using the specified options. (Overrides PublishStrategy..::..Publish(array<PublishOptions>[]()[][], Language).)

See Also

RemotePublishStrategy Class
RemotePublishStrategy Members
Sitecore.Publishing Namespace


Publish Method (PublishOptions[])

[image]

Sitecore 6.4.1 API
RemotePublishStrategy..::..Publish Method (array<PublishOptions>[]()[][])
RemotePublishStrategy Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Handle Publish(
    PublishOptions[] options
)
Visual Basic
Public Overrides Function Publish ( _
    options As PublishOptions() _
) As Handle
Visual C++
public:
virtual Handle^ Publish(
    array<PublishOptions^>^ options
) override

Parameters

options
Type: array< Sitecore.Publishing..::..PublishOptions >[]()[][]
The options.

Return Value

The handle.

See Also

RemotePublishStrategy Class
Publish Overload
Sitecore.Publishing Namespace


Publish Method (PublishOptions[], Language)

[image]

Sitecore 6.4.1 API
RemotePublishStrategy..::..Publish Method (array<PublishOptions>[]()[][], Language)
RemotePublishStrategy Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Handle Publish(
    PublishOptions[] options,
    Language clientLanguage
)
Visual Basic
Public Overrides Function Publish ( _
    options As PublishOptions(), _
    clientLanguage As Language _
) As Handle
Visual C++
public:
virtual Handle^ Publish(
    array<PublishOptions^>^ options,
    Language^ clientLanguage
) override

Parameters

options
Type: array< Sitecore.Publishing..::..PublishOptions >[]()[][]
The options.
clientLanguage
Type: Sitecore.Globalization..::..Language
The client Language.

Return Value

The handle.

See Also

RemotePublishStrategy Class
Publish Overload
Sitecore.Publishing Namespace


UpdatePublishStatus Method

[image]

Sitecore 6.4.1 API
RemotePublishStrategy..::..UpdatePublishStatus Method
RemotePublishStrategy Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void UpdatePublishStatus()
Visual Basic
Public Overrides Sub UpdatePublishStatus
Visual C++
public:
virtual void UpdatePublishStatus() override

See Also

RemotePublishStrategy Class
Sitecore.Publishing Namespace


StartPublishingRemoteEvent Class

[image]

Sitecore 6.4.1 API
StartPublishingRemoteEvent Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class StartPublishingRemoteEvent : IHasEventName
Visual Basic
Public Class StartPublishingRemoteEvent _
    Implements IHasEventName
Visual C++
public ref class StartPublishingRemoteEvent : IHasEventName

Inheritance Hierarchy

System..::..Object
Sitecore.Publishing..::..StartPublishingRemoteEvent

See Also

StartPublishingRemoteEvent Members
Sitecore.Publishing Namespace


StartPublishingRemoteEvent Members

[image] [image]

Sitecore 6.4.1 API
StartPublishingRemoteEvent Members
StartPublishingRemoteEvent Class Constructors Methods Properties See Also Send Feedback

The StartPublishingRemoteEvent type exposes the following members.

Constructors

 | Name | Description
Public method | StartPublishingRemoteEvent(array<DistributedPublishOptions>[]()[][], Handle, String) | Obsolete. Initializes a new instance of the StartPublishingRemoteEvent class.
Public method | StartPublishingRemoteEvent(array<DistributedPublishOptions>[]()[][], Handle, String, Language) | Initializes a new instance of the StartPublishingRemoteEvent class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ClientLanguage | Gets or sets the client language. Used for translations.
Public property | EventName | Gets or sets the name of the event.
Public property | Options | Gets or sets the options.
Public property | PublishingServer | Gets or sets the publish server.
Public property | StatusHandle | Gets or sets the status handle.
Public property | UserName | Gets or sets the name of the user.

See Also

StartPublishingRemoteEvent Class
Sitecore.Publishing Namespace


StartPublishingRemoteEvent Constructor

[image] [image]

Sitecore 6.4.1 API
StartPublishingRemoteEvent Constructor
StartPublishingRemoteEvent Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StartPublishingRemoteEvent(array<DistributedPublishOptions>[]()[][], Handle, String) | Obsolete. Initializes a new instance of the StartPublishingRemoteEvent class.
Public method | StartPublishingRemoteEvent(array<DistributedPublishOptions>[]()[][], Handle, String, Language) | Initializes a new instance of the StartPublishingRemoteEvent class.

See Also

StartPublishingRemoteEvent Class
StartPublishingRemoteEvent Members
Sitecore.Publishing Namespace


StartPublishingRemoteEvent Constructor (DistributedPublishOptions[], Handle, String)

[image]

Sitecore 6.4.1 API
StartPublishingRemoteEvent Constructor (array<DistributedPublishOptions>[]()[][], Handle, String)
StartPublishingRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Use StartPublishingRemoteEvent(DistributedPublishOptions[] options, Handle statusHandle, string userName, Language clientLanguage) instead.")]
public StartPublishingRemoteEvent(
    DistributedPublishOptions[] options,
    Handle statusHandle,
    string userName
)
Visual Basic
<ObsoleteAttribute("Use StartPublishingRemoteEvent(DistributedPublishOptions[] options, Handle statusHandle, string userName, Language clientLanguage) instead.")> _
Public Sub New ( _
    options As DistributedPublishOptions(), _
    statusHandle As Handle, _
    userName As String _
)
Visual C++
[ObsoleteAttribute(L"Use StartPublishingRemoteEvent(DistributedPublishOptions[] options, Handle statusHandle, string userName, Language clientLanguage) instead.")]
public:
StartPublishingRemoteEvent(
    array<DistributedPublishOptions^>^ options,
    Handle^ statusHandle,
    String^ userName
)

Parameters

options
Type: array< Sitecore.Publishing..::..DistributedPublishOptions >[]()[][]
The options.
statusHandle
Type: Sitecore..::..Handle
The status handle.
userName
Type: System..::..String
Name of the user starting the publish operation.

See Also

StartPublishingRemoteEvent Class
StartPublishingRemoteEvent Overload
Sitecore.Publishing Namespace


StartPublishingRemoteEvent Constructor (DistributedPublishOptions[], Handle, String, Language)

[image]

Sitecore 6.4.1 API
StartPublishingRemoteEvent Constructor (array<DistributedPublishOptions>[]()[][], Handle, String, Language)
StartPublishingRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public StartPublishingRemoteEvent(
    DistributedPublishOptions[] options,
    Handle statusHandle,
    string userName,
    Language clientLanguage
)
Visual Basic
Public Sub New ( _
    options As DistributedPublishOptions(), _
    statusHandle As Handle, _
    userName As String, _
    clientLanguage As Language _
)
Visual C++
public:
StartPublishingRemoteEvent(
    array<DistributedPublishOptions^>^ options,
    Handle^ statusHandle,
    String^ userName,
    Language^ clientLanguage
)

Parameters

options
Type: array< Sitecore.Publishing..::..DistributedPublishOptions >[]()[][]
The options.
statusHandle
Type: Sitecore..::..Handle
The status handle.
userName
Type: System..::..String
Name of the user starting the publish operation.
clientLanguage
Type: Sitecore.Globalization..::..Language
The client language.

See Also

StartPublishingRemoteEvent Class
StartPublishingRemoteEvent Overload
Sitecore.Publishing Namespace


StartPublishingRemoteEvent Methods

[image] [image]

Sitecore 6.4.1 API
StartPublishingRemoteEvent Methods
StartPublishingRemoteEvent Class See Also Send Feedback

The StartPublishingRemoteEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StartPublishingRemoteEvent Class
Sitecore.Publishing Namespace


StartPublishingRemoteEvent Properties

[image] [image]

Sitecore 6.4.1 API
StartPublishingRemoteEvent Properties
StartPublishingRemoteEvent Class See Also Send Feedback

The StartPublishingRemoteEvent type exposes the following members.

Properties

 | Name | Description
Public property | ClientLanguage | Gets or sets the client language. Used for translations.
Public property | EventName | Gets or sets the name of the event.
Public property | Options | Gets or sets the options.
Public property | PublishingServer | Gets or sets the publish server.
Public property | StatusHandle | Gets or sets the status handle.
Public property | UserName | Gets or sets the name of the user.

See Also

StartPublishingRemoteEvent Class
Sitecore.Publishing Namespace


ClientLanguage Property

[image]

Sitecore 6.4.1 API
StartPublishingRemoteEvent..::..ClientLanguage Property
StartPublishingRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ClientLanguage { get; protected set; }
Visual Basic
Public Property ClientLanguage As String
    Get
    Protected Set
Visual C++
public:
property String^ ClientLanguage {
    String^ get ();
    protected: void set (String^ value);
}

Field Value

The Language.

See Also

StartPublishingRemoteEvent Class
Sitecore.Publishing Namespace


Options Property

[image]

Sitecore 6.4.1 API
StartPublishingRemoteEvent..::..Options Property
StartPublishingRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DistributedPublishOptions[] Options { get; protected set; }
Visual Basic
Public Property Options As DistributedPublishOptions()
    Get
    Protected Set
Visual C++
public:
property array<DistributedPublishOptions^>^ Options {
    array<DistributedPublishOptions^>^ get ();
    protected: void set (array<DistributedPublishOptions^>^ value);
}

Field Value

The options.

See Also

StartPublishingRemoteEvent Class
Sitecore.Publishing Namespace


PublishingServer Property

[image]

Sitecore 6.4.1 API
StartPublishingRemoteEvent..::..PublishingServer Property
StartPublishingRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string PublishingServer { get; protected set; }
Visual Basic
Public Property PublishingServer As String
    Get
    Protected Set
Visual C++
public:
property String^ PublishingServer {
    String^ get ();
    protected: void set (String^ value);
}

Field Value

The publish server.

See Also

StartPublishingRemoteEvent Class
Sitecore.Publishing Namespace


StatusHandle Property

[image]

Sitecore 6.4.1 API
StartPublishingRemoteEvent..::..StatusHandle Property
StartPublishingRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Handle StatusHandle { get; protected set; }
Visual Basic
Public Property StatusHandle As Handle
    Get
    Protected Set
Visual C++
public:
property Handle^ StatusHandle {
    Handle^ get ();
    protected: void set (Handle^ value);
}

Field Value

The status handle.

See Also

StartPublishingRemoteEvent Class
Sitecore.Publishing Namespace


UserName Property

[image]

Sitecore 6.4.1 API
StartPublishingRemoteEvent..::..UserName Property
StartPublishingRemoteEvent Class See Also Send Feedback

Namespace: Sitecore.Publishing
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string UserName { get; protected set; }
Visual Basic
Public Property UserName As String
    Get
    Protected Set
Visual C++
public:
property String^ UserName {
    String^ get ();
    protected: void set (String^ value);
}

Field Value

The name of the user.

See Also

StartPublishingRemoteEvent Class
Sitecore.Publishing Namespace


Sitecore.Publishing.Pipelines.Publish Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Publishing.Pipelines.Publish Namespace
Send Feedback

Classes

 | Class | Description
Public class | AddItemsToQueue | PipelineSwitcher class
Public class | AddLanguagesToQueue | AddLanguagesToQueue class
Public class | AddTemplatesToQueue | AddTemplatesToQueue class
Public class | ProcessQueue | ProcessActions class
Public class | PublishContext | PublishPipelineArgs class
Public class | PublishingCandidate | PublishAction class
Public class | PublishPipeline | PublishPipeline class
Public class | PublishProcessor | PublishProcessor
Public class | PublishQueue | PublishIterator class
Public class | PublishResult | PublishItemResult class


AddItemsToQueue Class

[image]

Sitecore 6.4.1 API
AddItemsToQueue Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class AddItemsToQueue : PublishProcessor
Visual Basic
Public Class AddItemsToQueue _
    Inherits PublishProcessor
Visual C++
public ref class AddItemsToQueue : public PublishProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Publishing.Pipelines.Publish..::..PublishProcessor
Sitecore.Publishing.Pipelines.Publish..::..AddItemsToQueue

See Also

AddItemsToQueue Members
Sitecore.Publishing.Pipelines.Publish Namespace


AddItemsToQueue Members

[image] [image]

Sitecore 6.4.1 API
AddItemsToQueue Members
AddItemsToQueue Class Constructors Methods See Also Send Feedback

The AddItemsToQueue type exposes the following members.

Constructors

 | Name | Description
Public method | AddItemsToQueue | Initializes a new instance of the AddItemsToQueue class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides PublishProcessor..::..Process(PublishContext).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddItemsToQueue Class
Sitecore.Publishing.Pipelines.Publish Namespace


AddItemsToQueue Methods

[image] [image]

Sitecore 6.4.1 API
AddItemsToQueue Methods
AddItemsToQueue Class See Also Send Feedback

The AddItemsToQueue type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides PublishProcessor..::..Process(PublishContext).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddItemsToQueue Class
Sitecore.Publishing.Pipelines.Publish Namespace


AddLanguagesToQueue Class

[image]

Sitecore 6.4.1 API
AddLanguagesToQueue Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class AddLanguagesToQueue : PublishProcessor
Visual Basic
Public Class AddLanguagesToQueue _
    Inherits PublishProcessor
Visual C++
public ref class AddLanguagesToQueue : public PublishProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Publishing.Pipelines.Publish..::..PublishProcessor
Sitecore.Publishing.Pipelines.Publish..::..AddLanguagesToQueue

See Also

AddLanguagesToQueue Members
Sitecore.Publishing.Pipelines.Publish Namespace


AddLanguagesToQueue Members

[image] [image]

Sitecore 6.4.1 API
AddLanguagesToQueue Members
AddLanguagesToQueue Class Constructors Methods See Also Send Feedback

The AddLanguagesToQueue type exposes the following members.

Constructors

 | Name | Description
Public method | AddLanguagesToQueue | Initializes a new instance of the AddLanguagesToQueue class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides PublishProcessor..::..Process(PublishContext).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddLanguagesToQueue Class
Sitecore.Publishing.Pipelines.Publish Namespace


AddLanguagesToQueue Constructor

[image]

Sitecore 6.4.1 API
AddLanguagesToQueue Constructor
AddLanguagesToQueue Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AddLanguagesToQueue()
Visual Basic
Public Sub New
Visual C++
public:
AddLanguagesToQueue()

See Also

AddLanguagesToQueue Class
Sitecore.Publishing.Pipelines.Publish Namespace


AddLanguagesToQueue Methods

[image] [image]

Sitecore 6.4.1 API
AddLanguagesToQueue Methods
AddLanguagesToQueue Class See Also Send Feedback

The AddLanguagesToQueue type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides PublishProcessor..::..Process(PublishContext).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddLanguagesToQueue Class
Sitecore.Publishing.Pipelines.Publish Namespace


AddTemplatesToQueue Class

[image]

Sitecore 6.4.1 API
AddTemplatesToQueue Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class AddTemplatesToQueue : PublishProcessor
Visual Basic
Public Class AddTemplatesToQueue _
    Inherits PublishProcessor
Visual C++
public ref class AddTemplatesToQueue : public PublishProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Publishing.Pipelines.Publish..::..PublishProcessor
Sitecore.Publishing.Pipelines.Publish..::..AddTemplatesToQueue

See Also

AddTemplatesToQueue Members
Sitecore.Publishing.Pipelines.Publish Namespace


AddTemplatesToQueue Members

[image] [image]

Sitecore 6.4.1 API
AddTemplatesToQueue Members
AddTemplatesToQueue Class Constructors Methods See Also Send Feedback

The AddTemplatesToQueue type exposes the following members.

Constructors

 | Name | Description
Public method | AddTemplatesToQueue | Initializes a new instance of the AddTemplatesToQueue class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateItems | Gets the template items.
Protected method | GetTemplatesForFullPublish | Gets the templates for full publish.
Protected method | GetTemplatesForIncrementalPublish | Gets the templates for incremental publish.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides PublishProcessor..::..Process(PublishContext).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddTemplatesToQueue Class
Sitecore.Publishing.Pipelines.Publish Namespace


AddTemplatesToQueue Constructor

[image]

Sitecore 6.4.1 API
AddTemplatesToQueue Constructor
AddTemplatesToQueue Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AddTemplatesToQueue()
Visual Basic
Public Sub New
Visual C++
public:
AddTemplatesToQueue()

See Also

AddTemplatesToQueue Class
Sitecore.Publishing.Pipelines.Publish Namespace


AddTemplatesToQueue Methods

[image] [image]

Sitecore 6.4.1 API
AddTemplatesToQueue Methods
AddTemplatesToQueue Class See Also Send Feedback

The AddTemplatesToQueue type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateItems | Gets the template items.
Protected method | GetTemplatesForFullPublish | Gets the templates for full publish.
Protected method | GetTemplatesForIncrementalPublish | Gets the templates for incremental publish.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides PublishProcessor..::..Process(PublishContext).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddTemplatesToQueue Class
Sitecore.Publishing.Pipelines.Publish Namespace


GetTemplateItems Method

[image]

Sitecore 6.4.1 API
AddTemplatesToQueue..::..GetTemplateItems Method
AddTemplatesToQueue Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual IEnumerable<PublishingCandidate> GetTemplateItems(
    PublishOptions options
)
Visual Basic
Protected Overridable Function GetTemplateItems ( _
    options As PublishOptions _
) As IEnumerable(Of PublishingCandidate)
Visual C++
protected:
virtual IEnumerable<PublishingCandidate^>^ GetTemplateItems(
    PublishOptions^ options
)

Parameters

options
Type: Sitecore.Publishing..::..PublishOptions
The options.

Return Value

[Missing <returns> documentation for "M:Sitecore.Publishing.Pipelines.Publish.AddTemplatesToQueue.GetTemplateItems(Sitecore.Publishing.PublishOptions)"]

See Also

AddTemplatesToQueue Class
Sitecore.Publishing.Pipelines.Publish Namespace


GetTemplatesForFullPublish Method

[image]

Sitecore 6.4.1 API
AddTemplatesToQueue..::..GetTemplatesForFullPublish Method
AddTemplatesToQueue Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual IEnumerable<PublishingCandidate> GetTemplatesForFullPublish(
    PublishOptions options
)
Visual Basic
Protected Overridable Function GetTemplatesForFullPublish ( _
    options As PublishOptions _
) As IEnumerable(Of PublishingCandidate)
Visual C++
protected:
virtual IEnumerable<PublishingCandidate^>^ GetTemplatesForFullPublish(
    PublishOptions^ options
)

Parameters

options
Type: Sitecore.Publishing..::..PublishOptions
The options.

Return Value

[Missing <returns> documentation for "M:Sitecore.Publishing.Pipelines.Publish.AddTemplatesToQueue.GetTemplatesForFullPublish(Sitecore.Publishing.PublishOptions)"]

See Also

AddTemplatesToQueue Class
Sitecore.Publishing.Pipelines.Publish Namespace


GetTemplatesForIncrementalPublish Method

[image]

Sitecore 6.4.1 API
AddTemplatesToQueue..::..GetTemplatesForIncrementalPublish Method
AddTemplatesToQueue Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual IEnumerable<PublishingCandidate> GetTemplatesForIncrementalPublish(
    PublishOptions options
)
Visual Basic
Protected Overridable Function GetTemplatesForIncrementalPublish ( _
    options As PublishOptions _
) As IEnumerable(Of PublishingCandidate)
Visual C++
protected:
virtual IEnumerable<PublishingCandidate^>^ GetTemplatesForIncrementalPublish(
    PublishOptions^ options
)

Parameters

options
Type: Sitecore.Publishing..::..PublishOptions
The options.

Return Value

[Missing <returns> documentation for "M:Sitecore.Publishing.Pipelines.Publish.AddTemplatesToQueue.GetTemplatesForIncrementalPublish(Sitecore.Publishing.PublishOptions)"]

See Also

AddTemplatesToQueue Class
Sitecore.Publishing.Pipelines.Publish Namespace


ProcessQueue Class

[image]

Sitecore 6.4.1 API
ProcessQueue Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ProcessQueue : PublishProcessor
Visual Basic
Public Class ProcessQueue _
    Inherits PublishProcessor
Visual C++
public ref class ProcessQueue : public PublishProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Publishing.Pipelines.Publish..::..PublishProcessor
Sitecore.Publishing.Pipelines.Publish..::..ProcessQueue

See Also

ProcessQueue Members
Sitecore.Publishing.Pipelines.Publish Namespace


ProcessQueue Members

[image] [image]

Sitecore 6.4.1 API
ProcessQueue Members
ProcessQueue Class Constructors Methods See Also Send Feedback

The ProcessQueue type exposes the following members.

Constructors

 | Name | Description
Public method | ProcessQueue | Initializes a new instance of the ProcessQueue class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processor entry point. (Overrides PublishProcessor..::..Process(PublishContext).)
Protected method | ProcessEntries | Processes the specified actions.
Protected method | SkipReferrers | Determines whether item referrers should or shuld not be published.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProcessQueue Class
Sitecore.Publishing.Pipelines.Publish Namespace


ProcessQueue Constructor

[image]

Sitecore 6.4.1 API
ProcessQueue Constructor
ProcessQueue Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ProcessQueue()
Visual Basic
Public Sub New
Visual C++
public:
ProcessQueue()

See Also

ProcessQueue Class
Sitecore.Publishing.Pipelines.Publish Namespace


ProcessQueue Methods

[image] [image]

Sitecore 6.4.1 API
ProcessQueue Methods
ProcessQueue Class See Also Send Feedback

The ProcessQueue type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processor entry point. (Overrides PublishProcessor..::..Process(PublishContext).)
Protected method | ProcessEntries | Processes the specified actions.
Protected method | SkipReferrers | Determines whether item referrers should or shuld not be published.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProcessQueue Class
Sitecore.Publishing.Pipelines.Publish Namespace


Process Method

[image]

Sitecore 6.4.1 API
ProcessQueue..::..Process Method
ProcessQueue Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    PublishContext context
)
Visual Basic
Public Overrides Sub Process ( _
    context As PublishContext _
)
Visual C++
public:
virtual void Process(
    PublishContext^ context
) override

Parameters

context
Type: Sitecore.Publishing.Pipelines.Publish..::..PublishContext
The context.

See Also

ProcessQueue Class
Sitecore.Publishing.Pipelines.Publish Namespace


ProcessEntries Method

[image]

Sitecore 6.4.1 API
ProcessQueue..::..ProcessEntries Method
ProcessQueue Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void ProcessEntries(
    IEnumerable<PublishingCandidate> entries,
    PublishContext context
)
Visual Basic
Protected Overridable Sub ProcessEntries ( _
    entries As IEnumerable(Of PublishingCandidate), _
    context As PublishContext _
)
Visual C++
protected:
virtual void ProcessEntries(
    IEnumerable<PublishingCandidate^>^ entries,
    PublishContext^ context
)

Parameters

entries
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' PublishingCandidate >)>)>
The actions.
context
Type: Sitecore.Publishing.Pipelines.Publish..::..PublishContext
The context.

See Also

ProcessQueue Class
Sitecore.Publishing.Pipelines.Publish Namespace


SkipReferrers Method

[image]

Sitecore 6.4.1 API
ProcessQueue..::..SkipReferrers Method
ProcessQueue Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual bool SkipReferrers(
    PublishItemResult result,
    PublishContext context
)
Visual Basic
Protected Overridable Function SkipReferrers ( _
    result As PublishItemResult, _
    context As PublishContext _
) As Boolean
Visual C++
protected:
virtual bool SkipReferrers(
    PublishItemResult^ result,
    PublishContext^ context
)

Parameters

result
Type: Sitecore.Publishing.Pipelines.PublishItem..::..PublishItemResult
The result.
context
Type: Sitecore.Publishing.Pipelines.Publish..::..PublishContext
The context.

Return Value

true if item references should not be published.

See Also

ProcessQueue Class
Sitecore.Publishing.Pipelines.Publish Namespace


PublishContext Class

[image]

Sitecore 6.4.1 API
PublishContext Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PublishContext : PipelineArgs
Visual Basic
Public Class PublishContext _
    Inherits PipelineArgs
Visual C++
public ref class PublishContext : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Publishing.Pipelines.Publish..::..PublishContext

See Also

PublishContext Members
Sitecore.Publishing.Pipelines.Publish Namespace


PublishContext Members

[image] [image]

Sitecore 6.4.1 API
PublishContext Members
PublishContext Class Constructors Methods Properties See Also Send Feedback

The PublishContext type exposes the following members.

Constructors

 | Name | Description
Public method | PublishContext | Initializes a new instance of the PublishContext class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Job | Gets or sets the job.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | PublishOptions | Gets the options.
Public property | Queue | Gets or sets the source item ids.
Public property | Result | Gets the result of the publishing operation.
Public property | Statistics | Gets the statistics.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
Public property | User | Gets or sets the user.

See Also

PublishContext Class
Sitecore.Publishing.Pipelines.Publish Namespace


PublishContext Constructor

[image]

Sitecore 6.4.1 API
PublishContext Constructor
PublishContext Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PublishContext(
    PublishOptions options
)
Visual Basic
Public Sub New ( _
    options As PublishOptions _
)
Visual C++
public:
PublishContext(
    PublishOptions^ options
)

Parameters

options
Type: Sitecore.Publishing..::..PublishOptions
The options.

See Also

PublishContext Class
Sitecore.Publishing.Pipelines.Publish Namespace


PublishContext Methods

[image] [image]

Sitecore 6.4.1 API
PublishContext Methods
PublishContext Class See Also Send Feedback

The PublishContext type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PublishContext Class
Sitecore.Publishing.Pipelines.Publish Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
PublishContext..::..GetMessages Method
PublishContext Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

PublishContext Class
PublishContext Members
Sitecore.Publishing.Pipelines.Publish Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
PublishContext..::..Suspend Method
PublishContext Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

PublishContext Class
PublishContext Members
Sitecore.Publishing.Pipelines.Publish Namespace


PublishContext Properties

[image] [image]

Sitecore 6.4.1 API
PublishContext Properties
PublishContext Class See Also Send Feedback

The PublishContext type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | Job | Gets or sets the job.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | PublishOptions | Gets the options.
Public property | Queue | Gets or sets the source item ids.
Public property | Result | Gets the result of the publishing operation.
Public property | Statistics | Gets the statistics.
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
Public property | User | Gets or sets the user.

See Also

PublishContext Class
Sitecore.Publishing.Pipelines.Publish Namespace


Job Property

[image]

Sitecore 6.4.1 API
PublishContext..::..Job Property
PublishContext Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Job Job { get; set; }
Visual Basic
Public Property Job As Job
    Get
    Set
Visual C++
public:
property Job^ Job {
    Job^ get ();
    void set (Job^ value);
}

Field Value

The job.

See Also

PublishContext Class
Sitecore.Publishing.Pipelines.Publish Namespace


PublishOptions Property

[image]

Sitecore 6.4.1 API
PublishContext..::..PublishOptions Property
PublishContext Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PublishOptions PublishOptions { get; }
Visual Basic
Public ReadOnly Property PublishOptions As PublishOptions
    Get
Visual C++
public:
property PublishOptions^ PublishOptions {
    PublishOptions^ get ();
}

Field Value

The options.

See Also

PublishContext Class
Sitecore.Publishing.Pipelines.Publish Namespace


Queue Property

[image]

Sitecore 6.4.1 API
PublishContext..::..Queue Property
PublishContext Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public List<IEnumerable<PublishingCandidate>> Queue { get; }
Visual Basic
Public ReadOnly Property Queue As List(Of IEnumerable(Of PublishingCandidate))
    Get
Visual C++
public:
property List<IEnumerable<PublishingCandidate^>^>^ Queue {
    List<IEnumerable<PublishingCandidate^>^>^ get ();
}

Field Value

The source item ids.

See Also

PublishContext Class
Sitecore.Publishing.Pipelines.Publish Namespace


Statistics Property

[image]

Sitecore 6.4.1 API
PublishContext..::..Statistics Property
PublishContext Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PublishStatistics Statistics { get; }
Visual Basic
Public ReadOnly Property Statistics As PublishStatistics
    Get
Visual C++
public:
property PublishStatistics^ Statistics {
    PublishStatistics^ get ();
}

Field Value

The statistics.

See Also

PublishContext Class
Sitecore.Publishing.Pipelines.Publish Namespace


User Property

[image]

Sitecore 6.4.1 API
PublishContext..::..User Property
PublishContext Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual User User { get; set; }
Visual Basic
Public Overridable Property User As User
    Get
    Set
Visual C++
public:
virtual property User^ User {
    User^ get ();
    void set (User^ value);
}

Field Value

The user.

See Also

PublishContext Class
Sitecore.Publishing.Pipelines.Publish Namespace


PublishingCandidate Class

[image]

Sitecore 6.4.1 API
PublishingCandidate Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PublishingCandidate
Visual Basic
Public Class PublishingCandidate
Visual C++
public ref class PublishingCandidate

Inheritance Hierarchy

System..::..Object
Sitecore.Publishing.Pipelines.Publish..::..PublishingCandidate

See Also

PublishingCandidate Members
Sitecore.Publishing.Pipelines.Publish Namespace


PublishingCandidate Members

[image] [image]

Sitecore 6.4.1 API
PublishingCandidate Members
PublishingCandidate Class Constructors Methods Properties See Also Send Feedback

The PublishingCandidate type exposes the following members.

Constructors

 | Name | Description
Public method | PublishingCandidate | Initializes a new instance of the PublishingCandidate class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ChildEntries | Gets the child entries.
Public property | ItemId | Gets the item id.
Public property | PublishOptions | Gets the publish item options.

See Also

PublishingCandidate Class
Sitecore.Publishing.Pipelines.Publish Namespace


PublishingCandidate Methods

[image] [image]

Sitecore 6.4.1 API
PublishingCandidate Methods
PublishingCandidate Class See Also Send Feedback

The PublishingCandidate type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PublishingCandidate Class
Sitecore.Publishing.Pipelines.Publish Namespace


PublishingCandidate Properties

[image] [image]

Sitecore 6.4.1 API
PublishingCandidate Properties
PublishingCandidate Class See Also Send Feedback

The PublishingCandidate type exposes the following members.

Properties

 | Name | Description
Public property | ChildEntries | Gets the child entries.
Public property | ItemId | Gets the item id.
Public property | PublishOptions | Gets the publish item options.

See Also

PublishingCandidate Class
Sitecore.Publishing.Pipelines.Publish Namespace


ChildEntries Property

[image]

Sitecore 6.4.1 API
PublishingCandidate..::..ChildEntries Property
PublishingCandidate Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public IEnumerable<PublishingCandidate> ChildEntries { get; }
Visual Basic
Public ReadOnly Property ChildEntries As IEnumerable(Of PublishingCandidate)
    Get
Visual C++
public:
property IEnumerable<PublishingCandidate^>^ ChildEntries {
    IEnumerable<PublishingCandidate^>^ get ();
}

Field Value

The child entries.

See Also

PublishingCandidate Class
Sitecore.Publishing.Pipelines.Publish Namespace


ItemId Property

[image]

Sitecore 6.4.1 API
PublishingCandidate..::..ItemId Property
PublishingCandidate Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ID ItemId { get; }
Visual Basic
Public ReadOnly Property ItemId As ID
    Get
Visual C++
public:
property ID^ ItemId {
    ID^ get ();
}

Field Value

The item id.

See Also

PublishingCandidate Class
Sitecore.Publishing.Pipelines.Publish Namespace


PublishOptions Property

[image]

Sitecore 6.4.1 API
PublishingCandidate..::..PublishOptions Property
PublishingCandidate Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PublishOptions PublishOptions { get; }
Visual Basic
Public ReadOnly Property PublishOptions As PublishOptions
    Get
Visual C++
public:
property PublishOptions^ PublishOptions {
    PublishOptions^ get ();
}

Field Value

The publish options.

See Also

PublishingCandidate Class
Sitecore.Publishing.Pipelines.Publish Namespace


PublishPipeline Class

[image]

Sitecore 6.4.1 API
PublishPipeline Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PublishPipeline
Visual Basic
Public Class PublishPipeline
Visual C++
public ref class PublishPipeline

Inheritance Hierarchy

System..::..Object
Sitecore.Publishing.Pipelines.Publish..::..PublishPipeline

See Also

PublishPipeline Members
Sitecore.Publishing.Pipelines.Publish Namespace


PublishPipeline Members

[image] [image]

Sitecore 6.4.1 API
PublishPipeline Members
PublishPipeline Class Constructors Methods See Also Send Feedback

The PublishPipeline type exposes the following members.

Constructors

 | Name | Description
Public method | PublishPipeline | Initializes a new instance of the PublishPipeline class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run(PublishContext) | Runs the 'publish' pipeline with specified arguments.
 | Run(PublishOptions) | Runs the 'publish' pipeline with specified arguments.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PublishPipeline Class
Sitecore.Publishing.Pipelines.Publish Namespace


PublishPipeline Constructor

[image]

Sitecore 6.4.1 API
PublishPipeline Constructor
PublishPipeline Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PublishPipeline()
Visual Basic
Public Sub New
Visual C++
public:
PublishPipeline()

See Also

PublishPipeline Class
Sitecore.Publishing.Pipelines.Publish Namespace


PublishPipeline Methods

[image] [image]

Sitecore 6.4.1 API
PublishPipeline Methods
PublishPipeline Class See Also Send Feedback

The PublishPipeline type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run(PublishContext) | Runs the 'publish' pipeline with specified arguments.
 | Run(PublishOptions) | Runs the 'publish' pipeline with specified arguments.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PublishPipeline Class
Sitecore.Publishing.Pipelines.Publish Namespace


Run Method

[image] [image]

Sitecore 6.4.1 API
PublishPipeline..::..Run Method
PublishPipeline Class See Also Send Feedback

Overload List

Name | Description
Run(PublishContext) | Runs the 'publish' pipeline with specified arguments.
Run(PublishOptions) | Runs the 'publish' pipeline with specified arguments.

See Also

PublishPipeline Class
PublishPipeline Members
Sitecore.Publishing.Pipelines.Publish Namespace


Run Method (PublishContext)

[image]

Sitecore 6.4.1 API
PublishPipeline..::..Run Method (PublishContext)
PublishPipeline Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PublishResult Run(
    PublishContext context
)
Visual Basic
Public Shared Function Run ( _
    context As PublishContext _
) As PublishResult
Visual C++
public:
static PublishResult^ Run(
    PublishContext^ context
)

Parameters

context
Type: Sitecore.Publishing.Pipelines.Publish..::..PublishContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Publishing.Pipelines.Publish.PublishPipeline.Run(Sitecore.Publishing.Pipelines.Publish.PublishContext)"]

See Also

PublishPipeline Class
Run Overload
Sitecore.Publishing.Pipelines.Publish Namespace


Run Method (PublishOptions)

[image]

Sitecore 6.4.1 API
PublishPipeline..::..Run Method (PublishOptions)
PublishPipeline Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PublishResult Run(
    PublishOptions options
)
Visual Basic
Public Shared Function Run ( _
    options As PublishOptions _
) As PublishResult
Visual C++
public:
static PublishResult^ Run(
    PublishOptions^ options
)

Parameters

options
Type: Sitecore.Publishing..::..PublishOptions
The options.

Return Value

[Missing <returns> documentation for "M:Sitecore.Publishing.Pipelines.Publish.PublishPipeline.Run(Sitecore.Publishing.PublishOptions)"]

See Also

PublishPipeline Class
Run Overload
Sitecore.Publishing.Pipelines.Publish Namespace


PublishProcessor Class

[image]

Sitecore 6.4.1 API
PublishProcessor Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract class PublishProcessor
Visual Basic
Public MustInherit Class PublishProcessor
Visual C++
public ref class PublishProcessor abstract

Inheritance Hierarchy

System..::..Object
Sitecore.Publishing.Pipelines.Publish..::..PublishProcessor
Sitecore.Publishing.Pipelines.Publish..::..AddItemsToQueue
Sitecore.Publishing.Pipelines.Publish..::..AddLanguagesToQueue
Sitecore.Publishing.Pipelines.Publish..::..AddTemplatesToQueue
Sitecore.Publishing.Pipelines.Publish..::..ProcessQueue

See Also

PublishProcessor Members
Sitecore.Publishing.Pipelines.Publish Namespace


PublishProcessor Members

[image] [image]

Sitecore 6.4.1 API
PublishProcessor Members
PublishProcessor Class Constructors Methods See Also Send Feedback

The PublishProcessor type exposes the following members.

Constructors

 | Name | Description
Protected method | PublishProcessor | Initializes a new instance of the PublishProcessor class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PublishProcessor Class
Sitecore.Publishing.Pipelines.Publish Namespace


PublishProcessor Constructor

[image]

Sitecore 6.4.1 API
PublishProcessor Constructor
PublishProcessor Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected PublishProcessor()
Visual Basic
Protected Sub New
Visual C++
protected:
PublishProcessor()

See Also

PublishProcessor Class
Sitecore.Publishing.Pipelines.Publish Namespace


PublishProcessor Methods

[image] [image]

Sitecore 6.4.1 API
PublishProcessor Methods
PublishProcessor Class See Also Send Feedback

The PublishProcessor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PublishProcessor Class
Sitecore.Publishing.Pipelines.Publish Namespace


Process Method

[image]

Sitecore 6.4.1 API
PublishProcessor..::..Process Method
PublishProcessor Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract void Process(
    PublishContext context
)
Visual Basic
Public MustOverride Sub Process ( _
    context As PublishContext _
)
Visual C++
public:
virtual void Process(
    PublishContext^ context
) abstract

Parameters

context
Type: Sitecore.Publishing.Pipelines.Publish..::..PublishContext
The args.

See Also

PublishProcessor Class
Sitecore.Publishing.Pipelines.Publish Namespace


PublishQueue Class

[image]

Sitecore 6.4.1 API
PublishQueue Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PublishQueue
Visual Basic
Public Class PublishQueue
Visual C++
public ref class PublishQueue

Inheritance Hierarchy

System..::..Object
Sitecore.Publishing.Pipelines.Publish..::..PublishQueue

See Also

PublishQueue Members
Sitecore.Publishing.Pipelines.Publish Namespace


PublishQueue Methods

[image] [image]

Sitecore 6.4.1 API
PublishQueue Methods
PublishQueue Class See Also Send Feedback

The PublishQueue type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes all entries from the queue.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetChildIterator | Gets an iterator for enumerating a (sub)tree.
 | GetContentBranch | Gets an iterator for enumerating a (sub)tree.
Public method | GetCount | Gets the count.
 | GetEmptyIterator | Gets the empty iterator.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPublishQueue | Gets an iterator for enumerating the publish queue.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PublishQueue Class
Sitecore.Publishing.Pipelines.Publish Namespace


Clear Method

[image]

Sitecore 6.4.1 API
PublishQueue..::..Clear Method
PublishQueue Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

PublishQueue Class
Sitecore.Publishing.Pipelines.Publish Namespace


GetChildIterator Method

[image]

Sitecore 6.4.1 API
PublishQueue..::..GetChildIterator Method
PublishQueue Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static IEnumerable<PublishingCandidate> GetChildIterator(
    ID itemId,
    PublishOptions options
)
Visual Basic
Public Shared Function GetChildIterator ( _
    itemId As ID, _
    options As PublishOptions _
) As IEnumerable(Of PublishingCandidate)
Visual C++
public:
static IEnumerable<PublishingCandidate^>^ GetChildIterator(
    ID^ itemId,
    PublishOptions^ options
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
options
Type: Sitecore.Publishing..::..PublishOptions
The options.

Return Value

[Missing <returns> documentation for "M:Sitecore.Publishing.Pipelines.Publish.PublishQueue.GetChildIterator(Sitecore.Data.ID,Sitecore.Publishing.PublishOptions)"]

See Also

PublishQueue Class
Sitecore.Publishing.Pipelines.Publish Namespace


GetContentBranch Method

[image]

Sitecore 6.4.1 API
PublishQueue..::..GetContentBranch Method
PublishQueue Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static IEnumerable<PublishingCandidate> GetContentBranch(
    PublishOptions options
)
Visual Basic
Public Shared Function GetContentBranch ( _
    options As PublishOptions _
) As IEnumerable(Of PublishingCandidate)
Visual C++
public:
static IEnumerable<PublishingCandidate^>^ GetContentBranch(
    PublishOptions^ options
)

Parameters

options
Type: Sitecore.Publishing..::..PublishOptions
The options.

Return Value

[Missing <returns> documentation for "M:Sitecore.Publishing.Pipelines.Publish.PublishQueue.GetContentBranch(Sitecore.Publishing.PublishOptions)"]

See Also

PublishQueue Class
Sitecore.Publishing.Pipelines.Publish Namespace


GetCount Method

[image]

Sitecore 6.4.1 API
PublishQueue..::..GetCount Method
PublishQueue Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int GetCount()
Visual Basic
Public Function GetCount As Integer
Visual C++
public:
int GetCount()

Return Value

[Missing <returns> documentation for "M:Sitecore.Publishing.Pipelines.Publish.PublishQueue.GetCount"]

See Also

PublishQueue Class
Sitecore.Publishing.Pipelines.Publish Namespace


GetEmptyIterator Method

[image]

Sitecore 6.4.1 API
PublishQueue..::..GetEmptyIterator Method
PublishQueue Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static IEnumerable<PublishingCandidate> GetEmptyIterator()
Visual Basic
Public Shared Function GetEmptyIterator As IEnumerable(Of PublishingCandidate)
Visual C++
public:
static IEnumerable<PublishingCandidate^>^ GetEmptyIterator()

Return Value

[Missing <returns> documentation for "M:Sitecore.Publishing.Pipelines.Publish.PublishQueue.GetEmptyIterator"]

See Also

PublishQueue Class
Sitecore.Publishing.Pipelines.Publish Namespace


GetPublishQueue Method

[image]

Sitecore 6.4.1 API
PublishQueue..::..GetPublishQueue Method
PublishQueue Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static IEnumerable<PublishingCandidate> GetPublishQueue(
    PublishOptions options
)
Visual Basic
Public Shared Function GetPublishQueue ( _
    options As PublishOptions _
) As IEnumerable(Of PublishingCandidate)
Visual C++
public:
static IEnumerable<PublishingCandidate^>^ GetPublishQueue(
    PublishOptions^ options
)

Parameters

options
Type: Sitecore.Publishing..::..PublishOptions
The options.

Return Value

[Missing <returns> documentation for "M:Sitecore.Publishing.Pipelines.Publish.PublishQueue.GetPublishQueue(Sitecore.Publishing.PublishOptions)"]

See Also

PublishQueue Class
Sitecore.Publishing.Pipelines.Publish Namespace


PublishResult Class

[image]

Sitecore 6.4.1 API
PublishResult Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PublishResult
Visual Basic
Public Class PublishResult
Visual C++
public ref class PublishResult

Inheritance Hierarchy

System..::..Object
Sitecore.Publishing.Pipelines.Publish..::..PublishResult

See Also

PublishResult Members
Sitecore.Publishing.Pipelines.Publish Namespace


PublishResult Members

[image] [image]

Sitecore 6.4.1 API
PublishResult Members
PublishResult Class Constructors Methods See Also Send Feedback

The PublishResult type exposes the following members.

Constructors

 | Name | Description
Public method | PublishResult | Initializes a new instance of the PublishResult class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PublishResult Class
Sitecore.Publishing.Pipelines.Publish Namespace


PublishResult Constructor

[image]

Sitecore 6.4.1 API
PublishResult Constructor
PublishResult Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.Publish
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PublishResult()
Visual Basic
Public Sub New
Visual C++
public:
PublishResult()

See Also

PublishResult Class
Sitecore.Publishing.Pipelines.Publish Namespace


PublishResult Methods

[image] [image]

Sitecore 6.4.1 API
PublishResult Methods
PublishResult Class See Also Send Feedback

The PublishResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PublishResult Class
Sitecore.Publishing.Pipelines.Publish Namespace


Sitecore.Publishing.Pipelines.PublishItem Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Publishing.Pipelines.PublishItem Namespace
Send Feedback

Classes

 | Class | Description
Public class | AddItemReferences | Collects and registers for publishing items references.
Public class | CheckSecurity | CheckSecurity class
Public class | CheckVirtualItem | CheckVirtualItem class
Public class | DetermineAction | HandleUnauthorized class
Public class | ItemProcessedEventArgs | Defines the arguments passed in a publish:itemProcessed event.
Public class | ItemProcessingEventArgs | Defines the arguments passed in a publish:item:processing event.
Public class | MoveItems | MoveItems class
Public class | PerformAction | HandleUnpublishable class
Public class | PublishItemContext | PublishItemArgs class
Public class | PublishItemPipeline | PublishItemPipeline class
Public class | PublishItemProcessor | PublishItemProcessor class
Public class | PublishItemResult | PublishItemResult class
Public class | RaiseProcessedEvent | RaiseEvents class
Public class | RaiseProcessingEvent | RaiseEvents class
Public class | RemoveUnknownChildren | RemoveUnknownChildren class
Public class | UpdateStatistics | UpdateJobStatus class


AddItemReferences Class

[image]

Sitecore 6.4.1 API
AddItemReferences Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class AddItemReferences : PublishItemProcessor
Visual Basic
Public Class AddItemReferences _
    Inherits PublishItemProcessor
Visual C++
public ref class AddItemReferences : public PublishItemProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Publishing.Pipelines.PublishItem..::..PublishItemProcessor
Sitecore.Publishing.Pipelines.PublishItem..::..AddItemReferences

See Also

AddItemReferences Members
Sitecore.Publishing.Pipelines.PublishItem Namespace


AddItemReferences Members

[image] [image]

Sitecore 6.4.1 API
AddItemReferences Members
AddItemReferences Class Constructors Methods See Also Send Feedback

The AddItemReferences type exposes the following members.

Constructors

 | Name | Description
Public method | AddItemReferences | Initializes a new instance of the AddItemReferences class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetFileDropAreaMediaReferences(PublishItemContext) | Gets the list of referred media items via File Drop Area field.
Protected method | GetFileDropAreaMediaReferences(Item, Boolean, PublishItemContext) | Gets the file drop area media references.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetItemReferences | Gets the list of item references.
Protected method | GetPublishOptions | Gets the publish options.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides PublishItemProcessor..::..Process(PublishItemContext).)
Protected method | RegisterReferences | Registers the references for publishing.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddItemReferences Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


AddItemReferences Constructor

[image]

Sitecore 6.4.1 API
AddItemReferences Constructor
AddItemReferences Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public AddItemReferences()
Visual Basic
Public Sub New
Visual C++
public:
AddItemReferences()

See Also

AddItemReferences Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


GetFileDropAreaMediaReferences Method

[image] [image]

Sitecore 6.4.1 API
AddItemReferences..::..GetFileDropAreaMediaReferences Method
AddItemReferences Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetFileDropAreaMediaReferences(PublishItemContext) | Gets the list of referred media items via File Drop Area field.
Protected method | GetFileDropAreaMediaReferences(Item, Boolean, PublishItemContext) | Gets the file drop area media references.

See Also

AddItemReferences Class
AddItemReferences Members
Sitecore.Publishing.Pipelines.PublishItem Namespace


GetFileDropAreaMediaReferences Method (PublishItemContext)

[image]

Sitecore 6.4.1 API
AddItemReferences..::..GetFileDropAreaMediaReferences Method (PublishItemContext)
AddItemReferences Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual List<Item> GetFileDropAreaMediaReferences(
    PublishItemContext context
)
Visual Basic
Protected Overridable Function GetFileDropAreaMediaReferences ( _
    context As PublishItemContext _
) As List(Of Item)
Visual C++
protected:
virtual List<Item^>^ GetFileDropAreaMediaReferences(
    PublishItemContext^ context
)

Parameters

context
Type: Sitecore.Publishing.Pipelines.PublishItem..::..PublishItemContext
The publish context.

Return Value

The list of referred media items via File Drop Area field.

See Also

AddItemReferences Class
GetFileDropAreaMediaReferences Overload
Sitecore.Publishing.Pipelines.PublishItem Namespace


GetFileDropAreaMediaReferences Method (Item, Boolean, PublishItemContext)

[image]

Sitecore 6.4.1 API
AddItemReferences..::..GetFileDropAreaMediaReferences Method (Item, Boolean, PublishItemContext)
AddItemReferences Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual List<Item> GetFileDropAreaMediaReferences(
    Item item,
    bool sharedOnly,
    PublishItemContext context
)
Visual Basic
Protected Overridable Function GetFileDropAreaMediaReferences ( _
    item As Item, _
    sharedOnly As Boolean, _
    context As PublishItemContext _
) As List(Of Item)
Visual C++
protected:
virtual List<Item^>^ GetFileDropAreaMediaReferences(
    Item^ item,
    bool sharedOnly,
    PublishItemContext^ context
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The sitecore item.
sharedOnly
Type: System..::..Boolean
Determines whether to process shared fields only or not.
context
Type: Sitecore.Publishing.Pipelines.PublishItem..::..PublishItemContext
The context.

Return Value

The list of referred media items via File Drop Area field.

See Also

AddItemReferences Class
GetFileDropAreaMediaReferences Overload
Sitecore.Publishing.Pipelines.PublishItem Namespace


GetItemReferences Method

[image]

Sitecore 6.4.1 API
AddItemReferences..::..GetItemReferences Method
AddItemReferences Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual List<Item> GetItemReferences(
    PublishItemContext context
)
Visual Basic
Protected Overridable Function GetItemReferences ( _
    context As PublishItemContext _
) As List(Of Item)
Visual C++
protected:
virtual List<Item^>^ GetItemReferences(
    PublishItemContext^ context
)

Parameters

context
Type: Sitecore.Publishing.Pipelines.PublishItem..::..PublishItemContext
The publish item context.

Return Value

The list of item references.

See Also

AddItemReferences Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


GetPublishOptions Method

[image]

Sitecore 6.4.1 API
AddItemReferences..::..GetPublishOptions Method
AddItemReferences Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual PublishOptions GetPublishOptions(
    PublishItemContext context
)
Visual Basic
Protected Overridable Function GetPublishOptions ( _
    context As PublishItemContext _
) As PublishOptions
Visual C++
protected:
virtual PublishOptions^ GetPublishOptions(
    PublishItemContext^ context
)

Parameters

context
Type: Sitecore.Publishing.Pipelines.PublishItem..::..PublishItemContext
The context.

Return Value

The publish options.

See Also

AddItemReferences Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


Process Method

[image]

Sitecore 6.4.1 API
AddItemReferences..::..Process Method
AddItemReferences Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    PublishItemContext context
)
Visual Basic
Public Overrides Sub Process ( _
    context As PublishItemContext _
)
Visual C++
public:
virtual void Process(
    PublishItemContext^ context
) override

Parameters

context
Type: Sitecore.Publishing.Pipelines.PublishItem..::..PublishItemContext
The arguments.

See Also

AddItemReferences Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


RegisterReferences Method

[image]

Sitecore 6.4.1 API
AddItemReferences..::..RegisterReferences Method
AddItemReferences Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual void RegisterReferences(
    List<Item> references,
    PublishItemContext context
)
Visual Basic
Protected Overridable Sub RegisterReferences ( _
    references As List(Of Item), _
    context As PublishItemContext _
)
Visual C++
protected:
virtual void RegisterReferences(
    List<Item^>^ references,
    PublishItemContext^ context
)

Parameters

references
Type: System.Collections.Generic..::..List <(Of <(<' Item >)>)>
The references.
context
Type: Sitecore.Publishing.Pipelines.PublishItem..::..PublishItemContext
The context.

See Also

AddItemReferences Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


CheckSecurity Class

[image]

Sitecore 6.4.1 API
CheckSecurity Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CheckSecurity : PublishItemProcessor
Visual Basic
Public Class CheckSecurity _
    Inherits PublishItemProcessor
Visual C++
public ref class CheckSecurity : public PublishItemProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Publishing.Pipelines.PublishItem..::..PublishItemProcessor
Sitecore.Publishing.Pipelines.PublishItem..::..CheckSecurity

See Also

CheckSecurity Members
Sitecore.Publishing.Pipelines.PublishItem Namespace


CheckSecurity Members

[image] [image]

Sitecore 6.4.1 API
CheckSecurity Members
CheckSecurity Class Constructors Methods See Also Send Feedback

The CheckSecurity type exposes the following members.

Constructors

 | Name | Description
Public method | CheckSecurity | Initializes a new instance of the CheckSecurity class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified context. (Overrides PublishItemProcessor..::..Process(PublishItemContext).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckSecurity Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


CheckSecurity Constructor

[image]

Sitecore 6.4.1 API
CheckSecurity Constructor
CheckSecurity Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CheckSecurity()
Visual Basic
Public Sub New
Visual C++
public:
CheckSecurity()

See Also

CheckSecurity Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


CheckSecurity Methods

[image] [image]

Sitecore 6.4.1 API
CheckSecurity Methods
CheckSecurity Class See Also Send Feedback

The CheckSecurity type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified context. (Overrides PublishItemProcessor..::..Process(PublishItemContext).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckSecurity Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


Process Method

[image]

Sitecore 6.4.1 API
CheckSecurity..::..Process Method
CheckSecurity Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    PublishItemContext context
)
Visual Basic
Public Overrides Sub Process ( _
    context As PublishItemContext _
)
Visual C++
public:
virtual void Process(
    PublishItemContext^ context
) override

Parameters

context
Type: Sitecore.Publishing.Pipelines.PublishItem..::..PublishItemContext
The context.

See Also

CheckSecurity Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


CheckVirtualItem Class

[image]

Sitecore 6.4.1 API
CheckVirtualItem Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class CheckVirtualItem : PublishItemProcessor
Visual Basic
Public Class CheckVirtualItem _
    Inherits PublishItemProcessor
Visual C++
public ref class CheckVirtualItem : public PublishItemProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Publishing.Pipelines.PublishItem..::..PublishItemProcessor
Sitecore.Publishing.Pipelines.PublishItem..::..CheckVirtualItem

See Also

CheckVirtualItem Members
Sitecore.Publishing.Pipelines.PublishItem Namespace


CheckVirtualItem Members

[image] [image]

Sitecore 6.4.1 API
CheckVirtualItem Members
CheckVirtualItem Class Constructors Methods See Also Send Feedback

The CheckVirtualItem type exposes the following members.

Constructors

 | Name | Description
Public method | CheckVirtualItem | Initializes a new instance of the CheckVirtualItem class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified context. (Overrides PublishItemProcessor..::..Process(PublishItemContext).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckVirtualItem Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


CheckVirtualItem Constructor

[image]

Sitecore 6.4.1 API
CheckVirtualItem Constructor
CheckVirtualItem Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public CheckVirtualItem()
Visual Basic
Public Sub New
Visual C++
public:
CheckVirtualItem()

See Also

CheckVirtualItem Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


CheckVirtualItem Methods

[image] [image]

Sitecore 6.4.1 API
CheckVirtualItem Methods
CheckVirtualItem Class See Also Send Feedback

The CheckVirtualItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified context. (Overrides PublishItemProcessor..::..Process(PublishItemContext).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckVirtualItem Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


Process Method

[image]

Sitecore 6.4.1 API
CheckVirtualItem..::..Process Method
CheckVirtualItem Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    PublishItemContext context
)
Visual Basic
Public Overrides Sub Process ( _
    context As PublishItemContext _
)
Visual C++
public:
virtual void Process(
    PublishItemContext^ context
) override

Parameters

context
Type: Sitecore.Publishing.Pipelines.PublishItem..::..PublishItemContext
The context.

See Also

CheckVirtualItem Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


DetermineAction Class

[image]

Sitecore 6.4.1 API
DetermineAction Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class DetermineAction : PublishItemProcessor
Visual Basic
Public Class DetermineAction _
    Inherits PublishItemProcessor
Visual C++
public ref class DetermineAction : public PublishItemProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Publishing.Pipelines.PublishItem..::..PublishItemProcessor
Sitecore.Publishing.Pipelines.PublishItem..::..DetermineAction

See Also

DetermineAction Members
Sitecore.Publishing.Pipelines.PublishItem Namespace


DetermineAction Members

[image] [image]

Sitecore 6.4.1 API
DetermineAction Members
DetermineAction Class Constructors Methods See Also Send Feedback

The DetermineAction type exposes the following members.

Constructors

 | Name | Description
Public method | DetermineAction | Initializes a new instance of the DetermineAction class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified context. (Overrides PublishItemProcessor..::..Process(PublishItemContext).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DetermineAction Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


DetermineAction Constructor

[image]

Sitecore 6.4.1 API
DetermineAction Constructor
DetermineAction Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DetermineAction()
Visual Basic
Public Sub New
Visual C++
public:
DetermineAction()

See Also

DetermineAction Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


DetermineAction Methods

[image] [image]

Sitecore 6.4.1 API
DetermineAction Methods
DetermineAction Class See Also Send Feedback

The DetermineAction type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified context. (Overrides PublishItemProcessor..::..Process(PublishItemContext).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DetermineAction Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


Process Method

[image]

Sitecore 6.4.1 API
DetermineAction..::..Process Method
DetermineAction Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    PublishItemContext context
)
Visual Basic
Public Overrides Sub Process ( _
    context As PublishItemContext _
)
Visual C++
public:
virtual void Process(
    PublishItemContext^ context
) override

Parameters

context
Type: Sitecore.Publishing.Pipelines.PublishItem..::..PublishItemContext
The context.

See Also

DetermineAction Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


ItemProcessedEventArgs Class

[image]

Sitecore 6.4.1 API
ItemProcessedEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemProcessedEventArgs : EventArgs,
    IPassNativeEventArgs
Visual Basic
Public Class ItemProcessedEventArgs _
    Inherits EventArgs _
    Implements IPassNativeEventArgs
Visual C++
public ref class ItemProcessedEventArgs : public EventArgs,
    IPassNativeEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Publishing.Pipelines.PublishItem..::..ItemProcessedEventArgs

See Also

ItemProcessedEventArgs Members
Sitecore.Publishing.Pipelines.PublishItem Namespace


ItemProcessedEventArgs Constructor

[image]

Sitecore 6.4.1 API
ItemProcessedEventArgs Constructor
ItemProcessedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemProcessedEventArgs(
    PublishItemContext context
)
Visual Basic
Public Sub New ( _
    context As PublishItemContext _
)
Visual C++
public:
ItemProcessedEventArgs(
    PublishItemContext^ context
)

Parameters

context
Type: Sitecore.Publishing.Pipelines.PublishItem..::..PublishItemContext
The context.

See Also

ItemProcessedEventArgs Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


ItemProcessedEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
ItemProcessedEventArgs Methods
ItemProcessedEventArgs Class See Also Send Feedback

The ItemProcessedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemProcessedEventArgs Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


ItemProcessedEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
ItemProcessedEventArgs Properties
ItemProcessedEventArgs Class See Also Send Feedback

The ItemProcessedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Context | Gets the context.

See Also

ItemProcessedEventArgs Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


Context Property

[image]

Sitecore 6.4.1 API
ItemProcessedEventArgs..::..Context Property
ItemProcessedEventArgs Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PublishItemContext Context { get; }
Visual Basic
Public ReadOnly Property Context As PublishItemContext
    Get
Visual C++
public:
property PublishItemContext^ Context {
    PublishItemContext^ get ();
}

Field Value

The context.

See Also

ItemProcessedEventArgs Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


ItemProcessingEventArgs Class

[image]

Sitecore 6.4.1 API
ItemProcessingEventArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ItemProcessingEventArgs : CancelEventArgs,
    IPassNativeEventArgs
Visual Basic
Public Class ItemProcessingEventArgs _
    Inherits CancelEventArgs _
    Implements IPassNativeEventArgs
Visual C++
public ref class ItemProcessingEventArgs : public CancelEventArgs,
    IPassNativeEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..CancelEventArgs
Sitecore.Publishing.Pipelines.PublishItem..::..ItemProcessingEventArgs

See Also

ItemProcessingEventArgs Members
Sitecore.Publishing.Pipelines.PublishItem Namespace


ItemProcessingEventArgs Constructor

[image]

Sitecore 6.4.1 API
ItemProcessingEventArgs Constructor
ItemProcessingEventArgs Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ItemProcessingEventArgs(
    PublishItemContext context
)
Visual Basic
Public Sub New ( _
    context As PublishItemContext _
)
Visual C++
public:
ItemProcessingEventArgs(
    PublishItemContext^ context
)

Parameters

context
Type: Sitecore.Publishing.Pipelines.PublishItem..::..PublishItemContext
The context.

See Also

ItemProcessingEventArgs Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


ItemProcessingEventArgs Methods

[image] [image]

Sitecore 6.4.1 API
ItemProcessingEventArgs Methods
ItemProcessingEventArgs Class See Also Send Feedback

The ItemProcessingEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemProcessingEventArgs Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


ItemProcessingEventArgs Properties

[image] [image]

Sitecore 6.4.1 API
ItemProcessingEventArgs Properties
ItemProcessingEventArgs Class See Also Send Feedback

The ItemProcessingEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | Context | Gets the context.

See Also

ItemProcessingEventArgs Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


Context Property

[image]

Sitecore 6.4.1 API
ItemProcessingEventArgs..::..Context Property
ItemProcessingEventArgs Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PublishItemContext Context { get; }
Visual Basic
Public ReadOnly Property Context As PublishItemContext
    Get
Visual C++
public:
property PublishItemContext^ Context {
    PublishItemContext^ get ();
}

Field Value

The context.

See Also

ItemProcessingEventArgs Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


MoveItems Members

[image] [image]

Sitecore 6.4.1 API
MoveItems Members
MoveItems Class Constructors Methods See Also Send Feedback

The MoveItems type exposes the following members.

Constructors

 | Name | Description
Public method | MoveItems | Initializes a new instance of the MoveItems class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides PublishItemProcessor..::..Process(PublishItemContext).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MoveItems Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


MoveItems Constructor

[image]

Sitecore 6.4.1 API
MoveItems Constructor
MoveItems Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MoveItems()
Visual Basic
Public Sub New
Visual C++
public:
MoveItems()

See Also

MoveItems Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


MoveItems Methods

[image] [image]

Sitecore 6.4.1 API
MoveItems Methods
MoveItems Class See Also Send Feedback

The MoveItems type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides PublishItemProcessor..::..Process(PublishItemContext).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MoveItems Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


Process Method

[image]

Sitecore 6.4.1 API
MoveItems..::..Process Method
MoveItems Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    PublishItemContext context
)
Visual Basic
Public Overrides Sub Process ( _
    context As PublishItemContext _
)
Visual C++
public:
virtual void Process(
    PublishItemContext^ context
) override

Parameters

context
Type: Sitecore.Publishing.Pipelines.PublishItem..::..PublishItemContext
The args.

See Also

MoveItems Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


PerformAction Class

[image]

Sitecore 6.4.1 API
PerformAction Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PerformAction : PublishItemProcessor
Visual Basic
Public Class PerformAction _
    Inherits PublishItemProcessor
Visual C++
public ref class PerformAction : public PublishItemProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Publishing.Pipelines.PublishItem..::..PublishItemProcessor
Sitecore.Publishing.Pipelines.PublishItem..::..PerformAction

See Also

PerformAction Members
Sitecore.Publishing.Pipelines.PublishItem Namespace


PerformAction Members

[image] [image]

Sitecore 6.4.1 API
PerformAction Members
PerformAction Class Constructors Methods See Also Send Feedback

The PerformAction type exposes the following members.

Constructors

 | Name | Description
Public method | PerformAction | Initializes a new instance of the PerformAction class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides PublishItemProcessor..::..Process(PublishItemContext).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PerformAction Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


PerformAction Constructor

[image]

Sitecore 6.4.1 API
PerformAction Constructor
PerformAction Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PerformAction()
Visual Basic
Public Sub New
Visual C++
public:
PerformAction()

See Also

PerformAction Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


PerformAction Methods

[image] [image]

Sitecore 6.4.1 API
PerformAction Methods
PerformAction Class See Also Send Feedback

The PerformAction type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides PublishItemProcessor..::..Process(PublishItemContext).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PerformAction Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


Process Method

[image]

Sitecore 6.4.1 API
PerformAction..::..Process Method
PerformAction Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    PublishItemContext context
)
Visual Basic
Public Overrides Sub Process ( _
    context As PublishItemContext _
)
Visual C++
public:
virtual void Process(
    PublishItemContext^ context
) override

Parameters

context
Type: Sitecore.Publishing.Pipelines.PublishItem..::..PublishItemContext
The args.

See Also

PerformAction Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


PublishItemContext Class

[image]

Sitecore 6.4.1 API
PublishItemContext Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PublishItemContext : PipelineArgs
Visual Basic
Public Class PublishItemContext _
    Inherits PipelineArgs
Visual C++
public ref class PublishItemContext : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Publishing.Pipelines.PublishItem..::..PublishItemContext

See Also

PublishItemContext Members
Sitecore.Publishing.Pipelines.PublishItem Namespace


PublishItemContext Members

[image] [image]

Sitecore 6.4.1 API
PublishItemContext Members
PublishItemContext Class Constructors Methods Properties See Also Send Feedback

The PublishItemContext type exposes the following members.

Constructors

 | Name | Description
Public method | PublishItemContext | Initializes a new instance of the PublishItemContext class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline()()()() | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline(PublishOperation, PublishChildAction, String) | Aborts the pipeline.
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Public method | Clone | Create a clone with the specified item id.
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | Action | Gets the type of the action.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | ItemId | Gets the item id.
Public property | Job | Gets or sets the job.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | PublishContext | Gets the publish context.
Public property | PublishHelper | Gets or sets the publish helper.
Public property | PublishOptions | Gets the publish options.
Public property | Result | Gets or sets the result (i.e. the return value of the pipeline).
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
Public property | User | Gets or sets the user.
Public property | VersionToPublish | Gets or sets the version to publish.

See Also

PublishItemContext Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


PublishItemContext Constructor

[image]

Sitecore 6.4.1 API
PublishItemContext Constructor
PublishItemContext Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PublishItemContext(
    ID itemId,
    PublishOptions publishOptions
)
Visual Basic
Public Sub New ( _
    itemId As ID, _
    publishOptions As PublishOptions _
)
Visual C++
public:
PublishItemContext(
    ID^ itemId,
    PublishOptions^ publishOptions
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
publishOptions
Type: Sitecore.Publishing..::..PublishOptions
The publish options.

See Also

PublishItemContext Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
PublishItemContext..::..AddMessage Method
PublishItemContext Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

PublishItemContext Class
PublishItemContext Members
Sitecore.Publishing.Pipelines.PublishItem Namespace


Clone Method

[image]

Sitecore 6.4.1 API
PublishItemContext..::..Clone Method
PublishItemContext Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PublishItemContext Clone(
    ID itemId
)
Visual Basic
Public Function Clone ( _
    itemId As ID _
) As PublishItemContext
Visual C++
public:
PublishItemContext^ Clone(
    ID^ itemId
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Publishing.Pipelines.PublishItem.PublishItemContext.Clone(Sitecore.Data.ID)"]

See Also

PublishItemContext Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
PublishItemContext..::..GetMessages Method
PublishItemContext Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

PublishItemContext Class
PublishItemContext Members
Sitecore.Publishing.Pipelines.PublishItem Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
PublishItemContext..::..Suspend Method
PublishItemContext Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

PublishItemContext Class
PublishItemContext Members
Sitecore.Publishing.Pipelines.PublishItem Namespace


PublishItemContext Properties

[image] [image]

Sitecore 6.4.1 API
PublishItemContext Properties
PublishItemContext Class See Also Send Feedback

The PublishItemContext type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | Action | Gets the type of the action.
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | ItemId | Gets the item id.
Public property | Job | Gets or sets the job.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | PublishContext | Gets the publish context.
Public property | PublishHelper | Gets or sets the publish helper.
Public property | PublishOptions | Gets the publish options.
Public property | Result | Gets or sets the result (i.e. the return value of the pipeline).
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)
Public property | User | Gets or sets the user.
Public property | VersionToPublish | Gets or sets the version to publish.

See Also

PublishItemContext Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


Action Property

[image]

Sitecore 6.4.1 API
PublishItemContext..::..Action Property
PublishItemContext Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual PublishAction Action { get; set; }
Visual Basic
Public Overridable Property Action As PublishAction
    Get
    Set
Visual C++
public:
virtual property PublishAction Action {
    PublishAction get ();
    void set (PublishAction value);
}

Field Value

The type of the action.

See Also

PublishItemContext Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


ItemId Property

[image]

Sitecore 6.4.1 API
PublishItemContext..::..ItemId Property
PublishItemContext Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual ID ItemId { get; }
Visual Basic
Public Overridable ReadOnly Property ItemId As ID
    Get
Visual C++
public:
virtual property ID^ ItemId {
    ID^ get ();
}

Field Value

The item id.

See Also

PublishItemContext Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


Job Property

[image]

Sitecore 6.4.1 API
PublishItemContext..::..Job Property
PublishItemContext Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Job Job { get; set; }
Visual Basic
Public Property Job As Job
    Get
    Set
Visual C++
public:
property Job^ Job {
    Job^ get ();
    void set (Job^ value);
}

Field Value

The job.

See Also

PublishItemContext Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


PublishContext Property

[image]

Sitecore 6.4.1 API
PublishItemContext..::..PublishContext Property
PublishItemContext Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PublishContext PublishContext { get; set; }
Visual Basic
Public Property PublishContext As PublishContext
    Get
    Set
Visual C++
public:
property PublishContext^ PublishContext {
    PublishContext^ get ();
    void set (PublishContext^ value);
}

Field Value

The publish context.

See Also

PublishItemContext Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


PublishHelper Property

[image]

Sitecore 6.4.1 API
PublishItemContext..::..PublishHelper Property
PublishItemContext Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual PublishHelper PublishHelper { get; set; }
Visual Basic
Public Overridable Property PublishHelper As PublishHelper
    Get
    Set
Visual C++
public:
virtual property PublishHelper^ PublishHelper {
    PublishHelper^ get ();
    void set (PublishHelper^ value);
}

Field Value

The publish helper.

See Also

PublishItemContext Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


PublishOptions Property

[image]

Sitecore 6.4.1 API
PublishItemContext..::..PublishOptions Property
PublishItemContext Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual PublishOptions PublishOptions { get; }
Visual Basic
Public Overridable ReadOnly Property PublishOptions As PublishOptions
    Get
Visual C++
public:
virtual property PublishOptions^ PublishOptions {
    PublishOptions^ get ();
}

Field Value

The publish options.

See Also

PublishItemContext Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


Result Property

[image]

Sitecore 6.4.1 API
PublishItemContext..::..Result Property
PublishItemContext Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual PublishItemResult Result { get; set; }
Visual Basic
Public Overridable Property Result As PublishItemResult
    Get
    Set
Visual C++
public:
virtual property PublishItemResult^ Result {
    PublishItemResult^ get ();
    void set (PublishItemResult^ value);
}

Field Value

The result.

See Also

PublishItemContext Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


User Property

[image]

Sitecore 6.4.1 API
PublishItemContext..::..User Property
PublishItemContext Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual User User { get; set; }
Visual Basic
Public Overridable Property User As User
    Get
    Set
Visual C++
public:
virtual property User^ User {
    User^ get ();
    void set (User^ value);
}

Field Value

The user.

See Also

PublishItemContext Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


VersionToPublish Property

[image]

Sitecore 6.4.1 API
PublishItemContext..::..VersionToPublish Property
PublishItemContext Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Item VersionToPublish { get; set; }
Visual Basic
Public Overridable Property VersionToPublish As Item
    Get
    Set
Visual C++
public:
virtual property Item^ VersionToPublish {
    Item^ get ();
    void set (Item^ value);
}

Field Value

The version to publish.

See Also

PublishItemContext Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


PublishItemPipeline Class

[image]

Sitecore 6.4.1 API
PublishItemPipeline Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PublishItemPipeline
Visual Basic
Public Class PublishItemPipeline
Visual C++
public ref class PublishItemPipeline

Inheritance Hierarchy

System..::..Object
Sitecore.Publishing.Pipelines.PublishItem..::..PublishItemPipeline

See Also

PublishItemPipeline Members
Sitecore.Publishing.Pipelines.PublishItem Namespace


PublishItemPipeline Members

[image] [image]

Sitecore 6.4.1 API
PublishItemPipeline Members
PublishItemPipeline Class Constructors Methods See Also Send Feedback

The PublishItemPipeline type exposes the following members.

Constructors

 | Name | Description
Public method | PublishItemPipeline | Initializes a new instance of the PublishItemPipeline class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run(PublishItemContext) | Runs the 'publish' pipeline with specified arguments.
 | Run(ID, PublishOptions) | Runs the pipeline with the specified item id.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PublishItemPipeline Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


PublishItemPipeline Constructor

[image]

Sitecore 6.4.1 API
PublishItemPipeline Constructor
PublishItemPipeline Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PublishItemPipeline()
Visual Basic
Public Sub New
Visual C++
public:
PublishItemPipeline()

See Also

PublishItemPipeline Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


PublishItemPipeline Methods

[image] [image]

Sitecore 6.4.1 API
PublishItemPipeline Methods
PublishItemPipeline Class See Also Send Feedback

The PublishItemPipeline type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Run(PublishItemContext) | Runs the 'publish' pipeline with specified arguments.
 | Run(ID, PublishOptions) | Runs the pipeline with the specified item id.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PublishItemPipeline Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


Run Method

[image] [image]

Sitecore 6.4.1 API
PublishItemPipeline..::..Run Method
PublishItemPipeline Class See Also Send Feedback

Overload List

Name | Description
Run(PublishItemContext) | Runs the 'publish' pipeline with specified arguments.
Run(ID, PublishOptions) | Runs the pipeline with the specified item id.

See Also

PublishItemPipeline Class
PublishItemPipeline Members
Sitecore.Publishing.Pipelines.PublishItem Namespace


Run Method (PublishItemContext)

[image]

Sitecore 6.4.1 API
PublishItemPipeline..::..Run Method (PublishItemContext)
PublishItemPipeline Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PublishItemResult Run(
    PublishItemContext context
)
Visual Basic
Public Shared Function Run ( _
    context As PublishItemContext _
) As PublishItemResult
Visual C++
public:
static PublishItemResult^ Run(
    PublishItemContext^ context
)

Parameters

context
Type: Sitecore.Publishing.Pipelines.PublishItem..::..PublishItemContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Publishing.Pipelines.PublishItem.PublishItemPipeline.Run(Sitecore.Publishing.Pipelines.PublishItem.PublishItemContext)"]

See Also

PublishItemPipeline Class
Run Overload
Sitecore.Publishing.Pipelines.PublishItem Namespace


Run Method (ID, PublishOptions)

[image]

Sitecore 6.4.1 API
PublishItemPipeline..::..Run Method (ID, PublishOptions)
PublishItemPipeline Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PublishItemResult Run(
    ID itemId,
    PublishOptions options
)
Visual Basic
Public Shared Function Run ( _
    itemId As ID, _
    options As PublishOptions _
) As PublishItemResult
Visual C++
public:
static PublishItemResult^ Run(
    ID^ itemId,
    PublishOptions^ options
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
options
Type: Sitecore.Publishing..::..PublishOptions
The options.

Return Value

[Missing <returns> documentation for "M:Sitecore.Publishing.Pipelines.PublishItem.PublishItemPipeline.Run(Sitecore.Data.ID,Sitecore.Publishing.PublishOptions)"]

See Also

PublishItemPipeline Class
Run Overload
Sitecore.Publishing.Pipelines.PublishItem Namespace


PublishItemProcessor Members

[image] [image]

Sitecore 6.4.1 API
PublishItemProcessor Members
PublishItemProcessor Class Constructors Methods See Also Send Feedback

The PublishItemProcessor type exposes the following members.

Constructors

 | Name | Description
Protected method | PublishItemProcessor | Initializes a new instance of the PublishItemProcessor class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PublishItemProcessor Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


PublishItemProcessor Constructor

[image]

Sitecore 6.4.1 API
PublishItemProcessor Constructor
PublishItemProcessor Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected PublishItemProcessor()
Visual Basic
Protected Sub New
Visual C++
protected:
PublishItemProcessor()

See Also

PublishItemProcessor Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


PublishItemProcessor Methods

[image] [image]

Sitecore 6.4.1 API
PublishItemProcessor Methods
PublishItemProcessor Class See Also Send Feedback

The PublishItemProcessor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PublishItemProcessor Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


Process Method

[image]

Sitecore 6.4.1 API
PublishItemProcessor..::..Process Method
PublishItemProcessor Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public abstract void Process(
    PublishItemContext context
)
Visual Basic
Public MustOverride Sub Process ( _
    context As PublishItemContext _
)
Visual C++
public:
virtual void Process(
    PublishItemContext^ context
) abstract

Parameters

context
Type: Sitecore.Publishing.Pipelines.PublishItem..::..PublishItemContext
The args.

See Also

PublishItemProcessor Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


PublishItemResult Class

[image]

Sitecore 6.4.1 API
PublishItemResult Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PublishItemResult
Visual Basic
Public Class PublishItemResult
Visual C++
public ref class PublishItemResult

Inheritance Hierarchy

System..::..Object
Sitecore.Publishing.Pipelines.PublishItem..::..PublishItemResult

See Also

PublishItemResult Members
Sitecore.Publishing.Pipelines.PublishItem Namespace


PublishItemResult Members

[image] [image]

Sitecore 6.4.1 API
PublishItemResult Members
PublishItemResult Class Constructors Methods Properties See Also Send Feedback

The PublishItemResult type exposes the following members.

Constructors

 | Name | Description
Public method | PublishItemResult(PublishOperation, PublishChildAction) | Initializes a new instance of the PublishItemResult class.
Public method | PublishItemResult(PublishOperation, PublishChildAction, String) | Initializes a new instance of the PublishItemResult class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ChildAction | Gets the action for children.
Public property | Explanation | Gets an explanation of the result (might be blank).
Public property | Operation | Gets the type of operation that was performed.
Public property | ReferredItems | Gets the list of referred items that must be published together with current item.

See Also

PublishItemResult Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


PublishItemResult Constructor

[image] [image]

Sitecore 6.4.1 API
PublishItemResult Constructor
PublishItemResult Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PublishItemResult(PublishOperation, PublishChildAction) | Initializes a new instance of the PublishItemResult class.
Public method | PublishItemResult(PublishOperation, PublishChildAction, String) | Initializes a new instance of the PublishItemResult class.

See Also

PublishItemResult Class
PublishItemResult Members
Sitecore.Publishing.Pipelines.PublishItem Namespace


PublishItemResult Constructor (PublishOperation, PublishChildAction)

[image]

Sitecore 6.4.1 API
PublishItemResult Constructor (PublishOperation, PublishChildAction)
PublishItemResult Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PublishItemResult(
    PublishOperation operation,
    PublishChildAction childAction
)
Visual Basic
Public Sub New ( _
    operation As PublishOperation, _
    childAction As PublishChildAction _
)
Visual C++
public:
PublishItemResult(
    PublishOperation operation,
    PublishChildAction childAction
)

Parameters

operation
Type: Sitecore.Publishing..::..PublishOperation
The operation.
childAction
Type: Sitecore.Publishing..::..PublishChildAction
The child action.

See Also

PublishItemResult Class
PublishItemResult Overload
Sitecore.Publishing.Pipelines.PublishItem Namespace


PublishItemResult Constructor (PublishOperation, PublishChildAction, String)

[image]

Sitecore 6.4.1 API
PublishItemResult Constructor (PublishOperation, PublishChildAction, String)
PublishItemResult Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PublishItemResult(
    PublishOperation operation,
    PublishChildAction childAction,
    string explanation
)
Visual Basic
Public Sub New ( _
    operation As PublishOperation, _
    childAction As PublishChildAction, _
    explanation As String _
)
Visual C++
public:
PublishItemResult(
    PublishOperation operation,
    PublishChildAction childAction,
    String^ explanation
)

Parameters

operation
Type: Sitecore.Publishing..::..PublishOperation
Type of operation that was performed.
childAction
Type: Sitecore.Publishing..::..PublishChildAction
The action for children.
explanation
Type: System..::..String
An optional explanation of the result.

See Also

PublishItemResult Class
PublishItemResult Overload
Sitecore.Publishing.Pipelines.PublishItem Namespace


PublishItemResult Methods

[image] [image]

Sitecore 6.4.1 API
PublishItemResult Methods
PublishItemResult Class See Also Send Feedback

The PublishItemResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PublishItemResult Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


PublishItemResult Properties

[image] [image]

Sitecore 6.4.1 API
PublishItemResult Properties
PublishItemResult Class See Also Send Feedback

The PublishItemResult type exposes the following members.

Properties

 | Name | Description
Public property | ChildAction | Gets the action for children.
Public property | Explanation | Gets an explanation of the result (might be blank).
Public property | Operation | Gets the type of operation that was performed.
Public property | ReferredItems | Gets the list of referred items that must be published together with current item.

See Also

PublishItemResult Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


ChildAction Property

[image]

Sitecore 6.4.1 API
PublishItemResult..::..ChildAction Property
PublishItemResult Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PublishChildAction ChildAction { get; }
Visual Basic
Public ReadOnly Property ChildAction As PublishChildAction
    Get
Visual C++
public:
property PublishChildAction ChildAction {
    PublishChildAction get ();
}

Field Value

The child action.

See Also

PublishItemResult Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


Explanation Property

[image]

Sitecore 6.4.1 API
PublishItemResult..::..Explanation Property
PublishItemResult Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Explanation { get; }
Visual Basic
Public ReadOnly Property Explanation As String
    Get
Visual C++
public:
property String^ Explanation {
    String^ get ();
}

Field Value

The explanation.

See Also

PublishItemResult Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


Operation Property

[image]

Sitecore 6.4.1 API
PublishItemResult..::..Operation Property
PublishItemResult Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PublishOperation Operation { get; }
Visual Basic
Public ReadOnly Property Operation As PublishOperation
    Get
Visual C++
public:
property PublishOperation Operation {
    PublishOperation get ();
}

Field Value

The type of the action.

See Also

PublishItemResult Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


ReferredItems Property

[image]

Sitecore 6.4.1 API
PublishItemResult..::..ReferredItems Property
PublishItemResult Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public List<PublishingCandidate> ReferredItems { get; }
Visual Basic
Public ReadOnly Property ReferredItems As List(Of PublishingCandidate)
    Get
Visual C++
public:
property List<PublishingCandidate^>^ ReferredItems {
    List<PublishingCandidate^>^ get ();
}

Field Value

The list of referred items.

See Also

PublishItemResult Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


RaiseProcessedEvent Class

[image]

Sitecore 6.4.1 API
RaiseProcessedEvent Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RaiseProcessedEvent : PublishItemProcessor
Visual Basic
Public Class RaiseProcessedEvent _
    Inherits PublishItemProcessor
Visual C++
public ref class RaiseProcessedEvent : public PublishItemProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Publishing.Pipelines.PublishItem..::..PublishItemProcessor
Sitecore.Publishing.Pipelines.PublishItem..::..RaiseProcessedEvent

See Also

RaiseProcessedEvent Members
Sitecore.Publishing.Pipelines.PublishItem Namespace


RaiseProcessedEvent Members

[image] [image]

Sitecore 6.4.1 API
RaiseProcessedEvent Members
RaiseProcessedEvent Class Constructors Methods See Also Send Feedback

The RaiseProcessedEvent type exposes the following members.

Constructors

 | Name | Description
Public method | RaiseProcessedEvent | Initializes a new instance of the RaiseProcessedEvent class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified context. (Overrides PublishItemProcessor..::..Process(PublishItemContext).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RaiseProcessedEvent Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


RaiseProcessedEvent Constructor

[image]

Sitecore 6.4.1 API
RaiseProcessedEvent Constructor
RaiseProcessedEvent Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RaiseProcessedEvent()
Visual Basic
Public Sub New
Visual C++
public:
RaiseProcessedEvent()

See Also

RaiseProcessedEvent Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


RaiseProcessedEvent Methods

[image] [image]

Sitecore 6.4.1 API
RaiseProcessedEvent Methods
RaiseProcessedEvent Class See Also Send Feedback

The RaiseProcessedEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified context. (Overrides PublishItemProcessor..::..Process(PublishItemContext).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RaiseProcessedEvent Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


Process Method

[image]

Sitecore 6.4.1 API
RaiseProcessedEvent..::..Process Method
RaiseProcessedEvent Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    PublishItemContext context
)
Visual Basic
Public Overrides Sub Process ( _
    context As PublishItemContext _
)
Visual C++
public:
virtual void Process(
    PublishItemContext^ context
) override

Parameters

context
Type: Sitecore.Publishing.Pipelines.PublishItem..::..PublishItemContext
The context.

See Also

RaiseProcessedEvent Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


RaiseProcessingEvent Class

[image]

Sitecore 6.4.1 API
RaiseProcessingEvent Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RaiseProcessingEvent : PublishItemProcessor
Visual Basic
Public Class RaiseProcessingEvent _
    Inherits PublishItemProcessor
Visual C++
public ref class RaiseProcessingEvent : public PublishItemProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Publishing.Pipelines.PublishItem..::..PublishItemProcessor
Sitecore.Publishing.Pipelines.PublishItem..::..RaiseProcessingEvent

See Also

RaiseProcessingEvent Members
Sitecore.Publishing.Pipelines.PublishItem Namespace


RaiseProcessingEvent Constructor

[image]

Sitecore 6.4.1 API
RaiseProcessingEvent Constructor
RaiseProcessingEvent Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RaiseProcessingEvent()
Visual Basic
Public Sub New
Visual C++
public:
RaiseProcessingEvent()

See Also

RaiseProcessingEvent Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


RaiseProcessingEvent Methods

[image] [image]

Sitecore 6.4.1 API
RaiseProcessingEvent Methods
RaiseProcessingEvent Class See Also Send Feedback

The RaiseProcessingEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified context. (Overrides PublishItemProcessor..::..Process(PublishItemContext).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RaiseProcessingEvent Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


Process Method

[image]

Sitecore 6.4.1 API
RaiseProcessingEvent..::..Process Method
RaiseProcessingEvent Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    PublishItemContext context
)
Visual Basic
Public Overrides Sub Process ( _
    context As PublishItemContext _
)
Visual C++
public:
virtual void Process(
    PublishItemContext^ context
) override

Parameters

context
Type: Sitecore.Publishing.Pipelines.PublishItem..::..PublishItemContext
The context.

See Also

RaiseProcessingEvent Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


RemoveUnknownChildren Class

[image]

Sitecore 6.4.1 API
RemoveUnknownChildren Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class RemoveUnknownChildren : PublishItemProcessor
Visual Basic
Public Class RemoveUnknownChildren _
    Inherits PublishItemProcessor
Visual C++
public ref class RemoveUnknownChildren : public PublishItemProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Publishing.Pipelines.PublishItem..::..PublishItemProcessor
Sitecore.Publishing.Pipelines.PublishItem..::..RemoveUnknownChildren

See Also

RemoveUnknownChildren Members
Sitecore.Publishing.Pipelines.PublishItem Namespace


RemoveUnknownChildren Members

[image] [image]

Sitecore 6.4.1 API
RemoveUnknownChildren Members
RemoveUnknownChildren Class Constructors Methods See Also Send Feedback

The RemoveUnknownChildren type exposes the following members.

Constructors

 | Name | Description
Public method | RemoveUnknownChildren | Initializes a new instance of the RemoveUnknownChildren class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides PublishItemProcessor..::..Process(PublishItemContext).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RemoveUnknownChildren Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


RemoveUnknownChildren Constructor

[image]

Sitecore 6.4.1 API
RemoveUnknownChildren Constructor
RemoveUnknownChildren Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RemoveUnknownChildren()
Visual Basic
Public Sub New
Visual C++
public:
RemoveUnknownChildren()

See Also

RemoveUnknownChildren Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


RemoveUnknownChildren Methods

[image] [image]

Sitecore 6.4.1 API
RemoveUnknownChildren Methods
RemoveUnknownChildren Class See Also Send Feedback

The RemoveUnknownChildren type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides PublishItemProcessor..::..Process(PublishItemContext).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RemoveUnknownChildren Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


Process Method

[image]

Sitecore 6.4.1 API
RemoveUnknownChildren..::..Process Method
RemoveUnknownChildren Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    PublishItemContext context
)
Visual Basic
Public Overrides Sub Process ( _
    context As PublishItemContext _
)
Visual C++
public:
virtual void Process(
    PublishItemContext^ context
) override

Parameters

context
Type: Sitecore.Publishing.Pipelines.PublishItem..::..PublishItemContext
The context.

See Also

RemoveUnknownChildren Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


UpdateStatistics Class

[image]

Sitecore 6.4.1 API
UpdateStatistics Class
Members See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class UpdateStatistics : PublishItemProcessor
Visual Basic
Public Class UpdateStatistics _
    Inherits PublishItemProcessor
Visual C++
public ref class UpdateStatistics : public PublishItemProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Publishing.Pipelines.PublishItem..::..PublishItemProcessor
Sitecore.Publishing.Pipelines.PublishItem..::..UpdateStatistics

See Also

UpdateStatistics Members
Sitecore.Publishing.Pipelines.PublishItem Namespace


UpdateStatistics Members

[image] [image]

Sitecore 6.4.1 API
UpdateStatistics Members
UpdateStatistics Class Constructors Methods Properties See Also Send Feedback

The UpdateStatistics type exposes the following members.

Constructors

 | Name | Description
Public method | UpdateStatistics | Initializes a new instance of the UpdateStatistics class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides PublishItemProcessor..::..Process(PublishItemContext).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | TraceToLog | Gets or sets a value indicating whether to trace publishing information for every item to the log.

See Also

UpdateStatistics Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


UpdateStatistics Methods

[image] [image]

Sitecore 6.4.1 API
UpdateStatistics Methods
UpdateStatistics Class See Also Send Feedback

The UpdateStatistics type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Processes the specified args. (Overrides PublishItemProcessor..::..Process(PublishItemContext).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UpdateStatistics Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


Process Method

[image]

Sitecore 6.4.1 API
UpdateStatistics..::..Process Method
UpdateStatistics Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Process(
    PublishItemContext context
)
Visual Basic
Public Overrides Sub Process ( _
    context As PublishItemContext _
)
Visual C++
public:
virtual void Process(
    PublishItemContext^ context
) override

Parameters

context
Type: Sitecore.Publishing.Pipelines.PublishItem..::..PublishItemContext
The context.

See Also

UpdateStatistics Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


UpdateStatistics Properties

[image] [image]

Sitecore 6.4.1 API
UpdateStatistics Properties
UpdateStatistics Class See Also Send Feedback

The UpdateStatistics type exposes the following members.

Properties

 | Name | Description
Public property | TraceToLog | Gets or sets a value indicating whether to trace publishing information for every item to the log.

See Also

UpdateStatistics Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


TraceToLog Property

[image]

Sitecore 6.4.1 API
UpdateStatistics..::..TraceToLog Property
UpdateStatistics Class See Also Send Feedback

Namespace: Sitecore.Publishing.Pipelines.PublishItem
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual bool TraceToLog { get; set; }
Visual Basic
Public Overridable Property TraceToLog As Boolean
    Get
    Set
Visual C++
public:
virtual property bool TraceToLog {
    bool get ();
    void set (bool value);
}

Field Value

true if trace to log; otherwise, false.

See Also

UpdateStatistics Class
Sitecore.Publishing.Pipelines.PublishItem Namespace


Sitecore.Reflection Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Reflection Namespace
Send Feedback

Classes

 | Class | Description
Public class | MethodInstance | Represents a method instance.
Public class | Nexus | Nexus class
Public class | NexusHelper | NexusHelper class
Public class | PropertyTarget | Represents a property target.
Public class | ReflectionUtil | Implements a utility class for working with reflection.
Public class | TypeUtil | TypeUtil

Interfaces

 | Interface | Description
Public interface | IFactory | IFactory
Public interface | IInitializable | Defines the basic properties and functionality of an object that can be initialized.
Public interface | INexusDataApi | INexusDataApi interface
Public interface | INexusLicenseApi | INexusLicenseApi interface
Public interface | INexusPipelineApi | INexusPipelineApi interface
Public interface | INexusPlaceholderApi | INexusPlaceholderApi interface

Delegates

 | Delegate | Description
Public delegate | FastInvoker | A delegate to invoke fast methods.


FastInvoker Delegate

[image]

Sitecore 6.4.1 API
FastInvoker Delegate
See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public delegate Object FastInvoker(
    Object target,
    Object[] paramters
)
Visual Basic
Public Delegate Function FastInvoker ( _
    target As Object, _
    paramters As Object() _
) As Object
Visual C++
public delegate Object^ FastInvoker(
    Object^ target,
    array<Object^>^ paramters
)

Parameters

target
Type: System..::..Object
paramters
Type: array< System..::..Object >[]()[][]

See Also

Sitecore.Reflection Namespace


IFactory Interface

[image]

Sitecore 6.4.1 API
IFactory Interface
Members See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IFactory
Visual Basic
Public Interface IFactory
Visual C++
public interface class IFactory

See Also

IFactory Members
Sitecore.Reflection Namespace


IFactory Members

[image] [image]

Sitecore 6.4.1 API
IFactory Members
IFactory Interface Methods See Also Send Feedback

The IFactory type exposes the following members.

Methods

 | Name | Description
Public method | GetObject | Gets the object.

See Also

IFactory Interface
Sitecore.Reflection Namespace


IFactory Methods

[image] [image]

Sitecore 6.4.1 API
IFactory Methods
IFactory Interface See Also Send Feedback

The IFactory type exposes the following members.

Methods

 | Name | Description
Public method | GetObject | Gets the object.

See Also

IFactory Interface
Sitecore.Reflection Namespace


GetObject Method

[image]

Sitecore 6.4.1 API
IFactory..::..GetObject Method
IFactory Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
Object GetObject(
    string identifier
)
Visual Basic
Function GetObject ( _
    identifier As String _
) As Object
Visual C++
Object^ GetObject(
    String^ identifier
)

Parameters

identifier
Type: System..::..String
The identifier.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.IFactory.GetObject(System.String)"]

See Also

IFactory Interface
Sitecore.Reflection Namespace


IInitializable Interface

[image]

Sitecore 6.4.1 API
IInitializable Interface
Members See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface IInitializable
Visual Basic
Public Interface IInitializable
Visual C++
public interface class IInitializable

See Also

IInitializable Members
Sitecore.Reflection Namespace


IInitializable Members

[image] [image]

Sitecore 6.4.1 API
IInitializable Members
IInitializable Interface Methods Properties See Also Send Feedback

The IInitializable type exposes the following members.

Methods

 | Name | Description
Public method | Initialize | Initializes the object from the specified config node.

Properties

 | Name | Description
Public property | AssignProperties | Gets a value indicating whether the IInitializable assigns the properties.

See Also

IInitializable Interface
Sitecore.Reflection Namespace


IInitializable Methods

[image] [image]

Sitecore 6.4.1 API
IInitializable Methods
IInitializable Interface See Also Send Feedback

The IInitializable type exposes the following members.

Methods

 | Name | Description
Public method | Initialize | Initializes the object from the specified config node.

See Also

IInitializable Interface
Sitecore.Reflection Namespace


Initialize Method

[image]

Sitecore 6.4.1 API
IInitializable..::..Initialize Method
IInitializable Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void Initialize(
    XmlNode configNode
)
Visual Basic
Sub Initialize ( _
    configNode As XmlNode _
)
Visual C++
void Initialize(
    XmlNode^ configNode
)

Parameters

configNode
Type: System.Xml..::..XmlNode
The config node.

See Also

IInitializable Interface
Sitecore.Reflection Namespace


IInitializable Properties

[image] [image]

Sitecore 6.4.1 API
IInitializable Properties
IInitializable Interface See Also Send Feedback

The IInitializable type exposes the following members.

Properties

 | Name | Description
Public property | AssignProperties | Gets a value indicating whether the IInitializable assigns the properties.

See Also

IInitializable Interface
Sitecore.Reflection Namespace


AssignProperties Property

[image]

Sitecore 6.4.1 API
IInitializable..::..AssignProperties Property
IInitializable Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
bool AssignProperties { get; }
Visual Basic
ReadOnly Property AssignProperties As Boolean
    Get
Visual C++
property bool AssignProperties {
    bool get ();
}

Field Value

true if the IInitializable assigns the properties; otherwise, false.

See Also

IInitializable Interface
Sitecore.Reflection Namespace


INexusDataApi Interface

[image]

Sitecore 6.4.1 API
INexusDataApi Interface
Members See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface INexusDataApi
Visual Basic
Public Interface INexusDataApi
Visual C++
public interface class INexusDataApi

See Also

INexusDataApi Members
Sitecore.Reflection Namespace


INexusDataApi Members

[image] [image]

Sitecore 6.4.1 API
INexusDataApi Members
INexusDataApi Interface Methods See Also Send Feedback

The INexusDataApi type exposes the following members.

Methods

 | Name | Description
Public method | AddFromTemplate | Adds a new item from a template.
Public method | AddVersion | Adds a new version to an item.
Public method | BlobStreamExists | Determines whether the specified item field contains a BLOB value.
Public method | CopyItem | Copies an item.
Public method | CreateItem | Creates an item.
Public method | DeleteItem | Deletes an item.
Public method | GetBlobStream | Gets a BLOB stream from a field.
Public method | GetChildren | Gets the children of an item.
Public method | GetItem | Gets an item.
Public method | GetParent | Gets the parent of an item.
Public method | GetRootItem | Gets the root item of a database.
Public method | GetVersions | Gets the versions of an item.
Public method | HasChildren | Determines whether the specified item has any children.
Public method | MoveItem | Moves an item.
Public method | RemoveData | Removes the data associated with an item.
Public method | RemoveVersion | Removes a version from an item.
Public method | ResolvePath | Resolves an item path.
Public method | SaveItem | Saves an item.
Public method | SetBlobStream | Gets a BLOB stream from a field.

See Also

INexusDataApi Interface
Sitecore.Reflection Namespace


INexusDataApi Methods

[image] [image]

Sitecore 6.4.1 API
INexusDataApi Methods
INexusDataApi Interface See Also Send Feedback

The INexusDataApi type exposes the following members.

Methods

 | Name | Description
Public method | AddFromTemplate | Adds a new item from a template.
Public method | AddVersion | Adds a new version to an item.
Public method | BlobStreamExists | Determines whether the specified item field contains a BLOB value.
Public method | CopyItem | Copies an item.
Public method | CreateItem | Creates an item.
Public method | DeleteItem | Deletes an item.
Public method | GetBlobStream | Gets a BLOB stream from a field.
Public method | GetChildren | Gets the children of an item.
Public method | GetItem | Gets an item.
Public method | GetParent | Gets the parent of an item.
Public method | GetRootItem | Gets the root item of a database.
Public method | GetVersions | Gets the versions of an item.
Public method | HasChildren | Determines whether the specified item has any children.
Public method | MoveItem | Moves an item.
Public method | RemoveData | Removes the data associated with an item.
Public method | RemoveVersion | Removes a version from an item.
Public method | ResolvePath | Resolves an item path.
Public method | SaveItem | Saves an item.
Public method | SetBlobStream | Gets a BLOB stream from a field.

See Also

INexusDataApi Interface
Sitecore.Reflection Namespace


AddFromTemplate Method

[image]

Sitecore 6.4.1 API
INexusDataApi..::..AddFromTemplate Method
INexusDataApi Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
Item AddFromTemplate(
    ID templateId,
    Item destination,
    string itemName,
    ID newId
)
Visual Basic
Function AddFromTemplate ( _
    templateId As ID, _
    destination As Item, _
    itemName As String, _
    newId As ID _
) As Item
Visual C++
Item^ AddFromTemplate(
    ID^ templateId,
    Item^ destination,
    String^ itemName,
    ID^ newId
)

Parameters

templateId
Type: Sitecore.Data..::..ID
The template id.
destination
Type: Sitecore.Data.Items..::..Item
The destination.
itemName
Type: System..::..String
Name of the item.
newId
Type: Sitecore.Data..::..ID
The new id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.INexusDataApi.AddFromTemplate(Sitecore.Data.ID,Sitecore.Data.Items.Item,System.String,Sitecore.Data.ID)"]

See Also

INexusDataApi Interface
Sitecore.Reflection Namespace


AddVersion Method

[image]

Sitecore 6.4.1 API
INexusDataApi..::..AddVersion Method
INexusDataApi Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
Item AddVersion(
    Item item
)
Visual Basic
Function AddVersion ( _
    item As Item _
) As Item
Visual C++
Item^ AddVersion(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.INexusDataApi.AddVersion(Sitecore.Data.Items.Item)"]

See Also

INexusDataApi Interface
Sitecore.Reflection Namespace


BlobStreamExists Method

[image]

Sitecore 6.4.1 API
INexusDataApi..::..BlobStreamExists Method
INexusDataApi Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
bool BlobStreamExists(
    Guid blobId,
    Database database
)
Visual Basic
Function BlobStreamExists ( _
    blobId As Guid, _
    database As Database _
) As Boolean
Visual C++
bool BlobStreamExists(
    Guid blobId,
    Database^ database
)

Parameters

blobId
Type: System..::..Guid
The BLOB id.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

true if the field contains a BLOB value; otherwise, false.

See Also

INexusDataApi Interface
Sitecore.Reflection Namespace


CopyItem Method

[image]

Sitecore 6.4.1 API
INexusDataApi..::..CopyItem Method
INexusDataApi Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
Item CopyItem(
    Item source,
    Item destination,
    string copyName,
    ID copyId,
    bool deep
)
Visual Basic
Function CopyItem ( _
    source As Item, _
    destination As Item, _
    copyName As String, _
    copyId As ID, _
    deep As Boolean _
) As Item
Visual C++
Item^ CopyItem(
    Item^ source,
    Item^ destination,
    String^ copyName,
    ID^ copyId,
    bool deep
)

Parameters

source
Type: Sitecore.Data.Items..::..Item
The source.
destination
Type: Sitecore.Data.Items..::..Item
The destination.
copyName
Type: System..::..String
Name of the copy.
copyId
Type: Sitecore.Data..::..ID
The copy id.
deep
Type: System..::..Boolean
if set to true [deep].

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.INexusDataApi.CopyItem(Sitecore.Data.Items.Item,Sitecore.Data.Items.Item,System.String,Sitecore.Data.ID,System.Boolean)"]

See Also

INexusDataApi Interface
Sitecore.Reflection Namespace


CreateItem Method

[image]

Sitecore 6.4.1 API
INexusDataApi..::..CreateItem Method
INexusDataApi Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
Item CreateItem(
    ID itemId,
    string itemName,
    ID templateId,
    Item destination
)
Visual Basic
Function CreateItem ( _
    itemId As ID, _
    itemName As String, _
    templateId As ID, _
    destination As Item _
) As Item
Visual C++
Item^ CreateItem(
    ID^ itemId,
    String^ itemName,
    ID^ templateId,
    Item^ destination
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
itemName
Type: System..::..String
Name of the item.
templateId
Type: Sitecore.Data..::..ID
The template id.
destination
Type: Sitecore.Data.Items..::..Item
The destination.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.INexusDataApi.CreateItem(Sitecore.Data.ID,System.String,Sitecore.Data.ID,Sitecore.Data.Items.Item)"]

See Also

INexusDataApi Interface
Sitecore.Reflection Namespace


DeleteItem Method

[image]

Sitecore 6.4.1 API
INexusDataApi..::..DeleteItem Method
INexusDataApi Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
bool DeleteItem(
    Item item,
    ID parentId
)
Visual Basic
Function DeleteItem ( _
    item As Item, _
    parentId As ID _
) As Boolean
Visual C++
bool DeleteItem(
    Item^ item,
    ID^ parentId
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
parentId
Type: Sitecore.Data..::..ID
The parent id.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.INexusDataApi.DeleteItem(Sitecore.Data.Items.Item,Sitecore.Data.ID)"]

See Also

INexusDataApi Interface
Sitecore.Reflection Namespace


GetBlobStream Method

[image]

Sitecore 6.4.1 API
INexusDataApi..::..GetBlobStream Method
INexusDataApi Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
Stream GetBlobStream(
    Guid blobId,
    Database database
)
Visual Basic
Function GetBlobStream ( _
    blobId As Guid, _
    database As Database _
) As Stream
Visual C++
Stream^ GetBlobStream(
    Guid blobId,
    Database^ database
)

Parameters

blobId
Type: System..::..Guid
The BLOB id.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.INexusDataApi.GetBlobStream(System.Guid,Sitecore.Data.Database)"]

See Also

INexusDataApi Interface
Sitecore.Reflection Namespace


GetChildren Method

[image]

Sitecore 6.4.1 API
INexusDataApi..::..GetChildren Method
INexusDataApi Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
ItemList GetChildren(
    Item item
)
Visual Basic
Function GetChildren ( _
    item As Item _
) As ItemList
Visual C++
ItemList^ GetChildren(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.INexusDataApi.GetChildren(Sitecore.Data.Items.Item)"]

See Also

INexusDataApi Interface
Sitecore.Reflection Namespace


GetItem Method

[image]

Sitecore 6.4.1 API
INexusDataApi..::..GetItem Method
INexusDataApi Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
Item GetItem(
    ID itemId,
    Language language,
    Version version,
    Database database
)
Visual Basic
Function GetItem ( _
    itemId As ID, _
    language As Language, _
    version As Version, _
    database As Database _
) As Item
Visual C++
Item^ GetItem(
    ID^ itemId,
    Language^ language,
    Version^ version,
    Database^ database
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
language
Type: Sitecore.Globalization..::..Language
The language.
version
Type: Sitecore.Data..::..Version
The version.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.INexusDataApi.GetItem(Sitecore.Data.ID,Sitecore.Globalization.Language,Sitecore.Data.Version,Sitecore.Data.Database)"]

See Also

INexusDataApi Interface
Sitecore.Reflection Namespace


GetParent Method

[image]

Sitecore 6.4.1 API
INexusDataApi..::..GetParent Method
INexusDataApi Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
Item GetParent(
    Item item
)
Visual Basic
Function GetParent ( _
    item As Item _
) As Item
Visual C++
Item^ GetParent(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.INexusDataApi.GetParent(Sitecore.Data.Items.Item)"]

See Also

INexusDataApi Interface
Sitecore.Reflection Namespace


GetRootItem Method

[image]

Sitecore 6.4.1 API
INexusDataApi..::..GetRootItem Method
INexusDataApi Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
Item GetRootItem(
    Language language,
    Version version,
    Database database
)
Visual Basic
Function GetRootItem ( _
    language As Language, _
    version As Version, _
    database As Database _
) As Item
Visual C++
Item^ GetRootItem(
    Language^ language,
    Version^ version,
    Database^ database
)

Parameters

language
Type: Sitecore.Globalization..::..Language
The language.
version
Type: Sitecore.Data..::..Version
The version.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.INexusDataApi.GetRootItem(Sitecore.Globalization.Language,Sitecore.Data.Version,Sitecore.Data.Database)"]

See Also

INexusDataApi Interface
Sitecore.Reflection Namespace


GetVersions Method

[image]

Sitecore 6.4.1 API
INexusDataApi..::..GetVersions Method
INexusDataApi Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
VersionCollection GetVersions(
    Item item,
    Language language
)
Visual Basic
Function GetVersions ( _
    item As Item, _
    language As Language _
) As VersionCollection
Visual C++
VersionCollection^ GetVersions(
    Item^ item,
    Language^ language
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
language
Type: Sitecore.Globalization..::..Language
The language.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.INexusDataApi.GetVersions(Sitecore.Data.Items.Item,Sitecore.Globalization.Language)"]

See Also

INexusDataApi Interface
Sitecore.Reflection Namespace


HasChildren Method

[image]

Sitecore 6.4.1 API
INexusDataApi..::..HasChildren Method
INexusDataApi Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
bool HasChildren(
    Item item
)
Visual Basic
Function HasChildren ( _
    item As Item _
) As Boolean
Visual C++
bool HasChildren(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

true if the specified item has children; otherwise, false.

See Also

INexusDataApi Interface
Sitecore.Reflection Namespace


MoveItem Method

[image]

Sitecore 6.4.1 API
INexusDataApi..::..MoveItem Method
INexusDataApi Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
bool MoveItem(
    Item item,
    Item destination
)
Visual Basic
Function MoveItem ( _
    item As Item, _
    destination As Item _
) As Boolean
Visual C++
bool MoveItem(
    Item^ item,
    Item^ destination
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
destination
Type: Sitecore.Data.Items..::..Item
The destination.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.INexusDataApi.MoveItem(Sitecore.Data.Items.Item,Sitecore.Data.Items.Item)"]

See Also

INexusDataApi Interface
Sitecore.Reflection Namespace


RemoveData Method

[image]

Sitecore 6.4.1 API
INexusDataApi..::..RemoveData Method
INexusDataApi Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
bool RemoveData(
    ID itemId,
    Language language,
    bool removeSharedData,
    Database database
)
Visual Basic
Function RemoveData ( _
    itemId As ID, _
    language As Language, _
    removeSharedData As Boolean, _
    database As Database _
) As Boolean
Visual C++
bool RemoveData(
    ID^ itemId,
    Language^ language,
    bool removeSharedData,
    Database^ database
)

Parameters

itemId
Type: Sitecore.Data..::..ID
The item id.
language
Type: Sitecore.Globalization..::..Language
The language.
removeSharedData
Type: System..::..Boolean
If set to true, remove shared data.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.INexusDataApi.RemoveData(Sitecore.Data.ID,Sitecore.Globalization.Language,System.Boolean,Sitecore.Data.Database)"]

See Also

INexusDataApi Interface
Sitecore.Reflection Namespace


RemoveVersion Method

[image]

Sitecore 6.4.1 API
INexusDataApi..::..RemoveVersion Method
INexusDataApi Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
bool RemoveVersion(
    Item item
)
Visual Basic
Function RemoveVersion ( _
    item As Item _
) As Boolean
Visual C++
bool RemoveVersion(
    Item^ item
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.INexusDataApi.RemoveVersion(Sitecore.Data.Items.Item)"]

See Also

INexusDataApi Interface
Sitecore.Reflection Namespace


ResolvePath Method

[image]

Sitecore 6.4.1 API
INexusDataApi..::..ResolvePath Method
INexusDataApi Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
ID ResolvePath(
    string itemPath,
    Database database
)
Visual Basic
Function ResolvePath ( _
    itemPath As String, _
    database As Database _
) As ID
Visual C++
ID^ ResolvePath(
    String^ itemPath,
    Database^ database
)

Parameters

itemPath
Type: System..::..String
The item path.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.INexusDataApi.ResolvePath(System.String,Sitecore.Data.Database)"]

See Also

INexusDataApi Interface
Sitecore.Reflection Namespace


SaveItem Method

[image]

Sitecore 6.4.1 API
INexusDataApi..::..SaveItem Method
INexusDataApi Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
bool SaveItem(
    Item item,
    ItemChanges changes
)
Visual Basic
Function SaveItem ( _
    item As Item, _
    changes As ItemChanges _
) As Boolean
Visual C++
bool SaveItem(
    Item^ item,
    ItemChanges^ changes
)

Parameters

item
Type: Sitecore.Data.Items..::..Item
The item.
changes
Type: Sitecore.Data.Items..::..ItemChanges
The changes.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.INexusDataApi.SaveItem(Sitecore.Data.Items.Item,Sitecore.Data.Items.ItemChanges)"]

See Also

INexusDataApi Interface
Sitecore.Reflection Namespace


SetBlobStream Method

[image]

Sitecore 6.4.1 API
INexusDataApi..::..SetBlobStream Method
INexusDataApi Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
bool SetBlobStream(
    Stream stream,
    Guid blobId,
    Database database
)
Visual Basic
Function SetBlobStream ( _
    stream As Stream, _
    blobId As Guid, _
    database As Database _
) As Boolean
Visual C++
bool SetBlobStream(
    Stream^ stream,
    Guid blobId,
    Database^ database
)

Parameters

stream
Type: System.IO..::..Stream
The stream.
blobId
Type: System..::..Guid
The BLOB id.
database
Type: Sitecore.Data..::..Database
The database.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.INexusDataApi.SetBlobStream(System.IO.Stream,System.Guid,Sitecore.Data.Database)"]

See Also

INexusDataApi Interface
Sitecore.Reflection Namespace


INexusLicenseApi Interface

[image]

Sitecore 6.4.1 API
INexusLicenseApi Interface
Members See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface INexusLicenseApi
Visual Basic
Public Interface INexusLicenseApi
Visual C++
public interface class INexusLicenseApi

See Also

INexusLicenseApi Members
Sitecore.Reflection Namespace


INexusLicenseApi Members

[image] [image]

Sitecore 6.4.1 API
INexusLicenseApi Members
INexusLicenseApi Interface Methods Properties See Also Send Feedback

The INexusLicenseApi type exposes the following members.

Methods

 | Name | Description
Public method | DemandModule | Demands the module.
Public method | GetModuleCount | Gets the count value of a module.
Public method | GetSnapShot | Gets a snap shot of the current license state.
Public method | HasModule | Checks if a specific module has been licensed.
Public method | LicenseStatus | Licenses the status.
Public method | Reset | Resets this instance.
Public method | VerifiedLicense | Returns the verified license.

Properties

 | Name | Description
Public property | Address | Gets the company address.
Public property | CompanyNo | Gets the company number.
Public property | Expiration | Gets the license expiration date.
Public property | LastError | Gets the last error message.
Public property | LicenseAgreement | Gets the text of license agreement.
Public property | Licensee | Gets the name of the licensee.
Public property | LicenseID | Gets the license ID.
Public property | Purpose | Gets the purpose string.
Public property | Reseller | Gets the name of the reseller.
Public property | ResellerUrl | Gets the URL of the reseller.
Public property | Urls | Gets the company URLs.
Public property | Version | Gets the version.

See Also

INexusLicenseApi Interface
Sitecore.Reflection Namespace


INexusLicenseApi Methods

[image] [image]

Sitecore 6.4.1 API
INexusLicenseApi Methods
INexusLicenseApi Interface See Also Send Feedback

The INexusLicenseApi type exposes the following members.

Methods

 | Name | Description
Public method | DemandModule | Demands the module.
Public method | GetModuleCount | Gets the count value of a module.
Public method | GetSnapShot | Gets a snap shot of the current license state.
Public method | HasModule | Checks if a specific module has been licensed.
Public method | LicenseStatus | Licenses the status.
Public method | Reset | Resets this instance.
Public method | VerifiedLicense | Returns the verified license.

See Also

INexusLicenseApi Interface
Sitecore.Reflection Namespace


DemandModule Method

[image]

Sitecore 6.4.1 API
INexusLicenseApi..::..DemandModule Method
INexusLicenseApi Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void DemandModule(
    string moduleName
)
Visual Basic
Sub DemandModule ( _
    moduleName As String _
)
Visual C++
void DemandModule(
    String^ moduleName
)

Parameters

moduleName
Type: System..::..String
Name of the module.

See Also

INexusLicenseApi Interface
Sitecore.Reflection Namespace


GetModuleCount Method

[image]

Sitecore 6.4.1 API
INexusLicenseApi..::..GetModuleCount Method
INexusLicenseApi Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
int GetModuleCount(
    string name
)
Visual Basic
Function GetModuleCount ( _
    name As String _
) As Integer
Visual C++
int GetModuleCount(
    String^ name
)

Parameters

name
Type: System..::..String
The name of the module.

Return Value

The value of the count attribute for the module or 0 (zero) if no such attribute is available.

See Also

INexusLicenseApi Interface
Sitecore.Reflection Namespace


GetSnapShot Method

[image]

Sitecore 6.4.1 API
INexusLicenseApi..::..GetSnapShot Method
INexusLicenseApi Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
string GetSnapShot(
    Guid instance
)
Visual Basic
Function GetSnapShot ( _
    instance As Guid _
) As String
Visual C++
String^ GetSnapShot(
    Guid instance
)

Parameters

instance
Type: System..::..Guid

[Missing <param name="instance"/> documentation for "M:Sitecore.Reflection.INexusLicenseApi.GetSnapShot(System.Guid)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.INexusLicenseApi.GetSnapShot(System.Guid)"]

See Also

INexusLicenseApi Interface
Sitecore.Reflection Namespace


HasModule Method

[image]

Sitecore 6.4.1 API
INexusLicenseApi..::..HasModule Method
INexusLicenseApi Interface Example See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
bool HasModule(
    string name
)
Visual Basic
Function HasModule ( _
    name As String _
) As Boolean
Visual C++
bool HasModule(
    String^ name
)

Parameters

name
Type: System..::..String
The name of the module.

Return Value

True, if the license for the module is valid, otherwise false.

Examples

The following example checks that a specific module has a valid license.
CopyC#
string requiredLicense = "SiteCore.MyModule";
Error.Assert(Sitecore.License.HasModule(requiredLicense), "Can not use the module without the following license: " + requiredLicense);

See Also

INexusLicenseApi Interface
Sitecore.Reflection Namespace


LicenseStatus Method

[image]

Sitecore 6.4.1 API
INexusLicenseApi..::..LicenseStatus Method
INexusLicenseApi Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
CheckResult LicenseStatus(
    string name
)
Visual Basic
Function LicenseStatus ( _
    name As String _
) As CheckResult
Visual C++
CheckResult LicenseStatus(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

Return Value

The status.

See Also

INexusLicenseApi Interface
Sitecore.Reflection Namespace


Reset Method

[image]

Sitecore 6.4.1 API
INexusLicenseApi..::..Reset Method
INexusLicenseApi Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void Reset()
Visual Basic
Sub Reset
Visual C++
void Reset()

See Also

INexusLicenseApi Interface
Sitecore.Reflection Namespace


VerifiedLicense Method

[image]

Sitecore 6.4.1 API
INexusLicenseApi..::..VerifiedLicense Method
INexusLicenseApi Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
XmlDocument VerifiedLicense()
Visual Basic
Function VerifiedLicense As XmlDocument
Visual C++
XmlDocument^ VerifiedLicense()

Return Value

An XmlDocument containing the verified license.

See Also

INexusLicenseApi Interface
Sitecore.Reflection Namespace


INexusLicenseApi Properties

[image] [image]

Sitecore 6.4.1 API
INexusLicenseApi Properties
INexusLicenseApi Interface See Also Send Feedback

The INexusLicenseApi type exposes the following members.

Properties

 | Name | Description
Public property | Address | Gets the company address.
Public property | CompanyNo | Gets the company number.
Public property | Expiration | Gets the license expiration date.
Public property | LastError | Gets the last error message.
Public property | LicenseAgreement | Gets the text of license agreement.
Public property | Licensee | Gets the name of the licensee.
Public property | LicenseID | Gets the license ID.
Public property | Purpose | Gets the purpose string.
Public property | Reseller | Gets the name of the reseller.
Public property | ResellerUrl | Gets the URL of the reseller.
Public property | Urls | Gets the company URLs.
Public property | Version | Gets the version.

See Also

INexusLicenseApi Interface
Sitecore.Reflection Namespace


Address Property

[image]

Sitecore 6.4.1 API
INexusLicenseApi..::..Address Property
INexusLicenseApi Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
string Address { get; }
Visual Basic
ReadOnly Property Address As String
    Get
Visual C++
property String^ Address {
    String^ get ();
}

Field Value

The company address.

Remarks

This information is provided when the license form is filled in.

See Also

INexusLicenseApi Interface
Sitecore.Reflection Namespace


CompanyNo Property

[image]

Sitecore 6.4.1 API
INexusLicenseApi..::..CompanyNo Property
INexusLicenseApi Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
string CompanyNo { get; }
Visual Basic
ReadOnly Property CompanyNo As String
    Get
Visual C++
property String^ CompanyNo {
    String^ get ();
}

Field Value

The company number.

Remarks

This information is provided when the license form is filled in.

See Also

INexusLicenseApi Interface
Sitecore.Reflection Namespace


Expiration Property

[image]

Sitecore 6.4.1 API
INexusLicenseApi..::..Expiration Property
INexusLicenseApi Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
string Expiration { get; }
Visual Basic
ReadOnly Property Expiration As String
    Get
Visual C++
property String^ Expiration {
    String^ get ();
}

Field Value

The license expiration date.

Remarks

The license is invalid when the expiration date has been exceeded.

See Also

INexusLicenseApi Interface
Sitecore.Reflection Namespace


LastError Property

[image]

Sitecore 6.4.1 API
INexusLicenseApi..::..LastError Property
INexusLicenseApi Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
string LastError { get; set; }
Visual Basic
Property LastError As String
    Get
    Set
Visual C++
property String^ LastError {
    String^ get ();
    void set (String^ value);
}

Field Value

The message of the last error.

See Also

INexusLicenseApi Interface
Sitecore.Reflection Namespace


LicenseAgreement Property

[image]

Sitecore 6.4.1 API
INexusLicenseApi..::..LicenseAgreement Property
INexusLicenseApi Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
string LicenseAgreement { get; }
Visual Basic
ReadOnly Property LicenseAgreement As String
    Get
Visual C++
property String^ LicenseAgreement {
    String^ get ();
}

Field Value

The license agreement text.

See Also

INexusLicenseApi Interface
Sitecore.Reflection Namespace


LicenseID Property

[image]

Sitecore 6.4.1 API
INexusLicenseApi..::..LicenseID Property
INexusLicenseApi Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
string LicenseID { get; }
Visual Basic
ReadOnly Property LicenseID As String
    Get
Visual C++
property String^ LicenseID {
    String^ get ();
}

Field Value

The ID of the license.

See Also

INexusLicenseApi Interface
Sitecore.Reflection Namespace


Purpose Property

[image]

Sitecore 6.4.1 API
INexusLicenseApi..::..Purpose Property
INexusLicenseApi Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
string Purpose { get; }
Visual Basic
ReadOnly Property Purpose As String
    Get
Visual C++
property String^ Purpose {
    String^ get ();
}

Field Value

The purpose.

Remarks

This information is provided when the license form is filled in.

See Also

INexusLicenseApi Interface
Sitecore.Reflection Namespace


Reseller Property

[image]

Sitecore 6.4.1 API
INexusLicenseApi..::..Reseller Property
INexusLicenseApi Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
string Reseller { get; }
Visual Basic
ReadOnly Property Reseller As String
    Get
Visual C++
property String^ Reseller {
    String^ get ();
}

Field Value

The name of the reseller.

Remarks

This information is provided when the license form is filled in.

See Also

INexusLicenseApi Interface
Sitecore.Reflection Namespace


ResellerUrl Property

[image]

Sitecore 6.4.1 API
INexusLicenseApi..::..ResellerUrl Property
INexusLicenseApi Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
string ResellerUrl { get; }
Visual Basic
ReadOnly Property ResellerUrl As String
    Get
Visual C++
property String^ ResellerUrl {
    String^ get ();
}

Field Value

The URL of the reseller.

Remarks

This information is provided when the license form is filled in.

See Also

INexusLicenseApi Interface
Sitecore.Reflection Namespace


Version Property

[image]

Sitecore 6.4.1 API
INexusLicenseApi..::..Version Property
INexusLicenseApi Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
string Version { get; }
Visual Basic
ReadOnly Property Version As String
    Get
Visual C++
property String^ Version {
    String^ get ();
}

Field Value

The version.

See Also

INexusLicenseApi Interface
Sitecore.Reflection Namespace


INexusPipelineApi Interface

[image]

Sitecore 6.4.1 API
INexusPipelineApi Interface
Members See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface INexusPipelineApi
Visual Basic
Public Interface INexusPipelineApi
Visual C++
public interface class INexusPipelineApi

See Also

INexusPipelineApi Members
Sitecore.Reflection Namespace


INexusPipelineApi Members

[image] [image]

Sitecore 6.4.1 API
INexusPipelineApi Members
INexusPipelineApi Interface Methods See Also Send Feedback

The INexusPipelineApi type exposes the following members.

Methods

 | Name | Description
Public method | Resume | Resumes the specified pipeline.

See Also

INexusPipelineApi Interface
Sitecore.Reflection Namespace


INexusPipelineApi Methods

[image] [image]

Sitecore 6.4.1 API
INexusPipelineApi Methods
INexusPipelineApi Interface See Also Send Feedback

The INexusPipelineApi type exposes the following members.

Methods

 | Name | Description
Public method | Resume | Resumes the specified pipeline.

See Also

INexusPipelineApi Interface
Sitecore.Reflection Namespace


Resume Method

[image]

Sitecore 6.4.1 API
INexusPipelineApi..::..Resume Method
INexusPipelineApi Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void Resume(
    PipelineArgs args,
    Pipeline pipeline
)
Visual Basic
Sub Resume ( _
    args As PipelineArgs, _
    pipeline As Pipeline _
)
Visual C++
void Resume(
    PipelineArgs^ args,
    Pipeline^ pipeline
)

Parameters

args
Type: Sitecore.Pipelines..::..PipelineArgs
The args.
pipeline
Type: Sitecore.Pipelines..::..Pipeline
The pipeline.

See Also

INexusPipelineApi Interface
Sitecore.Reflection Namespace


INexusPlaceholderApi Interface

[image]

Sitecore 6.4.1 API
INexusPlaceholderApi Interface
Members See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public interface INexusPlaceholderApi
Visual Basic
Public Interface INexusPlaceholderApi
Visual C++
public interface class INexusPlaceholderApi

See Also

INexusPlaceholderApi Members
Sitecore.Reflection Namespace


INexusPlaceholderApi Members

[image] [image]

Sitecore 6.4.1 API
INexusPlaceholderApi Members
INexusPlaceholderApi Interface Methods See Also Send Feedback

The INexusPlaceholderApi type exposes the following members.

Methods

 | Name | Description
Public method | CreateChildControls | Creates the child controls of a placeholder.

See Also

INexusPlaceholderApi Interface
Sitecore.Reflection Namespace


INexusPlaceholderApi Methods

[image] [image]

Sitecore 6.4.1 API
INexusPlaceholderApi Methods
INexusPlaceholderApi Interface See Also Send Feedback

The INexusPlaceholderApi type exposes the following members.

Methods

 | Name | Description
Public method | CreateChildControls | Creates the child controls of a placeholder.

See Also

INexusPlaceholderApi Interface
Sitecore.Reflection Namespace


CreateChildControls Method

[image]

Sitecore 6.4.1 API
INexusPlaceholderApi..::..CreateChildControls Method
INexusPlaceholderApi Interface See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
void CreateChildControls(
    Placeholder placeholder
)
Visual Basic
Sub CreateChildControls ( _
    placeholder As Placeholder _
)
Visual C++
void CreateChildControls(
    Placeholder^ placeholder
)

Parameters

placeholder
Type: Sitecore.Web.UI.WebControls..::..Placeholder
The placeholder.

See Also

INexusPlaceholderApi Interface
Sitecore.Reflection Namespace


MethodInstance Class

[image]

Sitecore 6.4.1 API
MethodInstance Class
Members See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class MethodInstance
Visual Basic
Public Class MethodInstance
Visual C++
public ref class MethodInstance

Inheritance Hierarchy

System..::..Object
Sitecore.Reflection..::..MethodInstance

See Also

MethodInstance Members
Sitecore.Reflection Namespace


MethodInstance Members

[image] [image]

Sitecore 6.4.1 API
MethodInstance Members
MethodInstance Class Constructors Methods Properties See Also Send Feedback

The MethodInstance type exposes the following members.

Constructors

 | Name | Description
Public method | MethodInstance | Initializes a new instance of the MethodInstance class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Invokes this instance.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Method | Gets the method.
Public property | Object | Gets the object.
Public property | Parameters | Gets the parameters.

See Also

MethodInstance Class
Sitecore.Reflection Namespace


MethodInstance Constructor

[image]

Sitecore 6.4.1 API
MethodInstance Constructor
MethodInstance Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MethodInstance(
    Object obj,
    string methodName,
    Object[] parameters
)
Visual Basic
Public Sub New ( _
    obj As Object, _
    methodName As String, _
    parameters As Object() _
)
Visual C++
public:
MethodInstance(
    Object^ obj,
    String^ methodName,
    array<Object^>^ parameters
)

Parameters

obj
Type: System..::..Object
The object.
methodName
Type: System..::..String
Name of the method.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.

See Also

MethodInstance Class
Sitecore.Reflection Namespace


MethodInstance Methods

[image] [image]

Sitecore 6.4.1 API
MethodInstance Methods
MethodInstance Class See Also Send Feedback

The MethodInstance type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Invokes this instance.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MethodInstance Class
Sitecore.Reflection Namespace


Invoke Method

[image]

Sitecore 6.4.1 API
MethodInstance..::..Invoke Method
MethodInstance Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object Invoke()
Visual Basic
Public Function Invoke As Object
Visual C++
public:
Object^ Invoke()

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.MethodInstance.Invoke"]

See Also

MethodInstance Class
Sitecore.Reflection Namespace


MethodInstance Properties

[image] [image]

Sitecore 6.4.1 API
MethodInstance Properties
MethodInstance Class See Also Send Feedback

The MethodInstance type exposes the following members.

Properties

 | Name | Description
Public property | Method | Gets the method.
Public property | Object | Gets the object.
Public property | Parameters | Gets the parameters.

See Also

MethodInstance Class
Sitecore.Reflection Namespace


Method Property

[image]

Sitecore 6.4.1 API
MethodInstance..::..Method Property
MethodInstance Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MethodInfo Method { get; }
Visual Basic
Public ReadOnly Property Method As MethodInfo
    Get
Visual C++
public:
property MethodInfo^ Method {
    MethodInfo^ get ();
}

Field Value

The method.

See Also

MethodInstance Class
Sitecore.Reflection Namespace


Parameters Property

[image]

Sitecore 6.4.1 API
MethodInstance..::..Parameters Property
MethodInstance Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object[] Parameters { get; }
Visual Basic
Public ReadOnly Property Parameters As Object()
    Get
Visual C++
public:
property array<Object^>^ Parameters {
    array<Object^>^ get ();
}

Field Value

The parameters.

See Also

MethodInstance Class
Sitecore.Reflection Namespace


Nexus Class

[image]

Sitecore 6.4.1 API
Nexus Class
Members See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Nexus
Visual Basic
Public NotInheritable Class Nexus
Visual C++
public ref class Nexus abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Reflection..::..Nexus

See Also

Nexus Members
Sitecore.Reflection Namespace


Nexus Members

[image] [image]

Sitecore 6.4.1 API
Nexus Members
Nexus Class Properties See Also Send Feedback

The Nexus type exposes the following members.

Properties

Name | Description
DataApi | Gets the data API.
LicenseApi | Gets the license API.
PipelineApi | Gets the pipeline API.
PlaceholderApi | Gets the placeholder API.

See Also

Nexus Class
Sitecore.Reflection Namespace


Nexus Properties

[image] [image]

Sitecore 6.4.1 API
Nexus Properties
Nexus Class See Also Send Feedback

The Nexus type exposes the following members.

Properties

Name | Description
DataApi | Gets the data API.
LicenseApi | Gets the license API.
PipelineApi | Gets the pipeline API.
PlaceholderApi | Gets the placeholder API.

See Also

Nexus Class
Sitecore.Reflection Namespace


DataApi Property

[image]

Sitecore 6.4.1 API
Nexus..::..DataApi Property
Nexus Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static INexusDataApi DataApi { get; }
Visual Basic
Public Shared ReadOnly Property DataApi As INexusDataApi
    Get
Visual C++
public:
static property INexusDataApi^ DataApi {
    INexusDataApi^ get ();
}

Field Value

The data API.

See Also

Nexus Class
Sitecore.Reflection Namespace


LicenseApi Property

[image]

Sitecore 6.4.1 API
Nexus..::..LicenseApi Property
Nexus Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static INexusLicenseApi LicenseApi { get; }
Visual Basic
Public Shared ReadOnly Property LicenseApi As INexusLicenseApi
    Get
Visual C++
public:
static property INexusLicenseApi^ LicenseApi {
    INexusLicenseApi^ get ();
}

Field Value

The license API.

See Also

Nexus Class
Sitecore.Reflection Namespace


PipelineApi Property

[image]

Sitecore 6.4.1 API
Nexus..::..PipelineApi Property
Nexus Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static INexusPipelineApi PipelineApi { get; }
Visual Basic
Public Shared ReadOnly Property PipelineApi As INexusPipelineApi
    Get
Visual C++
public:
static property INexusPipelineApi^ PipelineApi {
    INexusPipelineApi^ get ();
}

Field Value

The pipeline API.

See Also

Nexus Class
Sitecore.Reflection Namespace


PlaceholderApi Property

[image]

Sitecore 6.4.1 API
Nexus..::..PlaceholderApi Property
Nexus Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static INexusPlaceholderApi PlaceholderApi { get; }
Visual Basic
Public Shared ReadOnly Property PlaceholderApi As INexusPlaceholderApi
    Get
Visual C++
public:
static property INexusPlaceholderApi^ PlaceholderApi {
    INexusPlaceholderApi^ get ();
}

Field Value

The placeholder API.

See Also

Nexus Class
Sitecore.Reflection Namespace


NexusHelper Class

[image]

Sitecore 6.4.1 API
NexusHelper Class
Members See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class NexusHelper
Visual Basic
Public NotInheritable Class NexusHelper
Visual C++
public ref class NexusHelper abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Reflection..::..NexusHelper

See Also

NexusHelper Members
Sitecore.Reflection Namespace


NexusHelper Members

[image] [image]

Sitecore 6.4.1 API
NexusHelper Members
NexusHelper Class Methods See Also Send Feedback

The NexusHelper type exposes the following members.

Methods

Name | Description
GetInvoker | Gets the invoker.

See Also

NexusHelper Class
Sitecore.Reflection Namespace


NexusHelper Methods

[image] [image]

Sitecore 6.4.1 API
NexusHelper Methods
NexusHelper Class See Also Send Feedback

The NexusHelper type exposes the following members.

Methods

Name | Description
GetInvoker | Gets the invoker.

See Also

NexusHelper Class
Sitecore.Reflection Namespace


GetInvoker Method

[image]

Sitecore 6.4.1 API
NexusHelper..::..GetInvoker Method
NexusHelper Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static FastInvoker GetInvoker(
    string typeName,
    string methodName,
    bool isStatic
)
Visual Basic
Public Shared Function GetInvoker ( _
    typeName As String, _
    methodName As String, _
    isStatic As Boolean _
) As FastInvoker
Visual C++
public:
static FastInvoker^ GetInvoker(
    String^ typeName,
    String^ methodName,
    bool isStatic
)

Parameters

typeName
Type: System..::..String
Name of the type.
methodName
Type: System..::..String
Name of the method.
isStatic
Type: System..::..Boolean
If set to true, the method is static.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.NexusHelper.GetInvoker(System.String,System.String,System.Boolean)"]

See Also

NexusHelper Class
Sitecore.Reflection Namespace


PropertyTarget Class

[image]

Sitecore 6.4.1 API
PropertyTarget Class
Members See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class PropertyTarget
Visual Basic
Public Class PropertyTarget
Visual C++
public ref class PropertyTarget

Inheritance Hierarchy

System..::..Object
Sitecore.Reflection..::..PropertyTarget

See Also

PropertyTarget Members
Sitecore.Reflection Namespace


PropertyTarget Members

[image] [image]

Sitecore 6.4.1 API
PropertyTarget Members
PropertyTarget Class Constructors Methods Properties See Also Send Feedback

The PropertyTarget type exposes the following members.

Constructors

 | Name | Description
Public method | PropertyTarget | Initializes a new instance of the PropertyTarget class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Object | Gets the object.
Public property | PropertyInfo | Gets the property info.

See Also

PropertyTarget Class
Sitecore.Reflection Namespace


PropertyTarget Constructor

[image]

Sitecore 6.4.1 API
PropertyTarget Constructor
PropertyTarget Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public PropertyTarget(
    Object obj,
    PropertyInfo info
)
Visual Basic
Public Sub New ( _
    obj As Object, _
    info As PropertyInfo _
)
Visual C++
public:
PropertyTarget(
    Object^ obj,
    PropertyInfo^ info
)

Parameters

obj
Type: System..::..Object
The object.
info
Type: System.Reflection..::..PropertyInfo
The info.

See Also

PropertyTarget Class
Sitecore.Reflection Namespace


PropertyTarget Methods

[image] [image]

Sitecore 6.4.1 API
PropertyTarget Methods
PropertyTarget Class See Also Send Feedback

The PropertyTarget type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PropertyTarget Class
Sitecore.Reflection Namespace


PropertyTarget Properties

[image] [image]

Sitecore 6.4.1 API
PropertyTarget Properties
PropertyTarget Class See Also Send Feedback

The PropertyTarget type exposes the following members.

Properties

 | Name | Description
Public property | Object | Gets the object.
Public property | PropertyInfo | Gets the property info.

See Also

PropertyTarget Class
Sitecore.Reflection Namespace


Object Property

[image]

Sitecore 6.4.1 API
PropertyTarget..::..Object Property
PropertyTarget Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Object Object { get; }
Visual Basic
Public ReadOnly Property Object As Object
    Get
Visual C++
public:
property Object^ Object {
    Object^ get ();
}

Field Value

The object.

See Also

PropertyTarget Class
Sitecore.Reflection Namespace


ReflectionUtil Class

[image]

Sitecore 6.4.1 API
ReflectionUtil Class
Members See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class ReflectionUtil
Visual Basic
Public NotInheritable Class ReflectionUtil
Visual C++
public ref class ReflectionUtil abstract sealed

Remarks

Inheritance Hierarchy

System..::..Object
Sitecore.Reflection..::..ReflectionUtil

See Also

ReflectionUtil Members
Sitecore.Reflection Namespace
Sitecore..::..DateUtil
Sitecore.IO..::..FileUtil
Sitecore..::..MainUtil
Sitecore..::..StringUtil
Sitecore.Xml..::..XmlUtil


ReflectionUtil Members

[image] [image]

Sitecore 6.4.1 API
ReflectionUtil Members
ReflectionUtil Class Methods See Also Send Feedback

The ReflectionUtil type exposes the following members.

Methods

Name | Description
CallMethod(Object, String) | Calls a method on an object.
CallMethod(Type, String) | Calls a method on a type.
CallMethod(Object, String, array<Object>[]()[][]) | Calls a method on an object.
CallMethod(Object, String, Boolean, Boolean) | Calls a method on an object.
CallMethod(Object, String, Boolean, Boolean, array<Object>[]()[][]) | Calls a method on an object.
CallMethod(Object, String, Boolean, Boolean, Boolean, array<Object>[]()[][]) | Calls a method on an object.
CallMethod(Type, Object, String, Boolean, Boolean, array<Object>[]()[][]) | Calls a method on an object.
CallMethod(Type, Object, String, Boolean, Boolean, Boolean, array<Object>[]()[][]) | Calls a method on an object.
CallStaticMethod | Calls a method on an object.
CreateEventHandler(Object, String) | Creates the event handler.
CreateEventHandler(Type, String) | Creates the event handler.
CreateObject(String) | Creates an instance of an object from a web.config setting.
CreateObject(Type) | Creates an instance of an object.
CreateObject(XmlNode) | Creates an instance of an object from a web.config setting.
CreateObject(String, array<Object>[]()[][]) | Creates an instance of an object.
CreateObject(Type, array<Object>[]()[][]) | Creates an instance of an object.
CreateObject(String, String, array<Object>[]()[][]) | Creates an instance of an object.
CreateObjectFromConfig(String) | Creates an instance of an object from a web.config setting.
CreateObjectFromConfig(String, array<Object>[]()[][]) | Creates an instance of an object from a web.config setting.
CreateObjectFromConfig(String, String, array<Object>[]()[][]) | Creates an instance of an object from a web.config setting.
GetAttribute | Gets the attribute.
GetConstructorInfo | Gets the constructor info.
GetField(Object, String) | Gets a field on an object.
GetField(Object, String, Object) | Gets a field on an object.
GetMethod(Object, String, array<Object>[]()[][]) | Gets a method on an object.
GetMethod(Object, String, Boolean, Boolean, array<Object>[]()[][]) | Gets a method on an object.
GetMethod(Type, String, Boolean, Boolean, array<Object>[]()[][]) | Gets a method on an object.
GetMethod(Type, String, Boolean, Boolean, Boolean, array<Object>[]()[][]) | Gets a method on an object.
GetMethod(Type, String, Boolean, Boolean, Boolean, array<Type>[]()[][]) | Gets a method on an object.
GetMethodInvoker | Gets a fast method invoker.
GetProperty(Object, String) | Gets a property on an object.
GetProperty(Object, String, Object) | Gets a property on an object.
GetPropertyInfo | Gets property info on an object.
GetTypeInfo(String) | Gets type information for a class.
GetTypeInfo(String, String) | Gets type information for a class.
GetTypes | Gets the types.
GetTypeString | Gets the type string.
HasAttribute(Object, Type) | Determines whether the specified object has attribute.
HasAttribute(MethodInfo, Type) | Determines whether the specified method has attribute.
InvokeMethod | Invokes a method on an object.
LoadAssembly | Loads an assembly from disk.
ParseEnum<(Of <<'(T>)>>) | Parses an enum type from a string.
SetField | Sets a field on an object.
SetProperties(Object, String) | Sets properties on an object from a list of parameters on the form: p1=value1&p2=value2&...
SetProperties(Object, String, Boolean) | Sets properties on an object from a list of parameters on the form: p1=value1&p2=value2&...
SetPropertiesFromConfig | Sets the properties from config.
SetProperty(Object, PropertyInfo, Object) | Sets a property on an object.
SetProperty(Object, String, Object) | Sets a property on an object.
SetStaticField | Sets the static field.

See Also

ReflectionUtil Class
Sitecore.Reflection Namespace


ReflectionUtil Methods

[image] [image]

Sitecore 6.4.1 API
ReflectionUtil Methods
ReflectionUtil Class See Also Send Feedback

The ReflectionUtil type exposes the following members.

Methods

Name | Description
CallMethod(Object, String) | Calls a method on an object.
CallMethod(Type, String) | Calls a method on a type.
CallMethod(Object, String, array<Object>[]()[][]) | Calls a method on an object.
CallMethod(Object, String, Boolean, Boolean) | Calls a method on an object.
CallMethod(Object, String, Boolean, Boolean, array<Object>[]()[][]) | Calls a method on an object.
CallMethod(Object, String, Boolean, Boolean, Boolean, array<Object>[]()[][]) | Calls a method on an object.
CallMethod(Type, Object, String, Boolean, Boolean, array<Object>[]()[][]) | Calls a method on an object.
CallMethod(Type, Object, String, Boolean, Boolean, Boolean, array<Object>[]()[][]) | Calls a method on an object.
CallStaticMethod | Calls a method on an object.
CreateEventHandler(Object, String) | Creates the event handler.
CreateEventHandler(Type, String) | Creates the event handler.
CreateObject(String) | Creates an instance of an object from a web.config setting.
CreateObject(Type) | Creates an instance of an object.
CreateObject(XmlNode) | Creates an instance of an object from a web.config setting.
CreateObject(String, array<Object>[]()[][]) | Creates an instance of an object.
CreateObject(Type, array<Object>[]()[][]) | Creates an instance of an object.
CreateObject(String, String, array<Object>[]()[][]) | Creates an instance of an object.
CreateObjectFromConfig(String) | Creates an instance of an object from a web.config setting.
CreateObjectFromConfig(String, array<Object>[]()[][]) | Creates an instance of an object from a web.config setting.
CreateObjectFromConfig(String, String, array<Object>[]()[][]) | Creates an instance of an object from a web.config setting.
GetAttribute | Gets the attribute.
GetConstructorInfo | Gets the constructor info.
GetField(Object, String) | Gets a field on an object.
GetField(Object, String, Object) | Gets a field on an object.
GetMethod(Object, String, array<Object>[]()[][]) | Gets a method on an object.
GetMethod(Object, String, Boolean, Boolean, array<Object>[]()[][]) | Gets a method on an object.
GetMethod(Type, String, Boolean, Boolean, array<Object>[]()[][]) | Gets a method on an object.
GetMethod(Type, String, Boolean, Boolean, Boolean, array<Object>[]()[][]) | Gets a method on an object.
GetMethod(Type, String, Boolean, Boolean, Boolean, array<Type>[]()[][]) | Gets a method on an object.
GetMethodInvoker | Gets a fast method invoker.
GetProperty(Object, String) | Gets a property on an object.
GetProperty(Object, String, Object) | Gets a property on an object.
GetPropertyInfo | Gets property info on an object.
GetTypeInfo(String) | Gets type information for a class.
GetTypeInfo(String, String) | Gets type information for a class.
GetTypes | Gets the types.
GetTypeString | Gets the type string.
HasAttribute(Object, Type) | Determines whether the specified object has attribute.
HasAttribute(MethodInfo, Type) | Determines whether the specified method has attribute.
InvokeMethod | Invokes a method on an object.
LoadAssembly | Loads an assembly from disk.
ParseEnum<(Of <<'(T>)>>) | Parses an enum type from a string.
SetField | Sets a field on an object.
SetProperties(Object, String) | Sets properties on an object from a list of parameters on the form: p1=value1&p2=value2&...
SetProperties(Object, String, Boolean) | Sets properties on an object from a list of parameters on the form: p1=value1&p2=value2&...
SetPropertiesFromConfig | Sets the properties from config.
SetProperty(Object, PropertyInfo, Object) | Sets a property on an object.
SetProperty(Object, String, Object) | Sets a property on an object.
SetStaticField | Sets the static field.

See Also

ReflectionUtil Class
Sitecore.Reflection Namespace


CallMethod Method (Object, String)

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..CallMethod Method (Object, String)
ReflectionUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object CallMethod(
    Object obj,
    string methodName
)
Visual Basic
Public Shared Function CallMethod ( _
    obj As Object, _
    methodName As String _
) As Object
Visual C++
public:
static Object^ CallMethod(
    Object^ obj,
    String^ methodName
)

Parameters

obj
Type: System..::..Object
The object.
methodName
Type: System..::..String
Name of the method.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.ReflectionUtil.CallMethod(System.Object,System.String)"]

See Also

ReflectionUtil Class
CallMethod Overload
Sitecore.Reflection Namespace


CallMethod Method (Type, String)

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..CallMethod Method (Type, String)
ReflectionUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object CallMethod(
    Type type,
    string methodName
)
Visual Basic
Public Shared Function CallMethod ( _
    type As Type, _
    methodName As String _
) As Object
Visual C++
public:
static Object^ CallMethod(
    Type^ type,
    String^ methodName
)

Parameters

type
Type: System..::..Type
The type.
methodName
Type: System..::..String
Name of the method.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.ReflectionUtil.CallMethod(System.Type,System.String)"]

See Also

ReflectionUtil Class
CallMethod Overload
Sitecore.Reflection Namespace


CallMethod Method (Object, String, Object[])

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..CallMethod Method (Object, String, array<Object>[]()[][])
ReflectionUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object CallMethod(
    Object obj,
    string methodName,
    Object[] parameters
)
Visual Basic
Public Shared Function CallMethod ( _
    obj As Object, _
    methodName As String, _
    parameters As Object() _
) As Object
Visual C++
public:
static Object^ CallMethod(
    Object^ obj,
    String^ methodName,
    array<Object^>^ parameters
)

Parameters

obj
Type: System..::..Object
The object.
methodName
Type: System..::..String
Name of the method.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.ReflectionUtil.CallMethod(System.Object,System.String,System.Object[])"]

See Also

ReflectionUtil Class
CallMethod Overload
Sitecore.Reflection Namespace


CallMethod Method (Object, String, Boolean, Boolean)

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..CallMethod Method (Object, String, Boolean, Boolean)
ReflectionUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object CallMethod(
    Object obj,
    string methodName,
    bool includeNonPublic,
    bool includeInherited
)
Visual Basic
Public Shared Function CallMethod ( _
    obj As Object, _
    methodName As String, _
    includeNonPublic As Boolean, _
    includeInherited As Boolean _
) As Object
Visual C++
public:
static Object^ CallMethod(
    Object^ obj,
    String^ methodName,
    bool includeNonPublic,
    bool includeInherited
)

Parameters

obj
Type: System..::..Object
The object.
methodName
Type: System..::..String
Name of the method.
includeNonPublic
Type: System..::..Boolean
if set to true this instance is include non public.
includeInherited
Type: System..::..Boolean
if set to true this instance is include inherited.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.ReflectionUtil.CallMethod(System.Object,System.String,System.Boolean,System.Boolean)"]

See Also

ReflectionUtil Class
CallMethod Overload
Sitecore.Reflection Namespace


CallMethod Method (Object, String, Boolean, Boolean, Object[])

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..CallMethod Method (Object, String, Boolean, Boolean, array<Object>[]()[][])
ReflectionUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object CallMethod(
    Object obj,
    string methodName,
    bool includeNonPublic,
    bool includeInherited,
    Object[] parameters
)
Visual Basic
Public Shared Function CallMethod ( _
    obj As Object, _
    methodName As String, _
    includeNonPublic As Boolean, _
    includeInherited As Boolean, _
    parameters As Object() _
) As Object
Visual C++
public:
static Object^ CallMethod(
    Object^ obj,
    String^ methodName,
    bool includeNonPublic,
    bool includeInherited,
    array<Object^>^ parameters
)

Parameters

obj
Type: System..::..Object
The object.
methodName
Type: System..::..String
Name of the method.
includeNonPublic
Type: System..::..Boolean
if set to true this instance is include non public.
includeInherited
Type: System..::..Boolean
if set to true this instance is include inherited.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.ReflectionUtil.CallMethod(System.Object,System.String,System.Boolean,System.Boolean,System.Object[])"]

See Also

ReflectionUtil Class
CallMethod Overload
Sitecore.Reflection Namespace


CallMethod Method (Type, Object, String, Boolean, Boolean, Object[])

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..CallMethod Method (Type, Object, String, Boolean, Boolean, array<Object>[]()[][])
ReflectionUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object CallMethod(
    Type type,
    Object obj,
    string methodName,
    bool includeNonPublic,
    bool includeInherited,
    Object[] parameters
)
Visual Basic
Public Shared Function CallMethod ( _
    type As Type, _
    obj As Object, _
    methodName As String, _
    includeNonPublic As Boolean, _
    includeInherited As Boolean, _
    parameters As Object() _
) As Object
Visual C++
public:
static Object^ CallMethod(
    Type^ type,
    Object^ obj,
    String^ methodName,
    bool includeNonPublic,
    bool includeInherited,
    array<Object^>^ parameters
)

Parameters

type
Type: System..::..Type
The type.
obj
Type: System..::..Object
The object.
methodName
Type: System..::..String
Name of the method.
includeNonPublic
Type: System..::..Boolean
if set to true this instance is include non public.
includeInherited
Type: System..::..Boolean
if set to true this instance is include inherited.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.ReflectionUtil.CallMethod(System.Type,System.Object,System.String,System.Boolean,System.Boolean,System.Object[])"]

See Also

ReflectionUtil Class
CallMethod Overload
Sitecore.Reflection Namespace


CallMethod Method (Type, Object, String, Boolean, Boolean, Boolean, Object[])

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..CallMethod Method (Type, Object, String, Boolean, Boolean, Boolean, array<Object>[]()[][])
ReflectionUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object CallMethod(
    Type type,
    Object obj,
    string methodName,
    bool includeNonPublic,
    bool includeInherited,
    bool includeStatic,
    Object[] parameters
)
Visual Basic
Public Shared Function CallMethod ( _
    type As Type, _
    obj As Object, _
    methodName As String, _
    includeNonPublic As Boolean, _
    includeInherited As Boolean, _
    includeStatic As Boolean, _
    parameters As Object() _
) As Object
Visual C++
public:
static Object^ CallMethod(
    Type^ type,
    Object^ obj,
    String^ methodName,
    bool includeNonPublic,
    bool includeInherited,
    bool includeStatic,
    array<Object^>^ parameters
)

Parameters

type
Type: System..::..Type
The type.
obj
Type: System..::..Object
The object.
methodName
Type: System..::..String
Name of the method.
includeNonPublic
Type: System..::..Boolean
if set to true this instance is include non public.
includeInherited
Type: System..::..Boolean
if set to true this instance is include inherited.
includeStatic
Type: System..::..Boolean
if set to true this instance is include static.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.ReflectionUtil.CallMethod(System.Type,System.Object,System.String,System.Boolean,System.Boolean,System.Boolean,System.Object[])"]

See Also

ReflectionUtil Class
CallMethod Overload
Sitecore.Reflection Namespace


CallStaticMethod Method

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..CallStaticMethod Method
ReflectionUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object CallStaticMethod(
    string typeName,
    string methodName,
    Object[] parameters
)
Visual Basic
Public Shared Function CallStaticMethod ( _
    typeName As String, _
    methodName As String, _
    parameters As Object() _
) As Object
Visual C++
public:
static Object^ CallStaticMethod(
    String^ typeName,
    String^ methodName,
    array<Object^>^ parameters
)

Parameters

typeName
Type: System..::..String
Name of the type.
methodName
Type: System..::..String
Name of the method.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.ReflectionUtil.CallStaticMethod(System.String,System.String,System.Object[])"]

See Also

ReflectionUtil Class
Sitecore.Reflection Namespace


CreateEventHandler Method

[image] [image]

Sitecore 6.4.1 API
ReflectionUtil..::..CreateEventHandler Method
ReflectionUtil Class See Also Send Feedback

Overload List

Name | Description
CreateEventHandler(Object, String) | Creates the event handler.
CreateEventHandler(Type, String) | Creates the event handler.

See Also

ReflectionUtil Class
ReflectionUtil Members
Sitecore.Reflection Namespace


CreateEventHandler Method (Object, String)

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..CreateEventHandler Method (Object, String)
ReflectionUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static EventHandler CreateEventHandler(
    Object obj,
    string method
)
Visual Basic
Public Shared Function CreateEventHandler ( _
    obj As Object, _
    method As String _
) As EventHandler
Visual C++
public:
static EventHandler^ CreateEventHandler(
    Object^ obj,
    String^ method
)

Parameters

obj
Type: System..::..Object
The object.
method
Type: System..::..String
The method.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.ReflectionUtil.CreateEventHandler(System.Object,System.String)"]

See Also

ReflectionUtil Class
CreateEventHandler Overload
Sitecore.Reflection Namespace


CreateEventHandler Method (Type, String)

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..CreateEventHandler Method (Type, String)
ReflectionUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static EventHandler CreateEventHandler(
    Type type,
    string method
)
Visual Basic
Public Shared Function CreateEventHandler ( _
    type As Type, _
    method As String _
) As EventHandler
Visual C++
public:
static EventHandler^ CreateEventHandler(
    Type^ type,
    String^ method
)

Parameters

type
Type: System..::..Type
The type.
method
Type: System..::..String
The method.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.ReflectionUtil.CreateEventHandler(System.Type,System.String)"]

See Also

ReflectionUtil Class
CreateEventHandler Overload
Sitecore.Reflection Namespace


CreateObject Method (String)

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..CreateObject Method (String)
ReflectionUtil Class Example See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object CreateObject(
    string name
)
Visual Basic
Public Shared Function CreateObject ( _
    name As String _
) As Object
Visual C++
public:
static Object^ CreateObject(
    String^ name
)

Parameters

name
Type: System..::..String
Name setting in the web.config.

Return Value

The instantiated object or null if the object could not be instantiated.

Remarks

The assembly name is expanded to a qualified path by:

  • prepending "/bin/", if the filename does not contain any folder information.
  • appending ".dll", if the filename does not end with ".dll".

If the object could not be instantiated, an error message is written to the log file (usually located in the data folder).

Examples

CopyC#
object MyObject = MainUtil.CreateObject("ShellAPI");

See Also

ReflectionUtil Class
CreateObject Overload
Sitecore.Reflection Namespace


CreateObject Method (Type)

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..CreateObject Method (Type)
ReflectionUtil Class Example See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object CreateObject(
    Type type
)
Visual Basic
Public Shared Function CreateObject ( _
    type As Type _
) As Object
Visual C++
public:
static Object^ CreateObject(
    Type^ type
)

Parameters

type
Type: System..::..Type
Name of both assembly and class of the object.

Return Value

The instantiated object or null if the object could not be instantiated.

Remarks

If the object could not be instantiated, an error message is written to the log file (usually located in the data folder).

Examples

CopyC#
object MyObject = ReflectionUtil.CreateObject(myType);

See Also

ReflectionUtil Class
CreateObject Overload
Sitecore.Reflection Namespace


CreateObject Method (String, Object[])

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..CreateObject Method (String, array<Object>[]()[][])
ReflectionUtil Class Example See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object CreateObject(
    string typeName,
    Object[] parameters
)
Visual Basic
Public Shared Function CreateObject ( _
    typeName As String, _
    parameters As Object() _
) As Object
Visual C++
public:
static Object^ CreateObject(
    String^ typeName,
    array<Object^>^ parameters
)

Parameters

typeName
Type: System..::..String
Name of type.
parameters
Type: array< System..::..Object >[]()[][]
Parameters.

Return Value

The instantiated object or null if the object could not be instantiated.

Remarks

The assembly name is expanded to a qualified path by:

  • prepending "/bin/", if the filename does not contain any folder information.
  • appending ".dll", if the filename does not end with ".dll".

If the object could not be instantiated, an error message is written to the log file (usually located in the data folder).

Examples

CopyC#
object MyObject = ReflectionUtil.CreateObject("/bin/MyAssembly.dll", "MyNamespace.MyObject");
object MyObject2 = ReflectionUtil.CreateObject("MyAssembly", "MyNamespace.MyObject2", parameter1, parameter2);

See Also

ReflectionUtil Class
CreateObject Overload
Sitecore.Reflection Namespace


CreateObject Method (Type, Object[])

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..CreateObject Method (Type, array<Object>[]()[][])
ReflectionUtil Class Example See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object CreateObject(
    Type type,
    Object[] parameters
)
Visual Basic
Public Shared Function CreateObject ( _
    type As Type, _
    parameters As Object() _
) As Object
Visual C++
public:
static Object^ CreateObject(
    Type^ type,
    array<Object^>^ parameters
)

Parameters

type
Type: System..::..Type
Name of both assembly and class of the object.
parameters
Type: array< System..::..Object >[]()[][]
Parameters.

Return Value

The instantiated object or null if the object could not be instantiated.

Remarks

If the object could not be instantiated, an error message is written to the log file (usually located in the data folder).

Examples

CopyC#
object MyObject = ReflectionUtil.CreateObject("MyAssembly.MyObject", parameter1, parameter2);

See Also

ReflectionUtil Class
CreateObject Overload
Sitecore.Reflection Namespace


CreateObject Method (String, String, Object[])

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..CreateObject Method (String, String, array<Object>[]()[][])
ReflectionUtil Class Example See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object CreateObject(
    string assembly,
    string className,
    Object[] parameters
)
Visual Basic
Public Shared Function CreateObject ( _
    assembly As String, _
    className As String, _
    parameters As Object() _
) As Object
Visual C++
public:
static Object^ CreateObject(
    String^ assembly,
    String^ className,
    array<Object^>^ parameters
)

Parameters

assembly
Type: System..::..String
An assembly file name.
className
Type: System..::..String
A class name.
parameters
Type: array< System..::..Object >[]()[][]
Parameters.

Return Value

The instantiated object or null if the object could not be instantiated.

Remarks

The assembly name is expanded to a qualified path by:

  • prepending "/bin/", if the filename does not contain any folder information.
  • appending ".dll", if the filename does not end with ".dll".

If the object could not be instantiated, an error message is written to the log file (usually located in the data folder).

Examples

CopyC#
object MyObject = ReflectionUtil.CreateObject("/bin/MyAssembly.dll", "MyNamespace.MyObject");
object MyObject2 = ReflectionUtil.CreateObject("MyAssembly", "MyNamespace.MyObject2", parameter1, parameter2);

See Also

ReflectionUtil Class
CreateObject Overload
Sitecore.Reflection Namespace


CreateObjectFromConfig Method

[image] [image]

Sitecore 6.4.1 API
ReflectionUtil..::..CreateObjectFromConfig Method
ReflectionUtil Class See Also Send Feedback

Overload List

Name | Description
CreateObjectFromConfig(String) | Creates an instance of an object from a web.config setting.
CreateObjectFromConfig(String, array<Object>[]()[][]) | Creates an instance of an object from a web.config setting.
CreateObjectFromConfig(String, String, array<Object>[]()[][]) | Creates an instance of an object from a web.config setting.

See Also

ReflectionUtil Class
ReflectionUtil Members
Sitecore.Reflection Namespace


CreateObjectFromConfig Method (String)

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..CreateObjectFromConfig Method (String)
ReflectionUtil Class Example See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object CreateObjectFromConfig(
    string configPath
)
Visual Basic
Public Shared Function CreateObjectFromConfig ( _
    configPath As String _
) As Object
Visual C++
public:
static Object^ CreateObjectFromConfig(
    String^ configPath
)

Parameters

configPath
Type: System..::..String
Path to node in web.config (relative to the sitecore section).

Return Value

The instantiated object or null if the object could not be instantiated.

Remarks

The assembly name is expanded to a qualified path by:

  • prepending "/bin/", if the filename does not contain any folder information.
  • appending ".dll", if the filename does not end with ".dll".

If the object could not be instantiated, an error message is written to the log file (usually located in the data folder).

Examples

CopyC#
object obj = ReflectionUtil.CreateObjectFromConfig("workflow/managers/simple");

See Also

ReflectionUtil Class
CreateObjectFromConfig Overload
Sitecore.Reflection Namespace


CreateObjectFromConfig Method (String, Object[])

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..CreateObjectFromConfig Method (String, array<Object>[]()[][])
ReflectionUtil Class Example See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object CreateObjectFromConfig(
    string configPath,
    Object[] parameters
)
Visual Basic
Public Shared Function CreateObjectFromConfig ( _
    configPath As String, _
    parameters As Object() _
) As Object
Visual C++
public:
static Object^ CreateObjectFromConfig(
    String^ configPath,
    array<Object^>^ parameters
)

Parameters

configPath
Type: System..::..String
Path to node in web.config (relative to the sitecore section).
parameters
Type: array< System..::..Object >[]()[][]
The parameters.

Return Value

The instantiated object or null if the object could not be instantiated.

Remarks

The assembly name is expanded to a qualified path by:

  • prepending "/bin/", if the filename does not contain any folder information.
  • appending ".dll", if the filename does not end with ".dll".

If the object could not be instantiated, an error message is written to the log file (usually located in the data folder).

Examples

CopyC#
object obj = ReflectionUtil.CreateObjectFromConfig("workflow/managers/simple");

See Also

ReflectionUtil Class
CreateObjectFromConfig Overload
Sitecore.Reflection Namespace


CreateObjectFromConfig Method (String, String, Object[])

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..CreateObjectFromConfig Method (String, String, array<Object>[]()[][])
ReflectionUtil Class Example See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object CreateObjectFromConfig(
    string configPath,
    string typeAttribute,
    Object[] parameters
)
Visual Basic
Public Shared Function CreateObjectFromConfig ( _
    configPath As String, _
    typeAttribute As String, _
    parameters As Object() _
) As Object
Visual C++
public:
static Object^ CreateObjectFromConfig(
    String^ configPath,
    String^ typeAttribute,
    array<Object^>^ parameters
)

Parameters

configPath
Type: System..::..String
Path to node in web.config (relative to the sitecore section).
typeAttribute
Type: System..::..String
Name of attribute that contains type information (on the form: 'class, assembly')
parameters
Type: array< System..::..Object >[]()[][]
The parameters.

Return Value

The instantiated object or null if the object could not be instantiated.

Remarks

The assembly name is expanded to a qualified path by:

  • prepending "/bin/", if the filename does not contain any folder information.
  • appending ".dll", if the filename does not end with ".dll".

If the object could not be instantiated, an error message is written to the log file (usually located in the data folder).

Examples

CopyC#
object obj = ReflectionUtil.CreateObjectFromConfig("workflow", "managerFactory");

See Also

ReflectionUtil Class
CreateObjectFromConfig Overload
Sitecore.Reflection Namespace


GetAttribute Method

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..GetAttribute Method
ReflectionUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Attribute GetAttribute(
    Object obj,
    Type attributeType
)
Visual Basic
Public Shared Function GetAttribute ( _
    obj As Object, _
    attributeType As Type _
) As Attribute
Visual C++
public:
static Attribute^ GetAttribute(
    Object^ obj,
    Type^ attributeType
)

Parameters

obj
Type: System..::..Object
The object.
attributeType
Type: System..::..Type
Type of the attribute.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.ReflectionUtil.GetAttribute(System.Object,System.Type)"]

See Also

ReflectionUtil Class
Sitecore.Reflection Namespace


GetConstructorInfo Method

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..GetConstructorInfo Method
ReflectionUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static ConstructorInfo GetConstructorInfo(
    Type type,
    Object[] construtorParameters
)
Visual Basic
Public Shared Function GetConstructorInfo ( _
    type As Type, _
    construtorParameters As Object() _
) As ConstructorInfo
Visual C++
public:
static ConstructorInfo^ GetConstructorInfo(
    Type^ type,
    array<Object^>^ construtorParameters
)

Parameters

type
Type: System..::..Type
The type.
construtorParameters
Type: array< System..::..Object >[]()[][]
The construtor parameters.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.ReflectionUtil.GetConstructorInfo(System.Type,System.Object[])"]

See Also

ReflectionUtil Class
Sitecore.Reflection Namespace


GetField Method

[image] [image]

Sitecore 6.4.1 API
ReflectionUtil..::..GetField Method
ReflectionUtil Class See Also Send Feedback

Overload List

Name | Description
GetField(Object, String) | Gets a field on an object.
GetField(Object, String, Object) | Gets a field on an object.

See Also

ReflectionUtil Class
ReflectionUtil Members
Sitecore.Reflection Namespace


GetField Method (Object, String)

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..GetField Method (Object, String)
ReflectionUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object GetField(
    Object obj,
    string name
)
Visual Basic
Public Shared Function GetField ( _
    obj As Object, _
    name As String _
) As Object
Visual C++
public:
static Object^ GetField(
    Object^ obj,
    String^ name
)

Parameters

obj
Type: System..::..Object
The object.
name
Type: System..::..String
The name.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.ReflectionUtil.GetField(System.Object,System.String)"]

See Also

ReflectionUtil Class
GetField Overload
Sitecore.Reflection Namespace


GetField Method (Object, String, Object)

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..GetField Method (Object, String, Object)
ReflectionUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object GetField(
    Object obj,
    string name,
    Object defaultValue
)
Visual Basic
Public Shared Function GetField ( _
    obj As Object, _
    name As String, _
    defaultValue As Object _
) As Object
Visual C++
public:
static Object^ GetField(
    Object^ obj,
    String^ name,
    Object^ defaultValue
)

Parameters

obj
Type: System..::..Object
The object.
name
Type: System..::..String
The name.
defaultValue
Type: System..::..Object
The _default.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.ReflectionUtil.GetField(System.Object,System.String,System.Object)"]

See Also

ReflectionUtil Class
GetField Overload
Sitecore.Reflection Namespace


GetMethod Method

[image] [image]

Sitecore 6.4.1 API
ReflectionUtil..::..GetMethod Method
ReflectionUtil Class See Also Send Feedback

Overload List

Name | Description
GetMethod(Object, String, array<Object>[]()[][]) | Gets a method on an object.
GetMethod(Object, String, Boolean, Boolean, array<Object>[]()[][]) | Gets a method on an object.
GetMethod(Type, String, Boolean, Boolean, array<Object>[]()[][]) | Gets a method on an object.
GetMethod(Type, String, Boolean, Boolean, Boolean, array<Object>[]()[][]) | Gets a method on an object.
GetMethod(Type, String, Boolean, Boolean, Boolean, array<Type>[]()[][]) | Gets a method on an object.

See Also

ReflectionUtil Class
ReflectionUtil Members
Sitecore.Reflection Namespace


GetMethod Method (Object, String, Object[])

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..GetMethod Method (Object, String, array<Object>[]()[][])
ReflectionUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static MethodInfo GetMethod(
    Object obj,
    string methodName,
    Object[] parameters
)
Visual Basic
Public Shared Function GetMethod ( _
    obj As Object, _
    methodName As String, _
    parameters As Object() _
) As MethodInfo
Visual C++
public:
static MethodInfo^ GetMethod(
    Object^ obj,
    String^ methodName,
    array<Object^>^ parameters
)

Parameters

obj
Type: System..::..Object
The object.
methodName
Type: System..::..String
Name of the method.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.ReflectionUtil.GetMethod(System.Object,System.String,System.Object[])"]

See Also

ReflectionUtil Class
GetMethod Overload
Sitecore.Reflection Namespace


GetMethod Method (Object, String, Boolean, Boolean, Object[])

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..GetMethod Method (Object, String, Boolean, Boolean, array<Object>[]()[][])
ReflectionUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static MethodInfo GetMethod(
    Object obj,
    string methodName,
    bool includeNonPublic,
    bool includeInherited,
    Object[] parameters
)
Visual Basic
Public Shared Function GetMethod ( _
    obj As Object, _
    methodName As String, _
    includeNonPublic As Boolean, _
    includeInherited As Boolean, _
    parameters As Object() _
) As MethodInfo
Visual C++
public:
static MethodInfo^ GetMethod(
    Object^ obj,
    String^ methodName,
    bool includeNonPublic,
    bool includeInherited,
    array<Object^>^ parameters
)

Parameters

obj
Type: System..::..Object
The object.
methodName
Type: System..::..String
Name of the method.
includeNonPublic
Type: System..::..Boolean
if set to true this instance is include non public.
includeInherited
Type: System..::..Boolean
if set to true this instance is include inherited.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.ReflectionUtil.GetMethod(System.Object,System.String,System.Boolean,System.Boolean,System.Object[])"]

See Also

ReflectionUtil Class
GetMethod Overload
Sitecore.Reflection Namespace


GetMethod Method (Type, String, Boolean, Boolean, Object[])

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..GetMethod Method (Type, String, Boolean, Boolean, array<Object>[]()[][])
ReflectionUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static MethodInfo GetMethod(
    Type type,
    string methodName,
    bool includeNonPublic,
    bool includeInherited,
    Object[] parameters
)
Visual Basic
Public Shared Function GetMethod ( _
    type As Type, _
    methodName As String, _
    includeNonPublic As Boolean, _
    includeInherited As Boolean, _
    parameters As Object() _
) As MethodInfo
Visual C++
public:
static MethodInfo^ GetMethod(
    Type^ type,
    String^ methodName,
    bool includeNonPublic,
    bool includeInherited,
    array<Object^>^ parameters
)

Parameters

type
Type: System..::..Type
The type.
methodName
Type: System..::..String
Name of the method.
includeNonPublic
Type: System..::..Boolean
if set to true this instance is include non public.
includeInherited
Type: System..::..Boolean
if set to true this instance is include inherited.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.ReflectionUtil.GetMethod(System.Type,System.String,System.Boolean,System.Boolean,System.Object[])"]

See Also

ReflectionUtil Class
GetMethod Overload
Sitecore.Reflection Namespace


GetMethod Method (Type, String, Boolean, Boolean, Boolean, Object[])

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..GetMethod Method (Type, String, Boolean, Boolean, Boolean, array<Object>[]()[][])
ReflectionUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static MethodInfo GetMethod(
    Type type,
    string methodName,
    bool includeNonPublic,
    bool includeInherited,
    bool includeStatic,
    Object[] parameters
)
Visual Basic
Public Shared Function GetMethod ( _
    type As Type, _
    methodName As String, _
    includeNonPublic As Boolean, _
    includeInherited As Boolean, _
    includeStatic As Boolean, _
    parameters As Object() _
) As MethodInfo
Visual C++
public:
static MethodInfo^ GetMethod(
    Type^ type,
    String^ methodName,
    bool includeNonPublic,
    bool includeInherited,
    bool includeStatic,
    array<Object^>^ parameters
)

Parameters

type
Type: System..::..Type
The type.
methodName
Type: System..::..String
Name of the method.
includeNonPublic
Type: System..::..Boolean
if set to true this instance is include non public.
includeInherited
Type: System..::..Boolean
if set to true this instance is include inherited.
includeStatic
Type: System..::..Boolean
if set to true this instance is include static.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.ReflectionUtil.GetMethod(System.Type,System.String,System.Boolean,System.Boolean,System.Boolean,System.Object[])"]

See Also

ReflectionUtil Class
GetMethod Overload
Sitecore.Reflection Namespace


GetMethod Method (Type, String, Boolean, Boolean, Boolean, Type[])

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..GetMethod Method (Type, String, Boolean, Boolean, Boolean, array<Type>[]()[][])
ReflectionUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static MethodInfo GetMethod(
    Type type,
    string methodName,
    bool includeNonPublic,
    bool includeInherited,
    bool includeStatic,
    Type[] types
)
Visual Basic
Public Shared Function GetMethod ( _
    type As Type, _
    methodName As String, _
    includeNonPublic As Boolean, _
    includeInherited As Boolean, _
    includeStatic As Boolean, _
    types As Type() _
) As MethodInfo
Visual C++
public:
static MethodInfo^ GetMethod(
    Type^ type,
    String^ methodName,
    bool includeNonPublic,
    bool includeInherited,
    bool includeStatic,
    array<Type^>^ types
)

Parameters

type
Type: System..::..Type
The type.
methodName
Type: System..::..String
Name of the method.
includeNonPublic
Type: System..::..Boolean
if set to true this instance is include non public.
includeInherited
Type: System..::..Boolean
if set to true this instance is include inherited.
includeStatic
Type: System..::..Boolean
if set to true this instance is include static.
types
Type: array< System..::..Type >[]()[][]
The types.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.ReflectionUtil.GetMethod(System.Type,System.String,System.Boolean,System.Boolean,System.Boolean,System.Type[])"]

See Also

ReflectionUtil Class
GetMethod Overload
Sitecore.Reflection Namespace


GetMethodInvoker Method

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..GetMethodInvoker Method
ReflectionUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static FastInvoker GetMethodInvoker(
    MethodInfo methodInfo
)
Visual Basic
Public Shared Function GetMethodInvoker ( _
    methodInfo As MethodInfo _
) As FastInvoker
Visual C++
public:
static FastInvoker^ GetMethodInvoker(
    MethodInfo^ methodInfo
)

Parameters

methodInfo
Type: System.Reflection..::..MethodInfo
The method info.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.ReflectionUtil.GetMethodInvoker(System.Reflection.MethodInfo)"]

See Also

ReflectionUtil Class
Sitecore.Reflection Namespace


GetProperty Method

[image] [image]

Sitecore 6.4.1 API
ReflectionUtil..::..GetProperty Method
ReflectionUtil Class See Also Send Feedback

Overload List

Name | Description
GetProperty(Object, String) | Gets a property on an object.
GetProperty(Object, String, Object) | Gets a property on an object.

See Also

ReflectionUtil Class
ReflectionUtil Members
Sitecore.Reflection Namespace


GetProperty Method (Object, String)

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..GetProperty Method (Object, String)
ReflectionUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object GetProperty(
    Object obj,
    string name
)
Visual Basic
Public Shared Function GetProperty ( _
    obj As Object, _
    name As String _
) As Object
Visual C++
public:
static Object^ GetProperty(
    Object^ obj,
    String^ name
)

Parameters

obj
Type: System..::..Object
The object.
name
Type: System..::..String
The name.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.ReflectionUtil.GetProperty(System.Object,System.String)"]

See Also

ReflectionUtil Class
GetProperty Overload
Sitecore.Reflection Namespace


GetProperty Method (Object, String, Object)

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..GetProperty Method (Object, String, Object)
ReflectionUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object GetProperty(
    Object obj,
    string name,
    Object defaultValue
)
Visual Basic
Public Shared Function GetProperty ( _
    obj As Object, _
    name As String, _
    defaultValue As Object _
) As Object
Visual C++
public:
static Object^ GetProperty(
    Object^ obj,
    String^ name,
    Object^ defaultValue
)

Parameters

obj
Type: System..::..Object
The object.
name
Type: System..::..String
The name.
defaultValue
Type: System..::..Object
The _default.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.ReflectionUtil.GetProperty(System.Object,System.String,System.Object)"]

See Also

ReflectionUtil Class
GetProperty Overload
Sitecore.Reflection Namespace


GetPropertyInfo Method

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..GetPropertyInfo Method
ReflectionUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static PropertyInfo GetPropertyInfo(
    Object obj,
    string name
)
Visual Basic
Public Shared Function GetPropertyInfo ( _
    obj As Object, _
    name As String _
) As PropertyInfo
Visual C++
public:
static PropertyInfo^ GetPropertyInfo(
    Object^ obj,
    String^ name
)

Parameters

obj
Type: System..::..Object
The object.
name
Type: System..::..String
The name.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.ReflectionUtil.GetPropertyInfo(System.Object,System.String)"]

Remarks

Declared properties are considered first.

See Also

ReflectionUtil Class
Sitecore.Reflection Namespace


GetTypeInfo Method

[image] [image]

Sitecore 6.4.1 API
ReflectionUtil..::..GetTypeInfo Method
ReflectionUtil Class See Also Send Feedback

Overload List

Name | Description
GetTypeInfo(String) | Gets type information for a class.
GetTypeInfo(String, String) | Gets type information for a class.

See Also

ReflectionUtil Class
ReflectionUtil Members
Sitecore.Reflection Namespace


GetTypeInfo Method (String)

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..GetTypeInfo Method (String)
ReflectionUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Type GetTypeInfo(
    string typeName
)
Visual Basic
Public Shared Function GetTypeInfo ( _
    typeName As String _
) As Type
Visual C++
public:
static Type^ GetTypeInfo(
    String^ typeName
)

Parameters

typeName
Type: System..::..String
Name of the type on the format 'Namespace.Class, Assembly'. Example: "Sitecore.Xml.Packet, Sitecore.Kernel".

Return Value

The type information or null if the type could not be found.

Remarks

The assembly name is expanded to a qualified path by:
  • prepending "/bin/", if the filename does not contain any folder information.
  • appending ".dll", if the filename does not end with ".dll".

See Also

ReflectionUtil Class
GetTypeInfo Overload
Sitecore.Reflection Namespace


GetTypeInfo Method (String, String)

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..GetTypeInfo Method (String, String)
ReflectionUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Type GetTypeInfo(
    string assembly,
    string className
)
Visual Basic
Public Shared Function GetTypeInfo ( _
    assembly As String, _
    className As String _
) As Type
Visual C++
public:
static Type^ GetTypeInfo(
    String^ assembly,
    String^ className
)

Parameters

assembly
Type: System..::..String
An assembly file name.
className
Type: System..::..String
A class name.

Return Value

The type information or null if the type could not be found.

Remarks

The assembly name is expanded to a qualified path by:
  • prepending "/bin/", if the filename does not contain any folder information.
  • appending ".dll", if the filename does not end with ".dll".

See Also

ReflectionUtil Class
GetTypeInfo Overload
Sitecore.Reflection Namespace


GetTypes Method

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..GetTypes Method
ReflectionUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Type[] GetTypes(
    Object[] parameters
)
Visual Basic
Public Shared Function GetTypes ( _
    parameters As Object() _
) As Type()
Visual C++
public:
static array<Type^>^ GetTypes(
    array<Object^>^ parameters
)

Parameters

parameters
Type: array< System..::..Object >[]()[][]
The parameters.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.ReflectionUtil.GetTypes(System.Object[])"]

See Also

ReflectionUtil Class
Sitecore.Reflection Namespace


GetTypeString Method

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..GetTypeString Method
ReflectionUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetTypeString(
    Type type
)
Visual Basic
Public Shared Function GetTypeString ( _
    type As Type _
) As String
Visual C++
public:
static String^ GetTypeString(
    Type^ type
)

Parameters

type
Type: System..::..Type
The type.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.ReflectionUtil.GetTypeString(System.Type)"]

See Also

ReflectionUtil Class
Sitecore.Reflection Namespace


HasAttribute Method

[image] [image]

Sitecore 6.4.1 API
ReflectionUtil..::..HasAttribute Method
ReflectionUtil Class See Also Send Feedback

Overload List

Name | Description
HasAttribute(Object, Type) | Determines whether the specified object has attribute.
HasAttribute(MethodInfo, Type) | Determines whether the specified method has attribute.

See Also

ReflectionUtil Class
ReflectionUtil Members
Sitecore.Reflection Namespace


HasAttribute Method (MethodInfo, Type)

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..HasAttribute Method (MethodInfo, Type)
ReflectionUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool HasAttribute(
    MethodInfo method,
    Type attributeType
)
Visual Basic
Public Shared Function HasAttribute ( _
    method As MethodInfo, _
    attributeType As Type _
) As Boolean
Visual C++
public:
static bool HasAttribute(
    MethodInfo^ method,
    Type^ attributeType
)

Parameters

method
Type: System.Reflection..::..MethodInfo
The method.
attributeType
Type: System..::..Type
Type of the attribute.

Return Value

true if the specified obj has attribute; otherwise, false.

See Also

ReflectionUtil Class
HasAttribute Overload
Sitecore.Reflection Namespace


InvokeMethod Method

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..InvokeMethod Method
ReflectionUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Object InvokeMethod(
    MethodInfo method,
    Object[] parameters,
    Object obj
)
Visual Basic
Public Shared Function InvokeMethod ( _
    method As MethodInfo, _
    parameters As Object(), _
    obj As Object _
) As Object
Visual C++
public:
static Object^ InvokeMethod(
    MethodInfo^ method,
    array<Object^>^ parameters,
    Object^ obj
)

Parameters

method
Type: System.Reflection..::..MethodInfo
The method.
parameters
Type: array< System..::..Object >[]()[][]
The parameters.
obj
Type: System..::..Object
The object.

Return Value

The return value of the method.

See Also

ReflectionUtil Class
Sitecore.Reflection Namespace


ParseEnum(T) Method

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..ParseEnum<(Of <(<'T>)>)> Method
ReflectionUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static T ParseEnum<T>(
    string value
)
where T : struct, new()
Visual Basic
Public Shared Function ParseEnum(Of T As {Structure, New}) ( _
    value As String _
) As T
Visual C++
public:
generic<typename T>
where T : value class, gcnew()
static T ParseEnum(
    String^ value
)

Parameters

value
Type: System..::..String
The value.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Sitecore.Reflection.ReflectionUtil.ParseEnum``1(System.String)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.ReflectionUtil.ParseEnum``1(System.String)"]

See Also

ReflectionUtil Class
Sitecore.Reflection Namespace


SetField Method

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..SetField Method
ReflectionUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool SetField(
    Object obj,
    string name,
    Object value
)
Visual Basic
Public Shared Function SetField ( _
    obj As Object, _
    name As String, _
    value As Object _
) As Boolean
Visual C++
public:
static bool SetField(
    Object^ obj,
    String^ name,
    Object^ value
)

Parameters

obj
Type: System..::..Object
The object.
name
Type: System..::..String
The name.
value
Type: System..::..Object
The _value.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.ReflectionUtil.SetField(System.Object,System.String,System.Object)"]

See Also

ReflectionUtil Class
Sitecore.Reflection Namespace


SetProperties Method

[image] [image]

Sitecore 6.4.1 API
ReflectionUtil..::..SetProperties Method
ReflectionUtil Class See Also Send Feedback

Overload List

Name | Description
SetProperties(Object, String) | Sets properties on an object from a list of parameters on the form: p1=value1&p2=value2&...
SetProperties(Object, String, Boolean) | Sets properties on an object from a list of parameters on the form: p1=value1&p2=value2&...

See Also

ReflectionUtil Class
ReflectionUtil Members
Sitecore.Reflection Namespace


SetProperties Method (Object, String)

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..SetProperties Method (Object, String)
ReflectionUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void SetProperties(
    Object obj,
    string parameters
)
Visual Basic
Public Shared Sub SetProperties ( _
    obj As Object, _
    parameters As String _
)
Visual C++
public:
static void SetProperties(
    Object^ obj,
    String^ parameters
)

Parameters

obj
Type: System..::..Object
The object.
parameters
Type: System..::..String
The parameters.

See Also

ReflectionUtil Class
SetProperties Overload
Sitecore.Reflection Namespace


SetPropertiesFromConfig Method

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..SetPropertiesFromConfig Method
ReflectionUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void SetPropertiesFromConfig(
    Object obj,
    string nodePath,
    string[] exclude
)
Visual Basic
Public Shared Sub SetPropertiesFromConfig ( _
    obj As Object, _
    nodePath As String, _
    exclude As String() _
)
Visual C++
public:
static void SetPropertiesFromConfig(
    Object^ obj,
    String^ nodePath,
    array<String^>^ exclude
)

Parameters

obj
Type: System..::..Object
The object.
nodePath
Type: System..::..String
The node path.
exclude
Type: array< System..::..String >[]()[][]
The exclude.

See Also

ReflectionUtil Class
Sitecore.Reflection Namespace


SetProperty Method

[image] [image]

Sitecore 6.4.1 API
ReflectionUtil..::..SetProperty Method
ReflectionUtil Class See Also Send Feedback

Overload List

Name | Description
SetProperty(Object, PropertyInfo, Object) | Sets a property on an object.
SetProperty(Object, String, Object) | Sets a property on an object.

See Also

ReflectionUtil Class
ReflectionUtil Members
Sitecore.Reflection Namespace


SetProperty Method (Object, PropertyInfo, Object)

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..SetProperty Method (Object, PropertyInfo, Object)
ReflectionUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static void SetProperty(
    Object obj,
    PropertyInfo property,
    Object value
)
Visual Basic
Public Shared Sub SetProperty ( _
    obj As Object, _
    property As PropertyInfo, _
    value As Object _
)
Visual C++
public:
static void SetProperty(
    Object^ obj,
    PropertyInfo^ property,
    Object^ value
)

Parameters

obj
Type: System..::..Object
The object.
property
Type: System.Reflection..::..PropertyInfo
The property.
value
Type: System..::..Object
The value.

See Also

ReflectionUtil Class
SetProperty Overload
Sitecore.Reflection Namespace


SetProperty Method (Object, String, Object)

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..SetProperty Method (Object, String, Object)
ReflectionUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool SetProperty(
    Object obj,
    string name,
    Object value
)
Visual Basic
Public Shared Function SetProperty ( _
    obj As Object, _
    name As String, _
    value As Object _
) As Boolean
Visual C++
public:
static bool SetProperty(
    Object^ obj,
    String^ name,
    Object^ value
)

Parameters

obj
Type: System..::..Object
The object.
name
Type: System..::..String
The name.
value
Type: System..::..Object
The _value.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.ReflectionUtil.SetProperty(System.Object,System.String,System.Object)"]

See Also

ReflectionUtil Class
SetProperty Overload
Sitecore.Reflection Namespace


SetStaticField Method

[image]

Sitecore 6.4.1 API
ReflectionUtil..::..SetStaticField Method
ReflectionUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool SetStaticField(
    Type type,
    string name,
    Object value
)
Visual Basic
Public Shared Function SetStaticField ( _
    type As Type, _
    name As String, _
    value As Object _
) As Boolean
Visual C++
public:
static bool SetStaticField(
    Type^ type,
    String^ name,
    Object^ value
)

Parameters

type
Type: System..::..Type
The type.
name
Type: System..::..String
The name.
value
Type: System..::..Object
The value.

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.ReflectionUtil.SetStaticField(System.Type,System.String,System.Object)"]

See Also

ReflectionUtil Class
Sitecore.Reflection Namespace


TypeUtil Class

[image]

Sitecore 6.4.1 API
TypeUtil Class
Members See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class TypeUtil
Visual Basic
Public NotInheritable Class TypeUtil
Visual C++
public ref class TypeUtil abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Reflection..::..TypeUtil

See Also

TypeUtil Members
Sitecore.Reflection Namespace


TypeUtil Members

[image] [image]

Sitecore 6.4.1 API
TypeUtil Members
TypeUtil Class Methods See Also Send Feedback

The TypeUtil type exposes the following members.

Methods

Name | Description
SizeOfCultureInfo | Gets the standard size of a CultureInfo.
SizeOfDictionary | Gets the standard size of a Dictionary<(Of <(<'TKey, TValue>)>)>.
SizeOfEnum | Gets the standard size of an Enum.
SizeOfGuid | Gets the standard size of a Guid.
SizeOfHashtable | Size of a hashtable.
SizeOfHashtableEntry | Gets the standard size of a Hashtable entry.
SizeOfID | Gets the standard size of an ID.
SizeOfInt32 | Gets the standard size of an Int32.
SizeOfInt64 | Gets the standard size of a Int64.
SizeOfLanguage | Gets the standard size of a Language.
SizeOfObject | Gets the standard size of an Object (ie. a pointer).
SizeOfString(Int32) | Gets the standard size of a String of a certain length.
SizeOfString(String) | Gets the standard size of a String.
SizeOfVersion | Gets the standard size of a Version.
SizeOfVersionUri | Gets the standard size of a VersionUri.

See Also

TypeUtil Class
Sitecore.Reflection Namespace


TypeUtil Methods

[image] [image]

Sitecore 6.4.1 API
TypeUtil Methods
TypeUtil Class See Also Send Feedback

The TypeUtil type exposes the following members.

Methods

Name | Description
SizeOfCultureInfo | Gets the standard size of a CultureInfo.
SizeOfDictionary | Gets the standard size of a Dictionary<(Of <(<'TKey, TValue>)>)>.
SizeOfEnum | Gets the standard size of an Enum.
SizeOfGuid | Gets the standard size of a Guid.
SizeOfHashtable | Size of a hashtable.
SizeOfHashtableEntry | Gets the standard size of a Hashtable entry.
SizeOfID | Gets the standard size of an ID.
SizeOfInt32 | Gets the standard size of an Int32.
SizeOfInt64 | Gets the standard size of a Int64.
SizeOfLanguage | Gets the standard size of a Language.
SizeOfObject | Gets the standard size of an Object (ie. a pointer).
SizeOfString(Int32) | Gets the standard size of a String of a certain length.
SizeOfString(String) | Gets the standard size of a String.
SizeOfVersion | Gets the standard size of a Version.
SizeOfVersionUri | Gets the standard size of a VersionUri.

See Also

TypeUtil Class
Sitecore.Reflection Namespace


SizeOfCultureInfo Method

[image]

Sitecore 6.4.1 API
TypeUtil..::..SizeOfCultureInfo Method
TypeUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int SizeOfCultureInfo()
Visual Basic
Public Shared Function SizeOfCultureInfo As Integer
Visual C++
public:
static int SizeOfCultureInfo()

Return Value

The size.

See Also

TypeUtil Class
Sitecore.Reflection Namespace


SizeOfDictionary Method

[image]

Sitecore 6.4.1 API
TypeUtil..::..SizeOfDictionary Method
TypeUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int SizeOfDictionary()
Visual Basic
Public Shared Function SizeOfDictionary As Integer
Visual C++
public:
static int SizeOfDictionary()

Return Value

The size.

See Also

TypeUtil Class
Sitecore.Reflection Namespace


SizeOfEnum Method

[image]

Sitecore 6.4.1 API
TypeUtil..::..SizeOfEnum Method
TypeUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int SizeOfEnum()
Visual Basic
Public Shared Function SizeOfEnum As Integer
Visual C++
public:
static int SizeOfEnum()

Return Value

The size.

See Also

TypeUtil Class
Sitecore.Reflection Namespace


SizeOfGuid Method

[image]

Sitecore 6.4.1 API
TypeUtil..::..SizeOfGuid Method
TypeUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int SizeOfGuid()
Visual Basic
Public Shared Function SizeOfGuid As Integer
Visual C++
public:
static int SizeOfGuid()

Return Value

The size.

See Also

TypeUtil Class
Sitecore.Reflection Namespace


SizeOfHashtable Method

[image]

Sitecore 6.4.1 API
TypeUtil..::..SizeOfHashtable Method
TypeUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int SizeOfHashtable()
Visual Basic
Public Shared Function SizeOfHashtable As Integer
Visual C++
public:
static int SizeOfHashtable()

Return Value

[Missing <returns> documentation for "M:Sitecore.Reflection.TypeUtil.SizeOfHashtable"]

See Also

TypeUtil Class
Sitecore.Reflection Namespace


SizeOfHashtableEntry Method

[image]

Sitecore 6.4.1 API
TypeUtil..::..SizeOfHashtableEntry Method
TypeUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int SizeOfHashtableEntry()
Visual Basic
Public Shared Function SizeOfHashtableEntry As Integer
Visual C++
public:
static int SizeOfHashtableEntry()

Return Value

The size.

See Also

TypeUtil Class
Sitecore.Reflection Namespace


SizeOfInt32 Method

[image]

Sitecore 6.4.1 API
TypeUtil..::..SizeOfInt32 Method
TypeUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int SizeOfInt32()
Visual Basic
Public Shared Function SizeOfInt32 As Integer
Visual C++
public:
static int SizeOfInt32()

Return Value

The size.

See Also

TypeUtil Class
Sitecore.Reflection Namespace


SizeOfInt64 Method

[image]

Sitecore 6.4.1 API
TypeUtil..::..SizeOfInt64 Method
TypeUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int SizeOfInt64()
Visual Basic
Public Shared Function SizeOfInt64 As Integer
Visual C++
public:
static int SizeOfInt64()

Return Value

The size.

See Also

TypeUtil Class
Sitecore.Reflection Namespace


SizeOfLanguage Method

[image]

Sitecore 6.4.1 API
TypeUtil..::..SizeOfLanguage Method
TypeUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int SizeOfLanguage()
Visual Basic
Public Shared Function SizeOfLanguage As Integer
Visual C++
public:
static int SizeOfLanguage()

Return Value

The size.

See Also

TypeUtil Class
Sitecore.Reflection Namespace


SizeOfObject Method

[image]

Sitecore 6.4.1 API
TypeUtil..::..SizeOfObject Method
TypeUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int SizeOfObject()
Visual Basic
Public Shared Function SizeOfObject As Integer
Visual C++
public:
static int SizeOfObject()

Return Value

The size.

See Also

TypeUtil Class
Sitecore.Reflection Namespace


SizeOfString Method

[image] [image]

Sitecore 6.4.1 API
TypeUtil..::..SizeOfString Method
TypeUtil Class See Also Send Feedback

Overload List

Name | Description
SizeOfString(Int32) | Gets the standard size of a String of a certain length.
SizeOfString(String) | Gets the standard size of a String.

See Also

TypeUtil Class
TypeUtil Members
Sitecore.Reflection Namespace


SizeOfString Method (Int32)

[image]

Sitecore 6.4.1 API
TypeUtil..::..SizeOfString Method (Int32)
TypeUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int SizeOfString(
    int stringLength
)
Visual Basic
Public Shared Function SizeOfString ( _
    stringLength As Integer _
) As Integer
Visual C++
public:
static int SizeOfString(
    int stringLength
)

Parameters

stringLength
Type: System..::..Int32

[Missing <param name="stringLength"/> documentation for "M:Sitecore.Reflection.TypeUtil.SizeOfString(System.Int32)"]

Return Value

The size.

See Also

TypeUtil Class
SizeOfString Overload
Sitecore.Reflection Namespace


SizeOfString Method (String)

[image]

Sitecore 6.4.1 API
TypeUtil..::..SizeOfString Method (String)
TypeUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int SizeOfString(
    string value
)
Visual Basic
Public Shared Function SizeOfString ( _
    value As String _
) As Integer
Visual C++
public:
static int SizeOfString(
    String^ value
)

Parameters

value
Type: System..::..String

[Missing <param name="value"/> documentation for "M:Sitecore.Reflection.TypeUtil.SizeOfString(System.String)"]

Return Value

The size.

See Also

TypeUtil Class
SizeOfString Overload
Sitecore.Reflection Namespace


SizeOfVersion Method

[image]

Sitecore 6.4.1 API
TypeUtil..::..SizeOfVersion Method
TypeUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int SizeOfVersion()
Visual Basic
Public Shared Function SizeOfVersion As Integer
Visual C++
public:
static int SizeOfVersion()

Return Value

The size.

See Also

TypeUtil Class
Sitecore.Reflection Namespace


SizeOfVersionUri Method

[image]

Sitecore 6.4.1 API
TypeUtil..::..SizeOfVersionUri Method
TypeUtil Class See Also Send Feedback

Namespace: Sitecore.Reflection
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static int SizeOfVersionUri()
Visual Basic
Public Shared Function SizeOfVersionUri As Integer
Visual C++
public:
static int SizeOfVersionUri()

Return Value

The size.

See Also

TypeUtil Class
Sitecore.Reflection Namespace


Sitecore.Reflection.Emit Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Reflection.Emit Namespace
Send Feedback

Classes

 | Class | Description
Public class | Argument | Represents an Argument.
Public class | EmitWriter | Represents a EmitWriter.
Public class | Local | Represents a Local.


Argument Class

[image]

Sitecore 6.4.1 API
Argument Class
Members See Also Send Feedback

Namespace: Sitecore.Reflection.Emit
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Argument
Visual Basic
Public Class Argument
Visual C++
public ref class Argument

Inheritance Hierarchy

System..::..Object
Sitecore.Reflection.Emit..::..Argument

See Also

Argument Members
Sitecore.Reflection.Emit Namespace


Argument Members

[image] [image]

Sitecore 6.4.1 API
Argument Members
Argument Class Constructors Methods Properties See Also Send Feedback

The Argument type exposes the following members.

Constructors

 | Name | Description
Public method | Argument()()()() | Initializes a new instance of the Argument class.
Public method | Argument(Int32) | Initializes a new instance of the Argument class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
 | Argument0 | Gets the argument0.
 | Argument1 | Gets the argument1.
 | Argument2 | Gets the argument2.
 | Argument3 | Gets the argument3.
Public property | Index | Gets or sets the index.

See Also

Argument Class
Sitecore.Reflection.Emit Namespace


Argument Constructor

[image] [image]

Sitecore 6.4.1 API
Argument Constructor
Argument Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Argument()()()() | Initializes a new instance of the Argument class.
Public method | Argument(Int32) | Initializes a new instance of the Argument class.

See Also

Argument Class
Argument Members
Sitecore.Reflection.Emit Namespace


Argument Constructor

[image]

Sitecore 6.4.1 API
Argument Constructor
Argument Class See Also Send Feedback

Namespace: Sitecore.Reflection.Emit
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Argument()
Visual Basic
Public Sub New
Visual C++
public:
Argument()

See Also

Argument Class
Argument Overload
Sitecore.Reflection.Emit Namespace


Argument Constructor (Int32)

[image]

Sitecore 6.4.1 API
Argument Constructor (Int32)
Argument Class See Also Send Feedback

Namespace: Sitecore.Reflection.Emit
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Argument(
    int index
)
Visual Basic
Public Sub New ( _
    index As Integer _
)
Visual C++
public:
Argument(
    int index
)

Parameters

index
Type: System..::..Int32
The index.

See Also

Argument Class
Argument Overload
Sitecore.Reflection.Emit Namespace


Argument Methods

[image] [image]

Sitecore 6.4.1 API
Argument Methods
Argument Class See Also Send Feedback

The Argument type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Argument Class
Sitecore.Reflection.Emit Namespace


Argument Properties

[image] [image]

Sitecore 6.4.1 API
Argument Properties
Argument Class See Also Send Feedback

The Argument type exposes the following members.

Properties

 | Name | Description
 | Argument0 | Gets the argument0.
 | Argument1 | Gets the argument1.
 | Argument2 | Gets the argument2.
 | Argument3 | Gets the argument3.
Public property | Index | Gets or sets the index.

See Also

Argument Class
Sitecore.Reflection.Emit Namespace


Argument0 Property

[image]

Sitecore 6.4.1 API
Argument..::..Argument0 Property
Argument Class See Also Send Feedback

Namespace: Sitecore.Reflection.Emit
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Argument Argument0 { get; }
Visual Basic
Public Shared ReadOnly Property Argument0 As Argument
    Get
Visual C++
public:
static property Argument^ Argument0 {
    Argument^ get ();
}

Field Value

The argument0.

See Also

Argument Class
Sitecore.Reflection.Emit Namespace


Argument1 Property

[image]

Sitecore 6.4.1 API
Argument..::..Argument1 Property
Argument Class See Also Send Feedback

Namespace: Sitecore.Reflection.Emit
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Argument Argument1 { get; }
Visual Basic
Public Shared ReadOnly Property Argument1 As Argument
    Get
Visual C++
public:
static property Argument^ Argument1 {
    Argument^ get ();
}

Field Value

The argument1.

See Also

Argument Class
Sitecore.Reflection.Emit Namespace


Argument2 Property

[image]

Sitecore 6.4.1 API
Argument..::..Argument2 Property
Argument Class See Also Send Feedback

Namespace: Sitecore.Reflection.Emit
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Argument Argument2 { get; }
Visual Basic
Public Shared ReadOnly Property Argument2 As Argument
    Get
Visual C++
public:
static property Argument^ Argument2 {
    Argument^ get ();
}

Field Value

The argument2.

See Also

Argument Class
Sitecore.Reflection.Emit Namespace


Argument3 Property

[image]

Sitecore 6.4.1 API
Argument..::..Argument3 Property
Argument Class See Also Send Feedback

Namespace: Sitecore.Reflection.Emit
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Argument Argument3 { get; }
Visual Basic
Public Shared ReadOnly Property Argument3 As Argument
    Get
Visual C++
public:
static property Argument^ Argument3 {
    Argument^ get ();
}

Field Value

The argument3.

See Also

Argument Class
Sitecore.Reflection.Emit Namespace


Index Property

[image]

Sitecore 6.4.1 API
Argument..::..Index Property
Argument Class See Also Send Feedback

Namespace: Sitecore.Reflection.Emit
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Index { get; set; }
Visual Basic
Public Property Index As Integer
    Get
    Set
Visual C++
public:
property int Index {
    int get ();
    void set (int value);
}

Field Value

The index.

See Also

Argument Class
Sitecore.Reflection.Emit Namespace


EmitWriter Class

[image]

Sitecore 6.4.1 API
EmitWriter Class
Members See Also Send Feedback

Namespace: Sitecore.Reflection.Emit
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class EmitWriter
Visual Basic
Public Class EmitWriter
Visual C++
public ref class EmitWriter

Inheritance Hierarchy

System..::..Object
Sitecore.Reflection.Emit..::..EmitWriter

See Also

EmitWriter Members
Sitecore.Reflection.Emit Namespace


EmitWriter Members

[image] [image]

Sitecore 6.4.1 API
EmitWriter Members
EmitWriter Class Constructors Methods Properties See Also Send Feedback

The EmitWriter type exposes the following members.

Constructors

 | Name | Description
Public method | EmitWriter | Initializes a new instance of the EmitWriter class.

Methods

 | Name | Description
Public method | BranchOnFalse | Branches on false.
Public method | BranchOnTrue | Branches on true.
Public method | Call | Emits the specified opcode.
Public method | CreateArray | Creates the array.
Public method | CreateObject(ConstructorInfo) | Creates the object.
Public method | CreateObject(List<(Of <<'(String>)>>), Local) | Emits the specified collection.
Public method | CreateObject(NameValueCollection, Local) | Emits the specified collection.
Public method | DeclareLocal | Declares the local.
Public method | DefineLabel | Declares the local.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkLabel | Declares the local.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Pop | Pops.
Public method | Push(Boolean) | Pushes the value.
Public method | Push(Int32) | Pushes the integer.
Public method | Push(array<Object>[]()[][]) | Pushes the specified parameters.
Public method | Push(String) | Pushes the string.
Public method | Push(Argument) | Pushes the argument.
Public method | Push(Local) | Pushes the integer.
Public method | PushNull | Pushes the string.
Public method | Return | Emits the return.
Public method | Store | Stores the in local.
Public method | StoreAndPush | Performs a stores and push operation.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ILGenerator | Gets the generator.

See Also

EmitWriter Class
Sitecore.Reflection.Emit Namespace


EmitWriter Methods

[image] [image]

Sitecore 6.4.1 API
EmitWriter Methods
EmitWriter Class See Also Send Feedback

The EmitWriter type exposes the following members.

Methods

 | Name | Description
Public method | BranchOnFalse | Branches on false.
Public method | BranchOnTrue | Branches on true.
Public method | Call | Emits the specified opcode.
Public method | CreateArray | Creates the array.
Public method | CreateObject(ConstructorInfo) | Creates the object.
Public method | CreateObject(List<(Of <<'(String>)>>), Local) | Emits the specified collection.
Public method | CreateObject(NameValueCollection, Local) | Emits the specified collection.
Public method | DeclareLocal | Declares the local.
Public method | DefineLabel | Declares the local.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkLabel | Declares the local.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Pop | Pops.
Public method | Push(Boolean) | Pushes the value.
Public method | Push(Int32) | Pushes the integer.
Public method | Push(array<Object>[]()[][]) | Pushes the specified parameters.
Public method | Push(String) | Pushes the string.
Public method | Push(Argument) | Pushes the argument.
Public method | Push(Local) | Pushes the integer.
Public method | PushNull | Pushes the string.
Public method | Return | Emits the return.
Public method | Store | Stores the in local.
Public method | StoreAndPush | Performs a stores and push operation.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EmitWriter Class
Sitecore.Reflection.Emit Namespace


BranchOnFalse Method

[image]

Sitecore 6.4.1 API
EmitWriter..::..BranchOnFalse Method
EmitWriter Class See Also Send Feedback

Namespace: Sitecore.Reflection.Emit
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void BranchOnFalse(
    Label label
)
Visual Basic
Public Sub BranchOnFalse ( _
    label As Label _
)
Visual C++
public:
void BranchOnFalse(
    Label label
)

Parameters

label
Type: System.Reflection.Emit..::..Label
The label.

See Also

EmitWriter Class
Sitecore.Reflection.Emit Namespace


BranchOnTrue Method

[image]

Sitecore 6.4.1 API
EmitWriter..::..BranchOnTrue Method
EmitWriter Class See Also Send Feedback

Namespace: Sitecore.Reflection.Emit
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void BranchOnTrue(
    Label label
)
Visual Basic
Public Sub BranchOnTrue ( _
    label As Label _
)
Visual C++
public:
void BranchOnTrue(
    Label label
)

Parameters

label
Type: System.Reflection.Emit..::..Label
The label.

See Also

EmitWriter Class
Sitecore.Reflection.Emit Namespace


Call Method

[image]

Sitecore 6.4.1 API
EmitWriter..::..Call Method
EmitWriter Class See Also Send Feedback

Namespace: Sitecore.Reflection.Emit
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Call(
    MethodInfo methodInfo
)
Visual Basic
Public Sub Call ( _
    methodInfo As MethodInfo _
)
Visual C++
public:
void Call(
    MethodInfo^ methodInfo
)

Parameters

methodInfo
Type: System.Reflection..::..MethodInfo
The method info.

See Also

EmitWriter Class
Sitecore.Reflection.Emit Namespace


CreateArray Method

[image]

Sitecore 6.4.1 API
EmitWriter..::..CreateArray Method
EmitWriter Class See Also Send Feedback

Namespace: Sitecore.Reflection.Emit
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void CreateArray(
    Type type
)
Visual Basic
Public Sub CreateArray ( _
    type As Type _
)
Visual C++
public:
void CreateArray(
    Type^ type
)

Parameters

type
Type: System..::..Type
The type.

See Also

EmitWriter Class
Sitecore.Reflection.Emit Namespace


CreateObject Method

[image] [image]

Sitecore 6.4.1 API
EmitWriter..::..CreateObject Method
EmitWriter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateObject(ConstructorInfo) | Creates the object.
Public method | CreateObject(List<(Of <<'(String>)>>), Local) | Emits the specified collection.
Public method | CreateObject(NameValueCollection, Local) | Emits the specified collection.

See Also

EmitWriter Class
EmitWriter Members
Sitecore.Reflection.Emit Namespace


CreateObject Method (ConstructorInfo)

[image]

Sitecore 6.4.1 API
EmitWriter..::..CreateObject Method (ConstructorInfo)
EmitWriter Class See Also Send Feedback

Namespace: Sitecore.Reflection.Emit
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void CreateObject(
    ConstructorInfo con
)
Visual Basic
Public Sub CreateObject ( _
    con As ConstructorInfo _
)
Visual C++
public:
void CreateObject(
    ConstructorInfo^ con
)

Parameters

con
Type: System.Reflection..::..ConstructorInfo
The con.

See Also

EmitWriter Class
CreateObject Overload
Sitecore.Reflection.Emit Namespace


CreateObject Method (List(String), Local)

[image]

Sitecore 6.4.1 API
EmitWriter..::..CreateObject Method (List<(Of <(<'String>)>)>, Local)
EmitWriter Class See Also Send Feedback

Namespace: Sitecore.Reflection.Emit
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void CreateObject(
    List<string> collection,
    Local local
)
Visual Basic
Public Sub CreateObject ( _
    collection As List(Of String), _
    local As Local _
)
Visual C++
public:
void CreateObject(
    List<String^>^ collection,
    Local^ local
)

Parameters

collection
Type: System.Collections.Generic..::..List <(Of <(<' String >)>)>
The collection.
local
Type: Sitecore.Reflection.Emit..::..Local
The local.

See Also

EmitWriter Class
CreateObject Overload
Sitecore.Reflection.Emit Namespace


CreateObject Method (NameValueCollection, Local)

[image]

Sitecore 6.4.1 API
EmitWriter..::..CreateObject Method (NameValueCollection, Local)
EmitWriter Class See Also Send Feedback

Namespace: Sitecore.Reflection.Emit
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void CreateObject(
    NameValueCollection collection,
    Local local
)
Visual Basic
Public Sub CreateObject ( _
    collection As NameValueCollection, _
    local As Local _
)
Visual C++
public:
void CreateObject(
    NameValueCollection^ collection,
    Local^ local
)

Parameters

collection
Type: System.Collections.Specialized..::..NameValueCollection
The collection.
local
Type: Sitecore.Reflection.Emit..::..Local
The local.

See Also

EmitWriter Class
CreateObject Overload
Sitecore.Reflection.Emit Namespace


DeclareLocal Method

[image]

Sitecore 6.4.1 API
EmitWriter..::..DeclareLocal Method
EmitWriter Class See Also Send Feedback

Namespace: Sitecore.Reflection.Emit
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void DeclareLocal(
    Type localType
)
Visual Basic
Public Sub DeclareLocal ( _
    localType As Type _
)
Visual C++
public:
void DeclareLocal(
    Type^ localType
)

Parameters

localType
Type: System..::..Type
Type of the loca.

See Also

EmitWriter Class
Sitecore.Reflection.Emit Namespace


DefineLabel Method

[image]

Sitecore 6.4.1 API
EmitWriter..::..DefineLabel Method
EmitWriter Class See Also Send Feedback

Namespace: Sitecore.Reflection.Emit
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Label DefineLabel()
Visual Basic
Public Function DefineLabel As Label
Visual C++
public:
Label DefineLabel()

Return Value

The label.

See Also

EmitWriter Class
Sitecore.Reflection.Emit Namespace


MarkLabel Method

[image]

Sitecore 6.4.1 API
EmitWriter..::..MarkLabel Method
EmitWriter Class See Also Send Feedback

Namespace: Sitecore.Reflection.Emit
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void MarkLabel(
    Label label
)
Visual Basic
Public Sub MarkLabel ( _
    label As Label _
)
Visual C++
public:
void MarkLabel(
    Label label
)

Parameters

label
Type: System.Reflection.Emit..::..Label
The label.

See Also

EmitWriter Class
Sitecore.Reflection.Emit Namespace


Pop Method

[image]

Sitecore 6.4.1 API
EmitWriter..::..Pop Method
EmitWriter Class See Also Send Feedback

Namespace: Sitecore.Reflection.Emit
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Pop()
Visual Basic
Public Sub Pop
Visual C++
public:
void Pop()

See Also

EmitWriter Class
Sitecore.Reflection.Emit Namespace


Push Method

[image] [image]

Sitecore 6.4.1 API
EmitWriter..::..Push Method
EmitWriter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Push(Boolean) | Pushes the value.
Public method | Push(Int32) | Pushes the integer.
Public method | Push(array<Object>[]()[][]) | Pushes the specified parameters.
Public method | Push(String) | Pushes the string.
Public method | Push(Argument) | Pushes the argument.
Public method | Push(Local) | Pushes the integer.

See Also

EmitWriter Class
EmitWriter Members
Sitecore.Reflection.Emit Namespace


Push Method (Boolean)

[image]

Sitecore 6.4.1 API
EmitWriter..::..Push Method (Boolean)
EmitWriter Class See Also Send Feedback

Namespace: Sitecore.Reflection.Emit
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Push(
    bool value
)
Visual Basic
Public Sub Push ( _
    value As Boolean _
)
Visual C++
public:
void Push(
    bool value
)

Parameters

value
Type: System..::..Boolean
The value.

See Also

EmitWriter Class
Push Overload
Sitecore.Reflection.Emit Namespace


Push Method (Int32)

[image]

Sitecore 6.4.1 API
EmitWriter..::..Push Method (Int32)
EmitWriter Class See Also Send Feedback

Namespace: Sitecore.Reflection.Emit
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Push(
    int value
)
Visual Basic
Public Sub Push ( _
    value As Integer _
)
Visual C++
public:
void Push(
    int value
)

Parameters

value
Type: System..::..Int32
The value.

See Also

EmitWriter Class
Push Overload
Sitecore.Reflection.Emit Namespace


Push Method (Object[])

[image]

Sitecore 6.4.1 API
EmitWriter..::..Push Method (array<Object>[]()[][])
EmitWriter Class See Also Send Feedback

Namespace: Sitecore.Reflection.Emit
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Push(
    params Object[] parameters
)
Visual Basic
Public Sub Push ( _
    ParamArray parameters As Object() _
)
Visual C++
public:
void Push(
    ... array<Object^>^ parameters
)

Parameters

parameters
Type: array< System..::..Object >[]()[][]
The parameters.

Exceptions

Exception | Condition
System..::..Exception | Invalid Parameter.

See Also

EmitWriter Class
Push Overload
Sitecore.Reflection.Emit Namespace


Push Method (String)

[image]

Sitecore 6.4.1 API
EmitWriter..::..Push Method (String)
EmitWriter Class See Also Send Feedback

Namespace: Sitecore.Reflection.Emit
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Push(
    string value
)
Visual Basic
Public Sub Push ( _
    value As String _
)
Visual C++
public:
void Push(
    String^ value
)

Parameters

value
Type: System..::..String
The string.

See Also

EmitWriter Class
Push Overload
Sitecore.Reflection.Emit Namespace


Push Method (Argument)

[image]

Sitecore 6.4.1 API
EmitWriter..::..Push Method (Argument)
EmitWriter Class See Also Send Feedback

Namespace: Sitecore.Reflection.Emit
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Push(
    Argument argument
)
Visual Basic
Public Sub Push ( _
    argument As Argument _
)
Visual C++
public:
void Push(
    Argument^ argument
)

Parameters

argument
Type: Sitecore.Reflection.Emit..::..Argument
The argument.

See Also

EmitWriter Class
Push Overload
Sitecore.Reflection.Emit Namespace


Push Method (Local)

[image]

Sitecore 6.4.1 API
EmitWriter..::..Push Method (Local)
EmitWriter Class See Also Send Feedback

Namespace: Sitecore.Reflection.Emit
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Push(
    Local local
)
Visual Basic
Public Sub Push ( _
    local As Local _
)
Visual C++
public:
void Push(
    Local^ local
)

Parameters

local
Type: Sitecore.Reflection.Emit..::..Local
The local storage.

See Also

EmitWriter Class
Push Overload
Sitecore.Reflection.Emit Namespace


PushNull Method

[image]

Sitecore 6.4.1 API
EmitWriter..::..PushNull Method
EmitWriter Class See Also Send Feedback

Namespace: Sitecore.Reflection.Emit
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void PushNull()
Visual Basic
Public Sub PushNull
Visual C++
public:
void PushNull()

See Also

EmitWriter Class
Sitecore.Reflection.Emit Namespace


Return Method

[image]

Sitecore 6.4.1 API
EmitWriter..::..Return Method
EmitWriter Class See Also Send Feedback

Namespace: Sitecore.Reflection.Emit
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Return()
Visual Basic
Public Sub Return
Visual C++
public:
void Return()

See Also

EmitWriter Class
Sitecore.Reflection.Emit Namespace


Store Method

[image]

Sitecore 6.4.1 API
EmitWriter..::..Store Method
EmitWriter Class See Also Send Feedback

Namespace: Sitecore.Reflection.Emit
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Store(
    Local local
)
Visual Basic
Public Sub Store ( _
    local As Local _
)
Visual C++
public:
void Store(
    Local^ local
)

Parameters

local
Type: Sitecore.Reflection.Emit..::..Local
The local storage.

See Also

EmitWriter Class
Sitecore.Reflection.Emit Namespace


StoreAndPush Method

[image]

Sitecore 6.4.1 API
EmitWriter..::..StoreAndPush Method
EmitWriter Class See Also Send Feedback

Namespace: Sitecore.Reflection.Emit
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void StoreAndPush(
    Local local
)
Visual Basic
Public Sub StoreAndPush ( _
    local As Local _
)
Visual C++
public:
void StoreAndPush(
    Local^ local
)

Parameters

local
Type: Sitecore.Reflection.Emit..::..Local
The local.

See Also

EmitWriter Class
Sitecore.Reflection.Emit Namespace


ILGenerator Property

[image]

Sitecore 6.4.1 API
EmitWriter..::..ILGenerator Property
EmitWriter Class See Also Send Feedback

Namespace: Sitecore.Reflection.Emit
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ILGenerator ILGenerator { get; }
Visual Basic
Public ReadOnly Property ILGenerator As ILGenerator
    Get
Visual C++
public:
property ILGenerator^ ILGenerator {
    ILGenerator^ get ();
}

Field Value

The generator.

See Also

EmitWriter Class
Sitecore.Reflection.Emit Namespace


Local Class

[image]

Sitecore 6.4.1 API
Local Class
Members See Also Send Feedback

Namespace: Sitecore.Reflection.Emit
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class Local
Visual Basic
Public Class Local
Visual C++
public ref class Local

Inheritance Hierarchy

System..::..Object
Sitecore.Reflection.Emit..::..Local

See Also

Local Members
Sitecore.Reflection.Emit Namespace


Local Members

[image] [image]

Sitecore 6.4.1 API
Local Members
Local Class Constructors Methods Properties See Also Send Feedback

The Local type exposes the following members.

Constructors

 | Name | Description
Public method | Local()()()() | Initializes a new instance of the Local class.
Public method | Local(Int32) | Initializes a new instance of the Local class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Index | Gets or sets the index.
 | Local0 | Gets the local0.
 | Local1 | Gets the local1.
 | Local2 | Gets the local2.
 | Local3 | Gets the local3.

See Also

Local Class
Sitecore.Reflection.Emit Namespace


Local Constructor

[image] [image]

Sitecore 6.4.1 API
Local Constructor
Local Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Local()()()() | Initializes a new instance of the Local class.
Public method | Local(Int32) | Initializes a new instance of the Local class.

See Also

Local Class
Local Members
Sitecore.Reflection.Emit Namespace


Local Constructor

[image]

Sitecore 6.4.1 API
Local Constructor
Local Class See Also Send Feedback

Namespace: Sitecore.Reflection.Emit
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Local()
Visual Basic
Public Sub New
Visual C++
public:
Local()

See Also

Local Class
Local Overload
Sitecore.Reflection.Emit Namespace


Local Constructor (Int32)

[image]

Sitecore 6.4.1 API
Local Constructor (Int32)
Local Class See Also Send Feedback

Namespace: Sitecore.Reflection.Emit
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Local(
    int index
)
Visual Basic
Public Sub New ( _
    index As Integer _
)
Visual C++
public:
Local(
    int index
)

Parameters

index
Type: System..::..Int32
The index.

See Also

Local Class
Local Overload
Sitecore.Reflection.Emit Namespace


Local Methods

[image] [image]

Sitecore 6.4.1 API
Local Methods
Local Class See Also Send Feedback

The Local type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Local Class
Sitecore.Reflection.Emit Namespace


Local Properties

[image] [image]

Sitecore 6.4.1 API
Local Properties
Local Class See Also Send Feedback

The Local type exposes the following members.

Properties

 | Name | Description
Public property | Index | Gets or sets the index.
 | Local0 | Gets the local0.
 | Local1 | Gets the local1.
 | Local2 | Gets the local2.
 | Local3 | Gets the local3.

See Also

Local Class
Sitecore.Reflection.Emit Namespace


Index Property

[image]

Sitecore 6.4.1 API
Local..::..Index Property
Local Class See Also Send Feedback

Namespace: Sitecore.Reflection.Emit
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Index { get; set; }
Visual Basic
Public Property Index As Integer
    Get
    Set
Visual C++
public:
property int Index {
    int get ();
    void set (int value);
}

Field Value

The index.

See Also

Local Class
Sitecore.Reflection.Emit Namespace


Local0 Property

[image]

Sitecore 6.4.1 API
Local..::..Local0 Property
Local Class See Also Send Feedback

Namespace: Sitecore.Reflection.Emit
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Local Local0 { get; }
Visual Basic
Public Shared ReadOnly Property Local0 As Local
    Get
Visual C++
public:
static property Local^ Local0 {
    Local^ get ();
}

Field Value

The local0.

See Also

Local Class
Sitecore.Reflection.Emit Namespace


Local1 Property

[image]

Sitecore 6.4.1 API
Local..::..Local1 Property
Local Class See Also Send Feedback

Namespace: Sitecore.Reflection.Emit
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Local Local1 { get; }
Visual Basic
Public Shared ReadOnly Property Local1 As Local
    Get
Visual C++
public:
static property Local^ Local1 {
    Local^ get ();
}

Field Value

The local1.

See Also

Local Class
Sitecore.Reflection.Emit Namespace


Local2 Property

[image]

Sitecore 6.4.1 API
Local..::..Local2 Property
Local Class See Also Send Feedback

Namespace: Sitecore.Reflection.Emit
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Local Local2 { get; }
Visual Basic
Public Shared ReadOnly Property Local2 As Local
    Get
Visual C++
public:
static property Local^ Local2 {
    Local^ get ();
}

Field Value

The local2.

See Also

Local Class
Sitecore.Reflection.Emit Namespace


Local3 Property

[image]

Sitecore 6.4.1 API
Local..::..Local3 Property
Local Class See Also Send Feedback

Namespace: Sitecore.Reflection.Emit
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Local Local3 { get; }
Visual Basic
Public Shared ReadOnly Property Local3 As Local
    Get
Visual C++
public:
static property Local^ Local3 {
    Local^ get ();
}

Field Value

The local3.

See Also

Local Class
Sitecore.Reflection.Emit Namespace


Sitecore.Research Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Research Namespace
Send Feedback

Classes

 | Class | Description
Public class | MyControl | Represents a MyControl.
Public class | MyControlBuilder | Represents a MyControlBuilder.


MyControl Class

[image]

Sitecore 6.4.1 API
MyControl Class
Members See Also Send Feedback

Namespace: Sitecore.Research
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class MyControl : UserControl
Visual Basic
Public Class MyControl _
    Inherits UserControl
Visual C++
public ref class MyControl : public UserControl

Inheritance Hierarchy

System..::..Object
System.Web.UI..::..Control
System.Web.UI..::..TemplateControl
System.Web.UI..::..UserControl
Sitecore.Research..::..MyControl
Sitecore.Shell.Research..::..Testontrol

See Also

MyControl Members
Sitecore.Research Namespace


MyControl Members

[image] [image]

Sitecore 6.4.1 API
MyControl Members
MyControl Class Constructors Methods Properties Events See Also Send Feedback

The MyControl type exposes the following members.

Constructors

 | Name | Description
Public method | MyControl | Initializes a new instance of the MyControl class

Methods

 | Name | Description
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Overrides Control..::..AddParsedSubObject(Object).)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Protected method | Construct | Performs design-time logic. (Inherited from TemplateControl.)
Protected method | CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Overrides Control..::..CreateChildControls()()()().)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Overrides Control..::..CreateControlCollection()()()().)
Protected method | CreateResourceBasedLiteralControl | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Public method | DesignerInitialize | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
Protected method | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | FrameworkInitialize | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Protected method | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
Protected method | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
Protected method | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Public method | InitializeAsUserControl | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Public method | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
Public method | LoadControl(Type, array<Object>[]()[][]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
Public method | LoadTemplate | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
Protected method | LoadViewState | Restores the view-state information from a previous user control request that was saved by the SaveViewState()()()() method. (Inherited from UserControl.)
Public method | MapPath | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAbortTransaction | Raises the AbortTransaction event. (Inherited from TemplateControl.)
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnCommitTransaction | Raises the CommitTransaction event. (Inherited from TemplateControl.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnError | Raises the Error event. (Inherited from TemplateControl.)
Protected method | OnInit | Raises the Init event. (Inherited from UserControl.)
Protected method | OnLoad | Raises the Load event. (Inherited from Control.)
Protected method | OnPreRender | Raises the PreRender event. (Inherited from Control.)
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Public method | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
Public method | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Public method | ReadStringResource | Reads a string resource. The ReadStringResource()()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
Protected method | RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Protected method | Render | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SaveViewState | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Protected method | SetStringResourcePointer | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | TestDeviceFilter | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TrackViewState | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
Protected method | WriteUTF8ResourceString | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
Protected method | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
Protected method | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
Protected method | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
Protected method | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
Protected method | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Protected method | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)

Properties

 | Name | Description
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
Public property | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
Protected property | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
Public property | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Protected property | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Public property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Public property | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
Public property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Public property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
Protected property | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Public property | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
Public property | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
Public property | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
Public property | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
Public property | Session | Gets the HttpSessionState object for the current Web request. (Inherited from UserControl.)
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
Protected property | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
Public property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)

Events

 | Name | Description
Public event | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
Public event | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

See Also

MyControl Class
Sitecore.Research Namespace


MyControl Constructor

[image]

Sitecore 6.4.1 API
MyControl Constructor
MyControl Class See Also Send Feedback

Namespace: Sitecore.Research
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MyControl()
Visual Basic
Public Sub New
Visual C++
public:
MyControl()

See Also

MyControl Class
Sitecore.Research Namespace


MyControl Methods

[image] [image]

Sitecore 6.4.1 API
MyControl Methods
MyControl Class See Also Send Feedback

The MyControl type exposes the following members.

Methods

 | Name | Description
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Overrides Control..::..AddParsedSubObject(Object).)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Protected method | Construct | Performs design-time logic. (Inherited from TemplateControl.)
Protected method | CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Overrides Control..::..CreateChildControls()()()().)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Overrides Control..::..CreateControlCollection()()()().)
Protected method | CreateResourceBasedLiteralControl | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Public method | DesignerInitialize | Performs any initialization steps on the user control that are required by RAD designers. (Inherited from UserControl.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
Protected method | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | FrameworkInitialize | Initializes the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Protected method | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
Protected method | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
Protected method | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Public method | InitializeAsUserControl | Initializes the UserControl object that has been created declaratively. Since there are some differences between pages and user controls, this method makes sure that the user control is initialized properly. (Inherited from UserControl.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Public method | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
Public method | LoadControl(Type, array<Object>[]()[][]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
Public method | LoadTemplate | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
Protected method | LoadViewState | Restores the view-state information from a previous user control request that was saved by the SaveViewState()()()() method. (Inherited from UserControl.)
Public method | MapPath | Assigns a virtual file path, either absolute or relative, to a physical file path. (Inherited from UserControl.)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAbortTransaction | Raises the AbortTransaction event. (Inherited from TemplateControl.)
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnCommitTransaction | Raises the CommitTransaction event. (Inherited from TemplateControl.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnError | Raises the Error event. (Inherited from TemplateControl.)
Protected method | OnInit | Raises the Init event. (Inherited from UserControl.)
Protected method | OnLoad | Raises the Load event. (Inherited from Control.)
Protected method | OnPreRender | Raises the PreRender event. (Inherited from Control.)
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Public method | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
Public method | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Public method | ReadStringResource | Reads a string resource. The ReadStringResource()()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
Protected method | RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Protected method | Render | Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SaveViewState | Saves any user control view-state changes that have occurred since the last page postback. (Inherited from UserControl.)
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Protected method | SetStringResourcePointer | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | TestDeviceFilter | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TrackViewState | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
Protected method | WriteUTF8ResourceString | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
Protected method | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
Protected method | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
Protected method | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
Protected method | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
Protected method | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Protected method | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)

See Also

MyControl Class
Sitecore.Research Namespace


AddParsedSubObject Method

[image]

Sitecore 6.4.1 API
MyControl..::..AddParsedSubObject Method
MyControl Class See Also Send Feedback

Namespace: Sitecore.Research
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void AddParsedSubObject(
    Object obj
)
Visual Basic
Protected Overrides Sub AddParsedSubObject ( _
    obj As Object _
)
Visual C++
protected:
virtual void AddParsedSubObject(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
An Object that represents the parsed element.

See Also

MyControl Class
Sitecore.Research Namespace


CreateChildControls Method

[image]

Sitecore 6.4.1 API
MyControl..::..CreateChildControls Method
MyControl Class See Also Send Feedback

Namespace: Sitecore.Research
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void CreateChildControls()
Visual Basic
Protected Overrides Sub CreateChildControls
Visual C++
protected:
virtual void CreateChildControls() override

See Also

MyControl Class
Sitecore.Research Namespace


CreateControlCollection Method

[image]

Sitecore 6.4.1 API
MyControl..::..CreateControlCollection Method
MyControl Class See Also Send Feedback

Namespace: Sitecore.Research
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override ControlCollection CreateControlCollection()
Visual Basic
Protected Overrides Function CreateControlCollection As ControlCollection
Visual C++
protected:
virtual ControlCollection^ CreateControlCollection() override

Return Value

A ControlCollection object to contain the current server control's child server controls.

See Also

MyControl Class
Sitecore.Research Namespace


DataBind Method

[image] [image]

Sitecore 6.4.1 API
MyControl..::..DataBind Method
MyControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)

See Also

MyControl Class
MyControl Members
Sitecore.Research Namespace


Eval Method

[image] [image]

Sitecore 6.4.1 API
MyControl..::..Eval Method
MyControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
Protected method | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)

See Also

MyControl Class
MyControl Members
Sitecore.Research Namespace


FindControl Method

[image] [image]

Sitecore 6.4.1 API
MyControl..::..FindControl Method
MyControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)

See Also

MyControl Class
MyControl Members
Sitecore.Research Namespace


GetGlobalResourceObject Method

[image] [image]

Sitecore 6.4.1 API
MyControl..::..GetGlobalResourceObject Method
MyControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
Protected method | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)

See Also

MyControl Class
MyControl Members
Sitecore.Research Namespace


GetLocalResourceObject Method

[image] [image]

Sitecore 6.4.1 API
MyControl..::..GetLocalResourceObject Method
MyControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
Protected method | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)

See Also

MyControl Class
MyControl Members
Sitecore.Research Namespace


LoadControl Method

[image] [image]

Sitecore 6.4.1 API
MyControl..::..LoadControl Method
MyControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
Public method | LoadControl(Type, array<Object>[]()[][]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)

See Also

MyControl Class
MyControl Members
Sitecore.Research Namespace


ParseControl Method

[image] [image]

Sitecore 6.4.1 API
MyControl..::..ParseControl Method
MyControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
Public method | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)

See Also

MyControl Class
MyControl Members
Sitecore.Research Namespace


RenderControl Method

[image] [image]

Sitecore 6.4.1 API
MyControl..::..RenderControl Method
MyControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)

See Also

MyControl Class
MyControl Members
Sitecore.Research Namespace


XPath Method

[image] [image]

Sitecore 6.4.1 API
MyControl..::..XPath Method
MyControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
Protected method | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
Protected method | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
Protected method | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)

See Also

MyControl Class
MyControl Members
Sitecore.Research Namespace


XPathSelect Method

[image] [image]

Sitecore 6.4.1 API
MyControl..::..XPathSelect Method
MyControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Protected method | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)

See Also

MyControl Class
MyControl Members
Sitecore.Research Namespace


MyControl Properties

[image] [image]

Sitecore 6.4.1 API
MyControl Properties
MyControl Class See Also Send Feedback

The MyControl type exposes the following members.

Properties

 | Name | Description
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | Application | Gets the Application object for the current Web request. (Inherited from UserControl.)
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
Public property | Attributes | Gets a collection of all attribute name and value pairs declared in the user control tag within the .aspx file. (Inherited from UserControl.)
Protected property | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | Cache | Gets the Cache object that is associated with the application that contains the user control. (Inherited from UserControl.)
Public property | CachePolicy | Gets a reference to a collection of caching parameters for this user control. (Inherited from UserControl.)
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Protected property | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Public property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Public property | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
Public property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Public property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
Protected property | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Public property | IsPostBack | Gets a value indicating whether the user control is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from UserControl.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
Public property | Request | Gets the HttpRequest object for the current Web request. (Inherited from UserControl.)
Public property | Response | Gets the HttpResponse object for the current Web request. (Inherited from UserControl.)
Public property | Server | Gets the HttpServerUtility object for the current Web request. (Inherited from UserControl.)
Public property | Session | Gets the HttpSessionState object for the current Web request. (Inherited from UserControl.)
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
Protected property | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | Trace | Gets the TraceContext object for the current Web request. (Inherited from UserControl.)
Public property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)

See Also

MyControl Class
Sitecore.Research Namespace


MyControl Events

[image] [image]

Sitecore 6.4.1 API
MyControl Events
MyControl Class See Also Send Feedback

The MyControl type exposes the following members.

Events

 | Name | Description
Public event | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
Public event | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

See Also

MyControl Class
Sitecore.Research Namespace


MyControlBuilder Class

[image]

Sitecore 6.4.1 API
MyControlBuilder Class
Members See Also Send Feedback

Namespace: Sitecore.Research
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class MyControlBuilder : FileLevelUserControlBuilder
Visual Basic
Public Class MyControlBuilder _
    Inherits FileLevelUserControlBuilder
Visual C++
public ref class MyControlBuilder : public FileLevelUserControlBuilder

Inheritance Hierarchy

System..::..Object
System.Web.UI..::..ControlBuilder
System.Web.UI..::..TemplateBuilder
System.Web.UI..::..RootBuilder
System.Web.UI..::..FileLevelUserControlBuilder
Sitecore.Research..::..MyControlBuilder

See Also

MyControlBuilder Members
Sitecore.Research Namespace


MyControlBuilder Members

[image] [image]

Sitecore 6.4.1 API
MyControlBuilder Members
MyControlBuilder Class Constructors Methods Properties See Also Send Feedback

The MyControlBuilder type exposes the following members.

Constructors

 | Name | Description
Public method | MyControlBuilder | Initializes a new instance of the MyControlBuilder class

Methods

 | Name | Description
Public method | AllowWhitespaceLiterals | Determines whether white space literals are permitted in the content between a control's opening and closing tags. This method is called by the ASP.NET page framework. (Inherited from ControlBuilder.)
Public method | AppendLiteralString | Adds the specified literal content to a control. This method is called by the ASP.NET page framework. (Inherited from ControlBuilder.)
Public method | AppendSubBuilder | Adds builders to the ControlBuilder object for any child controls that belong to the container control. (Inherited from ControlBuilder.)
Public method | BuildObject | Used during design time to build the template and its child controls. (Overrides TemplateBuilder..::..BuildObject()()()().)
Public method | CloseControl | Called by the parser to inform the builder that the parsing of the control's opening and closing tags is complete. (Inherited from TemplateBuilder.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChildControlType | Returns the control type of any parsed child controls. (Inherited from RootBuilder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectPersistData | Creates the ObjectPersistData object for this ControlBuilder object. (Inherited from ControlBuilder.)
Public method | GetResourceKey | Retrieves the resource key for this ControlBuilder object. (Inherited from ControlBuilder.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasBody | Determines if a control has both an opening and closing tag. This method is called by the ASP.NET page framework. (Inherited from ControlBuilder.)
Public method | HtmlDecodeLiterals | Determines whether the literal string of an HTML control must be HTML decoded. This method is called by the ASP.NET page framework. (Inherited from ControlBuilder.)
Public method | Init | Initializes the template builder when a Web request is made. (Overrides TemplateBuilder..::..Init(TemplateParser, ControlBuilder, Type, String, String, IDictionary).)
Public method | InstantiateIn | Defines the Control object that child controls and templates belong to in design time. (Inherited from TemplateBuilder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NeedsTagInnerText | Determines if the control builder needs to get its inner text. (Inherited from TemplateBuilder.)
Public method | OnAppendToParentBuilder | Notifies the ControlBuilder that it is being added to a parent control builder. (Inherited from ControlBuilder.)
Public method | ProcessGeneratedCode | Enables custom control builders to access the generated Code Document Object Model (CodeDom) and insert and modify code during the process of parsing and building controls. (Inherited from ControlBuilder.)
Public method | SetResourceKey | Sets the resource key for this ControlBuilder object. (Inherited from ControlBuilder.)
Public method | SetServiceProvider | Sets the service object for this ControlBuilder object. (Inherited from ControlBuilder.)
Public method | SetTagInnerText | Saves the inner text of the template tag. (Inherited from TemplateBuilder.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BindingContainerType | Gets the type of the binding container for the control that this builder creates. (Inherited from ControlBuilder.)
Public property | BuiltObjects | Gets a collection of the objects built by the root builder to be persisted. (Inherited from RootBuilder.)
Public property | ControlType | Gets the Type for the control to be created. (Inherited from ControlBuilder.)
Public property | CurrentFilterResolutionService | Gets an IFilterResolutionService object that is used to manage device-filter related services when parsing and persisting controls in the designer. (Inherited from ControlBuilder.)
Public property | DeclareType | Gets the type that will be used by code generation to declare the control. (Inherited from ControlBuilder.)
Protected property | FChildrenAsProperties | Determines whether the control has a ParseChildrenAttribute with ChildrenAsProperties set to true. (Inherited from ControlBuilder.)
Protected property | FIsNonParserAccessor | Determines whether the control implements the IParserAccessor interface. (Inherited from ControlBuilder.)
Public property | HasAspCode | Gets a value indicating whether the control contains any code blocks. (Inherited from ControlBuilder.)
Public property | ID | Gets or sets the identifier property for the control to be built. (Inherited from ControlBuilder.)
Protected property | InDesigner | Returns whether the ControlBuilder is running in the designer. (Inherited from ControlBuilder.)
Protected property | InPageTheme | Gets a Boolean value indicating whether this ControlBuilder object is used to generate page themes. (Inherited from ControlBuilder.)
Public property | Localize | Gets a Boolean value indicating whether the control that is created by this ControlBuilder object is localized. (Inherited from ControlBuilder.)
Public property | NamingContainerType | Gets the type of the naming container for the control that this builder creates. (Inherited from ControlBuilder.)
Protected property | Parser | Gets the TemplateParser responsible for parsing the control. (Inherited from ControlBuilder.)
Public property | ServiceProvider | Gets the service object for this ControlBuilder object. (Inherited from ControlBuilder.)
Public property | TagName | Gets the tag name for the control to be built. (Inherited from ControlBuilder.)
Public property | Text | Gets or sets the text between the opening and closing tags of the template. (Overrides TemplateBuilder..::..Text.)
Public property | ThemeResolutionService | Gets an IThemeResolutionService object that is used in design time to manage control themes and skins. (Inherited from ControlBuilder.)

See Also

MyControlBuilder Class
Sitecore.Research Namespace


MyControlBuilder Constructor

[image]

Sitecore 6.4.1 API
MyControlBuilder Constructor
MyControlBuilder Class See Also Send Feedback

Namespace: Sitecore.Research
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MyControlBuilder()
Visual Basic
Public Sub New
Visual C++
public:
MyControlBuilder()

See Also

MyControlBuilder Class
Sitecore.Research Namespace


MyControlBuilder Methods

[image] [image]

Sitecore 6.4.1 API
MyControlBuilder Methods
MyControlBuilder Class See Also Send Feedback

The MyControlBuilder type exposes the following members.

Methods

 | Name | Description
Public method | AllowWhitespaceLiterals | Determines whether white space literals are permitted in the content between a control's opening and closing tags. This method is called by the ASP.NET page framework. (Inherited from ControlBuilder.)
Public method | AppendLiteralString | Adds the specified literal content to a control. This method is called by the ASP.NET page framework. (Inherited from ControlBuilder.)
Public method | AppendSubBuilder | Adds builders to the ControlBuilder object for any child controls that belong to the container control. (Inherited from ControlBuilder.)
Public method | BuildObject | Used during design time to build the template and its child controls. (Overrides TemplateBuilder..::..BuildObject()()()().)
Public method | CloseControl | Called by the parser to inform the builder that the parsing of the control's opening and closing tags is complete. (Inherited from TemplateBuilder.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChildControlType | Returns the control type of any parsed child controls. (Inherited from RootBuilder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectPersistData | Creates the ObjectPersistData object for this ControlBuilder object. (Inherited from ControlBuilder.)
Public method | GetResourceKey | Retrieves the resource key for this ControlBuilder object. (Inherited from ControlBuilder.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasBody | Determines if a control has both an opening and closing tag. This method is called by the ASP.NET page framework. (Inherited from ControlBuilder.)
Public method | HtmlDecodeLiterals | Determines whether the literal string of an HTML control must be HTML decoded. This method is called by the ASP.NET page framework. (Inherited from ControlBuilder.)
Public method | Init | Initializes the template builder when a Web request is made. (Overrides TemplateBuilder..::..Init(TemplateParser, ControlBuilder, Type, String, String, IDictionary).)
Public method | InstantiateIn | Defines the Control object that child controls and templates belong to in design time. (Inherited from TemplateBuilder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NeedsTagInnerText | Determines if the control builder needs to get its inner text. (Inherited from TemplateBuilder.)
Public method | OnAppendToParentBuilder | Notifies the ControlBuilder that it is being added to a parent control builder. (Inherited from ControlBuilder.)
Public method | ProcessGeneratedCode | Enables custom control builders to access the generated Code Document Object Model (CodeDom) and insert and modify code during the process of parsing and building controls. (Inherited from ControlBuilder.)
Public method | SetResourceKey | Sets the resource key for this ControlBuilder object. (Inherited from ControlBuilder.)
Public method | SetServiceProvider | Sets the service object for this ControlBuilder object. (Inherited from ControlBuilder.)
Public method | SetTagInnerText | Saves the inner text of the template tag. (Inherited from TemplateBuilder.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MyControlBuilder Class
Sitecore.Research Namespace


BuildObject Method

[image]

Sitecore 6.4.1 API
MyControlBuilder..::..BuildObject Method
MyControlBuilder Class See Also Send Feedback

Namespace: Sitecore.Research
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Object BuildObject()
Visual Basic
Public Overrides Function BuildObject As Object
Visual C++
public:
virtual Object^ BuildObject() override

Return Value

A reference to the instance of the TemplateBuilder class.

See Also

MyControlBuilder Class
Sitecore.Research Namespace


Init Method

[image]

Sitecore 6.4.1 API
MyControlBuilder..::..Init Method
MyControlBuilder Class See Also Send Feedback

Namespace: Sitecore.Research
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void Init(
    TemplateParser parser,
    ControlBuilder parentBuilder,
    Type type,
    string tagName,
    string ID,
    IDictionary attribs
)
Visual Basic
Public Overrides Sub Init ( _
    parser As TemplateParser, _
    parentBuilder As ControlBuilder, _
    type As Type, _
    tagName As String, _
    ID As String, _
    attribs As IDictionary _
)
Visual C++
public:
virtual void Init(
    TemplateParser^ parser,
    ControlBuilder^ parentBuilder,
    Type^ type,
    String^ tagName,
    String^ ID,
    IDictionary^ attribs
) override

Parameters

parser
Type: System.Web.UI..::..TemplateParser
The TemplateParser responsible for parsing the control.
parentBuilder
Type: System.Web.UI..::..ControlBuilder
The ControlBuilder responsible for building the control.
type
Type: System..::..Type
The Type assigned to the control that the builder will create.
tagName
Type: System..::..String
The name of the tag to build. This allows the builder to support multiple tag types.
ID
Type: System..::..String
The ID assigned to the control.
attribs
Type: System.Collections..::..IDictionary
The IDictionary that holds all the specified tag attributes.

See Also

MyControlBuilder Class
Sitecore.Research Namespace


MyControlBuilder Properties

[image] [image]

Sitecore 6.4.1 API
MyControlBuilder Properties
MyControlBuilder Class See Also Send Feedback

The MyControlBuilder type exposes the following members.

Properties

 | Name | Description
Public property | BindingContainerType | Gets the type of the binding container for the control that this builder creates. (Inherited from ControlBuilder.)
Public property | BuiltObjects | Gets a collection of the objects built by the root builder to be persisted. (Inherited from RootBuilder.)
Public property | ControlType | Gets the Type for the control to be created. (Inherited from ControlBuilder.)
Public property | CurrentFilterResolutionService | Gets an IFilterResolutionService object that is used to manage device-filter related services when parsing and persisting controls in the designer. (Inherited from ControlBuilder.)
Public property | DeclareType | Gets the type that will be used by code generation to declare the control. (Inherited from ControlBuilder.)
Protected property | FChildrenAsProperties | Determines whether the control has a ParseChildrenAttribute with ChildrenAsProperties set to true. (Inherited from ControlBuilder.)
Protected property | FIsNonParserAccessor | Determines whether the control implements the IParserAccessor interface. (Inherited from ControlBuilder.)
Public property | HasAspCode | Gets a value indicating whether the control contains any code blocks. (Inherited from ControlBuilder.)
Public property | ID | Gets or sets the identifier property for the control to be built. (Inherited from ControlBuilder.)
Protected property | InDesigner | Returns whether the ControlBuilder is running in the designer. (Inherited from ControlBuilder.)
Protected property | InPageTheme | Gets a Boolean value indicating whether this ControlBuilder object is used to generate page themes. (Inherited from ControlBuilder.)
Public property | Localize | Gets a Boolean value indicating whether the control that is created by this ControlBuilder object is localized. (Inherited from ControlBuilder.)
Public property | NamingContainerType | Gets the type of the naming container for the control that this builder creates. (Inherited from ControlBuilder.)
Protected property | Parser | Gets the TemplateParser responsible for parsing the control. (Inherited from ControlBuilder.)
Public property | ServiceProvider | Gets the service object for this ControlBuilder object. (Inherited from ControlBuilder.)
Public property | TagName | Gets the tag name for the control to be built. (Inherited from ControlBuilder.)
Public property | Text | Gets or sets the text between the opening and closing tags of the template. (Overrides TemplateBuilder..::..Text.)
Public property | ThemeResolutionService | Gets an IThemeResolutionService object that is used in design time to manage control themes and skins. (Inherited from ControlBuilder.)

See Also

MyControlBuilder Class
Sitecore.Research Namespace


Text Property

[image]

Sitecore 6.4.1 API
MyControlBuilder..::..Text Property
MyControlBuilder Class See Also Send Feedback

Namespace: Sitecore.Research
Assembly: Sitecore.Client (in Sitecore.Client.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string Text { get; set; }
Visual Basic
Public Overrides Property Text As String
    Get
    Set
Visual C++
public:
virtual property String^ Text {
    String^ get () override;
    void set (String^ value) override;
}

Field Value

Return Value

The text that appears between the opening and closing tags of the template.

See Also

MyControlBuilder Class
Sitecore.Research Namespace


Sitecore.Resources Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Resources Namespace
Send Feedback

Classes

 | Class | Description
Public class | FileIcon | Extracts an icon from a file.
Public class | ImageBuilder | Builds image HTML tags.
Public class | Images | Provides methods for building image Html tags.
Public class | Resource | Creates resources.
Public class | ResourceContext | Specifies the current resource context.
Public class | ResourceItems | ResourceItems
Public class | ResourceUri | Represents an Uri to a resource.
Public class | Themes | Provides simple theming capabilities.
Public class | ZippedIcon | Defines the zipped icon class.


FileIcon Class

[image]

Sitecore 6.4.1 API
FileIcon Class
Members See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public sealed class FileIcon
Visual Basic
Public NotInheritable Class FileIcon
Visual C++
public ref class FileIcon sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Resources..::..FileIcon

See Also

FileIcon Members
Sitecore.Resources Namespace


FileIcon Members

[image] [image]

Sitecore 6.4.1 API
FileIcon Members
FileIcon Class Methods See Also Send Feedback

The FileIcon type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExtractIcon | Extracts the icon.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFileIcon(String, ImageDimension) | Gets the file icon.
 | GetFileIcon(String, Int32, Int32, Color) | Gets the icon.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileIcon Class
Sitecore.Resources Namespace


FileIcon Methods

[image] [image]

Sitecore 6.4.1 API
FileIcon Methods
FileIcon Class See Also Send Feedback

The FileIcon type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExtractIcon | Extracts the icon.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFileIcon(String, ImageDimension) | Gets the file icon.
 | GetFileIcon(String, Int32, Int32, Color) | Gets the icon.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileIcon Class
Sitecore.Resources Namespace


ExtractIcon Method

[image]

Sitecore 6.4.1 API
FileIcon..::..ExtractIcon Method
FileIcon Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Icon ExtractIcon(
    string extension,
    int dimension
)
Visual Basic
Public Shared Function ExtractIcon ( _
    extension As String, _
    dimension As Integer _
) As Icon
Visual C++
public:
static Icon^ ExtractIcon(
    String^ extension,
    int dimension
)

Parameters

extension
Type: System..::..String
The extension.
dimension
Type: System..::..Int32
The dimension.

Return Value

[Missing <returns> documentation for "M:Sitecore.Resources.FileIcon.ExtractIcon(System.String,System.Int32)"]

See Also

FileIcon Class
Sitecore.Resources Namespace


GetFileIcon Method

[image] [image]

Sitecore 6.4.1 API
FileIcon..::..GetFileIcon Method
FileIcon Class See Also Send Feedback

Overload List

Name | Description
GetFileIcon(String, ImageDimension) | Gets the file icon.
GetFileIcon(String, Int32, Int32, Color) | Gets the icon.

See Also

FileIcon Class
FileIcon Members
Sitecore.Resources Namespace


GetFileIcon Method (String, ImageDimension)

[image]

Sitecore 6.4.1 API
FileIcon..::..GetFileIcon Method (String, ImageDimension)
FileIcon Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetFileIcon(
    string filename,
    ImageDimension dimension
)
Visual Basic
Public Shared Function GetFileIcon ( _
    filename As String, _
    dimension As ImageDimension _
) As String
Visual C++
public:
static String^ GetFileIcon(
    String^ filename,
    ImageDimension dimension
)

Parameters

filename
Type: System..::..String
The filename.
dimension
Type: Sitecore.Web.UI..::..ImageDimension
The dimension.

Return Value

[Missing <returns> documentation for "M:Sitecore.Resources.FileIcon.GetFileIcon(System.String,Sitecore.Web.UI.ImageDimension)"]

See Also

FileIcon Class
GetFileIcon Overload
Sitecore.Resources Namespace


ImageBuilder Class

[image]

Sitecore 6.4.1 API
ImageBuilder Class
Members See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ImageBuilder
Visual Basic
Public Class ImageBuilder
Visual C++
public ref class ImageBuilder

Inheritance Hierarchy

System..::..Object
Sitecore.Resources..::..ImageBuilder

See Also

ImageBuilder Members
Sitecore.Resources Namespace


ImageBuilder Members

[image] [image]

Sitecore 6.4.1 API
ImageBuilder Members
ImageBuilder Class Constructors Methods Properties See Also Send Feedback

The ImageBuilder type exposes the following members.

Constructors

 | Name | Description
Public method | ImageBuilder | Initializes a new instance of the ImageBuilder class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetThemedSrc()()()() | Gets the themed source.
Public method | GetThemedSrc(Int32, Int32) | Gets the themed source.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Render | Renders the image to the specified output.
 | ResizeImageSrc | Resizes the image source.
Public method | ToString()()()() | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)
Public method | ToString(HtmlTextWriter) | Converts the ImageBuilder to a String.

Properties

 | Name | Description
Public property | Align | Gets or sets the align.
Public property | Alt | Gets or sets the alt text.
Public property | Attributes | Gets the attributes.
Public property | Border | Gets or sets the border.
Public property | Class | Gets or sets the class.
Public property | Disabled | Gets or sets a value indicating whether this ImageBuilder is disabled.
Public property | Float | Gets or sets the float style.
Public property | Height | Gets or sets the height.
Public property | ID | Gets or sets the ID.
Public property | Margin | Gets or sets the margin.
Public property | OnClick | Gets or sets the click event.
Public property | OnContextMenu | Gets or sets the on context menu.
Public property | OnDblClick | Gets or sets the double click event.
Public property | Overlay | Gets or sets the overlay.
Public property | Resize | Gets or sets a value indicating whether the image is resized.
Public property | RollOver | Gets or sets a value indicating whether the image has a roll over effect.
 | SizeRegex | Gets the size regex.
Public property | Src | Gets or sets the source.
Public property | Style | Gets or sets the style.
Public property | Title | Gets or sets the title.
Public property | Usemap | Gets or sets the image map.
Public property | Width | Gets or sets the width.

See Also

ImageBuilder Class
Sitecore.Resources Namespace


ImageBuilder Constructor

[image]

Sitecore 6.4.1 API
ImageBuilder Constructor
ImageBuilder Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ImageBuilder()
Visual Basic
Public Sub New
Visual C++
public:
ImageBuilder()

See Also

ImageBuilder Class
Sitecore.Resources Namespace


ImageBuilder Methods

[image] [image]

Sitecore 6.4.1 API
ImageBuilder Methods
ImageBuilder Class See Also Send Feedback

The ImageBuilder type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetThemedSrc()()()() | Gets the themed source.
Public method | GetThemedSrc(Int32, Int32) | Gets the themed source.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Render | Renders the image to the specified output.
 | ResizeImageSrc | Resizes the image source.
Public method | ToString()()()() | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)
Public method | ToString(HtmlTextWriter) | Converts the ImageBuilder to a String.

See Also

ImageBuilder Class
Sitecore.Resources Namespace


GetThemedSrc Method

[image] [image]

Sitecore 6.4.1 API
ImageBuilder..::..GetThemedSrc Method
ImageBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetThemedSrc()()()() | Gets the themed source.
Public method | GetThemedSrc(Int32, Int32) | Gets the themed source.

See Also

ImageBuilder Class
ImageBuilder Members
Sitecore.Resources Namespace


GetThemedSrc Method

[image]

Sitecore 6.4.1 API
ImageBuilder..::..GetThemedSrc Method
ImageBuilder Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string GetThemedSrc()
Visual Basic
Public Function GetThemedSrc As String
Visual C++
public:
String^ GetThemedSrc()

Return Value

The get themed source.

See Also

ImageBuilder Class
GetThemedSrc Overload
Sitecore.Resources Namespace


Render Method

[image]

Sitecore 6.4.1 API
ImageBuilder..::..Render Method
ImageBuilder Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Render(
    HtmlTextWriter output
)
Visual Basic
Public Sub Render ( _
    output As HtmlTextWriter _
)
Visual C++
public:
void Render(
    HtmlTextWriter^ output
)

Parameters

output
Type: System.Web.UI..::..HtmlTextWriter
The output.

See Also

ImageBuilder Class
Sitecore.Resources Namespace


ResizeImageSrc Method

[image]

Sitecore 6.4.1 API
ImageBuilder..::..ResizeImageSrc Method
ImageBuilder Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string ResizeImageSrc(
    string src,
    int width,
    int height
)
Visual Basic
Public Shared Function ResizeImageSrc ( _
    src As String, _
    width As Integer, _
    height As Integer _
) As String
Visual C++
public:
static String^ ResizeImageSrc(
    String^ src,
    int width,
    int height
)

Parameters

src
Type: System..::..String
The image source.
width
Type: System..::..Int32
The width.
height
Type: System..::..Int32
The height.

Return Value

The resize image source.

See Also

ImageBuilder Class
Sitecore.Resources Namespace


ToString Method

[image] [image]

Sitecore 6.4.1 API
ImageBuilder..::..ToString Method
ImageBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)
Public method | ToString(HtmlTextWriter) | Converts the ImageBuilder to a String.

See Also

ImageBuilder Class
ImageBuilder Members
Sitecore.Resources Namespace


ToString Method

[image]

Sitecore 6.4.1 API
ImageBuilder..::..ToString Method
ImageBuilder Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

ImageBuilder Class
ToString Overload
Sitecore.Resources Namespace


ToString Method (HtmlTextWriter)

[image]

Sitecore 6.4.1 API
ImageBuilder..::..ToString Method (HtmlTextWriter)
ImageBuilder Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void ToString(
    HtmlTextWriter writer
)
Visual Basic
Public Sub ToString ( _
    writer As HtmlTextWriter _
)
Visual C++
public:
void ToString(
    HtmlTextWriter^ writer
)

Parameters

writer
Type: System.Web.UI..::..HtmlTextWriter
The writer.

See Also

ImageBuilder Class
ToString Overload
Sitecore.Resources Namespace


ImageBuilder Properties

[image] [image]

Sitecore 6.4.1 API
ImageBuilder Properties
ImageBuilder Class See Also Send Feedback

The ImageBuilder type exposes the following members.

Properties

 | Name | Description
Public property | Align | Gets or sets the align.
Public property | Alt | Gets or sets the alt text.
Public property | Attributes | Gets the attributes.
Public property | Border | Gets or sets the border.
Public property | Class | Gets or sets the class.
Public property | Disabled | Gets or sets a value indicating whether this ImageBuilder is disabled.
Public property | Float | Gets or sets the float style.
Public property | Height | Gets or sets the height.
Public property | ID | Gets or sets the ID.
Public property | Margin | Gets or sets the margin.
Public property | OnClick | Gets or sets the click event.
Public property | OnContextMenu | Gets or sets the on context menu.
Public property | OnDblClick | Gets or sets the double click event.
Public property | Overlay | Gets or sets the overlay.
Public property | Resize | Gets or sets a value indicating whether the image is resized.
Public property | RollOver | Gets or sets a value indicating whether the image has a roll over effect.
 | SizeRegex | Gets the size regex.
Public property | Src | Gets or sets the source.
Public property | Style | Gets or sets the style.
Public property | Title | Gets or sets the title.
Public property | Usemap | Gets or sets the image map.
Public property | Width | Gets or sets the width.

See Also

ImageBuilder Class
Sitecore.Resources Namespace


Align Property

[image]

Sitecore 6.4.1 API
ImageBuilder..::..Align Property
ImageBuilder Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Align { get; set; }
Visual Basic
Public Property Align As String
    Get
    Set
Visual C++
public:
property String^ Align {
    String^ get ();
    void set (String^ value);
}

Field Value

The align.

See Also

ImageBuilder Class
Sitecore.Resources Namespace


Alt Property

[image]

Sitecore 6.4.1 API
ImageBuilder..::..Alt Property
ImageBuilder Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Alt { get; set; }
Visual Basic
Public Property Alt As String
    Get
    Set
Visual C++
public:
property String^ Alt {
    String^ get ();
    void set (String^ value);
}

Field Value

The alt text.

See Also

ImageBuilder Class
Sitecore.Resources Namespace


Attributes Property

[image]

Sitecore 6.4.1 API
ImageBuilder..::..Attributes Property
ImageBuilder Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public NameValueCollection Attributes { get; }
Visual Basic
Public ReadOnly Property Attributes As NameValueCollection
    Get
Visual C++
public:
property NameValueCollection^ Attributes {
    NameValueCollection^ get ();
}

Field Value

The attributes.

See Also

ImageBuilder Class
Sitecore.Resources Namespace


Border Property

[image]

Sitecore 6.4.1 API
ImageBuilder..::..Border Property
ImageBuilder Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Border { get; set; }
Visual Basic
Public Property Border As String
    Get
    Set
Visual C++
public:
property String^ Border {
    String^ get ();
    void set (String^ value);
}

Field Value

The border.

See Also

ImageBuilder Class
Sitecore.Resources Namespace


Class Property

[image]

Sitecore 6.4.1 API
ImageBuilder..::..Class Property
ImageBuilder Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Class { get; set; }
Visual Basic
Public Property Class As String
    Get
    Set
Visual C++
public:
property String^ Class {
    String^ get ();
    void set (String^ value);
}

Field Value

The class.

See Also

ImageBuilder Class
Sitecore.Resources Namespace


Disabled Property

[image]

Sitecore 6.4.1 API
ImageBuilder..::..Disabled Property
ImageBuilder Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Disabled { get; set; }
Visual Basic
Public Property Disabled As Boolean
    Get
    Set
Visual C++
public:
property bool Disabled {
    bool get ();
    void set (bool value);
}

Field Value

true if disabled; otherwise, false.

See Also

ImageBuilder Class
Sitecore.Resources Namespace


Float Property

[image]

Sitecore 6.4.1 API
ImageBuilder..::..Float Property
ImageBuilder Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Float { get; set; }
Visual Basic
Public Property Float As String
    Get
    Set
Visual C++
public:
property String^ Float {
    String^ get ();
    void set (String^ value);
}

Field Value

The float style.

See Also

ImageBuilder Class
Sitecore.Resources Namespace


Height Property

[image]

Sitecore 6.4.1 API
ImageBuilder..::..Height Property
ImageBuilder Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Height { get; set; }
Visual Basic
Public Property Height As Integer
    Get
    Set
Visual C++
public:
property int Height {
    int get ();
    void set (int value);
}

Field Value

The height.

See Also

ImageBuilder Class
Sitecore.Resources Namespace


ID Property

[image]

Sitecore 6.4.1 API
ImageBuilder..::..ID Property
ImageBuilder Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string ID { get; set; }
Visual Basic
Public Property ID As String
    Get
    Set
Visual C++
public:
property String^ ID {
    String^ get ();
    void set (String^ value);
}

Field Value

The ID.

See Also

ImageBuilder Class
Sitecore.Resources Namespace


Margin Property

[image]

Sitecore 6.4.1 API
ImageBuilder..::..Margin Property
ImageBuilder Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Margin { get; set; }
Visual Basic
Public Property Margin As String
    Get
    Set
Visual C++
public:
property String^ Margin {
    String^ get ();
    void set (String^ value);
}

Field Value

The margin.

See Also

ImageBuilder Class
Sitecore.Resources Namespace


OnClick Property

[image]

Sitecore 6.4.1 API
ImageBuilder..::..OnClick Property
ImageBuilder Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string OnClick { get; set; }
Visual Basic
Public Property OnClick As String
    Get
    Set
Visual C++
public:
property String^ OnClick {
    String^ get ();
    void set (String^ value);
}

Field Value

The click event.

See Also

ImageBuilder Class
Sitecore.Resources Namespace


OnContextMenu Property

[image]

Sitecore 6.4.1 API
ImageBuilder..::..OnContextMenu Property
ImageBuilder Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string OnContextMenu { get; set; }
Visual Basic
Public Property OnContextMenu As String
    Get
    Set
Visual C++
public:
property String^ OnContextMenu {
    String^ get ();
    void set (String^ value);
}

Field Value

The on context menu.

See Also

ImageBuilder Class
Sitecore.Resources Namespace


OnDblClick Property

[image]

Sitecore 6.4.1 API
ImageBuilder..::..OnDblClick Property
ImageBuilder Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string OnDblClick { get; set; }
Visual Basic
Public Property OnDblClick As String
    Get
    Set
Visual C++
public:
property String^ OnDblClick {
    String^ get ();
    void set (String^ value);
}

Field Value

The double click event.

See Also

ImageBuilder Class
Sitecore.Resources Namespace


Overlay Property

[image]

Sitecore 6.4.1 API
ImageBuilder..::..Overlay Property
ImageBuilder Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Overlay { get; set; }
Visual Basic
Public Property Overlay As String
    Get
    Set
Visual C++
public:
property String^ Overlay {
    String^ get ();
    void set (String^ value);
}

Field Value

The overlay.

See Also

ImageBuilder Class
Sitecore.Resources Namespace


Resize Property

[image]

Sitecore 6.4.1 API
ImageBuilder..::..Resize Property
ImageBuilder Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool Resize { get; set; }
Visual Basic
Public Property Resize As Boolean
    Get
    Set
Visual C++
public:
property bool Resize {
    bool get ();
    void set (bool value);
}

Field Value

true if resized; otherwise, false.

See Also

ImageBuilder Class
Sitecore.Resources Namespace


RollOver Property

[image]

Sitecore 6.4.1 API
ImageBuilder..::..RollOver Property
ImageBuilder Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool RollOver { get; set; }
Visual Basic
Public Property RollOver As Boolean
    Get
    Set
Visual C++
public:
property bool RollOver {
    bool get ();
    void set (bool value);
}

Field Value

true if the image has a roll over effect; otherwise, false.

See Also

ImageBuilder Class
Sitecore.Resources Namespace


SizeRegex Property

[image]

Sitecore 6.4.1 API
ImageBuilder..::..SizeRegex Property
ImageBuilder Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Regex SizeRegex { get; }
Visual Basic
Public Shared ReadOnly Property SizeRegex As Regex
    Get
Visual C++
public:
static property Regex^ SizeRegex {
    Regex^ get ();
}

Field Value

The size regex.

See Also

ImageBuilder Class
Sitecore.Resources Namespace


Src Property

[image]

Sitecore 6.4.1 API
ImageBuilder..::..Src Property
ImageBuilder Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Src { get; set; }
Visual Basic
Public Property Src As String
    Get
    Set
Visual C++
public:
property String^ Src {
    String^ get ();
    void set (String^ value);
}

Field Value

The source.

See Also

ImageBuilder Class
Sitecore.Resources Namespace


Style Property

[image]

Sitecore 6.4.1 API
ImageBuilder..::..Style Property
ImageBuilder Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Style { get; set; }
Visual Basic
Public Property Style As String
    Get
    Set
Visual C++
public:
property String^ Style {
    String^ get ();
    void set (String^ value);
}

Field Value

The style.

See Also

ImageBuilder Class
Sitecore.Resources Namespace


Title Property

[image]

Sitecore 6.4.1 API
ImageBuilder..::..Title Property
ImageBuilder Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Title { get; set; }
Visual Basic
Public Property Title As String
    Get
    Set
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

Field Value

The title.

See Also

ImageBuilder Class
Sitecore.Resources Namespace


Usemap Property

[image]

Sitecore 6.4.1 API
ImageBuilder..::..Usemap Property
ImageBuilder Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Usemap { get; set; }
Visual Basic
Public Property Usemap As String
    Get
    Set
Visual C++
public:
property String^ Usemap {
    String^ get ();
    void set (String^ value);
}

Field Value

The image map.

See Also

ImageBuilder Class
Sitecore.Resources Namespace


Width Property

[image]

Sitecore 6.4.1 API
ImageBuilder..::..Width Property
ImageBuilder Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public int Width { get; set; }
Visual Basic
Public Property Width As Integer
    Get
    Set
Visual C++
public:
property int Width {
    int get ();
    void set (int value);
}

Field Value

The width.

See Also

ImageBuilder Class
Sitecore.Resources Namespace


Images Class

[image]

Sitecore 6.4.1 API
Images Class
Members See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Images
Visual Basic
Public NotInheritable Class Images
Visual C++
public ref class Images abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Resources..::..Images

See Also

Images Members
Sitecore.Resources Namespace


Images Members

[image] [image]

Sitecore 6.4.1 API
Images Members
Images Class Methods See Also Send Feedback

The Images type exposes the following members.

Methods

Name | Description
GetImage(String, ImageDimension) | Gets an Img tag.
GetImage(String, ImageDimension, String) | Gets an Img tag.
GetImage(String, Int32, Int32) | Gets an Img tag.
GetImage(String, ImageDimension, String, String) | Gets an Img tag.
GetImage(String, Int32, Int32, String) | Gets an Img tag.
GetImage(String, ImageDimension, String, String, String) | Gets an Img tag.
GetImage(String, Int32, Int32, String, String) | Gets an Img tag.
GetImage(String, Int32, Int32, String, String, String) | Gets an Img tag.
GetImage(String, Int32, Int32, String, String, String, String, Boolean) | Gets an Img tag.
GetSpacer(Int32, Int32) | Gets an image HTML tag with a blank image.
GetSpacer(Int32, Int32, Boolean) | Gets an image HTML tag with a blank image.
GetThemedImageSource(String) | Gets a themed image path.
GetThemedImageSource(String, ImageDimension) | Gets a themed image path.
GetThemedImageSource(String, ImageDimension, Boolean) | Gets a themed image path.
GetUncachedImageSrc | Gets the uncached image src.

See Also

Images Class
Sitecore.Resources Namespace


Images Methods

[image] [image]

Sitecore 6.4.1 API
Images Methods
Images Class See Also Send Feedback

The Images type exposes the following members.

Methods

Name | Description
GetImage(String, ImageDimension) | Gets an Img tag.
GetImage(String, ImageDimension, String) | Gets an Img tag.
GetImage(String, Int32, Int32) | Gets an Img tag.
GetImage(String, ImageDimension, String, String) | Gets an Img tag.
GetImage(String, Int32, Int32, String) | Gets an Img tag.
GetImage(String, ImageDimension, String, String, String) | Gets an Img tag.
GetImage(String, Int32, Int32, String, String) | Gets an Img tag.
GetImage(String, Int32, Int32, String, String, String) | Gets an Img tag.
GetImage(String, Int32, Int32, String, String, String, String, Boolean) | Gets an Img tag.
GetSpacer(Int32, Int32) | Gets an image HTML tag with a blank image.
GetSpacer(Int32, Int32, Boolean) | Gets an image HTML tag with a blank image.
GetThemedImageSource(String) | Gets a themed image path.
GetThemedImageSource(String, ImageDimension) | Gets a themed image path.
GetThemedImageSource(String, ImageDimension, Boolean) | Gets a themed image path.
GetUncachedImageSrc | Gets the uncached image src.

See Also

Images Class
Sitecore.Resources Namespace


GetImage Method

[image] [image]

Sitecore 6.4.1 API
Images..::..GetImage Method
Images Class See Also Send Feedback

Overload List

Name | Description
GetImage(String, ImageDimension) | Gets an Img tag.
GetImage(String, ImageDimension, String) | Gets an Img tag.
GetImage(String, Int32, Int32) | Gets an Img tag.
GetImage(String, ImageDimension, String, String) | Gets an Img tag.
GetImage(String, Int32, Int32, String) | Gets an Img tag.
GetImage(String, ImageDimension, String, String, String) | Gets an Img tag.
GetImage(String, Int32, Int32, String, String) | Gets an Img tag.
GetImage(String, Int32, Int32, String, String, String) | Gets an Img tag.
GetImage(String, Int32, Int32, String, String, String, String, Boolean) | Gets an Img tag.

See Also

Images Class
Images Members
Sitecore.Resources Namespace


GetImage Method (String, ImageDimension)

[image]

Sitecore 6.4.1 API
Images..::..GetImage Method (String, ImageDimension)
Images Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetImage(
    string src,
    ImageDimension dimension
)
Visual Basic
Public Shared Function GetImage ( _
    src As String, _
    dimension As ImageDimension _
) As String
Visual C++
public:
static String^ GetImage(
    String^ src,
    ImageDimension dimension
)

Parameters

src
Type: System..::..String
The SRC.
dimension
Type: Sitecore.Web.UI..::..ImageDimension
The dimension.

Return Value

[Missing <returns> documentation for "M:Sitecore.Resources.Images.GetImage(System.String,Sitecore.Web.UI.ImageDimension)"]

See Also

Images Class
GetImage Overload
Sitecore.Resources Namespace


GetImage Method (String, ImageDimension, String)

[image]

Sitecore 6.4.1 API
Images..::..GetImage Method (String, ImageDimension, String)
Images Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetImage(
    string src,
    ImageDimension dimension,
    string align
)
Visual Basic
Public Shared Function GetImage ( _
    src As String, _
    dimension As ImageDimension, _
    align As String _
) As String
Visual C++
public:
static String^ GetImage(
    String^ src,
    ImageDimension dimension,
    String^ align
)

Parameters

src
Type: System..::..String
The SRC.
dimension
Type: Sitecore.Web.UI..::..ImageDimension
The dimension.
align
Type: System..::..String
The align.

Return Value

[Missing <returns> documentation for "M:Sitecore.Resources.Images.GetImage(System.String,Sitecore.Web.UI.ImageDimension,System.String)"]

See Also

Images Class
GetImage Overload
Sitecore.Resources Namespace


GetImage Method (String, Int32, Int32)

[image]

Sitecore 6.4.1 API
Images..::..GetImage Method (String, Int32, Int32)
Images Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetImage(
    string src,
    int width,
    int height
)
Visual Basic
Public Shared Function GetImage ( _
    src As String, _
    width As Integer, _
    height As Integer _
) As String
Visual C++
public:
static String^ GetImage(
    String^ src,
    int width,
    int height
)

Parameters

src
Type: System..::..String
The SRC.
width
Type: System..::..Int32
The width.
height
Type: System..::..Int32
The height.

Return Value

[Missing <returns> documentation for "M:Sitecore.Resources.Images.GetImage(System.String,System.Int32,System.Int32)"]

See Also

Images Class
GetImage Overload
Sitecore.Resources Namespace


GetImage Method (String, ImageDimension, String, String)

[image]

Sitecore 6.4.1 API
Images..::..GetImage Method (String, ImageDimension, String, String)
Images Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetImage(
    string src,
    ImageDimension dimension,
    string align,
    string margin
)
Visual Basic
Public Shared Function GetImage ( _
    src As String, _
    dimension As ImageDimension, _
    align As String, _
    margin As String _
) As String
Visual C++
public:
static String^ GetImage(
    String^ src,
    ImageDimension dimension,
    String^ align,
    String^ margin
)

Parameters

src
Type: System..::..String
The SRC.
dimension
Type: Sitecore.Web.UI..::..ImageDimension
The dimension.
align
Type: System..::..String
The align.
margin
Type: System..::..String
The margin.

Return Value

[Missing <returns> documentation for "M:Sitecore.Resources.Images.GetImage(System.String,Sitecore.Web.UI.ImageDimension,System.String,System.String)"]

See Also

Images Class
GetImage Overload
Sitecore.Resources Namespace


GetImage Method (String, Int32, Int32, String)

[image]

Sitecore 6.4.1 API
Images..::..GetImage Method (String, Int32, Int32, String)
Images Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetImage(
    string src,
    int width,
    int height,
    string align
)
Visual Basic
Public Shared Function GetImage ( _
    src As String, _
    width As Integer, _
    height As Integer, _
    align As String _
) As String
Visual C++
public:
static String^ GetImage(
    String^ src,
    int width,
    int height,
    String^ align
)

Parameters

src
Type: System..::..String
The SRC.
width
Type: System..::..Int32
The width.
height
Type: System..::..Int32
The height.
align
Type: System..::..String
The align.

Return Value

[Missing <returns> documentation for "M:Sitecore.Resources.Images.GetImage(System.String,System.Int32,System.Int32,System.String)"]

See Also

Images Class
GetImage Overload
Sitecore.Resources Namespace


GetImage Method (String, ImageDimension, String, String, String)

[image]

Sitecore 6.4.1 API
Images..::..GetImage Method (String, ImageDimension, String, String, String)
Images Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetImage(
    string src,
    ImageDimension dimension,
    string align,
    string margin,
    string alt
)
Visual Basic
Public Shared Function GetImage ( _
    src As String, _
    dimension As ImageDimension, _
    align As String, _
    margin As String, _
    alt As String _
) As String
Visual C++
public:
static String^ GetImage(
    String^ src,
    ImageDimension dimension,
    String^ align,
    String^ margin,
    String^ alt
)

Parameters

src
Type: System..::..String
The SRC.
dimension
Type: Sitecore.Web.UI..::..ImageDimension
The dimension.
align
Type: System..::..String
The align.
margin
Type: System..::..String
The margin.
alt
Type: System..::..String
The alt.

Return Value

[Missing <returns> documentation for "M:Sitecore.Resources.Images.GetImage(System.String,Sitecore.Web.UI.ImageDimension,System.String,System.String,System.String)"]

See Also

Images Class
GetImage Overload
Sitecore.Resources Namespace


GetImage Method (String, Int32, Int32, String, String)

[image]

Sitecore 6.4.1 API
Images..::..GetImage Method (String, Int32, Int32, String, String)
Images Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetImage(
    string src,
    int width,
    int height,
    string align,
    string margin
)
Visual Basic
Public Shared Function GetImage ( _
    src As String, _
    width As Integer, _
    height As Integer, _
    align As String, _
    margin As String _
) As String
Visual C++
public:
static String^ GetImage(
    String^ src,
    int width,
    int height,
    String^ align,
    String^ margin
)

Parameters

src
Type: System..::..String
The SRC.
width
Type: System..::..Int32
The width.
height
Type: System..::..Int32
The height.
align
Type: System..::..String
The align.
margin
Type: System..::..String
The margin.

Return Value

[Missing <returns> documentation for "M:Sitecore.Resources.Images.GetImage(System.String,System.Int32,System.Int32,System.String,System.String)"]

See Also

Images Class
GetImage Overload
Sitecore.Resources Namespace


GetImage Method (String, Int32, Int32, String, String, String)

[image]

Sitecore 6.4.1 API
Images..::..GetImage Method (String, Int32, Int32, String, String, String)
Images Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetImage(
    string src,
    int width,
    int height,
    string align,
    string margin,
    string alt
)
Visual Basic
Public Shared Function GetImage ( _
    src As String, _
    width As Integer, _
    height As Integer, _
    align As String, _
    margin As String, _
    alt As String _
) As String
Visual C++
public:
static String^ GetImage(
    String^ src,
    int width,
    int height,
    String^ align,
    String^ margin,
    String^ alt
)

Parameters

src
Type: System..::..String
The SRC.
width
Type: System..::..Int32
The width.
height
Type: System..::..Int32
The height.
align
Type: System..::..String
The align.
margin
Type: System..::..String
The margin.
alt
Type: System..::..String
The alt.

Return Value

[Missing <returns> documentation for "M:Sitecore.Resources.Images.GetImage(System.String,System.Int32,System.Int32,System.String,System.String,System.String)"]

See Also

Images Class
GetImage Overload
Sitecore.Resources Namespace


GetImage Method (String, Int32, Int32, String, String, String, String, Boolean)

[image]

Sitecore 6.4.1 API
Images..::..GetImage Method (String, Int32, Int32, String, String, String, String, Boolean)
Images Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetImage(
    string src,
    int width,
    int height,
    string align,
    string margin,
    string alt,
    string id,
    bool resize
)
Visual Basic
Public Shared Function GetImage ( _
    src As String, _
    width As Integer, _
    height As Integer, _
    align As String, _
    margin As String, _
    alt As String, _
    id As String, _
    resize As Boolean _
) As String
Visual C++
public:
static String^ GetImage(
    String^ src,
    int width,
    int height,
    String^ align,
    String^ margin,
    String^ alt,
    String^ id,
    bool resize
)

Parameters

src
Type: System..::..String
The SRC.
width
Type: System..::..Int32
The width.
height
Type: System..::..Int32
The height.
align
Type: System..::..String
The align.
margin
Type: System..::..String
The margin.
alt
Type: System..::..String
The alt.
id
Type: System..::..String
The id.
resize
Type: System..::..Boolean
if set to true the image is resized.

Return Value

[Missing <returns> documentation for "M:Sitecore.Resources.Images.GetImage(System.String,System.Int32,System.Int32,System.String,System.String,System.String,System.String,System.Boolean)"]

See Also

Images Class
GetImage Overload
Sitecore.Resources Namespace


GetSpacer Method

[image] [image]

Sitecore 6.4.1 API
Images..::..GetSpacer Method
Images Class See Also Send Feedback

Overload List

Name | Description
GetSpacer(Int32, Int32) | Gets an image HTML tag with a blank image.
GetSpacer(Int32, Int32, Boolean) | Gets an image HTML tag with a blank image.

See Also

Images Class
Images Members
Sitecore.Resources Namespace


GetSpacer Method (Int32, Int32)

[image]

Sitecore 6.4.1 API
Images..::..GetSpacer Method (Int32, Int32)
Images Class Example See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetSpacer(
    int width,
    int height
)
Visual Basic
Public Shared Function GetSpacer ( _
    width As Integer, _
    height As Integer _
) As String
Visual C++
public:
static String^ GetSpacer(
    int width,
    int height
)

Parameters

width
Type: System..::..Int32
Width of the image.
height
Type: System..::..Int32
Height of the image.

Return Value

The image HTML tag.

Examples

CopyC#
string spacer = Images.GetSpacer(10, 10); // <img src="/sitecore/images/blank.gif" border="0" height="10" width="10">

See Also

Images Class
GetSpacer Overload
Sitecore.Resources Namespace


GetSpacer Method (Int32, Int32, Boolean)

[image]

Sitecore 6.4.1 API
Images..::..GetSpacer Method (Int32, Int32, Boolean)
Images Class Example See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetSpacer(
    int width,
    int height,
    bool verticalCenter
)
Visual Basic
Public Shared Function GetSpacer ( _
    width As Integer, _
    height As Integer, _
    verticalCenter As Boolean _
) As String
Visual C++
public:
static String^ GetSpacer(
    int width,
    int height,
    bool verticalCenter
)

Parameters

width
Type: System..::..Int32
Width of the image.
height
Type: System..::..Int32
Height of the image.
verticalCenter
Type: System..::..Boolean
Indicates if the image is centered vertically.

Return Value

The image HTML tag.

Examples

CopyC#
string spacer = Images.GetSpacer(10, 10, true); // <img src="/sitecore/images/blank.gif" border="0" height="10" width="10" style="vertical-align: middle;">

See Also

Images Class
GetSpacer Overload
Sitecore.Resources Namespace


GetThemedImageSource Method

[image] [image]

Sitecore 6.4.1 API
Images..::..GetThemedImageSource Method
Images Class See Also Send Feedback

Overload List

Name | Description
GetThemedImageSource(String) | Gets a themed image path.
GetThemedImageSource(String, ImageDimension) | Gets a themed image path.
GetThemedImageSource(String, ImageDimension, Boolean) | Gets a themed image path.

See Also

Images Class
Images Members
Sitecore.Resources Namespace


GetThemedImageSource Method (String)

[image]

Sitecore 6.4.1 API
Images..::..GetThemedImageSource Method (String)
Images Class Example See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetThemedImageSource(
    string image
)
Visual Basic
Public Shared Function GetThemedImageSource ( _
    image As String _
) As String
Visual C++
public:
static String^ GetThemedImageSource(
    String^ image
)

Parameters

image
Type: System..::..String
Image file name.

Return Value

A path the the themed image.

Remarks

The function takes in account the current desktop theme.

Examples

CopyC#
string image = MainUtil.GetThemedImageSource("save20x20.png");
// "/sitecore/client/themes/standard/save20x20.png"

See Also

Images Class
GetThemedImageSource Overload
Sitecore.Resources Namespace


GetThemedImageSource Method (String, ImageDimension)

[image]

Sitecore 6.4.1 API
Images..::..GetThemedImageSource Method (String, ImageDimension)
Images Class Example See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetThemedImageSource(
    string image,
    ImageDimension dimension
)
Visual Basic
Public Shared Function GetThemedImageSource ( _
    image As String, _
    dimension As ImageDimension _
) As String
Visual C++
public:
static String^ GetThemedImageSource(
    String^ image,
    ImageDimension dimension
)

Parameters

image
Type: System..::..String
Image file name.
dimension
Type: Sitecore.Web.UI..::..ImageDimension
Dimensions of the image.

Return Value

A path to the themed image.

Remarks

The function takes in account the current desktop theme. If the name of the image contains a size part, the size part is changed according to the dimensions.

Examples

CopyC#
string image = MainUtil.GetThemedImageSource("save20x20.png", ImageDimension.id32x32);
// "/sitecore/client/themes/standard/save32x32.png"

See Also

Images Class
GetThemedImageSource Overload
Sitecore.Resources Namespace


GetThemedImageSource Method (String, ImageDimension, Boolean)

[image]

Sitecore 6.4.1 API
Images..::..GetThemedImageSource Method (String, ImageDimension, Boolean)
Images Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetThemedImageSource(
    string image,
    ImageDimension dimension,
    bool disabled
)
Visual Basic
Public Shared Function GetThemedImageSource ( _
    image As String, _
    dimension As ImageDimension, _
    disabled As Boolean _
) As String
Visual C++
public:
static String^ GetThemedImageSource(
    String^ image,
    ImageDimension dimension,
    bool disabled
)

Parameters

image
Type: System..::..String
Image file name.
dimension
Type: Sitecore.Web.UI..::..ImageDimension
Dimensions of the image.
disabled
Type: System..::..Boolean
if set to true this instance is disabled.

Return Value

A path to the themed image.

Remarks

The function takes in account the current desktop theme. If the name of the image contains a size part, the size part is changed according to the dimensions.

See Also

Images Class
GetThemedImageSource Overload
Sitecore.Resources Namespace


GetUncachedImageSrc Method

[image]

Sitecore 6.4.1 API
Images..::..GetUncachedImageSrc Method
Images Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetUncachedImageSrc(
    string src
)
Visual Basic
Public Shared Function GetUncachedImageSrc ( _
    src As String _
) As String
Visual C++
public:
static String^ GetUncachedImageSrc(
    String^ src
)

Parameters

src
Type: System..::..String
The path.

Return Value

[Missing <returns> documentation for "M:Sitecore.Resources.Images.GetUncachedImageSrc(System.String)"]

Remarks

The source attribute is modified with a timestamp.

See Also

Images Class
Sitecore.Resources Namespace


Resource Class

[image]

Sitecore 6.4.1 API
Resource Class
Members See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class Resource
Visual Basic
Public NotInheritable Class Resource
Visual C++
public ref class Resource abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Resources..::..Resource

See Also

Resource Members
Sitecore.Resources Namespace


Resource Members

[image] [image]

Sitecore 6.4.1 API
Resource Members
Resource Class Methods See Also Send Feedback

The Resource type exposes the following members.

Methods

Name | Description
GetWebControl | Gets the web control.

See Also

Resource Class
Sitecore.Resources Namespace


Resource Methods

[image] [image]

Sitecore 6.4.1 API
Resource Methods
Resource Class See Also Send Feedback

The Resource type exposes the following members.

Methods

Name | Description
GetWebControl | Gets the web control.

See Also

Resource Class
Sitecore.Resources Namespace


GetWebControl Method

[image]

Sitecore 6.4.1 API
Resource..::..GetWebControl Method
Resource Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static Control GetWebControl(
    string name
)
Visual Basic
Public Shared Function GetWebControl ( _
    name As String _
) As Control
Visual C++
public:
static Control^ GetWebControl(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

Return Value

The created web control.

See Also

Resource Class
Sitecore.Resources Namespace


ResourceContext Class

[image]

Sitecore 6.4.1 API
ResourceContext Class
Members See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ResourceContext
Visual Basic
Public Class ResourceContext
Visual C++
public ref class ResourceContext

Inheritance Hierarchy

System..::..Object
Sitecore.Resources..::..ResourceContext

See Also

ResourceContext Members
Sitecore.Resources Namespace


ResourceContext Members

[image] [image]

Sitecore 6.4.1 API
ResourceContext Members
ResourceContext Class Constructors Methods Properties See Also Send Feedback

The ResourceContext type exposes the following members.

Constructors

 | Name | Description
Public method | ResourceContext | Initializes a new instance of the ResourceContext class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Devices | Gets the devices.
Public property | Layouts | Gets the layouts.
Public property | Renderings | Gets the renderings.
Public property | Sublayouts | Gets the sublayouts.

See Also

ResourceContext Class
Sitecore.Resources Namespace


ResourceContext Constructor

[image]

Sitecore 6.4.1 API
ResourceContext Constructor
ResourceContext Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ResourceContext()
Visual Basic
Public Sub New
Visual C++
public:
ResourceContext()

See Also

ResourceContext Class
Sitecore.Resources Namespace


ResourceContext Methods

[image] [image]

Sitecore 6.4.1 API
ResourceContext Methods
ResourceContext Class See Also Send Feedback

The ResourceContext type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ResourceContext Class
Sitecore.Resources Namespace


ResourceContext Properties

[image] [image]

Sitecore 6.4.1 API
ResourceContext Properties
ResourceContext Class See Also Send Feedback

The ResourceContext type exposes the following members.

Properties

 | Name | Description
Public property | Devices | Gets the devices.
Public property | Layouts | Gets the layouts.
Public property | Renderings | Gets the renderings.
Public property | Sublayouts | Gets the sublayouts.

See Also

ResourceContext Class
Sitecore.Resources Namespace


Devices Property

[image]

Sitecore 6.4.1 API
ResourceContext..::..Devices Property
ResourceContext Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DeviceRecords Devices { get; }
Visual Basic
Public ReadOnly Property Devices As DeviceRecords
    Get
Visual C++
public:
property DeviceRecords^ Devices {
    DeviceRecords^ get ();
}

Field Value

The devices.

See Also

ResourceContext Class
Sitecore.Resources Namespace


Layouts Property

[image]

Sitecore 6.4.1 API
ResourceContext..::..Layouts Property
ResourceContext Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LayoutRecords Layouts { get; }
Visual Basic
Public ReadOnly Property Layouts As LayoutRecords
    Get
Visual C++
public:
property LayoutRecords^ Layouts {
    LayoutRecords^ get ();
}

Field Value

The layouts.

See Also

ResourceContext Class
Sitecore.Resources Namespace


Renderings Property

[image]

Sitecore 6.4.1 API
ResourceContext..::..Renderings Property
ResourceContext Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderingRecords Renderings { get; }
Visual Basic
Public ReadOnly Property Renderings As RenderingRecords
    Get
Visual C++
public:
property RenderingRecords^ Renderings {
    RenderingRecords^ get ();
}

Field Value

The renderings.

See Also

ResourceContext Class
Sitecore.Resources Namespace


Sublayouts Property

[image]

Sitecore 6.4.1 API
ResourceContext..::..Sublayouts Property
ResourceContext Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SublayoutRecords Sublayouts { get; }
Visual Basic
Public ReadOnly Property Sublayouts As SublayoutRecords
    Get
Visual C++
public:
property SublayoutRecords^ Sublayouts {
    SublayoutRecords^ get ();
}

Field Value

The sublayouts.

See Also

ResourceContext Class
Sitecore.Resources Namespace


ResourceItems Class

[image]

Sitecore 6.4.1 API
ResourceItems Class
Members See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ResourceItems
Visual Basic
Public Class ResourceItems
Visual C++
public ref class ResourceItems

Inheritance Hierarchy

System..::..Object
Sitecore.Resources..::..ResourceItems

See Also

ResourceItems Members
Sitecore.Resources Namespace


ResourceItems Members

[image] [image]

Sitecore 6.4.1 API
ResourceItems Members
ResourceItems Class Constructors Methods Properties See Also Send Feedback

The ResourceItems type exposes the following members.

Constructors

 | Name | Description
Public method | ResourceItems | Initializes a new instance of the ResourceItems class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Devices | Gets the devices.
Public property | Layouts | Gets the layouts.
Public property | Renderings | Gets the renderings.
Public property | Sublayouts | Gets the sublayouts.

See Also

ResourceItems Class
Sitecore.Resources Namespace


ResourceItems Constructor

[image]

Sitecore 6.4.1 API
ResourceItems Constructor
ResourceItems Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ResourceItems(
    Database database
)
Visual Basic
Public Sub New ( _
    database As Database _
)
Visual C++
public:
ResourceItems(
    Database^ database
)

Parameters

database
Type: Sitecore.Data..::..Database
The database.

See Also

ResourceItems Class
Sitecore.Resources Namespace


ResourceItems Methods

[image] [image]

Sitecore 6.4.1 API
ResourceItems Methods
ResourceItems Class See Also Send Feedback

The ResourceItems type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ResourceItems Class
Sitecore.Resources Namespace


ResourceItems Properties

[image] [image]

Sitecore 6.4.1 API
ResourceItems Properties
ResourceItems Class See Also Send Feedback

The ResourceItems type exposes the following members.

Properties

 | Name | Description
Public property | Devices | Gets the devices.
Public property | Layouts | Gets the layouts.
Public property | Renderings | Gets the renderings.
Public property | Sublayouts | Gets the sublayouts.

See Also

ResourceItems Class
Sitecore.Resources Namespace


Devices Property

[image]

Sitecore 6.4.1 API
ResourceItems..::..Devices Property
ResourceItems Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public DeviceRecords Devices { get; }
Visual Basic
Public ReadOnly Property Devices As DeviceRecords
    Get
Visual C++
public:
property DeviceRecords^ Devices {
    DeviceRecords^ get ();
}

Field Value

The devices.

See Also

ResourceItems Class
Sitecore.Resources Namespace


Layouts Property

[image]

Sitecore 6.4.1 API
ResourceItems..::..Layouts Property
ResourceItems Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public LayoutRecords Layouts { get; }
Visual Basic
Public ReadOnly Property Layouts As LayoutRecords
    Get
Visual C++
public:
property LayoutRecords^ Layouts {
    LayoutRecords^ get ();
}

Field Value

The layouts.

See Also

ResourceItems Class
Sitecore.Resources Namespace


Renderings Property

[image]

Sitecore 6.4.1 API
ResourceItems..::..Renderings Property
ResourceItems Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public RenderingRecords Renderings { get; }
Visual Basic
Public ReadOnly Property Renderings As RenderingRecords
    Get
Visual C++
public:
property RenderingRecords^ Renderings {
    RenderingRecords^ get ();
}

Field Value

The renderings.

See Also

ResourceItems Class
Sitecore.Resources Namespace


Sublayouts Property

[image]

Sitecore 6.4.1 API
ResourceItems..::..Sublayouts Property
ResourceItems Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public SublayoutRecords Sublayouts { get; }
Visual Basic
Public ReadOnly Property Sublayouts As SublayoutRecords
    Get
Visual C++
public:
property SublayoutRecords^ Sublayouts {
    SublayoutRecords^ get ();
}

Field Value

The sublayouts.

See Also

ResourceItems Class
Sitecore.Resources Namespace


ResourceUri Class

[image]

Sitecore 6.4.1 API
ResourceUri Class
Members See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ResourceUri
Visual Basic
Public Class ResourceUri
Visual C++
public ref class ResourceUri

Inheritance Hierarchy

System..::..Object
Sitecore.Resources..::..ResourceUri

See Also

ResourceUri Members
Sitecore.Resources Namespace


ResourceUri Members

[image] [image]

Sitecore 6.4.1 API
ResourceUri Members
ResourceUri Class Constructors Methods Properties See Also Send Feedback

The ResourceUri type exposes the following members.

Constructors

 | Name | Description
Protected method | ResourceUri | Initializes a new instance of the ResourceUri class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Parses the specified URI.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)
Public method | ToUrlString | Converts the Uri to a Url;

Properties

 | Name | Description
Public property | IsControlUri | Gets a value indicating whether this instance is a control URI.
Public property | Uri | Gets the URI.

See Also

ResourceUri Class
Sitecore.Resources Namespace


ResourceUri Constructor

[image]

Sitecore 6.4.1 API
ResourceUri Constructor
ResourceUri Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected ResourceUri(
    string uri
)
Visual Basic
Protected Sub New ( _
    uri As String _
)
Visual C++
protected:
ResourceUri(
    String^ uri
)

Parameters

uri
Type: System..::..String
The path.

See Also

ResourceUri Class
Sitecore.Resources Namespace


ResourceUri Methods

[image] [image]

Sitecore 6.4.1 API
ResourceUri Methods
ResourceUri Class See Also Send Feedback

The ResourceUri type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Parses the specified URI.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)
Public method | ToUrlString | Converts the Uri to a Url;

See Also

ResourceUri Class
Sitecore.Resources Namespace


ToString Method

[image]

Sitecore 6.4.1 API
ResourceUri..::..ToString Method
ResourceUri Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

ResourceUri Class
Sitecore.Resources Namespace


ToUrlString Method

[image]

Sitecore 6.4.1 API
ResourceUri..::..ToUrlString Method
ResourceUri Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public UrlString ToUrlString()
Visual Basic
Public Function ToUrlString As UrlString
Visual C++
public:
UrlString^ ToUrlString()

Return Value

The URL.

See Also

ResourceUri Class
Sitecore.Resources Namespace


ResourceUri Properties

[image] [image]

Sitecore 6.4.1 API
ResourceUri Properties
ResourceUri Class See Also Send Feedback

The ResourceUri type exposes the following members.

Properties

 | Name | Description
Public property | IsControlUri | Gets a value indicating whether this instance is a control URI.
Public property | Uri | Gets the URI.

See Also

ResourceUri Class
Sitecore.Resources Namespace


IsControlUri Property

[image]

Sitecore 6.4.1 API
ResourceUri..::..IsControlUri Property
ResourceUri Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public bool IsControlUri { get; }
Visual Basic
Public ReadOnly Property IsControlUri As Boolean
    Get
Visual C++
public:
property bool IsControlUri {
    bool get ();
}

Field Value

true if this instance is a control URI; otherwise, false.

See Also

ResourceUri Class
Sitecore.Resources Namespace


Uri Property

[image]

Sitecore 6.4.1 API
ResourceUri..::..Uri Property
ResourceUri Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string Uri { get; }
Visual Basic
Public ReadOnly Property Uri As String
    Get
Visual C++
public:
property String^ Uri {
    String^ get ();
}

Field Value

The URI.

See Also

ResourceUri Class
Sitecore.Resources Namespace


Themes Members

[image] [image]

Sitecore 6.4.1 API
Themes Members
Themes Class Methods Properties See Also Send Feedback

The Themes type exposes the following members.

Methods

Name | Description
GetCurrentTheme | Gets the current theme.
MapTheme(String) | Maps a theme path.
MapTheme(String, String, Boolean) | Maps a theme path.

Properties

Name | Description
Current | Gets or sets the current theme.
CurrentPath | Gets the current path.

See Also

Themes Class
Sitecore.Resources Namespace


Themes Methods

[image] [image]

Sitecore 6.4.1 API
Themes Methods
Themes Class See Also Send Feedback

The Themes type exposes the following members.

Methods

Name | Description
GetCurrentTheme | Gets the current theme.
MapTheme(String) | Maps a theme path.
MapTheme(String, String, Boolean) | Maps a theme path.

See Also

Themes Class
Sitecore.Resources Namespace


GetCurrentTheme Method

[image]

Sitecore 6.4.1 API
Themes..::..GetCurrentTheme Method
Themes Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetCurrentTheme()
Visual Basic
Public Shared Function GetCurrentTheme As String
Visual C++
public:
static String^ GetCurrentTheme()

Return Value

Returns the current theme.

See Also

Themes Class
Sitecore.Resources Namespace


MapTheme Method (String)

[image]

Sitecore 6.4.1 API
Themes..::..MapTheme Method (String)
Themes Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string MapTheme(
    string sourcePath
)
Visual Basic
Public Shared Function MapTheme ( _
    sourcePath As String _
) As String
Visual C++
public:
static String^ MapTheme(
    String^ sourcePath
)

Parameters

sourcePath
Type: System..::..String
The source path.

Return Value

The themed path.

See Also

Themes Class
MapTheme Overload
Sitecore.Resources Namespace


MapTheme Method (String, String, Boolean)

[image]

Sitecore 6.4.1 API
Themes..::..MapTheme Method (String, String, Boolean)
Themes Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string MapTheme(
    string sourcePath,
    string overlay,
    bool disabled
)
Visual Basic
Public Shared Function MapTheme ( _
    sourcePath As String, _
    overlay As String, _
    disabled As Boolean _
) As String
Visual C++
public:
static String^ MapTheme(
    String^ sourcePath,
    String^ overlay,
    bool disabled
)

Parameters

sourcePath
Type: System..::..String
The source path.
overlay
Type: System..::..String
The overlay.
disabled
Type: System..::..Boolean
if set to true this instance is disabled.

Return Value

The theme.

See Also

Themes Class
MapTheme Overload
Sitecore.Resources Namespace


Themes Properties

[image] [image]

Sitecore 6.4.1 API
Themes Properties
Themes Class See Also Send Feedback

The Themes type exposes the following members.

Properties

Name | Description
Current | Gets or sets the current theme.
CurrentPath | Gets the current path.

See Also

Themes Class
Sitecore.Resources Namespace


Current Property

[image]

Sitecore 6.4.1 API
Themes..::..Current Property
Themes Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string Current { get; set; }
Visual Basic
Public Shared Property Current As String
    Get
    Set
Visual C++
public:
static property String^ Current {
    String^ get ();
    void set (String^ value);
}

Field Value

The current theme.

See Also

Themes Class
Sitecore.Resources Namespace


CurrentPath Property

[image]

Sitecore 6.4.1 API
Themes..::..CurrentPath Property
Themes Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string CurrentPath { get; }
Visual Basic
Public Shared ReadOnly Property CurrentPath As String
    Get
Visual C++
public:
static property String^ CurrentPath {
    String^ get ();
}

Field Value

The current path.

See Also

Themes Class
Sitecore.Resources Namespace


ZippedIcon Class

[image]

Sitecore 6.4.1 API
ZippedIcon Class
Members See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static class ZippedIcon
Visual Basic
Public NotInheritable Class ZippedIcon
Visual C++
public ref class ZippedIcon abstract sealed

Inheritance Hierarchy

System..::..Object
Sitecore.Resources..::..ZippedIcon

See Also

ZippedIcon Members
Sitecore.Resources Namespace


ZippedIcon Members

[image] [image]

Sitecore 6.4.1 API
ZippedIcon Members
ZippedIcon Class Methods See Also Send Feedback

The ZippedIcon type exposes the following members.

Methods

Name | Description
Extract | Extracts the specified source.
GetFiles | Gets the files.
GetStream | Gets the stream.
GetZipFile | Gets the zip file.
MapZipFile | Maps the zip file.

See Also

ZippedIcon Class
Sitecore.Resources Namespace


ZippedIcon Methods

[image] [image]

Sitecore 6.4.1 API
ZippedIcon Methods
ZippedIcon Class See Also Send Feedback

The ZippedIcon type exposes the following members.

Methods

Name | Description
Extract | Extracts the specified source.
GetFiles | Gets the files.
GetStream | Gets the stream.
GetZipFile | Gets the zip file.
MapZipFile | Maps the zip file.

See Also

ZippedIcon Class
Sitecore.Resources Namespace


Extract Method

[image]

Sitecore 6.4.1 API
ZippedIcon..::..Extract Method
ZippedIcon Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static bool Extract(
    string source,
    string tempFileName,
    string zipFile
)
Visual Basic
Public Shared Function Extract ( _
    source As String, _
    tempFileName As String, _
    zipFile As String _
) As Boolean
Visual C++
public:
static bool Extract(
    String^ source,
    String^ tempFileName,
    String^ zipFile
)

Parameters

source
Type: System..::..String
The source.
tempFileName
Type: System..::..String
Name of the temp file.
zipFile
Type: System..::..String
The zip file.

Return Value

Returns the boolean.

See Also

ZippedIcon Class
Sitecore.Resources Namespace


GetFiles Method

[image]

Sitecore 6.4.1 API
ZippedIcon..::..GetFiles Method
ZippedIcon Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string[] GetFiles(
    string prefix,
    string zipFile
)
Visual Basic
Public Shared Function GetFiles ( _
    prefix As String, _
    zipFile As String _
) As String()
Visual C++
public:
static array<String^>^ GetFiles(
    String^ prefix,
    String^ zipFile
)

Parameters

prefix
Type: System..::..String
The prefix.
zipFile
Type: System..::..String
The zip file.

Return Value

Returns the files.

See Also

ZippedIcon Class
Sitecore.Resources Namespace


GetZipFile Method

[image]

Sitecore 6.4.1 API
ZippedIcon..::..GetZipFile Method
ZippedIcon Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string GetZipFile(
    string relativeIconPath
)
Visual Basic
Public Shared Function GetZipFile ( _
    relativeIconPath As String _
) As String
Visual C++
public:
static String^ GetZipFile(
    String^ relativeIconPath
)

Parameters

relativeIconPath
Type: System..::..String
The relative icon path.

Return Value

Returns the zip file.

See Also

ZippedIcon Class
Sitecore.Resources Namespace


MapZipFile Method

[image]

Sitecore 6.4.1 API
ZippedIcon..::..MapZipFile Method
ZippedIcon Class See Also Send Feedback

Namespace: Sitecore.Resources
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public static string MapZipFile(
    string absoluteIconPath
)
Visual Basic
Public Shared Function MapZipFile ( _
    absoluteIconPath As String _
) As String
Visual C++
public:
static String^ MapZipFile(
    String^ absoluteIconPath
)

Parameters

absoluteIconPath
Type: System..::..String
The source path.

Return Value

Returns the zip file.

See Also

ZippedIcon Class
Sitecore.Resources Namespace


Sitecore.Resources.Media Namespace

[image]

Sitecore 6.4.1 API
Sitecore.Resources.Media Namespace
Send Feedback

Classes

 | Class | Description
Public class | FastMediaCache | Obsolete. FastMediaCache class
Public class | GetMediaStreamPipelineArgs | GetMediaStreamPipelineArgs class
Public class | GrayscaleProcessor | GrayscaleProcessor class
Public class | ImageEffects | ImageEffects class
Public class | ImageEffectsResize | Represents a ImageEffectsResize.
Public class | ImageMedia | ImageMedia class
Public class | ImageThumbnailGenerator | ImageThumbnailCreator class
Public class | ImageValidator | Represents a Media Validator.
Public class | JpegMedia | ImageMedia class
Public class | MacromediaFlash | Parses header of a swf file.
Public class | Media | Media class
Public class | MediaCache | MediaCache class
Public class | MediaCacheRecord | MediaCacheRecord class
Public class | MediaConfig | MediaConfig class
Public class | MediaCreator | MediaCreator class
Public class | MediaCreatorOptions | MediaCreatorOptions class
Public class | MediaData | MediaData class
Public class | MediaHeaders | MediaHeaders class
Public class | MediaManager | MediaManager
Public class | MediaMetaDataCollection | Represents a collection of Media Meta Data.
Public class | MediaMetaDataFormatter | Represents a Media Meta Data Formatter.
Public class | MediaOptions | MediaOutputOptions class
Public class | MediaPathManager | Represents a Media Path.
Public class | MediaPathProvider | Represents a Media Path.
Public class | MediaPathProviderCollection | Collection of MediaPathProvider objects
Public class | MediaProvider | MediaProvider class
Public class | MediaRequest | MediaRequest class
Public class | MediaRequestHandler | MediaRequestHandler class
Public class | MediaStream | MediaStream class
Public class | MediaStreamInfo | MediaStreamInfo class
Public class | MediaThumbnailGenerator | ZipThumbnailCreator class
Public class | MediaTypeConfig | MediaTypeConfig class
Public class | MediaUploader | Represents a MediaUpload.
Public class | MediaUploadResult | Represents a MediaUploadResult.
Public class | MediaUri | MediaUri class
Public class | MediaUrlOptions | Represents a Media Query String.
Public class | MediaValidator | Represents a Media Validator.
Public class | MediaValidatorFormatter | Represents a Media Meta Data Formatter.
Public class | MediaValidatorResult | Represents a collection of Media Meta Data.
Public class | MimeResolver | MimeResolver class
Public class | Mp3Media | ImageMedia class
Public class | ResizeProcessor | ResizeProcessor class
Public class | SwfMedia | SwfMedia class
Public class | ThumbnailCreator | Summary description for ThumbnailCreator.
Public class | ThumbnailGenerator | Represents a Thumbnail Generator.
Public class | ThumbnailProcessor | ThumbnailProcessor class
Public class | TransformationOptions | ImageOptions class
Public class | UploadWatcher | Monitors the /Upload folder for changes for files.
Public class | WebDAVMediaRequest | WebDAV media request.
Public class | WebDAVMediaRequestHandler | WebDAV media request handler class
Public class | ZipMedia | ImageMedia class
Public class | ZipMetaDataFormatter | Represents a Zip Meta Data Formatter.

Enumerations

 | Enumeration | Description
Public enumeration | MediaMetaDataFormatterOutput | Represents the output of a Media Meta Data Formatter.
Public enumeration | MediaValidatorFormatterOutput | Defines the output formatting of a Media Validator Formatter.


FastMediaCache Class

[image]

Sitecore 6.4.1 API
FastMediaCache Class
Members See Also Send Feedback

Namespace: Sitecore.Resources.Media
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[ObsoleteAttribute("Deprecated.")]
public class FastMediaCache
Visual Basic
<ObsoleteAttribute("Deprecated.")> _
Public Class FastMediaCache
Visual C++
[ObsoleteAttribute(L"Deprecated.")]
public ref class FastMediaCache

Inheritance Hierarchy

System..::..Object
Sitecore.Resources.Media..::..FastMediaCache

See Also

FastMediaCache Members
Sitecore.Resources.Media Namespace


FastMediaCache Members

[image] [image]

Sitecore 6.4.1 API
FastMediaCache Members
FastMediaCache Class Constructors Methods Properties See Also Send Feedback

The FastMediaCache type exposes the following members.

Constructors

 | Name | Description
Public method | FastMediaCache | Initializes a new instance of the FastMediaCache class.

Methods

 | Name | Description
Public method | AddFilePath | Add the path of a media file to the cache.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCache | Gets the cache.
Public method | GetFilePath | Gets the path of a cached media file.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | MemoryCacheSize | Gets or sets the size of the memory cache.
Public property | SiteName | Gets or sets the name of the site context to use for default values etc.
Public property | UrlPrefix | Gets the URL prefix that the cache responds to.

See Also

FastMediaCache Class
Sitecore.Resources.Media Namespace


FastMediaCache Constructor

[image]

Sitecore 6.4.1 API
FastMediaCache Constructor
FastMediaCache Class See Also Send Feedback

Namespace: Sitecore.Resources.Media
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public FastMediaCache(
    string urlPrefix,
    string siteName
)
Visual Basic
Public Sub New ( _
    urlPrefix As String, _
    siteName As String _
)
Visual C++
public:
FastMediaCache(
    String^ urlPrefix,
    String^ siteName
)

Parameters

urlPrefix
Type: System..::..String
The URL prefix.
siteName
Type: System..::..String
Name of the site.

See Also

FastMediaCache Class
Sitecore.Resources.Media Namespace


FastMediaCache Methods

[image] [image]

Sitecore 6.4.1 API
FastMediaCache Methods
FastMediaCache Class See Also Send Feedback

The FastMediaCache type exposes the following members.

Methods

 | Name | Description
Public method | AddFilePath | Add the path of a media file to the cache.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCache | Gets the cache.
Public method | GetFilePath | Gets the path of a cached media file.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FastMediaCache Class
Sitecore.Resources.Media Namespace


AddFilePath Method

[image]

Sitecore 6.4.1 API
FastMediaCache..::..AddFilePath Method
FastMediaCache Class See Also Send Feedback

Namespace: Sitecore.Resources.Media
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void AddFilePath(
    HttpContext context,
    string filePath
)
Visual Basic
Public Overridable Sub AddFilePath ( _
    context As HttpContext, _
    filePath As String _
)
Visual C++
public:
virtual void AddFilePath(
    HttpContext^ context,
    String^ filePath
)

Parameters

context
Type: System.Web..::..HttpContext
The context.
filePath
Type: System..::..String
Path of the file.

See Also

FastMediaCache Class
Sitecore.Resources.Media Namespace


GetFilePath Method

[image]

Sitecore 6.4.1 API
FastMediaCache..::..GetFilePath Method
FastMediaCache Class See Also Send Feedback

Namespace: Sitecore.Resources.Media
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string GetFilePath(
    HttpContext context
)
Visual Basic
Public Overridable Function GetFilePath ( _
    context As HttpContext _
) As String
Visual C++
public:
virtual String^ GetFilePath(
    HttpContext^ context
)

Parameters

context
Type: System.Web..::..HttpContext
The context.

Return Value

[Missing <returns> documentation for "M:Sitecore.Resources.Media.FastMediaCache.GetFilePath(System.Web.HttpContext)"]

See Also

FastMediaCache Class
Sitecore.Resources.Media Namespace


FastMediaCache Properties

[image] [image]

Sitecore 6.4.1 API
FastMediaCache Properties
FastMediaCache Class See Also Send Feedback

The FastMediaCache type exposes the following members.

Properties

 | Name | Description
Public property | MemoryCacheSize | Gets or sets the size of the memory cache.
Public property | SiteName | Gets or sets the name of the site context to use for default values etc.
Public property | UrlPrefix | Gets the URL prefix that the cache responds to.

See Also

FastMediaCache Class
Sitecore.Resources.Media Namespace


MemoryCacheSize Property

[image]

Sitecore 6.4.1 API
FastMediaCache..::..MemoryCacheSize Property
FastMediaCache Class See Also Send Feedback

Namespace: Sitecore.Resources.Media
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string MemoryCacheSize { get; set; }
Visual Basic
Public Property MemoryCacheSize As String
    Get
    Set
Visual C++
public:
property String^ MemoryCacheSize {
    String^ get ();
    void set (String^ value);
}

Field Value

The size of the memory cache.

See Also

FastMediaCache Class
Sitecore.Resources.Media Namespace


SiteName Property

[image]

Sitecore 6.4.1 API
FastMediaCache..::..SiteName Property
FastMediaCache Class See Also Send Feedback

Namespace: Sitecore.Resources.Media
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public string SiteName { get; }
Visual Basic
Public ReadOnly Property SiteName As String
    Get
Visual C++
public:
property String^ SiteName {
    String^ get ();
}

Field Value

The site context.

See Also

FastMediaCache Class
Sitecore.Resources.Media Namespace


UrlPrefix Property

[image]

Sitecore 6.4.1 API
FastMediaCache..::..UrlPrefix Property
FastMediaCache Class See Also Send Feedback

Namespace: Sitecore.Resources.Media
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual string UrlPrefix { get; }
Visual Basic
Public Overridable ReadOnly Property UrlPrefix As String
    Get
Visual C++
public:
virtual property String^ UrlPrefix {
    String^ get ();
}

Field Value

The URL prefix.

See Also

FastMediaCache Class
Sitecore.Resources.Media Namespace


GetMediaStreamPipelineArgs Class

[image]

Sitecore 6.4.1 API
GetMediaStreamPipelineArgs Class
Members See Also Send Feedback

Namespace: Sitecore.Resources.Media
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
[SerializableAttribute]
public class GetMediaStreamPipelineArgs : PipelineArgs
Visual Basic
<SerializableAttribute> _
Public Class GetMediaStreamPipelineArgs _
    Inherits PipelineArgs
Visual C++
[SerializableAttribute]
public ref class GetMediaStreamPipelineArgs : public PipelineArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Sitecore.Pipelines..::..PipelineArgs
Sitecore.Resources.Media..::..GetMediaStreamPipelineArgs

See Also

GetMediaStreamPipelineArgs Members
Sitecore.Resources.Media Namespace


GetMediaStreamPipelineArgs Members

[image] [image]

Sitecore 6.4.1 API
GetMediaStreamPipelineArgs Members
GetMediaStreamPipelineArgs Class Constructors Methods Properties See Also Send Feedback

The GetMediaStreamPipelineArgs type exposes the following members.

Constructors

 | Name | Description
Protected method | GetMediaStreamPipelineArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the GetMediaStreamPipelineArgs class.
Public method | GetMediaStreamPipelineArgs(MediaData, MediaOptions) | Initializes a new instance of the GetMediaStreamPipelineArgs class.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | MediaData | Gets or sets the media.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Options | Gets or sets the options.
Public property | OutputStream | Gets or sets the stream.
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

GetMediaStreamPipelineArgs Class
Sitecore.Resources.Media Namespace


GetMediaStreamPipelineArgs Constructor

[image] [image]

Sitecore 6.4.1 API
GetMediaStreamPipelineArgs Constructor
GetMediaStreamPipelineArgs Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetMediaStreamPipelineArgs(SerializationInfo, StreamingContext) | Initializes a new instance of the GetMediaStreamPipelineArgs class.
Public method | GetMediaStreamPipelineArgs(MediaData, MediaOptions) | Initializes a new instance of the GetMediaStreamPipelineArgs class.

See Also

GetMediaStreamPipelineArgs Class
GetMediaStreamPipelineArgs Members
Sitecore.Resources.Media Namespace


GetMediaStreamPipelineArgs Constructor (SerializationInfo, StreamingContext)

[image]

Sitecore 6.4.1 API
GetMediaStreamPipelineArgs Constructor (SerializationInfo, StreamingContext)
GetMediaStreamPipelineArgs Class See Also Send Feedback

Namespace: Sitecore.Resources.Media
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected GetMediaStreamPipelineArgs(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
GetMediaStreamPipelineArgs(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

GetMediaStreamPipelineArgs Class
GetMediaStreamPipelineArgs Overload
Sitecore.Resources.Media Namespace


GetMediaStreamPipelineArgs Constructor (MediaData, MediaOptions)

[image]

Sitecore 6.4.1 API
GetMediaStreamPipelineArgs Constructor (MediaData, MediaOptions)
GetMediaStreamPipelineArgs Class See Also Send Feedback

Namespace: Sitecore.Resources.Media
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GetMediaStreamPipelineArgs(
    MediaData mediaData,
    MediaOptions options
)
Visual Basic
Public Sub New ( _
    mediaData As MediaData, _
    options As MediaOptions _
)
Visual C++
public:
GetMediaStreamPipelineArgs(
    MediaData^ mediaData,
    MediaOptions^ options
)

Parameters

mediaData
Type: Sitecore.Resources.Media..::..MediaData

[Missing <param name="mediaData"/> documentation for "M:Sitecore.Resources.Media.GetMediaStreamPipelineArgs.#ctor(Sitecore.Resources.Media.MediaData,Sitecore.Resources.Media.MediaOptions)"]

options
Type: Sitecore.Resources.Media..::..MediaOptions

[Missing <param name="options"/> documentation for "M:Sitecore.Resources.Media.GetMediaStreamPipelineArgs.#ctor(Sitecore.Resources.Media.MediaData,Sitecore.Resources.Media.MediaOptions)"]

See Also

GetMediaStreamPipelineArgs Class
GetMediaStreamPipelineArgs Overload
Sitecore.Resources.Media Namespace


GetMediaStreamPipelineArgs Methods

[image] [image]

Sitecore 6.4.1 API
GetMediaStreamPipelineArgs Methods
GetMediaStreamPipelineArgs Class See Also Send Feedback

The GetMediaStreamPipelineArgs type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Obsolete. Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AbortPipeline | Aborts this pipeline. (Inherited from PipelineArgs.)
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)
Protected method | Dispose | Disposes this instance. (Inherited from PipelineArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PipelineArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes this instance. (Inherited from PipelineArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessorDone | Called when the processor is done. (Inherited from PipelineArgs.)
Protected method | Resume | Resumes a processor. (Inherited from PipelineArgs.)
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetMediaStreamPipelineArgs Class
Sitecore.Resources.Media Namespace


AddMessage Method

[image] [image]

Sitecore 6.4.1 API
GetMediaStreamPipelineArgs..::..AddMessage Method
GetMediaStreamPipelineArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(String) | Adds the message. (Inherited from PipelineArgs.)
Public method | AddMessage(String, PipelineMessageType) | Adds the message. (Inherited from PipelineArgs.)

See Also

GetMediaStreamPipelineArgs Class
GetMediaStreamPipelineArgs Members
Sitecore.Resources.Media Namespace


GetMessages Method

[image] [image]

Sitecore 6.4.1 API
GetMediaStreamPipelineArgs..::..GetMessages Method
GetMediaStreamPipelineArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMessages()()()() | Gets the messages. (Inherited from PipelineArgs.)
Public method | GetMessages(PipelineMessageFilter) | Gets the messages. (Inherited from PipelineArgs.)

See Also

GetMediaStreamPipelineArgs Class
GetMediaStreamPipelineArgs Members
Sitecore.Resources.Media Namespace


Suspend Method

[image] [image]

Sitecore 6.4.1 API
GetMediaStreamPipelineArgs..::..Suspend Method
GetMediaStreamPipelineArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Suspend()()()() | Suspends this instance. (Inherited from PipelineArgs.)
Public method | Suspend(Boolean) | Suspends the specified resume last processor. (Inherited from PipelineArgs.)

See Also

GetMediaStreamPipelineArgs Class
GetMediaStreamPipelineArgs Members
Sitecore.Resources.Media Namespace


GetMediaStreamPipelineArgs Properties

[image] [image]

Sitecore 6.4.1 API
GetMediaStreamPipelineArgs Properties
GetMediaStreamPipelineArgs Class See Also Send Feedback

The GetMediaStreamPipelineArgs type exposes the following members.

Properties

 | Name | Description
Public property | Aborted | Gets a value indicating whether this PipelineArgs is aborted. (Inherited from PipelineArgs.)
Public property | CustomData | Gets the custom data. (Inherited from PipelineArgs.)
Public property | Data | Obsolete. Gets or sets the data. (Inherited from PipelineArgs.)
Public property | MediaData | Gets or sets the media.
Public property | Message | Gets the message. (Inherited from PipelineArgs.)
Public property | Options | Gets or sets the options.
Public property | OutputStream | Gets or sets the stream.
Public property | ProcessorItem | Gets or sets the processor item. (Inherited from PipelineArgs.)
Public property | Suspended | Gets a value indicating whether this PipelineArgs is suspended. (Inherited from PipelineArgs.)

See Also

GetMediaStreamPipelineArgs Class
Sitecore.Resources.Media Namespace


MediaData Property

[image]

Sitecore 6.4.1 API
GetMediaStreamPipelineArgs..::..MediaData Property
GetMediaStreamPipelineArgs Class See Also Send Feedback

Namespace: Sitecore.Resources.Media
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MediaData MediaData { get; set; }
Visual Basic
Public Property MediaData As MediaData
    Get
    Set
Visual C++
public:
property MediaData^ MediaData {
    MediaData^ get ();
    void set (MediaData^ value);
}

Field Value

The media.

See Also

GetMediaStreamPipelineArgs Class
Sitecore.Resources.Media Namespace


Options Property

[image]

Sitecore 6.4.1 API
GetMediaStreamPipelineArgs..::..Options Property
GetMediaStreamPipelineArgs Class See Also Send Feedback

Namespace: Sitecore.Resources.Media
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MediaOptions Options { get; set; }
Visual Basic
Public Property Options As MediaOptions
    Get
    Set
Visual C++
public:
property MediaOptions^ Options {
    MediaOptions^ get ();
    void set (MediaOptions^ value);
}

Field Value

The options.

See Also

GetMediaStreamPipelineArgs Class
Sitecore.Resources.Media Namespace


OutputStream Property

[image]

Sitecore 6.4.1 API
GetMediaStreamPipelineArgs..::..OutputStream Property
GetMediaStreamPipelineArgs Class See Also Send Feedback

Namespace: Sitecore.Resources.Media
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public MediaStream OutputStream { get; set; }
Visual Basic
Public Property OutputStream As MediaStream
    Get
    Set
Visual C++
public:
property MediaStream^ OutputStream {
    MediaStream^ get ();
    void set (MediaStream^ value);
}

Field Value

The stream.

See Also

GetMediaStreamPipelineArgs Class
Sitecore.Resources.Media Namespace


GrayscaleProcessor Class

[image]

Sitecore 6.4.1 API
GrayscaleProcessor Class
Members See Also Send Feedback

Namespace: Sitecore.Resources.Media
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class GrayscaleProcessor
Visual Basic
Public Class GrayscaleProcessor
Visual C++
public ref class GrayscaleProcessor

Inheritance Hierarchy

System..::..Object
Sitecore.Resources.Media..::..GrayscaleProcessor

See Also

GrayscaleProcessor Members
Sitecore.Resources.Media Namespace


GrayscaleProcessor Members

[image] [image]

Sitecore 6.4.1 API
GrayscaleProcessor Members
GrayscaleProcessor Class Constructors Methods See Also Send Feedback

The GrayscaleProcessor type exposes the following members.

Constructors

 | Name | Description
Public method | GrayscaleProcessor | Initializes a new instance of the GrayscaleProcessor class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process | Runs the processor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GrayscaleProcessor Class
Sitecore.Resources.Media Namespace


GrayscaleProcessor Constructor

[image]

Sitecore 6.4.1 API
GrayscaleProcessor Constructor
GrayscaleProcessor Class See Also Send Feedback

Namespace: Sitecore.Resources.Media
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public GrayscaleProcessor()
Visual Basic
Public Sub New
Visual C++
public:
GrayscaleProcessor()

See Also

GrayscaleProcessor Class
Sitecore.Resources.Media Namespace


Process Method

[image]

Sitecore 6.4.1 API
GrayscaleProcessor..::..Process Method
GrayscaleProcessor Class See Also Send Feedback

Namespace: Sitecore.Resources.Media
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public void Process(
    GetMediaStreamPipelineArgs args
)
Visual Basic
Public Sub Process ( _
    args As GetMediaStreamPipelineArgs _
)
Visual C++
public:
void Process(
    GetMediaStreamPipelineArgs^ args
)

Parameters

args
Type: Sitecore.Resources.Media..::..GetMediaStreamPipelineArgs

[Missing <param name="args"/> documentation for "M:Sitecore.Resources.Media.GrayscaleProcessor.Process(Sitecore.Resources.Media.GetMediaStreamPipelineArgs)"]

See Also

GrayscaleProcessor Class
Sitecore.Resources.Media Namespace


ImageEffects Members

[image] [image]

Sitecore 6.4.1 API
ImageEffects Members
ImageEffects Class Constructors Methods See Also Send Feedback

The ImageEffects type exposes the following members.

Constructors

 | Name | Description
Public method | ImageEffects | Initializes a new instance of the ImageEffects class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformFile | Gets a stream from a file.
Public method | TransformImageStream | Transforms an image stream.

See Also

ImageEffects Class
Sitecore.Resources.Media Namespace


ImageEffects Constructor

[image]

Sitecore 6.4.1 API
ImageEffects Constructor
ImageEffects Class See Also Send Feedback

Namespace: Sitecore.Resources.Media
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ImageEffects()
Visual Basic
Public Sub New
Visual C++
public:
ImageEffects()

See Also

ImageEffects Class
Sitecore.Resources.Media Namespace


ImageEffects Methods

[image] [image]

Sitecore 6.4.1 API
ImageEffects Methods
ImageEffects Class See Also Send Feedback

The ImageEffects type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformFile | Gets a stream from a file.
Public method | TransformImageStream | Transforms an image stream.

See Also

ImageEffects Class
Sitecore.Resources.Media Namespace


TransformFile Method

[image]

Sitecore 6.4.1 API
ImageEffects..::..TransformFile Method
ImageEffects Class See Also Send Feedback

Namespace: Sitecore.Resources.Media
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Stream TransformFile(
    string filePath,
    TransformationOptions options,
    ImageFormat outputFormat
)
Visual Basic
Public Overridable Function TransformFile ( _
    filePath As String, _
    options As TransformationOptions, _
    outputFormat As ImageFormat _
) As Stream
Visual C++
public:
virtual Stream^ TransformFile(
    String^ filePath,
    TransformationOptions^ options,
    ImageFormat^ outputFormat
)

Parameters

filePath
Type: System..::..String
The file path.
options
Type: Sitecore.Resources.Media..::..TransformationOptions
The options.
outputFormat
Type: System.Drawing.Imaging..::..ImageFormat
The output format.

Return Value

The file.

See Also

ImageEffects Class
Sitecore.Resources.Media Namespace


TransformImageStream Method

[image]

Sitecore 6.4.1 API
ImageEffects..::..TransformImageStream Method
ImageEffects Class See Also Send Feedback

Namespace: Sitecore.Resources.Media
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Stream TransformImageStream(
    Stream inputStream,
    TransformationOptions options,
    ImageFormat outputFormat
)
Visual Basic
Public Overridable Function TransformImageStream ( _
    inputStream As Stream, _
    options As TransformationOptions, _
    outputFormat As ImageFormat _
) As Stream
Visual C++
public:
virtual Stream^ TransformImageStream(
    Stream^ inputStream,
    TransformationOptions^ options,
    ImageFormat^ outputFormat
)

Parameters

inputStream
Type: System.IO..::..Stream
The stream containing the media data.
options
Type: Sitecore.Resources.Media..::..TransformationOptions
The image options.
outputFormat
Type: System.Drawing.Imaging..::..ImageFormat
The image format of the resulting thumbnail image.

Return Value

[Missing <returns> documentation for "M:Sitecore.Resources.Media.ImageEffects.TransformImageStream(System.IO.Stream,Sitecore.Resources.Media.TransformationOptions,System.Drawing.Imaging.ImageFormat)"]

See Also

ImageEffects Class
Sitecore.Resources.Media Namespace


ImageEffectsResize Class

[image]

Sitecore 6.4.1 API
ImageEffectsResize Class
Members See Also Send Feedback

Namespace: Sitecore.Resources.Media
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ImageEffectsResize
Visual Basic
Public Class ImageEffectsResize
Visual C++
public ref class ImageEffectsResize

Inheritance Hierarchy

System..::..Object
Sitecore.Resources.Media..::..ImageEffectsResize

See Also

ImageEffectsResize Members
Sitecore.Resources.Media Namespace


ImageEffectsResize Members

[image] [image]

Sitecore 6.4.1 API
ImageEffectsResize Members
ImageEffectsResize Class Constructors Methods See Also Send Feedback

The ImageEffectsResize type exposes the following members.

Constructors

 | Name | Description
Public method | ImageEffectsResize | Initializes a new instance of the ImageEffectsResize class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResizeImageStream | Resizes an image represented by a stream.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ImageEffectsResize Class
Sitecore.Resources.Media Namespace


ImageEffectsResize Constructor

[image]

Sitecore 6.4.1 API
ImageEffectsResize Constructor
ImageEffectsResize Class See Also Send Feedback

Namespace: Sitecore.Resources.Media
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ImageEffectsResize()
Visual Basic
Public Sub New
Visual C++
public:
ImageEffectsResize()

See Also

ImageEffectsResize Class
Sitecore.Resources.Media Namespace


ImageEffectsResize Methods

[image] [image]

Sitecore 6.4.1 API
ImageEffectsResize Methods
ImageEffectsResize Class See Also Send Feedback

The ImageEffectsResize type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResizeImageStream | Resizes an image represented by a stream.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ImageEffectsResize Class
Sitecore.Resources.Media Namespace


ResizeImageStream Method

[image]

Sitecore 6.4.1 API
ImageEffectsResize..::..ResizeImageStream Method
ImageEffectsResize Class See Also Send Feedback

Namespace: Sitecore.Resources.Media
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public Stream ResizeImageStream(
    Stream inputStream,
    TransformationOptions options,
    ImageFormat outputFormat
)
Visual Basic
Public Function ResizeImageStream ( _
    inputStream As Stream, _
    options As TransformationOptions, _
    outputFormat As ImageFormat _
) As Stream
Visual C++
public:
Stream^ ResizeImageStream(
    Stream^ inputStream,
    TransformationOptions^ options,
    ImageFormat^ outputFormat
)

Parameters

inputStream
Type: System.IO..::..Stream
The input stream.
options
Type: Sitecore.Resources.Media..::..TransformationOptions
The options.
outputFormat
Type: System.Drawing.Imaging..::..ImageFormat
The output format.

Return Value

The image stream.

See Also

ImageEffectsResize Class
Sitecore.Resources.Media Namespace


ImageMedia Class

[image]

Sitecore 6.4.1 API
ImageMedia Class
Members See Also Send Feedback

Namespace: Sitecore.Resources.Media
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ImageMedia : Media
Visual Basic
Public Class ImageMedia _
    Inherits Media
Visual C++
public ref class ImageMedia : public Media

Inheritance Hierarchy

System..::..Object
Sitecore.Resources.Media..::..Media
Sitecore.Resources.Media..::..ImageMedia
Sitecore.Resources.Media..::..JpegMedia

See Also

ImageMedia Members
Sitecore.Resources.Media Namespace


ImageMedia Members

[image] [image]

Sitecore 6.4.1 API
ImageMedia Members
ImageMedia Class Constructors Methods Properties See Also Send Feedback

The ImageMedia type exposes the following members.

Constructors

 | Name | Description
Public method | ImageMedia | Initializes a new instance of the ImageMedia class

Methods

 | Name | Description
Protected method | AddMetaData | Adds the meta data to the collection. (Inherited from Media.)
Protected method | ClearFields | Clears the specified fields in the inner item. (Inherited from Media.)
Protected method | ClearMetaData | Clears the meta data of a media item. (Overrides Media..::..ClearMetaData()()()().)
Public method | Clone | Clones the source object. Has the same effect as creating a new instance of the type. (Overrides Media..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetImage | Gets the media data as an image.
Protected method | GetImageStream | Gets a stream of the data contained in an image.
Public method | GetMetaData | Gets the meta data. (Inherited from Media.)
Public method | GetStream()()()() | Opens the stream associated with the media. (Inherited from Media.)
Public method | GetStream(MediaOptions) | Opens the stream associated with the media. (Inherited from Media.)
Protected method | GetStreamFromPipeline(MediaOptions) | Gets the stream from the pipeline 'getMediaStream'. (Inherited from Media.)
Protected method | GetStreamFromPipeline(MediaOptions, Boolean%) | Gets the stream from the pipeline 'getMediaStream'. (Inherited from Media.)
Public method | GetThumbnailStream | Gets a thumbnail for the media. (Inherited from Media.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this instance. Used after cloning. (Inherited from Media.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReleaseStream | Releases the stream. (Inherited from Media.)
Public method | SetImage | Sets the media data from an image.
Public method | SetStream(MediaStream) | Opens the stream associated with the media. (Inherited from Media.)
Public method | SetStream(Stream, String) | Sets the stream. (Inherited from Media.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateMetaData | Updates the meta data of a media item. (Overrides Media..::..UpdateMetaData(MediaStream).)

Properties

 | Name | Description
Public property | Extension | Gets the file extension of the media. (Inherited from Media.)
Public property | MediaData | Gets the media data. (Inherited from Media.)
Public property | MimeType | Gets the MIME type of the media. (Inherited from Media.)

See Also

ImageMedia Class
Sitecore.Resources.Media Namespace


ImageMedia Constructor

[image]

Sitecore 6.4.1 API
ImageMedia Constructor
ImageMedia Class See Also Send Feedback

Namespace: Sitecore.Resources.Media
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ImageMedia()
Visual Basic
Public Sub New
Visual C++
public:
ImageMedia()

See Also

ImageMedia Class
Sitecore.Resources.Media Namespace


ImageMedia Methods

[image] [image]

Sitecore 6.4.1 API
ImageMedia Methods
ImageMedia Class See Also Send Feedback

The ImageMedia type exposes the following members.

Methods

 | Name | Description
Protected method | AddMetaData | Adds the meta data to the collection. (Inherited from Media.)
Protected method | ClearFields | Clears the specified fields in the inner item. (Inherited from Media.)
Protected method | ClearMetaData | Clears the meta data of a media item. (Overrides Media..::..ClearMetaData()()()().)
Public method | Clone | Clones the source object. Has the same effect as creating a new instance of the type. (Overrides Media..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetImage | Gets the media data as an image.
Protected method | GetImageStream | Gets a stream of the data contained in an image.
Public method | GetMetaData | Gets the meta data. (Inherited from Media.)
Public method | GetStream()()()() | Opens the stream associated with the media. (Inherited from Media.)
Public method | GetStream(MediaOptions) | Opens the stream associated with the media. (Inherited from Media.)
Protected method | GetStreamFromPipeline(MediaOptions) | Gets the stream from the pipeline 'getMediaStream'. (Inherited from Media.)
Protected method | GetStreamFromPipeline(MediaOptions, Boolean%) | Gets the stream from the pipeline 'getMediaStream'. (Inherited from Media.)
Public method | GetThumbnailStream | Gets a thumbnail for the media. (Inherited from Media.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this instance. Used after cloning. (Inherited from Media.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReleaseStream | Releases the stream. (Inherited from Media.)
Public method | SetImage | Sets the media data from an image.
Public method | SetStream(MediaStream) | Opens the stream associated with the media. (Inherited from Media.)
Public method | SetStream(Stream, String) | Sets the stream. (Inherited from Media.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateMetaData | Updates the meta data of a media item. (Overrides Media..::..UpdateMetaData(MediaStream).)

See Also

ImageMedia Class
Sitecore.Resources.Media Namespace


ClearMetaData Method

[image]

Sitecore 6.4.1 API
ImageMedia..::..ClearMetaData Method
ImageMedia Class See Also Send Feedback

Namespace: Sitecore.Resources.Media
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected override void ClearMetaData()
Visual Basic
Protected Overrides Sub ClearMetaData
Visual C++
protected:
virtual void ClearMetaData() override

See Also

ImageMedia Class
Sitecore.Resources.Media Namespace


Clone Method

[image]

Sitecore 6.4.1 API
ImageMedia..::..Clone Method
ImageMedia Class See Also Send Feedback

Namespace: Sitecore.Resources.Media
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override Media Clone()
Visual Basic
Public Overrides Function Clone As Media
Visual C++
public:
virtual Media^ Clone() override

Return Value

[Missing <returns> documentation for "M:Sitecore.Resources.Media.ImageMedia.Clone"]

Implements

IPrototype<(Of <(<'TObjectType>)>)>..::..Clone()()()()

See Also

ImageMedia Class
Sitecore.Resources.Media Namespace


GetImage Method

[image]

Sitecore 6.4.1 API
ImageMedia..::..GetImage Method
ImageMedia Class See Also Send Feedback

Namespace: Sitecore.Resources.Media
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual Image GetImage()
Visual Basic
Public Overridable Function GetImage As Image
Visual C++
public:
virtual Image^ GetImage()

Return Value

[Missing <returns> documentation for "M:Sitecore.Resources.Media.ImageMedia.GetImage"]

See Also

ImageMedia Class
Sitecore.Resources.Media Namespace


GetImageStream Method

[image]

Sitecore 6.4.1 API
ImageMedia..::..GetImageStream Method
ImageMedia Class See Also Send Feedback

Namespace: Sitecore.Resources.Media
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
protected virtual MediaStream GetImageStream(
    Image image
)
Visual Basic
Protected Overridable Function GetImageStream ( _
    image As Image _
) As MediaStream
Visual C++
protected:
virtual MediaStream^ GetImageStream(
    Image^ image
)

Parameters

image
Type: System.Drawing..::..Image
The image.

Return Value

[Missing <returns> documentation for "M:Sitecore.Resources.Media.ImageMedia.GetImageStream(System.Drawing.Image)"]

See Also

ImageMedia Class
Sitecore.Resources.Media Namespace


GetStream Method

[image] [image]

Sitecore 6.4.1 API
ImageMedia..::..GetStream Method
ImageMedia Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetStream()()()() | Opens the stream associated with the media. (Inherited from Media.)
Public method | GetStream(MediaOptions) | Opens the stream associated with the media. (Inherited from Media.)

See Also

ImageMedia Class
ImageMedia Members
Sitecore.Resources.Media Namespace


GetStreamFromPipeline Method

[image] [image]

Sitecore 6.4.1 API
ImageMedia..::..GetStreamFromPipeline Method
ImageMedia Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetStreamFromPipeline(MediaOptions) | Gets the stream from the pipeline 'getMediaStream'. (Inherited from Media.)
Protected method | GetStreamFromPipeline(MediaOptions, Boolean%) | Gets the stream from the pipeline 'getMediaStream'. (Inherited from Media.)

See Also

ImageMedia Class
ImageMedia Members
Sitecore.Resources.Media Namespace


SetImage Method

[image]

Sitecore 6.4.1 API
ImageMedia..::..SetImage Method
ImageMedia Class See Also Send Feedback

Namespace: Sitecore.Resources.Media
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public virtual void SetImage(
    Image image
)
Visual Basic
Public Overridable Sub SetImage ( _
    image As Image _
)
Visual C++
public:
virtual void SetImage(
    Image^ image
)

Parameters

image
Type: System.Drawing..::..Image
The image.

See Also

ImageMedia Class
Sitecore.Resources.Media Namespace


UpdateMetaData Method

[image]

Sitecore 6.4.1 API
ImageMedia..::..UpdateMetaData Method
ImageMedia Class See Also Send Feedback

Namespace: Sitecore.Resources.Media
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override void UpdateMetaData(
    MediaStream mediaStream
)
Visual Basic
Public Overrides Sub UpdateMetaData ( _
    mediaStream As MediaStream _
)
Visual C++
public:
virtual void UpdateMetaData(
    MediaStream^ mediaStream
) override

Parameters

mediaStream
Type: Sitecore.Resources.Media..::..MediaStream

[Missing <param name="mediaStream"/> documentation for "M:Sitecore.Resources.Media.ImageMedia.UpdateMetaData(Sitecore.Resources.Media.MediaStream)"]

See Also

ImageMedia Class
Sitecore.Resources.Media Namespace


ImageMedia Properties

[image] [image]

Sitecore 6.4.1 API
ImageMedia Properties
ImageMedia Class See Also Send Feedback

The ImageMedia type exposes the following members.

Properties

 | Name | Description
Public property | Extension | Gets the file extension of the media. (Inherited from Media.)
Public property | MediaData | Gets the media data. (Inherited from Media.)
Public property | MimeType | Gets the MIME type of the media. (Inherited from Media.)

See Also

ImageMedia Class
Sitecore.Resources.Media Namespace


ImageThumbnailGenerator Class

[image]

Sitecore 6.4.1 API
ImageThumbnailGenerator Class
Members See Also Send Feedback

Namespace: Sitecore.Resources.Media
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public class ImageThumbnailGenerator : ThumbnailGenerator
Visual Basic
Public Class ImageThumbnailGenerator _
    Inherits ThumbnailGenerator
Visual C++
public ref class ImageThumbnailGenerator : public ThumbnailGenerator

Inheritance Hierarchy

System..::..Object
Sitecore.Resources.Media..::..ThumbnailGenerator
Sitecore.Resources.Media..::..ImageThumbnailGenerator

See Also

ImageThumbnailGenerator Members
Sitecore.Resources.Media Namespace


ImageThumbnailGenerator Members

[image] [image]

Sitecore 6.4.1 API
ImageThumbnailGenerator Members
ImageThumbnailGenerator Class Constructors Methods Properties See Also Send Feedback

The ImageThumbnailGenerator type exposes the following members.

Constructors

 | Name | Description
Public method | ImageThumbnailGenerator | Initializes a new instance of the ImageThumbnailGenerator class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetFileStream | Gets a stream from a file. (Inherited from ThumbnailGenerator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetImageFormat | Gets the image format to use for generating streams. (Inherited from ThumbnailGenerator.)
Protected method | GetImageStream | Gets a stream from an image stream. (Inherited from ThumbnailGenerator.)
Public method | GetStream | Gets the stream of the thumbnail image. (Overrides ThumbnailGenerator..::..GetStream(MediaData, TransformationOptions).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Extension | Gets or sets the file extension describing the format of the thumbnail. (Inherited from ThumbnailGenerator.)
Public property | MimeType | Gets the MIME type of the generated thumbnails. (Inherited from ThumbnailGenerator.)

See Also

ImageThumbnailGenerator Class
Sitecore.Resources.Media Namespace


ImageThumbnailGenerator Constructor

[image]

Sitecore 6.4.1 API
ImageThumbnailGenerator Constructor
ImageThumbnailGenerator Class See Also Send Feedback

Namespace: Sitecore.Resources.Media
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public ImageThumbnailGenerator()
Visual Basic
Public Sub New
Visual C++
public:
ImageThumbnailGenerator()

See Also

ImageThumbnailGenerator Class
Sitecore.Resources.Media Namespace


ImageThumbnailGenerator Methods

[image] [image]

Sitecore 6.4.1 API
ImageThumbnailGenerator Methods
ImageThumbnailGenerator Class See Also Send Feedback

The ImageThumbnailGenerator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetFileStream | Gets a stream from a file. (Inherited from ThumbnailGenerator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetImageFormat | Gets the image format to use for generating streams. (Inherited from ThumbnailGenerator.)
Protected method | GetImageStream | Gets a stream from an image stream. (Inherited from ThumbnailGenerator.)
Public method | GetStream | Gets the stream of the thumbnail image. (Overrides ThumbnailGenerator..::..GetStream(MediaData, TransformationOptions).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ImageThumbnailGenerator Class
Sitecore.Resources.Media Namespace


GetStream Method

[image]

Sitecore 6.4.1 API
ImageThumbnailGenerator..::..GetStream Method
ImageThumbnailGenerator Class See Also Send Feedback

Namespace: Sitecore.Resources.Media
Assembly: Sitecore.Kernel (in Sitecore.Kernel.dll) Version: 6.0.0.0 (6.4.1.3732)

Syntax

C#
public override MediaStream GetStream(
    MediaData mediaData,
    TransformationOptions options
)
Visual Basic
Public Overrides Function GetStream ( _
    mediaData As MediaData, _
    options As TransformationOptions _
) As MediaStream
Visual C++
public:
virtual MediaStream^ GetStream(
    MediaData^ mediaData,
    TransformationOptions^ options
) override

Parameters

mediaData
Type: Sitecore.Resources.Media..::..MediaData
The media data to generate a thumbnail for.
options
Type: Sitecore.Resources.Media..::..TransformationOptions

[Missing <param name="options"/> documentation for "M:Sitecore.Resources.Media.ImageThumbnailGenerator.GetStream(Sitecore.Resources.Media.MediaData,Sitecore.Resources.Media.TransformationOptions)"]

Return Value

[Missing <returns> documentation for "M:Sitecore.Resources.Media.ImageThumbnailGenerator.GetStream(Sitecore.Resources.Media.MediaData,Sitecore.Resources.Media.TransformationOptions)"]

See Also

ImageThumbnailGenerator Class
Sitecore.Resources.Media Namespace


ImageThumbnailGenerator Properties

[image] [image]

Sitecore 6.4.1 API
ImageThumbnailGenerator Properties
ImageThumbnailGenerator Class See Also Send Feedback

The ImageThumbnailGenerator type exposes the following members.

Properties

 | Name | Description
Public property | Extension | Gets or sets the file extension describing the format of the thumbnail. (Inherited from ThumbnailGenerator.)
Public property | MimeType | Gets the MIME type of the generated thumbnails. (Inherited from ThumbnailGenerator.)

See Also

ImageThumbnailGenerator Class
Sitecore.Resources.Media Namespace


ImageValidator Members

[image] [image]

Sitecore 6.4.1 API
ImageValidator Members
ImageValidator Class Constructors Methods See Also Send Feedback

The ImageValidator type exposes the following members.

Constructors

 | Name | Description
Public method | ImageValidator | Initializes a new instance of the ImageValidator class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Validate | Validates the specified item. (Inherited from MediaValidator.)
Protected method | ValidateItem | Validates the specified output. (Overrides MediaValidator..::..ValidateItem(MediaItem, MediaValidatorResult).)

See Also

ImageValidator Class
Sitecore.Resources.Media Namespace